Erste Schritte mit Microsoft Access 2000

Abhängig von Ihrem Erfahrungshintergrund gibt es unterschiedliche Möglichkeiten, erste Schritte mit Microsoft Access 2000 zu unternehmen.

Welche Aussage beschreibt am ehesten Ihren Erfahrungshintergrund?

Ich stelle von einer früheren Version von Microsoft Access auf Microsoft Access 2000 um.

Ich bin vertraut mit anderen Datenbank- oder Tabellenkalkulationsprogrammen.

Ich arbeite zum ersten Mal mit einer Datenbank.


Was ist neu am Datenbankfenster?

Das Datenbankfenster in Microsoft Access 2000 unterstützt eine Vielzahl neuer Optionen zum Anzeigen und Bearbeiten von Datenbankobjekten.

  • Verwenden der Objektsymbolleiste im Datenbankfenster Hier finden Sie zügig Befehle zum Erstellen, Öffnen und Verwalten von Datenbankobjekten.

  • Verwenden der Objektsymbolleiste Anzeigen von Objekten in der Objektsymbolleiste - einfachere Verwendung durch die vertikale Ausrichtung.

  • Organisieren von Datenbankobjekten in Gruppen Klicken Sie auf die Gruppensymbolleiste, um Ihre Gruppen anzuzeigen. Diese können Verknüpfungen zu Datenbankobjekten unterschiedlicher Typen enthalten.

  • Verwenden neuer Objektverknüpfungen Im Datenbankfenster können Sie schnell neue Datenbankobjekte mit Hilfe eines Assistenten erstellen oder ein neues Datenbankobjekt in der Entwurfsansicht öffnen.

  • Festlegen, wie Objekte im Datenbankfenster ausgewählt und geöffnet werden sollen Auf Wunsch können Sie das voreingestellte Verhalten ändern. Auf diese Weise können Sie Datenbanken öffnen, indem Sie den Mauszeiger darauf bewegen, oder Objekte durch einzelnes Klicken öffnen.

  • Auswählen von Objekten durch Eingeben des Namens Beispielsweise können Sie, während Sie die Liste der Tabellenobjekte anzeigen, die Tabelle Versandfirmen auswählen, indem Sie einfach Ve eingeben.


 Was ist neu beim Arbeiten mit Daten und Entwerfen von Datenbanken?

Was ist neu beim Arbeiten mit Daten und Entwerfen von Datenbanken?

Microsoft Access 2000 bietet viele neue Features, die das Arbeiten mit Daten und das Entwerfen von Datenbanken noch einfacher machen.

  • Verwenden der Sperrung auf Datensatzebene Microsoft Access-Datenbanken unterstützen jetzt zusätzlich zur Sperrung auf Seitenebene (bei der alle Datensätze auf einer Seite gesperrt werden) auch die Sperrung auf Datensatzebene. Sie aktivieren die Sperrungsebene mit der neuen Option DB mit Sperrung auf Datensatzebene öffnen (Menü Extras, Befehl Optionen, Registerkarte Weitere). Welche Ebene verwendet wird, hängt von der Programmierung der Access-Datenbank ab.

  • Suchen und Ersetzen Sie können sich jetzt frei zwischen den Dialogfeldern Suchen und Ersetzen sowie den Daten in der Sicht oder dem Fenster bewegen.

  • Anzeigen zusammengehöriger Daten in Unterdatenblättern Sie können ein Unterdatenblatt verwenden, um verwandte oder verknüpfte Daten im Datenblatt einer Tabelle, einer Abfrage bzw. eines Formulars oder in einem Unterformular anzuzeigen oder zu bearbeiten, jeweils in der gleichen Ansicht. Die Tabelle Lieferanten in der Beispieldatenbank Nordwind beispielsweise besitzt eine 1:n-Beziehung mit der Tabelle Artikel. Somit können Sie für jede Zeile in der Tabelle Lieferanten in der Datenblattansicht die verwandten Zeilen der Tabelle Artikel in einem Unterdatenblatt anzeigen und bearbeiten.

  • Automatische Korrektur von durch das Umbenennen von Feldern verursachten Fehlern Objektnamen-Autokorrektur korrigiert automatisch übliche Nebenwirkungen, die durch das Umbenennen von Formularen, Berichten, Tabellen, Abfragen, Feldern, Textfeldern oder anderen Steuerelementen ausgelöst werden.

  • Vorteile durch Unicode-Unterstützung Sie können in Ihren Daten die Schriftzeichen jeder Sprache verwenden, die Unicode unterstützt. Mit der Unicode-Kompression können Sie die Auswirkungen der erhöhten Speicherplatzanforderungen von Unicode ausgleichen. Nutzen Sie auch die Ersatzschriftartunterstützung - geben Sie eine Ersatzschriftart an, die zusätzlich zu Ihrer Standardschriftart verwendet werden soll, damit sämtliche Zeichen in Ihren Daten korrekt dargestellt werden.

  • Verwenden des Euro-Symbols Um Eurobeträge bequem zusammen mit anderen Währungen anzuzeigen, können Sie die Euro-Einstellung ( [image] #,###.##) der Format-Eigenschaft verwenden. Alternativ können Sie das Euro-Symbol ( [image]) eingeben, indem Sie im numerischen Tastenblock bei gedrückter NUM-Taste ALT+0128 eingeben. Beim Einfügen oder Importieren von Daten, in denen das Euro-Symbol ( [image]) enthalten ist, aus Microsoft Excel 2000 in Microsoft Access, speichert Access das Euro-Symbol unabhängig von dem in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Währungssymbol. Schließlich können Sie die EuroConvert-Funktion dazu verwenden, einzelne Währungen in andere zu konvertieren, indem sie den Euro als Zwischenwert benutzen. Weitere Infos über Verwenden des Euro-Symbols.

  • Ausdrucken von Beziehungen Drucken Sie einen Bericht mit allen Beziehungen Ihrer Access-Datenbank, so wie sie im Fenster Beziehungen angezeigt werden.

  • Verwalten von Beziehungen mittels der Tastatur Beziehungen und Verknüpfungen können Sie auch über die Tastatur erstellen, bearbeiten oder löschen.

  • Verwendung von Microsoft ActiveX Data Objects (ADO) Mit Microsoft ActiveX Data Objects (ADO) können Sie auf Daten in einem Datenbankserver über beliebige OLE DB-Anbieter zugreifen und sie bearbeiten.


Was ist neu bei Formularen und Berichten?

Microsoft Access 2000 bietet neue Features, mit denen Sie noch schneller und einfacher professionell aussehende Formulare und Berichte gestalten können.

  • Gruppieren von Textfeldern und anderen Steuerelementen Verwenden Sie den Befehl Gruppieren im Menü Format, um zusammengehörige Textfelder oder andere Steuerelemente in einem Formular oder Bericht zu gruppieren.

  • Definieren von Regeln zur bedingten Formatierung für Textfelder und andere Steuerelemente Mit dem Befehl Bedingte Formatierung im Menü Format können Sie die Schriftfarbe, Schriftgröße, Hintergrundfarbe und andere visuelle Informationen definieren, die eine Reaktion auf Benutzereingaben in Formulare signalisieren.

  • Erstellen von Formularen und Berichten für SQL Server-Datenbanken In Microsoft Access-Projekten können Sie Formulare und Berichte für SQL Server-Datenbanken mit den gleichen Tools erstellen, die Sie auch in Microsoft Access-Datenbanken zur Erstellung verwenden.

  • Verteilen von Berichten an Benutzer, die nicht über Microsoft Access verfügen Microsoft Access-Berichte können Sie in das Snapshot-Dateiformat (.snp) für Berichte exportieren. Mit dem Snapshot Viewer können Sie Berichts-Snapshots anzeigen, ausdrucken und als E-Mail-Nachricht versenden.


Was ist neu bei Datenzugriffsseiten?

Eine Datenzugriffsseite ist eine Webseite, mit der Sie in einer Microsoft Access-Datenbank oder einer SQL Server-Datenbank neue Daten hinzufügen oder vorhandene Daten bearbeiten, anzeigen oder ändern können. Sie können Seiten für die Eingabe und Bearbeitung von Daten erstellen, ähnlich wie Access-Formulare. Außerdem können Sie Seiten erstellen, die Datensätze hierarchisch gruppiert anzeigen, ähnlich wie Access-Berichte.

  • Sammeln und Verteilen von Daten auf verschiedenen Wegen Mit Hilfe der Seiten können Sie innerhalb einer Microsoft Access-Datenbank oder eines Microsoft Access-Projekts Daten hinzufügen, bearbeiten und anzeigen. Sie können sie im Internet oder in einem Intranet verwenden und auch per E-Mail verschicken.

  • Interaktives Anzeigen gruppierter Datensätze In gruppierten Seiten können Sie exakt die Informationen anzeigen, die Sie benötigen, indem Sie die Gruppenköpfe erweitern oder ausblenden. Darüber hinaus können Sie Einträge filtern und sortieren.

  • Analysieren von Daten und Erstellen von Projektionen Mit PivotTable-Listen können Sie Ihre Daten auf unterschiedlichste Weise organisieren, mit einem Tabellen-Steuerelement Projektionen und komplexe Berechnungen erstellen und mit einem Diagramm Daten grafisch anzeigen.

  • Anzeigen von HTML-Text Sie können HTML-Code in Feldern Ihrer Datenbank speichern und als formatierten HTML-Text auf der Seite anzeigen. Wenn ein Wert in einem Feld beispielsweise das HTML-Tag enthält, das Text kursiv formatiert (<I>Text</I>) können Sie auf der Seite ein gebundenes HTML-Steuerelement verwenden, um den Wert in kursiver Schrift anzuzeigen.

  • Verwendung vertrauter Entwurfstools Beim Erstellen von Seiten in der Entwurfsansicht arbeiten Sie mit Symbolleisten, der Toolbox, Designs und anderen Features, die den Tools zur Erstellung von Formularen und Berichten sehr ähnlich sind.


Was ist neu an Symbolleisten, Menüleisten und Kontextmenüs?

Mit den Symbolleisten, Menüleisten und Kontextmenüs in Microsoft Access 2000 können Sie Befehle ganz nach Ihren Wünschen anordnen, um sie schnell finden und anwenden zu können.

  • Verwendung personalierter Menüs und Symbolleisten Sie können Menüs so erweitern, dass sie alle Befehle anzeigen, oder bestimmte Befehle auswählen, die Ihrem persönlichen Menü hinzugefügt werden sollen. Access 2000 richtet Menüs und Symbolleisten entsprechend Ihrer Arbeitsweise ein, so dass dort nur die Befehle und Symbolleistenschaltflächen angezeigt werden, die Sie am häufigsten verwenden.

  • Anordnung der Symbolleisten nebeneinander Klicken Sie auf Weitere Schaltflächen, falls auf der Symbolleiste kein Platz mehr für die gewünschte Schaltfläche ist. Sie können die Symbolleiste vergrößern, wenn Sie noch mehr Platz für weitere Schaltflächen benötigen. Wenn Sie auf eine Schaltfläche geklickt haben, wird sie in der Symbolleiste mit den zuletzt verwendeten Schaltflächen angezeigt .

  • Zuweisen von Hyperlinks zu Symbolleistenschaltflächen oder Menübefehlen Sie können einen Hyperlink einer Symbolleistenschaltfläche oder einem Menübefehl zuweisen und so mühelos auf Speicherorte auf Ihrem Computer, im Netzwerk, einem Intranet oder im Internet zugreifen.


Was ist neu beim Schützen, Warten und Konvertieren von Datenbanken?

  • Schützen von Access-Datenbanken mit dem Benutzerdatensicherheits-Assistenten Der Benutzerdatensicherheits-Assistent ist jetzt viel einfacher zu bedienen und stellt die empfehlenswerteste Methode dar, die Datensicherheit für Microsoft Access-Datenbanken auf Benutzerebene für die häufigsten Sicherheitsschemen zu definieren.

  • Schützen des Codes mit dem Visual Basic für Applikationen-Kennwortschutz Module sowie hinter Formularen und Berichten stehende Module werden jetzt durch ein VBA-Kennwort geschützt, das Sie im Visual Basic-Editor erstellen. Sie werden nicht mehr durch Datensicherheit auf Benutzerebene geschützt.

  • Verbessertes Komprimierungs-Dienstprogramm Komprimieren Sie Microsoft Access-Datenbanken und Microsoft Access-Projekte mit einem verbesserten Dienstprogramm, das Komprimierung und Reparatur in einem einzigen Vorgang durchführt und sicherer und effektiver arbeitet.

  • Automatische Komprimierung Wählen Sie Beim Schließen komprimieren, um eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt beim Schließen automatisch zu komprimieren.

  • Konvertieren von Datenbanken in Microsoft Access 97 Access 2000-Datenbanken können Sie in das Access 97-Dateiformat konvertieren.


 Was ist neu beim Arbeiten im Internet?

Was ist neu beim Arbeiten im Internet?

Microsoft Access bietet neue Features, die zur Erleichterung Ihrer Arbeit im Internet beitragen sollen. Sie benötigen einen Webbrowser wie beispielsweise Microsoft Internet Explorer, ein Modem und eine Intranet- oder andere Netzwerkverbindung, um auf das Internet zugreifen und einige dieser neuen Features nutzen zu können.

  • Erstellen von Datenzugriffsseiten Erstellen Sie Datenzugriffsseiten, mit denen Sie in eine Microsoft Access-Datenbank oder eine Microsoft SQL Server-Datenbank neue Daten hinzufügen oder vorhandene ändern, anzeigen oder bearbeiten können.

  • Gemeinsames Bearbeiten über ein Intranet oder das Internet Mit NetMeeting können Sie Microsoft Access-Datenbanken oder Microsoft Access-Projekte gemeinsam mit anderen bearbeiten.

  • Zuordnen von Hyperlinks zu Symbolleistenschaltflächen oder Menübefehlen Sie können einen Hyperlink einer Symbolleistenschaltfläche oder einem Menübefehl zuordnen und so Speicherorte auf Ihrem Computer, in einem Netzwerk, in einem Intranet oder im Internet mühelos erreichen.


 Was ist neu beim Arbeiten mit anderen Anwendungen?

Was ist neu beim Arbeiten mit anderen Anwendungen?

Microsoft Access 2000 bietet neue Features für das Zusammenarbeiten mit anderen Produkten.

  • Arbeiten mit Microsoft SQL Server Sie können entweder ein Microsoft Access-Projekt erstellen, das sich problemlos mit einer Microsoft SQL Server-Datenbank verbinden lässt, oder mit Hilfe des Microsoft SQL Server-Datenbank-Assistenten rasch eine SQL Server-Datenbank und gleichzeitig ein Access-Projekt erstellen. Das Arbeiten mit einem Microsoft Access-Projekt ähnelt stark dem Umgang mit einer Microsoft Access-Datenbank. Der Prozess der Erstellung von Formularen, Berichten, Datenzugriffsseiten, Makros und Modulen ist der gleiche. Wenn Sie sich mit einer SQL Server-Datenbank verbinden, können Sie mit Hilfe der Microsoft SQL Server-Designtools Tabellen, Ansichten, gespeicherte Prozeduren und Datenbankdiagramme anzeigen, erstellen, ändern oder löschen.

  • Erstellen neuer Access-Datenbanken aus Daten in anderen Dateiformaten Öffnen Sie in Access einfach eine Datei in einem anderen Dateiformat, beispielsweise Text, dBASE, Paradox oder einem Tabellenkalkulationsformat. Microsoft Access erstellt automatisch eine Access-Datenbank und verknüpft die Datei.

  • Importieren oder Verknüpfen von Daten aus Microsoft Outlook oder Microsoft Exchange Mit Hilfe des Exchange/Outlook-Assistenten können Sie Daten aus Microsoft Outlook und Microsoft Exchange Server importieren oder verknüpfen. Beispielsweise können Sie eine Verknüpfung zu Ihrem Microsoft Outlook-Kontaktordner herstellen und dann Serienbriefe oder Versandetiketten erstellen, indem Sie die Daten mit dem Microsoft Word-Seriendruck-Assistenten verbinden.


 Komponenten einer Microsoft Access 2000-Installation

Komponenten einer Microsoft Access 2000-Installation

Den folgenden Informationen können Sie entnehmen, welche Features mit Microsoft Access 2000 installiert werden und an welcher Position im Installationsprogramm sich diese befinden. Diese Features werden außerdem über das Installationsprogramm von Office 2000 installiert; es handelt sich sowohl um Microsoft Access-Features als auch um Tools, Konverter und Filter von Office.

Installation (Standard)

Installation bei erstmaliger Verwendung (Standard)

Keine Installation (nur bei benutzerdefinierter Installation)

Anmerkungen zu Features

Andere Programme in Microsoft Office 2000

Installation (Standard)

Feature | Position im Installationsprogramm
ClipArt-Gallery | Office-Tools; ClipArt
Dateien für Core-Support, Internationaler Support | Office-Tools; Internationaler Support
Encapsulated Postscript | Konverter und Filter; Grafikfilter
GIF (Graphic Interchange Format) | Konverter und Filter; Grafikfilter
Hilfe zu Microsoft Access | Microsoft Access für Windows
Hilfe zu Microsoft Graph | Office-Tools; Microsoft Graph
Indexerstellung-Systemsteuerung | Office-Tools
JPEG Interchange Format | Konverter und Filter; Grafikfilter
Macintosh PICT-Import | Konverter und Filter; Grafikfilter
Microsoft Access-Programmdateien | Microsoft Access für Windows
Microsoft Graph | Office-Tools
Microsoft Office Shortcut-Leiste | Office-Tools
MS Info | Office-Tools
Office Web Components | Office-Tools
Office-Assistent (ein Assistent) | Office-Tools; Office-Assistent
Rechtschreibprüfung | Office-Tools; Überprüfungstools
Standardassistenten Um eine Liste der Assistenten anzuzeigen, klicken Sie auf [image] . | Microsoft Access für Windows
TIF-Dateiformat-Import | Konverter und Filter; Grafikfilter
Tool für Spracheinstellungen | Office-Tools
Typische Designs | Office-Tools; Designs
Webdiskussionen | Office-Tools
Webpublishing | Office-Tools
Windows Metafile-Import | Konverter und Filter; Grafikfilter

Zurück zum Anfang

Installation bei erstmaliger Verwendung (Standard)

Feature | Position im Installationsprogramm
Bidirektionaler Support | Office-Tools; Internationaler Support
Chinesische Schriftzeichen (Taiwan) | Office-Tools; Internationaler Support
Chinesische Schriftzeichen (VR China) | Office-Tools; Internationaler Support
Computer Graphics Metafile (.CGM)-Import | Konverter und Filter; Grafikfilter
CorelDRAW Import | Konverter und Filter; Grafikfilter
Datenbankreplikation | Microsoft Access für Windows
Digitale Unterschrift für VBA-Projekte | Office-Tools
Enhanced Metafile (.EMF)-Import | Konverter und Filter; Grafikfilter
FPX-Import | Konverter und Filter; Grafikfilter
Hilfe zu Visual Basic | Office-Tools
Japanische Schriftzeichen | Office-Tools; Internationaler Support
Kodak Foto-CD-Import | Konverter und Filter; Grafikfilter
Koreanische Schriftzeichen | Office-Tools; Internationaler Support
Microsoft Query | Office-Tools
Nordwind Datenbank | Microsoft Access für Windows; Beispieldatenbanken
Office-Assistent (sieben weitere Assistenten) | Office-Tools; Office-Assistent
Organigramm | Office-Tools
PC Paintbrush PCX-Import | Konverter und Filter; Grafikfilter
PNG-Dateiformat-Import | Konverter und Filter; Grafikfilter
Scanner- und Camera-Add-In | Office-Tools
Snapshot Viewer | Microsoft Access für Windows
Visuelle Client/Server-Designtools | Microsoft Access für Windows
Webskripting (Microsoft Skript-Editor) | Office-Tools; HTML-Quellcode-Bearbeitung
Weitere Assistenten Um eine Liste der Assistenten anzuzeigen, klicken Sie auf [image] . | Microsoft Access für Windows
Weitere Designs | Office-Tools; Designs
Windows Bitmap-Import | Konverter und Filter; Grafikfilter
WordPerfect-Grafikfilter | Konverter und Filter; Grafikfilter

Zurück zum Anfang

Keine Installation (nur bei benutzerdefinierter Installation)

Feature | Position im Installationsprogramm
Erweiterte Supportdateien, Internationaler Support | Office-Tools; Internationaler Support
Formel-Editor | Office-Tools
Kalender-Steuerelement | Microsoft Access für Windows
Lotus VIM Mail-Support | Office-Tools
Microsoft Foto-Editor | Office-Tools
Nordwind SQL-Projektdatei | Microsoft Access für Windows; Beispieldatenbanken
Universelle Schriftart | Office-Tools; Internationaler Support

Anmerkung Das Kalender-Steuerelement und die Nordwind SQL-Projektdatei werden auf der Benutzeroberfläche von Microsoft Access nicht erwähnt; Sie müssen das Setup-Programm von Microsoft Office 2000 oder Microsoft Access 2000 ausführen, um diese Features zu installieren.

Zurück zum Anfang

Anmerkungen zu Features

Nachdem Sie Microsoft Access 2000 oder Microsoft Office 2000 installiert haben, werden die Beispieldatenbanken in der Liste der zuletzt geöffneten Dateien im Menü Datei oder in der Liste unter Öffnet eine bestehende Datenbank in dem Dialogfeld, das beim erstmaligen Starten von Microsoft Access geöffnet wird, angezeigt. Nachdem Sie eigene Dateien in Microsoft Access geöffnet haben, sind die Datenbanken möglicherweise nicht mehr in diesen Listen enthalten. Um eine der Beispielanwendungen auf Ihrem Computer zu installieren, verwenden Sie das Setup-Programm von Microsoft Office 2000 oder Microsoft Access 2000.

Das Microsoft Access 2000-Setup-Programm installiert darüber hinaus Textkonverter und zusätzliche Überprüfungstools; die meisten dieser Komponenten werden bei erstmaliger Verwendung installiert und nehmen daher nicht viel Speicherplatz in Anspruch. Obwohl Sie diese Komponenten mit anderen Microsoft Office 2000-Anwendungen, z. B. Microsoft Word und Microsoft Excel, verwenden können, wurden sie nicht für die direkte Verwendung mit Microsoft Access entwickelt.

Sofern Sie keine benutzerdefinierte Installation durchführen, installieren die Setup-Programme von Microsoft Office 2000 und Microsoft Access 2000 Microsoft Internet Explorer 5. Wenn Sie eine benutzerdefinierte Installation durchführen, können Sie auf die Installation von Microsoft Internet Explorer verzichten. Microsoft Internet Explorer 5 ist jedoch erforderlich, um Datenzugriffsseiten in Microsoft Access verwenden zu können.

Zurück zum Anfang

Andere Programme in Microsoft Office 2000

Programm und Position im benutzerdefinierten Setupdialogfeld | In einer typischen Installation enthalten?
Microsoft Excel für Windows | Ja
Microsoft Outlook für Windows | Ja
Microsoft PowerPoint für Windows | Ja
Microsoft Word für Windows | Ja

Anmerkung Eine typische Installation von Microsoft Office 2000 Premium installiert darüber hinaus Microsoft FrontPage für Windows.

Zurück zum Anfang


 Was ist neu bei den Beispielanwendungen

Was ist neu bei den Beispielanwendungen

Die Beispielanwendungen, die Sie zusammen mit Microsoft Access installieren können, enthalten Beispiele zum Erstellen und Anpassen leistungsstarker Microsoft Access-Datenbanken.

Nordwind GmbH Die Beispielanwendung Nordwind wurde für Benutzer entwickelt, die noch nicht mit Microsoft Access-Datenbanken gearbeitet haben. Nordwind enthält Daten, die Sie ändern können, sowie Formulare, Berichte, Datenzugriffsseiten und andere Objekte, die Sie als Modelle für Ihre eigenen Datenbanken verwenden können.

NordwindCS Die Beispielanwendung NordwindCS enthält ein SQL-Skript, das die Nordwind-Datenbank in Microsoft SQL Server erstellt, sowie ein Microsoft Access-Projekt, das Sie mit der Nordwind-Datenbank verbinden. Das Access-Projekt enthält Formulare, Berichte, Datenzugriffsseiten und andere Objekte, die Sie als Modelle für Ihre eigenen Access-Projekte verwenden können.


 Microsoft Office 2000 Developer, Inhalt

Microsoft Office 2000 Developer, Inhalt

Microsoft Office 2000 Developer stellt hochentwickelte Tools bereit, mit deren Hilfe Entwickler benutzerdefinierte Anwendungsprogramme erstellen und verteilen können.

Office 2000 Developer enthält die folgenden Komponenten:

Microsoft Office Premium CD-ROM

Office Developer Tools CD-ROM

  • Eine Lizenz für den lizenzgebührenfreien Vertrieb (einschließlich der Laufzeitversion von Microsoft Graph) und die Tools, mit deren Hilfe Sie Ihre selbstentwickelten Microsoft Access-Anwendungsprogramme an alle Ihre Benutzer weitergeben können, unabhängig davon, ob die Benutzer Access installiert haben oder nicht.

  • Den Replikations-Managers, der Ihre Replikate plant, bestimmt, welche Objekte in der Datenbank repliziert werden sollen und mehrere Replikate gleichzeitig verwaltet. Mit dem Replikations-Manager können Sie eine visuelle Anzeige aller Replikate in einer Gruppe sehen.

  • Microsoft Visual SourceSafe 6.0 (einschließlich des Visual SourceSafe Add-Ins für Access und des Visual SourceSafe Visual Basic Editor-Add-Ins), das Anwendungsentwicklung für mehrere Entwickler unterstützt.

  • ActiveX-Steuerelemente, mit deren Hilfe Sie Ihre Anwendungen flexibler gestalten und Microsoft Windows 95-Funktionalität duplizieren können, einschließlich Steuerelementen für Internet-Anwendungen und Steuerelementen zum Herstellen einer Verbindung zu Microsoft Outlook-Messaging mit Daten und anderen Office-Anwendungen.

  • Einen aktualisieren Windows API-Viewer mit verbesserter Leistung. Der Windows API Viewer enthält Deklarationen und Konstanten, die in der Windows 95-API (Application Programming Interface, Anwendungsprogrammierschnittstelle) enthalten sind. Sie können diese Deklarationen und Konstanten kopieren und in Ihre Visual Basic-Module einfügen.

  • Die Datenumgebung, eine Benutzeroberfläche für problemlose Verbindungslösungen zu externen Datenbanken.

  • Das Funktionsmerkmal "Add-In erstellen" zum direkten Ersellen eines Add-Ins direkt aus dem Visual Basic Editor heraus (für einen speziellen Visual Basic Editor-Host).

  • Den Package and Deploy-Assistenten, mit dem Sie Office-Programmlösungen für einen beliebigen Visual Basic für Applikationen 6.0-Host auf Diskette, über das Netzwerk oder über das Web zur Verfügung stellen können.

  • Die Codebibliothek, ein Hilfsmittel zum Suchen nach Codeteilen in vorhandenen Quelldateien. Sie können nach Text suchen, Beschreibungen und Kommentarköpfe anzeigen und den Text in Ihr aktuelles Projekt einfügen.

  • Das HTML Help Workshop Software Development Kit (SDK), mit dem Sie Hilfethemen, ähnlich denen in Microsoft Office 2000, erstellen können. Das SDK enthält den HTML Help Workshop und die Laufzeitversion zur Verteilung an Ihre Benutzer.

  • Das Agent SDK, mit dem Sie die von Ihnen erstellten Office-Assistenten programmtechnisch überwachen können.

  • Microsoft Developer Network (MSDN), Office 2000 Edition. Enthält die gesamte MSDN-Bibliothek sowie eine spezielle Standarduntergruppe von Programmierbefehlen für Office und Visual Basic für Applicationen .

Gedruckte Dokumentation

  • Microsoft Office 2000/Visual Basic Programmierhandbuch

  • Object Model Guide


Arbeiten mit Daten im Jahr 2000 und später

Was möchten Sie tun?

Informationen darüber erhalten, wie Microsoft Access mit Daten im Jahr 2000 und später arbeitet

Informationen über die Website "Microsoft Jahr 2000-Ressourcen-Center" erhalten


Verarbeiten von Datumsangaben ab dem Jahr 2000 in Microsoft Access

Da die Regeln, die bestimmen, wie ein Kalkulationsprogramm Datumsangaben berechnet, sehr komplex sind, müssen Sie beim Eingeben von Datumsangaben so spezifisch wie möglich sein. Dadurch erreichen Sie für die Datumsverarbeitung von Access den höchsten Genauigkeitsgrad.

Interpretieren zweideutiger Datumsangaben durch Access Beim Interpretieren zweideutiger Datumsangaben geht Access von bestimmten Voraussetzungen aus. Wenn Sie z. B. ein Datum eingeben, das nur den Monat sowie ein oder zwei Ziffern umfasst, nimmt Access an, dass die Zahlen 1 bis 31 den Tag angeben und dass das Jahr das aktuelle Jahr ist. Access geht beispielsweise davon aus, dass December 01 der 1. Dezember des aktuellen und nicht des Jahres 2001 ist. Access nimmt weiter an, dass December 32 der 1. Dezember 1932 ist.

Interpretieren zweistelliger Jahre durch Access In Datenblättern und Bearbeitungssteuerelementen interpretiert Access Datumsangaben, die mit einem abgekürzten Jahresformat für das 21. Jahrhundert angegeben werden, auf folgende Weise:

Datumsbereich für das abgekürzte Jahresformat | Interpretation
1.1.00 bis 31.12.29 | 1.1.2000 bis 31.12.2029
1.1.30 bis 31.12.99 | 1.1.1930 bis 31.12.1999

Verwenden vierstelliger Jahreszahlen Um sicherzustellen, dass Access Werte wie beabsichtigt interpretiert, können Sie Jahreszahlen vierstellig eingeben (z. B. 2001 anstatt 01).

Ändern der Interpretation von Jahreszahlen Der Systemadministrator kann Office so anpassen, dass verschiedene Regeln bestimmen, wie Datumsangaben interpretiert werden. Der Administrator kann z. B. den frühesten zweistelligen Jahreswert, der als ein Datum im 20. Jahrhundert interpretiert wird, von 30 in einen niedrigeren Wert ändern (siehe die obige Tabelle). Ferner kann der Administrator das Standarddatumformat so ändern, dass vierstellige anstatt zweistellige Jahreszahlen angezeigt werden. Weitere Informationen zur Anpassung der Datumsinterpretation finden Sie im Microsoft Jahr 2000-Ressourcen-Center.

Anmerkung Wenn Sie mit Microsoft Windows 2000 Professional oder Windows 98 arbeiten, können Sie ohne Hilfe des Systemadministrators die Jahrhundertinterpretation und das Standarddatumsformat ändern, damit vierstellige Jahreszahlen angezeigt werden.


Installieren oder Entfernen einzelner Komponenten

Wenn Sie eine benötigte Microsoft Office 2000- oder Microsoft Access 2000-Komponente nicht finden, installiert das Windows-Installationsprogramm diese nicht automatisch. Sie können sie jedoch selbst installieren. Wenn Sie Office 2000 oder Access 2000 ursprünglich von einem Netzwerkdateiserver installiert haben, führen Sie diese Kopie des Setup-Programms erneut aus.

  1. Beenden Sie alle Programme.

  2. Klicken Sie auf die Windows-Schaltfläche Start, zeigen sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  3. Doppelklicken Sie auf das Symbol Software [image].

  4. Führen Sie einen der folgenden Schritte aus:

    Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf Microsoft Office 2000 und dann auf Hinzufügen/Entfernen, wenn Sie Access unter Verwendung des Office 2000 Setup-Programms installiert haben.

    Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf Microsoft Access 2000, wenn Sie Access einzeln installiert haben.

  5. Folgen Sie den Anweisungen auf dem Bildschirm.

    Informationen zu den Adressen der Komponenten im Installationsprogramm.

Anmerkungen

  • Wenn Sie Office oder Access von einer CD installiert und Ihrem CD-ROM-Laufwerk nach dem Installieren von Office oder Access einen neuen Buchstaben zugeordnet haben, führen Sie das Setup-Programm erneut von der CD aus. Wenn Sie Office- oder Access-Dateien von der CD ausführen, müssen Sie entweder dem CD-ROM-Laufwerk den ursprünglichen Buchstaben zuordnen oder Office oder Access deinstallieren und erneut von der CD-ROM installieren.

  • Wenn Sie möchten, dass sich sowohl Access 2000 als auch Access 97 auf Ihrem Computer befinden, müssen Sie beim Installieren von Access 2000 einen anderen Ordner auswählen als den, in dem Access 97 installiert ist. Andernfalls wird Access 97 ersetzt.

  • Microsoft Data Engine (MSDE) gehört nicht zum Office- oder Access- Setup. Sie können MSDE jedoch von der CD oder von einem Netzwerkdateiserver installieren. Dazu führen Sie die Datei SETUPSQL-EXE aus, die sich im Ordner \Sql\x86\Setup befindet. Weitere Informationen zur Verwendung von MSDE.

  • Wenn Sie Microsoft Internet Explorer 5 erneut installieren oder auf diese Version aktualisieren möchten, können Sie es von der CD oder vom Netzwerkdateiserver aus installieren. Dazu führen Sie IE5SETUP.EXE aus dem Ordner \Ie5 aus.


Office oder ein Office-Programm automatisch reparieren

  • Klicken Sie im Menü ? auf Erkennen und Reparieren.

    Um die Programmverknüpfungen zum Windows Startmenü wiederherzustellen, stellen Sie sicher, dass das Kontrollkästchen Meine Verknüpfungen während der Überprüfung wiederherstellen aktiviert ist.

Anmerkungen

  • Diese Prozedur erkennt und repariert Probleme im Hinblick auf alle installierten Office-Programme, z. B. fehlende Installationsdateien und Registrierungseinstellungen. Persönliche Dateien, wie Kalkulationstabellen oder Dokumente werden nicht repariert.

  • Wenn das Problem nicht mit dem Befehl Erkennen und Reparieren behoben werden kann, müssen Sie unter Umständen Office mit dem Windows Installer neu installieren.


Konvertieren einer Datenbank

Was möchten Sie tun?

Ich möchte eine vorhandene Datenbank in mehreren Versionen von Microsoft Access verwenden.

Verwenden einer Access-Datenbank in mehreren Versionen von Microsoft Access

Ich möchte eine vorhandene Datenbank in Microsoft Access 2000 verwenden, ohne diese zu konvertieren.

Informationen zum Öffnen einer in einer früheren Version erstellten Access-Datenbank, ohne diese zu konvertieren

Öffnen einer in einer früheren Version erstellten Access-Datenbank in Microsoft Access 2000, ohne diese zu konvertieren

Ich möchte eine vorhandene Access-Datenbank in Microsoft Access 2000 konvertieren.

Informationen zum Konvertieren einer mit einer früheren Versionen erstellten Access-Datenbank in Microsoft Access 2000

Informationen zum Konvertieren einer gesicherten Access-Datenbank

Konvertieren einer mit einer früheren Versionen erstellten Access-Datenbank in Microsoft Access 2000

Konvertieren einer replizierten Datenbank

Ich möchte eine Microsoft Access 2000-Datenbank in Microsoft Access 97 konvertieren

Konvertieren einer Access 2000-Datenbank in Microsoft Access 97

Ich möchte Informationen zu programmiertechnischen Fragen beim Konvertieren anzeigen.

Informationen zu Kompatibilitätsfragen beim Konvertieren von Tabellen, Formularen und Berichten aus früheren Versionen von Microsoft Access

Informationen zu Kompatibilitätsfragen beim Konvertieren von Makros und Visual Basic-Code aus früheren Versionen von Microsoft Access

Ich möchte Probleme behandeln, die beim Konvertieren auftreten.

Problembehandlung beim Konvertieren einer Datenbank einer früheren Version in Microsoft Access 2000


 Korrigieren fehlender Verweise nach dem Konvertieren einer Access 2000-Datenbank in Access 97

Korrigieren fehlender Verweise nach dem Konvertieren einer Access 2000-Datenbank in Access 97

Sie können den Code, der Datenzugriffsobjekte (DAO) verwendet, zurück in Microsoft Access 97 konvertieren. Sie erhalten jedoch möglicherweise keine Meldung, dass auf Ihrem Computer mindestens eine der Access 97-Objektbibliotheken fehlt. Verwenden Sie die nachfolgenden Schritte zum Korrigieren der fehlenden Verweise.

  1. Konvertieren Sie die Microsoft Access 2000-Datenbank in Microsoft Access 97. Wenn Sie eine Meldung erhalten, dass auf Ihrem Computer mindestens eine der Access 97-Objektbibliotheken fehlt, klicken Sie auf OK.

  2. Öffnen Sie die konvertierte Access-Datenbank in Microsoft Access 97.

  3. Öffnen Sie ein Modul in der Datenbank.

  4. Klicken Sie im Menü Extras auf Verweise.

  5. Deaktivieren Sie unter Verfügbare Verweise die Kontrollkästchen für fehlende Verweise, und legen Sie einen Verweis zur Microsoft DAO 3.51 Objektbibliothek fest.

Anmerkung Access 97 unterstützt im Gegensatz zu Access 2000 keine ActiveX-Datenobjekte (ADO).


 Konvertieren einer Access 2000-Datenbank in das Access 97-Format

Konvertieren einer Access 2000-Datenbank in das Access 97-Format

  1. Öffnen Sie die Microsoft Access-Datenbank, die sie konvertieren möchten. Falls es sich um eine Mehrbenutzer-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass kein anderer Benutzer diese Datenbank geöffnet hat.

    Wichtig Wenn Sie den Microsoft Visual Basic für Applikationen-Code (VBA-Code) gesichert haben, müssen Sie vor dem Konvertieren der Access-Datenbank das Kennwort angeben. Starten Sie dazu Microsoft Visual Basic, indem Sie ein Modul öffnen, klicken Sie dann im Menü Extras auf Eigenschaften von Datenbankname, und geben Sie das Kennwort im Feld Kennwort auf der Registerkarte Schutz ein.

    Wenn sie eine geschützte Access-Datenbank konvertieren, müssen Sie die Berechtigung zum Öffnen/Ausführen und zum exklusiven Öffnen für die Datenbank selbst sowie die Berechtigung zum Lesen und Entwerfen für alle Objekte in der Datenbank besitzen. Zum Sichern der konvertierten Datenbank müssen Sie sie in Microsoft Access 97 öffnen und Sicherheit auf Benutzerebene einstellen.

  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, klicken Sie auf Datenbank konvertieren und dann auf In vorhergehende Access-Datenbankversion.

  3. Geben Sie im Dialogfeld Datenbank konvertieren in den Namen der neuen Datenbank der älteren Version, die Sie erstellen wollen, im Feld Dateiname ein, und klicken Sie dann auf Speichern.

Anmerkung Wenn Ihre Access 2000-Datenbank Code enthält, müssen Sie unter Umständen nach der Konvertierung in Microsoft Access 97 fehlende Referenzen wiederherstellen. Falls die Access-Datenbank Add-Ins oder Bibliotheksdatenbanken verwendet, die in Access 2000 erstellt wurden, müssen Sie diese ebenfalls in das Access 97-Format zurückkonvertieren.

Informationen über das Konvertieren einer Access 2000-Datenbank in das Access 97-Format.


Öffnen der Beispieldatenbank "Nordwind"

  1. Starten Sie Microsoft Access.

  2. Stellen Sie sicher, dass Öffnet eine bestehende Datenbank im Startdialogfeld aktiviert ist.

  3. Klicken Sie in der Liste auf Beispieldatenbank Nordwind.

  4. Wenn Nordwind noch nicht installiert wurde, klicken Sie auf Ja, um sie jetzt zu installieren.

Anmerkungen

  • Wenn Sie bereits Access geöffnet haben, können Sie von einem beliebigen Fenster aus im Menü Datei auf den Befehl Datenbank öffnen klicken und danach zur Beispieldatenbank Nordwind wechseln. Sie befindet sich gewöhnlich im Ordner Programme\Microsoft Office\Office\Beispiele. Wenn Sie bereits eine andere Datenbank geöffnet haben, wird diese von Access beim Öffnen einer anderen Datenbank geschlossen.

  • Wenn die Beispieldatenbank im Startdialogfeld oder im Ordner Beispiel nicht angezeigt wird, können Sie Nordwind selbst installieren.

  • Zum Anzeigen weiterer Informationen zur Nordwind-Datenbank klicken Sie auf [image] .


Im Lieferumfang von Microsoft Access enthaltene Beispieldatenbanken

Beispiele anzeigen und Anregungen aus der Beispieldatenbank Nordwind GmbH erhalten

Im Lieferumfang von Microsoft Access ist die Beispieldatenbank Nordwind GmbH enthalten, die Sie verwenden können, während Sie Microsoft Access lernen: Die Datenbank Nordwind enthält Verkaufsdaten des fiktiven Unternehmens Nordwind GmbH, das weltweiten Import und Export von Delikatessen betreibt. Indem Sie die in der Datenbank Nordwind enthaltenen Tabellen, Abfragen, Formulare, Berichte, Makros und Module anzeigen, können Sie Ideen für Ihre eigene Access-Datenbank entwickeln. Außerdem können Sie mit den Nordwind-Daten in Access experimentieren, bevor Sie eigene Daten eingeben. Beispielsweise könnten Sie mit der Tabelle Bestellungen das Entwerfen von Abfragen üben, da sie genügend Datensätze enthält, um aussagekräftige Ergebnisse hervorzubringen.

Die Datenbank Nordwind enthält die Hilfedatei Demo, die die Hauptfeatures in der Datenbank dokumentiert.

So öffnen Sie Nordwind.

Anmerkung Microsoft Access enthält außerdem einen Datenbank-Assistenten, mit dem Sie häufig verwendete Access-Datenbanken erstellen können. Mit dem Datenbank-Assistenten erstellte Datenbanken lassen sich unverändert in der Praxis oder als Lernhilfe zum Entwerfen eigener Datenbanken einsetzen.


Abrufen von technischen Informationen von Microsoft

Wenn Sie eine Frage zu einem Office-Programm haben, fragen Sie zuerst den Office-Assistenten, und sehen Sie dann im Microsoft Office 2000 Resource Kit oder in der Infodatei nach, die im Lieferumfang des Programms enthalten war. Wenn Sie die benötigten Informationen nicht finden, können Sie die Informationen von den in der folgenden Liste aufgeführten Informationsquellen abrufen.

Von wo möchten Sie technische Informationen abrufen?

Microsoft Office-Update Eine Website, die regelmäßig aktualisiert wird. Sie bietet Informationen und Antworten auf Fragen zu allen Office-Produkten. Rufen Sie weitere Informationen zur Microsoft Office Update Website auf.

Microsoft Knowledge Base Enthält Produktinformationen für Microsoft Supporttechniker und Kunden. Rufen Sie weitere Informationen zur Microsoft Knowledge Base auf.

Microsoft Software Library Bietet die Möglichkeit, kostenlos binäre Dateien vom Internet zu allen Produkten von Microsoft herunterzuladen. Rufen Sie weitere Informationen zur Microsoft Software Library auf.

Microsoft TechNet und Microsoft Developer Network CD-ROMs CD-ROMs, die umfassende Informationen zum Produktsupport für Microsoft-Produkte im kommerziellen Bereich enthalten, sowie umfassende Informationen zur Programmierung und Toolkits. Rufen Sie weitere Informationen zu Microsoft TechNet und Microsoft Developer Network auf.

Microsoft Press Schulungs- und Supportmaterialien für Produkte von Microsoft. Rufen Sie weitere Informationen zu Microsoft Press auf.

Microsoft Download Service Beispielprogramme, Patches und andere Programmierhilfen. Rufen Sie weitere Informationen zu Microsoft Download Service auf.

FastTips Ein automatisierter, kostenloser Service, der rund um die Uhr und an sieben Tagen der Woche Antworten auf häufig gestellte technische Fragen bietet. Rufen Sie weitere Informationen zu FastTips auf.


 Glossar

Glossar

A | Zurück zum Anfang
1:1-Beziehung 1:n-Beziehung Abfrage - Entwurfsansicht Abfrage Abfragefenster Abfrageparameter-Datentypen Abfragetyp - Schaltfläche Absolute Positionierung Active Server Pages (ASP) ActiveX-Datenobjekte ActiveX-Komponente ActiveX-Steuerelement Add-In Admininstrator-Konto ADO (ActiveX Data Objects) Aggregatfunktion Aktion Aktionsabfrage Aktionsargument Aktionsliste Aktionszeile Aktivierte Datenbank Aktivierung für direkte Bearbeitung Aktualisierbarer Snapshot Aktualisieren Aktualisieren Aktualisierung Aktualisierungsabfrage Aktualisierungsweitergabe Aktuellen Wert anzeigen (Menü Debuggen) Aktueller Datensatz Alias Allgemeine Sortierreihenfolge American National Standards Institute (ANSI) | American Standard Code for Information Interchange (ASCII) Anfügeabfrage Anhalten (Menü Ausführen) Anonymes Replikat ANSI-Zeichensatz (American National Standards Institute) Ansicht (Fenster) Ansicht (Schaltfläche ) Anweisung API (Windows Application Programming Interface) Application Note Arbeitsgruppe Arbeitsgruppen-ID (WID) Arbeitsgruppen-Informationsdatei Arbeitsplatz Argument ASCII (American Standard Code for Information Interchange) ASP-Dateien Assistent Auflistung Aufrufbaum Aufrufliste (Menü Ansicht) Ausdruck Ausdrucks-Generator Ausfüllen Ausrichtung am Raster Auswahlabfrage Auswahlausschließender Filter Auswahlbasierter Filter Auswahlrechteck AutoFormat Automatische Verknüpfung Automatisierung Automatisierungsobjekt AutoWert-Datentyp
B | Zurück zum Anfang
Bedingte Formatierung Bedingte Kompilierungskonstante Bedingter Ausdruck Bedingung Befehlsleiste Befehlsschaltfläche Befehlszeile Benennungskonventionen für Objekte Benutzerdefinierte Auflistung Benutzerdefinierte Funktion Benutzerdefinierte Symbolleiste Benutzerdefiniertes Dialogfeld Benutzerdefiniertes Objekt Benutzergruppen Benutzerkonto Berechnetes Feld Berechnetes Steuerelement Berechnungsabfrage Berechtigungen Bereich Bereichsmarkierer Bericht | Bericht-Snapshot Bericht - Entwurfsansicht Berichtsfenster Berichtsfuß Berichtskopf Berichtsmarkierer Berichtsmodul Beschriftungsbereich Besitzer Bezeichner (Ausdrücke) Bezeichner (Visual Basic) Bezeichnungsfeld Beziehung Beziehungen - Fenster Bibliotheksdatenbank Bild-Steuerelement Bitmap Bitmaske Boolesch Browser Byte-Datentyp
C | Zurück zum Anfang
Client/Server Client | Code-Fenster
D | Zurück zum Anfang
Datenbank Datenbankfenster Datenbankobjekte Datenbankreplikation Datenblatt Datenblattansicht Datendefinition Datendefinitionsabfrage Datenfeld Datenfeld Datenherkunft Datenquellen-Steuerelement Datensatz Datensatzgruppe Datensatzmarkierer Datensatznavigationsbereich Datensatznavigationsleiste Datensatznavigationssteuerelement Datensatznummernfeld Datentyp Datenzugriffsobjekt Datenzugriffsseite - Eigenschaften Datenzugriffsseite - Entwurfsansicht Datenzugriffsseite - Fenster Datenzugriffsseite Datenzugriffsseitenansicht Datum/Uhrzeit-Datentyp | DDE-Kanal DDE (Dynamic Data Exchange) Deaktiviertes Steuerelement Debuggen Definition (Menü Ansicht) Deklarationsbereich Design Designmaster Detailbereich (Berichte) Detailbereich (Formulare) Dezimal-Datentyp DHTML (Dynamisches HTML) Diagramm Dialogfeld für benutzerdefinierte Eigenschaften Direkte Synchronisierung Direktfenster Direkthilfe DLL (Dynamic-Link Library) Dokumenteigenschaften Domäne Domänen-Aggregatfunktion Double-Datentyp Dropdownliste Dynamic-Link Library (DLL) Dynamic Data Exchange (DDE) Dynamisches HTML (DHTML)
E | Zurück zum Anfang
Einbetten (Einfügen) Echo Eigenschaft Eigenschaftenfenster Eindeutiger Index Eingabebasierter Filter Eingabeformat Eingebaute Konstante Eingebaute Symbolleiste Eingebettete Positionierung Einzelschritt (Menü Debuggen) Einzelschritte Einzug vergrößern (Menü Bearbeiten) Einzug verkleinern (Menü Bearbeiten) Element Endlosformular | Entwurfsansicht Entwurfsbereich Ereignis Ereigniseigenschaft Ereignisprozedur Ereignisweitergabe Ergebnisgruppe Erneut abfragen Erstellen von Anwendungsprogrammen mit Formularen und Berichten Erweiterungssymbol Exklusionsverknüpfung Exklusiv Exportieren Externe Datenbank Externe Tabelle
F | Zurück zum Anfang
Feld Felddatentypen Feldliste Feldmarkierer Fenster für Lokale Feste Positionierung Filter Fokus Format Formular - Entwurfsansicht Formular Formularansicht Formularbasierter Filter Formulareigenschaften | Formularfenster Formularfuß Formularkopf Formularmarkierer Formularmodul Fortsetzen (Menü Ausführen) Fragezeichen als Mauszeiger Freigegebene Datenbank Fremdschlüssel Fremdtabelle Front-End/Back-End-Anwendung FTP (File Transfer Protocol) FTP (File Transfer Protocol) Funktionsprozedur
G | Zurück zum Anfang
Gebunden Gebundene Spalte Gebundenes Bild Gebundenes HTML-Steuerelement Gebundenes Hyperlink-Steuerelement Gebundenes Objektfeld Gebundenes Steuerelement Generator für ODBC-Verbindungszeichenfolgen Generator Generator-Schaltfläche Gespeicherte Prozedur Gesperrt Gesschützte Arbeitsgruppe GIF (Graphics Interchange Format) Gitternetzlinien Globale Menüleiste Globales Kontextmenü | Globales Replikat Globally Unique Identifier (GUID) Graphics Interchange Format (GIF) Gruppe Administatoren Gruppenfilter-Steuerelement Gruppenfuß Gruppenkonto Gruppenkopf Gruppensymbolleiste Gruppierte Datenzugriffsseite Gruppierte Steuerelemente Gruppierungsebene GUID (Globally Unique Identifier) Gültigkeitsregel Gültigkeitsüberprüfung
H | Zurück zum Anfang
Haltepunkt ein/aus (Menü Debuggen) Haltepunkt Haltepunkte löschen (Menü Debuggen) Handle Hauptformular Hauptteil Hintergrund der Anwendung Hotspotbild-Steuerelement HTML (Hypertext Markup Language) HTTP (Hypertext Transfer Protocol) | HTX-Dateien Hub Hyperlink Hyperlinkbasis Hyperlink (Datentyp) Hyperlinkadresse Hyperlink-Feld Hypertext Markup Language (HTML) Hypertext Transfer Protocol (HTTP)
I | Zurück zum Anfang
IDC-Dateien IME (Input Method Editor) Import-/Exportspezifikation Importieren Index Indirekte Synchronisierung Indizes-Fenster | Inklusionsverknüpfung Input Method Editor (IME) Instanz Integer-Datentyp Internet Internetsynchronisierung Intranet
J-L | Zurück zum Anfang
Ja/Nein (Datentyp) Jet and Replication Objects (JRO) Joint Photographic Experts Group (JPEG) Journal (Outlook-Leiste) JPEG (Joint Photographic Experts Group) JRO (Jet and Replication Objects) Kalkulationstabelle Kanalnummer Klasse Klassenmodul Klassenname (OLE) Klassenname Kombinationsfeld Kompilierungszeit Komponente/ActiveX-Komponente Konflikt Konstante Kontextmenü Kontrollkästchen Kreuztabellenabfrage | Kriterien Lauftext Lauftext-Steuerelement Laufzeit Laufzeitfehler Layoutvorschau Leer Leere Zeichenfolge Lesezeichen Lineal Links-Inklusionsverknüpfung Listenfeld Listenindex Literal Lokales Objekt Lokales Replikat Long-Datentyp Löschabfrage Löschweitergabe
M | Zurück zum Anfang
m:n-Beziehung Makro Makrofenster Makrogruppe Manuelle Verknüpfung Markiertes Steuerelement Mastertabelle Mehrbenutzerdatenbank (gemeinsam genutzte Datenbank) Memo-Datentyp Menü Menüleiste Menüleistenmakro Metadatei Methode Microsoft Access-Datenbank | Microsoft Access-Datendatei Microsoft Access-Objekt Microsoft Access-Projekt Microsoft Data Engine (MSDE) Microsoft Download Service Microsoft Jet-Datenbank-Engine Microsoft Knowledge Base Microsoft Office Web Components Microsoft Skript-Editor Microsoft Software Library Microsoft Visual Basic Scripting Edition (VBScript) Microsoft Visual Basic Modul Modulebene MSDE (Microsoft Data Engine)
N-O | Zurück zum Anfang
Nachschlagefeld Navigationsmodus Navigationsschaltflächen Neues Objekt - Schaltfläche Normalisieren Null Nullfeld Numerischer Ausdruck Objekt Objektbibliothek Objektdatentyp Objektkatalog Objektliste Objektnamen-Autokorrektur Objektsymbolleiste ODBC-Datenbank ODBC-Datenquelle | ODBC (Open Database Connectivity) ODBCDirect Öffentliche Variable Office-Verknüpfungen - Schaltfläche OLE/DDE-Verknüpfung OLE OLE-Container OLE-Objekt OLE-Objektdatentyp OLE-Server OLE DB OLE DB-Provider Open Database Connectivity (ODBC) Operator Optionsfeld Optionsgruppe Outlook-Leiste
P | Zurück zum Anfang
Parameterabfrage Pass-Through-Abfrage Persönliche ID (PID) PivotTable-Formular PivotTable-Liste Pixel Pluszeiger Popupformular Primärschlüssel | Private Prozedur Projekt Prozedur (Menü Einfügen) Prozedur abschließen (Menü Debuggen) Prozedur Prozedurebene Prozedurschritt (Menü Debuggen) Punkt
Q | Zurück zum Anfang
QuickInfo
R | Zurück zum Anfang
Raster (Datenblattansicht) Raster (Entwurfsansicht) Rechts-Inklusionsverknüpfung Referenzielle Integrität Referenzierte Datenbank Reflexivverknüpfung Registerreihenfolge | Registersteuerelement Relative Positionierung Relative Verknüpfung Replikat Replikatgruppe Replikation Rumpfcode
S | Zurück zum Anfang
Schaltfläche Analysieren Schaltfläche Linien/Rahmenbreite Schaltfläche Kontextsensitive Hilfe Schlüsselwort Schriftart Seite (Datenspeicher) Seite (HTML) Seitenansicht Seitenfuß (Berichte) Seitenfuß (Formulare) Seitenkopf (Berichte) Seitenkopf (Formulare) Server Servergeneriertes HTML Shortcut Sicherheitsmaßnahmen auf Benutzerebene Sichtbarkeit Single-Datentyp Sitzung Snapshot Viewer Snapshot Viewer-Steuerelement Snapshot Sortieren und gruppieren-Feld (Berichte) Sortieren und gruppieren-Feld (Datenzugriffsseiten) Sortierreihenfolge Spalte Spaltenmarkierer | Spezialeffekt - Schaltfläche Spezialfilter/Sortierfenster Sprachenordner SQL (Structured Query Language) SQL-Ansicht SQL-Datenbank SQL-spezifische Abfrage SQL-Zeichenfolge/-Anweisung Standardeigenschaft Standardmodul Standardsteuerelementstil Standardwert Startseite Statusleiste Steuerelement Steuerelement mit Hyperlink Structured Query Language (SQL) Sub-Prozedur Suchseite Symbolleiste Formatierung Symbolleiste Formatierung (Seite) Symbolleiste Synchronisierung Syntaxfehler Systemmenü Systemobjekt
T | Zurück zum Anfang
Tabelle - Entwurfsansicht Tabelle Tabelleneigenschaften Tabellenerstellungsabfrage Tabellenfenster Tastaturbehandlungsroutine Teilreplikat Text-Datentyp Textabfrage (Microsoft Knowledge Base) Textdatei mit festgelegtem Format Textdatei mit Trennzeichen | Textfeld The Microsoft Network Thema Titelleiste Toolbox Topologie Transaktion Trennzeichen Twip Typbibliothek
U-V | Zurück zum Anfang
Überwachungsausdruck Überwachungsbereich Überwachungsfenster Umschaltfläche UNC (Universal Naming Convention) Ungebundenes Formular oder ungebundener Bericht Ungebundenes Objektfeld Ungebundenes Steuerelement Unicode Uniform Resource Locator (URL) Union-Abfrage Universal Naming Convention (UNC) Unterabfrage Unterbericht Unterbrechungsmodus Unterdatenblatt Unterformular-/Unterbericht-Steuerelement Unterformular Untermenü Unterscheidung nach Groß-/Kleinschreibung Unverankert | URL (Uniform Resource Locator) Variable auf Modulebene Variable auf Prozedurebene Variable Variant VBScript (Visual Basic Scripting Edition) Verankert Verb Verbindungszeichenfolge Vergleichsoperator Verknüpfte Tabelle Verknüpfung (OLE/DDE) Verknüpfung (Tabellen) Verknüpfung Verlaufsliste Veröffentlichen Verschieben-Modus Verweisdatenbank Visual Basic-Editor Vorschau
W-Z | Zurück zum Anfang
Währung-Datentyp Webseitenvorschau Wert WHERE-Klausel Windows Application Programming Interface (API) World Wide Web Zahl-Datentyp Zeichenfolge Zeichenfolgenausdruck Zeichenfolgendatentyp | Zeichenfolgentrennzeichen Zeichenfolgenvergleich Zeilenmarkierer Ziehpunkte zur Größenänderung Ziel Zoom Zugriffsschlüssel Zurücksetzen (Menü Ausführen) Zusammengesetztes Steuerelement
 | Zurück zum Anfang


Aktivieren oder Deaktivieren der automatischen Anzeige von Hilfethemen durch den Office-Assistenten

  1. Klicken Sie auf den Office-Assistenten.

    Wenn der Assistent nicht eingeblendet ist, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

  2. Klicken Sie auf Optionen.

  3. Aktivieren oder deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Hilfethemen erraten.


Ein- oder Ausblenden des Office-Assistenten

Sie können den Office-Assistenten beim Arbeiten in Microsoft Access vorübergehend aus- oder einblenden. Sie können den Office-Assistenten auch für eine ganze Access-Sitzung deaktivieren und nur das Hilfe-Fenster verwenden. So rufen Sie Hilfe ohne den Office-Assistenten auf.

Vorübergehendes Aus- oder Einblenden des Office-Assistenten

  • Klicken Sie im Menü ? auf Office-Assistenten ausblenden oder Office-Assistenten anzeigen.

Deaktivieren des Office-Assistenten für eine ganze Access-Sitzung

  1. Klicken Sie in der Sprechblase des Assistenten auf Optionen.

    Wenn die Sprechblase des Assistenten nicht angezeigt wird, klicken Sie auf den Assistenten.

  2. Deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Den Office-Assistenten verwenden.

Tipp Wenn Sie den Assistenten zu einem beliebigen Zeitpunkt wieder aktivieren möchten, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

Anmerkung Wenn Sie den Assistenten dauerhaft entfernen möchten, führen Sie Access Setup erneut aus. So entfernen Sie den Assistenten.


Auswählen eines anderen Office-Assistenten

  1. Klicken Sie auf den Office-Assistenten.

    Wenn der Assistent nicht angezeigt wird, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

  2. Klicken Sie in der Sprechblase des Assistenten auf Optionen.

  3. Klicken Sie auf die Registerkarte Katalog und dann auf Zurück oder Weiter, bis der gewünschte Assistent angezeigt wird.

Anmerkung Wenn Sie über einen Zugang zum Internet verfügen, können Sie weitere Assistenten von der Microsoft Office Update Website herunterladen. Klicken Sie dazu im Menü ? auf Office im Web.


Aktivieren und Deaktivieren der akustischen Signale des Office-Assistenten

Wenn Sie die akustischen Signale des Office-Assistenten hören möchten, muss in Ihrem Computer eine Soundkarte installiert sein.

  1. Klicken Sie auf den Assistenten.

    Wenn der Assistent nicht angezeigt wird, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

  2. Klicken Sie auf Optionen.

  3. Aktivieren oder deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Sounds aktivieren.


Tasten und Tastenkombinationen für das Verwenden des Office-Assistenten

Zum Ausführen der meisten der folgenden Aktionen muss der Office-Assistent aktiviert und eingeblendet sein.

Ausführung | Aufgabe
F1, wenn der Assistent angezeigt wird. | Anzeigen der Sprechblase des Office-Assistenten
ALT+Zahl (ALT+1 für das erste Thema, ALT+2 für das zweite usw.). | Wählen eines Hilfethemas aus der Liste, die der Office-Assistent anzeigt
Drücken Sie ALT+PFEIL-NACH-UNTEN. | Anzeigen weiterer Hilfethemen
Drücken Sie ALT+PFEIL-NACH-OBEN. | Anzeigen vorheriger Hilfethemen
Drücken Sie ESC. | Schließen einer Meldung des Assistenten
F1 Der Assistent muss eingeblendet sein. So blenden Sie den Assistenten ein und aus. | Anzeigen von Hilfe mit dem Assistenten
Drücken Sie ESC. | Schließen eines Tipps


Hilfemöglichkeiten während der Arbeit

Dieses Thema enthält Referenzinformationen über:

Den Office-Assistenten um Hilfe fragen

Hilfe über das Menü Hilfe

Hilfe von der Website für die Office-Aktualisierung

Neuigkeiten in Access 2000

Weitere Informationen

Den Office-Assistenten um Hilfe fragen

Wenn Sie eine Frage zu einem Microsoft Office-Programm haben, können Sie den Office-Assistenten fragen. Wenn Sie beispielsweise Hilfe zum Formatieren eines Diagramms benötigen, geben Sie im Office-Assistenten Wie formatiere ich ein Diagramm? ein.

Der Assistent bietet automatisch Hilfethemen und Tipps zu Aufgaben an, die Sie gerade ausführen - sogar bevor Sie eine Frage gestellt haben. Wenn Sie beispielsweise einen Bericht entwerfen, zeigt der Assistent automatisch Themen an, die Ihnen beim Entwurf und der Erstellung eines Berichts helfen.

Darüber hinaus zeigt der Assistent Tipps zur effektiveren Verwendung der Funktionen in Office-Programmen an. Klicken Sie auf die Glühbirne [image] neben dem Assistenten, um einen Tipp anzuzeigen.

Sie können auch einen anderen Assistenten auswählen und ihn so einstellen, dass er Ihren persönlichen Vorlieben und Ihrer Arbeitsweise entspricht. Wenn Sie beispielsweise lieber mit der Tastatur als mit der Maus arbeiten, können Sie Tastenkombinationen verwenden, um die Tipps des Assistenten anzuzeigen. Da der Assistent von allen Office-Programmen gemeinsam verwendet wird, gelten alle am Assistenten geänderten Optionen auch in den anderen Office-Programmen.

Zurück zum Anfang

Hilfe über das Menü "Hilfe"

Klicken Sie einfach im Menü Hilfe auf Microsoft Access-Hilfe. Wenn der Assistent eingeschaltet ist, wird er angezeigt. Wenn er nicht eingeschaltet ist, wird das Hilfefenster angezeigt. Um eine Frage im Hilfefenster einzugeben, klicken Sie auf die Registerkarte Antwort-Assistenten. Um im Inhaltsverzeichnis der Hilfe einen Bildlauf durchzuführen, klicken Sie auf die Registerkarte Inhalt. Wenn Sie nach einem bestimmten Wort oder Ausdruck suchen möchten, klicken Sie auf die Registerkarte Index.

Um eine QuickInfo zu einem Menübefehl, einer Symbolleistenschaltfläche oder einem Bildschirmbereich anzuzeigen, klicken Sie im Menü Hilfe auf Direkthilfe und danach auf das Element, zu dem Sie Informationen wünschen.

Um eine QuickInfo zu einer Dialogfeldoption anzuzeigen, klicken Sie auf die Fragezeichenschaltfläche [image] im Dialogfeld und danach auf die Option. (Wenn die Fragezeichenschaltfläche nicht angezeigt wird, wählen Sie die Option aus und drücken UMSCHALT+F1.)

Um den Namen einer Symbolleistenschaltfläche anzuzeigen, halten Sie den Zeiger über der Schaltfläche, bis der Name angezeigt wird.

Zurück zum Anfang

Hilfe von der Website für die Office-Aktualisierung

Sie können direkt aus einem Office-Programm eine Verbindung zur Website für die Aktualisierung von Microsoft Office und anderen Microsoft-Websites aufbauen, indem Sie im Menü Hilfe den Befehl Office im Web verwenden. Beispielsweise können Sie auf technische Informationen zugreifen und kostenfreie Produkterweiterungen herunterladen, ohne das Office-Programm, in dem Sie gerade arbeiten, zu verlassen.

Zurück zum Anfang

Neuigkeiten in Access 2000

Entdecken Sie die neuen Funktionen in Access 2000, durch die das Produkt leichter zu verwenden ist, sowie Tipps, wie Sie sie bei der Arbeit einsetzen können.

Zurück zum Anfang

Weitere Informationen

Aufbauen einer Verbindung zu den technischen Informationen von Microsoft

Anzeigen von Tipps und Meldungen über den Office-Assistenten

Hilfe ohne Office-Assistent

Zurück zum Anfang


Anzeigen von Hilfeinformationen ohne den Office-Assistenten

Wenn Sie Hilfe ohne den Assistenten anzeigen möchten, muss der Assistent deaktiviert sein. So deaktivieren Sie den Assistenten.

  1. Klicken Sie im Menü ? auf Microsoft Access-Hilfe.

    Wenn die Registerkarten Inhalt, Antwort-Assistent und Index nicht angezeigt werden, klicken Sie auf Anzeigen Steuerelement erweitern.

  2. Gehen Sie im Hilfefenster nach einer der folgenden Methoden vor:
Klicken auf | Zweck
Die Registerkarte Inhalt | Anzeigen des Inhaltsverzeichnisses der Hilfe.
Die Registerkarte Antwort-Assistent | Eingeben einer Frage zu einem Office-Programm.
Die Registerkarte Index | Suchen nach spezifischen Wörtern oder Ausdrücken. Sie können die Suche eingrenzen und festlegen, wie lang die Liste der gefundenen Themen sein soll. Dazu fügen Sie Suchbegriffe hinzu oder entfernen diese, bis nur die gewünschten Themen und Suchbegriffe in der Liste aufgeführt sind.


 Hilfe zu bestimmten Bereichen einer Datenzugriffsseite innerhalb der Seitenansicht erhalten

Hilfe zu bestimmten Bereichen einer Datenzugriffsseite innerhalb der Seitenansicht erhalten

Die Themen der Online-Hilfe für Microsoft Access erläutern den Umgang mit Datenzugriffsseiten im Allgemeinen. Es kann aber vorkommen, dass die Autoren einer Seite spezielle Hilfeinformationen bereitstellen, die sich nur auf die angezeigte Seite beziehen. Beispielsweise können sie direkte Anweisungen zur Benutzung der Seite hinzugefügt oder eine eigene Schaltfläche oder einen eigenen Hyperlink eingefügt haben, der zu den Hilfeinformationen für die Seite führt.

Eine Datenzugriffsseite kann außerdem Funktionen beinhalten, die ihr eigenes Hilfesystem bereitstellen. Beispielsweise besitzt eine Pivot-Tabelle oder eine Kalkulationstabelle jeweils ein eigenes Hilfesystem, das die Handhabung genau dieser Funktion der Seite erläutert.

Zur Anzeige von Hilfeinformationen in der Seitenansicht einer Datenzugriffsseite können Sie eine der folgenden Aktionen durchführen:

  • Hilfe für die Pivot-Tabelle oder die Kalkulationstabelle erhalten Sie, indem Sie in der Symbolleiste des entspechenden Steuerelements auf Hilfe [image] klicken.

  • Um die Microsoft Access-Hilfe erneut anzuzeigen, schließen Sie das Hilfefenster für die Pivot-Tabelle bzw. für die Kalkulationstabelle, und klicken Sie dann in der Symbolleiste des Seitenansichtsfensters auf Hilfe [image].

Anmerkung Andere Komponenten wie z. B. die Windows-Medienwiedergabe verfügen ebenfalls über ein eigenes Hilfesystem, das Sie durch Klicken mit der rechten Maustaste abrufen können.


 Anzeigen von Hilfeinformationen zum Microsoft Skript-Editor in einer Datenzugriffsseite

Anzeigen von Hilfeinformationen zum Microsoft Skript-Editor in einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht oder der Seitenansicht.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Microsoft Skript-Editor.

  3. Klicken Sie im Microsoft Skript-Editor auf Hilfe, und führen Sie dann einen der folgenden Schritte aus:
    • Klicken Sie zum Anzeigen eines Inhaltsverzeichnisses für die Hilfe zum Microsoft Skript-Editor auf Inhalt.

    • Klicken Sie zum Durchblättern des Index mit Schlüsselwörtern zum Suchen nach Informationen in der Hilfe zum Microsoft Skript-Editor auf Index.

    • Klicken Sie zum Suchen nach Begriffen in der Hilfe zum Microsoft Skript-Editor auf Suchen.

Anmerkung Der Microsoft Skript-Editor funktioniert nicht zusammen mit Microsoft Windows Terminal Server.


Drucken eines Hilfethemas

Drucken des aktuellen Themas

  1. Klicken Sie auf Drucken [image].

  2. Wählen Sie die gewünschten Druckoptionen aus.

Drucken einer Themengruppe

  1. Klicken Sie auf die Registerkarte Inhalt.

    Wenn die Registerkarte Inhalt nicht angezeigt wird, klicken Sie auf Erweitern Erweiterungs-Steuerelement, um den Navigationsausschnitt anzuzeigen.

  2. Wählen Sie die zu druckende Überschrift aus, und klicken Sie auf Drucken [image].

  3. Führen Sie einen der folgenden Schritte durch:

    Um das aktuelle Thema zu drucken, klicken Sie auf Ausgewähltes Thema drucken.

    Um alle Themen in der ausgewählten Überschrift zu drucken, klicken Sie auf Ausgewähltes Thema und alle Unterthemen drucken.

  4. Wählen Sie die gewünschten Druckoptionen aus.


Ändern der Schriftart und der Hintergrundfarben eines Hilfethemas

Was möchten Sie tun?

Ändern der Text- und Hintergrundfarben eines Hilfethemas

Ändern der Schriftart eines Hilfethemas

Erleichtern des Zugriffs auf Access

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Info über das Ändern der Schriftarten und Hintergrundfarben eines Hilfethemas

Info über das Ändern der Schriftarten und Hintergrundfarben eines Hilfethemas

Das Hilfefenster verwendet dieselben Einstellungen für Schriftartfarben, Schrifttypen und Hintergrundfarben wie der auf dem Computer installierte Webbrowser. Diese Einstellungen und andere Optionen hängen von der Version und vom Typ des installierten Browsers ab. Sie können die Anzeige der Hilfethemen im Hilfefenster ändern, indem Sie die Einstellungen für die Schriftart und Hintergrundfarbe bearbeiten. Diese Einstellungen werden in einem Cascading Style Sheet (CSS) angegeben. Sie können beliebige oder alle dieser Einstellungen außer Kraft setzen, wenn die Anzeige eingeschränkt ist. Bedenken Sie, dass sich bei Änderung der Schriftart und Hintergrundfarbe für die Hilfethemen im Hilfefenster diese Änderung auch auf die Schriftart und Hintergrundfarbe bei der Anzeige einer Webseite im Browser auswirkt. In der Hilfe zum Browser finden Sie weitere Informationen zu den Einstellungen und verfügbaren Optionen.

Kehren Sie zu Ändern der Schriftarten und Hintergrundfarben in einem Hilfefenster zurück.


Ändern der Text- und Hintergrundfarben eines Hilfethemas

  1. Klicken Sie im Hilfefenster von Microsoft Access auf Optionen [image] und dann auf Internetoptionen.

  2. Klicken Sie in der Registerkarte Allgemein auf Eingabehilfen und anschließend auf Farbangaben auf Webseiten ignorieren.

  3. Klicken Sie auf OK.

  4. Klicken Sie in der Registerkarte Allgemein auf Farben, und wählen Sie die gewünschten Optionen.


Ändern der Schriftart eines Hilfethemas

  1. Klicken Sie im Hilfefenster von Microsoft Access auf Optionen [image] und dann auf Internetoptionen.

  2. Klicken Sie in der Registerkarte Allgemein auf Eingabehilfen und anschließend auf Schriftartangaben auf Webseiten ignorieren.

  3. Klicken Sie auf OK.

  4. Klicken Sie in der Registerkarte Allgemein auf Schriftarten, und wählen Sie die gewünschten Optionen aus.


Abrufen von Informationen zu Ihrem Programm und Computer

  1. Klicken Sie im Menü ? auf Info.

    Im Dialogfeld Info werden Programminformationen angezeigt.

  2. Klicken Sie in dem Dialogfeld auf Systeminfo, wenn Sie Informationen zu Ihrem Computer anzeigen möchten.


 Anzeigen von Direkthilfe-Tipps

Anzeigen von Direkthilfe-Tipps

Anzeigen von Direkthilfe-Tipps zu Menübefehlen, Kontextmenübefehlen, Symbolleistenschaltflächen und anderen Bildschirmelementen

  1. Klicken Sie im Menü ? auf Direkthilfe. Der Zeiger verändert sich zum Fragezeichen-Mauszeiger.

  2. Klicken Sie auf das Element, zu dem Sie Informationen anzeigen möchten.

Anzeigen von Direkthilfe-Tipps zu Dialogfeldoptionen

  1. Zum Anzeigen von Hilfeinformationen zu einer Option klicken Sie auf das Fragezeichen [image]. Der Zeiger verändert sich zum Fragezeichen-Zeiger.

  2. Klicken Sie auf die Option, zu der Sie Informationen anzeigen möchten.

Tipp Sie können die Schaltfläche Direkthilfe [image] zu einer Symbolleiste hinzufügen. Die Schaltfläche Direkthilfe befindet sich in der Kategorie Fenster u. Hilfe (?) des Dialogfelds Anpassen (Registerkarte Befehle) (klicken Sie mit der rechten Maustaste auf eine beliebige Symbolleiste und danach auf Anpassen).


Anzeigen von Tipps und Meldungen mit Hilfe des Office-Assistenten

Was möchten Sie tun?

Einblenden, Ausblenden oder Deaktivieren des Office-Assistenten

Aktivieren oder Deaktivieren der automatischen Anzeige von Hilfethemen durch den Office-Assistenten

Anzeigen von Meldungen mit oder ohne den Office-Assistenten

Anzeigen des Tipps des Tages beim Starten von Microsoft Access

Sie wissen nicht, für welche Option Sie sich entscheiden sollen ?


Anzeigen des Tipps des Tages beim Starten von Microsoft Access

  1. Klicken Sie auf den Office-Assistenten.

    Wenn der Assistent nicht angezeigt wird, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

  2. Klicken Sie auf Optionen.
  3. Aktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Tipps und Tricks beim Start anzeigen.


Anzeigen von Meldungen mit und ohne den Office-Assistenten

  1. Klicken Sie auf den Office-Assistenten.

    Wenn der Assistent nicht angezeigt wird, klicken Sie im Menü ? auf Office-Assistenten anzeigen.

  2. Klicken Sie auf Optionen.

  3. Aktivieren oder deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Warnmeldungen anzeigen.


Info über das Anzeigen von Tipps und Meldungen unter Verwendung des Office-Assistenten

Der Office-Assistent kann Fragen beantworten, Tipps anbieten und Hilfe zu vielfältigen Funktionen des aktuell benutzten Programms liefern. Alle an seinen Optionen vorgenommenen Änderungen, z.B. an den Typen der anzuzeigenden Tipps, betreffen den Assistenten in allen Office-Programmen. Der Assistent kann auf folgende Arten Hilfe anzeigen:

Vorschläge Der Assistent kann, selbst wenn Sie noch nicht danach gefragt haben, Hilfe zu der gerade von Ihnen durchgeführten Arbeit vorschlagen.

Meldungen Wenn der Assistent eingeschaltet ist, werden Programm- und Systemmeldungen standardmäßig in der Assistent-Sprechblase angezeigt. Wenn Sie möchten, können Sie die Meldungen in einem Dialogfeld anzeigen, indem Sie den Assistenten deaktivieren. Ein- und Ausblenden des Office-Assistenten.

Zurück zu Anzeigen von Tipps und Meldungen unter Verwendung des Office-Assistenten.


 Fehlerbehandlung bei Problemen mit Kennwörtern

Fehlerbehandlung bei Problemen mit Kennwörtern

Warum kann ich mein Kennwort nicht löschen?

Ein Kennwort kann nur mit einem Administratorkonto (von einem Mitglied der Gruppe Administratoren, die die Rechte zum Verwalten der Arbeitsgruppensicherheit hat) gelöscht werden. Wenn Sie Ihr Kennwort vergessen oder verloren haben, müssen Sie einen Administrator bitten, dieses zu löschen.


Fehlerbehandlung beim Suchen und Öffnen von Dateien

Wobei benötigen Sie Hilfe?

Ich weiß, dass eine bestimmte Datei sich auf einem Laufwerk oder in einem Ordner befindet, das/der im Dialogfeld Öffnen angezeigt ist, ich kann sie jedoch nicht sehen.

Wenn ich eine meiner gespeicherten Suchen verwende, kann ich einige der zuvor gefundenen Dateien nicht finden.

Ich kann eine Datei im Internet nicht öffnen.

Ich möchte eine HTML-Datei in Access öffnen, die Datei wird jedoch in einem anderen Office-Programm geöffnet.


 Fehlerbehandlung bei der Komprimierung einer Access-Datenbank oder eines Access-Projekts

Fehlerbehandlung bei der Komprimierung einer Access-Datenbank oder eines Access-Projekts

Das Komprimieren einer Microsoft Access-Datenbank oder eines Microsoft Access-Projekts kann aus folgenden Gründen fehlschlagen:

  • Sie haben für die ursprüngliche und die komprimierte Version der Access-Datenbank oder des Access-Projekts nicht genügend Speicherplatz auf Ihrer Festplatte. Löschen Sie alle nicht benötigten Dateien, und wiederholen Sie den Vorgang.

  • Sie verfügen nicht über die Berechtigungen Öffnen/Ausführen und Exklusiv für die Access-Datenbank. Wenn Sie nicht der Besitzer dieser Datenbank sind, setzen Sie sich mit dem Besitzer in Verbindung, um festzustellen, ob Ihnen diese Berechtigungen erteilt werden können. Wenn Sie der Besitzer dieser Datenbank sind, müssen Sie Ihre Berechtigungen aktualisieren.

  • Die Access-Datenbank oder das Access-Projekt wurde von einem anderen Benutzer geöffnet.

  • Die Access-Datenbank oder das Access-Projekt befindet sich auf einer schreibgeschützten Netzwerkfreigabe, oder das Dateiattribut Schreibgeschützt wurde ausgewählt.


Problembehandlung beim Konvertieren einer Access-Datenbank

Sie können die meisten in einer früheren Version von Microsoft Access erstellten Datenbanken problemlos in Microsoft Access 2000 konvertieren. In einigen wenigen Fällen können jedoch neue Features zu Konflikten mit vorhandenen Objekten oder vorhandenem Code führen.

Konvertieren einer in einer früheren Version erstellten Datenbank

Ein Bezeichner verursacht einen Fehler.

Mein Code kann nicht kompiliert werden.

Uhrzeit- oder Datumswerte in meinen Abfragekriterien geben andere Ergebnisse zurück.

Konvertieren einer Microsoft Access 2.0-Datenbank

Mein aus Microsoft Access, Version 2.0, konvertierter Bericht hat andere Ränder.

Eine Prozedur verursacht einen Fehler.

Ich erhalte beim Konvertieren einer großen Datenbank die Meldung, dass zu wenig Speicherplatz vorhanden ist.

Meine 16-Bit-API-Aufrufe werden nicht konvertiert.

Meine AktiveX-Steuerelemente werden nicht konvertiert.

Ich erhalte eine Fehlermeldung, dass für eine Tabelle die Grenze von 32 Indizes überschritten ist.

Ich erhalte beim Öffnen eines Formulars oder Berichts in einer konvertierten Datenbank einen ODBC-Fehler.

Konvertieren einer Microsoft Access 2000-Datenbank in Microsoft Access 97

Ich erhalte eine Meldung, dass auf meinem Computer mindestens eine Access 97-Objektbibliothek fehlt.


 Problembehandlung beim Bearbeiten von Daten in einem Feld in der Datenblatt- oder der Formularansicht

Problembehandlung beim Bearbeiten von Daten in einem Feld in der Datenblatt- oder der Formularansicht

Es gibt mehrere Arten von Feldern in Formularen oder Datenblättern, die nicht geändert werden können. Die folgenden Felder zeigen zwar Werte an wie andere Felder auch. Wenn Sie aber versuchen Daten einzugeben, werden diese nicht angenommen:

  • AutoWert-Felder. Wenn ein Feld in einer Microsoft Access-Datenbank den Datentyp AutoWert oder in einem Microsoft Access-Projekt einen numerischen Datentyp hat, für den die Eigenschaft Identity eingestellt ist, weist Access diesem Feld für jeden Datensatz, den Sie hinzufügen, automatisch eine Zahl zu. Diese Feldart wird häufig als Datensatz-ID oder Primärschlüssel verwendet. Wenn Sie damit beginnen, einen neuen Datensatz hinzuzufügen, trägt Access automatisch den Feldwert für Sie ein; Sie können diesen Wert nicht bearbeiten.

  • Berechnete Felder. In einer Access-Datenbank zeigt ein berechnetes Feld Werte an, die Access berechnet. Diese basieren in der Regel auf anderen Feldern in Ihren Tabellen, werden jedoch nicht in Tabellen gespeichert und können nicht bearbeitet werden.

  • Gesperrte oder deaktivierte Felder. Wenn für ein Steuerelement eines Formulars die Eigenschaft Gesperrt auf Ja oder die Eigenschaft Aktiviert auf Nein festgelegt ist, können die Daten im entsprechenden Feld nicht bearbeitet werden.

  • Felder in einem gesperrten Datensatz. Wenn Sie eine Access-Datenbank in einer Mehrbenutzerumgebung einsetzen und ein Datensatz von einer anderen Benutzerin bzw. einem anderen Benutzer gesperrt ist, können Sie die Daten dieses Datensatzes nicht bearbeiten. Wenn Sie zu einem gesperrten Datensatz kommen, wird im Datensatzmarkierer der Anzeiger für gesperrte Datensätze [image] angezeigt.

  • Felder in Snapshots. Während die meisten Abfragen Datensatzgruppen zurückgeben, die Sie bearbeiten können, gibt es auch einige Abfragen, die Snapshots zurückgeben, welche nicht bearbeitet werden können.

  • Felder in einem schreibgeschützten Formular oder einer gesperrten Datenbank. Wenn die Eigenschaft BearbeitungenZulassen des Formulars, mit dem Sie gerade arbeiten, auf Nein eingestellt ist, oder die zugrunde liegenden Daten schreibgeschützt bzw. gesperrt sind, können die Daten des Formulars nicht bearbeitet werden.

Möglicherweise haben Sie Probleme beim Eingeben von Daten in ein Feld vom Datentyp Datum/Uhrzeit. Wenn Sie Datumsangaben unter Verwendung des Schrägstrich-Formats eingeben, dürfen Sie keinen Schrägstrich anfügen. Die Eingabe 1/3 ist gültig, die Eingabe 1/3/ ist ungültig.


Problembehandlung beim Suchen und Ersetzen von Text

Wobei benötigen Sie Hilfe?

Warum kann vorhandener Text nicht gefunden oder ersetzt werden?

Warum kann Text in einem Feld mit einem Eingabeformat nicht gefunden oder ersetzt werden?


Behandlung von Problemen mit Filtern in Tabellen, Abfragen und Formularen

Wobei benötigen Sie Hilfe?

Warum gibt der Filter nicht die korrekten Datensätze aus?

Warum sortiert der Filter die Datensätze nicht in der korrekten Reihenfolge?

Warum kann eine bestehende Abfrage nicht als Filter verwendet werden?

Warum sind einige Felder im Fenster Formularbasierter Filter nicht verfügbar?

Warum nimmt die Anzeige der Listen im Fenster Formularbasierter Filter so viel Zeit in Anspruch?

Warum stehen bei einem oder mehreren Feldern im Fenster Formularbasierter Filter keine Listen mit zur Auswahl stehenden Werten zur Verfügung?

Es wurde ein Filter in einem Unterformular erstellt, dessen Datensätze mit dem Hauptformular synchronisiert worden sind. Warum wirkt der Filter nicht auch auf das Hauptformular?

Es wurde ein Filter in einem Unterdatenblatt erstellt, dieser hatte jedoch keinen Einfluss auf das Datenblatt, das das Unterdatenblatt anzeigt..


Fehlerbehandlung beim Anzeigen von Daten oder Ändern von Objekten einer Access-Datenbank in einer Mehrbenutzerumgebung

Wobei benötigen Sie Hilfe?

Ich kann Änderungen an einer Microsoft Access-Datenbank nicht speichern.

Ich kann den Tabellenentwurf nicht ändern.

Ich kann die Daten in einer Tabelle nicht anzeigen.

Ich kann ein Datenbankobjekt nicht öffnen.


Problembehandlung beim Einfügen von Daten

Wobei benötigen Sie Hilfe?

Microsoft Access kann die Daten nicht einfügen. Warum nicht?

Die eingefügten Daten befinden sich im falschen Feld. Warum?


Problembehandlung bei Unterdatenblättern

In meinem Unterdatenblatt wird kein Fremdschlüssel oder keine übereinstimmenden Felder angezeigt.

Das Datenblatt, das ein Unterdatenblatt enthält, wird anders angezeigt als bei der letzten Speicherung.

Auf meinem Unterdatenblatt werden für jede Zeile des Datenblattes dieselben Daten angezeigt.

Das Feld Verknüpfen nach wird leer angezeigt, wenn ich in einer Microsoft Access-Datenbank zu einer Abfrage ein Unterdatenblatt hinzufüge.

Ich habe in einer Access-Datenbank eine Beziehung zwischen zwei Tabellen definiert, es wird jedoch kein Unterdatenblatt angezeigt.


Problembehandlung bei Problemen mit Auswahlabfragen

Welches Problem liegt vor?

Die Abfrage gibt nicht die gewünschten Datensätze aus

Die Datensätze werden nicht in der gewünschten Reihenfolge angezeigt

Die Spalten sind nicht korrekt

Die Berechnungen in der Abfrage sind nicht korrekt

Ich kann die Daten in der Abfrage nicht aktualisieren

Obwohl die Abfrage den Mechanismus "AutoNachschlagen" verwendet, werden Daten nicht automatisch eingetragen

Ich benötige Hilfe beim Festlegen von Kriterien

Microsoft Access verknüpft automatisch zum Abfrageentwurfsbereich hinzugefügte Tabellen oder Abfragen, die nicht verknüpft werden sollen

Ich erhalte die Meldung "Abfrage enthält mehrdeutige Inklusionsverknüpfungen."

Es ist ein Fehler bezüglich der Unverträglichkeit von Datentypen aufgetreten

Die Abfrage ist zu langsam

Ich erhalte eine Aufforderung zur Eingabe eines Parameters, wo ich es nicht erwarte


Behandlung von Problemen mit Anfügeabfragen

Welches Problem liegt vor?

Die Abfrage gibt nicht die gewünschten Datensätze aus

Die Berechnungen in der Abfrage sind nicht korrekt

Die Anfügeabfrage hat Daten an oder von nicht erwünschte(n) Felder(n) angefügt

Es wird eine Meldung bezüglich einer Schlüsselverletzung angezeigt

Es wird eine Meldung bezüglich der Verletzung einer Gültigkeitsregel angezeigt

Ich erhalte eine Fehlermeldung über s_Generation

Ich benötige Hilfe beim Festlegen von Kriterien

Die Abfrage ist zu langsam


Problembehandlung bei Problemen mit Kreuztabellenabfragen

Welches Problem liegt vor?

Die Spaltenüberschriften werden nicht in der gewünschten Reihenfolge angezeigt, oder es sollen einige Überschriften ausgeschlossen werden

Eine oder mehrere Spaltenüberschriften werden in den Abfrageergebnissen in Form von "< >" angezeigt

Ich erhalte die Meldung "Der Bezug des Namens Name kann nicht erkannt werden"

Zeilen- oder Spaltenüberschriften enthalten nicht die korrekten Feldwerte

Die Abfrage gibt nicht die gewünschten Datensätze aus

Die Datensätze werden nicht in der gewünschten Reihenfolge angezeigt

Die Spalten sind nicht korrekt

Die berechneten Beträge sind nicht korrekt

Ich benötige Hilfe beim Festlegen von Kriterien in der Abfrage

Ich kann die Daten in der Abfrage nicht aktualisieren

Die Abfrage ist zu langsam


Behandlung von Problemen mit Löschabfragen

Welches Problem liegt vor?

Die Abfrage gibt nicht die gewünschten Datensätze aus

Die Löschabfrage hat Datensätze aus der falschen Tabelle gelöscht

Ich möchte nach dem Arbeiten mit dem Abfrage-Assistenten zur Duplikatsuche nur die doppelten Datensätze löschen

Ich benötige Hilfe beim Festlegen von Kriterien

Eine Meldung bezüglich einer Schlüsselverletzung wird angezeigt

Die Abfrage ist zu langsam


Behandlung von Problemen mit Tabellenerstellungsabfragen

Welches Problem liegt vor?

Die Abfrage gibt nicht die gewünschten Datensätze aus

Die Datensätze werden nicht in der gewünschten Reihenfolge angezeigt

Die Spalten sind nicht korrekt

Die Berechnungen in der Abfrage sind nicht korrekt

Ich benötige Hilfe beim Festlegen von Kriterien

Die Abfrage ist zu langsam


Behandlung von Problemen mit Parameterabfragen

Welches Problem liegt vor?

Ich erhalte unerwarteterweise eine Aufforderung zum Eingeben eines Parameters

Ich möchte mit einer Parameterabfrage optional alle Datensätze ausgeben

Ich erhalte die Meldung "Der Bezug des Namens Name kann nicht erkannt werden."

Ich erhalte die Meldung "n Parameter wurden erwartet, aber es wurden zu wenig Parameter übergeben."


Behandlung von Problemen mit Aktualisierungsabfragen

Welches Problem liegt vor?

Die Abfrage hat nicht die gewünschte Aktualisierung vorgenommen

Die Abfrage gibt nicht die gewünschten Datensätze aus

Ich benötige Hilfe beim Festlegen von Kriterien

Eine arithmetische Berechnung im Abfrageentwurfsbereich gibt einen Nullwert (leeren Wert) aus

Ich erhalte die Meldung "Operation muss eine aktualisierbare Abfrage verwenden."

Es wird eine Meldung bezüglich einer Schlüsselverletzung angezeigt

Es wird eine Meldung bezüglich der Verletzung einer Gültigkeitsregel angezeigt

Ich weiß nicht, wann ich Daten aus einer Abfrage aktualisieren kann

Die Abfrage ist zu langsam


Fehlerbehandlung bei Problemen mit Formularen

Wobei benötigen Sie Hilfe?

Wie funktioniert ein Formular? Sie benötigen einen Überblick.

Das Formular ist leer. Warum werden die Daten nicht angezeigt?

Warum können die Daten in einem Formular nicht bearbeitet werden?

Es sind nur die Daten einer Tabelle zu sehen. Wie können die Daten anderer Tabellen angezeigt werden?

Optimieren der Leistung des Formulars

Die Meldung "#Fehler" oder "#Name?" wird in einem Steuerelement angezeigt

Fehlerbehandlung bei Problemen mit einem Kombinations- oder Listenfeld in einem Formular

Fehlerbehandlung bei Problemen mit einem Unterformular in einem Formular

Fehlerbehandlung bei Problemen mit einer Optionsgruppe in einem Formular

Fehlerbehandlung bei Problemen mit Bildern oder anderen OLE-Objekten in einem Formular


Problembehandlung in Eigenschaftenfenstern in Formularen und Berichten

Wobei benötigen Sie Hilfe?

Warum ist das Eigenschaftenfenster leer, obwohl ein Steuerelement markiert wurde?

Steuerelemente wurden markiert. Warum werden nicht alle Eigenschaften dieser Steuerelemente im Eigenschaftenfenster angezeigt?

Steuerelemente wurden markiert, und die korrekten Eigenschaften werden im Eigenschaftenfenster angezeigt. Dennoch ist das Einstellungsfeld einer bestimmten Eigenschaft leer, obwohl in einem oder mehreren Steuerelementen Werte für diese Eigenschaft festgelegt wurden.

Warum stimmen die Eigenschafteneinstellungen des gebundenen Steuerelements nicht mit den Einstellungen für das Feld im Tabellenentwurf überein?

Das Eigenschaftenfenster kann in der Formular- oder Datenblattansicht nicht geöffnet werden.


 Problembehandlung beim Sortieren und Gruppieren in einem Bericht

Problembehandlung beim Sortieren und Gruppieren in einem Bericht

Wobei benötigen Sie Hilfe?

In einer Microsoft Access-Datenbank (.mdb) oder in einem Microsoft Access-Projekt (.adp):

Die Datensätze im Bericht sollen in derselben Reihenfolge gedruckt werden, in der sie in der zugrunde liegenden Tabelle oder in einer anderen Datenquelle angezeigt werden.

Die Datensätze in den Gruppen erscheinen nicht sortiert.

Der Gruppenkopf soll in der Zeile gedruckt werden, in der der erste Detaildatensatz erscheint.

Duplikatwerte, die in derselben Gruppe erscheinen, sollen ausgeblendet werden.

In einer Microsoft Access-Datenbank:

Die Datensätze sind nicht gemäß der Arbeitssprache sortiert.


Problembehandlung bei einem PivotTable-Formular

Wobei benötigen Sie Hilfe?

Ein Teil der Daten im PivotTable-Formular ist abgeschnitten, und es sind keine Bildlaufleisten vorhanden, um diesen Teil anzuzeigen

Ich kann in Microsoft Excel keine Änderungen vornehmen, obwohl ich auf die Schaltfläche zum Bearbeiten des PivotTable-Formulars geklickt habe

Das PivotTable-Formular enthält nicht die aktuellen Daten. Wie werden die Daten aktualisiert?

Das PivotTable-Objekt kann nicht gefunden werden, wenn Microsoft Excel nicht über das Formular, das dieses Objekt enthält, geöffnet wird


Fehlerbehandlung bei Problemen mit Unterformularen

Definition und Funktionsweise von Unterformularen

Alle Datensätze werden im Unterformular angezeigt. Sie ändern sich nicht, wenn im Hauptformular von Datensatz zu Datensatz gewechselt wird.

Die Fehlermeldung "#Fehler" oder "#Name?" wird angezeigt, wenn versucht wird, Daten aus dem Unterformular im Hauptformular anzuzeigen

Warum können im Unterformulardatenblatt keine Formularköpfe und -füße angezeigt werden?

Optimieren von Unterformularen


Problembehandlung bei Diagrammen in einem Formular oder Bericht

Wobei benötigen Sie Hilfe?

Das Diagramm in einem Formular oder Bericht wurde geändert. Warum werden die Änderungen nicht gespeichert?

Beim Öffnen des Diagramms in einem Formular oder Bericht wird die Meldung "Der Bezug des Namens Name kann nicht erkannt werden" angezeigt.

Das Diagramm in einem Formular oder Bericht wird abgeblendet angezeigt oder ist leer.

Warum kann das Format der Bezeichnungen im Diagramm im Formular oder Bericht nicht geändert werden?

Warum können die Spalten im Diagramm in einem Formular oder Bericht nicht in der gewünschten Reihenfolge angeordnet werden?


Beheben von Fehlern in den Optionen für Datenzugriffsseiten

Arbeiten mit Dateien und Verknüpfungen

Die unterstützenden Dateien für eine Datenzugriffsseite sollen nicht länger in einem Ordner gespeichert werden.

Nach dem Speichern einer Datenzugriffsseite auf einem Dateiserver können andere Benutzer diese nicht finden oder anzeigen.

Nach dem Verschieben einer Datenzugriffsseite an einen anderen Speicherort funktionieren einige Verknüpfungen nicht mehr.

Sicherungskopie einer Datenzugriffsseite kann nicht automatisch erstellt werden.

Der Name eines Ordners für unterstützende Dateien einer Datenzugriffsseite hat eine andere Sprache.

Benutzer können eine interaktive Datenzugriffsseite nicht öffnen.

Datenzugriffsseite kann nicht geöffnet werden.

Arbeiten mit Grafiken

In einer Datenzugriffsseite wird ein rotes X, eine leere Grafik oder gar keine Grafik angezeigt.

Grafiken und Text einer Datenzugriffsseite sehen auf einem anderen Computer anders aus.

Angeben der Sprache

Eine Datenzugriffsseite zeigt für die Sprache die falschen Zeichen an.

Weitere Informationen

Veröffentlichen von Datenzugriffsseiten und anderen Webseiten


Fehlerbehandlung beim Öffnen von Datenzugriffsseiten

Wobei benötigen Sie Hilfe?

Eine Datenzugriffsseite kann nicht angezeigt werden.

Die mit der Datenzugriffsseite verknüpfte HTML-Datei kann nicht gefunden werden.

Eine HTML-Datei in Access soll geöffnet werden, aber es wird ein anderes Office-Programm geöffnet.


Fehlerbehandlung beim Entwerfen von Datenzugriffsseiten

Wobei benötigen Sie Hilfe?

Die Datensätze wurden nicht wie gewünscht sortiert.

Das Euro-Symbol wird in einem Währung-Feld auf einer Datenzugriffsseite nicht dargestellt.

Eine der folgenden Meldungen erscheint

"Der Ausdruck ist unzulässig."

"Undefinierte Funktion in einem Ausdruck."

"Die von Ihnen eingegebene Einstellung ist für diese Eigenschaft nicht zulässig."

"Ungültiges Argument."

"Die Eigenschaft DefaultSort ist ungültig."

"Der Assistent läuft nur, wenn die aktuelle Datenbank die Datenquelle für Ihre Seite ist."


Fehlerbehandlung beim Arbeiten mit Datenzugriffsseiten in der Seitenansicht

Wobei benötigen Sie Hilfe?

In der Datensatznavigationsleiste fehlen Schaltflächen.

Die Felder auf der Datenzugriffsseite sind leer.

Die Daten in einem Feld in der Seitenansicht können nicht bearbeitet werden.

Eine Datenzugriffsseite kann als E-Mail-Nachricht gesendet werden, aber der Empfänger kann sie nicht lesen.

Bei dem Versuch, Daten in der Seitenansicht einzugeben, erscheint eine Meldung.

Anmerkung Die Datenzugriffsseite kann eine PivotTable-Liste oder ein Spreadsheet enthalten, die über eigene Fehlerbehandlungsinformationen verfügt. Um weitere Informationen zu erhalten, klicken Sie in der Symbolleiste der PivotTable-Liste oder des Spreadsheet auf Hilfe [image], und suchen Sie nach "Fehlerbehandlung".


Fehlerbehandlung bei einer Gruppe von Steuerelementen in einem Formular oder Bericht

Wobei benötigen Sie Hilfe?

Ich kann Textfelder oder andere Steuerelemente nicht gruppieren.

Ich kann die Gruppierung ausgewählter Textfelder oder anderer Steuerelemente nicht aufheben.


Fehlerbehandlung bei bedingter Formatierung eines Textfeldes oder eines anderen Steuerelements in einem Formular oder Bericht

Wobei benötigen Sie Hilfe?

Die für ein Steuerelement festgelegte, bedingte Formatierung ändert sich nicht erwartungsgemäß.

Access wendet die bedingte Formatierung für ein Steuerelement in meinem Formular oder Bericht nicht korrekt an.


Fehlerbehandlung bei Problemen mit Listenfeldern, Dropdownlisten und Kombinationsfeldern

Definition und Funktionsweise von Listenfeldern.

Definition und Funktionsweise von Kombinationsfeldern und Dropdownlisten.

Das Listenfeld, Kombinationsfeld oder die Dropdownliste ist nicht wunschgemäß sortiert.

Der im Kombinationsfeld angezeigte Text ist aus der falschen Spalte. Wie können Daten aus anderen Spalten angezeigt werden?

Beim Auswählen eines Listenwertes wird dieser ausgeblendet, oder es wird eine Meldung angezeigt.

Warum kann kein Wert aus dem Listenfeld, Kombinationsfeld oder der Dropdownliste ausgewählt werden?

Das Kombinationsfeld bzw. die Dropdownliste enthält die Meldung "#Fehler?" bzw. ist leer.

Es soll auf eine andere Spalte als die gebundene im Listen- oder Kombinationsfeld verwiesen werden.

Warum kann kein neuer Wert in das Kombinationsfeld eingegeben werden?

Warum wird ein in das Kombinationsfeld eingegebener Wert nicht zu der Liste hinzugefügt?

Optimieren von Listenfeldern, Dropdownlisten oder Kombinationsfeldern.


Fehlerbehandlung bei Problemen mit Optionsgruppen

Definition und Funktionsweise von Optionsgruppen

Ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld wurde hinzugefügt, aber die Optionsgruppe ist nicht funktionsfähig.


Fehlerbehandlung bei Problemen mit Bildern und anderen OLE-Objekten in Formularen und Berichten

Welcher Unterschied besteht zwischen ungebundenen und gebundenen, eingebetteten und verknüpften Objekten?

Beim Doppelklicken auf ein verknüpftes oder eingebettetes Objekt wird die Meldung "Datei kann nicht geöffnet werden" angezeigt

Anstelle des Inhalts eines Objekts in einem Formular oder Bericht wird ein Symbol angezeigt

Das Bild erscheint verzerrt, wenn die Größe angepasst wird

Warum ist die Farbwiedergabe in dem Bild oder Formular so schlecht?

Warum vergrößert sich die Datenbank um wesentlich mehr als die Größe des hinzugefügten Objekts?


Problembehandlung bei Ausdrücken

Wobei benötigen Sie Hilfe?

Wie werden Ausdrücke verwendet? Anzeigen einer Übersicht.

Das Kriterienargument der Funktion DLookup oder einer anderen Aggregatfunktion für Domänen liefert unerwartete Ergebnisse.

Beim Kombinieren (Verketten) von Steuerelement- oder Feldwerten, Variablen oder Text in einem Ausdruck treten unerwartete Ergebnisse auf.

Beim Durchführen von Operationen in Feldern mit leeren Werten treten unerwartete Ergebnisse auf.

Beim Eingeben von Datumswerten in einen Ausdruck treten unerwartete Ergebnisse auf.

Beim Verweisen auf eine Eigenschaft oder ein Steuerelement in einem Unterformular oder Unterbericht treten unerwartete Ergebnisse auf.

Beim Verweisen auf Spalten in einem Listen- oder Kombinationsfeld treten unerwartete Ergebnisse auf.

Wie wird Text konvertiert, damit der erste Buchstabe in Großbuchstaben erscheint?


Fehlerbehandlung bei Makros

Wobei benötigen Sie Hilfe?

Ich benötige einen Überblick über die Funktionsweise von Makros.

Wie finde ich die Stellen in einem Makro, an denen Probleme auftreten?

Welches Ereignis muss ich einem Makro für eine bestimmte Aufgabe hinzufügen?

Wie wird eine Aktion in einem Makro vorübergehend deaktiviert?

Das Argument Bedingung in der Aktion ÖffnenFormular oder ÖffnenBericht erzeugt unerwartete Ergebnisse.

Die Aktion AusführenCode führt kein Visual Basic-Modul aus.

Microsoft Access zeigt beim Ausführen von Makros unerwünschte Meldungen an.

Tastenanschläge, die in einem Makro mit der Aktion Tastaturbefehle verwendet werden, werden nicht an das Dialogfeld gesendet.


Fehlerbehandlung bei Visual Basic-Modulen

Wobei benötigen Sie Hilfe?

Wie können Probleme, die im Visual Basic-Code auftreten, ermittelt werden?

Bei Verwendung des Kriterienarguments in einer DomWert-Funktion oder einer anderen Domänen-Aggregatfunktion treten unerwartete Ergebnisse auf.

Microsoft Access zeigt beim Ausführen von Code unerwünschte Meldungen an.

Wie wird Microsoft Visual Basic verwendet, um einen neuen Datensatz zu einer Tabelle hinzuzufügen?

Beim Verwenden einer Find-Methode treten unerwartete Ergebnisse auf.

Erstellte Sub-Prozedur oder Funktion testen.

Beim Verwenden der IsLoaded-Funktion erhalte ich die Meldung "Sub oder Funktion nicht definiert".

Beim Verweisen auf ein Tabellenfeld im Code erhalte ich die Meldung "Methode oder Datenelement nicht gefunden".

Wie wird Visual Basic zum Ändern der einer Abfrage zugrunde liegenden SQL-Anweisung verwendet?


 Problembehandlung bei verknüpften Tabellen in einer Microsoft Access-Datenbank

Problembehandlung bei verknüpften Tabellen in einer Microsoft Access-Datenbank

Anmerkung Die Verknüpfung einer Tabelle kann nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt erfolgen.

Wobei benötigen Sie Hilfe?

Warum kann eine verknüpfte Microsoft Visual FoxPro- oder dBASE-Tabelle nicht geöffnet oder aktualisiert werden?

Warum kann eine verknüpfte Paradox-Tabelle nicht geöffnet oder aktualisiert werden?

Warum kann eine verknüpfte SQL-Tabelle nicht geöffnet oder aktualisiert werden?

Warum geben meine Abfragen bei Verwendung verknüpfter Tabellen andere Ergebnisse aus?

Warum geben meine Filter bei Verwendung verknüpfter Tabellen andere Ergebnisse aus?

Warum erhalte ich bei dem Versuch, eine verknüpfte Tabelle zu öffnen, die Meldung "Die Datei '<Dateiname>' konnte nicht gefunden werden"?


Fehlerbehandlung beim Importieren von Text oder Kalkulationstabellen

Wobei benötigen Sie Hilfe?

Warum werden beim Importieren einer Kalkulationstabelle oder Textdatei Fehler gemeldet?

Warum werden beim Anfügen einer Kalkulationstabelle oder Textdatei Fehler gemeldet?


 Beim Öffnen einer Tabelle oder eines Formulars in einer konvertierten Datenbank wird ein ODBC-Fehler gemeldet

Beim Öffnen einer Tabelle oder eines Formulars in einer konvertierten Datenbank wird ein ODBC-Fehler gemeldet

Der Fehler "ODBC - Verbindung mit Datenquellenname fehlgeschlagen" tritt auf, wenn eine Tabelle in einer konvertierten Microsoft Access-Datenbank der Version 1.x oder 2.0 mit einer ODBC-Datenquelle verknüpft ist, die einen 16-Bit-Treiber-Manager und -Treiber verwendet. Microsoft Access 2000 kann nur verknüpfte ODBC-Datenquellen öffnen, welche die 32-Bit-Versionen des ODBC-Treiber-Managers (ODBC32.DLL) und den entsprechenden ODBC-Treiber verwenden, z. B. die 32-Bit-Version des Microsoft SQL Server ODBC-Treibers (SQLSRV32.DLL).

Um dieses Problem zu beheben, müssen Sie einen neuen identischen 32-Bit-Datenquellennamen (DSN = Data Source Name) für jede ODBC-Datenquelle erstellen, die mit der Originaldatenbank der Version 1.x oder 2.0 verknüpft ist.

  1. Klicken Sie in der Windows-Taskleiste auf die Schaltfläche Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf das Symbol ODBC (32-Bit) (in Microsoft Windows 95 oder höher) bzw. auf das Symbol ODBC (in Microsoft Windows NT Workstation 4.0 oder höher).

  3. Erstellen Sie den neuen Datenquellennamen, indem Sie Werte eingeben, die mit dem ursprünglichen Datenquellennamen identisch sind. Sie müssen z. B. für Microsoft SQL Server mindestens Datenquellenname und Server und eventuell auch zusätzliche Werte, wie z. B. einen Wert für Datenbankname definieren. Weitere Informationen über Datenquellen.

Wenn Sie den ursprünglichen Datenquellennamen nicht genau wissen, öffnen Sie die Originaldatenbank in der Microsoft Access-Version, in der sie erstellt wurde. Öffnen Sie die verknüpfte Tabelle in der Entwurfsansicht, und zeigen Sie dann das Eigenschaftenfenster Tabelleneigenschaften an. Die Eigenschaft Beschreibung der Tabelle enthält die Definition für die ODBC-Verbindungszeichenfolge. Der Parameter hinter DSN= in der Verbindungszeichenfolge ist der Datenquellenname. Um die restliche Definition des Datenquellennamens anzuzeigen, öffnen Sie die Windows-Systemsteuerung in Windows 95 oder höher, und doppelklicken Sie auf das Symbol ODBC (nicht auf das Symbol ODBC (32-Bit)). Klicken Sie in der Liste Datenquelle (Treiber) auf den Datenquellennamen und dann auf Konfigurieren, um die Definition des Datenquellennamens anzuzeigen.


Fehlerbehandlung beim Drucken und Anzeigen von Bericht-Snapshots

Wobei benötigen Sie Hilfe?

Ich kann einen Bericht-Snapshot nicht öffnen.

Bei dem Versuch, einen Bericht-Snapshot zu drucken, erhalte ich die Webseite an Stelle des Berichts.

Ich kann einen Bericht-Snapshot nicht in einer E-Mail senden.


Wie lautet die Registrierungs-ID?

Nachdem Microsoft die Registrierungsinformationen empfangen und geprüft hat, erhalten Sie über dieselbe Methode, mit der Sie die Registrierung durchgeführt haben, eine Registrierungs-ID (es sei denn, Sie haben sich über das Internet registriert. In diesem Fall benötigen Sie keine Registrierungs-ID). Beim nächsten Start von Microsoft Access oder eines anderen Microsoft Office-Programms werden Sie aufgefordert, die Registrierungs-ID einzugeben, um den Registrierungsprozess zu vervollständigen. Wenn Sie bis zu dem Zeitpunkt, an dem Sie Access oder Office erneut starten, keine Registrierungs-ID empfangen haben, können Sie den Registrierungsprozess telefonisch vervollständigen.


Microsoft Access oder Microsoft Office können nicht registriert werden

Sie haben keine Registrierung durchgeführt In einigen Ländern ist keine Registrierung erforderlich. Wenn Sie keine Registrierung durchführen müssen, haben Sie beim ersten Start von Access oder einem anderen Office-Programm die Möglichkeit, ein elektronisches Registrierungsformular auszufüllen und über eine Internet- oder E-Mail-Verbindung an Microsoft zurück zu senden. Wenn Sie keine Internet- oder E-Mail-Verbindung haben, können Sie das Formular drucken und per Post oder Fax an Microsoft schicken. Bei Befolgen der Anweisungen des Office-Registrierungsassistenten können Sie sich auch telefonisch registrieren. Die einzige Möglichkeit, das elektronische Registrierungsformular auszufüllen, ist beim ersten Start von Access oder einem anderen Microsoft Office-Programm. Wenn Sie zu diesem Zeitpunkt keine Registrierung durchführen, bietet die Microsoft Office Update-Website die einzige andere Möglichkeit der Registrierung.

Auf dem Computer ist ggf. kein Internet- oder E-Mail-Konto eingerichtet Um das Registrierungsformular auf elektronischem Weg zu Microsoft zurücksenden zu können, benötigen Sie ein Modem und ein Internet- oder E-Mail-Konto. Sie erhalten ein Konto über einen Internetdienstanbieter oder das Unternehmensnetzwerk. Wenn Sie keine Internet- oder E-Mail-Verbindung haben, können Sie das Formular drucken und per Post oder Fax an Microsoft schicken. Bei Befolgen der Anweisungen des Office-Registrierungsassistenten können Sie sich auch telefonisch registrieren. Wenn Sie in einer Region leben, in der keine Registrierung erforderlich ist und keine Registrierung beim ersten Start von Access oder einem anderen Office-Programm durchgeführt haben, bietet die Microsoft Office Update-Website die einzige andere Registrierungsmöglichkeit.

Das Netzwerk ist ggf. ausgelastet Überprüfen Sie die Netzwerkverbindung, und versuchen Sie, das Registrierungsformular später zurück zu senden, wenn die Netzwerkaktivität geringer ist. Sie können das Formular auch drucken und per Post oder Fax an Microsoft schicken. Bei Befolgen der Anweisungen des Office-Registrierungsassistenten können Sie sich auch telefonisch registrieren. Wenn Sie in einer Region leben, in der keine Registrierung erforderlich ist und keine Registrierung beim ersten Start von Access oder einem anderen Office-Programm durchgeführt haben, bietet die Microsoft Office Update-Website die einzige andere Möglichkeit der Registrierung.


 Das Erscheinungsbild der servergenerierten HTML-Dateien entspricht nicht den Erwartungen, wenn sie in einem Webbrowser angezeigt werden.

Das Erscheinungsbild der servergenerierten HTML-Dateien entspricht nicht den Erwartungen, wenn sie in einem Webbrowser angezeigt werden.

Wenn Sie ein Datenblatt in ein ASP- oder IDC/HTX-Ausgabeformat exportieren, sehen Sie die tatsächlichen Daten der dem Datensatz zugrunde liegenden Datensatzgruppe, wenn Sie die .ASP- oder .HTX-Datei in einem Webbrowser anzeigen. Standardmäßig speichert Microsoft Access Text- und Memofelder mit linker Ausrichtung, alle anderen unterstützten Datentypen mit rechter Ausrichtung.

Bei Ausgabe eines Datenblatts gibt Microsoft Access keine OLE-Objekte oder die entsprechenden Werte aus einem Nachschlagefeld aus. Die Einstellungen für die Eigenschaften SortiertNach, Filter, Format oder Eingabeformat werden ignoriert.

Soll das Erscheinungsbild der servergenerierten HTML-Dateien dem Datenblatt in einer Microsoft Access-Datenbank entsprechen, können Sie eine Abfrage erstellen und exportieren, die über dieselbe Datensatzgruppe verfügt wie das Datenblatt. Führen Sie beim Erstellen der Abfrage folgende Schritte durch:

  • Verwenden Sie das Feld Sortieren im Abfrageentwurfsbereich, um die Daten zu sortieren. Siehe auch Sortieren in einer Abfrage.

  • Verwenden Sie das Feld Kriterien im Abfrageentwurfsbereich, um die Daten zu filtern. Siehe auch Verwenden von Kriterien in einer Abfrage.

  • Verwenden Sie die Funktion Format, um die Felder zu formatieren, z.B. Währung, Datum/Uhrzeit und Ja/Nein. Siehe auch Verwenden der Funktion Format.

  • Erstellen Sie eine AutoNachschlage-Abfrage, um die Werte aus einer Nachschlageliste anzuzeigen. Siehe auch Erstellen einer AutoNachschlage-Abfrage, die automatisch Daten in neue Datensätze eingibt.


Die Befehle "Mailempfänger" und "Mailempfänger (als Anlage)" werden im Untermenü "Senden an" (Menü "Datei") nicht angezeigt.

Stellen Sie sicher, dass Sie eines der folgenden Produkte installiert haben, oder wenden Sie sich an Ihren Administrator, damit dieser das entsprechende Programm für Sie installiert:

  • Microsoft Exchange

  • Microsoft Outlook 2000

  • Outlook Express, Version 5.0


Problembehandlung beim Zusammenstellen und Einfügen

Ich kann keine weiteren Elemente zur Office-Zwischenablage hinzufügen.

Die Symbolleiste der Zwischenablage wird nicht mehr angezeigt, wenn ich Elemente kopieren und einfüge.

Die Symbolleiste der Zwischenablage ist nicht verfügbar.

Die Schaltfläche Alle einfügen ist nicht verfügbar.


Beheben von Fehlern bei Onlinebesprechungen

Wobei benötigen Sie Hilfe?

Während einer Onlinebesprechung kann eine Access-Datenbank, ein Access-Projekt oder eine Datenzugriffsseite nicht auf dem lokalen Drucker gedruckt bzw. auf der Festplatte gespeichert werden.

Andere Teilnehmer einer Onlinebesprechung sehen auf dem Bildschirm ein Kreuzschraffurzeichen.

Elemente, die anderen Teilnehmern der Onlinebesprechung angezeigt werden, werden nicht angezeigt.

Der Name eines Teilnehmers, der zu einer Onlinebesprechung eingeladen werden soll, ist nicht in der Liste enthalten.

Mit welchem NetMeeting-Verzeichnisserver soll eine Verbindung hergestellt werden ?


Problembehandlung beim Office-Assistenten

Wobei benötigen Sie Hilfe?

Der Office-Assistent stört.

Der Office-Assistent zeigt nicht das gewünschte Hilfethema an.

Die Sprechblase des Office-Assistenten ist verschwunden.


Fehlerbehebung in Symbolleisten, Menüleisten und Kontextmenüs

Wobei benötigen Sie Hilfe?

Meine eingebauten Symbolleisten und Menüs sind verschwunden. Wie bekomme ich diese zurück?

Ich habe Änderungen an den in Microsoft Access eingebauten Symbolleisten vorgenommen. Wie kann ich diese zurücksetzen?

Ich habe den Befehl Symbolleisten aus dem Menü Ansicht oder das Menü Ansicht aus der Menüleiste entfernt. Wie kann ich das Dialogfeld Anpassen anzeigen oder den Befehl Symbolleisten oder das Menü Ansicht zurückerhalten?

Ich habe Probleme beim Einfügen oder Zurücksetzen eines Symbolbilds in einem Menü oder in einer Symbolleiste.

Warum kann ich die Symbolleiste nicht anpassen?

Warum ist die Symbolleiste abgeschnitten?

Warum kann ich eine Symbolleiste, eine Menüleiste oder ein Kontextmenü nicht ein- oder ausblenden?

Menüs sollen so angezeigt werden wie in Microsoft Office 97.

Ich kann einen Menübefehl, eine Symbolleistenschaltfläche oder eine Dialogfeldoption nicht finden.

Kurzmenüs sollen sich nicht automatisch erweitern.


Fehlerbehebung beim Verwenden der persönlichen Einstellungen auf einem anderen Computer

Beim Anmelden stehen die persönlichen Einstellungen nicht zur Verfügung.

Benutzerdefinierte Vorlagen werden in der falschen Registerkarte angezeigt.


Fehlerbehandlung bei Hyperlinks

Eine Datei kann nicht über das Internet geöffnet werden.

Wenn auf einen Hyperlink geklickt wird, wird eine Fehlermeldung angezeigt.


Eingabehilfen für Microsoft Access

Access enthält Möglichkeiten für Eingabehilfen, die blinden Personen oder Personen mit stark eingeschränkter Seh- oder Bewegungsfähigkeit die Verwendung erleichtern. Informationen zu Eingabehilfen.

Was möchten Sie tun?

Tastatur an Stelle der Maus verwenden

Tastenkombinationen verwenden

Beziehungen unter Verwendung der Tastatur verwalten

Ein Textfeld oder ein anderes Steuerelement mit Hilfe der Tastatur in einem Formular oder Bericht platzieren

Ein Textfeld oder ein anderes Steuerelement mit Hilfe der Tastatur auf einer Datenzugriffsseite platzieren

Ein Textfeld oder ein anderes Steuerelement mit Hilfe der Tastatur in einem Formular oder Bericht kopieren

Spalten in der Datenblattansicht mit Hilfe der Tastatur neu anordnen

Symbolleisten und Menüs anpassen

Die Größe aller Symbolleistenschaltflächen auf einmal ändern

Symbolleistenschaltflächen, Menübefehle oder Menüs mit Hilfe von Trennlinien in Gruppen anordnen

Eine benutzerdefinierte Symbolleiste für die aktuelle Datenbank erstellen

Eine benutzerdefinierte Symbolleiste für alle Datenbanken erstellen

Schriften und Hintergrundfarben in einem Hilfethema ändern

Textfelder oder andere Steuerelemente anpassen

Benutzerdefinerte Farben für einen Bereich oder ein Steuerelement in einem Formular oder Bericht erstellen

Die Hintergrundfarbe eines Steuerelements oder Bereichs ändern

Daten eingeben

Wiederkehrende Eingaben in einer Spalte mit Hilfe der Tastatur einfügen

Access Text automatisch korrigieren lassen

Zusätzliche Dienste

Weitere Informationen zu Eingabehilfen im World Wide Web erhalten


Info über Eingabehilfen für Personen mit Behinderungen

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Eingabehilfen in Microsoft Access

Anpassen des Betriebssystems

Gedruckte Informationen zu Microsoft-Diensten

Eingabehilfen in Microsoft Access

Personen mit Behinderungen können mit Hilfe der folgenden Methoden die Eingabehilfen von Access nutzen:

  • Zeigen Sie Listen aller verfügbaren Tastenkombinationen an und drucken Sie diese aus.

  • Verwenden Sie die Tastatur, um Beziehungen zu definieren, Textfelder oder andere Steuerelemente auf Formularen und Berichten zu kopieren oder hinzuzufügen und um Spalten in der Datenblattansicht neu anzuordnen.

  • Erstellen Sie für die aktuelle Datenbank oder für alle Datenbanken eine Symbolleiste, die nur die Schaltflächen und Menüs enthält, die Sie am Häufigsten verwenden. Sie können auch Schaltflächen vergrößern und zusammengehörige Schaltflächen gruppieren.

  • Stellen Sie Menüs so ein, dass wie in Microsoft Office 97 immer alle Befehle angezeigt werden. Sie können auch festlegen, dass die Symbolleisten wie in Office 97 angezeigt werden.

  • Definieren Sie benutzerspezifische Farben oder ändern Sie die Hintergrundfarbe eines Abschnitts oder eines Steuerelements auf einem Formular oder Bericht.

  • Fügen Sie mit Hilfe der Tastatur sich wiederholende Einträge schnell in eine Spalte ein.

  • Geben Sie an, dass häufige Tippfehler automatisch korrigiert werden sollen, und geben Sie darüber hinaus eine Liste der Fehler an, die beim Tippen automatisch korrigiert werden sollen.

Informationen über weitere Eingabehilfe in Access.

Zurück zum Anfang

Anpassen des Betriebssystems

Wenn Sie auf Ihrem Computer Microsoft Windows 95 ausführen, können Sie die Eingabehilfen des Systems einstellen oder ändern. Sie können zum Beispiel die Tastaturmaus-Funktion von Windows verwenden, um über den Ziffernblock den Mauszeiger zu bewegen, zu klicken, doppelzuklicken und Objekte zu ziehen. Zum Ändern der Eingabehilfen drücken Sie STRG+ESC, um in Windows das Menü Start zu öffnen. Wählen Sie Einstellungen und dann Systemsteuerung. Markieren Sie das Symbol Eingabehilfen, drücken Sie STRG+TAB, um die gewünschte Registerkarte auszuwählen, und wählen Sie dann mit Hilfe der Tastatur die gewünschten Optionen aus. Wenn Sie Hilfe zu einer Option benötigen, markieren Sie diese Option und drücken Sie dann UMSCHALT+F1.

Wenn Sie Zugriff auf das World Wide Web haben, können Sie die Infos über das Verwenden von Eingabehilfen lesen, die in Betriebssystemen und anderen Produkten von Microsoft enthalten sind.

Zurück zum Anfang

Gedruckte Informationen zu Microsoft-Diensten

Weitere und umfassendere Informationen zu Microsoft-Diensten für Personen mit Behinderungen ist in einem Anhang des Buchs Entdecken Sie Microsoft Office 2000 enthalten, das zusammen mit Office 2000 erhältlich ist. Sie finden dort zum Beispiel Informationen dazu, wie Gehörlose oder Hörgeschädigte Kontakt mit dem Microsoft Support Network aufnehmen können. Sie finden dort auch Informationen, wie Sie Dokumentation von Microsoft von Recording for the Blind & Dyslexic, Inc., für die Menschen erhalten können, die Schwierigkeiten beim Lesen oder beim Umgang mit gedruckten Dokumenten haben. Dieser Anhang enthält darüber hinaus eine Beschreibung von Hardware- und Softwareprodukten von Drittanbietern, die es Personen mit Behinderungen erleichtern, einen Computer zu benutzen. Außerdem werden Organisationen aufgelistet, über die Sie weitere Informationen erhalten können.

Zurück zum Anfang


 Tastenkombinationen

Tastenkombinationen

Für schnellen Zugriff auf häufig verwendete Befehle oder Operationen können Sie Tastenkombinationen verwenden. In den unten aufgeführten Themen finden Sie die in Microsoft Access verfügbaren Tastenkombinationen. Sie können auch Zugriffstasten verwenden, um den Fokus auf ein Menü, einen Befehl oder ein Steuerelement zu bewegen, ohne eine Maus zu benutzen. Informationen über die Durchführung von Aufgaben mit Zugriffstasten.

Diese Seite enthält Hyperlinks zu Themen aus folgenden Bereichen:

Allgemeine Tastenkombinationen

Tastenkombinationen zum Arbeiten mit Text und Daten

Tastenkombinationen zum Navigieren in Datensätzen

Tastenkombinationen zum Arbeiten in Datenzugriffsseiten

Welche Tastenkombinationen möchten Sie verwenden?

Allgemeine Tastenkombinationen

Globale Tastenkombinationen in Microsoft Access

Datenbankfenster-Tastenkombinationen

Mit Menüs arbeiten

Mit Symbolleisten arbeiten

In Fenstern und Dialogfeldern arbeiten

Mit den Dialogfeldern Öffnen, Neue Datenbankdatei und Speichern arbeiten

Hilfe vom Office-Assistenten anfordern

Mit dem Hilfefenster arbeiten

E-Mail-Nachrichten versenden

Zurück zum Anfang

Tastenkombinationen zum Arbeiten mit Text und Daten

Text und Daten auswählen

Text und Daten bearbeiten

Zurück zum Anfang

Tastenkombinationen zum Navigieren in Datensätzen

In der Datenblattansicht navigieren

In Unterdatenblättern navigieren

In der Formularansicht navigieren

In der Seitenansicht und in der Layout-Vorschau navigieren

Im Datenbank-Diagrammfenster in einem Microsoft Access-Projekt navigieren

Im Abfragedesigner in einem Microsoft Access-Projekt navigieren

Zurück zum Anfang

Tastenkombinationen zum Arbeiten in Datenzugriffsseiten

Mit Datenzugriffsseiten in der Datenzugriffsseitenansicht arbeiten

Mit Datenzugriffsseiten in der Entwurfsansicht arbeiten

Mit PivotTable-Listen arbeiten

Mit einer Kalkulationstabelle arbeiten

Zurück zum Anfang

Anmerkung Um Informationen über Tastenkombinationen für den Visual Basic-Editor zu erhalten, öffnen Sie den Editor, und starten Sie die Visual Basic-Editor-Hilfe. Drücken Sie im Hilfefenster STRG+TAB, um die Registerkarte Inhalt auszuwählen. Wählen Sie Hilfe zur Visual Basic-Benutzeroberfläche, und drücken Sie EINGABE. Wählen Sie dann Tastenkombinationen, und drücken Sie EINGABE. Wählen Sie schließlich das gewünschte Thema aus, und drücken Sie EINGABE.


 Kopieren eines Textfeldes oder eines anderen Steuerelements in einem Formular oder Bericht mit der Tastatur

Kopieren eines Textfeldes oder eines anderen Steuerelements in einem Formular oder Bericht mit der Tastatur

  1. Drücken Sie ALT.

  2. Drücken Sie STRG+TAB, bis das Kombinationsfeld Objekt in der Symbolleiste Formatierung (Formular/Bericht) den Fokus hat, und drücken Sie anschließend die EINGABETASTE.

  3. Drücken Sie F4, um das Kombinationsfeld Objekt zu öffnen.

  4. Drücken Sie die NACH-UNTEN-TASTE, um das Steuerelement auszuwählen. Drücken Sie anschließend die EINGABETASTE.

  5. Drücken Sie STRG+C, um das Steuerelement in die Zwischenablage zu kopieren.

  6. Wiederholen Sie die Schritte 1 bis 3, um das Kombinationsfeld Objekt zu öffnen.

  7. Drücken Sie die NACH-UNTEN-TASTE, um den Bereich auszuwählen. Drücken Sie anschließend die EINGABETASTE.

  8. Drücken Sie STRG+V, um das Steuerelement in der oberen linken Ecke des Bereichs einzufügen. Zum Einfügen mehrerer Kopien drücken Sie wiederholt STRG+V.

  9. Zum Anpassen der Position des Steuerelements mit Eigenschafteneinstellungen markieren Sie das Steuerelement, und drücken Sie ALT+V+P, um das Eigenschaftenfenster des Steuerelements anzuzeigen. Drücken Sie STRG+TAB, um die Registerkarte Alle auszuwählen. Passen Sie die Eigenschafteneinstellungen Links und Oben an, um das Steuerelement an die gewünschte Position im Formular oder Bericht zu verschieben, und drücken Sie dann ALT+F4, um das Eigenschaftenfenster zu schließen.

    Sie können auch STRG+PFEIL drücken, um das Steuerelement manuell zu verschieben. Drücken Sie UMSCHALT+PFEIL, um die Größe des Steuerelements zu ändern. Informationen über Tastenkombinationen zum Bearbeiten von Steuerelementen anzeigen.


 Ablegen eines Textfeldes oder eines anderen Steuerelements auf einer Datenzugriffsseite unter Verwendung der Tastatur

Ablegen eines Textfeldes oder eines anderen Steuerelements auf einer Datenzugriffsseite unter Verwendung der Tastatur

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Drücken Sie ALT.

  3. Drücken Sie STRG+TAB, um den Fokus auf die Toolbox zu setzen.

    Anmerkung Wenn die Toolbox nicht angezeigt ist, drücken Sie die Tastenkombination ALT+A+X.

  4. Drücken Sie wiederholt TAB, bis das gewünschte Steuerelement ausgewählt ist.

  5. Drücken Sie UMSCHALT+EINGABETASTE, um das Steuerelement an der oberen linken Ecke des ausgewählten Bereichs hinzuzufügen.

  6. Stellen Sie sicher, dass das Steuerelement noch ausgewählt ist, und drücken Sie dann die Tastenkombination ALT+A+G, um das Eigenschaftenfenster des Steuerelements anzuzeigen. Drücken Sie dann STRG+TAB, um die Registerkarte Alle auszuwählen.

  7. Passen Sie die Eigenschafteneinstellungen Links und Oben so an, dass das Steuerelement an die gewünschte Stelle im Formular oder Bericht geschoben wird, und drücken Sie dann ALT+F4, um das Eigenschaftenfenster zu schließen. Alternativ können Sie das Steuerelement auch manuell unter Verwendung vorn STRG+der entsprechenden Pfeiltaste verschieben. Weitere Informationen zu Tastenkombinationen zum Bearbeiten von Steuerelementen.


 Verwenden der Tastatur zum Ablegen eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht

Verwenden der Tastatur zum Ablegen eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht

  1. Drücken Sie ALT.

  2. Drücken Sie zweimal STRG+TAB, um den Fokus auf die Toolbox zu setzen.

    Anmerkung Falls die Toolbox nicht angezeigt wird, drücken Sie auf STRG+UMSCHALT+F10, um das Kontextmenü für die Symbolleiste einzublenden. Wählen Sie mit Hilfe der NACH-UNTEN-TASTE die Option Toolbox aus, und drücken Sie die EINGABETASTE.

  3. Drücken Sie so oft TAB, bis das gewünschte Steuerelement ausgewählt ist.

  4. Drücken Sie UMSCHALT+EINGABETASTE, um das Steuerelement in der oberen linken Ecke des Detailbereichs im Formular oder Bericht hinzuzufügen.

  5. Stellen Sie sicher, dass das Steuerelement noch markiert ist, und drücken Sie dann ALT+A+I, um das Eigenschaftenfenster des Steuerelements anzuzeigen. Drücken Sie anschließend STRG+TAB, um die Registerkarte Alle auszuwählen.

  6. Passen Sie die Einstellungen der Eigenschaften Linksbündig und Oben so an, dass das Steuerelement an der gewünschten Position auf dem Formular oder Bericht angeordnet wird, und drücken Sie dann ALT+F4, um das Eigenschaftenfenster zu schließen. Alternativ dazu können Sie das Steuerelement auch mit STRG+PFEILTASTE manuell bewegen und mit UMSCHALT+PFEILTASTE in der Größe verändern. Durch Klicken erfahren Sie mehr über Tastenkombinationen zum Bearbeiten von Steuerelementen.

Hier erfahren Sie mehr über das Kopieren von Steuerelementen in Formularen oder Berichten mit Hilfe der Tastatur.


 Neuanordnen von Spalten in der Datenblattansicht unter Verwendung der Tastatur

Neuanordnen von Spalten in der Datenblattansicht unter Verwendung der Tastatur

  1. Setzen Sie die Einfügemarke auf ein Feld in der Spalte des Datenblattes oder Unterdatenblattes, die Sie verschieben möchten. Informationen über Navigieren in einem Datenblatt oder Navigieren zwischen einem Datenblatt und einem Unterdatenblatt anzeigen.

  2. Wenn das gesamte Feld nicht bereits markiert ist, drücken Sie F2.

  3. Um die gesamte Spalte zu markieren, drücken Sie STRG+LEERTASTE. Sie können mehrere Spalten markieren, indem Sie UMSCHALT+NACH-LINKS oder UMSCHALT+NACH-RECHTS drücken. (Sie müssen dies tun, bevor Sie in den Verschieben-Modus wechseln.)

  4. Drücken Sie STRG+UMSCHALT+F8, um zum Bewegungsmodus zurückzukehren.

  5. Zum Verschieben der Spalte nach rechts drücken Sie die NACH-RECHTS-TASTE.

    Zum Verschieben der Spalte nach links drücken Sie die NACH-LINKS-TASTE.

  6. Zum Deaktivieren des Bewegungsmodus drücken Sie ESC.


 Definieren von Beziehungen mit Hilfe der Tastatur

Definieren von Beziehungen mit Hilfe der Tastatur

  1. Schließen Sie alle geöffneten Tabellen. Für geöffnete Tabellen können Sie keine Beziehungen definieren oder bearbeiten.

  2. Falls noch nicht erfolgt, wechseln Sie zum Datenbankfenster. Mit F11 wechseln Sie von einem beliebigen Fenster zum Datenbankfenster.

  3. Drücken Sie ALT+X, um das Menü Extras auszuwählen, und drücken Sie dann H, um das Fenster Beziehungen zu öffnen.

  4. Wenn für die Datenbank noch keine Beziehungen definiert sind, wird das Dialogfeld Tabelle anzeigen automatisch angezeigt. Wenn Sie die Tabellen, für die eine Beziehung hergestellt werden soll, erst noch hinzufügen müssen, und wenn das Dialogfeld Tabelle anzeigen nicht angezeigt wird, drücken Sie ALT+Z, um das Menü Beziehungen auszuwählen. Drücken Sie dann T, um das Dialogfeld Tabelle anzeigen zu öffnen. Wenn die Tabellen, für die Sie eine Beziehung herstellen möchten, bereits angezeigt werden, fahren Sie mit Schritt 7 fort.

  5. Markieren Sie im Dialogfeld Tabelle anzeigen die erste Tabelle, für die Sie eine Beziehung erstellen möchten, und drücken Sie dann die EINGABETASTE, um sie zum Fenster Beziehungen hinzuzufügen.

  6. Wiederholen Sie Schritt 5 für alle weiteren Tabellen, für die Sie eine Beziehung erstellen möchten. Drücken Sie ALT+S, um das Dialogfeld Tabelle anzeigen zu schließen.

  7. Drücken Sie ALT+Z, um das Menü Beziehungen zu öffnen, und drücken Sie dann B, um das Dialogfeld Beziehungen bearbeiten zu öffnen.

  8. Öffnen Sie mit ALT+N das Dialogfeld Neue erstellen.

  9. Wählen Sie im Feld Linker Tabellenname den Namen der Tabelle, die den Primärschlüssel enthält.

  10. Wählen Sie im Feld Rechter Tabellenname den Namen der Tabelle, die den Fremdschlüssel enthält.

  11. Wählen Sie im Feld Linker Spaltenname das Primärschlüsselfeld, und wählen Sie im Feld Rechter Spaltenname das Fremdschlüsselfeld.

    Die Felder, für die eine Beziehung erstellt wird, brauchen nicht denselben Namen zu haben. Sie müssen jedoch den gleichen Datentyp haben und den gleichen Informationstyp enthalten. Wenn diese Felder Nummernfelder sind, muss für beide Felder die Feldgröße-Eigenschaft gleich eingestellt sein. Es gibt zwei Ausnahmen für gleiche Datentypen: Sie können eine Beziehung zwischen einem AutoWert-Feld und einem Nummernfeld herstellen, für das für die Feldgröße-Eigenschaft der Wert Long Integer eingestellt ist. Sie können eine Beziehung zwischen einem AutoWert-Feld und einem Nummernfeld herstellen, wenn für beide Felder für die Feldgröße-Eigenschaft der Wert Replikations-ID eingestellt ist.

  12. Drücken Sie die EINGABETASTE.

  13. Verwenden Sie im Dialogfeld Beziehungen bearbeiten die Pfeiltasten, um sicherzustellen, dass die beiden Spalten die gewünschten Feldnamen enthalten. Sie können die Feldnamen ändern, wenn dies erforderlich ist. Sie können auch zusätzliche Felder angeben, wenn Sie einen Mehr-Felder-Primärschlüssel verwenden.

    Falls erforderlich, stellen Sie die Optionen für die Beziehung ein. Um Informationen zu einem bestimmten Element im Dialogfeld Beziehungen zu erhalten, markieren Sie das Element, und drücken Sie dann F1.

  14. Drücken Sie ALT+E, um die Beziehung zu erstellen.

  15. Wiederholen Sie die Schritte 5 bis 14 für jedes Paar, für das Sie eine Beziehung erstellen möchten.

Anmerkungen

  • Zum Anzeigen aller Beziehungen, die in der Datenbank definiert sind, wählen Sie mit ALT+Z das Menü Beziehungen und drücken dann L. Wenn Sie nur die Beziehungen anzeigen möchten, die für eine bestimmte Tabelle definiert sind, markieren Sie diese Tabelle, drücken Sie ALT+Z, um das Menü Beziehungen auszuwählen, und drücken Sie dann D.

  • Wenn Sie den Entwurf einer Tabelle ändern möchten, markieren Sie die Tabelle. Öffnen Sie dann mit UMSCHALT+F10 das Kontextmenü, und wählen Sie dann Tabellenentwurf.

  • Sie können Beziehungen für Abfragen und für Tabellen definieren. Die referenzielle Integrität wird für Abfragen nicht erzwungen.

  • Wenn Sie für eine Tabelle eine Beziehung zu sich selbst herstellen möchten, fügen Sie diese Tabelle zweimal hinzu. Dieses Vorgehen ist nützlich, wenn Sie einen Nachschlagevorgang innerhalb derselben Tabelle durchführen müssen. Beispiel: In der Personaltabelle der Beispieldatenbank Nordwind wurde zwischen den Feldern Personal-Nr und Vorgesetze(r) eine Beziehung definiert, so dass im Feld Vorgesetze(r) Personaldaten aus einem entsprechenden Feld mit der Personal-Nummer angezeigt werden können.


Verwalten von Beziehungen mit Hilfe der Tastatur

Was möchten Sie tun?

Eine Beziehung definieren

Eine Beziehung bearbeiten oder löschen

Den Standardverknüpfungstyp festlegen


 Bearbeiten oder Löschen einer Beziehung mit Hilfe der Tastatur

Bearbeiten oder Löschen einer Beziehung mit Hilfe der Tastatur

  1. Schließen Sie alle Tabellen, die noch geöffnet sind. Für geöffnete Tabellen können Sie keine Beziehungen definieren oder bearbeiten.

  2. Wechseln Sie zum Datenbankfenster, falls dieses noch nicht erfolgt ist. Drücken Sie F11, um von einem beliebigen Fenster zum Datenbankfenster zu wechseln.

  3. Drücken Sie ALT+X, um das Menü Extras zu öffnen, und drücken Sie dann H, um das Fenster Beziehungen zu öffnen.

  4. Drücken Sie ALT+Z, um das Menü Beziehungen zu öffnen, und drücken Sie dann B, um das Dialogfeld Beziehungen bearbeiten zu öffnen.

  5. Drücken Sie ALT+T. Wählen Sie im Feld Tabelle/Abfrage den Namen der Tabelle, die den Primärschlüssel enthält. Stellen Sie sicher, dass die richtige Tabelle im Feld Detailtabelle/-abfrage angezeigt wird.

  6. Falls erforderlich, stellen Sie die Optionen für die Beziehung ein. Wenn Sie Informationen zu einem bestimmten Element im Dialogfeld Beziehungen benötigen, markieren Sie das Element und drücken dann F1.

  7. Zum Löschen der Beziehung drücken Sie die EINGABETASTE und dann ENTF.


 Definieren des Standardverbindungstyps mit Hilfe der Tastatur

Definieren des Standardverbindungstyps mit Hilfe der Tastatur

  1. Falls noch nicht erfolgt, wechseln Sie zum Datenbankfenster. Mit F11 wechseln Sie von einem beliebigen Fenster zum Datenbankfenster.

  2. Drücken Sie ALT+X, um das Menü Extras auszuwählen, und drücken Sie dann H, um das Fenster Beziehungen zu öffnen.

  3. Drücken Sie ALT+Z, um das Menü Beziehungen zu öffnen, und drücken Sie dann B, um das Dialogfeld Beziehungen bearbeiten zu öffnen.

  4. Drücken Sie ALT+T. Wählen Sie im Feld Tabelle/Abfrage den Namen der Tabelle aus, die den Primärschlüssel enthält. Wählen Sie dann im Feld Detailtabelle/-abfrage die entsprechende Tabelle aus.

  5. Drücken Sie ALT+V. Wählen Sie im Dialogfeld Verknüpfungseigenschaften den gewünschten Verknüpfungstyp.

    Mit Option 1 wird eine Exklusionsverknüpfung definiert. Dies ist die Standardeinstellung.

    Mit Option 2 wird eine Links-Inklusionsverknüpfung definiert.

    Mit Option 3 wird eine Rechts-Inklusionsverknüpfung definiert.

Anmerkung Wenn es sich bei den Tabellen um verknüpfte Tabellen handelt, können Sie den Standardverknüpfungstyp nicht ändern. Wenn die verknüpften Tabellen in einer anderen Microsoft Access-Datenbank gespeichert sind, können Sie die Datenbank öffnen, in der sie gespeichert sind, um den Verknüpfungstyp festzulegen.

Wenn im Fenster Beziehungen der Verknüpfungstyp für eine Beziehung definiert wird, ist davon die Beziehung selbst nicht betroffen. Vielmehr wird der Typ der Verknüpfung festgelegt, der standardmäßig beim Erstellen von Abfragen für verknüpfte Tabellen verwendet wird. Sie können zu einem späteren Zeitpunkt beim Definieren einer Abfrage den Standardverknüpfungstyp überschreiben.

Weitere Informationen zu Verknüpfungstypen anzeigen.


Gleichzeitiges Ändern der Größe aller Symbolleistenschaltflächen

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie auf die Registerkarte Optionen, und aktivieren oder deaktivieren Sie dann das Kontrollkästchen Große Symbole.

Anmerkung Diese Einstellung hat für alle Microsoft Office-Programme Gültigkeit.


Hinzufügen von Trennlinien zwischen Symbolleistenschaltflächen, Menübefehlen oder Menüs

Sie können zum Gruppieren verwandter Schaltflächen, Befehle und Menüs Trennlinien hinzufügen. So sind z.B. die Schaltflächen Neue Datenbank anlegen, Datenbank öffnen und Speichern in der Symbolleiste Datenbank durch eine Trennlinie hinter der Schaltfläche Speichern zu einer Gruppe zusammengefasst.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü an, in der/dem Sie verwandte Schaltflächen, Befehle oder Menüs gruppieren möchten.

  3. Lassen Sie das Dialogfeld Anpassen geöffnet. Klicken Sie in der Symbol- oder Menüleiste oder im Kontextmenü mit der rechten Maustaste auf die Schaltfläche, den Befehl oder das Menü, vor der/dem Sie eine Trennlinie einfügen möchten, und klicken Sie dann im Kontextmenü auf Gruppierung beginnen.

    Zum Entfernen einer Trennlinie klicken Sie erneut auf Gruppierung beginnen, um die Option zu deaktivieren.


Erstellen einer benutzerdefinierten Symbolleiste für die aktuelle Datenbank

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Neu.

  3. Geben Sie im Feld Symbolleistenname den gewünschten Namen ein, und klicken Sie dann auf OK.

  4. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  5. Legen Sie die gewünschten Eigenschaften fest, und klicken Sie dann auf Schließen.

    Die neue Symbolleiste befindet sich jetzt rechts neben dem Dialogfeld Anpassen.

  6. Zum Vervollständigen der Symbolleiste führen Sie die folgenden Schritte durch:
    • Fügen Sie Schaltflächen aus dem Dialogfeld Anpassen hinzu. Um weitere Informationen hierzu zu erhalten, klicken Sie auf [image] .

    • Verschieben oder kopieren Sie eine Schaltfläche aus einer anderen Symbolleiste. Um weitere Informationen hierzu zu erhalten, klicken Sie auf [image] .

Anmerkungen

  • Sie können auch Menüs zu einer Symbolleiste hinzufügen.

  • Microsoft Access kann automatisch eine Symbolleiste erstellen, die Schaltflächen zum Ausführen vorhandener Makros enthält. Um weitere Informationen hierzu zu erhalten, klicken Sie auf [image] .

  • Sie können die benutzerdefinierte Symbolleiste in ein Formular oder einen Bericht einbinden. Um weitere Informationen hierzu zu erhalten, klicken Sie auf [image] .


 Erstellen einer Symbolleiste für alle Access-Datenbanken und Access-Projekte

Erstellen einer Symbolleiste für alle Access-Datenbanken und Access-Projekte

Zum Entwerfen einer Symbolleiste, die für alle Ihre Microsoft Access-Datenbanken und Microsoft Access-Projekte zur Verfügung steht, fügen Sie Schaltflächen zu den leeren eingebauten Symbolleisten, Werkzeuge 1 und Werkzeuge 2, hinzu.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Aktivieren Sie auf der Registerkarte Symbolleisten im Feld Symbolleisten das Kontrollkästchen für Werkzeuge 1 oder Werkzeuge 2.

  3. Zum Vervollständigen der Symbolleiste führen Sie die folgenden Schritte aus:
    • Fügen Sie Schaltflächen aus dem Dialogfeld Anpassen hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Verschieben oder kopieren Sie eine Schaltfläche aus einer anderen Symbolleiste. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkung Sie können zu einer Symbolleiste auch Menüs hinzufügen.


 Erstellen benutzerdefinierter Farben für einen Bereich oder ein Steuerelement in einem Formular oder Bericht

Erstellen benutzerdefinierter Farben für einen Bereich oder ein Steuerelement in einem Formular oder Bericht

Wenn die Palette eine benötigte Farbe nicht enthält, können Sie eigene benutzerdefinierte Farben erstellen.

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Öffnen Sie das Eigenschaftenfenster für den Bereich oder das Steuerelement.

  3. Klicken Sie auf eine der Eigenschaften Textfarbe (für Text in einem Steuerelement), Hintergrundfarbe oder Rahmenfarbe.

  4. Klicken Sie neben dem Einstellungsfeld der Eigenschaft auf die Generator-Schaltfläche [image] , um das Dialogfeld Farbe zu öffnen.

  5. Klicken Sie auf Farben definieren, um das Dialogfeld zu erweitern.

  6. Klicken Sie auf der linken Seite des Dialogfelds auf eines der Felder unter Benutzerdefinierte Farben.

  7. Klicken Sie auf eine beliebige Stelle im Farbänderungsfeld. Das Farbänderungsfeld zeigt alle verfügbaren benutzerdefinierten Farben an.

  8. Ziehen Sie den Pfeil neben der Intensitätsleiste, um die Intensität der im Farbänderungsfeld gewählten Farbe wie gewünscht zu ändern.

    Microsoft Access zeigt die so festgelegte Farbe auf der linken Seite des Feldes Farbe|Einfarbig an. Wenn Sie die Basisfarbe sehen möchten, die der von Ihnen definierten Farbe am ehesten entspricht, doppelklicken Sie auf die rechte Seite des Feldes Farbe|Einfarbig.

  9. Klicken Sie auf Farben hinzufügen.

    Access zeigt die von Ihnen erstellte Farbe im Feld Benutzerdefinierte Farben an.

Anmerkung Sie können zum Erstellen einer Farbe auch Zahlen in die Felder Rot, Grün, Blau, Farbton, Sättigung und Helligkeit eingeben.


 Ändern der Hintergrundfarbe für ein Steuerelement oder einen Bereich

Ändern der Hintergrundfarbe für ein Steuerelement oder einen Bereich

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement oder den Bereich, das/den Sie ändern möchten.

  3. Klicken Sie auf der Formatsymbolleiste für Formulare und Berichte oder auf der Formatsymbolleiste für Datenzugriffsseiten auf den Pfeil neben Füll-/Hintergrundfarbe [image] .

  4. Klicken Sie in der Palette auf die gewünschte Farbe.

Anmerkungen

  • Wenn Sie die gewählte Farbe für ein anderes Steuerelement oder einen anderen Bereich verwenden möchten, können Sie einfach auf Füll-/Hintergrundfarbe [image] klicken (d. h., Sie müssen nicht auf den Pfeil neben der Schaltfläche klicken und die Farbe erneut auswählen.) Wenn Sie für mehrere Steuerelemente gleichzeitig unterschiedliche Farben festlegen möchten, klicken Sie auf den Pfeil neben Füll-/Hintergrundfarbe [image] , dann auf den Rahmen der Farbpalette, und ziehen Sie diese an eine andere Position. Auf diese Weise müssen Sie nicht jedesmal auf Füll-/Hintergrundfarbe [image] klicken, wenn Sie eine Farbe zuweisen möchten.

  • Wenn die Palette nicht die gewünschte Farbe enthält, können Sie eigene Farben definieren.

    Wie wird's gemacht?


Einstellen der Bildschirmauflösung, um auf dem Bildschirm mehr oder weniger anzuzeigen

  1. Zeigen Sie im Windows Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf das Symbol Anzeige [image].

  3. Klicken Sie auf die Registerkarte Einstellungen.

  4. Bewegen Sie den Schieber unter Bildschirmauflösung, um die Bildschirmauflösung zu ändern.

Anmerkung Ob Sie Ihre Bildschirmauflösung ändern können, hängt von Ihrem Monitor und Videoadapter ab.


Arbeiten mit AutoKorrekt

Was möchten Sie tun?

Die Rechtschreibung beim Eingeben automatisch korrigieren

Zwei aufeinander folgende Großbuchstaben in einer Zeile beim Eingeben automatisch korrigieren

Automatisches Großschreiben der Wochentage bei der Dateneingabe

Einen AutoKorrekt-Eintrag beim Überprüfen der Rechtschreibung hinzufügen

Deaktivieren der automatischen Korrektur eines bei der Dateneingabe vorgenommenen Eintrags

Die automatische Korrektur eines Eintrags beim Eingeben von Daten abbrechen

AutoKorrektur in einem Textfeld oder Kombinationsfeld verwenden


 Einfügen des Wertes aus demselben Feld des vorherigen Datensatzes

Einfügen des Wertes aus demselben Feld des vorherigen Datensatzes

  1. Öffnen Sie ein Datenblatt.

  2. Klicken Sie auf das Feld, in das Sie den Wert einfügen möchten.

  3. Drücken Sie die Tastenkombination STRG+' (Apostroph).


Anpassen der Microsoft Access-Umgebung durch Festlegen von Standardeinstellungen

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte mit den Optionen, die Sie festlegen möchten.

  3. Wählen Sie die gewünschten Optionen.

Anmerkung Zum Anpassen der Visual Basic-Editor-Umgebung zeigen Sie den Editor an, klicken Sie im Menü Extras auf Optionen, und wählen Sie dann die gewünschten Optionen.


Anpassen der Umgebung Ihrer Anwendung unter Verwendung von Microsoft Access-Benutzerprofilen

Was möchten Sie tun?

Weitere Informationen zum Anpassen der Anwendungsumgebung mit Microsoft Access-Benutzerprofilen anzeigen

Ein Access-Benutzerprofil erstellen

Access-Laufzeitoptionen festlegen


 Anzeigen eines benutzerdefinierten Symbols für eine Anwendung

Anzeigen eines benutzerdefinierten Symbols für eine Anwendung

  1. Klicken Sie im Menü Extras auf Start.

  2. Geben Sie im Feld Anwendungssymbol den Namen der .ICO- oder der .BMP-Datei ein, die Sie verwenden möchten. Wenn Sie den Namen der Datei nicht kennen, klicken Sie neben dem Feld auf die Schaltfläche Editor [image] und verwenden dann den Icon Browser, um die Datei zu suchen. (Der Icon Browser funktioniert genau wie das Dialogfeld Öffnen. Zum Anzeigen von Informationen zu den Suchfunktionen in diesen Dialogfeldern klicken Sie auf [image] .)

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start sind erst beim nächsten Öffnen der Datenbank oder Anwendung gültig.

  • Wenn Sie Ihre Anwendung weitergeben, empfiehlt es sich, die Symboldatei in dem Ordner abzulegen, in dem sich Ihre Microsoft Access-Anwendung befindet.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Informationen über das Verwenden persönlicher Einstellungen auf einem anderen Computer

Informationen über das Verwenden persönlicher Einstellungen auf einem anderen Computer

Dieses Thema enthält Referenzinformationen über:

Was ist ein Benutzerprofil?

Ständige Verfügbarkeit persönlicher Einstellungen

Weitere Benutzerinformationen

Was ist ein Benutzerprofil?

Ein Benutzerprofil ist eine Gruppe von Einstellungen, die angepasste Voreinstellungen und Optionen für einen bestimmten Benutzer enthält. Dazu zählen persönlich angepasste Dateien wie benutzerdefinierte Wörterbücher, benutzerdefinierte Vorlagen sowie AutoKorrektur- und AutoFormatlisten. Ein Benutzerprofil kann z. B. die installierten Anwendungen und gewählten Desktopsymbole und Farboptionen eines bestimmten Benutzers enthalten. Das Betriebssystem verwendet die in einem Benutzerprofil enthaltenen Informationen, um den Computer entsprechend diesen Einstellungen bei der Anmeldung zu konfigurieren.

Zurück zum Anfang

Ständige Verfügbarkeit festgelegter Einstellungen

Der Systemadministrator kann ein Benutzerprofil so konfigurieren, dass Sie es an verschiedenen Standorten verwenden können. Das heißt, dass die auf einem Server gespeicherten Einstellungen stets zur Verfügung stehen, wenn Sie sich bei einem anderen Computer anmelden. Dies ist besonders nützlich, wenn Sie sich bei verschiedenen Computern in einem Unternehmen anmelden oder einen Computer mit einem Kollegen gemeinsam nutzen. Wenn Sie sich anmelden, wird das Benutzerprofil vom Server auf den Computer übertragen, an dem Sie sich anmelden wollen. Ein Benutzerprofil ist nur gültig für das Betriebssystem, in dem es erstellt wurde. Ein Windows NT 4.0-Benutzerprofil kann z. B. nicht auf einem Windows 95-Computer verwendet werden. Wenn Sie sich abmelden, wird das Benutzerprofil zurück auf den Server kopiert, so dass alle Änderungen, die Sie bei der letzten Anmeldung vorgenommen haben, bei der nächsten Anmeldung verfügbar sind.

Zurück zum Anfang

Weitere Informationen

Speicherort der persönlichen Einstellungen

Zurück zum Anfang


Anpassen der von Microsoft Access verwendeten Einstellungen in der Windows-Registrierung

Achtung Viele der Microsoft Access-Registrierungseinstellungen werden automatisch hinzugefügt, wenn Sie Microsoft Access installieren. Das Ändern der installierten Einstellungen kann unerwartete Ergebnisse hervorrufen und unter Umständen sogar das Neuinstallieren von Microsoft Access erforderlich machen. Es wird dringend empfohlen, die Einstellungen in der Windows-Registrierung nicht zu ändern. Wenn Sie jedoch Registrierungseinstellungen oder -optionen ändern müssen, verwenden Sie dazu den Registrierungseditor von Windows, und ändern Sie nur die Einstellungen oder Optionen, die in den nachstehenden Themen ausdrücklich dokumentiert sind. Geänderte Einstellungen haben erst nach dem Beenden und erneuten Starten von Microsoft Access Gültigkeit. Erstellen Sie vor dem Durchführen von Änderungen unbedingt eine Sicherungskopie der gesamten Registrierung oder zumindest des Teils, den Sie bearbeiten möchten. Weitere Informationen finden Sie im Hilfeindex des Registrierungseditors (verfügbar über die Menüleiste des Registrierungseditors) unter "Sichern der Registrierung".

Was möchten Sie tun?

Informationen über die Windows-Registrierung erhalten

Die Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 4.0, anpassen

Die Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 3.x, anpassen

Die Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 2.x, anpassen

Microsoft Excel-Treibereinstellungen anpassen

Text-Treibereinstellungen anpassen

HTML-Treibereinstellungen anpassen

Exchange-Treibereinstellungen anpassen

ODBC-Treibereinstellungen anpassen

dBASE-Treibereinstellungen anpassen

Paradox-Treibereinstellungen anpassen

Lotus-Treibereinstellungen anpassen

Festlegen, ob OLE-Verknüpfungen im OLE-Format der Version 2.0 oder der Version 1.0 gespeichert werden sollen

Die Umgebung Ihrer Anwendung unter Verwendung von Benutzerprofilen anpassen

Eigene Assistenten, Editoren und Add-Ins erstellen


 Speicherort der persönlichen Einstellungen

Speicherort der persönlichen Einstellungen

Der Speicherort der im Benutzerprofil enthaltenen persönlichen Einstellungen hängt vom verwendeten Betriebssystem und davon ab, wie der Systemadministrator das Benutzerprofil auf dem Server konfiguriert hat. Das Benutzerprofil finden Sie am folgenden Speicherort:

Stammverzeichnis\Betriebssystem\Profiles\Benutzername

Stammverzeichnis ist ein Serverspeicherort oder Ordner auf einem Laufwerk, von dem alle anderen Ordner abzweigen (z. B. C:\). Betriebssystem ist der Betriebssystemordner (z. B. Windows oder Winnt) und Benutzername ist Ihr Benutzername.

Alle persönlichen Einstellungen und Office-spezifischen Dateien befinden sich im Benutzerprofilordner im Ordner Anwendungsdaten. Der Systemadministrator muss das Benutzerprofil so konfigurieren, dass Sie es an verschiedenen Standorten verwenden können, damit diese Dateien stets zur Verfügung stehen, wenn Sie sich bei einem anderen Computer anmelden. Die Pfade werden im Folgenden aufgeführt.

Benutzerprofildateien | Pfad
Add-Ins | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Addins
AutoKorrektur-Listen | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Office
Benutzerwörterbuch | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Proof
Diagramm | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Proof
Office-Verknüpfungsleiste | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\OSB
Profile mit persönlichen Informationen (Erweiterung .PIP) | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Office
Zuletzt verwendete Verknüpfungen | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Office\Zuletzt verwendet
Vorlagen | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Vorlagen
Designs | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Themes
Abfragen | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Abfragen
Start | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Excel\XLStart
Angepasste Symbolleisten | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Excel
Diagrammgalerie | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Excel
Angepasste Symbolleisten (Erweiterung .PCB) | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\PPT
Start | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Word\StartUp
Angepasste Assistenteninformationen | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Access
Briefpapier | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Stationery
AutoSignature | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Signatures
Angepasste Outlook-Dateien | Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Outlook


Microsoft Access-Spezifikationen

Was möchten Sie tun?

Informationen zu allgemeinen Spezifikationen für Microsoft Access-Datenbanken anzeigen

Informationen zu allgemeinen Spezifikationen für Microsoft Access-Projekte anzeigen

Informationen zu technischen Spezifikationen für Microsoft SQL Server-Datenbanken anzeigen

Informationen zu Spezifikationen für Access-Datenbanktabellen anzeigen

Informationen zu Spezifikationen für Access-Datenbankabfragen anzeigen

Informationen zu Spezifikationen für Formulare und Berichte anzeigen

Informationen zu Spezifikationen für Makros anzeigen


 Umgehen von Einstellungen, die das Verhalten von Access-Datenbanken und Access-Projekten beim Öffnen bestimmen

Umgehen von Einstellungen, die das Verhalten von Access-Datenbanken und Access-Projekten beim Öffnen bestimmen

  • Halten Sie hierzu beim Öffnen der Datenbank die UMSCHALTTASTE gedrückt.

Wenn Sie das Verhalten beim Öffnen einer Microsoft Access-Datenbank oder eines Microsoft Access-Projekts mit Hilfe des Dialogfeldes Start (Menü Extras) festgelegt oder zu diesem Zweck ein AutoExec-Makro oder eine Open-Ereignisprozedur erstellt haben, können Sie diese Einstellungen umgehen, um wieder vollen Zugriff auf Ihre Access-Datenbank bzw. das Access-Projekt zu erhalten.

Anmerkung Diese Umgehungstaste können Sie deaktivieren, indem Sie mit Hilfe eines Makros oder VBA-Codes die AllowBypassKey-Eigenschaft der Datenbank auf True festlegen.


 Festlegen, wie eine Access-Datenbank oder ein Access-Projekt beim Starten aussieht und sich verhält

Festlegen, wie eine Access-Datenbank oder ein Access-Projekt beim Starten aussieht und sich verhält

Sie können z.B. festlegen, welches Formular angezeigt werden soll, ob Symbolleisten angepasst werden dürfen und ob Kontextmenüs zur Verfügung stehen.

  1. Klicken Sie im Menü Extras auf Start.

  2. Wählen Sie die gewünschten Optionen, oder geben Sie die gewünschten Einstellungen ein.

Anmerkungen

  • Zum Anzeigen von Informationen zu einem bestimmten Element im Dialogfeld klicken Sie auf das Fragezeichen [image] am oberen Rand des Dialogfelds und dann auf das Element.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .

  • Um weitere Informationen zum Erstellen einer Anwendung anzuzeigen, klicken Sie auf [image] .


Anzeigen eines bestimmten Titels in der Titelleiste eines Anwendungsfensters

  1. Klicken Sie im Menü Extras auf Start.

  2. Geben Sie im Feld Anwendungstitel den Titel ein, der in der Titelleiste der Anwendung angezeigt werden soll.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start sind erst beim nächsten Öffnen der Datenbank oder Anwendung gültig.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Anzeigen eines Startformulars oder einer Datenzugriffsseite beim Öffnen einer Access-Datenbank oder eines Access-Projekts

Anzeigen eines Startformulars oder einer Datenzugriffsseite beim Öffnen einer Access-Datenbank oder eines Access-Projekts

  1. Klicken Sie im Menü Extras auf Start.

  2. Klicken Sie im Feld Formular/Seite anzeigen: auf ein Formular oder eine Datenzugriffsseite aus der aktuellen Microsoft Access-Datenbank oder dem aktuellen Microsoft Access-Projekt.

  3. Wenn Sie verhindern möchten, dass andere Benutzer das Datenbankfenster, das hinter dem Formular erscheint, sehen oder verwenden, deaktivieren Sie das Kontrollkästchen Datenbankfenster anzeigen.

  4. Auch wenn Sie das Kontrollkästchen Datenbankfenster anzeigen deaktiviert haben, kann das Datenbankfenster noch zur Verfügung stehen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start sind erst beim nächsten Öffnen der Access-Datenbank oder des Access-Projekts gültig.

  • Die Beispieldatenbank Nordwind verfügt über ein Startformular. Sie hat darüber hinaus ein Übersichtsformular zum Steuern der Navigation in Ihrer Access-Datenbank oder Ihrem Access-Projekt. Zum Anzeigen dieser Formulare öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL des Office-Ordners. Das Startformular erscheint automatisch, wenn Sie Nordwind öffnen, Sie können das Startformular und das Übersichtsformular jedoch auch zu jedem beliebigen anderen Zeitpunkt anzeigen. Dazu klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] , dann auf das Start- oder das Übersichtsformular und schließlich auf die Schaltfläche Öffnen in der Symbolleiste des Datenbankfensters. Um Informationen zum Öffnen von Nordwind anzuzeigen, klicken Sie auf [image] .

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Anzeigen oder Ausblenden des Datenbankfensters beim Öffnen einer Access-Datenbank oder eines Access-Projekts

Anzeigen oder Ausblenden des Datenbankfensters beim Öffnen einer Access-Datenbank oder eines Access-Projekts

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren bzw. deaktivieren Sie das Kontrollkästchen Datenbankfenster anzeigen.

Anmerkungen

  • Änderungen dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Microsoft Access-Datenbank oder des Microsoft Access-Projekts wirksam.

  • Falls Sie das Datenbankfenster ausblenden, müssen Sie ein Formular oder eine Datenzugriffsseite anzeigen lassen, damit andere Benutzer in der Access-Datenbank oder dem Access-Projekt navigieren können. Um weitere Informationen hierzu anzuzeigen, klicken Sie auf [image] .

  • Auch wenn Sie das Kontrollkästchen Datenbankfenster deaktivieren, kann das Datenbankfenster eventuell durch eine bestimmte Tastenkombination geöffnet werden. Um weitere Informationen hierzu anzuzeigen, klicken Sie auf [image] . Und selbst wenn Sie das Datenbankfenster und die Tastenkombination deaktivieren, können Benutzer möglicherweise auf das Datenbankfenster zugreifen. Dies kann geschehen, wenn ein Benutzer mehr als einmal versucht, die gleiche Access-Datenbank bzw. das gleiche Access-Projekt von der Liste der kürzlich verwendeten Access-Datenbanken oder Access-Projekte aus zu öffnen, welche automatisch im Menü Datei angezeigt wird. Damit Benutzer nicht auf diese Liste zugreifen können, müssen Sie das Menü Datei durch ein von Ihnen selbst definiertes Menü ersetzen.

  • Um eine Aufstellung der zu beachtenden Punkte bei der Einstellung von Optionen im Dialogfeld Start anzuzeigen, klicken Sie auf [image] .


 Anzeigen mehrerer Datenbankobjekte in der Windows-Taskleiste

Anzeigen mehrerer Datenbankobjekte in der Windows-Taskleiste

Wenn Sie die Microsoft Internet Explorer-Funktion Active Desktop installiert haben, können Sie die Windows-Taskleiste verwenden, um zwischen Datenbankobjekten zu wechseln, die gegenwärtig geöffnet sind.

  1. Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Ansicht.
  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Fenster in Tastleiste.

Anmerkungen

  • Um zu bestimmen, ob die Microsoft Internet Explorer-Funktion Active Desktop auf dem Computer installiert ist, klicken Sie mit der rechten Maustaste auf den Desktop. Wenn Active Desktop im Kontextmenü enthalten ist, wurde die Funktion installiert. Ist Active Desktop nicht installiert, können Sie das Kontrollkästchen Fenster in Taskleiste aktivieren, ohne das dies eine Auswirkung hat.

  • Das Aktivieren und Deaktivieren des Kontrollkästchens Fenster in Taskleiste wirkt sich nicht auf das Umschaltverhalten anderer Microsoft Office-Anwendungen aus.


Festlegen der Dateienanzahl in der Liste zuletzt geöffneter Dateien im Menü Datei

Wenn Sie auf der Menüleiste auf Datei klicken, wird eine Liste der zuletzt geöffneten Dateien im Menü angezeigt. Nun können Sie auf einen Dateinamen in dieser Liste klicken, um die entsprechende Datei mit denselben Optionseinstellungen wie bei der letzten Verwendung zu öffnen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Führen Sie auf der Registerkarte Allgemein einen der folgenden Schritte aus:
    • Wenn keine Dateien im Menü Datei angezeigt werden sollen, deaktivieren Sie das Kontrollkästchen Liste zuletzt geöffneter Dateien.

    • Möchten Sie die Anzahl der in der Liste im Menü Datei angezeigten Dateien ändern, muss das Kontrollkästchen Liste zuletzt geöffneter Dateien aktiviert sein. Wählen Sie dann in dem Feld rechts daneben die Anzahl der Dateien aus, die in der Liste angezeigt werden sollen. Standardmäßig werden vier Dateien angezeigt, aber optional können Sie bis zu neun Dateien anzeigen lassen.


 Festlegen von Standarddruckbereichen

Festlegen von Standarddruckbereichen

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Allgemein.

  3. Geben Sie unter Druckbereiche die Maße für die Ränder an, die Sie als Standard verwenden möchten.

Anmerkungen

  • Das Ändern dieser Einstellungen wirkt sich nicht auf die Druckbereiche vorhandener Formulare und Berichte aus.

  • Diese Einstellungen gelten nicht für Datenzugriffsseiten.


Ein- oder Ausblenden aller Objekte, die standardmäßig ausgeblendet sind

Wenn Sie mit Objekten arbeiten müssen, die als ausgeblendet definiert sind, ohne den ausgeblendeten Status ändern zu wollen, können Sie sie trotzdem im Datenbankfenster anzeigen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Ansicht.

  3. Aktivieren oder deaktivieren Sie unter Erweitern das Kontrollkästchen Ausgeblendete Objekte. Microsoft Access zeigt ausgeblendete Objekte mit abgeblendeten Symbolen an, um sie von Objekten zu unterscheiden, die nicht als ausgeblendet definiert sind.


 Standardmäßiges Ein- oder Ausblenden des Start-Dialogfelds "Microsoft Access"

Standardmäßiges Ein- oder Ausblenden des Start-Dialogfelds "Microsoft Access"

Das Start-Dialogfeld ist das erste Dialogfeld, das beim Starten von Microsoft Access angezeigt wird. Es enthält Optionen zum Erstellen oder Öffnen von Microsoft Access-Datenbanken bzw. Microsoft Access-Projekten.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Ansicht.

  3. Aktivieren bzw. deaktivieren Sie unter Erweitern das Kontrollkästchen Start-Dialogfeld.


Festlegen einer Ersatzschriftart für Ersatzschriftartunterstützung

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Ansicht.

  3. Klicken Sie unter Ersatzschriftartunterstützung auf das Kontrollkästchen Ersatzschriftart benutzen und dann in der Liste auf eine Schriftart.

Anmerkung Um optimale Leistung sicherzustellen, sollten Sie Ersatzschriftarten nur dann verwenden, wenn Sie Ersatzschriftartunterstützung zum Anzeigen aller Daten benötigen.

Weitere Informationen zur Ersatzschriftartunterstützung.


Starten von Microsoft Access mit Befehlszeilenoptionen

Was möchten Sie tun?

Befehlszeilenoptionen für Microsoft Access im Windows Startmenü angeben

Befehlszeilenoptionen für eine Verknüpfung angeben

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Startoptionen für die Befehlszeile

Startoptionen für die Befehlszeile

Die folgende Tabelle enthält die Microsoft Access-Befehlszeilenoptionen.

Option | Auswirkung | Betrifft
Datenbank | Öffnet die angegebene Microsoft Access-Datenbank oder das angegebene Microsoft Access-Projekt. Enthält gegebenenfalls einen Pfad. Wenn Sie Microsoft Windows 95 ausführen, wird standardmäßig der Ordner Eigene Dateien als Pfad angegeben. | Access-Datenbank oder Access-Projekt
/excl | Öffnet die angegebene Access-Datenbank für exklusiven Zugriff. Um die Datenbank für gemeinsamen Zugriff in einer Mehrbenutzerumgebung zu öffnen, geben Sie diese Option nicht an. | Nur Access-Datenbank
/ro | Öffnet die angegebene Access-Datenbank oder das angegebene Access-Projekt für schreibgeschützten Zugriff. | Access-Datenbank oder Access-Projekt
/user Benutzername | Startet Microsoft Access unter Verwendung des angegebenen Benutzernamens. | Nur Access-Datenbank
/pwd Kennwort | Startet Microsoft Access unter Verwendung des angegebenen Kennwortes. | Nur Access-Datenbank
/profile Benutzerprofil | Startet Microsoft Access, wobei nicht die bei der Installation von Microsoft Access erstellten Standardeinstellungen in der Windows-Registrierung verwendet werden, sondern die Optionen in dem angegebenen Benutzerprofil. Diese Option ersetzt die Option /ini, die in den Microsoft Access-Versionen vor Access 97 zur Angabe der Initialisierungsdatei verwendet wurde. | Access-Datenbank oder Access-Projekt
/compact Zieldatenbank oder Ziel-Access-Projekt | Komprimiert und repariert die Access-Datenbank bzw. komprimiert das Access-Projekt, das vor der Option /compact angegeben wurde, und beendet Microsoft Access. Wenn Sie im Anschluss an die Option /compact keinen Zieldateinamen eingeben, wird die Datei unter dem ursprünglichen Namen und Ordner komprimiert. Um die Datei unter einem anderen Namen zu komprimieren, geben Sie eine Zieldatei an. Wenn Sie in Zieldatenbank oder Ziel-Access-Projekt keinen Pfad angeben, wird die Zieldatei standardmäßig im Ordner Eigene Dateien erstellt. In einem Access-Projekt komprimiert diese Option zwar die Access-Projektdatei (.ADP), nicht jedoch die Microsoft SQL Server-Datenbank. | Access-Datenbank oder Access-Projekt
/repair | Repariert die Access-Datenbank, die vor der Option /repair angegeben wurde, und beendet Microsoft Access. In Microsoft Access 2000 werden die Komprimierungs- und die Reparaturfunktion in der Option /compact zusammengefasst. Die Option repair wird aus Gründen der Rückwärtskompatibilität unterstützt. | Nur Access-Datenbank
/convert Zieldatenbank | Konvertiert eine frühere Version einer Access-Datenbank in eine Access 2000-Datenbank mit einem neuen Namen und beendet Microsoft Access. Sie müssen die Quelldatenbank angeben, um die Option /convert verwenden zu können. | Nur Access-Datenbank
/x Makro | Startet Microsoft Access und führt das angegebene Makro aus. Sie können auch das Makro AutoExec verwenden, um beim Öffnen einer Datenbank ein Makro auszuführen. | Access-Datenbank oder Access-Projekt
/cmd | Gibt an, dass auf diese Befehlszeilenoption der Wert folgt, der durch die Command-Funktion zurückgegeben wird. Bei dieser Option muss es sich um die letzte Option in der Befehlszeile handeln. Als Alternative zu /cmd können Sie ein Semikolon (;) verwenden. Um Informationen zur Command-Funktion zu erhalten, klicken Sie auf [image] . | Access-Datenbank oder Access-Projekt
/nostartup | Startet Microsoft Access, ohne das Startdialogfeld anzuzeigen (das zweite Dialogfeld, das nach dem Start von Microsoft Access angezeigt wird). | Access-Datenbank oder Access-Projekt
/wrkgrp Arbeitsgruppen- Informationsdatei | Startet Microsoft Access unter Verwendung der angegebenen Arbeitsgruppen-Informationsdatei. | Nur Access-Datenbank

Anmerkungen

  • Um beim Öffnen einer Datenbank eine Visual Basic für Applikationen-Prozedur auszuführen, verwenden Sie die Aktion AusführenCode in dem Makro AutoExec oder dem Makro, das Sie mit Hilfe der Befehlszeilenoption /x ausführen. Darüber hinaus können Sie eine Visual Basic-Prozedur beim Öffnen einer Datenbank ausführen, wenn Sie ein Formular erstellen, in dem eine Visual Basic-Prozedur als BeimÖffnen-Ereignis definiert ist. Um dieses Formular als Startformular zu bestimmen, klicken Sie mit der rechten Maustaste in das Datenbankfenster, klicken Sie auf Start, und geben Sie dieses Formular im Feld Formular/Seite anzeigen ein.

  • Wenn Sie einen Schrägstrich (/) oder ein Semikolon (;) in der Befehlszeile verwenden möchten, müssen Sie das Zeichen zweimal eingeben. Um beispielsweise das Kennwort ;mjs/md in der Befehlszeile zu verwenden, geben Sie ;;mjs//md im Anschluss an die Befehlszeilenoption /pwd ein.


 Festlegen der OLE/DDE-Einstellungen

Festlegen der OLE/DDE-Einstellungen

  1. Klicken Sie im Menü Extras auf Optionen und klicken Sie dann auf die Registerkarte Weitere.

  2. Wählen Sie unter DDE -Operationen die gewünschte Option aus.
    • Wählen Sie DDE-Anfragen ignorieren, um die DDE-Anfragen von anderen Anwendungen zu ignorieren.
    • Wählen Sie DDE-Aktualisierung ermöglichen, um DDE-Verknüpfungen in dem Intervall zu aktualisieren, das im Feld Intervall für Anzeigeaktualisierung angegeben ist.
  3. Geben Sie in das Feld OLE/DDE-Timeout die Wartezeit in Sekunden ein (0 bis 300), die vergehen soll, bevor eine fehlgeschlagene OLE- oder DDE-Operation erneut ausgeführt wird.

Klicken Sie auf Übernehmen, um die Einstellungen sofort zuzuweisen, ohne das Dialogfeld zu schließen; klicken Sie auf OK, um die Einstellungen zuzuweisen und das Dialogfeld zu schließen.


 Aktivieren oder Deaktivieren von Tasten, die das Datenbankfenster oder Menüleisten anzeigen, oder die das Abrufen von Datensätzen in einem Access-Projekt stoppen

Aktivieren oder Deaktivieren von Tasten, die das Datenbankfenster oder Menüleisten anzeigen, oder die das Abrufen von Datensätzen in einem Access-Projekt stoppen

  1. Klicken Sie im Menü Extras auf Start.

  2. Klicken Sie auf Weitere.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Access-Spezialtasten verwenden, wenn Sie die folgenden Tasten aktivieren bzw. deaktivieren möchten.
Tasten | Ergebnis
F11 oder ALT+F1 | Holt das Datenbankfenster in den Vordergrund.
STRG+G | Zeigt das Direktfenster an.
STRG+F11 | Wechselt zwischen der benutzerdefinierten und der eingebauten Menüleiste hin und her.
STRG+UNTBR | Stoppt in einem Microsoft Access-Projekt das Abrufen von Datensätzen vom Server.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Microsoft Access-Datenbank bzw. des Microsoft Access-Projekts wirksam.

  • Wenn Sie das Kontrollkästchen Access-Spezialtasten verwenden deaktivieren und im Feld Menüleiste eine benutzerdefinierte Menüleiste festlegen, steht die eingebaute Menüleiste nicht zur Verfügung.

  • Auch wenn Sie sowohl das Kontrollkästchen Access-Spezialtasten verwenden als auch das Kontrollkästchen Datenbankfenster anzeigen deaktivieren, kann der Benutzer noch auf das Datenbankfenster zugreifen, wenn er mehrmals versucht, dieselbe Access-Datenbank bzw. dasselbe Access-Projekt aus der Liste der zuletzt geöffneten Access-Datenbanken bzw. Access-Projekte (diese erscheint automatisch im Menü Datei) zu öffnen. Wenn Sie verhindern möchten, dass der Benutzer Zugriff auf diese Liste hat, müssen Sie das Menü Datei durch ein benutzerdefiniertes Menü ersetzen.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Standardmäßiges Ein- oder Ausblenden der Statusleiste für alle Access-Datenbanken oder Access-Projekte

Standardmäßiges Ein- oder Ausblenden der Statusleiste für alle Access-Datenbanken oder Access-Projekte

Änderungen an dieser Einstellung wirken sich auf sämtliche Ihrer Microsoft Access-Datenbanken und Microsoft Access-Projekte aus.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Aktivieren bzw. deaktivieren Sie auf der Registerkarte Ansicht unter Erweitern das Kontrollkästchen Statusleiste.

Anmerkung Sie können festlegen, ob die Statusleiste für eine bestimmte Microsoft Access-Datenbank oder ein bestimmtes Microsoft Access-Projekt ein- oder ausgeblendet werden soll. Weitere Informationen erhalten Sie durch Klicken auf [image] .


 Ein- oder Ausblenden der Statusleiste für eine bestimmte Access-Datenbank oder ein bestimmtes Access-Projekt

Ein- oder Ausblenden der Statusleiste für eine bestimmte Access-Datenbank oder ein bestimmtes Access-Projekt

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Statusleiste anzeigen.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Microsoft Access-Datenbank bzw. des Microsoft Access-Projekts wirksam.

  • Sie können auch festlegen, dass die Statusleiste standardmäßig für alle Access-Datenbanken oder Access-Projekte ein- oder ausgeblendet sein soll. Dazu klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Ansicht. Anschließend aktivieren oder deaktivieren Sie das Kontrollkästchen Statusleiste. In der aktuellen Access-Datenbank bzw. dem Access-Projekt ist die Statusleiste ausgeblendet, wenn entweder das Kontrollkästchen Statusleiste im Dialogfeld Optionen oder das Kontrollkästchen Statusleiste anzeigen im Dialogfeld Start deaktiviert ist.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Verhindern oder Zulassen des Zugriffs auf integrierte Symbolleisten in einer Access-Datenbank oder einem Access-Projekt

Verhindern oder Zulassen des Zugriffs auf integrierte Symbolleisten in einer Access-Datenbank oder einem Access-Projekt

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Eingebaute Symbolleisten zulassen.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Microsoft Access-Datenbank bzw. des Microsoft Access-Projekts wirksam.

  • Diese Option betrifft nicht Symbolleisten für PivotTable-Listen oder PivotTable-Kalkulationstabellen auf einer Datenzugriffseite.

  • Wenn Sie Benutzern erlauben möchten, eingebaute Symbolleisten zu ändern, müssen Sie sowohl das Kontrollkästchen Eingebaute Symbolleisten zulassen als auch das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen aktivieren. Wenn Sie verhindern möchten, dass der Benutzer eingebaute Symbolleisten anpasst, aktivieren Sie das Kontrollkästchen Eingebaute Symbolleisten zulassen, deaktivieren jedoch das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen.

  • Sie können auch festlegen, dass der Benutzer nur bestimmte Symbolleisten nicht ändern kann. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Festlegen, ob einige oder alle der integrierten Menüs angezeigt werden sollen

Festlegen, ob einige oder alle der integrierten Menüs angezeigt werden sollen

Wenn die Microsoft Access-Datenbank oder das Microsoft Access-Projekt, welche Sie erstellen, dem Benutzer Zugriff auf eingebaute Menüs gewähren, können Sie die Anzeige der Menüs auf eine vordefinierte Untergruppe von Menüs beschränken. Auf diese Weise können Sie Menüs wie z. B. Ansicht und Einfügen, die es dem Benutzer erlauben, Objekte aus der Access-Datenbank oder dem Access-Projekt in der Entwurfsansicht anzuzeigen und deren Entwurf zu ändern, ausblenden.

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Unbeschränkte Menüs anzeigen.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Access-Datenbank oder des Access-Projekts wirksam.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Verhindern oder Zulassen, dass alle Symbol- oder Menüleisten in einer Access-Datenbank oder einem Access-Projekt geändert werden können

Verhindern oder Zulassen, dass alle Symbol- oder Menüleisten in einer Access-Datenbank oder einem Access-Projekt geändert werden können

Sie können festlegen, ob der Benutzer in der Lage sein soll, eingebaute oder benutzerdefinierte Symbol- und Menüleisten zu ändern.

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start sind erst beim nächsten Öffnen der Microsoft Access-Datenbank bzw. des Microsoft Access-Projekts gültig.

  • Diese Option betrifft nicht Symbolleisten für PivotTable-Listen oder -Tabellen auf einer Datenzugriffsseite.

  • Wenn Sie diese Option deaktivieren, können Sie Symbolleisten und Menüs trotzdem noch verschieben, vergrößern/verkleinern und andocken, vorausgesetzt, Sie haben nicht zuvor im Dialogfeld Anpassen für eine bestimmte Symbol- oder Menüleiste etwas anderes festgelegt.

  • Wenn diese Option deaktiviert ist, steht das Dialogfeld Anpassen nicht mehr zur Verfügung. Der Benutzer ist nicht mehr in der Lage Symbol- oder Menüleisten anzupassen, auch wenn für eine bestimmte Symbol- oder Menüleiste vorher im Dialogfeld Anpassen das Kontrollkästchen Anpassen zulassen aktiviert worden war.

  • Wenn Sie verhindern möchten, dass der Benutzer die eingebauten Symbolleisten verwendet, deaktivieren Sie das Kontrollkästchen Eingebaute Symbolleisten zulassen.

  • Wenn Sie nur die Kontextmenüs in Symbolleisten und Menüleisten deaktivieren möchten, lassen Sie das Kontrollkästchen Standardkontextmenüs zulassen aktiviert, deaktivieren jedoch das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen. Damit wird der Benutzer daran gehindert, Symbol- und Menüleisten anzupassen.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Festlegen einer globalen Menüleiste für Ihre Access-Datenbank oder Ihr Access-Projekt

Festlegen einer globalen Menüleiste für Ihre Access-Datenbank oder Ihr Access-Projekt

Wenn Sie eine eigene globale Menüleiste verwenden, können Sie bestimmen, welche Aufgaben andere Benutzer in Ihrer Microsoft Access-Datenbank oder Ihrem Microsoft Access-Projekt ausführen können. Auf diese Weise können Sie festlegen, welche Menüs und Befehle zur Verfügung stehen sollen, und Menüs und Befehle anpassen. Die globale Menüleiste ersetzt die eingebaute Menüleiste für alle Microsoft Access-Fenster, ausgenommen jedoch die Fälle, in denen Sie für ein Formular oder einen Bericht eine benutzerdefinierte Menüleiste erstellt haben.

  1. Klicken Sie im Menü Extras auf Start.

  2. Klicken Sie im Feld Menüleiste auf den Namen einer benutzerdefinierten Menüleiste aus der aktuellen Datenbank, oder klicken Sie auf (Standard), wenn Sie die eingebaute Menüleiste anzeigen möchten.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Access-Datenbank oder des Access-Projekts wirksam.

  • Auch wenn Sie eine globale Menüleiste definieren, kann die eingebaute Menüleiste noch zur Verfügung stehen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können die globale Menüleiste in einer Visual Basic für Applikationen-Prozedur festlegen oder ändern. Dazu stellen Sie die Eigenschaft Menüleiste des Objekts Application ein. Zum Anzeigen weiterer Informationen zur Eigenschaft Menüleiste klicken Sie auf [image] .

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Festlegen eines globalen Kontextmenüs für eine Access-Datenbank oder ein Access-Projekt

Festlegen eines globalen Kontextmenüs für eine Access-Datenbank oder ein Access-Projekt

Sie können ein globales Kontextmenü definieren, das eingebaute Kontextmenüs für Datenblätter, Formulare, Formular-Steuerelemente und Berichte ersetzt.

  1. Klicken Sie im Menü Extras auf Start.

  2. Klicken Sie im Feld Kontextmenüleiste auf den Namen eines benutzerdefinierten Kontextmenüs aus der aktuellen Microsoft Access-Datenbank bzw. dem aktuellen Microsoft Access-Projekt, oder klicken Sie auf (Standard), wenn Sie die eingebauten Kontextmenüs verwenden möchten.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start sind erst beim nächsten Öffnen der Access-Datenbank bzw. des Access-Projekts gültig.

  • Sie können das Kontextmenü in einer Visual Basic für Applikationen-Prozedur festlegen oder ändern. Dazu stellen Sie die Eigenschaft Kontextmenüleiste des Objekts Application ein. Zum Anzeigen weiterer Informationen zur Eigenschaft Kontextmenüleiste klicken Sie auf [image] .

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Aktivieren oder Deaktivieren von Kontextmenüs in einer Access-Datenbank oder einem Access-Projekt

Aktivieren oder Deaktivieren von Kontextmenüs in einer Access-Datenbank oder einem Access-Projekt

Sie können festlegen, ob der Benutzer auf eingebaute Kontextmenüs zugreifen darf.

  1. Klicken Sie im Menü Extras auf Start.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Standardkontextmenüs zulassen.

Anmerkungen

  • Änderungen an dieser Einstellung im Dialogfeld Start werden erst beim nächsten Öffnen der Microsoft Access-Datenbank oder des Microsoft Access-Projekts wirksam.

  • Diese Option gilt nicht für Kontextmenüs auf Datenzugriffsseiten, einschließlich der Kontextmenüs in PivotTable-Listen oder -Tabellen auf Datenzugriffsseiten.

  • Wenn Sie nur das Kontextmenü in Symbolleisten und Menüleisten deaktivieren möchten, lassen Sie das Kontrollkästchen Standardkontextmenüs zulassen aktiviert, deaktivieren jedoch das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen. Damit wird der Benutzer daran gehindert, Symbol- und Menüleisten anzupassen.

  • Zum Anzeigen einer Liste von Punkten, die beim Einstellen von Optionen im Dialogfeld Start zu berücksichtigen sind, klicken Sie auf [image] .


 Installieren oder Deinstallieren von Menü-Add-Ins

Installieren oder Deinstallieren von Menü-Add-Ins

Sie können Add-Ins unter Verwendung des Add-In-Managers installieren und deinstallieren.

  1. Zeigen Sie im Menü Extras auf Add-Ins und klicken Sie dann auf Add-In-Manager.

    Das Dialogfeld Add-In Manager wird angezeigt. Das Listenfeld Verfügbare Add-Ins zeigt die Add-Ins an, die momentan zur Verfügung stehen. Ein Add-In ist bereits installiert, wenn sich neben dessen Namen ein "X" befindet. Wenn ein Add-In deinstalliert wird, entfernt Microsoft Access das "X", der Name des Add-Ins wird jedoch weiterhin im Listenfeld angezeigt.

  2. Führen Sie einen der folgenden Schritte aus:
    • Zum Hinzufügen eines Add-Ins zu der Liste klicken Sie auf Hinzufügen und geben Sie anschließend den Pfad an.

    • Zum Installieren eines aktuell verfügbaren Add-Ins klicken Sie auf den Add-In-Namen im Listenfeld Verfügbare Add-Ins und klicken Sie dann auf Installieren.

    • Zum Deinstallieren eines aktuell verfügbaren Add-Ins klicken Sie auf den Add-In-Namen im Listenfeld Verfügbare Add-Ins und klicken Sie dann auf Deinstallieren.
  3. Klicken Sie auf Schließen, wenn Sie die Bearbeitung abgeschlossen haben.

Anmerkung Deinstallieren Sie ein Add-In, bevor Sie es als Datenbank öffnen, um dessen Entwurf zu bearbeiten.


 Assistenten, Add-Ins und Generatoren in Microsoft Access 2000

Assistenten, Add-Ins und Generatoren in Microsoft Access 2000

Assistent | Beschreibung
Abfrage-Assistent für Kreuztabellen | Erstellt eine Abfrage, die Daten in einem kompakten Format, das einer Kalkulationstabelle ähnelt, zusammenfasst.
Abfrage-Assistent zur Duplikatsuche | Erstellt eine Abfrage zum Abrufen von Datensätzen, die Duplikatwerte aufweisen und sich in einer einzelnen Tabelle oder Abfrage befinden.
Abfrage-Assistent zur Inkonsistenzsuche | Erstellt eine Abfrage zum Abrufen von Datensätzen in einer Tabelle, für die es in einer verknüpften Tabelle keine Entsprechung gibt.
Assistent zum Drucken von Beziehungen | Erstellt einen Bericht, in dem die Beziehungen in einer Microsoft Access-Datenbank mittels eines Diagramms dargestellt werden.
Assistent zur Behebung von Replikationskonflikten | Löst Konflikte, die beim Synchronisieren zwischen replizierten Datenbanken auftreten.
Assistent zur Datenbankaufteilung | Teilt Datenbanken in eine Backend- und eine Frontend-Datenbank, so dass ein oder mehrere Benutzer lokale Kopien der Frontend-Datenbank einsetzen können, die mit den Daten (in der Backend-Datenbank) auf einem Server verbunden sind.
Assistent zur Konvertierung eines Makros in ein Modul | Konvertiert Makros in Visual Basic-Code.
Assistent zur Leistungsanalyse | Analysiert die Leistung einer Datenbank und macht Vorschläge zur Verbesserung der Leistung.
Auswahlabfrage-Assistent | Erstellt eine Auswahlabfrage, die auf den von Ihnen ausgewählten Feldern basiert.
AutoBericht-Assistent | Erstellt einen Bericht automatisch.
AutoFormat-Assistent | Wendet ein vordefiniertes Format auf ein Formular oder einen Bericht an.
AutoFormular-Assistent | Erstellt ein Formular automatisch.
AutoSeiten-Assistent | Erstellt eine Datenzugriffsseite automatisch.
AutoWähler-Assistent | Ermöglicht Ihnen das Festlegen von Modeminformationen, wenn Sie in der Formularansicht auf eine AutoWähler-Schaltfläche klicken.
Befehlsschaltflächen-Assistent | Erstellt in einem Formular ein Befehlsschaltflächen-Steuerelement.
Benutzer-Datensicherheits- Assistent | Erstellt aus einer vorhandenen Datenbank eine neue, verschlüsselte Datenbank mit geregeltem Benutzerzugriff. Reguliert den Benutzerzugriff auf die aktuelle Datenbank und erstellt eine ungesicherte Sicherungskopie der Datenbank.
Bericht-Assistent | Erstellt einen Bericht, der auf einer Tabelle oder Abfrage basiert.
Datenbank-Assistent | Erstellt eine völlig neue Datenbank für eine Vielzahl unterschiedlicher Einsatzmöglichkeiten. Dabei stehen 2210 vordefinierte Modelle zur Verfügung.
Diagramm-Assistent | Fügt ein Diagramm zu einem Formular oder Bericht hinzu, das auf den Daten in einer Tabelle oder Abfrage basiert.
Dokumentierer | Erstellt einen Access-Bericht, in dem die Entwurfsmerkmale von Datenbankobjekten angezeigt werden.
Eingabeformat-Assistent | Erstellt ein Eingabeformat für ein Feld, das Sie in einer Tabelle auswählen.
Etiketten-Assistent | Erstellt Adressetiketten in Standardgrößen und benutzerdefinierten Größen.
Exchange/Outlook-Import-Assistent | Importiert einen Exchange- oder Outlook-Ordner in eine Tabelle einer Microsoft Access-Datenbank.
Exchange/Outlook-Verknüpfungs-Assistent | Verknüpft einen Exchange- oder Outlook-Ordner mit einer Tabelle in einer Microsoft Access-Datenbank.
Feldverknüpfungs-Assistent für Unterformulare/ -berichte | Verknüpft Felder in einem Hauptformular und einem Unterformular oder in einem Hauptbericht und einem Unterbericht.
Formular-Assistent | Erstellt ein neues Formular.
HTML-Import-Assistent | Importiert HTML-Tabellen und -Listen aus dem Internet oder einem Intranet in eine Microsoft Access-Tabelle.
HTML-Verknüpfungs-Assistent | Verknüpft eine HTML-Tabelle oder -Liste auf dem Internet oder einem Intranet in einer Microsoft Access-Tabelle.
Import-Assistent für Kalkulationstabellen | Importiert eine Microsoft Excel- oder eine andere Tabellenkalkulationstabelle in eine Microsoft Access-Tabelle.
Kombinationsfeld-Assistent | Erstellt in einem Formular ein Kombinationsfeld-Steuerelement.
Listenfeld-Assistent | Erstellt in einem Formular ein Listenfeld-Steuerelement.
Microsoft SQL Server Datenbank-Assistent | Erstellt eine neue Microsoft SQL Server-Datenbank, mit dem ein neues Microsoft Access-Projekt verbunden ist.
Microsoft Word- Seriendruck-Assistent | Verwaltet Seriendruckoperationen unter Verwendung von in Microsoft Word gespeicherten Briefen und in Microsoft Access gespeicherten Adressen.
Nachschlage-Assistent | Erstellt in einer Tabelle eine Nachschlage-Spalte, in der eine Liste von Werten angezeigt wird, aus der der Benutzer auswählen kann.
Optionsgruppen-Assistent | Erstellt in einem Formular eine Gruppe von Optionsschaltflächen.
PivotTable-Assistent | Erstellt in einem Microsoft Access-Formular eine Microsoft Excel-Pivot-Tabelle.
Seiten-Assistent | Erstellt eine neue Datenzugriffsseite.
Seitenbefehlsschaltflächen-Assistent | Erstellt eine Befehlsschaltfläche auf einer Datenzugriffsseite.
Seitenkombinationsfeld-Assistent | Erstellt ein Dropdownfeld auf einer Datenzugriffsseite.
Seitenlistenfeld-Assistent | Erstellt ein Listenfeld auf einer Datenzugriffsseite.
Tabellen-Assistent | Erstellt eine neue Tabelle.
Tabellenanalyse-Assistent | Teilt eine Tabelle mit vielen Duplikatwerten in verknüpfte Tabellen auf, die effektiver gespeichert werden können.
Tabellenverknüpfungs- Manager | Verwaltet Tabellenverknüpfungen zwischen Datenbanken.
Teilreplikations-Assistent | Erstellt oder ändert ein Teilreplikat einer Replikatsdatenbank.
Textexport-Assistent | Exportiert Daten in eine Textdatei.
Textimport-Assistent | Importiert eine Textdatei in eine Microsoft Access-Tabelle.
Textverknüpfungs-Assistent | Verknüpft eine Textdatei in einer Microsoft Access-Tabelle.
Übersichts-Manager | Erstellt und verwaltet Übersichtsformulare für Anwendungen.
Unterformular-/Unterberichts- Assistent | Erstellt in einem Formular oder Bericht ein neues Unterformular oder einen Unterbericht.
Upsizing-Assistent | Passt die Größe einer Microsoft Access-Datenbank an eine Microsoft SQL Server-Datenbank an.
Verknüpfungs-Assistent für Kalkulationstabellen | Verknüpft Tabellenkalkulationsdaten in einer Microsoft Access-Tabelle.

Generator | Beschreibung
Abfrage-Generator | Erstellt die korrekte Syntax für eine Abfrage.
Ausdrucks-Generator | Erstellt Ausdrücke für Makros, Abfragen und Eigenschaftenfenster.
Bild-Generator | Erstellt Bitmap-Bilder für Formulare und Berichte.
Farb-Generator | Zeigt eine Farbpalette zum Erstellen benutzerdefinierter Farben an.
Feld-Generator | Erstellt Felder in Tabellen.
Generator für ODBC- Verbindungszeichen- folgen | Erstellt die korrekte Syntax für eine Verbindung zu einer ODBC-Datenbank.

Add-In | Beschreibung
Add-In-Manager | Erlaubt das Installieren und Deinstallieren von Assistenten, Generatoren und Add-Ins.


 Erstellen eigener Assistenten, Generatoren und Add-Ins

Erstellen eigener Assistenten, Generatoren und Add-Ins

Um ein eigenes Add-In (einen Assistenten, einen Generator oder ein Menü-Add-In) zu entwickeln, können Sie mehrere Datenbankeigenschaften einstellen und in der Add-In-Datenbank (*.MDA, *.MDE) eine USysRegInfo-Tabelle erstellen, damit das Add-In unter Verwendung des Add-In-Managers installiert werden kann. Darüber hinaus können Sie ein COM-Add-In erstellen, das über den Add-In-Manager installiert werden kann. Weitere Informationen finden Sie in Kapitel 11, "Add-Ins, Assistenten, Bibliotheken und Vorlagen", im Microsoft Office 2000/Visual Basic Programmierhandbuch. Siehe auch Bezugsquellen für das Microsoft Office 2000/Visual Basic Programmierhandbuch.


 Info über das Suchen nach Dateien

Info über das Suchen nach Dateien

Suchen nach Dateien Die Dialogfelder Öffnen, Importieren und Verknüpfen (Menü Datei) sowie die Dialogfelder Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln (Menü Extras) unterstützen Sie bei der Suche nach Dateien auf Ihrer Festplatte und auf einem beliebigen Netzlaufwerk. Sie können nach einer Datei nach Dateiname, Typ, dem letzten Änderungsdatum oder nach Text in der Datei suchen, mit Ausnahme einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts. Sie können auch nach bestimmten Dateieigenschaften, wie z. B. Autor, Thema, Titel oder Erstellungsdatum, nach einer Datei suchen. Informationen über Suchen nach Dateien anzeigen.

Anhand von Dateieigenschaften nach Dateien suchen Dateieigenschaften sind Details über die Datei, die die Identifizierung der Datei erleichtern - z. B. ein beschreibender Titel, der Name des Autors, das Thema, Schlüsselwörter, die Sie der Datei zuweisen oder andere wichtige Informationen.

  • Einige Dateieigenschaften sind voreingestellt Dazu gehören Eigenschaften wie Autor, Titel und Thema, die bereits vorhanden sind und diejenigen, für die Sie einen Wert eingeben. Sie können beispielsweise das Schlüsselwort "Personal" zu allen Personaldatenbankdateien hinzufügen und anschließend nach allen Dateien mit diesem Schlüsselwort suchen.

  • Erstellen Sie eigene Dateieigenschaften Sie können zusätzliche Dateieigenschaften eingeben, wie z. B. einen beschreibenden Titel oder Schlüsselwörter zum Identifizieren der Datei. So können Sie die Datei schnell finden, indem Sie nach diesen Informationen suchen. Informationen über Festlegen von Dateieigenschaften, die zum Suchen von Dateien verwendet werden können anzeigen.

  • Einige Eigenschaften werden automatisch aktualisiert Dazu gehören statistische Angaben, wie z. B. Dateigröße und das Erstellungsdatum und das letzte Änderungsdatum. Sie können diese Eigenschaften beispielsweise verwenden, um nach allen Dateien zu suchen, die nach dem 3. März 1998 erstellt wurden. Sie können auch nach allen Dateien suchen, die gestern zuletzt geändert wurden. Informationen über Unter Verwendung von Dateieigenschaften nach Dateien suchen anzeigen.

Unter Verwendung besonderer Kriterien nach Dateien suchen Klicken Sie im Dialogfeld Öffnen auf Extras und dann auf Suchen, um unter Verwendung von Nichttexteigenschaften oder erweiterten Kombinationen aus Kriterien nach einer Datei zu suchen. Sie können z. B. nach Dateien suchen, die den Text "Budget" enthalten oder das Schlüsselwort "Budget99" haben.

Suchkriterien speichern Wenn Sie immer wieder nach denselben Informationen suchen oder eine komplexe Suche mit mehreren Suchkriterien ausführen möchten, können Sie den Suchlauf zur späteren Verwendung speichern. Informationen über Speichern von Suchkriterien anzeigen.

Gespeicherte Suchkriterien ändern Sie haben die Möglichkeit, gespeicherte Suchkriterien zu ändern. Informationen über Ändern von gespeicherten Suchkriterien anzeigen.

Zurück zu Dateien suchen


 Auffinden von Dateien

Auffinden von Dateien

Wenn Sie die Datei, die Sie öffnen möchten, nicht mit Hilfe der Tastenkombinationen aus der Umgebungsleiste oder durch Durchsuchen der Ordner, in denen Sie normalerweise Dokumente speichern, finden, können Sie in Access Suchkriterien eingeben (klicken Sie im Dialogfeld Öffnen auf Extras und dann auf Suchen).

Was möchten Sie tun?

Nach Dateien suchen

Unter Verwendung von Dateieigenschaften nach Dateien suchen

Mit einem gespeicherten Suchlauf nach Dateien suchen

Eine gespeicherte Suche ändern

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Sortieren einer Dateiliste

Sortieren einer Dateiliste

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf den Pfeil neben Ansichten [image], zeigen Sie auf Symbole anordnen, und klicken Sie dann auf den gewünschten Befehl.

Anmerkung Sie können eine Dateiliste auch mit den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras sortieren.


 Verbinden mit einem Netzlaufwerk

Verbinden mit einem Netzlaufwerk

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Netzlaufwerk verbinden.

  3. Klicken Sie im Feld Laufwerk auf den Laufwerksbuchstaben, der für die Verbindung zum Netzwerk verwendet werden soll.

  4. Geben Sie im Feld Pfad den Pfad zu dem freigegebenen Ordner an, zu dem Sie sich verbinden wollen.

Tipp Um bei jedem Starten von Microsoft Windows automatisch eine Verbindung zu diesem Netzlaufwerk herzustellen, aktivieren Sie das Kontrollkästchen Beim Anmelden erneut verbinden.


 Zurückgehen zum zuletzt verwendeten Laufwerk, Ordner oder zur zuletzt besuchten Internetadresse

Zurückgehen zum zuletzt verwendeten Laufwerk, Ordner oder zur zuletzt besuchten Internetadresse

  • Klicken Sie im Dialogfeld Öffnen (Menü Datei) auf die Schaltfläche Zurück [image] .

Tipp Der Name des zuletzt verwendeten Laufwerks, Ordners bzw. der zuletzt besuchten Internetadresse wird im QuickInfo angezeigt, wenn Sie den Mauszeiger auf die Schaltfläche Zurück bewegen.


 Möglichkeiten zum Erstellen von Hyperlinks oder Verknüpfungen mit Dateien, Ordnern und Webseiten

Möglichkeiten zum Erstellen von Hyperlinks oder Verknüpfungen mit Dateien, Ordnern und Webseiten

Über Hyperlinks und den Ordner Favoriten können Sie Verknüpfungen mit Dateien, Ordnern und Webseiten erstellen.

Hyperlinks Sie können einen Hyperlink in einer Tabelle, einem Formular oder einer Datenzugriffsseite erstellen und anschließend den Hyperlink verwenden, um zu einer Vielzahl von Speicherorten zu wechseln, so z. B. zu einem Datenbankobjekt in einer anderen Microsoft Access-Datenbank oder einem Microsoft Access-Projekt, einem Microsoft Word-Dokument oder einer Microsoft Excel-Arbeitsmappe oder zu einer Internet-, Intranet- oder E-Mail-Adresse. Sie können einen Hyperlink in einem Textfeld erstellen, das auf einem Hyperlink-Feld, einer Befehlsschaltfläche in einem Formular, einer Bezeichnung oder einem Bild in einem Formular oder einer Datenzugriffsseite basiert. Sie können ferner einer Symbolleistenschaltfläche einen Hyperlink zuordnen, damit Sie zu häufig genutzten Dateien, Webseiten oder E-Mail-Adressen springen können.

Der Ordner "Favoriten" Der Ordner Favoriten eignet sich gut zum Speichern häufig verwendeter Dateien und Ordnern, die sich auch an Remote-Netzwerkspeicherorten befinden können. Die ursprüngliche Datei oder der ursprüngliche Ordner werden nicht verschoben. Sie erstellen stattdessen eine Verknüpfung, über die Sie zu der Datei oder dem Ordner wechseln können. Durch das Speichern von Verknüpfungen im Ordner Favoriten haben Sie einen schnellen Zugriff auf eine beliebige Datei, ohne dass Sie sich merken müssen, wo die Datei gespeichert ist. Um schnell auf Dateien im Ordner Favoriten zuzugreifen, klicken Sie im Dialogfeld Öffnen (Menü Datei) in der Umgebungsleiste auf Favoriten [image] .

Zurück zu Erstellen von Verknüpfungen mit Dateien, Ordnern und Webseiten


 Suchen nach Dateien

Suchen nach Dateien

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Suchen.

  3. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, das bzw. den Sie durchsuchen möchten.

  4. Zum Durchsuchen aller Unterordner der ausgewählten Ordner und zum Anzeigen der Ordner, die die gefundenen Dateien enthalten, aktivieren Sie das Kontrollkästchen Unterordner durchsuchen.

  5. Klicken Sie im Feld Eigenschaft auf Dateiname.

  6. Klicken Sie im Feld Bedingung auf den gewünschten Eintrag.
  7. Geben Sie in das Feld Wert den Dateinamen ganz oder teilweise ein.

  8. Klicken Sie auf Zur Liste hinzufügen.

  9. Klicken Sie auf Suche starten.

Anmerkungen

  • Um mehrere Laufwerke gleichzeitig zu durchsuchen, trennen Sie die Laufwerksnamen bei der Eingabe in das Feld Suchen in durch ein Semikolon. Geben Sie z. B. C:\;D:\ ein.

  • Sie können nicht nach einer Datei suchen, indem Sie in einer Datei aus einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt nach dem Text suchen.

  • Sie können auch mit den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras nach Dateien suchen.


 Löschen einer gespeicherten Suche

Löschen einer gespeicherten Suche

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Suchen.

  3. Klicken Sie auf Gespeicherte Suchläufe.

  4. Klicken Sie auf den Namen der Suche und dann auf Löschen.

Anmerkung Sie können eine gespeicherte Suche auch in den Dialogfeldern Importieren oder Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras löschen.


 Suchen nach Dateien unter Verwendung von Dateieigenschaften

Suchen nach Dateien unter Verwendung von Dateieigenschaften

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Suchen.

  3. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, das bzw. den Sie durchsuchen möchten.

    Wenn Sie mehrere Laufwerke zugleich durchsuchen möchten, trennen Sie die Laufwerksnamen im Feld Suchen in durch Semikolons. Geben Sie z. B. C:\;D:\ ein.

  4. Zum Durchsuchen aller Unterordner der ausgewählten Ordner und zum Anzeigen der Ordner, die die gefundenen Dateien enthalten, aktivieren Sie das Kontrollkästchen Unterordner durchsuchen.

  5. Geben Sie unter Weitere Kriterien definieren Suchkriterien an. Wählen Sie dazu in den Feldern Eigenschaft, Bedingung und Wert die gewünschten Optionen aus, und klicken Sie auf Zur Liste hinzufügen.

    Anmerkung Wenn Sie nach einer anderen Office-Datei als einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt suchen, können Sie auch nach einem zusammengesetzten Begriff aus der Datei, wie z. B. "Apfelkuchen mit Sahne", suchen. Wählen Sie im Feld Eigenschaft den Eintrag Text oder Eigenschaft aus, und geben Sie den Begriff in doppelten Anführungszeichen in das Feld Wert ein. Verwenden von Bedingungen und Werten in einer Suche.

  6. Zum Erstellen zusätzlicher Suchkriterien klicken Sie auf Und oder auf Oder, und wiederholen Sie dann Schritt 5.

  7. Wählen Sie alle anderen gewünschten Optionen aus.

    Zum Aufrufen der Hilfe zu einer Option klicken Sie auf das Fragezeichen [image] und dann auf die Option.

  8. Zum Speichern der Suchkriterien für die spätere Verwendung klicken Sie auf Suche speichern, geben Sie einen Namen in das Feld Name dieses Suchvorgangs ein, und klicken Sie dann auf OK.

    Sie können beschreibende Namen mit bis zu 80 Zeichen verwenden, die auch Leerzeichen enthalten können.

  9. Zum Starten der Suche klicken Sie auf Suche starten.

Anmerkungen

  • Sie können benutzerdefinierte Eigenschaften erstellen, die durchsucht werden, wenn Sie später nach einer Datenbank suchen. Wie wird's gemacht?

  • Sie können nicht nach einer Datei suchen, indem Sie in einer Datei aus einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt nach dem Text suchen.

  • Sie können auch mit den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras nach Dateien suchen.


 Unter Verwendung von gespeicherten Suchkriterien nach Dateien suchen

Unter Verwendung von gespeicherten Suchkriterien nach Dateien suchen

Damit Sie gespeicherte Suchkriterien verwenden können, müssen Sie über einen gespeicherten Suchlauf verfügen. Eingeben und Speichern von Suchkriterien.

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Suchen.

  3. Klicken Sie auf Suche öffnen.

  4. Klicken Sie auf den Namen der Suche, die Sie verwenden möchten und dann auf Öffnen.

  5. Klicken Sie auf Suche starten.

Anmerkung Sie können auch mit den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder mit den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras nach Dateien suchen.


 Verwenden der Dateieigenschaften zum Suchen von Dateien

Verwenden der Dateieigenschaften zum Suchen von Dateien

Was möchten Sie tun?

Informationen über die Verwendung von Dateieigenschaften zum Suchen von Dateien anzeigen

Dokumentieren der Eigenschaften und verknüpften Schlüsselwörter einer Datenbank

Erstellen benutzerdefinierter Datenbankeigenschaften für die Verwendung beim Suchen einer Datei

Ändern oder Löschen von benutzerdefinierten Datenbankeigenschaften

Anzeigen einer Liste mit Datenbankobjekten in der aktuellen Datenbank

Anzeigen der Attribute einer Datenbankdatei

Anmerkungen

  • Mit Ausnahme der Eigenschaften in den Registerkarten Allgemein und Statistik im Dialogfeld Datenbankeigenschaften und der Eigenschaften einer Datenzugriffsseite können Dateieigenschaften auch in Visual Basic für Applikationen bearbeitet werden.

  • Wenn Sie eine Microsoft Access-Datenbank, ein Microsoft Access-Projekt oder eine Datenzugriffsseite über das Dialogfeld Öffnen suchen, können Sie mit den Suchkriterien die Eigenschaften der Datei angeben, nach der Sie suchen. Sie können z. B. nach einer Datenbank suchen, deren Contents-Eigenschaft eine Tabelle mit der Bezeichnung Lieferanten enthält. Informationen über Suchen nach Datendateien anhand von Dateieigenschaften anzeigen.


 Kopieren einer Datei

Kopieren einer Datei

  1. Klicken Sie auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in dem sich die Datei befindet, die Sie kopieren möchten.

  3. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, der die gewünschte Datei enthält.

    Wenn Sie die Datei nicht in der Ordnerliste finden, können Sie eine Suche durchführen.

    Wie?

  4. Rechtsklicken Sie auf die Datei, die Sie kopieren möchten, und klicken Sie anschließend im Kontextmenü auf Kopieren.

  5. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in das/den Sie die Datei kopieren möchten.

  6. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, in den Sie die Datei kopieren möchten.

  7. Klicken Sie mit der rechten Maustaste auf die Ordnerliste, ohne dadurch eine Datei zu markieren, und klicken Sie dann im Kontextmenü auf Einfügen.

    Der Befehl Einfügen ist nicht verfügbar, wenn eine Datei in der Ordnerliste markiert ist.


 Löschen einer Datei

Löschen einer Datei

  1. Klicken Sie auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in dem sich die Datei befindet, die Sie löschen möchten.

  3. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, der die gewünschte Datei enthält.

    Wenn Sie die Datei nicht in der Ordnerliste finden, können Sie eine Suche durchführen.

    Wie?

  4. Klicken Sie mit der rechten Maustaste auf die Datei, die Sie löschen möchten, und klicken Sie anschließend im Kontextmenü auf Löschen.


 Umbenennen einer Datei

Umbenennen einer Datei

  1. Klicken Sie auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in dem sich die Datei befindet, die Sie umbenennen möchten.

  3. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, der die gewünschte Datei enthält.

    Wenn Sie die Datei nicht in der Ordnerliste finden, können Sie eine Suche durchführen.

    Wie?

  4. Klicken Sie mit der rechten Maustaste auf die Datei, die Sie umbenennen möchten, und klicken Sie anschließend im Kontextmenü auf Umbenennen.

  5. Geben Sie den neuen Namen ein, und drücken Sie dann die EINGABETASTE.


 Verschieben einer Datei

Verschieben einer Datei

  1. Klicken Sie auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in dem sich die Datei befindet, die Sie verschieben möchten.

  3. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, der die gewünschte Datei enthält.

    Wenn Sie die Datei nicht in der Ordnerliste finden, können Sie eine Suche durchführen.

    Wie?

  4. Klicken Sie mit der rechten Maustaste auf die Datei, die Sie verschieben möchten, und klicken Sie anschließend im Kontextmenü auf Ausschneiden.

  5. Klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in das/den Sie die Datei verschieben möchten.

  6. Doppelklicken Sie in der Ordnerliste auf die entsprechenden Ordner, bis Sie den Ordner geöffnet haben, in den Sie die Datei verschieben möchten.

  7. Klicken Sie mit der rechten Maustaste auf die Ordnerliste, ohne dadurch eine Datei zu markieren, und klicken Sie dann im Kontextmenü auf Einfügen.

    Der Befehl Einfügen ist nicht verfügbar, wenn eine Datei in der Ordnerliste markiert ist.


Anzeigen aller Dateitypen und Dateinamenerweiterungen

  1. Öffnen Sie im Fenster Arbeitsplatz oder im Windows Explorer den Ordner, dessen Dateien Sie anzeigen möchten.

  2. Klicken Sie im Menü Ansicht auf Optionen.

  3. Wenn Sie alle Dateitypen anzeigen möchten, klicken Sie in der Registerkarte Ansicht auf Alle Dateien anzeigen.

    Wenn Sie in Windows 95 alle Dateinamenerweiterungen anzeigen möchten, entfernen Sie auf der Registerkarte Ansicht die Markierung aus dem Kontrollkästchen Keine MS-DOS-Erweiterungen für registrierte Dateien.

    Wenn Sie in Windows 98 alle Dateinamenerweiterungen anzeigen möchten, entfernen Sie die Markierung aus dem Kontrollkästchen Dateinamenserweiterung bei bekannten Dateitypen ausblenden in der Registerkarte Ansicht.

    Anmerkung Die letzten beiden Einstellungen legen fest, ob Dateinamenerweiterungen in der Liste Dateityp in den Dialogfeldern Öffnen, Exportieren, Importieren und Verknüpfen angezeigt werden.


 Der beste Ort zum Speichern von Dateien

Der beste Ort zum Speichern von Dateien

Wenn Sie die Dialogfelder Öffnen und Neue Datenbankdatei in Microsoft Access zum ersten Mal öffnen, ist der Ordner Eigene Dokumente der Standardarbeitsordner (oder aktive Ordner). So ändern Sie den Standardarbeitsordner.

Der Ordner "Eigene Dokumente"

Der Ordner Eigene Dokumente ist ein guter Ort, um Microsoft Access-Datenbanken, Microsoft Access-Projekte, Datenzugriffsseiten sowie andere Dateien, an denen Sie arbeiten, z.B. Dokumente, Tabellenblätter und Präsentationen, zu speichern. Um schnell auf Dateien im Ordner Eigene Dokumente zuzugreifen, klicken Sie auf der Umgebungsleiste auf Eigene Dokumente [image] .

Der Ordner "Favoriten"

Der Ordner Favoriten ist ein guter Ort, um häufig verwendete Verknüpfungen zu Dateien und Ordnern, auch wenn sich diese an entfernten Positionen im Netz befinden, zu speichern. Die ursprüngliche Datei wird nicht verschoben. Es wird lediglich eine Verknüpfung zu der Datei oder dem Ordner erstellt. Durch das Speichern von Verknüpfungen im Ordner Favoriten erhalten Sie schnellen Zugriff auf jede beliebige Datei, ohne dass Sie sich ihren Pfad merken müssen. Um schnell auf Dateien im Ordner Favoriten zuzugreifen, klicken Sie auf der Umgebungsleiste auf Favoriten [image] . Erstellen einer Datei- oder Ordnerverknüpfung zum Ordner "Favoriten".

Webordner

Webordner eignen sich gut, um im Internet und in einem Intranet zu verwendende Datenzugriffsseiten-Dateien zu speichern. Diese Dateien befinden sich auf einem Webserver, um einen schnellen Zugriff zu ermöglichen. Um schnell auf Dateien zuzugreifen, die auf einem Webserver gespeichert sind, klicken Sie auf den Umgebungsleisten auf Webordner. Informationen zu Webordner.


Wann werden die Ordner FAVORITEN und EIGENE DATEIEN verwendet?

Verwenden Sie den Ordner FAVORITEN, um Verknüpfungen zu häufig verwendeten Datenbanken zu speichern, einschließlich solcher, die sich an Remote-Standorten befinden. Der Standort von Originaldatei bzw. -ordner ändert sich dabei nicht. Für den schnellen Zugriff auf die Datei können Sie dann eine Verknüpfung verwenden und brauchen sich so nicht an den Standort der Datei zu erinnern. Um Informationen zum automatischen Hinzufügen einer Datenbankverknüpfung zum Ordner FAVORITEN anzuzeigen, klicken Sie auf [image] .

Im Ordner EIGENE DATEIEN speichern Sie alle Originaldatenbanken und anderen Dateien. Dadurch brauchen Sie jeweils nur eine Sicherungskopie eines einzigen Ordners zu erstellen. Hierbei handelt es sich um den Standardordner für neue Microsoft Access-Datenbanken, sofern Sie diesen nicht ändern. Um weitere Informationen zum Standardordner anzuzeigen, klicken Sie auf [image] .


Warum wird beim Öffnen oder Erstellen einer neuen Datenbank der Ordner "Eigene Dateien" standardmäßig angezeigt?

Der Standardarbeitsordner in Microsoft Access ist der Ordner Eigene Dateien. In diesem können Sie alle Ihre Dateien speichern, so dass Sie lediglich eine Sicherheitskopie dieses einen Ordners erstellen müssen.

Sie können den Ordner Eigene Dateien umbenennen oder verschieben; Microsoft Windows wird ihn dennoch als den Standardordner für Ihre Dateien erkennen. Wenn Sie also Microsoft Access erneut starten, wird der umbenannte Ordner standardmäßig angezeigt, unabhängig von seinem jeweiligen Namen oder Standort auf Ihrem Computer. Wenn Sie den Ordner Eigene Dateien löschen, wird er automatisch beim nächsten Starten der Anwendung erneut erstellt.

Wenn Sie möchten, können Sie auch einen anderen Ordner dauerhaft als Microsoft Access-Standardordner verwenden. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .


Festlegen des Standardarbeitsordners

Sie können den Standardarbeitsordner für alle Office-Programme ändern - und für die Schaltfläche und den Befehl Office-Dokument öffnen. Dazu benennen Sie den Ordner Eigene Dateien um und/oder verschieben ihn an einen anderen Speicherort. Sie können den Standardarbeitsordner für Microsoft Access in Windows und Windows NT Workstation 4.0 oder höher ändern.

Was möchten Sie tun?

Ändern des Standardarbeitsordners für Office

Ändern des Standardarbeitsordners nur für Microsoft Access

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Ändern des Standardarbeitsordners nur für Microsoft Access

  1. Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Allgemein.

  2. Geben Sie im Feld Standarddatenbankordner den Pfad für den Ordner an, den Sie als Standardarbeitsordner anzeigen möchten.

    Geben Sie z. B. C:\ARBEIT ein.


Ändern des Standardarbeitsordners für Office

  1. Speichern und schließen Sie alle Office-Dateien, und beenden Sie dann alle Office-Programme.

  2. Verschieben oder kopieren Sie im Windows Explorer alle Dateien, die Sie schnell finden möchten, in den Ordner Eigene Dateien.

  3. Klicken Sie im Windows Explorer mit der rechten Maustaste auf den Ordner Eigene Dateien, und klicken Sie dann im Kontextmenü auf Umbenennen. Geben Sie einen neuen Namen für den Ordner ein, und drücken Sie dann die EINGABETASTE.

    Wenn Sie den Ordner Eigene Dateien verschieben möchten, ziehen Sie ihn im Windows Explorer an die gewünschte neue Position in der Verzeichnisstruktur.


Anzeigen des Druckstatus von Drucker und Dateien während des Druckes

  • Doppelklicken Sie auf das Druckersymbol neben der Uhr in der Windows-Taskleiste.

    Wenn der Druck einer Datei beendet wurde, wird das Druckersymbol entfernt.


Einstellen des Standarddruckers

Zum Ausführen dieser Prozedur müssen Sie einen Drucker eingerichtet haben. Informationen über das Einrichten eines Druckers anzeigen.

  1. Zeigen Sie im Windows Startmenü auf Einstellungen, und klicken Sie dann auf Drucker.

  2. Klicken Sie mit der rechten Maustaste auf das Symbol für den Drucker, den Sie als Standarddrucker verwenden möchten, und klicken Sie dann im Kontextmenü auf Als Standard definieren.

    Wenn dieser Befehl durch ein Häkchen markiert ist, ist der Drucker bereits als Standarddrucker eingestellt.


Einstellen eines neuen Druckers

  1. Zeigen Sie im Windows Startmenü auf Einstellungen, und klicken Sie dann auf Drucker.

  2. Doppelklicken Sie auf das Symbol Neuer Drucker [image].

  3. Befolgen Sie die Anweisungen des Assistenten für die Druckerinstallation.

    Wenn Sie eine Testseite drucken möchten, stellen Sie sicher, dass der Drucker eingeschaltet und druckbereit ist.

Tipp Wenn Sie einen gemeinsam genutzten Netzwerkdrucker verwenden möchten, können Sie auf das Symbol Netzwerkumgebung auf dem Windows-Desktop doppelklicken, um den Drucker schnell und einfach einzustellen. Doppelklicken Sie auf den Computer, an den der gemeinsam genutzte Drucker angeschlossen ist. Klicken Sie auf das Druckersymbol und anschließend im Menü Datei auf Installieren.


Datenbanken: Definition und Funktionsweise

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Wenn Sie dieses Thema mit Hilfe der Tastatur anzeigen möchten, aktivieren Sie mit F6 das Themenfenster, wählen Sie mit TAB die Grafik aus, und drücken Sie dann die EINGABETASTE.


 Entwerfen einer Datenbank

Entwerfen einer Datenbank

Bevor Sie Microsoft Access verwenden, um die Tabellen, die Formulare und die anderen Objekte zu erstellen, aus denen Ihre Datenbank bestehen soll, sollten Sie sich etwas Zeit nehmen, um den Entwurf Ihrer Datenbank zu planen. Ob Sie nun eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt verwenden: ein durchdachter Datenbankentwurf ist der Schlüssel für eine Datenbank, die die gewünschten Aufgaben wirksam, präzise und effizient ausführt.

Weitere Informationen über Microsoft Access-Datenbanken und ihre Funktionsweise.

Informationen über Microsoft Access-Projekte.

Schritte zum Entwerfen einer Datenbank

Diese Seite enthält Übersichtsinformationen zu den folgenden grundlegenden Schritten beim Entwerfen einer Datenbank:

  1. Legen Sie den Verwendungszweck Ihrer Datenbank fest.

  2. Bestimmen Sie die Tabellen, die Sie in der Datenbank benötigen.

  3. Bestimmen Sie die Felder, die Sie in den Tabellen benötigen.

  4. Bestimmen Sie Felder mit eindeutigen Werten in jedem Datensatz.

  5. Legen Sie die Beziehungen zwischen den Tabellen fest.

  6. Überarbeiten Sie Ihren Entwurf.

  7. Fügen Sie Daten hinzu, und erstellen Sie andere Datenbankobjekte.

  8. Verwenden Sie die Analyse-Tools von Microsoft Access.

1 Legen Sie den Verwendungszweck Ihrer Datenbank fest

Der erste Schritt beim Entwerfen einer Datenbank besteht darin, den Zweck und die Art ihrer Verwendung festzulegen. Sie müssen wissen, welche Informationen Sie aus der Datenbank abrufen möchten. Auf dieser Grundlage können Sie bestimmen, über welche Themen Sie Daten speichern möchten (die Tabellen), und welche Daten Sie über die einzelnen Themen speichern möchten (die Felder in den Tabellen).

Sprechen Sie mit den zukünftigen Benutzern der Datenbank. Sammeln Sie deren und Ihre eigenen Fragen, zu denen die Datenbank Antworten liefern soll. Entwerfen Sie die Berichte, die die Datenbank erstellen soll. Sammeln Sie die Formulare, die Sie aktuell zum Erfassen der Daten verwenden. Schauen Sie sich durchdachte Entwürfe bestehender Datenbanken an, die Ihrer Datenbank gleichen.

Zurück zum Anfang

2 Bestimmen Sie die benötigten Tabellen

Das Bestimmen der Tabellen ist einer der schwierigsten Schritte im Datenbankentwurfsprozess, denn die Ergebnisse, die von Ihrer Datenbank erwartet werden (zu druckende Berichte, verfügbare Formulare, zu beantwortende Fragen), liefern nicht immer einen Hinweis über die Struktur der zugrunde liegenden Tabellen.

Sie brauchen Ihre Tabellen nicht mit Microsoft Access zu entwerfen. Es ist tatsächlich manchmal sinnvoller, den Entwurf zunächst auf Papier zu erstellen und zu überarbeiten. Wenn Sie Ihre Tabellen erstellen, unterteilen Sie die Informationen, wobei Sie die folgenden wesentlichen Entwurfsgrundsätze berücksichtigen:

  • Eine Tabelle sollte keine Informationen doppelt enthalten, und die gleichen Informationen sollten nicht in mehreren Tabellen enthalten sein. In dieser Hinsicht unterscheidet sich eine Tabelle einer relationalen Datenbank von einer Tabelle, die eine mit unstrukturierten Daten arbeitende Anwendung verwendet, beispielsweise einer Kalkulationstabelle.

    Wenn jede Information nur in einer Tabelle gespeichert wird, brauchen Sie Aktualisierungen auch nur an einer Stelle vorzunehmen. Dies ist effizienter und verhindert doppelte Einträge, die unterschiedliche Informationen enthalten. Speichern Sie z. B. jede Kundenadresse und Telefonnummer nur einmal, und zwar in einer Tabelle.

  • Jede Tabelle sollte Informationen zu einem einzigen Thema enthalten.

    Wenn jede Tabelle nur Daten zu einem einzigen Thema enthält, können Sie die Informationen zu jedem Thema unabhängig von anderen Themen verwalten. Speichern Sie z.B. Kundenadressen in einer und die Bestellungen der Kunden in einer anderen Tabelle, so dass Sie eine Bestellung löschen können, ohne die Kundeninformationen zu verlieren.

Weitere Informationen über Tabellen einer Microsoft Access-Datenbank und ihre Funktionsweise. Weitere Informationen über das Optimieren der allgemeinen Tabellenleistung in einer Access-Datenbank.

Informationen über das Optimieren der Leistung eines Microsoft Access-Projekts.

Zurück zum Anfang

3 Bestimmen Sie die benötigten Felder

Jede Tabelle enthält Informationen über ein Thema, und jedes Feld in der Tabelle enthält einzelne Fakten über den Gegenstand der Tabelle. Eine Kundentabelle enthält z.B. Felder für den Firmennamen, die Anschrift, den Ort, das Land und die Telefonnummer. Wenn Sie die Felder für die einzelnen Tabellen festlegen, berücksichtigen Sie die folgenden Tipps:

  • Jedes Feld steht in direktem Bezug zum Gegenstand der Tabelle.

  • Fügen Sie keine abgeleiteten oder berechneten Daten hinzu (Daten, die das Ergebnis eines Ausdrucks sind).

  • Fügen Sie alle Informationen hinzu, die Sie benötigen.

  • Speichern Sie die Informationen in den kleinstmöglichen logischen Einheiten (z.B. Vorname und Nachname, anstatt lediglich Name).

Informationen über die in einer Access-Datenbank verfügbaren Felddatentypen.

Vergleichen Sie die Felddatentypen in einer Access-Datenbank mit denjenigen in einem Access-Projekt.

Zurück zum Anfang

4 Bestimmen Sie das Feld bzw. die Felder mit eindeutigen Werten in jedem Datensatz.

Damit Microsoft Access die in verschiedenen Tabellen gespeicherten Informationen (z.B. einen Kunden mit allen seinen Bestellungen) verbindet, muss jede Tabelle in Ihrer Datenbank ein Feld oder eine Gruppe von Feldern enthalten, die die einzelnen Datensätze in der Tabelle eindeutig kennzeichnen. Ein solches Feld oder eine solche Gruppe von Feldern wird als Primärschlüssel bezeichnet.

Informationen über Primärschlüssel in einer Access-Datenbank.

Informationen über Primärschlüssel in einer Microsoft SQL Server-Datenbank.

Zurück zum Anfang

5 Legen Sie die Beziehungen zwischen den Tabellen fest

Nachdem Sie Ihre Informationen in Tabellen aufgeteilt und die Primärschlüsselfelder bestimmt haben, benötigen Sie eine Möglichkeit, Microsoft Access mitzuteilen, wie die verwandten Informationen wieder auf sinnvolle Weise zusammengefügt werden. Dazu definieren Sie Beziehungen zwischen den Tabellen einer Microsoft Access-Datenbank.

Weitere Informationen über Beziehungen innerhalb einer Microsoft SQL Server-Datenbank.

Es kann hilfreich sein, die Beziehungen in einem bestehenden, wohldurchdachten Datenbankentwurf anzuschauen. Wenn Sie z. B. die Beziehungen in der Beispieldatenbank Nordwind anzeigen möchten, öffnen Sie NORDWIND.MDB, und klicken Sie im Menü Extras auf Beziehungen. Oder vielleicht möchten Sie die Beziehungen in dem Access-Beispielprojekt Nordwind und der dazugehörigen Microsoft SQL Server-Datenbank untersuchen.

Weitere Informationen über referenzielle Integrität.

Zurück zum Anfang

6 Überarbeiten Sie Ihren Entwurf.

Nachdem Sie die benötigten Tabellen, Felder und Beziehungen entworfen haben, ist es an der Zeit, den Entwurf zu untersuchen und mögliche Fehler aufzuspüren. Es ist einfacher, Ihren Datenbankentwurf zu ändern, bevor Sie die Tabellen mit Daten gefüllt haben.

Verwenden Sie Microsoft Access, um die Tabellen zu erstellen, die Beziehungen zwischen den Tabellen festzulegen und ausreichend Beispieldaten in jede Tabelle einzugeben. Auf diese Weise können Sie den Entwurf überprüfen. Um die Beziehungen in Ihrer Datenbank zu testen, versuchen Sie, Abfragen zu erstellen, die die gewünschten Antworten liefern können. Erstellen Sie Rohentwürfe Ihrer Formulare und Berichte, und prüfen Sie, ob die gewünschten Daten angezeigt werden. Suchen Sie nach nicht benötigten, doppelten Daten, und löschen Sie diese. Wenn Sie auf Probleme stoßen, bearbeiten Sie den Entwurf.

Weitere Informationen über Abfragen in einer Access-Datenbank und ihre Funktionsweise.

Weitere Informationen über das Arbeiten mit Sichten in einer Microsoft SQL Server-Datenbank.

Zurück zum Anfang

7 Fügen Sie Daten hinzu, und erstellen Sie andere Datenbankobjekte

Wenn Sie mit der Tabellenstruktur zufrieden sind, und wenn diese die hier beschriebenen Entwurfsprinzipien erfüllt, geben Sie alle vorhandenen Daten in die Tabellen ein. Sie können anschließend alle benötigten Abfragen, Formulare, Berichte, Datenzugriffsseiten, Makros und Module erstellen.

Vergleich der Datenbankobjekte einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts.

Weitere Informationen über das Importieren von Daten in eine Access-Datenbank.

Zurück zum Anfang

8 Verwenden Sie die Analyse-Tools von Microsoft Access

Microsoft Access stellt zwei Tools zur Verfügung, die Ihnen beim Überarbeiten des Entwurfs Ihrer Access-Datenbank helfen. Der Tabellenanalyse-Assistent untersucht den Entwurf einzelner Tabellen, schlägt gegebenenfalls neue Tabellenstrukturen und Beziehungen vor und teilt eine Tabelle in neue verknüpfte Tabellen auf, wenn dies sinnvoll ist. Zum Anzeigen von Informationen über das Ausführen des Tabellenanalyse-Assistenten klicken Sie auf [image] .

Der Leistungsanalyse-Assistent untersucht Ihre gesamte Datenbank und gibt Vorschläge zu deren Verbesserung. Der Assistent kann diese Vorschläge auch implementieren. Um weitere Informationen zum Leistungsanalyse-Assistenten anzuzeigen, klicken Sie auf [image] .

Weitere Anregungen zum Entwerfen einer Microsoft Access-Datenbank erhalten Sie, wenn Sie sich den Entwurf der Beispieldatenbank Nordwind oder einer der Datenbanken anschauen, die Sie mit dem Datenbank-Assistenten erstellen können. Um weitere Informationen zum Datenbank-Assistenten anzuzeigen, klicken Sie auf [image] .

Weitere Ideen zur Analyse Ihrer Microsoft SQL Server-Datenbank, die zu einer Leistungsverbesserung der Datenbank führen, finden Sie in der Dokumentation für Microsoft SQL Server.

Zurück zum Anfang


Erstellen einer Datenbank

Was möchten Sie tun?

Eine Datenbank unter Verwendung eines Datenbank-Assistenten erstellen

Eine Datenbank ohne Verwendung eines Datenbank-Assistenten erstellen

Informationen über das Erstellen einer Datenbank durch Öffnen einer Datendatei mit einem anderen Dateiformat erhalten

Einen Überblick über den Zweck und die Funktionsweise von Datenbanken erhalten

Informationen über das Entwerfen von Datenbanken erhalten

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Infos zum Erstellen einer Anwendung

Infos zum Erstellen einer Anwendung

Wenn Sie sich mit Microsoft Access vertraut gemacht haben und wissen, wie Tabellen, Abfragen, Formulare, Berichte, benutzerdefinierte Symbolleisten usw. erstellt werden, können Sie Makros und Visual Basic für Applikationen-Code hinzufügen, um diese Objekte zu einer Anwendung zusammenzuführen. In einer Anwendung werden verwandte Aufgaben zusammengefasst, so dass der Benutzer sich auf die eigentliche Aufgabe konzentrieren kann und keine Kenntnisse der Funktionsweise der Anwendung und des zum Entwickeln der Anwendung verwendeten Programms benötigt. Ausführliche Informationen zum Erstellen einer Anwendung finden Sie im Handbuch unter Erstellen von Anwendungsprogrammen mit Formularen und Berichten. Informationen zu bestimmten Themen finden Sie außerdem im Office-Assistenten.

Sie können festlegen, wie Ihre Anwendung beim Starten aussehen und sich verhalten soll. Dazu legen Sie Startoptionen im Dialogfeld Start (Menü Extras) fest. Sie können z.B. angeben, welches Formular beim Starten Ihrer Anwendung angezeigt wird, oder welcher Text in der Titelleiste erscheint, während Ihre Anwendung ausgeführt wird. Weitere Informationen erhalten Sie im Handbuch unter Erstellen von Anwendungsprogrammen oder durch Klicken auf [image] .

Wenn Sie beabsichtigen, Ihre Anwendung an andere Benutzer weiterzugeben, möchten Sie möglicherweise Zugriffsrechte implementieren, um die Objekte, die Sie erstellt haben, und die in den Tabellen enthaltenen Daten vor unerlaubtem Zugriff zu schützen. Weitere Informationen zu Zugriffsrechten erhalten Sie im Handbuch unter Erstellen von Anwendungsprogrammen oder durch Klicken auf [image] .

Nach dem Weitergeben einer Anwendung an andere Benutzer verwenden Sie die in Microsoft Access enthaltenen Tools zur Wartung, um die Datenbank in regelmäßigen Abständen zu komprimieren und zu reparieren. Stellen Sie Benutzern an entfernten Computern diese Tools ebenfalls zur Verfügung. Weitere Informationen finden Sie im Handbuch unter Erstellen von Anwendungsprogrammen. Um weitere Informationen zum Reparieren und Komprimieren einer Datenbank anzuzeigen, klicken Sie auf [image] .

Anmerkung Zusätzlich zu den in Microsoft Access enthaltenen Tools und Informationen zum Entwickeln von Anwendungen stellt Microsoft Office 2000 Developer Ihnen weitere Tools zum Entwickeln von Microsoft Windows- und Microsoft Office-kompatiblen Anwendungen zur Verfügung. Zum Anzeigen weiterer Informationen über die Tools von Microsoft Office 2000 Developer klicken Sie auf [image] .


 Anzeigen oder Ändern der allgemeinen Eigenschaften eines Datenbankobjekts

Anzeigen oder Ändern der allgemeinen Eigenschaften eines Datenbankobjekts

  1. Klicken Sie im Datenbankfenster unter Objekte auf den Datenbankobjekttyp, dessen Eigenschaften Sie ändern möchten.

  2. Klicken Sie auf das Datenbankobjekt, dessen Eigenschaften Sie ändern möchten.

  3. Klicken Sie auf der Symbolleiste auf Eigenschaften [image] .

Um Hilfeinformationen zu einem Element anzuzeigen, klicken Sie auf das Fragezeichen [image] und dann auf das Element.

Anmerkungen

  • Der Inhalt des Feldes Beschreibung im Dialogfeld Eigenschaften wird im Datenbankfenster in der Spalte Beschreibung angezeigt, wenn Sie in der Symbolleiste auf Details [image] klicken.

  • In Microsoft Access-Projekten können Sie die Eigenschaften von Tabellen, Ansichten, Datenbankdiagrammen oder gespeicherten Prozeduren nicht ändern, da diese Objekte in der Microsoft SQL Server-Datenbank gespeichert sind. Eigenschaften von Formularen, Berichten, Makros und Modulen können Sie dagegen ändern, weil sich diese Objekte im Access-Projekt selbst und nicht in der Microsoft SQL Server-Datenbank befinden. Außerdem können Sie die Eigenschaften von Datenzugriffsseiten ändern.


 Umbenennen, Löschen, Kopieren oder Verschieben einer Access-Datenbank oder eines Access-Projekts

Umbenennen, Löschen, Kopieren oder Verschieben einer Access-Datenbank oder eines Access-Projekts

Was möchten Sie tun?

Eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt umbenennen

Eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt löschen

Eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt kopieren oder verschieben

Wichtig

  • Wenn Sie eine Microsoft Access-Datenbank umbenennen, löschen, kopieren oder verschieben und eine andere Datenbank Verknüpfungen zu Objekten aus dieser Datenbank enthält, aktualisieren Sie die entsprechenden Verknüpfungsinformationen in der anderen Datenbank mit Hilfe des Tabellenverknüpfungs-Managers. Andernfalls erzeugt Access bei jedem Versuch, diese verknüpften Objekte in der anderen Datenbank zu verwenden, einen Fehler.

    .
  • Verknüpfungen zu Datenzugriffsseiten müssen nur aktualisiert werden, wenn Sie die .html-Dateien der Datenzugriffsseite umbenennen, löschen oder verschieben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Öffnen einer Microsoft Access-Datenbank

Öffnen einer Microsoft Access-Datenbank

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie in der Umgebungsleiste oder im Feld Suchen in auf eine Verknüpfung, und klicken Sie dann auf den Ordner, der die gewünschte Microsoft Access-Datenbank enthält.

  3. Doppelklicken Sie in der Ordnerliste so oft auf Ordner, bis Sie den Ordner geöffnet haben, der die Datenbank enthält.

    Wenn Sie die zu öffnende Datenbank nicht finden, klicken Sie im Menü Extras auf Suchen [image] . Geben Sie im Dialogfeld Suchen weitere Suchkriterien ein. Um Hilfe zu einer Option anzuzeigen, klicken Sie auf das Fragezeichen [image] und dann auf die Option. Weitere Informationen zum Suchen nach Dateien.

  4. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie die Datenbank für gemeinsame Nutzung in einer Mehrbenutzerumgebung öffnen, damit Sie und andere Benutzer Lese-/Schreibzugriff für die Datenbank erhalten, klicken Sie auf Öffnen.

    • Zum Öffnen der Datenbank mit Exklusivzugriff klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und dann auf Exklusiv öffnen.

    • Um die Datenbank schreibgeschützt zu öffnen, so dass Sie sie anzeigen, jedoch nicht bearbeiten können, klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und dann auf Schreibgeschützt öffnen.

    • Um die Datenbank schreibgeschützt zu öffnen und gleichzeitig zu verhindern, dass andere Benutzer diese Datenbank auch öffnen, klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und dann auf Exklusiv schreibgeschützt öffnen.

    Zum Anzeigen von Hilfe zu einer Option klicken Sie auf das Fragezeichen [image] und dann auf das gewünschte Element.

Anmerkungen

  • Um im Dialogfeld Öffnen eine Liste von Verknüpfungen zu den zuletzt geöffneten Datenbanken anzuzeigen, klicken Sie in der Umgebungsleiste auf Verlauf [image] .

  • Zum Öffnen einer der Datenbanken, die Sie zuletzt geöffnet hatten, klicken Sie unten im Menü Datei auf den Dateinamen. Microsoft Access öffnet die Datenbank mit den Einstellungen, die sie beim letzten Öffnen hatte. Wenn die Liste der zuletzt geöffneten Datenbanken nicht angezeigt wird, klicken Sie im Menü Extras auf Optionen. Anschließend klicken Sie auf die Registerkarte Allgemein und aktivieren dort das Kontrollkästchen Liste zuletzt geöffneter Dateien.

  • Microsoft Access kann automatisch eine Verknüpfung im Ordner FAVORITEN erstellen. Auf diese Weise können Sie die Datenbank beim nächsten Mal direkt öffnen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] . Zum Anzeigen von Informationen dazu, wie Sie eine Verknüpfung manuell erstellen, klicken Sie auf [image] .

  • Sie können eine Datei direkt in einem externen Dateiformat, wie z. B. dBASE, Paradox, Microsoft Exchange oder Microsoft Excel öffnen. Sie können außerdem direkt jede beliebige ODBC-Datenquelle, wie z. B. Microsoft SQL Server oder Microsoft FoxPro, öffnen. Microsoft Access erstellt automatisch in dem Ordner, in dem sich die Datendatei befindet, eine neue Access-Datenbank und fügt Hyperlinks zu jeder Tabelle in der externen Datenbank hinzu. Weitere Informationen zum Importieren und Verknüpfen von Daten.


 Automatisches Erstellen einer Verknüpfung zu einer Access-Datenbank oder zu einem Access-Projekt im Ordner FAVORITEN

Automatisches Erstellen einer Verknüpfung zu einer Access-Datenbank oder zu einem Access-Projekt im Ordner FAVORITEN

Im Ordner FAVORITEN können Sie Verknüpfungen zu Microsoft Access-Datenbanken, Microsoft Access-Projekten, Ordnern und anderen Dateien speichern, die Sie häufig verwenden. Dazu gehören auch Datenbanken und Dateien an Remote-Standorten. Sie brauchen somit nicht jedesmal nach diesen Dateien zu suchen. Der Standort von Originaldatei bzw. -ordner ändert sich dabei nicht.

  1. Klicken Sie in der Symbolleiste auf Öffnen [image] .

  2. Um eine Verknüpfung zu einem Ordner, Unterordner, einer Access-Datenbank oder einem Access-Projekt herzustellen, der bzw. die in der Liste Suchen in aufgelistet ist, markieren Sie die Datei bzw. den Ordner, klicken Sie in der Symbolleiste auf Extras und dann auf Zu Favoriten hinzufügen.

Tipp Zum schnellen Öffnen des Ordners FAVORITEN nach dem Starten von Microsoft Access klicken Sie im Dialogfeld Öffnen auf Favoriten [image] . Um eine Favoritendatei oder einen Favoritenordner zu öffnen, klicken Sie auf die Verknüpfung und dann auf Öffnen.


 Hinzufügen der aktuellen Access-Datenbank zum Ordner "Favoriten"

Hinzufügen der aktuellen Access-Datenbank zum Ordner "Favoriten"

Sie können die aktuelle Microsoft Access-Datenbank dem Ordner Favoriten hinzufügen, damit Sie diese öffnen können, ohne sich den Pfad merken zu müssen, den Sie beim ersten Anzeigen der Datei eingegeben haben.

  1. Wird die Symbolleiste Web nicht angezeigt, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste Web auf Favoriten und dann auf Zu Favoriten hinzufügen.

  3. Klicken Sie auf Hinzufügen.


Erstellen von Verknüpfungen mit Dateien, Ordnern und Webseiten

Was möchten Sie tun?

Erstellen eines Felds zum Speichern von Hyperlinks in einer Microsoft Access-Datenbank

Erstellen einer Spalte zum Speichern von Hyperlinks in einem Microsoft Access-Projekt

Erstellen eines Hyperlinks in einem Formular oder einer Datenzugriffsseite

Zuweisen eines Hyperlinks zu einer Symbolleistenschaltfläche oder einem Menübefehl

Hinzufügen eines Ordners oder einer Datei zum Ordner Favoriten

Hinzufügen der aktuellen Datei zum Ordner Favoriten

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Öffnen einer Access-Datenbank oder eines Access-Projekts im Netzwerk unter Verwendung einer UNC-Adresse

Öffnen einer Access-Datenbank oder eines Access-Projekts im Netzwerk unter Verwendung einer UNC-Adresse

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Geben Sie im Feld Dateiname die UNC- Adresse für die gewünschte Netzwerkfreigabe ein, und drücken Sie anschließend die EINGABETASTE.

    Geben Sie z. B. \\Server1\Dateien ein, um eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt in der Freigabe Dateien auf dem Server Server1 zu öffnen.

  3. Suchen Sie in der Ordnerliste die gewünschte Access-Datenbank oder das gewünschte Access-Projekt, und öffnen Sie diese(s).

Tipp Um eine Access-Datenbank oder ein Access-Projekt in einer Netzwerkfreigabe zu öffnen, die Sie zuvor unter Verwendung einer UNC-Adresse geöffnet haben, klicken Sie auf den Pfeil neben dem Feld Dateiname und klicken dann auf die UNC-Verbindung.


 Ändern des Erscheinungsbildes von Objekten im Datenbankfenster

Ändern des Erscheinungsbildes von Objekten im Datenbankfenster

  1. Klicken Sie im Datenbankfenster auf eine der folgenden Schaltflächen auf der Symbolleiste Datenbankfenster: Große Symbole [image] , Kleine Symbole [image] , Liste [image] oder Details [image] .

  2. Um die Objekte zu sortieren, zeigen Sie im Menü Ansicht auf Symbole anordnen, und klicken Sie dann auf einen der folgenden Unterbefehle: nach Name, nach Typ, nach Erstellung oder nach Bearbeitung.

Anmerkung In Microsoft Access-Projekten werden keine Beschreibungen von Tabellen, Ansichten, Datenbankdiagrammen oder gespeicherten Prozeduren angezeigt, da diese Objekte in der Microsoft SQL Server-Datenbank gespeichert sind. Beschreibungen von Formularen, Berichten, Makros und Modulen können Sie dagegen sehen, weil sich diese Objekte im Access-Projekt selbst und nicht in der Microsoft SQL Server-Datenbank befinden. Außerdem können Sie Beschreibungen von Datenzugriffsseiten sehen.


 Ändern der Standardausrichtung von Text in neuen Textfeldern oder anderen Steuerelementen in Formularen oder Berichten

Ändern der Standardausrichtung von Text in neuen Textfeldern oder anderen Steuerelementen in Formularen oder Berichten

Standardmäßig wählen Sie ein Datenbankobjekt im Datenbankfenster durch einfaches Klicken aus und öffnen es durch Doppelklicken. Diese Standardeinstellung können Sie jedoch auch dahingehend ändern, dass Sie ein Objekt durch einfaches Klicken öffnen können, und es auswählen, indem Sie den Zeiger darauf bewegen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf der Registerkarte Ansicht auf Einfaches Klicken zum Öffnen.

Tipp Sie können ein Datenbankobjekt im Datenbankfenster auch auswählen, indem Sie den Namen des Objekts eingeben.


 Aktualisieren des Datenbankfensters

Aktualisieren des Datenbankfensters

Das Aktualisieren des Datenbankfensters gewährleistet, dass die Liste der Objekte in der Objektliste aktuell ist.

  1. Wechseln Sie in einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt ggf. zum Datenbankfenster, wenn Sie das noch nicht getan haben. Sie können zum Wechseln zum Datenbankfenster von einem beliebigen anderen Fenster aus F11 drücken.

  2. Drücken Sie F5, um das Datenbankfenster zu aktualisieren.

Anmerkung Microsoft Access aktualisiert das Datenbankfenster automatisch, wenn Sie eine Access-Datenbank oder ein Access-Projekt öffnen, oder wenn Sie ein neues Datenbankobjekt in einer Microsoft SQL Server-Datenbank erstellen, mit der das Access-Projekt verknüpft ist.


 Ein- oder Ausblenden von Verknüpfungen zur Erstellung neuer Datenbankobjekte

Ein- oder Ausblenden von Verknüpfungen zur Erstellung neuer Datenbankobjekte

Wenn Sie im Datenbankfenster auf Objekte und anschließend auf einen Objekttypen klicken, finden Sie in der Objektliste Verknüpfungen, die zur Erstellung eines neuen Datenbankobjekts dieses Typs verwendet werden können . Wenn Sie zum Beispiel auf Berichte klicken [image], werden die Verknüpfungen Erstellt einen Bericht in der Entwurfsansicht und Erstellt einen Bericht unter Verwendung des Assistenten in der Objektliste angezeigt. Sie können diese neuen Objektverknüpfungen entweder ein- oder ausblenden.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Ansicht.

  3. Führen Sie einen der folgenden Schritte aus:

    Um die neuen Objektverknüpfungen im Datenbankfenster anzuzeigen, aktivieren Sie das Kontrollkästchen Neue Objektverknüpfungen.

    Um die neuen Objektverknüpfungen auszublenden, deaktivieren Sie das Kontrollkästchen Neue Objektverknüpfungen.


 Objekte im Datenbankfenster mit Hilfe von Gruppen organisieren

Objekte im Datenbankfenster mit Hilfe von Gruppen organisieren

Im Datenbankfenster können Sie verschiedene Typen von Datenbankobjekten zu Gruppen zusammenstellen.

Was möchten Sie tun?

Informationen über Gruppen erhalten

Eine Gruppe erstellen

Eine Gruppe löschen oder umbenennen

Ein Datenbankobjekt zu einer Gruppe hinzufügen

Ein Datenbankobjekt in einer Gruppe löschen oder umbenennen


Kopieren von Datenbankobjekten

Was möchten Sie tun?

Ein Datenbankobjekt mit dem Befehl Kopieren kopieren

Ein Datenbankobjekt mit dem Befehl Speichern unter kopieren

Eine Kopie eines Datenbankobjekts als einen anderen Objekttyp speichern

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Löschen eines Datenbankobjekts

Löschen eines Datenbankobjekts

  1. Schließen Sie das Datenbankobjekt, das Sie löschen möchten. Stellen Sie in einer Mehrbenutzerumgebung sicher, dass alle Benutzer das Datenbankobjekt geschlossen haben.

  2. Klicken Sie im Datenbankfenster unter Objekte auf den Typ des Datenbankobjekts, das Sie löschen möchten.

  3. Klicken Sie auf das Objekt in der Objektliste, und drücken Sie dann ENTF.

    Anmerkung Wenn Sie eine Datenzugriffsseite aus der aktuellen Datenbank löschen, werden Sie von Microsoft Access gefragt, ob Sie die Verknüpfung und die Seite löschen möchten, oder ob nur die Verknüpfung gelöscht werden soll. Wenn nur die Verknüpfung gelöscht wird, wird die Seite aus der aktuellen Datenbank entfernt, die HTML-Datei bleibt jedoch auf Ihrem Computer erhalten.


 Umbenennen eines Datenbankobjekts

Umbenennen eines Datenbankobjekts

  1. Schließen Sie das Datenbankobjekt, das Sie umbenennen möchten. Stellen Sie in einer Mehrbenutzerumgebung sicher, dass alle Benutzer das Datenbankobjekt geschlossen haben.

  2. Klicken Sie im Datenbankfenster unter Objekte auf den Objekttyp für das Objekt, das Sie umbenennen möchten.

  3. Klicken Sie mit der rechten Maustaste auf das Objekt, und klicken Sie dann auf Umbenennen.

  4. Geben Sie den neuen Namen unter Beachtung der Microsoft Access-Konventionen zur Objektbenennung ein, und drücken Sie dann die EINGABETASTE.

Anmerkung Wenn Sie eine Datenzugriffsseite umbenennen, wird der Hyperlink zur HTML-Datei, nicht jedoch die HTML-Datei umbenannt. Verwenden Sie zum Umbenennen der Datei selbst Arbeitsplatz oder Windows Explorer.

Weitere Informationen zum Speichern von Änderungen an einer freigegebenen Access-Datenbank.


 Speichern eines Datenbankobjekts

Speichern eines Datenbankobjekts

  1. Klicken Sie in der Symbolleiste auf Speichern [image] .

  2. Beim ersten Speichern eines Datenbankobjekts geben Sie im Dialogfeld Speichern unter einen Namen unter Beachtung der Microsoft Access- Benennungsregeln für Objekte ein und klicken anschließend auf OK. Wenn Sie im Dialogfeld Speichern unter auf Abbrechen klicken, wird das Objekt nicht gespeichert.

Anmerkungen

  • Sie müssen neue Daten nicht in Datensätzen speichern. In Access wird automatisch ein Datensatz gespeichert, wenn Sie eine der folgenden Aufgaben ausführen: Verschieben des Fokus auf einen anderen Datensatz; Schließen des aktiven Formulars; Datenblätter, Datenzugriffsseiten oder Datenbanken; Beenden von Access.

  • Wenn Sie versuchen, eine neue Abfrage zu speichern, und eine Fehlermeldung darüber erhalten, dass der eingegebene Name bereits für ein anderes Objekt vergeben wurde, geben Sie einen anderen Namen ein. Möglicherweise enthält die Datenbank Abfragen, die in Visual Basic für Applikationen(VBA)-Code mit ActiveX Data-Objekten (ADO) erstellt wurden. Mit ADO erstellte Abfragen werden in der Liste der Objekte im Datenbankfenster nicht angezeigt.

  • Weitere Informationen über Speichern von Änderungen an freigegebenen Access-Datenbanken.

  • Weitere Informationen über Auswirkungen von Datenbankdiagrammen auf die Speicherung von Änderungen an Tabellen in einem Microsoft Access-Projekt.


 Anzeigen, Drucken, Ausgeben oder Speichern der Entwurfsmerkmale für Datenbankobjekte

Anzeigen, Drucken, Ausgeben oder Speichern der Entwurfsmerkmale für Datenbankobjekte

  1. Zeigen Sie im Menü Extras auf Analyse, und klicken Sie dann auf Dokumentierer.

  2. Klicken Sie auf die Registerkarte, die dem Typ des Datenbankobjekts entspricht, das Sie anzeigen oder drucken möchten.

    Sie können auch auf die Registerkarte Alle Objekttypen klicken, um eine vollständige Liste der Objekte in der Datenbank anzuzeigen.

  3. Wählen Sie die Objekte, deren Definition Sie anzeigen oder drucken möchten.

  4. Klicken Sie auf Optionen, um anzugeben, welche Merkmale des ausgewählten Objekts Sie drucken möchten, und klicken Sie dann auf OK.

  5. Klicken Sie auf OK.

  6. Jetzt können Sie eine der folgenden Anweisungen ausführen:
    • Um die Definitionen zu drucken, klicken Sie in der Symbolleiste auf Drucken [image] .

      Sie werden vielleicht die Länge Ihrer Definitionen im Seitenansichtsfenster überprüfen wollen. Einige Definitionen, insbesondere die von Formularen und Berichten, können nämlich mehrere Seiten umfassen.

    • Um die Definitionen in eine HTML-Datei, eine Microsoft Excel-Tabelle, eine .RTF-Datei (Rich Text Format), eine MS-DOS-Textdatei oder eine Datei im Snapshot-Format auszugeben, klicken Sie im Menü Datei auf Exportieren und füllen anschließend das Dialogfeld Exportieren von Bericht 'Berichtsname' nach aus.


 Drucken eines Datenbankobjekts unter Verwendung einer Verknüpfung

Drucken eines Datenbankobjekts unter Verwendung einer Verknüpfung

Nachdem Sie eine Verknüpfung für eine Tabelle, eine Abfrage, ein Formular oder einen Bericht erstellt haben, können Sie das Objekt direkt unter Verwendung des Verknüpfungssymbols drucken.

  1. Klicken Sie mit der rechten Maustaste auf die Verknüpfung.

  2. Klicken Sie im Kontextmenü auf Drucken.

Tipp Sie können schnell unter Verwendung einer Verknüpfung drucken, indem Sie das zugehörige Symbol zu einem Druckersymbol auf dem Desktop oder in den Ordner DRUCKER ziehen.


 Drucken des Datenblatts einer Tabelle, einer Abfrage oder eines Formulars

Drucken des Datenblatts einer Tabelle, einer Abfrage oder eines Formulars

So drucken Sie das vollständige Datenblatt

  1. Zeigen Sie die Tabelle, die Abfrage oder das Formular in der Datenblattansicht an.

  2. Wenn Ihr Datenblatt ein Unterdatenblatt enthält, das Sie ebenfalls drucken möchten, klicken Sie auf das Erweiterungssymbol(+) links von der Zeile, dessen Unterdatenblatt Sie erweitern möchten.

    Achtung Wenn Sie alle Unterdatenblätter erweitern (dazu klicken Sie auf Format, zeigen auf Unterdatenblatt und klicken dann auf Alles erweitern) enthält das Ergebnis u. U. unerwartet viele Datensätze. Drucken Sie nach dem Erweitern aller Unterblätter nur dann, wenn Sie sicher sind, dass sie alle Ergebnisse der Datensätze drucken wollen.

  3. Um vor dem Drucken die Einstellungen im Dialogfeld Drucken zu ändern, klicken Sie im Menü Datei auf Drucken, und wählen Sie dann die gewünschten Optionen.

    Um das Datenblatt sofort zu drucken, ohne die Einstellungen im Dialogfeld Drucken zu ändern, klicken Sie in der Symbolleiste auf Drucken [image] .

So drucken Sie nur bestimmte Datensätze im Datenblatt

  1. Zeigen Sie die Tabelle, die Abfrage oder das Formular in der Datenblattansicht an.

  2. Markieren Sie die Datensätze, die Sie drucken möchten.

  3. Klicken Sie im Menü Datei auf Drucken und dann auf Markierte Datensätze.

Anmerkungen

  • Sie können Ihr Datenblatt vor dem Drucken in der Seitenansicht ansehen. Klicken Sie hierzu in der Symbolleiste auf Seitenansicht [image] .

  • Informationen zum schnellen Drucken des Datenblatts unter Verwendung einer Verknüpfung erhalten Sie durch Klicken auf [image] .


 Erstellen einer Verknüpfung zum Öffnen eines Datenbankobjekts vom Desktop oder aus einem Ordner

Erstellen einer Verknüpfung zum Öffnen eines Datenbankobjekts vom Desktop oder aus einem Ordner

Sie können eine Verknüpfung erstellen, um in einer Microsoft Access-Datenbank oder in einem Microsoft Access-Projekt ein Datenbankobjekt zu öffnen, das in einer lokalen Datenbank auf Ihrem Computer oder in einer Remote-Datenbank auf einem Netzwerk-Dateiserver oder in einem freigegebenen Verzeichnis gespeichert ist.

So erstellen Sie eine Verknüpfung durch Ziehen des Objekts

  • Sie können schnell eine Verknüpfung erstellen, indem Sie das Objekt vom Datenbankfenster zum Desktop oder einem Ordner ziehen. Achten Sie dabei darauf, dass die Zielposition für die Verknüpfung sichtbar ist. (Falls Sie das Access-Fenster zuvor maximiert hatten, ändern Sie die Größe so, dass der Desktop oder der für die Verknüpfung vorgesehene Ordner sichtbar ist.)

So erstellen Sie eine Verknüpfung mit dem Befehl Verknüpfung erstellen

  1. Klicken Sie im Datenbankfenster unter Objekte auf den Datenbankobjekttyp, für den Sie eine Verknüpfung erstellen möchten.

  2. Klicken Sie mit der rechten Maustaste auf das gewünschte Objekt und dann auf Verknüpfung erstellen.

  3. Ist die Verknüpfung für einen anderen Standort als den Desktop bestimmt, geben Sie im Feld Pfad einen neuen Pfad ein, oder klicken Sie auf Durchsuchen, um den Standort zu wählen. Access füllt den Pfad dann für Sie aus. Vielleicht möchten Sie die Verknüpfung im Ordner Favoriten speichern. Darin sind Verknüpfungen für Elemente gespeichert, die Sie häufig verwenden.

  4. Wenn Sie eine Verknüpfung für ein Objekt in einer Datenbank erstellen möchten, die sich in einem Netzwerk befindet, aktiviert Access Diese Datei befindet sich im Netzwerk und füllt den Netzwerkpfad im Feld Vollständiger Netzwerkpfad aus. Falls Sie die Datenbank später verschieben, können Sie einen neuen Netzwerkpfad in folgendem Format eingeben:

    \\Server\Share\Dateiname

    Durch Angabe des Netzwerkpfads können Sie die Verknüpfung z. B. über E-Mail senden und sie somit anderen Benutzenden, die Zugriff auf das Netzwerk haben, zugänglich machen.

  5. Klicken Sie auf OK.

Wenn Sie auf die Verknüpfung doppelklicken, öffnet Access die Datenbank, in der das Objekt gespeichert ist, und zeigt es an. Eine Verknüpfung zu einem Makro führt ein Makro aus, und eine Verknüpfung zu einer gespeicherten Prozedur in einem Access-Projekt führt die gespeicherte Prozedur aus. Um das Objekt in einer bestimmten Ansicht zu öffnen, klicken Sie mit der rechten Maustaste auf die Verknüpfung und dann auf die gewünschte Ansicht.

Anmerkungen

  • Wenn Sie über eine Verknüpfung für eine Datenbank verfügen und diese zu einem späteren Zeitpunkt an einen anderen Standort verschoben wird, löschen Sie die alte Verknüpfung, und erstellen Sie eine neue.

  • Um eine Verknüpfung zu löschen, klicken Sie darauf, und drücken Sie dann ENTF. Das über die Verknüpfung geöffnete Element wird dadurch nicht gelöscht.


 Automatisches Reparieren von Fehlern, die beim Umbenennen entstehen

Automatisches Reparieren von Fehlern, die beim Umbenennen entstehen

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Führen Sie auf der Registerkarte Allgemein einen der folgenden Schritte aus:
    • Wenn Microsoft Access über die zum Durchführen der Objektnamen-Autokorrektur erforderlichen Informationen verfügen jedoch keine Korrekturen vornehmen soll, aktivieren Sie das Kontrollkästchen Informationen aufzeichnen.

    • Wenn Access bei Umbenennungen in der Datenbank die automatische Korrektur von Namen vornehmen soll, aktivieren Sie das Kontrollkästchen Ausführen.

    • Wenn Access die Änderungen, die es beim Durchführen der automatischen Korrektur von Namen vornimmt, protokollieren soll, aktivieren Sie das Kontrollkästchen Änderungen protokollieren. Access speichert die Änderungen in einer Tabelle namens Name AutoCorrect Log. Jede Änderung entspricht einem Datensatz in dieser Tabelle.

Anmerkung Die automatische Korrektur von Namen kann alle Diskrepanzen beheben, die beim Umbenennen eines Formulars oder anderen Objekts entstehen. Es kann jedoch nicht Objekte in bestimmten Situationen reparieren. Weitere Informationen dazu, was die automatische Korrektur von Namen beheben kann und was nicht.


 Was von Objektnamen-Autokorrektur in einer Access-Datenbank behoben wird und was nicht

Was von Objektnamen-Autokorrektur in einer Access-Datenbank behoben wird und was nicht

Dieses Thema bietet Referenzinformationen über:

Übersicht

Was von Objektnamen-Autokorrektur repariert wird

Was von Objektnamen-Autokorrektur nicht repariert wird

Übersicht

Wenn Sie in Microsoft Access 97 und früheren Versionen ein Feld in einer Tabelle umbenennen, stellen Sie fest, dass die auf diesem Feld basierenden Objekte die Daten aus diesem Feld nicht mehr anzeigen. In Microsoft Access 2000 werden Nebenwirkungen automatisch korrigiert, die beim Umbenennen von Formularen, Berichten, Tabellen, Abfragen, Feldern, Textfeldern oder anderen Steuerelementen in einer Microsoft Access-Datenbank häufig auftreten. Dieses Feature heißt Objektnamen-Autokorrektur.

Jedes Mal, wenn Sie ein Formular oder ein anderes Objekt öffnen, sucht Access automatisch nach Diskrepanzen zwischen dem Formular und den anderen Objekten, von denen das Formular abhängt, und behebt sie. Wenn Sie beispielsweise ein Formular öffnen, das an eine Tabelle gebunden ist, vergleicht Access die Date- und Timestamps für die Tabelle und das Formular. Wenn sie unterschiedlich sind, führt Access eine Objektnamen-Autokorrektur durch.

Um die Vorteile des Objektnamen-Autokorrektur-Features nutzen zu können, müssen Sie Änderungen an dem Formular, Bericht oder anderen Objekt, das Objektnamen-Autokorrektur repariert, speichern können. Sie können Änderungen an einem Objekt speichern, wenn Sie über die Berechtigung zum Ändern des Entwurfs des Objekts verfügen, Schreibzugriff auf die Datenbank haben sowie über einen exklusiven Zugriff zum Durchführen von Änderungen verfügen. Wenn Sie das Objekt nicht speichern können, werden die Reparaturen nicht gespeichert, wenn Sie das Objekt schließen. Objektnamen-Autokorrektur führt die Änderungen bei jedem Öffnen des Objekts durch, kann die Änderungen jedoch erst speichern, wenn eine Person mit der Berechtigung zum Ändern des Entwurfs das Objekt öffnet und speichert.

Objektnamen-Autokorrektur ist bei Datenbanken, die mit Access 2000 erstellt wurden, standardmäßig eingeschaltet. Für Datenbanken jedoch, die aus früheren Versionen in Access 2000 konvertiert wurden, müssen Sie Objektnamen-Autokorrektur einschalten. Automatisches Reparieren von Umbenennungsfehlern in einer Datenbank.

Zurück zum Anfang

Was von Objektnamen-Autokorrektur repariert wird

Objektnamen-Autokorrektur repariert alle Diskrepanzen, die auftreten, wenn Sie Formulare, Berichte, Tabellen, Abfragen oder Steuerelemente in Tabellen und Berichten umbenennen. Wenn Sie Formulare oder andere Objekte erstellen, während Objektnamen-Autokorrektur ausgeschaltet ist, und Objektnamen-Autokorrektur einschalten, repariert Access alle neuen Diskrepanzen, während Sie mit den Objekten weiterarbeiten. Wenn eins der Objekte bereits einen Umbenennungsfehler aufweist, wenn Sie Objektnamen-Autokorrektur einschalten, müssen Sie Verweise auf das Objekt von Hand reparieren. Bei Formularen oder Berichten, die Visual Basic-Code enthalten, repariert Access Verweise auf das Formular, aber keine Verweise auf Objekte in dem Visual Basic-Projekt.

Zurück zum Anfang

Was von Objektnamen-Autokorrektur nicht repariert wird

Objektnamen-Autokorrektur kann Verweise auf umbenannte Objekte in bestimmten Situationen nicht reparieren; beispielsweise kann Objektnamen-Autokorrektur Folgendes nicht:

  • Ändern von Verweisen in einer ungültigen SQL-Anweisung.

  • Reparieren von Verweisen in Ihrem Visual Basic-Code.

  • Reparieren von Verweisen in einer verknüpften Tabelle, wenn die Tabelle oder die Felder am Back-End einer Front-End/Back-End-Datenbank umbenannt wurden.

  • Arbeiten in einer replizierten Datenbank. Wenn Sie Ihre Datenbank replizieren, schaltet Access Objektnamen-Autokorrektur aus. Sie können Objektnamen-Autokorrektur nicht in einem Designmaster oder einem Replikat einer Datenbank einschalten.

  • Reparieren von Verweisen auf Makros in einer Symbolleiste oder einem Menü, einschließlich Menü- und Symbolleisteneigenschaften und Ereigniseigenschaften, die auf Makronamen eingestellt sind.

  • Arbeiten in einem Microsoft Access-Projekt.

Zurück zum Anfang


 Erstellen einer Sicherungskopie einer Datenbank

Erstellen einer Sicherungskopie einer Datenbank

  1. Schließen Sie die Datenbank. Wenn Sie sich in einer Mehrbenutzerumgebung befinden, stellen Sie sicher, dass alle Benutzer die Datenbank geschlossen haben.

  2. Kopieren Sie die Datenbankdatei (Datei mit der Erweiterung .MDB) mittels Windows Explorer, Arbeitsplatz, Microsoft Backup, des MS-DOS-Befehls copy oder einer anderen Sicherungs-Software auf einen Datenträger Ihrer Wahl.

Anmerkungen

  • Wenn Sie die Daten auf einer Diskette sichern und die Größe der Datenbankdatei die Kapazität der Diskette überschreitet, können Sie die Datenbank nicht mittels Windows Explorer oder Arbeitsplatz sichern. In diesem Fall müssen Sie Microsoft Backup oder eine Sicherungs-Software verwenden, um die Datei auf mehrere Disketten zu kopieren.

  • Sie sollten auch von der Arbeitsgruppen-Informationsdatei eine Sicherungskopie erstellen. Ist diese Datei nicht vorhanden oder beschädigt, kann Microsoft Access erst wieder gestartet werden, wenn sie repariert bzw. wiederhergestellt ist.

  • Sie können eine Sicherungskopie von einzelnen Datenbankobjekten erstellen, indem Sie eine leere Datenbank erstellen und dann die gewünschten Objekte aus der Originaldatenbank importieren.

  • Sie können die Anweisung Datei kopieren nicht in einer zweiten Instanz von Microsoft Access verwenden, um eine Sicherungskopie einer Datenbank zu erstellen, deren erste Instanz in Microsoft Access geöffnet ist.


Wiederherstellen einer Datenbank von einer Sicherungskopie

  • Kopieren Sie die Sicherungskopie Ihrer Datenbank mittels Windows Explorer, Arbeitsplatz, Microsoft Backup, der MS-DOS-Befehle copy bzw. restore oder einer anderen Sicherungs-Software in den Datenbankordner. Verwenden Sie das Verfahren, das Sie auch zum Erstellen der Sicherungskopie verwendet haben.

Vorsicht Wenn der Name der im Datenbankordner vorhandenen Datenbank mit dem Namen der Sicherungskopie identisch ist, wird die vorhandene Datenbankdatei beim Wiederherstellen der Sicherungskopie überschrieben. Soll die vorhandene Datei erhalten bleiben, benennen Sie sie um, bevor Sie die Sicherungsdatei kopieren.

Weitere Informationen über das Umbenennen einer Datenbankdatei erhalten Sie durch Klicken auf [image] .


 Komprimieren von Access-Datenbanken oder Access-Projekten

Komprimieren von Access-Datenbanken oder Access-Projekten

Um die optimale Leistung zu gewährleisten, sollten Sie Ihre Microsoft Access-Datenbanken und Microsoft Access-Projekte regelmäßig komprimieren. Komprimierung und Reparatur wurden verbessert und zu einem einzigen Vorgang zusammengefasst, der sicherer und effizienter arbeitet. Weitere Informationen über das Komprimieren von Access-Datenbanken oder Access-Projekten.

Was möchten Sie tun?

Die aktuelle Access-Datenbank oder das aktuelle Access-Projekt komprimieren

Nichtgeöffnete Access-Datenbanken oder -Projekte komprimieren

Eine Access-Datenbank oder ein Access-Projekt beim Schließen automatisch komprimieren


 Optimieren der Leistung

Optimieren der Leistung

Abhängig von der Konfiguration Ihres Computers und Ihrer Arbeitsumgebung können Sie verschiedene Einstellungen vornehmen, um die Leistung von Microsoft Access, Ihrer Microsoft Access-Datenbank bzw. Ihres Microsoft Access-Projekts zu verbessern.

Um die Leistung einer Access-Datenbank zu optimieren, beginnen Sie am besten mit dem Leistungsanalyse-Assistenten. Sie können mit Hilfe des Leistungsanalyse-Assistenten eine vollständige Datenbank oder bestimmte Objekte einer Datenbank analysieren. Der Leistungsanalyse-Assistent kann außerdem einige Änderungen automatisch vornehmen, wenn Sie dies wünschen.

Was möchten Sie tun?

Den Leistungsanalyse-Assistenten ausführen

Die Leistung von Microsoft Access und Ihr System verbessern

Die Leistung von Tabellen verbessern

Die Leistung von verknüpften Tabellen verbessern

Die Leistung von externen SQL-Datenbanken verbessern

Die Leistung in einer Mehrbenutzerumgebung verbessern

Die Leistung von Abfragen verbessern

Die Leistung von Filtern verbessern

Die Leistung der Features Suchen und Ersetzen verbessern

Die Leistung von Formularen und Unterformularen verbessern

Die Leistung von Listenfeldern und Kombinationsfeldern verbessern

Die Leistung von Berichten und Unterberichten verbessern

Die Leistung von Datenzugriffsseiten verbessern

Über das Umwandeln Ihrer Datenbank in eine MDE-Datei zur Leistungsverbesserung informieren

Die Leistung von Visual Basic für Applikationen verbessern

Die Leistung von Microsoft Access-Projekten optimieren

Eine Access-Datenbank oder ein Access-Projekt beim Schließen automatisch komprimieren


 Aufteilen einer Tabelle in Detailtabellen unter Verwendung des Tabellenanalyse-Assistenten

Aufteilen einer Tabelle in Detailtabellen unter Verwendung des Tabellenanalyse-Assistenten

Wenn Ihre Microsoft Access-Datenbank über eine Tabelle verfügt, die viele Informationen in einem oder mehreren Feldern doppelt enthält, können Sie den Tabellenanalyse-Assistenten verwenden, um die Daten in Detailtabellen aufzuteilen und sie damit effizienter zu speichern. Dieser Vorgang wird als Normalisierung bezeichnet.

  1. Zeigen Sie im Menü Extras auf Analyse, und klicken Sie dann auf Tabelle.

  2. Befolgen Sie die Anweisungen in den Dialogfeldern des Tabellenanalyse-Assistenten.

Sie können entweder die zu erstellenden Tabellen selbst angeben oder den Assistenten die Normalisierung Ihrer Tabellen automatisch durchführen lassen. Nachdem Sie die vorgeschlagenen neuen Tabellen definiert haben, hilft Ihnen der Assistent bei der Abstimmung der Daten, die in der Ursprungstabelle nicht übereinstimmend wiederholt wurden. Im letzten Dialogfeld können Sie eine Abfrage erstellen, um alle Informationen aus den geteilten Tabellen in einem einzigen Datenblatt, ähnlich Ihrer Ursprungstabelle, anzuzeigen.

Anmerkung In einem Microsoft Access-Projekt befinden sich die Tabellen in einer Microsoft SQL Server-Datenbank. Daher steht der Tabellenanalyse-Assistent hier nicht zur Verfügung.


Tabellen: Definition und Funktionsweise

Klicken Sie auf die Grafik, damit das Thema angezeigt wird:

Klicken Sie auf die Grafik, damit das Thema angezeigt wird.

Um das Thema mit Hilfe der Tastatur anzuzeigen, drücken Sie zunächst F6, um das Themenfenster zu aktivieren, anschließend TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


Möglichkeiten zum Anpassen einer Tabelle

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie nacheinander F6, um den Themenbereich zu aktivieren, TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


 Erstellen einer Tabelle

Erstellen einer Tabelle

Microsoft Access bietet zwei Möglichkeiten zum Erstellen einer Tabelle. Sie können entweder eine leere Tabelle erstellen, um Ihre eigenen Daten einzugeben, oder Sie können eine Tabelle unter Verwendung vorhandener Daten aus einer anderen Quelle erstellen.

Was möchten Sie tun?

Alle Tabellen, Formulare und Berichte in einer Operation erstellen

Felder für eine neue Tabelle aus einer bereits bestehenden wählen

Tabellen aus Daten automatisch erstellen

Eine Tabelle von Grund auf neu erstellen

Eine neue Tabelle auf der Basis vorhandener Daten erstellen

Weitere Informationen zur Definition und Funktionsweise von Tabellen anzeigen


 Öffnen einer Tabelle

Öffnen einer Tabelle

  1. Klicken Sie im Datenbankfenster [image] unter Objekte auf Tabellen.

  2. Klicken Sie auf den Namen der Tabelle, die Sie öffnen möchten.

  3. Um die Tabelle in der Entwurfsansicht zu öffnen, klicken Sie in der Symbolleiste des Datenbankfensters auf Entwurf.

    Um die Tabelle in der Datenblattansicht zu öffnen, klicken Sie in der Symbolleiste des Datenbankfensters auf Öffnen.

Anmerkungen

  • Nachdem Sie eine Tabelle geöffnet haben, können Sie auf einfache Weise zwischen den beiden Ansichten wechseln, indem Sie in der Symbolleiste auf die Schaltfläche Ansicht klicken.

  • Informationen zum Erstellen einer Verknüpfung, die eine Tabelle direkt vom Desktop oder einem Ordner aus öffnet, erhalten Sie durch Klicken auf [image] .


 Wechseln zwischen den Ansichten einer Tabelle

Wechseln zwischen den Ansichten einer Tabelle

Tabellen verfügen über zwei Ansichten: die Entwurfsansicht und die Datenblattansicht. In der Entwurfsansicht können Sie die Struktur einer Tabelle erstellen und ändern. In der Datenblattansicht können Sie Daten einer Tabelle anzeigen, hinzufügen, löschen und bearbeiten.

  • Klicken Sie in der Symbolleiste auf die Schaltfläche Ansicht.

Die Schaltfläche Ansicht ist eine Umschaltfläche. Wird die Tabelle in der Datenblattansicht angezeigt, wird nur die Schaltfläche zum Wechseln zur Entwurfsansicht angezeigt und umgekehrt.


 Optimieren der allgemeinen Leistung von Tabellen

Optimieren der allgemeinen Leistung von Tabellen

Es gibt verschiedene Möglichkeiten zum Optimieren Ihrer Tabellen. Zusätzlich zu den folgenden Tipps steht Ihnen der Leistungsanalyse-Assistent zur Verfügung, um bestimmte Tabellen in Ihrer Datenbank zu analysieren. Um weitere Informationen zum Verwenden des Leistungsanalyse-Assistenten anzuzeigen, klicken Sie auf [image] .

Entwerfen Sie Tabellen ohne redundante Daten Ein durchdachter Datenbankentwurf ist Voraussetzung für schnelle Datenabrufe und -aktualisierungen. Wenn bestehende Tabellen redundante Daten enthalten, können Sie den Tabellenanalyse-Assistenten verwenden, um Ihre Tabellen in verknüpfte Tabellen zu teilen und damit Ihre Daten effizienter zu speichern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Wählen Sie geeignete Datentypen für die Felder Sie können Speicherplatz in Ihrer Datenbank sparen und Verknüpfungsoperationen verbessern, indem Sie die passenden Datentypen für die Felder wählen. Wählen Sie beim Definieren eines Feldes den möglichst kleinen Datentyp oder die möglichst kleine Feldgröße, die Sie für die Daten in dem Feld benötigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Erstellen Sie Indizes für Felder, die sortiert, verknüpft oder für die Kriterien eingestellt werden Sie erzielen wesentliche Verbesserungen der Geschwindigkeit von Abfragen, indem Sie die Felder auf beiden Seiten der Verknüpfungen indizieren, oder indem Sie eine Beziehung zwischen den Feldern definieren und alle Felder indizieren, die zum Einstellen von Kriterien für die Abfrage verwendet werden. Das Suchen von Datensätzen mit Hilfe des Dialogfelds Suchen funktioniert ebenfalls wesentlich schneller, wenn Sie in einem indizierten Feld suchen.

Indizes sind jedoch nicht in allen Fällen sinnvoll. Sie vergrößern die .MDB-Datei, beeinträchtigen in Mehrbenutzeranwendungen das Zusammenwirken (d. h. die Fähigkeit, mehreren Benutzern gleichzeitig das Modifizieren einer Seite zu erlauben) und verschlechtern die Leistung beim Aktualisieren von Daten in indizierten Feldern und beim Hinzufügen oder Löschen von Datensätzen. Es ist sinnvoll zu experimentieren, um herauszufinden, welche Felder indiziert sein sollten. Das Hinzufügen eines Indexes beschleunigt möglicherweise eine Abfrage um eine Sekunde, verlangsamt jedoch das Hinzufügen einer Datenzeile um zwei Sekunden und verursacht Sperrungsprobleme. Es kann auch zu unwesentlichen Verbesserungen führen, je nachdem, welche anderen Felder indiziert sind. Wenn Sie z. B. einen Index zu einem Feld PLZ hinzufügen, erreichen Sie nur eine sehr geringe Leistungsverbesserung, wenn die Felder Firmenname und Nachname in der Tabelle bereits indiziert sind. Unabhängig von der Art der Abfragen, die Sie erstellen, sollten Sie nur die Felder indizieren, die im wesentlichen eindeutige Werte enthalten.

Verwenden Sie in einem Mehr-Felder-Index nur so viele Felder im Index, wie benötigt werden Zum Anzeigen weiterer Informationen zu Indizes klicken Sie auf [image] .


 Definieren von Gültigkeitsregeln, die festlegen, wann ein Datensatz gespeichert werden kann

Definieren von Gültigkeitsregeln, die festlegen, wann ein Datensatz gespeichert werden kann

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Tabelle anzuzeigen.

  3. Geben Sie im Einstellungsfeld für die Eigenschaft Gültigkeitsregel die Gültigkeitsregel ein, oder klicken Sie auf die Generator-Schaltfläche [image] , wenn Sie die Gültigkeitsregel mit Hilfe des Ausdrucks-Generators erstellen möchten.

    Sie können z.B. den Gültigkeitsausdruck [Lieferdatum]<=[Bestelldatum]+30 definieren, wenn Sie sicherstellen möchten, dass das Datum, das in das Feld Lieferdatum eingegeben wird, nicht mehr als 30 Tage nach dem Datum im Feld Bestelldatum liegt.

  4. Geben Sie im Einstellungsfeld für die Eigenschaft Gültigkeitsmeldung die Meldung ein, die Microsoft Access anzeigen soll, wenn die Regel nicht eingehalten wird.

    Für den Gültigkeitsausdruck [Lieferdatum]<=[Bestelldatum]+30 können Sie z.B. die Meldung Das Lieferdatum darf nicht mehr als 30 Tage nach dem Bestelldatum liegen eingeben.

    Wenn Sie eine Gültigkeitsregel für eine Tabelle definieren, die bereits Daten enthält, fragt Microsoft Access, ob die neue Regel beim Speichern der Tabelle auch zum Überprüfen bereits vorhandener Daten verwendet werden soll.

Anmerkungen

  • Sie können für eine Tabelle immer nur eine Gültigkeitsregel definieren. Wenn Sie mehrere Regeln definieren möchten, müssen Sie Ausdrücke für die Eigenschaft Gültigkeitsregel mit Hilfe des Operators Und kombinieren.

  • Gültigkeitsregeln für einen Datensatz werden immer überprüft, wenn Sie Daten hinzufügen oder bearbeiten. Dies gilt unabhängig davon, ob das Hinzufügen oder Bearbeiten in der Datenblattansicht der Tabelle, in einem Formular, das an das Feld gebunden ist, in einer Anfügeabfrage, in einer Aktualisierungsabfrage, in Form von Visual Basic für Applikationen-Code oder durch das Importieren von Daten aus einer anderen Tabelle erfolgt.

  • Sie können zum Prüfen, ob die Daten in einer Tabelle Gültigkeitsregeln entsprechen, auch in der Titelleiste der Entwurfsansicht der Tabelle mit der rechten Maustaste und dann auf Testet Gültigkeitsregeln klicken.


Die Abfrage des Tabellenanalyse-Assistenten

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema mit Hilfe der Tastatur anzuzeigen, drücken Sie F6, um den Themenbereich zu aktivieren, dann TAB, um die Grafik auszuwählen, und schließlich EINGABE.


 Hinzufügen eines Feldes zu einer Tabelle in der Entwurfsansicht

Hinzufügen eines Feldes zu einer Tabelle in der Entwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der das Feld hinzugefügt werden soll, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Ende der Tabelle hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Klicken Sie auf die Spalte Feldname, und geben Sie den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Übernehmen Sie in der Spalte Felddatentyp die Standardeinstellung (Text), oder klicken Sie auf die Spalte Felddatentyp, dann auf den Pfeil, und wählen Sie den gewünschten Datentyp aus.

    Um Informationen zum Auswählen eines geeigneten Datentyps anzuzeigen, klicken Sie auf [image] .

  5. Geben Sie in der Spalte Beschreibung eine Beschreibung der Informationen ein, die das Feld enthalten soll. Diese Beschreibung wird in die Objektdefinition der Tabelle aufgenommen und in der Statusleiste angezeigt, wenn dem Feld Daten hinzugefügt werden. Die Eingabe einer Beschreibung ist optional.

  6. Stellen Sie bei Bedarf im unteren Teil des Fensters Eigenschaften für das Feld ein.

    Wie wird's gemacht?

Anmerkung Wenn es sich um eine verknüpfte Tabelle handelt, können Sie in der aktuellen Datenbank kein neues Feld hinzufügen. Ist die verknüpfte Tabelle eine Microsoft Access-Tabelle, öffnen Sie deren Quelldatenbank, um ein Feld hinzuzufügen. Stammt die verknüpfte Tabelle aber aus einer anderen Anwendung, öffnen Sie die Quelldatei mit dieser Anwendung, um ein Feld hinzuzufügen.


 Welcher Datentyp soll für ein Feld in der Tabelle verwendet werden?

Welcher Datentyp soll für ein Feld in der Tabelle verwendet werden?

Bestimmen Sie auf der Basis der folgenden Überlegungen den geeigneten Datentyp für ein Feld:

  • Welche Wertarten sollen im Feld zulässig sein? Sie können beispielsweise in einem Feld des Datentyps Zahl keinen Text speichern.

  • Wie viel Speicherplatz möchten Sie für die Werte im Feld verwenden?

  • Welche Operationen möchten Sie mit den Werten im Feld durchführen? Microsoft Access kann beispielsweise die Werte in Feldern des Datentyps Zahl oder Währung summieren, jedoch nicht die Werte in Feldern des Datentyps Text oder OLE-Objekt.

  • Möchten Sie ein Feld sortieren oder indizieren? Felder des Datentyps OLE-Objekt können nicht sortiert oder indiziert werden.

  • Möchten Sie ein Feld zum Gruppieren von Datensätzen in Abfragen oder Berichten verwenden? Felder des Datentyps OLE-Objekt können nicht zum Gruppieren verwendet werden.

  • Wie sollen die Werte in einem Feld sortiert werden? In einem Feld des Datentyps Text werden Zahlen als Zeichenfolgen (1, 10, 100, 2, 20, 200 usw.) und nicht als numerische Werte sortiert. Verwenden Sie deshalb ein Feld des Datentyps Zahl oder Währung, um Zahlen als numerische Werte zu sortieren. Außerdem werden viele Datumsformate nicht richtig sortiert, wenn sie in ein Feld des Datentyps Text eingegeben werden. Verwenden Sie ein Feld des Datentyps Datum/Uhrzeit, um die Werte richtig zu sortieren.

  • Anzeigen einer Übersicht über Felddatentypen, die in Microsoft Access verfügbar sind.


 Kopieren einer Felddefinition in der Tabellenentwurfsansicht

Kopieren einer Felddefinition in der Tabellenentwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Markieren Sie das Feld bzw. die Felder, das/die Sie kopieren möchten.

    Um ein einziges Feld zu markieren, klicken Sie auf den Zeilenmarkierer des entsprechenden Feldes.

    Um eine Gruppe von Feldern zu markieren, ziehen Sie die Maus über die Zeilenmarkierer der entsprechenden Felder.

  3. Klicken Sie in der Symbolleiste auf Kopieren [image] und dann auf die erste leere Zeile.

  4. Klicken Sie in der Symbolleiste auf Einfügen [image] .

  5. Geben Sie einen neuen Namen für das kopierte Feld ein.

Anmerkung Bei diesem Verfahren wird nur die Definition eines Feldes kopiert. Es werden keine Werte in das Feld kopiert.


 Erstellen eines Feldes für Text oder Memos

Erstellen eines Feldes für Text oder Memos

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Text oder Memo aus. Um Informationen zu dem für bestimmte Bedingungen geeigneten Datentyp anzuzeigen, klicken Sie auf [image] .

  5. Stellen Sie die anderen Feldeigenschaften nach Bedarf ein.

    Wie wird's gemacht?

Anmerkung Die Standardfeldgröße für Felder des Datentyps Text beträgt 50 Zeichen. Sie können diese Größe für ein bestimmtes Feld ändern, indem Sie dessen Eigenschaft Feldgröße einstellen. Die Standardfeldgröße selbst können Sie ändern, indem Sie im Menü Extras auf Optionen und dann auf die Registerkarte Tabellen/Abfragen klicken.


 Erstellen eines Feldes für Zahlen oder Währungswerte

Erstellen eines Feldes für Zahlen oder Währungswerte

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Zahl oder Währung aus. Um Informationen zum geeigneten Datentyp anzuzeigen, klicken Sie auf [image] .

  5. Wenn Sie ein Feld vom Datentyp Zahl erstellen, stellen Sie im unteren Teil des Fensters die Eigenschaft Feldgröße auf die gewünschte Größe ein. Zum Anzeigen von Informationen zu Feldgrößen klicken Sie auf [image] .

  6. Um ein Anzeigeformat für ein Feld festzulegen, klicken Sie im unteren Teil des Fensters auf das Feld Format, dann auf den Pfeil, und wählen Sie das gewünschte Format aus. Wenn die vordefinierten Formate Ihren Anforderungen nicht entsprechen, können Sie auch ein benutzerdefiniertes Anzeigeformat erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  7. Stellen Sie die anderen Feldeigenschaften nach Bedarf ein.

    Wie wird's gemacht?

Anmerkung Änderungen an den Währungsformaten der Ländereinstellungen in der Windows-Systemsteuerung wirken sich automatisch auf die Felder des Datentyps Währung in Ihrer Datenbank aus. Hiervon ist jedoch nur das Format betroffen. Die Währungswerte selbst werden nicht konvertiert.


 Erstellen eines Feldes für Ja/Nein-, Wahr/Falsch- und Ein/Aus-Werte

Erstellen eines Feldes für Ja/Nein-, Wahr/Falsch- und Ein/Aus-Werte

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Ja/Nein aus.

  5. Um im Feld Wahr/Falsch oder Ein/Aus statt der Standardeinstellung Ja/Nein anzuzeigen, klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein auf das Feld Format, und wählen Sie das gewünschte Format aus.

  6. Stellen Sie die anderen Feldeigenschaften nach Bedarf ein.

    Wie wird's gemacht?


 Erstellen eines Feldes für Datums- oder Zeitangaben

Erstellen eines Feldes für Datums- oder Zeitangaben

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Klicken Sie auf die Spalte Feldname, und geben Sie den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Datum/Uhrzeit aus.

  5. Um ein Anzeigeformat für ein Feld festzulegen, klicken Sie im unteren Teil des Fensters auf das Feld Format, dann auf den Pfeil, und wählen Sie das gewünschte Format aus. Wenn die vordefinierten Formate Ihren Anforderungen nicht entsprechen, können Sie auch ein benutzerdefiniertes Anzeigeformat erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  6. Stellen Sie die anderen Feldeigenschaften nach Bedarf ein.

    Wie wird's gemacht?

Anmerkung Das Speichern von Datums- und Zeitangaben in einem Feld des Datentyps Datum/Uhrzeit gewährleistet, dass Datums- und Zeitwerte richtig sortiert werden. Änderungen der Datums- oder Zeitformate in den Ländereinstellungen der Windows-Systemsteuerung wirken sich automatisch auf die Felder des Datentyps Datum/Uhrzeit in Ihrer Datenbank aus.


 Erstellen eines Feldes, das automatisch Zahlen erzeugt

Erstellen eines Feldes, das automatisch Zahlen erzeugt

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie AutoWert aus.

  5. Um eine fortlaufende Zahl zu erstellen, übernehmen Sie die Eigenschafteneinstellungen im unteren Teil des Fensters. (Die Eigenschaft Feldgröße ist standardmäßig auf Long Integer und die Eigenschaft NeueWerte auf Inkrement eingestellt.)

    Um eine Zufallszahl zu erstellen, stellen Sie im unteren Teil des Fensters auf der Registerkarte Allgemein die Eigenschaft Neue Werte auf Zufall ein. Zum Anzeigen von Informationen zu den Arten von Feldern des Datentyps AutoWert, die Sie erstellen können, einschließlich Felder zur Datenbankreplikation, klicken Sie auf [image] .

  6. Stellen Sie die anderen Feldeigenschaften nach Bedarf ein.

    Wie wird's gemacht?


Erstellen eines Feldes, das Werte in Tabellen nachschlägt oder auflistet

Mit Hilfe des Nachschlage-Assistenten können Sie ein Feld erstellen, das eine von zwei Listenarten anzeigt, um die Dateneingabe zu vereinfachen:

  • Eine Nachschlageliste, in der die Werte angezeigt werden, die in einer vorhandenen Tabelle oder Abfrage nachgeschlagen werden.

  • Eine Wertliste, in der eine festgelegte Gruppe von Werten angezeigt wird, die Sie beim Erstellen des Feldes eingeben.

Was möchten Sie tun?

Ein Nachschlagelistenfeld in der Entwurfsansicht erstellen

Ein Nachschlagelistenfeld in der Datenblattansicht erstellen

Ein Wertlistenfeld in der Entwurfsansicht erstellen

Ein Wertlistenfeld in der Datenblattansicht erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Definieren oder Ändern von Datentypen

Was möchten Sie tun?

Bestimmen, welcher Datentyp verwendet werden sollte

Den Datentyp eines Feldes ändern

Ein Feld für Datums- oder Zeitangaben erstellen

Ein Feld zum Speichern von OLE-Objekten (Bilder, Word-Dokumente usw.) erstellen

Ein Feld für Ja/Nein-, Wahr/Falsch- oder An/Aus-Daten erstellen

Ein Feld erstellen, das automatisch Zahlen erzeugt

Ein Feld für Zahlen oder Währungswerte erstellen

Ein Feld für Text oder Memos erstellen

Ein Feld zum Speichern von Hyperlinks erstellen

Ein Feld zum Nachschlagen oder Auflisten von Werten in Tabellen erstellen

Informationen zu den Konsequenzen beim Ändern eines Datentyps anzeigen

Informationen zu AutoWert-Feldern und Replikation anzeigen


 Erstellen eines Feldes zum Speichern von OLE-Objekten (Bildern, Word-Dokumenten usw.)

Erstellen eines Feldes zum Speichern von OLE-Objekten (Bildern, Word-Dokumenten usw.)

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie OLE-Objekt aus.

Anmerkung Felder des Datentyps OLE-Objekt werden verwendet, um Daten, wie z. B. Microsoft Word- oder Microsoft Excel-Dokumente, Bilder, Klänge und andere in anderen Programmen erstellte binäre Daten zu speichern. OLE-Objekte können mit einem Feld in einer Microsoft Access-Tabelle verknüpft oder in ein Feld eingebettet werden. Verwenden Sie in einem Formular oder Bericht ein Steuerelement, um das OLE-Objekt anzuzeigen. Um Informationen zum Bearbeiten und Anzeigen von Objekten anzuzeigen, die in Feldern des Datentyps OLE-Objekt gespeichert sind, klicken Sie auf [image] .


 Verschieben eines Feldes in der Tabellenentwurfsansicht

Verschieben eines Feldes in der Tabellenentwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Markieren Sie das Feld bzw. die Felder, das/die Sie verschieben möchten.

    Um ein einziges Feld zu markieren, klicken Sie auf den Zeilenmarkierer des entsprechenden Feldes.

    Um eine Gruppe von Feldern zu markieren, ziehen Sie die Maus über die Zeilenmarkierer der entsprechenden Felder.

  3. Klicken Sie erneut auf den Zeilenmarkierer, und halten Sie die Maustaste gedrückt. Microsoft Access zeigt direkt über der letzten markierten Zeile einen dünnen horizontalen Strich an.

  4. Ziehen Sie den horizontalen Strich zu der Zeile, über der die Felder eingefügt werden sollen.

Anmerkung Das Ändern der Feldreihenfolge in der Tabellenentwurfsansicht ändert die Reihenfolge, in der die Felder in der Tabelle gespeichert sind, und die Spaltenreihenfolge im Datenblatt der Tabelle. Um Informationen zum Ändern der Spaltenreihenfolge des Datenblatts anzuzeigen, klicken Sie auf [image] .


 Ändern eines Feldnamens in einer Tabelle

Ändern eines Feldnamens in einer Tabelle

Sie können einen Feldnamen jederzeit ändern, ohne dass die Daten im Feld beeinflusst werden. Microsoft Access behebt gängige Nebeneffekte, die beim Ändern eines Feldnamens auftreten, automatisch. Um weitere Informationen darüber anzuzeigen, wie Microsoft Access Feldnamen aktualisiert, klicken Sie auf [image] .

Sie können einen Feldnamen in der Entwurfsansicht oder in der Datenblattansicht ändern.

Was möchten Sie tun?

Einen Feldnamen in der Entwurfsansicht ändern

Einen Feldnamen in der Datenblattansicht ändern


 Löschen eines Feldes aus einer Tabelle

Löschen eines Feldes aus einer Tabelle

Wie ein Feld gelöscht wird, hängt davon ab, ob Sie in der Entwurfsansicht oder in der Datenblattansicht arbeiten.

Was möchten Sie tun?

Ein Feld aus einer Tabelle in der Entwurfsansicht löschen

Ein Feld aus einer Tabelle in der Datenblattansicht löschen


 Ändern des Datentyps eines Feldes

Ändern des Datentyps eines Feldes

  1. Wenn Ihre Tabelle Daten enthält, erstellen Sie eine Sicherungskopie der Tabelle, bevor Sie Datentypen oder Feldgrößen ändern.

  2. Öffnen Sie die Tabelle in der Entwurfsansicht.

  3. Klicken Sie auf die Spalte Felddatentyp des zu ändernden Feldes, dann auf den Pfeil, und wählen Sie den neuen Datentyp aus.

  4. Klicken Sie in der Symbolleiste auf Speichern [image] .

Vorsicht Wenn die Konvertierung des Datentyps dazu führen wird, dass Werte verloren gehen, zeigt Microsoft Access vor dem Speichern der Änderungen eine Meldung an, dass beim Konvertieren Fehler aufgetreten sind. Klicken Sie auf Abbrechen, um die Änderungen abzubrechen. Klicken Sie auf OK, um fortzufahren und die Änderungen dennoch zu speichern.

Zum Anzeigen von Informationen zu den Auswirkungen durch das Ändern des Datentyps eines Feldes klicken Sie auf [image] .

Anmerkung In großen Tabellen kann das Ändern eines Datentyps lange dauern. Wenn Sie die Konvertierung zu einem beliebigen Zeitpunkt des Ablaufs abbrechen möchten, drücken Sie STRG+PAUSE, und klicken Sie dann auf OK.


 Definieren eines anderen Namens für den Spaltennamen eines Feldes in der Datenblattansicht

Definieren eines anderen Namens für den Spaltennamen eines Feldes in der Datenblattansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld , für das Sie einen anderen Spaltennamen definieren möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein in das Einstellungsfeld für die Eigenschaft Beschriftung, und geben Sie dann den Text für den Spaltennamen ein. Dieser Text kann eine beliebige Kombination aus Buchstaben, Zahlen, Leerzeichen und Sonderzeichen enthalten und bis zu 255 Zeichen lang sein.

Anmerkungen

  • Dies ist nützlich in Situationen, in denen Sie einen Spaltennamen benötigen, der länger oder aussagekräftiger ist als der eigentliche Feldname. Sie können z.B. ein Feld für den Einsatz in Visual Basic für Applikationen-Code oder in Ausdrücken mit "Nname" bezeichnen, als Überschrift für die Spalte dagegen "Nachname" anzeigen.

  • Die Eigenschaft Beschriftung eines Feldes gibt auch den Standardtext an, der Steuerelementen in Formularen und Berichten zugewiesen wird, die mit einem Assistenten oder Ziehen eines Feldes aus der Feldliste erstellt wurden.

  • Wenn Sie für ein Feld die Eigenschaft Beschriftung einstellen und später ein Feld in der Datenblattansicht umbenennen, wird der mit der Eigenschaft Beschriftung festgelegte Text gelöscht. In diesem Fall können Sie die Eigenschaft Beschriftung für das Feld, wie oben beschrieben, neu einstellen. Sie können dieses Problem vermeiden, wenn Sie Feldnamen ausschließlich in der Entwurfsansicht umbenennen.


 Festlegen des Standardsteuerelementtyps (Listenfeld, Kombinationsfeld oder Kontrollkästchen) für ein Feld

Festlegen des Standardsteuerelementtyps (Listenfeld, Kombinationsfeld oder Kontrollkästchen) für ein Feld

  1. Öffnen Sie in der Entwurfsansicht die Tabelle, die das Feld enthält.

  2. Klicken Sie auf die Spalte Felddatentyp für ein Feld vom Datentyp Text, Zahl oder Ja/Nein.

  3. Klicken Sie im unteren Teil des Bildschirms auf die Registerkarte Nachschlagen.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft SteuerelementAnzeigen auf einen der Steuerelementtypen aus der Liste.

Anmerkungen

  • Sie können für Felder vom Datentyp Text, Zahl und Ja/Nein einen Standardsteuerelementtyp festlegen. Wenn Sie für ein Feld einen Standardsteuerelementtyp festlegen, zeigt Microsoft Access dieses Steuerelement im Datenblatt der Tabelle an und erstellt diesen Steuerelementtyp automatisch immer dann, wenn Sie dieses Feld zu einem Formular oder Bericht hinzufügen. Für Felder vom Datentyp Text und Zahl kann als Standardsteuerelementtyp ein Textfeld, ein Kombinationsfeld oder ein Listenfeld (nur in Formularen) festgelegt werden. Für Felder vom Datentyp Ja/Nein kann als Standardsteuerelementtyp ein Kontrollkästchen, ein Textfeld oder ein Kombinationsfeld festgelegt werden.

  • Wenn Sie das Feld im Datenblatt einer Tabelle als Kombinationsfeld, im Datenblatt einer Abfrage jedoch als Textfeld anzeigen möchten, können Sie zusätzlich zur Tabelleneigenschaft die Eigenschaft Nachschlagen für das Feld im Abfrageentwurf einstellen.


 Ändern der Feldgröße für Felder vom Datentyp "Text" oder "Zahl"

Ändern der Feldgröße für Felder vom Datentyp "Text" oder "Zahl"

Verwenden Sie die nachfolgenden Schritte zum festlegen, wie viele Zeichen in ein Feld vom Datentyp Text oder welcher Bereich und welche Art von numerischen Werten in ein Feld vom Datentyp Zahl eingegeben werden dürfen.

  1. Klicken Sie in der Tabellenentwurfsansicht im oberen Teil des Fensters auf das Feld, für das Sie die Eigenschaft Feldgröße einstellen möchten.

  2. Klicken Sie im unteren Teil des Fensters in der Registerkarte Allgemeinauf das Einstellungsfeld für die Eigenschaft Feldgröße.

  3. Geben Sie für ein Feld vom Datentyp Text die Anzahl der Zeichen (höchstens 255) an, die maximal in das Feld eingegeben werden dürfen.

    Klicken Sie für ein Feld vom Datentyp Zahl auf den Pfeil, und wählen Sie die gewünschte Feldgröße. Zum Anzeigen weiterer Informationen zu Feldgrößen für Felder vom Datentyp Zahl klicken Sie auf [image] .


 Erstellen eines Eingabeformats zum Steuern der Eingabe von Daten in ein Feld oder Steuerelement

Erstellen eines Eingabeformats zum Steuern der Eingabe von Daten in ein Feld oder Steuerelement

Unter Verwendung der Eigenschaft Eingabeformat können Sie steuern, wie Daten in ein Feld in einer Tabelle oder Abfrage oder in ein Steuerelement in einem Formular oder Bericht eingegeben werden.

Was möchten Sie tun?

Ein Eingabeformat für ein Feld in der Tabellenentwurfsansicht definieren

Ein Eingabeformat für ein Feld in der Entwurfsansicht für Abfragen definieren

Ein Eingabeformat für ein Textfeld oder ein Kombinationsfeld in der Entwurfsansicht für Formulare definieren

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Definieren eines Standardwertes, der automatisch in ein Feld oder Steuerelement eingegeben wird

Mit Hilfe der Eigenschaft Standardwert eines Feldes können Sie einen Wert angeben, der automatisch in dieses Feld eingegeben wird, wenn Sie einen neuen Datensatz hinzufügen.

Was möchten Sie tun?

Einen Standardwert für ein Feld in der Tabellenentwurfsansicht definieren

Einen Standardwert für ein Steuerelement in einem Formular oder einer Datenzugriffsseite definieren

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Eigenschaften, die die Behandlung leerer Felder steuern

Eigenschaften, die die Behandlung leerer Felder steuern

Durch Festlegen unterschiedlicher Kombinationen von Einstellungen für die Eigenschaften Eingabe Erforderlich und Leere Zeichenfolge des Feldes können Sie festlegen, wie ein leeres Feld behandelt werden soll. Die Eigenschaft Leere Zeichenfolge steht nur für Felder vom Datentyp Text, Memo oder Hyperlink zur Verfügung. Die Eigenschaft Eingabe Erforderlich bestimmt, ob eine Dateneingabe obligatorisch ist. Wenn für die Eigenschaft Leere Zeichenfolge die Einstellung Ja festgelegt ist, unterscheidet Microsoft Access zwischen zwei Arten von leeren Werten: Nullwerte und Werte mit leeren Zeichenfolgen.

Dieses Thema enthält Referenzinformationen über:

Der Unterschied zwischen Nullwerten und leeren Zeichenfolgen

Wann in einem Feld Nullwerte zugelassen werden sollen

Wann in einem Feld weder Nullwerte noch leere Zeichenfolgen zugelassen werden sollen

Wann in einem Feld sowohl Nullwerte als auch leere Zeichenfolgen zugelassen werden sollen

Wann in einem Feld nur leere Zeichenfolgen oder ein bestimmter Wert zugelassen werden sollen

Unterscheiden zwischen Nullwerten und leeren Zeichenfolgen

Suchen nach leeren Zeichenfolgen oder Nullwerten

Der Unterschied zwischen Nullwerten und leeren Zeichenfolgen

Microsoft Access differenziert zwischen zwei Arten von leeren Werten. In bestimmten Situationen bleibt ein Feld möglicherweise leer, wenn Informationen z. B. vorhanden, jedoch zum Zeitpunkt der Eingabe nicht bekannt sind, oder wenn das Feld den Datensatz nicht betrifft. Wenn eine Tabelle z. B. ein Nummer-Feld enthält, können Sie dieses leer lassen, wenn Sie die Faxnummer des Kunden nicht genau kennen oder nicht wissen, ob der Kunde überhaupt ein Fax besitzt. Wenn Sie das Feld in einem solchen Fall leer lassen, wird eine Null erfasst, was dem Wert Unbekannt entspricht. Wenn Sie eine leere Zeichenfolge in Form von Anführungszeichen (" ") eingeben, bedeutet dies "Es ist bekannt, dass für dieses Feld kein Wert vorhanden ist".

Zurück zum Anfang

Wann in einem Feld Nullwerte zugelassen werden sollen

Wenn Sie ein Feld leer lassen möchten und nicht feststellen müssen, warum das Feld leer bleibt, legen Sie sowohl für die Eigenschaft Eingabe Erforderlich als auch für die Eigenschaft Leere Zeichenfolge die Einstellung Nein fest. Dies ist die Standardeinstellung für Felder vom Datentyp Text, Memo und Hyperlink.

Zurück zum Anfang

Wann in einem Feld weder Nullwerte noch leere Zeichenfolgen zugelassen werden sollen

Wenn Sie möchten, dass ein Feld in keinem Fall leer bleibt, legen Sie für die Eigenschaft Eingabe Erforderlich die Einstellung Ja und für die Eigenschaft Leere Zeichenfolge die Einstellung Nein fest.

Zurück zum Anfang

Wann in einem Feld sowohl Nullwerte als auch leere Zeichenfolgen zugelassen werden sollen

Wenn Sie zwischen einen Feld, das aufgrund unbekannter Informationen leer ist, und einem Feld, das leer ist, weil es auf die Informationen nicht zutrifft, unterscheiden möchten, legen Sie für die Einstellung Eingabe Erforderlich die Einstellung Nein und für die Eigenschaft Leere Zeichenfolge die Einstellung Ja fest.

In diesem Fall können Sie beim Hinzufügen eines neuen Datensatzes das Feld leer lassen (wobei ein Nullwert eingefügt wird), wenn die Information unbekannt ist. Wenn Sie jedoch angeben möchten, dass das Feld den aktuellen Datensatz nicht betrifft, geben Sie Anführungszeichen ("") ohne Leerzeichen dazwischen ein und fügen damit eine leere Zeichenfolge ein.

Zurück zum Anfang

Wann in einem Feld nur leere Zeichenfolgen oder ein bestimmter Wert zugelassen werden sollen

Wenn Sie das Offenlassen eines Feldes nur gestatten möchten, wenn Sie wissen, dass ein Feld für einen Datensatz nicht zutrifft, legen Sie sowohl für die Eigenschaft Eingabe Erforderlich als auch für die Eigenschaft Leere Zeichenfolge die Einstellung Ja fest.

In diesem Fall kann ein Feld nur dann leer bleiben, wenn Sie Anführungszeichen ("") ohne Leerzeichen dazwischen eingeben oder die LEERTASTE drücken, um eine leere Zeichenfolge einzufügen.

Die nachstehende Tabelle zeigt die Ergebnisse möglicher Einstellungen der Eigenschaften Eingabe Erforderlich und Leere Zeichenfolge.

Eingabe Erforderlich | Leere Zeichenfolge | Benutzeraktion | Eingegebener Wert
Nein | Nein | Drücken der EINGABETASTE | <Null>
 |  | Drücken der LEERTASTE | <Null>
 |  | Eingeben von " " | (nicht zulässig)
Ja | Nein | Drücken der EINGABETASTE | (nicht zulässig)
 |  | Drücken der LEERTASTE | (nicht zulassig)
 |  | Eingeben von " " | (nicht zulässig)
Nein | Ja | Drücken der EINGABETASTE | <Null>
 |  | Drücken der LEERTASTE | <Null>
 |  | Eingeben von " " | <leere Zeichenfolge>
Ja | Ja | Drücken der EINGABETASTE | (nicht zulässig)
 |  | Drücken der LEERTASTE | <leere Zeichenfolge>
 |  | Eingeben von " " | <leere Zeichenfolge>

Zurück zum Anfang

Unterscheiden zwischen Nullwerten und leeren Zeichenfolgen

Wenn Sie Daten in einem Feld anzeigen, das sowohl Nullwerte als auch leere Zeichenfolgen enthält, sehen die Felder gleich aus - sie enthalten keine Werte. Sie können Nullwerte von leeren Zeichenfolgen unterscheiden, indem Sie einen Ausdruck in einem Abfragefeld oder in der Steuerelementquelle eines ungebundenen Steuerelements in einem Formular, einem Bericht oder einer Datenzugriffsseite verwenden. Der folgende Ausdruck gibt "Unbekannt" zurück, wenn das Feld Null enthält, und "LZ", wenn das Feld eine leere Zeichenfolge enthält; anderenfalls gibt der Ausdruck den Wert in dem Feld zurück.

=IIf(IsNull([Feldname]),"Unbekannt",Format([Feldname],"@;\LZ"))

Weitere Informationen über die Verwendung der Format-Eigenschaft bei Feldern, die Nullwerte oder leeren Zeichenfolgen enthalten.

Zurück zum Anfang

Suchen nach leeren Zeichenfolgen oder nach Nullwerten

Mit dem Befehl Suchen aus dem Menü Bearbeiten können Sie nach leeren Zeichenfolgen oder nach Nullwerten suchen. Markieren Sie in der Datenblattansicht oder der Formularansicht das Feld, das Sie durchsuchen möchten. Geben Sie in das Feld Suchen nach den Wert Null ein, um nach Null Werten zu suchen, oder geben Sie Anführungszeichen (" ") ohne Leerzeichen zwischen diesen ein, um nach leeren Zeichenfolgen zu suchen. Wählen Sie im Feld Vergleichen die Option Ganzes Feld, und stellen Sie sicher, dass das Kontrollkästchen Formatierung beachten deaktiviert ist.

Zum Anzeigen weiterer Informationen zur Verwendung des Befehls Suchen klicken Sie auf [image] .

Zurück zum Anfang


 Einstellen von Feldeigenschaften zum Anpassen der Einstellungen zum Speichern, Behandeln und Anzeigen von Daten

Einstellen von Feldeigenschaften zum Anpassen der Einstellungen zum Speichern, Behandeln und Anzeigen von Daten

Mit Hilfe der Eigenschaften eines Feldes können Sie selbst festlegen, wie die Daten in diesem Feld gespeichert, verwaltet und angezeigt werden.

Was möchten Sie tun?

Die Suche in Feldern, die häufig durchsucht werden, in Abfragen verknüpft oder sortiert sind, beschleunigen

Die Maximalgröße für ein Feld vom Datentyp Text oder der Größe der Zahl für ein Feld vom Datentyp Zahl festlegen

Die Anzahl der Dezimalstellen, die maximal für ein Feld vom Datentyp Zahl oder Währung angezeigt werden, festlegen

Das Anzeigeformat für ein Feld, z. B. ein Datumsformat, definieren

Ein Eingabeformat mit Literalzeichen und Leerstellen, in das Daten wie Telefonnummern, Postleitzahlen oder Datumsangaben eingegeben werden sollen, definieren

Eine Beschriftung, die nicht mit dem Feldnamen übereinstimmt, für die Spaltenüberschrift des Feldes in der Datenblattansicht und für Steuerelemente in Formularen und Berichten, die durch Ziehen des Feldes aus der Feldliste erstellt werden, definieren

Einen Wert, der automatisch eingegeben wird, wenn ein neuer Datensatz hinzugefügt wird, definieren

Die Daten, die in ein Feld eingegeben werden, auf Werte, die eine bestimmte Bedingung erfüllen, beschränken

Festlegen, dass in ein Feld Daten eingegeben werden müssen

Zulassen, dass in einem Feld vom Datentyp Text oder Memo Zeichenfolgen der Länge Null gespeichert werden

Informationen über die Komprimierung von Daten in einem Text-, Memo- oder Hyperlink-Feld erhalten

Sie sind sich über die gewünschte Auswahl nicht sicher?


 Komprimieren von Daten in Feldern des Datentyps Text, Memo oder Hyperlink

Komprimieren von Daten in Feldern des Datentyps Text, Memo oder Hyperlink

Microsoft Access 2000 verwendet das Unicode-Zeichencodierungsverfahren, um die Daten in Feldern des Datentyps Text, Memo oder Hyperlink darzustellen. Bei Unicode wird jedes Zeichen durch zwei Byte statt einem beschrieben.

Zeichencodierungsverfahren, die Zeichen in einem Byte speichern, können nur eine Codeseite verwenden - ein nummerierter Satz von maximal 256 Zeichen. Dagegen unterstützt Unicode bis zu 65.536 Zeichen, da jedes Zeichen durch zwei Byte beschrieben wird. Daher nehmen Daten in Text-, Memo- oder Hyperlink-Feldern mehr Speicherplatz in Anspruch als in früheren Versionen von Access.

Sie können diesen Nebeneffekt der Unicode-Zeichendarstellung ausgleichen und optimale Leistung gewährleisten, indem Sie die Unicode-Kompression-Eigenschaft auf Ja einstellen. Dies ist die Standardeinstellung beim Erstellen neuer Text-, Memo- oder Hyperlink-Felder. Wenn die Unicode-Kompression-Eigenschaft eines Feldes auf Ja eingestellt ist, wird jedes Zeichen, dessen erstes Byte 0 ist, beim Speichern komprimiert und beim Abrufen wieder dekomprimiert. Da das erste Byte von lateinischen Zeichen - also Buchstaben der westeuropäischen Sprachen wie Englisch, Spanisch oder Deutsch - 0 ist, wirkt sich die Unicode-Zeichendarstellung nicht darauf aus, wie viel Speicherplatz für komprimierte Daten benötigt wird, die ausschließlich aus lateinischen Zeichen bestehen.

In einem einzelnen Feld können Sie jede Kombination von Zeichen speichern, die Unicode unterstützt. Wenn das erste Byte eines bestimmten Zeichens jedoch nicht 0 ist, wird dieses Zeichen nicht komprimiert.

Anmerkung Daten in Feldern vom Datentyp Memo werden nur komprimiert, wenn sie nach der Komprimierung 4,096 Byte oder weniger Speicherplatz benötigen. Daher können Inhalte von Memo-Feldern in manchen Datensätzen komprimiert sein, in anderen dagegen nicht.

Informationen über die Unicode-Unterstützung in Microsoft Office.


Festlegen der Anzahl der Dezimalstellen, die in einem Feld oder Steuerelement angezeigt werden sollen

Was möchten Sie tun?

Die Anzahl der Dezimalstellen, die für ein Feld in der Tabellenentwurfsansicht angezeigt werden sollen, festlegen

Die Anzahl der Dezimalstellen, die für ein Feld in der Abfrageentwurfsansicht angezeigt werden sollen, festlegen

Die Anzahl der Dezimalstellen, die für ein Steuerelement in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte angezeigt werden sollen, festlegen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Definieren des Datenanzeigeformats für ein Feld oder ein Steuerelement

Definieren des Datenanzeigeformats für ein Feld oder ein Steuerelement

Unter Verwendung der Eigenschaft Format können Sie das Datenanzeigeformat für ein Feld in einer Tabelle, einer Abfrage oder für ein Steuerelement in einem Formular oder Bericht definieren.

Was möchten Sie tun?

Das Datenanzeigeformat für ein Feld in der Tabellenentwurfsansicht definieren

Das Datenanzeigeformat für ein Feld in der Entwurfsansicht für Abfragen definieren

Das Datenanzeigeformat für ein Steuerelement in einem Formular oder Bericht definieren

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Festlegen, dass ein Feld des Datentyps "Text", "Memo" oder "Hyperlink" leere Zeichenfolgen akzeptiert

Festlegen, dass ein Feld des Datentyps "Text", "Memo" oder "Hyperlink" leere Zeichenfolgen akzeptiert

  1. Öffnen Sie die Tabelle, die das Feld enthält, in der Entwurfsansicht.

  2. Klicken Sie auf das Feld, in das Sie eine leere Zeichenfolge eingeben möchten.

  3. Stellen Sie sicher, dass die Feldeigenschaft Leere Zeichenfolge auf Ja eingestellt ist.

Anmerkung Nur Felder des Datentyps Text, Memo und Hyperlink akzeptieren leere Zeichenfolgen.


 Einschränken der Verwendung oder Überprüfen der Gültigkeit von Daten

Einschränken der Verwendung oder Überprüfen der Gültigkeit von Daten

Sie können Gültigkeitsregeln oder Eingabeformate verwenden, um festzulegen, wie Daten in ein Feld in einer Tabelle oder Abfrage oder in ein Steuerelement in einem Formular oder Bericht eingegeben werden sollen. Darüber hinaus können Sie Makros verwenden, um noch komplexere Gültigkeitsprüfungen vorzunehmen.

Was möchten Sie tun?

Weitere Informationen über das Überprüfen oder Einschränken der Dateneingabe unter Verwendung von Feld- oder Tabelleneigenschaften anzeigen

Weitere Informationen über das Überprüfen oder Einschränken der Dateneingabe unter Verwendung von Formulareigenschaften oder Makros anzeigen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Definieren von Gültigkeitsregeln, die festlegen, welche Werte in ein Feld eingegeben werden dürfen

Definieren von Gültigkeitsregeln, die festlegen, welche Werte in ein Feld eingegeben werden dürfen

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie die Gültigkeitsregel definieren möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein in das Einstellungsfeld für die Eigenschaft Gültigkeitsregel, und geben Sie dann die Gültigkeitsregel ein, oder klicken Sie auf die Aufbauen-Schaltfläche [image] , um die Gültigkeitsregel unter Verwendung des Ausdrucks-Generators zu erstellen.

    Sie können z.B. die Gültigkeitsregel >9 für ein Feld namens Menge erstellen, wenn Sie verhindern möchten, dass ein Benutzer Bestellungen annimmt, die weniger als 10 Einheiten umfassen.

  4. Geben Sie im Einstellungsfeld für die Eigenschaft Gültigkeitsmeldung die Meldung ein, die angezeigt werden soll, wenn die Regel nicht eingehalten wird.

    Für den Gültigkeitsausdruck >9 können Sie z.B. die Meldung Sie müssen 10 oder mehr Einheiten bestellen eingeben. Zum Anzeigen von Beispielen für Gültigkeitsregeln klicken Sie auf [image] .

    Wenn Sie eine Gültigkeitsregel für ein Feld definieren, das Daten enthält, fragt Microsoft Access, ob die neue Regel beim Speichern auch zur Überprüfung bereits vorhandener Daten verwendet werden soll.

Anmerkungen

  • Gültigkeitsregel für ein Feld werden immer überprüft, wenn Sie Daten hinzufügen oder bearbeiten. Dies gilt unabhängig davon, ob das Hinzufügen oder Bearbeiten in der Datenblattansicht der Tabelle, in einem Steuerelement eines Formulars, das an das Feld gebunden ist, in einer Anfügeabfrage, in einer Aktualisierungsabfrage, in Form von Visual Basic für Applikationen-Code oder durch Importieren von Daten aus einer anderen Tabelle erfolgt.

  • Sie können zum Prüfen, ob die Daten in einer Tabelle die Gültigkeitsregeln einhalten, auch in der Titelleiste der Entwurfsansicht mit der rechten Maustaste und dann auf Testet Gültigkeitsregeln klicken.


 Festlegen, dass in ein bestimmtes Feld Daten eingegeben werden müssen

Festlegen, dass in ein bestimmtes Feld Daten eingegeben werden müssen

  1. Klicken Sie im oberen Teil der Tabellenentwurfsansicht auf das Feld, für das die Dateneingabe obligatorisch sein soll.

  2. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein auf das Einstellungsfeld für die Eigenschaft Eingabe erforderlich und dann auf Ja.

    Wenn Sie Änderungen an Ihrer Tabelle speichern, gibt Microsoft Access Ihnen die Möglichkeit, zu prüfen, ob dieses Feld in allen vorhandenen Datensätzen einen Wert enthält. Sie können jedoch auch festlegen, dass dieses Feld nur in allen neuen Datensätzen einen Wert enthalten muss, und dass Felder vorhandener Datensätze, die möglicherweise Null Werte (leere Werte) enthalten, nicht geändert werden sollen.

Anmerkung Die Eigenschaft EingabeErforderlich wird auf Tabellenebene angewendet, d. h. wenn Sie für diese Eigenschaft die Einstellung Ja festlegen, muss ein Feld an allen Stellen, an denen in dieses Feld Daten eingegeben werden können (in der Tabelle und in allen Formularen und Datenblättern, die auf diesem Feld basieren), einen Wert enthalten. Dies gilt auch dann, wenn ein Makro oder Visual Basic für Applikationen-Code den Wert für das Feld setzt, oder wenn Daten in die Tabelle importiert werden.


 Welche Primärschlüsselart soll verwendet werden?

Welche Primärschlüsselart soll verwendet werden?

Die Stärke eines relationalen Datenbanksystems wie Microsoft Access liegt in der Fähigkeit, unter Verwendung von Abfragen, Formularen und Berichten in unterschiedlichen Tabellen gespeicherte Informationen schnell zu finden und zusammenzuführen. Damit diese Fähigkeit zum Tragen kommt, sollte in jeder Tabelle ein Feld oder eine Gruppe von Feldern enthalten sein, das/die jeden einzelnen Datensatz der Tabelle eindeutig identifiziert. Diese Information wird als Primärschlüssel der Tabelle bezeichnet. Nachdem Sie einer Tabelle einen Primärschlüssel zugewiesen haben, verhindert Microsoft Access, um die Eindeutigkeit zu gewährleisten, dass Duplikate oder Nullwerte in Primärschlüsselfelder eingegeben werden.

In Microsoft Access können drei Primärschlüsseltypen definiert werden: AutoWert-, Ein-Feld- und Mehr-Felder-Primärschlüssel.

AutoWert-Primärschlüssel

Ein-Feld-Primärschlüssel

Mehr-Felder-Primärschlüssel

AutoWert-Primärschlüssel

Ein Feld des Datentyps AutoWert kann so eingestellt werden, dass mit jedem der Tabelle hinzugefügten Datensatz automatisch eine fortlaufende Nummer eingegeben wird. Das Zuweisen eines solchen Feldes als Primärschlüssel einer Tabelle ist das einfachste Verfahren zum Erstellen eines Primärschlüssels. Wenn Sie vor dem Speichern einer neu erstellten Tabelle keinen Primärschlüssel festlegen, fragt Microsoft Access, ob es einen Primärschlüssel für Sie erstellen soll. Wenn Sie auf Ja klicken, erstellt Microsoft Access einen AutoWert-Primärschlüssel. Wird die Tabelle mit Datenbankreplikation verwendet, sind weitere Überlegungen zu berücksichtigen. Weitere Informationen zu Autowert-Felder und Replikation in einer Microsoft Access-Datenbank anzeigen.

Zurück zum Anfang

Ein-Feld-Primärschlüssel

Wenn Sie ein Feld mit eindeutigen Werten haben, wie z.B. Personalnummern oder Artikelnummern, können Sie dieses Feld als Primärschlüssel festlegen. Enthält das als Primärschlüssel ausgewählte Feld Duplikat- oder Nullwerte, verhindert Microsoft Access das Festlegen des Primärschlüssels. Sie können eine Abfrage zur Duplikatsuche ausführen, um die Datensätze zu ermitteln, die Duplikate enthalten. Wenn es nicht möglich ist, die Duplikateinträge durch das Bearbeiten der Daten zu entfernen, können Sie entweder ein Feld des Datentyps AutoWert hinzufügen und es als Primärschlüssel festlegen, oder Sie können einen Mehr-Felder-Primärschlüssel definieren.

Zurück zum Anfang

Mehr-Felder-Primärschlüssel

In Situationen, in denen die Eindeutigkeit eines einzelnen Feldes nicht gewährleistet werden kann, können Sie zwei oder mehr Felder als Primärschlüssel festlegen. Dies geschieht am häufigsten bei der Tabelle, die in einer m:n-Beziehung zum Verknüpfen von zwei anderen Tabellen verwendet wird. In der Beispieldatenbank Nordwind ist dies z. B. die Tabelle Bestelldetails, die die Tabellen Bestellungen und Artikel miteinander verknüpft. Ihr Primärschlüssel besteht aus zwei Feldern: Bestell-Nr und Artikel-Nr. Die Tabelle Bestelldetails kann viele Bestellungen und Artikel enthalten, aber jeder Artikel kann pro Bestellung nur einmal aufgeführt werden. So entsteht durch die Kombination der Felder Bestell-Nr und Artikel-Nr ein entsprechender Primärschlüssel.

Jedes Produkt kann pro Bestellung nur einmal aufgeführt werden.

Ein anderes Beispiel ist eine Lagerbestandsdatenbank, die einen Primärschlüssel Artikel-Nr aus zwei oder mehr Feldern verwendet (Artikel und Einzelteil).

Anmerkung Wenn Sie sich beim Auswählen einer geeigneten Feldkombination für einen Mehr-Felder-Primärschlüssel nicht sicher sind, fügen Sie ein Feld des Datentyps AutoWert hinzu und legen es als Primärschlüssel fest. Es empfiehlt sich z. B. nicht, die Felder Vorname und Nachname für einen Primärschlüssel zu kombinieren, da möglicherweise Duplikate dieser Feldkombination auftreten können.

Um Informationen zum Setzen eines Primärschlüssels anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang


 Setzen oder Ändern des Primärschlüssels

Setzen oder Ändern des Primärschlüssels

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Markieren Sie das Feld bzw. die Felder, das/die Sie als Primärschlüssel definieren möchten.

    Um ein einziges Feld zu markieren, klicken Sie auf den Zeilenmarkierer des gewünschten Feldes.

    Um mehrere Felder zu markieren, halten Sie STRG gedrückt, und klicken Sie auf den Zeilenmarkierer jedes einzelnen Feldes.

  3. Klicken Sie in der Symbolleiste auf Primärschlüssel [image] .

Um Informationen zum Wählen eines Primärschlüssels anzuzeigen, klicken Sie auf [image] .

Anmerkungen

  • Sie können zu einem Feld, das bereits Daten enthält, einen Primärschlüssel angeben. Microsoft Access gibt jedoch beim Speichern der Tabelle eine Fehlermeldung aus, wenn es in dem Feld Duplikatwerte oder Nullwerte findet. Bei dieser Fehlermeldung haben Sie folgende drei Möglichkeiten: Verwenden Sie eine Abfrage zur Duplikatsuche, um Datensätze mit Duplikatwerten oder Nullwerten zu suchen, und bearbeiten Sie dann das Feld, um diese zu entfernen. Wählen Sie ein anderes Feld. Fügen Sie ein Feld des Datentyps AutoWert hinzu, und definieren Sie es als Primärschlüssel. Um Informationen zum Suchen von Duplikaten anzuzeigen, klicken Sie auf [image] .

  • In einem Mehr-Felder-Primärschlüssel kann die Feldreihenfolge wichtig sein. Die Felder in einem Mehr-Felder-Primärschlüssel sind entsprechend ihrer Reihenfolge im Tabellenentwurf sortiert. Wenn Sie eine andere Reihenfolge wünschen, geben Sie zunächst, wie im vorhergehenden Verfahren beschrieben, die Felder für den Primärschlüssel an. Klicken Sie dann in der Symbolleiste auf Indizes [image] , um das Fenster Indizes anzuzeigen und die Feldnamen für den als Primärschlüssel bezeichneten Index neu zu ordnen.


 Entfernen des Primärschlüssels

Entfernen des Primärschlüssels

  1. Wenn der Primärschlüssel in einer Beziehung verwendet wird, löschen Sie zuerst die Beziehung, bevor Sie den Schlüssel entfernen können.

    Wie wird's gemacht?

  2. Öffnen Sie die Tabelle in der Entwurfsansicht.

  3. Klicken Sie auf den Zeilenmarkierer des aktuellen Primärschlüssels und dann in der Symbolleiste auf Primärschlüssel [image] .

Anmerkung Dieses Verfahren löscht nicht das Feld oder die Felder, die als Primärschlüssel festgelegt sind, sondern entfernt nur die Primärschlüsselmerkmale aus der Tabelle. In einigen Fällen möchten Sie vielleicht den Primärschlüssel für eine Tabelle zeitweilig entfernen. Durch das Importieren von Datensätzen in eine Tabelle z.B. können sich einige Duplikatwerte ergeben. Bevor Sie die Duplikate entfernen, entfernen Sie den Primärschlüssel. Um Informationen zum Suchen von Duplikaten anzuzeigen, klicken Sie auf [image] .


 Erstellen eines Indexes zum schnelleren Suchen und Sortieren von Datensätzen

Erstellen eines Indexes zum schnelleren Suchen und Sortieren von Datensätzen

Sie können ein einzelnes Feld oder eine Kombination von Feldern indizieren, um Datensätze schneller sortieren und suchen zu können.

Was möchten Sie tun?

Einen einfachen Index erstellen

Einen zusammengesetzten Index erstellen

Indizes anzeigen oder bearbeiten

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Löschen eines Indexes

Löschen eines Indexes

Indizes beschleunigen das Suchen in Datenbanken. Sie können jedoch umfangreiche Aktualisierungen, wie z.B. in Form von Anfügeabfragen, auch verlangsamen. Wenn Sie ein Feld oder mehrere Felder indiziert haben, die Sie nicht durchsuchen, sortieren oder verknüpfen möchten, und wenn Sie umfangreiche Aktualisierungen an Datensätzen vornehmen, die Sie beschleunigen möchten, empfiehlt es sich, den Index zu löschen. Beim Löschen eines Indexes werden weder das Feld noch die Daten im Feld gelöscht.

So löschen Sie einen einfachen Index

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie den Index löschen möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein in das Einstellungsfeld für die Eigenschaft Indiziert und dann auf Nein.

So löschen Sie einen zusammengesetzten Index

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Indizes [image] .

  3. Markieren Sie im Fenster Indizes die Zeilen, die den Index enthalten, den Sie löschen möchten, und drücken Sie dann die ENTF-TASTE. Damit wird nur der Index, nicht das Feld an sich gelöscht.


 Verhindern der Eingabe von Duplikatwerten in einer Felderkombination

Verhindern der Eingabe von Duplikatwerten in einer Felderkombination

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Erstellen Sie einen zusammengesetzten Index unter Verwendung der Felder, für die Sie das Eingeben von Duplikatwerten verhindern möchten. Lassen Sie das Fenster Indizes nach dem Definieren des Indexes geöffnet.

    Wie wird's gemacht?

  3. Klicken Sie im oberen Teil des Fenster Indizes auf den neuen Indexnamen.

  4. Klicken Sie im unteren Teil des Fenster Indizes auf das Einstellungsfeld für die Eigenschaft Eindeutig, und wählen Sie dann Ja.


 Verhindern der Eingabe von Duplikatwerten in ein Feld

Verhindern der Eingabe von Duplikatwerten in ein Feld

Ein Primärschlüssel für ein einzelnes Feld verhindert das Auftreten von Duplikatwerten in diesem Feld und gewährleistet damit, dass jeder Datensatz einen eindeutigen Bezeichner hat. Möglicherweise möchten Sie jedoch auch für andere Felder das Auftreten von Duplikatwerten verhindern. Angenommen, Sie möchten Mitarbeitern einen Computer zuweisen und verwenden dafür ein Feld mit einer fortlaufenden Nummer für jeden Computer:

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie Duplikatwerte ausschließen möchten.

  3. Klicken Sie im unteren Teil des Fensters in der Registerkarte Allgemein auf das Einstellungsfeld für die Eigenschaft Indiziert und dann auf Ja (Ohne Duplikate).

Um Informationen zum Ausschließen von Duplikatwerten in einer Felderkombination anzuzeigen, klicken Sie auf [image] .


Definieren oder Ändern eines Primärschlüssels

Was möchten Sie tun?

Den Primärschlüssel definieren oder ändern

Den Primärschlüssel entfernen

Bestimmen, welche Art von Primärschlüssel verwendet werden sollte


 Anzeigen oder Bearbeiten von Indizes

Anzeigen oder Bearbeiten von Indizes

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Indizes [image] .

  3. Ändern Sie Indizes oder Indexeigenschaften wie gewünscht. Zum Löschen eines Indexes löschen Sie die entsprechende Zeile im Fenster Indizes. Damit wird nur der Index, nicht das Feld an sich gelöscht.


 Beziehungen in einer Access-Datenbank

Beziehungen in einer Access-Datenbank

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Gründe für das Definieren von Beziehungen

Funktionsweise von Beziehungen

1:n-Beziehung

m:n-Beziehung

1:1-Beziehung

Definieren von Beziehungen

Gründe für das Definieren von Beziehungen

Nachdem Sie verschiedene Tabellen zu den einzelnen Themen in Ihrer Microsoft Access-Datenbank angelegt haben, müssen Sie Microsoft Access mitteilen, wie diese Informationen wieder zusammengeführt werden. Der erste Schritt in diesem Prozess besteht darin, Beziehungen zwischen Ihren Tabellen zu definieren. Anschließend können Sie Abfragen, Formulare und Berichte erstellen, um die Informationen aus verschiedenen Tabellen gleichzeitig anzuzeigen. Dieses Formular enthält z. B. Informationen aus fünf Tabellen:

Bestellformular mit Informationen aus insgesamt 5 miteinander durch Beziehungen verknüpften Tabellen

Zurück zum Anfang

Funktionsweise von Beziehungen

Im vorangegangenen Beispiel müssen die Felder aus fünf Tabellen so koordiniert werden, dass sie Informationen zu ein und derselben Bestellung anzeigen. Diese Koordination wird durch Beziehungen zwischen den Tabellen erreicht. Eine Beziehung funktioniert durch übereinstimmende Daten in Schlüsselfeldern, normalerweise ein Feld, das in beiden Tabellen denselben Namen besitzt. In den meisten Fällen stellen diese übereinstimmenden Felder den Primärschlüssel in der einen Tabelle dar, der einen eindeutigen Bezeichner für jeden Datensatz angibt, und einen Fremdschlüssel in der anderen Tabelle. Einzelnen Angestellten können z.B. Bestellungen zugeordnet werden, für die sie zuständig sind, indem eine Beziehung zwischen den Tabellen Personal und Bestellungen über die Felder Personal-Nr hergestellt wird.

<Personal-Nr> dient als Primärschlüssel in der Tabelle <Personal> und als Fremdschlüssel in der Tabelle <Bestellungen>.

Zurück zum Anfang

1:n-Beziehung

Eine 1:n-Beziehung ist der häufigste Beziehungstyp. In einer 1:n-Beziehung können einem Datensatz in Tabelle A mehrere passende Datensätze in Tabelle B zugeordnet sein, aber einem Datensatz in Tabelle B ist nie mehr als ein Datensatz in Tabelle A zugeordnet.

Datensatz in der Tabelle <Lieferanten> mit mehr als einem in Beziehung stehenden Datensatz in der Tabelle <Artikel>

Zurück zum Anfang

m:n-Beziehung

In einer m:n-Beziehung können jedem Datensatz in Tabelle A mehrere passende Datensätze in Tabelle B zugeordnet sein und umgekehrt. Dies ist nur möglich, indem eine dritte Tabelle definiert wird (die als Verbindungstabelle bezeichnet wird), deren Primärschlüssel aus zwei Feldern besteht, den Fremdschlüsseln aus den Tabellen A und B. Eine m:n-Beziehung besteht eigentlich aus zwei 1:n-Beziehungen mit einer dritten Tabelle. Zwischen der Tabelle Bestellungen und der Tabelle Artikel besteht z.B. eine m:n-Beziehung, die durch Erstellung von zwei 1:n-Beziehungen zur Tabelle Bestelldetails definiert wird.

Fremdschlüssel in der Tabelle <Bestelldetails> und die dazu passenden Primärschlüssel in den Tabellen <Bestellungen> und <Artikel>

Zurück zum Anfang

1:1-Beziehung

In einer 1:1-Beziehung ist jedem Datensatz in Tabelle A nur ein passender Datensatz in Tabelle B zugeordnet und umgekehrt. Diese Art von Beziehung ist nicht sehr häufig, weil die meisten Informationen, die auf diese Weise in Beziehung stehen, sich in einer Tabelle befinden. Sie können eine 1:1-Beziehung z.B. verwenden, um eine Tabelle mit vielen Feldern zu teilen, um einen Teil der Tabelle aus Gründen der Zugriffsrechte abzutrennen, oder um Informationen zu speichern, die sich nur auf eine Untergruppe der Haupttabelle beziehen. Sie können z.B. eine Tabelle erstellen, die nur die Angestellten enthält, die an einem für einen guten Zweck ausgerichteten Fußballspiel teilnehmen.

Zu jedem Datensatz in der Tabelle <Personal> kann es nur einen dazu passenden Datensatz in der Tabelle <Fußballspieler> geben.

Zurück zum Anfang

Definieren von Beziehungen

Sie definieren eine Beziehung, indem Sie die Tabellen, zwischen denen Sie Beziehungen herstellen möchten, dem Fenster Beziehungen hinzufügen und anschließend das Schlüsselfeld aus einer Tabelle auf das Schlüsselfeld der anderen Tabelle ziehen. Sie können auch Beziehungen mit Hilfe der Tastatur definieren.

Feld der einen Tabelle wird auf das passende Feld in der anderen Tabelle gezogen.

Welche Art von Beziehung Microsoft Access erstellt, hängt davon ab, wie die in Beziehung stehenden Felder definiert sind:

  • Eine 1:n-Beziehung wird hergestellt, wenn nur eines der in Beziehung stehenden Felder ein Primärschlüssel ist oder einen eindeutigen Index besitzt.

  • Eine 1:1-Beziehung wird hergestellt, wenn beide in Beziehung stehenden Felder Primärschlüssel sind oder über eindeutige Indizes verfügen.

  • Eine m:n-Beziehung besteht eigentlich aus zwei 1:n-Beziehungen mit einer dritten Tabelle, deren Primärschlüssel aus zwei Feldern besteht, und zwar den Fremdschlüsseln aus den beiden anderen Tabellen.

Zum Anzeigen weiterer Informationen zum Definieren von Beziehungen klicken Sie auf [image] .

Anmerkung Wenn Sie ein Feld, das kein Primärschlüssel ist und keinen eindeutigen Index besitzt, auf ein Feld ziehen, das ebenfalls kein Primärschlüssel ist und keinen eindeutigen Index besitzt, wird eine unbestimmte Beziehung erstellt. In Abfragen, die Tabellen mit einer unbestimmten Beziehung besitzen, zeigt Microsoft Access eine Standardverknüpfungslinie zwischen den Tabellen an, aber die referenzielle Integrität wird nicht durchgesetzt, und es gibt keine Garantie, dass die Datensätze in den Tabellen eindeutig sind.

Zurück zum Anfang

Weitere Informationen über Beziehungen in einem Microsoft Access-Projekt.


 Anzeigen des Fensters "Beziehungen"

Anzeigen des Fensters "Beziehungen"

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie in der Symbolleiste auf Beziehungen [image] .

    Das Fenster Beziehungen wird angezeigt. Wenn das Layout der Beziehung zuvor gespeichert wurde, wird das gespeicherte Layout angezeigt. Andernfalls wird das Dialogfeld Tabelle anzeigen angezeigt. Dort können Sie die Tabellen bzw. Abfragen auswählen, die dem Fenster Beziehungen hinzugefügt werden sollen.


 Definieren von Beziehungen zwischen Tabellen

Definieren von Beziehungen zwischen Tabellen

  1. Schließen Sie alle geöffneten Tabellen. Sie können keine Beziehungen zwischen geöffneten Tabellen erstellen oder bearbeiten.

  2. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  3. Klicken Sie in der Symbolleiste auf Beziehungen [image] .

  4. Wenn für die Datenbank keine Beziehungen definiert sind, wird automatisch das Dialogfeld Tabelle anzeigen angezeigt. Müssen die Tabellen, die Sie verknüpfen möchten, hinzugefügt werden, und wird das Dialogfeld Tabelle anzeigen nicht angezeigt, klicken Sie in der Symbolleiste auf Tabelle anzeigen [image] . Falls die zu verknüpfenden Tabellen bereits angezeigt werden, fahren Sie mit Schritt 6 fort.

  5. Doppelklicken Sie auf die Namen der Tabellen, die Sie miteinander verknüpfen möchten, und schließen Sie dann das Dialogfeld Tabelle anzeigen.

  6. Ziehen Sie das zu verknüpfende Feld aus der einen Tabelle zum Detailfeld in der anderen Tabelle.

    Um mehrere Felder gleichzeitig zu ziehen, drücken Sie STRG, und klicken Sie auf die einzelnen Felder, bevor Sie sie ziehen.

    In den meisten Fällen ziehen Sie das Primärschlüsselfeld (in Fettdruck dargestellt) aus einer Tabelle zu einem ähnlichen Feld (häufig mit demselben Namen), Fremdschlüssel genannt, in der anderen Tabelle. Die Detailfelder müssen nicht denselben Namen haben, sie müssen jedoch denselben Datentyp aufweisen (mit zwei Ausnahmen) und dieselbe Art an Informationen enthalten. Handelt es sich bei den übereinstimmenden Feldern um Felder des Datentyps Zahl, muss außerdem die Einstellung der Eigenschaft Feldgröße identisch sein. Bei der Übereinstimmung von Datentypen gibt es folgende zwei Ausnahmen: Ein Feld des Datentyps AutoWert kann mit einem Feld des Datenyps Zahl verknüpft werden, dessen Eigenschaft Feldgröße auf Long Integer eingestellt ist. Ein Feld des Datentyps AutoWert kann mit einem Feld des Typs Zahl verknüpft werden, wenn die Eigenschaft Feldgröße beider Felder auf Replikations-ID eingestellt ist.

  7. Das Dialogfeld Beziehungen bearbeiten wird angezeigt. Prüfen Sie, ob die in beiden Spalten angezeigten Feldnamen richtig sind. Sie können sie bei Bedarf ändern.

    Legen Sie ggf. die Beziehungsoptionen fest. Zum Anzeigen von Informationen zu einem bestimmten Element des Dialogfelds Beziehungen klicken Sie auf die Fragezeichenschaltfläche [image] und dann auf das Element.

  8. Klicken Sie auf die Schaltfläche Erstellen, um die Beziehung zu erstellen.

  9. Wiederholen Sie die Schritte 5 bis 8 für jedes Tabellenpaar, das Sie miteinander verknüpfen möchten.

    Wenn Sie das Fenster Beziehungen schließen, fragt Microsoft Access, ob Sie das Layout speichern möchten. Unabhängig davon, ob Sie das Layout speichern oder nicht, werden die erstellten Beziehungen in der Datenbank gespeichert.

Anmerkungen

  • Wenn Sie alle in der Datenbank definierten Beziehungen anzeigen möchten, klicken Sie in der Symbolleiste auf Alle Beziehungen anzeigen [image] . Um nur die für eine bestimmte Tabelle definierten Beziehungen anzuzeigen, klicken Sie auf die Tabelle und dann in der Symbolleiste auf Direkte Beziehungen anzeigen [image] .

  • Wenn Sie eine Änderung am Entwurf einer Tabelle vornehmen möchten, können Sie mit der rechten Maustaste auf die zu ändernde Tabelle und dann auf Tabellenentwurf klicken.

  • Sie können Beziehungen sowohl unter Verwendung von Abfragen als auch von Tabellen erstellen. Die referenzielle Integrität wird bei Abfragen jedoch nicht durchgesetzt.

  • Um eine Beziehung innerhalb einer Tabelle zu erstellen, fügen Sie diese Tabelle zweimal hinzu. Dies empfiehlt sich, wenn Sie innerhalb derselben Tabelle nachschlagen müssen. In der Tabelle Personal der Beispieldatenbank Nordwind wurde z.B. eine Beziehung zwischen den Feldern Personal-Nr und Vorgesetzte(r) erstellt, so dass im Feld Vorgesetzte(r) Personaldaten aus einem entsprechenden Feld Personal-Nr angezeigt werden können.

  • Sie können auch eine Beziehung mit Hilfe der Tastatur definieren.


 Definieren einer m:n-Beziehung zwischen Tabellen

Definieren einer m:n-Beziehung zwischen Tabellen

  1. Erstellen Sie die beiden Tabellen, zwischen denen eine m:n-Beziehung erstellt werden soll.

    Wie wird's gemacht?

  2. Erstellen Sie eine dritte Tabelle, eine sogenannte Verknüpfungstabelle. Fügen Sie dieser Tabelle Felder hinzu, deren Definitionen mit denen der Primärschlüsselfelder aus den beiden anderen Tabellen identisch sind. Die Primärschlüsselfelder in der Verknüpfungstabelle dienen als Fremdschlüssel. Genauso wie jeder anderen Tabelle können Sie der Verknüpfungstabelle auch andere Felder hinzufügen.

  3. Setzen Sie den Primärschlüssel der Verknüpfungstabelle auf die Primärschlüsselfelder der beiden anderen Tabellen. So besteht z.B. in einer Verknüpfungstabelle Bestelldetails der Primärschlüssel aus den Feldern Bestell-Nr und Artikel-Nr.

    Wie wird's gemacht?

  4. Definieren Sie eine m:n-Beziehung zwischen jeder der beiden Mastertabellen und der Verknüpfungstabelle.

    Wie wird's gemacht?

  5. Um den Tabellen Daten hinzuzufügen, führen Sie einen der folgenden Schritte aus:
    • Erstellen Sie eine Abfrage, die mehrere Tabellen einbezieht. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Erstellen Sie ein Formular, das mehrere Tabellen einbezieht. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkung In der Beispieldatenbank Nordwind besteht zwischen den Tabellen Bestellungen und Artikel eine m:n-Beziehung. Eine Bestellung in der Tabelle Bestellungen kann mehrere Artikel aus der Tabelle Artikel enthalten. Außerdem kann ein einzelner Artikel in vielen Bestellungen enthalten sein. Die Tabelle Bestelldetails in der Beispieldatenbank Nordwind ist eine Verknüpfungstabelle zwischen den Tabellen Bestellungen und Artikel.


 Definieren der Standardverknüpfungsart für eine Beziehung zwischen zwei Tabellen

Definieren der Standardverknüpfungsart für eine Beziehung zwischen zwei Tabellen

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie in der Symbolleiste auf Beziehungen [image] , um das Fenster Beziehungen zu öffnen.

  3. Doppelklicken Sie auf den mittleren Abschnitt einer Verknüpfungslinie zwischen zwei Tabellen, um das Dialogfeld Beziehungen zu öffnen.

  4. Klicken Sie auf die Schaltfläche Verknüpfungstyp und dann auf den gewünschten Verknüpfungstyp.

    Option 1 definiert eine Exklusionsverknüpfung. Dies ist die Standardeinstellung.

    Option 2 definiert eine Links-Inklusionsverknüpfung.

    Option 3 definiert eine Rechts-Inklusionsverknüpfung.

Anmerkung Wenn es sich um verknüpfte Tabellen handelt, ist die Schaltfläche Verknüpfungstyp nicht aktiviert. Bei Tabellen im Microsoft Access-Format können Sie die Datenbank öffnen, in der sie gespeichert sind, um den Verknüpfungstyp festzulegen.

Das Definieren des Verknüpfungstyps einer Beziehung im Fenster Beziehungen wirkt sich nicht auf die Beziehung selbst aus. Es wird nur die Art der Verknüpfung festgelegt, die beim Erstellen von Abfragen auf der Basis von Detailtabellen standardmäßig verwendet werden soll. Sie können den Standardverknüpfungstyp jederzeit außer Kraft setzen, wenn Sie eine Abfrage definieren.

Anmerkung Sie können auch den Standardverknüpfungstyp mit Hilfe der Tastatur definieren. Informationen über Verknüpfungstypen.


 Löschen einer Beziehung

Löschen einer Beziehung

  1. Schließen Sie alle geöffneten Tabellen. Sie können keine Beziehungen zwischen geöffneten Tabellen löschen.

  2. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  3. Klicken Sie in der Symbolleiste auf Beziehungen [image] .

  4. Wenn die Tabellen, deren Beziehung Sie löschen möchten, nicht angezeigt werden, klicken Sie in der Symbolleiste auf Tabelle anzeigen [image] , und doppelklicken Sie auf die Tabellen, die Sie hinzufügen möchten. Klicken Sie dann auf Schließen.

  5. Klicken Sie auf die Verknüpfungslinie der Beziehung, die Sie löschen möchten (die markierte Linie wird in Fettdruck dargestellt), und drücken Sie ENTF.

Anmerkung Sie können auch eine Beziehung mit Hilfe der Tastatur löschen.


 Bearbeiten einer bestehenden Beziehung

Bearbeiten einer bestehenden Beziehung

  1. Schließen Sie alle geöffneten Tabellen. Sie können keine Beziehungen zwischen geöffneten Tabellen bearbeiten.

  2. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  3. Klicken Sie in der Symbolleiste auf Beziehungen [image] .

  4. Wenn die Tabellen, deren Beziehung Sie bearbeiten möchten, nicht angezeigt werden, klicken Sie in der Symbolleiste auf Tabelle anzeigen [image] , und doppelklicken Sie auf jede einzelne Tabelle, die Sie hinzufügen möchten.

  5. Doppelklicken Sie auf die Verknüpfungslinie der Beziehung, die Sie bearbeiten möchten.

  6. Legen Sie die Beziehungsoptionen fest. Zum Anzeigen von Informationen zu einem bestimmten Element des Dialogfelds Beziehungen klicken Sie auf die Fragezeichenschaltfläche [image] und dann auf das Element.

Anmerkung Sie können auch eine Beziehung mit Hilfe der Tastatur ändern.


 Drucken des Fensters "Beziehungen"

Drucken des Fensters "Beziehungen"

In einer Microsoft Access-Datenbank können Sie mit Hilfe des Assistenten zum Drucken von Beziehungen einen Bericht erstellen, der die Beziehungen so anzeigt, wie sie im Fenster Beziehungen angezeigt werden.

  1. Öffnen Sie die Access-Datenbank, deren Beziehungen Sie drucken möchten.

  2. Klicken Sie im Menü Extras auf Beziehungen, um das Fenster "Beziehungen" zu öffnen.

  3. Klicken Sie im Menü Datei auf Beziehungen drucken.

Anmerkung Sie können nicht die Beziehungen in einem Microsoft Access-Projekt drucken.

Tipp Der Assistent zum Drucken von Beziehungen erstellt einen Bericht mit dem Kopf Beziehungen für Datenbankname und den Daten, die Sie im Bericht erstellt haben. Sie können diesen Bericht für spätere Verwendung speichern.


Entfernen einer Tabelle aus dem Fenster "Beziehungen"

  • Klicken Sie auf die zu entfernende Tabelle, und drücken Sie ENTF.

    Microsoft Access entfernt die Tabelle und ihre Verknüpfungslinien aus dem Fenster Beziehungen. Diese Aktion betrifft nur die Anzeige im Fenster Beziehungen. Die Tabelle und deren Beziehungen werden nicht aus der Datenbank gelöscht.


 Anzeigen vorhandener Beziehungen

Anzeigen vorhandener Beziehungen

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie in der Symbolleiste auf Beziehungen [image] .

  3. Um alle in der Datenbank definierten Beziehungen anzuzeigen, klicken Sie in der Symbolleiste auf Alle Beziehungen anzeigen [image] .

    Um nur die für eine bestimmte Tabelle definierten Beziehungen anzuzeigen, klicken Sie auf die Tabelle und dann in der Symbolleiste auf Direkte Beziehungen anzeigen [image] .

Anmerkung Wenn alle Tabellen, die mit der markierten Tabelle verknüpft sind, im Fenster Beziehungen bereits angezeigt werden, hat das Klicken auf die Schaltfläche Direkte Beziehungen anzeigen keine Auswirkungen. Diese Schaltfläche fügt nämlich nur Tabellen hinzu, die mit der aktuellen Tabelle verknüpft sind. Wenn Sie nur die direkten Beziehungen einer einzigen Tabelle anzeigen möchten, klicken Sie in der Symbolleiste auf Layout löschen [image] , um alle Tabellen und Beziehungen aus dem Fenster Beziehungen zu entfernen (sie werden dadurch nicht gelöscht). Fügen Sie die gewünschte Tabelle wieder hinzu, und klicken Sie auf die Schaltfläche Direkte Beziehungen anzeigen. Um eine Tabelle hinzuzufügen, klicken Sie in der Symbolleiste auf Tabelle anzeigen [image] . Doppelklicken Sie auf die Tabelle, und klicken Sie dann auf Schließen.


 Was ist referenzielle Integrität?

Was ist referenzielle Integrität?

Referenzielle Integrität ist ein Regelsystem, mit dessen Hilfe Microsoft Access sicherstellt, dass Beziehungen zwischen Datensätzen in Detailtabellen gültig sind und dass verknüpfte Daten nicht versehentlich gelöscht oder geändert werden. Sie können referenzielle Integrität festlegen, wenn alle folgenden Bedingungen erfüllt sind:

  • Das übereinstimmende Feld aus der Mastertabelle ist ein Primärschlüssel oder hat einen eindeutigen Index.

  • Die Detailfelder haben denselben Datentyp. Allerdings gibt es zwei Ausnahmen: Ein Feld des Datentyps AutoWert kann mit einem Feld des Datenyps Zahl verknüpft werden, dessen Eigenschaft Feldgröße auf Long Integer eingestellt ist. Ein Feld des Datentyps AutoWert kann mit einem Feld des Typs Zahl verknüpft werden, wenn die Eigenschaft Feldgröße beider Felder auf Replikations-ID eingestellt ist.

  • Beide Tabellen gehören zu derselben Microsoft Access-Datenbank. Handelt es sich dabei um verknüpfte Tabellen, müssen diese über das Microsoft Access-Format verfügen. Um referenzielle Integrität festzulegen, öffnen Sie die Datenbank, in der die Tabellen gespeichert sind. Referenzielle Integrität kann nämlich nicht für verknüpfte Tabellen aus Datenbanken anderer Formate durchgesetzt werden.

Beim Durchsetzen referenzieller Integrität beachten Sie folgende Regeln:

  • Sie können in das Fremdschlüsselfeld der Detailtabelle keinen Wert eingeben, der nicht im Primärschlüsselfeld der Mastertabelle enthalten ist. Sie können jedoch in das Fremdschlüsselfeld einen Nullwert eingeben und damit angeben, dass die Datensätze nicht miteinander verknüpft sind. So ist es z.B. nicht möglich, eine Bestellung zu haben, die einem nichtvorhandenen Kunden zugeordnet ist. Sie können jedoch eine Bestellung haben, die niemandem zugeordnet ist, indem Sie in das Feld Kunden-Nr einen Nullwert eingeben.

  • Sie können keinen Datensatz aus der Mastertabelle löschen, wenn übereinstimmende Datensätze in einer Detailtabelle enthalten sind. Beispielsweise können Sie einen Datensatz eines Mitarbeiters aus der Tabelle Personal nicht löschen, wenn diesem Mitarbeiter in der Tabelle Bestellungen Bestellungen zugeordnet sind.

  • Sie können keinen Primärschlüsselwert in der Mastertabelle ändern, wenn es zu diesem Datensatz Detaildatensätze gibt. Beispielsweise können Sie die Personalnummer eines Mitarbeiters in der Tabelle Personal nicht ändern, wenn diesem Mitarbeiter in der Tabelle Bestellungen Bestellungen zugeordnet sind.

Falls Microsoft Access diese Regeln für eine Beziehung durchsetzen soll, aktivieren Sie das Kontrollkästchen Mit referenzieller Integrität, wenn Sie die Beziehung erstellen. Wird die referenzielle Integrität für Detailtabellen durchgesetzt und dabei gegen eine dieser Regeln verstoßen, zeigt Microsoft Access eine Meldung an und lässt die Änderung nicht zu.

Sie können die Einschränkungen beim Löschen bzw. Ändern von Detaildatensätzen außer Kraft setzen und dennoch referenzielle Integrität wahren, indem Sie die Kontrollkästchen Aktualisierungsweitergabe an Detailfeld und Löschweitergabe an Detaildatensatz aktivieren. Ist das Kontrollkästchen Aktualisierungsweitergabe an Detailfeld aktiviert, wird beim Ändern eines Primärschlüsselwerts in der Mastertabelle der damit übereinstimmende Wert in allen Detaildatensätzen automatisch aktualisiert. Ist das Kontrollkästchen Löschweitergabe an Detaildatensatz aktiviert, werden beim Löschen eines Datensatzes in der Mastertabelle alle Detaildatensätze in der Detailtabelle ebenfalls automatisch gelöscht. Zum Anzeigen von Informationen zu den Kontrollkästchen Löschweitergabe an Detaildatensatz und Aktualisierungsweitergabe an Detailfeld klicken Sie auf [image] .

Um Informationen zum Bearbeiten einer vorhandenen Beziehung und zum Festlegen der referenziellen Integrität anzuzeigen, klicken Sie auf [image] .

Um Informationen zum Definieren einer neuen Beziehung anzuzeigen, klicken Sie auf [image] .


 Warum werden Aktualisierungsweitergaben oder Löschweitergaben verwendet?

Warum werden Aktualisierungsweitergaben oder Löschweitergaben verwendet?

Bei Beziehungen, in denen referenzielle Integrität durchgesetzt wird, können Sie angeben, ob Microsoft Access für Detaildatensätze automatisch Aktualisierungsweitergaben und Löschweitergaben durchführen soll. Wenn Sie diese Optionen setzen, sind Lösch- und Aktualisierungsoperationen zulässig, die normalerweise durch die Regeln referenzieller Integrität verhindert werden. Wenn Sie in einer Mastertabelle Datensätze löschen oder Primärschlüsselwerte ändern, führt Microsoft Access die erforderlichen Änderungen in den verknüpften Tabellen (Detailtabellen) aus, um die referenzielle Integrität zu wahren.

Wenn Sie beim Definieren einer Beziehung das Kontrollkästchen Aktualisierungsweitergabe an Detailfeld aktiviert haben, aktualisiert Microsoft Access bei jeder Änderung des Primärschlüssels eines Datensatzes der Mastertabelle automatisch den Primärschlüssel in allen Detaildatensätzen auf den neuen Wert. Ändern Sie z. B. in der Tabelle Kunden eine Kundennummer, wird das Feld Kunden-Code in der Tabelle Bestellungen automatisch für alle Bestellungen dieses Kunden aktualisiert, damit die Beziehung erhalten bleibt. Microsoft Access gibt Aktualisierungen ohne vorherige Anzeige einer Meldung weiter.

Anmerkung Handelt es sich beim Primärschlüssel der Mastertabelle um ein Feld des Datentyps AutoWert, hat das Aktivieren des Kontrollkästchens Aktualisierungsweitergabe an Detailfeld keine Wirkung, da der Wert in einem Feld des Datentyps AutoWert nicht geändert werden kann.

Wenn Sie beim Definieren einer Beziehung das Kontrollkästchen Löschweitergabe an Detaildatensatz aktiviert haben, löscht Microsoft Access bei jedem Löschen von Datensätzen in der Mastertabelle automatisch die Detaildatensätze in der Detailtabelle. Löschen Sie z. B. einen Kundendatensatz aus der Tabelle Kunden, werden automatisch alle Bestellungen dieses Kunden aus der Tabelle Bestellungen gelöscht (dies schließt Datensätze in der Tabelle Bestelldetails ein, die mit den Bestelldatensätzen verknüpft sind). Wenn Sie Datensätze aus einem Formular oder Datenblatt löschen und das Kontrollkästchen Löschweitergabe an Detaildatensatz aktiviert ist, gibt Microsoft Access die Warnung aus, dass Detaildatensätze ebenfalls gelöscht werden können. Wenn Sie Datensätze jedoch unter Verwendung einer Löschabfrage löschen, löscht Microsoft Access automatisch die Datensätze in den Detailtabellen, ohne zuvor eine Warnung anzuzeigen.

Um Informationen zum Bearbeiten einer vorhandenen Beziehung und zum Festlegen der referenziellen Integrität anzuzeigen, klicken Sie auf [image] .

Um Informationen zum Definieren einer neuen Beziehung anzuzeigen, klicken Sie auf [image] .


 Exportieren von Daten und Datenbankobjekten in ein anderes Datenbank- oder Dateiformat

Exportieren von Daten und Datenbankobjekten in ein anderes Datenbank- oder Dateiformat

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Was bedeutet Exportieren?

Exportieren von Datenbankobjekten

Versenden von Datenbankobjekten per E-Mail

Exportieren von Daten oder Datenobjekten zur Übernahme in eine Webseite

Exportieren bzw. Austauschen von Daten zur Verwendung mit Microsoft Word

Exportieren von Daten zur Verwendung mit Microsoft Excel oder einem anderen Tabellenkalkulationsprogramm

Automatisieren von Exportoperationen

Was bedeutet Exportieren?

Exportieren ist ein Verfahren zur Ausgabe von Daten und Datenobjekten in Dateiform unter Verwendung eines anderen Datenbank-, Tabellen- oder Dateiformats. Auf diese Weise können andere Datenbanken, Anwendungen und Programme diese Daten bzw. Datenbankobjekte verwenden. In seiner Funktion ähnelt das Exportieren der Kombination von Kopieren und Einfügen. In der Regel verwenden Sie zum Exportieren von Daten oder Datenbankobjekten den Befehl Exportieren im Menü Datei, aber es gibt diesbezüglich noch weitere Befehle, die Sie in der weiter unten beschriebenen Weise verwenden können. Für den Export von Daten stehen eine Vielzahl von unterstützten Datenbank-, Programm- und Dateiformaten zur Verfügung.

Zurück zum Anfang

Exportieren von Datenbankobjekten

Die meisten Datenbankobjekte einer Microsoft Access-Datenbank oder eines Microsoft Access-Projekts lassen sich per Export in eine andere Access-Datenbank bzw. ein anderes Access-Projekt übernehmen.

Zurück zum Anfang

Senden von Datenbankobjekten per E-Mail

Sie können im Menü Datei im Untermenü Senden an mit Hilfe des Befehls Mailempfänger (als Anlage) ein Datenbankobjekt als Anlage einer E-Mail-Nachricht ausgeben. Dabei stehen Ihnen mehrere verschiedene Dateiformate zur Verfügung, unter anderem Microsoft Excel (.xls), Rich Text Format (.rtf), MS-DOS-Text (.txt), HTML (.html), IDC/HTX, ASP und die Ausgabe als Datenzugriffsseite.

Sie können im Menü Datei im Untermenü Senden an mit Hilfe des Befehls Mailempfänger (als Anlage) eine Seite auch als Text einer E-Mail-Nachricht senden.

Um ein Datenbankobjekt per E-Mail zu senden, benötigen Sie Microsoft Outlook, Microsoft Exchange, Microsoft Mail oder ein anderes Programm zur Handhabung elektronischer Post, das die MAPI-Schnittstelle (Messaging Application Programming Interface) unterstützt.

Zurück zum Anfang

Exportieren von Daten oder Datenbankobjekten zur Übernahme in eine Webseite

Es gibt drei Arten, unter Verwendung von Microsoft Access-Daten oder -Datenbankobjekten eine Webseite zu erstellen:

  • In einem Webbrowser mit Unterstützung für Dynamic HTML Version 4.0 oder später können Sie Datenzugriffsseiten verwenden. Sie geben keine Datenzugriffsseiten aus, sondern Sie erstellen eine Datenzugriffsseite als ein Datenbankobjekt, das eine Verknüpfung mit der Adresse der zur Datenzugriffsseite gehörigen HTML-Datei enthält. Mit Hilfe von Datenzugriffsseiten lassen sich aktuelle Daten aus Microsoft Access-Datenbanken oder Microsoft SQL Server-Datenbanken anzeigen, bearbeiten, aktualisieren, löschen, filtern, gruppieren und sortieren. der folgende Hyperlink führt zu weiteren Informationen über das Erstellen einer Datenzugriffsseite.

  • Sie können serverseitig generierte HTML-Dateien (entweder ASP- oder IDC/HTX-Dateien) aus Tabellen, Abfragen und Formularen erstellen. Serverseitig generierte HTML-Dateien werden in einem Webbrowser in Tabellenform dargestellt. Verwenden Sie serverseitig generierte HTML-Dateien, wenn Sie beliebige Webbrowser einsetzen möchten und sich Ihre Daten häufig ändern, wenn Sie zusätzlich die Anzeige aktueller Daten in Tabellenform benötigen, die über eine ODBC-Datenquelle verknüpft sind, und wenn außerdem kein Ändern der Daten möglich sein muss.

  • Sie können HTML-Ausgabedateien aus Tabellen, Abfragen, Formularen und Berichten erstellen. Webbrowser stellen Berichte in einer speziellen Berichtsform dar, während Tabellen, Abfragen sowie Formulare in Form eines Datenblatts angezeigt werden. Verwenden Sie statische HTML-Dateien, wenn Sie beliebige Webbrowser mit Unterstützung für HTML Version 3.2 oder später verwenden möchten und wenn Ihre Daten nur selten geändert werden.

Zurück zum Anfang

Exportieren bzw. Austauschen von Daten zur Verwendung mit Microsoft Word

Es gibt vier verschiedene Arten, Microsoft Access-Daten in Vebindung mit Microsoft Word zu verwenden:

  • Innnerhalb einer Access-Datenbank können Sie den Microsoft Word-Seriendruck-Assistenten verwenden, um ein Seriendruckdokument in Microsoft Word 2000 zu erstellen, das eine Verknüpfung mit Microsoft Access 2000-Daten enthält. Zu diesem Zweck benutzen Sie den Befehl Seriendruck mit MS Word im Untermenü Office-Verknüpfungen des Menüs Extras. Nach Erstellung der Verknüpfung können Sie das Dokument jederzeit in Microsoft Word öffnen, um unter Verwendung der aktuellen Microsoft Access-Daten eine neue Serie von Formularbriefen oder Etiketten zu drucken.

  • Sie können Microsoft Access-Daten in eine als Datenquelle für den Seriendruck fungierende Datei exportieren, die dann in Kombination mit der Seriendruckfunktion von Word verwendet werden kann, wobei beliebige Microsoft Word-Versionen unterstützt werden.

  • Sie können die Ausgabe eines Datenblatts, Formulars oder Berichts in Form einer Rich Text Format (.rtf)-Datei speichern. Eine RTF-Datei übernimmt die Formatierungen (beispielsweise Schriftarten und -stile) und lässt sich mit Microsoft Word sowie anderen Windows-Textverarbeitungsprogrammen bzw. -DTP-Programmen öffnen.

  • Sie können die Ausgabe eines Datenblatts, Formulars oder Berichts in Form einer RTF-Datei speichern und diese Datei automatisch in Microsoft Word laden. Sie verwenden dazu im Menü Extras im Umtermenü Office-Verknüpfungen den Befehl Mit MS Word veröffentlichen .

Zurück zum Anfang

Exportieren von Daten zur Verwendung mit Microsoft Excel oder einem anderen Tabellenkalkulationsprogramm

Es gitb drei verschiedene Arten, Microsoft Access-Daten in Kombination mit Microsoft Excel oder einem anderen Tabellenkalkulationsprogramm zu verwenden:

  • Sie können den Datenblattinhalt als unformatierte Daten exportieren, die dann von Microsoft Excel oder einem anderen Tabellenkalkulationsprogramm weiterverarbeitet werden.

  • Sie können den Inhalt eines Datenblatts, Formulars oder Berichts direkt in Form einer Excel (.xls)-Datei oder -Arbeitsmappe speichern .

  • Sie können den Inhalt eines Datenblatts, Formulars oder Berichts in Form einer Excel (.xls)-Datei speichern und diese Datei automatisch in Microsoft Excel laden. Sie verwenden dazu im Menü Extras im Untermenü Office-Verknüpfungen den Befehl Analysieren mit MS Excel.

Was die beiden letzten Möglichkeiten anbelangt, so werden die meisten Formatierungen übernommen, unter anderem Schriftarten und Farbgebungen. Gruppierungsebenen in Berichten werden als Microsoft Excel-Gliederungsebenen gespeichert, während ein Formular in Form einer Datentabelle gespeichert wird.

Zurück zum Anfang

Automatisieren von Exportoperationen

Um häufig vorkommende Exportvorgänge bequemer durchzuführen, können Sie diese durch Erstellen von Makros oder Erstellen von VBA-Funktionen automatisieren.

Zurück zum Anfang


 Importieren und Verknüpfen von Daten und Importieren von Datenbankobjekten

Importieren und Verknüpfen von Daten und Importieren von Datenbankobjekten

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Unterschied zwischen Importieren und Verknüpfen

Importieren von Daten

Verknüpfen mit Daten

Verfahren zum Importieren und Verknüpfen von Daten

Verwenden von ODBC-Datenquellen

Nicht unterstützte Programme

Automatisieren von Importoperationen

Unterschied zwischen Importieren und Verknüpfen

Microsoft Access stellt zwei Möglichkeiten zur Verfügung, Daten externer Herkunft zu verwenden:

  • Importieren der Daten in eine neue Microsoft Access-Tabelle. Auf diese Weise lassen sich Daten, die in einem anderen Format vorliegen, konvertieren und in eine Microsoft Access-Datenbank übernehmen. Auch Datenbankobjekte können in die aktuelle Microsoft Access-Datenbank oder in das aktuelle Microsoft Access-Projekt importiert werden.

  • Verknüpfen der Daten. Es handelt sich um ein Verfahren, bei dem eine Verbindung mit Daten einer anderen Anwendung eingerichtet wird, ohne die Daten zu importieren, so dass diese sowohl in der ursprünglichen Anwendung als auch in der Access-Datenbank angezeigt und bearbeitet werden können. (In vorhergehenden Versionen von Microsoft Access wurde dieser Vorgang als Anbinden - attaching - bezeichnet.)

Das Importieren und Verknüpfen von Daten wird für eine Vielzahl von Datenbanken, Programmen und Dateiformaten unterstützt.

Zurück zum Anfang

Importieren von Daten

Beim Datenimport wird eine Kopie des Dateninhalts in Form einer neuen Tabelle in der Access-Datenbank bzw. im Access-Projekt erstellt. Die Originaltabelle- oder -datei wird bei diesem Vorgang nicht verändert.

Durch das Importieren von Daten können keine Daten an vorhandene Tabellen angehängt werden (außer Sie importieren Arbeitsmappen- oder Textdateien). Allerdings haben Sie in einer Access-Datenbank die Möglichkeit, nach dem Import einer Tabelle eine Anfügeabfrage auszuführen. Innerhalb eines Access-Projekts können Sie eine Gespeicherte Prozedur verwenden, um die importierten Tabellendaten einer anderen Tabelle anzuhängen.

Sie können außer Tabellen auch andere Datenbankobjekte, wie z. B. Formulare oder Berichte, aus einer anderen Access-Datenbank oder einem Microsoft Access-Projekt importieren.

Zurück zum Anfang

Verknüpfen von Daten

Das Verknüpfen von Daten innerhalb einer Access-Datenbank ermöglicht es Ihnen, diese Daten aus der externen Quelle zu lesen und (in den meisten Fällen) zu aktualisieren, ohne sie dabei zu importieren. Das Datenformat der externen Datenquelle bleibt unverändert, so dass Sie die Datei weiterhin mit dem Programm verwenden können, mit dem sie ursprünglich erstellt worden ist. Aber zusätzlich können Sie nun den Inhalt der Datei unter Verwendung von Microsoft Access ergänzen, löschen oder bearbeiten. Eine Tabelle kann nur in einer Access-Datenbank, aber nicht in einem Access-Projekt mit externen Daten verknüpft werden.

Microsoft Access verwendet unterschiedliche Symbole zur Darstellung von verknüpften Tabellen und von Tabellen, die in der aktuellen Datenbank gespeichert sind. Wenn Sie das Symbol für eine verknüpfte Tabelle löschen, wird dadurch nur die Verknüpfung gelöscht, nicht die externe Tabelle.

Symbole zur Darstellung verknüpfter Tabellen im Datenbankfenster

Zurück zum Anfang

Verfahren zum Importieren und Verknüpfen von Daten

Daten lassen sich auf zwei Arten importieren oder verknüpfen:

  • Sie öffnen oder erstellen eine neue Access-Datenbank, oder Sie erstellen ein neues Access-Projekt, welches die importierten Tabellen bzw. (im Falle einer Access-Datenbank) die verknüpften Tabellen enthalten soll. Anschließend verwenden Sie die Befehle Importieren oder Tabellen verknüpfen im Untermenü Externe Daten des Menüs Datei.

  • Die zweite Möglichkeit besteht darin, dass Sie innerhalb einer Access-Datenbank direkt die externe Datenbank öffnen. Zu den derart unterstützten Formaten gehören dBASE, Paradox, Exchange und beliebige ODBC-Datenquellen (einschließlich Microsoft SQL Server und Microsoft Visual FoxPro). Microsoft Access erstellt dann automatisch eine neue Access-Datenbank in demselben Ordner, in dem sich die externe Datenbank befindet, und fügt dann Verknüpfungen mit jeder Tabelle in der externen Datenbank hinzu.

Zurück zum Anfang

Verwenden von ODBC-Datenquellen

Sie können Daten aus ODBC-Datenbanken, wie z. B. Microsoft SQL-Server, Visual FoxPro und aus anderen Programmen, die Treiber entsprechend der ODBC-Ebene 1 für den Zugriff auf ihre Datendateien zur Verfügung stellen, importieren oder verknüpfen.

Zurück zum Anfang

Nicht unterstützte Programme

Wenn die Daten Ihres Programms nicht in einem der unterstützten externen Datenbank- oder Dateiformate vorliegen, das Programm aber in der Lage ist, seine Daten in eines dieser Formate zu exportieren, zu konvertieren oder zu speichern, dann können Sie diese Daten importieren. Außerdem übernimmt Access beim Importieren oder Verknüpfen einer externen Datenbank (beispielsweise einer dBASE- oder Paradox-Datei) die Indexinformationen der Datenbank. Es ist z. B. nicht möglich, eine Microsoft Works-Datenbank direkt zu importieren oder zu verknüpfen, aber Sie können die Daten aus Microsoft Works exportieren und als dBASE IV (.dbf)-Datenbankdateien speichern und anschließend diese Daten in Microsoft Access importieren, um Feldnamen und Indizes zu erhalten.

In der Regel sind die meisten Programme, für die keine direkte Importunterstützung besteht, - auch diejenigen, die unter anderen Betriebssystemen verwendet werden -, in der Lage, Daten in eine Textdatei fester Zeilenlänge zu exportieren, die Sie dann in Microsoft Access importieren oder verknüpfen können, obwohl in diesem Falle die Indexinformationen nicht erhalten bleiben.

Zurück zum Anfang

Automatisieren von Importoperationen

Um häufig vorkommende Importvorgänge bequemer durchzuführen, können Sie diese durch Erstellen von Makros oder Erstellen von VBA-Prozeduren automatisieren.

Zurück zum Anfang


 Importieren oder Verknüpfen von Tabellen

Importieren oder Verknüpfen von Tabellen

Anmerkung Das Verknüpfen einer Tabelle kann nur in einer Microsoft Access-Datenbank und nicht in einem Microsoft Access-Projekt erfolgen.

Gründe für das Importieren von Daten in eine Tabelle

Wenn Sie beabsichtigen, Ihre Daten ausschließlich in Microsoft Access zu verwenden, sollten Sie sie importieren. Microsoft Access arbeitet im Allgemeinen schneller mit eigenen Tabellen, und wenn Sie möchten, können Sie die importierte Tabelle so wie jede andere in Microsoft Access erstellte Tabelle bearbeiten, um sie an Ihre Wünsche anzupassen.

Gründe für das Verknüpfen mit Daten aus einer externen Tabelle

Wenn die Daten, die Sie in Ihrer Access-Datenbank verwenden möchten, außer von Microsoft Access auch noch von einem anderen Programm aktualisiert werden, sollten Sie sie verknüpfen. Mit diesem Verfahren kann das Aktualisieren, Verwalten und gemeinsame Nutzen von Daten jeweils direkt durchgeführt werden, und Sie können dennoch unter Verwendung von Microsoft Access mit den Daten arbeiten. So können Sie z.B. Abfragen, Formulare und Berichte erstellen, welche die externen Daten verwenden, die externen Daten mit den Daten in Microsoft Access-Tabellen kombinieren und die externen Daten ansehen und bearbeiten, während andere Benutzer im Originalprogramm damit arbeiten.

Sie können auch Tabellen aus anderen Microsoft Access-Datenbanken verknüpfen. Es kann z.B. vorkommen, dass Sie eine Tabelle aus einer anderen Microsoft Access-Datenbank, die über das Netzwerk gemeinsam genutzt wird, verwenden möchten. Dies ist insbesondere dann nützlich, wenn Sie alle Ihre Tabellen in einer Datenbank auf einem Netzwerk-Server speichern möchten, während Sie Ihre Formulare, Berichte und anderen Objekte in separaten Datenbanken aufbewahren, die Sie den anderen Benutzern der gemeinsam genutzten Datenbank als Kopie liefern. Sie können eine bestehende Datenbank mit dem Unterbefehl Datenbankaufteilung des Befehls Datenbank-Dienstprogramme im Menü Extras problemlos in zwei Datenbanken teilen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Datenformate, die Microsoft Access exportieren kann

Datenformate, die Microsoft Access exportieren kann

Anwendung | Unterstützte Version oder unterstütztes Format
Microsoft Access-Datenbank | 2.0, 7.0/95, 8.0/97 und 9.0/2000
Microsoft Access-Projekt | 2000
dBASE | III, III+, IV und 5 7 (Erfordert Borland Database Engine 4.x oder höher)
Paradox, Paradox für Windows | 3.x, 4.x und 5.0 8.0 (Erfordert Borland Database Engine 4.x oder höher)
Microsoft Excel | 3.0, 4.0, 5.0, 7.0/95, 8.0/97 und 9.0/2000
Microsoft Word, Rich Text Format |
Lotus 1-2-3 | .wk1 und .wk3-Formate
Textdateien mit Trennzeichen | Alle Zeichensätze
Textdateien mit fester Breite | Alle Zeichensätze
HTML und IDC/HTX | 1.0 (bei Listen) 2.0, 3.x, 4.x (bei Tabellen oder Listen)
Microsoft Active Server Pages |
SQL-Tabellen, Microsoft Visual FoxPro sowie Programme und Datenbanken, die das ODBC-Protokoll unterstützen | Visual FoxPro 3.0, 5.0 und 6.x Eine aktuelle Liste der unterstützten ODBC-Treiber finden Sie in der Microsoft Knowledge Base.


 Datenquellen, die Microsoft Access importieren oder verknüpfen kann

Datenquellen, die Microsoft Access importieren oder verknüpfen kann

Anmerkung Die Verknüpfung einer Tabelle kann nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt erfolgen.

Datenquelle | Unterstützte Version oder unterstütztes Format
Microsoft Access-Datenbank | 2.0, 7.0/95, 8.0/97, 9.0/2000
Microsoft Access-Projekt | 9.0/2000
dBASE | III, III+, IV und 5 7 (Verknüpfungen (Lesen/Schreiben) erfordern Borland Database Engine 4.x oder höher )
Paradox, Paradox für Windows | 3.x, 4.x und 5.0 8.0 (Verknüpfungen (Lesen/Schreiben) erfordern Borland Database Engine 4.x oder höher )
Microsoft Excel-Kalkulationstabellen | 3.0, 4.0, 5.0, 7.0/95, 8.0/97 und 9.0/2000
Lotus 1-2-3-Kalkulationstabellen (Verknüpfungen sind schreibgeschützt) | .wks, .wk1, .wk3 und .wk4
Microsoft Exchange | Alle Versionen
Textdateien mit Trennzeichen | Alle Zeichensätze
Textdateien mit fester Breite | Alle Zeichensätze
HTML | 1.0 (bei Listen) 2.0, 3.x (bei Tabellen oder Listen)
SQL-Tabellen, Microsoft Visual FoxPro sowie Daten aus anderen Programmen und Datenbanken, die das ODBC-Protokoll unterstützen | Visual FoxPro 2.x, 3.0, 5.0 und 6.x (nur zum Importieren) Eine aktuelle Liste der unterstützten ODBC-Treiber finden Sie in der Microsoft Knowledge Base.


 Info über ODBC-Datenquellen

Info über ODBC-Datenquellen

Das vorliegende Thema bietet Informationen zu folgenden Punkten:

Was ist eine Datenquelle?

Maschinendatenquellen

Dateidatenquellen

Verbindungszeichenfolgen

Was ist eine Datenquelle?

Eine Datenquelle besteht aus einer Quelle von Daten und den für den Zugriff auf diese Daten erforderlichen Verbindungsinformationen. Beispiele für Datenquellen sind Microsoft Access, Microsoft SQL Server, Oracle RDBMS, eine Kalkulationstabelle und eine Textdatei. Beispiele für Verbindungsinformationen sind Serverposition, Datenbankname, Anmelde-ID, Kennwort und verschiedene ODBC-Treiber-Optionen, die beschreiben, wie eine Verbindung zur Datenquelle hergestellt wird.

In der ODBC-Architektur stellt eine Anwendung (z. B. Access oder ein Microsoft Visual Basic-Programm) eine Verbindung zum ODBC-Teibermanager her, der dann einen bestimmten ODBC-Treiber (z. B. den ODBC-Treiber für Microsoft SQL) verwendet, um eine Verbindung zur Datenquelle (in diesem Fall eine SQL Server-Datenbank) herzustellen. In Access verwenden Sie ODBC-Datenquellen zum Herstellen einer Verbindung zu Daten außerhalb von Access, für die keine integrierten Treiber zur Verfügung stehen.

Zum Herstellen einer Verbindung zu diesen Datenquellen gehen Sie folgendermaßen vor:

  • Installieren Sie den entsprechenden ODBC-Treiber auf dem Computer, auf dem sich die Datenquelle befindet.

  • Definieren Sie einen Datenquellennamen (DSN, Data Source Name). Dazu verwenden Sie entweder den ODBC-Datenquellen-Administrator, um die Verbindungsinformationen in der Windows-Registrierung oder einer DSN-Datei zu speichern oder eine Verbindungszeichenfolge in Visual Basic-Code, um die Verbindungsinformationen direkt an den ODBC-Teibermanager zu übergeben.

Zurück zum Anfang

Maschinendatenquellen

Maschinendatenquellen speichern Verbindungsinformationen in der Windows-Registrierung auf einem bestimmten Computer mit einem benutzerdefinierten Namen. Sie können Maschinendatenquellen nur auf dem Computer verwenden, auf dem sie definiert sind. Es gibt zwei Arten von Maschinendatenquellen: Benutzer und System. Benutzerdatenquellen können nur vom aktuellen Benutzer verwendet werden und sind auch nur für diesen sichtbar. Systemdatenquellen können von allen Benutzern auf dem Computer und systemweiten Diensten, wie z. B. Microsoft Windows NT-Diensten, verwendet werden. Eine Maschinendatenquelle eignet sich besonders, wenn Sie zusätzlichen Schutz bieten möchten, da nur Benutzer, die angemeldet sind, eine Maschinendatenquelle sehen können, und da eine Maschinendatenquelle nicht von einem Remote-Benutzer auf einen anderen Computer kopiert werden kann.

Zurück zum Anfang

Dateidatenquellen

Dateidatenquellen (auch als DSN-Dateien bezeichnet) speichern Verbindungsinformationen in einer Textdatei (nicht in der Windows-Registrierung) und sind in der Regel flexibler als Maschinendatenquellen. Sie können Dateidatenquellen z. B. mit dem korrekten ODBC-Treiber auf einen beliebigen Computer kopieren, so dass Ihre Anwendung sich darauf verlassen kann, dass alle Computer, auf denen sie ausgeführt wird, konsistente und akkurate Verbindungsinformationen verwenden. Sie können die Dateidatenquelle auch auf einem einzelnen Server ablegen und mehreren Computern im Netzwerk gleichzeitig zur Verfügung stellen. Auf diese Weise werden die Verbindungsinformationen problemlos an nur einem Ort verwaltet.

Sie können für eine Dateidatenquelle auch festlegen, dass sie nicht gemeinsam genutzt werden soll. Eine Dateidatenquelle, die nicht gemeinsam genutzt werden darf, befindet sich auf einem Computer und zeigt auf eine Maschinendatenquelle. Mit Hilfe von Dateidatenquellen, die nicht gemeinsam genutzt werden dürfen, können Sie von der Dateidatenquelle aus auf vorhandene Maschinendatenquellen zugreifen.

Zurück zum Anfang

Verbindungszeichenfolgen

Als Programmierer können Sie in Ihrem Visual Basic-Code eine formatierte Verbindungszeichenfolge definieren, die die Verbindungsinformationen festlegt. Das Verwenden einer Verbindungszeichenfolge macht das Definieren einer Maschinen- oder Dateidatenquelle überflüssig und übergibt die Verbindungsinformationen direkt an den ODBC-Treibermanager. Dies ist z. B. nützlich, wenn Sie vermeiden möchten, dass Systemadministratoren oder Benutzer zuerst einen DSN erstellen müssen, oder wenn Sie die Installation Ihrer Anwendung vereinfachen möchten.

Weitere Informationen zum Programmieren von ODBC finden Sie im ODBC 3.0 Referenzhandbuch für Programmierer.

Zurück zum Anfang

Weitere Informationen

Einrichten von ODBC-Datenquellen

Zurück zum Anfang


 Unterschiede zwischen ODBC-Treibern und eingebauten Treibern für externe Daten

Unterschiede zwischen ODBC-Treibern und eingebauten Treibern für externe Daten

Microsoft Access ermöglicht das Importieren, Exportieren oder Verknüpfen vieler anderer Datenbank-, Tabellenkalkulations- oder Textdateiformate. Dazu verwendet Access entweder einen eingebauten Treiber oder einen ODBC-Treiber. Dieses Thema enthält Referenzinformationen über:

Eingebaute Treiber

ODBC-Treiber

Eingebaute Treiber

Access enthält eingebaute Treiber, die Ihnen das Importieren, Exportieren oder Verknüpfen folgender Datentypen ermöglichen: Andere Microsoft Access-Datenbanken, Microsoft Access-Projekte, Paradox, dBASE, Microsoft Excel, Lotus 1-2-3 Tabellenblätter, Microsoft Exchange, Microsoft Outlook, Textdateien mit festgelegtem Format, Textdateien mit Trennzeichen und HTML.

Weitere Informationen zu Datenquellen, die importiert oder mit denen Verknüpfungen hergestellt werden können.

Weitere Informationen zu Datenformaten, die exportiert werden können.

Die eingebauten Treiber sind verfügbar, wenn Sie die Befehle Exportieren aus dem Menü Datei sowie Importieren und Tabellen verknüpfen aus dem Untermenü Externe Daten des Menüs Datei verwenden. Wenn ein eingebauter Treiber für einen bestimmten Datentypen installiert wurde, steht dieses Datenformat im Feld Dateityp im Dialogfeld Exportieren von Objektname nach... oder im Feld Dateityp in den Dialogfeldern Importieren oder Verknüpfen zur Verfügung. Alle eingebauten Treiber werden automatisch installiert, wenn Sie Access installieren.

Zurück zum Anfang

ODBC-Treiber

Sie können ODBC-Treiber verwenden, um Verbindungen zu Microsoft SQL Server-Datenbanken, Microsoft FoxPro-Datenbanken und Daten aus anderen Programmen herzustellen, die 32-Bit-Treiber gemäß ODBC Level 1 für den Zugriff auf deren Datendateien verwenden. Microsoft Access installiert den Microsoft SQL-Server ODBC-Treiber (Sqlsrv32.dll), den FoxPro ODBC-Treiber (vfpodbc.dll), den Oracle ODBC-Treiber (msorcl32.dll) und einige ODBC-Unterstützungsdateien (Hilfedateien und das Symbol ODBC (32Bit) in der Systemsteuerung) automatisch. Die Option ODBC-Datenbanken ist im Feld Dateityp im Dialogfeld Exportieren von Objektname nach... und im Feld Dateityp in den Dialogfeldern Importieren oder Verknüpfen verfügbar. Außerdem wird das Symbol ODBC (32Bit) in der Systemsteuerung angezeigt.

Drittanbieter vertreiben möglicherweise zusätzliche ODBC-Treiber und Dokumentationen zur Unterstützung anderer Datenformate. Weitere Informationen dazu, ob ein ODBC-Treiber für ein bestimmtes Datenformat verfügbar ist, erhalten Sie von dem Anbieter des Programms, das das jeweilige Datenformat verwendet. Access unterstützt 32-Bit ODBC-Treiber gemäß ODBC Level 1.

Andere Microsoft-Produkte und Produkte anderer Anbieter könne ebenfalls ODBC-Treiber enthalten, darunter auch Treiber für die Anwendungen, die weiter oben im Abschnitt über die eingebauten Treiber aufgeführt sind. Diese ODBC-Treiber sind möglicherweise auf Ihrem Computer installiert. Microsoft empfiehlt jedoch, einen zugehörigen eingebauten Treiber zu verwenden, falls vorhanden. Wenn Sie wissen möchten, ob die ODBC-Treiber für die Verwendung mit Access getestet und überprüft worden sind, wenden Sie sich an den Händler, bei dem Sie den jeweiligen Treiber erworben haben.

Weitere Aktualisierunginformationen zu ODBC-Treibern finden Sie in der Microsoft Access Knowledge Base.

Weitere Informationen über den Zugriff auf technische Ressourcen von Microsoft.

Zurück zum Anfang


 Import-/Exportspezifikationen und Schema.ini-Dateien

Import-/Exportspezifikationen und Schema.ini-Dateien

Eine Import-/Exportspezifikation enthält Informationen (beispielsweise über Dateiformat, Datumsformat oder Zahlenformate), die Microsoft Access beim Importieren oder Exportieren einer Textdatei mit fester Zeilenlänge oder einer Textdatei mit Trennzeichen verwendet. Eine Import-/Exportspezifikation wird unter dem Standardnamen Dateiname_ImportSpec oder Datei_ExportSpec in der Datenbank gespeichert, in die Sie importieren bzw. aus der Sie exportieren.

Sie können eine Import-/Exportspezifikation mit Hilfe des Textimport-Assistenten oder des Textexport-Assistenten erstellen. Klicken Sie bei beiden Assistenten auf der ersten Bildschirmseite auf Weitere, definieren Sie die Spezifikation, und klicken Sie dann auf Speichern unter. Klicken Sie auf die Schaltfläche Spezifikationen, wenn Sie beim nächsten Aufruf des Assistenten die Spezifikation auswählen möchten.

Verwenden Sie eine Import-/Exportspezifikation, wenn Sie wiederholt in dieselbe Tabelle importieren bzw. in dieselbe Datei exportieren möchten, oder wenn Sie den Import- oder Exportvorgang automatisieren möchten.

Eine andere Möglichkeit besteht in der Verwendung einer Schema.ini-Datei, die Sie mit einem Visual Basic-Programm interpretieren können, um auf diese Weise noch weitergehende Kontrolle über den Dateninhalt in den Textdateien zu erhalten, beispielsweise durch Festlegen spezieller Formate für Währungsangaben oder die Handhabung von Gleitkommadatentypen. Eine Schema.ini-Datei ist eine Textdatei mit Einträgen, die bestimmte Standardeinstellungen zum Lesen und Schreiben von Textdateien in der Windows-Registrierung überschreiben. Die Schema.ini-Datei wird in demselben Ordner wie die importierte bzw. exportierte Textdatei gespeichert, und sie muss immer den Namen "Schema.ini" tragen.


 Optimieren der Leistung beim Arbeiten mit verknüpften Tabellen in einer Microsoft Access-Datenbank

Optimieren der Leistung beim Arbeiten mit verknüpften Tabellen in einer Microsoft Access-Datenbank

Anmerkung Die Verknüpfung einer Tabelle kann nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt erfolgen.

Obwohl Sie mit verknüpften Tabellen so arbeiten können, als seien es gewöhnliche Microsoft Access-Tabellen, ist es wichtig, sich bewußt zu machen, dass die Tabellen sich nicht wirklich in Ihrer Microsoft Access-Datenbank befinden. Immer wenn Sie sich Daten in einer verknüpften Tabelle ansehen, muss Microsoft Access Datensätze aus einer anderen Datei abrufen. Das ist zeitaufwendig, insbesondere dann, wenn sich die verknüpfte Tabelle auf einem Netzwerk oder in einer SQL-Datenbank befindet.

Wenn Sie mit einer verknüpften Tabelle arbeiten, die sich auf einem Netzwerk oder in einer SQL-Datenbank befindet, halten Sie sich an folgende Richtlinien, um optimale Ergebnisse zu erzielen:

  • Sie können die Leistung beim Öffnen der Hauptdatenbank und der Tabellen und Formulare deutlich verbessern, wenn Sie festlegen, dass die verknüpfte Datenbank geöffnet bleiben soll. Dazu erstellen Sie in der verknüpften Datenbank eine leere Tabelle und verknüpfen diese in der Hauptdatenbank. Verwenden Sie dann die Methode OpenRecordset, um die verknüpfte Tabelle zu öffnen. Auf diese Weise wird verhindert, dass die Microsoft Jet-Datenbank-Engine die verknüpfte Tabelle wiederholt öffnet und schließt und jedesmal die zugeordnete .LDB-Datei erstellt und löscht.

  • Zeigen Sie nur die Daten an, die Sie benötigen. Blättern Sie im Datenblatt nicht unnötig vor und zurück. Vermeiden Sie, in einer umfangreichen Tabelle zum letzten Datensatz zu springen. Wenn Sie Datensätze in eine große Tabelle einfügen möchten, klicken Sie im Menü Datensätze auf Daten eingeben, um das Laden vorhandener Datensätze in den Arbeitsspeicher zu verhindern.

  • Verwenden Sie Filter oder Abfragen, um die Anzahl der Datensätze, die im Formular oder Datenblatt angezeigt werden, einzuschränken. Dadurch braucht Microsoft Access nicht so viele Daten über das Netzwerk zu übertragen.

  • Verwenden Sie nach Möglichkeit in Abfragen, die sich auf verknüpfte Tabellen beziehen, keine Funktionen in den Abfragekriterien. Vermeiden Sie insbesondere die Verwendung von Aggregatfunktionen für Domänen, z.B. Dsum, in Ihren Abfragen. Beim Verwenden dieser Funktionen ruft Microsoft Access alle Daten der verknüpften Tabelle ab, um die Abfrage auszuführen.

  • Wenn Sie einer verknüpften Tabelle häufig Datensätze hinzufügen, erstellen Sie hierfür ein Formular, bei dem für die Eigenschaft Daten eingeben die Einstellung Ja festgelegt wurde. Beim Öffnen des Formulars zur Dateneingabe zeigt Microsoft Access keine vorhandenen Datensätze an. Mit dieser Eigenschafteneinstellung sparen Sie Zeit, da Microsoft Access keine Datensätze aus der verknüpften Tabelle abrufen muss.

  • Denken Sie daran, dass andere Benutzer möglicherweise versuchen, zur gleichen Zeit mit einer externen Tabelle zu arbeiten wie Sie. Befindet sich die entsprechende Microsoft Access-Datenbank auf einem Netzwerk, sollten Sie die Datensätze nicht länger als unbedingt notwendig sperren.


 Automatisieren des Importierens, Exportierens und Verknüpfens von Daten

Automatisieren des Importierens, Exportierens und Verknüpfens von Daten

Abhängig von dem Datentyp, mit dem Sie arbeiten, können Sie das Importieren, Exportieren und Verknüpfen von Daten automatisieren, indem Sie in einem Makro oder einer Visual Basic-Prozedur eine der Aktionen TransferDatenbank, TransferArbeitsblatt oder TransferText ausführen.

Was möchten Sie tun?

Das Importieren, Exportieren oder Verknüpfen von Daten unter Verwendung eines Makros automatisieren

Das Importieren, Exportieren oder Verknüpfen von Daten unter Verwendung von Visual Basic für Applikationen automatisieren


 Umbenennen und Einstellen von Eigenschaften für verknüpfte Tabellen in einer Microsoft Access-Datenbank

Umbenennen und Einstellen von Eigenschaften für verknüpfte Tabellen in einer Microsoft Access-Datenbank

Anmerkung Das Verknüpfen einer Tabelle kann nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt erfolgen.

Einstellen von Eigenschaften für verknüpfte Tabellen

Wenn Sie eine verknüpfte Tabelle in der Entwurfsansicht öffnen, sieht diese fast wie eine normale Microsoft Access-Tabelle aus. Obwohl Sie die Definition der verknüpften Tabelle und ihrer Felder in der externen Datenbank nicht ändern können, können Sie doch bestimmte Eigenschaften einstellen, die angeben, wie die Felder in Microsoft Access angezeigt werden. Änderungen, die Sie an den Eigenschaften verknüpfter Tabellen vornehmen, haben nur Einfluss auf die Art und Weise, wie Microsoft Access die Daten der verknüpften Tabelle behandelt und anzeigt; es werden keine Änderungen an der Quelltabelle vorgenommen. In der folgenden Tabelle sind die Feldeigenschaften aufgeführt, die Sie für verknüpfte Tabellen einstellen können.

Eigenschaft | Auswirkung
Format | Gibt an, wie Daten in einem Feld angezeigt werden.
Dezimalstellenanzeige | Gibt die Anzahl der angezeigten Dezimalstellen an.
Eingabeformat | Erstellt ein Dateneingabeformat mit Trennzeichen und Leerzeichen zum Eingeben.
Beschriftung | Ändert die Bezeichnung der Spaltenüberschriften eines Feldes im Datenblatt und gibt beim Einfügen eines Feldes in ein Formular einen Standardnamen für ein Bezeichnungsfeld an.

Um Informationen zum Einstellen von Eigenschaften anzuzeigen, klicken Sie auf [image] .

Andere Feldeigenschaften können Sie für verknüpfte Tabellen nicht ändern. Um die Dateneingabe effizienter und zuverlässiger zu gestalten, können Sie jedoch Formulare erstellen, mit deren Hilfe Sie die Daten Ihrer verknüpften Tabellen bearbeiten oder neue Daten hinzufügen können. Darüber hinaus können Sie Eigenschaften für Steuerelemente festlegen, die an Felder Ihrer verknüpften Tabelle gebunden sind. So können Sie z.B. die Eigenschaften Standardwert (DefaultValue), Gültigkeitsregel (ValidationRule) oder Gültigkeitsmeldung (ValidationText) für Steuerelemente dieser Formulare einstellen.

Anmerkung Wenn Sie Tabellen aus einer anderen Microsoft Access-Datenbank verknüpfen, verwenden diese die Eigenschafteneinstellungen der Datenbank, in der Sie gespeichert sind. Wenn eine Tabelle z.B. Gültigkeitsregeln in der ursprünglichen Datenbank besitzt, müssen die Daten, die Sie in die verknüpfte Tabelle eingeben, ebenfalls diesen Regeln entsprechen. Wenn Sie diese Eigenschaften ändern möchten, müssen Sie die Tabelle in der Datenbank öffnen, in der sie gespeichert ist.

Umbenennen verknüpfter Tabellen

Es kann vorkommen, dass Sie verknüpfte Tabellen umbenennen möchten. Da die Microsoft Access-Tabellennamen Leerzeichen und bis zu 64 Zeichen enthalten können, möchten Sie einer Tabelle nach dem Verknüpfen unter Umständen einen aussagekräftigeren Namen geben. Wenn Sie z.B. eine dBASE-Tabelle mit dem Namen SLSDATA verknüpfen, können Sie die verknüpfte Tabelle in Verkaufsdaten 1995 (aus dBASE) umbenennen. Beachten Sie dabei, dass dadurch nicht die Tabelle selbst umbenannt wird, sondern nur der von Microsoft Access verwendete Name, mit dem auf die Verknüpfung dieser Tabelle Bezug genommen wird.

Verwenden Sie zum Umbenennen einer verknüpften Tabelle das gleiche Verfahren wie zum Umbenennen anderer Datenbankobjekte. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Exportieren von Datenbankobjekten in eine vorhandene Microsoft Access-Datenbank oder ein vorhandenes Microsoft Access-Projekt

Exportieren von Datenbankobjekten in eine vorhandene Microsoft Access-Datenbank oder ein vorhandenes Microsoft Access-Projekt

  1. Klicken Sie im Datenbankfenster auf den Namen des Objekts, das Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie auf den Pfeil des Listenfelds Speichern in, und wählen Sie das Laufwerk oder den Ordner der Microsoft Access-Datenbank aus, in die Sie exportieren möchten.

  3. Doppelklicken Sie auf das Symbol der Datenbank, aus der Sie exportieren möchten.

  4. Geben Sie im Dialogfeld Exportieren einen Namen für das neue Objekt ein (oder übernehmen Sie den aktuellen Namen). Wählen Sie beim Exportieren einer Tabelle im Feld Exporttabellen, ob Sie nur die Definition oder sowohl die Definition als auch die Daten der Tabelle exportieren möchten. Klicken Sie auf OK, um das Objekt zu exportieren.

Anmerkungen

  • Sie können Tabellen nur in frühere Versionen von Microsoft Access exportieren.

  • Wenn Sie eine Tabelle in eine Access-Datenbank exportieren, dann exportiert Microsoft Access nur die Tabellendaten und die Datendefinitionen, nicht jedoch die Eigenschaften (dazu gehören auch Einschränkungen, Beziehungen und Indizes).

  • Microsoft Access 2000 codiert Daten im Unicode-Format. Deshalb können Daten umgewandelt und verändert werden, wenn Sie eine Tabelle in eine frühere Version exportieren. Weitere Informationen zum Umwandeln von Datenbanken aufrufen.

  • Sie können Sichten, gespeicherte Prozeduren und Datenbankdiagramme nicht in ein Microsoft Access-Projekt oder in eine Access-Datenbank exportieren. Sie können keine Abfragen oder Beziehungen aus einer Access-Datenbank in ein Access-Projekt exportieren.

  • Sie können immer nur ein Objekt auf einmal exportieren. Wenn Sie mehrere Objekte gleichzeitig exportieren möchten, öffnen Sie die Datenbank, in die Sie die Objekte exportieren möchten und importieren diese. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
  • Wenn Sie ein Objekt in eine andere Datenbank exportieren, ist es möglicherweise sinnvoll, auch die damit in Beziehung stehenden Objekte zu exportieren. So kann zum Beispiel ein Bericht eine Abfrage als Datenquelle haben. Diese Abfrage kann wiederrum auf einer Beziehung zwischen zwei Tabellen basieren.

  • Wenn Sie eine Datenzugriffsseite exportieren, exportieren Sie nur die Verknüpfung zu der entsprechenden HTML-Datei. Die HTML-Datei bleibt an ihrem Speicherort. Das heißt, dass Sie über zwei Datenzugriffsseiten verfügen, die auf dieselbe HTML-Datei verweisen. Wenn Sie das nicht möchten, speichern Sie eine der Datenzugriffsseiten unter einem anderen Namen (verwenden Sie dazu im Menü Datei den Befehl Speichern unter), geben Sie im Dialogfeld Als Datenzugriffsseite speichern einen anderen Dateispeicherort für die neue HTML-Datei an und löschen Sie dann die Datenzugriffsseite, die Sie gerade gespeichert haben.


 Exportieren eines Datenblattes in eine Textdatei mit Trennzeichen oder mit festgelegtem Format

Exportieren eines Datenblattes in eine Textdatei mit Trennzeichen oder mit festgelegtem Format

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle, Abfrage, Sicht oder gespeicherten Prozedur, die Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Listenfeld Dateityp auf Textdateien (*.txt;*.csv;*.tab;*.asc).

  3. Klicken Sie auf den Pfeil des Listenfelds Speichern in, und wählen Sie dann das Laufwerk oder den Ordner aus, in welchen Sie exportieren möchten.

  4. Geben Sie im Feld Dateiname den Dateinamen ein, und klicken Sie dann auf Speichern.

    Microsoft Access startet den Textexport-Assistenten.

  5. Folgen Sie den Anweisungen in den Dialogfeldern. Klicken Sie auf Weitere, um eine Import-/Exportspezifikation zu erstellen oder zu verwenden.

Anmerkung Um die Schriftart und andere Formatierungselemente des Datenblattes, die in einer Textdatei nicht enthalten sind, miteinzubeziehen, können Sie das gesamte Datenblatt oder einen Datenblattbereich als .RTF-Datei (Rich Text Format) speichern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Exportieren eines Datenblattes in eine Kalkulationstabellendatei

Exportieren eines Datenblattes in eine Kalkulationstabellendatei

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle, Abfrage oder gespeicherten Prozedur, die Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Listenfeld Dateityp auf das gewünschte Kalkulationstabellenformat.

  3. Klicken Sie auf den Pfeil des Listenfelds Speichern in, und wählen Sie dann das Laufwerk oder den Ordner aus, in welchen Sie exportieren möchten.

  4. Doppelklicken Sie auf eine vorhandene Kalkulationstabelle, oder geben Sie im Feld Dateiname einen neuen Namen ein.

    Vorsicht Beim Exportieren in eine bestehende Kalkulationstabellendatei löscht Microsoft Access die Daten dieser Kalkulationstabelle und ersetzt sie durch die neuen Daten. Die einzige Ausnahme dafür tritt dann ein, wenn Sie in eine Microsoft Excel-Arbeitsmappe, Version 5.0 oder höher, exportieren. Die Daten werden hierbei in die nächste verfügbare Arbeitsmappe kopiert.

    Wenn Sie in Schritt 3 Microsoft Excel, Version 5.0 bis 7.0, oder Microsoft Excel 97-2000 (*.xls) gewählt haben, und wenn Sie die Schriftarten, die angezeigten Daten aus Nachschlagefeldern sowie die Feldbreite beibehalten möchten, aktivieren Sie das Kontrollkästchen Mit Formatierung. Das Speichern dauert allerdings dadurch länger.

  5. Klicken Sie auf Speichern.

    Microsoft Access erstellt die Kalkulationstabellendatei mit den Daten Ihres Datenblattes. Die Feldnamen des Datenblattes befinden sich in der ersten Zeile der Kalkulationstabelle.


 Exportieren einer Tabelle oder Abfrage in eine Datenquellendatei für Microsoft Word-Seriendruck

Exportieren einer Tabelle oder Abfrage in eine Datenquellendatei für Microsoft Word-Seriendruck

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle oder Abfrage (nur Microsoft Access-Datenbank), die Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Listenfeld Dateityp auf Microsoft Word Merge (*.txt).

  3. Klicken Sie auf den Pfeil des Listenfelds Speichern in, und wählen Sie das Laufwerk oder den Ordner aus, in welches/n Sie exportieren möchten.

  4. Geben Sie im Feld Dateiname den Dateinamen ein, und klicken Sie dann auf Speichern.

    Microsoft Access erstellt die Datenquelle, die dann die Feldnamen und all die Daten aus Ihrer Tabelle enthält.

Anmerkung In einer Datenquelle für Word-Seriendruck enthält der erste Datensatz der Datei die Feldnamen und wird als Steuersatz bezeichnet. Alle nachfolgenden Datensätze stellen die Datenzeilen dar. Die Feldnamen des Steuerdatensatzes müssen mit den Feldnamen des Hauptdokuments übereinstimmen. Ist dies nicht der Fall, passen Sie entweder die Feldnamen der Datenquelle (durch Öffnen der Datenquelle in Microsoft Word) oder diejenigen des Hauptdokuments an.


 Exportieren einer Tabelle oder Abfrage in eine Paradox- oder dBASE-Datei

Exportieren einer Tabelle oder Abfrage in eine Paradox- oder dBASE-Datei

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle oder Abfrage (nur Microsoft Access-Datenbank), die Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Listenfeld Dateityp auf das gewünschte Paradox- oder DBASE-Datenbankformat.

  3. Klicken Sie auf den Pfeil des Listenfelds Speichern in, und wählen Sie das Laufwerk oder den Ordner aus, in welches/n Sie exportieren möchten.

  4. Geben Sie im Feld Dateiname den gewünschten Dateinamen an, und klicken Sie auf Speichern.

Anmerkungen

  • Zum Exportieren in das Paradox 8.0- oder dBASE 7-Dateiformat muss die Borland Database Engine (BDE), Version 4.x oder höher, auf Ihrem Computer installiert sein. Wenn BDE, Version 4.x oder höher, nicht installiert ist, erhalten Sie diese durch die Installation von Paradox 8.0 oder Delphi. Wenn Sie über eine frühere Version von BDE verfügen, die nicht das Paradox 8.0-Dateiformat unterstützt, können Sie Ihre Engine über die World Wide Web-Site von Borland upgraden. Wenn BDE nicht auf Ihrem Computer installiert ist, haben Sie darüber hinaus die Möglichkeit, in die folgenden Dateiformate zu exportieren: Paradox 3.x, 4.x und 5.0 und dBASE III, IV und 5.

  • Wenn Sie eine Tabelle exportieren, deren Tabellen- oder Feldnamen in der Zieldatenbank nicht zulässig sind, passt Microsoft Access die Namen entsprechend an. Wenn Sie z.B. Daten in eine dBASE-Tabelle exportieren, werden alle Feldnamen mit mehr als 10 Zeichen abgeschnitten.


 Exportieren einer Tabelle oder Abfrage in eine SQL-Datenbanktabelle oder andere ODBC-Datenquelle

Exportieren einer Tabelle oder Abfrage in eine SQL-Datenbanktabelle oder andere ODBC-Datenquelle

Wichtig Sie können nur dann eine Tabelle oder Abfrage in eine SQL-Datenbank oder eine andere ODBC-Datenquelle exportieren, wenn Sie den richtigen Treiber installiert haben.

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle oder Abfrage (nur Microsoft Access-Datenbank), die Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Dialogfeld Exportieren von Objektname nach... im Feld Dateityp auf ODBC Databases ().

  3. Geben Sie im Dialogfeld Exportieren einen Namen für die Datei ein (oder verwenden Sie den vorgeschlagenen Namen), und klicken Sie dann auf OK.

    Daraufhin wird das Dialogfeld Datenquelle auswählen angezeigt, das die definierten Datenquellen für beliebige, auf Ihrem Computer installierte ODBC-Treiber auflistet. Klicken Sie entweder auf die Registerkarte Dateidatenquelle oder Computerdatenquelle, und doppelklicken Sie auf die ODBC-Datenquelle, in die Sie exportieren möchten. Um eine neue Datenquelle für einen der installierten Treiber zu definieren, klicken Sie auf Neu und folgen den Anleitungen im Dialogfeld Datenquelle erstellen und den im Anschluss daran angezeigten Dialogfeldern, bevor Sie fortfahren. Weitere Informationen zu Datenquellen aufrufen.

    Die einzelnen ODBC-Datenquellen haben unterschiedliche Anforderungen beim Zugriff auf ihre Daten. Bei den meisten Datenquellen ist z.B. die Eingabe eines Anmeldenamens und eines Kennworts erforderlich. Fragen Sie gegebenenfalls Ihre Systemadministration danach. Geben Sie die erforderlichen Informationen im Dialogfeld ein, und klicken Sie dann auf OK.

    Microsoft Access stellt eine Verbindung zur ODBC-Datenquelle her und erstellt die neue Tabelle.

Anmerkungen

  • Nachdem Sie eine Tabelle aus einer Microsoft Access-Datenbank in eine SQL-Datenbank exportiert haben, können Sie der Tabelle mit Hilfe einer SQL Pass-Through-Abfrage einen Index hinzufügen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
  • Wenn Sie von einem Microsoft Access-Projekt in eine Microsoft SQL Server-Datenbank exportieren, haben Sie die Möglichkeit, Data Transformation Services (DTS) einzusetzen. Dies kann eine flexiblere und schnellere Methode zum Exportieren und Transformieren von Daten darstellen. Weitere Informationen dazu finden Sie in der Microsoft SQL Server-Dokumentation.


 Laden der Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Excel

Laden der Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Excel

  1. Klicken Sie im Datenbankfenster auf den Namen des Datenblatts, Formulars oder Berichts, das/den Sie in Microsoft Excel speichern und laden möchten. Um nur einen bestimmten Bereich eines Datenblatts zu speichern, öffnen Sie das Datenblatt, und wählen Sie, bevor Sie fortfahren, den gewünschten Bereich aus.

  2. Zeigen Sie im Menü Extras auf Office-Verknüpfungen, und klicken Sie dann auf Analysieren mit MS Excel.

    Die Ausgabe wird als Microsoft Excel-Datei (.XLS) im Standarddatenbankordner gespeichert, in dem Microsoft Access installiert wurde. Microsoft Excel startet und öffnet diese dann automatisch.


 Laden der Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Word

Laden der Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Word

  1. Klicken Sie im Datenbankfenster auf den Namen des Datenblatts, Formulars oder Berichts, das/den Sie speichern und in Microsoft Word laden möchten. Um nur einen bestimmten Bereich eines Datenblatts zu speichern, öffnen Sie das Datenblatt, und wählen Sie, bevor Sie fortfahren, den gewünschten Bereich aus.

  2. Zeigen Sie im Menü Extras auf Office-Verknüpfungen, und klicken Sie auf Mit MS Word veröffentlichen.

Die Ausgabe wird als .RTF-Datei im Standarddatenbankordner gespeichert. Microsoft Word startet und öffnet sie dann automatisch.


 Speichern der Ausgabe eines Objekts als Microsoft Excel- oder .RTF-Datei

Speichern der Ausgabe eines Objekts als Microsoft Excel- oder .RTF-Datei

  1. Klicken Sie im Datenbankfenster auf den Namen des Objekts, das Sie speichern möchten. Um nur einen bestimmten Bereich eines Datenblatts zu speichern, öffnen Sie das Datenblatt, und wählen Sie, bevor Sie fortfahren, den gewünschten Bereich aus.

  2. Klicken Sie im Menü Datei auf Exportieren.

  3. Klicken Sie im Listenfeld Dateityp auf Microsoft Excel 5-7 (*.xls), Microsoft Excel 97-2000 (*.xls) oder Rich Text Format (*.rtf).

  4. Klicken Sie auf den Pfeil des Felds Speichern in, und wählen Sie das Laufwerk oder den Ordner aus, in dem Sie die Ausgabe speichern möchten.

  5. Geben Sie im Feld Dateiname den Namen für die Datei ein (oder verwenden Sie den vorgeschlagenen Namen).

  6. Wenn Sie die Datei im Format Microsoft Excel 5-7, Microsoft Excel 97 oder Microsoft Excel 2000 speichern, wählen Sie das Kontrollkästchen Mit Formatierung aus. Wenn Sie die Ausgabe im .RTF-Format speichern möchten, wird das Kontrollkästchen Mit Formatierung automatisch aktiviert.

  7. Klicken Sie auf Alles speichern, um das gesamte Datenblatt zu speichern oder auf Auswahl speichern, wenn Sie in Schritt 1 einen Bereich des Datenblatts gewählt haben.


 Zusammenführen von Daten aus einer Tabelle oder Abfrage mit Hilfe des Microsoft Word-Seriendruck-Assistenten

Zusammenführen von Daten aus einer Tabelle oder Abfrage mit Hilfe des Microsoft Word-Seriendruck-Assistenten

Anmerkung Sie können den Microsoft Word-Seriendruck-Assistenten nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verwenden.

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle oder Abfrage (nur in Access-Datenbanken), die Sie exportieren möchten und dann im Menü Extras auf Office-Verknüpfungen, und klicken Sie anschließend auf Seriendruck mit MS Word.

  2. Folgen Sie den Anweisungen des Microsoft Word Seriendruck-Assistenten.

  3. Klicken Sie im Microsoft Word-Fenster auf Seriendruckfeld einfügen, um die gewünschten Felder in das Dokument einzufügen.

Anmerkung Sie können den Vorgang des Zusammenführens von Daten in Serienbriefe auch ausgehend von Word für Windows durchführen. Weitere Informationen finden Sie in der Microsoft Word-Hilfe.


 Exportieren eines Datenblatts in servergeneriertes HTML-Format

Exportieren eines Datenblatts in servergeneriertes HTML-Format

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle, der Abfrage oder des Formulars, die/das Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Exportieren.
  2. Klicken Sie im Dialogfeld Dateityp je nachdem, welches servergenerierte HTML-Ausgabeformat Sie wünschen, auf Microsoft IIS 1-2 (*.htx;*.idc) oder auf Microsoft Active Server Pages (*.asp). Weitere Informationen zu servergenerierten HTML-Format aufrufen.

  3. Klicken Sie auf eine Verknüpfung auf der Symbolleiste für Speicherorte oder auf den Pfeil rechts vom Feld Speichern in, und wählen Sie das Laufwerk oder den Ordner aus, auf das/in den Sie exportieren möchten.

  4. Geben Sie im Feld Dateiname den Dateinamen ein.

  5. Klicken Sie auf Speichern.

  6. Geben Sie die entsprechenden Informationen in die Dialogfelder Microsoft Active Server Pages-Ausgabeoptionen oder HTX/IDC-Ausgabeoptionen ein:

    Geben Sie in das Feld HTML-Vorlage den Speicherort einer HTML-Vorlage ein. Weitere Informationen zu HTML-Vorlagendateien aufrufen.

    Geben Sie in das Feld Datenquellenname den Namen der ODBC-Datenquelle ein, zu dem eine Verbindung hergestellt wird, wenn die servergeneriertenn HTML-Dateien auf dem Webserver verarbeitet werden. Weitere Informationen zu ODBC-Datenquellen aufrufen.

    Geben Sie für eine Microsoft Access-Datenbank in die Felder Benutzername und Benutzerkennwort einen Benutzernamen und ein Kennwort für die Sicherheit auf Benutzerebene ein, um es den Benutzern zu ermöglichen, von der Webseite aus auf die Access-Datenbank zuzugreifen. Wenn Sie keinen Benutzernamen und kein Kennwort eingeben, lautet der Standardbenutzername Admin und es wird kein Kennwort verwendet. Weitere Informationen zur Sicherheit auf Benutzerebene aufrufen.

    Geben Sie für ein Microsoft Access-Projekt in die Felder Benutzername und Kennwort einen Datenbankbenutzernamen und ein Kennwort ein, um es den Benutzern zu ermöglichen, von der Webseite aus auf die Microsoft SQL Server-Datenbank zuzugreifen. Wenn Sie keinen Benutzernamen und kein Kennwort eingeben, lautet der Standardbenutzername Sa und es wird kein Kennwort verwendet. Weitere Informationen zur SQL Server-Datenbanksicherheit aufrufen.

Wenn Sie ein Datenblatt in das Ausgabeformat ASP oder IDC/HTX ausgegeben haben, ist es noch erforderlich, die Dateien zu veröffentlichen, um sie im World Wide Web zugänglich zu machen. Weitere Informationen zum Veröffentlichen von servergenerierten HTML-Dateien auf einem Webserver aufrufen.

Anmerkungen

  • Wenn das Datenblatt eine Parameterabfrage enthält, simuliert Microsoft das Dialogfeld Parameterwerte eingeben. Dazu wird eine zusätzliche HTML-Parameterseite erstellt, die ein Textfeld-Steuerelement für ein HTML-Formular zum Eingeben des Parameterwertes und eine Schaltfläche zum Ausführen der Abfrage enthält. Sie müssen die Parameterdatentypen explizit definieren, wenn Sie die Parameterabfrage erstellen. Sie müssen darüber hinaus diese HTML-Parameterseite vor dem Anzeigen der Datenblatt-HTML-Seite in Ihrer Web-Anwendung anzeigen. Während des Exportiervorgangs führt Microsoft Access die Abfrage aus und zeigt das Dialogfeld Parameterwerte eingeben an, Sie können jedoch nur auf OK klicken, eine Eingabe wird ignoriert.

  • Felder mit einem Hyperlink-Datentyp werden als Zeichenfolgen unter Verwendung des folgenden Format für Hyperlinkadressen ausgegeben: displaytext#address#subaddress#screentip. Sie können in einem Webbrowser nicht auf den String klicken, um die Hyperlinkadresse zu verfolgen. Sie können jedoch den Adressenabschnitt kopieren und die die Adressenleiste des Webbrowsers einfügen.

  • Es dauert unter Umständen länger, ein Datenblatt mit vielen Datensätzen auszugeben und durch einen Webbrowser anzuzeigen. Sie können die Größe eines Datenblattes reduzieren, indem Sie Kriterien, wie z. B. ein Datenfeld oder eine Parameterabfrage verwenden.


 Exportieren eines Datenblattes in statisches HTML-Format

Exportieren eines Datenblattes in statisches HTML-Format

  1. Klicken Sie im Datenbankfenster auf den Namen der Tabelle, Abfrage oder des Formulars, die bzw. das exportiert werden soll. Klicken Sie dann im Menü Datei auf Exportieren.

  2. Klicken Sie im Feld Dateityp auf HTML-Dokumente (*.html;*.htm).

  3. Klicken Sie auf der Symbolleiste für Speicherorte auf eine Verknüpfung, oder klicken Sie auf den Pfeil rechts neben dem Feld Speichern in, und wählen Sie das Laufwerk oder den Ordner für den Export.

  4. Geben Sie in das Feld Dateiname den Dateinamen ein.

  5. Aktivieren Sie das Kontrollkästchen Mit Formatierung, wenn Sie die Tabelle, Abfrage oder das Formular in einem Format speichern möchten, dass der Anzeige in der Datenblattansicht entspricht. Aktivieren Sie das Kontrollkästchen Autostart, damit das Dialogfeld HTML-Ausgabeoptionen angezeigt wird, nachdem Sie in Schritt 6 auf Speichern geklickt haben.

  6. Aktivieren Sie Autostart, wenn Sie das Ergebnis in Ihrem Standard-Webbrowser anzeigen möchten.

  7. Klicken Sie auf Speichern.

  8. Wenn Sie in Schritt 5 das Kontrollkästchen Mit Formatierung aktiviert haben, wird das Dialogfeld HTML-Ausgabeoptionen angezeigt. In dem Feld HTML-Vorlage können Sie den Speicherort einer HTML-Vorlage eingeben. Weitere Informationen zu HTML-Vorlagedateien anzeigen.

Wenn Sie ein Datenblatt auf eine HTML-Datei ausgegeben haben, müssen Sie diese veröffentlichen, um sie im World Wide Web zur Verfügung zu stellen. Weitere Informationen zum Veröffentlichen statischer HTML-Dateien auf einem Webserver aufrufen.

Anmerkungen

  • Wenn das Datenblatt eine Parameterabfrage enthält, werden Sie von Microsoft Access aufgefordert, die Parameterwerte einzugeben. Erst dann werden die Ergebnisse exportiert.

  • Felder mit einem Hyperlinkdatentyp werden als Hyperlinkadressen mit Hilfe von <A HREF> HTML-Tags ausgegeben.

  • Wenn Sie in Schritt 5 das Kontrollkästchen Mit Formatierung aktiviert haben, dann wird in der HTML-Tabelle die Darstellung (dazu gehören Farbe, Schriftart und Ausrichtung) des Datenblattes übernommen.

  • Beim Exportieren eines Datenblattes wird kein Standarddesign verwendet. Sie können jedoch ein Design anwenden, indem Sie aus einer vorhandenen Webseite eine Datenzugriffsseite erstellen (in diesem Fall eine statische HTML-Datei, die Sie soeben erstellt haben), dann in der Entwurfsansicht für Seiten ein Design anwenden und dann die Seite speichern. Weitere Informationen zum Verwenden von Designs aufrufen.

  • Bei einem Datenblatt mit vielen Datensätzen kann die Ausgabe und Anzeige durch einen Webbrowser relativ lange dauern. Sie können die Größe eines Datenblattes reduzieren, indem Sie Kriterien, wie z. B. ein Datenfeld oder eine Parameterabfrage verwenden.


 Exportieren eines Berichts in statisches HTML-Format

Exportieren eines Berichts in statisches HTML-Format

  1. Klicken Sie im Datenbankfenster auf den Namen des Berichts, den Sie exportieren möchten. Klicken Sie dann im Menü Datei auf Exportieren.

  2. Klicken Sie im Feld Dateityp auf HTML-Dokumente (*.html;*.htm).

  3. Klicken Sie auf der Symbolleiste für Speicherorte auf eine Verknüpfung oder klicken Sie auf den Pfeil rechts neben dem Feld Speichern in, und wählen Sie das Laufwerk oder den Ordner für den Export.

  4. Geben Sie in das Feld Dateiname den Dateinamen ein.

  5. Aktivieren Sie das Kontrollkästchen Autostart wenn Sie das Ergebnis in Ihrem Standard-Webbrowser anzeigen möchten.

  6. Klicken Sie auf Speichern.

    Geben Sie im Dialogfeld HTML-Ausgabeoptionen in das Feld HTML-Vorlage den Speicherort einer HTML-Vorlage ein. Wenn Sie keine HTML-Vorlagendatei angeben, die Navigationstokens enthält, wendet Microsoft Access ein Standardnavigationsschema an. Weitere Informationen zu einer HTML-Vorlagendatei aufrufen.

Wenn Sie einen Bericht in eine HTML-Datei ausgegeben haben, ist es erforderlich, diese zu veröffentlichen, um sie im World Wide Web zugänglich zu machen. Weitere Informationen zum Veröffentlichen von statischen HTML-Dateien auf einem Webserver aufrufen.

Anmerkungen

  • Die Ausgabe eines Berichts in Microsoft Access erfolgt im Gegensatz zu einem Datenblatt in mehreren HTML-Dateien, wobei eine Datei pro gedruckte Seite ausgegeben wird. Die Dateinamen werden unter Verwendung des Objektnamens und Suffixes erstellt. Beispiele: Produkte.html, ProdukteSeite2.html, ProdukteSeite3.html, etc.

  • Wenn der Bericht eine Parameterabfrage enthält, werden Sie von Microsoft Access aufgefordert, die Parameterwerte einzugeben. Erst dann werden die Ergebnisse exportiert.

  • Felder mit einem Hyperlinkdatentyp werden als Hyperlinkadressen mit Hilfe von <A HREF> HTML-Tags ausgegeben.

  • Die meisten Steuerelemente und Features von Berichten sowie Unterberichte werden unterstützt. Es gibt folgende Ausnahmen: Linien, Rechtecke und OLE-Objekte. Sie können eine HTML-Vorlagendatei verwenden, um Bilder in einen Berichtkopf oder -fuß aufzunehmen.

  • Beim Exportieren des Berichts wird kein Standarddesign angewendet. Sie können jedoch ein Design anwenden, indem Sie eine Datenzugriffsseite aus einer vorhandenen Webseite erstellen (in diesem Fall die statische HTML-Datei, die Sie soeben erstellt haben), in der Entwurfsansicht ein Design anwenden und dann die Seite speichern. Weitere Informationen zum Verwenden von Designs aufrufen.

  • Microsoft Access bietet neben statischen HTML-Berichten noch mehrere Möglichkeiten, Berichtsinformationen in einem Webbrowser anzuzeigen. Sie können einen Berichts-Snapshot auf einer Webseite erstellen und Sie können eine gruppierte Datenzugriffsseite erstellen. Sie können jedoch einen Bericht nicht in servergenerierten HTML-Format ausgeben.


 HTML-Vorlagendateien

HTML-Vorlagendateien

Sie können eine oder mehrere HTML-Vorlagendateien verwenden, wenn Sie Erscheinungsbild, Konsistenz und Navigationsmöglichkeiten für Ihre statischen HTML- und servererstellten HTML-Dateien verbessern möchten. Auf diese Weise könnten Sie z.B. ein Firmenlogo zum Kopfbereich, ein Hintergrundbild zum Detailbereich und Ihre eigenen Navigationsschaltflächen zum Fußbereich Ihrer statischen HTML-Berichte hinzufügen.

Bei HTML-Vorlagen handelt es sich um Textdateien, die HTML-Marken und -Tokens enthalten, die für Microsoft Access eindeutig sind. Diese Tokens zeigen an, an welcher Stelle Ausgabe- und andere Informationen in die statische oder von einem Server erstellte HTML-Dateien eingefügt werden. Siehe das Beispiel einer HTML-Vorlagendatei.

Wenn Sie eine Tabelle, eine Abfrage, ein Formular oder einen Bericht ausgeben und dabei eine HTML-Vorlagendatei in dem damit verbundenen Dialogfeld Ausgabeoptionen angeben, führt Microsoft Access die HTML-Vorlagendatei mit den .htm-, .asp- und .htx-Ausgabedateien zusammen. Dabei werden die Tokens durch Folgendes ersetzt:

HTML-Vorlagen-Token | Ersetzung
<!--AccessVorlage_Titel--> | Name der Tabelle, der Abfrage, des Formulars oder des Berichts (wird in der Titelleiste des Webbrowsers angezeigt)
<!--AccessVorlage_Hauptteil--> | Die Ausgabe einer Tabelle, Abfrage, eines Formulars oder Berichts
<!--AccessVorlage_ErsteSeite--> | HTML-Anchor-Tag, das eine Verknüpfung zur ersten Seite eines Berichts herstellt
<!--AccessVorlage_VorherigeSeite--> | HTML-Anchor-Tag, das eine Verknüpfung zur vorhergehenden Seite der aktuellen Berichtseite herstellt
<!--AccessVorlage_NächsteSeite--> | HTML-Anchor-Tag, das eine Verknüpfung zur der aktuellen Berichtseite folgenden Seite herstellt
<!--AccessVorlage_LetzteSeite--> | HTML-Anchor-Tag, das eine Verknüpfung zur letzten Berichtseite herstellt
<!--AccessVorlage_Seitenzahl--> | Nummer der aktuellen Seite


 Importieren von Datenbankobjekten aus einer anderen Microsoft Access-Datenbank oder einem Microsoft Access-Projekt

Importieren von Datenbankobjekten aus einer anderen Microsoft Access-Datenbank oder einem Microsoft Access-Projekt

  1. Öffnen Sie die Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

  3. Wählen Sie im Listenfeld Dateityp den Eintrag Microsoft Access (*.MDB, *.ADP, *.MDW, *.MDA, *.MDE, *.ADE) aus.

  4. Klicken Sie auf den Pfeil des Listenfelds Suchen in, wählen Sie das Laufwerk und den Ordner der Microsoft Access-Datenbank (*.MDB) oder des Microsoft Access-Projekts (.ADP) aus, aus der/dem Sie importieren möchten, und doppelklicken Sie dann auf das Symbol der Datenbank.

  5. Klicken Sie im Dialogfeld Objekte importieren auf die Registerkarte für den Typ des zu importierenden Objekts und dann auf das/die Objekt(e), das/die Sie importieren möchten, oder klicken Sie auf Alle auswählen, wenn Sie alle Objekte des gewünschten Typs importieren möchten. Wiederholen Sie diesen Schritt für jeden Objekttyp, den Sie importieren möchten.

    Wenn Sie nur die Definitionen der Tabellen (nicht die enthaltenen Daten) importieren möchten, klicken Sie auf Optionen und dann unter Tabellen importieren auf Nur Definitionen.

    Wenn Sie in einer Access-Datenbank Auswahlabfragen als Tabellen importieren möchten (um z. B. eine schreibgeschützte Datenbank zu erstellen), klicken Sie auf Optionen und dann unter Abfragen importieren auf Als Tabelle. Aktionsabfragen werden unabhängig von der gewählten Option immer als Abfragen importiert.

    Wenn Sie Beziehungen (nur für Access-Datenbanken), benutzerdefinierte Menüs und Symbolleisten oder Import-/Exportspezifikationen (nur für Access-Datenbanken) einbeziehen möchten, klicken Sie auf Optionen und wählen dann unter Importieren die gewünschten Elemente aus. Microsoft Access importiert eine Symbolleiste, eine Menüleiste oder ein Kontextmenü nicht, wenn sie bzw. es den gleichen Namen hat wie ein Element in der Access-Datenbank oder im Access-Projekt.

Anmerkungen

  • Sichten, Gespeicherte Prozeduren oder Datenbankdiagramme aus einem Access-Projekt können nicht in eine Access-Datenbank importiert werden. Abfragen oder Beziehungen aus einer Access-Datenbank können nicht in ein Access-Projekt importiert werden.

  • Wenn Sie eine Datenzugriffsseite importieren, importieren Sie nur die Verknüpfung mit der entsprechenden HTML-Datei. Die HTML-Datei verbleibt an der ursprünglichen Position, d. h., Sie haben zwei Seiten, die auf dieselbe entsprechende HTML-Datei zeigen. Wenn dies nicht erwünscht ist, speichern Sie eine der Seiten unter einem anderen Namen (unter Verwendung des Befehls Speichern unter aus dem Menü Datei), geben eine andere Adresse für die neue entsprechende HTML-Datei in das Dialogfeld Als Datenzugriffsseite speichern ein und löschen dann die Seite, die Sie gerade gespeichert haben.

  • Wenn Sie ein Objekt aus einer anderen Datenbank importieren, können Sie auch verwandte Objekte importieren, um sicherzustellen, dass das Objekt ordnungsgemäß funktioniert. Ein Bericht kann z. B. als Datensatzquelle eine Abfrage haben, die auf einer Beziehung zwischen zwei Tabellen basiert.

  • Obwohl Tabellen aus einem Access-Projekt in eine Access-Datenbank importiert werden können, ist es u. U. effizienter, die Tabelle aus Microsoft SQL Server zu importieren. Wenn Sie Tabellen aus einem Access-Projekt in ein anderes importieren, können Sie in Erwägung ziehen, die Data Transformation Services (DTS) zu verwenden. Damit ist das Importieren und Konvertieren von Daten möglicherweise schneller und flexibler. Weitere Informationen finden Sie in der Dokumentation zu Microsoft SQL Server.

  • Wenn Sie eine Tabelle in ein Access-Projekt importieren, importiert Microsoft Access nur die Tabellendaten und die Datendefinitionen, nicht jedoch deren Eigenschaften, einschließlich Beschränkungen, Beziehungen und Indizes.

  • Obwohl Sie normalerweise zum Konvertieren einer früheren Version einer Microsoft Access-Datenbank den Befehl Datenbank konvertieren aus dem Untermenü Datenbank-Dienstprogramme des Menüs Extras verwenden, können Sie eine frühere Version auch durch Importieren der Datenbankobjekte konvertieren. Dies empfiehlt sich jedoch nur dann, wenn Sie nur einige der Datenbankobjekte konvertieren müssen, oder wenn Sie den Konvertierungsprozess in Visual Basic unter Verwendung der CreateDatabase- und der TransferDatabase-Methoden automatisieren möchten.


 Importieren oder Verknüpfen von Tabellen aus einer anderen Microsoft Access-Datenbank oder aus einem Microsoft Access-Projekt

Importieren oder Verknüpfen von Tabellen aus einer anderen Microsoft Access-Datenbank oder aus einem Microsoft Access-Projekt

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie zum Importieren von Tabellen im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

    Zeigen Sie zum Verknüpfen von Tabellen im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Stellen Sie sicher, dass im Dialogfeld Importieren (oder Verknüpfen) im Feld Dateityp die Option Microsoft Access (*.MDB;*.ADP;*.MDW;*.MDA;*.MDE;*.ADE) ausgewählt ist.

  4. Klicken Sie auf den Pfeil des Listenfelds Suchen in, wählen Sie das Laufwerk und den Ordner der Access-Datenbank (*.MDB) oder des Access-Projekts (.ADP) aus, aus der/dem Sie importieren oder zur der Sie eine Verknüpfung herstellen möchten, und doppelklicken Sie dann auf das Symbol der Datenbank.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Laufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

  5. Klicken Sie im Dialogfeld Objekte importieren auf alle Tabellen, die Sie importieren oder verknüpfen möchten.

    Wenn Sie nur die Definitionen (nicht die enthaltenen Daten) der ausgewählten Tabellen importieren möchten, klicken Sie auf Optionen und dann unter Tabellen importieren auf Nur Definitionen. Weitere Informationen zum Importieren anderer Datenbankobjekte.

Anmerkungen

  • Wenn Sie eine bereits verknüpfte Tabelle importieren, importiert Microsoft Access dann nicht die Daten, sondern verknüpft stattdessen die Tabelle mit ihrer Datenquelle (d.h., tatsächlich werden die Verknüpfungsinformationen kopiert).

  • Obwohl Tabellen aus einem Access-Projekt in eine Access-Datenbank importiert werden können, ist es u. U. effizienter, die Tabelle aus Microsoft SQL Server zu importieren. Wenn Sie Tabellen aus einem Access-Projekt in ein Access-Projekt importieren, können Sie in Erwägung ziehen, die Data Transformation Services (DTS) zu verwenden. Damit ist das Importieren und konvertieren von Daten möglicherweise schneller und flexibler. Weitere Informationen finden Sie in der Dokumentation zu Microsoft SQL Server.

  • Wenn Sie eine Tabelle in ein Access-Projekt importieren, importiert Microsoft Access nur die Tabellendaten und die Datendefinitionen, nicht jedoch deren Eigenschaften (einschließlich Beschränkungen, Beziehungen und Indizes).

  • Wenn die Datenbank, die Sie importieren oder verknüpfen möchten, über ein Datenbankkennwort verfügt, müssen Sie dann dieses Kennwort eingeben, bevor Sie fortfahren können. Das Verknüpfen von Tabellen aus einer derartigen Datenbank kann zu unerwünschten Ergebnissen führen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie zwei Tabellen aus derselben Access-Datenbank verknüpfen, bleiben dann alle Beziehungen, die in dieser Datenbank zwischen den beiden Tabellen bestanden haben, weiterhin bestehen.

  • Wenn Sie eine Tabelle in eine Access-Datenbank importieren, die Nachschlagefelder enthält, sollten Sie auch die Tabellen und Abfragen importieren, auf die diese Nachschlagefelder verweisen. Wenn Sie diese nicht importieren, zeigt Access beim Öffnen der importierten Tabelle in der Datenblattansicht für jede fehlende Tabelle oder Abfrage eine Fehlermeldung an. Um dieses Problem zu lösen, importieren Sie die fehlenden Tabellen oder Abfragen. Wenn Sie dies nicht möchten oder dies nicht möglich ist, öffnen Sie die Tabelle in der Entwurfsansicht, klicken auf die Registerkarte Nachschlagen, die sich auf die fehlende Tabelle oder Abfrage bezieht, und legen dann für die Eigenschaft SteuerelementAnzeigen (DisplayControl) die Einstellung Textfeld fest. Wiederholen Sie diesen Vorgang für alle Nachschlagefelder, die auf eine fehlende Tabelle oder Abfrage verweisen.


 Importieren einer Microsoft Works-Datenbank

Importieren einer Microsoft Works-Datenbank

Sie können eine Microsoft Works-Datenbank (.WDB) nicht direkt nach Microsoft Access importieren. Sie müssen die Datei zuerst mit Hilfe von Microsoft Works in einem der Dateiformate speichern, die Microsoft Access unterstützt.

  1. Öffnen Sie die Datenbank unter Verwendung von Microsoft Works.

  2. Klicken Sie im Menü Datei auf Speichern unter.

  3. Wählen Sie im Listenfeld Dateityp den Eintrag dBASE IV aus, und klicken Sie auf OK.

  4. Importieren Sie die in Schritt 3 erstellte dBASE IV-Datei (.DBF) nach Microsoft Access.

    Wie wird's gemacht?


 Importieren oder Verknüpfen einer Textdatei mit Trennzeichen oder einer Textdatei fester Breite

Importieren oder Verknüpfen einer Textdatei mit Trennzeichen oder einer Textdatei fester Breite

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

Wichtig Vor dem Importieren oder Verknüpfen von Daten aus einer Textdatei mit Trennzeichen oder einer Textdatei mit fester Breite müssen Sie sicherstellen, dass diese Datei in jedem Feld denselben Datentyp und in jeder Zeile dieselben Felder hat.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie zum Importieren von Daten im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

    Zeigen Sie zum Verknüpfen von Daten im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (oder Tabellen verknüpfen) im Listenfeld Dateityp den Eintrag Textdateien (*.TXT, *.CSV, *.TAB, *.ACS).

  4. Klicken Sie auf den Pfeil des Listenfelds Suchen in, wählen Sie das Laufwerk und den Ordner der Datei aus, und doppelklicken Sie auf ihr Symbol.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Laufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

  5. Folgen Sie den Anleitungen in den Dialogfeldern des Textimport-Assistenten. Klicken Sie auf Erweitert, um eine Import-/Exportspezifikation zu erstellen oder zu verwenden.

Anmerkungen

  • Obwohl Sie für die Daten in der Regel in Microsoft Access eine neue Tabelle erstellen, können Sie die Daten auch zu einer vorhandenen Tabelle hinzufügen, vorausgesetzt die erste Zeile Ihrer Textdatei enthält übereinstimmende Feldnamen..

  • Wenn das Importieren einer Textdatei unerwartet viel Zeit in Anspruch nimmt, kann es sein, dass mehrere Fehler aufgetreten sind. Um das Importieren abzubrechen, drücken Sie die Tastenkombination STRG+PAUSE.

  • In einer Textdatei fester Breite können Sie Felder, die sich am Ende eines Datensatzes befinden und keine Daten enthalten, ignorieren. Darüber hinaus kann das letzte Feld des Datensatzes, das Daten enthält, die maximale Breite unterschreiten.

  • Wenn alle Datensätze einer Textdatei fester Breite die gleiche Länge besitzen, kann sich in der Mitte eines Datensatzes ein eingebettetes Zeilentrennzeichen (z. B. ein Wagenrücklauf oder ein Zeilenvorschub) befinden. Wenn jedoch nicht alle Datensätze die gleiche Länge besitzen, sollten Sie keine eingebetteten Zeilentrennzeichen verwenden, da Microsoft Access diese wie das Datensatzende behandelt.


 Importieren oder Verknüpfen einer Kalkulationstabelle

Importieren oder Verknüpfen einer Kalkulationstabelle

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

Bevor Sie fortfahren, müssen Sie sicherstellen, dass die Daten in der Tabelle in einem passenden tabellarischen Format angeordnet sind und dass die Datentypen aller Felder (Spalten) in der Kalkulationstabelle identisch sind und sich in jeder Zeile die gleichen Felder befinden.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie zum Importieren einer Kalkulationstabelle im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

    Zeigen Sie zum Verknüpfen einer Kalkulationstabelle im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (oder Tabellen verknüpfen) im Listenfeld Dateityp den Eintrag Microsoft Excel (*.XLS) oder Lotus 1-2-3 (*.WK*).

  4. Klicken Sie auf den Pfeil des Listenfelds Suchen in, wählen Sie das Laufwerk und den Ordner der Kalkulationstabellendatei aus, und doppelklicken Sie dann auf deren Symbol.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Laufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

  5. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Wenn Sie Daten aus einer Microsoft Excel-Arbeitsmappe der Version 5.0 oder höher importieren möchten, können Sie ein Tabellenblatt der Arbeitsmappe importieren. Sie können jedoch Daten nicht aus beliebigen anderen Dateien mit mehreren Kalkulationstabellen, wie z. B. Arbeitsmappen von Microsoft Excel, Version 4.0, oder von Lotus, importieren. Um Daten aus diesen Dateien importieren zu können, müssen Sie die Kalkulationstabellen zuerst einzeln als Datei speichern.

Anmerkungen

  • Sie können die gesamten Daten einer Kalkulationstabelle importieren bzw. verknüpfen oder nur die Daten eines angegebenen Zellenbereichs. Obgleich Sie für die Daten normalerweise eine neue Tabelle in Microsoft Access erstellen, können Sie sie auch an eine bestehende Tabelle anfügen, vorausgesetzt, die Spaltenüberschriften der Kalkulationstabelle stimmen mit den Feldnamen der Tabelle überein.

  • Wenn das Importieren einer Kalkulationstabelle unerwartet viel Zeit in Anspruch nimmt, kann es sein, dass eine Reihe von Fehlern aufgetreten sind. Um das Importieren abzubrechen, drücken Sie die Tastenkombination STRG+PAUSE.

  • Microsoft Access versucht zwar, den importierten Feldern passende Datentypen zuzuweisen. Sie sollten Ihre Felder aber dennoch auf den gewünschten Datentyp überprüfen. Wird z. B. in einer Access-Datenbank ein Feld für eine Telefonnummer oder Postleitzahl als Feld vom Datentyp Zahl importiert, sollte es in Microsoft Access in ein Feld vom Datentyp Text umgewandelt werden, da es unwahrscheinlich ist, dass auf diesen Feldtypen Berechnungen durchgeführt werden. Sie sollten gegebenenfalls Feldeigenschaften überprüfen und festlegen, z. B. für Formatierungen.

  • Sie können Daten auch aus Kalkulationstabellen anderer Programme importieren, vorausgesetzt, sie besitzen das Format von Microsoft Excel oder Lotus 1-2-3.


 Importieren oder Verknüpfen von Daten aus Microsoft Outlook oder Microsoft Exchange

Importieren oder Verknüpfen von Daten aus Microsoft Outlook oder Microsoft Exchange

Anmerkung Sie können Daten nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zum Importieren von Daten zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Importieren.

    Zeigen Sie zum Verknüpfen von Daten im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (oder Tabellen verknüpfen) im Listenfeld Dateityp den Eintrag Outlook() oder Exchange().

  4. Folgen Sie den Anweisungen in den Dialogfeldern Exchange/Outlook-Assistenten.

Anmerkungen

  • Sie können den Exchange/Outlook-Assistent nur ausführen, wenn Microsoft Outlook, Outlook Express oder Microsoft Exchange auf Ihrem Computer installiert ist.

  • Verwenden Sie den Exchange/Outlook-Assistenten zum Erstellen einer Verknüpfung zu Ihrem Microsoft Outlook-Ordner der Kontakte und Erstellen von Serienbriefen und Adressetiketten durch Zusammenführen der Daten unter Verwendung des Microsoft Word Seriendruck-Assistenten.


 Importieren oder Verknüpfen von dBASE-Dateien

Importieren oder Verknüpfen von dBASE-Dateien

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zum Importieren von Dateien zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Importieren.

    Zum Verknüpfen von Dateien zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (bzw. Tabellen verknüpfen) aus dem Listenfeld Dateityp einen dBASE-Dateitypen aus.

  4. Klicken Sie auf den Pfeil des Listenfelds Suchen in, wählen Sie das Laufwerk und den Ordner der .DBF-Datei aus, und doppelklicken Sie auf ihr Symbol.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Netzlaufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

    • Beim Importieren erstellt Microsoft Access eine Tabelle mit dem Namen der ausgewählten Datei und importiert dann die Daten aus der .DBF-Datei. Fahren Sie mit Schritt 7 fort.

    • Beim Verknüpfen zeigt Microsoft Access ein Dialogfeld an, in dem Sie dBASE-Indexdateien zuordnen können. Fahren Sie mit Schritt 5 fort.
  5. Doppelklicken Sie auf alle dBASE-Indexdateien (.NDX oder .MDX), die Sie verwenden möchten, und klicken Sie dann auf Schließen. Sind keine Indizes vorhanden, klicken Sie auf Abbrechen, um fortzufahren.

  6. Wählen Sie im Dialogfeld Eindeutigen Datensatzbezeichner auswählen einen Index aus, der die einzelnen Datensätze eindeutig kennzeichnet. Dieser Index darf keine doppelten Werte enthalten, da Microsoft Access sonst nicht in der Lage ist, Daten in Abfragen mit verknüpften Tabellen fehlerfrei zu aktualisieren.

  7. Wenn Sie eine weitere dBASE-Datei importieren oder verknüpfen möchten, wiederholen Sie die Schritte 4 bis 6.

Anmerkungen

  • Zum Verknüpfen (Lesen/Schreiben) einer dBASE 7-Tabelle muss auf Ihrem Computer die Borland Database Engine (BDE), Version 4.x oder höher installiert sein. Wenn Sie BDE 4.x oder höher nicht installiert haben, erhalten Sie dies durch Installieren von dBASE 7 oder Delphi. Wenn Sie eine ältere Version der BDE haben, die das dBASE 7-Dateiformat nicht unterstützt, können Sie Ihre Engine aus der Borland World Wide Website aktualisieren. Wenn Sie die BDE nicht auf Ihrem Computer installiert haben, können Sie jedoch weiterhin Verknüpfungen zu dBASE III-, IV- und 5.0-Dateien erstellen.

  • Nach dem Importieren oder Verknüpfen einer .DBF- oder einer .DBC-Datei können Sie deren Feldeigenschaften einstellen. Wenn Sie eine .DBF- oder .DBC-Datei importieren, möchten Sie vielleicht auch einen Primärschlüssel für die Tabelle festlegen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie eine .DBF-Datei verknüpfen und ihr eine Indexdatei (.NDX oder .MDX) zuordnen, dann benötigt Microsoft Access diese Indexdatei zum Öffnen der verknüpften Tabelle. Wenn Sie dBASE-Indexdateien oder die von Microsoft Access erstellte Informationsdatei (.INF) löschen oder verschieben, können Sie die verknüpfte Tabelle nicht mehr öffnen.

  • Wenn Sie die Daten Ihrer .DBF-Datei mit Hilfe von Microsoft Access aktualisieren, aktualisiert Access auch die Indexdateien entsprechend. Wenn Sie Daten mit dBASE aktualisieren, müssen Sie dann auch die zugeordneten Indizes mit dBASE aktualisieren. Microsoft Access kann mit einer verknüpften Tabelle nur dann arbeiten, wenn die angegebenen Indizes die aktuellen Indizes sind.

  • Wenn Ihre dBASE-Tabellen auf einem schreibgeschützten Laufwerk oder einer CD-ROM gespeichert sind, kann Microsoft Access die .INF-Datei nicht in dem Ordner erstellen, in dem sich die .DBF-Dateien befinden. Um eine Tabelle auf einem schreibgeschützten Laufwerk zu verknüpfen, legen Sie die .INF-Datei auf einem Laufwerk mit Lese-/Schreibzugriff ab. Sie können den Pfad für die .INF-Datei in der Windows-Registrierung festlegen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Importieren oder Verknüpfen von Paradox-Tabellen

Importieren oder Verknüpfen von Paradox-Tabellen

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zum Importieren von Tabellen zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Importieren.

    Zum Verknüpfen von Tabellen zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (oder Tabellen verknüpfen) im Listenfeld Dateityp den Eintrag Paradox (*.DB).

  4. Klicken Sie auf den Pfeil rechts vom Feld Suchen in, wählen Sie das Laufwerk und den Ordner, an dem sich die .DB-Datei befindet, und doppelklicken Sie auf ihr Symbol.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Laufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

  5. Wenn die ausgewählte Paradox-Tabelle verschlüsselt ist, werden Sie von Microsoft Access nach dem Kennwort gefragt. Geben Sie das Kennwort für die Paradox-Tabelle ein, und klicken Sie auf OK.

  6. Wenn Sie eine weitere Paradox-Tabelle importieren oder verknüpfen möchten, wiederholen Sie die Schritte 2 bis 5. Andernfalls klicken Sie auf Schließen.

Anmerkungen

  • Zum Verknüpfen (Lesen/Schreiben) einer Paradox 8.0-Tabelle muss auf Ihrem Computer die Borland Database Engine (BDE), Version 4.x oder höher installiert sein. Wenn Sie BDE 4.x oder höher nicht installiert haben, erhalten Sie dies durch Installieren von Paradox 8.0 oder Delphi. Wenn Sie eine ältere Version der BDE haben, die das Paradox 8-Dateiformat nicht unterstützt, können Sie Ihre Engine aus der Borland World Wide Website aktualisieren. Wenn Sie die BDE nicht auf Ihrem Computer installiert haben, können Sie jedoch weiterhin Verknüpfungen (schreibgeschützt) zu Paradox 3.x, 4.x und 5.0-Tabellen erstellen.

  • Wenn Sie eine Paradox-Tabelle verknüpfen, die einen Primärschlüssel besitzt, benötigt Microsoft Access die zugeordnete Indexdatei (.PX), um die verknüpfte Tabelle öffnen zu können. Wenn Sie eine Paradox-Tabelle mit einem Memo-Feld verknüpfen, benötigt Microsoft Access dann zum Öffnen der verknüpften Tabelle die zugeordnete Memo-Datei (.MB). Wenn Sie diese Dateien löschen oder verschieben, sind Sie nicht mehr in der Lage, die verknüpfte Tabelle zu öffnen.

  • Wenn Sie eine Paradox-Tabelle verknüpfen, die keinen Primärschlüssel besitzt, können Sie die Daten der Tabelle nicht mit Microsoft Access aktualisieren. Um die Tabelle aktualisieren zu können, müssen Sie einen Primärschlüssel für die Tabelle in Paradox definieren.

  • In einer verknüpften oder importierten Paradox-Tabelle gespeicherte OLE-Objekte können nicht in Microsoft Access geöffnet werden.


 Importieren oder Verknüpfen von SQL-Datenbanktabellen oder Daten aus anderen ODBC-Datenquellen

Importieren oder Verknüpfen von SQL-Datenbanktabellen oder Daten aus anderen ODBC-Datenquellen

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

Wichtig Sie können eine SQL- oder eine andere ODBC-Datenquelle nur importieren oder verknüpfen, wenn Sie den entsprechenden Treiber installiert haben.

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zum Importieren von Tabellen zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Importieren.

    Zum Verknüpfen von Dateien zeigen Sie im Menü Datei auf Externe Daten und klicken dann auf Tabellen verknüpfen.

  3. Wählen Sie im Dialogfeld Importieren (oder Tabellen verknüpfen) im Listenfeld Dateityp den Eintrag ODBC Datenbases () aus.

    Wichtig Wenn Sie eine Datei auf einem lokalen Netzwerk verknüpfen, müssen Sie sicherstellen, dass Sie einen UNC-Pfad (Universal Naming Convention) und nicht den Laufwerksbuchstaben eines zugeordneten Laufwerks in Windows Explorer verwenden. Ein Laufwerksbuchstabe kann je nach Computer unterschiedlich oder gar nicht definiert sein, während ein UNC-Pfad Microsoft Access zuverlässig und konsistent erlaubt, die Datenquelle der verknüpften Datei zu finden.

    Das Dialogfeld Datenquelle auswählen zeigt die für die auf Ihrem Computer installierten ODBC-Treiber definierten Datenquellen an. Klicken Sie auf eine der Registerkarten Dateidatenquelle oder Computer-Datenquelle, und doppelklicken Sie dann auf die ODBC-Datenquelle, die Sie importieren möchten. Zum Definieren einer neuen Datenquelle für installierte ODBC-Treiber klicken Sie auf Neu und folgen dann den Anweisungen im Dialogfeld Neue Datenquelle erstellen und den nachfolgenden Dialogfeldern. Weitere Informationen zu Datenquellen.

  4. Wenn Sie aufgefordert werden, sich bei der ausgewählten ODBC-Datenquelle anzumelden, geben Sie Ihren Anmeldenamen und Ihr Kennwort ein (gegebenenfalls sind noch weitere Daten erforderlich), und klicken Sie dann auf OK.

    Microsoft Access stellt eine Verbindung zur ODBC-Datenquelle her und zeigt eine Liste mit Tabellen an, die Sie importieren oder verknüpfen können.

  5. Aktivieren Sie beim Verknüpfen einer Tabelle das Kontrollkästchen Anmeldenamen und Kennwort speichern, wenn Sie diese Informationen für die Tabelle in der aktuellen Datenbank speichern möchten, anstatt sie vom Benutzer eingeben zu lassen. Wenn Sie das Kontrollkästchen deaktiviert lassen, müssen alle Benutzer bei jedem Öffnen der Tabelle in einer neuen Microsoft Access-Sitzung den Anmeldenamen und das Kennwort eingeben. Der SQL-Datenbankadministrator kann das Deaktivieren des Kontrollkästchen veranlassen, so dass alle Benutzer beim Verbinden mit der SQL-Datenbank aufgefordert werden, die Anmeldenamen sowie das Kennwort einzugeben. Um Informationen zum Deaktivieren des Kontrollkästchens Anmeldenamen und Kennwort speichern anzuzeigen, klicken Sie auf [image] .

  6. Klicken Sie auf die Tabellen, die Sie importieren oder verknüpfen möchten, und dann auf OK. Wenn Sie eine Tabelle verknüpfen, die keinen Index besitzt, der die einzelnen Datensätze eindeutig kennzeichnet, zeigt Microsoft Access dann eine Liste mit den Feldern der verknüpften Tabelle an. Klicken Sie auf ein Feld oder eine Feldkombination, das bzw. die die Datensätze eindeutig kennzeichnet, und klicken Sie dann auf OK.

Anmerkungen

  • Nach dem Importieren bzw. Verknüpfen einer SQL-Datenbanktabelle können Sie deren Feldeigenschaften einstellen. Wenn Sie eine Tabelle importieren, möchten Sie vielleicht auch einen Primärschlüssel für die Tabelle festlegen. Zum Anzeigen weiterer Informationen zum Festlegen von Feldeigenschaften für die Tabelle klicken Sie auf [image] .

  • Wenn beim Importieren, Verknüpfen oder Arbeiten mit einer SQL-Datenbanktabelle ein Fehler auftritt, kann dies an Ihren Zugriffsrechten auf dem SQL-Datenbank-Server oder an der Datenbank selbst liegen. Wenn Sie auf eine SQL-Datenbanktabelle nicht zugreifen können, wenden Sie sich an die SQL-Datenbankadministration.

  • Um eine verknüpfte SQL-Datenbanktabelle zu bearbeiten, muss die Tabelle normalerweise einen eindeutigen Index auf dem Server besitzen. Wenn Sie eine SQL-Ansicht oder eine Tabelle, die keinen eindeutigen Index besitzt, bearbeiten möchten, können Sie in Microsoft Access einen Index erstellen, der der SQL-Datenbank nicht bekannt ist. Erstellen Sie hierfür eine Datendefinitionsabfrage unter Verwendung der Anweisung Create index. Achten Sie jedoch darauf, dass Sie den Index für ein Feld oder eine Feldkombination erstellen, dessen bzw. deren Werte eindeutig sind. Enthält das Feld doppelte Werte, verlaufen sämtliche Aktualisierungen der Tabelle fehlerhaft. Verwenden Sie zum Löschen des Indexes eine weitere Datendefinitionsabfrage. Um weitere Informationen zum Erstellen einer solchen Datendefinitionsabfrage zu erstellen, klicken Sie auf [image] .

  • Wenn sich die Struktur einer SQL-Datenbanktabelle nach dem Verknüpfen ändert, können Sie die Verknüpfung mit Hilfe des Tabellenverknüpfungs-Manager aktualisieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    .
  • Wenn Sie aus einer Microsoft SQL Server-Datenbank in ein Access-Projekt importieren, sollten Sie in Erwägung ziehen, Data Transformation Services (DTS) zu verwenden. Dies macht den Import und die Konvertierung von Daten u. U. schneller und flexibler. Weitere Informationen finden Sie in der Dokumentation zu Microsoft SQL Server.


 Importieren oder Verknüpfen von (schreibgeschützten) Daten auf einem FTP- oder einem HTTP-Internet-Server

Importieren oder Verknüpfen von (schreibgeschützten) Daten auf einem FTP- oder einem HTTP-Internet-Server

Anmerkung Beim Importieren auf oder Verknüpfen mit einem FTP- oder HTTP-Server können Sie nicht aus einer Microsoft Access-Datenbank, einer Textdatei oder einer ODBC-Datenquelle importieren oder mit einer dieser Quellen verknüpfen. Zum Anzeigen einer allgemeinen Übersicht über die Datenquellen, die Sie importieren oder verknüpfen können, klicken Sie auf [image] .

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie zum Importieren von Daten im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

    Zeigen Sie zum Verknüpfen von Daten im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Um von einem HTTP-Server zu importieren oder zu verknüpfen, geben Sie in das Feld Dateiname die Internet-Adresse ein. Um z. B. die Datei VERKAUFJAN.HTML auf dem HTTP-Server Pubweb zu verknüpfen, geben Sie http://pubweb/verkaufjan.html ein.

    Um von einem FTP-Server zu importieren oder zu verknüpfen, geben Sie entweder in das Feld Dateiname die Internet-Adresse ein, oder klicken Sie auf den Pfeil rechts vom Feld Suchen in, und wählen Sie dann FTP-Speicherorte. Doppelklicken Sie in der Liste der FTP-Adressen auf die Adresse des gewünschten Elements und doppelklicken Sie dann auf das Element.

Anmerkungen

  • Obwohl Sie eine Textdatei nicht unter Verwendung des Befehls Importieren importieren oder Verknüpfen können, können Sie die TransferText-Aktion oder -Methode verwenden.

  • Microsoft Access kopiert die gesamte Datei in den Ordner CACHE von Microsoft Internet Explorer auf Ihrem lokalen Computer. Dieser Vorgang ist unter Umständen zeitaufwendig, da möglicherweise größere Datenmengen über das Internet übertragen werden.

  • Eine verknüpfte Tabelle ist ein Daten-Snapshot der ursprünglichen, entfernten Datenquelle zu dem Zeitpunkt, an dem die Verknüpfung erstellt wird. Änderungen, die an der entfernten Adresse an den Daten vorgenommen werden, sehen Sie nicht, solange die Tabelle geöffnet ist, sondern erst beim nächsten Öffnen der Tabelle. Microsoft Access aktualisiert die lokale Kopie im Ordner CACHE.


 Importieren oder Verknüpfen (schreibgeschützt) von HTML-Tabellen und -Listen

Importieren oder Verknüpfen (schreibgeschützt) von HTML-Tabellen und -Listen

  1. Öffnen Sie eine Datenbank, oder wechseln Sie zum Datenbankfenster der geöffneten Datenbank.

  2. Zeigen Sie zum Importieren von HTML-Tabellen oder -Listen im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren

    Zeigen Sie zum Verknüpfen von HTML-Tabellen oder -Listen im Menü Datei auf Externe Daten, und klicken Sie dann auf Tabellen verknüpfen.

  3. Klicken Sie im Dialogfeld Importieren oder Verknüpfen im Feld Dateityp auf HTML Dokumente (*.html;*.htm).

  4. Klicken Sie auf einen Shortcut auf der Umgebungsleiste, oder klicken Sie auf den Pfeil rechts vom Feld Suchen in.

  5. Wählen Sie das Laufwerk oder den Ordner aus, auf/in dem sich die HTML-Datei befindet, die Sie importieren oder verknüpfen möchten, und doppelklicken Sie dann auf den Dateinamen.

  6. Folgen Sie den Anweisungen des HTML-Import -Assistenten oder des HTML-Verknüpfungs-Assistenten. Klicken Sie auf die Schaltfläche Optionen, wenn Sie eine Import-/Exportspezifikation bearbeiten oder andere Datei- und Feldformate festlegen möchten.

  7. Wenn Ihre HTML-Datei mehr als eine Tabelle oder Liste enthält, wiederholen Sie die Schritte 1 bis 5 für jede Tabelle oder Liste, die Sie importieren oder verknüpfen möchten.

Anmerkungen

  • Microsoft Access konvertiert eine HTML-Hyperlinkadresse standardmäßig in eine Spalte vom Datentyp Hyperlink. Dies gilt jedoch nur, wenn alle Werte in einer Tabellenspalte oder in einer Liste eine Hyperlinkadresse enthalten, die durch eine HTML-Marke <A HREF> definiert sind. Wenn Sie den HTML-Import-Assistenten oder den HTML-Verknüpfungs-Assistenten verwenden, können Sie den Datentyp ändern. Zum Anzeigen weiterer Informationen zu Hyperlinkadressen klicken Sie auf [image] .

  • Microsoft Access ignoriert GIF- und JPEG-Bilder, die in den HTML-Tabellen oder -Listen eingebettet sind.

  • Eine in einer Tabellenzelle in einer HTML-Datei eingebettete Tabelle wird beim Importieren oder Verknüpfen als separate Tabelle interpretiert. Eine in eine Tabellenzelle eingebettete Liste wird als Inhalt einer Zelle interpretiert, und jedes Element in der Liste wird vom nächsten durch ein Wagenrücklauf-/Zeilenvorschubzeichen getrennt.

  • Daten, die sich über Zeilen oder Spalten in einer HTML-Tabelle erstrecken, dupliziert Microsoft Access 2000 in jeder Zelle. Dagegen speichert Microsoft Excel 2000 die Daten in der ersten oder in der oberen linken Zelle und lässt die anderen Zellen leer.


 Löschen der Verknüpfung zu einer verknüpften Tabelle in einer Microsoft Access-Datenbank

Löschen der Verknüpfung zu einer verknüpften Tabelle in einer Microsoft Access-Datenbank

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank verknüpfen, nicht in einem Microsoft Access-Projekt.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Tabellen [image] und dann auf die verknüpfte Tabelle.

  2. Drücken Sie die ENTF-TASTE. Microsoft Access hebt die Verknüpfung auf und löscht den Namen der Tabelle aus der Liste.

Anmerkung Wenn Sie eine verknüpfte Tabelle löschen, werden nur die Informationen gelöscht, die Microsoft Access zum Öffnen der Tabelle benötigt, nicht die Tabelle selbst. Wenn Sie möchten, können Sie später wieder eine Verknüpfung zu dieser Tabelle erstellen.


 Verwenden der Tabelle MSysConf in einer Microsoft Access-Datenbank mit verknüpften SQL-Datenbanken

Verwenden der Tabelle MSysConf in einer Microsoft Access-Datenbank mit verknüpften SQL-Datenbanken

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank, nicht in einem Microsoft Access-Projekt verknüpfen.

Wenn Sie eine SQL-Datenbank verwalten, die Microsoft Access als Front-End verwendet, können Sie in der SQL-Datenbank eine Tabelle mit dem Namen MSysConf erstellen, die Sie bei der Steuerung der Kommunikation zwischen den beiden Anwendungen unterstützt. Die Tabelle MSysConf besitzt bei Bedarf zwei Funktionen:

  • Sie kann die Option deaktivieren, die dem Benutzer das Speichern des Anmeldenamens und des Kennworts für eine verknüpfte SQL-Datenbank im Microsoft Access-Front-End ermöglicht.

  • Sie kann optimieren, wie Microsoft Access während der Leerlaufzeit im Hintergrund die Datensätze füllt, indem sie die Anzahl der Datenzeilen, die gleichzeitig abgerufen werden, und die Anzahl der Sekunden, die zwischen zwei Abrufvorgängen liegen, festsetzt. Microsoft Access verwendet einen Standardwert von 100 zurückgegebenen Datensätzen in 10 Sekunden, wenn die Tabelle MSysConf nicht vorhanden ist.

Die Struktur der Tabelle MSysConf

Die SQL-Datenbanktabelle MSysConf sollte die folgende Struktur haben:

Spaltenname | Datentyp | Nullen zulässig?
Config | Ein Datentyp, der einem 2 Byte langen Integer-Wert entspricht. | Nein
chValue | VARCHAR(255) | Ja
nValue | Ein Datentyp, der einem 4 Byte langen Integer-Wert entspricht. | Ja
Comments | VARCHAR(255) | Ja

Anmerkung Wenn Sie mit einer Datenquelle arbeiten, die die Groß-/Kleinschreibung berücksichtigt, geben Sie die Tabellen- und Spaltennamen exakt wie oben an.

Alle Benutzer sollten die Berechtigung besitzen, die Anweisung Select auf diese Tabelle anzuwenden. Über die Berechtigung "Einfügen/Aktualisieren/Löschen" sollte jedoch ausschließlich die Systemadministration verfügen.

Die Daten in der Tabelle MSysConf

Es gibt drei gültige Datensätze in der Tabelle MSysConf. Die folgende Tabelle zeigt, welche Werte Sie in die Felder Config und nValue eingeben sollten. Die anderen Felder sind für zukünftige Verwendungen reserviert; ihr Inhalt wird ignoriert.

Config | nValue | Bedeutung
101 | 0 | Keine lokale Speicherung des Anmeldenamens und des Kennworts in verknüpften Tabellen zulässig.
 | 1 | Lokale Speicherung des Anmeldenamens und des Kennworts in verknüpften Tabellen zulässig.
102 | D | D gibt die Sekunden an, die zwischen zwei Abrufvorgängen liegen.
103 | N | N gibt die Anzahl der abgerufenen Zeilen an.

Anmerkungen

  • Wenn Sie die Zeit zwischen zwei Abrufvorgängen verlängern, wird zwar die Netzwerkbelastung vermindert, aber die Zeit, in der auf die Daten Lesesperren angewendet werden (falls der Server Lesesperren verwendet), wird ebenfalls verlängert.

  • Achten Sie beim Erstellen der Tabelle MSysConf darauf, dass Sie sie korrekt einrichten. Ansonsten werden Sie keine Verbindung zur SQL-Datenbanktabelle herstellen können.


 Anzeigen, Aktualisieren oder Ändern des Dateinamens und Pfades für verknüpfte Tabellen in einer Microsoft Access-Datenbank

Anzeigen, Aktualisieren oder Ändern des Dateinamens und Pfades für verknüpfte Tabellen in einer Microsoft Access-Datenbank

Anmerkung Sie können eine Tabelle nur in einer Microsoft Access-Datenbank und nicht in einem Microsoft Access-Projekt verknüpfen.

Verwenden Sie dieses Verfahren zum Anzeigen und Aktualisieren von Verknüpfungen, wenn sich Struktur oder Verzeichnis einer verknüpften Tabelle verändert haben. Der Tabellenverknüpfungs-Manager listet den Pfad aller momentan verknüpften Tabellen auf.

So können Sie Verknüpfungen anzeigen oder aktualisieren

  1. Öffnen Sie die Datenbank, welche die Verknüpfungen der Tabellen enthält.

  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme und klicken Sie dann auf Tabellenverknüpfungs-Manager.

  3. Aktivieren Sie das Kontrollkästchen für die Tabellen, deren Verknüpfungen Sie aktualisieren möchten.

  4. Klicken Sie auf OK, um die Verknüpfungen zu aktualisieren.

    Microsoft Access bestätigt die erfolgreich durchgeführte Aktualisierung oder zeigt, falls die Tabelle nicht gefunden wurde, das Dialogfeld Bitte Position angeben von <Tabellenname> an, in dem Sie das neue Verzeichnis der Tabelle angeben können.

    Wenn mehrere ausgewählte Tabellen in das von Ihnen angegebene Verzeichnis verschoben wurden, durchsucht der Tabellenverknüpfungs-Manager dieses Verzeichnis für alle ausgewählten Tabellen und aktualisiert alle Verknüpfungen in einem Schritt.

So ändern Sie den Pfad mehrerer verknüpfter Tabellen

  1. Öffnen Sie die Datenbank, welche die Verknüpfungen der Tabellen enthält.

  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme und klicken Sie dann auf Tabellenverknüpfungs-Manager.

  3. Aktivieren Sie das Kontrollkästchen Neuen Speicherort immer bestätigen lassen.

  4. Aktivieren Sie das Kontrollkästchen für die Tabellen, deren Verknüpfungen Sie ändern möchten, und klicken Sie dann auf OK.

  5. Geben Sie im Dialogfeld Auswählen der neuen Position von <Tabellenname> das neue Verzeichnis an, klicken Sie auf Öffnen und dann auf OK.

Anmerkungen

  • Wenn Sie Datenbank- oder Tabellendateien in ein neues Verzeichnis verschieben möchten, verwenden Sie Windows Explorer, den Arbeitsplatz oder die MS-DOS-Befehle zum Kopieren oder Verschieben. Nachdem Sie eine Datenbank oder Tabelle verschoben haben, können Sie mit dem Tabellenverknüpfungs-Manager die Verknüpfungen der verknüpften Tabellen aktualisieren.

  • Der Tabellenverknüpfungs-Manager kann keine Verknüpfungen mit Microsoft Access-Tabellen aktualisieren, deren Namen nach dem Verknüpfen geändert wurden. Sie müssen die momentane Verknüpfung aufheben und die Tabellen dann erneut verknüpfen.


 Meldungen der Importfehlertabelle

Meldungen der Importfehlertabelle

Die Tabelle Importfehler enthält Beschreibungen der meisten Fehlermeldungen, die beim Importieren einer Textdatei oder Kalkulationstabelle in eine Microsoft Access-Datenbank auftreten können. Die in der Tabelle enthaltenen Feldnamen und Zeilennummern geben an, welche Daten die Fehler verursacht haben.

Anmerkung In einem Microsoft Access-Projekt wird keine Importfehlertabelle erstellt. Verwenden Sie DTS (Data Transformation Services), um Daten schneller und flexibler zu importieren und umzuwandeln. Weitere Informationen finden Sie in der Microsoft SQL Server-Dokumentation.

Falls Microsoft Access Fehler dokumentiert hat, öffnen Sie die Tabelle Importfehler, und versuchen Sie festzustellen, warum Microsoft Access nicht alle Datensätze importieren konnte. In der folgenden Tabelle sind mögliche Importfehler sowie Beschreibungen der Ursachen aufgeführt.

Fehler | Beschreibung
Feld abgeschnitten | Ein Wert der Datei übersteigt die in der Einstellung für die Eigenschaft Feldgröße festgelegte Größe.
Fehler bei Typumwandlung | Ein Wert der Textdatei oder Kalkulationstabelle besitzt für das entsprechende Feld den falschen Datentyp.
Schlüsselverletzung | Der Primärschlüsselwert dieses Datensatzes ist ein Duplikat. Er ist bereits in der Tabelle vorhanden.
Verstoß gegen Gültigkeitsregel | Ein Wert verstößt gegen die in der Eigenschaft Gültigkeitsregel (ValidationRule) des Feldes oder der Tabelle angegebenen Regeln.
Kein Wert in notwendigem Feld | In diesem Feld ist kein Nullwert erlaubt, da die Eigenschaft Eingabe Erforderlich des Feldes auf Ja eingestellt ist.
Null-Wert in Feld AutoWert | Die importierten Daten enthalten einen Nullwert, den Sie an ein AutoWert-Feld anzuhängen versuchen.
Nicht lesbarer Datensatz | Ein Textwert enthält das Texttrennzeichen (normalerweise doppelte Anführungszeichen). Wenn ein Wert das Texttrennzeichen enthält, muss dieses in der Textdatei zweimal dargestellt werden, z.B.: "10 - 3 1/2"" Disketten/Packung"

Wenn Sie vermuten, dass der Fehler von Ihren Daten verursacht wird, bearbeiten Sie Ihre Textdatei oder Kalkulationstabelle. Wenn Sie Datensätze an eine bestehende Tabelle anfügen möchten, müssen Sie unter Umständen die Tabelle ändern (ordnen Sie z.B. die Felder neu an, oder ändern Sie die Datentypen). Importieren Sie die Daten erneut, nachdem Sie den Fehler behoben haben.


Einrichten von ODBC-Datenquellen

  1. Klicken Sie auf die Windows-Schaltfläche Start, zeigen Sie auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie anschließend auf das Symbol 32-Bit-ODBC (in Microsoft Windows 95 oder höher) bzw. auf das Symbol ODBC (in Microsoft Windows NT Workstation 4.0 oder höher).

  2. Wählen Sie je nach Typ der zu verändernden Datenquelle die Registerkarte Benutzer-DSN, System-DSN oder Datei-DSN aus. Weitere Informationen über Datenquellen.

  3. Zum Definieren einer neuen Datenquelle für einen bereits installierten Treiber klicken Sie auf Hinzufügen.

  4. Zum Ändern der Definition einer vorhandenen Datenquelle führen Sie folgende Schritte durch:
    • Wählen Sie die Datenquelle aus der Liste aus. Wenn Sie eine Dateidatenquelle verändern möchten, suchen Sie den entsprechenden Ordner im Feld Suchen in (verwenden Sie gegebenenfalls das Aufwärts)-Steuerelement, und wählen Sie dann die Datenquelle aus dem Ordner aus.

    • Klicken Sie auf Konfigurieren.
  5. Schließen Sie die Bearbeitung der Dialogfelder ab. Um weitere Informationen zu den verschiedenen Optionen zu erhalten, klicken Sie im jeweiligen Dialogfeld auf die Schaltfläche Hilfe.


Möglichkeiten zum Arbeiten mit Daten in einem Formular

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie nacheinander F6, um den Themenbereich zu aktivieren, TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie nacheinander F6, um den Themenbereich zu aktivieren, TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


 Hinzufügen neuer Daten in der Datenblatt- oder Formularansicht

Hinzufügen neuer Daten in der Datenblatt- oder Formularansicht

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Klicken Sie in der in der Symbolleiste auf Neuer Datensatz [image] .

  3. Geben Sie die gewünschten Daten ein, und drücken Sie dann TAB, um zum nächsten Feld zu gelangen.

  4. Drücken Sie am Ende des Datensatzes auf TAB, um zum nächsten Datensatz zu gelangen.


Speichern eines Datensatzes in der Datenblatt- oder Formularansicht

Microsoft Access speichert den gerade hinzugefügten oder bearbeiteten Datensatz automatisch, sobald Sie die Einfügemarke auf einen anderen Datensatz bewegen, oder sobald Sie das Formular oder Datenblatt, an dem Sie gerade arbeiten, schließen.

  • Um die Daten des Datensatzes während der Bearbeitung manuell zu speichern, klicken Sie im Menü Datensätze auf Datensatz speichern.


 Löschen eines Datensatzes in der Datenblatt- oder Formularansicht

Löschen eines Datensatzes in der Datenblatt- oder Formularansicht

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Klicken Sie auf den zu löschenden Datensatz.

  3. Klicken Sie in der Symbolleiste auf Datensatz löschen [image] .

Anmerkung Wenn Sie Daten löschen, kann es vorkommen, dass Sie auch zugehörige Daten in anderen Tabellen löschen möchten. Wenn Sie z. B. einen Lieferanten löschen, möchten Sie wahrscheinlich auch dessen gelieferte Artikel löschen. In einigen Fällen können Sie sicherstellen, dass die entsprechenden Daten gelöscht werden, indem Sie die referenzielle Integrität durchsetzen und die Option für Löschweitergaben aktivieren.

Informationen über referenzielle Integrität in einer Microsoft Access-Datenbank anzeigen.

Informationen über referenzielle Integrität in einem Microsoft Access-Projekt anzeigen.


 Einfügen eines Standardwertes in ein Feld

Einfügen eines Standardwertes in ein Feld

  1. Öffnen Sie ein Datenblatt.

  2. Klicken Sie auf das Feld, in das Sie den Standardwert einfügen möchten.

  3. Drücken Sie die Tastenkombination STRG+ALT+LEERTASTE.

Anmerkungen Um den Standardwert in einer Microsoft Access-Datenbank anzuzeigen, öffnen Sie die Tabelle in der Tabellenentwurfsansicht und sehen sich die Standardwert-Eigenschaft an. Um den Standardwert in einem Microsoft Access-Projekt anzuzeigen, wählen Sie in einem Datenbankdiagramm die Ansicht "Spalteneigenschaften" und sehen sich die Spalteneigenschaft Standardwert an.


 Bearbeiten der Daten in einem Feld in der Datenblatt- oder Formularansicht

Bearbeiten der Daten in einem Feld in der Datenblatt- oder Formularansicht

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Um Daten innerhalb eines Feldes zu bearbeiten, klicken Sie auf eine beliebige Stelle in dem zu bearbeitenden Feld.

    Um den gesamten Wert zu ersetzen, bewegen Sie den Zeiger im Feld ganz nach links, bis er in Form eines Plus-Zeigers [image] erscheint, und klicken Sie dann.

  3. Geben Sie nun den gewünschten Text ein.

Anmerkungen

  • Falls Ihnen ein Tippfehler unterläuft, drücken Sie die RÜCKTASTE. Wenn Sie Ihre Änderungen im aktuellen Feld rückgängig machen möchten, drücken Sie die ESC-TASTE. Wenn Sie Ihre Änderungen im gesamten Datensatz aufheben möchten, drücken Sie noch einmal ESC, bevor Sie das Feld verlassen.

  • Microsoft Access speichert Ihre Änderungen, sobald Sie zu einem anderen Datensatz wechseln.


 Angeben einer leeren Zeichenfolge in der Datenblatt- oder Formularansicht zum Kennzeichnen nicht vorhandener Daten

Angeben einer leeren Zeichenfolge in der Datenblatt- oder Formularansicht zum Kennzeichnen nicht vorhandener Daten

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Geben Sie zwei Anführungszeichen (" ") ohne Leerzeichen ein, um in das Feld eine leere Zeichenfolge einzugeben.

Das Feld enthält die leere Zeichenfolge auch dann noch, wenn die Anführungszeichen nicht mehr angezeigt werden, sobald Sie zu einem anderen Feld oder Objekt wechseln.

Anmerkungen

  • Falls Microsoft Access in einer Microsoft Access-Datenbank die Meldung "Feld 'Tabellenname.Feldname' darf keine Zeichenfolge der Länge Null sein" anzeigt, ändern Sie die Eigenschaft LeereZeichenfolge entsprechend. Zum Anzeigen von Informationen über das Ändern dieser Eigenschaft klicken Sie auf [image] .

  • In einem Microsoft Access-Projekt können Sie eine leere Zeichenfolge nur in ein Feld mit dem Datentyp "varchar" oder "nvarchar" in einer Microsoft SQL Server 7.0-Datenbank eingeben. Leere Zeichenfolgen werden in SQL Server 6.5 nicht unterstützt.


 Rückgängigmachen von Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen in der Datenblatt- oder Formularansicht

Rückgängigmachen von Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen in der Datenblatt- oder Formularansicht

  • Klicken Sie in der Symbolleiste auf Rückgängig [image] , um Ihre letzte Änderung rückgängig zu machen.

  • Klicken Sie im Menü Bearbeiten auf Rückgängig: Gespeicherter Datensatz, wenn Sie bereits Änderungen am aktuellen Datensatz gespeichert haben oder zu einem anderen Datensatz gewechselt haben.

Sobald Sie jedoch mit der Bearbeitung eines anderen Datensatzes beginnen, einen Filter zuweisen oder entfernen oder zu einem anderen Fenster wechseln, können Sie diese Methode des Aufhebens von Änderungen nicht verwenden.


 Welchen Einfluss haben der Datentyp eines Feldes und die Gültigkeitsprüfung auf die Dateneingabe in der Datenblattansicht oder der Formularansicht?

Welchen Einfluss haben der Datentyp eines Feldes und die Gültigkeitsprüfung auf die Dateneingabe in der Datenblattansicht oder der Formularansicht?

Wenn Sie versuchen, ein Feld nach dem Ändern von Daten zu verlassen, überprüft Microsoft Access die Daten, um sicherzustellen, dass der eingegebene Wert in diesem Feld zulässig ist. Ist der Wert nicht erlaubt, zeigt Microsoft Access eine Warnmeldung an. Um das Feld verlassen zu können, müssen Sie entweder die Daten in einen gültigen Wert ändern oder Ihre Änderungen rückgängig machen.

Ein Wert kann aus folgenden Gründen in einem Feld nicht zulässig sein:

  • Der Wert ist nicht kompatibel zum Datentyp des Feldes. Wenn Sie einen Wert eingeben, der nicht mit dem Datentyp übereinstimmt, versucht Microsoft Access, den Eintrag in den korrekten Datentyp umzuwandeln. Es gibt jedoch Daten, die nicht in andere Datentypen umgewandelt werden können. Sie können z.B. keinen Namen in einem Feld vom Datentyp Zahl in einer Microsoft Access-Datenbank oder in einem Feld des Datentyps smallint in einem Microsoft Access-Projekt speichern.

  • Die Daten verletzen eine der Regeln in der Eigenschaft Gültigkeitsregel des Feldes.

  • In das Feld müssen Daten eingegeben werden. Sie haben jedoch versucht, es leer zu lassen.

  • Das für die Eigenschaft VorAktualisierung angegebene Gültigkeitsmakro hat die Aktualisierung abgebrochen.

Microsoft Access führt auch eine Überprüfung der Daten durch, wenn Sie einen ganzen Datensatz verlassen. Bevor ein Datensatz gespeichert wird, stellt Microsoft Access sicher, dass keine der Gültigkeitsregeln in der Eigenschaft Gültigkeitsregel des Datensatzes verletzt wird. Wenn die Tabelle, an der Sie gerade arbeiten, einen Primärschlüssel oder einen eindeutigen Index besitzt, achtet Microsoft Access auch darauf, dass der Wert des Feldes bzw. der Felder im gerade bearbeiteten Datensatz nicht mit dem eines anderen Datensatzes der Tabelle identisch ist. Wenn der Datensatz nicht gespeichert werden kann, müssen Sie entweder die notwendigen Korrekturen vornehmen oder auf Rückgängig [image] klicken, um alle Änderungen am Datensatz aufzuheben.


 Auswählen von Feldern und Datensätzen in der Datenblattansicht

Auswählen von Feldern und Datensätzen in der Datenblattansicht

In der folgenden Tabelle sind die verschiedenen Verfahren aufgeführt, um mit der Maus Daten oder Datensätzen in der Datenblattansicht auszuwählen.

Auswählen | Klicken
Daten in einem Feld | Auf die Stelle, an der die Markierung beginnen soll und Ziehen über die gewünschten Daten.
Ein ganzes Feld | Auf die Stelle an der linken Ecke eines Feldes in einem Datenblatt, an der sich der Zeiger in [image] umwandelt.
Aufeinander folgende Felder | Auf die linke Ecke eines Feldes und Ziehen, um die Auswahl auszudehnen.
Eine Spalte | Auf den Feldmarkierer.
Nebeneinander liegende Spalten | Auf den Feldnamen ganz oben in der Spalte und Ziehen, um die Auswahl auszudehnen.
Einen Datensatz | Auf den Datensatzmarkierer.
Mehrere Datensätze | Auf den Datensatzmarkierer des ersten auszuwählenden Datensatzes und Ziehen, um die Auswahl auszudehnen.
Alle Datensätze | Im Menü Bearbeiten auf Alle Datensätze markieren.

In der folgenden Tabelle sind die Tastaturbefehle zum Auswählen von Daten und Datensätzen in der Datenblattansicht aufgelistet.

Auswählen | Aktion
Daten in einem Feld | Bewegen Sie die Einfügemarke an den Anfang des zu markierenden Textes, halten Sie die UMSCHALTTASTE gedrückt, und drücken Sie die entsprechenden Pfeiltasten, um sich zum Ende des zu markierenden Textes zu bewegen.
Ein ganzes Feld | Bewegen Sie die Einfügemarke auf das auszuwählende Feld, und drücken Sie die F2-TASTE.
Aufeinander folgende Felder | Wählen Sie ein Feld aus, halten Sie die UMSCHALTTASTE gedrückt, und drücken Sie die entsprechende Pfeiltaste.
Die aktuelle Spalte | Drücken Sie STRG+LEERTASTE.
Den aktuellen Datensatz | Drücken Sie UMSCHALT+LEERTASTE.
Mehrere Datensätze | Drücken Sie UMSCHALT+LEERTASTE und dann UMSCHALT+NACH-OBEN oder UMSCHALT+NACH-UNTEN.


 Erweitern eines Feldes oder Textfelds zur Erleichterung der Bearbeitung

Erweitern eines Feldes oder Textfelds zur Erleichterung der Bearbeitung

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Klicken Sie auf das zu bearbeitende Feld.

  3. Drücken Sie die Tastenkombination UMSCHALT+F2.

Anmerkung Sie können zum Erweitern des Einstellungsfelds für eine Eigenschaft in einem Eigenschaftenfenster auch mit der rechten Maustaste auf das Einstellungsfeld und dann auf Zoom klicken.


 Wann können Daten aus einer Abfrage aktualisiert werden?

Wann können Daten aus einer Abfrage aktualisiert werden?

In bestimmten Fällen können Sie die Daten in der Datenblattansicht der Abfrage bearbeiten, wenn Sie die Daten in der zugrunde liegenden Tabelle ändern möchten. In anderen Fällen ist dies nicht möglich. Die nachstehende Tabelle zeigt, wann die Ergebnisse einer Abfrage aktualisiert werden können.

Abfrage oder Abfragefeld | Aktualisierbar | Anmerkungen
Abfrage auf der Basis einer Tabelle | Ja |
Abfrage auf der Basis von Tabellen mit einer 1:1-Beziehung | Ja |
Abfrage auf der Basis von Tabellen mit einer 1:n-Beziehung | Normalerweise ja | Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
Abfrage auf der Basis von mindestens drei Tabellen mit einer 1:n-Beziehung | Nein | Obwohl Sie die Daten in der Abfrage nicht direkt aktualisieren können, können Sie diese jedoch in einem Formular oder in einer Datenzugriffsseite auf der Basis der Abfrage aktualisieren, sofern für dieses Formular die Eigenschaft Datensatzgruppentyp auf Dynaset (Inkonsistente Aktualisierungen) eingestellt ist.
Kreuztabellenabfrage | Nein |
SQL Pass-Through-Abfrage | Nein |
Abfrage, die für die Werte eines Feldes die Summe, den Mittelwert, die Anzahl oder eine andere Funktion berechnet, oder eine Aktualisierungsabfrage, die auf ein Feld in der Zeile Aktualisieren einer Kreuztabellen-, Auswahl- oder Unterabfrage verweist, die Funktionen oder Aggregatfunktionen enthält | Nein | Wenn Sie in der Zeile Aktualisieren einer Aktualisierungsabfrage eine Aggregatfunktion für Domänen verwenden, können Sie auf Felder einer Kreuztabellen-, Auswahl- oder Unterabfrage verweisen, die Funktionen oder Aggregatfunktionen enthält. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
Union-Abfrage | Nein |
Abfrage, deren Eigenschaft KeineDuplikate auf Ja eingestellt ist | Nein |
Abfrage, die eine verknüpfte ODBC-Tabelle ohne eindeutigen Index oder eine Paradox-Tabelle ohne Primärschlüssel enthält. | Nein |
Abfrage (oder zugrunde liegende Tabelle), für die keine Berechtigung zum Aktualisieren erteilt wurde | Kann gelöscht, jedoch nicht aktualisiert werden | Zum Ändern von Daten müssen Berechtigungen erteilt werden. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .
Abfrage (oder zugrunde liegende Tabelle), für die keine Berechtigung zum Löschen erteilt wurde | Kann aktualisiert, jedoch nicht gelöscht werden | Zum Löschen von Daten müssen Berechtigungen erteilt werden. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .
Abfrage auf der Basis mehrerer Tabellen oder Abfragen, in der die Tabellen oder Abfragen in der Entwurfsansicht nicht durch eine Verknüpfungslinie verknüpft sind | Nein | Um die Tabellen aktualisieren zu können, müssen Sie sie miteinander verknüpfen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
Berechnetes Feld | Nein |
Feld ist schreibgeschützt; die Datenbank wurde als schreibgeschützte Datenbank geöffnet oder befindet sich auf einem schreibgeschützten Laufwerk | Nein |
Feld in einem Datensatz, der gelöscht oder von einem anderen Benutzer gesperrt wurde | Nein | Ein gesperrter Datensatz kann normalerweise nach Aufhebung der Sperrung sofort wieder aktualisiert werden
Feld vom Datentyp Memo, Hyperlink oder OLE-Objekt in den Abfrageergebnissen | Ja |


 Kopieren oder Verschieben eines Feldes, Steuerelements, Textes, einer Makroaktion oder eines anderen Elements

Kopieren oder Verschieben eines Feldes, Steuerelements, Textes, einer Makroaktion oder eines anderen Elements

Sie können Objekte wie Felder, Steuerelemente, Text oder Makroaktionen kopieren oder verschieben. Außerdem können Sie Datenbankobjekte kopieren. Informationen über das Kopieren von Datenbankobjekten.

  1. Markieren Sie die Elemente, die Sie kopieren oder verschieben möchten.

  2. Um ein Element zu kopieren, klicken Sie in der Symbolleiste auf Kopieren [image] .

    Um ein Element zu verschieben, klicken Sie in der Symbolleiste auf Ausschneiden [image] .

  3. Klicken Sie auf die Stelle, an der Sie das Element platzieren möchten.

  4. Klicken Sie in der Symbolleiste auf Einfügen [image] .

Anmerkungen

  • Wenn Sie ein Feld, ein Steuerelement oder eine Makroaktion kopieren, schließt Microsoft Access alle zugehörigen Eigenschaften, Steuerelemente oder Aktionsargumente mit ein. Beim Kopieren eines Textfeld-Steuerelements kopiert Access beispielsweise auch dessen Bezeichnungsfeld. Beim Kopieren einer Aktion durch Klicken auf den Zeilenmarkierer kopiert Access auch die zugehörigen Aktionsargumente, Makros und bedingten Ausdrücke.

  • Access kopiert nicht zu einem Steuerelement gehörige Ereignisprozeduren.

  • Die Office-Zwischenablage können Sie zum Zusammenstellen und Einsetzen mehrerer Datenelemente, beispielsweise Datensätze, Datensatzgruppen oder Inhalte von Feldern und Steuerelementen, verwenden. In der Office-Zwischenablage können Sie jedoch keine Steuerelemente, Makroaktionen oder Datenbankobjekte zusammenstellen. Weitere Informationen zum Zusammenstellen und Einsetzen mehrerer Elemente.


Löschen eines Feldes, eines Steuerelements, eines Textes, einer Makroaktion oder eines anderen Elements

  1. Markieren Sie das oder die Elemente, die Sie löschen möchten.

    Weitere Informationen zum Markieren mehrerer Steuerelemente anzeigen.

  2. Drücken Sie ENTF.


 Auswählen von Feldern und Datensätzen in der Datenzugriffsseitenansicht

Auswählen von Feldern und Datensätzen in der Datenzugriffsseitenansicht

Die nachstehende Tabelle zeigt verschiedene Verwendungsmöglichkeiten der Maus zum Auswählen von Daten oder Datensätzen in der Datenzugriffsseitenansicht.

Zum Auswählen | Klicken auf
Daten in einem Feld | Beginn der Auswahl und Markierung
eines vollständigen Feldes | Dreimal
Ein Datensatz | Klicken Sie auf ein beliebiges Feld auf einer gruppierten Datenzugriffsseite.

Die nachstehende Tabelle zeigt verschiedene Verwendungsmöglichkeiten der Tastatur zum Auswählen von Daten oder Datensätzen in der Datenzugriffsseitenansicht.

Zum Auswählen | einer Aktion
von Daten in einem Feld | Setzen Sie die Einfügemarke an den Anfang des gewünschten Textes, halten Sie die UMSCHALTTASTE gedrückt, und drücken Sie die Pfeiltasten, um ans Ende der Auswahl zu gehen.
Ein vollständiges Feld | Setzen Sie die Einfügemarke an eine beliebige Stelle im Feld und drücken Sie POS 1, UMSCHALTTASTE+ENDE
Ein Datensatz | Drücken Sie auf einer gruppierten Datenzugriffsseite TAB.

Anmerkung Möglicherweise verfügt die Datenzugriffsseite über ein PivotTable-Listen- oder ein Kalkulationstabellen-Steuerelement, für die eigene Auswahlmethoden gelten. Um die Hilfe für PivotTable-Listen oder Kalkulationstabellen anzuzeigen, klicken Sie in der entsprechenden Symbolleiste auf Hilfe [image].


 Bearbeiten der Daten in einem Feld in der Datenzugriffsseitenansicht

Bearbeiten der Daten in einem Feld in der Datenzugriffsseitenansicht

  1. Wechseln Sie zu dem Datensatz, den Sie bearbeiten möchten, oder suchen Sie den Datensatz mit Hilfe eines Filters.

  2. Klicken Sie auf das Feld, das Sie bearbeiten möchten.

  3. Geben Sie den Text ein, den Sie einfügen möchten.

Anmerkungen

  • Wenn Ihnen ein Tippfehler unterläuft, drücken Sie die RÜCKTASTE. Wenn Sie die Änderungen im aktuellen Feld abbrechen möchten, drücken Sie ESC. Wenn Sie die Änderungen im ganzen Datensatz rückgängig machen möchten, klicken Sie in der Datensatznavigationsleiste auf Rückgängig: Datensatz [image] .

  • Änderungen werden automatisch gespeichert, wenn Sie zu einem anderen Datensatz wechseln, einen Filter anwenden oder entfernen oder zu einer anderen Webseite wechseln.


 Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen in Datenzugriffsseitenansicht rückgängig machen

Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen in Datenzugriffsseitenansicht rückgängig machen

  • Klicken Sie auf Rückgängig: Datensatz [image] auf der Datensatznavigationsleiste

Sobald Sie mit der Bearbeitung eines anderen Datensatzes beginnen, einen Filter zuweisen oder entfernen oder zu einer anderen Webseite wechseln, können Sie Ihre Änderungen nicht mehr rückgängig machen.


 Anzeigen der aktuellsten Daten in der Datenzugriffsseitenansicht

Anzeigen der aktuellsten Daten in der Datenzugriffsseitenansicht

Wenn andere Benutzer gleichzeitig Daten eingeben, werden möglicherweise auf Ihrer Datenzugriffsseite nicht die neuesten Änderungen der Microsoft Access-Datenbank bzw. des Microsoft Access-Projekts angezeigt. Sie können die aktuellen Daten aus der Datenbank laden.

  • Klicken Sie mit der rechten Maustaste auf die Seite, und klicken Sie dann auf Aktualisieren oder drücken Sie F5.

Achtung Wenn Sie auf Aktualisieren klicken, bevor Sie Ihre Änderungen gespeichert haben, werden Sie von Microsoft Access darauf hingewiesen, dass Ihre Änderungen verloren gehen können. Klicken Sie dann auf Abbrechen, um zu verhindern, dass Ihre Änderungen am aktuellen Datensatz verloren gehen.

Anmerkungen

  • Wenn das Laden der Daten sehr lange dauert und Sie den Vorgang abbrechen möchten, drücken Sie ESC.

  • Es ist möglich, dass Ihre Datenzugriffsseite über ein Steuerelement für eine PivotTable-Liste verfügt, die eine eigene Aktualisierungsmethode hat. Zum Anzeigen der Hilfe für eine PivotTable-Liste klicken Sie auf der Symbolleiste der PivotTable-Liste auf ? .


 Eingeben eines Hyperlinks durch Einfügen des Hyperlinks oder der Hyperlinkadresse

Eingeben eines Hyperlinks durch Einfügen des Hyperlinks oder der Hyperlinkadresse

  1. Wechseln Sie mit einem der folgenden Verfahren zu einem Hyperlink oder einer Hyperlinkadresse:
    • Öffnen Sie ein Microsoft Office-Dokument, das einen definierten Hyperlink enthält.

    • Öffnen Sie ein Dokument, das mit einem beliebigen Anwendungsprogramm erstellt wurde und eine gültige Hyperlinkadresse enthält, die nicht als Hyperlink definiert ist.

    • Öffnen Sie einen Webbrowser, wie beispielsweise Microsoft Internet Explorer.
  2. Führen Sie einen der folgenden Schritte aus:
    • In einem Microsoft Office-Dokument klicken Sie mit der rechten Maustaste auf den definierten Hyperlink. Zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Hyperlink kopieren.

    • In jedem anderen Dokument wählen Sie die Hyperlinkadresse aus, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

    • Wählen Sie im Internet Explorer die Adresse im Feld Adresse aus, oder wählen Sie eine gültige Hyperlinkadresse an einer beliebigen Stelle einer Seite aus, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Kopieren oder auf Shortcut kopieren.

    Anmerkung Stellen Sie beim Kopieren eines definierten Hyperlinks aus einem Office-Dokument sicher, dass nur der Hyperlink kopiert wird. Wenn Sie nicht zum Hyperlink gehörende Zeichen davor und/oder dahinter mitkopieren, verknüpft Microsoft Access mit dem markierten Text statt mit der Adresse des Hyperlinks.

  3. Wechseln Sie zu Microsoft Access, und führen Sie einen der folgenden Schritte durch:
    • In einer Microsoft Access-Datenbank (.mdb) öffnen Sie die Tabelle oder Abfrage in der Datenblattansicht.

    • In einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) öffnen Sie das Formular in der Datenblattansicht oder in der Formularansicht.
  4. Setzen Sie die Einfügemarke in dem Datenblatt in das Hyperlink-Feld oder in dem Formular in das Textfeld bzw. andere Steuerelement, das Hyperlinks akzeptiert.

  5. Führen Sie einen der folgenden Schritte aus:
    • Um einen definierten Hyperlink einzufügen, klicken Sie im Menü Bearbeiten auf Als Hyperlink einfügen.

    • Um eine Hyperlinkadresse einzufügen, die nicht als Hyperlink definiert ist, klicken Sie im Menü Bearbeiten auf Einfügen. Wenn Sie eine Adresse auf diese Weise einfügen, erkennt Microsoft Access das Protokoll in der Adresse und wandelt den Text in einen Hyperlink um.

    Microsoft Access fügt den Hyperlink dem Feld oder Steuerelement hinzu. Sie können auf den Hyperlink klicken, um das Zieldokument oder die Ziel-Webseite zu öffnen.


 Eingeben eines Hyperlinks durch Ziehen einer Internet-Verknüpfung

Eingeben eines Hyperlinks durch Ziehen einer Internet-Verknüpfung

  1. Gehen Sie in Microsoft Access nach einer der folgenden Methoden vor:
    • Öffnen Sie die Tabelle oder Abfrage in einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblattansicht bzw. in der Formularansicht. Wenn es sich um eine Datenzugriffsseite handelt, öffnen Sie diese in der Datenzugriffsseitenansicht.
  2. Wechseln Sie zu einer Internet-Verknüpfung (einem Symbol auf Ihrem Desktop oder einem Element im Ordner Verlauf, einem Unterordner des Ordners Windows).

  3. Markieren Sie die Internet-Verknüpfung.

  4. Klicken Sie mit der rechten Maustaste auf die Markierung, und ziehen Sie die Verknüpfung auf dem Datenblatt oder dem Textfeld auf das Hyperlink-Feld oder auf ein anderes Steuerelement des Formulars oder der Datenzugriffsseite, für das Hyperlinks zulässig sind.

    Microsoft Access fügt den Hyperlink zum Feld oder Steuerelement hinzu. Auf einem Formular oder auf einem Datenblatt können Sie auf den Hyperlink klicken, um das Zieldokument oder die Webseite zu öffnen. Auf einer Datenzugriffsseite wird das Textfeld, in das Sie eine Hyperlinkadresse eingeben, nicht automatisch als Hyperlink formatiert. Prüfen Sie, ob die Adresse an einer anderen Stelle auf der Seite als Hyperlink formatiert ist.

Tipp Klicken Sie auf der Symbolleiste von Internet Explorer auf die Schaltfläche Aktualisieren, um zu prüfen, ob die Hyperlinkadresse als formatierter Hyperlink angezeigt wird.


 Eingeben eines Hyperlinks in einem Feld oder Textfeld

Eingeben eines Hyperlinks in einem Feld oder Textfeld

  1. Öffnen Sie die Tabelle, Abfrage oder das Formular in der Datenblattansicht, das Formular in der Formularansicht oder die Datenzugriffsseite in der Seitenansicht.

  2. Positionieren Sie die Einfügemarke in das Hyperlink-Feld im Datenblatt, Textfeld oder einem anderem Steuerelement, das im Textfeldteil einen Hyperlink anzeigt.

  3. Geben Sie eine gültige Hyperlinkadresse ein. Eine Hyperlinkadresse kann aus bis zu vier Teilen bestehen, die durch ein Nummernzeichen (#) voneinander getrennt sind:

    Anzeigetext#Adresse#Unteradresse#Quickinfo

    Das folgende Beispiel enthält Anzeigetext, Adresse und QuickInfo. Beachten Sie, dass es auch das Nummernzeichen # für Unteradresse enthält, das weggelassen wurde:

    Microsoft Corporation#http://example.microsoft.com/##Beispielseite für Microsoft Corporation

Zum Anzeigen von Informationen zu Hyperlinkadressen klicken Sie auf [image] .

Microsoft Access fügt den Hyperlink dem Feld oder Steuerelement hinzu.

Anmerkung

  • In einer Microsoft Access-Datenbank können Sie das Zieldokument oder die Webseite öffnen, indem Sie auf den Hyperlink in einer Tabelle, Abfrage oder einem Formular in Datenblatt- oder Formularansicht klicken.

  • In einem Microsoft Access-Projekt können Sie das Zieldokument oder die Webseite öffnen, indem Sie auf den Hyperlink in einem Formular in Formular- oder Datenblattansicht klicken. In der Datenblattansicht einer Tabelle, Abfrage oder gespeicherten Prozedur wird die Hyperlinkadresse als Textzeichenfolge und nicht als formatierter Hyperlink angezeigt.

  • In einer Datenzugriffsseite zeigt das Textfeld, in das Sie eine Hyperlinkadresse eingeben, diese als Textzeichenfolge und nicht als formatierten Hyperlink an. Die als Hyperlink formatierte Adresse finden Sie an anderer Stelle auf der Seite.

    Das QuickInfo, das für einen Hyperlink auf einer Datenzugriffsseite angezeigt wird, ist für das Hyperlink-Steuerelement definiert, sodass ein von Ihnen eingegebenes QuickInfo auf der Seite nicht angezeigt wird.

    Klicken Sie im Microsoft Internet Explorer auf die Schaltfläche Jetzt aktualisieren, damit Sie die Hyperlinkadresse als formatierten Hyperlink auf der Datenzugriffsseite sehen können.


 Hinzufügen, Ändern oder Löschen der Adresse einer Grafik in der Seitenansicht

Hinzufügen, Ändern oder Löschen der Adresse einer Grafik in der Seitenansicht

Anmerkung Das Bild wird nicht in der Datenbank gespeichert. Stattdessen wird die Adresse der Grafik in der Datenbank und die Grafik selber im Dateisystem des Computers gespeichert.

  1. Gehen Sie zu dem Datensatz oder verwenden Sie einen Filter, um den Datensatz zu suchen, der die Adresse der Grafik enthält, die Sie hinzufügen, ändern oder löschen möchten.

  2. Klicken Sie auf das Feld, das die Adresse der Grafik enthält.

  3. Führen Sie einen der folgenden Schritte aus:

    Um die Adresse der Grafik hinzuzufügen, geben Sie die Adresse ein.

    Um die Adresse der Grafik zu ändern, bearbeiten Sie diese. Weitere Informationen über das Bearbeiten eines Feldes.

    Um die Adresse der Grafik zu löschen, wählen Sie den gesamten Feldinhalt aus und drücken dann die ENTF-TASTE.

Anmerkungen

  • Um Ihre Ergebnisse in der Datenzugriffsseite anzuzeigen, speichern Sie den Datensatz und aktualisieren dann die Datenzugriffsseite.

  • Die Adresse kann eine relative Adresse, eine Adresse auf Ihrem Computer, ein UNC-Pfad (Universal Naming Convention) oder ein URL (Uniform Resource Locator) sein. Welchen Adress-Typ Sie verwenden, ist abhängig von den Anforderungen Ihrer Datenbank.

  • Um die Grafik zu löschen, müssen Sie diese an der entsprechenden Position im Dateisystem löschen. Abhängig davon, wie die Seite erstellt worden ist, ist dies möglicherweise nicht direkt von der Seite aus möglich. Weitere Informationen zum Löschen von Dateien finden Sie in der Microsoft Windows-Hilfe.


 Hinzufügen eines neuen Datensatzes in der Datenzugriffsseitenansicht

Hinzufügen eines neuen Datensatzes in der Datenzugriffsseitenansicht

  1. Klicken Sie auf der Datensatznavigationsleiste auf Neuer Datensatz [image].

  2. Geben Sie die gewünschten Daten in das erste Feld ein, und drücken Sie danach TAB, um zum nächsten Feld zu wechseln.

  3. Wenn die Eingabe von Daten in die Felder abgeschlossen ist, klicken Sie auf Datensatz speichern [image] ,um den Datensatz zu speichern.

Anmerkung Der Datensatz wird automatisch gespeichert, sobald Sie mit der Bearbeitung eines anderen Datensatz beginnen, einen Filter anwenden bzw. entfernen oder zu einer anderen Webseite wechseln.


 Speichern eines Datensatzes in der Datenzugriffsseitenansicht

Speichern eines Datensatzes in der Datenzugriffsseitenansicht

  • Klicken Sie auf Datensatz speichern [image] in der Datensatznavigationsleiste, um die Daten ausdrücklich während ihrer Bearbeitung in einem Datensatz zu speichern.

Anmerkung Der Datensatz wird automatisch gespeichert, wenn Sie zu einem anderen Datensatz wechseln, einen Filter übernehmen oder entfernen oder zu einer anderen Webseite wechseln.


 Löschen eines Datensatzes in der Seitenansicht

Löschen eines Datensatzes in der Seitenansicht

Wichtig Wenn Sie einen Datensatz gelöscht haben, können Sie das Löschen in der Datenbank nicht mehr rückgängig machen.

  1. Wechseln Sie zu dem Datensatz oder suchen Sie mit Hilfe eines Filters den Datensatz, den Sie löschen möchten.

  2. Klicken Sie auf der Datensatznavigationsleiste auf Datensatz löschen [image] .


 Kopieren oder Verschieben von Daten aus einem Feld in ein anderes

Kopieren oder Verschieben von Daten aus einem Feld in ein anderes

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Wählen Sie die Daten aus, die Sie kopieren oder ausschneiden möchten.

    Wie wird's gemacht?

  3. Klicken Sie zum Kopieren der Daten in der Symbolleiste auf Kopieren [image] .

    Klicken Sie zum Verschieben der Daten in der Symbolleiste auf Ausschneiden [image] .

  4. Um den aktuellen Wert des Zielfelds zu ersetzen, wählen Sie das gesamte Feld aus.

    Um die Daten den bestehenden Daten hinzuzufügen, positionieren Sie die Einfügemarke an die Stelle, an der Sie die Daten einfügen möchten.

  5. Klicken Sie in der Symbolleiste auf Einfügen [image] .

    Zum Anzeigen von Informationen zur Problembehandlung beim Einfügen von Daten klicken Sie auf [image] .


 Kopieren oder Verschieben von Daten mehrerer Felder in der Datenblattansicht

Kopieren oder Verschieben von Daten mehrerer Felder in der Datenblattansicht

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Wählen Sie die Felder oder Spalten aus, die Sie kopieren oder ausschneiden möchten.

    Wie wird's gemacht?

  3. Klicken Sie zum Kopieren der Daten in der Symbolleiste auf Kopieren [image] .

    Klicken Sie zum Verschieben der Daten in der Symbolleiste auf Ausschneiden [image] .

  4. Wählen Sie die Zielfelder aus, oder wechseln Sie zu der Anwendung, in die Sie die Daten einfügen möchten, und wählen dann das Ziel aus.

  5. Klicken Sie in der Symbolleiste auf Einfügen [image] .

    Zum Anzeigen von Informationen zur Problembehandlung beim Einfügen von Daten klicken Sie auf [image] .


 Kopieren oder Verschieben von Datensätzen in ein Datenblatt

Kopieren oder Verschieben von Datensätzen in ein Datenblatt

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Wählen Sie den Datensatz bzw. die Datensätze aus, den/die Sie kopieren oder verschieben möchten.

    Wie wird's gemacht?

    Anmerkung Wenn Sie Datensätze aus einer anderen Anwendung kopieren oder verschieben möchten, achten Sie darauf, dass sich die Daten in einem Arbeitsblatt bzw. einer Tabelle befinden oder durch Tabulatorzeichen getrennt sind, bevor Sie sie auswählen.

  3. Klicken Sie zum Kopieren von Datensätzen in der Symbolleiste auf Kopieren [image] .

    Klicken Sie zum Verschieben von Datensätzen in der Symbolleiste auf Ausschneiden [image] .

  4. Öffnen Sie das Datenblatt, in das Sie die Datensätze einfügen möchten. Ordnen Sie die Spalten des Datenblatts gegebenenfalls neu an, um Sie der Reihenfolge der zu kopierenden oder zu verschiebenden Daten anzupassen.

  5. Um mit den ausgewählten Datensätzen andere Datensätze zu ersetzen, wählen Sie die zu ersetzenden Datensätze aus und klicken in der Symbolleiste auf Einfügen [image] .

    Um Datensätze am Ende des Datenblatts anzufügen, klicken Sie im Menü Bearbeiten auf Am Ende anfügen.

Wenn das Herkunftsdatenblatt mehr Felder besitzt als das Zieldatenblatt, werden die zusätzlichen Felder nicht eingefügt. Zum Anzeigen von Informationen zur Problembehandlung beim Einfügen von Daten klicken Sie auf [image] .


 Kopieren oder Verschieben von Datensätzen in ein Formular

Kopieren oder Verschieben von Datensätzen in ein Formular

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht.

  2. Wählen Sie den Datensatz bzw. die Datensätze aus, den/die Sie kopieren oder verschieben möchten.

    Wie wird's gemacht?

  3. Klicken Sie zum Kopieren von Datensätzen in der Symbolleiste auf Kopieren [image] .

    Klicken Sie zum Verschieben von Datensätzen in der Symbolleiste auf Ausschneiden [image] .

  4. Öffnen Sie das Formular, in das Sie die Datensätze einfügen möchten.

  5. Um mit den ausgewählten Datensätzen andere Datensätze zu ersetzen, wählen Sie die zu ersetzenden Datensätze aus und klicken in der Symbolleiste auf Einfügen [image] .

    Klicken Sie zum Anfügen von Datensätzen im Menü Bearbeiten auf Am Ende anfügen.

Microsoft Access fügt die Datensätze in Felder mit dem gleichen Namen wie die Herkunftsfelder ein, unabhängig von ihrer Reihenfolge im Formular. Wenn das Herkunftsformular Felder enthält, die im Zielformular nicht vorhanden sind, werden Sie von Microsoft Access gefragt, ob nur die Felder mit übereinstimmenden Namen eingefügt werden sollen. Sind keine übereinstimmenden Feldnamen vorhanden, werden die Felder entsprechend der Reihenfolge der Steuerelemente, welche unter Umständen nicht die von Ihnen gewünschte Reihenfolge ist, in das Zielformular eingefügt. Es ist daher sinnvoll, Felder mit unterschiedlichen Herkunfts- und Zielnamen in ein Datenblatt an Stelle eines Formulars einzufügen.

Zum Anzeigen von Informationen zur Problembehandlung beim Einfügen von Daten klicken Sie auf [image] .


 Kopieren oder Verschieben von Datensätzen aus Microsoft Access in ein anderes Anwendungsprogramm

Kopieren oder Verschieben von Datensätzen aus Microsoft Access in ein anderes Anwendungsprogramm

  1. Öffnen Sie ein Datenblatt oder ein Formular in der Formularansicht

  2. Wählen Sie die Daten aus, die Sie kopieren oder verschieben möchten.

    Wie wird's gemacht?

  3. Klicken Sie zum Kopieren von Daten in der Symbolleiste auf Kopieren [image] .

    Klicken Sie zum Verschieben von Daten in der Symbolleiste auf Ausschneiden [image] .

  4. Öffnen Sie das Anwendungsprogramm, in das Sie die Daten einfügen möchten.

  5. Um mit den Daten aus Microsoft Access andere Daten zu ersetzen, wählen Sie die zu ersetzenden Daten aus.

    Um die Daten den bestehenden Daten hinzuzufügen, positionieren Sie die Einfügemarke an die Stelle, an der Sie die Daten einfügen möchten.

    Anmerkung Wenn Sie Daten in eine Microsoft Excel-Tabelle einfügen möchten, wählen Sie die Zelle aus, in der sich die erste Spaltenüberschrift befinden soll. Wenn Sie Daten in ein Microsoft Word für Windows-Dokument einfügen möchten, setzen Sie die Einfügemarke an die Stelle, an der Sie die Datensätze positionieren möchten. Die Datensätze werden als Tabelle in Word eingefügt.

  6. Anmerkung Klicken Sie im Menü Bearbeiten auf Einfügen. Wenn Ihr Anwendungsprogramm diesen Befehl nicht unterstützt, verwenden Sie die in diesem Programm verfügbare Methode zum Einfügen.

Anmerkungen

  • Beim Einfügen von Datensätzen in ein anderes Anwendungsprogramm fügt Microsoft Access die Feldnamen in die erste Zeile und die Daten in die nachfolgenden Zeilen ein.

  • Wenn Sie aus einem Datenblatt kopieren, das Unterdatenblätter enthält, kann Microsoft Access gleichzeitig jeweils nur eine Ebene des Datenblatts kopieren.


 Kopieren oder Verschieben von Datensätzen aus einem anderen Anwendungsprogramm in Microsoft Access

Kopieren oder Verschieben von Datensätzen aus einem anderen Anwendungsprogramm in Microsoft Access

  1. Wählen Sie im anderen Anwendungsprogramm eine oder mehrere Zeilen, die Sie kopieren oder verschieben möchten. Wenn Sie Daten aus einem Textverarbeitungsprogramm kopieren möchten, achten Sie darauf, dass sich die Datensätze in einer Tabelle befinden oder durch Tabulatorzeichen getrennt sind, bevor Sie sie auswählen.

  2. Stellen Sie beim Einfügen in ein Datenblatt sicher, dass die Reihenfolge der Spalten mit derjenigen der zu kopierenden oder verschiebenden Daten übereinstimmt.

    Wenn Sie in ein Formular einfügen und die Namen der entsprechenden Steuerelemente im Formular mit den Spaltennamen der Daten übereinstimmen, die Sie kopieren, fügt Microsoft Access die Daten in die Steuerelemente mit den übereinstimmenden Namen ein. Wenn die Spaltennamen nicht übereinstimmen oder keine Spaltennamen vorhanden sind, fügt Microsoft Access die Daten in der Reihenfolge der Steuerelemente des Formulars ein.

  3. Klicken Sie zum Kopieren von Datensätzen im Menü Bearbeiten auf Kopieren.

    Klicken Sie zum Verschieben von Datensätzen im Menü Bearbeiten auf Ausschneiden.

    Anmerkung Wenn Ihr Anwendungsprogramm nicht über diese Befehle verfügt, verwenden Sie die in dieser Anwendung vergleichbaren Methoden.

  4. Öffnen Sie in Microsoft Access das Datenblatt oder Formular, in das Sie die Datensätze einfügen möchten.

  5. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie zum Ersetzen der Datensätze die gewünschten Datensätze aus, und klicken Sie dann in der Symbolleiste auf Einfügen [image] . Wenn in einem Formular der Datensatzmarkierer nicht sichtbar ist, klicken Sie zum Auswählen des aktuellen Datensatzes im Menü Bearbeiten auf Datensatz markieren.

    • Klicken Sie zum Anfügen der Daten als neue Datensätze im Menü Bearbeiten auf Am Ende anfügen.


 Zusammenstellen und Einfügen mehrerer Elemente

Zusammenstellen und Einfügen mehrerer Elemente

  1. Markieren Sie das erste Element, das Sie kopieren möchten.

  2. Klicken Sie in der Symbolleiste Zwischenablage auf Kopieren [image] .

    Um die Symbolleiste Zwischenablage anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken Sie dann auf Zwischenablage.

  3. Wenn sich das nächste Element, das Sie kopieren möchten, in einem anderen Programm befindet, wechseln Sie zu diesem Programm.

  4. Markieren Sie das nächste Element, das Sie kopieren möchten.

  5. Klicken Sie auf der Symbolleiste Zwischenablage auf Kopieren [image] .

    Wenn die Symbolleiste Zwischenablage nicht verfügbar ist, klicken Sie im Menü Bearbeiten auf Kopieren.

  6. Wiederholen Sie die Schritte 3 bis 5 so oft, bis Sie alle gewünschten Elemente kopiert haben (maximal 12).

  7. Klicken Sie auf die Position, an der die Elemente eingefügt werden sollen.

  8. Zum Einfügen aller kopierter Elemente, klicken Sie auf der Symbolleiste Zwischenablage auf Alle einfügen [image] .

    Wenn Sie nicht alle kopierten Elemente einfügen möchten oder wenn der Befehl Alle einfügen nicht verfügbar ist, können Sie spezifische Elemente einfügen.

Anmerkung Wenn die Symbolleiste Zwischenablage nicht verfügbar ist, befinden Sie sich in einem Programm oder einer Ansicht, das bzw. die das Anzeigen oder Einfügen mehrerer Elemente aus der Office-Zwischenablage nicht unterstützt. Wenn jedoch die Office-Zwischenablage in einem Office-Programm angezeigt wird, werden alle Elemente, die Sie in einem beliebigen Programm ausschneiden oder kopieren, automatisch in die Zwischenablage aufgenommen.


 Info über das Zusammenstellen und Einfügen mehrerer Elemente

Info über das Zusammenstellen und Einfügen mehrerer Elemente

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Kopieren mehrerer Elemente

Verwenden der Zwischenablagesymbolleiste

Die Zwischenablage in Office und in Windows

Funktionen der Office-Zwischenablage

Weitere Informationen

Kopieren mehrerer Elemente

Mit der Office-Zwischenablage können Sie mehrere Elemente zusammenstellen und einfügen. Sie können zum Beispiel in einem Word-Dokument Text kopieren, zu Microsoft Excel wechseln und ein Zeichnungsobjekt kopieren, zu Microsoft PowerPoint wechseln und eine Liste kopieren, zu Microsoft Access wechseln und ein Datenblatt kopieren und schließlich wieder zu Microsoft Word wechseln und dort die zusammengestellten kopierten Elemente einfügen. Wenn Sie nach einer der folgenden Methoden vorgehen, kopiert die Office-Zwischenablage automatisch mehrere Elemente:

  • Kopieren Sie zwei unterschiedliche Elemente nacheinander im selben Programm oder schneiden Sie diese aus

  • Kopieren Sie ein Element und fügen Sie es wieder ein, und kopieren Sie dann im selben Programm ein weiteres Element

  • Kopieren Sie ein Element zweimal nacheinander

Zurück zum Anfang

Verwenden der Zwischenablagesymbolleiste

Sie können mehrere Elemente kopieren, indem Sie die Symbolleiste Zwischenablage anzeigen (Menü Ansicht, Untermenü Symbolleisten), und dann auf Kopieren [image] klicken. Wenn Sie die Office-Zwischenablage in einem Microsoft Office-Programm öffnen, wird diese auch in anderen Programmen angezeigt. Die Symbolleiste Zwischenablage ist in den Ansichten nicht verfügbar, in denen die Befehle Kopieren, Ausschneiden und Einfügen nicht verfügbar sind.

Wenn die Symbolleiste Zwischenablage angezeigt wird, können Sie auf Alle einfügen [image] klicken, um alle kopierten Elemente einzufügen. Sie können auch auf ein einzelnes Element klicken, um nur dieses einzufügen. Mit dem Befehl Einfügen (Menü Bearbeiten) wird nur das zuletzt kopierte Element eingefügt. Wenn Sie ein Element oder alle Elemente aus der Symbolleiste Zwischenablage eingefügt haben, wird mit dem Befehl Einfügen (Menü Bearbeiten) jeweils das Element eingefügt, das zuletzt aus der Symbolleiste Zwischenablage eingefügt wurde.

Anmerkung Die Symbolleiste Zwischenablage kann nicht angepasst werden.

Zurück zum Anfang

Die Zwischenablage in Office und in Windows

Die Office-Zwischenablage ist nicht identisch mit der Windows-Zwischenablage. Wenn Sie mehrere Elemente in die Office-Zwischenablage kopieren, wird das zuletzt kopierte Element auch in die Windows-Zwischenablage übernommen. Wenn Sie die Office-Zwischenablage löschen, wird auch die Windows-Zwischenablage gelöscht. Mit dem Befehl Einfügen (Menü Bearbeiten), mit der Schaltfläche Einfügen oder mit der Tastenkombination zum Einfügen (STRG+V) fügen Sie den Inhalt der Windows-Zwischenablage ein.

Zurück zum Anfang

Funktionen der Office-Zwischenablage

Die Office-Zwischenablage kann maximal 12 Elemente aufnehmen. Enthält die Office-Zwischenablage bereits 12 Elemente und Sie kopieren ein weiteres Element, dann werden Sie in einer Meldung gefragt, ob das erste kopierte Element entfernt werden soll oder ob das aktuelle, also das dreizehnte Element, nicht kopiert werden soll. Die zusammengestellten Elemente bleiben so lange in der Office-Zwischenablage, bis Sie alle Office-Programme beenden, die auf Ihrem Computer ausgeführt werden.

Das Einfügen mehrerer Elemente und das Anzeigen der Office-Zwischenablage ist nur in den Programmen Microsoft Excel, Word, Access, Outlook und PowerPoint möglich. Wenn die Office-Zwischenablage in einem Office-Programm angezeigt wird, werden Elemente, die Sie in einem beliebigen Programm ausschneiden oder kopieren, automatisch zusammengestellt.

Zurück zum Anfang

Weitere Informationen

Zusammenstellen und Einfügen mehrerer Elemente

Einfügen spezifischer Elemente aus der Office-Zwischenablage

Löschen aller Elemente aus der Office-Zwischenablage

Zurück zum Anfang


 Löschen aller Elemente aus der Office-Zwischenablage

Löschen aller Elemente aus der Office-Zwischenablage

  • Klicken Sie auf der Symbolleiste Zwischenablage auf Zwischenablage löschen [image] .

    Zum Anzeigen der Symbolleiste Zwischenablage zeigen Sie im Menü Ansicht auf Zwischenablage, und klicken Sie dann auf Zwischenablage.


 Anzeigen des Inhalts der Office-Zwischenablage

Anzeigen des Inhalts der Office-Zwischenablage

  • Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Zwischenablage. Wenn die Symbolleiste Zwischenablage eine verankerte Symbolleiste ist, klicken Sie auf Elemente.

Tipp Zum Anzeigen der ersten 50 Zeichen eines Textes in der Office-Zwischenablage stellen Sie den Mauszeiger auf die Schaltfläche des Elements. Wenn es sich um ein Zeichnungsobjekt handelt oder wenn das Element keinen Text enthält, wird der Text "Bild n" oder "Element x" angezeigt, wobei n für eine Zahl steht, die die Position des Bildes in der Kopierreihenfolge der Zeichenobjekte und Bilder angibt, und x für eine Zahl steht, die die Position des Elements in der Kopierreihenfolge aller Elemente angibt.


 Einfügen bestimmter Elemente aus der Office-Zwischenablage

Einfügen bestimmter Elemente aus der Office-Zwischenablage

  1. Klicken Sie auf die Position, an der die Elemente eingefügt werden sollen.

  2. Klicken Sie auf der Symbolleiste Zwischenablage auf das Element, das Sie einfügen möchten.

    Wenn die Symbolleiste Zwischenablage verankert ist, klicken Sie auf Elemente, und klicken Sie dann auf das Element, das Sie einfügen möchten.

    Zum Anzeigen der Symbolleiste Zwischenablage zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Zwischenablage.

  3. Wiederholen Sie Schritt 2 für jedes Element, das Sie einfügen möchten.

Tipp Zum Anzeigen der ersten 50 Zeichen eines Textes in der Office-Zwischenablage bewegen Sie den Mauszeiger auf der Schaltfläche des Elements. Wenn es sich um ein Zeichnungsobjekt handelt oder wenn das Element keinen Text enthält, wird der Text "Bild n" oder "Element x" angezeigt, wobei n für eine Zahl steht, die die Position des Bildes in der Kopierreihenfolge der Zeichenobjekte und Bilder angibt, und wobei x für eine Zahl steht, die die Position des Elements in der Kopierreihenfolge aller Elemente angibt.


 Anzeigen von Daten aus einem Feld in einer Tabelle oder Abfrage

Anzeigen von Daten aus einem Feld in einer Tabelle oder Abfrage

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wenn Sie zum Erstellen des Steuerelements einen Assistenten verwenden möchten, müssen Sie sicherstellen, dass das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist.

    Anmerkungen

    • In Formularen und Berichten können Sie zum Erstellen von Befehlsschaltflächen, Listenfeldern, Unterformularen, Kombinationsfeldern und Optionsgruppen Assistenten verwenden. Auf Datenzugriffsseiten können Sie mit Assistenten Befehlsschaltflächen, Listenfelder und Dropdownlisten erstellen.

    • Assistenten sind nicht verfügbar, wenn Sie eigenständige Datenzugriffsseiten verwenden, oder wenn Sie in einer Datenzugriffsseite auf eine andere Datenbank als die aktuell geöffnete verweisen. In diesen Fällen müssen Sie das Steuerelement ohne Hilfe eines Assistenten erstellen.
  3. Zeigen Sie die Feldliste an, indem Sie in der Symbolleiste auf Feldliste [image] klicken.

  4. Führen Sie einen der folgenden Schritte durch:
    • Wählen Sie in einem Formular oder Bericht ein oder mehrere Felder in der Feldliste aus.
    Auszuwählendes Element | Vorgehensweise
    Ein Feld | Klicken Sie auf das Feld.
    Ein Feldblock | Klicken Sie auf das erste Feld des gewünschten Blocks, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf das letzte Feld des Blocks.
    Nichtangrenzende Felder | Halten Sie STRG gedrückt, und klicken Sie dann nacheinander auf die Namen aller Felder, die Sie verwenden möchten.
    Alle Felder | Doppelklicken Sie auf die Titelleiste der Feldliste.

    • Wählen Sie auf einer Datenzugriffsseite in der Feldliste ein Feld, eine Tabelle oder eine Abfrage aus.
    Auszuwählendes Element | Vorgehensweise
    Ein Feld | Klicken Sie auf das Feld.
    Eine Tabelle oder Abfrage | Klicken Sie in der Toolbox auf das Tool Assistenten [image] , falls es noch nicht aktiviert ist, und klicken Sie dann auf die Tabelle oder Abfrage.

  5. Führen Sie einen der folgenden Schritte durch:
    • Ziehen Sie das Feld oder mehrere Felder aus der Feldliste, und positionieren Sie es/sie im Formular oder Bericht.
    • Ziehen Sie das Feld, die Tabelle oder die Abfrage aus der Feldliste und positionieren Sie es/sie auf der Datenzugriffsseite. Klicken Sie im Dialogfeld Layout-Assistent auf Einzelne Steuerelemente.

    • Anmerkung Sie müssen Felder, Tabellen oder Abfragen aus der Feldliste ziehen. Wenn Sie die Felder, Tabellen oder Abfragen in der Feldliste nur anklicken und dann auf das Formular, den Bericht oder die Datenzugriffsseite klicken, erstellt Microsoft Access das Steuerelement nicht. Access fügt in das Formular, den Bericht oder die Datenzugriffsseite ein Textfeld für jedes Feld ein, das Sie in der Feldliste auswählen. Falls Sie eine Tabelle oder Abfrage in der Feldliste der Datenzugriffsseite auswählen, fügt Access ein Textfeld für jedes Feld in der Tabelle oder Abfrage in die Datenzugriffsseite ein. Jedes Textfeld ist an ein Feld in der zugrunde liegenden Datenquelle gebunden. Zudem wird jedem Textfeld standardmäßig ein Bezeichnungsfeld hinzugefügt.
  6. Setzen Sie die obere linke Ecke des jeweiligen Symbols an die Stelle, an der die obere linke Ecke des eigentlichen Steuerelements (nicht des Bezeichnungsfelds) angezeigt werden soll, und lassen Sie dann die Maustaste los.

Anmerkungen

  • Microsoft Access erstellt das entsprechende Steuerelement für das Feld und legt bestimmte Eigenschaften auf der Basis des Datentyps des Feldes fest. Ist dies nicht das gewünschte Steuerelement, klicken Sie vor dem Ziehen des Feldes aus der Feldliste auf das entsprechende Steuerelement in der Toolbox. In Formularen und Berichten werden Steuerelemente auch entsprechend der Einstellung der SteuerelementAnzeigen-Eigenschaft festgelegt. Zum Anzeigen von Informationen zur SteuerelementAnzeigen-Eigenschaft klicken Sie auf [image] .

  • In Formularen und Berichten können Sie ein Steuerelement nach dem Erstellen auch in einen anderen Steuerelementtyp ändern.

Wie wird's gemacht?


 Anzeigen von Daten, Text oder Summen in Formularen, Berichten oder Datenzugriffsseiten

Anzeigen von Daten, Text oder Summen in Formularen, Berichten oder Datenzugriffsseiten

Alle Elemente, die Sie einem Formular, einem Bericht oder einer Datenzugriffsseite hinzufügen, sind Steuerelemente unterschiedlichen Typs. Dazu gehören Textfelder, Bezeichnungsfelder, Listenfelder, Optionsfelder, Befehlsschaltflächen und Linien. Wie Sie ein Steuerelement erstellen, ist abhängig davon, ob Sie ein gebundenes Steuerelement, ein ungebundenes Steuerelement oder ein berechnetes Steuerelement erstellen möchten.

Was möchten Sie tun?

Weitere Informationen zu gebundenen, ungebundenen und berechneten Steuerelementen erhalten

Weitere Informationen über das Hinzufügen von Daten zu einer Datenzugriffsseite mit Hilfe der Feldliste erhalten

Ein gebundenes Steuerelement erstellen

Ein ungebundenes Steuerelement erstellen

Ein berechnetes Steuerelement erstellen

Einen bestimmten Steuerelementtyp in einem Formular erstellen (beispielsweise ein Textfeld, ein Kontrollkästchen, ein Listenfeld usw.)

Einen bestimmten Steuerelementtyp in einem Bericht erstellen (beispielsweise ein Bezeichnungsfeld, ein Textfeld, ein Kontrollkästchen usw.)

Einen bestimmten Steuerelementtyp in einer Datenzugriffsseite erstellen (beispielsweise ein Textfeld, ein Kontrollkästchen, ein Listenfeld usw.)


 Eingeben einer Hyperlinkadresse in der Datenzugriffsseitenansicht

Eingeben einer Hyperlinkadresse in der Datenzugriffsseitenansicht

Es gibt mehrere Möglichkeiten, bei Datensätzen mit jeweils unterschiedlichen Hyperlinks eine Hyperlinkadresse in der Datenzugriffsseitenansicht einer Datenzugriffsseite einzugeben. Das Textfeld auf der Datenzugriffsseite, in das Sie die Hyperlinkadresse eingeben, formatiert die Adresse nicht als Hyperlink. Suchen Sie die als Hyperlink formatierte Adresse an anderer Stelle auf der Seite.

Einen Hyperlink oder eine Hyperlinkadresse einfügen

Eine Internet-Verknüpfung durch Ziehen einfügen

Eine Hyperlinkadresse eingeben


 Öffnen eines Hyperlinks

Öffnen eines Hyperlinks

  1. Öffnen Sie die Tabelle, die Abfrage oder das Formular in der Datenblattansicht, das Formular in der Formularansicht oder die Datenzugriffsseite in der Seitenansicht.

  2. Halten Sie den Mauszeiger über den Hyperlink. Wenn sich der Zeiger in eine Hand verwandelt, klicken Sie auf den Hyperlink.

    Bevor Sie auf einen Hyperlink klicken, ist dieser standardmäßig blau und unterstrichen formatiert. Nach dem Klicken ist er standardmäßig lila und unterstrichen formatiert. Um Informationen über das Ändern des Standardformats anzuzeigen, klicken Sie auf [image] .


 Ändern eines Hyperlinks, der in einer Tabelle gespeichert ist, in der Formularansicht oder der Datenblattansicht

Ändern eines Hyperlinks, der in einer Tabelle gespeichert ist, in der Formularansicht oder der Datenblattansicht

  1. Führen Sie einen der folgenden Schritte aus:
    • Öffnen Sie die Tabelle oder Abfrage in einer Microsoft Access-Datenbank (.MDB) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.ADP) in der Datenblattansicht oder der Formularansicht.
  2. Klicken Sie mit der rechten Maustaste im Datenblatt auf das Hyperlink-Feld. Klicken Sie im Formular mit der rechten Maustaste auf das Textfeld oder das Kombinationsfeld, das den Hyperlink enthält.

  3. Um den Anzeigetext hinzuzufügen oder zu ändern, zeigen Sie im Kontextmenü auf Hyperlink. Geben Sie im Feld Text anzeigen als den gewünschten Text ein.

  4. Um eine Hyperlinkadresse zu ändern, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Hyperlink bearbeiten.

  5. Klicken Sie im Dialogfeld Hyperlink bearbeiten auf eine Option unter Link zu, und geben Sie dann die für diese Option erforderlichen Informationen ein.

Anmerkung In einem Access-Projekt können Sie einen Hyperlink in einem Tabellen- oder Abfragedatenblatt durch Eingabe in das Hyperlink-Feld ändern. Um Informationen zu der Syntax anzuzeigen, die für die Eingabe eines Hyperlinks erforderlich ist, klicken Sie auf [image] .


 Löschen eines in einer Tabelle gespeicherten Hyperlinks in der Formular- oder Datenblattansicht

Löschen eines in einer Tabelle gespeicherten Hyperlinks in der Formular- oder Datenblattansicht

  1. Führen Sie einen der folgenden Schritte durch:
    • Öffnen Sie eine Tabelle oder Abfrage in einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie ein Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblattansicht oder in der Formularansicht.
  2. Wechseln Sie zu dem Datensatz, der den Hyperlink enthält, den Sie löschen möchten.

  3. Klicken Sie auf einem Datenblatt mit der rechten Maustaste im Datenblatt auf das Hyperlink-Feld. Klicken Sie in einem Formular mit der rechten Maustaste auf das Textfeld oder das Kombinationsfeld, das den Hyperlink enthält.

  4. Zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Hyperlink entfernen.

Anmerkungen

  • Sie können in einem Access-Projekt einen Hyperlink in einer Tabelle oder Abfrage eines Datenblattes löschen, indem Sie den Feldinhalt markieren und dann ENTF drücken.

  • In einer Access-Datenbank und in einem Access-Projekt löschen Sie die Hyperlinks, die in einer Tabelle gespeichert sind, indem Sie das Feld, in dem die Hyperlinks gespeichert sind, aus dem Tabellenentwurf löschen.


 Eingeben einer Hyperlinkadresse in der Formular- oder Datenblattansicht

Eingeben einer Hyperlinkadresse in der Formular- oder Datenblattansicht

Es gibt mehrere Möglichkeiten, bei Datensätzen mit jeweils unterschiedlichen Hyperlinks eine Hyperlinkadresse in ein Formular oder Datenblatt einzugeben. In einer Microsoft Access-Datenbank (.mdb) können Sie alle im Folgenden aufgeführten Methoden verwenden, um Hyperlinks in der Datenblattansicht in eine Tabelle, eine Abfrage oder ein Formular oder in der Formularansicht in ein Formular einzugeben. Bei einem Microsoft Access-Projekt (.adp), können Sie diese Methoden nur zur Eingabe von Hyperlinks in Formulare in der Formular- oder Datenblattansicht verwenden. In der Datenblattansicht einer Tabelle, Sicht oder gespeicherten Prozedur müssen Sie den Hyperlink in das Feld eintragen.

Was möchten Sie tun?

Einen Link zu einem Dokument, einer Datei oder einer Webseite erstellen

Einen Link zu einer vorhandenen Datei oder Webseite mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Einen Link zu einer neuen Datenzugriffsseite und die Seite selbst mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Einen Hyperlink oder eine Hyperlinkadresse einfügen

Text aus einem Microsoft Office-Dokument einfügen

Eine Internet-Verknüpfung durch Ziehen einfügen

Eine Hyperlinkadresse eingeben

Einen Link zu einem Objekt in der aktuellen Datenbank erstellen

Einen Link zu einer Tabelle, einer Abfrage, einem Formular, einem Bericht oder einer Datenzugriffsseite in der aktuellen Datenbank mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Einen Link zu einer E-Mail-Adresse erstellen

Mit Hilfe der Schaltfläche Hyperlink einfügen einen Link erstellen, der Ihr E-Mail-Programm öffnet und eine Nachricht an die angegebene E-Mail-Adresse erzeugt


 Überprüfen der Rechtschreibung von Daten in der Datenblattansicht

Überprüfen der Rechtschreibung von Daten in der Datenblattansicht

  1. Öffnen Sie ein Datenblatt.

  2. Wählen Sie die Datensätze, Spalten, Felder oder den Text in einem Feld aus, deren/dessen Rechtschreibung Sie überprüfen möchten.

    Wie wird's gemacht?

  3. Klicken Sie in der Symbolleiste auf Rechtschreibung [image] .

Anmerkungen

  • Klicken Sie im Dialogfeld Rechtschreibung auf Hinzufügen, wenn Sie den Begriff im Feld Nicht im Wörterbuch dem benutzerdefinierten Wörterbuch hinzufügen möchten, das im Feld Wörter hinzufügen zu aufgeführt ist.

  • Falls das Datenblatt Unterdatenblätter enthält, prüft Microsoft Access lediglich die Rechtschreibung in dem Datenblatt oder Unterdatenblatt, in dem sich die Einfügemarke befindet.


 Überprüfen der Rechtschreibung von Daten in der Formularansicht

Überprüfen der Rechtschreibung von Daten in der Formularansicht

  1. Öffnen Sie ein Formular in der Formularansicht.

  2. Wählen Sie das Feld oder den Text aus, dessen Rechtschreibung Sie überprüfen möchten.

  3. Klicken Sie in der Symbolleiste auf Rechtschreibung [image] .

Anmerkung Klicken Sie im Dialogfeld Rechtschreibung auf Hinzufügen, wenn Sie den Begriff im Feld Nicht im Wörterbuch dem benutzerdefinierten Wörterbuch hinzufügen möchten, das im Feld Wörter hinzufügen zu aufgeführt ist.


 Überprüfen der Rechtschreibung in einem Datenbankobjekt im Datenbankfenster

Überprüfen der Rechtschreibung in einem Datenbankobjekt im Datenbankfenster

  1. Wechseln Sie zum Datenbankfenster.

  2. Klicken Sie im Datenbankfenster auf die Tabelle, die Abfrage, das Formular oder die gespeicherte Prozedur, deren/dessen Rechtschreibung Sie überprüfen möchten.

  3. Klicken Sie in der Symbolleiste auf Rechtschreibung [image] .

Anmerkung Klicken Sie im Dialogfeld Rechtschreibung auf Hinzufügen, wenn Sie den Begriff im Feld Nicht im Wörterbuch dem benutzerdefinierten Wörterbuch, das im Feld Wörter hinzufügen zu aufgeführt ist, hinzufügen möchten.


 Wählen eines benutzerdefinierten Wörterbuchs für die Rechtschreibprüfung

Wählen eines benutzerdefinierten Wörterbuchs für die Rechtschreibprüfung

  1. Gehen Sie zum Datenbankfenster.

  2. Klicken Sie auf eine Tabelle, eine Abfrage, eine Ansicht oder eine gespeicherte Prozedur.

  3. Klicken Sie in der Symbolleiste auf Rechtschreibung [image] .

    Anmerkung Sie müssen eventuell vorübergehend ein bestehendes Wort falsch schreiben, damit das Dialogfeld Rechtschreibung angezeigt wird.

  4. Klicken Sie auf Optionen.

  5. Wählen Sie im Feld Wörterbuch das gewünschte benutzerdefinierte Wörterbuch aus.


 Automatisches Korrigieren bei der Dateneingabe

Automatisches Korrigieren bei der Dateneingabe

Verwenden Sie AutoKorrektur, um Text, bei dem Ihnen häufig Schreibfehler unterlaufen, automatisch zu korrigieren und Abkürzungen automatisch durch den ausgeschriebenen Text zu ersetzen. Sie können z.B. die Abkürzung esq für Martin R. Esquivel definieren. Immer wenn Sie dann esq mit nachfolgendem Leerzeichen oder Satzzeichen eingeben, ersetzt Microsoft Access dies durch den Namen Martin R. Esquivel.

  1. Klicken Sie im Menü Extras auf AutoKorrektur.

  2. Aktivieren Sie das Kontrollkästchen Während der Eingabe ersetzen.

  3. Geben Sie in das Feld Ersetzen den Text ein, der automatisch korrigiert werden soll.

  4. Geben Sie in das Feld Durch den korrigierten Text ein.

  5. Klicken Sie dann auf Hinzufügen.

Anmerkungen

  • AutoKorrektur korrigiert keinen Text, der bereits vor dem Aktivieren des Kontrollkästchens Während der Eingabe ersetzen eingegeben wurde.

  • Wenn im vorangegangenen Beispiel an einer bestimmten Stelle wirklich esq angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Während der Eingabe ersetzen, geben in das entsprechende Feld esq ein und speichern das Feld, indem Sie zu einem anderen Datensatz gehen. Daraufhin können Sie das Kontrollkästchen Während der Eingabe ersetzen wieder aktivieren. Microsoft Access ändert dann die zuvor eingegebene und gespeicherte Zeichenfolge esq nicht.

  • AutoKorrektur arbeitet mit Text in einem Datenblatt oder mit Text in einem Formular in der Formularansicht.


Automatisches Großschreiben der Wochentage bei der Dateneingabe

  1. Klicken Sie im Menü Extras auf AutoKorrektur.

  2. Aktivieren Sie das Kontrollkästchen Wochentage immer großschreiben.


Automatisches Korrigieren von zwei Großbuchstaben am Wortanfang bei der Dateneingabe

  1. Klicken Sie im Menü Extras auf AutoKorrektur.

  2. Aktivieren Sie das Kontrollkästchen ZWei GRoßbuchstaben am WOrtanfang korrigieren.


Deaktivieren der automatischen Korrektur eines bei der Dateneingabe vorgenommenen Eintrags

  1. Klicken Sie im Menü Extras auf AutoKorrektur.

  2. Klicken Sie auf den Eintrag, den Sie im Feld am unteren Rand löschen möchten.

  3. Klicken Sie dann auf Löschen.


Hinzufügen eines AutoKorrektur-Eintrags während einer Rechtschreibprüfung

  1. Geben Sie im Dialogfeld Rechtschreibung den korrigierten Text in das Feld Ändern in ein.

  2. Klicken Sie im Dialogfeld Rechtschreibung auf AutoKorrektur.

Wenn Sie beim Einfügen von Daten in Tabellen oder Formulare den Text eingeben, der sich im Feld Nicht im Wörterbuch befindet, ändert Microsoft Access diesen automatisch in den Text um, der sich im Feld Ändern in befindet.


Deaktivieren der automatischen Korrekturen, die bei der Dateneingabe durchgeführt werden

  1. Klicken Sie im Menü Extras auf AutoKorrektur.

  2. Deaktivieren Sie die Kontrollkästchen der Optionen, die Sie außer Kraft setzen möchten.


 Suchen oder Ersetzen von Daten

Suchen oder Ersetzen von Daten

Möglichkeiten zum Suchen oder Ersetzen von Daten

In Microsoft Access gibt es viele Möglichkeiten, nach bestimmten Daten zu suchen oder diese zu ersetzen. Dabei spielt es keine Rolle, ob Sie nach einem bestimmten Wert, einem Datensatz oder einer Gruppe von Datensätzen suchen.

  • Sie können einen Datensatz durch Durchführen eines Bildlaufs in einem Datenblatt oder Formular oder durch Eingeben der Datensatznummer in das Feld Datensatznummer suchen.

  • Mit Hilfe des Dialogfeldes Suchen können Sie nach bestimmten Datensätzen oder nach bestimmten Werten in Feldern suchen. Sie können zwischen Datensätzen wechseln, während Access jedes Auftreten des gewünschten Elements anzeigt. Wenn Sie bestimmte Werte, die Sie gefunden haben, ersetzen möchten, verwenden Sie stattdessen das Dialogfeld Ersetzen.

  • Mit einem Filter können Sie bestimmte Gruppen von Datensätzen, mit denen Sie arbeiten möchten, vorübergehend im Formular oder Datenblatt isolieren und anzeigen.

  • Mit Hilfe einer Abfrage können Sie mit einer bestimmten Gruppe von Datensätzen aus einer oder mehreren Tabellen der Datenbank arbeiten, die bestimmten von Ihnen definierten Kriterien entsprechen. Sie können mit dieser Untergruppe unabhängig von einem bestimmten Formular oder Datenblatt arbeiten, indem Sie einfach die Abfrage ausführen.

Die Auswirkung der Datensatzbeschränkung in einem Microsoft Access-Projekt

Wenn Sie versuchen, Daten in einem Microsoft Access-Projekt zu suchen oder zu ersetzen, führt Access die Operation nur über die auf dem Client gespeicherten Daten durch. Wenn Ihr Datenblatt oder Formular die maximal erlaubte Anzahl an Datensätzen erreicht hat, gibt es noch weitere Daten auf dem Server. Um sicherzustellen, dass alle Daten auf dem Server gefunden und ersetzt werden, legen Sie fest, dass keine Datensatzbeschränkung gelten soll. Dazu verwenden Sie die Schaltfläche für die Beschränkung der Anzahl der Datensätze, die sich rechts von den Navigationsschaltflächen befindet.


 Info über die Verwendung von Platzhalterzeichen beim Suchen nach partiellen oder übereinstimmenden Werten

Info über die Verwendung von Platzhalterzeichen beim Suchen nach partiellen oder übereinstimmenden Werten

Sie verwenden Platzhalterzeichen, wenn Sie den zu suchenden Wert angeben und einer der folgenden zwei Punkte zutrifft:

  • Sie kennen nur einen Teil des Wertes.

  • Sie möchten Werte suchen, die mit einem bestimmten Buchstaben beginnen oder mit einer bestimmten Musterzeichenfolge übereinstimmen.

In einer Microsoft Access-Datenbank können Sie in den Dialogfeldern Suchen und Ersetzen oder in Abfragen, Befehlen und Ausdrücken die folgenden Zeichen verwenden, um nach Feldwerten, Datensätzen oder Dateinamen zu suchen.

Zeichen | Verwendung | Beispiel
* | Dieses Zeichen entspricht einer beliebigen Anzahl an Zeichen. Es kann entweder als erstes oder als letztes Zeichen der Zeichenfolge verwendet werden. | wa* findet was, war und warte
? | Dieses Zeichen entspricht einem einzelnen alphabetischen Zeichen. | w?r findet war, wer und wir
[ ] | Dieses Zeichen entspricht einem einzelnen Zeichen innerhalb der eckigen Klammern. | w[ae]r findet war und wer, aber nicht wir
! | Dieses Zeichen entspricht einem einzelnen beliebigen Zeichen, das in der eckigen Klammer nicht enthalten ist. | w[!ae]r findet wir, aber nicht war und wer
- | Dieses Zeichen entspricht einem einzelnen beliebigen Zeichen innerhalb des angegebenen Bereichs. Sie müssen den Bereich in aufsteigender Reihenfolge angeben (A bis Z, nicht Z bis A). | b[a-c]d findet bad, bbd und bcd
# | Dieses Zeichen entspricht einem einzelnen numerischen Zeichen. | 1#3 findet 103, 113, 123

Anmerkungen

  • Platzhalterzeichen sind für die Verwendung mit Feldern des Datentyps Text bestimmt, dennoch können sie manchmal auch mit anderen Datentypen verwendet werden, z.B. mit dem Datentyp Datum, wenn Sie die Ländereinstellungen für diese Datentypen nicht ändern.

  • Wenn Sie Platzhalterzeichen verwenden, um nach einem Sternchen (*), einem Fragezeichen (?), einem Nummernzeichen (#), einer offenen eckigen Klammer ([) oder einem Bindestrich (-) zu suchen, müssen Sie das zu suchende Zeichen in Klammern einschließen. Wenn Sie beispielsweise nach einem Fragezeichen suchen, geben Sie in das Dialogfeld Suchen Folgendes ein: [?]. Wenn Sie gleichzeitig nach einem Bindestrich und anderen Zeichen suchen, setzen Sie den Bindestrich entweder vor oder nach allen anderen Zeichen innerhalb der Klammern. (Folgt jedoch auf die offene Klammer ein Ausrufezeichen (!), setzen Sie den Bindestrich nach dem Ausrufezeichen.) Wenn Sie nach einem Ausrufezeichen (!) oder einer geschlossenen eckigen Klammer (]) suchen, müssen Sie diese nicht in Klammern setzen.

  • Sie können nicht gleichzeitig nach der offenen und der geschlossenen eckigen Klammer ([ ]) suchen, da Microsoft Access diese Kombination als leere Zeichenfolge interpretiert. Sie müssen die Anfangs- und Endklammern in Klammern angeben ([[ ]]).<

  • Ein Microsoft Access-Projekt verwendet andere Platzhalterzeichen als eine Access-Datenbank. Zum Anzeigen weiterer Informationen suchen Sie im Index der Microsoft SQL Server-Online-Bücher nach "Platzhalterzeichen". Wenn Sie nach Werten in einer beliebigen anderen Datenquelle suchen, müssen Sie u. U. andere Platzhalterzeichen verwenden. Informationen hierzu finden Sie in der Dokumentation zur entsprechenden Datenquelle.


 Suchen eines bestimmten Datensatzes durch Ausführen eines Bildlaufs in einem Datenblatt oder einem Formular

Suchen eines bestimmten Datensatzes durch Ausführen eines Bildlaufs in einem Datenblatt oder einem Formular

Wenn mehr Datensätze vorhanden sind, als in das Fenster der Datenblattansicht oder eines Endlosformulars passen, können Sie einen bestimmten Datensatz unter Verwendung des Bildlauffelds in der Bildlaufleiste suchen.

  • Ziehen Sie das Bildlauffeld in der Bildlaufleiste nach unten oder oben.

Neben dem Bildlauffeld zeigt Microsoft Access die Nummer des obersten auf dem Bildschirm angezeigten Datensatzes an.

Wenn Sie eine Microsoft IntelliMouse haben, können Sie zum Durchführen eines Bildlaufs zu einem bestimmten Datensatz die Radtaste verwenden. Die Bewegung der Radtaste ist dabei abhängig von der jeweiligen Ansicht.

Ansicht | Verhalten der Radtaste | Verhalten des Cursors
Datenblatt oder Unterformular, das als Datenblatt angezeigt wird | Führt den Bildlauf zeilenweise durch | Keine Bewegung
Einzelnes Formular oder Unterformular, das als einzelnes Formular angezeigt wird | Geht zum nächsten oder vorherigen Datensatz | Geht zum nächsten oder vorherigen Datensatz
Endlosformular oder Unterformular, das als Endlosformular angezeigt wird | Geht zum nächsten oder vorherigen Datensatz | Keine Bewegung


 Suchen nach einem Datensatz anhand der Datensatznummer in der Datenblatt- oder Formularansicht

Suchen nach einem Datensatz anhand der Datensatznummer in der Datenblatt- oder Formularansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht oder ein Formular in der Formularansicht.

  2. Doppelklicken Sie auf die Nummer im Datensatznummernfeld, um es auszuwählen, oder drücken Sie dazu F5.

  3. Geben Sie die Nummer des gewünschten Datensatzes ein, und drücken Sie dann die EINGABETASTE.


 Wechseln zwischen Datensätzen unter Verwendung der Navigationsschaltflächen in der Datenzugriffsseitenansicht

Wechseln zwischen Datensätzen unter Verwendung der Navigationsschaltflächen in der Datenzugriffsseitenansicht

  • Verwenden Sie die Navigationsschaltflächen in der Datensatznavigationsleiste, um sich schnell zwischen Datensätzen oder Gruppendatensätzen auf einer gruppierten Datenzugriffsseite zu bewegen.


 Suchen nach einem Wert in einem Feld

Suchen nach einem Wert in einem Feld

Für Informationen zur Suche nach Null-Werten und leeren Zeichenfolgen klicken Sie auf [image] .

  1. Markieren Sie in der Formular- oder Datenblattansicht das Feld (die Spalte) in dem (der) Sie suchen möchten, es sei denn, Sie möchten in allen Feldern suchen. (Das Suchen in einem einzelnen Feld geht schneller als das Suchen im gesamten Formular oder Datenblatt.)

  2. Klicken Sie in der Symbolleiste auf Suchen Objekt suchen .

  3. Geben Sie in das Feld Suchen nach den gesuchten Wert ein.

    Wenn Sie die genaue Zeichenfolge des zu suchenden Wertes nicht kennen, können Sie im Feld Suchen nach Platzhalterzeichen verwenden. Zum Anzeigen von Beispielen der Platzhalterzeichen und ihrer Verwendung klicken Sie auf [image] .

  4. Legen Sie im Dialogfeld Suchen alle anderen Optionen fest, die verwendet werden sollen. Klicken Sie auf Weitere, um weitere Optionen anzuzeigen.

  5. Klicken Sie auf Weitersuchen.

Anmerkungen

  • Wenn Sie nach Werten in einem Datenblatt mit einem Unterdatenblatt oder in einem Formular mit einem Unterformular suchen, das als Datenblatt angezeigt wird, sucht Microsoft Access nur im Datenblatt, Unterdatenblatt oder Formular, in dem sich die Einfügemarke befindet.

  • Im Code-Fenster enthält das Dialogfeld Suchen weitere Optionen speziell für den Visual Basic-Editor. Sie können den Suchbereich durch Auswählen einer Option in der Optionsgruppe Suchen festlegen. Beachten Sie, dass Access Prozeduren auf der Basis der Reihenfolge durchsucht, in der sie zum Modul hinzugefügt worden sind. Das Kontrollkästchen Mit Mustervergleich verwendet dieselbe Semantik wie der Operator Wie.


 Ersetzen eines Wertes in einem Feld

Ersetzen eines Wertes in einem Feld

Sie können alle Vorkommen eines bestimmten Wertes gleichzeitig oder nacheinander ersetzen. Wenn Sie allerdings Null-Werte oder leere Zeichenfolgen ersetzen möchten, müssen Sie das Dialogfeld Suchen verwenden und dann die entsprechenden Vorkommen manuell ersetzen. Um weitere Informationen zu erhalten, klicken Sie auf [image] .

  1. Markieren Sie in der Formular- oder Datenblattansicht das Feld (die Spalte) in der Sie suchen möchten, es sei denn, Sie möchten in allen Feldern suchen. (Das Suchen in einem einzelnen Feld ist schneller als das Suchen im gesamten Datenblatt oder Formular.)

  2. Klicken Sie im Menü Bearbeiten auf Ersetzen.

  3. Geben Sie in das Feld Suchen nach den zu suchenden Wert ein und in das Feld Ersetzen durch den Wert, mit dem der zu suchende Wert ersetzt werden soll.

    Wenn Sie nicht die genaue Zeichenfolge des zu suchenden Wertes kennen, können Sie in das Feld Suchen nach Platzhalterzeichen eingeben. Zum Anzeigen von Beispielen von Platzhalterzeichen und ihrer Verwendung klicken Sie auf [image] .

  4. Legen Sie alle anderen Optionen fest, die Sie im Dialogfeld Suchen/Ersetzen verwenden möchten. Klicken Sie zum Anzeigen weiterer Optionen auf Erweitern.

  5. Um jedes Auftreten des angegebenen Wertes sofort zu ersetzen, klicken Sie auf Alle ersetzen.

    Um das einzelne Auftreten des Wertes nacheinander zu ersetzen, klicken Sie auf Weitersuchen und dann auf Ersetzen. Um den gefundenen Wert zu überspringen und den nächsten zu suchen, klicken Sie auf Weitersuchen.

Anmerkungen

  • In einer Microsoft Access-Datenbank können Sie große Datenmengen schneller ersetzen oder Berechnungen über große Datenmengen (z. B. Erhöhen aller Löhne und Gehälter in der Tabelle Personal um 5 %) schneller durchführen, wenn Sie an Stelle des Dialogfeldes Suchen/Ersetzen eine Aktualisierungsabfrage verwenden. Bei Verwendung einer Aktualisierungsabfrage können Sie jedoch einzelne Ersetzung nicht bestätigen. Außerdem ist die Aktualisierungsabfrage umständlicher, wenn Sie Daten in mehreren Feldern suchen und ersetzen möchten. In einem Microsoft Access-Projekt können Sie zum Aktualisieren großer Datenmengen eine Gespeicherte Prozedur verwenden.

  • Wenn Sie Daten in einem Datenblatt durch ein Unterdatenblatt oder in einem Formular durch ein als Datenblatt angezeigtes Unterformular ersetzen, ersetzt Microsoft Access nur die Daten im Datenblatt, Unterdatenblatt oder Formular, die sich an der Einfügemarke befinden.

  • Im Code-Fenster gelten für das Dialogfeld Ersetzen andere Optionen als im Visual Basic-Editor. Sie können den Suchbereich durch Auswählen einer Option aus der Optionsgruppe Suchen festlegen. Beachten Sie, dass Access Prozeduren auf der Basis der Reihenfolge durchsucht, in der sie zum Modul hinzugefügt worden sind. Das Kontrollkästchen Mit Mustervergleich verwendet die gleiche Semantik, wie der Operator Wie.


Ändern des Standardverhaltens für Suchen- und Ersetzen-Operationen

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Bearbeiten/Suchen.

  3. Klicken Sie unter Suchen/Ersetzen-Standard auf die gewünschte Option.

Anmerkung Änderungen dieser Einstellung werden erst beim nächsten Start von Microsoft Access wirksam. Um für eine spezielle Suchen- oder Ersetzen-Operation das Verhalten sofort zu ändern, klicken Sie im Menü Bearbeiten auf Suchen oder Ersetzen, und legen Sie im Dialogfeld die entsprechenden Optionen fest.


 Optimieren der Suchen- und Ersetzen-Funktion

Optimieren der Suchen- und Ersetzen-Funktion

  • Um eine schnelle Suche durchzuführen, suchen Sie nach dem gesamten Feldinhalt oder nach dem ersten Buchstaben innerhalb eines einzelnen indizierten Feldes. Wenn Sie nach dem gleichen nicht-indizierten Feld wiederholt suchen möchten, indizieren Sie das Feld.

    Wie wird's gemacht?


 Suchen von leeren Feldern oder leeren Zeichenfolgen mit Hilfe des Dialogfelds "Suchen"

Suchen von leeren Feldern oder leeren Zeichenfolgen mit Hilfe des Dialogfelds "Suchen"

  1. Klicken Sie in der Formularansicht oder Datenblattansicht auf das Feld oder die Spalte, in dem bzw. der Sie suchen möchten, und klicken Sie anschließend in der Symbolleiste auf Suchen Objekt suchen .

  2. Klicken Sie gegebenenfalls auf Weiter.

  3. Führen Sie eine der folgenden Aktionen aus:
    • Wenn leere Felder formatiert sind (wie z. B. "Unbekannt"), geben Sie die formatierte Zeichenfolge ein, und stellen Sie sicher, dass das Kontrollkästchen Formatierung beachten aktiviert ist. Zum Suchen nach unformatierten leeren Feldern in einer Microsoft Access-Datenbank geben Sie in das Feld Suchen nach den Wert Null oder Ist Null ein. Stellen Sie außerdem sicher, dass das Kontrollkästchen Formatierung beachten deaktiviert ist.

    • Wenn Sie unformatierte leere Zeichenfolgen suchen möchten, geben Sie in das Feld Suchen nach ein Paar Anführungszeichen ("") ohne Leerzeichen ein, und stellen Sie sicher, dass das Kontrollkästchen Formatierung beachten nicht aktiviert ist. Wenn die leeren Zeichenfolgen formatiert sind (z. B. "NV"), suchen Sie nach der formatierten Zeichenfolge, und stellen Sie sicher, dass das Kontrollkästchen Formatierung beachten aktiviert ist.
  4. Wählen Sie im Feld Suchen die Option Aufwärts oder Abwärts aus.

  5. Stellen Sie sicher, dass im Feld Vergleichen der Eintrag Ganzes Feld ausgewählt ist.

  6. Wählen Sie unter Suchen in das Feld aus, das durchsucht werden soll.

  7. Wenn Sie nach einem oder mehreren Vorkommnissen eines leeren Feldes suchen möchten, klicken Sie auf Weitersuchen.


 Ähnlichkeiten und Unterschiede zwischen Auswahlabfragen und Filtern

Ähnlichkeiten und Unterschiede zwischen Auswahlabfragen und Filtern

Die wichtigste Ähnlichkeit zwischen Auswahlabfragen und Filtern besteht darin, dass beide eine Untergruppe von Datensätzen aus einer zugrunde liegenden Tabelle oder Abfrage abrufen. Die unterschiedliche Verwendung der abgerufenen Daten bedingt jedoch die Entscheidung, ob eher ein Filter oder eine Abfrage geeignet ist.

Verwenden Sie in der Regel einen Filter, wenn Sie eine Untergruppe von Datensätzen in einem Formular oder Datenblatt vorübergehend anzeigen oder bearbeiten möchten. Verwenden Sie dagegen eine Abfrage, wenn Sie eine oder alle der folgenden Aufgaben ausführen möchten:

  • Anzeigen der Untergruppe der Datensätze, ohne zuerst eine bestimmte Tabelle oder ein bestimmtes Formular öffnen zu müssen

  • Auswählen der Tabellen, die die Datensätze enthalten, mit denen Sie arbeiten möchten, und bei Bedarf Hinzufügen weiterer Tabellen zu einem späteren Zeitpunkt

  • Festlegen der Felder aus der Untergruppe der Datensätze, die in den Ergebnissen angezeigt werden sollen

  • Verwenden von Werten aus Feldern in Berechnungen

Anmerkung Auch wenn Sie festgestellt haben, dass Sie eine Abfrage benötigen, lohnt es sich zu überlegen, ob Sie eine der benutzerfreundlichen Optionen Formularbasierter Filter, Auswahlbasierter Filter oder Filter nach benutzen, um einen Filter zu erstellen und ihn anschließend als Abfrage speichern. Auf diese Weise umgehen Sie die Arbeit im Entwurfsbereich (es sei denn, Sie möchten nachträglich noch Änderungen an der Abfrage vornehmen). In jedem Fall sehen Sie beim Öffnen von Abfragen in der Entwurfsansicht, wie Microsoft Access den Entwurfsbereich unter Verwendung der Informationen aus dem Filter ausgefüllt hat. Verwenden Sie diese Informationen als Basis zum Durchführen von Änderungen.

Die nachstehende Tabelle zeigt die Ähnlichkeiten und Unterschiede zwischen Abfragen und Filtern.

Merkmale | Filter | Abfragen
Erlaubt das Hinzufügen weiterer Tabellen, wenn Sie deren Datensätze zu den ausgegebenen Untergruppen hinzufügen möchten | Nein | Ja
Erlaubt festzulegen, welche Felder aus der Untergruppe der Datensätze in den Ergebnissen angezeigt werden sollen | Nein | Ja
Erscheint als separates Objekt im Datenbankfenster | Nein | Ja
Kann in einer geschlossenen Tabelle, einer geschlossenen Abfrage oder einem geschlossenen Formular verwendet werden | Ja | Nein
Erzeugt Ergebnisse, die als Datenquelle für ein Formular oder einen Bericht verwendet werden können | Ja | Ja
Kann Summen, Durchschnittswerte, Zähler und andere Arten von Berechnungen durchführen | Nein | Ja
Kann Datensätze sortieren | Ja | Ja
Erlaubt das Bearbeiten von Daten, wenn das Bearbeiten grundsätzlich zugelassen ist | Ja | Ja, abhängig von der Art der Abfrage. Mit einer Aktualisierungsabfrage können Sie auch Aktualisierungen in großem Umfang ausführen


 Unterschiedliche Filtermethoden für Tabellen, Abfragen oder Formulare

Unterschiedliche Filtermethoden für Tabellen, Abfragen oder Formulare

Aufgabe | Auswahlbasierter Filter | Formularbasierter Filter und Filter nach | Spezialfilter/ -sortierung
Suchen nach Datensätzen, die mehrere Kriterien erfüllen. | Ja (Sie müssen die Kriterien jedoch einzeln eingeben.) | Ja (Sie können alle Kriterien gleichzeitig eingeben.) | Ja (Sie können alle Kriterien gleichzeitig eingeben.)
Suchen nach Datensätzen, die ein Kriterium oder ein anderes Kriterium erfüllen. | Nein | Ja | Ja
Eingeben von Ausdrücken als Kriterien. | Nein | Ja | Ja
Sortieren von Datensätzen in aufsteigender oder absteigender Reihenfolge. | Nein (Sie können jedoch alle gefilterten Datensätze nach dem Anwenden des Filters sortieren. Dazu klicken Sie in der Symbolleiste auf Aufsteigend [image] oder auf Absteigend [image] .) | Nein (Sie können jedoch alle gefilterten Datensätze nach dem Anwenden des Filters sortieren. Dazu klicken Sie in der Symbolleiste auf Aufsteigend [image] oder auf Absteigend [image] .) | Ja (Sie können einige Felder in aufsteigender und andere Felder in absteigender Reihenfolge sortieren.)


 Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Es gibt vier unterschiedliche Methoden, die Sie zum Filtern verwenden können: Auswahlbasierter Filter, Formularbasierter Filter, Filter nach und Spezialfilter/-sortierung.

Was möchten Sie tun?

Empfehlungen zum Auswählen einer Filtermethode anzeigen

Einen Vergleich der verschiedenen Filtermethoden als Entscheidungshilfe anzeigen

Die Methode Auswahlbasierter Filter verwenden

Die Methode Formularbasierter Filter verwenden

Die Methode Filter nach verwenden

Die Methode Spezialfilter/-sortierung verwenden


Ändern eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Wenn ein Filter nicht die gewünschten Datensätze ausgibt, können Sie ihn ändern. Zum Ändern eines Filters verwenden Sie die Technik, die Sie zum Erstellen verwendet haben, oder die für die gewünschten Änderungen am besten geeignete Technik.

Welche Filtermethode möchten Sie zum Ändern eines Filters verwenden?

Auswahlbasierter Filter oder Auswahlausschließender Filter

Filter nach

Formularbasierter Filter

Spezialfilter/-sortierung


 Wechseln zwischen Filterfenstern in einer Tabelle, einer Abfrage oder einem Formular

Wechseln zwischen Filterfenstern in einer Tabelle, einer Abfrage oder einem Formular

Sie können zwischen Fenstern wechseln, um einen Filter unter Verwendung der für Ihre Aufgaben am besten geeigneten Filtermethode zu erstellen oder zu ändern, oder um eine andere Ansicht eines vorhandenen Filters zu sehen. Für die Optionen Formularbasierter Filter und Spezialfilter/-sortierung stehen eigene Fenster zur Verfügung. Die Optionen Auswahlbasierter Filter oder Filter nach verwenden Sie dagegen direkt in der Formularansicht oder der Datenblattansicht.

Gewünschtes Fenster | Aktuelles Fenster | Ausführung
Formularbasierter Filter | Datenblattansicht oder Formularansicht | Klicken Sie in der Symbolleiste auf Formularbasierter Filter [image] .
 | Spezialfilter/-sortierung | Klicken Sie im Menü Filter auf Formularbasierter Filter.
Spezialfilter/- sortierung | Datenblattansicht oder Formularansicht | Zeigen Sie im Menü Datensätze auf Filter, und klicken Sie dann auf Spezialfilter/-sortierung.
 | Formularbasierter Filter | Klicken Sie im Menü Filter auf Spezialfilter/-sortierung.

Zum Anwenden eines Filters aus einem der Fenster Formularbasierter Filter oder Spezialfilter/-sortierung und Anzeigen der Ergebnisse in der Datenblatt- oder der Formularansicht klicken Sie in der Symbolleiste auf Filter anwenden [image] . Wenn Sie eines der Filterfenster schließen und zur Datenblatt- oder Formularansicht zurückkehren möchten, ohne den Filter anzuwenden, klicken Sie in der Symbolleiste auf Schließen [image] .

Anmerkung Nach dem Festlegen der gesuchten Werte unter Verwendung einer der Optionen Auswahlbasierter Filter, Formularbasierter Filter oder Filter nach können Sie im Fenster Spezialfilter/-sortierung sehen, wie die festgelegten Werte im Entwurfsbereich in einen Kriterienausdruck übersetzt werden.


 Optimieren der Leistung im Fenster "Formularbasierter Filter"

Optimieren der Leistung im Fenster "Formularbasierter Filter"

Wenn es sehr lange dauert, die Listen in Feldern im Fenster Formularbasierter Filter anzuzeigen, oder wenn die Listen nicht die Werte aus der zugrunde liegenden Tabelle anzeigen, können Sie die Leistung im Fenster Formularbasierter Filter für alle Tabellen, Abfragen und Formulare oder die Leistung für ein bestimmtes Formular verbessern. In beiden Fällen können Sie verhindern, dass die Listen die Feldwerte der zugrunde liegenden Tabelle anzeigen, Sie können in der Liste nur die Feldwerte für bestimmte Typen indizierter oder nichtindizierter Felder anzeigen oder die Datensatzgrenze ändern, die festlegt, ob in der Liste die Werte eines Feldes angezeigt werden.

Was möchten Sie tun?

Die Leistung im Fenster Formularbasierter Filter für alle Tabellen, Abfragen und Formulare der Datenbank optimieren

Die Leistung im Fenster Formularbasierter Filter für ein bestimmtes Formular optimieren


 Aktivieren oder Deaktivieren der Möglichkeit zum Filtern von Datensätzen in einem Formular

Aktivieren oder Deaktivieren der Möglichkeit zum Filtern von Datensätzen in einem Formular

  • Legen Sie für die Einstellung FilterZulassen (AllowFilters) des Formulars die Einstellung Ja fest, wenn Sie die Filtermöglichkeiten in der Formularansicht und in der Datenblattansicht zulassen möchten, oder legen Sie Nein fest, wenn Sie die Filtermöglichkeiten nicht zulassen möchten.

    Wie wird's gemacht?

Anmerkung Wenn Sie für die Eigenschaft FilterZulassen die Einstellung Nein festlegen, werden die Filtermethoden Auswahlbasierter Filter, Formularbasierter Filter, Filter nach und Spezialfilter/-sortierung deaktiviert.


Hinzufügen oder Ändern von Feldern in einem Filter

Was möchten Sie tun?

Felder zum Entwurfsbereich in einem Spezialfilter hinzufügen

Ein Feld im Entwurfsbereich eines Spezialfilters verschieben

Ein Feld aus dem Entwurfsbereich eines Spezialfilters entfernen

Ein Feld im Entwurfsbereich eines Spezialfilters einfügen

Eine vorhandene Abfrage als Filter in einem Formular, einem Unterformular oder einem Datenblatt anwenden


Hinzufügen oder Ändern einer Sortierreihenfolge für einen Filter

Was möchten Sie tun?

Datensätze unter Verwendung des Entwurfsbereichs eines Spezialfilters sortieren

Kriterien oder eine Sortierreihenfolge festlegen, wenn im Entwurfsbereich das Sternchen verwendet wird

Informationen zum Sortieren von Datensätzen anzeigen

Eine Sortierreihenfolge aus einer Tabelle, einer Abfrage oder einem Formular entfernen


Hinzufügen oder Ändern von Kriterien für einen Filter

Was möchten Sie tun?

Informationen zur Verwendung von Kriterien zum Abrufen bestimmter Datensätze in einem Filter anzeigen

Kriterien zum Abrufen bestimmter Datensätze in einem Filter eingeben

Beispiele für Kriterienausdrücke für Filter anzeigen

Eine Kriterienzeile in einem Spezialfilter einfügen oder löschen


 Anwenden eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Anwenden eines Filters in einer Tabelle, einer Abfrage oder einem Formular

  • Klicken Sie in einem Formular, in einem Datenblatt oder in einem der Filterfenster in der Symbolleiste auf Filter anwenden [image] .

Anmerkungen

  • Wenn Sie einen Filter auf ein Datenblatt anwenden, wendet Microsoft Access auch die Filter an, die Sie eventuell in einem enthaltenen Unterdatenblatt erstellt haben.

  • Microsoft Access kann einen Filter automatisch beim Öffnen eines Formulars anwenden, wenn Sie für die Eigenschaft BeimÖffnen (OnOpen) ein Makro, das die Aktion FilterAnwenden verwendet, oder eine Ereignisprozedur, die die Methode ApplyFilter des Objekts DoCmd verwendet, angeben.

  • Wenn Sie einen Filter in einem Formular, Unterformular, Datenblatt oder Unterdatenblatt erstellen, das bereits einen Filter aus einer vorhergehenden Arbeitssitzung enthält, ersetzt der neue Filter den zuvor verwendeten Filter.


 Anwenden einer vorhandenen Abfrage als Filter in einem Formular oder Datenblatt

Anwenden einer vorhandenen Abfrage als Filter in einem Formular oder Datenblatt

Obwohl Sie für jedes Datenblatt, Unterdatenblatt, Formular oder Unterformular nur einen Filter speichern können, können Sie Abfragen verwenden, die Sie als zusätzliche Filter erstellt haben. Wenn Sie eine Abfrage als Filter verwenden, muss die Abfrage bestimmten Anforderungen genügen. Zum Anzeigen weiterer Informationen zu diesen Anforderungen klicken Sie auf [image] .

  1. Klicken Sie in das Datenblatt, Unterdatenblatt, Formular oder Unterformular, das Sie filtern möchten.

  2. Wechseln Sie zum Fenster Formularbasierter Filter oder zum Fenster Spezialfilter/-sortierung.

    Wie wird's gemacht?

  3. Klicken Sie in der Symbolleiste auf Von Abfrage laden [image] .

  4. Wählen Sie eine Abfrage aus, und klicken Sie dann auf OK.

  5. Klicken Sie in der Symbolleiste auf Filter anwenden [image] .

Anmerkung Um Informationen zum Erstellen eines Formulars oder Berichts auf der Basis der gefilterten Daten anzuzeigen, klicken Sie auf [image] .


 Entfernen eines Filters aus einer Tabelle, einer Abfrage oder einem Formular

Entfernen eines Filters aus einer Tabelle, einer Abfrage oder einem Formular

  • Zum Entfernen eines Filters und Anzeigen der Datensätze, die vorher in der Tabelle, der Abfrage oder dem Formular angezeigt wurden, klicken Sie in der Datenblattansicht oder der Formularansicht in der Symbolleiste auf Filter entfernen [image] .

  • Wenn Sie einen Filter in einer Mehrbenutzerdatenbank entfernen und sehen möchten, welche Datensätze seit dem letzten Öffnen der Tabelle, der Abfrage oder des Formulars hinzugefügt, gelöscht oder geändert worden sind, klicken Sie in der Datenblattansicht oder der Formularansicht im Menü Datensätze auf Filter/Sortierung entfernen.

Anmerkungen

  • Wenn Sie einen Filter entfernen, wird dieser nicht gelöscht. Sie können den Filter erneut anwenden. Dazu klicken Sie in der Symbolleiste auf Filter anwenden [image] . Wenn Sie einen Filter aus einem Datenblatt entfernen, entfernt Microsoft Access auch alle Filter, die Sie eventuell auf ein enthaltenes Unterdatenblatt angewendet haben.

  • Sie können zum Entfernen des Filters auch ein Makro oder Visual Basic für Applikationen-Code mit der Aktion AnzeigenAlleDatensätze verwenden.


 Löschen eines Filters aus einer Tabelle, einer Abfrage oder einem Formular

Löschen eines Filters aus einer Tabelle, einer Abfrage oder einem Formular

Mit diesem Verfahren können Sie jeden beliebigen Filter (unabhängig von der zum Erstellen des Filters verwendeten Methode) löschen.

  1. Klicken Sie in das Datenblatt, Unterdatenblatt, Formular oder Unterformular, dessen Filter gelöscht werden soll.

  2. Wechseln Sie zum Fenster Spezialfilter/-sortierung.

    Wie wird's gemacht?

  3. Klicken Sie im Menü Bearbeiten auf Alles löschen.

  4. Klicken Sie in der Symbolleiste auf Filter anwenden [image] .


 Entfernen oder Anwenden eines übernommenen Filters aus/in einem Bericht

Entfernen oder Anwenden eines übernommenen Filters aus/in einem Bericht

  1. Öffnen Sie den Bericht in der Berichtsentwurfsansicht, oder stellen Sie sicher, wenn der Bericht bereits geöffnet ist, dass er auch markiert ist.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Berichts anzuzeigen.

  3. Klicken Sie im Einstellungsfeld für die Eigenschaft FilterAktiv (FilterOn) auf Nein, wenn Sie den Filter entfernen möchten, oder klicken Sie auf Ja, wenn Sie ihn anwenden möchten.

Anmerkungen

  • Microsoft Access kann einen Filter automatisch anwenden, wenn Sie einen Bericht öffnen. Dazu geben Sie für die Eigenschaft BeimÖffnen (OnOpen) ein Makro, das die Aktion FilterAnwenden verwendet, oder eine Ergeignisprozedur, die die Methode ApplyFilter des Objekts DoCmd verwendet, an. Sie können einen Filter in einem Bericht auch unter Verwendung der Aktion ÖffnenBericht oder der entsprechenden Methode automatisch anwenden.

  • Sie können den Filter bei Bedarf löschen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Welchen Einfluss haben ein Filter und eine Sortierreihenfolge auf neue Formulare oder Berichte?

Welchen Einfluss haben ein Filter und eine Sortierreihenfolge auf neue Formulare oder Berichte?

Wenn Sie ein Formular oder einen Bericht auf der Basis einer Tabelle oder Abfrage erstellen, die einen Filter hat, fügt Microsoft Access den Filter und die Sortierreihenfolge zum Formular oder Bericht hinzu. Die Sortierreihenfolge wird automatisch angewendet. Ob der Filter automatisch angewendet wird, hängt davon ab, wie Sie das Formular oder den Bericht erstellen.

  • Wenn Sie das Formular oder den Bericht direkt auf der Basis der gefilterten Daten erstellen, während diese in einer geöffneten Tabelle oder Abfrage angezeigt werden, wird der Filter automatisch bei jedem Anzeigen des Berichts angezeigt. In einem Formular wird er jedoch nur beim ersten Anzeigen des Formulars nach dem Erstellen angewendet. (Wenn Sie das Formular später wieder öffnen, müssen Sie den Filter manuell anwenden.)

  • Wenn Sie das Formular oder den Bericht auf der Basis einer geschlossenen Tabelle oder Abfrage erstellen, wird der Filter im neuen Formular oder Bericht nicht angewendet. Sie können den Filter bei Bedarf manuell anwenden.


 Ändern einer übernommenen Sortierreihenfolge in einem Bericht

Ändern einer übernommenen Sortierreihenfolge in einem Bericht

  1. Öffnen Sie den Bericht in der Berichtsentwurfsansicht, oder stellen Sie sicher, wenn der Bericht bereits geöffnet ist, dass er markiert ist.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Berichts anzuzeigen.

  3. Klicken Sie auf das Einstellungsfeld für die Eigenschaft SortiertNach (OrderBy), und geben Sie dann das Feld, über das Sie sortieren möchten, und die gewünschte Sortierreihenfolge an.
    • Geben Sie zum Sortieren der Datensätze in einem Feld in aufsteigender Reihenfolge den Feldnamen in eckigen Klammern ([ ]) gefolgt von den Zeichen ASC ein.

      [Feldname1] ASC

    • Geben Sie zum Sortieren der Datensätze in einem Feld in absteigender Reihenfolge den Feldnamen in eckigen Klammern ([ ]) gefolgt von den Zeichen DESC ein.

      [Feldname1] DESC

    • Geben Sie zum Sortieren in mehreren Feldern in aufsteigender oder absteigender Reihenfolge Folgendes ein:

      [Feldname1] ASC,
      [      Feldname2] DESC

Anmerkung Wenn Sie hinter dem Feldnamen weder ASC nach DESC eingeben, sortiert Microsoft Access in aufsteigender Reihenfolge erst das zuerst aufgeführte Feld, dann das nächste aufgeführte Feld usw.


 Ändern oder Löschen eines übernommenen Filters in einem Bericht

Ändern oder Löschen eines übernommenen Filters in einem Bericht

  1. Öffnen Sie den Bericht in der Berichtsentwurfsansicht, oder stellen Sie sicher, wenn der Bericht bereits geöffnet ist, dass er auch markiert ist.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Berichts anzuzeigen.

  3. Ändern Sie im Einstellungsfeld für die Eigenschaft Filter die SQL-Klausel WHERE. Wenn Sie die Klausel WHERE löschen, legen Sie für die Eigenschaft Filter aktiv die Einstellung Nein fest.

Tipp Wenn Sie mit SQL nicht vertraut sind, ändern Sie den Filter in der zugrunde liegenden Tabelle oder Abfrage, wechseln zur Entwurfsansicht für die Tabelle oder Abfrage und zeigen dann deren Eigenschaftenfenster an. Kopieren Sie anschließend die überarbeitete WHERE-Klausel aus der Eigenschaft Filter in die Eigenschaft Filter für den Bericht.


 Entfernen oder erneutes Anwenden einer übernommenen Sortierreihenfolge in einem Bericht

Entfernen oder erneutes Anwenden einer übernommenen Sortierreihenfolge in einem Bericht

  1. Öffnen Sie den Bericht in der Berichtsentwurfsansicht, oder stellen Sie sicher, wenn der Bericht bereits geöffnet ist, dass er auch markiert ist.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Berichts anzuzeigen.

  3. Klicken Sie im Einstellungsfeld für die Eigenschaft SortierungAktiv (OrderByOn) auf Nein, wenn Sie die Sortierreihenfolge entfernen möchten, oder klicken Sie auf Ja, wenn Sie die Reihenfolge erneut anwenden möchten.

Anmerkung Wenn Sie eine Sortierreihenfolge im Berichts-Assistenten oder in der Berichtsentwurfsansicht im Dialogfeld Sortieren und gruppieren festgelegt haben, überschreibt diese Sortierreihenfolge die übernommene Reihenfoge.


 Verwenden von Kriterien in Abfragen oder Spezialfiltern zum Abrufen bestimmter Datensätze

Verwenden von Kriterien in Abfragen oder Spezialfiltern zum Abrufen bestimmter Datensätze

Kriterien sind Einschränkungen, die Sie einer Abfrage oder einem Spezialfilter hinzufügen können, um bestimmte Datensätze zu finden, mit denen Sie arbeiten möchten. Statt z. B. alle Lieferanten Ihrer Firma anzuzeigen, können Sie ausschließlich die Lieferanten aus Japan anzeigen. Geben Sie hierfür Kriterien an, die das Ergebnis auf bestimmte Datensätze begrenzen, wie z. B. Japan im Feld Land.

Um für ein Feld im Entwurfsbereich Kriterien anzugeben, geben Sie in der Zelle Kriterien einen Ausdruck ein. Der Ausdruck für das vorangegangene Beispiel wäre Japan. Sie können auch komplexere Ausdrücke angeben, wie z. B. Zwischen 1000 Und 5000. Wenn Ihre Abfrage verknüpfte Tabellen enthält, müssen Sie bei den Werten, die Sie als Kriterien für Felder der verknüpften Tabellen angeben, die Groß-/Kleinschreibung beachten, d.h. die Schreibweise der Kriterien muss den Werten in der zugrunde liegenden Tabelle entsprechen.

Sie können weitere Kriterien für dasselbe Feld oder andere Felder eingeben. Wenn Sie Ausdrücke in mehrere Zellen der Zeile Kriterien eingeben, verknüpft Microsoft Access diese mit Hilfe der Operatoren Und bzw. Oder. Wenn sich die Ausdrücke in verschiedenen Zellen derselben Zeile befinden, verwendet Microsoft Access den Operator Und. Es werden dann nur die Datensätze zurückgegeben, die den Kriterien aller Zellen entsprechen. Befinden sich die Ausdrücke in verschiedenen Zeilen des Entwurfsbereichs, wird der Operator Oder verwendet, und es werden die Datensätze zurückgegeben, die den Kriterien in mindestens einer Zelle entsprechen.

Beispiele zur Verwendung mehrerer Kriterien im Entwurfsbereich.

Abgerufene Datensätze müssen den Kriterien in beiden Spalten entsprechen.

Sie können auch Kriterien angeben, um das Ergebnis einer Berechnung zu beeinflussen. Durch Hinzufügen von Kriterien können Sie die Gruppen begrenzen, für die Sie eine Berechnung durchführen, die in die Berechnung einzuschließenden Datensätze limitieren oder das Ergebnis einschränken, das nach der Durchführung der Berechnung angezeigt wird. Um Informationen zum Eingeben von Kriterien in eine Abfrage, die Berechnungen durchführt, anzuzeigen, klicken Sie auf [image] .


 Wo werden Ausdrücke in Abfragen und Filtern eingegeben?

Wo werden Ausdrücke in Abfragen und Filtern eingegeben?

Sie können Ausdrücke im Entwurfsbereich einer Abfrage oder im Fenster Spezialfilter/-sortierung, in einer SQL-Anweisung der SQL-Ansicht einer Abfrage oder im Fenster Formularbasierter Filter verwenden, um Kriterien festzulegen, welche die Datensätze angeben, mit denen Sie arbeiten möchten. In Abfragen können Sie Ausdrücke auch zum Aktualisieren von Werten in einer Datensatzgruppe oder zum Erstellen berechneter Felder verwenden.

Sie können den Ausdruck im Entwurfsbereich an verschiedenen Stellen eingeben, abhängig von der Operation, die Sie durchführen möchten. (Die folgende Tabelle verdeutlicht, wo Sie Ausdrücke eingeben können.) Nachdem Sie einen Ausdruck im Entwurfsbereich eingegeben und die EINGABETASTE gedrückt haben, zeigt Microsoft Access den Ausdruck in seiner eigenen Syntax an. Wenn Sie im Ausdruck keinen Operator angeben, setzt Microsoft Access automatisch den Operator = ein. Wenn Sie z.B. Dänemark als Kriterium im Feld Land eingeben, zeigt Microsoft Access zwar "Dänemark" an, interpretiert diesen Ausdruck aber als Land="Dänemark". Wenn Sie Verweise auf Feldnamen im Ausdruck angeben, müssen sich die Felder in einer der Tabellen befinden, die der Abfrage hinzugefügt wurden (es sei denn, Sie verwenden die Funktion DomWert oder eine Unterabfrage). Sie können die Felder jedoch nicht durch Ziehen dem Ausdruck im Entwurfsbereich hinzufügen.

Zweck | Eingabe des Ausdrucks
Festlegen von Kriterien für eine Auswahl-, Kreuztabellen- oder Aktionsabfrage oder für einen Spezialfilter | In eine Zelle der Zeile Kriterien im Entwurfsbereich einer Abfrage oder eines Spezialfilters
Erstellen eines berechneten Feldes | In eine Zelle der Zeile Feld im Entwurfsbereich einer Abfrage oder eines Spezialfilters
Aktualisieren von Datensätzen entsprechend den Ergebnissen des Ausdrucks (nur Aktualisierungsabfragen) | In eine Zelle der Zeile Aktualisieren im Entwurfsbereich einer Aktualisierungsabfrage
Angeben der Datensätze, mit denen Sie arbeiten möchten, der Gruppierungsweise, der Kriterien für die Gruppierung sowie der Sortierreihenfolge | In eine SQL-Anweisung der SQL-Ansicht
Festlegen von Kriterien beim Verwenden eines formularbasierten Filters | In ein Feld im Fenster Formularbasierter Filter (für einen benutzerdefinierten Ausdruck), oder durch Auswählen eines Ausdrucks aus der Liste des Feldes

Anmerkung Sie können sehen, wie Microsoft Access Abfrageausdrücke auswertet, indem Sie zur SQL-Ansicht einer Abfrage wechseln und deren zugrunde liegende SQL-Anweisungen anzeigen. Um eine Abfrage in der SQL-Ansicht anzuzeigen, klicken Sie in der Symbolleiste auf den Pfeil neben der Schaltfläche Ansicht und dann auf SQL-Ansicht. Wenn Ihre Abfrage verknüpfte Tabellen enthält, müssen Sie bei den Werten, die Sie als Kriterien für Felder der verknüpften Tabellen angeben, die Groß-/Kleinschreibung beachten, d.h. die Schreibweise der Kriterien muss den Werten in der zugrunde liegenden Tabelle entsprechen.


Erstellen eines Ausdrucks

Was möchten Sie tun?

Einen Ausdruck mit dem Ausdrucks-Generator erstellen

Einen Ausdruck ohne den Ausdrucks-Generator erstellen

Weitere Informationen über Ausdrücke erhalten

Beispiele für Ausdrücke anzeigen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen? ?


Ausdrücke in Abfragen und Filtern - Beispiele

Was möchten Sie tun?

Beispiele für Ausdrücke ansehen, die Berechnungen mit Feldwerten durchführen oder Feldwerte ändern

Beispiele für Ausdrücke ansehen, die als Kriterien zum Einschränken der Datensätze, mit denen Sie arbeiten, verwendet werden

Beispiele für Ausdrücke ansehen, die zum Aktualisieren von Daten in einer Aktualisierungsabfrage verwendet werden

Beispiele für Ausdrücke in SQL-Anweisungen in der SQL-Ansicht der Abfrage anzeigen

Informationen zum Eingeben von Ausdrücken in Abfragen und Filtern anzeigen

Informationen zum Erstellen eines Ausdrucks anzeigen


 Methoden zum Filtern von Datensätzen einer Datenzugriffsseite

Methoden zum Filtern von Datensätzen einer Datenzugriffsseite

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Methoden zum Filtern von Datensätzen vor ihrem Abruf aus der Datenbank

Methoden zum Filtern von Datensätzen nach ihrem Abruf aus der Datenbank

Methoden zum Filtern von Datensätzen vor ihrem Abruf aus der Datenbank

Um die Datensätze zu filtern, bevor die Datenzugriffsseite sie abruft, können Sie der Seite eine Abfrage zugrunde legen, die Kriterien (Suchbedingungen) zur Einschränkung der Datensatzmenge beinhaltet. Eine andere Möglichkeit besteht darin, in einem Microsoft Access-Projekt einen Filter über die ServerFilter-Eigenschaft unter Verwendung von Visual Basic für Applikationen oder Microsoft Visual Basic Scripting Edition (VBScript) zu definieren. Sie können auch in einer Microsoft Access-Datenbank einen Filter definieren, indem Sie die Filter-Eigenschaft über Visual Basic für Applikationen oder Microsoft Visual Basic Scripting Edition (VBScript) entsprechend einstellen. In einer Datenzugriffsseite mit Datensatzgruppierung können Sie einen Filter erstellen, der Daten für eine bestimmte Gruppe abruft, beispielsweise Bestellungen eines bestimmten Kunden. Die Datenzugriffsseite zeigt solange keine Datensätze an, bis Sie die entsprechende Gruppe in einer Dropdownliste in der Datenzugriffsseitenansicht oder im Microsoft Internet Explorer ausgewählt haben. Nach Auswahl der Gruppe wird der Filter angewendet und nur die darüber definierten Datensätze werden abgerufen. Sie können auch für Datenzugriffsseiten ohne Datengruppierung einen Filter definieren. Anstatt die Gruppe auszuwählen, deren Datensätze Sie anzeigen möchten, wählen Sie einen Wert für ein Feld aus, das Sie als Filterfeld festgelegt haben. Dieses Verfahren ähnelt der Verwendung Formularbasierter Filter. Alle Datensätze, die den ausgewählten Wert enthalten, werden abgerufen.

Anmerkung Das Filtern von Datensätzen vor ihrem Abruf aus der Datenbank kann die Leistung einer Datenzugriffsseite verbessern, da diese weniger Datensätze aus der zugrunde liegenden Datenbank übertragen muss.

Zurück zum Anfang

Methoden zum Filtern von Datensätzen nach ihrem Abruf aus der Datenbank

Um Datensätze zu filtern, nachdem sie für die aktuelle Datenzugriffsseite über die Seitenansicht oder mit dem Browser abgerufen wurden, verwenden Sie einen auswahlbasierten Filter. Mit Hilfe dieses Filtertyps wählen Sie einen Wert aus, den die gefilterten Datensätze enthalten sollen. In der Entwurfsansicht der Datenzugriffsseite können Sie außerdem einem Hyperlink auf der Seite einen Filter zuweisen. Wenn Sie anschließend in der Datenzugriffsseitenansicht oder im Browser auf diesen Hyperlink klicken, werden nur die über den Filter festgelegten Datensätze auf der Seite angezeigt, zu der Sie wechseln.

Zurück zum Anfang

Zurück zu Erstellen eines Filters für eine Datenzugriffsseite


Erstellen von Filtern für Datenzugriffsseiten

Mit Hilfe von Filtern können Sie die Datenzugriffsseite so begrenzen, dass nur bestimmte Untermengen der Datensätze angezeigt werden bzw. bearbeitet werden können.

Was möchten Sie tun?

Datensätze vor dem Abrufen aus der Datenbank eingrenzen

Einen Filter erstellen, der Datensätze auf einer ungruppierten Datenzugriffsseite findet

Einen Filter auf einer gruppierten Datenzugriffsseite erstellen

In einem Microsoft Access-Projekt einen Filter mittels Visual Basic für Applikationen oder Microsoft Visual Basic Scripting Edition (VBScript) erstellen

In einer Microsoft Access-Datenbank einen Filter mittels Visual Basic für Applikationen oder VBScript erstellen

Datensätze nach dem Abrufen aus der Datenbank eingrenzen

Einen Filter in der Datenzugriffsseitenansicht erstellen, um Datensätze nach dem Abrufen aus der Datenbank einzugrenzen

Einen Hyperlink erstellen, der Datensätze auf einer Datenzugriffsseite filtert, zu welcher der Hyperlink führt

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Suchen nach Daten unter Verwendung eines Filters auf einer Datenzugriffsseite in der Seitenansicht

Suchen nach Daten unter Verwendung eines Filters auf einer Datenzugriffsseite in der Seitenansicht

Mit einem Filter können Sie nach Datensätzen suchen, die in einem bestimmten Feld einen bestimmten Wert enthalten. Sie können z. B. nach allen Datensätze suchen, die im Feld Land den Wert Deutschland enthalten. Wenn Sie den Filter anwenden, werden nur die Datensätze in der Datenzugriffsseite angezeigt, die den ausgewählten Wert enthalten. Wenn Sie den Filter entfernen, werden wieder alle Datensätze angezeigt. Für gruppierte Datenzugriffsseiten können Sie die Liste der Gruppen (Gruppenüberschriften) oder die Datensätze innerhalb von Gruppen filtern.

  • Wählen Sie in einem Feld in der Seitenansicht einer Datenzugriffsseite den Wert aus, den Sie zum Filtern von Datensätzen verwenden möchten, und doppelklicken Sie dann in der Datensatznavigationsleiste auf Auswahlbasierter Filter [image].

    Für gruppierte Datenzugriffsseiten zeigen Sie die Datensätze innerhalb der Gruppe an, die Sie filtern möchten, wählen den Wert aus, nach dem Sie filtern möchten und klicken dann in der Datensatznavigationsleiste für diese Gruppe auf Auswahlbasierter Filter [image]. Der Filter gilt nur für die aktuelle Gruppe. D. h., wenn auf einer Seite Kundenbestellungen nach Land sortiert sind, können Sie die Datensätze für Brasilien mit einem Lieferdatum vom 02.06.98 herausfiltern. Dieser Filter gilt dann nur für Brasilien, nicht für die anderen Länder.

    Sie können die Untermenge weiter einschränken. Dazu wählen Sie Werte aus und klicken auf Auswahlbasierter Filter [image], bis alle gewünschten Datensätze herausgefiltert sind. Wenn Sie z. B. nur Datensätze für Kunden in Deutschland mit Lieferdatum 12.05.98 anzeigen möchten, wählen Sie im Feld Land den Wert Deutschland aus und klicken dann auf Auswahlbasierter Filter [image]. Anschließend wählen Sie im Feld Lieferdatum das Datum 12.05.98 aus und klicken erneut auf Auswahlbasierter Filter [image].

Anmerkungen

  • Auch wenn Sie nur einen Teil eines Wertes in einem Feld auswählen, verwendet die Datenzugriffsseite zum Filtern den gesamten Feldwert.

  • Sie können den Filter entfernen und dann während derselben Arbeitssitzung erneut anwenden.

  • Dieses Verfahren gilt nicht für eine PivotTable-Liste oder eine Kalkulationstabelle. Diese Funktionsmerkmale werden unabhängig vom Rest der Daten auf der Datenzugriffsseite gefiltert und können weitere Filtermöglichkeiten unterstützen. Zum Anzeigen weiterer Informationen klicken Sie in der Symbolleiste für die PivotTable-Liste oder die Kalkulationstabelle auf Hilfe [image] und suchen dann nach "Filter".


 Entfernen eines Filters zum Anzeigen aller Datensätze in einer Datenzugriffsseite in der Seitenansicht

Entfernen eines Filters zum Anzeigen aller Datensätze in einer Datenzugriffsseite in der Seitenansicht

  • Klicken Sie in der Seitenansicht einer Datenzugriffsseite in der Datensatznavigationsleiste auf Filter entfernen Filter-Objekt .

Anmerkungen

  • Wenn ein Filter entfernt wird, wird er nicht gelöscht. Sie können ihn sogar nach dem Schließen und erneuten Öffnen der Datenzugriffsseite wieder zuweisen. Dazu klicken Sie in der Datensatznavigationsleiste auf Filter zuweisen Filter-Objekt .

  • Dieses Verfahren gilt nicht für eine PivotTable-Liste oder ein Spreadsheet (Tabellenblatt). Diese Features können unabhängig von den übrigen Daten auf der Datenzugriffsseite gefiltert werden und auch weitere Filtermöglichkeiten unterstützen. Zum Anzeigen weiterer Informationen klicken Sie in der Symbolleiste für die PivotTable-Liste oder das Spreadsheet auf Hilfe [image] , und suchen Sie dann nach "Filter".


 Anwenden eines vorhandenen Filters auf eine Datenzugriffsseite in der Datenzugriffsseitenansicht

Anwenden eines vorhandenen Filters auf eine Datenzugriffsseite in der Datenzugriffsseitenansicht

In früheren Arbeitssitzungen erstellte Filter können erneut verwendet werden.

  • Klicken Sie in der Datenzugriffsseitenansicht auf Filter anwenden Filter-Objekt auf der Datensatznavigationsleiste. Bei gruppierten Datenzugriffsseiten müssen Sie zunächst die Datensätze in der Gruppe anzeigen, die gefiltert werden sollen, bevor Sie auf Filter anwenden Filter-Objekt auf der Datensatznavigationsleiste für diese Gruppe klicken.

Anmerkung Diese Vorgehensweise gilt nicht für PivotTable-Listen oder Kalkulationstabellen. Diese Features können unabhängig von den restlichen Daten auf der Datenzugriffsseite gefiltert werden und unterstützen eventuell noch weitere Filtermöglichkeiten. Weitere Informationen hierzu erhalten Sie, indem Sie auf Hilfe [image] auf der Symbolleiste für die PivotTable-Liste oder Kalkulationstabelle klicken und dann nach dem Stichwort "Filter" suchen.


 Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular

Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular

Sie können Datensätze in der Formularansicht eines Formulars oder in der Datenblattansicht einer Tabelle, einer Abfrage oder eines Formulars auch dann sortieren, wenn bereits ein Filter zugewiesen wurde. Sie können gefilterte Daten auch sortieren, indem Sie im Fenster Spezialfilter/-sortierung eine Sortierreihenfolge angeben. Wenn Sie die Ergebnisse einer Abfrage sortieren möchten, geben Sie in der Entwurfsansicht der Abfrage eine Sortierreihenfolge an.

Was möchten Sie tun?

Datensätze in der Datenblattansicht oder der Formularansicht sortieren

Gefilterte Datensätze unter Verwendung des Fensters Spezialfilter/-sortierung oder Datensätze in einem Abfrageergebnis unter Verwendung der Entwurfsansicht der Abfrage sortieren

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Sortieren von Daten auf einer Datenzugriffsseite in der Seitenansicht

Sortieren von Daten auf einer Datenzugriffsseite in der Seitenansicht

Die Daten auf einer Datenzugriffsseite können sortiert werden, einschließlich der Daten, die gruppiert sind. Auf gruppierten Datenzugriffsseiten können die Liste der Gruppen oder Datensätze innerhalb einer Gruppe sortiert werden.

  1. Klicken Sie in der Datenzugriffsseitenansicht auf das Feld, das Sie zum Sortieren von Datensätzen verwenden möchten. Zeigen Sie bei gruppierten Seiten die Datensätze innerhalb einer bestimmten Gruppe an, die Sie sortieren möchten und wählen Sie den zu sortierenden Wert.

  2. Führen Sie einen der folgenden Schritte aus:
    • Um in aufsteigender Reihenfolge zu sortieren, klicken Sie auf Aufsteigend sortieren [image].

    • Um in absteigender Reihenfolge zu sortieren, klicken Sie auf Absteigend sortieren [image].

Anmerkungen

  • Beim Sortieren von Datensätzen innerhalb einer Gruppe ist die Sortierreihenfolge nur für die jeweilige Gruppe gültig. Sie wirkt sich nicht auf die Reihenfolge in anderen Gruppen aus. Ist zum Beispiel eine Datenzugriffsseite nach Ländern sortiert, werden die Namen der Länder in aufsteigender Reihenfolge und unter jedem Land die Angestellten in aufsteigender Reihenfolge nach ihrem Nachnamen aufgeführt. Wenn Sie Personaldatensätze von Mexiko anzeigen und die Angestellten nach ihrem Nachnamen in absteigender Reihenfolge sortieren, sind sowohl die Personaldatensätze für andere Länder als auch die Liste der Länder selbst nach wie vor in aufsteigender Reihenfolge sortiert.

  • Zum Ändern der Sortierreihenfolge klicken Sie auf das zu sortierende Feld und anschließend auf die gewünschte Sortierschaltfläche.

  • Beim Schließen der Datenzugriffsseite geht die Sortierreihenfolge verloren. Die Datensätze können beim Öffnen der Seite erneut sortiert werden.

  • Die Reihenfolge, in der Zahlen, Text und Sonderzeichen sortiert werden, hängt von der Datenbank und den Ländereinstellungen in der Windows-Systemsteuerung ab.

  • Diese Prozedur trifft nicht auf eine PivotTable-Liste oder Kalkulationstabelle zu. Diese Features können unabhängig von den Daten auf der Datenzugriffsseite sortiert werden und möglicherweise auch zusätzliche Sortierfunktionen unterstützen. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie in der Symbolleiste auf Hilfe [image] für die PivotTable-Liste oder Kalkulationstabelle und suchen Sie anschließend nach "sortieren."


 Entfernen einer Sortierreihenfolge aus einer Tabelle, einer Abfrage oder einem Formular

Entfernen einer Sortierreihenfolge aus einer Tabelle, einer Abfrage oder einem Formular

  • Klicken Sie in der Datenblattansicht oder der Formularansicht im Menü Datensätze auf Filter/Sortierung entfernen. Wenn Sie die Sortierreihenfolge im Fenster Spezialfilter/-sortierung angegeben und dort ebenfalls Kriterien für einen Filter definiert haben, können Sie die Sortierreihenfolge im Entwurfsbereich im Feld Sortierung löschen, ohne die Kriterien des Filters zu verändern.


 Überlegungen zum Sortieren von Datensätzen einer Tabelle, Abfrage oder eines Berichts

Überlegungen zum Sortieren von Datensätzen einer Tabelle, Abfrage oder eines Berichts

  • Sortierreihenfolgen werden zusammen mit der entsprechenden Tabelle, Abfrage oder dem Formular gespeichert. Wenn Sie ein neues Formular oder einen neuen Bericht auf der Grundlage einer Tabelle oder Abfrage erstellen, für die eine Sortierreihenfolge gespeichert ist, übernimmt das neue Formular bzw. der neue Bericht diese Sortierreihenfolge.

  • Microsoft Access kann in einem oder mehreren Feldern, im Ergebnis einer Abfrage oder einem Spezialfilter, nach bis zu 255 Zeichen suchen.

  • Die Sortierreihenfolge ist abhängig von der Spracheinstellung, die Sie beim Anlegen Ihrer Datenbank im Dialogfeld Optionen angeben. Um diese Einstellung zu überprüfen oder zu ändern, klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Allgemein, um die Einstellung unter Sortierreihenfolge bei neuer DB anzuzeigen. Wenn Ihre Datenbank eine verknüpfte Tabelle aus einer Datenbank enthält, die die Sortierreihenfolge einer anderen Sprache verwendet, hat für Microsoft Access die Sortierreihenfolge der Datenbank Priorität, welche die Verknüpfung mit der Tabelle enthält, also nicht die Sortierreihenfolge der Datenbank, in der die Tabelle gespeichert ist.

  • Wenn der Entwurfsbereich für die Abfrage oder den Filter das Sternchen (*) aus der Feldliste enthält, können Sie erst eine Sortierreihenfolge im Entwurfsbereich angeben, wenn Sie die Felder, nach denen sortiert werden soll, dem Entwurfsbereich hinzugefügt haben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Verwenden Sie die aufsteigende Sortierreihenfolge, um Datums- und Zeitangaben so zu sortieren, dass Sie mit der ersten Angabe beginnen. Verwenden Sie die absteigende Sortierreihenfolge, um mit der aktuellsten Angabe beginnend zu sortieren.

  • Numerische Daten, die in Textfeldern gespeichert sind, werden als Zeichenfolgen, nicht als numerische Werte, sortiert. Um diese in numerischer Reihenfolge zu sortieren, müssen alle Textzeichenfolgen die gleiche Länge besitzen, wobei Sie kürzere Zahlen mit führenden Nullen auffüllen müssen. Das Ergebnis einer aufsteigenden Sortierung der Textzeichenfolge "1", "2", "11" und "22" lautet z.B. "1", "11", "2", "22". Damit die Zeichenfolgen korrekt sortiert werden, müssen Sie die einstelligen Zahlen mit einer führenden Null auffüllen: "01", "02", "11", "22". Für Felder, die keine Null-Werte enthalten, ist das Sortieren numerischer Werte in Zeichenfolgen mit Hilfe der Funktion Wert eine weitere Möglichkeit. Wenn z.B. die Spalte Alter ein Textfeld ist, das numerische Werte enthält, werden die Datensätze durch Angabe von Wert([Alter]) in einer Zelle der Zeile Feld und einer Sortierreihenfolge in der Zelle Sortierung in die richtige Reihenfolge gebracht. Wenn Sie in einem Textfeld nur Zahlen oder Datumsangaben speichern, ist es sinnvoll, den Datentyp des Feldes in der Tabelle, in der das Feld gespeichert ist, in Zahl, Währung oder Datum/Uhrzeit umzuwandeln. Wenn Sie das Feld dann sortieren, werden Zahlen oder Datumsangaben in die korrekte Reihenfolge gebracht, ohne dass führende Nullen benötigt werden.

  • Wenn Sie ein Feld in aufsteigender Reihenfolge sortieren, werden die Datensätze zuerst aufgeführt, in denen das Feld leer ist (einen Nullwert enthält). Wenn ein Feld sowohl Nullwerte als auch leere Zeichenfolgen enthält, werden die Felder mit den Nullwerten als erste in der Sortierreihenfolge angezeigt, unmittelbar gefolgt von den leeren Zeichenfolgen.

  • Felder vom Datentyp Memo, Hyperlink oder OLE-Objekt können nicht sortiert werden.


 Gemeinsame Nutzung einer Access-Datenbank über ein Netzwerk

Gemeinsame Nutzung einer Access-Datenbank über ein Netzwerk

Wenn Ihr Computer in ein Netzwerk eingebunden ist, können Sie zusammen mit anderen gleichzeitig mit derselben Microsoft Access-Datenbank arbeiten. Es gibt mehrere Möglichkeiten, Daten in einer Mehrbenutzerumgebung gemeinsam zu nutzen. Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Gemeinsame Nutzung der gesamten Access-Datenbank

Gemeinsame Nutzung der Tabellen einer Access-Datenbank

Gemeinsame Nutzung der Access-Datenbank über das Internet

Replizieren der Access-Datenbank

Erstellen einer Client/Server-Anwendung

Gemeinsame Nutzung der gesamten Access-Datenbank

Sie können die gesamte Access-Datenbank auf einem Netzwerkserver oder in einem freigegebenen Ordner installieren. Dies ist das einfachste Verfahren. Jeder kann auf die Daten zugreifen und dieselben Formulare, Berichte, Abfragen, Makros und Module benutzen. Verwenden Sie diese Methode, wenn jeder Benutzer die Access-Datenbank auf dieselbe Weise verwenden können soll, oder wenn Sie nicht in der Lage sind, Benutzern die Erstellung eigener Objekte zu ermöglichen. Weitere Informationen über die gemeinsame Nutzung einer Datenbank über einen Netzwerkserver.

Zurück zum Anfang

Gemeinsame Nutzung der Tabellen einer Access-Datenbank

Sie können sich auch darauf beschränken, nur die Tabellen auf einem Netzwerkserver zu installieren und die anderen Datenbankobjekte auf den Computern der Benutzer zu verwalten. In diesem Fall ist mit einem schnelleren Verhalten der Access-Datenbank zu rechnen, da nur die Daten über das Netzwerk gesendet werden. Außerdem können die Benutzer ihre Formulare, Berichte und anderen Objekte ihren eigenen Erfordernissen und Präferenzen anpassen, ohne dabei die Belange anderer Benutzer zu tangieren.

Die Trennung der Tabellen von den anderen Datenbankobjekten können Sie mit Hilfe des Assistenten zur Datenbankaufteilung durchführen.

Zurück zum Anfang

Gemeinsame Nutzung von Access-Datenbankobjekten oder Access-Datenzugriffsseiten über das Internet

Sie können eines oder mehrere Datenbankobjekte im statischen HTML-Format oder als serverseitig generierte HTML-Datei ausgeben, oder Datenzugriffsseiten erstellen und diese anschließend in einem Browser wie z.B. Internet Explorer im World Wide Web anzeigen. Weitere Informationen über die drei Arten von Webseiten, die mit Access erstellt werden können.

Zurück zum Anfang

Replizieren der Access-Datenbank

Bei Verwendung mehrerer Computer, beispielsweise einem Arbeitsplatzrechner und einem Laptop, können Sie mit dem Microsoft Windows-Aktenkoffer mehrere Replikate Ihrer Access-Datenbank erstellen und diese Replikate synchronisieren. Darüber hinaus können mehrere Benutzer, die sich an verschiedenen Orten aufhalten, gleichzeitig mti ihren eigenen Kopien arbeiten und diese dann über das Netzwerk synchronisieren. Die Synchronisation kann über eine Einwählverbindung oder über das Internet erfolgen. Weitere Informationen über das Replizieren einer Datenbank.

Zurück zum Anfang

Erstellen einer Client/Server-Anwendung

Wenn Sie in einer Client/Server-Umgebung arbeiten, können Sie die Vorteile nutzen, die sich aus den zusätzlichen Möglichkeiten und Sicherheitsmerkmalen einer Client/Server-Anwendung ergeben. Weitere Informationen über das Erstellen einer solchen Anwendung finden Sie in Kapitel 16, "Mehrbenutzer-Datenbankenanwendungen", im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang


Bearbeiten von Daten einer Access-Datenbank in einer Mehrbenutzerumgebung

In einer Mehrbenutzerumgebung können mehrere Benutzer gleichzeitig an denselben Datensätzen arbeiten. Da es vorkommen kann, dass die Daten, die Sie gerade bearbeiten, von anderen Benutzern geändert oder sogar gelöscht werden, kommt es gelegentlich zu Konfliktsituationen.

Microsoft Access hilft Ihnen, den Status von Datensätzen während ihrer Bearbeitung zu überprüfen und sicherzustellen, dass Sie mit den aktuellsten Daten arbeiten. Wenn mehrere Benutzer versuchen, denselben Datensatz zu bearbeiten, zeigt Microsoft Access eine Meldung an, die Sie beim Lösen der Konflikte unterstützt. Wenn Sie z.B. versuchen, einen Datensatz zu speichern, der von einem anderen Benutzer gesperrt ist, zeigt Microsoft Access dessen/deren Namen an.

Um Sie beim Überprüfen des Datensatzstatus zu unterstützen, zeigt Microsoft Access die folgenden Symbole im aktuellen Datensatzmarkierer an.

Symbol | Bedeutung
 | Dies ist der aktuelle Datensatz; er wurde noch nicht bearbeitet.
 | Sie haben diesen Datensatz bearbeitet, aber Ihre Änderungen noch nicht gespeichert. Solange dieses Symbol angezeigt wird, können die anderen Benutzer die von Ihnen vorgenommenen Änderungen am Datensatz nicht sehen. Außerdem können sie den Datensatz nicht bearbeiten, wenn Sie ihn gesperrt haben. Um den Datensatz für die weitere Bearbeitung freizugeben, speichern Sie ihn, oder machen Sie Ihre Änderungen rückgängig.
 | Dieser Datensatz ist von einem anderen Benutzer gesperrt. Sie können ihn nicht bearbeiten. Wenn Sie versuchen, Daten in einen gesperrten Datensatz einzugeben, gibt Microsoft Access einen Signalton aus.

Um Informationen zum Auswählen einer Strategie zum Sperren von Datensätzen zu erhalten, klicken Sie auf [image] .


 Speichern von Änderungen am Entwurf einer gemeinsam genutzten Microsoft Access-Datenbank

Speichern von Änderungen am Entwurf einer gemeinsam genutzten Microsoft Access-Datenbank

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Speichern von Änderungen am Entwurf einer gemeinsam genutzten Microsoft Access-Datenbank

Unterschiede zwischen größeren und kleineren Entwurfsänderungen

Strategien für das gemeinsame Entwerfen und Entwickeln einer Access-Datenbank

Weitere Informationen

Speichern von Änderungen am Entwurf einer gemeinsam genutzten Microsoft Access-Datenbank

Sie können keine am Entwurf einer Access-Datenbank vorgenommenen Änderungen speichern, während gleichzeitig andere Benutzer die Datenbank gemeinsam mit Ihnen benutzen. Die einzige Möglichkeit, sicherzustellen, dass diese Änderungen gespeichert werden, besteht darin, die Access-Datenbank mit exklusivem Zugriff zu öffnen.

Im Allgemeinen gilt, dass bei dem Versuch, bei gemeinsamer Benutzung einer Datenbank eine Entwurfsänderung an einem Datenbankobjekt (außer Tabellen und Abfragen) oder einem Feld vorzunehmen, Access denjenigen Benutzer, der die Änderung zu speichern versucht, zeitweise mit exklusivem Zugriff für die Access-Datenbank ausstattet, sofern er zu diesem Zeitpunkt der einzige Benutzer der Datenbank ist. Nach dem Speichern aller Entwurfsänderungen und dem Schließen aller Fenster der Entwurfsansicht kehrt Access hinsichtlich der geänderten Access-Datenbank zum Modus der gemeinsamen Nutzung zurück. In der Zwischenzeit sind andere Benutzer nicht in der Lage, die Access-Datenbank zu öffnen.

Wenn ein anderer Benutzer die Access-Datenbank im Modus für die gemeinsame Nutzung geöffnet hat und Sie versuchen, eine größere Entwurfsänderung beispielsweise an einem Formular vorzunehmen, signalisiert Access Ihnen, dass Sie diese Änderungen möglicherweise nicht speichern können. Hat ein anderer Benutzer die Access-Datenbank im Modus für die gemeinsame Nutzung geöffnet, während Sie versuchen, eine kleinere Entwurfsänderung vorzunehmen, beispielsweise Änderungen der Druckereinstellungen, so erhalten Sie von Access keinen Hinweis darauf, dass Ihre Änderungen unter Umständen nicht gespeichert werden können. In beiden Fällen sollten Sie möglicherweise solange warten, bis Sie der einzige Benutzer der Access-Datenbank sind, so dass Sie dann Ihre wichtigeren Änderungen speichern können und Access die weniger wichtigen Änderungen speichern kann.

Änderungen in einer Datenzugriffsseite werden anders gehandhabt. Obwohl das Erstellen, Umbenennen, Verschieben und Löschen einer Datenzugriffsseite durchaus den Übergang in den exklusiven Modus verlangt (da diese Operationen Informationen in der Access-Datenbank ändern müssen), ist der exklusive Zugriff beim Bearbeiten einer Datenzugriffsseite nicht erforderlich (da sich die zugehörige HTML-Datei außerhalb der Datenbank im Dateisystem befindet).

Zurück zum Anfang

Unterschiede zwischen größeren und kleineren Entwurfsänderungen

Ohne exklusiven Zugriff auf eine Access-Datenbank werden Sie von Access durch eine entsprechende Meldung darüber informiert, wenn eine größere Entwurfsänderung nicht gespeichert werden kann. Davon sind folgende Vorgänge betroffen:

  • Änderungen an Datenbankobjekten (außer Tabellen und Abfragen) in der Entwurfsansicht

  • Änderungen im Eigenschaftenfenster eines Formulars in der Formularansicht

  • Kompilieren des Projekts, Modifizieren von Projekteigenschaften, Hinzufügen oder Entfernen einer Referenz im Visual Basic-Editor

  • Umbenennen, Einfügen oder Löschen eines Datenbankobjekts

  • Speichern eines Datenbankobjekts unter Verwendung eines anderen Datenbankobjekt-Typs

  • Hinzufügen oder Ändern von Steuerelementen innerhalb einer Befehlsleiste

  • Bearbeiten von benutzerdefinierten Gruppen im Datenbankfenster

  • Erstellen, Umbennen, Verschieben und Löschen einer Datenzugriffsseite

Wenn Sie ohne exklusiven Zugriff auf eine Access-Datenbank eine der folgenden kleineren Änderungen möglicherweise nicht speichern können, erhalten Sie von Access keine Hinweismeldung darüber:

  • Änderungen an Formatierungseigenschaften eines Datenblatts, beispielsweise Linienart und Schriftarten

  • Fixieren von Datenblattspalten, Aufheben der Spaltenfixierung, Aus- und Einblenden von Datenblattspalten

  • Anpassen von Spaltenbreite und Zeilenhöhe der Datenblattansicht

  • Änderung der Filtereinstellungen oder der Sortierreihenfolge für ein Formular oder ein Datenblatt

  • Änderungen am Zustand eines (erweiterten oder ausgeblendeten) Unterdatenblatts

  • Änderungen der OLE/DDE-Verknüpfung eines OLE -Objekts oder des Inhalts eines ungebundenen Objektfelds

  • Änderungen an den Druckereinstellungen

  • Änderungen an einer Befehlsleiste, beispielsweise seiner Position und der Einstellung seines Sichtbarkeitsattributs

  • Änderungen am Layout des Datenbankfensters

Zurück zum Anfang

Strategien für das gemeinsame Entwerfen und Entwickeln einer Access-Datenbank

Wenn Sie den Entwurf einer Access-Datenbank auf mehrere Personen verteilen möchten, sollten Sie dabei die folgenden Hinweise berücksichtigen:

  • Weisen Sie bestimmte Objekte oder Gruppen von Objekten jeweils fest bestimmten Entwicklern zu. Während beispielsweise der eine Entwickler mit dem Formularentwurf beauftragt ist, hat der andere die Aufgabe, Berichte zu entwerfen. Unter diesen Umständen kann dann jeder Entwickler mit einer eigenen Kopie der Access-Datenbank arbeiten. Wenn die Arbeit Ihres Entwicklungsteams soweit fortgeschritten ist, dass Sie die Komponenten des Produkts zusammenfügen und das Produkt testen und freigeben möchten, kann jeder Entwickler seine Datenbankobjekte exportieren und auf diese Weise seine Komponenten aus seiner privaten Kopie der Datenbank in eine zentrale Access-Datenbank übertragen.

  • Verwenden Sie ein Programm zur Quellcode-Verwaltung. Beispielsweise können Sie Microsoft Visual SourceSafe Version 6.0 in Verbindung mit dem Add-In zur Quellcode-Verwaltung verwenden, das in Access die Unterstützung für die Quellcode-Verwaltung mit Visual Source Safe bereitstellt. Dieses Add-In ist über Microsoft Office 2000 Developer (MOD) verfügbar. Bei Verwendung von Visual SourceSafe empfiehlt es sich, regelmäßig den Assistenten zur Leistungsanalyse auszuführen (zeigen Sie dazu im Menü Extras auf Analyse, und klicken Sie dann auf Leistung), um ein optimiertes Leistungsverhalten zu erreichen.

Zurück zum Anfang

Weitere Informationen

Gemeinsame Nutzung einer Access-Datenbank über ein Netzwerk

Aufteilen einer vorhandenen Datenbank in ihre Daten und ihre Objekte

Öffnen einer Access-Datenbank

Festlegen, ob eine Datenbank standardmäßig mit exklusivem Zugriff oder für gemeinsame Nutzung geöffnet werden soll

Zurück zum Anfang


 Informationen zur Auswahl einer Strategie zum Sperren von Datensätzen in einer Access-Datenbank unter den Bedingungen einer Mehrbenutzerumgebung

Informationen zur Auswahl einer Strategie zum Sperren von Datensätzen in einer Access-Datenbank unter den Bedingungen einer Mehrbenutzerumgebung

Wenn Sie einen Datensatz bearbeiten, kann Microsoft Access andere Benutzer automatisch daran hindern, den Datensatz zu ändern, bevor Sie Ihre Bearbeitung abgeschlossen haben.

Wenn ein Benutzer exklusiven Zugriff auf einen Datensatz erhält, wird dies Sperrung genannt. Man unterscheidet beim Sperren drei Strategien:

  • Keine Sperrungen: Microsoft Access sperrt den Datensatz, den Sie gerade bearbeiten, nicht. Wenn Sie versuchen, Änderungen an einem Datensatz, den ein anderer Benutzer ebenfalls geändert hat, zu speichern, zeigt Microsoft Access eine Meldung mit den folgenden Optionen an: Überschreiben der Änderungen des anderen Benutzers, Kopieren Ihrer Version des Datensatzes in die Zwischenablage oder Verwerfen Ihrer Änderungen. Diese Strategie stellt zwar sicher, dass Datensätze immer bearbeitet werden können, es können jedoch Konflikte bei der Bearbeitung auftreten.

  • Bearbeitete Datensätze: Microsoft Access sperrt den Datensatz, den Sie gerade bearbeiten, so dass kein anderer Benutzer ihn ändern kann. Unter Umständen werden auch andere Datensätze gesperrt, die auf dem Datenträger in unmittelbarer Nähe gespeichert sind. Falls ein anderer Benutzer versucht, einen von Ihnen gesperrten Datensatz zu bearbeiten, zeigt Microsoft Access im Datenblatt des anderen Benutzers den Indikator "Gesperrter Datensatz" [image] an. Diese Strategie stellt sicher, dass Sie begonnene Änderungen immer zu Ende führen können. Sie ist geeignet, wenn es nicht häufig zu Konflikten bei der Bearbeitung kommt.

  • Alle Datensätze: Microsoft Access sperrt alle Datensätze im Formular oder Datenblatt (und in den zugrunde liegenden Tabellen), die Sie bis zum Schließen des Formulars oder Datenblattes bearbeiten, so dass sie von niemand anderem bearbeitet oder gesperrt werden können. Diese Strategie ist sehr einschränkend. Sie sollten sie nur dann wählen, wenn Sie wissen, dass Sie jeweils der/die einzige sind, der/die die Datensätze bearbeiten muss.

Um Informationen zum Festlegen einer dieser Optionen zu erhalten, klicken Sie auf [image] .

Anmerkung Wenn Sie Daten in einer verknüpften SQL-Datenbanktabelle unter Verwendung von ODBC bearbeiten, sperrt Microsoft Access die Datensätze nicht. Stattdessen steuern die Regeln der SQL-Datenbank die Sperrung. In diesem Fall verhält sich Microsoft Access so, als ob die Einstellung Keine Sperrungen gewählt wurde, unabhängig davon, welche Einstellung Sie für Ihre Datenbank gewählt haben.


 Optimieren der Leistung von Access-Datenbanken in einer Mehrbenutzerumgebung

Optimieren der Leistung von Access-Datenbanken in einer Mehrbenutzerumgebung

Mit Hilfe der folgenden Richtlinien können Sie die Leistung von Microsoft Access-Datenbanken optimieren, die in einer Mehrbenutzerumgebung eingesetzt werden.

  • Legen Sie die Tabellen auf einem Netzwerk-Server ab; lassen Sie die anderen Datenbankobjekte auf den Computern der Benutzer. Die Leistung der Datenbank ist dann höher, da nur Daten über das Netz gesendet werden müssen. Um die Tabellen von anderen Datenbankobjekten zu trennen, verwenden Sie den Assistenten zur Datenbankaufteilung. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wählen Sie eine angemessene Strategie zum Sperren von Datensätzen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wählen Sie eine Strategie zur Sperrung von Ebenen.

  • Vermeiden Sie Konflikte beim Sperren. Dazu ändern Sie gegebenenfalls die Einstellungen für das Intervall für Anzeigeaktualisierung, das Intervall für Datenaktualisierung, die Anzahl der Datenaktualisierungsversuche und das Intervall für ODBC-Anzeigeaktualisierung (wenn zutreffend). Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Optimieren Sie die Tabellenleistung. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Verbessern Sie die Leistung von Access-Datenbanken mit verknüpften Tabellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Verbessern Sie die Leistung von Access-Datenbanken, die mit einer SQL-Tabelle verknüpft sind. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Konvertieren Sie die Arbeitsgruppeninformationsdatei. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Gemeinsames Nutzen einer Datenbank auf einem Netzwerk-Server

Gemeinsames Nutzen einer Datenbank auf einem Netzwerk-Server

  1. Richten Sie eine Freigabe auf einem Netzwerk-Server ein. Unter Umständen benötigen Sie dabei die Unterstützung Ihrer Netzadministrator.

  2. Kopieren Sie die Microsoft Access-Datenbank auf den Netzwerk-Server.

  3. Vergewissern Sie sich, dass die Datenbank so eingerichtet ist, dass sie im Modus für die gemeinsame Nutzung, der Standardeinstellung, geöffnet wird.

    Wie wird's gemacht?

Anmerkung Um von einem anderen Computer auf die gemeinsam genutzte Access-Datenbank zugreifen zu können, muss auf diesem folgendes vorgenommen worden sein: eine lokale Installation von Microsoft Access, eine Netzwerk-Installation von Microsoft Access (mit Lizenz pro Benutzer) oder eine Laufzeitanwendung. Beim Kauf von Microsoft Office 2000 Developer (MOD) erhalten Sie eine gebührenfreie Lizenz zur Installation der Laufzeitanwendung auf jedem Computer.


 Gemeinsames Nutzen einer Access-Datenbank, wenn kein Netzwerk-Server vorhanden ist

Gemeinsames Nutzen einer Access-Datenbank, wenn kein Netzwerk-Server vorhanden ist

  1. Kopieren Sie die Microsoft Access-Datenbank in einen freigegebenen Ordner. (Informationen zur Freigabe von Ordnern finden Sie im Hilfeindex von Microsoft Windows.)

  2. Vergewissern Sie sich, dass die Access-Datenbank so eingerichtet ist, dass sie im Modus für die gemeinsame Nutzung, der Standardeinstellung, geöffnet wird.

    Wie wird's gemacht?

Anmerkung Um von einem anderen Computer auf die gemeinsam genutzte Access-Datenbank zugreifen zu können, muss auf diesem folgendes vorgenommen worden sein: eine lokale Installation von Microsoft Access, eine Netzwerk-Installation von Microsoft Access (mit Lizenz pro Benutzer) oder eine Laufzeitanwendung. Beim Kauf von Microsoft Office 2000 Developer (MOD) erhalten Sie eine gebührenfreie Lizenz zur Installation der Laufzeitanwendung auf jedem Computer.


 Aufteilen einer vorhandenen Access-Datenbank in Daten und Objekte

Aufteilen einer vorhandenen Access-Datenbank in Daten und Objekte

Bei diesem Verfahren wird eine Microsoft Access-Datenbank in zwei Dateien aufgeteilt: die eine enthält die Tabellen und die andere die Abfragen, Formulare, Berichte, Makros, Module und Verknüpfungen zu Datenzugriffsseiten. Auf diese Weise können Benutzer, die die Daten benötigen, ihre eigenen Formulare, Berichte, Seiten und anderen Objekte individuell gestalten, während sie nur auf eine einzige Datenquelle über das Netzwerk zugreifen.

  1. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie dann auf Assistent zur Datenbankaufteilung.

  2. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten zur Datenbankaufteilung.


 Festlegen, ob eine Access-Datenbank standardmäßig mit exklusivem Zugriff oder freigegeben geöffnet werden soll

Festlegen, ob eine Access-Datenbank standardmäßig mit exklusivem Zugriff oder freigegeben geöffnet werden soll

Dieses Verfahren legt fest, wie eine Microsoft Access-Datenbank ausschließlich auf Ihrem Computer geöffnet wird. Es wirkt sich nicht auf die Standardeinstellung der Benutzer anderer Computer aus.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Weitere.

  3. Wenn Sie zulassen möchten, dass andere Benutzer die Access-Datenbank auch dann öffnen können, wenn Sie sie geöffnet haben, klicken Sie auf Freigegeben.

    Wenn Sie über alleinigen Zugriff auf eine Access-Datenbank, die Sie geöffnet haben, verfügen möchten, klicken Sie auf Exklusiv.

Anmerkungen

  • In einer Mehrbenutzerumgebung können Sie eine Access-Datenbank im exklusiven und/oder schreibgeschützten Modus öffnen, auch wenn Sie als Standardmodus den freigegebenen Modus angeben. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .

  • Wenn Sie in Ihrer Mehrbenutzerumgebung Zugriffsschutz einrichten, können Sie sicherstellen, dass andere Benutzer eine Access-Datenbank nicht exklusiv öffnen, indem Sie Ihnen die Berechtigung Exklusiv für die Datenbank nicht erteilen. Zum Anzeigen weiterer Informationen zum Löschen von Berechtigungen zu erhalten, klicken Sie auf [image] .

  • Wenn Sie eine Access-Datenbankdatei im freigegebenen Modus öffnen, erstellt Microsoft Access unter Verwendung desselben Dateinamens (zum Beispiel Nordwind.ldb) und im selben Ordner, in dem sich die Datenbankdatei befindet, eine Datei mit Sperrungsinformationen (.ldb). Diese Datei speichert den Computernamen (wie zum Beispiel MeinComputer) und den Sicherheitsnamen (wie zum Beispiel Admin) jedes einzelnen Benutzers der Datenbank. In Microsoft Access werden diese Informationen zur Konkurrenzsteuerung verwendet. In den meisten Fällen wird in Microsoft Access diese Datei automatisch gelöscht, sobald der letzte Benutzer die Datenbank schließt.


 Tipps für das Bearbeiten von Access-Datenbankobjekten in einer Mehrbenutzerumgebung

Tipps für das Bearbeiten von Access-Datenbankobjekten in einer Mehrbenutzerumgebung

  • Es ist sinnvoll, Objekte zu entwerfen, bevor andere Benutzer die Microsoft Access-Datenbank für die gemeinsame Nutzung öffnen können. Wenn Sie Änderungen am Entwurf vornehmen möchten, können Sie sicherstellen, dass außer Ihnen niemand mit der Access-Datenbank arbeitet, wenn Sie sie öffnen, indem Sie im Dialogfeld Öffnen auf der Schaltfläche Öffnen auf Exklusiv öffnen klicken. Weitere Informationen über das Speichern von Änderungen an einer gemeinsam genutzten Microsoft Access-Datenbank.

  • Wenn ein anderer Benutzer eine Tabelle geöffnet hat oder sich Daten in Abfragen, Formularen oder Berichten ansieht, die auf der Tabelle basieren, können Sie keine Änderungen am Tabellenentwurf vornehmen. Microsoft Access teilt Ihnen dann mit, dass die Tabelle schreibgeschützt ist.

  • Wenn Objekte voneinander abhängig sind, aktualisieren Sie diese stets gleichzeitig, um zu vermeiden, dass andere Benutzer inkonsistente Versionen der Objekte öffnen. Wenn Sie z.B. einem Formular Felder hinzufügen möchten, achten Sie darauf, dass Sie die Felder zunächst der zugrunde liegenden Abfrage hinzufügen, bevor Sie das Formular aktualisieren.

  • Wenn ein anderer Benutzer eine Abfrage geöffnet hat, und Sie nehmen Änderungen daran vor, muss diese(r) Benutzer das geänderte Objekt schließen und erneut öffnen, um die aktuellste Version zu erhalten. Mit Visual Basic für Applikationen-Modulen können andere Benutzer die aktualisierten Funktionen oder Sub-Prozeduren erst ausführen, wenn sie die Access-Datenbank schließen und erneut öffnen.


Festlegen der Standard-Datensatzsperrung für die Bearbeitung von Datensätzen in einer Mehrbenutzerumgebung in einer Access-Datenbank

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Weitere.

  3. Klicken Sie im Feld Standard bei Datensatzsperrung auf die gewünschte Option.

    Um Informationen zu diesen Optionen zu erhalten, klicken Sie auf [image] .


 Angeben der Sperrebene, die in einer Access-Datenbank in einer Mehrbenutzerumgebung verwendet wird

Angeben der Sperrebene, die in einer Access-Datenbank in einer Mehrbenutzerumgebung verwendet wird

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Weitere.

  3. Um die Sperrung auf Datensatzebene zur neuen Standardeinstellung für die aktuelle Microsoft Access-Datenbank zu machen, aktivieren Sie das Kontrollkästchen DB mit Sperrung auf Datensatzebene öffnen.

    Um die Sperrung auf Seitenebene zur neuen Standardeinstellung für die aktuelle Access-Datenbank zu machen, deaktivieren Sie das Kontrollkästchen DB mit Sperrung auf Datensatzebene öffnen.

Anmerkungen

  • Diese Einstellung tritt beim nächsten Öffnen der Access-Datenbank in Kraft. Sie müssen jedoch den Befehl Öffnen im Menü Datei statt der Liste der zuletzt verwendeten Dateien am unteren Ende des Menüs Datei verwenden. Dieses Verhalten entspricht der Einstellung für den Standardöffnungsmodus.

  • Wenn Sie DB mit Sperrung auf Datensatzebene öffnen aktivieren, wird dies das neue Standardverhalten für den Zugriff auf Daten mit einem Formular, einem Datenblatt und Code, der ein Datensatzgruppenobjekt zum Durchlaufen von Datensätzen verwendet, aber nicht mit Aktionsabfragen oder mit Code, der Mengenoperationen unter Verwendung von SQL-Anweisungen durchführt. Weitere Informationen finden Sie im Kapitel 16, "Datenbankanwendungen für mehrere Benutzer", im Microsoft Office 2000/Visual Basic-Programmierhandbuch.


 Verfahren zum Vermeiden von Konflikten bei der Datensperrung in einer Access-Datenbank unter den Bedingungen einer Mehrbenutzerumgebung

Verfahren zum Vermeiden von Konflikten bei der Datensperrung in einer Access-Datenbank unter den Bedingungen einer Mehrbenutzerumgebung

Microsoft Access stellt vier Einstellungen zur Verfügung, mit deren Hilfe Sie Konflikte mit anderen Benutzern bei der Sperrung von Datensätzen einer Microsoft Access-Datenbank in einer Mehrbenutzerumgebung vermeiden können:

  • Intervall für Anzeigeaktualisierung (s): Legt die Anzahl der Sekunden fest, nach deren Ablauf Microsoft Access automatisch Datensätze in der Datenblattansicht oder Formularansicht aktualisiert. Gültige Werte sind 0 bis 32.766 Sekunden. Wenn Sie das aktuelle Datenblatt oder Formular aktualisieren, werden die Datensätze nicht neu sortiert, keine neuen Datensätze hinzugefügt oder gelöschte Datensätze entfernt. Um diese Änderungen anzuzeigen, müssen Sie die Abfrage für die Datensätze, die dem Datenblatt oder Formular zugrundeliegen, erneut ausführen.

  • Intervall für Datenaktualisierung (ms): Legt die Anzahl der Millisekunden fest, nach deren Ablauf Microsoft Access automatisch versucht, einen geänderten Datensatz, der von einem anderen Benutzer gesperrt ist, zu speichern. Gültige Werte sind 0 bis 1.000 Millisekunden.

  • Anzahl der Datenaktualisierungsversuche (Millisek.): Legt fest, wie oft Microsoft Access versucht, einen geänderten Datensatz, der von einem anderen Benutzer gesperrt ist, zu speichern. Gültige Werte sind 0 bis 10.

  • ODBC-Anzeigeaktualisierungsintervall (Sek.): Legt das Intervall fest, nach deren Ablauf Microsoft Access automatisch die Datensätze aktualisiert, auf die Sie mittels ODBC zugreifen. Gültige Werte sind 1 bis 32.766 Sekunden.

Um Informationen zum Festlegen einer dieser Optionen zu erhalten, klicken Sie auf [image] .


Festlegen von Einstellungen für das Daten- und Anzeigeaktualisierungsintervall für Mehrbenutzerumgebungen und ODBC in einer Access-Datenbank

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Weitere.

  3. Geben Sie in die Felder der zu ändernden Optionen die gewünschten Werte ein.

    Um Informationen zu diesen Optionen zu erhalten, klicken Sie auf [image] .


 Anzeigen der aktuellsten Daten einer Access-Datenbank in der Datenblatt- oder Formularansicht

Anzeigen der aktuellsten Daten einer Access-Datenbank in der Datenblatt- oder Formularansicht

Wenn Sie mit einer Microsoft Access-Datenbank arbeiten, die über ein Netzwerk gemeinsam genutzt wird, kann es vorkommen, dass ein Benutzer die Daten ändert, die Sie gerade in der Datenblatt- oder Formularansicht ansehen. Microsoft Access aktualisiert die angezeigten Daten in regelmäßigen Abständen. Sie können die Einstellung ändern, die angibt, wie oft die Daten automatisch aktualisiert werden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Führen Sie die nachfolgenden Schritte aus, wenn Sie die neuesten Daten sofort anzeigen möchten.

  1. Öffnen Sie eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht oder ein Formular in der Formularansicht.

  2. Klicken Sie im Menü Datensätze auf Jetzt aktualisieren.

Der Befehl Jetzt aktualisieren aktualisiert nur Daten, die sich bereits in Ihrem Datenblatt oder Formular befinden. Er sortiert die Datensätze nicht neu, zeigt keine neuen Datensätze an und entfernt nicht die gelöschten Datensätze oder solche, die den angegebenen Kriterien nicht mehr entsprechen. Um diese Aktionen durchzuführen, müssen Sie für die Datensätze die entsprechende Abfrage erneut durchführen, indem Sie die Tastenkombination UMSCHALT+F9 drücken.


 Ändern der Häufigkeit der automatischen Datenaktualisierung in einer Access-Datenbank in der Datenblatt- oder der Formularansicht

Ändern der Häufigkeit der automatischen Datenaktualisierung in einer Access-Datenbank in der Datenblatt- oder der Formularansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht oder ein Formular in der Formularansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Weitere.

  4. Geben Sie in das Feld Intervall für Datenaktualisierung (ms) die Anzahl der Sekunden an, die zwischen zwei automatischen Datenaktualisierungen vergehen sollen. Wenn Sie beispielsweise 120 eingeben, werden die Daten alle 2 Minuten aktualisiert.

Anmerkung Diese Einstellung wird nur wirksam, wenn die Datenbank gemeinsam über ein Netzwerk genutzt wird. Es werden nur die Daten aktualisiert, die sich bereits in Ihrem Datenblatt oder Formular befinden. Die Datensätze werden nicht neu sortiert, es werden keine neuen Datensätze angezeigt, und die gelöschten Datensätze oder solche, die den angegebenen Kriterien nicht mehr entsprechen, werden nicht entfernt. Um diese Aktionen durchzuführen, müssen Sie für die Datensätze die entsprechende Abfrage erneut durchführen, indem Sie die Tastenkombination UMSCHALT+F9 drücken.


 Bewegen zwischen Datensätzen unter Verwendung der Navigationsschaltflächen in der Datenblatt- oder Formularansicht

Bewegen zwischen Datensätzen unter Verwendung der Navigationsschaltflächen in der Datenblatt- oder Formularansicht

Die Navigationsschaltflächen befinden sich in der Datenblattansicht und in der Formularansicht am unteren Rand des Fensters. Mit diesen Schaltflächen können Sie sich schnell zwischen den Datensätzen hin- und herbewegen.

Aufzeichnen von Navigationsschaltflächen


 Bewegen zwischen Feldern in langen Datensätzen mit Hilfe des Kombinationsfelds "Geht zu dem ausgewählten Feld" in der Datenblattansicht

Bewegen zwischen Feldern in langen Datensätzen mit Hilfe des Kombinationsfelds "Geht zu dem ausgewählten Feld" in der Datenblattansicht

Mit Hilfe des Kombinationsfelds Feld auswählen können Sie sich in der Datenblattansicht mühelos zwischen den Feldern langer Datensätze bewegen.

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Klicken Sie im Menü Ansicht auf Symbolleisten.

  3. Wählen Sie Formatierung (Datenblatt) aus.

  4. Klicken Sie dann auf Schließen.

Das Kombinationsfeld Geht zu dem ausgewählten Feld befindet sich ganz links auf der Symbolleiste Format (Datenblatt). Geben Sie dort den Namen des Feldes im aktuellen Datensatz ein, zu dem Sie gehen möchten.


 Verschieben von Spalten in der Datenblattansicht

Verschieben von Spalten in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Wählen Sie die Spalten aus, die Sie verschieben möchten.

    Zum Auswählen einer Spalte klicken Sie auf den Feldmarkierer für diese Spalte.

    Zum Auswählen benachbarter Spalten klicken Sie auf den Feldmarkierer einer Spalte und ziehen dann mit der Maustaste, ohne diese loszulassen, bis alle gewünschten Spalten ausgewählt sind.

  3. Klicken Sie erneut auf den/die Feldmarkierer, und halten Sie die Maustaste gedrückt.

  4. Ziehen Sie die Spalten dann an eine neue Position.

Anmerkungen

  • Falls die Spalten sich nicht bewegen lassen, sind sie eventuell fixiert. Hier erfahren Sie mehr über fixierte Spalten.

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Ändern der Größe einer Spalte in der Datenblattansicht

Ändern der Größe einer Spalte in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Positionieren Sie den Zeiger entsprechend der folgenden Abbildung auf dem rechten Rand der Spalte, dessen Größe Sie ändern möchten.

    Ändern der Spaltenbreite bzw. Größenanpassung an den Umfang der enthaltenen Daten

  3. Ziehen Sie solange, bis die Spalte die gewünschte Größe erreicht hat.

Anmerkungen

  • Änderungen an der Größe der Spalten können Sie nicht mit Hilfe des Befehls Rückgängig aus dem Menü Bearbeiten rückgängig machen. Zum Rückgängigmachen dieser Änderungen schließen Sie das Datenblatt und klicken nach der Aufforderung zum Speichern des Layouts des Datenblatts auf Nein, keine.

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Ändern der Zeilengröße in der Datenblattansicht

Ändern der Zeilengröße in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Positionieren Sie den Zeiger zwischen zwei Datensatzmarkierern auf der linken Seite des Datenblatts entsprechend der folgenden Abbildung.

    Ändern der Zeilenhöhe für alle Zeilen

  3. Ziehen Sie am Rand der Zeile, bis diese die gewünschte Größe erreicht hat.

Anmerkungen

  • Durch diesen Vorgang wird die Größe sämtlicher Zeilen des Datenblatts geändert.

  • Änderungen an der Größe der Zeilen können Sie nicht mit Hilfe des Befehls Rückgängig aus dem Menü Bearbeiten rückgängig machen. Zum Rückgängigmachen dieser Änderungen schließen Sie das Datenblatt und klicken nach der Aufforderung zum Speichern des Layouts des Datenblatts auf Nein.

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Fixieren von Spalten in der Datenblattansicht und Aufheben der Fixierung

Fixieren von Spalten in der Datenblattansicht und Aufheben der Fixierung

Sie können eine oder mehrere Spalten eines Datenblatts fixieren, so dass diese die äußersten linken Spalten darstellen und immer sichtbar bleiben, egal wie weit nach rechts Sie einen Bildlauf durchführen.

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Wählen Sie die Spalten aus, die Sie fixieren möchten.

    Zum Markieren der Spalte klicken Sie auf den Feldmarkierer für diese Spalte.

    Zum Markieren weiterer Spalten klicken Sie auf den Feldmarkierer der Spalte und ziehen dann mit der Maus, ohne die Maustaste loszulassen, bis alle gewünschten Spalten markiert sind.

  3. Klicken Sie zum Fixieren der ausgewählten Spalten im Menü Format auf Spalten fixieren.

    Um die Fixierung für sämtliche Spalten aufzuheben, klicken Sie im Menü Format auf Spaltenfixierung aufheben.

Anmerkung Sie können Formatierungsänderungen an Datenblättern in einem Microsoft Access-Projekt nur speichern, wenn es sich dabei um ein Formular handelt. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Ausblenden von Spalten in der Datenblattansicht

Ausblenden von Spalten in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Wählen Sie die Spalte(n) aus, die Sie ausblenden möchten.

    Zum Auswählen einer Spalte klicken Sie auf den Feldmarkierer für diese Spalte.

    Zum Auswählen benachbarter Spalten klicken Sie auf den Feldmarkierer einer Spalte und ziehen dann mit der Maustaste, ohne diese loszulassen, bis alle gewünschten Spalten ausgewählt sind.

  3. Klicken Sie im Menü Format auf Spalten ausblenden.

Anmerkungen

  • Um Informationen zum Anzeigen ausgeblendeter Spalten anzuzeigen, klicken Sie auf [image] .

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Anzeigen der ausgeblendeten Spalten in der Datenblattansicht

Anzeigen der ausgeblendeten Spalten in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Klicken Sie im Menü Format auf Spalten einblenden.

  3. Wählen Sie im Dialogfeld Spalten einblenden die Namen der Spalten aus, die Sie wieder anzeigen möchten.

Anmerkungen Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Einstellen von Standardwerten für die Anzeige der Datenblattansicht

Einstellen von Standardwerten für die Anzeige der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Datenblatt.

  4. Klicken Sie auf die gewünschten Optionen.

Anmerkung Diese Optionen überschreiben nicht die Änderungen, die Sie vorher an bestimmten Datenblättern unter Verwendung der Befehle aus dem Menü Format vorgenommen haben. Wenn Sie möchten, dass diese Datenblätter dasselbe Format haben, müssen Sie die Änderungen auch unter Verwendung der Befehle aus dem Menü Format vornehmen oder die mit dem Visual Basic-Code gespeicherten Änderungen entfernen.


 Ändern von Schriftart, -stil, -grad und -farbe in der Datenblattansicht

Ändern von Schriftart, -stil, -grad und -farbe in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Klicken Sie Menü Format auf Schriftart.

  3. Klicken Sie auf die gewünschten Optionen.

Anmerkungen

  • Das Ändern des Formats für ein bestimmtes Datenblatt überschreibt das Standarddatenblattformat, das auf der Registerkarte Datenblatt (Dialogfeld Optionen, Menü Extras) festgelegt wurde.

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch für das Datenblatt die Eigenschaft Datenherkunft eingerichtet wird und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Ändern des Gitternetzlinienstils und der Hintergrundfarbe in der Datenblattansicht

Ändern des Gitternetzlinienstils und der Hintergrundfarbe in der Datenblattansicht

  1. Öffnen Sie eine Tabelle, eine Abfrage, ein Formular, eine Ansicht oder eine gespeicherte Prozedur in der Datenblattansicht.

  2. Klicken Sie im Menü Format auf Datenblatt.

  3. Klicken Sie auf die gewünschten Optionen.

Anmerkungen

  • Das Ändern eines Formats für ein bestimmtes Datenblatt überschreibt das Standarddatenblattformat, das auf der Registerkarte Datenblatt (Dialogfeld Optionen, Menü Extras) festgelegt wurde.

  • Formatierungsänderungen an einem Datenblatt in einem Microsoft Access-Projekt können Sie nur dann speichern, wenn das Datenblatt ein Formular ist. Falls Sie Formatierungsänderungen an einer Tabelle, Ansicht oder gespeicherten Prozedur eines Access-Projekts speichern müssen, erstellen Sie das Datenblatt mit Hilfe des AutoFormular-Assistenten als Formular (wodurch das Datenblatt die Eigenschaft Datenherkunft erhält und sämtliche Felder in das Formular eingefügt werden), und stellen Sie dann die Eigenschaften Standardansicht und ZugelasseneAnsicht(en) auf Datenblatt ein (wodurch sich das Formular wie ein Datenblatt verhält).


 Hinzufügen eines Feldes (einer Spalte) zu einer Tabelle in der Datenblattansicht

Hinzufügen eines Feldes (einer Spalte) zu einer Tabelle in der Datenblattansicht

  1. Öffnen Sie die Tabelle in der Datenblattansicht.

  2. Klicken Sie auf die Spalte, vor der eine neue Spalte eingefügt werden soll, und dann im Menü Einfügen auf Spalte.

  3. Doppelklicken Sie auf den Namen der neuen Spalte, und geben Sie dann einen Namen entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

    Wenn Sie die Definition eines Feldes weiter anpassen möchten, z.B. um den Datentyp zu ändern oder um eine Gültigkeitsregel zu definieren, verwenden Sie die Entwurfsansicht der Tabelle.

Anmerkung Wenn es sich um eine verknüpfte Tabelle handelt, ist der Befehl Spalte nicht verfügbar. Ist die verknüpfte Tabelle eine Microsoft Access-Tabelle, öffnen Sie deren Quelldatenbank, um ein Feld hinzuzufügen. Stammt die verknüpfte Tabelle aber aus einer anderen Anwendung, öffnen Sie die Quelldatei mit dieser Anwendung, um ein Feld hinzuzufügen.


 Info über die Verwendung von Unterdatenblättern

Info über die Verwendung von Unterdatenblättern

Dieses Thema enthält Referenzinformationen über:

Was ist ein Unterdatenblatt?

Verwendungsmöglichkeiten eines Unterdatenblattes

Tabellen- und Abfrageunterdatenblätter

Verschachteln von Unterdatenblättern

Formulare, Unterformulare und Unterdatenblätter

Vergleichen von Unterdatenblättern in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

Weitere Informationen

Was ist ein Unterdatenblatt?

In einem Unterdatenblatt können Sie zusammenhängende oder verknüpfte Daten in einer Tabelle, einer Abfrage, einem Formulardatenblatt oder einem Unterformular anzeigen und bearbeiten. Beispielsweise besitzt in der Beispieldatenbank Nordwind die Tabelle Lieferanten eine 1:n-Beziehung zu der Tabelle Produkte; Sie können also zu jeder Zeile der Tabelle Lieferanten in der Datenblattansicht die Zeilen der Tabelle Produkte in einem Unterdatenblatt anzeigen, die zu ihr in Beziehung stehen.

Die Lieferanten-Tabelle in der Datenblattansicht mit einem Unterdatenblatt der Produkte-Tabelle

Zurück zum Anfang

Verwendungsmöglichkeiten eines Unterdatenblattes

Access erstellt automatisch ein Unterdatenblatt in einer Tabelle, die in einer 1:1-Beziehung steht oder sich auf der "1"-Seite einer 1:n-Beziehung befindet, wenn die Unterdatenblattname-Eigenschaft den Wert Automatisch besitzt. Eine Beziehung wird definiert, indem die Primärschlüssel- und Fremdschlüssel-Felder der in Beziehung zueinander stehenden Tabellen miteinander verglichen werden. Anzeigen von Informationen über Definieren von Beziehungen.

Sie können jedoch jeder Tabelle, Abfrage oder jedem Formular ein Unterdatenblatt hinzufügen. Es kann eine Tabelle oder eine Abfrage als Quellobjekt besitzen (wird in der Unterdatenblattname-Eigenschaft festgelegt). Ein Unterdatenblatt, das einem Unterformular-Steuerelement entspricht, kann eine Tabelle, eine Abfrage oder ein Formular als Quellobjekt besitzen (wird in der Herkunftsobjekt-Eigenschaft des Unterfomular-Steuerlements festgelegt).

Zurück zum Anfang

Tabellen- und Abfrageunterdatenblätter

Sowohl eine Tabelle als auch eine Abfrage können in der Datenblattansicht entweder ein Tabellen- oder ein Abfrageunterdatenblatt enthalten. Wenn eine Tabelle mit mehreren anderen Tabellen in einer 1:1-Beziehung steht, können Sie wählen, welche Tabelle als Unterdatenblatt hinzugefügt werden soll, indem Sie auf das Erweiterungssymbol (+) klicken und im Dialogfeld Unterdatenblatt einfügen eine Tabelle auswählen.

Standardmäßig zeigt Access den Fremdschlüssel oder das bzw. die übereinstimmenden Felder im Unterdatenblatt nicht an. Sie können den Fremdschlüssel oder das bzw. die übereinstimmenden Felder vorübergehend mit Hilfe des Befehls Spalten einblenden (Menü Format) anzeigen, doch wenn Sie das Datenblatt, das das Unterdatenblatt enthält, das nächste Mal öffnen, werden die Spalten erneut ausgeblendet. Das Ein- oder Ausblenden dieser Felder ändert nur das Erscheinungsbild des Unterdatenblattes, jedoch keine Beziehung oder kein Quellobjekt.

Mit Hilfe des Befehls Unterdatenblatt (Menü Einfügen) können Sie in der Datenblattansicht einer Tabelle oder Abfrage ein Unterdatenblatt hinzufügen oder eines ändern. Sie geben die übereinstimmenden Felder zwischen Datenblatt und Unterdatenblatt im Dialogfeld Unterdatenblatt einfügen in den Feldern Verknüpfen von und Verknüpfen nach an. Diese Felder entsprechen den Verknüpfen von- und Verknüpfen nach-Eigenschaften der Tabelle oder Abfrage, die das Unterdatenblatt enthält. Wenn Sie diese Felder leer lassen, zeigt Access nicht nur die übereinstimmenden Zeilen im Unterdatenblatt, sondern alle Zeilen des Unterdatenblattes unter jeder Zeile des Datenblattes an.

Zurück zum Anfang

Verschachteln von Unterdatenblättern

Sie können ein Unterdatenblatt in einem Unterdatenblatt verschachteln (bis zu 8 Ebenen). Jedes Datenblatt oder Unterdatenblatt kann jedoch höchstens ein verschachteltes Unterdatenblatt besitzen. Beispielsweise kann in der Datenbank Nordwind die Tabelle Kunden ein Unterdatenblatt der Tabelle Bestellungen und das Unterdatenblatt der Tabelle Bestellungen ein Unterdatenblatt Bestelldetails enthalten. Die Tabelle Kunden kann jedoch nicht ein Unterdatenblatt der Tabelle Bestellungen und gleichzeitig ein Unterdatenblatt der Abfrage Verkaufspersonal enthalten.

Zurück zum Anfang

Formulare, Unterformulare und Unterdatenblätter

Ein Formular in der Formularansicht oder Datenblattansicht kann auch ein Unterdatenblatt enthalten, es bestehen jedoch Unterschiede zwischen einem Formularunterdatenblatt und einem Abfrageunterdatenblatt:

  • Sie fügen ein Unterdatenblatt in ein Formular ein, indem Sie ein Unterformular-Steuerelement hinzufügen und danach ein Quellobjekt definieren. Dies geschieht durch Festlegen einer Tabelle, Abfrage oder eines Formulars für die Herkunftsobjekt-Eigenschaft des Unterformular-Steuerelements. Ein Unterdatenblatt eines Formulars entspricht einem Unterformular. Wenn das Quellobjekt des Unterformulars ein Formular ist, kann für seine Standardansicht-Eigenschaft der Wert Datenblatt, Einzelnes Formular oder Endlosformular festgelegt werden. Deshalb wird in der Formulardatenblattansicht das Unterdatenblatt auch als einzelnes Formular oder Endlosformular angezeigt. Sie können in einem Unterdatenblatt zwischen Datenblattansicht und Formularansicht umschalten, indem Sie im Menü Ansicht auf Unterformular und dann auf Datenblatt klicken. Wie bei Tabellen- und Abfrageunterdatenblättern zeigt Access nicht nur die übereinstimmenden, sondern alle Zeilen des Quellobjekts an, wenn die Verknüpfen von- und Verknüpfen nach-Eigenschaften des Unterformulars nicht definiert sind.

  • Obwohl ein Formular mehrere Unterformulare enthalten kann, die alle bis zu zwei Ebenen verschachtelt sein können, wird in der Formulardatenblattansicht nur ein Unterdatenblatt angezeigt. Access zeigt das Unterdatenblatt an, das dem ersten Unterformular in der Reihenfolge der Formulare entspricht. Wenn ein Unterformular jedoch eine Tabelle oder Abfrage als Quellobjekt enthält und seine Standardansicht-Eigenschaft den Wert Datenblatt besitzt, können Sie ein weiteres Unterdatenblatt in das Unterdatenblatt einfügen, das dem Unterformular entspricht, und entweder in der Datenblattansicht oder in der Formularansicht bis zu acht Ebenen verschachteln.

  • Wenn Sie zum ersten Mal eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht öffnen, wird das zugehörige Unterdatenblatt nicht erweitert. Wenn Sie jedoch ein Formular zum ersten Mal in der Formularansicht öffnen, wird das Unterdatenblatt erweitert, das dem Unterformular entspricht.

  • Wenn das Quellobjekt des Unterformulars ein Formular ist, können Sie den Fremdschlüssel oder das bzw. die übereinstimmenden Felder in dem Unterdatenblatt dauerhaft anzeigen, das dem Unterformular entspricht.

Anzeigen von Informationen über Unterformulare.

Zurück zum Anfang

Vergleichen von Unterdatenblättern in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

Sie können ein Tabellen- oder Abfrageunterdatenblatt nur in einer Microsoft Access-Datenbank, nicht jedoch in einem Microsoft Access-Projekt verwenden. Sie können jedoch ein Unterdatenblatt in einem Unterformular oder in der Formulardatenblattansicht sowohl in einer Access-Datenbank wie auch in einem Access-Projekt verwenden.

Zurück zum Anfang

Weitere Informationen

Einfügen oder Ändern eines Unterdatenblattes in einer Tabelle oder Abfrage einer Access-Datenbank

Zurück zum Anfang


 Einfügen oder Ändern eines Unterdatenblattes in einer Tabelle oder Abfrage einer Access-Datenbank

Einfügen oder Ändern eines Unterdatenblattes in einer Tabelle oder Abfrage einer Access-Datenbank

Anmerkung Sie können ein Tabellen- oder Abfrage-Unterdatenblatt nur in einer Microsoft Access-Datenbank, nicht aber in einem Microsoft Access-Projekt verwenden.

  1. Öffnen Sie eine Tabelle oder Abfrage in der Datenblattansicht.

  2. Klicken Sie im Menü Einfügen auf Unterdatenblatt.

  3. Klicken Sie auf das Registerblatt Tabellen, Abfragen oder Beide, je nachdem, welche Art von Objekt als Unterdatenblatt eingefügt werden soll.

  4. Klicken Sie auf eine Tabelle oder Abfrage in der Liste.

  5. Klicken Sie im Feld Verknüpfen von auf das Feld, das der Fremdschlüssel oder das übereinstimmende Feld für die Tabelle oder Abfrage sein soll, die das unter Schritt 4 gewählte Unterdatenblatt ist.

  6. Klicken Sie im Feld Verknüpfen nach auf das Feld, das der Primärschlüssel oder das übereinstimmende Feld für die Tabelle oder Abfrage sein soll, die das unter Schritt 1 geöffnete Hauptdatenblatt ist.

Anmerkungen

  • Wenn Sie im Feld Verknüpfen von oder Verknüpfen nach zwei oder mehr Felder festlegen möchten, geben Sie die Feldnamen durch einen Strichpunkt (;) getrennt ein, beispielsweise Nachname;Vorname.

  • Sie können eine Reflexivverknüpfung erstellen, wenn Sie ein Unterdatenblatt einfügen oder ändern. Angenommen, Sie möchten das Personal, das jedem Manager untersteht, als Unterdatenblatt der Tabelle Personal in der Beispieldatenbank Nordwind anzeigen. Öffnen Sie die Tabelle Personal, klicken Sie im Menü Einfügen auf Unterdatenblatt, danach auf die Registerkarte Tabellen und auf die Tabelle Personal. Klicken Sie im Feld Verknüpfung von auf Vorgesetzte(r) und danach im Feld Verknüpfung von auf Personal-Nr.


 Erweitern oder Reduzieren eines Unterdatenblattes

Erweitern oder Reduzieren eines Unterdatenblattes

Nachdem Sie die Tabelle, die Abfrage oder das Formular mit dem Unterdatenblatt in der Datenblattansicht geöffnet haben, können Sie folgende Schritte ausführen:

Ein Unterdatenblatt für eine Zeile eines Datenblattes oder Unterdatenblattes erweitern

  • Klicken Sie links neben der Zeile auf das Erweiterungssymbol (+).

Alle Unterdatenblätter in dem Datenblatt oder Unterdatenblatt erweitern, das gerade den Fokus besitzt

  • Zeigen Sie im Menü Format auf Unterdatenblatt, und klicken Sie danach auf Alle Ebenen erweitern.

Ein Unterdatenblatt für eine Zeile eines Datenblattes oder Unterdatenblattes reduzieren

  • Klicken Sie links neben der Zeile auf das Erweiterungssymbol (-).

Alle Unterdatenblätter in dem Datenblatt oder Unterdatenblatt reduzieren, das gerade den Fokus besitzt

  • Zeigen Sie im Menü Format auf Unterdatenblatt, und klicken Sie danach auf Alles ausblenden.


 Entfernen eines Unterdatenblattes aus einer Tabelle oder Abfrage in einer Access-Datenbank

Entfernen eines Unterdatenblattes aus einer Tabelle oder Abfrage in einer Access-Datenbank

Anmerkung Sie können ein Tabellen- oder Abfrage-Unterdatenblatt nur in einer Microsoft Access-Datenbank, nicht aber in einem Microsoft Access-Projekt verwenden.

  1. Öffnen Sie die Tabelle oder Abfrage, die das Unterdatenblatt enthält, in der Datenblattansicht.

  2. Zeigen Sie im Menü Format auf Unterdatenblatt, und klicken Sie danach auf Entfernen.

Anmerkung Das Entfernen eines Unterdatenblattes löscht weder die Tabelle oder Abfrage, noch ändert es eine Beziehung.


Erstellen eines oder mehrerer Unterformulare

Was möchten Sie tun?

Ein Formular und ein Unterformular gleichzeitig erstellen

Ein Unterformular erstellen und zu einem vorhandenen Formular hinzufügen

Ein vorhandenes Formular zu einem anderen Formular hinzufügen zum Erstellen eines Formulars mit Unterformular

Ein Formular mit zwei Unterformularen erstellen

Ein Formular mit einem Unterformular erstellen, das ein weiteres Unterformular enthält


Abfragen: Definition und Funktionsweise

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie F6, um den Themenbereich zu aktivieren. Drücken Sie dann TAB, um die Grafik auszuwählen, und drücken Sie anschließend die EINGABETASTE.


 Öffnen oder Ausführen einer Abfrage

Öffnen oder Ausführen einer Abfrage

Sie können Auswahl-, Kreuztabellen- oder Aktionsabfragen in der Abfrageentwurfsansicht öffnen. Auswahl- und Kreuztabellenabfragen können Sie darüber hinaus auch in der Datenblattansicht öffnen, um die Ergebnisse der Abfrage anzuzeigen.

Beim Öffnen einer Aktionsabfrage in der Datenblattansicht werden nicht deren Ergebnisse angezeigt. Sie können jedoch in der Datenblattansicht eine Vorschau der Daten anzeigen, auf welche sich das Ausführen der Aktionsabfrage auswirken wird.

Was möchten Sie tun?

Eine Abfrage in der Abfrageentwurfsansicht öffnen

Die Ergebnisse einer Auswahl- oder Kreuztabellenabfrage in der Datenblattansicht anzeigen

Zwischen den Ansichten einer Abfrage wechseln

Eine Vorschau der Datensätze anzeigen, auf die sich eine Tabellenerstellungs-, eine Lösch-, eine Anfüge- oder eine Aktualisierungsabfrage in der Datenblattansicht auswirkt

Eine Tabellenerstellungs-, Anfüge-, Lösch- oder Aktualiserungsabfrage ausführen


Erstellen einer Abfrage

In den meisten Fällen kann Microsoft Access eine Abfrage für Sie erstellen, so dass Sie keine ganz neue Abfrage entwerfen müssen.

Was möchten Sie tun?

Informationen zu den unterschiedlichen Abfragetypen, die erstellt werden können, anzeigen

Informationen zu AutoNachschlagen-Abfragen

Eine vorhandene SQL-Anweisung als Abfrage speichern

Einen Filter erstellen, der als Abfrage gespeichert werden soll

Einen Assistenten zum Erstellen einer der folgenden Abfragen verwenden:

Einfache Auswahlabfrage

Kreuztabellenabfrage

Abfrage zum Suchen nach Duplikatwerten

Abfrage zum Suchen nach Inkonsistenzen

Eine der folgenden Abfragen manuell erstellen:

Auswahlabfrage

Parameterabfrage

Kreuztabellenabfrage

SQL-Abfrage (Unions-, SQL Pass-Through-, Datendefinitions- oder Unterabfrage)

Aktionsabfrage (Tabellenerstellungs-, Lösch-, Anfüge- oder Aktualisierungsabfrage)

AutoNachschlagen-Abfrage


 Erstellen einer Abfrage aus einem Filter in einer Tabelle, einer Abfrage oder einem Formular

Erstellen einer Abfrage aus einem Filter in einer Tabelle, einer Abfrage oder einem Formular

Sie müssen eine Abfrage nicht unbedingt in der Abfrageentwurfsansicht neu erstellen, sondern können auch einen vorhandenen Filter in einer Tabelle, einer Abfrage oder einem Formular als Abfrage speichern. Eine Abfrage bietet mehr Flexibilität als ein Filter. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  1. Zeigen Sie den Filter im Fenster Formularbasierter Filter oder im Fenster Spezialfilter/-sortierung an, und klicken Sie dann in der Symbolleiste auf Als Abfrage speichern [image] .

  2. Geben Sie einen Namen für die Abfrage ein, und klicken Sie dann auf OK.

    Die neue Abfrage erscheint im Datenbankfenster. Sie enthält automatisch alle Felder aus der zugrunde liegenden Tabelle, da für die Eigenschaft AlleFelderAusgeben (OutputAllFields) die Einstellung Ja festgelegt ist. Sie können jedoch bei Bedarf den Entwurf der Abfrage ändern. Um weitere Informationen zum Ändern einer Abfrage sowie zum Einstellen von Abfrageeigenschaften anzuzeigen, klicken Sie auf [image] .

Anmerkung Sie können die Abfrage auch als Filter verwenden. Dies ist z.B. dann sinnvoll, wenn Sie für ein Formular oder ein Datenblatt bereits einen Filter gespeichert haben und die Abfrage als zweiten Filter einsetzen möchten.


 Suche nach doppelten Datensätzen oder Feldwerten in einer Tabelle mit Hilfe eines Abfrage-Assistenten

Suche nach doppelten Datensätzen oder Feldwerten in einer Tabelle mit Hilfe eines Abfrage-Assistenten

Auf Basis der Ergebnisse einer Abfrage zur Duplikatsuche können Sie untersuchen, ob eine Tabelle doppelte Datensätze enthält, oder ermitteln, welche Datensätze in einer Tabelle einen gleichen Wert besitzen. Beispielsweise können Sie nach doppelten Werten in einem Adressfeld suchen, um festzustellen, ob für einen bestimmten Lieferanten Datensätze mehrfach existieren, oder Sie können nach doppelten Werten in einem Feld Stadt suchen, um zu sehen, welche Lieferanten in einer bestimmten Stadt ansässig sind.

Anmerkung Microsoft Access kann alle doppelten Datensätze in einer Tabelle automatisch löschen, allerdings können Sie dazu nicht den Assistenten zur Duplikatsuche verwenden. Um weitere Informationen hierzu zu erhalten, klicken Sie auf [image] .

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Abfrage-Assistent zur Duplikatsuche.

  3. Klicken Sie auf OK.

  4. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten. Falls Sie nicht festlegen, dass zusätzliche Felder zu denen mit doppelten Werten angezeigt werden sollen, werden in den Abfrageergebnissen die Vorkommen jedes doppelten Wertes summiert. Im letzten Dialogfeld können Sie zwischen den Optionen wählen, die Abfrage auszuführen oder die Abfragestruktur in der Entwurfsansicht anzuzeigen.

    Falls die erzeugte Abfrage nicht genau Ihren Vorstellungen entspricht, können Sie den Assistenten erneut ausführen oder die Abfrage in der Entwurfsansicht ändern. Um weitere Informationen zum Ändern von Abfragen in der Entwurfsansicht anzuzeigen, klicken Sie auf [image] .

Sie können jedes Datensatzduplikat, das der Assistent findet, manuell löschen. Um weitere Informationen hierzu anzuzeigen, klicken Sie auf [image] .


Möglichkeiten zum Anpassen einer Abfrage

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie nacheinander F6, um den Themenbereich zu aktivieren, TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


 Entwerfen oder Ändern einer Abfrage

Entwerfen oder Ändern einer Abfrage

In der Abfrageentwurfsansicht können Sie mit Hilfe eines der folgenden Verfahren den Entwurf einer gerade erstellten Abfrage vervollständigen oder eine vorhandene Abfrage ändern. Mit diesen Verfahren können Sie darüber hinaus eine SQL-Anweisung ändern, die als Datenherkunft für ein Formular, einen Bericht oder eine Datenzugriffsseite dient. Änderungen, die Sie in der Abfrageentwurfsansicht ausführen, spiegeln sich in der SQL-Anweisung wider.

Wenn Sie Abfragen in einer Mehrbenutzerumgebung entwerfen oder ändern, müssen Sie bestimmte Punkte berücksichtigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Was möchten Sie tun?

Arbeiten mit einer Tabelle oder einer Abfrage in einer Abfrage

Eine Tabelle oder Abfrage hinzufügen

Eine Tabelle oder Abfrage entfernen

Arbeiten mit Verknüpfungen

Mehrere Tabellen verknüpfen

Die Art der Verknüpfung zwischen Tabellen ändern

Eine Verknüpfung zwischen Tabellen löschen

Arbeiten mit Feldern

Ein Feld hinzufügen

Ein Feld löschen

Ein Feld verschieben

Ein Feld zwischen anderen Feldern einfügen

Einen Feldnamen ändern

Ein Feld in den Ergebnissen einer Abfrage ein- oder ausblenden

Eigenschaften einstellen

Arbeiten im Abfrageentwurfsbereich

Die Breite einer Spalte ändern

Den Entwurfsbereich löschen

Dem Abfrageentwurfsbereich eine Spalte hinzufügen

Festlegen von Kriterien oder einer Sortierreihenfolge

Eine Kriterienzelle einfügen oder löschen

Kriterien setzen oder ändern

Eine Sortierreihenfolge für die Ergebnisgruppe festlegen

Berechnungen an Daten durchführen

Arbeiten mit SQL in einer Abfrage

Die SQL-Anweisung direkt ändern


Informationen zum Verwenden des Sternchens im Abfrageentwurfsbereich

  • Wenn Sie in einer Abfrage das Sternchen (*) markieren, markieren Sie damit gleichzeitig alle Felder. Bei Verwenden des Sternchens beinhalten die Abfrageergebnisse automatisch auch alle Felder, die erst nach dem Erstellen der Abfrage zur zugrunde liegenden Tabelle oder Abfrage hinzugefügt wurden. Gleichzeitig werden auch automatisch alle Felder ignoriert, die nach dem Erstellen der Abfrage gelöscht worden sind.

  • Wenn Sie das Sternchen verwenden, können Sie Datensätze nur dann sortieren oder für Felder Kriterien festlegen, wenn Sie die entsprechenden Felder zusätzlich zum Sternchen zum Entwurfsbereich hinzufügen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie ein Sternchen nicht durch Ziehen, sondern durch Eingeben in die Zeile Feld einfügen, müssen Sie den Tabellennamen ebenfalls manuell einfügen. Geben Sie z. B. Kunden.* ein.

    Sternchen beziehen alle Felder aus einer Tabelle in eine Abfrage ein


 Arbeiten mit leeren Feldern in Abfragen

Arbeiten mit leeren Feldern in Abfragen

Wenn ein Feld keinen Wert enthält, besitzt es entweder einen Null-Wert oder (im Fall von Textfeldern, Memo- oder Hyperlink-Feldern) einen Null-Wert oder eine leere Zeichenfolge. Wenn sich Null-Werte in einem Feld befinden, können diese das Abfrageergebnis beeinflussen. Im folgenden finden Sie einige Richtlinien für die Arbeit mit Null-Werten und leeren Zeichenfolgen in Abfragen. (Um Informationen zu den Unterschieden zwischen Null-Werten und leeren Zeichenfolgen zu erhalten, klicken Sie auf [image] .)

Das vorliegende Thema gibt Informationen zu folgenden Punkten:

Verknüpfen von Feldern, die Null-Werte enthalten

Suchen nach Null-Werten oder leeren Zeichenfolgen

Einfluss von Null-Werten auf numerische Berechnungen

Konvertieren von Null-Werten in 0

Verbinden von Textfeldern, die Null-Werte enthalten

Sortieren über Felder, die Null-Werte und leere Zeichenfolgen enthalten

Verwenden des Sternchen-Platzhalterzeichens (*), um andere Werte als Null-Werte zurückzugeben

Verknüpfen von Feldern, die Null-Werte enthalten

Wenn Sie Tabellen in einer Abfrage verknüpfen, enthält das Ergebnis nur die Datensätze, die in den übereinstimmenden Feldern keine Null-Werte enthalten. Um z.B. Lieferanten und Kunden aus gleichen Regionen aufzulisten, können Sie eine Abfrage erstellen, welche die Tabellen Lieferanten und Kunden enthält, wobei die Tabellen über die Felder Region miteinander verknüpft sind. Wenn Sie sich dann das Ergebnis ansehen, sind dort die Werte der Datensätze aufgelistet, die im Feld Region beider Tabellen einen Wert enthalten.

Zurück zum Anfang

Suchen nach Null-Werten oder leeren Zeichenfolgen

Wenn Sie mit Hilfe einer Abfrage nach Null-Werten oder leeren Zeichenfolgen suchen, geben Sie in eine Zelle der Zeile Kriterien entweder Ist Null ein, um nach Null-Werten zu suchen, oder Anführungszeichen ("") (ohne Leerzeichen zwischen den Anführungszeichen) für die Suche nach leeren Zeichenfolgen.

Zurück zum Anfang

Einfluss von Null-Werten auf numerische Berechnungen

Wenn Sie mit einer Aggregatfunktion die Summe, den Mittelwert, die Anzahl oder einen anderen Betrag für die Werte eines Feldes ermitteln, werden Datensätze mit Null-Werten in diesem Feld bei den Berechnungen nicht berücksichtigt. Dies gilt unabhängig davon, ob Sie für Berechnungen die Zeile Funktion im Entwurfsbereich einer Abfrage, den Auswahlabfrage-Assistenten oder einen benutzerdefinierten Ausdruck verwenden. Wenn Sie z.B. mit der Funktion Anzahl die Anzahl der Werte eines Feldes ermitteln, wird die Anzahl aller Datensätze zurückgegeben, die keine Null-Werte enthalten. Wenn Sie die Gesamtanzahl der Datensätze, einschließlich derjenigen mit Null-Werten, ermitteln möchten, verwenden Sie Anzahl mit dem Sternchen-Platzhalterzeichen (*).

Einschließen von Datensätzen mit Null-Werten unter Verwendung der Funktion "Count"

Wenn Sie einen arithmetischen Operator (z.B. +, -, *, /, ^) in einem Ausdruck (z.B. [Lagerbestand]+[Bestellte Einheiten]) verwenden, der ein Feld mit einem Null-Wert enthält, ist das Ergebnis des gesamten Ausdrucks ein Null-Wert.

Zurück zum Anfang

Konvertieren von Null-Werten in 0

Wenn einige Ihrer Felder Null-Werte enthalten, können Sie einen Ausdruck erstellen, der die Null-Werte in 0 umwandelt. Dies ist sinnvoll, wenn Sie die Datensätze, die Null-Werte enthalten, in einer Aggregatfunktion berücksichtigen möchten, oder wenn Sie vermeiden möchten, dass ein Ausdruck, in dem auf ein Feld mit Null-Werten verwiesen wird, einen Null-Wert als Ergebnis hat. Verwenden Sie die Funktion Nz, um z. B. Null-Werte in 0 zu konvertieren:

Nz([Zwischensumme],0)+Nz([Frachtkosten],0)

Um weitere Informationen zur Funktion Nz zu erhalten, klicken Sie auf [image] .

Zurück zum Anfang

Verbinden von Textfeldern, die Null-Werte enthalten

Wenn Sie mit Hilfe eines Ausdrucks zwei Felder mit Textwerten verbinden, wobei eines oder auch beide Felder Null-Werte enthalten, verwenden Sie statt des Operators + den Operator &. Der Operator & verbindet die Werte auch dann, wenn sie Null-Werte enthalten, während der Operator + Null zurückgibt, sobald einer der beiden Werte Null ist. Zum Beispiel:

Name: [Nachname] & " " & [Vorname]

Zurück zum Anfang

Sortieren nach Feldern, die Null-Werte und leere Zeichenfolgen enthalten

Wenn Sie ein Feld in aufsteigender Reihenfolge sortieren, werden die Datensätze mit einem Null-Wert in diesem Feld als erstes aufgelistet. Wenn ein Feld sowohl Null-Werte als auch leere Zeichenfolgen enthält, werden in der Sortierreihenfolge zuerst die Null-Werte und unmittelbar darauf die leeren Zeichenfolgen angezeigt.

Zurück zum Anfang

Verwenden des Sternchen-Platzhalterzeichens (*), um andere Werte als Null-Werte zurückzugeben

Wenn Sie den Ausdruck Wie "*" beim Definieren von Abfragekriterien für ein Feld verwenden, enthält das Ergebnis in diesem Feld auch leere Zeichenfolgen, aber keine Null-Werte.

Zurück zum Anfang

Weitere Informationen

Möglichkeiten zum Durchführen von Berechnungen in einer Abfrage

Informationen zu Aggregatfunktionen und anderen Optionen in der Zeile "Funktion" des Entwurfsbereichs einer Abfrage

Festlegen einer Sortierreihenfolge für eine Abfrage


Verhindern der Anzeige von Duplikatdatensätzen in Abfrageergebnissen

Was möchten Sie tun?

Duplikatdatensätze in einer Abfrage auf der Basis von Feldern in der zugrunde liegenden Tabelle verhindern

Duplikatdatensätze in einer Abfrage auf der Basis von Feldern im Abfrageentwurfsbereich verhindern

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Beschränken der Anzeige der Ergebnisse einer Abfrage auf die höchsten oder die niedrigsten Werte

Beschränken der Anzeige der Ergebnisse einer Abfrage auf die höchsten oder die niedrigsten Werte

Die Abfrage kann z. B. die Datensätze mit den 10 höchsten oder niedrigsten Werten in einem bestimmten Feld oder 10 % der Datensätze mit den höchsten oder niedrigsten Werten im Feld anzeigen.

  1. Öffnen Sie die Abfrage in der Entwurfsansicht.

  2. Fügen Sie dem Entwurfsbereich die Felder hinzu, die in den Abfrageergebnissen angezeigt werden sollen, einschließlich des Feldes, für das Sie Spitzenwerte anzeigen möchten.

  3. Klicken Sie in der Zelle Sortierung für das Feld, für das Sie Spitzenwerte anzeigen möchten, auf Absteigend, wenn Sie die höchsten Werte anzeigen möchten, oder auf Aufsteigend, wenn Sie die niedrigsten Werte anzeigen möchten. Wenn Sie darüber hinaus andere Felder im Abfrageentwurfsbereich sortieren möchten, müssen sich diese rechts vom Feld für die Spitzenwerte befinden.

  4. Klicken Sie in der Symbolleiste auf das Feld Spitzenwerte [image] .

  5. Geben Sie den Prozentsatz oder die Anzahl der höchsten oder niedrigsten Werte an, die in den Abfrageergebnissen angezeigt werden sollen.

    Anmerkung Zum Angeben eines Prozentwerts geben Sie eine Zahl gefolgt von einem Prozentzeichen (%) ein.

    Festlegen des Prozentsatzes des höchsten oder niedrigsten anzuzeigenden Wertes

  6. Zum Anzeigen der Abfrageergebnisse klicken Sie in der Symbolleiste auf Ansicht [image] .

Anmerkung Das Einstellen der Eigenschaft Spitzenwerte im Eigenschaftenfenster der Abfrage hat dieselbe Funktion wie die Schaltfläche Spitzenwerte auf der Symbolleiste.


 Zusammenfassen von Daten aus mehreren Tabellen oder Abfragen in einer Abfrage

Zusammenfassen von Daten aus mehreren Tabellen oder Abfragen in einer Abfrage

Mit Abfragen können Daten aus mehreren Tabellen oder Abfragen zusammengefasst und Aktionen über diese zusammengefassten Daten ausgeführt werden. Sie können z. B. Kundeninformationen zusammen mit den entsprechenden Bestelldetails anzeigen. Zum Anzeigen dieser Informationen benötigen Sie Daten aus den Tabellen Kunden und Bestellungen.

Wenn eine Abfrage auf mehreren Tabellen oder Abfragen basiert, müssen Sie sicherstellen, dass deren Feldlisten durch eine Verknüpfungslinie miteinander verbunden sind. Microsoft Access erkennt anhand dieser Verknüpfungslinie, wie die Informationen verbunden werden.

Verknüpfungslinien zeigen die Beziehung zwischen Tabellen

Wenn die Tabellen in einer Abfrage weder direkt noch indirekt miteinander verknüpft werden können, weiß Microsoft Access nicht, welche Datensätze welchen zugeordnet werden sollen, und zeigt jede mögliche Kombination von Datensätzen zwischen den Tabellen an (dies wird als "Kreuzprodukt" oder als "kartesisches Produkt" bezeichnet). Wenn daher eine Tabelle zehn Datensätze enthält, enthält die Abfrage 100 Datensätze (10X10). Dies kann zu einer sehr langen Dauer des Ausführens der Abfrage und zu sinnlosen Ergebnissen führen.

Wenn Sie die Beziehungen zwischen Tabellen vorher im Fenster Beziehungen definiert haben, zeigt Microsoft Access beim Hinzufügen verknüpfter Tabellen in der Entwurfsansicht für Abfragen automatisch Verknüpfungslinien an. Wenn die referenzielle Integrität aktiviert ist, zeigt Microsoft Access oberhalb der Verknüpfungslinie eine "1" zur Kennzeichnung der Tabelle auf der "1"-Seite einer 1:n-Beziehung und das Symbol für Unendlichkeit [image] zur Kennzeichnung der Tabelle auf der "n"-Seite an.

Auch wenn Sie noch keine Beziehungen definiert haben, erstellt Microsoft Access beim Hinzufügen zweier Tabellen zu einer Abfrage, die beide ein Feld mit gleichem oder kompatiblem Datentyp enthalten und in denen eines der Verknüpfungsfelder ein Primärschlüssel ist, automatisch Verknüpfungslinien. In diesem Fall werden die "1"- und die "n"-Seite jedoch nicht gekennzeichnet, da keine referenzielle Integrität gefordert ist.

Manchmal enthalten Tabellen, die Sie zu einer Abfrage hinzufügen, keine Felder, die verknüpft werden können. In diesem Fall müssen Sie weitere Tabellen oder Abfragen hinzufügen, die lediglich als Verbindung zwischen den Tabellen dienen, deren Daten Sie verwenden möchten. Wenn z. B. eine Abfrage auf den Tabellen Kunden und Bestelldetails basiert, existiert zwischen diesen keine Verknüpfungslinie, da diese keine Felder enthalten, die verknüpft werden können. Da die Tabelle Bestellungen jedoch mit beiden Tabellen verknüpft ist, können Sie diese zur Abfrage hinzufügen und damit eine Verbindung zwischen den anderen beiden Tabellen herstellen.

Zusätzliche Tabelle in einer Verknüpfung ermöglicht eine Beziehung zwischen Tabellen

Wenn Sie dann Tabellen und Abfragen miteinander verknüpft und in der Entwurfsansicht für Abfragen Felder aus beiden Tabellen oder Abfragen zum Entwurfsbereich hinzugefügt haben, weist die Standardverknüpfung die Abfrage an, in den Verknüpfungsfeldern nach übereinstimmenden Werten zu suchen (dies wird in der Datenbankterminologie als Exklusionsverknüpfung bezeichnet). Wenn übereinstimmende Werte gefunden werden, werden die entsprechenden beiden Datensätze kombiniert und in den Abfrageergebnissen als ein Datensatz angezeigt. Wenn eine Tabelle nicht in einer der anderen Tabellen oder Abfragen über einen übereinstimmenden Datensatz verfügt, erscheint in den Abfrageergebnissen keiner der Datensätze. Wenn die Abfrage alle Datensätze aus einer Tabelle oder Abfrage unabhängig davon anzeigen soll, ob es in der anderen Tabelle oder Abfrage übereinstimmende Datensätze gibt, ändern Sie den Verknüpfungstyp.

Beispiele für unterschiedliche Verknüpfungstypen und deren Einfluss auf Abfrageergebnisse Wenn die Abfrage Datensätze so auswählen soll, dass der Wert im Verknüpfungsfeld größer als, kleiner als, ungleich, größer oder gleich bzw. kleiner oder gleich dem Wert im anderen Verknüpfungsfeld ist, müssen Sie in der SQL-Ansicht eine SQL-Anweisung erstellen.

Anmerkung Es gibt eine Reihe von Faktoren, anhand derer Sie bestimmen können, wann die Daten in einer Abfrage auf der Basis mehrerer Tabellen aktualisiert werden können. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Verknüpfungstypen und deren Einfluss auf Abfrageergebnisse

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie F6, um den Themenbereich zu aktivieren. Drücken Sie dann TAB, um die Grafik auszuwählen, und drücken Sie anschließend die EINGABETASTE.


 Aktivieren oder Deaktivieren von automatischen Verknüpfungen zwischen Tabellen und Abfragen, die zu Abfragen hinzugefügt wurden

Aktivieren oder Deaktivieren von automatischen Verknüpfungen zwischen Tabellen und Abfragen, die zu Abfragen hinzugefügt wurden

Auch wenn Sie keine Beziehungen zwischen Tabellen definiert haben, erstellt Microsoft Access automatisch Verknüpfungen, wenn Sie einer Abfrage zwei Tabellen hinzufügen, die jeweils über ein Feld mit gleichem oder kompatiblem Datentyp verfügen, und eines dieser Felder außerdem ein Primärschlüssel ist. Sie können diese automatischen Verknüpfungen aktivieren oder deaktivieren.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Tabellen/Abfragen.

  3. Aktivieren bzw. deaktivieren Sie das Kontrollkästchen AutoVerknüpfung aktivieren.

Anmerkungen

  • Wenn Sie die automatischen Verknüpfungen deaktivieren, können Sie immer noch manuell Verknüpfungen erstellen.

  • Diese Einstellung bezieht sich nur auf neu erstellte Abfragen.


 Verknüpfen mehrerer Tabellen und Abfragen in einer Abfrage

Verknüpfen mehrerer Tabellen und Abfragen in einer Abfrage

  • Ziehen Sie in der Entwurfsansicht für Abfragen ein Feld aus der Feldliste einer Tabelle oder Abfrage auf das entsprechende Feld (ein Feld desselben oder eines kompatiblen Datentyps, das ähnliche Daten enthält) in der Feldliste der anderen Tabelle oder Abfrage.

    Bei Verwendung dieses Verknüpfungstyps wählt Microsoft Access nur dann Datensätze aus beiden Tabellen oder Abfragen aus, wenn die Werte in den verknüpften Feldern gleich sind.

Verknüpfen von Tabellen durch Ziehen eines Feldes

Anmerkungen

  • Verknüpfen Sie numerische Felder nur dann, wenn für die Einstellung der Eigenschaft Feldgröße für beide Felder eine der Einstellungen Byte, Integer oder Long Integer festgelegt ist.

  • Sie können den Verknüpfungstyp so ändern, dass Microsoft Access alle Datensätze einer Tabelle oder Abfrage unabhängig davon anzeigt, ob es in der anderen Tabelle oder Abfrage übereinstimmende Datensätze gibt. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .


 Verknüpfen von zwei Kopien derselben Tabelle in einer Abfrage

Verknüpfen von zwei Kopien derselben Tabelle in einer Abfrage

Durch das Verknüpfen von zwei Kopien derselben Tabelle entsteht eine Reflexivverknüpfung, die Datensätze aus derselben Tabelle verknüpft, wenn in den verknüpften Feldern übereinstimmende Werte enthalten sind. Angenommen, Sie haben eine Tabelle Personal, in der das Feld Vorgesetzte(r) für jeden Mitarbeiterdatensatz an Stelle des Namens die Kennung des jeweiligen Vorgesetzten enthält. Mit Hilfe einer Reflexivverknüpfung können Sie in den einzelnen Mitarbeiterdatensätzen statt der Kennung den Namen des/der Vorgesetzten anzeigen.

  1. Fügen Sie in der Entwurfsansicht für Abfragen die Tabelle zweimal der Abfrage hinzu.

  2. Erstellen Sie die Verknüpfung durch Ziehen eines Feldes aus der Feldliste der ersten Tabelle auf das Feld in der Feldliste der zweiten Tabelle, mit dem Sie das Feld verknüpfen möchten.

Anmerkungen

  • Zu weiteren Informationen darüber, wie Sie die Reflexivverknüpfung des vorangegangenen Beispiels vervollständigen können, klicken Sie auf [image] .

  • Microsoft Access fügt an den Tabellennamen in der zweiten Feldliste "_1" an. Wenn Sie z. B. die Tabelle Personal zweimal hinzufügen, lautet der Titel der ersten Feldliste "Personal" und der Titel der zweiten Feldliste "Personal_1". Sie können die Tabelle umbenennen, um ihr einen aussagekräftigeren Namen zu geben. Dazu stellen Sie für die Feldliste die Eigenschaft Alias ein. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .


 Ändern der Art der Verknüpfung zwischen Tabellen und Abfragen in einer Abfrage

Ändern der Art der Verknüpfung zwischen Tabellen und Abfragen in einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Doppelklicken Sie auf die Verknüpfungslinie zwischen den Feldlisten für die Tabellen oder Abfragen.

    Doppelklicken Sie auf die Verknüpfungslinie, um das Dialogfeld Verknüpfungseigenschaften zu öffnen

  3. Klicken Sie im Dialogfeld Verknüpfungseigenschaften auf die gewünschte Verknüpfungsoption und dann auf OK.

Beispiele zu unterschiedlichen Verknüpfungsarten und deren Einfluss auf Abfrageergebnisse.

Anmerkungen

  • Im Fenster Beziehungen können Sie den Standardverknüpfungstyp für Tabellen ändern. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .

  • Alle Verknüpfungen, die im Dialogfeld Verknüpfungseigenschaften erstellt werden, wählen nur dann Datensätze aus, wenn die Werte in den verknüpften Feldern gleich sind. Sie können auch Verknüpfungen erstellen, die Datensätze nur dann auswählen, wenn der Wert in einem Verknüpfungsfeld größer als, kleiner als, ungleich, größer oder gleich bzw. kleiner oder gleich dem Wert im anderen Verknüpfungsfeld ist. Dazu müssen Sie in der SQL-Ansicht eine SQL-Anweisung erstellen.


 Löschen von Verknüpfungen zwischen Tabellen und Abfragen innerhalb einer Abfrage

Löschen von Verknüpfungen zwischen Tabellen und Abfragen innerhalb einer Abfrage

  • Wählen Sie in der Abfrageentwurfsansicht die Verknüpfungslinie aus, und drücken Sie die Taste ENTF.

Auswählen der Verknüpfungslinie, um sie zu löschen

Anmerkung Sie können Microsoft Access daran hindern, automatisch Verknüpfungen zwischen Tabellen in Abfragen zu erstellen. Um weitere Informationen hierzu anzuzeigen, klicken Sie auf [image] .


Standardmäßiges Ein- oder Ausblenden von Tabellennamen im Abfrageentwurfsbereich

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Tabellen/Abfragen.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Tabellennamen anzeigen.

Anmerkung Diese Einstellung bezieht sich nur auf neu angelegte Abfragen.


 Erstellen einer AutoNachschlage-Abfrage, die automatisch Daten in neue Datensätze eingibt

Erstellen einer AutoNachschlage-Abfrage, die automatisch Daten in neue Datensätze eingibt

Für die Anwendung der Option AutoNachschlagen auf neue Datensätze werden bestimmte Bedingungen vorausgesetzt. Um weitere Informationen zu erhalten, klicken Sie auf [image] .

  1. Erstellen Sie eine Auswahlabfrage. Fügen Sie zwei Tabellen hinzu, zwischen denen eine 1:n-Beziehung besteht.

    Wie wird's gemacht?

  2. Fügen Sie die Felder für die Abfrage in den Entwurfsbereich ein.

    Dabei müssen Sie das Verknüpfungsfeld für die "n"-Seite der Beziehung einfügen.

    Fügen Sie das Verknüpfungsfeld ein, um eine AutoNachschlagen-Abfrage zu erstellen

  3. Legen Sie bei Bedarf Kriterien zum Auswählen bestimmter Datensätze in der Zeile Kriterien fest.

    Wie wird's gemacht?

  4. Klicken Sie zum Anzeigen der Abfrageergebnisse auf der Symbolleiste auf Ansicht [image] .

    Wenn Sie in das Verknüpfungsfeld auf der "n"-Seite neue Daten eingeben, schlägt Microsoft Access automatisch die entsprechenden Daten auf der "1"-Seite nach und trägt diese ein.

Anmerkung Um Informationen zur Fehlerbeseitigung bei Problemen mit AutoNachschlagen-Abfragen anzuzeigen, klicken Sie auf [image] .


Hinzufügen oder Ändern von Kriterien

Was möchten Sie tun?

Informationen zur Verwendung von Abfragekriterien zum Abrufen bestimmter Datensätze anzeigen

Kriterien zum Abrufen bestimmter Datensätze in eine Abfrage eingeben

Mehrere Kriterien in einer Abfrage festlegen

Allgemeine Einsatzmöglichkeiten für Kriterien anzeigen

Beispiele zu Kriterienausdrücken für Abfragen anzeigen

Informationen zum Festlegen von Kriterien anzeigen, die beim Durchführen von Berechnungen angewendet werden sollen

Kriterien festlegen, wenn im Entwurfsbereich das Sternchen verwendet wird

Eine Parameterabfrage erstellen, die bei jedem Ausführen den Benutzer auffordert, Kriterien einzugeben

Eine Kriterienzeile in einer Abfrage einfügen oder löschen


Möglichkeiten für den Einsatz von Kriterien

Was möchten Sie tun?

Datensätze abrufen, die Werte enthalten, die zwischen den angegebenen Werten liegen, größer bzw. kleiner als die oder gleich bzw. ungleich der angegebenen Werte sind

Datensätze mit Werten abrufen, die mit bestimmten Zeichen oder Wörtern beginnen oder enden oder bestimmte Zeichen oder Wörter enthalten

Datensätze abrufen, die einem Wert nicht entsprechen

Datensätze abrufen, die einen Wert, keine Leerstellen (Null-Werte) enthalten

Datensätze abrufen, die keinen Wert enthalten

Datensätze abrufen, die das aktuelle Datum enthalten

Datensätze abrufen, die einen Wert aus einer Liste möglicher Werte enthalten


 Eingeben von Kriterien in eine Abfrage oder einen Spezialfilter zum Abrufen bestimmter Datensätze

Eingeben von Kriterien in eine Abfrage oder einen Spezialfilter zum Abrufen bestimmter Datensätze

Um weitere Informationen zum Verwenden von Kriterien anzuzeigen, klicken Sie auf [image] .

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht, oder zeigen Sie für eine Tabelle, eine Abfrage oder ein Formular das Fenster Spezialfilter/-sortierung an.

  2. Klicken Sie auf die erste Zelle Kriterien des Feldes, für das Sie Kriterien festlegen möchten.

  3. Geben Sie den Kriterienausdruck entweder durch Eingeben oder mit Hilfe des Ausdrucks-Generators an. Um den Ausdrucks-Generator anzuzeigen, klicken Sie mit der rechten Maustaste auf die Zelle der Zeile Kriterien, und klicken Sie dann auf Erstellen. Um weitere Informationen zur Verwendung des Ausdrucks-Generators anzuzeigen, klicken Sie auf [image] .

    Die aufgerufenen Datensätze entsprechen den Kriterien in beiden Spalten.

    Wenn Ihre Abfrage verknüpfte Tabellen enthält, müssen Sie bei den Werten, die Sie als Kriterien für Felder der verknüpften Tabellen angeben, die Groß-/Kleinschreibung beachten, d.h. die Schreibweise der Kriterien muss den Werten in der zugrunde liegenden Tabelle entsprechen.

    Wenn Sie in einer Abfrage ein Unterdatenblatt anzeigen, enthält das Fenster Spezialfilter/-sortierung nur die Datenherkunft für das ausgewählte Unterdatenblatt. Um die Filterung nach bestimmten Feldern im Hauptdatenblatt oder in einem anderen Unterdatenblatt durchzuführen, schließen Sie das Fenster Spezialfilter/-sortierung, wählen das Haupt- oder Unterdatenblatt aus, auf welches Sie die Filterkriterien beziehen wollen, und öffnen dann das Fenster Spezialfilter/-sortierung erneut.

  4. Um einen weiteren Ausdruck in dasselbe oder ein anderes Feld einzugeben, gehen Sie zur entsprechenden Zelle der Zeile Kriterien und geben den gewünschten Ausdruck ein.

Anmerkungen

  • Zum Anzeigen von Beispielen für Kriterienausdrücke klicken Sie auf [image] .

  • Um Informationen zum Eingeben von Kriterien in eine Abfrage, die Berechnungen durchführt, anzuzeigen, klicken Sie auf [image] .


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas unter Verwendung der Tastatur drücken Sie nacheinander F6, um den Themenbereich zu aktivieren, TAB, um die Grafik auszuwählen, und dann die EINGABETASTE.


 Festlegen von Kriterien oder einer Sortierreihenfolge bei Verwendung des Sternchens im Entwurfsbereich

Festlegen von Kriterien oder einer Sortierreihenfolge bei Verwendung des Sternchens im Entwurfsbereich

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Ziehen Sie das Sternchen (*) aus der Feldliste in die Zeile Feld des Entwurfsbereichs.

  3. Ziehen Sie die Felder, die Sie sortieren bzw. für die Sie Kriterien festlegen möchten, aus der Feldliste in die Zeile Feld.

  4. Wählen Sie in der Zeile Sortierung der zu sortierenden Felder eine Sortierreihenfolge aus.

    Wie wird's gemacht?

  5. Geben Sie in der Zeile Kriterien der entsprechenden Felder die gewünschten Kriterien ein.

    Wie wird's gemacht?

  6. Deaktivieren Sie für alle Felder mit Ausnahme des Sternchens das Kontrollkästchen Anzeigen. Ansonsten werden diese Felder zweimal im Abfrageergebnis angezeigt.

  7. Klicken Sie in der Symbolleiste auf die Schaltfläche Ansicht, um das Ergebnis anzuzeigen.


 Einfügen oder Löschen einer Kriterienzeile in einer Abfrage oder einem Spezialfilter

Einfügen oder Löschen einer Kriterienzeile in einer Abfrage oder einem Spezialfilter

  • Zum Einfügen einer Kriterienzeile in der Abfrageentwurfsansicht oder im Fenster Spezialfilter/-sortierung klicken Sie auf die Zeile, unter der die neue Zeile erscheinen soll, und dann im Menü Einfügen auf Zeile einfügen. Jetzt wird oberhalb der Zeile, die Sie markiert haben, eine neue Zeile eingefügt.

  • Zum Löschen einer Kriterienzeile klicken Sie auf eine beliebige Stelle in der Zeile und dann im Menü Bearbeiten auf Zeilen löschen.


 Verwenden einer Unterabfrage zum Definieren eines Feldes oder eines Kriteriums für ein Feld

Verwenden einer Unterabfrage zum Definieren eines Feldes oder eines Kriteriums für ein Feld

Sie können Unterabfragen verwenden, um z.B. das Vorhandensein von Ergebnissen der Unterabfrage zu überprüfen, nach Werten in der Hauptabfrage zu suchen, die gleich, größer als oder kleiner als Werte sind, die die Unterabfrage zurückgibt, oder um Unterabfragen innerhalb von Unterabfragen zu erstellen.

  1. Erstellen Sie eine neue Abfrage.

  2. Fügen Sie in der Abfrage-Entwurfsansicht dem Entwurfsbereich die gewünschten Felder hinzu, einschließlich der Felder, für die Sie die Unterabfrage verwenden möchten.

  3. Wenn Sie mit Hilfe einer Unterabfrage Kriterien für ein Feld definieren möchten, geben Sie eine SELECT-Anweisung in die Zelle Kriterien desjenigen Feldes ein, für das Sie Kriterien festlegen möchten. Setzen Sie die SELECT-Anweisung in Klammern.

    SELECT-Anweisungen in der Zelle "Kriterien" definieren Unterabfragen.

    Wenn Sie eine Unterabfrage verwenden möchten, um eine Zelle der Zeile Feld zu definieren, geben Sie eine in Klammern gesetzte SELECT-Anweisung in die entsprechende Zelle der Zeile Feld ein. Nachdem Sie die Zelle verlassen haben, fügt Microsoft Access automatisch Ausdr1:, Ausdr2: usw. vor der SELECT-Anweisung ein.

    Anmerkung Um einen größeren Eingabebereich für die SELECT-Anweisung zu erhalten, drücken Sie, während Sie sich in einer Zelle der Zeile Feld oder Kriterien befinden, die Tastenkombination UMSCHALT+F2, und geben Sie die Anweisung im Dialogfeld Zoom ein.

    Im Dialogfeld "Zoom" werden längere Unterabfrageanweisungen angezeigt.

    Um das Feld umzubenennen, ersetzen Sie Ausdr1 durch einen Feldnamen, wie z.B. Kategorie.

  4. Um das Ergebnis anzuzeigen, klicken Sie in der Symbolleiste auf Ansicht [image] .

Anmerkungen

  • Um weitere Beispiele für Unterabfragen zum Definieren von Kriterien anzuzeigen, klicken Sie auf [image] .

  • Sie können ein mit einer Unterabfrage definiertes Feld nicht zum Gruppieren von Datensätzen verwenden.

  • Sie können mit der SQL-Anweisung einer Unterabfrage keine Union-Abfrage oder Kreuztabellenabfrage definieren.


 Abrufen von Datensätzen mit Werten, die zwischen festgelegten Werten liegen oder >, <, >=, <= oder <> festgelegte Werte sind

Abrufen von Datensätzen mit Werten, die zwischen festgelegten Werten liegen oder >, <, >=, <= oder <> festgelegte Werte sind

  1. Erstellen Sie in der Abfrage-Entwurfsansicht eine Abfrage. Fügen Sie die Tabellen mit den gewünschten Datensätzen und dann die Felder, die im Ergebnis enthalten sein sollen, zum Abfrageentwurfsbereich hinzu.

  2. Geben Sie in der Zeile Kriterien des entsprechenden Feldes in einem Ausdruck einen Bereich an. Dazu verwenden Sie den Operator Zwischen...Und oder die Vergleichsoperatoren (<, >, <>, <= und >=). Sie können z. B. nach Bestellungen suchen, die vor dem 01. Januar 93 eingegangen sind, oder nach Artikeln, für die 10 bis 35 Stück auf Lager sind. In der nachstehenden Tabelle sehen Sie einige Beispiele für die Verwendung der Operatoren in Ausdrücken.
    Ausdruck | Bedeutung
    >234 | Zahlen größer als 234
    Zwischen #02.02.95# Und #01.12.95# | Daten vom 02. Feb. 95 bis zum 01. Dez. 95
    <1200,45 | Zahlen kleiner als 1.200,45
    >="Callahan" | Alle Namen von Callahan bis zum Ende des Alphabets

Anmerkung Datumsangaben und Zahlen werden im Abfrageentwurfsbereich in dem in der Windows-Systemsteuerung unter Ländereinstellungen definierten Format angezeigt. Das Format bei Datumsangaben lautet z. B. für die Vereinigten Staaten Monat/Tag/Jahr, für Deutschland dagegen Tag.Monat.Jahr.


 Verwenden einer Abfrage zum Abrufen von Datensätzen, die einem Wert nicht entsprechen

Verwenden einer Abfrage zum Abrufen von Datensätzen, die einem Wert nicht entsprechen

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen und anschließend die Felder, die im Ergebnis enthalten sein sollen, hinzu.

  2. Geben Sie in die Zeile Kriterien des entsprechenden Feldes einen Ausdruck mit dem Operator Nicht ein. Geben Sie z. B. in die Zeile Kriterien des Feldes Firma den Ausdruck Nicht T* ein, wenn Sie nach allen Kunden suchen möchten, deren Namen nicht mit T beginnen, oder geben Sie Nicht 2 in das Feld Firmen-Nr ein, um nach allen Versandfirmen zu suchen, deren Firmennummer ungleich 2 ist.


 Verwenden einer Abfrage zum Abrufen aller Datensätze, die keine Nullwerte enthalten

Verwenden einer Abfrage zum Abrufen aller Datensätze, die keine Nullwerte enthalten

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen und anschließend die Felder, die im Ergebnis enthalten sein sollen, hinzu.

  2. Geben Sie in der Zeile Kriterien des entsprechenden Feldes den Ausdruck Nicht Null oder Ist Nicht Null ein. Wenn Sie z. B. aus einer Tabelle mit Lieferanteninformationen eine Liste der Lieferanten anzeigen möchten, die über Faxnummern verfügen, geben Sie in die Zeile Kriterien für das Feld Telefaxnummer einen der Ausdrücke Nicht Null oder Ist Nicht Null ein.


 Verwenden einer Abfrage zum Abrufen von Datensätzen mit dem aktuellen Datum

Verwenden einer Abfrage zum Abrufen von Datensätzen mit dem aktuellen Datum

Microsoft Access verwendet als aktuelles Datum das Systemdatum der Uhr Ihres Computers.

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen und anschließend die Felder, die im Ergebnis enthalten sein sollen, hinzu.

  2. Geben Sie in der Zeile Kriterien des entsprechenden Feldes die Funktion Datum() (ohne Leerzeichen zwischen den Klammern) ein. Sie können z. B. nach allen Bestellungen suchen, die am aktuellen Tag versendet wurden, indem Sie Datum() im Feld Versanddatum eingeben.


 Verwenden einer Abfrage zum Abrufen von Datensätzen, die einen Wert aus einer Liste möglicher Werte enthalten

Verwenden einer Abfrage zum Abrufen von Datensätzen, die einen Wert aus einer Liste möglicher Werte enthalten

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen und anschließend die Felder, die im Ergebnis enthalten sein sollen, hinzu.

  2. Geben Sie in der Zeile Kriterien des entsprechenden Feldes einen Ausdruck mit dem Operator In ein. Wenn Sie z. B. nach Lieferanten aus Frankreich, Deutschland oder Japan suchen möchten, geben Sie in die Zeile Kriterien des Feldes Land der Tabelle Lieferanten Folgendes ein:

    In (Frankreich;Deutschland;Japan)

    Sie können jedoch auch Folgendes eingeben:

    Frankreich Oder Deutschland Oder Japan


 Verwenden einer Abfrage zum Abrufen von Datensätzen, die keine Werte enthalten

Verwenden einer Abfrage zum Abrufen von Datensätzen, die keine Werte enthalten

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen und anschließend die Felder, die im Ergebnis enthalten sein sollen, hinzu.

  2. Geben Sie in der Zeile Kriterien des entsprechenden Feldes den Ausdruck Ist Null ein. Wenn Sie z. B. aus einer Tabelle mit Lieferanteninformationen eine Liste der Lieferanten anzeigen möchten, die über Faxnummern verfügen, geben Sie in die Zeile Kriterien für das Feld Telefaxnummer den Ausdruck Ist Null ein.


 Extrahieren eines Teils eines bestehenden Textwerts unter Verwendung eines berechneten Feldes

Extrahieren eines Teils eines bestehenden Textwerts unter Verwendung eines berechneten Feldes

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen hinzu.

  2. Geben Sie zum Suchen nach Teilwerten eines Feldes in eine leere Zelle der Zeile Feld des Abfrageentwurfsbereichs einen Ausdruck mit einer der Funktionen Links, Rechts oder Teil ein.

    Die Syntax für diese Funktionen lautet folgendermaßen:

    Links(Zeichenfolgenausdr;n)
    Rechts(Zeichenfolgenausdr;n)
    TeilStr(Zeichenfolgenausdr;Start;n)

    Das Argument Zeichenfolgenausdr kann entweder ein Feldname (in eckigen Klammern) oder ein Textausdruck sein. n bezeichnet die Anzahl der zu extrahierenden Zeichen. Start gibt die Position des ersten Zeichens an, ab dem Sie extrahieren möchten.

    Die nachstehende Tabelle zeigt Beispiele für diese Funktionen.

    Wert im Feld "Teilenummer" | Ausdruck | Ausgabe
    BA-7893-R12 | Links ([Teilenummer];2) | BA
    BA-7893-R12 | Rechts ([Teilenummer];3) | R12
    BA-7893-R12 | TeilStr ([Teilenummer];4;4) | 7893
  3. Fügen Sie bei Bedarf weitere Felder zum Abfrageentwurfsbereich hinzu.


 Extrahieren eines Teils eines bestehenden Datumswerts unter Verwendung eines berechneten Feldes

Extrahieren eines Teils eines bestehenden Datumswerts unter Verwendung eines berechneten Feldes

  1. Erstellen Sie eine Abfrage in der Abfrage-Entwurfsansicht. Fügen Sie zum Abfrageentwurfsbereich die Tabellen mit den gewünschten Datensätzen hinzu.

  2. Geben Sie in eine leere Zelle der Zeile Feld des Abfrageentwurfsbereichs einen Ausdruck mit der Funktion DatTeil ein.

    Die Syntax für diese Funktion lautet folgendermaßen:

    DatTeil (DatTeil;Datum)

    Das Argument DatTeil ist die Abkürzung für den Teil des Datums, den Sie ausgeben möchten, z. B. "jjjj" für eine vierstellige Jahresangabe oder "q" für ein Quartal. Das Argument Datum ist der Name eines Feldes vom Datentyp Datum/Uhrzeit oder ein Literaldatum, wie z. B. 07. November 93.

    Die nachstehende Tabelle zeigt Beispiele für Ausdrücke mit der Funktion DatTeil für das Feld Bestelldatum aus der Tabelle Bestellungen.

    Bestelldatum | Ausdruck | Ausgabe
    03. Jun. 93 | DatTeil ("m";[Bestelldatum]) | 6 (Monat im Jahr)
    28. Mrz 92 | DatTeil ("jjjj";[Bestelldatum]) | 1992 (vierstellige Jahreszahl)
  3. Fügen Sie bei Bedarf weitere Felder zum Abfrageentwurfsbereich hinzu.


 Möglichkeiten zum Durchführen von Berechnungen in einer Abfrage

Möglichkeiten zum Durchführen von Berechnungen in einer Abfrage

Es gibt eine Reihe unterschiedlicher Berechnungen, die Sie in einer Abfrage durchführen können. Sie können z. B. die Summe oder den Mittelwert für die Werte in einem Feld berechnen, die Werte in zwei Feldern multiplizieren oder das Datum drei Monate ab dem aktuellen Datum berechnen.

Wenn Sie die Ergebnisse einer Berechnung in einem Feld anzeigen, werden die Ergebnisse nicht in der zugrunde liegenden Tabelle gespeichert. Stattdessen führt Microsoft Access die Berechnung bei jedem Ausführen der Abfrage erneut durch, damit die Ergebnisse immer auf den aktuellen Daten in der Datenbank basieren. Aus diesem Grund können sie die berechneten Ergebnisse nicht ändern.

Zum Anzeigen der Ergebnisse der Berechnung in einem Feld können Sie eine in Microsoft Access vordefinierte Berechnung verwenden oder eigene Berechnungen definieren. Verwenden Sie die vordefinierten Berechnungen, als "Funktionen" bezeichnet, zum Berechnen der folgenden Werte für Gruppen von Datensätzen oder für alle Datensätze: Summe, Mittelwert, Zahl, Minimalwert, Maximalwert, Standardabweichung oder Varianz. Wählen Sie für jedes Feld, das Sie berechnen möchten, eine Funktion aus.

Berechnungen, die in einer Abfrage angezeigt werden

Zur Berechnung bestimmter Arten von Funktionen können Sie den Auswahlabfrage-Assistenten verwenden, oder berechnen Sie alle Arten von Funktionen unter Verwendung der Zeile Funktion im Entwurfsbereich der Abfrage, wo Sie die Aggregatfunktion für die für ein Feld gewünschte Berechnung auswählen.

Im Entwurfsbereich für Abfragen können Sie auch Kriterien zum Beschränken der Gruppen angeben, für die Funktionen berechnet werden sollen. Außerdem können Sie die Anzahl der Datensätze beschränken, für die die Berechnung durchgeführt werden soll, oder die Ergebnisse beschränken, die nach dem Durchführen der Berechnung angezeigt werden sollen.

Eine benutzerdefinierte Berechnung ermöglicht das Ausführen numerischer, datumsbezogener und textbezogener Berechnungen für jeden Datensatz unter Verwendung von Daten aus einem oder mehr Feldern. Mit einer benutzerdefinierten Berechnung können Sie z. B. den Wert in einem Feld mit einem bestimmten Betrag multiplizieren, den Unterschied zwischen zwei Datumsangaben in separaten Feldern ermitteln, mehrere Werte in einem Textfeld zusammenfassen oder Unterabfragen erstellen. Mit Hilfe der Optionen in der Zeile Funktion im Entwurfsbereich für Abfragen können Sie die Berechnung für Gruppen von Datensätzen durchführen und eine Summe, einen Mittelwert, eine Anzahl oder eine andere Art von Funktion im berechneten Feld ermitteln.

Für benutzerdefinierte Berechnungen müssen Sie ein neues berechnetes Feld direkt im Entwurfsbereich erstellen. Zum Erstellen eines berechneten Feldes geben Sie einen Ausdruck in eine beliebige leere Feld-Zelle im Entwurfsbereich für Abfragen ein.

Berechnete Felder im Entwurfsbereich für Abfragen

Der Ausdruck kann aus mehreren Berechnungen (z. B. Summe([Lagerbestand]+[BestellteEinheiten]) bestehen. Sie können auch Kriterien für ein berechnetes Feld festlegen, die die Ergebnisse der Berechnung beeinflussen.

Sie müssen die Ergebnisse einer Berechnung in einem Feld jedoch nicht anzeigen. Stattdessen können Sie sie als Kriterien zum Ermitteln der Datensätze verwenden, die die Abfrage auswählen soll oder die eine Aktion durchführen sollen. Sie können z. B. in der Zeile Kriterien den folgenden Ausdruck eingeben, um festzulegen, dass die Abfrage nur Datensätze zurückgeben soll, deren Werte im Feld Lieferdatum zwischen dem heutigen Datum und dem Tag ab heute in drei Monaten liegen.

Berechnung zum Definieren von Kriterien für eine Datensatzauswahl

Sie können eine Berechnung auch zum Aktualisieren von Daten aus einer Aktualisierungsabfrage verwenden. Sie können z. B. den folgenden Ausdruck in die Zeile Update To eingeben, um alle Werte im Feld Einzelpreis um 5% zu erhöhen.

Berechnung zum Aktualisieren von Daten


Berechnungsarten in einer Abfrage

Was möchten Sie tun?

Weitere Informationen zum Durchführen von Berechnungen in einer Abfrage erhalten

Informationen zu den einzelnen Funktionen (Aggregatfunktionen) erhalten

Mit dem Auswahlabfrage-Assistenten eine Abfrage erstellen, die eine Summe, einen Mittelwert, eine Anzahl, ein Minimum oder ein Maximum für eine oder mehrere Datensatzgruppen berechnet

Unter Verwendung des Entwurfsbereichs einer Abfrage eine Summe, einen Mittelwert, eine Anzahl oder andere Funktion berechnen

Ein berechnetes Feld für benutzerdefinierte Berechnungen erstellen

Beispiele für Berechnungen ansehen, die als Kriterien verwendet werden

Beispiele für Berechnungen zum Aktualisieren von Daten ansehen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Was ist eine Auswahlabfrage, und wann wird diese verwendet?

Eine Auswahlabfrage ist der gebräuchlichste Abfragetyp. Sie ruft Daten aus einer oder mehreren Tabellen ab und zeigt die Ergebnisse in einem Datenblatt an. Dort können Sie die Datensätze (mit wenigen Einschränkungen) aktualisieren. Mit einer Auswahlabfrage können Sie auch Datensätze gruppieren und Summen, Anzahl, Durchschnittswerte und andere Werte berechnen.

Beispiele für Auswahlabfragen

Zurück zu Abfragetypen


 Erstellen einer einfachen Auswahlabfrage unter Verwendung eines Assistenten

Erstellen einer einfachen Auswahlabfrage unter Verwendung eines Assistenten

Der Auswahlabfrage-Assistent erstellt Abfragen, die Daten aus den angegebenen Feldern einer oder mehrerer Tabellen oder Abfragen abrufen. Der Assistent kann ggf. auch die Summe, die Anzahl oder den Mittelwert der Werte einzelner Datensatzgruppen oder aller Datensätze berechnen. Darüber hinaus kann der kleinste oder größte Wert eines Feldes berechnet werden. Sie können die Datensätze, die abgerufen werden, jedoch nicht durch das Festlegen von Kriterien einschränken.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Auswahlabfrage-Assistent.

  3. Klicken Sie auf OK.

  4. Klicken Sie auf den Namen der Tabelle oder Abfrage, auf der Ihre Abfrage basieren soll, und wählen Sie dann die Felder aus, deren Daten Sie abrufen möchten.

  5. Klicken Sie ggf. auf eine weitere Tabelle oder Abfrage, und wählen Sie auch hier die Felder aus, die Sie verwenden möchten. Wiederholen Sie diesen Schritt solange, bis Sie alle benötigten Felder ausgewählt haben.

  6. Folgen Sie den Anleitungen, die in den Dialogfeldern des Assistenten angezeigt werden. Im letzten Dialogfeld können Sie auswählen, ob Sie die Abfrage ausführen oder die Struktur der Abfrage in der Entwurfsansicht anzeigen möchten.

    Entspricht das Ergebnis der Abfrage nicht genau Ihren Vorstellungen, können Sie den Assistenten erneut ausführen oder die Abfrage in der Entwurfsansicht ändern. Um weitere Informationen zum Ändern einer Abfrage in der Entwurfsansicht anzuzeigen, klicken Sie auf [image] .

Um Informationen zum Behandeln von Problemen mit der Abfrage anzuzeigen, klicken Sie auf [image] .


Erstellen einer Auswahlabfrage ohne Verwendung eines Assistenten

Die in diesem Abschnitt beschriebenen Schritte führen Sie vom Beginn bis zum Ende durch den Vorgang der Erstellung einer Auswahlabfrage. Viele dieser Schritte werden Sie bei jeder Erstellung von Abfragen anwenden. Andere Schritte brauchen Sie nur beim Entwerfen von Abfragen mit Kriterien, die zur Auswahl von Informationen, zur Durchführung von Berechnungen oder zur Festlegung einer Sortierfolge benötigt werden. Verwenden Sie jeweils nur die Schritte, die für die Daten relevant sind, die Sie abrufen wollen. Ziehen Sie für andere Aufgaben in Verbindung mit der Erstellung von Abfragen den Antwort-Assistenten zu Rate.

Anzeige von Beispielen für Auswahlabfragen und ihre Funktion
  1. Hinzufügen einer Tabelle zu einer Abfrage

    Methoden, um Daten aus mehreren Tabellen oder Abfragen innerhalb einer Abfrage zu kombinieren

    Hinzufügen einer Tabelle oder einer Abfrage zu einer Abfrage

    Verknüpfen mehrerer Tabellen und Abfragen innerhalb einer Abfrage

    Ändern des Typs der Verknüpfung zwischen Tabellen und Abfragen innerhalb einer Abfrage

  2. Hinzufügen von Feldern zu einer Abfrage

    Einfügen von Feldern in den Entwurfsbereich einer Abfrage

    Einfügen von Spalten in den Entwurfsbereich einer Abfrage

  3. Festlegen von Abfragekriterien zur Auswahl bestimmter Daten

    Verwendung von Kriterien in Abfragen zum Abrufen bestimmter Datensätze

    Eingeben von Kriterien in eine Abfrage zum Abrufen bestimmter Datensätze

    Einfügen oder Löschen einer Kriterienzeile in einer Abfrage zum Abrufen bestimmter Datensätze

  4. Durchführen von Berechnungen in einer Abfrage

    Erstellen eines Feldes in einer Abfrage, das benutzerdefinierte Berechnungen durchführt oder Feldwerte abändert

    Beispiele für Ausdrücke, die mit Hilfe eines berechneten Feldes Werte berechnen oder modifizieren

  5. Verfeinern einer Abfrage

    Festlegen von Eigenschaften für eine Abfrage, deren Felder und Feldlisten

    Sortieren von Datensätzen mit Hilfe des Entwurfsbereichs einer Abfrage

    Erstellen einer AutoNachschlagen-Abfrage zum automatischen Eintragen von Daten

    AutoNachschlagen-Abfragen zur automatischen Eingabe von Daten


 Was ist eine Aktionsabfrage, und wann wird diese verwendet?

Was ist eine Aktionsabfrage, und wann wird diese verwendet?

Eine Aktionsabfrage führt in nur einer Operation Änderungen an einer Vielzahl von Datensätzen durch. Man unterscheidet vier Arten von Aktionsabfragen: Lösch-, Aktualisierungs-, Anfüge- und Tabellenerstellungsabfragen.

Das vorliegende Thema gibt Beispiele zu:

Löschabfragen

Aktualisierungsabfragen

Anfügeabfragen

Tabellenerstellungsabfragen

Löschabfragen

Dieser Abfragetyp löscht eine Gruppe von Datensätzen aus einer oder mehreren Tabellen. Sie können mit einer Löschabfrage z. B. Auslaufartikel löschen oder Artikel, für die keine Bestellungen vorliegen. Löschabfragen löschen immer vollständige Datensätze, nicht die in Datensätzen markierten Felder.

Um Informationen zum Erstellen von Löschabfragen anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Aktualisierungsabfragen

Dieser Abfragetyp führt globale Änderungen an Gruppen von Datensätzen in einer oder mehreren Tabellen durch. Sie können z. B. die Preise aller Molkereiprodukte um 10 % oder alle Gehälter für Mitarbeiter in einer bestimmten Kategorie um 5 % erhöhen. Mit einer Aktualisierungsabfrage können Sie Daten in vorhandenen Tabellen ändern.

Um Informationen zum Erstellen von Aktualisierungsabfragen anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Anfügeabfragen

Dieser Abfragetyp fügt eine Gruppe von Datensätzen aus einer oder mehreren Tabellen am Ende einer anderen Tabelle oder mehrerer Tabellen an. Wenn Sie z. B. einige neue Kunden anwerben und eine Datenbank mit einer Tabelle erhalten, die Informationen zu diesen Kunden enthält, brauchen Sie diese Informationen nicht neu einzugeben. Sie können sie der Tabelle Kunden anfügen. Mit Anfügeabfragen können Sie die folgenden Aufgaben erleichtern:

  • Anfügen von Feldern, die auf Kriterien basieren. Sie können z. B. nur die Namen und Adressen der Kunden mit noch offenen Bestellungen anfügen.

  • Anhängen von Datensätzen, wenn einige der Felder einer Tabelle in einer anderen Tabelle nicht existieren. Die Tabelle Kunden aus der Beispieldatenbank Nordwind enthält z. B. 11 Felder. Wenn Sie nun Datensätze aus einer anderen Tabelle anfügen möchten, deren Felder mit 9 der 11 Felder der Tabelle Kunden identisch sind, werden die Daten der identischen Felder unter Verwendung der Anfügeabfrage eingefügt und die anderen Felder ignoriert.

Um Informationen zum Erstellen von Anfügeabfragen anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Tabellenerstellungsabfragen

Dieser Abfragetyp erstellt eine Tabelle aus allen oder einem Teil der Daten in einer oder mehreren Tabellen. Mit Tabellenerstellungsabfragen können Sie die folgenden Aufgaben erleichtern:

  • Erstellen einer Tabelle zum Exportieren in andere Microsoft Access-Datenbanken. Sie können z. B. eine Tabelle erstellen, die mehrere Felder aus der Tabelle Personal enthält, und diese dann in eine Datenbank exportieren, die von der Personalabteilung verwendet wird.

  • Erstellen von Datenzugriffsseiten, die Daten ab einem bestimmten Zeitpunkt anzeigen. Wenn Sie am 15. Mai 96 eine Datenzugriffsseite anzeigen möchten, die die Umsätze des 1. Quartals anzeigt, die auf den Daten basieren, die sich am 1. April 96 um 9:00 Uhr in den zugrunde liegenden Tabellen befanden, extrahiert eine Datenzugriffsseite, die auf einer Abfrage oder SQL-Anweisung basiert, stets die aktuellsten Daten aus der Tabelle (vom 15. Mai 96), nicht die Daten zu einem bestimmten Zeitpunkt. Um die Daten so zu erhalten, wie sie am 1. April 96 um 9:00 Uhr vorliegen, erstellen Sie zu diesem Zeitpunkt eine Tabellenerstellungsabfrage, die die benötigten Datensätze abruft und diese in einer neuen Tabelle speichert. Verwenden Sie anschließend die neue Tabelle an Stelle einer Abfrage als Basis für die Datenzugriffsseite.

  • Erstellen einer Sicherungskopie einer Tabelle.

  • Erstellen einer Protokolltabelle, die alte Datensätze enthält. Sie können z. B. eine Tabelle erstellen, die alle alten Bestellungen enthält, bevor Sie sie aus der aktuellen Tabelle Bestellungen löschen.

  • Optimieren der Leistung von Formularen, Berichten und Datenzugriffsseiten, die auf Abfragen auf der Grundlage mehrerer Tabellen oder auf SQL-Anweisungen basieren. Angenommen, Sie möchten mehrere Berichte drucken, die auf einer Abfrage beruhen, die auf fünf Tabellen basiert und Summen enthält. Um diesen Vorgang zu beschleunigen, erstellen Sie zunächst eine Tabellenerstellungsabfrage, die die benötigten Datensätze abruft und in einer Tabelle speichert. Anschließend können Sie die Berichte auf diese Tabelle basieren oder die Tabelle in einer SQL-Anweisung als Datenherkunft für ein Formular, Bericht oder eine Datenzugriffsseite festlegen. Somit müssen Sie die Abfrage nicht für jeden Bericht erneut ausführen. Die Daten in der Tabelle bleiben jedoch auf dem Stand, auf dem sie beim Ausführen der Tabellenerstellungsabfrage waren.

Um Informationen zum Erstellen von Tabellenerstellungsabfragen anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang


 Erstellen einer neuen Tabelle aus den Ergebnissen einer Abfrage mit einer Tabellenerstellungsabfrage

Erstellen einer neuen Tabelle aus den Ergebnissen einer Abfrage mit einer Tabellenerstellungsabfrage

  1. Erstellen Sie eine Abfrage auf der Basis der Tabellen oder Abfragen, die die Datensätze enthalten, mit denen Sie die neue Tabelle erstellen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Tabellenerstellungsabfrage. Daraufhin wird das Dialogfeld Neue Tabelle erstellen angezeigt.

  3. Geben Sie im Feld Tabellenname den Namen der Tabelle ein, die Sie erstellen oder ersetzen möchten.

  4. Klicken Sie auf Aktuelle Datenbank, um die neue Tabelle der gerade geöffneten Datenbank hinzuzufügen, oder klicken Sie auf Andere Datenbank, und geben Sie den Namen der Datenbank ein, der Sie die neue Tabelle hinzufügen möchten. Geben Sie ggf. den Pfadnamen zu dieser Datenbank ein.

  5. Klicken Sie auf OK.

  6. Ziehen Sie die Felder, die Sie der neuen Tabelle hinzufügen möchten, aus der Feldliste in den Abfrageentwurfsbereich.

  7. Geben Sie in die Zelle Kriterien der Felder, die Sie in den Entwurfsbereich gezogen haben, Kriterien ein.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  8. Zum Anzeigen der neuen Tabelle klicken Sie vor dem Erstellen in der Symbolleiste auf Ansicht [image] . Um zur Abfrageentwurfsansicht zurückzukehren und Änderungen daran vorzunehmen oder die Abfrage auszuführen, klicken Sie in der Symbolleiste erneut auf Ansicht [image] .

  9. Klicken Sie zum Erstellen der neuen Abfrage in der Symbolleiste auf Ausführen [image] .

Anmerkungen

  • Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.

  • Die Daten der neu erstellten Tabelle übernehmen weder die Feldeigenschaften noch die Einstellung des Primärschlüssels aus der Originaltabelle.


 Ändern von Datensätzen als Gruppe unter Verwendung einer Aktualisierungsabfrage

Ändern von Datensätzen als Gruppe unter Verwendung einer Aktualisierungsabfrage

  1. Erstellen Sie eine Abfrage, indem Sie die Tabellen oder Abfragen auswählen, deren Datensätze Sie aktualisieren möchten, und deren Felder Sie zum Festlegen von Kriterien verwenden möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Aktualisieren.

  3. Ziehen Sie die Felder, die Sie aktualisieren oder für die Sie Kriterien festlegen möchten, aus der Feldliste in den Abfrageentwurfsbereich.

  4. Legen Sie in der Zelle Kriterien ggf. Kriterien fest.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  5. Geben Sie in der Zelle Aktualisieren der zu aktualisierenden Felder den Ausdruck oder den Wert ein, den Sie zum Ändern der Felder verwenden möchten (siehe hierzu die nachstehende Abbildung).

    Festlegen eines Ausdrucks zum Ändern einer Gruppe von Datensätzen

    Um Beispiele für Ausdrücke anzuzeigen, klicken Sie auf [image] .

  6. Um eine Liste der Datensätze, die aktualisiert werden, anzuzeigen, klicken Sie in der Symbolleiste auf Abfrageansicht [image] . Diese Liste enthält nicht die neuen Werte. Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie hier ggf. Änderungen durch.

  7. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Datensätze zu aktualisieren.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.


 Ausdrücke in Aktualisierungsabfragen - Beispiele

Ausdrücke in Aktualisierungsabfragen - Beispiele

Verwenden Sie im Abfrageentwurfsbereich für das Feld, das Sie aktualisieren möchten, Ausdrücke aus der Zelle Aktualisieren, wie z. B.:

Ausdruck | Ergebnis
"Verkaufsberater" | Ändert einen Wert in Verkaufsberater.
#10.08.96# | Ändert Datumswerte in 10. Aug. 96.
Ja | Ändert die Werte Nein in einem Feld vom Datentyp Ja/Nein in Ja.
"TN"&[Teilenummer] | Stellt jeder angegebenen Teilenummer TN voran.
[Einzelpreis]*[Anzahl] | Berechnet das Produkt aus Einzelpreis und Anzahl.
[Frachtkosten]*1.5 | Erhöht die Frachtkosten um 50 %.
DomSumme("[Anzahl]*[Einzelpreis]", "Bestelldetails","[Artikel-Nr]=" & [Artikel-Nr]) | Aktualisiert die Gesamtverkäufe der Produkte, deren Artikel-Nr in der aktuellen Tabelle und der Tabelle Bestelldetails übereinstimmen, auf Basis von Anzahl und Einzelpreis.
Rechts([PLZ],5) | Schneidet die linken Zeichen eines Feldes ab und die 5 letzten Zeichen von rechts bleiben erhalten.


 Anfügen von Datensätzen aus einer Tabelle an eine andere Tabelle unter Verwendung einer Anfügeabfrage

Anfügen von Datensätzen aus einer Tabelle an eine andere Tabelle unter Verwendung einer Anfügeabfrage

  1. Erstellen Sie eine Abfrage auf der Basis der Tabelle, aus der Sie Datensätze an eine andere Tabelle anfügen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Anfügen. Es wird das Dialogfeld Anfügen angezeigt.

  3. Geben Sie im Feld Tabellenname den Namen der Tabelle ein, an die Sie Datensätze anfügen möchten.

  4. Klicken Sie auf Aktuelle Datenbank, wenn sich die Tabelle in der gerade geöffneten Datenbank befindet, oder klicken Sie auf Andere Datenbank, und geben Sie den Namen der Datenbank ein, in der die Tabelle gespeichert ist. Geben Sie ggf. den Pfadnamen zu dieser Datenbank ein.

    Sie können auch einen Pfad zu einer Microsoft FoxPro-, einer Paradox- oder einer dBASE-Datenbank oder eine Verbindungszeichenfolge zu einer SQL-Datenbank eingeben.

  5. Klicken Sie dann auf OK.

  6. Ziehen Sie die Felder, die Sie anfügen möchten, sowie die Felder, für die Sie Kriterien festlegen möchten, aus der Feldliste in den Abfrageentwurfsbereich. Wenn für das Primärschlüsselfeld der Datentyp AutoWert festgelegt wurde, müssen Sie dieses nicht unbedingt hinzufügen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    Wenn die Feldnamen beider Tabellen identisch sind, können Sie das Sternchen (*) in den Abfrageentwurfsbereich ziehen. Wenn Sie mit einem Replikat einer Datenbank arbeiten, müssen Sie stattdessen alle Felder hinzufügen.

  7. Wenn die Namen der ausgewählten Felder in beiden Tabellen identisch sind, trägt Microsoft Access automatisch die entsprechenden Namen in der Zeile Anfügen an ein. Wenn die ausgewählten Namen in den beiden Tabellen nicht übereinstimmen, geben Sie in die Zeile Anfügen an die Feldnamen der Tabelle ein, an die Sie Datensätze anfügen.

  8. Geben Sie in der Zelle Kriterien für die Felder, die Sie in den Entwurfsbereich gezogen haben, die Kriterien ein, anhand derer Anfügungen vorgenommen werden sollen.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  9. Zum Anzeigen der Datensätze, die von der Abfrage angefügt werden, klicken Sie in der Symbolleiste auf Abfrageansicht [image] . Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie hier ggf. Änderungen durch.

  10. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Datensätze anzufügen.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.


Löschen einer Gruppe von Datensätzen mit einer Abfrage

Was möchten Sie tun?

Datensätze aus einer einzelnen oder mehreren Tabellen in einer 1:1-Beziehung löschen

Datensätze mit Hilfe einer Abfrage, die nur auf der Tabelle auf der "1"-Seite einer 1:n-Beziehung basiert, löschen

Datensätze mit Hilfe einer Abfrage, die auf beiden Tabellen einer 1:n-Beziehung basiert, löschen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Was ist eine Kreuztabellenabfrage, und wann wird diese verwendet?

Was ist eine Kreuztabellenabfrage, und wann wird diese verwendet?

Eine Kreuztabellenabfrage zeigt zusammengefasste Werte (Summen, Anzahl, Durchschnittswerte) für ein Feld einer Tabelle an und gruppiert diese nach einer Reihe von Kategorien, die untereinander auf der linken Seite des Datenblatts angezeigt werden, und nach einer anderen Reihe von Kategorien, die am oberen Rand des Datenblatts angezeigt werden.

Zum Anzeigen von Informationen zum Erstellen einer Kreuztabellenabfrage mit einem Assistenten klicken Sie auf [image] . Zum Anzeigen von Informationen zum Neuerstellen einer Kreuztabellenabfrage klicken Sie auf [image] .

Tipp Sie können Kreuztabellendaten anzeigen, ohne eine separate Abfrage in Ihrer Datenbank zu erstellen, indem Sie einfach einen PivotTable-Assistenten in einem Formular verwenden, oder eine PivotTable-Liste in einer Datenzugriffsseite erstellen. Mit einem PivotTable-Formular oder einer PivotTable-Liste können Sie Zeilen- und Spaltenüberschriften bei Bedarf ändern, um Ihre Daten auf unterschiedliche Arten analysieren zu können. Um Informationen zum Erstellen eines PivotTable-Formulars anzuzeigen, klicken Sie auf [image] .

Zum Anzeigen von Informationen zum Erstellen einer PivotTable-Liste auf einer Datenzugriffsseite klicken Sie auf [image] .


Beispiel für eine Kreuztabellenabfrage

Zum Anzeigen dieses Themas klicken Sie auf die Grafik:

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Wenn Sie dieses Thema mit Hilfe der Tastatur anzeigen möchten, aktivieren Sie den Themenbereich mit F6, wählen Sie die Grafik mit TAB aus, und drücken Sie dann die EINGABETASTE.


 Erstellen einer Kreuztabellenabfrage ohne Verwendung eines Assistenten

Erstellen einer Kreuztabellenabfrage ohne Verwendung eines Assistenten

Zum Anzeigen eines Beispiels für eine Kreuztabellenabfrage klicken Sie auf [image] .

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Entwurfsansicht und dann auf OK.

  3. Klicken Sie im Dialogfeld Tabelle anzeigen auf die Registerkarte für die Tabellen oder Abfragen, mit denen Sie arbeiten möchten.

  4. Doppelklicken Sie auf den Namen jedes einzelnen Objekts, das Sie zur Abfrage hinzufügen möchten, und dann auf Schließen.

  5. Fügen Sie im Entwurfsbereich in der Zeile Feld Felder hinzu, und legen Sie Kriterien fest.

  6. Klicken Sie in der Symbolleiste auf Abfragetyp [image] und dann auf Kreuztabellenabfrage.

  7. Klicken Sie für das Feld oder die Felder, dessen bzw. deren Werte als Zeilenüberschriften angezeigt werden sollen, auf die Zeile Kreuztabelle und dann auf Zeilenüberschrift.

    Für diese Felder müssen Sie in der Zeile Funktion die Standardeinstellung Gruppierung stehenlassen.

  8. Klicken Sie für das Feld, dessen Werte als Spaltenüberschriften angezeigt werden sollen, auf die Zeile Kreuztabelle und dann auf Spaltenüberschrift. Sie können Spaltenüberschrift nur für ein Feld auswählen, und Sie müssen für dieses Feld in der Zeile Funktion die Einstellung Gruppierung stehenlassen.

    Spaltenüberschriften werden standardmäßig in alphabetischer oder nummerischer Reihenfolge sortiert. Wenn diese in einer anderen Reihenfolge angezeigt werden sollen, oder wenn Sie die Anzeige der Spaltenüberschriften begrenzen möchten, stellen Sie für die Abfrage die Eigenschaft FixierteSpaltenüberschriften ein.

    Wie wird's gemacht?

  9. Klicken Sie für die Felder, die Sie in der Kreuztabelle verwenden möchten, auf die Zeile Kreuztabelle und dann auf Wert.

    Sie können nur für ein Feld die Einstellung Wert auswählen.

  10. Klicken Sie für dieses Feld in der Zeile Funktion auf den Typ der Aggregatfunktion, die Sie für die Kreuztabelle verwenden möchten (z.B. Summe, Mittelwert oder Anzahl).

  11. Zum Festlegen von Kriterien, die die Anzeige der Zeilenüberschriften vor dem Ausführen der Berechnung begrenzen, geben Sie in der Zeile Kriterien für ein Feld mit dem Eintrag Zeilenüberschrift in der Zelle Kreuztabelle einen Ausdruck ein. Sie könnten z.B. die Gesamtverkäufe aller Artikel bestimmter Kategorien, z.B. Fleischprodukte und Meeresfrüchte, anzeigen.

    Zum Festlegen von Kriterien, die die Zeilenüberschriften vor dem Gruppieren und vor dem Ausführen der Kreuztabellenabfrage begrenzen, fügen Sie das Feld, für das Sie Kriterien festlegen möchten, zum Entwurfsbereich hinzu. Klicken Sie dann in der Zelle Funktion auf Bedingung, lassen Sie die Zelle Kreuztabelle leer, und geben Sie zum Schluss einen Ausdruck in die Zeile Kriterien ein. (Die Abfrageergebnisse enthalten keine Felder, für die Bedingung in der Zeile Funktion gewählt ist.) Zum Anzeigen von Beispielen dazu, wie Kriterien Berechnungen in Abfragen beeinflussen, klicken Sie auf [image] .

  12. Zum Anzeigen der Abfrageergebnisse klicken Sie in der Symbolleiste auf Ansicht [image] .

    Zum Unterbrechen der Ausführung der Abfrage drücken Sie STRG+UNTBR.

Anmerkungen

  • Die Abfrage Quartalsbestellungen nach Artikeln aus der Beispieldatenbank Nordwind ist ein Beispiel für eine Kreuztabellenabfrage. Zum Anzeigen dieser Abfrage öffnen Sie die Nordwind-Datenbank im Ordner BEISPIEL innerhalb des Office-Ordners und dann Quartalsbestellungen nach Artikeln in der Entwurfsansicht. Zum Anzeigen von Informationen zum Öffnen der Datenbank Nordwind klicken Sie auf [image] .

  • Wenn Sie ein Feld zum Abfrageentwurfsbereich hinzufügen, jedoch in der Zelle Kreuztabelle auf die Option (nicht angezeigt) und in der Zelle Funktion auf die Option Gruppierung klicken, gruppiert Microsoft Access dieses Feld als Zeilenüberschrift, zeigt die Zeile jedoch in den Abfrageergebnissen nicht an.

  • Die Werte Ihrer Spaltenüberschriften können Zeichen enthalten, die normalerweise in Feldnamen nicht zugelassen sind, z.B. Dezimalstellen. Ist dies der Fall, ersetzt Microsoft Access diese im Datenblatt durch Unterstriche.

  • Zum Anzeigen von Informationen zur Behebung von Problemen mit einer Kreuztabellenabfrage klicken Sie auf [image] .

  • Um weitere Informationen zum Erstellen einer PivotTable-Liste in einer Datenzugriffsseite anzuzeigen, klicken Sie auf [image] .


 Erstellen einer Kreuztabellenabfrage unter Verwendung eines Assistenten

Erstellen einer Kreuztabellenabfrage unter Verwendung eines Assistenten

Zum Anzeigen eines Beispiels für eine Kreuztabellenabfrage klicken Sie auf [image] .

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Kreuztabellenabfrage-Assistent.

  3. Klicken Sie auf OK.

  4. Folgen Sie den Anleitungen, die in den Dialogfeldern des Assistenten angezeigt werden. Im letzten Dialogfeld können Sie wählen, ob Sie die Abfrage ausführen oder die Struktur der Abfrage in der Entwurfsansicht anzeigen möchten.

    Entspricht das Ergebnis der Abfrage nicht genau Ihren Vorstellungen, können Sie den Assistenten erneut ausführen oder die Abfrage in der Entwurfsansicht ändern. Um weitere Informationen zum Ändern einer Abfrage in der Entwurfsansicht anzuzeigen, klicken Sie auf [image] .

Um Informationen zum Behandeln von Problemen mit der Abfrage anzuzeigen, klicken Sie auf [image] .

Tipp Sie können die Kreuztabellendaten anzeigen, ohne eine separate Abfrage in Ihrer Datenbank zu erstellen, indem Sie entweder den PivotTable-Assistenten in einem Formular verwenden oder eine PivotTable-Liste in einer Datenzugriffsseite erstellen. Mit einem PivotTable-Formular oder einer PivotTable-Liste können Sie Zeilen- und Spaltenüberschriften bei Bedarf ändern, um Ihre Daten auf unterschiedliche Arten zu analysieren. Um weitere Informationen zum Erstellen eines PivotTable-Formulars anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zum Erstellen einer PivotTable-Liste auf einer Datenzugriffsseite anzuzeigen, klicken Sie auf [image] .


 Sortieren oder Begrenzen der in einer Kreuztabellenabfrage angezeigten Spaltenüberschriften

Sortieren oder Begrenzen der in einer Kreuztabellenabfrage angezeigten Spaltenüberschriften

In Spaltenüberschriften, die z.B. die Monate des Jahres enthalten, können Sie diese statt in alphabetischer in chronologischer Reihenfolge anzeigen, und Sie haben die Möglichkeit, nur die Monate Januar bis Juni anzuzeigen.

  1. Entwerfen Sie Ihre Kreuztabellenabfrage mit oder ohne Verwendung eines Assistenten.

  2. Zeigen Sie die Abfrage in der Entwurfsansicht an.

  3. Klicken Sie außerhalb des Entwurfsbereichs und der Feldlisten auf den Hintergrund der Abfrageentwurfsansicht.

  4. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  5. Geben Sie im Einstellungsfeld für die Eigenschaft FixierteSpaltenüberschriften die gewünschten Spaltenüberschriften in der Reihenfolge ein, in der diese angezeigt werden sollen. Geben Sie zwischen den Spaltenüberschriften ein Komma oder das für Ihr Land gültige Trennzeichen für Listen ein. (Um das für Ihr Land gültige Listentrennzeichen anzuzeigen, doppelklicken Sie in der Windows-Systemsteuerung auf Ländereinstellungen.)

    Die Spaltenüberschriften, die Sie eingeben, müssen genau mit den Spaltenüberschriften im Abfragedatenblatt übereinstimmen. Wenn z.B. im Datenblatt eine Spaltenüberschrift USA lautet, müssen Sie für die Eigenschaft FixierteSpaltenüberschriften den Ausdruck USA, nicht aber z.B. US eingeben. (Nach dem Drücken der EINGABETASTE oder Bewegen des Zeigers an eine andere Position gibt Microsoft Access vor und nach jeder Überschrift Anführungszeichen an.)

  6. Zum Anzeigen der Abfrageergebnisse klicken Sie in der Symbolleiste auf Ansicht [image] .

Anmerkungen

  • Wenn Sie eine Kreuztabellenabfrage häufig ausführen oder als Basis für ein Formular, einen Bericht oder eine Datenzugriffsseite verwenden, können Sie die Abfrage beschleunigen. Dazu verwenden Sie das vorstehend beschriebene Verfahren zum Angeben festgelegter Spaltenüberschriften.

  • Wenn Sie dieselben Spaltenüberschriften häufig in unterschiedlichen Abfragen verwenden, können Sie eine Tabelle mit einem Feld vom Datentyp Text erstellen und in diesem Feld die Spaltenüberschriften speichern. Anschließend öffnen Sie die Tabelle und kopieren bei Bedarf die Spaltenüberschriften in das Einstellungsfeld für die Eigenschaft FixierteSpaltenüberschriften.


 Was ist eine Parameterabfrage, und wann wird diese verwendet?

Was ist eine Parameterabfrage, und wann wird diese verwendet?

Eine Parameterabfrage ist eine Abfrage, die beim Ausführen ein Dialogfeld zum Eingeben von Informationen anzeigt. Dies können Kriterien zum Abrufen von Datensätzen oder auch Werte sein, die in ein Feld eingefügt werden sollen. Sie können die Abfrage auch so entwerfen, dass nach mehreren Informationen gefragt wird. Sie können z. B. nach zwei Datumsangaben fragen, wenn Sie möchten, dass Microsoft Access anschließend alle Datensätze abruft, die zwischen diesen beiden Daten liegen.

Parameterabfragen eignen sich besonders als Basis für Formulare, Berichte und Datenzugriffsseiten. Sie können z. B. einen Bericht über monatliche Einkünfte erstellen, der auf einer Parameterabfrage basiert. Wenn Sie den Bericht dann drucken, zeigt Microsoft Access ein Dialogfeld an, das Sie auffordert, den Monat anzugeben, der im Bericht erfasst werden soll. Nachdem Sie den Monat eingegeben haben, druckt Microsoft Access den entsprechenden Bericht. Um Informationen zum Erstellen einer Parameterabfrage anzuzeigen, klicken Sie auf [image] .

Sie können an Stelle des Dialogfelds der Parameterabfrage auch ein benutzerdefiniertes Formular oder ein anderes Dialogfeld erstellen, das den Benutzer auffordert, die Parameter für eine Abfrage einzugeben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Erstellen einer Parameterabfrage, die bei jedem Ausführen die Eingabe von Kriterien anfordert

Erstellen einer Parameterabfrage, die bei jedem Ausführen die Eingabe von Kriterien anfordert

Eine Parameterabfrage zeigt ein oder mehrere vordefinierte Dialogfelder mit der Aufforderung zur Eingabe der Parameterwerte (Kriterien) an. Sie können auch ein benutzerdefiniertes Dialogfeld erstellen, das den Benutzer auffordert, die Parameter für die Abfrage einzugeben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  1. Erstellen Sie eine Auswahl- oder Kreuztabellenabfrage.

  2. Ziehen Sie in der Abfrageentwurfsansicht die Felder aus der Feldliste in den Abfrage-Entwurfsbereich.

  3. Geben Sie für jedes Feld, für das Sie Parameter verwenden möchten, in der Zelle Kriterien eine Eingabeaufforderung in eckigen Klammern ein. Microsoft Access zeigt diese Eingabeaufforderung beim Ausführen der Abfrage an. Der Text der Eingabeaufforderung muss sich vom Feldnamen unterscheiden, kann diesen jedoch beinhalten.

    Text in der Zelle Kriterien erscheint als Eingabeaufforderung, wenn die Abfrage ausgeführt wird

    Sie können für ein Feld, das das Datum anzeigt, die Eingabeaufforderungen "Geben Sie das Anfangsdatum ein:" und "Geben Sie das Enddatum ein:" zum Angeben eines Wertebereichs anzeigen. Geben Sie in die Zeile Kriterien dieses Feldes Zwischen [Geben Sie das Anfangsdatum ein:] Und [Geben Sie das Enddatum ein:] ein.

  4. Um die Ergebnisse anzuzeigen, klicken Sie in der Symbolleiste auf Ansicht [image] , und geben Sie dann für den Parameter einen Wert ein. Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Ansicht [image] .

Anmerkungen

  • In einer Kreuztabellenabfrage oder einer Parameterabfrage, die einer Kreuztabellenabfrage oder einem Diagramm zugrundeliegen, müssen Sie einen Datentyp für die Parameter angeben. In der Kreuztabellenabfrage müssen Sie darüber hinaus die Eigenschaft Fixierte Spaltenüberschriften einstellen. In anderen Parameterabfragen legen Sie für ein Feld vom Datentyp Ja/Nein und für Felder, die aus einer Tabelle einer externen SQL-Datenbank stammen, einen Datentyp fest. Um Informationen zum Angeben eines Datentyps für Parameter anzuzeigen, klicken Sie auf [image] . Um Informationen zum Einstellen der Eigenschaft Fixierte Spaltenüberschrift anzuzeigen, klicken Sie auf [image] .

  • Wenn der Benutzer aufgefordert werden soll, ein oder mehrere Zeichen einzugeben, um nach Datensätzen suchen zu lassen, die mit den vom Benutzer angegebenen Zeichen beginnen oder diese enthalten, erstellen Sie eine Parameterabfrage, die den Wie-Operator und das Platzhaltersymbol (*) verwendet. So sucht beispielsweise die Anweisung

    LIKE [Geben Sie das erste zu suchende Zeichen ein: ] & "*"

    nach Wörtern, die mit dem angegebenen Buchstaben beginnen. Die Anweisung

    LIKE "*" & [Geben Sie ein beliebiges zu suchendes Zeichen ein: ] & "*"

    sucht nach Wörtern, die den angegebenen Buchstaben enthalten.

  • Sie können die Parameter in einem Bericht drucken. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Was ist eine SQL-Abfrage, und wann wird diese verwendet?

Was ist eine SQL-Abfrage, und wann wird diese verwendet?

Eine SQL-Abfrage ist eine Abfrage, die unter Verwendung einer SQL-Anweisung erstellt wird. Beispiele für SQL-Abfragen sind Unions-, SQL Pass-Through-, Datendefinitions- und Unterabfragen.

Das vorliegende Thema gibt Beispiele zu:

Union-Abfragen

Pass-Through-Abfragen

Datendefinitionsabfragen

Unterabfragen

Union-Abfragen

Dieser Abfragetyp kombiniert in den Abfrageergebnissen Felder (Spalten) aus einer oder mehreren Tabellen oder Abfragen in einem Feld oder einer Spalte. Wenn Sie z. B. 6 Lieferanten haben, die jeden Monat neue Lagerlisten schicken, können Sie diese Listen unter Verwendung einer Union-Abfrage zusammenfassen und dann auf der Basis der Union-Abfrage eine Tabellenerstellungsabfrage erstellen, um eine neue Tabelle anzulegen. Zum Anzeigen von Beispielen für Union-Abfragen klicken Sie auf [image] .

Um Informationen zum Erstellen einer Union-Abfrage anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

SQL Pass-Through-Abfragen

Dieser Abfragetyp sendet Befehle direkt an ODBC-Datenbanken, wie z. B. Microsoft FoxPro. Dabei werden Befehle verwendet, die der Server unterstützt. Mit einer SQL Pass-Through-Abfrage können Sie z. B. Datensätze abrufen oder Daten ändern.

Um Informationen zum Erstellen einer SQL Pass-Through-Abfrage anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Datendefinitionsabfragen

Dieser Abfragetyp erstellt, löscht oder ändert Tabellen, oder erstellt Indizes in einer Datenbank, wie z. B. Microsoft Access- oder Microsoft FoxPro-Tabellen.

Um Informationen zum Erstellen einer Datendefinitionsabfrage anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Unterabfragen

Dieser Abfragetyp besteht aus einer SQL SELECT-Anweisung innerhalb einer anderen Auswahl- oder Aktionsabfrage. Sie können diese Anweisungen zum Definieren eines neuen Feldes in die Zeile Feld oder zum Definieren von Kriterien für ein Feld in die Zeile Kriterien des Abfrageentwurfsbereichs eingeben. Mit Unterabfragen können Sie die folgenden Aufgaben ausführen:

  • Testen, ob Ergebnisse der Unterabfrage vorhanden sind (dazu verwenden Sie die reservierten Wörter EXISTS oder NOT EXISTS).

  • Suchen nach Werten in der Hauptabfrage, die gleich, größer als oder kleiner als Werte sind, die die Unterabfrage zurückgibt (dazu verwenden Sie die reservierten Wörter ANY, IN oder ALL).

  • Erstellen von Unterabfragen innerhalb von Unterabfragen (verschachtelte Unterabfragen).

Um Informationen zum Erstellen einer Unterabfrage anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang


Arbeiten mit SQL in Abfragen, Formularen, Berichten, Makros und Modulen

Was möchten Sie tun?

Eine SQL-Anweisung für eine bestehende Abfrage anzeigen oder ändern

Eine Abfrage in der Entwurfsansicht erstellen, um eine SQL-Anweisung zu erzeugen, anschließend zu kopieren und an anderer Stelle einzufügen

Die zugrunde liegende SQL-Anweisung für ein Formular oder einen Bericht ändern

Eine SQL-Anweisung als Datensatzherkunft für ein Listen- oder Kombinationsfeld verwenden

Eine SQL-spezifische Abfrage (Union-, SQL Pass-Through-, Datendefinitions- oder Unterabfrage) erstellen

Aktionsabfragen und Datendefinitionsabfragen mit Hilfe eines Makros an Stelle einer gespeicherten Abfrage durchführen

Informationen darüber erhalten, wie SQL im Programmcode verwendet werden kann

Sie wissen nicht für welche Option Sie sich entscheiden sollen??


 Verwenden der Abfrageentwurfsansicht zum Erstellen einer SQL-Anweisung, die an anderer Stelle eingefügt werden kann

Verwenden der Abfrageentwurfsansicht zum Erstellen einer SQL-Anweisung, die an anderer Stelle eingefügt werden kann

Sie können SQL-Anweisungen und -Klauseln in vielen Ausdrücken verwenden, z. B. als Argumente von Prozeduren oder als Einstellungen von Eigenschaften. Sie können eine SQL-Anweisung z. B. verwenden, um die Eigenschaft Datensatzherkunft eines Listenfelds in einem Formular oder Bericht so einzustellen, dass eine Liste mit Einträgen erzeugt wird.

  1. Erstellen Sie in der Abfrage-Entwurfsansicht die Abfrage, für welche die zugehörige SQL-Anweisung erzeugt werden soll.

  2. Klicken Sie in der Symbolleiste auf den Pfeil neben der Schaltfläche Abfrageansicht [image] und dann auf SQL-Ansicht.

  3. Wählen Sie die gesamte oder einen Teil der SQL-Anweisung aus, und drücken Sie dann die Tastenkombination STRG+C, um den ausgewählten Text in die Zwischenablage zu kopieren.

  4. Positionieren Sie die Einfügemarke an der Stelle, an der Sie die SQL-Anweisung einfügen möchten, wie z. B. im Einstellungsfeld einer Eigenschaft oder im Code-Fenster des Visual Basic-Editors.

  5. Drücken Sie dann die Tastenkombination STRG+V.

Anmerkungen

  • Sie können eine Abfrage statt in der Entwurfsansicht auch in der SQL-Ansicht erstellen oder bearbeiten. Wechseln Sie hierfür zur SQL-Ansicht, und geben Sie die SQL-Anweisung für die gewünschte Abfrage ein, bzw. nehmen Sie Änderungen daran vor. Wenn Sie dann zur Entwurfsansicht zurückkehren, wird die SQL-Anweisung im Entwurfsbereich dargestellt.

  • Die meisten Abfrageeigenschaften im Eigenschaftenfenster der Entwurfsansicht besitzen äquivalente Klauseln und Optionen in der SQL-Ansicht.

  • Wenn Sie mit Hilfe eines Assistenten ein Formular, einen Bericht oder eine Datenzugriffsseite auf der Basis mehrerer Tabellen erstellen, oder wenn Sie ein Listen- oder Kombinationsfeld erstellen, erzeugt Microsoft Access automatisch eine SQL-Anweisung als Datenherkunft für das Formular, den Bericht oder die Seite bzw. als Datensatzherkunft für das Listen- oder Kombinationsfeld. Ohne Verwendung eines Assistenten können Sie für die Eigenschaften Datenherkunft oder Datensatzherkunft eine SQL-Anweisung erstellen, indem Sie auf die Aufbauen-Schaltfläche [image] neben der entsprechenden Eigenschaft klicken und dann eine Abfrage in der Abfrageentwurfsansicht erstellen.

  • Sie können den Entwurfsbereich nicht verwenden, um SQL-spezifische Abfragen zu erstellen. Für diese Abfragetypen müssen Sie die SQL-Ansicht verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anzeigen oder Ändern der SQL-Anweisung hinter einer vorhandenen Abfrage

Anzeigen oder Ändern der SQL-Anweisung hinter einer vorhandenen Abfrage

Wenn Sie mit SQL vertraut sind, können Sie direkt mit der SQL-Anweisung arbeiten, die der Abfrage zugrunde liegt.

  1. Erstellen Sie eine neue Abfrage, oder öffnen Sie eine vorhandene Abfrage.

  2. Klicken Sie in der Symbolleiste auf den Pfeil neben Ansicht [image] und dann auf SQL-Ansicht.

    Microsoft Access zeigt daraufhin die SQL-Anweisung an, die der Abfrage entspricht, die Sie in der Entwurfsansicht erstellt haben.

  3. Wenn Sie die Abfrage ändern möchten, nehmen Sie diese Änderungen an der SQL-Anweisung vor.

  4. Um die Änderungen in der Entwurfsansicht anzuzeigen, klicken Sie in der Symbolleiste auf den Pfeil neben der Schaltfläche Abfrageansicht und dann auf Entwurfsansicht.


 Verwenden von Ausdrücken in SQL

Verwenden von Ausdrücken in SQL

Sie können Ausdrücke in SQL-Anweisungen eingeben, wenn Sie eine Abfrage in der SQL-Ansicht bearbeiten oder bestimmte Eigenschaften bzw. Argumente festlegen. Sie können eine SQL-Anweisung beispielsweise verwenden, um mit Hilfe der Eigenschaft Datensatzherkunft eines Listenfelds in einem Formular oder Bericht eine Liste mit Einträgen zu erzeugen.

Eingeben eines Ausdrucks in der SQL-Ansicht

Zum Eingeben eines Ausdrucks in die SQL-Ansicht einer Abfrage klicken Sie in der Symbolleiste auf den Pfeil neben Ansicht [image] und dann auf SQL-Ansicht. Microsoft Access zeigt die SQL-Anweisung an, die die aktive Abfrage beschreibt.

Sie können einen Ausdruck in eine SQL SELECT-Anweisung oder eine WHERE-, ORDER BY-, GROUP BY- oder HAVING-Klausel eingeben.

Zum Anzeigen von Beispielen für Ausdrücke in SQL-Anweisungen klicken Sie auf [image] .

Angeben eines SQL-Ausdrucks als Eigenschafteneinstellung oder Argument

Sie können einen SQL-Ausdruck für mehrere Argumente und Eigenschafteneinstellungen angeben. Darüber hinaus können Sie in der SQL-Ansicht kopieren und einfügen. Sie können einen SQL-Ausdruck z. B. als Argument Bedingung der Aktionen ÖffnenFormular oder AnwendenFilter, als Domänen- oder Kriterienargument einer Aggregatfunktion für Domänen oder als Einstellung der Eigenschaften Datenherkunft oder Datensatzherkunft in Formularen und Berichten verwenden.


 Ändern der zugrunde liegenden Abfrage oder SQL-Anweisung für ein Formular oder einen Bericht

Ändern der zugrunde liegenden Abfrage oder SQL-Anweisung für ein Formular oder einen Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht oder den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer bzw. den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Klicken Sie neben der Eigenschaft Datenherkunft auf die Aufbauen-Schaltfläche [image] , um die Abfrage zu öffnen. Sie können eine SQL-Anweisung auf dieselbe Weise bearbeiten wie eine Abfrage. Sie brauchen die einzelnen Felder nur zu ziehen und die Kriterien sowie die Sortierreihenfolge im Entwurfsbereich festlegen.

Anmerkung Wenn Sie von einer Tabelle oder Abfrage zu einer anderen wechseln möchten, klicken Sie auf den Pfeil im Einstellungsfeld der Eigenschaft Datenherkunft, um aus einer Liste von Tabellen und Abfragen auszuwählen.


 Zulassen der Anzeige oder der Ausführung einer Abfrage, jedoch nicht der Änderung an Daten oder am Abfrageentwurf durch andere Benutzer

Zulassen der Anzeige oder der Ausführung einer Abfrage, jedoch nicht der Änderung an Daten oder am Abfrageentwurf durch andere Benutzer

In einer geschützten Arbeitsgruppe können Sie anderen Benutzern Berechtigungen zum Anzeigen der Abfrageergebnisse oder zum Ausführen einer Aktionsabfrage erteilen, auch wenn diese keine Berechtigung zum Anzeigen der der Abfrage zugrunde liegenden Tabelle oder Abfrage haben.

  1. Öffnen Sie die Abfrage in der Entwurfsansicht.

  2. Markieren Sie die Abfrage, indem Sie in der Entwurfsansicht auf eine beliebige Stelle außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für die Abfrage anzuzeigen.

  4. Legen Sie für die Eigenschaft Ausführungsberechtigungen die Einstellung Besitzer fest.

    Wenn diese Einstellung festgelegt ist, gilt Folgendes:

    • Alle Benutzer verfügen für die Abfrage über die Berechtigung des Besitzers zum Anzeigen oder Ausführen der Abfrage.

    • Nur der Besitzer der Abfrage kann Änderungen an der Abfrage speichern.

    • Nur der Besitzer der Abfrage kann den Besitzerstatus der Abfrage ändern.

Anmerkung Sie können außerdem für alle neuen Abfragen Standardberechtigungen erteilen. Klicken Sie hierfür im Menü Extras auf Optionen, auf die Registerkarte Tabellen/Abfragen und dann auf die gewünschte Option unter Ausführungsberechtigungen.


 Ändern der Standardberechtigungen für alle neuen Abfragen

Ändern der Standardberechtigungen für alle neuen Abfragen

Sie können die Standardberechtigungen ändern, die Benutzern das Anzeigen von Abfrageergebnissen oder das Ausführen von Aktionsabfragen erlauben, auch wenn diese keine Berechtigungen zum Anzeigen der zugrunde liegenden Tabelle oder Abfrage haben. Das Ändern der Standardberechtigungen wirkt sich nur auf neue Abfragen aus.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Tabellen/Abfragen.

  3. Klicken Sie auf die gewünschte Ausführungsberechtigungsoption.

    Wenn Sie Des Besitzers wählen, gilt Folgendes:

    • Alle Benutzer verfügen für die Abfrage über die Berechtigung des Besitzers zum Anzeigen oder Ausführen der Abfrage.

    • Nur der Besitzer der Abfrage kann Änderungen an der Abfrage speichern.

    • Nur der Besitzer der Abfrage kann den Besitzerstatus der Abfrage ändern.

    Wenn Sie Des Benutzers wählen, gelten stattdessen die für diese Benutzerklasse definierten Berechtigungen, und jeder Benutzer mit Administratorberechtigungen für die Abfrage kann Änderungen an der Abfrage speichern oder den Besitzerstatus ändern.


 Setzen von Eigenschaften für eine Abfrage, deren Felder oder deren Feldlisten

Setzen von Eigenschaften für eine Abfrage, deren Felder oder deren Feldlisten

Sie können Eigenschaften für Abfragen, für Feldlisten in einer Abfrage und für Felder, die Sie im Entwurfsbereich zu einer Abfrage hinzufügen, einstellen.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Markieren Sie ein Feld, eine Feldliste oder eine Abfrage.
    • Zum Markieren eines Feldes klicken Sie auf die Zelle in der Zeile "Feld".

    • Zum Markieren einer Feldliste klicken Sie auf eine beliebige Stelle in der Liste.

    • Zum Markieren einer vollständigen Abfrage klicken Sie auf eine beliebige Stelle in der Entwurfsansicht für Abfragen außerhalb des Entwurfsbereichs und der Feldlisten.
  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das markierte Objekt anzuzeigen.

  4. Klicken Sie im Eigenschaftenfenster auf die Eigenschaft, die Sie einstellen möchten, und führen Sie dann einen der folgenden Schritte aus:
    • Wenn im Einstellungsfeld für die Eigenschaft ein Pfeil erscheint, klicken Sie auf den Pfeil und dann auf einen Wert aus der Liste.

    • Geben Sie in das Einstellungsfeld für die Eigenschaft eine Einstellung oder einen Ausdruck ein.

    • Wenn neben dem Einstellungsfeld für die Eigenschaft die Generator-Schaltfläche [image] angezeigt wird, können Sie auf diese Schaltfläche klicken, um einen Editor anzuzeigen.

      Wenn Sie zum Eingeben oder Bearbeiten einer Eigenschafteneinstellung mehr Platz benötigen, drücken Sie UMSCHALT+F2, um das Zoom-Fenster zu öffnen.

Tipp Zum Anzeigen weiterer Informationen zu einer Eigenschaft und deren Einstellungen klicken Sie im Eigenschaftenfenster auf die entsprechende Eigenschaft, und drücken Sie dann F1.


 Wie sind die Feldeigenschaften in einer Abfrage mit deren zugrunde liegender Tabelle oder Abfrage verknüpft?

Wie sind die Feldeigenschaften in einer Abfrage mit deren zugrunde liegender Tabelle oder Abfrage verknüpft?

Ein Feld in einer Abfrage übernimmt standardmäßig alle Eigenschaften des Feldes der zugrunde liegenden Tabelle oder Abfrage. Wenn Sie z.B. für die Eigenschaft Format eines Feldes Bestelldatum die Einstellung Datum, mittel festgelegt haben, wird das Feld Bestelldatum in den Abfrageergebnissen ebenfalls als Feld mit der Einstellung Datum, mittel formatiert. Im Eigenschaftenfenster eines Feldes in einer Abfrage werden nur die Feldeigenschaften angezeigt, die Sie ändern können.

Wenn Sie eine Feldeigenschaft in der Tabellenentwurfsansicht ändern, übernehmen neue oder vorhandene Abfragen automatisch diese Änderungen, es sei denn, Sie haben diese Eigenschaft zuvor in der Entwurfsansicht für Abfragen geändert. Einstellungen, die Sie in der Entwurfsansicht für Abfragen ändern, werden nicht von nachfolgenden Änderungen in der Tabellenentwurfsansicht überschrieben, und Änderungen, die in der Entwurfsansicht für Abfragen vorgenommen werden, haben keinen Einfluss auf die Tabellenentwurfsansicht.

Da berechnete Felder Daten anzeigen, die nicht in einer Tabelle gespeichert sind, übernehmen diese Felder keine Eigenschaften. Wenn Ihre Abfrage z.B. ein Feld zum Berechnen einer Währung enthält, werden die Werte in diesem Feld nur dann im Format Währung angezeigt, wenn Sie für dieses Feld die Eigenschaft Format mit der Einstellung Währung festlegen.

Wenn Sie auf der Basis einer Abfrage ein Formular oder einen Bericht erstellen, übernehmen die Felder im Formular oder Bericht die Feldeigenschaften, die Sie in der Abfrage oder der zugrunde liegenden Tabelle eingestellt haben. Wenn Sie im Nachhinein die Eigenschafteneinstellung für ein Steuerelement im Formular oder Bericht ändern, hat diese Änderung keinen Einfluss auf die Einstellung für dieses Feld in der zugrunde liegenden Abfrage. Ebenso wird die Eigenschafteneinstellung für ein Steuerelement nicht automatisch geändert, wenn Sie die Eigenschafteneinstellung für das entsprechende Feld in einer Abfrage nach dem Erstellen eines Formulars mit diesem Feld ändern. In diesem Fall müssen Sie die Eigenschafteneinstellung bei Bedarf manuell ändern.


 Ein- oder Ausblenden von Tabellennamen für jedes Feld im Abfrageentwurfsbereich

Ein- oder Ausblenden von Tabellennamen für jedes Feld im Abfrageentwurfsbereich

Wenn Sie Felder aus mehreren Tabellen zum Entwurfsbereich hinzufügen, möchten Sie vielleicht festhalten, welches Feld aus welcher Tabelle stammt. Dazu können Sie die Tabellennamen unter den Feldnamen anzeigen.

  • Klicken Sie in der Entwurfsansicht für Abfragen im Menü Ansicht auf Tabellennamen.

Um festzulegen, ob für neue Abfragen die Tabellennamen standardmäßig ein- oder ausgeblendet werden sollen, klicken Sie im Menü Extras auf Optionen. Wählen Sie die Registerkarte Tabellen/Abfragen, und aktivieren bzw. deaktivieren Sie dann das Kontrollkästchen Tabellennamen anzeigen.


Ändern der Standardeinstellung für die OutputAllFields-Eigenschaft (AlleFelderAusgeben)

Das Ändern dieser Option betrifft nur die Eigenschafteneinstellung für neu erstellte Abfragen; sie gilt nicht für bereits vorhandene Abfragen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Tabellen/Abfragen, und aktivieren oder deaktivieren Sie dann das Kontrollkästchen Alle Felder ausgeben.

Anmerkung Diese Option legt fest, ob die Abfrageergebnisse automatisch alle Felder der zugrunde liegenden Tabellen oder Abfragen umfassen (ohne dass sie dem Entwurfsbereich hinzugefügt werden müssen) oder nur die dem Entwurfsbereich hinzugefügten Felder.


 Öffnen oder Schließen einer Feldliste für ein Formular, einen Bericht oder eine Datenzugriffsseite

Öffnen oder Schließen einer Feldliste für ein Formular, einen Bericht oder eine Datenzugriffsseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Feldliste [image] .

Sie können die Feldliste verwenden, um einem Formular, einem Bericht oder einer Datenzugriffsseite gebundene Steuerelemente hinzuzufügen.


 Ein- oder Ausblenden des Rasters bei einem Formular, einem Bericht oder einer Datenzugriffsseite

Ein- oder Ausblenden des Rasters bei einem Formular, einem Bericht oder einer Datenzugriffsseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Ansicht auf Raster.


Aktivierthalten eines Toolbox-Tools

  • Doppelklicken Sie auf das Tool, das Sie aktiv halten möchten.

Wenn ein Tool aus der Toolbox aktiv gehalten wird, brauchen Sie nicht wiederholt darauf zu klicken, um eine bestimmte Aktion mehrmals auszuführen. Wenn Sie z. B. einem Formular mehrere Bezeichnungsfelder hinzufügen möchten, können Sie das Tool Bezeichnung in der Toolbox aktiv halten.

Drücken Sie ESC, um die Aktivierung aufzuheben.


 Öffnen oder Schließen der Toolbox

Öffnen oder Schließen der Toolbox

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Toolbox [image] .


 Was ist ein Eigenschaftenfenster?

Was ist ein Eigenschaftenfenster?

In Microsoft Access verwenden Sie Eigenschaften zum Festlegen der Merkmale von Tabellen, Abfragen, Feldern, Formularen, Berichten und Datenzugriffsseiten. Jeder Abschnitt und jedes Steuerelement in einem Formular, einem Bericht oder einer Datenzugriffsseite hat ebenfalls Eigenschaften. Steuerelementeigenschaften definieren die Struktur, das Aussehen und das Verhalten eines Steuerelements, sowie die Merkmale des im Steuerelement enthaltenen Textes oder der enthaltenen Daten. Zum Einstellen dieser Eigenschaften verwenden Sie das Eigenschaftenfenster. Die folgende Abbildung zeigt z. B. das Eigenschaftenfenster für das Steuerelement TotalSales in einem Bericht. Für die Eigenschaft Format dieses Steuerelements ist die Einstellung Währung festgelegt.

Eigenschaftenfenster für das Steuerelement "TotalSales"


 Optionen des Befehls "Inhalte einfügen" in Formularen und Berichten

Optionen des Befehls "Inhalte einfügen" in Formularen und Berichten

Wenn Sie einen markierten Bereich aus einer anderen Anwendung kopieren und im Menü Bearbeiten auf Inhalte einfügen klicken, zeigt Microsoft Access das Dialogfeld Inhalte einfügen an. Die nachstehende Tabelle erläutert die Einträge im Listenfeld Als des Dialogfelds Inhalte einfügen.

Eintrag im Feld "Als" | Funktion
Name der Anwendung (z. B. Microsoft Excel-Tabelle) | Anzeigen des Objekts in einem Objektfeld. Wenn Sie auf diesen Eintrag klicken, können Sie das Objekt direkt im Formular oder Bericht bearbeiten.
Bild oder Bitmap | Anzeigen des Objekts in einem Bild-Steuerelement. Klicken Sie auf einen dieser Einträge, wenn Sie die Leistung Ihres Formulars oder Berichts optimieren möchten. Wenn Sie auf einen dieser Einträge klicken, können Sie das Objekt nicht im Formular oder Bericht bearbeiten.

Text Anzeigen des Textes (z. B. der Text in einer Microsoft Excel-Zelle), den Sie in ein Bezeichnungsfeld (wenn das Objekt eingebettet ist) oder in ein Textfeld (wenn das Objekt verknüpft ist) kopieren. Wenn Sie auf diese Weise ein Textfeld verknüpfen, erstellt Microsoft Access im Textfeld eine DDE-Verknüpfung. Wenn Sie zur Formularansicht oder zur Seitenansicht wechseln, sehen Sie den tatsächlich verknüpften Text.


 Diagramme in Formularen, Berichten und Datenzugriffsseiten

Diagramme in Formularen, Berichten und Datenzugriffsseiten

Dieses Thema enthält Referenzinformationen über:

Verwendungszweck von Diagrammen

Diagramme in Formularen oder Berichten

Diagramme in Datenzugriffsseiten

Verwendungszweck von Diagrammen

Diagramme ziehen die Aufmerksamkeit optisch an und erleichtern es dem Betrachter, Vergleiche, Muster und Entwicklungstendenzen in Daten zu erkennen. In Microsoft Access können Sie zwei verschiedene Arten von Diagrammen erstellen: Diagramme in einem Formular oder Bericht sowie Diagramme in einer Datenzugriffsseite.

Die Vorgehensweisen zur Erstellung, Formatierung und Präsentation weisen bei den verschiedenen Diagrammarten geringfügige Unterschiede auf. Beispielsweise wird für jede Art ein anderer Diagramm-Assistent verwendet, der Sie durch den Vorgang der Diagrammerstellung führt, und beide Arten sind für bestimmte Zwecke vorgesehen. Die verfügbaren Diagrammtypen und Formatierungsoptionen sind ebenfalls unterschiedlich.

Zurück zum Anfang

Diagramme in Formularen oder Berichten

Microsoft Graph 2000 verwenden Sie zum Erstellen von Diagrammen in Formularen oder Berichten, die mit Daten aus den verfügbaren Tabellen, Abfragen oder anderen Datenherkünften verknüpft sind. Die Diagramme können global sein (sämtliche Daten werden abgebildet) oder datensatzgebunden (das Diagramm bildet nur die Daten aus dem aktuellen Datensatz ab und ändert sich jeweils, wenn Sie von einem Datensatz zum anderen wechseln).

Es stehen verschiedene Diagrammtypen zur Verfügung, sowohl zweidimensionale (2D) als auch dreidimensionale (3D), unter denen Sie auswählen können. Die Formatierungsoptionen beinhalten das Hinzufügen von Text und Grafiken zu den Diagrammen, das Ändern von Farben und das Hinzufügen von Trendlinien und Fehlerindikatoren.

Informationen zum Erstellen von Diagrammen in Formularen oder Berichten

Zurück zum Anfang

Diagramme in Datenzugriffsseiten

Microsoft Office Chart, eine Microsoft Office-Webkomponente, verwenden Sie zum Erstellen von dynamischen, interaktiven Diagrammen in Datenzugriffsseiten, die Sie in Websites bereitstellen und mit einem Browser anzeigen können. Beispielsweise können Sie ein Diagramm aus Daten in einer Tabelle mit Umsatzzahlen erstellen. Wenn Sie die Umsatzzahlen aktualisieren, aktualisiert sich auch das Diagramm. Auf diese Weise sehen Benutzer stets die aktuellsten Informationen auf den Webseiten.

Sie können Diagramme auf Datenzugriffsseiten auf der Basis von Daten aus Tabellen und Abfragen oder aus Kalkulationstabellen und PivotTable-Listen erstellen. Sie können unter einer Vielzahl von 2D-Diagrammtypen auswählen, bei denen Sie Text und Grafiken hinzufügen, die Farben ändern und viele andere Formatierungsoptionen wie Trendlinien und Fehlerindikatoren nutzen können.

Sie können auch Diagramme auf Datenzugriffsseiten verändern, die als interaktive Diagramme in Microsoft Excel bereitgestellt wurden. Wenn Sie ein interaktives Diagramm in Microsoft Excel veröffentlichen, werden die Daten für das Diagramm ebenfalls in Form einer Kalkulationstabelle oder PivotTable-Liste bereitgestellt. Weitere Informationen über das Veröffentlichen von Diagrammen in Excel finden Sie in der Excel-Hilfe.

Zum Erstellen von Diagrammen auf Datenzugriffsseiten ist Microsoft Internet Explorer 5 oder eine spätere Version erforderlich, jedoch können auch Benutzer von Internet Explorer, Version 4.x oder später, das Diagramm anzeigen und die Aktualisierungen im Diagramm in Reaktion auf Datenänderungen sehen.

Informationen zum Erstellen von Diagrammen auf Datenzugriffsseiten

Zurück zum Anfang


 Info über das Ändern eines Diagramms in einem Formular oder Bericht

Info über das Ändern eines Diagramms in einem Formular oder Bericht

Beim Bearbeiten eines Diagramms können Sie zwei Arten von Änderungen vornehmen: Änderungen am Erscheinungsbild und Änderungen an den Daten.

Die Änderungen am Erscheinungsbild umfassen das Ändern der Größe des Diagramms im Formular oder Bericht oder das Ändern der Position einzelner Diagrammelemente, des Textformats, der Farben und Muster, sowie der Achseneinteilung mit Hilfe von Microsoft Graph.

Datenänderungen umfassen das Ändern der zugrunde liegenden Tabelle bzw. Datenherkunft oder der Abfrage der Datensatzherkunft-Eigenschaft.

Wenn Sie ein Diagramm, das Daten aus Microsoft Access anzeigt, mit Hilfe des Diagramm-Assistenten erstellen, wählen Sie die Tabelle oder eine andere Datensatzquelle, die die im Diagramm angezeigten Felder enthält. Diese zugrunde liegende Tabelle bzw. Datensatzquelle enthält die Daten, wie z. B. Umsatzzahlen oder Kundenlisten. Nach dem Festlegen des Diagramms im Diagramm-Assistenten erstellt Microsoft Access eine sogenannte Datensatzherkunft-Abfrage, die auf der zugrunde liegenden Tabelle bzw. Datensatzquelle basiert. Die Abfrage der Datensatzherkunft-Eigenschaft basiert auf den Kriterien zur Einschränkung der Daten, die Sie im Diagramm-Assistenten festgelegt haben, z. B. einem Datumsbereich oder Bestellungen aus einer bestimmten Region.

Wenn Sie z. B. feststellen, dass die Umsatzzahlen in Ihrem Diagramm nicht korrekt sind, kann der Fehler in den in der zugrunde liegenden Tabelle gespeicherten Daten oder im Entwurf der zugrunde liegenden Datensatzquelle liegen. Korrigieren Sie in diesem Fall die zugrunde liegende Tabelle oder Datensatzquelle. Wenn Sie jedoch ein Feld ausgelassen haben, das im Diagramm berücksichtigt werden soll, können Sie entweder das Diagramm unter Verwendung des Diagramm-Assistenten neu erstellen oder die Datensatzherkunft-Abfrage bearbeiten.

Weitere Informationen

Ändern des Erscheinungsbilds eines Diagramms

Ändern der Daten in der zugrunde liegenden Tabelle bzw. Datensatzquelle

Anpassen des Formats eines Diagramms


 Hinzufügen eines neuen Diagramms zu einem Formular oder Bericht

Hinzufügen eines neuen Diagramms zu einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Formularentwurfsansicht oder den Bericht in der Berichtsentwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Diagramm.

    Tipp Wenn Sie viele Diagramme erstellen, können Sie der Symbolleiste die Schaltfläche Diagramm [image] hinzufügen.

    Wie wird's gemacht?

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Diagramm einfügen möchten.

  4. Folgen Sie den Anweisungen des Diagramm-Assistenten. Er erstellt das Diagramm auf der Basis von verfügbaren Tabellen oder anderen Datenherkünften sowie der ausgewählten Felder.

    Anmerkung Mindestens eines dieser Felder muss ein Feld eines Datentyps sein, der nur Zahlen speichert, wie beispielsweise Währung.

  5. Wechseln Sie zur Formularansicht oder zur Seitenansicht, um das Diagramm mit den aktuellen Daten anzuzeigen.

Anmerkungen

  • In einem Microsoft Access-Projekt können Sie den Diagramm-Assistenten nicht verwenden, Sie können Diagramme jedoch durch Einfügen des Microsoft Graph 2000-Diagramm-Objekts (Menü Einfügen, Befehl Objekt) hinzufügen.

  • In der Entwurfsansicht für Formulare bzw. Berichte zeigt ein Diagramm nach der Erstellung zunächst Beispieldaten an. Wenn Sie aktuelle Daten sehen wollen, wechseln Sie zur Formularansicht oder zur Seitenansicht, oder schließen Sie das Formular bzw. den Bericht und öffnen ihn erneut. Informationen über das Anpassen von Diagrammen anzeigen.

  • Der Diagramm-Assistent erstellt eine Abfrage für die Datenherkunft in der Eigenschaft Datensatzherkunft, in der die Kriterien gelten, die Sie beim Eingeben der Informationen in die Dialogfelder des Diagramm-Assistenten festgelegt haben. Wenn das Diagramm nicht Ihren Vorstellungen entspricht, klicken Sie auf [image] .

  • Mit dem Diagramm-Assistenten können Sie keine Netz-, Oberflächen- oder Kombinationsdiagramme erstellen. Sie können jedoch in Microsoft Graph das neu erstellte Diagramm mit Hilfe des Diagramm-Assistenten in eine beliebigen anderen Diagrammtyp umwandeln, darunter auch Netz-, Oberflächen- oder Kombinationsdiagramme. Informationen über die Verwendung von Microsoft Graph anzeigen.


 Verknüpfen eines vorhandenen Diagramms in einem Formular oder Bericht mit einem bestimmten Datensatz

Verknüpfen eines vorhandenen Diagramms in einem Formular oder Bericht mit einem bestimmten Datensatz

Wenn der Diagramm-Assistent ein globales Diagramm für alle Daten erstellt, Sie jedoch Diagramme für jeden einzelnen Datensatz wünschen, können Sie das Diagramm mit einem bestimmten Datensatz verknüpfen. Dazu führen Sie die nachstehend beschriebenen Schritte aus.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Vergewissern Sie sich, dass das Diagramm markiert ist, und klicken Sie dann auf Eigenschaften [image] .

  3. Geben Sie in den Einstellungsfeldern der Eigenschaften VerknüpfenVon und VerknüpfenNach den Namen eines Feldes ein, das im Einstellungsfeld der Eigenschaft Datensatzherkunft enthalten ist und jeden Datensatz eindeutig identifiziert, wie z.B. ein Primärschlüssel.

    Die Werte in den Einstellungsfeldern dieser Eigenschaften müssen in allen Datensätzen mit den Werten eines Feldes übereinstimmen, das in der dem Formular oder dem Bericht zugrunde liegenden Tabelle oder einer anderen Datenherkunft enthalten ist. Wenn Sie Ihr Diagramm über dieses Feld verknüpfen möchten, und die dem Formular zugrunde liegende Tabelle das Feld Artikel-Nr enthält, müssen Sie Artikel-Nr in den Einstellungsfeldern der Eigenschaften VerknüpfenVon und VerknüpfenNach eingeben.

  4. Um festzustellen, ob das Diagramm nur die Daten für den aktuellen Datensatz darstellt, zeigen Sie das Formular in der Formularansicht oder den Bericht in der Seitenansicht an.


 Hinzufügen eines vorhandenen Diagramms zu einem Formular oder Bericht

Hinzufügen eines vorhandenen Diagramms zu einem Formular oder Bericht

Mit Hilfe des nachstehend beschriebenen Verfahrens können Sie ein vorhandenes Diagramm, das in einer anderen Microsoft Access-Datenbank oder in einem anderen Programm erstellt wurde, Ihrer Datenbank hinzufügen. Sie können dieses Diagramm jedoch nicht durch Ändern der Daten in Ihrer Datenbank aktualisieren.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Klicken Sie in der Toolbox auf Ungebundener Objektrahmen [image] .

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Diagramm einfügen möchten.

  4. Klicken Sie im Dialogfeld Objekt einfügen auf Aus Datei erstellen, und geben Sie dann einen Pfad zu dieser Datei an. Klicken Sie auf Durchsuchen, wenn Sie den Pfad nicht kennen.

  5. Wenn Sie das Diagramm nicht einbetten, sondern verknüpfen möchten, aktivieren Sie das Kontrollkästchen Verknüpfen.

  6. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn das Diagramm als Symbol angezeigt werden soll.


 Hinzufügen der Schaltfläche "Diagramm" zu einer Symbolleiste in der Entwurfsansicht eines Formulars oder eines Berichts

Hinzufügen der Schaltfläche "Diagramm" zu einer Symbolleiste in der Entwurfsansicht eines Formulars oder eines Berichts

Anmerkung Die Schaltfläche "Diagramm" kann nur bei einer Microsoft Access-Datenbank und nicht bei Microsoft Access-Projekten hinzugefügt werden.

  1. Wechseln Sie zur entsprechenden Ansicht, und stellen Sie sicher, dass die Symbolleiste eingeblendet ist, zu der Sie die Schaltfläche Diagramm hinzufügen möchten.

  2. Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle in der Symbolleiste.

  3. Klicken Sie auf Anpassen.

  4. Klicken Sie auf die Registerkarte Befehle.

  5. Klicken Sie im Feld Kategorien auf Toolbox.

  6. Ziehen Sie aus dem Feld Befehle die Schaltfläche Diagramm [image] an die gewünschte Position in der Symbolleiste.


 Ändern der Größe eines Diagramms in einem Formular oder Bericht

Ändern der Größe eines Diagramms in einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Klicken Sie auf das Diagramm.

  3. Bewegen Sie den Mauszeiger über einen der Ziehpunkte zur Größenänderung, bis dieser zu einem Doppelpfeil wird.

  4. Ziehen Sie den Ziehpunkt an die Stelle, an der sich der Rand des Objekts befinden soll, und lassen Sie dann die Maustaste los.


 Ändern des Erscheinungsbildes eines Diagramms in einem Formular oder Bericht

Ändern des Erscheinungsbildes eines Diagramms in einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Doppelklicken Sie auf das Diagramm, um Microsoft Graph zu öffnen.

  3. Nehmen Sie die gewünschten Änderungen vor.

    Weitere Informationen zum Anpassen von Diagrammen.

    Zum Anzeigen von Informationen über Microsoft Graph klicken Sie im Menü Hilfe auf Microsoft Graph-Hilfe.

  4. Wenn Sie das Diagramm bearbeitet haben, klicken Sie im Menü Datei von Microsoft Graph auf Beenden.

  5. Wenn Sie aufgefordert werden, das Objekt zu aktualisieren, klicken Sie auf Ja.

Anmerkung Obwohl Sie die in Ihrem Diagramm dargestellten Daten auch im Datenblatt in Microsoft Graph ändern können, werden diese Datenänderungen sowie bestimmte Formatänderungen von Microsoft Access überschrieben. Um die im Diagramm angezeigten Daten zu aktualisieren, ändern Sie die zugrunde liegende Tabelle bzw. andere Datenherkunft oder die Abfrage in der Datensatzherkunft-Eigenschaft. Um weitere Informationen zum Ändern dieser Abfrage anzuzeigen, klicken Sie auf [image] .


 Ändern der Daten in der zugrunde liegenden Tabelle oder anderen Datenherkunft für ein Diagramm in einem Formular oder Bericht

Ändern der Daten in der zugrunde liegenden Tabelle oder anderen Datenherkunft für ein Diagramm in einem Formular oder Bericht

So ändern Sie die Daten in einer zugrunde liegenden Tabelle

  • Öffnen Sie die zugrunde liegende Tabelle in der Datenblattansicht, und bearbeiten Sie dann die Daten.

So ändern Sie Daten einer zugrunde liegenden Datenherkunft

  • Öffnen Sie die zugrunde liegende Datenherkunft in der Entwurfsansicht, und bearbeiten Sie dann die Daten.

Wenn Sie die Daten in der zugrunde liegenden Tabelle oder anderer Datenherkunft geändert haben, müssen Sie das Formular in der Formularansicht oder den Bericht in der Seitenansicht öffnen, um das Diagramm mit den aktuellen Daten anzuzeigen.

Falls das Ändern der Daten in der zugrunde liegenden Tabelle oder anderer Datenherkunft nicht zum gewünschten Ergebnis führt, können Sie versuchsweise die Datensatzherkunft-Abfrage ändern. Um weitere Informationen zum Ändern der Datensatzherkunft-Abfrage anzuzeigen, klicken Sie auf [image] .


 Konvertieren eines Diagramms in einem Formular oder einem Bericht in ein Bild, um Speicherplatz zu sparen

Konvertieren eines Diagramms in einem Formular oder einem Bericht in ein Bild, um Speicherplatz zu sparen

Wenn Sie Speicherplatz sparen müssen, können Sie das Diagramm in ein Bild konvertieren, sofern es sich nicht um ein Diagramm handelt, das an einen Datensatz gebunden ist. Nach dem Konvertieren in ein Bild lässt sich das Diagramm jedoch nicht mehr bearbeiten.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Klicken Sie auf das Diagramm.

  3. Zeigen Sie im Menü Format auf Ändern in, und klicken Sie dann auf Bild.


 In Microsoft Access verwendbare Grafikfilter und Dateiformate

In Microsoft Access verwendbare Grafikfilter und Dateiformate

Sie können viele der häufigsten Grafikdateiformate in ein Formular, in einen Bericht oder in eine Datenzugriffsseite einfügen. Dies kann entweder direkt oder mit Hilfe eines eigenen Grafikfilters erfolgen. Dazu verwenden Sie im Menü Einfügen den Befehl Bild. Bei Formularen und Berichten muß kein spezieller Grafikfilter installiert sein, um Grafken des folgenden Formats einzufügen: Erweiterte Metadateien (.emf), Windows Bitmaps (.bmp, .rle, .dib), Windows Metadateien (.wmf) und Symbole (.ico). Zum Einfügen der im Folgenden aufgelisteten Grafikformate benötigen Sie jedoch einen Grafikfilter.

Grafikdateiformate, für die Grafikfilter erforderlich sind
Computer Graphics Metafile (.cgm) | Kodak Photo CD (.pcd)
CorelDRAW (.cdr) | Macintosh PICT (.pct)
Encapsulated PostScript (.eps) | PC Paintbrush (.pcx)
FlashPix (.fpx) | Portable Network Graphics (.png)
Graphic Interchange Format (.gif) | Tagged Image File Format (.tif)
Hanako (.jsh, .jah, .jbh) | WordPerfect Graphics (.wpg)
JPEG-Dateiformat (.jpg) | X-Bitmap (.xbm)

Auf Seiten benötigen Sie keine speziellen Grafikfilter, um Windows Bitmapgrafiken (.bmp, .rle, .dib) einzufügen. Notwendig ist ein Grafikfilter jedoch, um Grafiken der folgenden Formate einzufügen: Graphic Interchange Format (.gif), JPEG-Dateiformat (.jpg), Portable Network Graphics (.png) und X-Bitmap (.xbm).

Diese Grafikfilter werden nicht mit der Einzelversion von Microsoft Access 2000 geliefert. Zum Verwenden der Filter ist es erforderlich, Microsoft Office 2000 Professional Edition, Microsoft Office 2000 Premier Edition oder eine Einzelversion von Microsoft Word 2000 zusammen mit Ihrer Einzelversion von Access 2000 zu installieren.

Anmerkung Weitere Informationen zu den einzelnen Grafikfiltern finden Sie in der Dokumentation zu Word.


Formulare: Definition und Funktionsweise

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


Erstellen eines Formulars

Was möchten Sie tun?

Ein Formular unter Verwendung von AutoFormular erstellen. Mit AutoFormular wählen Sie eine Datenquelle und entweder ein Spalten-, Tabellen- oder Datenblatt-Layout aus. AutoFormular erstellt ein Formular mit allen Feldern aus der ausgewählten Datenquelle und allen Feldern aus verknüpften Datenquellen.

Ein Formular mit Hilfe eines Assistenten erstellen. Der Assistent stellt detaillierte Fragen zu Datenquellen, Feldern, Layout und Format, das von Ihnen gewünscht wird, und erstellt basierend auf Ihren Antworten ein Formular.

Ein Formular ohne Assistenten erstellen

Ein Formular auf der Basis mehrerer Tabellen erstellen


Möglichkeiten zum Anpassen eines Formulars

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


Hinzufügen eines Bildes oder eines anderen Objekts zu einem Formular, einem Bericht oder einer Datenzugriffsseite

Was möchten Sie tun?

Ein ungebundenes Bild zu einem Formular, einem Bericht oder einer Datenzugriffsseite hinzufügen

Ein ungebundenes Objekt (beispielsweise ein Microsoft Excel- oder Microsoft Word-Dokument) zu einem Formular oder Bericht hinzufügen

Ein gebundenes Bild oder Objekt (beispielsweise ein Excel- oder Word-Dokument) zu einem Formular oder Bericht hinzufügen

Ein gebundenes Bild zu einer Datenzugriffsseite hinzufügen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Erstellen eines Formulars oder Berichts aus gefilterten Datensätzen

Erstellen eines Formulars oder Berichts aus gefilterten Datensätzen

  1. Zeigen Sie die gefilterten Datensätze an, und klicken Sie dann in der Symbolleiste neben der Schaltfläche Neues Objekt auf den Pfeil.
    • Wenn Sie den AutoFormular-Assistenten oder den AutoBericht-Assistenten verwenden möchten, klicken Sie auf AutoFormular bzw. auf AutoBericht.

    • Zum Festlegen der Art des Formulars oder Berichts, den Sie erstellen möchten, klicken Sie auf Formular bzw. Bericht und treffen danach Ihre Wahl.

      Das neue Objekt verwendet als Datenherkunft die Tabelle oder Abfrage, in der der Filter erstellt wurde, und übernimmt den Filter.

  2. Vervollständigen Sie den Entwurf, oder führen Sie andere Änderungen im Formular oder Bericht durch, und speichern Sie diesen dann.

Anmerkungen

  • Wenn in der zugrunde liegenden Tabelle oder Abfrage eine Sortierreihenfolge angewendet wurde, übernimmt das neue Formular bzw. der neue Bericht diese Reihenfolge.

  • Wenn Sie den Filter später in einer Tabelle oder Abfrage ändern, hat dies keinen Einfluss auf ein Formular oder einen Bericht, der auf einem Filter basierte, den Sie zuvor in dieser Tabelle oder Abfrage erstellt haben.


 Öffnen eines Formulars

Öffnen eines Formulars

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie auf das Formular, das Sie öffnen möchten.

  3. Klicken Sie auf die Schaltfläche Öffnen, um das Formular in der Formularansicht zu öffnen, oder auf die Schaltfläche Entwurf, um es in der Entwurfsansicht zu öffnen.

Tipp Sie können ein Formular auch in der Formularansicht öffnen, indem Sie es aus dem Datenbankfenster auf den Anwendungshintergrund ziehen.

Nachdem Sie ein Formular geöffnet haben, können Sie mühelos zwischen seinen drei Ansichten wechseln, indem Sie in der Symbolleiste auf die Schaltfläche Ansicht klicken.


 Wechseln zwischen den Ansichten eines Formulars

Wechseln zwischen den Ansichten eines Formulars

  • Klicken Sie in der Symbolleiste auf die Schaltfläche Ansicht. Wenn Sie zu einer Ansicht wechseln möchten, die durch eine Schaltfläche symbolisiert wird, klicken Sie auf die entsprechende Schaltfläche. Um eine Liste anderer wählbarer Ansichten anzuzeigen, klicken Sie auf den Pfeil neben der Schaltfläche.

Weitere Informationen zum Verwendungszweck der verschiedenen Ansichten erhalten Sie durch Klicken auf [image] .


Ansichten eines Formulars

Formulare haben drei Ansichten: Entwurfsansicht, Formularansicht und Datenblattansicht.

Zum Erstellen eines Formulars arbeiten Sie in der Entwurfsansicht. Das Anzeigen eines Formulars in der Entwurfsansicht ist wie die Arbeit an einer Werkbank, die mit nützlichen Werkzeugen gut bestückt ist.

Ein Formular in Entwurfsansicht

Nachdem Sie ein Formular in der Entwurfsansicht erstellt haben, können Sie es in der Formularansicht oder der Datenblattansicht anzeigen.

Ein Formular in Formularansicht und Datenblattansicht


 Markieren eines Formulars oder Berichts

Markieren eines Formulars oder Berichts

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf den Formularmarkierer bzw. den Berichtsmarkierer.

    Formularmarkierer oder Berichtsmarkierer

    Wenn die Lineale nicht angezeigt werden, können Sie im Menü Bearbeiten auf Formular auswählen oder Bericht auswählen klicken, oder Sie können auf den grauen Hintergrund rechts vom Formular klicken, um es zu markieren.


 Markieren eines Bereichs in einem Formular oder Bericht

Markieren eines Bereichs in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf den Bereichsmarkierer oder auf eine beliebige Stelle in der Bereichsleiste.

    Bereichsmarkierer und Bereichsleiste

    Sie können auch auf eine beliebige Stelle im Hintergrund des zu markierenden Bereichs klicken.


 Ändern der Rastergenauigkeit (Unterteilung)

Ändern der Rastergenauigkeit (Unterteilung)

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer bzw. den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Um die horizontalen Einheiten zu ändern, geben Sie für die Eigenschaft RasterX einen neuen Wert ein. Um die vertikalen Einheiten zu ändern, geben Sie für die Eigenschaft RasterY einen neuen Wert ein. Je höher der Wert, desto höher die Genauigkeit.

Anmerkung Das Raster ist horizontal und vertikal auf standardmäßig 5 Einheiten pro Zentimeter eingestellt. Wenn Sie als Maßeinheit Zoll verwenden, ist das Raster auf 10"x12" eingestellt. Sie können diese Einstellungen ändern und auf eine beliebige ganze Zahl zwischen 1 und 64 setzen. Bei einer Genauigkeit von mehr als 6 Einheiten pro Zentimeter oder 16 Einheiten pro Zoll sind Punkte auf dem Raster nicht sichtbar.


 Einstellen von Eigenschaften für ein Formular, einen Bericht, einen Bereich oder ein Steuerelement

Einstellen von Eigenschaften für ein Formular, einen Bericht, einen Bereich oder ein Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht. Falls die Eigenschaft Entwurfsänderungen zulassen eines Formulars auf Alle Ansichten eingestellt ist, können Sie Eigenschaften auch in der Formularansicht und in der Datenblattansicht einstellen.

  2. Führen Sie einen der folgenden Schritte aus:
    • Zum Einstellen der Eigenschaften für ein Formular oder einen Bericht doppelklicken Sie auf den Formularmarkierer bzw. den Berichtsmarkierer, um das entsprechende Eigenschaftenfenster zu öffnen.

    • Zum Einstellen der Eigenschaften für einen Bereich eines Formulars oder Berichts doppelklicken Sie auf den Bereichsmarkierer, um das Eigenschaftenfenster für den Bereich zu öffnen.

    • Zum Einstellen der Eigenschaften für ein Steuerelement vergewissern Sie sich, dass dieses markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] . Sie können auch auf ein Steuerelement doppelklicken, um dessen Eigenschaftenfenster zu öffnen.
  3. Klicken Sie im Eigenschaftenfenster auf die Eigenschaft, die eingestellt werden soll, und gehen Sie dann folgendermaßen vor:
    • Wird im Einstellungsfeld der Eigenschaft ein Pfeil angezeigt, klicken Sie darauf, und wählen Sie aus der Liste einen Wert aus.

    • Geben Sie in das Einstellungsfeld der Eigenschaft eine Einstellung oder einen Ausdruck ein.

    • Wird neben dem Einstellungsfeld der Eigenschaft eine Generator-Schaltfläche [image] angezeigt, klicken Sie darauf. Ein Editor bzw. ein Dialogfeld mit einer Auswahl von Editoren wird angezeigt. Sie können z. B. den Abfrage-Generator verwenden, um den Entwurf einer zugrunde liegenden Abfrage für ein Formular oder einen Bericht zu ändern.
  4. Wenn beim Eingeben oder Ändern einer Eigenschafteneinstellung der Platz im Einstellungsfeld nicht ausreicht, drücken Sie UMSCHALT+F2 (oder klicken Sie mit der rechten Maustaste und dann auf Zoom), um das Dialogfeld Zoom zu öffnen.

Wenn das Eigenschaftenfenster leer ist oder nicht die erwarteten Eigenschaften angezeigt werden, klicken Sie auf [image] .

Tipp Um Hilfe zu einer Eigenschaft im Eigenschaftenfenster anzuzeigen, klicken Sie auf die Eigenschaft, und drücken Sie dann F1.


 Festlegen der Formulargröße beim ersten Öffnen

Festlegen der Formulargröße beim ersten Öffnen

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Legen Sie die Größe des Formulars fest, indem Sie den Rahmen des Formularfensters in die gewünschte Position ziehen.

  3. Klicken Sie in der Symbolleiste auf Speichern [image] .

Anmerkung Ist die Eigenschaft GrößeAnpassen auf Ja gesetzt, passt Microsoft Access die Größe des Formulars automatisch so an, dass vollständige Datensätze angezeigt werden. Um die Formulargröße auf die gewünschte Größe einzustellen, setzen Sie die Eigenschaft GrößeAnpassen auf Nein.


 Wiederherstellen der gespeicherten Version eines Formulars oder Berichts

Wiederherstellen der gespeicherten Version eines Formulars oder Berichts

Sie können beliebige Änderungen an Visual Basic-Code, die Sie in der Entwurfsansicht eines Formulars oder Berichts durchgeführt haben, verwerfen und zur zuletzt gespeicherten Version eines Formulars oder Berichts zurückkehren.

Achtung Wenn Sie die zuletzt gespeicherte Version des Formulars oder Berichts wiederhergestellt haben, können Sie die seit dem letzten Öffnen des Formulars oder Berichts durchgeführten Änderungen nicht mehr wiederherstellen.

Zum Wiederherstellen der zuletzt gespeicherten Version führen Sie folgendes aus:

  • Klicken Sie im Menü Datei auf Wiederherstellen.

Anmerkung Dieser Befehl steht nur zur Verfügung, wenn Sie ein Formular oder einen Bericht in der Entwurfsansicht geöffnet und Änderungen daran vorgenommen haben. Der Befehl Wiederherstellen steht nicht in der Entwurfsansicht einer Datenzugriffsseite zur Verfügung.


 Anzeigen eines Formulars in der Seitenansicht

Anzeigen eines Formulars in der Seitenansicht

So zeigen Sie ein Formular aus der Entwurfs-, Formular- oder Datenblattansicht in der Vorschau an

  1. Klicken Sie in der Symbolleiste auf Seitenansicht [image] .

  2. Zur Rückkehr zur Entwurfsansicht, Formularansicht oder Datenblattansicht klicken Sie in der Symbolleiste auf die Schaltfläche Ansicht.

So zeigen Sie ein Formular aus dem Datenbankfenster in der Vorschau an

  1. Klicken Sie unter Objekte auf Formulare [image] .

  2. Wählen Sie das Formular aus, das Sie in der Vorschau anzeigen möchten.

  3. Klicken Sie in der Symbolleiste auf Seitenansicht

Wie Microsoft Access ein Formular in der Seitenansicht anzeigt, ist von der Ansicht abhängig, aus der Sie die Vorschau aktivieren.

Aus | Anzeige des Formulars
Entwurfsansicht | In der Formularansicht.
Formularansicht | In der Formularansicht.
Datenblattansicht | Als Datenblatt.
Datenbankfenster | In der Ansicht, die in der Eigenschaft Standardansicht des Formulars angegeben ist.

Weitere Informationen zum Anzeigen eines Formulars in verschiedenen Größen erhalten Sie durch Klicken auf [image] .

Weitere Informationen zum Anzeigen von zwei oder mehr Seiten gleichzeitig erhalten Sie durch Klicken auf [image] .


Drucken eines Formulars

Was möchten Sie tun?

Die Seitenausrichtung oder andere Seiteneinrichtungsoptionen festlegen

Ein Formular aus der Entwurfsansicht, Formularansicht oder Datenblattansicht drucken

Ein Formular aus dem Datenbankfenster drucken

Die in einem Formular oder Datenblatt markierten Datensätze drucken

Den aktuellen Datensatz drucken

Ein Formular unter Verwendung einer Verknüpfung drucken


 Drucken der in einem Formular oder Datenblatt markierten Datensätze

Drucken der in einem Formular oder Datenblatt markierten Datensätze

  1. Öffnen Sie das Formular in der Formularansicht oder der Datenblattansicht.

  2. Markieren Sie die zu druckenden Datensätze, indem Sie auf den Datensatzmarkierer klicken oder UMSCHALT+LEERTASTE drücken (im Modus Bearbeiten drücken Sie erst F2, bevor Sie UMSCHALT+LEERTASTE drücken). Wenn Sie mehrere Datensätze markieren möchten, klicken Sie auf den ersten Datensatzmarkierer und ziehen dann bis zum letzten zu druckenden Datensatz.

  3. Klicken Sie im Menü Datei auf Drucken.

  4. Klicken Sie im Dialogfeld Drucken unter Druckbereich auf Markierte Datensätze.


 Änderungen an Formulareigenschaften in der Formular- oder Datenblattansicht ermöglichen

Änderungen an Formulareigenschaften in der Formular- oder Datenblattansicht ermöglichen

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Stellen Sie die AllowDesignChanges-Eigenschaft auf Alle Ansichten ein.

Wenn die AllowDesignChanges-Eigenschaft auf Alle Ansichten eingestellt ist, können Sie die Eigenschaften des Formulars und seiner Steuerelemente ändern, indem sie das Eigenschaftenfenster in der Formularansicht oder Datenblattansicht anzeigen.


 Festlegen, ob ein Formular nur zum Eingeben von Daten geöffnet werden kann

Festlegen, ob ein Formular nur zum Eingeben von Daten geöffnet werden kann

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft DatenEingeben auf Ja, wenn Sie das Formular zum Eingeben von Daten (mit einem leeren Datensatz) öffnen möchten, oder klicken Sie auf Nein, wenn Sie das Formular zum Anzeigen aller Datensätze öffnen möchten.


 Definieren der Startansicht für ein Formular (ein Datensatz, mehrere Datensätze, Datenblatt)

Definieren der Startansicht für ein Formular (ein Datensatz, mehrere Datensätze, Datenblatt)

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Standardansicht-Eigenschaft auf eine der folgenden Einstellungen.
    Einstellung | Beschreibung
    Einzelnes Formular | Zeigt jeweils einen vollständigen Datensatz an. (Nur Formularansicht)
    Endlosformular | Zeigt so viele vollständige Datensätze an, wie in den Detailbereich des Formulars passen. (Nur Formularansicht)
    Datenblatt | Zeigt die Datensätze in Form von Zeilen und Spalten an. Zur Anzeige vollständiger Datensätze ist möglicherweise ein Bildlauf erforderlich.

Anmerkung Zum Deaktivieren der Formularansicht oder der Datenblattansicht können Sie die Eigenschaft ZugelasseneAnsicht(en) setzen.


Bereiche eines Formulars

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


 Hinzufügen oder Entfernen eines Formularkopfes oder -fußes oder eines Seitenkopfes oder -fußes

Hinzufügen oder Entfernen eines Formularkopfes oder -fußes oder eines Seitenkopfes oder -fußes

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie im Menü Ansicht auf Formularkopf/-fuß oder auf Seitenkopf/-fuß.

Anmerkungen

  • Formularköpfe und Formularfüße werden am oberen bzw. unteren Rand eines Formulars in der Formularansicht sowie am Anfang bzw. Ende eines gedruckten Formulars angezeigt. Seitenköpfe und Seitenfüße werden am oberen bzw. unteren Rand jeder gedruckten Seite angezeigt. In der Formularansicht werden sie nicht angezeigt.

  • Wenn Sie einen Kopf oder Fuß entfernen, löscht Microsoft Access die in diesem Kopf oder Fuß enthaltenen Steuerelemente .

  • Sie können Köpfe und Füße immer nur paarweise hinzufügen. Wenn Sie weder einen Kopf noch einen Fuß benötigen, können Sie diesem eine Höhe gleich Null zuweisen oder für dessen Eigenschaft Sichtbar die Einstellung Nein setzen. Darüber hinaus können Sie mit Hilfe der Eigenschaft Anzeigen festlegen, wann Kopf und Fuß angezeigt werden sollen: Immer, Nur beim Drucken oder Nur am Bildschirm.

Beispiel für die Verwendung unterschiedlicher Bereichsarten in einem Formular.


 Ausblenden der Bereichsbegrenzungslinien in einem Formular

Ausblenden der Bereichsbegrenzungslinien in einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Datensatztrennungen auf Nein.


 Anpassen der Formulargröße an den Inhalt

Anpassen der Formulargröße an den Inhalt

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie im Menü Fenster auf Größe an Formular anpassen.

    Anmerkung Bei einem maximierten Formularfenster ist der Befehl Größe an Formular anpassen nicht verfügbar.

  3. Klicken Sie in der Symbolleiste auf Speichern [image] , um die Größe des Formulars zu speichern.

Wenn Sie auf Größe an Formular anpassen klicken, passt Microsoft Access die Größe des Formulars je nach Einstellung der Eigenschaft Standardansicht (Einzelnes Formular oder Endlosformular) an.

  • Einzelnes Formular. Ist der angezeigte Datensatz kleiner als das Formularfenster, schneidet Größe an Formular anpassen das Fenster auf die Größe des Datensatzes zu. Ist der Datensatz größer als das Formularfenster, erweitert Größe an Formular anpassen das Formularfenster, um so viel wie möglich vom Datensatz anzuzeigen.

  • Endlosformular. Wird der letzte Datensatz nur teilweise angezeigt, schneidet Größe an Formular anpassen diesen Datensatz ab. Wird nur ein Datensatz teilweise angezeigt, erweitert Größe an Formular anpassen das Fenster, um so viel wie möglich vom Datensatz anzuzeigen.


 Zentrieren eines Formulars im Anwendungsfenster beim ersten Öffnen

Zentrieren eines Formulars im Anwendungsfenster beim ersten Öffnen

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Setzen Sie die Eigenschaft AutomatischZentrieren auf Ja.

    Beim nächsten Öffnen des Formulars wird es im Anwendungsfenster zentriert.


Ändern der Maßeinheit des Lineals in einem Formular oder Bericht

  1. Klicken Sie in Windows auf die Schaltfläche Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf das Symbol Ländereinstellungen.

  3. Klicken Sie auf die Registerkarte Zahlen.

  4. Klicken Sie im Listenfeld Maßsystem auf Metrisch oder US-Maße.


 Ändern der Aktivierreihenfolge der Steuerelemente in einem Formular

Ändern der Aktivierreihenfolge der Steuerelemente in einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie im Menü Ansicht auf Aktivierreihenfolge.

  3. Klicken Sie unter Bereich auf den Bereich, den Sie ändern möchten.

  4. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie auf Automatisch, wenn Sie möchten, dass Microsoft Access die Reihenfolge von links nach rechts und von oben nach unten festlegt.

    • Wenn Sie eine eigene Reihenfolge definieren möchten, klicken Sie auf den Markierer für das Steuerelement, das Sie verschieben möchten. (Klicken und ziehen Sie, wenn Sie mehrere Steuerelemente gleichzeitig markieren möchten.) Klicken Sie erneut auf den Markierer, und ziehen Sie das Steuerelement an die gewünschte Position in der Liste.
  5. Klicken Sie auf OK.

  6. Wechseln Sie zur Formularansicht, um die Reihenfolge zu testen. (In der Entwurfsansicht bleibt die Reihenfolge immer die, in der Sie die Steuerelemente erstellt haben.)

Anmerkungen

  • Wenn Sie festlegen möchten, dass ein Steuerelement in einem Formular markiert werden kann, dieses jedoch nicht in die Reihenfolge einbezogen werden soll, setzen Sie die Eigenschaft In Reihenfolge des Steuerelements auf Nein.

  • Sie können auch festlegen, welcher Datensatz oder welche Seite den Fokus erhalten soll, wenn Sie im letzten Feld des aktuellen Datensatzes TAB drücken.

    Wie wird's gemacht?


 Ändern der Aktivierreihenfolge für das letzte Feld eines Formulars

Ändern der Aktivierreihenfolge für das letzte Feld eines Formulars

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Zyklus auf eine der folgenden Einstellungen.
    Einstellung | Beschreibung
    Alle Datensätze | Wenn Sie im letzten Feld des Datensatzes TAB drücken, wird der Fokus auf das erste Feld des nächsten Datensatzes gesetzt.
    Aktueller Datensatz | Wenn Sie im letzten Feld des Datensatzes TAB drücken, wird der Fokus auf das erste Feld des aktuellen Datensatzes zurückgesetzt.
    Aktuelle Seite | Wenn Sie im letzten Feld auf der Formularseite TAB drücken, wird der Fokus auf das erste Feld der aktuellen Seite zurückgesetzt.


 Entfernen des Kontextmenüs aus einem Formular

Entfernen des Kontextmenüs aus einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Kontextmenü auf Nein.


 Entfernen von Datensatzmarkierern aus einem Formular

Entfernen von Datensatzmarkierern aus einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Datensatzmarkierer auf Nein.


 Entfernen der Navigationsschaltflächen aus einem Formular

Entfernen der Navigationsschaltflächen aus einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Navigationsschaltflächen auf Nein.


 Deaktivieren der Schließen-Schaltfläche in einem Formular

Deaktivieren der Schließen-Schaltfläche in einem Formular

  1. Doppelklicken Sie in der Entwurfsansicht für Formulare auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  2. Klicken Sie im Einstellungsfeld der Eigenschaft SchließenSchaltfläche auf Nein.

Anmerkungen

  • Wenn Sie die Eigenschaft SchließenSchaltfläche auf Nein einstellen, deaktiviert Microsoft Access sowohl die Schaltfläche Schließen [image] als auch den Befehl Schließen im Systemmenü.

  • Wenn Sie die Schaltfläche Schließen komplett entfernen möchten, können Sie die Eigenschaft Rahmenart verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Hinzufügen oder Entfernen von Bildlaufleisten zu/aus einem Formular oder Textfeld

Hinzufügen oder Entfernen von Bildlaufleisten zu/aus einem Formular oder Textfeld

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Öffnen Sie das Eigenschaftenfenster für das Textfeld oder das Formular. Um das Eigenschaftenfenster für das Textfeld zu öffnen, klicken Sie auf das Textfeld und dann in der Symbolleiste auf Eigenschaften [image] . Um das Eigenschaftenfenster für das Formular zu öffnen, doppelklicken Sie auf den Formularmarkierer.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Bildlaufleisten auf die gewünschte Einstellung.


 Ausblenden von Datensatzbegrenzungslinien in einem Endlosfomular

Ausblenden von Datensatzbegrenzungslinien in einem Endlosfomular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Trennlinien auf Nein.


 Ausblenden des Systemmenüs in einem Formular

Ausblenden des Systemmenüs in einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Mit Systemmenüfeld auf Nein.

Anmerkungen

  • Wenn die Eigenschaft Rahmenart des Formulars auf Keine eingestellt ist, enthält das Formular kein Systemmenüfeld, auch wenn die Eigenschaft Mit Systemmenüfeld auf Ja eingestellt ist.

  • Wenn Sie die Eigenschaft Mit Systemmenüfeld auf Nein festlegen, werden die Schaltflächen Minimieren, Maximieren und Schließen ebenfalls ausgeblendet.


 Ausblenden der Maximieren- und Minimieren-Schaltflächen bei Formularen

Ausblenden der Maximieren- und Minimieren-Schaltflächen bei Formularen

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft MinMaxSchaltflächen auf eine der Einstellungen.

Anmerkung Wenn die Eigenschaft Rahmenart des Formulars auf Keine oder Dialog eingestellt ist, enthält das Formular keine Minimieren- und Maximieren-Schaltfläche, auch wenn die Eigenschaft MinMaxSchaltflächen auf Min vorhanden, Max vorhanden oder Beide vorhanden festgelegt ist.


 Temporäres Öffnen eines beliebigen Formulars als Dialogfeld

Temporäres Öffnen eines beliebigen Formulars als Dialogfeld

  1. Erstellen Sie ein Makro oder eine Ereignisprozedur, das bzw. die die Aktion ÖffnenFormular verwendet, um das Formular zu öffnen.

  2. Setzen Sie das Argument Fenstermodus der Aktion ÖffnenFormular auf Dialog (acDIALOG für eine Ereignisprozedur).

    Wenn Sie ein Formular öffnen, dessen Argument Fenstermodus auf Dialog eingestellt ist, ist den Eigenschaften PopUp und Gebunden des Formulars so lange die Einstellung Ja zugeordnet, bis das Formular geschlossen wird. Microsoft Access deaktiviert außerdem die benutzerdefinierten Tastenkombinationen und einige andere Microsoft Access-Funktionen und setzt das Makro oder die Ereignisprozedur so lange außer Kraft, bis Sie das Formular schließen oder ausblenden. Sie können ein Formular ausblenden, indem Sie dessen Eigenschaft Sichtbar mit Hilfe der Aktion SetzenWert auf Nein einstellen.


Arbeiten mit Steuerelementgruppen in Formularen und Berichten

Was möchten Sie tun?

Textfelder oder andere Steuerelemente gruppieren

Die Gruppierung von Textfeldern oder anderen Steuerelementen aufheben

Die Größe eines Textfeldes oder anderen Steuerelements verändern

Ein Textfeld oder anderes Steuerelement in einer Gruppe verschieben

Ein einzelnes Textfeld oder anderes Steuerelement in einer Gruppe auswählen

Ein Textfeld oder anderes Steuerelement zu einer vorhandenen Gruppe hinzufügen

Ein Textfeld oder anderes Steuerelement aus einer vorhandenen Gruppe entfernen

Ein Textfeld oder anderes Steuerelement innerhalb einer Gruppe löschen


Bedingte Formatierungen in Textfeldern und anderen Steuerelementen in einem Formular oder Bericht

Was möchten Sie tun?

Die Farbe eines Steuerelements ändern, das in einem Formular den Fokus hat

Das Format des Wertes in einem Steuerelement ändern, wenn es bestimmte Kriterien erfüllt

Bedingte Formatierungen für ein Steuerelement ändern, hinzufügen oder löschen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Kopieren der bedingten Formatierung eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht

Kopieren der bedingten Formatierung eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Formular-Entwurfsansicht oder den Bericht in der Berichts-Entwurfsansicht.

  2. Wählen Sie das Steuerelement mit der bedingten Formatierung aus, die Sie kopieren möchten.

  3. Klicken Sie auf der Symbolleiste auf Format übertragen [image] .

  4. Klicken Sie auf das Steuerelement, auf das Sie die Formatierung übertragen wollen.


 Unterformulare: Definition und Funktionsweise

Unterformulare: Definition und Funktionsweise

Ein Unterformular ist ein Formular innerhalb eines Formulars. Das Primärformular wird als Hauptformular, das Formular innerhalb des Formulars als Unterformular bezeichnet. Eine Formular/Unterformular-Kombination wird oft auch als hierarchisches Formular oder als Kombination aus übergeordnetem und untergeordnetem Formular bezeichnet.

Unterformulare eignen sich vor allem zum Anzeigen von Daten aus Tabellen oder Abfragen mit einer 1:n-Beziehung. Sie können z.B. ein Formular mit einem Unterformular erstellen, um Daten aus einer Tabelle Kategorien und einer Tabelle Artikel anzuzeigen. Die Daten in der Tabelle Kategorien befinden sich auf der "1"-Seite und die Daten in der Tabelle Artikel auf der "n"-Seite der Beziehung. Jede Kategorie kann also einen oder mehrere Artikel enthalten.

Hauptformular mit Unterformular

Das Hauptformular und das Unterformular dieses Formulartyps sind so verknüpft, dass das Unterformular nur Datensätze anzeigt, die mit dem aktuellen Datensatz im Hauptformular verknüpft sind. Wenn z.B. das Hauptformular die Kategorie Getränke anzeigt, zeigt das Unterformular nur Artikel aus der Kategorie Getränke an.

Wenn Sie ein Formular zusammen mit einem Unterformular zum Eingeben neuer Datensätze verwenden, speichert Microsoft Access den aktuellen Datensatz im Hauptformular beim Wechseln zum Unterformular. Auf diese Weise wird gewährleistet, dass es für die Datensätze in der "n"-Tabelle einen entsprechenden Datensatz in der "1"-Tabelle gibt. Microsoft Access speichert automatisch auch jeden Datensatz beim Eingeben in das Unterformular.

Ein Unterformular kann, wie in der vorstehenden Abbildung gezeigt, als Datenblatt oder aber als einfaches oder Endlosformular angezeigt werden. Ein Hauptformular kann nur als einfaches Formular angezeigt werden.

Ein Hauptformular kann beliebig viele Unterformulare enthalten, vorausgesetzt, Sie stellen jedes dieser Unterformulare in das Hauptformular. Hauptformulare können auch Unterformulare enthalten, die auf bis zu zehn Ebenen verschachtelt sind. Ein Hauptformular kann also ein Unterformular und dieses Unterformular ein weiteres Unterformular enthalten u. s. w. So können Sie z. B. ein Hauptformular zum Anzeigen aller Kunden, ein Unterformular zum Anzeigen von Bestellungen und ein weiteres Unterformular zum Anzeigen von Bestelldetails verwenden.

Weitere Informationen

Siehe Beispiele zu unterschiedlichen Arten von Unterformularen

Erstellen eines oder mehrerer Unterformulare


 Unterformulartypen

Unterformulartypen

Wenn Sie ein Unterformular erstellen, können Sie festlegen, wie es angezeigt werden soll: nur in der Datenblattansicht, nur in der Formularansicht als Einzel- oder als Endlosformular oder in beiden Ansichten. Sie können ein Unterformular, das als Einzel- oder Endlosformular angezeigt wird, genau an Ihre Bedürfnisse anpassen und z. B. einen Kopf- und Fußbereich usw. hinzufügen.

Als Datenblatt angezeigtes Unterformular

Als einfaches Endlosformular angezeigtes Formular

Als Endlosformular in Form eines Datenblatts angezeigtes Formulars

Weitere Informationen

Unterformulare: Definition und Funktionsweise

Erstellen eines oder mehrerer Unterformulare

Anzeigen eines Endlosformulars als Datenblatt mit Kopf- und Fußbereich


 Ändern des Layouts eines Unterformulars

Ändern des Layouts eines Unterformulars

Die Art und Weise, wie Sie das Layout eines Unterformulars ändern, richtet sich danach, ob Sie das Unterformular in der Datenblattansicht öffnen oder in der Formularansicht als Einzelformular oder als Endlosformular anzeigen.

Was möchten Sie tun?

Das Layout eines Unterformulars, das in der Datenblattansicht angezeigt wird, ändern

Das Layout eines Unterformulars, das als Einzel- oder als Endlosformular angezeigt wird, ändern

Die Ansicht, in der das Unterformular angezeigt wird, ändern


 Wie werden Hauptformulare und Unterformulare verknüpft?

Wie werden Hauptformulare und Unterformulare verknüpft?

Unterformulare werden in der Regel zum Anzeigen von Daten aus Tabellen oder Abfragen der "n"-Seite einer 1:n-Beziehung verwendet. Eine Tabelle Kategorien und eine Tabelle Artikel haben z.B. eine 1:n-Beziehung: jede einzelne Kategorie kann mehrere Artikel beschreiben.

Wenn Sie ein Formular und ein Unterformular auf der Basis von Tabellen mit einer 1:n-Beziehung erstellen, zeigt das Hauptformular die "1"-Seite der Beziehung und das Unterformular die "n"-Seite der Beziehung. Das Hauptformular wird mit dem Unterformular so synchronisiert, dass das Unterformular nur Datensätze anzeigt, die mit dem Hauptformular verknüpft sind. Wenn Sie zum Erstellen eines Unterformulars einen Assistenten verwenden oder ein Formular, eine Tabelle oder eine Abfrage aus dem Datenbankfenster in ein anderes Formular ziehen, synchronisiert Microsoft Access automatisch das Hauptformular mit dem Unterformular, vorausgesetzt die beiden folgenden Bedingungen sind gegeben:

  • Sie haben Beziehungen für die ausgewählten Tabellen definiert, oder Sie haben Beziehungen für die den ausgewählten Abfragen zugrunde liegenden Tabellen definiert.

  • Das Hauptformular muss auf einer Tabelle mit einem Primärschlüssel und das Unterformular auf einer Tabelle basieren, die ein Feld enthält, dessen Name mit dem des Primärschlüssels meistens identisch ist, und deren Datentypen und Feldgröße kompatibel sind. Wenn der Primärschlüssel der dem Hauptformular zugrunde liegenden Tabelle z. B. ein Feld vom Datentyp AutoWert ist und die Eigenschaft Feldgröße auf Long Integer festgelegt ist, muss das entsprechende Feld in der dem Unterformular zugrunde liegenden Tabelle ein Feld vom Datentyp Zahl sein, und die Eigenschaft Feldgröße sollte auf Long Integer festgelegt sein. Wenn Sie eine oder mehrere Abfragen wählen, müssen die den Abfragen zugrunde liegenden Tabellen diesen Bedingungen entsprechen.

Anmerkung Microsoft Access verwendet zum Verknüpfen des Hauptformulars und des Unterformulars die Eigenschaften VerknüpfenNach und VerknüpfenVon des Unterformular-Steuerelements. Wenn Microsoft Access Formular und Unterformular aus irgendeinem Grund nicht verknüpft, können Sie die Formulare selbst verknüpfen.


 Verknüpfen eines Hauptformulars und eines Unterformulars

Verknüpfen eines Hauptformulars und eines Unterformulars

Wenn Sie zum Erstellen eines Unterformulars den Formular-Assistenten oder den Unterformular-Assistenten verwenden, verknüpft Microsoft Access das Hauptformular mit dem Unterformular automatisch, wenn bestimmte Bedingungen erfüllt sind. Zum Anzeigen weiterer Informationen klicken Sie auf [image] . Wenn Ihr Hauptformular und Ihr Unterformular diese Bedingungen nicht erfüllen, können Sie die Formulare unter Verwendung der nachstehenden Schritte manuell verknüpfen.

  1. Öffnen Sie das Hauptformular in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Unterformular-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das Unterformular-Steuerelement anzuzeigen.

  3. Geben Sie die verknüpfenden Felder oder Steuerelemente in die Einstellungsfelder für die Eigenschaften Verknüpfen von und Verknüpfen nach ein. Wenn Sie mehrere Verknüpfungsfelder oder -steuerelemente angeben möchten, geben Sie die Feld- oder Steuerelementnamen durch ein Semikolon voneinander getrennt ein. In diesem Fall müssen Sie die Feld- oder Steuerelementnamen in den Einstellungsfeldern beider Eigenschaften in derselben Reihenfolge angeben.
    • Geben Sie im Einstellungsfeld für die Eigenschaft Verknüpfen von den Namen jedes Verknüpfungsfeldes aus dem Unterformular ein. (Bei dieser Eigenschaft können Sie nicht den Namen eines Steuerelements verwenden.)

    • Geben Sie im Einstellungsfeld für die Eigenschaft Verknüpfen nach den Namen jedes Verknüpfungsfeldes oder -steuerelements aus dem Hauptformular ein.

      Wenn Sie nicht sicher sind, welches Feld bzw. Steuerelement für welche Eigenschaft bestimmt ist, klicken Sie auf die Aufbauen-Schaltfläche neben dem Einstellungsfeld für die Eigenschaft, um den Feldverknüpfungs-Assistenten für Unterformulare/-berichte zu öffnen.

  4. Wechseln Sie zur Formularansicht, um die Verknüpfung zu testen.

Anmerkungen

  • Die Verknüpfungsfelder müssen nicht unbedingt im Hauptformular oder im Unterformular angezeigt werden, Sie müssen jedoch in der zugrunde liegenden Datenherkunft enthalten sein. Wenn Sie zum Erstellen des Unterformulars den Formular-Assistenten verwenden, verknüpft Microsoft Access die Verknüpfungsfelder in der zugrunde liegenden Tabelle automatisch auch dann, wenn Sie diese nicht im Assistenten ausgewählt haben.

  • Die Verknüpfungsfelder müssen Daten desselben oder eines kompatiblen Datentyps und mit einer kompatiblen Feldgröße enthalten. Beispielsweise ist ein Feld vom Datentyp AutoWert, bei dem die Eigenschaft Feldgröße auf Long Integer festgelegt wurde, nur kompatibel mit einem Feld vom Datentyp Zahl, bei dem die Eigenschaft Feldgröße ebenfalls auf Long Integer festgelegt wurde.

  • Achten Sie darauf, dass für die Eigenschaft Verknüpfen von der Name eines Feldes festgelegt ist (wie in der Eigenschaft Steuerelementinhalt angegeben), nicht der Name eines Steuerelements (wie in der Eigenschaft Name angegeben). Die Eigenschaft Verknüpfen nach kann auf den Namen eines Feldes oder eines Steuerelements eingestellt sein.

  • Zum Anzeigen von Informationen zur Problembehandlung in Unterformularen klicken Sie auf [image] .


 Festlegen der Ansicht für ein Unterformular

Festlegen der Ansicht für ein Unterformular

Wenn Sie zum Erstellen eines Unterformulars den Formular-Assistenten oder den Unterformular-Assistenten verwendet haben, stellt Microsoft Access die Eigenschaft Standardansicht des Unterformulars entsprechend der Auswahl ein, die Sie in den Dialogfeldern des Assistenten treffen. Verwenden Sie die nachstehend beschriebenen Schritte, wenn Sie ein Unterformular manuell erstellen, oder wenn Sie die im Assistenten festgelegte Ansicht ändern möchten.

  1. Öffnen Sie das Hauptformular in der Entwurfsansicht. Das Unterformular wird in der Entwurfsansicht im Unterformular-Steuerelement angezeigt.

  2. Stellen Sie sicher, dass das Unterformular-Steuerelement markiert ist. Nachdem es markiert ist, können Sie erneut auf das Steuerelement klicken, um die Eigenschaften des Formulars einzustellen. Dabei verfahren Sie genauso, als würden Sie das Unterformular aus der Entwurfsansicht des Datenbankfensters öffnen.

  3. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Unterformulars zu öffnen.

  4. Klicken Sie im Einstellungsfeld für die Eigenschaft Standardansicht auf Einzelnes Formular, Endlosformular oder Datenblatt.

  5. Klicken Sie im Einstellungsfeld für die Eigenschaft ZugelasseneAnsicht(en) auf Formular, wenn Sie die Möglichkeit zum Wechseln zur Datenblattansicht nicht zulassen möchten. Klicken Sie auf Datenblatt, wenn Sie die Möglichkeit zum Wechseln zur Formularansicht nicht zulassen möchten. Wenn Sie zwischen beiden Ansichten beliebig hin- und herwechseln möchten, klicken Sie auf Beide.

Anmerkungen

  • Um Beispiele zu unterschiedlichen Unterformulartypen anzuzeigen, klicken Sie auf [image] .

  • Sie können zum Ändern der Standardansicht das Unterformular auch direkt aus dem Datenbankfenster heraus öffnen.


 Wechseln zwischen einem Hauptformular und einem Unterformular in der Formularansicht

Wechseln zwischen einem Hauptformular und einem Unterformular in der Formularansicht

Verwenden von TAB

  • Zum Wechseln vom letzten Feld im Hauptformular zum ersten Feld im Unterformular drücken Sie TAB.

  • Zum Wechseln vom ersten Feld im Unterformular zurück zum letzten Feld im Hauptformular drücken Sie STRG+UMSCHALT+TAB.

  • Zum Wechseln vom letzten Feld im Unterformular zum nächsten Feld im Hauptformular oder zum ersten Feld im nächsten Datensatz oder der nächsten Seite des Hauptformulars drücken Sie STRG+TAB. Falls die Zyklus-Eigenschaft des Formulars auf Aktueller Datensatz oder Aktuelle Seite eingestellt ist, müssen Sie die Navigationsschaltflächen oder andere eventuell in dem Formular vorgesehene Methoden verwenden, um zum nächsten Datensatz zu wechseln.

Verwenden der Maus

  • Zum Wechseln vom Hauptformular zum Unterformular klicken Sie auf eine beliebige Stelle des Unterformulars.

  • Zum Wechseln vom Unterformular zurück zum Hauptformular klicken Sie auf ein Steuerelement im Hauptformular (nicht auf den Hintergrund des Hauptformulars).


 Wechseln zwischen der Datenblattansicht und der Formularansicht in einem Unterformular

Wechseln zwischen der Datenblattansicht und der Formularansicht in einem Unterformular

  1. Öffnen Sie das Hauptformular in der Formularansicht.

  2. Klicken Sie auf eine beliebige Stelle des Unterformulars.

  3. Klicken Sie im Menü Ansicht auf Unterformulardatenblatt.

Anmerkung Sie können nur dann zwischen den Ansichten wechseln, wenn für die Eigenschaft ZugelasseneAnsicht(en) die Einstellung Beide festgelegt ist.


 Erstellen eines Datenblattunterformulars, das Kopfzeilen und Fußzeilen enthält

Erstellen eines Datenblattunterformulars, das Kopfzeilen und Fußzeilen enthält

Sie können bei einem Unterformular einen Formularkopf und -fuß sowie die Textfelder und anderen Steuerelemente so anordnen, dass das Unterformular beim Öffnen in der Formularansicht wie ein Datenblatt aussieht.

  1. Öffnen Sie das Formular, das Sie als Unterformular in der Entwurfsansicht verwenden möchten.

  2. Fügen Sie einen Formularkopf und -fuß hinzu, wenn dies nicht bereits geschehen ist. (Klicken Sie im Menü Ansicht auf Formularkopf/-fuß.)

  3. Ordnen Sie im Detailbereich die Textfelder und anderen Steuerelemente an, die Daten in einer einzelnen Zeile anzeigen.

  4. Ordnen Sie im Formularkopf die Bezeichnungsfelder für die Textfelder und anderen Steuerelemente an. Achten Sie darauf, die Bezeichnungsfelder im Formularkopf mit den zugehörigen Steuerelementen im Detailbereich auszurichten.

  5. Wenn Sie die Datensätze im Unterformular summieren wollen, erstellen Sie im Formularfuß berechnete Steuerelemente.

  6. Gestalten Sie jeden Bereich in der passenden Größe. Stellen Sie beispielsweise die Größe des Detailbereichs auf die Größe einer Zeile in einem Datenblatt ein. Falls keine Steuerelemente im Formularfuß vorgesehen sind, setzen Sie die Höhe-Eigenschaft auf 0 oder die Sichtbar-Eigenschaft auf Nein.

  7. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster für das Formular zu öffnen.

  8. Klicken Sie im Einstellungsfeld für die Standardansicht-Eigenschaft auf Endlosformular. Bei dieser Einstellung werden die Datensätze hintereinander in einem Formular angezeigt, ähnlich wie bei einem Datenblatt.

Anmerkungen

  • Wenn Sie für die Standardansicht die Einstellung Datenblatt wählen, blendet Microsoft Access die Kopf- und Fußzeile aus, wenn Sie das Formular in der Formularansicht anzeigen.

  • Das Formular Quartalsbestellungen in der Beispieldatenbank Nordwind enthält ein Endlos-Unterformular, das einen Formularkopf und -fuß besitzt und wie ein Datenblatt aussieht. Um dieses Formular anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL des Office-Ordners, und öffnen Sie dann das Formular Quartalsbestellungen in der Entwurfsansicht. Um Informationen zum Öffnen der Nordwind-Datenbank anzuzeigen, klicken Sie auf [image] .


 Erstellen eines berechneten Steuerelements in einem Formular oder Bericht

Erstellen eines berechneten Steuerelements in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool für den Steuerelementtyp, den Sie als berechnetes Steuerelement verwenden möchten.

    Anmerkung In der Regel wird zum Anzeigen eines berechneten Wertes ein Textfeld verwendet. Sie können jedoch jedes beliebige Steuerelement verwenden, für das Sie die Eigenschaft Steuerelementinhalt einstellen können.

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Steuerelement einfügen möchten.

  4. Führen Sie einen der folgenden Schritte aus:
    • Wenn es sich bei dem Steuerelement um ein Textfeld handelt, können Sie den Ausdruck direkt in das Textfeld eingeben.

    Ausdruck in einem Textfeld

    • Vergewissern Sie sich bei jedem Steuerelement, dass es markiert ist, klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen, und geben Sie dann den Ausdruck im Einstellungsfeld der Eigenschaft Steuerelementinhalt ein. Um den Ausdrucks-Generator zum Erstellen des Ausrudcks in einer Microsoft Access-Datenbank (.mdb) zu verwenden, klicken Sie auf die Generator-Schaltfläche [image] neben dem Feld der Steuerelementinhalt-Eigenschaft.

Anmerkungen

  • Geben Sie in einem berechneten Steuerelement vor jedem Ausdruck den Operator = ein.

  • Wenn Sie zum Eingeben eines Ausdrucks im Einstellungsfeld der Eigenschaft Steuerelementinhalt mehr Platz benötigen, drücken Sie UMSCHALT+F2, um das Dialogfeld Zoom zu öffnen.

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .

  • Wenn ein Formular auf einer Abfrage basiert, können Sie den Ausdruck auch statt in ein berechnetes Steuerelement direkt in die Abfrage eingeben. Zum Anzeigen von Informationen über das Erstellen eines berechneten Feldes in einer Abfrage einer Microsoft Access-Datenbank (,mdb) klicken Sie auf [image] . Zum Anzeigen von Informationen über das Erstellen eines berechneten Feldes in einer Abfrage in einem Microsoft Access-Projekt (.adp) klicken Sie auf


 Berechnen einer Funktion für einen Datensatz in einem Formular

Berechnen einer Funktion für einen Datensatz in einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool Textfeld Textfeld-Steuerelement .

  3. Klicken Sie im Detailbereich des Formulars auf die Stelle, an der Sie das Textfeld einfügen möchten.

  4. Führen Sie einen der folgenden Schritte aus:
    • Setzen Sie die Einfügemarke in das Textfeld, und geben Sie einen Ausdruck zum Berechnen einer Funktion ein. Zum Anzeigen von Beispielen für Ausdrücke zum Berechnen von Werten für einen Datensatz klicken Sie auf [image] .

    • Vergewissern Sie sich, dass das Textfeld markiert ist, klicken Sie in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen, und geben Sie den Ausdruck im Einstellungsfeld der Eigenschaft Steuerelementinhalt ein. Wenn Sie in einer Microsoft Access Datebank (.mdb) zum Erstellen des Ausdrucks den Ausdrucks-Generator verwenden möchten, klicken Sie neben dem Einstellungsfeld der Eigenschaft Steuerelementinhalt auf die Generator-Schaltfläche

Anmerkungen

  • Wenn Sie zum Eingeben eines Ausdrucks im Einstellungsfeld der Eigenschaft Steuerelementinhalt mehr Platz benötigen, drücken Sie UMSCHALT+F2, um das Dialogfeld Zoom zu öffnen.

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .

  • Wenn ein Formular auf einer Abfrage basiert, können Sie den Ausdruck auch statt in ein berechnetes Steuerelement direkt in die Abfrage eingeben. Zum Anzeigen von Informationen über das Erstellen eines berechneten Feldes in einer Abfrage einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] . Zum Anzeigen von Informationen über das Erstellen eines berechneten Feldes in einer Abfrage in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .


 Berechnen einer Funktion in einem Unterformular und Anzeigen dieser Funktion in einem Formular

Berechnen einer Funktion in einem Unterformular und Anzeigen dieser Funktion in einem Formular

Sie können zum Berechnen einer Funktion für eine Gruppe von Datensätzen ein Formular mit einem Unterformular verwenden. Das Hauptformular und das Unterformular basieren auf Tabellen mit einer 1:n-Beziehung. Das Hauptformular zeigt die Datensätze auf der "1"-Seite der Beziehung, das Unterformular die Datensätze auf der "n"-Seite der Beziehung an. Die nachstehende Abbildung zeigt z.B. ein Formular Bestellungen mit einem Unterformular.

Haupt- und Unterformular in der Formularansicht

Zum Berechnen einer Zwischensumme über die Bestellungen fügen Sie dem Fußbereich des Unterformulars ein Textfeld hinzu und geben im Einstellungsfeld der Eigenschaft Steuerelementinhalt des Textfelds einen Ausdruck ein, der die Funktion Summe verwendet. Der nachstehende Ausdruck berechnet z.B. die Gesamtsumme für alle Artikel im Formular Bestellungen:

=Summe([Anzahl]*[Einzelpreis])

In der Entwurfsansicht des Unterformulars befindet sich das berechnete Steuerelement im Formularfuß

Zum Anzeigen der Zwischensumme über die Bestellungen im Hauptformular erstellen Sie einen Ausdruck, der auf das Steuerelement im Unterformular verweist, das das berechnete Steuerelement enthält. Sie könnten z.B. den folgenden Ausdruck im Einstellungsfeld der Eigenschaft Steuerelementinhalt des Textfelds im Hauptformular angeben:

Ausdruck des Hauptformulars, der das berechnete Steuerelement im Unterformular referenziert

Anmerkungen

  • Wenn Sie zum Berechnen einer Funktion den Wert aus einem berechneten Steuerelement verwenden möchten, können Sie in der Funktion Summe nicht den Namen des Steuerelements angeben. Angenommen, Sie haben ein Steuerelement, das die Anzahl mit dem Einzelpreis multipliziert hat. In diesem Fall müssen Sie den Ausdruck trotzdem vollständig in der Syntax =Summe([Anzahl]*[Einzelpreis]) angeben. Wenn Sie daher einen Ausdruck verwenden, der eine Aggregatfunktion, wie z.B. Summe, benötigt, definieren Sie den Ausdruck am besten in der dem Formular zugrunde liegenden Abfrage oder SQL-Anweisung. Anschließend können Sie in der Funktion Summe den Namen des berechneten Feldes verwenden. So können beispielsweise in einer zugrunde liegenden Abfrage ein berechnetes Feld, z.B. Endpreis: [Anzahl]*[Einzelpreis], verwenden und den Feldnamen dann in dem Ausdruck angeben, der die Summe =Summe([Endpreis]) berechnet. Zum Anzeigen von Informationen zum Erstellen eines berechneten Feldes in einer Abfrage einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] . Zum Anzeigen von Informationen über das Erstellen eines berechneten Feldes in einer Abfrage in einem Microsoft Access-Projekt (.adp), klicken Sie auf [image] .

  • Das Formular Bestellungen in der Beispieldatenbank Nordwind enthält ein Beispiel eines Unterformulars zum Berechnen einer Zwischensumme, die im Hauptformular angezeigt wird. Zum Anzeigen dieses Formulars öffnen Sie die Datenbank NWIND.MDB im Unterordner Beispiele des Office-Ordners und öffnen dann das Formular Bestellungen in der Entwurfsansicht. Zum Anzeigen von Informationen über das Öffnen der Datenbank Nordwind klicken Sie auf [image] .


Überprüfen der Gültigkeit von Daten oder Einschränken der Verwendung von Daten in Formularen

Durch das Überprüfen der Gültigkeit von Daten oder das Einschränken der Verwendung von Daten können Sie dem Benutzer direkt Rückmeldung zu den gerade eingegebenen Daten geben und sicherstellen, dass die korrekten Informationen in ein Textfeld oder ein anderes Steuerelement in einem Formular eingegeben werden.

Was möchten Sie tun?

Ein Eingabeformat für ein Steuerelement erstellen

Ein Steuerelement deaktivieren oder sperren

Eine Gültigkeitsregel für ein Steuerelement erstellen

Weitere Informationen zu der Reihenfolge anzeigen, in der unterschiedliche Arten von Gültigkeitsprüfungen erfolgen

Weitere Informationen zu komplexen Gültigkeitsprüfungen anzeigen, die Sie mit Makros oder Ereignisprozeduren vornehmen können


 Deaktivieren der Formularansicht oder der Datenblattansicht für ein Formular

Deaktivieren der Formularansicht oder der Datenblattansicht für ein Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft ZugelasseneAnsicht(en) auf Formular, wenn Sie die Datenblattansicht deaktivieren möchten, oder auf Datenblatt, wenn Sie die Formularansicht deaktivieren möchten.

Anmerkung Sie können diese Eigenschaft auch zusammen mit der Eigenschaft Standardansicht einstellen, wenn Sie festlegen möchten, wie ein Benutzer ein Formular sieht und ob es auf unterschiedliche Arten angezeigt werden kann. Zum Anzeigen unterschiedlicher Kombinationen für die Einstellung dieser Eigenschaften klicken Sie auf [image] .


 Versehen eines Formulars mit Schreibschutz

Versehen eines Formulars mit Schreibschutz

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft BearbeitungenZulassen auf Nein.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft AnfügenZulassen auf Nein.

  5. Klicken Sie im Einstellungsfeld der Eigenschaft LöschenZulassen auf Nein.


 Festlegen, ob ein Benutzer in einem Formular einen Datensatz hinzufügen oder löschen darf

Festlegen, ob ein Benutzer in einem Formular einen Datensatz hinzufügen oder löschen darf

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft LöschenZulassen und/oder im Einstellungsfeld der Eigenschaft AnfügenZulassen auf Ja oder Nein.


 Festlegen, ob ein Benutzer in einem Formular gespeicherte Datensätze bearbeiten darf

Festlegen, ob ein Benutzer in einem Formular gespeicherte Datensätze bearbeiten darf

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft BearbeitungenZulassen auf Ja oder Nein.


Erstellen eines Popupformulars oder benutzerdefinierten Dialogfelds

Was möchten Sie tun?

Ein nicht gebundenes Popupformular erstellen

Ein benutzerdefiniertes Dialogfeld erstellen

Ein beliebiges Formular temporär als Dialogfeld öffnen

Informationen zu Eigenschaften erhalten, die Sie beim Anpassen eines Popupformulars oder eines benutzerdefinierten Dialogfelds verwenden können

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Eigenschaften zum Erstellen oder Anpassen von Popupformularen und benutzerdefinierten Dialogfeldern

Eigenschaften zum Erstellen oder Anpassen von Popupformularen und benutzerdefinierten Dialogfeldern

Die folgende Tabelle enthält Eigenschaften, die Sie beim Erstellen oder Anpassen von Popupformularen und benutzerdefinierten Dialogfeldern verwenden können. Um weitere Informationen zu einer dieser Eigenschaften zu erhalten, klicken Sie im Eigenschaftenfenster auf die entsprechende Eigenschaft, und drücken Sie dann F1.

Eigenschaft | Zweck
PopUp | Gibt an, ob ein Formular als Popupformular geöffnet wird. Ein Popupformular wird stets im Vordergrund angezeigt.
Gebunden | Gibt an, ob ein Formular als nicht gebundenes Formular (das Wechseln zu anderen Fenstern ist möglich) oder als gebundenes Formular (das Formular behält den Fokus bis zum Schließen) geöffnet wird.
Rahmenart | Gibt die für das Formular zu verwendende Rahmenart sowie die Rahmenelemente an (Titelleiste, Schaltfläche Schließen [image] , Systemmenü, Maximieren- und Minimieren-Schaltflächen). Bestimmt außerdem, ob ein Formular in der Größe veränderbar ist.
MitSystemmenüfeld | Gibt an, ob ein Formular in der Formularansicht ein Systemmenü enthält.
MinMaxSchaltflächen | Gibt an, ob ein Formular in der Formularansicht eine Maximieren- und Minimieren-Schaltfläche besitzt. Wenn Sie die Eigenschaft Rahmenart auf Dialog einstellen, entfernt Microsoft Access diese Schaltflächen automatisch.
SchließenSchaltfläche | Gibt an, ob die Schaltfläche Schließen deaktiviert ist.
Bildlaufleisten | Gibt an, ob ein Formular Bildlaufleisten enthält.
Navigationsschaltflächen | Gibt an, ob ein Formular Navigationsschaltflächen enthält.
Datensatzmarkierer | Gibt an, ob ein Formular Datensatzmarkierer enthält.
Kontextmenü | Gibt an, ob ein Kontextmenü angezeigt wird, wenn Sie mit der rechten Maustaste auf ein Formular klicken.
AutomatischZentrieren | Gibt an, ob ein Formular beim Öffnen automatisch im Anwendungsfenster zentriert wird.
BearbeitungenZulassen | Gibt an, ob ein/e Benutzer/in an gespeicherten Datensätzen in einem Formular beliebige Bearbeitungsvorgänge vornehmen kann.
LöschenZulassen | Gibt an, ob ein/e Benutzer/in mit Hilfe eines Formulars Datensätze löschen kann.
AnfügenZulassen | Gibt an, ob ein/e Benutzer/in mit Hilfe eines Formulars Datensätze hinzufügen kann.
DatenEingeben | Gibt an, ob ein Formular beim Öffnen alle vorhandenen Datensätze oder einen leeren (neuen) Datensatz anzeigt.
Standardansicht | Gibt an, ob ein Formular in der Datenblattansicht, als Einzelformular (ein Datensatz) oder als Endlosformular (mehrere Datensätze) angezeigt wird.
ZugelasseneAnsicht(en) | Gibt an, ob Sie zwischen der Formularansicht und der Datenblattansicht wechseln können.


 Verwenden eines Formulars zum Eingeben von Berichtskriterien

Verwenden eines Formulars zum Eingeben von Berichtskriterien

Erstellen eines ungebundenen Formulars, das zur Eingabe von Berichtskriterien auffordert

  1. Erstellen Sie ein ungebundenes Formular.

  2. Stellen Sie in der Entwurfsansicht die folgenden Formulareigenschaften ein.
    Eigenschaft | Einstellung
    Beschriftung | Name, der in der Titelleiste des Formulars angezeigt werden soll
    Standardansicht | Einzelnes Formular
    ZugelasseneAnsicht(en) | Formular
    Bildlaufleisten | Nein
    Datensatzmarkierer | Nein
    Navigationsschaltflächen | Nein
    Rahmenart | Dialog
  3. Fügen Sie für jedes Kriterium, das Sie eingeben möchten, ein ungebundenes Textfeld hinzu.

  4. Stellen Sie die Eigenschaften für die Textfelder wie folgt ein:
    Eigenschaft | Einstellung
    Name | Name, aus dem die Art des Kriteriums hervorgeht, z. B. Anfangsdatum
    Format | Format, das den Datentyp des Kriteriums angibt. Wählen Sie für ein Datumskriterium z. B. Datum, mittel.
  5. Speichern Sie das Formular. Geben Sie ihm dabei einen Namen (z. B. Dialog Verkauf).

    Fügen Sie dem Formular die Befehlsschaltflächen OK und Abbrechen hinzu, nachdem Sie dafür die folgenden Makros erstellt haben.

Erstellen der Makros für das Formular in einer Makrogruppe

  1. Klicken Sie im Datenbankfenster auf Makros [image] und klicken Sie dann in der Datenbankfenstersymbolleiste auf die Schaltfläche Neu.

    Im folgenden Verfahren werden Sie vier Makros in einer Makrogruppe erstellen.

  2. Erstellen Sie ein Makro, das das ungebundene Formular öffnet. Klicken Sie zunächst auf Makronamen [image] , um die Spalte Makroname anzuzeigen. Geben Sie in die Spalte Makroname einen Namen für Ihr Makro ein (z. B. Dialog öffnen), und klicken Sie auf die Aktion ÖffnenFormular. Stellen Sie dann die Aktionsargumente wie folgt ein:
    Argument | Einstellung
    Formularname | Name des ungebundenen Formulars (z. B. Dialog Verkauf)
    Ansicht | Formular
    Datenmodus | Bearbeiten
    Fenstermodus | Dialog

    Fügen Sie eine zweite Aktion (AbbrechenEreignis) hinzu, die die Seitenansicht oder das Drucken des Berichts abbricht, wenn im Formular auf die Schaltfläche Abbrechen geklickt wird. Klicken Sie dann auf Bedingungen [image] , um die Spalte Bedingung anzuzeigen, und geben Sie darin folgenden Ausdruck ein:

    Nicht IsLoaded("Dialog Verkauf")

    Die Funktion IsLoaded ist im Modul Dienstprogramme der Beispieldatenbank Nordwind definiert. Mit ihr wird überprüft, ob ein Formular in der Formular- oder in der Datenblattansicht geöffnet ist. Sie können diese Funktion erst verwenden, nachdem Sie sie in Ihrer Datenbank definiert haben. (Zu diesem Zweck können Sie sie kopieren und in ein Dienstprogrammmodul Ihrer Datenbank einfügen.) Um Informationen zum Definieren einer Funktion anzuzeigen, klicken Sie auf [image] . Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .

  3. Erstellen Sie ein Makro, das das Formular schließt. Geben Sie dem Makro einen Namen, z.B. Dialog schließen. Klicken Sie auf die Aktion Schließen. Stellen Sie dann die Aktionsargumente wie folgt ein:
    Argument | Einstellung
    Objekttyp | Formular
    Objektname | Name des ungebundenen Formulars
    Speichern | Nein
  4. Erstellen Sie ein Makro für die Schaltfläche OK. Dieses Makro blendet das Formular aus. Geben Sie dem Makro einen Namen, z.B. OK, und klicken Sie auf die Aktion SetzenWert. Stellen Sie dann die Aktionsargumente wie folgt ein:
    Argument | Einstellung
    Feld | [Sichtbar]
    Ausdruck | Nein
  5. Erstellen Sie ein Makro für die Schaltfläche Abbrechen. Dieses Makro schließt das Formular. Geben Sie dem Makro einen Namen, z.B. Abbrechen, und klicken Sie auf die Aktion Schließen. Stellen Sie dann die Aktionsargumente wie folgt ein:
    Argument | Einstellung
    Objekttyp | Formular
    Objektname | Name des ungebundenen Formulars
    Speichern | Nein
  6. Speichern und schließen Sie die Makrogruppe. Geben Sie der Makrogruppe einen Namen (z.B. den Namen, den Sie dem ungebundenen Formular gegeben haben: Dialog Verkauf).

Hinzufügen der Befehlsschaltflächen "OK" und "Abbrechen" zum Formular

  1. Öffnen Sie das ungebundene Formular erneut in der Entwurfsansicht.

  2. Erstellen Sie eine Befehlsschaltfläche OK, und stellen Sie deren Eigenschaften wie folgt ein. (Stellen Sie sicher, dass in der Toolbox das Tool Steuerelement-Assistenten [image] nicht gedrückt ist.)
    Eigenschaft | Einstellung
    Name | OK
    Beschriftung | OK
    BeiEingabetaste | Ja
    BeimKlicken | Name des Makros (z.B. Dialog Verkauf.OK)
  3. Erstellen Sie eine Befehlsschaltfläche Abbrechen, und stellen Sie deren Eigenschaften wie folgt ein.
    Eigenschaft | Einstellung
    Name | Abbrechen
    Beschriftung | Abbrechen
    BeimKlicken | Name des Makros (z.B. Dialog Verkauf.Abbrechen)
  4. Speichern und schließen Sie das Formular.

Eingeben der Kriterien in die dem Bericht zugrundeliegende Abfrage oder gespeicherte Prozedur

  1. Öffnen Sie für den Bericht die zugrunde liegende Abfrage oder die gespeicherte Prozedur in der Entwurfsansicht.

  2. Geben Sie die Kriterien für die Daten ein. Verwenden Sie im Ausdruck das Formulare-Objekt, den Namen des Formulars und die Namen der Steuerelemente in den Kriterien.
    • Für ein Formular mit dem Namen Dialog Verkauf verwenden Sie zum Beispiel in einer Microsoft Access-Datenbank (.mdb) den folgenden Ausdruck, um auf Steuerelemente mit der Bezeichnung Anfangsdatum und Enddatum in der Abfrage zu verweisen:

      Zwischen [Formulare]![Dialog Verkauf]![Anfangsdatum] und [Formulare]![Dialog Verkauf]![Enddatum]

    • In einem Microsoft Access-Projekt (.adp) müssen Sie zunächst explizit die Parameter in der gespeicherten Prozedur benennen; zum Beispiel:

      @Anfangsdatum datetime, @Enddatum datetime

      und dann diese Parameter in der WHERE-Klausel verwenden; zum Beispiel:

      WHERE Lieferungen.Lieferdatum Between @Anfangsdatum And @Enddatum

      Bei einem Microsoft Access-Projekt erstellen Sie einen Verweis zu den Steuerelementen im Formular in der Eingabeparameter-Eigenschaft im Bericht entsprechend der nächsten Prozedur.

Einstellen der Eingabeparameter-Eigenschaft im Hauptbericht (nur Microsoft Access-Projekte)

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Stellen Sie die Eingabeparameter-Eigenschaft des Berichts auf eine Zeichenfolge ein, die die Parameter angibt, die der gespeicherten Prozedur übergeben werden, an die der Bericht gebunden ist. Wie in dem folgenden Beispiel muss es sich bei der Zeichenfolge um einen Ausdruck handeln, der die Parameter einschließt, die Sie in der gespeicherten Prozedur und dem Verweis auf die Steuerelemente im Dialogfeld angegeben haben:

    @Anfangsdatum datetime = [Formulare]![Dialog Verkauf]![Anfangsdatum], @Enddatum datetime = [Formulare]![Dialog Verkauf]![Enddatum]

Einbinden der Makros in den Hauptbericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Stellen Sie die folgenden Berichtseigenschaften ein:
    Eigenschaft Einstellung
    BeimÖffnen Name des Makros, das das ungebundene Formular öffnet, z.B.
    Dialog Verkauf.Dialog öffnen
    BeimSchließen Name des Makros, das das ungebundene Formular schließt, z.B.
    Dialog Verkauf.Dialog schließen


Berichte: Definition und Funktionsweise

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


 Öffnen eines Berichts

Öffnen eines Berichts

  1. Klicken Sie im Datenbankfenster unter Objekte auf Berichte [image] .

  2. Klicken Sie auf den Bericht, den Sie öffnen möchten.

  3. Klicken Sie auf der Symbolleiste des Datenbankfensters auf die Schaltfläche Entwurf, um den Bericht in der Entwurfsansicht zu öffnen, oder auf die Schaltfläche Öffnen, um den Bericht in der Seitenansicht zu öffnen.

Tipp Sie können einen Bericht auch in der Seitenansicht öffnen, indem Sie ihn aus dem Datenbankfenster auf den Anwendungshintergrund ziehen.


Erstellen eines Berichts

Was möchten Sie tun?

Einen Bericht unter Verwendung von AutoBericht erstellen. Mit AutoBericht können Sie eine Datensatzquelle und entweder Spalten- oder Tabellenlayout auswählen; AutoBericht verwendet alle Felder aus der Datenquelle und wendet das zuletzt für den Bericht verwendete AutoFormat an.

Einen Bericht mit einem Assistenten erstellen. Der Assistent stellt detaillierte Fragen zu Datenquellen, Feldern, Layout und Format, die/das Sie wünschen, und erstellt auf der Basis Ihrer Antworten einen Bericht.

Einen Bericht ohne Assistenten erstellen


 Wechseln zwischen den Ansichten eines Berichts

Wechseln zwischen den Ansichten eines Berichts

Berichte können in drei Ansichten angezeigt werden: in der Entwurfsansicht, der Seitenansicht und der Layout-Vorschau. In der Entwurfsansicht können Sie einen Bericht erstellen oder die Struktur eines vorhandenen Berichts ändern. In der Seitenansicht sehen Sie die Daten des Berichts so, wie diese auf den einzelnen Seiten angezeigt werden. In der Layout-Vorschau können Sie sich das Layout des Berichts ansehen. Hier wird nur ein Beispielauszug aus den Daten des Berichts wiedergegeben.

  1. Öffnen Sie den Bericht in einer beliebigen Ansicht.

  2. Klicken Sie in der Symbolleiste auf die Ansichtsschaltfläche, um zu der durch die Grafik dargestellten Ansicht zu wechseln. Um eine Liste anderer wählbarer Ansichten anzuzeigen, klicken Sie auf den Pfeil neben der Schaltfläche.


Möglichkeiten zum Anpassen eines Berichts

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


Bereiche eines Berichts

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


 Formular- und Berichtsvorlagen

Formular- und Berichtsvorlagen

Wenn Sie ein Formular oder einen Bericht ohne Verwendung eines Assistenten erstellen, verwendet Microsoft Access eine Vorlage zum Festlegen der Standardeigenschaften des Formulars oder Berichts.

Die Vorlage bestimmt, welche Bereiche ein Formular oder Bericht haben wird, und legt die Abmessungen der Bereiche fest. Die Vorlage enthält darüber hinaus alle Standardeigenschafteneinstellungen für das Formular oder den Bericht und dessen Bereiche und Steuerelemente.

Die Standardvorlagen für Formulare und Berichte haben die Bezeichnung Normal. Sie können jedoch auch ein vorhandenes Formular oder einen vorhandenen Bericht als Vorlage verwenden oder ein Formular bzw. einen Bericht erstellen, das/der ausschließlich als Vorlage verwendet werden soll. Zum Anzeigen von Informationen zum Festlegen einer neuen Vorlage klicken Sie auf [image] .

Anmerkungen

  • Das Ändern einer Vorlage hat keinen Einfluss auf vorhandene Formulare oder Berichte.

  • Eine Vorlage erstellt keine Steuerelemente in einem neuen Formular oder Bericht.

  • Microsoft Access speichert die Einstellungen für die Optionen Formularvorlage und Berichtsvorlage in der Arbeitsgruppen-Informationsdatei und nicht in Ihrer Microsoft Access-Datenbank (der .MDB-Datei) oder Ihrem Microsoft Access-Projekt (der .ADP-Datei). Wenn Sie eine Optionseinstellung ändern, hat diese Änderung für alle Datenbanken oder Access-Projekte Gültigkeit, die Sie öffnen oder erstellen. Um den Namen der Vorlage anzuzeigen, die gerade für neue Formulare oder Berichte verwendet wird, klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Formulare/Berichte.

  • Wenn Sie Ihre Vorlagen in anderen Datenbanken oder Access-Projekten verwenden möchten, kopieren oder exportieren Sie diese dorthin. Wenn Ihre Vorlagen nicht in einer Datenbank oder einem Access-Projekt enthalten sind, verwendet Microsoft Access für alle Formulare und Berichte, die Sie neu erstellen, die Vorlage Normal. Die Namen Ihrer Vorlagen werden in jedem Fall für jede Datenbank oder jedes Access-Projekt in den Feldern Formularvorlage bzw. Berichtsvorlage angezeigt, auch wenn diese Vorlagen nicht in jeder Datenbank oder jedem Access-Projekt enthalten sind.


Festlegen einer neuen Vorlage für Formulare und Berichte

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Formulare/Berichte.

  3. Geben Sie im Feld Formularvorlage oder im Feld Berichtsvorlage den Namen der neuen Vorlage ein.

    Anmerkung Sie können ein vorhandenes Formular oder einen vorhandenen Bericht als Vorlage verwenden oder ein Formular oder einen Bericht zur Verwendung als Vorlage erstellen.

  4. Klicken Sie auf OK.

    Zum Anzeigen weiterer Informationen zu Vorlagen klicken Sie auf [image] .


Festlegen von Rändern, Seitenausrichtung und anderen Optionen zum Einrichten einer Seite

Was möchten Sie tun?

Seiteneinrichtungsoptionen für eine Tabelle, eine Abfrage, ein Formular oder einen Bericht festlegen

Seiteneinrichtungsoptionen für eine Datenzugriffsseite festlegen


Anzeigen eines Berichts in der Seitenansicht

Die Seitenansicht eines Berichts zeigt Ihnen, wie dieser gedruckt aussehen wird. Sie können entweder nur einen Blick auf das Layout des Berichts mit einigen Beispieldaten werfen oder aber sämtliche Berichtsdaten überprüfen und dazu den Bericht seitenweise durchsehen.

Was möchten Sie tun?

Nur das Layout des Berichts ansehen

Sämtliche Berichtsdaten seitenweise ansehen


 Drucken eines Berichts

Drucken eines Berichts

Vor dem ersten Drucken eines Berichts möchten Sie vielleicht die Ränder, die Seitenausrichtung und andere Druckereinrichtungsoptionen überprüfen. Zum Anzeigen von Informationen klicken Sie auf [image] .

  1. Wählen Sie den Bericht im Datenbankfenster aus, oder öffnen Sie ihn in der Entwurfsansicht, in der Seitenansicht oder in der Layout-Vorschau.

  2. Klicken Sie im Menü Datei auf Drucken.

  3. Geben Sie im Dialogfeld Drucken die gewünschten Einstellungen ein.
    • Wählen Sie unter Drucker einen Drucker aus.

    • Geben Sie unter Druckbereich entweder alle Seiten oder einen Seitenbereich an.

    • Geben Sie unter Exemplare die gewünschte Anzahl von Exemplaren an, und legen Sie fest, ob diese sortiert werden sollen oder nicht.
  4. Klicken Sie auf OK.

Tipp Um einen Bericht sofort zu drucken, ohne das Dialogfeld anzuzeigen, klicken Sie in der Symbolleiste auf Drucken [image] .


 Anzeigen einer Tabelle, eines Formulars oder eines Berichts in der Seitenansicht bei verschiedenen Zoom-Stufen

Anzeigen einer Tabelle, eines Formulars oder eines Berichts in der Seitenansicht bei verschiedenen Zoom-Stufen

  • Klicken Sie in der Symbolleiste Seitenansicht auf den Pfeil neben Zoom und dann auf die gewünschte Zoom-Stufe, oder geben Sie den gewünschten Prozentsatz ein.

Anmerkungen

  • Wenn Sie Passend wählen, passt Microsoft Access die Zoom-Stufe so an, dass die Seite bestmöglich in das Fenster passt.

  • Sie können von der ausgewählten Zoom-Stufe zu Passend zurückwechseln. Setzen Sie hierzu den Zeiger auf die Tabelle, das Formular oder den Bericht, und klicken Sie, sobald der Zeiger die Form einer Lupe annimmt.

  • Sie können mit Hilfe der Navigationsschaltflächen am unteren Rand des Seitenansichtsfensters zu einer anderen Seite gelangen. Auf der aktuellen Seite können Sie sich mit Hilfe der Bildlaufleisten oder, wenn Sie über eine Microsoft IntelliMouse verfügen, mit der Radtaste bewegen.


 Anzeigen mehrerer Seiten in der Seitenansicht

Anzeigen mehrerer Seiten in der Seitenansicht

So zeigen Sie zwei Seiten gleichzeitig an

  1. Öffnen Sie die Tabelle, die Abfrage, das Formular, den Bericht oder das Modul in der Seitenansicht.

  2. Klicken Sie in der Symbolleiste auf Zwei Seiten [image] .

So zeigen Sie mehr als zwei Seiten gleichzeitig an

  1. Öffnen Sie die Tabelle, die Abfrage, das Formular, den Bericht oder das Modul in der Seitenansicht.

  2. Klicken Sie in der Symbolleiste auf Mehrere Seiten [image] .

  3. Ziehen Sie die Maus, um die Anzahl der anzuzeigenden Seiten zu markieren.

So kehren Sie zur Einzelseitenanzeige zurück

  1. Öffnen Sie die Tabelle, die Abfrage, das Formular, den Bericht oder das Modul in der Seitenansicht.

  2. Klicken Sie in der Symbolleiste auf Eine Seite [image] .

Anmerkung Sie können mit Hilfe der Navigationsschaltflächen am unteren Rand des Seitenansichtsfensters zu einer anderen Seite gelangen. Auf der aktuellen Seite können Sie sich mit Hilfe der Bildlaufleisten oder, wenn Sie über eine Microsoft IntelliMouse verfügen, mit der Radtaste bewegen.


 Drucken jedes Datensatzes, jeder Gruppe oder jedes Bereichs eines Formulars oder Berichts auf einer separaten Seite

Drucken jedes Datensatzes, jeder Gruppe oder jedes Bereichs eines Formulars oder Berichts auf einer separaten Seite

  1. Öffnen Sie das Formular in der Entwurfsansicht, oder öffnen Sie den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Bereichsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Legen Sie für die Eigenschaft NeueSeite des Bereichs eine der folgenden Einstellungen fest:
    • Keine: (Standardeinstellung) Druckt den Bereich auf der aktuellen Seite.

    • VorBereich: Druckt den aktuellen Bereich beginnend am oberen Rand einer neuen Seite.

    • Nach Bereich: Druckt den nachfolgenden Bereich beginnend am oberen Rand einer neuen Seite.

    • Vor & Nach: Druckt den aktuellen Bereich und den nachfolgenden Bereich jeweils beginnend am oberen Rand einer neuen Seite.

Anmerkungen

  • Die Eigenschaft NeueSeite kann für alle Bereiche, ausgenommen jedoch Seitenköpfe und -füße, gesetzt werden.

  • Wenn Sie jeden Datensatz auf einer separaten Seite drucken möchten, müssen Sie für die Eigenschaft NeueSeite des Detailbereichs die Einstellung Nach Bereich setzen. Wenn Sie jede Gruppe auf einer separaten Seite drucken möchten, müssen Sie für die Eigenschaft NeueSeite für den Gruppenkopf die Einstellung Vor Bereich oder für den Gruppenfuß die Einstellung Nach Bereich setzen.


 Formatieren eines Formulars, Berichts oder Steuerelements unter Verwendung vordefinierter Formate

Formatieren eines Formulars, Berichts oder Steuerelements unter Verwendung vordefinierter Formate

  1. Öffnen Sie ein Formular in der Formularentwurfsansicht oder einen Bericht in der Berichtsentwurfsansicht.

  2. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie auf den Formularmarkierer oder den Berichtsmarkierer, wenn Sie das gesamte Formular bzw. den gesamten Bericht formatieren möchten.

    • Klicken Sie auf den Bereichsmarkierer, wenn Sie einen einzelnen Bereich formatieren möchten.

    • Markieren Sie das/die Steuerelement(e), das/die Sie formatieren möchten.
  3. Klicken Sie in der Symbolleiste auf AutoFormat [image] .

  4. Klicken Sie auf eines der Formate in der Liste.

  5. Klicken Sie auf Optionen, wenn Sie Attribute zuweisen möchten (z.B. Schriftart, Farbe oder Rahmen).

Anmerkung Zum Zuweisen eines Hintergrundbilds müssen Sie das gesamte Formular oder den gesamten Bericht markieren.


 Anpassen eines AutoFormats für ein Formular oder einen Bericht

Anpassen eines AutoFormats für ein Formular oder einen Bericht

  1. Öffnen Sie ein vorhandenes Formular in der Entwurfsansicht oder einen vorhandenen Bericht in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf AutoFormat.

  3. Klicken Sie im Dialogfeld AutoFormat auf ein AutoFormat in der Liste.

  4. Klicken Sie auf die Schaltfläche Optionen, und stellen Sie sicher, dass die Attribute, die Sie ändern möchten, ausgewählt sind.

  5. Klicken Sie auf die Schaltfläche Anpassen und dann auf eine Anpassungsoption. Sie können folgende Aufgaben durchführen:
    • Erstellen eines neuen AutoFormats auf Basis des geöffneten Formulars bzw. Berichts.

    • Aktualisierung des AutoFormats auf Basis des geöffneten Formulars bzw. Berichts.

    • Löschen des AutoFormats aus der Liste.
  6. Klicken Sie zweimal auf OK, um alle Dialogfelder zu schließen.


 Hinzufügen eines Hintergrundbildes zu einem Bericht

Hinzufügen eines Hintergrundbildes zu einem Bericht

Indem Sie einem Bericht ein Hintergrundbild hinzufügen, können Sie ein Wasserzeichen simulieren. Hintergrundbilder in Berichten werden auf die gesamte Seite angewendet.

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Stellen Sie die Bild-Eigenschaft auf das Dateiformat .bmp, .ico, .wmf, .dib oder .emf ein. Wenn Sie Grafikfilter für andere Anwendungen installiert haben, können Sie alle Dateien verwenden, die diese Filter unterstützen. Falls Sie den Pfad oder den Dateinamen nicht genau wissen, klicken Sie auf die Generator-Schaltfläche [image] .

  4. Geben Sie im Eigenschaftenfeld Bildtyp an, ob das Bild eingebettet oder verknüpft werden soll. Eingebettete Bilder werden in der Datenbankdatei gespeichert. Falls Sie das gleiche Bild in ein anderes Formular oder einen anderen Bericht einbetten, wird es erneut der Datenbank hinzugefügt. Verknüpfte Bilder werden nicht in der Datenbankdatei gespeichert, jedoch muss eine Kopie jedes Bildes auf der Festplatte gespeichert sein. Um Ihren Speicherplatz möglichst effizient zu nutzen, wählen Sie die Einstellung Verknüpft.

  5. Sie können mit den Einstellungen der Eigenschaft Bildgrößenmodus die Proportionen des Bildes bestimmen. Für diese Eigenschaft gibt es drei Einstellungsmöglichkeiten:
    • Abschneiden. Zeigt das Bild in der Originalgröße an. Falls das Bild größer als der Bereich innerhalb der Ränder ist, wird das Bild beschnitten.

    • Dehnen. Passt das Bild an die Größe des Bereichs innerhalb der Ränder an. Bei dieser Einstellung wird das Bild eventuell verzerrt dargestellt.

    • Zoomen. Passt das Bild so an, dass der Bereich innerhalb der Ränder entweder in der Höhe oder in der Breite ausgefüllt wird. Bei dieser Einstellung wird das Bild weder beschnitten noch proportional verzerrt dargestellt.
  6. Sie können mit den Einstellungen der Eigenschaft Bildausrichtung die Position des Bildes auf der Seite bestimmen. Microsoft Access richtet das Bild innerhalb der Ränder des Berichts aus. Die verfügbaren Einstellungen sind Links oben, Rechts oben, Mitte, Links unten und Rechts unten.

  7. Sie können das Bild auf der Seite mehrmals anzeigen, indem Sie die Eigenschaft Bild nebeneinander auf Ja festlegen. Die mehrfach angeordneten Bilder beginnen an der Position, die in der Eigenschaft Bildausrichtung festgelegt wurde.

    Anmerkung Mehrfach angeordnete Hintergrundbilder sehen am besten aus, wenn die Eigenschaft Bildgrößenmodus auf Abschneiden festgelegt wird.

  8. Mit der Eigenschaft Bildseiten können Sie festlegen, auf welchen Seiten des Berichts das Bild erscheinen soll. Die verfügbaren Einstellungen sind Alle Seiten, Erste Seite und Keine Seiten.

Anmerkungen

  • Falls die Farben des Hintergrundbilds nicht den Originalfarben entsprechen, können Sie festlegen, dass Microsoft Access die Farben der Anwendung verwendet, mit der Sie die Grafik erstellt haben.

  • Wie wird's gemacht?

  • Wenn Sie eigene Hintergrundbilder erstellen und Zugriff auf ein Grafikprogramm haben, das Metadateien erzeugt, können Sie als Hintergrund ein Metadateibild statt einem Bitmapbild verwenden. Weitere Information hierzu erhalten Sie, indem Sie auf [image] klicken.

  • In dem Bericht Personalumsätze nach Land in der Beispieldatenbank Nordwind ist ein Musterhintergrundbild enthalten. Um diesen Bericht anzuzeigen, öffnen Sie im Ordner BEISPIEL des Office-Ordners die Datenbank Nordwind, und öffnen Sie dann den Bericht Personalumsätze nach Land in der Entwurfsansicht. Um Information zum Öffnen von Nordwind anzuzeigen, klicken Sie auf [image] .


 Einfügen von Seitenwechseln in einen Bericht

Einfügen von Seitenwechseln in einen Bericht

In Berichten können Sie mit Hilfe eines Seitenwechsel-Steuerelements die Stelle markieren, an der eine neue Seite innerhalb eines Bereichs beginnen soll. Wenn zum Beispiel die Titelseite eines Berichts und der Einführungstext auf getrennte Seiten gedruckt werden sollen, fügen Sie in den Berichtskopf hinter den Steuerelementen, die auf der Titelseite erscheinen sollen, und vor den Steuerelementen für die zweite Seite einen Seitenwechsel ein.

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool Seitenwechsel [image] .

  3. Klicken Sie an die Stelle des Berichts, an der der Seitenwechsel eingefügt werden soll. Fügen Sie den Seitenwechsel oberhalb oder unterhalb eines Steuerelements ein, damit die Daten innerhalb dieses Steuerelements nicht geteilt werden.

    Microsoft Access markiert den Seitenwechsel mit einer kurzen punktierten Linie am linken Rand des Berichts.

    Wenn in einem Bericht jede Gruppe oder jeder Datensatz auf einer neuen Seite beginnen soll, aktivieren Sie die Eigenschaft NeueSeite des Gruppenkopfes, des Gruppenfußes bzw. des Detailbereichs.

    Wie wird's gemacht?

Anmerkung Der Bericht Katalog in der Beispieldatenbank Nordwind enthält ein Beispiel für einen Seitenwechsel im Berichtskopf. Um diesen Bericht anzuzeigen, öffnen Sie innerhalb des Office-Ordners im Ordner BEISPIEL die Datenbank Nordwind, und öffnen Sie dann in der Entwurfsansicht den Bericht Katalog. Um Information zum Öffnen von Nordwind anzuzeigen, klicken Sie auf [image] .


 Hinzufügen von Seitenzahlen zu einem Formular oder Bericht

Hinzufügen von Seitenzahlen zu einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht, oder öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Seitenzahlen.

  3. Wählen Sie im Dialogfeld Seitenzahlen das Format, die Position und die Ausrichtung für die Seitenzahlen. Für die Orientierung stehen die folgenden Optionen zur Verfügung:
    • Linksbündig: Fügt ein Textfeld am linken Rand hinzu.

    • Zentriert: Fügt ein Textfeld in der Mitte zwischen dem linken und dem rechten Rand hinzu.

    • Rechtsbündig: Fügt ein Textfeld am rechten Rand hinzu.

    • Innen: Fügt Textfelder an den linken und rechten Rändern hinzu. Ungerade Seitenzahlen werden am linken Rand und gerade Seitenzahlen am rechten Rand gedruckt.

    • Außen Fügt Textfelder an den linken und rechten Rändern hinzu. Gerade Seitenzahlen werden am linken Rand und ungerade Seitenzahlen am rechten Rand gedruckt.
  4. Zum Anzeigen einer Seitenzahl auf der ersten Seite aktivieren Sie das Kontrollkästchen Seitenzahl auf erster Seite anzeigen.

Microsoft Access verwendet zum Erstellen von Seitenzahlen einen Ausdruck. Zum Anzeigen von Beispielen für andere Seitenzahlenausdrücke klicken Sie auf [image] .


 Hinzufügen des aktuellen Datums und der aktuellen Zeit zu einem Formular oder Bericht

Hinzufügen des aktuellen Datums und der aktuellen Zeit zu einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht, oder öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Datum und Uhrzeit.

  3. Zum Einfügen eines Datums aktivieren Sie das Kontrollkästchen Datum einschließen, und klicken Sie dann auf das gewünschte Datumsformat.

  4. Zum Einfügen der Uhrzeit aktivieren Sie das Kontrollkästchen Zeit einschließen, und klicken Sie dann auf das gewünschte Zeitformat.

Microsoft Access fügt ein Textfeld zum Formular oder Bericht hinzu und stellt für die Eigenschaft Steuerelementinhalt einen Ausdruck ein. Wenn es einen Formular- oder Berichtskopf gibt, fügt Microsoft Access das Textfeld in diesen Bereich ein. Gibt es keinen Kopf, wird das Textfeld in den Detailbereich eingefügt.


 Ausdrücke für Seitenzahlen - Beispiele

Ausdrücke für Seitenzahlen - Beispiele

Die nachstehende Tabelle zeigt Seitenzahlenausdrücke, die Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte verwenden können, sowie die Ergebnisse, die Sie in anderen Ansichten sehen.

Ausdruck | Ergebnis
=[Seite] | 1, 2, 3
="Seite " & [Seite] | Seite 1, Seite 2, Seite 3
="Seite " & [Seite] & " von " & [Seiten] | Seite 1 von 3, Seite 2 von 3, Seite 3 von 3
=[Seite] & " von " & [Seiten] & " Seiten" | 1 von 3 Seiten, 2 von 3 Seiten, 3 von 3 Seiten
=[Seite] & "/" & [Seiten] & " Seiten" | 1/3 Seiten, 2/3 Seiten, 3/3 Seiten
=[Land] & " - " & [Seite] | UK - 1, UK - 2, UK - 3
=Format([Seite]; "000") | 001, 002, 003


 Hinzufügen oder Entfernen eines Berichtskopfes und -fußes

Hinzufügen oder Entfernen eines Berichtskopfes und -fußes

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie im Menü Ansicht auf Berichtskopf/-fuß oder auf Seitenkopf/-fuß.

Anmerkungen

  • Sie können Köpfe und Füße immer nur paarweise hinzufügen. Wenn Sie entweder einen Kopf oder einen Fuß nicht benötigen, können Sie die Eigenschaft Sichtbar des nicht benötigten Bereichs auf Nein einstellen. Oder Sie entfernen alle Steuerelemente aus dem Bereich und weisen diesem dann eine Höhe gleich Null zu bzw. stellen dessen Eigenschaft Sichtbar auf 0 ein.

  • Wenn Sie einen Kopf oder Fuß entfernen, löscht Microsoft Access auch die in diesem Kopf oder Fuß enthaltenen Steuerelemente.

  • Sehen Sie hier ein Beispiel für die Verwendung unterschiedlicher Bereichstypen in Berichten.


 Auslassen des Seitenkopfes oder -fußes auf Seiten mit Berichtskopf oder -fuß

Auslassen des Seitenkopfes oder -fußes auf Seiten mit Berichtskopf oder -fuß

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Legen Sie für die Eigenschaften Seitenkopf oder Seitenfuß eine der folgenden Einstellungen fest:
    • Alle Seiten: (Standardeinstellung) Druckt den Seitenkopf oder -fuß auf allen Seiten.

    • Außer Berichtskopf: Druckt den Seitenkopf oder -fuß nicht auf der Seite, auf welcher der Berichtskopf erscheint.

    • Außer Berichtsfuß: Druckt den Seitenkopf oder -fuß nicht auf der Seite, auf welcher der Berichtsfuß erscheint.

    • Außer Berichtskopf/-fuß: Druckt den Seitenkopf oder -fuß nicht auf einer Seite, auf der ein Berichtskopf oder -fuß erscheint.

Anmerkung Wenn Sie für die Eigenschaft Seitenkopf eine der Einstellungen Außer Berichtskopf oder Außer Berichtsfuß setzen, druckt Microsoft Access den Berichtsfuß auf einer neuen Seite.


 Ändern der Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Formular oder Bericht

Ändern der Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Formular oder Bericht

Sie können für die Bereiche in Formularen und Berichten unterschiedliche Höhen festlegen. Die Breite eines Formulars oder Berichts ist jedoch für alle Bereiche gleich. Wenn Sie die Breite eines Bereichs ändern, ändern Sie gleichzeitig die Breite des gesamten Formulars oder Berichts.

Ändern der Höhe oder der Breite

  1. Öffnen Sie das Formular in der Entwurfsansicht, oder öffnen Sie den Bericht in der Entwurfsansicht.

  2. Setzen Sie den Zeiger auf den unteren oder rechten Rand des Bereichs, um die Höhe bzw. die Breite des Bereichs zu ändern.

  3. Ziehen Sie den Zeiger nach oben oder nach unten, wenn Sie die Höhe des Bereichs ändern möchten. Ziehen Sie den Zeiger nach links oder nach rechts, wenn Sie die Breite des Bereichs ändern möchten.

Höhe des Bereichs ändern

Breite des Bereichs ändern

Ändern der Höhe und der Breite

  • Setzen Sie den Zeiger in die untere rechte Ecke des Bereichs, und ziehen Sie diesen diagonal in die gewünschte Richtung.

Höhe und Breite des Bereichs ändern


 Zusammenhalten der Daten eines Datensatzes auf einer Seite oder in einer Spalte eines Formulars oder Berichts

Zusammenhalten der Daten eines Datensatzes auf einer Seite oder in einer Spalte eines Formulars oder Berichts

  1. Öffnen Sie das Formular in der Entwurfsansicht oder den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Bereichsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Stellen Sie die Eigenschaft Zusammenhalten auf Ja ein. Wenn der gesamte Bereich nicht mehr auf die aktuelle Seite passt, druckt Microsoft Access den Bereich auf die nächste Seite. Falls der Bereich jedoch länger als der Druckbereich auf der Seite ist, wird die Eigenschaft Zusammenhalten ignoriert.

    Die Eigenschaft Zusammenhalten ist für sämtliche Bereiche verfügbar, mit Ausnahme der Kopf- und Fußbereiche der Seite.

Tipp Wenn Sie die Daten einer Gruppe, beispielsweise den Gruppenkopf, die Detaildatensätze und den Gruppenfuß, zusammenhalten wollen, legen Sie die Eigenschaft Zusammenhalten für die Gruppe fest.

Wie wird's gemacht?


 Erstellen von Adressetiketten

Erstellen von Adressetiketten

  1. Klicken Sie im Datenbankfenster auf Berichte [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neuer Bericht auf Etiketten-Assistent.

  4. Klicken Sie auf die Tabelle oder Abfrage, die die Daten für die Etiketten enthält, und dann auf OK.

  5. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.

    Entspricht der neue Etikettenbericht nicht Ihren Wünschen, können Sie ihn löschen und den Etiketten-Assistenten erneut ausführen.

Anmerkungen

  • Um Informationen zum Erstellen von Adressetiketten für einen Matrixdrucker anzuzeigen, klicken Sie auf [image] .

  • Der Bericht Kundenetiketten in der Beispieldatenbank Nordwind enthält dreispaltige Adressetiketten. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL Ihres Office-Ordners und dann den Bericht Kundenetiketten in der Entwurfsansicht. Um Informationen zum Öffnen der Nordwind-Datenbank anzuzeigen, klicken Sie auf [image] .


 Erstellen von Adressetiketten für einen Matrixdrucker

Erstellen von Adressetiketten für einen Matrixdrucker

Das Erstellen von Adressetiketten für einen Matrixdrucker oder einen Drucker mit Traktoreinzug macht im Allgemeinen eine Anpassung der benutzerdefinierten Seitengröße erforderlich. Bevor Sie einen Etikettenbericht für diesen Druckertyp erstellen, müssen Sie zunächst in der Systemsteuerung von Microsoft Windows den Standarddrucker und die Papiergröße einstellen.

Einstellen des Standarddruckers und der Papiergröße

  1. Klicken Sie in Windows auf die Schaltfläche Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Drucker, klicken Sie auf das Symbol für den Matrixdrucker und dann im Menü Datei auf Als Standard definieren.

  3. Klicken Sie im Menü Datei auf Eigenschaften und dann auf die Registerkarte Papier.

  4. Klicken Sie unter Papiergröße auf das Symbol Eigene.

  5. Wählen Sie im Dialogfeld Benutzerdefinierte Größe die Maßeinheit aus, und geben Sie dann die Breite und Länge des Etiketts ein.

    Um die Breite zu bestimmen, messen Sie den Abstand zwischen dem linken Rand des ganz links und dem rechten Rand des ganz rechts angeordneten Etiketts. Um die Länge zu bestimmen, messen Sie den Abstand zwischen dem oberen Rand des ersten Etiketts und dem oberen Rand des zweiten Etiketts. Wenn Sie z.B. zweispaltige Adressetiketten mit den Abmessungen 76,2 x 127 mm (3 x 5 Zoll) und einem Abstand von 6,4 mm (0,25 Zoll) verwenden, stellen Sie 0,1 mm (0,01 Zoll) unter Maßeinheit, 1652 (625) als Breite und 1333 (525) als Länge ein.

  6. Klicken Sie auf OK, um die Einstellungen im Dialogfeld Benutzerdefinierte Größe zu speichern.

  7. Klicken Sie auf OK, um die Einstellungen im Dialogfeld Eigenschaften des Druckers zu speichern.

Nachdem Sie den Drucker und die Papiergröße eingestellt haben, können Sie einen Etikettenbericht für einen Matrixdrucker erstellen, und zwar entweder mit Hilfe des Etiketten-Assistenten oder ohne einen Assistenten in der Entwurfsansicht des Berichts. Um Informationen zum Verwenden des Etiketten-Assistenten anzuzeigen, klicken Sie auf [image] .

Erstellen eines Etikettenberichts ohne einen Assistenten

  1. Erstellen Sie einen leeren Bericht, der an die Tabelle oder Abfrage gebunden ist, die die gewünschten Daten enthält.

    Wie wird's gemacht?

  2. Klicken Sie in der Entwurfsansicht des Berichts im Menü Ansicht auf Seitenkopf/-fuß, und entfernen Sie den Seitenkopf und -fuß. (Für diesen Bericht benötigen Sie nur den Detailbereich.)

  3. Passen Sie die Höhe und Breite des Detailbereichs an die Höhe und Breite eines Etiketts an.

    Wie wird's gemacht?

  4. Fügen Sie dem Detailbereich Textfelder hinzu. Stellen Sie dabei sicher, dass diese sich nicht überlagern. (Um Ränder für die Etiketten zu erstellen, sehen Sie einen Abstand von mindestens 5,1 mm (0,2 Zoll) zwischen den Textfeldern und allen Rändern des Detailbereichs vor.)

    Wie wird's gemacht?

  5. Klicken Sie im Menü Datei auf Seitenformat.

  6. Stellen Sie im Dialogfeld Seitenformat die folgenden Werte ein:
    • Ist der Matrixdrucker nicht als Standarddrucker eingestellt, klicken Sie auf der Registerkarte Seite auf Spezieller Drucker. Klicken Sie auf die Schaltfläche Drucker und dann in der Liste auf den Matrixdrucker.

    • Stellen Sie auf der Registerkarte Seite unter Papier für Größe die Option Benutzerdefinierte Größe und für Zufuhr die Option Traktor ein.

    • Stellen Sie auf der Registerkarte Ränder alle Ränder auf 0,0 mm (0,0 Zoll) ein.

    • Aktivieren Sie auf der Registerkarte Spalten unter Spaltengröße das Kontrollkästchen Wie Detailbereich.

      Sind die Etiketten mehrspaltig auf der Seite angeordnet, müssen Sie darüber hinaus auf der Registerkarte Spalten die folgenden Elemente unter Rastereinstellungen einstellen:

    • Geben Sie im Feld Spaltenanzahl die Anzahl der auf der Seite nebeneinander angeordneten Etiketten ein.

    • Geben Sie im Feld Zeilenabstand den Abstand zwischen dem unteren Rand eines Etiketts und dem oberen Rand des nächsten Etiketts ein.

    • Geben Sie im Feld Spaltenabstand den Abstand zwischen dem rechten Rand eines Etiketts und dem linken Rand des nächsten Etiketts ein.

Anmerkung Wenn in der Systemsteuerung von Microsoft Windows ein Matrixdrucker als Standarddrucker eingestellt ist und Sie Benutzerdefinierte Größe als Papiergröße eingestellt haben, verwendet Microsoft Access diese Papiergröße. Möchten Sie ein Etikett oder einen Bericht auf einer Seite einer anderen Größe erstellen oder drucken, müssen Sie zuvor die benutzerdefinierte Seitengröße in der Systemsteuerung ändern.


Individuelles Gestalten von Etiketten, die mit dem Etiketten-Assistenten erstellt wurden

Was möchten Sie tun?

Wenn Sie größere Änderungen an den Etiketten vornehmen möchten, ist es sinnvoll, mit dem Etiketten-Assistenten einen neuen Bericht für Etiketten zu erstellen.

Wenn Sie nur kleinere Änderungen an den Etiketten vornehmen möchten, gibt es verschiedene Möglichkeiten:

Die Schriftart des Textes in den Steuerelementen ändern

Den Schriftgrad des Textes in den Steuerelementen ändern

Die Größe von Steuerelementen ändern

Steuerelemente hinzufügen

Die Druckereinrichtungsoptionen ändern


Gruppierte Datensätze in einem Bericht - Beispiel

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema unter Verwendung der Tastatur anzuzeigen, drücken Sie F6, um den Themenfensterausschnitt zu aktivieren, TAB, um die Grafik auszuwählen, und danach die EINGABETASTE.


 Sortieren von Datensätzen in einem Bericht

Sortieren von Datensätzen in einem Bericht

Sie können in einem Bericht nach bis zu 10 Feldern oder Ausdrücken sortieren.

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Wählen Sie in der ersten Zeile der Spalte Feld/Ausdruck einen Feldnamen aus, oder geben Sie einen Ausdruck ein.

    Das Feld oder der Ausdruck in der ersten Zeile ist die erste Sortierebene (die größte Gruppe). Die zweite Zeile ist die zweite Sortierebene usw.

    Wenn Sie die Spalte Feld/Ausdruck ausfüllen, stellt Microsoft Access die Sortierreihenfolge auf Aufsteigend ein. Die aufsteigende Reihenfolge sortiert von A-Z oder 0-9.

  4. Um die Sortierreihenfolge zu ändern, wählen Sie in der Spalte Sortierreihenfolge die Option Absteigend aus. Die absteigende Reihenfolge sortiert von Z-A oder 9-0.

Anmerkung Der Bericht Kundenetiketten in der Beispieldatenbank Nordwind sortiert Datensätze nach den Werten in drei Feldern. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und anschließend den Bericht Kundenetiketten in der Entwurfsansicht. Zum Anzeigen von Informationen über das Öffnen der Datenbank Nordwind klicken Sie auf [image] .


 Gruppieren von Datensätzen in einem Bericht

Gruppieren von Datensätzen in einem Bericht

Sie können in einem Bericht nach bis zu 10 Feldern oder Ausdrücken gruppieren. Zum Anzeigen eines Beispiels für gruppierte Datensätze klicken Sie auf [image] .

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Legen Sie die Sortierreihenfolge für die Daten im Bericht fest.

    Wie wird's gemacht?

  4. Klicken Sie auf das Feld oder den Ausdruck, dessen Gruppeneigenschaften Sie einstellen möchten.

  5. Stellen Sie die nachfolgend aufgeführten Gruppeneigenschaften ein. Sie müssen zunächst entweder Gruppenkopf oder Gruppenfuß auf Ja einstellen, um eine Gruppierungsebene zu erstellen. Stellen Sie dann die anderen Gruppeneigenschaften ein.
    • Gruppenkopf: Fügt für das Feld oder den Ausdruck einen Gruppenkopf hinzu oder entfernt ihn.

    • Gruppenfuß: Fügt für das Feld oder den Ausdruck einen Gruppenfuß hinzu oder entfernt ihn.

    • GruppierenNach: Gibt an, wie die Werte gruppiert werden sollen. Die angezeigten Optionen hängen vom Datentyp des Feldes ab, nach dem Sie gruppieren. Wenn Sie nach einem Ausdruck gruppieren, werden alle Optionen für sämtliche Datentypen angezeigt.

    • Intervall: Gibt ein beliebiges Intervall an, das für die Werte in dem Feld oder Ausdruck, nach dem Sie gruppieren, gültig ist.

    • Zusammenhalten: Gibt an, ob Microsoft Access eine Gruppe ganz oder nur teilweise auf einer Seite drucken soll.

Weitere Informationen

Um weitere Informationen zum Gruppieren nach Feldern des Datentyps Text anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zum Gruppieren nach Feldern des Datentyps Datum/Uhrzeit anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zum Gruppieren nach Feldern der Datentypen AutoWert, Währung oder Zahl anzuzeigen, klicken Sie auf [image] .

Anmerkung Der Bericht Personalumsätze nach Land in der Beispieldatenbank Nordwind weist zwei Gruppierungsebenen auf. Um diesen Bericht anzusehen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht Personalumsätze nach Land in der Entwurfsansicht. Um weitere Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Ändern der Sortier- und Gruppierreihenfolge in einem Bericht

Ändern der Sortier- und Gruppierreihenfolge in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie im Fenster Sortieren und gruppieren auf den Zeilenmarkierer des Feldes oder des Ausdrucks, das (den) Sie verschieben möchten.

  4. Klicken Sie erneut auf den Markierer, und ziehen Sie die markierte Zeile an eine neue Stelle in der Liste.

Wenn die neu anzuordnenden Gruppen Kopfzeilen oder Fußzeilen umfassen, verschiebt Microsoft Access diese Kopf- und Fußzeilen mit allen darin befindlichen Steuerelementen an die neue Position. Die genaue Anordnung der Steuerelemente in den Kopf- und Fußzeilen müssen Sie jedoch selbst anpassen.


 Einfügen eines zusätzlichen Feldes oder eines weiteren Ausdrucks für das Sortieren oder Gruppieren

Einfügen eines zusätzlichen Feldes oder eines weiteren Ausdrucks für das Sortieren oder Gruppieren

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie im Fenster Sortieren und gruppieren auf den Zeilenmarkierer der Zeile, in die Sie das neue Feld oder den neuen Ausdruck einfügen möchten, und drücken Sie dann die EINFG-TASTE.

  4. Wählen Sie in der Spalte Feld/Ausdruck dieser leeren Zeile das Feld aus, nach dem sortiert werden soll, oder geben Sie einen Ausdruck ein.

    Wenn Sie die Spalte Feld/Ausdruck ausfüllen, stellt Microsoft Access die Sortierreihenfolge auf Aufsteigend ein.

  5. Um die Sortierreihenfolge zu ändern, wählen Sie aus der Spalte Sortierreihenfolge die Option Absteigend aus.


 Löschen eines Feldes oder Ausdrucks für das Sortieren oder Gruppieren

Löschen eines Feldes oder Ausdrucks für das Sortieren oder Gruppieren

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie im Fenster Sortieren und gruppieren auf den Zeilenmarkierer des Feldes oder des Ausdrucks, das (den) Sie löschen möchten, und drücken Sie dann die ENTF-TASTE.

  4. Klicken Sie auf Ja, um die Sortier- oder Gruppierungsebene zu löschen, bzw. auf Nein, um sie zu bewahren.

Anmerkung Enthält das zu löschende Feld oder der zu löschende Ausdruck eine Kopf- oder Fußzeile, löscht Microsoft Access diese ebenfalls, einschließlich ihrer Steuerelemente.


 Zusammenhalten der Daten einer Gruppe auf einer Seite oder in einer Spalte eines Berichts

Zusammenhalten der Daten einer Gruppe auf einer Seite oder in einer Spalte eines Berichts

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Fenster Sortieren und gruppieren anzuzeigen.

  3. Legen Sie die Gruppierungsebenen für den Bericht fest.

    Wie wird's gemacht?

  4. Klicken Sie auf das Feld oder den Ausdruck für die Gruppierungsebene, die Sie zusammenhalten möchten.

  5. Legen Sie im Bereich Gruppeneigenschaften des Fensters Sortieren und gruppieren für die Eigenschaft Zusammenhalten eine der folgenden Einstellungen fest.
    • Ganze Gruppe: Der Gruppenkopf, alle Detaildatensätze und der Gruppenfuß werden auf derselben Seite oder in derselben Spalte gedruckt.

    • Mit erstem Detaildatensatz: Der Gruppenkopf wird nur dann auf einer Seite oder in einer Spalte gedruckt, wenn auch der erste Detaildatensatz dort gedruckt werden kann.
  6. Zeigen Sie das Eigenschaftenfenster für den Bericht an.

    Wie wird's gemacht?

  7. Legen Sie für die Eigenschaft GruppeZusammenhalten eine der folgenden Einstellungen fest.
    • Pro Seite: Hält die Gruppe auf einer Seite zusammen.

    • Pro Spalte: Hält die Gruppe in einer Spalte oder Zeile zusammen.

Anmerkungen

  • Möchten Sie die Daten in einem Bereich zusammenhalten, z. B. einen Datensatz im Detailbereich, stellen Sie die Eigenschaft Zusammenhalten für diesen Bereich auf Ja ein.

    Wie wird's gemacht?

  • Der Bericht Alphabetische Artikelliste in der Beispieldatenbank Nordwind hält jeweils die mit ein- und demselben Buchstaben beginnenden Artikel in einer Gruppe zusammen. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht Alphabetische Artikelliste in der Entwurfsansicht. Um weitere Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Beginnen jeder Gruppe eines Berichts in einer neuen Zeile oder Spalte

Beginnen jeder Gruppe eines Berichts in einer neuen Zeile oder Spalte

  1. Erstellen Sie einen mehrspaltigen Bericht mit mindestens einer Gruppierungsebene.

    Um Informationen zum Erstellen eines mehrspaltigen Berichts anzuzeigen, klicken Sie auf [image] . Um Informationen zum Erstellen von Gruppierungsebenen anzuzeigen, klicken Sie auf [image] .

  2. Klicken Sie in der Entwurfsansicht des Berichts im Menü Datei auf Seitenformat.

  3. Klicken Sie auf die Registerkarte Spalten. Stellen Sie unter Rastereinstellungen sicher, dass in Spaltenanzahl ein Wert größer 1 steht.

  4. Führen Sie unter Spaltenlayout einen der folgenden Schritte aus:
    • Um jede Gruppe in einer neuen Spalte zu beginnen, klicken Sie auf die Option Nach unten, dann quer.

    • Um jede Gruppe in einer neuen Zeile zu beginnen, klicken Sie auf die Option Quer, dann nach unten.
  5. Klicken Sie auf OK.

  6. Doppelklicken Sie auf den Bereichsmarkierer für den Gruppenkopf oder den Gruppenfuß, um dessen Eigenschaftenfenster anzuzeigen.

  7. Legen Sie für die Eigenschaft NeueZeileOderSpalte eine der folgenden Einstellungen fest:
    Einstellung | Beschreibung
    Keine | (Standardeinstellung) Die Zeilen- oder Spaltenumbrüche werden von den Einstellungen im Dialogfeld Seitenformat und vom verfügbaren Platz auf der Seite bestimmt.
    Vor Bereich | Microsoft Access beginnt den Druck des aktuellen Bereichs (d. h. des Bereichs, für den Sie die Eigenschaft einstellen, z. B. den Gruppenkopf) in einer neuen Zeile oder Spalte. Der Druck des nächsten Bereichs, z. B. des Detailbereichs, beginnt in derselben Zeile oder Spalte.
    Nach Bereich | Microsoft Access beginnt den Druck des aktuellen Bereichs, z. B. des Gruppenkopfs, in der aktuellen Zeile oder Spalte. Der Druck des nächsten Bereichs, z. B. des Detailbereichs, beginnt in der nächsten Zeile oder Spalte.
    Vor & Nach | Microsoft Access beginnt den Druck des aktuellen Bereichs, z. B. des Gruppenkopfs, in einer neuen Zeile oder Spalte. Der Druck des nächsten Bereichs, z. B. des Detailbereichs, beginnt in der nächsten Zeile oder Spalte.

Anmerkungen

  • Um ein Beispiel anzuzeigen für einen Bericht, bei dem jede Gruppe in einer neuen Spalte beginnt, sowie für einem Bericht, bei dem jede Gruppe in einer neuen Zeile beginnt, klicken Sie auf [image] .

  • Im Bericht Artikel nach Kategorie in der Beispieldatenbank Nordwind beginnt jede Gruppe in einer neuen Spalte. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht Artikel nach Kategorie in der Entwurfsansicht. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Zurücksetzen von Seitenzahlen für jede Gruppe in einem Bericht

Zurücksetzen von Seitenzahlen für jede Gruppe in einem Bericht

Erstellen eines Makros, das Seitenzahlen zurücksetzt

  1. Erstellen Sie ein Makro, das die Aktion SetzenWert verwendet, um die Eigenschaft Seite in 1 zu ändern.

    Wie wird's gemacht?

    Entscheiden Sie, ob die Seitenzahl im Seitenkopf oder im Seitenfuß angezeigt werden soll, und verwenden Sie dann für die Argumente der Aktion SetzenWert die folgenden Werte.

    Position der
    Seitenzahl     		Argumente von
    "SetzenWert"
    Seitenkopf Feld: [Seite]

    Ausdruck: 0
    Seitenfuß Feld: [Seite]

    Ausdruck: 1
  2. Speichern und schließen Sie das Makro.

Ändern des Berichts

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Erstellen Sie im Seitenkopf oder im Seitenfuß ein Textfeld für die Seitenzahl, sofern ein solches nicht bereits vorhanden ist.

    Wie wird's gemacht?

  3. Stellen Sie die folgenden Eigenschaften für den Gruppenkopf und Gruppenfuß der ersten Gruppierungsebene ein, abhängig davon, wo die Seitenzahl angezeigt wird.

    Wenn die Seitenzahl im Seitenkopf angezeigt wird, stellen Sie die folgenden Eigenschaften ein:

    Bereich | Eigenschaft | Einstellung | Zweck
    Gruppenkopf | NeueSeite | Vor Bereich | Beginnt jede Gruppe auf einer neuen Seite.
    Gruppenfuß | BeimFormatieren | Name des zuvor erstellten Makros | Setzt die Seitenzahl für die neue Gruppe auf 1 zurück.

    Wenn die Seitenzahl im Seitenfuß angezeigt wird, stellen Sie die folgenden Eigenschaften ein:

    Bereich | Eigenschaft | Einstellung | Zweck
    Gruppenkopf | BeimFormatieren | Name des zuvor erstellten Makros | Setzt die Seitenzahl für die neue Gruppe auf 1 zurück.
    Gruppenfuß | NeueSeite | Nach Bereich | Beginnt jede Gruppe auf einer neuen Seite.

Anmerkung Der Bericht Personalumsätze nach Land in der Beispieldatenbank Nordwind verwendet eine Ereignisprozedur in der Eigenschaft BeimFormatieren, mit der die Seitenzahl für jedes Land zurückgesetzt wird. Um sich diesen Bericht anzusehen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht Personalumsätze nach Land in der Entwurfsansicht. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Wiederholen eines Gruppenkopfes auf einer anderen Seite oder in einer anderen Spalte

Wiederholen eines Gruppenkopfes auf einer anderen Seite oder in einer anderen Spalte

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Zeigen Sie das Eigenschaftenfenster für den Gruppenkopf an, den Sie wiederholen möchten. Doppelklicken Sie hierzu auf dessen Bereichsmarkierer.

  3. Stellen Sie die Eigenschaft BereichWiederholen auf Ja ein.


 Ausblenden von Duplikatwerten in einem Bericht

Ausblenden von Duplikatwerten in einem Bericht

Sie können Duplikatwerte in einem Bericht mit sortierten Datensätzen oder in einem Bericht mit gruppierten Datensätzen ausblenden.

Ausblenden von Duplikatwerten in einem Bericht mit sortierten Datensätzen

  1. Erstellen Sie einen Bericht, der Datensätze nach einem oder mehreren Feldern sortiert, die möglicherweise Duplikatwerte enthalten.

    Wie wird's gemacht?

  2. Fügen Sie in der Entwurfsansicht des Berichts die Textfelder für alle Felder in den Detailbereich ein.

  3. Um das Eigenschaftenfenster für ein Textfeld mit Daten anzuzeigen, die möglicherweise Duplikatwerte sind, stellen Sie sicher, dass das Textfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Stellen Sie die Eigenschaft DuplikateAusblenden auf Ja ein.

    Anmerkung Bei Textfeldern, deren Eigenschaft DuplikateAusblenden auf Ja eingestellt ist, druckt Microsoft Access einen Wert in den ersten Datensatz, in dem dieser Wert vorkommt. Wenn Datensätze mit dem Duplikatwert auf einer weiteren Seite fortgesetzt werden, druckt es den Wert an den Anfang einer neuen Seite.

Ausblenden von Duplikatwerten in einem Bericht mit gruppierten Datensätzen

  1. Erstellen Sie einen Bericht mit einer oder mehreren Gruppierungsebenen.

    Wie wird's gemacht?

  2. Verschieben Sie in der Entwurfsansicht des Berichts das Textfeld für das Feld, nach dem Sie gruppieren, vom Gruppenkopf in den Detailbereich.

  3. Um das Eigenschaftenfenster für das Textfeld anzuzeigen, stellen Sie sicher, dass das Textfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Stellen Sie die Eigenschaft DuplikateAusblenden auf Ja ein.

  5. Löschen Sie Linien und andere Steuerelemente aus dem Gruppenkopf.

  6. Doppelklicken Sie auf den Bereichsmarkierer des Gruppenkopfs, um dessen Eigenschaftenfenster anzuzeigen.

  7. Stellen Sie die Eigenschaft Höhe des Gruppenkopfs auf 0 ein.

    Anmerkung Der Gruppenname steht nur am Anfang einer neuen Gruppe oder einer neuen Seite, wenn die Gruppe auf mehr als einer Seite angezeigt wird.


 Berechnen einer Funktion für einen Datensatz in einem Bericht

Berechnen einer Funktion für einen Datensatz in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie im Detailbereich ein berechnetes Textfeld hinzu.

    Wie wird's gemacht?

  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld ausgewählt sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Geben Sie im Einstellungsfeld für die Eigenschaft Steuerelementinhalt einen entsprechenden Ausdruck ein.

    Ausdruck in einem Textfeld im Detailbereich eines Berichts

    Tipp In einer Microsoft Access-Datenbank (.mdb)können Sie auf die Generator-Schaltfläche [image] klicken, um den Ausdruck unter Verwendung des Ausdrucks-Generators zu erstellen.

Anmerkungen

  • Basiert ein Bericht auf einer Abfrage, können Sie den Ausdruck in der dem Bericht zugrunde liegenden Abfrage erstellen. Dies verbessert unter Umständen die Leistung des Berichts, und wenn Sie Summen für Datensatzgruppen berechnen möchten, können Sie leichter den Namen eines berechneten Feldes in einer Aggregatfunktion verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Zum Anzeigen von Beispielen für Ausdrücke zum Berechnen von Werten für einen Datensatz klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .


 Berechnen einer Summe oder eines Mittelwertes für eine Gruppe von Datensätzen oder für alle Datensätze in einem Bericht

Berechnen einer Summe oder eines Mittelwertes für eine Gruppe von Datensätzen oder für alle Datensätze in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie in einem oder mehreren der folgenden Bereiche ein berechnetes Textfeld hinzu:

    Wie wird's gemacht?

    • Zum Berechnen einer Summe oder eines Mittelwertes für eine Datensatzgruppe fügen Sie ein Textfeld in den Gruppenkopf oder den Gruppenfuß ein.

    • Zum Berechnen einer Endsumme oder eines Mittelwertes für alle Datensätze im Bericht fügen Sie ein Textfeld im Berichtskopf oder im Berichtsfuß hinzu.
  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Geben Sie im Einstellungsfeld für die Eigenschaft Steuerelementinhalt einen Ausdruck ein, der die Funktion Summe zum Berechnen einer Summe bzw. die Funktion Mittelwert zum Berechnen eines Mittelwertes verwendet.

    Steuerelemente, die Summen im Gruppenfuß und Berichtsfuß berechnen

    Tipp In einer Microsoft Access-Datenbank (.mdb) können Sie auf die Generator-Schaltfläche [image] klicken, um den Ausdruck unter Verwendung des Ausdrucks-Generators zu erstellen.

Anmerkungen

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.mdb) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Berechnen von Summen oder Mittelwerten unter Verwendung von Aggregatfunktionen, wie z. B. Summe oder Mittelwert, klicken Sie auf [image] .

  • Zum Anzeigen von Beispielen zu Ausdrücken mit Aggregatfunktionen klicken Sie auf [image] .

  • Der Bericht Personalumsätze nach Land aus der Beispieldatenbank Nordwind enthält ein Beispiel für Gruppensummen und eine Endsumme. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind aus dem Unterordner BEISPIELE in Ihrem Office-Ordner und öffnen danach den Bericht Personalumsätze nach Land in der Entwurfsansicht. Zum Anzeigen von Informationen über das Öffnen der Datenbank Nordwind klicken Sie auf [image] .


 Berechnen einer laufenden Summe in einem Bericht

Berechnen einer laufenden Summe in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie in einem oder mehreren der folgenden Bereiche ein Textfeld hinzu.

    Wie wird's gemacht?

    • Zum Berechnen einer laufenden Summe, die sich mit jedem Datensatz erhöht, fügen Sie im Detailbereich ein gebundenes Textfeld oder ein berechnetes Textfeld hinzu.

    • Zum Berechnen einer laufenden Summe, die sich mit jeder Datensatzgruppe erhöht, fügen Sie im Gruppenkopf oder im Gruppenfuß ein gebundenes oder ein berechnetes Textfeld hinzu.
  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] .

  4. Stellen Sie die Eigenschaft LaufendeSumme entsprechend der gewünschten laufenden Summe ein:
    • Über Gruppe: Setzt den Zähler am Anfang jeder nächsthöheren Gruppierungsebene auf 0 zurück.

    • Über Alles: Setzt den Zähler bis zum Ende des Berichts kontinuierlich hoch.

Anmerkungen

  • Zum Anzeigen eines Beispiels für einen Bericht, der laufende Summen berechnet, klicken Sie auf [image] .

  • Wenn Sie für die Eigenschaft LaufendeSumme die Einstellung Über Alles festlegen, können Sie die Endsumme im Berichtsfuß wiederholen. Erstellen Sie dazu im Berichtsfuß ein Textfeld, und legen Sie für die Eigenschaft Steuerelementinhalt des Fußes den Namen des Textfelds ein, das die laufende Summe berechnet, z.B. =[Preis].


 Berechnen von Prozentwerten in einem Bericht

Berechnen von Prozentwerten in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie die Textfelder zum Berechnen der Datensatzsumme, der Gruppensumme und der Endsumme hinzu.

    Wie wird's gemacht?

  3. Fügen Sie im entsprechenden Bereich das Textfeld zum Berechnen des Prozentwertes hinzu.

    Um den prozentualen Anteil eines Feldes an der Gruppen- oder der Endsumme zu berechnen, fügen Sie das Steuerelement im Detailbereich hinzu.

    Um den prozentualen Anteil einer Gruppe an der Endsumme zu berechnen, fügen Sie das Textfeld im Gruppenkopf oder im Gruppenfuß hinzu.

    Wenn Ihr Bericht mehrere Gruppierungsebenen enthält, fügen Sie das Textfeld im Kopf oder Fuß der Ebene hinzu, für die Microsoft Access einen prozentualen Anteil berechnen soll.

  4. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Steuerelementinhalt einen Ausdruck ein, der die kleinere Summe durch die größere Summe teilt. Teilen Sie z. B. den Wert aus dem Steuerelement Tagessumme durch den Wert aus dem Steuerelement Endsumme.

    Tipp In einer Microsoft Access-Datenbank (.mdb), können Sie auf die Generator-Schaltfläche [image] klicken, um den Ausdruck unter Verwendung des Ausdrucks-Generators zu erstellen.

  6. Legen Sie für die Eigenschaft Format des Textfelds die Einstellung Prozent fest.

    Textfelder, die in der Entwurfsansicht angezeigte Prozentwerte berechnen

Anmerkungen

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) klicken Sie auf [image] .

  • Der Bericht Personalumsätze nach Land aus der Beispieldatenbank Nordwind enthält ein Beispiel für Prozentwerte. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind aus dem Unterordner BEISPIELE in Ihrem Office-Ordner und öffnen danach den Bericht Personalumsätze nach Land in der Entwurfsansicht. Zum Anzeigen von Informationen über das Öffnen der Datenbank Nordwind klicken Sie auf [image] .


 Berechnen einer Summe für ein berechnetes Steuerelement in einem Formular oder Bericht

Berechnen einer Summe für ein berechnetes Steuerelement in einem Formular oder Bericht

Wenn Sie eine Summe mit einer Aggregatfunktion, wie beispielsweise Summe, oder mit einer Domänenaggregatfunktion, wie beispielsweise DomSumme, berechnen, können Sie in der Funktion Summe nicht den Namen eines berechneten Steuerelements angeben. Sie müssen den Ausdruck im berechneten Steuerelement wiederholen. Beispiel:

=Summe([Anzahl]*[Einzelpreis])

Wenn Sie jedoch ein berechnetes Feld in einer zugrunde liegenden Abfrage haben, wie beispielsweise das Feld

=Endpreis: [Anzahl]*[Einzelpreis]

können Sie den Namen dieses Feldes, wie im Folgenden gezeigt, in der Funktion Summe verwenden:

=Summe([Endpreis])

Anmerkungen

  • Klicken Sie hier, um Informationen zum Erstellen von berechneten Feldern in Abfragen in Microsoft Access-Datenbanken (.mdb) anzuzeigen [image] .

  • Klicken Sie hier, um Informationen zum Erstellen von berechneten Feldern in Abfragen in Microsoft Access-Projekten (.adp) anzuzeigen [image] .

  • Klicken Sie hier, um weitere Informationen über die Funktion Summe anzuzeigen [image] .

  • Klicken Sie hier, um weitere Informationen über die Funktion DomSumme anzuzeigen [image] .


Bericht, der laufende Summen berechnet - Beispiel

Sie können laufende Summen berechnen, die innerhalb jeder Gruppe aufsummiert und zu Beginn jeder neuen Gruppe zurückgesetzt werden, und Sie können laufende Summen für einen ganzen Bericht berechnen.

In der nachstehenden Abbildung wurden für die Eigenschaft LaufendeSumme der beiden Felder auf der rechten Seite, die an das Feld Gesamtpreis gebunden sind, die Einstellungen Über Gruppe bzw. Über Alles festgelegt.

Textfelder, die laufende Summen berechnen, angezeigt in der Entwurfsansicht

Im nachstehenden Ausdruck des Berichts sehen Sie, wie Microsoft Access die laufenden Summen berechnet.

Laufende Summen in einem Ausdruck des Berichts


 Nummerieren aller Datensätze im Detailbereich eines Berichts

Nummerieren aller Datensätze im Detailbereich eines Berichts

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie im Detailbereich ein berechnetes Textfeld hinzu.

    Wie wird's gemacht?

  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Legen Sie für die Eigenschaft Steuerelementinhalt die Einstellung =1 fest.

  5. Legen Sie für die Eigenschaft LaufendeSumme die Einstellung Über Alles fest.

    Wenn Sie den Bericht in der Seitenansicht anzeigen oder drucken, erhält jeder Datensatz eine fortlaufende Datensatznummer (1, 2, 3...).

Anmerkung Der Bericht Personalumsätze nach Land aus der Datenbank Nordwind enthält ein Beispiel für nummerierte Datensätze im Detailbereich. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind aus dem Unterordner BEISPIELE in Ihrem Office-Ordner und anschließend den Bericht Umsätze nach Jahr in der Entwurfsansicht. Zum Anzeigen von Informationen zum Öffnen der Datenbank Nordwind klicken Sie auf [image] .


 Zählen aller Datensätze in einem Bericht

Zählen aller Datensätze in einem Bericht

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie im Berichtskopf oder im Berichtsfuß ein berechnetes Textfeld hinzu.

    Wie wird's gemacht?

  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  4. Legen Sie für die Steuerelementinhalt-Eigenschaft des Textfelds die Einstellung =Anzahl (*) fest. Dieser Ausdruck verwendet die Anzahl-Funktion zum Zählen aller Datensätze im Bericht, auch wenn einige Felder in bestimmten Datensätzen den Wert Null enthalten. Zum Anzeigen von Informationen über die Anzahl-Funktion klicken Sie auf [image] .


 Zählen aller Datensätze in jeder einzelnen Gruppe eines Berichts

Zählen aller Datensätze in jeder einzelnen Gruppe eines Berichts

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Fügen Sie im Detailbereich ein berechnetes Textfeld hinzu.

    Wie wird's gemacht?

  3. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] .

  4. Stellen Sie die folgenden Eigenschaften ein.
    Eigenschaft | Einstellung
    Name | Datensatzzähler
    Steuerelementinhalt | =1
    LaufendeSumme | Über Gruppe
    Sichtbar | Nein
  5. Fügen Sie ein berechnetes Textfeld zum Gruppenfuß hinzu.

  6. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  7. Legen Sie für die Eigenschaft Steuerelementinhalt den Namen des Steuerelements aus dem Detailbereich fest, das die laufende Summe berechnet, z. B. =[Datensatzzähler].


 Kombinieren von Textwerten aus mehreren Feldern in Formularen, Berichten oder Datenzugriffsseiten

Kombinieren von Textwerten aus mehreren Feldern in Formularen, Berichten oder Datenzugriffsseiten

  1. Öffnen Sie das Formular in der Formular-Entwurfsansicht, den Bericht in der Berichts-Entwurfsansicht oder die Datenzugriffsseite in der Datenzugriffsseiten-Entwurfsansicht.

  2. Fügen Sie ein berechnetes Textfeld für die Felder hinzu, die Sie kombinieren möchten.

    Tipp Auf einer Datenzugriffsseite können Sie stattdessen auch ein gebundenes HTML-Steuerelement verwenden.

  3. Stellen Sie sicher, dass das Textfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster anzuzeigen.

  4. Geben Sie im Einstellungsfeld der Steuerelementinhalt-Eigenschaft einen Ausdruck ein, um die Werte in den jeweiligen Feldern zu verketten.

    Beispiel: Um eine Adresse wie

    Hugo-Eckener Str. 29, 50829 Köln, Deutschland

    zu erhalten, geben Sie diesen Ausdruck ein:

    =[Straße] & ", " & [Ort] & " " & [Postleitzahl] & ", " & [Land]

    Tipp In einem Formular oder oder einem Bericht in einer Microsoft Access-Datenbank (.mdb) können Sie auch auf die Generator-Schaltfläche [image] klicken, um den Ausdruck mit Hilfe des Ausdrucks-Generators zu erstellen.

Anmerkungen

  • Klicken Sie hier, um weitere Informationen über die Erstellung von Ausdrücken in Microsoft Access-Datenbanken (.mdb) zu erhalten [image] .

  • Klicken Sie hier, um Informationen über die Erstellung von Ausdrücken in Microsoft Access-Projekten (.adp) zu erhalten [image] .

  • Klicken Sie hier, um Informationen über das Kompensieren von Feldern mit Null-Werten in einigen Datensätzen zu erhalten [image] .

  • Die Berichte Personalumsätze nach Land und Kundenetiketten in der Beispieldatenbank Nordwind enthalten Beispiele für das Kombinieren von Textwerten. Um einen dieser Berichte anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner SAMPLES des Office-Ordners und dann den gewünschten Bericht in der Entwurfsansicht. Klicken sie hier, um weitere Informationen über das Öffnen der Nordwind-Datenbank zu erhalten [image] .


 Kombinieren von Textwerten aus Feldern mit gegebenenfalls leeren Inhalten

Kombinieren von Textwerten aus Feldern mit gegebenenfalls leeren Inhalten

Wenn Sie Textwerte aus mehreren Feldern kombinieren, können einige Datensätze leere Felder enthalten, was zu Ausgaben führen könnte, die nicht den von Ihnen Gewünschten entsprechen. Die Ausgabe könnte beispielsweise überflüssige Leerzeichen enthalten.

Um die Datensätze zu berücksichtigen, die in bestimmten Feldern keine Werte enthalten, können Sie die Funktion Wenn verwenden. Die Verwendung der Funktion Wenn empfiehlt sich, wenn Sie über den Wert (bzw. das Fehlen eines Wertes) in einem Feld festlegen möchten, welches von zwei möglichen Resultaten Sie zurückgeben möchten.

Wenn Sie beispielsweise wissen, dass nicht jeder Datensatz einen Eintrag im Feld Region haben wird, können Sie den folgenden Ausdruck verwenden:

=[Adresse] & ", " & [Stadt] & Wenn(IstNull([Region]),"", " " & [Region]) & " " & [Postleitzahl]

Wenn das Feld Region leer ist, liefert Microsoft Access eine leere Zeichenfolge zurück (hier durch das Argument "" festgelegt). Enthält das Feld Region einen Wert, gibt Microsoft Access ein Leerzeichen und den Wert für Region zurück, wie durch das Argument " " & [Region] festgelegt.

Anmerkungen

  • Um weitere Informationen zur Funktion Wenn anzuzeigen, klicken Sie auf [image] .

  • Der Bericht Rechnung der Beispieldatenbank Nordwind enthält ein Beispiel für das Kombinieren von Werten aus Textfeldern unter Verwendung der Funktion Wenn. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterverzeichnis BEISPIELE Ihres OFFICE-Verzeichnisses, und öffnen Sie dann den Bericht Rechnung in der Entwurfsansicht. Um weitere Informationen zum Öffnen von Nordwind zu erhalten, klicken Sie auf [image] .


 Drucken der ersten Zeichen eines Wertes als Gruppenkopf in einem Bericht oder einer Datenzugriffsseite

Drucken der ersten Zeichen eines Wertes als Gruppenkopf in einem Bericht oder einer Datenzugriffsseite

  1. Öffnen Sie den Bericht in der Entwurfsansicht oder die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf der Symbolleiste auf Sortieren und gruppieren [image] , und stellen Sie sicher, dass im Fenster Sortieren und gruppieren die Eigenschaften wie folgt eingestellt sind:
    Eigenschaft | Einstellung | Betrifft
    Feld/Ausdruck | (Wählen Sie ein Feld, oder geben Sie einen Ausdruck ein.) | Berichte
    Gruppendatensatzquelle | (Wird eingestellt, wenn Sie in der Symbolleiste auf Höher stufen oder Nach Tabelle gruppieren klicken) | Datenzugriffsseiten
    Gruppenkopf | Ja | Berichte, Seiten
    Gruppenfuß | Ja oder Nein | Berichte, Seiten
    GruppierenNach | Anfangszeichen | Berichte, Seiten
    Intervall | (Geben Sie die Anzahl der Zeichen ein.) | Berichte, Seiten
    Zusammenhalten | (Wählen Sie eine Option.) | Berichte
    Standardsortierung | (Geben Sie den oder die Namen des/der Felder ein, über das/die Sie sortieren möchten.) | Datenzugriffsseiten
  3. Fügen Sie ein berechnetes Textfeld im Gruppenkopf hinzu.

    Anmerkung In einer Datenzugriffsseite können Sie an Stelle eines Textfeldes auch ein gebundenes HTML-Steuerelement verwenden.

  4. Um das Eigenschaftenfenster anzuzeigen, muss das Textfeld oder das gebundene HTML-Steuerelement markiert sein. Klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Steuerelementinhalt den Ausdruck ein (unter Verwendung der Funktion Links bzw. Rechts), der die entsprechenden Zeichen extrahieren soll.

    Wenn Sie z.B. Büromaterial und -möbel verwalten und die Nummer des jeweiligen Objekts einen Buchstabencode zum Unterscheiden der einzelnen Objektkategorien (z.B. MB für Möbel) enthält, können Sie z.B. einen der Ausdrücke aus der nachstehenden Tabelle verwenden.

    Ausdruck | Ausgabe
    =Links([Code]; 2) | MB
    =Rechts([Code]; 3) | 100

    Tipp In einem Formular oder Bericht in einer Microsoft Access-Datenbank (.MDB) können Sie auf die Generator-Schaltfläche klicken [image] , um den Ausdruck unter Verwendung des Ausdrucks-Generators zu erstellen.

Anmerkungen

  • Zum Anzeigen weiterer Informationen zum Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.MDB) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen zum Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.ADP) klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen zur Funktion Links klicken Sie auf [image] .

  • Zum Anzeigen weiterer Informationen zur Funktion Rechts klicken Sie auf [image] .

  • Der Bericht Alphabetische Artikelliste aus der Beispieldatenbank Nordwind enthält ein Beispiel zum Drucken des ersten Buchstabens jeder Artikelgruppe im Gruppenkopf. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind im Unterordner Beispiele Ihres Office-Ordners und dann den Bericht Alphabetische Artikelliste in der Entwurfsansicht. Zum Anzeigen weiterer Informationen zum Öffnen von Nordwind klicken Sie auf [image] .


 Unterberichte: Definition und Funktionsweise

Unterberichte: Definition und Funktionsweise

Ein Unterbericht ist ein Bericht, der in einen anderen Bericht eingefügt wird. Wenn Sie mehrere Berichte zusammenführen, muss einer der Berichte als Hauptbericht dienen. Der Hauptbericht kann gebunden oder ungebunden sein, d. h., er basiert auf einer Tabelle, einer Abfrage oder einer SQL-Anweisung oder nicht.

Daten in nicht zusammenhängenden Datenquellen in einem Hauptbericht mit zwei Unterberichten

Ein ungebundener Hauptbericht dient zur Aufnahme nicht zusammenhängender Unterberichte, die Sie zusammenführen möchten.

Ungebundener Hauptbericht mit zwei Unterberichten, die nicht zusammenhängende Daten anzeigen

Daten aus einer Datenquelle in einem Hauptbericht und Unterbericht

Binden Sie den Hauptbericht an eine zugrunde liegende Tabelle, Abfrage oder SQL-Anweisung, um Unterberichte einzufügen, die Informationen zu den Daten im Hauptbericht enthalten. Sie können den Hauptbericht z. B. verwenden, um Detaildatensätze anzuzeigen (wie z. B. jeden einzelnen Verkauf im Verlauf eines Jahres), und anschließend in einem Unterbericht zusammenfassende Informationen (wie z. B. den Gesamtumsatz eines Quartals) anzeigen.

Hauptbericht und Unterbericht, die an die gleiche Datenquelle gebunden sind

Daten aus verknüpften Datenquellen in einem Hauptbericht mit zwei Unterberichten

Ein Hauptbericht kann auch Daten enthalten, die in zwei oder mehreren parallelen Unterberichten gemeinsam enthalten sind. In diesem Fall enthalten die Unterberichte die Detaildatensätze der gemeinsamen Daten.

Hauptbericht mit zwei Unterberichten mit den verknüpften Daten

Ein Hauptbericht kann Unterformulare und Unterberichte enthalten, und zwar so viele, wie Sie als Benutzer benötigen. Darüber hinaus kann ein Hauptbericht bis zu zwei Ebenen von Unterformularen und Unterberichten enthalten. Ein Bericht kann z. B. einen Unterbericht enthalten, der wiederum ein Unterformular oder einen Unterbericht enthält. In der nachfolgenden Tabelle sind die verschiedenen Kombinationsmöglichkeiten von Unterformularen und Unterberichten in einem Hauptbericht aufgeführt:

Ebene 1 | Ebene 2
Unterbericht 1 | Unterbericht 2
Unterbericht 1 | Unterformular 1
Unterformular 1 | Unterformular 2

Anmerkung Die Berichte Umsätze nach Kategorie und Umsätze nach Jahr in der Beispieldatenbank Nordwind verwenden Unterberichte. Zum Anzeigen dieser Berichte öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht in der Entwurfsansicht. Zum Anzeigen von Informationen zum Öffnen von Nordwind klicken Sie auf [image] .


Erstellen eines Unterberichts

Die Vorgehensweise zum Erstellen eines Unterberichts hängt davon ab, ob Sie diesen in einem existierenden Bericht oder durch Hinzufügen eines existierenden Berichts zu einem anderen existierenden Bericht erstellen möchten.

Was möchten Sie tun?

Einen Unterbericht in einem existierenden Bericht erstellen

Einen existierenden Bericht zu einem anderen existierenden Bericht hinzufügen

Weitere Informationen zu Unterberichten anzeigen


 Wie sind Hauptbericht und Unterbericht verknüpft?

Wie sind Hauptbericht und Unterbericht verknüpft?

Wenn Sie einen Unterbericht einfügen, der Informationen zu den Daten im Hauptbericht enthält, muss das Unterbericht-Steuerelement mit dem Hauptbericht verknüpft sein. Die Verknüpfung stellt sicher, dass die im Unterbericht gedruckten Datensätze den im Hauptbericht gedruckten entsprechen.

Wenn Sie einen Unterbericht erstellen, entweder mit Hilfe eines Assistenten oder indem Sie einen Bericht oder ein Datenblatt aus dem Datenbankfenster auf einen anderen Bericht ziehen, synchronisiert Microsoft Access automatisch Haupt- und Unterbericht, sofern die folgenden Voraussetzungen erfüllt sind:

  • Sie haben Beziehungen für die ausgewählten Tabellen definiert, oder Sie haben Beziehungen für die den ausgewählten Abfragen zugrunde liegenden Tabellen definiert.

  • Der Hauptbericht basiert auf einer Tabelle mit einem Primärschlüssel und der Unterbericht auf einer Tabelle, die ein Feld enthält, das denselben Namen wie der Primärschlüssel hat und denselben oder einen kompatiblen Datentyp aufweist. Wenn beispielsweise der Primärschlüssel der dem Hauptformular zugrunde liegenden Tabelle ein Feld des Datentyps AutoWert ist und seine Feldgröße-Eigenschaft den Wert Long Integer besitzt, sollte das zugehörige Feld in der dem Unterformular zugrunde liegenden Tabelle vom Datentyp Zahl sein und seine Feldgröße-Eigenschaft den Wert Long Integer erhalten. Wenn Sie eine oder mehrere Abfragen auswählen, müssen die zugrunde liegenden Tabellen dieselben Bedingungen erfüllen.

Anmerkung Microsoft Access verwendet die Eigenschaften VerknüpfenNach und VerknüpfenVon des Unterbericht-Steuerelements, um den Hauptbericht mit dem Unterbericht zu verknüpfen. Verknüpft Access den Hauptbericht aus irgendeinem Grund nicht mit dem Unterbericht, können Sie diese Eigenschaften direkt festlegen.

Wie wird's gemacht?


 Verknüpfen eines Hauptberichts mit einem Unterbericht

Verknüpfen eines Hauptberichts mit einem Unterbericht

Wenn Sie einen Unterbericht mit Hilfe des Berichts-Assistenten oder des Unterberichts-Assistenten erstellen, verknüpft Microsoft Access unter bestimmten Bedingungen automatisch den Hauptbericht mit dem Unterbericht. Zum Anzeigen von Informationen klicken Sie auf [image] . Erfüllen Ihr Haupt- und Unterbericht diese Bedingungen nicht, können Sie sie mit Hilfe des nachfolgend beschriebenen Verfahrens verknüpfen.

  1. Öffnen Sie den Hauptbericht in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Unterbericht-Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster anzuzeigen.

  3. Geben Sie die Verknüpfungsfelder an. Wenn Sie mehrere Verknüpfungsfelder oder -steuerelemente angeben möchten, geben Sie die Feld- oder Steuerelementnamen durch ein Semikolon voneinander getrennt ein. In diesem Fall müssen Sie die Namen in den Einstellungsfeldern für die Eigenschaften Verknüpfen von und Verknüpfen nach in derselben Reihenfolge eingeben.
    • Geben Sie im Einstellungsfeld der Eigenschaft Verknüpfen von die Namen der Verknüpfungsfelder im Unterbericht ein.

    • Geben Sie im Einstellungsfeld der Eigenschaft Verknüpfen nach die Namen der Verknüpfungsfelder oder -steuerelemente im Hauptbericht ein.

    Anmerkung Im Einstellungsfeld der Eigenschaft VerknüpfenVon können Sie nicht den Namen eines Steuerelements verwenden.

    Wenn Sie nicht sicher sind, welches Feld als Verknüpfungsfeld zu verwenden ist, klicken Sie auf die Aufbauen-Schaltfläche [image] neben dem Einstellungsfeld für die Eigenschaft, um den Feldverknüpfungs-Assistenten für Unterberichte/Unterformulare zu öffnen.

Anmerkungen

  • Die Verknüpfungsfelder brauchen nicht im Haupt- oder Unterbericht enthalten zu sein. Sie müssen jedoch in die zugrunde liegende Datenherkunft einbezogen werden. Wenn Sie den Unterbericht mit Hilfe des Berichts-Assistenten erstellen, nimmt Microsoft Access die Verknüpfungsfelder automatisch in die zugrunde liegende Datenherkunft auf, auch wenn Sie sie im Assistenten nicht auswählen.

  • Die Verknüpfungsfelder müssen dieselbe Art von Daten, denselben oder einen kompatiblen Datentyp sowie dieselbe oder eine kompatible Feldgröße aufweisen. Ein Feld des Datentyps AutoWert ist z. B. mit einem Feld des Datentyps Zahl kompatibel, dessen Eigenschaft Feldgröße auf Long Integer eingestellt ist.

  • Um Informationen zur Fehlerbehandlung bei Unterberichten anzuzeigen, klicken Sie auf [image] .


 Erstellen eines mehrspaltigen Berichts

Erstellen eines mehrspaltigen Berichts

  1. Erstellen Sie einen Bericht.

    Wie wird's gemacht?

    Anmerkungen

    • Beim Druck eines mehrspaltigen Berichts nehmen der Berichtskopf und der Berichtsfuß sowie der Seitenkopf und der Seitenfuß die volle Berichtsbreite ein, so dass Sie in der Entwurfsansicht Steuerelemente an einer beliebigen Stelle dieser Bereiche positionieren können.

    • Nach dem Druck nehmen der Gruppenkopf und der Gruppenfuß sowie der Detailbereich eines mehrspaltigen Berichts die Breite einer Spalte ein. Zum Drucken der Daten in zwei Spalten von z.B. jeweils 6 cm Breite fügen Sie die Steuerelemente in der Entwurfsansicht in die ersten 6 cm dieser Bereiche ein.
  2. Klicken Sie im Menü Datei auf Seitenformat.

  3. Klicken Sie im Dialogfeld Seitenformat auf die Registerkarte Spalten.

  4. Geben Sie unter Rastereinstellungen im Feld Spaltenanzahl die für jede Seite gewünschte Spaltenanzahl ein.

  5. Geben Sie im Feld Zeilenabstand den Abstand ein, der im Detailbereich jeweils zwischen den einzelnen Datensätzen eingehalten werden soll.

    Anmerkung Wenn Sie zwischen dem letzten Steuerelement im Detailbereich und dem unteren Rand des Detailbereichs Abstand gelassen haben, können Sie die Einstellung 0 für Zeilenabstand beibehalten.

  6. Geben Sie im Feld Spaltenabstand den Abstand ein, der zwischen den Spalten eingehalten werden soll.

  7. Geben Sie unter Spaltengröße die gewünschte Breite für eine Spalte im Feld Breite ein, z.B. 6 cm. Sie können die Höhe des Detailbereichs festlegen, indem Sie eine Zahl im Feld Höhe eingeben oder die Höhe des Bereichs in der Entwurfsansicht anpassen.

  8. Klicken Sie unter Spaltenlayout auf eine der Optionen Nach unten, dann quer oder Quer, dann nach unten.

  9. Klicken Sie auf die Registerkarte Seite.

  10. Klicken Sie unter Orientierung auf Hochformat oder auf Querformat.

  11. Klicken Sie auf OK.

Anmerkungen

  • Um Informationen zum Beginnen jeder Gruppe in einer neuen Zeile oder Spalte anzuzeigen, klicken Sie auf [image] .

  • Der Bericht Artikel nach Kategorie in der Beispieldatenbank Nordwind zeigt Daten mehrspaltig an. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL im Office-Ordner und dann den Bericht Artikel nach Kategorie in der Entwurfsansicht. Um weitere Informationen über das Öffnen der Nordwind-Datenbank anzuzeigen, klicken Sie auf [image] .


 Erstellen eines Kreuztabellenberichts mit fixierten Spaltenüberschriften

Erstellen eines Kreuztabellenberichts mit fixierten Spaltenüberschriften

Erstellen der zugrunde liegenden Abfrage

  1. Erstellen Sie eine Kreuztabellenabfrage.

    Wie wird's gemacht?

  2. Zeigen Sie in der Entwurfsansicht für Abfragen das Eigenschaftenfenster der Abfrage an. Doppelklicken Sie hierzu auf eine beliebige Stelle außerhalb des Entwurfsbereichs und außerhalb der Feldlisten.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Fixierte Spaltenüberschriften die Spaltenüberschriften ein, die im Bericht angezeigt werden sollen. Trennen Sie dabei die einzelnen Überschriften jeweils durch ein Semikolon. Enthält eine Spaltenüberschrift Leerzeichen, schließen Sie sie in Anführungszeichen (" ") ein. Für eine Abfrage über vierteljährliche Umsätze geben Sie z. B. Folgendes ein:

    "1. Quartal";"2. Quartal";"3. Quartal";"4. Quartal"

Erstellen des Berichts

  1. Erstellen Sie einen leeren Bericht, der an die Kreuztabellenabfrage gebunden ist.

    Wie wird's gemacht?

  2. Fügen Sie die Steuerelemente für die Felder hinzu, die im Bericht angezeigt werden sollen.
    • Fügen Sie Bezeichnungsfelder für die Zeilen- und Spaltenüberschriften in den Seitenkopf ein.

    • Fügen Sie Textfelder für die Zeilenüberschriften und Spaltenwerte in den Detailbereich ein.


 Abbrechen des Drucks eines Berichts, wenn dieser keine Datensätze enthält

Abbrechen des Drucks eines Berichts, wenn dieser keine Datensätze enthält

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Berichtsmarkierer, um das Eigenschaftenfenster des Berichts anzuzeigen.

  3. Stellen Sie die Eigenschaft BeiOhneDaten auf [Ereignisprozedur] oder auf den Namen des Makros ein, das die Seitenansicht oder das Drucken des Berichts abbricht.
    • Wenn Sie ein Makro verwenden, können Sie mit der Aktion Warnmeldung eine Meldung anzeigen, die beschreibt, warum keine Daten für den Bericht existieren. Mit der Aktion AbbrechenEreignis können Sie dann das Drucken oder die Seitenansicht des Berichts abbrechen. Um Informationen zum Erstellen eines Makros anzuzeigen, klicken Sie auf [image] .

    • Wenn Sie eine Ereignisprozedur verwenden, können Sie mit der Anweisung MsgBox eine Meldung anzeigen. Setzen Sie dann das Argument Cancel der Sub-Prozedur Report_NoData- auf True. Um Informationen zum Anpassen einer Ereignisprozedur anzuzeigen, klicken Sie auf [image] .

Anmerkung Der Bericht Personalumsätze nach Land in der Beispieldatenbank Nordwind verwendet in der Eigenschaft BeiOhneDaten eine Ereignisprozedur. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL des Office-Ordners, und öffnen Sie dann den Bericht Personalumsätze nach Land in der Entwurfsansicht. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Drucken der Kriterien für einen Bericht im Berichtskopf

Drucken der Kriterien für einen Bericht im Berichtskopf

  1. In einer Microsoft Access-Datenbank (.MDB), erstellen Sie die Kriterienparameter in der dem Bericht zugrunde liegenden Abfrage. In einem Microsoft Access-Projekt (.ADP), erstellen Sie die Parameter in der dem Bericht zugrunde liegenden gespeicherten Prozedur.

  2. Öffnen Sie den Bericht in der Entwurfsansicht.

  3. Erstellen Sie für jeden Parameter, den Sie anzeigen möchten, ein ungebundenes Textfeld. Klicken Sie hierzu in der Toolbox auf das Steuerelement Textfeld Textfeld-Steuerelement und dann auf den Berichtskopf.

  4. Stellen Sie sicher, dass das Textfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster anzuzeigen.

  5. Führen Sie einen der folgenden Schritte aus:
    • Stellen Sie in einer Access-Datenbank die Eigenschaft Steuerelementinhalt auf den bzw. die Parameter ein, die Sie in der Abfrage in der Zelle Kriterien angegeben haben. Angenommen, die Parameter in der Abfrage lauten folgendermaßen:

      Zwischen [Geben Sie ein Anfangsdatum ein:] Und [Geben Sie ein Enddatum ein:]

      lauten und Sie sie in zwei Textfeldern anzeigen möchten, setzen Sie die Eigenschaft Steuerelementinhalt des einen Textfelds auf

      [Geben Sie ein Anfangsdatum ein:]

      und die Eigenschaft Steuerelementinhalt des anderen Textfelds auf

      [Geben Sie ein Enddatum ein:]

      Möchten Sie beide Parameter in einem einzigen Textfeld anzeigen, können Sie im Einstellungsfeld der Eigenschaft Steuerelementinhalt einen Ausdruck verwenden, z. B.:

      ="Zwischen " & [Geben Sie ein Anfangsdatum ein:] & " und " & [Geben Sie ein Enddatum ein:]

    • In einem Access-Projekt legen Sie für die Eigenschaft EingabeParameter des Berichts an eine Zeichenfolge die Parameter fest, die an die Gespeicherte Prozedur übergeben werden, an die der Bericht gebunden ist. Wie im folgenden Beispiel gezeigt, muss die Zeichenfolge ein Ausdruck sein, der die Parameter enthält, die Sie in der Gespeicherten Prozedur angegeben haben, und den Text, der in der Eingabeaufforderung angezeigt werden soll. Geben Sie den Aufforderungstext in eckigen Klammern an ([ ]):

      @Anfangsdatum datetime = [Anfangsdatum], @Enddatum datetime = [Enddatum]

      Legen Sie dann für die Eigenschaft Steuerelementinhalt eine Zeichenfolge fest, die die Parameter in der Gespeicherten Prozedur angibt, beliebigen Text, den Sie einfügen möchten, sowie in eckigen Klammern den Aufforderungstext, wie im folgenden Beispiel gezeigt:

      ="Verkäufe von "& [Anfangsdatum] &" bis "& [Enddatum]

  6. Um die Kriterien anzuzeigen, drucken Sie den Bericht oder zeigen ihn in der Vorschau an. Microsoft Access zeigt die Parameterwerte exakt in der Form an, in der Sie sie in die Eingabeaufforderung eingegeben haben.

Anmerkung Der Bericht Personalumsätze nach Land in der Beispieldatenbank Nordwind druckt die Kriterien im Berichtskopf. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und dann den Bericht Alphabetische Artikelliste in der Entwurfsansicht. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


Tipps zum Optimieren der Leistung von Berichten und Unterberichten

Sie können verschiedene Dinge tun, damit Ihre Berichte schneller gedruckt werden. Außer den unten aufgeführten Tipps können Sie mit Hilfe des Leistungsanalyse-Assistenten ausgewählte Berichte in Ihrer Datenbank analysieren. Um Informationen zum Verwenden des Leistungsanalyse-Assistenten anzuzeigen, klicken Sie auf [image] .

Tipps zur Leistungsverbesserung

  • Vermeiden Sie sich überlagernde Steuerelemente.

  • Gehen Sie sparsam mit der Verwendung von Bitmaps und anderen grafischen Objekten um.

  • Konvertieren Sie Objektfelder, die Grafiken anzeigen, in Bild-Steuerelemente.

  • Verwenden Sie schwarzweiße Bitmaps an Stelle von farbigen Bitmaps.

  • Vermeiden Sie das Sortieren und Gruppieren nach Ausdrücken.

  • Indizieren Sie Felder, nach denen Sie sortieren oder gruppieren.

  • Basieren Sie Unterberichte auf Abfragen statt auf Tabellen, und schließen Sie nur die unbedingt erforderlichen Felder aus der Datenherkunft ein. Zusätzliche Felder können die Leistung der Unterberichte verringern.

  • Indizieren Sie alle Felder im Unterbericht, die mit dem Hauptbericht verknüpft sind.

  • Indizieren Sie alle Felder im Unterbericht, die für Kriterien verwendet werden.

  • Verwenden Sie möglichst keine Domänen-Aggregatsfunktionen. Beziehen Sie das Feld der dem Bericht zugrunde liegenden Abfrage ein, oder verwenden Sie einen Unterbericht.

  • Stellen Sie sicher, dass die dem Bericht zugrunde liegende Abfrage optimiert ist.

  • Ermitteln Sie mit der Eigenschaft HasData oder dem Ereignis NoData, ob ein Bericht an eine leere Datensatzgruppe gebunden ist.


 Datenzugriffsseiten: Definition und Funktionsweise

Datenzugriffsseiten: Definition und Funktionsweise

Eine Datenzugriffsseite stellt einen speziellen Typ von Webseite dar, der der Anzeige und Bearbeitung von Daten einer Microsoft Access-Datenbank oder einer Microsoft SQL Server-Datenbank im Internet oder einem Intranet dient. Eine Datenzugriffsseite kann außerdem auch Daten aus anderen Quellen enthalten, beispielsweise Microsoft Excel-Daten.

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Entwerfen unterschiedlicher Arten von Datenzugriffsseiten

Verwenden von Datenzugriffsseiten in Internet Explorer

Verwenden von Datenzugriffsseiten in Microsoft Access

Entwerfen unterschiedlicher Arten von Datenzugriffsseiten

Sie entwerfen Datenzugriffseiten in der Seitenentwurfsansicht von Microsoft Access. Die Seite selbst ist eine separate Datei, die außerhalb von Microsoft Access gespeichert wird. Allerdings fügt Microsoft Access beim Erstellen der Datei automatisch eine Verknüpfung mit der Datei im Datenbankfenster hinzu. Das Entwerfen einer Datenzugriffsseite ähnelt dem Entwerfen von Formularen und Berichten - Sie benutzen dazu eine Feldliste, die Toolbox, das Dialogfeld Sortieren und gruppieren usw. Aber es gibt einige wichtige Unterschiede, die das Entwerfen von Datenzugriffsseiten im Vergleich zum Entwerfen von Formularen und Berichten kennzeichnen. Der Entwurf einer Seite hängt wesentlich von ihrem Verwendungszweck ab:

  • Interaktive Datenauswertung Datenzugriffsseiten dieses Typs werden häufig zur Zusammenfassung und Gruppierung von in der Datenbank gespeicherten Informationen verwendet, die dann als Übersichtsinformationen veröffentlicht werden. Beispielsweise könnte eine solche Seite die Umsatzzahlen für alle Bereiche, in denen Sie arbeiten, veröffentlichen. Unter Verwendung von Erweiterungssymbolen könnten Sie dann, ausgehend von einer allgemeinen Zusammenfassung der Informationen (beispielsweise einer Liste aller Bereiche und der zugehörigen Gesamtumsatzsumme), zu speziellen Details einzelner Geschäftsabschlüsse innerhalb eines jeden Bereich gelangen. Während diese Art von Seite auch Schaltflächen zum Sortieren und und Filtern bereitstellen kann, ist es hier nicht möglich, die Daten der Seite zu bearbeiten. Ein Beispiel und weitere Informationen dazu finden Sie unter dem Thema Datenzugriffsseiten zur Gruppierung von Daten für die interaktive Datenauswertung.

  • Dateneingabe Eine Datenzugriffsseite dieses Typs wird zum Anzeigen, Bearbeiten und Hinzufügen von Datensätzen verwendet. Der folgende Hyperlink führt zu weiteren Informationen über Datenzugriffsseiten für die Dateneingabe.

  • Datenanalyse Eine Datenzugriffsseite dieses Typs kann ein Element des Typs PivotTable-Liste enthalten, ähnlich wie ein Microsoft Access PivotTable-Formular oder ein Microsoft Excel PivotTable-Bericht. PivotTable-Listen ermöglichen es Ihnen, die Daten durch Neuorganisation auf unterschiedliche Weisen zu analysieren. Eine Seite dieses Typs kann außerdem ein Diagramm enthalten, mit dem Sie Trends analysieren, Muster erkennen und Daten Ihrer Datenbank vergleichen können. Eine solche Seite kann auch eine Kalkulationstabelle enthalten, in der Sie Daten eingeben und bearbeiten sowie Formeln zur Berechnung von Werten verwenden können - genauso, wie Sie es gewöhnlich auch in Microsoft Excel tun. Der folgende Hyperlink führt zu einem Beispiel einer Datenzugriffsseite, die zur Datenanalyse verwendet wird.

Zurück zum Anfang

Verwenden von Datenzugriffsseiten in Internet Explorer

Eine Datenzugriffsseite wird direkt mit einer Datenbank verbunden. Wenn Benutzer die Datenzugriffsseite in Microsoft Internet Explorer anzeigen, betrachten sie eine Kopie der Seite. Das heißt, dass jedes Filtern, Sortieren oder Ändern der Datenanzeige (einschließlich Änderungen innerhalb einer PivotTable-Liste oder einer Kalkulationstabelle) nur die eigene Kopie der Datenzugriffsseite betrifft. Nur solche Änderungen, die an den Daten selbst erfolgen (also Änderungen von Werten, Hinzufügen und Löschen von Daten), werden in der zugrunde liegenden Datenbank gespeichert und sind deshalb allen Benutzern verfügbar, die die Datenzugriffsseite anzeigen.

Benutzer können Hilfeinformationen über die Handhabung einer Seite in Internet Explorer abrufen, indem sie auf die Schaltfläche Hilfe [image] in der Datensatznavigationsleiste klicken. Die dann angezeigte Hilfedatei ist automatisch Zubehör jeder Datenzugriffsseite, die mit einer Datensatznavigationsleiste veröffentlicht wird. Wenn Sie die Datensatznavigationsleiste entfernen oder die Schaltfläche Hilfe deaktivieren, sollten Sie den Benutzern der Seite eine Anleitung zu ihrer Benutzung zur Verfügung stellen.

Anmerkung Um eine Datenzugriffsseite anzuzeigen oder mit ihr zu arbeiten, benötigen Benutzer Microsoft Internet Explorer, Version 5, und eine Microsoft Office 2000-Lizenz.

Zurück zum Anfang

Verwenden von Datenzugriffsseiten in Microsoft Access

Die Arbeit mit einer Datenzugriffsseite kann auch in der Seitenansicht in Microsoft Access erfolgen. Datenzugriffsseiten können dabei zusätzlich zu den Formularen und Berichten der Datenbankanwendung ergänzende Aufgaben übernehmen. Bei der Überlegung, ob Sie eine Datenzugriffsseite, ein Formular oder einen Bericht erstellen möchten, sollten Sie die Aufgaben berücksichtigen, die Sie erledigen möchten.

Benutzer können Hilfeinformationen über die Handhabung einer Seite abrufen, indem sie in der Symbolleiste der Seitenansicht auf die Schaltfläche Hilfe klicken, um die Online-Hilfe für Access aufzurufen. Wenn sie in der Datensatznavigationsleiste einer Seite auf die Schaltfläche Hilfe klicken, erhalten die Benutzer Hilfeinformationen über die Handhabung der Seite in Internet Explorer. Wie bereits erwähnt, ist diese Hilfedatei automatisch Zubehör jeder Datenzugriffsseite, die mit einer Datensatznavigationsleiste veröffentlicht wird. Sie können die Schaltfläche Hilfe entfernen, wenn die Seite nur innerhalb von Access verwendet werden soll, oder Sie können sie modifizieren, um benutzerdefinierte Hilfeinformationen bereitzustellen.

Zurück zum Anfang

Weitere Informationen

Erstellen einer Datenzugriffsseite


 Erstellen von Datenzugriffsseiten

Erstellen von Datenzugriffsseiten

Zum Erstellen einer Datenzugriffsseite oder zum Öffnen einer Seite in der Entwurfsansicht, der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer müssen Sie Internet Explorer 5 installieren (oder eine spätere Version), falls dies noch nicht geschehen ist.

Was möchten Sie tun?

Eine Datenzugriffsseite mit Hilfe von AutoSeite erstellen Bei AutoSeite brauchen Sie nur eine Datenherkunft auszuwählen, und AutoSeite erstellt eine Seite mit allen Feldern dieser Datenherkunft.

Eine Datenzugriffsseite mit Hilfe eines Assistenten erstellen Der Assistent stellt Ihnen detaillierte Fragen über die gewünschten Datenherkünfte, Felder, Layouts und Formate und erstellt eine Seite anhand Ihrer Angaben.

Eine vorhandene Webseite in eine Datenzugriffsseite umwandeln

Eine Datenzugriffsseite selbst erstellen


 Sollte ein Formular, ein Bericht, ein Bericht-Snapshot oder eine Datenzugriffsseite verwendet werden?

Sollte ein Formular, ein Bericht, ein Bericht-Snapshot oder eine Datenzugriffsseite verwendet werden?

Jedes Microsoft Access-Datenbankobjekt wurde für einen bestimmten Zweck entworfen. In der folgenden Tabelle bezeichnet Ja die Objekte, die eine bestimmte Aufgabe am besten ausführen können, Möglich bezeichnet die Objekte, die die Aufgabe zwar ausführen können, jedoch nicht optimal dafür geeignet sind, und Nein bezeichnet die Objekte, die die Aufgabe nicht ausführen können.

Aufgabe/Zweck | Formular | Bericht | Bericht-Snapshot | Datenzugriffsseite
Eingeben und Bearbeiten von sowie Interagieren mit Daten innerhalb einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt | Ja | Nein | Nein | Ja
Eingeben und Bearbeiten von sowie Interagieren mit veränderlichen Daten über das Internet oder ein Intranet außerhalb einer Access-Datenbank oder eines Access-Projekts; Benutzer müssen über eine Lizenz für Microsoft Office 2000 verfügen, Office jedoch nicht installiert haben | Nein | Nein | Nein | Ja
Drucken von Daten für die Verbreitung | Möglich | Ja | Ja | Möglich
Verteilen von Daten über E-Mail | Nein | Nein | Ja (statische Daten) | Ja (veränderliche Daten)


 Strategien für das Erstellen von Datenzugriffsseiten

Strategien für das Erstellen von Datenzugriffsseiten

Was möchten Sie mit Ihrer Datenzugriffsseite erreichen? Es gibt viele Features, die Sie zum Erstellen von effektiven Datenzugriffsseiten verwenden können. Dieses Thema unterstützt Sie dabei, die richtigen Features und das richtige Layout zu finden, das Sie für die einzelnen Seitentypen verwenden können. Es gibt vier Typen von Datenzugriffsseiten. Diese können für Folgendes verwendet werden:

Analysieren von Daten

Eingeben und Bearbeiten von Daten

Erstellen von Projektionen

Überprüfen von Daten

Analysieren von Daten

Sie können für das Analysieren von Daten eine PivotTable-Liste verwenden, da diese es Ihnen ermöglicht, die Daten auf unterschiedliche Weise zu reorganisieren. Sie können eine PivotTable-Liste an Daten in der Datenbank binden oder Daten aus einer Microsoft Excel-Tabelle verwenden. Sie können die PivotTable-Liste als einziges Steuerelement auf einer Datenzugriffsseite verwenden oder zusammen mit anderen Steuerelementen.

  • Wenn Sie eine PivotTable-Liste auf einer nicht gruppierten Seite verwenden, platzieren Sie das Steuerelement für die PivotTable-Liste und andere Steuerelemente entweder in den Hauptteil oder in den Bereich.

  • Wenn Sie eine PivotTable-Liste auf einer gruppierten Datenzugriffsseite verwenden:
    • Platzieren Sie die PivotTable-Liste und gebundene Steuerelemente in den Bereich.

    • Stellen Sie sicher, dass die PivotTable-Liste der niedrigsten Gruppierungsebene angehört.

    • Wenn die PivotTable-Liste das einzige Steuerelement in einem Bereich ist, löschen Sie den Navigationsbereich für die Gruppierungsebene, zu der die PivotTable-Liste gehört, oder blenden Sie ihn aus.

    • Stellen Sie sicher, dass die Datenseitengröße-Eigenschaft im Fenster Sortieren und gruppieren auf 1 festgelegt ist.

Erstellen einer PivotTable-Liste auf einer Datenzugriffsseite.

Zurück zum Anfang

Eingeben und Bearbeiten von Daten

Sie können eine Datenzugriffsseite erstellen, auf der Daten in der Datenbank eingegeben, bearbeitet und gelöscht werden können. Beim Erstellen einer Seite für die Dateneingabe sollten folgende wichtige Punkte beachtet werden:

  • Verwenden Sie einzelne Steuerelemente, wie z. B. Textfelder, Listenfelder, Dropdownlisten, Optionsgruppen, Optionsfelder und Kontrollkästchen.

  • Platzieren Sie Steuerelemente entweder in das Hauptteil oder in den Bereich. Sie können den Bereich löschen, falls Sie ihn nicht verwenden.

  • Erstellen Sie nur eine Gruppierungsebene. Im Fenster Sortieren und gruppieren wird nur eine Gruppendatensatzquelle aufgelistet.

  • Stellen Sie sicher, dass die Datenseitengröße-Eigenschaft im Fenster Sortieren und gruppieren auf 1 festgelegt ist.

  • Verwenden Sie die Spreadsheet-Komponente zum Erstellen einer Kalkulationstabelle, um eine oder mehrere Berechnungen mit den Feldern in einem Datensatz durchzuführen. Sie können die berechneten Werte in der Kalkulationstabelle anzeigen oder die Kalkulationstabelle ausblenden und die berechneten Werte in gebundenen HTML-Steuerelementen anzeigen.

  • Bestimmen Sie, wie Benutzer/innen die Datenzugriffsseite verwenden können, indem Sie die Datensatznavigationsleiste anpassen.

  • Wenn Sie Daten aus Tabellen bearbeiten wollen, die eine 1:n-Beziehung besitzen, erstellen Sie eine Seite, die an die Tabelle auf der "Eins"-Seite der Beziehung gebunden ist, und eine weitere Datenzugriffsseite, die an die "n"-Seite gebunden ist. Anschließend können Sie das Dialogfeld Hyperlink einfügen verwenden, um einen Hyperlink zwischen den zwei Datenzugriffsseiten zu erstellen. Um die Daten aus beiden Seiten auf einer Seite anzuzeigen, können Sie einen HTML-Editor (z. B. Microsoft FrontPage) zum Erstellen von Frames verwenden.

Weitere Informationen über Erstellen einer Datenzugriffsseite für die Dateneingabe.

Zurück zum Anfang

Erstellen von Projektionen

Sie können die Chart-Komponente zum Erstellen eines Diagramms verwenden, um Trends zu analysieren, Muster aufzuzeigen und Vergleiche mit den Daten in Ihrer Datenbank anzustellen, oder Sie können ein Spreadsheet-Steuerelement verwenden, in dem Sie Daten eingeben und bearbeiten sowie Formeln verwenden können, um einige der gleichen Berechnungen durchzuführen, die auch in Excel möglich sind.

  • Wenn Sie ein Spreadsheet-Steuerelement auf einer nicht gruppierten Datenzugriffsseite verwenden, platzieren Sie das Chart-Steuerelement und andere Steuerelemente entweder in den Rumpf oder in den Bereich.

  • Wenn Sie ein Spreadsheet-Steuerelement auf einer gruppierten Datenzugriffsseite verwenden, platzieren Sie das Spreadsheet-Steuerelement und andere Steuerelemente, die an Felder in der Datenbank gebunden sind, in den Bereich. Ein Spreadsheet-Steuerelement kann in jeder Gruppierungsebene verwendet werden.

  • Stellen Sie sicher, dass die Datenseitengröße-Eigenschaft im Fenster Sortieren und gruppieren für den Bereich, der das Chart-Steuerelement enthält, auf 1 festgelegt ist.

Erstellen einer Kalkulationstabelle auf einer Datenzugriffsseite.

Erstellen eines Diagramms auf einer Datenzugriffsseite.

Zurück zum Anfang

Überprüfen von Daten

Datenzugriffsseiten ermöglichen es Ihnen, selektiv mit großen Datenmengen zu interagieren. Durch Erweitern und Reduzieren von Gruppen von Datensätzen können sich Benutzer/innen nur auf die Daten konzentrieren, die sie sehen möchten. Beim Erstellen einer gruppierten Seite sollten die folgenden Punkte beachtet werden:

  • Platzieren Sie gebundene Steuerelemente in den Bereich.

  • Verwenden Sie auf der untersten Gruppierungsebene einzelne Steuerelemente oder eine PivotTable-Liste, um Detaildatensätze anzuzeigen.

  • Entfernen Sie unbenutzte Schaltflächen aus der Datensatznavigationsleiste.

  • So beschleunigen Sie das Laden der Datenzugriffsseite in Microsoft Internet Explorer:
    • Verwenden Sie gebundene HTML-Steuerelemente an Stelle von Textfeldern.

    • Legen Sie die Standardmäßig erweitert-Eigenschaft für alle Gruppierungsebenen auf Nein fest.

    • Legen Sie die Datenseitengröße-Eigenschaft im Fenster Sortieren und gruppieren, die die Anzahl der in einer Gruppe auf einer Seite angezeigten Datensätze bestimmt, auf eine niedrige statt einer hohen Anzahl oder auf Alle fest. Je geringer die Anzahl, desto schneller werden die Datensätze angezeigt.

Erstellen einer Datenzugriffsseite, die Datensätze gruppiert.

Zurück zum Anfang


 Info über Datenzugriffsseiten für die Dateneingabe

Info über Datenzugriffsseiten für die Dateneingabe

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Verwenden einer Datenzugriffsseite für die Dateneingabe

Dateneingabeseite in der Entwurfsansicht

Dateneingabeseite in der Seitenansicht oder im Internet Explorer

Verwenden einer Datenzugriffsseite für die Dateneingabe

Die Dateneingabe über eine Datenzugriffsseite ist ähnlich zu handhaben wie die entsprechende Operation mit einem Dateneingabeformular: Sie können Daten in eine Datenbank eingeben, sie bearbeiten und löschen. Allerdings können Sie eine Datenzugriffsseite außerhalb einer Microsoft Access-Datenbank einsetzen, so dass Benutzer mit einer Microsoft Office 2000-Lizenz in der Lage sind, ihre Daten über das Internet oder ein Intranet zu aktualisieren.

Die folgende Abbildung zeigt die Datenzugriffsseitenansicht (bzw. die Ansicht in Microsoft Internet Explorer 5 oder später) der Datenzugriffsseite Produkte, die zur Eingabe und Aktualisierung von Produktinformationen dient.

Dateneingabe in der Seitenansicht

Zurück zum Anfang

Datenzugriffsseite in der Entwurfsansicht

Der Detailbereich Der Detailbereich bildet den für den Entwurf grundlegenden Ausschnitt einer Datenzugriffsseite. In einer Dateneingabeseite kann er dazu verwendet werden, Informationen in Textform, mit Daten verknüpfte Steuerelemente und Bereiche anzuzeigen. Die Positionen von Texten, Bereichen und anderen Elementen innerhalb des Detailbereichs sind relativ. Elemente gehen also in der Reihenfolge ineinander über, in der sie im HTML-Quelltext erscheinen. Die Position eines Elements innerhalb des Detailbereichs wird durch den vorhergehenden Inhalt bestimmt. Bei Anzeige in der Seitenansicht oder mit dem Internet Explorer passt sich der Inhalt des Detailbereichs der Größe des Webbrowser-Fensters an.

Bereiche Sie dienen der Anzeige von Text, Daten aus einer Datenbank und Symbolleisten. Die Positionen von Steuerelementen und anderen Elementen innerhalb eines Bereichs sind standardmäßig absolut. Jedes Steuerelement oder Element ist also bezüglich der Koordinaten der oberen und linken Ränder des Bereichs festgelegt. Steuerelemente mit absoluten Positionen innerhalb eines Bereichs behalten ihre Positionen auch, wenn Sie die Größe des Browserfensters ändern.

Es gibt zwei Arten von Bereichen, die normalerweise in Dateneingabeseiten verwendet werden: Gruppenkopfbereiche und Bereiche für die Datensatznavigation. Innerhalb einer Dateneingabeseite können Sie nur eine Gruppierungsebene verwenden. Deshalb steht der Gruppenfußbereich nicht zur Verfügung, aber Sie können einen Beschriftungsbereich verwenden.

  • Gruppenkopf Wird zur Anzeige von Daten und berechneten Werten verwendet.

  • Datensatznavigation Dient der Anzeige des Steuerelements zur Datensatznavigation auf Gruppierungsebene. Ein Bereich für die Datensatznavigation einer Gruppe erscheint hinter dem Gruppenkopfbereich. Es ist nicht möglich, gebundene Steuerelemente in einem Bereich zur Datensatznavigation zu platzieren.

  • Beschriftung Dient der Anzeige von Beschriftungen für Textfelder und andere Steuerelemente. Dieser Bereich erscheint unmittelbar vor dem Gruppenkopf. In einem Beschriftungsbereich können keine gebundenen Steuerelemente platziert werden.

Jeder Gruppierungsebene einer Datenzugriffsseite ist eine Datenquelle zugeordnet. Der Name der Datenquelle wird in der Bereichsleiste eines für eine Gruppierungsebene verwendeten Bereichs angezeigt. Die folgende Abbildung zeigt die Datenzugriffsseite Produkte in der Entwurfsansicht.

Teil einer Dateneingabeseite in der Entwurfsansicht

Zurück zum Anfang

Dateneingabeseite in der Seitenansicht oder im Internet Explorer

Die folgende Abbildung illustriert, wie die Bereiche der Datenzugriffsseite Produkte nach dem Öffnen der Seite in der Seitenansicht bzw. im Internet Explorer angezeigt werden. Dateneingabe und -bearbeitung ist mit Datenzugriffsseiten möglich, die nur eine Gruppierungsebene beinhalten und die nur einen Datensatz anzeigen. Um einen Datensatz anzuzeigen, weisen Sie in der Entwurfsansicht im Feld Sortieren und gruppieren der DataPageSize-Eigenschaft der Gruppierungsebene den Wert 1 zu.

Bereiche einer Dateneingabeseite in der Seitenansicht

Zurück zum Anfang

Weitere Informationen

Erstellen einer Datenzugriffsseite


 Gruppieren von Datensätzen in einer Datenzugriffsseite

Gruppieren von Datensätzen in einer Datenzugriffsseite

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Vorteile, die sich aus der Gruppierung von Datensätzen in einer Datenzugriffsseite ergeben

Entwurfsansicht einer Datenzugriffsseite mit Gruppierung der Datensätze

Datenzugriffsseitenansicht (bzw. Internet Explorer 5-Ansicht) einer Datenzugriffsseite mit Gruppierung der Datensätze

Vorteile, die sich aus der Gruppierung von Datensätzen in einer Datenzugriffsseite ergeben

Die Gruppierung von Datensätzen innerhalb einer Datenzugriffsseite ähnelt der Gruppierung von Datensätzen in einem Bericht: Sie können eine Hierarchie definieren, die die Datensätze ausgehend von allgemeinen Kategorien immer weiter verfeinert. Allerdings weisen Datenzugriffsseiten einige Vorteile gegenüber gedruckten Berichten auf.

  • Seiten, die an Daten einer Datenbank gebunden sind, zeigen aktuelle Daten an, da sie mit einer Datenbank verbunden sind.

  • Seiten sind interaktiv. Die Benutzer können die gewünschten Datensätze filtern, sortieren und anzeigen.

  • Seiten lassen sich auf elektronischem Wege über E-Mail verteilen. Die Empfänger erhalten beim Öffnen der Nachricht nur aktuelle Daten angezeigt.

Die folgende Abbildung zeigt ein Beispiel einer Datenzugriffsseite (Bestellungen, sortiert nach Bestelldatum). Diese Seite listet nach Bestelldatum sortiert die Auftragsvolumina auf. Die Darstellung zeigt die Seitenansicht bzw. die Ansicht in Microsoft Internet Explorer 5 oder höher.

Datenzugriffsseite mit erweiterter Darstellung einer Gruppe

Zurück zum Anfang

Entwurfsansicht einer Datenzugriffsseite mit Gruppierung der Datensätze

Der Detailbereich Der Detailbereich bildet den für den Entwurf grundlegenden Ausschnitt einer Datenzugriffsseite. In einer Seite mit Datengruppierung kann er dazu verwendet werden, Informationen in Textform und Bereiche anzuzeigen. Die Positionen von Texten, Bereichen und anderen Elementen innerhalb des Detailbereichs sind relativ. Elemente gehen also in der Reihenfolge ineinander über, in der sie im HTML-Quelltext erscheinen. Die Position eines Elements innerhalb des Detailbereichs wird durch den vorhergehenden Inhalt bestimmt. Bei Anzeige in der Seitenansicht oder mit Internet Explorer passt sich der Inhalt des Detailbereichs der Größe des Webbrowser-Fensters an.

Bereiche Sie dienen der Anzeige von Text, Daten aus einer Datenbank und Symbolleisten. Die Positionen von Steuerelementen und anderen Elementen innerhalb eines Bereichs sind standardmäßig absolut. Jedes Steuerelement oder Element ist also bezüglich der Koordinaten des oberen und des linken Bereichsrandes festgelegt. Steuerelemente mit absoluten Positionen innerhalb eines Bereichs behalten ihre Positionen auch bei, wenn Sie die Größe des Browserfensters ändern.

Innerhalb einer Datenzugriffsseite mit Datengruppierung gibt es vier Arten von Bereichen: Gruppenkopf, Gruppenfuß, Beschriftung und Datensatznavigation. Sie brauchen nur die Bereiche zu verwenden, die Sie für eine Gruppierungsebene benötigen.

  • Gruppenkopf Wird zur Anzeige von Daten und berechneten Werten verwendet. Um Daten zu gruppieren, müssen Sie mindestens zwei Gruppierungsebenen definiert haben. Der Gruppenkopf der untersten Ebene ähnelt dem Detailbereich eines Berichts, insofern er sich wiederholt, bis alle Datensätze der aktuellen Gruppe angezeigt sind.

  • Gruppenfuß Dient hauptsächlich der Berechnung von Summen. Er erscheint vor dem Bereich für die Datensatznavigation der Gruppierungsebene. Für die unterste Gruppierungsebene einer Datenzugriffsseite ist kein Gruppenfuß verfügbar.

  • Beschriftung Dient der Anzeige von Titeln für Datenspalten. Dieser Bereich befindet sich unmittelbar vor dem Gruppenkopf und wird nur angezeigt, wenn die nächsthöhere Gruppierungsebene erweitert wird. Innerhalb eines Beschriftungsbereichs können keine gebundenen Steuerelemente platziert werden.

  • Datensatznavigation Dient der Anzeige des Datensatznavigationssteuerelements für die Gruppierungsebene. Ein Bereich für die Datensatznavigation einer Gruppe erscheint hinter dem Gruppenkopfbereich, sofern es für die Gruppe keinen Gruppenfuß gibt. Andernfalls erscheint dieser Bereich hinter dem Gruppenfuß. Innerhalb eines Datensatznavigationsbereichs können keine gebundenen Steuerelemente platziert werden.

Jeder Gruppierungsebene ist eine Datenherkunft zugeordnet. Der Name der Datenquelle wird in der Bereichsleiste eines für eine Gruppierungsebene verwendeten Bereichs angezeigt. Die folgende Abbildung zeigt die Datenzugriffsseite Bestellungen in der Entwurfsansicht.

Bereiche einer Datenzugriffsseite mit zwei Gruppierungsebenen

Zurück zum Anfang

Seitenansicht (bzw. Internet Explorer 5-Ansicht) einer Datenzugriffsseite mit Gruppierung der Datensätze

Die folgende Abbildung zeigt dieselbe Datenzugriffseite und ihre Bereiche in der Seitenansicht bzw. in der Darstellung von Internet Explorer 5 oder später. Sie können die Anzahl der Datensätze festlegen, die innerhalb der Seite für jede Gruppierungsebene angezeigt werden sollen, indem Sie die DataPageSize-Eigenschaft im Feld Sortieren und gruppieren in der Entwurfsansicht mit einem entsprechenden Wert belegen. In der Beispielseite hat Datenseitengröße den Wert 2 für die Gruppierungsebene BestellteEinheiten-Bestelldatum und den Wert Alle für die Gruppierungsebene BestellteEinheiten.

Datenzugriffsseite mit Datengruppierung und einer Gruppe in erweiterter Anzeige

Zurück zum Anfang

Weitere Informationen

Erstellen einer Datenzugriffsseite mit Datensatzgruppierung.

Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach Intervallen von Werten des Typs Autowert, Währung oder Zahl

Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach datums- oder zeitangabenbezogenen Intervallen

Zusatzinfo: Gruppieren von Datensätzen nach Maßgabe der ersten n Zeichen eines Textwerts in einer Datenzugriffsseite


 Verbinden einer Datenzugriffsseite oder anderen Webseite mit einer Datenbank

Verbinden einer Datenzugriffsseite oder anderen Webseite mit einer Datenbank

Wenn beim Erstellen einer Datenzugriffsseite oder beim Öffnen einer außerhalb von Access erstellten Webseite in Microsoft Access keine Datenbank geöffnet ist, werden Sie von Access nach Verbindungsinformationen gefragt. Wenn Sie die Verbindungsinformationen nicht angeben, wenn Sie dazu aufgefordert werden, müssen Sie sie nach Öffnen der Seite angeben; andernfalls können Sie keine Datenbankdaten in die Seite einbinden. Darüber hinaus müssen Sie die Verbindungsinformationen für die Seite ändern, wenn Sie die Position einer Datenbank nach Erstellen einer Datenzugriffsseite ändern, die die ursprüngliche Position in ihrer ConnectionString-Eigenschaft speichert.

  1. Zeigen Sie die Feldliste in der Entwurfsansicht einer Datenzugriffsseite an.

  2. Klicken Sie mit der rechten Maustaste auf das Symbol der Datenbank oben auf der Liste.

  3. Klicken Sie im Kontextmenü auf Verbindung.

  4. Geben Sie die Verbindungsinformationen für die Datenbank, die Sie für die Datenzugriffsseite verwenden möchten, an.

    Um weitere Informationen über das Dialogfeld Verbindung zu erhalten, klicken Sie auf die Schaltfläche Hilfe am unteren Ende des Dialogfelds.

Anmerkungen

  • Wenn Sie beim Erstellen einer Datenzugriffsseite oder beim Öffnen einer außerhalb von Microsoft Access erstellten Webseite bereits eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt geöffnet haben, wird die Seite automatisch mit der geöffneten Datenbank verbunden und diese Verbindungsinformationen werden in ihrer ConnectionString-Eigenschaft gespeichert.

  • Sie können die ConnectionString-Eigenschaft auch direkt im Eigenschaftenfenster der Datenzugriffsseite ändern.

  • Möglicherweise verfügt eine PivotTable-Liste auf der Datenzugriffsseite über eine separate Verbindungszeichenfolge, wenn Daten aus einer externen Datenquelle angezeigt werden. Sie können die Verbindungsinformationen für die PivotTable-Liste innerhalb von Access unter Verwendung des Verbindungseditors im Bereich Datenquelle der PivotTable-Eigenschaftentoolbox ändern.


 Woher kommen die Daten einer Datenzugriffsseite?

Woher kommen die Daten einer Datenzugriffsseite?

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datenquellen für eine Datenzugriffsseite

Datenquellen für Microsoft Office Web Components in einer Datenzugriffsseite

Datenquellen für eine Datenzugriffsseite

Eine Datenzugriffsseite erhält ihre Daten von einer Microsoft Access Datenbank oder einer Microsoft SQL Server-Datenbank (Version 6.5 oder später). Soll eine Seite entworfen werden, die Daten aus einer dieser Datenbanken verwendet, so muss die Seite mit der Datenbank verbunden werden. Wenn Sie bereits eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt mit einer Verbindung zu einer Microsoft SQL Server-Datenbank geöffnet haben, wird die von Ihnen erstellte Datenzugriffsseite automatisch mit der aktuellen Datenbank verbunden und der entsprechende Pfad in der ConnectionString-Eigenschaft der Datenzugriffsseite gespeichert. Ruft ein Benutzer die Seite mit Internet Explorer 5 auf oder zeigt er die Seite in der Datenzugriffsseitenansicht an, so werden die aktuellen Daten aus der zugrunde liegenden Datenbank unter Verwendung der in der ConnectionString-Eigenschaft definierten Pfadangabe angezeigt. Erfolgt der Entwurf der Datenzugriffsseite unter Verwendung einer auf einem lokalen Laufwerk gespeicherten Datenbank, so benutzt Microsoft Access den lokalen Pfad, so dass die Daten für andere Benutzer nicht verfügbar sind. Deshalb ist es wichtig, dass Sie die Datenbank an eine über das Netzwerk zugängliche Stelle verschieben oder kopieren, so dass alle diejenigen, für die die Seite bestimmt ist, auch darauf zugreifen können. Sobald sich die Datenbank an der im Netzwerk freigegebenen Stelle befindet, öffnen Sie die Datenbank unter Verwendung der UNC-Adresse. Ist die Seite bereits fertig entworfen, wenn Sie die Datenbank verschieben oder kopieren, so müssen Sie den Pfad in der ConnectionString-Eigenschaft aktualisieren, so dass dieser auf die neue Position verweist.

Ist die Datenzugriffsseite mit einer Datenbank verbunden, so zeigt die Registerkarte Datenbank alle in der Datenbank verfügbaren Tabellen oder Abfragen an. Aus diesen Datenquellen werden Daten zur Datenquelle hinzugefügt. Wenn das Datenbanksymbol ein rotes X anzeigt und darunter keine Ordner aufgelistet sind, müssen Sie die Datenzugriffsseite mit einer Datenbank verbinden, um mit dem Entwurf der Seite fortfahren zu können.

Zurück zum Anfang

Datenquellen für Microsoft Office Web Compnents in einer Datenzugriffsseite

Obwohl die Datenzugriffsseite ihre Daten von einer Microsoft Access- oder Microsoft SQL Server-Datenbank erhält, sind Steuerelemente des Typs Microsoft Office Web Component in der Lage, sowohl Daten von diesen Datenbanken als auch Daten aus anderen Quellen anzuzeigen. Die Seite mag beispielsweise eine PivotTable-Liste, eine Kakulationstabelle oder ein Diagramm mit Daten aus einer Microsoft Excel-Arbeitsmappe oder einer Datenbank enthalten, die keine Microsoft Access- oder Microsoft SQL Server-Datenbank ist. Je nach Datenquelle handelt es sich bei den Daten dieser Steuerelemente um eine Kopie der ursprünglichen Daten oder um aktuelle Daten, die über eine separate Verbindung angezeigt werden, die zwischen dem Steuerelement und seiner Datenquelle eingerichtet ist.

Um eine Webkomponente zu erstellen, die ihre Daten nicht aus der aktuellen Datenbank, sondern aus einer anderen Datenquelle bezieht, müssen Sie möglicherweise ein anderes Programm als Microsoft Access verwenden, um die Daten zum ersten Male auf einer Webseite zu veröffentlichen. Wenn Sie beispielsweise eine Pivot-Tabelle mit Daten aus einer Microsoft Excel-Arbeitsmappe erstellen möchten, müssen Sie die Daten mit Microsoft Excel veröffentlichen. Anschließend können Sie in Microsoft Access die Webseite öffnen und in eine Datenzugriffsseite umwandeln, indem Sie Steuerelemente hinzufügen, die an eine Microsoft Access- bzw. Microsoft SQL Server-Datenbank gebunden sind. Darüber hinaus können Sie das Erscheinunngsbild der Seite durch Hinzufügen von Bezeichnungsfeldern, Bildern oder anderen Elementen anreichern. Sie haben außerdem die Möglichkeit, aus Microsoft Access heraus ein PivotTable-Steuerelement zu erstellen, das nicht nur Microsoft Excel-Daten, sondern auch Daten aus anderen externen Quellen verwenden kann. Dazu geben Sie bei Erstellung des Steuerelements entsprechende Informationen im Datenquellen-Bereich der PivotTable-Eigenschaft an.

Zurück zum Anfang

Weitere Informationen

Microsoft Office Web Components

OLE DB und Datenlinks


 Öffnen einer Datenzugriffsseite

Öffnen einer Datenzugriffsseite

Zum Erstellen einer Datenzugriffsseite oder zum Öffnen einer Seite in der Entwurfsansicht, in der Seitenansicht oder in Microsoft Internet Explorer müssen Sie ggf. Internet Explorer 5 oder höher installieren.

Öffnen einer Seite in der Entwurfsansicht oder der Seitenansicht

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie auf die Datenzugriffsseite, die Sie öffnen möchten.

  3. Führen Sie in der Symbolleiste des Datenbankfensters einen der folgenden Schritte aus:
    • Klicken Sie zum Öffnen der Seite in der Entwurfsansicht auf die Schaltfläche Entwurf.

    • Klicken Sie zum Öffnen der Seite in der Datenzugriffsseitenansicht auf die Schaltfläche Öffnen.

Anmerkung Sie können zum Öffnen einer Seite in der Datenzugriffsseitenansicht auch in Microsoft Access im Menü Datei auf Öffnen klicken. Access öffnet dann die Seite, ohne die Datenbank zu öffnen, mit der die Seite verknüpft ist. Daher stehen Assistenten, Generatoren und Add-Ins nicht zur Verfügung.

Öffnen einer Seite in Internet Explorer

Führen Sie einen der folgenden Schritte aus:

  • Öffnen Sie die Datenzugriffsseite in Access in der Entwurfsansicht oder der Seitenansicht, und klicken Sie dann im Menü Datei auf Webseitenvorschau.

  • Wenn Internet Explorer Ihr Standardwebbrowser ist, doppelklicken Sie in Windows Explorer auf die HTML-Seite, um die Seite in Internet Explorer zu öffnen, ohne vorher Access öffnen zu müssen.


 Wechseln zwischen Ansichten einer Datenzugriffsseite

Wechseln zwischen Ansichten einer Datenzugriffsseite

Um eine Datenzugriffsseite zu erstellen oder um eine Seite in der Entwurfsansicht, Seitenansicht oder im Microsoft Internet Explorer zu öffnen, muss Internet Explorer 5 oder höher installiert werden, wenn er noch nicht installiert wurde.

Wechseln zwischen Ansichten innerhalb von Microsoft Access

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf die Ansicht-Schaltfläche, um in die durch die Grafik angegebene Ansicht zu wechseln.

Wechseln zwischen Microsoft Access und Internet Explorer

Führen Sie einen der folgenden Schritte aus:

  • Öffnen Sie in Microsoft Access die Seite in der Entwurfsansicht oder der Seitenansicht, und klicken Sie anschließend im Menü Datei auf Webseitenvorschau.

  • Klicken Sie in Internet Explorer im Menü Datei auf Bearbeiten mit Microsoft Office 2000, um die Seite in Microsoft Access in der Entwurfsansicht zu öffnen.


 Hinzufügen von Daten zu einer Datenzugriffsseite unter Verwendung der Feldliste

Hinzufügen von Daten zu einer Datenzugriffsseite unter Verwendung der Feldliste

Wenn Sie zur Dateneingabe in einer Datenzugriffsseite die Feldliste verwenden, erstellt Microsoft Access automatisch neue Steuerelemente, die ähnlich wie bei den Feldlisten für Formulare und Berichte an die Felder gebunden werden, die Sie hinzufügen. Aber die Feldliste eines Formulars oder Berichts unterscheidet sich von der Feldliste einer Datenzugriffsseite. Bevor Sie gebundene Steuerelemente zu einem Formular oder Bericht hinzufügen können, müssen Sie zuerst das Formular bzw. den Bericht mit einer bestimmten Datenquelle verbinden. Ist das erfolgt, werden nur die Felder dieser Datensatzquelle in der Feldliste angezeigt. Eine Datenzugriffseite hingegen ist solange nicht gebunden, bis Sie ein Steuerelement hinzugefügt haben. Außerdem kann sie mit mehr als einer Datenquelle gleichzeitig verbunden werden. Deshalb zeigt die Feldliste einer Datenzugriffsseite alle Felder an, die Sie innerhalb der Datenbank auswählen können, um sie der Seite hinzuzufügen.

Dieses Thema enthält Übersichtsinformationen zur Handhabung von Feldlisten in Datenzugriffsseiten. Insbesondere erfahren Sie, wie Sie die Feldliste benutzen, was die Feldliste enthält, welche Aktionen Access bei Verwendung der Feldliste durchführt, und wie Sie Felder zur Datenzugriffsseite hinzufügen. Bevor Sie weiterlesen, sollten Sie sich mit den Strategien für die Erstellung von Datenzugriffsseiten vertraut machen.

Einrichten einer Verbindung mit einer Datenbank

Identifizierung der Felder durch Access

Hinzufügen einzelner Steuerelemente für die verschiedenen Felder

Hinzufügen einer Pivot-Tabelle mit mehreren Feldern

Erstellen der SQL-Abfrage für die Datenzugriffsseite durch Access

Erstellen der Datendefinition für die Datenzugriffseite durch Access

Einrichten einer Verbindung mit einer Datenbank

Bevor Sie Daten zu einer Datenzugriffsseite hinzufügen können, müssen Sie mit einer Microsoft Access-Datenbank oder einer Microsoft SQL Server-Datenbank verbunden sein. Falls die Seite mit einer dieser Datenbanken verbunden ist, zeigt die Registerkarte Datenbank der Feldliste die Ordner an, in denen die Tabellen und Abfragen der Datenbank enthalten sind. Wenn das Datenbanksymbol in der Feldliste ein rotes X trägt und unterhalb des Symbols keine Ordner aufgelistet sind, müssen Sie die Datenzugriffsseite mit einer Datenbank verbinden, um mit dem Entwurf der Seite fortfahren zu können.

Zurück zum Anfang

Identifizierung der Felder durch Access

Wenn Sie in der Feldliste auf das Erweiterungssymbol neben einem bestimmten Tabellen- oder Abfrageeintrag klicken, wird die Liste der zu dieser Datensatzquelle gehörigen Felder angezeigt. Wenn es sich bei der Datensatzquelle um eine Tabelle handelt, sehen Sie einen Ordner Verknüpfte Tabellen oberhalb der Felderliste. Dieser Ordner listet alle Tabellen und Felder auf, die mit der Tabelle verknüpft sind, deren Anzeige Sie in der Feldliste erweitert haben. Wenn Sie den Mauszeiger über eine der Tabellen im Ordner Verknüpfte Tabellen positionieren, werden die Felder hervorgehoben, über die die Tabellen verknüft sind. Wenn Sie Felder direkt aus verknüpften Tabellen oder aus Abfragen hinzufügen, die verknüpfte Tabellen verwenden, benutzt Microsoft Access automatisch die existierenden Verknüpfungen beim weiteren Entwurf der Datenzugriffsseite. Werden Felder aus Tabellen hinzugefügt, die keine oder mehrere Verknüpfungen zu bereits in der Seite verwendeten Tabellen aufweisen, erhalten Sie jedesmal von Microsoft Access die entsprechende Aufforderung, eine neue Verknüpfung zu definieren. Solcherart definierte Verknüpfungen gelten nur für die aktuelle Datenzugriffsseite und werden nicht in die Datenbank übernommen.

Anmerkung Beim Arbeiten in einer Mehrbenutzerumgebung werden Sie gelegentlich die Feldliste aktualisieren wollen, insbesondere wenn andere Benutzer neue Tabellen oder Abfragen hinzugefügt haben, nachdem Sie mit dem Entwurf der Datenzugriffsseite begonnen haben.

Zurück zum Anfang

Hinzufügen einzelner Steuerelemente für die verschiedenen Felder

Sie können die Felder einzeln auf die Datenzugriffsseite ziehen, um ein Steuerelement zu erstellen, das mit dem jeweiligen Feld verknüpft ist. Oder Sie können eine ganze Tabelle oder eine andere Datensatzquelle aus der Feldliste auf die Seite ziehen, um alle zugehörigen Felder auf einmal hinzuzufügen. Wenn das Steuerelement-Assistent- Tool [image] in der Symbolleiste ausgewählt ist, während Sie eine ganze Tabelle auf einen Bereich ziehen, zeigt Microsoft Access den Layout-Assistenten an, der Sie fragt, ob Sie die Felder als einzelne Steuerelemente oder in Form einer Pivot-Tabelle hinzufügen möchten. Sollen die Benutzer in der Lage sein, die Daten in den Feldern zu bearbeiten, oder sollen die Steuerelemente innerhalb eines frei definierten Layouts angeordnet werden, so empfiehlt sich die Verwendung individeller Steuerelemente. Mit einigen wenigen Ausnahmen erstellt Microsoft Access automatisch ein Steuerelement geeigneten Typs, das dem Datentyp der im Feld gespeicherten Daten entspricht. Sie können den Typ des zu erstellenden Steuerelements auch auswählen, bevor Sie das Feld auf die Datenzugriffsseite ziehen.

Zurück zum Anfang

Hinzufügen einer Pivot-Tabelle mit mehreren Feldern

Fügen Sie Felder als Teil eines PivotTable-Steuerelements hinzu, wenn Sie die Anzeige von Daten wünschen, die Sie neu anordnen, zusammenfassen und auf verschiedene Weisen analysieren können, deren Werte Sie aber nicht ändern können bzw. zu denen Sie keine neuen Werte hinzufügen können. Weitere Informationen dazu sollen Sie dem Thema Pivot-Tabelle: Definition und Funktionsweise entnehmen, bevor Sie sich festlegen. Pivot-Tabellen lassen sich aber auch zur Anzeige von Daten in einem Raster verwenden, beispielsweise zur Anzeige von Detaildatensätzen in einer Datenzugriffsseite mit gruppierten Daten. Wenn Sie ein PivotTable-Steuerelement auf diese Weise verwenden, können Sie über bestimmte Eigenschaften die Pivot-spezifische Funktionalität ausblenden. Wenn Sie eine Tabelle oder eine andere Datensatzquelle aus der Feldliste auf die Seite ziehen und dadurch ein PivotTable-Steuerelement erstellen, und anschließend den Befehl PivotTable wählen, sind bereits einige dieser Eigenschaften mit Werten belegt, die bestimmte Attribute der Pivot-Tabelle (beispielsweise Titelleiste, Symbolleiste sowie Dropbereiche für Spalten und Zeilen) deaktivieren. Verwenden Sie die PivotTable-Eigenschaftentoolbox, um diese und andere Eigenschaften des Steuerelements und seine Daten zu ändern.

Anmerkung Ein PivotTable-Steuerelement besitzt eine eigene Feldliste, die nicht mit der Feldliste der Datenzugriffsseite zu verwechseln ist. Diese Feldliste des Steuerelements zeigt alle Felder an, die Sie aus der Feldliste der Datenzugriffsseite dem PivotTable-Steuerelement hinzugefügt haben. Sie enthält also nicht alle Felder und Datenquellen, die in der Datenbank verfügbar sind. Wenn Sie im PivotTable-Steuerelement ein Feld entfernen, bleibt dieses Feld dennoch in der Feldliste der Pivot-Tabelle erhalten, so dass Sie es zu einem späteren Zeitpunkt hinzufügen können. Anders als die Feldliste der Datenzugriffsseite steht die Feldliste der Pivot-Tabelle auch im Browser zur Verfügung, so dass andere Benutzer der Seite der Pivot-Tabelle weitere Felder hinzufügen können, während sie die Daten analysieren.

Zurück zum Anfang

Erstellen der SQL-Abfrage für die Datenzugriffsseite durch Access

Während Sie Felder und Datensatzquellen auf die Datenzugriffseite ziehen und Gruppierungsebenen, Sortierreihenfolgen usw. hinzufügen, stellt Microsoft Access im Hintergrund eine Abfrage zusammen, die Ihre Entwurfsentscheidungen in entsprechende SQL (Structured Query Language)-Anweisungen übersetzt, die die Datenbank interpretieren kann. Unter Verwendung der vorhandenen Verknüpfungen zwischen den Datenquellen erstellt Microsoft Access eine Abfrage, die die von Ihnen ausgewählten Daten abruft und sie auf die von Ihnen festgelegte Weise anzeigt. Wenn Sie Felder aus Datensatzquellen hinzufügen, die keine Verküpfungen besitzen, zeigt Microsoft Access das Dialogfeld Neue Verknüpfung an, in dem Sie die gewünschte Verknüpfung definieren können.

Zurück zum Anfang

Erstellen der Datendefinition für die Datenzugriffseite durch Access

Wenn Sie ein Feld zur Datenzugriffsseite hinzufügen, wird dieses Feld von Access auch der Datendefinion der Seite hinzugefügt. Letztere umfasst alle Daten, die Sie der Seite hinzugefügt haben. Die Datendefinition, deren Darstellung Sie in der Registerkarte Seite der Feldliste finden, zeigt alle für die Seite verwendeten Datensatzquellen, die zwischen ihnen bestehenden Verknüpfungen sowie die Gruppierungsebenen an.

Zurück zum Anfang

Weitere Informationen

Woher kommen die Daten einer Datenzugriffsseite?


 Aktualisieren der Feldliste einer Datenzugriffsseite zum Anzeigen neuer Tabellen oder Abfragen

Aktualisieren der Feldliste einer Datenzugriffsseite zum Anzeigen neuer Tabellen oder Abfragen

Wenn Sie in einer Mehrbenutzerumgebung arbeiten, möchten Sie ggf. die Feldliste der Datenzugriffsseite aktualisieren, um neue Tabellen oder Abfragen oder Änderungen an vorhandenen Tabellen oder Abfragen anzuzeigen, die andere Benutzer hinzugefügt haben könnten, nach dem Sie mit dem Seitenentwurf begonnen haben.

  • Klicken Sie auf der Registerkarte Datenbank oben in der Feldliste mit der rechten Maustaste auf das Symbol Datenbank, und klicken Sie dann auf Aktualisieren.


 Definieren einer neuen Beziehung zwischen Datenquellen in einer Datenzugriffsseite

Definieren einer neuen Beziehung zwischen Datenquellen in einer Datenzugriffsseite

Wenn Sie zur Datenzugriffsseite Felder hinzufügen und noch keine Beziehung zwischen den Tabellen oder Abfragen besteht, werden Sie von Microsoft Access aufgefordert, die Beziehung zu definieren.

  • Geben Sie im Dialogfeld Neue Beziehung das Feld an, über das Sie eine eine Beziehung zwischen der Datenquelle, die Sie zur Datenzugriffsseite hinzufügen möchten, und der Datenquelle bzw. den Datenquellen herstellen möchten, die momentan Teil der Datendefinition der Datenzugriffsseite ist. Geben Sie darüber hinaus den Beziehungstyp für die beiden Datenquellen an.

Anmerkungen

  • Beziehungen, die Sie im Dialogfeld Neue Beziehung definieren, gelten nur für die aktuelle Datenzugriffsseite. Sie werden nicht zur Datenbank hinzugefügt. Deshalb werden sie auch nicht im Fenster Beziehungen einer Microsoft Access-Datenbank oder im Fenster Datenbankdiagramm in einem Microsoft Access-Projekt angezeigt.

  • In einigen Fällen stellt Access fest, dass zwischen den beiden Datenquellen nur ein Beziehungstyp möglich ist. In diesem Fall wird die andere Option deaktiviert.


 Auswählen einer Datenzugriffsseite, eines Bereichs, Steuerelements oder eines anderen Elements

Auswählen einer Datenzugriffsseite, eines Bereichs, Steuerelements oder eines anderen Elements

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Führen Sie einen der folgenden Schritte aus:
    • Zum Auswählen der Seite klicken Sie im Menü Bearbeiten auf Seite auswählen.

    • Zum Auswählen des Haptteils klicken Sie außerhalb eines Bereichs.

    • Zum Auswählen eines Bereichs klicken Sie auf die Bereichsleiste.

    • Zum Auswählen eines Steuerelements klicken Sie auf das Steuerelement.

    • Zum Auswählen von Text ziehen Sie den Cursor über den Text, den Sie auswählen möchten.


 Einstellen von Dokumenteigenschaften wie zum Beispiel Titel, Design und Autor einer Datenzugriffsseite

Einstellen von Dokumenteigenschaften wie zum Beispiel Titel, Design und Autor einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht oder der Seitenansicht.

  2. Klicken Sie im Menü Datei auf Seiteneigenschaften.

  3. Legen Sie die gewünschten Eigenschaften auf den folgenden Registerkarten fest:
    • Allgemein Hier werden dieselben Informationen angezeigt, die Sie auch abrufen können, indem Sie im Microsoft Windows Explorer mit der rechten Maustaste auf einen Dateinamen und dann im Kontextmenü auf Eigenschaften klicken. Der einzige Unterschied besteht darin, dass die Einstellungen für Attribute bei der Anzeige der Eigenschaften in Microsoft Access schreibgeschützt sind.

    • Zusammenfassung Die auf dieser Registerkarte eingegebenen Informationen werden dem SummaryInfo Document-Objekt in der Documents-Auflistung hinzugefügt. Diese Informationen entsprechen den Zusammenfassungsinformationen, die auch in anderen Microsoft Office-Anwendungen zur Verfügung gestellt werden können. Mit Hilfe von Zusammenfassungsinformationen können Sie sowohl Seiten aus Microsoft Access als auch solche aus anderen Programmen, wie beispielsweise der Microsoft Windows-Dateisuche, leichter identifizieren. Die Einstellung Hyperlinkbasis auf der Registerkarte Zusammenfassung dient zur Erstellung des Hyperlinkbasispfads, der am Anfang der relativen Einstellungen der HyperlinkAdresse-Eigenschaft angehängt wird.

    • Statistik Hier finden Sie unter anderem Informationen über das Erstellungsdatum und die Uhrzeit der Erstellung der aktiven Seite, über Datum und Uhrzeit der letzten Modifikation, den Benutzer, der die Modifikation vorgenommen hat, die Anzahl der bisherigen Bearbeitungen sowie die gesamte Bearbeitungszeit.

    • Inhalt Hier werden Informationen über den Titel und die Verbindungszeichenfolge angezeigt.

    • Benutzerdefiniert Die eingegebenen benutzerdefinierten Eigenschaften werden zu Eigenschaften des UserDefined Document-Objekts in der Documents-Auflistung.


 Festlegen der Eigenschaften für eine Datenzugriffsseite, einen Bereich oder ein Steuerelement

Festlegen der Eigenschaften für eine Datenzugriffsseite, einen Bereich oder ein Steuerelement

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Führen Sie einen der folgenden Schritte aus:
    • Zum Auswählen der Seite klicken Sie im Menü Bearbeiten auf Seite auswählen.

    • Zum Auswählen eines Bereichs klicken Sie auf die Bereichsleiste.

    • Zum Auswählen eines Steuerelements klicken Sie darauf.
  3. Klicken Sie auf der Symbolleiste auf Eigenschaften [image] . Microsoft Access zeigt den Namen des ausgewählten Objekts in der Titelleiste des Eigenschaftenfensters an.


 Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer Datenzugriffsseite

Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer Datenzugriffsseite

Was möchten Sie tun?

Eine Summe oder einen anderen Wert für einen Datensatz auf einer Seite berechnen, die zur Dateneingabe dient Bei dieser Methode wird ein Tabellen-Steuerelement verwendet, das automatisch die berechneten Beträge aktualisiert, wenn Sie Änderungen in den Feldern vornehmen, auf die der Ausdruck Bezug nimmt.

Eine Summe oder einen anderen Wert für einen Datensatz auf einer gruppierten Seite berechnen Bei dieser Methode wird ein gebundenes HTML-Steuerelement verwendet. Wenn Sie ein gebundenes HTML-Steuerelement an Stelle eines Tabellen-Steuerelements verwenden, können Sie mehrere Datensätze in jeder Gruppierungsebene auf der Seite anzeigen.


 Berechnen von Summen, Durchschnittswerten oder anderen Mengen für Datensatzgruppen auf einer Datenzugriffsseite

Berechnen von Summen, Durchschnittswerten oder anderen Mengen für Datensatzgruppen auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht. Die Seite muss mindestens zwei Gruppierungsebenen besitzen.

  2. Erstellen Sie ein gebundenes HTML-Steuerelement, das an das Feld gebunden ist, welches Sie zur Berechnung einer Summe, eines Mittelwertes oder einer anderen Menge im jeweiligen Gruppenkopf oder Gruppenfuß verwenden wollen. Beispiel: Zur Berechnung einer Bestellungszwischensumme auf einer Seite mit Gruppierungsebenen, die an die Tabellen Bestellungen und Bestelldetails gebunden sind, setzen Sie das Steuerelement zur Berechnung der Zwischensumme in den Gruppenkopf oder den Gruppenfuß der höheren Gruppierungsebene, nämlich Bestellungen, ein.

  3. Vergewissern Sie sich, dass das gebundene HTML-Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  4. Wählen Sie im Einstellungsfeld für die TotalType-Eigenschaft die gewünschte Aggregatfunktion aus der Liste: Sum, Avg, Min, Max, Count, Any oder Stdev.


 Berechnen von Endsummen oder anderen Mengen für alle Datensätze auf einer Datenzugriffsseite

Berechnen von Endsummen oder anderen Mengen für alle Datensätze auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht. Die Seite muss mindestens zwei Gruppierungsebenen besitzen.

  2. Erstellen Sie ein gebundenes HTML-Steuerelement, das an das Feld gebunden ist, welches Sie zur Berechnung der Endsumme im Gruppenkopf der höchsten Gruppierungsebene verwenden wollen.

  3. Vergewissern Sie sich, dass das gebundene HTML-Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Höher stufen [image] .

  4. Klicken Sie bei ausgewähltem Steuerelement in der Symbolleiste auf Eigenschaften [image] .

  5. Wählen Sie im Einstellungsfeld für die TotalType-Eigenschaft die gewünschte Aggregatfunktion aus der Liste: Sum, Avg, Min, Max, Count, Any oder Stdev.

    Die folgenden Schritte sind optional.

  6. Erstellen Sie ein Bezeichnungsfeld für das gebundene HTML-Steuerelement.

  7. Wählen Sie das Erweiterungssteuerelement in dem Kopfbereich aus, der die Endsumme enthält, und drücken Sie ENTF.

  8. Wählen Sie den Datensatznavigationsbereich für die Gruppierungsebene aus, die die Endsumme enthält, und drücken Sie ENTF. Access löscht den Bereich sowie das darin enthaltene Navigationssteuerelement.


 Beispiele für Ausdrücke in Datenzugriffsseiten

Beispiele für Ausdrücke in Datenzugriffsseiten

Ausdrücke zur Verwendung in Textfeldern und gebundenen HTML-Steuerelementen

Beispiele für Ausdrücke anzeigen, die Text bearbeiten

Beispiele für Ausdrücke anzeigen, die arithmetische Operationen durchführen

Beispiele für Ausdrücke anzeigen, die sich auf Werte von Steuerelementen beziehen

Beispiele für Ausdrücke anzeigen, die Daten bearbeiten und berechnen

Beispiele für Ausdrücke anzeigen, die einen von zwei möglichen Werten zurückgeben

Informationen über das Erstellen von Ausdrücken in einer Microsoft Access-Datenbank (.mdb) anzeigen

Informationen über das Erstellen von Ausdrücken in einem Microsoft Access-Projekt (.adp) anzeigen

Funktionen zur Verwendung in Steuerelementen auf Datenzugriffsseiten und ihnen zugrunde liegenden Abfragen

Ausdrücke zur Verwendung in Tabellen-Steuerelementen

Beispiele für häufig verwendete Formeln anzeigen


Info über Designs

Ein Design ist eine Gruppe zusammengehöriger Designelemente und Farbschemata für Aufzählungszeichen, Schriftarten, horizontale Linien, Hintergrundbilder und andere Elemente auf Datenzugriffsseiten. Mit Hilfe eines Designs können Sie leicht professionelle und ausgewogene Datenzugriffsseiten erstellen.

Wenn Sie ein Design auf eine Datenzugriffsseite anwenden, werden die folgenden Elemente in Ihrer Datenzugriffsseite angepasst: Auszeichnungen für Hauptteil und Überschriften, Hintergrundfarbe und -grafik, Tabellenrahmenfarbe, horizontale Linien, Aufzählungszeichen, Hyperlinkfarben und Steuerelemente.

Sie können einer Seite zum ersten Mal ein Design zuweisen, zu einem anderen Design wechseln oder ein Design entfernen. Dazu verwenden Sie den Befehl Design aus dem Menü Format. Sie können ein Design vor dem Anwenden in der Vorschau anzeigen. Dazu wählen Sie es aus der Liste der verfügbaren Designs aus und zeigen die Anzeige der Beispielelemente auf der Datenzugriffsseite im Feld Beispiel an. Vor dem Anwenden eines Designs im Dialogfeld Design können Sie Optionen wählen, um Text oder Grafiken hellere Farben zuzuweisen, bestimmte Designgrafiken zu animieren und Ihrer Datenzugriffsseite einen Hintergrund zuzuweisen. Designgrafiken werden nur animiert, wenn Sie die Datenzugriffsseite in einem Webbrowser anzeigen (nicht während der Anzeige der Seite in Microsoft Access).

Wenn Sie Access installieren, stehen eine Reihe von Designs auf Ihrem Festplattenlaufwerk zur Verfügung. Wenn Sie Microsoft FrontPage 4.0 oder 98 installiert haben, können Sie auch die FrontPage-Designs installieren. Darüber hinaus stehen weitere Designs im World Wide Web zur Verfügung. Zum Downloaden zusätzlicher Designs klicken Sie im Menü ? auf Office im Web.

Weitere Informationen

Verwenden eines Designs für eine neue oder vorhandene Datenzugriffsseite


Verwenden eines Designs für eine neue oder vorhandene Datenzugriffsseite

Was möchten Sie tun?

Weitere Informationen zu Designs anzeigen

Einer vorhandenen Datenzugriffsseite ein Design zuweisen

Einer neuen Datenzugriffsseite ein Design zuweisen

Ein Standarddesign für neue Datenzugriffsseiten zuweisen


 Auswählen eines Standarddesigns für neue Datenzugriffsseiten

Auswählen eines Standarddesigns für neue Datenzugriffsseiten

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Design.

  3. Klicken Sie in der Liste Design auswählen auf das gewünschte Design.

  4. Klicken Sie auf Als Standard festlegen.

  5. Klicken Sie auf Ja.


Entfernen eines Designs aus einer Datenzugriffsseite

Was möchten Sie tun?

Ein Design aus einer vorhandenen Datenzugriffsseite entfernen

Das Standarddesign für neue Datenzugriffsseiten entfernen


 Hinzufügen eines Hintergrundbildes zu einer Datenzugriffsseite

Hinzufügen eines Hintergrundbildes zu einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Zeigen Sie im Menü Format auf Hintergrund, und klicken Sie auf Bild.

  3. Überprüfen Sie im Dialogfeld Grafik einfügen, ob in der Liste Dateityp die Option Grafikdateien ausgewählt ist, und suchen Sie dann die Datei aus, die Sie als Hintergrundbild verwenden wollen.

  4. Klicken Sie auf OK.

Anmerkung Mit folgenden Eigenschaften im Eigenschaftenfenster können Sie festlegen, wie das Hintergrundbild angezeigt wird: BackgroundPostionX, BackgroundPositionY und BackgroundPositonRepeat.


 Hinzufügen eines Hintergrundsounds zu einer Datenzugriffsseite

Hinzufügen eines Hintergrundsounds zu einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Zeigen Sie im Menü Format auf Hintergrund, und klicken Sie auf Sound.

  3. Überprüfen Sie im Dialogfeld Sound einfügen, ob Alle Sounds (*.wav;*.au) in der Liste Dateityp ausgewählt ist, und suchen Sie dann die Datei aus, die Sie als Hintergrundsound verwenden wollen.

  4. Führen Sie eine der folgenden Aktionen aus:
    • Klicken Sie auf Einfügen, um die Sounddatei in dem Ordner zu speichern, in dem sich die Hilfsdateien für die Datenzugriffsseite befinden.

    • Klicken Sie auf Mit Datei verknüpfen, um einen Verweis auf die Sounddatei zu speichern.

    Der Sound wird abgespielt, wenn Sie die Seite in der Datenzugriffsseitenansicht oder in Internet Explorer öffnen.


 Ändern der Datenherkunft für einen Bereich auf einer Datenzugriffsseite

Ändern der Datenherkunft für einen Bereich auf einer Datenzugriffsseite

Verwenden Sie diese Methode bei Datenzugriffsseiten mit nur einer Gruppierungsebene.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf die Bereichsleiste des Bereichs, den Sie ändern möchten, und dann auf der Symbolleiste auf Eigenschaften [image] .

  3. Klicken Sie in der RecordSource-Eigenschaft auf eine Datenherkunft in der Liste.


 Ändern der Größe eines Kopf-, Fuß- oder anderen Bereichs auf einer Datenzugriffsseite

Ändern der Größe eines Kopf-, Fuß- oder anderen Bereichs auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf die Bereichsleiste des Bereichs, den Sie ändern möchten. Microsoft Access zeigt Ziehpunkte um den Bereichsrahmen an.

  3. Klicken Sie auf eine Auswahl. Wenn der Zeiger sich in ein Fadenkreuz verwandelt, ziehen Sie einen Ziehpunkt an der Ober- oder Unterseite des Bereichs nach oben oder unten, einen Ziehpunkt an der Seite nach rechts oder links oder einen Ziehpunkt in einer Ecke diagonal.

    Sie können an jedem Ziehpunkt ziehen, um die Größe des Bereichs zu ändern, jedoch ändert Access den Bereich immer von der unteren oder rechten Kante aus. Wenn Sie beispielsweise den Ziehpunkt auf der Oberseite eines Bereichs nach unten ziehen, um die Höhe des Bereichs zu verringern, verschiebt Access die untere Kante des Bereichs nach oben.


 Hinzufügen eines ungebundenen Bereichs zu einer Datenzugriffsseite, die noch keinen besitzt

Hinzufügen eines ungebundenen Bereichs zu einer Datenzugriffsseite, die noch keinen besitzt

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Ungebundener Bereich.

Wenn Sie den ungebundenen Bereich der Datenzugriffsseite hinzugefügt haben, können Sie das Design der Seite auf andere Weise modifizieren.


 Hinzufügen oder Entfernen eines Gruppenfußes auf einer Datenzugriffsseite

Hinzufügen oder Entfernen eines Gruppenfußes auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die Gruppendatensatzquelle, für die Sie einen Gruppenfuß hinzufügen oder entfernen wollen.

  4. Führen Sie im Einstellungsfeld der Eigenschaft GroupFooter einen der folgenden Schritte durch:
    • Um einen Gruppenfuß hinzuzufügen, klicken Sie auf Ja. Microsoft Access fügt den Gruppenfuß oberhalb des Datensatznavigationsbereichs für die ausgewählte Gruppendatensatzquelle ein. Sie können auch Steuerelemente zur Berechnung von Gruppensummen in den Gruppenfuß aufnehmen.

    • Um den Gruppenfuß zu löschen, klicken Sie auf Nein. Access entfernt den Gruppenfuß mit allen darin enthaltenen Steuerelementen.

Anmerkung Zu der untersten Gruppierungsebene auf einer Datenzugriffsseite können Sie keinen Gruppenfuß hinzufügen.


 Hinzufügen oder Entfernen eines Beschriftungsbereichs einer Gruppe auf einer Datenzugriffsseite

Hinzufügen oder Entfernen eines Beschriftungsbereichs einer Gruppe auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die Gruppendatensatzquelle, für die Sie den Beschriftungsbereich hinzufügen oder entfernen wollen.

  4. Führen Sie im Eigenschaftenfeld CaptionSection einen der folgenden Schritte durch:
    • Um einen Beschriftungsbereich hinzuzufügen, klicken Sie auf Ja. Microsoft Access fügt den Beschriftungsbereich oberhalb des Gruppenkopfes ein. Sie können entweder neue Bezeichnungsfelder erstellen oder vorhandene Bezeichnungsfelder zu dem Beschriftungsbereich hinzufügen.

    • Um einen Beschriftungsbereich zu löschen, klicken Sie auf Nein. Access entfernt den Beschriftungsbereich mit allen darin enthaltenen Steuerelementen.

Anmerkung Zu einem Beschriftungsbereich können Sie keine gebundenen Steuerelemente hinzufügen.


 Hinzufügen oder Entfernen des Navigationsbereichs einer Gruppe auf einer Datenzugriffsseite

Hinzufügen oder Entfernen des Navigationsbereichs einer Gruppe auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die Gruppendatensatzquelle, für die Sie einen Datensatznavigationsbereich hinzufügen oder entfernen wollen.

  4. Führen Sie im Eigenschaftenfeld RecordNavigationSection einen der folgenden Schritte durch:
    • Um einen Bereich hinzuzufügen, klicken Sie auf Ja. Microsoft Access fügt den Bereich und ein Datensatznavigationssteuerelement ein.

    • Um den Bereich zu löschen, klicken Sie auf Nein. Access entfernt den Datensatznavigationsbereich mit allen darin enthaltenen Steuerelementen.

Tipp Sie können einen Datensatznavigationsbereich mit allen darin enthaltenen Steuerelementen auch entfernen, indem Sie auf die Bereichsleiste klicken, um den Bereich auszuwählen, und dann ENTF drücken.

Anmerkungen

  • Wenn Sie das Datensatznavigationssteuerelement oder den Datensatznavigationsbereich einer Gruppierungsebene löschen, ändert Microsoft Access automatisch die DataPageSize-Eigenschaft für die Gruppe auf Alle. Falls Sie das Datensatznavigationssteuerelement oder den Datensatznavigationsbereich für die höchste Gruppierungsebene löschen, werden alle Datensätze in dieser Gruppierungsebene angezeigt, wenn Sie die Seite in der Datensatzzugriffsseitenansicht oder in Microsoft Internet Explorer öffnen. Infolgedessen können sich die Ladezeiten von Seiten verlängern.

  • Zu einem Datensatznavigationsbereich können Sie keine gebundenen Steuerelemente hinzufügen.


 Ändern der Aktivierreihenfolge der Steuerelemente auf einer Datenzugriffsseite

Ändern der Aktivierreihenfolge der Steuerelemente auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Steuerelement aus, das Sie an eine andere Position in der Aktivierreihenfolge bewegen möchten, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Geben Sie im Einstellungsfeld der TabIndex-Eigenschaft die neue Reihenfolgennummer ein.

  4. Wechseln Sie zur Datenzugriffsseitenansicht, um die Reihenfolge zu testen.

Anmerkung In der Entwurfsansicht ist die Aktivierreihenfolge stets die Reihenfolge, in der die Steuerelemente erstellt wurden.


 Entfernen eines Textfeldes oder eines anderen Steuerelements aus der Aktivierreihenfolge auf einer Datenzugriffsseite

Entfernen eines Textfeldes oder eines anderen Steuerelements aus der Aktivierreihenfolge auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Steuerelement aus, das Sie aus der Aktivierreihenfolge entfernen möchten, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Geben Sie in das Feld zur Einstellung der Eigenschaft TabIndex den Wert -1 ein.

Anmerkung Wenn für die Eigenschaft Deaktiviert eines Steuerelements die Einstellung Falsch festgelegt ist, können Sie auf das entsprechende Steuerelement in der Seitenansicht oder in einem Webbrowser klicken, um es auszuwählen, auch wenn für dessen Eigenschaft TabIndex der Wert -1 eingestellt ist.


 Anzeigen eines Titels oder anderer Informationstexte auf einer Datenzugriffsseite

Anzeigen eines Titels oder anderer Informationstexte auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Gehen Sie nach einer der folgenden Methoden vor:
    • Zum Hinzufügen eines Titels klicken Sie auf den Platzhaltertext Titeltext durch Klicken hinzufügen.

    • Zum Hinzufügen von weiterem Text mit Informationen klicken Sie auf den Platzhaltertext Text durch Klicken hinzufügen.
  3. Verwenden Sie die Schaltflächen auf der Formatsymbolleiste der Datenzugriffsseite, um die Schriftart, den Schriftgrad und andere Texteigenschaften zu ändern.

Anmerkung Zum Anzeigen von HTML-Text auf einer Seite erstellen Sie ein gebundenes HTML-Steuerelement im Hauptteil oder in einer Auswahl.


 Formatieren von Text als Liste mit Aufzählungszeichen oder Nummern auf einer Datenzugriffsseite

Formatieren von Text als Liste mit Aufzählungszeichen oder Nummern auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Markieren Sie den Text.

  3. Klicken Sie auf Nummerierung [image] oder auf Aufzählungszeichen [image] in der Symbolleiste.


 Vergrößern oder Verkleinern des Texteinzugs auf einer Datenzugriffsseite

Vergrößern oder Verkleinern des Texteinzugs auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Markieren Sie den Text.

  3. Klicken Sie in der Symbolleiste auf Einzug vergrößern [image] oder Einzug verkleinern [image] .


 Entfernen des Platzhaltertextes am Anfang der Datenzugriffsseite

Entfernen des Platzhaltertextes am Anfang der Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf Titeltext durch Klicken hinzufügen bzw. Text durch Klicken hinzufügen.

  3. Drücken Sie die ENTF-Taste.

Auch wenn Sie ihn nicht löschen, ist der Platzhaltertext beim Anzeigen der Seite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer nicht sichtbar.


 Gruppieren von Datensätzen auf einer Datenzugriffsseite

Gruppieren von Datensätzen auf einer Datenzugriffsseite

Das Gruppieren von Datensätzen auf einer Datenzugriffsseite ist dem Gruppieren von Datensätzen in einem Bericht ähnlich: Sie haben die Möglichkeit, eine Hierarchie zu erstellen, die Datensätze von allgemeinen Kategorien bis hin zu spezifischen Details gruppiert. Sie können die Daten auf Seiten mit gruppierten Datensätzen anzeigen, jedoch können Sie keine Daten hinzufügen, bearbeiten oder löschen.

Überblick über das Gruppieren von Datensätzen auf Datenzugriffsseiten.

Was möchten Sie tun?

Datensätze nach Werten in einem Gruppierungsfeld gruppieren, zum Beispiel Umsätze nach Mitarbeiternamen.

Datensätze unter Verwendung von Ausdrücken gruppieren.

Datensätze nach den ersten n Buchstaben in einem Textwert gruppieren, zum Beispiel Artikel nach dem ersten Buchstaben des Artikelnamens.

Datensätze nach Intervallen von Datums- oder Uhrzeitwerten gruppieren, zum Beispiel Umsätze nach Monat.

Datensätze nach Intervallen von Datums- oder Uhrzeitwerten gruppieren, zum Beispiel Umsätze in Intervallen von 1.000.

Anmerkung Sie können mit jeder der oben beschriebenen Methoden eine gruppierte Seite erstellen und einen Filter erzeugen, über den Sie auswählen können, welche Datensatzgruppen angezeigt werden sollen, wenn die Seite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer geöffnet wird.


 Zusammenführen von zwei Gruppierungen auf einer Datenzugriffsseite

Zusammenführen von zwei Gruppierungen auf einer Datenzugriffsseite

Wenn Sie zwei Gruppierungen zusammenführen, verschiebt Microsoft Access die Steuerelemente im Gruppenkopf und -fuß der ausgewählten Gruppierungsebene in den Kopf und Fuß der nächstniedrigeren Gruppierungsebene.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf die Bereichsleiste des Gruppenkopfs oder -fußes der Gruppierungsebene, die Sie mit der nächstniedrigeren Ebene zusammenführen möchten.

  3. Klicken Sie in der Symbolleiste auf Tiefer stufen [image] .


 Ändern der Gruppierungsordnung auf einer Datenzugriffsseite

Ändern der Gruppierungsordnung auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie den Gruppenkopf aus, den Sie auf eine niedrigere Gruppierungsebene verschieben wollen.

  3. Klicken Sie auf der Symbolleiste auf Tiefer stufen [image] .

    Microsoft Access verschiebt die Steuerelemente im ausgewählten Gruppenkopf und -fuß in den Kopf- und Fußbereich der nächsttieferen Gruppierungsebene.

  4. Klicken Sie auf das Steuerelement, das Sie auf eine höhere Gruppierungsebene verschieben wollen.

  5. Führen Sie einen der folgenden Schritte durch:
    • Um nach einem Feld in einer Tabelle oder Abfrage zu gruppieren, klicken Sie auf Höher stufen [image] auf der Symbolleiste.

    • Um nach einer Tabelle oder Abfrage zu gruppieren, klicken Sie auf Nach Tabelle gruppieren [image] auf der Symbolleiste.

    Microsoft Access fügt einen Gruppenkopf mit einem Erweiterungs-Steuerelement und einen Datensatznavigationsbereich mit einem Datensatznavigationssteuerelement ein. Wenn Sie nach einem Feld gruppiert haben, verschiebt Access das der Gruppierung zugrunde liegende Steuerelement in den Gruppenkopf. Haben Sie nach einer Tabelle oder Abfrage gruppiert, verschiebt Access alle Steuerelemente, auch an Felder in dieser Tabelle oder Abfrage gebundene oder an Nachschlagefelder gebundene Steuerelemente, in den Gruppenkopf.


 Festlegen oder Ändern der Standardsortierreihenfolge von Datensätzen auf einer Datenzugriffsseite

Festlegen oder Ändern der Standardsortierreihenfolge von Datensätzen auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die Gruppendatensatzquelle, für die Sie die Sortierreihenfolge festlegen wollen.

  4. Geben Sie im Einstellungsfeld der Standardsortierung-Eigenschaft den Namen des Feldes bzw. die Namen der Felder ein, nach denen Sie sortieren möchten. Trennen Sie die Namen mit einem Komma. Sie können hinter jeden Namen, getrennt durch ein Leerzeichen, die Schlüsselwörter ASC (aufsteigend) oder DESC (absteigend) eingeben. Beispiel: Bestelldatum DESC, BestellNr ASC. Wenn Sie keine Reihenfolge angeben, sortiert Microsoft Access in aufsteigender Reihenfolge.

    Anmerkung Falls das Steuerelement, nach dem Sie sortieren möchten, an einen Ausdruck gebunden ist, müssen Sie den Aliasnamen des Steuerelements so eingeben, wie in dessen Steuerelementinhalt-Eigenschaft angegeben. Ist beispielsweise in der Steuerelementinhalt-Eigenschaft des Steuerelements, nach dem Sie sortieren möchten, GruppeVonVerkaufspreis: Verkaufspreis angegeben, geben Sie in the Standardsortierung-Eigenschaft GruppeVonVerkaufspreis ein.


 Festlegen der Anzahl der in einer Gruppe anzuzeigenden Datensätze in einer Datenzugriffsseite

Festlegen der Anzahl der in einer Gruppe anzuzeigenden Datensätze in einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die Gruppendatensatzquelle, für die Sie die anzuzeigende Anzahl an Datensätzen festlegen möchten.

  4. Klicken Sie im Einstellungsfeld der Datenseitengröße-Eigenschaft auf einen Wert in der Liste, oder geben Sie in dem Feld einen Wert ein.

Wenn Sie für eine Gruppierungsebene die Datenseitengröße-Eigenschaft auf Alle einstellen und wenn es sich bei dieser Gruppierungsebene um die einzige oder um die höchste Gruppierungsebene auf der Seite handelt, werden alle Datensätze angezeigt, wenn Sie die Seite in Seitenansicht oder im Microsoft Internet Explorer öffnen. Enthält eine Seite viele Datensätze, dauert das Laden der Seite möglicherweise etwas länger.

Anmerkung Verfügt eine Gruppierungsebene nicht über einen Datensatznavigationsbereich oder ein Datensatznavigationssteuerelement, müssen Sie die Datenseitengröße-Eigenschaft auf Alle einstellen, um alle Datensätze dieser Gruppierungsebene sehen zu können.


 Festlegen, ob eine Gruppe standardmäßig auf einer Datenzugriffsseite erweitert oder ausgeblendet wird

Festlegen, ob eine Gruppe standardmäßig auf einer Datenzugriffsseite erweitert oder ausgeblendet wird

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Feld Sortieren und gruppieren anzuzeigen.

  3. Klicken Sie auf die gewünschte Gruppendatensatzquelle.

    Anmerkung Wenn Sie die Standardmäßig erweitert-Eigenschaft einstellen, legen Sie fest, ob die Datensätze auf der nächst niedrigeren Gruppierungsebene ein- oder ausgeblendet werden, wenn die Seite in Seitenansicht oder in Microsoft Internet Explorer angezeigt wird.

  4. Führen Sie im Einstellungsfeld für die Standardmäßig erweitert-Eigenschaft einen der folgenden Schritte aus:
    • Klicken Sie auf Ja, um die Seite so zu öffnen, dass die Datensätze in der nächst niedrigeren Gruppierungsebene eingeblendeten sind.

    • Klicken Sie auf Nein, um die Seite so zu öffnen, dass die Datensätze in der nächst niederigeren Gruppierungsebene ausgeblendet sind.

Anmerkung Die Seite wird in Seitenansicht und im Microsoft Internet Explorer schneller geladen, wenn die Standardmäßig erweitert-Eigenschaft für die höchste Gruppierungsebene auf der Seite auf Nein gestellt wird.


 Tipps für das Optimieren der Leistung einer Datenzugriffsseite

Tipps für das Optimieren der Leistung einer Datenzugriffsseite

Es gibt mehrere Möglichkeiten, das Laden Ihrer Datenzugriffsseiten in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer 5 zu beschleunigen.

  • Vermeiden Sie überlappende Steuerelemente.

  • Verwenden Sie Bitmaps und andere Grafikobjekte sparsam. Verwenden Sie schwarzweiße statt farbiger Bitmaps.

  • Stellen Sie sicher, dass die Standardmäßig erweitert-Eigenschaft im Fenster Sortieren und gruppieren für die höchste Gruppierungsebene auf Nein festgelegt ist. Wenn sie für niedrigere Gruppierungsebenen auf Nein festgelegt ist, werden nach dem Öffnen der Seite andere Interaktionen beschleunigt.

  • Stellen Sie sicher, dass die Datenseitengröße-Eigenschaft im Fenster Sortieren und gruppieren, die die Anzahl der Datensätze bestimmt, die in einer Gruppe auf einer Seite angezeigt werden, auf eine niedrige statt eine hohe Anzahl oder auf Alle festgelegt ist. Je niedriger die Anzahl, desto schneller werden die Datensätze angezeigt.

  • Verwenden Sie gebundene HTML-Steuerelemente an Stelle von Textfeldern, um nicht aktualisierbare Daten anzuzeigen - z. B., um automatisch nummerierte Werte, aus Ausdrücken gewonnene Werte sowie Hyperlinks anzuzeigen.

  • Verwenden Sie auf gruppierten Seiten gebundene HTML-Steuerelemente an Stelle von Textfeldern, um Daten anzuzeigen.

  • Schließen Sie beim Verwenden einer Datenzugriffsseite innerhalb von Microsoft Access alle nicht verwendeten Datenbankobjekte.

  • Schließen Sie beim Verwenden einer Datenzugriffsseite in Internet Explorer alle nicht verwendeten Fenster.

  • Legen Sie auf Datenzugriffsseiten, die zur Dateneingabe verwendet werden, die DataEntry-Eigenschaft der Seite auf Ja fest, damit die Seite mit einem leeren Datensatz geöffnet wird.

  • Indizieren Sie alle Felder, die Sie sortieren oder gruppieren oder auf die Sie einen Filter anwenden möchten.

  • Gruppieren Sie Datensätze auf Datenzugriffsseiten, die Datensätze mit einer 1:n-Beziehung enthalten, nach Tabelle statt nach einem Feld oder einem Ausdruck.

  • Binden Sie auf gruppierten Datenzugriffsseiten, die auf Tabellen mit einer 1:n-Beziehung basieren, jeden Abschnitt an eine Tabelle statt an eine Abfrage. In Microsoft Access werden die Datensätze erst aus einer Tabelle abgerufen, wenn sie auf der Seite angezeigt werden sollen. Bei einer Abfrage ruft Access sämtliche Datensätze ab, bevor Datensätze auf der Seite angezeigt werden. Verwenden Sie nur dann eine Abfrage, wenn Sie die Datenmenge beschränken möchten, die auf der Seite verwendet wird, Aggregatwerte berechnen möchten oder eine Aufgabe ausführen möchten, die nur in einer Abfrage möglich ist.


 Microsoft Office Web Components

Microsoft Office Web Components

Die Microsoft Office Web Components bestehen aus zwei CAB-Dateien (msowcin.cab, msowc.cab), die einige Laufzeitdateien enthalten, die zusammengefasst als Microsoft Office Web Components bezeichnet werden. Zu den Office Web Components gehören unter anderem Microsoft Jet 4.0 OLE DB Provider, Microsoft OLE DB Provider für SQL Server, Microsoft Office Data Source Control (MSODSC), mehrere andere ActiveX-Steuerelemente und deren Hilfedateien sowie andere dazugehörige Dateien. Wenn die Office Web Components auf Ihrem Computer installiert sind, sind Sie in der Lage, mit dem Internet Explorer (Version 5 oder später) eine Datenzugriffseite sowie interaktiv ein Kalkulationstabelle, eine Pivot-Tabelle und ein Diagramm zu verwenden.

Die Office Web Components lassen sich mit den Versionen Professional, Premium, Developer, and Standard von Microsoft Office 2000 installieren. Sofern die Office Web Components nicht auf Ihrem Computer installiert sind und Sie eine Microsoft Office 2000-Lizenz besitzen, die eine Verteilung über ein Intranet ermöglicht, kann Ihr Systemadministrator den Microsoft Internet Explorer entsprechend konfigurieren, so dass die Office Web Components automatisch beim ersten Zugriff auf eine Seite über das firmeneigene Intranet geladen werden. Auf diese Weise können die Benutzer Ihrer Site eine Seite verwenden, ohne dass sie Microsoft Office 2000-Software auf ihren Computern installiert haben müssen.

Weitere Informationen über das Konfigurieren von Office Web Components finden Sie unter Microsoft Office 2000 Resource Kit.


 Steuerelemente: Definition und Funktionsweise

Steuerelemente: Definition und Funktionsweise

Sämtliche Informationen eines Formulars oder Berichts sind in Steuerelementen enthalten. In Datenzugriffsseiten sind die Informationen ebenfalls in Steuerelementen enthalten. Allerdings können Daten auf einer Datenzugriffsseite auch direkt eingegeben werden. Steuerelemente sind Objekte in einem Formular, Bericht oder in einer Datenzugriffsseite. Sie dienen zum Anzeigen von Daten, Ausführen von Aktionen oder zur Gestaltung des Formulars, Berichts oder der Datenzugriffsseite. So können Sie z. B. mit Hilfe eines Textfelds in einem Formular oder Bericht Daten anzeigen, mit einer Schaltfläche auf einem Formular ein anderes Formular oder einen Bericht öffnen oder aber mit einer Linie oder einem Rechteck Steuerelemente voneinander trennen und gruppieren, damit sie einfacher zu lesen sind.

Microsoft Access enthält folgende Steuerelementtypen, auf die Sie in der Formularentwurfsansicht, der Berichtsentwurfsansicht oder der Datenzugriffsseiten-Entwurfsansicht über die Toolbox zugreifen können: Textfeld, Bezeichnungsfeld, Optionsgruppe, Optionsfeld, Kontrollkästchen, Listenfeld, Befehlsschaltfläche, Bild, Linie, Rechteck sowie benutzerdefinierte ActiveX-Steuerelemente. Formulare und Berichte können zusätzlich die folgenden Steuerelemente enthalten: Umschaltfläche, Kombinationsfeld, gebundenes Objektfeld, ungebundenes Objektfeld, Unterformular/-bericht und Seitenwechsel. Datenzugriffsseiten können zusätzlich folgende Komponenten enthalten: Dropdownlistenfeld, Hyperlinks, Lauftext, PivotTable-Liste, Kalkulationstabelle und Diagramm.

Steuerelemente können gebunden, ungebunden oder berechnet sein. Ein gebundenes Steuerelement ist mit einem Feld in einer zugrunde liegenden Tabelle oder Abfrage verbunden. Sie verwenden gebundene Steuerelemente, um Werte in Felder(n) Ihrer Datenbank anzuzeigen, einzugeben und zu aktualisieren. Ein ungebundenes Steuerelement hat keine Datenquelle. Sie können mit Hilfe von ungebundenen Steuerelementen Informationen, Linien, Rechtecke und Bilder anzeigen. Die folgende Abbildung zeigt Beispiele für gebundene, ungebundene und berechnete Steuerelemente. Ein berechnetes Steuerelement verwendet einen Ausdruck als Datenquelle. Ein Ausdruck kann Daten aus einem Feld in einer zugrunde liegenden Tabelle oder Abfrage eines Formulars oder Berichts oder aus einem anderen Steuerelement im Formular oder Bericht verwenden.

Gebundene, ungebundene und berechnete Steuerelemente

Weitere Informationen über Microsoft Access-Steuerelemente.


Microsoft Access-Steuerelemente

Es gibt eine Vielzahl von Steuerelementen, die Sie zu einem Formular, einem Bericht oder einer Datenzugriffsseite hinzufügen können, um Daten anzuzeigen oder zu analysieren, um mit Grafiken zu arbeiten und Webseiten zu verknüpfen usw.

Das vorliegende Thema liefert Ihnen Informationen über:

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Steuerelemente zum Analysieren von Daten

Steuerelemente, die Verknüpfungen zu Webseiten erstellen

Steuerelemente für Grafiken und animierte Texte

Steuerelemente, die vom Benutzer angepasst werden können

Steuerelemente zum Organisieren von Daten

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Kontrollkästchen

Kombinationsfelder

Befehlsschaltflächen

Dropdownlisten

Bezeichnungsfelder

Listenfelder

Optionsfelder

Optionsgruppen

Unterformulare

Unterberichte

Textfelder

Umschaltflächen

Zurück zum Anfang

Steuerelemente zum Analysieren von Daten

Office Charts

Office PivotTable-Listen

Office Spreadsheets

Zurück zum Anfang

Steuerelemente, die Verknüpfungen zu Websites erstellen

Hyperlinks und gebundene Hyperlinks

Zurück zum Anfang

Steuerelemente für Grafiken und animierte Texte

Hotspotbilder

Bildsteuerelemente, Ungebundene oder Gebundene Objektfelder

Lauftext

Zurück zum Anfang

Steuerelemente, die vom Benutzer angepasst werden können

ActiveX-Steuerelemente

Zurück zum Anfang

Steuerelemente zum Organisieren von Daten

Erweitern

Linien

Seitenwechsel

Datensatznavigation

Rechtecke

Registerkarten

Zurück zum Anfang


 Binden eines ungebundenen Textfeldes oder anderen Steuerelements an ein Feld oder eine Spalte

Binden eines ungebundenen Textfeldes oder anderen Steuerelements an ein Feld oder eine Spalte

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Steuerelementinhalt-Eigenschaft den Namen des Feldes ein, an das Sie das Steuerelement binden möchten.

Anmerkung Wenn Sie ein Steuerelement auf diese Weise an ein Feld binden oder wenn Sie das einem gebundenen Steuerelement zugrunde liegende Feld ändern, legt Microsoft Access für die Eigenschaften des Steuerelements nicht alle Werte fest, die für die entsprechenden Eigenschaften des zugrunde liegenden Feldes festgelegt sind. In Formularen und Berichten werden jedoch die Einstellungen der Eigenschaften Gültigkeitsregel, Gültigkeitsmeldung und Standardwert des zugrunde liegenden Feldes übernommen, da diese Eigenschaften nicht nur für das Steuerelement, sondern auch für das Feld in jedem Fall festgelegt werden. Wenn Sie ein gebundenes Steuerelement erstellen, indem Sie Felder aus der Feldliste in ein Formular oder einen Bericht ziehen, erhält das gebundene Steuerelement automatisch bestimmte Eigenschaften des Feldes. Um weitere Informationen über das Zuweisen von Eigenschaften und zur Funktionsweise der automatischen Zuweisung in Formularen und Berichten zu erhalten, klicken Sie auf [image] .


 Erstellen eines ungebundenen Textfeldes oder anderen Steuerelements

Erstellen eines ungebundenen Textfeldes oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wenn Sie zum Erstellen des Steuerelements einen Assistenten verwenden möchten, müssen Sie sicherstellen, dass das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist.

    Anmerkungen

    • Auf Formularen und Berichten können Sie mit Hilfe von Assistenten Befehlsschaltflächen, Listenfelder, Unterformulare, Kombinationsfelder und Optionsgruppen erstellen. Auf Datenzugriffsseiten können Sie mit Hilfe von Assistenten Befehlsschaltflächen, Listenfelder und Dropdownlisten erstellen.

    • Assistenten sind auf einer Datenzugriffsseite, für die keine Verbindung besteht, nicht verfügbar. Sie sind ebensowenig verfügbar, wenn Sie eine Datenzugriffsseite nicht auf die aktuell geöffnete Datenbank verweisen. In diesen Fällen müssen Sie das Steuerelement ohne einen Assistenten erstellen.
  3. Klicken Sie in der Toolbox auf das Steuerelement, das Sie erstellen möchten.

  4. Klicken Sie im Formular, im Bericht oder auf der Datenzugriffsseite auf die Stelle, an der die obere linke Ecke des Steuerelements platziert werden soll.

    Anmerkungen

    • Wenn Sie klicken und dann die Maustaste loslassen, erstellt Microsoft Access ein Steuerelement in Standardgröße. Zum Erstellen eines Steuerelements in einer bestimmten Größe klicken Sie mit der Maustaste und ziehen dann mit der Maus, bis das Steuerelement die gewünschte Größe hat.
    • Wenn Sie mehrere Steuerelemente des gleichen Typs erstellen möchten, können Sie in der Toolbox auf das entsprechende Steuerelement doppelklicken. Damit wird das Steuerelement aktiviert gehalten.


Erstellen von spezifischen Textfeld- oder Steuerelementtypen in Formularen

Sie können einem Formular unterschiedliche Steuerelemente zum Anzeigen, Eingeben, Analysieren von Daten usw. hinzufügen

Dieses Thema enthält Referenzinformationen über:

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Steuerelemente zum Analysieren von Daten

Steuerelemente zum Organisieren von Daten

Steuerelemente zur Anpassung von Formularen für das Web

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Kontrollkästchen, Umschaltflächen oder Optionsfelder, die nicht Teil einer Optionsgruppe sind

Befehlsschaltflächen

Steuerelemente für Bilder oder sonstige mit einem anderen Anwendungsprogramm erstellte Objekte (beispielsweise Word-Dokumente)

Bezeichnungsfelder

Listen- oder Kombinationsfelder

Optionsgruppen mit Kontrollkästchen, Umschaltflächen oder Optionsfeldern

Unterformulare

Textfelder

Zurück zum Anfang

Steuerelemente zum Analysieren von Daten

Diagramme

Steuerelemente zum Anzeigen von Microsoft Access-Daten in einem PivotTable-Bericht aus Microsoft Excel

Zurück zum Anfang

Steuerelemente zum Organisieren von Daten

Steuerelemente mit mehreren Seiten oder Registerkarten

Zurück zum Anfang

Steuerelemente zur Anpassung von Formularen für das Web

Webseiten in einem Formular anzeigen

Ein ActiveX-Steuerelement hinzufügen

Zurück zum Anfang


Erstellen eines Textfeldes oder anderen Steuerelements auf einer Datenzugriffsseite

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Steuerelemente zum Analyliseren von Daten

Steuerelemente, die Hyperlinks sind

Steuerelemente, die Grafiken und animierten Text anzeigen

Weitere Steuerelemente

Steuerelemente zum Organisieren von Daten

Was möchten Sie erstellen?

Steuerelemente zum Eingeben, Anzeigen und Filtern von Daten

Gebundene HTML-Steuerelemente

Kontrollkästchen oder Optionsschaltflächen, die nicht in einer Optionsgruppe enthalten sind

Befehlsschaltflächen

Listenfelder und Dropdownlisten

Bezeichungsfelder

Optionsgruppen, die Kontrollkästchen oder Optionsschaltflächen enthalten

Textfelder

Zurück zum Anfang

Steuerelemente zum Analylisieren von Daten

Diagramme

Steuerelemente, die Microsoft Access-Daten in einer PivotTable-Liste anzeigen

Kalkulationstabellen

Zurück zum Anfang

Steuerelemente, die Hyperlinks sind

Hyperlinks

Gebundene Hyperlinks

Zurück zum Anfang

Steuerelemente, die Grafiken und animierten Text anzeigen

Steuerelemente für Bilder

Steuerelemente für Hotspot-Bilder

Lauftext-Steuerelemente

Zurück zum Anfang

Weitere Steuerelemente

ActiveX-Steuerelemente

Zurück zum Anfang

Steuerelemente zum Organisieren von Daten

Erweiterungs-Steuerelemente

Steuerelemente für die Datensatznavigation

Linien

Rechtecke

Zurück zum Anfang


Erstellen eines Textfeld-Steuerelements oder eines anderen Steuerelementtyps in einem Bericht

Was möchten Sie tun?

Ein Etikett erstellen

Ein Textfeld erstellen

Ein Kontrollkästchen oder ein Optionsfeld erstellen, das nicht in einer Optionsgruppe enthalten ist

Eine Optionsgruppe erstellen, die Kontrollkästchen oder Optionsfelder enthält

Eine Linie zeichnen

Ein Rechteck zeichnen

Einen Unterbericht erstellen

Ein Steuerelement für ein Bild oder ein anderes Objekt erstellen, das in einer anderen Anwendung erstellt wurde

Ein Diagramm erstellen

Ein ActiveX-Steuerelement erstellen


 Markieren eines Textfeldes oder eines anderen Steuerelements

Markieren eines Textfeldes oder eines anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf eine beliebige Stelle des Steuerelements.

Wenn dem Steuerelement in einem Formular oder Bericht ein angehängtes Bezeichnungsfeld zugeordnet ist, sieht es folgendermaßen aus:

Ausgewähltes Steuerelement mit angehängtem Bezeichnungsfeld in einem Formular oder Bericht

Wenn dem Steuerelement in einer Datenzugriffsseite ein angehängtes Bezeichnungsfeld zugeordnet ist, sieht es folgendermaßen aus:

Ausgewähltes Steuerelement mit angehängtem Bezeichnungsfeld in einer Datenzugriffsseite

Anmerkung Klicken Sie auf ein bereits ausgewähltes Steuerelement, so wird in diesem Steuerelement eine Einfügemarke angezeigt, die die Texteingabe oder -bearbeitung ermöglicht. Zum Auswählen des Steuerelements klicken Sie an eine Stelle außerhalb dieses Steuerelements und dann erneut darauf.


 Markieren angrenzender Textfelder oder Steuerelemente in Formularen und Berichten

Markieren angrenzender Textfelder oder Steuerelemente in Formularen und Berichten

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.
  2. Zeigen Sie auf eine beliebige Stelle außerhalb eines Steuerelements und ziehen Sie ein Rechteck um die Steuerelemente, die Sie auswählen möchten.

Tipps

Sie können festlegen, ob das um die Steuerelemente gezogene Rechteck die Steuerelemente nur berühren oder aber diese vollständig umfassen muss, damit die Steuerelemente ausgewählt sind. Klicken Sie dazu im Menü Extras auf Optionen, klicken Sie dann auf die Registerkarte Formulare/Berichte und anschließend auf eine der Optionen unter Markierungsverhalten.

Wenn Sie ein oder mehrere Steuerelemente aus der ausgewählten Gruppe löschen möchten, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf die zu entfernenden Steuerelemente.


 Markieren nichtangrenzender oder überlappender Steuerelemente in einem Formular oder Bericht

Markieren nichtangrenzender oder überlappender Steuerelemente in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann nacheinander auf jedes Steuerelement, das Sie auswählen möchten.


 Entfernen eines Textfeldes oder eines anderen Steuerelements aus einer Gruppe markierter Elemente in einem Formular oder Bericht

Entfernen eines Textfeldes oder eines anderen Steuerelements aus einer Gruppe markierter Elemente in einem Formular oder Bericht

Wenn Sie in der Formularentwurfsansicht oder der Berichtsentwurfsansicht mehrere Steuerelemente markiert haben, können Sie einzelne oder mehrere Steuerelemente aus der Gruppe entfernen. Zum Entfernen eines Steuerelements aus einer markierten Gruppe, halten Sie die UMSCHALTTASTE gedrückt und klicken dann auf das Steuerelement oder die Steuerelemente, die Sie entfernen möchten.


 Verschieben eines Textfelds oder eines anderen Steuerelements zusammen mit dem zugehörigen Bezeichnungsfeld

Verschieben eines Textfelds oder eines anderen Steuerelements zusammen mit dem zugehörigen Bezeichnungsfeld

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement oder das zugeordnete Bezeichnungsfeld.

    Wenn Sie in Formularen und Berichten auf einen beliebigen Teil eines zusammengesetzten Steuerelements klicken, zeigt Microsoft Access für beide Steuerelemente Ziehpunkte zum Verschieben und für das Steuerelement, auf das Sie geklickt haben, Ziehpunkte zum Ändern der Größe an. Wenn das Steuerelement auf einer Datenzugriffsseite ausgewählt wird, wird das Bezeichnungsfeld nicht automatisch ausgewählt. Wenn Sie das Steuerelement verschieben, wird das Bezeichnungsfeld ebenfalls verschoben. Wenn Sie jedoch das Bezeichnungsfeld verschieben, wird das Steuerelement nicht verschoben.

  3. Setzen Sie den Zeiger auf den Rahmen (nicht auf den Ziehpunkt zum Verschieben) des Steuerelements oder des Bezeichnungsfelds. In Formularen und Berichten wird der Zeiger in Form einer geöffneten Hand angezeigt. In Datenzugriffseiten wird er in Form eines Vierfachpfeils angezeigt. Sobald sich der Zeiger geändert hat, ziehen Sie das Steuerelement an die neue Position.

Steuerelement in einem Formular oder Bericht mit einem Cursor in Form einer geöffneten Hand

Steuerelement in einer Datenzugriffsseite mit einem Cursor in Form eines Vierfachpfeils

Anmerkungen

  • Sie können beim Verschieben eines Steuerelements in einem Formular oder Bericht die horizontale oder vertikale Ausrichtung an anderen Steuerelementen beibehalten. Dazu halten Sie beim Markieren und Verschieben des Steuerelements die UMSCHALTTASTE gedrückt. Jetzt wird das Steuerelement, abhängig von der Richtung, in der Sie die erste Bewegung machen, entweder nur horizontal oder nur vertikal verschoben.

  • Wenn Sie die Position eines Steuerelements nur minimal verändern möchten, ist es möglicherweise einfacher, dazu STRG zusammen mit der entsprechenden Pfeiltaste zu drücken. Wenn Sie ein Steuerelement auf diese Weise verschieben, richtet Access es in Formularen, Berichten und Datenzugriffsseiten nicht am Raster aus. Dies gilt auch dann, wenn die Option Am Raster ausrichten aktiviert ist.


 Getrenntes Verschieben eines Steuerelements oder des zugehörigen Bezeichnungsfelds

Getrenntes Verschieben eines Steuerelements oder des zugehörigen Bezeichnungsfelds

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement oder das zugeordnete Bezeichnungsfeld.

  3. Setzen Sie den Zeiger in Formularen und Berichten auf den Ziehpunkt in der linken oberen Ecke des Steuerelements oder des Bezeichnungsfelds. Der Zeiger ändert sich dann in eine nach oben zeigende Hand. In Datenzugriffsseiten setzen Sie den Zeiger auf eine beliebige Ecke des Rahmens des Steuerelements, bis der Zeiger in Form eines Vierfachpfeils angezeigt wird.

  4. Ziehen Sie das Steuerelement oder das Bezeichnungsfeld an die gewünschte Position. Die erste Demonstration zeigt, wie ein Steuerelement in einem Formular verschoben wird, die zweite Demo zeigt, wie ein Steuerelement auf einer Datenzugriffsseite verschoben wird.

Nur das in einem Formular oder Bericht ausgewählte Steuerelement

Nur das auf einer Datenzugriffsseite ausgewählte Textfeld

Anmerkungen

  • Die Verbindung zwischen den Teilen eines zusammengesetzten Steuerelements bleibt auch dann erhalten, wenn Sie diese einzeln verschieben.

  • Wenn Sie das einem Steuerelement zugeordnete Bezeichnungsfeld in einen anderen Bereich verschieben möchten, ohne gleichzeitig auch das Steuerelement zu verschieben, müssen Sie die Befehle Ausschneiden und Einfügen verwenden. Wenn Sie eine Bezeichnung in einen anderen Bereich verschieben, wird die Zuordnung zum Steuerelement aufgehoben.

  • Wenn Sie die Position eines Steuerelements in einem Formular, einem Bericht oder einer Datenzugriffsseite nur minimal verändern möchten, ist es möglicherweise einfacher, dazu STRG zusammen mit der entsprechenden Pfeiltaste zu drücken. Wenn Sie ein Steuerelement auf diese Weise verschieben, richtet es Microsoft Access nicht am Raster aus. Dies gilt auch dann, wenn die Option Am Raster ausrichten aktiviert ist.


 Verschieben von zwei oder mehr Steuerelementen in einem Formular oder Bericht gleichzeitig

Verschieben von zwei oder mehr Steuerelementen in einem Formular oder Bericht gleichzeitig

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Wählen Sie die Steuerelemente, indem Sie die UMSCHALTTASTE gedrückt halten, während Sie auf die einzelnen Steuerelemente klicken.

  3. Bewegen Sie den Zeiger über den Rand (nicht den Ziehpunkt zum Verschieben) eines beliebigen ausgewählten Steuerelements, bis sich der Zeiger in eine geöffnete Hand umwandelt, und ziehen Sie die Steuerelemente anschließend an die neue Position.

Beispiel mehrerer gleichzeitig ausgewählter Steuerelemente


 Verschieben eines Textfelds oder eines anderen Steuerelements vor oder hinter andere Steuerelemente

Verschieben eines Textfelds oder eines anderen Steuerelements vor oder hinter andere Steuerelemente

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie verschieben möchten, und klicken Sie dann im Menü Format auf In den Hintergrund oder auf In den Vordergrund.

Anmerkung Ein Listenfeld oder ein Unterformular wird immer oben auf einem Stapel von Steuerelementen, d.h. im Vordergrund, angezeigt. Sie können Listenfelder und Unterformulare nicht in den Hintergrund verschieben.


 Ausschneiden oder Kopieren und Einfügen eines Textfeldes oder anderen Steuerelements

Ausschneiden oder Kopieren und Einfügen eines Textfeldes oder anderen Steuerelements

Verwenden Sie an Stelle des Befehls Kopieren eher den Befehl Duplizieren, wenn Sie eine Gruppe von Steuerelementen mit gleichem Abstand voneinander erstellen möchten. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ausschneiden oder kopieren möchten. Wenn dem Steuerelement ein Bezeichnungsfeld zugeordnet ist, müssen Sie auf das Steuerelement klicken, nicht auf das Bezeichnungsfeld.

  3. Klicken Sie im Menü Bearbeiten auf Ausschneiden, wenn Sie das Steuerelement verschieben möchten, oder klicken Sie auf Kopieren, wenn Sie das Steuerelement kopieren möchten.

  4. Markieren Sie den Bereich, in den Sie das Steuerelement einfügen möchten.

  5. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Sie können bis zu einem bestimmten Grad festlegen, an welcher Stelle Microsoft Access das Steuerelement einfügen soll. Wenn Sie einen Bereich markieren, fügt Access das Steuerelement in der oberen linken Ecke des Bereichs ein. Wenn Sie ein Steuerelement in der Nähe der Stelle markieren, an der Sie es wieder einfügen möchten, fügt Access das Steuerelement direkt unter dem markierten Steuerelement ein. Wenn Sie jedoch ein Bezeichnungsfeld auf einem Formular oder Bericht einfügen und dem markierten Steuerelement kein Bezeichnungsfeld zugeordnet ist, ordnet Access das eingefügte Bezeichnungsfeld dem markierten Steuerelement zu.

Anmerkung Access kopiert nicht die einem Steuerelement zugeordneten Ereignisprozeduren.


 Duplizieren eines Textfeldes oder anderen Steuerelements

Duplizieren eines Textfeldes oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie duplizieren möchten. Wenn das Steuerelement mit einer Beschriftung versehen ist, klicken Sie auf das Steuerelement, nicht auf die Beschriftung.

  3. Klicken Sie im Menü Bearbeiten auf Duplizieren.

    Microsoft Access fügt das Steuerelement direkt unter dem markierten Steuerelement ein.

  4. Wenn Sie im gleichen Abstand ein weiteres Steuerelement erstellen möchten, klicken Sie erneut auf Duplizieren.

    Microsoft Access platziert das Steuerelement unter das zuletzt eingefügte Steuerelement. Das ist auch dann der Fall, wenn Sie dieses Steuerelement verschoben haben.

Anmerkungen

  • Beim Duplizieren eines Steuerelements kopiert Microsoft Access nicht Ereignisprozeduren, die mit dem Steuerelement verknüpft sind.

  • Wenn Sie in einem Formular oder Bericht nur die Formatierungseigenschaften von einem Steuerelement auf ein anderes übertragen möchten, klicken Sie in der Symbolleiste auf Format übertragen [image] . Zum Aufrufen weiterer Informationen klicken Sie auf [image] .


 Kopieren der Formateigenschaften eines Textfeldes oder anderen Steuerelements in ein anderes Steuerelement in einem Formular oder Bericht

Kopieren der Formateigenschaften eines Textfeldes oder anderen Steuerelements in ein anderes Steuerelement in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das die Formateigenschaften besitzt, die Sie kopieren möchten.

    Anmerkung Sie können immer nur Eigenschaften eines einzelnen Steuerelements kopieren.

  3. Klicken Sie in der Symbolleiste auf Format übertragen [image] . Wenn Sie dieselben Formateigenschaften für mehrere Steuerelemente verwenden möchten, doppelklicken Sie auf die Schaltfläche, um diese festzuhalten.

  4. Klicken Sie auf das Steuerelement, für das Sie die Formateigenschaften einfügen möchten. Sie können auf ein Steuerelement desselben Typs klicken oder einen anderen Steuerelementtyp markieren. Sie können beispielsweise die Formateigenschaften eines Textfelds für ein Listenfeld kopieren.

    Microsoft Access unterstützt das Kopieren der folgenden Eigenschaften:

Rahmenart | Zeilenabstand | Spezialeffekt
Rahmenfarbe | Sichtbar | Schriftbreite
Rahmenbreite | Anzeigen | Textfarbe
Hintergrundfarbe | Schriftart | Kursiv
Hintergrundart | Schriftgrad | Unterstrichen
BezeichnungsfeldX | Textausrichtung | Bezeichnungsausrichtung
BezeichnungsfeldY |  |

Anmerkung Sie können nicht die Eigenschaften von oder für ActiveX-Steuerelementen kopieren.


 Löschen eines Textfeldes oder anderen Steuerelements

Löschen eines Textfeldes oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement.

  3. Drücken Sie ENTF.

    Wenn dem Steuerelement ein Bezeichnungsfeld zugeordnet ist, löscht Microsoft Access das Steuerelement und die entsprechende Bezeichnung. Wenn Sie nur das zugeordnete Bezeichnungsfeld löschen möchten, klicken Sie auf die Bezeichnung, und drücken Sie dann ENTF.


 Ändern eines Textfelds oder anderen Steuerelements

Ändern eines Textfelds oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das/die Steuerelement(e), für das/die Sie die Größe ändern möchten.

  3. Ziehen Sie an den Ziehpunkten zur Größenänderung, bis das Steuerelement die gewünschte Größe hat.

Anzeigen eines Beispiels für das Bewegen und Anpassen von Ziehpunkten

Wenn Sie in einem Formular oder Bericht mehrere Steuerelemente markieren, wird beim Ziehen am Ziehpunkt zur Größenänderung eines der Steuerelemente die Größe aller Steuerelemente geändert.

Anmerkungen

  • Auf einer Datenzugriffsseite kann weder ein Listenfeld noch eine Dropdownliste vertikal angepasst werden. Die vertikale Größe des Listenfelds oder der Dropdownliste basiert auf der Einstellung der Datenschriftart im Steuerelement.

  • Wenn Sie die Größe eines Steuerelements nur minimal in einer Formel oder einem Bericht verändern möchten, ist es möglicherweise einfacher, dazu die UMSCHALTTASTE zusammen mit der entsprechenden Pfeiltaste zu drücken.


 Anpassen eines Textfelds oder anderen Steuerelements, damit der Inhalt in ein Formular oder in einen Bericht passt

Anpassen eines Textfelds oder anderen Steuerelements, damit der Inhalt in ein Formular oder in einen Bericht passt

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Markieren Sie das/die Steuerelement(e), für das/die Sie die Größe ändern möchten.

  3. Zeigen Sie im Menü Format auf Größe und klicken Sie dann auf An Textgröße.


 Einheitliches Ändern von Textfeldern oder anderen Steuerelementen unter Verwendung des Rasters in einem Formular oder Bericht

Einheitliches Ändern von Textfeldern oder anderen Steuerelementen unter Verwendung des Rasters in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Sofern das Raster nicht bereits angezeigt wird, klicken Sie im Menü Ansicht auf Raster.

  3. Markieren Sie die Steuerelemente, deren Größe Sie anpassen möchten.

  4. Zeigen Sie im Menü Format auf Größe und klicken Sie dann auf Am Raster.

Anmerkung

  • Sie können festlegen, dass Microsoft Access Elemente beim Ändern der Größe automatisch am Raster ausrichtet. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .

  • Sie können den Abstand zwischen den Punkten im Raster ändern, wenn Sie beim Ändern der Größe von Steuerelementen einen höheren Genauigkeitsgrad benötigen. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .


 Einheitliches Ändern der Größe von Textfeldern oder anderen Steuerelementen in Relation zueinander in einem Formular oder Bericht

Einheitliches Ändern der Größe von Textfeldern oder anderen Steuerelementen in Relation zueinander in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Markieren Sie die Steuerelemente, deren Größe Sie ändern möchten.

  3. Zeigen Sie im Menü Format auf Größe und klicken Sie dann auf einen der folgenden Befehle:
    • Am Höchsten. Macht alle Steuerelemente so hoch wie das höchste markierte Steuerelement.

    • Am Niedrigsten. Macht alle Steuerelemente so niedrig wie das niedrigste markierte Steuerelement.

    • }Am Breitesten. Macht alle Steuerelemente so breit wie das breiteste markierte Steuerelement.

    • Am Schmalsten. Macht alle Steuerelemente so schmal wie das schmalste markierte Steuerelement.


 Ausrichten von Textfeldern und anderen Steuerelementen in Formularen oder Berichten mit Hilfe des Rasters

Ausrichten von Textfeldern und anderen Steuerelementen in Formularen oder Berichten mit Hilfe des Rasters

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Sofern das Raster nicht bereits angezeigt ist, klicken Sie im Menü Ansicht auf Raster.

  3. Wählen Sie das Steuerelement bzw. die Steuerelemente aus, das/die Sie ausrichten möchten.

  4. Zeigen Sie im Menü Format auf Ausrichten, und klicken Sie auf am Raster.

Anmerkungen

Sie können festlegen, dass Microsoft Access Elemente beim Erstellen oder Verschieben automatisch am Raster ausrichtet. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Sie können den Abstand zwischen den Punkten im Raster ändern, wenn Sie beim Ausrichten von Steuerelementen am Raster einen höheren Genauigkeitsgrad benötigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Ausrichten von Textfeldern oder anderen Steuerelementen auf Datenzugriffsseiten

Ausrichten von Textfeldern oder anderen Steuerelementen auf Datenzugriffsseiten

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Ausrichtung und Größenanpassung, um die Symbolleiste Ausrichtung und Größenanpassung anzuzeigen.

Symbolleiste Ausrichtung und Größenanpassung

  3. Vergewissern Sie sich, dass das Textfeld oder das andere Steuerelement, das in der gewünschten Weise ausgerichtet werden soll, markiert ist.

  4. Klicken Sie auf die entsprechende Schaltfläche in der Symbolleiste Ausrichtung und Größenanpassung und dann auf das Steuerelement, das Sie in der Größe verändern oder an dem ausgewählten Steuerelement ausrichten wollen.

    Tipp Um nur ein einzelnes Steuerelement auszurichten oder in der Größe zu verändern, klicken Sie nur einmal auf die Schaltfläche in der Symbolleiste. Um die Schaltfläche "einzurasten", so dass Sie mehrere Steuerelemente gleichzeitig ändern können, doppelklicken Sie auf die Schaltfläche. Um die Schaltfläche wieder zu lösen, klicken Sie auf die gleiche oder auf eine andere Schaltfläche, oder drücken Sie ESC.


 Aktivieren bzw. Deaktivieren der Funktion zum Ausrichten am Raster

Aktivieren bzw. Deaktivieren der Funktion zum Ausrichten am Raster

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Am Raster ausrichten.

    Wenn die Am Raster ausrichten-Funktion aktiviert ist und Sie ein Steuerelement durch Klicken auf das Formular oder den Bericht erstellen, richtet Microsoft Access die obere linke Ecke des Steuerelements am Raster aus. Wenn Sie ein Steuerelement durch Ziehen erstellen, richtet Microsoft Access alle Ecken am Raster aus. Wenn Sie ein vorhandenes Steuerelement verschieben oder seine Größe ändern, können Sie das Steuerelement oder dessen Rahmen nur rasterpunktweise bewegen.

Wenn die Am Raster ausrichten-Funktion deaktiviert ist, ignoriert Microsoft Access das Raster und überlässt es Ihnen, Steuerelemente an beliebigen Stellen im Formular, Bericht oder in der Datenzugriffsseite zu positionieren, verschieben oder zu vergrößern/verkleinern.

Tipp Wenn Sie die Am Raster ausrichten-Funktion vorübergehend deaktivieren möchten, drücken Sie vor dem Positionieren, Verschieben oder Vergrößern/Verkleinern eines Steuerelements STRG und halten Sie die Taste gedrückt. Sobald Sie STRG loslassen, ist die Am Raster ausrichten-Funktion wieder aktiviert.


 Ausrichten von Textfeldern und anderen Steuerelementen in Formularen oder Berichten

Ausrichten von Textfeldern und anderen Steuerelementen in Formularen oder Berichten

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Wählen Sie die Steuerelemente aus, die Sie ausrichten möchten. Wählen Sie nur Steuerelemente aus, die sich in der gleichen Zeile oder der gleichen Spalte befinden.

  3. Zeigen Sie im Menü Format auf Ausrichten, und klicken Sie dann auf einen der folgenden Befehle:
    • Linksbündig. Richtet die linken Ecken der Steuerelemente an den linken Ecken des Steuerelements aus, das am weitesten links positioniert ist.

    • Rechtsbündig. Richtet die rechten Ecken der Steuerelemente an den rechten Ecken des Steuerelements aus, das am weitesten rechts positioniert ist.

    • Nach oben. Richtet die oberen Ecken der Steuerelemente an den oberen Ecken des obersten Steuerelements aus.

    • Nach unten. Richtet die unteren Ecken der Steuerelemente an den unteren Ecken des untersten Steuerelements aus.

Anmerkung Wenn eines der ausgewählten Steuerelemente nach dem Ausrichten von einem anderen überlappt würde, positioniert Microsoft Access stattdessen die Steuerelemente so, dass die Ecken nebeneinander liegen.


 Gleichmäßiges Verteilen von Textfeldern oder anderen Steuerelementen in einem Formular oder einem Bericht

Gleichmäßiges Verteilen von Textfeldern oder anderen Steuerelementen in einem Formular oder einem Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Wählen Sie die Steuerelemente aus (mindestens drei), die angepasst werden sollen. Wenn Sie Steuerelemente mit zugeordnetem Bezeichnungsfeld ausrichten möchten, müssen Sie die Steuerelemente, nicht deren Bezeichnungsfelder, markieren.

  3. Zeigen Sie im Menü Format auf Horizontaler Abstand oder Vertikaler Abstand und klicken Sie dann auf Angleichen.

    In Microsoft Access werden Steuerelemente gleichmäßig verteilt. Nur die mittleren Steuerelemente passen sich tatsächlich an; die oberen und unteren Steuerelemente ändern ihre Position nicht.


 Vergrößern oder Verkleinern des Abstandes zwischen Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

Vergrößern oder Verkleinern des Abstandes zwischen Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Markieren Sie die Steuerelemente, für die Sie den Abstand ändern möchten.

  3. Zeigen Sie im Menü Format auf Horizontaler Abstand oder Vertikaler Abstand, und klicken Sie dann auf Vergrößern oder Verkleinern.

    Beim Verkleinern oder Vergrößern des Abstands zwischen Steuerelementen wird die Position des Steuerelements an der äußersten linken Position (beim Ändern des horizontalen Abstands) und des Steuerelements an der höchsten Position (beim Ändern des vertikalen Abstands) nicht verändert.


 Relative oder absolute Positionierung von Text, Textfeldern oder anderen Elementen auf einer Datenzugriffsseite

Relative oder absolute Positionierung von Text, Textfeldern oder anderen Elementen auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Textfeld oder andere Steuerelemente, der Bereich oder Text ausgewählt ist, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] .

  3. Klicken Sie im Einstellungsfeld der Position-Eigenschaft auf einen Wert in der Liste.
    • Relative Positioniert das Element im natürlichen HTML-Ablauf des Dokuments, passt jedoch die Position des Elements an die vorhergehenden Inhalte an. Zum Beispiel ist standardmäßig die Position eines Steuerelements, das in einen Absatz im Hauptteil einer Seite eingefügt wird, relativ zum vorhergehenden Text. Bei Anzeige in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer passt sich die Anordnung des Inhalts automatisch an die Größe des Fensters an.

    • Absolute Ordnet das Element in einer festen Position in Beziehung entweder zum nächsten positionierten Element in der Hierarchie (seinem übergeordneten Element), oder, falls dies nicht existiert, zum Hauptteil an. Die Werte in den Left- und Top-Eigenschaften des Elements beziehen sich auf die linke obere Ecke des übergeordneten Elements. Zum Beispiel wird die Position eines Steuerelements in einem Bereich standardmäßig in Beziehung zu den Left- und Top-Eigenschaften des Bereichs fixiert. Bei Anzeige in der Datenzugriffsseitenansicht oder in Internet Explorer behält der Inhalt seine Position bei, auch wenn sich die Größe des Fensters ändert.


 Ändern eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht in einen anderen Steuerelementtyp

Ändern eines Textfeldes oder anderen Steuerelements in einem Formular oder Bericht in einen anderen Steuerelementtyp

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie im Menü Format auf Ändern zu.

    Microsoft Access zeigt eine Liste mit Steuerelementen an, in die Sie das ausgewählte Steuerelement ändern können. Ist ein Steuerelementtyp im Menü nicht verfügbar, können Sie das ausgewählte Steuerelement nicht in diesen Typ ändern.

  4. Klicken Sie auf den Steuerelementtyp, in den Sie das ausgewählte Steuerelement ändern möchten.

    Beim Ändern eines Steuerelements in einen anderen Steuerelementtyp kopiert Access die entsprechenden Eigenschafteneinstellungen des ursprünglichen Steuerelements auf das neue Steuerelement. Wenn jedoch für das ursprüngliche Steuerelement eine Eigenschaft existiert, die für das neue Steuerelement nicht eingestellt werden kann, kopiert Access diese nicht. Existiert für das neue Steuerelement eine Eigenschaft, die für das ursprüngliche Steuerelement nicht existiert, legt Microsoft Access für diese Eigenschaft die entsprechende Standardsteuerelementeinstellung dieses Steuerelementtyps fest.


 Zuweisen eines Standardwertes zu einem Steuerelement

Zuweisen eines Standardwertes zu einem Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Standardwert den gewünschten Standardwert (z.B. Bonn) oder einen Ausdruck (z.B. =Datum()) ein. Wenn der eingegebene Zeichenfolgenausdruck Kommas oder andere Interpunktionszeichen enthält, müssen Sie den Wert in Anführungszeichen setzen. Um z.B. "Bonn, NRW" als Standardwert zu verwenden, geben Sie "Bonn, NRW" ein. Falls Sie bei einem Formular in einer Microsoft Access-Datenbank (.mdb) zum Erstellen des Ausdrucks Hilfe benötigen, klicken Sie auf die Aufbauen-Schaltfläche [image] , um den Ausdrucks-Generator zu verwenden.

Anmerkung Wenn Sie die Eigenschaft Standardwert für ein Feld im Tabellenentwurf einstellen und diese Eigenschaft auch für ein an das Feld gebundenes Steuerelement einstellen, setzt der Standardwert für das Steuerelement den für das Feld definierten Standardwert außer Kraft.


Ändern der Standardeigenschaften für ein Textfeld oder andere Steuerelemente in einem Formular oder Bericht

Was möchten Sie tun?

Die Standardeinstellung eines Steuerelements für das aktuelle Formular oder den aktuellen Bericht ändern

Die Standardeinstellung eines Steuerelements für das aktuelle Formular oder den aktuellen Bericht auf der Basis eines vorhandenen Steuerelements ändern

Die Standardeinstellung eines Steuerelements für alle Formulare oder Berichte ändern

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Info über das Ändern von Standardeigenschaften für ein Textfeld oder ein anderes Steuerelement in einem Formular oder Bericht

Info über das Ändern von Standardeigenschaften für ein Textfeld oder ein anderes Steuerelement in einem Formular oder Bericht

Es gibt für jeden Steuerelementtyp eine Reihe von Standardeigenschaften, die die allgemeine Darstellung und das Verhalten dieses Typs beschreiben. Die Standardeigenschaften für ein Textfeld beschreiben z. B. die Größe und die Schriftart für das Textfeld und geben an, ob dem Textfeld ein Bezeichnungsfeld zugeordnet ist. Diese Gruppe von Eigenschaften für ein bestimmtes Steuerelement wird als Standard-Steuerelementeinstellung bezeichnet. Sie können die Standard-Steuerelementeinstellung für einen Steuerelementtyp ändern, wenn Sie feststellen, dass Sie für diesen Typ nach dem Hinzufügen zu einem Formular oder Bericht sehr häufig dieselben Änderungen vornehmen.

Angenommen, Sie möchten für Textfelder, die Sie in ein neues Formular einfügen, grundsätzlich keine Bezeichnungsfelder erstellen. In diesem Fall ist es sinnvoller, für die Mit Bezeichnungsfeld-Eigenschaft der Standard-Steuerelementeinstellung für Textfelder die Einstellung Nein zu setzen, anstatt nach jedem Erstellen eines Textfelds das entsprechende Bezeichnungsfeld zu löschen.

Wenn Sie die Standard-Steuerelementeinstellung eines Steuerelementtyps zurücksetzen, erhalten alle Steuerelemente, die Sie im Anschluss an diese Änderung in das aktuelle Formular oder den aktuellen Bericht einfügen, diese Eigenschafteneinstellungen. Die Standard-Steuerelementeinstellung behält die gesetzten Einstellungen für dieses Formular bzw. den Bericht, bis Sie diese erneut ändern.

Zurück zu Ändern von Standardeigenschaften für ein Textfeld oder ein anderes Steuerelement in einem Formular oder Bericht.


 Gleichzeitiges Ändern der Eigenschaften mehrerer Textfelder oder anderer Steuerelemente in einem Formular oder Bericht

Gleichzeitiges Ändern der Eigenschaften mehrerer Textfelder oder anderer Steuerelemente in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass ein Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Markieren Sie alle weiteren Steuerelemente. Dazu drücken Sie die UMSCHALTTASTE und halten diese gedrückt, während Sie nacheinander auf alle gewünschten Steuerelemente klicken.

  4. Ändern Sie die gewünschten Einstellungen im Eigenschaftenfenster.

Anmerkungen

  • Sie können die Eigenschafteneinstellungen für eine Gruppe von Steuerelementen gleichen oder unterschiedlichen Typs gleichzeitig ändern. Wenn Sie Steuerelemente unterschiedlichen Typs markieren, zeigt Microsoft Access im Eigenschaftenfenster nur die Eigenschaften an, die der Gruppe gemeinsam sind. Wenn bei allen ausgewählten Steuerelementen eine Eigenschaft identisch eingestellt ist, erscheint diese Einstellung im Eigenschaftenfenster. Ist eine Einstellung nicht bei allen Steuerelementen identisch, bleibt die entsprechende Zeile im Eigenschaftenfenster leer. Wenn Sie eine Eigenschafteneinstellung ändern, hat diese Änderung für alle markierten Steuerelemente Gültigkeit.

  • Die Eigenschaft Name wird nie angezeigt, wenn mehr als ein Steuerelement markiert ist, da Steuerelementnamen eindeutig sein müssen.


 Beziehungen zwischen den Eigenschaften von Steuerelementen in einem Formular oder Bericht und den Eigenschaften der zugrunde liegenden Felder einer Access-Datenbank

Beziehungen zwischen den Eigenschaften von Steuerelementen in einem Formular oder Bericht und den Eigenschaften der zugrunde liegenden Felder einer Access-Datenbank

Wenn Sie in Formularen oder Berichten ein gebundenes Steuerelement erstellen, indem Sie ein Feld aus der Feldliste ziehen, kopiert Microsoft Access bestimmte Eigenschaften des Feldes in der zugrunde liegenden Tabelle oder Abfrage zum Steuerelement. Angenommen, es gibt in einer Tabelle Artikel ein Feld namens Einzelpreis, dessen Format-Eigenschaft auf den Wert Währung und dessen Dezimalstellenanzeige-Eigenschaft auf den Wert Automatisch gesetzt ist. Wenn Sie nun in einem Formular ein gebundenes Textfeld erstellen, und zu diesem Zweck das Feld Einzelpreis von der Feldliste auf das Formular ziehen, übernimmt Access automatisch dessen Einstellungen von Format und Dezimalstellenanzeige für das Textfeld-Steuerelement. (Das setzt voraus, dass die Sichtbar-Eigenschaft des Feldes Textfeld gesetzt oder nicht definiert ist.)

Die Einstellungen der geerbten (kopierten) Eigenschaften lassen sich in der Eigenschaftenseite des Steuerelements ändern. Wenn Sie die Einstellung einer solchen Steuerelementeigenschaft ändern, hat diese Änderung keine Auswirkung auf die entsprechende Eigenschaft des dem Steuerelement zugrunde liegenden Feldes (einer Tabelle oder Abfrage). Ähnliches gilt für den umgekehrten Fall: wenn Sie die Einstellung einer Eigenschaft eines Feldes in einer Tabelle oder Abfrage ändern, nachdem Sie unter Verwendung des Feldes ein Formular erstellt haben, müssen Sie diese Änderung manuell im Steuerelement nachvollziehen. (Beachten Sie aber, dass Einstellungsänderungen der Feldeigenschaften Standardwert, Gültigkeitsregel und Gültigkeitsmeldung automatisch von allen Steuerelementen übernommen werden, die auf der Grundlage dieses Felds erstellt wurden. Dies gilt auch für den Fall, dass die Steuerlemente erstellt wurden, bevor Sie die Feldeigenschaften geändert haben.)

Tipp Es empfiehlt sich, die Eigenschaften Format, Dezimalstellenanzeige, Eingabeformat, Gültigkeitsregel, Gültigkeitsmeldung und Standardwert eher im zugrunde liegenden Feld einzustellen als umgekehrt im Steuerelement. So können Sie sicher sein, dass Sie mit konsistenten Einstellungen arbeiten, wenn Sie Felder zu einem Formular oder Bericht hinzufügen.

Die folgende Tabelle listet für alle gebundenen Steuerelemente die Eigenschaften auf, die übernommen werden, wenn Sie innerhalb von Formularen oder Berichten ein entsprechendes Feld aus der Feldliste auf das Formular bzw. den Bericht ziehen.

Gebundenes Steuerelement | Geerbte Eigenschaften
Textfeld | Format, Dezimalstellenanzeige, Eingabeformat und Statusleistentext (letztere von der Beschriftung-Eigenschaft)
Listenfeld | Alle Eigenschaften, die in der Registerkarte Nachschlagen der Entwurfsansicht für die Tabelle aufgelistet sind, sowie die Statusleistentext-Eigenschaft (letztere von der Beschriftung-Eigenschaft)
Kombinationsfeld | Alle Eigenschaften, die in der Registerkarte Nachschlagen der Entwurfsansicht für die Tabelle aufgelistet sind, sowie die Eingabeformat-Eigenschaft und die Statusleistentext-Eigenschaft (letztere von der Beschreibung-Eigenschaft)
Kontrollkästchen, Optionsfeld, Optionsgruppe, Umschaltfläche Gebundenes Objektfeld | Statusleistentext-Eigenschaft (von der Beschreibung-Eigenschaft)

Anmerkungen

  • Die Einstellungen der Eigenschaften Standardwert, Gültigkeitsregel und Gültigkeitsmeldung werden nicht übernommen. Access übernimmt also die Einstellungen dieser Eigenschaften des zugrunde liegenden Feldes nicht in das einem Feld zugeordnete Steuerelement. Allerdings werden die Einstellungen dieser Eigenschaften in Kraft gesetzt, wenn Sie ein Steuerelement erstellen, das auf einem Feld mit diesen Eigenschaften basiert. Wenn Sie die Gültigkeitsregel-Eigenschaft für ein Feld und außerdem für ein auf diesem Feld basierenden Steuerelement definieren, setzt Access beide Regeln in Kraft. Wird die Standardwert-Eigenschaft für ein Feld und ein auf ihm basierendes Steuerelement definiert, so überschreibt die Einstellung der Steuerelementeigenschaft die Einstellung der Feldeigenschaft.

  • Bei Erstellung eines Textfeld-Steuerelements auf Basis eines Felds vom Datentyp Memo setzt Access automatisch die Eingabetastenverhalten-Eigenschaft auf den Wert Neue Zeile im Feld und die Bildlaufleisten-Eigenschaft auf den Wert Nur vertikal. Diese Eigenschaften werden nicht von den Feldeigenschaften übernommen, sondern es handelt sich um spezielle Eigenschaften des Steuerelements.


 Ändern der Schriftart für Text in einem Textfeld oder anderen Steuerelement

Ändern der Schriftart für Text in einem Textfeld oder anderen Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das den zu ändernden Text enthält.

  3. Klicken Sie im Feld Schriftart FontNames-Objekt in der Formatsymbolleiste für Formulare und Berichte oder der Formatsymbolleiste für Datenzugriffsseiten auf die Schriftart, die Sie anwenden möchten.

    Wenn Sie die Schriftart ändern, gilt die Änderung für den gesamten Inhalt des Steuerelements. Sie können keine einzelnen Zeichen in einem Steuerelement ändern.

Tipp Wenn Sie in Formularen oder Berichten die Größe des Steuerelements an die neue Schriftart anpassen möchten, zeigen Sie im Menü Format auf Größe und klicken dann auf Größe.


 Ändern des Schriftgrads für Text in einem Textfeld oder anderen Steuerelement

Ändern des Schriftgrads für Text in einem Textfeld oder anderen Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das den zu ändernden Text enthält.

  3. Geben Sie im Feld Schriftgrad [image] in der Formatsymbolleiste für Formulare und Berichte oder der Formatsymbolleiste für Datenzugriffsseiten den gewünschten Schriftgrad ein.

    In Lauftext-Steuerelementen auf Datenzugriffsseiten können Sie Text innerhalb des Steuerelements auswählen und Formatierungen auf einzelne Zeichen anwenden. In allen anderen Steuerelementen gelten Änderungen des Schriftgrades für den gesamten Inhalt des Steuerelements. In diesen Steuerelementen können Sie keine einzelnen Zeichen ändern.

Tipp Wenn Sie in Formularen oder Berichten die Größe des Steuerelements an den neuen Schriftgrad anpassen möchten, zeigen Sie im Menü Format auf Größe und klicken dann auf Größe.


 Ändern der Ausrichtung von Text in einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

Ändern der Ausrichtung von Text in einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das den zu ändernden Text enthält.

  3. Klicken Sie in der Formatsymbolleiste für Formulare und Berichte auf Zentrieren [image] , wenn Sie den Text zentrieren möchten, auf Rechtsbündig [image] , wenn Sie den Text am rechten Rand ausrichten möchten, oder auf Linksbündig [image] , wenn Sie den Text am linken Rand ausrichten möchten.

Anmerkung Wenn Sie keine der Schaltflächen zum Ausrichten wählen, erhält das Steuerelement die Standardausrichtung, d. h. Text wird am linken Rand und Zahlen sowie Datumsangaben am rechten Rand ausgerichtet.


 Ändern der Standardausrichtung von Text in neuen Textfeldern oder anderen Steuerelementen in Formularen oder Berichten

Ändern der Standardausrichtung von Text in neuen Textfeldern oder anderen Steuerelementen in Formularen oder Berichten

Änderungen, die Sie mit Hilfe der nachfolgenden Schritte vornehmen, haben nur für neue Steuerelemente im aktuellen Formular oder Bericht Gültigkeit. Wenn Sie die Standardeigenschafteneinstellungen für alle Formulare oder Berichte ändern möchten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das entsprechende Steuerelement. Wenn Sie beispielsweise die Standardausrichtung von Text in einem Textfeld ändern möchten, klicken Sie in der Toolbox auf das Steuerelement Textfeld Textfeld-Steuerelement .
  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

    Microsoft Access ändert die Titelleiste des Eigenschaftenfensters und weist so darauf hin, dass Sie jetzt die Standardeigenschaften für diesen Steuerelementtyp festlegen.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft Textausrichtung auf Standard, Linksbündig, Zentriert, Rechtsbündig oder Verteilen. Wenn Sie auf Standard klicken, richtet Access Text am linken Rand und Zahlen sowie Datumsangaben am rechten Rand aus.


 Einstellen der Ränder innerhalb eines Bezeichnungs- oder Textfelds in einem Formular oder Bericht

Einstellen der Ränder innerhalb eines Bezeichnungs- oder Textfelds in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Markieren Sie das Steuerelement und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für dieses Steuerelement anzuzeigen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie den linken Rand eines Steuerelements ändern möchten, geben Sie im Einstellungsfeld der LinkerRand-Eigenschaft die neue Randeinstellung ein.

    • Wenn Sie den oberen Rand eines Steuerelements ändern möchten, geben Sie im Einstellungsfeld der ObererRand-Eigenschaft die neue Randeinstellung ein.

    • Wenn Sie den rechten Rand eines Steuerelements ändern möchten, geben Sie im Einstellungsfeld der RechterRand-Eigenschaft die neue Randeinstellung ein.

    • Wenn Sie den unteren Rand eines Steuerelements ändern möchten, geben Sie im Einstellungsfeld der UntererRand-Eigenschaft die neue Randeinstellung ein.

Anmerkung Sie können Werte für Ränder wahlweise in Zoll ("), Zentimeter (cm), Pixel (px) oder Punkten (pt) angeben. So wird beispielsweise mit dem Wert 5px ein Rand eingestellt, der 5 Pixel vom äußeren Rand des Steuerelements entfernt ist.


 Vertikale Anzeige von Text in einem Text- oder Bezeichnungsfeld in einem Formular oder Bericht

Vertikale Anzeige von Text in einem Text- oder Bezeichnungsfeld in einem Formular oder Bericht

  1. Öffen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Markieren Sie das Steuerelement, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das Steuerelement anzuzeigen.

  3. Klicken Sie im Eigenschaftenfeld Vertikal auf Ja.


 Darstellen von Text in einem Textfeld oder einem anderen Steuerelement mit einer der Formatierungen Fett, Kursiv oder Unterstrichen

Darstellen von Text in einem Textfeld oder einem anderen Steuerelement mit einer der Formatierungen Fett, Kursiv oder Unterstrichen

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das den zu ändernden Text enthält.

  3. Klicken Sie in der Symbolleiste Formular-/Berichtsformat oder der Symbolleiste Datenzugriffsseiten-Format auf Fett [image] , um Text fett darzustellen, auf Kursiv [image] , um Text kursiv darzustellen oder auf Unterstrichen [image] , um Text zu unterstreichen.

    Auf einer Datenzugriffsseite können Sie durch Ausführen eines Lauftext-Steuerelemente Text auswählen und eines der Formate Fett, Kursiv oder Unterstrichen zuweisen, um einzelne Zeichen innerhalb des Steuerelements zu formatieren. In allen anderen Steuerelementen in Formularen, Berichten und Datenzugriffsseiten gilt beim Zuweisen eines dieser Formate die Änderung für den gesamten Inhalt des Steuerelements. Sie können nicht einzelne Zeichen in einem Steuerelement ändern.

Tipp Wenn Sie in Formularen und Berichten die Größe des Steuerelements an den geänderten Text anpassen möchten, zeigen Sie im Menü Format auf Größe und klicken dann auf an Textgröße.


 Ändern der Standardausrichtung von Text in neuen zugeordneten Bezeichnungsfeldern in Formularen oder Berichten

Ändern der Standardausrichtung von Text in neuen zugeordneten Bezeichnungsfeldern in Formularen oder Berichten

Änderungen, die Sie mit Hilfe der nachstehenden Schritte ausführen, gelten nur für neue Steuerelemente im aktuellen Formular oder Bericht. Wenn Sie die Standardeigenschafteneinstellungen für alle Formulare und Berichte ändern möchten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement für den gewünschten Steuerelementtyp, dem ein Bezeichnungsfeld zugeordnet ist. Wenn Sie beispielsweise die Standardausrichtung von Text in Bezeichnungsfeldern ändern möchten, die Textfeldern zugeordnet sind, klicken Sie in der Toolbox auf das Steuerelement Textfeld Textfeld-Steuerelement .

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

    Microsoft Access ändert die Titelleiste des Eigenschaftenfensters und weist so darauf hin, dass Sie jetzt die Standardeigenschaften für diesen Steuerelementtyp festlegen.

  4. Klicken Sie im Einstellungsfeld der Bezeichnungsausrichtung-Eigenschaft auf Linksbündig, Zentriert, Rechtsbündig oder Verteilen.

    Zum Anzeigen weiterer Informationen, wie die Bezeichnungsausrichtung-Eigenschaft mit den Eigenschaften BezeichnungsfeldX und BezeichnungsfeldY zusammenwirkt, klicken Sie auf [image] .


 Ändern der Textfarbe in einem Textfeld oder anderen Steuerelement

Ändern der Textfarbe in einem Textfeld oder anderen Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement mit dem Text, dessen Farbe Sie ändern möchten.

  3. Klicken Sie auf der Formatsymbolleiste für Formulare und Berichte oder auf der Formatsymbolleiste für Datenzugriffsseiten auf den Pfeil neben Schrift-/Vordergrundfarbe [image] .

  4. Klicken Sie in der Palette auf die gewünschte Farbe.

Tipp Wenn Sie die gewählte Farbe für ein anderes Steuerelement oder einen anderen Bereich verwenden möchten, können Sie einfach auf Schrift-/Vordergrundfarbe [image] klicken (d. h., Sie müssen nicht auf den Pfeil neben der Schaltfläche klicken und die Farbe erneut auswählen). Wenn Sie für mehrere Steuerelemente gleichzeitig unterschiedliche Farben festlegen möchten, klicken Sie auf den Pfeil neben Schrift-/Vordergrundfarbe [image] , dann auf den Rahmen der Farbpalette, und ziehen Sie diese an eine andere Position. Mit dieser Methode müssen Sie nicht jedesmal auf Schrift-/Vordergrundfarbe [image] klicken, wenn Sie eine Farbe zuweisen möchten.


 Einstellen der Farbeigenschaften in Formularen und Berichten auf die Microsoft Windows-Systemfarben

Einstellen der Farbeigenschaften in Formularen und Berichten auf die Microsoft Windows-Systemfarben

Mit Hilfe der Hintergrundfarbe-, Rahmenfarbe- und Textfarbe-Eigenschaften können Sie in Microsoft Access eine Farbskala erstellen, die derjenigen anderer Anwendungsprogramme unter Windows entspricht. Dies ist vor allem dann nützlich, wenn Sie eine Anwendung entwickeln, die Sie an mehrere Benutzer weitergeben möchten. Wenn Sie für die Farbeigenschaften die Systemfarben von Windows festlegen, können Sie mit einer einzigen Einstellung unterschiedliche Farben auf Computern verschiedener Benutzer anzeigen, je nachdem, welche Farben der jeweilige Benutzer in der Windows-Systemsteuerung gewählt hat.

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Öffnen Sie das Eigenschaftenblatt für den Bereich oder das Steuerelement.

  3. Klicken Sie im Eigenschaftenfenster auf die Hintergrundfarbe-Eigenschaft, die Rahmenfarbe-Eigenschaft oder die Textfarbe-Eigenschaft.

  4. Geben Sie im Einstellungsfeld der ausgewählten Eigenschaft einen der in der folgenden Tabelle aufgeführten Werte ein. Wenn zum Beispiel der Hintergrund des Formulars die Farbe aufweisen soll, die Sie selbst oder andere Benutzer als Hintergrundfarbe für Windows verwenden, stellen Sie für die Hintergrundfarbe-Eigenschaft den Wert -2147483643 ein, der auch für Windows gilt.
    Bildschirmelement | Wert
    Bildlaufleiste | -2147483648
    Desktop | -2147483647
    Titelleiste des aktiven Fensters | -2147483646
    Titelleiste eines inaktiven Fensters | -2147483645
    Menüleiste | -2147483644
    Fenster | -2147483643
    Fensterrahmen | -2147483642
    Menütext | -2147483641
    Fenstertext | -2147483640
    Titelleistentext | -2147483639
    Rahmen des aktiven Fensters | -2147483638
    Rahmen eines inaktiven Fensters | -2147483637
    Hintergrund der Anwendung | -2147483636
    Hervorheben | -2147483635
    Text hervorheben | -2147483634
    3D-Objekt, Front | -2147483633
    3D-Objekt, Schatten | -2147483632
    Abgeblendeter (deaktivierter) Text | -2147483631
    Schaltfläche: Text | -2147483630
    Titelleiste eines inaktiven Fensters: Text | -2147483629
    3D-Objekt, hervorgehoben | -2147483628
    3D-Objekt, dunkler Schatten | -2147483627
    3D-Objekt, hell | -2147483626
    QuickInfo-Text | -2147483625
    QuickInfo-Hintergrund | -2147483624

Anmerkungen

  • Die Systemfarbenwerte von Windows gelten nur für die Farbe des aufgeführten Bildschirmelements, nicht für die Art des Objekts, dem sie zugewiesen werden können. Sie können z. B. für die Hintergrundfarbe-Eigenschaft eines Textfelds die Windows-Systemfarbe für Bildlaufleisten, den Desktop oder ein anderes Bildschirmelement festlegen.

  • Die Werte für Windows-Bildschirmelemente sind, unabhängig von den Farbeinstellungen eines Benutzers, immer gleich.

  • Sie können zum Festlegen einer Systemfarbe von Windows für die Hintergrundfarbe-, Rahmenfarbe- und Textfarbe- Eigenschaften auch Visual Basic für Applikationen verwenden.


 Darstellen eines Textfeldes oder eines anderen Steuerelements als transparentes Steuerelement

Darstellen eines Textfeldes oder eines anderen Steuerelements als transparentes Steuerelement

Wenn ein Steuerelement transparent ist, sehen Sie darin die Farbe des Steuerelements, Bereichs oder Formulars, das/der hinter dem transparenten Steuerelement liegt.

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie in der Symbolleiste Formular-/Berichtsformat oder der Symbolleiste Datenzugriffsseiten-Format auf den Pfeil neben Füll-/Hintergrundfarbe [image] .

  4. Klicken Sie in der Palette auf die Schaltfläche Transparent.

Anmerkung Sie können mit Ausnahme von Bezeichnungsfeldern, Listenfeldern und Umschaltflächen alle Steuerelemente in Formularen und Berichten transparent darstellen. In Datenzugriffsseiten können Sie Dropdownlisten, Listenfelder, Rechtecke und PivoTabellen-Listen transparent darstellen. Optionsgruppen in Formularen, Berichten und Datenzugriffsseiten sind standardmäßig transparent.


 Ausblenden eines Bereichs oder Steuerelements

Ausblenden eines Bereichs oder Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie auf den Bereichsmarkierer, um das Eigenschaftenfenster für den Bereich zu öffnen, den Sie in einem Formular oder Bericht ausblenden möchten.

    • Doppelklicken Sie zum Öffnen des Eigenschaftenfensters für den Bereich, den Sie in einer Datenzugriffsseite ausblenden möchten, auf die Bereichsleiste.

    • Um das Eigenschaftenfenster für das auszublendende Steuerelement zu öffnen, klicken Sie, nachdem Sie das Steuerelement markiert haben, auf der Symbolleiste auf Eigenschaften [image] .
  3. Klicken Sie in Formularen und Berichten auf das Einstellungsfeld für die Eigenschaft Sichtbar, und klicken Sie dann auf Nein. Klicken Sie in Datenzugriffsseiten auf das Einstellungsfeld für die Eigenschaft Visibility und dann auf Hidden.

Anmerkungen

  • Wenn Sie ein Steuerelement in Formularen und Berichten als Reaktion auf ein Ereignis aus- bzw. einblenden möchten, verwenden Sie ein Makro oder eine Ereignisprozedur, um die Eigenschaft Sichtbar (Visible) einzustellen. Binden Sie das Makro oder die Ereignisprozedur an die Eigenschaft BeimAnzeigen (OnCurrent) eines Formulars oder die Eigenschaft BeimFormatieren (OnFormat) eines Berichts. Sie können z. B. in einem Verkaufsbericht neben dem monatlichen Gesamtumsatz eines Verkäufers, abhängig von dessen Höhe, eine Glückwunschmeldung ein- bzw. ausblenden.

  • Die Eigenschaft Sichtbar hat bei Formularbereichen keinen Einfluss auf die Spalten in der Datenblattansicht. Wenn Sie angeben möchten, ob eine Spalte in der Datenblattansicht sichtbar sein soll, verwenden Sie die Eigenschaft SpalteAusgeblendet.

  • Wenn Sie ein Objekt in einem Formular nur beim Drucken ausblenden möchten, verwenden Sie die Eigenschaft Anzeigen des Bereichs oder Steuerelements.


 Ändern der Rahmenbreite eines Textfeldes oder anderen Steuerelements

Ändern der Rahmenbreite eines Textfeldes oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie auf der Symbolleiste "Formatierung" für Formulare und Berichte oder auf der Symbolleiste "Formatierung" für Datenzugriffsseiten auf den Pfeil neben der Schaltfläche Linien-/Rahmenbreite [image] .

  4. Klicken Sie auf die gewünschte Rahmenbreite.

Anmerkungen

  • Wenn Sie die gleiche Rahmenbreite auch für ein anderes Steuerelement verwenden möchten, können Sie einfach auf die Schaltfläche Linien-/Rahmenbreite [image] klicken (d.h., Sie müssen nicht auf den Pfeil neben der Schaltfläche klicken und die Breite erneut aus der Liste auswählen).

  • Ist in einem Formular oder Bericht für die Zelleffekt-Eigenschaft des Steuerelements eine der Einstellungen Erhöht, Vertieft, Graviert oder Schattiert festgelegt, ändert Microsoft Access die Einstellung in Flach, wenn Sie die Rahmenbreite ändern.


 Ändern der Rahmenfarbe eines Textfeldes oder anderen Steuerelements

Ändern der Rahmenfarbe eines Textfeldes oder anderen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie auf der Formatsymbolleiste für Formulare und Berichte oder auf der Formatsymbolleiste für Datenzugriffsseiten auf den Pfeil neben Linien-/Rahmenfarbe [image] .

  4. Klicken Sie in der Palette auf die gewünschte Farbe.

Anmerkungen

  • Wenn Sie dieselbe Farbe für ein anderes Steuerelement verwenden möchten, können Sie einfach auf Linien-/Rahmenfarbe [image] klicken (d. h., Sie müssen nicht auf den Pfeil neben der Schaltfläche klicken und die Farbe erneut auswählen.) Wenn Sie für mehrere Steuerelemente gleichzeitig unterschiedliche Farben festlegen möchten, klicken Sie auf den Pfeil neben Linien-/Rahmenfarbe [image] , dann auf den Rahmen der Farbpalette, und ziehen Sie diese an eine andere Position. Auf diese Weise müssen Sie nicht jedesmal auf Linien-/Rahmenfarbe [image] klicken, wenn Sie eine Farbe zuweisen möchten.

  • Ist für die Eigenschaft Zelleffekt eines Steuerelements in einem Formular oder Bericht eine der Einstellungen Erhöht, Vertieft, Graviert oder Schattiert festgelegt, ändert Microsoft Access die Einstellung in Flach, wenn Sie die Rahmenfarbe ändern.


 Darstellen des Rahmens eines Textfeldes oder anderen Steuerelements als transparenter Rahmen

Darstellen des Rahmens eines Textfeldes oder anderen Steuerelements als transparenter Rahmen

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie in der Symbolleiste Formular-/Berichtsformat oder der Symbolleiste Datenzugriffsseiten-Format auf den Pfeil neben Linien-/Rahmenfarbe [image] .

  4. Klicken Sie in der Palette auf die Schaltfläche Transparent.

Anmerkung Ist für die Eigenschaft Zelleffekt für das Steuerelement eine der Einstellungen Erhöht, Vertieft, Graviert oder Schattiert festgelegt, ändert Microsoft Access die Einstellung in Flach, wenn Sie den Rahmen transparent darstellen.


 Anzeigen des Rahmens eines Textfeldes oder anderen Steuerelements in Formularen und Berichten als gepunktete, gestrichelte oder durchgezogene Linie

Anzeigen des Rahmens eines Textfeldes oder anderen Steuerelements in Formularen und Berichten als gepunktete, gestrichelte oder durchgezogene Linie

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften < [image] , um dessen Eigenschaftenfenster anzuzeigen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Rahmenart auf die Rahmenart, die Sie zuweisen möchten.

Anmerkung Ist für die Eigenschaft Zelleffekt für das Steuerelement eine der Einstellungen Höhergestellt, Vertieft, Graviert oder Gemeißelt festgelegt, ändert Microsoft Access die Einstellung in Flach, wenn Sie die Rahmenart ändern.


 Darstellen eines Textfeldes oder anderen Steuerelements als höher gestellt, vertieft, schattiert, gemeißelt oder graviert

Darstellen eines Textfeldes oder anderen Steuerelements als höher gestellt, vertieft, schattiert, gemeißelt oder graviert

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement, das Sie ändern möchten.

  3. Klicken Sie auf der Formatsymbolleiste für Formulare und Berichte oder auf der Formatsymbolleiste für Datenzugriffsseiten auf den Pfeil neben der Schaltfläche Zelleffekt [image] .

  4. Klicken Sie auf den Effekt, den Sie zuweisen möchten.

Anmerkungen

  • Wenn Sie den gleichen Spezialeffekt auch für ein anderes Steuerelement verwenden möchten, können Sie einfach auf die Schaltfläche Zelleffekt [image] klicken (d. h. Sie müssen nicht auf den Pfeil neben der Schaltfläche klicken und den Effekt erneut aus der Liste auswählen).

  • Zum Ändern der Breite des Schattens klicken Sie in der Formatsymbolleiste auf die Schaltfläche Linien-/Rahmenbreite [image] .

  • Wenn Sie bei Formularen und Berichten auf Erhöht, Vertieft, Graviert oder Schattiert klicken, setzt Microsoft Access alle festgelegten Einstellungen für die Eigenschaften Rahmenfarbe, Rahmenbreite und Rahmenart außer Kraft. Wenn Sie auf Graviert klicken, stellt Access außerdem die Hintergrundart-Eigenschaft für Text- und Kombinationsfelder auf Transparent sowie die Hintergrundfarbe-Eigenschaft für Listenfelder auf die Einstellung der Hintergrundfarbe-Eigenschaft des Bereichs ein.

  • Wenn Sie eine erhöhte oder vertiefte Darstellung gewählt haben, diese dreidimensionale Darstellung in Ihrem Formular jedoch nicht sichtbar wird, doppelklicken Sie in der Windows-Systemsteuerung auf Anzeige, klicken Sie auf die Registerkarte Darstellung und dann im Feld Schema auf Windows-Standard.


 Zeichnen eines Rechtecks in einem Formular, einem Bericht oder einer Datenzugriffsseite

Zeichnen eines Rechtecks in einem Formular, einem Bericht oder einer Datenzugriffsseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Rechteck Rechteck-Steuerelement .

  3. Klicken Sie in einem Formular, Bericht oder in einer Datenzugriffsseite auf eine beliebige Stelle, um ein Rechteck in Standardgröße zu erstellen, oder klicken und ziehen Sie, wenn Sie ein Rechteck in einer bestimmten Größe erstellen möchten.

Anmerkung Zum Ändern der Rahmenbreite für ein Rechteck klicken Sie auf das Rechteck, dann in der Symbolleiste Berichts- bzw. Formularformatierung oder in der Symbolleiste Datenzugriffsseitenformatierung auf den Pfeil neben der Schaltfläche Linien-/Rahmenbreite und anschließend auf die gewünschte Rahmenbreite. Zum Ändern der Rahmenart (Striche, doppelte Linie, usw.) eines Rechtecks in Formularen und Berichten klicken Sie auf das Rechteck. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster zu öffnen und dann im Einstellungsfeld der Eigenschaft Rahmenart auf die gewünschte Rahmenart. Auf Datenzugriffsseiten ist für das Rechteck-Steuerelement nur eine durchgezogene Linie möglich.


 Zeichnen einer Linie in einem Formular, einem Bericht oder einer Datenzugriffsseite

Zeichnen einer Linie in einem Formular, einem Bericht oder einer Datenzugriffsseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Linie Linien-Steuerelement .

  3. Klicken Sie im Formular, Bericht oder auf der Datenzugriffsseite auf eine beliebige Stelle, um eine Linie in Standardlänge zu erstellen. Sie können auch klicken und ziehen, um eine Linie in einer bestimmten Länge zu erstellen.

Anmerkungen

  • Zum Zeichnen horizontaler oder vertikaler Linien in einem Formular oder Bericht klicken Sie auf das Steuerelement Linie, halten die UMSCHALTTASTE gedrückt und ziehen dann, um die Linie zu erstellen.

  • Wenn Sie in einem Formular oder Bericht die Länge oder den Winkel einer Linie geringfügig ändern möchten, markieren Sie die Linie, halten Sie die UMSCHALTTASTE gedrückt und drücken dann eine der Pfeiltasten.

  • Wenn Sie die Position einer Linie geringfügig ändern möchten, halten Sie STRG gedrückt und drücken dann eine der Pfeiltasten.

  • Wenn Sie die Breite einer Linie ändern möchten, klicken Sie in der Symbolleiste Formular- bzw. Berichtsformatierung oder in der Symbolleiste Datenzugriffsseitenformatierung auf den Pfeil neben der Schaltfläche Linien-/Rahmenbreite [image] und dann auf die gewünschte Linienbreite.
  • Zum Ändern der Rahmenart (Punkte, Striche, doppelte Linie, etc.) für eine Linie in einem Formular oder Bericht klicken Sie auf die Linie, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster zu öffnen. Klicken Sie im Eigenschaftenfeld Rahmenart auf eine Rahmenart. Auf Datenzugriffsseiten ist als Rahmenart nur die durchgezogene Linie möglich.


 Verwenden benutzerdefinierter Farben aus einem anderen Anwendungsprogramm in einem Formular oder Bericht

Verwenden benutzerdefinierter Farben aus einem anderen Anwendungsprogramm in einem Formular oder Bericht

Wenn Sie Grafiken in den Farben anzeigen möchten, die in dem Anwendungsprogramm zur Verfügung stehen, in dem die Grafiken erstellt worden sind, können Sie für ein Formular oder einen Bericht eine benutzerdefinierte Farbpalette erstellen. Diese benutzerdefinierte Farbpalette ersetzt dann die Microsoft Access-Standardpalette nur für das jeweilige Formular oder den jeweiligen Bericht.

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer oder den Berichtsmarkierer, um das jeweilige Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Palettenherkunft den Pfad und den Dateinamen für einen der folgenden Dateitypen ein:
    • .DIB (device-independent bitmap file)

    • .PAL (Microsoft Windows palette file)

    • .ICO (Windows icon file)

    • .BMP (Windows bitmap file)

    • .WMF (Windows metafile)

    • .EMF (enhanced metafile)

    • Beliebige andere Dateitypen, vorausgesetzt, Sie haben die für diese Dateitypen erforderlichen Grafikfilter installiert

Anmerkung Wenn Sie Bilder und Diagramme in ihren Originalfarben anzeigen möchten, muss der in Ihrem System installierte Bildschirmtreiber die Palette unterstützen, die Sie für die Einstellung der Palettenherkunft-Eigenschaft festgelegt haben. Wenn Sie zum Beispiel C:\WIN95\256COLOR.BMP angeben, muss der derzeit geladene Bildschirmtreiber 256 Farben unterstützen.


 Erstellen eines Tipps, der beim Bewegen der Maus über ein Textfeld oder anderes Steuerelement eingeblendet wird

Erstellen eines Tipps, der beim Bewegen der Maus über ein Textfeld oder anderes Steuerelement eingeblendet wird

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement, für das Sie einen Tipp erstellen möchten, markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der SteuerelementTip-Text-Eigenschaft (bei Formularen und Berichten) oder der Title-Eigenschaft (bei Datenzugriffsseiten) die Meldung ein, die Sie für das Steuerelement anzeigen möchten. Sie können bis zu 255 Zeichen eingeben.

    Darüber hinaus können Sie für Ihr Formular benutzerdefinierte Hilfedateien und eine benutzerdefinierte Direkthilfe erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anzeigen von Anweisungen für ein Textfeld oder ein anderes Steuerelement in der Statusleiste eines Formulars oder Berichts

Anzeigen von Anweisungen für ein Textfeld oder ein anderes Steuerelement in der Statusleiste eines Formulars oder Berichts

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Statusleistentext die Meldung ein, die Sie für das Steuerelement anzeigen möchten.

    Sie können bis zu 255 Zeichen eingeben. Microsoft Access zeigt jedoch nur so viel Text an, wie in die Statusleiste passt. Wie viel Text angezeigt werden kann, ist abhängig von der verwendeten Schriftart und der Größe des Access-Fensters.

Tipp Sie können einen Tipp erstellen, der eingeblendet wird, wenn Sie den Zeiger über ein Steuerelement bewegen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] . Darüber hinaus können Sie benutzerdefinierte Hilfedateien und die Direkthilfe erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Was sind gebundene Hyperlinks?

Auf einer Datenzugriffsseite können Sie ein Steuerelement für einen gebundenen Hyperlink an ein Feld des Typs Text binden, das eine Internetadresse enthält. Verwenden Sie einen gebundenen Hyperlink, wenn Sie für jeden Datensatz in der Tabelle eine andere Hyperlinkadresse angeben möchten. Wenn Sie sich durch die Datensätze bewegen, können Sie auf den Hyperlink klicken und für jeden Datensatz zu einer anderen Webseite wechseln.


 Was ist ein Hotspotbild-Steuerelement?

Was ist ein Hotspotbild-Steuerelement?

Verwenden Sie ein Hotspotbild-Steuerelement, um einer Datenzugriffsseite ein Bild hinzuzufügen, das, wenn man darauf klickt, eine andere Webseite von Ihrem Festplattenlaufwerk, dem Web oder einer anderen Adresse anzeigt. Beim Erstellen eines Hotspotbild-Steuerelements wählen Sie das Bild aus, das auf der Seite angezeigt werden soll, und die Adresse der Datei, zu der gewechselt werden soll. In der Seitenansicht verwandelt sich der Pfeil über dem Bild in eine Hand und zeigt so an, dass es sich bei dem Bild um einen Hyperlink handelt, auf den Sie klicken können, um auf eine andere Seite zu gelangen. Sie können außerdem eine QuickInfo und einen Alternativtext für das Bild definieren.

Das Hotspotbild-Steuerelement ist nützlich für die Bereitstellung von Hyperlinks zu Informationen, die mit den Daten auf Ihrer Datenzugriffsseite in Zusammenhang stehen.

Weitere Informationen

Erstellen eines Hyperlinks zu einer Webseite unter Verwendung eines Bildes


 Info über Hyperlinkadressen

Info über Hyperlinkadressen

Sie können eine Hyperlinkadresse direkt in ein Hyperlink-Feld, Datenblatt oder Textfeld bzw. in ein Steuerelement eingeben, das Hyperlinks auf einem Formular oder einer Datenzugriffsseite annimmt.

Eine Hyperlinkadresse kann aus bis zu vier Teilen bestehen, die durch ein Nummernzeichen (#) voneinander getrennt sind:

Anzeigetext#Adresse#Unteradresse#QuickInfo

In der folgenden Tabelle werden die einzelnen Teile erläutert.

Teil | Beschreibung | Optional?
Anzeigetext | Der Text im Feld oder Steuerelement. Sie können z.B. einen beschreibenden Namen für die World Wide Web-Site oder das durch die Adresse und die Unteradresse angegebene Objekt anzeigen. | Ja
Adresse | Ein absoluter oder relativer Pfad zu einem Zieldokument. Ein absoluter Pfad ist ein voll qualifizierter URL oder UNC-Pfad zu einem Dokument. Bei Datenzugriffsseiten bezieht sich der relative Pfad auf die gespeicherte Position auf der Seite. Bei anderen Datenbankobjekten bezieht sich der relative Pfad auf den Basispfad, der in der Einstellung Hyperlinkbasis im Dialogfeld Datenbankname (das im Menü Datei über den Befehl Datenbankeigenschaften geöffnet werden kann) festgelegt wird, oder auf den aktuellen Datenbankpfad. | Nein, es sei denn, Unteradresse verweist auf ein Objekt in der aktuellen .MDB- oder .ADP-Datei
Unteradresse | Die Position in der Datei oder auf der Seite. Sie können z.B. auf ein bestimmtes Formular oder einen bestimmten Bericht in einer Microsoft Access-Datenbank oder auf eine bestimmte Textmarke in einem Microsoft Word-Dokument verweisen. Um Informationen zur korrekten Syntax für jeden Dokumenttyp anzuzeigen, klicken Sie auf [image] . | Ja
QuickInfo | Der Text, der angezeigt wird, wenn Sie den Cursor über einem Hyperlink positionieren. | Ja

Anmerkung In einem Feld oder Textfeld, das die Hyperlinkadresse als einen Hyperlink formatiert, zeigt Microsoft Access nicht alle vier Teile in dem Feld oder Steuerelement an. Soll die gesamte Hyperlinkadresse angezeigt werden, positionieren Sie die Einfügemarke mit Hilfe der Tastatur in dem Feld oder Steuerelement (damit die Verknüpfung nicht geöffnet wird), und drücken Sie F2.

  • Wenn Sie den Anzeigetext eingeben, zeigt Microsoft Access nicht die restliche Adresse im Anschluss an diesen Text an.

  • Wenn Sie den Anzeigetext nicht eingeben, zeigt Microsoft Access nur die Adresse an.

  • Die Unteradresse wird nur angezeigt, wenn kein Anzeigetext oder keine Adresse eingegeben wurde.

  • Die für einen Hyperlink auf einer Datenzugriffsseite angezeigte QuickInfo wird für das Hyperlink-Steuerelement definiert. Eine QuickInfo, die Sie im Rahmen der Adresse eingeben, wird also nicht auf der Datenzugriffsseite angezeigt.

Siehe auch eine Liste mit Beispielen für Hyperlinkadressen.


Erstellen von Hyperlinks auf Datenzugriffsseiten

Was möchten Sie tun?

Einen Link zu einer vorhandenen Datei oder Webseite erstellen

Eine neue Datenzugriffsseite und gleichzeitig einen Link zu dieser Seite erstellen

Einen Link von einer Datenzugriffsseite zu einer anderen erstellen

Einen Link erstellen, der Ihr E-Mail-Programm öffnet und eine Nachricht an die angegebene E-Mail-Adresse erzeugt


 Erstellen von Hyperlinks in einem Formular oder Bericht

Erstellen von Hyperlinks in einem Formular oder Bericht

Wenn Sie mit einer der folgenden Methoden einen Hyperlink erstellen, fügt Microsoft Access ein Bezeichnungsfeld-Steuerelement in das Formular oder den Bericht ein. Zwar funktionieren Hyperlinks in einem Bericht nicht, wenn dieser in Microsoft Access angezeigt wird, sie sind jedoch funktionsfähig, wenn Sie den Bericht zu Microsoft Word, Microsoft Excel oder HTML ausgebeen.

Was möchten Sie tun?

Einen Link zu einem Dokument, einer Datei oder einer Webseite erstellen

Einen Link zu einer vorhandenen Datei oder Webseite mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Eine neue Datenzugriffsseite und gleichzeitig einen Link zu dieser Seite mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Einen Hyperlink aus einem Microsoft Office-Dokument einfügen

Text aus einem Microsoft Office-Dokument einfügen

Eine Internet-Verknüpfung durch Ziehen einfügen

Einen Link zu einem Objekt in der aktuellen Datenbank erstellen

Einen Link zu einer Tabelle, einer Abfrage, einem Formular, einem Bericht oder einer Datenzugriffsseite mit Hilfe der Schaltfläche Hyperlink einfügen erstellen

Einen Link zu einer E-Mail-Adresse erstellen

Mit Hilfe der Schaltfläche Hyperlink einfügen einen Link erstellen, der Ihr E-Mail-Programm öffnet und eine Nachricht an die angegebene E-Mail-Adresse erzeugt


 Erstellen eines Feldes zum Speichern von Hyperlinks

Erstellen eines Feldes zum Speichern von Hyperlinks

  1. Öffnen Sie eine vorhandene Tabelle in der Entwurfsansicht, oder erstellen Sie eine neue Tabelle.

  2. Geben Sie im oberen Teil des Fensters einen Namen für das Feld ein, in dem Sie die Hyperlinks speichern werden.

  3. Wählen Sie Hyperlink in der Spalte Felddatentyp für dieses Feld aus.

  4. Klicken Sie in der Symbolleiste auf Speichern [image] , um die Tabelle zu speichern.

    Um Informationen zum Eingeben von Hyperlinkadressen in ein Formular oder Datenblatt anzuzeigen, klicken Sie auf [image] .

Anmerkungen

  • In der Datenblattansicht können Sie ein Feld zum Speichern von Hyperlinks erstellen, indem Sie im Menü Einfügen auf Hyperlinkspalte klicken und dann die Hyperlinkadresse in dem neuen Feld eingeben.

  • Wenn Sie eine Tabelle durch Importieren von Daten erstellen, macht Microsoft Access aus jeder Spalte, die URLs oder UNC-Pfade enthält, automatisch ein Hyperlink-Feld. Eine Spalte wird jedoch nur umgewandelt, wenn alle Werte mit einem bekannten Protokoll beginnen, wie z. B. "http:" oder "\\". Beginnt nur ein einziger Wert mit einem unbekannten Protokoll, wird die Spalte nicht in ein Hyperlink-Feld umgewandelt.


 Ändern des Hyperlinks eines Bezeichnungsfeldes, eines Bildes oder einer Befehlsschaltfläche

Ändern des Hyperlinks eines Bezeichnungsfeldes, eines Bildes oder einer Befehlsschaltfläche

  1. Öffnen Sie das Formular in der Entwurfsansicht oder den Bericht in der Entwurfsansicht.

  2. Klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, das Bild-Steuerelement oder die Befehlsschaltfläche, um das Kontextmenü anzuzeigen.

  3. Zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Hyperlink bearbeiten.

  4. Klicken Sie im Dialogfeld Hyperlink bearbeiten auf eine Option unter Link zu, und geben Sie die für diese Option erforderlichen Informationen ein.

  5. Geben Sie im Feld Text anzeigen als den Text ein, der im Steuerelement angezeigt werden soll.

  6. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink führt. Wenn Sie das Feld Infofelder leer lassen, zeigt Microsoft Access als Infofelder die Hyperlinkadresse, den Namen des Datenbankobjekts oder die E-Mail-Adresse an.

Anmerkung Sie können einen Hyperlink auch durch direkte Eingabe im Eigenschaftenfenster ändern. Um Informationen zu der Syntax anzuzeigen, die für die Eingabe eines Hyperlinks erforderlich ist, setzen Sie die Einfügemarke in die Eigenschaft Hyperlink-Adresse oder die Eigenschaft Hyperlink-Unteradresse, und drücken Sie F1.


 Erstellen eines Hyperlinks, der von einer Datenzugriffsseite zu einer anderen in der aktuellen Datenbank führt

Erstellen eines Hyperlinks, der von einer Datenzugriffsseite zu einer anderen in der aktuellen Datenbank führt

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Hyperlink.

  3. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Seite in dieser Datenbank.

  4. Geben Sie im Feld Text anzeigen als den Text ein, der in dem Feld bzw. Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die Hyperlinkadresse als Anzeigetext.

  5. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Quickinfotext leer lassen, zeigt Microsoft Access die Hyperlinkadresse als Quickinfo an.

  6. Wählen Sie aus der Liste die Datenzugriffsseite, zu der Sie den Hyperlink erstellen wollen.

  7. Um für die Datenzugriffsseite einen Filter zu erstellen, geben Sie im Feld Kriterien für Datenzugriffsseite filtern einen Ausdruck in der Form einer WHERE-Klausel ein. Wenn Sie beispielsweise eine Datenzugriffsseite mit Bestellinformationen haben, darunter die Personalnummer des Verkäufers, und Sie eine Verknüpfung zu einer zweiten Datenzugriffsseite mit dem Mitarbeiterdaten dieses Verkäufers erstellen möchten, geben Sie PersonalNr=[PersonalNr] ein.

  8. Klicken Sie auf OK.

    Microsoft Access fügt den Hyperlink in die Datenzugriffsseite ein. Um den Hyperlink zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf den Hyperlink. Microsoft Access öffnet die Zielseite in Ihrem Webbrowser.


 Erstellen eines Bildes, das als Hyperlink zwischen zwei Datenzugriffsseiten dient

Erstellen eines Bildes, das als Hyperlink zwischen zwei Datenzugriffsseiten dient

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Hotspotbild HotspotBild-Steuerelement , und klicken Sie dann auf die Stelle, an der Sie das Bild erstellen möchten.

  3. Suchen Sie im Dialogfeld Grafik einfügen das Bild, das Sie verwenden möchten, und klicken Sie dann auf OK.

  4. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Seite in dieser Datenbank.

  5. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger über den Hyperlink bewegt wird. Wenn Sie das Feld Quickinfotext leer lassen, wird als QuickInfo die Hyperlinkadresse angezeigt.

  6. Wählen Sie aus der Liste die Seite aus, zu der Sie eine Verknüpfung herstellen möchten.

  7. Zum Erstellen eines Filters für die Seite geben Sie im Feld Kriterien für Datenzugriffsseite filtern einen Ausdruck in Form einer WHERE-Klausel ein. Wenn Sie zum Beispiel die zweite Seite öffnen möchten, auf der die Datensätze für die Personalnummer der ersten Seite angezeigt werden, geben Sie Folgendes ein: PersonalNr=[PersonalNr].

  8. Klicken Sie auf OK.

    Microsoft Access fügt den Hyperlink zur Datenzugriffsseite hinzu. Wenn Sie den Link testen möchten, wechseln Sie in die Datenzugriffsseitenansicht und klicken Sie auf den Hyperlink. Microsoft Access öffnet daraufhin die Zielseite im Webbrowser.


Ändern des Standardformats von Hyperlinks

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Allgemein.

  3. Klicken Sie auf Weboptionen.

  4. Wählen Sie die gewünschten Optionen aus.


 Erstellen von Diagrammen auf einer Datenzugriffsseite

Erstellen von Diagrammen auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Office Chart Office Chart-Steuerelement .

  3. Klicken Sie auf der Datenzugriffsseite an die Stelle, an der die linke obere Ecke des Diagramm-Steuerelements stehen soll. Microsoft Access erstellt ein Steuerelement in der Standardgröße. Um ein Diagramm in einer anderen Größe zu erstellen, klicken Sie auf die Datenzugriffsseite, und ziehen Sie den Mauszeiger, bis das Steuerelement die gewünschte Größe hat.

  4. Folgen Sie den Anleitungen im Microsoft Office Diagramm-Assistenten.

Anmerkung Assistenten sind nicht verfügbar, wenn Sie mit einer eigenständigen Datenzugriffsseite arbeiten, oder wenn Sie eine Datenzugriffsseite auf eine andere Datenbank als die aktuell geöffnete verweisen.


 Erstellen einer PivotTable-Liste auf einer Datenzugriffsseite

Erstellen einer PivotTable-Liste auf einer Datenzugriffsseite

Sie können zwar das Layout einer PivotTable-Liste auf einer Datenzugriffsseite ändern und Eigenschaften festlegen, um das Aussehen und Verhalten zu ändern, Sie können jedoch nicht die in der PivotTable-Liste gespeicherten Werte löschen, ändern oder Werte hinzufügen.

  1. Zeigen Sie in der Entwurfsansicht einer Datenzugriffsseite die Toolbox an.

  2. Klicken Sie in der Toolbox auf das Office PivotTable-Steuerelement Steuerelement für Office Pivot-Liste .

  3. Klicken Sie auf der Datenzugriffsseite auf die Stelle, an der die obere linke Ecke des Steuerelements platziert werden soll.

  4. So wählen Sie eine Datenquelle für die PivotTable-Liste aus. Gehen Sie nach einer der folgenden Methoden vor:
    • Wenn Sie die aktuelle Microsoft Access- oder Microsoft SQL Server-Datenbank als Datenquelle verwenden möchten, zeigen Sie die Liste der Felder der Datenzugriffsseite an und ziehen Sie dann die Tabelle oder Abfrage auf das Steuerelement für die PivotTable-Liste, die Sie für die PivotTable-Liste verwenden möchten. Sie können auch nacheinander einzelne Felder aus diesen Datenquellen ziehen. Wenn Sie eine PivotTable-Liste durch Ziehen von Feldern aus der Feldliste erstellen, dann stellt Microsoft Access automatisch für die Option Datenquelle Steuerelement in der Toolbox zu PivotTable-Eigenschaften den Wert MSODSC ein. Das bedeutet, dass Microsoft Access dasselbe Datenquellen-Steuerelement sowohl für die PivotTable-Liste als auch für die Seite selbst verwendet. Darüber hinaus wird für die Option Data member der Name der Tabelle oder Abfrage festgelegt, auf der die PivotTable-Liste basiert. Fahren Sie mit Schritt 6 fort.

    • Wenn Sie eine externe Datenquelle verwenden möchten, zeigen Sie die Toolbox zu PivotTable-Eigenschaften an, klicken Sie auf die Leiste Datenquelle, klicken Sie auf die Option Verbindung und klicken Sie dann auf Verbindungseditor. Klicken Sie auf die Registerkarte Provider, und wählen Sie den OLE DB-Provider aus, den Sie zum Abrufen der Daten verwenden möchten. Klicken Sie auf die Registerkarte Verbindung, und geben Sie die Angaben zum Herstellen einer Verbindung zu den Daten ein, die Sie für die PivotTable-Liste verwenden möchten. Wenn Sie weitere Informationen zum Dialogfeld Datenlinkeigenschaften benötigen, klicken Sie unten im Dialogfeld auf die Schaltfläche ?
  5. Gehen Sie im Bereich Datenquelle der PivotTable-Eigenschaftentoolbox unter Daten verwenden aus nach einer der folgenden Methoden vor:
    • Wenn Sie die Daten aus einer bestimmten Datenquelle innerhalb der Datenbank verwenden möchten, klicken Sie auf Datenmitglied und wählen Sie das gewünschte Element aus der Liste aus.

    • Wenn Sie eine Abfrage oder einen Befehl, wie z. B. eine SQL-Anweisung, zum Auswählen von Daten einsetzen möchten, klicken Sie auf Befehltext und geben Sie dann die Abfrage bzw. den Befehl in das Feld ein. Weitere Informationen zur Abfragesyntax finden Sie in der Dokumentation zur externen Datenquelle.
  6. Stellen Sie die PivotTable-Liste fertig, indem Sie das Layout anordnen und mit Hilfe der Symbolleiste in der PivotTable-Liste und der PivotTable-Eigenschaftentoolbox Summen hinzufügen, Eigenschaften einstellen, etc., so dass das Steuerelement das gewünschte Aussehen und Verhalten aufweist. Weitere Informationen zu einer PivotTable-Liste und deren Verwendung aufrufen.

Anmerkungen

  • Zum Erstellen einer PivotTable-Liste, die Daten aus einem Microsoft Excel-Arbeitsblatt verwendet, ist es erforderlich, die Daten von Microsoft Excel aus auf einer Webseite zu veröffentlichen. Wenn Sie die Webseite dann in eine Datenzugriffsseite konvertieren möchten, öffnen Sie diese in Microsoft Access und fügen Sie die Steuerelemente hinzu, die an Datenbankdaten von Microsoft Access bzw. Microsoft SQL Server gebunden sind.

  • Wenn auf einer Datezugriffsseite ein Steuerelement für eine Webkomponente an eine externe Datenquelle gebunden ist und andere Steuerelemente an eine Microsoft Access- oder Microsoft SQL Server-Datenbank gebunden sind, dann verwendet das Steuerelement dieser Komponente ein anderes Steuerelement für die Datenquelle als der Rest der Seite.

  • Sie können ein Diagramm erstellen, das mit der PivotTable-Liste verknüpft ist, so dass bei einer Änderung der PivotTable-Liste das Diagramm automatisch aktualisiert wird und Änderungen angezeigt werden.

  • Wenn Sie eine PivotTable-Liste zu einer gruppierten Datenzugriffsseite hinzufügen, wird für jede eindeutige Gruppe eine PivotTable-Liste angezeigt, die nur die Datensätze für dieser Gruppe enthält. Beispiel: Auf einer Seite, die nach Jahren gruppiert ist, gibt es eine PivotTable-Liste mit Mitarbeiterverkaufsdaten. Dabei ist eine PivotTable-Liste pro Jahr vorhanden, die nur die Verkaufsdaten für das betreffende Jahr enthält. Sie können die PivotTable-Liste immer nur für eine Gruppe anzeigen.

  • Wenn Sie das Eingenschaftsblatt der Datenzugriffsseite öffnen, sehen Sie die spezifischen Eigenschaften, die mit den Einstellungen der PivotTable-Eigenschaftentoolbox verknüpft sind, sowie weitere Eigenschaften, die nicht in der Eigenschaftentoolbox verfügbar sind.


 Ändern der Verbindung zu einer externen Datenherkunft in einer PivotTable-Liste oder der auf ihr basierenden Abfrage

Ändern der Verbindung zu einer externen Datenherkunft in einer PivotTable-Liste oder der auf ihr basierenden Abfrage

  1. Aktivieren Sie in der Datenzugriffsseiten-Entwurfsansicht die PivotTable-Liste.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste, und zeigen Sie die PivotTable-Eigenschaftentoolbox an.

  3. Klicken Sie auf die Datenquellen-Leiste, um deren Einstellungen anzuzeigen.

  4. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie die Verbindungsinformationen ändern möchten, klicken Sie auf die Option Verbindung und dann auf Verbindungseditor. Klicken Sie im Verbindungseditor auf die Registerkarte Provider, und wählen Sie den OLE DB Provider, der zum Abrufen der Daten verwendet werden soll. Klicken Sie auf die Registerkarte Verbindung, und geben Sie dann die Verbindungsinformationen für die Daten ein, die Sie in der PivotTable-Liste nutzen wollen. Um weitere Informationen über das Dialogfeld Datenlinkeigenschaften zu erhalten, klicken Sie auf die Schaltfläche Hilfe am unteren Rand des Dialogfeldes.

    • Um Daten aus einer anderen Datenherkunft innerhalb der externen Datenbank zu verwenden, klicken Sie auf Datenmitglied, und wählen Sie dann in der Liste die gewünschte Datenherkunft aus.

    • Um den Befehlstext zu ändern, klicken Sie im Bereich Datenquellen in der PivotTable-Eigenschaftentoolbox, unter Daten verwenden aus auf Befehltext, und erstellen Sie dann die Abfrage zur Auswahl der Daten. Weitere Informationen über die Abfragesyntax finden Sie in der Dokumentation der externen Datenquelle.


 Hinzufügen einer Kalkulationstabelle zu einer Datenzugriffsseite

Hinzufügen einer Kalkulationstabelle zu einer Datenzugriffsseite

Fügen Sie ein Kalkulationstabellen-Steuerelement zu einer Datenzugriffsseite hinzu, wenn Sie ähnliche Möglichkeiten wie in einer Microsoft Excel-Kalkulationstabelle nutzen möchten. Sie können Werte eingeben, Formeln hinzufügen, Filter anwenden usw. Folgen Sie der unten beschriebenen Vorgehensweise, um eine Kalkulationstabelle zu erstellen, in die Sie Rohdaten eingeben oder Daten von einer Webseite oder aus einer Textdatei importieren können. Falls Sie in der Kalkulationstabelle Daten aus anderen Steuerelementen auf der Datenzugriffsseite nutzen möchten, müssen Sie Bezüge zu diesen Steuerelementen in den jeweiligen Tabellenzellen erstellen.

  1. Wechseln Sie in die Entwurfsansicht der Datenzugriffsseite, um die Toolbox anzuzeigen.

  2. Klicken Sie in der Toolbox auf das Steuerelement Office Spreadsheet Office-Tabellen-Steuerelement .

  3. Klicken Sie auf die Stelle der Datenzugriffsseite, an der die linke obere Ecke des Steuerelements positioniert werden soll.

  4. Geben Sie die Daten und Formeln ein, oder importieren Sie Daten in die Kalkulationstabelle.

  5. Nutzen Sie die Optionen in der Spreadsheet-Eigenschaftentoolbox, um die Tabelle zu vervollständigen und im Aussehen und Verhalten Ihren Wünschen anzupassen.


 Ändern eines Tabellen-Steuerelements, so dass es wie ein Textfeld-Steuerelement angezeigt wird

Ändern eines Tabellen-Steuerelements, so dass es wie ein Textfeld-Steuerelement angezeigt wird

Wenn Sie die Tabellenfunktionalität des Steuerelements ausblenden, die Farbe der Zellenrahmen an andere Elemente auf der Datenzugriffsseite anpassen und die Größe des Steuerelementes an eine Zelle oder einen Zellbereich anpassen, können Sie das Tabellen-Steuerelement so ändern, dass es wie Textfeld-Steuerelemente auf der Seite angezeigt wird.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Aktivieren Sie das Tabellen-Steuerelement, und zeigen Sie dann die Spreadsheet-Eigenschaftentoolbox an.

  3. Klicken Sie auf Ein-/Ausblenden, und blenden Sie dann die Symbolleiste, die Gitternetzlinien, die Titelleiste, die Spaltenköpfe und die Zeilenköpfe durch Klicken auf die entsprechenden Schaltflächen aus, so dass diese als nicht gedrückt angezeigt werden.

  4. Klicken Sie auf die Symbolleiste Erweitert, und führen Sie dann einen der folgenden Schritte aus:
    • Legen Sie für Spreadsheet automatisch anpassen die Einstellung Wahr fest.

    • Legen Sie für die Zelle oder den Zellbereich, die/den Sie anzeigen möchten, die Eigenschaft Sichtbarer Bereich fest. Legen Sie z. B. für Sichtbarer Bereich die Einstellung A1 fest, wenn Sie den Wert in der Zelle A1 anzeigen möchten.
  5. Wählen Sie die Zellen aus, deren Rahmen Sie ändern möchten.

  6. Wenn der Bereich Format in der Spreadsheet-Eigenschaftentoolbox nicht erweitert ist, klicken Sie auf die Formatierungsleiste.

  7. Klicken Sie in der Gruppe Zellformat auf die Schaltfläche Rahmen.

  8. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie zum Festlegen einer Rahmenfarbe auf die Schaltfläche Rahmenfarbe, und wählen Sie dann die Rahmenfarbe aus, die auch den anderen Steuerelementen auf der Datenzugriffsseite zugewiesen ist, denen das Tabellenelement entsprechen soll.

    • Um eine Linienstärke festzulegen, klicken Sie in der Liste auf die gewünschte Größe.
  9. Klicken Sie im Rahmendiagramm auf eine Rahmenlinie, um diese zu aktivieren oder zu deaktivieren. Klicken Sie auf einen Schnittpunkt, um alle Rahmenlinien an diesem Punkt zu aktivieren oder zu deaktivieren.

  10. Verschieben Sie das Steuerelement gegebenenfalls an die endgültige Position auf der Datenzugriffsseite.

Anmerkungen

  • Wenn Sie die Einstellungen für Rahmen, die vorher festgelegt worden sind, ändern, müssen Sie im Rahmendiagramm auf die vorhandenen Rahmenlinie klicken, um sie zu deaktivieren und dann erneut auf diese Linie klicken, um Sie mit den neuen Farb- und Stärkeneinstellungen wieder anzuzeigen.

  • Wenn Sie eine Datenzugriffsseite in der Seitenansicht oder in Internet Explorer anzeigen, wird der neue Rahmen nicht angezeigt, wenn das Steuerelement den Fokus hat. Verschieben Sie den Fokus, um den Effekt anzuzeigen.


 Aktivieren von PivotTable-Listen, Kalkulationstabellen oder Diagrammen auf Datenzugriffsseiten

Aktivieren von PivotTable-Listen, Kalkulationstabellen oder Diagrammen auf Datenzugriffsseiten

Das Aktivieren dieser Webkomponenten-Steuerelemente von Microsoft Office ist nicht gleichbedeutend mit dem Auswählen von Steuerelementen. Beim auswählen eines Steuerelement wählen Sie nur das Steuerelement als solches aus. Wenn das Steuerelement ausgewählt ist und den Fokus hat, können Sie den Fokus in das Steuerelement verlagern, um seinen Inhalt zu aktivieren. Erst wenn der Inhalt aktiviert ist, können Sie Eigenschaften festlegen und die verschiedenen Features des Steuerelements anwenden. In einer PivotTable-Liste können Sie dann beispielsweise Spalten und Zeilen verschieben oder in anderer Weise mit dem Layout und den Daten arbeiten.

  • Klicken Sie einmal auf das Steuerelement, um das Steuerelement selbst auszuwählen. Klicken Sie erneut darauf, um den Inhalt des Steuerelements zu aktivieren. Wenn der Inhalt aktiviert ist, werden um den Rand des Steuerelements herum Schrägstriche angezeigt.

Ausgewählte und aktivierte PivotTable-Listen-Steuerelemente

Sobald der Inhalt aktiviert ist, können Sie die verschiedenen Elemente der Webkomponente auswählen und Eigenschaften für das ausgewählte Element festlegen.


 Hinzufügen eines ActiveX-Steuerelements (eines OLE-Zusatzsteuerelements) zu einem Formular, einem Bericht oder einer Datenzugriffsseite

Hinzufügen eines ActiveX-Steuerelements (eines OLE-Zusatzsteuerelements) zu einem Formular, einem Bericht oder einer Datenzugriffsseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool Weitere Steuerelemente ActiveX-Steuerelement , und klicken Sie dann in der Liste auf das gewünschte Steuerelement.

    Anmerkung Wenn Sie ActiveX-Steuerelemente mit anderen Anwendungen, wie beispielsweise Microsoft Excel, installiert haben, werden diese angezeigt, sobald Sie in der Toolbox auf Weitere Steuerelemente oder im Menü Einfügen auf den Befehl ActiveX-Steuerelement klicken. Einige ActiveX-Steuerelemente funktionieren jedoch nicht einwandfrei in Microsoft Access. Eine Liste der Steuerelemente, die für die Verwendung in Microsoft Access getestet und für gut befunden wurden, finden Sie in der INFO-Datei oder erhalten Sie beim Händler des Steuerelements.

  3. Klicken Sie in dem Formular, dem Bericht oder auf der Datenzugriffsseite auf die Stelle, an der Sie das Steuerelement einfügen möchten.

  4. Klicken Sie mit der rechten Maustaste auf das Steuerelement, und klicken Sie dann auf Eigenschaften, um das Eigenschaftenfenster für das ActiveX-Steuerelement zu öffnen.

  5. Stellen Sie die Eigenschaften wie gewünscht ein.

    Zum Anzeigen von Hilfeinformationen zu einer beliebigen Eigenschaft klicken Sie im Eigenschaftenfenster auf die Eigenschaft und drücken dann F1.

Anmerkungen

  • Weitere Informationen zur Verwendung von ActiveX-Steuerelementen finden Sie unter "Verwenden von ActiveX-Steuerelementen" in Erstellen von Anwendungsprogrammen mit Formularen und Berichten.

  • Weitere ActiveX-Steuerelemente sind in Microsoft Office 2000 Developer verfügbar. Zum Anzeigen weiterer Informationen zum Inhalt von Office 2000 Developer klicken Sie auf [image] .


 Registrieren eines ActiveX-Steuerelements

Registrieren eines ActiveX-Steuerelements

Verwenden Sie die folgende Prozedur zum Registrieren eines ActiveX-Steuerelements, das nicht in Microsoft Access enthalten ist.

  1. Kopieren Sie die Dateien für das Steuerelement auf Ihre Festplatte. Weitere Informationen finden Sie in der Dokumentation zu dem Zusatzsteuerelement.

  2. Klicken Sie im Access-Menü Extras auf ActiveX-Steuerelemente.

  3. Klicken Sie im Dialogfeld ActiveX-Steuerelemente auf Registrieren, geben Sie einen Pfad zu dem Steuerelement im Dialogfeld ActiveX-Steuerelement hinzufügen ein, und klicken Sie anschließend auf Öffnen.

  4. Klicken Sie auf Schließen.


 Was ist ein Bezeichnungsfeld?

Was ist ein Bezeichnungsfeld?

Sie können Bezeichnungsfelder in einem Formular, einem Bericht oder auf einer Datenzugriffsseite verwenden, um beschreibenden Text, z. B. Titel, Beschriftungen oder kurze Anweisungen, anzuzeigen. Bezeichnungsfelder zeigen keine Werte aus Feldern oder Ausdrücken an. Sie sind stets ungebunden und verändern sich nicht beim Wechseln von einem Datensatz zum nächsten.

Bezeichnungsfelder sind entweder eigenständig oder mit einem Steuerelement verbunden

Sie können ein Bezeichnungsfeld einem anderen Steuerelement zuordnen. Wenn Sie z.B. ein Textfeld erstellen, besitzt dieses ein zugeordnetes Bezeichnungsfeld, das eine Beschriftung für das Textfeld anzeigt. Dieses Bezeichnungsfeld wird als Spaltenüberschrift in der Datenblattansicht eines Formulars angezeigt.

Wenn Sie ein Bezeichnungsfeld mit dem Bezeichnungsfeld-Tool Bezeichnungsfeld-Steuerelement erstellen, ist dieses unabhängig, d. h., es ist keinem anderen Steuerelement zugeordnet. Verwenden Sie eigenständige Bezeichnungsfelder für Informationen, wie Titel von Formularen, Berichten oder Datenzugriffsseiten, oder für anderen beschreibenden Text. Eigenständige Bezeichnungsfelder werden nicht in der Datenblattansicht angezeigt.


 Erstellen eines Bezeichnungsfelds

Erstellen eines Bezeichnungsfelds

Verwenden Sie die folgende Verfahrensweise zum Erstellen eines eigenständigen Bezeichnungsfelds (ein Bezeichnungsfeld, das keinem Steuerelement zugeordnet ist). Um ein Bezeichnungsfeld zu erstellen, das einem Steuerelement zugeordnet ist, erstellen Sie einfach das gewünschte Steuerelement. Microsoft Access ordnet dem Steuerelement beim Erstellen automatisch ein Bezeichnungsfeld zu.

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Bezeichnung Bezeichnungsfeld-Steuerelement .

  3. Klicken Sie in dem Formular, in dem Bericht oder in der Datenzugriffsseite auf die Stelle, an der das Bezeichnungsfeld eingefügt werden soll, und geben Sie dann den entsprechenden Text ein.

Anmerkungen

  • Wenn Sie den Text eines Bezeichnungsfelds in einem Formular oder Bericht in mehreren Zeilen anzeigen möchten, können Sie die Größe des Bezeichnungsfelds nach dem Eingeben des gesamten Textes entsprechend anpassen oder am Ende der ersten Textzeile die Tastenkombination STRG+EINGABETASTE drücken, um einen Wagenrücklauf einzugeben. Wenn Sie einen Wagenrücklauf eingeben, bricht Microsoft Access beim Schreiben automatisch die nachfolgenden Zeilen um. Um in einer nachfolgenden Zeile manuell einen Zeilenumbruch einzugeben, drücken Sie erneut STRG+EINGABETASTE. Die maximale Breite des Bezeichnungsfelds wird durch die Länge der ersten Textzeile bestimmt.

  • Wenn Sie in einem Bezeichnungsfeld in einem Formular oder Bericht ein kaufmännisches Und-Zeichen (&) verwenden möchten, müssen Sie dafür zwei Und-Zeichen (&&) eingeben, da Microsoft Access das Und-Zeichen in einem Bezeichnungsfeld oder auf einer Schaltfläche zum Definieren einer Zugriffstaste verwendet.


 Ändern des Beschriftungs- oder des Befehlsschaltflächentextes

Ändern des Beschriftungs- oder des Befehlsschaltflächentextes

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf die Beschriftung oder auf die Schaltfläche, und markieren Sie dann den Beschriftungs- oder den Schaltflächentext.

    Schaltfläche mit markiertem Beschriftungstext

  3. Geben Sie den neuen Text ein.


 Zuordnen eines Bezeichnungsfeldes zu einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

Zuordnen eines Bezeichnungsfeldes zu einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht, oder öffnen Sie einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Bezeichnungsfeld, das Sie einem Steuerelement zuordnen möchten.

  3. Klicken Sie in der Symbolleiste auf Ausschneiden [image] .

  4. Klicken Sie auf das Steuerelement, dem Sie das Bezeichnungsfeld zuordnen möchten.

  5. Klicken Sie in der Symbolleiste auf Einfügen [image] .


 Festlegen, ob neuen Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht automatisch Bezeichnungsfelder zugeordnet werden sollen

Festlegen, ob neuen Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht automatisch Bezeichnungsfelder zugeordnet werden sollen

Verwenden Sie die folgende Verfahrensweise, um die Standardeigenschafteneinstellungen für das aktuelle Formular oder den aktuellen Bericht zu ändern. Wenn Sie die Standardeigenschafteneinstellungen für alle Formulare und Berichte ändern möchten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement der Toolbox, für das Sie Standardeinstellungen festlegen möchten. Wenn Sie zum Beispiel festlegen möchten, ob Bezeichnungsfelder automatisch Textfeldern zugeordnet werden sollen, klicken Sie auf das Textfeld-Steuerelement Textfeld-Steuerelement .

  3. Klicken Sie auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  4. Klicken Sie in der Zelle für die Eigenschaft Mit Bezeichnungsfeld auf Ja oder Nein.


 Ändern der Standardpositionierung neu zugeordneter Bezeichnungsfelder in Formularen und Berichten

Ändern der Standardpositionierung neu zugeordneter Bezeichnungsfelder in Formularen und Berichten

Änderungen, die Sie mit Hilfe der nachfolgenden Schritte vornehmen, haben nur für neue Steuerelemente im aktuellen Formular oder Bericht Gültigkeit. Wenn Sie die Standardeigenschafteneinstellungen für alle Formulare oder Berichte ändern möchten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement für den Steuerelementtyp, dem das Bezeichnungsfeld zugeordnet ist. Wenn Sie beispielsweise die Standardpositionierung für Bezeichnungsfelder ändern möchten, die Textfeldern zugeordnet sind, klicken Sie in der Toolbox auf das Steuerelement Textfeld Textfeld-Steuerelement .

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

    Microsoft Access ändert die Titelleiste des Eigenschaftenfensters und weist so darauf hin, dass Sie jetzt die Standardeigenschaften für diesen Steuerelementtyp festlegen.

  4. Geben Sie im Einstellungsfeld der Eigenschaft BezeichnungsfeldX (für die horizontale Achse) eine positive oder negative Zahl ein, die den Anfangspunkt des Bezeichnungsfelds relativ zur oberen linken Ecke des Steuerelements angibt, dem das Bezeichnungsfeld zugeordnet ist. Wenn Sie eine negative Zahl eingeben, wird das Bezeichnungsfeld links vom Steuerelement positioniert. Wenn Sie eine positive Zahl eingeben, wird das Bezeichnungsfeld rechts vom Steuerelement positioniert.

  5. Geben Sie im Einstellungsfeld der Eigenschaft BezeichnungsfeldY (für die vertikale Achse) eine Zahl ein. Wenn Sie eine negative Zahl eingeben, wird das Bezeichnungsfeld oberhalb des Steuerelements positioniert. Wenn Sie eine positive Zahl eingeben, wird das Bezeichnungsfeld unterhalb des Steuerelements positioniert.

Tipp Wenn Sie eine andere als die unter Ländereinstellungen in der Microsoft Windows-Systemsteuerung festgelegte Maßeinheit verwenden möchten, geben Sie diese hinter der Zahl an (beispielsweise 1,5 Zoll oder 2 cm).

Zum Anzeigen weiterer Informationen, wie die Eigenschaften BezeichnungsfeldX und BezeichnungsfeldY mit der Bezeichnungsausrichtung-Eigenschaft zusammenwirken, klicken Sie auf [image] .


 Festlegen, ob neue zugeordnete Bezeichnungsfelder in einem Formular oder Bericht einen Doppelpunkt enthalten

Festlegen, ob neue zugeordnete Bezeichnungsfelder in einem Formular oder Bericht einen Doppelpunkt enthalten

Verwenden Sie die folgende Verfahrensweise, um die Standardsteuerelementeinstellung für das aktuelle Formular oder den aktuellen Bericht zu ändern. Wenn Sie die Standardsteuerungsformatvorlage für alle Formulare und Berichte ändern möchten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Steuerelement in der Toolbox, für das Sie Standardeinstellungen festlegen möchten. Wenn Sie zum Beispiel aus Bezeichnungsfeldern, die Textfeldern zugeordnet sind, Doppelpunkte entfernen möchten, klicken Sie auf das Textfeld-Steuerelement Textfeld-Steuerelement .

  3. Klicken Sie auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  4. Klicken Sie im Feld für die MitDoppelpunkt- Eigenschaft auf Ja oder Nein.


 Was ist ein Textfeld?

Was ist ein Textfeld?

Sie können Textfelder in einem Formular, einem Bericht oder einer Datenzugriffsseite verwenden, um Daten aus einer Datenherkunft anzuzeigen. Dieser Textfeldtyp wird als gebundenes Textfeld bezeichnet, da es an Daten eines Feldes gebunden ist. Textfelder können auch ungebunden sein. Sie können beispielsweise ein ungebundenes Textfeld erstellen, um das Ergebnis einer Berechnung anzuzeigen oder Benutzereingaben aufzunehmen. Daten in einem ungebundenen Textfeld werden nicht in einer Tabelle gespeichert.

Beispiele für gebundene und ungebundene Textfelder


 Erstellen eines Textfeldes

Erstellen eines Textfeldes

Die Art der Erstellung eines Textfeldes hängt davon ab, ob das Textfeld gebunden, ungebunden oder berechnet sein soll.

Was möchten Sie tun?

Mehr über gebundene, ungebundene und berechnete Steuerelemente erfahren

Ein gebundenes Textfeld erstellen

Ein ungebundenes Textfeld erstellen

Ein berechnetes Textfeld erstellen


 Größenanpassung von Textfeldern an den Umfang der Daten beim Drucken von Formularen oder Berichten

Größenanpassung von Textfeldern an den Umfang der Daten beim Drucken von Formularen oder Berichten

  1. Öffnen Sie das Formular in der Entwurfsansicht bzw. den Bericht in der Entwurfsansicht.

  2. Um das Eigenschaftenfenster anzuzeigen, vergewissern Sie sich, dass das Textfeld markiert ist, und klicken Sie dann auf Eigenschaften [image] auf der Symbolleiste.

  3. Stellen Sie die Eigenschaften Vergrößerbar oder Verkleinerbar auf Ja ein.
    • Vergrößerbar erweitert das Textfeld in der Höhe, damit die darin enthaltenen Daten beim Drucken des Formulars oder Berichts nicht abgeschnitten werden.

    • Verkleinerbar verringert die Höhe des Textfeldes, wenn darin beim Drucken des Formulars oder Berichts keine Daten enthalten sind.

    Um Beispiele für in der Größe anpassungsfähige Textfelder anzuzeigen, klicken Sie auf [image] .

Anmerkungen

  • Wenn Sie für ein Textfeld die Eigenschaft Vergrößerbar auf Ja einstellen, setzt Microsoft Access auch für den ganzen Bereich die Eigenschaft Vergrößerbar auf Ja.

  • Die Berichte Katalog und Rechnung in der Beispieldatenbank Nordwind verfügen über in der Größe anpassungsfähige Textfelder. Um diese Berichte anzuzeigen, öffnen Sie die Datenbank Nordwind im Ordner BEISPIEL innerhalb des Office-Ordners, und öffnen Sie dann den gewünschten Bericht in der Entwurfsansicht. Um Information zum Öffnen von Nordwind anzuzeigen, klicken Sie auf [image] .


 Was ist ein Kontrollkästchen?

Was ist ein Kontrollkästchen?

Sie können ein Kontrollkästchen in einem Formular, in einem Bericht oder auf einer Datenzugriffsseite als eigenständiges Steuerelement verwenden, um einen Ja/Nein-Wert einer zugrunde liegenden Tabelle, Abfrage oder SQL-Anweisung anzuzeigen. Das Kontrollkästchen in der folgenden Abbildung ist z. B. an das Feld Auslaufartikel der Tabelle Artikel gebunden. Der Datentyp dieses Feldes ist Ja/Nein. Wenn das Kontrollkästchen ein Häkchen enthält, ist der Wert Ja, andernfalls ist er Nein.

Kontrollkästchen, das an ein Feld mit einem "Ja/Nein"-Datentyp gebunden ist

Wenn Sie ein Kontrollkästchen aktivieren oder deaktivieren, das an ein Feld mit dem Datentyp Ja/Nein in einer Microsoft Access-Datenbank oder eine Spalte vom Typ Bit in einem Microsoft Access-Projekt gebunden ist, zeigt Access den Wert in der zugrunde liegenden Tabelle gemäß der Format-Eigenschaft (Ja/Nein, Wahr/Falsch oder Ein/Aus) des Feldes an. In einem Access-Projekt ist das Optionsfeld an eine Spalte gebunden, die als Datentyp Bit definiert ist. Wenn der Wert in dieser Spalte 1 beträgt, entspricht dies der Bedingung Ja, Ein oder Wahr. Wenn der Wert 0 beträgt, gibt die Spalte die Bedingung Nein, Aus oder Falsch an.

Sie können Kontrollkästchen auch in einer Optionsgruppe verwenden, um Werte zum Auswählen anzuzeigen. Um weitere Informationen zu Optionsgruppen zu erhalten, klicken Sie auf [image] .

Sie können ein ungebundenes Kontrollkästchen auch in einem benutzerdefinierten Dialogfeld zur Benutzereingabe verwenden.


 Was ist ein Optionsfeld?

Was ist ein Optionsfeld?

Sie können ein Optionsfeld in einem Formular, einem Bericht oder einer Datenzugriffsseite als eigenständiges Steuerelement verwenden, um einen Ja/Nein-Wert aus einer zugrunde liegenden Datenherkunft anzuzeigen. Das Optionsfeld in der folgenden Abbildung ist beispielsweise an das Feld Auslaufartikel der Tabelle Artikel einer Datenbank gebunden. Der Datentyp dieses Feldes ist Ja/Nein. Wenn das Optionsfeld ausgewählt ist, ist der Wert in der Tabelle Ja. Ist das Optionsfeld nicht gewählt, ist der Wert Nein.

Eigenständiges Optionsfeld, das einen an ein Feld gebundenen Ja-Wert anzeigt

Wenn Sie ein Optionsfeld auswählen oder löschen, das an ein Ja/Nein-Feld in einer Microsoft Access-Datenbank gebunden ist, wird der Wert in der zugrunde liegenden Tabelle entsprechend der Format-Feldeigenschaft (Ja/Nein, Wahr/Falsch oder Ein/Aus) angezeigt. In einem Microsoft Access-Projekt, ist das Optionsfeld an eine als Bit-Datentyp definierte Spalte gebunden. Wenn der Wert in dieser Spalte 1 beträgt, entspricht dies den Bedingungen Ja, Ein bzw. Wahr. Ist der Wert 0, gibt die Spalte die Bedingungen Nein, Aus bzw. Falsch an. Sie können diese Optionsfelder auch in einer Optionsgruppe verwenden, um Werte zum Auswählen anzuzeigen. Um weitere Informationen zu Optionsgruppen zu erhalten, klicken Sie [image] .

Sie können ein ungebundenes Optionsfeld auch in einem benutzerdefinierten Dialogfeld zur Benutzereingabe verwenden.


 Was ist eine Optionsgruppe?

Was ist eine Optionsgruppe?

Sie können eine Optionsgruppe in einem Formular, einem Bericht oder einer Datenzugriffsseite verwenden, um eine begrenzte Anzahl an Auswahlmöglichkeiten zur Verfügung zu stellen. Eine Optionsgruppe erleichtert die Auswahl, da Sie nur auf den gewünschten Wert zu klicken brauchen. In einer Optionsgruppe kann immer nur ein Wert ausgewählt werden.

In Formularen und Berichten besteht eine Optionsgruppe aus einem Gruppenrahmen und einer Gruppe von Kontrollkästchen, Optionsfeldern und Umschaltflächen. In Datenzugriffsseiten besteht eine Optionsgruppe nur aus einem Gruppenrahmen und einer Gruppe von Optionsfeldern.

Wenn eine Optionsgruppe an ein Feld gebunden ist, dann ist nur der Gruppenrahmen an das Feld gebunden, nicht aber die Kontrollkästchen, Umschaltflächen oder Optionsfelder innerhalb des Rahmens. Statt die Steuerelementinhalt-Eigenschaft für die einzelnen Steuerelemente der Optionsgruppe anzupassen, stellen Sie die Eigenschaften Optionvalue (Formulare und Berichte) bzw. Value (Datenzugriffsseiten) für jedes Kontrollkästchen, Optionsfeld oder jede Umschaltfläche ein. In einem Formular oder einem Bericht stellen Sie die Steuerelementeigenschaft auf einen sinnvollen Wert für das Feld ein, an welches der Gruppenrahmen gebunden ist. In einer Datenzugriffsseite stellen Sie die Steuerelementeigenschaft entweder auf einen Wert oder auf einen beliebigen sinnvollen Text für das Feld ein, an welches der Gruppenrahmen gebunden ist. Beim Auswählen einer Option in einer Optionsgruppe setzt Microsoft Access den Wert des Feldes, an das die Optionsgruppe gebunden ist, auf die Einstellung der Optionvalue- bzw. Value-Eigenschaft der ausgewählten Option.

Ausgewählte Option in einer Optionsgruppe

Anmerkungen

  • Die Eigenschaft Optionvalue bzw. Value wird auf eine Zahl gesetzt, da der Wert einer Optionsgruppe nur eine Zahl und kein Text sein kann. Access speichert diese Zahl in der zugrunde liegenden Tabelle. Wenn Sie in diesem Beispiel statt einer Zahl den Namen der Versandfirma in der Tabelle Bestellungen einer Access-Datenbank anzeigen möchten, können Sie eine eigene Tabelle namens Versandfirmen erstellen, welche die Namen der Versandfirmen beinhaltet. Ändern Sie dann das Feld Versandfirma in ein Nachschlagefeld (Listen- oder Kombinationsfeld) um, das die entsprechenden Daten in der Tabelle Versandfirmen heraussucht. Um weitere Informationen zum Erstellen eines Nachschlagefelds zu erhalten, klicken Sie auf [image] .

  • In einem Formular oder einem Bericht kann eine Optionsgruppe auch einen Ausdruck als Eigenschaft Steuerelementinhalt besitzen. Optionsgruppen in Formularen, Berichten oder Datenzugriffsseiten können ungebunden sein. Sie können eine ungebundene Optionsgruppe in einem benutzerdefinierten Dialogfeld zur Benutzereingabe verwenden und dann basierend auf dieser Eingabe eine Aktion durchführen.


 Erstellen eines Kontrollkästchens, einer Umschaltfläche oder eines Optionsfelds

Erstellen eines Kontrollkästchens, einer Umschaltfläche oder eines Optionsfelds

Wie Sie ein Kontrollkästchen, Optionsfeld oder eine Umschaltfläche erstellen, hängt davon ab, ob es sich dabei um ein eigenständiges Steuerelement, das an ein Ja/Nein-Feld in einer Microsoft Access-Datenbank oder an eine Bit-Spalte in einem Microsoft Access-Projekt gebunden ist, ein Steuerelement, das einer Optionsgruppe angehört oder ein ungebundenes Steuerelement handeln soll.

Was möchten Sie tun?

Informationen über Kontrollkästchen und ihre Funktionsweise erhalten.

Informationen über Umschaltflächen und ihre Funktionsweise erhalten.

Informationen über Optionsfelder und ihre Funktionsweise erhalten.

Informationen über Optionsgruppen und ihre Funktionsweise erhalten.

Ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld erstellen, das an ein Ja/Nein-Feld oder an eine Bit-Spalte gebunden ist.

Eine Optionsgruppe erstellen und dieser Kontrollkästchen, Umschaltflächen oder Optionsfelder hinzufügen.

Ein ungebundenes Kontrollkästchen, Optionsfeld oder eine ungebundene Umschaltfläche erstellen.


 Erstellen einer Optionsgruppe mit Kontrollkästchen, Umschaltflächen oder Optionsfeldern

Erstellen einer Optionsgruppe mit Kontrollkästchen, Umschaltflächen oder Optionsfeldern

Sie können eine Optionsgruppe entweder selbst erstellen oder sie von Microsoft Access mit Hilfe eines Assistenten erstellen lassen. Das Verwenden eines Assistenten erleichtert das Erstellen einer Optionsgruppe wesentlich, da er die grundlegenden Arbeiten für Sie übernimmt. Dabei werden Sie nach bestimmten Informationen gefragt, und daraufhin erstellt Access die Optionsgruppe auf der Grundlage Ihrer Antworten.

Anmerkung Umschaltflächen sind in Datenzugriffsseiten nicht verfügbar.

Tipp Wenn Sie eine größere Anzahl Optionen darstellen möchten, verwenden Sie an Stelle einer Optionsgruppe ein Listenfeld, ein Kombinationsfeld oder eine Dropdownliste.

Was möchten Sie tun?

Informationen über Optionsgruppen und ihre Funktionsweise erhalten.

Eine Optionsgruppe unter Verwendung eines Assistenten erstellen.

Eine Optionsgruppe ohne Verwendung eines Assistenten erstellen.


 Listenfelder: Definition und Funktionsweise

Listenfelder: Definition und Funktionsweise

Oftmals ist es leichter und schneller, einen Wert aus einer Liste auszuwählen, als ihn einzugeben. Mit Hilfe einer Auswahlliste können Sie außerdem sicherstellen, dass der Wert, den Sie in ein Feld eingegeben haben, korrekt ist.

Die Liste eines Listenfeldes besteht aus Datenzeilen. In einem Formular kann ein Listenfeld aus einer oder mehreren Spalten bestehen, die mit oder ohne Überschriften angezeigt werden können. Wenn ein mehrspaltiges Listenfeld gebunden ist, speichert Microsoft Access den Wert aus einer der Spalten. Auf einer Datenzugriffsseite besteht ein Listenfeld aus einer Spalte ohne Überschrift.

Listenfeldwert, der im zugrunde liegenden Feld gespeichert ist

Mit Hilfe eines ungebundenen Listenfelds können Sie einen Wert speichern, den Sie für ein anderes Steuerelement verwenden können. So können Sie ein ungebundenes Listenfeld z.B. verwenden, um die Werte in einem anderen Listenfeld oder einem benutzerdefinierten Dialogfeld zu begrenzen. Sie können es außerdem verwenden, um einen Datensatz zu suchen, der auf dem im Listenfeld ausgewählten Wert basiert.

In einem Formular können Sie ein Kombinationsfeld statt eines Listenfeldes verwenden. Dies benötigt weniger Platz, und Sie können sowohl neue Werte in das Feld eingeben als auch Werte aus einer Liste auswählen. Weitere Informationen über Kombinationsfelder in Formularen.

Auf einer Datenzugriffsseite können Sie statt eines Listenfeldes eine Dropdownliste verwenden; dieses benötigt weniger Platz; Sie können jedoch keine neuen Werte eingeben. Weitere Informationen über Dropdownlisten auf Datenzugriffsseiten.


 Kombinationsfelder: Definition und Funktionsweise

Kombinationsfelder: Definition und Funktionsweise

Oftmals ist es leichter und schneller, einen Wert aus einer Liste auszuwählen, als ihn einzugeben. Ein Kombinationsfeld ermöglicht Ihnen beides, ohne viel Platz im Formular zu beanspruchen. Ein Kombinationsfeld ist eine Kombination aus einem Text- und einem Listenfeld.

Kombinationsfeld vereinigt die Funktionalität von Textfeldern und Listenfeldern

Wenn Sie in ein gebundenes Kombinationsfeld Text eingeben oder einen Wert aus seiner Liste auswählen, wird dieser eingegebene oder ausgewählte Wert in das Feld eingefügt, an den das Kombinationsfeld gebunden ist.

Kombinationsfeldwert, der im zugrunde liegenden Feld gespeichert ist

Die Liste eines Kombinationsfeldes besteht aus Datenzeilen. Diese Zeilen wiederum können aus einer oder mehreren Spalten bestehen, die mit oder ohne Überschriften angezeigt werden können. Wenn ein mehrspaltiges Kombinationsfeld gebunden ist, speichert Microsoft Access den Wert aus einer der Spalten.

Mit Hilfe eines ungebundenen Kombinationsfelds können Sie einen Wert speichern, den Sie für ein anderes Steuerelement verwenden können. So können Sie ein ungebundenes Kombinationsfeld z.B. verwenden, um die Werte in einem anderen Kombinationsfeld oder einem benutzerdefinierten Dialogfeld zu begrenzen. Außerdem können Sie es verwenden, um einen Datensatz zu suchen, der auf dem im Kombinationsfeld ausgewählten Wert basiert.

Sie können für Kombinationsfelder die Eigenschaft NurListeneinträge einstellen, um anzugeben, ob ein beliebiger Wert in die Liste eingegeben werden kann, oder ob ausschließlich Text eingegeben werden kann, der mit einem der Listenwerte übereinstimmt.

Wenn Sie über genügend Platz in Ihrem Formular verfügen und die Liste permanent anzeigen oder wenn Sie die Dateneinträge immer auf die Listenwerte beschränken möchten, können Sie statt eines Kombinationsfelds ein Listenfeld verwenden. Zum Anzeigen weiterer Informationen zu Listenfeldern klicken Sie auf [image] .


 Dropdownlisten: Definition und Funktionsweise

Dropdownlisten: Definition und Funktionsweise

In vielen Fällen ist es einfacher und schneller, einen Wert in einer Liste auszuwählen, als sich ihn für die Eingabe zu merken. Mit Hilfe einer Dropdownliste können Sie einen Wert in einer Liste auswählen, ohne allzu viel Platz auf einer Datenzugriffsseite zu benötigen. Eine Dropdownliste einer Datenzugriffseite ähnelt einem Kombinationsfeld eines Formulars. Wie in einem Kombinationsfeld zeigt eine Dropdownliste solange nur einen Datensatz an, bis Sie auf das Element klicken, um die Anzeige zu erweitern. Allerdings können Sie in einer Dropdownliste keine neuen Werte eingeben.

Auswahl eines Wertes in einer Dropdownliste

Wenn es sich bei der Dropdownliste, in der Sie einen Wert auswählen, um ein gebundenes Steuerelement handelt, wird der ausgewählte Wert in das Feld eingefügt, an das die Dropdownliste gebunden ist.

In der Dropdownliste ausgewählter Wert wird in zugeordnetem Feld gespeichert

Das Listenfeld einer Dropdownliste besteht aus Datenzeilen. Diese Zeilen können nur eine einzige Spalte ohne Überschrift enthalten.

Sie können eine ungebundene Dropdownliste verwenden, um einen Wert zu speichern, den Sie dann mit einem anderen Steuerelement weiterverwenden können. Beispielsweise könnten Sie mit Hilfe einer ungebundenen Dropdownliste die Werte einer anderen Dropdownliste beschränken. Oder Sie könnten eine ungebundene Dropdownliste dazu verwenden, einen Datensatz nach Maßgabe des in der Dropdownliste ausgewählten Wertes zu suchen.

Wenn Ihre Datenzugriffsseite allerdings genügend Platz zur Verfügung stellt und wenn Sie möchten, dass der Listeninhalt immer sichtbar ist, könnte es sich für Sie empfehlen, statt einer Dropdownliste ein gewöhnliches Listenfeld zu verwenden. Um weitere Informationen über Listenfelder zu erhalten, klicken Sie auf [image] .


 Wann sollte ein Listenfeld, wann ein Kombinationsfeld und wann ein Dropdownlistenfeld verwendet werden?

Wann sollte ein Listenfeld, wann ein Kombinationsfeld und wann ein Dropdownlistenfeld verwendet werden?

Berücksichtigen Sie bei der Entscheidung, ob Sie ein Listenfeld, ein Kombinationsfeld oder ein Dropdownlistenfeld erstellen möchten, wo Sie das Steuerelement verwenden möchten, wie das Steuerelement in Ihrem Formular oder auf Ihrer Datenzugriffsseite angezeigt werden soll und wie es verwendet werden soll. Beide Steuerelemente haben bestimmte Vorteile:

Vorteile eines Listenfeldes Listenfelder können in Formularen und auf Datenzugriffsseiten verwendet werden. Die Liste wird permanent angezeigt, und der Wert des Steuerelements ist auf die Listeneinträge beschränkt. Um schnell zum ersten Wert mit einem bestimmten Anfangsbuchstaben zu gelangen, geben Sie einfach den Buchstaben ein. Wenn Sie das Formular oder die Datenzugriffsseite zur Dateneingabe oder -bearbeitung verwenden, können Sie nur Werte aus der Liste hinzufügen. Zum Anzeigen weiterer Informationen zu Listenfeldern und ihrer Arbeitsweise klicken Sie auf [image] .

Vorteile eines Kombinationsfeldes Kombinationsfelder können in Formularen verwendet werden. Da die Liste erst angezeigt wird, wenn Sie sie öffnen, benötigt dieses Steuerelement weniger Platz im Formular. Um einen Wert schnell zu suchen, geben Sie einfach die ersten paar Zeichen dieses Wertes in das Kombinationsfeld ein. Sie können außerdem angeben, ob ein beliebiger Wert in die Liste eingegeben werden kann, oder ob ausschließlich Text eingegeben werden kann, der mit einem der Listenwerte übereinstimmt. Zum Anzeigen weiterer Informationen zu Kombinationsfeldern und ihrer Arbeitsweise klicken Sie auf [image] .

Vorteile eine Dropdownlistenfeldes Dropdownlistenfelder können auf Datenzugriffsseiten verwendet werden. Da die Liste erst angezeigt wird, wenn Sie sie öffnen, benötigt dieses Steuerelement weniger Platz auf der Datenzugriffsseite. Der Wert des Steuerelements ist auf die Reihe der Alternativen in der Liste beschränkt. Um schnell zum ersten Wert mit einem bestimmten Anfangsbuchstaben zu gelangen, geben Sie einfach den Buchstaben ein. Zum Anzeigen weiterer Informationen zu Dropdownlistenfeldern und ihrer Arbeitsweise klicken Sie auf [image] .


 Erstellen von gebundenen oder ungebundenen Kombinationsfeldern, Dropdownlisten oder Listenfeldern

Erstellen von gebundenen oder ungebundenen Kombinationsfeldern, Dropdownlisten oder Listenfeldern

Das Verfahren zur Erstellung von Kombinationsfeldern, Dropdownlisten und Listenfeldern hängt von zwei Fragestellungen ab:

  • Sollen die Werte im Feld einer feststehenden Liste oder einer Tabelle bzw. Abfrage entnommen werden?

  • Soll Microsoft Access die vom Benutzer ausgewählten Werte speichern oder zur Steuerung der Inhalte eines anderen Steuerelements verwenden?

Was möchten Sie tun?

In einem Formular ein gebundenes Listen- oder Kombinationsfeld erstellen, das Daten einer Access-Datenbank anzeigt

In einem Microsoft Access-Projekt oder auf einer Datenzugriffsseite ein gebundenes Listenfeld, Kombinationsfeld oder eine Dropdownliste erstellen, das bzw. die Daten aus einer Datenquelle abruft

Ein ungebundenes Listenfeld, Kombinationsfeld oder eine Dropdownliste mit festen Werten erstellen

Ein ungebundenes Listenfeld, Kombinationsfeld oder eine Dropdownliste mit Werten aus einer Tabelle oder Abfrage erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Sortieren von Datensätzen in einem Listen-, Dropdownlisten- oder einem Kombinationsfeld

Sortieren von Datensätzen in einem Listen-, Dropdownlisten- oder einem Kombinationsfeld

Wenn Sie das Listenfeld, die Dropdownliste oder das Kombinationsfeld mit Hilfe eines Assistenten erstellen, sortiert Microsoft Access die Listeneinträge automatisch nach der ersten sichtbaren Spalte. Wenn Sie eine andere Sortierreihenfolge angeben möchten oder eine gespeicherte Abfrage als Datensatzquelle für das Listen-, Dropdownlisten oder Kombinationsfeld verwenden, können Sie diese Schritte durchführen.

Anmerkung In einer eigenständigen Datenzugriffsseite oder einer nicht der derzeit geöffneten Datenbank zugewiesenen Datenzugriffsseite stehen Assistenten nicht zur Verfügung. In diesem Fall müssen Sie selbst ein Listenfeld oder eine Dropdownliste erstellen.

  1. Öffnen Sie das Formular in der Entwurfsansicht oder die Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Listen-, Dropdownlisten- oder Kombinationsfeld markiert ist und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des betreffenden Steuerelements zu öffnen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Zur Änderung der Sortierreihenfolge eines Steuerelements auf einem Formular klicken Sie im Einstellungsfeld der Datensatzherkunft-Eigenschaft auf die Generator-Schaltfläche [image] , um den Abfrage-Generator oder den Ausdrucks-Generator zu öffnen.

    • Zum Ändern der Sortierreihenfolge eines Steuerelements auf einer Datenzugriffsseite erstellen Sie eine Abfrage mit der gewünschten Sortierreihenfolge und wählen anschließend auf der Datenzugriffsseite im Einstellungsfeld der ListRowSource-Eigenschaft die Abfrage aus der Liste aus.
  4. Geben Sie die Sortierreihenfolge an.

    Wie wird's gemacht?


 Binden einer Spalte aus einem Listenfeld, Kombinationsfeld oder einem Dropdownlistenfeld

Binden einer Spalte aus einem Listenfeld, Kombinationsfeld oder einem Dropdownlistenfeld

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Listenfeld, Dropdownlistenfeld oder Kombinationsfeld ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des betreffenden Steuerelements zu öffnen.

  3. Führen Sie einen der folgenden Schritte durch:

    Geben Sie in dem Formular im Einstellungsfeld der GebundeneSpalte-Eigenschaft für das Listen- oder Kombinationsfeld eine Zahl an, die der Position der zu bindenden Spalte im Listen- oder Kombinationsfeld entspricht. Geben Sie beispielsweise 1 ein, um die erste Spalte des Listen- oder Kombinationsfeldes an das zugrunde liegende Feld, das für die Steuerelementinhalt-Eigenschaft angegeben ist, zu binden. Schließen Sie beim Zählen der Spalten auch die ausgeblendeten Spalten mit ein.

    Auf einer Datenzugriffsseite geben Sie im Einstellungsfeld der ListBoundField-Eigenschaft für das Listenfeld oder Dropdownlistenfeld den Namen des Feldes an, das der Position der Spalte im Listenfeld oder Dropdownlistenfeld entspricht.

Anmerkungen

  • In Formularen können Sie die Position einer ausgeblendeten Spalte in der GebundeneSpalte-Eigenschaft angeben. Um weitere Informationen zum Ausblenden einer Spalte in einem mehrspaltigen Listen- oder Kombinationsfeld anzuzeigen, klicken Sie auf [image] .

  • Wenn Sie in Formularen die GebundeneSpalte-Eigenschaft auf 0 festlegen, speichert Microsoft Access den Listenindex statt des Wertes einer der Spalten. Dies ist nützlich, wenn Sie an Stelle des Listenwertes die Reihenfolge der Werte speichern möchten.

  • Zum Anzeigen weiterer Informationen zur GebundeneSpalte-Eigenschaft klicken Sie auf [image] .


 Optimieren der Leistung von Listenfeldern, Dropdownlistenfeldern oder Kombinationsfeldern

Optimieren der Leistung von Listenfeldern, Dropdownlistenfeldern oder Kombinationsfeldern

Es gibt verschiedene Möglichkeiten, Ihre Listenfelder, Dropdownlistenfelder und Kombinationsfelder schneller ausführen zu lassen.

  • Basieren Sie das Listenfeld, das Kombinationsfeld oder das Dropdownlistenfelde auf einer Gespeicherten Abfrage anstatt auf einer SQL-Anweisung. Wenn Sie in einem Formular einen Assistenten verwenden, um ein Listen- oder Kombinationsfeld zu erstellen, stellt Microsoft Access die Eigenschaft Datensatzherkunft des Steuerelements automatisch auf eine SQL-Anweisung ein. Sie ändern die Eigenschaft Datensatzherkunft in eine gespeicherte Abfrage, indem Sie auf die Generator-Schaltfläche [image] neben dem Einstellungsfeld der Eigenschaft Datensatzherkunft klicken. Klicken Sie, während das Abfrage-Generatorfenster geöffnet ist, im Menü Datei auf Speichern, und geben Sie einen Namen für die Abfrage ein. Wenn Sie das SQL-Generatorfenster schließen, klicken Sie auf Ja, wenn Microsoft Access Sie fragt, ob Sie die Eigenschaft aktualisieren möchten.

  • Basieren Sie das Dropdownlistenfeld auf einer Gespeicherten Abfrage anstatt auf einer Tabelle. Wenn Sie auf einer Datenzugriffsseite einen Assistenten verwenden, um ein Dropdownlistenfeld zu erstellen, legt Access automatisch die ListRowSource-Eigenschaft des Steuerelements auf die Tabelle fest, die Sie im Assistenten angegeben haben. Um Zeilen aus einer Abfrage anstatt aus einer Tabelle abzurufen, wählen Sie den Abfragenamen aus dem Einstellungsfeld der ListRowSource-Eigenschaft aus.

  • Fügen Sie zu der Abfrage, die im Einstellungsfeld der Datensatzherkunft- oder ListRowSource-Eigenschaft angegeben ist, nur die Felder hinzu, die Sie unbedingt benötigen. Zusätzliche Felder können die Leistung verringern.

  • Indizieren Sie sowohl das erste Feld des Kombinations- oder Listenfelds oder des Dropdownlistenfeldes als auch das gebundene Feld (falls diese Felder nicht identisch sind).

  • Stellen Sie in Kombinationsfeldern in Formularen die Eigenschaft AutomatischErgänzen auf Nein ein, wenn Sie die automatische Eingabeergänzung nicht benötigen.

  • Wenn in einem Formular die Eigenschaft Automatisch ergänzen eines Kombinationsfeldes auf Ja eingestellt ist, sollte das erste angezeigte Feld den Datentyp Text und nicht Zahl enthalten. Um eine Entsprechung in der Liste zu suchen, werden numerische Werte von Microsoft Access in Text konvertiert. Wenn der Datentyp Text ist, muss Microsoft Access diese Konvertierung nicht durchführen.

  • Wenn das gebundene Feld eines Nachschlage-Kombinationsfelds in einem Formular nicht das angezeigte Feld ist, beachten Sie Folgendes:
    • Verwenden Sie keine Ausdrücke für das gebundene oder das angezeigte Feld.

    • Verwenden Sie keine Einschränkungen in der Datensatzherkunft.

    • Verwenden Sie ggf. Datensatzherkünfte (oder Abfragen), die auf nur einer Tabelle basieren, an Stelle von Datensatzherkünften auf der Grundlage mehrerer Tabellen.
  • Erstellen Sie keine Listenfelder, Kombinationsfelder oder Dropdownlistenfelder auf der Grundlage von Daten in verknüpften Tabellen, wenn sich diese Daten nicht ändern. Es ist in diesem Fall sinnvoller, diese Daten in Ihre Datenbank zu importieren.

Anmerkung Generatoren sind in einer Datenzugriffsseite nicht verfügbar. Assistenten stehen in Einzel-Datenzugriffsseiten oder dann, wenn eine Datenzugriffsseite auf eine andere Datenbank als die gerade geöffnete zeigt, nicht zur Verfügung. In beiden Fällen müssen Sie selbst ein Listenfeld oder ein Dropdownlistenfeld erstellen.


 Hinzufügen von Spaltenüberschriften zu einem Listen- oder Kombinationsfeld in einem Formular

Hinzufügen von Spaltenüberschriften zu einem Listen- oder Kombinationsfeld in einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Listen- oder Kombinationsfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des betreffenden Steuerelements zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Spaltenüberschriften auf Ja, um die Spaltenüberschriften anzuzeigen.

Wenn dem Kombinations- oder Listenfeld eine Datenherkunft zugrunde liegt, verwendet Microsoft Access die Feldnamen der Datenherkunft als Spaltenüberschriften. Wenn das Kombinations- oder Listenfeld auf einer festen Wertliste basiert, verwendet Microsoft Access die ersten x Datenelemente aus der Wertliste (Eigenschaft Datensatzherkunft) als Spaltenüberschriften, wobei x die für die Eigenschaft Spaltenanzahl festgelegte Zahl darstellt.

Anmerkungen

  • In Kombinationsfeldern werden die Überschriften nur bei geöffneter Liste angezeigt.

  • Zum Anzeigen weiterer Informationen zum Erstellen fester Wertlisten mit Hilfe der Eigenschaft Datensatzherkunft, klicken Sie auf [image] .


 Ausblenden einer Spalte in einem Listen- oder Kombinationsfeld in einem Formular

Ausblenden einer Spalte in einem Listen- oder Kombinationsfeld in einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Listen- oder Kombinationsfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des betreffenden Steuerelements zu öffnen.

  3. Geben Sie im Einstellungsfeld Spaltenbreiten-Eigenschaft für die Spalte oder Spalten, die Sie ausblenden möchten, 0 ein.

Angenommen, Sie haben ein gebundenes Kombinationsfeld mit zwei Spalten, Lieferanten-Nr und Lieferantenname. Die Spalte Lieferanten-Nr ist die erste Spalte der Liste. Um sie auszublenden, stellen Sie die Eigenschaft Spaltenbreiten entsprechend der folgenden Abbildung ein.

Ausblenden von Spalten unter Verwendung der "Spaltenbreiten"-Eigenschaft

Anmerkung In einem Kombinationsfeld wird die erste sichtbare Spalte im Textfeld des Kombinationsfelds angezeigt, wenn die Liste nicht angezeigt wird. Im obigen Beispiel würde dann die Spalte Lieferantenname angezeigt, da die Spalte Lieferanten-Nr ausgeblendet ist. Wäre die Spalte Lieferanten-Nr nicht ausgeblendet, würde nur sie angezeigt.


 Einschränken der Einträge für ein Kombinationsfeld auf die Einträge in der Liste in einem Formular

Einschränken der Einträge für ein Kombinationsfeld auf die Einträge in der Liste in einem Formular

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Kombinationsfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft NurListeneinträge auf Ja.

Anmerkungen

  • Wenn die erste in einem Kombinationsfeld angezeigte Spalte nicht die gebundene Spalte ist, beschränkt Microsoft Access die Einträge auf diejenigen in der Liste, auch wenn die Eigenschaft NurListeneinträge auf Nein gesetzt ist.

  • Wenn Sie in ein gebundenes Kombinationsfeld, dessen Eigenschaft NurListeneinträge auf Nein gesetzt ist, einen Eintrag eingeben, der nicht in der Liste enthalten ist, wird dieser Eintrag zwar im zugrunde liegenden Feld gespeichert, doch der Liste nicht hinzugefügt. Um der Liste neue Einträge hinzuzufügen, können Sie die Eigenschaft BeiNichtInListe und das Ereignis NichtInListe verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Verwenden einer SQL-Anweisung als Datensatzquelle für ein Listen- oder Kombinationsfeld in einem Formular

Verwenden einer SQL-Anweisung als Datensatzquelle für ein Listen- oder Kombinationsfeld in einem Formular

Vielleicht möchten Sie an Stelle einer gespeicherten Abfrage lieber eine SQL-Anweisung als Datensatzquelle für ein Listen- oder Kombinationsfeld in einem Formular verwenden. Auf diese Weise wird die Abfrage nicht im Datenbankfenster angezeigt. Listen- oder Kombinationsfelder, die auf einer SQL-Anweisung basieren, sind jedoch langsamer als diejenigen, denen eine gespeicherte Abfrage zugrunde liegt.

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Listen- oder Kombinationsfeld markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des betreffenden Steuerelements zu öffnen.

  3. Klicken Sie auf die Generator-Schaltfläche [image] neben der RowSource-Eigenschaft, um den Abfrage-Generator zu öffnen.

  4. Klicken Sie im Abfrage-Generator im Menü Ansicht auf SQL.

  5. Markieren Sie im SQL-Fenster die vollständige SQL-Anweisung, und drücken Sie STRG+C, um sie zu kopieren. Schließen Sie dann den Abfrage-Generator.

  6. Klicken Sie im Einstellungsfeld der RowSource-Eigenschaft, und drücken Sie STRG+V, um die SQL-Anweisung in das Einstellungsfeld einzufügen.

  7. Löschen Sie die ursprüngliche Abfrage im Datenbankfenster.

Anmerkungen

  • Zum Anzeigen von Informationen zu Eigenschaften, die Sie zum Anpassen eines Listen- oder Kombinationsfelds verwenden können, klicken Sie auf [image] .

  • Wenn Sie ein Listen- oder Kombinationsfeld in einem Formular mit Hilfe eines Assistenten erstellen, verwendet Microsoft Access eine SQL-Anweisung als Datensatzquelle.


 Festlegen der maximalen Anzahl der Zeilen, die in einem Kombinationsfeld auf einem Formular angezeigt werden sollen

Festlegen der maximalen Anzahl der Zeilen, die in einem Kombinationsfeld auf einem Formular angezeigt werden sollen

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Kombinationsfeld markiert ist und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Zeilenanzahl-Eigenschaft eine Zahl ein.

    Wenn die tatsächliche Zeilenanzahl die für die Zeilenanzahl-Eigenschaft angegebene Zahl überschreitet, wird im Kombinationsfeld eine vertikale Bildlaufleiste angezeigt.


 Festlegen der Breite der Kombinationsfeldliste auf einem Formular

Festlegen der Breite der Kombinationsfeldliste auf einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Kombinationsfeld markiert ist und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Listenbreite-Eigenschaft die gewünschte Breite ein, und zwar unter Verwendung der aktuellen Maßeinheit (die in der Windows-Systemsteuerung festgelegt ist). Um eine andere als die Standardmaßeinheit zu verwenden, fügen Sie die entsprechende Maßeinheit ein. Geben Sie beispielsweise 2" ein.

Anmerkungen

  • Die Liste des Kombinationsfelds kann zwar breiter sein als das Textfeld, jedoch nicht schmaler. Mit der Standardeinstellung (Auto) wird für die Liste die gleiche Breite festgelegt wie für das Textfeld des Kombinationsfelds.

  • Lassen Sie beim Entwerfen eines Kombinationsfelds genügend Platz für eine Bildlaufleiste.


 Deaktivieren der automatischen Eingabeergänzung eines Kombinationsfelds in einem Formular

Deaktivieren der automatischen Eingabeergänzung eines Kombinationsfelds in einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Kombinationsfeld markiert ist und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der AutomatischErgänzen-Eigenschaft auf Nein.

    Anmerkung Wenn die AutomatischErgänzen-Eigenschaft auf Nein eingestellt ist, müssen Sie einen Wert aus der Liste wählen oder den vollständigen Wert eingeben.


 Eigenschaften, die Sie zum Erstellen oder Ändern von Listenfeldern und Kombinationsfeldern in einem Formular verwenden können

Eigenschaften, die Sie zum Erstellen oder Ändern von Listenfeldern und Kombinationsfeldern in einem Formular verwenden können

Wenn Sie ein Listen- oder Kombinationsfeld mit Hilfe eines Assistenten erstellen, stellt Microsoft Access bestimmte Eigenschaften für das Steuerelement ein. Sie können mit diesen Eigenschaften direkt arbeiten, wenn Sie das Steuerelement nicht mit einem Assistenten erstellen möchten, oder Sie erstellen das Steuerelement mit einem Assistenten und passen die Eigenschaften dann Ihren Bedürfnissen an. Um mehr über eine der folgenden Eigenschaften zu erfahren, klicken Sie im Eigenschaftenfenster auf die entsprechende Eigenschaft, und drücken Sie dann F1.

Anmerkung Wenn Sie planen, ein gebundenes Listen- oder Kombinationsfeld in mehr als einem Formular in einer Access-Datenbank (.mdb) zu verwenden, können Sie die meisten dieser Eigenschaften statt über das Eigenschaftenfenster des Steuerelements auch in der Tabellenentwurfsansicht einstellen. Somit brauchen Sie die Eigenschaften nur einmal anzugeben. Wenn Sie das Feld einem Formular hinzufügen, erstellt Microsoft Access das Steuerelement automatisch auf der Grundlage der angegebenen Eigenschaften.

Eigenschaft | Beschreibung
Herkunftstyp | Steht im Zusammenhang mit der Eigenschaft Datensatzherkunft. Geben Sie mit Hilfe dieser Eigenschaft den Typ der Datensatzquelle an (Tabelle/Abfrage, Wertliste, Feldliste oder eine Visual Basic-Funktion), und geben Sie dann bei den ersten drei Typen die konkrete Datensatzquelle mit der Eigenschaft Datensatzherkunft an.
Datensatzherkunft | Gibt den Namen der Tabelle, Abfrage oder SQL-Anweisung an, wenn Herkunftstyp auf Tabelle/Abfrage gesetzt ist. Gibt die Listeneinträge durch Semikolon getrennt an, wenn Herkunftstyp auf Wertliste gesetzt ist. Gibt den Namen der Tabelle oder Abfrage an, wenn Herkunftstyp auf Feldliste gesetzt ist, und bleibt leer, wenn Herkunftstyp einen Funktionsnamen enthält.
Gebundene Spalte | Gibt in einem gebundenen mehrspaltigen Listen- oder Kombinationsfeld an, welche Spalte an das zugrunde liegende, in der Eigenschaft Steuerelementinhalt angegebene Feld gebunden ist. Die Daten dieser Spalte werden im Feld gespeichert, wenn Sie das Listenelement auswählen. Diese Daten unterscheiden sich unter Umständen von den in der Liste erscheinenden Daten, wenn Sie die Spalte ausblenden.
Spaltenanzahl | Gibt die Anzahl der Spalten eines Listen- oder Kombinationsfelds an. Wenn Sie eine Spalte einfügen, aber nicht in der Liste anzeigen möchten, stellen Sie die Eigenschaft Spaltenbreiten ein. Dies ist z.B. der Fall, wenn Ihre Liste Werte aus einer Tabelle oder Abfrage abruft. Sie können dann z.B. eine Personalnummer einfügen lassen, aber in der Liste ausblenden. In einem Kombinationsfeld wird die erste sichtbare Spalte der Liste im Textfeld angezeigt.
Spaltenbreiten | Gibt die Breite der einzelnen Spalten an, getrennt durch Semikolon. Geben Sie 0 ein, um eine Spalte auszublenden. Geben Sie ein Semikolon ohne Maßangabe für den Standardwert ein (2,5 cm bzw. 1 Zoll, abhängig von der in der Windows-Systemsteuerung festgelegten Maßeinheit). In einem Kombinationsfeld wird die erste sichtbare Spalte im Textfeldbereich des Steuerelements angezeigt. Alle Werte, die Sie in das Kombinationsfeld eingeben, müssen über denselben oder einen kompatiblen Datentyp verfügen, wie die erste sichtbare Spalte.
Spaltenüberschriften | Legt fest, ob in einem Listen- oder Kombinationsfeld die Feldnamen der zugrunde liegenden Datensatzquelle als Spaltenüberschriften verwendet werden. In Kombinationsfeldern werden die Überschriften nur angezeigt, wenn die Liste geöffnet ist.
Listenbreite | Gibt die Breite der Liste eines Kombinationsfelds an.
Zeilenanzahl | Gibt die maximale Anzahl der Zeilen an, die in der Liste des Kombinationsfelds angezeigt werden.
NurListeneinträge | Legt fest, ob ein Kombinationsfeld jeden eingegebenen Text akzeptiert oder nur solchen, der mit einem der Listeneinträge übereinstimmt. Wenn Sie zulassen möchten, dass ein eingegebener neuer Wert der Liste hinzugefügt wird, setzen Sie diese Eigenschaft auf Nein und ordnen der Eigenschaft BeiNichtInListe eine Ereignisprozedur zu.
BeiNichtInListe | Führt die zugeordnete Ereignisprozedur aus, wenn das Ereignis NichtInListe eintritt. Mit dieser Eigenschaft können Sie einer Liste automatisch einen neuen Wert hinzufügen. Diese Eigenschaft ist nicht auf der Registerkarte Nachschlagen in der Tabellenentwurfsansicht verfügbar.
AutomatischErgänzen | Gibt an, ob Microsoft Access automatisch einen Wert ergänzt, wenn dessen Zeichen mit den von Ihnen in ein Kombinationsfeld eingegebenen Zeichen übereinstimmt. Diese Eigenschaft ist nicht auf der Registerkarte Nachschlagen in der Tabellenentwurfsansicht verfügbar.
SteuerelementAnzeigen | Gibt den Steuerelementtyp (Kombinations- oder Listenfeld) an, den Microsoft Access standardmäßig erstellt, wenn Sie einem Formular ein Nachschlagefeld hinzufügen. Diese Eigenschaft ist nur auf der Registerkarte Nachschlagen in der Tabellenentwurfsansicht verfügbar.


 Eigenschaften, die Sie zum Erstellen eines mehrspaltigen Listen- oder Kombinationsfelds in einem Formular verwenden können

Eigenschaften, die Sie zum Erstellen eines mehrspaltigen Listen- oder Kombinationsfelds in einem Formular verwenden können

Zum Erstellen eines mehrspaltigen Listen- oder Kombinationsfelds können Sie einen Assistenten verwenden. Dabei können Sie die Spalten des Listen- oder Kombinationsfelds durch Ziehen Ihren Bedürfnissen anpassen. Wenn Sie jedoch ein Listen- oder Kombinationsfeld, das Sie bereits mit einem Assistenten erstellt haben, anpassen oder ein mehrspaltiges Listen- oder Kombinationsfeld selbst erstellen möchten, können Sie die folgenden Eigenschaften einstellen. Zum Anzeigen weiterer Informationen zu einer dieser Eigenschaften klicken Sie im Eigenschaftenfenster auf die entsprechende Eigenschaft, und drücken Sie dann F1.

Anmerkung Wenn Sie das gebundene Listen- oder Kombinationsfeld in mehr als einem Formular verwenden wollen, können Sie diese Eigenschaften statt über das Eigenschaftenfenster des Steuerelements auch in der Tabellenentwurfsansicht einstellen. Somit brauchen Sie die Eigenschaften nur einmal anzugeben. Wenn Sie das Feld einem Formular hinzufügen, erstellt Microsoft Access das Steuerelement automatisch auf der Grundlage der angegebenen Eigenschaften.

Eigenschaft | Beschreibung
GebundeneSpalte | Gibt an, welche Spalte an das zugrunde liegende Feld, das für die Eigenschaft Steuerelementinhalt angegeben ist, gebunden ist. Die Daten dieser Spalte werden im Feld gespeichert, wenn Sie dieses Listenelement auswählen. Diese Daten unterscheiden sich unter Umständen von den in der Liste angezeigten Daten, wenn Sie die Spalte ausblenden.
Spaltenanzahl | Gibt die Anzahl der Spalten an. Wenn Sie eine Spalte einfügen, aber nicht in der Liste anzeigen möchten, stellen Sie die Eigenschaft Spaltenbreiten ein. Dies ist beispielsweise der Fall, wenn Ihre Liste Werte aus einer Tabelle oder Abfrage abruft. Sie können dann beispielsweise eine Personalnummer einfügen lassen, aber in der Liste ausblenden. In einem Kombinationsfeld wird die erste sichtbare Spalte der Liste im Textfeld angezeigt.
Spaltenbreiten | Gibt die Breite der einzelnen Spalten an, getrennt durch Semikolon. Geben Sie 0 ein, um eine Spalte auszublenden. Geben Sie ein Semikolon ohne Maßangabe für den Standardwert ein (2,5 cm bzw. 1 Zoll, abhängig von der in der Windows-Systemsteuerung festgelegten Maßeinheit).
Spaltenüberschriften | Legt fest, ob im Listen- oder Kombinationsfeld Spaltenüberschriften angezeigt werden. Wenn dem Kombinations- oder Listenfeld eine Datenherkunft zugrunde liegt, verwendet Microsoft Access die Feld- oder Spaltennamen aus der Datenherkunft als Spaltenüberschriften. Wenn das Kombinations- oder Listenfeld auf einer festen Wertliste basiert, verwendet Microsoft Access die ersten x Datenelemente aus der Wertliste (Eigenschaft Datensatzherkunft) als Spaltenüberschriften, wobei x die für die Eigenschaft Spaltenanzahl festgelegte Zahl darstellt. In Kombinationsfeldern werden die Überschriften nur bei geöffneter Liste angezeigt.

Anmerkung Wenn Sie in einem mehrspaltigen Listenfeld alle Spalten anzeigen möchten (statt einen horizontalen Bildlauf durchzuführen, um alle Spalten sehen zu können), passen Sie die Größe des Steuerelements den Spaltenbreiten an.


 Eigenschaften, die Sie zum Erstellen oder Ändern eines Listenfeldes oder einer Dropdownliste auf einer Datenzugriffsseite verwenden können

Eigenschaften, die Sie zum Erstellen oder Ändern eines Listenfeldes oder einer Dropdownliste auf einer Datenzugriffsseite verwenden können

Wenn Sie einen Assistenten zum Erstellen eines Listenfeldes oder einer Dropdownliste auf einer Datenzugriffsseite verwenden, legt Microsoft Access bestimmte Eigenschaften für das Steuerelement fest. Sie können direkt mit diesen Eigenschaften arbeiten, wenn Sie keinen Assistenten zum Erstellen des Steuerelements verwenden möchten, oder Sie können das Steuerelement mit einem Assistenten erstellen und dann diese Eigenschaften ändern, damit das Steuerelement nach Ihren Wünschen arbeitet. Weitere Informationen zu den folgenden Eigenschaften erhalten Sie, indem Sie im Eigenschaftenfenster auf die Eigenschaft klicken und F1 drücken.

Eigenschaft | Beschreibung
ListRowSource | Der Name einer Datensatzgruppe in der Datenquelle, die die Werte und den Text für das Listenfeld oder das Dropdownlistenfeld enthält.
ListBoundField | Gibt in einem gebundenen Listenfeld oder einem gebundenen Dropdownlistenfeld an, welches Feld an die in der ListRowSource-Eigenschaft angegebene zugrunde liegende Datenquelle gebunden ist. Daten in dieser Spalte werden in dem Feld gespeichert, wenn Sie das entsprechende Element in der Liste auswählen.
ListDisplayField | Gibt in einem gebundenen Listenfeld oder einem gebundenen Dropdownlistenfeld den Namen eines Feldes in der ListRowSource an, das die Anzeigewerte enthält, die den ListBoundField-Werten entsprechen.


 Was ist eine Befehlsschaltfläche?

Was ist eine Befehlsschaltfläche?

Verwenden Sie eine Befehlsschaltfläche in einem Formular oder einer Datenzugriffsseite, um eine einzelne Aktion oder eine Gruppe von Aktionen auszuführen. Sie können mit einer Befehlsschaltfläche z. B. ein anderes Formular öffnen. Damit eine Befehlsschaltfläche in einem Formular eine Aktion ausführt, müssen Sie ein Makro oder eine Ereignisprozedur erstellen und diese dann der BeimKlicken-Schaltflächeneigenschaft zuordnen. Auf einer Datenzugriffsseite können Sie einer Befehlsschaltfläche Code zuordnen, der in JScript oder Microsoft Visual Basic Scripting Edition (VBScript) geschrieben wurde, indem Sie den Microsoft Skript-Editor verwenden. Erstellen einer Ereignisprozedur für eine Befehlsschaltfläche auf einer Datenzugriffsseite.

Anmerkung Mit dem Befehlsschaltflächen-Assistenten können Sie über 30 verschiedene Befehlsschaltflächenarten erstellen. Microsoft Access erstellt dann sowohl die Schaltfläche als auch die Ereignisprozedur für Sie. Assistenten stehen in Einzeldatenzugriffsseiten oder dann, wenn eine Datenzugriffsseite auf eine andere Datenbank als die gerade geöffnete zeigt, nicht zur Verfügung. Der Befehlsschaltflächenassistent steht ebenfalls nicht zur Verfügung, wenn die Seite nicht an eine Tabelle oder Abfrage gebunden ist.

Befehlsschaltfläche für das Ausführen einer Ereignisprozedur

Sie können auf einer Befehlsschaltfläche in einem Formular einen Text anzeigen, indem Sie die Beschriftung-Eigenschaft festlegen, und ein Bild auf einer Befehlsschaltfläche anzeigen, indem Sie die Bild-Eigenschaft festlegen. Auf einer Datenzugriffsseite können Sie einen Text auf einer Befehlsschaltfläche anzeigen, indem Sie die Wert-Eigenschaft verwenden.


 Erstellen einer Befehlsschaltfläche

Erstellen einer Befehlsschaltfläche

Sie können eine Befehlsschaltfläche entweder selbst erstellen oder von Microsoft Access mit Hilfe eines Assistenten erstellen lassen. Das Verwenden eines Assistenten erleichtert das Erstellen einer Befehlsschaltfläche wesentlich, da er die grundlegenden Arbeiten für Sie übernimmt. Dabei werden Sie nach bestimmten Informationen gefragt, und daraufhin erstellt Access die Befehlsschaltfläche auf der Grundlage Ihrer Antworten.

Mit dem Befehlsschaltflächen-Assistenten können Sie über 30 verschiedene Befehlsschaltflächenarten erstellen. Sie können beispielsweise eine Befehlsschaltfläche erstellen, die einen Datensatz sucht oder druckt oder einen Formularfilter anwendet.

Es ist auch sinnvoll, den Befehlsschaltflächen-Assistenten zu verwenden, wenn Sie sich mit dem Erstellen von Ereignisprozeduren vertraut machen möchten. Wenn Access in einem Formular oder Bericht eine Befehlsschaltfläche mit einem Assistenten erstellt, wird eine Ereignisprozedur erzeugt und der Schaltfläche zugeordnet. Sie können die Ereignisprozedur öffnen, um sich anzusehen, wie sie funktioniert, und dann Ihren Wünschen entsprechend verändern. Wenn Sie dagegen eine Befehlsschaltfläche in einer Datenzugriffsseite mit einem Assistenten erstellen, erstellt Access keine Ereignisprozeduren. Informationen über das Erstellen von Ereignisprozeduren für eine Befehlsschaltfläche in einer Datenzugriffsseite.

Anmerkung In eigenständigen Datenzugriffsseiten, oder wenn Sie eine Datenzugriffsseite auf eine andere Datenbank als die zu diesem Zeitpunkt geöffnete verweisen, sind Assistenten nicht verfügbar. Der Befehlsschaltflächen-Assistent ist ebenfalls nicht verfügbar, wenn eine Datenzugriffsseite nicht an eine Tabelle oder Abfrage gebunden ist. Wenn keine Assistenten zur Verfügung stehen, müssen Sie Befehlsschaltflächen selbst erstellen.

Was möchten Sie tun?

Eine Befehlsschaltfläche unter Verwendung eines Assistenten erstellen.

Eine Befehlsschaltfläche ohne Verwendung eines Assistenten erstellen.


 Definieren einer Befehlsschaltfläche in einem Formular als Abbrechen-Schaltfläche

Definieren einer Befehlsschaltfläche in einem Formular als Abbrechen-Schaltfläche

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie auf die Befehlsschaltfläche und dann auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Befehlsschaltfläche zu öffnen.

  3. Klicken Sie im Eigenschaftenfeld Abbrechen auf Ja.

Wenn die Eigenschaft Abbrechen einer Befehlsschaltfläche auf Ja eingestellt ist, und das Formular aktiv ist, können Sie die Befehlsschaltfläche, wenn sie den Fokus besitzt, durch Klicken darauf oder durch Drücken der ESC-TASTE bzw. der EINGABETASTE wählen. Wenn die Eigenschaft Abbrechen für eine Befehlsschaltfläche auf Ja eingestellt ist, ist sie automatisch für alle anderen Befehlsschaltflächen des Formulars auf Nein festgelegt. In einem Formular kann immer nur eine Befehlsschaltfläche als Standardschaltfläche definiert sein.

Damit eine Schaltfläche zum Abbrechen alle in einem Formular oder Dialogfeld durchgeführten Aktionen abbricht, müssen Sie ein Makro oder eine Ereignisprozedur erstellen und dann der Eigenschaft Beim Klicken der Schaltfläche zuweisen.

Tipp In einem Formular, das unwiderrufliche Operationen erlaubt, wie z. B. Löschvorgänge, ist es sinnvoll, die Schaltfläche zum Abbrechen als Standardbefehlsschaltfläche zu definieren. Stellen Sie hierfür sowohl die Eigenschaft BeiTasteESC als auch die Eigenschaft BeiEingabetaste auf Ja ein.


 Definieren einer Befehlsschaltfläche als Standardschaltfläche in einem Formular oder in einem benutzerdefinierten Dialogfeld

Definieren einer Befehlsschaltfläche als Standardschaltfläche in einem Formular oder in einem benutzerdefinierten Dialogfeld

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie auf die Befehlsschaltfläche und dann auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Befehlsschaltfläche zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Standard auf Ja.

Wenn die Eigenschaft Standard einer Befehlsschaltfläche auf Ja eingestellt ist, und das Formular aktiv ist, können Sie die Befehlsschaltfläche durch Klicken darauf oder durch Drücken der EINGABETASTE wählen, wenn kein anderes Steuerelement den Fokus besitzt. Wenn die Eigenschaft Standard für eine Befehlsschaltfläche auf Ja eingestellt ist, ist sie automatisch für alle anderen Befehlsschaltflächen des Formulars auf Nein gesetzt. In einem Formular kann immer nur eine Befehlsschaltfläche als Standardschaltfläche definiert sein.

Tipp In einem Formular, das unwiderrufliche Operationen erlaubt, z. B. Löschvorgänge, ist es sinnvoll, die Schaltfläche zum Abbrechen als Standardbefehlsschaltfläche zu definieren. Stellen Sie hierfür sowohl die Eigenschaft Abbrechen als auch die Eigenschaft Standard auf Ja ein.


 Ausblenden einer Befehlsschaltfläche in einem Formular

Ausblenden einer Befehlsschaltfläche in einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie auf die Befehlsschaltfläche und dann auf der Symbolleiste auf Eigenschaften [image] , um deren Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Transparent auf Ja.

    Die Befehlsschaltfläche wird ausgeblendet, bleibt aber aktiv.

Tipp Um eine Schaltfläche auszublenden und gleichzeitig zu deaktivieren, müssen Sie die Eigenschaft Sichtbar auf Nein einstellen. Um eine Schaltfläche zu deaktivieren, ohne sie auszublenden, setzen Sie die Eigenschaft Aktiviert auf Nein. Wenn Sie eine Schaltfläche nur beim Drucken eines Formulars ausblenden möchten, stellen Sie die Eigenschaft Anzeigen auf Nur am Bildschirm ein.


 Ausblenden einer Befehlsschaltfläche auf einer Datenzugriffsseite

Ausblenden einer Befehlsschaltfläche auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf die Befehlsschaltfläche und dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Schaltfläche zu öffnen.

  3. Legen Sie für die Visible-Eigenschaft die Einstellung Hidden fest.

Tipp Zum Deaktivieren einer Schaltfläche, ohne diese auszublenden, legen Sie für die Disabled-Eigenschaft die Einstellung True fest.


 Hinzufügen eines Bildes zu einer Befehlsschaltfläche oder einer Umschaltfläche in einem Formular

Hinzufügen eines Bildes zu einer Befehlsschaltfläche oder einer Umschaltfläche in einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie auf die Befehlsschaltfläche oder Umschaltfläche und dann auf der Symbolleiste auf Eigenschaften [image] , um deren Eigenschaftenfenster zu öffnen.

  3. Geben Sie in das Einstellungsfeld der Eigenschaft Bild den Pfad und Dateinamen einer Datei mit der Erweiterung .BMP, .ICO oder .DIB ein. Wenn Sie den Pfad oder Dateinamen nicht genau kennen, klicken Sie auf die Generator-Schaltfläche [image] , um den Bild-Generator zu öffnen.

Tipp Wenn Sie auf einer Befehlsschaltfläche sowohl ein Bild als auch Text anzeigen möchten, können Sie beides zusammen in Microsoft Windows Paint erstellen. Um ein Bild in der Größe Ihrer Schaltfläche mit Hilfe von Paint zu erstellen, zeichnen Sie das Bild auf einem Hintergrund beliebiger Größe und wählen dann einen Ausschnitt aus, der auf Ihre Schaltfläche passt. Klicken Sie im Menü Bearbeiten auf Kopieren nach, und geben Sie im Dialogfeld Speichern unter einen Dateinamen an. Daraufhin wird eine Datei mit einem Bild erstellt, das der ausgewählten Größe genau entspricht.


 Anzeigen einer vom Befehlsschaltflächen-Assistenten erstellten Ereignisprozedur

Anzeigen einer vom Befehlsschaltflächen-Assistenten erstellten Ereignisprozedur

Im Folgenden wird beschrieben, wie Sie eine vom Befehlsschaltflächen-Assistenten für ein Formular erstellte Ereignisprozedur anzeigen können. In einer Datenzugriffsseite müssen Sie die Ereignisprozedur selbst erstellen.

  1. Klicken Sie in der Entwurfsansicht für Formulare mit der rechten Maustaste auf die vom Befehlsschaltflächen-Assistenten erstellte Befehlsschaltfläche.

  2. Klicken Sie im Kontextmenü auf Ereignis.


 Erstellen einer Ereignisprozedur für eine Befehlsschaltfläche einer Datenzugriffsseite

Erstellen einer Ereignisprozedur für eine Befehlsschaltfläche einer Datenzugriffsseite

  1. Klicken Sie in der Entwurfsansicht der Datenzugriffsseite mit der rechten Maustaste auf die Befehlschaltfläche.

  2. Klicken Sie im Kontextmenü auf Microsoft Skript-Editor.

  3. Doppelklicken Sie im Fenster Skriptgliederung auf die Befehlsschaltfläche.

  4. Doppelklicken Sie auf das BeimKlicken-Ereignis.


 Erstellen einer Befehlsschaltfläche, die einen Datensatz sucht

Erstellen einer Befehlsschaltfläche, die einen Datensatz sucht

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular oder auf der Datenzugriffsseite auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Datensatznavigation und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Anmerkungen

  • Wenn Sie sich in einem Formular die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] . In Datenzugriffsseiten können Sie mit Hilfe des Microsoft Skript-Editors einer Befehlsschaltfläche in JScript oder in Microsoft Visual Basic Scripting Edition (VBScript) geschriebenen Code zuordnen. Weitere Informationen über das Erstellen von Ereignisprozeduren für Befehlsschaltflächen auf Datenzugriffsseiten.

  • Assistenten sind nicht verfügbar, wenn Sie mit einer eigenständigen Datenzugriffsseite arbeiten, oder wenn Sie eine Datenzugriffsseite auf eine andere Datenbank als die aktuell geöffnete verweisen. Der Befehlsschaltflächen-Assistent ist ebenfalls nicht verfügbar, wenn die Seite nicht an eine Tabelle oder Abfrage gebunden ist.


 Erstellen einer Befehlsschaltfläche, die einen Filter in einem Formular bearbeitet oder anwendet

Erstellen einer Befehlsschaltfläche, die einen Filter in einem Formular bearbeitet oder anwendet

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Formularoperationen und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der Eigenschaft BeimKlicken der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche zum Öffnen, Synchronisieren, Schließen oder Drucken eines Formulars

Erstellen einer Befehlsschaltfläche zum Öffnen, Synchronisieren, Schließen oder Drucken eines Formulars

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , wenn der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Formularoperationen und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche, die Formulardaten aktualisiert

Erstellen einer Befehlsschaltfläche, die Formulardaten aktualisiert

Wenn Sie mit einer Datenbank arbeiten, die auf einem Netzwerk gemeinsam genutzt wird, können Sie die aktuellste Version bestehender Datensätze anzeigen, indem Sie eine Befehlsschaltfläche zum Aktualisieren von Formulardaten erstellen. Wenn Sie alle aktualisierten Datensätze, einschließlich der neuen Datensätze, anzeigen möchten, können Sie für die Datensätze die entsprechende Abfrage erneut durchführen. Um weitere Informationen zum Durchführen einer Abfrage für Datensätze zu erhalten, klicken Sie auf [image] .

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Formularoperationen und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche, die einen Bericht druckt oder als E-Mail verschickt

Erstellen einer Befehlsschaltfläche, die einen Bericht druckt oder als E-Mail verschickt

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Berichtsoperationen und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der Eigenschaft BeimKlicken der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche in einem Formular, die eine Tabelle druckt

Erstellen einer Befehlsschaltfläche in einem Formular, die eine Tabelle druckt

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Verschiedenes und dann im Listenfeld Aktionen auf Tabelle drucken.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche in einem Formular, die eine Anwendung ausführt oder beendet

Erstellen einer Befehlsschaltfläche in einem Formular, die eine Anwendung ausführt oder beendet

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Anwendungen und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche in einem Formular, die eine Abfrage oder ein Makro ausführt

Erstellen einer Befehlsschaltfläche in einem Formular, die eine Abfrage oder ein Makro ausführt

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Verschiedenes und dann im Listenfeld Aktionen auf den Schaltflächentyp, den Sie erstellen möchten.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


 Erstellen einer Befehlsschaltfläche in einem Formular, die eine Telefonnummer wählt

Erstellen einer Befehlsschaltfläche in einem Formular, die eine Telefonnummer wählt

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Verschiedenes und dann im Listenfeld Aktionen auf Autowähler.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur anschauen möchten, welche der Schaltfläche zugrunde liegt, klicken Sie im Einstellungsfeld der BeimKlicken-Eigenschaft der Befehlsschaltfläche auf die Generator-Schaltfläche [image] .


Was ist ein Registersteuerelement?

Sie können ein Registersteuerelement verwenden, um mehrere Seiten mit Informationen als Einheit zur Verfügung zu stellen. Dies ist besonders dann sinnvoll, wenn Sie mit einer größeren Anzahl von Steuerelementen arbeiten, die sich in zwei oder mehr Kategorien einteilen lassen. So können Sie ein Registersteuerelement z.B. in einem Personal-Formular verwenden, um allgemeine von persönlichen Daten zu trennen.

Registersteuerelement mit zwei Registerkarten

Um Informationen zum Erstellen eines Registersteuerelements anzuzeigen, klicken Sie auf [image] .


Erstellen eines Formulars mit mehreren Seiten oder Registerkarten

Was möchten Sie tun?

Ein Registersteuerelement verwenden, um ein Formular mit mehreren Seiten zu erstellen

Ein Seitenwechsel-Steuerelement verwenden, um ein Formular mit mehreren Seiten zu erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Hinzufügen eines Registersteuerelements zu einem Formular zum Erstellen eines mehrseitigen Formulars

Hinzufügen eines Registersteuerelements zu einem Formular zum Erstellen eines mehrseitigen Formulars

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool Registersteuerelement [image] , und klicken Sie dann im Formular auf die Stelle, an der Sie das Steuerelement einfügen möchten.

    Microsoft Access fügt ein Registersteuerelement mit zwei Seiten ein, wobei die erste Seite im Vordergrund angezeigt wird.

  3. Um dem Registersteuerelement wiederum Steuerelemente hinzuzufügen, klicken Sie auf die Registerkarte der Seite, der Sie Steuerelemente hinzufügen möchten. Wenden Sie dann eine der folgenden Vorgehensweisen an, um Steuerelemente hinzuzufügen:
    • Klicken Sie in der Symbolleiste auf Feldliste [image] , um die Feldliste anzuzeigen, und ziehen Sie anschließend ein oder mehrere Felder von dort auf die Seite mit der Registerkarte.

    • Klicken Sie auf ein Tool in der Toolbox, und klicken Sie dann auf die Seite mit der Registerkarte. Sie können jedes beliebige Steuerelement hinzufügen, mit Ausnahme eines weiteren Registersteuerelements.

    • Kopieren Sie Steuerelemente aus einem anderen Bereich der Seite oder von einer anderen Seite an die gewünschte Stelle. (Sie können die Steuerelemente jedoch nicht dorthin ziehen.)
  4. Wenden Sie die folgenden Vorgehensweisen für Aufgaben an, die Sie möglicherweise auch durchführen möchten:
    • Um die Beschriftung auf einer Registerkarte zu ändern, doppelklicken Sie auf die Registerkarte, um deren Eigenschaftenfenster zu öffnen. Geben Sie dann im Einstellungsfeld der Eigenschaft Beschriftung die neue Beschriftung ein. Wenn Sie für die Eigenschaft Beschriftung keine Beschriftung angeben, verwendet Microsoft Access die Einstellung der Eigenschaft Name.

    • Um Registerkarten hinzuzufügen, zu löschen oder deren Reihenfolge zu ändern, klicken Sie mit der rechten Maustaste auf den Rahmen des Registersteuerelements, und klicken Sie dann auf Seite einfügen, Seite löschen oder Reihenfolge der Seiten.

    • Um die Reihenfolge der Steuerelemente einer Seite zu ändern, klicken Sie mit der rechten Maustaste auf die entsprechende Seite, und klicken Sie dann auf Reihenfolge der Steuerelemente.

    • Um Schriftart, Schriftgrad, Schriftschnitt usw. für die Beschriftungen auf Registerkarten zu ändern, doppelklicken Sie auf den Rahmen des Registersteuerelements, um dessen Eigenschaftenfenster zu öffnen. Stellen Sie dort die entsprechenden Eigenschaften ein. Sie können für die einzelnen Registerkarten keine unterschiedlichen Einstellungen festlegen.
  5. Passen Sie die Größe des Registersteuerelements an. Klicken Sie auf die einzelnen Registerkarten, um sicherzustellen, dass deren Größe für die jeweiligen Steuerelemente ausreichend ist.

    Anmerkung Microsoft Access kürzt die Steuerelemente nicht, wenn Sie die Größe des Registersteuerelements anpassen. Um das Registersteuerelement zu verkleinern, verschieben Sie ggf. die Steuerelemente.

  6. Wechseln Sie zur Formularansicht, um das Steuerelement zu testen.

Anmerkungen

  • Zum Anzeigen weiterer Informationen zu anderen Eigenschaften, die Sie für ein Registersteuerelement einstellen können, klicken Sie auf [image] .

  • Ein Beispiel für ein Registersteuerelement finden Sie im Formular Personal der Datenbank Nordwind. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Eigenschaften zum Anpassen eines Registersteuerelements

Eigenschaften zum Anpassen eines Registersteuerelements

Mit Hilfe der folgenden Eigenschaften können Sie das Erscheinungsbild eines Registersteuerelements Ihren Wünschen entsprechend anpassen.

Eigenschaft | Beschreibung | Einstellung
Beschriftung | Gibt den Text an, der auf einer Registerkarte angezeigt wird. Wenn Sie diese Eigenschaft nicht einstellen, verwendet Microsoft Access die Einstellung der Eigenschaft Name. | Im Eigenschaftenfenster der Seite eines Registersteuerelements
MehrereZeilen | Gibt an, ob sich die Registerkarten eines Registersteuerelements über mehrere Zeilen erstrecken können. Ist diese Eigenschaft auf Nein eingestellt, schneidet Microsoft Access die Registerkarten ab, wenn sie die Breite des Registersteuerelements überschreiten, und fügt eine Bildlaufleiste hinzu. | Im Eigenschaftenfenster des Registersteuerelements
Formatvorlage | Gibt an, was am oberen Rand des Registersteuerelements angezeigt werden soll. Sie können Registerkarten oder Befehlsschaltflächen anzeigen. Sie können aber auch die Anzeige weglassen, wenn Sie z.B. eine Befehlsschaltfläche im Formular außerhalb des Registersteuerelements verwenden, um festzulegen, welche Seite den Fokus besitzt. Zum Anzeigen weiterer Informationen zur Eigenschaft Formatvorlage klicken Sie auf [image] . | Im Eigenschaftenfenster des Registersteuerelements
RegisterFesteHöhe | Gibt die Höhe von Registerkarten an, und zwar in der Maßeinheit, die in der Windows-Systemsteuerung festgelegt ist. Ist der Wert hierfür "0", ist die Höhe der einzelnen Registerkarten für deren Inhalt ausreichend. | Im Eigenschaftenfenster des Registersteuerelements
RegisterFesteBreite | Gibt die Breite von Registerkarten an, und zwar in der Maßeinheit, die in der Windows-Systemsteuerung festgelegt ist. Ist der Wert hierfür "0", ist die Breite der einzelnen Registerkarten für deren Inhalt ausreichend und bei mehreren Registerkarten-Zeilen wird die Registerkartenbreite so weit vergrößert, dass sich die einzelnen Zeilen über die gesamte Breite des Registersteuerelements erstrecken. Ist der Wert größer als "0", besitzen alle Registerkarten dieselbe Breite, nämlich die in dieser Eigenschaft angegebene. | Im Eigenschaftenfenster des Registersteuerelements
Bild | Wird verwendet, um einer Registerkarte eine Grafik hinzuzufügen. (Registersteuerelemente können Bitmaps, jedoch keine Windows Metadateien enthalten.) Die Grafik wird links vom Text, der durch die Eigenschaft Beschriftung festgelegt wird, angezeigt. Wenn Sie nur ein Bild, ohne einen Text, anzeigen möchten, geben Sie für die Eigenschaft Beschriftung ein Leerzeichen an, indem Sie die LEERTASTE drücken. | Im Eigenschaftenfenster der Seite eines Registersteuerelements

Anmerkungen

  • Um das Eigenschaftenfenster eines Registersteuerelements anzuzeigen, doppelklicken Sie auf dessen Rand. Um das Eigenschaftenfenster einer Seite in einem Registersteuerelement anzuzeigen, doppelklicken Sie auf die Registerkarte für die Seite.

  • Wenn Sie ein Registersteuerelement voraussichtlich in einem benutzerdefinierten Dialogfeld verwenden, können Sie zusätzliche Eigenschaften einstellen. Zum Anzeigen von Informationen zu Eigenschaften, die Sie für ein benutzerdefiniertes Dialogfeld einstellen können, klicken Sie auf [image] .


 Was ist eine Umschaltfläche in Formularen und Berichten?

Was ist eine Umschaltfläche in Formularen und Berichten?

Sie können eine Umschaltfläche in einem Formular als eigenständiges Steuerelement verwenden, um einen Ja/Nein-Wert aus einer zugrunde liegenden Datenherkunft anzuzeigen. Die Umschaltfläche in der folgenden Abbildung ist beispielsweise an das Feld Auslaufartikel der Tabelle Artikel einer Datenbank gebunden. Der Datentyp dieses Feldes ist Ja/Nein. Wenn die Umschaltfläche gedrückt ist, ist der Wert in der Tabelle Ja. Ist die Umschaltfläche nicht gedrückt, ist der Wert Nein.

Die Umschaltfläche gibt die Bedingungen Ja/Nein, Wahr/Falsch oder Ein/Aus zurück

Wenn Sie auf eine Umschaltfläche klicken, die an ein Ja/Nein-Feld in einer Microsoft Access-Datenbank gebunden ist, wird der Wert in der zugrunde liegenden Tabelle entsprechend der Format-Feldeigenschaft (Ja/Nein, Wahr/Falsch oder Ein/Aus) angezeigt. In einem Microsoft Microsoft Access-Projekt ist das Optionsfeld an eine als Bit-Datentyp definierte Spalte gebunden. Wenn der Wert in dieser Spalte 1 beträgt, entspricht dies den Bedingungen Ja, Ein oder Wahr. Ist der Wert 0, gibt die Spalte die Bedingungen Nein, aus bzw. Falsch an.

Die Verwendung von Umschaltflächen ist am effektivsten in einer Optionsgruppe zusammen mit anderen Umschaltflächen. Dort können Sie leicht erkennen, ob eine Schaltfläche gedrückt ist. Um weitere Informationen zu Optionsgruppen zu erhalten, klicken Sie auf [image] .

Anstelle von Text können Sie auch Bilder auf Umschaltflächen anzeigen. Sie könnten beispielsweise an Stelle des Wortes Auslaufartikel auf der Umschaltfläche des ersten Beispiels auch ein Bild mit einem Papierkorb anzeigen.

Beispiele für Umschaltflächen in gedrücktem und nicht gedrücktem Zustand

Sie können eine Umschaltfläche auch in einem benutzerdefinierten Dialogfeld zur Benutzereingabe verwenden.


 Was ist ein PivotTable-Formular?

Was ist ein PivotTable-Formular?

Ein PivotTable-Formular ist eine interaktive Tabelle, die von Ihnen ausgewählte Berechnungen ausführt, wie z. B. das Ermitteln einer Summe (die Standardberechnung für numerische Felder) oder einer Anzahl (die Standardberechnung für Textfelder), wobei es ausschlaggebend ist, wie die Daten im PivotTable-Formular angeordnet sind. Ein PivotTable-Formular kann Feldwerte z. B. horizontal oder vertikal anzeigen und dann die Summe der Zeile oder Spalte berechnen. Die Feldwerte können außerdem als Zeilen- oder Spaltenüberschriften verwendet werden, wobei an den Schnittpunkten der Zeilen und Spalten verschiedene Werte ermittelt und dann Gesamtsummen und Endsummen berechnet werden. Um z. B. für jeden Mitarbeiter die Umsätze nach der Artikelkategorie zu analysieren, können Sie die Mitarbeiternamen als Spaltenüberschriften am oberen Rand des PivotTable-Formulars angeben, die Artikelkategorien als Zeilenbeschriftungen am seitlichen Rand und die berechneten Umsätze nach der Artikelkategorie für die einzelnen Mitarbeiter an den Schnittpunkten der Zeilen und Spalten angeben.

Sie können die von dem PivotTable-Formular verwendeten Datensätze einschränken, indem Sie ein Feld als Seitenfeld kennzeichnen, welches dann zu einer Dropdownliste wird und wie ein Filter über dem PivotTable-Formular funktioniert. Der aus dieser Liste ausgewählte Wert legt fest, welche Datensätze im PivotTable-Formular angezeigt werden. So können Sie z. B. das Feld Ort der Tabelle Personal als Seitenfeld verwenden, um ausschließlich für die Verkaufsrepräsentanten in London die Umsätze nach Artikelkategorie anzuzeigen. Im Verkaufszahlenanalyseformular in der Datenbank Nordwind finden Sie ein Beispiel eines PivotTable-Formulars. Um dieses PivotTable-Formular anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE des Ordners OFFICE. Öffnen Sie anschließend das Verkaufszahlenanalyseformular in der Entwurfsansicht.

PivotTable-Formulare haben ihren Namen deshalb erhalten, weil sich ihr Layout dynamisch verändern lässt, um Daten auf verschiedene Art und Weise zu analysieren. Sie können die Zeilen- und Spaltenüberschriften sowie die Seitenfelder immer wieder neu anordnen, bis Sie das gewünschte Layout erhalten. Nach jeder Änderung des Layouts werden die Daten sofort vom PivotTable-Formular auf der Basis der geänderten Anordnung neu berechnet. Darüber hinaus können Sie das PivotTable-Formular aktualisieren, wenn sich die Herkunftsdaten ändern.

Sie können ein PivotTable-Formular in Microsoft Access erstellen, indem Sie den PivotTable-Assistenten verwenden. Der Assistent erstellt unter Verwendung von Microsoft Excel das PivotTable-Objekt und mit Hilfe von Microsoft Access ein Formular, in welches das PivotTable-Objekt eingebettet wird. Um Informationen zur Verwendung dieses Assistenten zu erhalten, klicken Sie auf [image] .

Wenn Sie ein PivotTable-Formular öffnen, zeigt dieses immer die Daten an, die beim letzten Aktivieren des PivotTable-Formulars aktuell waren. Um die aktuellsten Daten im PivotTable-Formular anzuzeigen, aktualisieren Sie die Daten. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Bearbeiten von PivotTable-Formularen

Bearbeiten von PivotTable-Formularen

Da ein PivotTable-Formular ein eingebettetes Microsoft Excel-Objekt ist, können Sie es nur ändern, indem Sie zum Microsoft Access-Formular wechseln, in dem das PivotTable-Objekt eingebettet ist, und dann Microsoft Excel starten und zum Bearbeiten der Daten verwenden.

  1. Öffnen Sie das PivotTable-Formular in der Formularansicht.

  2. Klicken Sie auf die Schaltfläche PivotTable-Objekt bearbeiten.

    Anmerkung Wenn Sie die direkte Bearbeitung verwenden möchten, statt das PivotTable-Formular in einem eigenen Microsoft Excel-Fenster zu bearbeiten, klicken Sie im Microsoft Access-Menü Bearbeiten auf Worksheet-Objekt und dann auf Bearbeiten.

  3. Klicken Sie im Microsoft Excel-Menü Daten auf Daten aktualisieren.

  4. Nehmen Sie die gewünschten Änderungen an dem PivotTable-Formular vor.

    Anmerkung Um Hilfe zu bestimmten Verfahren zu erhalten, wie Sie PivotTable-Formulare ändern oder verwenden können, verwenden Sie die Microsoft Excel-Hilfe.

  5. Wenn Sie die Bearbeitung des PivotTable-Formulars beendet haben, klicken Sie im Microsoft Excel-Menü Datei auf Beenden.

Anmerkungen

  • Falls Sie die gewünschten Antworten nicht in den Microsoft Excel-Hilfethemen finden, können Sie die Microsoft Access-Hilfe verwenden, wenn das PivotTable-Formular in Microsoft Access in der Formularansicht geöffnet ist. Wenn Sie die direkte Bearbeitung nutzen, klicken Sie zunächst auf eine Stelle im Access-Formular außerhalb des PivotTable-Objekts, um die Microsoft Access-Hilfe zu erhalten.

  • Die Quelldaten, die das PivotTable-Formular verwendet, werden nicht automatisch mit dem PivotTable-Formular gespeichert. Statt dessen aktualisieren Sie das PivotTable-Formular jedesmal, wenn Sie sie verwenden möchten, was bedeutet, dass Sie Zugriff auf die gespeicherten Daten benötigen. Wenn Sie wissen, dass die Bearbeitung des PivotTable-Formulars dann erforderlich ist, wenn Sie keinen Zugriff auf die Daten besitzen, speichern Sie eine Kopie der Daten zusammen mit dem PivotTable-Formular. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Aktualisieren der Daten eines PivotTable-Formulars

Aktualisieren der Daten eines PivotTable-Formulars

  1. Öffnen Sie das PivotTable-Formular in der Formularansicht.

  2. Klicken Sie auf die Schaltfläche PivotTable-Objekt bearbeiten.

  3. Klicken Sie im Microsoft Excel-Menü Daten auf Daten aktualisieren.


 Ein- oder Ausblenden von Textfeldern oder anderen Steuerelementen auf einer Datenzugriffsseite

Ein- oder Ausblenden von Textfeldern oder anderen Steuerelementen auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Steuerelement aus, das Sie ein- oder ausblenden möchten und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Damit das Steuerelement die Einstellung der Visibility-Eigenschaft des Bereichs erbt, indem es sich befindet, klicken Sie im Einstellungsfeld der Visibility-Eigenschaft auf inherit(erben).

    • Um das Steuerelement unsichtbar zu machen, klicken Sie im Einstellungsfeld der Visibility-Eigenschaft auf hidden.

    • Um das Steuerelement auf der Datenzugriffsseite anzuzeigen, klicken Sie im Einstellungsfeld der Visibility-Eigenschaft auf visible.

Anmerkung Wenn das Steuerelement über ein dazugehöriges Bezeichnungsfeld verfügt, muss dessen Sichtbarkeit getrennt vom Steuerelement eingestellt werden.


 Löschen eines Optionsfeldes oder eines anderen Steuerelements aus einer Optionsgruppe in einer Datenzugriffsseite

Löschen eines Optionsfeldes oder eines anderen Steuerelements aus einer Optionsgruppe in einer Datenzugriffsseite

Sie können ein oder mehrere Optionsfelder aus einem Optionsgruppen-Steuerelement in einer Datenzugriffsseite in der Entwurfsansicht löschen.

  • Klicken Sie auf das Steuerelement, das Sie löschen möchten, und drücken Sie dann die ENTF-TASTE.


 Deaktivieren eines Steuerelements oder Aktivieren von Schreibschutz für die Daten in einem Textfeld oder anderen Steuerelementen auf einer Datenzugriffsseite

Deaktivieren eines Steuerelements oder Aktivieren von Schreibschutz für die Daten in einem Textfeld oder anderen Steuerelementen auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Markieren Sie das Steuerelement, das Sie deaktivieren möchten, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um das dazugehörige Eigenschaftenfenster zu öffnen.

  3. Wenn Sie verhindern möchten, dass Benutzer die Daten ändern, legen Sie für die ReadOnly-Eigenschaft True fest.

Anmerkung Wenn Sie nicht möchten, dass ein Steuerelement in die Aktivierreihenfolge einbezogen wird, und wenn Sie in der Lage sein möchten, das Steuerelement auszuwählen, legen Sie für die TabIndex-Eigenschaft den Wert -1 fest.


 Hinzufügen eines Erweiterungs-Steuerelements zu einer Datenzugriffsseite

Hinzufügen eines Erweiterungs-Steuerelements zu einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf Erweitern [image] .

  3. Klicken Sie in den Gruppenkopf, dem das Erweiterungs-Steuerelement hinzugefügt werden soll.

  4. Geben Sie an, ob die Datensätze in der Gruppierungsebene unterhalb standardmäßig erweitert oder reduziert angezeigt werden sollen.


 Entfernen eines Erweiterungssteuerelements aus einer Datenzugriffsseite

Entfernen eines Erweiterungssteuerelements aus einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Erweiterungssteuerelement, das Sie löschen möchten, markiert ist.

  3. Drücken Sie ENTF.

Anmerkung Wenn Sie das Erweiterungssteuerelement für einen Gruppenkopf löschen, legt Microsoft Access automatisch für die ExpandedByDefault-Eigenschaft dieser Gruppe im Feld Sortieren und gruppieren die Einstellung Ja fest. Wenn für ExpandedByDefault für eine Gruppierungsebene Ja festgelegt ist, und wenn es sich dabei um die höchste Gruppierungsebene auf der Seite handelt, dann werden alle Datensätze der direkt darunter liegenden Gruppierungsebene angezeigt, wenn Sie die Seite in der Seitenansicht oder in Microsoft Internet Explorer anzeigen. Dadurch kann das Laden der Seite länger dauern. Wenn Sie für die ExpandedByDefault-Eigenschaft Nein festlegen, werden die Datensätze der direkt darunter liegenden Gruppierungsebene nicht angezeigt.


 Hinzufügen eines Datensatznavigationssteuerelements auf einer Datenzugriffsseite

Hinzufügen eines Datensatznavigationssteuerelements auf einer Datenzugriffsseite

Wenn Sie zu einer Gruppierungsebene einen Datensatznavigationsbereich hinzufügen, fügt Microsoft Access automatisch auch ein Datensatznavigationssteuerelement ein. Nutzen Sie diese Vorgehensweise bei Gruppierungsebenen, die über einen Datensatznavigationsbereich, aber nicht über ein Datensatznavigationssteuerelement verfügen.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf Datensatznavigation Datensatznavigationssteuerelement in der Toolbox.

  3. Klicken Sie auf den Datensatznavigationsbereich, in den das Datensatznavigationssteuerelement eingefügt werden soll.

  4. Geben Sie die Anzahl der Datensätze an, die für diese Gruppierungsebene angezeigt werden sollen, wenn Sie die Seite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer öffnen.

Anmerkung Sie können das Datensatznavigationssteuerelement mit Hilfe der Eigenschafteneinstellungen anpassen. Auf einer gruppierten Seite können Sie zum Beispiel die Schaltflächen für das Hinzufügen und Löschen von Datensätzen ausblenden.


 Anpassen eines Datensatznavigationssteuerelements auf einer Datenzugriffsseite

Anpassen eines Datensatznavigationssteuerelements auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Datensatznavigationssteuerelement markiert ist, und klicken Sie anschließend auf der Symbolleiste auf Eigenschaften [image] .

  3. Geben Sie Werte für die folgenden Eigenschaften ein, um sie zu ändern:
    • Ändern Sie bei der RecordsetLabel-Eigenschaften die Zeichenfolgen nach Bedarf. So könnte z. B. die RecordsetLabel-Eigenschaft für eine Produkt-Gruppierungsebene auf Produkte |0 von |2;Produkte |0-|1 von |2 eingestellt werden. Die erste Zeichenfolge (vor dem Semikolon (;)) stellt die Beschriftung dar, die angezeigt wird, wenn ein Datensatz auf der Seite in der Seitenansicht oder in Microsoft Internet Explorer angezeigt wird. Die zweite Zeichenfolge (nach dem Semikolon) stellt die Beschriftung dar, die angezeigt wird, wenn zwei oder mehr Datensätze auf der Seite angezeigt werden. |0 gibt die Nummer des aktuellen Datensatzes auf einer für die Dateneingabe verwendeten Seite oder die Nummer des ersten sichtbaren Datensatzes in der Gruppierung auf einer gruppierten Seite an; |1 gibt die Nummer des letzten sichtbaren Datensatzes in der Gruppierung auf einer gruppierten Seite an; und |2 gibt die Anzahl der Datensätze in der Datensatzgruppe an.

    • Geben Sie bei der Datenherkunft-Eigenschaft den Namen der Tabelle oder Abfrage für die Gruppierungsebene an.
  4. Legen Sie eine der folgenden Eigenschaften auf True fest, um eine Schaltfläche oder eine Beschriftung anzuzeigen, oder auf False, um eine Schaltfläche oder Beschriftung zu entfernen. In der Seitenansicht oder in Internet Explorer haben diese Schaltflächen folgende Funktionen:
    • ShowDelButton [image] Löscht einen Datensatz

    • ShowFilterBySelectionButton [image] Filtert die Datensätze heraus, die dem ausgewählten Feld entsprechen

    • ShowFirstButton [image] Bewegt sich zum ersten Datensatz

    • ShowHelpButton [image] Zeigt die Hilfe an

    • ShowLabel Zeigt die in der RecordsetLabel-Eigenschaft angegebenen Informationen an

    • ShowLastButton [image] Bewegt sich zum letzten Datensatz

    • ShowNewButton [image] Bewegt sich zu einem neuen Datensatz

    • ShowNextButton [image] Bewegt sich zum nächsten Datensatz

    • ShowPrevButton [image] Bewegt sich zum vorherigen Datensatz

    • ShowSaveButton [image] Speichert den aktuellen Datensatz

    • ShowSortAscendingButton [image] Sortiert Datensätze in aufsteigender Reihenfolge

    • ShowSortDescendingButton [image] Sortiert Datensätze in absteigender Reihenfolge

    • ShowToggleFilterButton Filter-Objekt Wendet einen Filter an oder entfernt ihn

    • ShowUndoButton [image] Macht Änderungen am letzten Datensatz rückgängig


 Entfernen eines Datensatznavigationssteuerelements aus einer Datenzugriffsseite

Entfernen eines Datensatznavigationssteuerelements aus einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Markieren Sie das Datensatznavigationssteuerelement, das Sie löschen möchten, indem Sie darauf klicken.

  3. Drücken Sie ENTF.

Anmerkungen

  • Wenn Sie ein Datensatznavigationssteuerelement gelöscht haben, sollten Sie auch den Datensatznavigationsbereich löschen.

  • Wenn Sie ein Steuerelement zur Datensatznavigation einer Gruppierungsebene oder einen Datensatznavigationsbereich löschen, ändert Microsoft Access automatisch die DataPageSize-Eigenschaft für die Gruppe in Alle. Wenn Sie das Steuerelement zur Datensatznavigation oder einen Datensatznavigationsbereich für die oberste Gruppierungsebene löschen, werden alle Datensätze in dieser Gruppierungsebene angezeigt, wenn Sie die Seite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer öffnen. Dadurch kann das Laden der Seite länger dauern.


 Was ist ein Lauftext-Steuerelement auf einer Datenzugriffsseite?

Was ist ein Lauftext-Steuerelement auf einer Datenzugriffsseite?

Mit einem Lauftext-Steuerelement, häufig auch als Marquee bezeichnet, können Sie auf einer Datenzugriffsseite Lauftext, d. h. durchlaufenden Text anzeigen. Lauftext zieht die Aufmerksamkeit auf eine bestimmte Textzeile, beispielsweise die Überschrift oder eine wichtige Ankündigung. Den Text, der in einem Feld Ihrer Datenbank enthalten ist, zeigen Sie an, indem Sie das Lauftext-Steuerelement an dieses Feld binden. Den Lauftext können Sie durch Optionen wie Laufrichtung, Geschwindigkeit und Bewegungsart individuell anpassen.

Um zu sehen, wie der Text sich innerhalb des Lauftext-Steuerelements bewegt, zeigen Sie ihn in der Datenzugriffsseitenansicht an.

Weitere Informationen

Arbeiten mit Lauftext


Mit Lauftext auf einer Datenzugriffsseite arbeiten

Was möchten Sie tun?

Ein gebundenes Lauftext-Steuerelement zur Anzeige von Daten erstellen

Ein ungebundenes Lauftext-Steuerelement erstellen

Die Bewegungsart von Lauftext ändern

Die Anzahl der Wiederholungen von Lauftext ändern

Das Tempo von Lauftext ändern

Die Richtung von Lauftext ändern

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Soll ein Bitmap, eine Metadatei oder eine andere Grafikdatei zum Anzeigen eines Bildes verwendet werden?

Soll ein Bitmap, eine Metadatei oder eine andere Grafikdatei zum Anzeigen eines Bildes verwendet werden?

Sie können Bitmap-Dateien (mit den Erweiterungen .bmp oder .dib), Metadateien (mit den Erweiterungen .wmf oder .emf) oder andere Grafikdateien, wie z. B. GIF- und JPEG-Dateien, verwenden, um Hintergrundbilder oder Bilder in gebundenen Objektfeldern, ungebundenen Objektfeldern oder Bild-Steuerelementen anzuzeigen.

Wann sollten Metadateien verwendet werden?

  • Wenn Sie die Größe Ihres Bildes anpassen möchten, ist es sinnvoll, eine Metadatei zu verwenden. Metadateien lassen sich besser skalieren als Bitmaps, weil sie aus Sammlungen von Linien und nicht aus Mustern einzelner Punkte bestehen.

  • Metadateien sind in der Regel viel kleiner als Bitmaps; wenn Sie also Speicherplatz einsparen möchten, verwenden Sie eine Metadatei.

Viele Grafikprogramme ermöglichen es Ihnen, Dateien als Metadateien zu speichern. Weitere Informationen finden Sie in der Dokumentation zu Ihrem Grafikprogramm. Beachten Sie, dass ein Bitmap, das Sie in ein Grafikprogramm einfügen und anschließend als Metadatei speichern, weiterhin ein Bitmap bleibt - es wird lediglich in die Metadatei eingebettet. Sie müssen die Grafik in dem Grafikprogramm erstellen und als Metadatei speichern.

Wann sollten Bitmaps verwendet werden?

  • Wenn Skalieren und Speicherplatz nicht wichtig sind, oder wenn Sie keinen Zugriff auf ein Tool besitzen, das Metadateien erstellt, verwenden Sie ein Bitmap.

  • Wenn Sie ein gekacheltes Hintergrundbild erstellen möchten, ist eine Bitmap die geeignete Lösung, weil sie nicht skaliert wird.

  • Wenn Sie in der Lage sein möchten, kleine Änderungen an dem Bild durchzuführen, verwenden Sie ein Bitmap. Bitmaps können Sie auf Pixelebene bearbeiten, so dass Sie sehr kleine Anpassungen an dem Bild vornehmen können.

Anmerkungen

  • Wenn Sie in Formularen oder Berichten die Größe des Bildes anpassen möchten, stellen Sie die Bildgrößenmodus-Eigenschaft (Hintergrundbilder) oder die Größenanpassung-Eigenschaft (gebundene oder ungebundene Objektfelder und Bild-Steuerelemente) auf Zoomen. Wenn Sie die Bildgrößenmodus-Eigenschaft bzw. die Größenanpassung-Eigenschaft auf Zoomen einstellen, behält Microsoft Access die Proportionen des Bildes bei, wenn Sie die Größe des Formulars oder Steuerelements verändern.

  • In einer Datenzugriffseite verwenden Sie die Höhe- und Breite-Eigenschaften zur Anpassung der Bildgröße. Geben Sie in den Feldern der Höhe- und Breite-Eigenschaften die Werte in Pixel (px), Punkt (pt), Zentimetern (cm) oder Zoll (in) ein. Wenn Sie beispielsweise 25px in das Eingabefeld der Höhe-Eigenschaft eingeben, hat das Bild eine Höhe von 25 Pixel.

  • Weitere Informationen über andere Grafikdateiformate, die Sie unter Microsoft Access verwenden können.


 Hinzufügen eines ungebundenen Bildes zu einem Formular, einem Bericht oder einer Datenzugriffsseite unter Verwendung eines Bild-Steuerelements

Hinzufügen eines ungebundenen Bildes zu einem Formular, einem Bericht oder einer Datenzugriffsseite unter Verwendung eines Bild-Steuerelements

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht, einen Bericht in der Berichtsentwurfsansicht oder eine Datenzugriffsseite in der Datenzugriffsseiten-Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Bild Bild-Steuerelement .

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der das Bild eingefügt werden soll.

  4. Klicken Sie im Dialogfeld Grafik einfügen auf den Dateinamen für das Bild, das Sie hinzufügen möchten. Möglicherweise benötigen Sie zum Angeben des Laufwerks und/oder des Ordners, in dem sich das Bild befindet, Informationen aus dem Feld Suchen In.

  5. Klicken Sie auf OK.

    Microsoft Access erstellt ein Bild-Steuerelement und zeigt das Bild im Steuerelement an.

Anmerkungen

  • Sie können nach dem Einfügen die Größe und die Proportionen des Bildes ändern.

    Wie wird's gemacht?

  • Wenn Sie ein Bild zu einem Bild-Steuerelement hinzufügen, fügt Microsoft Access das Bild standardmäßig in das Formular oder den Bericht ein. Wenn ein Bild in ein Formular oder einen Bericht eingefügt ist, wird es Teil der Datenbankdatei. Wenn Sie beabsichtigen, dasselbe Bild in verschiedenen Formularen und Berichten zu verwenden, ist es möglicherweise sinnvoll, das Bild zu verknüpfen und nicht einzufügen. Wenn Sie eine Verknüpfung mit einem Bild erstellen, wird das Bild nur an einer Stelle gespeichert. Zum Verknüpfen eines Bildes in einem Formular oder einem Bericht stellen Sie die Bildtyp-Eigenschaft (PictureType) des Bild-Steuerelements auf Verknüpft ein.
  • Wenn Sie ein Bild in eine Datenzugriffsseite einfügen, wird das Bild den Hilfsdateien hinzugefügt, die zu der Datenzugriffsseite gehören. Falls Sie vorhaben, das gleiche Bild auf mehreren Datenzugriffsseiten zu verwenden, sollten Sie das Bild verknüpfen, statt es einzufügen.


 Anpassen der Größe und der Proportionen eines Bildes in einem Formular oder Bericht

Anpassen der Größe und der Proportionen eines Bildes in einem Formular oder Bericht

Das Anpassen der Größe und Proportionen eines Bildes ist abhängig davon, ob es sich um ein Hintergrundbild (Wasserzeichen) oder ein Bild handelt, das unter Verwendung eines Bild-Steuerelements, eines ungebundenen Objektfelds oder eines gebundenen Objektfelds angezeigt wird.

Was möchten Sie tun?

Die Größe eines Hintergrundbilds anpassen

Die Größe eines Bildes, das in einem Bild-Steuerelement, einem ungebundenen Objektfeld oder einem gebundenen Objektfeld angezeigt wird, anpassen


 Hinzufügen eines Hintergrundbildes zu einem Formular

Hinzufügen eines Hintergrundbildes zu einem Formular

  1. Öffnen Sie ein Formular in der Entwurfsansicht

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Bild den Pfad und den Dateinamen für eine .BMP-, .ICO-, .DIB-, .WMF- oder .EMF-Datei ein. Wenn Sie Grafikfilter für andere Anwendungsprogramme installiert haben, können Sie jede beliebige, von diesen Filtern unterstützte Datei verwenden. Wenn Sie den Pfad oder Dateinamen nicht genau kennen, klicken Sie auf die Generator-Schaltfläche [image] .

  4. Geben Sie im Einstellungsfeld der Eigenschaft Bildtyp an, ob das Bild eingebettet oder verknüpft werden soll. Wenn Sie ein Bild einbetten, wird es in der Datenbankdatei gespeichert. Wenn Sie dasselbe Bild außerdem in einem anderen Formular einbetten, wird es der Datenbankdatei erneut hinzugefügt. Wenn Sie ein Bild verknüpfen, wird es nicht in der Datenbankdatei gespeichert. Eine Kopie davon muss sich aber auf Ihrer Festplatte befinden. Wenn Sie den Speicherplatz Ihrer Festplatte effizient nutzen möchten, geben Sie die Einstellung Verknüpft an.

  5. Nachdem Sie das Bild dem Formular hinzugefügt haben, können Sie es vergrößern/verkleinern oder abschneiden. Dazu klicken Sie im Einstellungsfeld der Eigenschaft Bildgrößenmodus auf eine der folgenden Einstellungen.
    Einstellung | Beschreibung
    Abschneiden | Zeigt das Bild in der tatsächlichen Größe an. Wenn das Bild größer ist als das Formularfenster, wird das Bild abgeschnitten.
    Dehnen | Passt die Größe des Bildes an das Formularfenster an. Bei Verwendung dieser Einstellung können die Proportionen des Bildes verzerrt werden.
    Zoomen | Ändert die Größe des Bildes so, dass es entweder in der Höhe oder in der Breite das Formularfenster ganz ausfüllt. Diese Einstellung schneidet das Bild weder ab, noch werden die Proportionen verzerrt.
  6. Wenn Sie die Ausrichtung des Bildes ändern möchten, klicken Sie auf eine der Einstellungen im Einstellungsfeld der Eigenschaft Bildausrichtung.

    Anmerkung Wenn Sie möchten, dass das Hintergrundbild zentriert dargestellt wird und es seine Größe an die jeweilige Größe des Fensters anpasst, klicken Sie auf die Einstellung Mitte. Wenn Sie nicht möchten, dass sich die Größe des Hintergrundbildes an die jeweilige Größe des Fensters anpasst, klicken Sie auf die Einstellung Formularmitte.

  7. Wenn Sie das Bild auf dem Hintergrund des Formulars mehrfach einfügen möchten, setzen Sie die Eigenschaft Bild nebeneinander auf Ja. Das Anordnen der Bilder nebeneinander beginnt an der Position, die Sie als Einstellung der Eigenschaft Bildausrichtung angegeben haben.

    Anmerkung Stellen Sie die Eigenschaft Bildgrößenmodus auf Abschneiden ein, wenn Sie das Hintergrundbild nebeneinander anordnen möchten. Wenn Sie für die Eigenschaft Bildgrößenmodus die Einstellung Zoomen oder Dehnen festgelegt haben, ist es nicht möglich, das Hintergrundbild nebeneinander anzuordnen.

Anmerkungen

  • Wenn die Farben in Ihrem Bild nicht den Originalfarben entsprechen, können Sie festlegen, dass Microsoft Access die Farben des Anwendungsprogramms verwenden soll, das Sie zum Erstellen des Bildes verwendet haben.

    Wie wird's gemacht?

  • Wenn Sie ein eigenes Hintergrundbild erstellen möchten und Zugriff auf ein Grafikprogramm haben, das Metadateien erstellt, können Sie statt eines Bitmaps eine Metadatei als Hintergrundbild verwenden. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Wiederherstellen einer Verknüpfung zu einem Bild in einem Formular oder Bericht

Wiederherstellen einer Verknüpfung zu einem Bild in einem Formular oder Bericht

Wenn Sie ein Bild umbenennen oder verschieben, kann die Verknüpfung zu diesem Bild verloren gehen. Wie Sie die Verknüpfung wiederherstellen, hängt davon ab, ob es sich um ein Bild in einem gebundenen Objektfeld oder in einem Objektfeld, ein Bild in einem Bild-Steuerelement oder um ein Hintergrundbild (Wasserzeichen) handelt.

Anmerkung Diese Verknüpfungsart ist nicht identisch mit einem Hyperlink, der in einem Formular oder Bericht zum Springen zu einem anderen Dokument, einem anderen Objekt oder einer anderen Seite verwendet wird. Zum Anzeigen weiterer Informationen zu Hyperlinks klicken Sie auf [image] .

Was möchten Sie tun?

Die Verknüpfung zu einem Bild in einem gebundenen Objektfeld oder einem Objektfeld wiederherstellen

Die Verknüpfung zu einem Bild in einem Bild-Steuerelement wiederherstellen

Die Verknüpfung zu einem Hintergrundbild wiederherstellen


 Wiederherstellen einer Verknüpfung zu einem Objekt in einem Formular oder Bericht

Wiederherstellen einer Verknüpfung zu einem Objekt in einem Formular oder Bericht

Wenn Sie ein verknüpftes Objekt umbenennen oder verschieben, kann die Verknüpfung zu diesem Objekt verloren gehen.

Anmerkung Diese Verknüpfungsart ist nicht identisch mit einem Hyperlink, der in einem Formular oder Bericht zum Springen zu einem anderen Dokument, einem anderen Objekt oder einer anderen Seite verwendet wird. Zum Anzeigen weiterer Informationen zu Hyperlinks klicken Sie auf [image] .

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Formular-Entwurfsansicht oder der Berichts-Entwurfsansicht auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Klicken Sie im Menü Bearbeiten auf OLE/DDE-Verknüpfungen.

  3. Klicken Sie im Feld Verknüpfungen auf die Verknüpfung, die Sie wiederherstellen oder ändern möchten.

  4. Klicken Sie auf Herkunft ändern.

  5. Wählen Sie im Feld Herkunft ändern den neuen Dateinamen. Möglicherweise müssen Sie zum Suchen nach der Datei zu einem anderen Laufwerk und/oder Ordner wechseln.

  6. Klicken Sie auf Öffnen, um die Verknüpfung zu vervollständigen und das Dialogfeld Herkunft ändern zu schließen, und klicken Sie dann im Dialogfeld Verknüpfungen auf Schließen.

Anmerkung Wenn Sie Änderungen an einer Verknüpfung für ein gebundenes Objektfeld vornehmen, ändern Sie die Verknüpfung nur für den aktuellen Datensatz. Zum Durchführen einer Änderung in einem anderen Datensatz gehen Sie zu diesem Datensatz und wiederholen die Änderung.


 Hinzufügen eines Bild-Steuerelements zu einer Datenzugriffsseite

Hinzufügen eines Bild-Steuerelements zu einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Bild Bildrahmen-Steuerelement .

  3. Klicken Sie in der Symbolleiste auf Feldliste [image] , um die Feldliste einzublenden.

  4. Ziehen Sie ein Feld aus der Feldliste, das den Pfad zu einem Bild enthält, in die Datenzugriffsseite. Setzen Sie die obere linke Ecke des Symbols an die Stelle, an der die obere linke Ecke des Bildes erscheinen soll, und lassen Sie die Maustaste los.

  5. Passen Sie die Größe des Bild-Steuerelements an. Anpassen der Größe eines in einem Bild-Steuerelement angezeigten Bildes.


 Informationen über das Arbeiten mit Grafiken in einer Datenzugriffsseite

Informationen über das Arbeiten mit Grafiken in einer Datenzugriffsseite

Dieses Thema enthält Referenzinformationen über:

Einfügen von Grafiken aus einer Datei

Ausrichten von Grafiken

Weitere Informationen

Einfügen von Grafiken aus einer Datei

Wenn Sie eine Grafik aus einer Datei einfügen, können Sie entweder die gesamte Grafik einfügen, indem Sie diese aus einem anderen Speicherort kopieren und einfügen, oder Sie können eine Verknüpfung mit der Grafik an einem festen Speicherort, wie z. B. einem Webserver oder einem relativen Dateispeicherort erstellen. Durch das Verknüpfen einer Grafik mit einer Datenzugriffsseite wird die Größe der Seite verringert, das Aktualisieren der Grafik erleichtert und das gemeiname Nutzen der Grafik in verschiedenen Datenzugriffsseiten vereinfacht. Stellen Sie in Windows beim Verschieben oder Kopieren einer Datenzugriffsseite an einen anderen Speicherort sicher, dass Sie auch alle unterstützenden Dateien verschieben und kopieren, wie z. B. Grafiken, Hintergrundstrukturen und Aufzählungszeichen, damit die Grafikverknüpfungen mit der Seite erhalten bleiben.

Zurück zum Anfang

Ausrichten von Grafiken

Die Symbolleiste Ausrichtung und Größenanpassung in der Entwurfsansicht der Datenzugriffsseite bietet Ausrichtungsbefehle, mit denen Sie Grafiken ausrichten können.

Zurück zum Anfang

Weitere Informationen

Hinzufügen eines Bildes oder eines anderen Objekts zu einer Datenzugriffsseite

Hinzufügen eines ActiveX-Steuerelements (eines OLE-Zusatzsteuerelements) zu einer Datenzugriffsseite

Zurück zum Anfang


 Anzeigen von Alternativtext statt eines Bildes auf einer Datenzugriffsseite

Anzeigen von Alternativtext statt eines Bildes auf einer Datenzugriffsseite

Möglicherweise möchten Sie für ein Bild einen Alternativtext hinzufügen. Falls ein Benutzer im Webbrowser die Grafikanzeige deaktiviert hat, oder wenn ein Benutzer ein Bildschirmlesegerät hat, dann wird an Stelle des Bildes der Alternativtext angezeigt.

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Markieren Sie das Steuerelement für das Bild, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das Steuerelement anzuzeigen.

  3. Geben Sie in das Eigenschaftenfeld Alt den Text ein, der angezeigt werden soll.


 Löschen eines ungebundenen Bildes auf einer Datenzugriffsseite

Löschen eines ungebundenen Bildes auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf Bildsteuerung.

  3. Drücken Sie die ENTF-TASTE.


 Was ist ein Ausdruck?

Was ist ein Ausdruck?

Ausdrücke sind wesentliche Bestandteile vieler Microsoft Access-Operationen. Ein Ausdruck ist eine Kombination von Symbolen (Bezeichner, Operatoren und Werte), die ein Ergebnis hervorbringt.

Sie können z.B. den folgenden Ausdruck in einem Steuerelement in einem Formular oder Bericht verwenden, um die Summe der Werte in den Steuerelementen Frachtkosten und Bestellmenge anzuzeigen:

= [Frachtkosten] + [Bestellmenge]

Hier sind einige Beispiele für Operationen, bei denen Sie Ausdrücke verwenden:

  • Bestimmen einer Eigenschaft, die ein berechnetes Steuerelement definiert, eine Gültigkeitsregel aufstellt oder einen Standardwert festlegt.

  • Eingeben von Kriterien, Erstellen eines berechneten Feldes oder Aktualisieren von Datensätzen in einer Abfrage oder einem Filter.

  • Festlegen einer Bedingung zum Ausführen einer Aktion oder einer Reihe von Aktionen in einem Makro oder Bestimmen von Argumenten für viele Aktionen.

  • Bestimmen von Argumenten für Funktionen, Anweisungen und Methoden in Visual Basic für Applikationen-Prozeduren.

  • Bearbeiten einer SQL-Abfrage in der SQL-Ansicht des Abfragefensters oder Verwenden einer SQL-Anweisung in einer Eigenschafteneinstellung oder einem Argument.

Um Informationen zum Erstellen eines Ausdrucks zu erhalten, klicken Sie auf [image] .

Um Beispiele für Ausdrücke anzuzeigen, klicken Sie auf [image] .


Erstellen eines Ausdrucks mit dem Ausdrucks-Generator

  1. Starten Sie den Ausdrucks-Generator.

    Wie wird's gemacht?

  2. Doppelklicken Sie auf das untere linke Feld des Ausdrucks-Generators, oder klicken Sie auf den Ordner, der die gewünschten Elemente enthält.

  3. Doppelklicken Sie im unteren mittleren Ordner auf ein Element, um es in das Ausdrucksfeld einzufügen, oder klicken Sie auf eine Kategorie von Elementen.

  4. Wenn Sie im unteren mittleren Feld eine Kategorie ausgewählt haben, werden die Werte im unteren rechten Feld angezeigt. Doppelklicken Sie auf einen Wert, um ihn in das Ausdrucksfeld einzufügen.

    Tipp Sie können einen beliebigen Teil des Ausdrucks auch direkt in das Ausdrucksfeld eingeben.

  5. Sie können beliebige Operatoren einfügen, indem Sie die Einfügemarke an die Stelle im Ausdrucksfeld positionieren, an der der Operator stehen soll, und dann auf eine der Operatorschaltflächen klicken, die in der Mitte des Ausdrucks-Generators angeordnet sind.

  6. Wenn Ihr Ausdruck vollständig ist, klicken Sie auf OK.

Microsoft Access kopiert Ihren Ausdruck an die Stelle, an der Sie den Ausdrucks-Generator gestartet haben. Wenn diese Position bereits einen Wert enthält, ersetzt Ihr neuer Ausdruck den Wert oder Text.

Um weitere Informationen über den Ausdrucks-Generator zu erhalten, klicken Sie auf [image] .


Arbeiten mit dem Ausdrucks-Generator

Was möchten Sie tun?

Allgemeines über den Ausdrucks-Generator erfahren

Den Ausdrucks-Generator starten

Mit dem Ausdrucks-Generator einen Ausdruck erstellen

Beispiele für Ausdrücke ansehen

Mehr über Ausdrücke erfahren


 Der Ausdrucks-Generator

Der Ausdrucks-Generator

Der Ausdrucks-Generator ist in drei Bereiche gegliedert:

Erstellen eines Ausdrucks durch Auswählen von Datenbankobjekten, Elementen und Werten aus den entsprechenden Listen

  • Im oberen Bereich befindet sich das Ausdrucksfeld, in dem Sie den Ausdruck zusammensetzen. Der untere Bereich dient dazu, die Elemente des Ausdrucks zu erzeugen und diese dann durch Einfügen in das Ausdrucksfeld zu einem vollständigen Ausdruck zu vereinen. Alternativ dazu können Sie die einzelnen Bestandteile des Ausdrucks auch direkt in das Ausdrucksfeld eingeben.

  • Im mittleren Bereich des Ausdrucks-Generators finden Sie Schaltflächen für häufig benötigte Operatoren. Sobald Sie auf eine dieser Schaltflächen klicken, fügt der Ausdrucks-Generator den jeweiligen Operator am Einfügepunkt in das Ausdrucksfeld ein. Wenn Sie eine Liste aller Operatoren sehen möchten, die in Ausdrücken verwendet werden können, klicken Sie auf den Ordner Operatoren im unteren linken Feld sowie auf eine der Operator-Kategorien im mittleren Feld. Das rechte Feld enthält alle Operatoren der ausgewählten Kategorie.

  • Im unteren Bereich des Ausdrucks-Generators befinden sich drei weitere Felder:
    • Das linke Feld enthält Ordner mit Listen der folgenden Elemente: Tabellen-, Abfrage-, Formular- und Berichstdatenbankobjekte, eingebaute und benutzerdefinierte Funktionen, Konstanten, Operatoren und häufig verwendete Ausdrücke.

    • Das mittlere Feld enthält entsprechend dem gewählten Ordner im linken Feld spezielle Elemente bzw. Kategorien von Elementen. Wenn Sie beispielsweise im linken Feld auf Eingebaute Funktionen klicken, enthält das mittlere Feld eine Liste der Microsoft Access-Funktionen.

    • Wenn es zu den im linken und mittleren Feld gewählten Element Werte gibt, werden diese im rechten Feld angezeigt. Wenn Sie beispielsweise im linken Feld auf Eingebaute Funktionen und im mittleren Feld auf eine Kategorie von Funktionen klicken, enthält das rechte Feld alle eingebauten Funktionen der ausgewählten Kategorie.

Anmerkungen

  • Wenn im Ausdrucks-Generator neue Feldnamen angezeigt werden sollen, muss die Tabelle oder Abfrage, die diese neuen Felder enthält, zuerst gespeichert werden.

  • Wenn ein Objekt oder eine Funktion nicht im unteren Teil des Ausdrucks-Generators aufgeführt ist, dann ist sie in dem Kontext, in dem Sie den Generator gestartet haben, ungültig. Sie können beispielsweise in der Gültigkeitsregel für ein Feld in der Tabellenentwurfsansicht nicht auf andere Felder und Steuerelemente verweisen, so dass die Ordner Tabellen, Abfragen, Formulare und Berichte nicht verfügbar sind, wenn Sie den Ausdrucks-Generator aus der Gültigkeitsregel-Eigenschaft eines Tabellenfelds heraus starten.

  • Wenn Sie einen Bezeichner in Ihren Ausdruck einfügen, fügt der Ausdrucks-Generator nur die Teile des Bezeichners ein, die im aktuellen Kontext erforderlich sind. Wenn Sie z.B. den Ausdrucks-Generator aus dem Eigenschaftenfenster im Formular Kunden starten und dann einen Bezeichner für die Sichtbar-Eigenschaft des Formulars in Ihren Ausdruck einfügen, fügt der Ausdrucks-Generator nur den Eigenschaftennamen (Sichtbar) ein. Wenn Sie den Ausdruck außerhalb des Formularkontextes verwenden, müssen Sie den vollständigen Bezeichner angeben: Formulare![Kunden].Sichtbar.


 So starten Sie den Ausdrucks-Generator

So starten Sie den Ausdrucks-Generator

Sie können den Ausdrucks-Generator von den meisten Positionen aus starten, in denen Sie Ausdrücke schreiben, wie beispielsweise in einem Eigenschaftenfenster, in einer Zelle Kriterien im Abfrageentwurfsbereich oder im Makrofenster.

Was möchten Sie tun?

Den Ausdrucks-Generator in einem Eigenschaftenfenster oder im unteren Bereich des Makrofensters starten

Den Ausdrucks-Generator im Abfrageentwurfsbereich oder in einer Makrobedingung starten


 Eingeben eines Ausdrucks in ein Eigenschaftenfenster, einen Entwurfsbereich oder in ein Aktionsargument

Eingeben eines Ausdrucks in ein Eigenschaftenfenster, einen Entwurfsbereich oder in ein Aktionsargument

Wenn Sie einen Ausdruck eingeben, der länger ist als der Standardeingabebereich in einem Eigenschaftenfenster, einem Entwurfsbereich oder einem Aktionsargument, können Sie den Ausdruck in das Dialogfeld Zoom eingeben. Um das Dialogfeld Zoom zu öffnen, drücken Sie die Tastenkombination UMSCHALT+F2, wenn sich der Fokus an der Stelle befindet, an der Sie den Ausdruck eingeben möchten.

Wenn Sie einen Ausdruck in ein Eigenschaftenfenster, einen Entwurfsbereich oder in ein Aktionsargument eingeben,

  • erkennt Microsoft Access länderspezifische Funktionsnamen, Eigenschaftennamen und Listentrennzeichen der internationalen Versionen.

  • fügt Microsoft Access für Sie bestimmte Zeichen ein, wenn sich der Fokus verändert. Je nachdem, an welcher Stelle Sie den Ausdruck eingeben, fügt Microsoft Access automatisch die folgenden Elemente ein:
    • Klammern ([ ]) um Formular-, Berichts-, Feld- oder Steuerelementnamen.

    • das Zeichen # um Datumsangaben.

    • Anführungszeichen (" ") um Text.

Anmerkung Vor Ausdrücken für ein berechnetes Steuerelement steht immer ein Gleichheitszeichen (=).

Verwenden von Funktionen und Eigenschaften in internationalen Versionen von Microsoft Access

Wenn Sie eine Funktion oder Eigenschaft in einen Ausdruck eingeben, können Sie in den meisten internationalen Versionen von Microsoft Access

  • deren lokalisierten Namen (in Ihrer Sprache) in ein Eigenschaftenfenster, einen Entwurfsbereich oder in ein Aktionsargument eingeben.

  • das Listentrennzeichen für Ihr Land verwenden, wenn Sie mehr als ein Argument für eine Funktion angeben. Sie können das Listentrennzeichen auf der Registerkarte Zahlen der Option Ländereinstellungen in der Windows Systemsteuerung angeben. Bei den meisten internationalen Versionen ist das Standard-Listentrennzeichen ein Semikolon (;).

Im Visual Basic für Applikationen-Code müssen Sie jedoch den englischen Funktions- oder Eigenschaftennamen eingeben und ein Komma (,) als Listentrennzeichen verwenden.

Eingeben von Objektnamen

Klammern ([ ]) um ein Feld, Steuerelement oder um eine Eigenschaft in einem Bezeichner zeigen an, dass das Element der Name einer Tabelle, Abfrage, eines Formulars, Berichts, Feldes oder Steuerelements ist.

Wenn Sie einen Objektnamen in einen Bezeichner eingeben, setzen Sie Klammern um den Namen, wenn dieser ein Leerzeichen oder ein Sonderzeichen, wie z.B. einen Bindestrich, enthält. Enthält der Name kein Leerzeichen oder Sonderzeichen, können Sie den Namen ohne Klammern eingeben. Microsoft Access fügt (abgesehen von den zwei unten aufgeführten Ausnahmen) automatisch Klammern ein.

Sie können z.B. den folgenden Ausdruck als Einstellung für die Eigenschaft ControlSource eingeben, um die Summe der Werte in den Feldern Frachtkosten und Bestellmenge zu berechnen.

= Frachtkosten + Bestellmenge

Microsoft Access zeigt den Ausdruck wie folgt an:

= [Frachtkosten] + [Bestellmenge]

Anmerkung In der Einstellung der Eigenschaft ValidationRule oder in einer Zelle Kriterien im Abfrageentwurfsbereich fügt Microsoft Access nicht automatisch Klammern um einen Namen ein. Wenn Sie einen Objektnamen eingeben, überprüfen Sie, ob Sie Klammern gesetzt haben. Sonst geht Microsoft Access davon aus, dass Sie Text eingeben und fügt Anführungszeichen hinzu.

Eingeben von Datum/Uhrzeit-Werten

Das Zeichen # um ein Element eines Ausdrucks zeigt an, dass es sich bei dem Element um einen Datum/Uhrzeit-Wert handelt. Microsoft Access wertet einen von den Zeichen # umgebenen Wert automatisch als einen Datum/Uhrzeit-Wert, und Sie können den Wert in einem beliebigen Datums- oder Zeitformat eingeben.

Sie müssen das Zeichen # nicht um einen Datum/Uhrzeit-Wert setzen, wenn es sich um einen Gültigkeitsregel- oder Kriterienausdruck für ein Feld handelt, dessen Felddatentyp Datum/Uhrzeit ist. Sie können den Wert in einem beliebigen Datums- oder Zeitformat eingeben, und Microsoft Access fügt automatisch das Zeichen # um den Wert ein.

Microsoft Access zeigt den Wert gemäß den Einstellungen im Dialogfeld Ländereinstellungen der Windows Systemsteuerung an. Sie können das Ausgabeformat eines Datums ändern, indem Sie die Eigenschaft Format verwenden.

Eingeben von Text

Anführungszeichen (" ") um ein Element eines Ausdrucks zeigen an, dass es sich bei dem Element um Text handelt.

Wenn Sie in einen Gültigkeitsregel- oder Kriterienausdruck Text eingeben, setzen Sie den Text in Anführungszeichen, wenn er ein Leerzeichen oder Satzzeichen enthält. Enthält der Text kein Leerzeichen oder Satzzeichen, können Sie den Text ohne die Anführungszeichen eingeben, und Microsoft Access fügt sie automatisch hinzu.

Wenn Sie z.B. den Ausdruck Paris eingeben, zeigt Microsoft Access den Ausdruck wie folgt an:

"Paris"


 Verwenden von Werten in Ausdrücken

Verwenden von Werten in Ausdrücken

Sie können einen Wert in einem Ausdruck angeben, indem Sie einen Literalwert, eine Konstante, eine Funktion oder einen Bezeichner verwenden:

  • Ein Literalwert stellt einen Wert, wie z. B. eine Zahl, eine Zeichenfolge oder ein Datum dar, den Microsoft Access genau so auswertet, wie er geschrieben wurde. "New York", 100 und #1-Jan-94# sind Beispiele für Literalwerte. Datumsangaben werden in Nummernzeichen (#) und Zeichenfolgen in doppelte (") Anführungszeichen eingeschlossen.

  • Eine Konstante stellt einen Wert dar, der sich nicht ändert. Wahr, Falsch und Null sind Beispiele für Konstanten, die von Microsoft Access automatisch definiert werden. Sie können in Visual Basic für Applikationen auch Ihre eigenen Konstanten definieren und diese dann in Visual Basic-Prozeduren verwenden.

  • Eine Funktion gibt einen Wert zurück, der auf dem Ergebnis einer Berechnung oder einer anderen Operation basiert. In Microsoft Access sind viele integrierte Funktionen enthalten, z. B.:
    • Die Date-Funktion gibt das aktuelle Datum zurück.

    • Die Sum-Funktion gibt die Summe einer Reihe von Feldwerten zurück.

    • Die DLookup-Funktion gibt einen bestimmten Feldwert zurück.

    Sie können mit Visual Basic auch Ihre eigenen Funktionen erstellen.

  • Ein Bezeichner verweist auf den Wert eines Feldes, eines Steuerelements oder einer Eigenschaft. Beispielsweise verweist der folgende Bezeichner auf den Wert der Standardwert-Eigenschaft des Steuerelements Bestelldatum im Formular Bestellungen:

    Formulare![Bestellungen]![Bestelldatum].DefaultValue

Sie können den Wert eines Feldes, eines Steuerelements oder einer Eigenschaft mit einer Literalzeichenfolge verbinden, indem Sie den Operator & (Zusammensetzung) verwenden. Beispielsweise verbindet der folgende Ausdruck die Literalzeichenfolge "[KategorieID] = " mit dem Wert des Steuerelements KategorieID im Formular Produkte:

"[KategorieID] = " & Formulare![Produkte]![KategorieID]

In einigen Zusammenhängen - beispielsweise in einer Domänen-Aggregatfunktion wie DLookup - muss der Wert des Feldes, des Steuerelements oder der Eigenschaft in einfachen (') oder doppelten (") Anführungszeichen stehen. Am einfachsten lässt sich dies erreichen, indem Sie der Literalzeichenfolge ein einfaches Anführungszeichen hinzufügen und dann den Ausdruck mit einer anderen Literalzeichenfolge verbinden, die aus einem einfachen Anführungszeichen nach dem Wert des Feldes, des Steuerelements oder der Eigenschaft besteht, wie im Folgenden dargestellt:

"[KategorieID] = ' " & Formulare![Produkte]![KategorieID] & " ' "

Bereits vorhandene Microsoft Access-Anwendungen verwenden möglicherweise die Senkrechtstrich-Operatoren (| |) an Stelle einer öffnenden und schließenden Kombination von doppelten Anführungszeichen und &-(Zusammensetzungs-)Operatoren, wie im Folgenden dargestellt:

"[KategorieID] = '|Formulare![Produkte]![KategorieID]|' "

Die Verwendung von senkrechten Strichen ist jedoch nicht empfehlenswert, da sie unter gewissen Umständen unerwartete Ergebnisse hervorrufen können.

Wenn ein Ausdruck eine Zeichenfolge erzeugen soll, die in doppelte Anführungszeichen eingeschlossen ist, können Sie die geschachtelte Zeichenfolge entweder in einfache Anführungszeichen oder in drei Paare doppelter Anführungszeichen einschließen. Beispielsweise sind die folgenden Ausdrücke gleichwertig:

Formulare![Ansprechpartner]![Stadt].DefaultValue = ' "Paris" '

Formulare![Ansprechpartner]![Stadt].DefaultValue = " " "Paris" " "

Um weitere Informationen über Konstanten anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen über das Erstellen eigener Funktionen anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen über das Verwenden von Bezeichnern in Ausdrücken anzuzeigen, klicken Sie auf [image] .


 Verweisen auf eine Listenspalte in einem Ausdruck

Verweisen auf eine Listenspalte in einem Ausdruck

Sie können auf eine Spalte in einem mehrspaltigen Listenfeld oder Kombinationsfeld verweisen, indem Sie die Eigenschaft Column des Listenfeld- oder Kombinationsfeld-Steuerelements verwenden.

  • Geben Sie den Bezeichner für die Eigenschaft Column ein, gefolgt von der Index-Nummer der Spalte in Klammern. Wählen Sie 0, um auf die erste Spalte zu verweisen, 1, um auf die zweite Spalte zu verweisen usw. Der folgende Bezeichner verweist z.B. auf die zweite Spalte des Listenfeld-Steuerelements Land im Formular Kunden:

    [Formulare]![Kunden]![Land].Spalte(1)

Anmerkung Wenn Sie ein Makro oder Visual Basic für Applikationen-Code ausführen, in dem ein enthaltener Ausdruck auf ein Formular oder einen Bericht verweist, muss das Formular bzw. der Bericht geöffnet sein.

Um Informationen zum Erstellen eines mehrspaltigen Listenfeldes oder Kombinationsfeldes zu erhalten, klicken Sie auf [image] .

Um Informationen zum Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck zu erhalten, klicken Sie auf [image] .


 Verweisen auf einen Formular- oder Berichtsbereich oder eine BerichtsGruppierungsebene in einem Ausdruck

Verweisen auf einen Formular- oder Berichtsbereich oder eine BerichtsGruppierungsebene in einem Ausdruck

  • Geben Sie den Bezeichner für das Formular oder den Bericht und dann den Operator . (Punkt) und den Namen des Bereichs oder der Gruppierungsebene ein. Der folgende Bezeichner verweist z.B. auf den Detailbereich im Formular Bestellungen:

    [Formulare]![Bestellungen].Detail

Anmerkungen

  • Wenn Sie ein Makro oder Visual Basic für Appikationen-Code ausführen, in dem ein enthaltener Ausdruck auf ein Formular oder einen Bericht verweist, muss das Formular bzw. der Bericht geöffnet sein.

  • Sie können auch durch Index-Nummern auf Formular- oder Berichtsbereiche oder BerichtsGruppierungsebenen verweisen, indem Sie die Eigenschaft Section verwenden. Um weitere Informationen zur Eigenschaft Section zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zum Verwenden von Bezeichnern in Ausdrücken zu erhalten, klicken Sie auf [image] .


 Verweisen auf ein Formular, einen Bericht, ein Unterformular oder einen Unterbericht in einem Ausdruck

Verweisen auf ein Formular, einen Bericht, ein Unterformular oder einen Unterbericht in einem Ausdruck

Zum Verweisen auf ein geöffnetes Formular oder einen Bericht, oder auf ein Unterformular oder Unterbericht in einem geöffneten Formular oder Bericht mit Hilfe eines Ausdrucks geben Sie den entsprechenden Bezeichner ein.

So verweisen Sie auf ein geöffnetes Formular oder einen geöffneten Bericht

  • Geben Sie den Namen der Forms- oder Reports-Auflistung, gefolgt vom Operator ! und dem Namen des Formulars oder Berichts ein. Der folgende Bezeichner verweist z. B. auf das Formular Bestellungen:

    Formulare![Bestellungen]

So verweisen Sie auf ein Unterformular oder einen Unterbericht

Verweisen Sie auf das Unterformular- oder Unterbericht-Steuerelement im Formular oder Bericht, das das Unterformular bzw. den Unterbericht enthält. Verwenden Sie dann die Eigenschaft Formular oder Bericht, um auf das eigentliche Unterformular oder den eigentlichen Unterbericht zu verweisen.

  • Geben Sie den Bezeichner für das Formular ein, das das Unterformular enthält, gefolgt vom Namen des Unterformular-Steuerelements, dem Operator . (Punkt) und der Eigenschaft Formular. Das folgende Beispiel verweist auf das Unterformular Unterformular Bestellungen im Formular Bestellungen:

    Formulare![Bestellungen]![Unterformular Bestellungen].Formular

Anmerkungen

  • Sie können zum Erstellen eines Bezeichners für ein Formular, einen Bericht, ein Unterformular oder einen Unterbericht den Ausdrucks-Generator verwenden.

  • Wenn Sie ein Makro oder Visual Basic für Applikationen-Code verwenden, das/der einen Ausdruck enthält, der auf ein Formular oder einen Bericht verweist, muss das Formular bzw. der Bericht geöffnet sein.

Zum Anzeigen weiterer Informationen zum Erstellen eines Ausdrucks unter Verwendung des Ausdrucks-Generators klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zur Bezeichnerverwendung in Ausdrücken klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zum Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck klicken Sie auf [image] .


 Verweisen auf ein Objekt oder dessen Eigenschaften in Ausdrücken

Verweisen auf ein Objekt oder dessen Eigenschaften in Ausdrücken

Verwenden Sie zum Verweisen auf ein Objekt oder dessen Eigenschaften in einem Ausdruck eine Kennung. Sie können z. B. auf ein geöffnetes Formular, einen geöffneten Bericht, ein Steuerelement in einem geöffneten Formular oder Bericht oder auf beliebige Eigenschaften des Formulars, Berichts oder Steuerelements verweisen. Die folgende Kennung verweist auf die Sichtbar-Eigenschaft eines Steuerelements:

Reportsl![Rechnung]![Empfänger].Sichtbar

Die vollständige Kennung eines Objekts oder einer Eigenschaft zeigt die Beziehung zwischen Elementen in der Kennung an. In diesem Beispiel heißt das:

  • "Reports" verweist auf die Auflistung geöffneter Berichte in der Datenbank. Microsoft Access erstellt automatisch Forms- und Reports-Auflistungen für jede Datenbank. Die Forms-Auflistung enthält alle geöffneten Formulare, die Reports-Auflistung alle geöffneten Berichte.

  • [Rechnung] verweist auf den Bericht Rechnung in der Reports-Auflistung.

  • [Empfänger] verweist auf das Steuerelement Empfänger im Bericht Rechnung.

  • "Sichtbar" verweist auf die Eigenschaft Sichtbar des Steuerelements Empfänger.

In der Regel ist es sinnvoll, unter Verwendung einer vollständigen Kennung auf ein Objekt oder eine Eigenschaft zu verweisen. Sie müssen z. B. die vollständige Kennung eingeben, wenn Sie auf ein Steuerelement in einem Formular oder Bericht verweisen, das/der gerade nicht aktiviert ist. Der nachstehende Ausdruck zeigt die Summe der Werte in den Steuerelementen Gesamtpreis und Frachtkosten des Formulars Bestellung in einem Steuerelement in einem anderen Formular an:

= Formulare![Bestellungen]![Gesamtpreis] + Formulare![Bestellungen]![Frachtkosten]

In bestimmten Fällen können Sie jedoch auch ohne Angabe der vollständigen Kennung auf ein Steuerelement oder seine Eigenschaften verweisen:

  • Wenn Sie auf ein Steuerelement im aktuellen Formular oder Bericht verweisen, müssen Sie die Formular- oder Berichtskennung nicht angeben. Sie können z. B. die Steuerelementinhalt-Eigenschaft folgendermaßen einstellen, wenn Sie die Summe der Werte aus den Steuerelementen Gesamtpreis und Frachtkosten in einem anderen Steuerelement desselben Formulars anzeigen möchten:

    = [Gesamtpreis] + [Frachtkosten]

  • Wenn Sie auf ein Steuerelement in einem Unterformular oder einem Unterbericht verweisen, müssen Sie die vollständige Kennung für das Formular oder den Bericht nicht angeben, wenn Sie die Formular-Eigenschaft oder die Bericht-Eigenschaft verwenden. Sie können z. B. die folgende Kennung verwenden, um auf das Steuerelement Menge im Unterformular Bestellungen zu verweisen:

    Formulare![Bestellungen]![Unterformular Bestellungen]![Menge]

    Die vollständige Kennung für das Steuerelement würde folgendermaßen lauten:

    Formulare![Bestellungen]![Unterformular Bestellungen].Form![Menge]

  • In einem Makro oder einem Aktionsargument müssen Sie die Kennung für das Formular oder den Bericht, in dem das Makro ausgeführt wird, nicht angeben. Wenn Sie z. B. für eine Ereigniseigenschaft in einem Formular den Namen eines Makros angeben, können Sie auf die Steuerelemente des Formulars in der Spalte Bedingung des Makros oder in Aktionsargumenten ohne Angabe der Kennung des Formulars verweisen.

  • In einer Visual Basic für Applikationen-Prozedur können Sie an Stelle der vollständigen Kennung das Schlüsselwort Me verwenden, um auf ein Steuerelement im aktuellen Formular oder Bericht zu verweisen. Fügen Sie z. B. die nachstehende Anweisung zur Ereignisprozedur hinzu, wenn Sie die Summe der Werte in den Steuerelementen Gesamtpreis und Frachtkosten eines Formulars der Variablen Bestellsumme in einer der Ereignisprozeduren des Formulars zuweisen möchten:
    Bestellsumme = Me![Gesamtpreis] + Me![Frachtkosten]

Anmerkungen

  • Wenn Sie ein Makro oder Visual Basic für Appikationen-Code ausführen, in dem ein enthaltener Ausdruck auf ein Formular oder einen Bericht verweist, muss das Formular bzw. der Bericht geöffnet sein.

  • In einer Visual Basic-Prozedur können Sie durch Angeben des Namens eines Objekts in Klammern und unter Verwendung doppelter Anführungszeichen anstatt des Operators ! auf ein Objekt verweisen. Die Klammernsyntax ist erforderlich, wenn Sie in einer Kennung eine Variable verwenden möchten. Die nachstehenden Kennungen sind z. B. gleichbedeutend:
    Formulare![Bestellungen]![Bestelldatum]
Forms("Bestellungen")("Bestelldatum")

Zum Anzeigen von Informationen zur Verwendung der Operatoren ! und . (Punkt) in Ausdrücken klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zum Verweisen auf ein Formular, einen Bericht, ein Unterformular oder einen Unterbericht in einem Ausdruck klicken Sie auf [image] .

Zum Anzeigen von Informationen zum Verweisen auf einen Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck klicken Sie auf [image] .


 Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck

Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck

Zum Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft mit Hilfe eines Ausdrucks geben Sie den entsprechenden Bezeichner ein.

So verweisen Sie auf den Wert eines Steuerelements

  • Geben Sie den Bezeichner für das Formular oder den Bericht ein, das/der das Steuerelement enthält, gefolgt vom Operator ! und dem Namen des Steuerelements. Der folgende Bezeichner verweist auf den Wert des Steuerelements Bestell-Nr im Formular Bestellungen:

    Formulare![Bestellungen]![Bestell-Nr]

    Tipp Wenn Sie auf ein Steuerelement in einem Unterformular oder einem Unterbericht verweisen, müssen Sie nicht unbedingt den vollständigen Bezeichner für das Formular oder Bericht (unter Verwendung der Eigenschaft Formular oder Bericht) angeben. Sie können zum Verweisen auf das Steuerelement Menge im Unterformular Unterformular Bestellungen z. B. den folgenden Bezeichner verwenden:

    Formulare![Bestellungen]![Unterformular Bestellungen]![Menge]

So verweisen Sie auf den Wert einer Eigenschaft

  • Geben Sie den Bezeichner für das Formular, den Bericht oder das Steuerelement ein, für das/den die Eigenschaft gilt, gefolgt vom Operator . (Punkt) und dem Namen der Eigenschaft. Der folgende Bezeichner verweist z. B. auf die Eigenschaft Standardwert des Steuerelements Bestelldatum im Formular Bestellungen:

    Formulare![Bestellungen]![Bestelldatum].Standardwert

Anmerkungen

  • Sie können zum Erstellen eines Bezeichners für einen Bericht oder eine Eigenschaft den Ausdrucks-Generator verwenden.

  • Wenn Sie ein Makro oder Visual Basic für Applikationen-Code verwenden, das/der einen Ausdruck enthält, der auf ein Formular oder einen Bericht verweist, muss das Formular bzw. der Bericht geöffnet sein.

Zum Anzeigen weiterer Informationen zum Erstellen eines Ausdrucks unter Verwendung des Ausdrucks-Generators klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zur Verwendung von Bezeichnern in Ausdrücken klicken Sie auf [image] .

Um weitere Informationen über das Verwenden von Werten in Ausdrücken zu erhalten, klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zum Verweisen auf ein Formular, einen Bericht, ein Unterformular oder einen Unterbericht in einem Ausdruck klicken Sie auf [image] .


 Verwenden der Operatoren ! und . (Punkt) in Ausdrücken

Verwenden der Operatoren ! und . (Punkt) in Ausdrücken

Die Operatoren ! und . (Punkt) werden in einem Bezeichner verwendet, um den Typ des unmittelbar folgenden Elements anzugeben.

Der Operator ! gibt an, dass ein benutzerdefiniertes Element folgt (ein Element einer Auflistung). Beispielsweise können Sie den Operator ! verwenden, um auf ein geöffnetes Formular, einen geöffneten Bericht oder ein Steuerelement in einem geöffneten Formular oder Bericht zu verweisen.

Bezeichner | Verweist auf
Formulare![Bestellungen] | Das geöffnete Formular Bestellungen
Reports![Rechnung] | Der geöffnete Bericht Rechnung
Formulare![Bestellungen]![Bestell_ID] | Das Steuerelement Bestell_ID im geöffneten Formular Bestellungen

Der Operator . (Punkt) gibt üblicherweise an, dass ein von Microsoft Access definiertes Element folgt. Beispielsweise können Sie den Operator . (Punkt) verwenden, um auf eine Eigenschaft eines Formulars, Berichts oder Steuerelements zu verweisen.

Anmerkung Sie können den Operator . (Punkt) auch verwenden, um auf einen Feldwert in einer SQL-Anweisung, einer Methode von Visual Basic für Applikationen oder einer Auflistung zu verweisen. Beispielsweise verweist der Bezeichner Formulare![Bestellungen].Controls auf die Controls-Auflistung des Formulars Bestellungen. Da es sich bei der Controls-Auflistung jedoch um die Standardauflistung für Formulare und Berichte handelt, ist ein expliziter Verweis auf sie normalerweise nicht erforderlich.


 Richtlinien zum Benennen von Feldern, Steuerelementen und Objekten

Richtlinien zum Benennen von Feldern, Steuerelementen und Objekten

Namen von Feldern, Steuerelementen und Objekten in Microsoft Access

  • können aus bis zu 64 Zeichen bestehen.

  • können beliebige Kombinationen von Buchstaben, Zahlen, Leerzeichen und Sonderzeichen einschließen, mit Ausnahme von einem Punkt (.), Ausrufezeichen (!), Accent grave (`), und eckigen Klammern ([ ]).

  • dürfen nicht mit vorangestellten Leerzeichen anfangen.

  • dürfen keine Steuerzeichen enthalten (ASCII Werte 0 bis 31).

  • dürfen keine doppelten Anführungszeichen (") in Tabellen-, Ansichten- oder gespeicherten Prozedurennamen in einem Microsoft Access-Projekt enthalten.

Obwohl Sie Leerzeichen in Feld-,Steuerelement- und Objektnamen einbeziehen können, sind die meisten Beispiele in der Microsoft Access-Dokumentation Feld- und Steuerelementnamen ohne Leerzeichen, weil Leerzeichen in Namen in manchen Fällen bei der Benennung in Visual Basic Probleme verursachen können.

Wenn Sie ein Feld, Steuerelement oder Objekt benennen, ist es sinnvoll, zu überprüfen, ob der Name nicht gleichlautend zu dem Namen einer Eigenschaft oder eines anderen von Microsoft Access verwendeten Elements ist. Sonst können in Ihrer Datenbank möglicherweise unerwartete Ereignisse auftreten. Wenn Sie beispielsweise auf den Wert eines Feldes Name in einer Tabelle NameInfo verweisen und die Syntax NameInfo.Name verwenden, zeigt Microsoft Access den Wert der Eigenschaft Name der Tabelle statt des Wertes des Feldes Name.

Eine weitere Möglichkeit, unerwartete Ergebnisse zu vermeiden, besteht darin, immer den Operator ! an Stelle des Operators . (Punkt) zu verwenden, um auf den Wert eines Feldes, Steuerelements oder Objekts zu verweisen. Der folgende Bezeichner verweist beispielsweise explizit auf den Wert des Feldes Name und nicht auf die Eigenschaft Name:

[NameInfo]![Name]

Um weitere Informationen zu den Operatoren ! und . (Punkt) in Ausdrücken zu erhalten, klicken Sie auf [image] .


Richtlinien zum Benennen von Prozeduren, Variablen, und Konstanten in Visual Basic

Namen von Prozeduren, Variablen und Konstanten in Ihrem Visual Basic für Applikationen-Code

  • können aus bis zu 255 Zeichen bestehen.

  • müssen mit einem Buchstaben anfangen.

  • können Buchstaben, Zahlen oder Unterstrichzeichen (_) enthalten.

  • dürfen keine Satzzeichen oder Leerzeichen enthalten.

  • dürfen keine Visual Basic-Schlüsselworte sein.

Ein Schlüsselwort ist ein Wort, das von Visual Basic als Teil seiner Sprache verwendet wird. Hierzu zählen vordefinierte Anweisungen (wie z.B. If und Loop), Funktionen (wie z.B. Len und Abs) und Operatoren (wie z.B. Or und Mod).


 Beispiele für Ausdrücke

Beispiele für Ausdrücke

Ausdrücke werden bei vielen Operationen in Microsoft Access verwendet, beispielsweise beim Erstellen von berechneten Steuerelementen, Abfragen und Filterkriterien, Standardwerten, Gültigkeitsregeln und Makrobedingungen. Der einfachste Weg zur Erstellung eines Ausdrucks besteht häufig darin, einen ähnlichen Beispielausdruck zu suchen wie der, den Sie erstellen möchten, und diesen dann entsprechend abzuändern.

Was für Beispiele möchten Sie anzeigen?

Beispiele für Ausdrücke in Formularen und Berichten

Beispiele für Ausdrücke in Abfragen und Filtern

Beispiele für Standardwertausdrücke

Beispiele für Ausdrücke in Feldgültigkeitsregeln

Beispiele für Ausdrücke in Makrobedingungen

Weitere Informationen über Ausdrücke


Ausdrücke in Formularen und Berichten - Beispiele

Was möchten Sie tun?

Beispiele für Ausdrücke, die Text ändern, anzeigen

Beispiele für Ausdrücke für Seitenzahlen anzeigen

Beispiele für Ausdrücke, die arithmetische Operationen durchführen, anzeigen

Beispiele für Ausdrücke, die auf Werte in Steuerelementen verweisen, anzeigen

Beispiele für Ausdrücke, die unter Verwendung von Aggregatfunktionen Werte zählen, addieren oder Mittelwerte berechnen, anzeigen

Beispiele für Ausdrücke, die unter Verwendung von Aggregatfunktionen für Domänen Werte zählen, addieren oder nachschlagen, anzeigen

Beispiele für Ausdrücke, die Datumsangaben ändern, anzeigen

Beispiele für Ausdrücke, die einen von zwei möglichen Werten ausgeben, anzeigen

Einen Ausdruck erstellen


 Ändern und Berechnen von Datumsangaben in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Ändern und Berechnen von Datumsangaben in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen, Berichten und Datenzugriffsseiten in berechneten Steuerelementen verwenden können.

Ausdruck | Beschreibung
=Datum() | Verwendet die Funktion Datum zum Anzeigen des aktuellen Datums im Formular unter Verwendung des Formats tt.mm.jj, wobei tt den Tag (1 bis 31), mm den Monat (1 bis 12) und jj die letzten beiden Ziffern der Jahreszahl (1980 bis 2099) angibt.
=Format(Jetzt(); "ww") | Verwendet die Funktion Format zum Anzeigen der Kalenderwoche des Jahres im aktuellen Datum, wobei ww ein Wert zwischen 1 und 53 ist.
=DatTeil ("jjjj"; [Bestelldatum]) | Verwendet die Funktion DatTeil zum Anzeigen der vierstelligen Jahreszahl aus dem Feld Bestelldatum.
=DatAdd ("j"; -10; [ZugesichertesDatum]) | Verwendet die Funktion DatAdd zum Anzeigen eines Datums, das 10 Tage vor dem Datum aus dem Feld ZugesichertesDatum liegt.
=DatDiff("t"; [Bestelldatum]; [Versanddatum]) | Verwendet die Funktion DatDiff zum Anzeigen der in Tagen ausgedrückten Abweichung zwischen den Werten in den Feldern Bestelldatum und Versanddatum.

Anmerkungen

  • In der Steuerelementinhalt-Eigenschaft eines berechneten Steuerelements sollte dem Ausdruck der =-Operator vorangestellt werden. In einer Datenzugriffsseite können Sie den =-Operator weglassen und stattdessen einen Aliasnamen eingeben, beispielsweise Kalenderwoche: Format(Jetzt(), "ww").

  • Verwenden Sie immer einen eindeutigen Namen, wenn Sie die Name-Eigenschaft eines berechneten Steuerelements in einem Formular oder Bericht oder die ID-Eigenschaft eines berechneten Steuerelements in einer Datenzugriffsseite festlegen. Verwenden Sie nicht den Namen oder die ID eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Wenn Sie innerhalb eines Formulars oder Berichts einen Ausdruck definieren, können Sie den Namen eines Steuerelements oder eines Feldes der zugrunde liegenden Datensatzquelle verwenden. In einem innerhalb einer Datenzugriffsseite definierten Ausdruck können Sie nur den Namen eines Feldes verwenden, der in der Datendefinition der Seite erscheint.


 Ändern von Textwerten in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Ändern von Textwerten in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen, Berichten und Datenzugriffsseiten für berechnete Steuerelemente verwenden können.

Ausdruck | Beschreibung
="N/V" | Zeigt N/V an.
=[Vorname] & " " & [Nachname] | Zeigt die Werte in den Feldern Vorname und Nachname durch ein Leerzeichen voneinander getrennt an.
=Links([Artikelname]; 1) | Verwendet die Links-Funktion zum Anzeigen des ersten Zeichens des Wertes im Feld Artikelname.
=Rechts([Dateiname]; 3) | Verwendet die Rechts-Funktion zum Anzeigen der letzten zwei Zeichen des Wertes im Feld Dateiname.
=Glätten([Straße]) | Verwendet die Glätten-Funktion zum Anzeigen des Wertes im Feld Straße, wobei führende und nachgestellte Leerzeichen entfernt werden.
=IIF(IstNull([Region]);
[Ort] & " " & [PLZ];
[Ort] & " " & [Region] & " " & [PLZ]) 		Verwendet die Wenn-Funktion zum Anzeigen der Werte in den Feldern Ort und PLZ, wenn der Wert in Region gleich Null ist. Ist dies nicht der Fall, werden die Werte aus den Feldern Ort, Region und PLZ durch Leerzeichen voneinander getrennt angezeigt.

Anmerkungen

  • In der Einstellung der Steuerelementinhalt-Eigenschaft eines berechneten Steuerelements sollte dem Ausdruck der =-Operator vorangestellt werden. In einer Datenzugriffsseite können Sie den =-Operator weglassen und stattdessen einen Aliasnamen eingeben, beispielsweise VollständigerName: [Vorname] & " " & [Nachname].

  • Verwenden Sie immer einen eindeutigen Namen, wenn Sie die Name-Eigenschaft eines berechneten Steuerelements in einem Formular oder Bericht oder die ID-Eigenschaft eines berechneten Steuerelements in einer Datenzugriffsseite festlegen. Verwenden Sie nicht den Namen oder die ID eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Wenn Sie innerhalb eines Formulars oder Berichts einen Ausdruck definieren, können Sie den Namen eines Steuerelements oder eines Feldes der zugrunde liegenden Datensatzquelle verwenden. In einem innerhalb einer Datenzugriffsseite definierten Ausdruck können Sie nur den Namen eines Feldes verwenden, der in der Datendefinition der Seite erscheint.


 Durchführen arithmetischer Operationen in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Durchführen arithmetischer Operationen in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen, Berichten und Datenzugriffsseiten für berechnete Steuerelemente verwenden können.

Ausdruck | Beschreibung
=[Gesamtpreis]+[Frachtkosten] | Zeigt die Summe der Werte in den Feldern Gesamtsumme und Frachtkosten an.
=[Lieferdatum]-[Versanddatum] | Zeigt die Differenz zwischen den Werten in den Feldern Lieferdatum und Versanddatum an.
=[Einzelpreis]*1,06 | Zeigt das Produkt aus dem Wert im Feld Einzelpreis und dem Wert 1,06 an (addiert 6 % zum Wert in Preis).
=[Anzahl]*[Einzelpreis] | Zeigt das Produkt aus den Werten in den Feldern Anzahl und Einzelpreis an.
=[Umsatz]/ [UmsatzLand] | Zeigt den Quotienten aus den Werten in den Feldern Umsatz und UmsatzLand an.

Anmerkungen

  • In der Einstellung der Steuerelementinhalt-Eigenschaft eines berechneten Steuerelements sollte dem Ausdruck der =-Operator vorangestellt werden. In einer Datenzugriffsseite können Sie den =-Operator weglassen und stattdessen einen Aliasnamen eingeben, beispielsweise Endpreis: [Anzahl]*[Einzelpreis].

  • Verwenden Sie immer einen eindeutigen Namen, wenn Sie die Name-Eigenschaft eines berechneten Steuerelements in einem Formular oder Bericht oder die ID-Eigenschaft eines berechneten Steuerelements in einer Datenzugriffsseite festlegen. Verwenden Sie nicht den Namen oder die ID eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Wenn Sie innerhalb eines Formulars oder Berichts einen Ausdruck definieren, können Sie den Namen eines Steuerelements oder eines Feldes der zugrunde liegenden Datensatzquelle verwenden. In einem innerhalb einer Datenzugriffsseite definierten Ausdruck können Sie nur den Namen eines Feldes verwenden, der in der Datendefinition der Seite enthalten ist.

  • Wenn Sie in einem Ausdruck einen arithmetischen Operator (+, -, *, /) verwenden und der Wert in einem der Steuerelemente im Ausdruck gleich Null ist, ist das Ergebnis des gesamten Ausdrucks gleich Null. Wenn einige Datensätze eines Formulars bzw. eines Berichts in einem der im Ausdruck verwendeten Steuerelemente einen Nullwert enthalten, können Sie den Nullwert unter Verwendung der Funktion Nz in einen Wert ungleich Null konvertieren, z. B.:

    =Nz([Gesamtpreis])+Nz([Frachtkosten])

    Zum Anzeigen weiterer Informationen zur Funktion Nz klicken Sie auf [image] .


Verweisen auf Werte in Formularen und Berichten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen in berechneten Steuerelementen verwenden können.

Ausdruck | Beschreibung
=Formulare![Bestellungen]![Bestell-Nr] | Zeigt den Wert aus dem Steuerelement Bestell-Nr des Formulars Bestellungen an.
=Formulare![Bestellungen]! [Bestellungen Unterformular].Formular! [BestellZwischensumme] | Zeigt den Wert aus dem Steuerelement BestellZwischensumme im Unterformular Bestellungen Unterformular des Formulars Bestellungen an.
=Formulare![Bestellungen]! [Bestellungen Unterformular]! [Artikel-Nr].Spalte(2) | Zeigt den Wert der dritten Spalte in Artikel-Nr, einem mehrspaltigen Listenfeld im Unterformular Bestellungen Unterformular des Formulars Bestellungen, an. (0 bezieht sich auf die erste Spalte, 1 auf die zweite Spalte usw.).
=Formulare![Bestellungen]! [Bestellungen Unterformular]![Preis]*1,06 | Zeigt das Produkt aus dem Wert im Steuerelement Preis im Unterformular Bestellungen Unterformular des Formulars Bestellungen und dem Wert 1,06 an (addiert 6 % zum Wert im Steuerelement Preis).
=Hauptobjekt![Bestell-Nr] | Zeigt den Wert aus dem Steuerelement Bestell-Nr im Hauptformular des aktuellen Unterformulars an.

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke für berechnete Steuerelemente in Berichten.

Ausdruck | Beschreibung
=Berichte![Rechnung]![Bestell-Nr] | Zeigt den Wert aus dem Steuerelement Bestell-Nr des Berichts Rechnung an.
=Berichte![Übersichtsbericht]! [Unterbericht-Übersichtsbericht].Bericht! [Umsätze (Gesamt)] | Zeigt den Wert aus dem Steuerelement Umsätze (Gesamt) aus dem Unterbericht Unterbericht-Übersichtsbericht des Berichts Übersichtsbericht an.
=Hauptobjekt![Bestell-Nr] | Zeigt den Wert aus dem Steuerelement Bestell-Nr aus dem Hauptbericht des aktuellen Unterberichts an.

Anmerkungen

  • Geben Sie in einem berechneten Steuerelement vor dem Ausdruck den Operator = ein.

  • Verwenden Sie beim Einstellen der Eigenschaft Name eines berechneten Steuerelements immer einen eindeutigen Namen. Verwenden Sie nicht den Namen eines der Steuerelemente, die Sie im Ausdruck angegeben haben.


 Zurückgeben eines von zwei möglichen Werten in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Zurückgeben eines von zwei möglichen Werten in Formularen, Berichten und Datenzugriffsseiten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen, Berichten und Datenzugriffsseiten für berechnete Steuerelemente verwenden können.

Ausdruck | Beschreibung
=Wenn([Bestätigt] = "Ja";
"Bestellung bestätigt";
"Bestellung nicht bestätigt") 		Verwendet die Funktion Wenn zum Anzeigen der Meldung "Bestellung bestätigt", wenn der Wert im Feld Bestätigt gleich Ja ist. Ist dies nicht der Fall, wird die Meldung "Bestellung nicht bestätigt" angezeigt.
=Wenn(IstNull([Land]); " "; [Land]) | Verwendet die Funktion Wenn zum Anzeigen einer leeren Zeichenfolge, wenn der Wert im Feld Land gleich Null ist. Ist dies nicht der Fall, wird der Wert aus dem Feld Land angezeigt.
=Wenn(IstNull([Region]);
[Ort] & " " & [PLZ];
[Ort] & " " & [Region] & " " & [PLZ]) 		Verwendet die Funktion Wenn zum Anzeigen der Werte aus den Feldern Ort und PLZ, wenn der Wert im Steuerelement Region gleich Null ist. Ist dies nicht der Fall, werden die Werte aus den Feldern Ort, Region und PLZ angezeigt.
=Wenn(IstNull([Lieferdatum]-[Versanddatum]);
"Prüfen Sie, ob ein Datum fehlt";
[Lieferdatum] - [Versanddatum]) 		Verwendet die Funktion Wenn zum Anzeigen der Meldung "Prüfen Sie, ob ein Datum fehlt", wenn beim Subtrahieren des Wertes aus Versanddatum vom Wert aus Lieferdatum der Wert Null ausgegeben wird; ist dies nicht der Fall, wird die Differenz zwischen den Werten aus den Feldern Lieferdatum und Versanddatum ausgegeben.

Anmerkungen

  • In der Steuerelementinhalt-Eigenschaft eines berechneten Steuerelements sollte dem Ausdruck der =-Operator vorangestellt werden. In einer Datenzugriffsseite können Sie den =-Operator weglassen und stattdessen einen Aliasnamen eingeben, beispielsweise AnzeigenLand: Wenn(IstNull([Land]), " ", [Land]).

  • Verwenden Sie immer einen eindeutigen Namen, wenn Sie die Name-Eigenschaft eines berechneten Steuerelements in einem Formular oder Bericht oder die ID-Eigenschaft eines berechneten Steuerelements in einer Datenzugriffsseite festlegen. Verwenden Sie nicht den Namen eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Wenn Sie innerhalb eines Formulars oder Berichts einen Ausdruck definieren, können Sie den Namen eines Steuerelements oder eines Feldes der zugrunde liegenden Datensatzquelle verwenden. In einem innerhalb einer Datenzugriffsseite definierten Ausdruck können Sie nur den Namen eines Feldes verwenden, der in der Datendefinition der Seite angezeigt wird.


 Aggregatfunktionen in Formularen und Berichten - Beispiele

Aggregatfunktionen in Formularen und Berichten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen und Berichten in berechneten Steuerelementen verwenden können.

Ausdruck | Beschreibung
=Mittelwert([Frachtkosten]) | Verwendet die Funktion Mittelwert zum Anzeigen des Mittelwertes aus allen Werten im Steuerelement Frachtkosten.
=Anzahl([Bestell-Nr]) | Verwendet die Funktion Anzahl zum Anzeigen der Anzahl aller Datensätze im Steuerelement Bestell-Nr.
=Summe([Umsätze]) | Verwendet die Funktion Summe zum Anzeigen der Summe aller Werte aus dem Steuerelement Umsätze.
=Summe([Anzahl]*[Preis]) | Verwendet die Funktion Summe zum Anzeigen des Produkts aus den Werten in den Steuerelementen Anzahl und Preis.
=100*[Umsätze]/ Summe([Umsätze]) | Berechnet den Prozentsatz der Umsätze durch Teilen des Wertes aus dem Steuerelement Umsätze durch die Summe aller Werte aus dem Steuerelement Umsätze. Anmerkung Wenn für die Eigenschaft Format die Einstellung Prozent festgelegt ist, brauchen Sie nicht *100 anzugeben.

Anmerkungen

  • Geben Sie in einem berechneten Steuerelement vor dem Ausdruck den Operator = ein.

  • Verwenden Sie beim Einstellen der Name-Eigenschaft eines berechneten Steuerelements immer einen eindeutigen Namen. Verwenden Sie nicht den Namen eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Sie können den Namen eines Steuerelements nicht in einem Ausdruck verwenden, der eine Aggregatfunktion enthält. Verwenden Sie in diesem Fall nur Feldnamen aus einer Tabelle, einer Abfrage oder einer SQL-Anweisung. Zum Anzeigen von Informationen über die Verwendung von Aggregatfunktionen für berechnete Steuerelemente klicken Sie auf [image] .


 Aggregatfunktionen für Domänen in Formularen und Berichten - Beispiele

Aggregatfunktionen für Domänen in Formularen und Berichten - Beispiele

Die nachstehende Tabelle zeigt Beispiele für Ausdrücke, die Sie in Formularen und Berichten in berechneten Steuerelementen verwenden können.

Ausdruck | Beschreibung
=DomWert("[Kontaktperson]"; "[Lieferanten]"; "[Lieferanten-Nr] = Formulare![Lieferanten-Nr]") | Verwendet die Funktion DomWert zum Anzeigen des Wertes aus dem Feld Kontaktperson der Tabelle Lieferanten unter der Bedingung, dass der Wert aus dem Feld Lieferanten-Nr in der Tabelle dem Wert im Steuerelement Lieferanten-Nr im aktiven Formular entspricht.
=DomWert("[Kontaktperson]"; "[Lieferanten]"; "[Lieferanten-Nr] = Formulare![NeueLieferanten]![Lieferanten-Nr]") | Verwendet die Funktion DomWert zum Anzeigen des Wertes aus dem Feld Kontaktperson der Tabelle Lieferanten unter der Bedingung, dass der Wert im Feld Lieferanten-Nr der Tabelle dem Wert im Steuerelement Lieferanten-Nr im Formular NeueLieferanten entspricht.
=DomSumme("[Preis]"; "[Bestellungen]"; "[Kunden-Code] = 'RATTC'") | Verwendet die Funktion DomSumme zum Anzeigen der Gesamtsumme aller Werte im Feld Preis der Tabelle Bestellungen unter der Bedingung, dass der Wert im Feld Kunden-Code gleich RATTC ist.

Anmerkungen

  • Geben Sie in einem berechneten Steuerelement vor dem Ausdruck den Operator = ein.

  • Verwenden Sie beim Einstellen der Eigenschaft Name eines berechneten Steuerelements immer einen eindeutigen Namen. Verwenden Sie nicht den Namen eines der Steuerelemente, die Sie im Ausdruck angegeben haben.

  • Sie können den Namen eines Steuerelements nicht in einem Ausdruck verwenden, der eine Domän-Aggregatfunktion enthält. Verwenden Sie in diesem Fall nur Feldnamen aus einer Tabelle, einer Abfrage oder einer SQL-Anweisung. Zum Anzeigen von Informationen zur Verwendung von Aggregatfunktionen für berechnete Steuerelemente klicken Sie auf [image] .


 Symbolleisten, Menüleisten und Kontextmenüs

Symbolleisten, Menüleisten und Kontextmenüs

Symbolleisten, Menüleisten und Kontextmenüs erlauben das Strukturieren der Befehle in Microsoft Access, so dass Sie diese schnell finden und einsetzen können. Symbolleisten können entweder nur Schaltflächen oder nur Menüs oder aber eine Kombination aus beiden enthalten. Die eingebaute Menüleiste wird standardmäßig am oberen Rand des Bildschirms angezeigt und enthält Standardmenüs wie Suchen, Bearbeiten und Ansicht.

Access passt Menüs und Symbolleisten automatisch an, indem geprüft wird, wie oft Sie Befehle verwenden. Beim ersten Starten von Access werden die wichtigsten Befehle angezeigt. Wenn Sie dann in Access arbeiten, werden die Menüs und Symbolleisten automatisch angepasst, so dass nur die Befehle und Schaltflächen der Symbolleisten angezeigt werden, die Sie am Häufigsten verwenden. Wenn Sie einen Befehl suchen, den Sie nicht sehr oft verwenden oder bisher noch gar nicht eingesetzt haben, klicken Sie am unteren Menürand auf die Pfeile Doppelte, nach unten zeigende Pfeile , um das Menü zu erweitern, so dass alle Befehle angezeigt werden. Sie können auch einfach auf ein Menü doppelklicken, um es zu erweitern. Wenn Sie ein Menü erweitern, werden alle Menüs so lange erweitert angezeigt, bis Sie einen Befehl auswählen oder eine andere Aktion durchführen. Wenn Sie im erweiterten Menü auf einen Befehl geklickt haben, wird dieser sofort zum angepassten Menü hinzugefügt. Ein Menübefehl wird aus dem angepassten Menü gelöscht, wenn Sie diesen in Access lange nicht verwendet haben. Wenn Sie möchten, können Sie festlegen, dass Access immer für jedes Menü alle Befehle anzeigt.

Symbolleisten können nebeineinander in eine Zeile gesetzt werden. Wenn Sie mehrere Symbolleisten nebeineinaner setzen, können möglicherweise nicht alle Schaltflächen angezeigt werden. Ist nicht genügend Platz vorhanden, werden die zuletzt verwendeten Schaltflächen angezeigt. Sie können die Größe einer Symbolleiste verändern, so dass weitere Schaltflächen angezeigt werden, oder Sie können angeben, dass alle Schaltflächen einer Symbolleiste angezeigt werden. Zum Anzeigen der Liste der Schaltflächen, die nicht auf eine eingebaute, verankerte Symbolleiste passen, klicken Sie am Ende der Symbolleiste auf Weitere Schaltflächen [image] . Wenn Sie eine Schaltfläche verwenden, die nicht auf der Symbolleiste angezeigt wird, wird diese auf die Symbolleiste gesetzt und eine andere Schaltfläche, die lange nicht mehr verwendet wurde, wird in die Liste Weitere Schaltflächen [image] verschoben.

Beim Arbeiten in Access werden die Menüs und Symbolleisten angepasst, so dass die Befehle angezeigt werden, die Sie am Häufigsten verwenden. Wenn Sie möchten, können Sie die Anzeige der Symbol- und Menüleiste zurücksetzen, so dass diese so angezeigt werden, wie sie beim ersten Starten von Access angezeigt wurden.

Sie können Menüs und Symbolleisten auch selbst anpassen. Sie können die eingebaute Menüleiste anpassen, indem Sie Schaltflächen hinzufügen oder entfernen oder indem Sie das Menü an eine andere Stelle verschieben. Zusätzlich zu der Möglichkeit, die eingebaute Menüleiste, eingebaute Kontextmenüs und Symbolleisten anzupassen, können Sie auch eigene Symbolleisten, Menüleisten und Kontextmenüs erstellen.

Zum Erstellen und Anpassen von Symbolleisten, Menüleisten und Kontextmenüs sowie zum Einstellen von Eigenschaften, die das Aussehen und das Verhalten dieser Leisten und Menüs bestimmen, verwenden Sie das Dialogfeld Anpassen. Sie öffnen dieses Dialogfeld, indem Sie im Menü Ansicht auf den Befehl Symbolleisten zeigen und anschließend auf Anpassen klicken.

Anmerkung In den Tools PivotTable-Liste, Kalkulationstabelle und Diagramm einer Datenzugriffsseite unterscheiden sich einige Funktionen der Symbolleiste von den normalen Funktionen in Microsoft Access.

Weitere Informationen

So verwenden Sie Symbolleisten

So verwenden Sie Menüleisten und Kontextmenüs


 Arbeiten mit Symbolleisten

Arbeiten mit Symbolleisten

Was möchten Sie tun?

Informationen zu Symbolleisten, Menüleisten und Kontextmenüs anzeigen

Eine Symbolleiste, Menüleiste oder ein Kontextmenü ein- oder ausblenden

Eine benutzerdefinierte Symbolleiste für die aktuelle Datenbank erstellen

Eine Symbolleiste für alle Datenbanken erstellen

Eine Symbol- oder Menüleiste verschieben

Eine Schaltfläche zu einer Symbolleiste hinzufügen

Eine Symbolleistenschaltfläche löschen

Eine Symbolleistenschaltfläche verschieben oder kopieren

Das Bild oder den Text auf einer Symbolleistenschaltfläche oder in einem Menübefehl ändern

Symbol- oder Menüleisten, einzelne Schaltflächen, Befehle oder Menüs wiederherstellen

Fehler in Symbolleisten, Menüleisten und Kontextmenüs behandeln

Anmerkung Zum Anzeigen spezieller Informationen zu Symbolleisten klicken Sie in der Symbolleiste auf Office-Assistent [image] , und geben Sie dann eine detaillierte Frage ein.


 Arbeiten mit Menüleisten und Kontextmenüs

Arbeiten mit Menüleisten und Kontextmenüs

Was möchten Sie tun?

Informationen zu Symbolleisten, Menüleisten und Kontextmenüs anzeigen

Eine Symbolleiste, Menüleiste oder ein Kontextmenü ein- oder ausblenden

Eine benutzerdefinierte Menüleiste für die aktuelle Datenbank erstellen

Ein benutzerdefiniertes Kontextmenü für die aktuelle Datenbank erstellen

Menümakros aus früheren Versionen von Microsoft Access in Menüleisten und Kontextmenüs konvertieren

Ein benutzerdefiniertes Menü zu einer Menü- oder Symbolleiste hinzufügen

Ein Menü in eine Menü- oder Symbolleiste verschieben oder kopieren

Ein Menü aus einer Menü- oder Symbolleiste löschen

Einen Menübefehl verschieben oder kopieren

Einen Befehl zu einem Menü hinzufügen

Einen Befehl aus einem Menü löschen

Das Bild oder den Text auf einer Symbolleistenschaltfläche oder in einem Menübefehl ändern

Symbol- oder Menüleisten, einzelne Schaltflächen, Befehle oder Menüs wiederherstellen

Fehler in Symbolleisten, Menüleisten und Kontextmenüs behandeln

Anmerkung Zum Anzeigen spezieller Informationen zu Menüleisten oder Kontextmenüs klicken Sie in der Symbolleiste auf Office-Assistent [image] , und geben Sie dann eine detaillierte Frage ein.


Erstellen einer benutzerdefinierten Menüleiste für die aktuelle Access-Datenbank oder das aktuelle Access-Projekt

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Neu.

  3. Geben Sie im Feld Name der Symbolleiste den gewünschten Namen ein, und klicken Sie dann auf OK.

  4. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  5. Klicken Sie im Listenfeld Typ auf Menüleiste.

  6. Stellen Sie die anderen Eigenschaften wie gewünscht ein, und klicken Sie dann auf Schließen.

    Die neue Menüleiste wird nun rechts vom Dialogfeld Anpassen angezeigt.

  7. Um die Menüleiste zu vervollständigen, führen Sie die folgenden Schritte aus:
    • Fügen Sie benutzerdefinierte Menüs hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Fügen Sie ein integriertes Menü hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkungen

  • Microsoft Access unterstützt Menüleistenmakros für Anwendungen, die mit einer früheren Version von Microsoft Access erstellt worden sind. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können die benutzerdefinierte Menüleiste in ein Formular, einen Bericht oder ein Steuerelement einbinden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] . Andererseits können Sie die Menüleiste auch als globale Menüleiste definieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Erstellen eines benutzerdefinierten Kontextmenüs für die aktuelle Access-Datenbank oder das aktuelle Access-Projekt

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Neu.

  3. Geben Sie im Feld Symbolleistenname den gewünschten Namen ein, und klicken Sie dann auf OK.

  4. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  5. Klicken Sie im Listenfeld Typ auf Popup.

  6. Stellen Sie die Eigenschaft AllowCustomizing wie gewünscht ein, und klicken Sie dann auf Schließen.

    Microsoft Access fügt das Kontextmenü zur Menüleiste Kontextmenüs hinzu, aus der Sie alle Kontextmenüs anpassen können.

  7. Klicken Sie in der Registerkarte Symbolleisten im Feld Symbolleisten auf Kontextmenüs.

  8. Klicken Sie in der Menüleiste Kontextmenüs auf die Kategorie Benutzerdefiniert.

  9. Um das Menü zu vervollständigen, führen Sie die folgenden Schritte aus.
    • Fügen Sie Befehle aus dem Dialogfeld Anpassen hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Verschieben oder kopieren Sie Befehle aus anderen Menüs. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkungen

  • Microsoft Access unterstützt Menüleistenmakros für Anwendungen, die mit einer früheren Version von Microsoft Access erstellt worden sind. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können das benutzerdefinierte Kontextmenü in ein Formular, einen Bericht oder ein Steuerelement einbinden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] . Andererseits können Sie das Menü auch als globales Kontextmenü definieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Importieren benutzerdefinierter Symbolleisten und Menüs aus einer anderen Access-Datenbank oder einem anderen Access-Projekt

Importieren benutzerdefinierter Symbolleisten und Menüs aus einer anderen Access-Datenbank oder einem anderen Access-Projekt

Sie können alle benutzerdefinierten Menüs und Symbolleisten aus einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt importieren. Microsoft Access importiert eine Symbol- oder Menüleiste oder ein Kontextmenü jedoch nur dann, wenn dessen Name nicht mit einem Namen in der Datenbank identisch ist, in die Sie importieren.

  1. Öffnen Sie eine Datenbank.

  2. Zeigen Sie im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

  3. Stellen Sie sicher, dass im Feld Dateityp die Option Microsoft Access (*.mdb, *.adp) gewählt ist.

  4. Wählen Sie im Feld Suchen in das Laufwerk und den Ordner für die Microsoft Access-Datenbank (.mdb oder .adp) aus, aus der Sie importieren möchten, und doppelklicken Sie dann auf die gewünschte Datenbank.

  5. Klicken Sie im Dialogfeld Objekt importieren auf Optionen.

  6. Klicken Sie unter Importieren auf Menüs und Symbolleisten.


 Konvertieren eines Menüleistenmakros aus einer vorherigen Programmversion in eine Menüleiste oder ein Kontextmenü

Konvertieren eines Menüleistenmakros aus einer vorherigen Programmversion in eine Menüleiste oder ein Kontextmenü

Das folgende Verfahren erstellt auf der Basis von Makros, die Sie in einer früheren Version von Microsoft Access erstellt haben, eine Menüleiste oder ein Kontextmenü im neuen Microsoft Access-Format.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] und dann auf den Namen des Makros, für das Sie eine Menüleiste oder ein Kontextmenü erstellen möchten.

    Zum Erstellen einer Menüleiste oder eines Kontextmenüs im neuen Format für Makros, die Sie zuvor für benutzerdefinierte Menüs verwendet haben, wählen Sie nur das Menüleistenmakro der obersten Ebene aus. Sie müssen nicht die Makrogruppe für jedes Menü auswählen, das in der Menüleiste angezeigt wird.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Menü aus Makro erstellen oder auf Kontextmenü aus Makro erstellen.

Anmerkungen

  • Jetzt können Sie die Menüleiste oder das Kontextmenü unter Verwendung des Dialogfelds Anpassen ändern. Zum Anzeigen dieses Dialogfelds zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Anpassen.

  • Microsoft Access löscht das Originalmakro (bzw. die Makros, wenn Sie mit einem Menüleistenmakro und den zugeordneten Makrogruppen arbeiten) nach dem Erstellen der neuen Menüleiste oder des neuen Kontextmenüs nicht. Die neue Menüleiste basiert nach wie vor auf dem/den Originalmakro(s). Dies gilt jedoch nicht für Makros, die nur Aktionen HinzufügenMenü oder Aktionen AusführenBefehl (früher AusführenMenübefehl) enthalten.


 Erstellen einer Symbolleiste auf der Basis eines Makros

Erstellen einer Symbolleiste auf der Basis eines Makros

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] und dann auf den Namen des Makros, für das Sie eine Symbolleiste erstellen möchten.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Symbolleiste aus Makro erstellen.

Anmerkung Microsoft Access löscht das Originalmakro (bzw. die Makros, wenn Sie mit einem Menüleistenmakro und den zugeordneten Makrogruppen arbeiten) nach dem Erstellen der neuen Symbolleiste nicht. Die neue Symbolleiste basiert nach wie vor auf dem/den Originalmakro(s). Dies gilt jedoch nicht für Makros, die nur Aktionen HinzufügenMenü oder Aktionen AusführenBefehl (früher AusführenMenübefehl) enthalten.


Verwalten oder Aktualisieren von Menüs, die zuvor mit Makros erstellt worden sind

Microsoft Access 2000 unterstützt nach wie vor Menüleistenmakros für Anwendungen, die mit einer Version von Microsoft Access vor Access 2000 erstellt worden sind. In Access 2000 und späteren Versionen werden Menüleisten und Kontextmenüs (sowie Symbolleisten) mit Hilfe des Dialogfelds Anpassen erstellt und angepasst. Zum Anzeigen dieses Dialogfelds zeigen Sie im Menü Ansicht auf Symbolleisten. Sie können das Dialogfeld auch zum Anpassen der eingebauten Menüleiste und Symbolleisten verwenden.

Anmerkung Sie können zum Arbeiten mit Menüleisten, Kontextmenüs und Symbolleisten auch Visual Basic für Applikationen verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Was möchten Sie tun?

Konvertieren von Menümakros aus früheren Versionen von Microsoft Access in Menüleisten und Kontextmenüs

Vorhandene Menüleistenmakros unter Verwendung der Aktion HinzufügenMenü verwalten

Informationen zu Makros für Menüleisten in einer konvertierten Microsoft Access-Datenbank anzeigen


Umbenennen eines benutzerdefinierten Kontextmenüs

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Klicken Sie im Feld Ausgewählte Symbolleiste auf das Kontextmenü, das Sie umbenennen möchten.

  4. Geben Sie im Feld Symbolleistenname den neuen Namen ein.


Umbenennen einer benutzerdefinierten Symbol- oder Menüleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Wählen Sie auf der Registerkarte Symbolleisten den Namen der Symbol- oder Menüleiste aus.

    Anmerkung Das Aktivieren oder Deaktivieren eines Kontrollkästchens im Dialogfeld Symbolleisten blendet die entsprechende Symbol- oder Menüleiste ein bzw. aus.

  3. Klicken Sie auf Umbenennen.

  4. Geben Sie im Feld Name der Symbolleiste den neuen Namen ein.

Anmerkung Eingebaute Symbol- und Menüleisten können nicht umbenannt werden.


Löschen eines benutzerdefinierten Kontextmenüs

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Klicken Sie im Feld Ausgewählte Symbolleiste auf den Namen des benutzerdefinierten Kontextmenüs, das Sie löschen möchten.

  4. Ändern Sie im Listenfeld Typ den Typ in Symbolleiste, und schließen Sie dann das Eigenschaftenfenster.

    Der Name des Kontextmenüs wird jetzt im Feld Symbolleisten auf der Registerkarte Symbolleisten angezeigt.

  5. Wählen Sie im Feld Symbolleisten den Namen Ihres benutzerdefinierten Kontextmenüs aus, und klicken Sie dann auf Löschen.


Löschen einer benutzerdefinierten Symbol- oder Menüleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Wählen Sie auf der Registerkarte Symbolleisten die Symbol- oder Menüleiste aus, die Sie löschen möchten.

  3. Klicken Sie auf Löschen.

Anmerkung Eingebaute Symbol- und Menüleisten können nicht gelöscht werden. Wenn Sie eine eingebaute Symbol- oder Menüleiste auswählen, steht die Schaltfläche Löschen nicht zur Verfügung. Statt dessen wird die Schaltfläche Zurücksetzen aktiviert. Wenn Sie auf diese Schaltfläche klicken, werden in der Symbol- oder Menüleiste alle Standardschaltflächen bzw. Standardmenüs und -untermenüs wiederhergestellt.


 Hinzufügen einer Schaltfläche zu einer Symbolleiste

Hinzufügen einer Schaltfläche zu einer Symbolleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbolleiste an, zu der Sie eine Schaltfläche hinzufügen möchten.
  3. Klicken Sie auf die Registerkarte Befehle.

  4. Klicken Sie im Feld Kategorien auf eine Kategorie für den Befehl, den die Schaltfläche ausführen soll.
    Aufgabe | Ausführung
    Hinzufügen einer eingebauten Schaltfläche | Klicken Sie auf die Kategorie für das entsprechende Menü oder die entsprechende Ansicht.
    Hinzufügen von Navigationsschaltflächen für HTML-Seiten | Klicken Sie auf Web.
    Hinzufügen von Schaltflächen zum Arbeiten mit Quellcode-Kontrolle | Klicken Sie auf Quellcode-Kontrolle
    Hinzufügen einer Schaltfläche zum Erstellen von ActiveX-Steuerelementen | Klicken Sie auf ActiveX Stuerelemente.
    Hinzufügen einer Schaltfläche, die ein Formular, einen Bericht oder ein anderes Objekt in dessen Standardansicht anzeigt Klicken Sie auf eine der folgenden Optionen: Alle Tabellen, Alle Abfragen, Alle Formulare, Alle Berichte, Alle Webseiten.

    Wenn Sie gerade ein Microsoft Access-Projekt bearbeiten, werden die folgenden Optionen angezeigt: Alle Datenbankdiagramme, Alle Ansichten und Alle gespeicherten Prozeduren.
    Hinzufügen einer Schaltfläche, die ein Makro ausführt | Klicken Sie auf Alle Makros.

  5. Ziehen Sie die gewünschte Schaltfläche, das Objekt oder das ActiveX-Steuerelement aus dem Feld Befehle in die angezeigte Symbolleiste.

Anmerkungen

  • Sie können auch Schaltflächen zum Ausführen von Visual Basic-Funktionen hinzufügen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Um schnell eine Schaltfläche hinzuzufügen, die ein Datenbankobjekt öffnet, ziehen Sie das Objekt aus dem Datenbankfenster in die Symbolleiste.

  • Sie können auf der Schaltfläche Zugriffstastentext anzeigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Microsoft Access kann automatisch eine Symbolleiste erstellen, die vorhandene Makros ausführt. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Tipp Wenn Sie schnell eine eingebaute Schaltfläche zu einer eingebauten Symbolleiste hinzufügen möchten, klicken Sie in einer verankerten Symbolleiste auf Weitere Schaltflächen [image], oder klicken Sie auf den Pfeil Pfeil-nach-unten in der oberen linken Ecke einer unverankerten Symbolleiste , klicken Sie auf Schaltflächen hinzufügen oder entfernen und aktivieren Sie dann das Kontrollkästchen neben der Schaltfläche, die Sie hinzufügen möchten.


Hinzufügen einer benutzerdefinierten Schaltfläche zum Ausführen einer Visual Basic-Funktion zu einer Symbolleiste

  1. Erstellen Sie die Funktion, die mit der Schaltfläche ausgeführt werden soll.

    Wie wird's gemacht?

  2. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  3. Zeigen Sie gegebenenfalls die Symbolleiste an, zu der Sie die Schaltfläche hinzufügen möchten.

    Wie wird's gemacht?

  4. Klicken Sie im Dialogfeld Anpassen auf die Registerkarte Befehle.

  5. Klicken Sie im Feld Kategorien auf Datei.

  6. Ziehen Sie den Befehl Benutzerdefiniert aus dem Feld Befehle in die angezeigte Symbolleiste.

  7. Klicken Sie mit der rechten Maustaste im geöffneten Dialogfeld Anpassen auf die Schaltfläche in der Symbolleiste, und geben Sie dann im Kontextmenü im Feld Name einen neuen Namen für die Schaltfläche ein.

  8. Klicken Sie im selben Kontextmenü auf Eigenschaften.

  9. Geben Sie im Feld Bei Aktion den Namen der Funktion ein, die in dem Format =Funktionsname() ausgeführt werden soll. Geben Sie z.B. für eine Funktion namens BeschriftungFestlegen Folgendes ein: =BeschriftungFestlegen(). Für eine eingebaute Funktion geben Sie den Namen der Funktion und alle erforderlichen Argumente ein, z. B. =MsgBox(IIf(Time()>#12:0:0#, "Guten Tag", "Guten Morgen")).

  10. Stellen Sie gegebenenfalls weitere Eigenschaften für die Schaltfläche ein.


Hinzufügen eines benutzerdefinierten Befehls zum Ausführen einer Visual Basic-Funktion zu einem Menü

  1. Erstellen Sie die Funktion, die Sie mit dem Befehl ausführen möchten.

    Wie wird's gemacht?

  2. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  3. Zeigen Sie die Menüleiste, das Kontextmenü oder die Symbolleiste, die das hinzuzufügende Menü enthält, gegebenenfalls an.

    Wie wird's gemacht?

  4. Klicken Sie im Dialogfeld Anpassen auf die Registerkarte Befehle.

  5. Klicken Sie im Feld Kategorien auf Datei.

  6. Ziehen Sie den Befehl Benutzerdefiniert aus dem Feld Befehle über das Menü in der Menüleiste oder der Symbolleiste oder unter die entsprechende Kategorie in der Symbolleiste Kontextmenüs. Wenn das Menü eine Liste von Menübefehlen (oder, wenn es neu ist, ein leeres Feld) anzeigt, zeigen Sie auf die Stelle im Menü, an der der Befehl angezeigt werden soll, und lassen Sie dann die Maustaste los.

  7. Klicken Sie mit der rechten Maustaste im geöffneten Dialogfeld Anpassen auf den Befehl im Menü, und geben Sie dann im Kontextmenü im Feld Name einen neuen Namen für den Befehl ein.

  8. Klicken Sie im selben Kontextmenü auf Eigenschaften.

  9. Geben Sie im Feld Bei Aktion den Namen der Funktion ein, die in dem Format =Funktionsname()ausgeführt werden soll. Geben Sie z.B. für eine Funktion namens BeschriftungFestlegen Folgendes ein: =BeschriftungFestlegen(). Für eine eingebaute Funktion geben Sie den Namen der Funktion und alle erforderlichen Argumente ein, z. B. =MsgBox(IIf(Time()>#12:0:0#, "Guten Tag", "Guten Morgen")).

  10. Stellen Sie gegebenenfalls weitere Eigenschaften für den Befehl ein.

Anmerkung Wenn Sie einen Befehl zu einem eingebauten Menü (z.B. zum Menü Bearbeiten) hinzufügen, erscheint dieser Befehl in allen Ansichten, in denen dieses eingebaute Menü angezeigt wird.


 Hinzufügen eines Befehls zu einem Menü

Hinzufügen eines Befehls zu einem Menü

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menüleiste, das Kontextmenü oder die Symbolleiste an, zu der Sie einen Befehl hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Befehle.

  4. Führen Sie im Feld Kategorien einen der folgenden Schritte aus:
    Aufgabe | Ausführung
    Hinzufügen eines eingebauten Befehls | Klicken Sie auf das entsprechende Menü oder die Ansichtskategorie.
    Hinzufügen von Schaltflächen zum Navigieren in HTML-Seiten | Klicken Sie auf Web.
    Hinzufügen von Schaltflächen zum Arbeiten mit Quellcode | Klicken Sie auf Quellcode-Kontrolle
    Hinzufügen eines Befehls zum Erstellen von ActiveX-Steuerelementen | Klicken Sie auf ActiveX Steuerelementes.
    Hinzufügen einer Schaltfläche, die ein Formular, einen Bericht oder ein anderes Objekt in dessen Standardansicht anzeigt Klicken Sie auf eine der folgenden Schaltflächen: Alle Tabellen, Alle Abfragen, Alle Formulare, Alle Berichte, Alle Webseiten.

    Wenn Sie gerade in einem Microsoft Access-Projekt arbeiten, werden die folgenden Optionen angezeigt: Alle Datenbankdiagramme, Alle Ansichten und Alle gespeicherten Prozeduren.
    Hinzufügen eines Befehls, der ein Makro ausführt | Klicken Sie auf Alle Makros.
  5. Ziehen Sie den gewünschten Befehl aus dem Feld Befehle über das Menü in die Menüleiste, in die Symbolleiste Kontextmenü oder in eine andere Symbolleiste. Wenn das Menü eine Liste von Befehlen anzeigt, zeigen Sie auf die Stelle, an der der Befehl im Menü stehen soll, und lassen dann die Maustaste los.

Anmerkungen

  • Sie können auch einen Befehl hinzufügen, der eine Visual Basic-Funktion ausführt. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können Zugriffstastentext für den Befehl anzeigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie einen Befehl zu einem Menü (z.B. zum Menü Bearbeiten) hinzufügen, wird der Befehl in allen Ansichten angezeigt, in denen dieses Menü eingeblendet wird.


Hinzufügen eines Untermenüs zu einem integrierten oder einem benutzerdefinierten Menü

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbolleiste oder Menüleiste mit dem Menü, zu dem Sie ein Untermenü hinzufügen möchten, gegebenenfalls an.

    Wie wird's gemacht?

  3. Klicken Sie im Dialogfeld Anpassen auf die Registerkarte Befehle.

  4. Klicken Sie im Feld Kategorien auf Neues Menü.

  5. Ziehen Sie aus dem Feld Befehle das Neue Menü über das Menü, zu dem Sie das Untermenü hinzufügen möchten, bis das Menü der obersten Ebene aufklappt, und fügen Sie das Neue Menü dann an der gewünschten Position ein.

  6. Klicken Sie mit der rechten Maustaste auf das neue Untermenü, und geben Sie dann im Kontextmenü in das Feld Name einen Namen ein. Drücken Sie die EINGABETASTE.

  7. Vervollständigen Sie das Menü durch Ausführen der folgenden Schritte:
    • Hinzufügen von Befehlen aus dem Dialogfeld Anpassen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Verschieben oder Kopieren von Befehlen aus anderen Menüs. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Hinzufügen eines eingebauten Menüs zu einer Symbol- oder Menüleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menü- oder Symbolleiste an, der Sie ein eingebautes Menü hinzufügen möchten.

    Wie wird's gemacht?

  3. Klicken Sie auf die Registerkarte Befehle.

  4. Klicken Sie im Feld Kategorien auf Eingebaute Menüs.

  5. Ziehen Sie das gewünschte Menü aus dem Feld Befehle auf die Symbol- oder Menüleiste.

Anmerkung Wenn ein Menübefehl im Feld Befehle nicht angezeigt wird, können Sie diesen verfügbar machen, indem Sie im Feld Kategorien auf Eingebaute Menüs klicken, und dann zur Symbol- oder Menüleiste das eingebaute Menü hinzufügen, das den betreffenden Befehl enthält. Wenn Sie jedoch ein eingebautes Menü auf der Symbol- oder Menüleiste ändern, wird diese Änderungen für alle Ansichten, in denen dieses Menü angezeigt wird, übernommen.


Hinzufügen eines benutzerdefinierten Menüs zu einer Menü- oder Symbolleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menü- oder Symbolleiste an, zu der Sie ein benutzerdefiniertes Menü hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Befehle.

  4. Klicken Sie im Feld Kategorien auf Neues Menü.

  5. Ziehen Sie die Option Neues Menü aus dem Feld Befehle in die angezeigte Menü- oder Symbolleiste.

  6. Klicken Sie mit der rechten Maustaste in der Menü- oder Symbolleiste auf das neue Menü, und geben Sie dann im Kontextmenü im Feld Name einen Namen ein. Drücken Sie die EINGABETASTE.

  7. Zum Vervollständigen des Menüs führen Sie die folgenden Schritte aus:
    • Fügen Sie Befehle aus dem Dialogfeld Anpassen hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Verschieben oder Kopieren Sie Befehle aus anderen Menüs. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Umbenennen eines Menübefehls oder einer Symbolleistenschaltfläche

Umbenennen eines Menübefehls oder einer Symbolleistenschaltfläche

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü mit dem Menübefehl oder der Symbolleistenschaltfläche an, den/die Sie ändern möchten.

  3. Öffnen Sie gegebenenfalls das Dialogfeld Anpassen, und führen Sie dann einen der folgenden Schritte aus:
    • Klicken Sie zum Umbenennen eines Menübefehls in der Menü- oder Symbolleiste auf das Menü, oder klicken Sie auf das Kontextmenü, das den Befehl enthält, den Sie umbenennen möchten. Klicken Sie mit der rechten Maustaste auf den Menübefehl, den Sie umbenennen möchten, geben Sie im Kontextmenü im Feld Name einen neuen Namen ein, und drücken Sie dann die EINGABETASTE.

    • Klicken Sie zum Umbenennen einer Symbolleistenschaltfläche mit der rechten Maustaste auf die Symbolleiste, geben Sie im Kontextmenü im Feld Name einen neuen Namen ein, und drücken Sie dann die EINGABETASTE.

Anmerkungen

  • Wenn eine Symbolleistenschaltfläche keinen Text anzeigt, sehen Sie den Namen nur dann, wenn Sie den QuickInfo anzeigen. Um Informationen zum Anzeigen von Text, einem Symbol oder von Text und Symbol zusammen auf einer Symbolleistenschaltfläche anzuzeigen, klicken Sie auf [image] .

  • Wenn Sie einen neuen Namen für einen Menübefehl oder für eine Symbolleistenschaltfläche angeben, können Sie eine Zugriffstaste zuweisen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Löschen einer Symbolleistenschaltfläche

Löschen einer Symbolleistenschaltfläche

  1. Zeigen Sie die Symbolleiste an, die Sie ändern möchten.
  2. Wenn das Dialogfeld Anpassen geöffnet ist, ziehen Sie die Schaltfläche aus der Symbolleiste weg von allen anderen Symbolleisten oder der Menüleiste. Wenn das Dialogfeld geschlossen ist, halten Sie beim Ziehen der Schaltfläche die ALT-TASTE gedrückt.

Anmerkung Wenn Sie eine integrierte Schaltfläche löschen, steht diese auch nach dem Löschen noch im Dialogfeld Anpassen zur Verfügung. Wenn Sie jedoch eine benutzerdefinierte Schaltfläche löschen, wird diese dauerhaft gelöscht. Zum Entfernen und Speichern einer Schaltfläche, die später wieder verwendet werden soll, erstellen Sie eine Symbolleiste zum Speichern von derzeit nicht benötigten Schaltflächen, verschieben die Schaltfläche in diese Speichersymbolleiste und blenden die Symbolleiste dann aus.

Tipp Wenn Sie schnell eine eingebaute Schaltfläche aus einer integrierten Symbolleiste löschen möchen, klicken Sie auf einer verankerten Symbolleiste auf Weitere Schaltflächen [image] oder klicken Sie in der oberen linken Ecke einer unverankerten Symbolleiste auf den Pfeil Pfeil-nach-unten . Klicken Sie dann auf Schaltflächen hinzufügen oder entfernen, und deaktivieren Sie das Kontrollkästchen neben der Schaltfläche, die Sie entfernen möchten.


Löschen eines Befehls aus einem Menü

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menüleiste, das Kontextmenü oder die Symbolleiste an, die den zu löschenden Menübefehl enthält.
  3. Öffnen Sie gegebenenfalls das Dialogfeld Anpassen, und klicken Sie in der Menü- oder Symbolleiste auf das Menü, oder klicken Sie auf das Kontextmenü, das den zu löschenden Befehl enthält.

  4. Ziehen Sie den zu löschenden Befehl aus dem Menü weg von allen anderen Menüs oder Symbolleisten.

Anmerkung Wenn Sie einen Befehl aus einem eingebauten Menü (z.B. dem Menü Bearbeiten) löschen, wird der Befehl in allen Ansichten, in denen vorher das Menü mit diesem Befehl angezeigt wurde, gelöscht.


Löschen eines Menüs aus einer Menü- oder Symbolleiste

  1. Zeigen Sie die Symbol- oder Menüleiste an, aus der Sie ein Menü löschen möchten.
  2. Wenn das Dialogfeld Anpassen geöffnet ist, ziehen Sie das Menü aus der Menü- oder Symbolleiste weg von allen anderen Symbol- oder Menüleisten. Wenn das Dialogfeld geschlossen ist, halten Sie beim Ziehen des Menüs die ALT-TASTE gedrückt.

Tipp Wenn Sie ein integriertes Menü löschen, steht dieses auch nach dem Löschen noch im Dialogfeld Anpassen zur Verfügung. Wenn Sie jedoch ein benutzerdefiniertes Menü löschen, wird dieses dauerhaft gelöscht. Zum Entfernen und Speichern eines Menüs, das später wieder verwendet werden soll, erstellen Sie eine Symbolleiste zum Speichern von derzeit nicht benötigten Menüs, verschieben das Menü in diese Speichersymbolleiste und blenden die Symbolleiste dann aus.


 Automatisches Wählen einer selektierten Telefonnummer mit Microsoft Access

Automatisches Wählen einer selektierten Telefonnummer mit Microsoft Access

Sie müssen über ein funktionierendes Hayes- oder Hayes-kompatibles Modem verfügen, um diese Prozedur verwenden zu können.

  1. Öffnen Sie eine Tabelle oder ein Formular in der Datenblattansicht, oder öffnen Sie ein Formular in der Formularansicht.

  2. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  3. Klicken Sie im Dialogfeld Anpassen auf die Registerkarte Befehle.

  4. Klicken Sie in der Liste Kategorien auf Datensätze.

  5. Ziehen Sie die Schaltfläche AutoWähler [image] auf die Symbolleiste der Formularansicht oder der Datenblattansicht oder auf eine benutzerdefinierte Symbolleiste.

  6. Klicken Sie auf Schließen.

  7. Suchen Sie in dem Formular oder Datenblatt die Telefonnummer aus, die Sie anwählen möchten.

  8. Klicken Sie in der Symbolleiste auf AutoWähler [image] .

  9. Überprüfen Sie, ob die Telefonnummer korrekt eingegeben ist, und klicken Sie anschließend auf OK.

Anmerkung Sie können Ihre Modem-Optionen ändern, indem Sie im Dialogfeld AutoWähler auf Setup klicken.


Ändern des Bildes oder Textes auf einer Symbolleistenschaltfläche oder einem Menübefehl

Auf einer Symbolleistenschaltfläche können Sie Text, ein Symbol oder beides anzeigen. Auf einem Menübefehl können Sie ein Symbol zusammen mit Text oder nur Text anzeigen. Sie können den Text, der auf einer Symbolleistenschaltfläche oder auf einem Menübefehl angezeigt wird, ändern. Ebenso können Sie das Bild für eine Symbolleistenschaltfläche oder einen Menübefehl ändern. Dies gilt jedoch nicht für diejenigen, die eine Liste oder ein Menü anzeigen, wenn Sie darauf klicken. Sie können zum Ändern des Bildes Bilder von anderen Symbolleistenschaltflächen oder Menübefehlen kopieren und einfügen, aus einer Liste vordefinierter Bilder wählen oder ein eigenes Bild in einem Grafikprogramm erstellen und dieses dann auf der Schaltfläche oder dem Menübefehl einfügen. Darüber hinaus können Sie ein vorhandenes Symbolleistenschaltflächen- oder Menübefehlbild bearbeiten.

Was möchten Sie tun?

Anzeigen von Text oder von einem Symbol zusammen mit Text auf einem Menübefehl

Anzeigen von Text, von einem Symbol oder von Text und Symbol zusammen auf einer Symbolleistenschaltfläche

Umbenennen eines Menübefehls oder einer Symbolleistenschaltfläche

Kopieren eines Bildes von einer Symbolleistenschaltfläche oder einem Menübefehl auf eine andere Symbolleistenschaltfläche oder einen anderen Menübefehl

Kopieren eines Bildes aus einem Grafikprogramm auf eine Symbolleistenschaltfläche oder auf einen Menübefehl

Wählen aus einer Liste vordefinierter Bilder für eine Symbolleistenschaltfläche oder für einen Menübefehl

Bearbeiten eines Bildes auf einer Symbolleistenschaltfläche oder auf einem Menübefehl


Auswählen eines vorhandenen Bildes für eine Symbolleistenschaltfläche oder einen Menübefehl

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbolleiste, die Menüleiste oder das Kontextmenü mit dem Symbolleistensymbol oder dem Menübefehlbild, das Sie ändern möchten, an.

    Wie wird's gemacht?

  3. Führen Sie im geöffneten Dialogfeld Anpassen einen der folgenden Schritte aus:
    • Klicken Sie zum Ändern eines Symbolleistenbilds mit der rechten Maustaste auf die Symbolleiste, zeigen Sie im Kontextmenü auf Schaltflächensymbol ändern, und klicken Sie dann auf ein Bild.

    • Klicken Sie zum Ändern eines Menübefehlbilds auf den Menünamen in der Menüleiste oder der Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl mit dem zu ändernden Bild enthält. Klicken Sie mit der rechten Maustaste auf den Menübefehl, zeigen Sie im Kontextmenü auf Schaltflächensymbol ändern, und klicken Sie dann auf ein Bild.

Anmerkung Wenn Sie das Bild für einen Befehl in einem eingebauten Menü (z.B. im Menü Bearbeiten) ändern, erscheint das Bild in allen Ansichten, in denen dieses Menü mit diesem Befehl angezeigt wird.


Verschieben oder Kopieren einer Symbolleistenschaltfläche

  1. Zeigen Sie die Symbolleiste an, mit der Schaltfläche, die Sie verschieben oder kopieren möchten, sowie die Symbolleiste, in die Sie die Schaltfläche verschieben oder kopieren möchten.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wenn das Dialogfeld Anpassen geöffnet ist, ziehen Sie zum Verschieben einer Symbolleistenschaltfläche diese an eine neue Position in derselben oder in einer anderen Symbolleiste. Wenn das Dialogfeld nicht geöffnet ist, halten Sie die ALT-TASTE gedrückt und ziehen dann die Schaltfläche an die neue Position.

    • Wenn das Dialogfeld Anpassen geöffnet ist, halten Sie zum Kopieren die STRG-TASTE gedrückt und ziehen dann die Schaltfläche an die neue Position. Wenn das Dialogfeld nicht geöffnet ist, halten Sie STRG+ALT gedrückt und ziehen dann die Schaltfläche an die neue Position.

Anmerkung Sie können eine Schaltfläche aus einer Symbolleiste auch in ein Menü verschieben oder kopieren.


Verschieben von Menüs oder Menübefehlen

Was möchten Sie tun?

Ein Menü in eine Menüleiste oder eine Symbolleiste kopieren oder verschieben

Einen Menübefehl kopieren oder verschieben


Verschieben oder Kopieren eines Menübefehls

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menüleiste, das Kontextmenü oder die Symbolleiste an, das bzw. die das Menü mit dem Befehl enthält, den Sie verschieben oder kopieren möchten. Wenn Sie den Befehl in eine andere Symbol- oder Menüleiste verschieben oder kopieren, müssen Sie auch diese Leiste anzeigen.
  3. Öffnen Sie gegebenenfalls das Dialogfeld Anpassen, und klicken Sie auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl enthält, den Sie kopieren oder verschieben möchten.

  4. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie den Befehl verschieben möchten, ziehen Sie ihn über das Menü, in dem Sie ihn ablegen möchten. Wenn das Menü eine Liste von Befehlen (oder, wenn es leer ist, ein leeres Feld) anzeigt, zeigen Sie auf die Stelle, an der der Befehl im Menü angezeigt werden soll, und lassen dann die Maustaste los.

    • Wenn Sie den Befehl kopieren möchten, halten Sie die STRG-TASTE gedrückt und ziehen dann den Befehl über das Menü, in dem Sie ihn ablegen möchten. Wenn das Menü eine Liste von Befehlen anzeigt, zeigen Sie auf die Stelle, an der der Befehl im Menü stehen soll, und lassen dann die Maustaste los.

Anmerkung Wenn Sie einen Befehl in ein eingebautes Menü (z.B. in das Menü Bearbeiten) verschieben oder kopieren, wird der Befehl in diesem Menü in allen Ansichten angezeigt, in denen das Menü eingeblendet wird.


Umbenennen eines Menüs in einer Menü- oder Symbolleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menü- oder Symbolleiste an, die das Menü enthält, das Sie umbenennen möchten.

  3. Lassen Sie das Dialogfeld Anpassen geöffnet. Klicken Sie in der Menü- oder Symbolleiste mit der rechten Maustaste auf das Menü, das Sie ändern möchten, und geben Sie dann im Kontextmenü im Feld Name den Namen ein.


Wiederherstellen von Symbol- und Menüleisten oder einzelnen Schaltflächen, Befehlen oder Menüs

Sie können eine Symbol- oder Menüleiste, alle ursprünglichen Schaltflächen oder Menüs und Befehle sowie einzelne Schaltflächen, Befehle oder Menüs vollständig wiederherstellen.

Was möchten Sie tun?

Alle Standardeinstellungen für eine Symbol- oder Menüleiste, einschließlich deren Eigenschafteneinstellungen und der Einstellungen für einzelne Schaltflächen, Menüs und Befehle wiederherstellen

Die ursprünglichen Schaltflächen, Menüs und Befehle in einer eingebauten Symbolleiste, Menüleiste oder in einem Kontextmenü wiederherstellen

Das Erscheinungsbild einer einzelnen Symbolleistenschaltfläche oder eines einzelnen Menübefehls wiederherstellen

Ein Menü wiederherstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen ?


Ändern der Breite eines Kombinationsfelds in einer Symbolleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbolleiste an, die Sie ändern möchten.
  3. Lassen Sie das Dialogfeld Anpassen geöffnet, und klicken Sie in der Symbolleiste auf das Kombinationsfeld, wie z.B. auf Schriftart oder Schriftgrad.

  4. Zeigen Sie auf den linken Rand des Feldes. Wenn der Zeiger sich in einen Doppelpfeil ändert, ziehen Sie am Rand des Feldes, bis das Feld die gewünschte Breite hat.


Zuweisen eines Hyperlinks zu einer Symbolleistenschaltfläche oder einem Menübefehl

Wenn Sie einer Symbolleistenschaltfläche oder einem Menübefehl einen Hyperlink zuweisen, ersetzt der Hyperlink den Befehl, der der Symbolleistenschaltfläche oder dem Menübefehl aktuell zugewiesen ist. Sie können einen Hyperlink nicht einer Schaltfläche zuweisen, die eine Liste oder ein Menü anzeigt, wenn auf sie geklickt wird.

  1. Blenden Sie die Symbolleiste ein, die Sie ändern möchten.

  2. Wenn sich die Schaltfläche, der Sie einen Hyperlink zuweisen möchten, nicht auf einer Symbolleiste befindet, fügen Sie die Schaltfläche der Symbolleiste hinzu.

    Wenn sich der Befehl, dem Sie einen Hyperlink zuweisen möchten, nicht in einem Menü befindet, fügen Sie den Befehl einem Menü hinzu.

  3. Klicken Sie im Menü Extras auf Anpassen.

  4. Klicken Sie mit der rechten Maustaste auf die Symbolleistenschaltfläche, zeigen Sie im Kontextmenü auf Hyperlink zuweisen, und klicken Sie danach auf Öffnen.

  5. Klicken Sie unter Link zu auf die Quelle, zu der Sie die Verknüpfung herstellen möchten.

  6. Wählen Sie die gewünschten Optionen aus.

    Um Hilfe zu einer Option zu erhalten, klicken Sie auf das Fragezeichen [image] und danach auf die Option.


 Anzeigen aller Schaltflächen auf einer Symbolleiste

Anzeigen aller Schaltflächen auf einer Symbolleiste

  • Verwenden Sie den Ziehpunkt Linker Rand einer verankerten Symbolleiste auf der Symbolleiste, um diese zur vorgesehenen Reihe zu ziehen. Es ist auch möglich, die Symbolleiste an an eine andere Position als den Rand des Programmfensters zu ziehen, so dass die Symbolleiste zu einer unverankerten Symbolleiste wird.


Anzeigen aller Befehle in den Menüs

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen.

  2. Deaktivieren Sie das Kontrollkästchen Menüs zeigen zuletzt verwendete Befehle zuerst an.

Anmerkung Das Kontrollkästchen Menüs zeigen zuletzt verwendete Befehle zuerst an betrifft alle Microsoft Office-Programme.


Anzeigen der Standardschaltflächen der Symbolleiste und der Standardmenübefehle

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen.

  2. Klicken Sie auf die Schaltfläche Zurücksetzen.

Anmerkungen

  • Die Schaltfläche Zurücksetzen verändert die Schaltflächen einer eingebauten Symbolleiste nur dann, wenn die Symbolleiste nicht groß genug ist, um alle Schaltflächen anzuzeigen. Sie verändert die angepassten eingebauten Menüs nur dann, wenn das Kontrollkästchen Menüs zeigen zuletzt verwendete Befehle zuerst an auf der Registerkarte Optionen des Dialogfeldes Anpassen (Menü Extras) aktiviert ist.

  • Die Schaltfläche Zurücksetzen betrifft nur die Symbolleistennschaltflächen und Menübefehle in Microsoft Access.

  • Bei Verwenden der Schaltfläche Zurücksetzen wird die Position von Symbolleisten nicht verändert. Schaltflächen oder Befehle, die mit Hilfe des Dialogfeldes Anpassen hinzugefügt wurden, werden nicht verändert und gelöschte Schaltflächen und Befehle werden nicht wieder hinzugefügt.


 Erstellen eines Shortcuts für eine integrierte Symbolleistenschaltfläche oder einen Menübefehl

Erstellen eines Shortcuts für eine integrierte Symbolleistenschaltfläche oder einen Menübefehl

Dieses Verfahren erstellt nur den Text für den Shortcut. Es weist nicht die Aktion zu, die mit der Taste ausgeführt werden soll.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie gegebenenfalls die Symbol- oder Menüleiste an, mit der Sie arbeiten möchten.

    Wie wird's gemacht?

  3. Klicken Sie, wenn das Dialogfeld Anpassen geöffnet ist, mit der rechten Maustaste auf die eingebaute Symbolleistenschaltfläche oder den Menübefehl, für den Sie Shortcut-Text angeben möchten.

  4. Klicken Sie im Kontextmenü auf Eigenschaften.

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Shortcut Text den Shortcut oder die Tastenkombination ein, die Sie anzeigen möchten. (Die Eigenschaft Shortcut Text steht für benutzerdefinierte Schaltflächen oder Befehle nicht zur Verfügung.)

Anmerkungen

  • Um die Aktion, die den Shortcut ausführen sollen, zuzuordnen, müssen Sie ein AutoKeys-Makro erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Für einen Befehl in einem Menü wird der Text für den Shortcut rechts vom Befehl angezeigt. Für eine Symbolleistenschaltfläche wird der Shortcut-Text in der QuickInfo angezeigt. Er wird jedoch nur dann angezeigt, wenn Sie auf der Registerkarte Optionen (Dialogfeld Anpassen) das Kontrollkästchen Tastenkombinationen in QuickInfo anzeigen aktiviert haben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Erstellen von Direkthilfe-Tipps für Symbolleistenschaltflächen oder Menübefehle

Direkthilfe-Tipps werden angezeigt, wenn Sie im Menü ? auf Direkthilfe klicken oder UMSCHALTTASTE+F1 drücken und dann auf eine Symbolleistenschaltfläche oder einen Menübefehl klicken.

Erstellen des Tipps

  1. Erstellen Sie die Quelldatei in einem beliebigen Texteditor oder Textverarbeitungsprogramm. Speichern Sie die Datei im .RTF-Format. Informationen zum Erstellen der Quelldatei finden Sie in der Hilfe zum Windows Help Compiler.

  2. Kompilieren Sie die Hilfe unter Verwendung des Windows Help Compiler.

    Anmerkung Die besten Ergebnisse erzielen Sie, wenn Sie die Hilfedatei im selben Ordner ablegen wie Ihre Anwendung. Auf diese Weise kann jeder Standort, an dem Ihre Anwendung verwendet wird, dieselbe Einstellung für die Eigenschaft Hilfedatei verwenden, die Anwendung jedoch in einem beliebigen Ordner installieren. Wenn Sie für diese Eigenschaft keinen Pfad angeben, sucht Microsoft Access die Hilfedatei in dem Ordner, in dem Ihre Anwendung installiert ist.

Zuweisen des Tipps zu einer Symbolleistenschaltfläche oder einem Menübefehl

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie gegebenenfalls die Symbol- oder Menüleiste an, mit der Sie arbeiten möchten.

    Wie wird's gemacht?

  3. Klicken Sie, wenn das Dialogfeld Anpassen geöffnet ist, mit der rechten Maustaste auf die Symbolleistenschaltfläche oder den Menübefehl, der/dem Sie einen Tipp zuweisen möchten, und klicken Sie dann im Kontextmenü auf Eigenschaften.

  4. Geben Sie im Einstellungsfeld für die Eigenschaft Hilfedatei den Pfad und den Dateinamen für die kompilierte Hilfedatei ein.

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Hilfekontext-ID die Nummer des Themas an (eine Nummer ungleich 0).

Anmerkungen

  • Die für die Eigenschaft Hilfekontext eingestellten Werte müssen mit den Kontextzeichenfolgen in Ihrem Hilfesystem übereinstimmen. Weitere Informationen finden Sie in der Hilfe zum Windows Help Compiler.

  • Benutzerdefinierte Direkthilfe-Tipps können nicht unter Verwendung des Office-Assistenten angezeigt werden.

  • Der Windows Help Compiler ist in Microsoft Office 2000 Developer Edition, Microsoft Visual Basic für Applikationen, Microsoft Visual C++ und im Microsoft Windows Software Development Kit (SDK) enthalten. Sie können jedoch auch ein Help Authoring Kit von Microsoft erwerben. Zum Anzeigen weiterer Informationen zum Inhalt von Microsoft Office 2000 Developer Edition klicken Sie auf [image] .


Erstellen einer benutzerdefinierten QuickInfo (ScreenTip) für eine Symbolleistenschaltfläche

QuickInfos werden angezeigt, wenn der Mauszeiger sich auf einer Schaltfläche oder einem Kombinationsfeld in einer Symbolleiste befindet.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie gegebenenfalls die Symbolleiste an, mit der Sie arbeiten möchten.

    Wie wird's gemacht?

  3. Klicken Sie, wenn das Dialogfeld Anpassen geöffnet ist, mit der rechten Maustaste auf die Symbolleistenschaltfläche, für die Sie eine QuickInfo erstellen möchten, und klicken Sie dann im Kontextmenü auf Eigenschaften.

  4. Geben Sie im Einstellungsfeld für die Eigenschaft QuickInfo die Information ein, die Sie anzeigen möchten.

Anmerkungen

  • Wenn Sie keine benutzerdefinierte QuickInfo erstellen, zeigt Microsoft Access standardmäßig den in der Eigenschaft Beschriftung festgelegten Text an.

  • Wenn die QuickInfo nicht erscheint, obwohl der Mauszeiger sich auf der Schaltfläche oder dem Kombinationsfeld befindet, stellen Sie sicher, dass Sie das Kontrollkästchen QuickInfo auf Symbolleisten anzeigen auf der Registerkarte Optionen (Dialogfeld Anpassen) aktiviert haben.


 Zuweisen einer Zugriffstaste zu einem Menü oder Befehl

Zuweisen einer Zugriffstaste zu einem Menü oder Befehl

Sie können zum Verschieben des Fokus auf ein Menü oder einen Menübefehl an Stelle der Maus auch eine Zugriffstaste verwenden. Drücken Sie z.B. ALT+E, um den Fokus auf das Menü Extras zu verschieben, und drücken Sie dann E, wenn Sie den Befehl AutoKorrektur auswählen möchten.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie gegebenenfalls die Symbol- oder Menüleiste an, mit der Sie arbeiten möchten.

    Wie wird's gemacht?

  3. Klicken Sie, wenn das Dialogfeld Anpassen geöffnet ist, mit der rechten Maustaste auf das Menü oder den Befehl, für den Sie eine Zugriffstaste angeben möchten.

  4. Geben Sie im Feld Name vor dem Buchstaben, den Sie als Zugriffstaste verwenden möchten, ein UND-Zeichen (&) ein.

    Im Menü oder Befehl unterstreicht Microsoft Access den Buchstaben, den Sie als Zugriffstaste definiert haben.

Anmerkung Verwenden Sie für jeden Befehl in einem Menü einen anderen Buchstaben.


 Einbinden einer benutzerdefinierten Menüleiste in ein Formular oder in einen Bericht

Einbinden einer benutzerdefinierten Menüleiste in ein Formular oder in einen Bericht

Sobald eine benutzerdefinierte Menüleiste eingebunden ist, ersetzt diese die eingebaute Menüleiste für das Formular oder den Bericht.

  1. Erstellen Sie die Menüleiste.

    Wie wird's gemacht?

  2. Öffnen Sie das Formular oder den Bericht in der Entwurfsansicht.

  3. Klicken Sie in der Entwurfsansicht auf den Formularmarkierer oder den Berichtsmarkierer.

  4. Klicken Sie in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellungsfeld für die Menüleiste-Eigenschaft einen Namen für die Menüleiste ein.

    Wiederholen Sie diese Schritte für jedes Formular oder für jeden Bericht, in das/den Sie die Menüleiste einbinden möchten.


 Einbinden einer benutzerdefinierten Symbolleiste in ein Formular oder in einem Bericht

Einbinden einer benutzerdefinierten Symbolleiste in ein Formular oder in einem Bericht

Sobald eine benutzerdefinierte Symbolleiste eingebunden ist, ersetzt diese die eingebaute Symbolleiste für das Formular oder den Bericht.

  1. Erstellen Sie die Symbolleiste.

    Wie wird's gemacht?

  2. Öffnen Sie das Formular oder den Bericht in der Entwurfsansicht.

  3. Klicken Sie in der Entwurfsansicht auf den Formularmarkierer oder den Berichtsmarkierer.

  4. Klicken Sie in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Symbolleiste (Toolbar) den Namen für die Symbolleiste ein.

    Wiederholen Sie diese Schritte für jedes Formular oder jeden Bericht, in das/den Sie die Symbolleiste einbinden möchten.


 Einbinden eines Kontextmenüs in ein Formular, ein Formular-Steuerelement oder in einen Bericht

Einbinden eines Kontextmenüs in ein Formular, ein Formular-Steuerelement oder in einen Bericht

Sobald ein Kontextmenü eingebunden ist, ersetzt dieses das eingebaute Kontextmenü für ein Formular, ein Steuerelement oder einen Bericht.

  1. Erstellen Sie das Kontextmenu.

    Wie wird's gemacht?

  2. Öffnen Sie das Formular oder den Bericht in der Entwurfsansicht.

  3. Klicken Sie in der Entwurfsansicht auf den Formularmarkierer, den Berichtsmarkierer oder das Steuerelement.

  4. Klicken Sie in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellungsfeld für die Eigenschaft Kontextmenüleiste (ShortcutMenuBar) den Namen für das Kontextmenü ein.

    Stellen Sie für ein Formular darüber hinaus sicher, dass für die Eigenschaft Kontextmenü (ShortcutMenu) die Einstellung Ja festgelegt ist.

    Wiederholen Sie diese Schritte für jedes Formular, jeden Bericht oder jedes Steuerelement, in das/den Sie das Kontextmenü einbinden möchten.


Festlegen, ob Symbol- oder Menüleisten verankert werden sollen

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste, für die Sie Eigenschaften einstellen möchten.

  4. Klicken Sie im Feld Andocken auf die Einstellung, die Sie verwenden möchten.

Anmerkungen

  • Wenn Sie eine andere Einstellung als Änderung nicht möglich wählen, muss auch das Kontrollkästchen Verschieben zulassen aktiviert sein.

  • Diese Einstellung ist unabhängig von der Einstellung Symbolleisten- und Menüänderungen zulassen im Dialogfeld Start (Menü Extras).


Festlegen, ob benutzerdefinierte Symbol- und Menüleisten im Menü "Symbolleisten" angezeigt werden sollen

Benutzerdefinierte Symbol- und Menüleisten können standardmäßig ein- oder ausgeblendet werden. Dazu wählen Sie die entsprechende Leiste entweder aus dem Untermenü, das angezeigt wird, wenn Sie im Menü Ansicht auf Symbolleisten zeigen, oder aus dem Kontextmenü, das angezeigt wird, wenn Sie mit der rechten Maustaste auf eine Symbolleistenschaltfläche oder einen Menübefehl klicken. Wenn Sie verhindern möchten, dass andere Benutzer Symbol- oder Menüleisten ein- oder ausblenden, entfernen Sie die Namen der entsprechenden Leisten aus diesen Menüs.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbolleiste, für die Sie Eigenschaften einstellen möchten.

  4. Aktivieren oder deaktivieren Sie das Kontrollkästchen Show On Toolbars Menu.

Anmerkungen

  • Wenn Sie diese Option deaktivieren, können Sie Symbolleisten noch aus dem Dialogfeld Anpassen heraus ein- oder ausblenden. Zum Anzeigen von Informationen dazu, wie Sie Benutzer daran hindern, das Dialogfeld Anpassen zu öffnen, klicken Sie auf [image] .

  • Wenn Sie diese Option aktivieren, muss auch das Kontrollkästchen Einblenden/Ausblenden zulassen aktiviert sein.


Verhindern oder Zulassen von Änderungen an bestimmten Symbol- oder Menüleisten oder an Kontextmenüs

Unter Änderungen versteht man in diesem Kontext das Hinzufügen, Entfernen oder Einstellen von Eigenschaften für Schaltflächen, Befehle oder Menüs.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Anpassen auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste oder des benutzerdefinierten Kontextmenüs, für das Sie Eigenschaften einstellen möchten.

  4. Aktivieren oder deaktivieren Sie das Kontrollkästchen Anpassen zulassen.

Anmerkung Wenn Sie alle Eigenschaften für Symbol- und Menüleisten sowie für Kontextmenüs wie gewünscht eingestellt haben, können Sie verhindern, dass andere Benutzer auf das Dialogfeld Anpassen zugreifen und diese Einstellungen ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Verhindern oder Zulassen, dass Symbol- oder Menüleisten verschoben werden können

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste, für die Sie Eigenschaften einstellen möchten.

  4. Aktivieren oder deaktivieren Sie das Kontrollkästchen Verschieben zulassen.

Anmerkung Diese Einstellung ist unabhängig von der Einstellung Symbolleisten- und Menüänderungen zulassen im Dialogfeld Start (Menü Extras).


 Verhindern oder Zulassen von Größenänderungen an Symbol- oder Menüleisten

Verhindern oder Zulassen von Größenänderungen an Symbol- oder Menüleisten

Sie können unverankerte Symbol- und Menüleisten vergrößern oder verkleinern.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste, für die Sie Eigenschaften einstellen möchten.

  4. Aktivieren oder deaktivieren Sie das Kontrollkästchen Größenanpassung zulassen.

Anmerkung Diese Einstellung ist unabhängig von der Einstellung Symbolleisten- und Menüänderungen zulassen im Dialogfeld Start (Menü Extras).


Verhindern oder Zulassen, dass bestimmte Symbol- oder Menüleisten ein- bzw. ausgeblendet werden können

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste, für die Sie Eigenschaften einstellen möchten.

  4. Aktivieren oder deaktivieren Sie das Kontrollkästchen Einblenden/Ausblenden zulassen.

Anmerkungen

  • Sie können alle eingebauten Symbolleisten automatisch ausblenden, wenn Sie verhindern möchten, dass andere Benutzer mit diesen arbeiten. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie diese Option deaktivieren, muss auch das Kontrollkästchen In Symbolleistenmenü anzeigen deaktiviert sein. Ist dies nicht der Fall, erscheint die Symbol- oder Menüleiste im Menü, Sie können sie jedoch nicht auswählen.


Animieren von Menüs, so dass diese beim Anzeigen nach unten ausfahren oder aufklappen

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Wählen Sie auf der Registerkarte Optionen die gewünschte Menüanimation.


 Ein- oder Ausblenden einer Symbolleiste, Menüleiste oder eines Kontextmenüs

Ein- oder Ausblenden einer Symbolleiste, Menüleiste oder eines Kontextmenüs

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Aktivieren oder deaktivieren Sie in der Registerkarte Symbolleisten das Kontrollkästchen für das Element, das Sie ein- bzw. ausblenden möchten. Zum Einblenden eines bestimmten Kontextmenüs wählen Sie Kontextmenüs, klicken Sie zuerst auf die Kategorie für das Kontextmenü, das eingeblendet werden soll, und dann auf den Namen des Kontextmenüs. Zum Einblenden eines beliebigen benutzerdefinierten Kontextmenüs klicken Sie auf die Kategorie Benutzerdefiniert.

Tipps

  • Um schnell eine unverankerte Symbolleiste auszublenden, klicken Sie auf deren Schaltfläche Schließen.

  • Um schnell eine benutzerdefinierte Symbol- oder Menüleiste ein- oder auszublenden, klicken Sie mit der rechten Maustaste im Kontextmenü auf den Namen der Leiste.


Ein- oder Ausblenden von Zugriffstasten in QuickInfo (ToolTips)

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie auf die Registerkarte Optionen.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Tastenkombinationen in Infofeldern anzeigen.

Anmerkung Diese Einstellung hat für alle Microsoft Office-Programme mit Ausnahme von Microsoft Excel Gültigkeit.


Ein- oder Ausblenden von QuickInfo (ToolTips)

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie auf die Registerkarte Optionen.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen QuickInfo auf Symbolleisten anzeigen.

Anmerkung Diese Einstellung hat für alle Microsoft Office-Programme Gültigkeit.


 Verschieben einer Symbol- oder Menüleiste

Verschieben einer Symbol- oder Menüleiste

  1. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie in einer verankerten Symbol- oder Menüleiste auf den Ziehpunkt zum Verschieben Linker Rand einer verankerten Symbolleiste.

    • Klicken Sie in einer unverankerten Symbol- oder Menüleiste auf die Titelleiste.
  2. Ziehen Sie die Symbol- oder Menüleiste an die neue Position. Wenn Sie eine Symbol- oder Menüleiste an den Rand des Programmfensters ziehen, wird diese verankert.

Anmerkung Wenn Sie eine verankerte Symbolleiste verschieben, kann sich dadurch die Position und Größe anderer Symbolleisten in derselben Reihe verändern.


 Ändern der Größe einer Symbol- oder Menüleiste

Ändern der Größe einer Symbol- oder Menüleiste

  • Zum Ändern der Größe einer unverankerten Symbol- oder Menüleiste ziehen Sie den Zeiger über einen Rand, bis der Zeiger als Doppelpfeil angezeigt wird. Anschließend ziehen Sie den Rand.

  • Zum Ändern der Größe einer verankerten Symbolleiste, die sich in derselben Zeile wie eine andere Symbolleiste befindet, klicken Sie auf den Ziehpunkt Linker Rand einer verankerten Symbolleiste , und ziehen Sie dann den Rand der Symbolleiste.

Anmerkungen

  • Sie können die Größe einer verankerten Symbolleiste nicht verändern, wenn sich diese in ihrer ursprünglichen Zeile, in einer horizontalen Symbolleistenreihe links außen oder in einer vertikalen Reihe ganz oben befindet.

  • Wenn Sie die Größe einer verankerten Symbolleiste verändern, kann sich damit die Position und Größe anderer Symbolleisten in derselben Zeile ändern.


 Dauerhaftes Anzeigen der Farb- und Formatpaletten während des Entwurfs eines Formulars oder Berichts

Dauerhaftes Anzeigen der Farb- und Formatpaletten während des Entwurfs eines Formulars oder Berichts

Wenn Sie eine Palette beim Entwerfen eines Formulars, eines Berichts oder einer Datenzugriffsseite dauerhaft anzeigen möchten, ziehen Sie diese aus der Symbolleistenschaltfläche heraus.

  1. Klicken Sie in der Formularentwurfsansicht, der Berichtsentwurfsansicht oder der Datenzugriffsseiten-Entwurfsansicht je nach der gewünschten Palette auf den Pfeil neben einer der folgenden Schaltflächen in der Symbolleiste Formatierung.
    Schalt-
    fläche     		Palette Auswahl
    Hintergrund-
    farbe         		Hintergrundfarbe für ein Steuerelement oder einen Bereich
    Schrift-/Vorder-
    grundfarbe         		Schriftfarbe für ein Steuerelement
    Linien-/
    Rahmenfarbe         		Farbe für den Rahmen eines Steuerelements
    Linien-/
    Rahmenbreite         		Breite der Rahmenlinien eines Steuerelements
    Zelleffekt Flache, erhöhte, oder vertiefte Darstellung eines Steuerelements oder Bereichs
  2. Klicken Sie auf die Leiste am oberen Rand der Palette, und ziehen Sie die Palette von der Schaltfläche herunter.


Anzeigen von Schriftartennamen in der Office-Schnittstellenschriftart

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen.

  2. Deaktivieren Sie das Kontrollkästchen Schriftartennamen in Schriftart anzeigen.

Anmerkung Das Kontrollkästchen Schriftartennamen in Schriftart anzeigen wirkt sich auf alle Microsoft Office-Programme aus.


 Info über das Verwalten der Arbeit in einer Datenbank und das Suchen nach Dateien unter Verwendung von Microsoft Outlook

Info über das Verwalten der Arbeit in einer Datenbank und das Suchen nach Dateien unter Verwendung von Microsoft Outlook

Microsoft Outlook ist ein Messaging- und Zusammenarbeits-Client, mit dessen Hilfe Sie Nachrichten senden und Besprechungen, Ereignisse oder Termine planen können. Darüber hinaus können Sie eine Liste von Kontaktpersonen speichern, eine persönliche Aufgabenliste verwalten, anderen Personen Aufgaben zuweisen und Ihre Aktivitäten verwalten. Wenn Sie Outlook installiert haben, können Sie einige der Funktionen von Outlook auch innerhalb Ihrer anderen Microsoft Office-Programme nutzen.

Wenn Outlook nicht verfügbar ist, klicken Sie im Menü Start auf Programme und danach auf Microsoft Outlook, um es zu installieren.

  • Mit dem Outlook Journal können Sie alle Dateien, die Sie in einem Office-Programm erstellen, automatisch verwalten. Wenn Sie beispielsweise Datenbanken nach ihrem Erstellungs- und Überarbeitungsdatum und nicht nach ihrem Speicherort verwalten möchten, können Sie Outlook jedes Mal, wenn Sie an einer Datenbank arbeiten, einen Journaleintrag erstellen lassen. Jeder Eintrag steht für eine Aktivität. So protokollieren Sie Datenbanken im Outlook Journal automatisch.

  • Wenn Sie nur eine Datei in einem Office-Programm oder Dateien in einem anderen Programm als Office verfolgen möchten, können Sie dies tun, indem Sie jede Aktivität, die Sie an einer einzelnen Datei durchführen, im Outlook Journal manuell aufzeichnen. So zeichnen Sie Arbeit an jeder einzelnen Datei im Outlook Journal automatisch auf.

  • Sie können Aufgaben, Journaleinträge, Kalkulationstabellen, Dokumente, Datenbanken und Präsentationen mit einer Kontaktperson verknüpfen, mit der Sie korrespondieren, um alle mit der Kontaktperson verwandten Elemente zu verfolgen. Wenn Sie beispielsweise Datenbanken nach einer oder mehreren Kontaktpersonen verfolgen möchten, die für die Arbeit an einer bestimmten Datenbank verwantwortlich sind, können Sie Kontaktinformationen mit einer Datenbank und anderen verwandten Elementen, z.B. Kalkulationstabellen, E-Mail-Nachrichten und Termine, verknüpfen . So verknüpfen Sie Aufgaben, Journaleinträge und Dokumente mit einem Kontakt.

  • Wenn Sie das integrierte Dateimanagement-System von Microsoft Outlook installiert haben, können Sie mit Outlook Dateien eines beliebigen Office-Programms, Dateien im Netz und Outlook-Objekte suchen. Sie können die Suchergebnisse sortieren, ordnen oder ihre Ansicht ändern. Sie können ein Objekt oder eine Datei in den Suchergebnissen auch öffnen, indem Sie darauf doppelklicken. Suchergebnisse lassen sich als Datei speichern, die von anderen Personen gemeinsam genutzt werden kann. Außerdem können Sie eine Suche öffnen, indem Sie auf eine gespeicherte Suchdatei doppelklicken. So verwenden Sie Microsoft Outlook zum Suchen nach Dateien oder Outlook-Objekten.


Verwalten der Arbeiten an einer Datenbank und Suchen nach Dateien mit Hilfe von Microsoft Outlook

Was möchten Sie tun?

Datenbanken im Outlook Journal automatisch protokollieren

Die Arbeit an jeder einzelnen Datei im Outlook Journal manuell aufzeichnen

Microsoft Outlook zum Suchen nach Dateien oder Outlook-Objekten verwenden

Verknüpfen von Aufgaben, Journaleinträgen und Dokumenten mit einer Kontaktperson

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Automatisches Protokollieren von Datenbanken im Outlook Journal

  1. Starten Sie Outlook.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Einstellungen, und klicken Sie dann auf Journaloptionen.

  4. Aktivieren Sie in der Liste Auch Dateien eintragen von das Kontrollkästchen Microsoft Access.

Anmerkung Bei Datenbanken, die automatisch im Outlook-Journal aufgezeichnet werden, dauert es einige Minuten, bis diese im Journal angezeigt werden.


 Manuelles Aufzeichnen der Arbeit an jeder einzelnen Datei im Outlook Journal

Manuelles Aufzeichnen der Arbeit an jeder einzelnen Datei im Outlook Journal

  1. Stellen Sie sicher, dass die Datei, für die Sie Arbeit aufzeichnen möchten, nicht geöffnet ist.

  2. Starten Sie Outlook.

  3. Klicken Sie in der Outlook-Leiste auf Andere oder auf Weitere Verknüpfungen.

  4. Doppelklicken Sie auf Arbeitsplatz [image] , und suchen Sie dann die Datei, die Sie aufzeichnen möchten.

    Wenn Arbeitsplatz nicht verfügbar ist, müssen Sie das Microsoft Outlook Integrated File Management-System installieren. Rufen Sie weitere Informationen zum Installieren eines Programms oder einer Komponente auf.

  5. Klicken Sie in der Outlook-Leiste auf Eigene Verknüpfungen, und stellen Sie sicher, dass Journal [image] angezeigt wird.

  6. Ziehen Sie die Datei, die Sie aufzeichnen möchten, auf Journal [image].

  7. Wählen Sie die gewünschten Optionen, und klicken Sie dann auf Speichern und Schließen [image] .


Verwenden von Microsoft Outlook zum Suchen nach Dateien oder Outlook-Objekten

  • Klicken Sie auf die Windows-Schaltfläche Start, zeigen Sie auf Suchen, und klicken Sie dann auf Using Microsoft Outlook.

Anmerkung Wenn Sie nach allen Dateien auf Ihrem Computer suchen möchten, muss das Microsoft Outlook Integrated File Management-System auf Ihrem Computer installiert sein. So installieren Sie ein Programm oder eine Komponente.


 Verwalten von Terminen, Kontakten, Aufgaben und Nachrichten über die Office Shortcut-Leiste

Verwalten von Terminen, Kontakten, Aufgaben und Nachrichten über die Office Shortcut-Leiste

Wenn Sie Microsoft Office verwenden und bei dessen Installation auch Microsoft Outlook installiert haben, enthält die Symbolleiste Office auf der Office Shortcut-Leiste sechs Verknüpfungen zu den am häufigsten verwendeten Microsoft Outlook-Features.

Befehl | Aktion
Neue Nachricht | Senden einer E-Mail-Nachricht aus Outlook.
Neuer Termin | Eintragen eines neuen Termins in Ihren Kalender in Outlook.
Neue Aufgabe | Hinzufügen einer neuen Aufgabe zu Ihrer Aufgabenliste in Outlook.
Neuer Kontakt | Erstellen eines Kontakts in Outlook.
Neues Journal | Manuelles Erfassen einer Aktivität im Journal in Outlook.
Neue Notiz | Erstellen einer Notiz in Outlook.


 Versenden einer Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht

Versenden einer Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht

Wichtig Eine Datenzugriffsseite wird mit einer OLE DB-Datenquelle verbunden, und zwar entweder mit einer Microsoft Access-Datenbank oder einer Datenbank für Microsoft SQL Server. Damit die Datenzugriffsseite fehlerfrei funktioniert, muss die Datenbank für die Benutzer der Seite verfügbar sein. Weitere Informationen zum Thema Freigabe der OLE DB-Datenquelle einer Seite.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten und dann auf den Namen der gewünschten Seite, die Sie als Hauptteil einer E-Mail-Nachricht versenden möchten.

  2. Klicken Sie im Menü Datei auf Senden an und wählen Sie dann den Mailempfänger.

    Access öffnet die Datenzugriffsseite in der Seitenentwurfsansicht, so dass Sie vor dem Versenden der Datenzugriffsseite Änderungen vornehmen können, wie zum Beispiel das Hinzufügen von Text oder Anmerkungen für den Mailempfänger zur Datenzugriffsseite.

  3. Geben Sie die Namen der Empfänger in die Felder An und Cc ein. Trennen Sie die Namen jeweils durch ein Semikolon (;).

    Um Namen von Empfängern aus einer Liste zu wählen, klicken Sie auf An oder Cc. Der Name des Objektes wird zwar standardmäßig im Feld Betreff angezeigt, jedoch können Sie auch einen beliebigen Betreff eingeben. Sie können Namen vor Versenden der Nachricht manuell prüfen. Sie können außerdem für die E-Mail-Nachricht zusätzliche Optionen einstellen.

  4. Klicken Sie in der Kopfzeile auf Senden.


 Anhängen der Ausgabe eines Objekts an eine E-Mail-Nachricht

Anhängen der Ausgabe eines Objekts an eine E-Mail-Nachricht

  1. Klicken Sie im Datenbankfenster unter Objekte auf den Typ des Datenbankobjekts und dann auf den Namen des Datenbankobjekts, das Sie als Anlage versenden möchten.

    Wenn Sie einen bestimmten Bereich eines Datenblatts versenden möchten, öffnen Sie das Datenblatt und wählen Sie den entsprechenden Bereich aus, bevor Sie fortfahren.

  2. Klicken Sie im Menü Datei auf Senden an und wählen Sie dann den Mailempfänger (als Anlage).
  3. Klicken Sie auf das Dateiformat, das Sie einschließen möchten, und dann auf OK.

    Microsoft Access öffnet eine neue E-Mail-Nachricht und schließt die Ausgabe des Objekts im angegebenen Format als Anhang ein.

  4. Geben Sie die Namen der Empfänger in die Felder An und Cc ein. Trennen Sie die Namen jeweils durch ein Semikolon (;).

    Um Namen von Empfängern aus einer Liste zu wählen, klicken Sie auf An oder Cc. Der Name des Objekts wird zwar standardmäßig im Feld Betreff angezeigt, Sie können jedoch auch einen beliebigen Betreff eingeben. Sie können Namen vor dem Versenden der Nachricht manuell prüfen. Sie können außerdem für die E-Mail-Nachricht zusätzliche Optionen einstellen.

  5. Klicken Sie in der Kopfzeile auf Senden.

Anmerkungen

  • Sie können in einer E-Mail-Nachricht ein Datenbankobjekt in einem der folgenden Ausgabeformate einbinden: HTML (.htm, .html), Microsoft Excel (.xls), Microsoft MS-DOS Text (.txt), Rich Text Format (.rtf), bei Datenzugriffsseiten : Datenzugriffsseiten (.htm, .html) oder bei Berichten : Bericht-Snapshot (.snp).

  • Obwohl Datenbankobjekte weder im Ausgabeformat Microsoft Internet Information Services (.htx, .idc) noch im Ausgabeformat Microsoft Active Server Pages (.asp) eingeschlossen werden können, können Sie das Objekt in das gewünschte Ausgabeformat exportieren und dann die Dateien in ein E-Mail-Programm einschließen, wie zum Beispiel Microsoft Outlook. Weitere Informationen über das Exportieren von Daten.

  • Seiten können Sie nur im Ausgabeformat Datenzugriffsseite (.htm, .html) versenden. Module können Sie nur im Ausgabeformat MS-DOS Text (.txt) versenden. Sie können weder Makros noch Datenbankdiagramme versenden (nur Microsoft Access-Projekte).


Einstellen von Optionen zum Senden einer E-Mail-Nachricht

Was möchten Sie tun?

Einstellen der Wichtigkeits- und Vertraulichkeitstufen

Einstellen der Wichtigkeitsstufe einer Nachricht

Einstellen eines Nachrichtenkennzeichens

Kennzeichnen einer Nachricht als privat, persönlich oder vertraulich

Einstellen der Sicherheitsstufe

Hinzufügen von Sicherheit zu Nachrichten

Rückverfolgen von Nachrichten und Antworten

Empfangen einer Benachrichtigung nach der Übermittlung einer Nachricht

Empfangen einer Benachrichtigung nach dem Lesen einer Nachricht

Hinzufügen von Abstimmungsschaltflächen zu einer E-Mail-Nachricht

Einstellen der Übermittlungsoptionen

Speichern einer Kopie der gesendeten Nachricht

Ungültigmachen einer gesendeten Nachricht nach Ablauf eines angegebenen Datums

Verzögern der Übermittlung einer Nachricht

Veranlassen des Sendens von Antworten auf eine Nachricht an einen anderen Benutzer

Informationen zum Zuweisen von Nachrichten zu Kategorien

Zuweisen von Nachrichten zu einer Kategorie

Einrichten eines E-Mail-Kontos

Auswählen des E-Mail-Kontos, das zum Senden einer Nachricht verwendet werden soll

Abrufen von Information über die Microsoft Outlook-Installation

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Manuelles Überprüfen von Namen vor dem Senden einer Nachricht

Manuelles Überprüfen von Namen vor dem Senden einer Nachricht

Bevor Sie die Ausgabe eines Datenbankobjekts oder einer Datenzugriffsseite als E-Mail-Nachricht senden, werden die Empfängernamen, die Sie in die Felder An, Cc und Bcc eingeben, automatisch mit den Namen im Adressbuch verglichen. Wird eine exakte Übereinstimmung gefunden, wird der Name unterstrichen. Wenn mehrere Namen gefunden werden, die mit dem eingegebenen Namen übereinstimmen, wird das Dialogfeld Namen überprüfen angezeigt, in dem Sie den gewünschten Namen auswählen können.

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Geben Sie in die Felder An und Cc die Empfängernamen ein. Trennen Sie die Namen mit einem Semikolon (;).

    Um Empfängernamen in einer Liste auszuwählen, klicken Sie auf An oder Cc.

  3. Klicken Sie auf Namen überprüfen [image].

    Tipp Sie können auch STRG+K drücken.


 Systemvoraussetzungen für das Senden und Anzeigen einer Datenzugriffsseite

Systemvoraussetzungen für das Senden und Anzeigen einer Datenzugriffsseite

Es folgen Systemvoraussetzungen für das Senden und Anzeigen einer Datenzugriffsseite.

Systemvoraussetzungen für das Senden und Anzeigen einer Datenzugriffsseite

Um eine Datenzugriffsseite per E-Mail zu senden, benötigen Sie eine der folgenden Anwendungen:

  • Microsoft Outlook 2000

  • Outlook Express, Version 5.0

  • Microsoft Exchange

Systemvoraussetzungen für das Anzeigen einer per E-Mail gesendeten Datenzugriffsseite

Um eine Datenzugriffsseite anzuzeigen, die per E-Mail gesendet wurde, benötigen Sie eine der folgenden Anwendungen:

  • Microsoft Outlook 2000

  • Outlook Express, Version 5.0

  • Eine Kombination von Microsoft Outlook 98 und Microsoft Internet Explorer 5 oder höher

  • Eine Kombination von Outlook Express und Microsoft Internet Explorer 5 oder höher

Anmerkungen

  • Das Senden einer Datenzugriffsseite per E-Mail über E-Mail-Gateways funktioniert ggf. nicht.

  • Es wird empfohlen, die Datenzugriffsseite als Anlage einer E-Mail-Nachricht zu senden, wenn der Empfänger Microsoft Office 97 oder früher verwendet.


 Öffnen kürzlich durchsuchter Dateien

Öffnen kürzlich durchsuchter Dateien

  1. Wenn die Symbolleiste Web nicht angezeigt wird, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste Web auf Zurück [image] , um das vorherige Dokument in der Verlaufsliste zu öffnen. Um das nächste Dokument zu öffnen, klicken Sie auf Vorwärts [image] .


 Öffnen der Web-Suchseite

Öffnen der Web-Suchseite

  1. Wenn die Symbolleiste Web nicht angezeigt wird, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste Web auf Im Web suchen [image] .

Anmerkung Eine Suchseite bietet eine strukturierte Möglichkeit des Suchens von und Wechselns zu Internet-Sites oder zu Dateien in einem Intranet.


 Öffnen der Web-Startseite

Öffnen der Web-Startseite

  1. Wenn die Symbolleiste Web nicht angezeigt wird, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste "Web" auf Startseite [image] .

Anmerkung Wenn Sie einen World Wide Web -Browser starten, ist die Startseite die erste im Browser angezeigte Seite. Sie können diese auf eine beliebige Website oder auf eine Datei auf der Festplatte des Computers einstellen.


 Aktualisieren der Anzeige der aktiven Datei oder Webseite

Aktualisieren der Anzeige der aktiven Datei oder Webseite

Eine geöffnete Webseite kann durch den Autor der Seite geändert werden, während Sie die Seite geöffnet haben. Beim Aktualisieren eines Dokuments wird die aktuellste Version der ursprünglichen Datei abgerufen, die sich auf dem Netzwerkserver, im Internet oder der Festplatte befinden kann.

  1. Wird die Symbolleiste Web nicht angezeigt, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste Web auf Aktuelle Seite aktualisieren [image] .


 Ein- und Ausblenden aller Symbolleisten außer der Symbolleiste "Web"

Ein- und Ausblenden aller Symbolleisten außer der Symbolleiste "Web"

  1. Wird die Symbolleiste Web nicht angezeigt, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Web.

  2. Klicken Sie in der Symbolleiste Web auf die Schaltfläche Nur Websymbolleiste anzeigen [image] .


 Einstellen einer Hyperlinkbasis für eine Access-Datenbank oder ein Access-Projekt

Einstellen einer Hyperlinkbasis für eine Access-Datenbank oder ein Access-Projekt

Durch Festlegen der Eigenschaft Hyperlinkbasis können Sie den Pfad der relativen Verknüpfungen in einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt festlegen. Weitere Informationen zu relativen Verknüpfungen und dem Festlegen einer Hyperlinkbasis.

  1. Öffnen Sie die Datenbank, für die Sie eine Hyperlinkbasis festlegen möchten.

  2. Klicken Sie im Menü Datei auf Datenbankeigenschaften und dann auf die Registerkarte Zusammenfassung.

    Geben Sie in das Feld Hyperlinkbasis den Pfad der relativen Verknüpfung ein, die Sie für alle in dieser Datenbank erstellten Hyperlinks verwenden wollen. Der Pfad kann auf einen Speicherort auf der Festplatte, auf ein Netzwerklaufwerk, ein Intranet oder auf das Internet verweisen.


 Ausschalten der automatischen Vervollständigung von Dateinamen und URLs

Ausschalten der automatischen Vervollständigung von Dateinamen und URLs

Wenn Sie mit Microsoft Internet Explorer 4.0 oder höher arbeiten, können Sie die Funktion ausschalten, die automatisch eine Übereinstimmung für Dateinamen und URLs vorschlägt, wenn Sie diese in Office-Programmen in das Dialogfeld Hyperlink einfügen oder in Internet Explorer in das Feld Adresse eingeben.

  1. Starten Sie oder wechseln Sie zu Internet Explorer.

  2. Führen Sie einen der folgenden Schritte aus:

    Wenn Sie mit Microsoft Internet Explorer 4.0 arbeiten, klicken Sie im Menü Ansicht auf Internetoptionen, und deaktivieren Sie in der Registerkarte Erweitert das Kontrollkästchen Automatische Vervollständigung verwenden.

    Wenn Sie mit Microsoft Internet Explorer 5 arbeiten, klicken Sie im Menü Extras auf Internetoptionen, und deaktivieren Sie in der Registerkarte Erweitert das Kontrollkästchen Verwenden von AutoVervollständigen für Webadressen.


Arbeiten mit FTP

Was möchten Sie tun?

Eine FTP-Site zur Liste der Internetsites hinzufügen

Eine FTP-Site aus Liste der Internetsites entfernen

Den Anmeldenamen oder das Kennwort für eine FTP-Site ändern

Eine Datenzugriffsseite in einer FTP-Site speichern


 Info über die Symbolleiste "Web"

Info über die Symbolleiste "Web"

Die Symbolleiste Web in Access soll das Durchsuchen von Office-Dokumenten erleichtern, die Hyperlinks enthalten. Mit der Symbolleiste Web können Sie eine Startseite oder Suchseite im Webbrowser öffnen. Wenn Sie interessante Sites im Web finden, können Sie diese über die SymbolleisteWeb dem Ordner Favoriten hinzufügen, um sie später schnell zu finden. Die Symbolleiste Web enthält eine Liste der letzten 25 Webseiten, für die Sie die Symbolleiste verwendet haben, oder einen Hyperlink, zu dem gewechselt werden kann, damit Sie problemlos zu allen Einträgen in der Liste gelangen können.


 Info über die drei Arten von Webseiten, die Microsoft Access erstellt

Info über die drei Arten von Webseiten, die Microsoft Access erstellt

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datenzugriffsseiten

Serverseitig generierter HTML-Code

Statischer HTML-Code

Datenzugriffsseiten

Sie können eine Datenzugriffsseite als ein Datenbankobjekt erstellen, das eine Verknüpfung mit dem Pfad der entsprechenden HTML-Datei der Seite enthält. Informationen anzeigen zum Erstellen von Datenzugriffsseiten.

Verwenden Sie Datenzugriffsseiten, um in Microsoft Internet Explorer 5 (oder später) aktuelle Daten aus einer Microsoft Access-Datenbank oder einer Microsoft SQL Server-Datenbank zu bearbeiten, zu aktualisieren, zu löschen, zu filtern, zu gruppieren und zu sortieren . Eine Seite kann außerdem zusätzliche Steuerelemente enthalten, unter anderem Tabellen, PivotTable-Listen oder Charts.

Um eigene Seiten im World Wide Web zur Verfügung zu stellen, veröffentlichen Sie die Seiten in Webverzeichnissen oder über einen Webserver und erlauben den Benutzern der Seite den Zugriff auf die Access-Datenbank oder SQL Server-Datenbank.

Internet Explorer muss die Seite nur einmal vom Webserver übertragen, damit der Benutzer sie anzeigen und mit den Daten der Seite arbeiten kann. Da eine Datenzugriffsseite Dynamic HTML verwendet, ist in einer Client-/Server-Umgebung der Zugriff auf die Datenbank in der Regel sehr effizient.

Zurück zum Anfang

Serverseitig generierter HTML-Code

Sie können serverseitig generierte HTML-Dateien (entweder ASP- oder IDC/HTX-Dateien) aus Tabellen, Abfragen und Formularen erstellen. Serverseitig generierte HTML-Dateien werden in einem Webbrowser in Tabellenform dargestellt. Verwenden Sie serverseitig generierte HTML-Dateien, wenn Sie beliebige Webbrowser einsetzen möchten und sich Ihre Daten häufig ändern, wenn Sie zusätzlich die Anzeige aktueller Daten in Tabellenform benötigen, die über eine ODBC-Datenquelle verknüpft sind, und wenn außerdem kein Ändern der Daten möglich sein muss.

Nach Generierung der ASP- oder IDC/HTX-Dateien müssen Sie diese Dateien veröffentlichen, damit sie durch einen Webserver und eine entsprechende Plattform mit geeigneter Unterstützung verarbeitet werden können.

Jedesmal, wenn ein Benutzer eine ASP- oder HTX-Datei mit einem Webbrowser öffnet bzw. aktualisiert, erstellt der Webserver dynamisch eine HTML-Datei und sendet dann diese HTML-Datei an den Webbrowser.

Zurück zum Anfang

Statischer HTML-Code

Sie können statische HTML-Dateien aus Tabellen, Abfragen, Formularen und Berichten erstellen. Webbrowser stellen Berichte in einer speziellen Berichtsform dar, während Tabellen, Abfragen sowie Formulare in Form eines Datenblatts angezeigt werden. Verwenden Sie statische HTML-Dateien, wenn Sie beliebige Webbrowser mit Unterstützung für HTML Version 3.2 oder später verwenden möchten und wenn Ihre Daten nur selten geändert werden.

Um statische HTML-Dateien im World Wide Web zur Verfügung zu stellen, veröffentlichen Sie die Dateien in Webverzeichnissen oder über einen Webserver.

Beim Zugriff auf die Daten über einen Webbrowser muss der Browser die statische HTML-Datei nur einmal vom Webserver übertragen, damit der Benutzer sie anzeigen kann. Allerdings zeigen diese HTML-Dateien die Daten nur in dem Zustand, in dem sie sich zum Zeitpunkt ihrer Veröffentlichung befanden. Es gibt also keine mit der statischen HTML-Datei verknüpften ODBC-Datenquelle, und wenn sich die Daten ändern, müssen Sie Ihre Dateien erneut exportieren, damit Benutzer in der Lage sind, die neuen Daten in einem Browser anzuzeigen.

Zurück zum Anfang


 Client-/Serverprodukte und -plattformen für Webseiten

Client-/Serverprodukte und -plattformen für Webseiten

In der folgenden Tabelle werden die unterstützten Produkte, Plattformen und Ausgabedateiformate für Webseiten aufgelistet.

Ausgabedateiformate
für Webseiten

HTML-
Version

 Unterstützte Clientbrowser

Unterstützte Serverprodukte
und -plattformen
Datenzugriffsseiten (*.HTM, *.HTML) Dynamisches HTML 4.0 oder höher Microsoft Internet Explorer 5 oder höher Alle Webserver-Produkte und -Plattformen

Anmerkung Um domänenübergreifenden Zugriff zu verhindern, ist IIS 4.0 unter Microsoft Windows NT Server 4.0 erforderlich. Siehe auch Sichern einer Datenzugriffsseite.
Servergenierter HTML, ASP (*.ASP) Alle Webbrowser
  • IIS 3.0 mit Active Server-Seiten unter Windows NT Server 4.0

  • IIS 4.0 unter Windows NT Server 4.0

  • Personal Web Server mit Active Server-Seiten unter Microsoft Windows NT Workstation 4.0

  • Personal Web Server mit Active Server-Seiten unter Microsoft Windows 95
Servergenerierter HTML, IDC/HTX (*.IDC, *.HTX) Alle Webbrowser
  • IIS (Microsoft Internet Information Server) 1.x mit dem Add-In Internet Database Connector unter Windows NT Server 3.51

  • IIS 2.0 unter Windows NT Server 3.51

  • IIS 3.0 mit Active Server-Seiten unter Windows NT Server 4.0

  • IIS 4.0 unter Windows NT Server 4.0

  • Personal Web Server unter Windows NT Workstation 4.0

  • Personal Web Server unter Windows 95
Statisches HTML (*.HTM, *.HTML) HTML 3.2 oder höher Alle Webbrowser Alle Webserver-Produkte und -Plattformen

Anmerkung Für die Verwendung einer Webseite auf einem Clientcomputer ist ein Webbrowser, z.B. Microsoft Internet Explorer, sowie ein Modem oder eine Netzwerkverbindung zum Internet- oder Intranetserver erforderlich, auf dem sich die Webseiten befinden. Informationen über das Einrichten des Internetzugriffs finden Sie in Microsoft Office 2000 - Die technische Referenz. Um Informationen zu Bezugsquellen für die technische Referenz zu erhalten, klicken Sie auf [image] .


 Verarbeitung des servergenerierten HTML-Formats durch den Webserver

Verarbeitung des servergenerierten HTML-Formats durch den Webserver

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Verarbeitung von .IDC/.HTX-Dateien durch den Webserver

Verarbeitung von .ASP-Dateien durch den Webserver

Verarbeitung von .IDC/.HTX-Dateien durch den Webserver

Wenn Sie eine Tabelle, Abfrage oder ein Formular als .IDC/.HTX-Dateien anstatt in eine .HTML-Datei ausgeben, erstellt Microsoft Access eine HTML-Erweiterungsdatei (.HTX) und eine Internet Database Connector-Datei (.IDC). Internet Database Connector (HTTPODBC.DLL) ist eine Komponente von Microsoft Internet Information Server.

Die .IDC-Datei enthält eine Abfrage in Form einer SQL-Anweisung und Informationen, die Microsoft Internet Information Server zum Herstellen einer Verbindung zu einer ODBC-Datenquelle, in diesem Fall entweder eine Microsoft Access-Datenbank oder eine Microsoft SQL Server-Datenbank, verwendet. Zu den Verbindungsinformationen gehören der Name der Datenquelle und häufig der Benutzername und das Kennwort. Die beiden letzten Angaben sind optional.

Die .HTX-Datei ist eine HTML-Datei, die Formatierungsmarken und -anweisungen sowie an Stelle von Daten Platzhalter enthält, die angeben, wo die von der Abfrage in der .IDX-Datei zurückgegebenen Werte eingefügt werden sollen.

Nach dem Publizieren Ihrer .IDC/.HTX-Dateien auf einem Webserver öffnet Microsoft Internet Information Server bei entsprechender Anfrage von einem Webbrowser die Datenbank (unter Verwendung des geeigenten ODBC-Treibers und der Verbindungsinformationen in der .IDC-Datei), führt die Abfrage in der .IDC-Datei zum Zugriff auf die Daten aus, führt die Ergebnisse und die .HTX-Datei in einer .HTML-Datei zusammen und sendet dann die dynamisch erstellte .HTML-Datei zurück zum Webbrowser, in dem sie als Webseite angezeigt wird.

Zurück zum Anfang

Verarbeitung von ASP-Dateien durch den Webserver

Wenn Sie eine Tabelle, Abfrage oder ein Formular in eine .ASP-Datei anstatt in eine .HTML-Datei ausgeben, erstellt Microsoft Access eine Microsoft Active Server Page-Datei (.ASP). Active Server ist ein Bestandteil von Microsoft Internet Information Server, Version 3.0 oder höher.

Die .ASP-Datei enthält HTML-Marken mit Visual Basic Scripting-Code, der ActiveX Data Objects (ADO) zum Herstellen einer Verbindung zu einer ODBC-Datenquelle, in diesem Fall einer Access- oder Microsoft SQL Server-Datenbank, verwendet. Die Verbindungsinformationen beinhalten den Namen der Datenquelle und häufig auch den Benutzernamen und das Kennwort. Die beiden letzten Angaben sind optional.

Nach dem Publizieren Ihrer .ASP-Dateien auf einem Webserver führt Microsoft Internet Information Server bei entsprechender Anfrage von einem Webbrowser den darin enthaltenen Visual Basic Scripting-Code aus, ruft die ActiveX Server-Steuerelemente auf, öffnet die Datenbank (unter Verwendung des geeigneten ODBC-Treibers und der Verbindungsinformationen der .ASP-Datei, führt Abfragen in der .ASP-Datei zum Zugriff auf die Daten aus, führt die Abfrageergebenisse und HTML-Marken aus der .ASP-Datei in einer .HTML-Datei zusammen und sendet die solcherart dynamisch erstellte .HTML-Datei zum Webbrowser, der die Datei als Webseite anzeigt.

Zurück zum Anfang


 Info über Webordner

Info über Webordner

Ehe Sie Ordner und Dateien auf einem Webserver erstellen, kopieren und verwalten können, benötigen Sie einen Zugriff auf einen Webserver. Befragen Sie den Systemadministrator nach einem Webserver, mit dem Sie eine Verbindung herstellen können.

Dieses Thema enthält Referenzinformationen über:

Speichern von Dateien auf Webservern

Anzeigen und Verwalten von Ordnern und Dateien

Weitere Informationen

Speichern von Dateien auf Webservern

Mit dem Feature Webordner können Sie eine Datenzugriffsseite auf einem Webserver speichern. Zugreifen können Sie auf Webordner über Windows Explorer oder über Microsoft Access, und zwar in den Dialogfeldern Öffnen (Menü Datei), Als Datenzugriffsseite speichern (Menü Datei) oder Webseite suchen (Objektverknüpfung Bearbeitet eine vorhandene Webseite).

Den Assisstenten zum Hinzufügen eines Webordners finden Sie in Windows-Explorer im Stammverzeichnis Webordner. Mit diesem Assistenten können Sie einen Ordner erstellen, der eine Verknüpfung mit einem Webserver darstellt. Alle diese Verknüpfungen werden Webordner genannt. Sie können auch in Microsoft Access über die Dialogfelder Öffnen, Als Datenzugriffsseite speichern oder Webseite suchen einen Webordner erstellen, indem Sie in der Umgebungsleiste auf Webordner [image] und anschließend auf Neuen Ordner erstellen klicken [image]. Nach dem Erstellen des Webordners können Sie die Dateien und Ordner der Datenzugriffsseite in diesem speichern.

Zurück zum Anfang

Anzeigen und Verwalten des Inhalts von Webordnern

Sie haben drei Möglichkeiten, die Dateien und Ordner einer Datenzugriffsseite in einem Webordner anzuzeigen und zu verwalten:

Windows-Explorer Wenn Sie den Inhalt eines Webordners anzeigen, sehen Sie eine Liste mit Ordnern und Dateien sowie die mit diesen verknüpften URLs. Wie bei einem normalen Dateiserver können Sie diese Datei und Ordner verschieben, kopieren, umbenennen und löschen. Ferner können Sie die Ordner- und Dateieigenschaften anzeigen. Darüber hinaus können Sie Dateien zwischen Webservern, einem Webserver und einem Dateiserver sowie einem Webserver und der Festplatte ziehen und ablegen.

Access Über die Dialogfelder Öffnen (Menü Datei) oder Webseite suchen (Objektverknüpfung Bearbeitet eine vorhandene Webseite) können Sie die Inhalte von Webordnern anzeigen und öffnen. Im Dialogfeld Als Datenzugriffsseite speichern (Menü Datei) können Sie eine Kopie einer Datenzugriffsseite in einem Webordner speichern. Ferner können Sie einen Webordner erstellen, indem Sie in der Umgebungsleiste auf Webordner [image] und anschließend Neuen Ordner erstellen klicken.

Browser Wenn Sie eine Verbindung mit einem Webserver herstellen, auf dem Microsoft Office-Servererweiterungen ausgeführt wird, können Sie den Inhalt von Webordnern und verknüpfte Dateisystemeigenschaften im Browser anzeigen.

Zurück zum Anfang

Weitere Informationen

Erstellen eines Webordners

Öffnen einer Datenzugriffsseite auf einem Webserver

Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver in Access

Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver in Windows-Explorer

Speicherorte für Datenzugriffsseiten im Web

Richtlinien für das Verwalten von Webdateien und Verknüpfungen

Zurück zum Anfang


 Erstellen eines Webordners

Erstellen eines Webordners

Ehe Sie einen Webordner erstellen können, fragen Sie den Systemadministrator nach dem URL eines Webservers, auf dem Sie Dateien speichern können.

  1. Doppelklicken Sie in Arbeitsplatz oder im Windows-Explorer auf Webordner.

  2. Doppelklicken Sie auf Webordner hinzufügen.

  3. Befolgen Sie die Anweisungen des Assistenten zum Hinzufügen eines Webordners.

  4. Um Dateien auf dem Webserver zu speichern, ziehen Sie sie und alle Hilfsordner in den neu erstellten Webordner.

Anmerkungen

  • So erstellen Sie einen Webordner in Microsoft Access: Klicken Sie im Dialogfeld Öffnen (Menü Datei), im Dialogfeld Als Datenzugriffsseite speichern (Datenzugriffsseite Menü Datei) oder im Dialogfeld Webseite suchen (Objektverknüpfung Bearbeitet eine vorhandene Webseite) in der Umgebungsleiste auf Webordner [image] und anschließend auf Neuen Ordner erstellen [image]. Befolgen Sie dann die Anweisungen des Assistenten zum Hinzufügen eines Webordners.

  • Um schnell in Microsoft Access einen Webordner für einen vorhandenen Webserverspeicherort zu erstellen, geben Sie im Dialogfeld Als Datenzugriffsseite speichern (Menü Datei) in das Feld Dateiname die Webadresse ein. Geben Sie z. B. http://myserver ein, um einen Webordner mit diesem Ziel zu erstellen.


 Info über Speicherorte im Web

Info über Speicherorte im Web

Die Schritte zum Speichern von Datenzugriffsseiten im Web hängen von den Orten ab, an denen Sie diese freigeben wollen. Unter diesem Thema finden Sie Referenzinformationen zu:

Bereitstellen von Datenzugriffsseiten in einem Intranet

Bereitstellen von Datenzugriffsseiten im Internet

Verwalten von Webseiten in einem Intranet oder im Internet

Weitere Informationen

Bereitstellen von Datenzugriffsseiten in einem Intranet

Wenn ein Unternehmen ein Intranet verwendet, das auf Internetprotokollen basiert, können Sie Webordner verwenden, um Kopien von Datenzugriffsseiten auf einem Webserver zu speichern. Sie benötigen einen Zugriff auf einen Webserver, ehe Sie Dateien und Ordner auf diesen kopieren und auf diesem verwalten können. Um den URL zu einem Webserver zu ermitteln, auf dem Sie Dateien speichern können, befragen Sie den Systemadministrator.

  • Wenn der Webserver Webordner unterstützt, können Sie in diesen Webordnern Kopien von Webseiten auf dem Webserver speichern. Ehe Sie Ordner und Dateien auf einen Webserver kopieren und auf diesem verwalten können, wenden Sie sich an den Systemadministrator oder Internetdienstanbieter, um einen Zugriff auf den Webserver zu erhalten, auf dem Sie Dateien speichern können, sowie den entsprechenden URL. Informationen zu Webordnern.

  • Falls der Webserver FTP (File Transfer Protocol) unterstützt, können Sie eine Datenzugriffsseite in einer FTP-Site speichern. Wenden Sie sich an den Systemadministrator oder Internetdienstanbieter, um Zugriff zu einer FTP-Site zu erhalten, in der Sie Dateien speichern können.

  • Bei Fragen zum Speichern von Datenzugriffsseiten im Intranet wenden Sie sich an den Systemadministrator.

Zurück zum Anfang

Bereitstellen von Datenzugriffsseiten im Internet

Um Ihre Datenzugriffsseiten im Internet bereitstellen zu können, müssen Sie entweder einen Internetdienstanbieter kontaktieren, der Speicherplatz für Datenzugriffsseiten bereitstellt, oder Webserversoftware auf dem Computer installieren. Beim Einrichten eines Computers als Webserver müssen Sie die Geschwindigkeit und Verfügbarkeit des Computers in Betracht ziehen. Wenn Sie den Computer nicht oder nahezu rund um die Uhr in Betrieb lassen wollen, sollten Sie den Computer nicht als Webserver einsetzen.

Es folgen einige Optionen für das Speichern von Webseiten im Internet.

  • Wenn der Webserver Webordner unterstützt, können Sie in diesen Webordnern Kopien von Webseiten auf dem Webserver speichern. Ehe Sie Ordner und Dateien auf einem Webserver kopieren und verwalten können, wenden Sie sich an den Systemadministrator oder Internetdienstanbieter, um einen Zugriff auf den Webserver zu erhalten, auf dem Sie Dateien speichern können, sowie den entsprechenden URL. Informationen über Webordner.

  • Falls der Webserver FTP unterstützt, können Sie eine Datenzugriffsseite in einer FTP-Site speichern. Wenden Sie sich an den Systemadministrator oder Internetdienstanbieter, um Zugriff auf einen Speicherort zu erhalten, an dem Sie Dateien speichern können.

  • Bei Fragen zum Speichern von Datenzugriffsseiten im Internet wenden Sie sich an den Systemadministrator oder Internetdienstanbieter.

Zurück zum Anfang

Verwalten von Datenzugriffsseiten in einem Intranet oder im Internet

Wenn Sie mit einem Internetdienstanbieter oder dem Webadministrator des Unternehmens zusammenarbeiten, befragen Sie diese dazu, wie die Datenzugriffsseiten, Grafikdateien und anderen Dateien auf dem Server gespeichert sein sollen. Ermitteln Sie, ob für Aufzählungszeichen und Bilder getrennte Ordner erstellt werden müssen oder ob Sie alle Dateien an einem Speicherort speichern müssen. Wenn Sie Formulare oder Bildzuordnungen verwenden wollen, fragen Sie nach den Einschränkungen für diese Elemente, da für diese eine erweiterte Serverunterstützung erforderlich ist. Informationen zu Richtlinien für das Verwalten von Webdateien und Verknüpfungen.

Zurück zum Anfang

Weitere Informationen

Veröffentlichen von Datenzugriffsseiten und anderen Webseiten

Beheben von Fehlern bei den Optionen für Datenzugriffsseiten

Zurück zum Anfang


 Richtlinien für das Verwalten von Webdateien und Verknüpfungen

Richtlinien für das Verwalten von Webdateien und Verknüpfungen

Dieses Thema enthält Referenzinformationen über:

Verwalten und Benennen von unterstützenden Dateien

Testen von Verknüpfungen

Weitere Informationen

Wenn Sie eine Datenzugriffsseite erstellen, verwaltet Microsoft Access die entsprechenden Dateien und plant die Verknüpfungen und Hyperlinks, damit die Bilder angezeigt werden und die Verknüpfungen funktionieren, wenn die Seite auf dem endgültigen Webserver abgelegt wird.

Verwalten und Benennen von unterstützenden Dateien

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, werden alle unterstützenden Dateien, wie z. B. Aufzählungszeichen, Hintergrundstrukturen und Grafiken, standardmäßig in einem Ordner für unterstützende Dateien gespeichert. Wenn Sie eine Datenzugriffsseite an einen anderen Speicherort kopieren oder verschieben, müssen Sie auch den Ordner für unterstützende Dateien verschieben, damit alle Verknüpfungen mit der Seite beibehalten werden.

Angenommen, Sie verfügen über die Seite Page1.htm. Diese enthält Aufzählungszeichen, die in dem Ordner für unterstützende Dateien Page1_files gespeichert sind. Die relativen Pfade für die Grafikdateien sind \Page1_files\image001.gif und \Page1_files\image002.gif. Wenn Sie Page1.htm verschieben, müssen Sie auch den Ordner für unterstützende Dateien Page1_files an den neuen Speicherort verschieben.

Der Name des Ordners für unterstützende Dateien ist standardmäßig der Name der Datenzugriffsseite plus ein Unterstrich (_), ein Punkt (.) oder ein Bindestrich (-) und das Wort "files". Das Wort "files" wird in der Sprache der Version von Microsoft Office 2000 angezeigt, die zum Speichern der Datei als Datenzugriffsseite verwendet wird. Wenn Sie z. B. die deutsche Sprachversion von Office 2000 verwenden, um die Datei Page1 als Datenzugriffsseite zu speichern, ist der Standardname des Ordners für unterstützende Dateien Page1_Dateien. Weitere Informationen zum Standardnamen von Ordnern für unterstützende Dateien.

Zurück zum Anfang

Testen von Verknüpfungen

Nach dem Veröffentlichen einer Datenzugriffsseite im Internet oder einem Intranet müssen Sie diese in einem Webbrowser testen. Prüfen Sie, ob alle Grafiken angezeigt werden und ob die Hyperlinks zu den gewünschten Zielen führen.

Zurück zum Anfang

Weitere Informationen

Erstellen eines Hyperlinks in einer Datenzugriffsseite

Informationen zu gebundenen Hyperlinks in einer Datenzugriffsseite

Zurück zum Anfang


 Veröffentlichen einer Datenzugriffsseite in Webordnern oder auf einem beliebigen Webserver

Veröffentlichen einer Datenzugriffsseite in Webordnern oder auf einem beliebigen Webserver

Wichtig Eine Datenzugriffsseite ist mit einer OLE DB-Datenquelle (entweder einer Microsoft Access-Datenbank oder einer Microsoft SQL Server-Datenbank) verknüpft. Damit die Seite ordnungsgemäß funktioniert, muss die Datenbank den Benutzern der Seite zur Verfügung stehen. Weitere Informationen zum gemeinsamen Nutzen einer OLE DB-Datenquelle einer Seite.

So veröffentlichen Sie eine Datenzugriffsseitendatei durch Speichern in Webordnern

  • Wenn Sie die Seite zuerst erstellt haben, speichern Sie sie in einem Webordner unter Webordner. Wenn Sie die Seite an einer anderen Stelle als einem Webordner unter Webordner erstellen, können Sie die entsprechende HTML-Datei sowie verknüpfte Dateien und Ordner in Access unter Verwendung des Befehls Speichern unter aus dem Menü Datei speichern. Unter Verwendung des Befehls Speichern unter können Sie eine neue Datenzugriffsseite erstellen und einen Webordner unter Webordner angeben.

Informationen zum Erstellen einer Seite.

Informationen zum Speichern einer Seite in Webordnern.

Anmerkungen

  • Microsoft Access speichert automatisch verwandte Dateien, wie Grafiken, Stylesheets, verknüpfte Dateien und die Ordner, die diese Dateien enthalten, wenn Sie eine Webseite unter Webordner speichern. Informationen zum Verwalten von Webdateien und Hyperlinks.

  • Sie können nur die Verknüpfung Webordner verwenden oder einen URL (Uniform Resource Locator) in das Feld Dateiname des Dialogfeldes Öffnen eingeben, wenn Sie eine Webseite bearbeiten, die bereits existiert, oder wenn Sie eine Datenzugriffsseite in der Seitenentwurfsansicht erstellen. Informationen zu Webordnern.

So veröffentlichen Sie eine Datenzugriffsseite auf einem beliebigen Webserver

  1. Kopieren Sie die der Seite entsprechende HTML-Datei sowie zugehörige Dateien und Ordner im Windows Explorer in einen Ordner unter dem Stammverzeichnis des Webservers. Das Standardverzeichnis lautet \Webshare\Wwwroot für Personal Web Server und \Inetpub\Wwwroot für Microsoft Internet Information Server.

  2. Kopieren Sie zugehörige Dateien, wie Grafiken, Stylesheets, verknüpfte Dateien und Ordner, die diese Dateien enthalten können, in den Ordner, oder stellen Sie sicher, dass sich die zugehörigen Dateien auf dem Webserver befinden können. Informationen zum Verwalten von Webdateien und Verknüpfungen.


 Gemeinsame Nutzung der mit einer Datenzugriffsseite verbundenen Datenbank

Gemeinsame Nutzung der mit einer Datenzugriffsseite verbundenen Datenbank

Die als OLE DB-Datenquelle einer Datenzugriffseite fungierende Microsoft Access-Datenbank oder Microsoft SQL Server-Datenbank muss sich auf einem Netzwerkserver oder einem über ein Netzwerk frei zugänglichen Computer befinden, damit andere Benutzer in einem Webbrowser oder in einer E-Mail-Nachricht mit Hilfe der Seite Daten anzeigen und interaktiv aufbereiten können.

Es empfiehlt sich, die Datenbank auf einem freigegebenen Server oder Computer zu installieren, bevor Sie die Seite erstellen. Wenn Sie nach Erstellung der Seite die Datenbank verschieben, müssen Sie die OLE DB-Datenquelle der Seite aktualisieren. Dazu klicken Sie mit der rechten Maustaste in der Entwurfsansicht auf das Datenbanksymbol in der Feldliste, und anschließend klicken Sie auf Verbindung.

Wichtig Stellen Sie sicher, dass Sie als Pfadangabe eine UNC (Universal Naming Convention)-Adresse bereitstellen, anstatt sich auf den Laufwerksbuchstaben eines im Windows Explorer zugewiesenen Netzlaufwerks zu beschränken. Ein Laufwerksbuchstabe kann sich auf einem Computer ändern oder möglicherweise gar nicht definiert sein, wohingegen ein UNC-Pfad für die Seite ein verlässliches und konsistentes Instrument zum Auffinden der Datenquelle darstellt.

Obwohl als Datenquelle einer Seite nur eine Access-Datenbank oder eine SQL Server-Datenbank benutzt werden kann, ist es möglich, Daten anderer Formate innerhalb einer Datenzugriffsseite verfügbar zu machen. Sie verwenden dazu innerhalb einer Access-Datenbank sogenannte verknüpfte Tabellen.

Um größtmögliche Sicherheit für Ihre Datenzugriffsseiten zu gewährleisten, müssen Sie die Access-Datenbank bzw. SQL Server-Datenbank auf demselben Webserver einrichten wie die Datenzugriffsseiten.

Weitere Informationen

Gemeinsame Nutzung einer Access-Datenbank

Gemeinsame Nutzung einer SQL Server-Datenbank

Importieren von und Verknüpfen mit Daten in einem anderen Datenformat

Sichern einer Datenzugriffsseite


 Veröffentlichen von serverbasierten HTML-Dateien auf einem Webserver

Veröffentlichen von serverbasierten HTML-Dateien auf einem Webserver

Um servergenerierte HTML-Dateien (entweder ASP oder IDC/HTX) auf einem Webserver zu verwenden, führen Sie Folgendes aus.

  1. Installieren Sie die entsprechende Software auf dem Computer, der als Webserver fungiert und der die servergenerierten HTML-Dateien verarbeiten wird.

  2. Erstellen Sie einen Ordner unter dem Stammverzeichnis für die .ASP oder .IDC/HTX-Dateien. Das Stammverzeichnis lautet \Webshare\Wwwroot für Personal Web Server und \Inetpub\Wwwroot für Microsoft Internet Information Server.

  3. Definieren Sie die entsprechenden Privilegien für den Ordner: Ausführen für Windows NT 4.0 oder höher und Skripts ausführen für Windows 95 oder höher. Weitere Informationen zur gemeinsamen Nutzung von Ordnern finden Sie in der Windows-Hilfe.

  4. Kopieren Sie die .ASP- oder die .IDC/HTX-Dateien in den Ordner. Kopieren Sie die zugehörigen Dateien, wie Grafiken, verknüpfte Dateien und ggf. Ordner, die diese Dateien enthalten, ebenfalls in den Ordner, oder stellen Sie sicher, dass die Webserver-Software die zugehörigen Dateien finden kann. Weitere Informationen zum Verwalten von Webseiten und Hyperlinks.

  5. Kopieren Sie die Microsoft Access-Datenbank oder die Microsoft SQL Server-Datenbank in den Ordner, oder definieren Sie dessen Netzwerkadresse in der ODBC-Datenquellendefinition in Schritt 6.

  6. Definieren Sie die ODBC-Datenquelle auf dem Webserver als System-DSN. Stellen Sie sicher, dass die Datenquelle den Namen hat, den Sie beim Ausgeben der .ASP- oder .IDC/HTX-Dateien in das entsprechende Dialogfeld Ausgabeoptionen eingegeben haben. Weitere Informationen zum Definieren einer ODBC-Datenquelle.

  7. Definieren Sie bei Bedarf die Datenbanksicherheit für die ODBC-Datenquelle, stellen Sie jedoch sicher, dass der Benutzer auch auf die ODBC-Datenquelle zugreifen kann.

    Erstellen Sie für eine Microsoft Access-Datenbank einen Benutzernamen und ein Kennwort für Sicherheit auf Benutzerebene, das Benutzern erlaubt, aus der Webseite heraus auf die Access-Datenbank zuzugreifen. Wenn Sie keine Sicherheitsmaßnahmen auf Benutzerebene (Benutzername und Kennwort) festlegen, wird der Standardbenutzername Admin und kein Kennwort verwendet. Weitere Informationen zu Sicherheit auf Benutzerebene in einer Access-Datenbank.

    Erstellen Sie für ein Microsoft Access-Projekt in den Feldern Benutzername und Kennwort den Namen und das Kennwort, um Benutzern zu erlauben, von der Webseite aus auf die Microsoft SQL Server-Datenbank zuzugreifen. Wenn Sie keinen Benutzernamen und kein Kennwort erstellen, wird der Standardbenutzername Sa und kein Kennwort verwendet. Weitere Informationen zu SQL Server-Datenbanksicherheit.

    Der Benutzername und das Kennwort müssen dem Benutzernamen und dem Kennwort entsprechen, den/das Sie in die Felder Benutzername und Benutzerkennwort des Dialogfeldes Microsoft Active Server Pages-Ausgabeoptionen oder des Dialogfeldes HTX/IDC- Ausgabeoptionen eingegeben haben. Diese werden beim Ausgeben der .ASP- und .IDC/HTX-Dateien angezeigt.

Anmerkung Wenn Sie mehrere Datenblätter exportieren müssen, können Sie den Vorgang automatisieren. Dazu erstellen Sie ein Makro oder ein Visual Basic für Applikationen-Programm. Dies ist besonders nützlich, wenn Sie häufig Datenblätter zum Testen und Erstellen einer Website exportieren.


 Veröffentlichen statischer HTML-Seiten in Webordnern oder auf einem beliebigen Webserver

Veröffentlichen statischer HTML-Seiten in Webordnern oder auf einem beliebigen Webserver

  1. Zum Veröffentlichen einer statischen HTML-Datei in Webordnern kopieren Sie die statische HTML-Datei(en) unter Verwendung von Windows Explorer in einen Webordner unter Webordner. Weitere Informationen zu Webordnern.

    Zum Veröffentlichen einer statischen HTML-Datei auf einem beliebigen Webserver kopieren Sie die Datei unter Verwendung von Windows Explorer in einen Ordner unter dem Stammverzeichnis des Webservers. Das Stammverzeichnis lautet standardmäßig \Webshare\Wwwroot für Personal Web Server und \Inetpub\Wwwroot für Microsoft Internet Information Server.

  2. Kopieren Sie zugehörige Dateien, wie Grafiken, Stylesheets, verknüpfte Dateien und Ordner, die diese Dateien enthalten können, in den Ordner, oder stellen Sie sicher, dass sich die zugehörigen Dateien auf dem Webserver befinden können. Informationen zum Verwalten von Webdateien und Verknüpfungen.

Anmerkung Wenn Sie mehrere Tabellen, Abfragen, Formulare oder Berichte exportieren, können Sie den Vorgang automatisieren. Dazu erstellen Sie ein Makro oder ein Visual Basic für Applikationen-Programm. Dies ist besonders nützlich, wenn Sie häufig Tabellen, Abfragen, Formulare und Berichte zum Testen und Erstellen einer Website exportieren.


 Standardnamen für die Ordner für unterstützende Dateien von Datenzugriffsseiten

Standardnamen für die Ordner für unterstützende Dateien von Datenzugriffsseiten

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, werden alle unterstützenden Dateien wie Aufzählungszeichen, Hintergrundstrukturen und Grafiken standardmäßig in einem Ordner für unterstützende Dateien gespeichert. Der Name des Ordners für unterstützende Dateien ist standardmäßig der Name der Datenzugriffsseite plus ein Unterstrich (_), ein Punkt (.) oder ein Bindestrich (-) und das Wort "files". Das Wort "files" wird in der Sprache der Version von Microsoft Office 2000 angezeigt, die zum Speichern der Datei als Datenzugriffsseite verwendet wird. Wenn Sie z. B. die deutsche Sprachversion von Office 2000 verwenden, um die Datei Seite1 als Datenzugriffsseite zu speichern, ist der Standardname des Ordners für unterstützende Dateien Seite1_Dateien.

Anmerkung Wenn Sie eine Datenzugriffsseite mit einem kurzen Dateinamen (mit höchstens acht Zeichen plus drei Zeichen für die Erweiterung) speichern, indem Sie das Kontrollkästchen Wenn möglich, lange Dateinamen verwenden im Dialogfeld Weboptionen deaktivieren, hat der Ordner für unterstützende Dateien den Namen der Datenzugriffsseite ohne den Zusatz "Dateien".

Die folgende Tabelle zeigt die Übersetzung für "files" in allen Sprachversionen von Office 2000.

Office 2000-Sprache | Standardname für den Ordner für unterstützende Dateien einer Webseite
Arabisch | ".files"
Baskisch | "_fitxategiak"
Brasilianisch | "_arquivos"
Bulgarisch | ".files"
Chinesisch (Traditionell) | ".files"
Chinesisch (Vereinfacht) | ".files"
Dänisch | "-filer"
Deutsch | "-Dateien"
Englisch | "_files"
Estnisch | "_failid"
Finnisch | "_tiedostot"
Französisch | "_fichiers"
Griechisch | ".files"
Hebräisch | ".files"
Italienisch | "-file"
Japanisch | ".files"
Katalanisch | "_fitxers"
Koreanisch | ".files"
Kroatisch | "_datoteke"
Lettisch | "_bylos"
Litauisch | "_fails"
Niederländisch | "_bestanden"
Norwegisch | "-filer"
Polnisch | "_pliki"
Portugiesisch | "_ficheiros"
Rumänisch | ".files"
Russisch | ".files"
Schwedisch | "-filer"
Serbisch (Kyrillisch) | ".files"
Serbisch (Lateinisch) | "_fajlovi"
Slowakisch | ".files"
Slowenisch | "_datoteke"
Spanisch | "_archivos"
Thai | ".files"
Tschechisch | "_soubory"
Türkisch | "_dosyalar"
Ukrainisch | ".files"
Ungarisch | "_elemei"
Vietnamesisch | ".files"


 Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver im Windows-Explorer

Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver im Windows-Explorer

  1. Klicken Sie im Windows-Explorer mit der rechten Maustaste auf die Datei, die Sie auf einen Webserver kopieren oder verschieben wollen.

  2. Klicken Sie im Kontextmenü auf Kopieren.

  3. Doppelklicken Sie auf Webordner.

  4. Doppelklicken Sie in der Liste der Webordnersites auf den gewünschten Ordner, und klicken Sie anschließend mit der rechten Maustaste auf den Zielordner, in dem Sie die Datenzugriffsseite speichern wollen.

  5. Klicken Sie im Kontextmenü auf Einfügen.

  6. Wenn der Webserver nicht angezeigt wird, auf dem Sie die Datenzugriffsseite speichern wollen, doppelklicken Sie im Stammverzeichnis der Webordner auf Webordner hinzufügen, um einen neuen Webordner hinzuzufügen. So erstellen Sie einen Webordner.

Tipp Wenn Sie eine Datenzugriffsseite speichern, werden alle unterstützenden Dateien, wie z. B. Aufzählungszeichen, Hintergrundstrukturen und Grafiken, standardmäßig in einem Ordner für unterstützende Dateien gespeichert. Wenn Sie eine Seite an einen anderen Speicherort kopieren oder verschieben, müssen Sie auch den Ordner für unterstützende Dateien verschieben, damit alle Verknüpfungen mit der Seite beibehalten werden. Informationen zum Verwalten von Webdateien und Verknüpfungen.


 Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver in Access

Speichern einer Kopie einer Datenzugriffsseite auf einem Webserver in Access

Sie können eine Kopie einer Microsoft Access-Datenzugriffsseite auf einem Webserver speichern.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Doppelklicken Sie auf die Datenzugriffsseite, die Sie öffnen wollen.

  3. Klicken Sie im Menü Datei auf Speichern unter.

  4. Geben Sie in das Feld Datenzugriffsseite <Objektname> speichern in den Namen der Datenzugriffsseite ein.

  5. Klicken Sie im Dialogfeld Als Datenzugriffsseite speichern in der Umgebungsleiste auf Webordner.

  6. Doppelklicken Sie in der Liste der Webordner-Sites auf den gewünschten Ordner, und doppelklicken Sie anschließend auf den Speicherort, an dem Sie die Datenzugriffsseite speichern wollen.

  7. Klicken Sie auf Speichern.

Tipp Um schnell in Microsoft Access einen Webordner für einen vorhandenen Webserverspeicherort zu erstellen, geben Sie im Dialogfeld Als Datenzugriffsseite speichern (Menü Datei) in das Feld Dateiname die Webadresse ein. Geben Sie z. B. http://myserver ein, um einen Webordner mit diesem Ziel zu erstellen.


 Öffnen einer Datenzugriffsseite auf einem Webserver in Access

Öffnen einer Datenzugriffsseite auf einem Webserver in Access

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Doppelklicken Sie auf die Objektverknüpfung Bearbeitet eine vorhandene Webseite.

  3. Klicken Sie in der Umgebungsleiste auf Webordner [image] , und doppelklicken Sie dann auf den Ordner im Web, der die Datenzugriffsseite enthält, die Sie öffnen möchten.

  4. Suchen Sie in der Ordnerliste den gewünschten Ordner, der die Datenzugriffsseite enthält.

  5. Doppelklicken Sie auf die Seite, die Sie öffnen wollen.

Anmerkung Stellen Sie sicher, dass der Ordner mit den unterstützenden Dateien auch in demselben Ordner ist, damit etwaige Verknüpfungen erhalten bleiben. Informationen zu Richtlinien für das Verwalten von Webdateien und Verknüpfungen.

Tipps

  • Um schnell eine Datenzugriffsseite auf einem Webserver zu öffnen, geben Sie in das Feld Dateiname die Adresse der zu öffnenden Seite ein, und drücken Sie die EINGABETASTE. Sie können z. B. http://Umsätze/Februar/Seite1.htm eingeben, um eine Seite der Vertriebsabteilung zu öffnen. Wenn nicht bereits ein Webordner unter http://Umsätze/Februar vorhanden ist, wird dieser automatisch erstellt, wenn Sie eine Adresse in das Feld Dateiname eingeben.

  • Wenn die Symbolleiste Web angezeigt wird, können Sie die Adresse in das Feld Adresse eingeben und anschließend die EINGABETASTE drücken, um die Seite schnell im Browser zu öffnen.


 Info über Onlinebesprechungen

Info über Onlinebesprechungen

Dieses Thema enthält Referenzinformationen über:

Iniziieren einer Onlinebesprechung

Teilnehmen an einer Onlinebesprechung

Zusammenarbeiten in einer Onlinebesprechung

Weitere Informationen

Durch die Integration des Programms Microsoft NetMeeting in Microsoft Office können Sie an verschiedenen Standorten in Echtzeit Informationen für Dritte freigeben oder mit diesen austauschen, als befänden sich alle im selben Raum. Eine Onlinebesprechung können Sie in allen Office-Anwendungen iniziieren. (Sie können auch direkt in NetMeeting arbeiten, indem Sie im Windows Startmenü auf NetMeeting klicken.) Wenn Sie eine Onlinebesprechung in einer Office-Anwendung starten, wird NetMeeting automatisch im Hintergrund gestartet, so dass Sie mit der Freigabe des Inhalts einer Datei beginnen können. Sie können eine Onlinebesprechung entweder iniziieren oder zur Teilnahme an dieser eingeladen werden.

Iniziieren einer Onlinebesprechung

Starten der Besprechung Sie können entweder mit Microsoft Outlook (siehe Microsoft Outlook-Hilfe) die Besprechung im Vorfeld planen oder in einer Microsoft Access-Datenbank, einem Microsoft Access-Projekt oder einer Datenzugriffsseite, die/das Sie freigeben möchten, spontan eine Onlinebesprechung starten. Wenn die Teilnehmer verfügbar sind und die Einladung annehmen, beginnt die Onlinebesprechung.

Kontrollieren der Access-Datenbank, des Access-Projekts oder der Datenzugriffsseite Zu Beginn einer Onlinebesprechung sind Sie der Einzige, der die Kontrolle über die Access-Datenbank, das Access-Projekt oder die Datenzugriffsseite hat, obwohl diese den Teilnehmern auf ihren Bildschirmen angezeigt werden. Sie können den Teilnehmern erlauben, Änderungen vorzunehmen, indem Sie die Zusammenarbeit einschalten, die Sie jederzeit wieder ausschalten können. Bei ausgeschalteter Zusammenarbeit können die Teilnehmer keine Änderungen mehr ausführen, jedoch weiter Ihre Arbeit verfolgen. Wenn die Zusammenarbeit eingeschaltet ist, können die Teilnehmer der Onlinebesprechung nacheinander die Bearbeitung und Kontrolle der Access-Datendatei übernehmen. Hat ein anderer die Kontrolle, können Sie den Cursor nicht nur in der Access-Datendatei, sondern auch zu keinem anderen Zweck verwenden. Neben dem Zeiger werden die Initialen der Person angezeigt, die die Kontrolle hat.

Hinzufügen von Teilnehmern zu einer laufenden Besprechung Sie können jederzeit zu einer laufenden Onlinebesprechung weitere Teilnehmer einladen. Teilnehmer, die Sie zu einer spontanen Onlinebesprechung einladen, müssen auf ihren Computern NetMeeting ausführen, damit sie die Einladung zu einer Onlinebesprechung empfangen können. So starten Sie Microsoft NetMeeting.

Zurück zum Anfang

Teilnehmen an einer Onlinebesprechung

Wenn Sie zu einer Onlinebesprechung eingeladen werden, erhalten Sie eine Nachricht, die Sie zur Teilnahme an einer kommenden oder laufenden Onlinebesprechung zu einem angegebenen Zeitpunkt und Datum auffordert. Wenn Sie die Einladung zu der Onlinebesprechung annehmen, werden auf dem Bildschirm die Symbolleiste Onlinebesprechung und die Microsoft Access-Datenbank, das Microsoft Access-Projekt oder die Datenzugriffsseite angezeigt, die/das freigegeben werden soll.

Zurück zum Anfang

Zusammenarbeiten in einer Onlinebesprechung

Bei einer Onlinebesprechung können Sie Anwendungen und Dokumente freigeben, Textnachrichten in Chat senden, Dateien übertragen und im Whiteboard arbeiten. Bei der Zusammenarbeit können die Teilnehmer die Kontrolle über die Access-Datenbank, das Access-Projekt oder die Datenzugriffsseite übernehmen, um deren/dessen Inhalt zu überprüfen und zu bearbeiten. Während einer Onlinebesprechung kann nur ein Teilnehmer gleichzeitig die Kontrolle über die Access-Datendatei übernehmen. Bei ausgeschalteter Zusammenarbeit können jedoch mehrere Benutzer in Chat oder im Whiteboard zusammenarbeiten. Der Initiator der Onlinebesprechung ist der einzige Teilnehmer, auf dessen Computer das freigegebene Dokument und dessen Anwendung vorhanden sein muss.

Zurück zum Anfang

Weitere Informationen

Verwenden von NetMeeting für eine Online-Besprechung

Zurück zum Anfang


 Verwenden von NetMeeting für eine Online-Besprechung

Verwenden von NetMeeting für eine Online-Besprechung

Microsoft NetMeeting bietet auf dem Desktop Datenfunktionen, mit deren Hilfe Sie in Echtzeit über das Internet oder das Intranet Ihres Unternehmens mit anderen kommunizieren und zusammenarbeiten können.

Anmerkung Wenn Sie erstmalig eine Onlinebesprechung starten, werden Sie aufgefordert, einen Verzeichnisserver auszuwählen, mit dem Sie sich verbinden können. Sie können unter Verzeichnis in der Liste in Servername einen beliebigen Verzeichniserver auswählen. Wenn Sie in einem Intranet arbeiten, fragen Sie den Systemadministrator nach dem Namen des Verzeichnisservers, mit dem Sie sich verbinden können.

Informationen zu Onlinebesprechungen.

  1. Starten einer Onlinebesprechung

    Starten einer spontanen Onlinebesprechung

  2. Teilnehmen an einer Onlinebesprechung

    Teilnehmen an einer Onlinebesprechung

    Entfernen von Teilnehmern aus einer Onlinebesprechung

    Hinzufügen von Teilnehmern zu einer bereits laufenden Onlinebesprechung

  3. Möglichkeiten der Kommunikation während einer Onlinebesprechung

    Kontrollieren einer Microsoft Access-Datenbank, eines Microsoft Access-Projekts oder einer Datenzugriffsseite während einer Onlinebesprechung

    Arbeiten im Whiteboard während einer Onlinebesprechung

    Senden eingegebener Nachrichten während einer Onlinebesprechung

  4. Beenden einer Onlinebesprechung

    Beenden einer Onlinebesprechung


Starten von NetMeeting

  • Zeigen Sie im Windows Startmenü auf Programme, und klicken Sie dann auf NetMeeting.


Teilnehmen an einer Onlinebesprechung

Führen Sie einen der folgenden Schritte aus:

  • Wenn Sie Initiator einer Onlinebesprechung sind und eine Microsoft Outlook-Onlinebesprechungserinnerung zu einer Besprechung empfangen, klicken Sie auf NetMeeting starten. Klicken Sie auf Schließen, um eine Anforderung einer Onlinebesprechung abzulehnen.

  • Wenn Sie zu einer Onlinebesprechung eingeladen sind und eine Microsoft Outlook-Onlinebesprechungserinnerung zu einer Besprechung empfangen, klicken Sie auf An dieser Netzbesprechung teilnehmen. Klicken Sie auf Schließen, um eine Anforderung einer Onlinebesprechung abzulehnen.

  • Wenn Sie einen Onlinebesprechungsanruf empfangen, klicken Sie im Dialogfeld An Besprechung teilnehmen auf Zusagen. Klicken Sie auf Ignorieren, um eine Onlinebesprechung abzulehnen. (Microsoft NetMeeting muss auf dem Computer ausgeführt werden, damit Sie einen Onlinebesprechungsanruf empfangen können.)


 Kontrollieren einer Access-Datenbank, eines Access-Projekts oder einer Datenzugriffsseite während einer Onlinebesprechung

Kontrollieren einer Access-Datenbank, eines Access-Projekts oder einer Datenzugriffsseite während einer Onlinebesprechung

Zu Beginn der Besprechung kontrolliert der Initiator die Microsoft Access-Datenbank, das Microsoft Access-Projekt oder die Datenzugriffsseite. Der Initiator kann die Zusammenarbeit für die Teilnehmer aktivieren und jederzeit deaktivieren. Bei eingeschalteter Zusammenarbeit kann ein beliebiger Teilnehmer die Access-Datenbank, das Access-Projekt oder die Datenzugriffsseite kontrollieren. Jedoch kann nur eine Person gleichzeitig die Kontrolle haben. Bei ausgeschalteter Zusammenarbeit können mehrere Teilnehmer gleichzeitig im Chat oder im Whiteboard zusammenarbeiten.

Kontrollieren einer Access-Datenbank, eines Access-Projekts oder einer Datenzugriffsseite als Initiator

  • Um die Zusammenarbeit einzuschalten, klicken Sie in der Symbolleiste Onlinebesprechung auf Anderen das Bearbeiten ermöglichen [image] .

  • Um bei eingeschalteter Zusammenarbeit wieder die Kontrolle über die Access-Datenbank, das Access-Projekt oder die Datenzugriffsseite zu erlangen, klicken Sie auf eine beliebige Stelle in der Access-Datendatei.

  • Um die Zusammenarbeit auszuschalten, klicken Sie nochmals auf Anderen das Bearbeiten ermöglichen, wenn Sie die Kontrolle haben, oder drücken Sie ESC, wenn Sie die Kontrolle nicht haben.

Kontrollieren einer Access-Datenbank, eines Access-Projekts oder einer Datenzugriffsseite als Teilnehmer

Um erstmalig die Kontrolle über ein/e freigegebene/s Access-Datenbank, ein Access-Projekt oder eine Datenzugriffsseite zu erlangen, doppelklicken Sie auf eine beliebige Stelle in der Access-Datendatei. Anschließend können Sie die Kontrolle wiedererlangen, indem Sie auf eine beliebige Stelle in der Access-Datendatei klicken.

Nur der Initiator der Besprechung kann die Symbolleiste Onlinebesprechung verwenden. Wenn Sie während einer Onlinebesprechung Funktionen von Microsoft NetMeeting stärker nutzen wollen, müssen Sie NetMeeting direkt verwenden, indem Sie in der Taskleiste auf Microsoft NetMeeting klicken.

Anmerkung Neben dem Mauszeiger werden die Initialen der Person angezeigt, die die Kontrolle innehat.


Anzeigen der Teilnehmerliste einer Onlinebesprechung

  • Klicken Sie in der Symbolleiste Onlinebesprechung auf die Teilnehmerliste. Wenn Teilnehmer zu der Onlinebesprechung hinzukommen oder diese verlassen, wird die Liste aktualisiert.


 Senden eingegebener Nachrichten während einer Onlinebesprechung

Senden eingegebener Nachrichten während einer Onlinebesprechung

Nur der Initiator der Onlinebesprechung kann in Microsoft Office das Fenster Chat öffnen. Wenn die Teilnehmer das Fenster Chat öffnen wollen, müssen sie das Programm Microsoft NetMeeting direkt verwenden, indem sie in der Symbolleiste auf Microsoft NetMeeting klicken.

  1. Klicken Sie in der Symbolleiste Onlinebesprechung auf Chatfenster anzeigen [image] .

  2. Geben Sie in das Feld E-Mail-Nachricht den gewünschten Text ein, und drücken Sie dann die EINGABETASTE.

Tipp Die Kommunikation über das Chatfenster erfolgt schneller, wenn der Initiator die Zusammenarbeit ausschaltet. Um die Zusammenarbeit auszuschalten, klicken Sie (wenn Sie die Kontrolle haben) in der Symbolleiste Onlinebesprechung auf Anderen das Bearbeiten ermöglichen [image] , oder drücken Sie ESC (wenn Sie nicht die Kontrolle haben).


 Arbeiten im Whiteboard während einer Onlinebesprechung

Arbeiten im Whiteboard während einer Onlinebesprechung

Nur der Initiator der Onlinebesprechung kann in Microsoft Office das Fenster Whiteboard öffnen. Wenn die Teilnehmer das Fenster Whiteboard öffnen wollen, müssen Sie das Programm Microsoft NetMeeting direkt verwenden, indem sie in der Taskleiste auf Microsoft NetMeeting klicken.

  • Klicken Sie in der Symbolleiste Onlinebesprechung auf Whiteboard anzeigen [image] .

    Das Fenster Whiteboard wird angezeigt.

Anmerkung Damit die Teilnehmer gleichzeitig in das Whiteboard zeichnen und eingeben können, muss der Iniziator die Zusammenarbeit ausschalten. Wenn Sie die Kontrolle über die Microsoft Access-Datenbank, das Microsoft Access-Projekt oder die Datenzugriffsseite haben, klicken Sie in der Symbolleiste Onlinebesprechung auf Anderen das Bearbeiten ermöglichen [image] . Wenn Sie nicht die Kontrolle haben, drücken Sie ESC.


 Entfernen von Teilnehmern aus einer Onlinebesprechung

Entfernen von Teilnehmern aus einer Onlinebesprechung

Anmerkung Der Initiator einer Onlinebesprechung ist der Einzige, der Teilnehmer aus einer Onlinebesprechung entfernen kann.

  1. Klicken Sie in der Symbolleiste Onlinebesprechung auf den Namen des Teilnehmers, den Sie aus der Teilnehmerliste entfernen wollen.

  2. Klicken Sie auf Teilnehmer entfernen [image] .


 Beenden einer Onlinebesprechung

Beenden einer Onlinebesprechung

  • Klicken Sie in der Symbolleiste Onlinebesprechung auf Besprechung beenden [image] .

Anmerkung Der Initiator der Onlinebesprechung ist der Einzige, der eine Onlinebesprechung für die gesamte Gruppe beenden kann. Die Teilnehmer an einer Onlinebesprechung können die Verbindung trennen, indem sie in der Taskleiste auf Microsoft NetMeeting und dann in der Symbolleiste von NetMeeting auf Auflegen klicken. Wenn der Initiator eine Onlinebesprechung beendet, werden die anderen Teilnehmer der Onlinebesprechung automatisch voneinander getrennt.


 Mit welchem NetMeeting-Verzeichnisserver soll eine Verbindung hergestellt werden?

Mit welchem NetMeeting-Verzeichnisserver soll eine Verbindung hergestellt werden?

Wenn Sie erstmalig eine Onlinebesprechung starten, werden Sie aufgefordert, einen Verzeichnisserver auszuwählen, mit dem Sie sich verbinden können. Sie können unter Verzeichnis in der Liste in Servername einen beliebigen Verzeichniserver auswählen. Wenn Sie in einem Intranet arbeiten, fragen Sie den Systemadministrator nach dem Namen des Verzeichnisservers, mit dem Sie sich verbinden können.


 Bericht-Snapshots und Snapshot Viewer

Bericht-Snapshots und Snapshot Viewer

Sie können in Microsoft Access erstellte Berichte anzeigen, drucken, senden und elektronisch verteilen, ohne dass hierzu eine Voll- oder Laufzeitlizenz für Microsoft Access erforderlich ist. Zu folgenden Themen stehen Informationen zur Verfügung:

Was ist ein Bericht-Snapshot?

Was ist Snapshot Viewer?

Vorteile von Bericht-Snapshots und Snapshot Viewer

Verwenden von Bericht-Snapshots

Verwenden von Bericht-Snapshots im World Wide Web

Senden von Bericht-Snapshots in E-Mails

Erstellen und Verteilen von Bericht-Snapshots

Weitere Informationen

Zurück zum Anfang

Was ist ein Bericht-Snapshot?

Ein Bericht-Snapshot ist eine Datei (mit der Erweiterung .SNP), die eine qualitativ hochwertige Kopie jeder Seite eines Microsoft Access-Berichts enthält und die das zweidimensionale Layout, die Abbildungen und andere eingebettete Objekte des Berichts beibehält.

Zurück zum Anfang

Was ist Snapshot Viewer?

Snapshot Viewer ist ein Programm, das zum Anzeigen, Drucken und Senden eines Snapshots, z.B. eines Bericht-Snapshots, verwendet werden kann. Snapshot Viewer, Version 9.0, besteht aus einem unabhängigen, ausführbaren Programm, einem Snapshot Viewer-Steuerelement (Snapview.ocx), einer Hilfedatei und anderen zugehörigen Dateien. Standardmäßig wird Snapshot Viewer automatisch von Microsoft Access 2000 installiert, wenn Sie erstmals einen Bericht-Snapshot erstellen. Darüber hinaus können Sie Snapshot Viewer über das Setupprogramm installieren oder über eine WWW-Seite zum Herunterladen von Software, die sich auf der Microsoft Access-Entwicklerwebsite befindet.

Sie können das Snapshot Viewer-Steuerelement verwenden, um einen Snapshot aus Microsoft Internet Explorer, Version 3.0 oder höher, oder aus einer anderen Anwendung anzuzeigen, die ActiveX-Steuerelemente unterstützt, z.B. Access oder Microsoft Visual Basic für Applikationen.

Zurück zum Anfang

Vorteile von Bericht-Snapshots und Snapshot Viewer

Wenn Sie Berichte drucken und an Benutzer innerhalb und außerhalb Ihres Unternehmens verteilen, kann die Verwendung von Bericht-Snapshots Zeit und Geld sparen. Sie müssen die gedruckten Microsoft Access-Berichte nicht fotokopieren und versenden, sondern können sie elektronisch verteilen und veröffentlichen, entweder über E-Mail oder mittels eines Webbrowsers, z.B. Microsoft Internet Explorer. Benutzer erhalten leicht und schnell Onlinezugriff auf die Berichte und können nur die für sie erforderlichen Berichtseiten ausdrucken. Dies ist vor allem dann von Vorteil, wenn Ihre Berichte Farb- und Bildelemente, z.B. Diagramme und Grafiken enthalten.

Zurück zum Anfang

Verwenden von Bericht-Snapshots

Sie können einen Bericht-Snapshot mit Microsoft Access 2000 erstellen. Um einen Bericht-Snapshot anzuzeigen, zu drucken, zu speichern, zu veröffentlichen, zu verteilen oder zu archivieren, ist jedoch keine Access-Lizenz erforderlich. Statt dessen kann eine Kombination aus Snapshot Viewer und anderen Programmen, wie Windows Explorer, einem E-Mail-Programm oder einem Webbrowser, z.B. Internet Explorer, verwendet werden.

Zurück zum Anfang

Verwenden von Bericht-Snapshots im World Wide Web

Es gibt zwei Möglichkeiten, um einen Bericht-Snapshot im World Wide Web zu veröffentlichen:

  • Sie können eine Verknüpfung zu dem Bericht-Snapshot erstellen, indem Sie eine HTML-Ankermarke auf einer Webseite verwenden. Zum Beispiel:
    <A HREF="http://Website/NWTraders/catalog.snp">Catalog report</A>

    Wird Internet Explorer, Version 3.0 oder höher, als Browser verwendet, werden der Bericht-Snapshot und Snapshot Viewer an der jeweiligen Stelle im Internet Explorer-Fenster aktiviert, wenn Sie auf die Verknüpfung klicken. Andere Browser öffnen den Bericht-Snapshot in einem eigenen Snapshot Viewer-Fenster. In jedem Fall müssen Snapshot Viewer und der Browser auf demselben Computer installiert sein. Es ist daher sinnvoll, eine zusätzliche Verknüpfung zu der Webseite zu erstellen, von der Snapshot Viewer heruntergeladen werden kann. Benutzer, auf deren Computer Snapshot Viewer nicht installiert ist, können Snapshot Viewer herunterladen und installieren, um den Bericht anzuzeigen.

  • Sie können das Snapshot Viewer-Steuerelement auf der Webseite einbetten, indem Sie eine HTML-Objektmarke verwenden. Zum Beispiel:
    <OBJECT ID="SnapshotViewer" WIDTH=640 HEIGHT=480
 CLASSID="CLSID:F0E42D60-368C-11D0-AD81-00A0C90DC8D9">
    <PARAM NAME="_ExtentX" VALUE="16722">
    <PARAM NAME="_ExtentY" VALUE="11774">
    <PARAM NAME="_Version" VALUE="65536">
    <PARAM NAME="SnapshotPath"
 VALUE="http://Website/NWTraders/catalog.snp">
    <PARAM NAME="Zoom" VALUE="0">
    <PARAM NAME="AllowContextMenu" VALUE="-1">
    <PARAM NAME="ShowNavigationButtons" VALUE="-1">
</OBJECT>

    Um das Snapshot Viewer-Steuerelement einzubetten, verwenden Sie das Microsoft ActiveX-Steuerelement, und stellen Sie die Steuerelementparameter mit Hilfe des Steuerelement-Eigenschaftenfensters ein.

    Diese Methode kann nur mit Internet Explorer 3.0 oder höher verwendet werden. Sind Snapshot Viewer und der Browser nicht auf demselben Computer installiert, lädt Internet Explorer automatisch das ActiveX-Steuerelement für Snapshot Viewer (nicht jedoch das gesamte Snapshot Viewer-Programm) herunter.

Zurück zum Anfang

Senden von Bericht-Snapshots in E-Mails

Mit Hilfe von Snapshot Viewer oder Microsoft Access können Sie einen Bericht-Snapshot in einer E-Mail senden. Darüber hinaus können Sie einen Bericht-Snapshot als Symbol oder Datei in eine E-Mail-Nachricht einbetten, sofern Sie ein E-Mail-Programm verwenden, das ActiveX-Steuerelemente unterstützt, z.B. Microsoft Outlook oder Microsoft Exchange. Wenn Sie Bericht-Snapshots in E-Mails senden, sollten Sie immer eine Verknüpfung zu der Webseite einfügen, von der Snapshot Viewer heruntergeladen werden kann.

Weitere Informationen über das Senden von Bericht-Snapshots in E-Mail-Nachrichten

Zurück zum Anfang

Erstellen und Verteilen von Bericht-Snapshots

Eine typische Unternehmensanwendung erstellt und verteilt Berichte nicht nur auf Anforderung, sondern auch nach einem an regelmäßigen Unternehmensabläufen ausgerichteten Plan, z.B. wöchentlichen Aktienkursen, monatlichen Umsatzberichten oder vierteljährlichen Bilanzen.

Mit Microsoft Access 2000 stehen Ihnen verschiedene Möglichkeiten zur Verfügung, um Bericht-Snapshots planmäßig zu erstellen und zu verteilen. Zum Beispiel:

  • Erstellen eines Makros, das mit Hilfe der /AusgabeIn-Aktion einen oder mehrere Berichte im Snapshotformat auf einen Webserver exportiert, der zum Veröffentlichen der Berichte verwendet wird.

  • Erstellen eines Makros, das mit Hilfe der SendenObjekt-Aktion einen Bericht an einen Mailempfänger oder eine Verteilerliste sendet.

  • Erstellen eines VBA-Programms (Visual Basic für Applikationen).

Zurück zum Anfang

Weitere Informationen

Erstellen eines Bericht-Snapshots

Zurück zum Anfang


Erstellen von Berichts-Snapshots

  1. Klicken Sie im Datenbankfenster auf den Namen des Berichts, der exportiert werden soll, und klicken Sie dann im Menü Datei auf Exportieren.

  2. Klicken Sie im Feld Dateityp auf Snapshot Format (*.snp).

  3. Klicken Sie auf den Pfeil rechts neben dem Feld Speichern in, und wählen Sie das Laufwerk bzw. den Ordner aus, in den die Datei exportiert werden soll.

  4. Geben Sie im Feld Dateiname den Dateinamen ein.

  5. Klicken Sie auf Speichern.

    Standardmäßig wird der Berichts-Snapshot im Snapshot Viewer angezeigt. Falls dies der erste Berichts-Snapshot ist, den Sie erstellen, und Sie beim Setup-Vorgang den Snapshot Viewer nicht installieren ließen, installiert Microsoft Access den Snapshot Viewer jetzt automatisch.

Anmerkungen

  • Der Berichts-Snapshot basiert auf der Datensatzgruppe, die dem Bericht zugrunde liegt, einschließlich der aktuellen Einstellungen für die Sortiert nach- oder Filter-Eigenschaften.

  • Falls der Bericht eine Parameterabfrage enthält, fragt Access Sie zunächst nach den Parameterwerten, bevor die Resultate ausgegeben werden.

  • Sie können auch die AusgabeIn-Aktion in einem Makro verwenden, um den Bericht in das Snapshot-Format zu exportieren.


 Erstellen eines Berichts-Snapshots unter Verwendung der "AusgabeIn"-Aktion und Bereitstellen des Snapshots im Web

Erstellen eines Berichts-Snapshots unter Verwendung der "AusgabeIn"-Aktion und Bereitstellen des Snapshots im Web

  1. Erstellen Sie ein Makro mit einer oder mehreren AusgabeIn-Aktionen, d. h. eine für jeden Bericht, der im Snapshot-Format ausgegeben werden soll. Beispiel:

    Erstellen des Snapshot-Makros

    Aktion | Argument | Wert
    AusgabeIn | Objekttyp | Bericht
    Objektname | Katalog
    Ausgabeformat | Snapshot-Format
    Ausgabedatei | \\Website\Inetpub\wwwroot\Webreports\Katalog.snp *
    Autostart | Nein

    * Ausgabe direkt in den Ordner auf dem World Wide Web-Server.

  2. Führen Sie in der Homepage der Website einen der folgenden Schritte durch:
    • Erstellen Sie mittels HTML-Anker-Tags einen Link zu jedem Berichts-Snapshot. Beispiel:
      <A HREF="http://Website/WebReports/katalog.snp">Katalog-Bericht</A>
    • Betten Sie das Snapshot Viewer-Steuerelement mit Hilfe der Anwendung Microsoft ActiveX Control Pad in ein HTML-Objekt-Tag ein, und legen Sie die Steuerelementparameter über den Control Pad-Objekteditior fest (diese Methode können Sie nur mit Microsoft Internet Explorer, Version 3.0 oder höher anwenden). Beispiel:
      <OBJECT ID="SnapshotViewer" WIDTH=640 HEIGHT=480
 CLASSID="CLSID:F0E42D60-368C-11D0-AD81-00A0C90DC8D9">
    <PARAM NAME="_ExtentX" VALUE="16722">
    <PARAM NAME="_ExtentY" VALUE="11774">
    <PARAM NAME="_Version" VALUE="65536">
    <PARAM NAME="SnapshotPath"
 VALUE="http://Website/WebReports/katalog.snp">
    <PARAM NAME="Zoom" VALUE="0">
    <PARAM NAME="AllowContextMenu" VALUE="-1">
    <PARAM NAME="ShowNavigationButtons" VALUE="-1">
</OBJECT>

Anmerkungen

  • Falls der Bericht auf einer Parameterabfrage basiert, müssen Sie das Makro für die Ausführung in einer Stapelverarbeitungsdatei modifizieren. Entweder übergeben Sie die Parameterdaten mittels der Aktion Tastaturbefehle, oder Sie ändern den Bericht, indem Sie die Parameterabfrage entfernen und stattdessen spezifische Kriterien verwenden.

  • Sie können auch eine Visual Basic für Applikationen-Anwendung für diese Aufgabe erstellen.


 Versenden eines Berichts-Snapshots per E-Mail unter Verwendung der "SendenObjekt"-Aktion

Versenden eines Berichts-Snapshots per E-Mail unter Verwendung der "SendenObjekt"-Aktion

  • Erstellen Sie ein Makro mit einer Aktion SendenObjekt. Beispiel:

Makro Snapshot senden

Aktion | Argument | Wert
SendenObjekt | Objekttyp | Bericht
 | Objektname | Zusammenfassung der Quartalsumsätze
 | Ausgabeformat | Snapshot-Format
 | An | Alle Nordwind-Händler; Gesellschafter
 | Cc |
 | Bcc |
 | Betreff | Quartalsbericht über Umsätze
 | Nachrichtentext | Dies war unser erfolgreichstes Quartal seit Jahren!
 | Nachricht bearbeiten | Nein

Anmerkungen

  • Je nach Konfiguration Ihres E-Mail-Programms ist ein softwaregestütztes Versenden Ihres Berichts-Snapshots eventuell nicht möglich, nämlich dann, wenn das E-Mail-Programm eine Anmeldung und Informationseingabe anfordert. Zum Beispiel kann Microsoft Outlook so konfiguriert werden, dass Sie beim Anmelden nach einem Benutzerprofil gefragt werden. In diesem Fall müssen Sie die Einstellungen Ihres E-Mail-Programms ändern.

  • Sie können auch eine Visual Basic für Applikationen-Anwendung für diese Aufgabe erstellen.


 Info über das Schützen einer Microsoft Access-Datenbank

Info über das Schützen einer Microsoft Access-Datenbank

Dieses Thema enthält Referenzinformationen über:

Schützen einer Microsoft Access-Datenbankdatei

Schützen von Datenbankobjekten mit Sicherheitsmaßnahmen auf Benutzerebene

Schützen von Visual Basic für Applikationen-Code (VBA-Code)

Schützen von Datenzugriffsseiten

Schützen von Anwendungen

Sicherheit in Mehrbenutzerumgebungen

Zurück zum Anfang

Schützen einer Microsoft Access-Datenbankdatei

Die einfachste Schutzmethode ist das Festlegen eines Kennworts zum Öffnen einer Microsoft Access-Datenbank (.mdb). Nachdem ein Kennwort festgelegt ist, erscheint beim Öffnen der Datenbank ein Dialogfeld, in das ein Kennwort eingegeben werden muss. Nur Benutzer, die das richtige Kennwort eingeben, können die Datenbank öffnen. Diese Methode ist sicher (Microsoft Access verschlüsselt das Kennwort, so dass dieses auch bei direktem Lesen in der Datenbankdatei nicht gelesen werden kann), es schützt jedoch nur das Öffnen der Datenbank. Sobald eine Datenbank geöffnet ist, stehen dem Benutzer alle Objekte zur Verfügung (es sei denn, es wurden darüber hinaus weitere Sicherheitsmaßnahmen definiert, wie weiter unten in diesem Themenabschnitt beschrieben). Für eine Datenbank, die nur von einer kleinen Benutzergruppe gemeinsam oder auf einem Einzelcomputer genutzt wird, reicht es in der Regel aus, ein Kennwort festzulegen.

Achtung Verwenden Sie kein Datenbankkennwort, wenn Sie eine Datenbank replizieren möchten. Replizierte Datenbanken können nicht synchronisiert werden, wenn für sie ein Kennwort festgelegt wurde.

Um die Datenbank weitergehend zu schützen, können Sie sie verschlüsseln. Durch das Verschlüsseln wird die Datenbankdatei komprimiert und für entsprechende Dienst- oder Textverarbeitungsprogramme unentzifferbar. Beim Entschlüsseln der Datenbank wird die Verschlüsselung rückgängig gemacht.

Zurück zum Anfang

Schützen von Datenbankobjekten mit Sicherheitsmaßnahmen auf Benutzerebene

Die flexibelste und weitreichendste Methode zum Schützen einer Datenbank ist der Einsatz von Sicherheitsmaßnahmen auf Benutzerebene. Diese Form der Sicherheit ähnelt den in den meisten Netzwerken verwendeten Methoden. Die beiden Hauptgründe für den Einsatz von Sicherheitsmaßnahmen auf Benutzerebene sind:

  • Verhindern der versehentlichen Beschädigung einer Anwendung durch Benutzer, die Tabellen, Abfragen, Formulare, Berichte oder Makros ändern könnten, auf denen die Anwendung basiert.

  • Schützen empfindlicher Daten in der Datenbank.

Beim Einsatz von Sicherheitsmaßnahmen auf Benutzerebene müssen sich Benutzer beim Starten von Microsoft Access durch eine Kennung identifizieren und ein Kennwort eingeben. In einer Arbeitsgruppen-Informationsdatei werden sie als Mitglied einer Gruppe identifiziert. Microsoft Access unterstützt zwei Standardgruppen: Administratoren (genannt Gruppe Administratoren) und Benutzer (genannt Gruppe Benutzer). Sie können darüber hinaus weitere Gruppen definieren.

Die Einrichtung von Sicherheitsmaßnahmen auf Benutzerebene ist in den meisten Datenbanken ein langwieriger Vorgang; der Benutzer-Datensicherheits-Assistent hingegen ermöglicht den raschen Schutz Ihrer Access-Datenbank in einem einzigen Schritt. Durch das Einrichten der häufigsten Sicherheitsschemen nimmt Ihnen der Benutzer-Datensicherheits-Assistent die Notwendigkeit ab, dies selbst mit dem Befehl Zugriffsrechte im Menü Extras vorzunehmen.

Nach dem Ausführen des Benutzer-Datensicherheits-Assistenten können Sie Berechtigungen für Benutzer- und Gruppenkonten in Ihrer Arbeitsgruppe für die Datenbank und ihre zugehörigen Tabellen, Abfragen, Formulare, Berichte und Makros erteilen oder zurücknehmen. Sie können auch die Standardberechtigungen einstellen, die Microsoft Access für in Datenbanken erstellte neue Tabellen, Abfragen, Formulare, Berichte und Makros erteilt.

Berechtigungen werden Gruppen und Benutzern erteilt, um zu regeln, in welcher Weise sie mit den Tabellen, Abfragen, Formularen, Berichten und Makros einer Datenbank arbeiten dürfen. Sie können beispielsweise festlegen, dass die Mitglieder der Gruppe Benutzer in einer Tabelle Kunden Daten anzeigen, eingeben oder ändern, nicht jedoch den Entwurf der Tabelle ändern dürfen. Ein anderes Beispiel: die Gruppe Benutzer könnte die Berechtigung zum Anzeigen von Daten in einer Tabelle mit Bestellinformationen erhalten, und Sie könnten gleichzeitig jeglichen Zugriff auf eine Tabelle mit Gehaltsdaten ausschließen. Mitglieder der Gruppe Administratoren haben vollen Zugriff auf alle Tabellen, Abfragen, Formulare, Berichte und Makros einer Datenbank. Wenn Sie die unterschiedlichen Berechtigungen sehr detailliert verteilen möchten, können Sie eigene Gruppenkonten erstellen, diesen Gruppen die entsprechenden Berechtigungen erteilen, und dann Benutzer zu diesen Gruppen hinzufügen.

Falls Sie für Ihre Sicherheitsanforderungen nur eine Gruppe Administratoren und eine Gruppe Benutzer benötigen, brauchen Sie keine weiteren Gruppen zu erstellen; verwenden Sie einfach die standardmäßig angelegten Gruppen Administratoren und Benutzer. In diesem Fall müssen Sie lediglich der Standardgruppe Benutzer die vorgesehenen Berechtigungen erteilen sowie eventuelle weitere Administratoren zur Standardgruppe Administratoren hinzufügen. Wenn Sie neue Benutzer hinzufügen, werden diese automatisch der Gruppe Benutzer hinzugefügt. Zu den üblichen Berechtigungen für die Gruppe Benutzer zählen "Daten lesen" und "Daten aktualisieren" für Tabellen und Abfragen sowie "Öffnen/Ausführen" für Formulare und Berichte.

Wenn Sie für verschiedene Gruppen von Benutzern detailliert abgestimmte Kontrollmöglichkeiten benötigen, können Sie eigene Gruppenkonten erstellen, diesen Gruppen jeweils unterschiedliche Berechtigungen erteilen und dann Benutzer in diese Gruppen aufteilen. Um die Rechteverwaltung zu erleichtern, ist es empfehlenswert, ausschließlich Berechtigungen an Gruppen zu vergeben (nicht an einzelne Benutzer), und dann die Benutzer der jeweils passenden Gruppe zuzuordnen.

Anmerkung Weitere Informationen zum Microsoft Access-Sicherheitsmodell finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang

Schützen von Visual Basic für Applikationen-Code (VBA-Code)

Sie können auch Microsoft Visual Basic für Applikationen-Code (VBA-Code) in Modulen und hinter Formularen und Berichten stehenden Modulen mit einem Kennwort schützen, das Sie bei jeder Sitzung einmal eingeben müssen. Das Kennwort verhindert, dass unautorisierte Benutzer VBA-Code bearbeiten, ausschneiden, einfügen, kopieren, exportieren und löschen können.

Um das intellektuelle Eigentum an Ihrem Code zu schützen, können Sie durch Speichern der Datenbank als .MDE-Datei editierbaren VBA-Code aus Ihrer Datenbank entfernen und damit Änderungen am Entwurf von Formularen, Berichten und Modulen verhindern.

Informationen zum Schützen von VBA-Code erhalten

Zurück zum Anfang

Schützen von Datenzugriffsseiten

Um eine Datenzugriffsseite sowie die Daten zu schützen, auf die sie zugreift, führen Sie folgende Maßnahmen durch:

  • Schützen Sie die Access-Datenbank, welche die Verknüpfung zu der Datenzugriffsseite und der zugehörigen HTML-Datei enthält, durch Sicherheitsmaßnahmen auf Dateisystemebene auf dem Computer, auf dem diese Dateien gespeichert sind.

  • Schützen Sie die mit der Datenzugriffsseite verbundene Datenbank, indem Sie sie gegen unautorisierte Benutzer sichern, beim Anmelden von Benutzern die Zugriffsrechte kontrollieren und das Datenbankkennwort nicht mit der Datenzugriffsseite speichern.

  • Verhindern Sie unautorisierte Zugriffe von böswilligen Visual Basic-Skripten durch die Verwendung der Sicherheitsoptionen von Microsoft Internet Explorer und des "Three-tier"-Datenzugriffs.

Informationen zum Schützen von Datenzugriffsseiten erhalten

Zurück zum Anfang

Schützen von Anwendungen

Schließlich können Sie verhindern, dass Ihre Anwendung durch neugierige oder böswillige Endbenutzer versehentlich oder absichtlich beschädigt wird, indem Sie Datenbankobjekte aus dem Datenbankfenster ausblenden und verschiedene Startoptionen einrichten, mit denen Sie Erscheinungsbild und Verhalten der Anwendung steuern und Menüs und Befehlsleisten sperren können.

Zurück zum Anfang

Sicherheit in Mehrbenutzerumgebungen

In manchen Fällen wollen Sie wahrscheinlich verhindern, dass Benutzer eine Datenbank replizieren können. Das Replizieren einer Datenbank bedeutet, dass Benutzer Kopien von freigegebenen Datenbanken erstellen und außerdem Felder hinzufügen oder andere Änderungen an der aktuellen Datenbank vornehmen können. Vermutlich wollen Sie Benutzer auch daran hindern, selbst Datenbankkennwörter zu vergeben. Wenn ein Benutzer ein Datenbankkennwort für eine freigegebene Datenbank vergibt, kann kein anderer Benutzer diese Datenbank öffnen, ohne dieses Kennwort einzugeben. Zudem sollten Benutzer meistens nicht die Möglichkeit haben, Starteigenschaften zu ändern, in denen spezielle Features wie angepasste Menüs, spezielle Symbolleisten oder das Startformular festgelegt sind.

Wenn für eine freigegebene Datenbank keine Sicherheitsmaßnahmen auf Benutzerebene definiert sind, können Sie Benutzer nicht daran hindern, derartige Änderungen vorzunehmen. Legen Sie hingegen mit Hilfe des Benutzer-Datensicherheits-Assistenten Sicherheitsmaßnahmen auf Benutzerebene für eine Datenbank fest, können Sie den Zugriff auf bestimmte Features steuern und bestimmen, auf welche Weise Datenbankobjekte verwendet werden können. Ist die Sicherheit auf Benutzerebene definiert, müssen Benutzer oder Gruppen über Verwaltungs-Berechtigungen für die Datenbank verfügen, um in der Lage zu sein, die Datenbank zu replizieren, ein Datenbankkennwort festzulegen oder Starteigenschaften zu verändern. Nach dem Ausführen des Benutzer-Datensicherheits-Assistenten besitzen nur Mitglieder der Gruppe Administratoren der aktuellen Arbeitsgruppe die Berechtigung "Verwalten".

Falls die Sicherheit auf Benutzerebene bereits definiert ist und ein Benutzer oder eine Gruppe gegenwärtig die Berechtigung "Verwalten" für eine Datenbank besitzt, können Sie diese Berechtigung zurücknehmen, um zu verhindern, dass der Benutzer oder die Gruppe die oben beschriebenen Aktionen durchführen kann. Muss jedoch ein Benutzer oder eine Gruppe in der Lage sein, eine dieser Aktionen durchzuführen, müssen Sie die Berechtigung "Verwalten" an diesen Benutzer oder die Gruppe erteilen. Es ist nicht möglich, den Zugriff auf diese drei Aktionen unabhängig voneinander zu regeln.

Zurück zum Anfang


 Schützen einer Datenzugriffsseite

Schützen einer Datenzugriffsseite

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Sichern der Verknüpfung einer Datenzugriffsseite und der zugehörigen HTML-Datei

Sichern und Steuern des Datenbankzugriffs aus einer Datenzugriffsseite heraus

Abwehr eines unberechtigten Zugriffs durch ein unsicheres Skript

Sichern der Verknüpfung einer Datenzugriffsseite und der zugehörigen HTML-Datei

Eine Datenzugriffsseite ist eine Kombination aus einer Verknüpfung, die in einer Microsoft Access-Datenbank (.mdb) oder in einem Microsoft Access-Projekt (.adp) gespeichert ist, und einer zugehörigen HTML (Hypertext Markup Language)-Datei, die sich innerhalb des Dateisystem Ihres Computers befindet. Um die Verknüpfung einer Seite sowie die zugehörige HTML-Datei gegen Umbenennung, Löschung oder Änderung zu schützen, verwenden Sie die Sicherheitsmaßnahmen des Dateisystems auf dem Computer, auf dem Sie diese beiden Dateien gespeichert haben. Sie haben beispielsweise die Möglichkeit, die auf Ihrem Computer befindlichen Dateien der Access-Datenbank bzw. des Access-Projekts, in denen die Verknüpfung der Seite gespeichert ist, mit einem Schreibschutzattribut zu versehen. Oder Sie können (nach dem Veröffentlichen der Seite) die der Seite zugeordnete HTML-Datei sowie den übergeordneten Ordner auf dem Webserver, auf dem diese gespeichert ist, mit einem Schreibschutzattribut versehen. Weitere Informationen über Sicherheit für Dateien und Ordner finden Sie in der Hilfe für Microsoft Windows.

Zurück zum Anfang

Sichern und Steuern des Datenbankzugriffs aus einer Datenzugriffsseite heraus

Wenn Sie für eine Datenzugriffsseite den sicheren Zugriff auf eine mit ihr verbundene Access-Datenbank oder Microsoft SQL Server-Datenbank gewährleisten möchten, sollten Sie die folgenden Vorkehrungen in Betracht ziehen:

Sichern Sie die Datenbank Sie können eine Seite entweder mit einer Access-Datenbank oder mit einer SQL Server-Datenbank verbinden. In jedem dieser Fälle sollten Sie zunächst geeignete Sicherheitsmaßnahmen zum Schutz der jeweiligen Datenbank treffen, um auf dieser Grundlage den Zugriff auf die Datenbank durch die Datenzugriffseite zu sichern. Wie bei jeder anderen Anwendung müssen Sie unberechtigte Benutzer daran hindern, auf die Datenbank zuzugreifen, und Sie müssen das Ausmaß des Zugriffs kontrollieren, indem Sie festlegen, wie ein Benutzer nach erfolgreicher Anmeldung bei der Datenbank agieren darf.

  • Wenn es sich um eine Access-Datenbank handelt, die durch Sicherheit auf Benutzerebene geschützt ist, und wenn Sie diesen Sicherheitsgrad auch für den Zugriff über die Seite einrichten möchten, müssen Sie sicherstellen, dass die Verbindungsinformationen für die Seite die richtige Arbeitsgruppeninformationsdatei benennen und dass diese Datei sich in einem freigegebenen öffentlichen Netzwerkordner befindet, auf den alle Benutzer zugreifen dürfen. Sie ändern die Verbindungsinformationen für die Seite, indem Sie im Dialogfeld Datenlinkeigenschaften auf die Registerkarte Alle klicken, auf den Eintrag Jet OLEDB:System database doppelklicken und anschließend die UNC-Adresse für die richtige Arbeitsgruppeninformationsdatei im Feld Eigenschaftswert eingeben. Weitere Informationen über das Sichern einer Access-Datenbank.

    Wenn Sie ein Datenbankkennwort für eine Access-Datenbank festgelegt haben, die mit einer Seite verbunden ist, werden Sie beim ersten Zugriff auf die Seite zur Eingabe des Kennworts aufgefordert.

  • Handelt es sich um eine SQL Server-Datenbank, und Sie möchten für die Verbindung mit einer Seite die integrierte Sicherheit von Windows NT benutzen, so ändern Sie die Verbindungsinformationen für die Seite, indem Sie im Dialogfeld Datenlinkeigenschaften auf die Registerkarte Verbindung klicken und anschließend die Option Integrierte Sicherheit von Windows NT verwenden auswählen. Weitere Informationen über das Sichern einer SQL Server-Datenbank.

Vermeiden Sie es, den Benutzernamen und das Kennwort zusammen mit der Seite zu speichern Wenn Benutzername und Datenbankkennwort zusammen mit der Seite gespeichert werden, kann sich jeder Benutzer bei der Datenbank anmelden. Sollen die Benutzer beim Seitenaufruf explizit zur Anmeldung bei der Datenbank aufgefordert werden, so ändern Sie die Verbindungsinformationen für die Seite, indem Sie im Dialogfeld Datenlinkeigenschaften auf die Registerkarte Verbindung klicken und anschließend das Kontrollkästchen Speichern des Kennworts zulassen deaktivieren.

Stellen Sie nur Datensätze bereit, die einen Bezug zum Benutzer aufweisen Möglicherweise möchten Sie eine Seite erstellen, die keine Eingabe von Benutzernamen und Kennwort benötigt, sondern die Benutzeridentität automatisch ermitteln kann und nur Datensätze auf Grundlage dieses Namens anzeigt. Beispielsweise können Sie eine Seite erstellen, die Benutzern den Zugriff auf ihre Personaldaten ermöglicht. Für eine solche Aktion sind allgemein die folgenden Schritte durchzuführen:

  • Erstellen Sie eine Seite in einem Access-Projekt, das mit einer SQL Server-Datenbank verbunden ist, die ihrerseit durch die integrierte Sicherheit von Microsoft Windows NT geschützt ist.

  • Fügen Sie der Tabelle Personal eine neue Spalte hinzu, die für jeden Mitarbeiter den zur Anmeldung bei Windows NT benötigten Benutzernamen enthält.

  • Erstellen Sie eine Sicht, die unter Verwendung der suser_sname()-Funktion die Identität des aktuell angemeldeten Benutzers ermittelt, und legen Sie diese Sicht als Datensatzquelle der Seite fest.

Ein ausführliches Beispiel hierzu finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang

Abwehr eines unberechtigten Zugriffs durch ein unsicheres Skript

Eine Datenzugriffsseite verwendet das Microsoft Office Datenquellen-Steuerelement (Microsoft Office Data Source Control, MSODSC), um eine Verbindung mit ihrer Datenquelle einzurichten. Wenn ein Benutzer die Seite öffnet, verwendet das MSODSC der Seite unter Umständen den Benutzernamen zur Anmeldung bei der Datenbank. Ein Seitenautor mit schädlichen Absichten könnte diesen Umstand ausnutzen, indem er unter Verwendung eines Microsoft Visual Basic, Scripting Edition- oder JScript-Skripts das MSODSC ansteuert und versucht, auf Datenbanken zuzugreifen, die für den Benutzer, aber nicht für den Seitenautor zugänglich sind. Der vom MSODSC benutzte Datenzugriffsmodus legt fest, ob eine Seite als inhärent sicher eingestuft wird, oder ob bereichsüberschreitender Datenzugriff über die Seite möglich ist. Sie können über die Konfiguration des MSODSC zwischen zwei Arten des Datenzugriffs, dem Zwei-Schichten- oder dem Drei-Schichten-Datenzugriff, auswählen

Beim Zwei-Schichten-Datenzugriff gibt es eine direkte Verbindung mit der Datenquelle, die dem herkömmlichen Client/Server-Modell entspricht - der Client (die erste Schicht) stellt eine direkte Verbindung zum Datenbankserver (der zweiten Schicht) her. Zur Durchführung eines Zwei-Schichten-Datenzugriffs stellt das MSODSC eine direkte Verbindung mit seiner Datenquelle her und verwendet dazu einen OLE DB-Anbieter, der auf dem Computer des Benutzers registriert ist. Im Falle einer Access-Datenbank verwendet der Zwei-Schichten-Datenzugriff den Anbieter "Microsoft Jet 4.0 OLE DB-Provider", um sich mit einer MDB-Datei in einem freigegebenen Netzwerkordner zu verbinden. Bei einer SQL Server-Datenbank benutzt der Zwei-Schichten-Datenzugriff den "Microsoft OLE DB-Provider für SQL Server", um sich mit einem auf Ihrem lokalen Netzwerk verfügbaren Datenbankserver zu verbinden.

Der Drei-Schichten-Datenzugriff bezieht eine dritte, nicht lokale Komponente ein, die zwischen Client- und Datenbankkomponente geschaltet wird. Ein typisches Beispiel für einen Drei-Schichten-Zugriff ist der Abruf von Daten über das Internet. Bei Drei-Schichten-Datenzugriffen unter Verwendung des MSODSC ist diese dritte Komponente die zu den ADO (ActiveX Data Objects)-Objekten gehörende Remote Data Service (RDS)-Komponente (auch als "Data Factory" bezeichnet wird). Sie ist Bestandteil von Microsoft Internet Information Server (IIS).

Bei jeder Seite, die den Zwei-Schichten-Datenzugriff verwendet, wird von Microsoft Internet Explorer angenommen, dass ein bereichsüberschreitenden Zugriff versucht wird. Je nach im Internet Explorer festgelegten Sicherheitseinstellungen tritt eines von drei Ereignissen ein, wenn ein Benutzer eine Seite mit dem Zwei-Schichten-Zugriff öffnet: die Seite wird automatisch deaktiviert, der Benutzer wird gefragt, ob er den Datenzugriff gestattet, oder die Seite wird automatisch aktiviert.

Die Sicherheitseinstellungen des Internet Explorers definieren außerdem unterschiedliche Sicherheitszonen. Wenn sich eine Seite auf einem Webserver befindet, der zur Zone vertrauenswürdiger Sites gehört, kann der bereichsübergreifende Zugriffsversuch automatisch aktiviert werden. In einer kontrollierten Umgebung, beispielsweise einem unternehmenseigenen Intranet, lassen sich Datenzugriffsseiten effizienter handhaben, wenn Sie den Zwei-Schichten-Datenzugriff verwenden und sicherstellen, dass die Seiten von einem Server veröffentlicht werden, der zu einer vertrauenswürdigen Sicherheitszone gehört. Dies stellt die einfachste Methode dar, sich gegen nicht berechtigten Zugriff durch unsichere Skripts zu schützen. Weitere Informationen über Sicherheitseinstellungen finden Sie in der Hilfe zu Internet Explorer.

Eine Seite, die den Drei-Schichten-Datenzugriff verwendet, um die Verbindung mit einer Datenbank herzustellen, wird als inhärent sicher eingestuft, und zwar unabhängig davon, aus welcher Internet Explorer-Sicherheitszone heraus die Seite veröffentlicht wurde. Der Benutzer wird außerdem beim Öffnen der Seite nicht vor bereichsüberschreitendem Zugriff gewarnt, sofern die Authentifizierungseinstellungen auf ihren Standardwerten belassen wurden.

Weitere Informationen über die Implementierung des Zwei-Schichten- und Drei-Schichten-Zugriffs finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang


Festlegen der Sicherheit auf Benutzerebene für eine bestimmte Microsoft Access-Datenbank

Wenn Benutzer unter Verwendung des Arbeitsgruppen-Administrators Mitglied einer Microsoft Access-Arbeitsgruppe werden, wird die Adresse der Arbeitsgruppen-Informationsdatei in der Windows-Registrierung gespeichert, was bedeutet, dass in vielen Fällen alle Access-Datenbanken auf dem Benutzercomputer (basierend auf den Daten dieser Arbeitsgruppen-Informationsdatei) durch Sicherheit auf Benutzerebene geschützt sind.

Es kann jedoch vorkommen, dass Sie den Sicherheitsbestimmungen auf Benutzerebene nur bei einer bestimmten Datenbank und nicht unbedingt auch bei den anderen Datenbank verwenden möchten. Dies erreichen Sie, indem Sie den Beitritt eines Benutzers zu einer Microsoft Access-Arbeitsgruppe nicht über den Arbeitsgruppen-Administrator, sondern über die Durchführung der folgenden Schritte veranlassen:

  1. Erstellen Sie eine Arbeitsgruppeninformationsdatei, und speichern Sie sie unter einer Adresse, auf die alle Benutzer dieser bestimmten Datenbank zugreifen dürfen.

  2. Erstellen Sie eine Verknüpfung, welche die bestimmte Datenbank startet, und verwenden Sie dabei die Befehlszeilenoption /wrkgrp zur Festlegung der Pfadadresse der Arbeitsgruppeninformationsdatei. Beispiel:

    "C:\Programme\Microsoft Office\Office\MSACCESS.EXE \\Verkaufssystem\DBDateien\VerkaufsS.mdb /wrkgrp \\Verkaufssystem\DBDateien\VerkaufsS.mdw"

    Weitere Informationen über das Erstellen von Verknüpfungen finden Sie in der Online-Hilfe für Windows.


 Schützen von VBA (Visual Basic für Applikationen)-Code

Schützen von VBA (Visual Basic für Applikationen)-Code

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Schützen von VBA (Visual Basic für Applikationen)-Code

Module, Formulare, Berichte und die Sicherheit auf Benutzerebene

Schützen von VBA (Visual Basic für Applikationen)-Code

In einem Microsoft Access-Projekt und einer Microsoft Access-Datenbank können Sie alle Module sowie allen Code schützen, der Formularen und Berichten zugeordnet ist. Zu diesem Zweck schützen Sie VBA-Code mit einem besonderen Kennwort, das Sie und andere Benutzer bereitstellen müssen, um den Code im Visual Basic Editor anzuzeigen oder zu bearbeiten. Nachdem Sie ein Kennwort definiert haben, geben Sie dieses Kennwort einmal bei jeder Sitzung ein. Das Kennwort ist nicht nur zum Anzeigen und Bearbeiten, sondern auch zum Ausschneiden, Kopieren, Einfügen, Exportieren und Löschen von Modulen erforderlich. Beachten Sie jedoch, dass diese Art von Codesicherung nicht verhindert, dass Sie oder andere Benutzer vorhandenen VBA-Code ausführen.

Zurück zum Anfang

Module, Formulare, Berichte und die Sicherheit auf Benutzerebene

In einer Microsoft Access 2000-Datenbank werden Module und Code für Formulare und Berichte nicht mehr durch Sicherheit auf Benutzerebene geschützt wie in vorhergehenden Versionen. Aber Formulare und Berichte selbst sind weiterhin auf diese Weise geschützt. Daraus folgt, das Module einerseits und Fomulare und Berichte andererseits durch zwei verschiedene Sicherheitsmechanismen geschützt werden.

Vorausgesetzt Sie haben die geeigneten Berechtigungen, können Sie beispielsweise ein Steuerelement zu einem Formular hinzufügen, aber wenn das VBA-Projekt für die Anzeige gesperrt und durch ein Kennwort geschützt ist, und wenn Sie dieses Kennwort nicht wissen, können Sie den Code des Formulars weder anzeigen noch bearbeiten. Umgekehrt sind Sie möglicherweise durch entsprechend restriktive Sicherheitsbestimmungen auf Benutzerebene daran gehindert, Änderungen am Entwurf vorzunehmen, aber wenn Sie das Kennwort des VBA-Projekts kennen, sind Sie in der Lage, auf den Code zuzugreifen, der dem Formular oder Bericht zugeordnet ist.

Es gibt diesbezüglich eine Ausnahme. Selbst wenn Sie für ein Formular oder einen Bericht die Berechtigung Entwurf ändern besitzen, können Sie das Formular bzw. den Bericht nicht löschen und auch die Enthält Modul-Eigenschaft nicht auf den Wert Nein setzen, da diese Aktion das Modul mit dem Code für das Formular bzw. den Bericht löschen würde.

Zurück zum Anfang


 MDE-Dateien

MDE-Dateien

Wenn Ihre Microsoft Access-Datenbank Microsoft Visual Basic-Code enthält und Sie sie als MDE-Datei speichern, werden alle Module kompiliert. Der gesamte editierbare Quellcode wird entfernt und die Zieldatenbank komprimiert. Ihr Visual Basic-Code lässt sich weiterhin ausführen, kann jedoch nicht angezeigt oder bearbeitet werden. Darüber hinaus wird Ihre Access-Datenbank durch das Entfernen des Codes kleiner, die Speichernutzung wird optimiert und dadurch die Leistung verbessert.

Das Speichern Ihrer Access-Datenbank als MDE-Datei verhindert die folgenden Aktionen:

  • Anzeigen, Ändern oder Erstellen von Formularen, Berichten oder Modulen in der Entwurfsansicht.

  • Hinzufügen, Löschen oder Ändern von Verweisen auf Objektbibliotheken oder Datenbanken.

  • Ändern von Code unter Verwendung der Eigenschaften oder Methoden der Microsoft Access- oder VBA-Objektmodelle - weil eine MDE-Datei keinen Quellcode enthält.

  • Importieren oder Exportieren von Formularen, Berichten oder Modulen. Tabellen, Abfragen, Datenzugriffsseiten und Makros dagegen können aus Nicht-MDE-Datenbanken in eine MDE-Datenbank importiert bzw. aus einer MDE-Datenbank in Nicht-MDE-Datenbanken exportiert werden. Alle Tabellen, Abfragen, Datenzugriffsseiten und Makros können in eine Access-Datenbank importiert werden, während dies für Formulare, Berichte und Module nicht gilt.

Vorsicht Achten Sie darauf, eine Kopie Ihrer Originaldatenbank zu speichern. Wenn der Entwurf von Formularen, Berichten oder Modulen in einer als MDE-Datei gespeicherten Access-Datenbank geändert werden muss, müssen Sie die Originaldatenbank öffnen, sie ändern und dann erneut als MDE-Datei speichern. Wird eine Access-Datenbank mit Tabellen als MDE-Datei gespeichert, führt dies bei einer späteren Änderung des Entwurfs der Formulare, Berichte oder Module zu Komplikationen, da unterschiedliche Versionen der Daten in Einklang gebracht werden. Aus diesem Grunde eignet sich das Speichern einer Access-Datenbank als MDE-Datei am besten für die Front-End-Datenbank einer Front-End/Back-End-Anwendung.

Vorsicht Ebenso wird es nicht möglich sein, Code einer MDE-Datei in Microsoft Access 2000 in zukünftigen Versionen von Microsoft Access zu öffnen, zu konvertieren oder auszuführen. Um eine MDE-Datei aus Microsoft Access 2000 für eine zukünftige Version konvertieren zu können, muss die Originaldatenbank, aus der die MDE-Datei erstellt wurde, geöffnet und konvertiert werden, und anschließend muss die konvertierte Access-Datenbank als MDE-Datei gespeichert werden.

Wichtig Einige Einschränkungen hindern Sie möglicherweise daran, Ihre Access-Datenbank als MDE-Datei zu speichern:

  • Wenn Ihre Datenbank mit Sicherheit auf Benutzerebene geschützt ist, müssen Sie bestimmte Kriterien erfüllen. Informationen über die Verwendung anderer Sicherheitsmaßnahmen in Verbindung mit einer als MDE-Datei gespeicherten Access-Datenbank.

  • Sie müssen über kennwortgeschützten Zugriff auf den Visual Basic-Code verfügen. Informationen über das Schützen von Visual Basic-Code.

  • Wenn Ihre Datenbank repliziert ist, müssen Sie zuerst die Tabellen und Eigenschaften des Replikationssystems entfernen.

  • Wenn Ihre Access-Datenbank auf eine andere Datenbank oder ein Add-In verweist, müssen Sie alle Access-Datenbanken oder Add-Ins in der Verweiskette als MDE-Dateien speichern.


 Datenbankverweise und MDE-Dateien

Datenbankverweise und MDE-Dateien

Wenn Sie versuchen, eine Microsoft Access-Datenbank (.MDB) oder ein Add-In (.MDA) zu speichern, das auf eine andere Access-Datenbank oder ein anderes Add-In verweist, zeigt Microsoft Access eine Fehlermeldung an, und Sie können diesen Vorgang nicht beenden. Zum Speichern einer Access-Datenbank, die auf eine andere Access-Datenbank als MDE-Datei verweist, müssen Sie alle Datenbanken in der Verweiskette als MDE-Dateien speichern und dabei mit der ersten Datenbank, auf die verwiesen wird, beginnen. Nach dem Speichern der ersten Datenbank als MDE-Datei ändern Sie den Verweis in der nächsten Datenbank so, dass er auf die neue MDE-Datei zeigt, bevor Sie diese Datenbank als MDE-Datei speichern, usw.

Wenn z.B. DATENBANK1.MDB auf DATENBANK2.MDB verweist, die wiederum auf DATENBANK3.MDA verweist, verfahren Sie folgendermaßen:

  1. Speichern Sie DATENBANK3.MDA als DATENBANK3.MDE.

  2. Öffnen Sie DATENBANK2.MDB, und ändern Sie deren Verweis so, dass er auf die neue DATENBANK3.MDE zeigt.

  3. Speichern Sie DATENBANK2.MDB als DATENBANK2.MDE.

  4. Öffnen Sie DATENBANK1.MDB, und ändern Sie deren Verweis so, dass er auf die neue DATENBANK2.MDE zeigt.

  5. Speichern Sie DATENBANK1.MDB als DATENBANK1.MDE.


 Speichern einer replizierten Microsoft Access-Datenbank als MDE-Datei

Speichern einer replizierten Microsoft Access-Datenbank als MDE-Datei

Eine replizierte Datenbank (entweder ein Replikat oder ein Designmaster) kann nicht als MDE-Datei gespeichert werden. Bevor Sie eine replizierte Datenbank als MDE-Datei speichern können, müssen Sie die Tabellen und Eigenschaften des Replikationssystems entfernen. Weitere Informationen zum Entfernen von Replikations-Features.

Wenn eine Datenbank als MDE-Datei gespeichert wurde, kann sie repliziert werden; diese Replikation ist jedoch nur sinnvoll, wenn keine zukünftigen Änderungen an der Originaldatenbank vorgenommen werden müssen. Es gibt keine Möglichkeit, Änderungen am Entwurf von Formularen, Berichten oder Code in der Designmaster-MDE-Datei vorzunehmen. Außerdem können in der Originaldatenbank vorgenommene Entwurfsänderungen nicht mit vorher existierenden MDE-Replikaten synchronisiert werden. Deshalb müssen Sie jede notwendige Entwurfsänderung an einer Replikatgruppe von MDE-Dateien in der Originaldatenbank vornehmen, diese erneut als MDE-Datei speichern und anschließend eine vollkommen neue Replikatgruppe aus der neuen MDE-Datei erstellen und verteilen.


 Was ist eine Microsoft Access-Arbeitsgruppe?

Was ist eine Microsoft Access-Arbeitsgruppe?

Eine Microsoft Access-Arbeitsgruppe ist eine Benutzergruppe in einer Mehrbenutzerumgebung, in der Daten gemeinsam genutzt werden. Wenn Sicherheitsmaßnahmen auf Benutzerebene aktiviert sind, werden die Mitglieder einer Arbeitsgruppe in Benutzerkonten und Gruppenkonten identifiziert, die in einer Microsoft Access-Arbeitsgruppen-Informationsdatei gespeichert werden. Die Kennwörter der Benutzer werden ebenfalls in der Arbeitsgruppen-Informationsdatei gespeichert. Diesen Sicherheitskonten können Sie dann Berechtigungen für Datenbanken und deren Tabellen, Abfragen, Formulare, Berichte und Makros zuweisen. Die Berechtigungen an den Objekten werden in der eigentlichen Datenbank gespeichert.

In Microsoft Access 2000 werden Benutzereinstellungen in der Windows-Registrierung im Schlüssel \Hkey_Current_User\Software\Microsoft\Office\9.0\Access\Settings gespeichert. In älteren Versionen als Microsoft Access 97 werden Benutzereinstellungen, die im Dialogfeld Optionen definiert werden, in der Arbeitsgruppen-Informationsdatei gespeichert.

Ihre Standardarbeitsgruppe wird in der Arbeitsgruppen-Informationsdatei definiert, die das Setup-Programm beim Installieren automatisch im Sprachenordner erstellt. Wenn Sie nicht mit dem Dienstprogramm Arbeitsgruppen-Administrator eine andere Arbeitsgruppen-Informationsdatei erstellen, verwendet Microsoft Access bei jedem Starten von Microsoft Access die Standardversion der Arbeitsgruppen-Informationsdatei. Mit dem Arbeitsgruppen-Administrator können Sie auch eine neue Microsoft Access-Arbeitsgruppen-Informationsdatei erstellen.

Wählen Sie vor dem Erstellen von Sicherheitskonten die Microsoft Access-Arbeitsgruppen-Informationsdatei aus, in der diese Konten gespeichert werden sollen. Sie können die Standardversion der Arbeitsgruppen-Informationsdatei verwenden, eine vorhandene Informationsdatei angeben oder eine neue Datei erstellen. Verwenden Sie nicht die Standardversion der Arbeitsgruppen-Informationsdatei, wenn gewährleistet werden soll, dass Arbeitsgruppen und deren Berechtigungen nicht dupliziert werden können. Stellen Sie in diesem Fall sicher, dass die Arbeitsgruppen-Informationsdatei, die Sie auswählen, mit einer eindeutigen Arbeitsgruppen-Identifikationsnummer (WID) erstellt wurde. Wenn eine solche Arbeitsgruppen-Informationsdatei nicht existiert, verwenden Sie den Arbeitsgruppen-Administrator, um diese zu erstellen.


 Bereitstellen einer geschützten Anwendung und Arbeitsgruppe für Benutzer

Bereitstellen einer geschützten Anwendung und Arbeitsgruppe für Benutzer

Eine geschützte Anwendung ist abhängig von Benutzern, die einerseits Zugriff auf eine Anwendungsdatenbank, in der Berechtigungen gespeichert sind, und andererseits Zugriff auf eine Arbeitsgruppe haben, in der Gruppenkonten und Kennwörter gespeichert sind. Abhängig davon, wie die Anwendung eingesetzt werden soll, können Sie den Benutzern sowohl die Anwendung als auch die Arbeitsgruppe auf unterschiedlichste Arten zugänglich machen.

Kopieren der Anwendungsdateien und der Arbeitsgruppen-Informationsdatei, in der die Arbeitsgruppe definiert ist, auf einen Computer im Netzwerk

Unter Verwendung des Arbeitsgruppen-Administrators können Benutzer sich der Arbeitsgruppe durch Angeben des Netzwerk-Server-Pfades zur Arbeitsgruppen-Informationsdatei anschließen und die Anwendung dann direkt vom Computer im Netzwerk aus ausführen. Wenn Sie verhindern möchten, dass Benutzer die Anwendung mit exklusivem Zugriff öffnen, entfernen Sie die Datenbank-Berechtigung Exklusiv für die Gruppe Benutzer.

Weitergeben einer Kopie der Anwendungsdateien und der Arbeitsgruppen-Informationsdatei, die die Arbeitsgruppe definiert, an jeden Benutzer

Unter Verwendung des Arbeitsgruppen-Administrators können Benutzer sich der Arbeitsgruppe durch Angeben des Pfades zur Arbeitsgruppen-Informationsdatei auf ihrem Computer anschließen und dann ihre eigene Kopie der Anwendung auf ihren Computern ausführen. Wenn Sie die Anwendung, deren Daten oder die Arbeitsgruppen-Informationsdatei jedoch aktualisieren müssen, müssen Sie jedem Benutzer Kopien aller aktualisierten Dateien zur Verfügung stellen.

Stattdessen können Sie die Anwendung auch in eine Datenbank für Daten, die auf dem Server abgelegt wird, und eine Anwendungsdatenbank mit allen anderen Datenbankobjekten unterteilen, die auf dem Computer jedes einzelnen Benutzers gespeichert wird. Bei dieser Konfiguration wird in der Regel auch die Arbeitsgruppen-Informationsdatei auf dem Server verwaltet. Wenn Sie jetzt die Anwendung aktualisieren müssen, müssen Sie den Benutzern nur noch aktualisierte Versionen der Anwendungsdatenbank zur Verfügung stellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Erteilen von Zugriffsrechten für die Anwendung an Benutzer in unterschiedlichen Microsoft Access-Arbeitsgruppen durch Erstellen identischer Gruppen in jeder Arbeitsgruppe

Sie können in jeder Arbeitsgruppe ein Gruppenkonto mit identischem Namen und identischer persönlicher Identifikationsnummer (PID) erstellen und dann in jeder Arbeitsgruppe zu dieser Gruppe Benutzer hinzufügen. So kann z.B. ein Benutzer in einem Netzwerk in einer Microsoft Access-Arbeitsgruppe in Tokio auf eine für eine Microsoft Access-Arbeitsgruppe in Köln erstellte Anwendung zugreifen, wenn dieser Benutzer Mitglied eines Gruppenkontos ist, das mit identischem Namen und identischer persönlicher Identifikationsnummer in beiden Arbeitsgruppen erstellt wurde.

Zum Ausführen der Anwendung muss jeder Benutzer über eine Kopie von Microsoft Access verfügen. Zum Erstellen einer Anwendung, für die keine Kopie von Microsoft Access erforderlich ist, benötigen Sie Microsoft Office 2000 Developer (MOD).


 Verwalten von Sicherheitskonten

Verwalten von Sicherheitskonten

Eine Microsoft Access-Arbeitsgruppen-Informationsdatei enthält die folgenden vordefinierten Konten.

Konto | Funktion
Administrator | Standard-Benutzerkonto. Dieses Konto ist für jede Kopie von Microsoft Access und andere Anwendungen, die die Microsoft Jet Datenbank-Engine verwenden können, wie z.B. Microsoft Visual Basic für Applikationen und Microsoft Excel, identisch.
Administratoren | Administratoren-Gruppenkonto. Dieses Konto wird für jede Arbeitsgruppen-Informationsdatei separat definiert. Der Benutzer Administrator befindet sich standardmäßig in der Gruppe Administratoren. Die Gruppe Administratoren muss zu jedem Zeitpunkt mindestens einen Benutzer enthalten.
Benutzer | Dieses Gruppenkonto umfasst alle Benutzerkonten. Microsoft Access fügt Benutzerkonten, die ein Mitglied der Gruppe Administratoren erstellt, automatisch zur Gruppe Benutzer hinzu. Dieses Konto ist für alle Arbeitsgruppen-Informationsdateien identisch, es enthält jedoch jeweils nur die Benutzerkonten, die von Mitgliedern der Gruppe Administratoren dieser Arbeitsgruppe erstellt werden. Dieses Konto verfügt standardmäßig über alle Berechtigungen für alle neu erstellten Objekte. Zum Entfernen eines Benutzerkontos aus der Gruppe Benutzer muss ein Mitglied aus der Gruppe Administratoren diesen Benutzer löschen.

Tatsächlich sind die in Microsoft Access integrierten Sicherheitsmaßnahmen immer "aktiviert". Bis zum Aktivieren des Anmeldeverfahrens für eine Arbeitsgruppe meldet Microsoft Access jeden Benutzer beim Starten automatisch und für den Benutzer nicht sichtbar unter Verwendung des Standardkontos Administrator und eines leeren Kennworts an. Dabei verwendet Microsoft Access das Administratorkonto für die Arbeitsgruppe und macht es zum Besitzer aller erstellten Datenbanken, Tabellen, Abfragen, Formulare, Berichte und Makros.

Administratoren und Besitzer spielen eine bedeutende Rolle, da sie über Berechtigungen verfügen, die nicht entfernt werden können:

  • Administratoren (Mitglieder der Gruppe Administratoren) können jederzeit für alle in der Arbeitsgruppe erstellten Objekte alle Berechtigungen erhalten.

  • Ein Konto, das Besitzer einer Tabelle, Abfrage, eines Formulars, Berichts oder Makros ist, kann jederzeit alle Berechtigungen für dieses Objekt erhalten.

  • Ein Konto, das Besitzer einer Datenbank ist, kann die Datenbank jederzeit öffnen.

Da das Benutzerkonto Administrator für alle Kopien von Microsoft Access identisch ist, ist der erste Schritt zum Schützen einer Datenbank das Definieren von neuen Administrator- und Besitzerbenutzerkonten (oder eines einzelnen Benutzerkontos als Administrator- und Besitzerkonto) und das Entfernen des Benutzerkontos Administrator aus der Gruppe Administratoren. Wenn dies nicht erfolgt, kann sich jeder Benutzer, der über eine Kopie von Microsoft Access verfügt, über das Administratorkonto an Ihre Arbeitsgruppe anmelden und alle Berechtigungen für die Tabellen, Abfragen, Formulare, Berichte und Makros der Arbeitsgruppe erhalten.

Erstellen Sie z.B. zum Schützen einer Datenbank namens Bestellungen Ihre eigenen Konten BestellungenAdministrator und BestellungenBenutzer, und definieren Sie dann für diese Konten Kennwörter.

Sie können zur Gruppe Administratoren beliebig viele Benutzerkonten hinzufügen, es kann jedoch nur ein Benutzer Besitzer der Datenbank selbst sein. Dies ist das Benutzerkonto, das beim Erstellen der Datenbank oder beim Übertragen des Eigentums durch Erstellen einer neuen Datenbank und Importieren aller Objekte dieser Datenbank in die neue Datenbank, aktiv ist. Gruppenkonten können jedoch Besitzer von Tabellen, Abfrageen, Formularen, Berichten und Makros in einer Datenbank sein.

Wichtig

  • Die Konten, die Sie für Benutzer der Datenbank erstellen, müssen in der Arbeitsgruppen-Informationsdatei gespeichert sein, der diese Benutzer sich anschließen, wenn sie die Datenbank verwenden. Wenn Sie zum Erstellen der Datenbank eine andere Datei verwenden, müssen Sie vor dem Erstellen der Konten die Datei wechseln.

  • Stellen Sie sicher, dass Sie für Ihre Administrator- und Benutzerkonten ein eindeutiges, separates Kennwort definieren. Ein Benutzer, der sich über das Administratorkonto anmelden kann, kann jederzeit alle Berechtigungen für alle in der Arbeitsgruppe erstellten Tabellen, Abfragen, Formulare, Berichte und Makros erhalten. Ein Benutzer, der sich über ein Benutzerkonto anmelden kann, kann jederzeit alle Berechtigungen für die Objekte erhalten, deren Besitzer er ist.

Das Verwalten von Benutzern in Benutzergruppen vereinfacht das Verwalten einer geschützten Datenbank. Auf diese Weise müssen Sie nicht jedem Benutzer für jede Tabelle oder Abfrage, jedes Formular, jeden Bericht oder jedes Makro in Ihrer Datenbank einzeln Berechtigungen zuweisen, sondern können einigen wenigen Gruppen Berechtigungen erteilen und dann Benutzer zu diesen Gruppen hinzufügen. Wenn ein Benutzer sich an Microsoft Access anmeldet, erhält er automatisch alle Berechtigungen aller Gruppen, zu denen er gehört. Es können sich nur Benutzerkonten, nicht Gruppenkonten, an Microsoft Access anmelden.

Sie können z.B. zum Schützen einer Datenbank Bestellungen eine Gruppe Vorgesetzte für alle leitenden Angestellten, eine Gruppe Verkäufer für alle Verkäufer und eine Gruppe Mitarbeiter für alle sonstigen Mitarbeiter erstellen. Sie können dann der Gruppe "Vorgesetzte" Berechtigungen mit den wenigsten Einschränkungen, der Gruppe Verkäufer Berechtigungen mit mehr Einschränkungen und der Gruppe Mitarbeiter Berechtigungen mit den stärksten Einschränkungen zuweisen. Wenn Sie dann ein Benutzerkonto für einen neuen Angestellten erstellen, fügen Sie diesen einfach zur entsprechenden Gruppe hinzu. Dieser Angestellte verfügt dann über die dieser Gruppe zugewiesenen Berechtigungen.

Nach dem Erstellen von Benutzer- und Gruppenkonten können Sie die Beziehungen zwischen diesen anzeigen. Dazu klicken Sie im Menü Extras auf Zugriffsrechte und dann auf Benutzer und Gruppenkonten. Anschließend klicken Sie auf die Schaltfläche Benutzer und Gruppen drucken. Microsoft Access druckt einen Bericht über alle Konten in der Arbeitsgruppe mit den einzelnen Gruppen und ihren jeweiligen Benutzern sowie den einzelnen Benutzern mit den Gruppen, denen sie angehören.


 Funktionsweise von Berechtigungen und Informationen zum Zuweisen

Funktionsweise von Berechtigungen und Informationen zum Zuweisen

Es gibt zwei Arten von Berechtigungen: explizite und implizite Berechtigungen. Explizite Berechtigungen sind Berechtigungen, die direkt einem Benutzerkonto erteilt werden und keinen Einfluss auf andere Benutzer haben. Implizite Berechtigungen sind Berechtigungen, die einem Gruppenkonto erteilt werden. Wird ein neuer Benutzer zu dieser Gruppe hinzugefügt, erhält er die Berechtigungen, die für diese Gruppe festgelegt wurden. Wird ein Benutzer aus einer Gruppe entfernt, werden ihm die Gruppenberechtigungen entzogen.

Wenn ein Benutzer versucht, eine Aktion an einem geschützten Datenbankobjekt auszuführen, basieren die Berechtigungen dieses Benutzers auf der Kombination der diesem Benutzer erteilten expliziten und impliziten Berechtigungen. Die Sicherheitsstufe eines Benutzers ist die am wenigsten einschränkende Stufe aus den expliziten Berechtigungen des Benutzers und der Berechtigung all der Gruppen, zu denen dieser Benutzer gehört. Aus diesem Grunde lassen sich Arbeitsgruppen am leichtesten durch Erstellen von Gruppen und Erteilen von Berechtigungen für diese Gruppen verwalten, während das Erteilen von Berechtigungen an Einzelbenutzer den Verwaltungsprozess sehr viel komplizierter macht. Nach dem Erstellen von Gruppen und Erteilen von Berechtigungen können Sie Berechtigungen für Einzelbenutzer ändern, indem Sie sie zu bestimmten Gruppen hinzufügen oder aus bestimmten Gruppen entfernen. Darüber hinaus erfolgt das Erteilen neuer Berechtigungen beim Erteilen von Gruppenberechtigungen einmalig an alle Mitglieder der Gruppe.

Berechtigungen für ein Datenbankobjekt können von folgenden Personen geändert werden.

  • Mitglieder der Gruppe Administratoren der Arbeitsgruppen-Informationsdatei, die beim Erstellen der Datenbank gültig war

  • Der Besitzer des jeweiligen Objekts

  • Ein beliebiger Benutzer, der für dieses Objekt über die Berechtigung Verwalten verfügt

Auch wenn ein Benutzer eine bestimmte Aktion gerade nicht ausführen kann, kann er in der Lage sein, sich selbst die Berechtigung zum Ausführen dieser Aktion zu erteilen. Dies gilt für Mitglieder der Gruppe Administratoren und für einen Benutzer, der Besitzer des jeweiligen Objekts ist.

Besitzer eines Objekts ist der Benutzer, der die Tabelle, die Abfrage, das Formular, den Bericht oder das Makro erstellt hat. Die Benutzergruppe, die Berechtigungen ändern kann, kann auch den Besitzerstatus für diese Objekte ändern. Dazu dient der Befehl Benutzer- und Gruppenberechtigungen aus dem Untermenü Zugriffsrechte (Menü Extras). Alternativ zu diesem Befehl kann der Besitzerstatus an einem dieser Objekte auch durch Neuerstellen des Objekts geändert werden. Dazu muss das Objekt nicht gänzlich neu erstellt werden. Sie können das Objekt z. B. kopieren oder in/aus eine(r) andere(n) Datenbank importieren bzw. exportieren. Zum Schützen einer vollständigen Datenbank übertragen Sie am einfachsten das Eigentum an allen diesen Objekten, einschließlich an der Datenbank. Die beste Methode zum Schützen einer Datenbank bietet der Benutzer-Datensicherheits-Assistent, der eine neue Datenbank erstellt und in diese alle Objekte importiert.

Anmerkung Das Kopieren, Importieren und Exportieren ändert nicht den Besitzerstatus für Abfragen, bei denen für die Ausführungsberechtigung-Eigenschaft die Einstellung Besitzer festgelegt ist. Zum Ändern des Besitzerstatus für eine Abfrage müssen Sie für die Ausführungsberechtigung-Eigenschaft die Einstellung Benutzer festlegen.

Zum Anzeigen von Informationen zu Berechtigungsarten klicken Sie auf [image] .


 Berechtigungsarten

Berechtigungsarten

Die folgende Tabelle zeigt eine Übersicht aller Berechtigungen, die erteilt werden können.

Berechtigung | Funktion | Gültigkeitsbereich
Öffnen/Ausführen | Öffnen einer Datenbank, eines Formulars oder eines Berichts oder Ausführen eines Makros | Datenbanken, Formulare, Berichte und Makros
Exklusiv | Öffnen einer Datenbank mit exklusivem Zugriff | Datenbanken
Entwurf lesen | Anzeigen von Objekten in der Entwurfsansicht | Tabellen, Abfragen, Formulare, Berichte und Makros
Entwurf ändern | Anzeigen und Ändern des Entwurfs von Objekten oder Löschen von Objekten | Tabellen, Abfragen, Formulare, Berichte und Makros
Verwalten | Für Datenbanken: Festlegen eines Datenbankkennworts, Replizieren einer Datenbank und Ändern von Starteigenschaften Für Tabellen, Abfragen, Formulare, Berichte und Makros: Vollzugriff auf diese Objekte und Daten, einschließlich der Möglichkeit, Berechtigungen zu erteilen | Datenbanken, Tabellen, Abfragen, Formulare, Berichte und Makros
Daten lesen | Anzeigen von Daten | Tabellen und Abfragen
Daten aktualisieren | Anzeigen und Ändern, nicht jedoch Einfügen oder Löschen von Daten | Tabellen und Abfragen
Daten einfügen | Anzeigen und Einfügen, nicht jedoch Ändern oder Löschen von Daten | Tabellen und Abfragen
Daten löschen | Anzeigen und Löschen, nicht jedoch Ändern oder Einfügen von Daten | Tabellen und Abfragen

Anmerkung

  • Einige Berechtigungen beinhalten automatisch andere Berechtigungen. Die Berechtigung Daten aktualisieren für eine Tabelle beinhaltet z.B. die Berechtigungen Daten lesen und Entwurf lesen, da diese zum Ändern von Daten in einer Tabelle erforderlich sind. Die Berechtigungen Entwurf ändern und Daten lesen beinhalten Entwurf lesen. Für Makros beinhaltet die Berechtigung Entwurf lesen auch die Berechtigung Öffnen/Ausführen.

  • Um Entwürfe für Formulare, Berichte, Makros oder Module in einer Mehrbenutzerumgebung erstellen zu können, müssen Sie eine Microsoft Access-Datenbank exklusiv öffnen, d. h., Sie müssen über die Berechtigung Exklusiv öffnen für die Access-Datenbank verfügen. Siehe auch Speichern von Entwurfsänderungen an einer gemeinsam genutzten Access-Datenbank.

  • Damit Benutzer auf eine verknüpfte Tabelle zugreifen können, erteilen Sie die Berechtigungen Daten lesen und Entwurf lesen für die Tabelle in der Back-End-Datenbank und die Berechtigung Entwurf ändern für die in der Front-End-Datenbank definierte Tabellenverknüpfung, so dass Benutzer die Tabelle problemlos neu verknüpfen können. Um den Zugriff auf die Back-End-Tabelle einzuschränken, Benutzern aber dennoch die Anzeige von Daten und die Neuverknüpfung von Tabellen zu ermöglichen, können Sie alle Berechtigungen aus der Back-End-Tabelle entfernen und die Abfragen in der Front-End-Datenbank verwenden, wobei für die Ausführungsberechtigungen-Eigenschaft die Einstellung Besitzer eingestellt sein muss.


 Erstellen und Ändern von Kennwörtern

Erstellen und Ändern von Kennwörtern

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datenbankkennwörter

Kennwörter für Sicherheitskonten

Kennwörter für VBA-Code

Datenbankkennwörter

Der erste Kennworttyp wird als "Datenbankkennwort" bezeichnet. Wenn Sie ein Datenbankkennwort festlegen, müssen alle Benutzer dieses vor dem Öffnen der Datenbank eingeben. Durch das Festlegen eines Datenbankkennworts können Sie auf einfache Weise verhindern, dass unautorisierte Benutzer Ihre Datenbank öffnen. Sobald eine Datenbank jedoch geöffnet ist, stehen nur dann weitere Sicherheitsmaßnahmen zur Verfügung, wenn zusätzlich zum Datenbankkennwort Sicherheitsmaßnahmen auf Benutzerebene definiert wurden. Wenn Sie für Ihre Datenbank Sicherheitsmaßnahmen auf Benutzerebene definiert haben, können Sie verhindern, dass ein Benutzer ein Datenbankkennwort festlegt.

Zurück zum Anfang

Kennwörter für Sicherheitskonten

Der zweite Kennworttyp wird als "Sicherheitskontenkennwort" bezeichnet und nur dann verwendet, wenn Sicherheitsmaßnahmen auf Benutzerebene für eine Arbeitsgruppe definiert worden sind. Ein Sicherheitskontenkennwort dient zum Sicherstellen, dass sich kein weiterer Benutzer unter dem Namen des jeweiligen Benutzers anmelden kann.

Microsoft Access weist dem Standardbenutzerkonto Administrator und jedem neuen Benutzerkonto, das Sie in Ihrer Arbeitsgruppe erstellen, ein leeres Kennwort zu. Sie können eine Datenbank nur dann richtig schützen, wenn Sie für die folgenden Konten ein Kennwort festlegen:

  • das Benutzerkonto Administrator (zum Aktivieren des Anmeldedialogfelds)

  • das Benutzerkonto, das als Besitzer der Datenbank und ihrer Tabellen, Abfragen, Formulare, Berichte und Makros festgelegt ist.

  • alle Benutzerkonten, die Sie zur Gruppe Administratoren hinzufügen

Darüber hinaus können Sie Kennwörter für Konten festlegen, die Sie für Benutzer erstellen, oder Benutzer anweisen, selbst Kennwörter festzulegen.

Jeder Benutzer kann sein eigenes Benutzerkontenkennwort erstellen oder ändern. Wenn ein Benutzer jedoch sein Kennwort vergisst, kann dieses nur von einem Administratorkonto gelöscht werden.

Zurück zum Anfang

Kennwörter für VBA-Code

Der dritte Typ von Kennwörtern wird als "VBA-Kennwort" bezeichnet. Ein solches Kennwort gilt jeweils für eine Sitzung und schützt VBA-Code in Modulen sowie Code, der Formularen und Berichten zugeordnet ist. Diese Art von Kennwort hindert nichtberechtigte Benutzer daran, VBA-Code zu bearbeiten, auszuschneiden, zu kopieren, zu exportieren oder zu löschen.

Zurück zum Anfang


 Verwenden eines Kennworts und Sicherheit auf Benutzerebene bei einer als MDE-Datei gespeicherten Microsoft Access-Datenbank

Verwenden eines Kennworts und Sicherheit auf Benutzerebene bei einer als MDE-Datei gespeicherten Microsoft Access-Datenbank

Durch das Erstellen einer MDE-Datei sichern Sie die Formulare, Berichte und den Microsoft Visual Basic-Code in Ihrer Microsoft Access-Datenbank. Benutzer brauchen sich nicht anzumelden, und Sie müssen keine Benutzerkonten und Berechtigungen erstellen und verwalten, die bei Sicherheit auf Benutzerebene benötigt werden. Wenn Sie jedoch ein Datenbankkennwort oder Sicherheit auf Benutzerebene definieren, bevor Sie eine Access-Datenbank als MDE-Datei speichern, gelten diese Features dennoch für eine aus dieser Datenbank erstellte MDE-Datei. Wurde für Ihre Access-Datenbank ein Kennwort oder Sicherheit auf Benutzerebene definiert, und möchten Sie diese Features wieder entfernen, müssen Sie dies erledigen, bevor Sie die Datenbank als MDE-Datei speichern. Um Informationen zum Entfernen eines Datenbankkennworts anzuzeigen, klicken Sie auf [image] . Um Informationen zum Entfernen von Sicherheit auf Benutzerebene anzuzeigen, klicken Sie auf [image] .

Zum Speichern einer mit Sicherheit auf Benutzerebene gesicherten Access-Datenbank als MDE-Datei müssen folgende Bedingungen erfüllt sein, bevor Sie fortfahren können:

  • Sie müssen sich der Arbeitsgruppen-Informationsdatei anschließen, welche die Benutzerkonten definiert, die für den Zugriff auf die Datenbank verwendet werden bzw. beim Erstellen der Datenbank verwendet wurden.

  • Ihr Benutzerkonto muss über die Berechtigungen Öffnen/Ausführen und Exklusiv für die Datenbank verfügen.

  • Ihr Benutzerkonto muss über die Berechtigungen "Entwurf ändern" oder "Verwalten" für alle Tabellen in der Datenbank verfügen, oder Sie müssen der Besitzer aller Tabellen in der Datenbank sein.

  • Ihr Benutzerkonto muss über die Berechtigung "Entwurf lesen" für alle Objekte in der Datenbank verfügen.


 Konvertieren oder Aufbereiten einer gesicherten Datenbank aus einer früheren Version von Microsoft Access

Konvertieren oder Aufbereiten einer gesicherten Datenbank aus einer früheren Version von Microsoft Access

Die Verwendung einer gesicherten Datenbank aus einer früheren Version von Microsoft Access erfordert einige zusätzliche Schritte und Überlegungen.

Wichtig Um eine gesicherte Datenbank zu konvertieren oder aufzubereiten, sind die folgenden Bedingungen erforderlich, da die Konvertierung sonst nicht erfolgen kann:

  • Wenn Sie Microsoft Access 2000 installieren, wird eine neue Arbeitsgruppen-Informationsdatei erstellt, die zur aktuellen Datei wird. Bevor Sie eine gesicherte Datenbank konvertieren, müssen Sie sich folglich der Arbeitsgruppen-Informationsdatei anschließen, die die zum Zugriff auf die zu konvertierende Datenbank verwendeten Benutzerkonten definiert oder die beim Sichern der Datenbank aktiv war. Um Informationen zum Anschluss an eine Arbeitsgruppen-Informationsdatei anzuzeigen, klicken Sie auf [image] .

  • Das Benutzerkonto, bei dem Sie sich während der Konvertierung anmelden, muss über die folgenden Berechtigungen verfügen:

    Die Berechtigungen "Öffnen/Ausführen" und "Exklusiv" für die Datenbank selbst.

    Die Berechtigungen "Entwurf ändern" oder "Verwalten" für alle Tabellen in der Datenbank (es sei denn, Sie sind der Besitzer aller Tabellen in der Datenbank).

    Die Berechtigung "Entwurf lesen" für alle Objekte in der Datenbank.

Wenn alle Benutzer einer gesicherten Datenbank aus einer früheren Version auf Microsoft Access 2000 aktualisieren, sollten Sie die Datenbank und die mit ihr verwendete Arbeitsgruppen-Informationsdatei konvertieren. Ihr Vorgehen hängt davon ab, von welcher Microsoft Access-Version Sie aktualisieren.

Wenn nur einige Benutzer einer gesicherten Datenbank auf Microsoft Access 2000 aktualisieren, können Sie die Datenbank und die Arbeitsgruppen-Informationsdatei in allen momentan aktiven Microsoft Access-Versionen gemeinsam nutzen. Es gibt mehrere Möglichkeiten zum gemeinsamen Nutzen der gesicherten Datenbank und der Arbeitsgruppen-Informationsdatei.

Wichtig Konvertieren Sie eine gesicherte Datenbank aus einer früheren Version nur dann, wenn alle Benutzer auf Microsoft Access 2000 aktualisieren. Wenn nur einige Benutzer aktualisieren, können Sie die Datenbank im aktuellen Format gemeinsam nutzen.

Wichtig Da es in Microsoft Access 2000 nicht möglich ist, Microsoft Visual Basic-Code in Modulen sowie Code als Bestandteil von Formularen und Berichten mit auf Benutzerebene definierter Sicherheit zu schützen, bleibt Code, der aus einer gesicherten Datenbank konvertiert wird, die mit einer früheren Version von Microsoft Access erstellt wurde, nicht länger geschützt. Der folgende Hyperlink führt zu Informationen über Schützen von Visual Basic-Code.


 Schützen einer Datenbank mittels eines Datenbankkennworts

Schützen einer Datenbank mittels eines Datenbankkennworts

  1. Schließen Sie die Datenbank. Wenn die Datenbank eine Mehrbenutzerdatenbank ist, vergewissern Sie sich, dass alle anderen Benutzer die Datenbank geschlossen haben.

  2. Machen Sie eine Sicherungskopie der Datenbank, und bewahren Sie diese an einem sicheren Ort auf.

  3. Klicken Sie im Menü Datei auf Öffnen.

  4. Klicken Sie auf den Pfeil rechts von der Schaltfläche Öffnen, und klicken Sie dann auf Exklusiv Öffnen.

  5. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Datenbankkennwort zuweisen.

  6. Geben Sie im Feld Kennwort Ihr Kennwort ein. Bei Kennwörtern müssen Sie die Groß-/Kleinschreibung beachten.

  7. Geben Sie im Feld Bestätigen das Kennwort erneut ein, um dieses zu bestätigen, und klicken Sie dann auf OK.

    Damit ist das Kennwort festgelegt. Wenn Sie oder ein anderer Benutzer die Datenbank das nächste Mal öffnen, erscheint ein Dialogfeld, in das ein Kennwort eingegeben werden muss.

Achtung

  • Wenn Sie Ihr Kennwort verlieren oder vergessen, können Sie dieses nicht wiederherstellen und Ihre Datenbank nicht mehr öffnen.

  • Verwenden Sie kein Datenbankkennwort, wenn Sie eine Datenbank replizieren möchten. Replizierte Datenbanken können nicht synchronisiert werden, wenn Kennwörter für Datenbanken festgelegt wird.

Anmerkungen

  • Ein Datenbankkennwort wird zusammen mit der Datenbank, nicht mit der Arbeitsgruppeninformationsdatei gespeichert.

  • Wenn für eine Datenbank die Sicherheitsmaßnahmen auf Benutzerebene aktiviert sind und Sie nicht über die Administratorberechtigung für die Datenbank verfügen, können Sie für diese Datenbank kein Kennwort festlegen. Außerdem wird ein Kennwort immer als Zusatz zu den Sicherheitsmaßnahmen auf Benutzerebene definiert, d.h. wenn Sicherheitsmaßnahmen auf Benutzerebene aktiviert sind, bleiben alle Einschränkungen für Zugriffsrechte aus diesen Sicherheitsmaßnahmen bestehen.

  • Wenn eine Tabelle aus einer kennwortgeschützten Datenbank verknüpft wird, wird das Kennwort in der Datenbank gespeichert, aus der es verknüpft wurde. Dies kann unvorhersehbare Folgen haben. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Entfernen eines Datenbankkennworts

Entfernen eines Datenbankkennworts

  1. Klicken Sie im Menü Datei auf Öffnen.

  2. Klicken Sie auf den Pfeil rechts neben der Schaltfläche Öffnen, klicken Sie auf Exklusiv öffnen, und öffnen Sie die Datenbank.

  3. Geben Sie im Dialogfeld Kennwort erforderlich das Kennwort der Datenbank ein, und klicken Sie dann auf OK. Bei Kennwörtern müssen Sie die Groß-/Kleinschreibung beachten.

  4. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Datenbankkennwort löschen. Dieser Befehl steht nur dann zur Verfügung, wenn zuvor ein Datenbankkennwort festgelegt wurde.

  5. Geben Sie im Dialogfeld Datenbankkennwort löschen das aktuelle Kennwort ein.

  6. Klicken Sie auf OK.


 Verknüpfen von Tabellen aus einer kennwortgeschützten Datenbank

Verknüpfen von Tabellen aus einer kennwortgeschützten Datenbank

Um eine Tabelle aus einer Microsoft Access-Datenbank zu verknüpfen, die kennwortgeschützt ist, müssen Sie das richtige Kennwort eingeben. Microsoft Access speichert das Datenbankkennwort dann zusammen mit den Informationen, die die Verknüpfung zur Tabelle definieren. Nach dem Definieren der Verknüpfung kann jeder Benutzer, der die Datenbank öffnen kann, mit der die Tabelle verknüpft ist, auch die verknüpfte Tabelle öffnen. Wenn ein Benutzer die verknüpfte Tabelle öffnet, verwendet Microsoft Access das gespeicherte Kennwort zum Öffnen der Datenbank, in der die Tabelle gespeichert ist. Wurde dieses Kennwort geändert, muss beim nächsten Öffnen der verknüpften Tabelle das neue Kennwort eingegeben werden, damit Microsoft Access sie öffnen kann.

Microsoft Access speichert das Datenbankkennwort in einer unverschlüsselten Form. Beeinträchtigt dies die Zugriffsrechte der kennwortgeschützten Datenbank, verwenden Sie zum Schützen der Datenbank kein Datenbankkennwort. Definieren Sie stattdessen Zugriffsrechte auf Benutzerebene, um den Zugriff auf wichtige Daten in dieser Datenbank zu steuern. Zum Anzeigen weiterer Informationen zu Zugriffsrechten auf Benutzerebene klicken Sie auf [image] .


 Verschlüsseln und Entschlüsseln einer Datenbank

Verschlüsseln und Entschlüsseln einer Datenbank

Beim Verschlüsseln einer Datenbank wird die Datenbankdatei komprimiert und kann dann mit Hilfe eines Dienstprogramms oder Textverarbeitungsprogramms nicht mehr gelesen werden. Das Entschlüsseln hebt die Verschlüsselung wieder auf.

  1. Starten Sie Microsoft Access, ohne eine Datenbank zu öffnen.

    Wichtig Sie können eine Datenbank nur dann verschlüsseln und entschlüsseln, wenn diese geschlossen ist. In einer Mehrbenutzerumgebung kann daher der Ver- oder Entschlüsselungsvorgang nur erfolgreich ausgeführt werden, wenn kein anderer Benutzer die Datenbank geöffnet hat.

  2. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Datenbank ver-/entschlüsseln.

  3. Geben Sie die Datenbank an, die Sie ver- oder entschlüsseln möchten, und klicken Sie dann auf OK.

  4. Geben Sie einen Namen, ein Laufwerk und einen Ordner für die verschlüsselte bzw. entschlüsselte Datenbank an, und klicken Sie dann auf OK.

    Wenn Sie denselben Namen, dasselbe Laufwerk und denselben Ordner wie für die Originaldatenbank angeben und die Datenbank erfolgreich ver- oder entschlüsselt werden kann, ersetzt Microsoft Access automatisch die Originaldatei durch die ver- bzw. entschlüsselte Version. Wenn ein Fehler auftritt, löscht Microsoft Access die Originaldatei nicht.

Anmerkungen

  • Wenn Sicherheitsmaßnahmen auf Benutzerebene definiert wurden, müssen Sie zum Verschlüsseln und Entschlüsseln einer Datenbank entweder der Besitzer der Datenbank oder Mitglied der Gruppe Administratoren sein sowie die Berechtigung haben, die Datenbank exklusiv zu öffnen. Andernfalls kann der Verschlüsselungs- bzw. Entschlüsselungsvorgang nicht erfolgreich durchgeführt werden.

  • Wenn ein Objekt in einer Datenbank der Version 1.x im Objektnamen einen Accent grave (`) enthält, können Sie die Datenbank nicht verschlüsseln. Verwenden Sie in diesem Fall Microsoft Access, Version 1.x, um das Objekt umzubenennen, und ändern Sie dann in Ihren Abfragen, Formularen, Berichten, Makros und in Access Basic-Code die Verweise auf dieses Objekt.

  • Das Verschlüsseln einer Datenbank verhindert nicht den Zugriff auf Objekte. Zum Anzeigen weiterer Informationen zu anderen Sicherheitsmethoden klicken Sie auf [image] .

  • Der Ver- bzw. Entschlüsselungsvorgang kann nur dann erfolgreich ausgeführt werden, wenn auf der Festplatte genügend Platz für das Original und die ver- bzw. entschlüsselte Version der Datenbank verfügbar ist.


 Ausblenden von Objekten im Datenbankfenster

Ausblenden von Objekten im Datenbankfenster

  1. Klicken Sie im Datenbankfenster auf das Objekt, das Sie ausblenden möchten.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] .

  3. Klicken Sie auf Ausgeblendet und dann auf OK.

Anmerkungen>

  • Zum Anzeigen aller ausgeblendeten Objekte klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Ansicht. Aktivieren Sie anschließend das Kontrollkästchen Ausgeblendete Objekte. Die Symbole für ausgeblendete Objekte werden mit einem abgeblendeten Rahmen angezeigt. Sie können diese Schritte dann wiederholen, aber bei Schritt 3 deaktivieren Sie Hidden, um die Objekte einzublenden.

  • In einem Microsoft Access-Projekt können Sie Tabellen, Sichten, Datenbankdiagramme oder Gespeicherte Prozeduren nicht ausblenden.


 Erstellen einer MDE-Datei

Erstellen einer MDE-Datei

  1. Schließen Sie die Microsoft Access-Datenbank. Wenn Sie in einer Mehrbenutzerumgebung arbeiten, müssen Sie sicherstellen, dass alle anderen Benutzer die Datenbank geschlossen haben.

  2. Klicken Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie dann auf MDE-Datei erstellen.

  3. Geben Sie im Dialogfeld Als MDE zu speichernde Datenbank die Access-Datenbank an, die Sie als MDE-Datei speichern möchten, und klicken Sie auf MDE erstellen.

  4. Geben Sie im Dialogfeld MDE speichern unter einen Namen, ein Laufwerk und einen Ordner für die Access-Datenbank an.

Achtung Bewahren Sie unbedingt eine Kopie Ihrer Original-Access-Datenbank auf. Sie können den Entwurf von Formularen, Berichten oder Modulen in einer als MDE-Datei gespeicherten Access-Datenbank nicht ändern. Falls es erforderlich wird, den Entwurf dieser Objekte zu ändern, müssen Sie die Änderungen in der Original-Access-Datenbank vornehmen und die Access-Datenbank anschließend erneut als MDE-Datei speichern. Außerdem können Sie eine als MDE-Datei gespeicherte Access-Datenbank in zukünftigen Versionen von Microsoft Access nicht ausführen oder konvertieren. Es ist nur möglich, die Original-Access-Datenbank zu öffnen oder zu konvertieren.


 Schützen von Visual Basic für Applikationen-Code mit einem Kennwort

Schützen von Visual Basic für Applikationen-Code mit einem Kennwort

Um zu verhindern, dass ein anderer Benutzer Ihren Visual Basic für Applikationen-Code unerwünscht anzeigt oder Änderungen daran vornimmt, können Sie den VBA-Code durch ein Kennwort schützen.

  1. Öffnen Sie das Microsoft Access-Projekt oder die Microsoft Access-Datenbank mit dem VBA-Code, den Sie schützen möchten.

  2. Klicken Sie im Datenbankfenster im Menü Extras auf Makro und dann auf Visual Basic-Editor.

    Tipp Sie können auch ALT+F11 drücken.

  3. Klicken Sie im Microsoft Visual Basic-Editor im Menü Extras auf Eigenschaften von <Access-Datenbank- oder Access-Projektname>.

  4. Klicken Sie auf Schutz.

  5. Aktivieren Sie das Kontrollkästchen Projekt für die Anzeige sperren.

  6. Geben Sie in das Feld Kennwort ein Kennwort ein, und bestätigen Sie das Kennwort durch erneutes Eingeben in das Feld Kennwort bestätigen.

Beim nächsten Öffnen der Access-Datenbank oder des Access-Projekts ist der VBA-Code dadurch geschützt, dass Sie (oder ein anderer Benutzer) das in Schritt 6 zum Anzeigen und Bearbeiten von VBA-Code festgelegte Kennwort eingeben müssen.

Anmerkungen

  • Zum Entfernen des Kennwortes löschen Sie alle Informationen auf der Registerkarte Schutz des Dialogfeldes Eigenschaften von <Access-Datenbank- oder Access-Projektname>.

  • Wenn Sie ein Kennwort festlegen, jedoch nicht das Kontrollkästchen Projekt für die Anzeige sperren aktivieren, kann der Code von jedem beliebigen Benutzer angezeigt und bearbeitet werden, das Dialogfeld Projekteigenschaften ist jedoch geschützt.

  • Notieren Sie sich das Kennwort, und bewahren Sie es an einem sichern Ort auf. Wenn Sie das Kennwort vergessen, können Sie den VBA-Code nicht mehr anzeigen und bearbeiten.


 Schützen einer Datenbank unter Verwendung des Benutzer-Datensicherheits-Assistenten

Schützen einer Datenbank unter Verwendung des Benutzer-Datensicherheits-Assistenten

Durch Ausführen des Benutzerdatensicherheits-Assistenten können Sie Sicherheitsmaßnahmen auf Benutzerebene mit dem üblicherweise verwendeten Sicherheitsschema einrichten und Ihre Microsoft Access-Datenbank verschlüsseln.

  1. Öffnen Sie die Datenbank, die Sie schützen möchten.

  2. Klicken Sie im Menü Extras auf Zugriffsrechte und dann auf Benutzerdatensicherheits-Assistent.

  3. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.

Anmerkungen

  • Der Benutzerdatensicherheits-Assistent erstellt eine Sicherungskopie der aktuellen Access-Datenbank mit dem gleichen Namen und der Erweiterung .bak und schützt dann die ausgewählten Objekte in der aktuellen Datenbank.

  • Falls Ihre aktuelle Access-Datenbank auf das Schützen von Visual Basic für Applikationen-Code (VBA-Code) mit einem Kennwort eingerichtet ist, fragt der Assistent Sie nach dem Kennwort. Sie müssen das Kennwort eingeben, damit der Assistent den Vorgang erfolgreich abschließen kann.

  • Kennwörter, die Sie mit Hilfe des Assistenten erstellt haben, werden nach Abschluss des Vorgangs im Bericht des Benutzerdatensicherheits-Assistenten ausgedruckt. Bewahren Sie diesen Bericht an einem sicheren Ort auf. Mit diesem Bericht können Sie auch Ihre Arbeitsgruppendatei neu erstellen.


 Sichern einer Datenbank ohne Benutzeranmeldung

Sichern einer Datenbank ohne Benutzeranmeldung

  1. Sichern Sie Ihre Datenbank mit Hilfe des Benutzerdatensicherheits-Assistenten.

    Wie wird's gemacht?

  2. Erteilen Sie für jedes Datenbankobjekt, das Sie Benutzern zur Verfügung stellen möchten, dem Benutzerkonto Administrator die entsprechenden Berechtigungen.

    Wie wird's gemacht?

  3. Deaktivieren Sie das Dialogfeld Anmelden.

    Wie wird's gemacht?

Wenn der Benutzer Microsoft Access startet und eine Datenbank öffnet, ohne sich anzumelden, meldet Microsoft Access ihn automatisch mit dem Benutzerkonto Administrator an. Aus diesem Grund verfügt er nur über die in Schritt 2 erteilten Berechtigungen. Dies gilt für jede Arbeitsgruppe, da das Administratorkonto in allen Arbeitsgruppen-Informationsdateien identisch ist. Nur das Benutzerkonto Administrator sowie alle anderen Mitglieder der Gruppe Administratoren der Arbeitsgruppen-Informationsdatei, die bei Ausführung des Assistenten in Schritt 1 geöffnet war, verfügen über alle Berechtigungen für die Tabellen, Abfragen, Formulare, Berichte und Makros der Datenbank.

Zum Ausführen von administrativen Funktionen können Sie entweder das Dialogfeld Anmelden reaktivieren und sich als Mitglied der Gruppe Administratoren anmelden oder unter Verwendung der Befehlszeilenoptionen /pwd und /user beim Starten von Microsoft Access Ihr Kennwort und Ihren Benutzernamen festlegen.


 Entfernen von Sicherheitsmaßnahmen auf Benutzerebene

Entfernen von Sicherheitsmaßnahmen auf Benutzerebene

Dieses Verfahren erfordert eine zweistufige Vorgehensweise. Zuerst melden Sie sich als Arbeitsgruppenadministrator an und erteilen der Gruppe Benutzer Berechtigungen für alle Tabellen, Abfragen, Formulare, Berichte und Makros. Anschließend geben Sie das Eigentum an der Datenbank und diese Objekten an den Standardbenutzer Administrator zurück. Dazu beenden Sie Microsoft Access, starten es erneut und melden sich wieder unter dem Konto Administrator an. Dann erstellen Sie eine leere Datenbank und importieren alle Objekte aus der ursprünglichen Datenbank in die neue Datenbank.

  1. Starten Sie Microsoft Access.

  2. Öffnen Sie die Datenbank.

  3. Melden Sie sich als Arbeitsgruppenadministrator (Mitglied der Gruppe Administratoren) an.

  4. Erteilen Sie der Gruppe Benutzer alle Berechtigungen für alle Tabellen, Abfragen, Formulare, Berichte und Makros in der Datenbank.

    Wie wird's gemacht?

  5. Beenden Sie Microsoft Access, öffnen Sie eine Datenbank, und starten Sie es erneut. Melden Sie sich dabei unter dem Konto Administrator an.

  6. Erstellen Sie eine neue leere Datenbank, und lassen Sie diese geöffnet.

  7. Importieren Sie alle Objekte aus der ursprünglichen Datenbank in die neue Datenbank.

    Wie wird's gemacht?

  8. Wenn ein Benutzer beim Öffnen der Datenbank die aktuelle Arbeitsgruppen-Informationsdatei verwendet, müssen Sie das Kennwort für das Konto Administrator löschen, um das Dialogfeld Anmelden für die aktuelle Arbeitsgruppe zu deaktivieren. Dies ist nicht erforderlich, wenn die Benutzer die beim Installieren von Microsoft Access eingerichtete Standardversion der Arbeitsgruppen-Informationsdatei verwenden.

Die neue Datenbank ist jetzt vollkommen ungeschützt. Jeder Benutzer, der die neue Datenbank öffnen kann, hat alle Berechtigungen für alle Tabellen, Abfragen, Formulare, Berichte und Makros in dieser Datenbank. Dies ist für jede Arbeitsgruppe gültig, da das Konto Administrator in jeder Arbeitsgruppen-Informationsdatei gleich ist. Die Arbeitsgruppen-Informationsdatei, die zum Zeitpunkt des Erstellens der neuen Datenbank (Schritt 6) gültig war, definiert die Gruppe Administratoren für die neue Datenbank.


 Erstellen einer neuen Microsoft Access-Arbeitsgruppen-Informationsdatei

Erstellen einer neuen Microsoft Access-Arbeitsgruppen-Informationsdatei

Wenn Sie Microsoft Access installieren, erstellt das Setup-Programm automatisch eine Microsoft Access-Arbeitsgruppen-Informationsdatei, die über Namens- und Firmeninformationen, die Sie angeben, identifiziert wird. Da diese Informationen oft leicht bestimmt werden können, besteht die Gefahr, dass ein nicht entsprechend autorisierter Benutzer eine Kopie dieser Arbeitsgruppendatei erstellt und damit in der in dieser Arbeitsgruppen-Informationsdatei definierten Arbeitsgruppe Berechtigungen eines Administratorkontos (ein Mitglied der Gruppe Administratoren) erhält. Um dies zu verhindern, erstellen Sie eine neue Arbeitsgruppen-Informationsdatei und legen eine Arbeitsgruppen-Identifikationsnummer (WID) fest. Nur wer diese Identifikationsnummer kennt, wird in der Lage sein, eine Kopie dieser Arbeitsgruppen-Informationsdatei zu erstellen.

  1. Beenden Sie Microsoft Access.

  2. Zum Starten des Arbeitsgruppen-Administrators öffnen Sie den Sprachenordner und doppelklicken Sie auf Wrkgadm.exe. Sie können auch die Verknüpfung MS Access Workgroup Administrator verwenden, die Sie im Ordner \Programme\Microsoft Office\Office finden.

  3. Klicken Sie im Dialogfeld Arbeitsgruppen-Administrator auf Erstellen.

  4. Geben Sie im Dialogfeld Informationen zum Arbeitsgruppeneigentümer Ihren Namen und die Firma an, und geben Sie für die Arbeitsgruppen-Identifikationsnummer eine beliebige Kombination aus bis zu 20 Ziffern und Buchstaben ein.

    Achtung Notieren Sie sich die genaue Schreibweise des Namens, der Firma und der Arbeitsgruppen-Identifikationsnummer, einschließlich der Groß-/Kleinschreibung (für alle drei Einträge), und bewahren Sie diese Informationen an einem sicheren Ort auf. Wenn Sie die Arbeitsgruppen-Informationsdatei neu erstellen müssen, müssen Sie diese Informationen genau wie beim ersten Mal wieder eingeben. Sie können diese Einträge, wenn Sie sie vergessen oder verlieren, nicht wiederherstellen und damit den Zugriff auf Ihre Datenbanken verlieren.

  5. Geben Sie einen neuen Namen für die neue Arbeitsgruppen-Informationsdatei ein, und klicken Sie dann auf OK. (Die Arbeitsgruppen-Informationsdatei wird standardmäßig im Sprachenordner installiert. Wenn Sie die Datei an einer anderen Stelle speichern möchten, geben Sie einen Pfadnamen ein, oder klicken Sie auf Durchsuchen, um den neuen Pfad anzugeben.)

Die neue Arbeitsgruppen-Informationsdatei wird beim nächsten Starten von Microsoft Access verwendet. Alle Benutzerkonten, Gruppenkonten oder Kennwörter, die Sie erstellen, werden in der neuen Arbeitsgruppen-Informationsdatei gespeichert. Wenn weitere Benutzer an die in der neuen Arbeitsgruppen-Informationsdatei definierte Arbeitsgruppe angeschlossen werden sollen, kopieren Sie die Datei in einen gemeinsam genutzten Ordner (sofern Sie dieses nicht bereits in Schritt 4 getan haben) und lassen dann jeden dieser Benutzer zum Anschließen an die Arbeitsgruppen-Informationsdatei das Dienstprogramm Arbeitsgruppen-Administrator ausführen.


 Sich einer Microsoft Access-Arbeitsgruppe unter Verwendung von Workgroup Administrator anschließen

Sich einer Microsoft Access-Arbeitsgruppe unter Verwendung von Workgroup Administrator anschließen

  1. Beenden Sie Microsoft Access.

  2. Zum Starten des Arbeitsgruppen-Administrators öffnen Sie den Sprachenordner und doppelklicken dann auf WRKGADM.EXE. Alternativ können Sie die Verknüpfung MS Access Workgroup Administrator im Ordner \Programmdateien\Microsoft Office\Office verwenden.

  3. Klicken Sie im Dialogfeld Arbeitsgruppen-Administrator auf Beitreten.

  4. Geben Sie den Pfad und den Namen der Arbeitsgruppen-Informationsdatei an, die die Microsoft Access-Arbeitsgruppe definiert, der Sie sich anschließen möchten, und klicken Sie dann auf OK, oder klicken Sie auf Durchsuchen, und verwenden Sie das Dialogfeld Arbeitsgruppen-Systemdatenbanken auswählen, um nach der Arbeitsgruppen-Informationsdatei zu suchen.

    Wenn Sie Microsoft Access das nächste Mal starten, verwendet es die Benutzer- und Gruppenkonten sowie die Kennwörter, die in der Arbeitsgruppen-Informationsdatei für die Arbeitsgruppe gespeichert sind, der Sie sich angeschlossen haben.

Wichtig Wenn Sie Sicherheitsmaßnahmen auf Benutzerebene aktivieren möchten und sicherstellen müssen, dass Ihre Arbeitsgruppe und deren Berechtigungen nicht dupliziert werden können, muss die Arbeitsgruppen-Informationsdatei für die Arbeitsgruppe, der Sie sich anschließen, eine eindeutige Arbeitsgruppen-Identifikationsnummer (WID) haben. Wenn eine solche Arbeitsgruppen-Informationsdatei nicht existiert, erstellen Sie diese. Zum Anzeigen von Informationen zum Erstellen einer neuen Arbeitsgruppen-Informationsdatei klicken Sie auf [image] .


 Einrichten von mindestens zwei Arbeitsgruppen, die dieselbe geschützte Datenbank verwenden

Einrichten von mindestens zwei Arbeitsgruppen, die dieselbe geschützte Datenbank verwenden

Sie können Benutzern in verschiedenen Microsoft Access-Arbeitsgruppen Zugriffsrechte für eine geschützte Datenbank und die darin enthaltenen Objekte erteilen, indem Sie in jeder Arbeitsgruppe, die auf die geschützte Datenbank zugreifen soll, ein Gruppenkonto mit identischem Namen und identischer persönlicher Identifikationsnummer (PID) einrichten. Anschließend können Sie in den einzelnen Arbeitsgruppen Benutzer zu diesem Gruppenkonto hinzufügen. Dies ist dann nützlich, wenn Benutzer an Remotestandorten ihre eigene Arbeitsgruppenzugehörigkeit verwalten sollen.

  1. Beenden Sie Microsoft Access.

  2. Verwenden Sie den Arbeitsgruppen-Administrator, um sich einer der Arbeitsgruppen anzuschließen.

    Wie wird's gemacht?

  3. Starten Sie Microsoft Access, öffnen Sie eine Datenbank und melden Sie sich dann als Arbeitsgruppen-Administrator (als Mitglied der Gruppe Administratoren) an.
  4. Richten Sie ein Gruppenkonto ein und geben Sie den Gruppennamen und die PID genau und unter Beachtung der Groß-/Kleinschreibung ein.

    Wie wird's gemacht?

  5. Fügen Sie Benutzer zur neuen Gruppe hinzu.

    Wie wird's gemacht?

    Anmerkung Sie können jederzeit Benutzer zu dieser Gruppe hinzufügen oder daraus entfernen.

  6. Wiederholen Sie die Schritte 1 bis 5 für jede Arbeitsgruppe, die Zugriff auf die gleiche geschützte Datenbank erhalten soll. Achten Sie in Schritt 3 darauf, die Einträge für den Gruppennamen und die PID (unter Beachtung der Groß-/Kleinschreibung) genau wie beim Erstellen des Gruppenkontos in der ersten Arbeitsgruppe einzugeben.

  7. Öffnen Sie die geschützte Datenbank, die von den Arbeitsgruppen gemeinsam genutzt werden soll und weisen Sie der neuen Gruppe Berechtigungen zu.

    Wie wird's gemacht?

Anmerkung Sie können auch den Arbeitsgruppen-Administrator an einem Remotestandort bitten, dieselbe Gruppe zu seiner Arbeitsgruppen-Informationsdatei hinzuzufügen. Teilen Sie ihm dazu den genauen, bei der Erstellung der Gruppe in Ihrer Arbeitsgruppen-Informationsdatei verwendeten Gruppennamen (mit Angabe der Groß-/Kleinschreibung) und die PID mit.


 Anmelden bei einer Microsoft Access-Arbeitsgruppe

Anmelden bei einer Microsoft Access-Arbeitsgruppe

Das Dialogfeld Anmeldung wird nur angezeigt, wenn für die Microsoft Access-Arbeitsgruppe die Anmeldeprozedur aktiviert wurde. Nach Aktivierung der Anmeldeprozedur müssen Sie sich beim Starten durch Eingabe eines gültigen Benutzerkontos anmelden. Wenn einem Benutzerkonto ein Kennwort hinzugefügt wurde, müssen Sie auch das Kennwort eingeben. Bei der Eingabe von Kennwörtern ist auf Groß-/Kleinschreibung zu achten.

  1. Wechseln Sie gegebenenfalls zur Arbeitsgruppe mit dem Benutzerkonto, unter dem Sie sich anmelden möchten. Verwenden Sie hierzu den Microsoft Access-Arbeitsgruppen-Administrator.

    Wie wird's gemacht?

  2. Starten Sie Microsoft Access, und öffnen Sie eine Datenbank. Wurde die Anmeldeprozedur aktiviert, wird das Dialogfeld Anmelden angezeigt.

  3. Geben Sie in das Textfeld Name den Namen des Benutzerkontos ein. Bei der Eingabe des Namens muss nicht auf Groß- und Kleinschreibung geachtet werden.

  4. Wenn Sie über ein Kennwort verfügen, geben Sie dieses in das Textfeld Kennwort ein. Andernfalls geben Sie kein Kennwort ein.

Weitere Informationen über das Aktivieren der Anmeldeprozedur erhalten Sie durch Klicken auf [image] .

Weitere Informationen über das Hinzufügen eines Kennworts zu Ihrem Konto erhalten Sie durch Klicken auf [image] .


 Festlegen, dass Benutzer sich an Microsoft Access anmelden müssen

Festlegen, dass Benutzer sich an Microsoft Access anmelden müssen

Wenn für eine Arbeitsgruppe kein Anmeldeverfahren aktiviert ist, meldet Microsoft Access alle Benutzer beim Starten unter Verwendung des vordefinierten Benutzerkontos Administrator automatisch an. Um festzulegen, dass die Benutzer einer Arbeitsgruppe sich anmelden müssen, fügen Sie zum Benutzerkonto Administrator ein Kennwort hinzu.

  1. Schließen Sie sich der Arbeitsgruppe mit dem Anmeldeverfahren an, das Sie aktivieren möchten.

    Wie wird's gemacht?

  2. Starten Sie Microsoft Access, und öffnen Sie dann eine Datenbank.

  3. Klicken Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Benutzer- und Gruppenkonten.

  4. Klicken Sie auf die Registerkarte Benutzer, und stellen Sie sicher, dass im Feld Name das vordefinierte Benutzerkonto Administrator markiert ist.

  5. Klicken Sie auf die Registerkarte Anmeldungskennwort ändern, klicken Sie auf das Feld Neues Kennwort, und geben Sie das neue Kennwort ein. Geben Sie nichts in das Feld Altes Kennwort ein.

    Microsoft Access zeigt beim Eingeben des Kennworts Sternchen (*) an, um die Sicherheit des Kennworts zu gewährleisten. Kennwörter können 1 bis 20 Zeichen lang sein und, mit Ausnahme des ASCII-Zeichens 0 (Null), alle beliebigen Zeichen enthalten. Bei Kennwörtern müssen Sie die Groß-/Kleinschreibung beachten.

  6. Geben Sie im Feld Bestätigen das Kennwort erneut ein, um dieses zu bestätigen, und klicken Sie dann auf OK.

    Das Dialogfeld Anmelden erscheint, wenn ein beliebiges Mitglied der Arbeitsgruppe, der Sie sich in Schritt 1 angeschlossen haben, Microsoft Access startet und eine Datenbank öffnet. Wenn derzeit keine Benutzerkonten für diese Arbeitsgruppe definiert sind, ist zu diesem Zeitpunkt das einzige gültige Konto das Benutzerkonto Administrator. Um Informationen zum Definieren von Benutzerkonten anzuzeigen, klicken Sie auf [image] .

Anmerkung Wenn Sie eine Datenbank schützen, erstellen Sie Benutzerkonten in einer Microsoft Access-Arbeitsgruppe und weisen dann diesen Konten und beliebigen Gruppenkonten, zu denen sie gehören, Berechtigungen für Datenbanken, Tabellen, Abfragen, Formulare, Berichte und Makros zu. Wenn Benutzer sich unter Verwendung ihrer Konten an Microsoft Access anmelden, erhalten sie nur die diesen Konten zugewiesenen Berechtigungen. Zum Anmelden an Microsoft Access müssen Benutzer im Dialogfeld Anmelden einen Benutzernamen und ein Kennwort eingeben.


 Deaktivieren des Dialogfelds "Anmelden"

Deaktivieren des Dialogfelds "Anmelden"

  1. Schließen Sie sich an die Arbeitsgruppe an, für die Sie das Anmeldeverfahren deaktivieren möchten.

    Wie wird's gemacht?

  2. Starten Sie Microsoft Access und öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Sicherheit und klicken Sie dann auf Benutzer- und Gruppenkonten.

  4. Klicken Sie auf die Registerkarte Benutzer. Klicken Sie im Feld Name in der Liste auf Administrator und dann auf Kennwort löschen.

    Beim nächsten Starten von Microsoft Access durch eines der Mitglieder der Arbeitsgruppe, der Sie sich in Schritt 1 angeschlossen haben, erscheint dann nicht mehr das Dialogfeld Anmelden.

Anmerkung Dieses Verfahren entfernt keine der für die Datenbank definierten Sicherheitsmaßnahmen auf Benutzerebene. Um Informationen zum Thema Entfernen aller Sicherheitsmaßnahmen auf Benutzerebene anzuzeigen, klicken Sie auf [image] .


 Wiederherstellen einer Arbeitsgruppen-Informationsdatei aus den Benutzer- und Gruppennamen und den Identifikationskennungen

Wiederherstellen einer Arbeitsgruppen-Informationsdatei aus den Benutzer- und Gruppennamen und den Identifikationskennungen

Wenn eine Arbeitsgruppen-Informationsdatei beschädigt wird oder gelöscht wurde und keine Sicherungskopie verfügbar ist, können Sie diese Datei erneut erstellen. Hierzu benötigen Sie die Informationen in exakter Groß-/Kleinschreibung, die Sie zum Erstellen der Datei sowie zum Definieren der Konten und Gruppen in der Datei verwendet haben.

  1. Erstellen Sie eine neue Arbeitsgruppen-Informationsdatei. Achten Sie dabei darauf, in exakter Groß-/Kleinschreibung den Benutzernamen, Firmennamen und Arbeitsgruppencode einzugeben, die Sie zum Erstellen der Originaldatei verwendet haben. Wenn Sie diese Eingaben nicht wiederholen, wird eine ungültige Gruppe Administratoren erstellt.

    Wie wird's gemacht?

  2. Erstellen Sie alle Gruppenkonten erneut. Achten Sie dabei darauf, den Gruppennamen und die persönliche Identifikationskennung (PID) für jede Gruppe in exakter Groß-/Kleinschreibung einzugeben.

    Wie wird's gemacht?

  3. Erstellen Sie jedes Benutzerkonto erneut. Achten Sie dabei darauf, den Benutzernamen und die persönliche Identifikationskennung für jeden Benutzer in exakter Groß-/Kleinschreibung einzugeben.

    Wie wird's gemacht?

  4. Wenn Sie die neue Arbeitsgruppen-Informationsdatei in Schritt 1 unter einem neuen Namen oder an einem neuen Standort gespeichert haben, fordern Sie die anderen Benutzer in der Arbeitsgruppe auf, sich der neuen Arbeitsgruppen-Informationsdatei unter Verwendung des Arbeitsgruppen-Administrators anzuschließen.


 Wiederherstellen einer beschädigten oder gelöschten Microsoft Access-Arbeitsgruppen-Informationsdatei

Wiederherstellen einer beschädigten oder gelöschten Microsoft Access-Arbeitsgruppen-Informationsdatei

In seltenen Fällen kann es dazu kommen, dass die Microsoft Access-Arbeitsgruppen-Informationsdatei beschädigt wird. Wenn Sie Microsoft Access starten und die Datei nicht geöffnet werden kann, erscheint eine entsprechende Meldung. Die Lösung dieses Problems ist abhängig davon, ob Sie über eine Sicherungskopie verfügen und davon, wie Ihre Arbeitsgruppen-Informationsdatei zu Beginn erstellt oder festgelegt wurde. Die nachstehende Tabelle zeigt die Lösungen für die unterschiedlichen Situationen.

Arbeitsgruppen- Informationsdatei verwendet | Sicherungs- kopie verwendet | Lösung
Nein. Standarddatei verwendet, die beim Installieren von Microsoft Access erstellt wurde. | Nein | Starten Sie Microsoft Access neu, damit das Windows-Installationsprogramm eine Standardversion der Arbeitsgruppen-Informationsdatei neu erstellen wird.
Nein. Standarddatei verwendet, die beim Installieren von Microsoft Access erstellt wurde. | Ja | Verwenden Sie den Windows Explorer, Ihren Arbeitsplatz, den MS-DOS-Befehl copy oder eine Sicherungssoftware zum Kopieren der letzten Kopie der Datei in den Ordner, in dem Sie Microsoft Access installiert haben.
Ja. Es wurde eine neue Datei erstellt. | Nein | Führen Sie den Arbeitsgruppen-Administrator erneut aus, und geben Sie den gleichen Namen (in identischer Groß-/Kleinschreibung), die Firma und die Arbeitsgruppen-Identifikationsnummern ein, die Sie ursprünglich verwendet haben. Zum Anzeigen weiterer Informationen zum Erstellen einer Arbeitsgruppendatei klicken Sie auf [image] .
Ja. Es wurde eine neue Datei erstellt. | Ja | Kopieren Sie die Sicherungsdatei in den Ordner, in dem Sie die Arnbeitsgruppen-Informationsdatei ursprünglich gespeichert haben (oder stellen Sie sie wieder her).
Ja. Es wurde eine Datei in einem anderen als dem Ordner angegeben, in dem Microsoft Access installiert wurde. | Ja. | Kopieren Sie die Sicherungsdatei in den ursprünglichen Ordner (oder stellen Sie sie wieder her).
Ja. Es wurde eine Datei in einem anderen als dem Ordner angegeben, in dem Microsoft Access installiert wurde. | Nein | Erstellen Sie eine neue Kopie unter Verwendung der Methode, die zum Erstellen der Originaldatei verwendet wurde: starten Sie Microsoft Access neu (damit das Installationsprogramm erneut eine Standardversion der Arbeitsgruppen- Informationsdatei erstellt) oder verwenden Sie den Arbeitsgruppen-Administrator (unter Eingabe des gleichen Namens -in identischer Groß-/Kleinschreibung-, der Firma und der Arbeitsgruppen-Identifikationsnummern, die ursprünglich verwendet wurden).

Wichtig Microsoft Access speichert Benutzer- und Gruppenkonto-Informationen in der Arbeitsgruppen-Informationsdatei. Daher müssen Sie in allen Fällen, in denen Sie nicht über eine Sicherungskopie verfügen und die Arbeitsgruppen-Informationsdatei neu erstellen müssen und in denen Sie eingeschränkte Berechtigungen auf Ihre Datenbank definiert hatten, die Sicherheitskonten neu erstellen. Dabei müssen Sie die gleichen Einträge für Namen und persönliche Identifikationsnummern (PID) wie beim ersten Mal verwenden. Zum Anzeigen weiterer Informationen zum erneuten Erstellen einer Arbeitsgruppen-Informationsdatei unter Verwendung von Benutzer- und Gruppennamen sowie -identifikationsnummern klicken Sie auf [image] .

Sie müssen weder Berechtigungen noch Informationen über Eigentum an Objekten neu definieren, da diese Informationen in der gesicherten Datenbank gespeichert werden.


 Erstellen eines Sicherheitsadministratorkontos

Erstellen eines Sicherheitsadministratorkontos

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung einer geschützten Arbeitsgruppe.

    Wichtig Ihre Datenbank ist nur dann vollständig geschützt, wenn Sie nicht die in der Arbeitsgruppen-Informationsdatei definierte Standardarbeitsgruppe, die beim Installieren von Microsoft Access erstellt wurde, verwenden. Stellen Sie sicher, dass die Arbeitsgruppen-Informationsdatei, die die von Ihnen verwendete Arbeitsgruppe definiert, unter Verwendung einer eindeutigen Arbeitsgruppen-Identifikationsnummer (WID) erstellt wurde. Erstellen Sie eine neue Datei, wenn dies nicht der Fall ist.

    Zum Anzeigen von Informationen zum Anschließen an eine vorhandene Arbeitsgruppe klicken Sie auf [image] . Zum Anzeigen weiterer Informationen zum Erstellen einer neuen Arbeitsgruppen-Informationsdatei klicken Sie auf [image] .

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Klicken Sie in der Registerkarte Benutzer auf Neu.

  5. Geben Sie im Dialogfeld Neue(r) Benutzer/Gruppe den Namen des Administratorkontos und eine persönliche Identifikationsnummer (PID) ein, und klicken Sie dann auf OK, um das neue Konto zu erstellen.

    Benutzernamen können 1 bis 20 Zeichen umfassen und alphabetische Zeichen, Zeichen mit Akzenten, Ziffern, Leerzeichen und Sonderzeichen enthalten. Ausgenommen sind die folgenden Zeichen:

    • Die Zeichen " \ [ ] : | < > + = ; , ? *

    • Vorangestellte Leerzeichen

    • Steuerzeichen (ASCII 10 bis ASCII 31)

    Achtung Notieren Sie sich unbedingt den genauen Kontonamen und den Eintrag für die persönliche Identifikationsnummer. Dabei muss auch die Groß-/Kleinschreibung berücksichtigt werden. Bewahren Sie diese Angaben an einem sicheren Ort auf. Wenn Sie das Konto aus einem beliebigen Grund zu einem späteren Zeitpunkt neu erstellen müssen, müssen Sie die Einträge für den Namen und die persönliche Identifikationsnummer genau wie beim ersten Eingeben angeben. Wenn Sie diese Angaben vergessen oder verlieren, können Sie diese nicht wiederherstellen.

  6. Klicken Sie im Feld Verfügbare Gruppen auf Administratoren und dann auf Hinzufügen.

    Microsoft Access fügt das neue Administratorkonto zur Gruppe Administratoren hinzu und zeigt im Feld Mitglied von den Eintrag Administratoren an.

Anmerkung Die in Schritt 5 eingegebene persönliche Identifikationsnummer (PID) ist kein Kennwort. Microsoft Access verwendet die PID und den Benutzernamen als Basis für einen Verschlüsselungsalgorithmus, um einen sicheren Bezeichner für das Benutzerkonto zu erstellen. Zum Anzeigen weiterer Informationen zum Erstellen von Kennwörtern klicken Sie auf [image] .


 Erstellen eines Sicherheitsbenutzerkontos

Erstellen eines Sicherheitsbenutzerkontos

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, in der Sie das Konto verwenden möchten.

    Wichtig Die Konten, die Sie für Benutzer erstellen, müssen in der Arbeitsgruppen-Informationsdatei gespeichert werden, der sich diese Benutzer anschließen, wenn sie die Datenbank verwenden. Wenn Sie zum Erstellen der Datenbank eine andere Arbeitsgruppe verwenden möchten, müssen Sie vor dem Erstellen der Konten Ihre Arbeitsgruppe wechseln.

    Zum Anzeigen von Informationen zum Anschließen an eine vorhandenen Arbeitsgruppe klicken Sie auf [image] . Zum Anzeigen von Informationen zum Erstellen einer neuen Arbeitsgruppen-Informationsdatei klicken Sie auf [image] .

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Klicken Sie in der Registerkarte Benutzer auf Neu.

  5. Geben Sie im Dialogfeld Neue(r) Benutzer/Gruppe den Namen des neuen Kontos und eine persönliche Identifikationsnummer (PID) ein, und klicken Sie dann auf OK, um das neue Konto zu erstellen. Es wird automatisch zur Gruppe Benutzer hinzugefügt.

    Benutzernamen können 1 bis 20 Zeichen umfassen und alphabetische Zeichen, Zeichen mit Akzenten, Ziffern, Leerzeichen und Sonderzeichen enthalten. Ausgenommen sind die folgenden Zeichen:

    • Die Zeichen " \ [ ] : | < > + = ; , ? *

    • Vorangestellte Leerzeichen

    • Steuerzeichen (ASCII 10 bis ASCII 31)

    Achtung Notieren Sie sich unbedingt den genauen Kontonamen und den Eintrag für die persönliche Identifikationsnummer. Dabei muss auch die Groß-/Kleinschreibung berücksichtigt werden. Bewahren Sie diese Angaben an einem sicheren Ort auf. Wenn Sie das Konto aus einem beliebigen Grund zu einem späteren Zeitpunkt neu erstellen müssen, müssen Sie die Einträge für den Namen und die persönliche Identifikationsnummer genau wie beim ersten Eingeben angeben. Wenn Sie diese Angaben vergessen oder verlieren, können Sie diese nicht wiederherstellen.

Anmerkungen

  • Die in Schritt 5 eingegebene persönliche Identifikationsnummer (PID) ist kein Kennwort. Microsoft Access verwendet die PID und den Benutzernamen als Basis für einen Verschlüsselungsalgorithmus, um einen sicheren Bezeichner für das Benutzerkonto zu erstellen. Zum Anzeigen weiterer Informationen zum Erstellen von Kennwörtern klicken Sie auf [image] .

  • Es ist in der Regel einfacher, Sicherheitsmaßnahmen durch Strukturieren von Benutzern in Gruppen und Zuweisen von Berechtigungen zu Gruppen, anstatt durch Zuweisen von Berechtigungen zu einzelnen Benutzern zu gewährleisten.


 Erstellen eines Sicherheitsgruppenkontos

Erstellen eines Sicherheitsgruppenkontos

Zum Schützen einer Datenbank können Sie in Ihrer Microsoft Access-Arbeitsgruppe Gruppenkonten erstellen, denen Sie eine Reihe von Berechtigungen für mehrere Benutzer zuweisen.

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, in der Sie das Konto verwenden möchten.

    Wichtig Die Konten, die Sie für Benutzer erstellen, müssen in der Arbeitsgruppen-Informationsdatei gespeichert werden, der diese Benutzer sich anschließen, wenn sie die Datenbank verwenden. Wenn Sie zum Erstellen der Datenbank eine andere Arbeitsgruppe verwenden, müssen Sie vor dem Erstellen der Konten Ihre Arbeitsgruppe wechseln. Sie können die Arbeitsgruppe mit Hilfe des Arbeitsgruppen-Administrators wechseln.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Klicken Sie in der Registerkarte Gruppen auf Neu.

  5. Geben Sie im Dialogfeld Neue(r) Benutzer/Gruppe den Namen des Administratorkontos und eine persönliche Identifikationsnummer (PID) ein, und klicken Sie dann auf OK, um das neue Konto zu erstellen.

    Gruppennamen können 1 bis 20 Zeichen umfassen und alphabetische Zeichen, Zeichen mit Akzenten, Ziffern, Leerzeichen und Sonderzeichen enthalten. Ausgenommen sind die folgenden Zeichen:

    • Die Zeichen " \ [ ] : | < > + = ; , ? *

    • Vorangestellte Leerzeichen

    • Steuerzeichen (ASCII 10 bis ASCII 31)

    Achtung Notieren Sie sich unbedingt den genauen Kontonamen und den Eintrag für die persönliche Identifikationsnummer. Dabei muss auch die Groß-/Kleinschreibung berücksichtigt werden. Bewahren Sie diese Angaben an einem sicheren Ort auf. Wenn Sie das Konto aus einem beliebigen Grund zu einem späteren Zeitpunkt neu erstellen müssen, müssen Sie die Einträge für den Namen und die persönliche Identifikationsnummer genau wie beim ersten Eingeben angeben. Wenn Sie diese Angaben vergessen oder verlieren, können Sie diese nicht wiederherstellen.

  6. Klicken Sie auf OK, um das neue Gruppenkonto zu erstellen.


 Hinzufügen von Benutzern zu Sicherheitsgruppenkonten

Hinzufügen von Benutzern zu Sicherheitsgruppenkonten

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, die die Benutzer- und Gruppenkonten enthält.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppe ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Wählen Sie auf der Registerkarte Benutzer im Feld Name den Namen des Benutzers aus, den Sie zu einer Gruppe hinzufügen möchten.

  5. Klicken Sie im Feld Verfügbare Gruppen auf die Gruppe, der Sie den Benutzer hinzufügen möchten, und dann auf Hinzufügen.

    Die markierte Gruppe erscheint im Listenfeld Mitglied von.

  6. Wiederholen Sie Schritt 5, wenn Sie diesen Benutzer zu einer beliebigen weiteren Gruppe hinzufügen möchten. Klicken Sie anschließend auf OK.


 Drucken von Informationen über Sicherheitsbenutzer und -gruppenkonten

Drucken von Informationen über Sicherheitsbenutzer und -gruppenkonten

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppen-Informationsdatei, deren Sicherheitsinformationen Sie drucken möchten.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppen-Informationsdatei ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Klicken Sie in der Registerkarte Benutzer auf Benutzer und Gruppen drucken.

  5. Klicken Sie im Dialogfeld Zugriffsrechte drucken auf Nur Benutzer zum Drucken eines Berichts mit allen Benutzern der aktuellen Arbeitsgruppe oder auf Nur Gruppen zum Drucken eines Berichts mit allen Gruppen der aktuellen Arbeitsgruppe. Klicken Sie auf Benutzer und Gruppe, wenn Sie sowohl Benutzer- als auch Gruppenkontoinformationen drucken möchten.

  6. Klicken Sie auf OK.

Anmerkung Wenn Sie eine Arbeitsgruppen-Informationsdatei verwenden, die in Microsoft Access, Version 2.0 erstellt wurde, müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein, um Benutzer- und Gruppeninformationen zu drucken. Wenn die Arbeitsgruppen-Informationsdatei in Microsoft Access, Version 7.0 oder höher, erstellt wurde, können alle Benutzer in der Arbeitsgruppe Benutzer- und Gruppeninformationen drucken.


 Entfernen von Benutzern aus Sicherheitsgruppenkonten

Entfernen von Benutzern aus Sicherheitsgruppenkonten

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, die die Benutzer- und Gruppenkonten enthält.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppe ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Wählen Sie auf der Registerkarte Benutzer im Feld Name den Namen des Benutzers aus, den Sie entfernen möchten.

  5. Klicken Sie im Feld Mitglied von auf die Gruppe, aus der Sie Benutzer entfernen möchten und dann auf Entfernen.

  6. Wiederholen Sie Schritt 5, wenn Sie diesen Benutzer aus weiteren Gruppen entfernen möchten, und klicken Sie dann auf OK.

Anmerkungen

  • Sie können keinen Benutzer aus der Standardgruppe Benutzer entfernen. Microsoft Access fügt automatisch alle Benutzer zur Gruppe Benutzer hinzu. Zum Entfernen von Benutzerkonten aus der Gruppe Benutzer müssen Sie das Konto löschen. Zum Anzeigen von Informationen zum Löschen eines Benutzerkontos klicken Sie auf [image] .

  • Die vordefinierte Gruppe Administratoren muss zu jedem Zeitpunkt mindestens einen Benutzer enthalten.


 Löschen eines Sicherheitsbenutzerkontos

Löschen eines Sicherheitsbenutzerkontos

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Öffnen Sie eine Datenbank.

  2. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  3. Wählen Sie auf der Registerkarte Benutzer im Feld Name einen Benutzernamen aus, und klicken Sie dann auf Löschen.

  4. Klicken Sie auf Ja, um das Benutzerkonto zu löschen.

  5. Wiederholen Sie die Schritte 3 und 4, wenn Sie weitere Benutzerkonten löschen möchten. Klicken Sie auf OK, wenn Sie alle gewünschten Konten gelöscht haben.

Anmerkung Das Benutzerkonto Administrator kann nicht gelöscht werden.


 Löschen eines Sicherheitsgruppenkontos

Löschen eines Sicherheitsgruppenkontos

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, die das zu löschende Konto enthält.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppe ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Wählen Sie auf der Registerkarte Gruppen im Feld Name die Gruppe aus, die Sie löschen möchten, und klicken Sie dann auf Löschen.

  5. Klicken Sie auf Ja, um das Gruppenkonto zu löschen.

  6. Wiederholen Sie die Schritte 4 und 5, wenn Sie weitere Gruppenkonten löschen möchten, und klicken Sie nach dem Löschen aller gewünschten Gruppen auf OK.

Anmerkung Die Gruppenkonten Administratoren und Benutzer können nicht gelöscht werden.


 Erstellen oder Ändern eines Kennworts für ein Sicherheitskonto

Erstellen oder Ändern eines Kennworts für ein Sicherheitskonto

Mit Hilfe eines Sicherheitskontos können Sie sicherstellen, dass kein anderer Benutzer sich unter dem Namen des jeweiligen Benutzers anmelden kann. Microsoft Access weist dem Benutzerkonto Administrator und jedem neuen Benutzerkonto, das Sie in Ihrer Arbeitsgruppe erstellen, automatisch ein leeres Kennwort zu.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppe, in der das Benutzerkonto gespeichert ist, und melden Sie sich unter dem Namen des Kontos an, für das Sie das Kennwort festlegen oder ändern möchten.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppe ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Lassen Sie auf der Registerkarte Anmeldungskennwort ändern das Feld Altes Kennwort leer, wenn für dieses Konto noch kein Kennwort definiert worden war. Wenn für dieses Konto bereits ein Kennwort existiert, geben Sie in das Feld Altes Kennwort das aktuelle Kennwort ein.

  5. Geben Sie in das Feld Neues Kennwort das neue Kennwort ein.

    Ein Kennwort kann zwischen 1 und 20 Zeichen lang sein und beliebige Zeichen enthalten, ausgenommen jedoch das ASCII -Zeichen 0 (Null). Bei Kennwörtern muss die Groß-/Kleinschreibung berücksichtigt werden.

  6. Geben Sie das Kennwort im Feld Bestätigen erneut ein, und klicken Sie dann auf OK.

Achtung Wenn Sie Ihr Kennwort vergessen, können Sie dieses nicht wiederherstellen. Bewahren Sie dieses daher an einem sicheren Ort auf. Wenn Sie Ihr Kennwort vergessen, können Sie sich erst wieder anmelden, wenn dieses von einem Benutzer, der sich unter einem Administratorkonto angemeldet hat (einem Mitglied der Gruppe Administratoren in der Arbeitsgruppe, in der das Kennwort festgelegt wurde), gelöscht worden ist.


 Löschen eines Kennworts für ein Sicherheitskonto

Löschen eines Kennworts für ein Sicherheitskonto

Zum Ausführen der nachstehenden Schritte müssen Sie als Mitglied der Gruppe Administratoren angemeldet sein.

  1. Starten Sie Microsoft Access unter Verwendung der Arbeitsgruppen-Informationsdatei, in der das Benutzerkonto (und dessen Kennwort) gespeichert ist.

    Verwenden Sie den Arbeitsgruppen-Administrator, wenn Sie herausfinden möchten, welches die aktuelle Arbeitsgruppen-Informationsdatei ist, oder wenn Sie zu einer anderen Arbeitsgruppe wechseln möchten.

  2. Öffnen Sie eine Datenbank.

  3. Zeigen Sie im Menü Extras auf Zugriffsrechte, und klicken Sie dann auf Benutzer und Gruppenkonten.

  4. Wählen Sie auf der Registerkarte Benutzer im Feld Name den Namen des Benutzerkontos aus.

  5. Klicken Sie auf Kennwort löschen.

  6. Wiederholen Sie die Schritte 4 und 5, wenn Sie weitere Kennwörter löschen möchten, und klicken Sie anschließend auf OK.


 Anzeigen oder Übertragen des Besitzes einzelner Tabellen, Abfragen, Formulare, Berichte und Makros in einer geschützten Datenbank

Anzeigen oder Übertragen des Besitzes einzelner Tabellen, Abfragen, Formulare, Berichte und Makros in einer geschützten Datenbank

Wenn Sie über die Berechtigung Verwalten für Tabellen, Abfragen, Formulare, Berichte oder Makros verfügen, können Sie den Besitz an dem Objekt einem anderen Benutzer oder einer anderen Gruppe übertragen.

  1. Öffnen Sie die Datenbank.

  2. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Benutzer- und Gruppenberechtigungen.

    In Microsoft Access wird auf der Registerkarte Besitzer ändern eine Liste mit Tabellen, Abfragen, Formularen, Berichten und Makros angezeigt, die gerade im Datenbankfenster angezeigt werden, und der aktuelle Besitzer dieser Objekte.

  3. Klicken Sie im Feld Objekttyp auf ein Objekt, oder verwenden Sie einen bereits bestehenden Objekttypen.

  4. Klicken Sie im Listenfeld Objekt auf ein Objekt oder mehrere Objekte, dessen/deren Besitzerstatus geändert werden soll. Um mehrere Objekte auszuwählen, halten Sie entweder STRG gedrückt und klicken auf die Objekte, oder markieren Sie die Objekte mit der Maus.

  5. Klicken Sie im Listenfeld Neuer Besitzer auf den Benutzer oder das Gruppenkonto, der oder das neuer Besitzer des Objektes/der Objekte werden soll.

  6. Klicken Sie auf die Schaltfläche Besitzer ändern.

Anmerkung Wenn der neue Besitzer einer Tabelle, Abfrage, eines Formulars, Berichts oder Makros ein Gruppenkonto sein soll, erhalten alle Benutzer, die der Gruppe angehören, automatisch die für den Besitzerstatus des Objekts zugewiesenen Berechtigungen.


 Übertragen des Besitzes einer vollständigen Datenbank an einen anderen Administrator

Übertragen des Besitzes einer vollständigen Datenbank an einen anderen Administrator

  1. Starten Sie Microsoft Access unter Verwendung einer geschützten Arbeitsgruppe, die das Benutzerkonto enthält, das Besitzer der Datenbank und deren Objekte werden soll.

  2. Melden Sie sich unter diesem Konto an.

  3. Erstellen Sie eine neue, leere Datenbank.

  4. Importieren Sie alle Objekte aus der Datenbank, deren Besitz Sie übertragen möchten, in die neue Datenbank.

    Wie wird's gemacht?

Anmerkung Zum Importieren einer Datenbank benötigen Sie für diese Datenbank die Berechtigung Öffnen/Ausführen und für die Objekte die Berechtigung Entwurf lesen. Zum Importieren von Tabellen benötigen Sie darüber hinaus die Berechtigung Daten lesen. Wenn Sie nur für einige Tabellen, Abfragen, Formulare, Berichte und Makros über Berechtigungen verfügen, importiert Microsoft Access nur diese Objekte.


 Zuweisen von Standardberechtigungen für neue Tabellen, Abfragen, Formulare, Berichte und Makros

Zuweisen von Standardberechtigungen für neue Tabellen, Abfragen, Formulare, Berichte und Makros

  1. Öffnen Sie die Datenbank, die die Tabellen, Abfragen, Formulare, Berichte und Makros enthält.

  2. Klicken Sie im Menü Extras auf Sicherheit und dann auf Benutzer- und Gruppenberechtigungen.

  3. Klicken Sie in der Registerkarte Berechtigungen auf Benutzer oder Gruppen und dann im Feld Benutzer/Gruppenname auf den Benutzer oder die Gruppe, dem/der Sie Berechtigungen zuweisen möchten.

  4. Klicken Sie im Feld Objekttyp auf den gewünschten Objekttyp und dann im Listenfeld Objektname auf Neues Objekt .

    Der Eintrag Neues Objekt erscheint je nach gewähltem Objekttyp unterschiedlich: als Neue Tabellen/Abfragen, Neue Formulare, Neue Berichte oder Neue Makros.

  5. Wählen Sie die Standardberechtigungen aus, die Sie für diesen Objekttyp zuweisen möchten, und klicken Sie dann auf Übernehmen. Wiederholen Sie die Schritte 4 und 5, wenn Sie weiteren Objekttypen für die aktuelle Gruppe oder den aktuellen Benutzern Berechtigungen zuweisen möchten.

    Zum Anzeigen von Informationen zu allen Berechtigungen, die Sie zuweisen können, klicken Sie auf [image] .

  6. Wiederholen Sie die Schritte 3 bis 5 für alle zusätzlichen Benutzer oder Gruppen, und klicken Sie anschließend auf OK.

Anmerkungen

  • Standardberechtigungen können nur mit einem Administratorkonto (von einem Mitglied der Gruppe Administratoren in der Arbeitsgruppe, in der die die Objekte enthaltende Datenbank erstellt wurde, oder vom Besitzer der Datenbank zugewiesen werden.

  • Einige Berechtigungen erteilen automatisch auch andere Berechtigungen. Die Berechtigung Daten aktualisieren erteilt beispielsweise automatisch auch die Berechtigungen Daten lesen und Entwurf lesen, da Sie diese zum Ändern von Daten in einer Tabelle benötigen. Die Berechtigungen Entwurf ändern und Daten lesen erteilen automatisch auch die Berechtigung Entwurf lesen. Für Makros erteilt die Berechtigung Entwurf lesen auch die Berechtigung Öffnen/Ausführen.

  • Das Verwalten von Benutzerkonten in Gruppen erleichtert die Sicherheitsverwaltung. Sie müssen beispielsweise nicht jedem einzelnen Benutzer für jedes Objekt Berechtigungen erteilen, sondern können einigen wenigen Gruppen Berechtigungen zuweisen und dann Benutzer zu den entsprechenden Gruppen hinzufügen. Wenn ein Benutzer sich an Microsoft Access anmeldet, erhält er automatisch die Berechtigungen der Gruppen, zu denen er gehört.


 Zuweisen oder Entfernen von Berechtigungen für eine Datenbank und vorhandene Tabellen, Abfragen, Formulare, Berichte und Makros

Zuweisen oder Entfernen von Berechtigungen für eine Datenbank und vorhandene Tabellen, Abfragen, Formulare, Berichte und Makros

  1. Öffnen Sie die Datenbank, deren Tabellen, Abfragen, Formulare, Berichte und Makros Sie schützen möchten.

    Die Arbeitsgruppen-Informationsdatei, die beim Anmelden aktiv ist, muss die Benutzer- oder Gruppenkonten enthalten, denen Sie zu diesem Zeitpunkt Berechtigungen erteilen möchten. Sie können jedoch auch später Gruppen Berechtigungen erteilen und diesen Benutzer hinzufügen.

  2. Klicken Sie im Menü Extras auf Sicherheit und dann auf Benutzer- und Gruppenberechtigungen.

  3. Klicken Sie in der Registerkarte Berechtigungen auf Benutzer oder Gruppen und dann im Feld Benutzer/Gruppennamen auf den Benutzer oder die Gruppe, dem/der Sie Berechtigungen zuweisen möchten.

  4. Klicken Sie im Feld Objekttyp auf den gewünschten Objekttyp und dann im Feld Objektname auf den Namen des Objekts, für das Sie Berechtigungen zuweisen möchten.

    Tipp Sie können im Feld Objektname mehrere Objekte auswählen. Dazu ziehen Sie über die Objekte, die Sie auswählen möchten, oder halten die STRG-TASTE gedrückt und klicken dann nacheinander auf die gewünschten Objekte.

  5. Wählen Sie unter Berechtigungen die Berechtigungen, die Sie zuweisen möchten, oder deaktivieren Sie die Berechtigungen, die Sie für die Gruppe oder den Benutzer entfernen möchten. Klicken Sie anschließend auf Übernehmen. Wiederholen Sie die Schritte 4 und 5, wenn Sie für den aktuellen Benutzer oder die aktuelle Gruppe Berechtigungen für weitere Objekte zuweisen oder entfernen möchten.

    Zum Anzeigen von Informationen zu allen Berechtigungen, die Sie zuweisen können, klicken Sie auf [image] .

  6. Wiederholen Sie die Schritte 3 bis 5 für zusätzliche Benutzer oder Gruppen, und klicken Sie anschließend auf OK.

Anmerkungen

  • Zum Anzeigen von Informationen darüber, wer Berechtigungen zuweisen und entfernen darf, klicken Sie auf [image] .

  • Einige Berechtigungen erteilen automatisch auch andere Berechtigungen. Die Berechtigung Daten aktualisieren erteilt beispielsweise automatisch auch die Berechtigungen Daten lesen und Entwurf lesen, da Sie diese zum Ändern von Daten in einer Tabelle benötigen. Die Berechtigungen Entwurf ändern und Daten lesen erteilen automatisch auch die Berechtigung Entwurf lesen. Für Makros erteilt die Berechtigung Entwurf lesen auch die Berechtigung Öffnen/Ausführen.

  • Wenn Sie ein Objekt bearbeiten und speichern, bleiben die für dieses Objekt erteilten Berechtigungen erhalten. Wird ein Objekt jedoch mit dem Befehl Speichern unter aus dem Menü Datei unter einem neuen Namen gespeichert, ausgeschnitten und eingefügt, importiert oder exportiert, dann werden die zugewiesenen Berechtigungen aufgehoben, und Sie müssen sie neu zuweisen. Der Grund dafür ist, dass Sie ein neues Objekt erstellen, dem die für diesen Objekttyp festgelegten Standardberechtigungen zugewiesen werden.
  • Ausgeblendete Objekte werden im Feld Objektname nur dann angezeigt, wenn Sie die Option Ausgeblendete Objekte auf der Registerkarte Ansicht im Dialogfeld Optionen aktivieren (Menü Extras).


 RunPermissions-Eigenschaft (Ausführungsberechtigungen)

RunPermissions-Eigenschaft (Ausführungsberechtigungen)

Sie können die Eigenschaft RunPermissions in einer Mehrbenutzerumgebung mit einer geschützten Arbeitsgruppe verwenden, um die bestehenden Benutzerberechtigungen außer Kraft zu setzen. Dadurch können Sie eine Abfrage anzeigen oder eine Anfüge-, Lösch-, Tabellenerstellungs- oder Aktualisierungsabfrage anzeigen, auch wenn Sie andernfalls keine Berechtigung dazu hätten. Sie können beispielsweise als Benutzer die Berechtigung "schreibgeschützt" für Abfragen haben, während der Besitzer der Abfragen über Lese-/Schreibzugriff verfügt. Wenn der Besitzer die Eigenschaft RunPermissions auf die Berechtigungen des Besitzers eingestellt hat, können Sie eine Anfügeabfrage ausführen, die Datensätze an eine Tabelle anfügt.

Einstellung

Die Eigenschaft RunPermissions verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Besitzer | Alle Benutzer haben die Berechtigungen des Besitzers, um eine Abfrage anzuzeigen oder auszuführen.
Benutzer | (Voreinstellung) Die Benutzer verfügen nur über ihre eigenen Berechtigungen, um eine Abfrage anzuzeigen oder auszuführen.

Sie können diese Eigenschaft im Abfrage-Eigenschaftenfenster einstellen.

Sie können die Eigenschaft RunPermissions auch in der SQL-Ansicht des Abfragefensters mit Hilfe der Deklaration WITH OWNERACCESS OPTION in der SQL-Anweisung einstellen.


Konvertieren einer gesicherten Datenbank aus Microsoft Access, Version 2.0

  1. Konvertieren Sie die gesicherte Datenbank.

    So wird's gemacht

  2. Konvertieren Sie die Arbeitsgruppeninformationsdatei (normalerweise SYSTEM.MDA), die mit der gesicherten Datenbank verwendet wurde.

    So wird's gemacht

  3. Fordern Sie die Benutzer auf, sich der konvertierten Arbeitsgruppen-Informationsdatei anzuschließen, bevor sie die gesicherte Datenbank öffnen.

    So wird's gemacht


 Konvertieren von gesicherten Microsoft Access 95/97-Datenbanken

Konvertieren von gesicherten Microsoft Access 95/97-Datenbanken

Wenn Sie von Microsoft Access 95 oder 97 aktualisieren, müssen Sie Ihre gesicherte Datenbank konvertieren, brauchen die Arbeitsgruppen-Informationsdatei jedoch nicht zu konvertieren, um sie mit Microsoft Access 2000 einzusetzen. Sie sollten allerdings diese Datei vor dem Einsatz komprimieren.

  1. Konvertieren Sie die gesicherte Datenbank.

    Wie wird's gemacht?

  2. Komprimieren Sie die gesicherte Datenbank.

    Wie wird's gemacht?

  3. Beenden Sie Microsoft Access.

  4. Bevor Sie die mit der gesicherten Datenbank verwendete Arbeitsgruppen-Informationsdatei (normalerweise SYSTEM.MDW) komprimieren, schließen Sie sich vorübergehend einer anderen Arbeitsgruppen-Informationsdatei an.

    Wie wird's gemacht?

  5. Starten Sie Microsoft Access, ohne eine Datenbank zu öffnen.

  6. Komprimieren Sie die mit der gesicherten Datenbank verwendete Arbeitsgruppen-Informationsdatei.

  7. Fordern Sie die Benutzer auf, sich der konvertierten Arbeitsgruppen-Informationsdatei anzuschließen, bevor sie die gesicherte Datenbank öffnen.


 Konvertieren einer Arbeitsgruppen-Informationsdatei aus einer früheren Version von Microsoft Access

Konvertieren einer Arbeitsgruppen-Informationsdatei aus einer früheren Version von Microsoft Access

Um die Verbesserungen im Bereich der Datensicherheit und Leistung nutzen zu können, sollten Sie die Arbeitsgruppen-Informationsdatei nach der folgenden Beschreibung erneut erstellen.

  1. Erstellen Sie eine neue Arbeitsgruppen-Informationsdatei. Achten Sie dabei darauf, in exakter Groß-/Kleinschreibung den Benutzernamen, Firmennamen und Arbeitsgruppencode einzugeben, der zum Erstellen der Originaldatei verwendet wurde. Wenn Sie die zum Erstellen der Originaldatei verwendeten Einträge nicht exakt wieder eingeben, wird eine ungültige Gruppe Administratoren erstellt.

    Wie wird's gemacht?

  2. Erstellen Sie alle Gruppenkonten erneut. Achten Sie dabei darauf, den Gruppennamen und die persönliche Identifikationskennung (PID) für jede Gruppe in exakter Groß-/Kleinschreibung einzugeben.

    Wie wird's gemacht?

  3. Erstellen Sie jedes Benutzerkonto erneut. Achten Sie dabei darauf, den Benutzernamen und die persönliche Identifikationskennung für jeden Benutzer in exakter Groß-/Kleinschreibung einzugeben.

    Wie wird's gemacht?

  4. Fordern Sie die anderen Microsoft Access 2000-Benutzer in der Arbeitsgruppe auf, sich der neuen Arbeitsgruppen-Informationsdatei unter Verwendung des Arbeitsgruppen-Administrators anzuschließen.


 Gemeinsame Nutzung einer gesicherten Datenbank aus einer früheren Version in mehreren Versionen von Microsoft Access

Gemeinsame Nutzung einer gesicherten Datenbank aus einer früheren Version in mehreren Versionen von Microsoft Access

Mit einer Ausnahme sind bei der gemeinsamen Nutzung einer gesicherten Datenbank in mehreren Versionen von Microsoft Access dieselben Punkte zu beachten wie bei der gemeinsamen Nutzung einer nichtgesicherten Datenbank in mehreren Versionen. Um Informationen zu allgemeinen Punkten bei der gemeinsamen Nutzung einer Datenbank in mehreren Versionen von Microsoft Access anzuzeigen, klicken Sie auf [image] .

Die einzige Ausnahme betrifft die Bearbeitung der Arbeitsgruppen-Informationsdateien, die mit der gesicherten Datenbank verwendet werden. Hierbei haben Sie zwei Auswahlmöglichkeiten:

  • Fordern Sie die auf Microsoft Access 2000 aktualisierenden Benutzer auf, sich in die Arbeitsgruppen-Informationsdatei mit der ältesten Microsoft Access-Version einzutragen, die die gesicherte Datenbank nutzt. In Microsoft Access 2000 ist es zwar möglich, mit früheren Versionen erstellte Arbeitsgruppen-Informationsdateien zu verwenden, in früheren Versionen lassen sich jedoch nur Arbeitsgruppen-Informationsdateien verwenden, die mit Microsoft Access 2000 oder einer früheren Version erstellt wurden. Um Informationen zum Eintragen in eine Arbeitsgruppen-Informationsdatei anzuzeigen, klicken Sie auf [image] .

    Wichtig Wenn Benutzer eine gesicherte Datenbank aus Microsoft Access 95 oder 97 gemeinsam nutzen werden, sollten Sie zuvor die aktuelle Arbeitsgruppen-Informationsdatei mit Microsoft Access 2000 komprimieren. Durch das Komprimieren der Datei mit Microsoft Access 2000 wird das Dateiformat nicht geändert, so dass die Datei weiterhin von allen Microsoft Access 95 oder 97-Benutzern verwendet werden kann, die nicht aktualisieren. Um Informationen zum Komprimieren einer Datenbank anzuzeigen, klicken Sie auf [image] .

  • Wenn die gemeinsam genutzte Datenbank in Microsoft Access, Version 2.0, erstellt wurde, konvertieren Sie die mit der gesicherten Datenbank zu verwendende Arbeitsgruppen-Informationsdatei. Fordern Sie ausschließlich Benutzer, die auf Microsoft Access 2000 aktualisieren, auf, sich in der konvertierten Arbeitsgruppen-Informationsdatei einzutragen. Alle Benutzer, die nicht von Version 2.0 aktualisieren, müssen weiterhin die mit dieser Version erstellte Arbeitsgruppen-Informationsdatei verwenden. Um Informationen zum Konvertieren einer Arbeitsgruppen-Informationsdatei anzuzeigen, klicken Sie auf [image] .


 Datenreplikation in einem Microsoft Access-Projekt

Datenreplikation in einem Microsoft Access-Projekt

Ein Microsoft Access-Projekt beinhaltet mehrere Assistenten, die Ihnen bei der Erstellung einer Veröffentlichung und eines Abonnements behilflich sind. Access-Projekte unterstützen Push-, Pull- und bidirektionale Arten der Synchronisation.

Innerhalb eines Projekts replizieren Sie nur die Daten und nicht die Formulare, Berichte oder anderen Objekte, die in dem Projekt enthalten sind. Außerdem darf ein Projekt kein Replikat einer Access-Datenbank enthalten.

Weitere Informationen über das Replizieren von Daten in Verbindung mit einem Access-Projekt finden Sie in der Dokumentation zu Microsoft SQL Server.

Weitere Informationen

Synchronisieren der Daten einer Replikatgruppe


 Erstellen von Teilreplikaten

Erstellen von Teilreplikaten

Was sind Teilreplikate?

Teilreplikate sind Replikate, die nur eine Teilmenge der Datensätze eines vollständigen Replikats enthalten. Um ein Teilreplikat zu erstellen, definieren Sie einen Filter, der die zu synchronisierenden Daten auf eine Teilmenge der vollständigen Datenbank einschränkt. Durch Verwendung von Teilreplikaten können Sie ein Replikat mit genau den Daten synchronisieren, die Sie benötigen, und brauchen sie nicht mit der gesamten Datenbank zu synchronisieren.

Beispielsweise kann eine Firma ihre gesamte Verkaufsdatenbank in der Zentrale speichern, aber zu den Regionalbüros nur die regionalen Daten replizieren. Sie können dann für jedes Regionalbüro ein separates Replikat erstellen, das nur die Daten für die betreffende Region enthält. Die Datenbank in der Zentrale stellt ein vollständiges Replikat dar, mit dem die verschiedenen Teilreplikate synchronisiert werden.

Vorteile der Verwendung von Teilreplikaten

Teilreplikate können zu kleineren Datenbanken führen, da nur die Teile repliziert werden müssen, mit denen Sie häufig arbeiten. Das Synchronisieren eines Teilreplikats benötigt weniger Zeit, und das Replikat selbst benötigt weniger Speicherplatz.

Teilreplikate können verwendet werden, um den Zugriff auf Daten einzuschränken. Im Beispiel der Verkaufsdatenbank können Teilreplikate dazu beitragen, dass die Angestellten in einem Regionalbüro die für andere Regionalbüros bestimmten Daten nicht anzeigen können. Obwohl Teilreplikate verwendet werden können, um den Zugriff auf Datensätze einzuschränken, stellen sie jedoch keinen Ersatz für ein Sicherheitssystem dar.

Teilreplikate bieten darüber hinaus Vorteile beim Replizieren von Daten über LANs (Local Area Networks = lokale Netzwerke) und WANs (Wide Area Networks). Durch das Einschränken der Replikation auf bestimmte Daten können Teilreplikate die über ein LAN oder WAN übertragene Datenmenge herabsetzen. Dies reduziert die Anzahl der Datenübertragungen im Netzwerk und damit die Übertragungskosten.

Erstellen eines Teilreplikats mit Active X Data-Objekten (ADO)

Um ein Teilreplikat zu erstellen, gehen Sie wie folgt vor:

  1. Verwenden Sie die CreateReplica-Methode bei einem Replica-Objekt, wobei Sie im Argument Replikattyp die Konstante jrRepTypePartial angeben. Dadurch wird das Teilreplikat erstellt.

  2. Verwenden Sie die Filters-Eigenschaft, um die Filter und Beziehungen einzustellen, mit denen festgelegt wird, welche Daten aus dem vollständigen Replikat repliziert werden sollen.

  3. Verwenden Sie die PopulatePartial-Methode, um alle Datensätze aus dem vollständigen Replikat zu übertragen, die den neuen Replikationsfilterkriterien entsprechen.

Wenn Sie Daten oder Filterkriterien im Teilreplikat ändern, verwenden Sie in jedem Fall die Synchronize- und die PopulatePartial-Methode zusammen, um sicherzustellen, dass alle Daten an das vollständige Replikat weitergegeben werden und dass das Teilreplikat auf der Basis der aktuellen Filterkriterien neu belegt wird.

Anmerkung Ein einmal erstelltes Teilreplikat können Sie nicht in ein vollständiges Replikat umwandeln. Wenn Sie alle Replikatfilter und Replikatbeziehungen im Teilreplikat löschen, enthält es alle Datensätze eines vollständigen Replikats, unterliegt jedoch nach wie vor den Einschränkungen eines Teilreplikats.

Erstellen eines Teilreplikats mit Datenzugriffsobjekten (DAO)

Um ein Teilreplikat zu erstellen, gehen Sie wie folgt vor:

  1. Verwenden Sie die MakeReplica-Methode bei einem Database-Objekt, wobei Sie im Argument Optionen die Konstante dbRepMakePartial angeben. Dadurch wird das Teilreplikat erstellt.

  2. Verwenden Sie die ReplicaFilter- und die PartialReplica-Eigenschaft, um die Filter und Beziehungen einzustellen, mit denen festgelegt wird, welche Daten aus dem vollständigen Replikat repliziert werden sollen.

  3. Verwenden Sie die PopulatePartial-Methode, um alle Datensätze aus dem vollständigen Replikat zu übertragen, die den neuen Replikationsfilterkriterien entsprechen.

Wenn Sie Daten oder Filterkriterien im Teilreplikat ändern, verwenden Sie in jedem Fall die Synchronize- und die PopulatePartial-Methode zusammen, um sicherzustellen, dass alle Daten an das vollständige Replikat weitergegeben werden und dass das Teilreplikat auf der Basis der aktuellen Filterkriterien neu belegt wird.

Anmerkung Ein einmal erstelltes Teilreplikat können Sie nicht in ein vollständiges Replikat umwandeln. Wenn Sie alle Replikatfilter und Replikatbeziehungen im Teilreplikat löschen, enthält es alle Datensätze eines vollständigen Replikats, unterliegt jedoch nach wie vor den Einschränkungen eines Teilreplikats.

Teilreplikat und referenzielle Integrität

In einem Replikat, dessen Beziehungen referenzielle Integrität erfordern, können viele Tabellen in der Datenbank mit der Tabelle in Beziehung stehen, auf der Ihr Filter basiert. Wenn Sie ein Teilreplikat erstellen, seien Sie sicher, dass alle Tabellen eingeschlossen werden, die zur Tabelle mit den gewünschten Daten in Beziehung stehen.

Wenn Sie z.B. die Beispieldatenbank Nordwind verwenden, können Sie einen Filter für die Tabelle Personal einführen, wie z.B. [Personal-Nr]=1, der die Datensätze genau eines Angestellten synchronisiert. Da die Tabelle Personal mit den Tabellen Bestellungen und Bestelldetails in Beziehung steht, schließen Sie diese Tabellen ebenfalls ein, so dass das Teilreplikat die entsprechenden Datensätze für diesen Angestellten in den Tabellen Bestellungen und Bestelldetails einschließt.

Es kann vorkommen, dass andere Tabellen eingeschlossen werden müssen, die mit dem Filter nur indirekt in Beziehung stehen. Dies ist z.B. dann der Fall, wenn das Teilreplikat eine vollständige Artikelliste enthalten soll, so dass in neuen Bestellungen alle verfügbaren Artikel aufgenommen werden können. In diesem Fall schließen Sie die Tabelle Artikel in das Teilreplikat ein.

Achten Sie außerdem auf Tabellen in Ihrer Datenbank, die keine Durchsetzungsbeziehungen haben, wie z.B. Nachschlagetabellen oder Tabellen mit Beziehungen ohne referenzielle Integrität. Beispielsweise kann eine Tabelle, die ein Kombinationsfeld enthält, in keiner Beziehung vorkommen. Wenn Sie eine solche Tabelle einschließen, werden alle Datensätze aufgegriffen; andernfalls wird kein Datensatz aufgegriffen.

Weitere Informationen zu Teilreplikaten und Tools zur Erstellung von Teilreplikaten finden Sie in Kapitel 16, "Datenbankanwendungen für viele Benutzer", im Microsoft Office 2000/Visual Basic- Programmierhandbuch. Um Informationen anzuzeigen, wie Sie das Microsoft Office 2000/Visual Basic- Programmierhandbuch bekommen können, klicken Sie auf [image] .


Internationale Features in Microsoft Access

Die Features und die Architektur von Microsoft Access 2000 bieten eine hohe Flexibilität für Benutzer/innen auf der ganzen Welt. Diese Features ermöglichen Benutzern und Benutzerinnen, die mit dem Programmieren nicht vertraut sind, eine funktionsfähige Datenbankanwendung zu erstellen, indem sie deren Objekte mit Hilfe der Eigenschaften in den Eigenschaftenfenstern der deutschen Access-Benutzeroberfläche entwerfen. In Kombination mit Visual Basic für Applikationen (eine dem Englischen ähnliche Programmiersprache) ermöglichen es die Features den Entwicklern, äußerst komplexe Anwendungen zu erstellen, die mit anderen Microsoft Office-Anwendungen zusammenarbeiten sowie über nationale Grenzen hinweg und in Microsoft Access-Versionen einer anderen Sprache übertragen werden können.

  • Sie können Tabellen, Abfragen, Formulare, Berichte und Makros mit Hilfe eines Eigenschaftenfensters entwerfen, das die Eigenschaften in Deutsch anzeigt. Wenn Sie diese Eigenschaften jedoch im Code angeben möchten, müssen Sie die englischen Namen der Eigenschaften im Modulfenster eines Formulars, Berichts oder im Standardmodulfenster verwenden.

    Anmerkung In den Microsoft Access-Themen zu Sprachelementen sind die deutschen Eigenschaftennamen in der Überschrift des jeweiligen Themas angegeben.

  • Wenn Sie im Eigenschaftenfenster einen Ausdruck zum Festlegen einer Eigenschaft angeben, können Sie für viele eingebaute Microsoft Access-Funktionen den deutschen Namen verwenden. Im Modulfenster eines Formulars, eines Berichts oder im Standardmodulfenster müssen Sie jedoch den englischen Funktionsnamen angeben.

    Sie können außerdem für viele Eigenschaften, die Sie in einem Aktionsargument eines Makros im Makrofenster verwenden, den deutschen Namen angeben.

    Anmerkung In den Microsoft Access-Themen zu Sprachelementen sind die deutschen Funktions- und Eigenschaftennamen in der Überschrift des jeweiligen Themas angegeben.

    Wenn Sie Änderungen am Entwurf einer Datenbankanwendung, die in einer Microsoft Access-Version einer anderen Sprache entwickelt wurde, vornehmen möchten, werden alle Ausdrücke automatisch mit den entsprechenden Funktions- und Eigenschaftennamen der aktuellen Microsoft Access-Sprachversion angezeigt. Dies gilt jedoch nicht für Namen von Eigenschaften, Objekten und Auflistungen in Abfrageausdrücken. Im Abfrageentwurfsbereich sollten Sie für Eigenschaften, Objekte und Auflistungen den englischen Namen verwenden, um Ihre Datenbank übertragbar zu machen.

    In der Microsoft Access-Benutzeroberfläche können Sie deutsche Schlüsselwörter in Ausdrücken folgender Ansichten angeben:

    • Tabellenentwurf (in den Eigenschaften Format, Standardwert (DefaultValue) und Gültigkeitsregel (ValidationRule))

    • Abfrageentwurf (in der Zeile Kriterien sowie für einige Eigenschaften im Eigenschaftenfenster)

      Tipp In der SQL-Ansicht müssen Ausdrücke in Englisch eingegeben werden, und die SQL-Anweisung für eine Abfrage, die im Abfrageentwurfsbereich entworfen wurde, wird hier auch in Englisch angezeigt. Wenn Sie im Modulfenster eine SQL-Anweisung in Ihren Code einfügen möchten, können Sie Ihre Abfrage im Abfrageentwurfsbereich entwerfen, dann zur SQL-Ansicht wechseln, die SQL-Syntax kopieren und im Modulfenster einfügen.

    • Formular- und Berichtsentwurf

    • Makroentwurf (in der Spalte Bedingung und in Makroargumenten der Aktionen SetzenWert, Meldung und anderer Aktionen)
  • Visual Basic für Applikationen (VBA) ist die gemeinsame Programmiersprache aller Microsoft Office-Anwendungen. Im Modulfenster der einzelnen Microsoft Office-Anwendungen müssen Sie das englische VBA-Schlüsselwort verwenden. In Microsoft Access können Sie jedoch für die meisten VBA-Funktionen auch den deutschen Namen in Ausdrücken von Abfragen, Formularen, Berichten und Makros verwenden. Klicken Sie auf [image] , um eine Liste dieser Funktionen anzuzeigen.

  • In Microsoft Access können Sie den deutschen Namen der SQL-Aggregatfunktionen im Abfrageentwurfsbereich einsetzen. Verwenden Sie den englischen Namen in Aggregatausdrücken der Eigenschaft SQL eines QueryDef-Objekts, oder wenn Sie ein Recordset-Objekt basierend auf einer SQL-Abfrage erstellen. Klicken Sie auf [image] , um eine Liste dieser Funktionen anzuzeigen.

  • Das in einem Ausdruck zu verwendende Listentrennzeichen ist im Dialogfeld Ländereinstellungen der Windows-Systemsteuerung definiert. Meistens ist dies ein Semikolon (;). Im Modulfenster müssen Sie jedoch als Listentrennzeichen immer ein Komma (,) angeben.

  • Die Eigenschafteneinstellungen in Datenzugriffsseiten erfordern einen Punkt (.) in numerischen Argumenten. Falls Ihre Ländereinstellungen in der Windows-Systemsteuerung ein Komma als Dezimaltrennzeichen festlegen, und Sie ein Komma im Eigenschaftenfenster einer Datenzugriffsseite eingeben, wird die Fehlermeldung "Ungültiges Argument" angezeigt.

  • Im Modulfenster müssen Sie das Datumsformat und das Dezimaltrennzeichen im US-Format angeben. Die Ausgabe wird jedoch in dem Format angezeigt, das Sie im Dialogfeld Ländereinstellungen der Windows-Systemsteuerung festgelegt haben, wie z. B. das Komma im folgenden Beispiel:
    Eval("3.2 + 4")= 7,2

    Eine Ausnahme bildet die Funktion Str:

    Str(3.12) = 3.12

  • Wenn Sie eine Symbolleiste ein- oder ausblenden, sollten Sie den englischen Namen der Symbolleiste zusammen mit dem CommandBar-Objekt verwenden, um zu gewährleisten, dass Ihr Code übertragbar ist. Unter Verwendung der Eigenschaft NameLocal des CommandBar-Objekts können Sie die Liste der englischen Namen aller eingebauten Symbolleisten anzeigen. Wenn Sie die Methode ShowToolbar des DoCmd-Objekts einsetzen, sollten Sie immer den englischen Namen der Symbolleiste angeben.


 Festlegen der generellen Tastatursprache für Text- oder Kombinationsfelder

Festlegen der generellen Tastatursprache für Text- oder Kombinationsfelder

Sprachspezifische Informationen

You can select the type of keyboard language you want in a text box or combo box.

  1. Open a form or report in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, in the KeyboardLanguage box, do one of the following:

    To make the keyboard language follow the most recent keyboard language you used, click System.

    To make the keyboard language a particular language, click one of the languages shown in the list.

Notes

  • The languages that appear in the KeyboardLanguage property box are determined by the keyboard languages you have installed by double-clicking Keyboard in Windows Control Panel.

  • Learn about right-to-left properties.


Verwenden des Euro

Was möchten Sie tun?

Unterstützung für den Euro in Microsoft Windows 95 und Windows NT 4.0

Arbeiten mit dem Euro-Symbol( [image])

Anzeigen des Euro-Symbols in einem Feld auf einer Datenzugriffsseite

Verwenden der Format-Eigenschaft

Verwenden der EuroConvert-Funktion


 Informationen zu "Korrekte Tastatureinstellungen"

Informationen zu "Korrekte Tastatureinstellungen"

Sprachspezifische Informationen

Korrekte Tastatureinstellungen ist eine Funktion, mit der im Modus Englisch eingegebene Wörter automatisch korrigiert werden, die im Modus hangul hätten eingegeben werden sollen, und umgekehrt. Wenn Sie z. B. eogksalsrnr im Modus Englisch eingeben, wird dies in tae han min kuk geändert. Wenn Sie yo u ya p d gya nya syo im Modus hangul eingeben, wird dies in university geändert. Ferner wird der Modus IME automatisch geändert.

Korrekte Tastatureinstellungen korrigiert auch automatisch englische Wörter, die eine im Modus Englisch eingegebene Hangul-Endung aufweisen. Wenn Sie z. B. optiondmf im Modus Englisch eingeben, wird dies automatisch in option ul geändert.

Korrekte Tastatureinstellungen wird sogar ausgeführt, wenn Hangul und Englisch kombiniert werden. Wenn Sie beispielsweise rntjddnjs ppyo mi ya syo eingeben, wird dies automatisch geändert in ku song won quality.


 Einstellen der Kodierung für eine Webseite

Einstellen der Kodierung für eine Webseite

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht erstellen, können Sie die Kodierung angeben, die ein Webbrowser für die Anzeige der Seite verwenden soll.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Allgemein und anschließend auf Weboptionen.

  4. Klicken Sie im Dialogfeld Weboptionen auf die Registerkarte Kodierung.

  5. Klicken Sie in der Liste Dieses Dokument speichern als auf die gewünschte Sprache.

Anmerkung Damit Access Seiten stets mit der Standardsprachkodierung speichert, aktivieren Sie das Kontrollkästchen Die Webseiten immer in der Standardcodierung speichern. Diese Einstellung gilt für die aktuelle und alle zukünfigen Seiten, die Sie speichern. Sie ist sinnvoll, wenn Sie Seiten aus anderen Quellen verwenden und alle Seiten mit derselben Kodierung speichern wollen.


Aktivieren von korrekten Tastatureinstellungen

Sprachspezifische Informationen

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Aktivieren Sie auf der Registerkarte AutoKorrektur das Kontrollkästchen Korrekte Tastatureinstellungen.


 Bidirektionale Schriftarten

Bidirektionale Schriftarten

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Any version of Access 2000 with left-to-right support is designed to display and print both right-to-left and left-to-right text. To do this, the program should use a font that contains both right-to-left and left-to-right language characters. Most fonts available with bidirectional Windows operating systems contain both right-to-left and left-to-right characters. If you choose a font that does not contain both right-to-left and left-to-right characters, existing text in one or both languages might be displayed incorrectly by using the default secondary font, Tahoma. To correct this problem, choose a different font.

More information

Set defaults for the appearance of Datasheet view

Change font, or font style, size, and color in Datasheet view

Change the font of text in a text box or other control


 Info über die bidirektionalen Eigenschaften der Benutzeroberfläche

Info über die bidirektionalen Eigenschaften der Benutzeroberfläche

Sprachspezifische Informationen

The options that appear in dialog boxes and other elements of the Microsoft Access 2000 user interface do not have properties that can be set. Although you cannot change their property settings, they do have bidirectional characteristics. Access 2000 assigns the following values:

Property | Value
KeyboardLanguage | System
TextAlign | General
ReadingOrder | Context
ScrollBarAlign | System
NumeralShapes | System

If the option contains no text, reading order is determined by the keyboard language when the control is entered: Right-to-left if the keyboard language is a right-to-left language, and left-to-right if otherwise. Initial alignment and insertion point position are determined by the General alignment setting.

Note CTRL+LEFT SHIFT and CTRL+RIGHT SHIFT keyboard sequences used to change keyboard language, reading order, and alignment in other bidirectional applications will temporarily change reading order and alignment.


 Rechtschreibprüfung für bidirektionalen Text

Rechtschreibprüfung für bidirektionalen Text

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

You can check the spelling of both your English and right-to-left text in the Memo, Text, and Hyperlink fields. Just choose a dictionary that corresponds to the text that will be used.

Note You must be using a right-to-left version of Microsoft Office 2000 to be able to check spelling in right-to-left text.

When right-to-left text is checked, English words are ignored and not flagged as misspelled. However, when English text is checked, right-to-left words aren't ignored.

What do you want to do?

Check the spelling of data

Choose a custom dictionary for checking spelling


 Kompatibilität mit Rechts-nach-links-Funktionalität

Kompatibilität mit Rechts-nach-links-Funktionalität

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Access 2000 provides full forward compatibility for database files saved in all previous versions of Microsoft Access and Microsoft Access with right-to-left support; however, databases saved in Access 2000 file format are not compatible with any previous versions of Microsoft Access.


 Info über die Eigenschaften mit Bezug auf die Rechts-nach-links-Funktionalität

Info über die Eigenschaften mit Bezug auf die Rechts-nach-links-Funktionalität

Sprachspezifische Informationen

Microsoft Access 2000 has specific right-to-left properties to support bidirectional data entry and display.

This topic provides reference information about the following properties:

  • ReadingOrder

  • KeyboardLanguage

  • TextAlign

  • ScrollBarAlign

  • NumeralShapes (Arabic only)

The settings for these properties are initially determined when the control is placed on the grid in form Design view or report Design view.

Note The settings associated with these properties are available for forms and reports. Control behavior for tables and queries is a fixed, bidirectional-capable configuration: ScrollBarAlign = System, NumeralShapes = System, KeyboardLanguage = System, TextAlign = General, ReadingOrder = Context, and initial insertion point position = data dependent. If the control contains no text, then alignment, reading order, and initial insertion point position are determined by the keyboard language when the control is entered: Right-to-Left if the keyboard language is a right-to-left language, and Left-to-Right if otherwise.

ReadingOrder property

Determines the reading order of the control. You can specify right-to-left or left-to-right reading order or choose to have the reading order determined by the keyboard language of text first entered. See how to set the ReadingOrder property for a control.

Return to top

KeyboardLanguage property

The KeyboardLanguage property overrides the keyboard language that is currently in use (including changing the active keyboard language icon on the taskbar). This property specifies the initial keyboard language when the control receives focus. This feature is useful for volume data entry programs because it reduces the need to make keyboard language changes when moving from one field to the next. You can subsequently choose a new keyboard language.

In Form view or Datasheet view, Microsoft Access 2000 will activate the designated keyboard language. If the operation fails (most likely because the requested keyboard language is not available on the developer/user system), the active keyboard language is not changed. For more sophisticated error handling, refer to the discussion of the Visual Basic for Applications KeyboardLanguage property. See how to set the KeyboardLanguage property for a control.

Return to top

TextAlign property

This property determines the placement of text within a control. In addition to the standard left, right, and center character alignments, right-to-left features in Access 2000 use the General alignment setting to specify how text is aligned. See how to set the TextAlign property for a control.

Return to top

ScrollBarAlign property

This property allows you to place the control's vertical scroll bars and buttons in the applicable right-to-left or left-to-right direction. The System setting orients the vertical scroll bar according to the user-interface language in effect. If the user-interface language is a right-to-left language, the vertical scroll bar will be on the left; if the user interface language is a left-to-right language, the vertical scroll bar will be on the right. See how to set the ScrollBarAlign property for a control.

Return to top

NumeralShapes property (Arabic only)

Two different representations of digit shapes are used in Middle Eastern countries: Arabic and Hindi. You can choose to have text in controls be specifically Arabic or Hindi, you can let the Microsoft Windows operating system determine the numerals, or you choose the numeral shape depending on the context of adjacent text. See how to set the NumeralShapes property for a control.

Return to top


 Info über die Rangfolge beim Festlegen der Rechts-nach-links-Schreibfunktionen

Info über die Rangfolge beim Festlegen der Rechts-nach-links-Schreibfunktionen

Sprachspezifische Informationen

The appearance of an object and the behavior of its right-to-left features are determined by a hierarchy of settings. The following progression illustrates this point:

  • The Default Direction setting on the Right-to-Left tab in the Options dialog box sets the direction for new forms or reports to right-to-left (unless the default was manually changed to left-to-right).

  • In the property sheet for a form or report, you can change the direction for a specific form or report by setting the Orientation property. This change will determine the default value of related left-to-right and right-to-left direction properties for each new control on that form or report.

  • Each control has a default set of right-to-left properties that can be changed for that individual control.

  • After controls are placed on the design grid, you can move them and change their right-to-left properties to change their appearance and behavior.


 Ändern der Standardeinstellungen für Rechts-nach-Links-Schreibfunktionen

Ändern der Standardeinstellungen für Rechts-nach-Links-Schreibfunktionen

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

You can set the default behavior for several right-to-left features.

What do you want to do?

Set the direction for new tables, queries, forms, reports, and pages

Set insertion point behavior

Specify alignment behavior for General alignment

Switch between Gregorian and Hijri calendars for the current database


 Festlegen des allgemeinen Ausrichtungsverhaltens

Festlegen des allgemeinen Ausrichtungsverhaltens

Sprachspezifische Informationen

  1. Click Options on the Tools menu, and then click the Right-to-Left tab.

  2. Do one of the following in the General Alignment option group:

    Click Interface Mode to align text and numbers in text fields according to the user interface language in effect.

    Click Text Mode to align text and numbers in text fields according to the keyboard language of the text first entered.


 Erstellen von Makros in Anwendungen mit Rechts-nach-links-Textfluss

Erstellen von Makros in Anwendungen mit Rechts-nach-links-Textfluss

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

You can create custom menus bars in a right-to-left or left-to-right direction. The following are some considerations to keep in mind:

  • The TransferText action allows you to choose code page format when importing, exporting, and linking files.

  • Menu bars you create can be displayed with a left-to-right or right-to-left direction. For example, if oriented right-to-left, the menu bar will display with menu items starting on the right side of the menu bar and continuing to the left in a right-to-left reading order.

  • The display direction of global and form menu bars is determined by the user-interface language.

  • You can name menu items in right-to-left, left-to-right, or bidirectional text. An ampersand (&) can be added to a menu item name to designate a menu item access key. The ampersand applies to the next character in the name and causes the character to be underlined when the menu item is displayed. In right-to-left text, this is the character to the left of the ampersand; in left-to-right text, it's the character to the right of the ampersand.

  • Macro names can be in right-to-left, left-to-right, or bidirectional text.

  • The Macro window has a left-to-right layout regardless of the user-interface language.


 Erstellen von Modulen in Anwendungen mit Rechts-nach-links-Textfluss

Erstellen von Modulen in Anwendungen mit Rechts-nach-links-Textfluss

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Access 2000 supports these right-to-left characteristics in modules:

  • Statements are displayed left-aligned and in left-to-right reading order. However, you can view and edit Visual Basic for Applications statements containing right-to-left or bidirectional text.

  • You can use right-to-left, left-to-right, or bidirectional text in module names.

Visual Basic for Applications

All Visual Basic for Applications procedures and properties that provide right-to-left functionality to Microsoft Access 2000 are listed alphabetically in the following table.

Procedures and properties | Type
Calendar | Property
DataType | Property
Date, Date$ | Function
DateAdd | Function
DateDiff | Function
DatePart | Function
DateSerial | Function
DateValue | Function
Day | Function
Format, Format$ | Function
Format | Property
GetOption, SetOption | Methods
KeyboardLanguage | Property
LabelAlign, TextAlign | Properties
LabelX, LabelY | Properties
Month | Function
NumeralShapes | Property
Orientation | Property
ReadingOrder | Property
ScrollBarAlign | Property
TransferText | Action/Method
Weekday | Function
Year | Function

For development of sophisticated right-to-left applications, you might want to take advantage of the numerous Microsoft Windows operating system application programming interfaces (APIs) that have right-to-left settings. For more information, see your local Microsoft dealer.


 Festlegen der Schreibrichtung für neue Tabellen, Abfragen, Formulare, Berichte und Datenzugriffsseiten

Festlegen der Schreibrichtung für neue Tabellen, Abfragen, Formulare, Berichte und Datenzugriffsseiten

Sprachspezifische Informationen

  1. Click Options on the Tools menu, and then click the Right-to-Left tab.

  2. Do one of the following in the Default Direction option group:

    Click Left-To-Right to have new objects displayed in a direction familiar to left-to-right users.

    Click Right-To-Left to have new objects displayed in a direction familiar to right-to-left users.


 Ändern der Schreibrichtung für Tabellen

Ändern der Schreibrichtung für Tabellen

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

What do you want to do?

Learn about right-to-left behavior in tables

Change individual table direction

Change the default direction for new tables


 Ändern der Schreibrichtung bei einzelnen Tabellen

Ändern der Schreibrichtung bei einzelnen Tabellen

Sprachspezifische Informationen

  1. Open a table in Design view.

  2. Click the Properties button [image] on the toolbar.

  3. Click the Orientation property.

  4. Do one of the following:

    For a right-to-left direction, click Right-to-Left.

    For a left-to-right direction, click Left-to-Right.

Note Table direction is configurable only for tables in a Microsoft Access database (.mdb). Table direction in a Microsoft Access project (.adp) is always left to right.


 Info über die Rechts-nach-links-Funktionalität in Tabellen

Info über die Rechts-nach-links-Funktionalität in Tabellen

Sprachspezifische Informationen

Right-to-left characteristics for tables are summarized as follows:

New table direction The direction for new tables is determined by the Default direction setting on the Right-to-Left tab in the Options dialog box (Tools menu).

Note Table direction is configurable only for tables in a Microsoft Access database (.mdb). Table direction in a Microsoft Access project (.adp) is always left-to-right.

Existing table direction The direction of an existing tables can be "flipped" from right to left, or the reverse, by changing the table's Orientation property.

User interface direction The direction and layout of several features that support tables, such as the Design view window, the Index window, frozen columns, and key visual characteristics such as Field Properties descriptions and tabs, the current record indicator, and grid column order are determined by the user interface you are currently using.

Field properties Text and Memo fields are assigned General alignment and Context reading order. Visual layout is automatically adjusted based on the language of the first character entered in a field when General alignment is set to Text mode in the Right-to-Left tab in the Options dialog box (Tools menu). Alignment can be then overridden by creating a custom format by using the format control character, the exclamation point (!), in the Format property. Reading order, however, cannot be changed.

Note You can create tables with more sophisticated right-to-left field properties and data entry features if you create a form that uses your table as a record source, and then view the form in Datasheet view.


 Importieren, Exportieren und Verknüpfen von im Textformat gespeicherten Tabellen mit Rechts-nach-links-Textfluss

Importieren, Exportieren und Verknüpfen von im Textformat gespeicherten Tabellen mit Rechts-nach-links-Textfluss

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Microsoft Access 2000 provides code page conversion of tables and worksheets with right-to-left characteristics for text files stored in logical text layout, with one of the following right-to-left code pages:

Language | Code page
Arabic | UTF-8 (default)
 | ISO 8859-6
 | DOS-720
 | ASMO-708
Hebrew | UTF-8 (default)
 | ISO 8859-8
 | DOS-862

To import, export, or link text files that are not recognized by Microsoft Access 2000, use ConvText, a stand-alone text-file conversion utility that provides both logical and visual text layout options and an expanded list of supported bidirectional code pages.

Note A table/worksheet in Lotus, dBASE, Microsoft FoxPro, Paradox, or ODBC database format that requires code page and/or text layout conversion can still be imported into Access 2000 by saving the table/worksheet in text file format prior to importing it. The ability to save a table/worksheet in text file format is a standard feature of most database/spreadsheet products. When Access 2000 imports the text file, all field names and records from the original table/worksheet will be fully recreated in a new Access table.

What do you want to do?

Convert bidirectional text files to ANSI

Convert bidirectional text files from ANSI


 Ändern der Schreibrichtung für Abfragen

Ändern der Schreibrichtung für Abfragen

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

What do you want to do?

Learn about right-to-left behavior in queries

Change individual query direction

Change the default direction for new queries


 Info über die Rechts-nach-links-Funktionalität in Abfragen

Info über die Rechts-nach-links-Funktionalität in Abfragen

Sprachspezifische Informationen

Right-to-left characteristics for queries are summarized as follows:

  • Query Design view displays the query in a layout consistent with the current user interface language.

  • The Orientation property allows you to change the overall right-to-left or left-to-right direction of the query in Datasheet view, regardless of the Default direction setting on the Right-to-Left tab in the Options dialog box (Tools menu).

Note Direction in queries is configurable only for queries in a Microsoft Access database (.mdb). Direction in queries in a Microsoft Access project (.adp) is always left-to-right.

Query Design view

All Text and Memo fields are assigned General alignment and Context reading order. Visual layout adjusts automatically based on the language of the first character entered in a field. Alignment can be overridden by creating a custom format by using the format control character, the exclamation point (!) in the Format property in the query's property sheet. Reading order, however, is fixed.

Microsoft Access 2000 provides right-to-left support to many of the other query features available in Design view. For example, if you choose to design a crosstab query, you have the same ability to use the query's property sheet to change the view direction of the crosstab query you're creating.

Query Datasheet view

The direction of the data, description fields, and other window components will be right-to-left or left-to-right depending on the query orientation you chose in Design view.

Other query design considerations

You can use right-to-left or mixed right-to-left and left-to-right text to name many of the objects you create. You can:

  • Provide bidirectional text in names given to tables you create with a make-table query.

  • Select tables with right-to-left or bidirectional text names when you add data to a table by using an append query.

  • Name query parameters with right-to-left or bidirectional text in a parameter query.

SQL

The editor displays SQL statements in an overall left-to-right direction regardless of the user interface language or chosen query view direction.

Important Dates in SQL statements are always displayed as Gregorian calendar values, regardless of database calendar chosen. If you change a date in a SQL statement, the new value MUST be a Gregorian date.


 Verwenden von bidirektionalem Text in Ausdrücken

Verwenden von bidirektionalem Text in Ausdrücken

Sprachspezifische Informationen

Microsoft Access 2000 preserves expressions with left alignment and left-to-right reading order. Expression terms are preserved in left-to-right order to ensure the visual readability of expression statements that contain mixed text. As each statement character is entered, the expression display is dynamically updated.

The following table provides examples of bidirectional text that is used in expressions:

Bidirectional text used in expressions

There are a few other considerations when using expressions with right-to-left languages:

  • Access 2000 displays Structured Query Language (SQL) statements by using the same rules it uses for displaying expressions.

  • Bidirectional control characters entered in expressions are removed prior to evaluating the expression to avoid possible conflicts.

Note Bidirectional text used in the Expression Builder will "swap" certain neutral character pairs such as "( )" and "{ }" when the keyboard language is a right-to-left language. To resolve this, change the keyboard language to a left-to-right language or type the correct character.


 Ändern der Schreibrichtung bei einzelnen Abfragen

Ändern der Schreibrichtung bei einzelnen Abfragen

Sprachspezifische Informationen

  1. Open a query in Design view.

  2. Select a field, field list, or query.

    To select a field, click the cell in the Field row.

    To select a field list, click anywhere in the list.

    To select the whole query, click anywhere in query Design view outside the design grid and the field lists.

  3. Click the Properties button [image] on the toolbar.

  4. In the Orientation property box, do one of the following:

    For a right-to-left direction, click Right-to-Left.

    For a left-to-right direction, click English.

Note Direction in queries is configurable only for queries in a Microsoft Access database (.mdb). Direction in queries in a Microsoft Access project (.adp) is always left-to-right.


 Verwenden der Rechts-nach-Links-Schreibfunktionen in Formularen und Berichten

Verwenden der Rechts-nach-Links-Schreibfunktionen in Formularen und Berichten

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

What do you want to do?

Learn about right-to-left behavior in forms and reports

Learn about right-to-left features hierarchy

Learn how labels are attached to controls

See examples of printing orders

Set right-to-left properties in controls


 Info über die Rechts-nach-links-Funktionalität in Formularen und Berichten

Info über die Rechts-nach-links-Funktionalität in Formularen und Berichten

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Right-to-left characteristics for forms and reports are summarized as follows:

Default direction

The default direction that was set on the Right-To-Left tab in the Options dialog box (Tools menu) determines whether your form has a left-to-right or right-to-left layout. If you have not changed the default, new controls added to the form are displayed with a right-to-left direction.

Ruler and grid

Whether a form or report is in a right-to-left or left-to-right direction, the ruler retains its origin in the upper-left corner of the design window. The same concept applies to the grid. This provision does not cause any problems when creating a right-to-left-oriented form. By dragging the right grid boundary to the right, controls on the grid move to the right in proportion to the distance the boundary is moved and the grid is extended from the left boundary.

Set control defaults

The Set Control Defaults command on the Format menu recognizes all right-to-left properties in Microsoft Access 2000. When you select this command, Access applies all right-to-left properties.

Change To

When you change a control's type (for example, from a text box to a list box) by using the Change To command, Access transfers any relevant right-to-left properties from the original control to the new one.

Snap To Grid and Align To Grid

These Format menu commands behave according to the direction of the current form or report.

Snap To Grid When you place a new control on a left-to-right form or report, the upper-left corner of the control is aligned to the nearest point on the grid. When you place a new control on a right-to-left form or report, the upper-right corner aligns to the nearest point.

Align To Grid In a left-to-right form or report, the upper-left corners of selected controls align to the nearest point in the grid. In a right-to-left form or report, upper-right corners of selected controls align to the nearest grid point.

Form Datasheet view

Datasheet view in forms is the way to present tables with the most sophisticated right-to-left behavior. In addition to displaying the underlying data in the column and row layout generally associated with tables, each field in Datasheet view has the right-to-left properties of the associated Form view control.

For example, if you set the KeyboardLanguage property to Arabic for a text box control bound to a Text field named Company, then the keyboard language will automatically switch to Arabic whenever you click in the Company field in Datasheet view. This feature is useful for volume data-entry applications because it reduces the need to make keyboard language changes when moving from one field to the next.

Form and report Design view

A hierarchy of control governs the orientation, overall appearance, and basic parameters of forms and reports.

Print Preview and Layout Preview in reports

Microsoft Access 2000 displays the report in the direction in which it was designed, left-to-right or right-to-left.


 Beispiele zur Reihenfolge beim Drucken

Beispiele zur Reihenfolge beim Drucken

Sprachspezifische Informationen

You can view and print your data in the direction, right-to-left or left-to-right, that you assigned to the object.

Objects that are longer or wider than can be printed on a single sheet of paper are printed on multiple sheets in an order that is determined by the view direction of the object. The following example shows the page numbering and printing order for a report that is three pages wide and requires six pages to print.

Object direction | Multiple page printing order
Left-to-Right | Left to right printing order
Right-to-Left | Right to left printing order

Note Reports and labels can be printed on a page in a multiple-column format. The layout of the columns will be determined by the direction of the report.

More information

Select printing options


 Verwendung der Rechts-nach-links-Schreibfunktionen in Datenzugriffsseiten

Verwendung der Rechts-nach-links-Schreibfunktionen in Datenzugriffsseiten

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

What do you want to do?

Learn about right-to-left features in data access pages

Set the direction for new tables, queries, forms, reports, and data access pages

Specify the direction of a data access page

Specify the direction of a control on a data access page


 Info über Rechts-nach-links-Schreibfunktionen für Datenzugriffsseiten

Info über Rechts-nach-links-Schreibfunktionen für Datenzugriffsseiten

Sprachspezifische Informationen

Right-to-left features in data access pages are set according to a two-level hierarchy: page level and control level.

Page level

Initially, a new data access page will be displayed in the direction, either left-to-right or right-to-left, that is selected under Default direction on the Right-to-Left tab in the Options dialog box (Tools menu). That direction appears as a setting of the Dir property of the data access page.

Note Data access page direction is included in the underlying HTML code of the data access page through use of the standard HTML Direction (DIR) attribute. For example, the code <HTML DIR=RTL> placed at the beginning of the <HTML> element identifies a right-to-left data access page.

Controls placed on a data access page inherit the directionality of the data access page itself, depending on whether the control has right-to-left features. Controls without right-to-left features are displayed in a left-to-right direction.

Control level

Controls with right-to-left features initially appear on a data access page according to the direction of the data access page. After you place a control on a data access page, you might be able to change the control display direction to give it right-to-left appearance and functionality. The property name that controls display direction varies with control type. The properties in the following table control directionality for data access page controls:

Control type | Description
Office Web Component controls | The Office Web Component controls are the spreadsheet, the chart, and the PivotTable list. The direction setting property is RightToLeft. Note Office Web Component controls each have a property toolbox that can be used both while designing the control and in the browser; however the right-to-left setting can't be changed in the browser.
Intrinsic browser controls | Examples of intrinsic browser controls include Table, Label, TextBox, ComboBox, ListBox, OptionGroup, and ScrollingText. The direction setting property is typically Dir.
ActiveX controls | These are other controls that are available with Microsoft Office 2000 programs or Microsoft Visual Basic. The direction setting property is typically RightToLeft.


 Festlegen der Schreibrichtung auf Datenzugriffsseiten

Festlegen der Schreibrichtung auf Datenzugriffsseiten

Sprachspezifische Informationen

  • Do one of the following:

    Before creating a new data access page, set the direction, either left-to-right or right-to-left, under Default direction on the Right-to-Left tab in the Options dialog box (Tools menu). That direction will appear as the setting of the Dir property of the new data access page.

    For an existing data access page:

    1. From the Database window, open the data access page in Design view.

    2. Select the page by clicking the page title bar.

    3. Click Properties [image] on the toolbar, click the All tab, and change the Dir property setting to the page direction you want: Right-to-left or Left-to-right.

    Tip To edit directly in HTML, click HTML Source from the View menu and modify the <HTML> element to <HTML DIR=RTL> for a right-to-left page direction or <HTML DIR=LTR> for a left-to-right page direction.


 Codepage- und Textlayout-Unterstützung für HTML-Dateien mit Rechts-nach-links-Textfluss

Codepage- und Textlayout-Unterstützung für HTML-Dateien mit Rechts-nach-links-Textfluss

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Right-to-left enabled Access 2000 supports several code pages used in importing, saving, and exporting HTML Web pages.

Code page conversion of tables/worksheets with right-to-left characteristics is provided for HTML files stored in logical text layout and one of the following right-to-left code pages:

Language | Code page
Arabic | UTF-8 (default)
 | ISO 8859-6
 | DOS-720
 | ASMO-708
Hebrew | UTF-8 (default)
 | ISO 8859-8
 | DOS-862

Note Microsoft Access 2000 supports editing and saving of HTML files in logical text layout. HTML files stored in visual text layout can be viewed but not edited or saved in logical text layout.

More information

Import HTML tables and lists

Export a table, query, form, or report to HTML format


 Codepage für die arabische Schrift

Codepage für die arabische Schrift

Sprachspezifische Informationen

Each code page is identified by a unique code page number. The code page (CP) for Arabic is CP 1256.

Note Microsoft Access 2000 sorts right-to-left databases by using values from Unicode, not those from the right-to-left code page as in earlier versions. Opened or imported databases that use the Arabic code page and Arabic sort order will be converted to Unicode and General sort order.

Arabic code page


 Info über Codepage für die hebräische Schrift

Info über Codepage für die hebräische Schrift

Sprachspezifische Informationen

Each code page is identified by a unique code page number. The code page (CP) for Hebrew is CP 1255.

Note Microsoft Access 2000 sorts right-to-left databases using values from Unicode, not those from the right-to-left code page as in earlier versions. Opened or imported databases that use the Hebrew code page and Hebrew sort order will be converted to Unicode and General sort order.

Hebrew code page


 Festlegen der Textausrichtung in Textfeldern und anderen Steuerelementen

Festlegen der Textausrichtung in Textfeldern und anderen Steuerelementen

Sprachspezifische Informationen

You can select the type of text alignment you want in a label, text box, combo box, or list box.

  1. Open a form or report in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, in the TextAlign box, click one of the following:

    To have text alignment follow the language of the text first entered or the user interface language, click General.

    To have alignment fixed, click one of the other choices.

Notes

  • CTRL+LEFT SHIFT and CTRL+RIGHT SHIFT shortcut keys used to dynamically change reading order and alignment in other bidirectional programs will temporarily change reading order only (alignment is excluded because changing alignment might negatively affect appearance). When the focus leaves the control, the display format reverts to the chosen control reading order.

  • Learn about right-to-left properties.


 Übersicht der Eigenschaften von Steuerelementen mit Bezug auf die Rechts-nach-links-Funktionalität

Übersicht der Eigenschaften von Steuerelementen mit Bezug auf die Rechts-nach-links-Funktionalität

Sprachspezifische Informationen

Most intrinsic Microsoft Access 2000 controls can be configured to present right-to-left appearance and behavior. In some cases, this can be done by using standard Microsoft Access control properties (for example, the TextAlign property) and repositioning of controls to achieve a right-to-left appearance.

However, in some cases right-to-left properties are needed to achieve proper right-to-left appearance and behavior. The following tables lists those controls for which new right-to-left properties are added:

 | Label | Text box | Toggle button | Combo box | List box | Command button
TextAlign | X | X |  | X | X |
ReadingOrder | X | X | X | X | X | X
KeyboardLanguage |  | X |  | X |  |
ScrollBarAlign |  | X |  | X | X |
NumeralShapes | X | X |  | X | X |


 Festlegen der Rechts-nach-Links-Schreibeigenschaften in Steuerelementen

Festlegen der Rechts-nach-Links-Schreibeigenschaften in Steuerelementen

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

What do you want to do?

Learn about right-to-left properties

Specify text reading order for a text box or other control

Specify the initial keyboard language in a text box or combo box

Specify text alignment in a text box or other control

Specify where you want scroll bars in a text box or other control

Specify the appearance of numbers (Arabic only) in a text box or other control

See a summary of right-to-left properties for controls

Learn about bidirectional properties of the user interface


 Platzierung von Bezeichnungsfeldern für Steuerelemente

Platzierung von Bezeichnungsfeldern für Steuerelemente

Sprachspezifische Informationen

Labels are automatically created and attached to most controls. Label placement is determined by the Orientation property setting for the parent form at the time you create the label. If the Orientation property is set to right-to-left, the label is placed to the right of the control. If the Orientation property is set to left-to-right, the label is placed to the left of the control.

Properties for a label attached to a control, except TextAlign, are inherited from default label control properties. TextAlign for an attached label is inherited from the LabelAlign property in the parent control (for example, text box, option group, toggle button, option button, check box, combo box, list box, subform/subreport, bound object frame, or command button). LabelAlign, which specifies the alignment of text within a label, exists only as a parent property until the control is created. Thereafter, it is available as TextAlign in the label control attached to the parent control.


 Festlegen des Verhaltens der Einfügemarke

Festlegen des Verhaltens der Einfügemarke

Sprachspezifische Informationen

  1. Click Options on the Tools menu, and then click the Right-to-Left tab.

  2. Do one of the following in the Cursor option group:

    Click Logical to have insertion point movement according to the logical order of mixed text.

    Click Visual to have insertion point movement that ignores text language and moves contiguously to the right or left.


 Festlegen der Textleserichtung in Textfeldern und anderen Steuerelementen

Festlegen der Textleserichtung in Textfeldern und anderen Steuerelementen

Sprachspezifische Informationen

You can select the type of reading order you want in a label, text box, toggle button, combo box, list box, or command button. Learn about the ReadingOrder property.

  1. Open a form or report in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, in the ReadingOrder box, do one of the following:

    To have the reading order follow the language of the text first entered, click Context.

    To force the reading order in one direction, click Right-To-Left or Left-To-Right.

Note CTRL+LEFT SHIFT and CTRL+RIGHT SHIFT shortcut keys used to dynamically change reading order and alignment in other bidirectional programs will temporarily change reading order only (alignment is excluded because changing alignment might negatively affect appearance). When the focus is moved outside the control, the display format reverts to the chosen control reading order.


 Festlegen der Erscheinungsform von Zahlen (nur Arabisch) in Textfeldern oder anderen Steuerelementen

Festlegen der Erscheinungsform von Zahlen (nur Arabisch) in Textfeldern oder anderen Steuerelementen

Sprachspezifische Informationen

You can select the appearance of numbers in a label, text box, combo box, or list box.

  1. Open a form or report in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, in the NumeralShapes box, do one of the following:

    For numerals formatted according to Unicode rules for adjacent text, click Context. In general, this means numeral shapes are Hindi if surrounding text is Arabic.

    For numerals formatted according to the Numeral Shapes option (set by double-clicking Regional Settings in Windows Control Panel), click System.

    For numerals in Arabic, click Arabic.

    For numerals in Hindi, click Hindi.

Note Learn about right-to-left properties.


 Festlegen der Schreibrichtung in Steuerelementen auf Datenzugriffsseiten

Festlegen der Schreibrichtung in Steuerelementen auf Datenzugriffsseiten

Sprachspezifische Informationen

  1. From the Database window, open the data access page in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, find the right-to-left property associated with the control (such as Dir).

  4. Do one of the following:

    Click Right-to-left (or the equivalent setting) to display the control with a right-to-left direction.

    Click Left-to-right (or the equivalent setting) to display the control with a left-to-right direction.


Festlegen der Position von Bildlaufleisten in Textfeldern und anderen Steuerelementen

Sprachspezifische Informationen

You can select the position of scroll bars you want in a text box, combo box, or list box.

  1. Open a form or report in Design view.

  2. Make sure the control is selected, and then click Properties [image] on the toolbar.

  3. On the All tab, in the ScrollBarAlign box, do one of the following:

    To have the scroll bar follow the setting of the Orientation property for the form or report that contains the control, click System. (A vertical scroll bar is placed on the left if the form or report Orientation property setting is Right-to-left; and on the right if the form or report Orientation property setting is Left-to-right.)

    To have a scroll bar on the right side of the control, click Right.

    To have a scroll bar on the left side of the control, click Left.

Note Learn about right-to-left properties.


 Verwendung der Datenbankkalender

Verwendung der Datenbankkalender

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Any version of Access 2000 that supports right-to-left text (except Hebrew) also supports the use of the Gregorian (default) and Hijri calendar for date entry and display.

What do you want to do?

Learn about using different calendars

Switch between Gregorian and Hijri calendars


 Info über die Verwendung unterschiedlicher Kalender

Info über die Verwendung unterschiedlicher Kalender

Sprachspezifische Informationen

If you open an existing database with date references and you have selected the wrong calendar setting, the program might report a variety of errors or other unexpected behaviors. For example, if you have checked the Hijri Calendar setting, Microsoft Access 2000 will display a syntax error message if a report makes reference to Gregorian dates that are invalid as Hijri dates (for example, the date 12/31/99 will produce a syntax error because no Hijri month has 31 days).

To avoid problems of this sort, all date references in a database must be based on the same calendar.

Important It is recommended that you choose the database calendar when you first create your database, and then never change it.

Other considerations when the database calendar is set to Hijri

  • To ensure Hijri dates strings are evaluated correctly in expressions and Visual Basic for Applications statements, use the CDate function to evaluate the strings instead of declaring the strings as constants.

    For example, type CDate("1/25/20") instead of #1/25/20#.

    The CDate function will always return a value based on the active database calendar, whereas date constants are always evaluated by using the Gregorian calendar.

  • For reliable behavior, enter and display dates in an unambiguous format. For example, dates in short date format might be misinterpreted in queries if the year or the day of the month are 12 or less (for example, 3/11/10). Dates in medium date format display only the first few characters of the month name, which can create ambiguity or an undesirable appearance. Use long date format whenever possible. You can alter the way a date is displayed in long format (for example, excluding the day of the month) by using Regional Settings in Windows Control Panel.

  • Dates entered in the ValidationRule property of a Date/Time field in a table (in table Design view) must be Hijri. However, to have the ValidationRule date appear as a Hijri date in validation messages, the validation rule must use the CDate function (for example, 'CDate ("1/25/1420")'.

  • Sample Access 2000 applications, such as the Northwind database, are not localized and expect the database calendar to be Gregorian. Because the sample applications contain hard-coded date constants that are not valid Hijri dates, running the sample applications with the database calendar set to Hijri is not recommended.

  • All Hijri years will be displayed as four-digit year values (for example, 1420) unless the Format() function is explicitly used.

  • The Visual Basic Date function, used to set the system date for your computer, will not accept Hijri dates. If the database calendar is set to Hijri, set the calendar to Gregorian before setting system date with the Date function.

  • Dates in tables exported as text files are always stored as Gregorian values. If the database calendar is set to Hijri, automatic Hijri to Gregorian conversion is performed during the export process. Similarly, dates in tables imported from text files are assumed to be Gregorian dates and will be converted to Hijri values during the import process if the database calendar setting is Hijri.

  • You can't set the database calendar programmatically by using Visual Basic for Applications.

More information

Import, export, and link right-to-left tables in text formats


Umschalten zwischen dem gregorianischen und dem Hijri-Kalender

Sprachspezifische Informationen

  1. On the Tools menu, click Startup.

  2. Click Advanced.

  3. Select the Hijri Calendar check box.

The setting is saved with the database and used for all date references in the database.


 Verwenden von Sortierreihenfolgen für Rechts-nach-links-Zeichensätze

Verwenden von Sortierreihenfolgen für Rechts-nach-links-Zeichensätze

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

The default Microsoft Access 2000 sort order, General, handles sorting of right-to-left characters; that is, there are no separate sort orders for right-to-left languages. General sort order now includes right-to-left characters because characters are stored as Unicode values. The behavior of General sort order for right-to-left characters stored as Unicode values is identical to the behavior of right-to-left characters previously stored as Arabic or Hebrew code page values and sorted by using Arabic sort order and Hebrew sort order, respectively.

Right-to-left text is sorted along the following guidelines:

  • Left-to-right text is always sorted ahead of right-to-left text.

  • Sort ignores kashidas and bidirectional control characters.

  • Characters with diacritics are clustered after other occurrences of the base character.

Note When opened or imported, previous-version databases that use a right-to-left sort order are saved with the Access 2000 General sort order.

What do you want to do?

Learn about Arabic sort order

Learn about Arabic code page

Learn about Hebrew sort order

Learn about Hebrew code page


 Sortierreihenfolge für die arabischen Zeichensätze

Sortierreihenfolge für die arabischen Zeichensätze

Sprachspezifische Informationen

Arabic sort order is described here by using the Arabic code page, not Unicode, because the former is more familiar to most users. The Arabic sort order table arranges the characters of the Arabic code page into a sort order. The sort order controls how data is sequentially ordered in Microsoft Access databases that use the Arabic code page.

Note Microsoft Access 2000 sorts right-to-left databases by using values from Unicode, not those from the right-to-left code page as in earlier versions. Opened or imported databases that use the Arabic code page and Arabic sort order will be converted to Unicode and General sort order.

The 256 characters of the Arabic code page can be organized into several categories that determine how characters are sorted.

  • Kashida and bidirectional control characters (hexadecimal code points 9D, 9E, DC, FD, and FE):

    Sort ignores these characters.

  • Arabic diacritics (hexadecimal code points F0 through F3, F5, F6, F8, and FA):

    Sort ignores Arabic diacritics except when the strings being compared are otherwise identical. In this case, unmarked characters (without diacritics) sort ahead of marked characters (with diacritics); diacritics with lower code point values sort ahead of others.

  • General control characters (hexadecimal code points 00 through 1F and 7F), reserved characters (hexadecimal code points 80, 81, 8D, 8E, 8F, and 90), and punctuation:

    These three categories sort ahead of alphanumeric characters in category order (that is, General control characters first) and in ascending code point order within each category (for example, 00 sorts ahead of 01).

  • Arabic and left-to-right alphanumeric characters (shown in the Arabic sort order table that follows):

    Left-to-right text is always sorted ahead of Arabic text.

    Left-to-right text sorting is not case sensitive. For example, although uppercase "A" is listed before lowercase "a" in the sort table, Access 2000 treats these characters equally and does not provide any sorting preference to either character.

    Unmarked left-to-right text (without diacritics) is sorted before marked left-to-right text.

The following table lists the alphanumeric characters of the Arabic code page along with their respective hexadecimal code points. Characters (Char) are arranged in columns according to their sort order, starting in the upper-left corner.

Arabic sort order


 Info über die Sortierreihenfolge für die hebräischen Zeichensätze

Info über die Sortierreihenfolge für die hebräischen Zeichensätze

Sprachspezifische Informationen

Hebrew sort order is described here by using the Hebrew code page, not Unicode, because the former is more familiar to most users. The Hebrew sort order table arranges the characters of the Hebrew code page into a sort order. The sort order controls how data is sequentially ordered in Microsoft Access databases that use the Hebrew code page.

Note Microsoft Access 2000 sorts right-to-left databases by using values from Unicode, not those from the right-to-left code page as in earlier versions. Opened or imported databases that use the Hebrew code page and Hebrew sort order will be converted to Unicode and General sort order.

The 256 characters of the Hebrew code page can be organized into several categories that determine how characters are sorted.

  • Bidirectional control characters (hexadecimal code points FD and FE):

    Sort ignores these characters.

  • Hebrew diacritics (hexadecimal code points C0 through CD, D1, and D2):

    Sort ignores Hebrew diacritics except when the strings being compared are otherwise identical. In this case, unmarked characters (without diacritics) sort ahead of marked characters (with diacritics); diacritics with lower code point values sort ahead of others.

  • General control characters (hexadecimal code points 00 through 1F and 7F), reserved characters (hexadecimal code points 80, 81, 8A, 8C through 90, 9A, 9C through 9F, CE through D0, D3 through DF, FB, FC, and FF), and punctuation:

    These three categories sort ahead of alphanumeric characters in category order (that is, General control characters first) and in ascending code point order within each category (for example, 00 sorts ahead of 01).

  • Hebrew and left-to-right alphanumeric characters (shown in the Hebrew sort order table that follows):

    Left-to-right text is always sorted ahead of Hebrew text.

    Left-to-right text sorting is not case sensitive. For example, although uppercase "A" is listed before lowercase "a" in the table on the following page, Hebrew Access treats these characters equally and does not provide any sorting preference to either character.

    Unmarked left-to-right text (without diacritics) is sorted before marked left-to-right text.

The following table lists the alphanumeric characters of the Hebrew code page along with their respective hexadecimal code points. Characters (Char) are arranged in columns according to their sort order, starting in the upper-left corner.

Hebrew sort order


 Konvertieren bidirektionaler Textdateien aus dem ANSI-Format

Konvertieren bidirektionaler Textdateien aus dem ANSI-Format

Sprachspezifische Informationen

The ConvText utility provides more support (additional code pages and visual text layout options) than is found in the Microsoft Access 2000 Import Text Wizard to convert bidirectional files from ANSI characters. ConvText is installed as part of Microsoft Access 2000.

  1. Export the Access object you want to convert to a non-ANSI code page.

  2. In the Program Files\Microsoft Office\Office folder, double-click the ConvText.exe icon.

  3. Click Convert From Windows ANSI Code Page.

  4. Type file names in the Source and Target boxes, or click Browse.

  5. Select the code page, text layout, file type, and file type parameters that match the target text file you are converting to.

  6. Click Load. You can also click Save to retain the conversion specifications.

  7. Click Convert.


 Konvertieren bidirektionaler Textdateien in das ANSI-Format

Konvertieren bidirektionaler Textdateien in das ANSI-Format

Sprachspezifische Informationen

The ConvText utility provides more support (additional code pages and visual text layout options) than is found in the Microsoft Access 2000 Import Text Wizard to convert bidirectional files to ANSI characters. ConvText is installed as part of Access 2000.

  1. In the Program Files\Microsoft Office\Office folder, double-click the ConvText.exe icon.

  2. Click Convert To Windows ANSI Code Page.

  3. Type file names in the Source and Target boxes, or click Browse.

  4. Select the code page, text layout, file type, and file type parameters that match the source text file you are converting.

  5. Click Load. You can also click Save to retain the conversion specifications.

  6. Click Convert.

  7. Import the converted text file into Access.

All field names and records from the original table/worksheet will be fully recreated in a new table.


 Konvertieren von als Textdatei gespeicherten Berichten in das ANSI-Format

Konvertieren von als Textdatei gespeicherten Berichten in das ANSI-Format

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

Reports exported as text files using the Save as/Export command (File menu) are saved as simple text files with fields in logical, not visual, order. You can use the resulting file with a number of different programs, but the file can be hard to read when it contains bidirectional text. Depending on the report complexity, a viewable version of the report can frequently be obtained by opening the file in Notepad and switching document reading order by using CTRL+LEFT SHIFT and CTRL+RIGHT SHIFT.

What do you want to do?

Convert bidirectional text files to ANSI characters

Convert bidirectional text files from ANSI characters


Die Sortierreihenfolge japanischer Zeichensätze

Sprachspezifische Informationen

Japanese characters are sorted in the following order:

  • Hiragana and Katakana are sorted in the order of the kana syllabary.

  • English letters will be sorted alphabetically. No distinction is made between uppercase and lowercase letters.

  • Numbers are sorted in descending order.

  • No distinction is made between half-pitch and full-pitch English characters and symbols.

  • Other kanji, symbols, and so on, are sorted in the order of their Shift-JIS codes.

The order of the kana syllabary is as follows:

  • Long vowel sounds ( [image]) are treated as the vowel of the previous syllable. For example, " [image] [image] [image] [image] [image] [image] " is treated as " [image] [image] [image] [image] [image] [image] ".

  • Repetition marks (" [image] ") are treated as the same character as the character preceding the mark. For example, " [image] [image] [image] " is treated as " [image] [image] [image] ".

  • Voiced and unvoiced sounds are sorted in the following order: unvoiced sound, voiced-sound, semi-voiced sound.

  • No distinction is made between hiragana, full-pitch katakana, and half-pitch katakana.


 Microsoft Access-Projekte

Microsoft Access-Projekte

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Was ist ein Microsoft Access-Projekt?

Unterstützung für Microsoft SQL Server-Datenbanken

Arbeiten mit einem Access-Projekt

Weitere Fragen

Was ist ein Microsoft Access-Projekt?

Ein Microsoft Access-Projekt (.adp) repräsentiert eine neue Art von Access-Datei, die einen eigenen effizienten Zugriff auf eine Microsoft SQL Server-Datenbank über die OLE DB-Komponentenarchitektur ermöglicht. Mit einerm Access-Projekt können Sie eine Client/Server-Anwendung genauso einfach erstellen wie eine Dateiserver-Anwendung. Eine solche Client/Server-Anwendung kann eine herkömmliche Lösung auf der Grundlage von Formularen und Berichten sein oder eine webbasierte Lösung unter Verwendung von Datenzugriffseiten oder eine Kombination von beidem.

Interaktion zwischen einem Microsoft Access-Projekt und einer Microsoft SQL Server-Datenbank

Ein Access-Projekt wird als "Projekt" bezeichnet, da es nur code-basierte oder HTML-basierte Datenbankobjekte enthält: Formulare, Berichte, Datenzugriffsseiten, Makros und Module. Dies sind die Datenbankobjekte, die Sie zur Erstellung einer Anwendung verwenden. Anders als eine Microsoft Access-Datenbank enthält ein Access-Projekt keine Daten oder an Datendefinitionen gebundene Objekte, also keine Tabellen, Sichten, Datenbankdiagramme oder Gespeicherte Prozeduren (die auch anwendungsbezogenen Code enthalten können). Stattdessen werden diese Datenbankobjekte in der SQL Server-Datenbank gespeichert.

Um eine Anwendung zu erstellen und auf die Daten zuzugreifen, verbinden Sie Access-Projekt und SQL Server-Datenbank mit dem Befehl Neu im Menü Datei oder indem Sie den Datenbank-Assistenten verwenden. Informationen über das Erstellen eines Access-Projekts.

Zurück zum Anfang

Unterstützung für Microsoft SQL Server-Datenbanken

Sie können ein Access-Projekt mit einer der folgenden SQL Server-Datenbanken verbinden:

  • Microsoft SQL Server 7.0 unter Microsoft Windows NT 4.0 oder höher (zusammen mit Microsoft Windows NT Service Pack 4 oder höher) und unter Microsoft Windows 95 oder höher

  • Microsoft Data Engine (MSDE) unter Windows NT 4.0 oder höher und unter Windows 95 oder höher

  • SQL Server 6.5 unter Windows NT 4.0 oder höher (zusammen mit SQL Server Service Pack 5 oder höher)

Zurück zum Anfang

Arbeiten mit einem Access-Projekt

Das Arbeiten mit einem Access-Projekt ähnelt sehr der Handhabung einer Access-Datenbank. Die beim Erstellen von Formularen, Berichten, Datenzugriffsseiten, Makros und Modulen verwendeten Verfahren sind im wesentlichen dieselben wie diejenigen, die bei der Erstellung einer Access-Datenbank eingesetzt werden.

Sobald eine Verbindung mit der SQL Server-Datenbank besteht, können Sie die Tabellen, Sichten, Gespeicherten Prozeduren und Datenbankdiagramme anzeigen, erstellen, ändern und löschen. Sie verwenden dazu dieselben Microsoft SQL Server-Entwurfstools, die auch in Verbindung mit Microsoft Visual Interdev und Microsoft Visual Basic eingesetzt werden. Obwohl die Benutzeroberfläche zur Handhabung dieser Datenbankobjekte eine andere als die zur Manipulation derselben Objekte in einer Access-Datenbank verwendete Oberfläche ist, lässt sie sich dennoch genauso einfach bedienen. Ein Access-Projekt enthält außerdem viele der Assistenten, die auch für eine Access-Datenbank zur Verfügung stehen, beispielsweise den Formular-Assistenten, den Berichts-Assistenten und den Seiten-Assistenten, mit deren Hilfe sich recht schnell ein Prototyp oder eine einfache Anwendung realisieren lässt.

Zurück zum Anfang

Weitere Fragen

OLE DB und Datenlinks

Microsoft Data Engine (MSDE)

Verwenden des Upsizing-Assistenten

Optimieren der Leistung eines Microsoft Access-Projekts

Dokumentation zu Microsoft SQL Server

Zurück zum Anfang


 OLE DB und Datenlinks

OLE DB und Datenlinks

Microsoft Access 2000 beinhaltet eine eigene Benutzeroberfläche und Programmierschnittstelle für OLE DB, mit deren Hilfe Sie auf Microsoft Access-Datenbanken, Microsoft SQL Server-Datenbanken und andere Datenquellen zugreifen können. Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Microsoft Access und die OLE DB-Architektur

Festlegen von Verbindungsinformationen

Erstellen und Zugreifen auf Microsoft-Datenlinkdateien

Installieren eines OLE DB-Providers

OLE DB-Programmierung

Zurück zum Anfang

Microsoft Access und die OLE DB-Architektur

OLE DB ist eine komponentenbasierte Datenbankarchitektur, die einen effizenten Netzwerk- bzw. Internetzugriff auf vielerlei Arten von Datenquellen implementiert. Zu diesen Datenquellen gehören relationale Datenbanken, E-Mail-Dateien, unstrukturierte Dateien und Dateien mit Tabellendaten. Im Rahmen der OLE DB-Architektur wird die Anwendung, die auf die Daten zugreift, als Datenverbraucher (data consumer) bezeichnet (beispielsweise Microsoft Access 2000 oder ein Microsoft Visual Basic 6.0-Programm), während das Programm, das den Datenzugriff ermöglicht, als Datenbankanbieter bezeichnet wird (Beispiele dafür sind Microsoft OLE DB Provider for SQL Server oder Microsoft Jet 4.0 OLE DB Provider).

Zurück zum Anfang

Festlegen von Verbindungsinformationen

Ein Datenlink beinhaltet die Verbindungsinformationen, die ein Datenverbraucher beim Zugriff auf eine Datenquelle über den OLE DB-Anbieter dieser Datenquelle benutzt. Innerhalb der Microsoft Access-Benutzeroberfläche verwenden Sie das Dialogfeld Datenlinkeigenschaften, um einen Datenlink für einen OLE DB-Anbieter zu definieren. Dieses Dialogfeld wird im Verlauf der folgenden Operationen aufgerufen:

  • Verbinden mit einer Microsoft SQL Server-Datenbank, während Sie ein Microsoft Access-Projekt unter Verwendung des Befehls Neu im Menü Datei oder mit dem Datenbank-Assistenten erstellen. Weitere Informationen dazu finden Sie unter Erstellen eines Access-Projekts.

  • Umdefinieren der Verbindungsinformationen eines Access-Projekts mit dem Befehl Verbindung im Menü Datei. Dieser Fall kann eintreten, wenn Sie von einer Testumgebung zu einer Produktionsumgebung oder von einem Primärserver zu einem sekundären Server wechseln möchten. Weitere Informationen dazu finden Sie unter Ändern der Verbindungsdaten eines Access-Projekts.

  • Umdefinieren der Verbindungsinformationen für eine vorhandene Datenzugriffsseite innerhalb der Seitenentwurfsansicht durch Klicken mit der rechten Maustaste auf die Feldliste und anschließendes Klicken auf Verbindung. Beim erstmaligen Erstellen einer Datenzugriffsseite definiert Microsoft Access die Verbindungsinformationen automatisch, indem eine Verbindung mit der aktuellen Access-Datenbank bzw. dem aktuellen Projekt hergestellt wird. Weitere Informationen dazu finden Sie unter Ändern der Verbindungsdaten einer Datenzugriffsseite.

  • Verbinden mit einer Webseite, die Sie über das Dialogfeld Öffnen (Menü Datei, Befehl Öffnen) aus einem leeren Datenbankfenster heraus geöffnet haben.

  • Erstellen einer Pivot-Tabelle oder Ändern der Verbindungsdaten einer Pivot-Tabelle.

Jeder OLE DB-Anbieter definiert spezielle Verbindungsinformationen. Beispielsweise benötigt Microsoft OLE DB Provider for SQL Server einen Servernamen, die Adresse des Servers und einen Benutzernamen. Darüber hinaus können Sie noch weitere Informationen festlegen, z.B. ein Kennwort oder die Verwendung der integrierten Sicherheitsfunktionen von Microsoft Windows NT.

Um Verbindungsinformationen mit dem Dialogfeld Datenlinkeigenschaften zu definieren, gehen Sie in der Regel folgendermaßen vor:

  • Klicken Sie auf die Registerkarte Provider, markieren den OLE DB-Provider und klicken dann auf Weiter, um die Registerkarte Verbindung anzuzeigen, in der Sie spezielle Verbindungsinformationen für den ausgewählten OLE DB-Anbieter eingeben können. Beachten Sie, dass je nachdem, wie Sie das Dialogfeld Datenlinkeigenschaften aufgerufen haben, die Registerkarte Provider unter Umständen nicht verfügbar ist. Access definiert automatisch die aktuell geöffnete Access-Datenbank (bzw. die mit dem aktuellen Access-Projekt verbundene SQL Server-Datenbank) als Anbieter.

  • Klicken Sie auf die Registerkarte Weitere, um zusätzliche Informationen wie z.B. Netzwerkeinstellungen und Zugriffsberechtigungen festzulegen.

  • Klicken Sie auf die Registerkarte Alle, um Initialisierungseigenschaften des OLE DB-Anbieters zu definieren.

Die Hilfedatei für das Dialogfeld Datenlinkeigenschaften (msdasc.hlp) liefert Ihnen zusätzliche Informationen über die Verwendung des Dialogfelds und das Definieren von Verbindungsinformationen für die einzelnen OLE DB-Anbieter.

Zurück zum Anfang

Erstellen und Zugreifen auf Microsoft-Datenlinkdateien

Obwohl Sie in der Regel die Verbindung mit einem OLE DB-Anbieter über Microsoft Access unter Verwendung des Dialogfelds Datenlinkeigenschaften einrichten, können Sie Verbindungsinformationen für einen OLE DB-Anbieter auch in Form einer Microsoft-Datenlinkdatei (.udl) zusammenstellen, die dann beispielsweise von einem Visual Basic-Programm verwendet werden kann. In solchen Dateien lassen sich die Verbindungsinformationen auf Ihrem Computer organisieren und verwalten.

Um Verbindungsinformationen in dieser Weise zu erstellen, öffnen Sie Microsoft Windows Explorer, klicken im Untermenü Neu auf Microsoft Datenlink, erstellen eine Microsoft-Datenlinkdatei, legen den Dateinamen fest, klicken mit der rechten Maustaste auf den Dateinamen und wählen dann den Befehl Eigenschaften.

Zurück zum Anfang

Installieren eines OLE DB-Anbieters

Microsoft Jet 4.0 OLE DB Provider und Microsoft OLE DB Provider for SQL Server werden automatisch bei Installation von Microsoft Office 2000 oder Microsoft Access 2000 installiert. Weitere OLE DB-Anbieter werden ebenfalls installiert, unter anderem OLE DB Provider for ODBC Drivers und OLE DB Provider for Oracle. Eine vollständige Liste aller auf Ihrem Computer installierten OLE DB-Anbieter erhalten Sie angezeigt, wenn Sie im Dialogfeld Datenlinkeigenschaften (aufgerufen über das Kontextmenü einer Datenlinkdatei) auf die Registerkarte Provider klicken.

Wenn Sie oder ein anderer Benutzer eine Seite mit dem Microsoft Internet Explorer Version 5 oder später anzeigen und auf Ihrem Computer über eine Microsoft Office 2000-Lizenz verfügen, lädt die Seite die erforderlichen OLE DB-Anbieter und andere zugehörige Dateien gegebenenfalls automatisch auf Ihren Computer im Rahmen der Installation der Microsoft Office Web Components.

Zurück zum Anfang

OLE DB-Programmierung

Der Zugriff auf die Daten eines OLE DB-Anbieters kann auch programmgesteuert durch ein Visual Basic für Applikationen-Programm erfolgen. Dabei werden Microsoft ADO-Objekte (ActiveX Data Objects) eingesetzt, um durch Festlegen der ConnectionString-Eigenschaft der Open-Methode des Connection-Objekts die entsprechenden Verbindungsinformationen an den OLE DB-Anbieter zu übergeben.Weitere Informationen dazu finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang


 Microsoft Data Engine (MSDE)

Microsoft Data Engine (MSDE)

Diese Seite enthält Übersichtsinformationen zu folgenden Themen im Zusammenhang mit Microsoft Data Engine (MSDE):

Was bedeutet MSDE?

Wann ist MSDE zu verwenden?

Installieren von MSDE

Weitere Informationen

Was bedeutet MSDE?

MSDE ist eine neue Technologie zur lokalen Datenspeicherung, die kompatibel mit Microsoft SQL Server 7.0 ist. Sie können MSDE auch zur servergestützten Datenspeicherung verwenden. Man kann sich MSDE als Client/Server-Alternative zum Dateiserver Microsoft Jet-Datenengine vorstellen. MSDE kann unter Microsoft Windows NT 4.0 oder später und unter Windows 95 oder später verwendet werden. Das Produkt wurde für die Verwendung auf kleinen Computersystemen entworfen und optimiert, beispielsweise für den Einsatz auf einzelnen PCs oder kleinen Arbeitsgruppen-Servern.

Da MSDE auf derselben Datenengine basiert wie SQL Server, lassen sich die meisten Microsoft Access-Projekte oder Client/Server-Anwendungen ohne Änderungen unter beiden Versionen ausführen. Anders als SQL Server 7.0 unterstützt MSDE jedoch nur Datenbanken bis zu einer Größe von 2 GB, beinhaltet keine Unterstützung für die Parallelverarbeitung durch Symmetrical Multiprocessing (SMP) unter Windows 95 oder später, und kann bei Verwendung von Transaktionsreplikation nicht als Replikationsverleger agieren (aber durchaus als Replikationsabonnent auftreten).

Zurück zum Anfang

Wann ist MSDE zu verwenden?

MSDE lässt sich als Desktop-Datenbank einsetzen und stellt so eine Alternative zu einer Microsoft Access-Datenbank dar. Folgende Möglichkeiten sind denkbar:

  • Verwendung als Serverdatenbank für kleine Arbeitsgruppen. Sie entwickeln Ihre Anwendungen im Rahmen eines Access-Projekts mit MSDE-Anbindung. Dabei planen Sie schon das weitere Wachstum Ihrer Arbeitsgruppe und der damit verbundenen Anforderungen ein, die letztendlich den Übergang zur vollen Funktionalität von SQL Server 7.0 in Verbindung mit einem großen Netzwerkserver nötig machen werden.

  • Verwendung als Replikationsabonnent in einer Umgebung mit replizierten SQL Server-Datenbanken. Ein Anwendungsfall wäre beispielsweise eine Hauptverwaltung mit Außendienstmitarbeitern, die in der Regel über Laptops und andere nicht vernetzte Computer auf MSDE zugreifen und Daten aktualisieren, aber sich gelegentlich auch mit der Master-Datenbank von SQL Server verbinden, um ihre Änderungen einzuspeisen.

  • Verwendung als lokale Enwicklungs- und Testumgebung auf einem PC oder einem Workstation-Computer für ein Access-Projekt oder eine Client-/Server-Anwendung. Nach erfolgreicher Entwicklung können die Verbindungsinformationen des Access-Projekts modifziert werden, um eine Verbindung mit einer SQL Server-Datenbank auf einem Remote-Server herzustellen und abschließende Tests in einer Produktionsumgebung durchzuführen.

Zurück zum Anfang

Installieren von MSDE

Obwohl MSDE nicht Bestandteil einer Microsoft Office 2000- oder Microsoft Access 2000-Installation ist, können Sie MSDE dennoch von der CD mit dem Programm Setupsql.exe installieren, das sich im Ordner \Sql\x86\Setup befindet.

Die Microsoft Office 2000-Version von MSDE enthält außerdem weitere Hilfedateien, die Sie im Ordner \Windows\Help finden können. Es handelt sich um die Hilfe für SQL Server Enterprise Manager (entmgr.chm) und den Replikations-Assistenten (replwiz.chm), die Sie in Verbindung mit den SQL Server-Datenbankprogrammen verwenden können, die über das Menü Extras in Access zur Verfügung stehen.

Nachdem Sie MSDE unter Windows 95 oder später auf Ihrem Computer installiert haben, müssen Sie gegebenenfalls den SQL Server Service Manager starten (indem Sie auf das Symbol MSSQLServer in der Taskleiste doppelklicken und anschließend auf Starten/Fortfahren klicken). Unter Windows NT 4.0 oder später wird MSDE automatisch gestartet. Den automatischen Start von MSDE unter Windows 95 oder später können Sie veranlassen, indem Sie das Kontrollkästchen Automatisch starten im Fenster des SQL Server Service Managers aktivieren.

Zurück zum Anfang

Weitere Informationen

Erstellen eines Access-Projekts mit dem Datenbank-Assistenten

Verbinden eines Access-Projekts mit einer SQL Server-Datenbank

Replikation in einem Microsoft Access-Projekt

Verwenden der Microsoft SQL Server-Datenbankprogramme innerhalb von Microsoft Access

Dokumentation zu Microsoft SQL Server

Zurück zum Anfang


 Optimieren der Leistung eines Microsoft Access-Projekts

Optimieren der Leistung eines Microsoft Access-Projekts

In einer Client/Server-Anwendung gibt es ein paar Grundregeln für das Reduzieren des Netzwerkverkehrs und das Optimieren der Leistung von Anwendungen: Die Verarbeitung der Daten sollte auf dem Server durchgeführt werden, Zugriffe auf Daten auf dem Server sollten möglichst selten stattfinden, und es sollten nur beschränkt Daten vom Server abgerufen werden. Dieses Thema enthält Referenzinformationen über:

Infos über OLE DB und die Client/Server-Umgebung

Verarbeiten von Daten auf dem Server

Beschränken der vom Server abgerufenen Daten

Optimieren der Microsoft SQL Server-Datenbank

Optimieren von Formularen

Optimieren von Berichten

Weitere Informationen

Infos über OLE DB und die Client/Server-Umgebung

Ein Microsoft Access-Projekt verwendet OLE DB für die Verbindung und Kommunikation mit einer SQL Server-Datenbank. Die OLE DB-Architektur wurde von Microsoft für die effiziente Arbeit in einer Client/Server-Umgebung entworfen.

Wenn Sie über ein Formular oder Datenblatt auf Daten zugreifen, ruft OLE DB eine aktualisierbare Snapshot- Datensatzgruppe von der SQL-Serverdatenbank ab (bis zur maximalen Datensatzgrenze) und führt eine Zwischenspeicherung der Daten auf dem Client durch - dies stellt einen Zugriff auf Daten auf dem Server dar. Access ruft die Daten asynchron ab, d. h., Sie können weiterhin mit Access arbeiten, während die Daten geladen werden. Wenn Sie mit den Daten im Formular oder Datenblatt arbeiten, z. B. Daten durchsuchen, filtern, sortieren, suchen und aktualisieren, arbeiten Sie mit den Daten, die auf dem Client zwischengespeichert sind.

Zurück zum Anfang

Verarbeiten von Daten auf dem Server

Um Daten auf dem Server zu verarbeiten, können Sie Gespeicherte Prozeduren und Trigger verwenden. Außerdem können Daten auf dem Server sortiert werden, bevor sie abgerufen werden.

Bei Gespeicherten Prozeduren handelt es sich um eine vorkompilierte Auflistung einer oder mehrerer SQL-Anweisungen und optionaler Ablaufsteuerungsanweisungen, an die Parameter übergeben werden können und die von Microsoft SQL Server als Einheit verarbeitet wird. Eine Gespeicherte Prozedur wird in der SQL Server-Datenbank abgelegt. Da eine Gespeicherte Prozedur bei ihrer Erstellung auf dem Server kompiliert wird, wird sie schneller ausgeführt als einzelne SQL-Anweisungen. Da eine Gespeicherte Prozedur außerdem auf dem Server ausgeführt wird, nutzt sie die größere Verarbeitungsleistung des Servers. Informationen zum Arbeiten mit Gespeicherten Prozeduren anzeigen.

Bei einem Trigger handelt es sich um eine besondere Art gespeicherter Prozedur, die automatisch ausgeführt wird, sobald Daten aktualisiert, eingefügt oder gelöscht werden. Trigger werden verwendet, um Geschäftsregeln und Beschränkungen anzuwenden, die komplexer sind als die mit Check-Einschränkungen definierten. Im Gegensatz zu Check-Einschränkungen können Trigger auf Spalten in anderen Tabellen verweisen. So kann ein Trigger z. B. ein Rollback von Aktualisierungen durchführen, bei denen ein (in einer Preisnachlasstabelle gespeicherter) Preisnachlass auf (in einer Titeltabelle gespeicherte) Bücher angewendet wurde, deren Preis weniger als DM 10 beträgt. Informationen zum Arbeiten mit Triggern.

Sortieren Sie Datensätze auf dem Server mit einer Gespeicherten Prozedur oder einer SQL-Anweisung, die in der Datenherkunft-Eigenschaft eines Formulars oder Berichts gespeichert ist (sie wird auf dem Server ausgeführt). Das Sortieren von Datensätzen auf dem Server stellt eine weitere Methode dar, die zusätzliche Verarbeitungsleistung des Servers zu nutzen. Informationen zu Sortiermethoden.

Zurück zum Anfang

Beschränken der vom Server abgerufenen Daten

Die Datenmenge, die eine Anwendung von der SQL Server-Datenbank abruft, sollte so weit wie möglich beschränkt werden. Verwenden Sie Sichten, Gespeicherte Prozeduren, Serverfilter und WHERE-Abschnitte in SQL-Anweisungen, um die Daten, die Ihnen oder den Benutzern in einem Formular oder Datenblatt angezeigt werden, auf nur die notwendigen Daten zu beschränken. Allgemein sollten Anwendungsszenarien vermieden werden, in denen Benutzer uneingeschränkt die Datenbank durchsuchen können.

In der Regel empfiehlt es sich, die Maximale Datensatzgrenze-Schaltfläche oder die MaxRecords-Eigenschaft zu verwenden, um die Daten zu beschränken, die Sie oder ein Benutzer in einem Formular oder Datenblatt sehen können.

Sie können auch Serverfilter verwenden, um Datensätze vor dem Abruf aus der Datenbank auf dem Server zu beschränken, sowie Filter, um Datensätze auf dem Client weiter zu beschränken. Weitere Informationen über Erstellen von Filtern. Ein Filter kann in der Serverfilter-Eigenschaft eines Formulars oder Berichts definiert werden. Außerdem können Sie die Leistung von Wertelisten in den Fenstern Formularbasierter Serverfilter und Formularbasierter Filter optimieren, indem Sie mit Hilfe der Filter anwenden-Eigenschaft die Anzahl der Werte steuern, die angezeigt werden sollen, wenn die Werte entweder vom Server oder vom Client abgerufen werden. Weitere Informationen über Optimieren der Filterleistung.

Zurück zum Anfang

Optimieren der SQL Server-Datenbank

Im Folgenden finden Sie allgemeine Richtlinien für das Optimieren der Leistung von SQL Server-Datenbanken. Nähere Informationen über das Verbessern der Leistung von SQL Server-Datenbanken finden Sie in der Dokumentation zu SQL Server.

  • Entwerfen von Tabellen ohne redundante Daten. Eine sorgfältig entworfene Datenbank ist eine Voraussetzung für das schnelle Abrufen und Aktualisieren von Daten.

  • Erzwingen Sie referenzielle Integrität, wodurch die definierten Beziehungen zwischen Tabellen beim Hinzufügen, Aktualisieren oder Löschen von Zeilen in diesen Tabellen erhalten bleiben, indem Sie Primär- und Fremdschlüsseleinschränkungen in den zusammenhängenden Tabellen definieren.

  • Auswählen des passenden Datentyps für Felder. Sie können in Ihrer Datenbank Platz sparen und Verknüpfungsoperationen verbessern. Wählen Sie beim Definieren eines Feldes den kleinsten Datentyp oder die kleinste Feldgröße, die zu den Daten in dem Feld passt.

  • Erstellen Sie Indizes für Felder, die Sie sortieren oder verknüpfen, oder für die Sie Kriterien festlegen. In einer Abfrage können Sie deutliche Geschwindigkeitsverbesserungen erreichen, indem Sie Felder indexieren, die sich auf den beiden Seiten einer Verknüpfung befinden, und Felder, die für das Festlegen von Kriterien für die Abfrage verwendet werden. Indizes können jedoch die Geschwindigkeit beim Einfügen, Aktualisieren und Löschen von Datensätzen verringern.

  • Fügen Sie Ihren Tabellen ein Timestamp-Feld hinzu, um die Leistung beim Löschen und Aktualisieren von Datensätzen zu erhöhen. Dies empfiehlt sich besonders dann, wenn die Tabelle viele Felder enthält. SQL Server verwendet ein Timestamp-Feld, um anzuzeigen, dass ein Datensatz geändert wurde, indem es ein Feld mit eindeutigem Wert erstellt und dieses Feld immer dann aktualisiert, wenn ein Datensatz aktualisiert wird. SQL Server verwendet den Wert in Timestamp-Feldern, um vor der Aktualisierung eines Datensatzes festzustellen, ob dieser geändert worden ist. Im Allgemeinen bietet ein Timestamp-Feld die höchste Leistung und Zuverlässigkeit, besonders in einer Umgebung mit mehreren Benutzern. Ohne ein Timestamp-Feld muss SQL Server alle Felder in dem Datensatz überprüfen, um festzustellen, ob der Datensatz geändert wurde. Diese Überprüfung kann die Leistung herabsetzen.

  • Komprimieren Sie in regelmäßigen Abständen Ihre SQL Server-Datenbank, um Speicherplatz einzusparen, und reorganisieren Sie für einen schnelleren Zugriff die Indizes und Daten.

Zurück zum Anfang

Optimieren von Formularen

Wenn Sie ein Formular entwerfen, sollten Sie im Allgemeinen die benötigten Daten und Funktionen feststellen. Diese Daten und Funktionen sollten jedoch erst dann vom Server abgefragt werden, wenn der Benutzer diese Informationen anfordert. Erstellen Sie beispielsweise ein Formular so, dass beim Öffnen des Formulars keine Daten vom Server abgerufen werden müssen. Sie können z. B. dem Formular eine Befehlsschaltfläche hinzufügen, um Daten in das Formular zu laden.

Lassen Sie Felder, die zum Abrufen der Daten vom Server viel Zeit benötigen, wie z. B. Text- und Bildfelder, nur auf Anfrage anzeigen. Dies kann auf die folgenden Arten erreicht werden:

  • Platzieren Sie Text- und Bildfelder auf einem Unterformular, das die gleiche Datenquelle verwendet. Access ruft nur die Text- oder Bildwerte für den aktuellen Datensatz ab.

  • Lassen Sie die wichtigsten Felder auf einem Hauptformular anzeigen, und stellen Sie dem Benutzer eine Schaltfläche mit dem Titel "Weitere Informationen" zur Verfügung, die ein weiteres Formular mit anderen Feldern öffnet. Das zweite Formular sollte auf einer Abfrage basieren, das als Parameter das Primärschlüsselfeld des Hauptformulars verwendet.

  • Wenn in Ihrer Anwendung viele Daten eingegeben werden sollen, z. B. bei einem Bestelleingabesystem, erstellen Sie ein spezielles Formular zum Hinzufügen von Datensätzen, bei dem die Daten eingeben-Eigenschaft auf "Ja" festgelegt ist. Wenn Sie das Formular öffnen, um neue Daten einzugeben, zeigt Access keine existierenden Datensätze an. Dies spart Zeit, da Access nicht alle Datensätze vom Server abrufen muss.

  • Wenn ein Formular oder Bericht auf einer parametrisierten gespeicherten Prozedur basiert, verwenden Sie die Eingabeparameter-Eigenschaft, um die Parameterwerte anzugeben.

Verwenden Sie die SQL-Anweisungen UPDATE und DELETE mit dem passenden WHERE-Abschnitt, um mehrere Datensätze zu aktualisieren oder zu löschen, die die gleichen Kriterien erfüllen. Dies ist effizienter als eine Datensatzgruppe zu öffnen und die Datensätze einen nach dem anderen zu aktualisieren oder zu löschen.

Zurück zum Anfang

Optimieren von Berichten

Statt einen langen Bericht anzuzeigen, sollten Berichte in kleinere Untermengen von Daten aufgeteilt werden. Dies erreichen Sie durch Verwenden von Sichten, Gespeicherten Prozeduren und SQL-Anweisungen als Datenquelle, oder mit Hilfe von Filtern.

Verwenden Sie die Layoutvorschau statt der Seitenansicht, wenn Sie einen Bericht entwerfen. So können Sie schnell das Layout überprüfen. Dieses enthält in der Layoutvorschau nur ein Muster der Daten. Wenn Sie die Arbeiten am Layout des Berichts beendet haben, öffnen Sie den Bericht in der Seitenansicht, um die Daten zu überprüfen.

Typischerweise erstellen und verbreiten Sie Berichte nach einem Zeitplan gemäß regelmäßiger Geschäftsabläufe wie z. B. wöchentliche Aktienkurs-Erinnerungen, monatliche Verkaufsberichte oder Finanzberichte einmal pro Quartal. Erstellen und verbreiten Sie diese Berichte als Snapshot-Dateien für Berichte in einer Batchdatei. Benutzer können den Snapshot Viewer zum Anzeigen und Ausdrucken der Berichte verwenden. Wenn Ihre Benutzer ganz aktuelle Berichte benötigen, verwenden Sie gruppierte Datenzugriffsseiten.

Zurück zum Anfang

Weitere Informationen

Tipps zur Leistungsoptimierung einer Datenzugriffsseite

Optimieren der Leistung von Visual Basic-Code

Zurück zum Anfang


 Dokumentation zu Microsoft SQL Server

Dokumentation zu Microsoft SQL Server

Microsoft Access dokumentiert in seinem Hilfesystem sowie im Microsoft Office 2000/Visual Basic Programmiererhandbuch die Verfahren zur Verwendung und Programmierung eines Microsoft Access-Projekts, das mit einer Microsoft SQL Server-Datenbank verbunden ist. Unter Umständen benötigen Sie außerdem spezielle Produktinformationen über SQL Server. Die Dokumentation zu SQL Server beinhaltet die folgenden Informationen:

Komponente | Beschreibung
Online-Bücher | Umfassende Dokumentation für SQL Server 7.0, einschließlich Programmiererhandbuch und Referenzteil zu Transact-SQL, einer Übersicht zu SQL Server sowie allgemeinen Benutzeranleitungen zu SQL Server.
Online-Hilfe mit Transact-SQL-Referenz | Referenzinformationen zur Transact-SQL-Syntax. Anmerkung Diese Hilfeinformationen sind ebenfalls über das Inhaltsfenster der Access-Online-Hilfe verfügbar.
SQL Server-Fehlermeldungen | Referenzinformationen über SQL Server-Fehlermeldungen, Fehlernummern und Maßnahmen zur Fehlerbehebung. Anmerkung Diese Hilfeinformationen sind auch über das Inhaltsfenster der Access-Online-Hilfe verfügbar.
Hilfe für Enterprise Manager | Hilfeinformationen zur Verwaltung einer SQL Server-Datenbank.
Replikations-Assistent | Hilfeinformationen zum Konfigurieren und Verwalten von Replikationen.
Hilfe für Client-Konfigurationsprogramm | Hilfeinformationen zum Verwalten von Netzwerk-Optionen für SQL Server.
Hilfe für ODBC-Treiber | Hilfeinformationen zum Erstellen von ODBC-Datenquellendefinitionen für SQL Server.
Hilfe für Profiler | Hilfeinformationen zum Erfassen von SQL Server-Ereignissen mit Hilfe einer Protokolldatei und deren Analyse bzw. Anzeige.
Hilfe für Query Analyzer | Hilfeinformationen zu einer grafischen Benutzeroberfläche, die der interaktiven Erstellung und testweisen Ausführung von Transact-SQL-Anweisungen, -Dateien und -Skripten dient.
Hilfe für Data Transformation Services (DTS) Designer | Hilfeinformationen zum Importieren, Exportieren und Umwandeln einer Vielzahl von Datenquellen.
SQL-DMO | Kontextabhängige Hilfeinformationen der Entwicklungsumgebung zu SQL-DMO-Objekten, -Eigenschaften und -Methoden.
Beispieldatenbank "The Pubs" | Die herkömmliche Beispieldatenbank für SQL Server.
Beispieldatenbank "Nordwind" für SQL Server | Eine neue Beispieldatenbank mit denselben Tabellen wie die gleichnamige Access-Beispieldatenbank sowie zusätzlichen speziellen SQL Server-Beispielen.


 Verwenden eines Microsoft Access-Projekts innerhalb einer Mehrbenutzerumgebung

Verwenden eines Microsoft Access-Projekts innerhalb einer Mehrbenutzerumgebung

Es gibt mehrere Arten der gemeinsamen Nutzung von Daten in einem Microsoft Access-Projekt (.adp), und es sind mehrere Überlegungen zu berücksichtigen, wenn die Arbeit mit dem Projekt in einer Mehrbenutzerumgebung erfolgen soll. Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Verwenden eines Microsoft Access-Projekts innerhalb einer Mehrbenutzerumgebung

Handhabung paralleler Aktualisierungen

Gemeinsame Nutzung einer Microsoft SQL Server-Datenbank über das Internet

Replizieren einer SQL Server-Datenbank

Verwenden eines Microsoft Access-Projekts innerhalb einer Mehrbenutzerumgebung

In eine Mehrbenutzerumgebung benötigt jeder Benutzer seine eigene Kopie der Access-Projektdatei, die mit derselben Microsoft SQL Server-Datenbank verbunden ist. Eine Access-Projektdatei kann nicht von zwei oder mehreren Benutzern gemeinsam genutzt werden.

Beim Öffnen eines Access-Projekts gilt immer der exklusive Zugriffsmodus. Hat ein anderer Benutzer als erster die Access-Projektdatei geöffnet, und Sie versuchen, dasselbe Access-Projekt zu öffnen, während der andere Benutzer es noch geöffnet hält, werden Sie von Access über eine entsprechende Meldung davon in Kenntnis gesetzt, dass die Datei bereits exklusiv geöffnet wurde. Sie erhalten dann die Möglichkeit, eine schreibgeschützte Kopie zu öffnen.

Praktisch übergeben Sie jedem Benutzer eine Kopie der Access-Projektdatei, wenn Sie eine gemeinsam genutzte Anwendung ausführen. In diesem Fall verfügt jeder Benutzer über eigene Kopien der Formulare, Berichte, Datenzugriffsseiten, Makros und Module. Aber tatsächlich teilen sie sich die Nutzung einer SQL Server-Datenbank sowie der darin enthaltenene Tabellen, Sichten, gespeicherten Prozeduren und Datenbankdiagramme. Deshalb ist es in einer Mehrbenutzerumgebung wichtig, für diese gemeinsam genutzen Datenbankobjekte die geeigneten Sicherheitsvorkehrungen zu treffen, damit die Integrität dieser Objekt nicht verletzt wird. Informationen über das Sichern eines Access-Projekts.

Zurück zum Anfang

Handhabung paralleler Aktualisierungen

In einer Mehrbenutzerumgebung können mehrere Benutzer gleichzeitig an denselben Datensätzen arbeiten. Da es vorkommen kann, dass die Daten, die Sie gerade bearbeiten, von anderen Benutzern geändert oder sogar gelöscht werden, kommt es gelegentlich zu Konfliktsituationen. Ein Access-Projekt verwendet eine als optimistische Datensatzsperrung bezeichnete Technik, um Konflikte beim Zugriff auf Datensätze zu handhaben.

Wenn Sie einen Datensatz ändern und eine andere Person aktualisiert diesen Datensatz, bevor Sie ihn speichern, zeigt Access eine Warnmeldung an, die Sie darauf hinweist, dass Sie die Änderungen des anderen Benutzers überschreiben, wenn Sie den Datensatz speichern. Sie haben dann folgende Möglichkeiten:

  • Drücken Sie Datensatz speichern, um den Datensatz zu speichern und die Änderungen des anderen Benutzers zu überschreiben.

  • Drücken Sie In Zwischenablage kopieren, um zuerst zu analysieren, welche Änderungen der andere Benutzer vorgenommen hat, so dass Sie diese Änderungen mit Ihren aktuellen Änderungen abstimmen können.

  • Drücken Sie Eigene Änderungen verwerfen, um Ihre eigenen Änderungen zu ignorieren und die Änderungen des anderen Benutzers zu akzeptieren.

Da andere Benutzer die Datensätze, die Sie bearbeiten, ebenfalls ändern, löschen oder um neue Datensätze ergänzen können, sollten Sie in regelmäßigen Abständen die Datenanzeige in der Datenblattansicht oder Formularansicht aktualisieren, indem Sie den Befehl Aktualisieren (im Menü Datensätze) verwenden, um die Abfrage neu zu starten und aktualisierte Daten anzuzeigen.

Zurück zum Anfang

Gemeinsame Nutzung einer Microsoft SQL Server-Datenbank über das Internet

Sie können Datenzugriffsseiten erstellen oder eines oder mehrere Datenbankobjekte in Form einer serverseitig generierten oder statischen HTML-Datei ausgeben. Diese Webseiten lassen sich mit einem Browser, beispielsweise Microsoft Internet Explorer, anzeigen und ermöglichen auch den Datenzugriff. Informationen über die drei Arten von Webseiten, die Microsoft Access erstellt.

Zurück zum Anfang

Replizieren einer SQL Server-Datenbank

Bei Verwendung mehrerer Computer, beispielsweise einem Arbeitsplatzrechner und einem Laptop, können Sie Replikate Ihrer SQL Server-Datenbank erstellen und diese Replikate synchronisieren. Mehrere Benutzer, die sich an verschiedenen Orten aufhalten, können gleichzeitig mit ihren eigenen Kopien einer Master-Datenbank arbeiten und diese Kopien dann über das Netzwerk synchronisieren. Die Synchronisation kann über eine Einwählverbindung oder über das Internet erfolgen. Informationen über die Datenreplikation in einem Microsoft Access-Projekt .

Zurück zum Anfang


 Datenaktualisierung in einem Microsoft Access-Projekt oder einer Datenzugriffsseite

Datenaktualisierung in einem Microsoft Access-Projekt oder einer Datenzugriffsseite

Microsoft Access aktualisiert Daten in einem Microsoft Access-Projekt oder einer Datenzugriffsseite auf andere Weise als Daten in einer Microsoft Access-Datenbank. Sowohl Benutzer als auch Programmierer sollten sich dieser Unterschiede bewusst sein. Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Allgemeine Regeln für das Aktualisieren von Daten

Arbeiten mit aktualisierungsfähigen Snapshots

Anzeigen aktualisierter Feldwerte

Empfohlene Vorgehensweisen zum Aktualisieren verknüpfter Daten

Allgemeine Regeln für das Aktualisieren von Daten

Die folgenden Regeln gelten für das Aktualisieren von Daten in einem Access-Projekt und für das Aktualisieren von Daten einer Datenzugriffsseite, die entweder mit einer Access-Datenbank oder mit einer Microsoft SQL Server-Datenbank verbunden ist:

  • Um irgendein Feld (einschließlich des Primärschlüsselfelds) in einer einzelnen Tabelle oder Basistabelle einer Verknüpfung zu aktualisieren, muss für diese Tabelle per Constraint ein eindeutiges Feld oder eine eindeutige Felderkombination als Primärschlüssel, als eindeutiger Schlüssel oder als eindeutiger Index qualifiziert sein.

  • Daten in einem Formular oder Bericht, die auf einer 1:n-Beziehung basieren, können aktualisiert werden, aber nur für Felder der Tabelle auf der rechten Seite der Beziehung. Wenn Sie eine Sicht oder eine Gespeicherte Prozedur, die eine Beziehung enthält, in der Datenblattansicht öffnen bzw. ausführen, besteht standardmäßig Schreibschutz. Allerdings können Sie die Daten eines Formulars oder einer Seite, die aus einer Datenquellen-Verbindung mit einer Sicht oder gespeicherten Prozedur stammen, aktualisieren, indem Sie die Eindeutige Tabelle-Eigenschaft des Formulars oder der Seite entsprechend setzen (siehe die Erläuterung weiter unten).

  • Um eine Sicht oder eine gespeicherte Prozedur zu aktualisieren, müssen Sie UPDATE-, INSERT- und DELETE-Berechtigungen für die in der Sicht oder Prozedur verwendeten Basistabellen besitzen. Außerdem müssen Sie für die Sicht über die SELECT-Berechtigung sowie über die EXECUTE-Berechtigung für die Prozedur verfügen.

  • In einer Seite mit Datensatzgruppierung können die Daten nicht aktualisiert werden. Nur Daten in Seiten ohne Gruppierung lassen sich aktualisieren.

  • Unter keinen Umständen können Daten aktualisiert werden, die von einer Reflexivverknüpfung abgeleitet sind (bespielsweise alle Mitarbeiter und die Vorgesetzten, denen sie berichten).

  • Gleiches gilt für eine Access-Datenbank:
    • Es ist nicht möglich, ein Formular, Datenblatt oder eine Seite zu aktualisieren, wo die zugrunde liegende SQL-Anweisung der Datensatzquelle eine GROUP BY- oder COMPUTE-Klausel enthält.

    • Sie können keine Felder aktualisieren, die auf Ausdrücken basieren (beispielsweise "Preis * Anzahl AS Gesamt_Preis").

    • Sie können kein Formular, Datenblatt und keine Seite aktualisieren, wo die Daten auf einer 1:n-Beziehung beruhen.

Zurück zum Anfang

Arbeiten mit aktualisierungsfähigen Snapshots

Access 2000 unterstützt in einem aktualisierungsfähigen Snapshot, der das Ergebnis einer 1:n-Beziehung in einer Sicht, das Zeilenresultat einer Gespeicherten Prozedur oder einer SQL-Anweisung darstellt, nur das Einfügen, Löschen und Aktualisieren von Daten innerhalb einer Zeile der eindeutigen Tabelle (also Daten aus Feldern der rechten Seite der Beziehung). Access 2000 verbietet die Aktualisierung von Feldern der linken Seite einer 1:n-Beziehung.

Ein Formular oder eine Seite auf der Grundlage einer 1:n-Beziehung muss die Eindeutige Tabelle-Eigenschaft definieren, um die Aktualisierbarkeit der Datensatzgruppe zu gewährleisten. Die eindeutige Tabelle bildet die rechte Seite einer 1:n-Beziehung. Sie wird als eindeutige Tabelle bezeichnet, da jedem Datensatz der eindeutigen Tabelle höchstens ein Datensatz in den Ergebnissen der Sicht, gespeicherten Prozedur oder der SQL-Anweisung entspricht. Beispielsweise stellt in einer Sicht, die zwei Tabellen namens Kunden und Bestellungen miteinander verknüpft, die Tabelle Bestellungen die eindeutige Tabelle dar, da jeder Bestellung (jedem Datensatz der Tabelle Bestellungen) höchstens ein Datensatz in der Sicht entspricht. Umgekehrt können einem Datensatz in der Tabelle Kunden mehrere Datensätze in der Sicht zugeordnet sein.

Des weiteren gilt bei Verwendung einer Gespeicherten Prozedur oder einer parametrisierten SQL-Anweisung als Datensatzquelle, dass Sie zur Anzeige der aktuellen Werte eines aktualisierten Datensatzes zusätzlich die ResyncBefehl-Eigenschaft setzen müssen. Wenn Sie in diesen Fällen die ResyncBefehl-Eigenschaft nicht setzen, ergeben sich keine weiteren Folgen, außer dass für einen aktualisierten oder neu eingefügten Datensatz die aktuellen Werte nicht angezeigt werden. Das Aktualisieren oder Einfügen wird in jedem Fall korrekt ausgeführt. Bei anderen Arten von Datensatzquellen zeigt Access immer die aktuellen Werte an, selbst wenn die ResyncBefehl-Eigenschaft nicht gesetzt wird.

Was die Datenanzeige in einem aktualisierungsfähigen Snapshot angeht, so sehen Sie bei einem bearbeiteten oder neu eingefügten Datensatz nur dann die aktuellen Werte, wenn dieser Datensatz erfolgreich gespeichert worden ist (siehe die Erklärung weiter unten). Die Tabelle Bestellungen beispielsweise enthält eine Identität (ID)-Spalte als Primärschlüssel. Bei Einfügungen in diese Tabelle wird der neue Wert für Bestell-Nr erst angezeigt, wenn Sie den Datensatz speichern oder zu einem anderen Datensatz wechseln (wodurch der Datensatz implizit gespeichert wird). Ähnliches gilt für ein Formular, dessen Daten aus einer Verknüpfung von Bestellungen und Kunden stammen. Wenn Sie hier das Feld Bestell-Nr durch einen neuen Kunden-Code aktualisieren, zeigt das Feld Adresse die Adresse des neuen Kunden erst dann an, nachdem der Datensatz gespeichert worden ist.

Schließlich ist zu beachten, dass alle Schlüsselfelder bzw. die EindeutigeTabelle in der Auswahlliste der SQL-Anweisung auftauchen müssen (allerdings nicht unbedingt sichtbar). Außerdem müssen Sie alle NOT NULL-Spalten auswählen, für die keine Server-Standardwerte definiert sind, und für diese Spalten Werte in der Datensatzgrupppe bereitstellen. Letzeres gilt nicht für Felder, deren Identität (ID)-Eigenschaft gesetzt ist.

Zurück zum Anfang

Anzeigen aktualisierter Feldwerte

Beim Aktualisieren von Feldern in Formularen, Datenblättern oder Seiten kann Access in der Regel automatisch einen Wert (beispielsweise einen Standardwert, ein berechnetes Feld, einen Zeitstempelwert, ein Identität (ID)- oder Autowert-Feld) oder eine von einem Trigger ausgeführte Aktion einfügen. Allerdings erfolgt im Gegensatz zu einer Access-Datenbank die Anzeige des Werts oder des Resultats der Triggeroperation erst, nachdem Sie den Datensatz festschreiben, da Access das Feld zuerst beim Server aktualisieren (bzw. dort die Operation durchführen) muss, bevor die Aktualisierung der Anzeige beim Client erfolgt.

Zurück zum Anfang

Empfohlene Vorgehensweisen zum Aktualisieren verknüpfter Daten

Hinsichtlich der Aktualisierung verknüpfter Daten wird Folgendes empfohlen:

  • AutoFormular ist ein bequemes Mittel zum Erstellen eines Formulars, das die Aktualisierung einer Sicht oder gespeicherten Prozedur auf der Grundlage verknüpfter Tabellen ermöglicht. Verwenden Sie AutoFormular zur schnellen Erstellung des Formulars, und wechseln Sie dann in die Entwurfsansicht, um die Eindeutige Tabelle-Eigenschaft zu setzen. Sie können zusätzlich noch die Standardansicht-Eigenschaft setzen, wenn Sie statt der Formularansicht die Datenblattansicht wünschen.

  • Um alle Daten in einer 1:n-Beziehung zu aktualisieren, können Sie eine Kombination aus Formular und Unterformular erstellen. Anstatt beispielsweise die aus einer Verknüpfung von Bestellungen und Kunden (in diesem Fall wären die Kunden-Felder schreibgeschützt) resultierenden Daten in einem einzelnen Formular anzuzeigen, können Sie ein Formular für die Kundendaten und ein Unterformular für die Bestelldaten erstellen. Da eine Formular/Unterformular-Kombination zwei verschiedene Datensatzgruppen verwendet, lassen sich alle Felder aktualisieren. Außerdem können Sie diese Formular/Unterformular-Kombination als Datenblatt mit einem Unterdatenblatt anzeigen.

  • Innerhalb einer Seite können Sie eine Formular/Unterformular-Kombination simulieren, indem Sie zwei Seiten über ein Hyperlink-Feld miteinander verknüpfen und dann mit Microsoft FrontPage zwei Frames erstellen, jeweils einen für jede Seite.

Zurück zum Anfang


 Vergleich der Datenbankobjekte einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts

Vergleich der Datenbankobjekte einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts

Die folgende Tabelle vergleicht die Datenbankobjekte einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts miteinander.

Access-Datenbank | Access-Projekt
Tabelle | Tabelle
Auswahlabfrage | Sicht
Aktionsabfrage Parameterabfrage | Gespeicherte Prozedur
Beziehung | Datenbankdiagramm
Formular | Formular
Bericht | Bericht
Datenzugriffsseite | Datenzugriffsseite
Makro | Makro
Modul | Modul

Anmerkung Tabellen, Sichten, Gespeicherte Prozeduren und Datenbankdiagramme werden physikalisch in der Microsoft SQL Server-Datenbank gespeichert, die mit dem Access-Projekt verbunden ist. Der folgende Hyperlink führt zu Informationen über Access-Projekte.


 Vergleich von Datentypen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

Vergleich von Datentypen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

In der folgenden Tabelle werden Datentypen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt verglichen.

Siehe auch Access-Datentypen.

Siehe auch SQL Server-Datentypen.

Microsoft Access-Datentypen | SQL Server-Datentypen
Ja/Nein | Bit
Zahl (Byte) | tinyint
Zahl (Integer) | smallint
Zahl (Long Integer) | int
Zahl (Single) | real
Zahl (Double) | float
Währung | money smallmoney
Dezimal/Numerisch | Dezimal Numerisch
Datum/Uhrzeit | datetime smalldatetime
AutoWert (Inkrement) | int (mit definierter Identity-Eigenschaft)
Text (n) | varchar(n) nvarchar(n)
Memo | Text
OLE-Objekt | image
Replikations-ID (auch als GUID (Globally Unique Identifier) bezeichnet) | uniqueidentifier (nur in SQL Server 7.0)
Hyperlink | ntext (Hyperlink ist jedoch nicht aktiv)
(Kein Äquivalent) | nchar
(Kein Äquivalent) | varbinary
(Kein Äquivalent) | Benutzerdefiniert
(Kein Äquivalent) | smallint
(Kein Äquivalent) | timestamp
(Kein Äquivalent) | char nchar

Anmerkungen

  • In einem Access-Projekt steht das Präfix "n" für "national". Dies bedeutet, dass es sich um einen Unicode-aktivierten Datentyp handelt. In einer Access-Datenbank sind alle Textspalten standardmäßig Unicode-aktiviert.

  • Dem AutoWert-Datentyp in einer Access-Datenbank entspricht in einem Access-Projekt der int-Datentyp mit definierter Identity-Eigenschaft. Dieser Datentyp enthält vom System erzeugte sequenzielle Werte, die jede Zeile innerhalb einer Tabelle eindeutig identifizieren (z.B. Mitarbeiter-Identifikationsnummern). Werden in eine Tabelle mit einer Identity-Spalte Werte eingefügt, erzeugt Access den nächsten Feldwert automatisch auf der Grundlage des zuletzt verwendeten (über die Eigenschaft Identity Seed eingestellten) Identity-Wertes sowie des (über die Eigenschaft Identity Increment eingestellten) Inkrementwertes, der beim Erstellen einer Spalte festgelegt wurde. Damit sich dieser Datentyp wie der AutoWert-Datentyp verhält, stellen Sie für die Eigenschaften Identity Seed und Identity Increment den Wert 1 ein.

  • Microsoft Access speichert entweder null (0) oder minus eins (-1) im Ja/Nein-Datentyp einer Access-Datenbank. Eine Access-Datenbank interpretiert 0 als 0, Nein oder Falsch, alle anderen Werte als -1, Ja oder Wahr. Im Gegensatz dazu speichert SQL Server entweder null (0) oder plus eins (+1) im bit-Datentyp. Ein Access-Projekt interpretiert 0 als Falsch und +1 als Wahr.

  • Obwohl der ntext-Datentyp keine aktiven Hyperlinks speichert, können Sie einen Hyperlink auf einem Formular in einem Access-Projekt aktivieren, indem Sie ein Steuerelement an ein beliebiges Textfeld binden und für die Eigenschaft IstHyperlink den Wert Wahr einstellen.


 Vergleich der Trennzeichen, Operatoren, Konstanten und Platzhalterzeichen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

Vergleich der Trennzeichen, Operatoren, Konstanten und Platzhalterzeichen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt

In dieser Tabelle werden Trennzeichen, Operatoren, Konstanten und Platzhalterzeichen in einer Microsoft Access-Datenbank und einem Microsoft Access-Projekt verglichen.

Beschreibung | Access-Datenbank | Access-Projekt
Datumstrennzeichen | Nummernzeichen (#) | Einfaches Anführungszeichen (')
Zeichenfolgentrennzeichen | Entsprechende einfache Anführungszeichen (') oder entsprechende doppelte Anführungszeichen (") | Entsprechende einfache Anführungszeichen (')
Mod-Operator | mod | Prozentzeichen (%)
Verkettungsoperator | Kaufmännisches Und-Zeichen (&) | Pluszeichen (+)
Platzhalterzeichen (entspricht einem einzelnen Zeichen) | Fragezeichen (?) | Unterstrich (_)
Platzhalterzeichen (entspricht null oder mehr Zeichen) | Sternchen (*) | Prozentzeichen (%)
Konstante | Ja | 1
Konstante | Ein | 1
Konstante | Wahr | 1
Konstante | Nein | 0
Konstante | Aus | 0
Konstante | Falsch | 0


 Vergleich der SQL-Syntax von Microsoft Access und SQL Server

Vergleich der SQL-Syntax von Microsoft Access und SQL Server

Die folgende Tabelle fasst wichtige Unterschiede zwischen der SQL-Syntax von Microsoft Access und Microsoft SQL Server zusammen und illustriert, wie der Upsizing-Assistent diese Unterschiede handhabt. Sie können diese Übersichtsinformationen auch verwenden, wenn Sie manuell SQL-Anweisungen einer Microsoft Access-Datenbankanwendung in den SQL-Code einer Microsoft Access-Projektanwendung konvertieren.

Element der SQL-Syntax Microsoft
Access 		Microsoft SQL
Server 		Upsizing-Assistent
Bezeichner Obergrenze von 64 Zeichen.

Schlüsselwörter und Sonderzeichen erlaubt.

Beliebiges Zeichen am Anfang erlaubt.

 SQL Server 6.5:
  • Obergrenze von 30 Zeichen.

  • Schlüsselwörter und Sonderzeichen nicht erlaubt.
  • Bezeichner muss mit Buchstaben beginnen.

SQL Server 7.0 ist voll kompatibel mit Access-Bezeichnern.

 Konvertiert in SQL Servernamen, falls erforderlich.
Ausgabefelder | Mehrere Ausgabefelder mit demselben Namen zulässig. | Keine Unterstützung für mehrere Ausgabefelder mit demselben Namen in Sichten. | Fügt Aliasnamen für doppelte Spaltennamen hinzu.
Datumstrennzeichen | Nummernzeichen (#) | Apostroph (') | Konvertiert Trennzeichen.
Boolesche Konstanten | True, False; On, Off; Yes, No | Integerwerte: 1 (true), 0 (false) | Konvertiert Konstanten.
Zusammensetzen von Zeichenfolgen Kaufmännisches Und (&) Pluszeichen (+) Konvertiert Zeichen.

Anmerkung Unter SQL Server wird das Kaufmännische Und-Zeichen (&) für bitweise logische UND-Operationen verwendet.
Platzhalter Sternchen (*) steht für 0 oder mehr Zeichen.

Fragezeichen (?) steht für ein einzelnes Zeichen.

Ausrufezeichen (!) steht für jedes Zeichen, das nicht in der folgenden Liste enthalten ist.

Nummernzeichen (#) steht für einzelne Ziffer.

 Prozentzeichen (%) steht für 0 oder mehr Zeichen.

Unterstrichzeichen (_) steht für ein einzelnes Zeichen.

Zirkumflexzeichen (^) steht jedes Zeichen, das nicht in der folgenden Liste enthalten ist.

Kein Äquivalent zum Nummernzeichen (#).

 Konvertiert Zeichen.

Konvertiert Nummernzeichen (#) in den Ausdruck [0-9], der für eine einzelne Ziffer steht.
TOP Schließt bei Anwesenheit einer ORDER BY-Klausel automatisch Bindungen ein. SQL Server 6.5 unterstützt dieses Prädikat nicht.

SQL Server 7.0 erfordert eine explizite WITH TIES-Klausel.

 Für SQL Server 6.5 werden alle Abfragen mit TOP-Prädikat ignoriert.

Für SQL Server 7.0 wird an das Ende jeder mit TOP qualifizierten Abfrage, die eine ORDER BY-Klausel enthält, eine WITH TIES-Klausel gehängt.

CREATE INDEX Indizes mit auf- und absteigender Sortierung sind zulässig.

Bei der Indexdeklaration können die Optionen PRIMARY, NO NULL und IGNORE NULL angegeben werden.

 Konvertiert Index.
DROP INDEX Syntax lautet:

Drop Index <Indexname> ON <Tabellenname>

 Syntax lautet:

Drop Index <Tabellenname>, <Indexname>

 Wird nicht konvertiert.
DISTINCTROW | Wird unterstützt (ermöglicht die Auswahl eindeutiger Datensätze). | Wird nicht unterstützt. | Wird nicht konvertiert.
OWNERACCESS | Wird unterstützt (überwacht Berechtigungen während der Ausführung). | Wird nicht unterstützt. | Wird aus SQL-Anweisung entfernt.
Tabelle in UNION-Abfrage Wird unterstützt. Ermöglicht die Angabe von Tabellen durch folgende Syntax:

TABLE <Tabellenname>

Wird nicht unterstützt. Wird nicht konvertiert.
ORDER BY in Union-Abfragen | Wird unterstützt. Ermöglicht mehrere ORDER BY-Klauseln in UNION-Abfragen. | Wird unterstützt. Ermöglicht nur eine ORDER BY-Klausel am Ende der Anweisung. | Wird nicht konvertiert.
TRANSFORM | Wird unterstützt. Verwendet für Kreuztabellenabfragen. | Wird nicht unterstützt. | Wird nicht konvertiert.
PARAMETERS | Wird unterstützt (Ausgabe in SQL). | Wird nicht unterstützt. | Entfernt explizit deklarierte Parameter aus der SQL-Zeichenfolge.


Vergleich der Funktionen von Visual Basic für Applikationen und Microsoft SQL Server Transact-SQL

In der folgenden Tabelle werden die Funktionen von VBA (Microsoft Visual Basic für Applikationen) und Microsoft SQL Server Transact-SQL verglichen. Beachten Sie, dass der Upsizing-Assistent die folgenden VBA-Funktionen (die in Gültigkeitregeln für Tabellen, Felder und Standards auftreten können) in Transact-SQL-Funktionen konvertiert. Zu folgenden Themen stehen Informationen zur Verfügung:

Funktionen für Zeichenfolgen

Funktionen für Konvertierungen

Funktionen für Datumsangaben

Mathematische Funktionen

Funktionen für Zeichenfolgen

Visual Basic-Funktionen | Transact-SQL-Funktionen
asc(x) | ascii(x)
chr$(x) | char(x)
lcase$(x) | lower(x)
len(x) | datalength(x)
ltrim$( x) | ltrim(x)
mid$(x,y,z) | substring(x,y,z)
right$(x,y) | right(x,y)
rtrim$(x) | rtrim(x)
space$( x) | space(x)
str$(x) | str(x)
ucase$( x) | upper(x)

Zurück zum Anfang

Funktionen für Konvertierungen

Visual Basic-Funktionen | Transact-SQL-Funktionen
ccur(x) | convert(money,x)
cdbl(x) | convert(float,x)
cint(x) | convert(smallint,x)
clng(x) | convert(int,x)
csng(x) | convert(real,x)
cstr(x) | convert(varchar,x)
cvdate(x) | convert(datetime,x)

Zurück zum Anfang

Funktionen für Datumsangaben

Visual Basic-Funktionen | Transact-SQL-Funktionen
date(x ) | convert(datetime,convert(varchar,getdate(x)))
dateadd("<Access datepart>", x, y) | dateadd(<SQL Server datepart>, x, y)
datediff("<Access datepart>", x, y) | datediff(<SQL Server datepart>, x, y)
datepart("<Access datepart>", x) | datepart(<SQL Server datepart>, x)
day(x) | datepart(dd,x)
hour(x) | datepart(hh,x)
minute(x) | datepart(mi,x)
month(x) | datepart(mm,x)
now(x) | getdate(x)
second(x) | datepart(ss,x)
weekday(x) | datepart(dw,x)
year(x) | datepart(yy,x)

Zurück zum Anfang

Mathematische Funktionen

Visual Basic-Funktionen | Transact-SQL-Funktionen
int(x) | floor(x)
sgn(x) | sign(x)

Zurück zum Anfang


 Wann ist Upsizing einer Microsoft Access-Datenbank auf Microsoft SQL Server sinnvoll?

Wann ist Upsizing einer Microsoft Access-Datenbank auf Microsoft SQL Server sinnvoll?

Mit der Zeit wachsen die meisten Datenbankanwendungen, nehmen an Komplexität zu und müssen höhere Benutzerzahlen unterstützen. Ab einem gewissen Punkt im Leben Ihrer Microsoft Access-Datenbank-Anwendung sollten Sie ein Upsizing auf Microsoft SQL Server in Betracht ziehen, um die Datenbank- und Anwendungsleistung, Skalierbarkeit, Sicherheit, Integrität, Wiederherstellbarkeit und Verfügbarkeit zu optimieren. In diesem Thema finden Sie Referenzinformationen zu den Hauptgründen für ein Upsizing auf eine SQL Server-Datenbank.

Hohe Performance und Skalierbarkeit

Erhöhte Verfügbarkeit

Verbesserte Sicherheit

Sofortige Wiederherstellbarkeit

Zuverlässig verteilte Daten und Transaktionen

Serverbasierte Verarbeitung

Hohe Performance und Skalierbarkeit

In vielen Situationen bietet Microsoft SQL Server eine bessere Performance als eine Access-Datenbank. SQL Server unterstützt auch sehr umfangreiche Datenbanken bis zu einem Terabyte, was natürlich erheblich größer ist als das derzeitige Limit von zwei Gigabyte für Access-Datenbanken. Darüber hinaus arbeitet SQL Server sehr effizient unter Microsoft Windows NT durch parallele Verarbeitung von Abfragen (mit Hilfe mehrerer nativer Threads in einem einzelnen Prozess bei der Bearbeitung von Benutzeranfragen) und durch Minimierung zusätzlicher Speicheranforderungen beim Hinzukommen weiterer Benutzer.

Zurück zum Anfang

Erhöhte Verfügbarkeit

Mit Microsoft SQL Server können Sie während des Betriebs dynamische Backups der Datenbank durchführen, inkrementell oder vollständig. Infolgedessen müssen Benutzer vor der Datensicherung nicht mehr aufgefordert werden, die Datenbank zu verlassen. Dies bedeutet, dass die Datenbank an allen sieben Tagen der Woche rund um die Uhr in Betrieb sein kann.

Zurück zum Anfang

Verbesserte Sicherheit

Microsoft SQL Server kann in die Windows NT-Betriebssystemsicherheit integriert werden, was das Anmelden am Netzwerk und bei der Datenbank in einem einmaligen Vorgang ermöglicht. Dadurch wird auch die Verwaltung komplexer Sicherheitsschemen enorm vereinfacht. Eine SQL Server-Datenbank auf einem Server ist zudem besser geschützt, da unautorisierte Benutzer nicht sofort auf die Datenbank zugreifen können, sondern sich zunächst Zugang zum Server verschaffen müssen.

Zurück zum Anfang

Sofortige Wiederherstellbarkeit

Für das Eintreten von Systemausfällen (etwa Betriebssystemabstürzen oder Stromausfällen) verfügt Microsoft SQL Server über einen automatischen Wiederherstellungsmechanismus, der die Datenbank binnen weniger Minuten in den letzten Konsistenzzustand wiederherstellt, ohne dass ein Eingriff des Datenbankadministrators erforderlich ist. Kritische Anwendungen sind sofort wieder betriebsbereit.

Zurück zum Anfang

Zuverlässig verteilte Daten und Transaktionen

Transaktionsverarbeitung ist eine lebenswichtige Anforderung für ein System, das für die Unterstützung kritischer Anwendungen wie Bankgeschäfte und Online-Auftragseingänge konzipiert ist. Microsoft SQL Server unterstützt elementare Transaktionen mit Transaktionsprotokollierung, wodurch sicher gewährleistet ist, dass alle Änderungen, die innerhalb einer Transaktion ausgeführt wurden, entweder festgeschrieben oder zurückgesetzt werden.

Die Konsistenz und Wiederherstellbarkeit von Datenbanktransaktionen sind selbst bei Eintreten eines Systemausfalls oder während der komplexesten Updates durch mehrere Benutzer garantiert. SQL Server behandelt sämtliche Datenbankänderungen innerhalb einer Transaktion als einzelne Arbeitseinheit. Per Definition wird entweder eine komplette Transaktion sicher abgeschlossen und alle resultierenden Änderungen in der Datenbank wiedergegeben, oder die Transaktion wird zurückgesetzt und alle Änderungen an der Datenbank werden rückgängig gemacht.

Dank eines zweiphasigen Festschreibungsprotokolls unterstützt SQL Server sogar synchronisierte Transaktionen über mehrere Server hinweg - bei voller Gewährleistung des konsistenten Zustandes aller Server im Netzwerk.

Zurück zum Anfang

Serverbasierte Verarbeitung

Microsoft hat Microsoft SQL Server von Anfang an als Client/Server-Datenbank konzipiert. Daten und Indizes befinden sich auf einem einzelnen Server-Computer, auf den viele Client-Computer ständig über das Netzwerk zugreifen. SQL Server reduziert den Netzwerkverkehr, indem Datenbankabfragen auf dem Server verarbeitet und nur die Ergebnisse an den Client geschickt werden. Auf diese Weise kann Ihre Client/Server-Anwendung die Verarbeitung dort ausführen, wo sie am besten geleistet werden kann - auf dem Server.

Ihre Anwendung kann auch gespeicherte Prozeduren und Trigger einsetzen, damit Anwendungslogik, Geschäftsregeln und -richtlinien, komplexe Abfragen sowie Code für Gültigkeitsprüfungen und referenzielle Integrität nicht auf dem Client, sondern auf dem Server zentral verwaltet und gemeinsam genutzt werden können.

Zurück zum Anfang


 Upsizing einer Microsoft Access-Datenbank

Upsizing einer Microsoft Access-Datenbank

Upsizing bezeichnet die Vorgänge bei der Übertragung (Migration) einiger oder aller Datenbankobjekte einer Microsoft Access-Datenbank (.mdb) auf eine neue oder vorhandene Microsoft SQL Server-Datenbank oder ein neues Microsoft Access-Projekt (.adp). Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Upsizing-Methoden

Der Upsizing-Assistenten-Bericht

Konvertieren von Anwendungscode

Weitere Fragen

Upsizing-Methoden

Der Upsizing-Assistent konvertiert eine Access-Datenbank in eine neue oder bestehende Microsoft SQL Server 6.5/ 7.0-Datenbank bzw. in ein neues Access-Projekt, indem er die Daten und Datendefinitionen überträgt und anschließend die Migration der Datenbankobjekte durchführt. Der Upsizing-Assistent lässt sich auf dreierlei Arten verwenden:

  • Nur Upsizing der Daten oder Datendefinitionen einer Access-Datenbank in eine SQL Server-Datenbank.

  • Erstellen eines Access-Front-End für eine SQL Server-Datenbank als Back-End. Diese Variante ermöglicht die Erstellung einer Front-End/Back-End -Anwendung.

  • Upsizing aller Datenbankobjekte einer Access-Datenbank in ein Access-Projekt. Diese Variante ermöglicht die Erstellung einer Client-/Server-Anwendung.

Zurück zum Anfang

Der Upsizing-Assistenten-Bericht

Der Upsizing-Assistent erstellt einen Bericht, der eine genaue Beschreibung aller generierten Objekte sowie aller dabei gegebenenfalls aufgetretenen Fehler enthält. Dieser Bericht wird vom Upsizing-Assistenten automatisch in Form eines Bericht-Snapshots erstellt. Der Bericht hat denselben Namen wie die Access-Datenbank (beispielsweise Nordwind.snp) und wird in demselben Ordner gespeichert.

Der Upsizing-Assistent enthält Informationen über Folgendes:

  • Details der Datenbank einschließlich Datenbankgröße, Transaktionsprotokoll, Gerätenamen und Größenangaben für eine SQL Server 6.5-Datenbank.

  • Upsizing-Parameter, einschließlich der für das Upsizing ausgewählten Tabellenattribute und die ausgewählte Upsizing-Methode.

  • Tabelleninformation, unter anderem ein Vergleich der von Access und SQL Server verwendeten Werte für Namen, Datentypen, Indizes, Gültigkeitsregeln, Standardeinstellungen und Trigger, sowie eine Angabe dazu, ob Zeitstempel hinzugefügt wurden oder nicht.

  • Informationen über alle aufgetretenen Fehler, insbesondere: Datenbank voll, Transaktionsprotokoll voll, Ungeeignete Berechtigungen, Gerät oder Datenbank nicht erstellt, Übergehen einer Tabelle, einer Standardeinstellung oder einer Gültigkeitsregel, Verknüpfung einer Beziehung nicht realisiert, Übergehen einer Abfrage (da sie nicht in die SQL Server-Syntax übersetzt werden konnte) sowie Fehler bei der Konvertierung von Steuerelementen und Datenquellen in Formularen und Berichten.

Zurück zum Anfang

Konvertieren von Anwendungscode

Entwurf und Erstellung einer optimierten Client-/Server-Anwendung unterscheiden sich von Entwurf und Erstellung einer optimierten Dateiserver-Anwendung. Deshalb werden Sie vermutlich Ihre Anwendung überarbeiten müssen, um alle Vorteile der Kombination von SQL Server und einem Access-Projekt nutzen zu können. Nach dem Upsizing müssen Sie in Ihrem Modulen manuell den Code von DAO (Data Access Objects)-Objekten in Code für ADO (ActiveX Data Objects)-Objekte transformieren und Abfragen konvertieren, die beim Upsizing nicht berücksichtigt wurden (beispielsweise jene, die eine zu große Verschachtelungstiefe aufwiesen). Weitere Informationen über die Entwicklung von optimierten Client-/Server-Anwendungen finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch

Zurück zum Anfang

Weitere Informationen

Vorbereitungen für das Upsizing einer Microsoft Access-Datenbank

Upsizing einer Microsoft Access-Datenbank

Optimieren der Leistung eines Microsoft Access-Projekts

Zurück zum Anfang


 Vorbereitungen für das Upsizing einer Microsoft Access-Datenbank

Vorbereitungen für das Upsizing einer Microsoft Access-Datenbank

Bevor Sie per Upsizing Ihre Microsoft Access-Datenbank in eine Microsoft SQL Server-Datenbank oder ein Microsoft Access-Projekt übertragen, sollten Sie Folgendes berücksichtigen:

Erstellen Sie eine Sicherungskopie Ihrer Datenbank Obwohl der Upsizing-Assistent keine Daten oder Datenbankobjekte Ihrer Access-Datenbank löscht, empfiehlt es sich doch, eine Sicherungskopie Ihrer Access-Datenbank zu erstellen, bevor Sie mit dem Upsizing beginnen.

Stellen Sie sicher, dass Sie über ausreichend freien Festplattenspeicherplatz verfügen Sie benötigen ausreichend Platz auf dem Datenträger, der die transformierte SQL Server-Datenbank aufnehmen soll. Der Upsizing-Assistent arbeitet am besten, wenn er über reichlich Speicherplatz auf der Festplattte verfügen kann.

Wenn Sie genug Festplattenspeicherplatz auf Ihrem Server zur Verfügung haben, multiplizieren Sie die Größe Ihrer Access-Datenbank mit 2, und reservieren Sie freien Speicherplatz in dieser Größenordnung auf Ihrer Festplatte. Auf diese Weise wird sichergestellt, dass der Upsizing-Assistent über genügend freien Speicherplatz zum Upsizing Ihrer Datenbank verfügt und außerdem noch Platz für das weitere Wachstum der neuen Datenbank übrig bleibt. Wenn Sie diesbezüglich mit großen zusätzlichem Datenvolumen rechnen, multiplizieren Sie mit einem größeren Faktor.

Achtung Wenn der Upsizing-Assistent während seiner Ausführung nicht mehr genügend Speicherplatz auf dem Server vorfindet, stoppt er den Vorgang, was zu einer nur teilweise eingerichteten Datenbank sowie zu nur teilweise definierten Laufwerken auf dem Server führen kann. Wenn dies passiert, können Sie die Laufwerke, Datenbanken und Tabellen mit Hilfe des Microsoft SQL Server Enterprise Managers entfernen.

Sofern erwünscht, erstellen Sie mehrere Festplattenlaufwerke Wenn das Upsizing-Ziel eine SQL Server 6.5-Datenbank ist, kann es wünschenswert sein, die Laufwerke vor der Ausführung des Upsizing-Assistenten zu erstellen. Der Upsizing-Assistent erstellt alle neuen Laufwerke auf derselben physischen Festplatte, auf der sich auch das Master- Datenbankmedium befindet. Wenn Ihr Server über mehrere Festplatten verfügt, können Sie Ihre Datenbank auf einer Festplatte unterbringen, während Sie das Transaktionsprotokoll auf einer anderen Festplatte speichern. Im Falle eines Festplattenausfalls können Sie dann Ihre Datenbank wiederherstellen. Stellen Sie sicher, dass Sie die Laufwerke auf beiden Festplatten groß genug definieren. Erstellen Sie notfalls neue Laufwerke.

Unter SQL Server besteht außerdem die Möglichkeit, Datenbank und Transaktionsprotokolle über mehrere Laufwerke hinweg anzulegen. Allerdings kann mit dem Upsizing-Assistenten nur ein Laufwerk für die Datenbank und ein Laufwerk für das Transaktionsprotokoll angegeben werden. Um mehrere Laufwerke für eine Datenbank bzw. ein Transaktionsprotokoll anzugeben, definieren Sie diese (aber keine anderen) Laufwerke als Standardlaufwerke. Führen Sie dann den Upsizing-Assistenten aus, und wählen Sie das Standardlaufwerk für Datenbank- bzw. Transaktionsprotokolle aus.

Anmerkung Wenn die Größe der neuen SQL Server-Datenbank oder die Größe des Transaktionsprotokoll nicht erfordern, dass alle als Standardlaufwerke definierten Laufwerke verwendet werden, benutzt SQL Server nur die Laufwerke, die für Datenbank oder Transaktionsprotokoll benötigt werden.

Definieren Sie einen Standarddrucker Sie müssen einen Standarddrucker festlegen, um den Upsizing-Assistenten verwenden zu können, da dieser automatisch einen Bericht-Snapshot des Upsizing-Asistenten-Berichts erstellt.

Erteilen Sie sich selbst die geeigneten Berechtigungen für die Access-Datenbank Sie benötigen Lese- und Entwurfsberechtigung für alle Datenbankobjekte, um diese per Upsizing zu transformieren.

Erteilen Sie sich selbst die geeigneten Berechtigungen für die SQL Server-Datenbank.

  • Soll das Upsizing in eine vorhandene Datenbank erfolgen, so benötigen Sie CREATE TABLE- und CREATE DEFAULT-Berechtigungen.

  • Um eine neue Datenbank erstellen zu können, benötigen Sie die CREATE DATABASE-Berechtigung sowie SELECT-Berechtigungen für die Systemtabellen der Master-Datenbank.

  • Um neue Laufwerke erstellen zu können, müssen Sie ein Systemadministrator sein.

Richten Sie sich von Beginn an nach den Namensregeln von SQL Server 6.5 Beim Upsizing zu einer SQL Server 6.5-Datenbank konvertiert der Upsizing-Assistent unzulässige Namen, indem er Leerzeichen und andere unzulässige Zeichen in Unterstrichzeichen (_) umwandelt. Es empfiehlt sich dennoch, von Anfang an nach Möglichkeit die erwähnten Namensregeln von SQL Server 6.5 einzuhalten. SQL Server 6.5-Namen müssen 30 oder weniger Zeichen umfassen, Das erste Zeichen muss ein Buchstabe oder das @-Zeichen sein. Die restlichen Zeichen dürfen Ziffern, Buchstaben, das Dollarzeichen ($), das Nummernzeichen (#) oder der Unterstrich (_) sein. Leerzeichen sind nicht zulässig.

Anmerkung In einer SQL Server 7.0-Datenbank verwendete Namen sind vollständig kompatibel mit Namen, die in einer Access-Datenbank verwendet werden.


 Erweitern der Microsoft Access-Datenbank

Erweitern der Microsoft Access-Datenbank

  1. Öffnen Sie die Microsoft Access-Datenbank, die Sie erweitern möchten.

  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme und klicken Sie dann auf Upsizing-Assistent.

  3. Folgen Sie den Anweisungen in den Dialogfeldern des Upsizing-Assistenten und klicken Sie, wenn Sie fertig sind, auf Fertig stellen.

  4. Wenn Sie weitere Informationen benötigen, um zu bestimmen, was in den einzelnen Dialogfelder gemacht wird, klicken Sie auf Hilfe.

Der Upsizing-Assistent stellt seine Arbeit fertig, wenn Sie auf Fertig stellen klicken; es gibt keine weiteren Aufforderungen. Alle Meldungen werden im Bericht des Upsizing-Assistenten vermerkt. Dies ist besonders nützlich, wenn Sie eine große Datenbank unbeaufsichtigt erweitern möchten. Falls Sie den Erweiterungsprozess abbrechen müssen, klicken Sie im Statusfeld, das der Upsizing-Assistent anzeigt, nachdem Sie auf Fertig stellen geklickt haben, auf Abbrechen.


 Angeben von Medien und Größen für Datenbanken und Transaktionsprotokolle

Angeben von Medien und Größen für Datenbanken und Transaktionsprotokolle

Wenn Sie eine neue Microsoft SQL Server 6.5-Datenbank erstellen, fordert Sie der Upsizing-Assistent zur Eingabe von Medien und Größen für die Datenbank und das Transaktionsprotokoll auf. Außerdem fordert er Sie dazu auf, eine vorab zugewiesene Größe für die Datenbank und für Transaktionen einzugeben. Dieses Thema enthält Referenzinformationen über:

Angeben eines Mediums und einer Größe für eine Datenbank

Angeben eines Mediums und einer Größe für ein Transaktionsprotokoll

Angeben einer Größe für eine Datenbank und ein Transaktionsprotokoll

Zurück zum Anfang

Angeben eines Mediums und einer Größe für eine Datenbank

Alle Datenbanken und Transaktionsprotokolle von SQL Server werden auf Medien platziert. Bei einem Medium handelt es sich sowohl um eine logische Adresse für Datenbanken und Transaktionsprotokolle als auch um eine physikalische Datei. Wenn Sie ein Medium erstellen, erstellt SQL Server eine Datei und reserviert eine bestimmte Menge Speicherplatz für den eigenen Gebrauch.

Wenn Sie ein Systemadministrator sind, zeigt der Upsizing-Assistent an, wie viel freier Speicherplatz auf den vorhandenen Medien zur Verfügung steht. Wählen Sie ein Medium, das mindestens über genügend freien Speicherplatz für die geschätzte Datenbankgröße verfügt.

Falls keins der vorhandenen Medien über genügend freien Speicherplatz verfügt, können Sie mit dem Upsizing-Assistenten ein neues Medium erstellen. Neue Medien sollten mindestens so groß sein wie die geschätzte Datenbankgröße. Falls möglich, sollte das Medium größer als die Datenbankgröße sein, damit Sie die Datenbank später erweitern oder andere Datenbanken oder Transaktionsprotokolle auf demselben Medium platzieren können.

Zurück zum Anfang

Eingeben eines Mediums und einer Größe für ein Transaktionsprotokoll

Bei dem Transaktionsprotokoll handelt es sich um eine chronologische Aufzeichnung aller Aktivitäten, die auf dem Server stattfinden, den SQL Server für Sicherungskopien und das Wiederherstellen von Datenbanken verwendet.

Das von Ihnen ausgewählte Medium für Transaktionsprotokolle muss über mindestens ein Megabyte freien Speicherplatz verfügen. Idealerweise sollten eine Datenbank und das dazugehörige Transaktionsprotokoll auf Medien platziert werden, die sich auf separaten physikalischen Datenträgern befinden. Diese Medien müssen vor dem Start des Upsizing-Assistenten erstellt werden, da der Upsizing-Assistent alle neuen Medien auf demselben physikalischen Datenträger erstellt, auf dem sich das Medium für die Masterdatenbank befindet.

Falls Sie nur über einen physikalischen Datenträger verfügen, sollten Sie die Datenbank und ihr Transaktionsprotokoll auf separaten Medien platzieren, damit Sie die Datenbank wiederherstellen können.

Der Upsizing-Assistent erstellt das Transaktionsprotokoll unter Verwendung der von Ihnen angegebenen Größe. Die Größe Ihres Transaktionsprotokolls sollte mindestens der Größe aller Tabellen für das Upsizing in Ihrer Datenbank entsprechen. Die von Ihnen angegebene Größe darf den zur Verfügung stehenden Speicherplatz auf dem von Ihnen ausgewählten Medium für das Transaktionsprotokoll nicht überschreiten.

Anmerkung Bei neuen Datenbanken schneidet der Upsizing-Assistent das Transaktionsprotokoll am Kontrollpunkt ab, wenn es vor der Beendigung des Upsizing bereits ganz gefüllt ist. Es ist jedoch möglich, dass das Transaktionsprotokoll bei einer einzigen Datei überläuft. Falls dies geschieht, führt Microsoft Access kein Upsizing der betreffenden Tabelle durch und schreibt den Fehler in den Bericht des Upsizing-Assistenten.

Zurück zum Anfang

Angeben einer Größe für eine Datenbank und ein Transaktionsprotokoll

Wenn Microsoft SQL Server 6.5 eine Datenbank erstellt, reserviert er eine festgelegte Menge Speicherplatz für diese Datenbank auf einem oder mehreren Medien. Die Datenbank verbraucht nicht notwendigerweise sofort den gesamten Speicherplatz. Bei der Datenbankgröße handelt es sich um die maximale Größe, die eine Datenbank erreichen kann, bevor nicht mehr genügend Speicherplatz vorhanden ist.

Um den für Ihre Datenbank benötigten Speicherplatz zu schätzen, betrachten Sie die Größe Ihrer Microsoft Access-Datenbank, und schätzen Sie die Wachstumsrate Ihrer neuen SQL Server-Datenbank. Im Allgemeinen benötigt jedes Megabyte Microsoft Access-Daten mindestens 1,3 bis 1,5 MB in SQL Server. Beachten Sie bitte, dass die Größe der Datei einer Microsoft Access-Datenbank (.mdb) alle Microsoft Access-Datenbankobjekte einschließt und nicht nur die Daten.

Wenn Sie über reichlich Speicherplatz auf Ihrem Server verfügen, multiplizieren Sie die Größe Ihrer Access-Datenbank mit 2. Dies stellt sicher, dass dem Upsizing-Assistenten genügend Speicherplatz für das Upsizing Ihrer Datenbank zur Verfügung steht, und zusätzlich hat die Datenbank noch etwas Platz zum Wachsen. Wenn zu erwarten ist, dass sehr viele Daten zu der Datenbank hinzugefügt werden, wählen Sie einen höheren Faktor.

Die Größe für das Transaktionsprotokoll sollte etwa 25 % der Datenbankgröße betragen.

Zurück zum Anfang


 Auswahl der zum Upsizing bestimmten Tabellen

Auswahl der zum Upsizing bestimmten Tabellen

Sie haben beim Upsizing zu einer Microsoft SQL Server-Datenbank die Möglichkeit, unter den Tabellen einer Microsoft Access-Datenbank eine Auswahl zu treffen. Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Verknüpfte Tabellen

Aliasabfragen

Die Auswirkungen der deklarativen referenziellen Integrität (DRI)

Verknüpfte Tabellen

Das Listenfeld Vorhandene Tabellen enthält alle verknüpften Tabellen außer denjenigen, die auf Microsoft SQL Server-Tabellen verweisen, die bereits in einer SQL Server-Datenbank vorhanden sind. Verknüpfte Tabellen, die auf eine SQL Server-Datenbank verweisen, die als Ziel des Upsizings ausgewählt wurde, werden automatisch im Listenfeld Nach SQL Server exportieren angezeigt und können nicht entfernt werden. Jede Tabelle, deren Name auf "_local" endet, wird von der Liste der vorhandenen Tabellen ausgeschlossen, um zu verhindern, dass über Upsizing umgewandelte Tabellen erneut vom Upsizing betroffen sind. Wenn Sie diese Tabellen erneut über Upsizing übertragen möchten, müssen Sie sie (durch Entfernen des Suffix "_local") umbenennen, bevor Sie den Upsizing-Assistenten ausführen. Aktuell im Datenbankfenster nicht sichtbare Tabellen sind ebenfalls ausgeschlossen, insbesondere ausgeblendete Tabellen und Systemtabellen.

Zurück zum Anfang

Aliasabfragen

Wenn Sie Microsoft SQL Server-Tabellen mit Ihrer Access-Datenbank verknüpfen möchten, kann der Upsizing-Assistent eine Aliasabfrage erstellen, um Namensunterschiede zwischen Microsoft Access und Microsoft SQL Server 6.5 zu handhaben. Letzteres Programm erlaubt in Feldnamen weder Leerzeichen noch Sonderzeichen außer Nummernzeichen (#), Dollarzeichen ($) und Unterstrichzeichen (_). Der Upsizing-Assistent ersetzt automatisch Leerzeichen und unzulässige Zeichen durch das Unterstrichzeichen (_). Wenn Feldnamen beim Upsizing einer Tabelle geändert werden, weist der Upsizing-Assistent der verknüpfte Tabelle den alten Namen mit dem Suffix "_remote" zu(beispielsweise Personal_remote) und benennt die ursprüngliche Tabelle um, indem er den alten Namen um das Suffix "_local" ergänzt (beispielsweise Personal_local). Annschließend erstellt der Upsizing-Assistent eine Aliasabfrage namens Personal, so dass Formulare, Berichte und Abfragen in Verbindung mit der neuen verknüpften SQL Server-Tabelle weiterhin korrekt funktionieren.

Zurück zum Anfang

Die Auswirkungen der deklarativen referenziellen Integrität (DRI)

Wenn Sie beim Upsizing zu SQL Server Version 6.5 die deklarative referenzielle Integrität (DRI) ausgewählt haben, um zuerst das Upsizing der Tabellen durchzuführen, verhindert DRI das Überschreiben relational verknüpfter Tabellen, die zuvor bereits per Upsizing übertragen worden sind. Es ist möglich, mit dem SQL Server Enterprise Manager eine gesamte über Upsizing erstellte SQL Server-Datenbank zu verwerfen (zu löschen) und dann das Upsizing der Access-Datenbank erneut durchzuführen. Soll das erneute Upsizing nur einige Tabellen betreffen, so müssen Sie diese Tabellen sowie alle anderen mit ihnen relational verknüpften Tabellen verwerfen, beginnend mit der Detailtabelle (der Tabelle auf der rechten Seite der 1:n-Beziehung, einer Tabelle, für die keine Verweise auf ihren Primärschlüssel in einer anderen Tabelle existieren). Anschließend führen Sie für die gesamte Gruppe von Tabellen das Upsizing erneut durch. Der Upsizing-Assistent kann DRI-Beziehungen nur zwischen relational verknüpften Tabellen etablieren, die gleichzeitig per Upsizing übertragen werden, nicht aber Beziehungen zwischen diesen Tabellen und bereits vorher auf dem Server vorhandenen Tabellen.

Zurück zum Anfang


 Auswählen von Tabellenattributen für das Upsizing

Auswählen von Tabellenattributen für das Upsizing

Sie können die Tabellenattribute für das Upsizing auf Ihre Microsoft SQL Server-Datenbank auswählen. Der Upsizing-Assistent konvertiert als Mindestmaß Access-Feldnamen in gültige SQL Server-Feldnamen und konvertiert Access-Datentypen in die entsprechenden SQL Server-Datentypen. Standardmäßig werden für das Upsizing alle Attribute ausgewählt. Dieses Thema enthält Referenzinformationen darüber, was geschieht beim:

Upsizing von Indizes

Upsizing von Gültigkeitsregeln

Upsizing von Standardwerten

Upsizing von Tabellenbeziehungen

Hinzufügen von Timestamp-Feldern zu Tabellen

Entscheiden gegen das Upsizing von Daten

Upsizing von Indizes

Wenn Sie das Kontrollkästchen Indizes aktivieren, führt der Upsizing-Assistent ein Upsizing aller Indizes durch.

Der Upsizing-Assistent konvertiert Microsoft Access-Primärschlüssel in nicht als CLUSTERED erstellte, eindeutige Indizes von Microsoft SQL Server und kennzeichnet sie als SQL Server-Primärschlüssel. Wenn Sie die SQL Server-Tabelle nach dem Upsizing mit Ihrer Access-Datenbank verknüpfen möchten, fügt der Upsizing-Assistent außerdem das Präfix "aaaaa" hinzu. In Microsoft Access wird der Index, der in der Liste der verfügbaren Indizes im Alphabet zuoberst steht, als Primärschlüssel ausgewählt. Das Präfix "aaaaa" stellt sicher, dass der richtige Index ausgewählt wird.

Alle anderen Indizes behalten ihre Namen, ungültige Zeichen werden jedoch durch das Zeichen "_" ersetzt. Eindeutige und nicht eindeutige Microsoft Access-Indizes werden zu eindeutigen und nicht eindeutigen SQL Server-Indizes. Beachten Sie bitte, dass SQL Server keine Indizes in aufsteigender oder absteigender Reihenfolge unterstützt.

Eine verknüpfte Tabelle muss, um in Microsoft Access aktualisierbar zu sein, über einen eindeutigen Index verfügen. Der Upsizing-Assistent kann ein Upsizing eines bestehenden eindeutigen Index durchführen, jedoch nicht, wenn keiner vorhanden ist, einen Index erstellen. Wenn Ihre Tabellen aktualisierbar sein sollen, stellen Sie bitte sicher, dass Sie jeder Access-Tabelle vor dem Upsizing einen eindeutigen Index hinzufügen.

Zurück zum Anfang

Upsizing von Gültigkeitsregeln

Wenn Sie das Kontrollkästchen Gültigkeitsregeln aktivieren, aktualisiert der Upsizing-Assistent alle Gültigkeitsregeln für Tabellen, Datensätze und Felder sowie Eingabe erforderlich-Eigenschaften für Felder als Update und fügt Trigger ein.

Bei einem Trigger handelt es sich um eine Reihe von Transact-SQL-Anweisungen, die mit einer SQL Server-Tabelle verbunden sind. Eine Tabelle kann drei Trigger besitzen, einen für jeden Befehl, mit dem Daten in einer Tabelle geändert werden können: die Befehle UPDATE, INSERT und DELETE. Der Trigger wird automatisch ausgeführt, wenn der Befehl ausgeführt wird. Der Upsizing-Assistent verwendet Trigger statt SQL Server-Regeln, um die Gültigkeitsprüfung auf Feldebene zu erzwingen, da SQL Server-Regeln das Anzeigen von benutzerdefinierten Fehlermeldungen nicht gestatten.

Nicht für jede Gültigkeitsregel besteht notwendigerweise auch eine Eins-zu-Eins-Entsprechung zu einem Trigger. Jede Gültigkeitsregel kann Bestandteil mehrerer Trigger werden, und jeder Trigger kann Code enthalten, um die Funktionalität mehrerer Gültigkeitsregeln zu emulieren.

Wenn Sie die Eingabe erforderlich-Eigenschaft eines Microsoft Access-Feldes auf True festlegen, kann ein Benutzer keinen Datensatz einfügen und das Feld, für das die Eingabe erforderlich ist, auf Null belassen (wenn kein Standardwert an das Feld gebunden ist) oder das Feld beim Aktualisieren eines Datensatzes auf Null setzen. Felder, für die eine Eingabe erforderlich ist, werden beim Upsizing auf SQL Server zu Feldern, in denen kein Nullwert zugelassen ist. Der Upsizing-Assistent erstellt außerdem ein Transact-SQL-Codefragment, das eine Meldung ähnlich der Meldung anzeigt, die in Microsoft Access angezeigt wird, wenn das Feld beim Hinzufügen oder Aktualisieren eines Datensatzes Null ist.

Zurück zum Anfang

Upsizing von Standardwerten

Wenn Sie das Kontrollkästchen Standardwerte aktivieren, führt der Upsizing-Assistent ein Upsizing aller Standardwerte in American National Standards Institute (ANSI)-Standardwerte durch, nicht in Standardobjekte, die an das entsprechende SQL Server-Feld gebunden sind. Microsoft SQL Server-Standardwerte sind im Gegensatz zu Microsoft Access-Standardwerten von einem bestimmten Feld oder einer bestimmten Tabelle unabhängig. Sobald Sie einen Standardwert erstellen, können Sie ihn an eine beliebige Anzahl unterschiedlicher Felder binden.

Zurück zum Anfang

Upsizing von Tabellenbeziehungen

Sie können bestimmen, wie das Upsizing von Tabellenbeziehungen und referenzieller Integrität durchgeführt wird, indem Sie entweder Aktualisierungs-, Einfüge- oder Löschtrigger oder Declared Referential Integrity (DRI) verwenden.

DRI funktioniert ebenso wie die referenzielle Integrität in Microsoft Access, indem Primärschlüsselbeschränkungen für Basistabellen (die "1"-Seite einer 1:n-Beziehung) und Fremdschlüsselbeschränkungen for Fremdtabellen (typischerweise die "n"-Seite einer 1:n-Beziehung) definiert werden. SQL Server-DRI verfügt jedoch nicht über die Aktualisierungs- und Löschweitergabemerkmale von Microsoft Access.

  • Verwenden von Triggern Wenn in Ihren Microsoft Access-Tabellenbeziehungen Aktualisierungs- oder Löschweitergaben definiert sind, und dieses Verhalten in Tabellen nach dem Upsizing erhalten bleiben soll, aktivieren Sie die Kontrollkästchen Tabellenbeziehungen und Mit Trigger, um ein Upsizing von Aktualisierungs- und Löschweitergaben auf Trigger zum Erzwingen der referenziellen Integrität zu ermöglichen.

    Für eine Tabellenbeziehung besteht nicht notwendigerweise eine Eins-zu-Eins-Entsprechung zu einem Trigger. Jede Beziehung kann Bestandteil mehrerer Trigger werden, oder jeder Trigger kann Code enthalten, um die Funktionalität mehrerer Regeln zur referenziellen Integrität zu emulieren. Einfügetrigger werden auf untergeordnete Tabellen angewendet, Löschtrigger auf übergeordnete Tabellen.

    Anmerkung Für das Microsoft SQL Server-Designtool ist Declared Referential Integrity (DRI) erforderlich, um das Datenbankdiagramm einer SQL Server-Datenbank zu lesen. Damit die SQL Server-Designtools das Datenbankdiagramm lesen können und referenzielle Integrität mit Hilfe von Triggern erzwungen wird, platziert der Upsizing-Assistent DRI auf die Beziehungen, schaltet aber die Überprüfung von Fremdschlüsselbeschränkungen ab.

  • Verwenden von DRI Wenn für Ihre Datenbank keine Aktualisierungs- oder Löschweitergaben definiert sind oder es Ihnen nichts ausmacht, wenn diese Features in der Datenbank beim Upsizing verloren gehen, aktivieren Sie die Kontrollkästchen Tabellenbeziehungen und Mit DRI, um DRI zum Erzwingen der referenziellen Integrität zu verwenden. In diesem Fall zeigt der Upsizing-Assistent eine Warnung an, dass die Aktualisierungs- und Löschweitergabefunktionalität verloren gehen wird.

Zurück zum Anfang

Hinzufügen von Timestamp-Feldern zu Tabellen

Microsoft SQL Server verwendet ein Timestamp-Feld, um anzuzeigen, dass ein Datensatz geändert wurde (nicht jedoch, wann er geändert wurde), indem ein Feld mit einem eindeutigen Wert erstellt wird und anschließend dieses Feld immer dann aktualisiert wird, wenn ein Datensatz aktualisiert wird. Bei einer verknüpften Tabelle verwendet Access den Wert in Timestamp-Feldern dazu, vor dem Aktualisieren eines Datensatzes zu ermitteln, ob dieser geändert worden ist. Im Allgemeinen bietet ein Timestamp-Feld die beste Leistung und Zuverlässigkeit. Ohne ein Timestamp-Feld muss SQL Server sämtliche Felder des Datensatzes überprüfen, um festzustellen, ob der Datensatz geändert wurde. Dies verringert die Leistung.

  • Wenn Sie den Standardwert Ja, der Assistent soll entscheiden auswählen, erstellt der Upsizing-Assistent neue Felder mit dem Timestamp-Datentyp in SQL Server-Tabellen, die bei einem Upsizing von Microsoft Access-Tabellen entstanden sind, die Fließkommafelder (einfache oder doppelte Genauigkeit), Memofelder oder OLE-Objektfelder enthalten.

  • Wahlweise kann der Upsizing-Assistent auch ein Timestamp-Feld für alle Tabellen erstellen, die beim Upsizing entstanden sind, gleich welche Feldtypen sie enthalten. Wählen Sie hierzu Ja, immer. Dies erhöht die Leistung von Access-Tabellen nach dem Upsizing, die möglicherweise keine Memo-, OLE-Objekt- oder Fließkommafelder, dafür aber Felder anderer Typen enthalten.

Anmerkung In verknüpften SQL Server-Tabellen überprüft Microsoft Access nicht, ob Memo- oder OLE-Objektfelder geändert wurden, da diese Felder mehrere Megabyte groß sein könnten und der Vergleich zu netzwerkintensiv und zeitraubend sein könnte. Wenn nur ein Text- oder Bildfeld geändert wurde und kein Timestamp-Feld vorhanden ist, überschreibt Microsoft Access daher die Änderung. Ferner kann der Wert eines Fließkommafeldes irrtümlich als geändert angezeigt werden. Daher stellt Microsoft Access, wenn kein Timestamp-Feld vorhanden ist, möglicherweise irrtümlich fest, dass der Datensatz geändert wurde.

Zurück zum Anfang

Entscheiden gegen das Upsizing von Daten

Standardmäßig führt der Upsizing-Assistent ein Upsizing aller Daten auf SQL Server durch. Wenn Sie das Kontrollkästchen Nur Tabellenstruktur erstellen, keine Daten aktivieren, findet nur ein Upsizing der Datenstruktur statt.

Zurück zum Anfang


 Auswahl des Verfahrens zum Upsizing einer Anwendung

Auswahl des Verfahrens zum Upsizing einer Anwendung

Sie können beim Upsizing Ihrer Microsoft Access-Datenbankanwendung zwischen verschiedenen Möglichkeiten auswählen. Diese Seite enthält Übersichtsinformationen zu jeder der folgenden Anwendungsänderungs-Optionen:

Keine Anwendungsänderungen

Einbinden von SQL Server-Tabellen in die bestehende Anwendung

Erstellen einer neuen Access-Client/Server-Anwendung

Speichern des Kennworts und der Benutzer-ID

Keine Anwendungsänderungen

Wählen Sie die Option Keine Anwendungsänderungen, wenn Sie ein Upsizing Ihrer Daten wünschen und keine Änderungen an Ihrer vorhandenen Access-Datenbankanwendung vornehmen möchten.

Zurück zum Anfang

Einbinden von SQL Server-Tabellen in die bestehende Anwendung

Bei Auswahl der Option SQL Server-Tabellen in die bestehende Anwendung einbinden kann der Upsizing-Assistent Ihre Access-Datenbank auf die Art und Weise modifizieren, dass Ihre Abfragen, Formulare, Berichte und Datenzugriffsseiten die Daten der neuen Microsoft SQL Server-Datenbank statt der Daten in Ihrer Microsoft Access-Datenbank verwenden.

Der Upsizing-Assistent versieht die zum Upsizing vorgesehenen Microsoft Access-Tabellen mit dem Suffix "_local." Wenn Sie beispielsweise eine Tabelle namens Personal über Upsizing übertragen, wird die Tabelle innerhalb Ihrer Access-Datenbank umbenannt in Personal_local. Anschließend erstellt der Upsizing-Assistent eine verknüpfte SQL Server-Tabelle namens Personal.

Abfragen, Formulare, Berichte und Datenzugriffsseiten, die auf der ursprüngliche Tabelle Personal basierten, verwenden nun die verknüpfte SQL Server-Tabelle Personal. Viele Eigenschaften der Felder in der ursprünglichen lokalen Tabelle werden an die neue lokale Tabelle vererbt, unter anderem Beschreibung, Beschriftung, Format, Eingabeformat und Dezimalstellenanzeige. Weitere Informationen über die Eigenschaften verknüpfter Tabellen.

Zurück zum Anfang

Erstellen einer neuen Access-Client-/Server-Anwendung

Bei Auswahl der Option Neue Access-Client/Server-Anwendung erstellen erstellt der Upsizing-Assistent ein neues Microsoft Access-Projekt. Der Upsizing-Assistent fordert zur Eingabe eines Namens auf und nimmt bei Nichteingabe den Namen der aktuellen Access-Datenbank als Standardnamen an. Dem Namen wird ein Suffix "CS" angehängt. Anschließend wird das Projekt in demselben Ordner wie die vorhandene Access-Datenbank gespeichert.

Der Upsizing-Assistent erstellt die Access-Projektdatei, zeigt das Dialogfeld Datenlinkeigenschaften an, in dem Sie eine Verbindung mit einer SQL Server-Datenbank herstellen können, und überträgt anschließend über Upsizing alle Datenbankobjekte der Access-Datenbank in das Access-Projekt:

  • Abfragen Der Upsizing-Assistent konvertiert Abfragen entweder in Sichten oder in Gespeicherte Prozeduren und wandelt die SQL-Syntax von Access in SQL-Syntax des SQL Servers um. Auswahlabfragen werden in Sichten konvertiert. Sortierabfragen werden in eine Kombination von Sichten und Gespeicherten Prozeduren konvertiert, um Verschachtelung und Sortierung zu ermöglichen (Sichten lassen sich schachteln, können aber keine ORDER BY-Klauseln enthalten - Gespeicherte Prozeduren können ORDER BY-Klauseln enthalten, aber nicht geschachtelt werden). Parameterabfragen und Abfragen, die von Parameterabfragen abhängen, sowie Aktionsabfragen werden in Gespeicherte Prozeduren konvertiert. Abfragen, die sich nicht durch Upsizing übertragen lassen (beispielsweise jene, die eine zu große Verschachtelungstiefe aufweisen), müssen Sie gegebenenfalls selbst manuell konvertieren. Für SQL Passthrough-Abfragen, Datendefinitionsabfragen und Union-Abfragen kann das Upsizing nicht durchgeführt werden.

  • Formulare, Berichte und Steuerelemente Der Upsizing-Assistent ändert die Datenherkunft-, Steuerelementinhalt- und Datensatzherkunft-Eigenschaften, indem er die Namen von Tabellen, Abfragen, SQL-Anweisungen oder Feldern in die äquivalenten Namen der SQL Server-Tabellen, -Sichten, -Gespeicherten Prozeduren oder -Feldnamen umwandelt.

  • Datenzugriffsseiten Der Upsizing-Assistent ändert die OLE DB-Verbindung und die Datenbindungsinformationen im Microsoft Office-Datenquellen-Steuerelement, die für die Arbeit mit der neuen SQL Server-Datenbank nötig sind. Außerdem kopiert er die zugehörige HTML-Datei in dasselbe Verzeichnis, in dem sich das Access-Projekt befindet, benennt die HTML-Datei neu und hängt dem Namen den Suffix "_CS" an. Die neuen Seiten im Access-Projekt behalten den ursprünglichen Namen, so dass Hyperlinks zwischen den SQL Server-Seiten weiterhin funktionieren.

  • Makros und Module Der Upsizing-Assistent nimmt an diesen Datenbankobjekten keine Änderungen vor. Nach dem Upsizing müssen Sie manuell den Code in den Modulen modifizieren, die Datensatzgruppen aus DAO (Data Access Objects)-Objekten verwenden, und diesen Code auf ADO (ActiveX Data Objects)-Objekte umstellen. Außerdem muss der gesamte Code überarbeitet werden, der den Entwurf von Tabellen und Abfragen betrifft (der Upsizing-Assistent ignoriert SQL-Datendefinitionen). Weitere Informationen über die Entwicklung optimierter Client-/Server-Anwendungen finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.

Zurück zum Anfang

Speichern des Kennworts und der Benutzer-ID

Standardmäßig erstellt der Assistent verknüpfte Tabellen innerhalb der vorhandenen Anwendung oder ein Access-Projekt ohne Speichern des Benutzernamens und des Kennworts. Deshalb werden die Benutzer einer SQL Server-Datenbank bei jeder Anmeldung zur Eingabe eines Benutzernamens und Kennworts aufgefordert.

Bei Auswahl der Option Kennwort und Benutzernamen speichern können Benutzer auf eine SQL Server-Datenbank ohne Anmeldung zugreifen. Wenn Sie die Option Neue Access-Client/Server-Anwendung erstellen wählen, speichert das Access-Projekt den Benutzernamen und das Kennwort in der OLE DB-Verbindungszeichenfolge.

Anmerkung Diese Option ist in Verbindung mit der Option Keine Anwendungsänderungen deaktiviert, wenn eine verknüpfte SQL Server-Tabelle unter Verwendung einer MSysConf-Tabelle so konfiguriert ist, dass sie das Speichern von Kennwörtern verweigert.

Zurück zum Anfang


Was ist neu für Entwickler in Microsoft Access 2000

Am Objekmodell für Microsoft Access 2000 Visual Basic sind umfangreiche Änderungen zur Unterstützung von neuen und verbesserten Features der Anwendung vorgenommen worden. Viele Objekte, Eigenschaften und Methoden wurden ersetzt. Um Abwärtskompatibilität zu ermöglichen, wurden die meisten ersetzten Komponenten jedoch ausgeblendet statt entfernt. Dies bedeutet, dass sie im Objektkatalog standardmäßig nicht angezeigt werden, alter Code, der die ausgeblendeten Komponenten verwendet, jedoch ohne Änderungen weiterhin einwandfrei funktioniert. Beim Schreiben von neuem Code sollten Sie allerdings die neuen Objekte, Eigenschaften und Methoden verwenden.

Bereiche mit neuen Features

Die folgenden Themen enthalten konzeptionelle Informationen zu Features, die neu in Microsoft Access 2000 sind.

Datenbankfenster

Datenbankentwurf

Datenzugriffsseiten

Formulare und Berichte

Internetunterstützung

Makros

Microsoft Access-Projekte

Datensicherheit

Visual Basic-Editor

Anzeigen und Bearbeiten von Web Script

Neue Sprachelemente

Die folgenden Themen enthalten Listen von Sprachelementen, die in Microsoft Access 2000 neu sind.

Neue Objekte

Neue Eigenschaften (Alphabetische Liste)

Neue Eigenschaften (nach Objekt)

Neue Methoden (Alphabetische Liste)

Neue Methoden (nach Objekt)

Neue Ereignisse

Sprachspezifische Eigenschaften und Methoden

Ausgeblendete Sprachelemente

Das folgende Thema enthält Listen von Sprachelementen, die in Microsoft Access 2000 ausgeblendet wurden.

Ausgeblendete Eigenschaften

Neue Features in Microsoft Access 97

Die folgenden Themen enthalten Informationen zu Entwickler-Features und Sprachelementen, die in Microsoft Access 97 neu waren.

Neue Eigenschaften

Neue Methoden


 Ereignisse: Erreichen von Zusammenarbeit Ihrer Datenbankobjekte

Ereignisse: Erreichen von Zusammenarbeit Ihrer Datenbankobjekte

Was ist ein Ereignis?

Ein Ereignis ist eine spezifische Aktion, die an oder in Verbindung mit einem bestimmten Objekt eintritt. Microsoft Access kann auf eine Vielzahl von Ereignissen reagieren: Mausklicks, Änderungen an Daten, das Öffnen oder Schließen von Formularen u.a. Ereignisse sind im Allgemeinen das Ergebnis einer Benutzeraktion.

Mit Hilfe einer Ereignisprozedur oder eines Makros können Sie Ihre eigene benutzerdefinierte Reaktion auf ein Ereignis, das in einem Formular, einem Bericht oder Steuerelement eintritt, festlegen.

Angenommen, Sie möchten, dass das Formular Artikeldetails geöffnet wird, wenn Sie in einem Formular Bestellungen auf eine Befehlsschaltfläche Artikeldetails klicken. Die folgenden Beispiele zeigen, wie Sie dies entweder über eine Ereignisprozedur oder über ein Makro erreichen können.

Reagieren auf ein Click-Ereignis unter Verwendung einer Ereignisprozedur

Wenn Sie eine Ereignisprozedur für ein Objekt erstellen, fügt Access dem Formular- oder Berichtsmodul eine Ereignisprozedurvorlage hinzu, die nach dem Ereignis und Objekt benannt ist. Sie brauchen lediglich Code hinzuzufügen, der bei Eintreten des Ereignisses im Formular oder Bericht auf die gewünschte Weise reagiert.

Erstellen einer Befehlsschaltfläche

Platzieren von Methoden in Ereignisprozeduren zur Ausführung von Aktionen

Reagieren auf ein Click-Ereignis unter Verwendung eines Makros

Damit als Reaktion auf ein Ereignis ein Makro ausgeführt wird, öffnen Sie das Eigenschaftenfenster für das Formular, den Bericht oder das Steuerelement. Suchen Sie die Eigenschaft, die auf das Ereignis reagiert, und stellen Sie sie auf das Makro ein, das Sie ausführen möchten.

Erstellen eines Makros, das mit einem Ereignis verbunden ist

Um eine vollständige Liste der Ereignisse anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zur Ausführung eine Makros oder einer Ereignisprozedur von einem Ereignis in einem Formular, Bericht oder Steuerelement aus anzuzeigen, klicken Sie auf [image] .


 Speichern eines Datenbankobjekts unter Verwendung eines Makros oder einer Ereignisprozedur

Speichern eines Datenbankobjekts unter Verwendung eines Makros oder einer Ereignisprozedur

Sie können das Speichern eines Datenbankobjekts automatisieren, indem Sie die Aktion Speichern in einem Makro oder einer Ereignisprozedur ausführen.

Was möchten Sie tun?

Speichern eines Datenbankobjekts unter Verwendung eines Makros

Speichern eines Datenbankobjekts unter Verwendung einer Ereignisprozedur


 Ausführen eines Makros oder einer Ereignisprozedur für ein Ereignis in einem Formular, Bericht oder Steuerelement

Ausführen eines Makros oder einer Ereignisprozedur für ein Ereignis in einem Formular, Bericht oder Steuerelement

Microsoft Access reagiert auf viele Typen von Ereignissen in Formularen, Berichten und Steuerelementen. Dazu gehören Mausklicks, Datenänderungen sowie das Öffnen oder Schließen von Formularen oder Berichten.

  1. Öffnen Sie das Formular oder den Bericht in der Entwurfsansicht.

  2. Erstellen Sie ein Makro oder eine Ereignisprozedur. Sie können beispielsweise ein Makro oder eine Ereignisprozedur erstellen, das bzw. die eine Meldung anzeigt, wenn Sie auf eine Befehlsschaltfläche klicken.

  3. Setzen Sie die entsprechende Ereigniseigenschaft des Formulars, Berichts oder Steuerelements auf den Namen des Makros oder aber auf [Ereignisprozedur], falls Sie eine Ereignisprozedur verwenden.

    Um beispielsweise ein Makro zu verwenden, das eine Meldung anzeigt, wenn Sie auf eine Befehlsschaltfläche klicken, setzen Sie die Eigenschaft OnClick der Befehlsschaltfläche auf den Namen des Makros, das die Meldung anzeigt. Um eine Ereignisprozedur zu verwenden, erstellen Sie eine Ereignisprozedur Name_Click für die Schaltfläche und setzen dann die Eigenschaft OnClick auf [Ereignisprozedur].

Anmerkungen

  • Um Informationen über das Erstellen eines Makros anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zum Erstellen einer Ereignisprozedur anzuzeigen, klicken Sie auf [image] .

  • Um Informationen darüber anzuzeigen, wann Ereignisse eintreten, klicken Sie auf [image] .


 Herausfinden, wann Ereignisse eintreten

Herausfinden, wann Ereignisse eintreten

Eine einzelne Aktion, wie das Wechseln von einem Steuerelement zu einem anderen, kann verschiedene Ereignisse auslösen, die in einer bestimmten Reihenfolge eintreten. Das Wissen darüber, wann und in welcher Reihenfolge Ereignisse eintreten, ist insofern wichtig, als es einen Einfluss darauf hat, wann Ihre Makros oder Ereignisprozeduren ausgeführt werden. Wenn beispielsweise zwei Ereignisprozeduren in einer bestimmten Reihenfolge ausgeführt werden sollen, werden Sie sicherstellen wollen, dass die dazugehörigen Ereignisse in eben dieser Reihenfolge eintreten.

Was möchten Sie tun?

Die Reihenfolge der Ereignisse für Steuerelemente in Formularen ansehen

Die Reihenfolge der Ereignisse für Datensätze in Formularen ansehen

Die Reihenfolge der Ereignisse zwischen Formularen und Unterformularen ansehen

Die Reihenfolge der Ereignisse für Tastenanschläge und Mausklicks ansehen

Die Reihenfolge der Ereignisse für Berichte und Berichtsbereiche ansehen

Anmerkung Sie können sich die Reihenfolge, in der Ereignisse eintreten, ansehen, indem Sie das Formular EreignisseAnzeigen in der Beispielanwendung Bestellungen öffnen. Wenn im Formular EreignisseAnzeigen Ereignisse eintreten (beispielsweise beim Öffnen des Formulars oder wenn Sie zu einem neuen Datensatz gehen), listet das Formular Ereignisprotokoll die Ereignisse in der Reihenfolge auf, in der sie eintreten. Um Informationen zum Öffnen von Aufträgen anzuzeigen, klicken Sie auf [image] .


 Ereignisse für die Gültigkeitsprüfung von Daten

Ereignisse für die Gültigkeitsprüfung von Daten

Meistens werden Sie die folgenden Ereignisse verwenden, um zu bestimmen, wann Microsoft Access ein Gültigkeitsmakro oder eine Ereignisprozedur in einem Formular ausführen soll.

Formularereignis | Gültigkeitsprüfung
BeforeUpdate | Vor dem Speichern neuer oder geänderter Daten in einem Datensatz.
OnDelete | Vor dem Löschen eines Datensatzes.

Steuerelementereignis | Gültigkeitsprüfung
BeforeUpdate | Vor dem Speichern neuer oder geänderter Daten in einem Steuerelement.
OnExit | Vor dem Verlassen eines Steuerelements.


 Reihenfolge der Gültigkeitsprüfungen für Steuerelemente und Felder

Reihenfolge der Gültigkeitsprüfungen für Steuerelemente und Felder

Gültigkeitsregeln für Steuerelemente und Felder werden in der folgenden Reihenfolge ausgewertet:

  1. Die Gültigkeitsprüfung unter Verwendung eines Makros oder einer Ereignisprozedur (z.B. ein Makro, das auf das BeforeUpdate-Ereignis des Steuerelements oder des Formulars, welches das Steuerelement enthält, reagiert; z.B. eine Ereignisprozedur, die auf das BeforeUpdate-Ereignis des Steuerelements oder des Formulars, welches das Steuerelement enthält, reagiert).

  2. Die ValidationRule-Eigenschaft des Steuerelements.

  3. Die Gültigkeitsregeln der zugrunde liegenden Tabelle für das Feld (die in den Eigenschaften ValidationRule, Required, und AllowZeroLength des Feldes festgelegt wurden).

  4. Die Eigenschaft ValidationRule der zugrunde liegenden Tabelle (diese Eigenschaft führt eine Gültigkeitsprüfung der Datensätze durch).


 Bewegen zwischen Steuerelementen, Datensätzen und Formularseiten

Bewegen zwischen Steuerelementen, Datensätzen und Formularseiten

Sie können sich automatisch zu einem Steuerelement, Datensatz oder einer Formularseite als Reaktion auf ein Ereignis in einem Formular bewegen, indem Sie in einem Makro oder einer Ereignisprozedur die Aktionen GeheZuSteuerelement, GeheZuSeite oder GeheZuDatensatz ausführen.

Was möchten Sie tun?

Sich zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung eines Makros bewegen

Sich zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung von Visual Basic für Applikationen bewegen


 Suchen nach einem Datensatz durch das Auswählen eines Werts aus einer Liste

Suchen nach einem Datensatz durch das Auswählen eines Werts aus einer Liste

Sie können in einem Formular ein Listenfeld oder ein Kombinationsfeld erstellen, das nach einem Datensatz sucht, sobald Sie einen Wert aus einer Liste auswählen.

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf Steuerelement-Assistenten [image] , falls diese Schaltfläche nicht bereits gedrückt ist.

  3. Klicken Sie in der Toolbox auf Listenfeld Listenfeld oder auf Kombinationsfeld .

  4. Klicken Sie im Formular auf die Stelle, an der das Listen- oder Kombinationsfeld eingefügt werden soll.

  5. Klicken Sie im ersten Dialogfeld des Assistenten auf die Option, die den Datensatz basierend auf dem im Listen- oder Kombinationsfeld ausgewählten Wert sucht.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um das Listen- oder Kombinationsfeld in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur ansehen möchten, die das Listen- oder Kombinationsfeld steuert, öffnen Sie das Eigenschaftenfenster des entsprechenden Feldes, und klicken Sie dann auf die Generator-Schaltfläche [image] neben dem Einstellungsfeld der AfterUpdate-Eigenschaft.


 Automatisches Anzeigen der aktuellen Datensätze für ein Formular

Automatisches Anzeigen der aktuellen Datensätze für ein Formular

Sie können für ein Formular die aktuellen Daten anzeigen, indem Sie die Anzeige aktualisieren oder für die Datensätze die entsprechende Abfrage erneut ausführen.

Wenn Sie mit einer Datenbank arbeiten, die im Netzwerk gemeinsam genutzt wird, können Sie die aktuelle Version der bestehenden Datensätze anzeigen, indem Sie eine Befehlsschaltfläche erstellen, welche die Formulardaten aktualisiert.

Um die aktuelle Gruppe von Datensätzen in einem Formular (einschließlich der neuen Datensätze) anzuzeigen, können Sie die Datensätze aktualisieren, indem Sie die Aktion AktualisierenDaten in ein Makro oder die Requery-Methode in eine Visual Basic-Prozedur einfügen.

Was möchten Sie tun?

Eine Befehlsschaltfläche erstellen, die Formulardaten aktualisiert

Die aktuellen Datensätze eines Formulars unter Verwendung eines Makros automatisch anzeigen

Die aktuellen Datensätze eines Formulars unter Verwendung von Visual Basic für Applikationen automatisch anzeigen


 Anzeigen von Detaildatensätzen in einem Formular beim Bewegen zwischen Datensätzen in einem anderen Formular

Anzeigen von Detaildatensätzen in einem Formular beim Bewegen zwischen Datensätzen in einem anderen Formular

Wenn Sie sich zwischen den Datensätzen eines Formulars bewegen, können Sie die entsprechenden Detaildatensätze in einem zweiten Formular anzeigen, indem Sie ein Makro oder eine Ereignisprozedur als Reaktion auf das Current-Ereignis des ersten Formulars ausführen.

Was möchten Sie tun?

Ein Makro verwenden, um Detaildatensätze beim Bewegen zwischen Datensätzen in einem Formular anzuzeigen

Visual Basic für Applikationen verwenden, um Detaildatensätze beim Bewegen zwischen Datensätzen in einem Formular anzuzeigen


Anzeigen von Detaildatensätzen beim Bewegen zwischen Datensätzen unter Verwendung von Visual Basic: Beispiel

Wenn Sie sich zwischen Lieferantendatensätzen in einem Formular Lieferanten bewegen, möchten Sie evenuell auch die Artikel der einzelnen Lieferanten in einem Formular Artikel anzeigen. In der Form_Current-Ereignisprozedur des Formulars Lieferanten stellen Sie die Eigenschaften FilterOn und Filter des Formulars Artikel ein:

Private Sub Form_Current()

    ' Deklarieren und Festlegen einer Variablen zum
    ' Speichern der WHERE-Klausel, die die anzuzeigenden
    ' Datensätze beschreibt.
    Dim strCond As String
    strCond = "[Lieferanten-Nr] = Formulare![Lieferanten]![Lieferanten-Nr]"

    ' Verwenden der IsLoaded-Funktion aus der Nordwind-
    ' Beispieldatenbank zum Überprüfen, ob das Formular
    ' Artikel geöffnet ist; Einstellen der Eigenschaften.
    If IsLoaded("Artikel") Then
        Formulare![Artikel].FilterOn = True
        Formulare![Artikel].Filter = strCond
    End If

End Sub


Synchronisieren von Datensätzen zwischen zwei Formularen

Häufig möchten Sie sich zusammenhängende Datensätze in zwei verschiedenen Formularen gleichzeitig ansehen. Während Sie sich zum Beispiel einen Kundendatensatz im Formular Kunden ansehen, möchten Sie vielleicht das Formular Bestellungen öffnen, das die Bestellungen dieses Kunden anzeigt.

Wenn Sie sich zwischen Datensätzen in einem Formular bewegen, können Sie auch Detaildatensätze eines zweiten Formulars automatisch anzeigen. Wenn Sie sich zum Beispiel zwischen Lieferantendatensätzen in einem Formular Lieferanten bewegen, möchten Sie sicher auch die Artikel der einzelnen Lieferanten in einem Formular Artikel anzeigen.

Sie können Datensätze zwischen zwei Formularen synchronisieren, indem Sie eine Befehlsschaltfläche erstellen, mit der ein zweites Formular geöffnet und synchronisiert werden kann, oder indem Sie das Current-Ereignis verwenden, um zusammenhängende Datensätze auf dem zweiten Formular anzuzeigen, wenn Sie sich zwischen Datensätzen auf dem ersten Formular bewegen.

Tipp Sie können auch den Formular-Assistenten verwenden, um zwei verknüpfte Formulare neu zu erstellen. Wählen Sie im ersten Bildschirm des Assistenten Felder aus zwei verschiedenen Tabellen aus. Klicken Sie im zweiten Bildschirm auf Verknüpfte Formulare. Der Assistent erstellt die beiden verknüpften Formulare; jedes von ihnen enthält Felder aus einer der Tabellen. Eins der Formulare enthält darüber hinaus eine Befehlsschaltfläche, die das andere Formular öffnet und die Datensätze zwischen den Formularen synchronisiert.

Was möchten Sie tun?

Eine Befehlsschaltfläche erstellen, die ein Formular öffnet und synchronisiert

Detaildatensätze in einem Formular anzeigen, während Sie sich zwischen den Datensätzen eines anderen Formulars bewegen


 Drucken eines Berichts von einem Formular aus

Drucken eines Berichts von einem Formular aus

Sie können das Drucken eines Berichts für den Benutzer automatisieren, indem Sie die Aktionen OpenReport und PrintOut in einem Makro oder einer Ereignisprozedur ausführen. Sie können dem Benutzer das Drucken eines Berichts z.B. durch Klicken auf eine Schaltfläche in einem Formular, durch Wählen eines Befehls in einem benutzerdefinierten Menü oder durch Drücken einer Tastenkombination ermöglichen.

Verwenden Sie die ÖffnenBericht-Aktion, wenn Sie die zu druckenden Datensätze einschränken oder einen Bericht in der Seitenansicht anzeigen möchten. Wenn Sie mit der ÖffnenBericht-Aktion einen Bericht drucken, verwendet Microsoft Access beim Drucken des Berichts die Standardeinstellungen des Dialogfelds Drucken.

Verwenden Sie die Drucken-Aktion, um vor dem Drucken des Berichts Druckoptionen festzulegen. Diese Aktion besitzt Argumente für alle Optionen des Dialogfelds Drucken.

Was möchten Sie tun?

Eine Befehlsschaltfläche erstellen, die einen Bericht druckt

Die ÖffnenBericht- oder Drucken-Aktion in ein Makro einfügen

Die ÖffnenBericht- oder Drucken-Aktion in einer Visual Basic-Prozedur ausführen

Informationen über die ÖffnenBericht-Aktion

Informationen über die Drucken-Aktion erhalten


 Erstellen einer Befehlsschaltfläche zum Drucken des aktuellen Datensatzes

Erstellen einer Befehlsschaltfläche zum Drucken des aktuellen Datensatzes

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf Steuerelement-Assistenten [image] , falls diese Schaltfläche nicht bereits gedrückt ist.

  3. Klicken Sie in der Toolbox auf Befehlsschaltfläche Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Klicken Sie im ersten Dialogfeld des Assistenten im Listenfeld Kategorien auf Datensatzoperationen und dann im Listenfeld Aktionen auf Drucke Datensatz.

  6. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Fertig stellen, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Wenn Sie sich die Ereignisprozedur ansehen möchten, welche die Schaltfläche steuert, öffnen Sie das Eigenschaftenfenster der Schaltfläche, und klicken Sie auf die Generator-Schaltfläche [image] neben dem Einstellungsfeld der Eigenschaft OnClick.

Tipp Sie können den aktuellen Datensatz eines Formulars in einem Bericht ausdrucken, indem Sie in der Ereignisprozedur Click für eine Befehlsschaltfläche die Methode OpenReport des Objekts DoCmd ausführen. Wenn Sie den folgenden Visual Basic für Applikationen-Code in die Click-Ereignisprozedur für eine Befehlsschaltfläche in einem Formular Bestellungen einfügen, wird z. B. der aktuelle Datensatz des Berichts Rechnung gedruckt:

Dim strDocName As String
Dim strFilter As String
strDocName = "Rechnung"
strFilter = "AuftragsNr = Formulare!Aufträge!AuftragsNr"
DoCmd.OpenReport DocName, acViewNormal, , strFilter


 Einstellen des Werts eines Steuerelements oder einer Eigenschaft als Reaktion auf ein Ereignis

Einstellen des Werts eines Steuerelements oder einer Eigenschaft als Reaktion auf ein Ereignis

Durch Zuweisen neuer Werte zu Steuerelementen und Eigenschaften als Reaktion auf Ereignisse in Formularen oder Berichten schaffen Sie die Voraussetzung dafür, dass die von Ihnen erstellten Objekte zusammenarbeiten und somit einfacher zu verwenden sind.

Folgende allgemeine Situationen erfordern das Festlegen von Werten unter Verwendung eines Makros oder einer Ereignisprozedur:

Einstellen des Werts eines Steuerelements in einem Formular auf den Wert eines Steuerelements in einem anderen Formular

Sie können z.B. in ein Formular Kunden eine Befehlsschaltfläche einfügen, die ein Formular Bestellungen öffnet, in das dann automatisch Rechnungsinformationen aus dem Formular Kunden übernommen werden.

Öffnen eines weiteren Formulars von einer Befehlsschaltfläche aus

Aktualisieren des Werts eines Steuerelements, das von dem Wert eines anderen Steuerelements abhängt

Angenommen, Sie haben ein Steuerelement Fälligkeitsdatum, dessen Standardwert das Lieferdatum darstellt (der Wert des Steuerelements Lieferdatum). Sie können dann mit einem Makro oder einer Ereignisprozedur den Wert des Steuerelements Fälligkeitsdatum automatisch zurücksetzen, sobald sich der Wert im Steuerelement Lieferdatum ändert.

Um weitere Informationen über das Festlegen des Werts eines Steuerelements, das auf dem Wert eines anderen Steuerelements basiert, zu erhalten, klicken Sie auf [image] .

Einstellen einer Formular- oder Steuerelementeigenschaft als Reaktion auf eine Auswahl oder ein anderes Ereignis

Sie können mit Hilfe eines Makros oder einer Ereignisprozedur eine Formular- oder Steuerelementeigenschaft für folgende Zwecke einstellen:

  • Ein- oder Ausblenden eines Steuerelements, das auf dem Wert eines anderen Steuerelements basiert. Sie können z.B. das Steuerelement Fälligkeitsdatum in einem Formular Bestellungen ausblenden, wenn die entsprechende Rechnung bereits bezahlt ist (wenn der Wert des Steuerelements Bezahlt auf Ja eingestellt ist), bzw. einblenden, wenn die Zahlung noch nicht eingegangen ist.

  • Deaktivieren oder Sperren eines Steuerelements, das auf dem Wert eines anderen Steuerelements beruht. Sie können z.B. ein Steuerelement Führerschein deaktivieren, wenn der Wert des Steuerelements Alter unter dem Mindestalter für den Erwerb des Führerscheins liegt.

  • Anzeigen verschiedener Gruppen von Datensätzen je nach Auswahl. Sie können z.B. steuern, welche Datensätze in einem Formular Kunden angezeigt werden, abhängig von der ausgewählten Option in einer Optionsgruppe Kundentyp. Stellen Sie hierfür die Eigenschaft Datenherkunft des Formulars auf eine von mehreren Abfragen ein, von denen jede die Datensätze einer bestimmten Kundengruppe enthält.

Um weitere Informationen über das Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis zu erhalten, klicken Sie auf [image] .


 Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements

Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements

Sie können einem Steuerelement, das auf dem Wert eines anderen Steuerelements beruht, einen Wert zuweisen, indem Sie die Aktion SetzenWert in ein Makro einfügen oder eine Zuweisungsanweisung in einer Visual Basic-Prozedur verwenden.

Was möchten Sie tun?

Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung eines Makros

Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung von Visual Basic für Applikationen


 Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis

Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis

Sie können einer Eigenschaft einen Wert zuweisen als Reaktion auf ein Ereignis, wie z. B. das Klicken auf eine Befehlsschaltfläche, indem Sie die Aktion SetzenWert in ein Makro einfügen oder eine Zuweisungsanweisung in einer Visual Basic-Prozedur verwenden.

Was möchten Sie tun?

Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung eines Makros

Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung von Visual Basic für Applikationen


 Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis: Beispiel

Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis: Beispiel

Sie können den Wert einer Eigenschaft basierend auf einem Wert im aktuellen Datensatz einstellen, indem Sie ein Makro oder eine Ereignisprozedur als Reaktion auf das Current-Ereignis des Formulars ausführen. Sie können z. B. das Steuerelement Fälligkeitsdatum in einem Formular Bestellungen ausblenden, wenn die entsprechende Rechnung bereits beglichen ist (wenn der Wert des Steuerelements Bezahlt auf Yes oder True gesetzt ist).

Um ein Makro auszuführen, stellen Sie die Ereigniseigenschaft OnCurrent des Formulars auf den Namen des Makros ein, das die Eigenschaft Visible des Steuerelements Fälligkeitsdatum auf No festlegt, wenn der Wert des Steuerelements Bezahlt auf Yes gesetzt ist.

Festlegen eines Wertes auf der Basis eines Ereignisses

Wenn Sie eine Ereignisprozedur verwenden möchten, fügen Sie den folgenden Visual Basic-Code in die Ereignisprozedur Form_Current ein:

If Me![Bezahlt] = True Then
   Me![Fälligkeitsdatum].Visible = False
Else
   Me![Fälligkeitsdatum].Visible = True
End If


 Anzeigen eines Meldungsfelds

Anzeigen eines Meldungsfelds

Wenn Sie eine kurze Meldung, wie z. B. eine Warnung, anzeigen möchten, können Sie dafür ein vordefiniertes Dialogfeld, ein sogenanntes Meldungsfeld, verwenden. Sie können ein Meldungsfeld anzeigen, indem Sie einem Makro die Aktion Warnmeldung oder einer Visual Basic-Prozedur die Funktion MsgBox hinzufügen.

Was möchten Sie tun?

Ein Meldungsfeld unter Verwendung eines Makros anzeigen

Ein Meldungsfeld unter Verwendung von Visual Basic für Applikationen anzeigen


 Ein- oder Ausblenden von Warnmeldungen

Ein- oder Ausblenden von Warnmeldungen

Sie können die modalen Warnmeldungen, die von Microsoft Access angezeigt werden, während ein Makro oder eine Visual Basic-Prozedur ausgeführt werden, vorübergehend ausblenden oder wieder einblenden, indem Sie die Aktion Warnmeldungen im Makro oder die Aktion SetWarnings in der Prozedur ausführen.

Was möchten Sie tun?

Warnmeldungen unter Verwendung eines Makros ein- oder ausblenden

Warnmeldungen unter Verwendung von Visual Basic für Applikationen ein- oder ausblenden


 Überprüfen der Gültigkeit von Daten unter Verwendung eines Makros oder einer Ereignisprozedur

Überprüfen der Gültigkeit von Daten unter Verwendung eines Makros oder einer Ereignisprozedur

Um die Daten, die in ein Formular unter Verwendung eines Makros, das auf ein Ereignis im Formular reagiert, oder mit Hilfe von Ereignisprozeduren eingegeben worden sind, zu überprüfen, können Sie wiederum ein Makro oder eine Ereignisprozedur verwenden.

Was möchten Sie tun?

Die Gültigkeit von Daten unter Verwendung eines Makros überprüfen

Überprüfen der Gültigkeit von Daten unter Verwendung einer Ereignisprozedur

Mehr über die Verwendung eines Makros oder einer Ereignisprozedur für die Gültigkeitsprüfung von Daten lernen


 Warum werden für die Gültigkeitsprüfung der Daten Makros oder Ereignisprozeduren verwendet?

Warum werden für die Gültigkeitsprüfung der Daten Makros oder Ereignisprozeduren verwendet?

In den meisten Fällen können Sie die korrekte Dateneingabe in ein Steuerelement eines Formulars gewährleisten, indem Sie die Eigenschaft ValidationRule des Steuerelements einstellen oder Gültigkeitsregeln für Datensätze oder Felder in der zugrunde liegenden Tabelle festlegen, an die das Steuerelement gebunden ist. Makros und Ereignisprozeduren bieten eine höhere Leistungsfähigkeit und Flexibilität für umfangreichere Gültigkeitsprüfungen.

Verwenden Sie ein Makro oder eine Ereignisprozedur für die Gültigkeitsprüfung von Daten, wenn

  • Ihre Gültigkeitsregel Bedingen für mehr als einen Wert im Formular umfasst. So können Sie beispielsweise sicherstellen, dass von drei Feldern mindestens zwei ausgefüllt sind, bevor Sie einen Datensatz speichern.

  • Sie für die verschiedenen Fehlerarten eines Feldes unterschiedliche Fehlermeldungen anzeigen möchten. Wenn beispielsweise der eingegebene Wert den zulässigen Bereich überschreitet, können Sie eine bestimmte Meldung anzeigen, und wenn der Wert diesen Bereich unterschreitet, können Sie eine andere Meldung anzeigen.

  • Sie dem Benutzer ermöglichen möchten, Ihre Gültigkeitsregel außer Kraft zu setzen. In diesem Fall können Sie eine Warnmeldung anzeigen, die den Benutzer bittet, die Daten zu bestätigen.

  • die Gültigkeitsprüfung Referenzen auf Steuerelemente in anderen Formularen oder eine Funktion enthält.

  • sich Ihre Gültigkeitsregel für mehrere Formulare verwenden lässt und Sie die Regeln nur einmal definieren möchten. Sie können sich in den Formularen dann jeweils darauf beziehen.

Um weitere Informationen über das Erstellen von Makros zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über das Anpassen einer Ereignisprozedur zu erhalten, klicken Sie auf [image] .


 Gültigkeitsprüfung von Daten mit einer Ereignisprozedur: Beispiel

Gültigkeitsprüfung von Daten mit einer Ereignisprozedur: Beispiel

Es kann vorkommen, dass Sie Gültigkeitsregeln verwenden möchten, die von komplexen Bedingungen abhängig sind. Sie können dann je nach Bedingung verschiedene Aktionen durchführen. Da z.B. in verschiedenen Ländern unterschiedliche Regeln für Postleitzahlen gelten, kann eine Datenbank, die Postleitzahlen speichert, sich nicht auf eine einfache Gültigkeitsregel verlassen, um zu gewährleisten, dass eine Postleitzahl korrekt eingegeben wurde.

Sie können jedoch eine Ereignisprozedur erstellen, die überprüft, welches Land im Steuerelement Land eingegeben wurde, und dann darauf achtet, dass der in das Steuerelement Postleitzahl eingegebene Wert die richtigen Merkmale für dieses Land besitzt.

Öffnen Sie zunächst das Formular, das die Steuerelemente enthält, in der Entwurfsansicht. Fügen Sie dann den folgenden Visual Basic-Code in die Ereignisprozedur BeforeUpdate des Formulars ein, um verschiedene Meldungen, abhängig vom Wert des Steuerelements Land und von der Länge des Eintrags im Steuerelement Postleitzahl, anzuzeigen.

Private Sub Form_BeforeUpdate(Cancel As Integer)
    Select Case Me![Land]
       Case "Frankreich", "Italien", "Spanien"
          If Len(Me![Postleitzahl]) <> 5 Then
             MsgBox "Die Postleitzahl muss 5 Zeichen lang sein."
             Cancel = True
          End If
       Case "Australien", "Singapur"
          If Len(Me![Postleitzahl]) <> 4 Then
             MsgBox "Die Postleitzahl muss 4 Zeichen lang sein."
             Cancel = True
          End If
    End Select
End Sub

Anmerkung Fügen Sie den Visual Basic-Code der BeforeUpdate-Ereignisprozedur des Formulars und nicht der des Steuerelements hinzu, da sich die Gültigkeitsprüfung auf zwei verschiedene Steuerelemente im Formular bezieht.

Wenn Sie nun das Formular verwenden, um einen neuen Lieferanten hinzuzufügen, führt Microsoft Access die Gültigkeitsprozedur aus, nachdem Sie die Eingabe des neuen Datensatzes beendet haben, jedoch noch bevor der Datensatz in der Tabelle Lieferanten gespeichert wird. Wenn eine der Bedingungen der Prozedur erfüllt ist, zeigt Access die entsprechende Meldung an und speichert den Datensatz nicht in der Tabelle.


 Was ist neu bei Makros?

Was ist neu bei Makros?

Microsoft Access 2000 stellt neue Aktionen bereit, mit denen Sie Datenzugriffsseiten und neue Datenbankobjekte, Diagramme, gespeicherte Prozeduren und Sichten in einem Microsoft Access-Projekt (.adp) öffnen können.

  • Öffnen von Datenzugriffsseiten Mit der Aktion ÖffnenDatenzugriffsseite können Sie eine Datenzugriffsseite der aktuellen Datenbank entweder in der Entwurfsansicht oder in der Datenzugriffsseitenansicht öffnen.

  • Öffnen von Diagrammen in Access-Projekten Ein Diagramm im aktuellen Access-Projekt können Sie mit der Aktion ÖffnenDiagramm öffnen.

  • Öffnen von gespeicherten Prozeduren in Access-Projekten Eine gespeicherte Prozedur im aktuellen Access-Projekt können Sie mit der Aktion ÖffnenGespeicherteProzedur öffnen. Die gespeicherte Prozedur kann in der Datenblattansicht, der Entwurfsansicht oder Seitenansicht geöffnet werden.

  • Öffnen von Sichten in Access-Projekten Eine Sicht im aktuellen Access-Projekt können Sie mit der Aktion ÖffnenSicht öffnen.


 Makros: Definition und Funktionsweise

Makros: Definition und Funktionsweise

Was ist ein Makro?

Ein Makro ist eine Gruppe von Aktionen, die jeweils eine bestimmte Operation ausführen, wie z.B. das Öffnen eines Formulars oder das Drucken eines Berichts. Mit Hilfe von Makros können Sie häufig vorkommende Aufgaben automatisieren. Sie können z.B. ein Makro ausführen, das einen Bericht druckt, wenn ein Benutzer auf eine Befehlsschaltfläche klickt.

Makros beinhalten Aktionen und Parameter

Ein Makro kann aus einem einzelnen Makro bestehen, das wiederum eine Reihe von Aktionen enthält, oder aus einer Makrogruppe. Sie können auch über einen bedingten Ausdruck bestimmen, ob bei Ausführung eines Makros in bestimmten Fällen eine Aktion ausgeführt wird.

Eine Folge von Aktionen

Das folgende Makro setzt sich aus einer Reihe von Aktionen zusammen. Microsoft Access führt diese Aktionen bei jeder Ausführung des Makros aus. Um dieses Makro auszuführen, verweisen Sie auf den Makronamen Artikelübersicht.

Makro mit mehreren Aktionen

Eine Makrogruppe

Wenn Sie über zahlreiche Makros verfügen, kann Ihnen das Gruppieren verwandter Makros in Makrogruppen die Verwaltung Ihrer Datenbank erleichtern. Um die Namen der Makros für eine Makrogruppe anzuzeigen, klicken Sie im Menü Ansicht des Makrofensters auf Makronamen.

Die folgende Makrogruppe mit dem Namen Schaltflächen besteht z.B. aus drei verwandten Makros: Personal, Artikel und Repräsentanten. Jedes Makro führt die Aktion ÖffnenFormular aus. Das Makro Artikel führt darüber hinaus die Aktion Positionieren aus.

Beispiel einer Makrogruppe

Der Name in der Spalte Makroname identifiziert die einzelnen Makros. Wenn Sie ein Makro in einer Makrogruppe ausführen, führt Access die Aktion in der Aktionsspalte aus sowie jede sich daran unmittelbar anschließende Aktion, deren Spalte Makroname leer ist.

Um ein Makro in einer Makrogruppe auszuführen, verwenden Sie den Makrogruppennnamen gefolgt von einem Punkt und dem Makronamen. Im vorangehenden Beispiel geben Sie zum Verweisen auf das Makro Personal in der Makrogruppe Schaltflächen Folgendes ein: Schaltflächen.Personal.

Bedingte Aktionen

Um die Spalte Bedingung anzuzeigen, klicken Sie im Menü Ansicht des Makrofensters auf Bedingungen. Das folgende Makro führt die Aktionen Warnmeldung und StoppMakro nur unter der Bedingung aus, dass der Ausdruck in der Spalte Bedingung wahr ist (wenn der Wert Null im Feld Lieferanten-Nr steht).

Beispiel einer bedingten Aktion in einem Makro

Um weitere Informationen zum Erstellen eines Makros anzuzeigen, klicken Sie auf [image] . Zum Anzeigen von Informationen zur Ausführung eines Makros klicken Sie auf [image] .


 Makros oder Visual Basic verwenden?

Makros oder Visual Basic verwenden?

In Microsoft Access können viele Aufgaben mit Hilfe von Makros oder über die Benutzeroberfläche ausgeführt werden. In vielen anderen Datenbankprogrammen setzen die gleichen Aufgaben Programmierarbeiten voraus. Ob sie ein Makro oder Visual Basic für Applikationen verwenden, hängt meistens davon ab, was Sie tun wollen.

Wann sollte ich ein Makro verwenden?

Makros bieten einen einfachen Weg, einfache Aufgaben wie das Öffnen und Schließen von Formularen, Ein- und Ausblenden von Symbolleisten oder das Ausführen von Berichten zu lösen. Die von Ihnen erstellten Datenbankobjekte können schnell und problemlos zusammengeführt werden, da Sie sich nur wenig Syntax merken müssen und die Argumente für jede Aktion im unteren Teil des Makrofensters angezeigt werden.

Neben dem Aspekt der einfachen Anwendung müssen Sie Makros stets bei folgenden Aufgaben verwenden:

  • Erstellen globaler Tastenzuweisungen.

  • Ausführen von Aktionen oder Aktionsabfolgen beim ersten Öffnen Ihrer Datenbank. Sie können bestimmte Vorgänge beim Öffnen einer Datenbank jedoch auch über das Dialogfeld Start auslösen, beispielsweise das Öffnen eines Formulars.

Wann sollte ich Visual Basic verwenden?

Visual Basic an Stelle von Makros sollten Sie bei folgenden Anforderungen verwenden:

  • Einfachere Verwaltung der Datenbank. Da die Makros eigenständige Objekte sind, getrennt von den Formularen und Berichten, die sie verwenden, ist eine Datenbank mit vielen Makros, die auf Ereignisse in Formularen und Berichten reagieren, schwieriger zu verwalten. Demgegenüber sind Visual Basic-Ereignisprozeduren in die Definition des Formulars oder Berichts integriert. Wenn Sie ein Formular oder einen Bericht von einer Datenbank in eine andere übernehmen, wandern die in das Formular bzw. den Bericht integrierten Ereignisprozeduren mit.

  • Erstellen eigener Funktionen. Access enthält eine Vielzahl eingebauter Funktionen, wie beispielsweise die ZINSZ-Funktion, die Zinszahlungen berechnet. Mit Hilfe dieser Funktionen können Sie Berechnungen durchführen, ohne komplizierte Ausdrücke erstellen zu müssen. Mit Visual Basic können Sie darüber hinaus Ihre eigenen Funktionen erstellen; entweder um Berechnungen durchzuführen, welche die Grenzen von Ausdrücken überschreiten, oder um sehr komplexe Ausdrücke zu ersetzen. Außerdem können Sie die von Ihnen erstellten Funktionen in Ausdrücken verwenden, um allgemeine Operationen auf mehr als ein Objekt anzuwenden.

  • Fehlermeldungen anpassen. Wenn unerwartete Ergebnisse auftreten, während ein Benutzer mit der Datenbank arbeitet, und Access eine Fehlermeldung anzeigt, kann der Benutzer oft recht wenig damit anfangen, insbesondere wenn er mit Access nicht vertraut ist. Mit Visual Basic können Sie den Fehler sofort feststellen, wenn er auftritt, und entweder einen eigenen Meldungstext anzeigen oder bestimmte Aktionen durchführen.

  • Erstellen und Verändern von Objekten. In den meisten Fällen dürfte es am einfachsten sein, Objekte jeweils in der Entwurfsansicht zu erstellen oder zu modifizieren. Manchmal möchten Sie jedoch vielleicht die Definition eines Objekts im Code ändern. Mit Visual Basic können Sie sämtliche Objekte einer Datenbank bearbeiten, einschließlich der Datenbank selbst.

  • Ausführen von Aktionen auf Systemebene. Sie können zwar mit der AusführenAnwendung-Aktion in einem Makro von Ihrer Anwendung aus andere Microsoft Windows- oder Microsoft MS-DOS-basierte Anwendungen ausführen, aber viel mehr Operationen außerhalb von Access können Sie mit einem Makro nicht bewerkstelligen. Dagegen können Sie mit Visual Basic beispielsweise überprüfen, ob eine Datei im System existiert, mit Automatisierung oder Dynamic Data Exchange (DDE) mit anderen Windows-basierten Anwendungen wie Microsoft Excel kommunizieren sowie Funktionen in den Dynamic-Link Libraries (DLLs) von Windows aufrufen.

  • Datensätze einzeln verarbeiten. Mit Visual Basic können Sie eine Folge von Datensätzen Schritt für Schritt durchlaufen und eine Operation an jedem einzelnen Datensatz durchführen. Im Gegensatz hierzu arbeiten Makros stets mit ganzen Datensatzgruppen gleichzeitig.

  • Übergeben von Argumenten an Visual Basic-Prozeduren. Sie können beim Erstellen eines Makros zwar Argumente für Makroaktionen im unteren Teil des Makrofensters einstellen, können sie jedoch beim Ausführen des Makros nicht mehr ändern. Mit Visual Basic hingegen können Sie Argumente an Ihren Code auch während der Laufzeit übergeben, und sie können Variablen für Argumente verwenden - was in Makros nicht möglich ist. Dies ermöglicht Ihnen ein hohes Maß an Flexibilität bei der Ausführung Ihrer Visual Basic-Prozeduren.


 Öffnen eines Makros

Öffnen eines Makros

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] .

  2. Klicken Sie auf den Namen des Makros, das Sie öffnen möchten.

  3. Klicken Sie auf die Schaltfläche Entwurf auf der Symbolleiste des Datenbankfensters.

  4. Führen Sie die gewünschten Änderungen am Makro durch. Zum Beispiel:
    • Zum Hinzufügen einer Aktion klicken Sie auf [image] .

    • Zum Verschieben oder Kopieren einer Aktion klicken Sie auf [image] .

    • Zum Hinzufügen einer Bedingung klicken Sie auf [image] .


 Öffnen eines Makros oder des Code-Fensters des Visual Basic-Editors aus einem Formular oder Bericht

Öffnen eines Makros oder des Code-Fensters des Visual Basic-Editors aus einem Formular oder Bericht

  1. Führen Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte eine der folgenden Aktionen aus:
    • Doppelklicken Sie auf den Formularmarkierer oder den Berichtsmarkierer, um das Eigenschaftenfenster für das Formular bzw. den Bericht zu öffnen.

    • Doppelklicken Sie auf den Bereichsmarkierer, um das Eigenschaftenfenster für den Bereich zu öffnen.

    • Stellen Sie sicher, dass ein Steuerelement ausgewählt ist, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] .
  2. Klicken Sie auf die Generator-Schaltfläche [image] neben der gewünschten Ereigniseigenschaft. Wenn Sie z. B. ein Makro oder eine Ereignisprozedur erstellen möchten, das bzw. die ausgeführt werden soll, wenn Sie auf eine Befehlsschaltfläche klicken, klicken Sie auf die Generator-Schaltfläche neben der Ereigniseigenschaft Beim Klicken der Befehlsschaltfläche.

  3. Klicken Sie auf Makro-Generator, um das Makrofenster zu öffnen, oder klicken Sie auf Code-Generator um das Code-Fenster des Visual Basic-Editors zu öffnen.

Anmerkung Wenn Sie den gesamten Code hinter einem Formular oder Bericht anzeigen möchten, klicken Sie im Menü Ansicht auf Code.


Erstellen von Makros

Was möchten Sie tun?

Ein Makro erstellen

Eine Makrogruppe erstellen

Einem Makro eine Aktion hinzufügen

Eine Aktion innerhalb eines Makros verschieben

Einen Ausdruck in ein Makroaktionsargument eingeben

Erfahren, wozu Bedingungen in einem Makro verwendet werden

Makronamen und Bedingungen im Makrofenster ein- und ausblenden


 Erstellen einer Makrogruppe

Erstellen einer Makrogruppe

Wenn Sie mehrere verwandte Makros zu einer Gruppe zusammenfassen möchten, anstatt sie einzeln zu verwalten, können Sie sie als Makrogruppe ablegen.

  1. Klicken Sie im Datenbankfenster unter Objekte auf die Registerkarte Makros [image] .

  2. Klicken Sie in der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie in der Symbolleiste auf Makronamen [image] , wenn diese Schaltfläche nicht bereits aktiviert ist.

  4. Geben Sie in der Spalte Makroname einen Namen für das erste Makro in der Gruppe ein.

  5. Fügen Sie die Aktionen hinzu, die Sie ausführen möchten.

    Wie wird's gemacht?

  6. Wiederholen Sie die Schritte 4 und 5 für alle Makros, die Sie der Makrogruppe hinzufügen möchten.

Anmerkung Wenn Sie die Makrogruppe speichern, erhält sie den Namen, den Sie beim Speichern festlegen. Dieser Name wird im Datenbankfenster in der Liste aller Makros und Makrogruppen angezeigt. Verwenden Sie zum Verweisen auf ein Makro aus einer Makrogruppe immer die folgende Syntax:

Makrogruppenname.Makroname

Der Name Schaltflächen.Artikel verweist z.B. auf das Makro Artikel aus der Makrogruppe Schaltflächen. In einer Liste von Makros, wie z.B. der Argumentliste für Makronamen für die Aktion AusführenMakro, zeigt Microsoft Access das Makro Artikel immer unter dem Namen Schaltflächen.Artikel an.


 Ausführen einer Aktion beim ersten Öffnen einer Datenbank

Ausführen einer Aktion beim ersten Öffnen einer Datenbank

Mit Hilfe eines speziellen Makros, dem sogenannten AutoExec-Makro, können Sie beim ersten Öffnen Ihrer Datenbank eine oder mehrere Aktionen ausführen. Wenn Sie eine Datenbank öffnen, sucht Microsoft Access nach einem Makro mit diesem Namen und führt es, falls vorhanden, automatisch aus.

  1. Erstellen Sie ein Makro, das die Aktionen enthält, die beim Öffnen der Datenbank ausgeführt werden sollen.

    Wie wird's gemacht?

  2. Speichern Sie das Makro unter dem Namen AutoExec.

Beim nächsten Öffnen der Datenbank führt Access dieses Makro automatisch aus.

Anmerkungen

  • Wenn Sie nicht möchten, dass das AutoExec-Makro ausgeführt wird, wenn Sie die Datenbank öffnen, halten Sie während des Öffnens der Datenbank die UMSCHALTTASTE gedrückt.

  • Sie können außerdem das Starten einer Datenbank oder Anwendung steuern, indem Sie im Menü Extras im Dialogfeld Start Optionen festlegen. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Tipps zum Setzen von Aktionsargumenten in einem Makro

Tipps zum Setzen von Aktionsargumenten in einem Makro

Nach dem Hinzufügen einer Aktion zu einem Makro setzen Sie im unteren Teil des Makrofensters die Argumente für die Aktion. Diese Argumente enthalten weitere Informationen, die Microsoft Access zum Ausführen des Makros benötigt.

Nachstehend finden Sie Tipps zum Setzen von Aktionsargumenten.

  • Sie können einen Wert in ein Argumentfeld eingeben oder in vielen Fällen auch eine Einstellung aus einer Liste wählen.

  • Setzen Sie Aktionsargumente möglichst immer in der Reihenfolge, in der diese aufgelistet sind, da bestimmte Argumente die Auswahl nachfolgender Argumente beeinflussen.

  • Wenn Sie eine Aktion durch Ziehen eines Datenbankobjekts aus dem Datenbankfenster zu einem Makro hinzufügen, setzt Microsoft Access automatisch die entsprechenden Argumente für diese Aktion.

  • Wenn eine Aktion ein Argument hat, das nach dem Namen eines Datenbankobjekts fragt, können Sie dieses Argument und das entsprechende Argument für den Objekttyp durch Ziehen des Objekts aus dem Datenbankfenster in das Argumentfeld automatisch einfügen.

  • Sie können zum Setzen vieler Aktionsargumente einen Ausdruck verwenden, vor dem ein Gleichheitszeichen (=) angegeben wird.

  • Zum Anzeigen weiterer Informationen zum Setzen eines bestimmten Aktionsarguments klicken Sie auf das Aktionsargument, und drücken Sie dann F1.


 Eingeben eines Ausdrucks in ein Aktionsargument für ein Makro

Eingeben eines Ausdrucks in ein Aktionsargument für ein Makro

  • Geben Sie ein Gleichheitszeichen (=) gefolgt von dem Ausdruck ein. Der folgende Ausdruck legt z. B. für das Aktionsargument den Wert aus dem Steuerelement Firmenliste fest:

    =[Firmenliste]

Es gibt jedoch zwei Ausnahmen: das Argument Ausdruck der Aktion SetzenWert und das Argument Wiederholbedingung der Aktion AusführenMakro. Wenn Sie in diesen Argumenten vor einem Ausdruck ein Gleichheitszeichen angeben, wertet Microsoft Access den Ausdruck zweimal aus. Dies kann zu unerwarteten Ergebnissen führen.

Tipp In einer Microsoft Access-Datenbank (.MDB) können Sie auf die Generator-Schaltfläche [image] klicken, um den Ausdrucks-Generator zu verwenden. Der Ausdrucks-Generator steht nicht für ein Microsoft Access-Projekt zur Verfügung.

Um weitere Informationen zum Setzen von Aktionsargumenten in einem Makro anzuzeigen, klicken Sie auf [image] .


 Warum werden in einem Makro Bedingungen verwendet?

Warum werden in einem Makro Bedingungen verwendet?

In bestimmten Fällen möchten Sie vielleicht eine Aktion oder eine Reihe von Aktionen in einem Makro nur dann ausführen, wenn eine bestimmte Bedingung wahr ist. Angenommen, Sie verwenden ein Makro zum Überprüfen von Daten in einem Formular und möchten auf verschiedene Kombinationen von Werten, die in einen Datensatz eingegeben werden, verschiedene Meldungen ausgeben. In solchen Fällen können Sie Bedingungen verwenden, die den Ablauf des Makros steuern.

Das folgende Makro führt z.B. die Aktion StoppMakro aus, wenn im Feld Land kein Wert enthalten ist (wenn der Wert gleich Null ist). Es führt mehrere verknüpfte Aktionen Warnmeldung und AbbrechenEreignis aus, wenn die Länge oder das Format des Wertes im Feld PLZ nicht dem Wert im Feld Land entspricht, d.h. für das aufgeführte Land nicht gültig ist.

Bedingtes Makro, das abhängig von den Werten in den Feldern "Land" und "PLZ" unterschiedliche Aktionen durchführt

Eine Bedingung ist ein logischer Ausdruck. Das Makro führt abhängig davon, ob eine Bedingung wahr oder falsch ist, unterschiedliche Aktionen aus. Zum Anzeigen von Beispielen für Makrobedingungen klicken Sie auf [image] .

Bedingungen werden im Makrofenster in die Spalte Bedingung eingegeben. Wenn eine Bedingung wahr ist, führt Microsoft Access die in dieser Zeile enthaltene Aktion aus. Sie können festlegen, dass Microsoft Access eine Reihe von Aktionen ausführt, wenn eine Bedingung wahr ist. Dazu geben Sie für alle Aktionen, die direkt hinter der Bedingung folgen, in der Spalte Bedingung ein Auslassungszeichen (...) ein.

Zum Anzeigen von Informationen darüber, wie ein Makro unter bestimmten Bedingungen ausgeführt wird, klicken Sie auf [image] .


 Festlegen von Bedingungen für das Ausführen von Makros

Festlegen von Bedingungen für das Ausführen von Makros

  1. Klicken Sie im Makrofenster in der Symbolleiste auf Bedingungen [image] .

  2. Geben Sie in der Spalte Bedingung für die Zeile, für die Sie die Bedingung festlegen möchten, einen bedingten Ausdruck ein.

    Anmerkungen

    • Klicken Sie in einer Microsoft Access-Datenbank (.mdb) auf die Aufbauen-Schaltfläche, [image] um den Ausdrucks-Generator zu verwenden. In Microsoft Access-Projekten ist der Ausdrucks-Generator nicht verfügbar.

    • In einer Makrospalte Bedingung können Sie keinen SQL-Ausdruck verwenden.
  3. Geben Sie in die Spalte Aktion die Aktion ein, die Microsoft Access ausführen soll, wenn die Bedingung wahr ist.

Beim Ausführen des Makros wertet Microsoft Access den ersten bedingten Ausdruck aus. Ist die Bedingung wahr, werden die Aktion in der entsprechenden Zeile und alle die direkt folgenden Aktionen ausgeführt, vor denen in der Spalte Bedingung ein Auslassungszeichen (...) angegeben ist. Das folgende Makro führt z. B. die Aktionen Warnmeldung und StoppMakro nur dann aus, wenn im Feld Lieferanten-Nr kein Wert enthalten ist (wenn der Wert gleich Null ist).

Makro mit einem bedingten Ausdruck

Danach führt Microsoft Access weitere im Makro enthaltene Aktionen aus, für die die Spalte Bedingung leer ist, bis ein weiterer Ausdruck, ein Makroname oder das Ende des Makros erreicht ist.

Wenn eine Bedingung falsch (nicht erfüllt) ist, ignoriert Microsoft Access die Aktion und die nachfolgenden Aktionen, die in der Spalte Bedingung durch ein Auslassungszeichen (...) gekennzeichnet sind. Anschließend wird die nächste Aktion ausgeführt, die in der Aktionszeile eine andere Bedingung enthält oder für die die Spalte Bedingung leer ist.

Zum Anzeigen von Beispielen für Makrobedingungen klicken Sie auf [image] . Zum Anzeigen von Informationen zum Erstellen von Ausdrücken klicken Sie auf [image] .


 Ein- und Ausblenden von Makronamen und Bedingungen im Makrofenster

Ein- und Ausblenden von Makronamen und Bedingungen im Makrofenster

  • Klicken Sie in der Symbolleiste auf Makronamen [image] , um die Spalte Makroname ein- oder auszublenden, oder klicken Sie auf Bedingungen [image] , um die Spalte Bedingung ein- oder auszublenden.

Um festzulegen, ob Microsoft Access diese Spalten beim Erstellen von Makros automatisch ein- oder ausblendet, klicken Sie im Menü Extras auf Optionen. Dann klicken Sie auf die Registerkarte Ansicht und aktivieren oder deaktivieren unter Im Makroentwurf anzeigen das Kontrollkästchen Namenspalte bzw. das Kontrollkästchen Bedingungsspalte.


 Makrobedingungen - Beispiele

Makrobedingungen - Beispiele

Ausdruck | Bedingung
[Ort]="Paris" | Führt die Aktion aus, wenn Paris der Wert im Feld Ort des Formulars ist, aus dem das Makro ausgeführt wird.
DomAnzahl ("[Bestell-Nr]"; "Bestellungen")>35 | Führt die Aktion aus, wenn das Feld Bestell-Nr in der Tabelle Bestellungen mehr als 35 Einträge enthält.
DomAnzahl ("*"; "Bestelldetails"; "[Bestell-Nr]=Formulare![Bestellungen]![Bestell-Nr]")>3 | Führt die Aktion aus, wenn im Feld Bestell-Nr der Tabelle Bestelldetails mehr als drei Einträge enthalten sind, für die es im Feld Bestell-Nr im Formular Bestellungen mehr als drei identische Einträge gibt.
[Versanddatum] Zwischen #02.02.1995# Und #02.03.1995# | Führt die Aktion aus, wenn der Wert im Feld Versanddatum in dem Formular, aus dem das Makro ausgeführt wird, nicht vor dem 2. Februar und nicht nach dem 2. März 1995 liegt.
Formulare![Artikel]![Lagerbestand]<5 | Führt die Aktion aus, wenn der Wert im Feld Lagerbestand im Formular Artikel kleiner als fünf ist.
IstNull([Vorname]) | Führt die Aktion aus, wenn der Wert im Feld Vorname in dem Formular, aus dem das Makro ausgeführt wird, gleich Null ist (wenn das Feld keinen Wert enthält). Dieser Ausdruck ist identisch mit dem Ausdruck [Vorname] IstNull.
[Land]="D" Und Formulare![Gesamtverkäufe)]![Gesamtbestellungen]>100 | Führt die Aktion aus, wenn der Wert im Feld Land in dem Formular, aus dem das Makro ausgeführt wird, gleich D und der Wert im Feld Gesamtbestellungen im Formular Gesamtverkäufe größer als 100 ist.
[Land] In ("Frankreich"; "Italien"; "Spanien") Und Länge([PLZ])<>5 | Führt die Aktion aus, wenn der Wert im Feld Land des Formulars, aus dem das Makro ausgeführt wird, entweder Frankreich, Italien oder Spanien und der Wert im Feld PLZ nicht 5 Zeichen lang ist.
Meldung("Änderungen bestätigen?";1)=1 | Führt die Aktion aus, wenn Sie in einem Dialogfeld, das die Funktion Meldung anzeigt, auf OK klicken. Wenn Sie im Dialogfeld auf Abbrechen klicken, ignoriert Microsoft Access die Aktion.

Tipp Wenn Sie möchten, dass Microsoft Access eine Aktion vorübergehend ignoriert, geben Sie eine Falsch-Bedingung ein. Das vorübergehende Ignorieren einer Aktion kann hilfreich sein, wenn Sie nach Fehlern in einem Makro suchen.


 Automatisches Einfügen eines Seitenumbruchs unter einer bestimmten Bedingung

Automatisches Einfügen eines Seitenumbruchs unter einer bestimmten Bedingung

Sie können beim Erfüllen einer bestimmten Bedingung einen Seitenumbruch in einem Bericht durchführen, indem Sie die Eigenschaft Visible eines Steuerelements für Seitenumbruch in einem Makro oder einer Ereignisprozedur einstellen.

Was möchten Sie tun?

Ein Makro verwenden, um einen Seitenumbruch in einem Bericht durchzuführen, wenn eine Bedingung erfüllt ist

Visual Basic für Applikationen verwenden, um einen Seitenumbruch in einem Bericht durchzuführen, wenn eine Bedingung erfüllt ist


Anzeigen von Detaildatensätzen beim Bewegen zwischen Datensätzen unter Verwendung eines Makros: Beispiel

Wenn Sie sich zwischen den Lieferantendatensätzen in einem Formular Lieferanten bewegen, möchten Sie sicher auch die Artikel der einzelnen Lieferanten in einem Formular Artikelliste anzeigen. Um dies zu ermöglichen, können Sie die Aktion ÖffnenFormular in einem Makro, das als Reaktion auf das Current-Ereignis des Formulars Lieferanten startet, ausführen. Sie können sich im Formular Artikelliste Datensätze anzeigen lassen, deren Wert im Feld Lieferanten-Nr in der zugrunde liegenden Tabelle mit dem Wert im Feld Lieferanten-Nr des Formulars Lieferanten übereinstimmt. Setzen Sie das Argument Bedingung der Aktion wie folgt:

[Lieferanten-Nr]=Formulare![Lieferanten]![Lieferanten-Nr]

Tipp Wenn das Formular Artikel nicht immer geöffnet werden soll, wenn Sie sich zwischen den Datensätzen im Formular Lieferanten bewegen, fügen Sie einen bedingten Ausdruck in das Makro ein, der überprüft, ob das Formular Artikel geöffnet ist oder nicht.

Anzeigen von Datensätzen in einer anderen Tabelle unter Verwendung eines Makros

Setzen Sie nach dem Erstellen des Makros die BeimAnzeigen-Eigenschaft des Formulars Lieferanten auf den Makronamen.


 Konvertieren von Makros zu Microsoft Visual Basic

Konvertieren von Makros zu Microsoft Visual Basic

Microsoft Access kann Makros automatisch zu Visual Basic-Ereignisprozeduren oder -Modulen konvertieren, die gleichartige Aktionen mit Hilfe von Visual Basic-Code ausführen. Sie können Makros in einem Formular oder Bericht konvertieren, oder Sie können globale Makros konvertieren, die keinem bestimmten Formular oder Bericht zugeordnet sind.

Was möchten Sie tun?

Makros in einem Formular oder Bericht konvertieren

Globale Makros konvertieren


 Ausführen einer Makroaktion in einer Visual Basic-Prozedur

Ausführen einer Makroaktion in einer Visual Basic-Prozedur

Microsoft Access definiert ein spezielles Objekt, DoCmd, mit dem Sie Makroaktionen in Visual Basic-Prozeduren ausführen können. Sie führen eine Aktion aus, indem Sie Ihrer Prozedur eine Methode des Objekts DoCmd hinzufügen. Die meisten Aktionen haben eine entsprechende DoCmd-Methode.

  • Fügen Sie in der Prozedur die DoCmd-Methode hinzu, die der Aktion entspricht, und verwenden Sie dabei die folgende Syntax:

    DoCmd.Methode [Argumente]

Methode ist der Name einer Methode. Argumente sind die Methodenargumente, die ggf. verwendet werden.

Um z.B. eine Prozedur zu erstellen, die die Aktion ÖffnenFormular ausführt, fügen Sie der Prozedur die Methode OpenForm des Objekts DoCmd hinzu. Die folgende Methode entspricht der Aktion ÖffnenFormular und öffnet das Formular Artikel hinzufügen:

DoCmd.OpenForm "Artikel hinzufügen"

Acht Makroaktionen sind keine entsprechenden DoCmd-Methoden zugeordnet, obwohl es für einige gleichwertige Visual Basic-Anweisungen oder -Funktionen gibt. Zum Anzeigen einer Liste dieser Aktionen und ihrer Visual Basic-Äquivalente klicken Sie auf [image] .


Makroaktionen ohne entsprechende DoCmd-Methoden

Aktion | Visual Basic-Äquivalent
HinzufügenMenü | Kein Äquivalent
Meldung | Funktion MsgBox
AusführenAnwendung | Funktion Shell
AusführenCode | Prozeduraufruf (Anweisung Call)
Tastaturbefehle | Anweisung SendKeys
SetzenWert | Zuweisungsanweisung (Anweisung Let)
StoppAlleMakros | Anweisungen Stopp oder End
StoppMakro | Anweisungen Exit Sub oder Exit Function


 Ausführen eines Makros

Ausführen eines Makros

Wenn Sie ein Makro ausführen, beginnt Microsoft Access am Anfang des Makros und führt alle im Makro enthaltenen Aktionen aus, bis ein anderes Makro (wenn es sich um ein solches in einer Makrogruppe handelt) oder das Ende des Makros erreicht ist.

Sie können ein Makro direkt, aus einem anderen Makro, aus einer Ereignisprozedur oder als Antwort auf ein Ereignis in einem Formular oder Bericht oder in einem Steuerelement eines Formulars oder Berichts ausführen. Sie können ein Makro z. B. einer Befehlsschaltfläche in einem Formular zuordnen. Es wird dann ausgeführt, wenn der Benutzer auf die Schaltfläche klickt. Sie können zum Ausführen eines Makros auch einen benutzerdefinierten Menübefehl oder eine Schaltfläche auf einer Symbolleiste erstellen, einem Makro eine Tastenkombination zuweisen oder ein Makro automatisch beim Öffnen einer Datenbank ausführen.

Was möchten Sie tun?

Ein Makro direkt ausführen

Ein Makro in einer Makrogruppe ausführen

Ein Makro aus einem anderen Makro oder aus einer Ereignisprozedur ausführen

Ein Makro als Reaktion auf ein Ereignis in einem Formular, Bericht oder Steuerelement ausführen

Ein Befehlsschaltfläche erstellen, die ein Makro ausführt

Einen Menübefehl zum Ausführen eines Makros hinzufügen

Eine Symbolleistenschaltfläche zum Ausführen eines Makros hinzufügen

Einer Tastenkombination ein Makro zuweisen

Ein Makro beim ersten Öffnen einer Datenbank ausführen


 Ausführen eines Makros aus einem anderen Makro oder aus einer Visual Basic-Prozedur

Ausführen eines Makros aus einem anderen Makro oder aus einer Visual Basic-Prozedur

Um ein Makro aus einem anderen Makro oder aus einer Visual Basic-Prozedur auszuführen, fügen Sie die Aktion AusführenMakro zu Ihrem Makro oder RunMacro zu Ihrer Prozedur hinzu.

  • Zum Hinzufügen der Aktion AusführenMakro klicken Sie in der Aktionsliste in einer leeren Aktionszeile auf AusführenMakro und legen den Namen des auszuführenden Makros im Argument Makroname fest.

  • Zum Hinzufügen der Aktion AusführenMakro zu einer Visual Basic-Prozedur fügen Sie die Methode RunMacro des Objekts DoCmd zur Prozedur hinzu und geben den Namen des Makros an, das Sie ausführen möchten. Mit der folgenden Methode RunMacro wird z. B. das Makro Makro1 ausgeführt:

    DoCmd.RunMacro "Makro1"

Um weitere Informationen zur Aktion AusführenMakro anzuzeigen, klicken Sie auf [image] .


 Suchen nach Fehlern in einem Makro durch Einzelschrittausführung

Suchen nach Fehlern in einem Makro durch Einzelschrittausführung

Durch Ausführen eines Makros in Einzelschritten können Sie sich den Ablauf des Makros und die Ergebnisse jeder Aktion anzeigen lassen und feststellen, welche Aktion einen Fehler hervorruft oder zu unerwünschten Ergebnissen führt.

  1. Öffnen Sie das Makro.

    Wie wird's gemacht?

  2. Klicken Sie auf der Symbolleiste auf Einzelschritt [image] .

  3. Klicken Sie auf der Symbolleiste auf Ausführen [image] .

  4. Klicken Sie auf Schritt, um die im Dialogfeld Einzelschritt angezeigte Aktion auszuführen.

  5. Klicken Sie auf Anhalten, wenn Sie das Makro beenden und das Dialogfeld schließen möchten.

  6. Klicken Sie auf Weiter, wenn Sie die Einzelschrittausführung beenden und den verbleibenden Teil des Makros ohne Unterbrechung ausführen möchten.

Tipp Zum Unterbrechen der Ausführung eines Makros und Starten der Einzelschrittausführung, drücken Sie STRG+UNTBR.


 Zuweisen einer Aktion oder einer Gruppe von Aktionen zu einer Taste

Zuweisen einer Aktion oder einer Gruppe von Aktionen zu einer Taste

Sie können einer bestimmten Taste oder Tastenkombination eine Aktion oder eine Gruppe von Aktionen zuweisen, indem Sie eine Makrogruppe zur Tastaturbelegung erstellen. Beim Drücken der Taste oder der Tastenkombination führt Microsoft Access die entsprechende Aktion aus.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] .

  2. Klicken Sie auf Neu.

  3. Klicken Sie in der Symbolleiste auf Makronamen [image] .

  4. Geben Sie in der Spalte Makroname die Taste oder Tastenkombination ein, der Sie die Aktion oder Gruppe von Aktionen zuweisen möchten.

    Um Informationen über die Tastenkombinationen zu erhalten, die Sie für Tastenzuweisungen verwenden können, klicken Sie auf [image] .

  5. Fügen Sie die Aktion oder Gruppe von Aktionen hinzu, die von der Taste oder Tastenkombination ausgeführt werden soll. Sie können beispielsweise die Aktion AusführenMakro hinzufügen, die das Makro Drucken ausführt, wenn die Tastenkombination STRG+P gedrückt wird.

    Auswählen einer Makroaktion die mit einer von Ihnen festgelegten Tastenkombination ausgeführt werden soll

  6. Wiederholen Sie die Schritte 4 und 5 für alle Tastenzuweisungen, die Sie vornehmen möchten.

  7. Speichern Sie die Makrogruppe dann unter dem Namen AutoKeys.

Die neuen Tastenbelegungen werden wirksam, sobald Sie die Makrogruppe speichern und immer dann, wenn die Datenbank geöffnet wird.

Anmerkung Wenn Sie eine Gruppe von Aktionen einer Tastenkombination zuordnen, die bereits von Access verwendet wird (beispielsweise STRG+C, der Tastenkombination für Kopieren), ersetzen die von Ihnen zugewiesenen Aktionen die ursprüngliche Access-Tastenbelegung.


 AutoKeys-Tastenkombinationen

AutoKeys-Tastenkombinationen

In der folgenden Tabelle sind die Tastenkombinationen aufgelistet, die Sie für Tastenzuweisungen in einer Makrogruppe zur Tastaturbelegung verwenden können. Diese Tastenkombinationen stellen eine Teilmenge der Syntax dar, die in der Anweisung SendKeys in Visual Basic verwendet wird. Um weitere Informationen zur Syntax der Anweisung SendKeys zu erhalten, klicken Sie auf [image] .

SendKeys-Syntax | Tastenkombination
^A oder ^4 | STRG+beliebige alphanumerische Taste
{F1} | Beliebige Funktionstaste
^{F1} | STRG+beliebige Funktionstaste
+{F1} | UMSCHALT+beliebige Funktionstaste
{EINFG} | EINFG
^{EINFG} | STRG+EINFG
+{EINFG} | UMSCHALT+EINFG
{ENTF} | ENTF
^{ENTF} | STRG+ENTF
+{ENTF} | UMSCHALT+ENTF


 Aufrufen von Hilfe zu Visual Basic

Aufrufen von Hilfe zu Visual Basic

Es gibt viele Möglichkeiten, Hilfeinformationen bei Fragen zu Microsoft Visual Basic und zu Visual Basic-Schlüsselwörtern anzuzeigen. Es folgt eine Beschreibung der gebräuchlichsten und nützlichsten dieser Möglichkeiten zum Anzeigen von Hilfeinformationen.

Sie haben folgende Möglichkeiten, um auf die Hilfe zuzugreifen:

  • Drücken Sie F1 in einem Visual Basic-Modul. Während der Arbeit in einem Modul können Sie direkt Hilfe zu einer Methode, Eigenschaft, Funktion, Anweisung oder einem Objekt anzeigen. Dazu klicken Sie in einer Codezeile auf das Schlüsselwort und drücken dann F1.

  • Drücken Sie F1 in einem Objektkatalog. Mit Hilfe des Objektkatalogs können Sie Informationen zu Objekten, Eigenschaften, Methoden und Konstanten anzeigen. Um Informationen zum Verwenden des Objektkatalogs anzuzeigen, klicken Sie auf [image] .

  • Befragen Sie den Office-Assistenten. Um die Sprechblase des Assistenten anzuzeigen und eine Frage einzugeben, klicken Sie in der Symbolleiste auf Office-Assistent. Falls der Assistent bereits ohne Sprechblase angezeigt wird, klicken Sie auf diesen. Der Office-Assistent erleichtert Ihnen die Suche nach bestimmten Themen. Geben Sie einfach die Methode, Eigenschaft, Funktion oder Anweisung ein, zu der Sie Hilfeinformationen anzeigen möchten, oder geben Sie eine Frage ein, und wählen Sie dann eines der Themen, die der Assistent anbietet. Je spezifischer Ihre Frage ist, desto spezifischer ist das angebotene Thema. Ein Beispiel für eine spezifische Frage lautet: "Wie programmiere ich mein Formular, um die Daten automatisch zu aktualisieren?"

    Anmerkungen

    • Wenn der Visual Basic-Editor aktiv ist, sucht der Office-Assistent standardmäßig nur Themen in Hilfedateien zur Programmierung. Um die Voreinstellung so zu ändern, dass Hilfedateien zur Programmierung und zum Produkt angezeigt werden, klicken Sie mit der rechten Maustaste auf den Office-Assistenten. Anschließend klicken Sie auf Optionen und wählen dann Sowohl Produkt- als auch Programmierhilfe während der Programmierung durchsuchen.

    • Wenn ein anderes Fenster als der Visual Basic-Editor aktiv ist, sucht der Office-Assistent standardmäßig nur Themen in Hilfedateien zum Produkt. Hilfe zu Aktionen und Microsoft Access-Eigenschaften ist sowohl in der Produkt- als auch in der Programmierhilfe verfügbar.

  • Verwenden Sie die Registerkarten "Inhalt" und "Suchen". Das Dialogfeld Hilfethemen enthält mehrere Registerkarten, über die Sie auf unterschiedliche Art und Weise auf Hilfeinformationen zugreifen können.

    • Klicken Sie auf die Registerkarte Inhalt, und doppelklicken Sie dann auf Microsoft Access Programmier- und Sprachverzeichnis oder auf das Buch Visual Basic für Applikationen, um Kategorien von Referenzinformationen anzuzeigen, wie z. B. Aktionen, Ereignisse, Funktionen, Objekte und Auflistungen, Methoden, Eigenschaften und Anweisungen. Doppelklicken Sie auf ein Kategoriebuch, um Themenlisten für jede Kategorie anzuzeigen.

      Um ein Thema oder Themenbuch zu drucken, wählen Sie das Thema oder Buch aus, und klicken Sie dann auf Drucken.

    • Klicken Sie auf die Registerkarte Suchen und dann auf das gewünschte Thema.

Tipps

  • Um zwischen Ihrer Anwendung und der Sprachverzeichnis-Hilfe zu wechseln, drücken Sie ALT+TAB, oder verwenden Sie die Windows-Taskleiste. Wenn die Hilfe geöffnet bleibt, können Sie sofort zu dem zuletzt angezeigten Thema zurückkehren.


 Kopieren von Visual Basic-Codebeispielen aus dem Hilfefenster in das Code-Fenster

Kopieren von Visual Basic-Codebeispielen aus dem Hilfefenster in das Code-Fenster

  1. Markieren Sie im Hilfethema den Beispielcode, den Sie kopieren möchten, und klicken Sie dann mit der rechten Maustaste darauf.

  2. Klicken Sie im Kontextmenü auf Kopieren.

  3. Wechseln Sie zum Visual Basic-Editor.

  4. Fügen Sie das Beispiel in das Code-Fenster Ihres Moduls ein.


 Module: Definition und Funktionsweise

Module: Definition und Funktionsweise

Was ist ein Modul?

Ein Modul ist eine Auflistung von Visual Basic für Applikationen-Deklarationen und -Prozeduren, die zusammen als eine Einheit gespeichert sind.

Bestandteile eines Moduls

Es werden zwei Grundtypen von Modulen unterschieden: Klassenmodule and Standardmodule. Jede Prozedur in einem Modul kann eine Funktion oder eine Sub-Prozedur sein.

Klassenmodule

Formular- und Berichtsmodule sind Klassenmodule, die mit einem bestimmten Formular oder Bericht verbunden sind. Formular- und Berichtsmodule enthalten häufig Ereignisprozeduren, die als Reaktion auf ein Ereignis in dem Formular oder Bericht ausgeführt werden. Mit Hilfe dieser Ereignisprozeduren können Sie das Verhalten Ihrer Formular und Berichte sowie ihre Reaktion auf Benutzeraktionen, wie z.B. das Klicken auf eine Befehlsschaltfläche, steuern.

Wenn Sie die erste Ereignisprozedur für ein Formular oder einen Bericht erstellen, erstellt Microsoft Access automatisch ein dazugehöriges Formular- oder Berichtsmodul. Zum Anzeigen des Moduls für ein Formular oder einen Bericht, klicken Sie in der Formular- oder Berichts-Entwurfsansicht in der Symbolleiste auf Code [image] .

Zur Auswahl einer Prozedur müssen ein Objekt und ein Ereignis ausgewählt werden

Prozeduren in Ihren Formular- und Berichtsmodulen können Prozeduren aufrufen, die Sie Standardmodulen hinzugefügt haben.

In Access 95 existieren Klassenmodule nur in Verbindung mit einem Formular oder Bericht. In Access 97 oder späteren Versionen können Klassenmodule auch unabhängig von einem Formular oder Bericht existieren. Klassenmodule dieser Art sind als Module in der Objekte-Liste des Datenbankfensters aufgelistet. Mit Hilfe eines Klassenmoduls der Module-Auflistung können Sie eine Definition für ein benutzerdefiniertes Objekt erstellen. Zum Anzeigen weiterer Informationen zur Programmierung mit diesen Klassenmodulen anzuzeigen, klicken Sie auf [image] .

Standardmodule

Standardmodule enthalten allgemeine Prozeduren, die nicht mit einem anderen Objekt verbunden sind, sowie häufig verwendete Prozeduren, die von jeder beliebigen Stelle innerhalb Ihrer Datenbank aus ausgeführt werden können.

Standardmodule enthalten Prozeduren, die überall in der Datenbank verfügbar sind

Sie können die Liste der Standardmodule in Ihrer Datenbank anzeigen, indem Sie im Datenbankfenster unter Objekte auf den Eintrag Module klicken. Formular-, Berichts- und Standardmodule sind ferner im Objektkatalog aufgelistet.

Zum Anzeigen weiterer Informationen zu Prozeduren klicken Sie auf [image] .


 Was ist eine Prozedur?

Was ist eine Prozedur?

Eine Prozedur ist eine Einheit von Visual Basic-Code. Sie enthält eine Reihe von Anweisungen und Methoden, die eine Operation durchführen oder einen Wert berechnen. Die folgende Ereignisprozedur verwendet beispielsweise die Methode OpenForm, um das Formular Bestellungen zu öffnen:

Private Sub ÖffnenBestellungen_Click()

    DoCmd.OpenForm "Bestellungen"

End Sub

Es gibt zwei Arten von Prozeduren:

  • Sub-Prozeduren führen eine Operation oder eine Reihe von Operationen durch, geben jedoch keinen Wert zurück. Sie können eigene Sub-Prozeduren erstellen oder die Vorlagen für Ereignisprozeduren verwenden, die Microsoft Access definiert.

    Jedes Formular und jeder Bericht in Ihrer Datenbank enthält ein eingebautes Formularmodul bzw. Berichtsmodul mit Vorlagen für Ereignisprozeduren. Sie können Code hinzufügen, der als Reaktion auf Ereignisse ausgeführt wird, die im Formular oder Bericht oder in den Steuerelementen des Formulars oder Berichts eintreten. Wenn Microsoft Access erkennt, dass ein Ereignis in einem Formular, Bericht oder Steuerelement eingetreten ist, führt es automatisch die für das Objekt und Ereignis benannte Ereignisprozedur aus. So können Sie beispielsweise eine Ereignisprozedur schreiben, die den Fokus auf das Textfeld NameDesGatten setzt, wenn der Benutzer das Kontrollkästchen Verheiratet aktiviert.

    Tipp Viele Assistenten (wie beispielsweise der Befehlsschaltflächen-Assistent) erstellen automatisch Ereignisprozeduren für ein Objekt, wenn Sie das Objekt erstellen. Sie können diese Ereignisprozeduren anzeigen, um Beispiele dafür zu erhalten, wie Prozeduren funktionieren.

  • Funktion-Prozeduren (auch einfach Funktionen genannt) geben einen Wert zurück, wie beispielsweise das Ergebnis einer Berechnung. Microsoft Visual Basic enthält viele eingebaute Funktionen. Die Funktion Now zeigt beispielsweise das aktuelle Datum und die aktuelle Uhrzeit an. Neben diesen eingebauten Funktionen können Sie eigene benutzerdefinierte Funktionen erstellen.

    Da Funktionen Werte zurückgeben, können Sie sie in Ausdrücken verwenden. Sie können Funktionen in Ausdrücken an vielen Stellen in Microsoft Access verwenden, einschließlich in einer Visual Basic-Anweisung oder -Methode, in vielen Eigenschafteneinstellungen oder in einem Kriterienausdruck in einem Filter oder einer Abfrage.

Dieses Beispiel für eine Funktion, ErsterDesNächstenMonats, zeigt das Datum des ersten Tages des Monats an, der auf das aktuelle Datum folgt:

Function ErsterDesNächstenMonats()

    ErsterDesNächstenMonats = _
        DateSerial(Year(Now), Month(Now) + 1, 1)

End Function

Diese benutzerdefinierte Funktion besteht aus einer einzigen Zuweisungsanweisung, die das Ergebnis eines Ausdrucks (auf der rechten Seite des Gleichheitszeichens [=]) dem Namen der Funktion, ErsterDesNächstenMonats (auf der linken Seite des Gleichheitszeichens), zuweist. Sie berechnet das Ergebnis mit Hilfe der eingebauten Visual Basic-Funktionen DateSerial, Year, Now und Month.

Nachdem Sie diese Funktion erstellt haben, können Sie sie in einem Ausdruck in Microsoft Access beliebig verwenden. Sie können beispielsweise festlegen, dass ein Textfeld den ersten Tag des Monats, der auf das aktuelle Datum folgt, als Standardwert anzeigt, indem Sie die Eigenschaft DefaultValue des Textfeld-Steuerelements auf den folgenden Ausdruck im Eigenschaftenfenster einstellen:

=ErsterDesNächstenMonats()

Anmerkung Um eine Funktion als Eigenschafteneinstellung verwenden zu können, muss sich diese im Formular- oder Berichtsmodul oder in einem Standardmodul befinden. Sie können eine Funktion nicht in einem Klassenmodul, das keinem Formular oder Bericht zugeordnet ist, als Eigenschafteneinstellung für Formulare oder Berichte verwenden.

Sowohl Sub-Prozeduren als auch Funktionen akzeptieren Argumente. Um Informationen zum Verwenden von Argumenten in Visual Basic anzuzeigen, klicken Sie auf [image] .


 Erstellen einer benutzerdefinierten Visual Basic-Prozedur

Erstellen einer benutzerdefinierten Visual Basic-Prozedur

Indem Sie Ihre Datenbank durch die Einbeziehung von Visual Basic-Prozeduren erweitern, können Sie Einfluss darauf nehmen, wie die Tabellen, Formulare, Berichte und Abfragen in der Datenbank zusammenarbeiten. Es gibt mehrere Arten von Prozeduren. Sie können eine Ereignisprozedur erstellen, indem Sie vordefinierten Vorlagen in einem Formularmodul oder Berichtsmodul Code hinzufügen. Sie können auch Ihre eigenen Funktionen oder Sub-Prozeduren in Standardmodulen oder in Klassenmodulen (zu denen Formular- und Berichtsmodule gehören) erstellen.

Sie können Prozeduren in einem Standardmodul oder einem Klassenmodul aus Ausdrücken, anderen Prozeduren, Ereignisprozeduren, Prozeduren in anderen Modulen und Makros aufrufen. Ereignisprozeduren werden automatisch als Reaktion auf Ereignisse ausgeführt, die in einem Formular, Bericht oder Steuerelement eintreten, wie z.B. Mausklicks.

Was möchten Sie tun?

Eine benutzerdefinierte Funktion erstellen

Eine benutzerdefinierte Sub-Prozedur erstellen

Eine Ereignisprozedur erstellen


 Erstellen eines Klassenmoduls, das nicht mit einem Formular oder Bericht verbunden ist

Erstellen eines Klassenmoduls, das nicht mit einem Formular oder Bericht verbunden ist

  1. Klicken Sie im Datenbankfenster oder im Visual Basic-Editor im Menü Einfügen auf Klassenmodul.

    Im Visual Basic-Editor wird ein leeres Klassenmodul angezeigt.

  2. Fügen Sie dem Modul die gewünschten Deklarationen und Prozeduren hinzu.

  3. Um das Modul zu speichern, klicken Sie in der Symbolleiste auf Speichern [image] und geben im Dialogfeld Speichern unter einen Namen für das Klassenmodul an.

Um das Klassenmodul nach dem ersten Speichern zu öffnen, klicken Sie im Datenbankfenster unter Objekte auf Module [image] und dann auf Entwurf.

Klicken Sie hier, um weitere Informationen zur Verwendung von Klassenmodulen anzuzeigen [image] . Weitere Informationen finden Sie auch in Erstellen von Anwendungsprogrammen mit Formularen und Berichten.


 Verwenden von Argumenten in Visual Basic

Verwenden von Argumenten in Visual Basic

Ein Argument liefert zusätzliche Informationen zu einer Prozedur, Anweisung oder Methode. Wenn Sie eine Funktion oder Sub-Prozedur erstellen, deklarieren Sie Argumente, damit Sie der Prozedur bei deren Aufruf Informationen liefern können.

Beim Aufrufen einer Prozedur, die Argumente besitzt, geben Sie die Argumente an, die Sie ihr übergeben möchten. Auch für viele Anweisungen und Methoden geben Sie Argumente an.

Was möchten Sie tun?

Eine benutzerdefinierte Funktion erstellen

Eine Sub-Prozedur erstellen

Argumente beim Verwenden einer Prozedur, Anweisung oder Methode angeben


 Arbeiten mit Daten und Datenbankobjekten unter Verwendung von Visual Basic-Code

Arbeiten mit Daten und Datenbankobjekten unter Verwendung von Visual Basic-Code

Neben dem Arbeiten mit Daten und Objekten, wie beispielsweise Formularen und Berichten, auf der Microsoft Access-Benutzeroberfläche, können Sie in Microsoft Visual Basic auch Prozeduren schreiben, die Daten und Objekte dynamisch erstellen, löschen und ändern. Sie können beispielsweise eine Prozedur schreiben, die eine Beschriftung auf einem Formular platziert oder die Farbe eines Feldes auf einem Formular ändert, wenn ein Benutzer eine bestimmte Aktion ausführt.

Sie können direkt in Ihrem Code auf Daten und Objekte verweisen, oder Sie können Objektvariablen deklarieren, um Daten und Objekte darzustellen. Nachdem Sie eine Objektvariable deklariert und zugeordnet haben, können Sie sie genauso verwenden wie den Namen des Objekts, das sie darstellt, und Sie können den Wert genauso ändern wie den jeder beliebigen Variablen.

Die folgende Sub-Prozedur erstellt eine Tabelle, Alte Rechnungen, mit einem einzigen Feld, Bestell-Nr.:

Sub TabelleErstellen()

    ' Variablen deklarieren.
    Dim dbs As Database, tbl As TableDef, fld As Field

    ' Aktuelle Datenbank der Datenbankvariablen
    ' zuweisen.
    Set dbs = CurrentDB

    ' Neue Tabelle und Feld erstellen und den
    ' Tabellen- und Feldvariablen zuweisen.
    Set tbl = dbs.CreateTableDef("Alte Rechnungen")
    Set fld = tbl.CreateField("Bestell-Nr", dbText)

    ' Feld der Tabelle hinzufügen, dann Tabelle der
    ' Datenbank hinzufügen.
    tbl.Fields.Append fld
    dbs.TableDefs.Append tbl
    dbs.TableDefs.Refresh

End Sub

Microsoft Data Access Objects (DAO) definiert die Objekte, wie beispielsweise Tabellen, Abfragen, Beziehungen und Indizes, die Datenverwaltungsaufgaben in einer Microsoft Access-Datenbank erledigen. Diese Objekte heißen Datenzugriffsobjekte. Sie können Visual Basic-Code, der Datenzugriffsobjekte verwendet, mit anderen Anwendungen, die Microsoft DAO einsetzen, wie Microsoft Excel, gemeinsam nutzen.

Sie können auch Jet- und Replikationsobjekte verwenden, um auf Daten in einem Datenbankserver über beliebige OLE-DB-Anbieter zuzugreifen und sie zu bearbeiten.

Darüber hinaus definiert Microsoft Access die verschiedensten Objekte, die Sie beim Arbeiten mit Daten verwenden, wie beispielsweise Formulare, Berichte und Steuerelemente.

Um Informationen zum Arbeiten mit Datenzugriffsobjekten anzuzeigen, klicken Sie auf [image] , oder lesen Sie Erstellen von Anwendungsprogrammen mit Formularen und Berichten. Um weitergehende Informationen über das Arbeiten mit Jet- und Replikationsobjekten zu erhalten, klicken Sie auf [image] .


 Ausführen von Visual Basic-Code

Ausführen von Visual Basic-Code

Sie führen Visual Basic-Code in Microsoft Access aus, indem Sie eine Sub-Prozedur oder eine Funktion ausführen. Prozeduren enthalten eine Reihe von Anweisungen und Methoden, die eine Operation durchführen oder einen Wert berechnen.

Prozeduren werden in Einheiten gespeichert, die als Module bezeichnet werden. Ein Modul führen Sie jedoch nicht aus, sondern Sie rufen die Prozeduren aus Ausdrücken, anderen Prozeduren oder Makros auf. Ereignisprozeduren in Formular- oder Berichtsmodulen werden als Reaktion auf Benutzeraktionen ausgeführt.

Sie haben folgende Möglichkeiten, um Visual Basic-Code in Microsoft Access auszuführen:

  • Erstellen Sie eine Ereignisprozedur. Wenn der Benutzer eine Aktion ausführt, die das betreffende Ereignis eintreten lässt, wird diese Ereignisprozedur ausgeführt.

    Sie können z. B. der Ereignisprozedur Click einer Befehlsschaltfläche Code hinzufügen, der ein Formular öffnet, wenn ein Benutzer auf die Schaltfläche klickt. Um Informationen zum Erstellen einer Ereignisprozedur anzuzeigen, klicken Sie auf [image] .

  • Verwenden Sie eine Funktion in einem Ausdruck oder im Direktbereich des Visual Basic-Editors.

    Sie können z. B. eine Funktion in einem Ausdruck verwenden, der ein berechnetes Feld in einem Formular, einem Bericht oder einer Abfrage definiert. Sie können Ausdrücke als Eigenschafteneinstellungen in Abfragen und Filtern, in Makros und Aktionen, in Visual Basic-Anweisungen und -Methoden oder in SQL-Anweisungen verwenden. Um Informationen zum Erstellen einer benutzerdefinierten Funktion anzuzeigen, klicken Sie auf [image] .

  • Rufen Sie eine Sub-Prozedur in einer anderen Prozedur oder im Direktbereich des Visual Basic-Editors auf.

    Wenn Sie bestimmten Code häufig ausführen, können Sie ihn in eine Sub-Prozedur einfügen. Statt den Visual Basic-Code, der die Operation in jeder Prozedur durchführt, zu wiederholen, schreiben Sie ihn einmal in die allgemeine Prozedur und rufen diese dann jedesmal auf, wenn Sie die Operation durchführen möchten. Um Informationen zum Erstellen einer Sub-Prozedur anzuzeigen, klicken Sie auf [image] .

  • Klicken Sie im Visual Basic-Editor im Menü Ausführen auf den Befehl Sub/UserForm ausführen, um eine Prozedur auszuführen, die keine Argumente erfordert.

    Setzen Sie den Cursor im Code-Fenster, in die Prozedur, die Sie ausführen möchten. Klicken Sie dann im Menü Ausführen auf Sub/UserForm ausführen.

  • Führen Sie die Aktion AusführenCode in einem Makro aus.

    Sie können mit der Aktion AusführenCode eine eingebaute Visual Basic-Funktion oder eine benutzerdefinierte Funktion ausführen. Um eine Sub-Prozedur oder eine Ereignisprozedur auszuführen, erstellen Sie eine Funktion, die die Sub-Prozedur bzw. die Ereignisprozedur aufruft, und führen Sie die Funktion dann mit Hilfe der Aktion AusführenCode aus. Zum Anzeigen von Informationen zur Aktion AusführenCode klicken Sie auf [image] .


 Verwendung des Microsoft Visual Basic-Editors

Verwendung des Microsoft Visual Basic-Editors

Der Microsoft Visual Basic-Editor (VBE) stellt die Entwicklungsumgebung zum Erstellen und Bearbeiten von Visual Basic für Applikationen-Code (VBA-Code) dar, der in Dateien enthalten ist, die Sie in Microsoft Office-Anwendungen erstellt haben - beispielsweise in Microsoft Access-Datenbanken und Microsoft Access-Projekten. Zu den VBE-Features zählen der Projektexplorer, das Eigenschaftenfenster, der Objektkatalog und das Code-Fenster sowie Debugging-Tools.

Was möchten Sie tun?

Informationen über das Ausführen von Visual Basic für Applikationen-Code erhalten

Eine Visual Basic-Prozedur erstellen

Mit Objekten in Visual Basic unter Verwendung des Objektkatalogs arbeiten

Visual Basic-Code testen

Hilfe zu Visual Basic erhalten


 Arbeiten mit Objekten in Visual Basic unter Verwendung des Objektkatalogs

Arbeiten mit Objekten in Visual Basic unter Verwendung des Objektkatalogs

Mit Hilfe des Objektkatalogs können Sie die Objekte, die in Microsoft Access und anderen Anwendungen, die sowohl Microsoft Visual Basic als auch die Methoden und Eigenschaften eines jeden Objekts unterstützen, anzeigen und von einem zum anderen navigieren. Wenn Sie eine Methode oder Eigenschaft im Objektkatalog suchen, können Sie sie in das aktive Modul kopieren und einfügen.

Was möchten Sie tun?

Eine Methode oder Eigenschaft im Objektkatalog suchen

Den Objektkatalog zum Einfügen der Syntax einer Methode oder Eigenschaft in ein Visual Basic-Modul verwenden


 Suchen einer Methode oder Eigenschaft im Objektkatalog

Suchen einer Methode oder Eigenschaft im Objektkatalog

  1. Öffnen Sie ein beliebiges Modul im Visual Basic-Editor.

  2. Klicken Sie in der Symbolleiste auf Objektkatalog [image] .

  3. Klicken Sie im Feld Projekt/Bibliothek (oben links) auf Access oder eine andere Bibliothek.

  4. Klicken Sie im Feld Klassen auf das gewünschte Objekt.

  5. Klicken Sie im Feld Elemente von auf die gewünschte Methode oder Eigenschaft.

Anmerkungen

  • Um Hilfe zu der ausgewählten Klasse, Methode, Eigenschaft oder dem ausgewählten Ereignis anzuzeigen, klicken Sie im Objektkatalog auf Hilfe [image].

  • Um die von der Microsoft Office 9.0-Objektbibliothek bereitgestellten Objekte, wie z. B. Befehlsleistenobjekte, anzuzeigen, müssen Sie einen Verweis auf diese Bibliothek erstellen. Klicken Sie im Visual Basic-Editor im Menü Extras auf Verweise, und aktivieren Sie dann das Kontrollkästchen Microsoft Office 9.0 Object Library.


 Verwenden des Objektkatalogs zum Einfügen der Syntax einer Methode oder Eigenschaft in ein Modul

Verwenden des Objektkatalogs zum Einfügen der Syntax einer Methode oder Eigenschaft in ein Modul

  1. Wählen Sie die Methode oder Eigenschaft im Objektkatalog aus.

  2. Markieren Sie im unteren Teil des Objektkatalogs die Syntax, die Sie einfügen möchten.

  3. Klicken Sie im Objektkatalog auf In Zwischenablage kopieren [image] .

  4. Klicken Sie im Code-Fenster des Moduls, in das Sie den Namen einfügen möchten.

  5. Klicken Sie in der Symbolleiste auf Einfügen [image] .

Microsoft Access fügt die Syntax der Methode oder Eigenschaft in das Modul ein.

Anmerkung Nach dem Einfügen der Syntax für Sub-Prozeduren müssen Sie alle runden Klammern entfernen, die in der Syntax Platzhalter umgeben.


Anpassen des Visual Basic-Code-Fensters

Was möchten Sie tun?

Den Anzeigemodus von Visual Basic-Code im Code-Fenster ändern

Die Syntaxfehlerüberprüfung für Visual Basic-Code deaktivieren

Die Fehlerbehandlung für Visual Basic-Code ignorieren

Variablendeklarationen für Visual Basic-Code fordern


 Ändern der Darstellungsweise von Visual Basic-Code im Code-Fenster

Ändern der Darstellungsweise von Visual Basic-Code im Code-Fenster

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Legen Sie die entsprechenden Optionen fest.

    Durch Festlegen der Optionen im Dialogfeld Optionen können Sie die Farbe, Schriftart, den Schriftgrad und die Tabulatorbreite ändern, die bei der Eingabe von Visual Basic-Code im Code-Fenster verwendet werden. Darüber hinaus können Sie festlegen, ob das gesamte Modul (Standard) oder jede Prozedur einzeln im Code-Fenster angezeigt wird, und verschiedene zusätzliche Optionen zum Arbeiten im Code-Fenster einstellen.


 Anzeigen von Syntaxinformationen im Code-Fenster des Visual Basic-Editors

Anzeigen von Syntaxinformationen im Code-Fenster des Visual Basic-Editors

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Editor.

  3. Stellen Sie sicher, dass unter Code-Einstellungen das Kontrollkästchen Automatische Quickinfo aktiviert ist.

Ist Automatische Quickinfo aktiviert, zeigt der Visual Basic-Editor Syntaxinformationen im Code-Fenster an. Wenn Sie im Anschluss an eine Methode oder den Namen einer bestehenden Prozedur ein Leerzeichen oder eine offene Klammer eingeben, wird automatisch ein Tipp mit den Syntaxinformationen zu der Methode oder Prozedur angezeigt (z. B. die Argumente, die Sie festlegen).


 Anzeigen des Wertes von Variablen im Lokalfenster des Visual Basic-Editors

Anzeigen des Wertes von Variablen im Lokalfenster des Visual Basic-Editors

  1. Unterbrechen Sie die Ausführung des Visual Basic-Codes.

    Wie?

  2. Klicken Sie im Menü Ansicht auf Lokal-Fenster.

Im Fenster Lokal zeigt Microsoft Access automatisch den Namen, den aktuellen Wert und den Typ aller Variablen und Objekte in der aktuellen Prozedur an. Die Werte im Lokalfenster werden bei jeder Unterbrechung der Codeausführung aktualisiert. Sie können den Wert einer Variablen im Lokalfenster ändern, indem Sie den bestehenden Wert markieren und den neuen Wert eingeben.


 Anzeigen einer Liste relevanter Objekte, Eigenschaften und Methoden im Editorfenster für Visual Basic-Code

Anzeigen einer Liste relevanter Objekte, Eigenschaften und Methoden im Editorfenster für Visual Basic-Code

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Editor.

  3. Stellen Sie unter Code-Einstellungen sicher, dass das Kontrollkästchen Elemente automatisch auflisten aktiviert ist.

Ist Elemente automatisch auflisten aktiviert, unterstützt Microsoft Access Sie beim Schreiben von Visual Basic-Code beim Ausfüllen von Anweisungen. Wenn Sie im Anschluss an den Namen eines Objekts ein Leerzeichen oder eine öffnende Klammer eingeben, zeigt Microsoft Access eine Liste relevanter Objekte, Eigenschaften und Methoden an, die auf den Objektnamen folgen können. Für das Eingeben eines Eintrags aus der Liste in die aktuelle Codezeile stehen Ihnen verschiedene Tasten zur Verfügung.

Taste | Auswirkung
TAB | Fügt das Element ein
LEERTASTE | Fügt das Element sowie im Anschluss daran ein Leerzeichen ein
EINGABE | Fügt das Element ein und verschiebt den Cursor zur nächsten Zeile

Anmerkung Um die Liste wieder auszublenden, drücken Sie ESC.


 Festlegen, dass Variablen in Visual Basic-Code deklariert werden müssen

Festlegen, dass Variablen in Visual Basic-Code deklariert werden müssen

In Microsoft Visual Basic müssen Sie eine Variable nicht explizit deklarieren, bevor Sie sie in einer Prozedur verwenden. Wenn Sie eine nicht explizit deklarierte Variable verwenden, deklariert Visual Basic diese implizit als Variable des Datentyps Variant.

Implizite Deklarationen sind zwar praktisch, können jedoch zu Fehlern in Ihrem Code führen. Um zu erzwingen, dass Variablen vor ihrem Einsatz in einer Prozedur deklariert werden, führen Sie die folgenden Schritte aus:

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Editor.

  3. Aktivieren Sie unter Codeeinstellungen das Kontrollkästchen Variablendeklaration erforderlich.

    Wenn das Kontrollkästchen Variablendeklaration erforderlich aktiviert ist, fügt Microsoft Access automatisch im Deklarationsbereich aller neuen Module in der Datenbank, einschließlich der neuen Formularen oder Berichten zugeordneten Formular- und Berichtsmodule, die Anweisung Option Explicit hinzu. Zum Anzeigen weiterer Informationen zur Anweisung Option Explicit klicken Sie auf [image] .


Testen von Visual Basic-Code

Was möchten Sie tun?

Informationen zum Beseitigen von Fehlern anzeigen

Einen Haltepunkt zum Unterbrechen der Ausführung von Visual Basic-Code verwenden

Code schrittweise durchlaufen

Die Werte von Ausdrücken und Variablen im Direktfenster des Visual Basic-Editors untersuchen

Die Werte von Ausdrücken und Variablen durch Festlegen eines Überwachungsausdrucks überwachen

Prozeduraufrufe in Visual Basic verfolgen

Den Wert von Variablen im Fenster Lokal des Visual Basic-Editors anzeigen

Den Wert einer Variablen oder eines Ausdrucks im Visual Basic-Editor anzeigen, wenn Code unterbrochen wird


 Deaktivieren der Syntaxüberprüfung für Visual Basic-Code

Deaktivieren der Syntaxüberprüfung für Visual Basic-Code

Microsoft Visual Basic überprüft automatisch bei der Eingabe den im Codefenster des Visual Basic-Editors eingegebenen Code auf Syntaxfehler. Um dieses Feature zu deaktivieren, führen Sie die folgenden Schritte aus:

  1. Klicken Sie im Menü Extras auf Optionen.
  2. Klicken Sie auf die Registerkarte Editor.

  3. Deaktivieren Sie unter Code-Einstellungen das Kontrollkästchen Automatische Syntaxüberprüfung.


 Verwenden des Direktfensters im Visual Basic-Editor während der Arbeit mit Visual Basic

Verwenden des Direktfensters im Visual Basic-Editor während der Arbeit mit Visual Basic

Verwenden Sie den Direktfenster im Visual Basic-Editor , um die Ergebnisse einer Zeile im Visual Basic-Code zu überprüfen. Mit dem Direktfenster können Sie den Wert eines Steuerelements, Feldes oder einer Eigenschaft überprüfen, das Ergebnis eines Ausdrucks anzeigen oder einer Variablen, einem Feld, einer Spalte oder einer Eigenschaft einen neuen Wert zuweisen. Das Direktfenster ist eine Art von Notizblockfenster, in dem Anweisungen, Methoden und Sub-Prozeduren sofort ausgewertet werden.

  1. Wenn Sie das Direktfenster an einem bestimmten Punkt während der Codeausführung verwenden möchten, unterbrechen Sie die Ausführung an diesem Punkt.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste Debug auf Direktfenster.

  3. Geben Sie im Fenster eine Anweisung, Methode oder einen Funktion oder Sub-Prozeduraufruf ein, und drücken Sie die EINGABETASTE.

Tipps

  • Sie können die Ergebnisse eines Ausdrucks im Direktfenster anzeigen, indem Sie die Print-Methode des Debug-Objekts und dahinter den Ausdruck eingeben. Als Kürzel für die Print-Methode können Sie ein Fragezeichen (?) verwenden. Microsoft Visual Basic zeigt z.B. den von der benutzerdefinierten Funktion ErsterDesNächstenMonats zurückgegebenen Wert an, wenn Sie eine der folgenden Zeilen im Direktfenster eingeben:
    Debug.Print ErsterDesNächstenMonats()

    Sie können die Methode Print des Objekts Debug Ihrem Visual Basic-Code auch hinzufügen, um die Werte oder Ergebnisse von Ausdrücken im Direktfenster anzuzeigen, während der Code ausgeführt wird. Wenn die Codeausführung beendet ist, können Sie sich die Ergebnisse ansehen.

  • Sie können den Direktfenster in jedem beliebigen Fenster in Microsoft Access anzeigen, indem Sie STRG+G drücken.


 Deaktivieren der Fehlerbehandlung für Visual Basic-Code

Deaktivieren der Fehlerbehandlung für Visual Basic-Code

Wenn Sie eine On Error-Anweisung zu einer Visual Basic-Prozedur hinzufügen, verzweigt Microsoft Visual Basic beim Auftreten eines Fehlers automatisch in eine Fehlerbehandlungsroutine. Vielleicht möchten Sie jedoch in einigen Fällen den Fehlerbehandlungscode einer Prozedur deaktivieren, z. B. während Sie die Prozedur testen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Allgemein.

  3. Aktivieren Sie unter Fehlerbehebung das Kontrollkästchen Bei allen Fehlern anhalten.

    Wenn Sie diese Option aktivieren, wechseln Sie beim Auftreten eines Fehlers, unabhängig von der Fehlerbehandlung, automatisch in den Unterbrechungsmodus.


 Optimieren der Leistung von Visual Basic-Code

Optimieren der Leistung von Visual Basic-Code

Oft ist es sinnvoll, zum Verbessern der Geschwindigkeit, mit der Ihr Visual Basic-Code ausgeführt wird, einen effizienteren Ansatz zu wählen. Bestimmte Techniken können Ihnen helfen, die Ausführung Ihres Codes zu beschleunigen.

  • Stellen Sie sicher, dass der Code in Ihrer Datenbank kompiliert ist. Klicken Sie im Code-Fenster des Visual Basic-Editors im Menü Debuggen auf Kompilieren.

    Anmerkung Sie müssen Ihren Code erneut kompilieren, nachdem Sie eine Datenbankdatei umbenannt haben, da beim Umbenennen einer Datenbank der Code in der Datenbank dekompiliert wird.

  • Deklarieren Sie Variablen immer explizit. Sie können sicherstellen, dass alle Variablen explizit deklariert werden, bevor sie in einer Prozedur verwendet werden, indem Sie die Option Variablen-Deklaration erforderlich auf der Registerkarte Editor des Dialogfelds Optionen einstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Verwenden Sie beim Deklarieren von Variablen immer den jeweils genauesten Datentyp. Deklarieren Sie z. B. eine Variable, die ein Formular darstellt, als Variable vom Typ Form und nicht vom Typ Object oder Variant.

  • Verwenden Sie Variablen, um auf Eigenschaften, Steuerelemente und Datenzugriffsobjekte zu verweisen. Wenn Sie mehrmals auf den Wert einer Eigenschaft oder eines Steuerelements in einem Formular oder auf ein Datenzugriffsobjekt oder dessen Eigenschaft verweisen, erstellen Sie Objektvariablen, und verweisen Sie auf die Variablen, anstatt die vollständigen Bezeichner zu verwenden.

  • Verwenden Sie für Formularverweise in Ereignisprozeduren in einem Formularmodul das Schlüsselwort Me.

  • Verwenden Sie die Funktion Ilf sparsam. Vermeiden Sie die Verwendung der Funktion Ilf, wenn die Auswertung eines der Rückgabeausdrücke viel Zeit in Anspruch nimmt. Verwenden Sie stattdessen If … Then … Else.

  • Verwenden Sie dort, wo sie angebracht sind, Zeichenfolgenfunktionen. Verwenden Sie $-Funktionen (z. B. die Funktion Str$), wenn Sie mit Zeichenfolgen arbeiten, und Funktionen ohne $, wenn Sie mit dem Datentyp Variant oder anderen Datentypen arbeiten.

  • Verwenden Sie, falls möglich, die Datentypen Integer oder Long für Berechnungen.

  • Verwenden Sie dynamische Datenfelder sowie die Anweisungen Erase oder ReDim, um Speicherplatz freizugeben.

  • Verwenden Sie Konstanten, wo immer dies möglich ist.

  • Verwenden Sie Lesezeichen zum schnellen Wiederauffinden. Verwenden Sie Lesezeichen an Stelle der Methode FindNext oder anderer Möglichkeiten, um zu einem bestimmten Datensatz zurückzukehren.

  • Verwenden Sie die Methoden FindRecord und FindNext bei indizierten Feldern. Diese Methoden sind wesentlich effizienter, wenn sie für ein indiziertes Feld eingesetzt werden.

  • Organisieren Sie Ihre Module. Visual Basic lädt Module bei Bedarf, d. h., ein Modul wird nur dann in den Speicher geladen, wenn Ihr Code eine der im Modul enthaltenen Prozeduren aufruft. Wenn Sie verwandte Prozeduren jeweils in ein Modul setzen, lädt Visual Basic weitere Module nur bei Bedarf.

  • Löschen Sie nicht verwendete Prozeduren und nicht verwendete Variablen. Während Sie Ihre Anwendungen entwickeln und ändern, bleiben manchmal Prozeduren zurück, die von keiner Stelle in Ihrem Code aufgerufen werden, oder es gibt noch deklarierte Variablen, die nicht mehr verwendet werden. Überprüfen Sie gegebenenfalls Ihren Code auf solche unbenötigten Prozeduren und Variablen, und entfernen Sie diese.

Weitere Informationen finden Sie unter Erstellen von Anwendungsprogrammen mit Formularen und Berichten.


 Info über Visual Basic-Skripten in einer Webseite

Info über Visual Basic-Skripten in einer Webseite

Ein Skript ist ein Typ von Computercode, mit dem Webseiten dynamisch gestaltet werden können. Sie können z. B. ein Skript zum Hinzufügen des Zählers "Zahl der Besucher" verwenden, der immer dann hochzählt, wenn jemand eine Webseite besucht. Oder Sie können ein Skript einsetzen, um einen Countdown für ein bestimmtes Ereignis hinzuzufügen: "Nur noch x Tage", wobei x mit jedem Tag um 1 verkleinert wird. Das Erstellen von Skripten ist eine erweiterte Office-Funktion, für die Programmierkenntnisse erforderlich sind. Als Entwickler können Sie in Microsoft Access in Webseiten Skripte unmittelbar erstellen und bearbeiten. Skripte werden in der Regel von einem Webbrowser beim Öffnen einer Webseite oder in der Seitenansicht einer Webseite ausgeführt, um Informationen anzuzeigen, die von dem Skript erstellt wurden.

Achtung

Gehen Sie beim Kopieren und Verschieben von Skripten mit Bedacht vor. Obwohl einige Skripte unabhängig sind und an allen Stellen einer Webseite einwandfrei funktionieren, gibt es andere Skripte, die von der Struktur der Webseite abhängig sind. Diese Skripte funktionieren nach dem Kopieren oder Verschieben in eine andere Webseite oder an eine andere Stelle in der Webseite möglicherweise nicht einwandfrei und geben bei der Anzeige in einem Browser möglicherweise Fehler zurück.


 Info über das Erstellen und Bearbeiten eines Visual Basic-Skripts in einer Webseite

Info über das Erstellen und Bearbeiten eines Visual Basic-Skripts in einer Webseite

Sie können einer Seite in Microsoft Access Microsoft Visual Basic Scripting Edition (VBScript) und JScript erstellte Skripte hinzufügen.

Die Skripterstellung ist nützlich bei der Entwicklung webbasierter Lösungen. Sie stellt ein vollständiges Objektmodell für den Webbrowser und die Objekte in der aktuellen Seite bereit. Dadurch wird das Schreiben von Code zum Bearbeiten der Elemente einer Seite erleichtert, ohne dass Sie Kenntnisse von HTML oder der Implementierung der Objekte haben müssen. Sie können auch Skriptcode erstellen, der sich speziell für die Verarbeitung von Ereignissen eignet, die bei Objekten (wie z. B. ActiveX-Steuerelementen) in der Webseite vorkommen.

Um den HTML-Code anzuzeigen oder ein Skript für eine Webseite zu bearbeiten, öffnen Sie den Microsoft Skript-Editor. Im Skript-Editor können Sie Text hinzufügen sowie HTML-Tags und Skriptcode bearbeiten. Des Weiteren können Sie die Webseite entsprechend der Browserdarstellung anzeigen.

Weitere Informationen zum Erstellen eines Skripts finden Sie in der Hilfe zum Microsoft Skript-Editor.

Weitere Informationen

Erstellen eines Skripts in einer Webseite

Anzeigen eines Skripts in einer Webseite


 Ändern der Standardskriptsprache

Ändern der Standardskriptsprache

  1. Öffnen Sie die Webseite in der Entwurfsansicht oder der Datenzugriffsseitenansicht.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Microsoft Skript-Editor.
  3. Klicken Sie im Fenster Eigenschaften im Listenfeld auf Dokument.

  4. Ändern Sie den Wert der Eigenschaft defaultClientScript in VBScript oder JavaScript.


Info über das Unterstützen von Java-Applets

Ein Java-Applet ist ein kleines Softwareprogramm, das in der Programmiersprache Java geschrieben ist, die hauptsächlich im World Wide Web eingesetzt wird. Ein Java-Applet ist eine separate Datei, auf die ein HTML-Dokument verweist. Mit Java-Applets können einer Webseite Animationen, Musik, Datenbankoperationen und Aktualisierungen hinzugefügt werden. Für die Entwicklung und Weiterentwicklung von Java ist Sun Microsystems, Inc. verantwortlich. Wenn Sie in Microsoft Access eine Webseite mit einem Java-Applet öffnen, wird in der Seite ein Symbol angezeigt, das das Java-Applet-Symbol darstellt.

Das Symbol wird nicht angezeigt, wenn Sie die Webseite in einem Browser anzeigen oder diese drucken.

Als Entwickler können Sie außerdem den Code des Java-Applets bearbeiten.

Achtung

Gehen Sie beim Kopieren und Verschieben von Java-Applets mit Bedacht vor. Obwohl einige Java-Applets unabhängig sind und an allen Stellen einer Webseite einwandfrei funktionieren, gibt es andere Java-Applets, die von der Struktur der Webseite abhängig sind. Diese Java-Applets funktionieren nach dem Kopieren oder Verschieben in eine andere Webseite oder an eine andere Stelle in der Webseite möglicherweise nicht einwandfrei und geben bei der Anzeige in einem Browser möglicherweise Fehler zurück.


 Anzeigen und Bearbeiten eines Webskripts

Anzeigen und Bearbeiten eines Webskripts

  1. Öffnen Sie die Webseite in der Entwurfsansicht oder der Seitenansicht.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Microsoft Skript-Editor.


 Kompatibilität bezüglich des Gültigkeitsbereichs und der Benennung von Objekten

Kompatibilität bezüglich des Gültigkeitsbereichs und der Benennung von Objekten

Die Gültigkeitsbereichsregeln von Visual Basic wirken sich auf die Namen aus, die Sie für Ihre Objekte, Module und Prozeduren wählen.

Module und andere Objekte mit identischem Namen

Wenn Sie ein Modul benennen, wählen Sie keinen Namen, der mit Form_ oder Report_ beginnt. Es können sonst Konflikte mit bestehendem Code auftreten, den Sie für Formulare und Berichte geschrieben haben.

Wenn ein Modul in einer Anwendung, die mit den Versionen 1.x oder 2.0 von Microsoft Access erstellt wurde, nicht diesen Namenskonventionen entspricht, erzeugt Microsoft Access 2000 einen Fehler, wenn Sie versuchen, die Anwendung zu konvertieren. So erzeugt z. B. ein Modul mit dem Namen Form_Bestellungen in einer Microsoft Access-Datenbank der Version 1.x oder 2.0 einen Fehler, und Sie werden dazu aufgefordert, das Modul vor dem Konvertieren umzubenennen.

Module und Prozeduren mit identischem Namen

Obwohl dieses Verfahren nicht empfohlen wird, können Sie einer Prozedur den gleichen Namen geben wie einem Modul. Um diese Prozedur aus einem beliebigen Ausdruck Ihrer Anwendung aufzurufen, müssen Sie den ausführlichen Namen der Prozedur angeben, d. h. den Modulnamen und den Prozedurnamen, wie z. B.:

IsLoaded.IsLoaded("Bestellungen")

Anmerkung Dieses Verfahren funktioniert nicht bei der Aktion AusführenCode in Makros. Das Zugreifen auf Prozeduren mit dem gleichen Namen wie ein Modul ist bei Makros nicht möglich.

Prozeduren und Steuerelemente mit identischem Namen

Wenn Sie aus einem Formular eine Prozedur aufrufen, die den gleichen Namen wie ein Steuerelement des Formulars besitzt, geben Sie den ausführlichen Namen des Prozeduraufrufs an, d.h. auch den Namen des Moduls, in dem sich die Prozedur befindet. Wenn Sie z.B. die Prozedur Rechnungsdruck aufrufen möchten, die sich in dem Standardmodul Dienstprogramme befindet, und es im gleichen Formular auch eine Schaltfläche mit dem Namen Rechnungsdruck gibt, verwenden Sie beim Aufrufen der Prozedur aus Ihrem Formular oder Formularmodul den ausführlichen Namen Dienstprogramme.Rechnungsdruck.

Steuerelemente mit ähnlichen Namen

Sie können Steuerelemente nicht so benennen, dass sich ihre Namen nur durch ein Leerzeichen oder ein Sonderzeichen unterscheiden. So können Sie z.B. nicht gleichzeitig Steuerelemente mit den Namen [Telefon_Privat], [TelefonPrivat] und [Telefon+Privat] bezeichnen.

Module und Typbibliotheken mit identischem Namen

Sie können ein Modul nicht unter dem gleichen Namen wie eine Typbibliothek speichern. Wenn Sie ein Modul unter dem Namen ADO, Access, DAO oder VBA zu speichern versuchen, weist Sie eine Fehlermeldung darauf hin, dass der Name zu Konflikten mit einem bestehenden Modul, Projekt oder einer Objektbibliothek führt. Ebenso können Sie ein Modul nicht unter dem Namen Excel speichern, wenn Sie z. B. einen Verweis auf eine Microsoft Excel-Typbibliothek hergestellt haben.

Felder und Methoden mit identischem Namen

Wenn ein Tabellenfeld denselben Namen wie eine ADO (ActiveX Data-Objekte)-Methode für ein ADO-Recordset-Objekt oder eine DAO (Datenzugriffsobjekt)-Methode für ein DAO-Recordset-Objekt besitzt, können Sie auf das entsprechende Feld der Datensatzgruppe nicht mit Hilfe der Syntax . (Punkt) verweisen. Verwenden Sie in diesem Fall die Syntax ! (Ausrufezeichen), damit Microsoft Access keinen Fehler erzeugt. Das folgende Beispiel verdeutlicht, wie Sie auf das Feld NeuesFeld einer geöffneten Datensatzgruppe verweisen können, die auf einer Tabelle namens Kontakte basiert.

ADO

Dim rst As New ADODB.Recordset
rst.Open "Kontakte",CurrentProject.Connection, _
    adOpenKeySet,adLockOptimistic
Debug.Print rst!NeuesFeld

DAO

Dim dbs As Database, rst As DAO.Recordset
Set dbs = CurrentDb
Set rst = dbs.OpenRecordset("Kontakte")
Debug.Print rst!NeuesFeld

Module und Visual Basic-Funktionen mit identischem Namen

Wenn Sie ein Modul unter dem Namen einer eingebauten Visual Basic-Funktion speichern, erzeugt Microsoft Access einen Fehler, sobald Sie versuchen, die Funktion auszuführen. Wenn Sie z. B. ein Modul unter dem Namen MsgBox speichern und dann versuchen, eine Prozedur auszuführen, welche die MsgBox-Funktion aufruft, zeigt Microsoft Access die Fehlermeldung "Variable oder Prozedur an Stelle eines Moduls erwartet" an.

Module und Objekte mit identischem Namen

Wenn eine mit einer früheren Version von Microsoft Access erstellte Datenbank ein Modul enthält, das denselben Namen wie ein Microsoft Access-Objekt, ein ADO-Objekt oder ein DAO-Objekt besitzt, können beim Konvertieren Ihrer Datenbank nach Microsoft Access 2000 Kompilierfehler auftreten. Beispielsweise können Module mit dem Namen Form oder Database einen Kompilierfehler erzeugen. Benennen Sie das Modul um, damit derartige Fehler vermieden werden.

Benennen von Feldern, die in Ausdrücken verwendet werden oder an Steuerelemente in Formularen und Berichten gebunden sind

Wenn Sie in einer Tabelle ein Feld erstellen, das in einem Bericht an ein Steuerelement gebunden oder in einem Ausdruck in der Eigenschaft Control Source eines Steuerelements oder Berichts verwendet wird, weisen Sie dem Feld in keinem Fall den Namen einer Methode des Application-Objekts zu. Um eine Liste der Methoden des Application-Objekts anzuzeigen, klicken Sie in der Modul-Entwurfsansicht im Menü Ansicht auf Objektkatalog. Klicken Sie dann im Feld Projekt/Bibliothek auf Access, klicken Sie im Feld Klassen auf Application, und sehen Sie die Methoden des Application-Objekts im Feld Elemente von an.

Wenn Sie in einer Tabelle ein Feld erstellen, das in einem Formular oder Bericht an ein Steuerelement gebunden wird, weisen Sie dem Feld in keinem Fall die folgenden Namen zu: AddRef, GetIDsOfNames, GetTypeInfo, GetTypeInfoCount, Invoke, QueryInterface, Release.

Bezeichner und Visual Basic-Schlüsselwörter mit identischem Namen

Die in Microsoft Access 97 und 2000 verwendete Visual Basic-Version enthält einige neue Visual Basic-Schlüsselwörter. Sie können daher die betreffenden Schlüsselwörter nicht mehr als Bezeichner verwenden. Es handelt sich um die folgenden Schlüsselwörter: AddressOf, Assert, Decimal, DefDec, Enum, Event, Friend, Implements, RaiseEvent und WithEvents. Wenn Sie eine mit einer früheren Version von Microsoft Access erstellte Datenbank konvertieren, erzeugen bestehende Bezeichner mit demselben Namen wie ein neues Visual Basic-Schlüsselwort einen Kompilierfehler. Um das Problem zu beheben, benennen Sie die Bezeichner um.

Projekte und Microsoft Access-Objekte mit identischen Namen

Ein Projektname ist die Zeichenfolge, die für den Namen Ihrer Microsoft Access-Anwendung steht. In früheren Versionen von Microsoft Access war der Projektname der Name der Datenbank. In Microsoft Access 2000 wird der Projektname durch die Einstellung der ProjectName-Eigenschaft festgelegt. Deren Standardeinstellung ist der Name der Datenbank. Wenn Sie eine Datenbank konvertieren, deren Namen mit dem einer Klasse von Objekten übereinstimmt (z. B. ANWENDUNG., FORMULAR. oder BERICHT.), fügt Microsoft Access dem Datenbanknamen einen Unterstrich hinzu, um einen Projektnamen zu erstellen, durch den sich kein Konflikt mit bestehenden Objekten ergibt.


 Benutzerdefinierte Methoden und Eigenschaften

Benutzerdefinierte Methoden und Eigenschaften

Sie können mit Hilfe eines Klassenmoduls eine Definition für ein neues benutzerdefiniertes Objekt erstellen. Wenn Sie eine neue Instanz einer Klasse erstellen, erstellen Sie ein neues Objekt und geben einen Verweis auf das Objekt zurück.

Jede innerhalb des Klassenmoduls definierte öffentliche Prozedur wird eine Methode des benutzerdefinierten Objekts. Die Anweisung Sub definiert eine Methode, die keinen Wert zurückgibt. Die Anweisung Function definiert dagegen eine Methode, die einen Wert eines festgelegten Typs zurückgeben kann.

Alle Prozeduren, Property Let, Property Get und Property Set, die Sie definieren, werden zu einer Eigenschaft des neuen Objekts. Property Get-Prozeduren rufen den Wert einer Eigenschaft ab. Property Let-Prozeduren stellen den Wert einer Nicht-Objekteigenschaft ein. Property Set-Prozeduren stellen den Wert einer Objekteigenschaft ein.

Sie können ein Klassenmodul z. B. verwenden, um eine Schnittstellenschicht zwischen Ihrer Anwendung und der Gruppe von Windows-API (Application Programming Interface = Schnittstelle für die Anwendungsprogrammierung)-Funktionen zu erstellen, die von der Anwendung aufgerufen werden. Hierzu erstellen Sie eine Gruppe einfacher Prozeduren, die wiederum komplexere Prozeduren in einer DLL aufrufen. Wenn Sie eine Instanz dieser Klasse erstellen, werden die erstellten Prozeduren zu Methoden des neuen Objekts. Sie können diese Methoden genau so anwenden wie die Methoden jedes beliebigen Objekts, wobei Sie hier auch die API-Funktionen aufrufen.


 Programmieren von Symbol- und Menüleisten

Programmieren von Symbol- und Menüleisten

Microsoft Access 2000 enthält Befehlsleisten, wobei programmierbare Symbolleisten und Menüleisten unterschieden werden. Mit Hilfe dieser Befehlsleisten können Sie benutzerdefinierte Symbolleisten und Menüs für Ihre Anwendung erstellen.

Wenn Sie mit Befehlsleisten programmieren möchten, richten Sie einen Verweis auf die Microsoft Office 9.0-Objektbibliothek ein. Klicken Sie in der Modul-Entwurfsansicht im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen neben Microsoft Office 9.0 Object Library.

Die CommandBars-Auflistung enthält alle Befehlsleisten, die momentan in der Anwendung vorhanden sind. Sie können ein neues CommandBar-Objekt zur CommandBars-Auflistung hinzufügen, indem Sie die Add-Methode dieser Auflistung verwenden. Beispielsweise erstellt der folgende Code die neue Befehlsleiste MeineBefehlsleiste. Beachten Sie, dass die Visible-Eigenschaft auf True (-1) eingestellt werden muss, damit die Befehlsleiste sichtbar wird.

Dim cmb As CommandBar
Set cmb = Application.CommandBars.Add("MeineBefehlsleiste")
cmb.Visible = True

Jedes CommandBar-Objekt besitzt eine CommandBarControls-Auflistung, die alle Steuerelemente in der Befehlsleiste enthält. Die Steuerelemente in der Befehlsleiste unterscheiden sich von den Steuerelementen in einem Formular. Sie können verschiedene Typen von Befehlsleisten-Steuerelementen erstellen: Schaltflächen, Kombinationsfelder und Popups. Sie können diese Steuerelemente gemischt verwenden, um eine benutzerdefinierte Symbolleiste oder Menüleiste zu erstellen.

Um sich auf die CommandBarControls-Auflistung zu beziehen, verwenden Sie die Controls-Eigenschaft des CommandBar-Objekts. Wenn Sie ein Steuerelement zu einer Befehlsleiste hinzufügen möchten, verwenden Sie die Add-Methode der CommandBarControls-Auflistung und geben den Typ des zu erstellenden Steuerelements an. Das folgende Beispiel fügt eine neue Schaltfläche zu der im vorangehenden Beispiel erstellten Befehlsleiste hinzu:

Dim cbc As CommandBarControl
Set cbc = cmb.Controls.Add(msoControlButton)
cbc.Caption = "Schaltfläche1"
cbc.Style = msoButtonCaption

Sie können einen Ausdruck angeben, der berechnet werden soll, oder ein Makro, das ausgeführt werden soll, wenn der Benutzer auf ein Befehlsleisten-Steuerelement klickt. Stellen Sie die OnAction-Eigenschaft auf den Namen eines Makros oder Ausdrucks ein, der eine eingebaute oder benutzerdefinierte Funktion enthält. Beispielsweise stellt die folgende Code-Zeile die OnAction-Eigenschaft eines CommandBarControl-Objekts auf einen Ausdruck ein, der die MsgBox-Funktion enthält. Das Beispiel verwendet die in den beiden vorhergehenden Beispielen erstellten Objekte CommandBar und CommandBarControl.

CommandBars("MeineBefehlsleiste").Controls("Schaltfläche1").OnAction = _
    "=MsgBox(""Wow!"")"

Anmerkung Anders als bei fast allen Auflistungen in Microsoft Access wird die Auflistung CommandBars sowie alle darin enthaltenen Auflistungen ab 1 und nicht ab 0 indiziert.


 Verbesserungen bezüglich der Kompilierung

Verbesserungen bezüglich der Kompilierung

Microsoft Access enthält Verbesserungen beim Laden von Modulen und bei der Kompilierungsleistung, so dass Ihr Code schneller kompiliert und ausgeführt wird.

Bei Bedarf erstellte Formular- und Berichtsmodule

Wenn Sie ein Formular oder einen Bericht in Microsoft Access 2000 erstellen, wird dem Formular bzw. Bericht nicht automatisch ein Modul zugewiesen. Das Modul wird erst erstellt, wenn Sie in der Symbolleiste auf Code [image] klicken, um das Formular- oder Berichtsmodul anzuzeigen. Sie können das Modul auch in Visual Basic erstellen, indem Sie auf die Modul-Eigenschaft des Formulars verweisen, während sich das Formular bzw. der Bericht in der Entwurfsansicht befindet, oder indem Sie die HasModule-Eigenschaft auf True (-1) festlegen.

Die Einstellung der Eigenschaft HasModule gibt an, ob einem Formular oder Bericht momentan ein Modul zugewiesen ist.

Da ein Formular- oder Berichtsmodul nur dann erstellt wird, wenn Sie Code hinzufügen, müssen in der Regel weniger Module Ihres Projekts kompiliert werden, was die Kompilierungsleistung heraufsetzt. Formulare und Berichte ohne Module werden darüber hinaus schneller geladen als solche mit Modulen.

Kompilieren bei Bedarf

Es ist zwar empfehlenswert, die Module Ihres Projekts mit den oben beschriebenen Befehlen explizit zu kompilieren, jedoch nicht unbedingt erforderlich. Microsoft Access kompiliert ein Modul, bevor eine darin befindliche Prozedur ausgeführt wird, wenn das Modul noch nicht kompiliert vorliegt.

Wenn ein Modul geladen wird, überprüft Microsoft Access vor der Ausführung des Moduls, ob es bereits kompiliert vorliegt. Ist das nicht der Fall, kompiliert Microsoft Access das Modul unmittelbar vor dem Ausführen der darin befindlichen Prozedur. Der Kompilierungsvorgang verlangsamt die Code-Ausführung; aus diesem Grund wird Code in kompiliert gespeicherten Modulen schneller ausgeführt.

Beachten Sie den Unterschied zu Microsoft Access 95. Wenn Sie dort eine Prozedur in einem Modul ausführen, werden alle Module im potenziellen Aufrufbaum geladen, jedoch standardmäßig erst kompiliert, wenn eine darin befindliche Prozedur aufgerufen wird. Da Microsoft Access 97 und Access 2000 Module nur bei Bedarf laden, kann der Code in vielen Fällen schneller ausgeführt werden.

Sie erreichen eine weitere Leistungssteigerung, wenn Sie Prozeduren so zu Modulen gruppieren, dass unnötige Kompilierungsvorgänge entfallen. Fassen Sie solche Prozeduren in Modulen zusammen, die sich gegenseitig aufrufen; bilden Sie keine Modulgruppen mit Prozeduren, die in keiner Beziehung zueinander stehen.


 Makroaktionen und Methoden des Objekts "DoCmd"

Makroaktionen und Methoden des Objekts "DoCmd"

Zum Ausführen von Makroaktionen aus dem Code heraus verwenden Sie in Microsoft Access 2000 das DoCmd-Objekt und die zugehörigen Methoden. Dieses Objekt ersetzt die Anweisung DoCmd, die Sie in den Versionen 1.x und 2.0 von Microsoft Access zum Ausführen von Makroaktionen verwendet haben.

Wenn Sie eine Datenbank konvertieren, konvertiert Microsoft Access automatisch alle DoCmd-Anweisungen und die Aktionen, die diese im Access Basic-Code ausgeführt haben, in Methoden des DoCmd-Objekts, indem das Leerzeichen durch den Operator . (Punkt) ersetzt wird.

Die Funktionsweise einiger Makroaktionen hat sich in Microsoft Access 2000 gegenüber den Versionen 1.x, 2.0 oder 7.0 geändert. Diese Änderungen werden nachstehend genauer erläutert.

Datenbanken, die mit Microsoft Access 95 erstellt wurden

Die AusführenMenübefehl-Aktion

Die Aktion AusführenMenübefehl wird in Microsoft Access 2000 nicht mehr verwendet. Um die Aufgaben der Aktion AusführenMenübefehl durchzuführen, verwenden Sie die neue Aktion AusführenBefehl.

Wenn Sie eine Datenbank aufbereiten, die mit einer früheren Version von Microsoft Access erstellt wurde, funktioniert die Aktion AusführenMenübefehl genauso wie bisher.

Wenn Sie eine Datenbank konvertieren, die mit einer früheren Version von Microsoft Access erstellt wurde, werden alle AusführenMenübefehl-Aktionen in Makros durch AusführenBefehl-Aktionen ersetzt, wenn die Makros zum ersten Mal nach der Konvertierung gespeichert werden. DoMenuItem-Methoden, die in Visual Basic-Prozeduren verwendet werden, bleiben unverändert.

Datenbanken, die mit Microsoft Access, Version 1.x oder 2.0, erstellt wurden

Die TransferArbeitsblatt-Aktion

Microsoft Access 2000 kann keine Kalkulationstabellen aus Microsoft Excel, Version 2.0, oder aus Lotus 1-2-3, Version 1.0, importieren. Wenn Ihre konvertierte Datenbank ein Makro enthält, das diese Funktionalität in der Version 1.x oder 2.0 von Microsoft Access mit Hilfe der Aktion TransferArbeitsblatt bereitstellte, wird durch das Konvertieren das Argument Dateiformat in Microsoft Excel, Version 3.0 geändert (falls Sie ursprünglich Microsoft Excel, Version 2.0 angegeben hatten), oder es kommt zu einem Fehler (wenn Sie ursprünglich Lotus 1-2-3, Version 1.0 angegeben hatten).

Sie können dieses Problem umgehen, indem Sie die Arbeitsblätter zuerst nach einer höheren Version von Microsoft Excel oder Lotus 1-2-3 konvertieren und dann in Microsoft Access importieren.

Die TransferText- und TransferArbeitsblatt-Aktionen

In Microsoft Access 2000 können Sie keine SQL-Anweisung verwenden, um die Daten anzugeben, die mit Hilfe der Aktionen TransferText oder TransferArbeitsblatt exportiert werden sollen. Statt dessen erstellen Sie zunächst eine Abfrage und geben dann den Namen der Abfrage im Aktionsargument Tabellenname an.

Vergleiche, die Nullwerte enthalten

Wenn Sie in Microsoft Access, Versionen 1.x und 2.0, zwei Ausdrücke innerhalb einer Makrobedingung mit Hilfe eines Vergleichsoperators vergleichen und einer dieser Ausdrücke eine Null ist, gibt Access Basic für den Vergleich True oder False zurück, je nachdem, welchen Vergleichsoperator Sie verwenden. In Microsoft Access 2000 gibt Visual Basic für einen Vergleich, in dem ein Ausdruck Null ist, Null zurück. Mit Hilfe der Funkion IsNull können Sie das Ergebnis des Vergleichs überprüfen und bestimmen, ob der Vergleich Null ergibt.


 Verwenden alphabetisch sortierter Konstanten in Microsoft Access 2000

Verwenden alphabetisch sortierter Konstanten in Microsoft Access 2000

In Microsoft Access 2000 wurden eine Reihe eingebauter Konstanten hinzugefügt oder geändert, mit dem Ziel, Listen alphabetisch sortierter Konstanten zu erstellen, die im Modulfenster für die Argumente verschiedener Microsoft Access-Methoden, -Funktionen und -Eigenschaften oder als Einstellung verschiedener Microsoft Access-Eigenschaften unter Elemente automatisch auflisten aufgelistet werden. Sie können die geeignete Konstante aus der Liste im Modulfenster auswählen. Dies hat den Vorteil, dass Sie sich die Konstante nicht merken oder im entsprechenden Hilfethema nachschlagen müssen.

Die folgenden Informationen sind für alphabetisch sortierte Konstanten gültig:

  • Die Menge alphabetisch sortierter Konstanten für jedes Methoden-, Funktions- oder Eigenschaftenargument trägt einen Namen, der in der Syntaxzeile für die Methode, Funktion oder Eigenschaft im Modulfenster angezeigt wird, wenn die Option Automatische Direkthilfe auf der Registerkarte Editor des Dialogfeldes Optionen aktiviert wurde. Das Dialogfeld ist durch Klicken auf Optionen im Menü Extras verfügbar. (Für Eigenschafteneinstellungen wird der Name nicht angezeigt, sondern nur die Liste von Konstanten.) Die Syntaxzeile für die OpenForm-Methode des DoCmd-Objekts zeigt für das Argument Ansicht der Methode z. B. Folgendes an: [View as AcFormView = acNormal]. AcFormView ist der Name dieser Menge alphabetisch sortierter Konstanten, acNormal ist die Standardeinstellung für das Argument. Der Objektkatalog listet ferner die Namen der Mengen alphabetisch sortierter Konstanten im Feld Klassen auf und listet im Feld Elemente von die eingebauten Konstanten in jeder dieser Mengen auf.

  • Haben sich Konstantennamen geändert, können nach wie vor die alten Namen verwendet werden. Eine der eingebauten Konstanten für das Argument Speichern der Methode Close des Objekts DoCmd hieß z.B. acPrompt. Der Name lautet nun acSavePrompt. acPrompt kann jedoch weiterhin verwendet werden.

  • In einer Reihe von Fällen in früheren Versionen von Microsoft Access konnten Sie eine Argumenteinstellung leer lassen; Microsoft Access führte dann die Standardaktion für dieses Argument aus. So schloß Microsoft Access z.B. das aktive Fenster, wenn Sie für das Argument Objekttyp (und Objektname) der Methode Close keine Angabe machten. Für die neuen Mengen alphabetischer sortierter Konstanten wurde die Blankoeinstellung durch eine neue Standardkonstante ersetzt. Das Argument Objekttyp der Methode Close hat jetzt z.B. die neue Standardkonstante acDefault. Das Einstellen dieses Arguments auf die neue Konstante hat dieselbe Wirkung wie fehlende Angaben zum Argument. Darüber hinaus können Sie für solche Argumente weiterhin keine Angaben machen. Microsoft Access geht dann von der neuen Standardkonstante als Einstellung aus.

  • Hierzu gibt es eine Ausnahme. Wenn Sie Visual Basic-Code von früheren Versionen von Visual Basic in Microsoft Access über OLE-Automatisierung ausführen, erzeugen leer gelassene Argumente bei Argumenten, für die die neuen Standardkonstanten vorliegen, einen Fehler. Dieses Problem tritt bei altem Visual Basic für Applikationen- oder Visual Basic-Code, der direkt in Microsoft Access ausgeführt wird, nicht auf.

Die folgende Tabelle listet alle eingebauten Konstanten auf, die hinzugefügt oder geändert wurden, um in Microsoft Access 2000 Listen alphabetisch sortierter Konstanten zu erstellen.

Sprachelement | Argument | Alte Konstante | Neue Konstante
Close-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
CopyObject-Methode | Objekttyp (Herkunft) | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
DeleteObject-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
acmthactOpenDataAccessPage-Methode | Ansicht | (keine) | acDataAccessPageBrowse acDataAccessPageDesign
OutputTo-Methode | Objekttyp | (keine) | acOutputDataAccessPage acOutputServerView acOutputStoredProcedure
Rename-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
RepaintObject-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
RunCommand-Methode | Befehl | (keine) | acCmdDataAccessPageBrowse acCmdDataAccessPageDesignView acCmdDiagramAddRelatedTables acCmdDiagramAutosizeSelectedTables acCmdDiagramDeleteRelationship acCmdDiagramLayoutDiagram acCmdDiagramLayoutSelection acCmdDiagramModifyUserDefinedView acCmdDiagramNewLabel acCmdDiagramNewTable acCmdDiagramRecalculatePageBreaks acCmdDiagramRelationshipLabels acCmdDiagramViewPageBreaks acCmdEditTriggers acCmdHidePane acCmdMicrosoftScriptEditor acCmdNewObjectAutoDataAccessPage acCmdNewObjectDataAccessPage acCmdNewObjectDiagram acCmdNewObjectStoredProcedure acCmdNewObjectView acCmdQueryAddToOutput acCmdSelectDataAccessPage acCmdShowPaneDiagram acCmdShowPaneGrid acCmdShowPaneView acCmdViewDataAccessPages acCmdViewDiagrams acCmdViewFieldList acCmdViewStoredProcedures acCmdViewTableColumnNames acCmdViewTableColumnProperties acCmdViewTableKeys acCmdViewTableNameOnly acCmdViewTableUserView acCmdViewViewVerifySQL acCmdViewViewViews acCmdZoomSelection
Save-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
SelectObject-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure
SendObject-Methode | Objekttyp | (keine) | acSendDataAccessPage
TransferDatabase-Methode | Objekttyp | (keine) | acDataAccessPage acDiagram acServerView acStoredProcedure


 Vergleich der Datentypen

Vergleich der Datentypen

Die Microsoft Jet-Datenbank-Engine kennt mehrere überlappende Datentypgruppen. In Microsoft Access gibt es vier Zusammenhänge, in denen Sie häufig einen Datentyp angeben müssen: in der Entwurfsansicht einer Tabelle, im Dialogfeld Abfrageparameter, in Visual Basic und in der SQL-Ansicht einer Abfrage.

In der folgenden Tabelle sind die insgesamt fünf Datentypgruppen gegenübergestellt, die zu den möglichen Zusammenhängen gehören. In der ersten Spalte stehen zum einen die Einstellungen der Eigenschaft Type, die in der Entwurfsansicht einer Tabelle unter Felddatentyp verfügbar sind, und zum anderen die sechs Einstellungen, die die Eigenschaft Feldgröße für den Datentyp Zahl annehmen kann. In der zweiten Spalte finden Sie die entsprechenden Datentypen einer Parameterabfrage, die im Dialogfeld Abfrageparameter für die Erstellung von Parameterabfragen zur Verfügung stehen. In der dritten Spalte sind die entsprechenden Visual Basic-Datentypen zusammengestellt. In der vierten Spalte sind die für ein DAO-Objekt Field möglichen Datentypen aufgeführt. In der fünften Spalte sind die entsprechenden SQL-Datentypen der Jet-Datenbank-Engine, wie sie für die Jet-Datenbank-Engine definiert sind, zusammen mit ihren zulässigen Synonymen aufgelistet.

Tabellenfelder | Abfrage- parameter | Visual Basic | ADO, Konstanten für Data Type-Eigenschaft | Microsoft Jet-Datenbank-Engine-SQL und Synonyme
Nicht unterstützt | Binary | Nicht unterstützt | adBinary | BINARY (siehe Anmerkungen) (Synonym: VARBINARY)
Ja/Nein | Yes/No | Boolean | adBoolean | BOOLEAN (Synonyme: BIT, LOGICAL, LOGICAL1, YESNO)
Zahl (Feldgröße = Byte) | Byte | Byte | adUnsignedTinyInt | BYTE (Synonym: INTEGER1)
AutoWert (Feldgröße= Long Integer) | Long Integer | Long | adInteger | COUNTER (Synonym: AUTOINCREMENT)
Währung | Currency | Currency | adCurrency | CURRENCY (Synonym: MONEY)
Datum/Uhrzeit | Date/Time | Date | adDate | DATETIME (Synonyme: DATE, TIME, TIMESTAMP)
Zahl (Feldgröße = Double) | Double | Double | adDouble | DOUBLE (Synonyme: FLOAT, FLOAT8, IEEEDOUBLE, NUMBER, NUMERIC)
AutoWert /GUID (Feldgröße = Replikations-ID) | Replication ID | Nicht unterstützt | adGUID | GUID
Zahl (Feldgröße = Long Integer) | Long Integer | Long | adInteger | LONG (Siehe Anmerkungen) (Synonyme: INT, INTEGER, INTEGER4)
OLE-Objekt | OLE Object | String | adLongVarBinary | LONGBINARY (Synonyme: GENERAL, OLEOBJECT)
Memo | Memo | String | adLongVarWChar | LONGTEXT (Synonyme: LONGCHAR, MEMO, NOTE)
Zahl (Feldgröße = Single) | Single | Single | adSingle | SINGLE (Synonyme: FLOAT4, IEEESINGLE, REAL)
Zahl (Feldgröße = Integer) | Integer | Integer | adSmallInt | SHORT (Siehe Anmerkungen) (Synonyme: INTEGER2, SMALLINT)
Text | Text | String | adVarWChar | TEXT (Synonyme: ALPHANUMERIC, CHAR, CHARACTER, STRING, VARCHAR)
Hyperlink | Memo | String | adLongVarWChar | LONGTEXT (Synonyme: LONGCHAR, MEMO, NOTE)
Nicht unterstützt | Value | Variant | adVariant | VALUE (Siehe Anmerkungen)

Anmerkungen

  • Microsoft Access selbst verwendet den Datentyp BINARY nicht. Dieser Datentyp wird nur in Abfragen akzeptiert, für die Folgendes gilt: Sie basieren auf verknüpften Tabellen, die aus anderen Datenbankprodukten stammen, die wiederum den Datentyp BINARY unterstützen.

  • Der in Jet-Datenbank-Engine-SQL verwendete Datentyp INTEGER entspricht nicht dem Datentyp Integer, wie er für Tabellenfelder, Abfrageparameter oder in Visual Basic definiert ist. Der SQL-Datentyp INTEGER entspricht stattdessen dem Datentyp Long Integer für Tabellenfelder und Abfrageparameter bzw. dem Datentyp Long in Visual Basic.

  • Das reservierte Wort VALUE entspricht keinem der Datentypen, die für die Jet-Datenbank-Engine definiert sind. In Microsoft Access oder SQL-Abfragen kann es aber als zulässiges Synonym für den Visual Basic-Datentyp Variant angesehen werden.

  • Wenn Sie in Visual Basic-Code den Datentyp eines DAO-Objekts einstellen, müssen Sie die Type-Eigenschaft des Objekts einstellen.


 Aufrufen von Prozeduren eines Unterformulars oder Unterberichts

Aufrufen von Prozeduren eines Unterformulars oder Unterberichts

Eine Prozedur, die sich in einem Modul eines Unterformulars oder Unterberichts befindet, können Sie auf zwei Arten aufrufen. Ist das Formular, das das Unterformular umfasst, in der Formularansicht geöffnet, können Sie die Prozedur als Methode des Unterformulars ansprechen. Im folgenden Beispiel wird gezeigt, wie eine Prozedur namens ArtikelNrAbrufen des Unterformulars Bestellungen Unterformular aufgerufen wird, das an ein Unterformular-Steuerelement des Formulars Bestellungen gebunden ist:

Geben Sie im Klassenmodul Bestellungen Unterformular folgende Codezeilen ein:

Function ArtikelNrAbrufen()
    ' Aktuelle Artikel-Nr zurückgeben
    ArtikelNrAbrufen = [Artikel-Nr]
End Function
Formulare!Bestellungen![Bestellungen Unterformular].Form.ArtikelNrAbrufen

Als zweite Möglichkeit können Sie eine neue Instanz des Formulars erstellen, das als Unterformular dient, und dann die Prozedur aufrufen. Dies funktioniert selbst dann, wenn weder das Hauptformular noch das Unterformular geöffnet ist. Und diese Vorgehensweise funktioniert für jedes Formular, also für normale Formulare und für Unterformulare. Im folgenden Beispiel wird gezeigt, wie eine Instanz des Unterformulars Bestellungen Unterformular erstellt und die Prozedur ArtikelNrAbrufen aufgerufen wird:

Dim frm As New [Form_Bestellungen Unterformular]
frm.ArtikelNrAbrufen

Anmerkung Wenn Sie eine neue Instanz eines Formulars erstellen, dessen Name aus mehreren Wörtern besteht, setzen Sie den Klassennamen des Formulars entsprechend dem vorangegangenen Beispiel in eckige Klammern.


 Programmieren mit Klassenmodulen

Programmieren mit Klassenmodulen

In Microsoft Access 2000 gibt es zwei Arten von Modulen: Standardmodule und Klassenmodule. In Microsoft Access 95 existierten Klassenmodule nur in Verbindung mit einem Formular oder Bericht. In Microsoft Access 97 waren sie dagegen auch in der Registerkarte Module des Datenbankfensters vorhanden.

Erstellen benutzerdefinierter Objekte mit Klassenmodulen

Sie können mit einem Klassenmodul eine Definition für ein benutzerdefiniertes Objekt erstellen. Der Name, unter dem Sie das Klassenmodul speichern, wird zugleich der Name des benutzerdefinierten Objekts. Öffentliche Sub- und Function-Prozeduren, die Sie in einem Klassenmodul definieren, werden zu benutzerdefinierten Methoden des Objekts. Öffentliche Property Let-, Property Get- und Property Set-Prozeduren werden zu Eigenschaften des Objekts.

Sobald Sie in einem Klassenmodul Prozeduren definiert haben, können Sie das neue Objekt erstellen, indem Sie eine neue Instanz der Klasse erstellen. Um eine neue Instanz einer Klasse zu erstellen, deklarieren Sie eine Variable des durch die Klasse definierten Typs. Wenn ein Klassenname z.B. EineBasicKlasse lautet, erstellen Sie eine neue Instanz dieser Klasse wie folgt:

Dim abc As New EineBasicKlasse

Wenn Sie den Code ausführen, den diese Deklaration enthält, erstellt Visual Basic die neue Instanz. Sie können deren Methoden und Eigenschaften einfach durch Verwendung der Variablen abc anwenden. Wenn Sie z.B. die benutzerdefinierte Methode ListeNamen definiert haben, können Sie diese wie folgt anwenden:

abc.ListeNamen

Neu in Microsoft Access 95: Erstellen der Standardinstanz einer Formularklasse

Wenn Sie ein Formular in der Formularansicht öffnen (von der Benutzeroberfläche oder von Visual Basic aus), erstellen Sie eine Instanz des Klassenmoduls dieses Formulars. Mit anderen Worten, Sie legen Platz im Arbeitsspeicher fest, in dem das Objekt nun existiert, und können dann seine Methoden im Code aufrufen und seine Eigenschaften im Code einstellen oder zurückgeben wie für jedes eingebaute Objekt. Das gleiche gilt, wenn Sie einen Bericht in der Seitenansicht öffnen.

Wenn Sie in Visual Basic-Code auf ein Formular verweisen, arbeiten Sie normalerweise mit der Standardinstanz der Klasse des Formulars. Die Klasse eines Formulars hat nur eine Standardinstanz. Sie können auch mehrere Instanzen derselben Klasse des Formulars von Visual Basic aus erstellen. Wenn Sie dies tun, erstellen Sie Nicht-Standardinstanzen.

Es bestehen vier Möglichkeiten zum Erstellen der Standardinstanz eines Formulars. Sie können ein bestehendes Formular folgendermaßen öffnen: über die Benutzerschnittstelle; durch Ausführen der OpenForm-Methode des DoCmd-Objekts; durch Aufrufen der CreateForm-Methode und Wechseln in die Formularansicht für das neue Formular; oder durch Erstellen einer Variablen des Typs Form in Visual Basic, die auf die Standardinstanz verweist. Das folgende Beispiel öffnet das Formular Personal und zeigt mit einer Variablen des Typs Form darauf.

Dim frm As Form
DoCmd.OpenForm "Personal"
Set frm = Formulare!Personal

Microsoft Access bietet auch eine Verknüpfung, mit der Sie in einem Schritt ein Formular öffnen und auf eine Methode, eine Eigenschaft oder ein Steuerelement des Formulars verweisen können. Sie verweisen auf das Klassenmodul des Formulars wie folgt:

Form_Personal.Visible = True
Form_Personal.Caption = "Neue Mitarbeiter"

Wenn Sie diesen Code ausführen, öffnet Microsoft Access das Formular Personal in der Formularansicht, falls es nicht bereits geöffnet ist, und stellt die Überschrift des Formulars auf "Neue Mitarbeiter" ein. Das Formular ist nicht sichtbar, bis Sie explizit seine Eigenschaft Visible auf True (-1) einstellen. Wenn die Prozedur, die diesen Code aufruft, die Ausführung beendet hat, wird die Instanz des Formulars zerstört, d. h., das Formular wird geschlossen.

Wenn Sie versuchen, diesen Code auszuführen, während das Formular Personal in der Entwurfsansicht geöffnet ist, erzeugt Microsoft Access einen Laufzeitfehler. Das Formular muss entweder in der Formularansicht oder darf gar nicht geöffnet sein.

Wenn Sie diese Syntax verwenden, um eine Eigenschaft oder ein Steuerelement des Formulars zu ändern, gehen die Änderungen verloren, wenn die Instanz des Formulars gelöscht wird. Dies trifft immer dann zu, wenn Sie eine Eigenschafteneinstellung für ein Formular in der Formularansicht ändern. Ändern Sie die Eigenschaft in der Entwurfsansicht und speichern die Änderungen mit dem Formular.

Erstellen mehrerer Nicht-Standardinstanzen von Formularen

Sie können mehrere Nicht-Standardinstanzen einer Klasse eines Formulars erstellen, wenn Sie mehrere Instanzen des Formulars gleichzeitig anzeigen möchten. Sie möchten z.B. die Datensätze für einen Angestellten und seinen Vorgesetzten gleichzeitig anzeigen. Sie können eine Instanz des Formulars Personal zur Anzeige des Angestellten-Datensatzes erstellen, und eine Instanz zur Anzeige des Vorgesetzten-Datensatzes.

Wenn Sie neue Nicht-Standardinstanzen einer Klasse eines Formulars aus Visual Basic heraus erstellen möchten, deklarieren Sie eine Variable, deren Typ der Klassenname des Formularmoduls ist. Schließen Sie das Schlüsselwort New in der Variablendeklaration ein. Beispielsweise erstellt der folgende Code eine neue Instanz des Formulars Personal und weist sie einer Variablen des Typs Form zu.

Dim frm As New Form_Personal

Diese Nicht-Standardinstanz des Formulars ist nicht sichtbar, bis Sie deren Eigenschaft Visible explizit einstellen.

Wenn die Ausführung der Prozedur, die diese Instanz erstellt hat, beendet ist, wird die Instanz aus dem Speicher entfernt, es sei denn, Sie haben die repräsentierende Variable als Variable auf Modulebene deklariert. Da Variablen auf Modulebene ihren Wert behalten, bis sie mit dem Befehl Neu initialisieren im Menü Ausführen oder der Schaltfläche Neu initialisieren [image] in der Symbolleiste zurückgesetzt werden, bleibt das Formular geöffnet, falls die Variable als Variable auf Modulebene deklariert worden ist.

Alle Eigenschaften, die Sie einstellen, beeinflussen diese Instanz der Klasse des Formulars, werden jedoch nicht mit dem Formular gespeichert. Auch kann keine neue Instanz der Klasse des Formulars erstellt werden, wenn das Formular in der Entwurfsansicht geöffnet ist.

Auf eine Nicht-Standardinstanz eines Formulars kann nicht über den Namen in der Auflistung Forms verwiesen werden. Es sind nur Verweise über die Indexnummer möglich. Da Sie mehrere Nicht-Standardinstanzen eines Formulars erstellen können und jede Instanz den gleichen Namen hat, kann die Auflistung Forms mehrere gleichnamige Formulare enthalten, die sich lediglich durch ihre Indexnummer unterscheiden.


 Option Private-Modul ist in einem Objektmodul nicht zulässig

Option Private-Modul ist in einem Objektmodul nicht zulässig

Microsoft Access-Formularmodule und Berichtsmodule sind Klassenmodule. Sie können die Option Private Module-Anweisung nicht in einem Formular- oder Berichtsmodul einschließen.


 Einstellen von Verweisen auf Typbibliotheken

Einstellen von Verweisen auf Typbibliotheken

Wenn Sie einen Verweis auf die Typbibliothek einer anderen Anwendung erstellen, können Sie die Objekte dieser Anwendung in Ihrem Code verwenden. Erstellen Sie z. B. einen Verweis von Microsoft Access auf die Microsoft Excel-Bibliothek, so können Sie Microsoft Excel-Objekte mit Hilfe der Automatisierung (früher "OLE-Automatisierung" genannt) verwenden. Wenn Sie einen Verweis auf ein Visual Basic-Projekt in einer anderen Datenbank erstellen, können Sie deren öffentliche Prozeduren aufrufen. Wenn Sie einen Verweis auf ein ActiveX-Steuerelement erstellen, können Sie das Steuerelement in Microsoft Access-Formularen verwenden.

Sie können einen Verweis in Microsoft Access erstellen, während der Visual Basic-Editor geöffnet ist, oder Sie können ihn im Visual Basic-Code erstellen.

Einstellen eines Verweises in Microsoft Access:

So stellen Sie einen Verweis auf die Typbibliothek einer Anwendung ein:

  1. Klicken Sie im Menü Extras auf Verweise. Der Befehl Verweise ist im Menü Extras nur dann verfügbar, wenn ein Modulfenster geöffnet und in der Entwurfsansicht aktiv ist.

  2. Aktivieren Sie die Kontrollkästchen der Anwendungen, deren Typbibliotheken referenziert werden sollen.

Einstellen eines Verweises in Visual Basic

Um einen Verweis in Visual Basic einzustellen, erstellen Sie ein neues Reference-Objekt, das den gewünschten Verweis darstellt. Die Auflistung References enthält alle momentan eingestellten Verweise.

Zum Erstellen eines neuen Reference-Objekts verwenden Sie die Methode AddFromFile oder die Methode AddFromGUID der Auflistung References. Um ein Reference-Objekt zu entfernen, verwenden Sie die Methode Remove.

Vorteile von Verweisen

Ihr Automatierungscode wird schneller ausgeführt, wenn Sie einen Verweis auf die Typbibliothek einer anderen Anwendung einrichten, bevor Sie mit deren Objekten arbeiten. Haben Sie einen Verweis eingerichtet, so können Sie eine Objektvariable deklarieren, die ein typisches Objekt der anderen Anwendung darstellt. Wenn Sie z.B. Code schreiben, um mit Microsoft Excel-Objekten zu arbeiten, können Sie mit der folgenden Syntax nur dann eine Objektvariable des Typs Excel.Application deklarieren, wenn Sie einen Verweis auf die Microsoft Excel-Typbibliothek erzeugt haben:

Dim appXL As New Excel.Application

Wenn Sie keinen Verweis auf die Microsoft Excel-Typbibliothek eingerichtet haben, deklarieren Sie die Variable als generische Variable vom Typ Object. Der folgende Code wird langsamer ausgeführt:

Dim appXL As Object

Zusätzlich werden beim Einrichten eines Verweises auf die Typbibliothek einer Anwendung alle Objekte, Methoden und Eigenschaften dieser Anwendung im Objektkatalog aufgeführt. Dadurch können Sie sehr einfach ermitteln, welche Eigenschaften und Methoden für jedes Objekt verfügbar sind.

Da Microsoft Access eine COM-Komponente ist, die die Automatisierung unterstützt, können Sie auch aus einer anderen Anwendung heraus einen Verweis auf die Typbibliothek von Microsoft Access einrichten und mit Microsoft Access-Objekten aus dieser Anwendung heraus arbeiten.


 Verweisen auf ein Visual Basic-Projekt in einer anderen Microsoft Access-Datenbank oder einem anderen Projekt

Verweisen auf ein Visual Basic-Projekt in einer anderen Microsoft Access-Datenbank oder einem anderen Projekt

Jede Microsoft Access-Datenbank (.mdb oder .adp) enthält ein Visual Basic-Projekt. Es besteht aus allen Modulen des Projekts - den Standardmodulen und den Klassenmodulen. Jede Microsoft Access-Datenbank (.mdb oder .adp), jede Bibliotheksdatenbank und jedes in einer .MDE-Datei enthaltene Add-In beinhaltet ein Visual Basic-Projekt.

Der Name der Access-Datenbank und der Name des Projekts können sich unterscheiden. Der Name der Access-Datenbank entspricht dem Namen der .mdb- (oder .mda- oder .mde-) oder .adp-Datei, während der Name des Projekts durch die Einstellung der Option Projektname in der Registerkarte Allgemein im Projekteigenschaftenfenster (Menü Extras, Befehl Eigenschaften von Projektname) festgelegt wird. Wenn Sie eine Datenbank (.mdb oder .adp) neu erstellen, sind Datenbankname und Projektname standardmäßig identisch. Wenn Sie die Datenbank später umbenennen, ändert sich der Projektname jedoch nicht automatisch. Umgekehrt hat auch das Ändern des Projektnamens keine Auswirkung auf den Datenbanknamen.

Sie können von einem Visual Basic-Projekt in einer Microsoft Access-Datenbank einen Verweis auf ein Projekt in einer anderen Microsoft Access-Datenbank, auf eine Bibliotheksdatenbank oder auf ein in einer .MDE-Datei enthaltenes Add-In einrichten. Anschließend können Sie Visual Basic-Prozeduren im referenzierten Projekt ausführen. Beispielsweise enthält die Beispieldatenbank Nordwind das Modul Dienstprogramme, das wiederum die Funktion IsLoaded enthält. Sie können von dem Projekt in der aktuellen Datenbank aus einen Verweis auf das Projekt in der Beispieldatenbank Nordwind einrichten und dann die Funktion IsLoaded so aufrufen, als ob sie innerhalb der aktuellen Datenbank definiert wäre.

So stellen Sie einen Verweis auf das Projekt in der Beispieldatenbank Nordwind von einem anderen Projekt aus ein:

  1. Öffnen Sie das Modulfenster.

  2. Klicken Sie im Menü Extras auf Verweise, und klicken Sie dann im Dialogfeld Verweise auf Durchsuchen.

  3. Klicken Sie im Feld Dateityp auf Microsoft Access-Datenbanken (*.mdb).

  4. Suchen Sie die Datei NORDWIND.MDB. Falls Sie diese Datei installiert haben, befindet sie sich standardmäßig im Verzeichnis \PROGRAMME\MICROSOFT OFFICE\OFFICE\BEISPIEL.

  5. Klicken Sie auf OK.

"NORDWIND.MDB" ist nun in der Liste der verfügbaren Verweise im Dialogfeld Verweise zu sehen.

Anmerkungen

  • Richten Sie einen Verweis auf das Projekt in einer anderen Microsoft Access-Datenbank ein, wenn Sie eine öffentliche Prozedur aufrufen möchten, die in einem Standardmodul dieser Datenbank definiert ist. Sie können keine Prozeduren aufrufen, die in einem Klassenmodul definiert sind, und keine Prozeduren in einem Standardmodul, denen das Schlüsselwort Private vorangestellt ist.

  • Sie können einen Verweis auf das Projekt in einer Microsoft Access-Datenbank nur von einer anderen Microsoft Access-Datenbank aus einrichten.

  • Sie können einen Verweis auf ein Projekt nur in einer anderen Microsoft Access 2000-Datenbank einrichten. Wenn Sie einen Verweis auf ein Projekt in einer Datenbank einrichten möchten, die mit einer früheren Microsoft Access-Version erstellt wurde, konvertieren Sie die Datenbank zuerst in Microsoft Access 2000.

  • Wenn Sie von Microsoft Access aus einen Verweis auf ein Projekt oder eine Typbibliothek einstellen und dann die Datei, die das Projekt oder die Typbibliothek enthält, in einen anderen Ordner verschieben, versucht Microsoft Access diese Datei zu finden und den Verweis wiederherzustellen. Ist der Schlüssel RefLibPaths bereits in der Registrierung vorhanden, dann sucht Microsoft Access zuerst dort. Wenn dieser Eintrag nicht gefunden wird, sucht Microsoft Access die Datei zuerst im aktuellen Ordner, danach in allen Ordnern des Laufwerks. Sie können den Schlüssel RefLibPaths mit Hilfe des Registrierungseditors in Windows unter dem Registrierungsschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access erstellen. Weitere Informationen über die Verwendung des Registrierungseditors finden Sie in der Windows-Dokumentation.


 Einstellen von Formular-, Berichts- und Steuerelementeigenschaften

Einstellen von Formular-, Berichts- und Steuerelementeigenschaften

Jedes Formular, jeder Bericht, jeder Bereich und jedes Steuerelement verfügt über Eigenschafteneinstellungen, mit denen Sie das Aussehen und die Funktionsweise eines Elements ändern können. Sie können die Eigenschaften im Eigenschaftenfenster, in einem Makro oder in Visual Basic anzeigen und ändern.

So stellen Sie Eigenschaften ein

  1. Wählen Sie in der Formular-Entwurfsansicht oder Berichts-Entwurfsansicht das Steuerelement, den Bereich, das Formular oder den Bericht aus, für das bzw. den Sie die Eigenschaft einstellen möchten. Sie haben folgende Auswahlmöglichkeiten:
    • Steuerelemente. Wenn Sie mehrere Steuerelemente auswählen möchten, klicken Sie bei gedrückter UMSCHALTTASTE auf die gewünschten Steuerelemente, oder ziehen Sie den Mauszeiger über die gewünschten Steuerelemente. Wenn Sie mehrere Steuerelemente auswählen, zeigt das Eigenschaftenfenster nur die Eigenschaften an, die alle markierten Steuerelemente gemeinsam besitzen.

    • Einen Bereich. Klicken Sie auf den Bereichsmarkierer des gewünschten Bereichs.

    • Das gesamte Formular oder den gesamten Bericht. Klicken Sie auf den Formularmarkierer oder Berichtsmarkierer in der oberen linken Ecke des Formulars bzw. Berichts.
  2. Zeigen Sie das Eigenschaftenfenster an, indem Sie zuerst mit der rechten Maustaste auf das Objekt oder den Bereich und dann im Kontextmenü auf Eigenschaften klicken, oder indem Sie auf Eigenschaften [image] in der Symbolleiste klicken.

  3. Klicken Sie auf die Eigenschaft, deren Wert Sie einstellen möchten, und führen Sie dann einen der folgenden Schritte durch:
    • Geben Sie im Einstellungsfeld der Eigenschaft die gewünschte Einstellung oder einen geeigneten Ausdruck ein.

    • Wenn das Einstellungsfeld der Eigenschaft einen Pfeil enthält, klicken Sie auf den Pfeil, und klicken Sie dann in der Liste auf einen Wert.

    • Wenn sich eine Editor-Schaltfläche [image] neben dem Einstellungsfeld der Eigenschaft befindet, klicken Sie darauf, um einen Editor oder ein Dialogfeld anzuzeigen, das eine Auswahl von Editoren anbietet. So können Sie z.B. den Code-Generator, den Makro-Generator oder den Abfrage-Generator verwenden, um bestimmte Eigenschaften einzustellen.

Weitere Informationen dazu, wenn das Eigenschaftenfenster leer ist oder nicht die erwarteten Eigenschaften enthält, finden Sie unter Problembehandlung in Eigenschaftenfenstern.

Tipps

  • Microsoft Access stellt ein Zoom-Feld für die Eingabe und die Anzeige von Ausdrücken oder anderen langen Eigenschafteneinstellungen bereit. Um das Zoom-Feld anzuzeigen, klicken Sie im Eigenschaftenfenster auf das Einstellungsfeld einer Eigenschaft. Drücken Sie dann UMSCHALT+F2, oder klicken Sie zuerst mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zoom.

  • Sie können die Eigenschaft ControlSource für einige Steuerelemente einstellen, indem Sie die Eigenschafteneinstellung im Steuerelement selbst vornehmen. Weitere Informationen finden Sie unter Erstellen eines berechneten Steuerelements.

  • Durch Ändern der Standardeigenschafteneinstellungen für einen Steuerelementtyp können Sie erreichen, dass Steuerelemente, die Sie später erstellen, über die neuen Standardeinstellungen verfügen.

  • Die Eigenschafteneinstellungen eines gebundenen Steuerelements stimmen nicht immer mit den entsprechenden Einstellungen im Feld der zugrunde liegenden Tabelle oder Abfrage überein, an die das Steuerelement gebunden ist. In diesem Fall setzen die Einstellungen des Formulars oder Berichts in der Regel die Einstellungen der Tabelle oder Abfrage außer Kraft. Weitere Informationen über die Vererbung von Eigenschaften finden Sie unter Beziehung zwischen Steuerelementeigenschaften und Eigenschaften in den zugrunde liegenden Feldern.


Einstellen von Eigenschaften unter Verwendung von Visual Basic

Die meisten Eigenschaften können Sie in Visual Basic-Code einstellen. Wie Sie eine Eigenschaft einstellen, hängt davon ab, ob Sie diese für Form-Objekte (Formulare), Report-Objekte (Berichte) oder Control-Objekte (Steuerelemente), für ActiveX Data-Objekte (ADO), Datenzugriffsobjekte (Data Access Objects, DAO) oder DataAccessPage-Objekte (Datenzugriffsseiten) einstellen. Die folgenden Themen beschreiben für jeden Objekttyp die Schritte, die zum Einstellen von Eigenschaften erforderlich sind.

Einstellen von Formular-, Berichts- und Steuerelementeigenschaften in Visual Basic

Einstellen der Eigenschaften von ActiveX Data-Objekten in Visual Basic

Einstellen der Eigenschaften von Datenzugriffsobjekten in Visual Basic

Einstellen der Eigenschaften von Datenzugriffsseiten in Visual Basic


 Einstellen von Eigenschaften unter Verwendung von Makros

Einstellen von Eigenschaften unter Verwendung von Makros

Aus einem Makro können Sie die Eigenschaften für Form-Objekte (Formulare), Report-Objekte (Berichte) und Control-Objekte (Steuerelemente) sowie für Formular- und Berichtsbereiche einstellen. Verwenden Sie die Aktion SetzenWert in einem Makro, um den Wert einer Eigenschaft einzustellen.

Sie können mit einem Makro weder die Eigenschaften anderer Microsoft Access-Objekte oder ActiveX Data-Objekte (ADO) noch die Standardeigenschaften eines Steuerelements einstellen. Diese können Sie jedoch in Visual Basic oder im Eigenschaftenfenster eines Objekts in der Entwurfsansicht vornehmen.

So stellen Sie eine Formular-, Berichts- oder Steuerelementeigenschaft mit einem Makro ein

  1. Fügen Sie zum Makro eine Aktion SetzenWert hinzu.

  2. Stellen Sie das Aktionsargument Feld der Aktion SetzenWert auf einen Ausdruck ein, der auf die einzustellende Eigenschaft verweist:
    • Um eine Formular- oder Berichtseigenschaft einzustellen, verwenden Sie die Syntax Forms!Formularname.Eigenschaftenname oder Reports!Berichtsname.Eigenschaftenname. Der folgende Ausdruck verweist z.B. auf die Eigenschaft Visible des Formulars Kunden.
      Formulare!Kunden.Visible
    • Um die Eigenschaft eines Steuerelements in einem Formular oder Bericht einzustellen, verwenden Sie die Syntax Forms!Formularname!Steuerelementname.Eigenschaftenname oder Reports!Berichtsname!Steuerelementname.Eigenschaftenname. Beispielsweise verweist der folgende Ausdruck auf die Eigenschaft Visible des Steuerelements VerborgenerSeitenumbruch im Bericht Rechnung.
      Reports!Rechnung!VerborgenerSeitenumbruch.Visible

    Tipp Wenn das Makro, das die Aktion SetzenWert enthält, aus dem Formular oder Bericht mit der einzustellenden Eigenschaft ausgeführt wird, reicht die Syntax Eigenschaftenname aus, um auf die Eigenschaft zu verweisen. Dennoch empfiehlt es sich, mit der vollständigen Syntax auf die Eigenschaft zu verweisen, um Konflikte mit Namen von Steuerelementen oder Visual Basic-Schlüsselwörtern zu vermeiden. Beispielsweise ist Name eine Microsoft Access-Eigenschaft; wenn Sie in Ihrem Formular ebenfalls ein Steuerelement Name verwenden, verwenden Sie sowohl für Verweise auf das Steuerelement als auch auf die Eigenschaft die vollständige Syntax.

  3. Stellen Sie das Aktionsargument Ausdruck der Aktion SetzenWert auf den gewünschten Wert der Eigenschaft ein. Stellt die Einstellung eine Zeichenfolge dar, so setzen Sie diese in Anführungszeichen ("). Wenn Sie z.B. die Eigenschaft Caption eines Formulars auf Bestellungen einstellen möchten, geben Sie "Bestellungen" im Argument Ausdruck ein.

So stellen Sie eine Bereichseigenschaft mit einem Makro ein

  1. Fügen Sie zum Makro eine Aktion SetzenWert hinzu.

  2. Verwenden Sie im Aktionsargument Feld die Syntax Forms!Formularname.Bereich(Konstante).Eigenschaftenname , um auf die einzustellende Eigenschaft zu verweisen. Das Argument Konstante verweist auf einen bestimmten Bereich des Formulars oder Berichts, der in der Eigenschaft Section beschrieben wird. Beispielsweise verweist der folgende Ausdruck auf die Eigenschaft Visible des Seitenkopfbereichs im Formular Kunden.
    Formulare!Kunden.Section(acHeader).Visible
  3. Stellen Sie das Aktionsargument Ausdruck wie oben beschrieben ein.

Anmerkungen Zu jeder Eigenschaft, die Sie einstellen möchten, erhalten Sie im Hilfeindex weitere Informationen zu folgenden Punkten:

  • Ob die Eigenschaft in einem Makro eingestellt werden kann.

  • Ansichten, in denen Sie die Eigenschaft einstellen können. Nicht alle Eigenschaften können in jeder Ansicht eingestellt werden. Sie können z.B. die Eigenschaft BorderStyle eines Formulars nur in der Formular-Entwurfsansicht einstellen.

  • Werte, die Sie zur Einstellung der Eigenschaft verwenden können. Einige Eigenschaften erfordern Einstellungen, die nicht den Werten im Eigenschaftenfenster entsprechen, sondern Zahlen sind. Stellen Sie die Eigenschaft unter Umständen mit den Werten ein, die Sie in Visual Basic verwenden, anstatt mit Werten, die Sie im Eigenschaftenfenster verwenden. Wenn die Eigenschafteneinstellungen in einer Dropdownliste ausgewählt werden, verwenden Sie für jede Auswahl den Wert oder seine numerische Entsprechung.


 Einstellen von Datenzugriffsseiten- und Steuerelementeigenschaften

Einstellen von Datenzugriffsseiten- und Steuerelementeigenschaften

Jede Datenzugriffsseite, jeder Bereich und das zugehörige Steuerelement besitzen Eigenschafteneinstellungen, die Sie ändern können, um das Aussehen und Verhalten dieses Elements zu ändern. Zum Anzeigen und Ändern von Eigenschaften verwenden Sie das Eigenschaftenfenster oder den Microsoft Visual Script Editor.

So stellen Sie Eigenschaften ein

  1. Markieren Sie in der Seiten-Entwurfsansicht die Datenzugriffsseite, den Bereich oder das Steuerelement, deren bzw. dessen Eigenschaft Sie einstellen möchten. Sie können markieren:
    • Ein Steuerelement. Klicken Sie auf das gewünschte Steuerelement.

    • Einen Bereich. Klicken Sie auf den Bereichsmarkierer des Bereichs, der markiert werden soll.

    • Die gesamte Datenzugriffsseite. Klicken Sie auf die Titelleiste der Datenzugriffsseite.
  2. Zeigen Sie das Eigenschaftenfenster an, indem Sie das Objekt markieren und in der Symbolleiste auf Eigenschaften [image] klicken. Bei Bereichen und Steuerelementen können Sie mit der rechten Maustaste auf den betreffenden Bereich bzw. das betreffende Steuerelement klicken und dann im Kontextmenü auf Eigenschaften klicken.

  3. Klicken Sie auf die Eigenschaft, deren Wert Sie einstellen möchten, und verwenden Sie dann eines der folgenden Verfahren:
    • Geben Sie im Einstellungsfeld für die Eigenschaft die entsprechende Einstellung oder den geeigneten Ausdruck ein.

    • Wenn das Einstellungsfeld für die Eigenschaft einen Pfeil enthält, klicken Sie auf den Pfeil und dann auf einen Wert in der Liste.

Ist das Eigenschaftenfenster leer oder enthält es nicht die erwarteten Eigenschaften, lesen Sie unter Problembehandlung in Eigenschaftenfenstern nach.

Tipps

  • Microsoft Access enthält das Dialogfeld Zoom für die Eingabe und Anzeige von Ausdrücken oder anderen langen Eigenschafteneinstellungen. Zum Anzeigen des Dialogfeldes Zoom klicken Sie im Eigenschaftenfenster auf ein Einstellungsfeld. Anschließend drücken Sie UMSCHALT+F2, oder Sie klicken mit der rechten Maustaste und klicken dann im Kontextmenü auf Zoom.

  • Die Eigenschafteneinstellungen eines gebundenen Steuerelements stimmen nicht immer mit den entsprechenden Einstellungen des Feldes der zugrunde liegenden Tabelle, Abfrage oder Sicht überein, an die das Steuerelement gebunden ist. In diesem Fall setzen die Einstellungen des Formulars oder Berichts die Einstellungen der Tabelle, Abfrage oder Sicht in der Regel außer Kraft. Weitere Informationen über die Vererbung von Eigenschaften finden Sie unter Beziehung zwischen Steuerelementeigenschaften und Eigenschaften in den zugrunde liegenden Feldern.


Einstellen von Starteigenschaften und Optionen in Code

Starteigenschaften beeinflussen die Darstellungsweise einer Datenbankanwendung, wenn diese geöffnet wird. Mit Hilfe der Starteigenschaften können Sie z.B. die Titelleiste, Menüs, Symbolleisten und das Startformular der Anwendung benutzerdefiniert anpassen. Um Eigenschaften im Dialogfeld Start anzuzeigen, klicken Sie im Menü Extras auf Start.

Sie können im Dialogfeld Optionen Optionen einstellen, die verschiedene Elemente der Anwendungsumgebung verändern, während Sie darin arbeiten. Beispielsweise können Sie Standardoptionen für Formulare, Berichte, Tabellen und Abfragen einstellen. Klicken Sie im Menü Extras auf Optionen, um das Dialogfeld Optionen anzuzeigen.

Weitere Informationen über das Einstellen von Starteigenschaften und Optionen in Code finden Sie unter folgenden Themen:

Einstellen von Starteigenschaften von Visual Basic aus

Einstellen von Optionen von Visual Basic aus


 Starteigenschaften in neuen Projekten und Datenbanken

Starteigenschaften in neuen Projekten und Datenbanken

Wenn Sie ein neues Microsoft Access-Projekt (.adp) oder eine neue Microsoft Access-Datenbank (.mdb) erstellen, fügt Microsoft Access der AccessObjectProperties-Auflistung des Projekts bzw. der Properties-Auflistung einer Datenbank automatisch eine Gruppe von Eigenschaften hinzu.

  • In einem Access-Projekt werden die folgenden Eigenschaften dem CurrentProject-Objekt hinzugefügt.

    Build AccessVersion

    Auf diese Eigenschaften können Sie mit folgender Syntax zugreifen:

    CurrentProject.Properties("Eigenschaftenname").Value

  • In einer Access-Datenbank werden die folgenden Eigenschaften dem Database-Objekt hinzugefügt.

    Name | RecordsAffected
    Connect | ReplicaID
    Transactions | DesignMasterID
    Updatable | Connection
    CollatingOrder | AccessVersion
    QueryTimeout | Build
    Version

    Auf diese Eigenschaften können Sie mit folgender Syntax zugreifen:

    CurrentDB.Properties("Eigenschaftenname").Value

Wenn Sie eine Starteigenschaft in einem Projekt oder einer Datenbank über das Dialogfeld Start festlegen (zum Öffnen dieses Dialogfeldes klicken Sie im Menü Extras auf Start) fügt Microsoft Access eine Gruppe von Starteigenschaften zur entsprechenden Properties-Auflistung hinzu. Diese Eigenschaften werden nicht hinzugefügt, wenn eine Starteigenschaft programmgesteuert hinzugefügt wird.

  • In einem Access-Projekt wird eine Teilmenge der folgenden Starteigenschaften dem CurrentProject-Objekt hinzugefügt. Diese Teilmenge hängt von der über das Dialogfeld Start eingestellten Starteigenschaft ab.

    AppTitle | AllowBuiltinToolbars
    StartupForm | AllowToolbarChanges
    StartupShowDBWindow | AllowBreakIntoCode
    StartupShowStatusbar | AllowSpecialKeys
    StartupMenubar | AppIcon
    AllowShortcutMenus | StartupShortcutMenubar
    AllowFullMenus | HijriCalendar

  • In einer Access-Datenbank wird eine Teilmenge der folgenden Starteigenschaften dem Database-Objekt hinzugefügt. Diese Teilmenge hängt von der über das Dialogfeld Start eingestellten Starteigenschaft ab.

    AppTitle | AllowBuiltinToolbars
    StartupForm | AllowToolbarChanges
    StartupShowDBWindow | AllowBreakIntoCode
    StartupShowStatusbar | AllowSpecialKeys
    StartupMenubar | AppIcon
    AllowShortcutMenus | StartupShortcutMenubar
    AllowFullMenus | HijriCalendar


 Angeben datums- und zeitbezogener Kriterien

Angeben datums- und zeitbezogener Kriterien

Wenn Sie datums- oder zeitbezogene Kriterien für das Argument Kriterien angeben möchten, geben Sie einen Datums- oder Zeitwert als Bestandteil des Zeichenfolgenausdrucks an. Dieser Wert muss in Nummernzeichen (#) eingeschlossen sein.

Anmerkung Durch das Nummernzeichen wird Microsoft Access mitgeteilt, dass das Argument Kriterien ein Datum oder eine Uhrzeit innerhalb einer Zeichenfolge enthält.

Angenommen, Sie erstellen einen Filter für ein Formular Personal, um die Datensätze aller Angestellten anzuzeigen, die am 1. Januar 1960 oder später geboren wurden. Sie könnten dann das Argument Kriterien der Eigenschaft Filter oder Serverfilter des Formulars wie im folgenden Beispiel zusammenstellen. Beachten Sie die Anordnung der Nummernzeichen.

Formulare!Personal.Filter = "[Geburtsdatum] >= #1-1-60#"


 Angeben datums- und zeitbezogener Kriterien aus einem Steuerelement in einem Formular

Angeben datums- und zeitbezogener Kriterien aus einem Steuerelement in einem Formular

Wenn Sie das Argument Kriterien einer Operation entsprechend einem Benutzerwunsch ändern möchten, können Sie angeben, dass die Kriterien einem bestimmten Steuerelement eines Formulars entnommen werden. Sie könnten z. B. angeben, dass das Argument Kriterien einem Listenfeld entnommen wird, das Bestelldaten aus der Tabelle Bestellungen enthält.

Wenn Sie datums- oder zeitbezogene Kriterien angeben möchten, die einem Steuerelement eines Formulars entnommen werden sollen, fügen Sie in das Argument Kriterien einen Ausdruck ein, der auf das Steuerelement im Formular verweist. Dieser Ausdruck sollte vom Zeichenfolgenausdruck getrennt stehen, damit er zuerst ausgewertet und dann mit dem Rest des Zeichenfolgenausdrucks verkettet wird, bevor die entsprechende Operation ausgeführt wird.

Sie müssen nicht nur den gesamten Zeichenfolgenausdruck in Anführungszeichen (") setzen, sondern auch die datums- oder zeitbezogenen Kriterien innerhalb des Zeichenfolgenausdrucks in Nummernzeichen (#). Die Nummernzeichen müssen sich in den Zeichenfolgen befinden, die neben dem Ausdruck stehen, der auf das Steuerelement im Formular verweist.

Anmerkung Durch die Nummernzeichen wird Microsoft Access mitgeteilt, dass das Argument Kriterien eine Datums- oder Zeitangabe innerhalb einer Zeichenfolge enthält.

Im folgenden Beispiel wird die Eigenschaft Filter oder Serverfilter eines Formulars auf der Grundlage von Kriterien eingestellt. Die Kriterien stammen von einem Steuerelement namens Einstellungsdatum des Formulars. Beachten Sie die Anordnung der Nummernzeichen.

Formulare!Personal.Filter = "[Einstellungsdatum] >= #" _
 &     Formulare!Personal!Einstellungsdatum & "#"
Formulare!Personal.FilterOn = True

- oder -

Formulare!Personal.ServerFilter = "[Einstellungsdatum] >= #" _
 &     Formulare!Personal!Einstellungsdatum & "#"
Formulare!Personal.FilterOn = True

Ist der aktuelle Wert des Steuerelements Einstellungsdatum 1.5.92, hat die Eigenschaft Filter oder Serverfilter das folgende Argument Kriterien:

"[Einstellungsdatum] >= #1.5.92#"

Tipp Wenn Sie Fehler im Argument Kriterien beseitigen möchten, unterteilen Sie den Ausdruck in kleinere Komponenten und testen diese einzeln im Direktfenster. Wenn alle Komponenten einwandfrei funktionieren, setzen Sie sie nacheinander wieder zusammen, bis der gesamte Ausdruck einwandfrei funktioniert.

Sie können auch eine Variable, die ein Datum oder eine Uhrzeit darstellt, in das Argument Kriterien einfügen. Die Variable sollte getrennt vom Zeichenfolgenausdruck stehen, damit sie zuerst ausgewertet wird. Das Ergebnis wird dann mit dem Rest des Zeichenfolgenausdrucks verkettet. Das Datums- oder Zeitkriterium muss in Nummernzeichen (#) eingeschlossen sein.

Das folgende Beispiel zeigt, wie das Argument Kriterien zusammengestellt wird, wenn es eine Variable enthalten soll, die ein Datum oder eine Uhrzeit darstellt:

Dim datEinstellungsdatum As Date
datEinstellungsdatum = #1.5.92#
Formulare!Personal.Filter = "[Einstellungsdatum] >= #" _
 &     datEinstellungsdatum & "#"


 Angeben mehrerer Felder im Argument "Kriterien"

Angeben mehrerer Felder im Argument "Kriterien"

Sie können mehrere Felder im Argument Kriterien einer Aggregatfunktion für Domänen angeben.

Dabei müssen Sie sicherstellen, dass mehrere Zeichenfolgenausdrücke korrekt zu einer gültigen SQL WHERE-Klausel verkettet sind. In einer SQL WHERE-Klausel mit mehreren Feldern können Felder durch eines der folgenden drei Schlüsselwörter verknüpft werden: AND, OR oder NOT. Ihr Ausdruck muss nach der Auswertung eine Zeichenfolge ergeben, die eines dieser Schlüsselwörter enthält.

Angenommen, Sie wollen die Eigenschaft Filter für ein Formular Personal einstellen, um die angezeigten Datensätze durch zwei Gruppen von Kriterien einzuschränken. Im folgenden Beispiel werden die Daten gefiltert, so dass nur Angestellte aufgelistet werden, die den Titel "Vertriebsmitarbeiterin" tragen und nach dem 1. Januar 1993 eingestellt wurden:

Dim datEinstellungsdatum As Date, strPosition As String
datEinstellungsdatum = #1.1.93#
strPosition = "Vertriebsmitarbeiterin"
Formulare!Personal.Filter = "[Einstellungsdatum] >= #" & _
    datEinstellungsdatum & "# AND [Position] = '" & strPosition & "'"
Formulare!Personal.FilterOn = True

Als Argument Kriterien erhalten Sie folgende Zeichenfolge:

"[Einstellungsdatum] >= #1.1.93# AND [Position] = 'Vertriebsmitarbeiterin'"

Tipp Wenn Sie Fehler im Argument Kriterien beseitigen möchten, unterteilen Sie den Ausdruck in kleinere Komponenten und testen diese einzeln im Direktfenster. Wenn alle Komponenten einwandfrei funktionieren, setzen Sie sie nacheinander wieder zusammen, bis der gesamte Ausdruck einwandfrei funktioniert.


 Angeben numerischer Kriterien

Angeben numerischer Kriterien

Wenn Sie numerische Kriterien für das Argument Kriterien angeben möchten, geben Sie einen numerischen Wert als Bestandteil des Zeichenfolgenausdrucks an.

Angenommen, Sie führen die Funktion Dlookup (DomWert) auf der Tabelle Personal aus, um den Nachnamen eines bestimmten Angestellten zu ermitteln, und Sie möchten einen Wert aus dem Feld Personal-Nr im Argument Kriterien der Funktion verwenden, dann können Sie das Argument Kriterien wie im folgenden Beispiel zusammenstellen. Im Beispiel wird der Nachname des Angestellten mit der Personal-Nr 7 zurückgegeben:

=DomWert("[Nachname]"; "Personal"; "[Personal-Nr] = 7")


 Angeben numerischer Kriterien aus einem Steuerelement in einem Formular

Angeben numerischer Kriterien aus einem Steuerelement in einem Formular

Wenn Sie das Argument Kriterien einer Aggregatfunktion für Domänen entsprechend den Wünschen eines Benutzers ändern möchten, können Sie angeben, dass die Kriterien einem bestimmten Steuerelement in einem Formular entnommen werden sollen. Sie könnten z. B. angeben, dass das Argument Kriterien einem Textfeld entnommen wird, das die Personal-Nr enthält.

Wenn Sie numerische Kriterien angeben möchten, die einem Steuerelement in einem Formular entnommen werden sollen, fügen Sie in das Argument Kriterien einen Ausdruck ein, der auf das Steuerelement verweist. Dieser Ausdruck sollte vom Zeichenfolgenausdruck getrennt stehen, damit er zuerst ausgewertet und dann mit dem Rest des Zeichenfolgenausdrucks verkettet wird, bevor die entsprechende Operation ausgeführt wird.

Angenommen, Sie führen die Funktion Dlookup(DomWert) auf einer Tabelle Personal aus, um den Nachnamen eines bestimmten Angestellten basierend auf der Personal-Nr zu finden. Im folgenden Beispiel werden die Kriterien durch den aktuellen Wert im Steuerelement Personal-Nr des Formulars Bestellungen festgelegt. Der auf das Steuerelement verweisende Ausdruck wird bei jedem Aufruf der Funktion ausgewertet. Wenn sich also der Wert des Steuerelements ändert, wird diese Änderung im Argument Kriterien berücksichtigt.

=DomWert("[Nachname]"; "Personal"; "[Personal-Nr] = " _
    & Formulare!Bestellungen![Personal-Nr])

Wenn der aktuelle Wert des Feldes Personal-Nr 7 lautet, wird das folgende Argument Kriterien an die Funktion DomWert übergeben:

"[Personal-Nr] = 7"

Tipp Wenn Sie Fehler im Argument Kriterien beseitigen möchten, unterteilen Sie den Ausdruck in kleinere Komponenten und testen diese einzeln im Direktfenster. Wenn alle Komponenten einwandfrei funktionieren, setzen Sie sie nacheinander wieder zusammen, bis der gesamte Ausdruck einwandfrei funktioniert.

Sie können auch eine Variable, die einen numerischen Wert darstellt, in das Argument Kriterien einfügen. Die Variable sollte getrennt vom Zeichenfolgenausdruck stehen, damit sie von Microsoft Access zuerst ausgewertet wird. Das Ergebnis wird dann mit dem Rest des Zeichenfolgenausdrucks verkettet.

Das folgende Beispiel zeigt, wie das Argument Kriterien zusammengestellt wird, wenn es eine Variable enthalten soll:

Dim intNum As Integer, Ergebnis As Variant
intNum = 7
Ergebnis = DomWert("[Nachname]", "Personal", _
    "[Personal-Nr] = " & intNum)


 Angeben textbezogener Kriterien

Angeben textbezogener Kriterien

Wenn Sie textbezogene Kriterien für das Argument Kriterien angeben möchten, geben Sie eine Textzeichenfolge als Bestandteil des Zeichenfolgenausdrucks an. Diese Textzeichenfolge muss in Hochkommas (') gesetzt werden.

Anmerkung Durch die Hochkommas wird Microsoft Access mitgeteilt, dass das Argument Kriterien eine Zeichenfolge innerhalb einer Zeichenfolge enthält.

Angenommen, Sie verwenden die ADO-Methode Find, um die Stelle des erstmaligen Auftretens eines Nachnamens in einer Tabelle Personal aufzufinden. Sie können dazu das Argument Kriterien wie im folgenden Beispiel zusammenstellen. Im Beispiel wird der aktuelle Datensatzzeiger auf den ersten Datensatz gesetzt, der in der Tabelle Personal den Nachnamen Buchanan enthält. Achten Sie darauf, dass das Zeichenfolgenliteral Buchanan in Hochkommas und die ganze Zeichenfolge, die das Argument Kriterien bildet, in Anführungszeichen (") gesetzt werden muss.

Dim rs As New ADODB.Connection

rs.open "Personal", CurrentProject.Connection,_
     dbOpenDynaset, adlockoptimistic)
rs.Find "[Nachname] = 'Buchanan'"


 Angeben textbezogener Kriterien aus einem Steuerelement in einem Formular

Angeben textbezogener Kriterien aus einem Steuerelement in einem Formular

Wenn Sie das Argument Kriterien einer Operation entsprechend einem Benutzerwunsch ändern möchten, können Sie angeben, dass die Kriterien einem bestimmten Steuerelement eines Formulars entnommen werden sollen. Sie könnten z. B. angeben, dass das Argument Kriterien einem Listenfeld entnommen wird, das die Nachnamen aller Angestellten in einer Tabelle Personal enthält.

Wenn Sie textbezogene Kriterien angeben möchten, die einem Steuerelement eines Formulars entnommen werden sollen, fügen Sie in das Argument Kriterien einen Ausdruck ein, der auf das Steuerelement des Formulars verweist. Dieser Ausdruck sollte vom Zeichenfolgenausdruck getrennt stehen, damit er zuerst ausgewertet und dann mit dem Rest des Zeichenfolgenausdrucks verkettet wird, bevor die entsprechende Operation ausgeführt wird.

Sie müssen nicht nur den gesamten Zeichenfolgenausdruck in Anführungszeichen ("), sondern auch die textbezogenen Kriterien innerhalb des Zeichenfolgenausdrucks in Hochkommas (') setzen. Die Hochkommas müssen sich in den Zeichenfolgen neben dem Ausdruck befinden, der auf das Steuerelement im Formular verweist.

Anmerkung Durch die Hochkommas wird Microsoft Access mitgeteilt, dass das Argument Kriterien eine Zeichenfolge innerhalb einer Zeichenfolge enthält.

Im folgenden Beispiel wird eine Suche in der Tabelle Personal durchgeführt, um die Region zurückzugeben, in der ein Angestellter wohnt, wobei der Nachname des Angestellten zugrunde gelegt wird. Der aktuelle Wert des Listenfeld-Steuerelements Nachname im Formular Personal bestimmt die Kriterien. Beachten Sie die Anordnung der Hochkommas.

=DomWert("[Region]"; "Personal"; "[Nachname] = '" _
    & Formulare!Personal!Nachname & "'")

Wenn der aktuelle Wert des Steuerelements King lautet, wird folgendes Argument Kriterien an die Funktion Dlookup (DomWert) übergeben, nachdem der Ausdruck ausgewertet und die Zeichenfolge verkettet wurde:

"[Nachname] = 'King'"

Beachten Sie, dass die gesamte Zeichenfolge, die das Argument Kriterien enthält, ebenfalls in Anführungszeichen stehen muss, nachdem die Zeichenfolge verkettet wurde.

Tipp Wenn Sie Fehler im Argument Kriterien beseitigen möchten, unterteilen Sie den Ausdruck in kleinere Komponenten und testen diese einzeln im Direktfenster. Wenn alle Komponenten einwandfrei funktionieren, setzen Sie sie nacheinander wieder zusammen, bis der gesamte Ausdruck einwandfrei funktioniert.

Sie können auch eine Variable, die eine textbezogene Zeichenfolge darstellt, in das Argument Kriterien einfügen. Die Variable sollte getrennt vom Zeichenfolgenausdruck stehen, damit sie zuerst ausgewertet wird. Das Ergebnis wird dann mit dem Rest des Zeichenfolgenausdrucks verkettet. Die textbezogene Zeichenfolge muss in Hochkommas oder in Anführungszeichen gesetzt sein.

Das folgende Beispiel zeigt, wie das Argument Kriterien zusammengestellt wird, wenn es eine Variable enthalten soll, die eine textbezogene Zeichenfolge darstellt:

Dim strNachname As String, varErg As Variant
strNachname = "King"
varErg = DomWert("[Personal-Nr]", "Personal", "[Nachname] = '" _
    & strNachname & "'")


Unterschiede bei Zeichenfolgenfunktionen

Sprachspezifische Informationen

The memory storage formats for text are different in Visual Basic for Microsoft Access 7.0 and Access Basic of previous versions of Microsoft Access. Text is stored in ANSI format within Access Basic code, and in Unicode format in Visual Basic.

The Unicode format is used in Visual Basic to match the format of text within OLE, which is indirectly related to Visual Basic.

For example, the text string "ABC [image] [image] [image] " would be stored in memory as shown below.

Storage format | Storage pattern | Description
Unicode | 41 00 42 00 43 00 42 30 44 30 46 30 | Each character is stored as 2 bytes.
ANSI | 41 42 43 82 A0 82 A2 82 A4 | ASCII characters are stored as 1 byte; Japanese characters are stored as 2 bytes.

Because of these differences in internal format, there are string processing functions that operate differently in Access Basic and Visual Basic. The functions that operate differently and their statements are as shown below.

Asc function, Chr function, InputB function, InStrB function, LeftB function, LenB function, RightB function, MidB function, and their corresponding statements.

Also, the ChrB function and AscB function have been added to Visual Basic.

In that these functions and statements both process text in byte units, they are the same in Access Basic and Visual Basic, but because their storage formats for text are different, they operate differently. For example, in LenB("A") would be 1 in Access Basic, but 2 in Visual Basic.

Programs created in previous versions of Microsoft Access that use the string processing functions that work in byte units must be changed in Visual Basic to a source code that recognizes Unicode. However, if only string processing functions that process character units, such as the Len function, Left function, and Right function, are used, there is no need to recognize them.

If programs created in a previous version of Microsoft Access are moved to Microsoft Access 7.0, consider the following points regarding string processing.

Asc Function and AscB Function

This program ran properly in previous versions of Access, but produces a run-time error in Visual Basic in Microsoft Access 7.0.

Print Asc(MidB("  ", 2,1))

This is because MidB(" [image] ", 2,1), an argument of the Asc function, does not correctly return data to Unicode text.

Use the following AscB function to make this program run in Microsoft Access 7.0:

Print AscB(MidB("  ", 2,1))

In this program, the value (&H30) of the second Unicode byte is returned.

Chr Function and ChrB Function

The Chr function in Microsoft Access 7.0 always returns 2-byte characters. In previous versions of Microsoft Access, Chr(&H41) and ChrB(&H41) were equal, but in Microsoft Access 7.0, Chr(&H41) and ChrB(&H41) + ChrB(0) are equal.

Also, in previous versions of Microsoft Access, " [image] " was expressed as ChrB(&H82) + ChrB(&HA0), but in Microsoft Access 7.0 it is expressed as ChrB(&H42) + ChrB(&H30).

Calling the Windows Application Programming Interface (API)

In several Windows API the byte length of a string has a special meaning. For example, the following program returns a folder set up in Windows. In Microsoft Access 7.0, LeftB(Buffer, ret) does not return the correct string. This is because, in spite of the fact that it shows the byte length of an ANSI string, the LeftB function processes Unicode strings. In this case, use the InStr function so that only the character string, without nulls, is returned.

Private Declare Function GetWindowsDirectory Lib "kernel32" _
    Alias "GetWindowsDirectoryA" (ByVal lpBuffer As String, _
    ByVal nSize As Long) As Long

Private Sub Command1_Click()
    Buffer$ = Space(255)
    ret = GetWindowsDirectory(Buffer$, 255)
    ' WinDir = LeftB(Buffer, ret)   '<--- Incorrect code"

    WinDir = Left(Buffer$, InStr(Buffer$, Chr(0)) - 1)
                                        '<--Correct code"
    Print WinDir
End Sub

Input Function and InputB Function

The Input function in Microsoft Access 7.0 converts the number of characters designated when the text is read from the file into a Unicode string and reads them as variables. The InputB function, on the other hand, assumes the data to be binary data and stores it as variables without converting it. If the InputB function is used when reading a file stored in a fixed length field, the fixed byte length data must be converted once it is read.

Open "Data.Dat" For Input As 1
dat1 = StrConv(InputB(10, 1), vbUnicode)
dat2 = StrConv(InputB(10, 1), vbUnicode)
dat3 = StrConv(InputB(10, 1), vbUnicode)

===DATA.DAT
123456789012345678901234567
Name      Address      Telephone

Processing ANSI string bytes in Microsoft Access 7.0

If it is necessary to process ANSI string bytes in Microsoft Access 7.0, use the StrConv function. You can convert text between ANSI and Unicode by setting the vbUnicode or vbFromUnicode constant. If you process bytes after temporarily converting a string to an ANSI string, and then reconvert it back to Unicode once the process is finished, you can use codes from previous version of Access relatively easily.

'                                                    ANSI
dat = StrConv(dat, vbFromUnicode)
.
.
.    '
.    '
.
.
'                                                     Unicode
dat = StrConv(dat, vbUnicode)

Sample Functions that perform operations that are compatible with byte processing functions of 16-bit versions

In Microsoft Access 7.0's Visual Basic, the internal processing of strings is performed using Unicode. Thus, the binary processing functions are different from those of Access Basic used in previous versions of Microsoft Access.

The ANSI function was created to preserve compatibility between the operations of Access Basic and Visual Basic.

Note Strings input and removed with these ANSI processing functions are always Unicode. After being converted temporarily to ANSI strings within the function, they are restored to Unicode once the process is finished.

The following cannot combine the first and second byte of a DBCS character to create a DBCS character.

AnsiMidB("  ",1,1) + AnsiMidB("  ",2,1)

These functions have been created to process strings in byte units. However, a different character cannot be created by the byte-unit processing. In this case, it would be expressed as follows:

StrArg = "  "
StrArg = StrConv(StrArg, vbFromUnicode)    ' ANSI
RetArg = MidB(StrArg,1,1) + MidB(StrArg,2,1)    '
    '
StrArg = StrConv(StrArg, vbUnicode)    '                Unicode
RetArg = StrConv(RetArg, vbUnicode)    '

Generally, if you convert a string to an ANSI character before processing, you should restore the converted string to a Unicode character after the process is finished.

A byte string process is always a function for processing a string. To process binary data, use a byte Array, not a string variable or a byte string processing function.

A string stored in a byte Array appears as follows:

       Array
Dim Var() As Byte
Var = "            "             ' Unicode
Var = StrConv("            ", vbFromUnicode)    ' ANSI

Function AnsiStrConv(StrArg, flag)
    nsiStrConv = StrConv(StrArg, flag)
End Function

' LenB               ANSI                               Unicode
Function AnsiLenB(ByVal StrArg As String) As Long
    AnsiLenB = LenB(AnsiStrConv(StrArg, vbFromUnicode))
End Function

' MidB                 ANSI                                 Unicode
'
Function AnsiMidB(ByVal StrArg As String, ByVal arg1 As Long, _
            Optional arg2) As String
    If IsMissing(arg2) Then
    AnsiMidB = AnsiStrConv(MidB(AnsiStrConv(StrArg, vbFromUnicode) _
            , arg1),vbUnicode)
    Else
    AnsiMidB = AnsiStrConv(MidB(AnsiStrConv(StrArg, vbFromUnicode) _
            , arg1, arg2), vbUnicode)
    End If
End Function

' LeftB                  ANSI                                 Unicode
Function AnsiLeftB(ByVal StrArg As String, ByVal arg1 As Long) As String
    AnsiLeftB = AnsiStrConv(LeftB(AnsiStrConv(StrArg, _
            vbFromUnicode), arg1), vbUnicode)
End Function

' RightB                 ANSI                                 Unicode
Function AnsiRightB(ByVal StrArg As String, ByVal arg1 As Long) As String
    AnsiRightB = AnsiStrConv(RightB(AnsiStrConv(StrArg, _
            vbFromUnicode), arg1), vbUnicode)
End Function

' InStrB    2                        Ansi             Ansi
Function AnsiInStrB(arg1, arg2, Optional arg3) As Integer
    If IsNumeric(arg1) Then
    pos = LenB(AnsiLeftB(arg2, arg1))
    AnsiInStrB = InStrB(arg1, AnsiStrConv(arg2, vbFromUnicode) _
            , AnsiStrConv(arg3, vbFromUnicode))
    Else
    AnsiInStrB = InStrB(AnsiStrConv(arg1, vbFromUnicode) _
            , AnsiStrConv(arg2, vbFromUnicode))
    End If
End Function

Using byte data type

In Microsoft Access 7.0 Byte data type is added as a new data type. If a string variable is used when processing binary data, text is converted between ANSI and Unicode, and binary data is changed. Thus, when dealing with binary data, use Byte data type variables.

Dim ByteData() As Byte
ByteData = "        "        ' Unicode
ByteData = StrConv("        ", vbFromUnicode)     'ANSI
ByteData = InputB(10, #1)    '
Debug.Print ByteData(5)        '


 Verwenden von Anführungszeichen in Zeichenfolgen

Verwenden von Anführungszeichen in Zeichenfolgen

In Situationen, in denen Sie Zeichenfolgen verketten müssen, sollten Sie unter Umständen eine Zeichenfolge oder Zeichenfolgenvariable in eine andere Zeichenfolge einbetten, z.B. in den folgenden Situationen:

  • Beim Angeben von Kriterien für Aggregatfunktionen für Domänen.

  • Beim Angeben von Kriterien für die Find-Methoden.

  • Beim Angeben von Kriterien der Filter- bzw. der ServerFilter-Eigenschaft eines Formulars.

  • Beim Erstellen von SQL-Zeichenfolgen.

In diesen Situationen muss Microsoft Access eine Zeichenfolge an die Microsoft Jet-Datenbank-Engine übergeben. Wenn Sie z.B. das Argument Kriterien für eine Aggregatfunktion für Domänen angeben, muss Microsoft Access alle Variablen auswerten, sie zu einer Zeichenfolge verketten und schließlich die ganze Zeichenfolge an die Jet-Datenbank-Engine übergeben.

Wenn Sie eine numerische Variable einbetten, wertet Microsoft Access die Variable aus und verkettet den Wert mit der Zeichenfolge. Handelt es sich bei der Variablen jedoch um eine Textzeichenfolge, dann enthält die sich ergebende Kriterienzeichenfolge eine Zeichenfolge innerhalb einer Zeichenfolge. Eine Zeichenfolge innerhalb einer Zeichenfolge muss durch Zeichenfolgen-Trennzeichen gekennzeichnet werden. Andernfalls kann die Jet-Datenbank-Engine nicht feststellen, welcher Teil der Zeichenfolge den Wert darstellt, den Sie verwenden möchten.

Die Zeichenfolgen-Trennzeichen sind eigentlich kein Bestandteil der Variablen, aber sie müssen in die Zeichenfolge für das Argument Kriterien eingebettet sein. Es gibt drei Möglichkeiten, um die Zeichenfolge für das Argument Kriterien zusammenzusetzen. Bei allen Möglichkeiten erhalten Sie eine Zeichenfolge für das Argument Kriterien, die wie eines der folgenden Beispiele aussieht.

"[Nachname] = 'Schmidt'"

- Oder -

"[Nachname] = ""Schmidt"""

Verwenden von Hochkommas

Sie sollten Hochkommas in der Zeichenfolge für Kriterien so verwenden, dass der Wert einer Variablen, die mit der Zeichenfolge verkettet wird, in die Hochkommas gesetzt wird. Wenn das Argument Kriterien z.B. die Zeichenfolgenvariable strName enthalten soll, können Sie das Argument Kriterien wie im folgenden Beispiel zusammensetzen:

"[Nachname] = '" & strName & "'"

Wenn die Variable strName ausgewertet und mit der Zeichenfolge Kriterien verkettet ist, sieht die Zeichenfolge Kriterien folgendermaßen aus:

"[Nachname] = 'Schmidt'"

Anmerkung Bei dieser Syntax sind keine Hochkommas im Wert der Variablen selbst zulässig. Enthält der Wert der Zeichenfolgenvariablen ein Hochkomma, dann gibt Microsoft Access einen Laufzeitfehler aus. Wenn Ihre Variable Werte mit Hochkommas darstellen kann, sollten Sie die weiter unten beschriebenen Syntaxvarianten verwenden.

Verwenden von Anführungszeichen

Sie sollten Anführungszeichen in der Zeichenfolge für das Argument Kriterien so verwenden, dass der Wert einer Variablen nach der Auswertung in Anführungszeichen gesetzt ist. Innerhalb einer Zeichenfolge müssen Sie zwei Paar Anführungszeichen verwenden, um ein Paar Anführungszeichen darzustellen. Sie könnten das Argument Kriterien wie im folgenden Beispiel zusammenstellen:

"[Nachname] = """ & strName & """"

Wenn die Variable strName ausgewertet und mit dem Argument Kriterien verkettet wird, wird jedes Paar Anführungszeichen durch ein Anführungszeichen ersetzt. Sie erhalten das folgende Argument Kriterien:

"[Nachname] = 'Schmidt'"

Diese Syntax erscheint vielleicht komplizierter als bei der Verwendung von Hochkommas, aber sie ermöglicht das Einbetten einer Zeichenfolge, die ein Hochkomma innerhalb der Zeichenfolge Kriterien enthält. Außerdem haben Sie die Möglichkeit, mehrere Zeichenfolgen in der eingebetteten Zeichenfolge zu verschachteln.

Verwenden einer Variablen, die Anführungszeichen darstellt

Sie können eine Zeichenfolgenvariable erstellen, die Anführungszeichen darstellt, und diese Variable zusammen mit dem Wert der Variablen mit der Zeichenfolge für Kriterien verketten. Die in ANSI verwendete Darstellung für Anführungszeichen ist Chr$(34). Sie könnten diesen Wert einer Zeichenfolgenvariablen strAnfZeich zuweisen, und Sie könnten dann das Argument Kriterien wie im folgenden Beispiel zusammensetzen:

"[Nachname] = " & strAnfZeich & strName & strAnfZeich

Wenn die Variablen ausgewertet und mit der Zeichenfolge Kriterien verkettet werden, erhalten Sie folgendes Argument Kriterien:

[Nachname] = "Schmidt"


 Einschränken von Daten auf eine Teilmenge von Datensätzen

Einschränken von Daten auf eine Teilmenge von Datensätzen

Bei der Arbeit mit Daten müssen Sie die Daten häufig auf eine bestimmte Gruppe von Datensätzen begrenzen. Sie können bei einigen Prozeduren Kriterien als Argument angeben, um festzulegen, welche Daten zurückgegeben werden. Geben Sie z.B. bei der Verwendung von Aggregatfunktionen für Domänen Kriterien an, um festzulegen, welche Daten zurückgegeben werden. Sie können auch Kriterien angeben, wenn Sie die Find-Methode eines Recordset-Objekts verwenden, die Filter- bzw. die ServerFilter-Eigenschaft eines Formulars einstellen oder eine SQL-Anweisung konstruieren. Obwohl diese Operationen unterschiedliche Syntax verwenden, ähnelt sich die Bildung des Kriterierenausdrucks.

Mit der Aggregatfunktion für Domänen DSum (DSum) können Sie z.B. die Gesamtsumme aller Frachtkosten in der Tabelle Bestellungen suchen. Sie können ein berechnetes Steuerelement erstellen, indem Sie den folgenden Ausdruck in die Eigenschaft ControlSource (Steuerelementinhalt) eingeben:

=DomSumme("[Frachtkosten]"; "Bestellungen")

Wenn Sie das Argument Kriterien angeben, wird die Funktion DomSumme auf einer Teilmenge von Domäne ausgeführt. Sie könnten z.B. die Gesamtsumme aller Frachtkosten in der Tabelle Bestellungen für die Bestellungen suchen, die in den US-Bundesstaat Kalifornien geliefert wurden:

=DomSumme("[Frachtkosten]"; "Bestellungen"; "[Region] = 'CA'")

Wenn Sie das Argument Kriterien für eine Domänenfunktion angeben, wertet Microsoft Access zunächst alle Ausdrücke im Argument aus und erstellt daraus einen Zeichenfolgenausdruck. Anschließend wird der Zeichenfolgenausdruck an die Domänenfunktion übergeben. Der Zeichenfolgenausdruck entspricht einer SQL WHERE-Klausel ohne das Wort WHERE.

Sie können numerische, textbezogene oder datums-/zeitbezogene Kriterien angeben. Welches Kriterium Sie auch angeben, das Argument Kriterien wird immer in eine Zeichenfolge umgewandelt, bevor es an die Aggregatfunktion für Domänen übergeben wird. Nachdem alle Ausdrücke ausgewertet wurden, müssen Sie daher sicherstellen, dass alle Bestandteile des Arguments zu einer einzigen Zeichenfolge verkettet werden, die in Anführungszeichen (") gesetzt wird.

Achten Sie beim Zusammenstellen von Kriterien darauf, dass die Zeichenfolge korrekt verkettet wird.

In der folgenden Liste werden die verschiedenen Möglichkeiten zum Angeben von Kriterien für eine Domänenfunktion aufgeführt:

Angeben numerischer Kriterien

Angeben textbezogener Kriterien

Angeben datums- und zeitbezogener Kriterien

Angeben numerischer Kriterien aus einem Steuerelement in einem Formular

Angeben textbezogener Kriterien aus einem Steuerelement in einem Formular

Angeben datums- und zeitbezogener Kriterien aus einem Steuerelement in einem Formular

Angeben mehrerer Felder im Argument "Kriterien"


 Berechnen von Feldern in Aggregatfunktionen für Domänen

Berechnen von Feldern in Aggregatfunktionen für Domänen

Sie können das Zeichenfolgeargument (das Argument Ausdr) in einer Aggregatfunktion für Domänen verwenden, um eine Berechnung an Werten in einem Feld durchzuführen. Beispielsweise können Sie einen Prozentwert (etwa einen Preisaufschlag oder die Umsatzsteuer) berechnen, indem Sie den Feldwert durch eine Zahl teilen.

In der folgenden Tabelle finden Sie Beispiele für Berechnungen zu Feldern in einer Tabelle Bestellungen und einer Tabelle Bestelldetails.

Berechnung | Beispiel
Addieren einer Zahl zu einem Feld | "[Frachtkosten] + 5"
Subtrahieren einer Zahl von einem Feld | "[Frachtkosten] - 5"
Multiplizieren eines Feldes mit einer Zahl | "[Frachtkosten] * 2"
Dividieren eines Feldes durch eine Zahl | "[Frachtkosten] / 2"
Addieren eines Feldes zu einem anderen | "[EinheitenAufLager] + [EinheitenBestellt]"
Subtrahieren eines Feldes von einem anderen | "[Mindestbestand] - [EinheitenAufLager]"

Aggregatfunktionen für Domänen werden Sie höchstwahrscheinlich in Makros oder Modulen, in berechneten Steuerelementen von Formularen oder Berichten oder in Kriterienausdrücken in Abfragen verwenden.

Zum Beispiel können Sie in einer Tabelle Bestelldetails den durchschnittlichen Skontobetrag für alle Bestellungen berechnen. Dazu multiplizieren Sie zunächst das Feld Einzelpreis mit dem Feld Skonto, um den Skontobetrag für jede Bestellung zu ermitteln, und berechnen Sie anschließend den Durchschnitt. Geben Sie das folgende Beispiel in eine Prozedur in einem Modul ein.

Dim dblX As Double
dblX = DAvg("[Einzelpreis] * [Skonto]", "[Bestelldetails]")


 Erstellen von SQL-Anweisungen, die Variablen und Steuerelemente enthalten

Erstellen von SQL-Anweisungen, die Variablen und Steuerelemente enthalten

Beim Arbeiten mit Datenzugriffsobjekten (DAO) kann es notwendig sein, eine SQL-Anweisung über Code zu erstellen. Wenn Sie z.B. ein neues QueryDef-Objekt erstellen, stellen Sie seine SQL-Eigenschaft auf eine gültige SQL-Zeichenfolge ein. Auch beim Erstellen eines Recordset-Objekts ist häufig eine SQL-Anweisung erforderlich.

Am einfachsten erstellen Sie eine SQL-Anweisung, indem Sie eine Abfrage im Abfrageentwurfsbereich erstellen, zur SQL-Ansicht umschalten und die entsprechende SQL-Anweisung kopieren und in Ihren Code einfügen.

Häufig basiert eine Abfrage auf Werten, die der Benutzer bereitstellt oder die sich in verschiedenen Situationen ändern. Ist dies der Fall, schließen Sie Variablen oder Steuerelementwerte in Ihre Abfrage ein. Die Microsoft Jet-Datenbank-Engine verarbeitet alle SQL-Anweisungen, jedoch keine Variablen oder Steuerelemente. Erstellen Sie deshalb Ihre SQL-Anweisung so, dass Microsoft Access diese Werte zuerst bestimmen und dann mit der SQL-Anweisung verknüpfen kann, die der Jet-Datenbank-Engine übergeben wird.

Das folgende Beispiel zeigt, wie ein QueryDef-Objekt mit einer einfachen SQL-Anweisung erstellt wird. Diese Abfrage gibt alle Bestellungen aus einer Tabelle Bestellungen zurück, die nach dem 31.03.1996 getätigt wurden.

Dim dbs As Database, qdf As QueryDef, strSQL As String
Set dbs = CurrentDb
strSQL = "SELECT * FROM Bestellungen WHERE _ Bestelldatum >#3-31-96#;"
Set qdf = dbs.CreateQueryDef("ZweitesQuartal", strSQL)

Das nächste Beispiel erstellt das gleiche QueryDef-Objekt mit Hilfe eines in einer Variablen gespeicherten Wertes. Beachten Sie, dass die #-Zeichen, die den Datumswert kennzeichnen, in der Zeichenfolge enthalten sind, damit sie mit dem Datumswert verknüpft werden.

Dim dbs As Database, qdf As QueryDef, strSQL As String
Dim datStart As Date
datStart = #3-31-96#
Set dbs = CurrentDb
strSQL = "SELECT * FROM Bestellungen WHERE " & _
 "Bestelldatum > #" & datStart & "#;"
Set qdf = dbs.CreateQueryDef("ZweitesQuartal", strSQL)

Das nächste Beispiel erstellt ein QueryDef-Objekt mit Hilfe eines Wertes in dem Steuerelement Bestelldatum in dem Formular Bestellungen. Achten Sie darauf, dass Sie den ausführlichen Verweis auf das Steuerelement bereitstellen und die #-Zeichen angeben, die das Datum in der Zeichenfolge kennzeichnen.

Dim dbs As Database, qdf As QueryDef, strSQL As String
Set dbs = CurrentDb
strSQL = "SELECT * FROM Bestellungen WHERE " & _
    "Bestelldatum > #" & _
 Formulare!Bestellungen!Bestelldatum & "#;"
Set qdf = dbs.CreateQueryDef("ZweitesQuartal", strSQL)


 Verwenden von internationalen Datumsformaten in SQL-Anweisungen

Verwenden von internationalen Datumsformaten in SQL-Anweisungen

Sie müssen in Visual Basic in SQL-Anweisungen Datumsformate verwenden, die der Ländereinstellung English (USA) entsprechen. Im Abfrageentwurfsbereich können Sie dagegen auch internationale Datumsformate verwenden.


 Fehlerbehebung

Fehlerbehebung

Mit Hilfe der Anweisung On Error GoTo können Sie Fehler auffangen und die Ausführung an die Stelle einer Prozedur umleiten, an der sich die Anweisungen für die Fehlerbehandlung befinden. Die folgende Anweisung leitet die Ausführung z.B. zur Sprungmarke ErrorHandler: um:

On Error GoTo ErrorHandler

Bei der Vergabe der Namen für die Sprungmarken der Fehlerbehandlungsroutinen einer Prozedur achten Sie auf Folgendes: Der Name einer Sprungmarke muss eindeutig sein und darf nicht zu einem Konflikt mit einem anderen Element der Prozedur führen; und hinter dem jeweiligen Namen muss ein Doppelpunkt stehen. Innerhalb einer Prozedur setzen Sie die Anweisung Exit Sub bzw. Exit Function vor die erste Sprungmarke der Fehlerbehandlungsroutinen, damit der Fehlerbehandlungscode nicht auch dann ausgeführt wird, wenn kein Fehler auftritt.

Sub VerursachtEinenFehler()
    ' Bei Auftreten eines Fehlers die Ausführung umleiten.
    On Error GoTo ErrorHandler
    ' Provozieren des Fehlers "Division durch 0".
    Err.Raise 11
    Exit Sub

ErrorHandler:
    ' Fehlerinformationen anzeigen.
    MsgBox "Fehler " & Err.Number & ": " & Err.Description
    ' Die Ausführung mit der Anweisung fortsetzen, die unmittelbar
    ' auf die fehlerverursachende Anweisung folgt.
    Resume Next
End Sub

Die Methode Raise des Objekts Err provoziert den angegebenen Fehler. Die Eigenschaft Number des Objekts Err gibt die Nummer zurück, die dem zuletzt aufgetretenen Laufzeitfehler zugewiesen ist; die Eigenschaft Description gibt die Meldung zurück, die diesem Fehler zugewiesen ist.

Anmerkungen

  • In Microsoft Access, Version 1.x und 2.0, haben Sie eventuell die Anweisung Error verwendet, um einen Fehler zu provozieren, die Funktion Err, um die Fehlernummer zurückzugeben, und die Funktion Error, um die Beschreibung des Fehlers zurückzugeben. Alter Fehlerbehandlungscode, in dem die Anweisung Error und die Funktion Error verwendet werden, funktioniert auch weiterhin einwandfrei. Wenn Sie neuen Code schreiben, sollten Sie allerdings das Objekt Err sowie dessen Eigenschaften und Methoden verwenden.

  • Microsoft Access, Version 1.x und 2.0, hat für alle im Zusammenhang mit OLE-Automatisierung (früher als "OLE-Automatisierung" bezeichnet) auftretenden Fehler nur einen Fehler zurückgegeben. Jetzt gibt eine Anwendung, die als COM-Komponente dient und einen Fehler entdeckt hat, dieselben Fehlerinformationen zurück, die Sie auch erhalten, wenn Sie direkt mit dieser Anwendung arbeiten. Schreiben Sie eventuell alten Fehlerbehandlungscode um, damit die neuen OLE-Automatisierungsfehler korrekt verwaltet werden.

  • Wenn Sie die Beschreibung zurückgeben möchten, die einem Microsoft Access-Fehler oder einem Fehler eines Datenzugriffsobjekts (DAO) zugewiesen ist, der zugehörige Fehler in Ihrem Code aber nicht auftritt, können Sie die Methode AccessError verwenden, um die Beschreibung zurückzugeben.

Weitere Informationen, wie Fehler aufgefangen und Anweisungen zur Fehlerbehandlung geschrieben werden, finden Sie im OPG9TBD in Kapitel 9, "Behandeln von Laufzeitfehlern". Um zu erfahren, wie Sie das OPG9TBD erhalten können, klicken Sie auf [image] .


 Elemente der Laufzeitfehlerbehandlung

Elemente der Laufzeitfehlerbehandlung

Fehler und Fehlerbehandlung

Wenn Sie eine Anwendung programmieren, berücksichtigen Sie, was beim Auftreten eines Fehlers geschieht. In Ihrer Anwendung kann aus einem der folgenden beiden Gründen ein Fehler auftreten. Erstens: Eine Bedingung beim Ausführen der Anwendung bewirkt, dass ansonsten gültiger Code fehlschlägt. Versucht Ihr Code z.B., eine Tabelle zu öffnen, die der Benutzer gelöscht hat, tritt ein Fehler auf. Zweitens: Ihr Code enthält ggf. unzutreffende Logik, wodurch nicht das erwünschte Ziel erreicht wird. Es tritt z.B. ein Fehler auf, wenn Ihr Code versucht, einen Wert durch Null zu teilen.

Wenn Sie keine Fehlerbehandlung implementiert haben, unterbricht Visual Basic die Ausführung und zeigt eine Fehlermeldung an, wenn in Ihrem Code ein Fehler auftritt. Der Benutzer Ihrer Anwendung ist in diesem Fall möglicherweise verunsichert und enttäuscht. Sie können viele Probleme vermeiden, indem Sie in Ihrem Code gründliche Fehlerbehandlungsroutinen vorsehen, die alle potenziellen Fehler behandeln.

Wenn Sie Fehlerbehandlung zu einer Prozedur hinzufügen, berücksichtigen Sie, wie die Prozedur die Ausführung beim Auftreten eines Fehlers weiterleitet. Der erste Schritt bei der Übergabe der Ausführung an eine Fehlerbehandlungsroutine besteht darin, eine Fehlerbehandlungsroutine zu aktivieren. Hierzu wird eine Form der Anweisung On Error in die Prozedur aufgenommen. Die Anweisung On Error leitet die Ausführung im Falle eines Fehlers. Existiert keine Anweisung On Error, hält Visual Basic die Ausführung einfach an und zeigt beim Auftreten eines Fehler eine Fehlermeldung an.

Tritt ein Fehler in einer Prozedur mit einer aktivierten Fehlerbehandlunsroutine auf, zeigt Visual Basic die übliche Fehlermeldung nicht an. Statt dessen wird die Ausführung an eine Fehlerbehandlungsroutine übergeben, sofern eine solche existiert. Wird die Ausführung an eine aktivierte Fehlerbehandlungsroutine übergeben, wird diese Fehlerbehandlungsroutine aktiv. Innerhalb der aktiven Fehlerbehandlungsroutine können Sie bestimmen, welcher Fehlertyp aufgetreten ist, und diesen in der gewünschten Weise ansprechen. Microsoft Access stellt drei Objekte bereit, die Informationen über aufgetretene Fehler enthalten: das ADO-Objekt Error, das Visual Basic-Objekt Err und das Datenzugriffsobjekt Error.

Weitere Informationen zur Behandlung von Fehlern finden Sie im Microsoft Access 2000/Visual Basic Programmierhandbuch, Kapitel 8, "Fehlerbehandlung und Debugging".

Weiterleiten der Ausführung beim Auftreten eines Fehlers

Eine Fehlerbehandlungsroutine gibt an, was innerhalb einer Prozedur geschieht, wenn ein Fehler auftritt. Sie möchten z.B., dass die Prozedur beendet wird, wenn ein bestimmter Fehler auftritt, oder Sie möchten die Bedingung korrigieren, die den Fehler ausgelöst hat, und die Ausführung wieder aufnehmen. Die Anweisungen On Error und Resume bestimmen, wie die Ausführung im Falle eines Fehlers fortgeführt wird.

Die On Error-Anweisung

Die Anweisung On Error aktiviert oder deaktiviert eine Fehlerbehandlungsroutine. Wird eine Fehlerbehandlungsroutine aktiviert, wird die Ausführung beim Auftreten eines Fehlers an die Fehlerbehandlungsroutine übergeben.

Es werden drei Formen von On Error-Anweisungen unterschieden: On Error GoTo Marke, On Error GoTo 0 und On Error Resume Next. Die Anweisung On Error GoTo Marke aktiviert eine Fehlerbehandlungsroutine, die mit der Zeile beginnt, in der sich die Anweisung befindet. Aktivieren Sie daher die Fehlerbehandlungsroutine vor der ersten Zeile, in der ein Fehler auftreten kann. Ist die Fehlerbehandlungsroutine aktiv und tritt ein Fehler auf, wird die Ausführung an die Zeile übergeben, die durch das Argument Marke festgelegt ist.

Die im Argument Marke angegebene Zeile sollte den Beginn der Fehlerbehandlungsroutine enthalten. Die folgende Prozedur gibt z.B. an, dass beim Auftreten eines Fehlers die Fehlerbehandlung an die Zeile mit der Marke Error_FehlerKönnteAuftreten übergeben wird:

Function FehlerKönnteAuftreten()
    ' Fehlerbehandlungsroutine aktivieren.
    On Error GoTo Error_FehlerKönnteAuftreten
    .            ' Code einfügen, der einen Fehler auslösen könnte.
    .
    .

Error_FehlerKönnteAuftreten:
                 ' Code zur Behandlung des Fehlers einfügen.
    .
    .
End Function

Die Anweisung On Error GoTo 0 deaktiviert die Fehlerbehandlungsroutine innerhalb einer Prozedur. Sie gibt die Zeile 0 nicht als Start des Fehlerbehandlungscode an, selbst wenn die Prozedur eine Zeile mit der Nummer 0 enthält. Enthält Ihr Code keine Anweisung On Error GoTo 0, wird die Fehlerbehandlungsroutine automatisch deaktiviert, wenn die Prozedur vollständig ausgeführt wurde. Die Anweisung On Error GoTo 0 setzt die Eigenschaften des Objekts Err zurück und hat somit dieselbe Wirkung wie die Methode Clear des Objekts Err.

Die Anweisung On Error Resume Next ignoriert die Zeile, die einen Fehler verursacht hat, und übergibt die Ausführung an die sich daran anschließende Zeile. Die Ausführung wird dabei nicht unterbrochen. Sie können mit Hilfe der Anweisung On Error Resume Next die Eigenschaften des Objekts Err unmittelbar im Anschluss an die Zeile überprüfen, in der Sie einen Fehler erwarten, und den Fehler dann innerhalb der Prozedur statt in einer Fehlerbehandlungsroutine behandeln.

Die Resume-Anweisung

Die Anweisung Resume führt die Ausführung aus einer Fehlerbehandlungsroutine heraus zurück zum Kern der Prozedur. Sie können eine Anweisung Resume in eine Fehlerbehandlungsroutine setzen, wenn Sie möchten, dass die Ausführung an einem bestimmten Punkt der Prozedur fortgeführt wird. Eine Anweisung Resume ist jedoch nicht notwendig, Sie können die Prozedur nach der Fehlerbehandlungsroutine auch beenden.

Es werden drei Formen der Anweisung Resume unterschieden. Die Anweisung Resume- oder Resume 0 setzt die Ausführung in der Zeile fort, in der der Fehler aufgetreten ist. Die Anweisung Resume Next setzt die Ausführung in der sich unmittelbar anschließenden Zeile fort. Die Anweisung Resume Marke setzt die Ausführung in der durch das Argument Marke angegebenen Zeile fort. Das Argument Marke muss entweder eine Zeilenmarke oder eine Zeilennummer festlegen.

Üblicherweise verwenden Sie die Anweisung Resume oder Resume 0, wenn der Benutzer eine Korrektur vornehmen muss. Wenn Sie den Benutzer z.B. auffordern, den Namen einer zu öffnenden Tabelle einzugeben, und der dieser den Namen einer nicht existierenden Tabelle angibt, können Sie ihn erneut auffordern und die Ausführung mit der Anweisung fortsetzen, die den Fehler verursachte.

Sie verwenden die Anweisung Resume Next, wenn Ihr Code den Fehler innerhalb einer Fehlerbehandlungsroutine korrigiert und Sie die Ausführung fortsetzen möchten, ohne die Zeile, die den Fehler verursachte, erneut auszuführen. Sie verwenden die Anweisung Resume Marke, wenn Sie die Ausführung an einem anderen Punkt der Prozedur fortführen möchten, der durch das Argument Marke festgelegt ist. Vielleicht möchten Sie die Ausführung an einer Exit-Routine wiederaufnehmen, wie im folgenden Abschnitt beschrieben.

Verlassen einer Prozedur

Wenn Sie in eine Prozedur eine Fehlerbehandlungsroutine aufnehmen, sehen Sie auch eine Exit-Routine vor, so dass die Fehlerbehandlungsroutine nur beim Auftreten eines Fehlers ausgeführt wird. Sie können eine Exit-Routine mit einer Zeilenmarke auf dieselbe Weise festlegen wie eine Fehlerbehandlungsroutine.

Sie können dem Beispiel im vorangehenden Abschnitt z.B. eine Exit-Routine hinzufügen. Tritt kein Fehler auf, wird die Exit-Routine im Anschluss an den Kern der Prozedur ausgeführt. Beim Auftreten eines Fehlers wird die Ausführung an die Exit-Routine übergeben, nachdem der Code in der Fehlerbehandlungsroutine ausgeführt wurde. Die Exit-Routine enthält eine Anweisung Exit.

Function FehlerKönnteAuftreten()
    ' Fehlerbehandlungsroutine aktivieren.
    On Error GoTo Error_FehlerKönnteAuftreten
    .            ' Code einfügen, der einen Fehler auslösen könnte.
    .
    .

Exit_FehlerKönnteAuftreten:
    Exit Function

Error_FehlerKönnteAuftreten:
    .            ' Code zur Behandlung des Fehlers einfügen.
    .
    .
    ' Ausführung über Exit-Routine zum Verlassen der Funktion wiederaufnehmen.
    Resume Exit_FehlerKönnteAuftreten
End Function

Behandlung von Fehlern in verschachtelten Prozeduren

Tritt ein Fehler in einer verschachtelten Prozedur auf, die über keine aktivierte Fehlerbehandlungsroutine verfügt, durchsucht Visual Basic die Aufrufliste rückwärts nach einer aktivierten Fehlerbehandlungsroutine in einer anderen Prozedur, statt die Ausführung einfach anzuhalten. Dadurch ist Ihr Code in der Lage, den Fehler innerhalb einer anderen Prozedur zu beheben. Angenommen, Prozedur A ruft Prozedur B auf, und Prozedur B ruft Prozedur C auf. Wenn nun in Prozedur C ein Fehler auftritt und keine Fehlerbehandlungsroutine aktiviert ist, überprüft Visual Basic zunächst Prozedur B und dann Prozedur A nach einer aktivierten Fehlerbehandlungsroutine. Existiert eine solche, wird die Ausführung an diese übergeben. Ist dies nicht der Fall, wird die Ausführung unterbrochen und eine Fehlermeldung angezeigt.

Visual Basic durchsucht die Aufrufliste auch rückwärts nach einer aktivierten Fehlerbehandlungsroutine, wenn innerhalb einer aktiven Fehlerbehandlungsroutine ein Fehler auftritt. Sie können erzwingen, dass Visual Basic die Aufrufliste rückwärts durchsucht, indem Sie innerhalb einer aktiven Fehlerbehandlungsroutine mit der Methode Raise des Objekts Err einen Fehler neu erzeugen. Dies bietet sich zur Behandlung von Fehlern an, die Sie innerhalb einer Fehlerbehandlungsroutine nicht erwarten. Tritt ein unvorhergesehener Fehler auf und Sie behandeln diesen innerhalb der Fehlerbehandlungsroutine, gibt die Ausführung die Aufrufliste zurück, bis eine andere Fehlerbehandlungsroutine gefunden wird, die zur Behandlung des Fehlers eingerichtet werden kann.

Angenommen, Prozedur C verfügt über eine aktivierte Fehlerbehandlungsroutine, die jedoch den aufgetretenen Fehler nicht behebt. Nachdem die Fehlerbehandlungsroutine alle Fehler überprüft hat, die Sie erwartet haben, kann sie den ursprünglichen Fehler neu erzeugen. Die Ausführung gibt dann die Aufrufliste zu der Fehlerbehandlungsroutine in Prozedur B zurück, sofern eine solche existiert, und bietet dieser Fehlerbehandlungsroutine die Möglichkeit, den Fehler zu behandeln. Existiert in Prozedur B keine Fehlerbehandlungsroutine, oder behebt sie den Fehler nicht und erzeugt ihn neu, wird die Ausführung an die Fehlerbehandlungsroutine in Prozedur A übergeben, sofern diese existiert.

Nachfolgend ein weiteres Beispiel für dieses Konzept: Angenommen, Sie verfügen über eine verschachtelte Prozedur, die eine Fehlerbehandlungsroutine für eine fehlende Typübereinstimmung enthält und Sie haben diesen Fehler erwartet. An einer bestimmten Stelle in Prozedur C tritt der Fehler einer Division durch Null auf, den Sie nicht erwartet hatten. Wenn Sie eine Anweisung zur erneuten Erzeugung des ursprünglichen Fehlers vorgesehen haben, gibt die Ausführung die Aufrufliste bis zu einer anderen aktivierten Fehlerbehandlungsroutine zurück, falls eine solche existiert. Haben Sie in einer anderen Prozedur in der Aufrufliste einen Fehler der Division durch Null behoben, wird dieser Fehler behoben. Erzeugt Ihr Code den Fehler nicht neu, wird die Prozedur weiter ausgeführt, ohne den Divisionsfehler zu korrigieren. Dies kann wiederum andere Fehler innerhalb der Gruppe verschachtelter Prozeduren herbeiführen.

Zusammenfassend durchsucht Visual Basic die Aufrufliste in den folgenden Fällen rückwärts nach einer aktivierten Fehlerbehandlungsroutine:

  • Wenn in einer Prozedur, die keine aktivierte Fehlerbehandlungsroutine enthält, ein Fehler auftritt.

  • Wenn innerhalb einer aktivierten Fehlerbehandlungsroutine ein Fehler auftritt. Wenn Sie zum Neuerzeugen eines Fehlers die Methode Raise des Objekts Err verwenden, können Sie erzwingen, dass Visual Basic die Aufrufliste rückwärts nach einer aktivierten Fehlerbehandlungsroutine durchläuft.

Anfordern von Informationen zu einem Fehler

Nachdem die Ausführung an die Fehlerbehandlungsroutine übergeben wurde, muss Ihr Code bestimmen, welcher Fehler aufgetreten ist, und ihn adressieren. Visual Basic und Microsoft Access stellen mehrere Sprachelemente bereit, mit deren Hilfe Sie Informationen zu einem bestimmten Fehler anfordern können. Jedes ist jeweils für einen anderen Fehlertyp geeignet. Da Fehler in verschiedenen Teilen Ihrer Anwendung auftreten können, bestimmen Sie anhand der jeweils erwarteten Fehler, welches Element Sie in Ihrem Code verwenden.

Zur Fehlerbehandlung stehen die folgenden Sprachelemente zur Verfügung:

  • Das Objekt Err.

  • Das ADO-Objekt Error und die Errors-Auflistung.

  • Das DAO-Objekt Error und die Errors-Auflistung.

  • Die Methode AccessError.

  • Das Ereignis Error.

Das Err-Objekt

Das Objekt Err wird von Visual Basic bereitgestellt. Wenn ein Visual Basic-Fehler auftritt, werden Informationen über diesen Fehler im Objekt Err gespeichert. Das Objekt Err wartet Informationen zu jeweils nur einem Fehler. Tritt ein neuer Fehler auf, wird das Objekt Err dahingehend aktualisiert, dass es stattdessen Informationen zu diesem Fehler enthält.

Um Informationen zu einem bestimmten Fehler zu erhalten, können Sie die Eigenschaften und Methoden des Objekts Err verwenden. Die Eigenschaft Number ist die Standardeigenschaft des Objekts Err; sie gibt die Kennnummer des aufgetretenen Fehlers zurück. Die Eigenschaft Description des Objekts Err gibt die zu einem Visual Basic-Fehler gehörende Beschreibungszeichenfolge zurück. Die Methode Clear löscht die aktuellen Fehlerinformationen aus dem Objekt Err. Die Methode Raise erzeugt einen spezifischen Fehler neu und liefert den Eigenschaften des Objekts Err die Informationen zu diesem Fehler.

Das folgende Beispiel zeigt, wie Sie das Objekt Err in einer Prozedur verwenden können, die eine fehlende Typübereinstimmung auslösen kann:

Function FehlerKönnteAuftreten()
    ' Konstante zur Darstellung des potenziellen Fehlers deklarieren.
    Const conFehlendeTypübereinstimmung As Integer = 13

    On Error GoTo Error_FehlerKönnteAuftreten
        .            ' Code einfügen, der einen Fehler auslösen könnte.
        .
        .

Exit_FehlerKönnteAuftreten:
    Exit Function

Error_FehlerKönnteAuftreten:
    ' Eigenschaften des Err-Objekts überprüfen.
    If Err = conFehlendeTypübereinstimmung Then
        .            ' Code zur Fehlerbehandlung einfügen.
        .
        .
    Else
        ' Ursprünglichen Fehler erneut erzeugen.
        Dim intFehlerNr As Integer
        intFehlerNr = Err
        Err.Clear
        Err.Raise intFehlerNr
    End If
    ' Ausführung über Exit-Routine zum Verlassen der Funktion wieder aufnehmen.
    Resume Exit_FehlerKönnteAuftreten
End Function

Beachten Sie, dass im oben stehenden Beispiel die Methode Raise zum Neuerzeugen des ursprünglichen Fehlers verwendet wird. Tritt ein anderer Fehler als eine fehlende Typübereinstimmung auf, wird die Ausführung an eine andere, innerhalb der Aufrufliste zurückliegende aktivierte Fehlerbehandlungsroutine übergeben, sofern eine solche existiert.

Das Objekt Err liefert Ihnen alle Informationen, die Sie zu Visual Basic-Fehlern benötigen. Es liefert jedoch keine vollständigen Informationen zu Microsoft Access-Fehlern oder Fehlern der Microsoft Jet-Datenbank-Engine. Microsoft Access und Datenzugriffsobjekte (DAO, Data Access Objects) stellen weitere Sprachelemente bereit, die Sie im Umgang mit solchen Fehlern unterstützen.

Das Error-Objekt und die Errors-Auflistung

Das Error-Objekt und die Errors-Auflistung werden durch ADO und DAO zur Verfügung gestellt. Das Error-Objekt stellt einen ADO- oder DAO-Fehler dar. Eine einzige ADO- oder DAO-Operation kann mehrere Fehler verursachen, insbesondere, wenn Sie DAO-ODBC-Operationen ausführen. Jedem Fehler, der während einer bestimmten Datenzugriffsoperation auftritt, ist ein Error-Objekt zugeordnet. Alle einer bestimmten ADO- oder DAO-Operation zugeordneten Error-Objekte sind in der Errors-Auflistung gespeichert, wobei der Fehler der niedrigsten Ebene das erste Objekt in der Auflistung und der Fehler der höchsten Ebene das letzte Objekt in der Auflistung darstellt.

Tritt ein ADO- oder DAO-Fehler auf, enthält das Visual Basic-Objekt Err die Fehlernummer für das erste Objekt in der Errors-Auflistung. Um zu bestimmen, ob weitere ADO- oder DAO-Fehler aufgetreten sind, überprüfen Sie die Errors-Auflistung. Die Werte der ADO-Eigenschaft Number bzw. der DAO-Eigenschaft Number sowie der ADO-Eigenschaft Description bzw. der DAO-Eigenschaft Description des ersten Error-Objekts in der Errors-Auflistung sollten mit den Werten der Number- und der Description-Eigenschaft des Visual Basic-Objekts Err übereinstimmen.

Die AccessError-Methode

Mit Hilfe der Raise-Methode des Err-Objekts können Sie einen Visual Basic-Fehler generieren, der nicht wirklich aufgetreten ist, und die zu diesem Fehler gehörende Beschreibungszeichenfolge festlegen. Sie können mit der Raise-Methode jedoch keinen Microsoft Access-, ADO- oder DAO-Fehler erzeugen. Um die Beschreibungszeichenfolge zu einem nicht wirklich aufgetretenen Microsoft Access-, ADO- oder DAO-Fehler zu bestimmen, verwenden Sie die AccessError-Methode.

Das Error-Ereignis

Mit Hilfe des Ereignisses Error können Sie Fehler auffangen, die in einem Microsoft Access-Formular oder -Bericht auftreten. Versucht ein Benutzer z.B. Text in ein Feld des Datentyps Datum/Uhrzeit einzugeben, tritt das Ereignis Error ein. Wenn Sie einem Formular Personal eine Ereignisprozedur Error hinzufügen und dann versuchen, einen Textwert in das Feld Einstellungsdatum einzugeben, wird die Ereignisprozedur Error ausgeführt.

Die Ereignisprozedur Error nimmt das ganzzahlige Argument DataErr an. Wird eine Ereignisprozedur Error ausgeführt, enthält das Argument DataErr die Nummer des aufgetretenen Microsoft Access-Fehlers. Die einzige Möglichkeit, die Fehlernummer des aufgetretenen Fehlers zu bestimmen, besteht darin, den Wert des Arguments DataErr zu überprüfen. Das Objekt Err enthält keine Fehlerinformationen, nachdem das Ereignis Error aufgetreten ist. Sie können den Wert des Arguments DataErr in Verbindung mit der Funktion AccessError verwenden, um die Fehlernummer und die Beschreibungszeichenfolge zu bestimmen.

Anmerkung Die Anweisung Error und die Funktion Error sind nur aus Gründen der Rückwärtskompatibilität vorgesehen. Wenn Sie neuen Code schreiben, verwenden Sie die Objekte Err und Error, die Methode AccessError und das Ereignis Error, um Informationen über einen Fehler zu erhalten.


Bestimmen der für Microsoft Access und die Microsoft Jet-Datenbank-Engine reservierten Fehlercodes

Die folgende Prozedur erstellt eine Tabelle, die viele der Fehlercodes und Fehlermeldungen enthält, die von Microsoft Access oder der Microsoft Jet-Datenbank-Engine verwendet werden bzw. für diese reserviert sind. Die ausgegebene Tabelle enthält nicht alle Fehlercodes, da einige außerhalb des von dieser Prozedur ausgewerteten Bereichs von Fehlercodes (0 bis 3500) existieren.

Function AccessUndJetFehlertabelle() As Boolean
    Dim cat As New ADOX.Catalog
    Dim tbl As New ADOX.Table
    Dim cnn As ADODB.Connection
    Dim rst As New ADODB.Recordset, lngCode As Long
    Dim strAccessErr As String

    Const conAppObjectError = "Anwendungs- oder objektdefinierter Fehler"
    On Error GoTo Error_AccessUndJetFehlertabelle

    Set cnn = CurrentProject.Connection
        ' Fehlertabelle mit Fehlernummer und Fehlerbeschreibung erstellen.
    tbl.Name = "AccessUndJetFehler"
    tbl.Columns.Append "Fehlercode", adInteger
    tbl.Columns.Append "Fehlerzeichenfolge", adLongVarWChar

    Set cat.ActiveConnection = cnn
    cat.Tables.Append tbl
    ' Datensatzgruppe für Fehlertabelle öffnen.
    rst.Open "AccessUndJetFehler", cnn, adOpenStatic, adLockOptimistic
    ' Schleife durch Fehlercodes durchlaufen.
    For lngCode = 0 To 3500
        On Error Resume Next
        ' Jeden Fehler berücksichtigen.
        strAccessErr = AccessError(lngCode)
        DoCmd.Hourglass True
        ' Fehlernummern ohne zugehörige Zeichenfolge überspringen.
        If strAccessErr <> "" Then
            ' Codes, die anwendungs- oder objektdefinierte Fehler generieren, überspringen.
            If strAccessErr <> conAppObjectError Then
                ' Jeden Fehlercode und jede Fehlerzeichenfolge zur Fehlertabelle hinzufügen.
                rst.AddNew
                rst!Fehlercode = lngCode
                ' Zeichenfolge an Memo-Feld anfügen.
                rst!Fehlerzeichenfolge = strAccessErr
                rst.Update
            End If
        End If
    Next lngCode
    ' Datensatzgruppe schließen.
    rst.Close
    DoCmd.Hourglass False
    RefreshDatabaseWindow
    MsgBox "Access- und Jet-Fehlertabelle erstellt."
    AccessUndJetFehlertabelle= True

Exit_AccessUndJetFehlertabelle:
    Exit Function

Error_AccessUndJetFehlertabelle:
    MsgBox Err & ": " & Err.Description
    AccessUndJetFehlertabelle = False
    Resume Exit_AccessUndJetFehlertabelle
End Function


 Ermitteln der von Visual Basic reservierten Fehlercodes

Ermitteln der von Visual Basic reservierten Fehlercodes

Die folgende Prozedur erstellt eine Tabelle in Microsoft Access, die die von Visual Basic verwendeten oder reservierten Fehlercodes und -meldungen enthält. Die Tabelle enthält keine Fehler der ADO (ActiveX Data)-Objekte.

Visual Basic reserviert einen Bereich der ersten 1.000 möglichen Fehlernummern, so dass dieses Beispiel nur Fehlernummern zwischen 1 und 1.000 berücksichtigt. Andere Fehlernummern sind von der Microsoft Jet-Datenbank-Engine reserviert oder sind zur Definition von benutzerdefinierten Fehlern verfügbar.

Sub TabelleFehlerErstellen()
    Dim cat As New ADOX.Catalog
    tbl As New ADOX.Table
    cnn As ADODB.Connection
    Dim rst As New ADODB.Recordset, lngCode As Long
    Const conAnwOderObjektFehler = "Anwendungs- oder objektdefinierter Fehler"

    Set cnn = CurrentProject.Connection
    ' Tabelle "Fehler" mit den Feldern "Fehlernummer" und
    ' "Fehlerbeschreibung" erstellen.
    tbl.Name = "Fehler"
    tbl.Columns.Append "Fehlernummer", adInteger
    tbl.Columns.Append "Fehlerbeschreibung", adVarWChar
    Set cat.ActiveConnection = cnn
    cat.Tables.Append tbl
    ' Datensatzgruppe auf Basis der Tabelle "Fehler" öffnen.
    rst.Open "Fehler", cnn, adOpenStatic, adLockOptimistic
    ' Schleife für die ersten 1000 Visual Basic-Fehler.
    For lngCode = 1 To 1000
        On Error Resume Next
        ' Jeden Fehler provozieren.
        Err.Raise lngCode
        DoCmd.Hourglass True
        ' Fehlernummern überspringen, die anwendungs- oder objektdefinierte
        ' Fehler hervorrufen.
        If Err.Description <> conAppObjectError Then
            ' Jede Fehlernummer und jede Fehlerbeschreibung zur Tabelle
            ' "Fehler" hinzufügen.
            rst.AddNew
            rst!Fehlernummer = Err.Number
            rst!Fehlerbeschreibung = Err.Description
            rst.Update
        End If
        ' Inhalt des Err-Objekts löschen.
        Err.Clear
    Next lngCode
    ' Datensatzgruppe schließen.
    rst.Close
    DoCmd.Hourglass False
    MsgBox "Die Tabelle 'Fehler' wurde erstellt."
End Sub


 Verwenden der Eigenschaften, Methoden und Ereignisse eines ActiveX-Steuerelements

Verwenden der Eigenschaften, Methoden und Ereignisse eines ActiveX-Steuerelements

Dieses Hilfethema enthält Informationen zum Einstellen und Verwenden von Sprachelementen von ActiveX-Steuerelementen in Microsoft Access 2000 und beschreibt einige Features von ActiveX-Steuerelementen, die in Microsoft Access 95 und Microsoft Access 97 hinzugefügt wurden.

Anmerkung Diese Informationen gelten nicht für ActiveX-Steuerelemente in einer Datenzugriffsseiten-Umgebung.

Allgemeine Aufgaben

Beim Arbeiten mit ActiveX-Steuerelementen in Microsoft Access 97 mussten Sie nicht mehr die Object-Eigenschaft verwenden, um in Syntaxausdrücken auf Eigenschaften und Methoden zu verweisen. Die folgenden beiden Syntaxzeilen haben nun normalerweise die gleiche Bedeutung:

ActiveXCtl0.Object.MonthLength = 0
ActiveXCtl0.MonthLength = 0

Die einzige Ausnahme liegt vor, wenn ein Sprachelement eines ActiveX-Steuerelements denselben Namen wie ein Microsoft Access-Sprachelement hat, das ebenfalls für dieses ActiveX-Steuerelement gilt. In diesem Fall verwenden Sie weiterhin die Syntay .Object.

ActiveX-Steuerelementvariablen können nur vom Typ Control sein; speziellere Typen wie z.B. Calendar sind nicht zulässig.

Eigenschaften

Eigenschaften von ActiveX-Steuerelementen werden im Microsoft Access-Eigenschaftenfenster angezeigt. Sie können die meisten Eigenschaften im zusätzlichen Eigenschaftenfenster eines ActiveX-Steuerelements oder im Microsoft Access-Eigenschaftenfenster einstellen.

Anmerkung Die Eigenschaften eines ActiveX-Steuerelements sind nicht in der ADO-Auflistung Properties bzw. der DAO-Auflistung Properties aufgeführt. Sie können auf diese Eigenschaften nur zugreifen, indem Sie die im voranstehenden Abschnitt gezeigte Syntax verwenden.

Ereignisse

Für Microsoft Access-Ereignisse, wie z.B. Enter, die auch für ActiveX-Steuerelemente gelten, können Sie ein Makro oder eine Ereignisprozedur ausführen, wenn das Ereignis eintritt, indem Sie die Ereigniseigenschaft auf den Namen des Makros oder auf [Ereignisprozedur] einstellen. Für Ereignisse, die speziell für ActiveX-Steuerelemente gelten, wie z.B. das Ereignis NewMonth des Kalender-Steuerelements, öffnen Sie jedoch das Formularmodul in der Entwurfsansicht und wählen den Namen des ActiveX-Steuerelements im Feld Objekt und anschließend das Ereignis im Feld Prozedur aus. Auf diese Weise erstellen Sie eine Ereignisprozedur für das Ereignis des ActiveX-Steuerelements, die ausgeführt wird, wenn das Ereignis eintritt. Sie können die Syntax, die in diesem Fall für die Ereignisprozedur erstellt wird, auch kopieren, wenn Sie sie selbst erstellen möchten.

Wenn für ein ActiveX-Steuerelement sowohl ein Microsoft Access-Ereignis als auch ein ActiveX-Steuerelementereignis mit demselben Namen gilt, fügt Microsoft Access zum Namen des ActiveX-Steuerelementereignisses in der Dropdownliste des Feldes Prozedur "Object" hinzu. Auf diese Weise können beim Eintreten der beiden Ereignisse unterschiedliche Ereignisprozeduren ausgeführt werden.


 Microsoft Access-Sprachelemente, die für ActiveX-Steuerelemente gelten

Microsoft Access-Sprachelemente, die für ActiveX-Steuerelemente gelten

Neben den speziell für ein ActiveX-Steuerelement definierten Eigenschaften, Methoden und Ereignissen gelten einige bestehende Microsoft Access-Eigenschaften, -Methoden und -Ereignisse auch für ActiveX-Steuerelemente. Weitere Informationen zur Funktionsweise dieser Sprachelemente finden Sie im Microsoft Access-Hilfethema zum jeweiligen Sprachelement.

Eigenschaften

Die folgenden Microsoft Access-Eigenschaften gelten für ActiveX-Steuerelemente in Formularen und Berichten. Sie sind im Microsoft Access-Eigenschaftenfenster verfügbar.

BorderColor

BorderStyle

BorderWidth

Class

ControlSource (nur für ActiveX-Steuerelemente verfügbar, die an ein Feld gebunden werden können)

ControlTipText

DisplayWhen

Enabled

HelpContextID

 Height

Left

Locked (nur für ActiveX-Steuerelemente verfügbar, die an ein Feld gebunden werden können)

Name

Object

OLEClass

OnEnter

OnExit

OnGotFocus

 OnLostFocus

OnUpdated

SpecialEffect

TabIndex

TabStop

Tag

Top

Verb

Visible

Width

Die folgenden Microsoft Access-Eigenschaften gelten für ActiveX-Steuerelemente. Sie sind nur in einem Makro oder in Visual Basic verfügbar.

ControlType | InSelection | Parent
EventProcPrefix | ObjectVerbsCount | Section

Ereignisse

Die folgenden Microsoft Access-Ereignisse gelten für ActiveX-Steuerelemente in Formularen und Berichten:

Enter | GotFocus | Updated
Exit | LostFocus |

Methoden

Die folgenden Microsoft Access-Methoden gelten für ActiveX-Steuerelemente in Formularen und Berichten:


 Verwenden des zusätzlichen Eigenschaftenfensters eines ActiveX-Steuerelements

Verwenden des zusätzlichen Eigenschaftenfensters eines ActiveX-Steuerelements

Wenn Sie die Eigenschaften eines ActiveX-Steuerelements einstellen, möchten Sie möglicherweise das zusätzliche Eigenschaftenfenster des Steuerelements verwenden. Das zusätzliche Eigenschaftenfenster ist eine Alternative zur Eigenschaftenliste im Microsoft Access-Eigenschaftenfenster zum Einstellen der Eigenschaften des ActiveX-Steuerelements in der Entwurfsansicht.

Anmerkung Diese Informationen betreffen nur ActiveX-Steuerelemente in einer Microsoft Access-Datenbank-Umgebung (.mdb).

Zwei Möglichkeiten zum Einstellen von Eigenschaften

Der Grund für das Vorhandensein des zusätzlichen Eigenschaftenfensters besteht darin, dass nicht alle Anwendungen, die ActiveX-Steuerelemente benutzen, ein Eigenschaftenfenster wie das von Microsoft Access besitzen. Das zusätzliche Eigenschaftenfenster stellt eine Schnittstelle zum Einstellen der wichtigsten Steuerelementeigenschaften bereit, unabhängig von der Oberfläche der Host-Anwendung.

Die Eigenschaften einiger ActiveX-Steuerelemente können Sie in beiden Eigenschaftenfenstern einstellen:

  • Im Microsoft Access-Eigenschaftenfenster

  • Im zusätzlichen Eigenschaftenfenster eines ActiveX-Steuerelements.

In einigen Fällen können Sie nur das zusätzliche Eigenschaftenfenster zum Einstellen einer Eigenschaft in der Entwurfsansicht verwenden. Dies ist normalerweise dann der Fall, wenn die Schnittstelle, die zum Einstellen einer Eigenschaft benötigt wird, nicht innerhalb des Microsoft Access-Eigenschaftenfensters funktioniert. Beispielsweise besitzt die Eigenschaft GridFont des Kalender-Steuerelements mehrere Argumente; Sie können jedoch im Microsoft Access-Eigenschaftenfenster nur ein Argument pro Eigenschaft einstellen.

Suchen des zusätzlichen Eigenschaftenfensters

Nicht alle ActiveX-Steuerelemente besitzen ein zusätzliches Eigenschaftenfenster. Um herauszufinden, ob ein Steuerelement ein zusätzliches Eigenschaftenfenster bereitstellt, suchen Sie im Microsoft Access-Eigenschaftenfenster für dieses Steuerelement nach der Eigenschaft Benutzerdefiniert. Wenn in der Liste der Eigenschaften der Name Benutzerdefiniert enthalten ist, besitzt das Steuerelement das zusätzliche Eigenschaftenfenster.

Verwenden des zusätzlichen Eigenschaftenfensters

Klicken Sie im Microsoft Access-Eigenschaftenfenster auf das Einstellungsfeld der Eigenschaft Benutzerdefiniert und anschließend auf die Generator-Schaltfläche [image] rechts neben dem Einstellungsfeld der Eigenschaft, um das zusätzliche Eigenschaftenfenster des Steuerelements anzuzeigen. Es wird häufig als Dialogfeld mit Registerkarten dargestellt. Wählen Sie die entsprechende Registerkarte zum Einstellen der gewünschten Eigenschaften.

Nachdem Sie Änderungen in einer Registerkarte vorgenommen haben, können Sie diese Änderungen häufig direkt anwenden, indem Sie auf die Schaltfläche Übernehmen (falls vorhanden) klicken. Sie können auch auf andere Registerkarten klicken, um bei Bedarf weitere Eigenschaften einzustellen. Damit alle im zusätzlichen Eigenschaftenfenster vorgenommenen Änderungen wirksam werden, klicken Sie auf die Schaltfläche OK. Wenn Sie zum Microsoft Access-Eigenschaftenfenster zurückkehren möchten, ohne Eigenschafteneinstellungen zu ändern, klicken Sie auf die Schaltfläche Abbrechen.

Sie können das zusätzliche Eigenschaftenfenster auch anzeigen, indem Sie im Menü Bearbeiten auf den Eintrag für das ActiveX-Steuerelement (z.B. Calendar-Objekt) und dann auf den Unterbefehl Eigenschaften klicken, oder indem Sie im Kontextmenü des ActiveX-Steuerelements auf diesen Unterbefehl klicken. Außerdem besitzen einige Eigenschaften, wie z.B. die Eigenschaft GridFontColor, im Microsoft Access-Eigenschaftenfenster für das ActiveX-Steuerelement eine Generator-Schaltfläche rechts neben dem Einstellungsfeld der Eigenschaft. Wenn Sie auf die Generator-Schaltfläche klicken, wird das zusätzliche Eigenschaftenfenster angezeigt, wobei die geeignete Registerkarte (z.B. Farbe) ausgewählt ist.


 Anzeigen des Infofelds eines ActiveX-Steuerelements

Anzeigen des Infofelds eines ActiveX-Steuerelements

Zum Einblenden eines Infofelds, das Versions- und Copyright-Informationen für ein ActiveX-Steuerelement anzeigt, klicken Sie auf das Einstellungsfeld der Eigenschaft Info im Microsoft Access-Eigenschaftenfenster. Klicken Sie anschließend auf die Generator-Schaltfläche [image] rechts neben dem Einstellungsfeld der Eigenschaft.

Anmerkung Das Infofeld ist für ActiveX-Steuerelemente auf einer Datenzugriffsseite nicht verfügbar.


 Informationen zur Konvertierung und Kompatibilität

Informationen zur Konvertierung und Kompatibilität

Sie können eine Microsoft Access 2000-Datenbank nicht mit früheren Microsoft Access-Versionen öffnen. Sie können jedoch Microsoft Access 2000 (Version 9.0)-Tabellen mit Microsoft Access 97 (Version 8.0)-Datenbanken verknüpfen und in diese importieren. Sie können auch eine Version 8.0-Tabelle in eine Version 7.0-Datenbank exportieren, und Sie können Daten aus einer Version 8.0-Tabelle ausschneiden und in eine Version 7.0-Tabelle kopieren oder einfügen.

Sie können eine Datenbank, die mit einer früheren Version von Microsoft Access erstellt wurde, so aufbereiten, dass sie mit Microsoft Access 2000 ausgeführt werden kann. Sie können jedoch keine neuen Objekte zu dieser Datenbank hinzufügen und keinen Objektentwurf in der Datenbank ändern.

Wenn die Konvertierung einer Datenbank in Microsoft Access 2000 fehlschlägt, können Sie auch eine neue Microsoft Access 2000-Datenbank erstellen und alle Objekte aus der früheren Version in die neue Datenbank importieren.

Anmerkung Wenn Sie eine Datenbank gemeinsam mit Benutzern verwenden möchten, die mit einer früheren Version von Microsoft Access arbeiten, öffnen Sie die Datenbank der früheren Version, um sie lediglich aufzubereiten und nicht zu konvertieren. Konvertieren Sie die Datenbank in diesem Fall also nicht in das Microsoft Access 2000-Format.

Konvertieren einer Datenbank

Konvertieren einer gesicherten Datenbank aus einer früheren Version von Microsoft Access

Konvertieren von Bibliotheksdatenbanken und Add-Ins

Was ist neu für Entwickler: Überblick

Konvertieren von Access Basic-Code in Visual Basic

Konvertieren von Code, der eine DLL aufruft

Makroaktionen und Methoden des DoCmd-Objekts

Konvertieren von Tastenkombinationen für Tastaturbefehle/SendKeys

Neues Format für eingebaute Konstanten

Kompatibilität von Gültigkeitsbereichen und Objektnamen

DAO-Objektbibliothekskompatibilität

Beispiele zum Konvertieren von DAO-Code


 Konvertieren von Microsoft Access-Tabellen, -Formularen und -Berichten

Konvertieren von Microsoft Access-Tabellen, -Formularen und -Berichten

Verschiedene in Microsoft Access 2000 enthaltene Änderungen können Auswirkungen auf das Verhalten der Anwendungen der Version 1.x oder 2.0 haben. Die folgenden Abschnitte bieten genauere Informationen zu diesen Änderungen.

Indizes und Beziehungen

Eine Microsoft Access-Tabelle kann bis zu 32 Indizes enthalten. Sehr komplexe Tabellen, die Bestandteil vieler Beziehungen sind, können unter Umständen die Indexeinschränkung überschreiten, so dass Sie nicht in der Lage sind, die Datenbank mit diesen Tabellen zu konvertieren. Die Version 3.5 der Microsoft Jet-Datenbank-Engine erstellt Indizes für beide Seiten der Beziehungen zwischen Tabellen. Wenn sich Ihre Datenbank nicht konvertieren lässt, löschen Sie einige Beziehungen, und versuchen Sie dann erneut, die Datenbank zu konvertieren.

Die LimitToList-Eigenschaft von Kombinationsfeldern

In Microsoft Access 2000 werden Null-Werte in Kombinationsfeldern akzeptiert, wenn die LimitToList-Eigenschaft auf True (-1) eingestellt ist, unabhängig davon, ob die Liste Null-Werte enthält oder nicht. In der Version 2.0 akzeptiert ein Kombinationsfeld, dessen LimitToList-Eigenschaft auf True eingestellt ist, nur dann einen Null-Wert, wenn die Liste einen Null-Wert enthält. Wenn Sie die Eingabe eines Null-Wertes in ein Kombinationsfeld nicht zulassen möchten, stellen Sie die Eingabe erforderlich-Eigenschaft des betreffenden Tabellenfeldes auf Ja ein.

Menüs und direkte Bearbeitung von OLE-Objekten

Um während der direkten Bearbeitung von OLE-Objekten eine erweiterte Funktionalität zur Verfügung zu stellen, wurden einige Menübefehle in ein Menü verschoben, das beim Aktivieren eines OLE-Servers nicht ersetzt wird.

Von diesen Änderungen sind nicht die Makros Ihrer konvertierten Anwendung betroffen, die mit Hilfe der Aktion AusführenMenübefehl einen Menübefehl der Version 2.0 ausführen, wenn eine Komponente aktiviert ist. Die Befehle der Version 2.0 werden in die entsprechenden Microsoft Access 2000-Befehle umgewandelt.

Verweisen auf ein Steuerelement eines schreibgeschützten Formulars

In Microsoft Access 2000 können Sie nicht mit Hilfe eines Ausdrucks auf den Wert eines Steuerelements eines schreibgeschützten Formulars verweisen, das an eine leere Datenquelle gebunden ist. In früheren Versionen gab der Ausdruck einen Null-Wert zurück. Bevor Sie auf ein Steuerelement eines schreibgeschützten Formulars verweisen, vergewissern Sie sich, dass die Datenquelle des Formulars Datensätze enthält.

Datumsfelder und Dateneingabe

Wenn Sie in ein Feld vom Typ Datum/Uhrzeit auf einem Formular- oder Tabellen-Datenblatt 3.3 eingeben, trägt Microsoft Access 2000 dort automatisch auch das aktuelle Jahr ein. Wenn Sie in das gleiche Feld jedoch 3.3. eingeben, zeigt Microsoft Access eine Fehlermeldung an. Lassen Sie das letzte Datumstrennzeichen weg, damit Microsoft Access das Datum in das richtige Format übertragen kann.

Mit dem Befehlsschaltflächen-Assistent erstellte Schaltflächen

Wenn Sie in den Versionen 2.0 oder 7.0 von Microsoft Access mit Hilfe des Befehlsschaltflächen-Assistenten Code erstellt haben, der eine andere Anwendung aufruft, löschen Sie diese Schaltfläche, und erstellen Sie sie unter Verwendung des Befehlsschaltflächen-Assistenten in Microsoft Access 2000 erneut.

Die Klassenmodule für Formulare und Berichte

In früheren Microsoft Access-Versionen sind Form- und Report-Objekten Klassenmodule zugeordnet, auch wenn hinter dem Objekt kein Code steht. In Microsoft Access 2000 können Sie die HasModule-Eigenschaft eines Formulars oder Berichts auf False einstellen. In diesem Fall benötigt das Formular bzw. der Bericht weniger Festplattenspeicherplatz und wird schneller geladen, da ihm kein Klassenmodul mehr zugeordnet ist.

Konvertierter Version 2.0-Bericht besitzt andere Randeinstellungen

Probleme können auftreten, wenn Sie einen Microsoft Access 2000-Bericht, der von Microsoft Access 2.0 konvertiert wurde und bei dem einige Ränder auf 0 eingestellt sind, drucken oder in der Seitenansicht anzeigen möchten. Wenn Sie einen Microsoft Access 2.0-Bericht konvertieren, werden die Ränder nicht auf 0 eingestellt, sondern auf den kleinsten Rand, der für den Standarddrucker zulässig ist. Dadurch können keine Berichtsdaten im nicht bedruckbaren Bereich des Druckers gedruckt werden.

Um das Problem zu beheben, verringern Sie die Spaltenbreite, den Spaltenabstand und/oder die Anzahl der Spalten im Bericht so, dass die Summe aus allen Spaltenbreiten und der Breite der Standardränder kleiner oder gleich der Papierbreite ist.

Format-Eigenschaft kann nicht verwendet werden, um zwischen Null-Werten und leeren Zeichenfolgen zu unterscheiden.

In den Versionen 1.x und 2.0 können Sie die Format-Eigenschaft eines Steuerelements verwenden, um Null-Werte und leere Zeichenfolgen (" ") unterschiedlich anzuzeigen. Wenn Sie in Microsoft Access 2000 zwischen Null-Werten und leeren Zeichenfolgen in einem Steuerelement eines Formulars unterscheiden möchten, stellen Sie die ControlSource-Eigenschaft des Steuerelements auf einen Ausdruck ein, der auf den Null-Wert testet. Um in dem Steuerelement MeinSteuerelement beispielsweise "Null" oder "LZ" anzuzeigen, stellen Sie seine ControlSource-Eigenschaft auf den folgenden Ausdruck ein:

=IIf(IsNull([MeinSteuerelement]), "Null", Format([MeinSteuerelement], "@;LZ"))


Konvertieren von DAO-Code in ADO

Microsoft Access enthält ADO (ActiveX Data Objects) 2.1 als Standard-Datenzugriffsbibliothek. Obwohl auch DAO (Data Access Objects) 3.6 einbezogen ist, wird darauf standardmäßig nicht verwiesen. Die folgenden Informationen sollen als Hilfe beim Konvertieren von Code in den neueren ADO-Standard dienen.

Anmerkung In Microsoft Access 2000 werden Versionen der DAO-Bibliothek vor Version 3.6 nicht mehr bereitgestellt oder unterstützt.

Umwandlung von DAO-Objekten in ADO-Objekte

DAO | ADO(ADODB) | Anmerkung
DBEngine | Keine |
Workspace | Keine |
Database | Connection |
Recordset | Recordset |
Dynaset-Type | Keyset | Ruft eine Gruppe von Zeigern für die Datensätze der Datensatzgruppe ab
Snapshot-Type | Static | Rufen beide vollständige Datensätze ab, doch eine Datensatzgruppe vom Typ Static kann aktualisiert werden.
Table-Type | Keyset mit Option adCmdTableDirect |
Field | Field | Wenn darauf in einer Datensatzgruppe verwiesen wird

DAO ADO
Öffnen eines Recordset-Objekts
Dim db as Database
Dim rs as DAO.Recordset
Set db = CurrentDB()
Set rs = db.OpenRecordset("Personal")

Dim rs as New ADODB.Recordset
rs.Open "Personal", CurrentProject.Connection, adOpenKeySet, adLockOptimistic
Bearbeiten eines Recordset-Objekts
rs.Edit
rs("Textfeldname") = "NeuerWert"
rs.Update

rs("Textfeldname") = "NeuerWert"
rs.Update

Anmerkung Wenn der Fokus über MoveNext, MoveLast, MoveFirst, MovePrevious vom aktuellen Datensatz verschoben wird, ohne zuerst die CancelUpdate-Methode zu verwenden, wird die Update-Methode implizit ausgeführt.


Konvertieren von DAO DDL-Elementen in ADOX

Microsoft Access enthält zusätzliche Bibliotheken, die verwendet werden, wenn die DDL (Data Definition Language)-Funktionen von DAO in die DDL-Funktionen von ADO (Active Data Objects) konvertiert werden.

Anmerkung In Microsoft Access 2000 wird auf ADO DDL standardmäßig nicht verwiesen. Deshalb müssen Sie zuerst einen Verweis auf MSADOX.DLL erstellen, indem Sie Verweise im Menü Extras wählen und dann Microsoft ADO Ext. 2.1 for DDL and Security aktivieren.

Umwandlung von DAO-Objekten in ADO-Objekte

DAO | ADO(ADOX)
DBEngine | Kein
Workspace | Kein
Database | Catalog
QueryDef (Einfache Auswahlabfrage) | View
QueryDef (Aktions-/Paramaterabfrage) | Procedure
TableDef | Table
Parameter | Parameter
Field | Column

Umwandlung von DAO- in ADO-Zugriffsrechtekonstanten

DAO | ADO(ADOX) | Möglichkeiten für den Benutzer
dbSecNoAccess | adRightNone | Hat keinen Zugriff auf Dokument
dbSecFullAccess | adRightFull | Hat vollständigen Objektzugriff
dbSecDelete | adRightDelete | Kann Objekt löschen
dbSecReadSec | adRightReadDesign | Kann sicherheitsbezogene Informationen lesen
dbSecWriteSec | adRightWriteDesign | Kann Zugriff ändern
dbSecWriteOwner | adRightWriteOwner | Kann Besitzer ändern
dbSecCreate | adRightCreate or adRightWithGrant | Kann neue Dokumente erstellen
dbSecReadDef | adRightRead or adRightReadDesign | Kann die Definition einer Tabelle oder Abfrage lesen
dbSecWriteDef | adRightUpdate or adRightWriteDesign | Kann die Definition einer Tabelle oder Abfrage ändern
dbSecRetrieveData | adRightRead | Kann die in einer Tabelle oder Abfrage gespeicherten Daten lesen. Impliziert Leseberechtigung für die Definition.
dbSecInsertData | adRightInsert | Kann neue Zeilen in eine Tabelle oder Abfrage einfügen
dbSecReplaceData | adRightUpdate | Kann Tabellen- oder Abfragedaten ändern
dbSecDeleteData | adRightDelete or adRightWithGrant | Kann Zeilen aus einer Tabelle oder Abfrage löschen

Jet-Felddatentypen | DAO-Datentypen | ADO-Datentypen
Ja/Nein | dbBoolean | adBoolean
Zahl (Feldgröße = Byte) | dbByte | adUnsignedTinyInt
AutoWert (Feldgröße = Long Integer) | dbLong | adInteger
Währung | dbCurrency | adCurrency
Datum/Uhrzeit | dbDate | adDate
Zahl (Feldgröße = Double) | dbDouble | adDouble
Zahl oder AutoWert (Feldgröße = Replikations-ID) | dbGUID | adGUID
Zahl (Feldgröße = Long Integer) | dbLong | adInteger
OLE-Objekt | dbLongBinary | adLongVarBinary
Memo | dbMemo | adLongVarWChar
Zahl (Feldgröße = Single) | dbSingle | adSingle
Zahl (Feldgröße = Integer) | dbInteger | adSmallInt
Text | dbText | adVarWChar
Hyperlink | dbMemo | adLongVarWChar
Zahl (Feldgröße = Decimal) | dbDecimal | adDecimal

  4. DAO
  1. ADO
Erstellen eines Database-Objekts
Dim wsp As Workspace, dbs As Database
Set wsp = DBEngine(0)
Set dbs = wsp.CreateDatabase("NeueDb.mdb")

Dim cat As New ADOX.Catalog
cat.Create "Provider = Microsoft.Jet.OLEDB.4.0;" _
       & "Data Source = NeueDb.mdb"
Erstellen eines Table-Objekts
Dim dbs As Database
Dim tdf As TableDef, fld As Field

Set dbs = CurrentDb
Set tdf = dbs.CreateTableDef("NeueTabelle")
Set fld = tdf.CreateField("FName", dbText, 50)
tdf.Fields.Append fld
dbs.TableDefs.Append tdf
Dim cat As New ADOX.Catalog
Dim tbl As New ADOX.Table

Set cat.ActiveConnection = CurrentProject.Connection
tbl.Name = "NeueTabelle"
tbl.Columns.Append "FName", adVarWChar, 50
Cat.Tables.Append tbl
Erstellen eines Query-Objekts
Dim dbs As Database
Dim qdf As QueryDef

Set dbs = CurrentDb
Set qdf = dbs.CreateQueryDef("NeueAbfrage", _
     "Select * From Personal")
dbs.QueryDefs.Append qdf
Dim cat As New ADOX.Catalog
Dim cmd As New ADODB.Command

Set cat.ActiveConnection = CurrentProject.Connection
cmd.CommandText "Select * From Personal"
Cat.Views.Append "NeueAbfrage", cmd


Konvertieren von DAO-Replikation in JRO

Neben den ADO- und ADOX-Objektbibliotheken enthält Microsoft Access Jet- und Replikationsobjekte (JRO). Diese Gruppe von Objekten stellt ein Objektmodell und Methoden bereit, die speziell für den Einsatz bei ADO und der Jet-Database-Engine konzipiert wurden.

Anmerkung Um die JRO-Funktionalität nutzen zu können, müssen Sie zuerst einen Verweis auf MSJRO.DLL erstellen, indem Sie Verweise im Menü Extras wählen und dann Microsoft Jet and Replication Objects 2.1 Library aktivieren.

Im Folgenden sind einige allgemeine DAO-Replikationsmethoden und ihre JRO-Entsprechungen aufgelistet.

DAO | ADO(JRO) | Anmerkung
DBEngine | JetEngine |
Database | Catalog |

Erstellen eines Replica-Objekts
' Bei geöffnetem Database-Objekt
' "dbReplicable"
Dim dbTemp As Database

Set dbTemp=OpenDatabase(dbReplicable)
dbTemp.MakeReplica strNewReplica, _
"Replikat von " & strReplicableDB
dbsTemp.Close

Dim rpMaster As New JRO.Replica
rpMaster.MakeReplicable "nordwind.mdb",False
Set rpMaster = Nothing
rpMaster.ActiveConnection ="nordwind.mdb"
rpMaster.CreateReplica "nordwind2.mdb", _
 "Vollständiges Replikat1", jrRepTypeFull, jrRepVisibilityGlobal
Set rpMaster = Nothing
Komprimieren und Verschlüsseln eines Database-Objekts
Dim dbNWD As Database
Set dbNWD =OpenDatabase("Nordwind.mdb")
DBEngine.CompactDatabase "Nordwind.mdb", _
"NWD_DAOComp.mdb", , dbEncrypt

Dim je As New JRO.JetEngine
je.CompactDatabase _
"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=Nordwind.mdb", _
   "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=NWD_ADOComp.mdb.mdb;" _
& "Jet OLEDB:Encrypt Database=True"


 Beispiele zum Konvertieren von DAO-Code

Beispiele zum Konvertieren von DAO-Code

Microsoft Access enthält Version 4.0 der Microsoft Jet-Datenbank-Engine und Version 3.6 der DAO-Objektbibliothek. Alle früheren DAO-Versionen werden in Microsoft Access 2000 nicht mehr unterstützt. Die folgenden Beispiele zeigen, wie Code-Konstrukte in Microsoft Access-Datenbanken konvertiert werden, die mit früheren Versionen der Jet-Datenbank-Engine und der DAO-Objektbibliotheken erstellt wurden.

Anmerkung Diese Informationen dienen nur zur Referenz. Versionen von DAO-Code vor Version 3.6 werden in Access 2000 nicht mehr unterstützt. Es wird empfohlen, dass Sie die ADO-Methoden für den Zugriff auf Daten Ihrer aktuellen Datenbank bei allen neuen Anwendungen und für zukünftige Versionskompatibilität verwenden.

Einrichten eines Verweises auf die aktuelle Datenbank

Version Beispiel
1.x
Dim dbs As Database
Set dbs = CurrentDb
2.x
Dim dbs As Database
Set dbs = DBEngine.Workspaces(0).Databases(0)
oder
Dim dbs As Database
Set dbs = DBEngine(0)(0)
7.0 oder höher
Dim dbs As DAO.Database
Set dbs = CurrentDb
9.0

(Empfohlen)

Dim cnn As ADODB.Connection
Set cnn = CurrentProject.Connection

Anmerkung In Microsoft Access ist die aktuelle Datenbank die Standarddatenbank der Databases-Auflistung; daher können Sie weiterhin mit Hilfe der Syntax DBEngine(0)(0) eine Objektvariable vom Typ Database zurückgeben, die auf die aktuelle Datenbank verweist. Bei der Verwendung von DAO wird jedoch die CurrentDb-Methode als Verfahren für die Rückgabe dieser Objektvariablen bevorzugt, da sie das Erstellen mehrerer Objektvariablen vom Typ Database ermöglicht, die auf die aktuelle Datenbank verweisen.

Öffnen einer Datenbank und Einrichten eines Verweises

Version Beispiel
1.x
Set dbs = OpenDatabase("Kontakte.mdb")
2.x und höher
Set dbs = DBEngine.Workspaces(0).OpenDatabase("Kontakte.mdb")
oder
Set dbs = Workspaces(0).OpenDatabase("Kontakte.mdb")
oder
Set dbs = OpenDatabase("Kontakte.mdb")
9.x (Empfohlen)
cnn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=Kontakte.mdb"

Öffnen einer Datensatzgruppe vom Typ "Tabelle"

Version Beispiel
1.x
Dim tbl As Table
Set tbl = dbs.OpenTable("Bestellungen")
2.x
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", DB_OPEN_TABLE)
oder
Dim rst As Recordset
Set rst = dbs!Bestellungen.OpenRecordset
7.0 oder höher
Dim rst As DAO.Recordset
Set rst = dbs.OpenRecordset("Bestellungen", dbOpenTable)
oder
Dim rst As DAO.Recordset
Set rst = dbs!Bestellungen.OpenRecordset
9.0 (Empfohlen)
Dim rst As New ADODB.Recordset
rst.Open "Bestellungen",cnn,adOpenKeyset,adLockOptimistic,adCmdTableDirect

Öffnen einer Datensatzgruppe vom Typ "Tabelle" im exklusiven Modus

Version Beispiel
1.x
Dim tbl As Table
Set tbl = dbs.OpenTable("Bestellungen", DB_DENY_READ)
2.x
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", DB_OPEN_TABLE, DB_DENY_READ)
oder
Dim rst As Recordset
Set rst = dbs!Bestellungen.OpenRecordset(DB_OPEN_TABLE, DB_DENY_READ)
7.0 oder höher
Dim rst As DAO.Recordset
Set rst = dbs.OpenRecordset("Bestellungen", dbOpenTable, dbDenyRead)
oder
Dim rst As DAO.Recordset
Set rst = dbs!Bestellungen.OpenRecordset(dbOpenTable, dbDenyRead)
9.0 (Empfohlen)
S/A (Über ADO nicht verfügbar )

Öffnen eines Recordset-Objekts vom Typ "Dynaset"

Version Beispiel
1.x
Dim dyn As Dynaset
Set dyn = dbs.CreateDynaset("Bestellungen")
2.x
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", DB_OPEN_DYNASET)
oder
Set rst = dbs!Bestellungen.OpenRecordset(dbOpenDynaset)
7.0 oder höher
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
oder
Set rst = dbs!Bestellungen.OpenRecordset(dbOpenDynaset)
9.0 (Empfohlen)
Dim rst As New ADODB.Recordset
rst.Open "Bestellungen", cnn, adOpenKeyset, adLockOptimistic

Öffnen eines Recordset-Objekts vom Typ "Snapshot"

Version Beispiel
1.x
Dim snp As Snapshot
Set snp = dbs.CreateSnapshot("Bestellungen")
2.x
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", DB_OPEN_SNAPSHOT)
oder
Set rst = dbs!Bestellungen.OpenRecordset(DB_OPEN_SNAPSHOT)
7.0 oder höher
Dim rst As Recordset
Set rst = dbs.OpenRecordset("Bestellungen", dbOpenSnapshot)
oder
Set rst = dbs!Bestellungen.OpenRecordset(dbOpenSnapshot)
9.0 (Empfohlen)
Dim rst As New ADODB.Recordset
rst.Open "Bestellungen", cnn, adOpenStatic, adLockReadOnly

Auflisten von Feldern

Version Beispiel
1.x
' Bei geöffnetem Table-Objekt "tbl".
Dim snp As Snapshot
Set snp = tbl.ListFields()
While Not snp.EOF
   Debug.Print snp!Name, snp!Type
   snp.MoveNext
Wend
snp.Close
2.x
' Bei geöffnetem TableDef-Objekt "tdf".
Dim intI As Integer, fld As Field
For intI = 0 To tdf.Fields.Count - 1
   Set fld = tdf.Fields(intI)
   Debug.Print fld.Name, fld.Type
Next intI
7.0 oder höher
' Bei geöffnetem TableDef-Objekt "tdf".
Dim fld As Field
For Each fld in tdf.Fields
   Debug.Print fld.Name, fld.Type
Next fld
9.0 (Empfohlen)
' Bei geöffnetem Table-Objekt "tbl".
Dim col as ADOX.column
For Each col in tbl.Columns
   Debug.Print col.Name, col.Type
Next col

Auflisten der Tabellen einer Datenbank

Version Beispiel
1.x
' Bei geöffnetem Database-Objekt "dbs".
Dim snp As Snapshot
Set snp = dbs.ListTables()
While Not snp.EOF
   Debug.Print snp!Name
   snp.MoveNext
Wend snp.Close
2.x
' Bei geöffnetem Database-Objekt "dbs".
Dim intJ As Integer, tdf As TableDef
For intJ = 0 To dbs.TableDefs.Count - 1
   Set tdf = dbs.TableDefs(intJ)
   Debug.Print tdf.Name
Next intJ
7.0 oder höher
' Bei geöffnetem Database-Objekt "dbs".
Dim tdf As TableDef
For Each tdf in dbs.TableDefs
   Debug.Print tdf.Name
Next tdf
9.0 (Empfohlen)
' Bei geöffnetem Catalog-Objekt "cat".
Dim tbl As ADOX.Table
For Each tbl in cat.Tables
   Debug.Print tbl.Name
Next tbl

Auflisten der Indizes einer Tabelle

Version Beispiel
1.x
' Bei geöffnetem Table-Objekt "tbl".
Dim snp As Snapshot
Set snp = tbl.ListIndexes()
While Not snp.EOF
   Debug.Print snp!Name
   snp.MoveNext
Wend
snp.Close
2.x
' Bei geöffnetem TableDef-Objekt "tdf".
Dim intI As Integer, idx As Index
For intI = 0 To tdf.Indexes.Count - 1
   Set idx = tdf.Indexes(intI)
   Debug.Print idx.Name
Next intI
7.0 oder höher
' Bei geöffnetem TableDef-Objekt "tdf".
Dim idx As DAO.Index
For Each idx in tdf.Indexes
   Debug.Print idx.Name
Next idx
9.0

(Empfohlen)

' Bei geöffnetem Table-Objekt "tbl".
Dim idx As ADOX.Index
For Each idx in tbl.Indexes
   Debug.Print idx.Name
Next idx

Auflisten der Parameter einer Abfrage

Version Beispiel
1.x
' Bei geöffnetem QueryDef-Objekt "qdf".
Dim snp As Snapshot
Set snp = qdf.ListParameters()
While Not snp.EOF
   Debug.Print snp!Name
   snp.MoveNext
Wend
snp.Close
2.x
' Bei geöffnetem QueryDef-Objekt "qdf".
Dim intI As Integer, prm As Parameter
For intI = 0 to qdf.Parameters.Count - 1
   Set prm = qdf.Parameters(i)
   Debug.Print prm.Name
Next intI
7.0 oder höher
' Bei geöffnetem QueryDef-Objekt "qdf".
Dim prm As Parameter
For Each prm in qdf.Parameters
   Debug.Print prm.Name
Next prm
9.0 (Empfohlen)
' Bei geöffnetem Procedure-Objekt "prc".
Dim prm As ADODB.Parameter
For Each prm in prc.Parameters
   Debug.Print prm.Name
Next prm

Dynamisches Einstellen von Abfrageparametern

Version Beispiel
1.x
' Bei geöffneter Datenbank "dbs".
Dim qdf As QueryDef, dyn As Dynaset
Set qdf = dbs.OpenQueryDef("BestellungenAbfrage")
qdf.ParameterName = "[Anfangsdatum]"
Set dyn = qdf.CreateDynaset()
2.x
' Bei geöffnetem QueryDef-Objekt "qdf".
Dim intI As Integer, prm As Parameter, rst As Recordset
For intI = 0 To qdf.Parameters.Count - 1
   Set prm = qdf.Parameters(intI)
   prm.Value = InputBox("Wert für " & prm.Name)
Next intI
Set rst = qdf.OpenRecordset
7.0 oder höher
' Bei geöffnetem QueryDef-Objekt "qdf".
Dim prm As Parameter, rst As Recordset
For Each prm in qdf.Parameters
   prm.Value = InputBox("Wert für " & prm.Name)
Next prm
Set rst = qdf.OpenRecordset
9.0 (Empfohlen)
' Bei geöffnetem Procedure-Objekt "prc".
Dim prm As ADODB.Parameter, rst As ADODB.Recordset
For Each prm in prc.Command.Parameters
   prm.Value = InputBox("Wert für " & prm.Name)
Next prm
rst.Open prc.Command,,adOpenKeyset, adLockOptimistic

Ausführen einer Pass-Through-Abfrage

Version Beispiel
1.x
' Bei geöffnetem Database-Objekt "dbs".
Dim lngRows As Long
' Gespeicherte Prozedur auf Server ausführen.
lngRows = dbs.ExecuteSQL("EXECUTE SP_StoredProc")
oder
Dim snp As Snapshot
Set snp = dbs.CreateSnapshot("EXECUTE SP_StoredProc", DB_SQLPassThrough)
2.x und höher
' Bei geöffnetem Database-Objekt "dbs".
Dim qdf As QueryDef, rst As Recordset
Set qdf = dbs.CreateQueryDef("ODBCAbfrage")
qdf.Connect = "ODBC;" & "DSN=Server1;" _
   & "UID=sa;" & "PWD=hithere;" & "DATABASE=pubs"
qdf.SQL = "EXECUTE SP_StoredProc"
qdf.ReturnsRecords = True
.
.
.
Set rst = qdf.OpenRecordset
9.0 und höher
' Bei geöffnetem Catalog-Objekt mit eingestelltem Wert für "ActiveConnection", Objekt "cat".
Dim rst As Recordset, cmdPassthru As New ADODB.Command
Set cmdPassthru.ActiveConnection = Currentproject.connection
cmdPassthru("Jet OLEDB:Passthru Query conection string")= _
   "ODBC;DSN=Server1;UID=sa;PWD=hithere;DATABASE=pubs"
cmdPassthru.CommandText = "EXECUTE SP_StoredProc"
cat.Procedures.Append "ODBCAbfrage", cmdPassthru

Set rst = cmd.Execute

Erstellen einer temporären Abfrage

Version Beispiel
1.x
' Bei geöffnetem Database-Objekt "dbs".
Dim qdf As QueryDef, strTemp As String
strTemp = "TMP:" & User() & Time()
qdf = dbs.CreateQueryDef(strTemp)
qdf.SQL = "UPDATE Tabelle1 SET Tabelle1.Feld1 = Feld1 * 1.1;"
.
.
.
qdf.Execute
qdf.Close
.
.
dbs.DeleteQueryDef(strTemp)
2.x und höher
qdf = dbs.CreateQueryDef("")
qdf.Execute
qdf.Close
9.0 und höher
cmd.CommandText = "UPDATE Tabelle1 SET Tabelle1.Feld1 = Feld1 * 1.1;" cmd.Execute
set cmd = Nothing


 Automatisierung mit Microsoft Access

Automatisierung mit Microsoft Access

Microsoft Access ist eine COM-Komponente, die Automatisierung, früher OLE-Automatisierung genannt, unterstützt. Microsoft Access unterstützt die Automatisierung in zweierlei Hinsicht: in Microsoft Access können Sie mit Objekten arbeiten, die von einer anderen Komponente bereitgestellt werden, und umgekehrt stellt Microsoft Access seine Objekte anderen COM-Komponenten zur Verfügung.

In früheren Microsoft Access-Versionen konnten Sie die Funktionen CreateObject oder GetObject verwenden, um mit einer Variablen auf eine Instanz einer Komponente zu zeigen. In Microsoft Access für Windows 97 und Access 2000 können Sie auch das Schlüsselwort New verwenden, um eine neue Instanz bestimmter Komponenten zu erstellen. In der Dokumentation der jeweiligen Anwendung finden Sie Hinweise, welche Syntax jeweils unterstützt wird.

In Microsoft Access können Sie einen Verweis auf die Typbibliothek einer Komponente einrichten, um die Leistung zu steigern, wenn Sie mit dieser Anwendung über Automatisierung arbeiten. Microsoft Access enthält auch den Objektkatalog, ein Tool, mit dem Sie Objekte und ihre Methoden und Eigenschaften in Typbibliotheken anderer Anwendungen anzeigen können.

Die Microsoft Access-Typbibliothek stellt für andere Komponenten Informationen über Microsoft Access-Objekte bereit. Sie können in einer Komponente einen Verweis auf die Microsoft Access-Typbibliothek einstellen und deren Objekte im Objektkatalog anzeigen.

Wenn Sie Microsoft Access-Objekte über die Automatisierung bearbeiten möchten, erstellen Sie eine Instanz des Microsoft Access-Objekts Application. Nehmen Sie z.B. an, Sie möchten Daten von Microsoft Excel in einem Microsoft Access-Formular oder -Bericht anzeigen. Um Microsoft Access von Microsoft Excel aus starten zu können, erstellen Sie zuerst mit dem Schlüsselwort New eine Instanz des Microsoft Access-Objekts Application. Sie können auch die Funktion CreateObject verwenden, um eine neue Instanz des Microsoft Access-Objekts Application zu erstellen, oder Sie können mit der Funktion GetObject eine Objektvariable als Zeiger auf eine bestehende Instanz von Microsoft Access definieren. Überprüfen Sie die Dokumentation der Komponente, um zu ermitteln, welche Syntax sie unterstützt.

Wenn Sie eine Instanz von Microsoft Access gestartet haben und Microsoft Access-Objekte steuern möchten, öffnen Sie zuerst eine Datenbank (.mdb) oder ein Projekt (.adp) im Microsoft Access-Fenster. Hierzu verwenden Sie die OpenCurrentDatabase- oder die NewCurrentDatabase-Methode für eine Datenbank bzw. die OpenAccessProject- oder die NewAccessProject-Methode für ein Projekt.

Haben Sie Microsoft Access nur geöffnet, um die von Microsoft Access-DAO bereitgestellten Datenzugriffsobjekte zu verwenden, dann brauchen Sie im Microsoft Access-Fenster keine Datenbank zu öffnen. Sie können die Eigenschaft DBEngine des Microsoft Access-Objekts Application verwenden, um während einer Automatisierungsoperation auf Objekte in der Microsoft DAO 3.6-Objektbibliothek zuzugreifen.


 Verwenden von ActiveX Data-Objekten in Microsoft Access 2000

Verwenden von ActiveX Data-Objekten in Microsoft Access 2000

Microsoft Access 2000 enthält drei neue Objektmodelle, die Sie beim Erstellen, Warten und Verwalten Ihrer Access 2000-Datenbanken und der zugehörigen Daten mit Visual Basic verwenden können.

Microsoft ActiveX Data-Objekte (ADO)

ADO enthält die Objekte, die zum Erstellen, Pflegen und Löschen von Datensätzen in einer bestimmten Datenquelle erforderlich sind.

Microsoft ADO Ext. for DDL and Security (ADOX)

ADOX stellt die DDL (Data Definition Language)-Objekte bereit, die zum Erstellen einer neuen Datenbank und der darin enthaltenen Objekte zusätzlich zu den zum Verwalten der Zugriffsrechte benötigten Objekten erforderlich sind.

Microsoft Jet and Replication Objects 2.1 Library (JRO)

Da ADO-Objekte für die Zusammenarbeit mit vielen Datenbanken neben den Microsoft Jet-Datenbanken konzipiert wurden, wurde die Jet-spezifische Funktionalität in die JRO-Bibliothek verlagert.

Die folgende Liste listet die von jedem der neuen Objektmodelle bereitgestellten Funktionen im Vergleich zu DAO auf.

Funktion | DAO | ADO1 | ADOX2 | JRO (nur MDBs)
Erstellen von Datensatzgruppen | X | X |  |
Bearbeiten von Starteigenschaften | X | X** |  |
Unterstützung von ANSI92 SQL*** |  | X | X |
Erstellen von Tabellen | X |  | X |
Erstellen einer neuen Datenbank | X |  | X* |
Bearbeiten vorhandener Tabelleneigenschaften | X |  | X |
Erstellen von Tabellenbeziehungen | X |  | X* |
Erstellen neuer Benutzer/Gruppen | X |  | X |
Bearbeiten von Sicherheitseinstellungen | X |  | X* |
Unterstützung des neuen Jet 4.0-Datentyps Decimal |  |  | X |
Unterstützung des Attributs Compression für Spaltendaten |  |  | X |
Bearbeiten gespeicherter SQL-Standardabfragen oder -ansichten | X |  | X* |
Erstellen permanenter Abfragen, auf die nur über Code zugegriffen werden kann |  |  | X* |
Erstellen von Abfragen, auf die über Datenbankcontainer/UI und Code zugegriffen werden kann | X |  |  |
Komprimieren/Verschlüsseln von Datenbanken | X |  |  | X4
Aktualisieren des Cachespeichers | X |  |  | X
Datenbank replizierbar machen | X |  |  | X3
Erstellen von Datenbankreplikaten | X |  |  | X3
Synchronisieren von Replikaten | X |  |  | X3
Bearbeiten von Datenbankeigenschaften | X |  |  |
Erstellen benutzerdefinierter Datenbankeigenschaften | X |  |  |
Bearbeiten von Tabellenspalteneigenschaften | X |  |  |

* Nur verfügbar beim Arbeiten mit Microsoft Access-Datenbanken (.MDB). Zukünftige Versionen des SQL-Providers stellen diese Funktionalität möglicherweise auch in Microsoft Access-Projekten (.ADP) bereit.

** Nur verfügbar beim Arbeiten mit Access-Projekten.

*** Obwohl Jet ANSI 92 SQL teilweise unterstützt, ist es noch nicht vollständig ANSI92-kompatibel.

1 Verweist mit Hilfe des Connection-Objekts auf Datenbank

2 Verweist mit Hilfe des Catalog-Objekts auf Datenbank

3 Verweist mit Hilfe des Replica-Objekts auf Datenbank

4 Verweist mit Hilfe des JetEngine-Objekts auf Datenbank

Anmerkung Im Gegensatz zu DAO können ADO- and ADOX-Objekte die gekennzeichneten Aktionen in anderen Datenbanken als Jet-Datenbanken ausführen, sofern der Provider für diese Datenbanken die betreffende Aktion unterstützt.


 Kompatibilität der DAO-Objektbibliotheken

Kompatibilität der DAO-Objektbibliotheken

Microsoft Access 2000 stellt neue DAO-Objekte, -Methoden und -Eigenschaften zur Verfügung, die diejenigen der Versionen 1.x, 2.0 und 7.0 ersetzen. Sie müssen die älteren Sprachelemente, die von Microsoft Access 2000 nicht unterstützt werden, durch die von der DAO 3.6-Objektbibliothek zur Verfügung gestellten Elemente ersetzen.

Mit Hilfe der folgenden Tabelle können Sie die Objekte, Methoden und Eigenschaften, die nicht in der Microsoft DAO 3.6-Objektbibliothek enthalten sind, sowie die Features, die diese ersetzen, bestimmen. Mit den neuen Elementen in der zweiten Spalte können Sie Code, der in früheren Microsoft Access-Versionen geschrieben wurde, anpassen.

Beispiele zum Konvertieren von DAO-Code finden Sie in Beispiele zum Konvertieren von DAO-Code.

In DAO 3.6 nicht verfügbare Funktionalität | Empfohlene DAO 3.6-Ersetzungen
FreeLocks | Idle-Methode des DBEngine-Objekts (wird für Microsoft Access 2000-Datenbanken nicht benötigt)
SetDefaultWorkspace | Eigenschaften DefaultUser/ DefaultPassword des Objekts DBEngine
SetDataAccessOption | Eigenschaft IniPath des Objekts DBEngine
Datenbank.BeginTrans | Arbeitsbereich.BeginTrans
Datenbank.CommitTrans | Arbeitsbereich.CommitTrans
Datenbank.CreateDynaset | Datenbank.OpenRecordset vom Typ dbOpenDynaset
Datenbank.CreateSnapshot | Datenbank.OpenRecordset vom Typ dbOpenSnapshot
Datenbank.DeleteQueryDef | Methode Delete der Auflistung QueryDefs
Database.ExecuteSQL | Methode Datenbank.Execute und Eigenschaft Datenbank.RecordsAffected
Datenbank.ListTables | Auflistung Datenbank.TableDefs
Datenbank.OpenQueryDef | Auflistung Datenbank.QueryDefs
Datenbank.OpenTable | Datenbank.OpenRecordset vom Typ dbOpenTable
Datenbank.Rollback | Arbeitsbereich.Rollback
Methode ListFields der Table-, Dynaset- und Snapshot-Objekte | Auflistung Datensatzgruppe.Fields
Table.ListIndexes | Auflistung TableDef.Indexes
QueryDef.CreateDynaset | QueryDef.OpenRecordset
QueryDef.CreateSnapshot | QueryDef.OpenRecordset
QueryDef.ListParameters | Auflistung QueryDef.Parameters
Dynaset-Objekt | Recordset-Objekt vom Typ Dynaset
Snapshot-Objekt | Recordset-Objekt vom Typ Snapshot
Table-Objekt | Recordset-Objekt vom Typ Tabelle
Methode CreateDynaset der Dynaset- und QueryDef-Objekte | Datensatzgruppe.OpenRecordset mit Parameter dbOpenDynaset
Methode CreateSnapshot der Dynaset- und QueryDef-Objekte | Datensatzgruppe.OpenRecordset mit Parameter dbOpenSnapshot


 Verwenden von ODBCDirect mit Microsoft Access

Verwenden von ODBCDirect mit Microsoft Access

Was ist ODBCDirect?

ODBCDirect ist eine Technik, die das Arbeiten mit ODBC-Datenbank-Servern ermöglicht, ohne dass die Microsoft Jet-Datenbank-Engine geladen werden muss. ODBCDirect basiert auf dem Microsoft DAO 3.6-Objektmodell, so dass Sie bestehenden DAO-Code ganz einfach ändern können, um die Vorteile von ODBCDirect zu nutzen. Microsoft DAO 3.6 enthält neue Objekte, Methoden und Eigenschaften zur Unterstützung von ODBCDirect.

Vorteile des Zugriffs auf ODBC-Daten mit ODBCDirect

ODBCDirect bietet die folgenden Vorteile für ODBC-Operationen:

  • ODBCDirect macht Ihren Code schneller und effizienter, da der direkte Zugriff auf ODBC-Datenherkünfte ermöglicht wird. Da die Microsoft Jet-Datenbank-Engine nicht geladen werden muss, kommt ODBCDirect client-seitig mit weniger Ressourcen aus. Der ODBC-Server ist für die gesamte Abfrageverarbeitung zuständig.

  • ODBCDirect gestattet den erweiterten Zugriff auf server-spezifische Features, die bei Verwendung von ODBC über Microsoft Jet nicht verfügbar sind. Beispielsweise ermöglicht ODBCDirect für Server, die Cursor-Spezifikationen unterstützen, die Festlegung des Cursor-Ortes (lokal oder auf dem Server). Wenn Sie mit gespeicherten Prozeduren auf Serverebene arbeiten möchten, können Sie bei Verwendung von ODBCDirect Eingabewerte angeben und Rückgabewerte überprüfen, was mit Microsoft Jet nicht möglich ist.

  • ODBCDirect unterstützt auch asynchrone Abfragen. Wenn Sie eine Abfrage ausführen, brauchen Sie nicht auf die Beendigung der Abfrage zu warten, bevor Sie eine andere Operation ausführen können. Sie können die Ausführung der Abfrage mit Hilfe der Eigenschaft StillExecuting verfolgen.

  • ODBCDirect unterstützt die Stapelaktualisierung, so dass Änderungen von Recordset-Objekten zunächst lokal zwischengespeichert und später in einem Stapel an den Server abgesetzt werden können.

  • Mit ODBCDirect können Sie einfache cursorfreie Ergebnisgruppen, aber auch komplexe Cursor erstellen. Sie können auch Abfragen ausführen, die beliebig viele Ergebnisgruppen zurückgeben. Sie können die Anzahl der Rückgabezeilen einschränken und alle Meldungen und Fehler überwachen, die von der Ferndatenherkunft erzeugt werden, ohne hierbei die Ausführungsgeschwindigkeit der Abfrage zu beeinträchtigen.

Erstellen eines ODBCDirect-Arbeitsbereichs

Sie können einen ODBC-Arbeitsbereich erstellen, indem Sie im Argument Typ der Methode CreateWorkspace die Konstante dbUseODBC angeben. Sie können auch festlegen, dass ein ODBC-Arbeitsbereich standardmäßig erstellt wird, indem Sie die Eigenschaft DefaultType des Objekts DBEngine einstellen.

Sobald Sie einen ODBC-Arbeitsbereich erstellt haben, können Sie DAO-Objekte, -Eigenschaften und -Methoden verwenden, um die Daten auf dem ODBC-Datenbank-Server zu bearbeiten.

Vorteile des Zugriffs auf ODBC-Daten mit Microsoft Jet

Die Arbeitsbereiche von Microsoft Jet und ODBCDirect bieten unterschiedliche Funktionen, die sich gegenseitig ergänzen. Verwenden Sie einen Microsoft Jet-Arbeitsbereich, um auf .MDB-Dateien und ISAM-Datenformate, wie z.B. Text und Kalkulationstabellen, zuzugreifen. Microsoft Jet allein bietet die folgenden Features, die über ODBCDirect nicht verfügbar sind:

  • Aktualisierbare Verknüpfungen. Verwenden Sie einen Microsoft Jet-Arbeitsbereich, um Daten in Recordset-Objekten aktualisieren zu können, die auf Verknüpfungen mit mehreren Tabellen basieren.

  • Heterogene Verknüpfungen. Verwenden Sie einen Microsoft Jet-Arbeitsbereich, wenn Sie Tabellen in unterschiedlichen Datenherkünften verknüpfen möchten.

  • DDL-Operationen (Data Definition Language = Datendefinitionssprache). Verwenden Sie einen Microsoft Jet-Arbeitsbereich, wenn Sie DDL-Operationen mit Datenzugriffsobjekten (DAO) durchführen möchten. ODBCDirect bietet kein TableDef-Objekt, so dass Sie Tabellen nicht mit DAO erstellen oder ändern können. Sie können DDL-Operationen jedoch durchführen, indem Sie mit SQL DDL-Anweisungen mit Hilfe von ODBCDirect ausführen.

  • Anbindung von Formularen und Steuerelementen. Wenn Formulare oder Steuerelemente Ihrer Anwendung an Daten in einer ODBC-Datenherkunft gebunden werden sollen, verwenden Sie Microsoft Jet. Daten, auf die in einem ODBCDirect-Arbeitsbereich zugegriffen wird, können nicht an Formulare oder Steuerelemente gebunden werden.

Wenn Sie die aufgeführten Features nicht benötigen, können Sie einen ODBCDirect-Arbeitsbereich verwenden.

Anmerkung Sie können in Ihren Anwendungen sowohl Microsoft Jet- als auch ODBCDirect-Arbeitsbereiche definieren und in beliebiger Kombination verwenden. Beispielsweise können Sie in derselben Funktion einen Microsoft Jet-Arbeitsbereich definieren, um DDL-Operationen mit Hilfe von DAO durchzuführen, und daneben einen ODBCDirect-Arbeitsbereich definieren, um asynchrone Abfragen durchzuführen.


 Verwenden von Microsoft Access als DDE-Server

Verwenden von Microsoft Access als DDE-Server

Microsoft Access unterstützt dynamischen Datenaustausch (DDE) sowohl als Zielanwendung (Client) als auch als Quellanwendung (Server). Eine Anwendung wie Microsoft Word kann z.B. als Client Daten mittels DDE von einer Microsoft Access-Datenbank als Server abrufen.

Tipp Wenn Sie Microsoft Access-Objekte aus einer anderen Anwendung heraus bearbeiten möchten, bietet sich Automatisierung an.

Ein DDE-Datenaustausch zwischen einem Client und einem Server findet zu einem bestimmten Thema statt. Ein Thema kann entweder eine Datendatei in dem von der Server-Anwendung unterstützten Format oder das Thema System sein, welches Informationen über die Server-Anwendung selbst bereitstellt. Nachdem ein Datenaustausch zu einem bestimmten Thema begonnen hat, kann nur ein mit diesem Thema verbundenes Datenelement übertragen werden.

Wenn Sie z.B. in Microsoft Word arbeiten und Daten aus einer bestimmten Microsoft Access-Datenbank in ein Dokument einfügen möchten, leiten Sie einen DDE-Datenaustausch mit Microsoft Access ein, indem Sie einen DDE-Kanal mit der Funktion DDEInitiate öffnen und den Namen der Datenbankdatei als Thema angeben. Sie können dann diesen Kanal dazu verwenden, Daten von dieser Datenbank an Microsoft Word zu übertragen.

Die folgenden Themen werden von Microsoft Access als DDE-Server unterstützt:

  • Das Thema System

  • Der Name einer Datenbank (Thema Datenbank)

  • Der Name einer Tabelle (Thema Tabellenname)

  • Der Name einer Abfrage (Thema Abfragename)

  • Eine Microsoft Access SQL-Zeichenfolge (Thema SQLZeichenfolge)

Nachdem Sie einen DDE-Datenaustausch eingeleitet haben, können Sie die Anweisung DDEExecute dazu verwenden, einen Befehl von der Client- an die Server-Anwendung zu senden. Wenn Microsoft Access als DDE-Server verwendet wird, erkennt es die folgenden Befehle als gültig an:

  • Den Namen eines Makros in der aktuellen Datenbank

  • Jede Aktion, die Sie in Visual Basic mit einer Methode des Objekts DoCmd ausführen können.

  • Die Aktionen DatenbankÖffnen und DatenbankSchließen, die nur für DDE-Operationen verwendet werden. (Ein Beispiel zur Anwendung dieser Aktionen finden Sie weiter unten in diesem Thema.)

Anmerkung Wenn Sie eine Makroaktion als eine DDEExecute-Anweisung angeben, folgen die Aktion und alle Argumente der Syntax des Objekts DoCmd und werden in eckigen Klammern ([ ]) angegeben. Anwendungen, die DDE unterstützen, erkennen jedoch keine eingebauten Konstanten in DDE-Operationen. Außerdem werden Zeichenfolgenargumente, die ein Komma enthalten, in Anführungszeichen ("") angegeben. In anderen Fällen sind Anführungszeichen nicht notwendig.

Die Client-Anwendung kann die Funktion DDERequest dazu verwenden, Textdaten über einen geöffneten DDE-Kanal von der Server-Anwendung abzurufen. Außerdem kann der Client die Anweisung DDEPoke dazu verwenden, Daten an die Server-Anwendung zu senden. Nachdem die Datenübertragung beendet wurde, kann der Client die Anweisung DDETerminate zum Schließen des DDE-Kanals oder die Anweisung DDETerminateAll zum Schließen aller offenen Kanäle verwenden.

Anmerkung Wenn Ihre Client-Anwendung keine Daten über einen DDE-Kanal mehr empfängt, sollte sie diesen Kanal schließen, um Speicher-Ressourcen freizugeben.

Das folgende Beispiel zeigt, wie Sie eine Microsoft Word-Prozedur mit Visual Basic erstellen können, die Microsoft Access als DDE-Server verwendet. (Damit dieses Beispiel funktioniert, muss Microsoft Access geöffnet sein.)

Sub AccessDDE()
    Dim intChan1 As Integer, intChan2 As Integer
    Dim strQueryData As String

    ' Verwenden des Themas "System" zum Öffnen der Nordwind-Beispieldatenbank.
    ' Datenbank muß vor dem Verwenden anderer Themen geöffnet worden sein.
    intChan1 = DDEInitiate("MSAccess", "System")
    ' Passen Sie gegebenenfalls den Pfad so an, dass er auf den tatsächlichen
    'Speicherort der Nordwind-Datenbank in Ihrem System verweist.
    DDEExecute intChan1, "[OpenDatabase C:\Programme\Microsoft Office\Samples\Nordwind.mdb]"

    ' Alle Daten über die Abfrage "Die zehn teuersten Artikel" erhalten.
    intChan2 = DDEInitiate("MSAccess", "Nordwind.mdb;" _
        & "QUERY Die zehn teuersten Artikel")
    strQueryData = DDERequest(intChan2, "All")
    DDETerminate intChan2

    ' Datenbank schließen.
    DDEExecute intChan1, "[CloseDatabase]"
    DDETerminate intChan1

    ' Erhaltene Daten im Debug-Fenster ausgeben.
    Debug.Print strQueryData
End Sub

Informationen zur Verwendung von Microsoft Access als DDE-Client finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um Informationen anzuzeigen, wie Sie den Microsoft Office 2000/Visual Basic Programmierhandbuch bekommen können, klicken Sie auf [image] .

In den folgenden Abschnitten finden Sie Informationen über die gültigen, von Microsoft Access unterstützten DDE-Themen.

Das Thema System

Das Thema System ist ein Standardthema für alle auf Microsoft Windows basierenden Anwendungen. Es liefert Informationen zu den anderen von der Anwendung unterstützten Themen. Damit auf diese Informationen zugegriffen werden kann, muss Ihr Code zuerst die Funktion DDEInitiate mit "System" als Argument Thema abrufen und dann die Funktion DDERequest mit einer der folgenden Angaben für das Argument Element ausführen.

Element | Rückgabewert(e)
SysItems | Eine Liste von Elementen, die vom Thema System in Microsoft Access unterstützt werden
Formats | Eine Liste der Formate, die Microsoft Access in die Zwischenablage kopieren kann
Status | "Busy" oder "Ready"
Topics | Eine Liste aller geöffneten Datenbanken

Das folgende Beispiel zeigt die Verwendung der Funktionen DDEInitiate und DDERequest mit dem Thema System:

'In Visual Basic eine DDE-Konversation mit Microsoft Access initiieren.
Dim intChan1 As Integer, strResults As String
intChan1 = DDEInitiate("MSAccess", "System")
' Anfragen einer Liste der vom Thema System unterstützen Themen
strResults = DDERequest(intChan1, "SysItems")
' Ausführen der OpenDatabase-Aktion zum Öffnen der der Datenbank Nordwind.mdb.
' Passen Sie gegebenenfalls den Pfad so an, dass er auf den tatsächlichen
' Speicherort der Nordwind-Datenbank in Ihrem System verweist
DDEExecute intChan1, "[OpenDatabase C:\Programme\Microsoft Office\Samples\Nordwind.mdb]"

Das Thema Datenbank

Das Thema Datenbank ist der Dateiname einer vorhandenen Datenbank. Sie können entweder nur den Namen der Datenbank (Nordwind) oder den vollständigen Pfad mit der Erweiterung .MDB (C:\PROGRAMME\MICROSOFT OFFICE\ACCESS\BEISPIEL\NORDWIND.MDB) eingeben. Nachdem Sie den DDE-Datenaustausch mit der Datenbank eingeleitet haben, können Sie eine Liste aller Objekte in der Datenbank anfordern.

Anmerkung Sie können DDE nicht zum Abfragen der Microsoft Access Informationsdatei zu Arbeitsgruppen verwenden.

Das Thema Datenbank unterstützt die folgenden Elemente.

Element | Rückgabewert(e)
TableList | Eine Liste mit Tabellen
QueryList | Eine Liste mit Abfragen
FormList | Eine Liste mit Formularen
ReportList | Eine Liste mit Berichten
MacroList | Eine Liste mit Makros
ModuleList | Eine Liste mit Modulen
ViewList | Eine Liste mit Ansichten
StoredProcedureList | Eine Liste mit gespeicherten Prozeduren
DatabaseDiagramList | Eine Liste mit Datenbank-Diagrammen

Das folgende Beispiel zeigt, wie Sie das Formular Personal in der Nordwind-Beispieldatenbank mit einer Visual Basic-Prozedur öffnen können:

' In Visual Basic eine DDE-Konversation mit der
' Beispieldatenbank Nordwind einleiten
' Sicherstellen, dass die Datenbank geöffnet ist.
intChan2 = DDEInitiate("MSAccess", "Nordwind")
' Anfragen einer Liste der Formulare in der Beispieldatenbank Nordwind
strResponse = DDERequest(intChan2, "FormList")
' Ausführen der OpenForm-Aktion mit Argumenten zum Öffnen des Formulars Personal.
DDEExecute intChan2, "[OpenForm Personal,0,,,1,0]"

Die Themen TABLE Tabellenname, QUERY Abfragename und SQL SQLZeichenfolge

Diese Themen verwenden die folgende Syntax:

Datenbankname; TABLE Tabellenname

Datenbankname; QUERY Abfragename

Datenbankname; SQL [SQLZeichenfolge]

Argument | Beschreibung
Datenbankname | Der Name der Datenbank, zu der die Tabelle oder Abfrage gehört oder für die die SQL-Anweisung gilt, gefolgt von einem Semikolon (;). Der Datenbankname kann entweder nur der Name der Datenbank (Nordwind) oder der vollständige Pfad mit der Erweiterung .MDB (C:\PROGRAMME\MICROSOFT OFFICE\ACCESS\BEISPIEL\NORDWIND.MDB) sein.
Tabellenname | Der Name einer vorhandenen Tabelle
Abfragename | Der Name einer vorhandenen Abfrage
SQLZeichenfolge Eine gültige SQL-Anweisung mit maximal 256 Zeichen und einem Semikolon am Ende. Wenn Sie mehr als 256 Zeichen austauschen möchten, geben Sie dieses Argument nicht an, sondern erstellen stattdessen eine SQL-Anweisung mit einer Reihe von DDEPoke-Anweisungen.

Der folgende Visual Basic-Code verwendet z.B. die Anweisung DDEPoke, um eine SQL-Anweisung zu erstellen und dann das Ergebnis der Abfrage anzufordern.

intChan1 = DDEInitiate("MSAccess", "Nordwind;SQL")
DDEPoke intChan1, "SQLText", "SELECT *"
DDEPoke intChan1, "SQLText", " FROM Bestellungen"
DDEPoke intChan1, "SQLText", " WHERE [Frachtkosten] > 100;"
strResponse = DDERequest(intChan1, "NextRow")
DDETerminate intChan1

In der folgenden Tabelle sind die gültigen Elemente der Themen TABLE Tabellenname, QUERY Abfragename und SQL SQLZeichenfolge aufgeführt.

Element | Rückgabewert(e)
All | Alle Daten in der Tabelle, einschließlich Feldnamen
Data | Alle Zeilen mit Daten, ohne Feldnamen
FieldNames | Eine einzeilige Liste der Feldnamen
FieldNames;T | Eine zweizeilige Liste von Feldnamen (erste Zeile) und deren Datentypen (zweite Zeile)
Die folgende Liste enthält die Rückgabewerte und die Datentypen, die sie darstellen:
Wert | Datentyp
0 | Ungültig
1 | True/False (nicht-Null)
2 | Byte ohne Vorzeichen
3 | 2-Byte-Ganzzahl mit Vorzeichen (Integer)
4 | 4-Byte-Ganzzahl mit Vorzeichen (Long)
5 | 8-Byte-Ganzzahl mit Vorzeichen (Currency)
6 | 4-Byte Gleitkomma einfacher Genauigkeit (Single)
7 | 8-Byte Gleitkomma doppelter Genauigkeit (Double)
8 | Datum/Uhrzeit
9 | Binäre Daten, maximal 256 Bytes
10 | ANSI-Text, Groß- und Kleinschreibung nicht beachtet, maximal 256 Bytes (Text)
11 | Long Binary (OLE-Objekt)
12 | Long Text (Memo)
NextRow | Die Daten in der nächsten Zeile der Tabelle oder Abfrage. Beim Öffnen eines Kanals gibt NextRow die Daten in der ersten Zeile zurück. Wenn bei der Ausführung von NextRow die aktuelle Zeile der letzte Datensatz ist, schlägt die Anforderung fehl.
PrevRow | Die Daten der vorhergehenden Zeile der Tabelle oder Abfrage. Wenn PrevRow als erste Anforderung über einen neuen Kanal angegeben wird, werden die Daten der letzten Zeile der Tabelle oder Abfrage zurückgegeben. Ist der erste Datensatz die aktuelle Zeile, schlägt die Anforderung fehl.
FirstRow | Die Daten in der ersten Zeile einer Tabelle oder Abfrage
LastRow | Die Daten in der letzten Zeile einer Tabelle oder Abfrage
FieldCount | Die Anzahl der Felder in einer Tabelle oder Abfrage
SQLText | Eine SQL-Anweisung, die für die Tabelle oder Abfrage steht. Für Tabellen gibt dieses Element eine SQL-Anweisung in der Form "SELECT * FROM Tabelle;" zurück.
SQLText;n Eine SQL-Anweisung in Abschnitten mit jeweils n Zeichen, die die Tabelle oder Abfrage darstellt, wobei n eine Ganzzahl bis maximal 256 sein kann. Angenommen, für eine Abfrage wird die folgende SQL-Anweisung verwendet:
"SELECT * FROM Bestellungen;"

Das Element "SQLText;7" gibt dann die folgenden, durch Tabulatoren getrennten Abschnitte zurück:

"SELECT "
"* FROM "
"Bestellungen;"

Das folgende Beispiel zeigt, wie Sie DDE in einer Visual Basic-Prozedur verwenden können, um Daten aus einer Tabelle in der Nordwind-Beispieldatenbank abzurufen und diese in einer Textdatei einzufügen:

Sub NordwindDDE
    Dim intChan1 As Integer, intChan2 As Integer, intChan3 As Integer
    Dim strResp1 As Variant, strResp2 As Variant, strResp3 As Variant

    ' In einem Visual Basic-Modul Daten aus der Tabelle Kategorien,
    ' der Abfrage Artikel nach Kategorie und der Tabelle Bestellungen in der Datenbank Nordwind.mdb erhalten.
    ' Zunächst sicherstellen, dass die Datenbank geöffnet ist.
    intChan1 = DDEInitiate("MSAccess", "Nordwind;TABLE Kategorien")
    intChan2 = DDEInitiate("MSAccess", "Nordwind;QUERY Artikel nach Kategorie")
    intChan3 = DDEInitiate("MSAccess", "Nordwind;SQL SELECT * " _
        & "FROM Bestellungen " _
        & "WHERE [Bestell-Nr] > 10050;")

    strResp1 = DDERequest(intChan1, "All")
    strResp2 = DDERequest(intChan2, "FieldNames;T")
    strResp3 = DDERequest(intChan3, "FieldNames;T")
    DDETerminate intChan1
    DDETerminate intChan2
    DDETerminate intChan3

    ' Daten in eine Textdatei einfügen.
    Open "C:\DATEN.TXT" For Append As #1
    Print #1, strResp1
    Print #1, strResp2
    Print #1, strResp3
    Close #1
End Sub


Microsoft Access-Objekte

Application-Objekt

Legende

gelbes Feld Objekt und Auflistung
blaues Feld Nur Objekt

Pfeil nach rechts Klicken Sie auf den roten Pfeil, um das Schema zu erweitern


Verzeichnis der Visual Basic für Applikationen-Funktionen (Deutsch-Englisch)

Visual Basic für Applikationen ist die gemeinsame Programmiersprache aller Microsoft Office-Anwendungen. Sie müssen die englischen Visual Basic für Applikationen-Schlüsselwörter im Codefenster aller Office-Anwendungen verwenden. In Microsoft Access können Sie jedoch für die meisten Visual Basic für Applikationen-Funktionen auch den deutschen Namen in Ausdrücken von Abfragen, Formularen, Berichten und Makros einsetzen.

Anmerkung Um weitere Informationen über internationale Features zu erhalten, klicken Sie auf .

In den folgenden Tabellen werden die jeweiligen Entsprechungen der VBA-Funktionen sowohl in deutsch-englischer als auch in englisch-deutscher Reihenfolge aufgeführt.

Deutsch-Englisch

Deutscher Name | Englischer Name | Deutscher Name | Englischer Name
Abs | Abs | Oktal$ | Oct$
AktVerz | CurDir$ | QWurzel | Sqr
AktVerz$ | CurDir$ | Rechts | Right
ArcTan | Atn | Rechts$ | Right$
Asc | Asc | RechtsB | RightB
AscB | AscB | RechtsB$ | RightB$
Ausführen | Shell | RGB | RGB
Bereich | Partition | RGlätten | RTrim
BW | PV | RGlätten$ | RTrim$
Cos | Cos | RMZ | Pmt
DatAdd | DateAdd | Schalter | Switch
DatDiff | DateDiff | Sekunde | Second
DatSeriell | DateSerial | Sin | Sin
DatTeil | DatePart | Str | Str
Datum | Date | Str$ | Str$
Datum$ | Date$ | String | String
DatWert | DateValue | String$ | String$
DIA | SYD | StrVgl | StrComp
Eingabefeld | InputBox | Stunde | Hour
Exponential | Exp | Tag | Day
Farbe | QBColor | Tan | Tan
Fix | Fix | Teil | Mid
Format | Format | Teil$ | Mid$
Format$ | Format$ | TeilB | MidB
GDA | DDB | TeilB$ | MidB$
Glätten | Trim | Umgebung | Environ
Glätten$ | Trim$ | VarTyp | VarType
Großbst | UCase | Verz | Dir
Großbst$ | UCase$ | Verz$ | Dir$
Hex | Hex | Vorzchn | Sgn
Hex$ | Hex$ | Wählen | Choose
InStr | InStr | Wenn | IIF
InStrB | InStrB | Wert | Val
Int | Int | Wochentag | Weekday
IstDatum | IsDate | ZBoolean | CBool
IstLeer | IsEmpty | ZByte | CByte
IstNull | IsNull | Zchn | Chr
IstNumerisch | IsNumeric | Zchn$ | Chr$
Jahr | Year | ZchnB | ChrB
Jetzt | Now | ZchnB$ | ChrB$
KAPZ | PPmt | ZCurrency | CCur
Kleinbst | LCase | ZDate | CDate
Kleinbst$ | LCase$ | ZDouble | CDbl
Länge | Len | Zeit | Time
LängeB | LenB | Zeit$ | Time$
LeerZchn | Space | Zeitgeber | Timer
LeerZchn$ | Space$ | ZeitSeriell | TimeSerial
LGlätten | LTrim | ZeitSeriellStr | TimeValue
LGlätten$ | LTrim$ | ZINS | Rate
LIA | SLN | ZINSZ | IPmt
Links | Left | ZInteger | CInt
Links$ | Left$ | ZLong | CLng
LinksB | LeftB | ZSingle | CSng
LinksB$ | LeftB$ | ZString | CStr
Log | Log | ZVariant | CVar
Meldung | MsgBox | ZW | FV
Minute | Minute | ZZG | Rnd
Monat | Month | ZZR | NPer
Oktal | Oct |  |

Englisch-Deutsch

Englischer Name | Deutscher Name | Englischer Name | Deutscher Name
Abs | Abs | LenB | LängeB
Asc | Asc | Log | Log
AscB | AscB | LTrim | LGlätten
Atn | ArcTan | LTrim$ | LGlätten$
CBool | ZBoolean | Mid | Teil
CByte | ZByte | Mid$ | Teil$
CCur | ZCurrency | MidB | TeilB
CDate | ZDate | MidB$ | TeilB$
CDbl | ZDouble | Minute | Minute
Choose | Wahl | Month | Monat
Chr | Zchn | MsgBox | Meldung
Chr$ | Zchn$ | Now | Jetzt
ChrB | ZchnB | NPer | ZZR
ChrB$ | ZchnB$ | Oct | Oktal
CInt | ZInteger | Oct$ | Oktal$
CLng | ZLong | Partition | Bereich
Cos | Cos | Pmt | RMZ
CSng | ZSingle | PPmt | KAPZ
CStr | ZString | PV | BW
CurDir | AktVerz | QBColor | Farbe
CurDir$ | AktVerz$ | Rate | ZINS
CVar | ZVariant | RGB | RGB
Date | Datum | Right | Rechts
Date$ | Datum$ | Right$ | Rechts$
DateAdd | DatAdd | RightB | RechtsB
DateDiff | DatDiff | RightB$ | RechtsB$
DatePart | DatTeil | Rnd | ZZG
DateSerial | DatSeriell | RTrim | RGlätten
DateValue | DatWert | RTrim$ | RGlätten$
Day | Tag | Second | Sekunde
DDB | GDA | Sgn | Vorzchn
Dir | Verz | Shell | Ausführen
Dir$ | Verz$ | Sin | Sin
Environ | Umgebung | SLN | LIA
Exp | Exponential | Space | LeerZchn
Fix | Fix | Space$ | LeerZchn$
Format | Format | Sqr | QWurzel
Format$ | Format$ | Str | Str
FV | ZW | Str$ | Str$
Hex | Hex | StrComp | StrVgl
Hex$ | Hex$ | String | String
Hour | Stunde | String$ | String$
IIF | Wenn | Switch | Schalter
InputBox | Eingabefeld | SYD | DIA
InStr | InStr | Tan | Tan
InStrB | InStrB | Time | Zeit
Int | Int | Time$ | Zeit$
IPmt | ZINSZ | Timer | Zeitgeber
IsDate | IstDatum | TimeSerial | ZeitSeriell
IsEmpty | IstLeer | TimeValue | ZeitSeriellStr
IsNull | IstNull | Trim | Glätten
IsNumeric | IstNumerisch | Trim$ | Glätten$
LCase | Kleinbst | UCase | Großbst
LCase$ | Kleinbst$ | UCase$ | Großbst$
Left | Links | Val | Wert
Left$ | Links$ | VarType | VarTyp
LeftB | LinksB | Weekday | Wochentag
LeftB$ | LinksB$ | Year | Jahr
Len | Länge |  |


Verzeichnis der SQL-Aggregatfunktionen (Deutsch-Englisch)

In Microsoft Access können Sie den deutschen Namen der folgenden SQL-Aggregatfunktionen im Abfrageentwurfsbereich einsetzen. Sie müssen den englischen Namen in Aggregatausdrücken der SQL-Eigenschaft eines QueryDef-Objekts verwenden, oder wenn Sie ein Recordset-Objekt basierend auf einer SQL-Abfrage erstellen.

Anmerkung Um weitere Informationen über internationale Features zu erhalten, klicken Sie auf .

Deutscher Name | Englischer Name | Englischer Name | Deutscher Name
Anzahl Mittelwert StAbw, StAbwn Summe Varianz, Varianzen | Count Avg StDev, StDevP Sum Var, VarP | Avg Count StDev, StDevP Sum Var, VarP | Mittelwert Anzahl StAbw, StAbwn Summe Varianz, Varianzen


Aktionen, nach Aufgaben gruppiert

Die nachstehende Tabelle gruppiert Aktionen nach Aufgabenkategorien.

Kategorie | Aufgabe | Aktion
Daten in Formularen und Berichten | Daten einschränken | AnwendenFilter
 | Durch Daten bewegen | SuchenWeiter, SuchenDatensatz, GeheZuSteuerelement, GeheZuSeite, GeheZuDatensatz
Ausführung | Einen Befehl ausführen | AusführenBefehl
 | Microsoft Access beenden | Verlassen
 | Ein Makro, eine Prozedur oder eine Abfrage ausführen | ÖffnenAbfrage, AusführenCode, AusführenMakro, AusführenSQL
 | Eine andere Anwendung ausführen | AusführenAnwendung
 | Ausführung anhalten | AbbrechenEreignis, Verlassen, StoppAlleMakros, StoppMakro
Import/Export | Microsoft Access-Objekte an andere Anwendungen senden | AusgabeIn, SendenObjekt
 | Daten zwischen Microsoft Access und anderen Datenformaten übertragen | TransferDatenbank, TransferArbeitsblatt, TransferText
Objektbearbeitung | Ein Objekt kopieren, umbenennen oder speichern | KopierenObjekt, UmbenennenObjekt, Speichern
 | Ein Objekt löschen | LöschenObjekt
 | Ein Fenster verschieben oder die Fenstergröße ändern | Maximieren, Minimieren, Positionieren, Wiederherstellen
 | Ein Objekt öffnen oder schließen | Schließen, ÖffnenFormular, ÖffnenModul, ÖffnenAbfrage, ÖffnenBericht, ÖffnenTabelle, ÖffnenDatenzugriffsseite, ÖffnenDiagramm, ÖffnenGespeicherteProzedur, ÖffnenSicht
 | Ein Objekt drucken | ÖffnenFormular, ÖffnenAbfrage, ÖffnenBericht, ÖffnenGespeicherteProzedur, ÖffnenSicht, Drucken
 | Ein Objekt auswählen | AuswählenObjekt
 | Den Wert eines Feldes, eines Steuerelements oder einer Eigenschaft einstellen | SetzenWert
 | Daten oder den Bildschirm aktualisieren | AktualisierenObjekt, AktualisierenDaten, AnzeigenAlleDatensätze
Sonstige | Eine benutzerdefinierte Menüleiste, ein benutzerdefiniertes Kontextmenü, eine globale Menüleiste oder ein globales Kontextmenü erstellen | HinzufügenMenü
 | Den Status von Menüelementen in einer benutzerdefinierten oder globalen Menüleiste einstellen | SetzenMenüelement
 | Informationen am Bildschirm anzeigen | Echo, Sanduhr, Meldung, Warnmeldungen
 | Tastaturbefehle generieren | Tastaturbefehle
 | Die eingebaute oder benutzerdefinierte Befehlsleiste anzeigen oder ausblenden | EinblendenSymbolleiste
 | Einen Signalton ausgeben | Signalton


 AbbrechenEreignis-Aktion

AbbrechenEreignis-Aktion

Sie können die Aktion AbbrechenEreignis verwenden, um das Ereignis abzubrechen, auf Grund dessen Microsoft Access das Makro mit dieser Aktion ausgeführt hat. Der Makroname entspricht der Einstellung einer Ereigniseigenschaft, wie z. B. BeforeUpdate, OnOpen, OnUnload oder OnPrint.

Einstellung

Die Aktion AbbrechenEreignis verwendet keine Argumente.

Anmerkung

In einem Formular verwenden Sie die Aktion AbbrechenEreignis in der Regel in einem Makro zur Gültigkeitsüberprüfung einer Eingabe zusammen mit der Ereigniseigenschaft BeforeUpdate. Gibt ein Benutzer Daten in einem Steuerelement oder einem Datensatz ein, so führt Microsoft Access das Makro aus, bevor es die Daten zur Datenbank hinzufügt. Erfüllen die Daten die Gültigkeitsbedingungen in dem Makro nicht, so bricht die Aktion AbbrechenEreignis den Aktualisierungsvorgang ab, bevor er begonnen hat.

Häufig wird diese Aktion zusammen mit der Aktion Warnmeldung verwendet, um anzuzeigen, dass die eingegebenen Daten die Gültigkeitsbedingungen nicht erfüllen, und um Informationen über die korrekten Eingabedaten bereitzustellen.

Die folgenden Ereignisse können mit der Aktion AbbrechenEreignis abgebrochen werden:

ApplyFilter | Dirty | MouseDown
BeforeDelConfirm | Exit | NoData
BeforeInsert | Filter | Open
BeforeUpdate | Format | Print
DblClick | KeyPress | Unload
Delete |  |

Anmerkung Sie können die Aktion AbbrechenEreignis zusammen mit dem Ereignis MouseDown nur verwenden, um das Ereignis abzubrechen, das beim Klicken mit der rechten Maustaste auf ein Objekt auftritt.

Gibt die Ereigniseigenschaft OnDblClick eines Steuerelements ein Makro an, das die Aktion AbbrechenEreignis enthält, so bricht die Aktion das Ereignis DblClick ab.

Bei Ereignissen, die abgebrochen werden können, tritt das Standardverhalten für das Ereignis (also die normale Reaktion von Microsoft Access auf das Ereignis) ein, sobald das Makro für das Ereignis ausgeführt wird. Das gibt Ihnen die Möglichkeit, das Standardverhalten abzubrechen. Wenn Sie z. B. in einem Textfeld auf das Wort doppelklicken, auf dem sich die Einfügemarke befindet, markiert Microsoft Access dieses Wort normalerweise. Sie können das Standardverhalten im Makro für das Ereignis DblClick abbrechen und eine andere Aktion ausführen, z. B. ein Formular mit Informationen zu den Daten im Textfeld öffnen. Bei Ereignissen, die nicht abgebrochen werden können, tritt das Standardverhalten für das Ereignis ein, bevor das Makro ausgeführt wird.

Anmerkung Gibt die Ereigniseigenschaft OnUnload eines Formulars ein Makro an, das die Aktion AbbrechenEreignis ausführt, so können Sie das Formular nicht schließen. Korrigieren Sie hierzu entweder den Zustand, der die Aktion AbbrechenEreignis ausgelöst hat, oder öffnen Sie das Makro und löschen die Aktion AbbrechenEreignis. Handelt es sich um ein gebundenes Formular, so können Sie das Makro nicht öffnen.

Zum Ausführen der Aktion AbbrechenEreignis in Visual Basic verwenden Sie die CancelEvent-Methode des DoCmd-Objekts.


 AktualisierenDaten-Aktion

AktualisierenDaten-Aktion

Sie können die Aktion AktualisierenDaten verwenden, um die Daten in einem Steuerelement des aktiven Objekts durch erneutes Abfragen der Herkunft des Steuerelements zu aktualisieren. Ist kein Steuerelement angegeben, so fragt die Aktion die Herkunft des Objekts selbst ab. Verwenden Sie diese Aktion, um sicherzustellen, dass das aktive Objekt oder eines seiner Steuerelemente die aktuellen Daten anzeigt.

Einstellung

Die Aktion AktualisierenDaten verwendet das folgende Argument.

Aktionsargument | Beschreibung
Steuerelementname | Der Name des zu aktualisierenden Steuerelements. Geben Sie den Steuerelementnamen im Bereich Aktionsargumente des Makrofensters im Feld Steuerelementname ein. Geben Sie nur den Namen des Steuerelements an, nicht den ausführlichen Bezeichner (wie z. B. Formulare!Formularname!Steuerelementname). Lassen Sie dieses Argument leer, um die Herkunft des aktiven Objekts zu aktualisieren. Ist das aktive Objekt ein Datenblatt oder ein Abfrage-Ergebnis, so lassen Sie dieses Argument leer.

Anmerkung

Die Aktion AktualisierenDaten führt eine der folgenden Operationen aus:

  • Zurückgeben der Abfrage, auf der das Steuerelement oder Objekt basiert.

  • Anzeigen der neuen und veränderten Datensätze, und Entfernen der gelöschten Datensätze aus der Tabelle, auf der das Steuerelement oder das Objekt basiert.

Anmerkung Die Aktion AktualisierenDaten hat keinen Einfluss auf die Position des Datensatzzeigers.

Folgende Steuerelemente basieren auf einer Abfrage oder Tabelle:

  • Listenfelder und Kombinationsfelder.

  • Unterformular-Steuerelemente.

  • OLE-Objekte, z. B. Diagramme.

  • Steuerelemente, die Aggregatfunktionen für Domänen enthalten, wie DSum.

Basiert das angegebene Steuerelement nicht auf einer Abfrage oder Tabelle, so löst diese Aktion eine Neuberechnung des Steuerelements aus.

Wenn Sie für das Argument Steuerelementname keinen Wert eingeben, hat die Aktion AktualisierenDaten dieselbe Wirkung wie das Drücken von UMSCHALT+F9, wenn das Objekt über den Fokus verfügt. Verfügt ein Unterformular-Steuerelement über den Fokus, so fragt diese Aktion lediglich die Herkunft des Unterformulars erneut ab (wie beim Drücken von UMSCHALT+F9 auch).

Anmerkung Die Aktion AktualisierenDaten fragt die Herkunft des Steuerelements oder des Objekts erneut ab. Im Gegensatz dazu aktualisiert die Aktion AktualisierenObjekt Steuerelemente im angegebenen Objekt, ohne jedoch die Datenbank erneut abzufragen oder neue Datensätze anzuzeigen. Die Aktion AnzeigenAlleDatensätze fragt nicht nur das aktive Objekt erneut ab, sondern entfernt auch alle zugewiesenen Filter (im Gegensatz zur Aktion AktualisierenDaten).

Wenn Sie ein Steuerelement erneut abfragen möchten, das sich nicht im aktiven Objekt befindet, verwenden Sie die Requery-Methode in Visual Basic und nicht die Aktion AktualisierenDaten oder die entsprechende Requery-Methode des DoCmd-Objekts. Die Requery-Methode in Visual Basic ist schneller als die Aktion AbfragenDaten oder die Requery-Methode des DoCmd-Objekts. Außerdem schließt Microsoft Access die Abfrage und lädt sie erneut von der Datenbank, wenn Sie die Aktion AktualisierenDaten oder die Methode Requery des DoCmd-Objekts verwenden. Wenn Sie dagegen die Methode Requery verwenden, führt Microsoft Access die Abfrage erneut aus, ohne sie zu schließen und erneut zu laden. Beachten Sie, dass die ActiveX Data Object (ADO)-Methode Requery genauso funktioniert, wie die Microsoft Access-Methode Requery.


 AktualisierenObjekt-Aktion

AktualisierenObjekt-Aktion

Mit der Aktion AktualisierenObjekt können Sie alle anstehenden Bildschirmaktualisierungen für ein angegebenes Datenbankobjekt oder (wenn keines angegeben wird) das aktive Datenbankobjekt ausführen. In diese Aktualisierungen werden alle anstehenden Neuberechnungen für Steuerelemente des Objekts einbezogen.

Einstellung

Die Aktion AktualisierenObjekt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des Objekts, das Sie aktualisieren möchten. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Objekttyp auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Diagramm oder Gespeicherte Prozedur. Lassen Sie dieses Argument leer, um das aktive Objekt auszuwählen.
Objektname | Der Name des zu aktualisierenden Objekts. Das Feld Objektname zeigt alle in der Datenbank vorhandenen Objekte des mit dem Argument Objekttyp ausgewählten Typs an. Wenn Sie das Argument Objekttyp leer lassen, lassen Sie dieses Argument ebenfalls leer.

Anmerkungen

Microsoft Access wartet mit der Ausführung von anstehenden Bildschirmaktualisierungen, bis andere Aufgaben beendet wurden. Mit dieser Aktion können Sie die sofortige Aktualisierung der Steuerelemente des angegebenen Objekts erzwingen. Sie können die Aktion AktualisierenObjekt in folgenden Situationen verwenden:

  • Wenn Sie mit der Aktion SetzenWert in mehreren Steuerelementen Werte ändern. Microsoft Access kann die Änderungen möglicherweise nicht sofort anzeigen. Dies trifft besonders dann zu, wenn andere Steuerelemente (z. B. berechnete Steuerelemente) von Werten der geänderten Steuerelemente abhängig sind.

  • Wenn Sie sicherstellen möchten, dass das momentan angezeigte Formular Daten in allen Steuerelementen anzeigt. Beispielsweise zeigen Steuerelemente mit OLE-Objekten ihre Daten häufig nicht sofort nach dem Öffnen eines Formulars an.

Anmerkungen

  • Diese Aktion bewirkt keine erneute Abfrage der Datenbank und zeigt deshalb keine neuen oder geänderten Datensätze an oder entfernt gelöschte Datensätze aus der dem Objekt zugrunde liegenden Tabelle oder Abfrage. Verwenden Sie für eine erneute Abfrage der Datenquelle des Objekts oder eines seiner Steuerelemente die Aktion AktualisierenDaten. Verwenden Sie die Aktion AnzeigenAlleDatensätze, um die aktuellsten Datensätze anzuzeigen und alle zugewiesenen Filter zu entfernen.

  • Die Aktion AktualisierenObjekt bewirkt nicht dasselbe wie die Auswahl des Befehls Jetzt aktualisieren aus dem Menü Datensätze. Dieser zeigt alle Änderungen an, die an den momentan angezeigten Datensätzen in Formularen und Datenblättern vorgenommen wurden.

Zum Ausführen der Aktion AktualisierenObjekt in Visual Basic verwenden Sie die RepaintObject-Methode des DoCmd-Objekts.


 AnwendenFilter-Aktion

AnwendenFilter-Aktion

Sie können die Aktion AnwendenFilter verwenden, um einen Filter, eine Abfrage oder eine SQL-WHERE-Klausel auf eine Tabelle, ein Formular oder einen Bericht anzuwenden. Dadurch können Sie die Datensätze einer Tabelle bzw. der dem Formular oder Bericht zugrunde liegenden Tabelle oder Abfrage einschränken oder sortieren. Bei Berichten können Sie diese Aktion nur in einem Makro verwenden, das durch die Ereigniseigenschaft OnOpen des Berichts festgelegt wird.

Anmerkung Sie können diese Aktion nur dann zum Anwenden einer SQL-WHERE-Klausel verwenden, wenn Sie einen Serverfilter benutzen. Die Verwendung eines Serverfilters bei gespeicherten Prozedur-Datensatzquellen ist nicht möglich.

Einstellung

Die Aktion AnwendenFilter verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Filtername | Der Name eines Filters oder einer Abfrage, der/die die Datensätze einer Tabelle, eines Formulars oder eines Berichts einschränkt oder sortiert. Sie können auch den Namen einer existierenden Abfrage oder eines Filters, der als Abfrage gespeichert wurde, im Abschnitt Aktionsargumente des Makrofensters im Feld Filtername eingeben.
 | Anmerkung Wenn Sie diese Aktion zum Benutzen eines Serverfilters verwenden, muss das Argument Filtername leer sein.
Bedingung | Eine gültige SQL-WHERE-Klausel (ohne das Wort WHERE) oder ein Ausdruck, der die Datensätze der Tabelle, des Formulars oder des Berichts einschränkt.
 | Anmerkung Auf der linken Seite eines Ausdrucks der WHERE-Bedingung steht in der Regel ein Feldname der zugrunde liegenden Tabelle oder Abfrage für das Formular oder den Bericht. Auf der rechten Seite des Ausdrucks stehen in der Regel die Kriterien, die Sie auf dieses Feld anwenden möchten, um Datensätze einzuschränken oder zu sortieren. Als Kriterium kann z.B. der Name eines Steuerelements in einem anderen Formular dienen, das den Wert enthält, mit dem die Datensätze im ersten Formular übereinstimmen sollen. Der Name des Steuerelements muss vollständig angegeben werden, wie z.B.: Formulare!Formularname!Steuerelementname. Feldnamen sollten zwischen doppelte und Zeichenfolgenliterale zwischen einfache Anführungszeichen gesetzt werden.
 | Das Argument Bedingung darf bis zu 256 Zeichen lang sein. Ist es notwendig, eine längere SQL-WHERE-Klausel einzugeben, verwenden Sie die ApplyFilter-Methode des DoCmd-Objekts in Visual Basic. In Visual Basic können SQL-Anweisungen mit WHERE-Klauseln bis zu 32.768 Zeichen lang sein.
Filtertyp | Gibt an, ob die Suche formatierte Daten beinhaltet. Klicken Sie auf Normal (Microsoft Access sucht so nach Daten, wie sie formatiert sind und im Feld angezeigt werden) oder auf Server (Microsoft Access sucht so nach Daten, wie sie in der Datenbank gespeichert sind. Dies entspricht nicht immer der Anzeige). Die Standardeinstellung lautet Normal.

Anmerkung Sie können das Argument Filtername verwenden, wenn Sie bereits einen Filter definiert haben, der die passenden Daten bereitstellt. Sie können das Argument Bedingung verwenden, um die einschränkenden Kriterien direkt einzugeben. Verwenden Sie beide Argumente, so wendet Microsoft Access die WHERE-Klausel auf das Ergebnis des Filters an. Sie müssen mindestens ein Argument verwenden.

Anmerkung

Sie können einen Filter oder eine Abfrage auf ein Formular in der Formularansicht oder Datenblattansicht anwenden.

Der Filter und die WHERE-Bedingung, die Sie anwenden, wird als Einstellung der Filter-Eigenschaft oder der ServerFilter-Eigenschaft des Formulars oder Berichts übernommen.

Bei Tabellen und Formularen ist diese Aktion mit dem Klicken auf Filter anwenden oder auf Serverfilter anwenden im Menü Datensätze oder dem Klicken auf Filter anwenden [image] oder auf Serverfilter anwenden [image] in der Symbolleiste vergleichbar. Der Menübefehl oder die Schaltfläche wendet den zuletzt erstellten Filter auf die Tabelle oder das Formular an, während die Aktion AnwendenFilter einen bestimmten Filter oder eine bestimmte Abfrage anwendet.

Wenn Sie in einer Microsoft Access-Datenbank (.MDB) im Menü Datensätze auf Filter zeigen und dann nach dem Ausführen der Aktion Filter anwenden auf Spezialfilter/-sortierung klicken, zeigt das Fenster Spezialfilter/-sortierung die zusammen mit dieser Aktion ausgewählten Kriterien an.

Wenn Sie einen Filter entfernen und alle Datensätze für eine Tabelle oder ein Formular in einer Access-Datenbank anzeigen, können Sie die Aktion AnzeigenAlleDatensätze, den Befehl Filter/Sortierung entfernen aus dem Menü Datensätze oder Filter entfernen [image] aus der Symbolleiste verwenden. Zum Entfernen eines Filters aus einem Microsoft Access-Projekt (.ADP) können Sie zum Fenster Formularbasierter Serverfilter wechseln und alle Filterkriterien entfernen. Anschließend klicken Sie im Menü Datensätze oder in der Symbolleiste auf Serverfilter anwenden oder legen für die ServerFilterByForm-Eigenschaft die Einstellung Falsch (0) fest.

Wenn Sie eine Tabelle oder ein Formular speichern, speichert Microsoft Access alle momentan in diesem Objekt definierten Filter, wendet den Filter jedoch nicht automatisch beim nächsten Öffnen des Objekts an (im Gegensatz dazu werden alle Sortierungen angewendet, die Sie vor dem Speichern auf das Objekt angewendet haben). Soll ein Filter beim ersten Öffnen eines Formulars automatisch angewendet werden, so geben Sie ein Makro an, das die Aktion AnwendenFilter verwendet, oder eine Ereignisprozedur, welche die Methode ApplyFilter des Objekts DoCmd als Einstellung der Ereigniseigenschaft OnOpen des Formulars verwendet. Sie können einen Filter auch anwenden, indem Sie die Aktionen ÖffnenFormular oder ÖffnenBericht oder die entsprechenden Methoden verwenden. Soll ein Filter automatisch angewendet werden, wenn eine Tabelle das erste Mal geöffnet wird, so können Sie die Tabelle mit einem Makro öffnen, das unmittelbar nacheinander die Aktionen ÖffnenTabelle und AnwendenFilter enthält.


 AnzeigenAlleDatensätze-Aktion

AnzeigenAlleDatensätze-Aktion

Sie können die Aktion AnzeigenAlleDatensätze verwenden, um alle zugewiesenen Filter aus der aktiven Tabelle, der Abfrage-Ergebnisgruppe oder dem Formular zu entfernen und um alle Datensätze in der Tabelle oder Ergebnisgruppe bzw. alle Datensätze der dem Formular zugrunde liegenden Tabelle oder Abfrage anzuzeigen.

Einstellung

Die Aktion AnzeigenAlleDatensätze verwendet keine Argumente.

Anmerkung

Sie können mit dieser Aktion sicherstellen, dass alle Datensätze (einschließlich aller veränderten oder neuen Datensätze) einer Tabelle, einer Abfrageergebnisgruppe oder eines Formulars angezeigt werden. Diese Aktion bewirkt ein erneutes Abfragen der Datensätze in einem Formular oder Unterformular.

Sie können diese Aktion auch verwenden, um alle Filter zu entfernen, die mit der Aktion AnwendenFilter, dem Befehl Filter anwenden im Menü Datensätze oder den Argumenten Filtername oder Bedingung der Aktion ÖffnenFormular zugewiesen wurden.

Diese Aktion hat dieselbe Wirkung wie das Klicken auf Filter/Sortierung entfernen im Menü Datensätze oder das Klicken auf Filter entfernen [image] in der Symbolleiste in der Formularansicht oder Datenblattansicht.

Zum Ausführen der Aktion AnzeigenAlleDatensätze in Visual Basic verwenden Sie die ShowAllRecords-Methode des DoCmd-Objekts.


 AusführenAnwendung-Aktion

AusführenAnwendung-Aktion

Sie können die Aktion AusführenAnwendung verwenden, um eine auf Windows oder MS-DOS basierende Anwendung wie Microsoft Excel, Microsoft Word oder Microsoft PowerPoint aus Microsoft Access heraus auszuführen. Auf diese Weise können Sie z. B. ein Microsoft Excel-Tabellenblatt in Ihre Microsoft Access-Datenbank einfügen.

Einstellung

Die Aktion AusführenAnwendung verwendet das folgende Argument.

Aktionsargument | Beschreibung
Befehlszeile | Die zum Start der Anwendung verwendete Befehlszeile (einschließlich des Pfadnamens und aller anderen benötigten Parameter, z. B. Schalter, welche die Anwendung in einem bestimmten Modus ausführen). Geben Sie die Befehlszeile im Bereich Aktionsargumente des Makrofensters im Feld Befehlszeile ein. Dieses Argument ist erforderlich.

Anmerkung

Die mit dieser Aktion ausgewählte Anwendung wird geladen und im Vordergrund ausgeführt. Das Makro, das diese Aktion enthält, wird weiterhin ausgeführt.

Sie können Daten zwischen der anderen Anwendung und Microsoft Access mit Hilfe von Microsoft Windows DDE (dynamischer Datenaustausch) oder über die Zwischenablage übertragen. Mit der Aktion Tastaturbefehle können Sie Tastenanschläge an die andere Anwendung senden (obwohl DDE die wesentlich effizientere Methode zur Übertragung von Daten darstellt). Sie können auf Daten in mehreren Anwendungen auch mit Hilfe der Automatisierung (früher unter der Bezeichnung "OLE-Automatisierung" bekannt) gemeinsam zugreifen.

Auf MS-DOS basierende Anwendungen werden in einem MS-DOS-Fenster innerhalb der Windows-Umgebung ausgeführt.

In Windows 98 bestehen mehrere Möglichkeiten, eine Anwendung zu starten: Starten des Programms aus dem Windows Explorer durch Verwenden des Befehls Ausführen aus dem Menü Start und Doppelklicken auf ein Programmsymbol auf dem Windows-Desktop.

Sie können die Aktion AusführenAnwendung nicht in Visual Basic ausführen. Verwenden Sie stattdessen die Visual Basic-Funktion Shell.


 AusführenBefehl-Aktion

AusführenBefehl-Aktion

Mit Hilfe der Aktion AusführenBefehl können Sie einen eingebauten Microsoft Access-Befehl ausführen. Der Befehl kann in einer Microsoft Access-Menüleiste oder -Symbolleiste oder in einem Microsoft Access-Kontextmenü angezeigt werden.

Einstellung

Die Aktion AusführenBefehl verwendet das folgende Aktionsargument.

Aktionsargument | Beschreibung
Befehl | Name des Befehls, den Sie ausführen möchten. Das Feld Befehl zeigt die in Microsoft Access verfügbaren eingebauten Befehle in alphabetischer Reihenfolge an. Dieses Argument ist notwendig.

Anmerkung

In Microsoft Access 97 ersetzte die Aktion AusführenBefehl die Aktion AusführenMenübefehl. Wenn Sie ein Makro aus einer früheren Version von Microsoft Access öffnen und speichern, das eine Aktion AusführenMenübefehl enthält, werden die Aktion und ihre Aktionsargumente automatisch in die entsprechende Aktion AusführenBefehl konvertiert. Die Aktion AusführenMenübefehl wird in der Liste der Aktionen im Makrofenster nicht mehr angezeigt.

Mit Hilfe der Aktion AusführenBefehl können Sie einen Microsoft Access-Befehl von einer benutzerdefinierten Menüleiste, einer globalen Menüleiste, einem benutzerdefinierten Kontextmenü oder einem globalen Kontextmenü aus ausführen. Im Allgemeinen ist es jedoch einfacher, das Dialogfeld Anpassen zum Hinzufügen von Microsoft Access-Befehlen zu benutzerdefinierten Menüs und Kontextmenüs zu verwenden. Dieses ist verfügbar, wenn Sie im Menü Ansicht auf Symbolleisten zeigen und dann auf Anpassen klicken. Die Registerkarte Befehle im Dialogfeld Anpassen listet die eingebauten Microsoft Access-Befehle auf, die in den Microsoft Access-Symbolleisten und -Menüs angezeigt werden.

Sie können die Aktion AusführenBefehl in einem Makro mit bedingten Ausdrücken verwenden, um einen Befehl in Abhängigkeit von bestimmten Bedingungen auszuführen.

Anmerkung Das Microsoft Access 2000-Menü Datei zeigt die zuletzt verwendeten Datenbanken an. Sie können statt auf Öffnen direkt auf eine dieser Datenbanken klicken. Diese Datenbanken werden im Dropdownlistenfeld für das Argument Befehl nicht angezeigt, und sind auch nicht bei Verwendung der Aktion AusführenBefehl in einem Makro verfügbar.

Wenn Sie eine Microsoft Access-Datenbank von einer früheren Version von Microsoft Access konvertieren, sind einige Befehle unter Umständen nicht mehr verfügbar. Ein Befehl kann umbenannt oder in ein anderes Menü verschoben worden sein, oder er steht in Microsoft Access 2000 nicht mehr zur Verfügung. Die Aktionen vom Typ AusführenMenübefehl für solche Befehle können nicht in Aktionen vom Typ AusführenBefehl konvertiert werden. Wenn Sie das Makro öffnen, zeigt Microsoft Access für solche Befehle eine Aktion AusführenBefehl mit einem leeren Argument Befehl an. Bearbeiten Sie das Makro, indem Sie ein gültiges Befehlsargument eingeben, oder löschen Sie die Aktion AusführenBefehl.

Zum Ausführen der Aktion AusführenBefehl in Visual Basic verwenden Sie die RunCommand-Methode des Application-Objekts. (Dies entspricht der RunCommand-Methode des DoCmd-Objekts.)


 AusführenCode-Aktion

AusführenCode-Aktion

Sie können die Aktion AusführenCode verwenden, um eine Visual Basic-Funktion aufzurufen.

Einstellung

Die Aktion AusführenCode verwendet das folgende Argument.

Aktionsargument | Beschreibung
Funktionsname | Der Name der aufzurufenden Visual Basic-Funktion. Geben Sie Funktionsargumente in Klammern ein. Geben Sie den Funktionsnamen im Bereich Aktionsargumente des Makrofensters im Feld Funktionsname ein. Dieses Argument ist erforderlich. Anmerkung In einer Microsoft Access-Datenbank (.MDB) klicken Sie auf die Schaltfläche Aufbauen, [image] um den Ausdrucks-Generator zum Auswählen einer Funktion für dieses Argument zu starten. Die Funktion wählen Sie rechts vom Feld Funktionsname aus. Klicken Sie in der Liste des Ausdrucks-Generators auf die gewünschte Funktion.

Anmerkung

Die benutzerdefinierten Funktionen werden in Microsoft Access-Modulen gespeichert.

Geben Sie die Klammern auch dann an, wenn die Funktion wie im folgenden Beispiel über keine Argumente verfügt.

TestFunktion()

Im Gegensatz zu benutzerdefinierten Funktionsnamen, die für Einstellungen von Ereigniseigenschaften verwendet werden, beginnt der Funktionsname im Argument Funktionsname nicht mit einem Gleichheitszeichen (=).

Microsoft Access ignoriert den Rückgabewert der Funktion.

Anmerkung Sie können eine Function-Prozedur nicht aus einem Makro aufrufen, wenn der Funktionsname mit dem Namen des Moduls identisch ist.

Tipp Damit Sie eine in Visual Basic geschriebene Sub-Prozedur oder Ereignisprozedur ausführen können, erstellen Sie eine Funktion, die die Sub-Prozedur oder Ereignisprozedur aufruft. Führen Sie dann die Funktion mit Hilfe der Aktion AusführenCode aus.

Wenn Sie eine Funktion mit Hilfe der Aktion AusführenCode aufrufen, sucht Microsoft Access die im Argument Funktionsname angegebene Funktion in den Standardmodulen der Datenbank. Wenn diese Aktion allerdings als Reaktion auf das Klicken auf einen Menübefehl in einem Formular oder Bericht oder das Auftreten eines Ereignisses in einem Formular oder Bericht ausgeführt wird, sucht Microsoft Access die Funktion zuerst im Klassenmodul des Formulars- oder Berichts und erst dann in den Standardmodulen. Microsoft Access sucht die im Argument Funktionsname angegebene Funktion nicht in den Klassenmodulen, die in der Registerkarte Module im Datenbankfenster angezeigt wird.

Diese Aktion ist in Visual Basic nicht verfügbar. Führen Sie die gewünschte Funktion direkt in Visual Basic aus.


 AusführenMakro-Aktion

AusführenMakro-Aktion

Sie können die Aktion AusführenMakro zum Ausführen eines Makros verwenden. Das Makro kann sich in einer Makrogruppe befinden.

Sie können diese Aktion wie folgt verwenden:

  • Zum Ausführen eines Makros aus einem anderen Makro.

  • Zum Ausführen eines Makros abhängig von einem bestimmten Zustand.

  • Zum Zuordnen eines Makros zu einem benutzerdefinierten Menübefehl.

Einstellung

Die Aktion AusführenMakro verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Makroname | Der Name des auszuführenden Makros. Das Feld Makroname im Bereich Aktionsargumente des Makrofensters zeigt alle Makros (und Makrogruppen) in der aktuellen Datenbank an. Befindet sich das Makro in einer Makrogruppe, so ist es unter dem Markrogruppennamen in der Liste als Makrogruppenname.Makroname aufgelistet. Dieses Argument ist erforderlich.
 | Wenn Sie ein Makro, das die Aktion AusführenMakro enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access in der Bibliotheksdatenbank und nicht in der aktuellen Datenbank nach einem Makro mit diesem Namen.
Wiederholungen | Gibt an, wie oft das Makro maximal ausgeführt wird. Wenn dieses Argument leer bleibt (und das Argument Wiederholbedingung auch leer ist), wird das Makro nur einmal ausgeführt.
Wiederholbedingung | Ein Ausdruck, der als Wahr (-1) oder Falsch (0) ausgewertet wird. Das Makro wird angehalten, wenn der Ausdruck den Wert Falsch ergibt. Der Ausdruck wird bei jedem Ausführen des Makros ausgewertet.

Anmerkung

Wenn Sie einen Makrogruppennamen für das Argument Makroname eingeben, führt Microsoft Access das erste Makro in der Makrogruppe aus.

Diese Aktion ist mit dem Klicken auf Makro im Menü Extras vergleichbar, mit dem Sie ein bestimmtes Makro auswählen und ausführen können. Der Befehl führt das Makro jedoch nur einmal aus, während die Aktion AusführenMakro ein Makro beliebig oft ausführen kann.

Tipp Sie können mit den Argumenten Wiederholungen und Wiederholbedingung angeben, wie oft ein Makro ausgeführt werden soll:

  • Lassen Sie beide Argumente leer, wird das Makro einmal ausgeführt.

  • Geben Sie eine Zahl für Wiederholungen ein, lassen jedoch Wiederholbedingung leer, so wird das Makro so oft ausgeführt, wie durch die Zahl angegeben.

  • Lassen Sie Wiederholungen leer, geben aber einen Ausdruck für Wiederholbedingung ein, so wird das Makro so oft ausgeführt, bis der Ausdruck den Wert Falsch ergibt.

  • Geben Sie Werte für beide Argumente ein, so wird das Makro so oft ausgeführt, wie durch die Zahl in Wiederholungen angegeben, oder bis Wiederholbedingung den Wert Falsch ergibt, je nachdem, welcher Fall zuerst eintritt.

Wenn Sie ein Makro ausführen, das die Aktion AusführenMakro enthält, führt Microsoft Access das aufgerufene Makro aus. Ist das aufgerufene Makro beendet, kehrt Microsoft Access zum ursprünglichen Makro zurück und führt die nächste Aktion aus.

Anmerkungen

  • Sie können ein Makro in der gleichen Makrogruppe oder in einer anderen Makrogruppe aufrufen.

  • Sie können Makros ineinander verschachteln, also z.B. Makro A ausführen, von dort Makro B aufrufen usw. Auf jeden Fall kehrt Microsoft Access nach dem Beenden des aufgerufenen Makros zu dem aufrufenden Makro zurück und führt die nächste Aktion in diesem Makro aus.

Tipp Sie können mit der Aktion AusführenMakro in einer Makrogruppe, die benutzerdefinierte Befehle für eine benutzerdefinierte Menüleiste definiert, ein Makro aus einem benutzerdefinierten Menü heraus ausführen. Es ist jedoch einfacher, die neue Befehlsleistenfunktionalität zu verwenden, um ein Makro aus einer Menüleiste, einer Symbolleiste oder einem Kontextmenü heraus auszuführen. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen anzuzeigen. Wählen Sie in der Registerkarte Symbolleisten die Menüleiste, Symbolleiste oder das Kontextmenü aus, das aus dem Makro heraus ausgeführt werden soll. Klicken Sie in der Registerkarte Befehle im Feld Kategorien auf Alle Makros, wählen Sie dann im Feld Befehle das Makro aus, das auf der Menüleiste, Symbolleiste bzw. im Kontextmenü ausgeführt werden soll, und ziehen Sie es dorthin. Wenn Sie in der Menüleiste, Symbolleiste oder im Kontextmenü auf das Symbol für dieses Makro klicken, führt es Microsoft Access aus. Sie können ein Makro auch aus dem Datenbankfenster auf eine Menüleiste oder Symbolleiste ziehen; Microsoft Access erstellt dann ein Symbol, das das betreffende Makro ausführt.

Zum Ausführen der Aktion AusführenMakro in Visual Basic verwenden Sie die RunMacro-Methode des DoCmd-Objekts.


 AusführenSQL-Aktion

AusführenSQL-Aktion

Mit Hilfe der Aktion AusführenSQL können Sie eine Microsoft Access-Aktionsabfrage ausführen, indem Sie die entsprechende SQL-Anweisung verwenden. Sie können auch eine Datendefinitionsabfrage ausführen.

Einstellung

Die Aktion AusführenSQL verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
SQL-Anweisung | SQL-Anweisung für die Aktionsabfrage oder Datendefinitionsabfrage, die Sie ausführen möchten. Die maximale Länge dieser Anweisung beträgt 256 Zeichen. Dieses Argument ist erforderlich.
Transaktion verwenden | Wählen Sie Ja, wenn Sie diese Abfrage in eine Transaktion aufnehmen möchten. Wählen Sie Nein, wenn Sie keine Transaktion verwenden möchten. Die Standardeinstellung ist Ja. Vor Microsoft Access 97 wurde in früheren Versionen von Microsoft Access die Abfrage bei Ausführung dieser Aktion grundsätzlich in eine Transaktion aufgenommen. Beginnen Sie mit einer BeginTrans-Methode, führen Sie die SQL-Anweisung aus und verwenden Sie dann die CommitTrans-Methode. Wenn Sie für dieses Argument Nein wählen, wird die Abfrage gegebenenfalls schneller ausgeführt.

Anmerkung

Mit Hilfe von Aktionsabfragen können Sie Datensätze anfügen, löschen und aktualisieren sowie die Ergebnisgruppe einer Abfrage als neue Tabelle speichern. Mit Hilfe von Datendefinitionsabfragen können Sie Tabellen erstellen, ändern und löschen sowie Indizes erstellen und löschen. Mit Hilfe der Aktion AusführenSQL können Sie diese Operationen direkt von einem Makro aus ausführen, ohne gespeicherte Abfragen zu verwenden.

Wenn Sie eine SQL-Anweisung eingeben müssen, die länger als 256 Zeichen ist, verwenden Sie stattdessen in Visual Basic die RunSQL-Methode des DoCmd-Objekts. In Visual Basic können Sie bis zu 32.768 Zeichen lange SQL-Anweisungen eingeben.

Microsoft Access-Abfragen sind genau genommen SQL-Anweisungen, die erstellt werden, wenn Sie eine Abfrage unter Verwendung des Entwurfsbereichs im Abfragefenster entwerfen. Die folgende Tabelle zeigt die Microsoft Access-Aktionsabfragen und -Datendefinitionsabfragen und ihre entsprechenden SQL-Anweisungen.

Abfragetyp | SQL-Anweisung
Aktion |
Anfügeabfrage | INSERT INTO
Löschabfrage | DELETE
Tabellenerstellungsabfrage | SELECT...INTO
Aktualisierungsabfrage | UPDATE
Datendefinition (SQL-spezifisch) |
Erstellen einer Tabelle | CREATE TABLE
Ändern einer Tabelle | ALTER TABLE
Löschen einer Tabelle | DROP TABLE
Erstellen eines Indexes | CREATE INDEX
Löschen eines Indexes | DROP INDEX

Sie können für diese Anweisung zum Ändern von Daten in einer anderen Datenbank auch die Klausel IN verwenden.

Anmerkung Um eine Auswahlabfrage oder eine Kreuztabellenabfrage von einem Makro aus auszuführen, verwenden Sie das Argument Ansicht der Aktion OpenQuery, um eine bestehende Auswahl- oder Kreuztabellenabfrage in der Datenblattansicht zu öffnen. Bestehende Aktionsabfragen und SQL-spezifische Abfragen können Sie auf dieselbe Weise ausführen.

Tipp Um das SQL-Äquivalent einer Microsoft Access-Abfrage zu sehen, klicken Sie im Menü Ansicht des Abfragefensters auf SQL-Ansicht. Sie können die aufgelisteten SQL-Anweisungen als Modelle zum Erstellen von Abfragen, die mit der Aktion AusführenSQL ausgeführt werden, verwenden. Das Duplizieren einer SQL-Anweisung im Argument SQL-Anweisung für die Aktion AusführenSQL hat dieselbe Auswirkung wie das Ausführen dieser Microsoft Access-Abfrage im Abfragefenster.


 AusgabeIn-Aktion

AusgabeIn-Aktion

Mit Hilfe der Aktion AusgabeIn können Sie die Daten im angegebenen Microsoft Access-Datenbankobjekt (Datenblatt, Formular, Bericht, Modul, Datenzugriffsseite) oder in eine Datei in Microsoft Excel 98 (*.XLS), MS-DOS-Text (*.TXT) oder in Rich-Text-Format (*.RTF) ausgeben. Sie können auch in eine Datei in HTML-Format (*.HTML), in Dateien im Microsoft Internet Information Server-Format (*.HTX, *.IDC) oder in eine Datei im Microsoft Active Server-Format (*.ASP) ausgeben. Dateien im Microsoft Internet Information Server-Format können auch zusammen mit Microsoft Personal Web Server verwendet werden.

Einstellung

Die AusgabeIn-Aktion verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Typ des Objekts, das die auszugebenden Daten enthält. Klicken Sie im Feld Objekttyp im Bereich Aktionsargumente des Makrofensters auf Tabelle (für ein Tabellendatenblatt), Abfrage (für ein Abfragedatenblatt), Formular (für ein Formular oder ein Formulardatenblatt), Bericht, Modul, Datenzugriffsseite, Gespeicherte Prozedur oder Serversicht. Die Ausgabe kann nicht in Form eines Makros erfolgen. Wenn Sie das aktive Objekt ausgeben möchten, genügt es, wenn Sie mit diesem Argument den Typ des Objekts angeben, jedoch das Argument Objektname unausgefüllt lassen. Dies ist ein notwendiges Argument. Die Standardeinstellung lautet Tabelle.
Objektname | Name des Objekts, das die auszugebenden Daten enthält. Das Feld Objektname zeigt alle Datenbankobjekte des im Argument Objekttyp angegebenen Typs an.
 | Wenn Sie ein Makro, das die AusgabeIn-Aktion enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ausgabeformat | Format, in dem Sie die Daten ausgeben möchten. Klicken Sie im Feld auf das gewünschte Format: HTML (*.HTML), Microsoft Active Server Pages (*.ASP), Microsoft Excel (*.XLS), Microsoft IIS (*.HTX, *.IDC), MS-DOS Text (*.TXT), RTF-Format (*.RTF) oder Microsoft Datenzugriffsseite (*.HTML). Module können nur im MS-DOS-Textformat ausgegeben werden. Datenzugriffsseiten können nur im HTML-Format ausgegeben werden. Die Microsoft Internet Information Server-Formate und das Microsoft Active Server Pages-Format sind nur für Tabellen, Abfragen und Formulare verfügbar. Wenn Sie dieses Argument leer lassen, fragt Microsoft Access nach dem Ausgabeformat.
Ausgabedatei | Datei, in die Sie die Daten ausgeben möchten, einschließlich der vollständigen Pfadangabe. Sie können die entsprechenden Standarderweiterungen (.ASP, .HTM oder .HTML, .HTX, .XLS, .TXT oder .RTF) für das im Argument Ausgabeformat angegebene Ausgabeformat angeben, obwohl dies nicht zwingend erforderlich ist. Wenn die Ausgabe in Microsoft Internet Information Server- oder Microsoft Active Server Pages-Dateien erfolgt, erstellt Microsoft Access immer Dateien mit den Standarderweiterungen .HTX und .IDC bzw. .ASP. Wenn Sie Datenzugriffsseiten ausgeben, erstellt Microsoft Access immer Dateinamen mit der Dateierweiterung .HTML. Wenn Sie das Argument Ausgabeformat leer lassen, fragt Microsoft Access nach einem Namen für die Ausgabedatei.
Autostart | Gibt an, ob die entsprechende Software unmittelbar nach dem Ausführen der AusgabeIn-Aktion automatisch gestartet und die im Argument Ausgabedatei angegebene Datei geöffnet werden soll. Wenn Sie Ja wählen, wird eines der folgenden gestartet und die Ausgabedatei des Microsoft Access-Objekts geladen: Microsoft Excel (für .XLS-Dateien), Microsoft Word für Windows (für .RTF-Dateien) oder der Editor von Microsoft Windows (für .TXT-Dateien). Für .HTML-Dateien wird Ihr Standard-Internetbrowser gestartet.
Vorlagedatei | Pfad und Name der Datei, die Sie als Vorlage für .HTML-, .HTX- oder .ASP-Dateien verwenden möchten. Die Vorlagedatei enthält HTML-Marken.

Anmerkung

Die Microsoft Access-Daten werden in dem gewählten Format ausgegeben und können von jeder Anwendung, die das vorliegende Format verwendet, gelesen werden. Sie können z. B. einen Microsoft Access-Bericht mit seiner Formatierung in ein Dokument im RTF-Format ausgeben und dieses Dokument anschließend in Word für Windows öffnen.

Wenn Sie das Datenbankobjekt im HTML-Format ausgeben, erstellt Microsoft Access eine Datei im HTML-Format mit den Daten des Objekts. Mit Hilfe des Arguments Vorlagedatei können Sie eine Datei festlegen, die als Vorlage für die .HTML-Datei verwendet werden soll.

Wenn Sie das Objekt im Microsoft Internet Information Server-Format ausgeben, erstellt Microsoft Access zwei Dateien:

  • Eine .IDC-Datei, die Informationen über das Herstellen einer Verbindung zu einer ODBC-Datenquelle enthält, und eine SQL-Anweisung, die an dieser Datenquelle ausgeführt werden soll. In diesem Fall enthält das ausgegebene Microsoft Access-Objekt die in der SQL-Anweisung definierten Daten und die aktuelle Microsoft Access-Datenbank ist die ODBC-Datenquelle.

  • Eine .HTX-Datei, die Informationen über die Formatierung der Daten enthält, die von der in der .IDC-Datei als HTML-Dokument angegebenen SQL-Anweisung geliefert werden. Mit Hilfe des Arguments Vorlagedatei können Sie eine .HTML-Datei angeben, die als Vorlage für die .HTX-Datei verwendet werden soll.

Der Microsoft Internet Information Server erstellt mit Hilfe der .HTX- und .IDC-Dateien eine .HTML-Datei mit den Daten im ausgegebenen Microsoft Access-Objekt.

Wenn Sie das Datenbankobjekt im Microsoft Active Server Pages-Format ausgeben, erstellt Microsoft Access eine Datei im .ASP-Format, die Informationen zum Zugriff und zur Formatierung der Daten des Objekts enthält. Der Microsoft Internet Information Server erstellt mit Hilfe der .ASP-Datei eine .HTML-Datei mit den Daten im ausgegebenen Microsoft Access-Objekt. Mit Hilfe des Arguments Vorlagedatei können Sie eine .HTML-Datei angeben, die als Vorlage für die .ASP-Datei verwendet werden soll.

Die folgenden Regeln gelten, wenn Sie die AusgabeIn-Aktion verwenden, um ein Datenbankobjekt in eines der Ausgabeformate mit Ausnahme von Microsoft Active Server Pages (einige der Regeln gelten auch für das Microsoft Active Server Pages-Format) ausgeben:

  • Sie können Daten in Tabellen-, Abfrage- und Formulardatenblättern ausgeben. In der Ausgabedatei sehen alle Felder des Datenblatts genau wie in Microsoft Access aus, mit Ausnahme der Felder, die OLE-Objekte enthalten. Die Spalten für diese Felder sind in der Ausgabedatei zwar enthalten, die Felder sind jedoch leer.

  • Für ein Steuerelement, das an ein Ja/Nein-Feld (eine Umschaltfläche, ein Optionsfeld oder ein Kontrollkästchen) gebunden ist, zeigt die Ausgabedatei die Werte -1 (Ja) oder 0 (Nein) an.

  • Für ein Textfeld, das an ein Feld des Datentyps Hyperlink gebunden ist, zeigt die Ausgabedatei den Hyperlink für alle Ausgabeformate ausgenommen MS-DOS-Text (in diesem Fall wird der Hyperlink als normaler Text angezeigt) an.

  • Wenn Sie die Daten eines Formulars in der Formularansicht ausgeben, enthält die Ausgabedatei immer die Datenblattansicht des Formulars.

  • Wenn Sie die Daten eines Berichts ausgeben, werden nur die folgenden Steuerelemente in die Ausgabedatei aufgenommen: Textfelder (für .XLS-Ausgabedateien) bzw. Textfelder und Bezeichnungsfelder (für .RTF-, .TXT- und .HTML-Ausgabedateien). Alle anderen Steuerelemente bleiben unberücksichtigt. Kopf- und Fußinformationen sind ebenfalls nicht in der Ausgabedatei enthalten. Die einzige Ausnahme stellt das Einschließen eines Textfelds in einem Gruppenfuß, das einen Ausdruck enthält, der die Funktion Sum verwendet, in der Ausgabedatei dar, wenn Sie die Daten eines Berichts in eine Microsoft Excel-Datei ausgeben. Kein anderes Steuerelement in einem Kopf oder Fuß (und keine andere Aggregatfunktion als die Funktion Sum) wird in die Ausgabedatei aufgenommen.

  • Unterberichte werden in die Ausgabedatei eingefügt, Unterformulare werden jedoch beim Ausgeben in .ASP-Format nur eingefügt, wenn als Formular (nicht als Datenblatt) ausgegeben wird.

  • Wenn Sie ein Datenblatt, Formular oder eine Datenzugriffsseite im HTML-Format ausgeben, wird eine .HTML-Datei erstellt. Wenn Sie einen Bericht im HTML-Format ausgeben, wird für jede Seite des Berichts eine .HTML-Datei erstellt.

Weitere Informationen zu Regeln und Beschränkungen bei der Ausgabe in .HTML-Dateien finden Sie unter Exportieren eines Datenblatts in statisches HTML-Format und unter Exportieren eines Berichts in statisches HTML-Format.

Weitere Informationen zu Regeln und Beschränkungen bei der Ausgabe in Microsoft Internet Information Server-Dateien finden Sie unter Exportieren eines Datenblatts in dynamisches HTML-Format und unter Exportieren eines Formulars in dynamisches HTML-Format.

Weitere Informationen zu Regeln und Beschränkungen bei der Ausgabe in Microsoft Active Server-Dateien finden Sie unter Exportieren eines Datenblatts in dynamisches HTML-Format, Exportieren eines Formulars in dynamisches HTML-Format und unter Unterstützte und nicht unterstützte Formularsteuerelemente für dynamisches ASP-Format.

Tipp Falls Sie die Daten eines Berichts in eine Ausgabedatei ausgeben und die Spalten und Zeilen der Daten in der Ausgabedatei nicht wie in dem Bericht ausgerichtet sind, können die folgenden Tipps hilfreich sein:

  • Sie können im Menü Format auf Größe zeigen und dann auf An Textgröße klicken, um die Größe der Steuerelemente anzupassen.

  • Sie sollten überlagernde Steuerelemente oder sehr nah beieinander platzierte Steuerelemente vermeiden.

  • Sie können im Menü Format auf Ausrichten zeigen und dann auf den entsprechenden Befehl klicken, um die Steuerelemente des Berichts auszurichten. Steuerelemente, die nicht in der gleichen Zeile ausgerichtet sind, werden möglicherweise in verschiedenen Zeilen platziert, was zusätzlichen Platz beansprucht.

Die AusgabeIn-Aktion hat eine ähnliche Wirkung wie das Klicken auf Exportieren im Menü Datei und das Aktivieren des Kontrollkästchens Mit Formatierung im angezeigten Dialogfeld. Die Aktionsargumente entsprechen den Einstellungen des Dialogfeldes Exportieren. Allerdings gilt der Befehl Exportieren nur für das im Datenbankfenster markierte Objekt. Durch Verwenden der AusgabeIn-Aktion können Sie das Objekt angeben, das Sie ausgeben möchten.

Anmerkung Sie können die markierten Daten mit dem Befehl Exportieren ausgeben. Diese Funktionalität steht mit der AusgabeIn-Aktion nicht zur Verfügung.

Sie können auch im Menü Extras auf Office-Verknüpfungen zeigen und dann auf Analysieren mit MS Excel oder Mit MS Word veröffentlichen klicken, um ein Datenbankobjekt auszugeben und die Ausgabedatei sofort in Microsoft Excel oder Microsoft Word für Windows zu öffnen.

Zum Ausführen der Aktion AusgabeIn in Visual Basic verwenden Sie die OutputTo-Methode des DoCmd-Objekts.


 AuswählenObjekt-Aktion

AuswählenObjekt-Aktion

Sie können die Aktion AuswählenObjekt verwenden, um ein bestimmtes Datenbankobjekt auszuwählen.

Einstellung

Die Aktion AuswählenObjekt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des auszuwählenden Datenbankobjekts. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Objekttyp auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseiten, Serversicht oder Gespeicherte Prozeduren. Dieses Argument ist erforderlich.
Objektname | Der Name des auszuwählenden Objekts. Das Feld Objektname zeigt alle Objekte des im Argument Objekttyp ausgewählten Typs in der gesamten Datenbank an. Wenn Sie für Objekttyp keinen Wert eingeben, geben Sie für dieses Argument ebenfalls keinen Wert ein. Dieses Argument ist erforderlich, es sei denn, Sie stellen das Argument In Datenbankfenster auf Ja ein. Wenn Sie das Argument In Datenbankfenster auf Ja einstellen und das Argument Objektname leer lassen, wählt Microsoft Access im Datenbankfenster die Registerkarte aus, die dem im Argument Objekttyp angegebenen Datenbankobjekt entspricht.
 | Anmerkung Die Objektnamen für Serversicht-, Diagramm- oder Gespeicherte Prozeduren-Objekte werden im Feld Objektname eines Microsoft Access-Projekts (.ADP) nicht angezeigt.
In Datenbankfenster | Gibt an, ob Microsoft Access das Objekt im Datenbankfenster auswählt. Klicken Sie auf Ja (um das Objekt im Datenbankfenster auszuwählen) oder Nein (um es nicht auszuwählen). Die Standardeinstellung ist Nein.

Anmerkung

Die Aktion AuswählenObjekt kann für alle Microsoft Access-Objekte ausgeführt werden, die den Fokus erhalten können. Diese Aktion setzt den Fokus auf das angegebene Objekt und zeigt das Objekt an, wenn es ausgeblendet ist. Ist das Objekt ein Formular, so stellt die Aktion AuswählenObjekt die Eigenschaft Sichtbar des Formulars auf Ja ein und setzt das Formular auf den von seinen Formulareigenschaften eingestellten Modus zurück (z.B. gebundenes Formular oder Popupformular).

Ist das Objekt in keinem anderen Microsoft Access-Fenster geöffnet, so können Sie es im Datenbankfenster auswählen, indem Sie das Argument In Datenbankfenster auf Ja einstellen. Stellen Sie das Argument In Datenbankfenster auf Nein ein, so wird eine Fehlermeldung angezeigt, wenn Sie versuchen, ein nicht geöffnetes Objekt auszuwählen.

Sie können diese Aktion z.B. verwenden, um ein Objekt auszuwählen, auf dem weitere Aktionen ausgeführt werden sollen. Beispielsweise können Sie ein Objekt wiederherstellen, das (mit der Aktion Wiederherstellen) minimiert wurde, oder ein Fenster (mit der Aktion Vollbild) maximieren, das ein Objekt enthält, mit dem Sie arbeiten möchten.

Wenn Sie ein Formular auswählen, können Sie die Aktionen GeheZuSteuerelement, GeheZuDatensatz und GeheZuSeite verwenden, um zu bestimmten Bereichen des Formulars zu gelangen. Die Aktion GeheZuDatensatz funktioniert auch für Datenblätter.

Zum Ausführen der Aktion AuswählenObjekt in Visual Basic verwenden Sie die Methode SelectObject des Objekts DoCmd.


 Drucken-Aktion

Drucken-Aktion

Mit der Aktion Drucken können Sie das aktive Objekt in der geöffneten Datenbank drucken. Sie können Datenblätter, Berichte, Formulare, Datenzugriffsseiten und Module drucken.

Einstellung

Die Aktion Drucken verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Druckbereich | Der zu druckende Bereich. Klicken Sie im Abschnitt Aktionsargumente des Makrofensters im Feld Druckbereich auf Alles (der Benutzer kann das gesamte Objekt drucken), auf Markierung (der Benutzer kann den markierten Teil des Objekts drucken) oder auf Seiten (der Benutzer kann in den Argumenten Von und Bis einen Seitenbereich festlegen). Die Standardeinstellung ist Alles.
Von | Die erste zu druckende Seite. Der Ausdruck beginnt am Anfang dieser Seite. Dieses Argument ist erforderlich, wenn Sie im Feld Druckbereich auf Seiten klicken.
Bis | Die letzte zu druckende Seite. Der Ausdruck endet am Ende dieser Seite. Dieses Argument ist erforderlich, wenn Sie im Feld Druckbereich auf Seiten klicken.
Druckqualität | Die Qualität des Ausdrucks. Klicken Sie auf Hoch, Mittel, Niedrig oder Entwurf. Je geringer die Qualität, desto schneller wird das Objekt gedruckt. Die Standardeinstellung ist Hoch.
Exemplare | Die Anzahl der zu druckenden Exemplare. Die Standardeinstellung ist 1.
Exemplare sortieren | Klicken Sie auf Ja (um die gedruckten Exemplare zu sortieren) oder auf Nein (wenn keine Sortierung benötigt wird). Das Objekt wird meist schneller gedruckt, wenn dieses Argument auf Nein eingestellt ist. Die Standardeinstellung ist Ja.

Anmerkung

Diese Aktion ist mit dem Auswählen eines Objekts und dem anschließenden Klicken auf Drucken im Menü Datei vergleichbar. Bei Verwendung dieser Aktion wird jedoch das Dialogfeld Drucken nicht angezeigt.

Tipp Wenn Sie bestimmte Druckeinstellungen regelmäßig verwenden möchten, erstellen Sie ein Makro, das die Aktion Drucken mit den entsprechend eingestellten Argumenten enthält.

Die Argumente für diese Aktion entsprechen den Optionen im Dialogfeld Drucken. Im Gegensatz zur Aktion SuchenDatensatz und zum Dialogfeld Suchen in Feld werden die Argumenteinstellungen jedoch nicht gleichzeitig für die Optionen des Dialogfelds Drucken verwendet.

Zum Ausführen der Aktion Drucken in Visual Basic verwenden Sie die PrintOut-Methode des DoCmd-Objekts.


 Echo-Aktion

Echo-Aktion

Mit der Aktion Echo können Sie angeben, ob Echo eingeschaltet ist. Sie können diese Aktion z. B. verwenden, um das Ergebnis eines Makros während der Ausführung auszublenden oder anzuzeigen.

Einstellung

Die Aktion Echo verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Echo | Klicken Sie im Abschnitt Aktionsargumente des Makrofensters im Feld Echo auf Ja, um das Echo einzuschalten, oder auf Nein, um das Echo auszuschalten. Die Standardeinstellung ist Ja.
Statuszeilentext | Der in der Statusleiste anzuzeigende Text, wenn Echo eingeschaltet ist. Wenn Echo ausgeschaltet ist, kann z. B. die Statusleiste den Text "Das Makro wird gerade ausgeführt" anzeigen.

Anmerkung

Beim Ausführen von einem Makro in Microsoft Access werden durch Bildschirmaktualisierungen oft Informationen angezeigt, die für die Funktionalität des Makros ohne Bedeutung sind. Wenn Sie das Argument Echo auf Nein einstellen, wird das Makro ohne Bildschirmaktualisierung ausgeführt. Beim Beenden des Makros schaltet Microsoft Access automatisch Echo wieder ein und aktualisiert das Fenster. Die Einstellung Nein für Echo hat keinerlei Auswirkungen auf das Makro und sein Ergebnis.

Die Aktion Echo unterdrückt nicht die Anzeige von gebundenen Dialogfeldern, wie z. B. Fehlermeldungen, oder von Popupformularen, wie z. B. Eigenschaftenfenster. Sie können diese für Benutzereingaben oder zur Anzeige von Informationen verwenden, wenn Echo ausgeschaltet ist. Verwenden Sie die Aktion Warnmeldungen, um alle Meldungs- oder Dialogfelder außer Fehlermeldungen und Dialogfelder, die den Benutzer zu Eingaben auffordern, auszuschalten.

Sie können die Aktion Echo mehrmals in einem Makro ausführen. Dadurch können Sie den Text in der Statusleiste verändern, während das Makro ausgeführt wird.

Wenn Sie Echo ausschalten, so können Sie die Aktion Sanduhr verwenden, um den Mauszeiger als Sanduhr-Symbol anzuzeigen (oder in Form eines anderen Mauszeigersymbols, das Sie in Microsoft Windows 98 für den Zustand "Ausgelastet" oder in Windows NT für den Zustand "Warten" eingestellt haben). Damit zeigen Sie dem Benutzer an, dass das Makro momentan ausgeführt wird.

Zum Ausführen der Aktion Echo in Visual Basic verwenden Sie die Echo-Methode des DoCmd-Objekts.


 EinblendenSymbolleiste-Aktion

EinblendenSymbolleiste-Aktion

Mit Hilfe der EinblendenSymbolleiste-Aktion können Sie eine eingebaute oder benutzerdefinierte Symbolleiste ein- bzw. ausblenden. Eine eingebaute Symbolleiste können Sie in allen Microsoft Access-Fenstern anzeigen oder lediglich in der Ansicht, in der sie normalerweise angezeigt wird (z. B. die Symbolleiste Formularansicht in der Formularansicht).

Anmerkung Die EinblendenSymbolleiste-Aktion wirkt sich nur auf Symbolleisten und nicht auf Menüleisten oder Kontextmenüs aus.

Einstellung

Die EinblendenSymbolleiste-Aktion verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Symbolleistenname | Name der Symbolleiste, die Sie ein- oder ausblenden möchten. Das Feld Symbolleistenname im Bereich Aktionsargumente des Makrofensters zeigt alle eingebauten Symbolleisten von Microsoft Access an, gefolgt von den benutzerdefinierten Symbolleisten, die Sie in der aktuellen Datenbank definiert haben. Dies ist ein notwendiges Argument.
 | Wenn das Kontrollkästchen Eingebaute Symbolleisten zulassen im Dialogfeld Start (wird durch Klicken auf Start im Menü Extras angezeigt) deaktiviert ist, können Sie die Aktion lediglich zum Einblenden bzw. Ausblenden von benutzerdefinierten Symbolleisten verwenden.
 | Wenn Sie ein Makro, das die EinblendenSymbolleiste-Aktion enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Symbolleiste mit dem angegebenen Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Einblenden | Gibt an, ob und in welchen Ansichten die Symbolleiste ein- bzw. ausgeblendet wird. Die Voreinstellung ist Nein (Symbolleiste ist ausgeblendet).
 | Wählen Sie für eingebaute Symbolleisten die Einstellung Ja, um die Symbolleiste in allen aktiven Microsoft Access-Fenstern anzuzeigen, die Einstellung Sofern passend, um die Symbolleiste nur in der Ansicht anzuzeigen, in der sie normalerweise angezeigt wird (entsprechend der Voreinstellung von Microsoft Access) oder die Einstellung Nein, um die Symbolleiste in allen Microsoft Access-Fenstern auszublenden.
 | Wählen Sie für benutzerdefinierte Symbolleisten die Einstellung Ja, um eine benutzerdefinierte Symbolleiste eines Formulars oder Berichts in allen Microsoft Access-Fenstern anzuzeigen, wenn das Formular oder der Bericht aktiviert ist, die Einstellung Sofern passend, um eine benutzerdefinierte Symbolleiste eines Formulars oder Berichts im aktiven Fenster zur Darstellung der aktiven Formulare oder Berichte anzuzeigen und die Einstellung Nein, um die Symbolleiste in allen Microsoft Access-Fenstern auszublenden.

Anmerkung

Sie können diese Aktion in einem Makro mit bedingten Ausdrücken verwenden, um eine oder mehrere Symbolleisten in Abhängigkeit von bestimmten Bedingungen ein- bzw. auszublenden.

Wenn Sie eine bestimmte Symbolleiste nur in einem Formular oder Bericht anzeigen möchten, stellen Sie für die OnActivate-Eigenschaft dieses Formulars oder Berichts die Einstellung auf den Namen eines Makros ein, das die EinblendenSymbolleiste-Aktion enthält, um die Symbolleiste einzublenden. Stellen Sie dann für die OnDeactivate-Eigenschaft des Formulars oder Berichts die Einstellung auf den Namen eines Makros ein, das die Aktion EinblendenSymbolleiste-Aktion enthält, um die Symbolleiste auszublenden.

Die EinblendenSymbolleiste-Aktion hat dieselbe Wirkung, als würden Sie im Menü Ansicht auf Symbolleisten zeigen, auf Anzeigen klicken, und dann in der Registerkarte Symbolleisten des Dialogfelds Anpassen eine spezifische Symbolleiste aktivieren oder deaktivieren. Mit der EinblendenSymbolleiste-Aktion können Sie bestimmen, ob eine eingebaute Symbolleiste in allen Microsoft Access-Fenstern angezeigt wird oder nur in der Ansicht, in der sie standardmäßig angezeigt wird.

Die eingebauten Symbolleisten können auch nicht angezeigt oder ausgeblendet werden, wenn Sie die AllowBuiltInToolbars-Eigenschaft in Visual Basic auf Falsch (0) eingestellt haben, oder wenn Sie in Visual Basic unter Verwendung der SetOption-Methode die Option Eingebaute Symbolleisten zulassen auf Falsch eingestellt haben.

Zum Ausführen der Aktion EinblendenSymbolleiste in Visual Basic verwenden Sie die Methode ShowToolbar-Methode des DoCmd-Objekts.


 GeheZuDatensatz-Aktion

GeheZuDatensatz-Aktion

Mit der Aktion GeheZuDatensatz können Sie den angegebenen Datensatz zum aktuellen Datensatz in einer geöffneten Tabelle, einem geöffneten Formular oder im Abfrageergebnis machen.

Einstellung

Die Aktion GeheZuDatensatz verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des Objekts, das den Datensatz enthält, der zum aktuellen Datensatz werden soll. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Objekttyp auf Tabelle, Abfrage, Formular, Serversicht oder Gespeicherte Prozedur. Wenn Sie dieses Feld leer lassen, wird das aktive Objekt ausgewählt.
Objektname | Der Name des Objekts, das den Datensatz enthält, der zum aktuellen Datensatz werden soll. Das Feld Objektname zeigt alle Objekte in der aktuellen Datenbank an, die dem im Argument Objekttyp angegebenen Typ entsprechen. Wenn Sie das Feld Objekttyp leer lassen, muss dieses Feld ebenfalls leer bleiben.
Datensatz | Der Datensatz, der zum aktuellen Datensatz werden soll. Klicken Sie im Feld Datensatz auf Voriger, Nächster, Erster, Letzter, Gehe zu oder Neuer. Die Standardeinstellung ist Nächster.
Offset Eine Ganzzahl oder ein Ausdruck mit vorangestelltem Gleichheitszeichen (=), der zu einer Ganzzahl ausgewertet wird. Dieses Argument gibt den Datensatz an, der zum aktuellen Datensatz werden soll. Sie können das Argument Offset auf zwei Arten verwenden:
  • Wenn das Argument Datensatz den Wert Nächster oder Voriger hat, bewegt Microsoft Access sich um die im Argument Offset angegebene Anzahl an Datensätzen vorwärts oder zurück.

  • Wenn das Argument Datensatz den Wert Gehe zu hat, wechselt Microsoft Access zu dem Datensatz, dessen Nummer im Argument Offset angegeben ist. Die Datensatznummer wird im Feld Datensatznummer ganz unten auf dem Bildschirm angezeigt.

Anmerkung Wenn Sie das Argument Datensatz auf Erster, Letzter oder Neuer einstellen, übergeht Microsoft Access das Argument Offset. Geben Sie einen zu großen Wert für Offset ein, so zeigt Microsoft Access eine Fehlermeldung an. Sie können keine negativen Werte für das Argument Offset eingeben.

Anmerkung

Befindet sich der Fokus auf einem bestimmten Steuerelement in einem Datensatz, so setzt diese Aktion den Fokus im neuen Datensatz auf dasselbe Steuerelement.

Sie können sich mit Hilfe der Einstellung Neuer des Arguments Datensatz zu dem leeren Datensatz am Ende eines Formulars oder einer Tabelle bewegen, um dort neue Daten einzugeben.

Diese Aktion ist mit dem Klicken auf Gehe zu im Menü Bearbeiten vergleichbar. Die Unterbefehle Erster, Letzter, Nächster, Vorheriger und Neu des Befehls Gehe zu haben dieselbe Wirkung auf das ausgewählte Objekt wie die Einstellungen Erster, Letzter, Nächster, Voriger und Neuer des Arguments Datensatz. Sie können sich auch zu Datensätzen bewegen, indem Sie die Navigationsschaltflächen unten im Fenster verwenden.

Sie können die Aktion GeheZuDatensatz verwenden, um den Datensatz in einem ausgeblendeten Formular zum aktuellen Datensatz zu machen, wenn Sie das ausgeblendete Formular in den Argumenten Objekttyp und Objektname angeben.

Zum Ausführen der Aktion GeheZuDatensatz in Visual Basic verwenden Sie die GoToRecord-Methode des DoCmd-Objekts.


 GeheZuSeite-Aktion

GeheZuSeite-Aktion

Mit der Aktion GeheZuSeite können Sie den Fokus im aktiven Formular auf das erste Steuerelement auf einer bestimmten Seite setzen. Sie können diese Aktion verwenden, wenn Sie ein Formular mit Seitenumbrüchen erstellt haben, das Gruppen zusammenhängender Informationen enthält. Wenn Sie z. B. über ein Formular Personal verfügen, das persönliche Angaben auf einer Seite, dienstliche Angaben auf einer anderen Seite und Umsatzzahlen auf einer dritten Seite enthält, können Sie sich mit der Aktion GeheZuSeite zur gewünschten Seite bewegen. Sie können auch mehrere Informationsseiten auf einem einzigen Formular darstellen, wenn Sie Registersteuerelemente verwenden.

Einstellung

Die Aktion GeheZuSeite verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Seitenzahl | Die Nummer der Seite, auf die der Fokus gesetzt werden soll. Geben Sie die Seitenzahl im Abschnitt Aktionsargumente des Makrofensters im Feld Seitenzahl ein. Wenn Sie dieses Argument leer lassen, bleibt der Fokus auf der aktuellen Seite. Mit Hilfe der Argumente Rechts und Unten können Sie den gewünschten Teil der Seite anzeigen.
Rechts | Die horizontale Position der Stelle auf der Seite (gemessen vom linken Rand des umgebenden Fensters), die am linken Rand des Fensters angezeigt werden soll. Dieses Argument ist erforderlich, wenn Sie das Argument Unten angegeben haben.
Unten | Die vertikale Position der Stelle auf der Seite (gemessen vom oberen Rand des umgebenden Fensters), die am oberen Rand des Fensters angezeigt werden soll. Dieses Argument ist erforderlich, wenn Sie das Argument Rechts angegeben haben.

Anmerkung Die Maßeinheiten Rechts und Unten werden in Zentimetern oder Zoll angegeben, abhängig von der Maßeinheit, die in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen in der Registerkarte Zahlen eingestellt ist.

Anmerkung

Mit dieser Aktion können Sie das erste Steuerelement (wie in der Reihenfolge für das Formular definiert) auf der angegebenen Seite auswählen. Verwenden Sie die Aktion GeheZuSteuerelement, um sich zu einem bestimmten Steuerelement in dem Formular zu bewegen.

Sie können die Argumente Rechts und Unten für Formulare verwenden, deren Seiten größer sind als das Microsoft Access-Fenster. Verwenden Sie zuerst das Argument Seitenzahl, um sich zur gewünschten Seite zu bewegen, und dann die Argumente Rechts und Unten, um den gewünschten Teil der Seite anzuzeigen. Microsoft Access zeigt den Teil einer Seite an, dessen linke obere Ecke den angegebenen Abstand von der linken oberen Ecke der Seite hat.

In den folgenden Fällen können Sie die Aktion GeheZuSeite nicht verwenden:

  • Um den Fokus auf eine Seite in einem ausgeblendeten Formular zu setzen.

  • Um den Fokus innerhalb des Registersteuerelements von einer Seite zu einer anderen Seite zu bewegen.

Zum Ausführen der Aktion GeheZuSeite in Visual Basic verwenden Sie die GoToPage-Methode des DoCmd-Objekts.


 GeheZuSteuerelement-Aktion

GeheZuSteuerelement-Aktion

Sie können die Aktion GeheZuSteuerelement verwenden, um den Fokus auf das angegebene Feld oder Steuerelement im aktuellen Datensatz des geöffneten Formulars, Formulardatenblatts, Tabellendatenblatts oder Abfragedatenblatts zu setzen. Sie können diese Aktion verwenden, wenn ein bestimmtes Feld oder Steuerelement den Fokus erhalten soll. Dieses Feld oder Steuerelement kann dann für Vergleiche oder SuchenDatensatz-Aktionen verwendet werden. Sie können sich mit Hilfe dieser Aktion auch abhängig von bestimmten Bedingungen in einem Formular bewegen. Gibt der Benutzer z. B. in einem Steuerelement Verheiratet in einem Formular Lebensversicherung den Wert Nein ein, so kann der Fokus automatisch das Steuerelement Name des Ehepartners überspringen und auf das nächste Steuerelement gesetzt werden.

Anmerkung Diese Aktion ist bei der Verwendung von Datenzugriffseiten nicht verfügbar.

Einstellung

Die Aktion GeheZuSteuerelement verwendet das folgende Argument.

Aktionsargument | Beschreibung
Steuerelementname | Der Name des Feldes oder Steuerelements, auf das der Fokus gesetzt werden soll. Geben Sie den Feld- oder Steuerelementnamen im Abschnitt Aktionsargumente des Makrofensters im Feld Steuerelementname ein. Dieses Argument ist erforderlich. Anmerkung Geben Sie lediglich den Namen des Feldes oder Steuerelements im Argument Steuerelementname an, nicht den vollständigen Bezeichner, wie z. B. Formulare!Artikel![Artikel-Nr].

Anmerkung

Sie können die Aktion GeheZuSteuerelement nicht verwenden, um den Fokus auf ein Steuerelement in einem ausgeblendeten Formular zu setzen.

Tipp Sie können die Aktion GeheZuSteuerelement verwenden, um sich zu einem Unterformular zu bewegen, das ein Steuerelement darstellt. Sie können sich dann mit Hilfe der Aktion GeheZuDatensatz zu einem bestimmten Datensatz im Unterformular bewegen. Sie können sich mit der Aktion GeheZuSteuerelement auch zu einem Steuerelement in einem Unterformular bewegen, indem Sie sich zuerst zum Unterformular und dann zum Steuerelement in dem Unterformular bewegen.

Zum Ausführen der Aktion GeheZuSteuerelement in Visual Basic verwenden Sie die GoToControl-Methode des DoCmd-Objekts. Sie können auch die SetFocus-Methode verwenden, um den Fokus auf ein Steuerelement in einem Formular oder einem der Unterformulare oder in ein Feld in einer geöffneten Tabelle, Abfrage oder eines Formulardatenblatts zu setzen.


 HinzufügenMenü-Aktion

HinzufügenMenü-Aktion

Mit der Aktion HinzufügenMenü können Sie die folgenden Menüleisten erstellen:

  • Eine benutzerdefinierte Menüleiste für ein Formular oder einen Bericht. Die benutzerdefinierte Menüleiste ersetzt die eingebaute Menüleiste für das Formular oder den Bericht.

  • Ein benutzerdefiniertes Kontextmenü für ein Formular, Formular-Steuerelement oder einen Bericht. Das benutzerdefinierte Kontextmenü ersetzt das eingebaute Kontextmenü für das Formular, das Formular-Steuerelement oder den Bericht.

  • Eine globale Menüleiste. Die globale Menüleiste ersetzt die eingebaute Menüleiste für alle Microsoft Access-Fenster mit Ausnahme der Fenster, in denen Sie eine benutzerdefinierte Menüleiste für ein Formular oder einen Bericht hinzugefügt haben.

  • Ein globales Kontextmenü. Das globale Kontextmenü ersetzt das eingebaute Kontextmenü für alle Felder in Tabellen- und Abfrage-Datenblättern, Formulare in der Formularansicht, Datenblattansicht und Seitenansicht sowie Berichte in der Seitenansicht, mit Ausnahme der Fälle, in denen Sie ein benutzerdefiniertes Kontextmenü für ein Formular, ein Formular-Steuerelement oder einen Bericht hinzugefügt haben.

Anmerkung Sie können in Microsoft Access 98 weiterhin alle benutzerdefinierten Menütypen mit Makros erstellen, welche die Aktion HinzufügenMenü enthalten. Ebenso können Sie weiterhin alle bestehenden benutzerdefinierten Menüs, die Sie unter Verwendung von Makros erstellt haben, nutzen. Es wird jedoch empfohlen, diese Makros mit Hilfe des Dialogfelds Anpassen zu erstellen. Dieses wird verfügbar, wenn Sie im Menü Ansicht auf Symbolleisten zeigen und auf Anpassen klicken. Wenn das Dialogfeld Anpassen angezeigt wird, können Sie ganz einfach neue Menüs erstellen und eingebaute Menüs anpassen.

Einstellung

Die Aktion HinzufügenMenü verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Menüname | Der Name des Dropdownmenüs, das zur benutzerdefinierten Menüleiste oder globalen Menüleiste hinzugefügt werden soll. Geben Sie den Menünamen im Bereich Aktionsargumente des Makrofensters im Feld Menüname ein. Dieses Argument ist für benutzerdefinierte Menüleisten und globale Menüleisten erforderlich; es wird für benutzerdefinierte Kontextmenüs und globale Kontextmenüs ignoriert.
 | Um eine Zugriffstaste zu definieren, mit der Sie das Menü auf der Tastatur auswählen können, geben Sie ein &-Zeichen vor dem Buchstaben ein, der als Zugriffstaste dienen soll. Dieser Buchstabe wird im Menünamen auf der Menüleiste unterstrichen dargestellt.
Menümakroname | Der Name der Makrogruppe, welche die Makros für die Menübefehle enthält. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion HinzufügenMenü enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Makrogruppe mit diesem Namen nur in der aktuellen Datenbank.
Statuszeilentext | Der Text, der in der Statusleiste angezeigt wird, wenn das Menü ausgewählt wird. Dieses Argument wird für benutzerdefinierte Kontextmenüs und globale Kontextmenüs ignoriert.

Anmerkung

Um eine benutzerdefinierte Menüleiste, ein benutzerdefiniertes Kontextmenü, eine globale Menüleiste oder ein globales Kontextmenü zu erstellen, führen Sie folgende Schritte aus:

  1. Erstellen Sie ein Menüleistenmakro, das die Aktion HinzufügenMenü für jedes Dropdownmenü enthält, das in der benutzerdefinierten Menüleiste oder globalen Menüleiste angezeigt werden soll. Für benutzerdefinierte Kontextmenüs und globale Kontextmenüs darf das Menüleistenmakro nur eine Aktion HinzufügenMenü enthalten.

  2. Weisen Sie jedem Dropdownmenü Befehle zu, indem Sie für jedes Menü eine Makrogruppe erstellen. Jeder Befehl führt die Aktionen aus, die von einem Makro dieser Makrogruppe definiert wurden. Für benutzerdefinierte Kontextmenüs und globale Kontextmenüs erstellen Sie eine einzige Makrogruppe, in der jedes Makro die Aktionen für genau einen Befehl des Kontextmenüs enthält.

  3. Ordnen Sie das Menüleistenmakro dem jeweiligen Microsoft Access-Objekt wie folgt zu:
    • Bei benutzerdefinierten Menüleisten geben Sie den Namen des Menüleistenmakros in der Eigenschaft MenuBar für das Formular oder den Bericht ein.

    • Bei benutzerdefinierten Kontextmenüs geben Sie den Namen des Menüleistenmakros in der Eigenschaft ShortcutMenuBar für das Formular, das Formular-Steuerelement oder den Bericht ein.

    • Bei globalen Menüleisten klicken Sie im Menü Extras auf Start und geben dann im Dialogfeld Start den Namen des Menüleistenmakros im Feld Menüleiste ein.

    • Bei globalen Kontextmenüs klicken Sie im Menü Extras auf Start und geben dann im Dialogfeld Start den Namen des Menüleistenmakros im Feld Kontextmenüleiste ein.

Jedes Menü in der Menüleiste benötigt eine eigene Aktion HinzufügenMenü.

Die benutzerdefinierten und globalen Menüleisten und Kontextmenüs ersetzen die eingebauten Menüleisten und Kontextmenüs für die ihnen zugeordneten Objekte. Sollen diese Menüs weiterhin bestimmte Microsoft Access-Befehle enthalten, verwenden Sie die Aktion AusführenBefehl, um die betreffenden Befehle in die Makrogruppe der gewünschten Menüs einzutragen.

Sie können ein Makro von einem Menübefehl ausführen, indem Sie die Aktion AusführenMakro im Makro für den Befehl ausführen.

Anmerkung HinzufügenMenü-Aktionen können nur in einem Menüleistenmakro, das von der Eigenschaft MenuBar oder ShortcutMenuBar eines Formulars, Formular-Steuerelements oder Berichts angegeben wurde, oder in den Feldern Menüleiste oder Kontextmenüleiste im Dialogfeld Start (Menü Extras, Befehl Start) verwendet werden. Menüleistenmakros dürfen nur HinzufügenMenü-Aktionen enthalten.

Wenn Sie ein Menüleistenmakro für ein Formular, für einen Bericht oder für die Datenbank angeben, führt Microsoft Access das Menüleistenmakro immer dann aus, wenn das Formular, der Bericht oder die Datenbank geöffnet wird. Wenn Sie das Menüleistenmakro oder die Makrogruppen, in denen die Befehle in den Dropdownmenüs definiert werden, zu einem Zeitpunkt ändern, in dem das Formular, der Bericht oder die Datenbank geöffnet ist, müssen Sie das Formular, den Bericht bzw. die Datenbank schließen und erneut öffnen, damit die Änderungen in den benutzerdefinierten Menüleisten und in den zugehörigen Menüs sichtbar werden.

Wenn Sie die Makrogruppen erstellen, die die Befehle für ein benutzerdefiniertes Menü enthalten, beachten Sie die folgenden Punkte:

  • In der Makrogruppe werden die Namen in der Spalte Makroname als Befehlsname verwendet. Der Text in der Spalte Kommentar für ein Makro wird in der Statusleiste angezeigt, wenn Sie den Befehl auswählen.

  • Um eine Trennlinie zwischen zwei Menübefehlen zu ziehen, geben Sie in der Spalte Makroname zwischen den betreffenden Menübefehlen einen Bindestrich (-) ein.

  • Um eine Zugriffstaste zu definieren, mit der Sie das Menü auf der Tastatur auswählen können, geben Sie ein &-Zeichen vor dem Buchstaben ein, der im Menünamen als Zugriffstaste dienen soll. Dieser Buchstabe wird im Menünamen unterstrichen dargestellt.

Sie können ein Untermenü für ein benutzerdefiniertes Menü oder ein benutzerdefiniertes Kontextmenü erstellen, indem Sie die Aktion HinzufügenMenü in der im Argument Menümakroname angegebenen Makrogruppe verwenden. Wenn Sie die Aktion HinzufügenMenü in eine solche Makrogruppe einfügen, erstellt Microsoft Access ein Untermenü mit dem Menünamen und Statusleistentext, der in den Argumenten Menüname und Statuszeilentext für diese Aktion festgelegt wurde. Das Untermenü enthält die von den Makros in der Makrogruppe definierten Befehle, die im Argument Menümakroname für die Aktion HinzufügenMenü angegeben wurden. Die Spalten Menüname und Kommentar einer solchen Aktion HinzufügenMenü (die normalerweise den Befehlsnamen und Statuszeilentext für einen Befehl in einem benutzerdefinierten Menü angeben) werden ignoriert, da diese Aktion ein Untermenü definiert und keinen Befehl im Hauptmenü. Sie können mehrere Untermenüebenen erstellen, indem Sie die Aktion HinzufügenMenü in den Makrogruppen für jede Menüebene verwenden.

Makrobedingungen werden nur im Menüleistenmakro des Hauptmenüs unterstützt. Sie können also in einem Menüleistenmakro eine Bedingung verwenden, um festzustellen, ob ein bestimmtes Menü in der benutzerdefinierten Menüleiste oder globalen Menüleiste angezeigt wird, aber nur für die Menüs der Hauptmenüleiste. Sie können mit Bedingungen keine Befehle oder Untermenüs in den Menüs anzeigen oder ausblenden, aber Sie können Bedingungen verwenden, um ein benutzerdefiniertes Kontextmenü oder ein globales Kontextmenü anzuzeigen oder auszublenden.

Zum Ausführen der Aktion MenüHinzufügen in Visual Basic verwenden Sie die AddMenu-Methode des DoCmd-Objekts. Sie können auch die Eigenschaften MenuBar oder ShortcutMenuBar in Visual Basic einstellen, um eine benutzerdefinierte Menüleiste oder eine benutzerdefinierte Kontextmenüleiste einem Formular, einem Formular-Steuerelement oder Berichtssteuerelement zuzuordnen. Sie können die StartupMenuBar-Eigenschaft (die programmtechnische Entsprechung des Feldes Menüleiste) einstellen, um eine globale Menüleiste zu erstellen. Sie können auch die MenuBar-Eigenschaft des Application-Objekts einstellen, um eine globale Menüleiste zu erstellen. Ebenso können Sie die StartupShortcutMenuBar-Eigenschaft (die programmtechnische Entsprechung des Feldes Kontextmenüleiste) oder die ShortcutMenuBar-Eigenschaft des Application-Objekts einstellen, um eine globales Kontextmenü zu erstellen.


 KopierenObjekt-Aktion

KopierenObjekt-Aktion

Sie können die Aktion KopierenObjekt zum Kopieren des angegebenen Datenbankobjekts in eine andere Microsoft Access-Datenbank (.mdb) oder in die gleiche Datenbank oder ein Microsoft Access-Projekt (.ADP) unter einem neuen Namen kopieren. Sie können z. B. ein Objekt in ein vorhandenes Objekt oder in eine Datenbank kopieren oder sicher oder schnell ein ähnliches Objekt erstellen.

Einstellung

Die Aktion KopierenObjekt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Zieldatenbank Ein gültiger Pfad und Dateiname für die Zieldatenbank. Geben Sie Pfad und Dateinamen im Abschnitt Aktionsargumente des Makrofensters im Feld Zieldatenbank ein. Lassen Sie dieses Argument leer, wenn Sie die aktuelle Datenbank auswählen möchten.

Anmerkung Dieses Argument steht nur in der Microsoft Access-Datenbankumgebung (.MDB) zur Verfügung. Wenn diese Aktion in einer Access-Projektumgebung (.ADP) verwendet wird, muss das Argument Zieldatenbank leer sein.

Wenn Sie ein Makro, das die Aktion KopierenObjekt enthält, in einer Bibliotheksdatenbank ausführen und dieses Argument leer lassen, kopiert Microsoft Access das Objekt in die Bibliotheksdatenbank.
Neuer Name | Ein neuer Name für das Objekt. Wenn Sie das Objekt in eine andere Datenbank kopieren, lassen Sie dieses Argument leer, wenn der Name beibehalten werden soll.
Objekttyp (Herkunft) | Der zu kopierende Objekttyp. Klicken Sie auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Diagramm, Gespeicherte Prozedur. Um das im Datenbankfenster ausgewählte Objekt zu kopieren, lassen Sie dieses Argument leer.
Objektname (Herkunft) Der Name des zu kopierenden Objekts. Das Feld Objektname (Herkunft) zeigt alle Objekte in der Datenbank an, die dem im Argument Objekttyp (Herkunft) angegebenen Typ entsprechen. Klicken Sie im Feld Objekttyp (Herkunft) auf das zu kopierende Objekt. Wenn Sie das Feld Objekttyp (Herkunft) leer lassen, muss dieses Feld ebenfalls leer bleiben.

Wenn Sie ein Makro, das die Aktion KopierenObjekt enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkung

Geben Sie einen Wert für mindestens eines der Argumente Zieldatenbank und Neuer Name für diese Aktion ein.

Lassen Sie die Argumente Objekttyp (Herkunft) und Objektname (Herkunft) leer, so kopiert Microsoft Access das im Datenbankfenster ausgewählte Objekt. Um ein Objekt im Datenbankfenster auszuwählen, verwenden Sie die Aktion AuswählenObjekt, wobei das Argument Im Datenbankfenster auf Ja eingestellt ist.

Die Aktion KopierenObjekt ist mit dem Auswählen eines Objekts im Datenbankfenster, dem Klicken auf Kopieren im Menü Bearbeiten und dem anschließenden Klicken auf Einfügen im Menü Bearbeiten vergleichbar. Das Dialogfeld Einfügen als wird angezeigt, so dass Sie dem Objekt einen neuen Namen geben können. Die Aktion KopierenObjekt führt diese Schritte automatisch aus.

Anmerkung Beim Kopieren von Datenzugriffsseiten kopiert die KopierenObjekt-Aktion lediglich die Verknüpfung zu der entsprechenden .htm-Datei und nicht die eigentliche .htm-Datei.

Sie können auch ein im Datenbankfenster ausgewähltes Objekt oder ein geöffnetes Objekt im Tabellenfenster, Abfragefenster, Formularfenster, Berichtsfenster, Makrofenster oder Modulfenster kopieren, indem Sie im Menü Datei auf Speichern unter/Exportieren klicken. Das Dialogfeld Speichern unter ermöglicht es Ihnen, eine Kopie des Objekts unter einem neuen Namen in der aktuellen Datenbank zu speichern oder das Objekt selbst in einer anderen Datenbank zu speichern. War dieses Objekt bereits gespeichert, und speichern Sie es in der aktuellen Datenbank unter einem neuen Namen, so bleibt die Originalversion mit dem alten Namen erhalten.

Pfad und Dateiname der Zieldatenbank müssen existieren, bevor das Makro die Aktion KopierenObjekt ausführt. Andernfalls zeigt Microsoft Access eine Fehlermeldung an.

Zum Ausführen der Aktion KopierenObjekt in Visual Basic verwenden Sie die CopyObject-Methode des DoCmd-Objekts.


 LöschenObjekt-Aktion

LöschenObjekt-Aktion

Mit Hilfe der LöschenObjekt-Aktion können Sie ein angegebenes Datenbankobjekt löschen.

Einstellung

Die LöschenObjekt-Aktion verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Typ des zu löschenden Objekts. Klicken Sie im Feld Objekttyp im Bereich Aktionsargumente des Makrofensters auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht oder Diagramm, Gespeicherte Prozedur. Lassen Sie dieses Feld leer, um das im Datenbankfenster ausgewählte Objekt zu löschen.
Objektname | Name des zu löschenden Objekts. Das Feld Objektname zeigt alle Datenbankobjekte des im Argument Objekttyp angegebenen Objekttyps an. Wenn Sie für das Feld Objekttyp keine Angabe machen, lassen Sie auch dieses Feld leer.
 | Wenn Sie ein Makro, das die LöschenObjekt-Aktion enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Objekt mit dem angegebenen Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Achtung Wenn Sie die Argumente Objekttyp und Objektname leer lassen, löscht Microsoft Access das im Datenbankfenster aktuell ausgewählte Objekt, ohne eine Warnmeldung anzuzeigen, wenn es auf die LöschenObjekt-Aktion stößt. Verwenden Sie die AuswählenObjekt-Aktion, und stellen Sie das Argument im Datenbankfenster auf Ja ein, um ein Objekt im Datenbankfenster auszuwählen.

Anmerkung

Sie können die LöschenObjekt-Aktion verwenden, um temporäre Objekte zu löschen, die beim Ausführen eines Makros erstellt wurden. Angenommen, Sie verwenden die ÖffnenAbfrage-Aktion, um eine Tabellenerstellungsabfrage auszuführen, die eine temporäre Tabelle erstellt. Wenn Sie die temporäre Tabelle nicht mehr benötigen, können Sie die LöschenObjekt-Aktion ausführen, um die temporäre Tabelle zu löschen.

Diese Aktion hat dieselbe Wirkung wie das Auswählen eines Objekts im Datenbankfenster und das anschließende Drücken von ENTF oder Klicken auf Löschen im Menü Bearbeiten.

Zum Ausführen der Aktion LöschenObjekt in Visual Basic verwenden Sie die DeleteObject-Methode des DoCmd-Objekts.


 Maximieren-Aktion

Maximieren-Aktion

Sie können die Aktion Maximieren verwenden, um das aktive Fenster in ein Vollbild zu vergrößern, damit es das Microsoft Access-Fenster ausfüllt. Mit dieser Aktion können Sie den größtmöglichen Teil des Objekts im aktiven Fenster anzeigen.

Anmerkung Diese Aktion kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen zu Modulfenstern finden Sie im Thema zur WindowState-Eigenschaft.

Einstellung

Die Aktion Maximieren verwendet keine Argumente.

Anmerkung

Diese Aktion hat dieselbe Wirkung wie das Klicken auf die Schaltfläche Maximieren in der oberen rechten Ecke des Fensters oder das Klicken auf Maximieren im Systemmenü.

Sie können die Aktion Wiederherstellen verwenden, um ein maximiertes Fenster wieder in seiner bisherigen Größe darzustellen.

Tipps

  • Verwenden Sie ggf. die Aktion AuswählenObjekt, wenn das zu maximierende Fenster nicht das aktive Fenster ist.

  • Wenn Sie ein Fenster in Microsoft Access maximieren, werden alle anderen Fenster, die Sie öffnen oder zu denen Sie wechseln, ebenfalls maximiert. Popupformulare werden jedoch nicht maximiert. Wenn ein Formular seine Größe beibehalten soll, obwohl andere Fenster maximiert werden, stellen Sie seine PopUp-Eigenschaft auf Ja ein.

Zum Ausführten der Aktion Maximieren in Visual Basic verwenden Sie die Maximize-Methode des DoCmd-Objekts.


 Meldung-Aktion

Meldung-Aktion

Sie können die Aktion Warnmeldung verwenden, um ein Meldungsfeld anzuzeigen, das eine Warnung oder Informationen enthält. Beispielsweise können Sie die Aktion Warnmeldung in Makros für Gültigkeitsüberprüfungen verwenden. Wenn ein Steuerelement oder ein Datensatz eine Gültigkeitsbedingung im Makro nicht erfüllt, können Sie in einem Meldungsfeld eine Fehlermeldung und Hinweise zur korrekten Dateneingabe anzeigen.

Einstellung

Die Aktion Warnmeldung verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Meldung | Der Text im Meldungsfeld. Geben Sie den Meldungstext im Abschnitt Aktionsargumente des Makrofensters im Feld Warnmeldung ein. Sie können bis zu 256 Zeichen oder einen Ausdruck (mit vorangestelltem Gleichheitszeichen) eingeben.
Signalton | Gibt an, ob die Lautsprecher des Computers bei Anzeige der Meldung einen Signalton ausgeben. Klicken Sie auf Ja (um einen Signalton auszugeben) oder auf Nein (um keinen Signalton auszugeben). Die Standardeinstellung ist Ja.
Typ | Der Typ des Meldungsfelds. Jeder Typ verfügt über ein anderes Symbol. Klicken Sie auf Ohne Symbol, Kritisch, Warnmeldung (?), Warnmeldung (!) oder Information. Die Standardeinstellung ist Ohne Symbol.
Titel | Der Text, der in der Titelleiste des Meldungsfelds angezeigt wird. Sie können z. B. den Text "Überprüfen der Kundennummer" in der Titelleiste anzeigen. Wenn Sie dieses Argument leer lassen, wird "Microsoft Access" angezeigt.

Anmerkung

Sie können mit der Aktion Warnmeldung eine formatierte Fehlermeldung erstellen, vergleichbar den von Microsoft Access angezeigten eingebauten Fehlermeldungen. Mit der Aktion Warnmeldung können Sie die Meldung im Argument Meldung in drei Abschnitten angeben, wobei die Abschnitte jeweils durch ein @-Zeichen voneinander getrennt werden.

Das folgende Beispiel zeigt ein formatiertes Meldungsfeld mit einer in Abschnitte unterteilten Meldung an. Der erste Textabschnitt in der Meldung wird als fett formatierte Überschrift angezeigt. Der zweite Abschnitt wird als unformatierter Text unter der Überschrift angezeigt. Der dritte Abschnitt wird ebenfalls als unformatierter Text unter dem zweiten Abschnitt angezeigt und ist von diesem durch eine Leerzeile getrennt.

Geben Sie den folgenden Text im Argument Meldung ein:

Falsche Schaltfläche!@Diese Schaltfläche funktioniert nicht.@Verwenden Sie eine andere.

Anmerkung Wenn der Office-Assistent verfügbar ist, wird die Meldung in der Sprechblase des Assistenten und nicht in einem separaten Meldungsfeld angezeigt.

Sie können die Aktion Warnmeldung nicht in Visual Basic ausführen. Verwenden Sie stattdessen die Funktion MsgBox.


 Minimieren-Aktion

Minimieren-Aktion

Sie können die Aktion Minimieren verwenden, um das aktuelle Fenster auf eine kleine Titelleiste im unteren Bereich des Microsoft Access-Fensters zu verkleinern.

Anmerkung Diese Aktion kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen zu Modulfenstern finden Sie im Thema zur WindowState-Eigenschaft.

Einstellung

Die Aktion Minimieren verwendet keine Argumente.

Anmerkung

Sie können diese Aktion verwenden, um ein Fenster vom Bildschirm zu entfernen, wobei das Objekt weiterhin geöffnet bleibt. Sie können mit dieser Aktion auch ein Objekt öffnen, ohne das zugehörige Fenster anzuzeigen. Zum Anzeigen des Objekts verwenden Sie die Aktion AuswählenObjekt entweder zusammen mit der Aktion Maximieren oder mit der Aktion Wiederherstellen. Die Aktion Wiederherstellen stellt ein minimiertes Fenster wieder in seiner bisherigen Größe dar.

Die Aktion Minimieren hat dieselbe Wirkung wie das Klicken auf die Schaltfläche Minimieren in der oberen rechten Ecke des Fensters oder das Klicken auf Minimieren im Systemmenü.

Tipps

  • Verwenden Sie ggf. zuerst die Aktion AuswählenObjekt, wenn das zu minimierende Fenster nicht das aktive Fenster ist.

  • Sie minimieren das Datenbankfenster, indem Sie Aktion AuswählenObjekt mit dem auf Ja eingestellten Argument In Datenbankfenster und dann die Aktion Minimieren verwenden.

  • Sie können den Befehl Ausblenden aus dem Menü Fenster verwenden, um das aktive Fenster auszublenden. Das Fenster wird dann nicht auf Symbolgröße verkleinert, sondern es wird unsichtbar. Mit dem Befehl Erweitern aus dem Menü Fenster kann das Fenster wieder angezeigt werden. Sie können die beiden Befehle auch mit der Aktion AusführenBefehl in einem Makro ausführen.

  • Sie können auch die Aktion SetzenWert verwenden, um die Eigenschaft Visible eines Formulars so einzustellen, dass das Formularfenster ausgeblendet oder angezeigt wird.

Zum Ausführen der Aktion Minimieren in Visual Basic verwenden Sie die Minimize-Methode des DoCmd-Objekts.


 ÖffnenAbfrage-Aktion

ÖffnenAbfrage-Aktion

Sie können die Aktion ÖffnenAbfrage zum Öffnen einer Auswahl- oder Kreuztabellenabfrage in der Datenblattansicht, Entwurfsansicht oder Seitenansicht verwenden. Diese Aktion führt eine Aktionsabfrage aus. Sie können auch einen Dateneingabemodus für die Abfrage auswählen.

Anmerkung Diese Aktion steht nur in derMicrosoft Access-Datenbank-Umgebung (.MDB) zur Verfügung. Informationen zur Verwendung der Access-Projekt-Umgebung (.ADP) finden Sie unter den Informationen zu den Aktionen ÖffnenSicht oder ÖffnenGespeicherteProzedur.

Einstellung

Die Aktion ÖffnenAbfrage verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Abfragename | Der Name der zu öffnenden Abfrage. Das Feld Abfragename im Bereich Aktionsargumente des Makrofensters zeigt alle Abfragen der aktuellen Datenbank an. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion ÖffnenAbfrage enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Abfrage mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Die Ansicht, in der die Abfrage geöffnet wird. Klicken Sie im Feld Ansicht auf Datenblatt, Entwurf oder Seitenansicht. Die Standardeinstellung ist Datenblatt.
Datenmodus | Der Dateneingabemodus für die Abfrage. Dies betrifft nur Abfragen, die in der Datenblattansicht geöffnet werden. Klicken Sie auf Hinzufügen (der Benutzer kann neue Datensätze hinzufügen, jedoch keine bestehenden Datensätze bearbeiten), auf Bearbeiten (der Benutzer kann bestehende Datensätze bearbeiten und neue Datensätze hinzufügen) oder auf Nur lesen (der Benutzer kann die Datensätze nur ansehen). Die Standardeinstellung ist Bearbeiten.

Anmerkung

Wenn Sie für das Argument Ansicht auf Datenblatt klicken, zeigt Microsoft Access das Ergebnis an, falls es sich bei der Abfrage um eine Auswahl-, Kreuztabellen-, Union- oder Pass-Through-Abfrage handelt, deren Eigenschaft ReturnsRecords auf Ja eingestellt ist, oder es führt die Abfrage aus, falls es sich um eine Aktions-, Datendefinitions- oder Pass-Through-Abfrage handelt, deren Eigenschaft ReturnsRecords auf Nein eingestellt ist.

Die Aktion ÖffnenAbfrage ist vergleichbar mit dem Klicken auf die Schaltfläche Öffnen oder die Schaltfläche Entwurf im Datenbankfenster, nachdem eine Abfrage in der Registerkarte Abfragen ausgewählt wurde. Mit dieser Aktion können Sie zusätzliche Optionen auswählen.

Tipp Sie können eine Abfrage im Datenbankfenster auswählen und es in eine Makro-Aktionszeile ziehen. Dadurch erstellen Sie automatisch eine Aktion ÖffnenAbfrage, welche die Abfrage in der Datenblattansicht öffnet.

Das Wechseln zur Entwurfsansicht bei geöffneter Abfrage entfernt die Einstellungen des Arguments Datenmodus für die Abfrage. Diese Einstellung wird auch dann nicht mehr wirksam, wenn der Benutzer zur Datenblattansicht zurückkehrt.

Tipp Sollen die Systemmeldungen nicht angezeigt werden (die normalerweise beim Ausführen einer Aktionsabfrage angezeigt werden und anzeigen, dass es sich um eine Aktionsabfrage handelt und wie viele Datensätze betroffen sind), so können Sie die Aktion Warnmeldungen verwenden, um die Anzeige dieser Meldungen zu unterbinden.

Zum Ausführen der Aktion ÖffnenAbfrage in Visual Basic verwenden Sie die OpenQuery-Methode des DoCmd-Objekts.


 ÖffnenBericht-Aktion

ÖffnenBericht-Aktion

Die Aktion ÖffnenBericht öffnet einen Bericht in der Entwurfsansicht oder Seitenansicht, oder sie druckt den Bericht unmittelbar aus. Sie können auch die Datensätze einschränken, die im Bericht gedruckt werden.

Einstellung

Die Aktion ÖffnenBericht verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Berichtsname Der Name des zu öffnenden Berichts. Das Feld Berichtsname im Bereich Aktionsargumente des Makrofensters zeigt alle Datensätze der aktuellen Datenbank an. Dieses Argument ist erforderlich.

Wenn Sie ein Makro, das die Aktion ÖffnenBericht enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access den Bericht mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Die Ansicht, in welcher der Bericht geöffnet wird. Klicken Sie im Feld Ansicht auf Drucken (um den Bericht sofort auszudrucken), Entwurf oder Seitenansicht. Die Standardeinstellung ist Drucken.
Filtername | Ein Filter, der die Datensätze des Berichts einschränkt. Sie können den Namen einer bestehenden Abfrage oder den Namen eines Filters eingeben, der als Abfrage gespeichert wurde. Allerdings muss die Abfrage alle Felder des zu öffnenden Berichts enthalten, oder seine Eigenschaft OutputAllFields muss auf Ja eingestellt sein.
Bedingung Eine gültige SQL-WHERE-Klausel (ohne das Wort WHERE) oder ein Ausdruck, mit dem Microsoft Access Datensätze aus der dem Bericht zugrunde liegenden Tabelle oder Abfrage auswählt. Wenn Sie einen Filter mit dem Argument Filtername auswählen, wendet Microsoft Access die WHERE-Klausel auf das Filterergebnis an.

Um ein Formular zu öffnen und seine Datensätze auf solche zu beschränken, die dem Wert eines Steuerelements in einem anderen Formular entsprechen, verwenden Sie den folgenden Ausdruck:

[Feldname] = Formulare![Formularname]![Steuerelementname in anderem Formular]

Das Argument Feldname entspricht dem Namen eines Feldes in der zugrunde liegenden Tabelle oder Abfrage des zu öffnenden Berichts. Das Argument Steuerelement in anderem Formular entspricht dem Namen des Steuerelements in dem anderen Formular, das den Wert enthält, mit dem die Datensätze im Bericht übereinstimmen müssen.
Das Argument Bedingung darf bis zu 256 lang sein. Ist es notwendig, eine komplexere SQL-WHERE-Klausel einzugeben, verwenden Sie die OpenReport-Methode des DoCmd-Objekts in Visual Basic. In Visual Basic können SQL-Anweisungen mit WHERE-Klauseln bis zu 32.768 Zeichen lang sein.

Anmerkung

Die Einstellung Drucken des Arguments Ansicht druckt den Bericht unmittelbar unter Verwendung der aktuellen Druckereinstellungen aus, ohne das Dialogfeld Drucken anzuzeigen. Sie können auch die Aktion ÖffnenBericht verwenden, um einen Bericht zu öffnen und einzurichten, und dann die Aktion Drucken verwenden, um den Bericht zu drucken. In bestimmten Situationen bearbeiten Sie z. B. den Bericht oder verwenden die Aktion Drucken, um die Druckereinstellungen anzupassen, bevor Sie den Bericht drucken.

Der Filter und die WHERE-Bedingung, die Sie anwenden, wird als Einstellung der Eigenschaft Filter des Berichts übernommen.

Die Aktion ÖffnenBericht ist vergleichbar mit dem Klicken auf die Schaltfläche Entwurf, die Schaltfläche Seitenansicht oder den Befehl Drucken im Menü Datei im Datenbankfenster, nachdem ein Bericht ausgewählt wurde.

Tipps

  • Wenn Sie ähnliche Berichte für verschiedene Datenmengen drucken möchten, verwenden Sie einen Filter oder eine WHERE-Klausel, um die im Bericht ausgegebenen Datensätze einzuschränken. Bearbeiten Sie dann das Makro und wenden einen anderen Filter an, oder verändern Sie das Argument Bedingung.

  • Sie können einen Bericht im Datenbankfenster auswählen und ihn in eine Makro-Aktionszeile ziehen. Damit erstellen Sie automatisch eine Aktion ÖffnenBericht, die den Bericht in der Seitenansicht öffnet.


 ÖffnenDiagramm-Aktion

ÖffnenDiagramm-Aktion

Mit der Aktion ÖffnenDiagramm können Sie in der Entwurfsansicht ein Datenbankdiagramm öffnen.

Einstellung

Die Aktion ÖffnenDiagramm verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Diagrammname | Der Name des zu öffnenden Datenbankdiagramms. Das Feld Diagrammname im Bereich Aktionsargumente des Makrofensters zeigt alle Datenbankdiagramme der aktuellen Datenbank an. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion ÖffnenDiagramm enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Diagramm mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkungen

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Entwurf im Datenbankfenster, nachdem ein Datenbankdiagramm in der Registerkarte Datenbankdiagramme ausgewählt wurde.

Tipp Sie können ein Datenbankdiagramm im Datenbankfenster markieren und es in eine Makroaktionszeile ziehen. Dadurch wird automatisch eine Aktion ÖffnenDiagramm erstellt, die das Datenbankdiagramm in der Entwurfsansicht öffnet.

Zum Ausführen der Aktion ÖffnenDiagramm in Visual Basic verwenden Sie die OpenDiagram-Methode des DoCmd-Objekts.


 ÖffnenFormular-Aktion

ÖffnenFormular-Aktion

Sie können die Aktion ÖffnenFormular zum Öffnen eines Formulars in der Formularansicht, Formular-Entwurfsansicht, Seitenansicht oder Datenblattansicht verwenden. Sie können Dateneingabe- und Fenstermodi für das Formular auswählen und die Datensätze einschränken, die im Formular angezeigt werden.

Einstellung

Die Aktion ÖffnenFormular verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Formularname Der Name des zu öffnenden Formulars. Das Feld Formularname im Bereich Aktionsargumente des Makrofensters zeigt alle Formulare der aktuellen Datenbank an. Dieses Argument ist erforderlich.

Wenn Sie ein Makro, das die Aktion ÖffnenFormular enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Formular mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Die Ansicht, in der das Formular geöffnet wird. Klicken Sie im Feld Ansicht auf Formular, Entwurf, Seitenansicht oder Datenblatt. Die Standardeinstellung ist Formular.
Anmerkung Die Einstellung des Arguments Ansicht hat Vorrang vor den Einstellungen der Eigenschaften Standardansicht und Zugelassene Ansicht(en) des Formulars. Ist z.B. die Eigenschaft Zugelassene Ansicht(en) eines Formulars auf Datenblatt eingestellt, so können Sie trotzdem die Aktion ÖffnenFormular verwenden, um das Formular in der Formularansicht zu öffnen.
Filtername | Ein Filter, der die Datensätze des Formulars einschränkt oder sortiert. Sie können den Namen einer bestehenden Abfrage oder den Namen eines Filters eingeben, der als Abfrage gespeichert wurde. Allerdings muss die Abfrage alle Felder der geöffneten Abfrage enthalten, oder ihre Eigenschaft OutputAllFields muss auf Ja eingestellt sein.
Bedingung Eine gültige SQL-WHERE-Klausel (ohne das Wort WHERE) oder ein Ausdruck, mit dem Microsoft Access Datensätze aus der dem Formular zugrunde liegenden Tabelle oder Abfrage auswählt. Wenn Sie einen Filter mit dem Argument Filtername auswählen, wendet Microsoft Access die WHERE-Klausel auf das Filterergebnis an.

Um ein Formular zu öffnen und seine Datensätze auf solche zu beschränken, die dem Wert eines Steuerelements in einem anderen Formular entsprechen, verwenden Sie den folgenden Ausdruck:

[Feldname] = Formulare![Formularname]![Steuerelementname in anderem Formular]

Das Argument Feldname entspricht dem Namen eines Feldes in der zugrunde liegenden Tabelle oder Abfrage des zu öffnenden Formulars. Das Argument Steuerelement in anderem Formular entspricht dem Namen des Steuerelements in dem anderen Formular, das den Wert enthält, mit dem die Datensätze im ersten Formular übereinstimmen müssen.
Anmerkung Das Argument Bedingung darf bis zu 256 Zeichen lang sein. Wenn es notwendig ist, eine längere SQL-WHERE-Klausel einzugeben, verwenden Sie die OpenForm-Methode des DoCmd-Objekts in Visual Basic. In Visual Basic können SQL-Anweisungen mit WHERE-Klauseln bis zu 32.768 Zeichen lang sein.
Datenmodus | Der Dateneingabemodus für das Formular. Dies betrifft nur Formulare, die in der Formularansicht oder Datenblattansicht geöffnet werden. Klicken Sie auf Hinzufügen (der Benutzer kann neue Datensätze hinzufügen, jedoch keine bestehenden Datensätze bearbeiten), auf Bearbeiten (der Benutzer kann bestehende Datensätze bearbeiten und neue Datensätze hinzufügen) oder auf Nur lesen (der Benutzer kann die Datensätze nur ansehen). Die Standardeinstellung ist Bearbeiten.
Anmerkungen
  • Die Einstellung des Arguments Datenmodus hat Vorrang vor den Einstellungen der Eigenschaften AllowEdits, AllowDeletions, AllowAdditions und DataEntry des Formulars. Ist z.B. die Eigenschaft AllowEdits eines Formulars auf Nein eingestellt, so können Sie immer noch die Aktion ÖffnenFormular verwenden, um das Formular im Modus Bearbeiten zu öffnen.

  • Wenn Sie dieses Argument leer lassen, öffnet Microsoft Access das Formular in dem Dateneingabemodus, der mit den Eigenschaften AllowEdits, AllowDeletions, AllowAdditions und DataEntry eingestellt wurde.
Fenstermodus | Der Fenstermodus, in dem das Formular geöffnet wird. Klicken Sie auf Normal (das Formular befindet sich in dem von seinen Eigenschaften eingestellten Modus), auf Ausgeblendet (das Formular ist ausgeblendet), auf Symbol (das Formular wird unten am Bildschirm in Form einer kleinen Titelleiste geöffnet) oder auf Dialog (die Eigenschaften Modal und PopUp des Formulars werden auf Ja eingestellt). Die Standardeinstellung ist Normal.

Anmerkung

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Öffnen oder die Schaltfläche Entwurf im Datenbankfenster, nachdem ein Formular in der Registerkarte Formular ausgewählt wurde.

Ein Formular kann gebunden (es muss geschlossen oder ausgeblendet werden, bevor der Benutzer eine andere Aktion ausführen kann) oder nicht gebunden (der Benutzer kann zu anderen Fenstern wechseln, während das Formular geöffnet ist). Es kann sich auch um ein Popupformular handeln (ein Formular für Benutzereingaben oder zur Anzeige von Informationen, das immer im Vordergrund, d.h. vor allen anderen Microsoft Access-Fenstern, angezeigt wird). Sie stellen die Eigenschaften Modal und PopUp ein, wenn Sie das Formular entwerfen. Wenn Sie das Argument Fenstermodus auf den Wert Normal einstellen, wird das Formular in dem Modus geöffnet, den diese beiden Eigenschafteneinstellungen festlegen. Wenn Sie das Argument Fenstermodus auf Dialog einstellen, werden beide Eigenschaften auf Ja eingestellt. Ein als ausgeblendet oder als Symbol geöffnetes Formular kehrt zu dem von seinen Eigenschafteneinstellungen festgelegten Modus zurück, wenn Sie es anzeigen oder wiederherstellen.

Wenn Sie ein Formular öffnen, dessen Argument Fenstermodus auf Dialog eingestellt ist, unterbricht Microsoft Access das Makro solange, bis das Formular geschlossen oder ausgeblendet wird. Sie können ein Formular ausblenden, indem Sie die Eigenschaft Visible mit der Aktion SetzenWert auf Nein einstellen.

Tipp Sie können ein Formular im Datenbankfenster auswählen und es in eine Makro-Aktionszeile ziehen. Damit erstellen Sie automatisch eine Aktion ÖffnenFormular, die das Formular in der Formularansicht öffnet.

Das Wechseln zur Entwurfsansicht bei geöffnetem Formular entfernt die meisten Argumenteinstellungen für das Formular, z.B. die Argumenteinstellungen Datenmodus und Fenstermodus. Sie werden auch dann nicht mehr wirksam, wenn der Benutzer zur Formularansicht oder Datenblattansicht zurückkehrt.

Der Filter und die WHERE-Bedingung, die Sie anwenden, wird als Einstellung der Eigenschaft Filter des Formulars übernommen.


 ÖffnenGespeicherteProzedur-Aktion

ÖffnenGespeicherteProzedur-Aktion

Mit der Aktion ÖffnenGespeicherteProzedur können Sie eine gespeicherte Prozedur in der Datenblattansicht, der Entwurfsansicht oder der Seitenansicht öffnen. Diese Aktion führt die benannte gespeicherte Prozedur beim Öffnen in der Datenblattansicht aus. Sie können die Dateneingabe für die gespeicherte Prozedur wählen und die von der Prozedur angezeigten Datensätze einschränken.

Einstellung

Die Aktion ÖffnenGespeicherteProzedur verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Gespeicherte Prozedur | Der Name der zu öffnenden gespeicherten Prozedur. Das Feld Gespeicherte Prozedur im Abschnitt Aktionsargumente des Makrofensters zeigt alle gespeicherten Prozeduren der aktuellen Datenbank an. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion ÖffnenGespeicherteProzedur enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die gespeicherte Prozedur mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Sicht | Die Ansicht, in der die gespeicherte Prozedur geöffnet wird. Klicken Sie im Feld Sicht auf Datenblatt, Entwurf oder Seitenansicht. Die Standardeinstellung ist Datenblatt.
Datenmodus | Der Dateneingabemodus für die gespeicherte Prozedur. Dies betrifft nur gespeicherte Prozeduren, die in der Datenblattansicht geöffnet werden. Klicken Sie auf Hinzufügen (der Benutzer kann neue Datensätze hinzufügen, jedoch keine bestehenden Datensätze anzeigen oder bearbeiten), auf Bearbeiten (der Benutzer kann bestehende Datensätze anzeigen oder bearbeiten und neue Datensätze hinzufügen) oder auf Nur lesen (der Benutzer kann Datensätze nur anzeigen). Die Standardeinstellung ist Bearbeiten.

Anmerkungen

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Ausführen bzw. die Schaltfläche Entwurf im Datenbankfenster, nachdem eine Datenzugriffsseite in der Registerkarte Gespeicherte Prozeduren ausgewählt wurde.

Das Wechseln zur Entwurfsansicht bei geöffneter gespeicherter Prozedur entfernt die Einstellung des Arguments Datenmodus für die Prozedur. Diese Einstellung ist auch dann nicht mehr wirksam, wenn der Benutzer zur Datenblattansicht zurückkehrt.

Tipps Sie können eine gespeicherte Prozedur im Datenbankfenster markieren und sie in eine Makroaktionszeile ziehen. Damit erstellen Sie automatisch eine Aktion ÖffnenGespeicherteProzedur, die diese Prozedur in der Datenblattansicht öffnet.

Wenn Sie die Systemmeldungen nicht anzeigen möchten, die beim Ausführen einer gespeicherten Prozedur normalerweise ausgegeben werden (Hinweis, dass es sich hier um eine gespeicherte Prozedur handelt, und Anzeige der Anzahl betroffener Datensätze), können Sie die Anzeige dieser Meldungen mit Hilfe der Aktion Warnmeldungen unterdrücken.

Zum Ausführen der Aktion ÖffnenGespeicherteProzedur in Visual Basic verwenden Sie die OpenStoredProcedure-Methode des DoCmd-Objekts.


 ÖffnenModul-Aktion

ÖffnenModul-Aktion

Mit Hilfe der ÖffnenModul-Aktion können Sie ein angegebenes Visual Basic-Modul so öffnen, dass eine bestimmte Prozedur angezeigt wird. Hierbei kann es sich um eine Sub-Prozedur, eine Function-Prozedur oder eine Ereignisprozedur handeln.

Einstellung

Die ÖffnenModul-Aktion verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Modulname | Name des zu öffnenden Moduls. Lassen Sie dieses Feld leer, wenn Sie alle Standardmodule in der Datenbank nach einer bestimmten Prozedur durchsuchen und das betreffende Modul so öffnen möchten, dass diese Prozedur angezeigt wird.
 | Wenn Sie ein Makro, das die ÖffnenModul-Aktion enthält, in einer Bibliotheksdatenbank ausführen, sucht das Modul mit dem angegebenen Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Prozedurname | Name der Prozedur, an der das Modul geöffnet werden soll. Wenn Sie dieses Feld leer lassen, wird das Modul geöffnet und dessen Deklarationsbereich angezeigt.

Anmerkung Für mindestens eines der Argumente Modulname oder Prozedurname müssen Sie einen gültigen Namen eingeben.

Anmerkung

Verwenden Sie diese Aktion zum Öffnen einer Ereignisprozedur, indem Sie die Ereignisprozedur im Argument Modulname und im Argument Prozedurname angeben. Wenn Sie im Formular Bestellungen z. B. die Click-Ereignisprozedur der Schaltfläche RechnungDrucken öffnen möchten, stellen Sie das Argument Modulname auf Form.Bestellungen und das Argument Prozedurname auf RechnungDrucken_Click ein. Damit Sie die Ereignisprozedur eines Formulars oder Berichts anzeigen können, muss das Formular oder der Bericht geöffnet sein.

Analog müssen Sie zum Öffnen einer Prozedur in einem Klassenmodul den Modulnamen angeben, das Klassenmodul braucht jedoch nicht geöffnet zu sein.

Damit Sie eine private Prozedur öffnen können, muss das Modul, das die Prozedur enthält, geöffnet sein.

Diese Aktion hat dieselbe Wirkung wie das Markieren eines Moduls im Datenbankfenster und das anschließende Klicken auf die Schaltfläche Entwurf. Mit Hilfe dieser Aktion können Sie auch einen Prozedurnamen angeben und die Standardmodule in einer Datenbank nach Prozeduren durchsuchen.

Tipp Sie können ein Modul im Datenbankfenster markieren und es in eine Makro-Aktionszeile ziehen. Dadurch wird automatisch eine ÖffnenModul-Aktion erstellt, die das Modul öffnet und dessen Deklarationsbereich anzeigt.

Zum Ausführen der Aktion ÖffnenModul in Visual Basic verwenden Sie die OpenModule-Methode des DoCmd-Objekts.


 ÖffnenSicht-Aktion

ÖffnenSicht-Aktion

Mit der Aktion ÖffnenSicht können Sie eine Sicht in der Datenblattansicht, der Entwurfsansicht oder der Seitenansicht öffnen. Diese Aktion führt die benannte Ansicht beim Öffnen in der Datenblattansicht aus. Sie können den Dateneingabemodus für die Ansicht wählen und die von der Ansicht angezeigten Datensätze einschränken.

Einstellung

Die Aktion ÖffnenSicht verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Sichtname | Der Name der zu öffnenden Ansicht. Das Feld Sichtname im Bereich Aktionsargumente des Makrofensters zeigt alle Ansichten der aktuellen Datenbank an. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion ÖffnenSicht enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Ansicht mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Sicht | Die Ansicht, in der die Ansicht geöffnet wird. Klicken Sie im Feld Sicht auf Datenblatt, Entwurf oder Seitenansicht. Die Standardeinstellung ist Datenblatt.
Datenmodus | Der Dateneingabemodus für die Ansicht. Dies betrifft nur Ansichten, die in der Datenblattansicht geöffnet werden. Klicken Sie auf Hinzufügen (der Benutzer kann neue Datensätze hinzufügen, jedoch keine bestehenden Datensätze anzeigen oder bearbeiten), auf Bearbeiten (der Benutzer kann bestehende Datensätze anzeigen oder bearbeiten und neue Datensätze hinzufügen) oder auf Nur lesen (der Benutzer kann Datensätze nur anzeigen). Die Standardeinstellung ist Bearbeiten.

Anmerkungen

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Öffnen bzw. die Schaltfläche Entwurf im Datenbankfenster, nachdem eine Ansicht in der Registerkarte Sichten ausgewählt wurde.

Das Wechseln zur Entwurfsansicht bei geöffneter Ansicht entfernt die Einstellung des Arguments Datenmodus für die Ansicht. Diese Einstellung ist auch dann nicht mehr wirksam, wenn der Benutzer zur Datenblattansicht zurückkehrt.

Tipps Sie können eine Ansicht im Datenbankfenster auswählen und sie in eine Makroaktionszeile ziehen. Damit erstellen Sie automatisch eine Aktion ÖffnenSicht, die die Ansicht in der Datenblattansicht öffnet.

Wenn Sie die Systemmeldungen nicht anzeigen möchten, die beim Ausführen einer Ansicht normalerweise ausgegeben werden (Hinweis, dass es sich hier um eine Ansicht handelt, und Anzeige der Anzahl betroffener Datensätze), können Sie die Anzeige dieser Meldungen mit Hilfe der Aktion Warnmeldungen unterdrücken.

Zum Ausführen der Aktion ÖffnenSicht in Visual Basic verwenden Sie die OpenView-Methode des DoCmd-Objekts.


 ÖffnenTabelle-Aktion

ÖffnenTabelle-Aktion

Sie können die Aktion ÖffnenTabelle zum Öffnen einer Tabelle in der Datenblattansicht, Entwurfsansicht oder Seitenansicht verwenden. Sie können auch einen Dateneingabemodus für die Tabelle auswählen.

Einstellung

Die Aktion ÖffnenTabelle verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Tabellenname | Der Name der zu öffnenden Tabelle. Das Feld Tabellenname im Bereich Aktionsargumente des Makrofensters zeigt alle Tabellen der aktuellen Datenbank an. Dieses Argument ist erforderlich.
 | Wenn Sie ein Makro, das die Aktion ÖffnenTabelle enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Tabelle mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Die Ansicht, in der die Tabelle geöffnet wird. Klicken Sie im Feld Ansicht auf Datenblatt, Entwurf oder Seitenansicht. Die Standardeinstellung ist Datenblatt.
Datenmodus | Der Dateneingabemodus für die Tabelle. Dies betrifft nur Tabellen, die in der Datenblattansicht geöffnet werden. Klicken Sie auf Hinzufügen (der Benutzer kann neue Datensätze hinzufügen, jedoch keine bestehenden Datensätze bearbeiten), auf Bearbeiten (der Benutzer kann bestehende Datensätze bearbeiten und neue Datensätze hinzufügen) oder auf Nur lesen (der Benutzer kann die Datensätze nur ansehen). Die Standardeinstellung ist Bearbeiten.

Anmerkung

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Öffnen oder die Schaltfläche Entwurf im Datenbankfenster, nachdem eine Tabelle in der Registerkarte Tabellen ausgewählt wurde.

Tipp Sie können eine Tabelle im Datenbankfenster auswählen und in eine Makro-Aktionszeile ziehen. Damit erstellen Sie automatisch eine Aktion ÖffnenTabelle, welche die Tabelle in der Datenblattansicht öffnet.

Das Wechseln zur Entwurfsansicht bei geöffneter Tabelle entfernt die Einstellungen des Arguments Datenmodus der Tabelle. Diese Einstellung wird auch dann nicht mehr wirksam, wenn der Benutzer zur Datenblattansicht zurückkehrt.

Zum Ausführen der Aktion ÖffnenTabelle in Visual Basic verwenden Sie die OpenTable-Methode des DoCmd-Objekts.


 Positionieren-Aktion

Positionieren-Aktion

Sie können die Aktion Positionieren verwenden, um das aktive Fenster zu verschieben oder seine Größe zu verändern.

Einstellung

Die Aktion Positionieren verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Rechts | Die neue horizontale Position der oberen linken Ecke des Fensters, gemessen vom linken Rand des umgebenden Fensters. Geben Sie die Position im Abschnitt Aktionsargumente des Makrofensters im Feld Rechts ein.
Unten | Die neue vertikale Position der oberen linken Ecke des Fensters, gemessen vom oberen Rand des umgebenden Fensters.
Breite | Die neue Breite des Fensters.
Höhe | Die neue Höhe des Fensters.

Wenn Sie für ein Argument keinen Wert angeben, verwendet Microsoft Access die aktuellen Einstellungen des Fensters.

Geben Sie für mindestens ein Argument einen Wert ein.

Anmerkung Die Maßeinheiten werden in Zentimetern oder Zoll angegeben, abhängig von der Maßeinheit, die in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen in der Registerkarte Zahlen eingestellt ist.

Anmerkung

Diese Aktion ist mit dem Klicken auf Verschieben oder Größe ändern im Systemmenü des Fensters vergleichbar. Bei den Menübefehlen verwenden Sie die Pfeiltasten der Tastatur, um die Größe oder Position des Fensters zu ändern. Bei der Aktion Positionieren geben Sie die Position und Abmessungen direkt ein. Sie können die Größe und Position von Fenstern auch mit der Maus ändern.

Sie können diese Aktion in jedem Fenster und in jeder Ansicht verwenden.

Tipps

  • Um ein Fenster zu verschieben, ohne die Größe zu ändern, geben Sie Werte für die Argumente Rechts und Unten ein, aber lassen Sie die Argumente Breite und Höhe leer.

  • Um die Größe des Fensters zu ändern, ohne es zu verschieben, geben Sie Werte für die Argumente Breite und Höhe ein, aber lassen Sie die Argumente Rechts und Unten leer.

Zum Ausführen der Aktion Positionieren in Visual Basic verwenden Sie die MoveSize-Methode des DoCmd-Objekts.


 Sanduhr-Aktion

Sanduhr-Aktion

Sie können die Aktion Sanduhr verwenden, um den Mauszeiger in Form einer Sanduhr (oder eines beliebigen anderen Symbols) anzuzeigen, während ein Makro ausgeführt wird. Diese Aktion ist ein visueller Hinweis für den Benutzer, dass momentan ein Makro ausgeführt wird. Dies erweist sich insbesondere dann als hilfreich, wenn eine Makroaktion oder das Makro selbst eine längere Ausführungszeit beansprucht.

Einstellung

Die Aktion Sanduhr verwendet das folgende Argument.

Aktionsargument | Beschreibung
Sanduhr | Klicken Sie im Abschnitt Aktionsargumente des Makrofensters im Feld Sanduhr auf Ja (um das Symbol anzuzeigen) oder Nein (um den normalen Mauszeiger anzuzeigen). Die Standardeinstellung ist Ja.

Anmerkung

Häufig wird diese Aktion verwendet, wenn Sie das Echo mit der Aktion Echo ausgeschaltet haben. Wenn das Echo ausgeschaltet wird, führt Microsoft Access solange keine Bildschirmaktualisierung aus, bis das Makro beendet ist.

Microsoft Access stellt die Aktion Sanduhr automatisch auf Nein ein, wenn das Makro abgeschlossen ist.

Anmerkungen

  • In Microsoft Windows 95 zeigt diese Aktion das Symbol an, das Sie in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Maus in der Registerkarte Zeiger für Ausgelastet eingestellt haben (Standardeinstellung ist eine bewegte Sanduhr).

  • In Windows NT wird das Symbol verwendet, das Sie in der Windows-Systemsteuerung im Dialogfeld Cursor für Warten eingestellt haben (Standardeinstellung ist ebenfalls eine Sanduhr).

  • In beiden Fällen können Sie ein anderes Symbol wählen.

Zum Ausführen der Aktion Sanduhr in Visual Basic verwenden Sie die Hourglass-Methode des DoCmd-Objekts.


 Schließen-Aktion

Schließen-Aktion

Sie können die Aktion Schließen verwenden, um ein bestimmtes Microsoft Access-Fenster oder, wenn kein Fenster angegeben wird, das aktive Fenster zu schließen.

Einstellung

Die Aktion Schließen verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des Objekts, dessen Fenster Sie schließen möchten. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Objekttyp auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Diagramm oder Gespeicherte Prozedur. Um das aktive Fenster auszuwählen, lassen Sie dieses Argument leer.
 | Anmerkung Wenn ein Modul im Visual Basic-Editor geschlossen wird, müssen Sie im Argument Objekttyp die Einstellung Modul verwenden.
Objektname | Der Name des zu schließenden Objekts. Das Feld Objektname zeigt alle Objekte in der Datenbank an, die dem im Argument Objekttyp angegebenen Typ entsprechen. Klicken Sie auf das Objekt, um es zu schließen. Wenn Sie das Feld Objekttyp leer lassen, muss dieses Feld ebenfalls leer bleiben.
Speichern | Gibt an, ob Veränderungen an einem Objekt beim Schließen gespeichert werden sollen. Klicken Sie auf Ja (um das Objekt zu speichern), auf Nein (um das Objekt zu schließen, ohne es zu speichern), oder auf Nachfragen (um den Benutzer zu fragen, ob das Objekt gespeichert werden soll oder nicht). Die Standardeinstellung ist Nachfragen.

Anmerkung

Die Aktion Schließen betrifft alle Datenbankobjekte, die der Benutzer explizit öffnen oder schließen kann. Diese Aktion hat dieselbe Wirkung wie das Auswählen eines Objekts und das darauffolgende Schließen durch Klicken auf den Befehl Schließen im Menü Datei, auf Schließen im Systemmenü für das Fenster des Objekts oder auf die Schaltfläche Schließen {close.gif} des Objekts.

Wenn das Argument Speichern auf Nachfragen eingestellt ist und das Objekt vor Ausführung der Aktion Schließen noch nicht gespeichert wurde, fordert ein Dialogfeld den Benutzer auf, das Objekt zu speichern, bevor es vom Makro geschlossen wird. Haben Sie das Argument Warnmeldungen An der Aktion Warnmeldungen auf Nein eingestellt, so wird das Dialogfeld nicht angezeigt, und das Objekt wird automatisch gespeichert.

Zum Ausführen der Aktion Schließen in Visual Basic verwenden Sie die Methode Close des DoCmd-Objekts.


 SendenObjekt-Aktion

SendenObjekt-Aktion

Mit Hilfe der Aktion SendenObjekt können Sie das angegebene Microsoft Access-Datenblatt, -Formular oder -Modul, den angegebenen Microsoft Access-Bericht oder die angegebene Microsoft Access-Datenzugriffsseite in eine E-Mail-Nachricht einfügen, in der dieses Objekt angezeigt oder weitergeleitet werden kann. Sie können Objekte im Microsoft Excel 2000-Format (*.XLS), MS-DOS-Textformat (*.TXT), Rich-Text-Format (*.RTF) oder im HTML-Format (*.HTML) in Nachrichten in Microsoft Exchange, Microsoft Mail, Microsoft Windows für Workgroups Mail oder andere E-Mail-Anwendungen aufnehmen, die die Microsoft MAPI Standard-Programmierschnittstelle (MAPI = Mail Applications Programming Interface) verwenden.

Wenn Sie über eine E-Mail-Anwendung verfügen, die das VIM (Vendor Independent Mail)-Protokoll verwendet, und die Dynamic Link Library (MAPIVIM.DLL), die MAPI-Mail-Nachrichten in das VIM-Protokoll konvertiert, installiert und eingestellt haben, können Sie Microsoft Access-Objekte an die VIM Mail-Anwendung senden.

Einstellung

Die Aktion SendenObjekt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des in die E-Mail-Nachricht aufzunehmenden Objekts. Klicken Sie im Feld Objekttyp im Bereich Aktionsargumente des Makrofenstersauf Tabelle (für ein Tabellendatenblatt), Abfrage (für ein Abfragedatenblatt), Formular (für ein Formular oder ein Formulardatenblatt), Bericht, Modul, Datenzugriffsseite, Serveransicht, oder Gespeicherte Prozeduren. Makros können nicht gesendet werden. Wenn Sie das aktive Objekt in die Nachricht aufnehmen möchten, wählen Sie über dieses Argument seinen Typ, und lassen das Argument Objektname leer.
Objektname | Der Name des in die E-Mail-Nachricht aufzunehmenden Objekts. Das Feld Objektname zeigt alle Datenbankobjekte des im Argument Objekttyp angegebenen Typs an. Wenn Sie für die beiden Argumente Objekttyp und Objektname nichts angeben, sendet Microsoft Access eine Nachricht ohne ein Datenbankobjekt an die E-Mail-Anwendung.
 | Wenn Sie ein Makro, das die Aktion SendenObjekt enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Objekt mit dem angegebenen Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ausgabeformat | Das Format des Objekts, das in die Nachricht aufgenommen wird. Klicken Sie im Feld Ausgabeformat auf das gewünschte Format: HTML (*.html), Microsoft Excel (*.xls), MS-DOS-Text (*.txt), Rich-Text-Format (*.rtf) oder Microsoft Datenzugriffsseite (*.html). Module können nur im MS-DOS-Textformat gesendet werden und Datenzugriffsseiten nur im HTML-Format. Wenn Sie für dieses Argument nichts angeben, fordert Microsoft Access Sie auf, das Ausgabeformat anzugeben.
 | Anmerkung Sie können keine Objekte in den Formaten Microsoft Active Server Pages (*.asp) oder Microsoft IIS (*.htx, *.idc) in eine Nachricht einfügen, obwohl diese Formate in der Auswahlliste angezeigt werden.
An | Die Empfänger der Nachricht, deren Namen in der Nachricht in der Zeile An angezeigt werden sollen. Wenn Sie für dieses Argument nichts angeben, fordert Microsoft Access Sie auf, den Empfängernamen anzugeben.
 | Trennen Sie die Empfängernamen, die Sie in den Argumenten An, Cc oder Bcc festlegen, durch Semikolons (;) oder das Listentrennzeichen, das in der Systemsteuerung von Microsoft Windows auf der Registerkarte Zahlen im Dialogfeld Eigenschaften von Ländereinstellungen eingestellt ist. Wenn die E-Mail-Anwendung die Empfängernamen nicht zuordnen kann, wird die Nachricht nicht gesendet, und ein Fehler tritt auf.
Cc | Diejenigen Empfänger der Nachricht, deren Namen in der Zeile Cc ("carbon copy") der Nachricht angezeigt werden. Wenn Sie für dieses Argument nichts angeben, ist die Zeile Cc in der Nachricht leer.
Bcc | Diejenigen Empfänger der Nachricht, deren Namen in der Zeile Bcc ("blind carbon copy") der Nachricht angezeigt werden. Wenn Sie für dieses Argument keine Angabe machen, ist die Zeile Bcc in der Nachricht leer.
Betreff | Der Betreff der Nachricht. Dieser Text wird in der Zeile Betreff der Nachricht angezeigt. Wenn Sie für dieses Argument nichts angeben, ist die Zeile Betreff in der Nachricht leer.
Nachricht | Ein beliebiger Text, den Sie zusätzlich zum Datenbankobjekt in die Nachricht aufnehmen möchten. Dieser Text wird im Hauptteil der Nachricht im Anschluss an das Objekt angezeigt. Wenn Sie für dieses Argument nichts angeben, wird der Nachricht kein zusätzlicher Text hinzugefügt. Wenn Sie für die Argumente Objekttyp und Objektname nichts angeben, können Sie dieses Argument zum Senden einer Nachricht verwenden, die kein Datenbankobjekt enthält.
Nachricht bearbeiten | Gibt an, ob die Nachricht vor dem Senden bearbeitet werden kann. Wenn Sie Ja wählen, wird die E-Mail-Anwendung automatisch gestartet, und Sie können die Nachricht bearbeiten. Wenn Sie Nein wählen, wird die Nachricht ohne eine Möglichkeit zum Bearbeiten direkt gesendet. Die Standardeinstellung ist Nein.
Vorlagedatei | Der Pfad und Dateiname einer Datei, die Sie als Vorlage für eine .HTML-Datei verwenden möchten. Die Vorlagedatei enthält HTML-Tags.

Anmerkungen

Die Aktion SendenObjekt steht nur dann zur Verfügung, wenn auf Ihrem Computer eine E-Mail-Anwendung installiert ist, die die MAPI-Standardschnittstelle unterstützt, oder wenn Sie über eine VIM-unterstützende E-Mail-Anwendung verfügen und MAPIVI32.DLL installiert und eingestellt haben. Informationen zum Installieren und Einstellen von Microsoft Access-Unterstützung für VIM Mail-Anwendungen finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um Informationen anzuzeigen, wie Sie das Microsoft Office 2000/Visual Basic Programmierhandbuch erwerben können, klicken Sie auf [image] .

Das Objekt in der Nachricht liegt in dem ausgewählten Ausgabeformat vor. Wenn Sie auf das Objekt doppelklicken, wird die entsprechende Software gestartet und das Objekt geöffnet. Die den einzelnen Ausgabeformaten zugeordneten Anwendungen sind Microsoft Excel (für .XLS-Dateien), Microsoft Word für Windows (für .RTF-Dateien) und der Editor von Microsoft Windows (für .TXT-Dateien). Für .HTML-Dateien wird Ihr voreingestellter Internet Browser gestartet.

Die folgenden Regeln werden angewendet, wenn Sie die Aktion SendenObjekt verwenden, um ein Datenbankobjekt in eine E-Mail-Nachricht aufzunehmen:

  • Sie können Tabellen-, Abfrage- und Formulardatenblätter senden. Alle Felder des in die Nachricht aufgenommenen Datenblatts werden genau wie in Microsoft Access angezeigt, mit Ausnahme der Felder, die OLE-Objekte enthalten. Die Spalten für diese Felder sind in dem Objekt zwar enthalten, die Felder sind jedoch leer.

  • Für ein Steuerelement, das an ein Ja/Nein-Feld (eine Umschaltfläche, ein Optionsfeld oder ein Kontrollkästchen) gebunden ist, zeigt die Ausgabedatei die Werte -1 (Ja) oder 0 (Nein) an.

  • Für ein Textfeld, das an ein Feld des Datentyps Hyperlink gebunden ist, zeigt die Ausgabedatei den Hyperlink für alle Ausgabeformate mit Ausnahme von MS-DOS-Text an (in diesem Fall wird der Hyperlink als normaler Text angezeigt).

  • Wenn Sie ein Formular in der Formularansicht senden, enthält die Nachricht als Objekt immer die Datenblattansicht des Formulars.

  • Wenn Sie einen Bericht senden, sind nur die folgenden Steuerelemente im Objekt enthalten: Textfelder (für .XLS-Dateien), oder Textfelder und Bezeichnungsfelder (für .RTF-, .TXT- und .HTML-Dateien). Alle anderen Steuerelemente bleiben unberücksichtigt. Kopf- und Fußzeilen sind ebenfalls nicht enthalten. Die einzige Ausnahme ist das Einbeziehen eines Textfeldes, das einen Ausdruck mit der Sum-Funktion enthält, in einen Gruppenfuß im Objekt, wenn Sie einen Bericht im Microsoft Excel-Format senden. Kein anderes Steuerelement in einer Kopf- oder Fußzeile (und keine andere Aggregatfunktion als die Sum-Funktion) ist in dem Objekt enthalten.

  • Das Objekt kann Unterberichte aufnehmen; Unterformulare jedoch werden bei einer Ausgabe in das .ASP-Format nur als Formular (nicht als Datenblatt) einbezogen.

  • Wenn Sie ein Datenblatt, ein Formular oder eine Datenzugriffsseite im HTML-Format senden, wird eine einzige .HTML-Datei erstellt. Wenn Sie einen Bericht im HTML-Format senden, wird für jede Seite des Berichts eine .HTML-Datei erstellt.

Weitere Informationen zu Regeln und Einschränkungen bei der Aufnahme von Objekten im HTML-Format finden Sie unter Exportieren eines Datenblatts in statisches HTML-Format und Exportieren eines Berichts in statisches HTML-Format.

Tipp Falls Sie die Daten eines Berichts senden und die Spalten und Zeilen der Daten im aufgenommenen Objekt nicht wie im Bericht ausgerichtet sind, können die folgenden Tipps hilfreich sein:

  • Sie können im Menü Format auf Größe zeigen und dann auf an Textgröße klicken, um die Größe der Steuerelemente anzupassen.

  • Sie sollten sich überlagernde Steuerelemente oder sehr nah beieinander angeordnete Steuerelemente vermeiden.

  • Sie können im Menü Format auf Ausrichten zeigen und dann auf den entsprechenden Befehl klicken, um die Steuerelemente des Berichts auszurichten. Steuerelemente, die nicht in der gleichen Zeile ausgerichtet sind, werden möglicherweise in verschiedenen Zeilen angeordnet, was zusätzlichen Platz beansprucht.

Die Aktion SendenObjekt hat eine ähnliche Wirkung wie das Klicken auf Senden an im Menü Datei, und die Aktionsargumente entsprechen den Einstellungen in den Dialogfeldern Senden. Der Befehl Senden an wird jedoch nur auf das aktive Objekt angewendet. Wenn Sie die Aktion SendenObjekt verwenden, können Sie dagegen ein beliebiges Objekt angeben, das Sie senden möchten.

Anmerkung Sie können die ausgewählten Daten über den Befehl Senden an senden. Diese Funktionalität ist in Verbindung mit der Aktion SendenObjekt jedoch nicht verfügbar.

Um die Aktion SendenObjekt in Visual Basic auszuführen, verwenden Sie die SendObject-Methode des DoCmd-Objekts.


 SetzenMenüelement-Aktion

SetzenMenüelement-Aktion

Sie können die Aktion SetzenMenüelement verwenden, um für das aktive Fenster den Status der Menüelemente (Aktiviert, Deaktiviert, Mit Häkchen, Ohne Häkchen) auf der benutzerdefinierten Menüleiste oder der globalen Menüleiste festzulegen.

Anmerkung Die Aktion SetzenMenüelement funktioniert nur mit benutzerdefinierten und globalen Menüleisten, die mit Menüleistenmakros erstellt wurden. Die Aktion SetzenMenüelement ist in dieser Microsoft Access-Version nur wegen der Kompatibilität mit früheren Versionen vorhanden. Sie funktioniert nicht im Zusammenhang mit der neuen Befehlsleisten-Funktionalität. Sie können jedoch die Eigenschaften Enabled und State in Visual Basic verwenden, um Elemente in den neuen Menüleisten, Symbolleisten und Kontextmenüs zu aktivieren und deaktivieren bzw. mit Häkchen zu versehen oder das Häkchen zu entfernen.

Einstellung

Die Aktion SetzenMenüelement verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Menüindex Der Index des Menüs mit dem Befehl, dessen Status Sie festlegen möchten. Geben Sie einen Wert vom Typ Integer, beginnend bei 0, für den Index des gewünschten Menüs in der benutzerdefinierten oder globalen Menüleiste für das aktive Fenster ein. Geben Sie den Indexwert im Feld Menüindex im Abschnitt Aktionsargument des Makrofensters ein. Der Index ist relativ zu der Position, die das Menü im Menüleistenmakro für die benutzerdefinierte bzw. globale Menüleiste einnimmt (die Position der Aktion HinzufügenMenü im Menüleistenmakro, beginnend bei 0). Die Anzeige der Menüleiste kann geringfügig anders aussehen, da Sie bedingte Ausdrücke im Menüleistenmakro verwenden können, um benutzerdefinierte Menübefehle aus- oder einzublenden. Dieses Argument ist erforderlich.

Falls Sie ein Menü mit diesem Argument auswählen und die Argumente Befehlsindex und Unterbefehlsindex leer lassen, können Sie den Menünamen selbst aktivieren oder deaktivieren. Sie können einen Menünamen jedoch nicht mit Häkchen versehen oder das Häkchen entfernen. (Microsoft Access ignoriert die Einstellungen Mit Häkchen und Ohne Häkchen für das Argument Kennzeichen für Menünamen).
Befehlsindex | Der Index des Befehls, dessen Status Sie festlegen möchten. Geben Sie einen Wert vom Typ Integer, beginnend bei 0, für den Index des gewünschten Befehls des Menüs ein, das mit dem Argument Menüindex ausgewählt wurde. Der Index ist relativ zu der Position, die der Befehl in der Makrogruppe einnimmt, die das ausgewählte Menü für die benutzerdefinierte oder globale Menüleiste definiert (die Position des Makros dieses Befehls in der Makrogruppe, beginnend bei 0). Die Anzeige des Menüs kann geringfügig anders aussehen, da Sie bedingte Ausdrücke in der Makrogruppe des Menüs verwenden können, um benutzerdefinierte Menübefehle aus- oder einzublenden.
Unterbefehlsindex | Der Index des Unterbefehls, dessen Status Sie festlegen möchten. Dieser wird nur angewendet, wenn der gewünschte Befehl ein Untermenü hat. Geben Sie einen Wert vom Typ Integer, beginnend bei 0, für den Index des gewünschten Unterbefehls des Untermenüs ein, das mit dem Argument Befehlsindex ausgewählt wurde. Der Index ist relativ zur Position des Unterbefehls in der Makrogruppe, die das ausgewählte Untermenü für die benutzerdefinierte oder globale Menüleiste definiert (die Position des Makros dieses Unterbefehls in der Makrogruppe, beginnend bei 0).
Kennzeichen | Der Status, auf den Sie den Befehl oder Unterbefehl einstellen möchten. Klicken Sie auf Deaktiviert, um den Befehl zu deaktivieren (er wird dann abgeblendet angezeigt), auf Aktiviert, um ihn zu aktivieren, auf Mit Häkchen, um den Befehl mit einem Häkchen zu versehen (zeigt in der Regel an, dass er ausgewählt oder eingeschaltet wurde), oder auf Ohne Häkchen, um das Häkchen zu entfernen. Die Standardeinstellung ist Aktiviert.

Anmerkung

Die Aktion SetzenMenüelement funktioniert nur für die benutzerdefinierte oder die globale Menüleiste des aktiven Fensters. Sie funktioniert nicht für die eingebauten Microsoft Access-Menüleisten. Falls das aktive Fenster keine benutzerdefinierte oder globale Menüleiste enthält, wird beim Ausführen eines Makros, das die Aktion SetzenMenüelement enthält, ein Laufzeitfehler verursacht. Falls Sie eine globale Menüleiste definiert haben, beachten Sie, dass diese die eingebaute Menüleiste in allen Microsoft Access-Fenstern ersetzt, es sei denn, Sie haben eine benutzerdefinierte Menüleiste für ein Formular oder einen Bericht hinzugefügt.

Sie können mit dieser Aktion den Status von Menübefehlen und Unterbefehlen festlegen, jedoch nicht den Status von Unterbefehlen der Unterbefehle.

Zum Ausführen der Aktion SetzenMenüelement in Visual Basic verwenden Sie die SetMenuItem-Methode des DoCmd-Objekts.


 SetzenWert-Aktion

SetzenWert-Aktion

Sie können die Aktion SetzenWert verwenden, um den Wert eines Microsoft Access-Feldes, Steuerelements oder einer Eigenschaft in einem Formular, Formulardatenblatt oder Bericht einzustellen.

Anmerkung Sie können die Aktion SetzenWert nicht zum Setzen des Wertes einer Microsoft Access-Eigenschaft verwenden, die ein Objekt zurückgibt.

Einstellung

Die Aktion SetzenWert verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Feld | Der Name des Feldes, Steuerelements oder der Eigenschaft, dessen/deren Wert Sie einstellen möchten. Geben Sie den Namen des Feldes, Steuerelements oder der Eigenschaft im Bereich Aktionsargumente des Makrofensters im Feld Feld ein. Verwenden Sie die vollständige Syntax, um dieses Element anzugeben, z. B. Steuerelementname (für ein Steuerelement in dem Formular oder Bericht, von dem aus das Makro aufgerufen wurde) oder Formulare!Formularname!Steuerelementname. Dieses Argument ist erforderlich.
Ausdruck Der Ausdruck, den Microsoft Access zum Einstellen des Wertes für dieses Element verwendet. Verwenden Sie immer die vollständige Syntax, um sich auf ein Objekt im Ausdruck zu beziehen. Verwenden Sie z. B. Formulare!Personal!Gehalt*1,1, um den Wert des Steuerelements Gehalt in einem Formular Personal um 10 Prozent zu erhöhen. Dieses Argument ist erforderlich.

Anmerkung Sie sollten vor dem Ausdruck in diesem Argument kein Gleichheitszeichen (=) verwenden. Falls Sie es doch tun, wertet Microsoft Access den Ausdruck aus und verwendet diesen Wert als den Ausdruck in diesem Argument. Dies kann zu unerwarteten Ergebnissen führen, wenn der Ausdruck eine Zeichenfolge ist.

Wenn Sie z.B für dieses Argument ="Zeichenfolge1" eingeben, wertet Microsoft Access zuerst den Ausdruck als Zeichenfolge1 aus. Dann wird Zeichenfolge als der Ausdruck in diesem Argument verwendet, in der Erwartung, ein Steuerelement oder eine Eigenschaft namens Zeichenfolge in dem Formular oder dem Bericht zu finden, aus dem das Makro aufgerufen wurde.

Anmerkung In einer Microsoft Access-Datenbank (.MDB) klicken Sie auf die Schaltfläche Aufbauen [image] rechts vom Feld Element oder Ausdruck, um mit Hilfe des Ausdrucks-Generators einen Ausdruck für eines dieser Argumente zu erstellen.

Anmerkung

Sie können diese Aktion verwenden, um den Wert für ein Feld oder ein Steuerelement in einem Formular, einem Formulardatenblatt oder einem Bericht einzustellen. Sie können auch den Wert für fast alle Steuerelements-, Formular- und Berichtseigenschaften in jeder Ansicht einstellen. Informationen darüber, ob und in welchen Ansichten eine bestimmte Eigenschaft mit einem Makro eingestellt werden kann, finden Sie im Thema zu dieser Eigenschaft.

Sie können auch den Wert für ein Feld in der einem Formular zugrunde liegenden Tabelle einstellen, sogar dann, wenn in dem Formular kein Steuerelement an das Feld gebunden wurde. Verwenden Sie die Syntax Formulare!Formularname!Feldname im Feld Feld, um den Wert für ein solches Feld einzustellen. Sie können sich auch auf ein Feld in der einem Bericht zugrunde liegenden Tabelle beziehen, indem Sie die Syntax Reports!Berichtsname!Feldname verwenden, jedoch muss hierbei ein Steuerelement in dem Bericht an dieses Feld gebunden sein, oder das Feld muss sich auf ein berechnetes Steuerelement in dem Bericht beziehen.

Wenn Sie den Wert eines Steuerelements in einem Formular einstellen, löst die Aktion SetzenWert keine Überprüfung der Gültigkeitsregeln für Steuerelemente auf Formularebene aus, aber die Überprüfung der Gültigkeitsregeln in der dem Feld zugrunde liegenden Tabelle, falls das Steuerelement an die Datenbank gebunden ist. Die Aktion SetzenWert löst außerdem eine Neuberechnung aus, die aber nicht unbedingt sofort erfolgt. Sie setzen die sofortige Aktualisierung und den Abschluss der Neuberechnung durch, indem Sie die Aktion AktualisierenObjekt verwenden. Der in einem Steuerelement mit der Aktion SetzenWert eingestellte Wert ist auch nicht von einem Eingabeformat betroffen, das in der Eigenschaft Eingabeformat des Steuerelements oder des zugrunde liegenden Feldes eingestellt ist.

Sie können den Wert eines Steuerelements ändern, indem Sie die Aktion SetzenWert in einem Makro verwenden, das mit der Ereigniseigenschaft AfterUpdate des Steuerelements angegeben wird. Sie können die Aktion SetzenWert allerdings nicht in einem Makro verwenden, das von der Ereigniseigenschaft BeforeUpdate angegeben wird, um den Wert des Steuerelements zu ändern (obwohl Sie SetzenWert zum Ändern anderer Steuerelemente verwenden können). Sie können die Aktion SetzenWert auch in einem Makro verwenden, das in der Eigenschaft BeforeUpdate oder AfterUpdate eines Formulars angegeben wird, um den Wert eines beliebigen Steuerelements im aktuellen Datensatz zu ändern.

Anmerkung Mit der Aktion SetzenWert können Sie die Werte der folgenden Steuerelemente nicht einstellen:

  • Gebundene Steuerelemente und berechnete Steuerelemente in Berichten

  • Berechnete Steuerelemente in Formularen

Tipp Sie können mit der Aktion SetzenWert ein Formular in der Formularansicht ausblenden oder einblenden. Geben Sie Formulare!Formularname.Visible im Feld Feld und Nein oder Ja im Feld Ausdruck ein. Das Einstellen der Eigenschaft Visible eines gebundenen Formulars auf Nein blendet das Formular aus und ändert dessen Zustand auf "nicht gebunden". Das Einstellen der Eigenschaft auf Ja zeigt das Formular an und ändert seinen Zustand auf "gebunden".

Wenn Sie mit der Aktion SetzenWert den Wert eines Steuerelements ändern oder neue Daten in einem Makro hinzufügen, löst dies keine Ereignisse wie BeforeUpdate, BeforeInsert oder Change aus, die auftreten, wenn Sie in der Benutzeroberfläche Daten in diesen Steuerelementen ändern oder eingeben. Diese Ereignisse treten auch dann nicht auf, wenn Sie den Wert des Steuerelements mit Visual Basic einstellen.

Diese Aktion ist in Visual Basic nicht verfügbar. Stellen Sie den Wert direkt in Visual Basic ein.


 Signalton-Aktion

Signalton-Aktion

Sie können die Aktion Signalton verwenden, um einen Signalton über den Lautsprecher des Computers auszugeben.

Einstellung

Die Aktion Signalton verwendet keine Argumente.

Anmerkung

Sie können die Aktion Signalton für folgende Situationen verwenden:

  • Wichtige Änderungen sind auf dem Bildschirm aufgetreten.

  • Die falsche Art von Daten wurde in einem Steuerelement eingegeben. Der Benutzer hat z. B. numerische Daten in einem Textfeld-Steuerelement eingegeben.

  • Ein Makro hat einen festgelegten Punkt erreicht oder seine Aktionen abgeschlossen.

Frequenz und Dauer des Signaltons sind abhängig von der eingesetzten Hardware und können sich daher von Computer zu Computer unterscheiden.

Zum Ausführen der Aktion Beep in Visual Basic verwenden Sie die Beep-Methode des DoCmd-Objekts.


 Speichern-Aktion

Speichern-Aktion

Sie können die Aktion Speichern verwenden, um das angegebene Microsoft Access-Objekt oder, falls kein Objekt angegeben wurde, das aktive Objekt zu speichern. Sie können das aktive Objekt in bestimmten Fällen auch unter einem neuen Namen speichern (diese Funktion entspricht dem Befehl Speichern unter im Menü Datei).

Einstellung

Die Aktion Speichern verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Objekttyp | Der Typ des Objekts, das Sie speichern möchten. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Objekttyp auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serveransicht, Diagramm oder Gespeicherte Prozedur. Um das aktive Objekt auszuwählen, lassen Sie dieses Argument leer. Wenn Sie einen Objekttyp in diesem Argument auswählen, wählen Sie im Argument Objektname einen vorhandenen Objektnamen aus.
Objektname | Der Name des zu speichernden Objekts. Das Feld Objektname zeigt alle in der Datenbank vorhandenen Objekte des im Argument Objekttyp ausgewählten Typs an. Wenn Sie das Argument Objekttyp leer lassen, können Sie dieses Argument ebenfalls leer lassen, um das aktive Objekt zu speichern, oder Sie können in bestimmten Fällen einen neuen Namen eingeben, um das aktive Objekt unter diesem Namen zu speichern. Falls Sie einen neuen Namen eingeben, befolgen Sie die Standardregeln zur Benennung von Microsoft Access-Objekten.

Anmerkung

Die Aktion Speichern funktioniert bei allen Datenbankobjekten, die der Benutzer explizit öffnen und speichern kann. Das betreffende Objekt muss geöffnet sein, damit die Aktion Speichern überhaupt eine Auswirkung hat. Die Aktion hat die gleiche Wirkung wie das Auswählen und anschließende Speichern eines Objekts, indem Sie im Menü Datei auf Speichern oder in der Symbolleiste auf Speichern [image] klicken. Wenn Sie das Argument Objekttyp leer lassen und für das Argument Objektname einen neuen Namen eingeben, hat dies die gleiche Wirkung wie das Klicken auf Speichern unter im Menü Datei mit anschließender Eingabe eines neuen Namens für das aktive Objekt. Mit Hilfe der Aktion Speichern können Sie ein Objekt aus einem Makro heraus zum Speichern angeben und den Befehl Speichern unter ausführen.

Anmerkung Sie können die Aktion Speichern nicht verwenden, um die folgenden Elemente unter einem neuen Namen zu speichern:

  • Ein Formular in der Formularansicht oder Datenblattansicht.

  • Einen Bericht in der Seitenansicht.

  • Ein Modul.

  • Eine Serveransicht in der Datenblattansicht oder Seitenansicht.

  • Eine Datenzugriffsseite in der Datenzugriffsseitenansicht.

  • Eine Tabelle in der Datenblattansicht oder Seitenansicht.

  • Eine Abfrage in der Datenblattansicht oder Seitenansicht.

  • Eine gespeicherte Prozedur in der Datenblattansicht oder Seitenansicht.

Die Aktion Speichern speichert das angegebene bzw. aktive Objekt immer in der Datenbank, in der das Objekt erstellt wurde. Dies gilt auch dann, wenn das Makro, zu dem die Aktion gehört, nicht in der aktuellen Datenbank, sondern in einer Bibliotheksdatenbank ausgeführt wird.

Falls Sie das aktive Objekt unter einem neuen Namen speichern möchten, der Name jedoch bereits für ein vorhandenes Objekt des gleichen Typs verwendet wird, werden Sie in einem Dialogfeld gefragt, ob Sie das vorhandene Objekt überschreiben möchten. Falls Sie das Argument Warnmeldungen An der Aktion Warnmeldungen auf Nein eingestellt haben, wird das Dialogfeld nicht angezeigt, und das alte Objekt wird automatisch überschrieben.

Wenn Sie die Aktion Speichern in Visual Basic ausführen möchten, verwenden Sie die Methode Save des DoCmd-Objekts.


 StoppAlleMakros-Aktion

StoppAlleMakros-Aktion

Sie können die Aktion StoppAlleMakros verwenden, um alle Makros zu beenden, die momentan ausgeführt werden.

Einstellung

Die Aktion StoppAlleMakros verwendet keine Argumente.

Anmerkung

Sie verwenden diese Aktion in der Regel dann, wenn ein Fehler die Beendigung aller Makros erfordert. Sie können einen bedingten Ausdruck in der Aktionszeile des Makros verwenden, der diese Aktion enthält. Ergibt der Ausdruck den Wert Wahr (-1), so beendet Microsoft Access alle Makros.

Sie verfügen z.B. über ein Makro, das ein Meldungsfeld als eine von mehreren komplexen Aktionen anzeigt und das auch andere Makros ausführt. Klickt der Benutzer in diesem Meldungsfeld auf Abbrechen, so beendet die Aktion StoppAlleMakros alle momentan ausgeführten Makros.

Hat ein Makro die Aktionen Echo oder Warnmeldungen verwendet, um das Echo oder die Anzeige von Systemmeldungen auszuschalten, so schaltet die Aktion StoppAlleMakros beides automatisch wieder ein.

Diese Aktion ist in Visual Basic nicht verfügbar.


 StoppMakro-Aktion

StoppMakro-Aktion

Sie können die Aktion StoppMakro verwenden, um das momentan ausgeführte Makro zu beenden.

Einstellung

Die Aktion StoppMakro verwendet keine Argumente.

Anmerkung

Sie verwenden diese Aktion in der Regel dann, wenn das Makro auf Grund einer bestimmten Bedingung beendet werden muss. Sie können einen bedingten Ausdruck in der Aktionszeile des Makros verwenden, der diese Aktion enthält. Ergibt der Ausdruck den Wert Wahr (-1), so beendet Microsoft Access das Makro.

Sie möchten z. B. ein Makro erstellen, das ein Formular öffnet, in dem die Auftragseingangssumme für das in einem benutzerdefinierten Dialogfeld eingegebene Datum angezeigt wird. Sie können einen bedingten Ausdruck verwenden, um sicherzustellen, dass das Steuerelement Bestelldatum des Dialogfelds ein gültiges Datum enthält. Ist dies nicht der Fall, so kann die Aktion Warnmeldung eine Fehlermeldung anzeigen, und die Aktion StoppMakro kann das Makro beenden.

Hat das Makro die Aktionen Echo oder Warnmeldungen verwendet, um das Echo oder die Anzeige von Systemmeldungen auszuschalten, so schaltet die Aktion StoppMakro beides automatisch wieder ein.

Diese Aktion ist in Visual Basic nicht verfügbar.


 SuchenDatensatz-Aktion

SuchenDatensatz-Aktion

Mit der Aktion SuchenDatensatz können Sie das erste Vorkommen der Daten suchen, die die in den Argumenten der Aktion SuchenDatensatz festgelegten Kriterien erfüllen. Dies kann im aktuellen Datensatz, in einem vorhergehenden oder nachfolgenden Datensatz, aber auch im ersten Datensatz sein. Sie können Datensätze im aktiven Tabellendatenblatt, Abfragedatenblatt, Formulardatenblatt oder Formular suchen.

Einstellung

Die Aktion SuchenDatensatz verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Suchen nach | Legt die im Datensatz zu suchenden Daten fest. Geben Sie den gewünschten Text, eine Zahl oder ein Datum im Abschnitt Aktionsargumente des Makrofensters im Feld Suchen nach ein, oder geben Sie einen Ausdruck ein, dem ein Gleichheitszeichen (=) vorangestellt ist. Sie können Platzhalterzeichen verwenden. Dieses Argument ist erforderlich.
Vergleichen | Gibt an, wo im Feld nach den Daten gesucht wird. Sie können Daten suchen, die an beliebiger Stelle im Feld vorkommen (Teil des Feldinhaltes), die mit dem gesamten Feldinhalt übereinstimmen (Gesamter Feldinhalt), oder die sich am Feldanfang befinden (Anfang des Feldinhaltes). Die Standardeinstellung ist Gesamter Feldinhalt.
Groß-/Kleinschreibung | Gibt an, ob bei der Suche die Groß-/Kleinschreibung berücksichtigt wird (Groß- und Kleinbuchstaben müssen genau übereinstimmen). Klicken Sie auf Ja (um die Groß-/Kleinschreibung beim Suchen zu berücksichtigen), oder auf Nein (um die Groß-/Kleinschreibung nicht zu berücksichtigen). Die Standardeinstellung ist Nein.
Suchen | Gibt die Suchrichtung an: vom aktuellen Datensatz in Richtung Anfang der Datensätze (Oben), in Richtung Ende der Datensätze (Unten), oder in Richtung Ende der Datensätze und dann wieder vom Anfang der Datensätze bis zum aktuellen Datensatz, so dass alle Datensätze durchsucht werden (Alle). Die Standardeinstellung ist Alle.
Wie formatiert Gibt an, ob die Suche formatierte Daten enthält. Klicken Sie auf Ja, damit Microsoft Access die Daten in der Form sucht, wie sie im Feld formatiert und angezeigt werden. Klicken Sie auf Nein, damit Microsoft Access die Daten so sucht, wie sie in der Datenbank gespeichert sind, was nicht immer der Darstellung auf dem Bildschirm entspricht. Die Standardeinstellung ist Nein.

Mit dieser Funktion können Sie die Suche auf Daten beschränken, die ein bestimmtes Format besitzen. Klicken Sie z. B. auf Ja, und geben Sie im Argument Suchen nach den Wert 1.234 ein, um den Wert 1.234 in einem Feld zu finden, das Punkte enthalten darf. Klicken Sie auf Nein, wenn Sie 1234 eingeben möchten, um Daten in diesem Feld zu suchen.

Wenn Sie Datumsangaben suchen, klicken Sie auf Ja, um das Datum mit der exakten Formatierung zu finden, z. B. 01. Juli 1996. Wenn Sie auf Nein klicken, geben Sie das Datum im Argument Suchen nach in dem Format ein, das im Dialogfeld Eigenschaften von Ländereinstellungen der Microsoft Windows-Systemsteuerung eingestellt ist. (Dies entspricht dem Feld Kurzes Datumsformat in der Registerkarte Datum des Dialogfelds Eigenschaften von Ländereinstellungen.) Ist z. B. das Feld Kurzes Datumsformat auf T/M/JJ eingestellt, so können Sie 1/7/96 eingeben, damit Microsoft Access alle Einträge in einem Datumsfeld (unabhängig von der Formatierung des Feldes) sucht, die dem 1. Juli 1996 entsprechen.

Anmerkung Dieses Argument ist nur wirksam, wenn das aktuelle Feld ein gebundenes Steuerelement ist und das Argument Vergleichen auf Gesamter Feldinhalt, das Argument Nur aktuelles Feld auf Ja sowie das Argument Groß-/Kleinschreibung beachten auf Nein eingestellt ist.

Wenn Sie Groß-/Kleinschreibung beachten auf Ja oder Nur aktuelles Feld auf Nein einstellen, stellen Sie auch Wie formatiert auf Ja ein.
Nur aktuelles Feld | Gibt an, ob die Suche auf das aktuelle Feld in allen Datensätzen beschränkt ist oder ob in allen Feldern in allen Datensätzen gesucht werden soll. Die Suche im aktuellen Feld ist schneller. Klicken Sie auf Ja, um die Suche auf das aktuelle Feld zu beschränken, oder auf Nein, um in allen Feldern aller Datensätze zu suchen. Die Standardeinstellung ist Ja.
Am Anfang beginnen | Gibt an, ob die Suche beim ersten Datensatz oder beim aktuellen Datensatz beginnt. Klicken Sie auf Ja, um beim ersten Datensatz zu beginnen, oder auf Nein, um beim aktuellen Datensatz zu beginnen. Die Standardeinstellung ist Ja.

Anmerkung

Führt ein Makro die Aktion SuchenDatensatz aus, so sucht Microsoft Access die angegebenen Daten in den Datensätzen, wobei die Suchreihenfolge im Argument Suchen festgelegt ist. Wenn Microsoft Access die angegebenen Daten findet, werden diese im Datensatz markiert.

Die Aktion SuchenDatensatz entspricht dem Klicken auf Suchen im Menü Bearbeiten, und die Argumente stimmen mit den Optionen im Dialogfeld Suchen in Feld überein. Wenn Sie die Argumente der Aktion SuchenDatensatz im Makrofenster einstellen, das Makro ausführen und dann auf Suchen klicken, sehen Sie, dass die entsprechenden Optionen im Dialogfeld Suchen in Feld ausgewählt sind.

Microsoft Access speichert die zuletzt in einem Suchvorgang verwendeten Argumente während einer Datenbanksitzung, so dass Sie nicht mehrmals dieselben Kriterien eingeben müssen, wenn Sie die Aktion SuchenDatensatz wiederholt ausführen. Wenn Sie für ein Argument keinen Wert angeben, verwendet Microsoft Access die letzte Einstellung für das Argument aus der vorhergehenden Aktion SuchenDatensatz oder aus dem Dialogfeld Suchen in Feld.

Wenn Sie einen Datensatz mit einem Makro suchen möchten, verwenden Sie die Aktion SuchenDatensatz, nicht die Aktion AusführenMenübefehl mit einem Argument, das zur Ausführung des Befehls Suchen eingestellt ist.

Anmerkung Während die Aktion SuchenDatensatz dem Befehl Suchen im Menü Bearbeiten für Tabellen, Abfragen und Formularen entspricht, ist dies im Modulfenster beim Befehl Suchen im Menü Bearbeiten nicht der Fall. Sie können die Aktion SuchenDatensatz nicht zum Suchen von Text in Modulen verwenden.

Wenn der derzeit ausgewählte Text mit dem gesuchten Text identisch ist und dann die Makroaktion SuchenWeiter ausgeführt wird, beginnt die Suche direkt im Anschluss an die Auswahl in dem Feld und dem Datensatz, in dem die Auswahl erfolgte. Ist dies nicht der Fall beginnt die Suche am Anfang des aktuellen Datensatzes. So können Sie das wiederholte Auftreten desselben Suchkriteriums in einem einzelnen Datensatz finden.

Wenn Sie jedoch ein Makro, das die Aktion SuchenDatensatz enthält, mit Hilfe einer Befehlsschaltfläche ausführen, beachten Sie, dass wiederholt das erste Vorkommen des Suchkriteriums gefunden wird. Das liegt daran, dass der Fokus beim Klicken auf die Befehlsschaltfläche dem Feld, das den übereinstimmenden Wert enthält, genommen wird. Die Aktion SuchenDatensatz beginnt dadurch erneut am Anfang des Datensatzes, so dass stets das erste Vorkommen des Suchkriteriums in demselben Datensatz gefunden wird. Um dieses Problem zu umgehen, führen Sie das Makro mit einem Verfahren aus, das den Fokus nicht ändert, beispielsweise mit einer Schaltfläche in einer benutzerdefinierten Symbolleiste oder einer Tastenkombination, die in einem Makro AutoKeys definiert ist. Sie können aber auch im Makro den Fokus auf das Feld setzen, das das Suchkriterium enthält, bevor Sie die Aktion SuchenDatensatz ausführen.

Dasselbe Verhalten tritt auch auf, wenn Sie ein Makro, das die Aktion SuchenWeiter enthält, mit Hilfe einer Befehlsschaltfläche ausführen.

Zum Ausführen der Aktion SuchenDatensatz in Visual Basic verwenden Sie die FindRecord-Methode des DoCmd-Objekts.


 SuchenWeiter-Aktion

SuchenWeiter-Aktion

Mit der Aktion SuchenWeiter können Sie den nächsten Datensatz suchen, der die Kriterien erfüllt, die durch die vorhergehende Aktion SuchenDatensatz oder im Dialogfeld Suchen in Feld (Menü Bearbeiten, Befehl Suchen) angegeben wurden. Sie können mit der Aktion SuchenWeiter wiederholt Datensätze suchen. Beispielsweise können Sie nacheinander alle Datensätze für einen bestimmten Kunden anzeigen.

Einstellung

Die Aktion SuchenWeiter verwendet keine Argumente. Die Aktion SuchenWeiter sucht den nächsten Datensatz, der die zuvor von der Aktion SuchenDatensatz oder im Dialogfeld Suchen in Feld festgelegten Kriterien erfüllt. Die Argumente für die Aktion SuchenDatensatz werden ebenso als Optionen im Dialogfeld Suchen in Feld verwendet.

Um Suchkriterien einzustellen, verwenden Sie die Aktion SuchenDatensatz. In der Regel geben Sie die Aktion SuchenDatensatz in ein Makro ein und verwenden dann die Aktion SuchenWeiter, um nachfolgende Datensätze zu finden, die dieselben Kriterien erfüllen. Falls Datensätze nur dann gesucht werden sollen, wenn eine bestimmte Bedingung zutrifft, geben Sie in der Spalte Bedingung der Zeile Aktion für die Aktion SuchenWeiter einen bedingten Ausdruck an.

Anmerkung

Diese Aktion hat dieselbe Wirkung wie die Schaltfläche Weitersuchen im Dialogfeld Suchen in Feld.

Anmerkung Während die Aktion SuchenDatensatz dem Befehl Suchen im Menü Bearbeiten für Tabellen, Abfragen und Formulare entspricht, ist dies im Modulfenster beim Befehl Suchen im Menü Bearbeiten nicht der Fall. Sie können die Aktion SuchenDatensatz oder SuchenWeiter nicht zum Suchen von Text in Modulen verwenden.

Tipp Wenn Sie das Argument Nur aktuelles Feld der Aktion SuchenDatensatz auf Ja eingestellt haben, setzen Sie ggf. mit der Aktion GeheZuSteuerelement den Fokus auf das Steuerelement, das die gesuchten Daten enthält, bevor Sie die Aktion SuchenWeiter verwenden.

Wenn der derzeit ausgewählte Text mit dem gesuchten Text identisch ist und dann die Makroaktion SuchenWeiter ausgeführt wird, beginnt die Suche direkt im Anschluss an die Auswahl in dem Feld und dem Datensatz, in dem die Auswahl erfolgte. Ist dies nicht der Fall beginnt die Suche am Anfang des aktuellen Datensatzes. So können Sie das wiederholte Auftreten desselben Suchkriteriums in einem einzelnen Datensatz finden.

Wenn Sie jedoch ein Makro, das die Aktion SuchenWeiter enthält, mit Hilfe einer Befehlsschaltfläche ausführen, beachten Sie, dass wiederholt das erste Vorkommen des Suchkriteriums gefunden wird. Das liegt daran, dass der Fokus beim Klicken auf die Befehlsschaltfläche dem Feld, das den übereinstimmenden Wert enthält, genommen wird. Die Aktion SuchenWeiter beginnt dadurch erneut am Anfang des Datensatzes, so dass stets das erste Vorkommen des Suchkriteriums in demselben Datensatz gefunden wird. Um dieses Problem zu umgehen, führen Sie das Makro mit einem Verfahren aus, das den Fokus nicht ändert, beispielsweise mit einer Schaltfläche in einer benutzerdefinierten Symbolleiste oder einer Tastenkombination, die in einem Makro AutoKeys definiert ist. Sie können aber auch im Makro den Fokus auf das Feld setzen, das das Suchkriterium enthält, bevor Sie die Aktion SuchenWeiter ausführen.

Dasselbe Verhalten tritt auch auf, wenn Sie ein Makro, das die Aktion SuchenDatensatz enthält, mit Hilfe einer Befehlsschaltfläche ausführen, wobei das Aktionsargument Am Anfang beginnen auf Nein eingestellt ist.

Zum Ausführen der Aktion SuchenWeiter in Visual Basic verwenden Sie die FindNext-Methode des DoCmd-Objekts.


 Tastaturbefehle-Aktion

Tastaturbefehle-Aktion

Sie können die Aktion Tastaturbefehle verwenden, um Tastenanschläge direkt an Microsoft Access oder eine aktive, auf Windows basierende Anwendung zu senden.

Einstellung

Die Aktion Tastaturbefehle verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Tastenfolge | Die von Microsoft Access oder der Anwendung zu verarbeitende Tastenfolge. Geben Sie die Tastenanschläge im Bereich Aktionsargumente des Makrofensters im Feld Tastenfolge ein. Sie können bis zu 255 Zeichen eingeben. Dieses Argument ist erforderlich.
Warten | Gibt an, ob das Makro warten soll, bis die Tastatureingaben verarbeitet sind. Klicken Sie auf Ja, wenn es warten soll, und auf Nein, wenn es nicht warten soll. Die Standardeinstellung ist Nein.

Anmerkung

Microsoft Access verarbeitet die durch die Aktion Tastaturbefehle erhaltene Tastenfolge genauso, als wenn Sie diese direkt in einem Microsoft Access-Fenster eingeben.

Verwenden Sie zum Angeben der Tastenfolge die gleiche Syntax wie für die Anweisung SendKeys.

Anmerkung Ein Fehler tritt auf, wenn das Argument Tastenfolge syntaktisch falsch oder inkorrekt geschrieben ist oder andere Werte enthält, die für das Fenster, an das die Tastenfolge gesendet wird, nicht geeignet sind.

Sie können diese Aktion zur Eingabe von Informationen in einem Dialogfeld verwenden, insbesondere, wenn Sie das Makro nicht unterbrechen möchten, um manuelle Eingaben im Dialogfeld vorzunehmen. Manche Aktionen in Microsoft Access, wie Drucken und SuchenDatensatz, wählen automatisch die Optionen in bestimmten, regelmäßig verwendeten Dialogfeldern aus. Sie können die Aktion Tastaturbefehle verwenden, um Optionen in weniger gebräuchlichen Dialogfeldern auszuwählen.

Anmerkungen

  • Da das Dialogfeld das Makro unterbricht, führen Sie die Aktion Tastaturbefehle vor der Aktion, die das Dialogfeld öffnet, aus und stellen das Argument Warten auf Nein ein.

  • Das richtige Abschätzen der Zeit, die Tastenfolgen benötigen, um Microsoft Access oder eine andere Anwendung zu erreichen, kann schwierig sein. Verwenden Sie daher die Aktion Tastaturbefehle nicht zum Ausfüllen von Optionen in einem Dialogfeld, wenn für die gewünschte Operation andere Methoden (z.B. die Aktion SuchenDatensatz) zur Verfügung stehen.

Wenn mehr als 255 Zeichen an Microsoft Access oder eine andere auf Windows basierende Anwendung gesendet werden sollen, können Sie mehrere Aktionen Tastaturbefehle hintereinander in einem Makro verwenden.

Die Verwendung der Aktion Tastaturbefehle zum Senden von Tastenfolgen löst die entsprechenden Ereignisse KeyDown, KeyUp und KeyPress aus. Das Senden von Tastenanschlägen, die keinen ANSI-Zeichen entsprechen (z.B. Funktionstasten) löst das KeyPress-Ereignis nicht aus.

Diese Aktion ist in Visual Basic nicht verfügbar. Verwenden Sie stattdessen die Anweisung SendKeys.


 TransferArbeitsblatt-Aktion

TransferArbeitsblatt-Aktion

Mit Hilfe der Aktion TransferArbeitsblatt können Sie Daten zwischen der aktuellen Microsoft Access-Datenbank (.mdb) bzw. dem aktuellen Access-Projekt (.adp) und einer Tabellenkalkulationsdatenbank importieren oder exportieren. Sie können auch die Daten einer Microsoft Excel-Tabelle mit der aktuellen Microsoft Access-Datenbank verknüpfen. Bei einer verknüpften Tabelle können Sie die Tabellendaten mit Microsoft Access anzeigen und bearbeiten, während es weiterhin uneingeschränkt möglich ist, über Microsoft Excel auf die Daten zuzugreifen. Sie können auch eine Verknüpfung zu den Daten in einer Lotus 1-2-3-Tabellenkalkulationsdatei herstellen. Diese Daten sind in Microsoft Access jedoch schreibgeschützt.

Einstellung

Die Aktion TransferArbeitsblatt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Transfertyp | Typ des Transfers, den Sie durchführen möchten. Wählen Sie im Feld Transfertyp des Bereichs Aktionsargumente des Makrofensters eine der Einstellungen Importieren, Exportieren oder Verknüpfen. Die Standardeinstellung ist Importieren.
 | Anmerkung Der Transfertyp Verknüpfen wird für Access-Projekte (.adp) nicht unterstützt.
Dateiformat | Typ der Tabellenkalkulationsdatei, aus der Sie importieren, in die Sie exportieren oder die Sie verknüpfen möchten. Sie können eines von mehreren Tabellenkalkulationsformaten im Feld wählen. Die Standardeinstellung ist Microsoft Excel 8.
 | Anmerkung Sie können aus Lotus .WK4-Dateien importieren und (schreibgeschützt) verknüpfen, können jedoch keine Microsoft Access-Daten in dieses Dateiformat exportieren. Ferner unterstützt Microsoft Access das Importieren, Exportieren oder Verknüpfen von Daten aus dem .WKS-Format von Lotus oder aus Microsoft Excel, Version 2.0, mit dieser Aktion nicht mehr. Wenn Sie Tabellenkalkulationsdaten aus Microsoft Excel, Version 2.0, oder dem .WKS-Format von Lotus importieren oder verknüpfen möchten, konvertieren Sie die Tabellenkalkulationsdaten in eine spätere Version von Microsoft Excel oder Lotus 1-2-3, bevor Sie die Daten in Microsoft Access importieren oder verknüpfen.
Tabellenname | Name der Microsoft Access-Tabelle, in die Tabellenkalkulationsdaten importiert oder verknüpft bzw. aus der Tabellenkalkulationsdaten exportiert werden sollen. Sie können auch den Namen der Microsoft Access-Auswahlabfrage angeben, deren Daten Sie exportieren möchten. Dieses Argument ist erforderlich.
 | Wenn Sie für das Argument Transfertyp die Einstellung Importieren gewählt haben, fügt Microsoft Access die Tabellendaten an diese Tabelle an, sofern sie bereits vorhanden ist. Ist die Tabelle noch nicht vorhanden, so erstellt Microsoft Access eine neue Tabelle mit den Tabellendaten.
 | In Microsoft Access 2000 können Sie zum Angeben der zu exportierenden Daten bei Verwendung der Aktion TransferArbeitsblatt keine SQL-Anweisung verwenden. Statt dessen erstellen Sie zunächst eine Abfrage und geben dann im Argument Tabellenname den Namen der Abfrage an.
Dateiname | Name der Tabellenkalkulationsdatei, aus der importiert, in die exportiert oder die verknüpft werden soll. Geben Sie den vollständigen Pfad an. Dieses Argument ist erforderlich.
 | Microsoft Access erstellt eine neue Tabellenkalkulationsdatei, wenn Sie Daten aus Microsoft Access exportieren. Ist der Dateiname identisch mit dem Namen einer vorhandenen Tabellenkalkulationsdatei, überschreibt Microsoft Access die vorhandene Datei, es sei denn, Sie exportieren in ein Arbeitsblatt von Microsoft Excel, Version 5.0, 7.0, 8.0 oder in eine Excel 2000-Arbeitsmappe. In diesem Fall kopiert Microsoft Access die exportierten Daten auf das nächste verfügbare Arbeitsblatt in der Arbeitsmappe.
 | Wenn Sie aus einer Tabelle von Microsoft Excel, Version 5.0, 7.0, 8.0 oder Excel 2000 importieren oder verknüpfen, können Sie über das Argument Bereich ein bestimmtes Arbeitsblatt angeben.
Besitzt Feldnamen | Gibt an, ob die erste Zeile der Tabelle die Namen der Felder enthält. Wenn Sie Ja wählen, verwendet Microsoft Access beim Importieren oder Verknüpfen der Tabellendaten die Namen aus dieser Zeile als Feldnamen in der Microsoft Access-Tabelle. Wenn Sie Nein wählen, interpretiert Microsoft Access die erste Zeile als normale Datenzeile. Die Standardeinstellung ist Nein.
 | Wenn Sie Daten von Microsoft Access-Tabellen oder -Auswahlabfragen in eine Tabellenkalkulationsdatei exportieren, werden die Feldnamen in die erste Zeile der Tabelle eingefügt, unabhängig davon, welche Einstellung Sie für dieses Argument wählen.
Bereich | Bereich der zu importierenden oder zu verknüpfenden Zellen. Lassen Sie dieses Argument leer, wenn Sie die ganze Tabelle importieren oder verknüpfen möchten. Sie können den Namen eines Tabellenbereichs oder den Bereich der zu importierenden oder zu verknüpfenden Zellen, z.B. A1:E25 (beachten Sie, dass die Syntax A1..E25 in Microsoft Access 97 oder Microsoft Access 2000 nicht verwendet werden kann), angeben. Falls Sie aus einer Tabelle von Microsoft Excel, Version 5.0, 7.0 oder 8.0 oder einem Excel 2000-Arbeitsblatt importieren oder verknüpfen, können Sie den Namen der Tabelle und ein Ausrufezeichen (z.B. Budget!A1:C7) vor die Bereichsangaben setzen.
 | Anmerkung Wenn Sie in eine Tabellenkalkulationsdatei exportieren, lassen Sie dieses Argument leer. Wenn Sie einen Bereich eingeben, schlägt der Export fehl.

Anmerkung

Sie können die Daten in Microsoft Access-Auswahlabfragen in Tabellenkalkulationen exportieren. Microsoft Access exportiert die Ergebnisgruppe der Abfrage und behandelt sie wie eine Tabelle.

Tabellenkalkulationsdaten, die Sie an eine vorhandene Microsoft Access-Tabelle anfügen, müssen mit der Struktur der Tabelle kompatibel sein.

  • Jedes Feld in der Kalkulationstabelle muss denselben Datentyp haben wie das entsprechende Feld in der Datenbanktabelle.

  • Die Felder müssen in derselben Reihenfolge angezeigt werden (es sei denn, Sie haben das Argument Besitzt Feldnamen auf Ja eingestellt. In diesem Fall müssen die Feldnamen in der Kalkulationstabelle mit den Feldnamen in der Datenbanktabelle übereinstimmen).

Wenn Sie im Menü Datei des Datenbankfensters auf Externe Daten oder Exportieren zeigen und dann auf Importieren oder Tabellen verknüpfen klicken, hat das in etwa dieselbe Auswirkung wie diese Aktion. Mit diesen Befehlen können Sie eine Datenquelle, wie z.B. Microsoft Access, ein anderes Datenbankformat, eine Tabellenkalkulationsdatei oder eine Textdatei auswählen. Wenn Sie eine Tabellenkalkulationsdatei wählen, wird eine Reihe von Dialogfeldern angezeigt oder ein Microsoft Access-Assistent ausgeführt, in denen Sie den Namen der Tabellenkalkulationsdatei und verschiedene andere Optionen wählen können. Die Argumente für die Aktion TransferArbeitsblatt entsprechen den Optionen in diesen Dialogfeldern oder in den Assistenten.

Anmerkung Wenn Sie eine Abfrage oder einen Filter an einem verknüpften Arbeitsblatt ausführen, wird bei der Abfrage oder dem Filter die Groß-/Kleinschreibung beachtet.

Wenn Sie eine Verknüpfung zu einem Excel-Arbeitsblatt herstellen, das im Bearbeitungsmodus geöffnet ist, stellt Microsoft Access die Verknüpfung erst her, nachdem der Bearbeitungsmodus des Excel-Arbeitsblatts beendet ist; dabei ergibt sich keine Wartezeit.

Um die Aktion TransferArbeitsblatt in Visual Basic auszuführen, verwenden Sie die TransferSpreadsheet-Methode des DoCmd-Objekts.


 TransferDatenbank-Aktion

TransferDatenbank-Aktion

Mit Hilfe der TransferDatenbank-Aktion können Sie Daten zwischen der aktuellen Microsoft Access-Datenbank (.MDB) oder einem Access-Projekt (.ADP) und einer anderen Datenbank importieren oder exportieren. Für Microsoft Access-Datenbanken (.MDB) können Sie auch eine Tabelle einer anderen Datenbank mit der aktuellen Microsoft Access-Datenbank verknüpfen. Mit einer verknüpften Tabelle haben Sie Zugriff auf die Daten der Tabelle, während die Tabelle als solche in der anderen Datenbank bleibt.

Einstellung

Die Aktion TransferDatenbank verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Transfertyp | Typ von Transfer, den Sie vornehmen möchten. Wählen Sie im Feld Transfertyp des Bereichs Aktionsargumente des Makrofensters eine der Optionen Importieren, Exportieren oder Verknüpfen. Die Standardeinstellung ist Importieren.
 | Anmerkung Der Transfertyp Verknüpfen wird nicht für Access-Projekte (.ADP) unterstützt.
Datenbankformat | Datenbankformat, aus dem importiert, in das exportiert oder mit dem eine Verknüpfung hergestellt werden soll. Sie können im Feld Datenbankformat den Eintrag Microsoft Access oder ein anderes der zur Auswahl stehenden Formate wählen. Standardmäßig ist Microsoft Access vorgegeben.
 | Welche Datenbankformate im Argument Datenbankformat gezeigt werden, ist abhängig davon, wie Sie Microsoft Access eingerichtet haben. Nicht alle Datenbankformate werden standardmäßig installiert. Wenn das Datenbankformat, das Sie zum Importieren, Exportieren oder Verknüpfen verwenden möchten, nicht zur Verfügung steht, führen Sie das Microsoft Access Setup-Programm aus, klicken auf die Option Hinzufügen/Entfernen, wählen im Dialogfeld die Option Datenzugriff und ActiveX-Steuerelemente und klicken dann auf die Schaltfläche Option ändern. Anschließend wählen Sie das Datenbankformat, das Sie installieren möchten, aus dem Feld Datenbank-Treiber aus und klicken dann erneut auf Option ändern.
Datenbankname | Name der Datenbank, aus der importiert, in die exportiert oder mit der eine Verknüpfung hergestellt werden soll. Geben Sie den vollständigen Pfad an. Dieses Argument ist erforderlich.
 | Geben Sie für Datenbanken, die für jede Tabelle separate Dateien verwenden (wie z. B. FoxPro, Paradox und dBASE) das Verzeichnis an, das die Datei enthält. Geben Sie den Dateinamen im Argument Quelle (bei einen Import oder einer Verknüpfung) oder im Argument Ziel (bei einem Export) an.
 | Geben Sie für ODBC-Datenbanken die vollständige ODBC (Open Database Connectivity)- Verbindungszeichenfolge ein. Um ein Beispiel für eine Verbindungszeichenfolge zu sehen, verknüpfen Sie eine externe Tabelle mit Microsoft Access. Hierzu zeigen Sie im Menü Datei auf Externe Daten und klicken auf Tabellen verknüpfen. Öffnen Sie die Tabelle in der Entwurfsansicht, und zeigen Sie die Tabelleneigenschaften an. Der Text in der Einstellung der Eigenschaft Description ist die Verbindungszeichenfolge für diese Tabelle.
 | Weitere Informationen zu ODBC-Verbindungszeichenfolgen finden Sie in der Hilfedatei oder anderen Dokumentation zum ODBC-Treiber für diesen Typ von ODBC-Datenbank.
Objekttyp | Typ des zu importierenden oder exportierenden Objekts. Wenn Sie für das Argument Datenbankformat die Option Microsoft Access auswählen, können Sie im Feld Objekttyp unter Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Diagramm oder Gespeicherte Prozeduren wählen. Wenn Sie ein anderes Datenbankformat wählen, oder wenn Sie im Feld Transfertyp die Option Verknüpfen wählen, wird dieses Argument ignoriert. Der Standardwert lautet Tabelle.
 | Wenn Sie eine Auswahlabfrage in eine Microsoft Access-Datenbank exportieren, wählen Sie für dieses Argument die Einstellung Tabelle, um die Ergebnisgruppe der Abfrage zu exportieren, bzw. die Einstellung Abfrage, um die Abfrage als solche zu exportieren. Wenn Sie eine Auswahlabfrage in ein anderes Datenbankformat exportieren, wird dieses Argument ignoriert und die Ergebnisgruppe der Abfrage exportiert.
Quelle | Name der Tabelle, Auswahlabfrage oder des Microsoft Access-Objekts, das Sie importieren, exportieren oder verknüpfen möchten. Für einige Datenbankformate, wie z. B. FoxPro, Paradox oder dBASE, ist dies ein Dateiname. Nehmen Sie die Dateinamenerweiterung (wie z. B. .DBF) in den Dateinamen auf. Dieses Argument ist erforderlich.
Ziel | Der Name der importierten, exportierten oder verknüpften Tabelle oder Auswahlabfrage bzw. des importierten, exportierten oder verknüpften Microsoft Access-Objekts in der Zieldatenbank. Für einige Datenbankformate wie z. B. FoxPro, Paradox oder dBASE ist dies ein Dateiname. Nehmen Sie die Dateinamenerweiterung (wie z. B. .DBF) in den Dateinamen auf. Dieses Argument ist erforderlich.
 | Wenn Sie für das Argument Transfertyp die Einstellung Importieren wählen und für das Argument Objektyp die Einstellung Tabelle wählen, erstellt Microsoft Access eine neue Tabelle, die die Daten in der importierten Tabelle enthält.
 | Wenn Sie eine Tabelle oder ein anderes Objekt importieren, fügt Microsoft Access dem Namen eine Zahl hinzu, falls sich ein Konflikt mit einem bestehenden Namen ergibt. Wenn Sie z. B. ein Objekt mit dem Namen Personal importieren und bereits ein Objekt dieses Namens existiert, benennt Microsoft Access das importierte Objekt (z. B. Tabelle) in Personal1 um.
 | Wenn Sie in eine Microsoft Access-Datenbank oder ein anderes Datenbankformat exportieren, überschreibt Microsoft Access automatisch jedes bestehende Objekt (z. B. Tabelle), das denselben Namen trägt.
Nur Struktur | Gibt an, ob nur die Struktur einer Datenbanktabelle ohne ihre Daten importiert oder exportiert werden soll. Wählen Sie Ja oder Nein. Die Standardeinstellung ist Nein.

Anmerkung

Sie können Tabellen zwischen Microsoft Access und anderen Datenbankformaten importieren und exportieren. Sie können auch Microsoft Access-Auswahlabfragen in andere Datenbankformate exportieren. Microsoft Access exportiert die Ergebnisgruppe der Abfrage in Form einer Tabelle. Ein beliebiges Microsoft Access-Datenbankobjekt können Sie importieren und exportieren, wenn beide Datenbanken Microsoft Access-Datenbanken sind.

Wenn Sie in Microsoft Access 2000 eine Tabelle aus einer anderen Microsoft Access-Datenbank (.MDB) importieren, die in dieser Datenbank eine verknüpfte Tabelle ist, ist sie nach dem Importieren nach wie vor verknüpft. Es wird also die Verknüpfung und nicht die Tabelle als solche importiert.

Ist für die Datenbank, auf die Sie zugreifen, ein Kennwort erforderlich, wird ein Dialogfeld angezeigt, wenn Sie das Makro ausführen. Geben Sie das Kennwort in das Dialogfeld ein.

Anmerkung Sie können Daten nur zwischen Microsoft Access- und FoxPro-Datenbanken der Version 3.0 importieren und exportieren. Wenn Sie über einen FoxPro-ODBC-Treiber verfügen, können Sie eine Verknüpfung zu Tabellen in diesen FoxPro-Datenbanken herstellen.

Die Aktion TransferDatenbank hat eine vergleichbare Wirkung, wie wenn Sie im Menü Datei des Datenbankfensters auf Externe Daten oder auf Exportieren zeigen und dann auf Importieren oder Tabellen verknüpfen klicken. Mit Hilfe dieser Befehle können Sie eine Datenquelle (z.B. Microsoft Access) oder ein Datenbankformat, ein Arbeitsblatt oder eine Textdatei wählen. Wenn Sie eine Datenbank wählen, werden ein oder mehrere Dialogfelder angezeigt, in dem/denen Sie den zu importierenden oder exportierenden Objekttyp (bei Microsoft Access-Datenbanken), den Namen des Objekts und andere Optionen wählen, je nachdem, aus welcher Datenbank Sie importieren, in welche Sie exportieren oder zu welcher Sie eine Verknüpfung herstellen. Die Argumente der Aktion TransferDatenbank entsprechen den Optionen in diesen Dialogfeldern.

Wenn Sie Indexinformationen für eine verknüpfte FoxPro- oder dBASE-Tabelle bereitstellen möchten, verknüpfen Sie die FoxPro- oder dBASE-Tabelle zunächst. Hierzu zeigen Sie im Menü Datei auf Externe Daten und klicken auf Tabellen verknüpfen. Geben Sie dann die Indizes in den Dialogfeldern zu diesem Befehl an. Microsoft Access speichert die Indexinformationen in einer speziellen Informationsdatei (.INF), die sich im Ordner OFFICE befindet (der Pfad lautet C:\MSOFFICE). Dann können Sie die Verknüpfung zu der verknüpften Tabelle löschen. Wenn Sie die Aktion TransferDatenbank das nächste Mal zum Herstellen einer Verknüpfung zu dieser FoxPro- oder dBASE-Tabelle verwenden, verwendet Microsoft Access die von Ihnen festgelegten Indexinformationen.

Anmerkung Wenn Sie eine Abfrage oder einen Filter an einer verknüpften Tabelle ausführen, wird bei der Abfrage oder dem Filter die Groß-/Kleinschreibung beachtet.

Zum Ausführen der Aktion TransferDatenbank in Visual Basic verwenden Sie die TransferDatabase-Methode des DoCmd-Objekts.


 TransferText-Aktion

TransferText-Aktion

Mit Hilfe der Aktion TransferText können Sie Text zwischen der aktuellen Microsoft Access-Datenbank (.mdb) bzw. dem aktuellen Access-Projekt (.adp) und einer Textdatei importieren oder exportieren. Sie können auch die Daten einer Textdatei mit der aktuellen Access-Datenbank verknüpfen. Mit einer verknüpften Textdatei können Sie die Textdaten mit Microsoft Access anzeigen und bearbeiten, während es weiterhin uneingeschränkt möglich ist, aus Ihrem Textverarbeitungsprogramm heraus auf die Daten zuzugreifen. Ferner besteht die Möglichkeit, aus einer Tabelle oder Liste in einer HTML-Datei (*.HTML) zu importieren, bzw. in diese zu exportieren und zu verknüpfen.

Anmerkung Wenn Sie eine Verknüpfung zu Daten in einer Textdatei oder einer HTML-Datei herstellen, sind die Daten in Microsoft Access schreibgeschützt.

Einstellung

Die Aktion TransferText verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Transfertyp | Typ des Transfers, den Sie durchführen möchten. Sie können Daten aus Textdateien mit Trennzeichen oder Textdateien mit festgelegtem Format oder HTML-Dateien importieren, Daten in diese Dateien exportieren oder Daten verknüpfen. Sie können außerdem Daten in Microsoft Word für Windows-Seriendruckdateien exportieren, mit denen Sie dann unter Verwendung der Word für Windows Seriendruck-Funktion Seriendruckdokumente, wie z.B. Serienbriefe und Adressetiketten, erstellen können.
 | Wählen Sie im Makrofensters im Bereich Aktionsargumente im Feld Transfertyp eine der Einstellungen Import mit Trennzeichen, Import festgelegtes Format, Import HTML, Export mit Trennzeichen, Export festgelegtes Format, Export HTML, Export Word für Windows-Seriendruck, Verknüpfung mit Trennzeichen, Verknüpfung festgelegtes Format oder Verknüpfung HTML. Die Standardeinstellung lautet Import mit Trennzeichen.
 | Anmerkung In einem Access-Projekt (.adp) werden nur die Transfertypen Import mit Trennzeichen, Import festgelegtes Format, Export mit Trennzeichen, Export festgelegtes Format oder Export Word für Windows-Seriendruck unterstützt.
Spezifikationsname | Spezifikationsname für die Gruppe von Optionen, die festlegt, wie eine Textdatei importiert, exportiert oder verknüpft wird. Bei einer Textdatei mit festgelegtem Format müssen Sie entweder ein Argument angeben oder eine Datei schema.ini verwenden. Diese Datei muss in demselben Ordner wie die importierte, verknüpfte oder exportierte Textdatei gespeichert werden.
 | Wählen Sie den Unterbefehl Importieren oder Tabellen verknüpfen des Befehls Externe Daten oder im Menü Datei den Befehl Exportieren, um eine Spezifikation für einen bestimmten Textdateityp zu erstellen. Dies kann z. B. eine Textdatei mit Trennzeichen sein, in der Tabulatorzeichen zum Trennen der Felder verwendet werden und in der Datumsfelder im Format TMJ formatiert sind. Wenn Sie auf einen dieser Befehle klicken und einen Textdateityp für den Import, Export oder die Verknüpfung auswählen, wird der Textimport-Assistent, Textexport-Assistent oder Textverknüpfungs-Assistent ausgeführt. Sie können im Assistenten auf die Schaltfläche Weitere klicken und eine Spezifikation im angezeigten Dialogfeld definieren und speichern. Sie können dann den Spezifikationsnamen für dieses Argument eingeben, wann immer Sie denselben Textdateityp importieren oder exportieren möchten.
 | Sie können Textdateien mit Trennzeichen auch ohne Angabe eines Spezifikationsnamens für dieses Argument importieren, exportieren oder verknüpfen. In diesem Fall verwendet Microsoft Access die im Dialogfeld des Assistenten gesetzten Standardeinstellungen. Microsoft Access verwendet ein vorbestimmtes Format für Seriendruckdateien, so dass Sie keinen Spezifikationsnamen für dieses Argument eingeben müssen, wenn Sie diese Dateitypen exportieren. Sie können Import-/Exportspezifikationen in Verbindung mit HTML-Dateien einsetzen, wobei der einzig relevante Teil der Spezifikation der über die Formatierung von Datentypen ist.
Tabellenname | Name der Microsoft Access-Tabelle, in die Textdaten importiert, aus der sie exportiert oder mit der sie verknüpft werden sollen. Sie können auch den Namen der Microsoft Access-Abfrage eingeben, deren Daten Sie exportieren möchten. Dieses Argument ist erforderlich.
 | Wenn Sie im Feld Transfertyp auf eine der Einstellungen Import mit Trennzeichen, Import festgelegtes Format oder Import HTML klicken, fügt Microsoft Access die Textdaten an diese Tabelle an, sofern die Tabelle bereits vorhanden ist. Ist die Tabelle noch nicht vorhanden, so erstellt Microsoft Access eine neue Tabelle mit den Daten aus der Textdatei.
 | In Microsoft Access 2000 können Sie zum Angeben der zu exportierenden Daten bei Verwendung der Aktion TransferText keine SQL-Anweisung verwenden. Statt dessen erstellen Sie zunächst eine Abfrage und geben dann im Argument Tabellenname den Namen der Abfrage an.
Dateiname | Name der Textdatei, aus der importiert, in die exportiert oder die verknüpft werden soll. Geben Sie den vollständigen Pfad an. Dieses Argument ist erforderlich.
 | Microsoft Access erstellt eine neue Textdatei, wenn Sie Daten aus Microsoft Access exportieren. Ist der Dateiname identisch mit dem Namen einer vorhandenen Textdatei, so überschreibt Microsoft Access die vorhandene Textdatei.
 | Möchten Sie eine bestimmte Tabelle oder Liste in einer HTML-Datei importieren oder verknüpfen, können Sie das Argument HTML-Tabellenname verwenden.
Besitzt Feldnamen | Gibt an, ob die erste Zeile der Textdatei die Spaltennamen enthält. Wenn Sie Ja wählen, verwendet Microsoft Access beim Importieren oder Verknüpfen die Namen aus dieser Zeile als Feldnamen der Microsoft Access-Tabelle. Wenn Sie Nein wählen, interpretiert Microsoft Access die erste Zeile als normale Datenzeile. Die Standardeinstellung ist Nein.
 | Microsoft Access beachtet dieses Argument in Word für Windows-Seriendruckdateien nicht, weil deren erste Zeile die Feldnamen enthalten muss.
 | Wenn Sie Daten aus Microsoft Access-Tabellen oder -Auswahlabfragen in eine Textdatei mit Trennzeichen oder mit festgelegtem Format exportieren und Sie für dieses Argument die Option Ja ausgewählt haben, fügt Microsoft Access die Feldnamen Ihrer Tabelle oder Auswahlabfrage in die erste Zeile der Textdatei ein.
 | Wenn Sie eine Textdatei mit festgelegtem Format importieren oder verknüpfen und in diesem Feld Ja ausgewählt haben, muss die erste, die Feldnamen enthaltende Zeile die gleichen Texttrennzeichen verwenden, die in den Import-/Export-Spezifikationen festgelegt sind, um die Feldnamen zu trennen. Wenn Sie in eine Textdatei mit festgelegtem Format exportieren und für dieses Argument Ja wählen, fügt Microsoft Access die Feldnamen in die erste Zeile der Textdatei unter Verwendung dieser Trennzeichen ein.
HTML-Tabellenname | Name der Tabelle oder Liste in der HTML-Datei, die Sie importieren oder verknüpfen möchten. Dieses Argument wird nur beachtet, wenn das Argument Transfertyp auf Import HTML oder Verknüpfung HTML eingestellt ist. Wenn Sie dieses Argument leer lassen, wird die erste Tabelle oder Liste in der HTML-Datei importiert oder verknüpft.
 | Der Name der Tabelle oder Liste in der HTML-Datei wird durch den Text bestimmt, der durch die <CAPTION>-Marke festgelegt ist, sofern eine solche existiert. Existiert keine <CAPTION>-Marke, wird der Name durch den in der <TITLE>-Marke festgelegten Text bestimmt. Tragen mehrere Tabellen oder Listen ein und denselben Namen, unterscheidet Microsoft Access sie durch Hinzufügen einer Zahl am Ende des jeweiligen Namens (z.B. Personal1 und Personal2).
Codepage | Name des Zeichensatzes, der bei der Codeseite verwendet wird.

Anmerkung

Sie können Microsoft Access-Auswahlabfragen in Textdateien exportieren. Microsoft Access exportiert die Ergebnisgruppe der Abfrage und behandelt diese wie eine Tabelle.

Textdaten, die Sie an eine vorhandene Microsoft Access-Tabelle anfügen, müssen mit der Struktur der Tabelle kompatibel sein.

  • Jedes Feld im Text muss denselben Datentyp haben wie das entsprechende Feld in der Tabelle.

  • Die Felder müssen in derselben Reihenfolge angezeigt werden (es sei denn, Sie haben das Argument Besitzt Feldnamen auf Ja eingestellt. In diesem Fall müssen die Feldnamen im Text mit den Feldnamen der Tabelle übereinstimmen).

Wenn Sie im Menü Datei des Datenbankfensters auf Externe Daten oder Exportieren zeigen und dann auf Importieren oder Tabellen verknüpfen klicken, so hat dies dieselbe Auswirkung wie diese Aktion. Mit diesen Befehlen können Sie eine Datenquelle, wie z.B. Microsoft Access, einen anderen Datenbanktyp, eine Tabellenkalkulationsdatei oder eine Textdatei auswählen. Wenn Sie eine Textdatei mit Trennzeichen, eine Textdatei mit festgelegtem Format oder eine HTML-Datei wählen, fordert Sie ein Assistent auf, den Namen der Datei und verschiedene andere Optionen zu wählen. Die Argumente der Aktion TransferText entsprechen den Optionen in diesen Assistenten.

Tipp Eine Import-/Exportspezifikation speichert die Informationen, die Microsoft Access zum Importieren, Exportieren oder Verknüpfen einer Textdatei benötigt. Sie können die gespeicherten Spezifikationen zum Importieren, Exportieren oder Verknüpfen von Textdaten aus bzw. in ähnlichen Textdateien verwenden. Wenn Sie z.B. wöchentlich Umsätze in einer Textdatei von einer Großrechenanlage erhalten, können Sie für diesen speziellen Typ von Daten eine Spezifikation erstellen und speichern, und diese immer verwenden, wenn Sie diese Daten zu Ihrer Microsoft Access-Datenbank hinzufügen möchten.

Anmerkung Wenn Sie eine Abfrage oder einen Filter an der verknüpften Textdatei ausführen, wird bei der Ausfrage oder dem Filter die Groß-/Kleinschreibung beachtet.

Um die Aktion TransferText in Visual Basic auszuführen, verwenden Sie die Methode TransferText des Objekts DoCmd.


 UmbenennenObjekt-Aktion

UmbenennenObjekt-Aktion

Sie können die Aktion UmbenennenObjekt verwenden, um ein Datenbankobjekt umzubenennen.

Einstellung

Die Aktion UmbenennenObjekt verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Neuer Name | Ein neuer Name für das Datenbankobjekt. Geben Sie den Objektnamen im Bereich Aktionsargumente des Makrofensters im Feld Neuer Name ein. Dieses Argument ist erforderlich.
Objekttyp | Der Typ des umzubenennenden Objekts. Klicken Sie auf Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Diagramm oder Gespeicherte Prozeduren. Wenn Sie das im Datenbankfenster ausgewählte Objekt umbenennen möchten, lassen Sie dieses Argument leer.
Alter Name | Der Name des umzubenennenden Objekts. Das Feld Alter Name zeigt alle Objekte des im Argument Objekttyp ausgewählten Typs in der gesamten Datenbank an. Wenn Sie für Objekttyp keinen Wert eingeben, lassen Sie dieses Argument ebenfalls leer. Anmerkung Wenn Sie ein Makro, das die Aktion UmbenennenObjekt enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Objekt zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkung

Der neue Name des Datenbankobjekts muss den Standardregeln zur Benennung von Microsoft Access-Objekten entsprechen.

Sie können kein geöffnetes Objekt umbenennen.

Wenn die Argumente Objekttyp und Alter Name leer bleiben, benennt Microsoft Access das im Datenbankfenster ausgewählte Objekt um. Um ein Objekt im Datenbankfenster auszuwählen, verwenden Sie die Aktion AuswählenObjekt, wobei Sie das Argument In Datenbankfenster auf Ja einstellen.

Sie können ein Objekt auch umbenennen, indem Sie im Datenbankfenster darauf klicken, erneut darauf klicken, um den Namen zu bearbeiten, und dann einen neuen Namen eingeben. Mit der Aktion UmbenennenObjekt brauchen Sie dagegen das Objekt nicht zuerst im Datenbankfenster auszuwählen, und Sie müssen das Makro auch nicht anhalten, um den neuen Namen einzugeben.

Diese Aktion unterscheidet sich von der Aktion KopierenObjekt dadurch, dass letztere eine Kopie des Objekts mit einem neuen Namen erstellt.

Zum Ausführen der Aktion Umbenennen in Visual Basic verwenden Sie die Rename-Methode des DoCmd-Objekts.


 Verlassen-Aktion

Verlassen-Aktion

Sie können die Aktion Verlassen zum Beenden von Microsoft Access verwenden. Mit der Aktion Verlassen können Sie außerdem verschiedene Optionen für die Speicherung von Datenbankobjekten vor dem Beenden von Microsoft Access festlegen.

Einstellung

Die Aktion Verlassen verwendet das folgende Argument.

Aktionsargument | Beschreibung
Optionen | Gibt an, was mit ungespeicherten Objekten beim Beenden von Microsoft Access geschieht. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Optionen auf Nachfragen (um Dialogfelder einzublenden, die für jedes Objekt nachfragen, ob es gespeichert werden soll) auf Alles Speichern (um alle Objekte ohne Dialogfeldaufforderung zu speichern), oder auf Beenden (um Microsoft Access zu beenden, ohne ein Objekt zu speichern). Die Standardeinstellung ist Alles Speichern.

Anmerkung

Microsoft Access führt keine Aktionen aus, die der Aktion Verlassen in einem Makro folgen.

Sie können mit dieser Aktion Microsoft Access ohne Aufforderung durch Speichern-Dialogfelder aus einem benutzerdefinierten Menübefehl oder einer Schaltfläche in einem Formular heraus beenden. Wenn Sie z. B. in einem Hauptformular die Objekte in Ihrem benutzerdefinierten Arbeitsbereich anzeigen, kann dieses Formular eine Schaltfläche Beenden enthalten, die ein Makro mit der Aktion Verlassen ausführt, wobei das Argument Optionen auf Alles Speichern eingestellt ist.

Diese Aktion hat dieselbe Wirkung wie das Klicken auf Beenden im Menü Datei. Wenn Objekte beim Klicken auf diesen Befehl noch nicht gespeichert sind, werden dieselben Dialogfelder angezeigt, die auch beim Verwenden von Nachfragen für das Argument Optionen der Aktion Verlassen angezeigt werden.

Sie können die Aktion Speichern in einem Makro verwenden, um das angegebene Objekt zu speichern, ohne Microsoft Access zu beenden oder das Objekt zu schließen.

Zum Ausführen der Aktion Verlassen in Visual Basic verwenden Sie die Quit-Methode des DoCmd-Objekts.


 Warnmeldungen-Aktion

Warnmeldungen-Aktion

Sie können die Aktion Warnmeldungen verwenden, um Systemmeldungen ein- oder auszuschalten.

Einstellung

Die Aktion Warnmeldungen verwendet das folgende Argument.

Aktionsargument | Beschreibung
Warnmeldungen An | Gibt an, ob Systemmeldungen angezeigt werden. Klicken Sie im Bereich Aktionsargumente des Makrofensters im Feld Warnmeldungen An auf Ja (um Systemmeldungen einzuschalten) oder auf Nein (um Systemmeldungen auszuschalten). Die Standardeinstellung ist Nein.

Anmerkung

Sie können diese Aktion verwenden, damit gebundene Warnungen und Meldungsfelder das Makro nicht unterbrechen. Fehlermeldungen werden jedoch immer angezeigt. Microsoft Access zeigt auch alle Dialogfelder an, die andere Eingaben als lediglich das Auswählen einer Schaltfläche erfordern (z.B. OK, Abbrechen, Ja oder Nein), z.B. jedes Dialogfeld, in dem Sie Text eingeben oder eine Option auswählen müssen.

Das Ausführen dieser Aktion, wobei Warnmeldungen An auf Ja eingestellt ist, hat dieselbe Wirkung wie das Drücken der EINGABETASTE, sobald eine Warnung oder ein Meldungsfeld angezeigt wird. In der Regel wird eine Schaltfläche OK oder Ja als Antwort auf die Warnung oder Meldung gewählt.

Nach dem Beenden des Makros schaltet Microsoft Access automatisch die Anzeige der Systemmeldungen wieder an.

Häufig wird diese Aktion zusammen mit der Aktion Echo verwendet, die die Ergebnisse eines Makros so lange ausblendet, bis das Makro beendet ist. Sie können die Aktion Warnmeldungen auch verwenden, um Warnungen und Meldungsfelder auszublenden.

Vorsicht Obwohl die Aktion Warnmeldungen Wechselwirkungen mit Makros vereinfachen kann, seien Sie beim Ausschalten von Systemmeldungen vorsichtig. In einigen Situationen soll das Makro bestimmt angehalten werden, wenn eine bestimmte Warnmeldung angezeigt wird. Verwenden Sie diese Aktion nicht, solange Sie die Wirkung aller Makroaktionen nicht genau kennen.

Zum Ausführen der Aktion Warnmeldungen in Visual Basic verwenden Sie die SetWarnings-Methode des DoCmd-Objekts.


 Wiederherstellen-Aktion

Wiederherstellen-Aktion

Sie können die Aktion Wiederherstellen verwenden, um die ursprüngliche Größe eines maximierten oder minimierten Fensters wiederherzustellen.

Anmerkung Diese Aktion kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen zu Modulfenstern finden Sie unter dem Thema WindowState-Eigenschaft.

Einstellung

Die Aktion Wiederherstellen verwendet keine Argumente.

Anmerkung

Diese Aktion bezieht sich auf das ausgewählte Objekt. Ein minimiertes Objekt können Sie zuerst mit der Aktion AuswählenObjekt auswählen und dann mit der Aktion Wiederherstellen in der ursprünglichen Größe wiederherstellen.

Sie können die Aktion Positionieren verwenden, um ein wiederhergestelltes Fenster zu verschieben oder dessen Größe zu ändern.

Die Aktion Wiederherstellen hat dieselbe Wirkung wie das Klicken auf die Schaltfläche Wiederherstellen in der oberen rechten Fensterecke oder das Klicken auf den Befehl Wiederherstellen im Systemmenü des Fensters.

Zum Ausführen der Aktion Wiederherstellen in Visual Basic verwenden Sie die Restore-Methode des DoCmd-Objekts.


 Microsoft Access-Konstanten - Übersicht

Microsoft Access-Konstanten - Übersicht

Allgemeine Aufgaben

Eine Konstante stellt einen nicht veränderlichen numerischen oder Zeichenfolgen-Wert dar. Sie können Konstanten zur Verbesserung der Lesbarkeit sowie zur Vereinfachung der Pflege Ihres Visual Basic-Codes verwenden. Zusätzlich stellt die Verwendung von eingebauten Konstanten sicher, dass Code auch dann weiterhin ausgeführt wird, wenn die von den Konstanten dargestellten, zugrunde liegenden Werte in späteren Versionen von Microsoft Access verändert werden.

Microsoft Access unterstützt drei Arten von Konstanten:

  • Symbolische Konstanten, die Sie über die Anweisung Const erstellen und in Modulen verwenden.

  • Eingebaute Konstanten, die Teil von Microsoft Access oder einer referenzierten Bibliothek sind.

  • Systemdefinierte Konstanten: True, False und Null.

Symbolische Konstanten

Oftmals verwenden Sie die gleichen Werte wiederholt in Ihrem Code, oder Sie stellen fest, dass der Code von bestimmten Zahlen abhängt, die keine auf den ersten Blick erkennbare Bedeutung haben. In diesen Fällen können Sie die Lesbarkeit und Wartung des Codes vereinfachen, indem Sie symbolische oder benutzerdefinierte Konstanten verwenden, die Ihnen die Verwendung von bedeutungsvollen Namen an Stelle einer Zahl oder einer Zeichenfolge ermöglichen.

Haben Sie einmal eine Konstante über die Anweisung Const erstellt, können Sie sie weder ändern noch ihr einen neuen Wert zuweisen. Sie können weiterhin keine Konstante erstellen, die über den gleichen Namen wie eine eingebaute Konstante verfügt.

Die folgenden Beispiele zeigen einige der Möglichkeiten, wie Sie die Anweisung Const zur Deklaration von numerischen und Zeichenfolgen-Konstanten verwenden können:

Const conPI = 3.14159265                ' Pi gleich diese Zahl.
Const conPI2 = conPI * 2
    ' Eine Konstante wird zur Erstellung einer anderen verwendet.
Const conVersion = "Version 7.0"
    ' Zeichenfolgen-Konstante deklarieren.

Eingebaute Konstanten

Zusätzlich zu den Konstanten, die Sie mit der Const-Anweisung deklarieren, deklariert Microsoft Access automatisch eine Anzahl eingebauter Konstanten und stellt Zugriff auf die VBA (Visual Basic für Applikationen)- und die ADO (ActiveX Data-Objekte)-Konstanten bereit. Sie können auch Konstanten verwenden, die sich in anderen referenzierten Objektbibliotheken befinden. Weitere Informationen über das Hinzufügen von Verweisen finden Sie unter Einstellen von Verweisen auf Typbibliotheken.

Jede eingebaute Konstante kann in einem Makro oder in Visual Basic verwendet werden. Diese Konstanten sind jederzeit verfügbar. Die speziellen, mit einer bestimmten Funktion, Methode oder Eigenschaft verwendeten eingebauten Konstanten werden im Hilfethema zur jeweiligen Funktion, Methode oder Eigenschaft beschrieben.

Anmerkung Sie können den Objektkatalog zur Ansicht von Listen eingebauter Konstanten aller verfügbaren Objektbibliotheken verwenden.

Eingebaute Konstanten verfügen über ein Präfix von zwei Buchstaben, das die Objektbibliothek kennzeichnet, in der die Konstante definiert ist. Konstanten der Microsoft Access-Bibliothek wird "ac" vorangestellt; Konstanten der ADO-Bibliothek wird "ad" vorangestellt; Konstanten der Visual Basic-Bibliothek wird "vb" vorangestellt. Beispiel:

  • acForm

  • adAddNew

  • vbCurrency

Anmerkung Da sich die von eingebauten Konstanten dargestellten Werte in zukünftigen Versionen von Microsoft Access verändern können, verwenden Sie die Konstanten an Stelle ihrer aktuellen Werte. Sie können dennoch den aktuellen Wert einer Konstanten durch Wahl der Konstanten im Objektkatalog oder durch Eingabe von ?Konstantenname im Direktfenster anzeigen.

Sie können eingebaute Konstanten überall dort verwenden, wo Sie auch symbolische oder benutzerdefinierte Konstanten verwenden, einschließlich der Verwendung in Ausdrücken. Das folgende Beispiel zeigt, wie Sie die eingebaute Konstante vbCurrency verwenden können, um zu ermitteln, ob die Variable varNum eine Variable vom Typ Variant ist, für den die VarType-Funktion 6 (Currency) zurückgibt:

Dim varNum As Variant
If VarType(varNum) = vbCurrency Then
    Debug.Print "varNum enthält Daten des Typs Currency."
Else
    Debug.Print "varNum enthält keine Daten des Typs Currency."
End If

Es gibt mehrere Kategorien eingebauter Konstanten. Sie können eine Liste der eingebauten Konstanten einer bestimmten Kategorie anzeigen, indem Sie auf eine der folgenden Kategorien klicken:

  • Aktionskonstanten

  • Datenzugriffsobjektkonstanten

  • Ereignisprozedurkonstanten

  • Tastaturcode-Konstanten

  • Sonstige Konstanten

  • RunCommand-Konstanten (eine Teilmenge der Aktionskonstanten)

  • Zugriffsrechtekonstanten

  • Visual Basic-Konstanten

  • VarType-Konstanten

Systemdefinierte Konstanten

Sie können die systemdefinierten Konstanten True, False und Null überall in Microsoft Access verwenden. Sie können z.B. True im folgenden Makrobedingungsausdruck verwenden. Die Bedingung trifft zu, wenn die Einstellung der Eigenschaft Visible für das Formular Personal den Wert True hat.

Formulare!Personal.Visible = True

Sie können die Konstante Null überall in Microsoft Access verwenden. Sie können z.B. Null zur Einstellung der Eigenschaft DefaultValue für ein Formular-Steuerelement über den folgenden Ausdruck verwenden:

=Null


 Schreibweise der eingebauten Konstanten

Schreibweise der eingebauten Konstanten

In Microsoft Access 2000 sind alle eingebauten Konstanten in Typbibliotheken enthalten und können im Objektkatalog angezeigt werden. Microsoft Access verfügt über Typbibliotheken für Microsoft Access, ActiveX Data-Objeke (ADO), Datenzugriffsobjekte (DAO) und Visual Basic. Alle genannten Typbibliotheken enthalten eingebaute Konstanten.

Darüber hinaus bestehen die Namen eingebauter Konstanten in Microsoft Access 2000 aus einer Kombination von Groß- und Kleinbuchstaben, wobei die einzelnen Namensbestandteile miteinander verkettet und nicht durch Unterstriche getrennt sind. Beispielsweise heißt die Konstante A_NORMAL der Versionen 1.x und 2.0 jetzt acNormal.

Eingebaute Konstanten in Datenbanken, die in früheren Microsoft Access-Versionen erstellt wurden, werden nicht automatisch in das neue Konstantenformat konvertiert. Die alten Konstanten arbeiten aber weiterhin fehlerfrei. Es wird jedoch empfohlen, beim Erstellen von neuem Code das neue Format zu verwenden.


 Verwenden integrierter Konstanten als Bit-Masken

Verwenden integrierter Konstanten als Bit-Masken

Zum Auswerten des Arguments Shift oder Button verwenden Sie eine Bit-Maske.

Das Argument Button ist ein Bit-Feld, dessen niederwertige Bits der linken Maustaste (Bit 0), der rechten Maustaste (Bit 1) und der mittleren Maustaste (Bit 2) entsprechen. Diese Bits entsprechen den Werten 1, 2 bzw. 4. Nur eines dieser Bits ist gesetzt und gibt damit an, welche Taste das Ereignis ausgelöst hat.

Die eingebauten Konstanten, die Microsoft Access für das Argument Button bereitstellt, haben die folgenden Werte.

Konstante | Wert
acLeftButton | 1
acRightButton | 2
acMiddleButton | 4

Das Argument Shift ist ein Bit-Feld, dessen niederwertige Bits den Tasten UMSCHALT (Bit 0), STRG (Bit 1) und ALT (Bit 2 ) entsprechen. Diese Bits entsprechen den Werten 1, 2 bzw. 4. Das Argument Shift zeigt den Status dieser Tasten an. Es können einige, alle oder keine dieser Bits gesetzt sein, womit angegeben wird, dass einige, alle oder keine der entsprechenden Tasten gedrückt sind. Ist z.B. sowohl STRG als auch ALT gedrückt, hat das Argument Shift den Wert 6.

Die eingebauten Konstanten, die Microsoft Access für das Argument Shift bereitstellt, haben die nachstehend aufgeführten Werte.

Konstante | Wert
acShiftMask | 1
acCtrlMask | 2
acAltMask | 4

Diese Konstanten erlauben es, auf beliebige Tastenkombinationen zu prüfen, ohne für jede Kombination den zugehörigen Wert des Bit-Felds ermitteln zu müssen. Ein Bit wird gesetzt, wenn die entsprechende Maustaste oder Taste gedrückt wird.


Verzeichnis der Ereignisse und Ereigniseigenschaften

In der folgenden Referenztabelle werden die Ereignisse sowohl in Aufgabentyp-Kategorien gruppiert als auch alphabetisch sortiert aufgeführt.

Gruppierung nach Aufgaben

Datenereignisse | Filterereignisse
Druckereignisse | Fokusereignisse
Fehlerereignisse und zeitabhängige Ereignisse | Mausereignisse
Fensterereignisse | Tastaturereignisse

Alphabetische Liste

Ereignis | Ereigniseigenschaft
Activate (Aktivierung) | OnActivate (BeiAktivierung)
AfterDelConfirm (NachLöschbestätigung) | AfterDelConfirm (NachLöschbestätigung)
AfterInsert (NachEingabe) | AfterInsert (NachEingabe)
AfterUpdate (NachAktualisierung) | AfterUpdate AfterUpdate (NachAktualisierung)
ApplyFilter (AnwendenFilter) | OnApplyFilter (BeiAngewendetemFilter)
BeforeDelConfirm (VorLöschbestätigung) | BeforeDelConfirm (VorLöschbestätigung)
BeforeInsert (VorEingabe) | BeforeInsert (VorEingabe)
BeforeUpdate (VorAktualisierung) | BeforeUpdate (VorAktualisierung)
Change (Änderung) | OnChange (BeiÄnderung)
Click (Klicken) | OnClick (BeimKlicken)
Close (Schließen) | OnClose (BeimSchließen)
Current (Anzeigen) | OnCurrent (BeimAnzeigen)
DblClick (Doppelklicken) | OnDblClick (BeimDoppelklicken)
Deactivate (Deaktivierung) | OnDeactivate (BeiDeaktivierung)
Delete (Löschen) | OnDelete (BeimLöschen)
Dirty Event (Änderung) | OnDirty (BeiÄnderung)
Enter (Hingehen) | OnEnter (BeimHingehen)
Error (Fehler) | OnError (BeiFehler)
Exit (Verlassen) | OnExit (BeimVerlassen)
Filter | OnFilter (BeiFilter)
Format (Formatieren) | OnFormat (BeimFormatieren)
GotFocus (Fokuserhalt) | OnGotFocus (BeiFokuserhalt)
Initialize (Initialisieren) | keine
ItemAdded | keine
ItemRemoved | keine
KeyDown (TasteAb) | OnKeyDown (BeiTasteAb)
KeyPress (Taste) | OnKeyPress (BeiTaste)
KeyUp (TasteAuf) | OnKeyUp (BeiTasteAuf)
Load (Laden) | OnLoad (BeiLaden)
LostFocus (Fokusverlust) | OnLostFocus (BeiFokusverlust)
MouseDown (MaustasteAb) | OnMouseDown (BeiMaustasteAb)
MouseMove (Mausbewegung) | OnMouseMove (BeiMausbewegung)
MouseUp (MaustasteAuf) | OnMouseUp (BeiMaustasteAuf)
NoData (OhneDaten) | OnNoData (BeiOhneDaten)
NotInList (NichtInListe) | OnNotInList (BeiNichtInListe)
Open (Öffnen) | OnOpen (BeimÖffnen)
Page (Seite) | OnPage (BeiSeite)
Print Drucken) | OnPrint (BeimDrucken)
Resize (Größenänderung) | OnResize (BeiGrößenänderung)
Retreat (Rücknahme) | OnRetreat (BeiRücknahme)
Terminate (Beenden) | keine
Timer (Zeitgeber) | OnTimer (BeiZeitgeber)
Unload (Entladen) | OnUnload (BeiEntladen)
Updated (OLEAktualisierung) | OnUpdated (BeiOLEAktualisierung)


Neue Ereignisse

Das folgende Ereignis wurde Visual Basic in Microsoft Access 2000 hinzugefügt.

Dirty


 Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung)

Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung)

  • Das Ereignis Activate tritt ein, wenn ein Formular oder ein Bericht den Fokus erhält und zum aktiven Fenster wird.

  • Das Ereignis Deactivate tritt ein, wenn ein Formular oder ein Bericht den Fokus an ein Tabellen-, Abfrage-, Formular-, Berichts-, Makro- oder Modulfenster oder an das Datenbankfenster abgibt.

Anmerkung Das Activate-Ereignis tritt nicht ein, wenn ein Formular den Fokus von einem Dialogfeld, einem Popupformular oder einem anderen Formular zurück erhält. Das Deactivate-Ereignis tritt nicht ein, wenn ein Formular oder Bericht den Fokus an ein Dialogfeld oder ein Formular, für das für die Eigenschaft PopUp die Einstellung Ja festgelegt ist, oder an ein Fenster in einer anderen Anwendung abgibt.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft OnActivate oder OnDeactivate auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Sie können ein Formular oder einen Bericht auf folgende Arten aktivieren: durch Öffnen des Formulars bzw. Berichts, durch Klicken auf das Formular/den Bericht oder auf ein Steuerelement, das sich in diesem befindet, oder durch Verwenden der Methode SetFocus in Visual Basic (dies ist nur für Formulare möglich).

Das Ereignis Activate kann nur eintreten, wenn ein Formular oder ein Bericht sichtbar ist.

Das Ereignis Activate tritt vor dem Ereignis GotFocus ein. Das Ereignis Deactivate tritt vor dem Ereignis LostFocus ein.

Wenn Sie zwischen zwei geöffneten Formularen wechseln, tritt das Ereignis Deactivate für das Formular ein, das Sie verlassen, und das Ereignis Activate für das Formular, zu dem Sie wechseln. Wenn die Formulare keine sichtbaren aktivierten Steuerelemente enthalten, tritt das Ereignis LostFocus für das erste Formular vor dem Ereignis Deactivate und das Ereignis GotFocus für das zweite Formular nach dem Ereignis Activate ein.

Wenn Sie ein Formular zum ersten Mal öffnen, treten die folgenden Ereignisse in der nachstehend gezeigten Reihenfolge ein:

Open Þ Load Þ Resize Þ Activate Þ Current

Wenn Sie ein Formular schließen, treten die folgenden Ereignisse in der aufgeführten Reihenfolge ein:

Unload Þ Deactivate Þ Close


 Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung)

Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung)

  • Das Ereignis Delete tritt ein, nachdem der Benutzer, z. B. durch Drücken der ENTF-Taste, einen Vorgang ausgelöst hat, der einen Datensatz löscht, jedoch vor dem tatsächlichen Löschen des Datensatzes.

  • Das Ereignis BeforeDelConfirm tritt ein, nachdem der Benutzer einen oder mehrere Datensätze gelöscht hat, jedoch bevor Microsoft Access ein Dialogfeld anzeigt, in dem der Benutzer zur Bestätigung des Löschvorgangs aufgefordert wird.

  • Das Ereignis AfterDelConfirm tritt ein, nachdem der Benutzer den Löschvorgang bestätigt hat und die Datensätze tatsächlich gelöscht sind, oder wenn der Löschvorgang abgebrochen wurde.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Löschen, Vor Löschbestätigung bzw. Nach Löschbestätigung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Wenn ein Datensatz gelöscht ist, wird er in einem temporären Puffer gespeichert. Das Ereignis BeforeDelConfirm tritt nach dem Ereignis Delete auf (oder, wenn Sie mehr als einen Datensatz gelöscht haben, nachdem alle Datensätze gelöscht sind, wobei das Ereignis Delete für jeden Datensatz eintritt), jedoch vor dem Anzeigen des Dialogfelds zur Bestätigung des Löschvorgangs. Wird das Ereignis BeforeDelConfirm unterbunden, werden die entsprechenden Datensätze aus dem Puffer wiederhergestellt, und das Dialogfeld zum Bestätigen des Löschvorgangs wird nicht angezeigt.

Das Ereignis AfterDelConfirm tritt nach dem tatsächlichen Löschen eines oder mehrerer Datensätze oder nach dem Unterbinden eines oder mehrere Löschvorgänge ein. Wird das Ereignis BeforeDelConfirm nicht unterbunden, tritt das Ereignis AfterDelConfirm nach der Anzeige des Dialogfelds zum Bestätigen des Löschvorgangs ein. Das Ereignis AfterDelConfirm tritt auch dann ein, wenn das Ereignis BeforeDelConfirm unterbunden wird. Die Ereignisprozedur für das Ereignis AfterDelConfirm gibt Statusinformationen zum jeweiligen Löschvorgang zurück. Sie können z. B. ein Makro oder eine Ereignisprozedur für das Ereignis AfterDelConfirm verwenden, wenn Sie Summen neu berechnen möchten, die sich durch das Löschen von Datensätzen ändern.

Wenn Sie das Ereignis Delete unterbinden, treten die Ereignisse BeforeDelConfirm und AfterDelConfirm nicht ein, und das Dialogfeld zum Bestätigen des Löschvorgangs wird nicht angezeigt.

Anmerkung Die Ereignisse BeforeDelConfirm und AfterDelConfirm treten nicht ein und das Dialogfeld zum Bestätigen des Löschvorgangs wird nicht angezeigt, wenn Sie das Kontrollkästchen Datensatzänderungen unter Bestätigen auf der Registerkarte Bearbeiten/Suchen des Dialogfelds Optionen deaktivieren. (Sie können dieses Dialogfeld durch Klicken auf den Befehl Optionen im Menü Extras anzeigen.)

Durch Ausführen eines Makros oder einer Ereignisprozedur bei Eintreten des Ereignisses Delete können Sie verhindern, dass ein Datensatz tatsächlich gelöscht wird, oder festlegen, dass er nur unter bestimmten Bedingungen gelöscht wird. Das Ereignis Delete kann auch zur Anzeige eines Dialogfelds verwendet werden, das den Benutzer zur Bestätigung des Löschvorgangs auffordert.

Zum Löschen eines Datensatzes klicken Sie im Menü Bearbeiten auf den Befehl Datensatz löschen. Damit löschen Sie den aktuellen Datensatz (der Datensatz, der durch den Datensatzmarkierer gekennzeichnet ist). Sie können stattdessen auch auf den Datensatzmarkierer oder auf Datensatz markieren im Menü Bearbeiten klicken, um einen Datensatz zu markieren, und ihn anschließend durch Drücken der Taste ENTF löschen. Wenn Sie auf Datensatz löschen, den Datensatzmarkierer des aktuellen Datensatzes oder Datensatz markieren klicken, treten für das Steuerelement, das den Fokus hat, die Ereignisse Exit und LostFocus ein. Wurden in dem Datensatz Daten geändert, treten vor den Ereignissen Exit und LostFocus die Ereignisse BeforeUpdate und AfterUpdate für den Datensatz ein. Wenn Sie auf den Datensatzmarkierer eines anderen Datensatzes klicken, tritt außerdem das Ereignis Current für diesen Datensatz ein.

Nach dem Löschen des Datensatzes erhält der auf den gelöschten Datensatz folgende Datensatz den Fokus, und es tritt für diesen Datensatz zunächst das Ereignis Current ein. Anschließend treten für das erste Steuerelement dieses Datensatzes die Ereignisse Enter und GotFocus ein.

Das Ereignis BeforeDelConfirm tritt direkt ein, bevor Microsoft Access das Dialogfeld zur Bestätigung des Löschvorgangs anzeigt. Sobald die Frage im Dialogfeld beantwortet wurde (d.h. nach dem Bestätigen oder Abbrechen des Löschvorgangs) tritt das Ereignis AfterDelConfirm ein.

Es können ein oder mehrere Datensätze gleichzeitig gelöscht werden. Das Ereignis Delete tritt nach dem Löschen jedes einzelnen Datensatzes ein. Dies erlaubt Ihnen, vor dem eigentlichen Löschen auf die Daten des Datensatzes zuzugreifen und den Löschvorgang für jeden einzelnen Datensatz in einem Makro oder einer Ereignisprozedur für das Ereignis Delete zu bestätigen oder abzubrechen. Wenn Sie mehrere Datensätze löschen, treten das Ereignis Current für den Datensatz, der auf den zuletzt gelöschten folgt, und die Ereignisse Enter und GotFocus für das erste Steuerelement dieses Datensatzes erst dann ein, wenn alle Datensätze gelöscht sind. D.h., es tritt für jeden markierten Datensatz das Ereignis Delete ein, jedoch keine weiteren Ereignisse, bis alle markierten Datensätze gelöscht sind. Ebenso treten die Ereignisse BeforeDelConfirm und AfterDelConfirm erst ein, wenn alle markierten Datensätze gelöscht sind.


 BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe)

BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe)

  • Das Ereignis BeforeInsert tritt ein, wenn der Benutzer das erste Zeichen in einen neuen Datensatz eingibt, jedoch bevor der entsprechende Datensatz tatsächlich erstellt wird.

  • Das Ereignis AfterInsert tritt nach dem Hinfzufügen eines neuen Datensatzes ein.

Anmerkung Diese Ereignisse werden nicht ausgelöst, wenn der Wert eines Steuerelements unter Verwendung eines Makros oder von Visual Basic eingestellt wird.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft BeforeInsert bzw. AfterInsert auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Sie können eine Ereignisprozedur oder ein Makro für das Ereignis AfterInsert verwenden, um für eine Datensatzgruppe eine Abfrage erneut durchzuführen, sobald ein neuer Datensatz hinzugefügt wird.

Die Ereignisse BeforeInsert und AfterInsert ähneln den Ereignissen BeforeUpdate und AfterUpdate. Diese Ereignisse treten in der folgenden Reihenfolge ein:

BeforeInsert Þ BeforeUpdate Þ AfterUpdate Þ AfterInsert.

Die nachstehenden Tabelle zeigt die Interaktion zwischen diesen Ereignissen.

Ereignis | Tritt ein
BeforeInsert | Wenn der Benutzer das erste Zeichen in einen neuen Datensatz eingibt.
BeforeInsert | Wenn der Benutzer den Datensatz aktualisiert.
AfterUpdate | Wenn der Datensatz aktualisiert ist.
AfterInsert | Wenn der aktualisierte Datensatz ein neuer Datensatz ist.

Wenn das erste Zeichen eines neuen Datensatzes in ein Textfeld oder ein Kombinationsfeld eingegeben wird, tritt das Ereignis BeforeInsert vor dem Ereignis Change ein.


 BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung)

BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung)

  • Das Ereignis BeforeUpdate tritt ein, bevor geänderte Daten in einem Steuerelement oder Datensatz aktualisiert werden.

  • Das Ereignis AfterUpdate tritt ein, nachdem geänderte Daten in einem Steuerelement oder Datensatz aktualisiert wurden.

Anmerkungen

  • Das Ändern von Daten in einem Steuerelement mit Visual Basic oder einem Makro, das die Aktion SetzenWert enthält, löst diese Ereignisse nicht aus. Wenn Sie danach jedoch zu einem anderen Datensatz gehen oder den Datensatz speichern, treten die Ereignisse BeforeUpdate und AfterUpdate des Formulars ein.

  • Die Ereignisse BeforeUpdate und AfterUpdate gelten nur für Steuerelemente eines Formulars, nicht für Steuerelemente eines Berichts.

  • Diese Ereignisse gelten nicht für Optionsfelder, Kontrollkästchen oder Umschaltflächen einer Optionsgruppe, sondern nur für die Optionsgruppe selbst.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft BeforeUpdate oder AfterUpdate auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Die Ereignisse BeforeUpdate und AfterUpdate werden beim Aktualisieren eines Steuerelements oder Datensatzes ausgelöst. Innerhalb eines Datensatzes werden geänderte Daten in jedem Steuerelement aktualisiert, wenn das Steuerelement den Fokus abgibt oder wenn der Benutzer die EINGABETASTE oder TAB drückt. Wenn der Fokus den Datensatz verlässt oder der Benutzer im Menü Datensätze auf den Befehl Datensatz speichern klickt, wird der gesamte Datensatz aktualisiert. Gleichzeitig werden die Daten in der Datenbank gespeichert.

Wenn Sie in ein Steuerelement eines Formulars neue oder geänderte Daten eingeben und dann zu einem anderen Datensatz wechseln oder den Datensatz mit dem Befehl Datensatz speichern aus dem Menü Datensätze speichern, treten zunächst die Ereignisse BeforeUpdate und AfterUpdate des Steuerelements und unmittelbar danach die Ereignisse BeforeUpdate und AfterUpdate des Formulars ein. Wenn Sie zu einem anderen Datensatz gewechselt haben, treten für das Steuerelement die Ereignisse Exit und LostFocus ein, gefolgt vom Ereignis Current für den Datensatz, zu dem Sie gelangt sind, und den Ereignissen Enter und GotFocus für das erste Steuerelement dieses Datensatzes. Sie können die Makros oder Ereignisprozeduren für die Ereignisse BeforeUpdate oder AfterUpdate ohne die Makros oder Ereignisprozeduren für die Ereignisse Exit oder LostFocus ausführen, indem Sie den Datensatz mit dem Befehl Datensatz speichern aus dem Menü Datensätze speichern.

Die Makros und Ereignisprozeduren für die Ereignisse BeforeUpdate und AfterUpdate werden nur ausgeführt, wenn Sie in einem Steuerelement Daten ändern. Diese Ereignisse treten nicht ein, wenn sich ein Wert in einem berechneten Steuerelement ändert. Die Makros und Ereignisprozeduren für die Ereignisse BeforeUpdate und AfterUpdate eines Formulars werden nur ausgeführt, wenn Sie die Daten in einem oder mehreren Steuerelementen des Datensatzes ändern.

Bei Formularen können Sie das Ereignis BeforeUpdate verwenden, um das Aktualisieren eines Datensatzes zu unterbinden, bevor Sie zu einem anderen Datensatz wechseln.

Bei gebundenen Steuerelementen wird die Einstellung der Eigenschaft BeforeUpdate erst dann auf den aktualisierten Wert gesetzt, nachdem das Ereignis AfterUpdate eingetreten ist. Selbst wenn der Benutzer in das Steuerelement einen neuen Wert eingibt, wird die Einstellung der Eigenschaft BeforeUpdate erst geändert, wenn die Daten gespeichert sind (der Datensatz aktualisiert ist). Wenn Sie die Aktualisierung unterbinden, wird der im Steuerelement vorhandene Wert durch den Wert der Eigenschaft BeforeUpdate ersetzt.

Sie verwenden das Ereignis BeforeUpdate häufig, um Daten zu überprüfen, insbesondere bei komplexen Gültigkeitsüberprüfungen wie z. B.:

  • Gültigkeitsüberprüfungen, die Bedingungen für mehrere Werte eines Formulars einbeziehen.

  • Gültigkeitsüberprüfungen, die verschiedene Fehlermeldungen für verschiedene eingegebene Daten anzeigen.

  • Gültigkeitsüberprüfungen, die durch den Benutzer außer Kraft gesetzt werden können.

  • Gültigkeitsüberprüfungen, die Verweise auf Steuerelemente anderer Formulare bzw. auf benutzerdefinierte Funktionen enthalten.

Anmerkung Wenn Sie einfache oder komplexere Gültigkeitsüberprüfungen durchführen möchten, wie z. B. das Erzwingen eines Wertes in einem Feld oder die Überprüfung mehrerer Steuerelemente eines Formulars, können Sie für Steuerelemente die Eigenschaft Gültigkeitsregel und für Felder und Datensätze in Tabellen die Eigenschaften Gültigkeitsregel und Eingabe erforderlich verwenden.


 ApplyFilter-Ereignis (AnwendenFilter)

ApplyFilter-Ereignis (AnwendenFilter)

Das ApplyFilter-Ereignis kann in einem Microsoft Access-Projekt (.adp) oder einer Access-Datenbank (.mdb) eintreten.

In einer Access-Datenbank tritt ein ApplyFilter-Ereignis ein, nachdem Sie einen der folgenden Schritte ausgeführt haben:

  • Klicken Sie in der Formularansicht im Menü Datensätze auf Filter anwenden, klicken Sie im Dialogfeld für die Filterdefinition im Menü Filter auf Filter anwenden oder in der Symbolleiste auf Filter anwenden. Filter-Objekt Daraufhin wird der zuletzt erstellte Filter zugewiesen (der entweder als formularbasierter Filter oder im Dialogfeld Spezialfilter/-sortierung erstellt wurde).

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter und klicken Sie auf Auswahlbasierter Filter, oder klicken Sie in der Symbolleiste auf Auswahlbasierter Filter [image] . Daraufhin wird ein Filter zugewiesen, der auf dem Eintrag basiert, der momentan im Formular ausgewählt ist.

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter und klicken Sie auf Auswahlausschließender Filter. Daraufhin wird ein Filter zugewiesen, der die aktuelle Markierung im Formular ausschließt.

  • Klicken Sie in der Formularansicht im Menü Datensätze auf Filter/Sortierung entfernen, oder klicken Sie in der Symbolleiste auf Filter entfernen. Filter-Objekt Dadurch werden alle Filter (oder Sortierungen), die dem Formular aktuell zugewiesen sind, entfernt.

  • Klicken Sie im Kontextmenü auf Auswahlbasierter Filter, Auswahlausschließender Filter oder Filter/Sortierung entfernen, oder geben Sie im Feld Filter nach einen Wert oder Ausdruck ein, wenn ein gebundenes Steuerelement den Fokus hat.

  • Schließen Sie das Dialogfeld Spezialfilter/-sortierung oder das Dialogfeld Formularbasierter Filter.

  • Klicken Sie im Menü Filter auf Spezialfilter/-sortierung, während das Fenster Formularbasierter Filter geöffnet ist, oder klicken Sie im Menü Filter auf Formularbasierter Filter, während das Fenster Spezialfilter/-sortierung geöffnet ist. Dadurch wird veranlasst, dass die beiden Ereignisse ApplyFilter und Filter eintreten: ApplyFilter tritt ein, sobald das offene Filterdefinitionsfenster geschlossen ist, und das Ereignis Filter tritt ein, sobald das andere Filterdefinitionsfenster geöffnet ist.

In einem Access-Projekt tritt ein ApplyFilter-Ereignis ein, nachdem Sie einen der folgenden Schritte ausgeführt haben:

  • Klicken Sie in der Formularansicht im Menü Datensätze auf Filter anwenden, klicken Sie im Fenster für die Filterdefinition im Menü Filter auf Filter anwenden oder in der Symbolleiste auf Filter anwenden Filter-Objekt. Daraufhin wird der zuletzt (als formularbasierter Filter) erstellte Filter zugewiesen.

  • Klicken Sie in der Formularansicht im Menü Datensätze auf Serverfilter anwenden, klicken Sie im Fenster für die Filterdefinition im Menü Filter auf Serverfilter anwenden oder in der Symbolleiste auf Serverfilter anwenden [image] . Daraufhin wird der zuletzt (als formularbasierter Serverfilter) erstellte Filter zugewiesen.

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie auf Auswahlbasierter Filter, oder klicken Sie in der Symbolleiste auf Auswahlbasierter Filter [image]. Daraufhin wird ein Filter zugewiesen, der auf dem Eintrag basiert, der aktuell im Formular ausgewählt ist.

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie auf Auswahlausschließender Filter. Daraufhin wird ein Filter zugewiesen, der die aktuelle Auswahl im Formular ausschließt.
  • Klicken Sie im Kontextmenü auf Auswahlbasierter Filter bzw. Auswahlausschließender Filter, oder geben Sie im Feld Filter nach einen Wert oder Ausdruck ein, wenn ein gebundenes Steuerelement den Fokus hat.

Anmerkung

Soll ein Makro oder eine Ereignisprozedur ausgeführt werden, wenn dieses Ereignis eintritt, stellen Sie die Eigenschaft OnApplyFilter auf den Namen des Makros bzw. auf [Ereignisprozedur] ein.

Mit dem Ereignis ApplyFilter können Sie folgende Schritte einleiten:

  • Prüfen, ob der zugewiesene Filter korrekt ist. Angenommen, Sie möchten sich vergewissern, dass jeder Filter, der dem Formular Bestellungen zugewiesen wird, Kriterien enthält, die das Feld Bestelldatum einschränken. Sie können dazu den Wert der Filter- bzw. ServerFilter-Eigenschaft des Formulars daraufhin prüfen, ob diese Kriterien Bestandteil des Ausdrucks sind, der die WHERE-Klausel bildet.

  • Ändern der Darstellungsweise des Formulars, bevor ein Filter zugewiesen wird. Dies bietet sich z.B. an, wenn Sie einige Felder deaktivieren oder ausblenden möchten, die für die von diesem Filter angezeigten Datensätze überflüssig sind.

  • Zurücknehmen oder Ändern von Vorgängen, die ausgelöst wurden, nachdem das Ereignis Filter eingetreten war. So können Sie z.B. bestimmte Steuerelemente des Formulars deaktivieren oder ausblenden, wenn Sie nicht möchten, dass diese in die Filterkriterien einbezogen werden, wenn ein Benutzer den Filter erstellt. Sie können diese Steuerelemente wieder aktivieren oder anzeigen, nachdem der Filter zugewiesen wurde.

Die Vorgänge eines AnwendenFilter-Makros oder einer ApplyFilter-Ereignisprozedur werden entweder ausgelöst, bevor der Filter zugewiesen oder gelöscht wird oder nachdem eines der Fenster Spezialfilter/-sortierung, Formularbasierter Filter oder Formularbasierter Serverfilter geschlossen wurde, aber bevor das Formular erneut angezeigt wird. Die Kriterien, die Sie in den neu erstellten Filter eingegeben haben, stehen dem AnwendenFilter-Makro oder der ApplyFilter-Ereignisprozedur als Einstellung der Filter- bzw. ServerFilter-Eigenschaft zur Verfügung.

Anmerkung Das Ereignis ApplyFilter tritt nicht ein, wenn der Benutzer einen der folgenden Schritte ausführt:

  • Zuweisen oder Entfernen eines Filters aus einem Makro heraus mit einer der Aktionen ZuweisenFilter, ÖffnenFormular oder AnzeigenAlleDatensätze oder aus Visual Basic mit den entsprechenden Methoden des Objekts DoCmd.

  • Verwenden der Aktion Schließen bzw. der Close-Methode des DoCmd-Objekts, um eines der Fenster Spezialfilter/-sortierung, Formularbasierter Filter oder Formularbasierter Serverfilter zu schließen.

  • Einstellen der Filter- bzw. ServerFilter-Eigenschaft oder der FilterOn- bzw. ServerFilterByForm-Eigenschaft aus einem Makro oder aus Visual Basic (obwohl Sie diese Eigenschaften in einem AnwendenFilter-Makro oder einer ApplyFilter-Ereignisprozedur einstellen können).


 Change-Ereignis (Änderung)

Change-Ereignis (Änderung)

Das Change-Ereignis tritt ein, wenn sich der Inhalt eines Textfeldes oder des Textteils eines Kombinationsfeldes ändert. Es tritt auch ein, wenn Sie in einem Registersteuerelement zu einer anderen Seite wechseln. Beispiele für dieses Ereignis sind Zeichen, die unmittelbar in das Textfeld oder das Kombinationsfeld eingegeben werden, oder das Ändern der Einstellung der Eigenschaft Text des Steuerelements unter Verwendung eines Makros oder mit Visual Basic.

Anmerkungen

  • Das Festlegen des Wertes eines Steuerelements unter Verwendung eines Makros oder mit Visual Basic löst dieses Ereignis für das Steuerelement nicht aus. Sie müssen die Daten direkt in das Steuerelement eingeben oder die Eigenschaft Text des Steuerelements einstellen.

  • Dieses Ereignis hat nur für die Steuerelemente eines Formulars Gültigkeit, nicht aber für die Steuerelemente eines Berichts.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Änderung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Wenn Sie bei Eintreten des Ereignisses Change ein Makro oder eine Ereignisprozedur ausführen, können Sie die Datenanzeige in mehreren Steuerelementen koordinieren. Sie können darüber hinaus auch Daten oder eine Formel in einem Steuerelement und die Ergebnisse in einem anderen Steuerelement anzeigen.

Das Ereignis Change tritt nicht ein, wenn sich ein Wert in einem berechneten Steuerelement ändert oder wenn Sie einen Eintrag aus dem Listenteil eines Kombinationsfelds auswählen.

Anmerkung Das Ereignis Change kann ein sich wiederholendes Ereignis verursachen. Dies ist der Fall, wenn ein Makro oder eine Ereignisprozedur, das/die als Reaktion auf ein Ereignis Change eines Steuerelements ausgeführt wird, den Inhalt des Steuerelements ändert, z. B. durch Ändern einer Eigenschafteneinstellung, die den Wert des Steuerelements festlegt, wie etwa die Eigenschaft Text eines Textfelds. Sich wiederholende Ereignisse können Sie folgendermaßen verhindern:

  • Vermeiden Sie es möglichst, einem Steuerelement ein Makro oder eine Ereignisprozedur für das Ereignis Change zuzuweisen, das bzw. die den Inhalt des Steuerelements ändert.

  • Erstellen Sie nicht zwei oder mehr Steuerelemente, deren Ereignisse Change sich gegenseitig beeinflussen, wie z. B. zwei Textfelder, die sich wechselseitig aktualisieren.

Das Ändern der Daten in einem Textfeld oder einem Kombinationsfeld unter Verwendung der Tastatur löst zusätzlich zum Eintreten von Ereignissen wie etwa Change das Eintreten von Tastaturereignissen aus. Wenn Sie z. B. zu einem neuen Datensatz gehen und in ein Textfeld des Datensatzes ein ANSI-Zeichen eingeben, treten die folgenden Ereignisse in der aufgeführten Reihenfolge ein:

KeyDown Þ KeyPress Þ BeforeInsert Þ Change Þ KeyUp

Die Ereignisse BeforeUpdate und AfterUpdate für das Textfeld oder das Kombinationsfeld treten nach dem Eingeben der neuen Daten oder Ändern der Daten im Textfeld oder Kombinationsfeld (oder nach dem Klicken auf Datensatz speichern im Menü Datensätze) und damit nach allen Change-Ereignissen des Steuerelements ein.

Das NotInList-Ereignis tritt für Kombinationsfelder, deren Eigenschaft Nur Listeneinträge auf Ja eingestellt ist, nach dem Eingeben eines Wertes, der nicht in der Liste ist, und dem Versuch ein, zu einem anderen Steuerelement zu wechseln oder den Datensatz zu speichern. Es tritt nach allen Change-Ereignissen für das Kombinationsfeld ein. In diesem Fall treten die BeforeUpdate- und AfterUpdate-Ereignisse für das Kombinationsfeld nicht ein, da Microsoft Access keinen Wert akzeptiert, der nicht Bestandteil der Liste ist.


 Click-Ereignis (Klicken)

Click-Ereignis (Klicken)

Das Ereignis Click tritt ein, wenn der Benutzer eine Maustaste drückt und wieder loslässt, während sich der Mauszeiger auf einem Objekt befindet.

Anmerkungen

  • Das Ereignis Click gilt nur für Formulare, Formularbereiche und Steuerelemente eines Formulars, nicht aber für Steuerelemente eines Berichts.

  • Dieses Ereignis gilt nicht für Kontrollkästchen, Optionsfelder oder Umschaltflächen einer Optionsgruppe, sondern nur für die Optionsgruppe selbst.

  • Dieses Ereignis gilt nicht für Bezeichnungsfelder, die einem anderen Steuerelement zugeordnet sind, wie z. B. das Bezeichnungsfeld eines Textfelds, sondern nur für "freistehende" Bezeichnungsfelder. Das Klicken auf ein zugeordnetes Bezeichnungsfeld wirkt sich genauso aus wie das Klicken auf das zugeordnete Steuerelement. Es treten die normalen Ereignisse für das Steuerelement ein, aber kein Ereignis für das zugeordnete Bezeichnungsfeld.

  • Dieses Ereignis betrifft ein Steuerelement, das einen hyperlink enthält.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Klicken auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Bei einem Formular tritt dieses Ereignis ein, wenn der Benutzer auf eine leere Fläche oder auf einen Datensatzmarkierer des Formulars klickt.

Bei einem Steuerelement tritt dieses Ereignis bei folgenden Benutzeraktionen ein:

  • Klicken mit der linken Maustaste auf ein Steuerelement. Dieses Ereignis wird nicht ausgelöst, wenn mit der rechten oder mittleren Maustaste auf das Steuerelement geklickt wird.

  • Klicken mit der linken Maustaste auf ein Steuerelement, das Hyperlinkdaten enthält. Dieses Ereignis wird nicht ausgelöst, wenn mit der rechten oder mittleren Maustaste auf das Steuerelement geklickt wird. Bewegt der Benutzer den Mauszeiger über ein Steuerelement mit Hyperlinkdaten, wird der Mauszeiger als "Handsymbol" dargestellt. Ein anschließendes Klicken mit der Maustaste aktiviert den Hyperlink und löst das Ereignis Click aus.

  • Auswählen eines Eintrags in einem Kombinationsfeld oder Listenfeld, indem entweder die PFEILTASTEN und dann die EINGABETASTE gedrückt werden oder mit der Maustaste geklickt wird.

  • Drücken der LEERTASTE, während sich der Fokus auf einer Befehlsschaltfläche, einem Kontrollkästchen, einem Optionsfeld oder einer Umschaltfläche befindet.

  • Drücken der EINGABETASTE auf einem Formular mit einer Befehlsschaltfläche, deren Eigenschaft Standard auf Ja eingestellt ist.

  • Drücken von ESC auf einem Formular mit einer Befehlsschaltfläche, deren Eigenschaft Abbrechen auf Ja eingestellt ist.

  • Drücken der Zugriffstaste eines Steuerelements. Wenn z. B. die Eigenschaft Beschriftung einer Befehlsschaltfläche auf &Start eingestellt ist, wird das Ereignis durch Drücken von ALT+S ausgelöst.

In der Regel ordnen Sie eine Ereignisprozedur oder ein Makro für das Ereignis Click einer Befehlsschaltfläche zu, um Befehle und befehlsähnliche Aktionen auszuführen. Bei den anderen möglichen Steuerelementen können Sie mit diesem Ereignis auf die weiter oben beschriebenen Situationen reagieren.

Bei Befehlsschaltflächen führt Microsoft Access das durch die Eigenschaft Beim Klicken angegebene Makro bzw. die angegebene Ereignisprozedur aus, wenn der Benutzer die Befehlsschaltfläche durch Drücken der EINGABETASTE oder einer Zugriffstaste wählt. Das Makro bzw. die Ereignisprozedur wird nur einmal ausgeführt. Soll das Makro oder die Ereignisprozedur mehrmals ausgeführt werden, während die Befehlsschaltfläche gedrückt wird, stellen Sie deren Eigenschaft Makro wiederholen auf Ja ein. Bei anderen Arten von Steuerelementen klicken Sie mit der Maus auf das Steuerelement, um das Ereignis Click auszulösen.

Für eine Befehlsschaltfläche tritt das Ereignis Click ein, wenn Sie die Befehlsschaltfläche wählen. Wenn der Fokus beim Wählen noch nicht auf die Befehlsschaltfläche gesetzt ist, treten vor dem Ereignis Click zunächst die Ereignisse Enter und GotFocus für die Befehlsschaltfläche ein.

Durch Doppelklicken auf ein Steuerelement treten die Ereignisse DblClick und Click ein. Bei Befehlsschaltflächen löst das Doppelklicken die folgenden Ereignisse in der angegebenen Reihenfolge aus:

MouseDown Þ MouseUp Þ Click Þ DblClick Þ Click

Sie können in einem Makro für das Ereignis DblClick die Aktion AbbrechenEreignis verwenden, um das zweite Click-Ereignis zu unterbinden. Weitere Informationen finden Sie im Hilfethema zum Ereignis DblClick.

Das Ereignis Click tritt für eine Optionsgruppe ein, nachdem Sie den Wert eines der Steuerelemente der Optionsgruppe durch Klicken auf das Steuerelement geändert haben. Wenn Sie z. B. auf eine Umschaltfläche, ein Optionsfeld oder ein Kontrollkästchen einer Optionsgruppe klicken, tritt das Ereignis Click für die Optionsgruppe nach den Ereignissen BeforeUpdate und AfterUpdate für die Optionsgruppe ein.

Tipp Verwenden Sie die Ereignisse MouseDown und MouseUp, um zwischen der linken, rechten und mittleren Maustaste zu unterscheiden.


 Open-, Close-Ereignisse (Öffnen, Schließen)

Open-, Close-Ereignisse (Öffnen, Schließen)

  • Bei Formularen tritt das Ereignis Open beim Öffnen eines Formulars ein, jedoch bevor der erste Datensatz angezeigt wird. Bei Berichten tritt dieses Ereignis ein, bevor der Bericht in der Seitenansicht angezeigt oder gedruckt wird.

  • Das Ereignis Close tritt ein, wenn ein Formular oder Bericht geschlossen wurde und nicht mehr angezeigt wird.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Öffnen oder Beim Schließen auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Wenn Sie beim Eintreten des Ereignisses Open für ein Formular ein Makro oder eine Ereignisprozedur ausführen, können Sie ein anderes Fenster schließen oder den Fokus auf ein bestimmtes Steuerelement eines Formulars setzen. Sie können mit einem Makro oder einer Ereignisprozedur auch Informationen abfragen, die vor dem Öffnen oder Drucken des Formulars oder Berichts benötigt werden. Ein Makro oder eine Ereignisprozedur für das Ereignis Open kann z. B. ein benutzerdefiniertes Dialogfeld öffnen, in das der Benutzer die Kriterien für die im Formular anzuzeigenden Datensätze oder den im Bericht enthaltenen Datumsbereich eingibt.

Das Ereignis Open tritt nicht ein, wenn Sie ein bereits geöffnetes Formular aktivieren, z. B. wenn Sie von einem anderen Fenster in Microsoft Access zu diesem Formular wechseln oder in einem Makro die Aktion ÖffnenFormular verwenden, um das geöffnete Formular in den Vordergrund zu bringen. Das Ereignis Activate tritt in derartigen Situationen jedoch ein.

Beim Öffnen eines Formulars führt Microsoft Access zunächst die dem Formular zugrunde liegende Abfrage aus und dann das Makro oder die Ereignisprozedur für das Ereignis Open. Beim Öffnen eines Berichts führt Microsoft Access jedoch das Makro oder die Ereignisprozedur für das Ereignis Open aus, bevor die dem Bericht zugrunde liegende Abfrage ausgeführt wird. Somit kann der Benutzer Kriterien für den Bericht angeben, bevor der Bericht geöffnet wird, z. B. in einem benutzerdefinierten Dialogfeld, das beim Eintreten des Ereignisses Open angezeigt wird.

Wenn in Ihrer Anwendung mehrere Formulare gleichzeitig geladen werden können, verwenden Sie die Ereignisse Activate und Deactivate an Stelle von Open, um beim Bewegen des Fokus zu einem anderen Formular die benutzerdefinierten Symbolleisten ein- oder auszublenden.

Das Ereignis Open tritt vor dem Ereignis Load ein. Letzteres wird ausgelöst, wenn ein Formular geöffnet und die zugehörigen Datensätze angezeigt werden.

Wenn Sie ein Formular zum ersten Mal öffnen, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

Open Þ Load Þ Resize Þ Activate Þ Current

Das Ereignis Close tritt nach dem Ereignis Unload ein. Letzteres wird ausgelöst, nachdem das Formular geschlossen wurde, aber bevor es vom Bildschirm entfernt wird.

Wenn Sie ein Formular schließen, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

Unload Þ Deactivate Þ Close

Wenn das Ereignis Close eintritt, können Sie ein anderes Fenster öffnen oder den Namen des Benutzers anfordern, um einen Protokolleintrag vorzunehmen.

Bei der Verwendung der Ereignisse Open und Load für Makros oder Ereignisprozeduren gibt es einen wesentlichen Unterschied: die Ausführung des Ereignisses Open kann unterbunden werden, was beim Ereignis Load nicht der Fall ist. Wenn Sie z. B. in einer Ereignisprozedur für das Ereignis Open eines Formulars einen Datensatz des Formulars dynamisch erstellen, können Sie das Öffnen des Formulars unterbinden, wenn keine Datensätze vorhanden sind. Die Ausführung des Ereignisses Unload kann ebenfalls unterbunden werden, die Ausführung des Ereignisses Close jedoch nicht.


 Current-Ereignis (Anzeigen)

Current-Ereignis (Anzeigen)

Das Ereignis Current tritt ein, wenn der Fokus auf einen Datensatz gesetzt wird, der somit zum aktuellen Datensatz wird. Es tritt außerdem ein, wenn das Formular aktualisiert bzw. erneut abgefragt wird.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft OnCurrent auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Dieses Ereignis tritt ein, wenn entweder ein Formular geöffnet oder der Fokus von einem Datensatz auf einen anderen gesetzt wird. Microsoft Access führt das Makro oder die Ereignisprozedur für das Ereignis Current aus, bevor der erste oder nächste Datensatz angezeigt wird.

Wenn Sie beim Eintreten des Ereignisses Current für ein Formular ein Makro oder eine Ereignisprozedur ausführen, können Sie eine Meldung anzeigen oder Datensätze in einem anderen Formular synchronisieren, das mit dem aktuellen Datensatz zusammenhängt. Wenn z. B. ein Kundendatensatz zum aktuellen Datensatz wird, können Sie die vorherige Bestellung des Kunden anzeigen. Wenn ein Lieferantendatensatz zum aktuellen Datensatz wird, können Sie die bei diesem Lieferanten erhältlichen Artikel in einem Lieferantenformular anzeigen. Sie können auch anhand des aktuellen Datensatzes Berechnungen durchführen oder das Formular entsprechend den Daten im aktuellen Datensatz ändern.

Wenn das Makro oder die Ereignisprozedur die Aktion GeheZuSteuerelement oder GeheZuDatensatz bzw. die entsprechende Methode des Objekts DoCmd als Reaktion auf das Ereignis Open ausführt, tritt das Ereignis Current ein.

Das Ereignis Current tritt auch ein, wenn Sie ein Formular aktualisieren oder die dem Formular zugrunde liegende Tabelle oder Abfrage erneut abfragen. Dies ist z. B. der Fall, wenn Sie den Befehl Filter/Sortierung entfernen aus dem Menü Datensätze wählen, oder wenn Sie in einem Makro die Aktion AktualisierenDaten bzw. in Visual Basic-Code die Methode Requery verwenden.

Wenn Sie ein Formular zum ersten Mal öffnen, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

Open Þ Load Þ Resize Þ Activate Þ Current


 DblClick-Ereignis (Doppelklicken)

DblClick-Ereignis (Doppelklicken)

Das Ereignis DblClick tritt ein, wenn der Benutzer innerhalb der Systemzeitspanne für das Doppelklicken zweimal hintereinander die linke Maustaste drückt und wieder loslässt, während sich der Mauszeiger auf einem Objekt befindet.

Für ein Formular tritt das Ereignis DblClick ein, wenn der Benutzer auf eine leere Fläche oder auf einen Datensatzmarkierer des Formulars doppelklickt. Für ein Steuerelement tritt dieses Ereignis ein, wenn der Benutzer in der Formularansicht auf das Steuerelement oder dessen Bezeichnungsfeld doppelklickt. Das Ereignis DblClick tritt ein, wenn der Benutzer auf das Formular oder Steuerelement doppelklickt, jedoch bevor das Ergebnis des Doppelklickens angezeigt wird (z. B. bevor Microsoft Access das Wort auswählt, auf dem sich die Einfügemarke in einem Textfeld befindet).

Anmerkungen

  • Das Ereignis DblClick gilt nur für Formulare, Formularbereiche und Steuerelemente eines Formulars, nicht aber für Steuerelemente eines Berichts.

  • Dieses Ereignis gilt nicht für Kontrollkästchen, Optionsfelder oder Umschaltflächen einer Optionsgruppe, sondern nur für die Optionsgruppe selbst.

  • Dieses Ereignis gilt nicht für Bezeichnungsfelder, die einem anderen Steuerelement zugeordnet sind, wie z. B. das Bezeichnungsfeld eines Textfelds, sondern nur für "freistehende" Bezeichnungsfelder. Das Doppelklicken auf ein zugeordnetes Bezeichnungsfeld wirkt sich genauso aus wie das Doppelklicken auf das zugeordnete Steuerelement. Es treten die normalen Ereignisse für das Steuerelement ein, aber keine Ereignisse für das zugeordnete Bezeichnungsfeld.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Doppelklicken auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Bei Steuerelementen hängt das Ergebnis des Doppelklickens vom Steuerelement ab. So wird z. B. durch das Doppelklicken auf ein Wort in einem Textfeld das gesamte Wort ausgewählt. Beim Doppelklicken auf ein Steuerelement, das ein OLE-Objekt enthält, wird die Anwendung, mit der das Objekt erstellt wurde, zur Bearbeitung des Objekts gestartet.

Wenn das Ereignis DblClick nicht in der für das System festgelegten Zeitspanne für das Doppelklicken eintritt, erkennt das Formular, der Formularbereich oder das Steuerelement das zweifache Eintreten des Ereignisses Click an Stelle des Eintretens des Ereignisses DblClick. Die Zeitspanne für das Doppelklicken hängt davon ab, auf welchen Wert die Doppelklickgeschwindigkeit in der Systemsteuerung von Microsoft Windows (Option Maus, Registerkarte Tasten) eingestellt ist.

Durch Ausführen eines Makros oder einer Ereignisprozedur beim Eintreten des Ereignisses DblClick können Sie ein Fenster oder ein Dokument öffnen, wenn Sie auf ein Symbol doppelklicken.

Beim Doppelklicken auf ein Steuerelement treten die Ereignisse Click und DblClick ein. Wenn der Fokus beim Doppelklicken noch nicht auf das Steuerelement gesetzt ist, treten vor dem Ereignis Click und DblClick zunächst die Ereignisse Enter und GotFocus für das Steuerelement ein.

Bei Objekten, die auf Mausereignisse reagieren, treten die Ereignisse in der folgenden Reihenfolge ein:

MouseDown Þ MouseUp Þ Click Þ DblClick

Wenn Sie auf eine Befehlsschaltfläche doppelklicken, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

MouseDown Þ MouseUp Þ Click Þ DblClick Þ MouseUp Þ Click

Es kann sein, dass das zweite Klicken keine Auswirkungen hat. Dies ist z. B. der Fall, wenn das Makro zum Ereignis Click ein gebundenes Dialogfeld als Reaktion auf das erste Eintreten des Ereignisses Click öffnet. Fügen Sie die Aktion AbbrechenEreignis in das Makro für das Ereignis DblClick ein, oder verwenden Sie in der Ereignisprozedur für das Ereignis DblClick das Argument Cancel, um das Ausführen des zweiten Makros oder der zweiten Ereignisprozedur für das Ereignis Click zu verhindern. Im Allgemeinen sollte ein Doppelklicken auf eine Befehlsschaltfläche unterbunden werden.

Wenn Sie auf ein anderes Steuerelement als eine Befehlsschaltfläche doppelklicken, tritt das zweite Ereignis Click nicht ein.


 Dirty-Ereignis (Geändert)

Dirty-Ereignis (Geändert)

Das Dirty-Ereignis tritt ein, wenn sich der Inhalt eines Formulars oder der Textbereich in einem Kombinationsfeld ändert. Es tritt auch ein, wenn Sie in einem Registersteuerelement zu einer anderen Seite wechseln. Beispiele für dieses Ereignis sind Zeichen, die unmittelbar in das Textfeld oder das Kombinationsfeld eingegeben werden, oder das Ändern der Einstellung der Text-Eigenschaft des Steuerelements unter Verwendung eines Makros oder mit Visual Basic.

Anmerkungen

  • Das Ändern eines Datensatzes in einem Formular unter Verwendung eines Makros oder mit Visual Basic löst dieses Ereignis nicht aus. Sie müssen die Daten direkt in den Datensatz eingeben oder die Text-Eigenschaft des Steuerelements festlegen.

  • Dieses Ereignis betrifft nur gebundene Formulare, nicht ein ungebundenes Formular oder einen Bericht.

Anmerkungen

Wenn bei Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die OnDirty-Eigenschaft auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Wenn Sie bei Eintreten des Dirty-Ereignisses ein Makro oder eine Ereignisprozedur ausführen, können Sie ermitteln, ob sich der Datensatz ändern lässt. Außerdem können Sie eine Meldung anzeigen und nach der Berechtigung zum Bearbeiten fragen.

Werden Daten in einem Datensatz unter Verwendung der Tastatur geändert, löst dies zusätzlich zum Eintreten von Ereignissen wie etwa Dirty das Eintreten von Tastaturereignissen aus. Wenn Sie z. B. zu einem neuen Datensatz wechseln und in ein Textfeld des Datensatzes ein ANSI-Zeichen eingeben, treten die folgenden Ereignisse in der aufgeführten Reihenfolge ein:

KeyDown Þ KeyPress Þ BeforeInsert Þ Dirty Þ KeyUp

Das BeforeUpdate-Ereignis und dasAfterUpdate-Ereignis für einen Datensatz treten ein, nachdem Sie die neuen Daten eingegeben oder im Datensatz geändert haben und zu einem anderen Datensatz gewechselt sind (oder im Menü Datensätze auf Datensatz speichern geklickt haben) - und damit nach dem Dirty-Ereignis des Datensatzes.


 Enter-, Exit-Ereignisse (Hingehen, Verlassen)

Enter-, Exit-Ereignisse (Hingehen, Verlassen)

  • Das Ereignis Enter tritt ein, bevor ein Steuerelement den Fokus von einem anderen Steuerelement desselben Formulars erhält.

  • Das Ereignis Exit tritt ein, unmittelbar bevor ein Steuerelement den Fokus an ein anderes Steuerelement desselben Formulars abgibt.

Anmerkungen

  • Die Ereignisse Enter und Exit gelten nur für Steuerelemente eines Formulars, nicht für Steuerelemente eines Berichts.

  • Diese Ereignisse gelten nicht für Kontrollkästchen, Optionsfelder oder Umschaltflächen einer Optionsgruppe, sondern nur für die Optionsgruppe selbst.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Hingehen oder Beim Verlassen auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Da das Ereignis Enter eintritt, bevor der Fokus auf ein bestimmtes Steuerelement bewegt wird, können Sie ein Makro oder eine Ereignisprozedur für das Ereignis Enter verwenden, um Anweisungen anzuzeigen. Sie können z. B. ein Makro oder eine Ereignisprozedur verwenden, um ein kleines Formular oder ein Meldungsfeld anzuzeigen, das die Verwendung des Steuerelements erläutert oder den Datentyp angibt, den das Steuerelement normalerweise enthält.

Das Ereignis Enter tritt vor dem Ereignis GotFocus ein. Das Ereignis Exit tritt vor dem Ereignis LostFocus ein.

Im Gegensatz zu GotFocus und LostFocus treten die Ereignisse Enter und Exit nicht ein, wenn ein Formular den Fokus erhält oder abgibt. Angenommen, Sie aktivieren ein Kontrollkästchen und klicken dann auf einen Bericht. In diesem Fall treten die Ereignisse GotFocus und Enter beim Aktivieren des Kontrollkästchens ein. Wenn Sie auf den Bericht klicken, tritt nur das Ereignis LostFocus ein. Das Ereignis Exit tritt nicht ein, da der Fokus in ein anderes Fenster verlagert wird. Wenn Sie erneut auf das Kontrollkästchen des Formulars klicken, um das Formular in den Vordergrund zu holen, tritt das Ereignis GotFocus, aber nicht das Ereignis Enter ein, da sich der Fokus bereits auf dem Steuerelement befand, als das Formular zuletzt aktiv war. Das Ereignis Exit tritt nur ein, wenn Sie auf dem Formular auf ein anderes Steuerelement klicken.

Wenn Sie den Fokus auf einem anderen Formular auf ein Steuerelement verlagern, das den Fokus auf diesem Formular nicht hatte, treten die Ereignisse Exit und LostFocus für das Steuerelement, das den Fokus auf diesem Formular hat, vor den Ereignissen Enter und GotFocus für das Steuerelement ein, zu dem Sie sich bewegt haben.

Wenn Sie mit der Maus den Fokus von einem Steuerelement des Hauptformulars auf ein Steuerelement eines Unterformulars setzen, treten die folgenden Ereignisse ein:

Exit (für das Steuerelement des Hauptformulars)

ß

LostFocus (für das Steuerelement des Hauptformulars)

ß

Enter (für das Unterformular-Steuerelement)

ß

Exit (für das Steuerelement des Unterformulars, das den Fokus hatte)

ß

LostFocus (für das Steuerelement des Unterformulars, das den Fokus hatte)

ß

Enter (für das Steuerelement des Unterformulars, auf das der Fokus gesetzt wird)

ß

GotFocus (für das Steuerelement des Unterformulars, auf das der Fokus gesetzt wird)

Wenn der Fokus auf dem Unterformular bereits auf das Steuerelement gesetzt war, zu dem Sie sich bewegen, treten die Ereignisse Enter und GotFocus nicht ein, wohl aber das Ereignis Enter für das Steuerelement im Unterformular. Wenn Sie den Fokus von einem Steuerelement eines Unterformulars auf ein Steuerelement des Hauptformulars bewegen, treten die Ereignisse Exit und LostFocus für das Steuerelement des Unterformulars nicht ein. Es treten nur das Ereignis Exit für das Steuerelement des Unterformulars und die Ereignisse Enter und GotFocus für das Steuerelement des Hauptformulars ein.

Anmerkung Sie verwenden meistens die Maus oder eine Taste, z. B. TAB, um den Fokus auf ein anderes Steuerelement zu bewegen. Dies führt dazu, dass zusätzlich zu den weiter oben erwähnten Ereignissen Mausereignisse oder Tastaturereignisse eintreten.


 Error-Ereignis (Fehler)

Error-Ereignis (Fehler)

Das Ereignis Error tritt ein, wenn in Microsoft Access ein Laufzeitfehler erzeugt wird, während ein Formular oder Bericht den Fokus hat. Dies gilt auch für Fehler der Microsoft Jet-Datenbank-Engine, nicht jedoch für Laufzeitfehler in Visual Basic.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Fehler auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Durch Ausführen einer Ereignisprozedur oder eines Makros bei Eintreten des Ereignisses Error können Sie eine Fehlermeldung von Microsoft Access abfangen und stattdessen eine benutzerdefinierte Meldung anzeigen, die für Ihre Anwendung geeigneter ist.


 Filter-Ereignis

Filter-Ereignis

Das Filter-Ereignis kann in einem Microsoft Access-Projekt (.adp) oder einer Microsoft Access-Datenbank (.mdb) eintreten.

In einer Access-Datenbank tritt ein Filter-Ereignis ein, nachdem Sie einen der folgenden Schritte ausgeführt haben:

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie auf Formularbasierter Filter, oder klicken Sie in der Symbolleiste auf Formularbasierter Filter [image] . Daraufhin wird das Fenster Formularbasierter Filter geöffnet, in dem Sie basierend auf den Feldern des Formulars einen Filter erstellen können.

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie auf Spezialfilter/-sortierung. Daraufhin wird das Fenster Spezialfilter/-sortierung geöffnet, in dem Sie komplexe Filter für das Formular erstellen können.

  • Klicken Sie im Menü Filter auf Spezialfilter/-sortierung, während das Fenster Formularbasierter Filter geöffnet ist, oder klicken Sie im Menü Filter auf Formularbasierter Filter, während das Fenster Spezialfilter/-sortierung geöffnet ist. Dadurch wird veranlasst, dass die beiden Ereignisse ApplyFilter und Filter eintreten: ApplyFilter tritt ein, sobald das offene Filterdefinitionsfenster geschlossen ist, und das Ereignis Filter tritt ein, sobald das andere Filterdefinitionsfenster geöffnet ist.

In einem Access-Projekt tritt ein Filter-Ereignis ein, nachdem Sie einen der folgenden Schritte ausgeführt haben:

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie auf Formularbasierter Filter, oder klicken Sie in der Symbolleiste auf Formularbasierter Filter [image]. Daraufhin wird das Fenster Formularbasierter Filter geöffnet, in dem Sie basierend auf den Feldern des Formulars einen Filter erstellen können.

  • Zeigen Sie in der Formularansicht im Menü Datensätze auf Filter, und klicken Sie in der Symbolleiste auf Formularbasierter Serverfilter [image] . Daraufhin wird das Fenster Formularbasierter Serverfilter geöffnet, in dem Sie auf Basis der Felder des Formulars schnell einen Serverfilter erstellen können.

  • Das Fenster Spezialfilter/-sortierung steht in einem Access-Projekt nicht zur Verfügung.

Anmerkung

Soll ein Makro oder eine Ereignisprozedur ausgeführt werden, wenn dieses Ereignis eintritt, stellen Sie die Eigenschaft OnFilter auf den Namen des Makros bzw. auf [Ereignisprozedur] ein.

Mit dem Ereignis Filter können Sie folgende Schritte einleiten:

  • Entfernen des Filters, der jeweils für das Formular verwendet wird. Legen Sie dazu die Filter- bzw. ServerFilter-Eigenschaft des Formulars in dem Filter-Makro oder in der Filter-Ereignisprozedur auf eine leere Zeichenfolge (" ") fest. Dies bietet sich immer dann an, wenn Sie sicherstellen möchten, dass für den neuen Filter keine alten Kriterien übernommen werden. Immer dann, wenn Sie das Merkmal Auswahlbasierter Filter verwenden, wird das von Ihnen angegebene Kriterium (der Text, der auf dem jeweiligen Formular markiert ist), zur WHERE-Klausel der Filter- bzw. ServerFilter-Eigenschaft hinzugefügt. Dieses Kriterium wird dann sowohl im Fenster Formularbasierter Filter als auch im Fenster Spezialfilter/-sortierung bzw. Formularbasierter Serverfilter angezeigt. Mit Hilfe des Filter-Ereignisses können Sie dieses alte Kriterium entfernen.

  • Eingeben von Standardeinstellungen für den neuen Filter. Legen Sie dazu die Filter- bzw. ServerFilter-Eigenschaft fest, damit die entsprechenden Kriterien berücksichtigt werden. Sie könnten z. B. festlegen, dass alle Filter, die dem Formular Artikel zugewiesen sind, nur aktuelle Artikel anzeigen (Artikel, bei denen auf dem Formular Artikel das Steuerelement Auslaufartikel nicht aktiviert ist).

  • Verwenden Ihres eigenen Filterdefinitionsfensters statt eines der Filterdefinitionsfenster von Microsoft Access. Sobald das Filter-Ereignis eingetreten ist, können Sie Ihr eigenes Formular öffnen. Die in dieses Formular eingegebenen Werte können Sie dann verwenden, um die Filter- bzw. ServerFilter-Eigenschaft einzustellen und das ursprüngliche Formular zu filtern. Sobald der Benutzer Ihr Filterdefinitionsformular geschlossen hat, legen Sie die FilterOn- bzw. ServerFilterByForm-Eigenschaft des ursprünglichen Formulars auf True (-1) fest, damit der Filter zugewiesen wird. Wird das Filter-Ereignis abgebrochen, wird das Microsoft Access-Filterdefinitionsfenster nicht geöffnet.

  • Für bestimmte Steuerelemente verhindern, dass sie auf dem Formular angezeigt oder im Fenster Formularbasierter Filter bzw. Formularbasierter Serverfilter verwendet werden. Wenn Sie ein Steuerelement in dem Filter-Makro oder in der Filter-Ereignisprozedur ausblenden oder deaktivieren, ist dieses Steuerelement im Fenster Formularbasierter Filter bzw. Formularbasierter Serverfilter ausgeblendet bzw. deaktiviert und kann nicht für das Festlegen von Filterkriterien verwendet werden. Sie können dann das ApplyFilter-Ereignis verwenden, um das Steuerelement wieder anzuzeigen oder zu aktivieren, nachdem der Filter zugewiesen oder aus dem Formular entfernt wurde.


 FirstPage-, LastPage-, NextPage-, PrevPage-Ereignisse

FirstPage-, LastPage-, NextPage-, PrevPage-Ereignisse

Das FirstPage-, LastPage-, NextPage- oder PrevPage-Ereignis tritt ein, wenn der Benutzer auf die Navigationsschaltflächen des Snapshot Viewer-Steuerelements klickt oder das Kontextmenü des Steuerelements verwendet.

Anmerkungen

  • Diese Ereignisse verwenden keine Argumente.

  • Diese Ereignisse werden nur ausgelöst, wenn die Navigation über die Navigationsschaltflächen oder das Kontextmenü erfolgt. Sie werden nicht ausgelöst, wenn auf Seiten programmgesteuert navigiert wird.


 Format-Ereignis (Formatieren)

Format-Ereignis (Formatieren)

Das Ereignis Format tritt ein, wenn Microsoft Access die Daten ermittelt, die in einen Bereich eines Berichts gehören, jedoch bevor der Bereich für die Vorschau oder für das Drucken formatiert wird.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Formatierung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Das Ereignis Format tritt für jeden Bereich eines Berichts ein. Dadurch können Sie komplexe fortlaufende Berechnungen mit Daten aus allen Bereichen durchführen, einschließlich nicht gedruckter Bereiche.

Bei Detailbereichen in Berichten tritt das Ereignis Format für jeden Datensatz im Bereich ein, unmittelbar bevor Microsoft Access die Daten im Datensatz formatiert. Ein Makro oder eine Ereignisprozedur für das Ereignis Format kann auf die Daten im aktuellen Datensatz zugreifen.

Bei Gruppenköpfen in Berichten tritt das Ereignis Format für jede neue Gruppe ein. Ein Makro oder eine Ereignisprozedur für das Ereignis Format kann auf Daten im Gruppenkopf und im ersten Datensatz des Detailbereichs zugreifen. Bei Gruppenfüßen in Berichten tritt das Ereignis Format für jede neue Gruppe ein. Ein Makro oder eine Ereignisprozedur für das Ereignis Format kann auf die Daten im Gruppenfuß und im letzten Datensatz des Detailbereichs zugreifen.

Wenn Sie beim Eintreten des Ereignisses Format ein Makro oder eine Ereignisprozedur ausführen, können Sie mit Daten aus dem aktuellen Datensatz Änderungen am Seitenlayout des Berichts vornehmen. Sie können z. B. in einem Umsatzbericht einen Glückwunsch neben den monatlichen Umsätzen eines Verkaufsberaters ein- oder ausblenden. Dies ist von der Höhe der Umsätze abhängig. Nachdem das Steuerelement ein- oder ausgeblendet ist, formatiert Microsoft Access den Bereich unter Verwendung der Einstellungen der Formatierungseigenschaften wie Vergrößerbar Verkleinerbar, Keine Duplikate, Zusammenhalten und Sichtbar.

Bei Änderungen, die sich nicht auf das Seitenlayout auswirken, oder bei Ereignisprozeduren und Makros, die erst nach dem Formatieren der Daten einer Seite ausgeführt werden sollen (z. B. ein Makro zum Drucken von Seitensummen), verwenden Sie für den Berichtsbereich das Ereignis Print.

Manchmal muss Microsoft Access auf Grund mehrerer Formatierungsdurchläufe zu vorhergehenden Bereichen eines Berichts zurückkehren. In diesem Fall tritt das Ereignis Retreat ein, wenn zum jeweils vorhergehenden Bereich des Berichts gewechselt wird, und das Ereignis Format tritt für jeden Bereich mehrmals ein. Sie können ein Makro oder eine Ereignisprozedur beim Eintreten des Ereignisses Retreat ausführen, um alle Änderungen rückgängig zu machen, die beim Eintreten des Ereignisses Format für den Bereich vorgenommen wurden. Dies bietet sich an, wenn das Makro oder die Ereignisprozedur für das Ereignis Format Operationen ausführt, die für jeden Bereich nur einmal durchgeführt werden sollen (z. B. das Berechnen der Seitensummen oder das Ändern der Bereichsgröße).


 GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust)

GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust)

  • Das Ereignis GotFocus tritt ein, wenn ein Formular oder ein Steuerelement den Fokus erhält.

  • Das Ereignis LostFocus tritt ein, wenn ein Formular oder ein Steuerelement den Fokus abgibt.

Anmerkung Die Ereignisse GotFocus und LostFocus haben nur für Formulare und Steuerelemente eines Formulars Gültigkeit, nicht aber für Steuerelemente eines Berichts.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Fokuserhalt bzw. Bei Fokusverlust auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Diese Ereignisse treten ein, wenn der Fokus als Reaktion auf eine Benutzeraktion verschoben wird. Dies ist z. B. der Fall, wenn ein Objekt durch Drücken von TAB oder durch Klicken auf das Objekt aktiviert wird, wenn Sie in Visual Basic die Methode SetFocus verwenden oder in einem Makro eine der Aktionen AuswählenObjekt, GeheZuDatensatz, GeheZuSteuerelement oder GeheZuSeite benutzen.

Ein Steuerelement kann nur dann den Fokus erhalten, wenn dessen Eigenschaften Sichtbar und Aktiviert auf Ja eingestellt sind. Ein Formular kann den Fokus nur erhalten, wenn es keine Steuerelemente enthält oder wenn alle sichtbaren Steuerelemente deaktiviert sind. Wenn ein Formular ein sichtbares aktiviertes Steuerelement enthält, tritt das Ereignis GotFocus für das Formular nicht ein.

Sie können festlegen, was passieren soll, wenn ein Formular oder ein Steuerelement den Fokus erhält. Dazu führen Sie bei Eintreten des Ereignisses GotFocus ein Makro oder eine Ereignisprozedur aus. Wenn Sie z. B. jedem Steuerelement eines Formulars eine Ereignisprozedur für GotFocus zuordnen, können Sie einen Benutzer durch Ihre gesamte Anwendung führen, indem Sie in einem Textfeld kurze Anleitungen oder Meldungen anzeigen. Darüber hinaus können Sie auf dem Bildschirm Stichwörter bereitstellen, indem Sie Steuerelemente aktivieren, deaktivieren oder anzeigen, die von dem Steuerelement abhängen, das den Fokus hat.

Anmerkung Zum Anpassen der Reihenfolge, in der der Fokus auf einem Formular beim Drücken von TAB von einem Steuerelement an das nächste abgegeben wird, legen Sie die Reihenfolge der Steuerelemente fest oder definieren Zugriffstasten für die Steuerelemente.

Das Ereignis GotFocus tritt im Gegensatz zum Ereignis Enter jedesmal ein, wenn ein Steuerelement den Fokus erhält. Angenommen, der Benutzer klickt auf ein Kontrollkästchen eines Formulars, anschließend auf einen Bericht und zum Schluss erneut auf das Kontrollkästchen des Formulars, um dieses in den Vordergrund zu holen. Das Ereignis GotFocus tritt beide Male ein, wenn das Kontrollkästchen den Fokus erhält. Das Ereignis Enter tritt dagegen nur nach dem ersten Klicken des Benutzers auf das Kontrollkästchen ein. Das Ereignis GotFocus tritt nach dem Ereignis Enter ein.

Das Ereignis LostFocus tritt im Gegensatz zum Ereignis Exit jedesmal ein, wenn ein Steuerelement den Fokus abgibt. Das Ereignis Exit tritt nur dann ein, wenn ein Steuerelement den Fokus an ein anderes Steuerelement desselben Formulars abgibt. Das Ereignis LostFocus tritt nach dem Ereignis Exit ein.

Wenn Sie den Fokus von einem Formular auf ein Steuerelement eines anderen Formulars setzen, das auf diesem Formular nicht den Fokus hat, treten die Ereignisse Exit und LostFocus für das Steuerelement, das auf dem ersten Formular den Fokus hat, vor den Ereignissen Enter und GotFocus des Steuerelements ein, das auf dem zweiten Formular den Fokus erhält.

Wenn Sie zum Verschieben des Fokus von einem Steuerelement eines Hauptformulars auf ein Steuerelement eines Unterformulars dieses Formulars die Maus verwenden, treten die folgenden Ereignisse ein:

Exit (für das Steuerelement des Hauptformulars)

ß

LostFocus (für das Steuerelement des Hauptformulars)

ß

Enter (für das Unterformular-Steuerelement)

ß

Exit (für das Steuerelement des Unterformulars, das den Fokus hatte)

ß

Exit (für das Steuerelement des Unterformulars, das den Fokus hatte)

ß

Enter (für das Steuerelement des Unterformulars, das den Fokus erhalten hat)

ß

GotFocus (für das Steuerelement des Unterformulars, das den Fokus erhalten hat)

Wenn das Steuerelement des Unterformulars, zu dem Sie wechseln, vorher den Fokus hatte, tritt für dieses Steuerelement weder das Ereignis Enter noch das Ereignis GotFocus ein, es tritt jedoch das Ereignis Enter für das Unterformular ein. Wenn Sie den Fokus von einem Steuerelement des Unterformulars zu einem Steuerelement des Hauptformulars verschieben, treten für das Steuerelement des Unterformulars nicht die Ereignisse Exit und LostFocus ein, es treten lediglich das Ereignis Exit für das Unterformular-Steuerelement und die Ereignisse Enter und GotFocus für das Steuerelement des Hauptformulars ein.

Anmerkung In der Regel wird zum Verschieben des Fokus zu einem anderen Steuerelement die Maustaste oder eine Taste, wie z. B. TAB, verwendet. Dies löst Mausereignisse oder Tastaturereignisse aus, die zusätzlich zu den oben beschriebenen Ereignissen eintreten.

Wenn Sie zwischen zwei geöffneten Formularen wechseln, tritt für das erste Formular das Ereignis Deactivate und für das zweite Formular das Ereignis Activate ein. Enthalten die Formulare keine sichtbaren aktivierten Steuerelemente, tritt für das erste Formular vor dem Ereignis Deactivate das Ereignis LostFocus und für das zweite Formular nach dem Ereignis Activate das Ereignis GotFocus ein.


 Initialize-Ereignis (Initialisieren)

Initialize-Ereignis (Initialisieren)

Das Ereignis Initialize für ein Klassenmodul tritt ein, wenn Sie eine Instanz des Klassenmoduls erstellen.

Anmerkung Wenn Sie Code ausführen möchten, der beim Eintreten des Ereignisses Initialize ausgeführt werden soll, schreiben Sie den Code innerhalb der Ereignisprozedur Initialize in einem Klassenmodul.

Anmerkung

Das Ereignis Initialize tritt in folgenden Fällen ein:

  • Beim direkten Erstellen einer neuen Instanz einer Klasse mit Hilfe des Schlüsselworts New zusammen mit der Anweisung Set.

  • Beim Dimensionieren einer Objektvariablen unter Verwendung des Schlüsselwortes New und beim indirekten Erstellen einer Klasseninstanz durch Einstellen oder Zurückgeben einer Eigenschaft oder Anwenden einer im Klassenmodul definierten Methode.


 ItemAdded-Ereignis

ItemAdded-Ereignis

Das Ereignis ItemAdded tritt ein, wenn von Visual Basic aus ein Verweis zum Projekt hinzugefügt wird.

Anmerkungen

  • Das Ereignis ItemAdded betrifft die Auflistung References. Es ist im Gegensatz zu den meisten anderen Ereignissen keinem Steuerelement, Formular oder Bericht zugeordnet. Um eine Prozedurdefinition für die Ereignisprozedur ItemAdded zu erstellen, müssen Sie daher eine spezielle Syntax verwenden.

  • Das Ereignis ItemAdded kann, wenn es eintritt, nur eine Ereignisprozedur ausführen, aber kein Makro.

Anmerkung

Dieses Ereignis tritt ein, wenn Sie einen Verweis vom Code aus hinzufügen. Es tritt nicht ein, wenn Sie einen Verweis vom Dialogfeld Verweise aus hinzufügen. Dieses Dialogfeld wird angezeigt, indem Sie im Menü Extras auf Verweise klicken, wenn das Modulfenster das aktive Fenster ist


 ItemRemoved-Ereignis

ItemRemoved-Ereignis

Das Ereignis ItemRemoved tritt ein, wenn ein Verweis aus einem Projekt entfernt wird.

Anmerkungen

  • Das Ereignis ItemRemoved betrifft die Auflistung References. Es ist im Gegensatz zu den meisten anderen Ereignissen keinem Steuerelement, Formular oder Bericht zugeordnet. Um eine Prozedurdefinition für die Ereignisprozedur ItemRemoved zu erstellen, verwenden Sie daher eine spezielle Syntax.

  • Das Ereignis ItemRemoved kann, wenn es eintritt, nur eine Ereignisprozedur ausführen, aber kein Makro.

Anmerkung

Dieses Ereignis tritt ein, wenn Sie einen Verweis vom Code aus entfernen. Es tritt nicht ein, wenn Sie einen Verweis vom Dialogfeld Verweise aus entfernen. Dieses Dialogfeld wird angezeigt, indem Sie im Menü Extras auf Verweise klicken, wenn das Modulfenster das aktive Fenster ist


 KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf)

KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf)

  • Das KeyDown-Ereignis tritt ein, wenn der Benutzer eine Taste drückt, während ein Formular oder Steuerelement den Fokus hat. Dieses Ereignis tritt auch ein, wenn Sie mit der Aktion Tastaturbefehle in einem Makro bzw. mit der Anweisung SendKeys in Visual Basic Tastenanschläge an ein Formular oder Steuerelement senden.

  • Das KeyUp-Ereignis tritt ein, wenn der Benutzer eine Taste loslässt, während das Formular oder das Steuerelement den Fokus hat. Dieses Ereignis tritt auch ein, wenn Sie mit der Aktion Tastaturbefehle in einem Makro bzw. mit der Anweisung SendKeys in Visual Basic Tastenanschläge an ein Formular oder Steuerelement senden.

Anmerkung Das KeyDown- und das KeyUp-Ereignis haben nur für Formulare sowie Steuerelemente eines Formulars Gültigkeit, nicht aber für die Steuerelemente eines Berichts.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Taste Ab bzw. Bei Taste Auf auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Für beide Ereignisse gilt, dass alle Tastenanschläge von dem Objekt empfangen werden, das den Fokus hat. Ein Formular kann nur dann den Fokus haben, wenn es keine Steuerelemente enthält oder alle seine sichtbaren Steuerelemente deaktiviert sind.

Ein Formular empfängt auch dann alle Tastaturereignisse, d. h. auch die, die für Steuerelemente eintreten, wenn Sie die Eigenschaft Tastenvorschau des Formulars auf Ja eingestellt haben. Mit dieser Eigenschafteneinstellung treten alle Tastaturereignisse zuerst für das Formular und dann für das Steuerelement ein, das den Fokus hat. Sie können, unabhängig davon, welches Steuerelement den Fokus hat, auf bestimmte auf einem Formular gedrückte Tasten reagieren. Sie können z. B. festlegen, dass mit der Tastenkombination STRG+X auf einem Formular immer dieselbe Aktion ausgeführt werden soll.

Wenn Sie eine Taste drücken und festhalten, treten das KeyDown- und das KeyPress-Ereignis wiederholt im Wechsel ein (KeyDown, KeyPress, KeyDown, KeyPress usw.), bis Sie die Taste wieder loslassen. Beim Loslassen tritt das KeyUp-Ereignis ein.

Das KeyDown- und das KeyUp-Ereignis treten zwar beim Drücken fast aller Tasten ein, Sie werden jedoch in der Regel verwendet, um die folgenden Tasten bzw. Tastenkombinationen zu erkennen und zwischen diesen zu unterscheiden:

  • Tasten des erweiterten Zeichensatzes, wie z. B. Funktionstasten.

  • Navigationstasten, wie z. B. POS1, ENDE, BILD-AUF, BILD-AB, NACH-OBEN, NACH-UNTEN, NACH-RECHTS, NACH-LINKS und TAB.

  • Tastenkombinationen und Standardumschalttasten (UMSCHALTTASTE, STRG und ALT).

  • Die Zehnertastatur und die Zahlentasten der Tastatur.

Das KeyDown- und das KeyUp-Ereignis treten nicht ein, wenn Sie die folgenden Tasten drücken:

  • Die EINGABETASTE, wenn das Formular eine Befehlsschaltfläche enthält, deren Eigenschaft Standard auf Ja eingestellt ist.

  • Die Taste ESC, wenn das Formular eine Befehlsschaltfläche enthält, deren Eigenschaft Abbrechen auf Ja eingestellt ist.

Tipp Mit dem KeyPress-Ereignis können Sie feststellen, welchem ANSI-Zeichen die gedrückte Taste entspricht.

Das KeyDown- und das KeyUp-Ereignis treten ein, wenn Sie eine ANSI-Taste drücken oder senden. Das KeyUp-Ereignis tritt nach jedem Ereignis für ein Steuerelement ein, das durch das Drücken oder Senden einer Taste ausgelöst wurde. Wenn ein Tastenanschlag bewirkt, dass der Fokus von einem Steuerelement an ein anderes abgegeben wird, tritt für das erste Steuerelement das KeyDown-Ereignis ein, während für das zweite Steuerelement das KeyPress- und das KeyUp-Ereignis eintreten.

Weitere Informationen finden Sie unter Reihenfolge von Ereignissen bei Tastenanschlägen und Mausklicks.

Wenn durch das Drücken und Senden einer Taste ein gebundenes Dialogfeld angezeigt wird, treten das KeyDown- und das KeyPress-Ereignis ein, nicht aber das KeyUp-Ereignis.


 KeyPress-Ereignis (Taste)

KeyPress-Ereignis (Taste)

Das Ereignis KeyPress tritt ein, wenn der Benutzer eine Taste oder Tastenkombination drückt und loslässt, die einem ANSI-Code entspricht, während ein Formular oder ein Steuerelement den Fokus hat. Dieses Ereignis tritt auch ein, wenn Sie mit einer Aktion Tastaturbefehle in einem Makro bzw. mit der Anweisung SendKeys in Visual Basic einen ANSI-Tastenanschlag an ein Formular oder ein Steuerelement senden.

Anmerkung Das Ereignis KeyPress hat nur für Formulare und Steuerelemente eines Formulars Gültigkeit, nicht aber für die Steuerelemente eines Berichts.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Taste auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Das Objekt, das den Fokus hat, empfängt alle Tastenanschläge. Ein Formular kann den Fokus nur dann haben, wenn es keine Steuerelemente enthält oder alle seine sichtbaren Steuerelemente deaktiviert sind.

Ein Formular empfängt auch dann alle Tastaturereignisse, d. h. auch die, die für Steuerelemente eintreten, wenn Sie die Eigenschaft Tastenvorschau des Formulars auf Ja eingestellt haben. Mit dieser Eigenschafteneinstellung treten alle Tastaturereignisse zuerst für das Formular und dann für das Steuerelement ein, das den Fokus hat. Sie können unabhängig davon, welches Steuerelement den Fokus hat, auf bestimmte auf dem Formular gedrückte Tasten reagieren. Sie können z. B. festlegen, dass mit der Tastenkombination STRG+X auf einem Formular immer dieselbe Aktion ausgeführt werden soll.

Wenn Sie eine ANSI-Taste drücken und festhalten, treten die Ereignisse KeyDown und KeyPress wiederholt im Wechsel (KeyDown, KeyPress, KeyDown, KeyPress usw.) ein. Sobald Sie die Taste loslassen, tritt das Ereignis KeyUp ein.

Die folgenden Tasten können das Ereignis KeyPress auslösen: jedes druckbare Zeichen der Tastatur, die STRG-TASTE kombiniert mit einem Zeichen des Standardalphabets oder mit einem Sonderzeichen, sowie die EINGABETASTE und die RÜCKTASTE. Mit Ereignisprozeduren für die Ereignisse KeyDown und KeyUp können Sie auf alle Tastenanschläge reagieren, die von dem Ereignis KeyPress nicht erkannt werden, wie z. B. Funktionstasten, Navigationstasten und beliebige Kombinationen dieser Tasten mit den Umschalttasten der Tastatur (ALT, UMSCHALT oder STRG). Im Gegensatz zu den Ereignissen KeyDown und KeyUp gibt das Ereignis KeyPress nicht den Status der Tastatur an, sondern stattdessen das ANSI-Zeichen, das der gedrückten Taste oder Tastenkombination entspricht.

KeyPress interpretiert die groß- und klein geschriebene Version jedes Zeichens als eigenständige Tastencodes, d. h. als zwei getrennte Zeichen.

Anmerkung Die RÜCKTASTE gehört zum ANSI-Zeichensatz, die ENTF-TASTE dagegen nicht. Wenn Sie in einem Steuerelement ein Zeichen unter Verwendung der RÜCKTASTE löschen, tritt das Ereignis KeyPress ein, wenn Sie die ENTF-TASTE verwenden jedoch nicht.

Die Ereignisse KeyDown und KeyPress treten ein, wenn Sie ein ANSI-Zeichen drücken oder senden. Das Ereignis KeyUp tritt nach jedem Ereignis für ein Steuerelement ein, das durch das Drücken oder Senden einer Taste ausgelöst wurde. Wenn ein Tastenanschlag bewirkt, dass der Fokus von einem Steuerelement an ein anderes abgegeben wird, tritt für das erste Steuerelement das Ereignis KeyDown ein, während für das zweite Steuerelement die Ereignisse KeyPress und KeyUp eintreten.

Wenn Sie z. B. zu einem neuen Datensatz gehen und in das erste Steuerelement des Datensatzes ein Zeichen eingeben, treten die folgenden Ereignisse ein:

Current (für den neuen Datensatz)

ß

Enter (für das erste Steuerelement des neuen Datensatzes)

ß

GotFocus (für das Steuerelement)

ß

KeyDown (für das Steuerelement)

ß

KeyPress (für das Steuerelement)

ß

BeforeInsert (für den neuen Datensatz im Formular)

ß

Change (für das Steuerelement, wenn es ein Textfeld oder Kombinationsfeld ist)

ß

KeyUp (für das Steuerelement)

Weitere Informationen finden Sie unter Reihenfolge von Ereignissen bei Tastenanschlägen und Mausklicks.


 Load-, Unload-Ereignisse (Laden, Entladen)

Load-, Unload-Ereignisse (Laden, Entladen)

  • Das Ereignis Load tritt ein, wenn ein Formular geöffnet und dessen Datensätze angezeigt werden.

  • Das Ereignis Unload tritt ein, nachdem ein Formular geschlossen wurde, aber bevor es vom Bildschirm gelöscht wird. Beim erneuten Laden des Formulars zeigt Microsoft Access das Formular wieder an und initialisiert den Inhalt aller darin enthaltenen Steuerelemente.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Laden bzw. Beim Entladen auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Das Ereignis Load wird durch die folgenden Benutzeraktionen ausgelöst:

  • Starten einer Anwendung.

  • Öffnen eines Formulars durch Klicken auf Öffnen im Datenbankfenster.

  • Ausführen der Aktion ÖffnenFormular in einem Makro.

Das Ereignis Unload wird durch die folgenden Benutzeraktionen ausgelöst:

  • Klicken auf die Schaltfläche Schließen in einem Formularfenster oder Klicken auf Schließen im Menü Datei oder im Systemmenü eines Formulars.

  • Ausführen der Aktion Close in einem Makro.

  • Beenden einer Anwendung durch Klicken mit der rechten Maustaste auf die Schaltfläche der Anwendung in der Taskleiste und anschließendem Klicken auf Schließen.

  • Beenden von Windows während der Ausführung einer Anwendung.

Durch Ausführen eines Makros oder einer Ereignisprozedur beim Eintreten des Ereignisses Load für ein Formular können Sie Voreinstellungen für Steuerelemente festlegen oder berechnete Daten anzeigen, die auf Daten in den Datensätzen des Formular basieren.

Sie können mit einem Makro oder einer Ereignisprozedur, das/die während des Eintretens des Ereignisses Unload ausgeführt wird, bestätigen, dass das Formular entladen werden soll, oder Aktionen festlegen, die beim Entladen des Formulars ausgeführt werden sollen. Sie können darüber hinaus ein weiteres Formular öffnen oder ein Dialogfeld anzeigen, das nach dem Benutzernamen fragt, um einen Protokolleintrag zu erstellen, der angibt, wer das Formular verwendet hat.

Wenn Sie ein Formular zum ersten Mal öffnen, treten die folgenden Ereignisse in der nachstehend gezeigten Reihenfolge ein:

Open Þ Load Þ Resize Þ Activate Þ Current

Wenn Sie herausfinden möchten, ob sich für Ihr Makro oder Ihre Ereignisprozedur eher das Ereignis Open oder das Ereignis Load eignet, berücksichtigen Sie bei Ihrer Entscheidung, dass das Ereignis Open im Gegensatz zum Ereignis Load unterbunden werden kann. Wenn Sie z. B. in einer Ereignisprozedur für das Ereignis Open eine Datenherkunft für ein Formular dynamisch erstellen, können Sie das Öffnen des Formulars unterbinden, wenn es keine Datensätze gibt, die angezeigt werden können.

Beim Schließen eines Formulars treten die folgenden Ereignisse in der nachstehend gezeigten Reihenfolge ein:

Unload Þ Deactivate Þ Close

Das Ereignis Unload tritt vor dem Ereignis Close ein. Im Gegensatz zum Ereignis Unload kann das Ereignis Close nicht unterbunden werden.

Anmerkung Wenn Sie Makros oder Ereignisprozeduren für Ereignisse erstellen, die zum Ereignis Load in Beziehung stehen, wie z. B. Activate und GotFocus, müssen Sie sicherstellen, dass diese sich nicht gegenseitig behindern (stellen Sie z .B. sicher, dass Sie in einem Makro oder einer Ereignisprozedur keinen Vorgang auslösen, der in einem anderen Makro oder einer anderen Ereignisprozedur abgebrochen wird) und dass diese keine sich wiederholenden Ereignisse auslösen.


 MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf)

MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf)

  • Das Ereignis MouseDown tritt ein, wenn der Benutzer eine Maustaste drückt.

  • Das Ereignis MouseUp tritt ein, wenn der Benutzer eine Maustaste loslässt.

Anmerkungen

  • Die Ereignisse MouseDown und MouseUp haben nur für Formulare, Formularbereiche und Steuerelemente eines Formulars Gültigkeit, nicht jedoch für Steuerelemente eines Berichts.

  • Diese Ereignisse haben keine Gültigkeit für ein einem anderen Steuerelement zugeordnetes Bezeichnungsfeld, wie z. B. ein Bezeichnungsfeld für ein Textfeld. Sie gelten lediglich für "freistehende" Bezeichnungsfelder. Das Drücken und Loslassen einer Maustaste in einem zugeordneten Bezeichnungsfeld hat dieselbe Wirkung wie das Drücken und Loslassen der Taste im zugeordneten Steuerelement. Es treten nur die für das Steuerelement üblichen Ereignisse, keine zusätzlichen Ereignisse für das zugeordnete Steuerelement ein.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Maustaste Ab bzw. Bei Maustaste Auf auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Mit dem Ereignis MouseDown oder MouseUp können Sie festlegen, was passiert, wenn eine bestimmte Maustaste gedrückt oder losgelassen wird. Die Ereignisse MouseDown und MouseUp erlauben im Gegensatz zu den Ereignissen Click und DblClick das Unterscheiden zwischen der linken, der rechten und der mittleren Maustaste. Außerdem können Sie Code für Maus-Tastatur-Kombinationen schreiben, in denen die Tasten UMSCHALT, STRG und ALT verwendet werden.

Zum Auslösen des Ereignisses MouseDown oder MouseUp für ein Formular drücken Sie die Maustaste auf einer leeren Stelle oder auf dem Datensatzmarkierer des Formulars. Zum Auslösen des Ereignisses MouseDown oder MouseUp für einen Formularbereich markieren Sie den Bereich und drücken dann die Maustaste auf einer leeren Stelle des Formularbereichs.

Die folgenden Aussagen gelten sowohl für das Ereignis MouseDown als auch für das Ereignis MouseUp:

  • Wird eine Maustaste gedrückt, während sich der Mauszeiger auf einem Formular oder Steuerelement befindet, empfängt dieses Objekt alle Mausereignisse bis einschließlich des letzten MouseUp-Ereignisses.

  • Wenn nacheinander mehrere Maustasten gedrückt werden, empfängt das Objekt, an das das Mausereignis gesendet wird, das nach dem ersten Drücken eintritt, so lange alle Mausereignisse, bis alle Tasten losgelassen wurden.

Wenn Sie auf ein Ereignis reagieren möchten, das durch Bewegen der Maus ausgelöst wird, müssen Sie das Ereignis MouseMove verwenden.


 MouseMove-Ereignis (Mausbewegung)

MouseMove-Ereignis (Mausbewegung)

Das Ereignis MouseMove tritt ein, wenn der Benutzer die Maus bewegt.

Anmerkungen

  • Das Ereignis MouseMove hat nur für Formulare, Formularbereiche und Steuerelemente eines Formulars Gültigkeit, nicht aber für Steuerelemente eines Berichts.

  • Dieses Ereignis gilt nicht für ein einem anderen Steuerelement zugeordnetes Bezeichnungsfeld, wie z. B. ein Bezeichnungsfeld für ein Textfeld. Es hat nur für "freistehende" Bezeichnungsfelder Gültigkeit. Das Bewegen des Mauszeigers über ein zugeordnetes Bezeichnungsfeld hat dieselbe Wirkung wie das Bewegen des Zeigers über das zugeordnete Steuerelement. Es treten nur die für das Steuerelement üblichen, keine zusätzlichen Ereignisse für das Bezeichnungsfeld ein.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Mausbewegung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Das Ereignis MouseMove wird ständig wiederholt ausgelöst, während sich der Mauszeiger über einem Objekt bewegt. Solange kein anderes Objekt ein Mausereignis auslöst, erkennt ein Objekt immer dann das Ereignis MouseMove, wenn der Mauszeiger innerhalb der Berandung des Objekts positioniert wird.

Zum Auslösen des Ereignisses MouseMove für ein Formular bewegen Sie den Mauszeiger über eine freie Stelle, auf den Datensatzmarkierer oder auf die Bildlaufleiste des Formulars. Zum Auslösen des Ereignisses MouseMove für einen Formularbereich markieren Sie den Formularbereich und bewegen dann den Mauszeiger über eine freie Stelle in diesem Bereich.

Anmerkungen

  • Das Verschieben eines Formulars kann das Ereignis MouseMove auch dann auslösen, wenn die Maus nicht bewegt wird, da dieses Ereignis durch das Bewegen eines Formulars unter dem Zeiger ausgelöst wird. Wenn ein Makro oder eine Ereignisprozedur ein Formular als Reaktion auf das Ereignis MouseMove verschiebt, kann sich das Ereignis wiederholen (d.h., es wird ständig das Ereignis MouseMove erzeugt).

  • Wenn zwei Steuerelemente sehr eng nebeneinander angeordnet sind und Sie den Mauszeiger schnell über den Zwischenraum zwischen diesen bewegen, wird das Ereignis MouseMove möglicherweise nicht für den Zwischenraum erzeugt (dies kann z. B. für das Ereignis MouseMove für den Formularbereich der Fall sein). In einem solchen Fall müssen Sie möglicherweise sowohl auf das Ereignis MouseMove für das angrenzende Steuerelement als auch für das Ereignis für den Formularbereich reagieren.

Zum Ausführen eines Makros oder einer Ereignisprozedur als Reaktion auf das Drücken und Loslassen der Maustasten verwenden Sie die Ereignisse MouseDown und MouseUp.


 NoData-Ereignis (OhneDaten)

NoData-Ereignis (OhneDaten)

Das Ereignis NoData tritt ein, nachdem Microsoft Access einen Bericht zum Drucken formatiert hat, der keine Daten enthält (der Bericht ist an eine leere Datensatzgruppe gebunden), aber bevor der Bericht gedruckt wird. Sie können dieses Ereignis verwenden, um zu verhindern, dass ein leerer Bericht gedruckt wird.

Anmerkung

Soll ein Makro oder eine Ereignisprozedur ausgeführt werden, wenn dieses Ereignis eintritt, stellen Sie die Eigenschaft OnNoData auf den Namen des Makros bzw. auf [Ereignisprozedur] ein.

Ist der Bericht nicht an eine Tabelle oder Abfrage gebunden (über die Eigenschaft RecordSource des Berichts), tritt das Ereignis NoData nicht ein.

Dieses Ereignis tritt ein, nachdem für den Bericht das Ereignis Format und bevor für den Bericht das erste Mal das Ereignis Print eingetreten ist.

Für Unterberichte tritt dieses Ereignis nicht ein. Für den Fall, dass Sie Steuerelemente eines Unterberichts ausblenden möchten, wenn der Unterbericht keine Daten enthält, und Sie daher verhindern möchten, dass die Steuerelemente gedruckt werden, können Sie die Eigenschaft HasData in einem Makro oder einer Ereignisprozedur verwenden, die ausgeführt wird, wenn eines der Ereignisse Format oder Print eintritt.

Das Ereignis NoData tritt ein, bevor das Ereignis Page das erste Mal für den Bericht eintritt.


 NotInList-Ereignis (NichtInListe)

NotInList-Ereignis (NichtInListe)

Das Ereignis NotInList tritt ein, wenn der Benutzer in das Textfeld eines Kombinationsfelds einen Wert eingibt, der nicht in der Liste des Kombinationsfelds enthalten ist.

Anmerkung Das Ereignis NotInList hat nur für Steuerelemente eines Formulars, nicht für Steuerelemente eines Berichts Gültigkeit.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Nicht in Liste auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Dieses Ereignis erlaubt dem Benutzer, einen neuen Wert zum Listenfeld eines Kombinationsfelds hinzuzufügen.

Das Ereignis NotInList kann nur eintreten, wenn die Eigenschaft Nur Listeneinträge auf Ja eingestellt ist.

Das Ereignis NotInList löst nicht das Ereignis Error aus.

Das Ereignis NotInList tritt für Kombinationsfelder ein, deren Eigenschaft LimitToList auf Ja eingestellt ist, und zwar wenn Sie einen Wert eingeben, der nicht in der Liste enthalten ist, und versuchen, zu einem anderen Steuerelement zu wechseln oder den Datensatz zu speichern. Es tritt nach allen Ereignissen Change für das Kombinationsfeld ein.

Wenn die Eigenschaft Automatisch ergänzen auf Ja eingestellt ist, wählt Microsoft Access in der Liste die Einträge aus, die mit der fortlaufenden Eingabe des Benutzers im Textfeldteil des Kombinationsfelds übereinstimmen. Entspricht die Eingabe dem Anfang eines Listeneintrags (Beispiel: der Benutzer gibt "Schm" ein, und "Schmittchen" kommt in der Liste vor), so tritt das Ereignis NotInList nicht auf, wenn der Benutzer zu einem anderen Steuerelement übergeht oder den Datensatz speichert. Die Zeichen, die Microsoft Access zur Eingabe des Benutzer hinzufügt (im obigen Beispiel "ittchen"), werden jedoch im Textfeldteil des Kombinationsfelds markiert. Wenn der Benutzer in solchen Fällen das Ereignis NotInList anwenden möchte (um beispielsweise den Namen "Schmitt" zur Kombinationsfeldliste hinzuzufügen), muss er hinter dem letzten Zeichen des neuen Wertes ein LEERZEICHEN eingeben oder die RÜCKTASTE oder ENTF-TASTE drücken.

Wenn die Eigenschaft LimitToList auf Ja eingestellt ist, und die Dropdown-Kombinationsfeldliste geöffnet wird, wählt Microsoft Access in der Liste genau die Zeichenfolgen aus, die mit der fortlaufenden Eingabe des Benutzers im Textfeldteil des Kombinationsfelds übereinstimmen, selbst wenn die Eigenschaft AutoExpand auf Nein eingestellt ist. Drückt der Benutzer die EINGABETASTE, oder wechselt er zu einem anderen Steuerelement oder Datensatz, so wird der ausgewählte Wert im Kombinationsfeld angezeigt. In diesem Fall wird das Ereignis NotInList nicht angewendet. Wenn das Ereignis NotInList trotzdem eintreten soll, darf der Benutzer die Kombinationsfeldliste nicht öffnen.


 Page-Ereignis (Seite)

Page-Ereignis (Seite)

Das Ereignis Page tritt ein, nachdem Microsoft Access eine Seite eines Berichts zum Drucken formatiert hat, jedoch bevor die Seite gedruckt wird. Sie können dieses Ereignis verwenden, um einen Rahmen für die Seite zu erstellen oder um der Seite andere grafische Elemente hinzuzufügen.

Anmerkung

Wenn Sie ein Makro oder eine Ereignisprozedur erstellen möchten, die ausgeführt wird, sobald diese Ereignis eingetreten ist, stellen Sie die Eigenschaft Bei Seite auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Dieses Ereignis tritt ein nach allen für den Bericht ausgelösten Format-Ereignissen und nach allen für die Seite ausgelösten Print-Ereignissen, aber bevor die Seite tatsächlich gedruckt wird.

Meist verwenden Sie in der Print-Ereignisprozedur die Methoden Line, Circle und PSet, um die für die Seite gewünschten Grafikelemente zu erstellen.

Das Ereignis NoData tritt ein, bevor das erste Page-Ereignis für den Bericht ausgelöst wird.


 Print-Ereignis (Drucken)

Print-Ereignis (Drucken)

Das Ereignis Print tritt ein, wenn Daten in einem Bereich eines Berichts zum Drucken formatiert werden, jedoch bevor der Bereich gedruckt wird.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Beim Drucken auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Bei Detailbereichen in Berichten tritt das Ereignis Print für jeden Datensatz im Bereich ein, unmittelbar bevor Microsoft Access die Daten des Datensatzes druckt. Ein Makro oder eine Ereignisprozedur für das Ereignis Print kann auf die Daten des aktuellen Datensatzes zugreifen.

Bei Gruppenköpfen in Berichten tritt das Ereignis Print für jede neue Gruppe ein. Ein Makro oder eine Ereignisprozedur für das Ereignis Print kann auf Daten im Gruppenkopf und im ersten Datensatz des Detailbereichs zugreifen. Bei Gruppenfüßen in Berichten tritt das Ereignis Print für jede neue Gruppe ein. Ein Makro oder eine Ereignisprozedur für das Ereignis Print kann auf die Daten im Gruppenfuß und im letzten Datensatz des Detailbereichs zugreifen.

Sie können mit dem Ereignis Print erst dann ein Makro oder eine Ereignisprozedur ausführen, wenn Microsoft Access die Daten zum Drucken auf einer Seite aufbereitet hat. Sie können z. B. laufende Seitensummen berechnen, die im Seitenkopf oder -fuß gedruckt werden.

Bei Änderungen, die das Seitenlayout betreffen, z. B. das Ein- oder Ausblenden von Steuerelementen, verwenden Sie das Ereignis Format.

Das Ereignis Print tritt nur für Bereiche ein, die tatsächlich gedruckt werden. Wenn Sie auf Daten aus Bereichen zugreifen müssen, die nicht gedruckt werden (z. B. wenn Sie eine fortlaufende Summe haben, aber nur einzelne Seiten drucken), verwenden Sie stattdessen das Ereignis Format.

Das Ereignis Page tritt ein, nachdem für den Bericht alle Ereignisse Format und für eine Seite alle Ereignisse Print eingetreten sind, jedoch bevor die Seite tatsächlich gedruckt wird.


 Progress-Ereignis

Progress-Ereignis

Das Progress-Ereignis tritt während des Ladens einer Snapshot-Datei ein.

Syntax

Sub Steuerelementname_Progress(ByVal Betrag As Long)

Das Progress-Ereignis verwendet die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Snapshot-Steuerelements.
Betrag | Ein Wert vom Typ Integer zwischen 0 und 100, der für den Prozentsatz der geladenen Snapshot-Datei steht.

Anmerkungen

Die SnapshotPath-Eigenschaft kann auf eine Snapshot-Datei mit einer HTTP- oder FTP-Adresse verweisen. Je nach der Dateigröße und der Geschwindigkeit der Internet- oder Intranetverbindung kann die Übertragung der vollständigen Datei relativ viel Zeit beanspruchen.

Mit Hilfe des Arguments Betrag des Progress-Ereignisses können Sie einen Statusanzeiger einblenden, der den Status des Übertragungsvorgangs der Datei wiedergibt.

Mit Hilfe der ReadyState-Eigenschaft können Sie ermitteln, wann eine Snapshot-Datei vollständig in das Snapshot Viewer-Steuerelement geladen ist.


 ReadyStateChange-Ereignis

ReadyStateChange-Ereignis

Das ReadyStateChange-Ereignis tritt ein, sobald sich die ReadyState-Eigenschaft eines Snapshot-Steuerelements ändert.

Syntax

Sub Steuerelementname_ReadyStateChange(ByVal ReadyState As Long)

Das ReadyStateChange-Ereignis verwendet die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Snapshot-Steuerelements.
ReadyState | Ein Wert vom Typ Integer zwischen 0 und 4, der für den aktuellen Wert der ReadyState-Eigenschaft steht.

Anmerkungen

Mit Hilfe dieses Ereignisses können Änderungen an der ReadyState-Eigenschaft erfasst werden.


 Resize-Ereignis (Größenänderung)

Resize-Ereignis (Größenänderung)

Das Ereignis Resize tritt ein, wenn ein Formular geöffnet wird und wenn sich die Größe eines Formulars ändert.

Anmerkung

Wenn beim Eintreten dieser Ereignisse ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Größenänderung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Dieses Ereignis tritt ein, wenn Sie die Größe des Formulars in einem Makro oder in einer Ereignisprozedur ändern, z. B. unter Verwendung der Aktion Positionieren in einem Makro.

Durch das Ausführen eines Makros oder einer Ereignisprozedur bei Eintreten des Ereignisses Resize können Sie ein Steuerelement verschieben oder dessen Größe ändern, wenn die Größe des Formulars sich ändert, auf dem sich dieses Steuerelement befindet. Sie können das Ereignis Resize auch zur Neuberechnung von Variablen oder zum Zurücksetzen von Eigenschafteneinstellungen verwenden, die von der Größe des Formulars abhängen.

Wenn Sie ein Formular zum ersten Mal öffnen, treten die folgenden Ereignisse in der aufgeführten Reihenfolge ein:

Open Þ Load Þ Resize Þ Activate Þ Current

Anmerkung Seien Sie vorsichtig, wenn Sie in einem Makro bzw. einer Ereignisprozedur für das Ereignis Resize eine der Aktionen Positionieren, Maximieren, Minimieren oder Wiederherstellen bzw. die entsprechenden Methoden für das Objekt DoCmd verwenden (MoveSize, Maximize, Minimize, Restore). Diese Aktionen können ein Ereignis Resize für das Formular auslösen und somit zu einem sich wiederholenden Ereignis führen.


 Retreat-Ereignis (Rücknahme)

Retreat-Ereignis (Rücknahme)

Das Ereignis Retreat tritt ein, wenn Microsoft Access während der Formatierung eines Berichts zu einem vorherigen Berichtsbereich zurückkehrt.

Anmerkung Das Ereignis Retreat betrifft alle Berichtsbereiche außer Seitenköpfen und Seitenfüßen.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft OnRetreat auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Unter bestimmten Umständen muss Microsoft Access zu einem vorherigen Berichtsbereich zurückkehren, um ermitteln zu können, wo sich bestimmte Steuerelemente und Bereiche eines Berichts befinden und ob diese in den jeweils verfügbaren Platz hineinpassen. Beispiele:

  • Gruppen (ausgenommen solche für Seitenköpfe und -füße), deren Eigenschaft KeepTogether auf Ganze Gruppe oder Mit 1. Detaildatensatz eingestellt ist.

  • Unterberichte oder Unterformulare, deren Eigenschaften CanGrow und/oder CanShrink auf Ja eingestellt sind.

  • Bereiche auf der letzten Seite eines Berichts.

In diesen Situationen tritt das Ereignis Format ein, während Microsoft Access ermittelt, wie die Bereiche auf die gedruckte Seite passen (das Ereignis Print tritt jedoch nicht ein, da die Bereiche zu diesem Zeitpunkt noch nicht gedruckt werden). Wenn die Bereiche nicht gedruckt werden können, kehrt Microsoft Access zu der geforderten Position zurück, so dass die Bereiche auf der nächsten Seite gedruckt werden können. Das Ereignis Retreat tritt für jeden Bereich ein, hinter dem Microsoft Access eine Rücknahme vornimmt. Das Ereignis Format tritt dann erneut für jeden Bereich ein, wenn Microsoft Access das Neudrucken der Bereiche vorbereitet.

Wenn Microsoft Access z. B. beim Formatieren eines Berichts das Ende der letzten Seite erreicht, tritt das Ereignis Retreat solange für jeden vorhergehenden Bereich ein, bis Microsoft Access den obersten Bereich auf der letzten Seite erreicht hat. Anschließend tritt erneut für jeden Bereich der Seite das Ereignis Format gefolgt vom Ereignis Print ein.

Sie können bei Eintreten des Ereignisses Retreat eine Ereignisprozedur oder ein Makro zum Rückgängigmachen von Änderungen ausführen, die Sie beim Eintreten des Ereignisses Format für diesen Bereich vorgenommen hatten. Dies ist dann hilfreich, wenn Ihre Ereignisprozedur bzw. Ihr Makro für das Ereignis Format Aktionen ausführt (wie z. B. das Berechnen von Seitensummen oder Prüfen der Größe eines Bereichs), die Sie für jeden Bereich nur einmal ausführen möchten.

Das Ereignis Retreat erlaubt auch das Beibehalten der Position von Berichtselementen. Der Bericht Umsätze nach Jahr aus der Nordwind-Beispieldatenbank verwendet dieses Ereignis zum Bestimmen, ob ein Seitenkopf gedruckt werden soll oder nicht. (Der Seitenkopf wird auf Seiten gedruckt, die auf eine Seite folgen, auf der der Gruppenkopf gedruckt wurde. Der Seitenkopf wird nicht auf Seiten gedruckt, die auf eine Seite folgen, auf der der Gruppenfuß gedruckt wurde.)


 Terminate-Ereignis (Beenden)

Terminate-Ereignis (Beenden)

Das Ereignis Terminate für ein Klassenmodul tritt ein, wenn alle Verweise auf eine Instanz der Klasse aus dem Speicher entfernt wurden.

Anmerkung Wenn Sie Code ausführen möchten, der beim Eintreten des Ereignisses Terminate ausgeführt werden soll, schreiben Sie den Code innerhalb der Ereignisprozedur Terminate in einem Klassenmodul.

Anmerkung

Dieses Ereignis tritt nur ein, wenn Sie einen Verweis auf eine Instanz einer Klasse aus dem Speicher entfernen.


 Timer-Ereignis (Zeitgeber)

Timer-Ereignis (Zeitgeber)

Das Ereignis Timer tritt in gleichbleibenden Intervallen ein, die in der Einstellung der Eigenschaft Zeitgeberintervall eines Formulars festgelegt sind.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Zeitgeber auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Durch Ausführen eines Makros oder einer Ereignisprozedur bei Eintreten des Ereignisses Timer können Sie steuern, welche Schritte Microsoft Access nach jedem Intervall des Zeitgebers ausführen soll. Sie können z. B. festlegen, dass zugrunde liegende Datensätze erneut abgefragt werden sollen oder die Anzeige in bestimmten Intervallen aktualisiert werden soll.

Die Einstellung der Formulareigenschaft TimerInterval gibt die Länge des Intervalls in Millisekunden an, das zwischen zwei Ereignissen Timer liegt. Das Intervall kann von 0 bis 65.535 Millisekunden lang sein. Wenn für die Eigenschaft TimerInterval die Einstellung 0 festgelegt wird, tritt das Ereignis Timer nicht ein.


 Updated-Ereignis (OLEAktualisierung)

Updated-Ereignis (OLEAktualisierung)

Das Ereignis Updated tritt ein, wenn die Daten in einem OLE-Objekt geändert wurden.

Anmerkung Das Ereignis Updated hat nur für Steuerelemente eines Formulars, nicht für Steuerelemente eines Berichts Gültigkeit.

Anmerkung

Wenn beim Eintreten dieses Ereignisses ein Makro oder eine Ereignisprozedur ausgeführt werden soll, stellen Sie die Eigenschaft Bei Aktualisierung auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Mit diesem Ereignis können Sie feststellen, ob sich die Daten eines Objekts seit dessen letzter Speicherung geändert haben.

Das Ereignis Updated tritt ein, wenn die Daten in einem OLE-Objekt geändert wurden. Diese Aktualisierung kann sowohl aus der Anwendung stammen, mit der das Objekt erstellt wurde, als auch aus einer der verknüpften Kopien des Objekts. Aus diesem Grund ist dieses Ereignis nicht synchron mit anderen Microsoft Access-Ereignissen für Steuerelemente.

Anmerkungen

  • Das Ereignis Updated und die Ereignisse BeforeUpdate und AfterUpdate für gebundene und ungebundene Objektfelder stehen nicht in Beziehung zueinander. Das Ereignis Updated tritt ein, wenn sich die Daten in einem OLE-Objekt geändert haben, während die Ereignisse BeforeUpdate und AfterUpdate eintreten, wenn Daten aktualisiert werden. Obwohl diese Ereignisse nicht direkt in Beziehung zueinander stehen, treten sie doch in der Regel zusammen ein, wenn die Daten in einem OLE-Objekt geändert werden. Das Ereignis Updated tritt normalerweise vor den Ereignissen BeforeUpdate und AfterUpdate ein; dies ist jedoch nicht immer der Fall.

  • Das mit Microsoft Access 97 gelieferte Kalender-Steuerelement unterstützt das Ereignis Updated nicht mehr. Wenn Sie eine Datenbank konvertieren, die das Kalender-Steuerelement aus einer früheren Version von Microsoft Access enthält, verschieben Sie den Code des Updated-Ereignisses für das Kalender-Steuerelement in das Ereignis AfterUpdate.


Verzeichnis der Funktionen

Das folgende Verzeichnis listet alle Funktionen in alphabetischer Reihenfolge auf.

Anmerkung Die mit einem Sternchen (*) gekennzeichneten Funktionen sollten in einer Datenzugriffsseite nicht gegenüber einer gespeicherten Abfrage verwendet werden.

A-C

Abs (VBA) | Cos (VBA)
Array (VBA) | Count (DAO)
Asc (VBA) | Atn (VBA)
Avg (DAO) | CBool (VBA)
CreateObject (VBA) | CByte (VBA)
CCur (VBA) | CDate (VBA)
CSng (VBA) | CDbl (VBA)
CStr (VBA) | CDec (VBA)
CurDir (VBA) | Choose (VBA)
Chr (VBA) | CInt (VBA)
CVar (VBA) | CLng (VBA)
CVDate (VBA) | CVErr (VBA)
Command* |

D-H

Date (VBA) | DVar
DateAdd (VBA) | DVarP
DateDiff (VBA) | Environ* (VBA)
DatePart (VBA) | EOF (VBA)
DateSerial (VBA) | Error (VBA)
DateValue (VBA) | EuroConvert
DAvg | Eval
Day (VBA) | Exp (VBA)
DomAnzahl | FileAttr (VBA)
DDB (VBA) | FileDateTime* (VBA)
DDE | FileLen* (VBA)
DDEInitiate | First (DAO)
DDERequest | Fix (VBA)
DDESend | Format (VBA)
DFirst | FreeFile (VBA)
Dir* (VBA) | FV (VBA)
DLast | GetAllSetting (VBA)
DLookup | GetAttr* (VBA)
DMax | GetObject (VBA)
DMin | GetSetting* (VBA)
DoEvents (VBA) | GUIDFromString
DStDev | Hex (VBA)
DStDevP | Hour (VBA)
DSum | HyperlinkPart

I-R

IIf (VBA) | Log (VBA)
IMEStatus (VBA) | LTrim (VBA)
Input* (VBA) | Max (DAO)
InputBox (VBA) | Mid (VBA)
InStr (VBA) | Min (DAO)
Int (VBA) | Minute (VBA)
IPmt (VBA) | MIRR (VBA)
IRR (VBA) | Month (VBA)
IsArray (VBA) | MsgBox (VBA)
IsDate (VBA) | Now (VBA)
IsEmpty (VBA) | NPer (VBA)
IsError (VBA) | NPV (VBA)
IsMissing (VBA) | Nz
IsNull (VBA) | Oct (VBA)
IsNumeric (VBA) | Partition (VBA)
IsObject (VBA) | Pmt (VBA)
Last (DAO) | PPmt (VBA)
LBound (VBA) | PV (VBA)
LCase (VBA) | QBColor (VBA)
Left (VBA) | Rate (VBA)
Len (VBA) | RGB (VBA)
Right (VBA) | Loc (VBA)
Rnd (VBA) | LOF (VBA)
RTrim (VBA) |

S-Z

Second (VBA) | SYD (VBA)
Seek (VBA) | Tab (VBA)
Sgn (VBA) | Tan (VBA)
Shell* (VBA) | Time (VBA)
Sin (VBA) | Timer (VBA)
SLN (VBA) | TimeSerial (VBA)
Space (VBA) | TimeValue (VBA)
Spc (VBA) | Trim (VBA)
Sqr (VBA) | TypeName (VBA)
StDev (DAO) | UBound (VBA)
StDevP (DAO) | UCase (VBA)
Str (VBA) | Val (VBA)
StrComp (VBA) | Var (DAO)
StrConv (VBA) | VarP (DAO)
String (VBA) | VarType (VBA)
StringFromGUID | Weekday (VBA)
Sum (DAO) | Year (VBA)
Switch (VBA) |


 Aggregatfunktionen für Domänen

Aggregatfunktionen für Domänen

Aggregatfunktionen liefern statistische Informationen über Datensatzgruppen (Domänen). Sie können eine Aggregatfunktion z. B. verwenden, um die Anzahl der Datensätze in einer bestimmten Datensatzgruppe zu zählen oder um den Durchschnitt von Werten in einem bestimmten Feld zu ermitteln.

Die beiden Typen der Aggregatfunktionen, Aggregatfunktionen für Domänen und SQL-Aggregatfunktionen, haben eine ähnliche Funktion, werden jedoch in unterschiedlichen Situationen eingesetzt. Die SQL-Aggregatfunktionen können in die Syntax einer SQL-Anweisung eingebunden, aber nicht direkt aus Visual Basic aufgerufen werden. Umgekehrt können die Aggregatfunktionen für Domänen direkt aus Visual Basic-Code aufgerufen werden. Sie können auch in eine SQL-Anweisung eingebunden werden, jedoch ist es im Allgemeinen effizienter, in diesem Fall SQL-Aggregatfunktionen zu verwenden.

Wenn Sie statistische Berechnungen innerhalb von Code durchführen, müssen Sie die Aggregatfunktionen für Domänen verwenden. Sie können die Aggregatfunktionen für Domänen auch verwenden, um Kriterien anzugeben, Werte zu aktualisieren oder berechnete Felder in einem Abfrageausdruck zu erzeugen. Sie können entweder die SQL-Aggregatfunktionen oder die Aggregatfunktionen für Domänen in einem berechneten Steuerelement in einem Formular oder einem Bericht verwenden.

Es gibt folgende Aggregatfunktionen für Domänen:

DAvg-Funktion

DCount-Funktion

DLookup-Funktion

DFirst, Dlast-Funktionen

DMin-, DMax-Funktionen

DStDev-, DStDevP-Funktionen

DSum-Funktion

DVar-, DVarP-Funktionen


 Command-Funktion (Befehl)

Command-Funktion (Befehl)

Mit der Command-Funktion können Sie den Argumententeil einer Befehlszeile zurückgeben, die zum Starten von Microsoft Access verwendet wird.

Syntax

Command

Anmerkungen

Wenn Microsoft Access aus der Befehlszeile gestartet wird, wird der Teil der Befehlszeile, der hinter der Option /cmd folgt, als Befehlszeilenargument an das Programm übergeben. Mit der Command-Funktion können Sie das Argument zurückgeben, das übergeben wurde.

Um das Befehlszeilenargument nach dem Öffnen einer Datenbank zu ändern, klicken Sie im Menü Extras auf Optionen. Geben Sie dann im Dialogfeld Optionen auf der Registerkarte Weitere in das Feld Befehlszeilenargumente ein neues Argument ein. Die Command-Funktion gibt jetzt das neue, von Ihnen eingegebene Argument zurück.

Wenn die Command-Funktion nicht in einem Modul in Visual Basic-Code verwendet wird, müssen Sie hinter dem Funktionsnamen Klammern angeben. Um die Command-Funktion z. B. in einem Textfeld eines Formulars zu verwenden, legen Sie für die Steuerelementinhalt-Eigenschaft des Textfeldes einen Ausdruck fest, der folgendermaßen aussieht:

=Command()


 DAvg-Funktion (DomMittelwert)

DAvg-Funktion (DomMittelwert)

Mit der DAvg-Funktion können Sie den Mittelwert einer Gruppe von Werten in einer bestimmten Datensatzgruppe (einer Domäne) berechnen. Verwenden Sie die DAvg-Funktion in Visual Basic-Code, in einem Makro, in einem Abfrageausdruck oder in einem berechneten Steuerelement.

Sie können die DAvg-Funktion z. B. in der Zeile Kriterien einer ausgewählten Abfrage über Frachtkosten verwenden, um die Ergebnisse auf die Datenätze zu beschränken, in denen die Frachtkosten den Mittelwert überschreiten. Oder Sie können einen Ausdruck verwenden, der die DAvg-Funktion in einem berechneten Steuerelement enthält und den Mittelwert früherer Bestellungen neben dem Wert einer neuen Bestellung anzeigt.

Syntax

DAvg(Ausdr, Domäne[, Kriterien])

Die DAvg-Funktion hat die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld mit den nummerischen Daten kennzeichnet, für die Sie einen Mittelwert berechnen möchten. Dies kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfeldes, ein Steuerelement eines Formulars, eine Konstante oder eine Funktion einbeziehen. Wenn das Argument Ausdr eine Funktion enthält, so kann dies sowohl eine eingebaute als auch eine benutzerdefinierte Funktion sein. Domänen-Aggregatfunktionen oder SQL-Aggregatfunktionen sind nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen einer Tabelle oder um den Namen einer Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den die DAvg-Funktion ausgeführt wird. Das Argument Kriterien ist z. B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnet DAvg das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst gibt DAvg den Wert Null zurück.

Anmerkungen

Datensätze, die Null-Werte enthalten, werden in die Mittelwertberechnung nicht einbezogen.

Unabhängig davon, ob Sie die DAvg-Funktion in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen, um sicherzugehen, dass es korrekt ausgewertet wird.

Sie können die DAvg-Funktion zum Festlegen von Kriterien in der Zeile Kriterien einer Abfrage verwenden. Sie können z. B. eine Liste aller Produkte, deren Bestellmenge den Mittelwert überschreitet, nach Mengen sortiert anzeigen. Dazu erstellen Sie eine Abfrage über die Tabellen Bestellungen, Bestelldetails und Artikel und fügen das Feld Artikelname und das Feld Menge mit dem folgenden Ausdruck in der Zeile Kriterien neben dem Feld Menge hinzu:

>DAvg("[Menge]", "Bestellungen")

Sie können die DAvg-Funktion auch innerhalb eines berechneten Feldausdrucks in einer Abfrage oder in der Zeile Aktualisieren einer Aktualisierungsabfrage verwenden.

Anmerkung Sie können entweder die DAvg-Funktion oder die Avg-Funktion in einem berechneten Feldausdruck in einer Berechnungsabfrage verwenden. Wenn Sie DAvg verwenden, werden die Mittelwerte berechnet, bevor die Daten gruppiert werden. Wenn Sie Avg verwenden, werden die Daten gruppiert, bevor der Mittelwert über die Werte im Feldausdruck berechnet wird.

Verwenden Sie die DAvg-Funktion in einem berechneten Steuerelement, wenn Sie Kriterien zum Einschränken des Bereichs der Daten festlegen möchten, für die die DAvg-Funktion durchgeführt wird. Legen Sie z. B. zum Anzeigen der durchschnittlichen Frachtkosten für Lieferungen nach Kalifornien für die Steuerelementinhalt-Eigenschaft eines Textfeldes den folgenden Ausdruck fest:

=DAvg("[Frachtkosten]", "Bestellungen", "[Region] = 'CA'")

Wenn Sie einfach einen Mittelwert über alle Datensätze in der Domäne berechnen möchten, verwenden Sie die Avg-Funktion.

Sie können die DAvg-Funktion in einem Modul oder Makro oder in einem berechneten Steuerelement in einem Formular verwenden, wenn ein Feld, das Sie anzeigen möchten, nicht die Datenquelle ist, auf der Ihr Formular basiert. Angenommen, Sie haben ein Formular, das auf der Tabelle Bestellungen basiert und möchten das Feld Menge aus der Tabelle Bestelldetails hinzufügen, um den Mittelwert der von einem bestimmten Kunden bestellten Artikel anzuzeigen. Verwenden Sie jetzt die DAvg-Funktion zum Durchführen dieser Berechnung und zum Anzeigen der Daten in Ihrem Formular.

Tipps

  • Wenn Sie die DAvg-Funktion in einem berechneten Steuerelement verwenden, können Sie das Steuerelement im Formularkopf oder -fuß ablegen, damit der Wert für dieses Steuerelement nicht bei jedem Wechsel zu einem neuen Datensatz neu berechnet wird.

  • Wenn der Datentyp des Feldes, von dem das Argument Ausdr stammt, eine Zahl ist, gibt die DAvg-Funktion den Datentyp Double zurück. Wenn Sie DAvg in einem berechneten Steuerelement verwenden, fügen Sie eine Datentyp-Konvertierungsfunktion in den Ausdruck ein, um das Leistungsverhalten zu verbessern.

  • Obwohl Sie DAvg verwenden können, um den Mittelwert aus Werten in einem Feld in einer Fremdtabelle zu berechnen, kann es effizienter sein, eine Abfrage zu erstellen, die die benötigten Felder aus beiden Tabellen enthält, und Ihrem Formular oder Bericht dann diese Abfrage zugrundezulegen.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die nicht gespeichert sind, werden bei dieser Funktion nicht berücksichtigt. Wenn die DAvg-Funktion die geänderten Werte einbeziehen soll, müssen Sie die Änderungen zuerst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen, den Fokus auf einen anderen Datensatz setzen oder die Methode Update verwenden.


 DCount-Funktion (DomAnzahl)

DCount-Funktion (DomAnzahl)

Mit der DCount-Funktion können Sie die Anzahl der Datensätze in einer bestimmten Datensatzgruppe (einer Domäne) ermitteln. Verwenden Sie die DCount-Funktion in Visual Basic, einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement.

Sie können DCount z. B. in einem Modul verwenden, um die Anzahl der Datensätze in einer Tabelle Bestellungen zu ermitteln, die die an einem bestimmten Tag bestellten Artikel enthalten.

Syntax

DCount(Ausdr, Domäne[, Kriterien])

Die DCount-Funktion hat die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld kennzeichnet, für das Sie Datensätze zählen möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen einer Tabelle oder um den Namen einer Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den DCount ausgeführt wird. Das Argument Kriterien ist z. B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnet DCount das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst gibt DCount den Wert Null zurück.

Anmerkungen

Verwenden Sie die DCount-Funktion zum Zählen der Datensätze in einer Domäne, wenn Sie die eigentlichen Werte nicht kennen müssen. Obwohl das Argument Ausdr eine Berechnung über ein Feld durchführen kann, ermittelt DCount nur die Anzahl der Datensätze. Der Wert einer beliebigen mit Ausdr durchgeführten Berechnung steht nicht zur Verfügung.

Unabhängig davon, ob Sie DCount in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen,um sicherzugehen, dass es korrekt ausgewertet wird.

Verwenden Sie DCount in einem berechneten Steuerelement, wenn Sie das Argument Kriterien angeben möchten, um den Datenbereich einzuschränken, auf dem die Funktion ausgeführt wird. Wenn Sie z. B. die Anzahl der Bestellungen anzeigen möchten, die nach Kalifornien versendet werden sollen, legen Sie die ControlSource-Eigenschaft eines Textfelds auf den folgenden Ausdruck fest:

=DCount("[Bestell-Nr]", "Bestellungen", "[Region] = 'CA'")

Wenn Sie einfach nur alle Datensätze in der Domäne - ohne Beschränkungen - zählen möchten, verwenden Sie die Count-Funktion.

Tipp Die Count-Funktion wurde optimiert, um das Zählen von Datensätzen in Abfragen zu beschleunigen. Verwenden Sie in einer Abfrage die Count-Funktion an Stelle von DCount, und legen Sie optionale Kriterien fest, um das Ergebnis einzuschränken. Verwenden Sie die DCount-Funktion, wenn Sie Datensätze in einer Domäne aus einem Codemodul, einem Makro oder in einem berechneten Steuerelement zählen müssen.

Sie können mit der DCount-Funktion die Anzahl der Datensätze zählen, die ein bestimmtes Feld enthalten, das nicht in der Datenquelle enthalten ist, auf dem Ihr Formular oder Bericht basiert. Sie können z. B. die Anzahl der Bestellungen aus der Tabelle Bestellungen in einem berechneten Steuerelement eines Formulars anzeigen, das auf der Tabelle Artikel basiert.

Die DCount-Funktion zählt keine Datensätze die in dem im Ausdr genannten Feld Null-Werte enthalten, es sei denn Ausdr ist das Platzhalterzeichen Sternchen (*). Wenn Sie ein Sternchen verwenden, berechnet DCount die Gesamtzahl aller Datensätze einschließlich derjenigen, die Null-Felder enthalten. Das folgende Beispiel berechnet die Anzahl der Datensätze in der Tabelle Bestellungen.

intX = DCount("*", "Bestellungen")

Wenn die Domäne eine Tabelle mit einem Primärschlüssel ist, können Sie die Gesamtzahl aller Datensätze auch durch Festlegen des Primärschlüsselfeldes für Ausdr berechnen, da es in einem Primärschlüsselfeld nie einen Null-Wert geben kann.

Wenn Ausdr mehrere Felder kennzeichnet, trennen Sie die Feldnamen durch einen Verbindungsoperator, wie z. B. ein UND-Zeichen (&) oder den Additions-Operator (+) voneinander. Wenn Sie zum Trennen der Felder ein UND-Zeichen verwenden, gibt die DCount-Funktion die Anzahl der Datensätze zurück, die in einem der aufgelistenen Felder Werte enthalten. Wenn Sie den Additions-Operator verwenden, gibt DCount nur die Anzahl der Datensätze zurück, die in allen der aufgeführten Felder Daten enthalten. Das folgende Beispiel zeigt die Wirkung der einzelnen Operatoren bei Verwendung mit einem Feld, das in allen Datensätzen Daten enthält (Firma) und mit einem Feld, das keine Daten enthält (Region).

intW = DCount("[Firma]", "Bestellungen")          ' Gibt 831 zurück.
intX = DCount("[Region]", "Bestellungen")          ' Gibt 323 zurück.
intY = DCount("[Firma] + [Region]", _
     "Bestellungen")      ' Gibt 323 zurück.
intZ = DCount("[Firma] & [Region]", _
     "Bestellungen")      ' Gibt 831 zurück.

Anmerkung Das UND-Zeichen wird als Operator zum Trennen von Zeichenfolgen empfohlen. Verwenden Sie den Additions-Operator ausschließlich für nummerische Additionen, es sei denn, Sie möchten mit Hilfe eines Ausdrucks Nullen propagieren.

Ungespeicherte Änderungen in Datensätzen der Domäne werden bei Verwendung dieser Funktion nicht einbezogen. Wenn Sie der Funktion die geänderten Werte zugrundelegen möchten, müssen Sie die Änderungen zuerst speichern. Dazu klicken Sie im Menü Datei auf Datensatz speichern, bewegen den Fokus auf einen anderen Datensatz oder verwenden die Update-Methode.


 DDE-Funktion

DDE-Funktion

Mit der DDE-Funktion können Sie einen Dynamischen Datenaustausch (DDE) mit einer anderen Anwendung initiieren, ein Informationselement anfordern und Informationen in einem Steuerelemet eines Formulars oder Berichts anzeigen.

Sie können die DDE-Funktion z. B. in der Steuerelementinhalt-Eigenschaft eines Textfeldes verwenden, um Daten aus einer bestimmten Zelle in einer Microsoft Excel-Kalkulationstabelle anzuzeigen.

Syntax

DDE(Anwendung, Thema, Elemente)

Die DDE-Funktion hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Ein Zeichenfolgenausdruck, der eine Anwendung angibt, die an einem DDE-Datenaustausch teilnehmen kann. Normalerweise ist Anwendung der Name einer .EXE-Datei (ohne die Erweiterung .EXE) einer auf Microsoft Windows basierenden Anwendung, wie z. B. Microsoft Excel. Um beispielsweise einen DDE-Datenaustausch mit Microsoft-Excel zu initieren, geben Sie "Excel" als Argument Anwendung ein
Thema | Ein Zeichenfolgenausdruck, der den Namen eines Themas enthält, das von Anwendung erkannt wird. In der Dokumentation der Anwendung finden Sie eine Liste der Themen.
Element | Ein Zeichenfolgenausdruck, der den Namen eines Datenelements enthält, das von Anwendung erkannt wird. Eine Liste der Elemente finden Sie in der Dokumentation der Anwendung.

Anmerkungen

Die DDE-Funktion versucht, einen DDE-Datenaustausch mit der angegebenen Anwendung zum angegebenen Thema zu initiieren und fordert die Daten in Element an. Wenn dies erfolgreich verläuft, gibt DDE eine Zeichenfolge mit den angeforderten Informationen zurück.

Wenn Sie Daten aus Microsoft Excel anfordern, kann Element eine Zeilen- und Spaltenkennung sein, wie z. B. "R1C1", oder der Name eines Zellbereichs. Im folgenden Beispiel fordert DDE Informationen aus der Zelle in Zeile1, Spalte 1 einer Microsoft Excel-Kalkulationstabelle an. Sie können diesen Ausdruck für ein Textfeld-Steuerelement im Eigenschaftenfeld Steuerelementinhalt im Eigenschaftenblatt des Steuerelements eingeben:

=DDE("Excel", "Tabelle1", "R1C1")

Sie können die DDE-Funktion nur in der Steuerelementinhalt-Eigenschaft eines Textfeldes, einer Optionsgruppe, eines Kontrollkästchens oder eines Kombinationsfeldes verwenden. Sie können die Funktion nicht aus Visual Basic heraus aufrufen.

Wenn Sie die DDE-Funktion verwenden, wird das Steuerelement in der Formularansicht und der Seitenansicht schreibgeschützt. Wenn Sie z. B. die DDE-Funktion in einem Textfeld verwenden, kann der Text im Textfeld nicht bearbeitet werden. Sie müssen den Text in der anderen Anwendung bearbeiten. Da die Steuerelementinhalt-Eigenschaft in der Formularansicht und der Seitenansicht schreibgeschützt ist, müssen Änderungen am Steuerelement in der Entwurfsansicht vorgenommen werden.

Microsoft Windows sowie der Hauptspeicher und die Ressourcen Ihres Computers legen fest, wie viele DDE-Konversationen maximal gleichzeitig geöffnet sein können. Wenn eine Konversation nicht initiiert werden kann, weil Anwendung nicht ausgeführt oder Thema nicht erkannt wird, oder weil die maximale Anzahl an Konversationen bereits erreicht ist, gibt die DDE-Funktion eine Null zurück.

Anmerkung Die andere Anwendung ist möglicherweise so konfiguriert, dass sie Ihre Anfragen für einen DDE-Datenaustausch ignoriert. Wenn dies der Fall ist, gibt DDE eine Null zurück. Ebenso können Sie auch für Microsoft Access festlegen, dass Anforderungen von anderen Anwendungen ignoriert werden. Dazu klicken Sie im Menü Extras auf Optionen und wählen auf der Registerkarte Weitere unter DDE-Operationen die Option DDE-Anfragen ignorieren.

Tipp Wenn Sie Objekte aus einer anderen Anwendung in Micorsoft Access ändern müssen, können Sie u. U. auch Automatisierung verwenden.

Die folgende Tabelle illustriert das Verhalten der DDE-Funktion bei Verwendung mit den einzelnen Steuerelementen.

Steuerelement | Anmerkungen
Textfeld | Das Argument Element kann auf Text oder Zahlen verweisen. Wenn Element auf mehr als ein Informationselement verweist, wie z. B. auf einen Bereich in einer Microsoft Excel-Kalkulationstabelle, der mehrere Zellen enthält, gibt die DDE-Funktion den ersten Eintrag zurück. Sie können diese Funktion zusammen mit einem Textfeld zum Anzeigen der Daten aus einer Zelle in der Kalkulationstabelle verwenden.
Kombinationsfeld | Die DDE-Funktion trägt im Kombinationsfeld die Informationen ein, auf die in Element verwiesen wird. Sie können im Textteil des Feldes keine Daten eingeben. Sie können die DDE-Funktion zusammen mit einem Kombinationsfeld z. B. zum Anzeigen einer Liste von Orten oder Ländern verwenden, die Sie in einer Microsoft Excel-Kalkulationstabelle verwalten.
Optionsgruppe | Für die Optionswert-Eigenschaft eines jeden Optionsfeldes in einer Optionsgruppe wird eine Zahl eingestellt. In der Regel lautet der Wert der ersten Schaltfläche 1, der zweiten 2 usw. Die von der DDE-Funktion zurückgegebene Zahl legt fest, welches Optionsfeld ausgewählt wird. Wenn die DDE-Funktion z. B. den Wert 2 zurückgibt, wird das zweite Optionsfeld gewählt. Wenn diese Funktion einen Wert zurückgibt, der keiner der Optionswert-Eigenschafteneinstellungen entspricht, wird keines der Felder gewählt. Wenn Element auf mehr als ein Informationselement verweist, z. B. auf einen Bereich in einer Micorosft Excel-Kalkulationstabelle, der mehrere Zellen enthält, gibt die Funktion den ersten Eintrag zurück.
Kontrollkästchen | Wenn die DDE-Funktion den Wert 0 zurückgibt, wird das Kontrollkästchen deaktiviert. Wenn diese Funktion einen Wert ungleich 0 zurückgibt, z. B. 1 oder -1, wird das Kontrollkästchen aktiviert. Wenn Element auf Text verweist oder auf mehrere Informationselemente, wie z. B. einen Bereich in einer Microsoft Excel-Kalkulationstabelle, steht das Kontrollkästchen nicht zur Verfügung.


 DDEInitiate-Funktion (DDEInit)

DDEInitiate-Funktion (DDEInit)

Mit der Funktion DDEInitiate können Sie einen DDE-Dialog (DDE = dynamischer Datenaustausch) mit einer anderen Anwendung beginnen. Die Funktion DDEInitiate öffnet einen DDE-Kanal zur Datenübertragung zwischen einem DDE-Server und einer Client-Anwendung.

Wenn Sie z.B. Daten von einer Microsoft Excel-Tabelle zu einer Microsoft Access-Datenbank übertragen möchten, können Sie die Funktion DDEInitiate zum Öffnen eines Kanals zwischen diesen beiden Anwendungen verwenden. In diesem Beispiel dient Microsoft Access als Client-Anwendung und Microsoft Excel als Server-Anwendung.

Syntax

DDEInitiate(Anwendung, Thema)

Die Funktion DDEInitiate verwendet die folgenden Argumente:

Argument | Beschreibung
Anwendung | Ein Zeichenfolgenausdruck, der eine Anwendung angibt, die an einem DDE-Datenaustausch teilnehmen kann. Normalerweise ist Anwendung der Name einer .EXE-Datei (ohne die Erweiterung .EXE) einer auf Microsoft Windows basierenden Anwendung, wie z.B. Microsoft Excel.
Thema | Ein Zeichenfolgenausdruck, der den Namen eines Themas enthält, das von Anwendung erkannt wird. In der Dokumentation der Anwendung finden Sie eine Liste der Themen.

Anmerkung

Wenn kein Fehler auftritt, beginnt die Funktion DDEInitiate den DDE-Datenaustausch mit der angegebenen Anwendung und dem angegebenen Thema und gibt einen ganzzahligen Wert vom Datentyp Long zurück. Dieser Rückgabewert stellt eine eindeutige Kanalnummer für einen Kanal dar, über den die Datenübertragung stattfinden kann. Diese Kanalnummer wird anschließend für andere DDE-Funktionen und -Anweisungen verwendet.

Wenn die Anwendung noch nicht gestartet wurde oder zwar gestartet wurde, das Thema aber nicht erkennt oder kein DDE unterstützt, gibt die Funktion DDEInitiate einen Laufzeitfehler zurück.

Der Wert des Arguments Thema hängt von der Anwendung ab. Bei Anwendungen, die Dokumente oder Datendateien verwenden, enthalten gültige Themenbezeichnungen häufig den Namen dieser Dateien.

Anmerkung Die Anzahl von Kanälen, die maximal gleichzeitig geöffnet sein können, wird von Microsoft Windows sowie vom Arbeitsspeicher und den Ressourcen Ihres Computers bestimmt. Wenn Sie einen Kanal nicht benötigen, schließen Sie ihn, um System-Ressourcen nicht unnötig zu belegen. Verwenden Sie dazu die Anweisungen DDETerminate oder DDETerminateAll.

Tipp Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


 DDERequest-Funktion (DDEAnfrage)

DDERequest-Funktion (DDEAnfrage)

Mit der Funktion DDERequest können Sie über einen geöffneten DDE-Kanal (DDE = dynamischer Datenaustausch) ein Element oder Informationen von einer DDE-Server-Anwendung anfordern.

Wenn z.B. ein offener DDE-Kanal zwischen Microsoft Access und Microsoft Excel existiert, können Sie mit der Funktion DDERequest Text von einer Microsoft Excel-Tabelle an eine Microsoft Access-Datenbank übertragen. In diesem Beispiel dient Microsoft Access als Client-Anwendung und Microsoft Excel als Server-Anwendung.

Syntax

DDERequest(Kanalnummer, Element)

Die Funktion DDERequest verwendet die folgenden Argumente:

Argument | Beschreibung
Kanalnummer | Eine Kanalnummer, eine Ganzzahl, die von der Funktion DDEInitiate zurückgegeben wird.
Element | Ein Zeichenfolgenausdruck, der den Namen eines Datenelements darstellt, das von der durch die Funktion DDEInitiate angegebenen Anwendung erkannt wird. In der Dokumentation der Anwendung finden Sie eine Liste der möglichen Elemente.

Anmerkung

Das Argument Kanalnummer gibt die Kanalnummer des gewünschten DDE-Datenaustauschs an, und das Argument Element legt fest, welche Daten von der Server-Anwendung abgerufen werden. Der Wert von Element ist abhängig von der beim Öffnen des Kanals Kanalnummer angegebenen Anwendung und dem angegebenen Thema. Element kann z.B. einen Bereich von Zellen in einer Microsoft Excel-Tabelle darstellen.

Die Funktion DDERequest gibt eine Zeichenfolge vom Datentyp Variant zurück, die die angeforderten Informationen enthält, wenn die Anforderung erfolgreich war.

Die Daten werden im alphanumerischen Textformat angefordert. Bilder oder Text in einem anderen Format können nicht übertragen werden.

Wenn Kanalnummer keine Ganzzahl ist, die einem geöffneten Kanal entspricht, oder wenn die angeforderten Daten nicht übertragen werden können, tritt ein Laufzeitfehler auf.

Tipp Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


 DDESend-Funktion (DDESenden)

DDESend-Funktion (DDESenden)

Mit der DDESend-Funktion können Sie einen Dynamischen Datenaustausch (DDE) mit einer anderen Anwendung initiieren und ein Informationselement an diese Anwendung senden, das aus einem Steuerelement in einem Formular oder Bericht stammt.

Sie können die DDESend-Funktion z. B. in der Steuerelementinhalt-Eigenschaft eines Textfeldes zum Senden der im Textfeld angezeigten Daten an eine bestimmte Zelle in einer Microsoft Excel-Tabelle verwenden.

Syntax

DDESend(Anwendung, Thema, Element, Daten)

Die DDESend-Funktion hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Ein Zeichenfolgenausdruck, der eine Anwendung angibt, die an einem DDE-Datenaustausch teilnehmen kann. Normalerweise ist Anwendung der Name einer .EXE-Datei (ohne die Erweiterung .EXE) einer auf Microsoft Windows basierenden Anwendung, wie z. B. Microsoft Excel. Um beispielsweise einen DDE-Datenaustausch mit Microsoft Excel zu initieren, geben Sie "Excel" als Argument Anwendung ein.
Thema | Ein Zeichenfolgenausdruck, der den Namen eines Themas angibt, das von Anwendung erkannt wird. Das Argument Thema ist häufig ein Dokument oder eine Datendatei. Eine Liste der Themen finden Sie in der Dokumentation der Anwendung.
Element | Ein Zeichenfolgenausdruck, der den Namen eines Datenelements enthält, das von Anwendung erkannt wird. Eine Liste der Elemente finden Sie in der Dokumentation der Anwendung.
Daten | Eine Zeichenfolge oder ein Ausdruck mit den Daten, die an Anwendung gesendet werden.

Anmerkungen

Die DDESend-Funktion initiiert einen DDE-Datenaustausch mit Anwendung und Thema und identifiziert Element als das Datenelement, das die Daten empfangen wird. Wenn Anwendung z. B. Microsoft Excel ist, kann Thema "Blatt1" und Element eine Zeilen-/Spaltenkennung wie z. B. "R1C1" oder der Name eines Zellbereichs sein.

Das Argument Daten bezeichnet die Informationen, die Sie senden möchten. Dies kann eine Literalzeichenfolge, wie z. B. "Johns Bericht", oder ein Ausdruck sein, der das Ergebnis einer Funktion enthält, die eine Zeichenfolge erstellt, wie z. B. "Angefertigt am" & Datum(). Wenn Element auf mehr als ein Informationselement verweist, wie z. B. auf einen Bereich in einer Microsoft Excel-Kalkulationstabelle, die mehrere Zellen enthält, sendet die DDESend-Funktion die Daten an den ersten Eintrag.

Im folgenden Beispiel sendet die DDE-Funktion die Zeichenfolge "Ein Text" an die Zelle in Zeile1, Spalte 1 in einer Microsoft Excel-Tabelle. Sie können diesen Ausdruck für ein Textfeld-Steuerelement im Eigenschaftenfeld Steuerelementinhalt im Eigenschaftenblatt des Steuerelements eingeben:

=DDESend("Excel", "Tabelle1", "R1C1", "Ein Text")

Angenommen, Sie möchten Daten aus einem gebundenen Steuerelement in einem Microsoft Access-Formular an eine Zelle in einer Microsoft Excel-Tabelle senden. Die Steuerelementinhalt-Eigenschaft des gebundenen Steuerelements enthält bereits einen Feldnamen oder Ausdruck. Sie können ein weiteres Textfeld oder Kombinationsfeld erstellen und für dessen Steuerelementinhalt-Eigenschaft einen Ausdruck festlegen, der die DDESend-Funktion beinhaltet, wobei Daten der Name des gebundenen Steuerelements ist. Wenn Sie z. B. ein gebundenes Textfeld namens Nachname haben, können Sie ein weiteres Textfeld erstellen und für dessen Steuerelementinhalt-Eigenschaft Folgendes einstellen:

=DDESend("Excel", "Tabelle1", "R1C1", [Nachname])

Dieses Übergangssteuerelement muss entweder ein Textfeld oder ein Kombinationsfeld sein. Sie können den Namen eines gebundenen Steuerelements nicht als Argument Daten für ein Kontrollkästchen oder eine Optionsgruppe verwenden.

Sie können die DDESend-Funktion nur in der Einstellung der Steuerelementinhalt-Eigenschaft eines Textfeldes, einer Optionsgruppe, eines Kontrollkästchens oder eines Kombinationsfeldes in einem Formular verwenden. Sie können die DDESend-Funktion nicht aus Visual Basic heraus aufrufen.

Wenn Sie die DDESend-Funktion verwenden, wird das Steuerelement in der Formularansicht und der Seitenansicht schreibgeschützt. Da auch die Steuerelementinhalt-Eigenschaft in der Formularansicht und der Seitenansicht schreibgeschützt ist, müssen Änderungen am Steuerelement in der Formularentwurfsansicht vorgenommen werden.

Microsoft Windows sowie der Hauptspeicher und die Ressourcen Ihres Computers legen fest, wie viele DDE-Datenaustauschverbindungen maximal gleichzeitig geöffnet sein können. Wenn ein Austausch nicht initiiert werden kann, weil Anwendung nicht ausgeführt oder Thema nicht erkannt wird, oder weil die maximale Anzahl an Austauschverbindungen bereits erreicht ist, gibt die DDESend-Funktion eine Null zurück.

Anmerkung Die andere Anwendung ist möglicherweise so konfiguriert, dass sie Ihre Anfragen für einen DDE-Datenaustausch ignoriert. Wenn dies der Fall ist, gibt DDE eine Null zurück. Ebenso können Sie auch für Microsoft Access festlegen, dass Anforderungen von anderen Anwendungen ignoriert werden. Dazu klicken Sie im Menü Extras auf Optionen und wählen auf der Registerkarte Weitere unter DDE-Operationen die Option DDE-Anfragen ignorieren.

Tipp Wenn Sie Objekte aus der anderen Anwendung in Microsoft Access ändern müssen, können Sie u. U. auch Automatisierung verwenden.

Die folgende Tabelle illustriert das Verhalten der DDESend-Funktion bei Verwendung mit den einzelnen Steuerelementen.

Steuerelement Anmerkungen
Textfeld oder Kombinationsfeld Da das Textfeld oder Kombinationsfeld in der Formularansicht und der Seitenansicht leer angezeigt wird, möchten Sie u. U. für dessen Sichtbar-Eigenschaft die Einstellung Falsch festlegen.

Das Argument Daten kann auf ein anderes Steuerelement verweisen. Das folgende Beispiel zeigt, wie Sie den Inhalt eines Steuerelements Nachname an eine Microsoft Excel-Kalkulationstabelle senden:

=DDESend("Excel", "Tabelle1", "R1C1", [Nachname])
Optionsgruppe Keines der Optionsfelder einer Optionsgruppe wird in der Formularansicht und der Seitenansicht ausgewählt. Sie können daher die Optionsgruppe (und ihre Optionsfelder) ausblenden, indem Sie für die Sichtbar-Eigenschaft der Gruppe die Einstellung Falsch festlegen.

Das Argument Daten muss nummerische Daten, wie z. B. "2" enthalten. Wenn das Argument Daten nicht nummerisch ist, sendet die DDESend-Funktion die Informationen nicht und Element wird nicht geändert.
Kontrollkästchen Das Kontrollkästchen ist in der Formularansicht und der Seitenansicht abgeblendet. Sie können daher für dessen Sichtbar-Eigenschaft die Einstellung Falsch festlegen.

Das Argument Daten muss nummerische Daten, wie z. B. "2" enthalten. Wenn das Argument Daten nicht nummerisch ist, sendet die DDESend-Funktion die Informationen nicht und Element wird nicht geändert.


 DFirst-, DLast-Funktionen (DomErsterWert, DomLetzterWert)

DFirst-, DLast-Funktionen (DomErsterWert, DomLetzterWert)

Mit den DFirst und DLast-Funktionen können Sie einen zufälligen Wert eines bestimmten Feldes in einer Tabelle oder einer Abfrage zurückgeben, wenn Sie einen beliebigen Wert aus diesem Feld benötigen. Sie können die beiden Funktionen in einem Makro, einem Modul, einem Abfrageausdruck oder in einem berechneten Steuerelement eines Formulars oder Berichts verwenden.

Syntax

DFirst(Ausdr, Domäne[, Kriterien])

DLast(Ausdr, Domäne[, Kriterien])

Die Funktionen DFirst und DLast verwenden die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld kennzeichnet, von dem Sie den ersten oder letzten Wert ermitteln möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den die Funktion DFirst oder DLast ausgeführt wird. Das Argument Kriterien ist z. B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnen DFirst und DLast das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst geben DFirst und DLast den Wert Null zurück.

Anmerkung

Wenn Sie den ersten oder letzten Datensatz einer Gruppe von Datensätzen (Domaine) zurückgeben möchten, sollten Sie eine als "Aufsteigend" oder "Absteigend" sortierte Abfrage erstellen und die Eigenschaft TopValues auf 1 einstellen. Weitere Informationen finden Sie im Thema zur Eigenschaft TopValues. Aus Visual Basic können Sie auch ein Recordset-Objekt erstellen und die Methoden MoveFirst oder MoveLast verwenden, um den ersten oder letzten Datensatz einer Gruppe von Datensätzen zurückzugeben.


 DLookup-Funktion (DomWert)

DLookup-Funktion (DomWert)

Mit der DLookup-Funktion können Sie den Wert eines bestimmten Feldes aus einer bestimmten Datensatzgruppe (einer Domäne) abrufen. Verwenden Sie die DLookup-Funktion in Visual Basic, einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement in einem Formular oder Bericht.

Mit der DLookup-Funktion können Sie einen Wert eines Feldes anzeigen, das sich nicht in der Datenquelle Ihres Formulars oder Berichts befindet. Angenommen, Sie haben ein Formular auf der Basis der Tabelle Bestelldetails. Das Formular zeigt die Felder Bestell-Nr, Artikel-Nr, Einzelpreis und Rabatt an. Das Feld Artikelname befindet sich jedoch in einer anderen Tabelle, der Tabelle Artikel. Mit der DLookup-Funktion können Sie jetzt im gleichen Formular in einem berechneten Steuerelement den Artikelnamen anzeigen.

Syntax

DLookup(Ausdr, Domäne[, Kriterien])

Die DLookup-Funktion hat die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld kennzeichnet, dessen Werte Sie zurückgeben möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder einer Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können in das Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen der Tabelle oder um den Namen der Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den die DLookup-Funktion ausgeführt wird. Das Argument Kriterien ist z. B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnet DLookup das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst gibt DLookup den Wert Null zurück.

Anmerkungen

Die DLookup-Funktion gibt einen einzelnen Feldwert auf der Basis der in Kriterien festgelegten Informationen zurück. Obwohl Kriterien ein optionales Argument ist, sollten Sie dieses angeben, da DLookup sonst einen Zufallswert aus der Domäne zurückgibt.

Wenn kein Datensatz die Kriterien erfüllt, oder wenn Domäne keine Datensätze enthält, gibt DLookup eine Null zurück.

Wenn mehrere Felder die Kriterien erfüllen, gibt die DLookup-Funktion das erste dieser Felder zurück. Geben Sie Kriterien an, die sicherstellen, dass der von DLookup zurückgegebene Feldwert eindeutig ist. Sie können für Ihre Kriterien auch einen Primärschlüsselwert verwenden, wie z. B. [Personal-Nr] im folgenden Beispiel, um sicherzustellen, dass DLookup einen eindeutigen Wert zurückgibt:

Dim varX As Variant
varX = DLookup("[Nachname]", "Personal", "[Personal-Nr] = 1")

Gleich, ob Sie die DLookup-Funktion in einem Makro oder Modul, in einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, Sie müssen das Argument Kriterien sehr sorgfältig angeben, um sicherzustellen, dass es korrekt ausgewertet wird.

Sie können die DLookup-Funktion zum Festlegen von Kriterien in der Zeile Kriterien einer Abfrage, in einem berechneten Feldausdruck einer Abfrage oder in der Zeile Aktualisieren in einer Aktualisierungsabfrage verwenden.

Sie können die DLookup-Funktion auch in einem Ausdruck in einem berechneten Steuerelement eines Formulars oder Berichtes verwenden, wenn das Feld, das Sie anzeigen möchten, sich nicht in der Datenquelle befindet, auf der Ihr Formular oder Bericht basiert. Angenommen, Sie haben ein Formular Bestelldetails, das auf der Tabelle Bestelldetails basiert, mit einem Textfeld Artikel-Nr, das das Feld Artikel-Nr anzeigt. Zum Nachschlagen eines Artikelnamens aus der Tabelle Artikel, der auf dem Wert im Textfeld basiert, können Sie ein weiteres Textfeld erstellen und für dessen Steuerelementinhalt-Eigenschaft den folgenden Ausdruck festlegen:

=DLookup("[Artikelname]", "Artikel", "[Artikel-Nr] =" _
     & Formulare![Bestelldetails]![Artikel-Nr])

Tipps

  • Obwohl Sie die DLookup-Funktion auch zum Anzeigen eines Wertes aus einem Feld in einer Fremdtabelle verwenden können, ist es u. U. effizienter, eine Abfrage zu erstellen, die die benötigten Felder aus beiden Tabellen enthält, und Ihrem Formular oder Bericht dann diese Abfrage zugrunde zu legen.

  • Sie können zum Suchen nach Werten in einer Fremdtabelle auch den Nachschlage-Assistenten verwenden.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die nicht gespeichert sind, werden bei dieser Funktion nicht berücksichtigt. Wenn die DLookup-Funktion die geänderten Werte einbeziehen soll, müssen Sie die Änderungen erst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen und den Fokus auf einen anderen Datensatz setzen oder indem Sie die Update-Methode verwenden.


 DMin-, DMax-Funktionen (DomMin, DomMax)

DMin-, DMax-Funktionen (DomMin, DomMax)

Mit den Funktionen DMin und DMax können Sie den kleinsten und größten Wert in einer angegebenen Datensatzgruppe (Domäne) ermitteln. Verwenden Sie DMin und DMax in Visual Basic, in einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement.

Sie können z.B. DMin und DMax in berechneten Steuerelementen in einem Bericht verwenden, um die größten und kleinsten Bestellmengen eines bestimmten Kunden anzuzeigen. Sie können DMin auch in einem Abfrageausdruck verwenden, um alle Bestellungen mit einem größeren als dem kleinstmöglichen Rabatt anzuzeigen.

Syntax

DMin(Ausdr, Domäne[, Kriterien])

DMax(Ausdr, Domäne[, Kriterien])

Die Funktionen DMin und DMax verwenden die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld kennzeichnet, von dem Sie den kleinsten oder größten Wert ermitteln möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunkionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen der Tabelle oder um den Namen der Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den DMin oder DMax ausgeführt wird. Das Argument Kriterien ist z.B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnen DMin und Dmax das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst geben DMin und DMax den Wert Null zurück.

Anmerkung

DMin und DMax geben den kleinsten und den größten Wert zurück, der die Bedingung im Argument Kriterien erfüllt. Gibt das Argument Ausdr numerische Daten an, so geben DMin und DMax numerische Werte zurück. Gibt das Argument Ausdr Zeichenfolgendaten an, so wird die Zeichenfolge zurückgegeben, die alphabetisch an erster oder letzter Stelle steht.

DMin und DMax ignorieren Null-Werte in dem Feld, das durch das Argument Ausdr angegeben wird. Erfüllt allerdings kein Datensatz die Bedingung im Argument Kriterien, oder enthält das Argument Domäne keine Datensätze, so geben DMin und DMax den Wert Null zurück.

Unabhängig davon, ob Sie DMin oder DMax in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen und dafür sorgen, dass es korrekt ausgewertet wird.

Sie können DMin und DMa) verwenden, um die Kriterien in der Zeile Kriterien einer Abfrage, in einem berechneten Feldausdruck in einer Abfrage oder in der Zeile Aktualisieren einer Aktualisierungsabfrage anzugeben.

Anmerkung Sie können DomMin und DomMax (DMin und DMax) oder die Funktionen Min und Max in einem berechneten Feldausdruck in einer Berechnungsabfrage verwenden. Wenn Sie DMin und Dmax verwenden, werden die Werte ausgewertet, bevor die Daten gruppiert werden. Verwenden Sie Min oder Max, so werden die Daten gruppiert, bevor der Wert im Feldausdruck ausgewertet wird.

Verwenden Sie DMin oder DMax in einem berechneten Steuerelement, wenn Sie Kriterien festlegen müssen, um den Datenbereich einzuschränken, auf dem die Funktion ausgeführt wird. Wenn Sie z.B. die höchsten Frachtkosten anzeigen möchten, die für eine nach Kalifornien versandte Bestellung berechnet wurden, legen Sie die Eigenschaft ControlSource eines Textfelds auf den folgenden Ausdruck fest.

= DomMax("[Frachtkosten]"; "Bestellungen"; "[Region] = 'CA'")

Möchten Sie einfach nur den kleinsten oder größten Wert aller Datensätze der im Argument Domäne angegebenen Domäne finden, so verwenden Sie die Funktion Min oder Max.

Sie können DMin oder DMax in einem Modul, einem Makro oder einem berechneten Steuerelement eines Formulars verwenden, wenn sich das Feld, das Sie anzeigen möchten, nicht in der Datenherkunft befindet, die Ihrem Formular zugrunde liegt.

Tipp Obwohl Sie DMin oder DMax verwenden können, um den kleinsten oder größten Wert in einem Feld einer Fremdtabelle zu finden, kann es effizienter sein, eine Abfrage zu erstellen, die die benötigten Felder aus beiden Tabellen enthält, und dann Ihrem Formular oder Bericht diese Abfrage zugrundezulegen.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die noch nicht gespeichert sind, werden von diesen Funktionen nicht berücksichtigt. Wenn die Funktionen DMin oder DMax auf den geänderten Werten basieren sollen, müssen Sie die Änderungen erst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen, den Fokus auf einen anderen Datensatz setzen oder die Methode Update ausführen.


 DStDev-, DStDevP-Funktionen (DomStAbw, DomStAbwG)

DStDev-, DStDevP-Funktionen (DomStAbw, DomStAbwG)

Mit den Funktionen DStDev und DStDevP können Sie die Standardabweichung einer Gruppe von Werten in einer bestimmten Datensatzgruppe (Domäne) ermitteln. Verwenden Sie DStDev und DStDevP in einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement in einem Formular oder Bericht.

Verwenden Sie DStDev, um eine Population auszuwerten, und DStDevP, um eine Populationsstichprobe auszuwerten.

Sie können z.B. die Funktion DStDev in einem Modul verwenden, um die Standardabweichung einer Gruppe von Testergebnissen von Studenten zu berechnen.

Syntax

DStDev(Ausdr, Domäne[, Kriterien])

DStDevP(Ausdr, Domäne[, Kriterien])

Die Syntax der Funktionen DStDev und DStDevP enthält die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das numerische Feld kennzeichnet, aus dem die Standardabweichung berechnet werden soll. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunkionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen der Tabelle oder um den Namen der Abfrage handeln.
Kriterien | Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für denDStDev oder DStDevP ausgeführt wird. Das Argument Kriterien ist z.B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnen DStDev und DStDevP das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst geben DStDev und DStDevP den Wert Null zurück.

Anmerkung

Bezieht sich das Argument Domäne auf weniger als zwei Datensätze, oder erfüllen weniger als zwei Datensätze die Bedingungen im Argument Kriterien, so geben DStDev und DStDevP den Wert Null zurück, um anzuzeigen, dass eine Standardabweichung nicht berechnet werden kann.

Unabhängig davon, ob Sie die Funktion DStDev oder DStDevP in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen und dafür sorgen, dass es korrekt ausgewertet wird.

Mit den Funktionen DStDev und DStDevP können Sie Kriterien in der Zeile Kriterien einer Auswahlabfrage festlegen. Sie können z.B. eine Abfrage auf der Tabelle Bestellungen und der Tabelle Artikel erstellen, um die Artikel anzuzeigen, bei denen die Frachtkosten über dem Mittelwert zuzüglich Standardabweichung für Frachtkosten liegen. Die Zeile Kriterien unter dem Feld Frachtkosten würde dann den folgenden Ausdruck enthalten:

> (DomStAbw("[Frachtkosten]"; "Bestellungen") + _
    DomMittelwert("[Frachtkosten]"; "Bestellungen"))

Sie können DStDev und DStDevP innerhalb eines berechneten Feldausdrucks in einer Abfrage oder in der Zeile Aktualisieren einer Aktualisierungsabfrage verwenden.

Anmerkung Sie können DStDev und DStDevP oder StDev und StDevP in einem berechneten Feldausdruck in einer Berechnungsabfrage verwenden. Wenn Sie DStDev oder DStDevP verwenden, werden die Werte berechnet, bevor die Daten gruppiert werden. Wenn Sie StDev oder StDevP verwenden, werden die Daten gruppiert, bevor die Werte im Feldausdruck ausgewertet werden.

Verwenden Sie DStDev und DStDevP in einem berechneten Steuerelement, wenn Sie das Argument Kriterien angeben möchten, um den Datenbereich einzuschränken, auf dem die Funktion ausgeführt wird. Wenn Sie z.B. die Standardabweichung von Bestellungen anzeigen möchten, die nach Kalifornien versendet werden sollen, legen Sie die Eigenschaft ControlSource eines Textfelds auf den folgenden Ausdruck fest:

= DomStAbw("[Frachtkosten]"; "Bestellungen"; "[Region] = 'CA'")

Möchten Sie lediglich die Standardabweichung aller Datensätze einer Domäne ermitteln, so verwenden Sie die Funktion StAbw oder StAbwG (StDev oder StDevP).

Tipp Wenn der Datentyp des Feldes, von dem das Argument Ausdr stammt, eine Zahl ist, geben DStDev und DStDevP den Datentyp Double zurück. Wenn Sie DStDev oder DStDevP in einem berechneten Steuerelement verwenden, fügen Sie eine Datentyp-Konvertierungsfunktion in den Ausdruck ein, um das Leistungsverhalten zu verbessern.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die noch nicht gespeichert sind, werden von diesen Funktionen nicht berücksichtigt. Wenn die Funktionen DStDev oder DStDevP auf den geänderten Werten basieren sollen, müssen Sie die Änderungen erst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen, den Fokus auf einen anderen Datensatz setzen oder die Methode Update ausführen.


 DSum-Funktion (DomSumme)

DSum-Funktion (DomSumme)

Mit der Funktion DSum können Sie die Summe einer Gruppe von Werten in einer bestimmten Datensatzgruppe (Domäne) berechnen. Verwenden Sie DSum in Visual Basic, in einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement.

Sie können z.B. die Funktion DSum in einem berechneten Feldausdruck in einer Abfrage verwenden, um den Gesamtumsatz zu berechnen, den ein bestimmter Angestellter in einem Zeitraum gemacht hat. Sie können die Funktion DSum auch in einem berechneten Steuerelement verwenden, um die laufenden kumulierten Umsätze eines bestimmten Produkts anzuzeigen.

Syntax

DSum(Ausdr, Domäne[, Kriterien])

Die Funktion DSum verwendet die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das Feld mit den numerischen Daten kennzeichnet, dessen Werte Sie aufsummieren möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck, der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen sind jedoch nicht zulässig.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen der Tabelle oder um den Namen der Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den DSum ausgeführt wird. Das Argument Kriterien ist z.B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnet DSum das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst gibt DSum den Wert Null zurück.

Anmerkung

Erfüllt kein Datensatz die Bedingungen im Argument Kriterien, oder enthält die Domäne keine Datensätze, so gibt die Funktion DSum den Wert Null zurück.

Unabhängig davon, ob Sie DSum in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen und dafür sorgen, dass es korrekt ausgewertet wird.

Mit DSum können Sie die Kriterien in der Zeile Kriterien in einer Abfrage, in einem berechneten Feld in einem Abfrageausdruck oder in der Zeile Aktualisierung bei einer Aktualisierungsabfrage festlegen.

Anmerkung Sie können entweder DSum oder Sum in einem berechneten Feldausdruck in einer Berechnungsabfrage verwenden. Wenn Sie DSum verwenden, werden die Werte berechnet, bevor die Daten gruppiert werden. Wenn Sie die Funktion Sum verwenden, werden die Daten gruppiert, bevor die Werte im Feldausdruck ausgewertet werden.

Sie sollten DSum verwenden, wenn Sie die Summe einer Gruppe von Werten, die sich nicht in der Datenherkunft Ihres Berichts befindet, anzeigen möchten. Nehmen Sie z.B. an, ein Formular zeigt Informationen über ein bestimmtes Produkt an. Sie können DSum verwenden, um die Zwischensummen der Umsätze mit diesem Produkt in einem berechneten Steuerelement anzuzeigen.

Tipp Wenn Sie eine Zwischensumme in einem Steuerelement auf einem Bericht anzeigen möchten, können Sie die Eigenschaft RunningSum des Steuerelements verwenden, wenn das dem Steuerelement zugrunde liegende Feld in der Datenherkunft des Berichts enthalten ist. Verwenden Sie DSum, um eine Zwischensumme in einem Formular anzuzeigen.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die nicht gespeichert sind, werden bei dieser Funktion nicht berücksichtigt. Wenn die Funktion DSum die geänderten Werte einbeziehen soll, müssen Sie die Änderungen erst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen, den Fokus auf einen anderen Datensatz setzen oder die Methode Update verwenden.


 DVar-, DVarP-Funktionen (DomVarianz, DomVarianzen)

DVar-, DVarP-Funktionen (DomVarianz, DomVarianzen)

Mit den Funktionen DVar und DVarP können Sie die Varianz einer Gruppe von Werten in einer angegebenen Datensatzgruppe (Domäne) abschätzen. Verwenden Sie DVar und DVarP in Visual Basic, in einem Makro, einem Abfrageausdruck oder einem berechneten Steuerelement in einem Formular oder Bericht.

Verwenden Sie DVarP, um die Varianz einer Population zu ermitteln, und verwenden Sie DVar, um die Varianz einer Populationsstichprobe zu ermitteln.

Sie können z.B. DVar verwenden, um die Varianz einer Gruppe von Testergebnissen von Studenten zu ermitteln.

Syntax

DVar(Ausdr, Domäne[, Kriterien])

DVarP(Ausdr, Domäne[, Kriterien])

Die Funktionen DVar und DVarP verwenden die folgenden Argumente.

Argument | Beschreibung
Ausdr | Ein Ausdruck, der das numerische Feld kennzeichnet, für dessen Werte Sie die Varianz ermitteln möchten. Der Ausdruck kann ein Zeichenfolgenausdruck sein, der ein Feld in einer Tabelle oder Abfrage kennzeichnet, oder ein Ausdruck , der eine Berechnung mit Daten in dem Feld durchführt. Sie können im Argument Ausdr den Namen eines Tabellenfelds, eines Steuerelements in einem Formular, einer Konstanten oder einer Funktion einbeziehen. Enthält das Argument Ausdr eine Funktion, so kann dies entweder eine eingebaute oder eine benutzerdefinierte Funktion sein; Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen sind jedoch nicht zulässig. Jedes in Ausdr enthaltene Feld muss ein numerisches Feld sein.
Domäne | Ein Zeichenfolgenausdruck, der die Gruppe der Datensätze kennzeichnet, die die Domäne bilden. Es kann sich hierbei um den Namen der Tabelle oder um den Namen der Abfrage handeln.
Kriterien | Ein Zeichenfolgenausdruck, den Sie optional angeben können, um den Datenbereich einzuschränken, für den die Funktion oder DVar oder DvarP ausgeführt wird. Das Argument Kriterien ist z.B. oft gleichbedeutend mit der WHERE-Klausel in einem SQL-Ausdruck (ohne das Wort WHERE). Wird das Argument Kriterien nicht angegeben, so berechnen DVar oder DVarP das Argument Ausdr für die gesamte Domäne. Jedes Feld, das im Argument Kriterien enthalten ist, muss auch ein Feld des Arguments Domäne sein, sonst geben DVar oder DVarP den Wert Null zurück.

Anmerkung

Bezieht sich das Argument Domäne auf weniger als zwei Datensätze, oder erfüllen weniger als zwei Datensätze das Argument Kriterien, so geben DVar und DVarP den Wert Null zurück, um anzuzeigen, dass keine Varianz berechnet werden kann.

Unabhängig davon, ob Sie DVar oder DVarP in einem Makro, einem Modul, einem Abfrageausdruck oder einem berechneten Steuerelement verwenden, müssen Sie das Argument Kriterien sehr sorgfältig erstellen und dafür sorgen, dass es korrekt ausgewertet wird.

Sie können DVar und DVarP verwenden, um die Kriterien in der Zeile Kriterien einer Auswahlabfrage, in einem berechneten Feldausdruck in einer Abfrage oder in der Zeile Aktualisieren einer Aktualisierungsabfrage festzulegen.

Anmerkung Sie können DVar und DVarP oder Var und VarP in einem berechneten Feldausdruck in einer Berechnungsabfrage verwenden. Wenn Sie DVar oder DVarP verwenden, werden die Werte berechnet, bevor die Daten gruppiert werden. Wenn Sie Var oder VarP verwenden, werden die Daten gruppiert, bevor die Werte im Feldausdruck ausgewertet werden.

Verwenden Sie DVar und DVarP in einem berechneten Steuerelement, wenn Sie das Argument Kriterien festlegen müssen, um den Datenbereich einzuschränken, auf dem die Funktion ausgeführt wird. Wenn Sie z.B. die Varianz der Bestellungen anzeigen möchten, die nach Kalifornien versendet werden sollen, legen Sie die Eigenschaft ControlSource eines Textfelds auf den folgenden Ausdruck fest:

= DVarianz("[Frachtkosten]"; "Bestellungen"; "[Region] = 'CA'")

Möchten Sie lediglich die Standardabweichung aller Datensätze im Argument Domäne ermitteln, so verwenden Sie Var oder VarP.

Anmerkung Änderungen von Datensätzen im Argument Domäne, die noch nicht gespeichert sind, werden von diesen Funktionen nicht berücksichtigt. Wenn die Funktionen DVar oder DVarP die geänderten Werte einbeziehen sollen, müssen Sie die Änderungen erst speichern, indem Sie aus dem Menü Datei den Befehl Datensatz speichern wählen, den Fokus auf einen anderen Datensatz setzen oder die Methode Update ausführen.


 EuroConvert-Funktion

EuroConvert-Funktion

Sie können die EuroConvert-Funktion verwenden, um eine Zahl in Euro oder von Euro in eine beteiligte Währung umzuwandeln. Sie können die Funktion außerdem verwenden, um eine Zahl aus einer beteiligten Währung in eine andere umzuwandeln, indem Sie den Euro als Zwischenwert verwenden (Triangulieren). Die EuroConvert-Funktion verwendet feste Wechselkurse, die von der EU (Europäische Union) festgelegt wurden.

Syntax

EuroConvert(number, sourcecurrency, targetcurrency[, fullprecision, triangulationprecision])

Argument | Beschreibung
number | Die Zahl, die Sie umwandeln möchten oder eine Referenz auf ein Feld, das die Zahl enthält.
sourcecurrency | Ein Zeichenfolgenausdruck oder eine Referenz auf ein Feld, das die Zeichenfolge enthält, die mit den ISO (International Standards Organization)-Abkürzungen für die Währung übereinstimmen muss, die umgewandelt werden soll. In der folgenden Tabelle werden einige ISO-Codes aufgeführt.
 | Währung | ISO-Code |  | Berechnungsgenauigkeit | Anzeigegenauigkeit
 | Belgische Franc | BEF |  | 0 | 0
 | Luxemburgische Franc | LUF |  | 0 | 0
 | Deutsche Mark | DEM |  | 2 | 2
 | Spanische Peseten | ESP |  | 0 | 0
 | Französische Franc | FRF |  | 2 | 2
 | Irisches Pfund | IEP |  | 2 | 2
 | Italienische Lire | ITL |  | 0 | 0
 | Niederländische Gulden | NLG |  | 2 | 2
 | Österreichische Schilling | ATS |  | 2 | 2
 | Portugiesische Escudos | PTE |  | 1 | 2
 | Finnische Mark | FIM |  | 2 | 2
 | Euro | EUR |  | 2 | 2
 | In der vorhergehenden Tabelle legt die Berechnungsgenauigkeit fest, auf welche Währungseinheit das Ergebnis, basierend auf der Umwandlungsgenauigkeit, gerundet wird. Wenn Sie beispielsweise in Deutsche Mark umwandeln, ist die Berechnungsgenauigkeit 2, und das Ergebnis wird auf den nächsten Pfennig gerundet, wobei eine Mark aus hundert Pfennig besteht. Die Anzeigegenauigkeit legt fest, wie viele Dezimalstellen in dem Ergebnisfeld angezeigt werden.
 | Neuere Versionen der EuroConvert-Funktion unterstützen eventuell zusätzliche Währungen. Weitere Informationen über neue, beteiligte Währungen und Aktualisierungen der EuroConvert-Funktion, erhalten Sie unter Unterstützung für den Euro in Microsoft Windows 95 und Windows NT 4.0.
 | Währung |  | ISO-Code
 | Dänische Kronen |  | DKK
 | Griechische Drachmen |  | GRD
 | Schwedische Kronen |  | SEK
 | Britisches Pfund Sterling |  | GBP
targetcurrency | Ein Zeichenfolgenausdruck oder eine Referenz auf ein Feld, das die Zeichenfolge enthält, die mit dem ISO-Code der Währung übereinstimmen muss, in die die Zahl umgewandelt werden soll. Eine Liste der ISO-Codes finden Sie unter der Argumentbeschreibung von sourcecurrency.
fullprecision | Optional. Ein Boolean-Wert, bei dem Wahr (1) die währungsspezifischen Rundungsvorschriften ignoriert (genannt "Anzeigegenauigkeit" in der Argumentbeschreibung von sourcecurrency) und den Umwandlungsfaktor mit 6 signifikanten Ziffern ohne anschließende Rundung verwendet. Falsch (0) verwendet die währungsspezifischen Rundungsvorschriften, um das Ergebnis anzuzeigen. Wird der Parameter nicht angegeben, ist der Standardwert Falsch.
triangulationprecision | Optional. Ein Integer-Wert größer als oder gleich 3, der die Anzahl der signifikanten Ziffern in der Berechnungsgenauigkeit festlegt, die für den Euro-Zwischenwert verwendet wird, wenn zwischen zwei nationalen Währungen umgewandelt wird.

Anmerkungen

Nachfolgende Nullen werden abgeschnitten und bei ungültigen Parametern wird #Fehler zurückgegeben.

Wenn der ISO-Quellcode derselbe ist wie der ISO-Zielcode, wird der Originalwert der Zahl aktiviert.

Diese Funktion übernimmt kein Format.

Die EuroConvert-Funktion verwendet die aktuellen Kurse, die von der EU (Europäische Union) festgelegt wurden. Wenn sich die Kurse ändern, wird Microsoft die Funktion aktualisieren. Alle Informationen über die derzeit gültigen Vorschriften und Kurse erhalten Sie aus den Veröffentlichungen der Europäischen Kommission zum Euro. Besuchen Sie die Microsoft Office Euro Currency-Website, um diese Veröffentlichungen zu erhalten; Unterstützung für den Euro in Microsoft Windows 95 und Windows NT 4.0.

Beispiele

Das erste Beispiel wandelt 1,20 Deutsche Mark in einen Euro-Wert (Antwort = 0,61) um. Das zweite Beispiel wandelt 1,47 Französische Franc in Deutsche Mark um (Antwort = 0,44 DM). Sie setzen Wechselkurse von 1 Euro = 6,55858 Französische Franc und 1,92974 Deutsche Mark voraus.

EuroConvert(1.20,"DEM","EUR")
EuroConvert(1.47,"FRF","DEM",TRUE,3)


 Eval-Funktion (Auswerten)

Eval-Funktion (Auswerten)

Mit der Funktion Eval können Sie einen Ausdruck auswerten, der als Ergebnis eine Textzeichenfolge oder einen numerischen Wert liefert.

Sie können z. B. eine Zeichenfolge erstellen und diese dann an die Funktion Eval übergeben, als handele es sich bei der Zeichenfolge um einen tatsächlichen Ausdruck. Die Funktion Eval wertet den Zeichenfolgenausdruck aus und gibt dessen Wert zurück. So gibt Eval("1 + 1") z. B. den Wert 2 zurück.

Wenn Sie der Funktion Eval eine Zeichenfolge übergeben, die den Namen einer Funktion enthält, gibt Eval den Rückgabewert der Funktion zurück. So gibt Eval("Chr$(65)") z. B. "A" zurück.

Syntax

Eval(Zeichenfolgenausdruck)

Das Argument Zeichenfolgenausdruck ist ein Ausdruck, der eine alphanumerische Textzeichenfolge ergibt. Zeichenfolgenausdruck kann z. B. eine Funktion sein, die eine Zeichenfolge oder einen numerischen Wert zurückgibt. Das Argument kann aber auch ein Verweis auf ein Steuerelement eines Formulars sein. Das Argument Zeichenfolgenausdruck muss eine Zeichenfolge oder einen numerischen Wert bereitstellen; es darf kein Microsoft Access-Objekt ergeben.

Anmerkung Wenn Sie den Namen einer Funktion an die Funktion Eval übergeben, müssen Sie im Argument Zeichenfolgenausdruck ein Klammernpaar hinter den Namen der Funktion setzen. Z. B.:

' NamenAnzeigen ist eine benutzerdefinierte Funktion.
Debug.Print Eval("NamenAnzeigen()")
Debug.Print Eval("StrComp(""Helga"",""helga"", 1)")
Debug.Print Eval("Date()")

Bemerkungen

Sie können die Funktion Eval in einem berechneten Steuerelement eines Formulars oder Berichts oder auch in einem Makro oder Modul verwenden. Die Funktion Eval gibt einen Wert vom Datentyp Variant zurück, der entweder eine Zeichenfolge oder ein numerischer Wert ist.

Das Argument Zeichenfolgenausdruck muss ein Ausdruck sein, der in einer Zeichenfolge gespeichert ist. Wenn Sie der Funktion Eval eine Zeichenfolge übergeben, die weder einen numerischen Ausdruck noch einen Funktionsnamen, sondern nur eine einfache Textzeichenfolge enthält, tritt ein Laufzeitfehler auf. So führt Eval("Schmidt") z. B. zu einem Fehler.

Mit der Funktion Eval können Sie den Wert ermitteln, der in der Eigenschaft Value eines Steuerelements gespeichert ist. Im folgenden Beispiel wird eine Zeichenfolge, die einen vollständigen Verweis auf ein Steuerelement enthält, an die Funktion Eval übergeben. Anschließend wird der aktuelle Wert des Steuerelements in einem Dialogfeld angezeigt.

Dim ctl As Control, strCtl As String
Set ctl = Formulare!Personal!Nachname
strCtl = "Formulare!Personal!Nachname"
MsgBox ("Der aktuelle Wert von " & ctl.Name & " ist " & Eval(strCtl))

Mit der Funktion Eval können Sie auf Ausdrucksoperatoren zugreifen, die normalerweise in Visual Basic nicht verfügbar sind. Sie können z. B. die SQL-Operatoren Between...And oder In nicht direkt in Ihrem Code verwenden, jedoch in einem Ausdruck, der an die Funktion Eval übergeben wird.

Im nächsten Beispiel wird ermittelt, ob der Wert des Steuerelements Region, das zu einem Formular namens Bestellungen gehört, einer angegebenen Abkürzung für einen amerikanischen Bundesstaat entspricht. Enthält das Feld eine der Abkürzungen, so ergibt intState den Wert True (-1). Sie müssen Hochkommas verwenden, um eine Zeichenfolge innerhalb einer anderen Zeichenfolge anzugeben.

Dim intState As Integer
intState = Eval("Formulare!Bestellungen![Region In] " _
    & "('AK', 'CA', 'ID', 'WA', 'MT', 'NM', 'OR')")


 GUIDFromString-Funktion

GUIDFromString-Funktion

Die Funktion GUIDFromString wandelt eine Zeichenfolge in einen GUID-Wert um. Dieser ist ein Datenfeld vom Typ Byte.

Syntax

GUIDFromString(Zeichenfolgenausdruck)

Die Funktion GUIDFromString hat folgende Argumente.

Argument | Beschreibung
Zeichenfolgenausdruck | Ein Zeichenfolgenausdruck, der zu einem als Zeichenfolge vorliegenden GUID-Wert ausgewertet wird.

Anmerkung

Die Microsoft Jet-Datenbank-Engine speichert GUIDs als Datenfelder vom Typ Byte. Microsoft Access kann jedoch keine Byte-Daten aus einem Steuerelement auf einem Formular oder Bericht zurückgeben. Um einen GUID-Wert aus einem Steuerelement zurückzugeben, wandeln Sie ihn daher in eine Zeichenfolge um. Verwenden Sie zum Umwandeln eines GUID-Werts in eine Zeichenfolge die Funktion StringFromGUID. Um eine Zeichenfolge in einen GUID-Wert umzuwandeln, verwenden Sie die Funktion GUIDFromString.


 Nz-Funktion

Nz-Funktion

Sie können die Funktion Nz verwenden, um Null, eine leere Zeichenfolge (" ") oder einen anderen festgelegten Wert zurückzugeben, wenn eine Variable des Typs Variant den Wert Null hat. Sie können diese Funktion z. B. verwenden, um einen Wert Null in einen anderen Wert umzuwandeln und so zu verhindern, dass der Wert durch einen Ausdruck verbreitet wird.

Syntax

Nz(Variant[, WertWennNull])

Die Funktion Nz hat die folgenden Argumente.

Argument | Beschreibung
Variant | Eine Variable des Datentyps Variant.
WertWennNull | Optional (wenn nicht in einer Abfrage verwendet). Eine Variable des Datentyps Variant, die einen Wert liefert, der zurückgegeben wird, falls das Argument Variant den Wert Null hat. Dieses Argument ermöglicht es Ihnen, einen Wert zurückzugeben, der ungleich 0 bzw. keine leere Zeichenfolge ist. Anmerkung Wenn Sie die Nz-Funktion in einem Ausdruck in einer Abfrage ohne das Argument WertWennNull verwenden, wird in Feldern mit Nullwerten eine leere Zeichenfolge ausgegeben.

Falls der Wert des Arguments Variant gleich Null ist, gibt die Funktion Nz die Zahl Null oder eine leere Zeichenfolge zurück (gibt immer eine leere Zeichenfolge zurück, wenn sie in einem Abfrageausdruck verwendet wird), je nachdem, ob der Kontext anzeigt, dass der Wert eine Zahl oder eine Zeichenfolge sein soll. Wenn das optionale Argument WertWennNull angegeben ist, gibt die Funktion Nz den durch dieses Argument festgelegten Wert zurück, wenn das Argument Variant den Wert Null hat. Bei Verwendung in einem Abfrageausdruck sollte die Funktion Nz immer das Argument WertWennNull verwenden.

Wenn der Wert von Variant ungleich Null ist, gibt die Funktion Nz den Wert von Variant zurück.

Anmerkung

Die Funktion Nz ist für Ausdrücke sinnvoll, die Werte Null enthalten können. Damit ein Ausdruck einen Wert liefert, der ungleich Null ist, auch wenn er einen Wert Null enthält, verwenden Sie die Funktion Nz, um eine 0, eine leere Zeichenfolge oder einen benutzerdefinierten Rückgabewert zurückzugeben.

Der Ausdruck 2 + varX gibt z. B. immer den Wert Null zurück, wenn die Variable varX den Typ Variant hat und mit Null belegt ist. Der Ausdruck 2 + Nz(varX) gibt dagegen 2 zurück.

Sie können die Funktion Nz häufig als Alternative zur Funktion IIf verwenden. So sind z. B. im folgenden Code zwei jeweils mit der Funktion IIf formulierte Ausdrücke erforderlich, um das gewünschte Ergebnis zurückzugeben. Der erste Ausdruck mit der Funktion IIf wird verwendet, um den Wert einer Variablen zu überprüfen und, sofern dieser gleich Null ist, in 0 umzuwandeln.

varTemp = IIf(IsNull(varFracht), 0, varFracht)
varErgebnis = IIf(varTemp > 50, "Hoch", "Niedrig")

Im nächsten Beispiel erledigt die Funktion Nz die gleiche Aufgabe wie der erste Ausdruck, und das gewünschte Ergebnis wird in einem Schritt statt in zwei Schritten erreicht.

varErgebnis = IIf(Nz(varFracht) > 50, "Hoch", "Niedrig")

Wenn Sie einen Wert für das optionale Argument WertWennNull angeben, wird dieser Wert zurückgegeben, wenn Variant den Wert Null hat. Durch Verwendung dieses optionalen Arguments können Sie eventuell darauf verzichten, einen Ausdruck zu verwenden, der die Funktion IIf enthält. Der folgende Ausdruck verwendet z. B. die Funktion IIf, um eine Zeichenfolge zurückzugeben, falls der Wert von varFracht gleich Null ist.

varErgebnis = IIf(IsNull(varFracht), "Keine Frachtkosten", varFracht)

Im nächsten Beispiel liefert das an die Funktion Nz übergebene optionale Argument die Zeichenfolge, die zurückgegeben werden soll, falls varFracht gleich Null ist.

varErgebnis = Nz(varFracht, "Keine Frachtkosten")


 StringFromGUID-Funktion

StringFromGUID-Funktion

Die Funktion StringFromGUID wandelt einen GUID-Wert in eine Zeichenfolge um. Ein GUID-Wert ist ein Datenfeld vom Typ Byte.

Syntax

StringFromGUID(guid)

Die Funktion StringFromGUID hat folgende Argumente.

Argument | Beschreibung
guid | Ein Datenfeld vom Typ Byte, das eine Anwendung, eine Komponente oder ein Datenelement für das Betriebssystem eindeutig identifiziert.

Anmerkung

Die Microsoft Jet-Datenbank-Engine speichert GUIDs als Datenfelder vom Typ Byte. Microsoft Access kann jedoch keine Byte-Daten aus einem Steuerelement auf einem Formular oder Bericht zurückgeben. Um einen GUID-Wert aus einem Steuerelement zurückzugeben, wandeln Sie ihn daher in eine Zeichenfolge um. Verwenden Sie zum Umwandeln eines GUID-Werts in eine Zeichenfolge die Funktion StringFromGUID. Wandeln Sie umgekehrt eine Zeichenfolge in einen GUID-Wert mit der Funktion GUIDFromString um.

Es kommt beispielsweise vor, dass Sie bei der Datenbankreplikation auf ein Feld verweisen möchten, das einen GUID-Wert enthält. Um in einem Formular den Wert eines Steuerelements zurückzugeben, das an ein Feld gebunden ist, welches einen GUID-Wert enthält, wandeln Sie den GUID-Wert mit der Funktion StringFromGUID in eine Zeichenfolge um.

Wenn Sie ein Steuerelement an das Feld s_GUID einer replizierten Tabelle binden möchten, beachten Sie, dass Sie zunächst im Menü Extras auf Optionen klicken und dann im Dialogfeld Optionen auf der Registerkarte Ansicht das Kontrollkästchen Systemobjekte aktivieren.


Verzeichnis der Methoden

Das folgende Verzeichnis gruppiert alle Methoden nach Objekt oder Auflistung und listet die Methoden in alphabetischer Reihenfolge auf. Die Methoden, die in Microsoft Access 2000 neu hinzugefügt wurden, sind mit zwei Sternchen (**) markiert.

Gruppiert nach Objekt oder Auflistung

AccessObject | AccessObjectProperties
AccessObjectProperty | AllDataAccessPages
AllDatabaseDiagrams | AllForms
AllMacros | AllModules
AllQueries | AllReports
AllStoredProcedures | AllTables
AllViews | Application
Assistant (Office) | CodeData
CodeProject | Collection (VBA)
ComAddIns (Office) | Command (ADO)
Connection (ADO) | Connection (ADO)
Container, Containers (DAO) | Connection, Connections (DAO)
Controls | Control
CurrentProject | CurrentData
DataAccessPages | DataAccessPage
DBEngine (DAO) | Database, Databases (DAO)
DefaultWebOptions | Debug (VBA)
Document, Documents (DAO) | DoCmd
Error (ADO) | Err (VBA)
Errors (ADO) | Error, Errors (DAO)
Field, Fields (DAO) | Field (ADO)
FileSearch (Office) | Fields (ADO)
Group, Groups (DAO) | Form
Module | Index, Indexes (DAO)
Page | Modules
Pages | Page
Parameter (ADO) | Pages
Parameters (ADO) | Parameter, Parameters (DAO)
Property, Properties (DAO) | Property (ADO)
QueryDef, QueryDefs (DAO) | Properties (ADO)
Recordset, Recordsets (DAO) | Recordset (ADO)
References | Reference
Report | Relation, Relations (DAO)
TableDef, TableDefs (DAO) | Screen
VBE (VBA) | User, Users (DAO)
Workspace, Workspaces (DAO) | WebOptions

Alphabetisch sortiert

A-C

AccessError | Close (ADO)
Add (AccessObjectProperties-Auflistung)** | Close (DAO)
Add (FormatConditions-Auflistung)** | Close
Add (VBA) | CloseConnection**
Add (Pages-Auflistung) | CloseCurrentDatabase
AddFromFile (Module-Objekt) | CodeDb
AddFromFile (References-Auflistung) | CommitTrans (ADO)
AddFromGUID | CommitTrans (DAO)
AddFromString | CompactDatabase (DAO)
AddMenu** | CompareBookmarks (ADO)
AddNew (ADO) | CopyObject
AddNew (DAO) | CopyQueryDef (DAO)
AddToFavorites | CreateControl
Append (ADO) | CreateDataAccessPage**
Append (DAO) | CreateDatabase (DAO)
AppendChunk (ADO) | CreateEventProc
AppendChunk (DAO) | CreateField (DAO)
ApplyFilter | CreateForm
ApplyTheme** | CreateGroup (DAO)
Beep | CreateGroupLevel
BeginTrans (ADO) | CreateIndex (DAO)
BeginTrans (DAO) | CreateNewDocument**
BuildCriteria | CreateParameter (ADO)
Cancel (ADO) | CreateProperty (DAO)
Cancel (DAO) | CreateQueryDef (DAO)
CancelBatch (ADO) | CreateRelation (DAO)
CancelEvent | CreateReport
CancelUpdate (ADO) | CreateReportControl
CancelUpdate (DAO) | CreateTableDef (DAO)
Circle | CreateUser (DAO)
Clear (ADO) | CreateWorkspace (DAO)
Clear (VBA) | CurrentDb
Clone (ADO) | CurrentUser
Clone (DAO) |

D-F

DefaultControl | Execute (ADO, Command-Objekt)
DefaultWorkspaceClone | Execute (ADO, Connection-Objekt)
Delete (ADO, Fields-Auflistung) | Execute (DAO)
Delete (ADO, Parameters-Auflistung) | FillCache (DAO)
Delete (ADO, Recordset-Auflistung) | Find
Delete (DAO) | Find (ADO)
Delete (FormatCondition-Objekt)** | FindFirst (DAO)
Delete (FormatConditions-Auflistung)** | FindLast (DAO)
DeleteLines | FindNext (DAO)
DeleteObject | FindNext
DoMenuItem | FindPrevious (DAO)
Dropdownfeld | FindRecord
Echo (DoCmd-Objekt) | Follow
Echo (Application-Objekt) | FollowHyperlink
Edit (DAO) |

G-M

GetChunk (ADO) | LoadPicture
GetChunk (DAO) | MakeReplica (DAO)
GetHiddenAttribute** | Maximize
GetOption | Minimize
GetRows (ADO) | Modify (FormatCondition-Objekt)**
GetRows (DAO) | Move (ADO)
GoToControl | Move (DAO)
GoToPage (DoCmd-Objekt) | MoveFirst (ADO)
GoToPage (Form-Objekt) | MoveFirst (DAO)
GoToRecord | MoveLast (ADO)
GetString (ADO) | MoveLast (DAO)
Hourglass | MoveNext (ADO)
Idle (DAO) | MoveNext (DAO)
InsertLines | MovePrevious (ADO)
InsertText | MovePrevious (DAO)
Item (VBA) | MoveSize
Line |

N-Q

NewAccessProject** | OpenQuery
NewCurrentDatabase | OpenRecordset (DAO)
NewPassword (DAO) | OpenReport
NextRecordset (ADO) | OpenSchema (ADO)
NextRecordset (DAO) | OpenStoredProcedure**
Open (ADO, Connection-Objekt) | OpenTable
Open (ADO, Recordset-Objekt) | OpenView**
OpenAccessProject** | OutputTo
OpenConnection** | PopulatePartial (DAO)
OpenConnection (DAO) | Print (VBA)
OpenCurrentDatabase | Print
OpenDataAccessPage** | PrintOut
OpenDatabase (DAO) | PSet
OpenDiagram** | Quit (DoCmd-Objekt)
OpenForm | Quit (Application-Objekt)
OpenModule |

R

Raise (VBA) | RepaintObject
Recalc | RepairDatabase (DAO)
Refresh | ReplaceLine
Refresh (ADO) | Requery (ADO)
Refresh (DAO) | Requery (DAO)
RefreshDatabaseWindow | Requery (DoCmd-Objekt)
RefreshLink (DAO) | Requery (Control- oder Form-Objekt)
RefreshTitleBar | Restore
RegisterDatabase (DAO) | Resync (ADO)
Remove (AccessObjectProperties-Auflistung)** | RollbackTrans (ADO)
Remove (VBA) | Rollback (DAO)
Remove (Pages-Auflistung) | Run
Remove (References-Auflistung) | RunCommand
Rename | RunMacro
Repaint | RunSQL

S-Z

Save | SizeToFit
Save (ADO) | Supports (ADO)
Scale | Synchronize (DAO)
Seek (ADO) | SysCmd
Seek (DAO) | TextHeight
SelectObject | TextWidth
SendObject | TransferDatabase
SetFocus | TransferSpreadsheet
SetHiddenAttribute** | TransferText
SetMenuItem | Undo
SetOption (DAO) | Update (ADO)
SetOption | Update (DAO)
SetWarnings | UpdateBatch (ADO)
ShowAllRecords | UseDefaultFolderSuffix**
ShowToolbar |


 Neue Methoden (Alphabetische Liste)

Neue Methoden (Alphabetische Liste)

Die folgende Liste enthält Methoden, die Microsoft Access 2000 hinzugefügt wurden.

A-H

Add (AccessObjectProperties-Auflistung)

Add (FormatConditions-Auflistung)

AddMenu

ApplyTheme

CloseConnection

CreateAccessProject

 CreateDataAccessPage

CreateNewDocument

Delete (FormatCondition-Objekt)

Delete (FormatConditions-Auflistung)

GetHiddenAttribute

I-Q

Modify (FormatCondition-Objekt)

NewAccessProject

OpenAccessProject

OpenConnection

 OpenDataAccessPage

OpenDiagram

OpenStoredProcedure

OpenView

R-Z

Remove (AccessObjectProperties-Auflistung)

SetHiddenAttribute

 UseDefaultFolderSuffix

Microsoft Office-Methoden

Um die Liste der neuen Methoden in der Microsoft Office 9.0-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Office Visual Basic-Referenz.

Wenn Sie die von Microsoft Office bereitgestellten Objekte verwenden möchten, richten Sie bei geöffnetem Visual Basic-Editor einen Verweis auf die Microsoft Office 9.0-Objektbibliothek ein, indem Sie im Menü Extras auf Verweise klicken und das entsprechende Kontrollkästchen aktivieren.

Microsoft Visual Basic-Editor-Methoden

Um die Liste der neuen Methoden in der Microsoft Visual Basic für Applikationen Extensibility 5.3-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Visual Basic-Referenz.

Wenn Sie die vom Microsoft Visual Basic-Editor bereitgestellten Objekte verwenden möchten, richten Sie einen Verweis auf die Microsoft Visual Basic für Applikationen Extensibility 5.3-Objektbibliothek ein. Zu diesem Zweck öffnen Sie den Visual Basic-Editor, klicken im Menü Extras auf Verweise und aktivieren dann das entsprechende Kontrollkästchen.


 AboutBox-Methode (Snapshot Viewer)

AboutBox-Methode (Snapshot Viewer)

Die AboutBox-Methode zeigt das Dialogfeld Info des Microsoft Snapshot Viewer-Steuerelements an.

Syntax

Objekt.AboutBox

Die AboutBox-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Objekt, das ein Steuerelement des Typs Snapshot Viewer repräsentiert.

Anmerkungen

Bei Verwendung der AboutBox-Methode wird das Dialogfeld Info des Microsoft Snapshot Viewer-Steuerelements angezeigt.


AccessError-Methode

Mit der AccessError-Methode können Sie die beschreibende Zeichenfolge zurückgeben, die einem Microsoft Access-Fehler oder einem ADO-Fehler zugeordnet ist.

Syntax

[Anwendung.]AccessError(Fehlernummer)

Die Methode AccessError verwendet folgende Argumente:

Argument | Beschreibung
Anwendung | Optional. Das Application-Objekt.
Fehlernummer | Die Nummer des Fehlers, zu dem Sie eine beschreibende Zeichenfolge zurückgeben möchten.

Anmerkung

Mit der AccessError-Methode können Sie die einem Microsoft Access-Fehler oder einem ADO-Fehler zugeordnete beschreibende Zeichenfolge zurückgeben, wenn der Fehler nicht wirklich aufgetreten ist.

Sie können die Visual Basic-Methode Raise verwenden, um einen Visual Basic-Fehler neu zu erzeugen. Nachdem Sie den Fehler erzeugt haben, können Sie dessen zugeordnete beschreibende Zeichenfolge ermitteln, indem Sie die Eigenschaft Description des Objekts Err abrufen.

Die Raise-Methode können Sie nicht verwenden, um einen Microsoft Access-Fehler oder einen ADO-Fehler neu zu erzeugen. Mit Hilfe der AccessError-Methode können Sie jedoch die diesen Fehlern zugeordnete beschreibende Zeichenfolge ausgeben, ohne den Fehler erzeugen zu müssen.

Mit dieser Methode können Sie eine beschreibende Zeichenfolge aus dem Ereignis Error eines Formulars heraus ausgeben.

Wenn der Microsoft Access-Fehler aufgetreten ist, können Sie die beschreibende Zeichenfolge entweder mit Hilfe der Methode AccessError oder der Eigenschaft Description des Visual Basic-Objekts Err zurückgeben.


 Add-Methode (AccessObjectProperties-Auflistung)

Add-Methode (AccessObjectProperties-Auflistung)

Mit der Add-Methode können Sie eine neue Eigenschaft in Form eines AccessObjectProperty-Objekts der AccessObjectProperties-Auflistung eines AccessObject-Objekts hinzufügen.

Syntax

Objekt.Add Eigenschaftenname, Wert

Die Add-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur AccessObjectProperties-Auflistung eines AccessObject-Objekts ausgewertet wird.
Eigenschaftenname | Ein Zeichenfolgenausdruck, der den Namen der neuen Eigenschaft angibt.
Wert | Ein Variant-Wert, der der Einstellung der Option entspricht. Welche Einstellung das Argument Wert besitzt, hängt von den für eine gegebene Option möglichen Einstellungen ab. Es kann sich um eine Konstante oder eine Zeichenfolge handeln.

Anmerkungen

Sie können die Remove-Methode der AccessObjectProperties-Auflistung verwenden, um eine vorhandene Eigenschaft zu löschen.


 Add-Methode (FormatConditions-Auflistung)

Add-Methode (FormatConditions-Auflistung)

Mit der Add-Methode können Sie eine bedingte Formatierung in Form eines FormatCondition-Objekts zur FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements hinzufügen.

Syntax

Objekt.Add Typ [, Operator][, Ausdruck1][, Ausdruck2]

Die Add-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur FormatConditions-Auflistung eines Kombinationsfeld- oder eine Textfeld-Steuerelements ausgewertet wird.
Typ | Eine der folgenden eingebauten Konstanten: acExpression acFieldHasFocus acFieldValue
Operator | Eine der folgenden eingebauten Konstanten: acBetween (Voreinstellung) acEqual acGreaterThan acGreaterThanOrEqual acLessThan acLessThanOrEqual acNotBetween acNotEqual
 | Wenn für das Argument Typ der Wert acExpression angegeben wird, hat das Argument Operator keine Bedeutung und wird ignoriert. Beim Weglassen dieses Arguments wird der Standardwert (acBetween) angenommen.
Ausdruck1 | Ein Variant-Wert oder -Ausdruck, der dem ersten Teil der bedingten Formatierung entspricht. Es kann sich dabei um eine Konstante oder eine Zeichenfolge handeln.
Ausdruck2 | Ein Variant-Wert oder -Ausdruck, der dem zweiten Teil der bedingten Formatierung entspricht, sofern für das Argument Operator einer der Werte acBetween oder acNotBetween angegeben ist (andernfalls wird dieses Argument ignoriert). Es kann sich um eine Konstante oder eine Zeichenfolge handeln.

Anmerkung

Sie können die Delete-Methode der FormatConditions-Auflistung verwenden, um eine vorhandene FormatConditions-Auflistung eines Kombinationsfeld- oder eines Textfeld-Steuerelements zu löschen.


 Add-Methode (Pages-Auflistung)

Add-Methode (Pages-Auflistung)

Die Methode Add fügt ein neues Page-Objekt zur Pages-Auflistung eines Registersteuerelements hinzu.

Syntax

Objekt.Add [Vor]

Die Methode Add hat folgende Argumente.

Argument | Beschreibung
Objekt | Die Pages-Auflistung eines Registersteuerelements.
Vor | Ein Integer-Wert, der den Index des Page-Objekts angibt, vor dem das neue Page-Objekt hinzugefügt werden soll. Der Index des Page-Objekts entspricht dem Wert der Eigenschaft PageIndex für das Page-Objekt. Wenn Sie dieses Argument weglassen, wird das neue Page-Objekt am Ende der Auflistung angefügt.

Anmerkung

Das erste Page-Objekt in der Pages-Auflistung entspricht der am weitesten links liegenden Seite im Registersteuerelement und besitzt den Index 0. Das zweite Page-Objekt befindet sich unmittelbar rechts neben der ersten Seite und hat den Index 1 usw. für alle Page-Objekte im Registersteuerelement.

Wenn Sie 0 für das Argument Vor angeben, wird das neue Page-Objekt vor dem ersten Page-Objekt in der Pages-Auflistung hinzugefügt. Das neue Page-Objekt wird dann das erste Page-Objekt in der Auflistung und erhält den Index 0.

Sie können ein Page-Objekt zur Pages-Auflistung eines Registersteuerelements nur dann hinzufügen, wenn sich das Formular in der Entwurfsansicht befindet.


 AddFromFile-Methode (Module-Objekt)

AddFromFile-Methode (Module-Objekt)

Die Methode AddFromFile fügt den Inhalt einer Textdatei zu einem Module-Objekt hinzu. Das Module-Objekt kann ein Standardmodul oder ein Klassenmodul sein.

Syntax

Objekt.AddFromFile Dateiname

Die Methode AddFromFile hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Dateiname | Name und vollständiger Pfad einer Textdatei (.TXT) oder einer anderen Datei, die Text im ANSI-Format speichert.

Anmerkung

Die Methode AddFromFile legt den Inhalt der angegebenen Datei unmittelbar hinter dem Deklarationsbereich und vor der ersten Prozedur im Modul ab, falls dieser andere Prozeduren enthält.

Mit der Methode AddFromFile können Sie Code oder in einer Textdatei gespeicherte Kommentare importieren.

Um den Inhalt einer Datei zu einem Formularmodul oder Berichtsmodul hinzuzufügen, öffnen Sie das Formular bzw. den Bericht in der Formularentwurfsansicht oder Berichtsentwurfsansicht. Zum Hinzufügen einer Datei zu einem Standard- oder Klassenmodul öffnen Sie das betreffende Modul.


 AddFromFile-Methode (References-Auflistung)

AddFromFile-Methode (References-Auflistung)

Die Methode AddFromFile erstellt einen Verweis auf eine Typbibliothek in einer angegebenen Datei.

Syntax

Set Objekt = References.AddFromFile(Dateiname)

Die Methode AddFromFile hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Reference-Objekt.
Dateiname | Ein Zeichenfolgenausdruck, der zum vollständigen Pfad und Dateinamen der Datei mit der Typbibliothek ausgewertet wird, auf die ein Verweis hergestellt werden soll.

Anmerkung

In der folgenden Tabelle sind Dateitypen aufgeführt, die häufig Typbibliotheken enthalten.

Dateinamenserweiterung | Dateityp
.olb, .tlb | Typbibliotheksdatei
.mdb, .mda, .mde | Datenbank
.exe, .dll | Ausführbare Datei
.ocx | ActiveX-Steuerelement


 AddFromGUID-Methode

AddFromGUID-Methode

Die Methode AddFromGUID erstellt ein Reference-Objekt, das auf dem GUID-Wert für eine Typbibliothek basiert.

Syntax

Objekt.AddFromGUID(guid)

Die Methode AddFromGUID hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Reference-Objekt.
Guid | Ein GUID-Wert, der eine Typbibliothek identifiziert.

Anmerkung

Die Eigenschaft GUID gibt den GUID-Wert für ein angegebenes Reference-Objekt zurück. Wenn Sie den Wert der Eigenschaft GUID einmal gespeichert haben, können Sie ihn zum Neuerstellen eines verloren gegangenen Verweises verwenden.


 AddFromString-Methode

AddFromString-Methode

Die Methode AddFromString fügt eine Zeichenfolge zu einem Module-Objekt hinzu. Das Module-Objekt kann ein Standardmodul oder ein Klassenmodul sein.

Syntax

Objekt.AddFromString Zeichenfolgenausdruck

Die Methode AddFromString hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Zeichenfolgenausdruck | Ein Zeichenfolgenausdruck.

Anmerkung

Die Methode AddFromString legt den Inhalt einer Zeichenfolge unmittelbar hinter dem Deklarationsbereich und vor der ersten Prozedur im Modul ab, falls dieser andere Prozeduren enthält.

Um den Inhalt einer Zeichenfolge zu einem Formularmodul oder Berichtsmodul hinzuzufügen, öffnen Sie das Formular bzw. den Bericht in der Formularentwurfsansicht oder Berichtsentwurfsansicht. Zum Hinzufügen einer Zeichenfolge zu einem Standard- oder Klassenmodul öffnen Sie das betreffende Modul.


 AddMenu-Methode

AddMenu-Methode

Die AddMenu-Methode führt die Aktion HinzufügenMenü in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.AddMenu Menüname, Menümakroname, Statusleistentext

Die Aktion HinzufügenMenü verwendet die folgenden Argumente.

Argument | Beschreibung
Menüname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Dropdownmenüs darstellt, das zur benutzerdefinierten Menüleiste oder globalen Menüleiste hinzugefügt werden soll.
 | Um eine Zugriffstaste zu definieren, mit der Sie das Menü auf der Tastatur auswählen können, geben Sie ein &-Zeichen vor dem Buchstaben ein, der als Zugriffstaste dienen soll. Dieser Buchstabe wird im Menünamen auf der Menüleiste unterstrichen dargestellt.
Menümakroname | Ein Zeichenfolgenausdruck, der den gültigen Namen der Makrogruppe darstellt, die die Makros für die Menübefehle enthält. Dieses Argument ist erforderlich.
Statusleistentext | Ein Zeichenfolgenausdruck für den Text, der in der Statusleiste angezeigt wird, wenn das Menü ausgewählt wird.

Anmerkung

Bei benutzerdefinierten und globalen Menüleisten müssen Sie der AddMenu-Methode die Argumente Menüname und Menumakroname bereitstellen. Das Argument Menüname ist für benutzerdefinierte und globale Kontextmenüs nicht erforderlich und wird in diesen Fällen ignoriert.

Das Argument Statusleistentext ist optional und wird bei benutzerdefinierten und globalen Kontextmenüs ignoriert.


 AddToFavorites-Methode

AddToFavorites-Methode

Die Methode AddToFavorites fügt eine Hyperlinkadresse zum Ordner FAVORITEN hinzu.

Syntax

Objekt.Hyperlink.AddToFavorites

Die Methode AddToFavorites hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Application-Objekt oder ein Control-Objekt, das einen Hyperlink enthält. Bezeichnungsfeld-, Befehlsschaltfläche- und Bild-Steuerelemente können Hyperlinks enthalten.
Hyperlink | Der Hyperlink des Control-Objekts.

Anmerkung

Wenn die Methode AddToFavorites auf ein Application-Objekt angewendet wird, fügt sie den Namen der aktuellen Datenbank zum Ordner FAVORITEN hinzu. Wenn Sie beispielsweise mit der Nordwind-Beispieldatenbank arbeiten, bewirkt die Anwendung der Methode AddToFavorites auf das Application-Objekt, dass die Hyperlinkadresse der Nordwind-Datenbank zum Ordner FAVORITEN hinzugefügt wird.

Wenn sie auf ein Control-Objekt angewendet wird, fügt die Methode AddToFavorites die in einem Steuerelement enthaltene Hyperlinkadresse zum Ordner FAVORITEN hinzu. Der Ordner FAVORITEN wird standardmäßig im Ordner WINDOWS eingerichtet.

Sie erzielen dieselbe Wirkung wie die Methode AddToFavorites, wenn Sie in der Symbolleiste Web im Menü Favoriten auf Zu Favoriten hinzufügen klicken, sofern das Dokument, dessen Adresse hinzugefügt werden soll, geöffnet ist.


 ApplyFilter-Methode

ApplyFilter-Methode

Die ApplyFilter-Methode führt die Aktion AnwendenFilter in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.ApplyFilter [Filtername][, Bedingung][, Filtertyp]

Die ApplyFilter-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Filtername | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Filters oder einer Abfrage der aktuellen Datenbank angibt.
 | Anmerkung Soll mit Hilfe dieser Methode ein Serverfilter angewendet werden, so muss das Argument Filtername leer sein.
WHERE-Bedingung | Ein Zeichenfolgenausdruck, der eine gültige SQL-WHERE-Klausel ohne das Wort WHERE angibt.
Filtertyp | Eine der folgenden eingebauten Konstanten:
 | acFilterNormal (Standardwert) acServerFilter

Der Filter und die WHERE-Bedingung, die Sie anwenden, wird als Einstellung der Filter-Eigenschaft oder der ServerFilter-Eigenschaft des Formulars oder Berichts übernommen.

Anmerkungen

Verwenden Sie mindestens ein Argument der Methode ApplyFilter. Wenn Sie für beide Argumente einen Wert eingeben, wird das Argument WHERE-Bedingung auf den Filter angewendet.

Das Argument WHERE-Bedingung darf bis zu 32.768 Zeichen lang sein (im Gegensatz zum Aktionsargument WHERE-Bedingung im Makrofenster, dessen maximale Länge 256 Zeichen beträgt).

Wenn Sie das Argument WHERE-Bedingung angeben und das Argument Filtername weglassen, müssen Sie das Komma des Arguments Filtername angeben.


 ApplyTheme-Methode

ApplyTheme-Methode

Mit der ApplyTheme-Methode können Sie das Microsoft Office-Design für eine angegebene Datenzugriffsseite festlegen.

Syntax

Objekt.ApplyTheme Designname

Die ApplyTheme-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Optional. Ein Zeichenfolgenausdruck, der zum DataAccessPage-Objekt ausgewertet wird.
Designname | Ein Zeichenfolgenausdruck, der den Namen des Office-Designs angibt.

Anmerkungen

Die ApplyTheme-Methode ermöglicht es, Umgebungsoptionen aus Visual Basic-Code heraus zu ändern.


Beep-Methode

Die Methode Beep führt die Aktion Signalton in Visual Basic aus. Weitere Informationen zu dieser Aktion finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Beep

Diese Methode verwendet keine Argumente.

Anmerkung

Sie können auch die Visual Basic-Anweisung Beep verwenden, damit Ihr Computer einen Signalton ausgibt.


 BuildCriteria-Methode

BuildCriteria-Methode

Die BuildCriteria-Methode gibt eine analysierte Kriterienzeichenfolge so zurück, wie sie im Abfrageentwurfsbereich, im Modus Formularbasierter Filter oder im Modus Formularbasiertem Serverfilter angezeigt wird. Sie können diese Methode z.B. einsetzen, wenn Sie die Filter-Eigenschaft oder ServerFilter-Eigenschaft eines Formulars abhängig von verschiedenen Kriterien einstellen möchten, die der Benutzer angegeben hat. Mit der BuildCriteria-Methode können Sie den Zeichenfolgenausdruck erstellen, der der Filter-Eigenschaft zugewiesen werden soll.

Syntax

Anwendung.BuildCriteria(Feld, Feldtyp, Ausdruck)

Die BuildCriteria-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Anwendung | (Optional) Das Application-Objekt.
Feld | Ein Zeichenfolgenausdruck, der das Feld angibt, für das Sie Kriterien definieren möchten.
Feldtyp | Eine eingebaute Konstante, die den Datentyp des Feldes angibt. Eine Liste der möglichen Felddatentypen finden Sie unter der ADO-Eigenschaft Type.
Ausdruck | Ein Zeichenfolgenausdruck, der die zu analysierenden Kriterien angibt.

Die BuildCriteria-Methode gibt eine Zeichenfolge zurück.

Anmerkung

Die BuildCriteria-Methode ermöglicht es Ihnen, Kriterien für einen auf Benutzereingaben basierenden Filter problemlos zusammenzustellen. Sie analysiert das Argument Ausdruck genauso, wie der Ausdruck analysiert werden würde, wenn Sie ihn in den Abfrageentwurfsbereich oder im Modus Formularbasierter Filter bzw. im Modus Formularbasierter Serverfilter eingeben würden.

So könnte z.B. ein Benutzer, der eine Abfrage zu der Tabelle Bestellungen erstellt, die Ergebnisgruppe auf nach dem 1. Januar 1996 erteilte Aufträge beschränken, indem er Kriterien für das Feld Bestelldatum eingibt. Der Benutzer kann einen Ausdruck, wie etwa den folgenden, in die Zeile Kriterien unterhalb des Feldes Bestelldatum eingeben:

>1.1.96

Microsoft Access analysiert diesen Ausdruck automatisch und gibt den folgenden Ausdruck zurück:

>#01.01.96#

Die BuildCriteria-Methode ermöglicht es, Ausdrücke in Visual Basic-Code auf dieselbe Weise zu analysieren. Damit z.B. die obige, richtig analysierte Zeichenfolge zurückgegeben wird, können Sie die folgenden Argumente an die BuildCriteria-Methode übergeben:

Dim strKriterien As String
strKriterien = BuildCriteria("Bestelldatum", dbDate, ">1.1.96")

Da Sie für die Eigenschaft Filter Kriterien in korrekt analysierter Form zur Verfügung stellen müssen, können Sie die BuildCriteria-Methode zum Aufbauen einer korrekt analysierten Zeichenfolge verwenden.

Sie können die BuildCriteria-Methode zum Zusammenstellen einer Zeichenfolge mit mehreren Kriterien verwenden, wenn sich diese Kriterien auf dasselbe Feld beziehen. Die BuildCriteria-Methode kann z.B. mit den folgenden Argumenten verwendet werden, um eine mit dem Feld Bestelldatum zusammenhängende Zeichenfolge mit mehreren Kriterien zusammenzustellen:

strKriterien = BuildCriteria("Bestelldatum", dbDate, ">1.1.96 Und <1.5.96")

Dieses Beispiel gibt die folgende Kriterienzeichenfolge zurück:

Bestelldatum>#1/1/96# And Bestelldatum<#5/1/96#

Falls Sie jedoch eine Kriterienzeichenfolge erstellen möchten, die auf mehrere Felder verweist, müssen Sie die Zeichenfolgen erstellen und selbst miteinander verketten. Wenn Sie z.B. Kriterien für einen Filter erstellen, um Datensätze für Bestellungen anzuzeigen, die nach dem 1. Januar 1996 aufgegeben wurden und für die die Frachtkosten unter 75 DM liegen, müssen Sie die BuildCriteria-Methode zweimal verwenden und die sich daraus ergebenden Zeichenfolgen verketten.


 CancelEvent-Methode

CancelEvent-Methode

Die Methode CancelEvent führt die Aktion AbbrechenEreignis in Visual Basic aus. Weitere Informationen zu dieser Aktion finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.CancelEvent

Diese Methode verwendet keine Argumente.

Anmerkung

Die Methode CancelEvent wirkt sich nur aus, wenn sie als Ergebnis eines Ereignisses ausgeführt wird. Diese Methode bricht die Ausführung des Ereignisses ab.

Alle Ereignisse, deren Ausführung in Visual Basic abgebrochen werden kann, weisen das Argument Abbrechen auf. Sie können dieses Argument an Stelle der Methode CancelEvent verwenden, um die Ausführung des Ereignisses abzubrechen. Die Ereignisse KeyPress und MouseDown (nur zum Klicken der rechten Maustaste) können nur in Makros und nicht in Ereignisprozeduren abgebrochen werden. Verwenden Sie daher in einem Makro die Aktion AbbrechenEreignis, um die Ausführung dieser Ereignisse abzubrechen.


 Circle-Methode

Circle-Methode

Die Methode Circle zeichnet einen Kreis, eine Ellipse oder einen Bogen auf einem Report-Objekt, wenn das Ereignis Print eintritt.

Syntax

Objekt.Circle [Step](x, y), Radius[, [Farbe][, [Startwert][, [Endwert][, Seitenverhältnis]]]]

Sie können diese Methode nur in einer Ereignisprozedur oder in einem Makro verwenden, die bzw. das in den Ereigniseigenschaften für einen Berichtsbereich oder in der Ereigniseigenschaft OnPage für einen Bericht angegeben ist.

Die Methode Circle hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Report-Objekt, auf dem der Kreis gezeichnet werden soll.
Step | Ein Schlüsselwort, das angibt, dass der Kreis-, Ellipsen- oder Bogenmittelpunkt relativ zu den aktuellen Koordinaten liegt, die von den Einstellungen der Eigenschaften CurrentX und CurrentY des Arguments Objekt angegeben werden.
x, y | Werte vom Datentyp Single, die die Koordinaten des Kreis-, Ellipsen- oder Bogenmittelpunkts angeben. Die Scale-Eigenschaften (ScaleMode, ScaleLeft, ScaleTop, ScaleHeight und ScaleWidth) des im Argument Objekt angegebenen Report-Objekts legen die verwendete Maßeinheit fest.
Radius | Ein Wert vom Datentyp Single, der den Radius des Kreises, der Ellipse oder des Bogens angibt. Die Scale-Eigenschaften (ScaleMode, ScaleLeft, ScaleTop, ScaleHeight und ScaleWidth) des im Argument Objekt angegebenen Report-Objekts legen die verwendete Maßeinheit fest. Standardmäßig werden die Strecken in Twips gemessen.
Farbe | Ein Wert vom Datentyp Long, der die RGB-Farbe (rot-grün-blau) der Kreislinie angibt. Wird dieses Argument nicht angegeben, wird der Wert der Eigenschaft ForeColor verwendet. Sie können zum Definieren der Farbe auch die Funktionen RGB oder QBColor verwenden.
Startwert, Endwert | Werte vom Datentyp Single. Wenn ein Kreis- oder Ellipsenbogen gezeichnet wird, geben die Argumente Startwert und Endwert die Anfangs- und die Endposition des Bogens (im Bogenmaß) an. Der Standardwert für Startwert ist 0; der Standardwert für Endwert ist 2 Pi. Der Bereich für beide Werte lautet -2 Pi bis 2 Pi (im Bogenmaß).
Seitenverhältnis | Ein Wert vom Datentyp Single, der das Seitenverhältnis des Kreises definiert. Standardmäßig lautet dieser Wert 1.0, was auf jedem beliebigen Bildschirm einen echten (keine Ellipse) ergibt.

Anmerkung

Wenn beim Zeichnen eines Kreis- oder Ellipsenbogens das Argument Startwert negativ eingestellt ist, zeichnet die Methode Circle eine Radiuslinie bis zur Position, die das Argument Startwert angibt, und interpretiert den Winkel als positiven Winkel. Ist das Argument Endwert negativ, zeichnet die Methode Circle eine Radiuslinie bis zur Position, die das Argument Endwert angibt, und interpretiert den Winkel ebenfalls positiv. Die Methode Circle zeichnet immer gegen den Uhrzeigersinn.

Damit Sie einen Kreis ausfüllen können, stellen Sie die Eigenschaften FillColor und FillStyle des Berichts ein. Nur geschlossene Figuren können ausgefüllt werden; dazu zählen Kreise, Ellipsen und Kreissektoren (Bögen mit Radiuslinien bis zu beiden Endpunkten).

Wenn Sie beim Zeichnen von Kreissektoren eine Radiuslinie für den Winkel 0 zeichnen möchten, um eine nach rechts laufende horizontale Radiuslinie zu erzeugen, geben Sie für das Argument Startwert nicht 0, sondern einen sehr kleinen negativen Wert an, z.B. -.00000001.

Sie brauchen nicht alle in der Syntax aufgeführten Argumente anzugeben, müssen aber für jedes weggelassene Argument das zugehörige Komma vor dem nächsten Argument einfügen. Wenn Sie Argumente am Ende weglassen, dürfen Sie nach dem letzten angegebenen Argument kein Komma angeben.

Die Linienbreite, die Sie zum Zeichnen des Kreises, der Ellipse oder des Bogens verwenden, ist abhängig von der Einstellung der Eigenschaft DrawWidth. Wie der Kreis auf dem Hintergrund gezeichnet wird, hängt von den Einstellungen der Eigenschaften DrawMode und DrawStyle ab.

Wenn Sie die Methode Circle anwenden, werden die Eigenschaften CurrentX und CurrentY auf die Mittelpunktskoordinaten eingestellt, die durch die Argumente x und y bestimmt sind.


 Close-Methode

Close-Methode

Die Methode Close führt die Aktion Schließen in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Close [Objekttyp, Objektname], [Speichern]

Die Methode Close verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
 | Anmerkung Wenn Sie ein Modul im Visual Basic-Editor (VBE) schließen, müssen Sie acModule im Argument Objekttyp angeben.
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.
Speichern | Eine der folgenden eingebauten Konstanten:
 | acSaveNo acSavePrompt (Standardwert) acSaveYes
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acSavePrompt) verwendet.

Anmerkung

Wenn Sie die Argumente Objekttyp und Objektname nicht angeben, wird die Standardkonstante (acDefault) für Objekttyp verwendet, und Microsoft Access schließt das aktive Fenster. Wenn Sie das Argument Speichern angeben und die Argumente Objekttyp und Objektname weglassen, geben Sie die Kommas der Argumente Objekttyp und Objektname an.

Anmerkung Wenn bei einem Formular ein Steuerelement an ein Feld gebunden ist, dessen Eigenschaft Erforderlich auf 'Ja' gesetzt wurde, und das Formular mit Hilfe der Methode Close ohne Eingabe von Daten in dieses Feld geschlossen wird, dann wird keine Fehlermeldung angezeigt. Die am Datensatz vorgenommenen Änderungen werden abgebrochen. Wenn das Formular mit der Windows-Schaltfläche Schließen, der Aktion Schließen in einem Makro oder durch Wählen von Schließen aus dem Menü Datei geschlossen wird, zeigt Microsoft Access eine Warnung an. Der folgende Code zeigt eine Fehlermeldung an, wenn versucht wird, ein Formular mit einem Null-Feld unter Verwendung der Methode Close zu schließen.

If IsNull(Me![Feld1]) Then
    If Meldung("'Feld1' muss einen Wert enthalten." _
        & Chr(13) & Chr(10) _
    & "Drücken Sie 'OK', um zurückzukehren und einen Wert einzugeben." _
    & Chr(13) & Chr(10) _
    & "Drücken Sie 'Abbrechen', um den Datensatz abzubrechen.", _
        vbOKCancel, "Ein erforderliches Feld ist Null") = _
        vbCancel Then
        DoCmd.Close
    End If
End If


 CloseCurrentDatabase-Methode

CloseCurrentDatabase-Methode

Sie können die Methode CloseCurrentDatabase verwenden, um die aktuelle Datenbank (eine Microsoft Access-Datenbank (.mdb) oder ein Access-Projekt (.adp) von einer anderen Anwendung aus zu schließen, die eine Datenbank über Automatisierung geöffnet hat. Sie können diese Methode z. B. von Microsoft Excel aus verwenden, um die derzeit im Microsoft Access-Fenster geöffnete Datenbank zu schließen, bevor Sie eine andere Datenbank öffnen.

Syntax

Anwendung.CloseCurrentDatabase

Die Methode CloseCurrentDatabase hat das folgende Argument.

Argument | Beschreibung
Anwendung | Das Objekt Application.

Anmerkung

Die Methode CloseCurrentDatabase ist sinnvoll, wenn Sie eine Microsoft Access-Datenbank von einer anderen Anwendung aus über Automatisierung geöffnet haben. Sobald Sie eine Instanz von Microsoft Access aus einer anderen Anwendung heraus erstellt haben, müssen Sie auch eine neue Datenbank erstellen oder eine vorhandene Datenbank angeben, die geöffnet werden soll. Diese Datenbank wird im Microsoft Access-Fenster geöffnet.

Wenn Sie die Methode CloseCurrentDatabase verwenden, um die in der aktuellen Instanz von Microsoft Access geöffnete Datenbank zu schließen, können Sie anschließend eine andere Datenbank öffnen, ohne dass Sie eine weitere Instanz von Microsoft Access erstellen müssen.


 CodeDb-Methode

CodeDb-Methode

Sie können mit der CodeDb-Methode in einem Modul den Namen des Database-Objekts ermitteln, das auf die Datenbank verweist, in der momentan Code ausgeführt wird. Mit der CodeDb-Methode können Sie auf Datenzugriffsobjekte (DAO) zugreifen, die Bestandteil einer Bibliotheksdatenbank sind.

Sie können z.B. mit der CodeDb-Methode in einem Modul einer Bibliotheksdatenbank ein Database-Objekt erstellen, das auf die Bibliotheksdatenbank verweist. Anschließend können Sie eine Datensatzgruppe öffnen, die auf einer Tabelle der Bibliotheksdatenbank basiert.

Syntax

Set Datenbank = CodeDb

Die CodeDb-Methode verwendet das folgende Argument.

Argument | Beschreibung
Datenbank | Eine Database-Objektvariable.

Anmerkung

Die CodeDb-Methode gibt ein Database-Objekt zurück, dessen Name-Eigenschaft auf den vollständigen Pfad und den Namen der Datenbank eingestellt ist, aus der es aufgerufen wurde. Diese Methode bietet sich dann an, wenn Sie die Datenzugriffsobjekte in Ihrer Bibliotheksdatenbank bearbeiten müssen.

Wenn Sie eine Methode einer Bibliotheksdatenbank aufrufen, bleibt die Datenbank, von der aus Sie die Methode aufgerufen haben, die aktuelle Datenbank, auch wenn Code in einem Modul der Bibliotheksdatenbank ausgeführt wird. Sie müssen den Namen des Database-Objekts, das der Bibliotheksdatenbank entspricht, kennen, um auf die Datenzugriffsobjekte in der Bibliotheksdatenbank verweisen zu können.

Angenommen, in einer Bibliotheksdatenbank gibt es eine Tabelle mit einer Liste von Fehlermeldungen. Wenn Sie Daten in der Tabelle aus Code heraus bearbeiten möchten, können Sie mit Hilfe der CodeDb-Methode den Namen des Database-Objekts ermitteln, das auf die Bibliotheksdatenbank verweist, zu der die Tabelle gehört.

Wird die CodeDb-Methode in der aktuellen Datenbank ausgeführt, gibt die Methode den Namen der aktuellen Datenbank zurück. Dies entspricht dem Wert, der von der CurrentDB-Methode zurückgegeben wird.


 CopyObject-Methode

CopyObject-Methode

Die CopyObject-Methode führt die Aktion KopierenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.CopyObject [Zieldatenbank][, Neuer Name][, Objekttyp (Herkunft) , Objektname (Herkunft)]

Die CopyObject-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Zieldatenbank | Ein Zeichenfolgenausdruck, der den gültigen Pfad- und Dateinamen der Datenbank angibt, in die Sie das Objekt kopieren möchten. Geben Sie dieses Argument nicht an, wenn Sie die aktuelle Datenbank auswählen möchten.
 | Anmerkung In einem Microsoft Access-Projekt (.adp) muss das Argument Zieldatenbank leer bleiben.
 | Wenn Sie Visual Basic-Code, der die CopyObject-Methode enthält, in einer Bibliotheksdatenbank ausführen und dieses Argument nicht angeben, kopiert Microsoft Access das Objekt in die Bibliotheksdatenbank.
Neuer Name | Ein Zeichenfolgenausdruck, der den neuen Namen des zu kopierenden Objekts angibt. Wenn Sie das Objekt unter demselben Namen in eine andere Datenbank kopieren möchten, geben Sie dieses Argument nicht an.
Objekttyp (Herkunft) | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
 | Anmerkung Bei Verwendung der CopyObject-Methode in Verbindung mit einer Datenzugriffsseite werden eine Kopie der HTML-Datei für die Datenzugriffsseite im Standarddatenbankordner sowie eine Verknüpfung damit in der Zieldatenbank erstellt.
Objektname (Herkunft) | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp (Herkunft) angibt.
 | Wenn Sie Visual Basic-Code, der die CopyObject-Methode enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkungen

Verwenden Sie bei dieser Methode das Argument Zieldatenbank, das Argument Neuer Name oder beide Argumente.

Wenn Sie die Argumente Objekttyp (Herkunft) und Objektname (Herkunft) nicht angeben, wird die Standardkonstante (acDefault) für Objekttyp (Herkunft) verwendet, und Microsoft Access kopiert das im Datenbankfenster markierte Objekt. Um ein Objekt im Datenbankfenster zu markieren, verwenden Sie die Aktion AuswählenObjekt oder die SelectObject-Methode, wobei das Argument Im Datenbankfenster auf True eingestellt sein muss.

Wenn Sie die Argumente Objekttyp (Herkunft) und Objektname (Herkunft) angeben, aber eines der Argumente Neuer Name oder Zieldatenbank weglassen, geben Sie die Kommas der Argumente Neuer Name bzw. Zieldatenbank an. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 CreateAccessProject-Methode

CreateAccessProject-Methode

Mit der CreateAccessProject-Methode können Sie ein neues Microsoft Access-Projekt (.adp) auf der Festplatte erstellen.

Syntax

Objekt.CreateAccessProject Projektname [, Verbindung ]

Die CreateAccessProject-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zum Application-Objekt ausgewertet wird.
Projektname | Ein Zeichenfolgenausdruck, der den Namen des neuen Access-Projekts einschließlich des Pfadnamens und der Dateinamenerweiterung enthält. Sofern dies von Ihrem Netzwerk unterstützt wird, können Sie auch einen Netzwerkpfad in der folgenden Art angeben: \\Server\Freigabe\Ordner\Dateiname.adp
Verbindung | Ein Zeichenfolgenausdruck, der eine gültige Verbindungszeichenfolge für das Access-Projekt angibt. Weitere Informationen über diese Zeichenfolge finden Sie unter dem Thema zur ADO ConnectionString-Eigenschaft.

Anmerkungen

Die CreateAccessProject-Methode ermöglicht es Ihnen, ein neues Access-Projekt aus Microsoft Access oder einer anderen Anwendung heraus über den Weg der Automatisierung (formell als OLE-Automatisierung bezeichnet) zu erstellen. Sie können beispielsweise die CreateAccessProject-Methode von Microsoft Excel heraus aufrufen, um ein neues Access-Projekt auf der Festplatte zu erstellen. Nach Erstellung einer Microsoft Access-Instanz über eine andere Anwendung müssen Sie zudem auch ein neues Access-Projekt erstellen.

Wenn das durch Projektname bezeichnete Access-Projekt bereits vorhanden ist, tritt ein Fehler auf.

Anmerkungen

  • Um ein neues Access-Projekt zu erstellen und als aktuelles Access-Projekt im Access-Fenster zu öffnen, verwenden Sie die NewAccessProject-Methode des Application-Objekts.

  • Um ein vorhandenes Access-Projekt als aktuelles Access-Projekt im Access-Fenster zu öffnen, verwenden Sie die OpenAccessProject-Methode des Application-Objekts.


 CreateControl-, CreateReportControl-Methoden

CreateControl-, CreateReportControl-Methoden

  • Die CreateControl-Methode erstellt ein Steuerelement im angegebenen geöffneten Formular.

  • Die CreateReportControl-Methode erstellt ein Steuerelement im angegebenen geöffneten Bericht.

Angenommen, Sie möchten beispielsweise einen benutzerdefinierten Assistenten erstellen, mit dessen Hilfe Benutzer ein bestimmtes Formular auf einfache Weise erstellen können. Dann können Sie die CreateControl-Methode in diesem Assistenten verwenden, um dem Formular die entsprechenden Steuerelemente hinzuzufügen.

Syntax

CreateControl(Formularname, Steuerelementtyp[, Bereich[, übergeordnet[, Spaltenname[, links[, oben[, Breite[, Höhe]]]]]]])

CreateReportControl(Berichtsname, Steuerelementtyp[, Bereich[, übergeordnet[, Spaltenname[, links[, oben[, Breite[, Höhe]]]]]]])

Die CreateControl- und die CreateReportControl-Methode verwenden die folgenden Argumente.

Argument | Beschreibung
Formularname, Berichtsname | Ein Zeichenfolgenausdruck, der den Namen des geöffneten Formulars bzw. Berichts identifiziert, in dem das Steuerelement erstellt werden soll.
Steuerelementtyp | Eine der folgenden eingebauten Konstanten, die den Typ des zu erstellenden Steuerelements identifiziert. Um diese Konstanten im Objektkatalog anzuzeigen und in Ihren Code einzufügen, klicken Sie in der Symbolleiste Visual Basic auf Objektkatalog [image] , dann im Feld Projekt/Bibliothek auf Access und schließlich im Feld Klassen auf AcControlType.
 | Konstante | Steuerelement
 | acLabel | Bezeichnung
 | acRectangle | Rechteck
 | acLine | Linie
 | acImage | Bild
 | acCommandButton | Befehlsschaltfläche
 | acOptionButton | Optionsfeld
 | acCheckBox | Kontrollkästchen
 | acOptionGroup | Optionsgruppe
 | acBoundObjectFrame | Gebundenes Objektfeld
 | acTextBox | Textfeld
 | acListBox | Listenfeld
 | acComboBox | Kombinationsfeld
 | acSubform | Unterformular
 | acObjectFrame | Objektfeld
 | acPage | Seite
 | acPageBreak | Seitenwechsel
 | acCustomControl | ActiveX-Steuerelement
 | acToggleButton | Umschaltfläche
 | acTabCtl | Registersteuerelement
Bereich | Eine der folgenden eingebauten Konstanten zur Identifizierung des Bereichs, der das neue Steuerelement enthält. Um diese Konstanten im Objektkatalog anzuzeigen und in Ihren Code einzufügen, klicken Sie in der Symbolleiste Visual Basic auf Objektkatalog [image] , dann im Feld Projekt/Bibliothek auf Access und schließlich im Feld Klassen auf AcSection.
 | Konstante | Bereich
 | acDetail | (Standardeinstellung) Detailbereich
 | acHeader | Formular- oder Berichtskopf
 | acFooter | Formular- oder Berichtsfuß
 | acPageHeader | Seitenkopf
 | acPageFooter | Seitenfuß
 | acGroupLevel1Header | Gruppierungsebene 1 Kopf (nur Berichte)
 | acGroupLevel1Footer | Gruppierungsebene 1 Fuß (nur Berichte)
 | acGroupLevel2Header | Gruppierungsebene 2 Kopf (nur Berichte)
 | acGroupLevel2Footer | Gruppierungsebene 2 Fuß (nur Berichte)
 | Wenn ein Bericht zusätzliche Gruppierungsebenen hat, werden die Kopf/Fuß-Paare, beginnend mit 9, fortlaufend nummeriert.
übergeordnet | Ein Zeichenfolgenausdruck, der den Namen des übergeordneten Steuerelements eines zugeordneten Steuerelements identifiziert. Bei Steuerelementen ohne übergeordnetes Steuerelement verwenden Sie eine leere Zeichenfolge für dieses Argument, oder lassen Sie es weg.
Spaltenname | Der Name des Feldes, an das das Steuerelement gebunden wird, wenn es sich um ein datengebundenes Steuerelement handeln soll.
 | Wenn Sie ein Steuerelement erstellen, das nicht an ein Feld gebunden werden soll, verwenden Sie eine leere Zeichenfolge für dieses Argument.
links, oben | Numerische Ausdrücke, die die Koordinaten für die obere linke Ecke des Steuerelements in Twips angeben.
Breite, Höhe | Numerische Ausdrücke, die die Breite und Höhe des Steuerelements in Twips angeben.

Anmerkungen

Sie können die CreateControl- und die CreateReportControl-Methode in einem benutzerdefinierten Assistenten verwenden, um Steuerelemente in einem Formular oder Bericht zu erstellen. Beide Methoden geben ein Control-Objekt zurück.

Sie können die CreateControl- und die CreateReportControl-Methode nur in der Entwurfsansicht für Formulare bzw. der Entwurfsansicht für Berichte verwenden.

Mit dem Argument übergeordnet identifizieren Sie die Beziehung zwischen einem Hauptsteuerelement und einem untergeordneten Steuerelement. Hat z. B. ein Textfeld ein zugeordnetes Bezeichnungsfeld, so ist das Textfeld das (übergeordnete) Hauptsteuerelement, und das Bezeichnungsfeld ist das untergeordnete Steuerelement. Wenn Sie das Bezeichnungsfeld-Steuerelement erstellen, setzen Sie dessen Argument übergeordnet auf eine Zeichenfolge, die den Namen des übergeordneten Steuerelements identifiziert. Wenn Sie das Textfeld erstellen, setzen Sie dessen Argument übergeordnet auf eine leere Zeichenfolge.

Das Argument übergeordnet stellen Sie auch beim Erstellen von Kontrollkästchen, Optionsschaltflächen oder Umschaltflächen ein. Eine Optionsgruppe ist das übergeordnete Steuerelement der darin enthaltenen Kontrollkästchen, Optionsfelder oder Umschaltflächen. Die einzigen Steuerelemente, für die es ein übergeordnetes Steuerelement geben kann, sind Bezeichnungsfeld, Kontrollkästchen, Optionsfeld und Umschaltfläche. Alle diese Steuerelemente können auch unabhängig, also ohne ein übergeordnetes Steuerelement erstellt werden.

Stellen Sie das Argument Spaltenname entsprechend dem Typ des zu erstellenden Steuerelements und in Abhängigkeit davon ein, ob es an ein Feld in einer Tabelle gebunden wird oder nicht. Die Steuerelemente, die an ein Feld gebunden werden können, umfassen Textfeld, Listenfeld, Kombinationsfeld, Optionsgruppe und gebundenes Objektfeld. Darüber hinaus können die Umschaltfläche-, Optionsfeld- und die Kontrollkästchen-Steuerelemente an ein Feld gebunden werden, wenn sie nicht in einer Optionsgruppe enthalten sind.

Wenn Sie bei dem Argument Spaltenname den Namen eines Feldes angeben, erstellen Sie ein an dieses Feld gebundenes Steuerelement. Sämtliche Eigenschaften des Steuerelements werden dann automatisch auf die Einstellungen aller entsprechenden Feldeigenschaften eingestellt. So ist beispielsweise der Wert der Eigenschaft des ValidationRule-Steuerelements identisch mit dem Wert dieser Eigenschaft für das Feld.

Anmerkung Wenn der Assistent Steuerelemente in einem neuen oder vorhandenen Formular oder Bericht erstellt, müssen Sie zuerst das Formular bzw. den Bericht in der Entwurfsansicht öffnen.

Zum Entfernen eines Steuerelements aus einem Formular oder Bericht verwenden Sie die Anweisungen DeleteControl und DeleteReportControl.


 CreateDataAccessPage-Methode

CreateDataAccessPage-Methode

Mit der CreateDataAccessPage-Methode können Sie eine neue leere Datenzugriffsseite erstellen oder eine vorhandene HTML-Seite als Datenzugriffsseite öffnen.

Syntax

Objekt.CreateDataAccessPage Dateiname [, NeueDateiErstellen]

Die CreateDataAccessPage-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Das Application-Objekt.
Dateiname | Ein Zeichenfolgenausdruck, der den Namen und Pfad der Datenzugriffsseite bezeichnet.
NeueDateiErstellen | Ein Wert vom Typ Boolean. True (-1) erstellt eine neue HTML-Seite und die zugehörige Verknüpfung, während False eine neue Verknüpfung zu einer vorhandenen HTML-Datei erstellt. Der Standardwert ist True.

Die folgende Tabelle zeigt die vier möglichen Kombinationen der für die CreateDataAccessPage-Methode festlegbaren Einstellungen und die Ergebinsse dieser Einstellungen.

Dateiname | NeueDateiErstellen | Ergebnis
leer oder neuer Name und Pfad | True (-1) | Eine neue minimierte Datenzugriffsseite wird erstellt und in der Entwurfsansicht geöffnet. Eine Verknüpfung mit dieser Seite wird in der Pages-Objektliste des Datenbankfensters erstellt.
leer oder neuer Name und Pfad | False (0) | Ein Fehler tritt auf.
Name und Pfad einer vorhandenen Datei | False (0) | Eine neue Verknüpfung mit eindeutigem Namen wird erstellt. Diese neue Verknüpfung verweist auf die vorhandene Datenzugriffsseite.
Name und Pfad einer vorhandenen Datei | True (-1) | Ein Fehler tritt auf.

Anmerkungen

Sie können die CreateDataAccessPage-Methode beim Entwurf eines Assistenten zur Erstellung einer neuen Datenzugriffsseite verwenden.

Die mit dem Argument Dateiname bezeichnete Datenzugriffsseite kann eine speziell für die Verwendung als Vorlage erstellte Seite oder eine beliebige andere Datenzugriffsseite in der Datenbank sein, die mit Dateiname und dem Wert False für das Argument NeueDateiErstellen festgelegt wird.

Die CreateDataAccessPage-Methode erstellt eine Datenzugriffsseite in minimierter Darstellung. Wenn Sie die neue Datenzugriffsseite nach der Erstellung anzeigen möchten, müssen Sie die Restore-Methode verwenden.


 CreateEventProc-Methode

CreateEventProc-Methode

Die Methode CreateEventProc erstellt eine Ereignisprozedur in einem Klassenmodul. Sie gibt einen Wert vom Datentyp Long zurück, der die Nummer der ersten Zeile der Ereignisprozedur angibt.

Syntax

Objekt.CreateEventProc(Ereignisname, Objektname)

Die Methode CreateEventProc hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt vom Typ Form oder Report; dessen Type-Eigenschaft acClassModule, eine Konstante mit dem Wert 1, zurückgibt.
Ereignisname | Ein Zeichenfolgenausdruck, der zum Namen eines Ereignisses ausgewertet wird.
Objektname | Ein Objekt, auf das das im Argument Ereignisname angegebene Ereignis zutrifft. Es kann ein Form-, Report- oder Control-Objekt, ein Formular- oder Berichtsbereich oder ein Klassenmodul sein.

Anmerkung

Die Methode CreateEventProc erstellt einen Code-Abschnitt für eine Ereignisprozedur für das angegebene Objekt. Beispielsweise können Sie mit dieser Methode eine Click-Ereignisprozedur für eine Befehlsschaltfläche auf einem Formular erstellen. Microsoft Access erstellt die Click-Ereignisprozedur in dem Modul, das dem Formular mit der betreffenden Befehlsschaltfläche zugeordnet ist.

Wenn Sie den Code-Abschnitt für die Ereignisprozedur mit der Methode CreateEventProc erstellt haben, können Sie Codezeilen mit Hilfe anderer Methoden des Module-Objekts hinzufügen. Beispielsweise können Sie mit der Methode InsertLines eine Codezeile einfügen.


 CreateForm-, CreateReport-Methoden

CreateForm-, CreateReport-Methoden

  • Die CreateForm-Methode erstellt ein Formular und gibt ein Form-Objekt zurück.

  • Die CreateReport-Methode erstellt einen Bericht und gibt ein Report-Objekt zurück.

Angenommen, Sie entwickeln einen Assistenten, der Umsatzberichte erstellen soll. Sie können die CreateReport-Methode in Ihrem Assistenten verwenden, um einen neuen Bericht zu erstellen, der auf einer angegebenen Berichtsvorlage basiert.

Syntax

CreateForm([Datenbank[, Formularvorlage]])

CreateReport([Datenbank[, Berichtsvorlage]])

Die CreateForm- und die CreateReport-Methode haben die folgenden Argumente.

Argument | Beschreibung
Datenbank | Ein Zeichenfolgenausdruck, der den Namen der Datenbank angibt, in der die Formular- oder Berichtsvorlage enthalten ist, die Sie zum Erstellen des Formulars oder Berichts verwenden möchten. Wenn Sie die aktuelle Datenbank verwenden möchten, lassen Sie dieses Argument weg. Wenn Sie eine geöffnete Bibliotheksdatenbank verwenden möchten, geben Sie sie mit diesem Argument an.
Formularvorlage, Berichtsvorlage | Ein Zeichenfolgenausdruck, der den Namen des Formulars oder Berichts angibt, das bzw. der als Vorlage zum Erstellen eines neuen Formulars oder Berichts verwendet werden soll. Wenn Sie dieses Argument nicht angeben, legt Microsoft Access dem neuen Formular oder Bericht die Vorlage zugrunde, die im Dialogfeld Optionen auf der Registerkarte Formulare/Berichte angegeben ist. Sie öffnen dieses Dialogfeld, indem Sie im Menü Extras auf Optionen klicken.

Anmerkung

Sie können die CreateForm- und die CreateReport-Methode verwenden, wenn Sie einen Assistenten entwickeln, mit dem neue Formulare oder Berichte erstellt werden können.

Die CreateForm- und die CreateReport-Methode öffnen ein neues, minimiertes Formular bzw. einen neuen, minimierten Bericht in der Entwurfsansicht eines Formulars bzw. in der Entwurfsansicht eines Berichts.

Bei dem als Formularvorlage angegebenen Formular oder dem als Berichtsvorlage angegebenen Bericht kann es sich um ein Formular/einen Bericht handeln, das/der eigens zur Verwendung als Vorlage erstellt wurde, oder um ein beliebiges Formular bzw. einen beliebigen Bericht in derjenigen Datenbank, die durch das Argument Datenbank angegeben ist. Ist die im Argument Datenbank angegebene Datenbank nicht die aktuelle Datenbank, muss diese Datenbank als Bibliotheksdatenbank geöffnet sein. Weitere Informationen zu Bibliotheksdatenbanken finden Sie in Kapitel 10, "Die Windows-API and andere DLL's", im Microsoft Office 2000/Visual Basic Handbuch für Programmierer. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Handbuch für Programmierer erhalten können, klicken Sie auf [image] .

Anmerkung Wenn Sie eine Formular- oder Berichtsvorlage, die Sie als Vorlage verwenden möchten, in einer anderen Datenbank erstellt haben, können Sie diese Vorlage einfach in die aktuelle Datenbank importieren, statt eine Bibliotheksdatenbank zu laden. Danach sollten Sie prüfen, ob im Dialogfeld Optionen auf der Registerkarte Formulare/Berichte im Feld Formularvorlage bzw. Berichtsvorlage der gewünschte Formular- bzw. Berichtsname angezeigt wird. Formulare bzw. Berichte, die später mit der CreateForm- bzw. mit der CreateReport-Methode erstellt werden, basieren dann auf dieser Vorlage.

Ist der im Argument Formularvorlage bzw. Berichtsvorlage verwendete Name ungültig, verwendet Visual Basic die Formular- bzw. Berichtsvorlage, die im Dialogfeld Optionen auf der Registerkarte Formulare/Berichte im Feld Formularvorlage bzw. Berichtsvorlage angegeben ist.

Wenn Sie ein Formular bzw. einen Bericht mit der CreateForm- bzw. mit der CreateReport-Methode erstellen, wird die Eigenschaft Enthält Modul des Formulars bzw. Berichts auf Nein (0) eingestellt. Wenn Sie möchten, dass das neue Formular bzw. der neue Bericht ein Klassenmodul hat, können Sie diese Eigenschaft auf Ja (-1) einstellen.

Die CreateForm- und die CreateReport-Methode erstellen minimierte Formulare bzw. Berichte.


 CreateGroupLevel-Methode

CreateGroupLevel-Methode

Mit der CreateGroupLevel-Methode können Sie ein Feld oder einen Ausdruck angeben, nach dem Daten in einem Bericht gruppiert oder sortiert werden sollen.

Angenommen, Sie entwickeln einen Assistenten, der dem Benutzer, wenn er einen Bericht entwirft, die Wahl zwischen mehreren Feldern gibt, nach denen Daten gruppiert werden können. Rufen Sie aus dem Assistenten heraus die CreateGroupLevel-Methode auf, um die passenden Gruppen entsprechend der Auswahl des Benutzers zu erstellen.

Syntax

CreateGroupLevel(Bericht, Ausdruck, Kopf, Fuß)

Die CreateGroupLevel-Methode hat die folgenden Argumente.

Argument | Beschreibung
Bericht | Ein Zeichenfolgenausdruck, der den Namen des Berichts angibt, der die neue Gruppierungsebene enthält.
Ausdruck | Ein Zeichenfolgenausdruck, der das Feld oder den Ausdruck angibt, nach dem sortiert oder gruppiert werden soll.
Kopf, Fuß | Ein Integer-Wert, der angibt, ob das Feld oder der Ausdruck einen zugeordneten Gruppenkopf und/oder Gruppenfuß hat. Ist das Argument Kopf oder Fuß auf True (-1) eingestellt, hat das Feld bzw. der Ausdruck einen Gruppenkopf oder -fuß. Ist das Argument Kopf oder Fuß auf False (0) eingestellt, hat das Feld bzw. der Ausdruck keinen Gruppenkopf oder -fuß. Sie können einen Kopf und einen Fuß erstellen, indem Sie beide Argumente auf True einstellen.

Anmerkung

Sie können die CreateGroupLevel-Methode verwenden, wenn Sie einen Assistenten entwickeln, der einen Bericht mit Gruppen oder Summen erstellt. Die CreateGroupLevel-Methode gruppiert oder sortiert Daten nach dem angegebenen Feld oder Ausdruck und erstellt einen Kopf und/oder Fuß für die Gruppierungsebene.

Die CreateGroupLevel-Methode steht nur in der Entwurfsansicht eines Berichts zur Verfügung.

Microsoft Access verwendet ein Datenfeld, das Eigenschaftendatenfeld GroupLevel, um die für einen Bericht erstellten Gruppierungsebenen zu verwalten. Die CreateGroupLevel-Methode fügt, ausgehend von dem Argument Ausdruck, eine neue Gruppierungsebene zu dem Datenfeld hinzu. Danach gibt die CreateGroupLevel-Methode einen Indexwert zurück, der die Position der neuen Gruppierungsebene in diesem Datenfeld angibt. Das erste Feld oder der erste Ausdruck, nach dem sortiert oder gruppiert wird, entspricht der Ebene 0, das oder der zweite der Ebene 1 usw. Ein Bericht kann bis zu zehn Gruppierungsebenen (0-9) haben.

Wenn Sie dem Argument Kopf oder Fuß (oder beiden) den Wert True zuweisen, werden die Eigenschaften GroupHeader und GroupFooter des Berichts auf Ja eingestellt, und es wird ein Kopf und/oder Fuß für die Gruppierungsebene erstellt.

Nachdem ein Kopf oder Fuß erstellt wurde, können Sie weitere Gruppierungsebeneneigenschaften einstellen: GroupOn (GruppierenNach), GroupInterval (Intervall) und KeepTogether (Zusammenhalten). Sie können diese Eigenschaften in Visual Basic oder in dem Dialogfeld Sortieren und gruppieren einstellen. Letzteres wird angezeigt, wenn Sie in der Symbolleiste Berichtsentwurf auf Sortieren und gruppieren [image] klicken.

Anmerkung Wenn Ihr Assistent Gruppierungsebenen in einem neuen oder vorhandenen Bericht erstellt, muss er den Bericht in der Entwurfsansicht öffnen.


 CreateNewDocument-Methode

CreateNewDocument-Methode

Mit der CreateNewDocument-Methode können Sie ein neues, mit einem bestimmten Hyperlink verknüpftes Dokument erstellen.

Syntax

Objekt.CreateNewDocument Dateiname, JetztBearbeiten, Überschreiben

Die CreateNewDocument-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Das Hyperlink-Objekt innerhalb eines Steuerelements.
Dateiname | Ein Zeichenfolgenausdruck, der den Namen und Pfad des Dokuments bezeichnet. Der Typ des gewünschten Dokumentenformats kann anhand der Dateinamenerweiterung bestimmt werden, die zusammen mit dem Dateinamen für die Datenausgabe verwendet wird. Sie können HTML-Dateien (*.htm), Microsoft Active Server Pages-Dateien (*.asp), Microsoft Excel-Dateien (*.xls), Microsoft IIS-Dateien (*.htx, *.idc), MS-DOS Textdateien (*.txt), Rich Text Format-Dateien (*.rtf) oder Microsoft-Datenzugriffsdateien (Data Access Pages, *.html) erstellen. Code kann nur im MS-DOS Textformat ausgegeben werden. Datenzugriffsseiten lassen sich nur im HTML-Format speichern. Microsoft Internet Information Server- und Microsoft Active Server-Dateiformate sind nur für Tabellen, Abfragen und Formulare verfügbar.
 | Anmerkung Wenn keine Dateinamenerweiterung angegeben wird, gilt das Format für Datenzugriffsseiten (.html). Wenn kein Verzeichnis angegeben ist, wird der Standarddatenbankordner verwendet. Dieses Verzeichnis wird anhand der Einstellungen im Dialogfeld Optionen ermittelt.
JetztBearbeiten | Ein Wert vom Typ Boolean. True (-1) öffnet das Dokument in der Entwurfsansicht, während False das neue Dokument im angegebenen Datenbankverzeichnis speichert. Der Standardwert ist True.
Überschreiben | Ein Wert vom Typ Boolean. True (-1) überschreibt ein vorhandenes Dokument, wenn das Argument Dateiname ein bereits existierendes Dokument bezeichnet, während False voraussetzt, dass Dateiname einen neuen Dateinamen angibt. Der Standardwert ist False.

Anmerkungen

Die CreateNewDocument-Methode ermöglicht es, ein Dokument programmgesteuert zu erstellen, das mit einem Hyperlink innerhalb eines Steuerelements verknüpft ist.


 CurrentDb-Methode

CurrentDb-Methode

Die CurrentDb-Methode gibt eine Objektvariable des Typs Database zurück, die der Datenbank entspricht, die momentan im Microsoft Access-Fenster geöffnet ist.

Anmerkung In Microsoft Access 2000 bewirkt die CurrentDb-Methode die Erstellung einer verborgenen Referenz auf die Microsoft DAO 3.6-Objektbibliothek in einer Microsoft Access-Datenbank (.mdb). Wenn Sie die CurrentDb-Methode in einem Microsoft Access-Projekt (.adp) verwenden möchten. müssen Sie eine permanente Referenz auf die DAO 3.6-Objektbibliothek im Microsoft Visual Basic-Editor festlegen.

Syntax

CurrentDb

Anmerkung

Wenn Sie die Struktur Ihrer Datenbank und deren Daten aus Visual Basic heraus ändern möchten, müssen Sie Datenzugriffsobjekte (DAO) verwenden. Die CurrentDb-Methode bietet eine Möglichkeit zum Zugriff auf die aktuelle Datenbank von Visual Basic-Code aus, ohne dass Sie den Namen der Datenbank kennen müssen. Sobald Sie eine Variable haben, die auf die aktuelle Datenbank zeigt, können Sie auch auf andere Objekte und Auflistungen der DAO-Hierarchie zugreifen und sie bearbeiten.

Mit der CurrentDb-Methode können Sie mehrere Objektvariablen erstellen, die auf die aktuelle Datenbank verweisen. Im folgenden Beispiel verweisen die Variablen dbsA und dbsB beide auf die aktuelle Datenbank:

Dim dbsA As Database, dbsB As Database
Set dbsA = CurrentDb
Set dbsB = CurrentDb

Anmerkung In älteren Versionen von Microsoft Access haben Sie möglicherweise die Syntax DBEngine.Workspaces(0).Databases(0) oder DBEngine(0)(0) verwendet, um einen Zeiger auf die aktuelle Datenbank zurückzugeben. In Microsoft Access 2000 sollten Sie stattdessen die CurrentDb-Methode verwenden. Die CurrentDb-Methode erstellt eine weitere Instanz der aktuellen Datenbank, während die Syntax DBEngine(0)(0) auf die geöffnete Kopie der aktuellen Datenbank verweist. Die CurrentDb-Methode ermöglicht es Ihnen, mehrere Variablen des Typs Database zu erstellen, die alle auf die aktuelle Datenbank verweisen. Microsoft Access unterstützt zwar weiterhin die Syntax DBEngine(0)(0), Sie sollten jedoch die Änderung Ihres Codes in Betracht ziehen, um mögliche Konflikte in einer Mehrbenutzerdatenbank zu vermeiden.

Falls Sie mit einer anderen Datenbank arbeiten müssen, während die aktuelle Datenbank im Microsoft Access-Fenster geöffnet ist, verwenden Sie die OpenDatabase-Methode eines Workspace-Objekts. Die OpenDatabase-Methode öffnet die zweite Datenbank nicht wirklich im Microsoft Access-Fenster, sondern gibt einfach eine Variable des Typs Database zurück, die der zweiten Datenbank entspricht. Im folgenden Beispiel wird ein Zeiger auf die aktuelle Datenbank sowie auf eine Datenbank namens Kontakte.mdb zurückgegeben:

Dim dbsAktuell As Database, dbsKontakte As Database
Set dbsAktuell = CurrentDb
Set dbsKontakte = _ DBEngine.Workspaces(0).OpenDatabase("Kontakte.mdb")


 CurrentUser-Methode

CurrentUser-Methode

Mit der CurrentUser-Methode können Sie den Namen des aktuellen Datenbankbenutzers zurückgeben.

Verwenden Sie z. B. die CurrentUser-Methode in einer Prozedur, die die Benutzer protokolliert, die Änderungen an der Datenbank vornehmen.

Syntax

CurrentUser

Bemerkungen

Die CurrentUser-Methode gibt eine Zeichenfolge zurück, die den Namen des aktuellen Benutzerkontos enthält.

Falls Sie keine geschützte Arbeitsgruppe eingerichtet haben, gibt die CurrentUser-Methode den Namen des Standardbenutzerkontos "Administrator" zurück. Das Benutzerkonto "Administrator" gewährt dem Benutzer uneingeschränkte Zugriffsberechtigungen auf alle Datenbankobjekte.

Falls Sie den Arbeitsgruppenschutz aktiviert haben, gibt die CurrentUser-Methode den Namen des aktuellen Benutzerkontos zurück. Für ein Benutzerkonto, das nicht den Namen "Administrator" hat, können Sie Berechtigungen angeben, die den Zugriff des Benutzers auf die Datenbankobjekte einschränken.

Im folgenden Beispiel wird der Name des aktuellen Benutzers abgerufen und in einem Dialogfeld angezeigt.

MsgBox("Der aktuelle Benutzer heißt: " & CurrentUser)


 DefaultControl-Methode

DefaultControl-Methode

Die Methode DefaultControl gibt ein Objekt Control zurück, mit dem Sie für ein bestimmtes Formular die Standardeigenschaften eines bestimmten Typs von Steuerelement in einem bestimmten Formular oder Bericht einstellen können. Bevor Sie z. B. ein Textfeld in einem Formular erstellen, möchten Sie möglicherweise die Standardeigenschaften für das Textfeld einstellen. Als nächstes können Sie eine Reihe von Textfeldern erstellen, die über die gleichen grundlegenden Eigenschafteneinstellungen verfügen, anstatt die Eigenschaften für jedes Textfeld einzeln einstellen zu müssen, sobald Sie es erstellt haben.

Syntax

Set Steuerelement = Objekt.DefaultControl(Steuerelementtyp)

Die Methode DefaultControl hat die folgenden Argumente.

Argument | Beschreibung
Steuerelement | Ein Objekt Control, für das die Standardeigenschaften eingestellt werden sollen.
Objekt | Ein Objekt Form oder Report, auf dem Steuerelemente erstellt werden sollen. Die für eine Steuerelementart definierten Standardeigenschafteneinstellungen gelten nur für die auf diesem Formular oder Bericht erstellten Steuerelemente desselben Typs.
Steuerelementtyp | Eine eingebaute Konstante, die den Typ des Steuerelements angibt, für das Standardeigenschafteneinstellungen festgelegt werden sollen.

Anmerkung

Die Methode DefaultControl ermöglicht es Ihnen, die Standardeigenschaften eines Steuerelements aus Code heraus festzulegen. Sobald Sie die Standardeigenschaften für einen bestimmten Steuerelementtyp eingestellt haben, hat jedes daraufhin erstellte Steuerelement dieses Typs dieselben Standardwerte.

Wenn Sie z. B. die Eigenschaft Schriftgrad der standardmäßigen Befehlsschaltfläche auf 12 einstellen, wird jede neue Befehlsschaltfläche den Schriftgrad 12 Punkt haben.

Nicht alle Eigenschaften eines Steuerelements sind als Standardeigenschaften verfügbar. Die für ein Steuerelement verfügbaren Standardeigenschaften hängen vom Typ des Steuerelements ab.

Die Methode DefaultControl gibt ein Objekt Control des Typs zurück, der durch das Argument Steuerelementart festgelegt ist. Dieses Objekt Control stellt kein tatsächliches Steuerelement eines Formular dar, sondern ein Standardsteuerelement, das als Vorlage für alle anschließend erstellten Steuerelemente dieses Typs dient. Sie stellen die Standardsteuerelementeigenschaften für das von der Methode DefaultControl zurückgegebene Objekt Control auf die gleiche Weise ein, wie Sie die Eigenschaften für ein Steuerelement eines Formulars einstellen würden.

Eine Liste der eingebauten Konstanten, die als Argument Steuerelementart übergeben werden können, finden Sie unter der Methode CreateControl. Diese Konstanten werden auch aufgelistet, wenn Sie im Objektkatalog das Modul Constants auswählen.

Die Methode DefaultControl kann nur in der Formularentwurfsansicht oder der Berichtsentwurfsansicht verwendet werden. Falls Sie versuchen, diese Methode auf ein Formular oder einen Bericht anzuwenden, das oder der sich nicht in der Entwurfsansicht befindet, ergibt sich ein Laufzeitfehler.

Wenn Sie versuchen, eine Eigenschaft einzustellen, die nicht als Standardeigenschaft mit der Methode DefaultControl eingestellt werden kann, ergibt sich ein Laufzeitfehler. Wenn Sie ermitteln möchten, welche Eigenschaften Standardeigenschaften sein können, müssen Sie die Auflistung Properties des Objekts Control auswerten, das von der Methode DefaultControl zurückgegeben wird.


 DefaultWorkspaceClone-Methode

DefaultWorkspaceClone-Methode

Sie können die Methode DefaultWorkspaceClone verwenden, um ein neues Objekt Workspace zu erstellen, ohne dass sich der Benutzer erneut anmelden muss. Wenn Sie z. B. zwei Transaktionen gleichzeitig in getrennten Arbeitsbereichen durchführen müssen, können Sie mit der Methode DefaultWorkspaceClone ein zweites Objekt Workspace mit demselben Benutzernamen und Kennwort erstellen, ohne dass der Benutzer erneut zur Eingabe dieser Informationen aufgefordert wird.

Anmerkung Bei Microsoft Access 2000 ist die Methode DefaultWorkspaceClone in dieser Microsoft Access-Version nur wegen der Kompatibilität mit früheren Versionen vorhanden, die die DAO (Data Access Object)-Sprache verwenden.

Syntax

Anwendung.DefaultWorkspaceClone

Die Methode DefaultWorkspaceClone hat das folgende Argument.

Argument | Beschreibung
Anwendung | Das Objekt Application.

Anmerkung

Die Methode DefaultWorkspaceClone erstellt in Microsoft Access ein Duplikat des standardmäßigen Objekts Workspace. Die Eigenschaften des duplizierten Objekts Workspace haben dieselben Einstellungen wie das standardmäßige Objekt Workspace, mit Ausnahme der Eigenschaft Name. Für das standardmäßige Objekt Workspace ist der Wert der Eigenschaft Name stets #Default Workspace#. Für das duplizierte Objekt Workspace ist der Wert #CloneAccess#.

Die Eigenschaft UserName des standardmäßigen Objekts Workspace zeigt den Namen an, unter dem der jetzige Benutzer angemeldet ist. Das duplizierte Objekt Workspace entspricht dem Objekt Workspace, das erstellt werden würde, wenn sich derselbe Benutzer erneut unter demselben Kennwort anmeldete.


 Delete-Methode (FormatCondition-Objekt)

Delete-Methode (FormatCondition-Objekt)

Mit der Delete-Methode können Sie ein FormatCondition-Objekt aus der FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements entfernen.

Syntax

Objekt.Delete

Die Delete-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zu einem FormatCondition-Objekt eines Kombinationsfeld- oder Textfeld-Steuerelements ausgewertet wird.

Anmerkungen

Sie können die Add-Methode dazu verwenden, eine bedingte Formatierung zur FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements hinzuzufügen.


 Delete-Methode (FormatConditions-Auflistung)

Delete-Methode (FormatConditions-Auflistung)

Mit der Delete-Methode können Sie alle bedingten Formatierungen in der FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements entfernen.

Syntax

Objekt.Delete

Die Delete-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur FormatConditions-Auflistung des Kombinationsfeld- bzw. Textfeld-Steuerelements ausgewertet wird.

Anmerkungen

Sie können die Add-Methode dazu verwenden, bedingte Formatierungen zur FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements hinzuzufügen.


 DeleteControl-, DeleteReportControl-Methoden

DeleteControl-, DeleteReportControl-Methoden

  • Die DeleteControl-Methode löscht ein Steuerelement von einem Formular.

  • Die DeleteReportControl-Methode löscht ein Steuerelement von einem Bericht.

Angenommen, Sie haben eine Prozedur, die immer dann ausgeführt werden muss, wenn sich ein Benutzer das erste Mal bei Ihrer Datenbank anmeldet. Sie können über die OnClick-Eigenschaft einer Schaltfläche des Formulars dafür sorgen, dass diese Prozedur ausgeführt wird. Nachdem sich der Benutzer angemeldet und die Prozedur ausgeführt hat, können Sie die DeleteControl-Methode verwenden, um die Befehlsschaltfläche dynamisch von dem Formular zu löschen.

Syntax

DeleteControl Formularname, Steuerelementname

DeleteReportControl Berichtsname, Steuerelementname

Die DeleteControl- und die DeleteReportControl-Methode haben die folgenden Argumente.

Argument | Beschreibung
Formularname, Berichtsname | Ein Zeichenfolgenausdruck, der den Namen des Formulars oder Berichts angibt, zu dem das zu löschende Steuerelement gehört.
Steuerelementname | Ein Zeichenfolgenausdruck, der den Namen des zu löschenden Steuerelements angibt.

Anmerkung

Die DeleteControl- und die DeleteReportControl-Methode sind nur in der Formularentwurfsansicht bzw. in der Berichtsentwurfsansicht verfügbar.

Anmerkung Wenn Sie einen Assistenten entwickeln, der ein Steuerelement von einem Formular oder Bericht löscht, muss der Assistent das Formular oder den Bericht in der Entwurfsansicht öffnen, bevor er das Steuerelement löschen kann.


 DeleteLines-Methode

DeleteLines-Methode

Die Methode DeleteLines löscht Zeilen in einem Standardmodul oder Klassenmodul.

Syntax

Objekt.DeleteLines Anfangszeile, Anzahl

Die Methode DeleteLines hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Anfangszeile | Ein Wert vom Datentyp Long, der angibt, ab welcher Zeile gelöscht werden soll.
Anzahl | Ein Wert vom Datentyp Long, der angibt, wie viele Zeilen gelöscht werden sollen.

Anmerkung

Die Zeilen in einem Modul sind ab Eins nummeriert. Sie können die Anzahl der Zeilen in einem Modul mit der Eigenschaft CountOfLines ermitteln.

Um eine Zeile durch eine andere zu ersetzen, verwenden Sie die Methode ReplaceLine.


 DeleteObject-Methode

DeleteObject-Methode

Die Methode DeleteObject führt die Aktion LöschenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.DeleteObject [Objekttyp][, Objektname]

Die Methode DeleteObject verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcdure acTable
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.
 | Wenn Sie Visual Basic-Code, der die Methode DeleteObject enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkung

Wenn Sie die Argumente Objekttyp und Objektname nicht angeben, wird die Standardkonstante (acDefault) für Objekttyp verwendet, und Microsoft Access löscht das im Datenbankfenster markierte Objekt. Um ein Objekt im Datenbankfenster zu markieren, verwenden Sie die Aktion AuswählenObjekt oder die Methode SelectObject, wobei das Argument Im Datenbankfenster auf True eingestellt sein muss.


 DoMenuItem-Methode

DoMenuItem-Methode

Anmerkung In Microsoft Access 97 wurde die Methode DoMenuItem durch die Methode RunCommand ersetzt. Die Methode DoMenuItem ist in dieser Microsoft Access-Version nur wegen der Kompatibilität mit früheren Versionen vorhanden. Wenn Sie bestehenden Visual Basic-Code ausführen, der eine Methode DoMenuItem enthält, zeigt Microsoft Access den entsprechenden Menü- oder Symbolleistenbefehl für Microsoft Access 2000 an. Im Gegensatz zur Aktion AusführenMenübefehl in einem Makro wird eine Methode DoMenuItem in Visual Basic-Code nicht in eine Methode RunCommand konvertiert, wenn Sie eine Datenbank aus einer früheren Microsoft Access-Version konvertieren.

Einige Befehle aus früheren Microsoft Access-Versionen sind in Microsoft Access 2000 nicht mehr verfügbar. DoMenuItem-Methoden, die solche Befehle ausführen, erzeugen einen Fehler, wenn sie in Visual Basic ausgeführt werden. Bearbeiten Sie den Visual Basic-Code, und ersetzen oder löschen Sie die betreffenden DoMenuItem-Methoden.

Syntax

DoCmd.DoMenuItem Menüleiste, Menüname, Befehl[, Unterbefehl][, Version]

Die Methode DoMenuItem verwendet die folgenden Argumente:

Argument | Beschreibung
Menüleiste | Verwenden Sie in der Formularansicht für die Menüleiste die eingebaute Konstante acFormBar.
 | Verwenden Sie für andere Ansichten die Nummer der gewünschten Ansicht in der Liste des Arguments Menüleiste (zählen Sie in der Liste abwärts, beginnend bei 0). Die entsprechende Anzeige wurde in früheren Microsoft Access-Versionen im Makrofenster dargestellt.
Menüname | Verwenden Sie eine der folgenden eingebauten Konstanten:
 | acFile acEditMenu acRecordsMenu
 | Sie können acRecordsMenu nur für die Menüleiste der Formularansicht in Datenbanken von Microsoft Access, Version 2.0, und Microsoft Access 95 verwenden.
 | Verwenden Sie für andere Ansichten die Nummer der gewünschten Ansicht in der Liste des Arguments Menüleiste (zählen Sie in der Liste abwärts, beginnend bei 0). Die entsprechende Anzeige wurde in früheren Microsoft Access-Versionen im Makrofenster dargestellt.
Befehl | Verwenden Sie eine der folgenden eingebauten Konstanten:
 | acNew acSaveForm acSaveFormAs acSaveRecord acUndo acCut acCopy acPaste acDelete acSelectRecord acSelectAllRecords acObject acRefresh
 | Verwenden Sie für andere Befehle die Nummer des gewünschten Befehls in der Liste des Arguments Befehl (zählen Sie in der Liste abwärts, beginnend bei 0). Die entsprechende Anzeige wurde in früheren Microsoft Access-Versionen im Makrofenster dargestellt.
Unterbefehl | Verwenden Sie eine der folgenden eingebauten Konstanten:
 | acObjectVerb acObjectUpdate
 | Die Konstante acObjectVerb stellt den ersten Befehl im Untermenü des Befehls Objekt aus dem Menü Bearbeiten dar. Der Objekttyp legt den ersten Befehl des Untermenüs fest. Für ein Paintbrush-Objekt, das bearbeitet werden kann, lautet dieser Befehl z. B. Bearbeiten.
 | Verwenden Sie für andere Befehle in Untermenüs die Nummer des gewünschten Unterbefehls in der Liste des Arguments Unterbefehl (zählen Sie in der Liste abwärts, beginnend bei 0). Die entsprechende Anzeige wurde in früheren Microsoft Access-Versionen im Makrofenster dargestellt.
Version | Verwenden Sie die eingebaute Konstante acMenuVer70 für Code, der für Microsoft Access 95-Datenbanken geschrieben wurde, die eingebaute Konstante acMenuVer20 für Code, der für Microsoft Access-Datenbanken der Version 2.0 geschrieben wurde, oder die eingebaute Konstante acMenuVer1X für Code, der für Microsoft Access-Datenbanken der Version 1.x geschrieben wurde. Dieses Argument ist nur in Visual Basic verfügbar.
 | Anmerkung Der Standardwert dieses Arguments ist acMenuVer1X, so dass für Microsoft Access, Version 1.x, geschriebener Code unverändert ausgeführt wird. Wenn Sie für eine Datenbank von Microsoft Access 95 oder Microsoft Access, Version 2.0, Code schreiben und mit der Methode DoMenuItem die Menübefehle von Microsoft Access 95 oder Microsoft Access, Version 2.0, verwenden möchten, stellen Sie dieses Argument auf acMenuVer70 bzw. acMenuVer20 ein.
 | Wenn Sie im Makrofenster in den Listen für die Aktionsargumente Menüleiste, Menüname, Befehl und Unterbefehl zählen, um die Nummern für die Argumente der Methode DoMenuItem zu ermitteln, verwenden Sie ebenfalls die Listen der richtigen Versionen: Microsoft Access 95, falls das Argument Version auf acMenuVer70 eingestellt ist; Microsoft Access, Version 2.0, falls das Argument Version auf acMenuVer20 eingestellt ist; Microsoft Access, Version 1.x, falls das Argument Version auf acMenuVer1X eingestellt ist oder fehlt.
 | Anmerkung Die Einstellung acMenuVer80 gibt es für dieses Argument nicht. Sie können mit der Methode DoMenuItem keine Microsoft Access 97- oder Microsoft Access 2000-Befehle anzeigen (obwohl die bestehenden DoMenuItem-Methoden in Visual Basic-Code weiterhin funktionieren). Verwenden Sie stattdessen die Methode RunCommand.

Anmerkung

Die Auswahlmöglichkeiten, die im Makrofenster in den Listen der Aktionsargumente Menüname, Befehl und Unterbefehl angezeigt werden, hängen vom jeweils vorher gewählten Argument ab. Verwenden Sie für die Argumente Menüleiste, Menüname, Befehl und Unterbefehl geeignete Zahlen bzw. eingebaute Konstanten.

Wenn Sie das Argument Unterbefehl weglassen, aber das Argument Version angeben, geben Sie das Komma des Arguments Unterbefehl an. Wenn Sie die Argumente Unterbefehl und Version weglassen, geben Sie nach dem Argument Befehl kein Komma an.


 Dropdown-Methode

Dropdown-Methode

Mit der Methode Dropdownfeld können Sie erzwingen, dass die Liste des angegebenen Kombinationsfelds geöffnet wird. Sie könnten z. B. mit Hilfe dieser Methode veranlassen, dass die Dropdownliste eines Kombinationsfelds, in dem Händlercodes aufgelistet werden, geöffnet wird, sobald das Steuerelement für die Händlercodes während der Dateneingabe den Fokus erhalten hat.

Syntax

Kombinationsfeld.Dropdown

Die Methode Dropdownfeld hat das folgende Argument.

Argument | Beschreibung
Kombinationsfeld | Ein Kombinationsfeld-Steuerelement auf einem Formular.

Anmerkung

Wenn das angegebene Kombinationsfeld-Steuerelement nicht den Fokus hat, tritt ein Fehler auf. Das Verwenden dieser Methode entspricht dem Drücken von F4, wenn das Steuerelement den Fokus hat.


 Echo-Methode (Application-Objekt)

Echo-Methode (Application-Objekt)

Die Methode Echo gibt an, ob Microsoft Access die Bildschirmanzeige des Computers aktualisieren soll.

Syntax

Application.Echo EchoEin[, Statusleistentext]

Die Methode Echo hat folgende Argumente.

Argument | Beschreibung
EchoEin | True (Standardeinstellung) gibt an, dass die Bildschirmanzeige aktualisiert werden soll; False gibt an, dass sie nicht aktualisiert werden soll.
Statusleistentext | Ein Zeichenfolgenausdruck mit dem Text, der in der Statusleiste angezeigt werden soll, wenn die Bildschirmaktualisierung ein- oder ausgeschaltet wird.

Anmerkung

Wenn Sie Visual Basic-Code ausführen, der die auf dem Bildschirm angezeigten Objekte stark ändert, wird der Code in der Regel schneller ausgeführt, wenn Sie die Bildschirmaktualisierung ausschalten, bis die Prozedur beendet ist. Sie können die Aktualisierung auch ausschalten, wenn der Code Änderungen durchführt, die der Benutzer nicht sehen soll oder nicht sehen muss.

Die Methode Echo verhindert nicht die Anzeige von gebundenen Dialogfeldern, wie z. B. Fehlermeldungen, oder Popupformularen, wie z. B. Eigenschaftenfenstern.

Schalten Sie die Bildschirmaktualisierung aus, so zeigt der Bildschirm keinerlei Veränderungen an, auch dann nicht, wenn der Benutzer STRG+UNTBR drückt oder Visual Basic auf einen Haltepunkt trifft, und zwar solange, bis Sie die Bildschirmaktualisierung wieder einschalten. Es empfiehlt sich, ein Makro zu schreiben, das die Bildschirmaktualisierung einschaltet, und das Makro einer Taste oder einem benutzerdefinierten Menübefehl zuzuweisen. Sie können dann mit der Tastenkombination oder dem Menübefehl die Aktualisierung einschalten, wenn sie in Visual Basic ausgeschaltet wurde.

Wenn Sie die Bildschirmaktualisierung ausschalten und versuchen, den Code im Einzelschrittmodus auszuführen, können Sie die Code-Verarbeitung nicht verfolgen und erhalten auch keine anderen optischen Hinweise, bis die Aktualisierung wieder eingeschaltet wird. Der Code wird dennoch weiterhin ausgeführt.

Anmerkung Verwechseln Sie die Methode Echo nicht mit der Methode Repaint. Die Methode Echo schaltet die Bildschirmaktualisierung ein oder aus. Die Methode Repaint führt dagegen eine sofortige Bildschirmaktualisierung durch.


 Echo-Methode (DoCmd-Objekt)

Echo-Methode (DoCmd-Objekt)

Die Methode Echo des Objekts DoCmd führt die Aktion Echo in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Echo Echo[, Statusleistentext]

Die Methode Echo verwendet die folgenden Argumente:

Argument | Beschreibung
Echo | Verwenden Sie True (-1), um das Echo einzuschalten, und False (0), um es auszuschalten.
Statusleistentext | Ein Zeichenfolgenausdruck.

Anmerkung

Wenn Sie das Argument Statusleistentext weglassen, geben Sie nach dem Argument Echo kein Komma ein.

Wenn Sie das Echo in Visual Basic ausschalten, schalten Sie es wieder ein. Andernfalls bleibt es ausgeschaltet, selbst wenn der Benutzer STRG+UNTBR drückt oder Visual Basic auf einen Haltepunkt stößt. Sie können ein Makro erstellen, das das Echo einschaltet, und das Makro dann einer Tastenkombination oder einem benutzerdefinierten Menübefehl zuweisen. Sie können dann das Echo mit dieser Tastenkombination oder dem Menübefehl wieder einschalten, wenn es in Visual Basic ausgeschaltet wurde.

Die Methode Echo des Objekts DoCmd wurde hinzugefügt, um die Abwärtskompatibilität zu gewährleisten, wenn die Aktion Echo im Visual Basic-Code in Microsoft Access 95 ausgeführt wird. Es empfiehlt sich jedoch, stattdessen die vorhandene Methode Echo des Objekts Application zu verwenden.


Exportieren von Berichts-Snapshots

Es gibt zwei Arten, einen Berichts-Snapshot programmgesteuert aus einer Microsoft Access-Datenbank zu exportieren.

  • Sie können die SendObject-Methode verwenden, um einen Berichts-Snapshot in eine E-Mail-Nachricht einzubetten.

  • Außerdem können Sie mit der OutputTo-Methode einen Berichts-Snapshot auf der Festplatte speichern.

Die folgende Tabelle enthält Informationen über die ersten drei Argumente der SendObject-Methode, die zum Versenden eines Berichts-Snapshots in einer E-Mail-Nachricht verwendet wird. Beachten Sie, dass hier nur die ersten drei Argumente der SendObject-Methode behandelt werden, da diese festlegen, wie ein Bericht als Snapshot-Datei anzugeben ist. Weitere Informationen über die anderen Argumente der SendObject-Methode finden Sie unter dem zugehörigen Thema in der Online-Hilfe für Microsoft Access.

Argument | Beschreibung
Objekttyp | Eine Konstante, die den Typ des Objekts bezeichnet, das Sie versenden möchten. Für Berichts-Snapshots ist die Konstante acSendReport anzugeben.
Objektname | Ein Zeichenfolgenausdruck, der den Namen des Berichts angibt, der in die E-Mail-Nachricht als Snapshot-Datei eingebunden werden soll.
Ausgabeformat | Übergeben Sie für dieses Argument den string-Wert "Snapshot Format", um einen Berichts-Snapshot auszugeben.

Die folgende Tabelle enthält Informationen über die ersten vier Argumente der OutputTo-Methode, die zur Speicherung einer Snapshot-Datei auf der Festplatte verwendet wird. Beachten Sie, dass hier die vier Argumente der OutputTo-Methode beschrieben sind, die erforderlich sind, um festzulegen, wie ein Bericht als Snapshot-Datei auf Festplatte gespeichert wird. Weitere Informationen über die restlichen Argumente der OutputTo-Methode finden Sie unter dem zugehörigen Thema in der Online-Hilfe für Microsoft Access.

Argument | Beschreibung
Objekttyp | Eine Konstante, die den Typ des Objekts bezeichnet, das Sie auf der Festplatte speichern möchten. Für Berichts-Snapshots ist die Konstante acOutputReport anzugeben.
Objektname | Ein Zeichenfolgenausdruck, der den Namen des Berichts angibt, der auf der Festplatte gespeichert werden soll.
Ausgabeformat | Übergeben Sie für dieses Argument den string-Wert "Snapshot Format", um einen Berichts-Snapshot zu speichern.
Ausgabedatei | Ein Zeichenfolgenausdruck, der den vollständigen Pfad und Dateinamen der Snapshot-Datei bezeichnet, die Sie auf der Festplatte speichern möchten. Beispiel: "c:\Eigene Dateien\mysnapshot.snp"


 Find-Methode

Find-Methode

Die Methode Find sucht den angegebenen Text in einem Standardmodul oder Klassenmodul.

Syntax

Objekt.Find(Ziel, Anfangszeile, Anfangsspalte, Endzeile, Endspalte[, GanzesWort, GroßKlein, Mustervergleich])

Die Methode Find hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Ziel | Ein Zeichenfolgenausdruck, der zum Suchbegriff ausgewertet wird.
Anfangszeile | Ein Wert vom Datentyp Long, der angibt, ab welcher Zeile gesucht werden soll. Wenn der Suchbegriff gefunden wird, zeigt der Wert des Arguments Anfangszeile auf die Zeile, in der sich das erste Zeichen des betreffenden Textes befindet.
Anfangsspalte | Ein Wert vom Datentyp Long, der angibt, ab welcher Spalte gesucht werden soll. Jedes Zeichen einer Zeile befindet sich in einer eigenen Spalte, wobei die Spalte ganz links im Modul die Spalte Null ist. Wenn der Suchbegriff gefunden wird, zeigt der Wert des Arguments Anfangsspalte auf die Spalte, in der sich das erste Zeichen des betreffenden Textes befindet.
Endzeile | Ein Wert vom Datentyp Long, der angibt, in welcher Zeile der Suchvorgang beendet werden soll. Wenn der Suchbegriff gefunden wird, zeigt der Wert des Arguments Endzeile auf die Zeile, in der sich das letzte Zeichen des betreffenden Textes befindet.
Endspalte | Ein Wert vom Datentyp Long, der angibt, in welcher Spalte der Suchvorgang beendet werden soll. Wenn der Suchbegriff gefunden wird, zeigt der Wert des Arguments Endspalte auf die Zeile, in der sich das letzte Zeichen des betreffenden Textes befindet.
GanzesWort | Optional. Ein Wert vom Datentyp Boolean. True (-1) bewirkt, dass nur nach ganzen Wörtern gesucht wird. False (0) bewirkt, dass der Suchbegriff auch eingebettet in längere Wörter gesucht wird. Standardeinstellung ist False.
GroßKlein | Optional. Ein Wert vom Datentyp Boolean. True bewirkt, dass nur nach Wörtern gesucht wird, deren Groß- und Kleinschreibung mit dem im Argument Ziel angegebenen Suchbegriff genau übereinstimmt. False bewirkt, dass unabhängig von der Groß-/Kleinschreibung gesucht wird. Standardeinstellung ist False.
Mustervergleich | Optional. Ein Wert vom Datentyp Boolean. True bewirkt, dass im Argument Ziel Platzhalter, wie z. B. Sternchen (*) und Fragezeichen (?) als besondere Suchoperatoren erlaubt sind. False (0) bewirkt, dass Fragezeichen und Sternchen nicht als Platzhalter interpretiert werden. Standardeinstellung ist False.

Anmerkung

Die Methode Find sucht die angegebene Textzeichenfolge in einem Module-Objekt. Wenn die Zeichenfolge gefunden wird, gibt die Methode Find den Wert True zurück, andernfalls False.

Wenn Sie die Position des gefundenen Textes im Modul ermitteln möchten, übergeben Sie an die Methode Find leere Variablen für die Argumente Anfangszeile, Anfangsspalte, Endzeile und Endspalte. Wenn der Suchbegriff gefunden wird, enthalten diese Argumente die Nummern der Zeile und Spalte, an der der gefundene Text beginnt (Anfangszeile, Anfangsspalte) und endet (Endzeile, Endspalte).

Wenn z. B. der gefundene Text in Zeile 5 ab Spalte 10 beginnt und in Spalte 20 endet, haben diese Argumente folgende Werte: Anfangszeile = 5, Anfangsspalte = 10, Endzeile = 5, Endspalte = 20.


FindNext-Methode

Die Methode FindNext führt die Aktion SuchenWeiter in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.FindNext

Diese Methode verwendet keine Argumente.


 FindRecord-Methode

FindRecord-Methode

Die Methode FindRecord führt die Aktion SuchenDatensatz in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.FindRecord Suchen nach[, Vergleichen][, Groß-/Kleinschreibung][, Suchen][, Wie formatiert][, Nur aktuelles Feld][, Am Anfang beginnen]

Die Methode FindRecord verwendet die folgenden Argumente:

Argument | Beschreibung
Suchen nach | Ein Ausdruck, der zu einem Text, einer Zahl oder einem Datum ausgewertet wird. Der Ausdruck enthält die zu suchenden Daten.
Vergleichen | Eine der folgenden eingebauten Konstanten:
 | acAnywhere acEntire (Standardwert) acStart
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acEntire) verwendet.
Groß-/Kleinschreibung | Verwenden Sie True (-1), um bei der Suche Groß- und Kleinschreibung zu beachten, und False (0), um Groß- und Kleinschreibung unberücksichtigt zu lassen. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
Suchen | Eine der folgenden eingebauten Konstanten:
 | acDown acSearchAll (Standardwert) acUp
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acSearchAll) verwendet.
Wie formatiert | Verwenden Sie True, um Daten so zu suchen, wie sie formatiert sind, und False, um Daten so zu suchen, wie sie in der Datenbank gespeichert sind. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
Nur aktuelles Feld | Eine der folgenden eingebauten Konstanten:
 | acAll acCurrent (Standardwert)
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acCurrent) verwendet.
Am Anfang beginnen | Verwenden Sie True, um die Suche im ersten Datensatz zu beginnen. Verwenden Sie False, um die Suche im Datensatz zu beginnen, der auf den aktuellen Datensatz folgt. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (True) verwendet.

Anmerkung

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 FirstPage-, LastPage-, NextPage- und PreviousPage-Methoden

FirstPage-, LastPage-, NextPage- und PreviousPage-Methoden

Die FirstPage-, die LastPage-, die NextPage- und die PreviousPage-Methode werden verwendet, um durch die Seiten einer Snapshot-Datei zu blättern.

Syntax

Objekt.FirstPage

Objekt.LastPage

Objekt.NextPage

Objekt.PreviousPage

Diese Methoden verwenden die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Objekt, das ein Snapshot Viewer-Steuerelement repräsentiert.

Anmerkungen

Diese Methoden dienen dazu, sich durch die Seiten in einer Snapshot-Datei zu bewegen. Mit einer Ausnahme hat die Ausführung dieser Methoden dieselbe Wirkung wie das Klicken auf die Navigationsschaltflächen des Snapshot Viewer-Steuerelements. Die Ausnahme besteht darin, dass beim Klicken auf eine Navigationsschaltfläche des Steuerelements das entsprechende FirstPage-, LastPage-, NextPage- bzw. PreviousPage-Ereignis ausgelöst wird, während bei der programmgesteuerten Navigation diese Ereignisse nicht ausgelöst werden.

Wenn die SnapshotPath-Eigenschaft keinen oder einen ungültigen Wert hat, führt die Anwendung einer dieser Methoden zu einem Fehler. Sie können die ReadyState-Eigenschaft verwenden, um sicherzustellen, dass die SnapshotPath-Eigenschaft eine gültige Einstellung besitzt.

Wird die NextPage-Methode verwendet, während Sie sich auf der letzten Seite der Snapshot-Datei befinden, wird diese letzte Seite erneut angezeigt, und es tritt kein Fehler auf. Ähnliches gilt für die Verwendung der PreviousPage-Methode. Befinden Sie sich auf der ersten Seite der Snapshot-Datei, so wird bei Anwendung dieser Methode erneut diese erste Seite der Datei angezeigt, und es tritt kein Fehler auf.


 Follow-Methode

Follow-Methode

Die Methode Follow öffnet das Dokument oder die Webseite, das/die durch die einem Steuerelement in einem Formular oder Bericht zugeordnete Hyperlinkadresse angegeben wird.

Syntax

Objekt.Hyperlink.Follow[([NeuesFenster], [VerlaufHinzufügen], [Extrainfo], [Methode], [Headerinfo])]

Die Methode Follow verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Control-Objekt, das einen Hyperlink enthält. Die Steuerelemente Kombinationsfeld, Bezeichnung, Listenfeld, Textfeld, Befehlsschaltfläche und Bild können Hyperlinks enthalten.
Hyperlink | Der Hyperlink des Control-Objekts.
NeuesFenster | Ein Wert des Datentyps Boolean. True (-1) öffnet das Dokument in einem neuen Fenster, und False (0) öffnet es im aktuellen Fenster. Die Standardeinstellung ist False.
VerlaufHinzufügen | Ein Wert des Datentyps Boolean. True fügt den Hyperlink dem Ordner Verlauf hinzu, und False fügt ihn diesem Ordner nicht hinzu. Die Standardeinstellung ist True.
Extrainfo | Eine Zeichenfolge oder ein Datenfeld vom Typ Byte, die/das zusätzliche Informationen zum Navigieren zu einem Hyperlink angibt. Mit diesem Argument kann z. B. ein Suchparameter für eine .ASP- oder .IDC-Datei angegeben werden. In einem Webbrowser kann das Argument Extrainfo nach der Hyperlinkadresse stehen und von dieser durch ein Fragezeichen (?) getrennt werden. Wenn Sie das Argument Extrainfo angeben, brauchen Sie das Fragezeichen nicht einzubeziehen.
Methode | Ein Wert des Datentyps Integer, der angibt, wie das Argument Extrainfo zugeordnet wird. Das Argument Methode kann eine der folgenden eingebauten Konstanten sein.
 | Konstante | Beschreibung
 | msoMethodGet | Das Argument Extrainfo wird an die Hyperlinkadresse angefügt und kann nur eine Zeichenfolge sein. Dieser Wert wird standardmäßig übergeben.
 | msoMethodPost | Das Argument Extrainfo wird als Zeichenfolge oder als Datenfeld vom Typ Byte bereitgestellt.
Headerinfo | Eine Zeichenfolge, die Headerinformationen angibt. Standardmäßig ist das Argument Headerinfo eine leere Zeichenfolge (" ").

Anmerkung

Die Methode Follow hat dieselbe Wirkung wie das Klicken auf einen Hyperlink.

Sie können die Methode Follow in eine Ereignisprozedur einbeziehen, wenn Sie einen Hyperlink als Reaktion auf eine Benutzeraktion öffnen möchten. So kann beispielsweise eine Webseite mit Referenzinformationen geöffnet werden, wenn ein Benutzer ein bestimmtes Formular öffnet.

Bei Verwendung der Methode Follow brauchen Sie nicht die Adresse zu wissen, die durch die Eigenschaft Hyperlink-Adresse eines Steuerelements angegeben wird. Sie müssen nur den Namen des Steuerelements wissen, das den betreffenden Hyperlink enthält. Umgekehrt müssen Sie bei Verwendung der Methode FollowHyperlink die Adresse für den Hyperlink angeben, dem Sie folgen möchten.


 FollowHyperlink-Methode

FollowHyperlink-Methode

Die Methode FollowHyperlink öffnet das Dokument oder die Webseite, das/die durch eine Hyperlinkadresse angegeben wird.

Syntax

[Anwendung.]FollowHyperlink Adresse, [Unteradresse], [NeuesFenster], [VerlaufHinzufügen], [Extrainfo], [Methode], [Headerinfo]

Die Methode FollowHyperlink verwendet die folgenden Argumente.

Argument | Beschreibung
Anwendung | Das Objekt Application.
Adresse | Ein Zeichenfolgenausdruck, der zu einer gültigen Hyperlinkadresse ausgewertet wird.
Unteradresse | Ein Zeichenfolgenausdruck, der zu einer benannten Position in dem durch das Argument Adresse angegebenen Dokument ausgewertet wird. Die Standardeinstellung ist eine leere Zeichenfolge (" ").
NeuesFenster | Ein Wert des Datentyps Boolean. True (-1) öffnet das Dokument in einem neuen Fenster, und False (0) öffnet es im aktuellen Fenster. Die Standardeinstellung ist False.
VerlaufHinzufügen | Ein Wert des Datentyps Boolean. True fügt den Hyperlink dem Ordner Verlauf hinzu, und False fügt ihn diesem Ordner nicht hinzu. Die Standardeinstellung ist True.
Extrainfo | Eine Zeichenfolge oder ein Datenfeld vom Typ Byte, die/das zusätzliche Informationen zum Navigieren zu einem Hyperlink angibt. Mit diesem Argument kann z.B. ein Suchparameter für eine .asp- oder .idc-Datei angegeben werden. In einem Webbrowser kann das Argument Extrainfo nach der Hyperlinkadresse stehen und von dieser durch ein Fragezeichen (?) getrennt werden. Wenn Sie das Argument Extrainfo angeben, brauchen Sie das Fragezeichen nicht einzubeziehen.
Methode | Ein Wert des Datentyps Integer, der angibt, wie das Argument Extrainfo zugeordnet wird. Das Argument Methode kann eine der folgenden eingebauten Konstanten sein.
 | Konstante | Beschreibung
 | msoMethodGet | Das Argument Extrainfo wird an die Hyperlinkadresse angefügt und kann nur eine Zeichenfolge sein. Dieser Wert wird standardmäßig übergeben.
 | msoMethodPost | Das Argument Extrainfo wird als Zeichenfolge oder als Datenfeld vom Typ Byte bereitgestellt.
Headerinfo | Eine Zeichenfolge, die Headerinformationen angibt. Standardmäßig ist das Argument Headerinfo eine leere Zeichenfolge.

Anmerkung

Mit Hilfe der Methode FollowHyperlink können Sie einem Hyperlink folgen, der in einem Steuerelement nicht vorhanden ist. Dieser Hyperlink kann von Ihnen oder dem Benutzer angegeben werden. So können Sie einen Benutzer beispielsweise auffordern, eine Hyperlinkadresse in einem Dialogfeld einzugeben, und dann mit der Methode FollowHyperlink diesem Hyperlink folgen.

Mit den Argumenten Extrainfo und Methode können Sie zusätzliche Informationen beim Navigieren zu einem Hyperlink bereitstellen. Beispielsweise können Sie Parameter für ein Suchmodul angeben. Um die Site Yahoo nach Informationen über Microsoft zu durchsuchen, könnten Sie die Methode FollowHyperlink folgendermaßen aufrufen:

Application.FollowHyperlink "http://search.yahoo.com/bin/search", _
    , , , "p=Microsoft", msoMethodGet

Zum Verfolgen eines Hyperlinks, der einem Steuerelement zugeordnet ist, können Sie die Methode Follow verwenden.


 GetHiddenAttribute-, SetHiddenAttribute-Methoden

GetHiddenAttribute-, SetHiddenAttribute-Methoden

  • Die GetHiddenAttribute-Methode gib den Wert des Attributs Ausgeblendet für ein Microsoft Access-Objekt zurück. Dieses Attribut ist über das Dialogfeld Eigenschaften des jeweiligen Objekts zugänglich, mit dem Sie arbeiten können, indem Sie das Objekt im Datenbankfenster wählen und im Menü Ansicht auf Eigenschaften klicken.

  • Die SetHiddenAttribute-Methode legt den Wert des Attributs Ausgeblendet eines Access-Objekts fest.

Syntax

Objekt.GetHiddenAttribute(Objekttyp, Objektname)

Objekt.SetHiddenAttribute Objekttyp, Objektname, Einstellung

Die GetHiddenAttribute-Methode und die SetHiddenAttribute-Methode verwenden die folgenden Argumente.

Argument | Beschreibung
Objekt | Optional. Das Application-Objekt.
Objekttyp | Eine der folgenden eingebauten Konstanten: acDataAccessPage acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
 | Für das Argument Objekttyp muss eine der spezifischen Konstanten angegeben werden. acDefault ist also kein gültiger Wert.
Objektname | Ein Zeichenfolgenausdruck, der den Namen des Access-Objekts angibt.
Einstellung | Ein Wert vom Typ Boolean. True (-1) aktiviert das Attribut Ausgeblendet, während False (0) das Attribut deaktiviert.

Anmerkungen

Die GetHiddenAttribute-Methode und die SetHiddenAttribute-Methode ermöglichen es, das Attribut Ausgeblendet eines Objekts durch Visual Basic-Code zu ändern. Mit diesen Methoden können Sie die Einstellung der Option ermitteln oder festlegen, die über das zum Objekt gehörige Dialogfeld Eigenschaften verfügbar ist.

Da der Benutzer das Attribut Ausgeblendet durch Aktivieren oder Deaktivieren eines Kontrollkästchens festlegt, gibt die GetHiddenAttribute-Methode den Wert True (-1) zurück, falls die Option ausgewählt (das Kontrollkästchen aktiviert) wurde, oder False (0), falls die Option nicht ausgewählt (das Kontrollkästchen deaktiviert) wurde. Um diese Art von Option mit Hilfe der SetHiddenAttribute-Methode festzulegen, geben Sie für das Argument Einstellung einen der Werte True oder False an, wie in dem folgenden Beispiel:

Application.SetHiddenAttribute acTable,"Kunden", True


 GetOption-, SetOption-Methoden

GetOption-, SetOption-Methoden

  • Die Methode GetOption gibt den aktuellen Wert einer Option im Dialogfeld Optionen zurück, das Sie durch Klicken auf Optionen im Menü Extras öffnen können.

  • Die Methode SetOption stellt den aktuellen Wert einer Option im Dialogfeld Optionen ein.

Syntax

Objekt.GetOption(Optionsname)

Objekt.SetOption Optionsname, Einstellung

Die Methoden GetOption und SetOption verwenden die folgenden Argumente.

Argument | Beschreibung
Objekt | Optional. Das Application-Objekt.
Optionsname | Der Name der Option. Eine Liste der Zeichenfolgen des Arguments Optionsname finden Sie unter Festlegen von Optionen aus Visual Basic heraus.
Einstellung | Ein Wert des Datentyps Variant entsprechend der Optionseinstellung. Der Wert des Arguments Einstellung hängt von den möglichen Einstellungen für eine bestimmte Option ab.

Anmerkungen

Die Methoden GetOption und SetOption bieten eine Möglichkeit zum Ändern der Umgebungsoptionen aus Visual Basic-Code. Mit diesen Methoden können Sie jede im Dialogfeld Optionen verfügbare Option einstellen oder überprüfen, ausgenommen die Optionen der Registerkarte Module.

Die verfügbaren Optionseinstellungen hängen von dem Typ der einzustellenden Option ab. Es gibt drei allgemeine Optionstypen:

  • Ja/Nein-Optionen, die durch Aktivieren oder Deaktivieren eines Kontrollkästchens eingestellt werden können.

  • Optionen, die durch Eingabe einer Zeichenfolge oder eines numerischen Wertes eingestellt werden können.

  • Vordefinierte Optionen, die aus einem Listenfeld, einem Kombinationsfeld oder einer Optionsgruppe ausgewählt werden können.

Bei Optionen, die der Benutzer durch Aktivieren oder Deaktivieren eines Kontrollkästchens einstellt, gibt die Methode GetOption den Wert True (-1) zurück, wenn die Optionseinstellung Ja lautet (das Kontrollkästchen aktiviert ist), bzw. False (0) zurück, wenn die Optionseinstellung Nein lautet (das Kontrollkästchen deaktiviert ist). Um eine Option dieser Art mit Hilfe der Methode SetOption einzustellen, geben Sie True oder False für das Argument Einstellung an. Beispiel:

Application.SetOption "Show Status Bar", True

Bei Optionen, die der Benutzer durch Eingabe einer Zeichenfolge oder eines numerischen Wertes einstellt, gibt die Methode GetOption die Einstellung so zurück, wie sie im Dialogfeld angezeigt wird. Das folgende Beispiel gibt eine Zeichenfolge mit der Einstellung für den linken Rand zurück:

Dim varSetting As Variant
varSetting = Application.GetOption("Left Margin")

Um diesen Optionstyp mit Hilfe der Methode SetOption einzustellen, geben Sie die Zeichenfolge oder den numerischen Wert an, der in das Dialogfeld eingegeben würde. Das folgende Beispiel stellt die Standardformularvorlage auf Bestellvorlage ein:

Application.SetOption "Form Template", "Bestellvorlage"

Bei Optionen mit Einstellungen, die Wahlmöglichkeiten in Listen- oder Kombinationsfeldern darstellen, gibt die Methode GetOption eine Zahl entsprechend der Position der Einstellung in der Liste zurück. Das Indizieren beginnt bei 0. Deshalb gibt die Methode GetOption 0 für den ersten Eintrag, 1 für den zweiten Eintrag usw. zurück. Wenn z.B. die Option Standardfeldtyp der Registerkarte Tabellen/Abfragen auf AutoWert (sechster Eintrag in der Liste) eingestellt ist, gibt die Methode GetOption den Wert 5 zurück.

Zum Einstellen dieses Optionstyps geben Sie die numerische Position der Option innerhalb der Liste als Argument Einstellung für die Methode SetOption an. Das folgende Beispiel stellt die Option Standardfeldtyp auf AutoWert ein:

Application.SetOption "Default Field Type", 5

Andere Optionen werden durch Klicken auf ein Schaltfläche Option in einer Optionsgruppe des Dialogfeldes Optionen eingestellt. In Visual Basic werden diese Optionen auch durch Angabe der Position einer bestimmten Option innerhalb ihrer Optionsgruppe eingestellt. Die erste Option in der Gruppe hat die Nummer 0, die zweite die Nummer 1 usw. Wenn z.B. die Option Markierungsverhalten der Registerkarte Formulare/Berichte auf Teilweise eingerahmt eingestellt ist, gibt die Methode GetOption 0 zurück. Beispiel:

Debug.Print Application.GetOption("Selection Behavior")

Zum Einstellen einer Option, die ein Element einer Optionsgruppe darstellt, geben Sie die Indexnummer der Option innerhalb der Gruppe an. Das folgende Beispiel stellt Markierungsverhalten auf Voll eingerahmt ein:

Application.SetOption "Selection Behavior", 1

Anmerkungen

  • Wenn Sie eine Option im Dialogfeld Optionen mit Hilfe der Methode GetOption oder der Methode SetOption einstellen, brauchen Sie die Registerkarte, auf der sich die Option befindet, nicht anzugeben.

  • Mit der Methode GetOption oder der Methode SetOption können Sie keine der Optionen der Registerkarte Modul des Dialogfeldes Optionen überprüfen oder einstellen.

  • Wird der Rückgabewert der Methode GetOption einer Variablen zugewiesen, muss diese als Variable des Datentyps Variant deklariert werden.

  • Wenn eine Datenbank in einer Microsoft Access-Version für eine andere Sprache ausgeführt wird als die Sprache, in der sie erstellt wurde, müssen Sie die Argumente für die Methoden GetOption und SetOption in Englisch eingeben.

Beim Beenden von Microsoft Access können Sie alle Optionen auf ihre Originaleinstellungen zurücksetzen, indem Sie die Methode SetOption für alle geänderten Optionen verwenden. Sie können öffentliche Variablen zum Speichern der Werte der Originaleinstellungen erstellen. Anschließend können Sie den Code zum Zurücksetzen von Optionen in die Ereignisprozedur Close für ein Formular oder in eine benutzerdefinierte Prozedur Exit einbeziehen, die der Benutzer ausführen muss, um die Anwendung zu beenden.


 GoToControl-Methode

GoToControl-Methode

Die Methode GoToControl führt die Aktion GeheZuSteuerelement in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.GoToControl Steuerelementname

Die Methode GoToControl verwendet folgendes Argument:

Argument | Beschreibung
Steuerelementname | Ein Zeichenfolgenausdruck, der den Namen eines Steuerelements im aktiven Formular oder Datenblatt angibt.

Anmerkung

Geben Sie für das Argument Steuerelementname nur den Namen des Steuerelements ein, nicht die vollständige Syntax.

Sie können für dieses Argument auch eine Variable vom Datentyp Control verwenden.

Dim ctlSteuerelement As Control
Set ctlSteuerelement = Formulare!Formular1!Feld3
DoCmd.GoToControl ctlSteuerelement.Name

Sie können auch die Methode SetFocus verwenden, um den Fokus auf ein Steuerelement eines Formulars oder eines seiner Unterformulare oder auf ein Feld einer geöffneten Tabelle, einer geöffneten Abfrage oder eines geöffneten Formulardatenblatts zu setzen. Diese Methode wird in Visual Basic zum Setzen des Fokus bevorzugt, vor allem wenn er auf Steuerelemente in Formularen und verschachtelten Unterformularen gesetzt werden soll, da Sie die vollständige Syntax zum Angeben des Steuerelements verwenden können.


 GoToPage-Methode (DoCmd-Objekt)

GoToPage-Methode (DoCmd-Objekt)

Die Methode GoToPage des Objekts DoCmd führt die Aktion GeheZuSeite in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.GoToPage [Seitenzahl][, Rechts, Unten]

Die Methode GoToPage verwendet die folgenden Argumente:

Argument | Beschreibung
Seitenzahl | Ein numerischer Ausdruck, der eine gültige Seitenzahl des aktiven Formulars angibt. Wenn Sie dieses Argument nicht angeben, bleibt der Fokus auf der aktuellen Seite. Sie können die Argumente Rechts und Unten verwenden, um den gewünschten Teil der Seite anzuzeigen.
Rechts | Ein numerischer Ausdruck, der einen gültigen horizontalen Versatz für die Seite angibt.
Unten | Ein numerischer Ausdruck, der einen gültigen vertikalen Versatz für die Seite angibt.

Anmerkung

Die Maßeinheit für die Argumente Rechts und Unten lautet Twips.

Wenn Sie die Argumente Rechts und Unten angeben, aber Seitenzahl weglassen, geben Sie das Komma des Arguments Seitenzahl an. Wenn Sie die Argumente Rechts und Unten nicht angeben, geben Sie nach dem Argument Seitenzahl kein Komma ein.

Die Methode GoToPage des Objekts DoCmd wurde hinzugefügt, um die Abwärtskompatibilität zu gewährleisten, wenn die Aktion GoToPage im Visual Basic-Code in Microsoft Access 95 ausgeführt wird. Es empfiehlt sich jedoch, stattdessen die vorhandene Methode GoToPage des Objekts Form zu verwenden.


 GoToPage-Methode (Form-Objekt)

GoToPage-Methode (Form-Objekt)

Die Methode GoToPage verschiebt den Fokus auf das erste Steuerelement der angegebenen Seite im aktiven Formular.

Syntax

Formular.GoToPage Seitenzahl[, rechts, unten]

Die Methode GoToPage verwendet die folgenden Argumente.

Argument | Beschreibung
Formular | Ein Form-Objekt, das das aktive Formular darstellt.
Seitenzahl | Ein numerischer Ausdruck, der eine gültige Seitenzahl für das aktive Formular ist.
rechts | Ein numerischer Ausdruck, der einen gültigen horizontalen Versatz (in Twips) von der linken Seite des Fensters zu dem Teil der Seite angibt, der angezeigt werden soll.
unten | Ein numerischer Ausdruck, der einen gültigen vertikalen Versatz (in Twips) vom oberen Rand des Fensters zu dem Teil der Seite angibt, der angezeigt werden soll.

Anmerkungen

Wenn Sie mit Hilfe dieser Methode zu der angegebenen Seite eines Formulars wechseln, wird der Fokus auf das erste Steuerelement der Seite gesetzt, das durch die Reihenfolge der Steuerelemente des Formulars festgelegt wird. Um zu einem bestimmten Steuerelement im Formular zu wechseln, verwenden Sie die Methode SetFocus.

Sie können die Methode GoToPage Aktion verwenden, wenn Sie ein Formular mit Seitenumbrüchen erstellt haben, das Gruppen zusammenhängender Informationen enthält. Wenn Sie z.B. über ein Formular Personal verfügen, das persönliche Angaben auf einer Seite, dienstliche Angaben auf einer anderen Seite und Umsatzzahlen auf einer dritten Seite enthält, können Sie mit der Methode GoToPage zur gewünschten Seite wechseln.

Sie können die Argumente rechts und unten für Formulare verwenden, deren Seiten größer sind als das Microsoft Access-Fenster. Verwenden Sie zuerst das Argument Seitenzahl, um zur gewünschten Seite zu wechseln, und dann die Argumente rechts und unten, um den gewünschten Teil der Seite anzuzeigen. Microsoft Access zeigt den Teil der Seite an, der von der oberen linken Ecke des Fensters um den in den Argumenten rechts und unten angegebenen Abstand versetzt ist.


 GoToRecord-Methode

GoToRecord-Methode

Die Methode GoToRecord führt die Aktion GeheZuDatensatz in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.GoToRecord [Objekttyp, Objektname][, Datensatz][, Offset]

Die Methode GoToRecord verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acActiveDataObject (Standardwert) acDataForm acDataQuery acDataTable
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.
Datensatz | Eine der folgenden eingebauten Konstanten:
 | acFirst acGoTo acLast acNewRec acNext (Standardwert) acPrevious
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acNext) verwendet.
Offset | Ein numerischer Ausdruck, der die Anzahl der Datensätze angibt, um die vorwärts oder rückwärts geblättert werden soll, wenn Sie für das Argument Datensatz acNext oder acPrevious angegeben haben, oder der Datensatz, zu dem Sie gehen möchten, wenn Sie für das Argument Datensatz acGoTo angegeben haben. Der Ausdruck muss eine gültige Datensatznummer ergeben.

Anmerkung

Wenn Sie die Argumente Objekttyp und Objektname nicht angeben, wird die Standardkonstante (acActiveDataObject) für Objekttyp angenommen, und das aktive Objekt wird verwendet.

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


Hourglass-Methode

Die Methode Hourglass führt die Aktion Sanduhr in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie im Thema zur jeweiligen Aktion.

Syntax

DoCmd.Hourglass Sanduhr

Die Methode Hourglass verwendet das folgende Argument:

Argument | Beschreibung
Sanduhr | Verwenden Sie True (-1), um die Sanduhr (oder ein anderes gewähltes Symbol) anzuzeigen. Verwenden Sie False (0), um den normalen Mauszeiger anzuzeigen.


 hWndAccessApp-Methode

hWndAccessApp-Methode

Mit der Methode hWndAccessApp können Sie die Kennnummer (Handle) ermitteln, die Microsoft Windows 98 dem Microsoft Access-Hauptfenster zugewiesen hat.

Einstellung

Die Methode hWndAccessApp gibt einen Wert des Typs Long Integer zurück, der von Microsoft Access eingestellt wird und schreibgeschützt ist.

Anmerkung

Sie können diese Methode in Visual Basic verwenden, wenn Sie Funktionen des Microsoft Windows API (Application Programming Interface) oder andere externe Prozeduren aufrufen, die als Argument eine Fensterkennnummer (Fenster-Handle) erwarten.

Mit der Eigenschaft hWnd können Sie die Kennnummer eines Fensters ermitteln, das ein Microsoft Access-Objekt, z. B. ein Formular oder einen Bericht, enthält.


 HyperlinkPart-Methode

HyperlinkPart-Methode

Die Methode HyperlinkPart liefert Informationen über Daten, die als Datentyp Hyperlink gespeichert sind. Die Daten in einem Hyperlink-Feld können aus bis zu vier Teilen in folgendem Format bestehen:

Anzeigetext#Adresse#Unteradresse#QuickInfo

Syntax

Objekt.HyperlinkPart(Hyperlink As Variant [, Teil As Integer])

Die Methode HyperlinkPart verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Optional. Das Application-Objekt.
Hyperlink | Ein Wert des Datentyps Variant, der für die in einem Hyperlink-Feld gespeicherten Daten steht.
Teil | Optional. Der Wert für das Argument Teil ist eine eingebaute Konstante zur Darstellung der Informationen, welche die Methode HyperlinkPart liefern soll:
 | Konstante | Wert | Beschreibung
 | acDisplayedValue | 0 | (Voreinstellung) Der unterstrichene Text, der in einem Hyperlink angezeigt wird.
 | acDisplayText | 1 | Der Teil Anzeigetext eines Hyperlink-Feldes.
 | acAddress | 2 | Der Teil Adresse eines Hyperlink-Feldes.
 | acSubAddress | 3 | Der Teil Unteradresse eines Hyperlink-Feldes.
 | acScreenTip | 4 | Der Teil QuickInfo eines Hyperlink-Feldes.
 | acFullAddress | 5 | Die Teile Adresse und Unteradresse eines Hyperlink-Feldes, die durch ein "#"-Zeichen voneinander abgegrenzt werden.

Anmerkung

Mit Hilfe der Methode HyperlinkPart geben Sie einen von drei Werten eines Hyperlink-Feldes oder des angezeigten Wertes zurück. Der gelieferte Wert hängt von der Einstellung des Arguments Teil ab. Das Argument Teil ist optional. Wird es nicht verwendet, liefert die Funktion den Wert, den Microsoft Access für den Hyperlink anzeigt (entspricht der Einstellung acDisplayedValue für das Argument Teil). Bei den gelieferten Werten kann es sich um einen der vier Teile des Hyperlink-Feldes (Anzeigetext, Adresse, Unteradresse oder QuickInfo), die vollständige Adresse, Adresse#Unteradresse oder um den Wert handeln, den Microsoft Access für den Hyperlink anzeigt.

Anmerkung Wenn Sie die Methode HyperlinkPart in einer Abfrage verwenden, ist das Argument Teil notwendig. Sie können dann die oben aufgelisteten Konstanten nicht verwenden. Verwenden Sie stattdessen den aktuellen Wert.

Enthält der Teil Anzeigetext eines Hyperlink-Feldes einen Wert, zeigt Microsoft Access den Wert der Einstellung Anzeigetext an. Enthält der Teil Anzeigetext eines Hyperlink-Feldes keinen Wert, wird als Wert der Teil Adresse oder Unteradresse des Hyperlink-Feldes angezeigt, je nachdem, welcher Wert im Feld als erster steht.

Die folgende Tabelle zeigt die Werte, die von der Methode HyperlinkPart für in einem Hyperlink-Feld gespeicherte Daten geliefert werden.

Daten im Hyperlink-Feld | Von der Methode "HyperlinkPart" gelieferte Werte
#http://www.microsoft.com# | acDisplayedValue: http://www.microsoft.com acDisplayText: acAddress: http://www.microsoft.com acSubAddress: acScreenTip: acFullAddress: http://www.microsoft.com
Microsoft#http://www.microsoft.com# | acDisplayedValue: Microsoft acDisplayText: Microsoft acAddress: http://www.microsoft.com acSubAddress: acScreenTip: acFullAddress: http://www.microsoft.com
Kunden#http://www.microsoft.com#Formular Kunden | acDisplayedValue: Kunden acDisplayText: Kunden acAddress: http://www.microsoft.com acSubAddress: Formular Kunden acScreenTip: acFullAddress: http://www.microsoft.com#Formular Kunde
##Formular Kunden#Informationen eingeben | acDisplayedValue: Formular Kunden acDisplayText: acAddress: acSubAddress: Formular Kunden acScreenTip: Informationen eingeben acFullAddress: #FormularKunde

Wenn Sie einem Hyperlink-Feld über das Dialogfeld Hyperlink einfügen (verfügbar durch Klicken auf Hyperlink im Menü Einfügen) oder durch direktes Eingeben einer Adresse in ein Hyperlink-Feld einen Adresse-Teil hinzufügen, fügt Microsoft Access die beiden #-Symbole hinzu, die die einzelnen Teile der Hyperlinkdaten voneinander abgrenzen.

Sie können den Teil Anzeigetext eines Hyperlink-Feldes hinzufügen oder bearbeiten, indem Sie in einer Tabelle, einem Formular oder einem Bericht mit der rechten Maustaste auf einen Hyperlink klicken, im Kontextmenü auf Hyperlink zeigen und dann den Text, der angezeigt werden soll, im Feld Anzeigetext eingeben.

Sehen Sie die beiden #-Symbole zur Abgrenzung der einzelnen Teile der Hyperlinkdaten vor, wenn Sie einem Hyperlink-Feld direkt Daten hinzufügen.


 InsertLines-Methode

InsertLines-Methode

Die Methode InsertLines fügt eine oder mehrere Codezeilen in ein Standardmodul oder Klassenmodul ein.

Syntax

Objekt.InsertLines Zeile, Zeichenfolge

Die Methode InsertLines hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Zeile | Die Nummer der Zeile, ab der eingefügt werden soll.
Zeichenfolge | Der Text, der im Modul eingefügt werden soll.

Anmerkung

Bei Verwendung der Methode InsertLines wird der Code in der im Argument Zeile angegebenen Zeile nach unten verschoben.

Wenn Sie mehrere Zeilen hinzufügen möchten, verwenden Sie die eingebaute Konstante vbCrLf an den vorgesehenen Zeilenumbrüchen in der Zeichenfolge, die Sie im Argument Zeichenfolge angeben. Diese Konstante fügt einen Wagenrücklauf und Zeilenvorschub ein.

Die Zeilen in einem Modul sind ab Eins nummeriert. Sie können die Anzahl der Zeilen in einem Modul mit der Eigenschaft CountOfLines ermitteln.


 InsertText-Methode

InsertText-Methode

Die Methode InsertText fügt eine Textzeichenfolge in ein Standardmodul oder Klassenmodul ein.

Syntax

Objekt.InsertText Text

Die Methode InsertText hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Text | Der Text, der im Modul eingefügt werden soll.

Anmerkung

Wenn Sie eine Zeichenfolge mit der Methode InsertText einfügen, fügt Microsoft Access den neuen Text am Modulende hinter allen anderen Prozeduren an.

Wenn Sie mehrere Zeilen hinzufügen möchten, verwenden Sie die eingebaute Konstante vbCrLf an den vorgesehenen Zeilenumbrüchen in der Zeichenfolge, die Sie im Argument Text angeben. Diese Konstante fügt einen Wagenrücklauf und Zeilenvorschub ein.

Wenn Sie angeben möchten, in welcher Zeile der Text eingefügt werden soll, verwenden Sie die Methode InsertLines. Zum Einfügen von Code im Deklarationsbereich des Moduls verwenden Sie nicht die Methode InsertText, sondern die Methode InsertLines.

Anmerkung In früheren Versionen von Microsoft Access war InsertText eine Methode des Application-Objekts. Sie können die Methode InsertText des Application-Objekts weiterhin verwenden; es wird jedoch empfohlen, stattdessen die Methode InsertText des Module-Objekts zu verwenden.


 Item-Methode

Item-Methode

Die Methode Item gibt ein bestimmtes Element einer Auflistung entweder nach Position oder nach Schlüssel zurück.

Syntax

Objekt.Item(Index)

Die Methode Item verwendet die folgenden Argumente:

Argument | Beschreibung
Objekt | Die Auflistung References.
Index | Ein Ausdruck, der die Position eines Elements der Auflistung angibt, auf die im Argument Objekt verwiesen wird. Wenn es sich um einen numerischen Ausdruck handelt, muss das Argument Index eine Zahl zwischen 1 und dem Wert der Eigenschaft Count der Auflistung sein. Wenn es sich um einen Zeichenfolgenausdruck handelt, muss das Argument Index der Name eines Elements der Auflistung sein.

Anmerkung

Wenn der für das Argument Index angegebene Wert keinem vorhandenen Element der Auflistung entspricht, tritt ein Fehler auf.

Die Methode Item ist das Standardelement der Auflistung References, Sie brauchen die Methode daher nicht explizit anzugeben. Die folgenden zwei Codezeilen z.B. haben dieselbe Bedeutung:

Debug.Print References(1).Name
Debug.Print References.Item(1).Name


 Line-Methode

Line-Methode

Die Methode Line zeichnet Linien und Rechtecke in ein Report-Objekt, wenn das Ereignis Print eintritt.

Syntax

Objekt.Line [[Step](x1, y1)] - [Step](x2, y2)[, [Farbe][, B[F]]]

Sie können diese Methode nur in einer Ereignisprozedur oder einem Makro verwenden, das durch die Ereigniseigenschaft OnPrint bzw. OnFormat für einen Berichtsbereich oder durch die Ereigniseigenschaft OnPage für einen Bericht angegeben wird.

Die Methode Line verwendet die folgenden Argumente:

Argument | Beschreibung
Objekt | Das Report-Objekt, in dem die Linie oder das Rechteck gezeichnet werden soll.
Step | Ein Schlüsselwort, welches angibt, dass die Anfangspunktkoordinaten relativ zur aktuellen Position der Grafik sind, die durch die Einstellungen für die Eigenschaften CurrentX und CurrentY des Arguments Objekt festgelegt wird.
x1, y1 | Werte des Datentyps Single, die die Koordinaten des Anfangspunktes für die Linie oder das Rechteck bezeichnen. Die Scale-Eigenschaften (ScaleMode, ScaleLeft, ScaleTop, ScaleHeight und ScaleWidth) des durch das Argument Objekt angegebenen Report-Objekts bestimmen die verwendete Maßeinheit. Wenn dieses Argument weggelassen wird, beginnt die Linie an der durch die Eigenschaften CurrentX und CurrentY angegebenen Position.
Step | Ein Schlüsselwort, welches angibt, dass die Endpunktkoordinaten relativ zum Anfangspunkt der Linie sind.
x2, y2 | Werte des Datentyps Single, die die Koordinaten des Endpunktes für die zu zeichnende Linie angeben. Diese Argumente sind erforderlich.
Farbe | Ein Wert des Datentyps Long, der die zum Zeichnen der Linie verwendete RGB (Rot-Grün-Blau)-Farbe angibt. Wird dieses Argument weggelassen, so wird der Wert der Eigenschaft ForeColor verwendet. Sie können für die Farbangabe auch die Funktion RGB oder die Funktion QBColor verwenden.
B | Eine Option, die ein Rechteck erstellt, indem sie die Koordinaten als dessen entgegengesetzte Ecken verwendet.
F | F kann nicht ohne B verwendet werden. Bei Verwendung der Option B gibt die Option F an, dass das Rechteck mit derselben Farbe ausgefüllt wird, mit der es gezeichnet wurde. Bei Verwendung von B ohne F wird das Rechteck mit der Farbe ausgefüllt, die durch die aktuellen Einstellungen der Eigenschaften FillColor und BackStyle festgelegt wird. Der Standardwert für die Eigenschaft BackStyle lautet für Rechtecke und Linien Normal.

Anmerkungen

Stellen Sie beim Verbinden von zwei gezeichneten Linien sicher, dass eine Linie am Endpunkt der vorhergehenden Linie beginnt.

Die Breite einer gezeichneten Linie hängt von der Einstellung der Eigenschaft Rahmenbreite ab. Die Art, wie eine Linie oder ein Rechteck auf den Hintergrund gezeichnet wird, hängt von den Einstellungen der Eigenschaften Rahmenart und Rahmenbreite ab.

Wenn Sie die Methode Line anwenden, werden die Eigenschaften CurrentX und CurrentY auf die Endpunktkoordinaten eingestellt, die durch die Argumente x2 und y2 bestimmt sind.


 LoadPicture-Methode

LoadPicture-Methode

Die LoadPicture-Methode lädt eine Grafik in ein ActiveX-Steuerelement.

Syntax

LoadPicture(Zeichenfolgenausdruck)

Die LoadPicture-Methode hat das folgende Argument.

Argument | Beschreibung
Zeichenfolgenausdruck | Der Dateiname der zu ladenden Grafik. Die Grafik kann eine Bitmap-Datei (.BMP), eine Symboldatei (.ICO), eine Run-Length Encoded-Datei (.RLE) oder eine Metadatei (.WMF) sein.

Anmerkung

Weisen Sie den Rückgabewert der LoadPicture-Methode der Eigenschaft Picture eines ActiveX-Steuerelements zu, um eine Grafik dynamisch in ein Bild zu laden. Das folgende Beispiel lädt eine Bitmap in ein Steuerelement namens BenutzerdefiniertesOLESteuerelement in ein Formular Bestellungen:

Set Formulare!Bestellungen!BenutzerdefiniertesOLESteuerelement.Picture = _
    LoadPicture("Sterne.bmp")

Die LoadPicture-Methode gibt ein Objekt vom Typ Picture zurück. Diesen Wert können Sie einer Variablen vom Typ Objekt zuweisen. Dazu verwenden Sie die Set-Anweisung.

Das Objekt Picture ist kein Microsoft Access-Objekt, es steht jedoch für Prozeduren in Microsoft Access zur Verfügung.

Anmerkung Sie können die LoadPicture-Methode nicht zum Einstellen der Eigenschaft Picture eines Bild-Steuerelements verwenden. Diese Methode kann nur für ActiveX-Steuerelemente verwendet werden. Zum Einstellen der Eigenschaft Picture eines Bild-Steuerelements weisen Sie einfach eine Zeichenfolge zu, die den Datennamen und den Pfad der gewünschten Grafik angibt.


Maximize-Methode

Die Methode Maximize führt die Aktion Maximieren in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Diese Methode kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen über Möglichkeiten zum Beeinflussen von Modulfenstern finden Sie unter dem Thema zur Eigenschaft WindowState.

Syntax

DoCmd.Maximize

Diese Methode verwendet keine Argumente.


Minimize-Methode

Die Methode Minimize führt die Aktion Minimieren in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Diese Methode kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen über Möglichkeiten zum Beeinflussen von Modulfenstern finden Sie unter dem Thema zur Eigenschaft WindowState.

Syntax

DoCmd.Minimize

Diese Methode verwendet keine Argumente.


 Modify-Methode (FormatCondition-Objekt)

Modify-Methode (FormatCondition-Objekt)

Mit der Modify-Methode können Sie die bedingten Formatierungen eines FormatCondition-Objekts in der FormatConditions-Auflistung eines Kombinationsfeld- oder Textfeld-Steuerelements ändern.

Syntax

Objekt.Modify Typ [, Operator][, Ausdruck1][, Ausdruck2]

Die Modify-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zum FormatCondition-Objekt eines Kombinationsfeld- oder Textfeld-Steuerelements ausgewertet wird.
Typ | Eine der folgenden eingebauten Konstanten: acExpression acFieldHasFocus acFieldValue
Operator | Eine der folgenden eingebauten Konstanten: acBetween (Standard) acEqual acGreaterThan acGreaterThanOrEqual acLessThan acLessThanOrEqual acNotBetween acNotEqual
 | Wenn für das Argument Typ der Wert acExpression angegeben wird, ist das Argument Operator ohne Belang und wird ignoriert. Bei Weglassen des Arguments gilt der Standardwert (acBetween).
Ausdruck1 | Ein Variant-Wert oder -Ausdruck, der dem ersten Teil der bedingten Formatierung entspricht. Es kann sich dabei um einen constant-Wert oder einen string-Wert handeln.
Ausdruck2 | Ein Variant-Wert oder -Ausdruck, der dem zweiten Teil der bedingten Formatierung entspricht, sofern für das Argument Operator einer der Werte acBetween oder acNotBetween angegeben ist (andernfalls wird dieses Argument ignoriert). Es kann sich um einen constant -Wert oder einen string -Wert handeln.

Anmerkungen


 MoveSize-Methode

MoveSize-Methode

Die Methode MoveSize führt die Aktion Positionieren in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.MoveSize [Rechts][, Unten][, Breite][, Höhe]

Die Methode MoveSize verwendet die folgenden Argumente:

Argument | Beschreibung
Rechts | Numerischer Ausdruck.
Unten | Numerischer Ausdruck.
Breite | Numerischer Ausdruck.
Höhe | Numerischer Ausdruck.

Anmerkung

Verwenden Sie mindestens ein Argument der Methode MoveSize. Für Argumente, die Sie nicht angeben, wird die aktuelle Einstellung für das Fenster verwendet.

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.

Die Maßeinheit für die Argumente lautet Twips.


 NewAccessProject-Methode

NewAccessProject-Methode

Mit der NewAccessProject-Methode können Sie ein neues Microsoft Access-Projekt (.adp) erstellen und als das aktuelle Access-Projekt im Microsoft Access-Fenster öffnen.

Syntax

Objekt.NewAccessProject Projektname [, Verbindung]

Die NewAccessProject-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Das Application-Objekt.
Projektname | Ein Zeichenfolgenausdruck, der den Namen des neuen Access-Projekts (einschließlich des Pfadnamens und der Dateinamenerweiterung) bezeichnet. Sofern dies Ihr Netzwerk unterstützt, können Sie außerdem einen Netzwerkpfad der folgenden Art angeben: \\Server\Freigabe\Ordner\Dateiname.adp
Verbindung | Ein Zeichenfolgenausdruck, der eine gültige Verbindungszeichenfolge für das Access-Projekt angibt. Weitere Informationen über diese Zeichenfolge finden Sie unter dem Thema zur ADO ConnectionString-Eigenschaft.

Anmerkungen

Die NewAccessProject-Methode ermöglicht es Ihnen, ein neues Access-Projekt aus Microsoft Access heraus oder mit einer anderen Anwendung über den Weg der Automatisierung (formell als OLE-Automatisierung bezeichnet) zu erstellen. Sie können die NewAccessProject-Methode beispielsweise von Microsoft Excel aus aufrufen, um ein neues Access-Projekt im Access-Fenster zu erstellen. Nach Erstellung einer Microsoft Access-Instanz über eine andere Anwendung müssen Sie außerdem auch ein neues Access-Projekt erstellen. Dieses Accesss-Projekt wird im Microsoft Access-Fenster geöffnet.

Existiert das durch Projektname bezeichnete Access-Projekt bereits, so tritt ein Fehler auf.

Das neue Access-Projekt wird unter Kontrolle des Benutzerkontos "Administrator" geöffnet.

Anmerkung Zum Öffnen einer Access-Datenbank (.mdb) verwenden Sie die NewCurrentDatabase-Methode des Application-Objekts.


 NewCurrentDatabase-Methode

NewCurrentDatabase-Methode

Mit der Methode NewCurrentDatabase können Sie im Microsoft Access-Fenster eine neue Microsoft Access-Datenbank (.mdb) erstellen. Sie können mit dieser Methode eine neue Datenbank aus einer anderen Anwendung heraus erstellen, von der Microsoft Access über Automatisierung, früher OLE-Automatisierung genannt, gesteuert wird. So können Sie z.B. in Microsoft Excel die Methode NewCurrentDatabase verwenden, um eine neue Datenbank im Microsoft Access-Fenster zu erstellen.

Anmerkung Mit der Methode NewAccessProject können Sie ein neues Microsoft Access-Projekt (.adp) im Access-Fenster erstellen.

Syntax

Anwendung.NewCurrentDatabase DBName

Die Methode NewCurrentDatabase hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Das Application-Objekt.
DBName | Ein Zeichenfolgenausdruck, der den Namen der neuen Datenbankdatei angibt, einschließlich Pfad und Dateinamenerweiterung. Wenn Ihr Netzwerk dies unterstützt, können Sie einen Netzwerkpfad auch in folgender Schreibweise angeben: \\Server\Freigabe\Ordner\Dateiname
 | Anmerkung Wenn Sie keine Dateinamenerweiterung angeben, wird an den Dateinamen automatisch .mdb angehängt.

Anmerkung

Die Methode NewCurrentDatabase ermöglicht es Ihnen, eine neue Microsoft Access-Datenbank über Automatisierung aus einer anderen Anwendung zu erstellen. Nachdem Sie eine Instanz von Microsoft Access aus der anderen Anwendung heraus erstellt haben, müssen Sie eine neue Datenbank erstellen. Diese Datenbank wird dann im Microsoft Access-Fenster geöffnet.

Wenn die unter DBName angegebene Datenbank bereits existiert, tritt ein Fehler auf.

Die neue Datenbank wird unter dem Administrator-Benutzerkonto geöffnet.


 OpenAccessProject-Methode

OpenAccessProject-Methode

Mit der OpenAccessProject-Methode können Sie ein vorhandenes Microsoft Access-Projekt (.adp) als das aktuelle Access-Projekt im Microsoft Access-Fenster öffnen.

Syntax

Objekt.OpenAccessProject Projektname

Die OpenAccessProject-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Das Application-Objekt.
Projektname | Ein Zeichenfolgenausdruck, der den Namen des vorhandenen Access-Projekts (einschließlich des Pfadnamens und der Dateinamenerweiterung) bezeichnet. Sofern dies Ihr Netzwerk unterstützt, können Sie außerdem einen Netzwerkpfad der folgenden Art angeben: \\Server\Freigabe\Ordner\Dateiname.adp
 | Anmerkung Wenn Sie die Dateinamenerweiterung nicht angeben, wird automatisch .adp an den Dateinamen angehängt. Sie können diese Methode oder die OpenCurrentDatabase-Methode verwenden, um .adp-Dateien zu öffnen.

Anmerkungen

Die OpenAccessProject-Methode ermöglicht es Ihnen, ein vorhandenes Projekt aus Microsoft Access heraus oder mit einer anderen Anwendung über den Weg der Automatisierung (formell als OLE-Automatisierung bezeichnet) zu öffnen. Sie können die OpenAccessProject-Methode beispielsweise durch Microsoft Excel aufrufen, um die Beispieldatenbank Nordwind.adp im Microsoft Access-Fenster zu öffnen. Nach Erstellung einer Microsoft Access-Instanz durch eine andere Anwendung müssen Sie außerdem ein neues Access-Projekt erstellen oder ein bestimmtes Access-Projekt zum Öffnen angeben. Dieses Access-Projekt wird im Microsoft Access-Fenster geöffnet.

Wenn Sie bereits ein Projekt geöffnet haben und ein weiteres Projekt im Microsoft Access-Fenster öffnen möchten, können Sie die CloseCurrentDatabase-Methode verwenden, um das erste Access-Projekt zu schließen, bevor Sie das andere Projekt öffnen.

Anmerkung Verwenden Sie zum Öffnen einer Access-Datenbank (.mdb) die OpenCurrentDatabase-Methode des Application-Objekts.


 OpenCurrentDatabase-Methode

OpenCurrentDatabase-Methode

Mit der Methode OpenCurrentDatabase können Sie eine vorhandene Microsoft Access-Datenbank (.mdb) als aktuelle Datenbank öffnen. Sie könnten mit dieser Methode z.B. eine Datenbank aus einer anderen Anwendung öffnen, von der Microsoft Access über Automatisierung, früher OLE-Automatisierung genannt, gesteuert wird. So könnten Sie z.B. die Methode OpenCurrentDatabase in Microsoft Excel verwenden, um die Beispieldatenbank Nordwind.mdb im Microsoft Access-Fenster zu öffnen.

Anmerkung Mit der Methode OpenAccessProject können Sie ein vorhandenes Microsoft Access-Projekt (.adp) als aktuelle Datenbank öffnen.

Syntax

Anwendung.OpenCurrentDatabase DBName[, Exklusiv]

Die Methode OpenCurrentDatabase hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Das Application-Objekt.
DBName | Ein Zeichenfolgenausdruck, der den Namen einer bestehenden Datenbankdatei angibt, einschließlich Pfadname und Dateinamenerweiterung. Wenn Ihr Netzwerk dies unterstützt, können Sie einen Netzwerkpfad auch in folgender Schreibweise angeben: \\Server\Freigabe\Ordner\Dateiname
 | Anmerkung Wenn Sie keine Dateinamenerweiterung angeben, wird an den Dateinamen automatisch .mdb angehängt.
Exklusiv | Optional. Ein Boolscher Integer Wert, der angibt, ob Sie die Datenbank im Exklusivmodus öffnen möchten. Der Standardwert ist False, was bedeutet, dass eine Datenbank im Modus für gemeinsame Nutzung geöffnet wird.

Anmerkung

Die Methode OpenCurrentDatabase ermöglicht es Ihnen, eine Microsoft Access-Datenbank über Automatisierung aus einer anderen Anwendung heraus zu öffnen. Nachdem Sie eine Instanz von Microsoft Access aus der anderen Anwendung heraus erstellt haben, müssen Sie entweder eine neue Datenbank erstellen oder eine Datenbank angeben, die geöffnet werden soll. Diese Datenbank wird dann im Microsoft Access-Fenster geöffnet.

Wenn Sie bereits eine Datenbank geöffnet haben und eine andere Datenbank im Microsoft Access-Fenster öffnen möchten, können Sie mit der Methode CloseCurrentDatabase die erste Datenbank schließen, bevor Sie eine andere öffnen.

Stellen Sie das Argument Exklusiv auf True ein, um die Datenbank im Exklusivmodus zu öffnen. Wenn Sie dieses Argument nicht angeben, wird die Datenbank im Modus für gemeinsame Nutzung geöffnet.

Anmerkung Verwechseln Sie die Methode OpenCurrentDatabase nicht mit der ADO (ActiveX Data Objects)-Methode Open oder der DAO (Data Access Object)-Methode OpenDatabase. Die Methode OpenCurrentDatabase öffnet eine Datenbank im Microsoft Access-Fenster. Dagegen gibt die ADO-Methode Open lediglich eine Connection-Objektvariable und die DAO-Methode OpenDatabase eine Database-Objektvariable zurück. Beide Variablen entsprechen einer bestimmten Datenbank, öffnen diese jedoch nicht tatsächlich im Microsoft Access-Fenster.


 OpenDataAccessPage-Methode

OpenDataAccessPage-Methode

Die OpenDataAccessPage-Methode führt die Aktion ÖffnenDatenzugriffsseite in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenDataAccessPage Seitenname [, Seitenansicht]

Die OpenDataAccessPage-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Seitenname | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Datenzugriffsseite in der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die OpenDataAccessPage-Methode enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access ein Formular mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Seitenansicht | Eine der folgenden eingebauten Konstanten:
 | acDataPageBrowse (Voreinstellung) acDataPageDesign
 | acDataPageBrowse öffnet das Formular in der Seitenansicht.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acDataPageBrowse) verwendet.

Anmerkung

Falls bei der Erstellung der Datenzugriffsseite kein Verbindungskennwort in die Verbindungsinformationen aufgenommen wurde, wird der Benutzer beim Aufruf der OpenDataAccessPage-Methode zur Eingabe eines Kennworts aufgefordert.


 OpenDiagram-Methode

OpenDiagram-Methode

Die OpenDiagram-Methode führt die Aktion ÖffnenDiagramm in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenDiagram Diagrammname

Die OpenDiagram-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Seitenname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Datenbankdiagramms in der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenDiagram enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Datenbankdiagramm mit diesem Namen zunächst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.


 OpenForm-Methode

OpenForm-Methode

Die Methode OpenForm führt die Aktion ÖffnenFormular in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenForm Formularname [, Ansicht][, Filtername][, Bedingung][, Datenmodus][, Fenstermodus][, Öffnungsargumente]

Die Methode OpenForm verwendet die folgenden Argumente:

Argument | Beschreibung
Formularname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Formulars der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenForm enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Formular mit diesem Namen zunächst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Eine der folgenden eingebauten Konstanten:
 | acDesign acFormDS acNormal (Standardwert) acPreview
 | acNormal öffnet das Formular in der Formularansicht.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acNormal) verwendet.
Filtername | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Abfrage der aktuellen Datenbank angibt.
Bedingung | Ein Zeichenfolgenausdruck, der eine gültige SQL WHERE-Klausel ohne das Wort WHERE angibt.
Datenmodus | Eine der folgenden eingebauten Konstanten:
 | acFormAdd acFormEdit acFormPropertySettings (Standardwert) acFormReadOnly
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acFormPropertySettings) verwendet, und Microsoft Access öffnet das Formular in dem Datenmodus, der mit den Eigenschaften Bearbeitungen zulassen, Löschen zulassen, Anfügen zulassen und Daten eingeben eingestellt ist.
Fenstermodus | Eine der folgenden eingebauten Konstanten:
 | acDialog acHidden acIcon acWindowNormal (Standardwert)
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acWindowNormal) verwendet.
Öffnungsargumente | Ein Zeichenfolgenausdruck, der zum Einstellen der Formulareigenschaft Öffnungsargumente verwendet wird. Diese Einstellung kann dann von Code in einem Formularmodul verwendet werden, z.B. in der jeweiligen Open-Ereignisprozedur. Auf die Eigenschaft Öffnungsargumente kann auch in Makros und Ausdrücken verwiesen werden.
 | Wenn Sie z.B. eine Kundenliste öffnen, die als Endlosformular vorliegt, und den Fokus beim Öffnen des Formulars auf einen bestimmten Kundendatensatz setzen möchten, können Sie den Kundennamen im Argument Öffnungsargumente angeben. Anschließend können Sie den Fokus mit der Methode FindRecord auf den Datensatz des Kunden mit dem angegebenen Namen setzen.
 | Dieses Argument ist nur in Visual Basic verfügbar.

Anmerkung

Das Argument Bedingung darf bis zu 32.768 Zeichen lang sein (im Gegensatz zum Aktionsargument Bedingung im Makrofenster, dessen maximale Länge 256 Zeichen beträgt).

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 OpenModule-Methode

OpenModule-Methode

Die Methode OpenModule führt die Aktion ÖffnenModul in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenModule [Modulname][, Prozedurname]

Die Methode OpenModule verwendet die folgenden Argumente:

Argument | Beschreibung
Modulname | Ein Zeichenfolgenausdruck, der den gültigen Namen des zu öffnenden Visual Basic-Moduls angibt. Wenn Sie dieses Argument nicht angeben, sucht Microsoft Access in allen Standardmodulen der Datenbank nach der im Argument Prozedurname angegebenen Prozedur und öffnet das Modul an dieser Prozedur.
 | Wenn Sie Visual Basic-Code, der die Methode OpenModule enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach diesem Modul mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Prozedurname | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Prozedur angibt, an der das Modul geöffnet werden soll. Wenn Sie dieses Argument nicht angeben, wird das Modul geöffnet und sein Deklarationsbereich angezeigt.

Anmerkung

Verwenden Sie mindestens ein Argument der Methode OpenModule. Wenn Sie für beide Argumente einen Wert eingeben, öffnet Microsoft Access das angegebene Modul an der angegebenen Prozedur.

Wenn Sie das Argument Prozedurname weglassen, geben Sie nach dem Argument Modulname kein Komma ein.


 OpenQuery-Methode

OpenQuery-Methode

Die Methode OpenQuery führt die Aktion ÖffnenAbfrage in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Diese Methode ist nur in der Umgebung Microsoft Access-Datenbank (.mdb) verfügbar. Lesen Sie die Themen zu den Methoden OpenView bzw. OpenStoredProcedure, wenn Sie die Microsoft-Umgebung Access-Projekt (.adp) verwenden.

Syntax

DoCmd.OpenQuery Abfragename[, Ansicht][, Datenmodus]

Die Methode OpenQuery verwendet die folgenden Argumente:

Argument | Beschreibung
Abfragename | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Abfrage der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenQuery enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Abfrage mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Eine der folgenden eingebauten Konstanten:
 | acViewDesign acViewNormal (Standardwert) acViewPreview
 | Wenn für das Argument Abfragename entweder der Name einer Auswahl-, Kreuztabellen-, Union- oder der Name einer Pass-Through-Abfrage angegeben wird, deren Eigenschaft ReturnsRecords auf -1 eingestellt ist, zeigt acNormal die Ergebnisgruppe der Abfrage an. Wenn sich das Argument Abfragename auf eine Aktions- oder Datendefinitionsabfrage bzw. auf eine Pass-Through-Abfrage bezieht, deren Eigenschaft ReturnsRecords auf 0 eingestellt ist, führt acViewNormal die Abfrage aus.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acViewNormal) verwendet.
Datenmodus | Eine der folgenden eingebauten Konstanten:
 | acAdd acEdit (Standardwert) acReadOnly
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acEdit) verwendet.

Anmerkung

Wenn Sie das Argument Datenmodus angeben und das Argument Ansicht weglassen, geben Sie das Komma des Arguments Ansicht an. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 OpenReport-Methode

OpenReport-Methode

Die Methode OpenReport führt die Aktion ÖffnenBericht in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenReport Berichtsname[, Ansicht][, Filtername][, Bedingung]

Die Methode OpenReport verwendet die folgenden Argumente:

Argument | Beschreibung
Berichtsname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Berichts in der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenReport enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Bericht mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Eine der folgenden eingebauten Konstanten:
 | acViewDesign acViewNormal (Standardwert) acViewPreview
 | acViewNormal druckt den Bericht sofort aus. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acViewNormal) verwendet.
Filtername | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Abfrage der aktuellen Datenbank angibt
Bedingung | Ein Zeichenfolgenausdruck, der eine gültige SQL WHERE-Klausel ohne das Wort WHERE angibt.

Anmerkung

Das Argument Bedingung darf bis zu 32.768 Zeichen lang sein (im Gegensatz zum Aktionsargument Bedingung im Makrofenster, dessen maximale Länge 256 Zeichen beträgt).

Sie können optionale Argumente in der Syntax weglassen, geben jedoch in jedem Fall das zum Argument gehörende Komma an. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 OpenStoredProcedure-Methode

OpenStoredProcedure-Methode

Die OpenStoredProcedure-Methode führt die Aktion ÖffnenGespeicherteProzedur in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenStoredProcedure Prozedurname [, Ansichtsmodus] [, Datenmodus]

Die OpenStoredProcedure-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Prozedurname | Ein Zeichenfolgenausdruck., der den gültigen Namen einer Gespeicherten Prozedur in der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die OpenStoredProcedure-Methode enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access eine Gespeicherte Prozedur mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansichtsmodus | Eine der folgenden eingebauten Konstanten:
 | acViewNormal (Voreinstellung) acViewDesign acViewPreview
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acViewNormal) verwendet.
Datenmodus | Eine der folgenden eingebauten Konstanten:
 | acAdd acEdit (Voreinstellung) acReadOnly
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acEdit) verwendet.


 OpenTable-Methode

OpenTable-Methode

Die Methode OpenTable führt die Aktion ÖffnenTabelle in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenTable Tabellenname[, Ansicht][, Datenmodus]

Die Methode OpenTable verwendet die folgenden Argumente:

Argument | Beschreibung
Tabellenname | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Tabelle der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenTable enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach der Tabelle mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Eine der folgenden eingebauten Konstanten:
 | acViewDesign acViewNormal (Standardwert) acViewPreview
 | acViewNormal öffnet die Tabelle in der Datenblattansicht.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acViewNormal) verwendet.
Datenmodus | Eine der folgenden eingebauten Konstanten:
 | acAdd acEdit (Standardwert) acReadOnly
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acEdit) verwendet.

Anmerkung

Wenn Sie das Argument Datenmodus angeben und das Argument Ansicht weglassen, geben Sie das Komma des Arguments Ansicht an. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 OpenView-Methode

OpenView-Methode

Die OpenView-Methode führt die Aktion ÖffnenSicht in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OpenView Ansichtsname [, Ansichtsmodus] [, Datenmodus]

Die Methode OpenView verwendet die folgenden Argumente:

Argument | Beschreibung
Sichtname | Ein Zeichenfolgenausdruck, der den gültigen Namen einer Sicht in der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode OpenView enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access die Sicht mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Sicht | Eine der folgenden eingebauten Konstanten:
 | acViewNormal (Voreinstellung) acViewDesign acPreview
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acViewNormal) verwendet.
Datenmodus | Eine der folgenden eingebauten Konstanten.
 | acEdit (Voreinstellung) acAdd acReadOnly
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acEdit) verwendet.


 OutputTo-Methode

OutputTo-Methode

Die Methode OutputTo führt die Aktion AusgabeIn in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.OutputTo Objekttyp[, Objektname][, Ausgabeformat][, Ausgabedatei][, Autostart][, Vorlagedatei]

Die Methode OutputTo verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acOutputDataAccessPage acOutputForm acOutputModule acOutputQuery acOutputReport acOutputServerView acOutputStoredProcedure acOutputTable
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt. Wenn Sie das aktive Objekt ausgeben möchten, geben Sie mit dem Argument Objekttyp den Typ des Objekts an, und lassen Sie dieses Argument weg.
 | Wenn Sie Visual Basic-Code, der die Methode OutputTo enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ausgabeformat | Eine der folgenden eingebauten Konstanten:
 | acFormatASP acFormatDAP acFormatHTML acFormatIIS acFormatRTF acFormatSNP acFormatTXT acFormatXLS
 | Wenn Sie dieses Argument weglassen, fordert Microsoft Access Sie auf, eine Ausgabedatei anzugeben.
Ausgabedatei | Ein Zeichenfolgenausdruck, der den vollständigen Namen und Pfad der Datei angibt, in die das Objekt ausgegeben werden soll.
 | Wenn Sie dieses Argument weglassen, fordert Microsoft Access Sie auf, eine Ausgabedatei anzugeben.
Autostart | Verwenden Sie True (-1), um die entsprechende auf Windows basierende Anwendung sofort zu starten und die im Argument Ausgabedatei angegebene Datei zu laden. Verwenden Sie False (0), wenn die Anwendung nicht gestartet werden soll. Dieses Argument wird für Microsoft Internet Information Server-Dateien (.htx, .idc) und Microsoft Active Server Pages-Dateien (*.asp) nicht beachtet.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
Vorlagedatei | Ein Zeichenfolgenausdruck, der den vollständigen Namen und Pfad der Datei angibt, die Sie als Vorlage für eine HTML-, HTX- oder ASP-Datei verwenden möchten.

Anmerkung

Module können nur im MS-DOS-Textformat ausgegeben werden. Wenn Sie also für das Argument Objekttyp acOutputModule angeben, geben Sie für das Argument Ausgabeformat acFormatTXT an. Microsoft Internet Information Server-Formate und das Microsoft Active Server Page-Format sind nur für Tabellen, Abfragen und Formulare verfügbar. Wenn Sie also für das Argument Ausgabeformat acFormatIIS oder acFormatASP angeben, geben Sie für das Argument Objekttyp acOutputTable, acOutputQuery oder acOutputForm an.

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 Print-Methode (Microsoft Access)

Print-Methode (Microsoft Access)

Die Methode Print druckt Text in einem Report-Objekt mit der aktuellen Farbe und Schriftart.

Syntax

Objekt.Print [{Spc(n) | Tab(n)}][Ausdrucksliste][{;|,}]

Die Methode Print verwendet die folgenden Argumente:

Argument | Beschreibung
Objekt | Das Report-Objekt, in das der Text gedruckt werden soll.
Spc(n) | Die Visual Basic-Funktion, mit der n Leerzeichen in die gedruckte Ausgabe eingefügt werden. Mehrfachverwendung ist zulässig.
Tab(n) | Die Visual Basic-Funktion, mit der die Einfügemarke in die n. Druckzone bewegt wird, bevor die Ausdrucksliste gedruckt wird. Druckzonen beginnen in jeder 14. Spalte. Die Breite jeder Spalte ist die durchschnittliche Breite aller Zeichen des Schriftgrades für die gewählte Schriftart. Mehrfachverwendung ist zulässig.
Ausdrucksliste | Die zu druckenden numerischen Ausdrücke oder Zeichenfolgenausdrücke. Wenn dieses Argument weggelassen wird, druckt die Methode Print eine Leerzeile. Mehrere Ausdrücke können durch ein Leerzeichen, ein Semikolon (;) oder ein Komma voneinander getrennt werden. Ein Leerzeichen bewirkt dasselbe wie ein Semikolon. Sie können auch die Funktionen Spc und Tab verwenden, um jedes Paar von Ausdrücken voneinander zu trennen.
{;|,} | Bestimmt die Position der Einfügemarke für das nächste gedruckte Zeichen. Ein Semikolon bedeutet, dass die Einfügemarke direkt hinter das letzte gedruckte Zeichen gesetzt wird; ein Komma bedeutet, dass sie an den Anfang der nächsten Druckzone gesetzt wird.

Anmerkungen

Sie können diese Methode nur in einer Ereignisprozedur oder einem Makro verwenden, das durch die Einstellung der Ereigniseigenschaft OnPrint eines Bereichs angegeben wird.

Die durch das Argument Ausdrucksliste angegebenen Ausdrücke werden im Objekt gedruckt, beginnend an der Position, die durch die Einstellungen der Eigenschaften CurrentX und CurrentY festgelegt ist.

Beim Drucken des Arguments Ausdrucksliste wird normalerweise ein Wagenrücklauf angehängt, so dass die nächste Print-Methode mit dem Drucken in der nächsten Zeile beginnt. Wenn ein Wagenrücklauf vorkommt, wird die Einstellung der Eigenschaft CurrentY um die Höhe des Arguments Ausdrucksliste (identisch mit dem durch die Methode TextHeight zurückgegebenen Wert) vergrößert und die Eigenschaft CurrentX auf 0 eingestellt.

Folgt auf das Argument Ausdrucksliste ein Semikolon, wird kein Wagenrücklauf angefügt, und die nächste Print-Methode druckt in dieselbe Zeile wie die aktuelle Print-Methode. Die Eigenschaften CurrentX und CurrentY werden auf den Punkt direkt hinter dem letzten gedruckten Zeichen eingestellt. Falls das Argument Ausdrucksliste selbst Wagenrückläufe enthält, stelllt jeder derart eingebettete Wagenrücklauf die Eigenschaften CurrentX and CurrentY wie bei der Methode Print ohne Semikolon ein.

Folgt auf das Argument Ausdrucksliste ein Komma, werden die Eigenschaften CurrentX und CurrentY auf die nächste Druckzone in derselben Zeile eingestellt.

Wenn das Argument Ausdrucksliste in ein Report-Objekt gedruckt wird, erfolgt bei Zeilen, die nicht in die angegebene Position passen, kein Bildlauf. Der Text wird entsprechend dem Objekt abgeschnitten.

Da die Methode Print in der Regel mit Zeichen in Proportionalschrift druckt, ist zu bedenken, dass keine Beziehung zwischen der Anzahl der gedruckten Zeichen und der Anzahl der Spalten fester Breite besteht, die diese Zeichen einnehmen. Beispielsweise nimmt ein breiter Buchstabe (wie W) mehr als eine Spalte fester Breite ein, während ein schmaler Buchstabe (wie I) weniger Platz einnimmt. Daher sollten Sie sicherstellen, dass der Abstand der Tabellenspalten ausreicht, um den zu druckenden Text aufzunehmen. Alternativ können Sie in einer Schriftart mit fester Schriftbreite (wie Courier) drucken, um sicherzustellen, dass jedes Zeichen nur eine Spalte einnimmt.


 PrintOut-Methode

PrintOut-Methode

Die Methode PrintOut führt die Aktion Drucken in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.PrintOut [Druckbereich][, Von, Bis][, Druckqualität][, Exemplare][, Exemplare sortieren]

Die Methode PrintOut verwendet die folgenden Argumente:

Argument | Beschreibung
Druckbereich | Eine der folgenden eingebauten Konstanten:
 | acPrintAll (Standardwert) acSelection acPages
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acPrintAll) verwendet.
Von | Ein numerischer Ausdruck, der eine gültige Seitenzahl des aktiven Formulars oder Datenblatts angibt. Dieses Argument ist erforderlich, wenn Sie für das Argument Druckbereich die Konstante acPages angegeben haben.
Bis | Ein numerischer Ausdruck, der eine gültige Seitenzahl des aktiven Formulars oder Datenblatts angibt. Dieses Argument ist erforderlich, wenn Sie für das Argument Druckbereich die Konstante acPages angegeben haben.
Druckqualität | Eine der folgenden eingebauten Konstanten:
 | acDraft acHigh (Standardwert) acLow acMedium
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acHigh) verwendet.
Exemplare | Ein numerischer Ausdruck. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (1) verwendet.
Exemplare sortieren | Verwenden Sie True (-1), um die Exemplare beim Drucken sortieren zu lassen, und False (0), um die Exemplare nicht sortieren zu lassen. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (True) verwendet.

Anmerkung

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 PrintSnapshot-Methode

PrintSnapshot-Methode

Die PrintSnapshot-Methode dient dem Ausdrucken der aktuellen Snapshot-Datei.

Syntax

Objekt.PrintSnapshot([Drucken-DialogAnzeigen As Boolean])

Die PrintSnapshot-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Objekt, das ein Snapshot Viewer-Steuerelement repräsentiert.
Drucken-DialogAnzeigen | (Optional) Ein Wert des Typs Boolean, der angibt, ob das Dialogfeld Drucken angezeigt werden soll. Der Standardwert ist True.

Anmerkungen

Wird das optionale Argument Drucken-DialogAnzeigen weggelassen, so wird das Dialogfeld Drucken angezeigt. Falls der Benutzer im Dialogfeld Drucken auf die Schaltfläche Abbrechen klickt, tritt ein Fehler (Fehlernummer 2504) auf. Wenn Sie die PrintSnapshot-Methode verwenden, ohne dass eine Snapshot-Datei im Steuerelement angezeigt wird, tritt ebenfalls ein Fehler (Fehlernummer 2502) auf. Um sicherzustellen, dass im Steuerelement eine gültige Snapshot-Datei angezeigt wird, können Sie die Eigenschaften SnapshotPath und ReadyState verwenden.

Sie können einzelne Seiten einer Snapshot-Datei drucken, indem Sie die Seitenzahlen im Dialogfeld Drucken angeben

Die PrintSnapshot-Methode zeigt ein Sanduhr-Symbol an, während die Snapshot-Datei gedruckt wird.


 PSet-Methode

PSet-Methode

Die Methode PSet färbt einen Punkt auf einem Report-Objekt in der angegebenen Farbe, wenn das Ereignis Print eintritt.

Syntax

Objekt.PSet [Step](x, y)[, Farbe]

Sie können diese Methode nur in einer Ereignisprozedur oder in einem Makro verwenden, die bzw. das in den Ereigniseigenschaften OnPrint oder OnFormat für einen Berichtsbereich oder in der Ereigniseigenschaft OnPage für einen Bericht angegeben ist.

Die Methode PSet hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Report-Objekt, auf dem der Punkt gezeichnet werden soll.
Step | Ein Schlüsselwort, das angibt, dass die Koordinaten relativ zur aktuellen Grafikposition liegen, die durch die Einstellungen der Eigenschaften CurrentX und CurrentY des Arguments Objekt festgelegt ist.
x, y | Werte vom Datentyp Single, die die horizontale und vertikale Koordinate des zu färbenden Punktes definieren.
Farbe | Ein Wert vom Datentyp Long, der die RGB-Farbe (rot-grün-blau) für den zu färbenden Punkt angibt. Wird dieses Argument nicht angegeben, wird der Wert der Eigenschaft ForeColor verwendet. Sie können zum Festlegen der Farbe auch die Funktionen RGB oder QBColor verwenden.

Anmerkung

Die Größe des Punktes hängt von der Einstellung der Eigenschaft Rahmenbreite ab. Wenn die Eigenschaft Rahmenbreite auf 1 eingestellt ist, stellt die Methode PSet ein einzelnes Pixel auf die angegebene Farbe ein. Ist der Wert der Eigenschaft Rahmenbreite größer als 1, wird der Punkt auf den angegebenen Koordinaten zentriert.

Wie der Punkt gezeichnet wird, hängt von den Einstellungen der Eigenschaften Rahmenart und Rahmenbreite ab.

Wenn Sie die Methode PSet anwenden, werden die Eigenschaften CurrentX und CurrentY auf die Punktkoordinaten eingestellt, die durch die Argumente x und y bestimmt sind.

Wenn Sie ein Pixel mit der Methode PSet löschen möchten, geben Sie die Koordinaten des Pixels an, und verwenden Sie &HFFFFFF (Weiß) für das Argument Farbe.

Tipp Mit der Methode Line wird eine Linie schneller als mit der Methode PSet gezeichnet.


 Quit-Methode (Application-Objekt)

Quit-Methode (Application-Objekt)

Die Methode Quit beendet Microsoft Access. Sie können eine von mehreren Optionen wählen, um ein Datenbankobjekt vor dem Beenden zu speichern.

Syntax

Application.Quit [Option]

Die Methode Quit verwendet das folgende Argument.

Argument | Beschreibung
Option | Eine eingebaute Konstante, die angibt, was mit ungespeicherten Objekten beim Beenden von Microsoft Access geschieht. Dieses Argument kann eine der folgenden Konstanten sein.
 | Konstante | Beschreibung
 | acSaveYes | (Standardeinstellung) Speichert alle Objekte, ohne ein Dialogfeld anzuzeigen.
 | acPrompt | Zeigt ein Dialogfeld an, das fragt, ob Sie geänderte, noch nicht gespeicherte Datenbankobjekte speichern möchten.
 | acExit | Beendet Microsoft Access, ohne Objekte zu speichern.

Anmerkungen

Die Methode Quit hat dieselbe Wirkung wie das Klicken auf Beenden im Menü Datei. Sie können einen benutzerdefinierten Menübefehl oder eine Befehlsschaltfläche in einem Formular mit einer Prozedur erstellen, die die Methode Quit enthält. So können Sie beispielsweise die Schaltfläche Beenden in ein Formular einfügen und in deren Ereignis Click eine Prozedur einbeziehen, die die Methode Quit verwendet, wobei das Argument Option auf acSaveYes eingestellt ist.


 Quit-Methode (DoCmd-Objekt)

Quit-Methode (DoCmd-Objekt)

Die Methode Quit des Objekts DoCmd führt die Aktion Verlassen in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Quit [Optionen]

Die Methode Quit verwendet das folgende Argument:

Argument | Beschreibung
Optionen | Eine der folgenden eingebauten Konstanten:
 | acQuitPrompt acQuitSaveAll (Standardwert) acQuitSaveNone
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acQuitSaveAll) verwendet.

Anmerkung

Die Methode Quit des Objekts DoCmd wurde hinzugefügt, um die Abwärtskompatibilität zu gewährleisten, wenn die Aktion Quit im Visual Basic-Code in Microsoft Access 95 ausgeführt wird. Es empfiehlt sich jedoch, stattdessen die vorhandene Methode Quit des Objekts Application zu verwenden.


 Recalc-Methode

Recalc-Methode

Die Methode Recalc aktualisiert sofort alle berechneten Steuerelemente eines Formulars.

Syntax

Formularname.Recalc

Die Methode Recalc hat folgendes Argument.

Argument | Beschreibung
Formularname | Ein Form-Objekt, das das Formular mit den Steuerelementen darstellt, deren Werte Sie neu berechnen möchten.

Anmerkung

Diese Methode bewirkt dasselbe wie das Drücken von F9, während das Formular den Fokus besitzt. Sie können mit dieser Methode die Werte von Steuerelementen neu berechnen, die von anderen Feldern, deren Inhalt sich möglicherweise geändert hat, abhängig sind.


 Refresh-Methode

Refresh-Methode

Die Methode Refresh aktualisiert sofort die Datensätze der zugrunde liegenden Datenherkunft für ein angegebenes Formular oder Datenblatt und berücksichtigt dadurch die Änderungen, die Sie oder andere Benutzer in einer Mehrbenutzerumgebung an den Daten vorgenommen haben.

Syntax

Formularname.Refresh

Die Methode Refresh hat folgendes Argument.

Argument | Beschreibung
Formularname | Ein Form-Objekt, das das zu aktualisierende Formular darstellt.

Anmerkung

Die Verwendung der Methode Refresh entspricht dem Klicken auf Aktualisieren im Menü Datensätze.

Microsoft Access aktualisiert Datensätze automatisch auf Grund der Einstellung für Anzeigeaktualisierungsintervall in der Registerkarte Fortgeschritten des Dialogfelds Optionen, das durch Klicken auf Optionen im Menü Extras verfügbar ist. ODBC-Datenherkünfte werden entsprechend der Einstellung ODBC-Anzeigeaktualisierungsintervall in der Registerkarte Fortgeschritten des Dialogfelds Optionen aktualisiert. Mit der Methode Refresh können Sie feststellen, welche Änderungen an den aktuellen Datensätzen in einem Formular oder Datenblatt seit der letzten automatischen Aktualisierung der dem Formular oder Datenblatt zugrunde liegenden Datenherkunft vorgenommen wurden.

Die Methode Refresh zeigt lediglich Änderungen an, die an Datensätzen der aktuellen Gruppe vorgenommen wurden. Da die Methode Refresh die Datenbank nicht erneut abfragt, werden in die Gruppe keine Datensätze aufgenommen, die hinzugefügt wurden, oder Datensätze daraus entfernt, die gelöscht wurden, seit die Datenbank das letzte Mal abgefragt wurde. Auch Datensätze, die nicht mehr den Kriterien der Abfrage oder des Filters entsprechen, werden nicht entfernt. Wenn Sie eine erneute Abfrage der Datenbank durchführen möchten, verwenden Sie die Methode Requery. Wenn die Datenherkunft für ein Formular erneut abgefragt wird, gibt die aktuelle Gruppe der Datensätze alle Daten in der Datenherkunft wieder.

Anmerkungen

  • Manchmal ist die Aktualisierung eines Formulars oder Datenblatts schneller als eine erneute Abfrage. Dies gilt insbesondere dann, wenn die ursprüngliche Abfrage zeitaufwendig war.

  • Verwechseln Sie die Methode Refresh nicht mit der Methode Repaint, die den Bildschirm mit allen anstehenden optischen Änderungen aktualisiert.


 RefreshDatabaseWindow-Methode

RefreshDatabaseWindow-Methode

Die Methode RefreshDatabaseWindow aktualisiert das Datenbankfenster, nachdem ein Datenbankobjekt erstellt, gelöscht oder umbenannt wurde.

Syntax

[Anwendung.]RefreshDatabaseWindow

Die Methode RefreshDatabaseWindow hat folgende Argumente.

Argument | Beschreibung
Anwendung | Das Microsoft Access Application-Objekt.

Anmerkung

Mit der Methode RefreshDatabaseWindow können Sie Änderungen von Objekten in Microsoft Access unmittelbar im Datenbankfenster darstellen. Wenn Sie beispielsweise ein neues Formular aus Visual Basic hinzufügen und speichern, können Sie den Namen des neuen Formulars mit der Methode RefreshDatabaseWindow auf der Registerkarte Formulare des Datenbankfensters unmittelbar nach dem Speichern des Formulars anzeigen.


 RefreshTitleBar-Methode

RefreshTitleBar-Methode

Die RefreshTitleBar-Methode aktualisiert die Microsoft Access-Titelleiste, nachdem in Visual Basic eine der Eigenschaften AppTitle oder AppIcon eingestellt wurde. Sie können z.B. die Beschriftung in der Microsoft Access-Titelleiste in "Adressdatenbank" ändern, indem Sie der AppTitle-Eigenschaft einen entsprechenden Wert zuweisen.

Syntax

Anwendung.RefreshTitleBar

Die RefreshTitleBar-Methode verwendet das folgende Argument.

Argument | Beschreibung
Anwendung | Das Application-Objekt.

Anmerkung

Mit den Eigenschaften AppTitle und AppIcon können Sie Ihre Anwendung individuell gestalten und den Titel und das Symbol, die in der Microsoft Access-Titelleiste angezeigt werden, ändern. Die Titelleiste wird nicht automatisch aktualisiert, nachdem Sie diese Eigenschaften eingestellt haben. Damit die Änderungen in der Titelleiste sichtbar werden, müssen Sie die RefreshTitleBar-Methode verwenden.

Anmerkung In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaften AppTitle und AppIcon auf ihren jeweiligen Standardwert zurücksetzen, indem Sie beide aus der Properties-Auflistung entfernen, die die aktuelle Datenbank repräsentiert. Nach dem Löschen dieser Eigenschaften müssen Sie mit Hilfe der RefreshTitleBar-Methode die Microsoft Access-Standardeinstellungen für die Titelleiste wiederherstellen.


 Remove-Methode (AccessObjectProperties-Auflistung)

Remove-Methode (AccessObjectProperties-Auflistung)

Mit der Remove-Methode können Sie ein AccessObjectProperty-Objekt aus der AccessObjectProperties-Auflistung eines AccessObject-Objekts entfernen.

Syntax

Objekt.Remove Element

Die Remove-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur AccessObjectProperties-Auflistung eines AccessObject-Objekts ausgewertet wird.
Element | Ein Ausdruck, der die Position eines Elements der Auflistung bestimmt, auf die im Argument Objekt verwiesen wird. Wenn es sich um einen numerischen Ausdruck handelt, muss das Argument Index eine Zahl zwischen 0 und dem Wert der Count-Eigenschaft der Auflistung minus 1 sein. Wenn es sich um einen Zeichenfolgenausdruck handelt, muss das Argument Index der Name eines Elements der Auflistung sein.


 Remove-Methode (Pages-Auflistung)

Remove-Methode (Pages-Auflistung)

Die Methode Remove entfernt ein Page-Objekt aus der Pages-Auflistung eines Registersteuerelements.

Syntax

Objekt.Remove [Element]

Die Methode Remove hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur Pages-Auflistung eines Registersteuerelements ausgewertet wird.
Element | Ein Integer-Wert, der den Index des Page-Objekts angibt, das entfernt werden soll. Der Index des Page-Objekts entspricht dem Wert der Eigenschaft PageIndex für das Page-Objekt. Wenn Sie dieses Argument weglassen, wird das letzte Page-Objekt aus der Auflistung entfernt.

Anmerkung

Die Indizierung der Pages-Auflistung beginnt bei Null. Die am weitesten links liegende Seite im Registersteuerelement besitzt den Index 0, die Seite unmittelbar rechts daneben hat den Index 1 usw.

Sie können ein Page-Objekt aus der Pages-Auflistung eines Registersteuerelements nur dann entfernen, wenn sich das Formular in der Entwurfsansicht befindet.


 Remove-Methode (References-Auflistung)

Remove-Methode (References-Auflistung)

Die Methode Remove entfernt ein Reference-Objekt aus der References-Auflistung.

Syntax

Objekt.Remove Referenz

Die Methode Remove hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zur References-Auflistung ausgewertet wird.
Referenz | Das Reference-Objekt, das den zu entfernenden Verweis darstellt.

Anmerkung

Um den Namen des zu entfernenden Reference-Objekts zu ermitteln, überprüfen Sie das Feld Projekt/Bibliothek im Objektkatalog. In diesem Feld werden die Namen aller momentan eingestellten Verweise aufgeführt. Jeder Name entspricht dem Wert der Eigenschaft Name eines Reference-Objekts.


 Rename-Methode

Rename-Methode

Die Methode Rename führt die Aktion UmbenennenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Rename Neuer Name[, Objekttyp, Alter Name]

Die Methode Rename verwendet die folgenden Argumente:

Argument | Beschreibung
Neuer Name | Ein Zeichenfolgenausdruck, der den neuen Namen des umzubenennenden Objekts angibt. Der Name muss den Benennungskonventionen für Objekte in Microsoft Access entsprechen.
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
Alter Name | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.
 | Wenn Sie Visual Basic-Code, der die Methode Rename enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach den Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.

Anmerkung

Wenn Sie die Argumente Objekttyp und Objektname nicht angeben, wird die Standardkonstante (acDefault) für Objekttyp verwendet, und Microsoft Access benennt das im Datenbankfenster markierte Objekt um. Um ein Objekt im Datenbankfenster zu markieren, verwenden Sie die Aktion AuswählenObjekt oder die Methode SelectObject, wobei das Argument Im Datenbankfenster auf Ja eingestellt sein muss.

Wenn Sie die Argumente Objekttyp und Alter Name weglassen, geben Sie nach dem Argument Neuer Name kein Komma ein.


 Repaint-Methode

Repaint-Methode

Die Methode Repaint führt alle anstehenden Bildschirmaktualisierungen eines bestimmten Formulars aus. Wird diese Methode für ein Formular ausgeführt, so führt Repaint auch alle anstehenden Neuberechnungen der Steuerelemente durch.

Syntax

Formular.Repaint

Die Methode Repaint hat folgendes Argument.

Argument | Beschreibung
Formularname | Ein Form-Objekt, das das zu aktualisierende Formular darstellt.

Anmerkung

Gelegentlich wartet Microsoft Access mit der Ausführung von anstehenden Bildschirmaktualisierungen, bis andere Aufgaben beendet wurden. Mit der Methode Repaint können Sie die sofortige Aktualisierung der Steuerelemente des angegebenen Formulars erzwingen. Sie können die Methode Repaint in folgenden Situationen verwenden:

  • Wenn Sie in mehreren Feldern Werte ändern. Bis Sie eine Aktualisierung erzwingen, kann Microsoft Access die Änderungen möglicherweise nicht sofort anzeigen. Dies trifft besonders dann zu, wenn andere Felder, z.B. solche in dem Ausdruck eines berechneten Steuerelements, von Werten der geänderten Felder abhängig sind.
  • Wenn Sie sicherstellen möchten, dass ein Formular Daten in allen Feldern anzeigt. Beispielsweise zeigen Felder mit OLE-Objekten ihre Daten häufig nicht sofort nach dem Öffnen eines Formulars an.

Diese Methode bewirkt weder eine erneute Abfrage der Datenbank, noch zeigt sie neue oder geänderte Datensätze aus der dem Formular zugrunde liegenden Datenherkunft an. Verwenden Sie für eine erneute Abfrage der Datenherkunft des Formulars oder seiner Steuerelemente die Methode Requery.

Anmerkungen

  • Verwechseln Sie die Methode Repaint nicht mit der Methode Refresh oder dem Befehl Aktualisieren im Menü Datensätze. Die Methode Refresh und der Befehl Aktualisieren zeigen alle Änderungen an, die Sie oder andere Benutzer in der zugrunde liegenden Datenherkunft an den gerade angezeigten Datensätzen in Formularen und Datenblättern vorgenommen haben. Die Methode Repaint aktualisiert lediglich den Bildschirm, wenn die Aktualisierung dadurch verzögert wurde, dass Microsoft Access andere Aufgaben ausführen musste.

  • Die Methode Repaint unterscheidet sich von der Methode Echo darin, dass die Methode Repaint eine einzelne sofortige Aktualisierung erzwingt, während die Methode Echo die Bildschirmaktualisierung ein- oder ausschaltet.


 RepaintObject-Methode

RepaintObject-Methode

Die RepaintObject-Methode führt die Aktion AktualisierenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.RepaintObject [Objekttyp, Objektname]

Die RepaintObject-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagramacForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.

Anmerkungen

Wenn Sie die RepaintObject-Methode ohne Argumente verwenden (der Standardwert acDefault wird für das Argument Objekttyp verwendet), wird das aktive Fenster aktualisiert.

Die RepaintObject-Methode des Objekts DoCmd wurde hinzugefügt, um die Abwärtskompatibilität zu gewährleisten, wenn die Aktion UmbenennenObjekt im Visual Basic-Code in Microsoft Access 95 ausgeführt wird. Wenn Sie ein Formular aktualisieren möchten, empfiehlt es sich jedoch, stattdessen die vorhandene Repaint-Methode des Form-Objekts zu verwenden.


 ReplaceLine-Methode

ReplaceLine-Methode

Die Methode ReplaceLine ersetzt eine angegebene Zeile in einem Standardmodul oder Klassenmodul.

Syntax

Objekt.ReplaceLine Zeile, Zeichenfolge

Die Methode ReplaceLine hat folgende Argumente.

Argument | Beschreibung
Objekt | Ein Module-Objekt.
Zeile | Ein Wert vom Datentyp Long, der die Nummer der zu löschenden Zeile angibt.
Zeichenfolge | Der Text, der die bestehende Zeile ersetzen soll.

Anmerkung

Die Zeilen in einem Modul sind ab Eins nummeriert. Sie können die Anzahl der Zeilen in einem Modul mit der Eigenschaft CountOfLines ermitteln.


 Requery-Methode (DoCmd-Objekt)

Requery-Methode (DoCmd-Objekt)

Die Requery-Methode des Objekts DoCmd führt die Aktion AktualisierenDaten in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Requery [Steuerelementname]

Die Requery-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Steuerelementname | Ein Zeichenfolgenausdruck, der den Namen eines Steuerelements des aktiven Formulars angibt.

Anmerkungen

Geben Sie für das Argument Steuerelementname nur den Namen des Steuerelements ein, nicht die vollständige Syntax.

Sie können für dieses Argument auch eine Variable vom Datentyp Control verwenden.

Dim ctlListenfeld As Control
Set ctlListenfeld = Formulare!Formular1!Feld3
DoCmd.Requery ctlListenfeld.Name

Die Requery-Methode des Objekts DoCmd unterscheidet sich von der Requery -Methode in Visual Basic. Die Requery-Methode des Objekts DoCmd wurde hinzugefügt, um beim Ausführen der Aktion AktualisierenDaten im Visual Basic-Code in Microsoft Access 95 Abwärtskompatibilität zu gewährleisten. Wenn Sie ein Steuerelement, das sich nicht im aktiven Objekt befindet, durch erneutes Abfragen aktualisieren möchten, verwenden Sie die Requery-Methode in Visual Basic; die Aktion AktualisierenDaten und die entsprechende Requery-Methode des Objekts DoCmd sind dafür nicht geeignet. Die Requery-Methode eines Visual Basic-Formulars oder -Steuerelements ist schneller als die Aktion AktualisierenDaten oder die DoCmd.Requery-Methode. Außerdem schließt Microsoft Access die Abfrage und lädt sie erneut aus der Datenbank, wenn Sie die Aktion AktualisierenDaten oder die DoCmd.Requery-Methode verwenden. Verwenden Sie dagegen die Requery-Methode in Visual Basic, so führt Microsoft Access die Abfrage erneut aus, ohne sie zu schließen und erneut zu laden.

Anmerkung Die Requery-Methode in ActiveX-Datenobjekten (ADO-Objekten) kann ebenfalls zur erneuten Ausführung der Abfrage verwendet werden.


 Requery-Methode (Steuerelement- oder Formular-Objekt)

Requery-Methode (Steuerelement- oder Formular-Objekt)

Die Methode Requery aktualisiert die zugrunde liegenden Daten eines angegebenen Formulars oder eines Steuerelements auf dem aktiven Formular durch erneutes Abfragen der Datenherkunft des Formulars bzw. Steuerelements.

Syntax

[Objektname.]Requery

Die Methode Requery hat folgendes Argument.

Argument | Beschreibung
Objektname | Ein Form- oder Control-Objekt, das das zu aktualisierende Formular oder Steuerelement darstellt. Geben Sie dieses Argument nicht an, wenn die Datenherkunft des aktiven Objekts erneut abgefragt werden soll.

Anmerkung

Mit dieser Methode stellen Sie sicher, dass im Formular oder Steuerelement die aktuellen Daten angezeigt werden.

Die Methode Requery führt einen der folgenden Vorgänge aus:

  • Erneutes Ausführen der Abfrage, auf der das Formular oder Steuerelement basiert.
  • Anzeigen aller neuen oder geänderten Datensätze oder Entfernen gelöschter Datensätze aus der Tabelle, auf der das Formular oder Steuerelement basiert.
  • Aktualisieren der angezeigten Datensätze, die auf den Änderungen der Eigenschaft Filter des Formulars basieren.

Folgende Steuerelemente können auf einer Abfrage oder Tabelle basieren:

  • Listenfelder und Kombinationsfelder.

  • Unterformular-Steuerelemente.

  • OLE-Objekte wie z.B. Diagramme.

  • Steuerelemente, für die die Einstellung der Eigenschaft ControlSource Aggregatfunktionen für Domänen oder SQL-Aggregatfunktionen enthält.

Wenn Sie für das Argument Objektname ein Steuerelement anderen Typs angeben, wird die Datenherkunft des Formulars erneut abgefragt.

Wenn das im Argument Objektname angegebene Steuerelement nicht an ein Feld einer Tabelle oder Abfrage gebunden ist, erzwingt die Methode Requery eine Neuberechnung des Steuerelements.

Wenn Sie das Argument Objektname nicht angeben, führt die Methode Requery eine Abfrage der zugrunde liegenden Datenherkunft des Formulars oder Steuerelements durch, das den Fokus besitzt. Wenn das Steuerelement, das den Fokus hat, eine Datenherkunft oder Datensatzherkunft besitzt, wird diese erneut abgefragt. Andernfalls werden die Daten des Steuerelements einfach aktualisiert.

Wenn ein Unterformular-Steuerelement den Fokus hat, löst diese Methode lediglich eine Neuabfrage der Datenherkunft dieses Unterformulars aus, nicht des übergeordneten Formulars.

Anmerkungen

  • Die Methode Requery aktualisiert die einem Formular oder Steuerelement zugrunde liegenden Daten, um Datensätze anzuzeigen, die neu sind oder seit der letzten Abfrage aus der Datenherkunft gelöscht wurden. Die Methode Refresh zeigt nur Änderungen, die an den aktuellen Datensätzen vorgenommen wurden, und keine neuen oder in der Datenherkunft gelöschten Datensätze. Die Methode Repaint aktualisiert lediglich das angegebene Formular und dessen Steuerelemente.

  • Die Methode Requery gibt die Kontrolle nicht an das Betriebssystem zurück, um es Microsoft Windows so zu ermöglichen, die Verarbeitung von Nachrichten fortzusetzen. Verwenden Sie die Funktion DoEvents, falls Sie die Kontrolle temporär an das Betriebssystem übergeben möchten.

  • Die Methode Requery ist schneller als die Aktion AktualisierenDaten. Wenn Sie die Aktion AktualisierenDaten verwenden, schließt Microsoft Access zuerst die Abfrage und lädt sie dann neu aus der Datenbank. Wenn Sie die Methode Requery verwenden, führt Microsoft Access die Abfrage erneut aus, ohne sie vorher zu schließen und neu zu laden.


Restore-Methode

Die Methode Restore führt die Aktion Wiederherstellen in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Diese Methode kann nicht auf Modulfenster im Visual Basic-Editor (VBE) angewendet werden. Informationen über Möglichkeiten zum Beeinflussen von Modulfenstern finden Sie unter dem Thema zur Eigenschaft WindowState.

Syntax

DoCmd.Restore

Diese Methode verwendet keine Argumente.


 Run-Methode

Run-Methode

Mit der Methode Run können Sie eine bestimmte Microsoft Access- oder benutzerdefinierte Funktion oder Sub-Prozedur ausführen. Diese Methode ist nützlich, wenn Sie Microsoft Access über Automatisierung, früher OLE-Automatisierung genannt, aus einer anderen Anwendung heraus steuern. Sie können z.B. die Methode Run aus einem ActiveX-Element verwenden, um eine Sub-Prozedur auszuführen, die in einer Microsoft Access-Datenbank definiert ist.

Syntax

Anwendung.Run Prozedur[, Arg1, Arg2, ..., Arg30]

Die Methode Run hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Das Application-Objekt.
Prozedur | Der Name der Function- oder Sub-Prozedur, die ausgeführt werden soll. Wenn Sie eine Prozedur in einer anderen Datenbank aufrufen, verwenden Sie im Formular den Projektnamen und den Prozedurnamen, getrennt durch einen Punkt: "Projektname.Prozedurname" Wenn Sie Visual Basic Code ausführen, der die Methode Run in einer Bibliotheksdatenbank enthält, sucht Microsoft Access die Prozedur zuerst in der Bibliotheksdatenbank und danach in der aktuellen Datenbank.
Arg1, Arg2, ... | Optional. Die Argumente für die angegebene Sub-Prozedur oder Funktion. Sie können maximal 30 Argumente angeben.

Anmerkung

Sie können in jedem anderen ActiveX Element eine Referenz bzw. einen Verweis auf die Typbibliothek von Microsoft Access aktivieren und die in der Bibliothek definierten Objekte, Methoden und Eigenschaften in Ihrem Code verwenden. Allerdings können Sie keine Referenz auf eine einzelne Microsoft Access-Datenbank aus einer anderen Anwendung als Microsoft Access festlegen. Die Methode Run bietet eine Möglichkeit, aus einer anderen Anwendung heraus eine Prozedur aufzurufen, die Sie in einer Microsoft Access-Datenbank definiert haben.

Angenommen, Sie haben in einer Datenbank, deren Eigenschaft ProjektName auf RUNCODE gesetzt ist, eine Prozedur namens NeuesFormular definiert, die als Argument eine Zeichenfolge erwartet. Sie können NeuesFormular folgendermaßen aus Visual Basic heraus aufrufen.

Dim appAccess As New Access.Application
appAccess.OpenCurrentDatabase ("C:\Eigene Dateien\RunCode.mdb")
appAccess.Run "RunCode.NeuesFormular", "Eine Zeichenfolge"

Enthält eine andere Datenbank eine Prozedur gleichen Namens, müssen Sie das Argument Prozedur, wie im obigen Beispiel gezeigt, um den Namen der Datenbank erweitern, in der sich die entsprechende Prozedur befindet.

Sie können mit der Methode Run aus einer Datenbank heraus auch eine Prozedur aufrufen, die sich in einer referenzierten Microsoft Access-Datenbank befindet.


RunCommand-Methode

Die Methode RunCommand führt einen eingebauten Menü- oder Symbolleistenbefehl aus.

Syntax

[Objekt.]RunCommand Befehl

Die Methode RunCommand hat folgende Argumente.

Argument | Beschreibung
Objekt | Optional. Das Application-Objekt oder das DoCmd-Objekt.
Befehl | Eine eingebaute Konstante, die festlegt, welcher eingebaute Menü- oder Symbolleistenbefehl ausgeführt wird.

Anmerkung

Jedem Menü- und Symbolleistenbefehl ist in Microsoft Access eine Konstante zugeordnet, den Sie mit der Methode RunCommand verwenden können, um den Befehl aus Visual Basic auszuführen.

Eine Liste der zulässigen Konstanten für das Argument Befehl finden Sie unter RunCommand-Konstanten. Sie können sich diese Konstanten ebenfalls im Objektkatalog anschauen. Wählen Sie Access in der Drop-Down-Liste Projekt/Bibliothek, wählen Sie dann AcCommand in der Liste Klassen aus. Die Konstanten werden in der Liste Elemente von angezeigt.

Sie können die Methode RunCommand nicht dazu verwenden, einen Befehl in einem benutzerdefinierten Menü oder einer benutzerdefinierten Symbolleiste auszuführen. Sie können sie nur mit eingebauten Menüs und Symbolleisten verwenden.

Die Methode RunCommand ersetzt die Methode DoMenuItem des DoCmd-Objekts.


 RunMacro-Methode

RunMacro-Methode

Die Methode RunMacro führt die Aktion AusführenMakro in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.RunMacro Makroname[, Wiederholungen][, Wiederholbedingung]

Die Methode RunMacro verwendet die folgenden Argumente:

Argument | Beschreibung
Makroname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Makros der aktuellen Datenbank angibt.
 | Wenn Sie Visual Basic-Code, der die Methode RunMacro enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Makro mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Wiederholungen | Ein numerischer Ausdruck, der zu einer ganzen Zahl ausgewertet wird und angibt, wie oft das Makro ausgeführt wird.
Wiederholbedingung | Ein numerischer Ausdruck, der bei jeder Ausführung des Makros ausgewertet wird. Sobald der Ausdruck den Wert False (0) annimmt, wird die Ausführung des Makros angehalten.

Anmerkung

Sie können für das Argument Makroname auch Makrogruppenname.Makroname verwenden, um ein bestimmtes Makro einer Makrogruppe auszuführen.

Wenn Sie das Argument Wiederholbedingung angeben und das Argument Wiederholungen weglassen, geben Sie das Komma des Arguments Wiederholungen an. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 RunSQL-Methode

RunSQL-Methode

Die RunSQL-Methode führt die Aktion AusführenSQL in Visual Basic innerhalb von Aktionsabfragen aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Diese Methode betrifft nur Microsoft Access-Datenbanken (.mdb).

Syntax

DoCmd.RunSQL SQL-Anweisung[, TransaktionVerwenden]

Die RunSQL-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
SQL-Anweisung | Ein Zeichenfolgenausdruck, der eine gültige SQL-Anweisung für eine Aktionsabfrage oder eine Datendefinitionsabfrage angibt. Verwendet werden kann eine der folgenden Anweisungen: INSERT INTO, DELETE, SELECT...INTO, UPDATE, CREATE TABLE, ALTER TABLE, DROP TABLE, CREATE INDEX oder DROP INDEX . Fügen Sie eine IN-Klausel hinzu, wenn Sie auf eine andere Datenbank zugreifen möchten.
TransaktionVerwenden | Verwenden Sie True (-1), um diese Abfrage in eine Transaktion einzubinden, oder False (0), wenn Sie keine Transaktion durchführen möchten. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (True) verwendet.

Anmerkungen

Die maximale Länge des Arguments SQL-Anweisung beträgt 32.768 Zeichen (im Gegensatz zum Argument SQL-Anweisung der entsprechenden Aktion im Makrofenster, dessen maximale Läge 256 Zeichen beträgt).

Wenn Sie das Argument TransaktionVerwenden weglassen, brauchen Sie hinter dem Argument SQL-Anweisung kein Komma anzugeben.


 Save-Methode

Save-Methode

Die Save-Methode führt die Aktion Speichern in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.Save [Objekttyp, Objektname]

Die Save-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDefault (Standardwert) acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
 | Anmerkung Wenn ein Modul im Visual Basic-Editor (VBE) geschlossen wird, muss für das Argument Objekttyp der Wert acModule verwendet werden.
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt.

Anmerkungen

Wenn Sie die Argumente Objekttyp und Objektname nicht angeben, (der Standardwert acDefault wird für das Argument Objekttyp verwendet), speichert Microsoft Access das aktive Objekt. Wenn Sie das Argument Objekttyp weglassen, aber im Argument Objektname einen Namen eingeben, speichert Microsoft Access das aktive Objekt unter dem angegebenen Namen. Wenn Sie das Argument Objekttyp angeben, geben Sie im Argument Objektname den Namen eines vorhandenen Objekts an.

Wenn Sie das Argument Objekttyp weglassen, aber im Argument Objektname einen Namen eingeben, müssen Sie das Komma des Arguments Objekttyp angeben.

Anmerkung Sie können die Methode Save nicht verwenden, um die folgenden Objekte unter einem neuen Namen zu speichern:

  • Ein Formular in der Formularansicht oder Datenblattansicht.

  • Ein Bericht in der Seitenansicht.

  • Ein Modul.

  • Eine Datenzugriffsseite in der Seitenansicht.

  • Eine Serveransicht in der Datenblattansicht oder Seitenansicht.

  • Eine Tabelle in der Datenblattansicht oder Seitenansicht.

  • Eine Abfrage in derDatenblattansicht oder Seitenansicht.

  • Eine Gespeicherte Prozedur in der Datenblattansicht oder Seitenansicht.

Die Save-Methode speichert das angegebene oder aktive Objekt immer in der Datenbank, in der es erstellt wurde, unabhängig davon, ob sie in der aktuellen Datenbank oder in einer Bibliotheksdatenbank ausgeführt wird.


 Scale-Methode

Scale-Methode

Die Methode Scale definiert das Koordinatensystem für -Objekt ein Report-Objekt.

Syntax

Objekt.Scale[(x1, y1) - (x2, y2)]

Sie können diese Methode nur in einer Ereignisprozedur oder in einem Makro verwenden, die bzw. das in den Ereigniseigenschaften OnPrint oder OnFormat für einen Berichtsbereich oder in der Ereigniseigenschaft OnPage für einen Bericht angegeben ist.

Die Methode Scale hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Report-Objekt, dem das Koordinatensystem zugeordnet werden soll.
x1, y1 | Werte vom Datentyp Single für die horizontale und vertikale Koordinate, die die obere linke Ecke des Objekts definieren.
x2, y2 | Werte vom Datentyp Single für die horizontale und vertikale Koordinate, die die untere rechte Ecke des Objekts definieren.

Anmerkung

Mit der Methode Scale können Sie das Koordinatensystem auf jede beliebige Maßeinteilung einstellen. Wenn Sie die Methode Scale ohne Argumente verwenden, wird das Koordinatensystem auf Twips zurückgesetzt. Die Methode Scale wirkt sich auf das Koordinatensystem aus, das für die Methode Print und die Grafikmethoden für Berichte (Circle, Line und PSet) verwendet wird.


 SelectObject-Methode

SelectObject-Methode

Die Methode SelectObject führt die Aktion AuswählenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.SelectObject Objekttyp[, Objektname][, Im Datenbankfenster]

Die Methode SelectObject verwendet die folgenden Argumente.

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acDataAccessPage acDiagram acForm acMacro acModule acQuery acReport acServerView acStoredProcedure acTable
 | Anmerkung Die in der Liste Elemente automatisch auflisten für dieses Argument angezeigte Konstante acDefault ist für das Argument ungültig. Stattdessen müssen Sie eine der oben aufgelisteten Konstanten verwenden.
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt. Dieses Argument wird benötigt, außer wenn Sie für das Argument Im Datenbankfenster Wahr (-1) angeben. Wenn Sie für das Argument Im Datenbankfenster Wahr (-1) angeben und das Argument Objektname weglassen, wählt Microsoft Access diejenige Registerkarte im Datenbankfenster aus, die dem im Argument Objekttyp angegebenen Datenbankobjekt entspricht.
Im Datenbankfenster | Geben Sie Ja an, um das Objekt im Datenbankfenster zu markieren. Geben Sie Nein (0) an, um ein bereits geöffnetes Objekt zu markieren. Wenn Sie dieses Argument weglassen, wird der Standardwert (Nein) verwendet.

Anmerkung

Wenn Sie das Argument Im Datenbankfenster auf Ja einstellen und das Argument Objektname weglassen, geben Sie das Komma des Arguments Objektname ein. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 SendObject-Methode

SendObject-Methode

Die SendObject-Methode führt die Aktion SendenObjekt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.SendObject [Objekttyp][, Objektname][, Ausgabeformat][, An][, cc][, Bcc][, Betreff][, Nachricht][, Nachricht bearbeiten][, Vorlagedatei]

Die SendObject-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acSendDataAccessPage acSendForm acSendModule acSendNoObject (Standardwert) acSendQuery acSendReport acSendTable
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Objekts vom Typ Objekttyp angibt. Wenn Sie das aktive Objekt in die E-Mail-Nachricht aufnehmen möchten, geben Sie das Argument Objekttyp an, und lassen Sie dieses Argument weg. Wenn Sie weder Objekttyp noch Objektname angeben (der Standardwert acSendNoObject wird für das Argument Objekttyp verwendet), sendet Microsoft Access eine Meldung ohne Datenbankobjekt an die E-Mail-Anwendung.
 | Wenn Sie Visual Basic-Code, der die SendObject-Methode enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach dem Objekt mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ausgabeformat | Eine der folgenden eingebauten Konstanten:
 | acFormatDAP acFormatHTML acFormatRTF acFormatTXT acFormatXLS
 | Wenn Sie dieses Argument weglassen, fordert Microsoft Access Sie auf, eine Ausgabedatei anzugeben.
An | Ein Zeichenfolgenausdruck, der die Empfänger auflistet, deren Namen in die Zeile An der E-Mail-Nachricht aufgenommen werden sollen.
 | Wenn Sie mehrere Empfänger in den Argumenten An, Cc und Bcc eingeben, trennen Sie diese mit einem Semikolon (;) oder dem Listentrennzeichen, das in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen in der Registerkarte Zahlen festgelegt wurde. Wenn die E-Mail-Anwendung die Empfängernamen nicht zuordnen kann, wird die Nachricht nicht gesendet, und ein Fehler tritt auf.
 | Wenn Sie dieses Argument weglassen, fordert Microsoft Access Sie auf, die Empfänger anzugeben.
Cc | Ein Zeichenfolgenausdruck, der die Empfänger auflistet, deren Namen in die Zeile Cc der E-Mail-Nachricht aufgenommen werden sollen. Wenn Sie dieses Argument nicht angeben, ist die Zeile Cc der E-Mail-Nachricht leer.
Bcc | Ein Zeichenfolgenausdruck, der die Empfänger auflistet, deren Namen in die Zeile Bcc der E-Mail-Nachricht aufgenommen werden sollen. Wenn Sie dieses Argument nicht angeben, ist die Zeile Bcc der E-Mail-Nachricht leer.
Betreff | Ein Zeichenfolgenausdruck mit dem Text, der in die Zeile Betreff der E-Mail-Nachricht aufgenommen werden soll. Wenn Sie dieses Argument nicht angeben, ist die Zeile Betreff der E-Mail-Nachricht leer.
Nachricht | Ein Zeichenfolgenausdruck mit dem Text, der hinter dem Objekt zusätzlich in die Nachricht aufgenommen werden soll. Wenn Sie dieses Argument nicht angeben, ist nur das Objekt in der Nachricht enthalten.
Nachricht bearbeiten | Verwenden Sie True (-1), wenn die E-Mail-Anwendung sofort zusammen mit der geladenen Nachricht geöffnet werden soll, so dass die Nachricht noch bearbeitet werden kann. Verwenden Sie False (0), um die Nachricht ohne vorherige Bearbeitung zu senden. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (True) verwendet.
Vorlagedatei | Ein Zeichenfolgenausdruck, der den vollständigen Namen und Pfad der Datei angibt, die Sie als Vorlage für eine HTML-Datei verwenden möchten.

Anmerkungen

Module können nur im MS-DOS-Textformat ausgegeben werden. Wenn Sie also für das Argument Objekttyp den Wert acSendModule angeben, müssen Sie für das Argument Ausgabeformat den Wert acFormatTXT angeben.

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 SetFocus-Methode

SetFocus-Methode

Die Methode SetFocus setzt den Fokus auf das angegebene Formular, auf das angegebene Steuerelement auf dem aktiven Formular oder auf das angegebene Feld des aktiven Datenblatts.

Syntax

Objektname.SetFocus

Die Methode SetFocus hat folgendes Argument.

Argument | Beschreibung
Objektname | Ein Form-Objekt, das ein Formular darstellt, oder ein Control-Objekt, das ein Steuerelement des aktiven Formulars oder Datenblatts ist.

Anmerkung

Verwenden Sie die Methode SetFocus, wenn ein bestimmtes Feld oder Steuerelement den Fokus besitzen soll, damit alle Benutzereingaben an das betreffende Objekt geleitet werden.

Damit Sie die Eigenschaften eines Steuerelements lesen können, stellen Sie sicher, dass das Steuerelement den Fokus besitzt. Ein Textfeld z. B. muss zuerst den Fokus besitzen, bevor Sie seine Eigenschaft Text lesen können.

Andere Eigenschaften können nur eingestellt werden, wenn ein Steuerelement nicht den Fokus besitzt. Sie können z. B. die Eigenschaften Sichtbar oder Aktiviert eines Steuerelements nicht auf Nein (0) einstellen, wenn das Steuerelement den Fokus besitzt.

Mit der Methode SetFocus können Sie außerdem in einem Formular entsprechend bestimmten Bedingungen navigieren. Wählt der Benutzer z. B. für die erste Frage einer Fragengruppe in einem Formular, das einen Fragebogen darstellt, Nicht zutreffend aus, kann Visual Basic-Code die weiteren Fragen dieser Gruppe automatisch überspringen und den Fokus auf das erste Steuerelement in der nächsten Fragengruppe setzen.

Sie können den Fokus nur auf ein sichtbares Steuerelement oder Formular setzen. Ein Formular und seine Steuerelemente sind so lange ausgeblendet, bis das Ereignis Load des Formulars abgeschlossen ist. Dies hat folgende Konsequenz: Wenn Sie die Methode SetFocus in der Load-Ereignisprozedur eines Formulars verwenden, um den Fokus auf dieses Formular zu setzen, verwenden Sie vor der Methode SetFocus die Methode Repaint.

Sie können den Fokus nicht auf ein Steuerelement setzen, dessen Eigenschaft Enabled auf False eingestellt ist. Deshalb stellen Sie zuerst die Eigenschaft Enabled eines Steuerelements auf True (-1) ein, bevor Sie den Fokus auf dieses Steuerelement setzen können. Allerdings können Sie den Fokus auf ein Steuerelement setzen, dessen Eigenschaft Locked auf den Wert True eingestellt ist.

Wenn ein Formular Steuerelemente enthält, deren Eigenschaft Enabled auf True eingestellt ist, können Sie den Fokus nicht auf das Formular selbst setzen, sondern nur auf die Steuerelemente des Formulars. Wenn Sie bei dieser Ausgangslage versuchen, den Fokus mit SetFocus auf ein Formular zu setzen, erhält dasjenige Steuerelement des Formulars den Fokus, das den Fokus zuletzt besaß.

Tipp Mit der Methode SetFocus können Sie den Fokus auch auf ein Unterformular setzen, das eine Art Steuerelement ist. Außerdem können Sie den Fokus auf ein Steuerelement in einem Unterformular setzen, indem Sie ihn mit der Methode SetFocus zunächst auf das Unterformular und anschließend auf das Steuerelement im Unterformular setzen.


 SetMenuItem-Methode

SetMenuItem-Methode

Die Methode SetMenuItem führt die Aktion SetzenMenüelement in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Die Methode SetMenuItem betrifft nur benutzerdefinierte Menüleisten und globale Menüleisten, die mit Menüleistenmakros erstellt wurden. Die Methode SetMenuItem ist in dieser Microsoft Access-Version nur wegen der Kompatibilität mit Versionen vor Microsoft Access 97 vorhanden. Sie funktioniert nicht mit der neuen Befehlsleisten-Funktionalität. In Microsoft Access 2000 müssen Sie die Eigenschaften und Methoden des Auflistungsobjekts CommandBars verwenden, um Menüelemente der obersten Ebene zu aktivieren oder zu deaktivieren.

Syntax

DoCmd.SetMenuItem Menüindex[, Befehlsindex][, Unterbefehlsindex][, Kennzeichen]

Die Methode SetMenuItem verwendet die folgenden Argumente:

Argument | Beschreibung
Menüindex | Eine ganze Zahl, die den gültigen Index eines Menüs in der benutzerdefinierten oder globalen Menüleiste des aktiven Fensters angibt, wobei das erste Menü den Index 0 hat. Die Menüleiste ist im Menüleistenmakro für die benutzerdefinierte bzw. globale Menüleiste definiert.
 | Wenn Sie ein Menü mit diesem Argument auswählen und die Argumente Befehlsindex und Unterbefehlsindex nicht angeben (oder auf -1 setzen), können Sie den Menünamen aktivieren oder deaktivieren. Sie können einen Menünamen jedoch nicht mit einem Häkchen kennzeichnen, da Microsoft Access für Menünamen die Einstellungen acMenuCheck und acMenuUncheck des Arguments Kennzeichen ignoriert.
Befehlsindex | Eine ganze Zahl, die den gültigen Index eines Befehls in dem Menü angibt, das im Argument Menüindex angegeben ist, wobei der erste Befehl den Index 0 hat. Der Index verweist auf den Eintrag der Makrogruppe, in der das ausgewählte Menü für die benutzerdefinierte oder globale Menüleiste des aktiven Fensters definiert wird.
Unterbefehlsindex | Eine ganze Zahl, beginnend bei 0, die den gültigen Index eines Unterbefehls in dem Untermenü angibt, das mit dem Argument Befehlsindex ausgewählt wurde, wobei der erste Unterbefehl den Index 0 hat. Der Index verweist auf den Eintrag der Makrogruppe, in der das ausgewählte Untermenü für die benutzerdefinierte oder globale Menüleiste des aktiven Fensters definiert ist.
Kennzeichen | Eine der folgenden eingebauten Konstanten:
 | acMenuCheck acMenuGray acMenuUncheck acMenuUngray (Standardwert)
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acMenuUngray) verwendet.

Anmerkung

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.


 SetWarnings-Methode

SetWarnings-Methode

Die Methode SetWarnings führt die Aktion Warnmeldungen in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.SetWarnings Warnmeldungen an

Die Methode SetWarnings verwendet das folgende Argument:

Argument | Beschreibung
Warnmeldungen an | Verwenden Sie True (-1), um die Anzeige von Systemmeldungen einzuschalten, und False (0), um sie auszuschalten.

Anmerkung

Wenn Sie die Anzeige von Systemmeldungen in Visual Basic ausschalten, müssen Sie sie wieder einschalten. Andernfalls bleibt sie ausgeschaltet, selbst wenn der Benutzer STRG+UNTBR drückt oder Visual Basic auf einen Haltepunkt stößt. Sie können ein Makro erstellen, das die Anzeige von Systemmeldungen einschaltet, und das Makro dann einer Tastenkombination oder einem benutzerdefinierten Menübefehl zuweisen. Sie können dann die Anzeige von Systemmeldungen mit dieser Tastenkombination oder dem Menübefehl wieder einschalten, wenn sie in Visual Basic ausgeschaltet wurde.


ShowAllRecords-Methode

Die Methode ShowAllRecords führt die Aktion AnzeigenAlleDatensätze in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Diese Methode betrifft nur Tabellen, Abfragen und Formulare in einer Microsoft-Datenbank (.mdb).

Syntax

DoCmd.ShowAllRecords

Diese Methode verwendet keine Argumente.


 ShowToolbar-Methode

ShowToolbar-Methode

Die Methode ShowToolbar führt die Aktion EinblendenSymbolleiste in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Anmerkung Die Methode ShowToolbar betrifft nur Symbolleisten, keine Menüleisten oder Kontextmenüs.

Syntax

DoCmd.ShowToolbar Symbolleistenname[, Einblenden]

Die Methode ShowToolbar verwendet die folgenden Argumente:

Argument | Beschreibung
Symbolleistenname | Ein Zeichenfolgenausdruck, der den gültigen Namen einer in Microsoft Access eingebauten Symbolleiste oder einer bereits erstellten benutzerdefinierten Symbolisierte angibt.
 | Wenn Sie Visual Basic-Code, der die Methode ShowToolbar enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access nach der Symbolleiste mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Einblenden | Eine der folgenden eingebauten Konstanten:
 | acToolbarNo acToolbarWhereApprop acToolbarYes (Standardwert)
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acToolbarYes) verwendet.

Anmerkung

Wenn Sie das Argument Einblenden weglassen, geben Sie nach dem Argument Symbolleistenname kein Komma ein.


 SizeToFit-Methode

SizeToFit-Methode

Mit der Methode SizeToFit können Sie die Größe eines Steuerelements an den Text oder das Symbol anpassen, den oder das es enthält. Sie können z. B. die Methode SizeToFit auf eine Befehlsschaltfläche anwenden, die zum Anzeigen des gesamten in ihrer Eigenschaft Beschriftung angegebenen Textes zu schmal ist.

Syntax

Steuerelement.SizeToFit

Die Methode SizeToFit hat das folgende Argument.

Argument | Beschreibung
Steuerelement | Ein Steuerelement, das einen Text oder ein Bild anzeigt. Dazu gehören folgende Steuerelemente: Bezeichnungsfeld, Umschaltfläche, Befehlsschaltfläche, Bild, Objektfeld und Unterformular/-bericht.

Anmerkung

Die Anwendung der Methode SizeToFit entspricht der Auswahl eines Steuerelements eines Formulars oder Berichts, dem anschließenden Zeigen auf Größe im Menü Format und dem Klicken auf An Textgröße. Sie können die Methode SizeToFit nur in der Formularentwurfsansicht oder in der Berichtsentwurfsansicht auf Steuerelemente anwenden.

Die Methode SizeToFit vergrößert oder verkleinert ein Steuerelement, je nach der Größe des darin enthaltenen Textes oder Bildes.

Sie können die Methode SizeToFit in Verbindung mit der Methode CreateControl verwenden, um die Größe neuer Steuerelemente zu ändern, die Sie in Code erstellt haben.

Anmerkung Nicht alle Steuerelemente, die Text oder ein Bild enthalten, können mit der Methode SizeToFit vergrößert oder verkleinert werden. Einige Steuerelemente sind an Daten gebunden, deren Größe sich von einem Datensatz zum nächsten ändern kann. Zu diesen Steuerelementen gehören folgende: Textfeld, Listenfeld, Kombinationsfeld und Gebundenes Objektfeld. Die Methode SizeToFit betrifft keine Steuerelemente in Datenzugriffsseiten.


 SysCmd-Methode

SysCmd-Methode

Mit der Methode SysCmd können Sie eine der folgenden Operationen durchführen:

  • Anzeigen eines Statusanzeigers oder optional eines bestimmten Textes in der Statusleiste.

  • Zurückgeben von Informationen über Microsoft Access und seine zugehörigen Dateien.

  • Zurückgeben des Zustands eines angegebenen Datenbankobjektes, um mitzuteilen, ob das Objekt geöffnet ist, ob es sich um ein neues Objekt handelt oder ob es geändert, aber nicht gespeichert wurde.

Wenn Sie z. B. einen Assistenten entwickeln, der ein neues Formular erstellt, können Sie mit Hilfe der Methode SysCmd einen Statusanzeiger anzeigen, der den Fortschritt des Assistenten beim Erstellen des Formulars angibt.

Syntax

Rückgabewert = SysCmd(Aktion[, Text][, Wert])

Objektzustand = SysCmd(Aktion[, Objekttyp][, Objektname])

Die Methode SysCmd hat die folgenden Argumente.

Argument | Beschreibung
Aktion | Eine der folgenden eingebauten Konstanten, die die Art der durchzuführenden Aktion angeben.
 | Die nachfolgend aufgeführten Konstanten betreffen einen Statusanzeiger. SysCmd gibt den Wert Null zurück, wenn diese Aktionen erfolgreich sind. Andernfalls löst Microsoft Access einen Laufzeitfehler aus.
 | acSysCmdInitMeter | Initialisiert den Statusanzeiger. Sie müssen die Argumente Text und Wert angeben, wenn Sie diese Aktion verwenden.
 | acSysCmdUpdateMeter | Aktualisiert den Statusanzeiger mit dem angegebenen Wert. Sie müssen das Argument Text angeben, wenn Sie diese Aktion verwenden.
 | acSysCmdRemoveMeter | Entfernt den Statusanzeiger.
 | acSysCmdSetStatus | Stellt den Text in der Statusleiste auf das Argument Text ein.
 | acSysCmdClearStatus | Setzt den Text in der Statusleiste zurück.
 | Die nachfolgend aufgeführten Konstanten geben Informationen über Microsoft Access zurück.
 | acSysCmdRuntime | Gibt den Wert True (-1) zurück, wenn eine Laufzeitversion von Microsoft Access ausgeführt wird.
 | acSysCmdAccessVer | Gibt die Versionsnummer von Microsoft Access zurück.
 | acSysCmdIniFile | Gibt den Namen der von Microsoft Access verwendeten .INI-Datei zurück.
 | acSysCmdAccessDir | Gibt den Namen des Verzeichnisses zurück, in dem sich MSACCESS.EXE befindet.
 | acSysCmdProfile | Gibt die Einstellung von /profile zurück, die der Benutzer angegeben hat, wenn er Microsoft Access über die Befehlszeile gestartet hat.
 | acSysCmdGetWorkgroupFile | Gibt den Pfad zur Arbeitsgruppen-Datei (SYSTEM.MDW) zurück.
 | acSysCmdClearHelpTopic |
 | Die folgende Konstante gibt Informationen über den Zustand eines Datenbankobjekts zurück.
 | acSysCmdGetObjectState | Gibt den Zustand des angegebenen Datenbankobjekts zurück. Sie müssen die Argumente Objekttyp und Objektname angeben, wenn Sie für Aktion diesen Wert verwenden.
Text | Ein Zeichenfolgenausdruck, der den Text angibt, der linksbündig in der Statusleiste angezeigt wird. Dieses Argument ist erforderlich, wenn das Argument Aktion auf acSysCmdInitMeter, acSysCmdUpdateMeter oder acSysCmdSetStatus eingestellt ist. Für andere Werte des Argumentes Aktion ist dieses Argument nicht zulässig.
Wert | Ein numerischer Ausdruck, der die Anzeige des Statusanzeigers steuert. Dieses Argument ist erforderlich, wenn das Argument Aktion auf acSysCmdInitMeter eingestellt ist. Für andere Werte des Argumentes Aktion ist dieses Argument nicht zulässig.
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acTable acQuery acForm acReport acMacro acModule acDataAccessPage acDefault acDiagram acServerView acStoreProcedure
 | Dieses Argument ist erforderlich, wenn das Argument Aktion auf acSysCmdGetObjectState eingestellt ist. Für andere Werte des Argumentes Aktion ist dieses Argument nicht zulässig.
Objektname | Ein Zeichenfolgenausdruck, der den gültigen Namen eines Datenbankobjekts angibt, das den Typ hat, der durch das Argument Objekttyp angegeben ist. Dieses Argument ist erforderlich, wenn das Argument Aktion auf acSysCmdGetObjectState eingestellt ist. Für andere Werte des Argumentes Aktion ist dieses Argument nicht zulässig.

Anmerkung

Indem Sie die Methode SysCmd mit den verschiedenen Statusanzeiger-Aktionen aufrufen, können Sie in der Statusleiste einen Statusanzeiger für eine Operation anzeigen, für die die Dauer oder die Anzahl der durchzuführenden Schritte bekannt ist, und den Statusanzeiger aktualisieren, um den Fortschritt der Operation mitzuteilen.

Damit ein Statusanzeiger in der Statusleiste angezeigt wird, müssen Sie zunächst die Methode SysCmd mit der Aktion acSysCmdInitMeter und den Argumenten Text und Wert aufrufen. Ist das Argument Aktion auf acSysCmdInitMeter eingestellt, gibt das Argument Wert den Maximalwert (gleich 100 Prozent) des Statusanzeigers an.

Sie aktualisieren den Statusanzeiger, um den Fortschritt der Operation anzuzeigen, indem Sie die Methode SysCmd mit der Aktion acSysCmdUpdateMeter und dem Argument Wert aufrufen. Hat das Argument Aktion den Wert acSysCmdUpdateMeter, verwendet die Methode SysCmd das Argument Wert, um den im Statusanzeiger angezeigten Prozentsatz zu berechnen. Wenn Sie z. B. den Maximalwert auf 200 einstellen und anschließend den Statusanzeiger mit dem Wert 100 aktualisieren, wird der Statusanzeiger bis zur Mitte gefüllt.

Sie können auch den in der Statusleiste angezeigten Text ändern, indem Sie die Methode SysCmd mit der Aktion acSysCmdSetStatus und dem Argument Text aufrufen. Während eines Sortiervorgangs könnte der Text z. B. in "Sortiervorgang läuft..." geändert werden. Sobald der Sortiervorgang abgeschlossen ist, könnten Sie die Statusleiste zurücksetzen, indem Sie den Text entfernen. Das Argument Text kann ungefähr 80 Zeichen enthalten. Da der Text in der Statusleiste in einer Proportionalschriftart angezeigt wird, ist die tatsächliche Anzahl der angezeigten Zeichen von der Gesamtbreite aller durch Text angegebenen Zeichen abhängig.

Wenn Sie den in der Statusleiste angezeigten Text verbreitern, wird der Statusanzeiger entsprechend gekürzt. Ist der Text länger als die Statusleiste und das Argument Aktion auf acSysCmdInitMeter eingestellt, ignoriert die Methode SysCmd den Text, so dass in der Statusleiste nichts angezeigt wird. Ist der Text länger als die Statusleiste und das Argument Aktion auf acSysCmdSetStatus eingestellt, kürzt die Methode SysCmd den Text so, dass er in die Statusleiste passt.

Sie können den Statusleistentext nicht auf eine leere Zeichenfolge (" ") einstellen. Zum Löschen des vorhandenen Textes aus der Statusleiste müssen Sie das Argument Text auf ein Leerzeichen einstellen. Die folgenden Beispiele zeigen, wie Text aus der Statusleiste gelöscht werden kann:

varRückgabe = SysCmd(acSysCmdInitMeter, " ", 100)
varRückgabe = SysCmd(acSysCmdSetStatus, " ")

Wird der Statusanzeiger bereits angezeigt, wenn Sie den Text einstellen, indem Sie die Methode SysCmd mit der Aktion acSysCmdSetStatus aufrufen, löscht die Methode SysCmd den Statusanzeiger automatisch.

Rufen Sie die Methode SysCmd mit anderen Aktionen auf, um Systeminformationen über Microsoft Access zu erhalten, z. B. welche Version von Microsoft Access ausgeführt wird, ob es sich um eine Laufzeitversion handelt, wo sich die ausführbare Datei von Microsoft Access befindet, welche Einstellung für das Argument /profile in der Befehlszeile angegeben wurde und wie der Name der .INI-Datei lautet, die zu Microsoft Access gehört.

Anmerkung Sowohl die allgemeinen als auch die benutzerdefinierten Einstellungen von Microsoft Access werden jetzt in der Windows-Registrierung gespeichert, so dass Sie wahrscheinlich keine .INI-Datei für Ihre Microsoft Access-Anwendung benötigen. Die Aktion acSysCmdIniFile gibt es nur aus Gründen der Kompatibilität mit früheren Versionen von Microsoft Access.

Rufen Sie die Methode SysCmd mit der Aktion acSysCmdGetObjectState und den Argumenten Objekttyp und Objektname auf, um den Zustand eines angegebenen Datenbankobjekts zurückzugeben. Es gibt vier mögliche Zustände für ein Objekt: nicht geöffnet bzw. nicht vorhanden, geöffnet, neu, geändert, aber noch nicht gespeichert.

Wenn Sie z. B. einen Assistenten entwickeln, der ein neues Feld in eine Tabelle einfügt, müssen Sie ermitteln, ob die Struktur der Tabelle geändert, aber noch nicht gespeichert wurde, damit Sie die Tabelle speichern können, bevor Sie ihre Struktur verändern. Sie ermitteln den Zustand der Tabelle, indem Sie den von der Methode SysCmd zurückgegebenen Wert auswerten.

Wird die Methode SysCmd mit der Aktion acSysCmdGetObjectState aufgerufen, kann sie eine beliebige Kombination der folgenden Konstanten zurückgeben.

Konstante | Zustand des Datenbankobjekts | Wert
acObjStateOpen | Geöffnet | 1
acObjStateDirty | Geändert, aber nicht gespeichert | 2
acObjStateNew | Neu | 4

Anmerkung Wenn das Objekt, auf das durch das Argument Objektname verwiesen wird, nicht geöffnet oder nicht vorhanden ist, gibt die Methode SysCmd den Wert 0 zurück.


 TextHeight-Methode

TextHeight-Methode

Die Methode TextHeight gibt die Höhe einer Textzeichenfolge zurück, wie diese in der aktuellen Schriftart des Report-Objekts gedruckt wird.

Syntax

Objekt.TextHeight(Zeichenfolgenausdruck)

Die Methode TextHeight hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Report-Objekt, das die Schriftart und die Punktgröße festlegt.
Zeichenfolgenausdruck | Die Textzeichenfolge, deren Texthöhe bestimmt wird.

Anmerkung

Mit der Methode TextHeight können Sie die Gesamthöhe ermitteln, die eine Textzeichenfolge in der aktuellen Schriftart einnimmt, wenn der Bericht formatiert und gedruckt wird. Eine Textzeichenfolge, die z. B. in Arial mit 9 Punkt formatiert ist, benötigt eine andere Höhe als eine in Courier mit 12 Punkt formatierte Textzeichenfolge. Damit Sie die aktuelle Schriftart und den Schriftgrad für den Text in einem Bericht ermitteln können, überprüfen Sie die Einstellungen der Eigenschaften Schriftart und Schriftgrad für den Bericht.

Der von der Methode TextHeight zurückgegebene Wert wird in der Maßeinheit des Koordinatensystems ausgedrückt, das für den Bericht gültig ist und mit der Methode Scale festgelegt wurde. Sie können mit der Eigenschaft ScaleMode das für den Bericht verwendete Koordinatensystem ermitteln.

Wenn das Argument Zeichenfolgenausdruck eingebettete Wagenrücklaufzeichen enthält, gibt die Methode TextHeight die kumulierte Höhe der Zeilen zurück, einschließlich des normalen Abstands über und unter jeder Zeile. Sie können den von der Methode TextHeight zurückgegebenen Wert verwenden, um den erforderlichen Platz zu berechnen, wenn mehrere Textzeilen innerhalb eines Berichts zu positionieren sind.


 TextWidth-Methode

TextWidth-Methode

Die Methode TextWidth gibt die Breite einer Textzeichenfolge zurück, wie diese in der aktuellen Schriftart des Report-Objekts gedruckt wird.

Syntax

Objekt.TextWidth(Zeichenfolgenausdruck)

Die Methode TextWidth hat folgende Argumente.

Argument | Beschreibung
Objekt | Das Report-Objekt, das die Schriftart und die Punktgröße festlegt.
Zeichenfolgenausdruck | Die Textzeichenfolge, deren Textbreite bestimmt wird.

Anmerkung

Mit der Methode TextWidth können Sie die horizontale Ausdehnung (Breite) ermitteln, die eine Textzeichenfolge in der aktuellen Schriftart einnimmt, wenn der Bericht formatiert und gedruckt wird. Eine Textzeichenfolge, die z. B. in Arial mit 9 Punkt formatiert ist, benötigt eine andere Breite als eine in Courier mit 12 Punkt formatierte Textzeichenfolge. Damit Sie die aktuelle Schriftart und den Schriftgrad für den Text im Bericht ermitteln können, überprüfen Sie die Einstellungen der Eigenschaften Schriftart und Schriftgrad des Berichts.

Der von der Methode TextWidth zurückgegebene Wert wird in der Maßeinheit des Koordinatensystems ausgedrückt, das für den Bericht gültig ist und mit der Methode Scale festgelegt wurde. Sie können mit der Eigenschaft ScaleMode das für den Bericht verwendete Koordinatensystem ermitteln.

Wenn das Argument Zeichenfolgenausdruck eingebettete Wagenrücklaufzeichen enthält, gibt die Methode TextWidth die Länge der längsten Zeile zurück, gemessen vom Zeilenanfang bis zum Wagenrücklaufzeichen. Sie können den von der Methode TextWidth zurückgegebenen Wert verwenden, um den erforderlichen Platz zu berechnen, wenn mehrere Textzeilen innerhalb eines Berichts zu positionieren sind.


 TransferDatabase-Methode

TransferDatabase-Methode

Die Methode TransferDatabase führt die Aktion TransferDatenbank in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.TransferDatabase [Transfertyp], Datenbankformat, Datenbankname[, Objekttyp], Herkunft, Ziel[, Nur Struktur][, Anmeldename speichern]

Die Methode TransferDatabase verwendet die folgenden Argumente:

Argument | Beschreibung
Transfertyp | Eine der folgenden eingebauten Konstanten:
 | acExport acImport (Standardwert) acLink
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acImport) verwendet.
 | Anmerkung Der Transfertyp acLink wird für Microsoft Access-Projekte (.adp) nicht unterstützt.
Datenbankformat | Ein Zeichenfolgenausdruck, der den Namen eines Datenbankformats angibt, das zum Importieren, Exportieren oder Verknüpfen von Daten verwendet werden kann. Microsoft Access (Standardwert) Jet 2.x Jet 3.x dBase III dBase IV dBase 5 Paradox 3.x Paradox 4.x Paradox 5.x Paradox 7.x ODBC (-Datenbanken)
 | Die Datenbankformate werden im Makrofenster in der Liste des Aktionsarguments Datenbankformat der Aktion TransferDatenbank angezeigt.
Datenbankname | Ein Zeichenfolgenausdruck, der den vollständigen Namen und Pfad der Datenbank angibt, die zum Importieren, Exportieren oder Einbinden (Verknüpfen) von Daten verwendet werden soll.
Objekttyp | Eine der folgenden eingebauten Konstanten:
 | acTable (Standardwert) acQuery acForm acReport acMacro acModule acDataAccessPage acServerView acDiagram acStoredProcedure
 | Dieses Argument gibt den Typ des Objekts an, dessen Daten importiert, exportiert oder eingebunden (verknüpft) werden sollen. Sie können für dieses Argument nur dann einen anderen Wert als acTable angeben, wenn Sie Daten zwischen zwei Microsoft Access-Datenbanken im- oder exportieren. Wenn Sie das Ergebnis einer Auswahlabfrage in Microsoft Access in ein anderes Datenbankformat exportieren, geben Sie acTable an.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acTable) verwendet.
 | Anmerkung Die Konstante acDefault, die in der Liste Elemente automatisch auflisten für dieses Argument angezeigt wird, ist für dieses Argument ungültig. Wählen Sie eine der oben aufgeführten Konstanten aus.
Herkunft | Ein Zeichenfolgenausdruck, der den Namen des Objekts angibt, dessen Daten importiert, exportiert oder eingebunden werden sollen.
Ziel | Ein Zeichenfolgenausdruck, der den Namen des importierten, exportierten oder eingebundenen (verknüpften) Objekts in der Zieldatenbank angibt.
Nur Struktur | Verwenden Sie True (-1), um nur die Struktur einer Datenbanktabelle zu importieren oder zu exportieren. Verwenden Sie False (0), um die Struktur der Tabelle sowie deren Daten zu importieren oder zu exportieren.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
Anmeldename speichern | Verwenden Sie True, um in der Verbindungszeichenfolge einer eingebundenen Tabelle den Anmeldenamen (ID) und das Kennwort für eine ODBC-Datenbank zu speichern, zu der die Tabelle gehört. Sie brauchen sich dann nicht jedesmal anzumelden, wenn Sie die Tabelle öffnen. Verwenden Sie False, wenn Sie den Anmeldenamen und das Kennwort nicht speichern möchten.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
 | Dieses Argument ist nur in Visual Basic verfügbar.

Anmerkung

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.

Der Administrator einer ODBC-Datenbank kann die Funktion des Arguments Anmeldename speichern deaktivieren, so dass alle Benutzer beim Herstellen einer Verbindung zu einer ODBC-Datenbank ihren Anmeldenamen und ihr Kennwort jedesmal neu eingeben.

Anmerkung Sie können auch ActiveX-Datenobjekte (ADO) verwenden, um eine Verknüpfung mit Hilfe der ActiveConnection-Eigenschaft für das Recordset-Objekt zu erstellen.


 TransferSpreadsheet-Methode

TransferSpreadsheet-Methode

Die TransferSpreadsheet-Methode führt die Aktion TransferArbeitsblatt in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.TransferSpreadsheet [Transfertyp][, Spreadsheettyp], Tabellenname, Dateiname[, Besitzt Feldnamen][, Bereich]

Die TransferSpreadsheet-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Transfertyp | Eine der folgenden eingebauten Konstanten:
 | acImport (Standardwert) acExport acLink
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acImport) verwendet.
Spreadsheettyp | Eine der folgenden eingebauten Konstanten oder deren numerische Entsprechung:
 | 0 acSpreadsheetTypeExcel3 (Standardwert) 6 acSpreadsheetTypeExcel4 5 acSpreadsheetTypeExcel5 5 acSpreadsheetTypeExcel7 8 acSpreadsheetTypeExcel8 8 acSpreadsheetTypeExcel9 2 acSpreadsheetTypeLotusWK1 3 acSpreadsheetTypeLotusWK3 7 acSpreadsheetTypeLotusWK4 4 acSpreadsheetTypeLotusWJ2 — nur japanische Version
 | Anmerkung Sie können mit Daten in Lotus 1-2-3-Tabellenkalkulationsdateien verknüpfen, jedoch sind diese Daten in Microsoft Access schreibgeschützt. Sie können Daten aus Lotus .WK4-Dateien importieren und verknüpfen (schreibgeschützt), aber keine Microsoft Access-Daten in dieses Format exportieren. Darüber hinaus unterstützt Microsoft Access nicht mehr das Importieren, Exportieren und Einbinden (Verknüpfen) von Daten aus Tabellen von Lotus (.WKS) und Microsoft Excel, Version 2.0.
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert acSpreadsheetTypeExcel8 verwendet.
Tabellenname | Ein Zeichenfolgenausdruck, der den Namen einer Microsoft Access-Tabelle zum Importieren, Exportieren oder Einbinden (Verknüpfen) von Kalkulationsdaten angibt, oder die Microsoft Access-Auswahlabfrage, deren Ergebnisse in eine Kalkulationstabelle exportiert werden sollen.
Dateiname | Ein Zeichenfolgenausdruck, der den Dateinamen und Pfad der Kalkulationstabelle angibt, die zum Importieren, Exportieren oder Einbinden (Verknüpfen) von Daten verwendet werden soll.
Besitzt Feldnamen | Verwenden Sie True (-1), um die erste Zeile der Kalkulationstabelle beim Importieren, Exportieren oder Einbinden (Verknüpfen) als Feldnamen zu verwenden. Verwenden Sie False (0), wenn die erste Zeile als normale Datenzeile gelten soll. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
 | Wenn Sie Daten aus einer Microsoft Access-Tabelle oder Microsoft Access-Auswahlabfrage in ein Spreadsheet exportieren, werden die Feldnamen in der ersten Zeile des Spreadsheets eingefügt, unabhängig vom Wert dieses Arguments.
Bereich | Ein Zeichenfolgenausdruck, der einen gültigen Zellenbereich oder den Namen eines Bereichs im Spreadsheet angibt. Dieses Argument betrifft nur das Importieren. Geben Sie dieses Argument nicht an, wenn Sie das gesamte Spreadsheet importieren möchten.
 | Wenn Sie in ein Spreadsheet exportieren, lassen Sie dieses Argument weg. Wenn Sie einen Bereich eingeben, wird das Exportieren fehlschlagen.

Anmerkungen

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.

Anmerkung Sie können eine Verknüpfung auch unter Verwendung von ActiveX-Datenobjekten (ADO-Objekten) erstellen. Sie verwenden dazu die ActiveConnection-Eigenschaft des RecordSet-Objekts.


 TransferText-Methode

TransferText-Methode

Die TransferText-Methode führt die Aktion TransferText in Visual Basic aus. Weitere Informationen zu dieser Aktion und ihren Argumenten finden Sie unter dem Thema zur jeweiligen Aktion.

Syntax

DoCmd.TransferText [Transfertyp][, Spezifikationsname], Tabellenname, Dateiname[, Besitzt Feldnamen][, HTML-Tabellenname][, Codepage]

Die TransferText-Methode verwendet die folgenden Argumente:

Argument | Beschreibung
Transfertyp | Eine der folgenden eingebauten Konstanten:
 | acExportDelim acExportFixed acExportHTML acExportMerge acImportDelim (Voreinstellung) acImportFixed acImportHTML acLinkDelim acLinkFixed acLinkHTML
 | Wenn Sie dieses Argument nicht angeben, wird der Standardwert (acImportDelim) verwendet.
 | Anmerkungen Sie können Verknüpfungen zu Daten in einer Textdatei oder HTML-Datei herstellen, jedoch sind diese Daten in Microsoft Access schreibgeschützt. Nur die Transfertypen acImportDelim, acImportFixed, acExportDelim, acExportFixed oder acExportMerge werden von einem Microsoft Access-Projekt (.adp). unterstützt
Spezifikationsname | Ein Zeichenfolgenausdruck, der den Namen einer Import- oder Exportspezifikation angibt, die Sie in der aktuellen Datenbank erstellt und gespeichert haben.
 | Bei einer Textdatei mit fester Zeilenlänge müssen Sie entweder ein Argument angeben oder eine Schemadatei (Schema.ini) verwenden, die in demselben Ordner wie die importierte, verknüpfte oder exportierte Textdatei gespeichert sein muss. Zur Erstellung einer Schemadatei können Sie den Import/Export-Assistenten für Text verwenden. Bei Textdateien mit Trennzeichen und Microsoft Word-Serienbriefdateien können Sie dieses Argument weglassen, um so die Standardeinstellungen für das Importieren und Exportieren auszuwählen.
Tabellenname | Ein Zeichenfolgenausdruck, der den Namen einer Microsoft Access-Tabelle zum Importieren, Exportieren oder Einbinden (Verknüpfen) von Textdaten angibt, oder die Microsoft Access-Auswahlabfrage, deren Ergebnisse in eine Textdatei exportiert werden sollen.
Dateiname | Ein Zeichenfolgenausdruck, der den vollständigen Namen und den Pfad der Textdatei angibt, die zum Importieren, Exportieren oder Einbinden (Verknüpfen) von Daten verwendet werden soll.
Besitzt Feldnamen | Verwenden Sie True (-1), um die erste Zeile der Kalkulationstabelle beim Importieren, Exportieren oder Einbinden (Verknüpfen) als Feldnamen zu verwenden. Verwenden Sie False (0), wenn die erste Zeile als normale Datenzeile gelten soll. Wenn Sie dieses Argument nicht angeben, wird der Standardwert (False) verwendet.
 | Dieses Argument wird bei Word für Windows-Serienbriefdateien ignoriert, da diese in der ersten Zeile immer Feldnamen enthalten müssen.
HTML-Tabellenname | Ein Zeichenfolgenausdruck, der den Namen der Tabelle oder Liste in der HTML-Datei angibt, die Sie importieren oder einbinden (verknüpfen) möchten. Dieses Argument wird nur dann beachtet, wenn das Argument Transfertyp auf acImportHTML oder acLinkHTML eingestellt ist. Wenn Sie dieses Argument weglassen, wird die erste Tabelle oder Liste in der HTML-Datei importiert oder verknüpft.
 | Der Tabellen- oder Listenname in der HTML-Datei wird durch den in der Marke <CAPTION> angegebenen Text bestimmt, falls dieser vorhanden ist. Andernfalls wird der Name durch den Text bestimmt, der in der Marke <TITLE> angegeben ist. Wenn mehrere Tabellen oder Listen denselben Namen besitzen, unterscheidet sie Microsoft Access durch Anhängen einer Zahl an den Tabellen- oder Listennamen, wie z.B. Personal1 und Personal2.
Codepage | Ein Wert des Typs Long, der den Zeichensatz der Codepage angibt.

Anmerkung

Sie können optionale Argumente in der Syntax weglassen, müssen jedoch in jedem Fall das zum Argument gehörende Komma angeben. Wenn Sie Argumente am Anweisungsende weglassen, entfällt auch das Komma nach dem letzten angegebenen Argument.

Anmerkung Sie können auch ActiveX-Datenobjekte (ADO-Objekte) verwenden, um eine Verknüpfung zu erstellen. Dies lässt sich mit Hilfe der ActiveConnection-Eigenschaft des Recordset-Objekts durchführen.


 Undo-Methode

Undo-Methode

Mit der Methode Undo können Sie ein Steuerelement oder Formular zurücksetzen, wenn sich dessen Wert geändert hat. Sie können die Methode Undo z. B. verwenden, um eine Änderung eines Datensatzes aufzuheben, der einen ungültigen Dateneintrag enthält.

Syntax

Objekt.Undo

Die Methode Undo hat folgendes Argument.

Argument | Beschreibung
Objekt | Ein Form-Objekt oder ein Control-Objekt.

Anmerkung

Wird die Methode Undo auf ein Formular angewandt, gehen alle Änderungen am aktuellen Datensatz verloren. Wird die Methode Undo auf ein Steuerelement angewandt, ist lediglich das Steuerelement selbst betroffen.

Diese Methode muss angewandt werden, bevor das Formular oder Steuerelement aktualisiert wird. Es empfiehlt sich, diese Methode zur Ereignisprozedur BeforeUpdate eines Formulars bzw. zur Ereignisprozedur Change eines Steuerelements hinzuzufügen.

Die Methode Undo lässt sich alternativ zu der Anweisung SendKeys einsetzen, um in einer Ereignisprozedur den Wert der ESC-TASTE zu senden.


 UseDefaultFolderSuffix-Methode

UseDefaultFolderSuffix-Methode

Mit der UseDefaultFolderSuffix-Methode können Sie das Ordnersuffix für die angegebene Datenzugriffsseite auf das für die ausgewählte bzw. installierte Sprachunterstützung gültige Standardsuffix festlegen.

Syntax

Objekt.UseDefaultFolderSuffix

Die UseDefaultFolderSuffix-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zu eine bestimmten Datenzugriffsseite und deren WebOptions-Objekt ausgewertet wird.

Anmerkung

Microsoft Access benutzt das Ordnersuffix, wenn Sie ein Dokument als Webseite speichern möchten, lange Dateinamen verwenden und sich dafür entscheiden, Hilfsdateien in einem eigenen Ordner zu speichern (wenn also die Eigenschaften UseLongFileNames und OrganizeInFolder jeweils auf den Wert True gesetzt sind).

Das Suffix erscheint im Ordnernamen hinter den Namen der Datenzugriffsseite. Wenn die Datenzugriffsseite beispielsweise "Book1" heißt und Englisch als Sprache verwendet wird, lautet der Ordnername "Book1_files". Die verfügbaren Ordnersuffixe sind in dem Thema zur FolderSuffix-Eigenschaft aufgelistet.


 Neue Objekte

Neue Objekte

Die folgende Liste enthält Objekte, die Visual Basic in Microsoft Access 2000 hinzugefügt wurden.

Objekte | Beschreibung
AccessObject | Neues Objekt, das alle Datenbankobjekte innerhalb der Funktionalität des CodeData-, CodeProject-, CurrentData- und CurrentProject-Objekts darstellt
AccessObjectProperty, AccessObjectProperties | Neue Auflistungen und Eigenschaften für das AccessObject-Objekt innerhalb der Funktionalität des CodeData-, CodeProject-, CurrentData- und CurrentProject-Objekts
AllDataAccessPages, AllForms, AllMacros, AllModules, AllReports | Neue Auflistungen für die Funktionalität des neuen CurrentData- und CurrentProject-Objekts
AllDatabaseDiagrams, AllQueries, AllStoredProcedures, AllTables, AllViews | Neue Auflistungen für die Funktionalität des neuen CodeData- und CodeProject-Objekts
CodeData, CodeProject | Neue Objekte für die Datenbankfunktionalität von Code
ComAddIns | Funktionalität für neue COM-Add-Ins
CurrentData, CurrentProject | Neue Objekte für die Funktionalität der aktuellen Daten
DataAccessPage, DataAccessPages | Neues Feature "Datenzugriffsseite"
DefaultWebOptions | Standard-Weboptionen für die Anwendung
FileSearch | Funktionalität für die neue Dateisuche
FormatCondition, FormatConditions | Neues Feature "Bedingte Formatierung"
VBE | Funktionalität für den neuen Visual Basic-Editor
WebOptions | Weboptionen für Datenzugriffsseiten

ADO-Objekte

Um die Liste der neuen Objekte in der Microsoft ActiveX Data Objects 2.0-Bibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft ActiveX Data Objects-Referenz.

Sie können die von Microsoft ActiveX Data Objects 2.0 bereitgestellten Objekte verwenden; ein Verweis auf die Microsoft Office 9.0-Objektbibliothek wird bei geöffnetem Visual Basic-Editor automatisch eingerichtet.

Microsoft Office-Objekte

Um die Liste der neuen Objekte in der Microsoft Office 9.0-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Office Visual Basic-Referenz.

Wenn Sie die von Microsoft Office bereitgestellten Objekte verwenden möchten, richten Sie bei geöffnetem Visual Basic-Editor einen Verweis auf die Microsoft Office 9.0-Objektbibliothek ein, indem Sie im Menü Extras auf Verweise klicken und das entsprechende Kontrollkästchen aktivieren.

Microsoft Visual Basic-Editor-Objekte

Um die Liste der neuen Objekte in der Microsoft Visual Basic for Applications Extensibility 5.3-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Visual Basic-Referenz.

Wenn Sie die vom Microsoft Visual Basic-Editor bereitgestellten Objekte verwenden möchten, richten Sie einen Verweis auf die Microsoft Visual Basic for Applications Extensibility 5.3-Objektbibliothek ein. Zu diesem Zweck öffnen Sie den Visual Basic-Editor, klicken im Menü Extras auf Verweise und aktivieren dann das entsprechende Kontrollkästchen.


 AccessObject-Objekt

AccessObject-Objekt

Ein AccessObject-Objekt verweist auf ein bestimmtes Microsoft Access-Objekt innerhalb der folgenden Auflistungen.

AllForms | AllTables
AllReports | AllQueries
AllMacros | AllViews
AllModules | AllStoredProcedures
AllDataAccessPages | AllDatabaseDiagrams

Anmerkung

Ein AccessObject-Objekt beinhaltet Informationen über eine bestimmte Objektinstanz. Die folgende Tabelle listet die Typen von Objekten auf, die ein AccessObject-Objekt beschreibt, sowie den Namen der zugehörigen Auflistung und einen Anmerkung auf die in einem AccessObject enthaltenen Informationen.

AccessObject | Auflistung | Enthält Informationen über
Formular | AllForms | Gespeicherte Formulare
Bericht | AllReports | Gespeicherte Berichte
Makro | AllMacros | Gespeicherte Makros
Modul | AllModules | Gespeicherte Module
Datenzugriffsseite | AllDataAccessPages | Gespeicherte Datenzugriffsseiten
Tabelle | AllTables | Gespeicherte Tabellen
Abfrage | AllQueries | Gespeicherte Abfragen
Ansicht | AllViews | Gespeicherte Ansichten
Gespeicherte Prozedur | AllStoredProcedures | Gespeicherte "Gespeicherte Prozeduren"
Datenbankdiagramm | AllDatabaseDiagrams | Gespeicherte Datenbankdiagramme

Da ein AccessObject-Objekt einem vorhandenen Objekt entspricht, können keine neuen AccessObject-Objekte erstellt oder vorhandene gelöscht werden. Der Zugriff auf ein AccessObject-Objekt in einer Auflistung erfolgt über dessen Ordnungszahl oder den Wert der Name-Eigenschaft, wobei Sie die folgenden Syntaxformen verwenden können:

AllForms(0)
AllForms("Name")
AllForms![Name]


 AccessObjectProperties-Auflistung

AccessObjectProperties-Auflistung

Die AccessObjectProperties-Auflistung enthält alle benutzerdefinierten AccessObjectProperty-Objekte einer bestimmten Instanz eines Objekts. Diese AccessObjectProperty-Objekte (die oft nur als "Eigenschaften" bezeichnet werden) kennzeichnen die betreffende Objektinstanz eindeutig.

Anmerkungen

Verwenden Sie die AccessObjectProperties-Auflistung in Visual Basic oder in einem Ausdruck, um auf Eigenschaften des CurrentProject-, CodeProject- oder AccessObject-Objekts zu verweisen. So können Sie z. B. die AccessObjectProperties-Auflistung in einer Schleife durchlaufen, um die Werte der Eigenschaften eines einzelnen Berichts einzustellen oder zurückzugeben.

Um eine benutzerdefinierte Eigenschaft einer vorhandenen Instanz eines Objekts hinzuzufügen, definieren Sie zunächst dessen Merkmale und fügen es der Auflistung mit der Add-Methode hinzu. Wenn Sie auf ein benutzerdefiniertes AccessObjectProperty-Objekt verweisen, das noch nicht an eine AccessObjectProperties-Auflistung angefügt wurde, führt dies zu einem Fehler. Ein Fehler tritt auch auf, wenn ein benutzerdefiniertes AccessObjectProperty-Objekt an eine AccessObjectProperties-Auflistung angefügt wird, die ein AccessObjectProperty-Objekt gleichen Namens enthält.

Mit der Remove-Methode können Sie benutzerdefinierte Eigenschaften aus der AccessObjectProperties-Auflistung entfernen.

Anmerkung Ein eingebautes oder benutzerdefiniertes AccessObjectProperty-Objekt wird nur der spezifischen Instanz eines Objekts zugeordnet. Die Eigenschaft wird nicht für alle Instanzen von Objekten des ausgewählten Typs definiert.

Um in einer Auflistung auf ein eingebautes oder benutzerdefiniertes AccessObjectProperty-Objekt über seine Ordnungszahl oder die Einstellung seiner Name-Eigenschaft zu verweisen, verwenden Sie eine der folgenden Syntaxformen:

CurrentProject.AllForms("Form1").Properties(0)
CurrentProject.AllForms("Form1").Properties("Name")
CurrentProject.AllForms("Form1").Properties![Name]

Mit den gleichen Syntaxformen können Sie auch auf die Value-Eigenschaft eines AccessObjectProperty-Objekts verweisen. Der Kontext des Verweises bestimmt, ob auf das AccessObjectProperty-Objekt selbst oder auf die Value-Eigenschaft des AccessObjectProperty-Objekts verwiesen wird.

Anmerkung Eigenschaften in der AccessObjectProperties-Auflistung werden nicht gespeichert und können verloren gehen, wenn das Objekt, dem sie zugeordnet sind, unter Verwendung des Add-Ins zur Quellcodeverwaltung ein- oder ausgecheckt wird.


 AccessObjectProperty-Objekt

AccessObjectProperty-Objekt

Ein AccessObjectProperty-Objekt repräsentiert eine integrierte oder benutzerdefinierte Eigenschaft eines AccessObject-Objekts.

Anmerkung

Jedes AccessObject-Objekt enthält eine AccessObjectProperties-Auflistung, die íhrerseits AccessObjectProperty-Objekte umfasst, die den Eigenschaften des AccessObject-Objekts entsprechen. Der Benutzer kann außerdem AccessObjectProperty-Objekte definieren und sie der AccessObjectProperties-Auflistung eines AccessObject-Objekts anhängen.

Sie können für die folgenden Objekte benutzerdefinierte Eigenschaften erstellen:

  • CodeData-, CodeProject-, CurrentProject- und CurrentData-Objekte

  • AccessObject-Objekte in den folgenden Auflistungen.

    CurrentProject- und CodeProject-Objektauflistungen CodeData- und CodeProject-Objektauflistungen
    AllForms AllTables
    AllReports AllQueries
    AllDataAccessPages AllViews
    AllMacros AllStoredProcedures
    AllModules AllDatabaseDiagrams

Um eine benutzerdefinierte Eigenschaft hinzuzufügen, erstellen Sie mit der Add-Methode ein AccessObjectProperty-Objekt mit einer eindeutigen Einstellung für die Name-und Value-Eigenschaften, und fügen dann das neue AccessObjectProperty-Objekt zur AccessObjectProperties-Auflistung des entsprechenden Objekts hinzu. Das Objekt, dem Sie die benutzerdefinierte Eigenschaft hinzufügen, muss bereits Bestandteil einer Auflistung sein. Die Bezugnahme auf ein benutzerdefiniertes AccessObjectProperty-Objekt, das noch nicht an eine AccessObjectProperties-Auflistung angehängt worden ist, führt zu einem Fehler. Ebenfalls zu einem Fehler führt es, wenn ein benutzerdefiniertes AccessObjectProperty-Objekt zu einer AccessObjectProperties-Auflistung hinzugefügt wird, die bereits ein AccessObjectProperty-Objekt desselben Namens enthält.

Sie können benutzerdefinierte Eigenschaften aus der AccessObjectProperties-Auflistung entfernen.

Anmerkung Ein benutzerdefiniertes AccessObjectProperty-Objekt bezieht sich nur auf eine bestimmte Objektinstanz. Die Eigenschaft ist nicht für alle Objektinstanzen des ausgewählten Typs definiert.

Das AccessObjectProperty-Objekt besitzt zwei integrierte Eigenschaften:

  • Die Name-Eigenschaft mit einem String-Wert, der die Eigenschaft eindeutig kennzeichnet.

  • Die Value-Eigenschaft mit einem Variant-Wert, der die Einstellung der benutzerdefinierten Eigenschaft beinhaltet.

Um auf ein integriertes oder benutzerdefiniertes AccessObjectProperty-Objekt in einer Auflistung zuzugreifen, verwenden Sie die Ordinalzahl des Objekts oder den Wert seiner Name-Eigenschaft. Sie können die folgenden Syntaxformen benutzen:

CurrentProject.AllForms("Formular1").Properties(0)
CurrentProject.AllForms("Formular1").Properties("Name")
CurrentProject.AllForms("Formular1").Properties![Name]

Dieselben Syntaxformen sind möglich, wenn Sie auf die Value-Eigenschaft einesAccessObjectProperty-Objekts zugreifen möchten. Der Kontext der Bezugnahme entscheidet, ob Sie das AccessObjectProperty-Objekt selbst oder die Value-Eigenschaft des AccessObjectProperty-Objekts meinen.

Anmerkung Eigenschaften in der AccessObjectProperties-Auflistung werden nicht gespeichert und können deshalb verloren gehen, wenn das Objekt, dem sie zugeordnet sind, bei Verwendung der Quellcode-Kontrolle (Add-In) ein- oder ausgecheckt wird.


 AllDataAccessPages-Auflistung

AllDataAccessPages-Auflistung

Die AllDataAccessPages-Auflistung enthält ein AccessObject-Objekt für jede Datenzugriffsseite im CurrentProject- bzw. CodeProject-Objekt.

Anmerkung Obwohl es so aussehen kann, als ob ein Microsoft Access-Projekt (.adp) oder eine Microsoft Access-Datenbank (.mdb) Datenzugriffsseiten enthielte, werden diese Seiten tatsächlich in für das Projekt oder die Datenbank externen Dateien gespeichert.

Anmerkungen

Das CurrentProject- bzw. CodeProject-Objekt besitzt eine AllDataAccessPages-Auflistung mit AccessObject-Objekten, die Instanzen aller Datenzugriffsseiten beschreiben. So können Sie z. B. die AllDataAccessPages-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können in der AllDataAccessPages-Auflistung auf ein einzelnes AccessObject-Objekt entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte Datenzugriffsseite in der AllDataAccessPages-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllDataAccessPages-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine Datenzugriffsseite über ihren Index verweisen, ist AllDataAccessPages(0) die erste Seite, AllDataAccessPages(1) die zweite Seite usw.

Anmerkung Zum Auflisten aller geöffneten Datenzugriffsseiten der Datenbank verwenden Sie in der AllDataAccessPages-Auflistung von jedem AccessObject-Objekt die IsLoaded-Eigenschaft. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer Datenzugriffsseite zurückzugeben.

Es ist nicht möglich, in einer AllDataAccessPages-Auflistung ein AccessObject-Objekt hinzuzufügen oder zu löschen.


 AllDatabaseDiagrams-Auflistung

AllDatabaseDiagrams-Auflistung

Die AllDatabaseDiagrams-Auflistung enthält ein AccessObject-Objekt für jedes Datenbankdiagramm im CurrentData- bzw. CodeData-Objekt.

Anmerkungen

Das CurrentData- bzw. CodeData-Objekt besitzt eine AllDatabaseDiagrams-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentData bzw. CodeData angegebenen Datenbankdiagramme beschreiben. So können Sie z.B. die AllDatabaseDiagrams-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllDatabaseDiagrams-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf ein bestimmtes Datenbankdiagramm in der AllDatabaseDiagrams-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllDatabaseDiagrams-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf ein Datenbankdiagramm über seinen Index verweisen, ist AllDatabaseDiagrams(0) das erste Diagramm, AllDatabaseDiagrams(1) das zweite Diagramm usw.

Anmerkungen

  • Die AllDatabaseDiagrams-Auflistung enthält nur AccessObject-Objekte innerhalb eines Microsoft Access-Projekts (.adp). Eine Microsoft Access-Datenbank (.mdb) enthält keine Datenbankdiagramme.

  • Zum Auflisten aller geöffneten Datenbankdiagramme des Projekts verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllDatabaseDiagrams-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Datenbankdiagramms zurückzugeben.

Es ist nicht möglich, der AllDatabaseDiagrams-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllForms-Auflistung

AllForms-Auflistung

Die AllForms-Auflistung enthält ein AccessObject-Objekt für jedes Formular im CurrentProject- bzw. CodeProject-Objekt.

Anmerkungen

Das CurrentProject- bzw. CodeProject-Objekt besitzt eine AllForms-Auflistung mit AccessObject-Objekten, die Instanzen aller Formulare der Datenbank beschreiben. So können Sie z.B. die AllForms-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllForms-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf ein bestimmtes Formular in der AllForms-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllForms-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf ein Formular über seinen Index verweisen, ist AllForms(0) das erste Formular, AllForms(1) das zweite Formular usw.

Anmerkung Zum Auflisten aller geöffneten Formulare der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllForms-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Formulars zurückzugeben.

Es ist nicht möglich, der AllForms-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllMacros-Auflistung

AllMacros-Auflistung

Die AllMacros-Auflistung enthält ein AccessObject-Objekt für jedes Makro im CurrentProject- bzw. CodeProject-Objekt.

Anmerkungen

Das CurrentProject- bzw. CodeProject-Objekt besitzt eine AllMacros-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentProject bzw. CodeProject angegebenen Makros beschreiben. So können Sie z.B. die AllMacros-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt der AllMacros-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf ein bestimmtes Makro in der AllMacros-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllMacros-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf ein Makro über seinen Index verweisen, ist AllMacros(0) das erste Makro, AllMacros(1) das zweite Makro usw.

Anmerkung Zum Auflisten aller geöffneten Makros der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllMacros-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Makros zurückzugeben.

Es ist nicht möglich, der AllMacros-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllModules-Auflistung

AllModules-Auflistung

Die AllModules-Auflistung enthält ein AccessObject-Objekt jedes Moduls im CurrentProject- bzw. CodeProject-Objekt.

Anmerkungen

Das CurrentProject- bzw. CodeProject-Objekt besitzt eine AllModules-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentProject bzw. CodeProject angegebenen Module-Objekte beschreiben. So können Sie z.B. die AllModules-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllModules-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf ein bestimmtes Modul in der AllModules-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllModules-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf ein Modul über seinen Index verweisen, ist AllModules(0) das erste Modul, AllModules(1) das zweite Modul usw.

Anmerkung Zum Auflisten aller geöffneten Module der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllModules-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Moduls zurückzugeben.

Es ist nicht möglich, der AllModules-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllQueries-Auflistung

AllQueries-Auflistung

Die AllQueries-Auflistung enthält ein AccessObject-Objekt für jede Abfrage im CurrentData- bzw. CodeData-Objekt.

Anmerkungen

Das CurrentData- bzw. CodeData-Objekt besitzt eine AllQueries-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentData bzw. CodeData angegebenen Abfragen beschreiben. So können Sie z.B. die AllQueries-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllQueries-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte Abfrage in der AllQueries-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllQueries-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine Abfrage über ihren Index verweisen, ist AllQueries(0) die erste Abfrage, AllQueries(1) die zweite Abfrage usw.

Anmerkungen

  • Die AllQueries-Auflistung enthält nur AccessObject-Objekte innerhalb einer Microsoft Access-Datenbank (.mdb). Ein Microsoft Access-Projekt (.adp) enthält keine Abfragen; siehe die AllViews-Auflistung.

  • Zum Auflisten aller geöffneten Abfragen der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllQueries-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer Abfrage zurückzugeben.

  • Es ist nicht möglich, der AllQueries-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllReports-Auflistung

AllReports-Auflistung

Die AllReports-Auflistung enthält ein AccessObject-Objekt für jeden Bericht im CurrentProject- bzw. CodeProject-Objekt.

Anmerkungen

Das CurrentProject- bzw. CodeProject-Objekt besitzt eine AllReports-Auflistung mit AccessObject-Objekten, die Instanzen aller Berichte in der Datenbank beschreiben. So können Sie z.B. die AllReports-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllReports-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf einen bestimmten Bericht in der AllReports-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllReports-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf einen Bericht über seinen Index verweisen, ist AllReports(0) der erste Bericht, AllReports(1) der zweite Bericht usw.

Anmerkung Zum Auflisten aller geöffneten Berichte in der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllReports-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Berichts zurückzugeben.

Es ist nicht möglich, der AllReports-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllStoredProcedures-Auflistung

AllStoredProcedures-Auflistung

Die AllStoredProcedures-Auflistung enthält ein AccessObject-Objekt für jede gespeicherte Prozedur im CurrentData- bzw. CodeData-Objekt.

Anmerkungen

Das CurrentData- bzw. CodeData-Objekt besitzt eine AllStoredProcedures-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentData bzw. CodeData angegebenen gespeicherten Prozeduren beschreiben. So können Sie z.B. die AllStoredProcedures-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllStoredProcedures-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte gespeicherte Prozedur in der AllStoredProcedures-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllStoredProcedures-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine gespeicherte Prozedur über ihren Index verweisen, ist AllStoredProcedures(0) die erste gespeicherte Prozedur, AllStoredProcedures(1) die zweite gespeicherte Prozedur usw.

Anmerkungen

  • Die AllStoredProcedures-Auflistung enthält nur AccessObject-Objekte innerhalb eines Microsoft Access-Projekts (.adp). Eine Microsoft Access-Datenbank (.mdb) enthält keine gespeicherten Prozeduren; siehe die AllMacros-Auflistung.

  • Zum Auflisten aller geöffneten gespeicherten Prozeduren des Projekts verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllStoredProcedures-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer gespeicherten Prozedur zurückzugeben.

  • Es ist nicht möglich, der AllStoredProcedures-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllTables-Auflistung

AllTables-Auflistung

Die AllTables-Auflistung enthält ein AccessObject-Objekt für jede Tabelle im CurrentData- bzw. CodeData-Objekt.

Anmerkungen

Das CurrentData- bzw. CodeData-Objekt besitzt eine AllTables-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentData bzw. CodeData angegebenen Tabellen beschreiben. So können Sie z.B. die AllTables-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllTables-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte Tabelle in der AllTables-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllTables-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine Tabelle über ihren Index verweisen, ist AllTables(0) die erste Tabelle, AllTables(1) die zweite Tabelle usw.

Anmerkung Zum Auflisten aller geöffneten Tabellen der Datenbank verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllTables-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer Tabelle zurückzugeben.

Es ist nicht möglich, der AllTables-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 AllViews-Auflistung

AllViews-Auflistung

Die AllViews-Auflistung enthält ein AccessObject-Objekt für jede Sicht im CurrentData- bzw. CodeData-Objekt.

Anmerkungen

Das CurrentData- bzw. CodeData-Objekt besitzt eine AllViews-Auflistung mit AccessObject-Objekten, die Instanzen aller durch CurrentData bzw. CodeData angegebenen Sichten beschreiben. So können Sie z.B. die AllViews-Auflistung in Visual Basic in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner AccessObject-Objekte in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes AccessObject-Objekt in der AllViews-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte Ansicht in der AllViews-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die AllViews-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine Ansicht über ihren Index verweisen, ist AllViews(0) die erste Sicht, AllViews(1) die zweite Sicht usw.

Anmerkungen

  • Die AllViews-Auflistung enthält nur AccessObject-Objekte innerhalb eines Microsoft Access-Projekts (.adp). Eine Microsoft Access-Datenbank (.mdb) enthält keine Sichten; siehe die AllQueries-Auflistung.

  • Zum Auflisten aller geöffneten Sichten des Projekts verwenden Sie die IsLoaded-Eigenschaft jedes AccessObject-Objekts in der AllViews-Auflistung. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer Sicht zurückzugeben.

  • Es ist nicht möglich, der AllViews-Auflistung ein AccessObject-Objekt hinzuzufügen oder aus ihr zu löschen.


 Application-Objekt

Application-Objekt

Das Objekt Application bezieht sich auf die aktive Microsoft Access-Anwendung.

Anmerkung

Das Application-Objekt enthält alle Microsoft Access-Objekte und Auflistungen.

Verwenden Sie das Objekt Application, um Methoden oder Eigenschafteneinstellungen auf die gesamte Microsoft Access-Anwendung anzuwenden. Beispielsweise können Sie die Methode SetOption des Objekts Application verwenden, um Datenbankoptionen aus Visual Basic festzulegen. Das folgende Beispiel zeigt, wie Sie das Kontrollkästchen Statusleiste unter Anzeigen auf der Registerkarte Ansicht des Dialogfelds Optionen einstellen können.

Application.SetOption "Show Status Bar", True

Microsoft Access ist eine COM-Komponente, die Automatisierung, bisher OLE-Automatisierung genannt, unterstützt. Sie können Microsoft Access-Objekte von einer anderen Anwendung aus bearbeiten, die ebenfalls Automatisierung unterstützt. Verwenden Sie hierzu das Objekt Application.

Beispielsweise ist Microsoft Visual Basic eine COM-Komponente. Sie können eine Microsoft Access-Datenbank aus Microsoft Visual Basic öffnen und mit Ihren Objekten arbeiten. Erstellen Sie zunächst in Visual Basic einen Verweis auf die Microsoft Access 9.0-Objektbibliothek. Erstellen Sie dann eine neue Instanz der Klasse Application, und zeigen Sie mit einer Objektvariablen auf die Instanz, wie im folgenden Beispiel.

Dim appAccess As New Access.Application

Aus Anwendungen, die das Schlüsselwort New nicht unterstützen, können Sie eine neue Instanz der Klasse Application mit Hilfe der Funktion CreateObject wie folgt erstellen:

Dim appAccess As Object
Set appAccess = CreateObject("Access.Application.9")

Sobald Sie eine neue Instanz des Microsoft Access-Objekts Application erstellt haben, können Sie eine Datenbank öffnen oder neu erstellen, indem Sie die Methode OpenCurrentDatabase oder die Methode NewCurrentDatabase verwenden. Dann können Sie die Eigenschaften des Application-Objekts einstellen und dessen Methoden aufrufen. Wenn Sie mit der Eigenschaft CommandBars des Application-Objekts einen Verweis auf das Objekt CommandBars erstellen, können Sie unter Verwendung dieses Verweises auf alle Objekte und Auflistungen der OFF9TBD-Befehlsleiste zugreifen.

Sie können auch andere Microsoft Access-Objekte durch das Objekt Application bearbeiten. Beispielsweise können Sie unter Verwendung der Methode OpenForm des Microsoft Access-Objekts DoCmd ein Microsoft Access-Formular aus Microsoft Excel heraus öffnen.

appAccess.DoCmd.OpenForm "Bestellformular"

Weitere Informationen zum Erstellen eines Verweises und zum Steuern von Objekten durch Automatisierung finden Sie in der Dokumentation der Anwendung, die als COM-Komponente fungiert.


 CodeData-Objekt

CodeData-Objekt

Das CodeData-Objekt verweist auf Objekte, die innerhalb der von der Serveranwendung (Jet oder SQL) verwalteten Codedatenbank gespeichert sind.

Anmerkung

Das CodeData-Objekt besitzt mehrere Auflistungen, die bestimmte Objekttypen innerhalb der Codedatenbank enthält. Die folgende Tabelle listet die Namen der durch die Datenbank definierten Auflistungen sowie die Typen der jeweils enthaltenen Objekte auf.

Auflistungen | Objekttyp
AllTables | Alle Tabellen
AllQueries | Alle Abfragen (die Anzahl (.Count) der Abfragen in einem Microsoft Access-Projekt (.adp) ist Null).
AllViews | Alle Sichten (die Anzahl (.Count) der Sichten in einer Access-Datenbank (.mdb) ist Null).
AllStoredProcedures | Alle gespeicherten Prozeduren (die Anzahl (.Count) der gespeicherten Prozeduren in einer Access-Datenbank (.mdb) ist Null).
AllDatabaseDiagrams | Alle Datenbankdiagramme (die Anzahl (.Count) der Datenbankdiagramme in einer Access-Datenbank (.mdb) ist Null).

Anmerkung Die Auflistungen der vorhergehenden Tabelle enthalten alle diesbezüglichen Objekte in der Datenbank und zwar unabhängig davon, ob sie geöffnet sind oder nicht.

So ist beispielsweise ein AccessObject-Objekt, das eine Tabelle repräsentiert, ein Element der AllTables-Auflistung, einer Auflistung von AccessObject-Objekten innerhalb der aktuellen Datenbank. Einzelne Tabellen innerhalb der AllTables-Auflistung werden mit Null beginnend indiziert. Sie können auf ein einzelnes AccessObject-Objekt in der AllTables-Auflistung zugreifen, indem Sie entweder den Namen der Tabelle oder den Index des Objekts innerhalb der Auflistung angeben. Wenn Sie auf ein bestimmtes Element der AllTables-Auflistung bezugnehmen möchten, ist die Namensreferenz vorzuziehen, da sich der Index des Objekts ändern kann. Wenn der Objektnamen ein Leerzeichen enthält, muss der Name in eckige Klammern ([ ]) gesetzt werden.

Syntax | Beispiel
AllTables!Tabellenname | AllTables!Bestellungen
AllTables![Tabellenname] | AllTables![Tabelle Bestellungen]
AllTables("Tabellenname") | AllTables("Bestellungen")
AllTables(Index) | AllTables(0)


 Control-Objekt

Control-Objekt

Ein Control-Objekt stellt ein Steuerelement dar, das sich in einem Formular, einem Bericht, einem Bereich oder innerhalb eines anderen Steuerelements befindet oder einem anderen Steuerelement beigefügt ist. Die folgende Abbildung zeigt das Objekt Control in Beziehung zu einem Form- oder Report- Objekt.

Anmerkung

Alle Steuerelemente eines Formulars oder Berichts gehören zur Auflistung Controls des entsprechenden Objekts Form oder Report. Steuerelemente innerhalb eines bestimmten Bereichs gehören zur Auflistung Controls dieses Bereichs. Steuerelemente innerhalb eines Registersteuerelements oder eines Optionsgruppen- Steuerelements gehören zur Auflistung Controls dieses Steuerelements. Ein Bezeichnungsfeld- Steuerelement, das einem anderen Steuerelement beigefügt ist, gehört zur Auflistung Controls dieses Steuerelements.

Wenn Sie auf ein bestimmtes Control-Objekt der Auflistung Controls verweisen, können Sie auf die Auflistung Controls implizit oder explizit verweisen.

' Impliziter Verweis auf das Steuerelement "NeueDaten"
    ' in der Controls-Auflistung
Me!NeueDaten
' Eckige Klammern, wenn Steuerelementname Leerzeichen enthält.
Me![Neue Daten]
' Etwas schlechteres Leistungsverhalten.
Me("NeueDaten")
' Verweis auf ein Steuerelement über den Index
    ' in der Controls-Auflistung.
Me(0)
' Verweis auf das Steuerelement "NeueDaten" unter Verwendung
    ' des Unterformular-Steuerelements der Controls-Auflistung.
Me.ctlUnterformular.Controls!NeueDaten
' Expliziter Verweis auf das Steuerelement "NeueDaten"
    ' in der Controls-Auflistung
Me.Controls!NeueDaten
Me.Controls("NeueDaten")
Me.Controls(0)

Anmerkung Sie können das Schlüsselwort Me nur dann im Code zur Darstellung eines Form- oder Report-Objekts verwenden, wenn Sie auf das Formular oder den Bericht im Code innerhalb des Klassenmoduls verweisen. Bei Verweisen aus einem Standardmodul oder einem Modul eines anderen Formulars oder Berichts auf ein Formular oder einen Bericht verwenden Sie die vollständige Referenz auf das Formular oder den Bericht.

Jedem Control-Objekt ist eine eingebaute Konstante zugeordnet. Beispielsweise ist die eingebaute Konstante acTextBox mit einem Textfeld-Steuerelement verbunden, und acCommandButton ist mit einer Befehlsschaltfläche verbunden. Die Konstanten für die verschiedenen Microsoft Access-Steuerelemente werden in der Eigenschaft ControlType verwaltet.

Um den Typ eines vorhandenen Steuerelements zu ermitteln, verwenden Sie die Eigenschaft ControlType. Sie brauchen den Typ eines Steuerelements jedoch nicht zu kennen, um es im Code verwenden zu können. Sie können das Steuerelement einfach durch eine Variable des Datentyps Control darstellen.

Wenn Sie den Datentyp des Steuerelements, auf das Sie sich beziehen, kennen, und wenn es sich dabei um ein eingebautes Microsoft Access Steuerelement handelt, sollten Sie es durch eine Variable eines bestimmten Datentyps darstellen. Wenn Sie beispielsweise wissen, dass ein bestimmtes Steuerelement ein Textfeld ist, deklarieren Sie dafür eine Variable des Typs Textfeld, wie im folgenden Code gezeigt wird.

Dim txt As TextBox
Set txt = Formulare!Kunden!Nachname

Anmerkung Wenn ein Steuerelement ein ActiveX Steuerelement ist, müssen Sie eine Variable vom Typ Control deklarieren, um es darzustellen; Sie können dazu keinen bestimmten Typ verwenden. Wenn Sie nicht sicher sind, auf welchen Steuerelement-Typ die Variable zeigen wird, deklarieren Sie die Variable als Typ Control.

Das Optionsgruppe-Steuerelement kann andere Steuerelemente innerhalb seiner Auflistung Controls enthalten. Dazu gehören Optionsfeld-, Kontrollkästchen-, Umschaltfläche- und Bezeichnungsfeld-Steuerelemente.

Das Registersteuerelement enthält eine Auflistung Pages, bei der es sich um einen bestimmten Typ der Auflistung Controls handelt. Die Auflistung Pages enthält Page-Objekte, die Steuerelemente sind. Jedes Page-Objekt seinerseits enthält eine Auflistung Controls, die alle Steuerelemente dieser Seite enthält.

Andere Control-Objekte haben eine Auflistung Controls, die ein beigefügtes Bezeichnungsfeld enthalten kann. Diese Steuerelemente umfassen Textfeld-, Optionsgruppe-, Optionsfeld-, Umschaltfläche-, Kontrollkästchen-, Kombinationsfeld-, Listenfeld-, Befehlsschaltfläche-, Gebundenes Objektfeld- und Objektfeld-Steuerelemente.


 Controls-Auflistung (Steuerelemente)

Controls-Auflistung (Steuerelemente)

Die Controls-Auflistung enthält alle Steuerelemente eines Formulars, Berichts oder Bereichs sowie alle sich innerhalb eines anderen Steuerelements befindenden oder an ein anderes Steuerelement gebundenen Steuerelemente. Die Controls-Auflistung ist ein Element eines Form-, Report-, Section- oder Control-Objekts. Das folgende Diagramm zeigt die Beziehung zwischen der Controls-Auflistung und einem Objekt Form oder Report.

Anmerkungen

Sie können eine Auflistung Controls durchlaufen, die Anzahl der zu ihr gehörenden Steuerelemente zählen und deren Eigenschaften einstellen. Sie können z. B. die Auflistung Controls eines bestimmten Formulars durchlaufen und die Eigenschaft Height jedes Steuerelements auf einen bestimmten Wert einstellen.

Tipp Eine Auflistung lässt sich am besten mit einer Anweisung For Each...Next durchlaufen.

Es ist schneller, auf die Auflistung Controls implizit zu verweisen, wie in den folgenden Beispielen, die auf ein Steuerelement namens NeueDaten verweisen, das sich auf dem Formular Bestellformular befindet. Von den folgenden Syntaxbeispielen ist Me!NeueDaten die schnellste Möglichkeit, auf das Steuerelement zu verweisen.

Me!NeueDaten                ' Oder Formulare!Bestellformular!NeueDaten.
Me![Neue Daten]            ' Wenn der Steuerelementname Leerzeichen enthält.
Me("NeueDaten")            ' Etwas schlechteres Leistungsverhalten.

Sie können auch auf ein Steuerelement verweisen, indem Sie explizit auf die Auflistung Controls verweisen.

Me.Controls!NeueDaten        ' Oder Formulare!Bestellformular.Controls!NeueDaten.
Me.Controls![Neue Daten]
Me.Controls("NeueDaten")

Außerdem können Sie auf ein Steuerelement durch dessen Index in der Auflistung verweisen. Die Auflistung Controls wird beginnend mit Null indiziert.

Me(0)                        ' Verweist auf den ersten Eintrag der Auflistung.
Me.Controls(0)

Anmerkung Sie können mit dem Schlüsselwort Me ein Formular oder einen Bericht in Code angeben, allerdings nur dann, wenn Sie auf das Formular oder den Bericht durch Code innerhalb des Formularmoduls oder des Berichtsmoduls verweisen. Verweisen Sie auf ein Formular oder einen Bericht von einem Standardmodul oder einem anderen Formular- oder Berichtsmodul aus, müssen Sie den vollständigen Verweis auf das Formular oder den Bericht verwenden.

Verwenden Sie für die Arbeit mit den Steuerelementen in einem Bereich eines Formulars oder Berichts die Eigenschaft Section, um einen Verweis auf ein Section-Objekt zurückzugeben. Verweisen Sie dann auf die Auflistung Controls des Objekts Section.

Zwei Arten von Control-Objekten, das Registersteuerelement und die Optionsgruppe, besitzen Controls-Auflistungen, die mehrere Steuerelemente enthalten können. Die Auflistung Controls zum Optionsgruppen-Steuerelement enthält ein beliebiges Optionsfeld, Kontrollkästchen oder Bezeichnungsfeld bzw. eine beliebige Umschaltfläche.

Das Registersteuerelement enthält eine Pages-Auflistung. Hierbei handelt es sich um einen Spezialtyp der Controls-Auflistung. Die Auflistung Pages enthält Page-Objekte. Page-Objekte sind ebenfalls Steuerelemente. Die Konstante für ein Page-Steuerelement der Eigenschaft ControlType lautet acPage. Ein Page-Objekt besitzt wiederum seine eigene Controls-Auflistung, die alle Steuerelemente einer Einzelseite enthält.

Andere Control-Objekte besitzen eine Controls-Auflistung, die ein zugeordnetes Bezeichnungsfeld enthalten kann. Zu diesen Steuerelementen zählen das Textfeld, die Optionsgruppe, das Optionsfeld, die Umschaltfläche, das Kontrollkästchen, das Kombinationsfeld, das Listenfeld, die Befehlsschaltfläche, das ungebundene Objektfeld, und das gebundene Objektfeld.


 CurrentData-Objekt

CurrentData-Objekt

Das CurrentData-Objekt verweist auf Objekte, die innerhalb der von der Serveranwendung (Jet oder SQL) verwalteten Datenbank gespeichert sind.

Anmerkung

Das CurrentData-Objekt besitzt mehrere Auflistungen, die bestimmte AccessObject-Objekte innerhalb der aktuellen Datenbank enthalten. Die folgende Tabelle listet die Namen aller Auflistungen, die durch die Datenbank definiert sind, sowie die Typen der jeweils enthaltenen Objekte auf.

Auflistungen | Objekttyp
AllTables | Alle Tabellen
AllQueries | Alle Abfragen (die Anzahl (.Count) der Abfragen in einem Microsoft Access-Projekt (.adp) ist Null).
AllViews | Alle Sichten (die Anzahl (.Count) der Sichten in einer Microsoft Access-Datenbank (.mdb) ist Null).
AllStoredProcedures | Alle gespeicherten Prozeduren (die Anzahl (.Count) der gespeicherten Prozeduren in einer Access-Datenbank (.mdb) ist Null).
AllDatabaseDiagrams | Alle Datenbankdiagramme (die Anzahl (.Count) der Datenbankdiagramme in einer Access-Datenbank (.mdb) ist Null).

Anmerkung Die Auflistungen der vorhergehenden Tabelle enthalten alle diesbezüglichen Objekte in der Datenbank und zwar unabhängig davon, ob sie geöffnet sind oder nicht.

So ist beispielsweise ein AccessObject-Objekt, das eine Tabelle repräsentiert, ein Element der AllTables-Auflistung, einer Auflistung von AccessObject-Objekten innerhalb der aktuellen Datenbank. Einzelne Tabellen innerhalb der AllTables-Auflistung werden mit Null beginnend indiziert. Sie können auf ein einzelnes AccessObject-Objekt in der AllTables-Auflistung zugreifen, indem Sie entweder den Namen der Tabelle oder den Index des Objekts innerhalb der Auflistung angeben. Wenn Sie auf ein bestimmtes Element der AllTables-Auflistung bezugnehmen möchten, ist die Namensreferenz vorzuziehen, da sich der Index des Objekts ändern kann. Wenn der Objektnamen ein Leerzeichen enthält, muss der Name in eckige Klammern ([ ]) gesetzt werden.

Syntax | Beispiel
AllTables!Tabellenname | AllTables!Bestellungen
AllTables![Tabellenname] | AllTables![Tabelle Bestellungen]
AllTables("Tabellenname") | AllTables("Bestellungen")
AllTables(index) | AllTables(5)


 CurrentProject-Objekt

CurrentProject-Objekt

Das CurrentProject-Objekt verweist auf das Projekt zur Verwaltung des aktuellen Microsoft Access-Projekts (.adp) bzw. der Microsoft Access-Datenbank (.mdb).

Anmerkung

Das CurrentProject-Objekt besitzt mehrere Auflistungen, die bestimmte AccessObject-Objekte innerhalb der aktuellen Datenbank enthalten. Die folgende Tabelle listet die Namen aller Auflistungen und die Typen der jeweils enthaltenen Objekte auf.

Auflistungen | Objekttyp
AllForms | Alle Formulare
AllReports | Alle Berichte
AllMacros | Alle Makros
AllModules | Alle Module
AllDataAccessPages | Alle Datenzugriffsseiten

Anmerkung Die Auflistungen der vorhergehenden Tabelle enthalten alle diesbezüglichen Objekte in der Datenbank und zwar unabhängig davon, ob sie geöffnet sind oder nicht.

So ist beispielsweise ein AccessObject-Objekt, das ein Formular repräsentiert, ein Element der AllForms-Auflistung, einer Auflistung von AccessObject-Objekten innerhalb der aktuellen Datenbank. Einzelne Formulare innerhalb der AllForms-Auflistung werden mit Null beginnend indiziert. Sie können auf ein einzelnes AccessObject-Objekt in der AllForms-Auflistung zugreifen, indem Sie entweder den Namen des Formulars oder den Index des Objekts innerhalb der Auflistung angeben. Wenn Sie auf ein bestimmtes Element der AllForms-Auflistung bezugnehmen möchten, ist die Namensreferenz vorzuziehen, da sich der Index des Objekts ändern kann. Wenn der Objektnamen ein Leerzeichen enthält, muss der Name in eckige Klammern ([ ]) gesetzt werden.

Syntax | Beispiel
AllForms!Formularname | AllFormulare!Bestellformular
AllFormulare![Formularname] | AllFormulare![Formular Bestellungen]
AllForms("Formularname") | AllForms("Bestellformular")
AllForms(index) | AllForms(0)


DefaultWebOptions-Objekt

Das DefaultWebOptions-Objekt enthält globale Attribute auf Anwendungsebene, die Microsoft Access beim Speichern einer Datenzugriffsseite als Webseite oder beim Öffnen einer Webseite verwendet. Attribute lassen sich entweder global (auf Anwendungsebene) oder auf Datenzugriffsseitenebene lesen und schreiben. (Beachten Sie, dass sich die Attributwerte der verschiedenen Datenzugriffsseiten unterscheiden können, je nachdem, welchen Attributwert eine Datenzugriffsseite beim Speichern besaß.) Attribute auf Datenzugriffsseitenebene überschreiben die anwendungsbezogenen Attribute. Die seitenbezogenen Attribute sind im WebOptions-Objekt zusammengefasst.

Anmerkung

Verwenden Sie die DefaultWebOptions-Eigenschaft, um zu dem DefaultWebOptions-Objekt zurückzukehren.


 DoCmd-Objekt

DoCmd-Objekt

Sie können die Methoden des Objekts DoCmd verwenden, um Microsoft Access-Aktionen aus Visual Basic heraus auszuführen. Eine Aktion führt Operationen durch, wie das Schließen von Fenstern, das Öffnen von Formularen und das Einstellen der Werte von Steuerelementen. Sie können z. B. mit der Methode OpenForm des Objekts DoCmd ein Formular öffnen oder mit der Methode Hourglass dem Mauszeiger das Aussehen eines Sanduhrsymbols geben.

Syntax

[Anwendung.]DoCmd.Methode [Arg1, Arg2, ...]

Das Objekt DoCmd hat die folgenden Argumente.

Argument | Beschreibung
Anwendung | Optional. Das Application-Objekt.
Methode | Eine der von diesem Objekt unterstützten Methoden.
Arg1, Arg2, ... | Die Argumente für die ausgewählte Methode. Diese Argumente entsprechen den Aktionsargumenten für die zugehörige Aktion.

Anmerkung

Die meisten Methoden des DoCmd-Objekts haben Argumente, von denen einige erforderlich, während andere optional sind. Für optionale Argumente, die Sie nicht angeben, werden deren für die jeweilige Methode wirksamen Standardwerte angenommen. Die Methode OpenForm hat z. B. sieben Argumente, von denen jedoch lediglich das erste Argument, Formularname, erforderlich ist. Das folgende Beispiel zeigt, wie Sie das Formular Personal in der aktuellen Datenbank öffnen können. Es werden nur Angestellte berücksichtigt, die die Position einer Vertriebsmitarbeiterin einnehmen.

DoCmd.OpenForm "Personal", , ,"[Position] = 'Vertriebsmitarbeiterin'"

Das Objekt DoCmd unterstützt keine Methoden, die den folgenden Aktionen entsprechen:

  • HinzufügenMenü

  • Warnmeldung. Verwenden Sie die Funktion MsgBox.

  • AusführenAnwendung. Verwenden Sie die Funktion Shell, um eine andere Anwendung auszuführen.

  • AusführenCode. Führen Sie die jeweilige Funktion direkt in Visual Basic aus.

  • Tastaturbefehle. Verwenden Sie die Anweisung SendKeys.

  • SetzenWert. Stellen Sie den Wert direkt in Visual Basic ein.

  • StoppAlleMakros

  • StoppMakro

Weitere Informationen zu den Microsoft Access-Aktionen, die einer Methode DoCmd entsprechen, finden Sie im Hilfeindex unter dem Namen der jeweiligen Aktion.


 Hyperlink-Objekt

Hyperlink-Objekt

Das Hyperlink-Objekt repräsentiert einen Hyperlink, der mit dem Steuerelement eines Formulars, Berichts oder einer Datenzugriffsseite verknüpft ist.

Anmerkung

Um die Referenz auf ein Hyperlink-Objekt zu erhalten, verwenden Sie die Hyperlink-Eigenschaft.


 FormatCondition-Objekt

FormatCondition-Objekt

Das FormatCondition-Objekt repräsentiert eine bedingte Formatierung eines Kombinationsfeld- oder Textfeld-Steuerelements und existiert als Element der FormatConditions-Auflistung.

Anmerkung

Sie können die Schreibweise FormatConditions(Index) verwenden, um ein FormatCondition-Objekt zurückzugeben, wobei Index die Zahl des bedingten Formats bezeichnet.

Um eine neue bedingte Formatierung zu erstellen, verwenden Sie die Add-Methode. Mit der Modify-Methode können Sie ein Format ändern und mit der Delete-Methode können Sie ein Format löschen.

Bedingte Formatierungen für Kombinationsfelder oder Textfelder lassen sich auch im Dialogfeld Bedingte Formatierung festlegen. Das Dialogfeld Bedingte Formatierung ist verfügbar, wenn Sie bei Anzeige eines Formulars in der Entwurfsansicht im Menü Format auf Bedingte Formatierung klicken.

Die Eigenschaften BackColor, Enabled, FontBold, FontItalic, FontUnderline und ForeColor des FormatCondition-Objekts lassen sich zur Beeinflussung der Darstellung eines formatierten Kombinationsfeld- oder Textfeld-Steuerelements verwenden.


 FormatConditions-Auflistung

FormatConditions-Auflistung

Die FormatConditions-Auflistung stellt die Auflistung bedingter Formatierungen für ein Kombinationsfeld- oder Textfeld-Steuerelement dar. Jede Formatierung wird durch ein FormatCondition-Objekt dargestellt.

Anmerkung

Verwenden Sie die FormatConditions-Eigenschaft eines Kombinations- oder Textfeldes in Visual Basic oder in einem Ausdruck, um eine FormatConditions-Auflistung zurückzugeben. Verwenden Sie die Add-Methode, um eine neue bedingte Formatierung zu erstellen, und die Modify-Methode, um eine vorhandene bedingte Formatierung zu ändern.

Mit der Modify-Methode können Sie eine der Formatierungen ändern und mit der Delete-Methode eine Formatierung löschen.

Die bedingte Formatierung für ein Kombinations- oder Textfeld kann auch über das Dialogfeld Bedingte Formatierung eingestellt werden. Zum Öffnen dieses Dialogfeldes klicken Sie im Menü Format auf Bedingte Formatierung, wenn ein Formular in der Entwurfsansicht angezeigt wird.


 Form-Objekt

Form-Objekt

Ein Form-Objekt verweist auf ein bestimmtes Microsoft Access-Formular.

Anmerkung

Ein Form-Objekt ist ein Element der Auflistung Forms, einer Auflistung aller momentan geöffneten Formulare. Die einzelnen Formulare in der Auflistung Forms werden durch einen bei Null beginnenden Index nummeriert. Sie verweisen auf einzelne Form-Objekte in der Auflistung Forms über den Formularnamen oder über den Index des Formulars innerhalb der Auflistung. Verwenden Sie bei Verweisen auf ein bestimmtes Form-Objekt in der Auflistung Forms vorzugsweise den Formularnamen, da sich der Formularindex in der Auflistung unter Umständen ändert. Enthält der Formularname Leerzeichen, so muss der Name in eckigen Klammern ([ ]) stehen.

Syntax | Beispiel
Forms!Formularname | Formulare!Bestellformular
Formulare![Name des Formulars] | Formulare![Formular Bestellungen]
Forms("Formularname") | Forms("Bestellformular")
Forms(Index) | Forms(0)

Jedes Form-Objekt verfügt über eine Auflistung Controls, die alle Steuerelemente des Formulars enthält. Sie verweisen auf ein Steuerelement in einem Formular durch eine implizite oder explizite Referenz auf die Auflistung Controls. Der Code ist effizienter, wenn Sie implizit auf die Auflistung Controls verweisen. Die folgenden Beispiele zeigen zwei Möglichkeiten, um auf das Steuerelement NeueDaten im Formular Bestellformular zu verweisen.

' Impliziter Verweis.
Formulare!Bestellformular!NeueDaten
' Expliziter Verweis.
Formulare!Bestellformular.Controls!NeueDaten

Die beiden folgenden Beispiele zeigen, wie Sie auf das Steuerelement NeueDaten im Unterformular ctlUnterformular des Formulars Bestellformular verweisen können.

Formulare!Bestellformular.ctlUnterformular.Form!Controls.NeueDaten
Formulare!Bestellformular.ctlUnterformular!NeueDaten

Jedes Form-Objekt verfügt über eine Auflistung Controls, die alle Steuerelemente des Formulars enthält. Sie verweisen auf ein Steuerelement in einem Formular durch eine implizite oder explizite Referenz auf die Auflistung Controls. Der Code ist effizienter, wenn Sie implizit auf die Auflistung Controls verweisen. Die folgenden Beispiele zeigen zwei Möglichkeiten, um auf das Steuerelement NeueDaten im Formular Bestellformular zu verweisen:

' Impliziter Verweis.
Formulare!Bestellformular!NeueDaten
' Expliziter Verweis.
Formulare!Bestellformular.Controls!NeueDaten

Die beiden folgenden Beispiele zeigen, wie Sie auf das Steuerelement NeueDaten im Unterformular ctlUnterformular des Formulars Bestellformular verweisen können.

Formulare!Bestellformular.ctlUnterformular.Form!Controls.NeueDaten
Formulare!Bestellformular.ctlUnterformular!NeueDaten


 Forms-Auflistung (Formulare)

Forms-Auflistung (Formulare)

Die Auflistung Forms enthält alle aktuell geöffneten Formulare einer Microsoft Access-Datenbank.

Anmerkung

Verwenden Sie die Auflistung Forms in Visual Basic oder in einem Ausdruck, um auf momentan geöffnete Formulare zu verweisen. Sie können z.B. die Auflistung Forms in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner Formulare in der Auflistung einzustellen oder zurückzugeben.

Tipp Die Anweisung For Each...Next ist hilfreich zum Durchlaufen einer Auflistung.

Sie verweisen auf ein bestimmtes Form-Objekt in der Auflistung Forms über den Formularnamen oder über den Index des Formulars innerhalb der Auflistung. Verwenden Sie bei Verweisen auf ein bestimmtes Formular in der Auflistung Forms vorzugsweise den Formularnamen, da sich der Formularindex in der Auflistung unter Umständen ändert.

Die Auflistung Forms wird beginnend mit Null indiziert. Wenn Sie über den Index auf ein Formular verweisen, ist das erste Formular Forms(0), das zweite Formular Forms(1), usw. Öffnen Sie beispielsweise zuerst Formular1 und dann Formular2, so erfolgen Verweise über den Index auf Formular2 in der Auflistung Forms mit Forms(1). Wenn Sie anschließend Formular1 schließen, erfolgen Verweise über den Index auf Formular2 in der Auflistung Forms mit Forms(0).

Anmerkung Wenn Sie alle Formulare in der Datenbank (geöffnete und geschlossene) auflisten möchten, durchlaufen Sie die AllForms-Auflistung des CurrentProject-Objekts. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Formulars zurückzugeben..

Sie können ein Form-Objekt aus der Auflistung Forms weder löschen noch zu ihr hinzufügen.


 Module-Objekt

Module-Objekt

Ein Module-Objekt verweist auf ein Standardmodul oder ein Klassenmodul.

Anmerkung

Microsoft Access enthält Klassenmodule, die keinem Objekt zugeordnet sind; Formularmodule und Berichtsmodule sind einem Formular bzw. Bericht zugeordnet.

Wenn Sie mit Hilfe von Code feststellen möchten, ob ein Module-Objekt ein Standardmodul oder ein Klassenmodul darstellt, prüfen Sie die Eigenschaft Type des Module-Objekts.

Die Auflistung Modules enthält alle geöffneten Module-Objekte, unabhängig von deren Typ. Module in der Auflistung Modules können kompiliert oder unkompiliert sein.

Wenn Sie einen Verweis auf ein Module-Objekt für ein bestimmtes Standard- oder Klassenmodul in der Auflistung Modules zurückgeben möchten, verwenden Sie eine der folgenden Syntaxformen.

Syntax | Beschreibung
Modules!Modulname | Das Argument Modulname ist der Name des Module-Objekts.
Modules("Modulname") | Das Argument Modulname ist der Name des Module-Objekts.
Modules(Index) | Das Argument Index ist die numerische Position des Objekts in der Auflistung.

Das folgende Beispiel gibt einen Verweis auf ein Module-Objekt für ein Standardmodul zurück und weist diesen einer Objektvariablen zu:

Dim mdl As Module
Set mdl = Modules![Dienstprogramme]

Beachten Sie, dass die eckigen Klammern um den Namen des Module-Objekts nur erforderlich sind, wenn der Name des Module-Objekts Leerzeichen enthält.

Das nächste Beispiel gibt einen Verweis auf ein Module-Objekt für ein Formularmodul zurück und weist diesen einer Objektvariablen zu:

Dim mdl As Module
Set mdl = Modules!Form_Personal

Wenn Sie auf ein bestimmtes Formular- oder Berichtsmodul verweisen möchten, können Sie auch die Eigenschaft Module des Form- oder Report-Objekts verwenden:

Forms!Formularname.Module

Das folgende Beispiel gibt auch einen Verweis auf das dem Formular Personal zugeordnete Module-Objekt zurück und weist diesen einer Objektvariablen zu:

Dim mdl As Module
Set mdl = Formulare!Personal.Module

Nachdem Sie einen Verweis auf ein Module-Objekt zurückgegeben haben, können Sie dessen Eigenschaften einstellen oder lesen und dessen Methoden anwenden.


 Modules-Auflistung

Modules-Auflistung

Die Auflistung Modules enthält alle geöffneten Standardmodule und Klassenmodule in einer Microsoft Access-Datenbank.

Anmerkung

Sie können die Modules-Auflistung durchlaufen, indem Sie die For Each...Next-Anweisung verwenden. Um zu bestimmen, ob ein einzelnes Module-Objekt ein Standardmodul oder ein Klassenmodul ist, überprüfen Sie die Type-Eigenschaft des Module-Objekts.

Alle geöffneten Module sind in der Auflistung Modules enthalten, unabhängig davon, ob sie unkompiliert oder kompiliert sind, ob sie sich im Unterbrechungsmodus befinden oder den gerade ausgeführten Code enthalten.

Die Modules-Auflistung gehört zum Microsoft Access-Objekt Application.

Die einzelnen Module-Objekte in der Auflistung Modules sind, beginnend bei Null, indiziert.


 Page-Objekt

Page-Objekt

Ein Page-Objekt entspricht einer einzelnen Seite auf einem Registerkarten-Steuerelement.

Anmerkung

Ein Page-Objekt ist ein Element der Auflistung Pages eines Reigisterkarten-Steuerelements.

Wenn Sie einen Verweis auf ein bestimmtes Page-Objekt in der Auflistung Pages zurückgeben möchten, verwenden Sie eine der folgenden Syntaxformen.

Syntax | Beschreibung
Pages!Seitenname | Das Argument Seitenname ist der Name des Page-Objekts.
Pages("Seitenname") | Das Argument Seitenname ist der Name des Page-Objekts.
Pages(Index) | Das Argument Index ist die numerische Position des Objekts in der Auflistung.

Sie können Page-Objekte entweder in Visual Basic oder in der Formularentwurfsansicht erstellen, verschieben oder löschen und deren Eigenschaften einstellen. Wenn Sie ein neues Page-Objekt in Visual Basic erstellen möchten, verwenden Sie die Methode Add der Auflistung Pages. Wenn Sie ein Page-Objekt löschen möchten, verwenden Sie die Methode Remove der Auflistung Pages.

Wenn Sie ein neues Page-Objekt in der Formularentwurfsansicht erstellen möchten, klicken Sie im Registersteuerelement mit der rechten Maustaste, und klicken Sie anschließend im Kontextmenü auf Seite einfügen. Außerdem können Sie eine vorhandene Seite kopieren und einfügen. Sie können die Eigenschaften des neuen Page-Objekts in der Formularentwurfsansicht unter Verwendung des Eigenschaftenfensters einstellen.

Jedes Page-Objekt besitzt eine Eigenschaft PageIndex, die seine Position innerhalb der Auflistung Pages angibt. Die Eigenschaft Seitenindex des Registerkarten-Steuerelements entspricht der Eigenschaft PageIndex der aktuellen Seite. Sie können Eigenschaften verwenden, um zu bestimmen, welche Seite aktuell ausgewählt ist, nachdem der Benutzer von einer Seite zur andern gewechselt ist, oder um die Reihenfolge zu bestimmen, in der die Seiten im Steuerelement angezeigt werden.

Ein Page-Objekt ist auch eine Art Control-Objekt. Die Eigenschaftenkonstante ControlType für ein Page-Objekt ist acPage. Obwohl es sich um ein Steuerelement handelt, gehört ein Page-Objekt eher zu der Auflistung Pages als zu der Auflistung Controls. Die Auflistung Pages eines Registersteuerelements ist eine besondere Art der Auflistung Controls.

Jedes Page-Objekt kann auch ein oder mehrere Steuerelemente enthalten. Steuerelemente in einem Page-Objekt gehören zur Auflistung Controls dieses Page-Objekts. Wenn Sie mit einem Steuerelement in einem Page-Objekt arbeiten möchten, verweisen Sie auf dieses Steuerelement innerhalb der Auflistung Controls.


 Pages-Auflistung

Pages-Auflistung

Die Auflistung Pages enthält alle Page-Objekte in einem Registerkarten-Steuerelement.

Anmerkung

Die Auflistung Pages ist eine besondere Art der Auflistung Controls, die zu dem Registersteuerelement gehört. Sie enthält Page-Objekte, die Steuerelemente sind. Die Auflistung Pages unterscheidet sich von einer typischen Auflistung Controls dadurch, dass Sie Page-Objekte hinzufügen und löschen können, indem Sie Methoden der Auflistung Pages verwenden.

Wenn Sie in Visual Basic ein neues Page-Objekt zur Auflistung Pages hinzufügen möchten, verwenden Sie die Methode Add der Pages-Auflistung. Wenn Sie ein vorhandenes Page-Objekt entfernen möchten, verwenden Sie die Methode Remove der Pages-Auflistung. Wenn Sie die Anzahl der Page-Objekte in der Pages-Auflistung feststellen möchten, verwenden Sie die Eigenschaft Count der Pages-Auflistung.

Sie können die Methode CreateControl ebenfalls verwenden, um ein Page-Objekt zu der Pages-Auflistung eines Registersteuerelements hinzuzufügen. Zu diesem Zweck müssen Sie den Namen des Registersteuerelements für das Argument Parent der Funktion CreateControl angeben. Die Eigenschaftenkonstante ControlType für ein Page-Objekt ist acPage.

Sie können die Pages-Auflistung durchlaufen, indem Sie die For Each...Next-Anweisung verwenden.

Die einzelnen Page-Objekte in der Auflistung Pages sind, beginnend bei Null, indiziert.


 Properties-Auflistung

Properties-Auflistung

Die Properties-Auflistung enthält alle eingebauten Eigenschaften einer Instanz eines geöffneten Form-, Report- oder Control-Objekts. Diese Eigenschaften kennzeichnen die jeweilige Instanz des Objekts eindeutig.

Anmerkungen

Verwenden Sie die Properties-Auflistung in Visual Basic oder in einem Ausdruck, um auf Formular-, Berichts- oder Steuerelementeigenschaften der momentan geöffneten Formulare bzw. Berichte zu verweisen.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Mit Hilfe der Properties-Auflistung eines Objekts können Sie dessen eingebaute Eigenschaften in einer Schleife durchlaufen. Zu diesem Zweck müssen Sie nicht genau wissen, welche Eigenschaften vorhanden sind oder mit welchen Merkmalen (Name- und Value-Eigenschaft) sie bearbeitet werden sollen.

Anmerkung Zusätzlich zu den eingebauten Eigenschaften können Sie auch eigene benutzerdefinierte Eigenschaften erstellen und hinzufügen. Informationen darüber, wie eine benutzerdefinierte Eigenschaft einer vorhandenen Instanz eines Objekts hinzugefügt wird, finden Sie unter den Themen zur AccessObjectProperties-Auflistung und zur Add-Methode.


 Reference-Objekt

Reference-Objekt

Das Reference-Objekt stellt einen Verweis auf die Typbibliothek einer anderen Anwendung oder eines anderen Projekts dar.

Anmerkung

Wenn Sie ein Reference-Objekt erstellen, stellen Sie dynamisch über Visual Basic einen Verweis ein.

Das Reference-Objekt ist ein Element der Auflistung References. Wenn Sie auf ein bestimmtes Reference-Objekt in der Auflistung References verweisen möchten, verwenden Sie eine der folgenden Syntaxformen.

Syntax | Beschreibung
References!Verweisname | Das Argument Verweisname ist der Name des Reference-Objekts.
References("Verweisname") | Das Argument Verweisname ist der Name des Reference-Objekts.
References(Index) | Das Argument Index ist die numerische Position des Objekts in der Auflistung.

Das folgende Beispiel verweist auf das Reference-Objekt, das den Verweis auf die Typbibliothek von Microsoft Access darstellt:

Dim ref As Reference
Set ref = References!Access


References-Auflistung

Die References-Auflistung enthält Reference-Objekte, die alle aktuell eingestellten Verweise darstellen.

Anmerkung

Die Reference-Objekte in der Auflistung References entsprechen der Liste der Verweise im Dialogfeld Verweise. Sie öffnen das Dialogfeld, indem Sie im Menü Extras auf Verweise klicken. Jedes Reference-Objekt stellt einen ausgewählten Verweis in der Liste dar. Im Dialogfeld Verweise angezeigte aber nicht ausgewählte Verweise sind nicht in der Auflistung References enthalten.

Sie können die Auflistung References durchlaufen, indem Sie die Anweisung For Each...Next verwenden.

Die References-Auflistung gehört zum Microsoft Access-Objekt Application.

Die einzelnen Reference-Objekte in der Auflistung References sind, beginnend bei 1, indiziert.


 Report-Objekt

Report-Objekt

Ein Report-Objekt verweist auf einen bestimmten Microsoft Access-Bericht.

Anmerkung

Ein Report-Objekt ist ein Element der Auflistung Reports, einer Auflistung aller momentan geöffneten Berichte. Die einzelnen Berichte in der Auflistung Reports werden durch einen bei Null beginnenden Index nummeriert. Sie verweisen auf einzelne Report-Objekte in der Auflistung Reports über den Berichtsnamen oder über den Index des Berichts innerhalb der Auflistung. Enthält der Formularname Leerzeichen, so muss der Name in eckigen Klammern ([ ]) stehen.

Syntax | Beispiel
Reports!Berichtsname | Reports!Bestellbericht
Reports![Name des Berichts] | Reports![Bericht Bestellungen]
Reports("Berichtsname") | Reports("Bestellbericht")
Reports(Index) | Reports(0)

Jedes Report-Objekt verfügt über eine Auflistung Controls, die alle Steuerelemente des Berichts enthält. Sie verweisen auf ein Steuerelement in einem Bericht durch eine implizite oder explizite Referenz auf die Auflistung Controls. Der Code ist effizienter, wenn Sie implizit auf die Auflistung Controls verweisen. Die folgenden Beispiele zeigen zwei Möglichkeiten, um auf das Steuerelement NeueDaten im Bericht Bestellbericht zu verweisen.

' Impliziter Verweis.
Reports!Bestellbericht!NeueDaten
' Expliziter Verweis
Reports!Bestellbericht.Controls!NeueDaten


 Reports-Auflistung (Berichte)

Reports-Auflistung (Berichte)

Die Auflistung Reports enthält alle aktuell geöffneten Berichte einer Microsoft Access-Datenbank.

Anmerkung

Sie können die Auflistung Reports in Visual Basic oder in einem Ausdruck verwenden, um auf aktuell geöffnete Berichte zu verweisen. Beispielsweise können Sie die Auflistung Reports durchlaufen, um die Werte der Eigenschaften einzelner Berichte der Auflistung einzustellen oder zurückzugeben.

Tipp Die Anweisung For Each...Next ist hilfreich zum Durchlaufen einer Auflistung.

Sie verweisen auf ein bestimmtes Report-Objekt in der Auflistung Reports über den Berichtsnamen oder über den Index des Berichts innerhalb der Auflistung.

Die Auflistung Reports wird beginnend mit Null indiziert. Wenn Sie über den Index auf einen Bericht verweisen, ist der erste Bericht Reports(0), der zweite Bericht Reports(1), usw. Öffnen Sie beispielsweise zuerst Bericht1 und dann Bericht2, so erfolgen Verweise über den Index auf Bericht2 in der Auflistung Reports mit Reports(1). Wenn Sie anschließend Bericht1 schließen, erfolgen Verweise über den Index auf Bericht2 in der Auflistung Reports mit Reports(0).

Anmerkung Wenn Sie alle Berichte in der Datenbank (geöffnete und geschlossene) auflisten möchten, durchlaufen Sie die AllReports-Auflistung des CurrentProject-Objekts. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen eines Berichts zurückzugeben.

Sie können ein Report-Objekt aus der Auflistung Reports weder löschen noch zu ihr hinzufügen.


 Screen-Objekt (Bildschirm)

Screen-Objekt (Bildschirm)

Das Objekt Screen verweist auf das Formular, den Bericht oder das Steuerelement, das bzw. der momentan den Fokus hat.

Anmerkung

Sie können das Objekt Screen und seine Eigenschaften verwenden, um auf ein bestimmtes Formular, einen Bericht oder ein Steuerelement zu verweisen, das oder der den Fokus hat. Sie können z.B. das Objekt Screen mit der Eigenschaft ActiveForm verwenden, um auf das Formular im aktiven Fenster zu verweisen, ohne den Namen des Formulars zu kennen. Das folgende Beispiel zeigt den Namen des Formulars an, das sich im aktiven Fenster befindet.

MsgBox Screen.ActiveForm.Name

Das Verweisen auf das Objekt Screen macht ein Formular, einen Bericht oder ein Steuerelement nicht aktiv. Um ein Formular, einen Bericht oder ein Steuerelement aktiv zu machen, verwenden Sie die Aktion AuswählenObjekt des Objekts DoCmd.

Wenn Sie auf das Objekt Screen verweisen, obwohl kein aktives Formular, kein aktiver Bericht oder kein aktives Steuerelement vorhanden ist, gibt Microsoft Access einen Laufzeitfehler zurück. Wenn sich z.B. ein Standardmodul im aktiven Fenster befindet, gibt der Code im obigen Beispiel einen Fehler zurück.


 WebOptions-Objekt

WebOptions-Objekt

Ein WebOptions-Objekt verweist auf die zu einer bestimmten Microsoft Access-Datenzugriffsseite gehörigen Eigenschaften, welche die Weboption festlegen.

Anmerkung

Das Objekt beinhaltet Attribute einer Datenzugriffsseite, die Microsoft Access beim Speichern einer Datenzugriffsseite als Webseite oder beim Öffnen einer Webseite verwendet. Attribute lassen sich entweder anwendungsbezogen (globale Ebene) oder auf die Datenzugriffsseite bezogen lesen und schreiben. (Beachten Sie, dass sich die Attributwerte der verschiedenen Datenzugriffsseiten unterscheiden können, je nachdem, welchen Attributwert eine Datenzugriffsseite beim Speichern besaß.) Diejenigen Attribute, die sich auf die Ebene der Datenzugriffsseite beziehen, überschreiben die anwendungsbezogenen Attribute. Letzere sind im DefaultWebOptions-Objekt zusammengefasst.

Anmerkung

Verwenden Sie die WebOptions-Eigenschaft, um auf das WebOptions-Objekt zurückzugeben.

Vergessen Sie nicht, dass das Ändern eines seitenbezogenen Attributwerts automatisch bewirkt, dass dem Attribut auch auf der anwendungsbezogenen Ebene derselbe Wert zugewiesen wird. Deshalb sollten Sie die anwendungsbezogenen Werte einer gegebenen Datenzugriffseite während jeder Sitzung von dieser Seite wiederherstellen bzw. in ihr speichern.


Verzeichnis der Eigenschaften

Das folgende Verzeichnis gruppiert alle Eigenschaften nach Objekt oder Auflistung und listet sie alphabetisch auf. Ein Sternchen (*) zeigt an, dass die Eigenschaft in Microsoft Access 2000 hinzugefügt wurde.

Gruppiert nach Objekt oder Auflistung

AccessObject* | Err (VBA)
AccessObjectProperties* | Error (ADO)
AccessObjectProperty* | Error, Errors (DAO)
AllDataAccessPages* | Errors (ADO)
AllDatabaseDiagrams* | Field (ADO)
AllForms* | Field, Fields (DAO)
AllMacros* | Fields (ADO)
AllModules* | FileSearch*
AllQueries* | Form
AllReports* | Forms
AllStoredProcedures* | Group, Groups (DAO)
AllTables* | Index
AllViews* | Index, Indexes (DAO)
AnswerWizard | LanguageSettings*
Application | Module
Assistant | Modules
CodeData* | Parameter, Parameters (DAO)
CodeProject* | Parameters (ADO)
Collection (VBA) | Properties
ComAddIns* | Property, Properties (DAO)
Command (ADO) | Query
CommandBars | QueryDef, QueryDefs (DAO)
Connection (ADO) | Recordset (ADO)
Connection, Connections (DAO) | Recordset, Recordsets (DAO)
Container, Containers (DAO) | Reference
Control | References
Controls | Relation, Relations (DAO)
CurrentData* | Report
CurrentProject* | Reports
DataAccessPage* | Screen
DataAccessPages* | Table
Database, Databases (DAO) | TableDef, TableDefs (DAO)
DBEngine (DAO) | User, Users (DAO)
Debug (VBA) | VBE * (VBA)
DefaultWebOptions* | WebOptions*
DoCmd | Workspace, Workspaces (DAO)
Document, Documents (DAO) |

Alphabetisch sortiert

A

AbsolutePage (ADO) | AllowEdits
AbsolutePosition (ADO) | AllowFilters
AbsolutePosition (DAO) | AllowFullMenus
Action | AllowShortcutMenus
ActiveCommand (ADO) | AllowSpecialKeys
ActiveConnection (ADO) | AllowToolbarChanges
ActiveControl | AllowZeroLength
ActiveDatasheet | AllowZeroLength (DAO)
ActiveForm | AllPermissions (DAO)
ActiveReport | AppIcon
ActualSize (ADO) | Application
AfterDelConfirm | AppTitle
AfterInsert | Assistant
AfterUpdate | Attributes (ADO)
Alias | Attributes (DAO)
AllowAdditions | AutoActivate
AllowAutoCorrect | AutoCenter
AllowBreakIntoCode | AutoExpand
AllowBuiltInToolbars | AutoRepeat
AllowBypassKey | AutoResize
AllowDeletions | AutoTab

B

BackColor | BOF (ADO)
BackStyle | BOF (DAO)
BatchCollisionCount (DAO) | Bookmark
BatchCollisions (DAO) | Bookmark (ADO)
BatchSize (DAO) | Bookmark (DAO)
BeforeDelConfirm | Bookmarkable (DAO)
BeforeInsert | BorderColor
BeforeUpdate | BorderStyle
Bezeichnungsausrichtung | BorderWidth
BezeichnungsfeldX | BoundColumn
BezeichnungsfeldY | BuiltIn

C

CacheSize (ADO) | Connection (DAO)
CacheSize (DAO) | ConnectionString (ADO)
CacheStart (DAO) | ConnectionTimeout (ADO)
Cancel | Container (DAO)
CanGrow | ControlBox
CanShrink | ControlSource
Caption | ControlTipText
Class | ControlType
CloseButton | Count
Clustered (DAO) | Count (ADO)
CodeContextObject | Count (DAO)
CollatingOrder (DAO) | Count (VBA)
Column | CountOfDeclarationLines
ColumnCount | CountOfLines
ColumnHeadings | CurrentObjectName
ColumnHeads | CurrentObjectType
ColumnHidden | CurrentRecord
ColumnOrder | CurrentSectionLeft
ColumnWidth | CurrentSectionTop
ColumnWidths | CurrentView
CommandBars | CurrentX
CommandText (ADO) | CurrentY
CommandTimeout (ADO) | CursorLocation (ADO)
CommandType (ADO) | CursorType (ADO)
ConflictTable (DAO) | Cycle
Connect (DAO) |

D

Database Properties | DefaultUser (DAO)
Database (DAO) | DefaultValue
DataEntry | DefaultValue (DAO)
DataMember (ADO) | DefaultView
DatasheetBackColor | DefinedSize (ADO)
DatasheetCellsEffect | Description
DatasheetFontHeight | Description (ADO)
DatasheetFontItalic | Description (DAO)
DatasheetFontName | Description (VBA)
DatasheetFontUnderline | DesignMasterID (DAO)
DatasheetFontWeight | DestConnectStr
DatasheetForeColor | DestinationDB
DatasheetGridLinesBehavior | DestinationTable
DatasheetGridLinesColor | Direction (ADO)
DataSource (ADO) | Direction (DAO)
DataType | Dirty
DataUpdatable (DAO) | DisplayControl
DateCreated (DAO) | DisplayType
DateGrouping | DisplayWhen
DBEngine | DistinctCount (DAO)
DecimalPlaces | DividingLines
Default | DrawMode
DefaultCursorDriver (DAO) | DrawStyle
DefaultDatabase (ADO) | DrawWidth
DefaultType (DAO) |

E-F

EditMode (ADO) | FontItalic
EditMode (DAO) | FontName
Enabled | FontSize
EnterKeyBehavior | FontUnderline
EOF (ADO) | FontWeight
EOF (DAO) | ForceNewPage
EventProcPrefix | ForeColor
FailOnError | Foreign (DAO)
FastLaserPrinting | ForeignName (DAO)
Feldgröße | ForeignTable (DAO)
Feldname | Form
FieldSize (DAO) | Format
FillColor | Format - Datentyp Datum/Uhrzeit
FillStyle | Format - Datentyp Ja/Nein
Filter | Format - Datentypen Text und Memo
Filter (ADO) | Format - Datentypen Zahl und Währung
Filter (DAO) | FormatCount
FilterLookup | FrozenColumns
FilterOn | FullPath
FontBold |

G-H

GridX | HelpContext (ADO)
GridY | HelpContext (DAO)
GroupFooter | HelpContext (VBA)
GroupHeader | HelpContextID
GroupInterval | HelpFile
GroupLevel | HelpFile (ADO)
GroupOn | HelpFile (DAO)
GrpKeepTogether | HideDuplicates
GUID | HWnd
HasContinued | Hyperlink
HasData | HyperlinkAddress
HasModule | HyperlinkSubAddress
Height |

I-K

IgnoreNulls | IsBroken
IgnoreNulls (DAO) | IsolateODBCTrans (DAO)
ImageHeight | IsolationLevel (ADO)
ImageWidth | IsVisible
Index (ADO) | Item (Auflistungen)
Index (DAO) | Item (Objektfeld-Steuerelement)
Indexed | ItemData
Inherit (DAO) | KeepLocal (DAO)
Inherited (DAO) | KeepTogether - Bereiche
IniPath (DAO) | KeepTogether - Gruppen
InputMask | KeyPreview
InSelection | Kind
InsideHeight |
InsideWidth |

L

LastDLLError (VBA) | ListIndex
LastModified (DAO) | ListRows
LastUpdated (DAO) | ListWidth
LayoutForPrint | Locked
Left | LockEdits (DAO)
LimitToList | LockType (ADO)
Lines | LoginTimeout (DAO)
LineSlant | LogMessages
LinkChildFields | LogMessages (DAO)
LinkMasterFields | LpOLEObject
ListCount |

M-N

Major | MoveLayout
MarshalOptions (ADO) | MultiRow
MaxRecords | MultiSelect
MaxRecords (ADO) | Name
MaxRecords (DAO) | Name (ADO)
MDE | Name (DAO)
Me | NativeError (ADO)
MenuBar | NavigationButtons
MinMaxButtons | NewRecord
Minor | NewRowOrCol
MitBezeichnungsfeld | NewValues
MitDoppelpunkt | NoMatch (DAO)
Modal | Number (ADO)
Mode (ADO) | Number (DAO)
Module | Number (VBA)
MousePointer | NumericScale (ADO)

O

Object Properties | OnFormat
Object | OnLostFocus
ObjectPalette | OnMouseDown
ObjectVerbs | OnMouseMove
ObjectVerbsCount | OnMouseUp
ODBCConnectStr | OnNoData
ODBCTimeout | OnNotInList
ODBCTimeout (DAO) | OnOpen
OldValue | OnPage
OLEClass | OnPrint
OLEData | OnResize
OLEType | OnRetreat
OLETypeAllowed | OnTimer
OnActivate | OnUnload
OnChange | OnUpdated
OnClick | OpenArgs
OnClose | OptionValue
OnCurrent | OrderBy
OnDblClick | OrderByOn
OnDeactivate | OrdinalPosition (DAO)
OnDelete | OriginalValue (ADO)
OnEnter | OriginalValue (DAO)
OnError | OutputAllFields
OnExit | Owner (DAO)

P

Page | PictureType
PageCount (ADO) | PID (DAO)
PageFooter | PopUp
PageHeader | Precision (ADO)
PageIndex | Prepare (DAO)
Pages | Prepared (ADO)
PageSize (ADO) | PreviousControl
Painting | Primary
PaintPalette | Primary (DAO)
PaletteSource | PrintCount
Parent | PrintSection
PartialReplica (DAO) | ProcBodyLine
Password (DAO) | ProcCountLines
PercentPosition (DAO) | ProcOfLine
Permissions (DAO) | ProcStartLine
Picture | ProjectName
PictureAlignment | Properties
PictureData | Provider (ADO)
PicturePages | PrtDevMode
PictureSizeMode | PrtDevNames
PictureTiling | PrtMip

Q-R

QueryTimeout (DAO) | ReplicationConflictFunction
RecordCount (ADO) | Report
RecordCount (DAO) | Required
RecordLocks | Required (DAO)
RecordsAffected (DAO) | Restartable (DAO)
RecordSelectors | ReturnsRecords
RecordsetClone | ReturnsRecords (DAO)
RecordsetType | RowHeight
RecordSource | RowSource
RepeatSection | RowSourceType
Replicable (DAO) | RunningSum
ReplicaFilter (DAO) | RunPermissions
ReplicaID (DAO) |

S

ScaleHeight | Source (VBA)
ScaleLeft | SourceConnectStr
ScaleMode | SourceDatabase
ScaleTop | SourceDoc
ScaleWidth | SourceField (DAO)
ScrollBars | SourceItem
Section | SourceObject
Selected | SourceTable (DAO)
SelHeight | SourceTableName (DAO)
SelLeft | SpecialEffect
SelLength | SQL (DAO)
SelStart | SQLState (ADO)
SelText | StartupForm
SelTop | StartupMenuBar
SelWidth | StartupShortcutMenuBar
ShortcutMenu | StartupShowDBWindow
ShortcutMenuBar | StartupShowStatusBar
Size (DAO) | State (ADO)
SizeMode | Status (ADO)
Sort (ADO) | StatusBarText
Sort (DAO) | StayInSync (ADO)
SortOrder | StillExecuting (DAO)
Source | Style
Source (ADO, Error-Objekt) | SystemDB (DAO)
Source (ADO, Recordset-Objekt) |
Source (DAO) |

T-U

TabFixedHeight | Type
TabFixedWidth | Type (ADO)
TabIndex | Type (DAO)
Table (DAO) | UnderlyingValue (ADO)
TabStop | Unique
Tag | Unique (DAO)
Text | UniqueRecords
TextAlign | UniqueValues
TimerInterval | Updatable (DAO)
Toolbar | UpdateOptions
Top | UpdateOptions (DAO)
TopValues | UserControl
Transactions (DAO) | UserName (DAO)
Transparent | UseTransaction
TripleState |

V-Z

V1xNullBehavior (DAO) | Version (DAO)
ValidateOnSet (DAO) | ViewsAllowed
ValidationRule | Visible
ValidationRule (DAO) | Visible (Application-Objekt)
ValidationText | VisibleValue (DAO)
ValidationText (DAO) | WhatsThisButton
Value | WhatsThisButton (VBA)
Value (ADO) | Width
Value (DAO) | WillContinue
Verb | WindowHeight
Version (ADO) | WindowWidth


 Neue Eigenschaften (Alphabetische Liste)

Neue Eigenschaften (Alphabetische Liste)

Die folgende Liste enthält Eigenschaften (in alphabetischer Reihenfolge), die vorhandenen Objekten in Microsoft Access 2000 hinzugefügt wurden.

A-G

ActiveDataAccessPage

Address

AllDataAccessPages

AllDatabaseDiagrams

AllForms

AllMacros

AllModules

AllowDesignChanges

AllQueries

AllReports

AllStoredProcedures

AllTables

AllViews

AlwaysSaveInDefaultEncoding

AnswerWizard

BaseConnectionString

BottomMargin

CheckIfOfficeHTMLEditor

CodeData

CodeProject

 COMAddIns

Connection

ConnectionString

CurrentData

CurrentProject

DataAccessPages

DefaultWebOptions

Document

DownloadComponents

EmailSubject

Enabled (FormatCondition-Objekt)

Encoding

Expression1

Expression2

FeatureInstall

FolderSuffix

FileSearch

FollowedHyperlinkColor

FormatConditions

FullName

H-P

HyperlinkColor

InputParameters

IsConnected

IsHyperlink

IsLoaded

ItemsSelected

LanguageSettings

LeftMargin

LineSpacing

LocationOfComponents

 MaxRecButton

Operator (FormatCondition-Objekt)

OrganizeInFolder

Path

ProductCode

ProjectType

Properties Property (AccessObjectProperties-Auflistung)

Properties Property (Properties-Auflistung)

Q-Z

Recordset

ResyncCommand

RightMargin

ScreenTip

ServerFilter

ServerFilterByForm

SubAddress

SubdatasheetExpanded

SubdatasheetHeight

SubdatasheetName

 TextToDisplay

TopMargin

Type (AccessObject-Objekt)

Type (FormatCondition-Objekt)

UnderlineHyperlinks

UniqueTable

UseLongFileNames

VBE

Vertical

WebOptions

Microsoft Office-Eigenschaften

Um die Liste der neuen Eigenschaften in der Microsoft Office 9.0-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Office Visual Basic-Referenz.

Wenn Sie die von Microsoft Office bereitgestellten Objekte verwenden möchten, richten Sie bei geöffnetem Visual Basic-Editor einen Verweis auf die Microsoft Office 9.0-Objektbibliothek ein, indem Sie im Menü Extras auf Verweise klicken und das entsprechende Kontrollkästchen aktivieren.

Microsoft Visual Basic-Editor-Eigenschaften

Um die Liste der neuen Eigenschaften in der Microsoft Visual Basic für Applikationen Extensibility 5.3-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Visual Basic-Referenz.

Wenn Sie die vom Microsoft Visual Basic-Editor bereitgestellten Eigenschaften verwenden möchten, richten Sie einen Verweis auf die Microsoft Visual Basic für Applikationen Extensibility 5.3-Objektbibliothek ein. Zu diesem Zweck öffnen Sie den Visual Basic-Editor, klicken im Menü Extras auf Verweise und aktivieren dann das entsprechende Kontrollkästchen.


ActiveX-Steuerelement - Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein ActiveX-Steuerelement einstellen können.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BorderColor | Object
BorderStyle | OLEClass
BorderWidth | OnEnter (NF)
Class | OnExit (NF)
ControlSource | OnGotFocus (NF)
ControlTipText | OnLostFocus (NF)
ControlType | OnUpdated (NF)
Custom | SpecialEffect
DisplayWhen (NF) | TabIndex (NF)
Enabled (NF) | TabStop (NF)
Height | Tag
HelpContextID (NF) | Top
InSelection (NF) | Verb
Left | Visible
Locked (NF) | Width
Name |


Befehlsschaltflächen-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für eine Befehlsschaltfläche einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AutoRepeat (NF) | Name
Bezeichnungsausrichtung | OnClick (NF)
BezeichnungsfeldX | OnDblClick (NF)
BezeichnungsfeldY | OnEnter (NF)
Cancel (NF) | OnExit (NF)
Caption | OnGotFocus (NF)
ControlTipText (NF) | OnKeyDown (NF)
ControlType | OnKeyPress (NF)
Default | OnKeyUp (NF)
DisplayWhen (NF) | OnLostFocus (NF)
Enabled (NF) | OnMouseDown (NF)
FontItalic | OnMouseMove (NF)
FontName | OnMouseUp (NF)
FontSize | Picture
FontUnderline | PictureType
FontWeight | ShortcutMenuBar
ForeColor | StatusBarText (NF)
Height | TabIndex (NF)
HelpContextID (NF) | TabStop (NF)
HyperlinkAddress | Tag
HyperlinkSubAddress | Top
InSelection (NF) | Transparent
Left | Visible
MitBezeichnungsfeld | Width
MitDoppelpunkt |


Bezeichnungsfeld-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Bezeichnungsfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BackColor | InSelection (NF)
BackStyle | Left
BorderColor | LeftMargin
BorderStyle | LineSpacing
BorderWidth | Name
BottomMargin | OnClick (NF)
Caption | OnDblClick (NF)
ControlTipText (NF) | OnMouseDown (NF)
ControlType | OnMouseMove (NF)
DisplayWhen (NF) | OnMouseUp (NF)
FontItalic | RightMargin
FontName | ShortcutMenuBar
FontSize | SpecialEffect
FontUnderline | Tag
FontWeight | TextAlign
ForeColor | Top
Height | TopMargin
HelpContextID | Vertical
HyperlinkAddress | Visible
HyperlinkSubAddress | Width


Bild-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Bild einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BackColor | OnDblClick (NF)
BackStyle | OnMouseDown (NF)
BorderColor | OnMouseMove (NF)
BorderStyle | OnMouseUp (NF)
BorderWidth | Picture
ControlTipText (NF) | PictureAlignment
ControlType | PictureTiling (NF)
DisplayWhen (NF) | PictureType
Height | ShortcutMenuBar
HelpContextID | SizeMode
HyperlinkAddress | SpecialEffect
HyperlinkSubAddress | Tag
InSelection (NF) | Top
Left | Visible
Name | Width
OnClick (NF) |


DDE-Funktionen und -Anweisungen

DDE-Funktion

DDEExecute-Anweisung

DDEInitiate-Funktion (DDEInit)

DDEPoke-Anweisung

DDERequest-Funktion (DDEAnfrage)

DDESend-Funktion (DDESenden)

DDETerminate-Anweisung

DDETerminateAll-Anweisung


Diagramm-Eigenschaften (Formulare und Berichte)

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Diagramm einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AfterUpdate (NF) | OnClick (NF)
AutoActivate (NF) | OnDblClick (NF)
BackColor | OnEnter (NF)
BackStyle | OnExit (NF)
BeforeUpdate (NF) | OnGotFocus (NF)
Bezeichnungsausrichtung | OnKeyDown (NF)
BezeichnungsfeldX | OnKeyPress (NF)
BezeichnungsfeldY | OnKeyUp (NF)
BorderColor | OnLostFocus (NF)
BorderStyle | OnMouseDown (NF)
BorderWidth | OnMouseMove (NF)
Class | OnMouseUp (NF)
ColumnCount | OnUpdated (NF)
ColumnHeads | RowSource
ControlSource | RowSourceType
ControlTipText | ShortcutMenuBar
ControlType | SizeMode
DisplayType | SourceDoc
DisplayWhen (NF) | SourceItem
Enabled (NF) | SpecialEffect
Height | StatusBarText (NF)
HelpContextID (NF) | TabIndex (NF)
InSelection (NF) | TabStop (NF)
Left | Tag
LinkChildFields | Top
LinkMasterFields | UpdateOptions
Locked (NF) | Verb
MitBezeichnungsfeld | Visible
MitDoppelpunkt | Width
Name |
OLETypeAllowed |


Gebundene Objektfelder - Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein gebundenes Objektfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

A-O

AfterUpdate (NF) | InSelection (NF)
AutoActivate (NF) | Left
BackColor | Locked (NF)
BackStyle | MitBezeichnungsfeld
BeforeUpdate (NF) | MitDoppelpunkt
Bezeichnungsausrichtung | Name
BezeichnungsfeldX | OLETypeAllowed
BezeichnungsfeldY | OnClick (NF)
BorderColor | OnDblClick (NF)
BorderStyle | OnEnter (NF)
BorderWidth | OnExit (NF)
Class | OnGotFocus (NF)
ControlSource | OnKeyDown (NF)
ControlTipText | OnKeyPress (NF)
ControlType | OnKeyUp (NF)
DisplayType | OnLostFocus (NF)
DisplayWhen (NF) | OnMouseDown (NF)
Enabled (NF) | OnMouseMove (NF)
Height | OnMouseUp (NF)
HelpContextID (NF) | OnUpdated (NF)

P-Z

ShortcutMenuBar | TabStop (NF)
SizeMode | Tag
SourceDoc | Top
SourceItem | UpdateOptions
SpecialEffect | Verb
StatusBarText (NF) | Visible
TabIndex (NF) | Width


Kombinationsfeld-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Kombinationsfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

A-M

AfterUpdate (NF) | DisplayWhen (NF)
AllowAutoCorrect | Enabled (NF)
AutoExpand | FontItalic
BackColor | FontName
BackStyle | FontSize
BeforeUpdate (NF) | FontUnderline
Bezeichnungsausrichtung | FontWeight
BezeichnungsfeldX | ForeColor
BezeichnungsfeldY | Format
BorderColor | Height
BorderStyle | HelpContextID (NF)
BorderWidth | InputMask
BoundColumn | InSelection (NF)
Column | IsHyperlink
ColumnCount | ItemData
ColumnHeads | Left
ColumnWidths | LimitToList
ControlSource | ListRows
ControlTipText (NF) | ListWidth
ControlType | Locked (NF)
DecimalPlaces | MitBezeichnungsfeld
DefaultValue (NF) | MitDoppelpunkt

N-Z

Name | RowSource
OnChange (NF) | RowSourceType
OnClick (NF) | ShortcutMenuBar
OnDblClick (NF) | SpecialEffect
OnEnter (NF) | StatusBarText (NF)
OnExit (NF) | TabIndex (NF)
OnGotFocus (NF) | TabStop (NF)
OnKeyDown (NF) | Tag
OnKeyPress (NF) | TextAlign
OnKeyUp (NF) | Top
OnLostFocus (NF) | ValidationRule (NF)
OnMouseDown (NF) | ValidationText (NF)
OnMouseMove (NF) | Visible
OnMouseUp (NF) | Width
OnNotInList (NF) |


Kontrollkästchen-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Kontrollkästchen einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AfterUpdate (NF) | OnDblClick (NF)
BeforeUpdate (NF) | OnEnter (NF)
Bezeichnungsausrichtung | OnExit (NF)
BezeichnungsfeldX | OnGotFocus (NF)
BezeichnungsfeldY | OnKeyDown (NF)
BorderColor | OnKeyPress (NF)
BorderStyle | OnKeyUp (NF)
BorderWidth | OnLostFocus (NF)
ControlSource | OnMouseDown (NF)
ControlTipText | OnMouseMove (NF)
ControlType | OnMouseUp (NF)
DefaultValue (NF) | ShortcutMenuBar
DisplayWhen (NF) | SpecialEffect
Enabled (NF) | StatusBarText (NF)
Height | TabIndex (NF)
HelpContextID (NF) | TabStop (NF)
InSelection (NF) | Tag
Left | Top
Locked (NF) | TripleState
MitBezeichnungsfeld | ValidationRule (NF)
MitDoppelpunkt | ValidationText (NF)
Name | Visible
OnClick (NF) | Width


Linie-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für eine Linie einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BorderColor | LineSlant
BorderStyle | Name
BorderWidth | SpecialEffect
ControlType | Tag
DisplayWhen (NF) | Top
Height | Visible
InSelection (NF) | Width
Left |


Listenfeld-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Listenfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

A-M

AfterUpdate (NF) | DisplayWhen (NF)
BackColor | Enabled (NF)
BeforeUpdate (NF) | FontItalic
Bezeichnungsausrichtung | FontName
BezeichnungsfeldX | FontSize
BezeichnungsfeldY | FontUnderline
BorderColor | FontWeight
BorderStyle | ForeColor
BorderWidth | Height
BoundColumn | HelpContextID (NF)
Column (NF) | InSelection (NF)
ColumnCount | ItemData
ColumnHeads | Left
ColumnWidths | Locked (NF)
ControlSource | MitBezeichnungsfeld
ControlTipText (NF) | MitDoppelpunkt
ControlType | MultiSelect
DefaultValue (NF) |

N-Z

Name | RowSourceType
OnClick (NF) | ShortcutMenuBar
OnDblClick (NF) | SpecialEffect
OnEnter (NF) | StatusBarText (NF)
OnExit (NF) | TabIndex (NF)
OnGotFocus (NF) | TabStop (NF)
OnKeyDown (NF) | Tag
OnKeyPress (NF) | TextAlign
OnKeyUp (NF) | Top
OnLostFocus (NF) | ValidationRule (NF)
OnMouseDown (NF) | ValidationText (NF)
OnMouseMove (NF) | Visible
OnMouseUp (NF) | Width
RowSource |


Optionsfeld-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Optionsfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AfterUpdate (NF) | OnDblClick (NF)
BeforeUpdate (NF) | OnEnter (NF)
Bezeichnungsausrichtung | OnExit (NF)
BezeichnungsfeldX | OnGotFocus (NF)
BezeichnungsfeldY | OnKeyDown (NF)
BorderColor | OnKeyPress (NF)
BorderStyle | OnKeyUp (NF)
BorderWidth | OnLostFocus (NF)
ControlSource | OnMouseDown (NF)
ControlTipText (NF) | OnMouseMove (NF)
ControlType | OnMouseUp (NF)
DefaultValue (NF) | ShortcutMenuBar
DisplayWhen (NF) | SpecialEffect
Enabled (NF) | StatusBarText (NF)
Height | TabIndex (NF)
HelpContextID (NF) | TabStop (NF)
InSelection (NF) | Tag
Left | Top
Locked (NF) | TripleState
MitBezeichnungsfeld | ValidationRule (NF)
MitDoppelpunkt | ValidationText (NF)
Name | Visible
OnClick (NF) | Width


Optionsgruppe-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für eine Optionsgruppe einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AfterUpdate (NF) | MitBezeichnungsfeld
BackColor | MitDoppelpunkt
BackStyle | Name
BeforeUpdate (NF) | OnClick (NF)
Bezeichnungsausrichtung | OnDblClick (NF)
BezeichnungsfeldX | OnEnter (NF)
BezeichnungsfeldY | OnExit (NF)
BorderColor | OnMouseDown (NF)
BorderStyle | OnMouseMove (NF)
BorderWidth | OnMouseUp (NF)
ControlSource | ShortcutMenuBar
ControlTipText (NF) | SpecialEffect
ControlType | StatusBarText (NF)
DefaultValue (NF) | TabIndex (NF)
DisplayWhen (NF) | TabStop (NF)
Enabled (NF) | Tag
Height | Top
HelpContextID (NF) | ValidationRule (NF)
InSelection | ValidationText (NF)
Left | Visible
Locked (NF) | Width


Rechteck-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Rechteck einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BackColor | OnClick (NF)
BackStyle | OnDblClick (NF)
BorderColor | OnMouseDown (NF)
BorderStyle | OnMouseMove (NF)
BorderWidth | OnMouseUp (NF)
ControlType | SpecialEffect
DisplayWhen (NF) | Tag
Height | Top
InSelection (NF) | Visible
Left | Width
Name |


Registersteuerelement - Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Registersteuerelement einstellen können.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

BackStyle | OnKeyDown (NF)
ControlType | OnKeyPress (NF)
DisplayWhen | OnKeyUp (NF)
Enabled | OnMouseDown
FontItalic | OnMouseMove
FontName | OnMouseUp
FontSize | ShortcutMenuBar
FontUnderline | StatusBarText
FontWeight | Style
Height | TabFixedHeight
HelpContextID | TabFixedWidth
InSelection | TabIndex
Left | TabStop
MultiRow | Tag
Name | Top
OnChange | Visible
OnClick | Width
OnDblClick |


Seitenwechsel-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für einen Seitenwechsel einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

ControlType Name
InSelection (NF) Tag


 Steuerelementeigenschaften für Datenzugriffsseiten

Steuerelementeigenschaften für Datenzugriffsseiten

Die folgende Liste enthält die Dynamic HTML-Eigenschaften, Microsoft Access-Eigenschaften, Eigenschaften für Access-Elementerweiterungen sowie die Webeigenschaften, die Sie für ein Steuerelement einstellen können, wenn dieses in einer Datenzugriffsseite verwendet wird.

Klicken Sie auf einen der Namen unten, um zusätzliche Informationen zu der betreffenden Eigenschaft anzuzeigen. Diese Eigenschaften können im Eigenschaftenfenster oder im Microsoft Skript-Editor eingestellt werden.

AccessKey | DisplayGridlines | Overflow
Align | DisplayHorizontalScrollBox | Port
AlinkColor | DisplayPropertyToolbox | Position
AllowDetails | DisplayRowHeaders | ProviderType
AllowFiltering | DisplayTitleBar | ReadOnly
AllowGrouping | DisplayToolbar | RecordsetLabel
AllowPropertyToolbox | DisplayVerticalScrollBar | RecordSource
Alt | Dynsrc | ResyncCommand
AlternateDataSource | ElementID | RightMargin
AltHtml | EnableAutoCalculate | RightToLeft
AutoFit | EnableEvents | ScreenUpdating
BackColor | FgColor | Scroll
BackgroundColor | FileModifiedDate | ScrollAmount
BackgroundImage | FileUpdatedDate | ScrollDelay
BackgroundPositionX | FontFamily | SelectionType
BackgroundPositionY | FontSize | ShowDelButton
BackgroundRepeat | FontStyle | ShowFilterBySelectionButton
Behavior | FontVariant | ShowFirstButton
BGProperties | FontWeight | ShowLastButton
BorderColor | GridX | ShowNewButton
BorderStyle | GridY | ShowNextButton
BorderWidth | HasChartspaceLegend | ShowPrevButton
BottomMargin | HasChartspaceTitle | ShowSaveButton
BuildNumber | HasDetails | ShowSortAscendingButton
CanUndo | Height | ShowSortDescendingButton
Caption | Host | ShowToggleFilterButton
ChartLayout | Href | ShowUndoButton
ChartWrapCount | Hspace | Size
Checked | HTMLURL | Src
ChildLabel | Id | Start
ClassName | Indeterminate | Status
Code | IsExpanded | TabIndex
CodeBase | IsMap | TagName
CodeType | Lang | Target
Color | Left | TextAlign
CommandText | Length | Title
ConnectionString | LinkColor | Top
ConsumesRecordset | ListBoundField | TotalType
ControlSource | ListDisplayField | TrueSpeed
DataFormatAs | ListRowSource | Type
DataMember | Loop | UniqueTable
DataSourceType | Lowsrc | UseMap
Datatype | MajorVersion | UseRemoteProvider
DefaultChecked | MaxHeight | Value
DefaultValue | MaxWidth | Version
Dir | MemberExpand | ViewableRange
Direction | MinorVersion | Visibility
Disabled | MoveAfterReturn | VlinkColor
Display | MoveAfterReturnDirection | Vspace
DisplayColHeaders | Multiple | Width
DisplayExpandIndicator | NoShade | Zindex
DisplayFieldList | NoWrap |


Textfeld-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Textfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

A-N

AfterUpdate (NF) | EnterKeyBehavior (NF)
AllowAutoCorrect | FilterLookup
AutoTab (NF) | FontBold
BackColor | FontItalic
BackStyle | FontName
BeforeUpdate (NF) | FontSize
Bezeichnungsausrichtung | FontUnderline
BezeichnungsfeldX | FontWeight
BezeichnungsfeldY | ForeColor
BorderColor | Format
BorderStyle | Height
BorderWidth | HelpContextID (NF)
BottomMargin | InputMask
CanGrow | InSelection (NF)
CanShrink | IsHyperlink
ControlSource | Left
ControlTipText (NF) | LeftMargin
ControlType | LineSpacing
DecimalPlaces | Locked (NF)
DefaultValue (NF) | MitBezeichnungsfeld
DisplayWhen (NF) | MitDoppelpunkt
Enabled (NF) | Name

O-P

OnChange (NF) | ShortcutMenuBar
OnClick (NF) | SpecialEffect
OnDblClick (NF) | StatusBarText (NF)
OnEnter (NF) | TabIndex (NF)
OnExit (NF) | TabStop (NF)
OnGotFocus (NF) | Tag
OnKeyDown (NF) | TextAlign
OnKeyPress (NF) | Top
OnKeyUp (NF) | TopMargin
OnLostFocus (NF) | ValidationRule (NF)
OnMouseDown (NF) | ValidationText (NF)
OnMouseMove (NF) | Vertical
OnMouseUp (NF) | Visible
RightMargin | Width
ScrollBars (NF) |


Umschaltfläche-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für eine Umschaltfläche einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AfterUpdate (NF) | OnClick (NF)
BeforeUpdate (NF) | OnDblClick (NF)
Bezeichnungsausrichtung | OnEnter (NF)
BezeichnungsfeldX | OnExit (NF)
BezeichnungsfeldY | OnGotFocus (NF)
Caption | OnKeyDown (NF)
ControlSource | OnKeyPress (NF)
ControlTipText (NF) | OnKeyUp (NF)
ControlType | OnLostFocus (NF)
DefaultValue (NF) | OnMouseDown (NF)
DisplayWhen (NF) | OnMouseMove (NF)
Enabled (NF) | OnMouseUp (NF)
FontItalic | Picture
FontName | PictureType
FontSize | ShortcutMenuBar
FontUnderline | StatusBarText (NF)
FontWeight | TabIndex (NF)
ForeColor | TabStop (NF)
Height | Tag
HelpContextID (NF) | Top
InSelection (NF) | TripleState
Left | ValidationRule (NF)
Locked (NF) | ValidationText (NF)
MitBezeichnungsfeld | Visible
MitDoppelpunkt | Width
Name |


Ungebundene Objektfelder - Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein ungebundenes Objektfeld einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

AutoActivate (NF) | OnDblClick (NF)
BackColor | OnEnter (NF)
BackStyle | OnExit (NF)
BorderColor | OnGotFocus (NF)
BorderStyle | OnLostFocus (NF)
BorderWidth | OnMouseDown (NF)
Class | OnMouseMove (NF)
ColumnCount | OnMouseUp (NF)
ColumnHeads | OnUpdated (NF)
ControlTipText (NF) | RowSource
ControlType | RowSourceType
DisplayType | ShortcutMenuBar
DisplayWhen (NF) | SizeMode
Enabled (NF) | SourceDoc
Height | SourceItem
HelpContextID (NF) | SpecialEffect
InSelection (NF) | StatusBarText
Left | TabIndex (NF)
LinkChildFields | TabStop (NF)
LinkMasterFields | Tag
Locked (NF) | Top
Name | UpdateOptions
OLEClass | Verb
OLEType | Visible
OLETypeAllowed | Width
OnClick (NF) |


Unterformular/Unterbericht-Eigenschaften

In der folgenden Liste sind die Eigenschaften aufgeführt, die Sie für ein Unterformular bzw. einen Unterbericht einstellen können. Eigenschaften, die nur gelten, wenn sich das Steuerelement in einem Formular befindet, sind mit (NF) für "Nur Formulare" gekennzeichnet.

Zum Anzeigen weiterer Informationen über die betreffende Eigenschaft, klicken Sie auf einen Namen in der Liste, z.B. weitere Beschränkungen zu ihrer Verfügbarkeit, und ob Sie die Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen können.

Bezeichnungsausrichtung | Locked (NF)
BezeichnungsfeldX | MitBezeichnungsfeld
BezeichnungsfeldY | MitDoppelpunkt
BorderColor | Name
BorderStyle | OnEnter (NF)
BorderWidth | OnExit (NF)
CanGrow | SourceObject
CanShrink | SpecialEffect
ControlType | StatusBarText (NF)
DisplayWhen (NF) | TabIndex (NF)
Enabled (NF) | TabStop (NF)
Height | Tag
InSelection (NF) | Top
Left | Visible
LinkChildFields | Width
LinkMasterFields |


Verzeichnis der Abfrageeigenschaften

Jede Abfrage verfügt über Eigenschafteneinstellungen, die Sie ändern können, um die Funktionsweise der Abfrage und das Aussehen des Abfrageergebnisses zu beeinflussen.

Weitere Informationen über eine Abfrageeigenschaft erhalten Sie, wenn Sie auf einen der folgenden Eigenschaftennamen klicken. Ein Sternchen (*) zeigt an, dass die Eigenschaft Abfragefelder oder Feldlisten betrifft. Eine Eigenschaft ohne Sternchen betrifft die Abfrage als ganzes.

Alias* | ODBCTimeout
Caption* | OrderBy
ColumnHeadings | OrderByOn
Description | OutputAllFields
DestConnectStr | RecordLocks
DestinationDB | RecordsetType
DestinationTable | ReturnsRecords
DisplayControl* | RunPermissions
FailOnError | Source*
Filter | SourceConnectStr
Format* | SourceDatabase
FrozenColumns | SubdatasheetExpanded
InputMask* | SubdatasheetHeight
LinkChildFields | SubdatasheetName
LinkMasterFields | TopValues
LogMessages | UniqueRecords
MaxRecords | UniqueValues
ODBCConnectStr | UseTransaction


Verzeichnis der Feldeigenschaften

Jedes Feld verfügt über Eigenschafteneinstellungen, die Sie ändern können, um Funktionsweise und Aussehen des Feldes zu beeinflussen. Die für ein Feld verfügbaren Eigenschaften hängen vom Datentyp des Feldes ab.

Weitere Informationen über eine Feldeigenschaft erhalten Sie, wenn Sie auf einen der nachstehenden Eigenschaftennamen klicken.

AllowZeroLength | FrozenColumns
BorderColor | IgnoreNulls
BorderStyle | Indexed
BorderWidth | InputMask
BoundColumn | LimitToList
Caption | ListRows
ColumnCount | ListWidth
ColumnHeads | NewValues
ColumnHidden | Primary
ColumnOrder | PrtDevModes
ColumnWidth | PrtDevNames
ColumnWidths | PrtMip
DatasheetCellsEffect | Required
DatasheetGridlinesBehavior | RowSource
DataType | RowSourceType
DecimalPlaces | SelHeight
DefaultValue | SelTop
Description | SortOrder
DisplayControl | SpecialEffect
Feldgröße | Unique
Feldname | ValidationRule
ForeColor | ValidationText
Format |


 Verzeichnis der Steuerelementeigenschaften

Verzeichnis der Steuerelementeigenschaften

Jedes Steuerelement besitzt Eigenschafteneinstellungen, die Sie ändern können, um sein Aussehen und Verhalten zu ändern.

Sie können die Standardeigenschafteneinstellungen ändern, bevor Sie ein Steuerelement einem Formular oder Bericht hinzufügen, oder Sie können die Eigenschafteneinstellungen für ein Steuerelement ändern, das sich bereits auf einem Formular oder Bericht befindet.

Zum Anzeigen weiterer Informationen zu einer Steuerelementeigenschaft klicken Sie auf einen Steuerelementnamen in der Liste.

ActiveX | Optionsfeld
Befehlsschaltfläche | Optionsgruppe
Bezeichnung | Rechteck
Bild | Register
Diagramm | Seitenwechsel
Gebundenes Objektfeld | Textfeld
Kombinationsfeld | Umschaltfläche
Kontrollkästchen | Ungebundenes Objektfeld
Linie | Unterformular/-bericht
Listenfeld |


Verzeichnis der Tabelleneigenschaften

Jede Tabelle verfügt über Eigenschafteneinstellungen, die Sie ändern können, um Funktionsweise und Aussehen der Tabelle zu beeinflussen.

Weitere Informationen über eine Tabelleneigenschaft erhalten Sie, wenn Sie auf einen der nachstehenden Eigenschaftennamen klicken.

Description | SubdatasheetExpanded
Filter | SubdatasheetHeight
LinkChildFields | SubdatasheetName
LinkMasterFields | ValidationRule
OrderBy | ValidationText


 Action-Eigenschaft

Action-Eigenschaft

Mit der Eigenschaft Action können Sie in Visual Basic die Operation angeben, die an einem OLE-Objekt durchgeführt werden soll.

Einstellung

Die Eigenschaft Action verwendet die folgenden Einstellungen.

Konstante | Beschreibung
acOLECreateEmbed (0) | Erstellt ein eingebettetes Objekt. Um diese Einstellung zu verwenden, müssen Sie zuerst die Eigenschaft OLETypeAllowed des Steuerelements auf acOLEEmbedded oder acOLEEither einstellen. Stellen Sie die Eigenschaft Class auf den Typ des zu erstellenden OLE-Objekts ein. Mit Hilfe der Eigenschaft SourceDoc können Sie eine vorhandene Datei als Vorlage verwenden.
acOLECreateLink (1) | Erstellt ein verknüpftes OLE-Objekt aus dem Inhalt einer Datei. Um diese Einstellung zu verwenden, müssen Sie zuerst die Eigenschaften OLETypeAllowed und SourceDoc des Steuerelements einstellen. Stellen Sie die Eigenschaft OLETypeAllowed auf acOLELinked oder acOLEEither ein. Die Eigenschaft SourceDoc gibt die Datei an, die zum Erstellen des OLE-Objekts verwendet wurde. Sie können auch die Eigenschaft SourceItem des Steuerelements einstellen (um z.B. einen Zeilen- und-Spalten-Bereich anzugeben, wenn es sich bei dem zu erstellenden Objekt um eine Microsoft Excel-Tabelle handelt). Wenn Sie ein OLE-Objekt mit dieser Einstellung erstellen, zeigt das Steuerelement eine Metadateigrafik der durch die Eigenschaft SourceDoc des Steuerelements angegebenen Datei an. Wenn Sie das OLE-Objekt speichern, werden nur die Verknüpfungsinformationen (wie der Name der Quellanwendung des Objekts und der Name der verknüpften Datei) gespeichert, da das Steuerelement ein Abbild der Daten, aber keine Quelldaten, enthält.
acOLECopy (4) | Kopiert das Objekt in die Zwischenablage. Wenn Sie ein OLE-Objekt in die Zwischenablage kopieren, werden alle damit verbundenen Daten und Verknüpfungsinformationen ebenfalls in die Zwischenablage kopiert. Sie können sowohl verknüpfte als auch eingebettete Objekte in die Zwischenablage kopieren. Das Verwenden dieser Einstellung entspricht dem Klicken auf Kopieren im Menü Bearbeiten.
acOLEPaste (5) | Fügt Daten aus der Zwischenablage in das Steuerelement ein. Wenn die Einfügeoperation erfolgreich ist, wird die Eigenschaft OLEType des Steuerelements auf acOLELinked bzw. acOLEEmbedded eingestellt. Schlägt die Einfügeoperation fehl, wird die Eigenschaft OLEType auf acOLENone eingestellt. Das Verwenden der Einstellung acOLEPaste entspricht dem Klicken auf Einfügen im Menü Bearbeiten.
acOLEUpdate (6) | Ruft die aktuellen Daten aus der Quellanwendung des Objekts ab und zeigt diese Daten als Metadateigrafik (*.wmf) im Steuerelement an.
acOLEActivate (7) | Öffnet ein OLE-Objekt für eine Operation, wie z.B. Bearbeiten. Um diese Einstellung zu verwenden, müssen Sie zuerst die Eigenschaft Verb des Steuerelements einstellen. Die Eigenschaft Verb gibt die Operation an, die am aktivierten OLE-Objekt durchgeführt werden soll.
acOLEClose (9) | Schließt ein OLE-Objekt und beendet die Verbindung mit dessen Quellanwendung. Diese Einstellung gilt nur für eingebettete Objekte. Das Verwenden dieser Einstellung entspricht dem Klicken auf Schließen im Systemmenü des Objekts.
acOLEDelete (10) | Löscht das angegebene OLE-Objekt und gibt den zugeordneten Speicher frei. Diese Einstellung ermöglicht Ihnen das explizite Löschen eines OLE-Objekts. Objekte werden automatisch gelöscht, wenn ein Formular geschlossen oder das Objekt auf ein neues Objekt aktualisiert wird. Sie können die Eigenschaft Action nicht verwenden, um ein gebundenes OLE-Objekt aus seiner zugrunde liegenden Tabelle oder Abfrage zu löschen.
acOLEInsertObjDlg (14) | Zeigt das Dialogfeld Objekt einfügen an. In der Formularansicht bzw. der Datenblattansicht ermöglichen Sie es dem Benutzer mit diesem Dialogfeld, ein neues Objekt zu erstellen oder ein vorhandenes Objekt zu verknüpfen oder einzubetten. Mit der Eigenschaft OLETypeAllowed des Steuerelements (und der Konstante acOLELinked, acOLEEmbedded oder acOLEEither) können Sie den Objekttyp bestimmen, der über dieses Dialogfeld erstellt werden kann.
acOLEPasteSpecialDlg (15) | Zeigt das Dialogfeld Inhalte einfügen an. In der Formular- bzw. der Datenblattansicht ermöglichen Sie es dem Benutzer mit diesem Dialogfeld, ein Objekt aus der Zwischenablage einzufügen. Das Dialogfeld bietet mehrere Optionen, darunter das Einfügen eines verknüpften oder eingebetteten Objekts. Mit der Eigenschaft OLETypeAllowed des Steuerelements (und der Konstante acOLELinked, acOLEEmbedded oder acOLEEither) können Sie den Objekttyp bestimmen, der über dieses Dialogfeld eingefügt werden kann.
acOLEFetchVerbs (17) | Aktualisiert die Liste der Verben, die ein OLE-Objekt unterstützt. Zum Anzeigen der Liste von Verben verwenden Sie die Eigenschaften ObjectVerbs und ObjectVerbsCount.

Sie können die Eigenschaft Action nur in Visual Basic einstellen. Die Einstellung von Action ist ein Wert des Datentyps Integer.

Die Eigenschaft Action ist in der Entwurfsansicht nicht verfügbar, kann in anderen Ansichten jedoch überprüft oder eingestellt werden.

Anmerkung

Wenn die Eigenschaft Aktiviert eines Steuerelements auf Nein oder die Eigenschaft Gesperrt auf Ja eingestellt ist, können Sie einige Einstellungen der Eigenschaft Action nicht verwenden. Die folgende Tabelle gibt an, welche Einstellungen unter diesen Bedingungen zulässig oder nicht zulässig sind.

Einstellung | Aktiviert = Nein | Gesperrt = Ja
acOLECreateEmbed (0) | Nicht zulässig | Nicht zulässig
acOLECreateLink (1) | Nicht zulässig | Nicht zulässig
acOLECopy (4) | Zulässig | Zulässig
acOLEPaste (5) | Nicht zulässig | Nicht zulässig
acOLEUpdate (6) | Nicht zulässig | Nicht zulässig
acOLEActivate (7) | Zulässig | Zulässig
acOLEClose (9) | Nicht zulässig | Zulässig
acOLEDelete (10) | Nicht zulässig | Nicht zulässig
acOLEInsertObjDlg (14) | Nicht zulässig | Nicht zulässig
acOLEPasteSpecialDlg (15) | Nicht zulässig | Nicht zulässig
acOLEFetchVerbs (17) | Nicht zulässig | Zulässig


 ActiveControl-Eigenschaft

ActiveControl-Eigenschaft

Sie können die Eigenschaft ActiveControl zusammen mit dem Screen-Objekt verwenden, um das Steuerelement zu kennzeichnen oder auf das Steuerelement zu verweisen, das den Fokus besitzt.

Einstellung

Die Einstellung dieser Eigenschaft enthält einen Verweis auf das Control-Objekt, das zur Laufzeit den Fokus hat.

Diese Eigenschaft ist in einem Makro oder in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Verwenden Sie die Eigenschaft ActiveControl, um auf das Steuerelement zu verweisen, das zur Laufzeit den Fokus hat, und um eine der zugehörigen Eigenschaften oder Methoden anzugeben. Das folgende Beispiel weist den Namen des Steuerelements, das den Fokus besitzt, der Variablen strSteuerelement zu:

Dim AktSteuerelement As Control
Dim strSteuerelement As String
Set AktSteuerelement = Screen.ActiveControl
strSteuerelement = AktSteuerelement.Name

Wenn Sie die Eigenschaft ActiveControl verwenden, jedoch kein Steuerelement den Fokus hat, oder wenn alle Steuerelemente des aktiven Formulars ausgeblendet oder deaktiviert sind, tritt ein Fehler auf.


 ActiveDatasheet-Eigenschaft

ActiveDatasheet-Eigenschaft

Sie können die Eigenschaft ActiveDatasheet zusammen mit dem Screen-Objekt verwenden, um das Datenblatt, das den Fokus hat, zu ermitteln oder darauf zu verweisen.

Einstellung

Die Einstellung der Eigenschaft ActiveDatasheet enthält das Datenblattobjekt, das zur Laufzeit den Fokus hat.

Diese Eigenschaft ist in einem Makro oder in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Sie können diese Eigenschaft verwenden, um auf ein aktives Datenblatt mit einer seiner Eigenschaften oder Methoden zu verweisen. Der folgende Code z.B. verwendet die Eigenschaft ActiveDatasheet, um auf die oberste Zeile der Auswahl zu verweisen, die im aktiven Datenblatt wirksam ist.

TopRow = Screen.ActiveDatasheet.SelTop


 ActiveForm-Eigenschaft

ActiveForm-Eigenschaft

Sie können die Eigenschaft ActiveForm zusammen mit dem Screen-Objekt verwenden, um das Formular zu kennzeichnen oder auf das Formular zu verweisen, das den Fokus besitzt.

Einstellung

Die Einstellung dieser Eigenschaft enthält das Form-Objekt, das zur Laufzeit den Fokus hat.

Diese Eigenschaft ist in einem Makro oder in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Verwenden Sie die Eigenschaft ActiveForm, um auf das Formular zu verweisen und eine der zugehörigen Eigenschaften oder Methoden anzugeben. Das folgende Beispiel zeigt die Einstellung der Eigenschaft Name des aktiven Formulars an:

Dim AktFormular As Form
Set AktFormular = Screen.ActiveForm
MsgBox "Das aktuelle Formular ist " & AktFormular.Name

Wenn ein Unterformular den Fokus hat, verweist ActiveForm auf das Hauptformular. Wenn Sie die Eigenschaft ActiveForm verwenden, aber kein Formular oder Unterformular den Fokus hat, tritt ein Fehler auf.


 ActiveReport-Eigenschaft

ActiveReport-Eigenschaft

Sie können die Eigenschaft ActiveReport zusammen mit dem Screen-Objekt verwenden, um den Bericht anzugeben oder auf den Bericht zu verweisen, der den Fokus besitzt.

Einstellung

Die Einstellung dieser Eigenschaft enthält das Report-Objekt, das zur Laufzeit den Fokus hat.

Diese Eigenschaft ist nur in einem Makro oder in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Verwenden Sie die Eigenschaft ActiveReport, um auf den aktiven Bericht zu verweisen und eine der zugehörigen Eigenschaften oder Methoden anzugeben. Das folgende Beispiel zeigt die Einstellung der Eigenschaft Name des aktiven Berichts an:

Dim AktuellerBericht As Report
Set AktuellerBericht = Screen.ActiveReport
MsgBox "Der aktuelle Bericht ist " & AktuellerBericht.Name

Wenn Sie die Eigenschaft ActiveReport verwenden, aber kein Bericht den Fokus hat, tritt ein Fehler auf.


 Address-Eigenschaft

Address-Eigenschaft

Mit der Eigenschaft Address können Sie den Pfad zu einem Objekt, einem Dokument, einer Webseite oder einem anderen Ziel für ein Hyperlink-Objekt angeben oder ermitteln, das einer Befehlsschaltfläche, einem Bild-Steuerelement oder einem Bezeichnung-Steuerelement zugeordnet ist.

Einstellung

Die Eigenschaft Address ist ein Zeichenfolgenausdruck, der den Pfad der Eigenschaft Hyperlink-Adresse zu einer Datei (UNC-Pfad) oder einer Webseite (URL) darstellt.

Die Eigenschaft Address ist nur in Visual Basic verfügbar. Beim Einstellen von Address geben Sie für das dem Hyperlink zugeordnete Steuerelement automatisch die Eigenschaft Hyperlink-Adresse an.

Anmerkung

Weitere Informationen über Hyperlinkadressen und deren Format finden Sie unter den Themen zur Eigenschaft Hyperlink-Adresse und Hyperlink-Unteradresse.


 Alias-Eigenschaft (Alias)

Alias-Eigenschaft (Alias)

Sie können die Eigenschaft Alias zur Angabe eines benutzerdefinierten Namens für eine Eingabetabelle oder -abfrage verwenden, wenn Sie dieselbe Tabelle mehrmals in derselben Abfrage verwenden.

Anmerkung Die Eigenschaft Alias betrifft nur Tabellen oder Abfragen, wenn diese als Datenquelle in einer Abfrage verwendet werden.

Einstellung

Sie stellen die Eigenschaft Alias mit Hilfe eines Zeichenfolgenausdrucks auf einen beliebigen Namen ein, der noch nicht in der Datenbank verwendet wird. Sie stellen diese Eigenschaft in der Abfrageentwurfsansicht ein, indem Sie mit der rechten Maustaste auf die Feldliste im Abfrageentwurfsbereich klicken und dann auf Eigenschaften klicken.

Sie stellen diese Eigenschaft Alias in der SQL-Ansicht des Abfragefensters mit Hilfe einer AS-Klausel in der SQL-Anweisung ein.

Anmerkung

Bei der Erstellung einer Reflexivverknüpfung in einer SQL-Anweisung müssen Sie einen Alias verwenden.

Wenn Sie einer Abfrage eine Tabelle oder Abfrage hinzufügen, stellt Microsoft Access automatisch die Eigenschaft Alias auf den Namen der Tabelle oder Abfrage ein. Wird eine weitere Instanz derselben Tabelle oder Abfrage hizugefügt, so nimmt Microsoft Access die Einstellung der Eigenschaft Alias als Objektnamen und fügt einen Unterstrich und die Zahl 1 an ("_1").

Durch das Erstellen eines Alias wird nicht der Name der Tabelle oder Abfrage geändert. Es wird lediglich ein anderer Name angegeben, mit dem auch auf die Tabelle oder Abfrage verwiesen werden kann. Beispielsweise können Sie in einer Abfrage mit einer Reflexivverknüpfung, die Angestellte und deren Vorgesetzte zeigt, zwei Kopien der Tabelle Personal verwenden. Microsoft Access nennt die duplizierte Tabelle automatisch Personal_1. Sie können der Tabelle einen aussagekräftigeren Namen geben, indem Sie ihre Eigenschaft Alias auf Vorgesetzte einstellen.


AllDataAccessPages-Eigenschaft

Mit der AllDataAccessPages-Eigenschaft können Sie auf die AllDataAccessPages-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllDataAccessPage-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllDatabaseDiagrams-Eigenschaft

Mit der AllDatabaseDiagrams-Eigenschaft können Sie auf die AllDatabaseDiagrams-Auflistung und deren zugehörige Eigenschaften zugreifen.

Einstellung

Die AllDatabaseDiagrams-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllForms-Eigenschaft

Mit der AllForms-Eigenschaft können Sie auf die AllForms-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllForms-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllMacros-Eigenschaft

Mit der AllMacros-Eigenschaft können Sie auf die AllMacros-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllMacros-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllModules-Eigenschaft

Mit der AllModules-Eigenschaft können Sie auf die AllModules-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllModules-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


 AllowAdditions-Eigenschaft (AnfügenZulassen)

AllowAdditions-Eigenschaft (AnfügenZulassen)

Sie können mit der Eigenschaft AllowAdditions angeben, ob es einem Benutzer möglich sein soll, mit einem Formular Datensätze hinzuzufügen.

Einstellung

Die Eigenschaft AllowAdditions verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Der Benutzer kann neue Datensätze hinzufügen.
Nein | False (0) | Der Benutzer kann keine neuen Datensätze hinzufügen.

Sie können die Eigenschaft AllowAdditions im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Das Einstellen der Eigenschaft AllowAdditions auf Nein ermöglicht den Benutzern das Anzeigen oder Bearbeiten bestehender, jedoch nicht das Hinzufügen neuer Datensätze.

Wenn Sie das Ändern von bestehenden Datensätzen verhindern (einem Formular Schreibschutz zuweisen) möchten, stellen Sie die Eigenschaften AllowAdditions, AllowDeletions und AllowEdits auf Nein ein. Sie können Datensätze auch gegen Überschreiben schützen, indem Sie die Eigenschaft RecordsetType auf Snapshot einstellen.

Wenn Sie ein Formular nur für die Dateneingabe öffnen möchten, stellen Sie die Eigenschaft DataEntry des Formulars auf Ja ein.

Wenn die Eigenschaft AllowAdditions auf Nein eingestellt ist, ist der Befehl Daten eingeben im Menü Datensätze nicht verfügbar.

Anmerkung Wenn das Argument Datenmodus der Aktion ÖffnenFormular verwendet wird, überschreibt Microsoft Access eine Reihe von Formulareigenschaften. Wenn das Argument Datenmodus der Aktion ÖffnenFormular auf Bearbeiten eingestellt ist, öffnet Microsoft Access das Formular mit den folgenden Eigenschafteneinstellungen:

  • AllowEdits - Ja

  • AllowDeletions - Ja

  • AllowAdditions - Ja

  • DataEntry - Nein

Wenn Sie verhindern möchten, dass die Aktion ÖffnenFormular diese vorhandenen Eigenschafteneinstellungen überschreibt, lassen Sie die Einstellung des Arguments Datenmodus weg, damit Microsoft Access die vom Formular definierten Eigenschafteneinstellungen verwendet.


 AllowAutoCorrect-Eigenschaft (AutoKorrekturZulassen)

AllowAutoCorrect-Eigenschaft (AutoKorrekturZulassen)

Sie können mit der Eigenschaft AllowAutoCorrect angeben, ob ein Textfeld- oder ein Kombinationsfeld -Steuerelement Benutzereingaben automatisch korrigieren soll.

Einstellung

Die Eigenschaft AllowAutoCorrect verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Einträge werden entsprechend den Einstellungen im Dialogfeld AutoKorrektur automatisch korrigiert.
Nein | False (0) | Einträge werden nicht korrigiert.

Sie können die Eigenschaft AutoKorrektur zulassen im Eigenschaftenfenster eines Steuerelements, in einem Makro oder in Visual Basic einstellen. Sie können die Standardeinstellung für diese Eigenschaft festlegen, indem Sie die Standardeigenschafteneinstellungen eines Steuerelements oder die Methode DefaultControl in Visual Basic verwenden.

Anmerkung

Sie öffnen das Dialogfeld AutoKorrektur durch Klicken auf AutoKorrektur im Menü Extras.


 AllowBreakIntoCode-Eigenschaft

AllowBreakIntoCode-Eigenschaft

Mit Hilfe der AllowBreakIntoCode-Eigenschaft können Sie festlegen, ob der Benutzer Visual Basic-Code anzeigen kann, nachdem in einem Modul ein Laufzeitfehler eingetreten ist.

Einstellung

Die AllowBreakIntoCode-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Aktiviert die Schaltfläche Debuggen im Dialogfeld, die bei Eintreten eines Laufzeitfehlers angezeigt wird.
False (0) | Deaktiviert die Schaltfläche Debuggen.

Am einfachsten stellen Sie diese Eigenschaft über die Option Codeansicht nach Fehler zulassen im Bereich Weitere des Dialogfelds Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowBreakIntoCode-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:.

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Stellen Sie sicher, dass die AllowBreakIntoCode-Eigenschaft beim Testen einer Anwendung auf True eingestellt ist.

Ist die AllowSpecialKeys-Eigenschaft auf True eingestellt, können Sie durch Drücken von STRG+UNTBR die Ausführung des Visual Basic-Codes unterbrechen, auch wenn die AllowBreakIntoCode-Eigenschaft auf False eingestellt ist.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowBuiltInToolbars-Eigenschaft

AllowBuiltInToolbars-Eigenschaft

Mit Hilfe der AllowBuiltInToolbars-Eigenschaft können Sie festlegen, ob der Benutzer die eingebauten Symbolleisten von Microsoft Access anzeigen kann oder nicht. Sie können über die AllowBuiltInToolbars-Eigenschaft z.B. verhindern, dass ein Benutzer in einer Datenbankanwendung eine eingebaute Microsoft Access-Symbolleiste sieht.

Einstellung

Die AllowBuiltInToolbars-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Läßt die Anzeige eingebauter Symbolleisten zu.
False (0) | Läßt die Anzeige eingebauter Symbolleisten nicht zu.

Am einfachsten stellen Sie diese Eigenschaft über die Option Eingebaute Symbolleisten zulassen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowBuiltinToolbars-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Spezifische Symbolleisten können Sie über das Dialogfeld Anpassen ein- oder ausblenden. Dieses Dialogfeld ist verfügbar, wenn Sie im Menü Ansicht auf Symbolleisten zeigen und dann auf Anpassen klicken.

Wenn Sie im Menü Ansicht auf Symbolleisten klicken und die AllowBuiltInToolbars-Eigenschaft auf False eingestellt ist, zeigt Microsoft Access im Untermenü Symbolleisten nur benutzerdefinierte Symbolleisten an. Wenn Sie in diesem Untermenü auf Anpassen klicken, zeigt das Dialogfeld Anpassen die eingebauten Symbolleisten an, Sie können sie jedoch weder auswählen noch anpassen.

Der Benutzer kann eingebaute Symbolleisten nur dann ändern, wenn sowohl die AllowToolbarChanges-Eigenschaft als auch die AllowBuiltInToolbars-Eigenschaft auf True eingestellt ist.

Ist die AllowBuiltInToolbars-Eigenschaft auf False eingestellt, können Sie die Aktion EinblendenSymbolleiste nicht verwenden, um eine eingebaute Symbolleiste anzuzeigen.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowBypassKey-Eigenschaft

AllowBypassKey-Eigenschaft

Mit Hilfe der AllowBypassKey-Eigenschaft können Sie festlegen, ob die UMSCHALTTASTE zum Umgehen der Starteigenschaften und des Makros AutoExec aktiviert sein soll oder nicht. Sie können die AllowBypassKey-Eigenschaft z.B. auf False einstellen, um einen Benutzer daran zu hindern, die Starteigenschaften und das Makro AutoExec zu umgehen.

Einstellung

Die AllowBypassKey-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Aktiviert die UMSCHALTTASTE, so dass der Benutzer die Starteigenschaften und das Makro AutoExec umgehen kann.
False (0) | Deaktiviert die UMSCHALTTASTE und hindert den Benutzer daran, die Starteigenschaften und das Makro AutoExec zu umgehen.

Sie können diese Eigenschaft mit Hilfe eines Makros oder von Visual Basic einstellen.

Um die AllowBypassKey-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf einer der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Stellen Sie sicher, dass die AllowBypassKey-Eigenschaft beim Testen einer Anwendung auf True eingestellt ist.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowContextMenu-Eigenschaft

AllowContextMenu-Eigenschaft

Mit der AllowContextMenu-Eigenschaft können Sie angeben oder ermitteln, ob das Kontextmenü des Snapshot Viewer-Steuerelements eingeblendet wird, wenn Sie mit der rechten Maustaste auf das Steuerelement klicken, oder wenn Sie die Taste für Kontextmenüs auf einer Microsoft Windows-Tastatur drücken.

Einstellung

Die AllowContextMenu-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Das Kontextmenü des Steuerelements wird beim Klicken mit der rechten Maustaste auf das Steuerelement angezeigt.
Nein | False (0) | Das Kontextmenü des Steuerelements wird nicht angezeigt.

Sie können die Kontextmenü-Eigenschaft im Eigenschaftenfenster des Steuerelements oder in Visual Basic einstellen.

Anmerkung

Wenn diese Eigenschaft auf Ja eingestellt wird, enthält das Kontextmenü, das beim Klicken mit der rechten Maustaste auf ein Snapshot Viewer-Steuerelement angezeigt wird, Befehle, mit denen die Einstellung der Zoom-Eigenschaft des Steuerelements angegeben oder zwischen Seiten im Snapshot gewechselt werden kann. Außerdem enthält das Kontextmenü Optionen zum Drucken von einer oder mehreren Seiten des aktuellen Snapshots.

Wird diese Eigenschaft auf Nein eingestellt, so wird das Kontextmenü beim Klicken mit der rechten Maustaste auf das Steuerelement nicht eingeblendet. Sie können weiterhin zwischen den Einstellungen der Zoom-Eigenschaft Ausfüllen und Anpassen wechseln, indem Sie direkt auf das im Steuerelement angezeigte Snapshot klicken. Sie können zu anderen Seiten im Snapshot wechseln oder das Snapshot mit Hilfe der Schaltflächen unten im Snapshot-Steuerelement drucken. Darüber hinaus können Sie ein Snapshot mit Hilfe der Schaltfläche Drucken (rechts neben den Navigationsschaltflächen) drucken.

Das Snapshot Viewer-Steuerelement unterstützt nicht die ShortcutMenuBar-Eigenschaft.


 AllowDeletions-Eigenschaft (LöschenZulassen)

AllowDeletions-Eigenschaft (LöschenZulassen)

Sie können mit der Eigenschaft AllowDeletions angeben, ob es einem Benutzer möglich sein soll, mit einem Formular Datensätze zu löschen.

Einstellung

Die Eigenschaft AllowDeletions verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Der Benutzer kann Datensätze löschen.
Nein | False (0) | Der Benutzer kann keine Datensätze löschen.

Sie können die Eigenschaft Löschen zulassen im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Sie können diese Eigenschaft auf Nein einstellen, um Benutzern das Anzeigen und das Bearbeiten, jedoch nicht das Löschen bestehender Datensätze zu erlauben. Wenn die Eigenschaft AllowDeletions auf Ja eingestellt ist, können Datensätze gelöscht werden, sofern dadurch nicht die Regeln verletzt werden, die bezüglich der referenziellen Integrität definiert sind.

Wenn Sie das Ändern von bestehenden Datensätzen verhindern (einem Formular Schreibschutz zuweisen) möchten, stellen Sie die Eigenschaften AllowAdditions, AllowDeletions und AllowEdits auf Nein ein. Sie können Datensätze auch gegen Überschreiben schützen, indem Sie die Eigenschaft RecordsetType auf Snapshot einstellen.

Wenn die Eigenschaft AllowDeletions auf Nein eingestellt ist, ist der Befehl Datensatz löschen im Menü Bearbeiten nicht verfügbar.

Anmerkung Wenn das Argument Datenmodus der Aktion ÖffnenFormular eingestellt wird, überschreibt Microsoft Access eine Reihe von Formulareigenschaften. Wenn das Argument Datenmodus der Aktion ÖffnenFormular auf Bearbeiten eingestellt ist, öffnet Microsoft Access das Formular mit den folgenden Eigenschafteneinstellungen:

  • AllowEdits - Ja

  • AllowDeletions - Ja

  • AllowAdditions - Ja

  • DataEntry - Nein

Wenn Sie verhindern möchten, dass die Aktion ÖffnenFormular diese vorhandenen Eigenschafteneinstellungen überschreibt, lassen Sie die Einstellung des Arguments Datenmodus weg, damit Microsoft Access die vom Formular definierten Eigenschafteneinstellungen verwendet.


 AllowDesignChanges-Eigenschaft (EntwurfsänderungenZulassen)

AllowDesignChanges-Eigenschaft (EntwurfsänderungenZulassen)

Mit der AllowDesignChanges-Eigenschaft können Sie auswählen oder bestimmen, ob Änderungen am Entwurf eines Formulars in allen Ansichten oder nur in der Entwurfsansicht vorgenommen werden können.

Einstellung

Die AllowDesignChanges-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Alle Ansichten | True (-1) | (Voreinstellung) Entwurfsänderungen können in allen Formularansichten durchgeführt werden.
Nur Entwurfsansicht | False (0) | Entwurfsänderungen können nur in der Entwurfsansicht vorgenommen werden.

Sie können die AllowDesignChanges-Eigenschaft mit Hilfe des zum Formular gehörigen Eigenschaftenfensters oder durchVisual Basic-Befehle einstellen.


 AllowEdits-Eigenschaft (BearbeitungenZulassen)

AllowEdits-Eigenschaft (BearbeitungenZulassen)

Sie können mit der Eigenschaft AllowEdits angeben, ob es einem Benutzer möglich sein soll, mit einem Formular Datensätze zu bearbeiten, die gespeichert sind.

Einstellung

Die Eigenschaft AllowEdits verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Der Benutzer kann gespeicherte Datensätze bearbeiten.
Nein | False (0) | Der Benutzer kann gespeicherte Datensätze nicht bearbeiten.

Sie können die Eigenschaft Bearbeitungen zulassen im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Sie können die Eigenschaft AllowEdits verwenden, um das Ändern aller in einem Formular angezeigten Daten zu verhindern. Wenn Sie das Ändern der Daten in einem bestimmten Steuerelement verhindern möchten, verwenden Sie die Eigenschaften Enabled oder Locked.

Wenn Sie das Ändern von bestehenden Datensätzen verhindern (einem Formular Schreibschutz zuweisen) möchten, stellen Sie die Eigenschaften AllowAdditions, AllowDeletions und AllowEdits auf Nein ein. Sie können Datensätze auch gegen Überschreiben schützen, indem Sie die Eigenschaft RecordsetType auf Snapshot einstellen.

Wenn die Eigenschaft AllowEdits auf Nein eingestellt ist, sind die Befehle Datensatz löschen im Menü Bearbeiten und Daten eingeben im Menü Datensätze nicht verfügbar.

Anmerkung Wenn das Argument Datenmodus der Aktion ÖffnenFormular eingestellt wird, überschreibt Microsoft Access eine Reihe von Formulareigenschaften. Wenn das Argument Datenmodus der Aktion ÖffnenFormular auf Bearbeiten eingestellt ist, öffnet Microsoft Access das Formular mit den folgenden Eigenschafteneinstellungen:

  • AllowEdits - Ja

  • AllowDeletions - Ja

  • AllowAddition - Ja

  • DataEntry - Nein

Wenn Sie verhindern möchten, dass die Aktion ÖffnenFormular diese vorhandenen Eigenschafteneinstellungen überschreibt, lassen Sie die Einstellung des Arguments Datenmodus weg, damit Microsoft Access die vom Formular definierten Eigenschafteneinstellungen verwendet.


 AllowFilters-Eigenschaft (FilterZulassen)

AllowFilters-Eigenschaft (FilterZulassen)

Mit der AllowFilters-Eigenschaft können Sie angeben, ob Datensätze in einem Formular gefiltert werden können.

Einstellung

Die AllowFilters-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Datensätze können gefiltert werden.
Nein | False (0) | Datensätze können nicht gefiltert werden.

Sie können die AllowFilters-Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Filter werden normalerweise verwendet, um eine temporäre Teilmenge der Datensätze in einer Datenbank anzuzeigen. Durch Verwenden des Filters wenden Sie Kriterien an, um nur solche Datensätze anzuzeigen, die diese Kriterien erfüllen. Beispielsweise können Sie in einer Tabelle Personal einen Filter verwenden, um nur Datensätze zu den Angestellten anzuzeigen, die länger als 5 Jahre im Betrieb beschäftigt sind. Sie können einen Filter auch verwenden, um den Zugriff auf Datensätze mit vertraulichen Informationen, wie z.B. Gehaltsangaben oder medizinische Daten, einzuschränken.

Wenn die AllowFilters-Eigenschaft auf Nein eingestellt ist, sind alle Filteroptionen im Menü Datensätze, das Kontextmenü des Formulars und die Symbolleiste Formatierung (Formular/Bericht) deaktiviert. Dies betrifft die folgenden Befehle und Schaltflächen:

  • Die Befehle Filter, Filter anwenden und Filter/Sortierung entfernen.

  • Die Befehle Formularbasierter Filter, Filter anwenden, Filter/Sortierung entfernen, Formularbasierter Serverfilter und Serverfilter anwenden im Kontextmenü des Formulars.

  • Die entsprechenden Schaltflächen Auswahlbasierter Filter [image] , Formularbasierter Filter [image] , Filter anwenden / Filter entfernen Filter-Objekt und Formularbasierter Serverfilter [image] .

Anmerkung Das Einstellen der AllowFilters-Eigenschaft auf Nein wirkt sich auf die Eigenschaften Filter, FilterOn, ServerFilter oder ServerFilterByForm nicht aus. Sie können diese Eigenschaften weiter zum Einstellen und Entfernen von Filtern verwenden. Die folgenden Aktionen und Methoden können Sie immer noch zum Anwenden oder Entfernen von Filtern benutzen.

Aktionen Methoden


 AllowFullMenus-Eigenschaft

AllowFullMenus-Eigenschaft

Mit Hilfe der AllowFullMenus-Eigenschaft können Sie festlegen, ob beim Öffnen der Datenbankanwendung die unbeschränkten eingebauten Menüs von Microsoft Access verfügbar sein sollen oder nicht. Sie können über die AllowFullMenus-Eigenschaft z.B. Menüeinträge deaktivieren, über die die Benutzer Tabellen-, Formular-, Abfrage- oder Berichtsstrukturen ändern können.

Einstellung

Die AllowFullMenus-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Zeigt beim Start die unbeschränkten eingebauten Menüs an.
False (0) | Zeigt beim Start die unbeschränkten eingebauten Menüs nicht an.

Am einfachsten stellen Sie diese Eigenschaft über die Option Unbeschränkte Menüs anzeigen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowFullMenus-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder erstellen Sie die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Wenn Sie diese Eigenschaft auf False einstellen, wird in Ihrer Datenbank eine vordefinierte Untergruppe der unbeschränkten eingebauten Menüs angezeigt. Diese Menügruppe enthält keine Menüs und Befehle, über welche die Benutzer den Entwurf von Datenbankobjekten ändern können.

Durch Einstellen dieser Eigenschaft auf False werden auch die Symbolleistenschaltflächen deaktiviert, die den deaktivierten Menüeinträgen entsprechen. Auf Kontextmenüs wirkt sich dies jedoch nicht aus (Sie können einige Entwurfsmerkmale demnach weiterhin über Kontextmenübefehle ändern). Wenn Sie nicht möchten, dass die Benutzer Zugriff auf die Befehle in den Kontextmenüs haben, können Sie die AllowShortcutMenus-Eigenschaft auf False einstellen.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowShortcutMenus-Eigenschaft

AllowShortcutMenus-Eigenschaft

Mit Hilfe der AllowShortcutMenus-Eigenschaft können Sie festlegen, ob Ihre Anwendung zulassen soll, dass Microsoft Access eingebaute Kontextmenüs anzeigt. Sie können die AllowShortcutMenus-Eigenschaft in Ihrer Anwendung z.B. in Verbindung mit der AllowFullMenus-Eigenschaft verwenden, um zu verhindern, dass Benutzer eingebaute Menüleisten-, Symbolleisten- oder Kontextmenübefehle verwenden, über die Sie Änderungen am Entwurf von Datenbankobjekten vornehmen können.

Einstellung

Die AllowShortcutMenus-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Läßt die Anzeige eingebauter Microsoft Access-Kontextmenüs zu.
False (0) | Läßt die Anzeige eingebauter Microsoft Access-Kontextmenüs nicht zu.

Am einfachsten stellen Sie diese Eigenschaft über die Option Standardkontextmenüs zulassen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowShortcutMenus-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Die Einstellung dieser Eigenschaft hat keine Auswirkung auf benutzerdefinierte Kontextmenüs und globale Kontextmenüs. Über die ShortcutMenuBar-Eigenschaft können Sie benutzerdefinierte Kontextmenüs für Formulare, Steuerelemente in Formularen und Berichte anzeigen. Über die StartupShortcutMenuBar-Eigenschaft oder die ShortcutMenuBar-Eigenschaft des Application-Objekts können Sie ein globales Kontextmenü anzeigen.

Wenn Sie in Ihrer Anwendung eingebaute Kontextmenüs anzeigen möchten, der Benutzer daran jedoch keine Änderungen vornehmen soll, stellen Sie die AllowShortcutMenus-Eigenschaft auf True und die AllowToolbarChanges-Eigenschaft auf False ein.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowSpecialKeys-Eigenschaft

AllowSpecialKeys-Eigenschaft

Mit Hilfe der AllowSpecialKeys-Eigenschaft können Sie festlegen, ob spezielle Tastenfolgen (ALT+F1 (F11), STRG+F11, STRG+UNTBR und STRG+G) deaktiviert oder aktiviert sein sollen. Über die AllowSpecialKeys-Eigenschaft können Sie z.B. verhindern, dass ein Benutzer das Datenbankfenster durch Drücken von F11 anzeigt, in einem Visual Basic-Modul durch Drücken von STRG+UNTBR den Unterbrechungsmodus aktiviert oder durch Drücken von STRG+G das Direktfenster anzeigt.

Einstellung

Die AllowSpecialKeys-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Aktiviert die speziellen Tastenfolgen.
False (0) | Deaktiviert die speziellen Tastenfolgen.

Am einfachsten stellen Sie diese Eigenschaft über die Option Access-Spezialtasten verwenden im Bereich Weitere des Dialogfelds Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. In einer Microsoft Access-Datenbank (.mdb) können Sie diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowSpecialKeys-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf einer der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Stellen Sie sicher, dass die AllowSpecialKeys-Eigenschaft beim Testen einer Anwendung auf True eingestellt ist.

Die AllowSpecialKeys-Eigenschaft wirkt sich auf die folgenden Tastenfolgen aus.

Tastenfolgen | Auswirkung
ALT+F1 (F11) | Bringt das Datenbankfenster in den Vordergrund.
STRG+G | Zeigt das Direktfenster an.
STRG+F11 | Schaltet zwischen der benutzerdefinierten Menüleiste und der eingebauten Menüleiste um.
STRG+UNTBR | Aktiviert den Unterbrechungsmodus und zeigt das aktuelle Modul im Code-Fenster an.

Wenn Sie die UseSpecialKeys-Eigenschaft auf False einstellen und über die StartupMenuBar-Eigenschaft oder die MenuBar-Eigenschaft des Application-Objekts eine globale Menüleiste festlegen, ist die eingebaute Menüleiste nicht verfügbar.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowToolbarChanges-Eigenschaft

AllowToolbarChanges-Eigenschaft

Mit Hilfe der AllowToolbarChanges-Eigenschaft können Sie festlegen, ob es den Benutzern Ihrer Datenbank möglich sein soll, Symbolleisten, Menüleisten und Kontextmenüs anzupassen. Sie können über die AllowToolbarChanges-Eigenschaft z.B. verhindern, dass die Benutzer eine Symbolleistenschaltfläche oder eine ganze Symbolleiste aus Ihrer Anwendung löschen.

Einstellung

Die AllowToolbarChanges-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Läßt Änderungen an Symbolleisten, Menüleisten und Kontextmenüs zu.
False (0) | Läßt keine Änderungen an Symbolleisten, Menüleisten und Kontextmenüs zu.

Am einfachsten stellen Sie diese Eigenschaft über die Option Symbolleisten- und Menüänderungen zulassen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AllowToolbarChanges-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Anmerkung

Wenn Sie die AllowToolbarChanges-Eigenschaft auf False einstellen, können die Benutzer keine Symbolleisten, Menüleisten und Kontextmenüs ändern. Ferner wird der Unterbefehl Anpassen des Befehls Symbolleisten im Menü Ansicht deaktiviert sowie der Befehl Anpassen, der angezeigt wird, wenn Sie mit der rechten Maustaste auf eine Symbolleiste oder die Menüleiste klicken.

Wenn Sie diese Eigenschaft auf False einstellen, kann der Benutzer Symbolleisten und die Menüleiste nach wie vor verschieben, in der Größe ändern und verankern.

Eingebaute Symbolleisten kann der Benutzer nur ändern, wenn sowohl die AllowToolbarChanges-Eigenschaft als auch die AllowBuiltInToolbars-Eigenschaft auf True eingestellt ist.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 AllowZeroLength-Eigenschaft (LeereZeichenfolge)

AllowZeroLength-Eigenschaft (LeereZeichenfolge)

Mit der AllowZeroLength-Eigenschaft können Sie angeben, ob eine leere Zeichenfolge (" ") einen gültigen Eintrag in einem Feld darstellt.

Anmerkung Die AllowZeroLength-Eigenschaft gilt nur für Felder vom Typ Text, Memo und Hyperlink in Tabellen.

Einstellung

Die AllowZeroLength-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Eine leere Zeichenfolge ist ein gültiger Eintrag.
Nein | False (0) | (Voreinstellung) Eine leere Zeichenfolge ist ein ungültiger Eintrag.

Sie können diese Eigenschaft im Eigenschaftenblatt oder in Visual Basic einstellen.

Anmerkung Verwenden Sie die DAO-Eigenschaft AllowZeroLength oder die ADO-Eigenschaft Column.Properties ("Set OLEDB:Allow Zero Length"), um mit Visual Basic auf die Eigenschaft AllowZeroLength eines Feldes zuzugreifen.

Anmerkung

Soll Microsoft Access einen leere Zeichenfolge anstatt eines Null-Wertes speichern, wenn ein Feld leer bleibt, müssen die Eigenschaften AllowZeroLength und Required auf Ja eingestellt werden.

Die folgende Tabelle zeigt die Ergebnisse bei der Kombination der Einstellungen der Eigenschaften AllowZeroLength und Required .

AllowZeroLength | Required | Benutzeraktion | Gespeicherter Wert
Nein | Nein | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | Null Null (nicht zulässig)
Ja | Nein | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | Null Null Leere Zeichenfolge
Nein | Ja | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | (nicht zulässig) (nicht zulässig) (nicht zulässig)
Ja | Ja | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | (nicht zulässig) Leere Zeichenfolge Leere Zeichenfolge

Anmerkung Sie können die Format-Eigenschaft verwenden, um zwischen der Anzeige eines Null-Wertes und einer leeren Zeichenfolge zu unterscheiden. Die Zeichenfolge "Keine" kann z.B. angezeigt werden, wenn eine leere Zeichenfolge eingegeben wird.

Die AllowZeroLength-Eigenschaft ist von der Required-Eigenschaft unabhängig. Die Required-Eigenschaft stellt lediglich fest, ob ein Null-Wert ein gültiger Wert für ein Feld ist. Ist die AllowZeroLength-Eigenschaft auf Ja eingestellt, so ist eine leere Zeichenfolge ein gültiger Wert für das Feld, unabhängig von der Einstellung der Required-Eigenschaft.


AllQueries-Eigenschaft

Mit der AllQueries-Eigenschaft können Sie auf die AllQueries-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllQueries-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllReports-Eigenschaft

Mit der AllReports-Eigenschaft können Sie auf die AllReports-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllReports-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllStoredProcedures-Eigenschaft

Mit der AllStoredProcedures-Eigenschaft können Sie auf die AllStoredProcedures-Auflistung und deren Eigenschaften zugreifen.

Einstellung

Die AllStoredProcedures-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllTables-Eigenschaft

Mit der AllTables-Eigenschaft können Sie auf die AllTables-Auflistung und deren dazugehörigen Eigenschaften zugreifen.

Einstellung

Die AllTables-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AllViews-Eigenschaft

Mit der AllViews-Eigenschaft können Sie auf die AllViews-Auflistung und deren dazugehörige Eigenschaften zugreifen.

Einstellung

Die AllViews-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


AlwaysSaveInDefaultEncoding-Eigenschaft

Mit der AlwaysSaveInDefaultEncoding-Eigenschaft können Sie festlegen oder abfragen, ob der Webbrowser eine Datenzugriffsseite mit dem Standardzeichensatz oder mit der ursprünglichen Codierung (Zeichensatz) öffnet.

Einstellung

Die AlwaysSaveInDefaultEncoding-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Beim Speichern einer Datenzugriffsseite ist die durch die Encoding-Eigenschaft festgelegte Standardkodierung zu verwenden.
Nein | False (0) | (Standardeinstellung) Die ursprüngliche Kodierung der Datenzugriffsseite ist zu verwenden.

Die AlwaysSaveInDefaultEncoding-Eigenschaft steht nur unter Visual Basic zur Verfügung.

Anmerkung

Die Encoding-Eigenschaft kann zur Festlegung des Standardzeichensatzes verwendet werden.


 AnswerWizard-Eigenschaft (Microsoft Access)

AnswerWizard-Eigenschaft (Microsoft Access)

Mit der AnswerWizard-Eigenschaft können Sie einen Verweis auf das aktuelle AnswerWizard-Objekt und dessen zugehörige Eigenschaften zurückgeben.

Einstellung

[Anwendung.]AnswerWizard[.Methode oder Eigenschaft]

Die AnswerWizard-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Anwendung | Optional. Das Application-Objekt.
AnswerWizard | Erforderlich. Wird die AnswerWizard-Eigenschaft ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie das AnswerWizard-Objekt zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des AnswerWizard-Objekts.

Die AnswerWizard-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Nachdem Sie einen Verweis auf das AnswerWizard-Objekt eingerichtet haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Zum Festlegen eines Verweises auf das AnswerWizard-Objekt klicken Sie in der Entwurfsansicht des Moduls im Menü Extras auf Verweise. Anschließend stellen Sie einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie im Dialogfeld Verweise das entsprechende Kontrollkästchen aktivieren. Microsoft Access stellt diesen Verweis automatisch ein, wenn Sie eine Konstante der Microsoft Office 9.0 Object Library zum Einstellen einer Eigenschaft des AnswerWizard-Objekts oder als Argument einer Methode dieses Objekts verwenden.


 AppIcon-Eigenschaft

AppIcon-Eigenschaft

Mit Hilfe der AppIcon-Eigenschaft können Sie den Namen der Bitmap (.BMP)- oder Symbol-Datei (.ICO) festlegen, die das Anwendungssymbol enthält. Sie können über die AppIcon-Eigenschaft z.B. eine .BMP-Datei festlegen, die das Bild eines Automobils enthält, um eine Autoteile-Anwendung darzustellen.

Einstellung

Die AppIcon-Eigenschaft ist ein Zeichenfolgenausdruck, der einem gültigen Bitmap- oder Symboldateinamen (einschließlich Pfad) entspricht.

Am einfachsten stellen Sie diese Eigenschaft über die Option Anwendungssymbol im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AppIcon-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein. Oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anhängen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Sie müssen außerdem die RefreshTitleBar-Methode verwenden, um alle Änderungen unmittelbar anzuzeigen.

Anmerkungen

Wenn Sie Ihre Anwendung verteilen, empfiehlt es sich, die .BMP- oder .ICO-Datei mit dem Symbol in das Verzeichnis Ihrer Microsoft Access-Anwendung zu stellen.

Ist die AppIcon-Eigenschaft nicht eingestellt oder ungültig, wird das Microsoft Access-Symbol angezeigt.

Die Einstellung dieser Eigenschaft wird unmittelbar nach ihrer Einstellung im Code (sofern dieser die RefreshTitleBar-Methode enthält) oder nach dem Schließen des Dialogfelds Start wirksam.


Application-Eigenschaft

Sie können die Eigenschaft Application in Visual Basic verwenden, um auf das aktive Microsoft Access-Objekt Application sowie dessen zugehörige Eigenschaften zuzugreifen.

Einstellung

Die Eigenschaft Application wird von Microsoft Access eingestellt und ist in allen Ansichten schreibgeschützt.

Anmerkung

Jedes Microsoft Access-Objekt hat die Eigenschaft Application, die das aktuelle Application-Objekt zurückgibt. Sie können diese Eigenschaft verwenden, um auf jede Eigenschaft des Application-Objekts zuzugreifen. Sie können z.B. mit der folgenden Syntax vom aktuellen Formular aus auf die Menüleiste des Application-Objekts verweisen:

Me.Application.MenuBar


 AppTitle-Eigenschaft

AppTitle-Eigenschaft

Mit Hilfe der AppTitle-Eigenschaft können Sie den Text festlegen, der in der Titelleiste der Anwendungsdatenbank angezeigt werden soll. Sie können über die AppTitle-Eigenschaft z.B. festlegen, dass die Zeichenfolge "Inventur" in der Titelleiste Ihrer Datenbankanwendung Inventur angezeigt werden soll.

Einstellung

Die AppTitle-Eigenschaft ist ein Zeichenfolgenausdruck, der dem Text, der in der Titelleiste angezeigt werden soll, entspricht.

Am einfachsten stellen Sie diese Eigenschaft über die Option Anwendungstitel im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die AppTitle-Eigenschaft mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein. Oder Sie erstellen die Eigenschaft auf eine der folgenden Arten:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit der CreateProperty-Methode hinzufügen und anschließend der Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp) können Sie die Eigenschaft der AccessObjectProperties-Auflistung des CurrentProject-Objekts unter Verwendung der Add-Methode anhängen.

Sie müssen außerdem die RefreshTitleBar-Methode verwenden, um alle Änderungen unmittelbar anzuzeigen.

Anmerkungen

Ist diese Eigenschaft nicht definiert, so wird in der Titelleiste die Zeichenfolge "Microsoft Access" angezeigt.

Die Einstellung dieser Eigenschaft wird unmittelbar nach ihrer Einstellung im Code (sofern dieser die Methode RefreshTitleBar enthält) oder nach dem Schließen des Dialogfelds Start wirksam.


 Assistant-Eigenschaft

Assistant-Eigenschaft

Mit der Eigenschaft Assistant können Sie einen Verweis auf das Objekt Assistant zurückgeben.

Einstellung

[Anwendung.]Assistant[.Methode oder Eigenschaft]

Die Eigenschaft Assistant verwendet die folgenden Einstellungen:

Einstellung | Beschreibung
Anwendung | Optional. Das Objekt Application.
Assistant | Erforderlich. Wird die Eigenschaft Assistant ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie die Eigenschaft Item des Objekts Assistant zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des Objekts Assistant.

Die Eigenschaft Assistant ist nur in Visual Basic verfügbar.

Anmerkung

Nachdem Sie einen Verweis auf das Objekt Assistant eingestellt haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Sie stellen einen Verweis auf das Objekt Assistant ein, indem Sie in der Modul-Entwurfsansicht im Menü Extras auf Verweise klicken. Anschließend stellen Sie im Dialogfeld Verweise einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie das entsprechende Kontrollkästchen aktivieren. Microsoft Access kann diesen Verweis automatisch einstellen, wenn Sie eine Konstante der Microsoft Office 9.0 Object Library zum Einstellen einer Eigenschaft des Objekts Assistant oder als Argument einer Methode des Objekts Assistant verwenden.


 AutoActivate-Eigenschaft (Objektaktivierung)

AutoActivate-Eigenschaft (Objektaktivierung)

Mit der Eigenschaft AutoActivate können Sie angeben, auf welche Weise der Benutzer ein OLE-Objekt aktivieren kann.

Einstellung

Die Eigenschaft AutoActivate verwendet die folgenden Einstellungen.

Einstellung | Konstante | Beschreibung
Manuell | acOLEActivateManual (0) | Das OLE-Objekt wird nicht aktiviert, wenn es den Fokus erhält oder der Benutzer auf das Steuerelement doppelklickt. Sie können das OLE-Objekt nur aktivieren, indem Sie in Visual Basic die Eigenschaft Action des Steuerelements auf acOLEActivate einstellen.
Fokus | acOLEActivateGetFocus (1) | (Nur für Steuerelemente des Typs Ungebundenes Objektfeld und Diagramm) Wenn das Steuerelement ein OLE-Objekt enthält, wird die Anwendung, die das Objekt bereitstellt, aktiviert, sobald das Steuerelement den Fokus erhalten hat.
Doppelklicken | acOLEActivateDoubleClick (2) | (Standardeinstellung) Wenn das Steuerelement ein OLE-Objekt enthält, wird die Anwendung, die das Objekt bereitstellt, aktiviert, sobald der Benutzer auf das Steuerelement doppelgeklickt oder, sofern das Steuerelement den Fokus hat, STRG+EINGABETASTE gedrückt hat.

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft AutoActivate kann nur in der Entwurfsansicht eingestellt werden.

Anmerkung

Einige OLE-Objekte können aus dem jeweiligen Steuerelement heraus aktiviert werden. Sobald ein solches Objekt aktiviert wurde, kann es innerhalb des Steuerelements bearbeitet werden (oder es können bestimmte andere Vorgänge ausgeführt werden). Dieses Feature wird als direkte Aktivierung bezeichnet. Für den Fall, dass ein Objekt die direkte Aktivierung unterstützt, finden Sie in der Dokumentation der Anwendung, mit der das Objekt erstellt wurde, Informationen darüber, wie dieses Feature verwendet werden kann.

In Visual Basic können Sie ermitteln, ob ein Steuerelement ein Objekt enthält, indem Sie die Eigenschaft OLEType des Steuerelements auswerten.

Anmerkung Wenn Sie die Eigenschaft AutoActivate eines Steuerelements auf Doppelklicken einstellen und für das Ereignis DblClick des Steuerelements einen Wert angeben, tritt das Ereignis DblClick auf, bevor das Objekt aktiviert wird.


 AutoCenter-Eigenschaft (AutomatischZentrieren)

AutoCenter-Eigenschaft (AutomatischZentrieren)

Mit der Eigenschaft AutoCenter können Sie angeben, ob ein Formular beim Öffnen automatisch im Anwendungsfenster zentriert wird.

Einstellung

Die Eigenschaft AutoCenter verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular wird beim Öffnen automatisch zentriert.
Nein | False (0) | (Standardeinstellung) Die obere linke Ecke des Formulars befindet sich an derselben Stelle wie beim letzten Speichern des Formulars.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaft nur in der Entwurfsansicht einstellen.

Anmerkung

Je nach Größe und Position des Anwendungsfensters können Formulare über eine Seite des Anwendungsfensters hinausragen, so dass ein Teil des Formulars verdeckt ist. Das automatische Zentrieren beim Öffnen des Formulars erleichtert die Anzeige und Verwendung.

Wenn Sie in der Entwurfsansicht Änderungen an einem Formular vornehmen, dessen Eigenschaft AutoResize auf Nein und dessen Eigenschaft AutoCenter auf Ja eingestellt ist, wechseln Sie in die Formularansicht, bevor Sie das Formular speichern. Andernfalls schneidet Microsoft Access beim nächsten Öffnen des Formulars dessen rechten und unteren Rand ab.


 AutoExpand-Eigenschaft (AutomatischErgänzen)

AutoExpand-Eigenschaft (AutomatischErgänzen)

Mit der Eigenschaft AutoExpand können Sie angeben, ob Microsoft Access automatisch im Textfeldteil eines Kombinationsfelds einen Wert anzeigen soll, der mit Ihrer fortlaufenden Eingabe im Kombinationsfeld übereinstimmt. Dies ermöglicht Ihnen die schnelle Eingabe eines bestehenden Wertes in ein Kombinationsfeld, ohne den Listenfeldteil des Kombinationsfelds anzuzeigen.

Einstellung

Die Eigenschaft AutoExpand verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Microsoft Access trägt in das Kombinationsfeld aus der Liste den ersten Wert ein, dessen erstes Zeichen mit Ihrem ersten Eingabezeichen übereinstimmt. Geben Sie weitere Zeichen ein, zeigt Microsoft Access jeweils die Zeichenfolge an, deren Anfang mit allen bisher eingegebenen Zeichen übereinstimmt.
Nein | False (0) | Sie müssen einen Wert der Liste auswählen oder den gesamten Wert eingeben.

Sie können die Eigenschaft AutoExpand im Eigenschaftenfenster des Kombinationsfelds, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wenn Sie Zeichen in den Textfeldteil eines Kombinationsfelds eingeben, sucht Microsoft Access in der Liste die Einträge, die mit den von Ihnen eingegebenen Zeichen übereinstimmen. Ist die Eigenschaft AutoExpand auf Ja eingestellt, zeigt Microsoft Access automatisch den ersten Listeneintrag an, der den bis zu diesem Zeitpunkt eingegebenen Zeichen entspricht.

Wenn die Eigenschaft LimitToList auf Ja eingestellt ist und die Dropdown-Kombinationsfeldliste geöffnet wird, wählt Microsoft Access in der Liste genau die Zeichenfolgen aus, die mit der fortlaufenden Eingabe des Benutzers im Textfeldteil des Kombinationsfelds übereinstimmen, selbst wenn die Eigenschaft AutoExpand auf Nein eingestellt ist. Drückt der Benutzer die EINGABETASTE oder wechselt er zu einem anderen Steuerelement oder Datensatz, wird der ausgewählte Wert im Kombinationsfeld angezeigt.


 AutoRepeat-Eigenschaft (MakroWiederholen)

AutoRepeat-Eigenschaft (MakroWiederholen)

Mit der Eigenschaft AutoRepeat können Sie angeben, ob eine Ereignisprozedur oder ein Makro wiederholt ausgeführt wird, solange die entsprechende Befehlsschaltfläche eines Formulars gedrückt ist.

Einstellung

Die Eigenschaft AutoRepeat verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Makro oder die Ereignisprozedur, das bzw. die für das Ereignis Click angegeben ist, wird wiederholt ausgeführt, solange die Befehlsschaltfläche gedrückt ist.
Nein | False (0) | (Standardeinstellung) Das Makro oder die Ereignisprozedur wird nur einmal ausgeführt.

Sie können diese Eigenschaft im Eigenschaftenfenster der jeweiligen Befehlsschaltfläche, mit einem Makro oder mit Visual Basic einstellen.

Anmerkung

Die Ereignisprozedur oder das Makro wird, nachdem es das erstemal ausgeführt wurde, 0,5 Sekunden später erneut ausgeführt. Die weiteren Wiederholungen erfolgen dann abhängig davon, welcher Zeitraum länger ist, entweder alle 0,25 Sekunden oder im Anschluss an den Zeitraum, der für die Ausführung der Ereignisprozedur bzw. des Makros benötigt wird.

Bewirkt der Code, der der Befehlsschaltfläche zugeordnet ist, dass der aktueIle Datensatz geändert wird, hat die Eigenschaft AutoRepeat keine Auswirkungen.

Bewirkt der Code, der der Befehlsschaltfläche zugeordnet ist, dass ein anderes Steuerelement des jeweiligen Formulars geändert wird, sorgen Sie mit der Funktion DoEvents dafür, dass der Bildschirm korrekt aktualisiert wird.


 AutoResize-Eigenschaft (GrößeAnpassen)

AutoResize-Eigenschaft (GrößeAnpassen)

Mit der Eigenschaft AutoResize können Sie angeben, ob die Größe eines Formularfensters beim Öffnen automatisch für die Anzeige vollständiger Datensätze angepasst wird.

Einstellung

Die Eigenschaft AutoResize kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Größe des Formularfensters wird automatisch so angepasst, dass ein vollständiger Datensatz angezeigt werden kann.
Nein | False (0) | Wird das Formularfenster geöffnet, so hat es die zuletzt gespeicherte Größe. Sie speichern die Größe eines Formularfensters, indem Sie das Formular öffnen, die Fenstergröße anpassen, das Formular durch Klicken auf Speichern im Menü Datei speichern und dann das Formular schließen. Wenn Sie das nächste Mal das Formular öffnen, wird es mit der gespeicherten Fenstergröße angezeigt.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann nur in der Entwurfsansicht eingestellt werden

Anmerkung

Die Größe des Formularfensters wird nur angepasst, wenn es in der Formularansicht geöffnet wird. Öffnen Sie das Formular zuerst in der Entwurfsansicht oder in der Datenblattansicht und wechseln dann zur Formularansicht, wird die Größe des Formularfensters nicht angepasst.

Wenn Sie in der Entwurfsansicht Änderungen an einem Formular vornehmen, dessen Eigenschaft AutoResize auf Nein und dessen Eigenschaft AutoCenter auf Ja eingestellt ist, wechseln Sie in die Formularansicht, bevor Sie das Formular speichern. Wenn Sie dies nicht tun, schneidet Microsoft Access das Formular beim nächsten Öffnen am rechten und unteren Rand ab.

Wenn die Eigenschaft AutoCenter auf Nein eingestellt ist, wird die linke obere Ecke eines Formularfensters beim Öffnen immer an derselben Stelle angezeigt, an der sie beim Schließen des Formularfensters angezeigt wurde.


 AutoTab-Eigenschaft (AutomatischWeiter)

AutoTab-Eigenschaft (AutomatischWeiter)

Mit der Eigenschaft AutoTab können Sie angeben, ob automatisch zum nächsten Feld gewechselt werden soll, wenn das letzte mit dem Eingabeformat des Steuerelements eines Textfelds mögliche Zeichen eingegeben wurde. Ein automatischer Wechsel setzt den Fokus auf das nächste Steuerelement in der Reihenfolge der Steuerelemente des Formulars.

Einstellung

Die Eigenschaft AutoTab verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Wechselt zum nächsten Feld, wenn das letzte mögliche Zeichen in einem Textfeld eingegeben wurde
Nein | False (0) | (Voreinstellung) Wechselt nicht zum nächsten Feld, wenn das letzte mögliche Zeichen in einem Textfeld eingegeben wurde

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können die Voreinstellung mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Die Eigenschaft AutoTab wirkt sich in der Formularansicht und in der Datenblattansicht auf die Reihenfolge der Steuerelemente aus.

Anmerkung

Sie erstellen ein Eingabeformat für ein Steuerelement unter Verwendung der Eigenschaft InputMask.

Sie können auch ein Eingabeformat für ein Textfeld-Steuerelement erstellen, das an ein Feld gebunden ist, indem Sie die Eigenschaft InputMask für das Feld in der dem Formular zugrunde liegenden Tabelle oder Abfrage einstellen. Wird das Feld aus der Feldliste auf ein Formular gezogen, dann wird das Eingabeformat des Feldes vom Textfeld-Steuerelement geerbt.

Sie können die Eigenschaft AutoTab beispielsweise verwenden, wenn ein Formular ein Textfeld enthält, in das Sie in der Regel die zulässige Höchstzahl an Zeichen für jeden Datensatz eingeben. Nachdem Sie die maximale Anzahl an Zeichen eingegeben haben, wird der Fokus auf das nächste Steuerelement in der Reihenfolge verschoben. Sie könnten diese Eigenschaft z.B. für ein Feld namens Kategorietyp verwenden, das immer fünf Zeichen enthalten muss.


 BackColor-Eigenschaft (Hintergrundfarbe)

BackColor-Eigenschaft (Hintergrundfarbe)

Mit der BackColor-Eigenschaft können Sie die Farbe im Inneren eines Steuerelements oder Bereichs angeben.

Einstellung

Die BackColor-Eigenschaft enthält einen numerischen Ausdruck, welcher der Farbe entspricht, in der das Innere eines Steuerelements oder Bereichs angezeigt werden soll.

Sie können den Farb-Generator verwenden, um diese Eigenschaft einzustellen, indem Sie auf die Schaltfläche Erstellen [image] rechts neben der Eigenschaft im Eigenschaftenfenster klicken. Mit dem Farb-Generator können Sie benutzerdefinierte Hintergrundfarben für Steuerelemente und Bereiche definieren.

Sie können diese Eigenschaft auch mit Füll-Hintergrundfarbe [image] in der Symbolleiste Formatierung (Formular/Bericht), im Eigenschaftenfenster eines Steuerelements oder Bereichs, in einem Makro oder in Visual Basic einstellen.

In Visual Basic verwenden Sie einen numerischen Ausdruck, um diese Eigenschaft einzustellen. Die Einstellung für diese Eigenschaft hat den Datentyp Long.

Sie können die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder der DefaultControl-Methode in Visual Basic einstellen.

Bei Table-Objekten können Sie diese Eigenschaft einstellen, indem Sie Füllen/Hintergrundfarbe [image] in der Symbolleiste Format (Datenblatt) oder in Visual Basic die DatasheetBackColor-Eigenschaft verwenden.

Anmerkungen

Sie können die BackColor-Eigenschaft nur verwenden, wenn die BackStyle-Eigenschaft (falls verfügbar) auf Normal eingestellt ist.


 BackStyle-Eigenschaft (Hintergrundart)

BackStyle-Eigenschaft (Hintergrundart)

Mit der Eigenschaft BackStyle können Sie angeben, ob ein Steuerelement durchsichtig (transparent) sein soll.

Einstellung

Die Eigenschaft BackStyle verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Normal | 1 | (Standardeinstellung für alle Steuerelemente mit Ausnahme der Optionsgruppe) Die Farbe für das Innere des Steuerelements wird durch die Eigenschaft BackColor eingestellt.
Transparent | 0 | (Standardeinstellung für die Optionsgruppe) Das Steuerelement ist transparent. Die Farbe des Formulars oder Berichts hinter dem Steuerelement ist sichtbar.

Sie können diese Eigenschaft mit Schrift-/Vordergrundfarbe [image] in der Symbolleiste Formatierung (Formular/Bericht) im Eigenschaftenfenster eines Steuerelements oder Bereichs, in einem Makro oder in Visual Basic einstellen.

Sie können die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Ist in der Palette der Schaltfläche Hintergrundfarbe die Schaltfläche Transparent ausgewählt, so wird die Eigenschaft BackStyle auf Transparent eingestellt; andernfalls auf Normal.

Tipp Sie blenden eine Befehlsschaltfläche aus, indem Sie deren Eigenschaft Transparent auf Ja einstellen.


 BaseConnectionString-Eigenschaft

BaseConnectionString-Eigenschaft

Mit der BaseConnectionString-Eigenschaft können Sie auf die Haupt-Verbindungszeichenfolge des CurrentProject-Objekts oder des CodeProject-Objekts zugreifen.

Einstellung

Die BaseConnectionString-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Die BaseConnectionString-Eigenschaft liefert die Verbindungszeichenfolge, die durch die OpenConnection-Methode oder mit Hilfe des Befehls Verbindung im Menü Datei definiert worden ist. Beim Herstellen der Verbindung modifiziert das Microsoft Access-Projekt die BaseConnectionString-Eigenschaft und passt sie der ADO-Umgebung an.


 Bezeichnungsausrichtung-Eigenschaft, TextAlign-Eigenschaft (Textausrichtung)

Bezeichnungsausrichtung-Eigenschaft, TextAlign-Eigenschaft (Textausrichtung)

  • Die Bezeichnungsausrichtung-Eigenschaft gibt die Textausrichtung innerhalb zugeordneter Bezeichnungsfelder in neuen Steuerelementen an.

  • Die TextAlign-Eigenschaft gibt die Textausrichtung in neuen Steuerelementen an.

Einstellung

Die Bezeichnungsausrichtung-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Allgemein | (Standardeinstellung) Der Text im Bezeichnungsfeld wird am linken Rand ausgerichtet.
Linksbündig | Der Text im Bezeichnungsfeld wird am linken Rand ausgerichtet.
Zentriert | Der Text im Bezeichnungsfeld wird zentriert.
Rechtsbündig | Der Text im Bezeichnungsfeld wird am rechten Rand ausgerichtet.

Sie können die Bezeichnungsausrichtung-Eigenschaft unter Verwendung der Standardsteuerelementeinstellung eines Steuerelements oder mit der DefaultControl-Methode in Visual Basic einstellen.

Die TextAlign-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Allgemein | 0 | (Standardeinstellung) Text wird am linken Rand ausgerichtet; Zahlen und Datumsangaben werden am rechten Rand ausgerichtet.
Linksbündig | 1 | Text, Zahlen und Datumsangaben werden am linken Rand ausgerichtet.
Zentriert | 2 | Text, Zahlen und Datumsangaben werden zentriert.
Rechtsbündig | 3 | Text, Zahlen und Datumsangaben werden am rechten Rand ausgerichtet.

Sie können die TextAlign-Eigenschaft im Eigenschaftenfenster des Steuerelements, mit einem Makro oder in Visual Basic einstellen.

Außerdem können Sie die TextAlign-Eigenschaft einstellen, indem Sie auf der Symbolleiste Formatierung (Formular/Bericht) auf Linksbündig [image] , Zentriert [image] oder Rechtsbündig [image] klicken.

Die Standardeinstellung für die TextAlign-Eigenschaft können Sie unter Verwendung der Standardsteuerelementeinstellung eines Steuerelements oder mit der DefaultControl-Methode in Visual Basic festlegen.

Anmerkung

Erstellte Steuerelemente besitzen ein zugeordnetes Bezeichnungsfeld (sofern ihre MitBezeichnungsfeld-Eigenschaft auf Ja eingestellt ist). Änderungen an der Standardsteuerelementeinstellung für Bezeichnungsausrichtung wirken sich nur auf Steuerelemente aus, die im aktuellen Formular oder Bericht erstellt wurden. Informationen darüber, wie die Standardsteuerelementeinstellung für alle neuen Formulare oder Berichte, die ohne einen Microsoft Access-Assistenten erstellt wurden, geändert wird, finden Sie unter Festlegen einer neuen Vorlage für Formulare und Berichte .


 BezeichnungsfeldX-, BezeichnungsfeldY-Eigenschaften

BezeichnungsfeldX-, BezeichnungsfeldY-Eigenschaften

Mit den Eigenschaften BezeichnungsfeldX und BezeichnungsfeldY können Sie die Position eines Bezeichnungsfelds ändern, das einem neuen Steuerelement zugeordnet ist. Sie können z. B. angeben, dass ein zugeordnetes Bezeichnungsfeld nicht links, sondern rechts neben dem entsprechenden Steuerelement angezeigt wird.

Einstellung

Geben Sie eine positive oder negative Zahl ein, die den Abstand angibt, der zwischen dem Text des Bezeichnungsfelds und der oberen linken Ecke des Steuerelements liegen soll, dem das Bezeichnungsfeld zugeordnet ist. Wenn Sie eine andere Maßeinheit verwenden möchten als die, die in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen festgelegt ist, geben Sie die Einheit an (z. B. 2 cm oder 1,5 Zoll).

Sie können diese Eigenschaften nur mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Mit der Eigenschaft BezeichnungsfeldX wird der Abstand auf der horizontalen Achse und mit der Eigenschaft BezeichnungsfeldY wird der Abstand auf der vertikalen Achse eingestellt. Ist die Eigenschaft BezeichnungsfeldX auf eine negative Zahl eingestellt, wird die obere linke Ecke des Bezeichnungsfelds links vom Steuerelement angeordnet. Ist die Eigenschaft BezeichnungsfeldY auf eine negative Zahl eingestellt, wird die obere linke Ecke des Bezeichnungsfelds oberhalb des Steuerelements angeordnet. Sind beide Eigenschaften auf eine positive Zahl eingestellt, wird das Bezeichnungsfeld rechts von und unterhalb der oberen linken Ecke des Steuerelements angezeigt.

Wenn die Eigenschaft Bezeichnungsausrichtung auf Rechtsbündig oder Linksbündig eingestellt ist, geben die Eigenschaften BezeichnungsfeldX und BezeichnungsfeldY den Abstand an, der zwischen der rechten bzw. linken Kante des Bezeichnungsfelds und der oberen linken Ecke des Steuerelements liegt. Ist die Eigenschaft Bezeichnungsausrichtung auf Zentriert eingestellt, geben die Eigenschaften BezeichnungsfeldX und BezeichnungsfeldY den Abstand an, der zwischen der Mitte des Bezeichnungsfelds und der oberen linken Ecke des Steuerelements liegt.

Verschiedene Kombinationen der Eigenschaften BezeichnungsfeldX, BezeichnungsfeldY und Bezeichnungsausrichtung führen zu folgenden Ergebnissen.

BezeichnungsfeldX | BezeichnungsfeldY | Bezeichnungsausrichtung | Ergebnis
-1 Zoll | 0 Zoll | Standard | Die obere linke Ecke des Bezeichnungsfelds befindet sich 1 Zoll links von der oberen linken Ecke des Steuerelements.
-0,5 Zoll | 0 Zoll | Rechtsbündig | Die obere rechte Ecke des Bezeichnungsfelds befindet sich 0,5 Zoll links von der oberen linken Ecke des Steuerelements.
0,5 Zoll | -0,5 Zoll | Zentriert | Der mittlere Punkt der oberen Kante des Bezeichnungsfelds befindet sich 0,5 Zoll rechts und 0,5 Zoll oberhalb der oberen linken Ecke des Steuerelements.


 Bookmark-Eigenschaft (Microsoft Access)

Bookmark-Eigenschaft (Microsoft Access)

Sie können die Bookmark-Eigenschaft in Verbindung mit Formularen verwenden, um ein Lesezeichen zu definieren, das eindeutig einen bestimmten Datensatz kennzeichnet, die dem Formular über eine Tabelle, Abfrage oder SQL-Anweisung zugrunde liegt.

Einstellung

Die Bookmark-Eigenschaft enthält einen von Microsoft Access generierten Zeichenfolgenausdruck.

Sie können diese Eigenschaft mit Hilfe eines Makros oder durch Visual Basic-Code einstellen.

Anmerkung Die Bookmark-Eigenschaft des Formulars wird unabhängig von der ADO Bookmark-Eigenschaft oder der DAO Bookmark-Eigenschaft der zugrunde liegenden Tabelle oder Abfrage abgefragt bzw. gesetzt.

Anmerkungen

Wird ein gebundenes Formular in der Formularansicht geöffnet, erhält jeder Datensatz ein eindeutiges Lesezeichen zugewiesen. Unter Visual Basic können Sie das Lesezeichen des aktuellen Datensatzes speichern, indem Sie den Wert der Bookmark-Formulareigenschaft einer Stringvariablen zuweisen. Wenn Sie einen gespeicherten Datensatz erneut abrufen möchten, nachdem Sie zwischenzeitlich zu einem anderen Datensatz gewechselt sind, weisen Sie der Bookmark-Eigenschaft des Formulars den in der Stringvariablen gespeicherten Wert zu. Mit der StrComp-Funktion können Sie den Wert einer Variant- oder Stringvariablen mit einem Lesezeichen vergleichen bzw. den Vergleich zwischen zwei Lesezeichen durchführen. Das dritte Argument der StrComp-Funktion muss auf einen Wert von Null gesetzt werden.

Anmerkung Lesezeichen werden nicht in den Datensätzen gespeichert, die sie repräsentieren, und besitzen nur Gültigkeit, solange das Formular geöffnet ist. Sie werden bei jedem Öffnen eines gebundenen Formulars von Microsoft Access neu generiert.

Es gibt keine Beschränkung hinsichtlich der Anzahl der gespeicherten Lesezeichen, sofern jedes von ihnen in einer separaten Stringvariablen gespeichert wird.

Die Bookmark-Eigenschaft ist jeweils nur für den aktuellen Datensatz des Formulars verfügbar. Um das Lesezeichen eines anderen Datensatzes zu speichern, müssen Sie auf den gewünschten Datensatz wechseln, und den Wert der Bookmark-Eigenschaft in einer Stringvariablen speichern, die diesen Datensatz kennzeichnet.

Lesezeichen können in jedem Formular verwendet werden, das komplett auf Microsoft Access-Tabellen basiert. Allerdings unterstützen andere Datenbankprogramme möglicherweise keine Lesezeichen. So können Sie beispielsweise in einem Formular, dem eine verknüpfte Tabelle ohne Primärindex zugrunde liegt, keine Lesezeichen benutzen.

Das erneute Abfragen eines Formulars bewirkt, dass alle möglicherweise für Datensätze des Formulars definierten Lesezeichen ungültig werden. Allerdings gilt das nicht für den Befehl Aktualisieren im Menü Datensätze, der nicht die Lesezeichen betrifft.

Da Microsoft Access beim Öffnen eines Formulars für jeden Datensatz in der Datensatzgruppe des Formulars ein eindeutiges Lesezeichen generiert, kann ein solches Formularlesezeichen nicht in Verbindung mit einer anderen Datensatzgruppe funktionieren, selbst dann nicht, wenn die beiden Datensatzgruppen auf Grundlage derselben Tabelle, Abfrage oder SQL-Anweisung erstellt wurden. Angenommen, Sie öffnen ein an die Tabelle Kunden gebundenes Formular. Wenn Sie die Tabelle Kunden anschließend mit Visual Basic öffnen und die ADO Seek-Methode oder die DAO Seek-Methode verwenden, um nach einem bestimmten Datensatz in der Tabelle zu suchen, können Sie die Bookmark-Eigenschaft nicht auf den aktuellen Tabellendatensatz setzen. Zur Durchführung einer derartigen Operation können Sie die ADO Find-Methode oder die DAO Find-Methode in Kombination mit der RecordsetClone-Eigenschaft des Formulars verwenden.

Wenn Sie die Bookmark-Eigenschaft auf den Wert einer Stringvariablen setzen, die das Lesezeichen eines zuvor gelöschten Datensatz enthält, und anschließend versuchen, zu diesem Datensatz zu gelangen, tritt ein Fehler auf.

Der Wert der Bookmark-Eigenschaft ist nicht dasselbe wie eine Datensatznummer.


 BorderColor-Eigenschaft (Rahmenfarbe)

BorderColor-Eigenschaft (Rahmenfarbe)

Mit der Eigenschaft BorderColor können Sie die Farbe des Rahmens eines Steuerelements angeben.

Einstellung

Die Einstellung der Eigenschaft BorderColor ist ein numerischer Ausdruck, der der Farbe entspricht, die Sie für den Rahmen des Steuerelements verwenden möchten.

Sie können diese Eigenschaft mit dem Farb-Editor einstellen, indem Sie im Eigenschaftenfenster auf die Generator-Schaltfläche [image] rechts neben der Eigenschaft klicken. Mit Hilfe des Farb-Editors können Sie benutzerdefinierte Rahmenfarben für Steuerelemente definieren.

Sie können diese Eigenschaft auch mit Linien-/Rahmenfarbe [image] aus der Symbolleiste Formatierung (Formular/Bericht), mit einem Makro oder mit Visual Basic einstellen.

Sie können die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Die Rahmenfarbe eines Steuerelements ist nur sichtbar, wenn dessen Eigenschaft SpecialEffect auf Flach oder Schattiert eingestellt ist. Ist die Eigenschaft SpecialEffect auf einen anderen Wert als Flach oder Schattiert eingestellt, wird deren Einstellung in Flach geändert, sobald die Eigenschaft BorderColor eingestellt wurde.


 BorderStyle-Eigenschaft (Rahmenart)

BorderStyle-Eigenschaft (Rahmenart)

  • Formulare. Mit der Rahmenart-Eigenschaft können Sie den Typ des Rahmens und der Rahmenelemente (Titelleiste, Systemmenü, Schaltflächen Minimieren und Maximieren oder Schaltfläche Schließen) zur Verwendung für das Formular angeben. In der Regel verwenden Sie unterschiedliche Rahmenarten für normale Formulare, Popupformulare und benutzerdefinierte Dialogfelder.

  • Steuerelemente. Mit der Rahmenart-Eigenschaft können Sie angeben, wie der Rahmen eines Steuerelements aussehen soll.

Einstellung

Bei Formularen verwendet die Rahmenart-Eigenschaft die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keine | 0 | Das Formular hat keine Rahmen oder zugehörige Rahmenelemente. Die Größe des Formulars kann nicht geändert werden.
Dünn | 1 | Das Formular hat einen dünnen Rahmen und kann jedes der Rahmenelemente enthalten. Seine Größe kann nicht geändert werden (der Befehl Größe im Systemmenü ist nicht verfügbar). Diese Einstellung verwenden Sie oft für Popupformulare. (Wenn ein Formular im Vordergrund vor allen Microsoft Access-Fenstern bleiben soll, müssen Sie außerdem seine PopUp-Eigenschaft auf Ja einstellen.)
Veränderbar | 2 | (Standardeinstellung) Das Formular hat den Standardrahmen für Microsoft Access-Formulare, kann jedes der Rahmenelemente enthalten, und seine Größe kann geändert werden. Diese Einstellung verwenden Sie oft für normale Microsoft Access-Formulare.
Dialog | 3 | Das Formular hat einen dicken (doppelten) Rahmen und kann nur eine Titelleiste, eine Schaltfläche Schließen und ein Systemmenü enthalten. Das Formular kann nicht maximiert, minimiert oder in seiner Größe geändert werden (die Befehle Maximieren, Minimimieren und Größe sind im Systemmenü nicht verfügbar). Diese Einstellung verwenden Sie oft für benutzerdefinierte Dialogfelder. (Wenn ein Formular jedoch gebunden sein soll, müssen Sie außerdem seine Modal-Eigenschaft auf Ja einstellen. Soll es ein gebundenes Popupformular (die übliche Form von Dialogfeldern) sein, müssen Sie die beiden Eigenschaften PopUp und Modal auf Ja einstellen.)

Sie können die Rahmenart-Eigenschaft für ein Formular nur in der Entwurfsansicht für Formulare im Eigenschaftenfenster des Formulars, mit einem Makro oder in Visual Basic einstellen.

Bei Steuerelementen verwendet die Rahmenart-Eigenschaft die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Transparent | 0 | (Standardeinstellung nur für Bezeichnung, Diagramm und Unterbericht) Transparent
Durchgezogen | 1 | (Standardeinstellung) Durchgezogene Linie
Strichlinien | 2 | Gestrichelte Linie
Kurze Strichlinien | 3 | Gestrichelte Linie mit kurzen Strichen
Punkte | 4 | Gepunktete Linie
Wenige Punkte | 5 | Gepunktete Linie mit weit auseinander liegenden Punkten
Strichlinie Punkt | 6 | Linie mit einer Kombination aus Strich-Punkt
Strichlinie Punkt Punkt | 7 | Linie mit einer Kombination aus Strich-Punkt-Punkt
Doppelt durchgezogen | 8 | Doppelte durchgezogene Linien

Sie können die Rahmenart-Eigenschaft für ein Steuerelement in dessen Eigenschaftenfenster, mit einem Makro oder in Visual Basic einstellen.

Die Standardeinstellung für diese Eigenschaft können Sie unter Verwendung der Standardsteuerelementeinstellung eines Steuerelements oder mit der DefaultControl-Methode in Visual Basic festlegen.

Anmerkung

Die Rahmenart eines Steuerelements ist nur sichtbar, wenn seine Spezialeffect-Eigenschaft auf Flach oder Schattiert eingestellt ist. Ist die Spezialeffect-Eigenschaft auf einen anderen Wert als Flach oder Schattiert eingestellt, wird sie durch das Einstellen der Rahmenart-Eigenschaft auf Flach geändert.

Bei einem Formular richtet die Rahmenart-Eigenschaft die Merkmale ein, die es als normales Formular, Popupformular oder benutzerdefiniertes Dialogfeld kennzeichnen. Zum weiteren Festlegen der Formularmerkmale können Sie auch die Eigenschaften Modal und PopUp einstellen.

Darüber hinaus können Sie bei Bedarf die Eigenschaften Mit Systemmenüfeld, Schließen Schaltfläche, MinMaxSchaltflächen, Bildlaufleisten, Navigationsschaltflächen und Datensatzmarkierer des Formulars einstellen. Diese Eigenschaften wirken folgendermaßen zusammen:

  • Ist die Rahmenart-Eigenschaft auf Keine oder Dialog eingestellt, enthält das Formular (unabhängig von der Einstellung der MinMaxSchaltflächen-Eigenschaft) keine Schaltfläche Maximieren bzw. Minimieren.

  • Ist die Rahmenart-Eigenschaft auf Keine eingestellt, enthält das Formular (unabhängig von der Einstellung der Mit Systemmenüfeld-Eigenschaft) kein Systemmenü.

  • Die Einstellung der Rahmenart-Eigenschaft wirkt sich nicht auf die Anzeige der Bildlaufleisten, der Navigationsschaltflächen, des Datensatznummernfeldes oder der Datensatzmarkierer aus.

Die Rahmenart-Eigenschaft ist nur in der Formularansicht wirksam. Die Eigenschafteneinstellung wird in der Entwurfsansicht für Formulare ignoriert.

Wenn Sie die Rahmenart-Eigenschaft eines Popupformulars auf Keine einstellen, können Sie das Formular nicht schließen, außer wenn Sie die Schaltfläche Schließen eingefügt haben. Diese führt ein Makro mit der Aktion Schließen oder in Visual Basic eine Ereignisprozedur aus, die die Close-Methode verwendet.

Popupformulare haben normalerweise eine feste Größe. Sie können ein solches Formular jedoch veränderbar machen, indem Sie seine PopUp-Eigenschaft auf Ja und seine Rahmenart-Eigenschaft auf Veränderbar einstellen.

Außerdem können Sie die Einstellung Dialog des Arguments Fenstermodus der Aktion ÖffnenFormular verwenden, um die Eigenschaften Modal und PopUp eines Formulars auf Ja einzustellen.


 BorderWidth-Eigenschaft (Rahmenbreite)

BorderWidth-Eigenschaft (Rahmenbreite)

Mit der Eigenschaft BorderWidth können Sie die Breite eines Steuerelementrahmens angeben.

Einstellung

Die Eigenschaft BorderWidth verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Haarlinie | 0 | (Standardeinstellung) Der schmalste auf dem System mögliche Rahmen.
1 pt bis 6 pt | 1 to 6 | Die Breite in Punkt.

Sie können diese Eigenschaft mit Linien-/Rahmenbreite [image] in der Symbolleiste Formatierung (Formular/Bericht), im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Sie können die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Sie können die Eigenschaft BorderWidth nur verwenden, wenn die Eigenschaft SpecialEffect auf Flach oder Schattiert eingestellt ist und die Eigenschaft BorderStyle nicht auf Transparent eingestellt ist. Wenn die Eigenschaft SpecialEffect auf einen anderen Wert und/oder die Eigenschaft BorderStyle auf Transparent eingestellt ist und Sie die Eigenschaft BorderWidth einstellen, wird die Eigenschaft SpecialEffect automatisch auf Flach und die Eigenschaft BorderStyle auf Durchgezogen zurückgesetzt.

Die genaue Rahmenbreite hängt vom Computer und Drucker ab. Auf manchen Systemen werden die Rahmenbreiten Haarlinie und 1 pt identisch dargestellt.


 LeftMargin-, TopMargin-, RightMargin-, BottomMargin-Eigenschaften (LinkerRand, ObererRand, RechterRand, UntererRand)

LeftMargin-, TopMargin-, RightMargin-, BottomMargin-Eigenschaften (LinkerRand, ObererRand, RechterRand, UntererRand)

Mit den LeftMargin-, TopMargin-, RightMargin- und BottomMargin-Eigenschaften können Sie die Position angeben oder ermitteln, an der Daten in einem Bezeichnungsfeld- oder Textfeld-Steuerelement angezeigt werden. So können Sie beispielsweise festlegen, dass Informationen in einem Textfeld-Steuerelement mit 0.25 Zoll Abstand vom linken und oberen Rand angezeigt werden.

Einstellung

Die Position der in einem Steuerelement angezeigten Information ist der Abstand zwischen dem linken, oberen, rechten oder unteren Rand des Steuerelements und jeweils dem linken, oberen, rechten oder unteren Rand der angezeigten Information. Wenn Sie die LeftMargin- oder TopMargin-Eigenschaft auf 0 festlegen, liegt die Kante der angezeigten Information unmittelbar am linken bzw. oberen Rand des Steuerelements an. Um eine andere als die im Dialogfeld Ländereinstellungen in der Windows-Systemsteuerung eingestellte Maßeinheit zu verwenden, geben Sie die die gewünschte Einheit, etwa cm oder Zoll, an (z. B. 3 cm oder 2 Zoll).

In Visual Basic geben Sie den Wert für diese Eigenschaft mit einem numerischen Ausdruck an. Werte werden in Twips ausgedrückt.

Sie können diese Eigenschaften im Eigenschaftenfenster, in einem Makro oder in Visual Basic festlegen.


 BoundColumn-Eigenschaft (GebundeneSpalte)

BoundColumn-Eigenschaft (GebundeneSpalte)

Wenn Sie eine Auswahl in einem Listenfeld oder Kombinationsfeld treffen, ermittelt Microsoft Access aus der Eigenschaft BoundColumn, aus welcher Spalte die Werte für das Steuerelement verwendet werden sollen. Ist das Steuerelement an ein Feld gebunden, so wird der Wert in der von der Eigenschaft BoundColumn festgelegten Spalte in dem Feld gespeichert, das in der Eigenschaft ControlSource genannt wird.

Einstellung

Die Eigenschaft BoundColumn verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
0 | Der Wert der Eigenschaft ListIndex wird an Stelle des Spaltenwerts im aktuellen Datensatz gespeichert. Der Wert von ListIndex ist für die erste Zeile 0, für die zweite Zeile 1 usw. Microsoft Access stellt die Eigenschaft ListIndex ein, wenn ein Eintrag aus einem Listenfeld oder dem Listenfeldteil eines Kombinationsfelds ausgewählt wird. Das Einstellen der Eigenschaft BoundColumn auf 0 und das Verwenden des Wertes der Eigenschaft ListIndex des Steuerelements sind hilfreich, wenn Sie z.B. lediglich eine Folge von Zahlen speichern möchten.
1 oder größer | (Standardeinstellung ist 1) Der Wert in der angegebenen Spalte wird zum Steuerelementwert. Ist das Steuerelement an ein Feld gebunden, so wird der Wert im betreffenden Feld des aktuellen Datensatzes gespeichert. Die Eigenschaft BoundColumn kann auf keinen Wert eingestellt werden, der größer als der Wert der Eigenschaft ColumnCount ist.

Sie können die Eigenschaft Gebunden im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld oder Listenfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft BoundColumn automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Stellen Sie in Visual Basic die Eigenschaft BoundColumn unter Verwendung einer Zahl oder eines numerischen Ausdrucks auf einen Wert ein, der zwischen 0 und dem Wert der Eigenschaft ColumnCount liegt.

Anmerkung

Die am weitesten links sichtbare Spalte in einem Kombinationsfeld (das ist die am weitesten links liegende Spalte des Kombinationsfelds, dessen Eigenschaft ColumnWidths nicht auf 0 eingestellt ist), enthält die Daten, die im Textfeldteil des Kombinationsfelds in der Formularansicht oder in einem Bericht angezeigt werden. Die Eigenschaft BoundColumn legt fest, welche Spalte der Text- oder Kombinationsfeldliste gespeichert wird, wenn Sie eine Auswahl treffen. Dadurch können Sie andere Daten anzeigen als die, die Sie als Wert des Steuerelements gespeichert haben.

Anmerkung Entspricht die gebundene Spalte nicht der am weitesten links sichtbaren Spalte des Steuerelements (oder haben Sie die Eigenschaft BoundColumn auf 0 eingestellt), so wird die Eigenschaft LimitToList auf Ja eingestellt.

Microsoft Access verwendet zum Verweisen auf Spalten in der Eigenschaft Column Zahlen ab Null. Auf die erste Spalte wird mit dem Ausdruck Column(0)verwiesen, auf die zweite Spalte mit dem Ausdruck Column(1) usw. Dagegen verwendet die Eigenschaft BoundColumn Zahlen ab Eins, um auf Spalten zu verweisen. Das bedeutet, dass Sie mit dem Ausdruck Column(0) auf den in dieser Spalte gespeicherten Wert zugreifen können, falls die Eigenschaft BoundColumn auf 1 eingestellt ist.

Ist die Eigenschaft AutoExpand auf Ja eingestellt, so füllt Microsoft Access den Textfeldteil des Kombinationsfelds automatisch mit einem Wert, der den von Ihnen in das Kombinationsfeld eingegebenen Zeichen entspricht.


 BuiltIn-Eigenschaft

BuiltIn-Eigenschaft

Die Eigenschaft BuiltIn gibt einen Wert des Datentyps Boolean zurück, der angibt, ob ein Reference-Objekt auf einen Standardverweis zeigt, den Microsoft Access benötigt, um korrekt arbeiten zu können.

Einstellung

Die Eigenschaft BuiltIn steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Die Eigenschaft BuiltIn gibt einen der folgenden Werte zurück.

Wert | Beschreibung
True (-1) | Das Reference-Objekt verweist auf einen Standardverweis, der nicht gelöscht werden kann.
False (0) | Das Reference-Objekt verweist auf einen Verweis, der kein Standardverweis und folglich nicht erforderlich ist, damit Microsoft Access korrekt arbeitet.

Anmerkung

Die Standardverweise in Microsoft Access beinhalten folgende Bibliotheken: Microsoft Access 9.0 Object Library, Visual Basic für Anwendungen-Bibliothek, OLE-Automatisierungs-Bibliothek und Microsoft ActiveX Data Objects 2.0-Bibliothek.


 Callback-Eigenschaft

Callback-Eigenschaft

Sie verwenden die Callback-Eigenschaft, wenn Sie mit einer nicht gebundenen Sprechblase arbeiten. Eine nicht gebundene Sprechblase ermöglicht dem Benutzer, zurück zu der Anwendung zu wechseln, in der er gerade arbeitet, ohne die Sprechblase vorher zu schließen. Eine nicht gebundene Sprechblase kann z. B. beim Erstellen von Hilfe sinnvoll sein, die der Benutzer geöffnet lassen möchte, während er verschiedene Schritte in der Anwendung ausführt. Wenn Sie die Mode-Eigenschaft des Balloon-Objekts auf msoModeModeless einstellen, wird die Sprechblase ungebunden.

Die Callback-Eigenschaft bestimmt, welche Funktion oder welches Makro ausgeführt wird, wenn der Benutzer auf eine Schaltfläche in einer Sprechblase klickt. Wenn Sie eine Funktion schreiben, die von der Callback-Eigenschaft aufgerufen wird, können Sie mit dieser Funktion feststellen, auf welche Schaltfläche geklickt wurde.

Sie können die Callback-Eigenschaft auf den Namen einer Funktion oder eines Makros einstellen. Folgender Code legt die Callback-Eigenschaft fest:

Assistant.NewBalloon.Callback = "KontrollkästchenAuswerten"

Beachten Sie, dass Sie die Callback-Eigenschaft auf den Namen einer Funktion, nicht aber auf den Namen einer Sub-Prozedur einstellen können. Die Funktion muss öffentlich sein.


 Cancel-Eigenschaft (Abbrechen)

Cancel-Eigenschaft (Abbrechen)

Mit der Eigenschaft Cancel können Sie für eine Befehlsschaltfläche angeben, ob sie gleichzeitig die Schaltfläche Abbrechen des Formulars sein soll.

Einstellung

Die Eigenschaft Cancel kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Befehlsschaltfläche ist die Schaltfläche Abbrechen.
Nein | False (0) | (Standardeinstellung) Die Befehlsschaltfläche ist nicht die Schaltfläche Abbrechen.

Sie können diese Eigenschaft im Eigenschaftenfenster der Befehlsschaltfläche, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wird die Eigenschaft Cancel einer Befehlsschaltfläche auf Ja eingestellt, wird diese zur Schaltfläche Abbrechen des Formulars. Sie müssen aber nach wie vor das Makro oder die Visual Basic-Ereignisprozedur schreiben, in der die Schritte ausgeführt werden, die als Reaktion auf das Wählen der Schaltfläche Abbrechen erfolgen sollen (z. B. Schließen des Formulars, ohne dass vorgenommene Änderungen gespeichert werden). Stellen Sie die Ereigniseigenschaft OnClick der Befehlsschaltfläche auf den Namen des Makros oder auf [Ereignisprozedur] ein.

Wenn die Eigenschaft Cancel einer Befehlsschaltfläche auf Ja eingestellt und das Formularfenster aktiv ist, kann der Benutzer die Befehlsschaltfläche wählen, indem er ESC drückt, indem er die EINGABETASTE drückt, wenn die Befehlsschaltfläche den Fokus hat, oder indem er auf die Befehlsschaltfläche klickt.

Anmerkung Hat ein Textfeld den Fokus, wenn der Benutzer ESC drückt, gehen alle an den Daten in dem Textfeld vorgenommenen Veränderungen verloren, und die Originaldaten werden wiederhergestellt.

Ist die Eigenschaft Cancel einer Befehlsschaltfläche eines Formulars auf Ja eingestellt, wird diese Eigenschaft für alle anderen Befehlsschaltflächen des Formulars automatisch auf Nein eingestellt.

Tipp In Formularen, die unwiderrufliche Operationen (z. B. das Löschen von Daten) unterstützen, sollte die Schaltfläche Abbrechen die Standard-Befehlsschaltfläche sein. Dazu stellen Sie die Eigenschaften Cancel und Default auf Ja ein.


 CanGrow-, CanShrink-Eigenschaften (Vergrößerbar, Verkleinerbar)

CanGrow-, CanShrink-Eigenschaften (Vergrößerbar, Verkleinerbar)

Mit den Eigenschaften CanGrow und CanShrink können Sie das Aussehen von Bereichen oder Steuerelementen eines Formulars oder Berichts steuern, das bzw. der gedruckt oder in der Seitenansicht angezeigt wird. Wenn Sie z. B. beide Eigenschaften auf Ja einstellen, wird die Höhe eines Bereichs oder Steuerelements automatisch so angepasst, dass alle Daten gedruckt oder angezeigt werden, die der Bereich oder das Steuerelement enthält.

Anmerkungen

  • Die Eigenschaften CanGrow und CanShrink betreffen weder den Seitenkopf- noch den Seitenfußbereich eines Formulars oder Berichts, betreffen aber die Steuerelemente, die sich in einem solchen Bereich befinden.

  • Diese Eigenschaften wirken sich nur dann auf die Anzeige von Bereichen und Steuerelementen eines Formulars aus, wenn das Formular gedruckt oder in der Seitenansicht angezeigt wird. Wird das Formular in der Formularansicht, Datenblattansicht oder Entwurfsansicht angezeigt, sind diese Eigenschaften wirkungslos.

Einstellung

Die Eigenschaft CanGrow verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Höhe des Bereichs oder Steuerelements wird vergrößert, so dass alle Daten, die der Bereich oder das Steuerelement enthält, gedruckt oder angezeigt werden können.
Nein | False (0) | (Standardeinstellung) Der Bereich oder das Steuerelement wird nicht vergrößert. Daten, die nicht in den Bereich oder das Steuerelement fester Größe hineinpassen, werden weder gedruckt noch in der Seitenansicht angezeigt.

Die Eigenschaft CanShrink verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True | Die Höhe des Bereichs oder Steuerelements wird so verkleinert, dass alle Daten, die der Bereich oder das Steuerelement enthält, gedruckt oder angezeigt werden, ohne dass leere Zeilen vorhanden sind.
Nein | False | (Standardeinstellung) Der Bereich oder das Steuerelement wird nicht verkleinert.

Sie können diese Eigenschaft im Eigenschaftenfenster des Bereichs oder Steuerelements einstellen.

Bei Steuerelementen können Sie die Standardeinstellungen für diese Eigenschaften mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

Die Einstellungen dieser Eigenschaften sind in allen Ansichten, mit Ausnahme der Entwurfsansicht, in einem Makro oder in Visual Basic schreibgeschützt.

Anmerkung

Mit diesen Eigenschaften können Sie das Aussehen gedruckter Formulare oder Berichte steuern. Wenn Sie beide Eigenschaften auf Ja einstellen, wird die Größe des zugehörigen Objekts automatisch so angepasst, dass Daten beliebigen Umfangs gedruckt werden können. Wenn ein Steuerelement vergrößert oder verkleinert wird, werden die Steuerelemente, die sich unterhalb dieses Steuerelements befinden, auf der Seite nach unten bzw. oben verschoben.

Wenn Sie die Eigenschaft CanGrow eines Steuerelements auf Ja einstellen, stellt Microsoft Access die Eigenschaft CanGrow des Bereichs, der das Steuerelement enthält, automatisch auf Ja ein. (Wenn Sie die Eigenschaft CanShrink eines Steuerelements auf Ja einstellen, stellt Microsoft Access die Eigenschaft CanShrink des Bereichs dagegen nicht auf Ja ein.)

Die Höhe eines Bereichs wird in dessen gesamter Breite vergrößert oder verkleinert. Nehmen Sie z. B. an, ein Formular hat zwei Textfelder, die nebeneinander angeordnet sind, und bei beiden Steuerelementen ist die Eigenschaft CanShrink auf Ja eingestellt. Enthält ein Textfeld eine Datenzeile und das andere Textfeld zwei Datenzeilen, sind beide Textfelder zwei Zeilen lang, da die Höhe des Bereichs in der gesamten Breite angepasst wird. Wenn die Datenbereiche unabhängig voneinander vergrößert oder verkleinert werden sollen, ordnen Sie zwei Unterformular- bzw. Unterbericht-Steuerelemente nebeneinander an und stellen deren Eigenschaften CanGrow und CanShrink auf Ja ein.

Wenn Sie die Eigenschaften CanGrow und CanShrink verwenden, beachten Sie Folgendes:

  • Die Einstellungen der Eigenschaften wirken sich nicht auf den horizontalen Abstand zweier Steuerelemente aus; sie wirken sich nur auf die Höhe aus, die die Steuerelemente beanspruchen.

  • Überlappende Steuerelemente können weder vergrößert noch verkleinert werden.

  • Die Höhe eines großen Steuerelements kann verhindern, dass Steuerelemente, die sich neben diesem befinden, verkleinert werden. Wenn sich z. B. mehrere kurze Steuerelemente auf der linken Seite des Detailbereichs eines Berichts befinden und ein langes Steuerelement, wie z. B. ein ungebundenes Objektfeld, auf der rechten Seite, werden die auf der linken Seite befindlichen Steuerelemente selbst dann nicht verkleinert, wenn sie keine Daten enthalten.


 Caption-Eigenschaft (Beschriftung)

Caption-Eigenschaft (Beschriftung)

Sie können die Eigenschaft Caption verwenden, um dem Benutzer hilfreiche Informationen bereitzustellen, indem Sie Beschriftungen für Objekte in verschiedenen Ansichten angeben:

  • Felder. Gibt den Text für Bezeichnungsfelder von Steuerelementen an, die durch Ziehen eines Feldes aus der Feldliste erstellt wurden, und dient als Spaltenüberschrift für das Feld in der Tabellen- oder Abfrage- Datenblattansicht.

  • Formulare. Gibt den Text an, der in der Titelleiste in der Formularansicht angezeigt wird.

  • Berichte. Gibt den Titel des Berichts in der Seitenansicht an.

  • Schaltflächen und Bezeichnungsfelder. Gibt den Text an, der im Steuerelement angezeigt wird.

Einstellung

Die Eigenschaft Caption ist ein Zeichenfolgenausdruck, der bis zu 2.048 Zeichen enthalten kann. Beschriftungen für Formulare und Berichte, die zu lang sind, um in der Titelleiste angezeigt zu werden, werden abgeschnitten.

Bei Steuerelementen können Sie diese Eigenschaft im Eigenschaftenfenster einstellen. Bei Feldern können Sie diese Eigenschaft im Eigenschaftenfenster in der Tabellenentwurfsansicht oder im Abfragefenster (im Eigenschaftenfenster Feldeigenschaften) einstellen. Sie können auch ein Makro oder Visual Basic verwenden.

Anmerkung

Wenn Sie keine Beschriftung für ein Tabellenfeld angeben, wird die Einstellung der Eigenschaft Feldname des Feldes in der Datenblattansicht als Beschriftung eines Steuerelements oder als Spaltenüberschrift verwendet. Wenn Sie keine Beschriftung für ein Abfragefeld angeben, wird die Beschriftung des zugrunde liegenden Tabellenfelds verwendet. Wenn Sie keine Beschriftung für ein Formular, eine Schaltfläche oder ein Bezeichnungsfeld einstellen, weist Microsoft Access dem Objekt einen eindeutigen, auf dem Objekt basierenden Namen (z. B. "Formular1") zu.

Wenn Sie ein Steuerelement durch Ziehen eines Feldes aus der Feldliste erstellen und keine Einstellung für die Eigenschaft Caption des Feldes angegeben haben, wird die Einstellung der Eigenschaft Feldname des Feldes in das Einstellungsfeld der Eigenschaft Name des Steuerelements kopiert und auch im Bezeichnungsfeld des erstellten Steuerelements angezeigt.

Anmerkung Ist die Eigenschaft HyperlinkAddress oder HyperlinkSubAddress für ein Steuerelement eingestellt, so erscheint der Text der Eigenschaft Caption für ein Bezeichnungsfeld oder eine Befehlsschaltfläche als Hyperlink.

Sie können die Eigenschaft Caption verwenden, um einem Steuerelement oder einer Befehlsschaltfläche eine Zugriffstaste zuzuweisen. Geben Sie in der Beschriftung ein kaufmännisches Und-Zeichen (&) vor dem Zeichen ein, das zur Zugriffstaste werden soll. Das Zeichen wird dann unterstrichen dargestellt. Beim Bewegen im Formular drücken Sie ALT und gleichzeitig das unterstrichene Zeichen, um den Fokus auf dieses Steuerelement zu setzen.

Tipp Geben Sie zwei kaufmännische Und-Zeichen (&&) in der Einstellung der Beschriftung eines Steuerelements ein, wenn Sie das kaufmännische Und-Zeichen (&) selbst im Beschriftungstext anzeigen möchten. Wenn Sie z. B. Speichern & Beenden anzeigen möchten, müssen Sie Speichern && Beenden im Einstellungsfeld der Eigenschaft Caption eingeben.


CheckIfOfficeIsHTMLEditor-Eigenschaft

Mit der CheckIfOfficeIsHTMLEditor-Eigenschaft können Sie festlegen oder abfragen, ob zum Bearbeiten von Webseiten der für das System definierte Standard-HTML-Editor verwendet wird.

Einstellung

Die CheckIfOfficeIsHTMLEditor-Eigenschaft verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardwert) Beim Start von Microsoft Access wird geprüft, ob eine Office-Anwendung als Standard-HTML-Editor verwendet wird.
Nein | False (0) | Die Überprüfung wird nicht vorgenommen.

Die CheckIfOfficeIsHTMLEditor-Eigenschaft steht nur unter Visual Basic zur Verfügung.

Anmerkungen

Die CheckIfOfficeIsHTMLEditor-Eigenschaft kann nur benutzt werden, wenn der von Ihnen eingesetzte Webbrowser die Bearbeitung von HTML-Code und die Einbindung eines HTML-Editors unterstützt.

Um einen anderen HTML-Editor zu verwenden, müssen Sie diese Eigenschaft auf den Wert False setzen und dann den Editor in der Systemregistrierung als Standard-HTML-Editor registrieren lassen.


 Class-Eigenschaft (Klasse)

Class-Eigenschaft (Klasse)

Mit der Eigenschaft Class können Sie den Klassennamen eines eingebetteten OLE-Objekts angeben oder ermitteln.

Einstellung

Die Einstellung der Eigenschaft Class ist ein Zeichenfolgenausdruck, der von Ihnen oder von Microsoft Access bereitgestellt wird, wenn Sie ein OLE-Objekt erstellen oder einfügen.

Sie können die Eigenschaft Class im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Ein Klassenname definiert den Typ des jeweiligen OLE-Objekts. Microsoft Excel unterstützt z. B. mehrere OLE-Objekttypen, einschließlich Tabellenblätter und Diagramme. Deren Klassennamen lauten Excel.Sheet bzw. Excel.Chart. Wenn Sie ein OLE-Objekt in der Entwurfsansicht erstellen, indem Sie im Menü Bearbeiten auf Inhalte einfügen oder im Menü Einfügen auf Objekt einfügen klicken, trägt Microsoft Access den Klassennamen des neuen Objekts automatisch in das Eigenschaftenfenster ein.

Anmerkung Wenn Sie den Klassennamen eines OLE-Objekts wissen möchten, finden Sie die entsprechenden Informationen in der Dokumentation der Anwendung, von der das Objekt bereitgestellt wird.

Die Einstellung der Eigenschaft Class wird aktualisiert, sobald Sie ein Objekt aus der Zwischenablage eingefügt haben. Wenn Sie z. B. ein Microsoft Excel-Diagramm aus der Zwischenablage in ein OLE-Objekt einfügen, das zuvor ein Microsoft Excel-Tabellenblatt enthalten hat, ändert sich die Einstellung der Eigenschaft Class von Excel.Sheet in Excel.Chart. Sie können ein Objekt aus der Zwischenablage einfügen, indem Sie in Visual Basic die Eigenschaft Action des Steuerelements auf acOLEPaste oder acOLEPasteSpecialDlg einstellen.

Anmerkung Die Eigenschaften OLEClass und Class ähneln sich zwar, sind aber nicht identisch. Die Einstellung der Eigenschaft OLEClass ist eine allgemeine Beschreibung des OLE-Objekts, während die Einstellung der Eigenschaft Class der Name ist, mit dem in Visual Basic auf das OLE-Objekt verwiesen wird. Beispiele für die Einstellung der Eigenschaft OLEClass sind: Microsoft Excel Chart, Microsoft Word Document und Paintbrush Picture.


 CloseButton-Eigenschaft (SchließenSchaltfläche)

CloseButton-Eigenschaft (SchließenSchaltfläche)

Sie können mit der Eigenschaft CloseButton angeben, ob für ein Formular die Schaltfläche Schließen [image] aktiviert ist.

Einstellung

Die Eigenschaft CloseButton verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Schaltfläche Schließen ist aktiviert.
Nein | False (0) | Die Schaltfläche Schließen ist deaktiviert, und im Systemmenü ist der Befehl Schließen nicht verfügbar.

Sie können die Eigenschaft CloseButton im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft CloseButton nur in der Formularentwurfsansicht einstellen.

Anmerkung

Wenn Sie die Eigenschaft CloseButton auf Nein einstellen, bleibt die Schaltfläche Schließen sichtbar, ist jedoch abgeblendet, und Sie müssen eine andere Möglichkeit zum Schließen des Formulars bereitstellen (z. B. eine Befehlsschaltfläche oder einen benutzerdefinierten Menübefehl, die oder der ein Makro oder eine Ereignisprozedur zum Schließen des Formulars ausführt.

Tipp Sie können das Formular auch durch Drücken der Tastenkombination ALT+F4 schließen.


 CodeContextObject-Eigenschaft

CodeContextObject-Eigenschaft

Mit der Eigenschaft CodeContextObject können Sie das Objekt ermitteln, in dem ein Makro bzw. Visual Basic-Code ausgeführt wird.

Einstellung

Die Eigenschaft CodeContextObject wird von Microsoft Access eingestellt und ist in allen Ansichten schreibgeschützt.

Anmerkung

Die Eigenschaften ActiveControl, ActiveDataAccessPage, ActiveDatasheet, ActiveForm und ActiveReport eines Screen-Objekts geben immer das Objekt zurück, das momentan den Fokus hat. Dieses Objekt kann, muss aber nicht das Objekt sein, in dem momentan ein Makro oder Visual Basic-Code ausgeführt wird. So ist es z. B. möglich, dass Visual Basic-Code in der Timer-Ereignisprozedur eines ausgeblendeten Formulars ausgeführt wird.


CodeData-Eigenschaft

Mit der CodeData-Eigenschaft können Sie auf das CodeData-Objekt und dessen zugehörige Auflistungen zugreifen.

Einstellung

Die CodeData-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Verwenden Sie die CodeData-Eigenschaft, wenn Sie auf eine der folgenden Auflistungen der Codedatenbank und deren Eigenschaften bzw. Methoden zugreifen möchten.

AllTables | AllQueries
AllViews | AllStoredProcedures
AllDatabaseDiagrams |


CodeProject-Eigenschaft

Mit der CodeProject-Eigenschaft können Sie auf das CodeProject-Objekt und dessen zugehörige Auflistungen, Eigenschaften und Methoden zugreifen.

Einstellung

Die CodeProject-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Verwenden Sie die CodeProject-Eigenschaft, wenn Sie auf eine der folgenden Auflistungen der Codedatenbank und deren Eigenschaften bzw. Methoden zugreifen möchten.


Collection-Eigenschaft

Die Eigenschaft Collection gibt einen Verweis auf die Auflistung zurück, zu der ein Objekt gehört.

Einstellung

Die Eigenschaft Collection steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Mit Hilfe der Eigenschaft Collection können Sie auf die Auflistung zugreifen, zu der ein Objekt gehört. Beispielsweise gibt die Eigenschaft Collection eines Reference-Objekts einen Objektverweis auf die Auflistung References zurück.

Die Eigenschaft Collection ist mit der Eigenschaft Parent vergleichbar.


 Column-Eigenschaft

Column-Eigenschaft

Sie können die Eigenschaft Column verwenden, um auf eine bestimmte Spalte oder Spalten- und Zeilenkombination in einem mehrspaltigen Kombinationsfeld oder Listenfeld zu verweisen. Mit 0 verweisen Sie auf die erste Spalte, mit 1 auf die zweite Spalte usw. Entsprechend verweisen Sie mit 0 auf die erste Zeile, mit 1 auf die zweite Zeile usw. Beispielsweise können Sie in einem Listenfeld, das eine Spalte mit Kundennummern und eine Spalte mit Kundennamen enthält, auf den Kundennamen in der zweiten Spalte und fünften Zeile wie folgt verweisen:

Formulare!Kontakte!Kunden.Column(1, 4)

Einstellung

Steuerelement.Column(Spalte, Zeile)

Die Eigenschaft Column verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Steuerelement | Ein Control-Objekt, das das aktive Kombinationsfeld- oder Listenfeld-Steuerelement darstellt.
Spalte | Ein Wert vom Typ Integer zwischen 0 und dem Wert der Eigenschaft ColumnCount minus 1.
Zeile | Optional. Ein Wert vom Typ Integer zwischen 0 und dem Wert der Eigenschaft ListCount minus 1.

Diese Eigenschafteneinstellung steht nur in einem Makro oder in Visual Basic zur Verfügung. Sie ist nicht in der Entwurfsansicht verfügbar und ist in anderen Ansichten schreibgeschützt.

Anmerkung

Sie können die Eigenschaft Column verwenden, um den Inhalt eines Kombinationsfelds oder Listenfelds einem anderen Steuerelement zuzuweisen, etwa einem Textfeld. Beispielsweise können Sie den folgenden Ausdruck verwenden, um die Eigenschaft ControlSource eines Textfelds auf den Wert der zweiten Spalte eines Listenfelds einzustellen:

=Formulare!Kunden!Firma.Column(1)

Hat der Benutzer keine Auswahl getroffen, wenn Sie auf eine Spalte in einem Kombinationsfeld oder Listenfeld verweisen, so wird die Eigenschaft Column auf Null eingestellt. Sie können mit der Funktion IsNull feststellen, ob eine Auswahl getroffen wurde, wie im folgenden Beispiel gezeigt wird.

If IsNull(Formulare!Kunden!Land)
    Then MsgBox "Keine Auswahl."
End If

Anmerkung Um festzustellen, wie viele Spalten ein Kombinationsfeld oder Listenfeld besitzt, können Sie die Einstellung der Eigenschaft ColumnCount überprüfen.


 ColumnCount-Eigenschaft (Spaltenanzahl)

ColumnCount-Eigenschaft (Spaltenanzahl)

Mit der ColumnCount-Eigenschaft können Sie die Anzahl der Spalten angeben, die in einem Listenfeld oder in einem Teil des Listenfeldes eines Kombinationsfeldes angezeigt oder zu OLE-Objekten in einem Diagramm-Steuerelement oder einem ungebundenen Objektfeld gesendet werden. Wenn Sie die ColumnCount-Eigenschaft z. B. für ein Listenfeld im Formular Personal auf 3 einstellen, können in einer Spalte Nachnamen, in einer anderen Spalte Vornamen und in der dritten Spalte Personalnummern aufgelistet werden.

Einstellung

Die ColumnCount-Eigenschaft enthält eine Ganzzahl zwischen 1 und der maximalen Anzahl von Feldern in der Tabelle, Abfrage oder SQL-Anweisung oder die maximale Anzahl von Werten in der Wertliste, die in der RowSource-Eigenschaft des Steuerelements angegeben wird.

Sie können die ColumnCount-Eigenschaft im Eigenschaftenfenster des Steuerelements, mit einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft auf der Registerkarte Nachschlagen im Abschnitt Feldeigenschaften der Tabellenentwurfsansicht für Felder einstellen, wobei die Steuerelement anzeigen-Eigenschaft auf Kombinationsfeld oder Listenfeld eingestellt ist.

Tipp Microsoft Access stellt die ColumnCount-Eigenschaft automatisch ein, wenn Sie Nachschlage-Assistent als Datentyp für ein Feld in der Tabellenentwurfsansicht einstellen.

Anmerkung

Ein Kombinations- oder Listenfeld kann mehrere Spalten haben. Wenn die RowSource-Eigenschaft des Steuerelements den Namen einer Tabelle, Abfrage oder SQL-Anweisung enthält, zeigt ein Kombinations- bzw. Listenfeld die Felder aus dieser Datensatzherkunft von links nach rechts bis zu der Anzahl an, die durch die ColumnCount-Eigenschaft festgelegt wurde.

Um eine andere Kombination von Feldern anzuzeigen, erstellen Sie eine neue Abfrage oder eine neue SQL-Anweisung für die RowSource-Eigenschaft unter Angabe der gewünschten Felder und der gewünschten Reihenfolge.

Wenn die RowSource-Eigenschaft eine Liste von Werten enthält (die RowSourceType-Eigenschaft auf Wertliste eingestellt ist), werden die Werte in die Zeilen und Spalten des Kombinations- oder Listenfeldes in der Reihenfolge eingefügt, in der sie in der RowSource-Eigenschaft aufgelistet sind. Enthält RowSource beispielsweise die Liste "Rot; Grün; Blau; Gelb" und ist die ColumnCount-Eigenschaft auf 2 eingestellt, so enthält die erste Zeile des Kombinations- oder Listenfeldes "Rot" in der ersten Spalte und "Grün" in der zweiten Spalte. Die zweite Zeile enthält "Blau" in der ersten Spalte und "Gelb" in der zweiten Spalte.

Um die Breite der im Steuerelement angezeigten Spalten einzustellen oder Spalten auszublenden, können Sie die ColumnWidths-Eigenschaft verwenden.


 ColumnHeadings-Eigenschaft (FixierteSpaltenüberschriften)

ColumnHeadings-Eigenschaft (FixierteSpaltenüberschriften)

Sie können die Eigenschaft FixierteSpaltenüberschriften verwenden, um die Reihenfolge der Spalten in einer Kreuztabellenabfrage anzugeben oder die Anzahl der angezeigten Spalten zu begrenzen. Sie können z. B. in einer Abfrage, die Namen von Ländern anzeigt, die Namen in einer bestimmten Reihenfolge aufführen, z. B. zuerst Deutschland, dann Österreich und als drittes die Schweiz.

Einstellung

Geben Sie die Datenwerte aus dem Feld Spaltenüberschrift der Kreuztabellenabfrage als Zeichenfolgenausdruck in der Reihenfolge ein, wie die Werte im Datenblatt der Kreuztabellenabfrage angezeigt werden sollen, jeweils getrennt durch ein Semikolon (oder durch das im Dialogfeld Ländereinstellungen der Systemsteuerung von Windows eingestellte Listentrennzeichen). Die folgende Tabelle zeigt Beispieleinstellungen der Eigenschaft ColumnHeadings und das Ergebnis im Datenblatt der Kreuztabellenabfrage.

Beispieleinstellung | Ergebnis
"Qtl. 1"; "Qtl. 2"; "Qtl. 3"; "Qtl. 4" | Zeigt Spaltenüberschriften für jedes Quartal an.
"Deutschland"; "Österreich"; "Schweiz" | Zeigt Spaltenüberschriften für jedes Land an

Sie können diese Eigenschaft im Abfrage-Eigenschaftenfenster einstellen. Sie können diese Eigenschaft auch in der SQL-Ansicht des Abfragefensters oder in Visual Basic mit Hilfe einer PIVOT-Klausel in der SQL-Anweisung einstellen.

Anmerkung Die Spaltenüberschriften, die Sie für die Eigenschaft ColumnHeadings festlegen, müssen genau mit den Datenwerten im Feld Spaltenüberschrift im Abfrageentwurfsbereich übereinstimmen. Andernfalls werden die Daten nicht in den Spalten angezeigt.

Anmerkung

Mit der Eigenschaft ColumnHeadings können Sie das Aussehen von Spaltenüberschriften in einer Kreuztabellenabfrage besser steuern. Standardmäßig zeigt Microsoft Access alle Datenwerte als Spaltenüberschriften in aufsteigender Reihenfolge an. Hat das Feld Spaltenüberschrift z. B. den Namen Monat, so werden standardmäßig die Spaltenüberschriften April, August, Dezember, Februar usw. angezeigt. Sie können die Eigenschaft ColumnHeadings verwenden, um die Daten in der richtigen Reihenfolge und mit der richtigen Einstellung anzuzeigen: "Januar", "Februar", "März" usw.

Schließen Sie eine Spaltenüberschrift in der Einstellung der Eigenschaft ColumnHeadings ein, so wird die Spalte immer in der Datenblattansicht der Abfrage angezeigt, auch dann, wenn die Spalte keine Daten enthält. Dies erweist sich beispielsweise als hilfreich, wenn Sie einen Bericht erstellen, der auf einer Kreuztabellenabfrage basiert, wobei immer dieselben Spaltenüberschriften im Bericht angezeigt werden sollen.

Tipp Sie können die ColumnHeadings verwenden, um die Geschwindigkeit von Kreuztabellenabfragen zu erhöhen, indem Sie die Zahl der angezeigten Spalten begrenzen.


 ColumnHeads-Eigenschaft (Spaltenüberschriften)

ColumnHeads-Eigenschaft (Spaltenüberschriften)

Sie können die Eigenschaft ColumnHeads zur Anzeige einer einzelnen Zeile von Spaltenüberschriften für Listenfelder, Kombinationsfelder und OLE-Objekte, die Spaltenüberschriften akzeptieren, verwenden. Sie können diese Eigenschaft auch zur Erstellung von Bezeichnungsfeldern für die Einträge eines Diagramm-Steuerelements verwenden. Welche Spaltenüberschrift tatsächlich als erste angezeigt wird, hängt von der Einstellung der Eigenschaft RowSourceType des Objekts ab.

Einstellung

Die Eigenschaft ColumnHeads verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Spaltenüberschriften sind aktiviert, und als Spaltenüberschriften oder Diagramm-Bezeichnungsfelder werden Feldbeschriftungen, Feldnamen oder die erste Datenzeile verwendet.
Nein | False (0) | (Standardeinstellung) Spaltenüberschriften sind nicht aktiviert.

Sie können die Eigenschaft ColumnHeads im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld oder Listenfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft ColumnHeads automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Anmerkung

Die Eigenschaft RowSourceType gibt an, ob Feldnamen oder die erste Datenzeile zur Erstellung von Spaltenüberschriften verwendet werden. Ist die Eigenschaft RowSourceType auf Tabelle/Abfrage eingestellt, werden die Feldnamen als Spaltenüberschriften verwendet. Hat das Feld eine Beschriftung, dann wird die Beschriftung angezeigt. Verfügt z. B. ein Listenfeld über drei Spalten (die Eigenschaft ColumnCount ist auf 3 eingestellt), und ist die Eigenschaft RowSourceType auf Tabelle/Abfrage eingestellt, werden die ersten drei Feldnamen (oder Beschriftungen) als Überschriften verwendet.

Ist die Eigenschaft RowSourceType auf Wertliste eingestellt, wird die erste Datenzeile der Wertliste (die die Einstellung der Eigenschaft RowSource ist) als Spaltenüberschrift verwendet. Wenn beispielsweise ein Listenfeld drei Spalten hat und die Eigenschaft RowSourceType auf Wertliste eingestellt ist, werden die ersten drei Elemente der Einstellung der Eigenschaft RowSource als Überschriften verwendet.

Tipp Wenn Sie die erste Zeile eines Listen- oder Kombinationsfelds in der Formularansicht nicht auswählen können, überprüfen Sie, ob die Eigenschaft ColumnHeads auf Ja eingestellt ist.

Überschriften in Kombinationsfeldern werden nur angezeigt, wenn die Liste im Steuerelement angezeigt wird.


 ColumnHidden-Eigenschaft

ColumnHidden-Eigenschaft

Sie können die ColumnHidden-Eigenschaft zum Anzeigen oder Ausblenden einer bestimmten Spalte in der Datenblattansicht verwenden. Sie könnten z.B. ein Feld namens Kundenadresse, das zu breit ist, ausblenden, so dass die Felder Kundenname und Telefonnummer angezeigt werden können.

Anmerkung Die ColumnHidden-Eigenschaft gilt für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Einstellung

Sie können die ColumnHidden-Eigenschaft einstellen, indem Sie im Menü Format in der Datenblattansicht auf Spalten ausblenden oder Spalten einblenden klicken.

Sie können diese Eigenschaft auch innerhalb einer Microsoft Access-Datenbank (.mdb) einstellen, indem Sie eine der folgenden Einstellungen in Visual Basic unter Verwendung eines Wertes vom Typ Long Integer festlegen.

Einstellung | Beschreibung
True (-1) | Die Spalte ist ausgeblendet.
False (0) | (Voreinstellung) Die Spalte ist sichtbar.

Wenn Sie diese Eigenschaft für eine Tabelle oder Abfrage mit Visual Basic einstellen oder ändern möchten, müssen Sie die Properties-Auflistung einer Spalte verwenden. Ausführliche Informationen zur Verwendung der Properties-Auflistung finden Sie unter Properties.

Die ColumnHidden-Eigenschaft ist in der Entwurfsansicht des Formulars nicht verfügbar.

Anmerkung

Das Ausblenden einer Spalte in der Datenblattansicht blendet keine Felder dieser Spalte in der Formularansicht aus. Auch blendet das Einstellen der Visible-Eigenschaft eines Steuerelements in der Formularansicht auf False nicht die entsprechende Spalte in der Datenblattansicht aus.

Sie können ein Feld in einer Abfrage auch dann anzeigen, wenn die Spalte des Tabellenfelds in der Datenblattansicht ausgeblendet ist.

Sie können Werte einer ausgeblendeten Spalte als Kriterien für einen Filter auch dann verwenden, wenn die Spalte nach Hinzufügen des Filters ausgeblendet bleibt.

Sie können die Befehle Kopieren, Einfügen, Suchen und Ersetzen im Menü Bearbeiten nicht für ausgeblendete Spalten verwenden.

Das Einstellen der ColumnWidth-Eigenschaft eines Feldes auf 0 oder die Größenänderung des Feldes auf die Breite Null in der Datenblattansicht bewirkt, dass Microsoft Access die entsprechende ColumnHidden-Eigenschaft auf True einstellt. Das Einblenden einer Spalte stellt die ColumnWidth-Eigenschaft wieder auf den Wert ein, der vor der Ausblendung eingestellt war.


 ColumnOrder-Eigenschaft

ColumnOrder-Eigenschaft

Sie können die ColumnOrder-Eigenschaft zur Festlegung der Reihenfolge der Spalten in der Datenblattansicht verwenden.

Anmerkung Die ColumnOrder-Eigenschaft gilt für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Einstellung

Sie stellen diese Eigenschaft ein, indem Sie in der Datenblattansicht eine Spalte auswählen und diese an eine neue Position ziehen.

Sie können die ColumnOrder-Eigenschaft innerhalb einer Microsoft Access-Datenbank (.mdb) unter Verwendung eines Wertes vom Typ Long Integer aus Visual Basic einstellen.

Wenn Sie diese Eigenschaft für eine Tabelle oder Abfrage mit Visual Basic einstellen oder ändern möchten, müssen Sie die Properties-Auflistung einer Spalte verwenden. Ausführliche Informationen zur Verwendung der Properties-Auflistung finden Sie unter Properties.

Anmerkung Die ColumnOrder-Eigenschaft ist in der Entwurfsansicht des Formulars nicht verfügbar.

Anmerkung

In der Datenblattansicht wird die Einstellung der ColumnOrder-Eigenschaft eines Feldes durch die Position des Feldes bestimmt. So hat z.B. das Feld in der Spalte ganz links in der Datenblattansicht den Wert 1 für die ColumnOrder-Eigenschaft, das nächste Feld hat die Einstellung 2 usw. Eine Veränderung der Einstellung der ColumnOrder-Eigenschaft eines Feldes setzt die Eigenschaft für dieses Feld sowie für jedes Feld in der Datenblattansicht links von dessen ursprünglicher Position zurück.

In anderen Ansichten hat die Einstellung der Eigenschaft solange den Wert 0, bis Sie die Reihenfolge eines oder mehrerer Felder in der Datenblattansicht explizit ändern (entweder durch das Ziehen von Feldern an neue Positionen oder durch das Verändern ihrer Einstellungen für die ColumnOrder-Eigenschaft). Felder rechts neben der neuen Position der verschobenen Felder erhalten den Wert 0 für die Einstellung der ColumnOrder-Eigenschaft für alle Ansichten außer der Datenblattansicht.

Die Reihenfolge der Felder in der Datenblattansicht hat keine Auswirkungen auf die Reihenfolge der Felder in der Tabellen-Entwurfsansicht oder Formularansicht.


 ColumnWidth-Eigenschaft (Spaltenbreite)

ColumnWidth-Eigenschaft (Spaltenbreite)

Sie können die Eigenschaft ColumnWidth zur Einstellung der Breite einer Spalte in der Datenblattansicht verwenden.

Anmerkung Die Eigenschaft ColumnWidth gilt für alle Felder in der Datenblattansicht und für Formular-Steuererlemente, wenn sich das Formular in der Datenblattansicht befindet.

Einstellung

Sie können diese Eigenschaft auch durch Ziehen des Rahmens des Spaltenmarkierers einstellen oder direkt den gewünschten Wert eingeben, indem Sie in der Datenblattansicht im Menü Format auf Spaltenbreite klicken. Legen Sie die Eigenschaft ColumnWidth durch Verwendung des Befehls Spaltenbreite fest, wird der Wert in Punkten angezeigt.

In Visual Basic entspricht die Einstellung der Eigenschaft ColumnWidth einem Wert vom Typ Integer, der die Spaltenbreite in Twips darstellt. Sie können eine Breite festlegen oder eine der folgenden vordefinierten Einstellungen verwenden.

Einstellung | Beschreibung
0 | Blendet die Spalte aus.
-1 | (Voreinstellung) Passt die Spalte der Standardbreite an.

Anmerkung

Das Einstellen der Eigenschaft ColumnWidth auf 0 oder das Ändern der Feldbreite auf Null in der Datenblattansicht stellt die Eigenschaft ColumnHidden des Feldes auf True (-1) ein und blendet das Feld in der Datenblattansicht aus.

Das Einstellen der Eigenschaft ColumnHidden eines Feldes auf False (0) stellt die Eigenschaft ColumnWidth des Feldes wieder auf den Wert ein, der vor der Ausblendung Gültigkeit besaß. Hatte die Eigenschaft ColumnWidth z. B. den Wert -1, bevor die Spalte durch Einstellung der Eigenschaft ColumnWidth auf 0 ausgeblendet wurde, so bewirkt das Verändern der Eigenschaft ColumnHidden des Feldes auf False, dass die Eigenschaft ColumnWidth auf -1 zurückgesetzt wird.

Die Eigenschaft ColumnWidth eines Feldes ist nicht verfügbar, wenn die Eigenschaft ColumnHidden des Feldes auf True eingestellt ist.


 ColumnWidths-Eigenschaft (Spaltenbreiten)

ColumnWidths-Eigenschaft (Spaltenbreiten)

Sie können die Eigenschaft ColumnWidths zur Einstellung der Breite jeder einzelnen Spalte in einem mehrspaltigen Kombinationsfeld oder Listenfeld verwenden. Sie können diese Eigenschaft auch verwenden, um Spalten auszublenden.

Einstellung

Die Eigenschaft ColumnWidths enthält einen Wert, der die Breite jeder Spalte in Zentimeter oder Zoll angibt, abhängig vom Maßsystem, das in der Windows-Systemsteuerung auf der Registerkarte Zahlen des Dialogfelds Eigenschaften von Ländereinstellungen im Feld Maßsystem ausgewählt ist. Die Standardeinstellung ist 2,54 Zentimeter oder 1 Zoll. Die Eigenschaft ColumnWidths muss für jede Spalte des Listen- oder Kombinationsfelds einen Wert zwischen 0 und 55,87 cm (22 Zoll) besitzen.

Verwenden Sie für die Spalteneinträge als Listentrennzeichen Semikolons (;) (oder das im Feld Ländereinstellungen auf der Registerkarte Zahlen des Dialogfelds Eigenschaften von Ländereinstellungen ausgewählte Listentrennzeichen).

Eine Breite von 0 blendet eine Spalte aus. Beliebig viele Einstellungen der Eigenschaft ColumnWidths können leer sein. Sie erstellen eine leere Einstellung, indem Sie ein Listentrennzeichen ohne vorhergehenden Wert eingeben. Leere Werte bewirken in Microsoft Access automatisch das Einstellen einer Standardspaltenbreite, die von der Spaltenanzahl und der Breite des Kombinations- oder Listenfelds abhängt.

Anmerkung In einem Kombinationsfeld wird die erste sichtbare Spalte im Textfeldteil des Steuerelements angezeigt.

Sie können die Eigenschaft ColumnWidths im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld oder Listenfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft ColumnWidths automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Verwenden Sie in Visual Basic einen Zeichenfolgenausdruck zur Einstellung des Spaltenbreitenwerts in Twips. Die Spaltenbreitenwerte werden durch Semikolons getrennt. Sie können eine andere Maßeinheit (Zentimeter oder Zoll) festlegen, indem Sie diese zusammen mit dem Wert angeben. Beispielsweise gibt der folgende Zeichenfolgenausdruck drei Spaltenbreiten in Zentimetern an.

"6 cm;0;6 cm"

Anmerkung

Wenn Sie keinen Wert für die Eigenschaft ColumnWidths angeben, stellt Microsoft Access jede Spalte auf die Gesamtbreite des Listen- oder Kombinationsfelds, dividiert durch die Spaltenanzahl, ein.

Wenn Sie die Spaltenbreiten so groß einstellen, dass sie insgesamt nicht vollständig im Kombinations- oder Listenfeld angezeigt werden können, werden einige Spalten von rechts beginnend ausgeblendet, und eine horizontale Bildlaufleiste wird angezeigt.

Wenn Sie die Breite für einige Spalten angeben, für andere Spalten jedoch nicht, dividiert Microsoft Access die verbleibende Breite durch die der Spalten, deren Breite Sie nicht angegeben haben. Als Mindestspaltenbreite wird 1.440 Twips (entspricht 2,54 cm oder 1 Zoll) verwendet.

Beispielsweise werden für ein 11 Zentimeter breites Listenfeld mit drei Spalten die folgenden Einstellungen verwendet.

Einstellung | Beschreibung
3,5 cm;0;7,5 cm | Die erste Spalte ist 3,5 cm breit, die zweite Spalte ist ausgeblendet, und die dritte Spalte ist 7,5 cm breit.
5 cm;;5 cm | Die erste Spalte ist 5 cm breit, die zweite Spalte ist 2,54 cm breit (Standardeinstellung), und die dritte Spalte ist 5 cm breit. Da die dritte Spalte nur zur Hälfte sichtbar ist, wird eine horizontale Bildlaufleiste angezeigt.
(Leer) | Die drei Spalten haben die gleiche Breite (3,66 cm).

Anmerkung Diese Eigenschaft unterscheidet sich von der Eigenschaft ColumnWidth; diese gibt die Breite einer bestimmten Spalte eines Datenblatts an.


 COMAddIns-Eigenschaft

COMAddIns-Eigenschaft

Mit der COMAddIns-Eigenschaft können Sie einen Verweis auf das aktuelle Auflistungsobjekt COMAddIns und dessen zugehörige Eigenschaften zurückgeben.

Einstellung

[Anwendung.]COMAddIns[.Methode oder Eigenschaft]

Die COMAddIns-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Anwendung | Das Application-Objekt.
COMAddIns | Erforderlich. Wenn die COMAddIns-Eigenschaft ohne Angabe einer Methode oder Eigenschaft verwendet wird, gibt sie das Auflistungsobjekt COMAddIns zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des Auflistungsobjekts COMAddIns.

Die COMAddIns-Eigenschaft ist nur in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Das Auflistungsobjekt COMAddIns ist die Auflistung aller momentan registrierten COM-Add-Ins einer Anwendung. Sie können auf einzelne Elemente der Auflistung mit dem Index des betreffenden Elementobjekts oder mit einem Zeichenfolgenausdruck verweisen, bei dem es sich um den Namen des Elementobjekts handelt. Das erste Elementobjekt in der Auflistung hat den Indexwert 1. Die Gesamtzahl der Elementobjekte in der Auflistung ist der Wert der Count-Eigenschaft der Auflistung COMAddIns.

Nachdem Sie einen Verweis auf das Auflistungsobjekt COMAddIns eingerichtet haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Zum Festlegen eines Verweises auf das Auflistungsobjekt COMAddIns klicken Sie in der Entwurfsansicht des Moduls im Menü Extras auf Verweise. Anschließend stellen Sie einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie im Dialogfeld Verweise das entsprechende Kontrollkästchen aktivieren. Microsoft Access stellt diesen Verweis automatisch ein, wenn Sie eine Konstante der Microsoft Office 9.0 Object Library zum Einstellen einer Eigenschaft des Auflistungsobjekts COMAddIns oder als Argument einer Methode dieses Auflistungsobjekts verwenden.


 CommandBars-Eigenschaft

CommandBars-Eigenschaft

Mit der Eigenschaft CommandBars können Sie einen Verweis auf das Auflistungsobjekt CommandBars zurückgeben.

Einstellung

[Anwendung.]CommandBars[.Methode oder Eigenschaft]

Die Eigenschaft CommandBars verwendet die folgenden Einstellungen:

Einstellung | Beschreibung
Anwendung | Optional. Das Objekt Application.
CommandBars | Erforderlich. Wird die Eigenschaft CommandBars ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie das Auflistungsobjekt CommandBars zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des Auflistungsobjekts CommandBars. Die Eigenschaft Item (Auflistungen) ist die Standardeigenschaft des Auflistungsobjekts CommandBars.

Die Eigenschaft CommandBars ist nur in Visual Basic verfügbar.

Anmerkung

Das Auflistungsobjekt CommandBars ist die Auflistung aller eingebauten und benutzerdefinierten Befehlsleisten in einer Anwendung. Sie können auf einzelne Elemente der Auflistung verweisen, indem Sie den Index des Elementobjekts oder einen Zeichenfolgenausdruck verwenden, der den Namen des Elementobjekts darstellt. Das erste Elementobjekt in der Auflistung besitzt den Indexwert 1, und die Gesamtanzahl der Elementobjekte in der Auflistung entspricht dem Wert der Eigenschaft Count der Auflistung CommandBars.

Nachdem Sie einen Verweis auf das Auflistungsobjekt CommandBars eingestellt haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Sie stellen einen Verweis auf das Auflistungsobjekt CommandBars ein, indem Sie in der Modul-Entwurfsansicht im Menü Extras auf Verweise klicken. Stellen Sie im Dialogfeld Verweise einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie das entsprechende Kontrollkästchen aktivieren.


 Connection-Eigenschaft

Connection-Eigenschaft

Mit der Connection-Eigenschaft können Sie einen Verweis auf das Connection-Objekt der aktuellen ActiveX-Datenobjekte (ADO) und dessen zugehörige Eigenschaften zurückgeben.

Einstellung

[Objekt.]Connection[.Methode oder Eigenschaft]

Die Connection-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Objekt | Das CurrentProject- oder CodeProject-Objekt.
Connection | Erforderlich. Wenn die Connection-Eigenschaft ohne Angabe einer Methode oder Eigenschaft verwendet wird, gibt sie die ConnectionString-Eigenschaft des Connection-Objekts zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des Connection-Objekts.

Die Connection-Eigenschaft ist nur in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Verwenden Sie die Connection-Eigenschaft des CurrentProject-Objekts, um auf das Connection-Objekt des aktuellen Objekts Microsoft Access-Projekt (.adp) oder Access-Datenbank (.mdb) zu verweisen. Verwenden Sie die Connection-Eigenschaft des CodeProject-Objekts, um auf das Connection-Objekt des Access-Projekts oder des Datenbankobjekts des Access-Datenbankcodes zu verweisen. Sie können die Connection-Eigenschaft verwenden, um Methoden im Connection-Objekt aufzurufen, wie z. B. BeginTrans und CommitTrans.

Anmerkung Die Connection-Eigenschaft gibt in Wirklichkeit einen Verweis auf eine Kopie der ADO-Verbindung für die aktive Datenbank zurück. Deshalb wirkt sich das Anwenden der Close-Methode oder ein Versuch, die Verbindung über die Methoden oder Eigenschaften des Connection-Objekts zu ändern, nicht auf das eigentliche Verbindungsobjekt aus, mit dessen Hilfe Microsoft Access eine aktive Verbindung zur aktuellen Datenbank aufrechterhält. Da die Connection-Eigenschaft die vorrangige "Shape"-Providerverbindung darstellt, müssen Sie bei der Verwendung dieser Eigenschaft die folgende Information beachten.

  1. MSDataShape verwendet Recordset.CursorLocation = adUseClient. Die Einstellung CursorLocation sollte erst nach der Zuweisung eines Datensatzes zum CurrentProject.Connect erfolgen.

  2. MSDataShape verwendet Recordset.CursorType = adOpenStatic. Die Einstellung CursorType sollte erst nach der Zuweisung eines Datensatzes zum CurrentProject.Connection erfolgen.

  3. MSDataShape unterstützt Recordset.LockType = adLockOptimistic, adLockBatchOptimistic, oder adLockReadOnly (standardmäßig). Eine Einstellung auf adLockPessimistic wird zu adLockOptimistic geändert.

  4. Die "Shape"-Verbindung unterstützt nicht alle ADOX-Vorgänge, insbesondere wird die Columns.Properties-Auflistung nicht unterstützt.

  5. Um korrektes Funktionieren der "Shape"-Verbindung zu gewährleisten, muss eine Einstellung von Command.CommandType auf adCmdTable vorgenommen werden.


 ConnectionString-Eigenschaft

ConnectionString-Eigenschaft

Mit der ConnectionString-Eigenschaft können Sie auf die Haupt-Verbindungszeichenfolge des DataAccessPage-Objekts zugreifen.

Einstellung

Die ConnectionString-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Die ConnectionString-Eigenschaft liefert als Wert die Verbindungszeichenfolge, die über die OpenConnection-Methode oder mit Hilfe des Befehls Verbindung im Menü Datei definiert worden ist. Beim Herstellen der Verbindung modifiziert das Microsoft Access-Projekt die ConnectionString-Eigenschaft und passt sie der ADO-Umgebung an. Das Microsoft Office-Datenquellen-Steuerelement (MSODSC) ändert ebenfalls den Wert der ConnectionString-Eigenschaft.


 ControlBox-Eigenschaft (MitSystemmenüfeld)

ControlBox-Eigenschaft (MitSystemmenüfeld)

Mit der Eigenschaft ControlBox können Sie angeben, ob ein Formular in der Formularansicht und in der Datenblattansicht über ein Systemmenü verfügt.

Einstellung

Die Eigenschaft ControlBox verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Das Formular verfügt in der Formular- und Datenblattansicht über ein Systemmenü.
Nein | False (0) | Das Formular verfügt in der Formular- und Datenblattansicht über kein Systemmenü.

Anmerkung Das Einstellen der Eigenschaft ControlBox auf Nein entfernt die Minimieren-, Maximieren- und Schließen-Schaltflächen in einem Formular.

Sie können die Eigenschaft ControlBox im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaft nur in der Formularentwurfsansicht einstellen.

Anmerkung

Zur Anzeige eines Systemmenüs in einem Formular muss die Eigenschaft ControlBox auf Ja und die Eigenschaft BorderStyle des Formulars auf Dünn, Veränderbar oder Dialog eingestellt sein.

Auch wenn die Eigenschaft ControlBox eines Formulars auf Nein eingestellt ist, verfügt das Formular stets über ein Systemmenü, wenn es in der Entwurfsansicht geöffnet wird.

Das Einstellen der Eigenschaft ControlBox auf Nein unterbindet die Anzeige des Systemmenüs in folgenden Fällen:

  • Beim Öffnen des Formulars in der Formularansicht aus dem Datenbankfenster.

  • Beim Öffnen des Formulars aus einem Makro.

  • Beim Öffnen des Formulars in Visual Basic.

  • Beim Öffnen des Formulars in der Datenblattansicht.

  • Beim Wechseln aus der Entwurfsansicht zur Formular- oder Datenblattansicht.


 Controls-Eigenschaft (Form-, SubForm-, Report-Objekt)

Controls-Eigenschaft (Form-, SubForm-, Report-Objekt)

Mit der Controls-Eigenschaft können Sie auf die Auflistung Controls eines Formulars, Unterformulars, Berichts oder Bereichs verweisen.

Einstellung

Die Controls-Eigenschaft ist nur in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Verwenden Sie die Controls-Eigenschaft, um auf eines der Steuerelemente in einem Formular, Unterformular, Bericht oder Bereich innerhalb eines anderen Steuerelements oder auf ein Steuerelement zu verweisen, das einem anderen Steuerelement zugeordnet ist. Beispielsweise würde die erste Codesyntax die Anzahl der Steuerelemente in Formular1 zurückgeben. Die zweite Syntax würde auf den Namen einer Eigenschaft innerhalb eines Steuerelements verweisen.

Forms("Formular1").Controls.Count

Forms("Formular1").Controls("Textbox1").Properties(5).Name


 ControlSource-Eigenschaft (Steuerelementinhalt)

ControlSource-Eigenschaft (Steuerelementinhalt)

Mit der Eigenschaft ControlSource können Sie angeben, welche Daten in einem Steuerelement angezeigt werden sollen. Sie können Daten, die an ein Feld gebunden sind, in einer Tabelle, Abfrage oder SQL-Anweisung anzeigen und bearbeiten. Sie können auch das Ergebnis eines Ausdrucks darstellen. Für einen Bericht auf Gruppierungsebene bestimmt die Eigenschaft ControlSource das Feld oder den Ausdruck, nach dem gruppiert wird.

Anmerkung Die Eigenschaft ControlSource gilt nicht für Kontrollkästchen-, Optionsfeld- oder Umschaltfläche-Steuerelemente in einer Optionsgruppe. Sie gilt nur für die Optionsgruppe an sich.

Bei Berichten gilt die Eigenschaft ControlSource nur für BerichtsGruppierungsebenen.

Einstellung

Die Eigenschaft ControlSource hat die folgenden Einstellungen.

Einstellung | Beschreibung
Ein Feldname | Das Steuerelement ist an ein Feld einer Tabelle, Abfrage oder SQL-Anweisung gebunden. Die Daten des Feldes werden im Steuerelement angezeigt. Veränderungen an den Daten innerhalb des Steuerelements bewirken Veränderungen an den entsprechenden Daten in dem Feld. (Stellen Sie die Eigenschaft Locked auf Ja ein, um das Steuerelement auf schreibgeschützt einzustellen.) Wenn Sie auf ein Steuerelement klicken, das an ein Feld gebunden ist, das den Datentyp Hyperlink hat, erfolgt ein Sprung zu dem Ziel, das in der Hyperlinkadresse angegeben ist.
Ein Ausdruck | Das Steuerelement zeigt Daten an, die durch einen Ausdruck erstellt wurden. Diese Daten können zwar vom Benutzer geändert werden, werden aber nicht in der Datenbank gespeichert.

Sie können die Eigenschaft ControlSource eines Steuerelements im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft ControlSource auch für ein Textfeld einstellen, indem Sie einen Feldnamen oder Ausdruck direkt in das Textfeld in der Formularentwurfsansicht oder in der Berichtsentwurfsansicht eingeben.

Sie können diese Eigenschaft für einen Bericht durch Auswahl eines Feldes in der oder durch Eingabe eines Ausdrucks in die Spalte Feld/Ausdruck im Dialogfeld Sortieren und gruppieren einstellen. Weitere Informationen finden Sie unter der Eigenschaft GroupLevel.

Verwenden Sie in Visual Basic einen Zeichenfolgenausdruck, um den Wert dieser Eigenschaft einzustellen.

Anmerkung

Formulare und Berichte verhalten sich wie "Fenster" zu Ihrer Datenbank. Sie geben die primäre Herkunft von Daten für ein Formular oder einen Bericht durch Einstellen der zugehörigen Eigenschaft RecordSource auf eine Tabelle, Abfrage oder SQL-Anweisung an. Anschließend können Sie die Eigenschaft ControlSource auf ein Feld in der Herkunft der Daten oder auf einen Ausdruck einstellen. Ist die Einstellung von ControlSource ein Ausdruck, so ist der angezeigte Wert schreibgeschützt und wird nicht in der Datenbank gespeichert. Sie können z.B. folgende Einstellungen verwenden.

Beispieleinstellung | Beschreibung
Nachname | Bei einem Steuerelement werden Daten aus dem Feld Nachname im Steuerelement angezeigt. Bei einem Bericht auf Gruppierungsebene gruppiert Microsoft Access die Daten nach dem Nachnamen.
=Datum( ) + 7 | Bei einem Steuerelement zeigt dieser Ausdruck ein Datum im Steuerelement an, das sieben Tage in der Zukunft liegt.
=DatTeil("q";Versanddatum) | Bei einem Steuerelement zeigt dieser Ausdruck das Quartal des Versanddatums an. Bei einem Bericht auf Gruppierungsebene gruppiert Microsoft Access die Daten nach dem Quartal des Versanddatums.


 ControlTipText-Eigenschaft (SteuerelementTipText)

ControlTipText-Eigenschaft (SteuerelementTipText)

Mit der Eigenschaft ControlTipText können Sie den Text angeben, der in einem InfoFeld angezeigt wird, wenn sich der Mauszeiger über einem Steuerelement befindet.

Einstellung

Sie stellen die Eigenschaft ControlTipText mit einem Zeichenfolgenausdruck ein, der bis zu 255 Zeichen lang sein darf.

Sie können die Eigenschaft ControlTipText im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei Steuerelementen eines Formulars können Sie die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

Sie können die Eigenschaft ControlTipText in jeder Ansicht einstellen.

Anmerkung

Die Eigenschaft ControlTipText bietet eine einfache Möglichkeit, Informationen zu Steuerelementen eines Formulars bereit zu stellen.

Es gibt weitere Möglichkeiten, Informationen zu einem Formular oder einem Steuerelement eines Formulars bereit zu stellen. Sie können die Eigenschaft StatusBarText verwenden, um in der Statusleiste Informationen zu einem Steuerelement anzuzeigen. Wenn Sie eine ausführlichere Hilfe zu einem Formular oder Steuerelement bereit stellen möchten, können Sie die Eigenschaften HelpFile und HelpContextID verwenden.


 ControlType-Eigenschaft

ControlType-Eigenschaft

Sie können die Eigenschaft ControlType in Visual Basic einsetzen, um den Typ (die Art) eines Steuerelements zu ermitteln, das zu einem Formular oder Bericht gehört.

Einstellung

Das Einstellen der Eigenschaft ControlType ist eine eingebaute Konstante, die den Steuerelementtyp angibt.

Konstante | Steuerelement
acBoundObjectFrame | Gebundenes Objektfeld
acCheckBox | Kontrollkästchen
acComboBox | Konbinationsfeld
acCommandButton | Befehlsschaltfläche
acCustomControl | ActiveX-Steuerelement
acImage | Bild
acLabel | Bezeichnungsfeld
acLine | Linie
acListBox | Listenfeld
acObjectFrame | ungebundenes Objektfeld oder Diagramm
acOptionButton | Optionsschaltfläche
acOptionGroup | Optionsgruppe
acPage | Seite
acPageBreak | Seitenwechsel
acRectangle | Rechteck
acSubform | Unterformular/-bericht
acTabCtl | Registersteuerelement
acTextBox | Textfeld
acToggleButton | Umschaltfläche

Die Eigenschaft ControlType kann nur über Visual Basic in der Formularentwurfsansicht oder Berichtsentwurfsansicht eingestellt werden, jedoch in allen Ansichten gelesen werden.

Anmerkung

Die Eigenschaft ControlType ist nicht nur für die Suche nach einem bestimmten Steuerelementtypen im Code, sondern auch für den Wechsel des Steuerelementtyps nützlich. Sie können z.B. ein Textfeld in ein Kombinationsfeld umwandeln, indem Sie die Eigenschaft ControlType des Textfelds auf acComboBox einstellen, während das Formular in der Entwurfsansicht angezeigt wird.

Sie können die Eigenschaft ControlType zum Ändern der Merkmale ähnlicher Steuerelemente in einem Formular abhängig von bestimmten Bedingungen verwenden. Wenn Sie z.B. nicht möchten, dass Benutzer bestehende Daten in Textfeldern bearbeiten, können Sie die Eigenschaft SpecialEffect für alle Textfelder auf Flach und die Eigenschaft AllowEdits des Formulars auf Nein einstellen. (Die Eigenschaft SpecialEffect hat keine Auswirkungen darauf, ob die Daten bearbeitet werden können; sie wird hier verwendet, um einen sichtbaren Anhaltspunkt über die Veränderung des Steuerelementverhaltens bereit zu stellen.)

Die Eigenschaft ControlType wird auch verwendet, um die Typen der Steuerelemente festzulegen, die mit der Methode CreateControl erstellt werden.


 Count-Eigenschaft (Anzahl)

Count-Eigenschaft (Anzahl)

Mit der Eigenschaft Count können Sie ermitteln, wie viele Elemente in der angegebenen Auflistung geöffnet sind.

Einstellung

Die Einstellung der Eigenschaft Count ist ein Wert des Typs Integer und in allen Ansichten schreibgeschützt.

Die Einstellung der Eigenschaft Count eines Objekts können Sie mit einem Makro oder mit Visual Basic ermitteln.

Anmerkung

Wenn Sie z. B. die Anzahl der Formulare ermitteln möchten, die in der Datenbank momentan geöffnet oder vorhanden sind, geben Sie folgenden Code ein:

'Determine the number of open forms.

forms.count

'Determine the number of forms (open or closed)
'in the current database.

currentproject.allforms.count


 CountOfDeclarationLines-Eigenschaft

CountOfDeclarationLines-Eigenschaft

Die Eigenschaft CountOfDeclarationLines gibt einen Wert des Datentyps Long zurück, der angibt, wie viele Codezeilen der Deklarationsbereich eines Standardmoduls oder eines Klassenmoduls enthält.

Einstellung

Die Eigenschaft CountOfDeclarationLines steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Nummerierung der Zeilen eines Moduls beginnt mit 1.

Der Wert der Eigenschaft CountOfDeclarationLines ist gleich der Zeilennummer der letzten Zeile im Deklarationsbereich. Mit Hilfe dieser Eigenschaft können Sie ermitteln, wo der jeweilige Deklarationsbereich endet und wo der Rumpf des Moduls beginnt.


 CountOfLines-Eigenschaft

CountOfLines-Eigenschaft

Die Eigenschaft CountOfLines gibt einen Wert des Datentyps Long zurück, der angibt, wie viele Codezeilen ein Standardmodul oder ein Klassenmodul enthält.

Einstellung

Die Eigenschaft CountOfLines steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Nummerierung der Zeilen eines Moduls beginnt mit 1.

Die Zeilennummer der letzten Zeile eines Moduls ist gleich dem Wert der Eigenschaft CountOfLines.


CurrentData-Eigenschaft

Mit der CurrentData-Eigenschaft können Sie auf das CurrentData-Objekt und dessen zugehörige Auflistungen zugreifen.

Einstellung

Diese Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Verwenden Sie die CurrentData-Eigenschaft, wenn Sie auf eine der folgenden Auflistungen der aktuellen Datenbank und deren Eigenschaften bzw. Methoden zugreifen möchten.

AllTables | AllQueries
AllViews | AllStoredProcedures
AllDatabaseDiagrams |


 CurrentObjectType-, CurrentObjectName-Eigenschaften

CurrentObjectType-, CurrentObjectName-Eigenschaften

Sie können die Eigenschaften CurrentObjectType und CurrentObjectName zusammen mit dem Application-Objekt verwenden, um den Typ des aktiven Datenbankobjekts (Tabelle, Abfrage, Formular, Bericht, Makro, Modul, Datenzugriffsseite, Serversicht, Datenbankdiagramm oder Gespeicherte Prozedur) und den Namen des aktiven Datenbankobjekts zu ermitteln. Das Objekt mit dem Fokus oder das Objekt, in dem Code ausgeführt wird, ist das aktive Datenbankobjekt.

Einstellung

Die CurrentObjectType-Eigenschaft wird von Microsoft Access auf eine der folgenden eingebauten Konstanten eingestellt.

Einstellung | Beschreibung
acTable (0) | Das aktive Objekt ist eine Tabelle.
AcQuery (1) | Das aktive Objekt ist eine Abfrage.
AcForm (2) | Das aktive Objekt ist ein Formular.
AcReport (3) | Das aktive Objekt ist ein Bericht.
AcMacro (4) | Das aktive Objekt ist ein Makro.
AcModule (5) | Das aktive Objekt ist ein Modul.
acDataAccessPage (6) | Das aktive Objekt ist eine Datenzugriffsseite.
acServerView (7) | Das aktive Objekt ist eine Serversicht.
acDiagram (8) | Das aktive Objekt ist ein Datenbankdiagramm.
acStoredProcedure (9) | Das aktive Objekt ist eine Gespeicherte Prozedur.

Die CurrentObjectName-Eigenschaft wird von Microsoft Access auf einen Zeichenfolgenausdruck festgelegt, der den Namen des aktiven Objekts enthält.

Die Einstellungen dieser Eigenschaften sind nur in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Die folgenden Bedingungen bestimmen, welches Objekt als das aktive Objekt angesehen wird:

  • Ist das aktive Objekt ein Eigenschaftenfenster, eine Befehlsleiste, ein Menü, eine Palette oder eine Feldliste eines Objekts geben die Eigenschaften CurrentObjectType und CurrentObjectName den Typ und den Namen des zugrunde liegenden Objekts zurück.

  • Ist das Objekt ein Popupformular, beziehen sich die Eigenschaften CurrentObjectType und CurrentObjectName auf das Popupformular selbst und nicht auf das Formular, von dem aus dieses geöffnet wurde.

  • Wenn das aktive Objekt das Datenbankfenster ist, geben die Eigenschaften CurrentObjectType und CurrentObjectName das im Datenbankfenster ausgewählte Element zurück.

  • Wenn kein Objekt ausgewählt ist, gibt die CurrentObjectType-Eigenschaft den Wert True (-1) und die CurrentObjectName-Eigenschaft eine leere Zeichenfolge ("") zurück.

  • Wenn der aktuelle Zustand mehrdeutig ist (d.h. das aktive Objekt ist keine Tabelle, keine Abfrage, kein Formular, kein Bericht, kein Makro und auch kein Modul) —, wenn z.B. ein Dialogfeld den Fokus — hat, gibt die CurrentObjectType-Eigenschaft den Wert True und die CurrentObjectName-Eigenschaft den Namen des Dialogfelds zurück.

Sie können diese Eigenschaften mit der SysCmd-Methode verwenden, um das aktive Objekt und seinen Zustand zu ermitteln (z.B. ob das Objekt geöffnet oder neu ist, bzw. ob es geändert, aber nicht gespeichert wurde).


 CurrentPage-Eigenschaft

CurrentPage-Eigenschaft

Mit der CurrentPage-Eigenschaft können Sie die Seitenzahl der im Snapshot Viewer-Steuerelement angezeigten Seite angeben oder ermitteln.

Einstellung

Die Einstellung der CurrentPage-Eigenschaft ist ein Wert des Datentyps Long, der eine Seitenzahl in einem Snapshot darstellt.

Diese Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Wenn Sie diese Eigenschaft auf eine ungültige Seitenzahl einstellen, einen ungültigen Dateityp laden oder darauf zuzugreifen versuchen, während der Wert der ReadyState-Eigenschaft kleiner als 4 ist, tritt ein Fehler auf.


CurrentProject-Eigenschaft

Mit der CurrentProject-Eigenschaft können Sie auf das CurrentProject-Objekt und dessen zugehörige Auflistungen, Eigenschaften und Methoden zugreifen.

Einstellung

Die CurrentProject-Eigenschaft enthält eine Referenz auf das CurrentProject-Objekt für die aktuelle Codedatenbank.

Diese Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Verwenden Sie die CurrentProject-Eigenschaft, wenn Sie auf eine der folgenden Auflistungen der aktuellen Datenbank und deren Eigenschaften bzw. Methoden zugreifen möchten.


 CurrentRecord-Eigenschaft

CurrentRecord-Eigenschaft

Mit Hilfe der Eigenschaft CurrentRecord können Sie den aktuellen Datensatz in der Datensatzgruppe bestimmen, die gerade in einem Formular angezeigt wird.

Einstellung

Microsoft Access stellt diese Eigenschaft auf einen Wert des Datentyps Long Integer ein, der für die Nummer des gerade in einem Formular angezeigten Datensatzes steht.

Die Eigenschaft CurrentRecord ist in der Formularansicht und in der Datenblattansicht schreibgeschützt. In der Entwurfsansicht steht sie nicht zur Verfügung. Diese Eigenschaft steht nur bei Verwendung eines Makros oder von Visual Basic zur Verfügung.

Anmerkung

Der durch diese Eigenschaft festgelegte Wert entspricht dem Wert, der im Datensatznummernfeld angezeigt wird. Dieses befindet sich in der linken unteren Ecke des Formulars.


 CurrentSectionLeft-, CurrentSectionTop-Eigenschaften (AktuellerBereichLinks, AktuellerBereichOben)

CurrentSectionLeft-, CurrentSectionTop-Eigenschaften (AktuellerBereichLinks, AktuellerBereichOben)

Sie können diese Eigenschaften verwenden, um den Abstand zwischen oberem Rand und linker Kante des aktuellen Bereichs und oberem Rand und linker Kante des Formulars in Twips anzugeben.

Einstellung

  • Eigenschaft CurrentSectionLeft: ein Wert vom Typ Integer, der den Abstand von der linken Kante des aktuellen Bereichs zum linken Rand des Formulars darstellt.

  • Eigenschaft CurrentSectionTop: ein Wert vom Typ Integer, der den Abstand vom oberen Rand des aktuellen Bereichs zum oberen Rand des Formulars darstellt.

Diese Eigenschafteneinstellungen sind schreibgeschützt und nur in einem Makro oder in Visual Basic verfügbar.

Anmerkung

Die Einstellungen der Eigenschaften CurrentSectionLeft und CurrentSectionTop ändern sich immer dann, wenn ein Benutzer durch ein Formular blättert.

Bei Formularen, deren Eigenschaft DefaultView auf Einzelnes Formular eingestellt ist, entsprechen die Eigenschafteneinstellungen negativen Werten, wenn der Benutzer einen Bildlauf über die obere linke Ecke des Bereichs oder links über den linken Rand des Formulars hinaus durchführt.

Bei Formularen, deren Eigenschaft DefaultView auf Endlosformular eingestellt ist, entspricht die Eigenschaft CurrentSectionTop der Eigenschaft InsideHeight des Formulars, wenn ein Bereich nicht sichtbar ist.

Die Eigenschaften CurrentSectionLeft und CurrentSectionTop sind hilfreich, um die Position von in der Formularansicht angezeigten Detailbereichen zu finden, die als Endlosformulare oder in der Datenblattansicht angezeigt werden. Jeder Detailbereich verfügt über eine eigene Einstellung der Eigenschaft CurrentSectionTop, die von der Position des Bereichs im Formular abhängt.


 CurrentView-Eigenschaft (AktuelleAnsicht)

CurrentView-Eigenschaft (AktuelleAnsicht)

Mit der Eigenschaft CurrentView können Sie ermitteln, wie ein Formular oder eine Datenzugriffsseite momentan angezeigt wird. Sie möchten z. B. wissen, ob ein Formular in der Formularansicht oder in der Datenblattansicht angezeigt wird, bevor Sie versuchen, mit Visual Basic Steuerelemente auf dem Formular anzuordnen.

Einstellung

Die Eigenschaft CurrentView verwendet folgende Einstellungen.

Einstellung | Formular angezeigt in: | Datenzugriffsseite angezeigt in:
0 | Entwurfsansicht | Entwurfsansicht
1 | Formularansicht | Seitenansicht
2 | Datenblattansicht | Entfällt

Diese Eigenschaft steht nur in einem Makro oder in Visual Basic zur Verfügung und ist in allen Ansichten schreibgeschützt.

Anmerkung

Sie können diese Eigenschaft auch verwenden, um abhängig von der aktuellen Ansicht unterschiedliche Vorgänge auszuführen. In einer Ereignisprozedur kann z. B. ermittelt werden, in welcher Ansicht das Formular angezeigt wird, und dann ein Vorgang ausgeführt werden, wenn das Formular in der Formularansicht angezeigt wird, bzw. ein anderer Vorgang, wenn das Formular in der Datenblattansicht angezeigt wird.


 CurrentX-, CurrentY-Eigenschaften

CurrentX-, CurrentY-Eigenschaften

Sie können die Eigenschaften CurrentX und CurrentY zum Einstellen der horizontalen und vertikalen Koordinaten für die Startposition der nächsten Druck- und Zeichen-Methode in einem Bericht verwenden. Sie können mit diesen Eigenschaften z. B. feststellen, wo sich der Kreismittelpunkt in einem Berichtsbereich befindet.

Einstellung

  • Die Eigenschaft CurrentX gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die horizontale Koordinate der nächsten Druck- oder Zeichenmethode einstellt.

  • Die Eigenschaft CurrentY gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die vertikale Koordinate der nächsten Druck- oder Zeichenmethode einstellt.

Die Koordinaten werden von der oberen linken Ecke des Berichtsbereichs aus gemessen, der den Verweis auf die Eigenschaft CurrentX oder CurrentY enthält. Die Einstellung der Eigenschaft CurrentX hat für den linken Rand des Bereichs den Wert 0, und die Einstellung der Eigenschaft CurrentY hat für den oberen Rand des Bereichs den Wert 0.

Die Eigenschaften CurrentX und CurrentY können nur in einem Makro oder in einer Visual Basic-Ereignisprozedur eingestellt werden, die in der Einstellung der Eigenschaft OnPrint eines Berichtsbereichs angegeben ist.

Anmerkung

Verwenden Sie die Eigenschaft ScaleMode, um die Maßeinheit (Punkt, Pixel, Zeichen, Zoll, Millimeter oder Zentimeter) zu definieren, die für die Koordinaten verwendet werden soll.

Wenn Sie die folgenden Grafikmethoden verwenden, werden die Einstellungen für CurrentX und CurrentY wie folgt geändert:

Methode | Wert für CurrentX und CurrentY
Circle | Mittelpunkt des Objekts.
Line | Endpunkt der Linie (die Koordinaten x2 und y2).
Print | Nächste Druckposition.


 Cycle-Eigenschaft (Zyklus)

Cycle-Eigenschaft (Zyklus)

Mit der Eigenschaft Cycle können Sie festlegen, wie reagiert werden soll, wenn TAB gedrückt wird und sich der Fokus im letzten Steuerelement eines gebundenen Formulars befindet.

Einstellung

Die Eigenschaft Cycle verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Alle Datensätze | 0 | (Standardeinstellung) Wird TAB gedrückt, wenn das letzte Steuerelement eines Formulars den Fokus hat, erfolgt ein Wechsel zum nächsten Datensatz, und der Fokus wird auf das Steuerelement verschoben, das in der Reihenfolge der Steuerelemente das erste Steuerelement ist.
Aktueller Datensatz | 1 | Wird TAB gedrückt, wenn das letzte Steuerelement den Fokus hat, wird der Fokus auf das in der Reihenfolge der Steuerelemente erste Steuerelement verschoben. Es erfolgt aber kein Wechsel zum nächsten Datensatz.
Aktuelle Seite | 2 | Wird TAB gedrückt, wenn das letzte Steuerelement den Fokus hat, wird der Fokus auf das Steuerelement verschoben, das bezüglich der aktuellen Seite in der Reihenfolge der Steuerelemente das erste Steuerelement ist.

Sie können die Eigenschaft Cycle im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft Cycle in jeder Ansicht einstellen.

Anmerkung

Wenn Sie TAB auf einem Formular drücken, bewegt sich der Fokus von Steuerelement zu Steuerelement entsprechend der Position, die jedes Steuerelement in der Reihenfolge der Steuerelemente einnimmt.

Bei Formularen, die für die Eingabe von Daten vorgesehen sind, können Sie die Eigenschaft Cycle auf Alle Datensätze einstellen. Dies ermöglicht es dem Benutzer, durch Drücken von TAB zum nächsten Datensatz zu wechseln.

Anmerkung Die Eigenschaft Cycle legt das Verhalten, wie auf das Drücken von TAB reagiert wird, nur für das Formular fest, zu der sie gehört. Befindet sich in der Reihenfolge der Steuerelemente ein Unterformular-Steuerelement und erhält dieses den Fokus, bestimmt die Eigenschaft Cycle des Unterformulars, wie reagiert wird, wenn TAB gedrückt wird.

Drücken Sie STRG+TAB, um den Fokus aus einem Unterformular-Steuerelement zu einem Steuerelement des Hauptformulars zu verschieben.


DataAccessPages-Eigenschaft

Mit der DataAccessPages-Eigenschaft können Sie auf die DataAccessPages-Auflistung und deren zugehörige Eigenschaften zugreifen.

Einstellung

Die DataAccessPages-Eigenschaft steht nur unter Visual Basic zur Verfügung und ist schreibgeschützt.


 DataEntry-Eigenschaft (DatenEingeben)

DataEntry-Eigenschaft (DatenEingeben)

Sie können mit der Eigenschaft DataEntry angeben, ob ein gebundenes Formular nur für die Dateneingabe geöffnet werden soll. Die Eigenschaft Data Entry gibt nicht an, ob Datensätze hinzugefügt werden können, sondern nur, ob bestehende Datensätze angezeigt werden.

Einstellung

Die Eigenschaft DataEntry verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular zeigt beim Öffnen nur einen leeren Datensatz an.
Nein | False (0) | (Standardeinstellung) Das Formular zeigt beim Öffnen vorhandene Datensätze an.

Sie können die Eigenschaft DataEntry im Eigenschaftenfenster eines Formulars, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann in allen Ansichten eingestellt werden.

Anmerkung

Die Eigenschaft DataEntry ist nur dann wirksam, wenn die Eigenschaft AllowAdditions auf Ja eingestellt ist.

Das Einstellen der Eigenschaft DataEntry auf Ja mit Visual Basic hat den gleichen Effekt wie das Klicken auf Daten eingeben im Menü Datensätze. Das Einstellen der Eigenschaft auf Nein mit Visual Basic entspricht dem Klicken auf Filter/Sortierung entfernen im Menü Datensätze.

Anmerkung Wenn das Argument Datenmodus der Aktion ÖffnenFormular eingestellt wird, überschreibt Microsoft Access eine Reihe von Formulareigenschaften. Wenn das Argument Datenmodus der Aktion ÖffnenFormular auf Bearbeiten eingestellt ist, öffnet Microsoft Access das Formular mit den folgenden Eigenschafteneinstellungen:

  • AllowEdits - Ja

  • AllowDeletions - Ja

  • AllowAdditions - Ja

  • DataEntry - Nein

Wenn Sie verhindern möchten, dass die Aktion ÖffnenFormular diese vorhandenen Eigenschafteneinstellungen überschreibt, lassen Sie die Einstellung des Arguments Datenmodus weg, damit Microsoft Access die vom Formular definierten Eigenschafteneinstellungen verwendet.


 DatasheetBackColor-, DatasheetForeColor-Eigenschaften (DatenblattHintergrundfarbe, DatenblattVordergrundfarbe)

DatasheetBackColor-, DatasheetForeColor-Eigenschaften (DatenblattHintergrundfarbe, DatenblattVordergrundfarbe)

  • Mit der DatasheetBackColor-Eigenschaft können Sie in Visual Basic für eine gesamte Tabelle, eine gesamte Abfrage oder ein gesamtes Formular die Hintergrundfarbe angeben oder ermitteln, die in der Datenblattansicht innerhalb einer Microsoft Access-Datenank (.mdb ) verwendet wird .

  • Mit der DatasheetForeColor-Eigenschaft können Sie in Visual Basic für den gesamten Text einer Tabelle, einer Abfrage oder eines Formulars die Farbe angeben oder ermitteln, die in der Datenblattansicht innerhalb einer Access-Datenbank (.mdb) verwendet wird.

Einstellung

Die Eigenschaften DatasheetBackColor und DatasheetForeColor werden auf Werte des Long Integer-Datentyps eingestellt. Diese Werte geben für ein Datenblatt die Einstellungen der Hintergrund- und der Vordergrundfarbe an.

Die folgenden Angaben über Einstellungen gelten sowohl für Microsoft Access-Datenbanken als auch für Access-Projekte (.adp):

  • Sie können diese Eigenschaften auch einstellen, indem Sie in der Symbolleiste Format (Datenblatt) auf Füll-/Hintergrundfarbe [image] bzw. Schrift-/Vordergrundfarbe [image] und dann in der Farbpalette auf die gewünschte Farbe klicken.

  • Die Standardwerte für die Eigenschaften DatasheetBackColor und DatasheetForeColor können Sie auch im Dialogfeld Optionen auf der Registerkarte Datenblatt angeben. Das Dialogfeld Optionen wird angezeigt, wenn Sie im Menü Extras auf Optionen klicken.

Anmerkung

Wenn Sie die Eigenschaften DatasheetBackColor und DatasheetForeColor einer Tabelle oder einer Abfrage einstellen, hat dies keine Auswirkungen auf die Einstellungen der entsprechenden Eigenschaften eines Formulars, für das die Tabelle oder Abfrage als Datenquelle verwendet wird.

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetBackColor | DatasheetFontUnderline*
DatasheetCellsEffect | DatasheetFontWeight*
DatasheetFontHeight* | DatasheetForeColor*
DatasheetFontItalic* | DatasheetGridlinesBehavior
DatasheetFontName* | DatasheetGridlinesColor

Anmerkung Wenn Sie eine Eigenschaft hinzufügen oder einstellen, hinter der ein Sternchen steht, fügt Microsoft Access diese Eigenschaft automatisch zu der entsprechenden Auflistung Properties hinzu.


 DatasheetCellsEffect-Eigenschaft

DatasheetCellsEffect-Eigenschaft

Mit der DatasheetCellsEffect-Eigenschaft können Sie angeben, ob Zellen eines Datenblatts Spezialeffekte zugewiesen werden.

Anmerkungen Die DatasheetCellsEffect-Eigenschaft gilt nur für Objekte in der Datenblattansicht.

Diese Eigenschaft ist nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

Die DatasheetCellsEffect-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Flach | AcEffectNormal (0) | (Voreinstellung) Den Zellen im Datenblatt werden keine Spezialeffekte zugewiesen.
Erhöht | AcEffectRaised (1) | Zellen im Datenblatt werden erhöht dargestellt.
Vertieft | AcEffectSunken (2) | Zellen im Datenblatt werden vertieft dargestellt.

Sie können diese Eigenschaft mit der Schaltfläche Zelleffekt in der Symbolleiste Formatierung (Datenblatt) und innerhalb einer Access-Datenbank(.mdb) durch Verwendung eines Makros oder von Visual Basic-Code.

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Access-Projekte (.adp):

Diese Eigenschaft kann auch eingestellt werden, indem Sie im Menü Format auf den Befehl Zellen klicken und dann im Dialogfeld Zelleffekte unter "Zelleffekt" auf den Typ des gewünschten Zelleffekts klicken.

Sie können die Voreinstellung der DatasheetCellsEffect-Eigenschaft in der Registerkarte Datenblatt des Dialogfelds Optionen (das Sie über das Menü Extras öffnen) festlegen.

Anmerkung

Die Eigenschaft wendet den ausgewählten Effekt auf das gesamte Datenblatt an.

Wenn diese Eigenschaft auf Erhöht oder Vertieft eingestellt ist, sind im Datenblatt Gitternetzlinien zu sehen, unabhängig von der Einstellung der DatasheetGridLinesBehavior-Eigenschaft.

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Wenn Sie eine der Eigenschaften setzen oder hinzufügen, die mit einem Sternchen markiert sind, fügt Microsoft Access automatisch alle in der Auflistung mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DatasheetFontName-, DatasheetFontHeight-Eigenschaften

DatasheetFontName-, DatasheetFontHeight-Eigenschaften

Sie können die Eigenschaften DatasheetFontName und DatasheetFontHeight verwenden, um die Schriftart und den Schriftgrad in Punkten für die Anzeige und den Druck von Feldnamen und Daten in der Datenblattansicht anzugeben.

Anmerkungen Die Eigenschaften DatasheetFontName und DatasheetFontHeight gelten für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Diese Eigenschaften sind nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

  • DatasheetFontName. In Visual Basic stellen Sie diese Eigenschaft mit Hilfe eines Zeichenfolgenausdrucks, der dem Namen der Schriftart entspricht, ein.

  • DatasheetFontHeight. In Visual Basic entspricht diese Eigenschafteneinstellung einem Wert vom Typ Integer zwischen 1 und 127, der den Schriftgrad in Punkt darstellt.

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Access-Projekte (.adp):

  • Sie stellen diese Eigenschaften durch Wahl des Schriftnamens aus dem Feld Schriftart FontNames-Objekt oder des Schriftgrades aus dem Feld Schriftgrad [image] in der Symbolleiste Format (Datenblatt) ein.

  • Sie können auch in der Datenblattansicht im Menü Format auf Zeichen klicken und mit den Feldern Schriftart und Schriftgrad die Eigenschaften einstellen.

Anmerkung

Bei der DatasheetFontName-Eigenschaft hängen Schriftartnamen, die von Ihnen angegeben werden können, von den auf Ihrem System und für Ihren Drucker installierten Schriftarten ab. Wenn Sie eine Schriftart angeben, die Ihr System nicht darstellen kann oder die nicht installiert ist, setzt Microsoft Windows stattdessen eine ähnliche Schriftart ein.

Bei der DatasheetFontHeight-Eigenschaft muss der von Ihnen angegebene Schriftgrad in Punkten für die von der DatasheetFontName-Eigenschaft festgelegte Schriftart gültig sein. So ist die Schriftart MS Sans Serif z.B. in den Punktgrößen 8, 10, 12, 14, 18 und 24 verfügbar.

Sie können die Standardwerte für DatasheetFontName und DatasheetFontHeight mit Hilfe der Einstellungen unter Standardschriftart im Menü Extras auf der Registerkarte Datenblatt des Dialogfelds Optionen einstellen.

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Wenn Sie eine Eigenschaft hinzufügen oder setzen, die in der Liste mit einem Sternchen versehen ist, fügt Microsoft Access automatisch alle in der Liste mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DatasheetFontItalic-, DatasheetFontUnderline-Eigenschaften

DatasheetFontItalic-, DatasheetFontUnderline-Eigenschaften

Sie können die Eigenschaften DatasheetFontItalic und DatasheetFontUnderline verwenden, um Feldnamen und Daten in der Datenblattansicht kursiv bzw. unterstrichen anzuzeigen.

Anmerkungen Die Eigenschaften DatasheetFontItalic und DatasheetFontUnderline gelten für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Diese Eigenschaften sind nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

In Visual Basic verwendet die DatascheetFontItalic-Eigenschaft die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Der Text ist kursiv.
False (0) | (Voreinstellung) Der Text ist nicht kursiv.

In Visual Basic verwendet die Eigenschaft DatasheetFontUnderline die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Der Text ist unterstrichen.
False (0) | (Voreinstellung) Der Text ist nicht unterstrichen.

In Visual Basic sind diese Eigenschaften vom Datentyp Boolean.

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Access-Projekte (.adp):

Sie stellen diese Eigenschaften ein, indem Sie in der Symbolleiste Format (Datenblatt) auf die Schaltfläche Kursiv [image] oder Unterstrichen [image] klicken.

Sie können diese Eigenschaften auch im Dialogfeld Zeichen einstellen, indem Sie in der Datenblattansicht im Menü Format auf Zeichen klicken.

Anmerkung

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Fügen Sie eine Eigenschaft zu oder setzen eine Eigenschaft, die in der Liste mit einem Sternchen versehen ist, fügt Microsoft Access automatisch alle in der Liste mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DatasheetFontWeight-Eigenschaft

DatasheetFontWeight-Eigenschaft

Sie können die DatasheetFontWeight-Eigenschaft verwenden, um die Strichstärke der Schriftart anzugeben, die zur Anzeige und Ausgabe von Zeichen für Feldnamen und Daten in der Datenblattansicht verwendet wird.

Anmerkungen Die DatasheetFontWeight-Eigenschaft gilt für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Diese Eigenschaften sind nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

In Visual Basic verwendet die Einstellung der DatasheetFontWeight-Eigenschaft die folgenden Werte vom Typ Integer.

Einstellung | Beschreibung
250 | Extra dünn
200 | Sehr dünn
300 | Dünn
400 | (Voreinstellung) Normal
500 | Mittel
600 | Halbfett
700 | Fett
800 | Sehr fett
900 | Extra fett

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Access-Projekte (.adp):

  • Sie können Normal und Fett für diese Eigenschaft auch im Dialogfeld Zeichen einstellen, indem Sie in der Datenblattansicht im Menü Format auf Zeichen klicken. Im Feld Schriftschnitt des Dialogfelds Zeichen, sind die einzigen verfügbaren Einstellungen für Schriftbreiten Standard (identisch mit Normal) und Fett.

  • Sie können die Einstellungen Normal und Fett auch durch Klicken auf Fett [image] in der Symbolleiste Formatierung (Datenblatt) einstellen.

  • Sie können die Standardeigenschaften für DatasheetFontWeight mit Hilfe der Einstellungen unter Standardschriftart im Menü Extras auf der Registerkarte Datenblatt des Dialogfelds Optionen einstellen.

Anmerkungen

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Wenn Sie eine Eigenschaft hinzufügen oder setzen, die in der Liste mit einem Sternchen versehen ist, fügt Microsoft Access automatisch alle in der Liste mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DatasheetGridlinesBehavior-Eigenschaft

DatasheetGridlinesBehavior-Eigenschaft

Mit Hilfe der DatasheetGridlinesBehavior-Eigenschaft können Sie angeben, welche Gitternetzlinien in der Datenblattansicht angezeigt werden.

Anmerkungen Die DatasheetGridlinesBehavior-Eigenschaft betrifft nur Objekte in der Datenblattansicht.

Diese Eigenschaft ist nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

Die DatasheetGridlinesBehavior-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keines | acGridlinesNone (0) | Es werden keine Gitternetzlinien angezeigt.
Horizontal | AcGridlinesHoriz (1) | Nur horizontale Gitternetzlinien werden angezeigt.
Vertikal | AcGridlinesVert (2) | Nur vertikale Gitternetzlinien werden angezeigt.
Beide | AcGridlinesBoth (3) | (Voreinstellung) Horizontale und vertikale Gitternetzlinien werden angezeigt.

Sie können diese Eigenschaft mit der Schaltfläche Gitternetzlinien in der Symbolleiste Format (Datenblatt), und in einer Access-Datenbank (.mdb) mit einem Makro oder mit Visual Basic-Code einstellen.

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Microsoft Access-Projekte (.adp):

Diese Eigenschaft kann auch eingestellt werden, indem Sie im Menü Format auf den Befehl Datenblatt klicken und dann im Dialogfeld Datenblatt formatieren unter Gitternetzlinien den Typ der gewünschten Gitternetzlinien auswählen.

Sie können die Voreinstellung der DatasheetGridlinesBehavior-Eigenschaft in der Registerkarte Datenblatt des Dialogfelds Optionen (das Sie über das Menü Extras öffnen) festlegen.

Anmerkung

Änderungen an der DatasheetGridlinesBehavior-Eigenschaft sind nur dann sichtbar, wenn die DatasheetCellsEffect-Eigenschaft auf Flach eingestellt ist.

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angehängt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Wenn Sie eine der Eigenschaften setzen oder hinzufügen, die mit einem Sternchen markiert sind, fügt Microsoft Access automatisch alle in der Auflistung mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DatasheetGridlinesColor-Eigenschaft

DatasheetGridlinesColor-Eigenschaft

Mit Hilfe der DatasheetGridlinesColor-Eigenschaft können Sie die Farbe der Gitternetzlinien eines Datenblatts angeben.

Anmerkungen Die DatasheetGridlinesColor-Eigenschaft betrifft nur Objekte in der Datenblattansicht.

Diese Eigenschaft ist nur über Visual Basic-Code innerhalb einer Microsoft Access-Datenbank (.mdb) verfügbar.

Einstellung

Die Einstellung der DatasheetGridlinesColor-Eigenschaft ist vom Datentyp Long Integer. In Visual Basic können Sie diese Eigenschaft auch mit den Funktionen RGB und QBColor einstellen.

Sie können diese Eigenschaft mit der Schaltfläche Linien-/Rahmenfarbe [image] in der Symbolleiste Format (Datenblatt) einstellen, In einer Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe eines Makros oder durch Visual Basic-Code hinzufügen.

Die folgenden Angaben über Einstellungen gelten sowohl für Access-Datenbanken als auch für Microsoft Access-Projekte (.adp):

Diese Eigenschaft kann auch eingestellt werden, indem Sie im Menü Format auf den Befehl Datenblatt klicken und dann im Dialogfeld Datenblatt formatieren in der Dropdownliste Gitternetzlinienfarbe die gewünschte Farbe auswählen.

Sie können die Voreinstellung der DatasheetGridlinesColor-Eigenschaft in der Registerkarte Datenblatt des Dialogfelds Optionen (das Sie über das Menü Extras öffnen) festlegen.

Anmerkung

Die Einstellung dieser Eigenschaft wirkt sich auf die Gitternetzlinienfarbe des gesamten Datenblatts aus. Es ist nicht möglich, die Gitternetzlinienfarbe für einzelne Zellen in der Datenblattansicht einzustellen.

Die folgende Tabelle enthält die Eigenschaften, die so lange nicht in der DAO Properties-Auflistung enthalten sind, bis Sie die Eigenschaften entweder mit der Symbolleiste Format (Datenblatt) eingestellt oder innerhalb einer Access-Datenbank (.mdb) mit der CreateProperty-Methode hinzugefügt und der DAO Properties-Auflistung angefügt haben.

DatasheetFontItalic* | DatasheetForeColor*
DatasheetFontHeight* | DatasheetBackColor
DatasheetFontName* | DatasheetGridlinesColor
DatasheetFontUnderline* | DatasheetGridlinesBehavior
DatasheetFontWeight* | DatasheetCellsEffect

Anmerkung Wenn Sie eine der Eigenschaften setzen oder hinzufügen, die mit einem Sternchen markiert sind, fügt Microsoft Access automatisch alle in der Auflistung mit einem Sternchen versehenen Eigenschaften der Properties-Auflistung der Datenbank hinzu.


 DataType-Eigenschaft (Felddatentyp)

DataType-Eigenschaft (Felddatentyp)

Sie können die Eigenschaft DataType verwenden, um den Typ der in einem Tabellenfeld gespeicherten Daten anzugeben. Jedes Feld kann nur Daten eines einzelnen Datentyps speichern.

Einstellung

Die Eigenschaft DataType verwendet die folgenden Einstellungen.

Einstellung | Datentyp | Größe
Text | (Voreinstellung) Text oder Kombinationen aus Text und Zahlen und auch Zahlen, die keine Berechnungen erfordern, z.B. Telefonnummern. | Bis zu 255 Zeichen oder die in der Eigenschaft Feldgröße eingestellte Länge (je nachdem, welcher Wert kleiner ist). Microsoft Access reserviert keinen Platz für nicht genutzte Teile eines Textfelds.
Memo | Langer Text oder Kombinationen aus Text und Zahlen. | Bis zu 65,535 Zeichen. (Wird das Feld Memo durch DAO gesteuert und werden nur Text und Zahlen [keine binären Daten] gespeichert, ist die Größe des Feldes Memo durch die Größe der Datenbank begrenzt.
Zahl | Numerische Daten, die in mathematischen Berechnungen verwendet werden. Weitere Informationen zur Einstellung eines bestimmten Zahlentyps finden Sie im Thema der Eigenschaft Feldgröße. | 1, 2, 4 oder 8 Bytes (16 Bytes falls die Eigenschaft Feldgröße auf die Replikations-ID eingestellt ist).
Datum/Uhrzeit | Datums- und Zeitwerte für die Jahre 100 bis 9999. | 8 Bytes
Währung | Währungswerte und numerische Daten, die in mathematischen Berechnungen verwendet werden und eine bis vier Dezimalstellen enthalten. Auf bis zu 15 Stellen links, und bis zu 4 Stellen rechts vom Dezimaltrennzeichen genau. | 8 Bytes
AutoWert | Eine eindeutige, fortlaufende Zahl (die jeweils um 1 hochgezählt wird) oder eine Zufallszahl, die von Microsoft Access zugewiesen wird, wenn ein neuer Datensatz in eine Tabelle eingetragen wird. Felder vom Typ AutoWert können nicht aktualisiert werden. Weitere Informationen finden Sie unter NewValues-Eigenschaft. | 4 Bytes (16 Bytes falls die Eigenschaft Feldgröße auf die Replikations-ID eingestellt ist).
Ja/Nein | Ja- und Nein-Werte und -Felder, die nur einen von zwei Werten enthalten (Ja/Nein, True/False oder Ein/Aus). | 1 Bit
OLE-Objekt | Ein Objekt (wie z.B. eine Microsoft Excel-Tabelle, ein Microsoft Word-Dokument, Grafiken, Klänge oder andere binäre Daten), das mit einer Microsoft Access-Tabelle verknüpft oder darin eingebettet ist. | Bis zu 1 Gigabyte (durch den verfügbaren Festplattenspeicher begrenzt).
Hyperlink Text oder Kombinationen aus Text und Zahlen, die als Text abgespeichert und als Hyperlinkadresse verwendet werden. Eine Hyperlinkadresse besteht aus bis zu drei Teilen:

Angezeigter Text. Der Text, der in einem Feld oder einem Steuerelement angezeigt wird.

Adresse. Der Pfad auf eine Datei (UNC-Pfad) oder Seite (URL).

UnterAdresse. Eine Stelle innerhalb einer Datei oder Seite.

Infofeld. Text, der als Quickinfo eingeblendet wird.

Im Menü Einfügen kann durch Klicken auf Hyperlink einfach eine Hyperlinkadresse in ein Feld oder Steuerelement eingefügt werden.

Weitere Informationen finden Sie unter Eingeben von Hyperlinkadressen in der Formular- und Datenblattansicht.

 Jeder Teil, des aus vier Teilen bestehenden Datentyps Hyperlink,kann bis zu 2048 Zeichen enthalten.
Nachschlage - Assistent | Erstellt ein Feld, das Ihnen ermöglicht, einen Wert aus einer anderen Tabelle oder aus einer Liste von Werten mit Hilfe eines Listenfelds oder eines Kominationsfelds. Durch das Wählen dieser Option wird der Nachschlage-Assistent gestartet, der ein Nachschlagefeld erstellt. Schließen Sie den Assistenten, stellt Microsoft Access den im Assistenten gewählten Datentyp ein. | Die gleiche Größe wie das Primärschlüsselfeld, das zum Nachschlagen benötigt wird, in der Regel 4 Bytes.

Sie können diese Eigenschaft nur im oberen Teil der Tabellenentwurfsansicht einstellen.

In Visual Basic, verwenden Sie die ADO-Eigenschaft Type um den Datentyp eines Feldes einzustellen bevor er an die Auflistung der Felder angefügt wird.

Anmerkung

Felder vom Typ Memo, Hyperlink und OLE-Objekt können nicht indiziert werden.

Tipp Verwenden Sie den Datentyp Währung für ein Feld, das viele Berechnungen mit Daten bis zu vier Dezimalstellen einschließt. Felder vom Datentyp Single und Double erfordern Gleitkommaberechnungen. Der Datentyp Währung verwendet eine schnellere Berechnungsmethode, die auf einer festen Anzahl an Dezimalstellen basiert.

Vorsicht Die Veränderung eines Felddatentyps nach der Eingabe von Daten in einer Tabelle bewirkt eventuell eine lange Datenkonvertierung, wenn die Tabelle gespeichert wird. Treten zwischen dem Datentyp in einem Feld und einer geänderten Einstellung der Eigenschaft DataType Konflikte auf, so gehen möglicherweise Daten verloren.

Stellen Sie die Eigenschaft Format ein, um ein vordefiniertes Anzeigeformat für die Datentypen Zahl, Datum/Uhrzeit, Währung und Ja/Nein anzugeben.

Weitere Informationen über die Auswahl von Felddatentypen finden Sie in Kapitel 3, "Schreiben von hartem Kode" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Programmierhandbuch beziehen können, klicken Sie auf [image] .


 DateGrouping-Eigenschaft (Datumsgruppierung)

DateGrouping-Eigenschaft (Datumsgruppierung)

Mit der Eigenschaft DateGrouping können Sie angeben, wie Datumsangaben in einem Bericht gruppiert werden sollen. Verwenden Sie z. B. die Einstellung US-Standard, so beginnt die Woche mit dem Sonntag. Wenn Sie die Eigenschaft GroupOn eines Feldes Datum/Uhrzeit auf Woche einstellen, gruppiert der Bericht die Daten daher von Sonntag bis Samstag.

Anmerkung Die Einstellung der Eigenschaft DateGrouping gilt für den gesamten Bericht, nicht nur für eine bestimmte Gruppe im Bericht.

Einstellung

Die Eigenschaft DateGrouping verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
US-Standard | 0 | Microsoft Access verwendet die US-Standardeinstellungen für den ersten Tag in der Woche (Sonntag) und die erste Woche des Jahres (Woche, in die der 1. Januar fällt).
Systemeinstellungen verwenden | 1 | (Standardeinstellung) Microsoft Access verwendet die Einstellungen, die in der Systemsteuerung von Windows in den Ländereinstellungen unter Gebietsschema im Dialogfeld Eigenschaften von Ländereinstellungen ausgewählt sind.

Sie können diese Eigenschaft im Eigenschaftenfenster des Berichts, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft DateGrouping nur in der Berichtsentwurfsansicht oder in der Ereignisprozedur Open eines Berichts einstellen.

Anmerkung

Die Einstellung der Eigenschaft DateGrouping wirkt sich nicht auf die in einem Bericht verwendete Sortierreihenfolge aus.


 Datenbankeigenschaften

Datenbankeigenschaften

Die Datenbankeigenschaften ermöglichen es Ihnen, weitere Informationen zu Ihrer Datenbank bereitzustellen. Damit die Datenbankeigenschaften angezeigt werden, klicken Sie im Menü Datei auf Datenbankeigenschaften.

Einstellung

Sie können diese Eigenschaften einstellen, indem Sie die entsprechenden Informationen im Dialogfeld Datenbankname Eigenschaften in die Registerkarten Zusammenfassung und Anpassen eingeben oder indem Sie geeigneten Visual Basic-Code in einer Microsoft Access-Datenbank (.mdb) verwenden.

Anmerkung Die Database-Eigenschaften eines Microsoft Access-Projekts (.adp) stehen unter Visual Basic nicht zur Verfügung.

In Visual Basic erstellen Sie eine Datenbankeigenschaft, die noch nicht im Dialogfeld Datenbankname Eigenschaften eingestellt wurde, mit der CreateProperty-Methode und fügen sie zu der Properties-Auflistung eines Document-Objekts hinzu. Mit Visual Basic können Sie die Eigenschaften, die auf der Registerkarte Zusammenfassung angezeigt werden, einstellen, indem Sie das Document-Objekt SummaryInfo aus der Documents-Auflistung verwenden. Die Eigenschaften, die auf der Registerkarte Anpassen angezeigt werden, können Sie mit Hilfe des Document-Objekts UserDefined aus der Documents-Auflistung einstellen. Bevor Sie eine benutzerdefinierte Datenbankeigenschaft zu Ihrer Datenbank hinzufügen können, müssen Sie für diese Eigenschaft einen Namen, einen Datentyp und einen Standardwert angeben. Weitere Informationen erhalten Sie, indem Sie im Thema "Documents-Auflistung" auf Zusatzinfo klicken.

Anmerkung Sie können nur die Eigenschaften eingeben bzw. bearbeiten, die auf einer der Registerkarten Zusammenfassung oder Anpassen angezeigt werden. Die anderen Datenbankeigenschaften sind schreibgeschützt.

Anmerkung

Die Datenbankeigenschaften werden im Dialogfeld Datenbankname Eigenschaften auf einer der folgenden Registerkarten angezeigt.

Registerkarte | Beschreibung
Allgemein | Dies sind dieselben Informationen, die auch angezeigt werden, wenn Sie im Windows Explorer mit der rechten Maustaste auf einen Dateinamen und dann im Kontextmenü auf Eigenschaften klicken. Der einzige Unterschied besteht darin, dass die Einstellungen dieser Eigenschaften, wenn sie in Microsoft Access hinter Attribute angezeigt werden, schreibgeschützt sind.
Zusammenfassung | Diese Informationen ähneln den Datei-Informationen, die Sie in anderen Microsoft Office-Anwendungen bereitstellen können. Datei-Informationen ermöglichen es dem Benutzer, eine Datenbank besser zu verstehen, und zwar sowohl innerhalb von Microsoft Access als auch aus anderen Programmen heraus, wie z.B. das Windows-Programm Suchen nach: Dateien. In Microsoft Access-Datenbanken(.mdb) werden die Informationen, die Sie in diese Registerkarte eingeben, zu dem Document-Objekt SummaryInfo hinzugefügt, das zur Documents-Auflistung gehört. Die Einstellung der auf der Registerkarte Zusammenfassung befindlichen Eigenschaft HyperlinkBase wird verwendet, um den Hyperlinkbasispfad zu erstellen, der vor die Einstellung der Eigenschaft HyperlinkAddress gesetzt wird, wenn diese eine relative Adresse enthält.
Statistik | Diese Informationen enthalten das Datum und die Uhrzeit, zu der die aktive Datenbank erstellt wurde, sowie das Datum und die Uhrzeit, zu der zuletzt auf die Datenbank zugegriffen, zu der sie zuletzt geändert und zu der sie zuletzt gedruckt wurde.
Inhalt | Diese Informationen enthalten die Namen der Objekte, die Bestandteil Ihrer Datenbank sind.
Anpassen | In Microsoft Access-Datenbanken (.mdb) werden die benutzerdefinierten Eigenschaften, die Sie eingeben, zu Eigenschaften des Document-Objekts UserDefined, das zur Documents-Auflistung gehört.


DBEngine-Eigenschaft

Sie können die Eigenschaft DBEngine in Visual Basic verwenden, um auf das aktuelle DBEngine-Objekt sowie dessen zugehörige Eigenschaften zuzugreifen.

Einstellung

Die Eigenschaft DBEngine wird von Microsoft Access eingestellt und ist in allen Ansichten schreibgeschützt.

Anmerkung

Die Eigenschaft DBEngine des Objekts Application entspricht der Microsoft Jet-Datenbank-Engine. Das Objekt DBEngine ist im DAO-Modell (DAO = Data Access Objects) das oberste Objekt. Es enthält und steuert alle anderen Objekte, die Bestandteile der Hierarchie der Datenzugriffsobjekte sind.


 DecimalPlaces-Eigenschaft (Dezimalstellenanzeige)

DecimalPlaces-Eigenschaft (Dezimalstellenanzeige)

Sie können die Eigenschaft DecimalPlaces verwenden, um die Anzahl an Dezimalstellen anzugeben, die Microsoft Access zur Darstellung von Zahlen verwenden soll.

Einstellung

Die Eigenschaft DecimalPlaces verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Automatisch | 255 | (Voreinstellung) Zahlen werden so angezeigt, wie von der Eigenschaft Format angegeben.
0 bis 15 | 0 bis 15 | Ziffern rechts des Dezimaltrennzeichens werden mit der angegebenen Anzahl an Dezimalstellen angezeigt; Ziffern links des Dezimaltrennzeichens werden so angezeigt, wie von der Eigenschaft Format angegeben.

Sie können diese Eigenschaft für Textfelder und Kombinationsfelder mit Hilfe des Eigenschaftenfensters des Steuerelements und für Tabellenfelder mit Hilfe des Eigenschaftenfensters der Tabelle einstellen. Sie können diese Eigenschaft auch im Eigenschaftenfenster der Feldeigenschaften in der Abfrageentwurfsansicht einstellen.

Tipp Sie sollten die Eigenschaft DecimalPlaces im Eigenschaftenfenster der Tabelle einstellen. Ein gebundenes Steuerelement, das Sie in einem Formular oder einem Bericht erstellen, übernimmt die Einstellung der Eigenschaft DecimalPlaces aus dem Feld der zugrunde liegenden Tabelle oder Abfrage, so dass Sie die Eigenschaft nicht für jedes gebundene Steuerelement, das Sie neu erstellen, angeben müssen.

Für Steuerelemente können Sie diese Eigenschaft auch mit Hilfe eines Makros oder in Visual Basic einstellen.

Die Einstellung der Eigenschaft DecimalPlaces hat keine Auswirkungen, wenn die Eigenschaft Format keine Einstellung aufweist oder auf Allgemeine Zahl eingestellt ist.

Anmerkung

Die Eigenschaft DecimalPlaces betrifft nur die Anzahl der angezeigten Dezimalstellen, nicht die Anzahl der gespeicherten Dezimalstellen. Sie können die Art der Speicherung für eine Zahl mit der Eigenschaft Feldgröße in der Tabellenentwurfsansicht ändern.

Mit der Eigenschaft DecimalPlaces können Sie ein Anzeigeformat für Zahlen angeben, das von der Einstellung der Eigenschaft Format oder der gespeicherten Form abweicht. So zeigt z. B. die Einstellung Währung der Eigenschaft Format nur zwei Dezimalstellen an (5,35 DM). Sie können Währungsbeträge mit vier Dezimalstellen anzeigen (z. B. 5,3523 DM), indem Sie die Eigenschaft DecimalPlaces auf den Wert 4 einstellen.


 Default-Eigenschaft (Standard)

Default-Eigenschaft (Standard)

Mit der Eigenschaft Default können Sie angeben, ob eine Befehlsschaltfläche die Standardschaltfläche eines Formulars sein soll.

Einstellung

Die Eigenschaft Default kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Befehlsschaltfläche ist die Standardschaltfläche.
Nein | False (0) | (Standardeinstellung) Die Befehlsschaltfläche ist nicht die Standardschaltfläche.

Sie können diese Eigenschaft im Eigenschaftenfenster der Befehlsschaltfläche, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Ist die Eigenschaft Default der Befehlsschaltfläche auf Ja eingestellt und ist das Formularfenster aktiv, kann der Benutzer die Befehlsschaltfläche wählen, indem er die EINGABETASTE drückt (falls keine andere Befehlsschaltfläche den Fokus hat) oder indem er auf diese Befehlsschaltfläche klickt.

Nur eine Befehlsschaltfläche eines Formulars kann die Standardschaltfläche sein. Ist die Eigenschaft Default für eine Befehlsschaltfläche auf Ja eingestellt, wird sie automatisch für alle anderen Befehlsschaltflächen des Formulars auf Nein eingestellt.

Tipp In Formularen, die unwiderrufliche Operationen (z. B. das Löschen von Daten) unterstützen, sollte die Schaltfläche Abbrechen die Standard-Befehlsschaltfläche sein. Dazu stellen Sie die Eigenschaften Default und Cancel auf Ja ein.


 DefaultValue-Eigenschaft (Standardwert)

DefaultValue-Eigenschaft (Standardwert)

Mit der Eigenschaft DefaultValue können Sie einen Wert angeben, der automatisch in ein Feld eingetragen wird, wenn ein neuer Datensatz erstellt wird. Beispielsweise können Sie in einer Tabelle Adressen den Standardwert für das Feld Ort auf Seeheim einstellen. Tragen die Benutzer der Tabelle einen neuen Datensatz in die Tabelle ein, so können sie diesen Standardwert übernehmen oder den Namen eines anderen Ortes eingeben.

Anmerkungen

  • Die Eigenschaft DefaultValue gilt nicht für Kontrollkästchen-, Optionsfeld- und Umschaltfläche-Steuerelemente, die sich in einer Optionsgruppe befinden. Sie gelten nur für die Optionsgruppe selbst.

  • Die Eigenschaft DefaultValue gilt für alle Tabellenfelder, außer für solche mit dem Datentyp AutoWert und OLE-Objekt.

Einstellung

Die Eigenschaft DefaultValue gibt einen Text oder Ausdruck an, der beim Erstellen eines neuen Datensatzes automatisch in ein Feld eingetragen wird. Stellen Sie z.B. die Eigenschaft DefaultValue für ein Textfeld-Steuerelement auf = Jetzt() ein, so zeigt das Steuerelement das aktuelle Datum und die aktuelle Uhrzeit an. Der Wert der Eigenschaft DefaultValue kann maximal 255 Zeichen lang sein.

Für ein Steuerelement können Sie die Eigenschaft DefaultValue im Eigenschaftenfenster des Steuerelements einstellen. Für ein Feld können Sie diese Eigenschaft in der Tabellenentwurfsansicht (unter Feldeigenschaften), in einem Makro oder in Visual Basic einstellen.

Verwenden Sie in Visual Basic einen Zeichenfolgenausdruck, um den Wert dieser Eigenschaft einzustellen. Beispielsweise stellt die folgende Codezeile die Eigenschaft DefaultValue für das Textfeld-Steuerelement Zahlungsmethode auf "Bar" ein.

Formulare!frmRechnung!Zahlungsart!.DefaultValue = """Bar"""

Anmerkung Wenn Sie diese Eigenschaft für ein Feld mit Visual Basic einstellen möchten, verwenden Sie die ADO-Eigenschaft DefaultValue oder die DAO-Eigenschaft DefaultValue.

Anmerkung

Die Eigenschaft DefaultValue wird nur angewendet, wenn Sie einen neuen Datensatz erstellen. Wenn Sie die Eigenschaft DefaultValue ändern, wird die Änderung nicht automatisch für bestehende Datensätze übernommen.

Wenn Sie die Eigenschaft DefaultValue eines Formular-Steuerelements, in einem Formular für ein Feld einstellen, für das auch in der Tabelle eine Einstellung für die Eigenschaft DefaultValue besteht, hat die Steuerelementeinstellung Vorrang vor der Einstellung in der Tabelle.

Erstellen Sie ein Steuerelement durch Ziehen eines Feldes aus der Feldliste, so wird die in der Tabelle definierte Einstellung der Eigenschaft DefaultValue des Feldes auf das Steuerelement im Formular angewendet. Hierbei bleibt die Einstellung der Eigenschaft DefaultValue des Steuerelements jedoch leer.

Ein Steuerelement kann den Standardwert für ein anderes Steuerelement bereitstellen. Wenn Sie z.B. die Eigenschaft DefaultValue für ein Steuerelement auf den folgenden Ausdruck einstellen, wird der Standardwert des Feldes auf die Einstellung der Eigenschaft DefaultValue für das Steuerelement txtAusliefernAn eingestellt.

=Formulare![frmRechnung]!txtAusliefernAn

Befinden sich die Steuerelemente in demselben Formular, so muss das Steuerelement, das die Herkunft des Standardwerts darstellt, weiter vorne in der Reihenfolge der Steuerelemente angezeigt werden als das Steuerelement, das den Ausdruck enthält.


 DefaultView-, ViewsAllowed-Eigenschaften (Standardansicht, ZugelasseneAnsicht(en))

DefaultView-, ViewsAllowed-Eigenschaften (Standardansicht, ZugelasseneAnsicht(en))

  • Sie können die Eigenschaft DefaultView zur Angabe der Startansicht eines Formulars verwenden.

  • Mit der Eigenschaft ViewsAllowed können Sie angeben, ob ein Benutzer dadurch zwischen der Datenblattansicht und der Formularansicht wechseln kann, dass er entweder im Menü Ansicht auf Formularansicht bzw. Datenblattansicht oder auf den Pfeil rechts neben der Schaltfläche Ansicht und anschließend auf Formularansicht bzw. Datenblattansicht klickt.

Einstellung

Die Eigenschaft DefaultView kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Einzelnes Formular | 0 | (Standardeinstellung) Zeigt jeweils einen Datensatz an.
Endlosformular | 1 | Zeigt so viele Datensätze an, wie in das aktuelle Fenster passen, jeweils in einer eigenen Kopie des Detailbereichs des Formulars.
Datenblatt | 2 | Zeigt die Felder des Formulars in Zeilen und Spalten an, wie in einem Tabellenblatt.

Die Eigenschaft ViewsAllowed kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Beide | 0 | (Standardeinstellung) Die Benutzer können zwischen Formularansicht und Datenblattansicht wechseln.
Formular | 1 | Die Benutzer können aus der Formularansicht nicht zur Datenblattansicht wechseln.
Datenblatt | 2 | Die Benutzer können aus der Datenblattansicht nicht zur Formularansicht wechseln.

Die Entwurfsansicht ist immer verfügbar (es sei denn, die Berechtigungen sind anders eingestellt).

Sie können diese Eigenschaften im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Welche Ansichten in der Liste der Schaltfläche Ansicht sowie im Menü Ansicht angezeigt werden, hängt von der Einstellung der Eigenschaft ViewsAllowed ab. Ist die Eigenschaft ViewsAllowed z. B. auf Datenblatt eingestellt, ist Formularansicht sowohl in der Liste der Schaltfläche Ansicht als auch im Menü Ansicht deaktiviert.

Durch Kombination dieser Eigenschaften sind folgende Zustände möglich.

DefaultView | ViewsAllowed | Beschreibung
Einzelnes Formular, Endlosformular oder Datenblatt | Beide | Benutzer können zwischen Formularansicht und Datenblattansicht wechseln.
Einzelne Formulare oder Endlosformulare | Formular | Benutzer können von der Formularansicht nicht zur Datenblattansicht wechseln.
Einzelne Formulare oder Endlosformulare | Datenblatt | Benutzer können von der Formularansicht zur Datenblattansicht, aber nicht wieder zurück wechseln.
Datenblatt | Formular | Benutzer können von der Datenblattansicht zur Formularansicht, jedoch nicht wieder zurück wechseln.
Datenblatt | Datenblatt | Benutzer können nicht von der Datenblattansicht zur Formularansicht wechseln.


DefaultWebOptions-Eigenschaft

Mit der DefaultWebOptions-Eigenschaft können Sie auf das DefaultWebOptions-Objekt und dessen zugehörige Eigenschaften verweisen.

Einstellung

Die DefaultWebOptions-Eigenschaft ist in Visual Basic verfügbar.

Anmerkung

Verwenden Sie die Eigenschaft DefaultWebOptions, um die DefaultWebOptions-Objekteigenschaften des Application-Objekts zu identifizieren oder einzustellen. Mit diesen Eigenschaften können Sie die im Dialogfeld Weboptionen verfügbaren Standardwebseiteneinstellungen festlegen oder ändern. Zum Anzeigen dieses Dialogfeldes klicken Sie im Menü Extras auf Optionen. Klicken Sie auf die Registerkarte Allgemein und dann auf die Schaltfläche Weboptionen.


 Description-Eigenschaft (Beschreibung)

Description-Eigenschaft (Beschreibung)

Sie können die Eigenschaft Description verwenden, um Informationen über im Datenbankfenster enthaltene Objekte sowie über einzelne Tabellen- oder Abfragefelder bereitzustellen.

Einstellung

Wählen Sie für ein Datenbankobjekt aus dem Menü Ansicht den Befehl Eigenschaften, und geben Sie den beschreibenden Text in das Feld Beschreibung ein. Für Tabellen und Abfragen können Sie auch die Beschreibung im Eigenschaftenfenster der Tabelle oder Abfrage eingeben. Eine Beschreibung des Objekts wird neben dem Namen des Objekts im Datenbankfenster angezeigt, wenn Sie im Menü Ansicht auf Details klicken.

Geben Sie für einzelne Tabellen- oder Abfragefelder die Feldbeschreibung im oberen Bereich der Tabellenentwurfsansicht oder im Eigenschaftenfenster der Feldeigenschaften im Abfragefenster ein. Die maximale Länge beträgt 255 Zeichen.

Um in Visual Basic diese Eigenschaft erstmals in einem Microsoft Access-Projekt (.adp) einzustellen, müssen Sie eine anwendungsdefinierte Eigenschaft mit Hilfe der Add-Methode erstellen. In einer Microsoft Access-Datenbank (.mdb) müssen Sie die DAO-Methode CreateProperty verwenden.

Anmerkung

Die Beschreibung eines Objekts wird in der Spalte Beschreibung in der Detailansicht des Datenbankfensters angezeigt.

Wenn Sie Steuerelemente erstellen, indem Sie ein Feld aus der Feldliste ziehen, kopiert Microsoft Access die Eigenschaft Description des Feldes in die Eigenschaft StatusBarText des Steuerelements.

Anmerkung Bei einer verknüpften Tabelle zeigt Microsoft Access die Verbindungsinformationen in der Eigenschaft Description an.


 DestConnectStr-, DestinationDB-, DestinationTable-Eigenschaften (Zielverbindung, Zieldatenbank, Zieltabelle)

DestConnectStr-, DestinationDB-, DestinationTable-Eigenschaften (Zielverbindung, Zieldatenbank, Zieltabelle)

  • Die Eigenschaft DestinationDB gibt den Typ der Anwendung an, der zum Erstellen einer externen Datenbank verwendet wird

  • Die Eigenschaft DestConnectStr gibt die Verbindungszeichenfolge für den Namen der Datenbank an, die die neue Tabelle enthält (für Tabellenerstellungsabfragen), oder für den Namen der Datenbank, die die Tabelle enthält, an die Daten angefügt werden (für Anfügeanfragen).

  • Mit der Eigenschaft DestinationTable wird der Name der Tabelle angegeben, die die Daten der Tabellenerstellungsabfrage oder Anfügeanfrage aufnimmt.

Anmerkung Die Eigenschaften DestConnectStr, DestinationDB und DestinationTable gelten nur für Tabellenerstellungs- und Anfügeabfragen.

Einstellung

Sie stellen die Eigenschaften DestConnectStr, DestinationDB und DestinationTable mit Hilfe eines Zeichenfolgenausdrucks ein.

Die Standardeinstellung für die Eigenschaft DestinationDB lautet "(aktuell)", d.h. sie verweist auf die momentan aktive Datenbank.

Sie können diese Eigenschaften im Abfrage-Eigenschaftenfenster, oder in der SQL-Ansicht des Abfragefensters einstellen.

In der SQL-Anweisung für eine Anfügeabfrage entspricht der Tabellenname in der Anweisung INSERT INTO der Einstellung der Eigenschaft DestinationTable. Die IN-Klausel entspricht den Einstellungen der Eigenschaften DestinationDB und DestConnectStr.

In der SQL-Anweisung für eine Tabellenerstellungsabfrage entspricht der Tabellenname in der INTO-Klausel der Einstellung der Eigenschaft DestinationTable. Die IN-Klausel entspricht den Einstellungen der Eigenschaften DestinationDB und DestConnectStr.

Anmerkung Microsoft Access stellt diese Eigenschaften automatisch aufgrund der von Ihnen im Abfrage-Eigenschaftenfenster oder in der SQL-Ansicht des Abfragefensters eingegebenen Informationen ein.

Anmerkung

Wenn Sie im Menü Abfrage den Befehl Neue Tabelle erstellen oder Anfügen wählen, fordert Microsoft Access Sie auf, die nötigen Informationen zum Einstellen dieser Eigenschaften einzugeben. Microsoft Access verwendet den von Ihnen im Feld Tabellenname eingegebenen Wert zur Einstellung der Eigenschaft DestinationTable und die von Ihnen im Feld Dateiname eingegebenen Informationen zur Einstellung der Eigenschaften DestConnectStr und DestinationDB.

Sie verwenden das Eigenschaftenfenster, um eine Tabelle in einer Microsoft Access-Datenbank anzugeben, indem Sie den Namen der Tabelle (z.B. Klienten) im Feld Zieltabelle eingeben. Im Feld Zieldatenbank geben Sie den Pfad und Datenbanknamen ohne Dateinamenerweiterung ein (z.B. C:\KONTEN\KUNDEN). Microsoft Access fügt die Erweiterung automatisch hinzu. Sie müssen die Eigenschaft DestConnectStr nicht einstellen.

Sie geben eine Tabelle in einer mit einem anderen Produkt, z.B. Paradox, erstellten Datenbank an, indem Sie den Namen der Tabelle im Feld Zieltabelle eingeben. Im Feld Zieldatenbank geben Sie den Pfad ein (z.B. C:\PARADOX\DATEN). Im Feld Zielverbindung geben Sie den Kennzeichner für den Datenbanktyp ein (z.B. Paradox 3.x). Eine Liste der Kennzeichner finden unter der Beschreibung der ADO-Eigenschaft Connect.

Sie geben eine ODBC-Datenbank (ODBC = Open Database Connectivity) an, indem Sie den Namen der Datenbank im Feld Zielverbindung zusammen mit weiteren vom Produkt benötigten Informationen, z.B. Anmeldeinformationen (ID) und Kennwort, eingeben. Sie können z.B. die folgende Einstellung für eine Microsoft SQL Server-Datenbank verwenden:

ODBC;DSN=PowerNet;UID=AndyK;PWD=Kennwort;DATABASE=Umsatz;

Weitere Informationen zu ODBC-Treibern wie Microsoft SQL Server finden Sie in der vom Treiber bereitgestellten Hilfe.

Sie müssen die Eigenschaft DestinationDB für ODBC-Datenbanken nicht einstellen.

Weitere Informationen über den Zugriff auf Daten in ODBC-Datenbanken finden Sie in Kapitel 15, "Empfangen und Analysieren von Daten" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Programmierhandbuch beziehen können, klicken Sie auf [image] .


Dir-Eigenschaft (Datenzugriffsseite)

Sprachspezifische Informationen

You can use the Dir property to specify or determine the view orientation for information within a control for language-specific displays.

Setting

The Dir property uses the following settings.

Setting | Description
ltr | Sets the control's text direction to left to right.
rtl | Sets the control's text direction to right to left.

Remarks

The Dir property directly influences how information in controls is displayed.


 Dirty-Eigenschaft (Geändert)

Dirty-Eigenschaft (Geändert)

Mit der Eigenschaft Dirty können Sie feststellen, ob der aktuelle Datensatz seit dem letzten Speichern verändert worden ist. Sie können den Benutzer z. B. fragen, ob Veränderungen an einem Datensatz beabsichtigt sind, und andernfalls zulassen, dass der Benutzer ohne Speichern der Änderungen zum nächsten Datensatz wechseln kann.

Einstellung

Die Eigenschaft Dirty verfügt über die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
True | True (-1) | Der aktuelle Datensatz wurde verändert.
False | False (0) | Der aktuelle Datensatz wurde nicht verändert.

Diese Eigenschaft ist nur in der Formularansicht und der Datenblattansicht verfügbar.

Diese Eigenschaft ist schreibgeschützt und nur in einem Makro oder in Visual Basic verfügbar.

Anmerkung

Wird ein Datensatz gespeichert, so wird die Eigenschaft Dirty automatisch auf False gesetzt. Nimmt ein Benutzer Änderungen an einem Datensatz vor, so wird die Eigenschaft auf True gesetzt.


 DisplayControl-Eigenschaft (SteuerelementAnzeigen)

DisplayControl-Eigenschaft (SteuerelementAnzeigen)

Mit der Eigenschaft DisplayControl können Sie in der Tabellenentwurfsansicht das Standard-Steuerelement

Einstellung

Sie können diese Eigenschaft im Eigenschaftenfenster der Tabelle in der Tabellenentwurfsansicht einstellen, indem Sie unter Feldeigenschaften auf die Registerkarte Nachschlagen klicken.

Die Eigenschaft enthält eine Dropdownliste, welche die verfügbaren Steuerelemente für das ausgewählte Feld enthält. Für Felder des Datentyps Text oder Zahl kann diese Eigenschaft auf Textfeld, Listenfeld oder Kombinationsfeld eingestellt werden. Für Felder des Datentyps Ja/Nein kann die Eigenschaft auf Kontrollkästchen, Textfeld oder Kombinationsfeld eingestellt werden.

Anmerkung

Wenn Sie ein Steuerelement für diese Eigenschaft auswählen, werden alle zusätzlichen Eigenschaften, die zur Konfiguration des Steuerelements benötigt werden, ebenfalls in der Registerkarte Nachschlagen angezeigt.

Tipp Wenn Sie den Nachschlage-Assistenten verwenden, stellt Microsoft Access die Eigenschaft DisplayControl und alle damit verbundenen Eigenschaften für Sie ein.

Das Einstellen dieser Eigenschaft und aller damit verbundenen Eigenschaften von Steuerelementtypen wirkt sich auf die Feldanzeige sowohl in der Datenblattansicht als auch in der Formularansicht aus. Das Feld wird mit den in der Tabellenentwurfsansicht festgelegten Einstellungen für Steuerelemente und Steuerelementeigenschaften angezeigt. Falls die Eigenschaft DisplayControl für ein Feld in der Tabellenentwurfsansicht eingestellt wurde, und Sie es in der Formularentwurfsansicht aus der Feldliste ziehen, kopiert Microsoft Access die entsprechenden Eigenschaften in das Eigenschaftenfenster des Steuerelements.


 DisplayType-Eigenschaft (Anzeigeart)

DisplayType-Eigenschaft (Anzeigeart)

Sie können die Eigenschaft DisplayType verwenden, um anzugeben, ob Microsoft Access den Inhalt eines OLE-Objekts oder ein Symbol anzeigt. Ist das OLE-Objekt z. B. ein Microsoft Word-Dokument, und Sie stellen diese Eigenschaft auf Inhalt ein, zeigt das Steuerelement das Word-Dokument an; stellen Sie diese Eigenschaft auf Symbol ein, zeigt das Steuerelement das Microsoft Word-Symbol an.

Einstellung

Die Eigenschaft DisplayType verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Inhalt | acOLEDisplayContent (0) | (Standardeinstellung) Wenn das Steuerelement ein OLE-Objekt enthält, zeigt es die Daten des Objekts an, wie z. B. ein Dokument oder eine Kalkulationstabelle.
Symbol | acOLEDisplayIcon (1) | Wenn das Steuerelement ein OLE-Objekt enthält, zeigt es das Symbol des Objekts an.

Die Eigenschaft DisplayType können Sie in einem Eigenschaftenfenster, in einem Makro oder mit Visual Basic einstellen. Die Standardeinstellung dieser Eigenschaft können Sie in den Standardeigenschafteneinstellungen eines Steuerelements oder mit Hilfe der Methode DefaultControl in Visual Basic festlegen.

Für ein gebundenes Objektfeld kann die Eigenschaft DisplayType nur in der Entwurfsansicht eingestellt, jedoch in allen Ansichten gelesen werden. Für ein ungebundenes Objektfeld oder ein Diagramm kann die Eigenschaft im Dialogfeld Objekt einfügen eingestellt werden, wenn das Objekt erstellt wird (die Standardeinstellung lautet Inhalt oder, wenn Sie das Kontrollkästchen Als Symbol darstellen aktiviert haben, Symbol).

Anmerkung

Die Eigenschaft DisplayType legt die Standardeinstellung des Kontrollkästchens Als Symbol darstellen in den Dialogfeldern Inhalte einfügen und Objekt einfügen fest. Das Dialogfeld Inhalte einfügen wird angezeigt, wenn Sie im Menü Bearbeiten auf Inhalte einfügen klicken. Das Dialogfeld Objekt einfügen wird angezeigt, wenn Sie ein ungebundenes Objektfeld einfügen. Wenn Sie diese Dialogfelder entweder in der Formularansicht, der Datenblattansicht oder der Entwurfsansicht anzeigen, wird das Kontrollkästchen Als Symbol darstellen automatisch aktiviert, sofern die Eigenschaft DisplayType auf Symbol eingestellt ist. Diese Kästchen sind z. B. aktiviert, wenn Sie mit Visual Basic die Eigenschaft Action des Steuerelements auf acOLEInsertObjDlg oder acOLEPasteSpecialDlg einstellen.

Die Einstellung der Eigenschaft DisplayType hat keine Auswirkung auf den Zustand des Kontrollkästchens Als Symbol darstellen im Dialogfeld Objekt, wenn Sie ein Objekt in ein ungebundenes Objektfeld einfügen. Fügen Sie ein Objekt aus der Zwischenablage ein, spiegelt das Kontrollkästchen Als Symbol darstellen den Zustand des Objekts in der Zwischenablage wider.

Wenn Sie die Einstellung der Eigenschaft DisplayType für ein gebundenes Objektfeld ändern, hat dies keine Auswirkung auf die Anzeige vorhandener Objekte im Steuerelement. Die Änderungen wirken sich jedoch auf neue Objekte aus, die Sie zu dem Steuerelement hinzufügen, indem Sie aus dem Menü Einfügen den Befehl Objekt verwenden.


 DisplayWhen-Eigenschaft (Anzeigen)

DisplayWhen-Eigenschaft (Anzeigen)

Mit der Eigenschaft DisplayWhen können Sie angeben, welche Bereiche oder Steuerelemente eines Formulars auf dem Bildschirm angezeigt oder gedruckt werden sollen.

Anmerkung Die Eigenschaft DisplayWhen gilt nur für die folgenden Formularbereiche: Detail, Formularkopf und Formularfuß. Sie gilt auch für alle Steuerelemente (außer Seitenwechsel) in einem Formular.

Einstellung

Die Eigenschaft DisplayWhen verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Immer | 0 | (Standardeinstellung) Das Objekt wird in der Formularansicht und im Ausdruck angezeigt.
Nur beim Drucken | 1 | Das Objekt wird in der Formularansicht ausgeblendet, erscheint jedoch im Ausdruck.
Nur am Bildschirm | 2 | Das Objekt wird in der Formularansicht angezeigt, jedoch nicht im Ausdruck.

Sie können die Eigenschaft DisplayWhen im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

Für Steuerelemente können Sie die Standardeinstellung dieser Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

In vielen Fällen erweisen sich bestimmte Steuerelemente nur in der Formularansicht als hilfreich. Damit Microsoft Access diese Steuerelemente nicht ausdruckt, können Sie deren Eigenschaft DisplayWhen auf Nur am Bildschirm einstellen. Beispielsweise kann ein Formular eine Befehlsschaltfläche oder Anweisungen enthalten, die Sie nicht drucken möchten, oder es gibt Formularkopf- und Formularfuß-Bereiche, die nicht am Bildschirm angezeigt, jedoch gedruckt werden sollen. Stellen Sie in diesem Fall die Eigenschaft DisplayWhen auf Nur beim Drucken ein.

Tipp Verwenden Sie für Berichte die Ereignisse Format und Retreat, um eine Ereignisprozedur oder ein Makro anzugeben, die/das die Eigenschaft Visible derjenigen Steuerelemente einstellt, die nicht gedruckt werden sollen. Weiterhin können Sie für einen Berichtsbereich die Ereignisse Format oder Print abbrechen, damit dieser Bereich nicht gedruckt wird.


 DividingLines-Eigenschaft (Trennlinien)

DividingLines-Eigenschaft (Trennlinien)

Sie können mit der Eigenschaft DividingLines angeben, ob die Bereiche eines Formulars oder die Datensätze, die in einem Endlosformular angezeigt werden, durch Trennlinien voneinander getrennt werden sollen.

Einstellung

Die Eigenschaft DividingLines verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Trennlinien unterteilen Bereiche und Datensätze in Endlosformularen.
Nein | False (0) | Es werden keine Trennlinien verwendet.

Sie können die Eigenschaft DividingLines im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann in allen Ansichten eingestellt werden.


DoCmd-Eigenschaft

Sie können die DoCmd-Eigenschaft verwenden, um auf das DoCmd-Objekt und die zugehörigen Methoden zuzugreifen.

Einstellung

Diese Eigenschaft steht nur in Visual Basic zur Verfügung


Document-Eigenschaft

Mit Hilfe der Document-Eigenschaft können Sie auf das Document-Objekt von Microsoft Internet Explorer 5.0 Dynamic HTML für HTML-Seiten zugreifen.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Weitere Informationen über DHTML und das Document-Objektmodell finden Sie unter den folgenden Themen:

DHTML-Lernprogramm

Document-Objektmodell

Document-ObjektrReferenzen


 DownloadComponents-Eigenschaft

DownloadComponents-Eigenschaft

Mit der DownloadComponents-Eigenschaft können Sie angeben oder ermitteln, ob die Microsoft Office-Tools automatisch beim Anzeigen der Webseite gedownloadet werden.

Einstellung

Die DownloadComponents-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die erforderlichen Office-Steuerelemente werden gedownloadet, wenn Sie das gespeicherte Dokument in einem Webbrowser anzeigen.
Nein | False (0) | (Standard) Die Steuerelemente werden nicht gedownloadet.

Die DownloadComponents-Eigenschaft steht nur in Visual Basic zur Verfügung

Anmerkung

Sie können die LocationOfComponents-Eigenschaft auf einen zentralen URL einstellen, von wo autorisierte Benutzer die Steuerelemente beim Anzeigen Ihrer gespeicherten Datenzugriffsseite downloaden können. Der Pfad muss gültig sein und auf einen Speicherort verweisen, der die erforderlichen Komponenten enthält. Außerdem muss der Benutzer über eine gültige Microsoft Office 2000-Lizenz verfügen.

Durch die Office-Webkomponenten werden Datenzugriffsseiten, die Sie als Webseiten gespeichert haben, um interaktive Funktionen erweitert. Wenn Sie eine solche Webseite im Browser auf einem Computer anzeigen, auf dem diese Komponenten nicht installiert sind, bleiben die interaktiven Elemente der Seite statisch.


 DrawMode-Eigenschaft

DrawMode-Eigenschaft

Mit der Eigenschaft DrawMode können Sie angeben, wie sich der Stift (die beim Zeichnen verwendete Farbe) auf vorhandene Hintergrundfarben in einem Bericht auswirkt, wenn eine der Methoden Line, Circle oder PSet zum Zeichnen in einem Bericht verwendet wird.

Einstellung

Die Eigenschaft DrawMode hat folgende Einstellungen.

Einstellung | Beschreibung
1 | Schwarzer Stift.
2 | Umkehrung von Einstellung 15 (Nicht-Stift-Mischen, NotMergePen).
3 | Kombination der Farben, die die Hintergrundfarbe und die Umkehrung der Stiftfarbe gemeinsam haben (Maskieren-Nicht-Stift, MaskNotPen).
4 | Umkehrung von Einstellung 13 (Nicht-Stift-Kopieren, NotCopyPen).
5 | Kombination der Farben, die der Stift und die Umkehrung des Bildschirms gemeinsam haben (Stift-Maskieren-Nicht, MaskPenNot).
6 | Umkehrung der Bildschirmfarbe (Invers, Invert).
7 | Kombination der Farben des Stifts und des Bildschirms, die beide nicht gemeinsam haben (Stift-Xor, XorPen).
8 | Umkehrung von Einstellung 9 (Nicht-Stift-Maskieren, NotMaskPen).
9 | Kombination der Farben, die Stift und Bildschirm gemeinsam haben (Stift-Maskieren, MaskPen).
10 | Umkehrung von Einstellung 7 (Nicht-Stift-Xor, NotXorPen).
11 | Keine Operation - die Ausgabe wird nicht verändert. Diese Einstellung deaktiviert den Zeichenmodus (Keine-Operation, Nop).
12 | Kombination der Bildschirmfarbe und der Umkehrung der Stiftfarbe (Mischen-Nicht-Stift, MergeNotPen).
13 | (Standardeinstellung) Die mit der Eigenschaft ForeColor festgelegte Farbe (Stift-Kopieren, CopyPen).
14 | Kombination der Stiftfarbe und der Umkehrung der Bildschirmfarbe (Stift-Mischen-Nicht, MergePenNot).
15 | Kombination der Stiftfarbe und der Bildschirmfarbe (Stift-Mischen, MergePen).
16 | Weißer Stift.

Die Einstellung der Eigenschaft DrawMode ist ein Wert vom Typ Integer.

Sie können die Eigenschaft DrawMode in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Verwenden Sie diese Eigenschaft, um beim Zeichnen in einem Bericht optische Effekte zu erzielen. Microsoft Access vergleicht jedes Pixel im Zeichenmuster mit dem entsprechenden Pixel im vorhandenen Hintergrund, um festzustellen, wie die Zeichnung im Bericht ausgegeben wird. Beispielsweise verwendet Einstellung 7 den Operator Xor, um ein Zeichenmuster-Pixel mit einem Hintergrund-Pixel zu kombinieren.


 DrawStyle-Eigenschaft

DrawStyle-Eigenschaft

Sie können die Eigenschaft DrawStyle verwenden, um die Linienart für die Methoden Line und Circle zu definieren, wenn Sie Linien in Berichten ausgeben möchten.

Einstellung

Die Eigenschaft DrawStyle verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
0 | (Standardeinstellung) Durchgezogen, innen transparent
1 | Gestrichelt, innen transparent
2 | Gepunktet, innen transparent
3 | Strichlinie Punkt, innen transparent
4 | Strichlinie Punkt Punkt, innen transparent
5 | Unsichtbare Linie, innen transparent
6 | Unsichtbare Linie, innen durchgezogen

Die Einstellung der Eigenschaft DrawStyle ist ein Wert vom Typ Integer.

Sie können diese Eigenschaft in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Die Eigenschaft DrawStyle erzielt die oben beschriebenen Ergebnisse, wenn Sie für die Eigenschaft DrawWidth den Wert 1 einstellen. Wenn für die Eigenschaft DrawWidth ein größerer Wert als 3 eingestellt ist, erzeugen die Einstellungen 1 bis 4 der Eigenschaft DrawStyle eine durchgezogene Linie (der Wert der Eigenschaft DrawStyle wird nicht verändert).


 DrawWidth-Eigenschaft

DrawWidth-Eigenschaft

Sie können die Eigenschaft DrawWidth verwenden, um die Linienbreite für die Methoden Line, Circle und PSet einzustellen, wenn Sie Linien in Berichten ausgeben möchten.

Einstellung

Sie können für die Eigenschaft DrawWidth einen Wert vom Typ Integer im Bereich von 1 bis 32.767 einstellen. Dieser Wert gibt die Linienbreite in Pixeln an. Die Standardeinstellung ist 1, d. h. eine Breite von 1 Pixel.

Sie können diese Eigenschaft in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Erhöhen Sie den Wert für diese Einstellung, um die Linienbreite zu vergrößern. Wenn für die Eigenschaft DrawWidth ein größerer Wert als 3 eingestellt ist, erzeugen die Einstellungen 1 bis 4 der Eigenschaft DrawStyle eine durchgezogene Linie (der Wert der Eigenschaft DrawStyle wird nicht verändert). Wenn Sie für die Eigenschaft DrawWidth den Wert 1 einstellen, können Sie die in der Tabelle der Eigenschaft DrawStyle beschriebenen Ergebnisse erzielen.


 EmailSubject-Eigenschaft

EmailSubject-Eigenschaft

Mit der EmailSubject-Eigenschaft können Sie die E-Mail-Betreffzeile eines Hyperlinks zu einem Objekt, einem Dokument, einer Webseite oder einem anderen Ziel für eine Befehlsschaltfläche, ein Bild-Steuerelement oder ein Bezeichnung-Steuerelement zurückgeben.

Einstellung

Die EmailSubject-Eigenschaft ist ein Zeichenfolgenausdruck, der die Betreffzeile in einer Datei (UNC-Pfad) oder auf einer Webseite (URL) darstellt.

Sie können die EmailSubject-Eigenschaft mit einem Makro oder in Visual Basic einstellen.

Außerdem können Sie zum Einstellen dieser Eigenschaft das Dialogfeld Hyperlink einfügen verwenden. Sie öffnen dieses Dialogfeld durch Klicken auf die Aufbauen-Schaltfläche [image] rechts neben dem Einstellungsfeld der Eigenschaft im Eigenschaftenfenster.

Anmerkung Wenn Sie einen Hyperlink mit Hilfe des Dialogfeldes Hyperlink einfügen erstellen, stellt Microsoft Access die EmailSubject-Eigenschaft automatisch auf die im Feld Betreff der Registerkarte E-Mail-Adresse angegebene Position ein.

Anmerkung

Wenn Sie den Cursor über eine Befehlsschaltfläche, ein Bild-Steuerelement oder ein Bezeichnungsfeld-Steuerelement bewegen, deren/dessen HyperlinkAddress-Eigenschaft eingestellt ist, wird der Cursor zu einer nach oben zeigenden Hand. Durch Klicken auf das betreffende Steuerelement wird das durch den Link angegebene Objekt oder die Webseite angezeigt.

Um Objekte in der aktuellen Datenbank zu öffnen, lassen Sie die HyperlinkAddress-Eigenschaft unberücksichtigt, und geben Sie Typ und Namen des zu öffnenden Objekts in der HyperlinkSubAddress-Eigenschaft unter Verwendung der Syntax "Objekttyp Objektname" an. Wenn Sie ein Objekt öffnen möchten, das in einer anderen Microsoft Access-Datenbank enthalten ist, geben Sie den Datenbankpfad und Dateinamen in der HyperlinkAddress-Eigenschaft ein, und legen Sie das zu öffnende Datenbankobjekt mit Hilfe der HyperlinkSubAddress-Eigenschaft fest.

Die HyperlinkAddress-Eigenschaft kann einen absoluten oder einen relativen Pfad zu einem Zieldokument enthalten. Ein absoluter Pfad ist ein vollständiger URL oder UNC-Pfad zu einem Dokument. Ein relativer Pfad bezieht sich auf den Basispfad, der in der Einstellung Hyperlinkbasis im Dialogfeld Eigenschaften Datenbankname (zu öffnen durch Klicken auf Datenbankeigenschaften im Menü Datei) angegeben wird, oder auf den Pfad der aktuellen Datenbank. Wenn Microsoft Access die Einstellung der HyperlinkAddress-Eigenschaft nicht in einen gültigen URL oder UNC-Pfad auflösen kann, nimmt es an, dass Sie einen Pfad relativ zu dem in der Einstellung Hyperlinkbasis enthaltenen Basispfad oder zum aktuellen Datenbankpfad angegeben haben.

Anmerkung Wenn Sie einem Hyperlink zu einem anderen Microsoft Access-Datenbankobjekt folgen, werden die Starteigenschaften der Datenbank angewendet. Hat die Zieldatenbank z. B. einen Anzeigeformularsatz, wird dieses Formular beim Öffnen der Datenbank angezeigt.


 Enabled-, Locked-Eigenschaften (Aktiviert, Gesperrt)

Enabled-, Locked-Eigenschaften (Aktiviert, Gesperrt)

  • Die Eigenschaft Enabled gibt an, ob ein Steuerelement in der Formularansicht den Fokus haben kann.

  • Die Eigenschaft Locked gibt an, ob Sie Daten in einem Steuerelement in der Formularansicht bearbeiten können.

Einstellung

Die Eigenschaft Enabled verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Voreinstellung für alle Steuerelemente mit Ausnahme von ungebundenen Objektfeldern). Das Steuerelement kann den Fokus haben. Ist das Steuerelement ein ungebundenes Objektfeld, wird durch Doppelklicken auf dieses Objekt das Hauptverb des Steuerelements ausgeführt. Ungebundene Objektfelder können z. B. ein eingebettetes Klang-Objekt abspielen.
Nein | False (0) | (Voreinstellung für ungebundene Objektfelder) Das Steuerelement kann nicht über den Fokus verfügen und wird abgeblendet angezeigt. Ist das Steuerelement eine Optionsgruppe, so können weder die Optionsgruppe noch die darin enthaltenen Steuerelemente über den Fokus verfügen.

Die Eigenschaft Locked verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Voreinstellung für ungebundene Objektfelder) Das Steuerelement arbeitet normal, erlaubt jedoch kein Bearbeiten, Hinzufügen oder Löschen von Daten.
Nein | False (0) | (Voreinstellung für alle Steuerelemente mit Ausnahme von ungebundenen Objektfeldern) Das Steuerelement arbeitet normal und erlaubt das Bearbeiten, Hinzufügen und Löschen von Daten.

Sie können diese Eigenschaften im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Verwenden Sie die Eigenschaft Enabled, um Steuerelemente zu aktivieren und zu deaktivieren. In der Formularansicht z. B. können Sie eine Befehlsschaltfläche solange deaktivieren, bis Sie Daten in einem Textfeld-Steuerelement verändert haben. Dann können Sie das Ereignis AfterUpdate des Steuerelements verwenden, um eine Ereignisprozedur oder ein Makro zur Aktivierung der Befehlsschaltfläche aufzurufen.

Verwenden Sie die Eigenschaft Locked, um Daten in einem Feld zu schützen und es mit Schreibschutz zu versehen. Ein Steuerelement soll z. B. nur Informationen anzeigen, ohne das Bearbeiten zuzulassen, oder es soll gesperrt sein, bis eine bestimmte Bedingung erfüllt ist.

Sie können die Einstellungen der Eigenschaften Enabled und Locked kombinieren, um folgende Ergebnisse zu erzielen.

Enabled | Locked | Ergebnis
Ja | Ja | Das Steuerelement kann den Fokus haben. Daten werden normal angezeigt und können kopiert, aber nicht bearbeitet werden.
Ja | Nein | Das Steuerelement kann den Fokus haben. Daten werden normal angezeigt und können kopiert und bearbeitet werden
Nein | Ja | Das Steuerelement kann nicht den Fokus haben. Daten werden normal angezeigt, können aber nicht kopiert und bearbeitet werden.
Nein | Nein | Das Steuerelement kann nicht den Fokus haben. Steuerelement und Daten sind deaktiviert (abgeblendet).

Die Eigenschaft TabStop kann mit der Eigenschaft Enabled kombiniert werden, um das Auswählen einer Befehlsschaltfläche mit TAB zu unterbinden, während sie weiterhin durch Klicken ausgewählt werden kann. Die Einstellung der Eigenschaft TabStop auf Nein bedeutet, dass sich die Befehlsschaltfläche nicht in der Reihenfolge der Steuerelemente befindet. Dennoch können Sie, wenn die Eigenschaft Enabled auf Ja eingestellt ist, weiterhin auf die Befehlsschaltfläche klicken.

Damit Sie ein eingebettetes oder verknüpftes Objekt in einem ungebundenen Objektfeld bearbeiten können, müssen Sie die Eigenschaft Enabled des Objektfelds auf Ja und die Eigenschaft Locked auf Nein einstellen.


 Encoding-Eigenschaft

Encoding-Eigenschaft

Mit der Encoding-Eigenschaft können Sie die Codierung der Datenzugriffsseite (Zeichenumsetzungstabelle oder Zeichensatz) angeben oder ermitteln, die der Webbrowser beim Anzeigen der gespeicherten Datenzugriffsseite verwendet.

Einstellung

Die Encoding-Eigenschaft ist ein Wert vom Datentyp Long, der eine der MsoEncoding-Konstanten repräsentiert. Eine Liste der zulässigen MsoEncoding-Konstanten finden Sie im Objektkatalog im Microsoft Visual Basic-Editor.


 EnterKeyBehavior-Eigenschaft

EnterKeyBehavior-Eigenschaft

Mit der EnterKeyBehavior-Eigenschaft können Sie angeben, was geschieht, wenn die EINGABETASTE in einem Textfeld-Steuerelement in der Formularansicht oder der Datenblattansicht gedrückt wird. Diese Eigenschaft können Sie beispielsweise verwenden, wenn Sie in einer Tabelle ein Steuerelement an ein Memo-Feld gebunden haben, um die Eingabe von mehrzeiligem Text zu erleichtern. Wenn Sie diese Eigenschaft nicht auf Neue Zeile im Feld einstellen, müssen Sie STRG+EINGABE drücken, um eine neue Zeile im Textfeld einzugeben.

Einstellung

Die EnterKeyBehavior-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Standard | False (0) | (Standardeinstellung) Microsoft Access verwendet das unter Cursor mit Eingabetaste bewegen auf der Registerkarte Tastatur des Dialogfeldes Optionen angegebene Ergebnis. Zum Öffnen dieses Dialogfeldes klicken Sie im Menü Extras auf Optionen. Weitere Informationen finden Sie im Abschnitt "Anmerkung".
Neue Zeile im Feld | True (-1) | Durch das Drücken der EINGABETASTE im Steuerelement wird darin eine neue Zeile erstellt, so dass Sie weiteren Text eingeben können.

Sie können diese Eigenschaft im Eigenschaftenfenster eines Formulars, mit einem Makro oder in Visual Basic einstellen.

Die Standardeinstellung für diese Eigenschaft können Sie mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder mit der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Die folgenden Optionen sind unter Cursor mit Eingabetaste bewegen auf der Registerkarte Tastatur des Dialogfeldes Optionen verfügbar.

Option | Beschreibung
Nicht bewegen | Das Drücken der EINGABETASTE hat keine Wirkung.
Nächstes Feld | Durch das Drücken der EINGABETASTE wird die Einfügemarke zum nächsten Steuerelement oder Feld im Formular bzw. Datenblatt in der Reihenfolge der Steuerelemente bewegt.
Zum nächsten Datensatz bewegen | Durch das Drücken der EINGABETASTE wird die Einfügemarke zum ersten Steuerelement oder Feld im nächsten Datensatz des Formulars bzw. Datenblatts bewegt.


 Ereigniseigenschaften

Ereigniseigenschaften

Ereigniseigenschaften bewirken, dass ein Makro oder die zugeordnete Visual Basic-Ereignisprozedur ausgeführt werden, wenn ein bestimmtes Ereignis eintritt. Wenn Sie z. B. den Namen eines Makros in die Eigenschaft OnClick einer Befehlsschaltfläche eingeben, wird dieses Makro beim Klicken auf die Schaltfläche ausgeführt. Eine vollständige Liste der Ereigniseigenschaften finden Sie unter "Verzeichnis der Ereignisse und Ereigniseigenschaften".

Einstellung

Geben Sie zum Ausführen eines Makros dessen Namen ein. Sie können ein vorhandenes Makro in der Liste wählen. Wenn das Makro zu einer Makrogruppe gehört, wird es unter dem betreffenden Makrogruppennamen als Makrogruppenname.Makroname aufgeführt.

Um die einem bestimmten Ereignis zugeordnete Ereignisprozedur auszuführen, wählen Sie [Ereignisprozedur] in der Liste aus.

Anmerkung Obwohl die Verwendung einer Ereignisprozedur die empfohlene Methode zum Ausführen von Visual Basic-Code als Reaktion auf ein Ereignis ist, können Sie beim Eintreten eines Ereignisses auch eine benutzerdefinierte Funktion ausführen. Zum Ausführen einer benutzerdefinierten Funktion setzen Sie ein Gleichheitszeichen (=) vor den Funktionsnamen und hinter den Namen Klammern, wie in =Funktionsname( ).

Sie können Ereigniseigenschaften im Eigenschaftenfenster für ein Objekt, in einem Makro oder in Visual Basic einstellen. Beachten Sie, dass während des Formatierens oder Druckens eines Formulars oder Berichts keine Ereigniseigenschaften eingestellt werden können.

Tipp Als Hilfe beim Einstellen einer Ereigniseigenschaft können Sie Editoren verwenden. Um diese zu starten, klicken Sie auf die Aufbauen-Schaltfläche [image] rechts neben dem Einstellungsfeld der entsprechenden Eigenschaft, oder klicken Sie mit der rechten Maustaste auf dieses Feld, und klicken Sie dann im Kontextmenü auf Aufbauen. Wählen Sie im Dialogfeld Generator auswählen die folgenden Elemente aus:

  • Den Makro-Generator zum Erstellen und Angeben eines Makros für die betreffende Ereigniseigenschaft. Sie können den Makro-Generator auch verwenden, um ein durch die Eigenschaft bereits angegebenes Makro zu bearbeiten.

  • Den Code-Generator zum Erstellen und Angeben einer Ereignisprozedur für die betreffende Ereigniseigenschaft. Sie können den Code-Generator auch verwenden, um eine durch die Eigenschaft bereits angegebene Ereignisprozedur zu bearbeiten.

  • In einer Microsoft Access-Datenbank (.mdb) den Ausdrucks-Generator zum Wählen und Angeben einer benutzerdefinierten Funktion für die betreffende Ereigniseigenschaft.

Stellen Sie die Eigenschaft in Visual Basic auf einen Zeichenfolgenausdruck ein.

Ausführen von Erforderliche Syntax Beispiel
Makro "Makroname"
Button1.OnClick = "Makro1"
Ereignisprozedur "[Ereignisprozedur]"
Button1.OnClick = "[Ereignisprozedur]"
Benutzerdefinierte Funktion "=Funktionsname( )"
Button1.OnClick = "=Funktion1()"


 Error-Eigenschaft

Error-Eigenschaft

Mit der Error-Eigenschaft können Sie ermitteln, ob beim Laden oder Drucken eines Snapshots ein Fehler aufgetreten ist.

Einstellung

Die Einstellung der Error-Eigenschaft ist ein Wert des Datentyps Long, der den beim Versuch des Ladens einer Snapshot-Datei aufgetretenen Fehler darstellt.

Diese Eigenschaft ist nur in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Nachdem Sie einen Snapshot geladen haben, können Sie die Error-Eigenschaft überprüfen, um zu ermitteln, ob Fehler aufgetreten sind. Wenn diese Eigenschaft den Wert 0 hat, ist kein Fehler aufgetreten.

Die folgende Tabelle enthält eine Beschreibung der Fehler, die beim Öffnen einer Snapshot-Datei auftreten können.

Fehler | Beschreibung
2500 | Ungültiger Wert.
2501 | Ungültige Seite.
2502 | Snapshot-Datei fehlt oder ist ungültig.
2503 | Eigenschaft ist schreibgeschützt.
2504 | Vorgang wurde vom Benutzer abgebrochen.
2505 | Zum Anzeigen dieser Snapshot-Datei benötigen Sie eine neuere Version des Snapshot Viewer-Steuerelements.
2506 | Fehler beim Drucken.
2507 | Fehler beim Öffnen einer Snapshot-Datei.
2508 | Kein Speicher mehr vorhanden.
2509 | Fehler beim Schreiben in eine temporäre Datei während des Öffnens einer Snapshot-Datei.
2510 | Es wurde kein Drucker installiert oder als Standarddrucker ausgewählt.


 EventProcPrefix-Eigenschaft (EreignisprozPräfix)

EventProcPrefix-Eigenschaft (EreignisprozPräfix)

Mit der Eigenschaft EventProcPrefix können Sie das Präfix des Namens einer Ereignisprozedur ermitteln. Wenn Sie z. B. eine Befehlsschaltfläche mit einer Ereignisprozedur namens Details_Click haben, gibt die Eigenschaft EventProcPrefix die Zeichenfolge "Details" zurück.

Einstellung

Die Einstellung der Eigenschaft EventProcPrefix ist ein Zeichenfolgenausdruck.

Diese Eigenschaft ist nur in einem Makro oder in Visual Basic verfügbar und ist in allen Ansichten schreibgeschützt.

Anmerkung

Microsoft Access setzt das Präfix des Namens einer Ereignisprozedur zusammen mit einem Unterstrich (_) vor den Namen des jeweiligen Ereignisses.


 Expression1-,Expression2-Eigenschaften (FormatCondition-Objekt)

Expression1-,Expression2-Eigenschaften (FormatCondition-Objekt)

Sie können die Expression1- und Expression2-Eigenschaften verwenden, um die Werte einer bedingten Formatierung in einem FormatCondition-Objekt zurückzugeben.

Einstellung

  • Die Expression1-Eigenschaft gibt einen Variant-Wert oder Ausdruck zurück, der mit dem ersten Teil der bedingten Formatierung verbunden ist.

  • Die Expression2-Eigenschaft gibt einen Variant-Wert oder Ausdruck zurück, der mit dem zweiten Teil der bedingten Formatierung verbunden ist, wenn die Operator-Eigenschaft des FormatCondition-Objektes acBetween oder acNotBetween ist; andernfalls ist die Expression2-Eigenschaft Null.

Die Expression1- und Expression2-Eigenschaften sind nur bei Verwendung von Visual Basic verfügbar und sind schreibgeschützt.

Bedingte Formatierungen können vom Dialogfeld Bedingte Formatierung aus auch für Kombinationsfelder oder Textfelder festgelegt werden. Das Dialogfeld Bedingte Formatierung kann durch Klicken auf Bedingte Formatierung im Menü Format aufgerufen werden, wenn ein Formular in der Entwurfsansicht angezeigt wird.


 FailOnError-Eigenschaft (BeiFehlerAbbrechen)

FailOnError-Eigenschaft (BeiFehlerAbbrechen)

Mit der Eigenschaft FailOnError können Sie angeben, ob eine Aktualisierungsabfrage oder eine Löschabfrage, die für eine ODBC Datenquelle ausgeführt wird, beendet wird, wenn ein Fehler auftritt. Die Eigenschaft FailOnError ermöglicht es Ihnen, eine umfangreiche Aktualisierungsabfrage, die für eine ODBC-Datenquelle ausgeführt wird, so zu optimieren, dass sie auf dem Server ausgeführt wird, wenn Sie das bestimmte Verhalten, mit dem die Microsoft Jet-Datenbank-Engine auf Fehler reagiert, nicht wünschen.

Anmerkung Die Eigenschaft FailOnError bezieht sich nur auf Aktualisierungs- und Löschabfragen.

Einstellung

Die FailOnError-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Bei einem Fehler wird die Abfrage beendet.
Nein | False (0) | (Standardeinstellung) Bei einem Fehler wird die Abfrage nicht beendet.

Sie können die Eigenschaft FailOnError im Eigenschaftenfenster der Abfrage oder in Visual Basic einstellen. Um diese Eigenschaft mit Visual Basic in einer Microsoft Access-Datenbank (.mdb) einzustellen, müssen Sie sie zunächst zu einer Properties-Auflistung eines QueryDef-Objekts hinzufügen, indem Sie die CreateProperty-Methode verwenden.

Anmerkung

Eine Abfrage wird an den jeweiligen Server gesendet und dort ausgeführt, wenn die Eigenschaft FailOnError auf Ja eingestellt ist und folgende Bedingungen erfüllt sind: Die Abfrage wird an nur eine Tabelle einer ODBC-Datenbank gerichtet und enthält keine Ausdrücke, die auf dem Server nicht ausgewertet werden können. Wenn die Eigenschaft FailOnError auf Ja eingestellt ist, wird, falls während eines Lösch- oder Aktualisierungsvorgangs ein Fehler auftritt, die Ausführung der Abfrage beendet, und die Tabelle wird auf ihren ursprünglichen Stand zurückgesetzt. In allen anderen Fällen wird die Eigenschaft FailOnError so behandelt, als sei sie auf Nein eingestellt. Wenn die Eigenschaft FailOnError auf Nein eingestellt ist und ein Fehler auftritt, können Sie entweder das Ergebnis der Abfrage akzeptieren oder alle vorgenommenen Änderungen zurücksetzen.

Wenn die Eigenschaft FailOnError auf Nein eingestellt ist und die Abfrage an lokale Daten gerichtet wird, funktioniert eine Aktualisierungs- oder Löschabfrage so wie in früheren Versionen von Microsoft Access: Für den Fall, dass sich die Abfrage auf mehrere Zeilen auswirkt, kann es sein, dass einige Zeilen aktualisiert werden, während andere infolge von Fehlern ungeändert bleiben. Wenn ein Fehler aufgetreten ist, werden Ihnen der Grund des Fehlers sowie die Anzahl der betroffenen Datensätze mitgeteilt, und Sie können entweder das Ergebnis der Abfrage akzeptieren oder alle vorgenommenen Änderungen zurücksetzen.

Wenn Sie diese Eigenschaft auf Ja einstellen, erzielen Sie dasselbe Ergebnis, als wenn Sie die eingebaute Konstante dbFailOnError der DAO-Methode Execute verwenden.


 FastLaserPrinting-Eigenschaft (SchnellerLaserdruck)

FastLaserPrinting-Eigenschaft (SchnellerLaserdruck)

Mit der Eigenschaft FastLaserPrinting können Sie angeben, ob Linien und Rechtecke durch Linien aus Textzeichen (vergleichbar mit den Zeichen Unterstrich (_) und vertikaler Strich (|)) ersetzt werden, wenn Sie ein Formular oder einen Bericht mit einem der gängigen Laserdrucker drucken. Das Drucken kann erheblich schneller erfolgen, wenn Linien und Rechtecke durch Linien aus Textzeichen ersetzt werden.

Einstellungen

Die Eigenschaft FastLaserPrinting kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Linien und Rechtecke werden durch Linien aus Textzeichen ersetzt.
Nein | False (0) | Linien und Rechtecke werden nicht durch Linien aus Textzeichen ersetzt.

Sie können diese Eigenschaft im Eigenschaftenfenster eines Formulars oder Berichts, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Die Eigenschaft FastLaserPrinting (SchnellerLaserdruck) betrifft sowohl jede Linie und jedes Rechteck auf einem Formular oder Bericht als auch die Steuerelemente, die Linien oder Rechtecke enthalten (z. B. ein Rahmen um ein Textfeld).

Anmerkung Diese Eigenschaft wirkt sich nicht auf PostScript-Drucker, Nadeldrucker oder frühere Versionen von Laserdruckern aus, die keine Linien aus Textzeichen unterstützen.

Wenn diese Eigenschaft auf Ja eingestellt ist und das zu druckende Formular oder der zu druckende Bericht überlappende Rechtecke oder Linien enthält, werden die überlappten Rechtecke oder Linien nicht durch die überlappenden Rechtecken oder Linien gelöscht. Wenn Sie auf einem Bericht überlappende Grafiken benötigen, müssen Sie die Eigenschaft FastLaserPrinting auf Nein einstellen.


FeatureInstall-Eigenschaft

Mit der FeatureInstall-Eigenschaft können Sie angeben oder ermitteln, wie Microsoft Access mit Aufrufen von Methoden und Eigenschaften noch nicht installierter Funktionsmerkmale verfährt.

Einstellung

Die FeatureInstall-Eigenschaft verwendet eine der folgenden msoFeatureInstall-Konstanten.

Konstante | Wert | Beschreibung
msoFeatureInstallNone | 0 | (Standardeinstellung) Beim Aufruf von nicht installierten Features während des Programmbetriebs tritt ein Automatisierungsfehler auf.
msoFeatureInstallOnDemand | 1 | Der Benutzer wird aufgefordert, neue Features zu installieren.
msoFeatureInstallOnDemandWithUI | 2 | Das Feature wird automatisch installiert, und während der Installation wird eine Fortschrittsanzeige eingeblendet. Der Benutzer wird nicht aufgefordert, neue Features zu installieren.

Anmerkungen

Wenn durch VBA-Code ein nicht installiertes Objekt referenziert wird, versucht das Microsoft-Installationsprogramm, das erforderliche Feature zu installieren. Mit der FeatureInstall-Eigenschaft können Sie steuern, was bei der Referenzierung eines nicht installierten Objektes geschieht. Bei der Standardeinstellung versucht das Installationsprogramm bei allen Zugriffsversuchen auf nicht installierte Objekte, das erforderliche Feature zu installieren. Unter Umständen kann dies einige Zeit in Anspruch nehmen, was den Benutzer eventuell zu der Annahme verleitet, dass der Computer auf Befehle nicht mehr reagiert.

Sie können die FeatureInstall-Eigenschaft auf die Option msoFeatureInstallOnDemandWithUI einstellen, so dass die Benutzer eine Aktion erkennen können, während die Installation des Features erfolgt. Wenn Sie den wiedergegebenen Fehler auffangen und dem Benutzer Ihr eigenes Dialogfeld anzeigen oder eine bestimmte andere Aktion einleiten möchten, können Sie die FeatureInstall-Eigenschaft auf msoFeatureInstallNone einstellen.

Falls Sie die UserControl-Eigenschaft auf False eingestellt haben, werden die Benutzer in keinem Fall aufgefordert, neue Features zu installieren, auch wenn die FeatureInstall-Eigenschaft auf msoFeatureInstallOnDemand eingestellt ist. Wurde die UserControl-Eigenschaft auf True eingestellt, wird eine Installations-Fortschrittsanzeige eingeblendet, wenn die FeatureInstall-Eigenschaft auf msoFeatureInstallOnDemand eingestellt ist.


 Feldgröße-Eigenschaft

Feldgröße-Eigenschaft

Sie können die Eigenschaft Feldgröße verwenden, um die maximale Datenmenge festzulegen, die in einem Feld gespeichert werden kann, das auf den Datentyp Text, Zahl, oder AutoWert eingestellt ist.

Einstellung

Ist die Eigenschaft DataType auf Text eingestellt, so geben Sie eine Zahl von 0 bis 255 ein. Die Standardeinstellung ist 50.

Ist die Eigenschaft DataType auf AutoWert eingestellt, so werden die Einstellungen der Eigenschaft Feldgröße als Long Integer oder Replications-ID eingestellt.

Ist die Eigenschaft DataType auf Zahl eingestellt, so werden die Einstellungen der Eigenschaft Feldgröße und deren Werte in folgender Weise miteinander verknüpft.

Einstellung | Beschreibung | Dezimale Genauigkeit | Speichergröße
Byte | Speichert Zahlen von 0 bis 255 (keine Bruchzahlen). | Keine | 1 Byte
Dezimal | Speichert Zahlen von -10^38 -1 bis 10^38 -1 (.adp) Speichert Zahlen von -10^28 -1 bis 10^28 -1 (.mdb) | 28 | 12 Byte
Integer | Speichert Zahlen von -32.768 bis 32.767 (keine Bruchzahlen). | Keine | 2 Bytes
Long Integer | (Voreinstellung) Speichert Zahlen von -2.147.483.648 bis 2.147.483.647 (keine Bruchzahlen). | Keine | 4 Bytes
Single | Speichert Zahlen von -3.402823E38 bis -1.401298E-45 für negative Werte, und von 1.401298E-45 bis 3.402823E38 für positive Werte. | 7 | 4 Bytes
Double | Speichert Zahlen von -1.79769313486231E308 bis -4.94065645841247E-324 für negative Werte, und von 1.79769313486231E308 bis 4.94065645841247E-324 für positive Werte. | 15 | 8 Bytes
Replikations- ID | Globally unique identifier (GUID) | N/A | 16 Bytes

Sie können diese Eigenschaft nur im Eigenschaftenfenster der Tabelle einstellen.

In Visual Basic verwenden Sie die DAO-Eigenschaft Size, um die maximale Größe von Textfeldern zu lesen und einzustellen. (Für andere Datentypen als Text legt die Einstellung der ADO-Eigenschaft Type automatisch die Einstellung der Eigenschaft Size fest.)

Anmerkung Sie können die Standardfeldgrößen für Text- und Zahlenfelder angeben, indem Sie die Werte in der Option Standardfeldgröße auf der Registerkarte Tabellen/Abfragen verändern. Klicken Sie dazu im Menü Extras auf Optionen.

Anmerkung

Sie sollten die kleinstmögliche Einstellung der Eigenschaft Feldgröße verwenden, da kleinere Daten schneller verarbeitet werden können und weniger Speicherplatz belegen.

Vorsicht Wenn Sie eine große Einstellung der Eigenschaft Feldgröße in eine kleinere ändern und das zu ändernde Feld bereits Daten enthält, gehen möglicherweise Daten in diesem Feld verloren. Verändern Sie z.B. die Einstellung der Eigenschaft Feldgröße für ein Feld vom Datentyp Text von 255 auf 50, so gehen die Daten verloren, die mehr als 50 Zeichen umfassen.

Wenn die Daten in einem Feld vom Datentyp Zahl nicht mit der neuen Einstellung von Feldgröße übereinstimmen, werden Bruchzahlen eventuell gerundet, oder Sie erhalten einen Null -Wert. Wechseln Sie z.B. vom Datentyp Single zum Datentyp Integer, so werden Bruchzahlenwerte auf die nächste ganze Zahl gerundet, und Werte größer als 32.767 oder kleiner als -32.768 ergeben Null-Felder.

Sie können die Änderungen, die auf einer neuen Einstellung der Eigenschaft Feldgröße basieren, nach dem Speichern in der Tabellenentwurfsansicht nicht wieder rückgängig machen.

Tipp Sie können den Datentyp Währung verwenden, wenn Sie mehrere Berechnungen auf einem Feld durchführen möchten, das Daten mit bis zu vier Dezimalstellen enthält. Felder des Datentyps Single und Double erfordern Fließkommaberechnungen. Felder vom Datentyp Währung verwenden die schnellere Berechnungsmethode mit Festkomma.


 Feldname-Eigenschaft

Feldname-Eigenschaft

Mit der Eigenschaft Feldname können Sie den Namen eines Feldes in einer Tabelle angeben. Sie können z.B. "Nachname" für ein Feld festlegen, das den Nachnamen der Angestellten in der Tabelle Personal enthält.

Einstellung

Geben Sie einen Feldnamen ein, der den Microsoft Access-Konventionen zur Objektbenennung entspricht. Der Name darf mit keinem anderen Feldnamen in der Tabelle übereinstimmen.

Anmerkung Geben Sie keinen Namen für ein Feld an, der Konflikte mit Namen von eingebauten Microsoft Access-Funktionen oder -Eigenschaften (z.B. mit der Eigenschaft Name) verursachen kann.

Sie können diese Eigenschaft im oberen Bereich der Tabellenentwurfsansicht oder mit Visual Basic einstellen.

Verwenden Sie in Visual Basic die Name-Eigenschaft des ADO-Objekts, um den Feldnamen einer Tabelle zu lesen und einzustellen.

Anmerkung

Microsoft Access identifiziert ein Feld anhand seines Feldnamens. Haben Sie einmal einen Feldnamen in der Tabellenentwurfsansicht festgelegt, so können Sie diesen Namen in Ausdrücken, Visual Basic-Prozeduren und SQL-Anweisungen verwenden.


FELineBreak-Eigenschaft

Sprachspezifische Informationen

You can use the FELineBreak property to control line breaks at the beginning and end of lines in the form control (text box).

Settings

The FELineBreak property uses the following settings.

Setting | Description | Visual Basic
Yes | Controls line breaks. | True (-1)
No | Does control line breaks (default). | False (0)

You can set this property by using the property sheet, a macro, or Visual Basic.

Remarks

Setting the FELineBreak property to Yes moves any punctuation marks and closing parentheses at the beginning of a line to the end of the previous line, and opening parentheses at the end of a line to the beginning of the next line.


 FileSearch-Eigenschaft (Microsoft Access)

FileSearch-Eigenschaft (Microsoft Access)

Mit der FileSearch-Eigenschaft können Sie einen Verweis auf das aktuelle FileSearch-Objekt sowie dessen zugehörige Eigenschaften und Methoden zurückgeben.

Einstellung

[Anwendung.]FileSearch[.Methode oder Eigenschaft]

Die FileSearch-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Anwendung | Das Application-Objekt.
FileSearch | Erforderlich. Wird die FileSearch-Eigenschaft ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie das FileSearch-Objekt zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des FileSearch-Objekts.

Die FileSearch-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Nachdem Sie einen Verweis auf das FileSearch-Objekt eingerichtet haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Zum Festlegen eines Verweises auf das FileSearch-Objekt klicken Sie in der Entwurfsansicht des Moduls im Menü Extras auf Verweise. Anschließend stellen Sie einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie im Dialogfeld Verweise das entsprechende Kontrollkästchen aktivieren. Microsoft Access stellt diesen Verweis automatisch ein, wenn Sie eine Konstante der Microsoft Office 9.0 Object Library zum Einstellen einer Eigenschaft des FileSearch-Objekts oder als Argument einer Methode dieses Objekts verwenden.


 FillColor-Eigenschaft

FillColor-Eigenschaft

Mit der Eigenschaft FillColor geben Sie die Farbe an, mit denen die Methoden Line und Circle Felder und Kreise in Berichten ausfüllen. Sie können diese Eigenschaft auch in Visual Basic verwenden, um optische Spezialeffekte in benutzerdefinierten Berichten zu erzielen, wenn Sie diese auf Farbdruckern drucken oder auf Farbbildschirmen anzeigen.

Einstellung

Die Eigenschaft FillColor enthält einen numerischen Ausdruck, der die Füllfarbe für alle Felder und Kreise angibt.

Sie können diese Eigenschaft nur in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Ereigniseigenschaft OnPrint eines Bereichs angegeben ist.

Sie können die Funktionen RGB oder QBColor verwenden, um diese Eigenschaft einzustellen. Die Einstellung der Eigenschaft FillColor hat den Datentyp Long.


 FillStyle-Eigenschaft

FillStyle-Eigenschaft

Mit der Eigenschaft FillStyle können Sie angeben, ob ein Kreis oder eine Linie, der bzw. die mit der Methode Circle oder Line gezeichnet wird, transparent, undurchsichtig oder mit einem Muster gefüllt ist.

Einstellung

Die Eigenschaft FillStyle verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
0 | Undurchsichtig
1 | (Standardeinstellung) Transparent
2 | Horizontale Linie
3 | Vertikale Linie
4 | Steigende Diagonale
5 | Fallende Diagonale
6 | Kreuzschraffur
7 | Diagonale Kreuzschraffur

Sie können die Eigenschaft FillStyle in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Wenn die Eigenschaft FillStyle auf 0 eingestellt wird, wird die Farbe des Kreises oder der Linie durch die Einstellung der Eigenschaft FillColor bestimmt. Ist die Eigenschaft FillStyle auf 1 eingestellt, so wird das Innere des Kreises oder der Linie transparent und in der Farbe des im Hintergrund dargestellten Berichts angezeigt.

Um die Eigenschaft FillStyle verwenden zu können, müssen Sie die Eigenschaft SpecialEffect auf Normal einstellen.


 Filter-Eigenschaft (Microsoft Access)

Filter-Eigenschaft (Microsoft Access)

Mit der Eigenschaft Filter können Sie eine Teilmenge von Datensätzen angeben, die angezeigt werden soll, wenn ein Filter auf ein Formular, einen Bericht, eine Abfrage oder eine Tabelle angewendet wird.

Anmerkung Wenn Sie innerhalb eines Microsoft Access-Projekts (.adp) einen Serverfilter für auf einem Server gespeicherte Daten angeben möchten, verwenden Sie die ServerFilter-Eigenschaft.

Einstellung

Die Eigenschaft Filter ist ein Zeichenfolgenausdruck und besteht aus einer Klausel WHERE ohne das Schlüsselwort WHERE. Der folgende Visual Basic-Code z.B. definiert und wendet einen Filter an, der nur Kunden aus den USA anzeigt:

Me.Filter = "Land = 'USA'"
Me.FilterOn = True

Sie können die Eigenschaft Filter im Eigenschaftenfenster einer Tabelle oder eines Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaft auch in der Formularansicht oder der Datenblattansicht einstellen, indem Sie im Menü Datensätze auf Filter zeigen und dann im Untermenü auf einen geeigneten Befehl klicken.

Anmerkung Das Einstellen der Eigenschaft Filter hat keine Auswirkungen auf die ADO-Eigenschaft Filter.

Anmerkung

Mit Hilfe der Eigenschaft Filter können Sie einen Filter speichern und zu einem späteren Zeitpunkt anwenden. Filter werden mit den Objekten gespeichert, in denen sie erstellt wurden. Sie werden zwar automatisch geladen, wenn das Objekt geöffnet wird, aber werden nicht automatisch angewendet.

Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die Eigenschaften RecordSource, Filter, OrderBy und OrderByOn.

Wenn Sie einen gespeicherten Filter auf ein Formular, eine Abfrage oder eine Tabelle anwenden möchten, können Sie in der Symbolleiste auf Filter anwenden Filter-Objekt klicken, im Menü Datensätze auf Filter anwenden klicken oder mit einem Makro oder Visual Basic die Eigenschaft FilterOn auf True (-1) einstellen. Auf Berichte können Sie einen Filter anwenden, indem Sie im Eigenschaftenfenster des Berichts die Eigenschaft FilterOn auf Ja einstellen.

Die Schaltfläche Filter anwenden zeigt den Status der Eigenschaften Filter und FilterOn an. Die Schaltfläche ist deaktiviert, solange es keinen Filter gibt, der angewendet werden kann. Ist bereits ein vorhandener Filter angewendet, wird die Schaltfläche Filter anwenden im gedrückten Zustand angezeigt.

Wenn Sie einen Filter automatisch beim Öffnen eines Formulars anwenden möchten, geben Sie in der Einstellung der Ereigniseigenschaft OnOpen des Formulars entweder ein Makro an, das die Aktion AnwendenFilter verwendet, oder eine Ereignisprozedur, die die Methode ApplyFilter des Objekts DoCmd verwendet.

Sie entfernen einen Filter, indem Sie auf die gedrückte Schaltfläche Filter anwenden klicken, im Menü Datensätze auf Filter/Sortierung entfernen klicken, oder indem Sie mit Visual Basic die Eigenschaft FilterOn auf False (0) einstellen.

Anmerkung Sie können einen Filter als Abfrage speichern, indem Sie im Menü Datei auf Als Abfrage speichern klicken, während Sie sich im Fenster Formularbasierter Filter oder Spezialfilter/-sortierung befinden.

Wenn die Eigenschaft Filter in der Formularentwurfsansicht eingestellt wird, versucht Microsoft Access nicht, den SQL-Ausdruck zu bestätigen. Ist der SQL-Ausdruck ungültig, so tritt beim Anwenden des Filters ein Fehler auf.


 FilterLookup-Eigenschaft (FilterAnwenden)

FilterLookup-Eigenschaft (FilterAnwenden)

Mit der Eigenschaft FilterLookup können Sie angeben, ob Werte in einem gebundenen Textfeld-Steuerelement angezeigt werden, wenn Sie das Fenster Formularbasierter Filter oder Formularbasierter Serverfilter verwenden.

Einstellung

Die FilterLookup-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Nie | 0 | Die Feldwerte werden nicht angezeigt. Sie können angeben, ob die gefilterten Datensätze Null-Werte enthalten dürfen.
Datenbankstandard | 1 | (Voreinstellung) Die Feldwerte werden angezeigt entsprechend den Einstellungen im Dialogfeld Optionen in der Registerkarte Bearbeiten/Suchen unter Standards für formularbasierte Filter. Sie öffnen dieses Dialogfeld, indem Sie im Menü Extras auf Optionen klicken.
Immer | 2 | Die Feldwerte werden immer angezeigt.

Sie können die Eigenschaft FilterLookup im Eigenschaftenfenster des Textfelds, in einem Makro oder in Visual Basic einstellen.

Sie können die Voreinstellung für diese Eigenschaft mit den Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Wenn Sie die Feldarten, die angezeigt werden sollen, begrenzen möchten, deaktivieren Sie im Dialogfeld Optionen in der Registerkarte Bearbeiten/Suchen unter Standard für formularbasierte Filter das entsprechende Kontrollkästchen. Sie öffnen das Dialogfeld, indem Sie im Menü Extras auf Optionen klicken. Wenn keine Feldlisten angezeigt werden, geben Sie im Feld Keine Liste anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird eine Zahl an, die größer oder gleich der maximalen Anzahl von Datensätzen in den Feldern der zugrunde liegenden Datenherkunft ist.


 FilterOn-Eigenschaft (FilterAktiv)

FilterOn-Eigenschaft (FilterAktiv)

Mit der FilterOn-Eigenschaft können Sie angeben oder ermitteln, ob die Eigenschaft Filter für ein Formular oder einen Bericht angewendet wird.

Anmerkung Wenn Sie innerhalb eines Microsoft Access-Projekts (.adp) einen Serverfilter angegeben haben, verwenden Sie die ServerFilterByForm-Eigenschaft.

Einstellung

Die Eigenschaft FilterOn verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Eigenschaft Filter des Objekts wird angewendet.
Nein | False (0) | (Voreinstellung) Die Eigenschaft Filter des Objekts wird nicht angewendet.

Für Berichte können Sie die Eigenschaft FilterOn im Eigenschaftenfenster des Berichts oder mit Visual Basic einstellen.

Für Formulare können Sie die Eigenschaft FilterOn in einem Makro oder in Visual Basic einstellen. Sie können diese Eigenschaft auch einstellen, indem Sie in der Symbolleiste Formularansicht oder in der Symbolleiste Filter/Sortieren auf Filter anwenden Filter-Objekt klicken.

Anmerkung

Sie wenden einen gespeicherten Filter an, indem Sie auf die Schaltfläche Filter anwenden (für Formulare) klicken, oder indem Sie mit einem Makro oder Visual Basic die Eigenschaft FilterOn für Formulare und Berichte auf True einstellen. Für einen Bericht können Sie die Eigenschaft FilterOn im Eigenschaftenfenster des Berichts auf Ja einstellen.

Die Schaltfläche Filter anwenden zeigt den Status der Eigenschaften Filter und FilterOn an. Die Schaltfläche ist solange deaktiviert, bis ein Filter vorhanden ist, der angewendet werden kann. Wird momentan ein vorhandener Filter angewendet, wird die Schaltfläche in gedrücktem Zustand dargestellt. Wenn ein Filter beim Öffnen eines Formulars oder Berichts automatisch angewendet werden soll, geben Sie in der Ereigniseigenschaft OnOpen des Formulars entweder ein Makro an, das die Aktion AnwendenFilter verwendet, oder eine Ereignisprozedur, die die Methode ApplyFilter des Objekts DoCmd verwendet.

Sie entfernen einen Filter, indem Sie auf die gedrückte Schaltfläche Filter anwenden klicken, im Menü Datensätze auf Filter/Sortierung entfernen klicken oder mit Hilfe von Visual Basic die Eigenschaft FilterOn auf False einstellen. Sie entfernen einen Filter für Berichte, indem Sie die Eigenschaft FilterOn im Eigenschaftenfenster des Berichts auf Nein einstellen.

Anmerkung Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die Eigenschaften RecordSource, Filter, ServerFilter, OrderBy und OrderByOn. Bei Formularen und Berichten werden geerbte Filter nicht automatisch angewendet, wenn ein Objekt geöffnet wird.


 FolderSuffix-Eigenschaft

FolderSuffix-Eigenschaft

Mit der FolderSuffix-Eigenschaft können Sie das Ordnersuffix festlegen, das Microsoft Access beim Speichern einer Datenzugriffsseite als Webseite verwendet, auf Wunsch lange Dateinamen verwenden und Hilfsdateien in einem separaten Ordner speichern (allerdings nur, wenn die UseLongFileNames-Eigenschaft und die OrganizeInFolder-Eigenschaft auf True eingestellt sind).

Einstellung

Die FolderSuffix-Eigenschaft ist ein Zeichenfolgenausdruck, der den als Hyperlink angezeigten Text repräsentiert.

Diese Eigenschaft steht nur bei Verwendung von Visual Basic zur Verfügung.

Anmerkungen

Neu erstellte Datenzugriffsseiten verwenden das Suffix, das von der FolderSuffix-Eigenschaft des DefaultWebOptions-Objekts zurückgegeben wird. Der Wert der FolderSuffix-Eigenschaft des WebOptions-Objekts kann sich eventuell von dem des DefaultWebOptions-Objekts unterscheiden, wenn die Datenzugriffsseite zuvor in einer anderen Sprachversion von Microsoft Access bearbeitet wurde. Mit Hilfe der UseDefaultFolderSuffix-Methode können Sie das Suffix entsprechend der Sprache, die Sie zurzeit in Microsoft Office 2000 verwenden, ändern.

In der Standardeinstellung wird der Name des betreffenden Ordners aus dem Namen der Webseite plus einem Understrich (_), einem Punkt (.) oder einem Bindestrich (-) und dem Wort "Dateien" (jeweils in der Sprache der Version von Microsoft Access 2000, in welcher die Datei als Webseite gespeichert wurde) gebildet. Wenn Sie beispielsweise in der niederländischen Sprachversion von Access 2000 eine Datei namens "Page1" als Webseite speichern, ist der standardmäßige Name des zugehörigen Ordners "Page1_bestanden".

Die folgende Tabelle zeigt die Sprachversionen von Office 2000 mit dem jeweiligen Wert der LanguageID-Eigenschaft und dem Ordnersuffix an. Bei Sprachen, die in der Tabelle nicht aufgeführt sind, wird das Suffix ".files" verwendet.

Sprache

Sprache | LanguageID | Ordnersuffix
Arabisch | 1025 | .files
Baskisch | 1069 | _fitxategiak
Bulgarisch | 1026 | .files
Chinesisch (Taiwan) | 1028 | .files
Chinesisch (VR China) | 2052 | .files
Dänisch | 1030 | -filer
Deutsch | 1031 | -Dateien
Englisch | 1033 | _files
Estnisch | 1061 | _failid
Finnisch | 1035 | _tiedostot
Französisch | 1036 | _fichiers
Griechisch | 1032 | .files
Hebräisch | 1037 | .files
Italienisch | 1040 | -file
Japanisch | 1041 | .files
Katalanisch | 1027 | _fitxers
Koreanisch | 1042 | .files
Kroatisch | 1050 | _datoteke
Lettisch | 1062 | _fails
Litauisch | 1063 | _bylos
Niederländisch | 1043 | _bestanden
Norwegisch | 1044 | -filer
Polnisch | 1045 | _pliki
Portugiesisch | 2070 | _ficheiros
Portugiesisch (Brasilien) | 1046 | _arquivos
Rumänisch | 1048 | .files
Russisch | 1049 | .files
Schwedisch | 1053 | -filer
Serbisch (Kyrillisch) | 3098 | .files
Serbisch (Lateinisch) | 2074 | _fajlovi
Slowakisch | 1051 | .files
Slowenisch | 1060 | _datoteke
Spanisch | 3082 | _archivos
Thai | 1054 | .files
Tschechisch | 1029 | _soubory
Türkisch | 1055 | _dosyalar
Ukrainisch | 1058 | .files
Ungarisch | 1038 | _elemei
Vietnamesisch | 1066 | .files


 FollowedHyperlinkColor-Eigenschaft

FollowedHyperlinkColor-Eigenschaft

Mit der FollowedHyperlinkColor-Eigenschaft können Sie die Standardfarbe von besuchten Hyperlinks innerhalb des Application-Objekts angeben oder ermitteln.

Einstellung

Die FollowedHyperlinkColor-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic
Schwarz | acColorIndexBlack (0)
Braun | acColorIndexMaroon (1)
Grün | acColorIndexGreen (2)
Olivgrün | acColorIndexOlive (3)
Dunkelblau | acColorIndexDarkBlue (4)
Violett (Standardeinstellung, dunkel) | acColorIndexViolet (5)
Blaugrün | acColorIndexTeal (6)
Grau | acColorIndexGray (7)
Silber | acColorIndexSilver (8)
Rot | acColorIndexRed (9)
Hellgrün | acColorIndexBrightGreen (10)
Gelb | acColorIndexYellow (11)
Blau | acColorIndexBlue (12)
Violett (hell) | acColorIndexFushia (13)
Hellblau | acColorIndexAqua (14)
Weiß | acColorIndexWhite (15)

Sie können die FollowedHyperlinkColor-Eigenschaft mit Visual Basic über die DefaultWebOptions-Eigenschaft oder die SetOption-Methode einstellen.

Die Standardfarbe für besuchte Hyperlinks können Sie im Dialogfeld Weboptionen einstellen bzw. ändern. Um dieses Dialogfeld anzuzeigen, klicken Sie im Menü Extras auf Optionen. Klicken Sie auf die Registerkarte Allgemein und dann auf die Schaltfläche Webseiten.

Anmerkungen

Die Standardfarbe eines Hyperlinks wechselt zu der Farbe für besuchte Hyperlinks, wenn auf das Hyperlink-Steuerelement geklickt wurde.

Verwenden Sie die DefaultWebOptions-Eigenschaft, um die DefaultWebOptions-Objekteigenschaften des Application-Objekts zu überprüfen oder festzulegen.


 FontBold-Eigenschaft (SchriftFett)

FontBold-Eigenschaft (SchriftFett)

Mit der Eigenschaft FontBold können Sie angeben, ob eine Schriftart in den folgenden Situationen fett ausgezeichnet wird:

  • Wenn Steuerelemente eines Formulars oder Berichts angezeigt bzw. gedruckt werden.

  • Wenn für einen Bericht die Methode Print verwendet wird.

Einstellung

Die Eigenschaft FontBold verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Der Text wird fett ausgezeichnet.
False (0) | (Standardeinstellung) Der Text wird nicht fett ausgezeichnet.

Sie können die Eigenschaft FontBold nur in einem Makro oder in Visual Basic einstellen.

Anmerkung

Damit Sie die Eigenschaft FontBold für einen Bericht verwenden können, erstellen Sie zunächst eine Print-Ereignisprozedur, in der der gewünschte Text gedruckt wird.

Das Aussehen einer Schriftart kann je nach verwendetem Computer und Drucker auf dem Bildschirm bzw. in gedruckter Form unterschiedlich sein.

Die Strichbreite, die für den Text eines Steuerelements verwendet wird, kann auch mit der Eigenschaft FontWeight eingestellt werden, die im Eigenschaftenfenster des jeweiligen Steuerelements verfügbar ist. Die Eigenschaft FontBold bietet eine schnelle Möglichkeit, Text fett auszuzeichnen. Die Eigenschaft FontWeight erlaubt Ihnen dagegen eine feiner abgestufte Einstellung der für Text verwendeten Strichbreite. In der folgenden Tabelle sind die Wechselwirkungen zwischen den Einstellungen dieser Eigenschaften aufgeführt.

Wenn | Dann
FontBold = False | FontWeight = Normal (400)
FontBold = True | FontWeight = Fett (700)
FontWeight < 700 | FontBold = False
FontWeight > = 700 | FontBold = True


 FontItalic-, FontUnderline-Eigenschaften (Kursiv, Unterstrichen)

FontItalic-, FontUnderline-Eigenschaften (Kursiv, Unterstrichen)

Mit der Eigenschaft FontItalic bzw. FontUnderline können Sie angeben, ob Text in folgenden Situationen kursiv bzw. unterstrichen ausgezeichnet wird:

  • Wenn Steuerelemente eines Formulars oder Berichts angezeigt bzw. gedruckt werden.

  • Wenn für einen Bericht die Methode Print verwendet wird.

Einstellung

Die Eigenschaft FontItalic verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Der Text wird kursiv ausgezeichnet.
Nein | False (0) | (Standardeinstellung) Der Text wird nicht kursiv ausgezeichnet.

Die Eigenschaft FontUnderline verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True | Der Text wird unterstrichen.
Nein | False | (Standardeinstellung) Der Text wird nicht unterstrichen.

Für ein Steuerelement eines Formulars oder Berichts können Sie diese Eigenschaften im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Für einen Bericht können Sie diese Eigenschaften nur in einer Ereignisprozedur oder in einem Makro einstellen, die bzw. das als Einstellung der Ereigniseigenschaft OnPrint angegeben ist.

Sie können diese Eigenschaften auch einstellen, indem Sie in der Formatsymbolleiste (Formular/Bericht) auf Kursiv [image] bzw. Unterstrichen [image] klicken.

Sie können die Standardeinstellungen dieser Eigenschaften mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Bei einem Textfeld, einem Kombinationsfeld, einem Bezeichnungsfeld oder einer Befehlsschaltfläche, das bzw. die einen Hyperlink enthält, stellt Microsoft Access die Eigenschaft FontUnderline automatisch auf Ja ein, wenn im Dialogfeld Optionen auf der Registerkarte Hyperlinks/HTML das Kontrollkästchen Hyperlinks unterstreichen aktiviert ist. Dieses Dialogfeld wird angezeigt, wenn Sie im Menü Extras auf Optionen klicken. Wenn Sie den jeweiligen Hyperlink aus einem Steuerelement löschen (z.B., indem Sie die Eigenschaft ControlSource eines gebundenen Textfelds auf eine Herkunft einstellen, die kein Hyperlink-Feld ist), stellt Microsoft Access die Eigenschaft FontUnderline wieder auf die Standardeigenschafteneinstellung ein. Bei einer Befehlsschaltfläche wirkt sich die Einstellung der Eigenschaft FontUnderline nur dann aus, wenn die Befehlsschaltfläche kein Bild, sondern eine Beschriftung enthält.


 FontName-, FontSize-Eigenschaften (Schriftart, Schriftgrad)

FontName-, FontSize-Eigenschaften (Schriftart, Schriftgrad)

Mit den Eigenschaften FontName und FontSize können Sie die Schriftart und den Schriftgrad in Punkt angeben, die in folgenden Situationen für Text verwendet werden:

  • Wenn Steuerelemente eines Formulars oder Berichts angezeigt bzw. gedruckt werden.

  • Wenn für einen Bericht die Methode Print verwendet wird.

Einstellung

Die Einstellung der Eigenschaft FontName ist gleich dem Namen der Schriftart, in der der Text angezeigt wird.

Die Eigenschaft FontSize verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
8 | (Standardeinstellung für alle Berichte und Steuerelemente, ausgenommen Befehlsschaltflächen) Der Schriftgrad ist 8 Punkt.
10 | (Standardeinstellung für Befehlsschaltflächen) Der Schriftgrad ist 10 Punkt.
Andere Zahl | Der Schriftgrad ist gleich der angegebenen Zahl.

Für ein Steuerelement eines Formulars oder Berichts können Sie diese Eigenschaften im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaften auch einstellen, indem Sie in der Formatsymbolleiste (Formular/Bericht) auf das Feld Schriftart [image] bzw. Schriftgrad [image] klicken.

Sie können die Standardeinstellungen dieser Eigenschaften mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Für einen Bericht können Sie diese Eigenschaften nur in einer Ereignisprozedur oder in einem Makro einstellen, die bzw. das als Einstellung der Ereigniseigenschaft OnPrint angegeben ist.

In Visual Basic stellen Sie die Eigenschaft FontName mit einem Zeichenfolgenausdruck ein, der den Namen der gewünschten Schriftart angibt, und die Eigenschaft FontSize mit einem numerischen Ausdruck, dessen Wert gleich dem gewünschten Schriftgrad ist. Die Eigenschaft FontSize kann jeden Wert von 1 bis 127 annehmen.

Anmerkung

Welche Schriftarten verfügbar sind, hängt von Ihrem System und Ihrem Drucker ab. Wenn Sie eine Schriftart auswählen, die Ihr System nicht anzeigen kann oder die nicht installiert ist, verwendet Windows stattdessen eine ähnliche Schriftart.


 FontWeight-Eigenschaft (Schriftbreite)

FontWeight-Eigenschaft (Schriftbreite)

Mit der Eigenschaft FontWeight können Sie die Strichbreite angeben, die Windows verwendet, um die Zeichen eines Steuerelements anzuzeigen bzw. zu drucken

Einstellung

Die Eigenschaft FontWeight verwendet die folgenden Einstellungen.

Einstellung | Visual Basic
Extra dünn | 100
Sehr dünn | 200
Dünn | 300
Normal | 400
Mittel | 500
Halbfett | 600
Fett | 700
Sehr fett | 800
Extra fett | 900

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen. Sie können auch in der Formatsymbolleiste (Formular/Bericht)auf Fett [image] klicken. Dadurch wird die Eigenschaft FontWeight auf Bold (700) eingestellt.

Sie können die Standardeinstellung dieser Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Das Aussehen einer Schriftart kann je nach verwendetem Computer und Drucker auf dem Bildschirm bzw. in gedruckter Form unterschiedlich sein. So kann z.B. Text, für den die Eigenschaft FontWeight auf Extra dünn eingestellt ist, auf dem Bildschirm genauso aussehen, wie Text, für den die Eigenschaft FontWeight auf Normal eingestellt ist, während derselbe Text in gedruckter Form dünner erscheint.

Die Strichbreite für den Text eines Steuerelements oder eines Berichts kann auch mit der Eigenschaft FontBold eingestellt werden. Diese nur in Visual Basic sowie in Makros verfügbare Eigenschaft bietet eine schnelle Möglichkeit, Text fett auszuzeichnen. Die Eigenschaft FontWeight erlaubt Ihnen dagegen eine feiner abgestufte Einstellung der für Text verwendeten Strichbreite. In der folgenden Tabelle sind die Wechselwirkungen zwischen den Einstellungen dieser Eigenschaften aufgeführt.

Wenn | Dann
FontBold = False (0) | FontWeight = Normal (400)
FontBold = True (-1) | FontWeight = Fett (700)
FontWeight < 700 | FontBold = False
FontWeight > = 700 | FontBold = True


 ForceNewPage-Eigenschaft (NeueSeite)

ForceNewPage-Eigenschaft (NeueSeite)

Mit der Eigenschaft ForceNewPage können Sie angeben, dass Formularbereiche (Formularkopf, Detailbereich, Formularfuß) oder Berichtsbereiche (Berichtskopf, Detailbereich, Berichtsfuß) nicht auf der aktuellen Seite, sondern auf einer eigenen Seite gedruckt werden. Sie haben z.B. die letzte Seite eines Berichts als Bestellformular gestaltet. Wenn die Eigenschaft ForceNewPage auf Vor Bereich eingestellt ist, wird das Bestellformular immer auf einer neuen Seite gedruckt.

Anmerkung Die Eigenschaft ForceNewPage betrifft weder Seitenköpfe noch Seitenfüße.

Einstellung

Die Eigenschaft ForceNewPage verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keine | 0 | (Standardeinstellung) Der aktuelle Bereich (der Bereich, für den Sie die Eigenschaft einstellen) wird auf der aktuellen Seite gedruckt.
Vor Bereich | 1 | Der aktuelle Bereich wird ab dem Anfang einer neuen Seite gedruckt.
Nach Bereich | 2 | Der Bereich, der unmittelbar auf den aktuellen Bereich folgt, wird ab dem Anfang einer neuen Seite gedruckt.
Vor & Nach | 3 | Sowohl der aktuelle Bereich als auch der nächste Bereich werden jeweils ab dem Anfang einer neuen Seite gedruckt.

Sie können diese Eigenschaft im Eigenschaftenfenster des Bereichs, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Nachstehend finden Sie einige Beispiele, wie die Eigenschaft ForceNewPage eingestellt sein kann.

Bereich | Beispieleinstellung | Beschreibung
Ein Gruppenkopf, in dem das Jahr angezeigt wird | Vor Bereich | Der Gruppenkopf wird am Anfang der Seite gedruckt. Daran anschließend werden der Detailbereich, der Gruppenfuß und der Seitenfuß gedruckt.
Ein Detailbereich eines Berichts | Nach Bereich | Der Gruppenfuß wird ab dem Anfang einer neuen Seite gedruckt.
Ein Berichtskopf, der den Berichtstitel und ein Firmenlogo enthält | Nach Bereich | Der Berichtstitel und das Logo werden am Anfang des Berichts auf einer eigenen Seite gedruckt.


 ForeColor-Eigenschaft (Textfarbe)

ForeColor-Eigenschaft (Textfarbe)

Sie können die Eigenschaft ForeColor verwenden, um die Farbe anzugeben, in der der Text eines Steuerelements angezeigt werden soll. Sie können diese Eigenschaft für Steuerelemente eines Formulars oder Berichts verwenden, damit sie einfacher lesbar sind oder um ihre spezielle Bedeutung hervorzuheben. Sie können z.B. für ein Steuerelement namens EinheitenImLager dessen Textfarbe ändern, wenn sein Wert unter den Mindestbestand fällt und eine Neubestellung erforderlich ist.

Sie können diese Eigenschaft für Berichte verwenden, um spezielle optische Effekte zu erzielen, wenn Sie mit einem Farbdrucker arbeiten. Für einen Bericht gibt diese Eigenschaft die Farbe an, mit der die Methoden Print, Line und Circle drucken bzw. zeichnen.

Einstellung

Die Eigenschaft ForeColor enthält einen numerischen Ausdruck, der dem Wert der Textfarbe des Steuerelements entspricht.

Sie können diese Eigenschaft mit dem Farb-Editor einstellen, indem Sie im Eigenschaftenfenster auf die Generator-Schaltfläche [image] rechts neben der Eigenschaft klicken. Mit Hilfe des Farb-Editors können Sie benutzerdefinierte Farben für die Texte von Steuerelementen definieren.

Für Steuerelemente können Sie diese Eigenschaft mit Schrift-/Vordergrundfarbe [image] aus der Symbolleiste Formatierung (Formular/Bericht), im Eigenschaftenfenster des jeweiligen Steuerelements, mit einem Makro oder mit Visual Basic einstellen.

Die Standardeinstellung dieser Eigenschaft können Sie in den Standardeigenschafteneinstellungen eines Steuerelements oder der Methode DefaultControl in Visual Basic festlegen.

Für Berichte können Sie die Eigenschaft ForeColor nur mit einem Makro oder einer Visual Basic-Ereignisprozedur einstellen, das bzw. die in der Ereigniseigenschaft OnPrint eines Bereichs angegeben ist.

Für Table-Objekte können Sie diese Eigenschaft mit Schrift-/Vordergrundfarbe [image] aus der Symbolleiste Formatierung(Datenblattsymbolleiste Formatierung) oder in Visual Basic mit der Eigenschaft DatasheetForeColor einstellen.

Anmerkung

Für ein Textfeld, Kombinationsfeld, Bezeichnungsfeld oder eine Befehlsschaltfläche, die einen Hyperlink enthalten, stellt Microsoft Access die Eigenschaft ForeColor automatisch auf die Farbe ein, die im Dialogfeld Optionen auf der Registerkarte Hyperlinks/HTML im Feld Farbe für besuchten Hyperlink oder Hyperlink-Farbe angegeben ist. Sie öffnen das Dialogfeld Optionen, indem Sie im Menü Extras auf Optionen klicken. Wenn Sie den Hyperlink aus dem Steuerelement entfernen (z.B., indem Sie der Eigenschaft ControlSource eines gebundenen Textfelds eine Quelle zuweisen, die kein Hyperlink-Feld ist), stellt Microsoft Access die Eigenschaft ForeColor wieder auf die Standardeigenschafteneinstellung ein. Bei Befehlsschaltflächen hat die Einstellung der ForeColor-Eigenschaft nur dann eine Auswirkung, wenn die Befehlsschaltfläche eine Beschriftung und kein Bild enthält.


 Form-, Report-Eigenschaften (Formular, Bericht)

Form-, Report-Eigenschaften (Formular, Bericht)

Sie können die Eigenschaften Form und Report verwenden, um auf ein Formular, einen Bericht oder auf das Formular bzw. auf den Bericht, das dem Unterformular-Steuerelement bzw. dem Unterbericht-Steuerelement zugeordnet ist, zu verweisen.

Einstellung

Diese Eigenschaften verweisen auf ein Formular- oder Berichtobjekt und sind in allen Ansichten schreibgeschützt.

Sie können diese Eigenschaften in einem Makro oder in Visual Basic verwenden.

Anmerkung

Diese Eigenschaften werden normalerweise verwendet, um auf das Formular oder den Bericht, das bzw. der in einem Unterformular- oder Unterbericht-Steuerelement enthalten ist, zu verweisen. Das folgende Beispiel z. B. verwendet die Eigenschaft Form, um auf das Steuerelement Bestell-Nr eines Unterformulars zuzugreifen, das im Unterformular-Steuerelement BestellDetails enthalten ist.

Dim intBestellNr As Integer
intBestellNr = Forms!Bestellungen!BestellDetails.Form![Bestell-Nr]

Das nächste Beispiel ruft eine Funktion aus einem Eigenschaftenfenster unter Verwendung der Eigenschaft Form auf, um auf das aktive Formular zu verweisen, das das Steuerelement mit dem Namen Kunden-Code enthält.

= TestFunktion(Form![Kunden-Code])

Wenn Sie die Eigenschaft Form auf diese Weise verwenden, verweisen Sie auf das aktive Formular, und der Name des Formulars wird nicht benötigt.

Das nächste Beispiel stellt die Entsprechung zum vorhergehenden Beispiel in Visual Basic dar.

X = TestFunktion(Forms!Kunden![Kunden-Code])

Anmerkung Wenn Sie die Auflistungen Forms oder Reports verwenden, müssen Sie den Namen des Formulars oder Berichts angeben.


 Format-Eigenschaft

Format-Eigenschaft

Mit der Eigenschaft Format können Sie die Darstellung von Zahlen, Datumsangaben, Zeitangaben und Text auf dem Bildschirm und im Ausdruck anpassen. Wenn Sie z. B. ein Textfeld-Steuerelement mit dem Namen Preis erstellen, können Sie dessen Eigenschaft Format auf Währung und dessen Eigenschaft DecimalPlaces auf "2" oder Auto einstellen. Wenn Sie dann 4321,678 im Steuerelement eingeben, wird die Zahl als 4.321,68 DM angezeigt.

Sie können ein vordefiniertes Format verwenden oder ein benutzerdefiniertes Format mit Hilfe von Formatierungssymbolen erstellen.

Einstellung

Die Eigenschaft Format verwendet verschiedene Einstellungen für unterschiedliche Datentypen. Informationen zu den Einstellungen für einen bestimmten Datentyp finden Sie unter den folgenden Themen:

  • Datentyp Datum/Uhrzeit

  • Datentypen Zahl und Währung

  • Datentypen Text und Memo

  • Datentyp Ja/Nein

Für ein Steuerelement können Sie die Eigenschaft Format im Eigenschaftenfenster des Steuerelements einstellen. Für ein Feld können Sie diese Eigenschaft in der Tabellenentwurfsansicht (unter Feldeigenschaften) oder in der Entwurfsansicht des Abfragefensters (im Eigenschaftenfenster der Feldeigenschaften) einstellen. Sie können aber auch ein Makro oder Visual Basic verwenden.

Anmerkung Geben Sie in Visual Basic einen Zeichenfolgenausdruck ein, der einem vordefinierten Format entspricht, oder geben Sie ein benutzerdefiniertes Format ein.

Anmerkung

Die Eigenschaft Format wirkt sich nur darauf aus, wie die Daten angezeigt werden, aber nicht darauf, wie sie gespeichert werden.

Microsoft Access stellt vordefinierte Formate für die Datentypen Datum/Uhrzeit, Zahl und Währung, Text und Memo sowie Ja/Nein zur Verfügung. Die vordefinierten Formate hängen von dem Gebietsschema ab, das in der Systemsteuerung von Windows unter Ländereinstellungen ausgewählt wurde. Microsoft Access zeigt Daten in dem für das ausgewählte Land geeigneten Format an. Wenn in der Registerkarte Gebietsschema z. B. Englisch (USA) ausgewählt ist, wird 1234.56 im Format Währung als $1,234.56 angezeigt; ist dagegen Englisch (Großbritannien) ausgewählt, wird die Zahl als £1,234.56 angezeigt.

Wenn Sie die Eigenschaft Format eines Feldes in der Tabellenentwurfsansicht einstellen, verwendet Microsoft Access dieses Format, um die Daten in Datenblättern anzuzeigen. Microsoft Access verwendet die Eigenschaft Format des Feldes auch für neue Steuerelemente in Formularen und Berichten.

Sie können in benutzerdefinierten Formaten für alle Datentypen die folgenden Symbole verwenden.

Symbol | Bedeutung
(Leerzeichen) | Zeigt Leerzeichen als Literal an.
"ABC" | Zeigt alle Zeichen in Anführungszeichen als Literal an.
! | Ausrichtung ist linksbündig statt rechtsbündig.
* | Der verfügbare Platz wird mit dem nächsten Zeichen aufgefüllt.
\ | Das nächste Zeichen wird als Literal angezeigt. Sie können Literale auch in Anführungszeichen einschließen.
[Farbe] | Zeigt die formatierten Daten in der in eckigen Klammern angegebenen Farbe an. Verfügbare Farben: Schwarz, Blau, Grün, Zyan, Rot, Magenta, Gelb, Weiß.

Sie können benutzerdefinierte Formatierungssymbole für den Datentyp Zahl nicht mit Formatierungssymbolen für die Datentypen Datum/Uhrzeit, Ja/Nein oder Text und Memo mischen.

Wenn Sie ein Eingabeformat definiert haben und für dieselben Daten die Eigenschaft Format einstellen, hat die Eigenschaft Format Priorität bei der Datenanzeige, d. h. das Eingabeformat wird ignoriert. Wenn Sie z. B. ein Eingabeformat für ein Kennwort in der Tabellenentwurfsansicht erstellen und zusätzlich die Eigenschaft Format in der Tabelle oder in einem Steuerelement eines Formulars einstellen, wird das Eingabeformat für das Kennwort ignoriert, und die Daten werden entsprechend der Einstellung der Eigenschaft Format angezeigt.


FormatConditions-Eigenschaft

Mit der FormatConditions-Eigenschaft können Sie einen Verweis auf die FormatConditions-Auflistung und die zugehörigen Eigenschaften zurückgeben.

Einstellung

Diese Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Bedingte Formatierungen können vom Dialogfeld Bedingte Formatierung aus auch für Kombinationsfelder oder Textfelder festgelegt werden. Das Dialogfeld Bedingte Formatierung kann durch Klicken auf Bedingte Formatierung im Menü Format aufgerufen werden, wenn ein Formular in der Entwurfsansicht angezeigt wird.


 FormatCount-Eigenschaft

FormatCount-Eigenschaft

Mit der Eigenschaft FormatCount können Sie ermitteln, wie oft die Eigenschaft OnFormat (BeimFormatieren) des aktuellen Bereichs eines Berichts ausgewertet wurde.

Einstellung

Sie können diese Eigenschaft nur in dem Makro oder in der Visual Basic-Ereignisprozedur verwenden, auf das bzw. die die Eigenschaft OnFormat (BeimFormatieren) eines Bereichs eingestellt ist.

Der Wert, auf den die Eigenschaft FormatCount eingestellt ist, hat den Datentyp Long.

Diese Eigenschaft ist in der Entwurfsansicht eines Berichts nicht verfügbar und in den anderen Ansichten schreibgeschützt.

Anmerkung

Microsoft Access erhöht die Eigenschaft FormatCount immer dann um 1, wenn die Einstellung der Eigenschaft OnFormat des aktuellen Bereichs ausgewertet wird. Sobald der nächste Bereich formatiert wird, setzt Microsoft Access die Eigenschaft FormatCount auf 1 zurück.

Es gibt Situationen, in denen Microsoft Access einen Bereich mehrmals formatiert. Angenommen, Sie haben einen Bericht entworfen, bei dem die Eigenschaft KeepTogether (Zusammenhalten) des Detailbereichs auf Ja eingestellt ist. Sobald Microsoft Access den Fuß der Seite erreicht hat, formatiert es einmal den aktuellen Detailbereich, um festzustellen, ob genügend Platz für den Detailbereich vorhanden ist. Ist dies nicht der Fall, wechselt Microsoft Access zur nächsten Seite und formatiert den Detailbereich erneut. In diesem Fall wird die Eigenschaft FormatCount des Detailbereichs auf 2 eingestellt, da der Bereich zweimal formatiert wurde, bevor er gedruckt wurde.

Mit der Eigenschaft FormatCount können Sie dafür sorgen, dass ein zeitaufwendiger Vorgang, der sich auf die Formatierung auswirkt, nur einmal für einen Bereich ausgeführt wird. Im folgenden Beispiel wird die Funktion DLookup nur ausgewertet, wenn die Eigenschaft FormatCount auf 1 eingestellt ist:

Private Sub Detail_Format(Cancel As Integer, _
     FormatCount As Integer)
    Const conFett = 700
    Const conNormal = 400
    If FormatCount = 1 Then
        If DLookup("Firma", _
                "Kunden", "[Kunden-Code] = Reports!" _
                & "[Kundenetiketten]![Kunden-Code]") _
                Like "B*" Then
            FirmaLinie.FontWeight = conFett
        Else
            FirmaLinie.FontWeight = conNormal
        End If
    End If
End Sub


Forms-Eigenschaft

Mit der Eigenschaft Forms können Sie einen Verweis auf die Auflistung Forms und deren zugehörige Eigenschaften zurückgeben.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Die Eigenschaften der Auflistung Forms in Visual Basic beziehen sich auf die momentan geöffneten Formulare.


 FrozenColumns-Eigenschaft

FrozenColumns-Eigenschaft

Mit Hilfe der Eigenschaft FrozenColumns können Sie ermitteln, wie viele Spalten in einem Datenblatt fixiert sind. Fixierte Spalten werden auf der linken Seite des Datenblatts angezeigt und bewegen sich nicht, wenn Sie einen Bildlauf horizontal durch das Datenblatt durchführen.

Anmerkung Die Eigenschaft FrozenColumns gilt nur für Tabellen, Formulare und Abfragen in der Datenblattansicht.

Einstellung

Die Eigenschaft FrozenColumns wird von Microsoft Access eingestellt, wenn Sie im Menü Format auf Spalten fixieren klicken.

In Visual Basic entspricht diese Eigenschafteneinstellung einem Wert vom Typ Integer, der die Anzahl der mit Hilfe des Befehls Spalten fixieren im Datenblatt fixierten Spalten anzeigt. Die Spalte des Datensatzmarkierers ist stets fixiert, so dass der Standardwert 1 entspricht. Demzufolge wird die Eigenschaft FrozenColumns auf 2 eingestellt, wenn Sie eine Spalte fixieren, auf 3, wenn Sie zwei Spalten fixieren usw.

Diese Eigenschafteneinstellung ist in allen Ansichten schreibgeschützt.

Anmerkung

Fixieren Sie Spalten mit Hilfe des Befehls Spalten fixieren, so bewegt Microsoft Access die Spalten automatisch zu der am weitesten links befindlichen Ecke des Datenblatts in der Reihenfolge, in der Sie diese fixiert haben. Fixieren Sie z.B. drei Spalten, so werden diese zur ersten, zweiten und dritten Spalte des Datenblatts. Da die Spalte des Datensatzmarkierers stets fixiert ist, wird die Eigenschaft FrozenColumns in diesem Fall auf 4 eingestellt. Die Eigenschaften ColumnOrder der drei fixierten Spalten sind nun auf 1, 2 und 3 eingestellt (in der Reihenfolge der Fixierung).

Klicken Sie im Menü Format auf Spaltenfixierung aufheben, so werden die Fixierungen aller Spalten aufgehoben und die Eigenschaft FrozenColumns auf 1 eingestellt.

Anmerkung Der Befehl Spaltenfixierung aufheben stellt nicht die ursprüngliche Reihenfolge der Spalten wieder her, wenn der Befehl Spalten fixieren die Spaltenreihenfolge verändert hat.


 FullName-Eigenschaft

FullName-Eigenschaft

Mit der FullName-Eigenschaft können Sie den vollständigen Pfadnamen (einschließlich Dateiname) einer bestimmten Datenzugriffsseite feststellen.

Einstellung

Die FullName-Eigenschaft ist ein Zeichenfolgenausdruck, der nur bei Verwendung von Visual Basic verfügbar und schreibgeschützt ist.

Anmerkungen

Die FullName-Eigenschaft ist der vollständige Name der Datei, auf die der Link verweist. Die Name-Eigenschaft ist der Name des Links.

Der Wert der FullName-Eigenschaft ist die gleiche Zeichenfolge, die auch angezeigt wird, wenn Sie den Cursor über den Namen einer Datenzugriffsseite im Datenbankfenster bewegen.


 FullPath-Eigenschaft

FullPath-Eigenschaft

Die Eigenschaft FullPath gibt eine Zeichenfolge zurück, die den Pfad und den Dateinamen der Typbibliothek angibt, auf die verwiesen wird.

Einstellung

Die Eigenschaft FullPath steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Typbibliotheken befinden sich in Dateien. In der folgenden Tabelle sind die Dateinamenerweiterungen für Dateien zusammengestellt, die normalerweise Typbibliotheken enthalten.

Dateinamenerweiterung | Typ der Datei
.olb, .tlb | Typbibliothek
.adp, .ade, .mdb, .mda, .mde | Datenbank
.exe, .dll | Ausführbare Datei
.ocx | ActiveX-Steuerelement

Ist die Eigenschaft IsBroken eines Reference-Objekts auf True (-1) eingestellt, wird ein Fehler ausgelöst, wenn die Eigenschaft FullPath gelesen wird.


FuriganaControl-Eigenschaft

Sprachspezifische Informationen

You can use the FuriganaControl property to indicate a target control and automatically create furigana for text entered in a text box.

Settings

The setting value is the name of the control for entering Furigana.

You can set this property by using the property sheet, a macro, or Visual Basic.

Remarks

If the FuriganaControl property is set in the control, furigana will automatically be created, and can be displayed in a separately designated control. Only if a control name in the same form is set with the FuriganaControl property will the form run properly when executed. If text is entered in a control other than the designated control name in the same form, an error will occur. The type of furigana characters is determined by the IMEMode/KanjiConversionMode property settings in the control.

Note If you enter text in the target control, the furigana of the newly entered text is automatically added to the end of the designated target control content. Even if the text of the target control is revised or deleted, the characters before the change in the target control will not be revised or deleted. Changing the content of the target control revises the text in the Furigana control as necessary. The FuriganaControl property will not run if text is pasted into the target control.


 GridX, GridY-Eigenschaft (RasterX, RasterY)

GridX, GridY-Eigenschaft (RasterX, RasterY)

Mit den Eigenschaften GridX und GridY können Sie die horizontalen und vertikalen Einheiten des Ausrichtungsrasters in der Formularentwurfsansicht oder der Berichtsentwurfsansicht angeben.

Einstellung

Geben Sie eine Ganzzahl von 1 bis 64 ein, die die Anzahl an Unterteilungen pro Maßeinheit festlegt. Ist in der Windows-Systemsteuerung im Dialogfeld Ländereinstellungen auf der Registerkarte Zahlen das Feld Maßsystem auf US-Maße eingestellt, ist die Standardeinstellung 24 für die Eigenschaft GridX (horizontal) und 24 für die Eigenschaft GridY (vertikal).

Sie können diese Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft mit Hilfe eines numerischen Ausdrucks ein.

Anmerkung

Die Eigenschaften GridX und GridY ermöglichen die Steuerung bei der Positionierung und Ausrichtung von Objekten in einem Formular oder Bericht. Sie können die Genauigkeit des Rasters vergrößern oder verkleinern. Sie zeigen das Raster an, indem Sie im Menü Ansicht auf Raster klicken. Ist die Einstellung der Eigenschaft GridX oder GridY größer als 24, verschwinden die Rasterpunkte aus der Ansicht (obwohl die Gitternetzlinien weiterhin angezeigt werden).


 GroupHeader-, GroupFooter-Eigenschaften (Gruppenkopf, Gruppenfuß)

GroupHeader-, GroupFooter-Eigenschaften (Gruppenkopf, Gruppenfuß)

Sie können die Eigenschaften GroupHeader und GroupFooter verwenden, um einen Gruppenkopf oder einen Gruppenfuß für ein ausgewähltes Feld oder einen ausgewählten Ausdruck in einem Bericht zu erstellen. Sie können Gruppenköpfe und -füße zur Bezeichnung von Gruppen oder zur Zusammenfassung von Daten in einer Gruppe verwenden. Wenn Sie beispielsweise die Eigenschaft GroupHeader für das Feld Kategorie auf Ja einstellen, beginnt jede Artikelgruppe mit ihrem Kategorienamen.

Einstellung

Die Eigenschaften GroupHeader und GroupFooter verwenden die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Erstellt einen Gruppenkopf oder Gruppenfuß.
Nein | (Standardeinstellung) Erstellt keinen Gruppenkopf oder Gruppenfuß.

Sie stellen diese Eigenschaften im Fenster Sortieren und gruppieren ein.

Sie können diese Eigenschaften nur in der Berichtsentwurfsansicht einstellen.

Anmerkung In Visual Basic können Sie diese Eigenschaften nicht direkt einstellen oder auf sie verweisen. Um einen Gruppenkopf oder -fuß für ein Feld oder einen Ausdruck in Visual Basic zu erstellen, verwenden Sie die Methode CreateGroupLevel.

Anmerkung

Wenn die Gruppierungseigenschaften GroupOn, GroupInterval und KeepTogether - von der Standardeinstellung abweichende Werte erhalten sollen, müssen Sie zuerst die Eigenschaften GroupHeader und/oder GroupFooter für das ausgewählte Feld oder den ausgewählten Ausdruck auf Ja einstellen.


 GroupInterval-Eigenschaft (Intervall)

GroupInterval-Eigenschaft (Intervall)

Sie können die Eigenschaft GroupInterval zusammen mit der Eigenschaft GroupOn verwenden, um anzugeben, wie Daten in einem Bericht gruppiert werden. Die Eigenschaft GroupInterval gibt ein Intervall an, nach dem die Daten gruppiert werden. Das Intervall hängt vom Datentyp und der Einstellung der Eigenschaft GroupOn des Feldes oder Ausdrucks ab, nach dem Sie gruppieren. Sie können z. B. die Eigenschaft GroupInterval auf 1 einstellen, um Datensätze nach dem ersten Zeichen eines Textfelds wie z. B. Artikelname zu gruppieren.

Einstellung

Die Einstellungen der Eigenschaft GroupInterval sind Werte vom Typ Integer, die vom Datentyp des Feldes und von der Einstellung der Eigenschaft GroupOn abhängen. Die Standardeinstellung der Eigenschaft GroupInterval ist 1.

Sie können diese Eigenschaft im Fenster Sortieren und gruppieren, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft GroupInterval nur in der Berichtsentwurfsansicht oder in der Ereignisprozedur Open eines Berichts einstellen.

Anmerkung

Die folgenden Beispiele zeigen Einstellungen für die Eigenschaft GroupInterval für verschiedene Felddatentypen.

Felddatentyp | Einstellung für GroupOn (Gruppieren nach) | Einstellung für GroupInterval (Intervall)
Alle | Jedem Wert | (Standardeinstellung) 1.
Text | Anfangszeichen | 3. Es wird nach den ersten drei Zeichen im Feld gruppiert (z. B. würden Chai, Chartreuse und Chang zusammen gruppiert).
Datum/Uhrzeit | Woche | 2. Die Daten werden in 14-Tage-Gruppen (2 Wochen) zurückgegeben.
Datum/Uhrzeit | Stunde | 12. Die Daten werden in 12-Stunden-Gruppen (Halbtag) zurückgegeben.

Wenn die Eigenschaft GroupInterval einen von der Standardeinstellung (1) abweichenden Wert erhalten soll, müssen Sie zuerst die Eigenschaften GroupHeader und/oder GroupFooter für das markierte Feld oder den markierten Ausdruck auf Ja einstellen.


 GroupLevel-Eigenschaft

GroupLevel-Eigenschaft

Sie können die Eigenschaft GroupLevel in Visual Basic verwenden, um auf die Gruppierungsebene zu verweisen, nach der ein Bericht gruppiert oder sortiert werden soll.

Einstellung

Die Einstellung für die Eigenschaft GroupLevel ist ein Datenfeld, in dem jeder Eintrag eine Gruppierungsebene kennzeichnet. Verwenden Sie die folgende Syntax, um auf eine Gruppierungsebene zu verweisen:

GroupLevel (n)

Die Zahl n ist die Gruppierungsebene, beginnend mit 0. Das erste Feld oder der erste Ausdruck, nach dem Sie gruppieren, hat die Gruppierungsebene 0, das zweite die Gruppierungsebene 1 usw. Bis zu 10 Gruppierungsebenen (0 bis 9) sind möglich.

Die folgenden Beispiele zeigen, wie Sie die Eigenschaft GroupLevel verwenden, um auf eine Gruppierungsebene zu verweisen.

Group level | Bezug auf
GroupLevel(0) | das erste Feld oder den ersten Ausdruck, nach dem Sie sortieren oder gruppieren.
GroupLevel(1) | das zweite Feld oder den zweiten Ausdruck, nach dem Sie sortieren oder gruppieren.
GroupLevel(2) | das dritte Feld oder den dritten Ausdruck, nach dem Sie sortieren oder gruppieren.

Sie können diese Eigenschaft nur in Visual Basic verwenden, um die Eigenschaften SortOrder, GroupOn, GroupInterval, KeepTogether und ControlSource einzustellen. Sie stellen diese Eigenschaften in der Ereignisprozedur Open eines Berichts ein.

Anmerkung

In Berichten können Sie nach mehreren Feldern oder Ausdrücken gruppieren oder sortieren. Jedes Feld oder jeder Ausdruck, nach dem Sie gruppieren oder sortieren, ist eine Gruppierungsebene.

Mit der Methode CreateGroupLevel geben Sie die Felder und Ausdrücke an, nach denen sortiert und gruppiert wird.

Wenn für einen Bericht bereits eine Gruppe definiert ist (die Eigenschaft GroupLevel ist auf 0 eingestellt), können Sie mit der Eigenschaft ControlSource die Gruppierungsebene in der Ereignisprozedur Open des Berichts zurücksetzen. Beispielsweise ändert der folgende Code die Eigenschaft ControlSource auf den Wert des Textfelds txtEingabe in einem geöffneten Formular namens FormularSortieren:

Private Sub Report_Open(Cancel As Integer)
    Me.GroupLevel(0).ControlSource _
        = Formulare!FormularSortieren!txtEingabe
End Sub


 GroupOn-Eigenschaft (GruppierenNach)

GroupOn-Eigenschaft (GruppierenNach)

Mit der Eigenschaft GroupOn können Sie angeben, wie Daten in einem Feld oder Ausdruck nach Datentyp gruppiert werden sollen. Diese Eigenschaft ermöglicht beispielsweise das Gruppieren eines Datumsfelds nach Monaten.

Einstellung

Die möglichen Einstellungen der Eigenschaft GroupOn für ein Feld hängen vom Datentyp des Feldes ab; sie werden in der folgenden Tabelle beschrieben. Bei einem Ausdruck stehen alle Einstellungen zur Verfügung. Die Standardeinstellung für alle Datentypen ist Jedem Wert.

Felddatentyp | Einstellung | Datensätze gruppieren nach | Visual Basic
Text | (Standardeinstellung) Jedem Wert | demselben Wert im Feld oder Ausdruck. | 0
 | Anfangszeichen | den ersten n übereinstimmenden Zeichen im Feld oder Ausdruck. | 1
Datum/Uhrzeit | (Standardeinstellung) Jedem Wert | demselben Wert im Feld oder Ausdruck. | 0
 | Jahr | Datumsangaben im selben Kalenderjahr. | 2
 | Quartal | Datumsangaben in demselben Quartal. | 3
 | Monat | Monat. | 4
 | Woche | Datumsangaben in derselben Woche. | 5
 | Tag | Datumsangaben an demselben Tag. | 6
 | Stunde | Zeitangaben in derselben Stunde. | 7
 | Minute | Zeitangaben in derselben Minute. | 8
AutoWert, Währung, Zahl | (Standardeinstellung) Jedem Wert | demselben Wert im Feld oder Ausdruck. | 0
 | Intervall | Werten innerhalb eines von Ihnen angegebenen Intervalls. | 9

Sie können die Eigenschaft GroupOn im Fenster Sortieren und gruppieren, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft in der Ereignisprozedur Open eines Berichts ein.

Anmerkung

Wenn die Eigenschaft GroupOn einen anderen Wert als Jedem Wert erhalten soll, müssen Sie vorher die Eigenschaften GroupHeader und/oder GroupFooter für das ausgewählte Feld oder den ausgewählten Ausdruck auf Ja einstellen.


 GrpKeepTogether-Eigenschaft (GruppeZusammenhalten)

GrpKeepTogether-Eigenschaft (GruppeZusammenhalten)

Sie können mit der Eigenschaft GrpKeepTogether angeben, ob Gruppen eines mehrspaltigen Berichts, deren Eigenschaft KeepTogether auf Ganze Gruppe oder Mit 1. Detaildatensatz eingestellt ist, pro Seite oder pro Spalte zusammengehalten werden.

Einstellung

Die Eigenschaft GrpKeepTogether verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Pro Seite | 0 | Gruppen werden pro Seite zusammengehalten.
Pro Spalte | 1 | (Voreinstellung) Gruppen werden pro Spalte zusammengehalten.

Sie können die Eigenschaft GrpKeepTogether im Eigenschaftenfenster des Berichts, mit einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann nur in der Berichtsentwurfsansicht eingestellt werden.

Anmerkung

Mit der Eigenschaft GrpKeepTogether können Sie angeben, ob alle Daten einer Gruppe in derselben Spalte angezeigt werden sollen. Haben Sie z.B. eine Liste der Angestellten je Abteilung in einem mehrspaltigen Format, können Sie diese Eigenschaft dazu verwenden, alle Mitglieder einer Abteilung in derselben Spalte aufzuführen.

Die Einstellung der Eigenschaft GrpKeepTogether hat keine Wirkung , wenn die Eigenschaft KeepTogether auf No gesetzt ist.


 GUID-Eigenschaft

GUID-Eigenschaft

Die Eigenschaft GUID eines Reference-Objekts gibt eine GUID zurück, die in der Windows-Registrierung eine Typbibliothek kennzeichnet.

Einstellung

Die Eigenschaft GUID steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Jede Typbibliothek hat eine zugeordnete GUID, die in der Registrierung gespeichert ist. Wenn Sie einen Verweis auf eine Typbibliothek einstellen, verwendet Microsoft Access die GUID der Typbibliothek, um die Typbibliothek zu identifizieren.

Mit der Methode AddFromGUID können Sie aus der GUID einer Typbibliothek ein Reference-Objekt erstellen.


HasContinued-Eigenschaft

Mit der HasContinued-Eigenschaft können Sie ermitteln, ob ein Teil der aktuellen Auswahl auf der vorherigen Seite beginnt.

Einstellung

Die HasContinued-Eigenschaft wird von Microsoft Access eingestellt und ist in allen Ansichten schreibgeschützt.

Wert | Beschreibung
True (-1) | Ein Teil der aktuellen Auswahl wurde auf die vorherige Seite gedruckt.
False (0) | Kein Teil der aktuellen Auswahl wurde auf die vorherige Seite gedruckt.

Sie können den Wert der HasContinued-Eigenschaft mit einem Makro oder in Visual Basic abrufen.

Anmerkung

Mit dieser Eigenschaft können Sie bestimmen, ob bestimmte Steuerelemente je nach dem Wert der Eigenschaft angezeigt oder ausgeblendet werden sollen. Beispielsweise enthält ein ausgeblendetes Bezeichnungsfeld im Seitenkopf den Text "Fortsetzung von der vorherigen Seite". Wenn die HasContinued-Eigenschaft den Wert True hat, können Sie das ausgeblendete Bezeichnungsfeld sichtbar machen.


 HasData-Eigenschaft

HasData-Eigenschaft

Mit der HasData-Eigenschaft können Sie ermitteln, ob ein Formular oder Bericht an eine leere Datensatzgruppe gebunden ist.

Einstellung

Die HasData-Eigenschaft wird von Microsoft Access eingestellt. Der Wert dieser Eigenschaft kann nur beim Drucken oder während der Anzeige in der Seitenansicht gelesen werden.

Wert | Beschreibung
-1 | Das Objekt enthält Daten.
0 | Das Objekt enthält keine Daten.
1 | Das Objekt ist ungebunden.

Sie können den Wert der HasData-Eigenschaft mit einem Makro oder in Visual Basic abrufen.

Anmerkung

Mit dieser Eigenschaft können Sie festlegen, ob ein Unterbericht, der keine Daten enthält, ausgeblendet werden soll. Der folgende Ausdruck beispielsweise blendet das Unterbericht-Steuerelement aus, wenn der zugehörige Bericht keine Daten enthält.

Me!Unterberichtsteuerelement.Visible = Me!Unterberichtsteuerelement.Report.HasData


 HasModule-Eigenschaft (EnthältModul)

HasModule-Eigenschaft (EnthältModul)

Mit der Eigenschaft HasModule können Sie angeben oder ermitteln, ob ein Formular oder Bericht ein Klassenmodul hat. Wenn Sie diese Eigenschaft auf Nein einstellen, ist es wahrscheinlich, dass das Leistungsverhalten Ihrer Datenbank verbessert und Ihre Datenbank kleiner wird.

Einstellung

Die Eigenschaft HasModule verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular oder der Bericht hat ein Klassenmodul.
Nein | False (0) | (Standardeinstellung) Das Formular oder der Bericht hat kein Klassenmodul.

Sie können die Eigenschaft HasModule im Eigenschaftenfenster des Formulars oder Berichts, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft HasModule kann nur in der Formularentwurfsansicht oder in der Berichtsentwurfsansicht eingestellt werden, kann aber in allen anderen Ansichten gelesen werden.

Anmerkung

Formulare oder Berichte, deren Eigenschaft HasModule auf Nein eingestellt ist, werden als einfache Objekte behandelt. Einfache Objekte sind kleiner und werden normalerweise schneller geladen und angezeigt als Objekte, die Klassenmodule haben. In vielen Fällen sind für ein Formular oder einen Bericht keine Ereignisprozeduren und somit auch kein Klassenmodul erforderlich.

Wenn in Ihrer Anwendung keine Befehlsschaltflächen mit Ereignisprozeduren, sondern ein Übersichtsformular verwendet wird, um zu anderen Formularen zu gelangen, können Sie eine Befehlsschaltfläche mit einem Makro oder einem Hyperlink verwenden. Sie können z. B. das Formular Personal über eine Befehlsschaltfläche eines Übersichtsformulars öffnen, wenn Sie die Eigenschaft HyperlinkSubAddress des Steuerelements auf Form Personal eingestellt haben.

Sogenannte einfache Objekte werden nicht im Objektkatalog angezeigt, und Sie können nicht das Schlüsselwort New verwenden, um eine neue Instanz des Objekts zu erstellen. Ein einfaches Formular oder ein einfacher Bericht kann als Unterformular bzw. Unterbericht verwendet werden und ist in der jeweiligen Auflistung Forms bzw. Reports enthalten. Einfache Objekte unterstützen das Aufrufen von Makros sowie von öffentlichen Prozeduren, die Bestandteile eines Standardmoduls sind, wenn die Makros oder Prozeduren über das Eigenschaftenfenster des jeweiligen Objekts aufgerufen werden.

Microsoft Access stellt die Eigenschaft HasModule auf True ein, sobald Sie versuchen, ein Modul des Objekts anzuzeigen, und dies sogar dann, wenn kein Code in das Modul eingefügt wird. Wenn z. B. ein Formular in der Entwurfsansicht angezeigt wird und Sie im Menü Ansicht auf Code klicken, fügt Microsoft Access ein Klassenmodul zu dem Form-Objekt hinzu und stellt dessen Eigenschaft HasModule auf True ein. Auf gleiche Weise können Sie ein Klassenmodul zu einem Objekt hinzufügen, indem Sie die Eigenschaft HasModule im Eigenschaftenfenster eines Objekts auf Ja einstellen.

Warnung Wenn Sie die Eigenschaft HasModule im Eigenschaftenfenster eines Objekts auf Nein bzw. in Visual Basic auf False einstellen, löscht Microsoft Access das Klassenmodul des Objekts und somit auch den Code, den das Klassenmodul enthält.

Wenn Sie eine Methode des Module-Objekts verwenden oder in der Entwurfsansicht auf die Eigenschaft Module eines Formulars oder Berichts verweisen, erstellt Microsoft Access das zugehörige Modul und stellt die Eigenschaft HasModule auf True ein. Wenn Sie während der Laufzeit auf die Eigenschaft Module eines Formulars oder Berichts verweisen und die Eigenschaft HasModule des Objekts auf False eingestellt ist, tritt ein Fehler auf.

Objekte, die mit einer der Methoden CreateForm oder CreateReport erstellt wurden, sind standardmäßig einfache Objekte.


 Height-, Width-Eigenschaften (Höhe, Breite)

Height-, Width-Eigenschaften (Höhe, Breite)

Sie können die Eigenschaften Height und Width verwenden, um die Größe eines Objekts an bestimmte Maße anzupassen. Dies kann z. B. hilfreich sein, wenn Sie Objekte erstellen möchten, die dieselbe Größe oder dieselbe Breite bzw. Höhe haben.

Anmerkungen

  • Die Eigenschaft Height betrifft nur Formularbereiche und Berichtsbereiche. Sie betrifft keine Formulare oder Berichte.

  • Die Eigenschaft Width betrifft nur Formulare und Berichte. Sie betrifft keine Formularbereiche oder Berichtsbereiche.

  • Beide Eigenschaften betreffen die Steuerelemente eines Formulars oder Berichts.

Einstellung

Geben Sie eine Zahl ein, die in der aktuellen Maßeinheit die gewünschte Höhe oder Breite festlegt. Wenn Sie eine andere Maßeinheit verwenden möchten als die, die in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen festgelegt ist, geben Sie die Einheit an (z. B. 5 cm oder 3 Zoll). Die Eigenschaft Width kann auf jeden Wert von 0 bis 55,87 cm (22 Zoll) eingestellt werden.

Sie können diese Eigenschaften im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

Bei Steuerelementen können Sie die Standardeinstellungen für diese Eigenschaften mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

In Visual Basic stellen Sie den Wert der jeweiligen Eigenschaft mit einem numerischen Ausdruck ein. Ein solcher Wert wird in Twips interpretiert.

Bei einem Berichtsbereich können Sie die Eigenschaft Height weder in einem Makro noch in Visual Basic einstellen, wenn Sie den Bericht drucken oder in der Seitenansicht anzeigen. Bei einem Steuerelement eines Berichts können Sie die Eigenschaften Height und Width, wenn Sie den Bericht drucken oder in der Seitenansicht anzeigen, nur in dem Makro oder in der Ereignisprozedur einstellen, das bzw. die in der Ereigniseigenschaft OnFormat eines Bereichs angegeben ist.

Sobald der jeweilige Druckvorgang begonnen hat, können Sie diese Eigenschaften nicht mehr für ein Objekt einstellen. Wenn Sie z. B. versuchen, die Eigenschaft Height in der Print-Ereignisprozedur eines Berichts einzustellen, wird ein Fehler gemeldet.

Anmerkung

Microsoft Access stellt die Eigenschaften Height und Width automatisch ein, wenn Sie in der Formularentwurfsansicht oder Berichtsentwurfsansicht ein Steuerelement erstellen oder die Größe eines Steuerelements oder eines Fensters ändern.

Sowohl die Höhe eines Bereichs als auch die Breite eines Formulars oder Berichts werden ab der Innenseite seines Rahmens gemessen. Die Höhe und die Breite eines Steuerelements werden ab der Mitte seines Rahmens gemessen, so dass Steuerelemente mit unterschiedlichen Rahmenbreiten richtig ausgerichtet werden. Die Seitenränder von Formularen und Berichten werden im Dialogfeld Seitenformat eingestellt. Dieses Dialogfeld wird angezeigt, nachdem Sie im Menü Datei auf Seitenformat geklickt haben.

Anmerkung Mit den Eigenschaften Left und Top können Sie die linke und die obere Position eines Objekts angeben.


 HelpContextID-, HelpFile-Eigenschaft (HilfekontextID, Hilfedatei)

HelpContextID-, HelpFile-Eigenschaft (HilfekontextID, Hilfedatei)

  • Die Eigenschaft HelpContextID gibt die Kennnummer eines Themas an, das sich in der benutzerdefinierten Hilfedatei befindet, die als Einstellung der Eigenschaft HelpFile angegeben ist.

  • Die Eigenschaft HelpFile gibt den Namen einer benutzerdefinierten Hilfedatei an, die dem aktuellen Formular oder Bericht zugeordnet ist.

Einstellung

  • Geben Sie für die Eigenschaft HelpContextID einen Wert des Typs Long Integer ein, der zwischen 0 und 2.147.483.647 liegt und die Kennnummer des Themas der Hilfedatei angibt, das Sie anzeigen möchten. Die Standardeinstellung ist 0.

    Anmerkung Wenn Sie die Kennnummer des Hilfethemas als positive Zahl eingeben, wird das Hilfethema in der Vollbildansicht des Hilfefensters angezeigt. Wenn Sie vor der Kennnummer ein Minuszeichen (-) hinzufügen, wird das Hilfethema in einem Popupfenster angezeigt. Beim Erstellen in Microsoft Help Workshop muss die Kennnummer nicht unbedingt als negative Zahl eingegeben werden. Sie müssen das Minuszeichen hinzufügen, wenn Sie die Eigenschaft so einstellen, dass das Thema im Popupfenster angezeigt wird.

  • Geben Sie für die Eigenschaft HelpFile einen Zeichenfolgenausdruck ein, der den Pfad und den Namen einer benutzerdefinierten Hilfedatei enthält, die mit dem Windows Hilfe-Compiler erstellt wurde.

Sie können diese Eigenschaften im Eigenschaftenfenster, mit einem Makro oder mit Visual Basic einstellen. Diese Eigenschaften gelten nicht für Steuerelemente eines Berichts.

Anmerkung

Sie können eine benutzerdefinierte Hilfedatei erstellen, um Formulare, Berichte oder Anwendungen zu beschreiben, die Sie mit Microsoft Access erstellt haben.

Wenn Sie in der Formularansicht die Taste F1 drücken, ruft Microsoft Access das Anwendungsprogramm Microsoft Help Workshop oder Microsoft HTML Help Workshop auf, lädt die benutzerdefinierte Hilfedatei, die von der Eigenschaft HelpFile des Formulars oder Berichts angegeben wird, und zeigt das Hilfethema an, das von der Einstellung der Eigenschaft HelpContextID angegeben wird.

Ist die Eigenschaft HelpContextID eines Steuerelements auf 0 eingestellt (Standardeinstellung), verwendet Microsoft Access die Eigenschaften HelpContextID und HelpFile des Formulars, um das anzuzeigende Hilfethema zu ermitteln. Wenn Sie F1 nicht in der Formularansicht, sondern in einer anderen Ansicht drücken oder wenn sowohl die Eigenschaft HelpContextID des Formulars als auch die des Steuerelements auf 0 eingestellt ist, wird ein Microsoft Access-Hilfethema angezeigt.


 HideDuplicates-Eigenschaft (DuplikateAusblenden)

HideDuplicates-Eigenschaft (DuplikateAusblenden)

Mit der Eigenschaft HideDuplicates können Sie ein Steuerelement eines Berichts ausblenden für den Fall, dass der Wert des Steuerelements für den aktuellen und den vorhergehenden Datensatz identisch ist. Beispielsweise kann ein Bericht, in dem Lieferanten und deren Artikel zusammengestellt sind, so aufgebaut sein, dass der Name des jeweiligen Lieferanten nicht für jeden Artikel, sondern nur einmal für jede Artikelgruppe aufgeführt wird.

Anmerkung Die Eigenschaft HideDuplicates betrifft nur Steuerelemente (Kontrollkästchen, Kombinationsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Textfeld, Umschaltfläche) eines Berichts.

Die Eigenschaft betrifft keine Kontrollkästchen, Optionsfelder oder Umschaltflächen, wenn diese Bestandteil einer Optionsgruppe sind. In diesem Fall betrifft die Eigenschaft die Optionsgruppe selbst.

Einstellung

Die Eigenschaft HideDuplicates verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Ist der Wert oder der Dateninhalt des Steuerelements für den aktuellen und den vorhergehenden Datensatz identisch, wird das Steuerelement ausgeblendet.
Nein | False (0) | (Standardeinstellung) Das Steuerelement ist unabhängig davon, welcher Wert im vorhergehenden Datensatz steht, sichtbar.

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft HideDuplicates nur in der Entwurfsansicht eines Berichts einstellen

Anmerkung

Sie können die Eigenschaft HideDuplicates dazu verwenden, einen gruppierten Bericht zu erstellen, indem Sie auf einen Gruppenkopf verzichten und nur den Detailbereich verwenden.


 hWnd-Eigenschaft

hWnd-Eigenschaft

Mit der Eigenschaft hWnd können Sie die Zugriffsnummer (Handle) ermitteln, die Microsoft Windows dem aktuellen Fenster zugewiesen hat. Diese Zugriffsnummer hat den Datentyp Long Integer und ist eindeutig.

Einstellung

Diese Eigenschaft ist schreibgeschützt und nur in einem Makro oder in Visual Basic verfügbar.

Anmerkung

Sie können diese Eigenschaft in Visual Basic verwenden, wenn Sie eine Funktion des Microsoft Windows API (Application Programming Interface) oder eine andere externe Routine aufrufen, die als Argument die Eigenschaft hWnd erwartet. Es gibt viele Windows-Funktionen, die als eines ihrer Argumente den Wert erfordern, den die Eigenschaft hWnd des aktuellen Fensters hat.

Vorsicht Speichern Sie den Wert der Eigenschaft hWnd nicht in einer öffentlichen Variablen, da sich der Wert dieser Eigenschaft ändern kann, während das jeweilige Programm läuft.


 Hyperlink-Eigenschaft

Hyperlink-Eigenschaft

Mit der Eigenschaft Hyperlink können Sie ein Verweis auf ein Hyperlink-Objekt zurückgeben. Sie können die Eigenschaft Hyperlink verwenden, um auf die Eigenschaften und Methoden eines Hyperlink-Objekts zuzugreifen, das einer Befehlsschaltfläche, einem Bild- oder einem Bezeichnungsfeld-Steuerelement zugeordnet ist.

Einstellung

Die Eigenschaft Hyperlink steht nur in Visual Basic zur Verfügung


 HyperlinkAddress-Eigenschaft (HyperlinkAdresse)

HyperlinkAddress-Eigenschaft (HyperlinkAdresse)

Mit der Eigenschaft HyperlinkAddress können Sie für einen Hyperlink, der einer Befehlsschaltfläche, einem Bild-Steuerelement oder einem Bezeichnungsfeld-Steuerelement zugeordnet ist, einen Pfad zu einem Objekt, einem Dokument, einer Webseite oder einem anderen Ziel angeben oder ermitteln.

Einstellung

Die Einstellung der Eigenschaft HyperlinkAddress ist ein Zeichenfolgenausdruck, der den Pfad zu einer Datei (UNC-Pfad) oder Webseite (URL) angibt.

Sie können die Eigenschaft HyperlinkAddress im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung Mit der Einstellung der HyperlinkAddress-Eigenschaft legen Sie automatisch auch die Address-Eigenschaft für das Hyperlink-Objekt fest, das dem Steuerelement zugeordnet ist.

Sie können diese Eigenschaft auch im Dialogfeld Hyperlink einfügen einstellen. Klicken Sie dazu im Eigenschaftenfenster auf die Generator-Schaltfläche [image] , die sich rechts neben dem Einstellungsfeld der Eigenschaft befindet.

Anmerkung Wenn Sie einen Hyperlink mit dem Dialogfeld Hyperlink einfügen erstellen, stellt Microsoft Access die HyperlinkAddress- und HyperlinkSubAddress-Eigenschaften automatisch auf die Position ein, die im Feld Dateityp oder Webseite angegeben ist. Die HyperlinkSubAddress-Eigenschaft kann auch auf die Position eingestellt werden, die im Feld Wählen Sie ein Objekt in der Datenbank angegeben ist.

Wenn Sie einen Hyperlink aus einer anderen Anwendung in die Zwischenablage kopieren und von dort in ein Formular oder einen Bericht einfügen, erstellt Microsoft Access ein Bezeichnungsfeld-Steuerelement, dessen Caption-, HyperlinkAddress- und HyperlinkSubAddress-Eigenschaften automatisch eingestellt sind.

Anmerkung

Wenn sich der Cursor über einem Befehlsschaltfläche-, Bild- oder Bezeichnungsfeld-Steuerelement befindet, dessen Eigenschaft HyperlinkAddress eingestellt ist, ändert sich der Cursor in eine nach oben zeigende Hand. Wird das Steuerelement angeklickt, wird das Objekt oder die Webseite angezeigt, das bzw. die für den Hyperlink angegeben ist.

Wenn Sie ein Objekt der aktuellen Datenbank öffnen möchten, tragen Sie in die Eigenschaft HyperlinkAddress nichts ein und geben den Typ und den Namen des Objekts, das Sie öffnen möchten, in der Eigenschaft HyperlinkSubAddress gemäß folgender Syntax an: "Objekttyp Objektname". Wenn Sie ein Objekt öffnen möchten, das sich in einer anderen Microsoft Access-Datenbank befindet, geben Sie den Pfad und den Dateinamen der Datenbank in der Eigenschaft HyperlinkAddress und das Datenbankobjekt, das geöffnet werden soll, in der Eigenschaft HyperlinkSubAddress an.

Die Eigenschaft HyperlinkAddress kann entweder einen absoluten oder einen relativen Pfad zu dem Zieldokument enthalten. Ein absoluter Pfad ist ein vollständig angegebener URL- oder UNC-Pfad zu einem Dokument. Ein relativer Pfad ist ein Pfad, der sich entweder auf den Basispfad bezieht, der im Dialogfeld Eigenschaften von Datenbankname (wird angezeigt, wenn Sie im Menü Datei auf Datenbankeigenschaften klicken) im Feld Hyperlinkbasis angegeben ist, oder auf den Pfad der aktuellen Datenbank. Wenn es Microsoft Access nicht gelingt, aus der Einstellung der Eigenschaft HyperlinkAddress einen gültigen URL- oder UNC-Pfad abzuleiten, geht Microsoft Access davon aus, dass Sie einen Pfad angegeben haben, der entweder relativ zu dem Basispfad ist, der im Feld Hyperlinkbasis steht, oder relativ zum Pfad der aktuellen Datenbank.

Anmerkung Wenn Sie einem Hyperlink zu einem anderen Microsoft Access-Datenbankobjekt folgen, werden die Eigenschaften angewendet, die das Startverhalten der Datenbank festlegen. Wenn z.B. für die Zieldatenbank ein nach dem Start anzuzeigendes Formular angegeben ist, wird dieses Formular angezeigt, sobald die Datenbank geöffnet ist.

Die folgende Tabelle enthält Beispiele zu Einstellungen der Eigenschaften HyperlinkAddress und HyperlinkSubAddress.

HyperlinkAddress | HyperlinkSubAddress | Beschreibung
http://www.microsoft.com/ |  | Die Microsoft-Homepage im Web.
C:\Programme\Microsoft Office\Office\Beispiele\Cajun.htm |  | Die Cajun Delights-Seite im Unterverzeichnis für die Beispielanwendungen (ACCESS\BEISPIEL).
C:\Programme\Microsoft Office\Office\Beispiele\Cajun.htm | NewProducts | Die Namenskennung (Name tag) "NewProducts" auf der Cajun Delights-Seite.
C:\Persönlich\Lebenslauf.doc | Zeugnisse | Die Textmarke "Zeugnisse" im Microsoft Word-Dokument LEBENSLAUF.DOC.
C:\Finanzen\Erstes Quartal.xls | Tabelle1!Umsatz | Der Bereich "Umsatz" in der Microsoft Excel-Arbeitsmappe ERSTES QUARTAL.XLS.
C:\Präsentation\NeuePläne.ppt | 10 | Die 10te Folie im Microsoft PowerPoint-Dokument NEUEPLÄNE.PPT.


 HyperlinkColor-Eigenschaft

HyperlinkColor-Eigenschaft

Mit der HyperlinkColor-Eigenschaft können Sie die Standardfarbe von allen Hyperlinks innerhalb des Application-Objekts angeben oder ermitteln.

Einstellung

Die HyperlinkColor-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic
Schwarz | acColorIndexBlack (0)
Braun | acColorIndexMaroon (1)
Grün | acColorIndexGreen (2)
Olivgrün | acColorIndexOlive (3)
Dunkelblau | acColorIndexDarkBlue (4)
Violett (Dunkel ) | acColorIndexViolet (5)
Blaugrün | acColorIndexTeal (6)
Grau | acColorIndexGray (7)
Silber | acColorIndexSilver (8)
Rot | acColorIndexRed (9)
Hellgrün | acColorIndexBrightGreen (10)
Gelb | acColorIndexYellow (11)
Blau (Standardeinstellung) | acColorIndexBlue (12)
Violett (hell) | acColorIndexFushia (13)
Hellblau | acColorIndexAqua (14)
Weiß | acColorIndexWhite (15)

Sie können die HyperlinkColor-Eigenschaft mit Visual Basic über die DefaultWebOptions-Eigenschaft oder die SetOption-Methode einstellen.

Die Standardfarbe für Hyperlinks können Sie im Dialogfeld Weboptionen einstellen bzw. ändern. Um dieses Dialogfeld anzuzeigen, klicken Sie im Menü Extras auf Optionen. Klicken Sie auf die Registerkarte Allgemein und dann auf die Schaltfläche Webseiten.

Anmerkungen

Die Standardfarbe eines Hyperlinks wechselt zu der Farbe für besuchte Hyperlinks, wenn auf das Hyperlink-Steuerelement geklickt wurde.

Verwenden Sie die DefaultWebOptions-Eigenschaft, um die DefaultWebOptions-Objekteigenschaften des Application-Objekts zu überprüfen oder festzulegen.


 HyperlinkSubAddress-Eigenschaft (HyperlinkUnteradresse)

HyperlinkSubAddress-Eigenschaft (HyperlinkUnteradresse)

Mit der Eigenschaft HyperlinkSubAddress können Sie eine Position angeben oder ermitteln, die sich in dem Zieldokument befindet, das in der Eigenschaft HyperlinkAddress angegeben ist. Die Einstellung der Eigenschaft HyperlinkSubAddress kann Folgendes sein: ein Objekt einer Microsoft Access-Datenbank, eine Textmarke eines Microsoft Word-Dokument, ein benannter Bereich eines Microsoft Excel-Tabellenblatts, eine Folie einer Microsoft PowerPoint-Präsentation oder eine Position in einem HTML-Dokument.

Einstellung

Die Einstellung der Eigenschaft HyperlinkSubAddress ist ein Zeichenfolgenausdruck, der eine benannte Position angibt, die in dem Zieldokument liegt, das in der Eigenschaft HyperlinkAddress angegeben ist.

Sie können die Eigenschaft HyperlinkSubAddress im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaft auch im Dialogfeld Hyperlink einfügen einstellen. Klicken Sie dazu im Eigenschaftenfenster auf die Generator-Schaltfläche [image] , die sich rechts neben dem Einstellungsfeld der Eigenschaft befindet.

Anmerkung Wenn Sie einen Hyperlink mit dem Dialogfeld Hyperlink einfügen erstellen, stellt Microsoft Access die HyperlinkAddress- und HyperlinkSubAddress-Eigenschaften automatisch auf die Position ein, die im Feld Dateityp oder Webseite angegeben ist. Die HyperlinkSubAddress-Eigenschaft wird auf die Position eingestellt, die im Feld Wählen Sie ein Objekt in der Datenbank angegeben ist.

Anmerkung

Wenn sich der Cursor über einer Befehlsschaltfläche, einem Bild-Steuerelement oder einem Bezeichnungsfeld-Steuerelement befindet, dessen Eigenschaft HyperlinkAddress eingestellt ist, ändert sich der Cursor in eine nach oben zeigende Hand. Wird das Steuerelement angeklickt, wird das Objekt oder die Webseite angezeigt, das bzw. die für den Hyperlink angegeben ist.

Wenn Sie ein Objekt der aktuellen Datenbank öffnen möchten, tragen Sie in die Eigenschaft HyperlinkAddress nichts ein und geben den Typ und den Namen des Objekts, das Sie öffnen möchten, in der Eigenschaft HyperlinkSubAddress gemäß folgender Syntax an: "Objekttyp Objektname". Angenommen, Sie möchten einen Hyperlink für eine Befehlsschaltfläche erstellen, über die das Formular Personal geöffnet werden kann. Stellen Sie dazu die Eigenschaft HyperlinkSubAddress des Steuerelements auf Form Personal ein. Wenn Sie ein Objekt öffnen möchten, das sich in einer anderen Microsoft Access-Datenbank befindet, geben Sie den Pfad und den Dateinamen der Datenbank in der Eigenschaft HyperlinkAddress und das Datenbankobjekt, das geöffnet werden soll, in der Eigenschaft HyperlinkSubAddress an.

Anmerkung Wenn Sie einem Hyperlink zu einem anderen Microsoft Access-Datenbankobjekt folgen, werden die Eigenschaften angewendet, die das Startverhalten der Datenbank festlegen. Wenn z.B. für die Zieldatenbank ein nach dem Start anzuzeigendes Formular angegeben ist, wird dieses Formular angezeigt, sobald die Datenbank geöffnet ist.

Die folgende Tabelle enthält Beispiele zu Einstellungen der Eigenschaften HyperlinkAddress und HyperlinkSubAddress.

HyperlinkAddress | HyperlinkSubAddress | Beschreibung
http://www.microsoft.com/ |  | Die Microsoft-Homepage im Web.
C:\Programme\Microsoft Office\Office\Beispiele\Cajun.htm |  | Die Cajun Delights-Seite im Unterverzeichnis für die Beispielanwendungen (ACCESS\BEISPIEL).
C:\Programme\Microsoft Office\Office\Beispiele\Cajun.htm | NewProducts | Die Namenskennung (Name tag) "NewProducts" auf der Cajun Delights-Seite.
C:\Persönlich\Lebenslauf.doc | Zeugnisse | Die Textmarke "Zeugnisse" im Microsoft Word-Dokument LEBENSLAUF.DOC.
C:\Finanzen\Erstes Quartal.xls | Tabelle1!Umsatz | Der Bereich "Umsatz" in der Microsoft Excel-Arbeitsmappe ERSTES QUARTAL.XLS.
C:\Präsentation\NeuePläne.ppt | 10 | Die 10te Folie im Microsoft PowerPoint-Dokument NEUEPLÄNE.PPT.


 IgnoreNulls-Eigenschaft (NullwerteIgnorieren)

IgnoreNulls-Eigenschaft (NullwerteIgnorieren)

Mit der IgnoreNulls-Eigenschaft können Sie angeben, dass Datensätze mit Null-Werten in indizierten Feldern nicht in den Index aufgenommen werden.

Einstellung

Die Eigenschaft IgnoreNulls verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Datensätze, die Null-Werte in indizierten Feldern enthalten, werden nicht in den Index aufgenommen.
Nein | False (0) | (Voreinstellung) Datensätze, die Null-Werte in indizierten Feldern enthalten, werden in den Index aufgenommen.

Sie können diese Eigenschaft im Fenster Indizes in der Tabellenentwurfsansicht oder in Visual Basic einstellen.

Anmerkung Sie greifen auf die Eigenschaft IgnoreNulls eines Indexes mit Visual Basic zu, indem Sie die Eigenschaft IgnoreNulls des Datenzugriffsobjekts verwenden.

Anmerkung

Sie können einen Index für ein Feld definieren, um schnelle Suchvorgänge nach Datensätzen in diesem Feld zu ermöglichen. Wenn Sie Null-Einträge im indizierten Feld zulassen und erwarten, dass viele Null-Einträge vorhanden sein werden, stellen Sie die Eigenschaft IgnoreNulls für den Index auf Ja ein, um den für den Index benötigten Speicherplatz zu reduzieren.


 ImageHeight-Eigenschaft

ImageHeight-Eigenschaft

Sie können die Eigenschaft ImageHeight in Visual Basic verwenden, um die Höhe des Bildes in einem Bild-Steuerelement in Twips festzulegen.

Einstellung

Die Eigenschaft ImageHeight ist ein Wert vom Datentyp Integer, der der Höhe eines Bildes in Twips entspricht.

Diese Eigenschaft ist in allen Ansichten schreibgeschützt.

Anmerkung

Sie können die Eigenschaft ImageHeight zusammen mit der Eigenschaft ImageWidth zur Festlegung der Größe eines Bildes in einem Bild-Steuerelement verwenden. Sie könnten diese Information dann dazu verwenden, die Eigenschaften Height und Width des Bild-Steuerelements der Größe des angezeigten Bildes anzupassen.


 ImageWidth-Eigenschaft

ImageWidth-Eigenschaft

Sie können die Eigenschaft ImageWidth in Visual Basic dazu verwenden, die Breite eines Bildes in einem Bild-Steuerelement in Twips festzulegen.

Einstellung

Die Eigenschaft ImageWidth ist ein Wert vom Datentyp Integer, der der Breite eines Bildes in Twips entspricht.

Diese Eigenschaft ist in allen Ansichten schreibgeschützt.

Anmerkung

Sie können die Eigenschaft ImageWidth zusammen mit der Eigenschaft ImageHeight zur Festlegung der Größe eines Bildes in einem Bild-Steuerelement verwenden. Sie könnten diese Information dann dazu verwenden, die Eigenschaften Height und Width des Bild-Steuerelements der Größe des angezeigten Bildes anzupassen.


 IMEHold/HoldKanjiConversionMode-Eigenschaft

IMEHold/HoldKanjiConversionMode-Eigenschaft

Sprachspezifische Informationen

You can use the IMEHold/Hold KanjiConversionMode property to show whether the Kanji Conversion Mode is maintained when the control loses the focus.

Settings

The IMEHold/Hold KanjiConversionMode property uses the following settings.

Settings | Description | Visual Basic
Yes | Maintains the Kanji Conversion Mode set in the last control. | True (-1)
No | Does not maintain the Kanji Conversion Mode set in the last control (default). | False (0)

You can set this property by using the property sheet, a macro, or Visual Basic.

Remarks

By setting the IMEHold/Hold KanjiConversionMode property, you can designate whether or not the Kanji Conversion Mode is maintained when the control loses the focus. If this property is set to Yes, the Kanji Conversion Mode setting is maintained when the control loses the focus and once that control regains the focus, the Kanji Conversion Mode setting for that control is restored. If this property is set to No (default setting), the Kanji Conversion Mode will be set by the IMEMode/KanjiConversionMode property for that control.

Note To set the Kanji Conversion Mode when the focus shifts to the control, set the IMEMode/KanjiConversionMode property.


 IMEMode/KanjiConversionMode-Eigenschaft

IMEMode/KanjiConversionMode-Eigenschaft

Sprachspezifische Informationen

You can use the IMEMode/KanjiConversionMode property to set a control's Kanji Conversion Mode when the focus shifts to the control.

Settings

The IMEMode/KanjiConversionMode property uses the following settings.

Setting | Description | Visual Basic
No Control | Kanji Conversion Mode not set (default). | 0
On | Turns on Kanji Conversion Mode. | 1
Off | Turns off Kanji Conversion Mode. | 2
Disable | Disables Kanji Conversion Mode. | 3
Hiragana | Sets full pitch hiragana | 4
Full pitch Katakana | Sets full pitch katakana. | 5
Half pitch Katakana | Sets half pitch katakana. | 6
Full pitch Alpha/Num | Sets full pitch letters/numbers. | 7
Half pitch Alpha/Num | Sets half pitch letters/numbers. | 8

You can set this property by using the property sheet, a macro, or Visual Basic.

Remarks

You can specify the Kanji Conversion Mode when the focus shifts to control by setting the IMEMode/KanjiConversionMode property. If set to No Control (default) the setting before the focus shifted to that control is used. For any other setting, the Kanji Conversion Mode setting for that control is used. For example, if the IMEMode/KanjiConversionMode property is set to Off, the Kanji Conversion Mode is turned off, and if the IMEMode/KanjiConversionMode property is set to On, the Kanji Conversion Mode is turned on. The Kanji Conversion Mode automatically changes each time the focus shifts between controls.

Note If set to Disable, the Kanji Conversion Mode settings cannot be changed. If any other setting is used, the Kanji Conversion Mode can be changed, but when the focus changes, the settings are lost. If you want to save the settings before the control loses the focus, set the IMEHold/HoldKanjiConversionMode property.


 Indexed-Eigenschaft (Indiziert)

Indexed-Eigenschaft (Indiziert)

Sie können die Eigenschaft Indexed verwenden, um einen Einzelfeld-Index einzustellen. Ein Index beschleunigt Abfragen auf den indizierten Feldern sowie Sortier- und Gruppieroperationen. Suchen Sie z.B. nach einem bestimmten Angestelltennamen in einem Feld namens Nachname, so können Sie einen Index für dieses Feld erstellen.

Einstellung

Die Indexed-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Nein | (Voreinstellung) Kein Index.
Ja (Duplikate möglich) | Der Index lässt Duplikate zu.
Ja (Ohne Duplikate) | Der Index lässt keine Duplikate zu.

Sie können diese Eigenschaft nur im Bereich Feldeigenschaften in der Tabellenentwurfsansicht einstellen. Sie können einen Einzelfeld-Index setzen, indem Sie in der Tabellenentwurfsansicht die Eigenschaft Indexed einstellen. Im Menü Ansicht können Sie durch Klicken auf Indizes Mehr-Felder-Indizes im Fenster Indizes einrichten.

Wenn Sie einen Einzelfeld-Index im Fenster Indizes hinzufügen, stellt Microsoft Access die Eigenschaft Indexed auf Ja ein

In Visual Basic verwenden Sie die ADO-Methode Append aus der Indexes-Auflistung, um einen Index für ein Feld zu erstellen.

Anmerkung

Verwenden Sie die Eigenschaft Indexed, um mit Hilfe eines Einzelfelds in einer Tabelle nach Datensätzen zu suchen und zu sortieren. Das Feld kann entweder eindeutige oder nicht-eindeutige Werte enthalten. Sie können z.B. einen Index für ein Feld namens Personal-Nr in einer Personaltabelle erstellen, in der jede Personal-Nr eindeutig ist, oder Sie können einen Index für ein Namensfeld erstellen, in dem einige Namen mehrfach vorkommen können.

Anmerkung Sie können keine Felder vom Datentyp Memo, Hyperlink, oder OLE-Objekt indizieren.

Sie können beliebig viele Indizes erstellen. Die Indizes werden erstellt, wenn Sie den Tabellenentwurf speichern, und sie werden automatisch aktualisiert, wenn Sie Datensätze verändern oder hinzufügen. Sie können Indizes jederzeit in der Tabellenentwurfsansicht hinzufügen oder löschen.

Tipp Sie können Text, der normalerweise am Anfang oder Ende eines Feldnamens verwendet wird (z.B. "ID", "Code" oder "Nr"), mit der Option AutoIndex bei Importieren/Erstellen auf der Registerkarte Tabellen/Abfragen des Dialogfelds Optionen angeben (klicken Sie im Menü Extras auf Optionen, um das Dialogfeld zu öffnen). Importieren Sie Datendateien, die diesen Text in ihren Feldnamen enthalten, so erstellt Microsoft Access einen Index für diese Felder.

Entspricht der Primärschlüssel einer Tabelle einem Einzelfeld, so stellt Microsoft Access die Eigenschaft Indexed für dieses Feld automatisch auf Ja (Keine Duplikate) ein.

Mehr-Felder-Indizes erstellen Sie mit Hilfe des Fensters Indizes.


 InputMask-Eigenschaft (Eingabeformat)

InputMask-Eigenschaft (Eingabeformat)

Mit der Eigenschaft InputMask können Sie die Dateneingabe vereinfachen und die Werte festlegen, die Benutzer in einem Textfeld-Steuerelement eingeben können. Sie können z. B. ein Eingabeformat für ein Telefonnummernfeld erstellen, das genau vorgibt, wie eine neue Nummer eingegeben werden muss: (___) ___-____. Häufig ist es einfacher, zur Einstellung der Eigenschaft den Eingabeformat-Assistenten zu verwenden.

Einstellung

Die Eigenschaft InputMask kann maximal drei Bereiche enthalten, die durch Semikolons (;) voneinander getrennt sind.

Bereich | Beschreibung
Erster | Gibt das Eingabeformat selbst an, wie z. B. (999) 000-0000!. Eine Liste der zur Definition des Eingabeformats zulässigen Zeichen finden Sie in der folgenden Tabelle.
Zweiter | Gibt an, ob Microsoft Access die angezeigten Literalzeichen in der Tabelle speichert, wenn Sie Daten eingeben. Wenn Sie für diesen Bereich den Wert 0 verwenden, werden alle Literale (z. B. die Klammern in einem Telefonnummern-Eingabeformat) zusammen mit dem Wert gespeichert. Wenn Sie den Wert 1 oder keinen Wert in diesem Bereich eingeben, werden nur die Zeichen gespeichert, die tatsächlich im Steuerelement eingegeben werden.
Dritter | Gibt das Zeichen an, das Microsoft Access an den Stellen des Eingabeformats anzeigt, an der Zeichen eingeben werden sollen. Hierzu können Sie jedes beliebige Zeichen verwenden. Um eine leere Zeichenfolge anzuzeigen, verwenden Sie ein in Anführungszeichen eingeschlossenes Leerzeichen (" ").

In Visual Basic verwenden Sie einen Zeichenfolgeausdruck, um diese Eigenschaft einzustellen. Beispielsweise legt die folgende Codezeile ein Eingabeformat für ein Textfeld-Steuerelement zur Eingabe von Telefonnummern fest:

Formulare![Kunden]![Telefon].InputMask = "(###) ###-####"

Wenn Sie ein Eingabeformat erstellen, können Sie durch Angabe von Sonderzeichen festlegen, dass bestimmte Daten (z. B. die Vorwahl) eingegeben werden sollen und die Eingabe anderer Daten (z. B. der Durchwahl) optional ist, indem Sie spezielle Zeichen verwenden. Diese Zeichen legen fest, welchen Typ von Daten Sie für jedes Zeichen im Eingabeformat eingeben können.

Sie können ein Eingabeformat mit Hilfe der folgenden Zeichen definieren.

Zeichen | Beschreibung
0 | Ziffer (0 bis 9, Eingabe erforderlich, Plus- (+) und Minuszeichen (-) sind nicht erlaubt).
9 | Ziffer oder Leerzeichen (Eingabe nicht erforderlich, Plus- und Minuszeichen sind nicht erlaubt).
# | Ziffer oder Leerzeichen (Eingabe nicht erforderlich, Leerzeichen werden als Leerzeichen im Bearbeitungsmodus angezeigt, aber beim Speichern der Daten entfernt, Plus- und Minuszeichen sind erlaubt).
L | Buchstabe (A bis Z, Eingabe erforderlich).
? | Buchstabe (A bis Z, Eingabe optional).
A | Buchstabe oder Ziffer (Eingabe erforderlich).
a | Buchstabe oder Ziffer (Eingabe optional).
& | Beliebiges Zeichen oder Leerzeichen (Eingabe erforderlich).
C | Beliebiges Zeichen oder Leerzeichen (Eingabe optional).
. , : ; - / | Platzhalter für Dezimaltrennzeichen sowie Tausender-, Datums- und Zeit-Trennzeichen. (Das tatsächlich verwendete Zeichen hängt von den Einstellungen im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows ab.)
< | Alle Buchstaben werden in Kleinbuchstaben umgewandelt.
> | Alle Buchstaben werden in Großbuchstaben umgewandelt.
! | Das Eingabeformat wird von rechts nach links und nicht von links nach rechts angezeigt. Die eingegebenen Zeichen füllen das Eingabeformat immer von links nach rechts auf. Sie können das Ausrufezeichen im Eingabeformat an beliebiger Stelle angeben.
\ | Das folgende Zeichen wird als Literal angezeigt, die Wirkung als Sonderzeichen wird ggf. dadurch aufgehoben. (z. B. wird \A als A angezeigt).

Anmerkung Die Einstellung der Eigenschaft InputMask auf das Wort "Kennwort" erstellt ein Steuerelement zur Eingabe von Kennwörtern. Jedes in das Steuerelement eingegebenen Zeichen wird zwar wie eingegeben gespeichert, jedoch als Sternchen (*) angezeigt. Sie verwenden das Eingabeformat "Kennwort", um zu verhindern, dass die eingegebenen Zeichen auf dem Bildschirm angezeigt werden.

Für ein Steuerelement können Sie die Eigenschaft InputMask im Eigenschaftenfenster des Steuerelements einstellen. Für ein Feld in einer Tabelle können Sie diese Eigenschaft in der Tabellenentwurfsansicht (unter Feldeigenschaften) oder in der Entwurfsansicht des Abfragefensters (im Eigenschaftenfenster der Feldeigenschaften) einstellen.

Sie können diese Eigenschaft aber auch ein in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wenn Sie Daten in einem Feld eingeben, für das Sie ein Eingabeformat definiert haben, werden die Daten immer im Überschreibungsmodus eingegeben. Wenn Sie mit der RÜCKTASTE ein Zeichen löschen, wird es durch ein Leerzeichen ersetzt.

Wenn Sie Text aus einem Feld, für das Sie ein Eingabeformat definiert haben, in die Zwischenablage kopieren, werden die Literalzeichen kopiert, auch wenn Sie festgelegt haben, dass diese mit den Daten gespeichert werden.

Anmerkung Nur direkt in ein Steuerelement oder Kombinationsfeld eingegebene Zeichen sind vom Eingabeformat betroffen. Microsoft Access beachtet keine Eingabeformate, wenn Sie Daten importieren, eine Aktionsabfrage ausführen oder Zeichen in ein Steuerelement eintragen, indem Sie in Visual Basic die Eigenschaft Text des Steuerelements einstellen oder in einem Makro die Aktion SetzenWert verwenden.

Haben Sie ein Eingabeformat definiert und für das gleiche Feld die Eigenschaft Format eingestellt, so hat die Eigenschaft Format bei der Datenanzeige Priorität. Selbst wenn Sie ein Eingabeformat gespeichert haben, wird es in diesem Fall beim Formatieren und Anzeigen der Daten nicht beachtet. Die Daten in der zugrunde liegenden Tabelle selbst werden jedoch nicht geändert; die Eigenschaft Format hat nur Auswirkungen auf die Anzeige der Daten.


 InputParameters-Eigenschaft

InputParameters-Eigenschaft

Mit der InputParameters-Eigenschaft können Sie die Eingabeparameter angeben oder ermitteln, die an eine SQL-Anweisung in der RecordSource-Eigenschaft eines Formulars oder Berichts oder an eine gespeicherte Prozedur übergeben werden, wenn diese die Datenherkunft eines Formulars oder eines Berichts in einem Microsoft Access-Projekt (.adp) ist.

Einstellung

<Name> <Datentyp> = <Ausdruck> [,<Name> <Datentyp> = <Ausdruck> ] ...

Die InputParameters-Eigenschaft verfügt über folgende Argumente.

Argument | Beschreibung
Name | Der Name des Parameters. Falls es sich um eine gespeicherte Prozedur handelt, muss der Name ein vorangestelltes @-Zeichen enthalten. Leerzeichen sind in Parameternamen nicht zulässig.
Datentyp | Der SQL Server-Datentyp des Parameters.
Ausdruck | Ein Microsoft Access-Ausdruck, der zur Auflösung an den Ausdrucks-Generator übergeben wird. Wie andere Ausdrücke kann er sich auf ein anderes Steuerelement in dem Formular beziehen, einen Aufforderungstext für Benutzereingaben zurückgeben, oder er kann ein Literal sein.
 | Falls hinter dem =-Zeichen entweder nichts oder unmittelbar ein Komma folgt, wird die Prozedur mit dem Standard-Parameterwert ausgeführt, wie in der Abfrage oder im Befehl CREATE PROC definiert. Dies gilt ebenso, wenn der Parameter in der Zeichenfolge überhaupt nicht aufgeführt wird.

Sie können diese Eigenschaft im Eigenschaftenfenster oder mit Visual Basic einstellen.

Anmerkungen

Bei Verwendung mit einer RecordSource-Eigenschaft

Eine Zeichenfolge der InputParameter-Eigenschaft in Verbindung mit einer SQL-Anweisung in der RecordSource-Eigenschaft zum Beispiel verwendet folgende Syntax:

state char=[Form]![StateList], salesyear smallint=[Enter year of interest]

Dadurch wird der Parameter state auf den aktuellen Wert des StateList-Steuerelements gesetzt und der Benutzer aufgefordert, den Parameter salesyear einzugeben. Falls weitere Parameter existieren, die nicht in der Liste aufgeführt sind, werden ihnen die Standardwerte zugewiesen.

Die Abfrage sollte mit einem ?-Marker für jeden Nicht-Standardparameter in der InputParameter-Liste ausgeführt werden.

Ein Aktualisierungs- oder Abfragewiederholungsbefehl (per Menü, Tastatur oder Navigationsleiste) in Access sollte ein erneutes Ausführen der Abfrage auslösen. Benutzer können dies im Code durch Aufrufen der standardmäßigen Recordset.Requery-Methode durchführen. Falls der Wert eines Parameters an ein Steuerelement im Formular gebunden ist, wird bei der Abfragewiederholung der aktuelle Wert des Steuerelements verwendet. Die gespeicherte Prozedur wird nicht automatisch erneut ausgeführt, wenn der Wert des Steuerelements sich ändert.

Bei Verwendung mit einer gespeicherten Prozedur

Ein Zeichenfolge der InputParameter-Eigenschaft in Verbindung mit einer gespeicherten Prozedur wäre beispielsweise:

@state char=[Form]![StateList], @salesyear smallint=[Enter year of interest]

Dadurch wird der Parameter @state auf den aktuellen Wert des StateList-Steuerelements gesetzt und der Benutzer aufgefordert, den Parameter @salesyear einzugeben. Falls die gespeicherte Prozedur über weitere Parameter verfügt, die nicht in der Liste aufgeführt sind, werden ihnen die Standardwerte zugewiesen.

Die gespeicherte Prozedur sollte mit einer Befehlszeichenfolge ausgeführt werden, die die {Call }-Syntax mit einem ?-Marker für jeden Nicht-Standardparameter in der InputParameter-Liste verwendet.

Ein Aktualisierungs- oder Abfragewiederholungsbefehl (per Menü, Tastatur oder Navigationsleiste) in Access sollte ein erneutes Ausführen der gespeicherten Prozedur auslösen. Benutzer können dies im Code durch Aufrufen der standardmäßigen Recordset.Requery-Methode durchführen. Falls der Wert eines Parameters an ein Steuerelement im Formular gebunden ist, wird bei der Abfragewiederholung der aktuelle Wert des Steuerelements verwendet. Die gespeicherte Prozedur wird nicht automatisch erneut ausgeführt, wenn der Wert des Steuerelements sich ändert.

Dieser Editor-Dialog wird aufgerufen, wenn eine gespeicherte Prozedur erstmals als Datenherkunft eines Formulars ausgewählt wird - falls die gespeicherte Prozedur Parameter besitzt. Nach der ursprünglichen Erstellung der InputParameters-Zeichenfolge wird derselbe Dialog als Editor zum Ändern der Zeichenfolge verwendet. In diesem Fall entstammt die Liste der Parameter, von den bereits in der Zeichenfolge enthaltenen Angaben.

Parameterwerte können im Code mit Hilfe der Command- und Parameter-Objekte des ActiveX-Datenobjekts (ADO) festgelegt werden. Falls als Ergebnis eine Ergebnisgruppe zurückgegeben wird, kann daran durch Festlegen der Recordset-Eigenschaft ein Formular gebunden werden. ADO-Code ist der einzige Weg, um mit gespeicherten Prozeduren zu arbeiten, die keine Ergebnisgruppen zurückgeben, wie beispielsweise Aktionsabfragen, die Ausgabeparameter zurückgeben, oder die mehrfache Ergebnisgruppen zurückgeben.


 InSelection-Eigenschaft (InAuswahl)

InSelection-Eigenschaft (InAuswahl)

Mit der Eigenschaft InSelection können Sie für ein Steuerelement eines Formulars ermitteln bzw. festlegen, ob es in der Entwurfsansicht ausgewählt ist bzw. sein soll.

Einstellung

Die Eigenschaft InSelection verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Das Steuerelement ist ausgewählt.
False (0) | Das Steuerelement ist nicht ausgewählt.

Diese Eigenschaft steht nur in einem Makro oder in Visual Basic zur Verfügung.

Anmerkung

Wenn ein Steuerelement ausgewählt ist, sind seine Ziehpunkte sichtbar, so dass der Benutzer die Größe des Steuerelements ändern kann. Es können auch gleichzeitig mehrere Steuerelemente ausgewählt sein.


 InsideHeight-, InsideWidth-Eigenschaften

InsideHeight-, InsideWidth-Eigenschaften

Mit Hilfe der Eigenschaften InsideHeight und InsideWidth können Sie die Höhe und Breite (in Twips) des Fensters bestimmen, das ein Formular enthält.

Einstellung

  • Die Eigenschaft InsideHeight. Ein Wert des Datentyps Integer (in Twips), der für die Höhe eines Formularfensters steht.

  • Die Eigenschaft InsideWidth. Ein Wert des Datentyps Integer (in Twips), der für die Breite eines Formularfensters steht.

Die Eigenschaften InsideHeight und InsideWidth stehen nur bei Verwendung eines Makros oder von Visual Basic zur Verfügung und können jederzeit eingestellt werden.

Anmerkung

Möchten Sie die inneren Abmessungen des Formulars bestimmen, verwenden Sie die Eigenschaft Width, um die Formularbreite zu bestimmen. Die Höhe bestimmen Sie über die Summe der Höhen der sichtbaren Bereiche des Formulars (die Eigenschaft Height gilt nur für Formularbereiche und nicht für ganze Formulare). Das Innere eines Formulars ist der Bereich innerhalb des Formulars ohne die Bildlaufleisten und die Datensatzmarkierer.

Sie können auch die Eigenschaften WindowHeight und WindowWidth verwenden, um die Höhe und Breite des Fensters zu bestimmen, das ein Formular enthält.

Ist ein Fenster maximiert dargestellt, hat das Einstellen dieser Eigenschaften so lange keinen Einfluss, bis die normale Größe des Fensters wiederhergestellt wird.


 IsBroken-Eigenschaft

IsBroken-Eigenschaft

Die Eigenschaft IsBroken gibt einen Wert des Datentyps Boolean zurück, der angibt, ob ein Reference-Objekt auf einen gültigen Verweis in der Windows-Registrierung zeigt.

Einstellung

Die Eigenschaft IsBroken steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Der Standardwert der Eigenschaft IsBroken lautet False (0). Die Eigenschaft IsBroken gibt nur dann True (-1) zurück, wenn das Reference-Objekt nicht mehr auf einen gültigen Verweis in der Registrierung zeigt.

Anmerkung

Durch Auswerten der Eigenschaft IsBroken können Sie ermitteln, ob die Datei, die einem bestimmten Reference-Objekt zugeordnet ist, in ein anderes Verzeichnis verschoben oder gelöscht wurde.

Ist die Eigenschaft IsBroken auf True eingestellt, meldet Microsoft Access einen Fehler, wenn Sie versuchen, eine der Eigenschaften Name oder FullPath zu lesen.


 IsCompiled-Eigenschaft

IsCompiled-Eigenschaft

Die Eigenschaft IsCompiled gibt einen Wert des Datentyps Boolean zurück, der angibt, ob das Visual Basic-Projekt kompiliert ist.

Einstellung

Die Eigenschaft IsCompiled steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Die Eigenschaft IsCompiled gibt True (-1) zurück, wenn das Projekt kompiliert ist.

Anmerkung

Sie können Visual Basic von der Benutzeroberfläche aus in der Modul-Entwurfsansicht dazu veranlassen, das Projekt zu kompilieren, indem Sie im Menü Debuggen auf Alle Module kompilieren oder Alle Module kompilieren und speichern klicken.

Die Eigenschaft IsCompiled eines Application-Objekts ist False (0), wenn das Projekt nie vollständig kompiliert, ein Modul nach der Kompilierung hinzugefügt, bearbeitet oder gelöscht, oder ein Modul nicht im kompilierten Zustand gespeichert wurde.


IsConnected-Eigenschaft

Mit der IsConnected-Eigenschaft können Sie feststellen, ob das CurrentProject- oder CodeProject-Objekt gegenwärtig verbunden ist.

Einstellung

Die IsConnected-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das CurrentProject- bzw. CodeProject-Objekt ist gegenwärtig verbunden.
Nein | False (0) | Das CurrentProject- bzw. CodeProject-Objekt ist nicht verbunden.

Die IsConnected-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 IsHyperlink-Eigenschaft (IstHyperlink)

IsHyperlink-Eigenschaft (IstHyperlink)

Mit der IsHyperlink-Eigenschaft können Sie angeben oder ermitteln, ob die Daten in einem Textfeld oder Kombinationsfeld einen Hyperlink bilden.

Einstellung

Die IsHyperlink-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die angezeigten Daten bilden einen Hyperlink.
Nein | False (0) | Die angezeigten Daten bilden keinen Hyperlink.

Sie können die IsHyperlink-Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic festlegen.


IsLoaded-Eigenschaft

Mit der IsLoaded-Eigenschaft können sie feststellen, ob ein AccessObject gegenwärtig geladen ist.

Einstellung

Die IsLoaded-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das angegebene AccessObject ist geladen.
Nein | False (0) | Das angegebene AccessObject ist nicht geladen.

Die IsLoaded-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 IsVisible-Eigenschaft

IsVisible-Eigenschaft

Mit der Eigenschaft IsVisible können Sie in Visual Basic ermitteln, ob ein Steuerelement, das sich auf einem Bericht befindet, sichtbar ist.

Einstellung

Die Eigenschaft IsVisible verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | (Standardeinstellung) Das Steuerelement ist sichtbar.
False (0) | Das Steuerelement ist nicht sichtbar.

Sie können die Eigenschaft IsVisible nur in der Print-Ereignisprozedur des Berichtsbereichs verwenden, der das Steuerelement enthält.

Anmerkung

Sie können anhand der Eigenschaften IsVisible und HideDuplicates ermitteln, ob ein Steuerelement eines Berichts sichtbar ist, und als Reaktion auf das jeweilige Ergebnis andere Steuerelemente ein- oder ausblenden. Sie können z. B. ein Linie-Steuerelement ausblenden, wenn ein Textfeld-Steuerelement ausgeblendet ist, weil es Duplikatwerte enthält.


 Item-Eigenschaft (Auflistungen)

Item-Eigenschaft (Auflistungen)

Die Eigenschaft Item gibt ein bestimmtes Element einer Auflistung entweder nach Position oder nach Index zurück.

Einstellung

Objekt.Item(Index)

Die Eigenschaft Item verwendet die folgenden Einstellungen:

Einstellung | Beschreibung
Objekt | Eine der folgenden Auflistungen:
 | Controls Forms Modules Pages Reports Properties AccessObjectProperties DataAccessPages AllForms AllReports | AllDataAccessPages AllMacros AllModules AllTables AllQueries AllViews AllStoredProcedures AllDatabaseDiagrams FormatConditions
Index | Ein Ausdruck, der die Position eines Elements der Auflistung bestimmt, auf die im Argument Objekt verwiesen wird. Wenn es sich um einen numerischen Ausdruck handelt, muss das Argument Index eine Zahl zwischen 0 und dem Wert der Count-Eigenschaft der Auflistung minus 1 sein. Wenn es sich um einen Zeichenfolgenausdruck handelt, muss das Argument Index der Name eines Elements der Auflistung sein.

Die Eigenschaft Item ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Wenn der für das Argument Index angegebene Wert keinem vorhandenen Element der Auflistung entspricht, tritt ein Fehler auf.

Die Eigenschaft Item ist das Standardelement einer Auflistung, Sie brauchen die Eigenschaft daher nicht explizit anzugeben. Die folgenden zwei Codezeilen haben z. B. dieselbe Bedeutung:

Debug.Print Modules(0)
Debug.Print Modules.Item(0)


 Item-Eigenschaft (Objektfeld-Steuerelement)

Item-Eigenschaft (Objektfeld-Steuerelement)

Sie können die Eigenschaft Item verwenden, um eine Beschreibung der verknüpften Daten zu erhalten, die in einem Diagramm-Steuerelement oder in einem ungebundenen Objektfeld angezeigt werden.

Einstellung

Die Einstellung der Eigenschaft Item ist ein Zeichenfolgenausdruck. Die Eigenschaft ist in allen Ansichten schreibgeschützt.

Anmerkung Wenn Sie mit Automatisierung (früher als OLE-Automatisierung bezeichnet) arbeiten und einen Datenbereich angeben müssen, verwenden Sie die Eigenschaft SourceItem.

Anmerkung

Die Beschreibung eines verknüpften Objektfelds ist abhängig vom Typ des OLE-Objekts, mit dem es verknüpft ist. Wenn Sie das Objektfeld z. B. mit Zellen eines Microsoft Excel-Tabellenblatts verknüpfen, zeigt Microsoft Access im Objektfeld die in den Zellen stehenden Daten an, und die Eigenschaft Item beschreibt die verknüpften Zellen im Zeilen-und-Spalten-Format (Z1S1-Schreibweise). Bei einem Diagramm enthält die Einstellung der Eigenschaft Item das Wort Chart. Bei einer Grafik entspricht die Einstellung den Koordinaten des verknüpften Grafikbereichs.

Anmerkung Die Daten eines verknüpften OLE-Objekts werden zwar im entsprechenden Objektfeld angezeigt, werden aber von der Anwendung gespeichert, die die Daten erstellt hat. Wenn Sie diese Daten ändern möchten, verwenden Sie die zugehörige Anwendung.

Wenn Sie ein OLE-Objekt mit einem ungebundenen Objektfeld verknüpfen, indem Sie im Menü Bearbeiten auf Inhalte einfügen klicken, stellt Microsoft Access die Eigenschaften SourceObject, OLEClass und Item ein. Die folgende Tabelle enthält typische Einstellungen der Eigenschaften für verschiedene OLE-Objekte.

Objekt | Eigenschaft SourceObject | Eigenschaft OLEClass | Eigenschaft Item
Tabelle | C:\Excel\Xls\Tabelle.xls | Microsoft Excel Worksheet | Z1S1:Z7S4
Diagramm | C:\Excel\Xls\Diagramm.xlc | Microsoft Excel Chart | Chart
Grafik | C:\Windows\Bitmap.bmp | Paintbrush Picture | 0 0 72 71


 ItemData-Eigenschaft

ItemData-Eigenschaft

Die ItemData-Eigenschaft gibt die Daten in der gebundenen Spalte für die angegebene Zeile in einem Kombinationsfeld oder Listenfeld zurück.

Syntax

Steuerelement.ItemData(Zeilenindex)

Die ItemData-Eigenschaft verwendet die folgenden Argumente.

Argument | Beschreibung
Steuerelement | Ein Control-Objekt, das ein Kombinations- oder Listenfeld darstellt.
Zeilenindex | Die Zeile im Kombinations- oder Listenfeld, die die zurückzugebenden Daten enthält. Zeilen in Kombinations- und Listenfeldern sind, beginnend bei Null, indiziert. Um z. B. den Eintrag in der sechsten Zeile eines Kombinationsfeldes zurückzugeben, geben Sie 5 für das Argument Zeilenindex an.

Anmerkungen

Die Eigenschaft ItemData ermöglicht es Ihnen, die Liste der Einträge in einem Kombinations- oder Listenfeld zu durchlaufen. Angenommen beispielsweise, Sie möchten alle Einträge in einem Listenfeld durchlaufen, um nach einem bestimmten Eintrag zu suchen. Dann können Sie mit Hilfe der ListCount-Eigenschaft die Anzahl der Zeilen im Listenfeld ermitteln und anschließend mit Hilfe der ItemData-Eigenschaft die Daten für die gebundene Spalte in jeder Zeile zurückgeben.

Sie können die ItemData-Eigenschaft auch verwenden, um Daten nur aus ausgewählten Zeilen eines Listenfeldes zurückzugeben. Zu diesem Zweck können Sie die Auflistung ItemsSelected durchlaufen, um zu ermitteln, welche Zeile(n) im Listenfeld ausgewählt wurde(n), und dann mit Hilfe der ItemData-Eigenschaft die Daten in diesen Zeilen zurückgeben. Sie müssen die MultiSelect-Eigenschaft des Listenfeldes auf Einzeln oder Erweitert einstellen, damit ein Benutzer mehrere Zeilen gleichzeitig auswählen kann.

Tipp Mit der Column-Eigenschaft können Sie Daten aus einer angegebenen Zeile und Spalte auch dann zurückgeben, wenn die angegebene Spalte nicht gebunden ist.


 ItemsSelected-Eigenschaft

ItemsSelected-Eigenschaft

Mit der ItemsSelected-Eigenschaft können Sie einen Verweis auf die ausgeblendete Auflistung ItemsSelected zurückgeben. Diese ausgeblendete Auflistung kann für den Zugriff auf Daten in ausgewählten Zeilen eines Listenfeld-Steuerelements mit Mehrfachauswahl verwendet werden.

Anmerkungen

Die Auflistung ItemsSelected unterscheidet sich dadurch von anderen Auflistungen, dass es sich bei ihr um eine Auflistung von Variablen des Datentyps Variant statt von Objekten handelt. Jede Variable des Datentyps Variant ist ein ganzzahliger Index, der auf eine ausgewählte Zeile in einem Listen- oder Kombinationsfeld verweist.

Verwenden Sie die Auflistung ItemsSelected zusammen mit der Column-Eigenschaft oder der ItemData-Eigenschaft, um Daten aus ausgewählten Zeilen in einem Listen- oder Kombinationsfeld abzurufen. Sie können die Auflistung ItemsSelected mit der Anweisung For Each...Next anzeigen.

Wenn z. B. ein Formular das Listenfeld Personal enthält, können Sie die Auflistung ItemsSelected anzeigen und mit Hilfe der ItemData-Eigenschaft des Steuerelements den Wert der gebundenen Spalte für jede ausgewählte Zeile im Listenfeld zurückgeben.

Tipp Zum Aktivieren einer Mehrfachauswahl von Zeilen in einem Listenfeld stellen Sie die MultiSelect-Eigenschaft des Steuerelements auf Einzeln oder Erweitert ein.

Die Auflistung ItemsSelected verwendet keine Methoden. Sie besitzt zwei Eigenschaften: Count und Item.


 KeepTogether-Eigenschaft (Zusammenhalten) - Bereiche

KeepTogether-Eigenschaft (Zusammenhalten) - Bereiche

Sie können die Eigenschaft KeepTogether eines Bereichs verwenden, um diesen Bereich eines Formulars oder Berichts vollständig auf einer Seite zu drucken. So haben Sie z. B. eine Gruppe zusammengehörender Informationen, für die Sie verhindern möchten, dass sie über zwei Seiten gedruckt werden.

Anmerkung Die Eigenschaft KeepTogether betrifft nur Formular- und Berichtsbereiche (ausgenommen Seitenköpfe und Seitenfüße).

Einstellung

Die Eigenschaft KeepTogether eines Bereichs verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Wenn Microsoft Access den Bereich nicht vollständig auf der aktuellen Seite drucken kann, druckt es den Bereich ab dem Anfang der nächsten Seite.
Nein | False (0) | (Standardeinstellung) Microsoft Access druckt möglichst viel vom Bereich auf der aktuellen Seite und druckt den verbleibenden Teil auf der nächsten Seite.

Sie können diese Eigenschaft im Eigenschaftenfenster des Bereichs, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft KeepTogether eines Bereichs können Sie nur in der Formularentwurfsansicht oder der Berichtsentwurfsansicht einstellen.

Anmerkung

Ergibt sich ein Seitenwechsel, während ein Bereich gedruckt wird, setzt Microsoft Access das Drucken des Bereichs normalerweise auf der nächsten Seite fort. Mit der Eigenschaft KeepTogether können Sie dafür sorgen, dass der Bereich vollständig auf einer Seite gedruckt wird. Erstreckt sich ein Bereich über mehrere Seiten, druckt Microsoft Access ihn ab der nächsten Seite und setzt das Drucken auf den folgenden Seiten fort.

Ist die Eigenschaft KeepTogether einer Gruppe auf Ganze Gruppe oder Mit 1. Detaildatensatz und die Eigenschaft KeepTogether eines Bereichs auf Nein eingestellt, wird die Einstellung der Eigenschaft KeepTogether des Bereichs ignoriert.


 KeepTogether-Eigenschaft (Zusammenhalten) - Gruppen

KeepTogether-Eigenschaft (Zusammenhalten) - Gruppen

Mit der KeepTogether-Eigenschaft für eine Gruppe in einem Bericht können Sie Teile einer Gruppe - darunter Gruppenkopf, Detailbereich und Gruppenfuß - auf derselben Seite zusammenhalten. So soll beispielsweise ein Gruppenkopf immer auf dieselbe Seite wie der erste Detailbereich gedruckt werden.

Einstellung

Die KeepTogether-Eigenschaft einer Gruppe verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Nein | 0 | (Standardeinstellung) Druckt die Gruppe ohne Zusammenhalten von Gruppenkopf, Detailbereich und Gruppenfuß auf dieselbe Seite.
Ganze Gruppe | 1 | Druckt Gruppenkopf, Detailbereich und Gruppenfuß auf dieselbe Seite.
Mit 1. Detaildatensatz | 2 | Druckt den Gruppenkopf nur dann auf eine Seite, wenn auch der erste Detaildatensatz gedruckt werden kann.

Sie können die KeepTogether-Eigenschaft für eine Gruppe im Feld Sortieren und gruppieren, mit einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie die KeepTogether-Eigenschaft für eine Gruppe in der Entwurfsansicht für Berichte oder der Ereignisprozedur Open eines Berichts unter Verwendung der GroupLevel-Eigenschaft ein.

Anmerkungen

Um die KeepTogether-Eigenschaft für eine Gruppe auf einen anderen Wert als Nein einzustellen, müssen Sie die Eigenschaft GroupHeader bzw. GroupFooter oder beide Eigenschaften für das ausgewählte Feld oder den Ausdruck auf Ja einstellen.

Eine Gruppe umfasst Gruppenkopf, Detailbereich und Gruppenfuß. Wenn Sie die KeepTogether-Eigenschaft für eine Gruppe auf Ganze Gruppe einstellen und die Gruppe so groß ist, dass sie nicht auf eine Seite passt, ignoriert Microsoft Access die Einstellung für diese Gruppe. Wenn Sie diese Eigenschaft auf Mit 1. Detaildatensatz einstellen und der Gruppenkopf oder der Detailbereich so groß ist, dass er nicht auf eine Seite passt, wird die Einstellung ebenfalls ignoriert.

Wenn die KeepTogether-Eigenschaft für einen Bereich auf Nein und für eine Gruppe auf Ganze Gruppe oder Mit 1. Detaildatensatz eingestellt ist, wird diese Einstellung für den Bereich ignoriert.


KeyboardLanguage-Eigenschaft

Sprachspezifische Informationen

You can use the KeyboardLanguage property to specify or determine the keyboard language on entry into a control.

Setting

The KeyboardLanguage uses the following settings.

Setting | Visual Basic | Description
System | 0 | Sets the initial keyboard language to the most recently used keyboard language.
English | 11 | Sets the initial keyboard language to English.
Arabic | 3 | Sets the initial keyboard language to Arabic.
Hebrew | 15 | Sets the initial keyboard language to Hebrew.

You can set this property by using the property sheet or Visual Basic.

For more information about right-to-left properties, see Learn more about right-to-left properties in Microsoft Access 2000.


 KeyPreview-Eigenschaft (Tastenvorschau)

KeyPreview-Eigenschaft (Tastenvorschau)

Sie können die Eigenschaft KeyPreview verwenden, um anzugeben, ob die auf Formularebene für Tastaturereignisse definierten Ereignisprozeduren vor den Tastaturereignisprozeduren eines Steuerelements aufgerufen werden.

Anmerkung Die Tastaturereignisse sind KeyDown, KeyUp und KeyPress.

Einstellung

Die Eigenschaft KeyPreview verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Tastaturereignisse werden zunächst an das Formular und erst danach an das aktive Steuerelement gesendet.
Nein | False (0) | (Standardeinstellung) Tastaturereignisse werden nur an das aktive Steuerelement gesendet.

Sie können die Eigenschaft KeyPreview im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft KeyPreview in jeder Ansicht einstellen.

Anmerkung

Sie können die Eigenschaft KeyPreview verwenden, um für ein Formular eine Prozedur zu erstellen, in der Tastenfolgen verarbeitet werden. Nehmen Sie z. B. an, für eine Anwendung werden Funktionstasten verwendet. Wenn Sie die Eigenschaft KeyPreview auf True einstellen, können Sie jede Tastenfolge auf Formularebene verarbeiten und können darauf verzichten, Code für jedes Steuerelement zu schreiben, an das Tastaturereignisse gesendet werden können.

Wenn Sie Tastaturereignisse nur auf Formularebene behandeln und verhindern möchten, dass Tastaturereignisse an Steuerelemente gesendet werden, gehen Sie wie folgt vor: Stellen Sie in der KeyPress-Ereignisprozedur des Formulars das Argument KeyAscii auf 0 ein, und stellen Sie sowohl in der KeyDown- als auch der KeyUp-Ereignisprozedur des Formulars das Argument KeyCode auf 0 ein.

Hat ein Formular keine sichtbaren oder aktivierten Steuerelemente, werden keine Tastaturereignisse an das Formular gesendet.


Kind-Eigenschaft

Die Kind-Eigenschaft gibt an, welche Art von Verweis das Objekt Reference darstellt.

Einstellung

Die Eigenschaft Kind ist schreibgeschützt und kann nur von Visual Basic aus gelesen werden.

Die Eigenschaft Kind gibt die folgenden Werte zurück:

Wert | Beschreibung
Project (1) | Das Reference-Objekt stellt einen Verweis auf ein Visual Basic-Projekt dar.
TypeLib (0) | Das Reference-Objekt stellt einen Verweis auf eine Datei dar, die eine Typbibliothek enthält.


 LanguageSettings-Eigenschaft (Microsoft Access)

LanguageSettings-Eigenschaft (Microsoft Access)

Mit der LanguageSettings-Eigenschaft können Sie einen Verweis auf das aktuelle LanguageSettings-Objekt sowie dessen zugehörige Eigenschaften zurückgeben.

Einstellung

[Anwendung.]LanguageSettings[.Eigenschaft]

Die LanguageSettings-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Application | Das Application-Objekt.
LanguageSettings | Erforderlich. Wird die LanguageSettings-Eigenschaft ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie das LanguageSettings-Objekt zurück.
Eigenschaft | Eine Eigenschaft des LanguageSettings-Objekts.

Die LanguageSettings-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Nachdem Sie einen Verweis auf das LanguageSettings-Objekt eingerichtet haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Zum Festlegen eines Verweises auf das LanguageSettings-Objekt klicken Sie in der Entwurfsansicht des Moduls im Menü Extras auf Verweise. Anschließend stellen Sie einen Verweis auf die Microsoft Office 9.0 Object Library ein, indem Sie im Dialogfeld Verweise das entsprechende Kontrollkästchen aktivieren. Microsoft Access stellt diesen Verweis automatisch ein, wenn Sie eine Konstante der Microsoft Office 9.0 Object Library zum Einstellen einer Eigenschaft des LanguageSettings-Objekts oder als Argument einer Methode dieses Objekts verwenden.


 LayoutForPrint-Eigenschaft (Drucklayout)

LayoutForPrint-Eigenschaft (Drucklayout)

Mit der Eigenschaft LayoutForPrint können Sie angeben, ob das Formular oder der Bericht Drucker- oder Bildschirm-Schriftarten verwenden soll.

Einstellung

Die Eigenschaft LayoutForPrint verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung für Berichte) Verwenden von Druckerschriftarten.
Nein | False (0) | (Standardeinstellung für Berichte) Verwenden von Bildschirmschriftarten.

Sie können die Eigenschaft LayoutForPrint im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft kann nur in der Formularentwurfsansicht und in der Berichtsentwurfsansicht eingestellt werden.

Anmerkung

Beim Wählen einer Schriftart in Microsoft Access wählen Sie entweder eine Bildschirmschriftart oder eine Druckerschriftart, abhängig von der Einstellung der Eigenschaft LayoutForPrint. Druckerschriftarten und Bildschirmschriftarten können jedoch voneinander abweichen, so dass die Zeichen auf dem Bildschirm nicht immer genau mit den gedruckten Zeichen übereinstimmen.

Tipp Wenn Sie eine skalierbare Schriftart, z. B. eine TrueType-Schriftart, wählen, sind die Zeichen auf dem Bildschirm und auf der gedruckten Seite nahezu identisch.

Bildschirmschriftarten sind Abbilder von Buchstaben, Zahlen und Symbolen, die im System für die Bildschirmausgabe installiert werden. Wenn Sie einen Drucker installiert haben, sind unter Umständen automatisch zusätzliche Bildschirmschriftarten installiert worden.

Druckerschriftarten sind die Buchstaben, Zahlen und Symbole, die beim Drucken eines Berichts oder Formulars ausgegeben werden. Verfügbar sind diejenigen Schriftarten, die beim Einrichten des Druckers installiert wurden; sie sind druckerabhängig.

Stellen Sie die Eigenschaft LayoutForPrint auf Ja ein, so zeigt die Symbolleiste Formatierung (Formular/Bericht) die verfügbaren Schriftarten und Punktgrößen für Ihren Drucker an.

Wenn Sie ein Formular oder einen Bericht auf einem System mit einem anderen als dem von Ihnen eingerichteten Drucker erstellen, teilt Microsoft Access in einer Meldung mit, dass das Formular oder der Bericht für einen anderen Druckertyp erstellt worden ist. Drucken Sie das Formular oder den Bericht trotzdem, so verwendet der Drucker möglicherweise andere Schriftarten. Auch wenn Sie die Einstellung der Eigenschaft LayoutForPrint ändern, verwendet Microsoft Access möglicherweise andere Schriftarten. Sie können beispielsweise ein Formular oder einen Bericht erstellen, für das bzw. den LayoutForPrint auf Nein eingestellt ist, und dann die Einstellung auf Ja ändern. Sie können die Schriftart für jedes Steuerelement erneut auswählen, um das Aussehen des Formulars oder des Berichts festzulegen.


 Left-, Top-Eigenschaften (Links, Oben)

Left-, Top-Eigenschaften (Links, Oben)

Mit den Eigenschaften Left und Top können Sie die Position angeben, die ein Objekt auf einem Formular oder Bericht einnimmt. Sie können z. B. für ein Steuerelement festlegen, dass es immer in der oberen rechten Ecke eines Bereichs angeordnet wird.

Einstellung

Die Position eines Steuerelements ergibt sich aus dem Abstand, der zwischen dessen linker oder oberer Kante und dem linken oder oberen Rand des Bereichs gemessen wird, der das Steuerelement enthält. Ist die Eigenschaft Left oder Top auf 0 eingestellt, wird die entsprechende Kante des Steuerelements unmittelbar am linken bzw. oberen Rand des Bereichs angeordnet. Wenn Sie eine andere Maßeinheit verwenden möchten als die, die in der Windows-Systemsteuerung im Dialogfeld Eigenschaften von Ländereinstellungen festgelegt ist, geben Sie die Einheit an (z. B. 3 cm oder 2 Zoll).

In Visual Basic stellen Sie den Wert der jeweiligen Eigenschaft mit einem numerischen Ausdruck ein. Ein solcher Wert wird in Twips interpretiert.

Bei einem Steuerelement können Sie diese Eigenschaften im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei Berichten können Sie diese Eigenschaften nur einstellen, indem Sie ein Makro oder in Visual Basic eine Ereignisprozedur verwenden, während der Bericht entweder in der Seitenansicht angezeigt oder gedruckt wird.

Anmerkung

Wenn Sie ein Steuerelement verschieben, werden dessen neue Einstellungen der Eigenschaften Left und Top automatisch in das Eigenschaftenfenster eingetragen. Wenn Sie ein Formular oder einen Bericht in der Seitenansicht anzeigen oder ein Formular drucken, wird die Position eines Steuerelements dadurch bestimmt, auf welche Werte dessen Eigenschaften Left und Top sowie im Dialogfeld Seitenformat die Ränder eingestellt sind. Dieses Dialogfeld wird angezeigt, nachdem Sie im Menü Datei auf Seitenformat geklickt haben.

Bei Berichten entspricht die Einstellung der Eigenschaft Top dem Abstand, um den der aktuelle Bereich gegenüber dem Kopf der Seite versetzt ist. Die Einstellung der Eigenschaft Left entspricht dem Abstand, um den der aktuelle Bereich gegenüber dem linken Rand der Seite versetzt ist. Beide Eigenschafteneinstellungen werden in Twips ausgedrückt. In der Format-Ereignisprozedur eines Bereichs können Sie diese Eigenschaften verwenden, um anzugeben, wie weit nach unten versetzt auf einer Seite der Bereich ausgegeben werden soll.


 LimitToList-Eigenschaft (NurListeneinträge)

LimitToList-Eigenschaft (NurListeneinträge)

Sie können mit der Eigenschaft LimitToList festlegen, dass die zulässigen Werte in einem Kombinationsfeld auf die in der Liste aufgeführten Einträge beschränkt bleiben.

Einstellung

Die Eigenschaft LimitToList verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Wählt der Benutzer einen Eintrag aus der Kombinationsfeldliste aus oder gibt der Benutzer Text ein, der einem Eintrag entspricht, akzeptiert Microsoft Access dies. Eingegebener Text, der mit keinem aufgelisteten Eintrag übereinstimmt, wird nicht akzeptiert. Der Benutzer muss dann seine Eingabe wiederholen, einen Eintrag auswählen, ESC drücken oder im Menü Bearbeiten auf Rückgängig klicken.
Nein | False (0) | (Standardeinstellung) Microsoft Access akzeptiert jeden Text, der den Regeln der Eigenschaft ValidationRule genügt.

Sie können die Eigenschaft LimitToList im Eigenschaftenfenster des Kombinationsfelds, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft LimitToList automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Anmerkung

Wird die Eigenschaft LimitToList eines gebundenen Kombinationsfelds auf Nein eingestellt, können Sie in das Kombinationsfeld einen Wert eingeben, der nicht in der Liste aufgeführt ist. Microsoft Access speichert den neuen Wert in der dem Formular zugrunde liegenden Tabelle oder Abfrage (in dem Feld, das in der Eigenschaft ControlSource des Kombinationsfelds angegeben ist), und nicht in der Tabelle oder Abfrage, auf die das Kombinationsfeld über die Eigenschaft RowSource eingestellt ist. Damit neu eingegebene Werte im Kombinationsfeld angezeigt werden, fügen Sie die neuen Werte zu der Tabelle oder Abfrage hinzu, die von der Eigenschaft RowSource festgelegt ist, indem Sie ein Makro oder eine Visual Basic-Ereignisprozedur verwenden, die beim Auftreten des Ereignisses NotInList ausgeführt wird.

Anmerkung Stellen Sie die Eigenschaft BoundColumn des Kombinationsfelds auf eine andere als die erste sichtbare Spalte (oder auf 0) ein, wird die Eigenschaft LimitToList automatisch auf Ja eingestellt.

Wenn Sie die Eigenschaften LimitToList und AutoExpand auf Ja einstellen, sucht Microsoft Access in der Liste nur Zeichenfolgen aus, die mit der Eingabe des Benutzers im Textfeldteil des Kombinationsfelds übereinstimmen, und lässt bei der Eingabe nur Zeichenfolgen zu, die in der Liste vorkommen.

Wenn die Eigenschaft LimitToList auf Ja eingestellt ist und der Benutzer auf den Pfeil neben dem Kombinationsfeld klickt, wählt Microsoft Access in der Liste genau die Zeichenfolgen aus, die mit der fortlaufenden Eingabe des Benutzers im Textfeldteil des Kombinationsfelds übereinstimmen, selbst wenn die Eigenschaft AutoExpand auf Nein eingestellt ist. Drückt der Benutzer die EINGABETASTE oder wechselt er zu einem anderen Steuerelement oder Datensatz, wird der ausgewählte Wert im Kombinationsfeld angezeigt.

Kombinationsfelder nehmen Null-Werte an, wenn die Eigenschaft LimitToList auf Ja oder True gesetzt ist, egal ob die Liste Null-Werte enthält oder nicht. Wenn Benutzer daran gehindert werden sollen, einen Null-Wert in ein Kombinationsfeld einzugeben, stellen Sie die Eigenschaft Required des Feldes in der Tabelle, an die das Kombinationsfeld gebunden ist, auf Ja ein.


 Lines-Eigenschaft

Lines-Eigenschaft

Die Eigenschaft Lines gibt eine Zeichenfolge zurück, die aus dem Inhalt einer oder mehrerer Zeilen eines Standardmoduls oder eines Klassenmoduls besteht.

Einstellung

Objekt.Lines(Zeile, AnzahlZeilen)

Die Eigenschaft Lines verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Objekt | Ein Module-Objekt.
Zeile | Ein Wert des Datentyps Long, der die Zeilennummer der Zeile angibt, die als erste zurückgegeben werden soll.
AnzahlZeilen | Ein Wert des Datentyps Long, der angibt, wie viele Zeilen zurückgegeben werden sollen.

Die Eigenschaft Lines steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Nummerierung der Zeilen eines Moduls beginnt mit 1. Wenn Sie z. B. die Eigenschaft Lines lesen und dabei für das Argument Zeile eine 1 und für das Argument AnzahlZeilen eine 1 angeben, gibt die Eigenschaft Lines eine Zeichenfolge zurück, die den Text der ersten Zeile des entsprechenden Moduls enthält.

Mit der Methode InsertLines können Sie Textzeilen in ein Modul einfügen.


 LineSlant-Eigenschaft (Neigung)

LineSlant-Eigenschaft (Neigung)

Mit der LineSlant-Eigenschaft können Sie angeben, ob ein Linie-Steuerelement von oben links nach unten rechts oder von oben rechts nach unten links geneigt ist.

Einstellung

Die LineSlant-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
\ | False (0) | (Standardeinstellung) Von oben links nach unten rechts
/ | True (-1) | Von oben rechts nach unten links

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, mit einem Makro oder in Visual Basic einstellen.

Anmerkung

Mit der LineSlant-Eigenschaft können Sie die Richtung einer Linie ändern. Um die Linie im Formular oder Bericht zu positionieren oder ihre Länge zu ändern, verwenden Sie die Maus.


 LineSpacing-Eigenschaft (Zeilenabstand)

LineSpacing-Eigenschaft (Zeilenabstand)

Mit der LineSpacing-Eigenschaft können Sie die Position angeben oder ermitteln, an der Daten in einem Bezeichnungsfeld- oder Textfeld-Steuerelement angezeigt werden. So können Sie beispielsweise festlegen, dass Informationen in einem Textfeld-Steuerelement mit 0.25 Zoll Zwischenraum zwischen jeder Textzeile im Steuerelement angezeigt werden.

Einstellung

Die Position der in einem Steuerelement angezeigten Information ist der Abstand zwischen den Zeilen der angezeigten Information. Um eine andere als die im Dialogfeld Ländereinstellungen in der Windows-Systemsteuerung eingestellte Maßeinheit zu verwenden, geben Sie die die gewünschte Einheit, etwa cm oder Zoll, an (z. B. 3 cm oder 2 Zoll).

In Visual Basic geben Sie den Wert für diese Eigenschaft mit einem numerischen Ausdruck an. Werte werden in Twips ausgedrückt.

Sie können diese Eigenschaften im Eigenschaftenfenster, in einem Makro oder in Visual Basic festlegen.


 LinkChildFields-, LinkMasterFields-Eigenschaften (VerknüpfenVon, VerknüpfenNach)

LinkChildFields-, LinkMasterFields-Eigenschaften (VerknüpfenVon, VerknüpfenNach)

Sie können mit den Eigenschaften LinkChildFields und LinkMasterFields festlegen, wie Microsoft Access Datensätze in einem Formular oder Bericht mit Datensätzen in einem Unterformular, Unterbericht oder eingebetteten Objekt, wie z. B. einem Diagramm, verknüpft. Falls diese Eigenschaften eingestellt sind, aktualisiert Microsoft Access automatisch die verknüpften Datensätze im Unterformular, wenn Sie zu einem neuen Datensatz in einem Hauptformular wechseln.

Einstellung

Sie können die Eigenschaften LinkChildFields und LinkMasterFields für das Unterformular, den Unterbericht oder das eingebettete Objekt folgendermaßen einstellen:

  • Die Eigenschaft LinkChildFields. Geben Sie die Namen der Felder des Unterformulars, Unterberichts oder eingebetteten Objekts an, die als Verknüpfungsfelder dienen sollen.

  • Die Eigenschaft LinkMasterFields. Geben Sie die Namen der Felder oder Steuerelemente des Hauptformulars oder Hauptberichts an, die als Verknüpfungsfelder bzw. -steuerelemente dienen sollen.

Sie können den Feldverknüpfungs-Assistenten für Unterformulare/Unterberichte verwenden, um diese Eigenschaften einzustellen, indem Sie auf die Generator-Schaltfläche [image] rechts neben der Eigenschaft im Eigenschaftenfenster klicken.

Sie können diese Eigenschaften auch über einen Zeichenfolgeausdruck in einem Makro oder Visual Basic einstellen.

Die Eigenschaften können nur in der Entwurfsansicht oder während des Ereignisses Open eines Formulars oder Berichts eingestellt werden.

Anmerkung

Die Felder oder Steuerelemente, die Sie zum Einstellen dieser Eigenschaften verwenden, brauchen nicht dieselben Namen zu haben, sie müssen jedoch bezüglich der Daten identische oder kompatible Felddatentypen und Feldgrößen besitzen. Ein Feld des Datentyps AutoWert ist z. B. kompatibel mit einem Feld des Datentyps Zahl, wenn die Eigenschaft Feldgröße für das Zahlenfeld auf Long Integer eingestellt ist.

Sie können den Namen eines Steuerelements (einschließlich des Namens eines berechneten Steuerelements) zum Einstellen der Eigenschaft LinkMasterFields, jedoch nicht zum Einstellen der Eigenschaft LinkChildFields verwenden. Wenn Sie einen berechneten Wert als Verknüpfung für ein Unterformular, einen Unterbericht oder ein eingebettetes Objekt verwenden möchten, definieren Sie in der dem untergeordneten Objekt zugrunde liegenden Abfrage ein berechnetes Feld, und stellen Sie die Eigenschaft LinkChildFields auf das Feld ein.

Wenn Sie mehr als einen Feld- oder Steuerelementnamen für diese Eigenschafteneinstellungen angeben, müssen Sie dieselbe Anzahl von Feldern oder Steuerelementen für beide Eigenschaften, durch Semikolons (;) voneinander getrennt, angeben.

Wenn Sie ein Unterformular oder einen Unterbericht aus dem Datenbankfenster in ein anderes Formular oder einen anderen Bericht ziehen, um ein Formular oder einen Bericht zu erstellen, oder wenn Sie dazu den Formular-Assistenten verwenden, stellt Microsoft Access die Eigenschaften LinkChildFields und LinkMasterFields unter den folgenden Bedingungen automatisch ein:

  • Sowohl das Hauptformular oder der Hauptbericht als auch das untergeordnete Objekt basieren auf Tabellen, und mit dem Befehl Beziehungen wurde eine Beziehung definiert. Microsoft Access verwendet die Felder, die die Beziehung zwischen den beiden Tabellen herstellen, als Verknüpfungsfelder.

  • Das Hauptformular oder der Hauptbericht basiert auf einer Tabelle mit einem Primärschlüssel, und das Unterformular oder der Unterbericht basiert auf einer Tabelle oder Abfrage, die ein Feld enthält, das denselben Namen besitzt und denselben oder einen kompatiblen Datentyp hat wie dieser Primärschlüssel. Microsoft Access verwendet als Verknüpfungsfelder den Primärschlüssel der Tabelle, die dem Hauptobjekt zugrunde liegt, und das namensgleiche Feld der Tabelle oder Abfrage, die dem untergeordneten Objekt zugrunde liegt.

Anmerkung Die Verknüpfungsfelder müssen nicht in dem Hauptobjekt oder dem untergeordneten Objekt enthalten sein. Solange diese Felder in den den Objekten zugrunde liegenden Tabellen oder Abfragen enthalten sind, können Sie diese Felder zum Verknüpfen der Objekte verwenden. Verwenden Sie einen Assistenten, schließt Microsoft Access die Verknüpfungsfelder automatisch ein.


 ListCount-Eigenschaft

ListCount-Eigenschaft

Mit der Eigenschaft ListCount können Sie feststellen, wie viele Zeilen ein Listenfeld oder der Listenfeldteil eines Kombinationsfelds enthält.

Einstellung

Microsoft Access stellt die Eigenschaft ListCount auf die Anzahl der Zeilen im Listenfeld oder im Listenfeldteil des Kombinationsfelds ein. Der Wert der Eigenschaft ListCount ist schreibgeschützt und kann daher nicht vom Benutzer eingestellt werden.

Diese Eigenschaft ist nur in einem Makro oder in Visual Basic verfügbar. Sie können diese Eigenschaft nur in der Formularansicht und der Datenblattansicht lesen.

Anmerkung

Die Eigenschaft ListCount enthält die Gesamtanzahl der Zeilen in der Kombinationsfeldliste oder im Listenfeld, wie mit den Eigenschaften RowSource und RowSourceType des Steuerelements festgelegt. Wenn das Steuerelement auf einer Tabelle oder Abfrage basiert (d. h., die Eigenschaft RowSourceType ist auf Tabelle/Abfrage und die Eigenschaft RowSource auf eine bestimmte Tabelle oder Abfrage eingestellt), enthält die Eigenschaft ListCount die Anzahl der Datensätze der Tabelle bzw. der Ergebnisgruppe. Ist die Eigenschaft RowSourceType auf Wertliste eingestellt, gibt die Eigenschaft ListCount an, wie viele Zeilen die in der Eigenschaft RowSource angegebene Wertliste enthält (diese Anzahl hängt von der Wertliste und der Anzahl der Spalten im Listenfeld oder in der Kombinationsfeldliste ab, wie mit der Eigenschaft ColumnCount eingestellt).

Wenn Sie die Eigenschaft ColumnHeads auf Ja einstellen, wird die Zeile mit den Spaltenüberschriften bei der Anzahl der Zeilen, die die Eigenschaft ListCount zurückgibt, mitgezählt. Für Kombinations- und Listenfelder, die auf einer Tabelle oder Abfrage basieren, wird durch Hinzufügen von Spaltenüberschriften eine Zeile hinzugefügt. Für Kombinations- und Listenfelder, die auf einer Wertliste basieren, ändert sich die Zeilenanzahl nicht (die erste Datenzeile wird für die Spaltenüberschriften verwendet).

Sie können die Eigenschaft ListCount gemeinsam mit der Eigenschaft ListRows verwenden, um festzulegen, wie viele Zeilen im Listenfeldteil eines Kombinationsfelds angezeigt werden sollen.


 ListIndex-Eigenschaft

ListIndex-Eigenschaft

Mit der Eigenschaft ListIndex können Sie herausfinden, welches Element in einem Listenfeld oder Kombinationsfeld ausgewählt ist.

Einstellung

Die Eigenschaft ListIndex enthält eine Ganzzahl zwischen 0 und der maximalen Anzahl der Einträge in einem Listen- oder Kombinationsfeld minus 1. Microsoft Access stellt den Wert der Eigenschaft ListIndex ein, sobald ein Eintrag in einem Listenfeld oder in einem Listenfeldteil eines Kombinationsfelds ausgewählt wurde. Der Wert von ListIndex für den ersten Eintrag einer Liste ist 0, der Wert für den zweiten Eintrag ist 1 usw.

Diese Eigenschaft ist nur in einem Makro oder in Visual Basic verfügbar. Sie können diese Eigenschaft nur in der Formularansicht und der Datenblattansicht lesen. Die Eigenschaft ist schreibgeschützt und in anderen Ansichten nicht verfügbar.

Anmerkung

Der Wert der Eigenschaft ListIndex ist auch verfügbar, indem die Eigenschaft BoundColumn für ein Kombinations- oder Listenfeld auf 0 eingestellt wird. In diesem Fall enthält das zugrunde liegende Tabellenfeld, an das das Kombinations- oder Listenfeld gebunden ist, den gleichen Wert wie die Eigenschaft ListIndex.

Listenfelder haben auch die Eigenschaft MultiSelect, die dem Benutzer die Auswahl mehrerer Elemente aus dem Steuerelement gestattet. Wurden mehrere Auswahlen in einem Listenfeld getätigt, so können Sie mit der Eigenschaft Selected des Steuerelements feststellen, welche Einträge ausgewählt sind. Die Eigenschaft Selected ist ein Datenfeld mit Werten zwischen 0 und dem Wert der Eigenschaft ListCount minus 1. Die Eigenschaft Selected hat für jedes im Listenfeld ausgewählte Element den Wert True (-1) und für jedes nicht ausgewählte Element den Wert False (0).

Die Auflistung ItemsSelected bietet ebenfalls eine Möglichkeit, auf Daten in ausgewählten Zeilen eines Listenfelds oder Kombinationsfelds zuzugreifen.


 ListRows-Eigenschaft (Zeilenanzahl)

ListRows-Eigenschaft (Zeilenanzahl)

Mit der Eigenschaft ListRows können Sie einstellen, wie viele Zeilen höchstens im Listenfeldteil eines Kombinationsfelds angezeigt werden sollen.

Einstellung

Die Eigenschaft ListRows enthält eine Ganzzahl, die angibt, wie viele Zeilen maximal angezeigt werden sollen. Die Standardeinstellung ist 8. Die zulässigen Werte für die Eigenschaft ListRows liegen zwischen 1 und 255.

Sie können die Eigenschaft ListRows im Eigenschaftenfenster des Kombinationsfelds, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft ListRows automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Stellen Sie den Wert dieser Eigenschaft in Visual Basic unter Verwendung eines numerischen Ausdrucks ein.

Sie können die Standardeinstellung dieser Eigenschaft auch in den Standardeigenschafteneinstellungen eines Kombinationsfelds oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Überschreitet die aktuelle Zeilenanzahl die in der Einstellung der Eigenschaft ListRows angegebene Anzahl, wird eine vertikale Bildlaufleiste im Listenfeldteil des Kombinationsfelds angezeigt.


 ListWidth-Eigenschaft (Listenbreite)

ListWidth-Eigenschaft (Listenbreite)

Mit der Eigenschaft ListWidth können Sie die Breite des Listenfeldteils eines Kombinationsfelds einstellen.

Einstellung

Die Eigenschaft ListWidth enthält die Breite des Listenfeldteils eines Kombinationsfelds in Zoll oder Zentimetern, abhängig vom Maßsystem (Metrisch oder US-Maße), das in der Systemsteuerung von Windows 95 im Dialogfeld Ländereinstellungen auf der Registerkarte Zahlen im Feld Maßsystem ausgewählt ist. Wenn Sie die eingestellte Standardmaßeinheit nicht verwenden möchten, geben Sie zusätzlich die gewünschte Maßeinheit, wie cm oder Zoll, an. Mit der Standardeinstellung (Automatisch) wird der Listenfeldteil des Kombinationsfelds genauso breit wie das Kombinationsfeld.

Sie können die Eigenschaft ListWidth im Eigenschaftenfenster des Kombinationsfelds, in einem Makro oder in Visual Basic einstellen.

Bei Tabellenfeldern können Sie diese Eigenschaft in der Tabellenentwurfsansicht im Abschnitt Feldeigenschaften auf der Registerkarte Nachschlagen für Felder einstellen, deren Eigenschaft DisplayControl auf Kombinationsfeld eingestellt ist.

Tipp Microsoft Access stellt die Eigenschaft ListWidth automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Stellen Sie den Wert dieser Eigenschaft in Visual Basic unter Verwendung eines numerischen Ausdrucks ein. Die Standardmaßeinheit in Visual Basic ist Twips.

Sie können die Standardeinstellung dieser Eigenschaft auch in den Standardeigenschafteneinstellungen eines Kombinationsfelds oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Der Listenteil des Kombinationsfelds kann breiter, aber nicht schmaler als das Kombinationsfeld selbst sein.

Wenn Sie eine Liste mit mehreren Spalten anzeigen möchten, geben Sie einen entsprechend großen Wert an, damit alle Spalten im Listenfeld angezeigt werden können.

Tipp Achten Sie beim Erstellen von Kombinationsfeldern darauf, dass genügend Platz zur Anzeige Ihrer Daten und der von Microsoft Access eingefügten vertikalen Bildlaufleiste verfügbar ist.


 LocationOfComponents-Eigenschaft

LocationOfComponents-Eigenschaft

Mit der LocationOfComponents-Eigenschaft können Sie den zentralen URL bzw. Pfad angeben oder ermitteln, von wo autorisierte Benutzer beim Anzeigen Ihrer gespeicherten Datenbank Microsoft Office-Steuerelemente downloaden können.

Einstellung

Die LocationOfComponents-Eigenschaft ist ein Zeichenfolgenausdruck, der nur bei Verwendung von Visual Basic verfügbar ist.

Anmerkungen

Die Microsoft Office-Steuerelemente werden automatisch mit der Webseite gedownloadet, wenn die DownloadComponents-Eigenschaft auf True eingestellt ist, die Komponenten nicht bereits installiert sind, der Pfad gültig ist und auf einen Speicherort verweist, der die erforderlichen Komponenten enthält, und der Benutzer über eine gültige Microsoft Office 2000-Lizenz verfügt.


 LogMessages-Eigenschaft (MeldungenProtokollieren) (Microsoft Access)

LogMessages-Eigenschaft (MeldungenProtokollieren) (Microsoft Access)

Sie können die LogMessages-Eigenschaft in einer SQL Pass-Through-Abfrage verwenden, um anzugeben, ob die von einer SQL-Datenbank zurückgegebenen Meldungen in einer Meldungstabelle in der aktuellen Microsoft Access-Datenbank gespeichert werden sollen.

Anmerkung Die LogMessages-Eigenschaft gilt nur für Pass-Through-Abfragen.

Einstellung

Die LogMessages-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Microsoft Access speichert von der SQL-Datenbank zurückgegebene Meldungen in einer Meldungstabelle.
Nein | False (0) | (Standardeinstellung) Microsoft Access speichert von einer SQL-Datenbank zurückgegebene Meldungen nicht.

Sie können diese Eigenschaft im Abfrage-Eigenschaftenfenster oder in Visual Basic festlegen.

Anmerkungen

Der Name der Meldungstabelle, in der die zurückgegebenen Meldungen gespeichert werden, ist Benutzername - nn, wobei Benutzername den Anmeldenamen des Benutzers darstellt, der die Pass-Through-Abfrage ausführt, und nn einen Wert vom Typ Integer, der jeweils um 1 erhöht wird und mit 00 beginnt. Legt z. B. die Benutzerin AnetteS die LogMessages-Eigenschaft auf Ja fest, und erhält diese Benutzerin Meldungen von einer SQL-Datenbank, so erhält die Meldungstabelle den Namen AnnetteS - 00. Erhält AnnetteS Meldungen in einer anderen Microsoft Access-Sitzung (und wurde die erste Tabelle nicht gelöscht), so wird eine neue Tabelle mit dem Namen AnnetteS - 01 erstellt.

Anmerkung Fehlermeldungen vom SQL-Server werden nicht in der Meldungstabelle gespeichert.


 lpOLEObject-Eigenschaft

lpOLEObject-Eigenschaft

Mit der Eigenschaft lpOLEObject können Sie in Visual Basic die Arbeitsspeicheradresse eines OLE-Objekts ermitteln. Die Eigenschaft lpOLEObject gibt einen Zeiger auf IOLEObject zurück.

Einstellung

Sie können die Eigenschaft lpOLEObject verwenden, um auf die Adresse des aktiven Objekts zu verweisen. Wird kein Objekt angezeigt, lautet die Einstellung 0. Die Einstellung der Eigenschaft lpOLEObject ist ein Wert des Datentyps Long und wird von Microsoft Access festgelegt.

Diese Eigenschaft steht in der Entwurfsansicht nicht zur Verfügung und ist in den anderen Ansichten schreibgeschützt.

Anmerkung

Für viele Funktionen der zu OLE gehörenden Dynamic Link Libraries (DLLs) ist es erforderlich, dass ihnen beim Aufrufen die Adresse des jeweiligen OLE-Objekts als Argument übergeben wird. Wenn Sie eine Funktion einer OLE-DLL über das API (Application Programming Interface) aufrufen, können Sie den Wert übergeben, den die Eigenschaft lpOLEObject angibt.

Anmerkung Wird über das API eine DLL-Funktion aufgerufen, die ihrerseits wieder das Steuerelement aufruft, sind die Ergebnisse unvorhersehbar.


 Major-Eigenschaft

Major-Eigenschaft

Die Eigenschaft Major eines Reference-Objekts gibt einen Wert des Datentyps Long zurück, der den Hauptteil der Versionsnummer einer Anwendung angibt, zu der Sie einen Verweis aktiviert haben.

Einstellung

Die Eigenschaft Major steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Eigenschaft Major gibt den Wert zurück, der in einer Versionsnummer links vom Dezimalpunkt steht. Wenn Sie z. B. einen Verweis auf eine Anwendung aktiviert haben, die die Versionsnummer 2.5 hat, gibt die Eigenschaft Major den Wert 2 zurück.


 MaxRecButton-Eigenschaft

MaxRecButton-Eigenschaft

Mit der MaxRecButton-Eigenschaft können Sie angeben oder ermitteln, ob die Schaltfläche Max. Datensätze in der Navigationsleiste eines Formulars in der Datenblattansicht oder Formularansicht verfügbar ist.

Anmerkung Diese Eigenschaft steht nur bei Formularen in einem Microsoft Access-Projekt (.adp) zur Verfügung.

Einstellung

Die MaxRecButton-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Schaltfläche Max. Datensätze ist für Benutzer verfügbar.
Nein | False (0) | Die Schaltfläche Max. Datensätze ist nicht verfügbar.

Sie können diese Eigenschaft im Eigenschaftenfenster oder mit Visual Basic festlegen.


 MaxRecords-Eigenschaft (MaxDatensätze)

MaxRecords-Eigenschaft (MaxDatensätze)

Mit Hilfe der Eigenschaft MaxRecords können Sie angeben oder ermitteln, wie viele Datensätze höchstens zurückgegeben werden bei:

  • Einer Abfrage, die Daten von einer ODBC-Datenbank an eine Microsoft Access-Datenbank (.mdb) zurückgibt.

  • Einer Sicht, die Daten von einer SQL-Datenbank an ein Microsoft Access-Projekt (.adp) zurückgibt.

Einstellung

Die Einstellung der Eigenschaft MaxRecords ist ein Wert des Datentyps Long Integer, der die Anzahl der zurückgegebenen Datensätze angibt.

In einer Microsoft Access-Datenbank können Sie diese Eigenschaft im Eigenschaftenfenster der Abfrage oder in Visual Basic festlegen.

In Visual Basic legen Sie diese Eigenschaft mit der ADO-Methode MaxRecords fest.

Anmerkung

Die Datensätze werden in der Reihenfolge zurückgegeben, die durch die ORDER BY-Klausel der Abfrage festgelegt ist.

Sie können die Eigenschaft MaxRecords immer dann verwenden, wenn die Anzahl der zurückgegebenen Datensätze infolge begrenzter Systemressourcen eingeschränkt wird.


 MDE-Eigenschaft

MDE-Eigenschaft

Mit der Eigenschaft MDE können Sie ermitteln, ob eine Datei als .MDE-Datei gespeichert wurde.

Anmerkung Diese Eigenschaft ist nur bei Microsoft Access-Datenbanken (.mdb) verfügbar.

Einstellung

Wenn eine Datenbank als .MDE-Datei gespeichert wird, fügt Microsoft Access die Eigenschaft MDE zu der Datenbank hinzu und stellt diese Eigenschaft auf den String-Wert T ein.

Die Eigenschaft MDE kann nur in Visual Basic ausgewertet werden und ist in allen Ansichten schreibgeschützt.

Wichtig Wenn versucht wird, die Eigenschaft MDE für eine Datenbank auszuwerten, die nicht als .MDE-Datei gespeichert wurde, wird der Laufzeitfehler 3270 ("Eigenschaft nicht gefunden") verursacht. Die Eigenschaft MDE gibt es nicht in einer Datenbank, wenn die Datenbank nicht als .MDE-Datei gespeichert wurde.

Anmerkung

Sie können eine Datenbank in eine .MDE-Datei umwandeln, indem Sie im Menü Extras auf Datenbank-Dienstprogramme zeigen und auf MDE-Datei erstellen klicken. Wenn Sie eine Datenbank als .MDE-Datei speichern, löscht Microsoft Access den gesamten bearbeitbaren Quellcode, kompiliert alle Module und komprimiert die Datenbank. Ihr Visual Basic-Code funktioniert zwar weiterhin, kann aber weder angezeigt noch geändert werden. Außerdem können keine Formular- oder Berichtsobjekte hinzugefügt oder geändert werden.

Warnung Achten Sie darauf, eine Kopie Ihrer Originaldatenbank zu behalten. Falls Sie den Code oder den Entwurf von Objekten in einer .mde-Datenbank verändern möchten, müssen Sie diese Änderungen in der Originaldatenbank vornehmen und anschließend eine neue .mde-Datenbank erstellen. Sie werden die Originaldatenbank ebenfalls benötigen, um in zukünftige Versionen von Microsoft Access zu konvertieren, weil .mde-Dateien nicht direkt konvertiert werden können.

Eine Datenbank als .MDE-Datei zu speichern, bietet sich immer dann an, wenn Sie verhindern möchten, dass Änderungen an den Formularen oder Berichten vorgenommen werden oder dass die Datenbankbenutzer Zugang zu Ihrem Visual Basic-Code haben. Sie können eine Datenbank auch in eine .MDE-Datei umwandeln, wenn Sie Ihre eigenen Assistenten erstellen oder für den Front-End-Teil einer Front-End/Back-End-Anwendung.

Eine replizierte Datenbank kann nicht als .MDE-Datei gespeichert werden. Aber eine als .MDE-Datei gespeicherte Datenbank kann repliziert werden.


 Me-Eigenschaft

Me-Eigenschaft

Sie können die Eigenschaft Me in Visual Basic verwenden, um auf das Formular, den Bericht oder das Klassenmodul zu verweisen, in dem momentan Visual Basic-Code ausgeführt wird. Dies kann auch das Formular oder der Bericht sein, das bzw. der mit einem Unterformular oder Unterbericht verknüpft ist, in dem momentan Visual Basic-Code ausgeführt wird.

Einstellung

Die Eigenschaft Me ist nur in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung

Die Eigenschaft Me enthält eine Objektreferenz auf das aktuelle Formular oder den aktuellen Bericht und ist schneller als eine qualifizierte Objektreferenz. Die folgenden zwei Konstrukte beziehen sich zum Beispiel auf den Wert des Steuerelements Nachname für den aktuellen Datensatz im Formular Personal:

strNachname = Formulare!Personal.Nachname
strNachname = Me!Nachname

In den meisten Fällen bezieht sich die Eigenschaft Me auf dasselbe Formular bzw. denselben Bericht wie die Eigenschaften ActiveForm oder ActiveReport des Screen-Objekts. Diese Eigenschaften beziehen sich jedoch auf das Formular bzw. den Bericht mit dem Fokus, während sich die Eigenschaft Me immer auf das Formular bzw. den Bericht bezieht, in dem Code ausgeführt wird. Das Ereignis Timer kann z.B. in einem Formular eintreten, das nicht den Fokus besitzt. In diesem Fall bezieht sich der Code Screen.ActiveForm auf das Formular mit dem Fokus und die Eigenschaft Me auf das Formular, in dem das Ereignis Timer eingetreten ist. Deshalb sollte beim Erstellen von allgemeinen Prozeduren, die Operationen auf dem aktuellen Formular ausführen, das Formular mit Hilfe der Eigenschaft Me an die Prozedur übergeben werden, anstatt mit Hilfe der Eigenschaft ActiveForm.

Sie können mit dem Schlüsselwort Me in Klassenmodulen auf die aktuelle Instanz der betreffenden Klassen verweisen. Genauso wie Sie Me in Formular- und Berichtsklassenmodulen verwenden, um einen Verweis auf das aktuelle Formular bzw. den aktuellen Bericht abzurufen, können Sie mit Me in einem Klassenmodul einen Verweis auf das aktuelle Klassenmodulobjekt abrufen.


 MenuBar-Eigenschaft (Menüleiste)

MenuBar-Eigenschaft (Menüleiste)

Mit der MenuBar-Eigenschaft können Sie die Menüleiste angeben, die für eine Microsoft Access-Datenbank (.mdb), ein Microsoft Access-Projekt (.adp), ein Formular oder einen Bericht verwendet werden soll. Sie erstellen diese Menüleisten mit dem Unterbefehl Anpassen des Befehls Symbolleisten im Menü Ansicht. Weitere Informationen zum Erstellen benutzerdefinierter Symbolleisten finden Sie unter Erstellen einer benutzerdefinierten Menüleiste für die aktuelle Datenbank.

Außerdem können Sie mit der MenuBar-Eigenschaft das Menüleistenmakro angeben, das zum Anzeigen einer benutzerdefinierten Menüleiste für eine Datenbank, ein Formular oder einen Bericht verwendet wird.

Anmerkung In früheren Microsoft Access-Versionen haben Sie eine benutzerdefinierte Symbolleiste erstellt, indem Sie die MenuBar-Eigenschaft auf den Namen eines Menüleistenmakros eingestellt haben. Anschließend haben Sie Makrogruppen erstellt, die die Befehle für die Menüs dieser Menüleiste enthielten. Diese Funktionalität wird in Access9TBD weiterhin unterstützt. Es ist jedoch dringend angeraten, dass Sie benutzerdefinierte Menüleisten mit dem neuen Dialogfeld Anpassen erstellen, das Sie durch Klicken auf Symbolleisten im Menü Ansicht öffnen können.

Einstellung

Geben Sie den Namen der anzuzeigenden Menüleiste ein. Wenn Sie die MenuBar-Eigenschaft nicht angeben, zeigt Microsoft Access die eingebaute Menüleiste (Standardmenüleiste) oder die globale Menüleiste der Anwendung an. Wenn Sie die MenuBar-Eigenschaft auf einen Wert einstellen, der nicht der Name einer vorhandenen Menüleiste oder eines Menüleistenmakros ist, gibt es für das Formular oder den Bericht keine Menüleiste (die Standardmenüleiste wird nicht angezeigt).

Sie können diese Eigenschaft im Eigenschaftenfenster des Objekts, mit einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft mit einem Zeichenfolgenausdruck ein, der den Namen der anzuzeigenden Menüleiste darstellt.

Wenn Sie bei einer Datenbank, einem Formular oder einem Bericht die eingebaute Menüleiste oder die globale Menüleiste mit einem Makro oder in Visual Basic anzeigen möchten, stellen Sie die Eigenschaft auf eine leere Zeichenfolge (" ") ein.

Anmerkung

Wenn Sie die MenuBar-Eigenschaft bei Formularen oder Berichten verwenden, zeigt Microsoft Access die angegebene Menüleiste an, sobald das Formular oder der Bericht geöffnet ist. Diese Menüleiste wird danach immer dann angezeigt, wenn das Formular oder der Bericht den Fokus hat.

Bei Verwendung mit dem Application-Objekt ermöglicht Ihnen die MenuBar-Eigenschaft das Anzeigen einer benutzerdefinierten Menüleiste für die gesamte Datenbank. Haben Sie MenuBar jedoch für ein Formular oder einen Bericht in der Datenbank eingestellt, wird statt der benutzerdefinierten Menüleiste der Datenbank die benutzerdefinierte Menüleiste des Formulars bzw. Berichts immer dann angezeigt, wenn dieses/dieser den Fokus hat. Wenn das Formular bzw. der Bericht den Fokus abgibt, wird die benutzerdefinierte Menüleiste für die Datenbank angezeigt.

Anmerkung Sie können zwischen der benutzerdefinierten Menüleiste einer Datenbank und der eingebauten Menüleiste wechseln, indem Sie STRG+F11 drücken.


 MinMaxButtons-Eigenschaft (MinMaxSchaltflächen)

MinMaxButtons-Eigenschaft (MinMaxSchaltflächen)

Mit der Eigenschaft MinMaxButtons können Sie angeben, ob die Maximieren- oder Minimieren-Schaltflächen in einem Formular sichtbar sein sollen.

Einstellung

Die Eigenschaft MinMaxButtons verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keine | 0 | Das Formular verfügt nicht über die Maximieren- und Minimieren-Schaltflächen.
Min vorhanden | 1 | Nur die Minimieren-Schaltfläche ist verfügbar.
Max vorhanden | 2 | Nur die Maximieren-Schaltfläche ist verfügbar.
Beide vorhanden | 3 | (Standardeinstellung) Die Maximieren- und Minimieren-Schaltflächen sind beide verfügbar.

Sie können die Eigenschaft MinMaxButtons im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Sie können diese Eigenschaft nur in der Formularentwurfsansicht einstellen.

Anmerkung

Das Klicken auf die Maximieren-Schaltfläche eines Formulars vergrößert das Formular, so dass es das Microsoft Access-Fenster vollständig ausfüllt. Das Klicken auf die Minimieren-Schaltfläche eines Formulars verkleinert das Formular zu einer kleinen Titelleiste ganz unten im Microsoft Access-Fenster.

Damit die Maximieren- und Minimieren-Schaltflächen in einem Formular angezeigt werden, stellen Sie die Eigenschaft BorderStyle des Formulars auf Dünn oder Veränderbar und die Eigenschaft ControlBox auf Ja ein. Wenn Sie die Eigenschaft BorderStyle auf Keine oder Dialog oder die Eigenschaft ControlBox auf Nein einstellen, enthält das Formular weder die Maximieren- noch die Minimieren-Schaltfläche, unabhängig von der Einstellung der Eigenschaft MinMaxButtons.

Auch wenn die Eigenschaft MinMaxButtons auf Keine eingestellt ist, verfügt ein Formular in der Entwurfsansicht immer über die Maximieren- und Minimieren-Schaltflächen.

Ist die Eigenschaft MinMaxButtons eines Formulars auf Keine eingestellt, so sind die Befehle Maximieren und Minimieren im Systemmenü des Formulars nicht verfügbar.


 Minor-Eigenschaft

Minor-Eigenschaft

Die Eigenschaft Minor eines Reference-Objekts gibt einen Wert des Datentyps Long zurück, der den Nebenteil der Versionsnummer einer Anwendung angibt, zu der Sie einen Verweis aktiviert haben.

Einstellung

Die Eigenschaft Minor steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Eigenschaft Minor gibt den Wert zurück, der in einer Versionsnummer rechts vom Dezimalpunkt steht. Wenn Sie z. B. einen Verweis auf eine Anwendung aktiviert haben, die die Versionsnummer 2.5 hat, gibt die Eigenschaft Minor den Wert 5 zurück.


 MitDoppelpunkt-, MitBezeichnungsfeld-Eigenschaften

MitDoppelpunkt-, MitBezeichnungsfeld-Eigenschaften

  • Die Eigenschaft MitDoppelpunkt gibt an, ob ein Doppelpunkt hinter den Text des Bezeichnungsfelds eines neuen Steuerelements gesetzt werden soll.

  • Die Eigenschaft MitBezeichnungsfeld gibt an, ob für ein neues Steuerelement automatisch ein Bezeichnungsfeld erstellt wird, das dem Steuerelement zugeordnet wird.

Einstellung

Die Eigenschaft MitDoppelpunkt verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Hinter den Text des Bezeichnungsfelds eines neuen Steuerelements wird ein Doppelpunkt gesetzt.
Nein | Hinter den Text des Bezeichnungsfelds eines neuen Steuerelements wird kein Doppelpunkt gesetzt.

Die Eigenschaft MitBezeichnungsfeld verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Einem neuen Steuerelement wird ein Bezeichnungsfeld zugeordnet.
Nein | Einem neuen Steuerelement wird kein Bezeichnungsfeld zugeordnet.

Sie können diese Eigenschaften nur mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Änderungen an den Standardeigenschafteneinstellungen betreffen nur die Steuerelemente, die auf dem aktuellen Formular oder Bericht erstellt wurden. Informationen dazu, wie die Standardeigenschafteneinstellungen für alle neuen Formulare oder Berichte geändert werden können, die Sie ohne einen Microsoft Access-Assistenten erstellen, finden Sie unter Angeben einer neuen Vorlage für Formulare und Berichte.


 Modal-Eigenschaft (Gebunden)

Modal-Eigenschaft (Gebunden)

Mit der Eigenschaft Modal können Sie angeben, ob ein Formular als gebundenes Formular geöffnet wird. Ist dies der Fall, schließen Sie das Formular, bevor Sie den Fokus auf ein anderes Objekt verschieben können.

Einstellung

Die Eigenschaft Modal verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular wird als gebundenes Formular in der Formularansicht geöffnet.
Nein | False (0) | (Standardeinstellung) Das Formular wird als nicht gebundenes Formular in der Formularansicht geöffnet.

Sie können die Eigenschaft Modal im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wenn Sie ein gebundenes Formular öffnen, sind alle anderen Fenster gesperrt, bis Sie das Formular schließen (das Wechseln zu Fenstern in anderen Anwendungen ist jedoch möglich). Um außer den anderen Fenstern auch Menüs und Symbolleisten zu sperren, stellen Sie die Eigenschaften Modal und PopUp des Formulars auf Ja ein.

Sie können die Eigenschaft BorderStyle zur Einstellung der Rahmenart eines Formulars verwenden. In der Regel ist die Eigenschaft BorderStyle von gebundenen Formularen auf Dialog eingestellt.

Tipp Sie können die Eigenschaften Modal, PopUp und BorderStyle zur Erstellung eines benutzerdefinierten Dialogfelds verwenden. Für benutzerdefinierte Dialogfelder stellen Sie die Eigenschaft Modal auf Ja, die Eigenschaft PopUp auf Ja und die Eigenschaft BorderStyle auf Dialog ein.

Das Einstellen der Eigenschaft Modal auf Ja bewirkt, dass das Formular nur in folgenden Fällen als gebunden behandelt wird:

  • Beim Öffnen des Formulars in der Formularansicht aus dem Datenbankfenster.

  • Beim Öffnen des Formulars in der Formularansicht mit einem Makro oder Visual Basic.

  • Beim Wechseln von der Entwurfsansicht zur Formularansicht.

In einem gebundenen Formular können Sie nicht von der Formularansicht zur Datenblattansicht wechseln. Sie können aber zur Entwurfsansicht und dann zur Formularansicht wechseln.

In der Entwurfsansicht und in der Datenblattansicht ist das Formular nicht gebunden. Dies gilt auch, wenn Sie von der Datenblattansicht zur Entwurfsansicht wechseln.

Anmerkung Sie können die Einstellung Dialog des Arguments Fenstermodus der Aktion ÖffnenFormular verwenden, um ein Formular so zu öffnen, dass dessen Eigenschaften Modal und PopUp auf Ja eingestellt sind.


 Module-Eigenschaft

Module-Eigenschaft

Sie können die Eigenschaft Module verwenden, um ein Formularmodul oder Berichtsmodul anzugeben.

Einstellung

Die Module-Eigenschaften ist nur in Visual Basic verfügbar und in allen Ansichten schreibgeschützt.

Anmerkung Die Module-Eigenschaft gibt auch eine Referenz auf ein bestimmtes Module-Objekt zurück.

Anmerkung

Verwenden Sie die Eigenschaft Module, um auf die Eigenschaften und Methoden eines Modulobjekts zuzugreifen, die einem Objekt Form oder Report zugeordnet sind.

Die Einstellungen der Eigenschaft HasModule eines Formulars oder eines Berichts legt fest, ob es ein zugeordnetes Modul gibt. Ist der Wert der Eigenschaft HasModule vom Typ False, ist dem Formular oder dem Bericht kein Modul zugeordnet. Beziehen Sie sich in der Entwurfsansicht auf die Eigenschaft Module des Formulars oder Berichts, so erstellt Microsoft Access das zugeordnete Modul und setzt die Eigenschaft HasModule auf True. Wenn Sie dagegen zur Laufzeit auf die Eigenschaft Module eines Formulars oder Berichts verweisen und die Eigenschaft HasModule des Objekts auf False eingestellt ist, tritt ein Fehler auf.

Sie können diese Eigenschaft in Verbindung mit allen Eigenschaften und Methoden des Module-Objekts verwenden.


 Modules-Eigenschaft

Modules-Eigenschaft

Mit der Modules-Eigenschaft können Sie auf die Auflistung Modules und deren zugehörige Eigenschaften zugreifen.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Verwenden Sie die Eigenschaften der Auflistung Modules in Visual Basic, um auf alle geöffneten Standardmodule und Klassenmodule zu verweisen.


 MousePointer-Eigenschaft

MousePointer-Eigenschaft

Sie können die Eigenschaft MousePointer zusammen mit dem Screen-Objekt verwenden, um den Typ des Mauszeigers anzugeben oder zu ermitteln, der momentan angezeigt wird.

Einstellung

Die Einstellung der Eigenschaft MousePointer ist ein Wert des Datentyps Integer, der einem der folgenden Zeiger entspricht.

Einstellung | Beschreibung
0 | (Standardeinstellung) Die Form wird von Microsoft Access festgelegt.
1 | Normale Auswahl Pfeil)
3 | Text-Auswahl (I-Balken)
7 | Vertikale Größe ändern (Größe N, S)
9 | Horizontal Größe ändern (Größe O, W)
11 | In Arbeit (Sanduhr)

Anmerkung Wenn Sie die Eigenschaft MousePointer auf eine Ganzzahl einstellen, die nicht in der obigen Tabelle aufgeführt ist, wird die Eigenschaft auf 0 eingestellt.

Sie können die Eigenschaft MousePointer nur in Visual Basic einstellen.

Anmerkung

Die Einstellung der Eigenschaft MousePointer wirkt sich für den gesamten Bildschirm auf das Aussehen des Mauszeiger aus. Einige benutzerdefinierte Steuerelemente haben die Eigenschaft MousePointer, die, sofern sie eingestellt ist, angibt, wie der Mauszeiger angezeigt wird, wenn er sich über dem Steuerelement befindet.

Sie können z.B. mit Hilfe der Eigenschaft MousePointer mitteilen, dass Ihre Anwendung beschäftigt ist, indem Sie die Eigenschaft auf 11 einstellen, so dass ein Sanduhrsymbol angezeigt wird. Sie können die Einstellung der Eigenschaft MousePointer auch lesen, um zu ermitteln, welches Symbol angezeigt wird. Dies kann z.B. sinnvoll sein, wenn Sie einen Benutzer daran hindern möchten, auf eine Befehlsschaltfläche zu klicken, solange der Mauszeiger als Sanduhrsymbol angezeigt wird.

Wenn Sie die Eigenschaft MousePointer auf 11 einstellen, erzielen Sie dasselbe Ergebnis, als wenn Sie True (-1) als Argument an die Methode Hourglass des Objekts DoCmd übergeben. Umgekehrt wird die Eigenschaft MousePointer auf 11 eingestellt, wenn Sie True als Argument an die Methode Hourglass übergeben.


MoveLayout-, NextRecord-, PrintSection-Eigenschaften

Sie können die Einstellungen dieser Eigenschaften in Visual Basic kombinieren, um das Layout eines Berichts anzugeben oder zu ändern, wenn der Bericht in der Seitenansicht angezeigt, gedruckt oder in einer Datei gespeichert wird:

  • Die Eigenschaft MoveLayout gibt an, ob Microsoft Access zur nächsten Druckposition der Seite wechseln soll.

  • Die Eigenschaft NextRecord gibt an, ob ein Bereich zum nächsten Datensatz wechseln soll.

  • Die Eigenschaft PrintSection gibt an, ob ein Bereich gedruckt werden soll.

Einstellungen

Die Eigenschaft MoveLayout kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True (-1) | (Standardeinstellung) Die Eigenschaften Left und Top des Bereichs werden auf die Werte der nächsten Druckposition eingestellt.
False (0) | Die Einstellungen der Eigenschaften Left und Top des Bereichs werden nicht geändert.

Die Eigenschaft NextRecord kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True | (Standardeinstellung) Der Bereich wechselt zum nächsten Datensatz.
False | Der Bereich wechselt nicht zum nächsten Datensatz.

Die Eigenschaft PrintSection kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True | (Standardeinstellung) Der Bereich wird gedruckt.
False | Der Bereich wird nicht gedruckt.

Sie stellen diese Eigenschaften ein, indem Sie für die Eigenschaft OnFormat (BeimFormatieren) eines Bereichs ein Makro oder eine Ereignisprozedur angeben.

Microsoft Access stellt diese Eigenschaften für jeden Bereich vor dessen Ereignis Format auf True ein.

Anmerkung

Diese Eigenschaften sind hilfreich, wenn Sie einen Bericht als Vorlage verwenden möchten, in den Sie während des Druckens Daten aus einem Makro oder aus Visual Basic schreiben.

In der folgenden Tabelle sind die Ergebnisse beschrieben, die aus unterschiedlichen Kombinationen der Einstellungen dieser Eigenschaften folgen.

MoveLayout | NextRecord | PrintSection | Beschreibung
True | True | True | (Standardeinstellung) Wechseln zur nächsten Druckposition, Lesen des nächsten Datensatzes und Drucken der Daten.
True | False | True | Wechseln zur nächsten Druckposition, kein Lesen des nächsten Datensatzes, aber Drucken der Daten. Diese Kombination wird üblicherweise dann verwendet, wenn die Daten eines Bereichs mehr Platz beanspruchen, als ihnen vom Layout her zusteht, und wenn Sie möchten, dass die restlichen Daten dort gedruckt werden, wo sonst der nächste Bereich gedruckt würden.
False | True | False | Überspringen eines Datensatzes, ohne einen leeren Abschnitt auf der Seite zu belassen.
True | True | False | Überspringen eines Datensatzes und Belassen eines leeren Abschnitts auf der Seite.
True | False | False | Belassen eines leeren Abschnitts, ohne einen Datensatz zu überspringen.
False | True | True | Drucken des aktuellen Datensatzes als Überdeckung über den letzten Datensatz.
False | False | True | Nicht zulässig.
False | False | False | Nicht zulässig.


 MultiRow-Eigenschaft (MehrereZeilen)

MultiRow-Eigenschaft (MehrereZeilen)

Mit der Eigenschaft MultiRow können Sie angeben oder ermitteln, ob ein Registersteuerelement mehrere Zeilen mit Registerkartenzungen anzeigen kann.

Einstellung

Die Eigenschaft MultiRow verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Es sind mehrere Zeilen zulässig.
Nein | False (0) | (Standardeinstellung) Es ist nur eine Zeile zulässig.

Sie können die Eigenschaft MultiRow im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Die Standardeinstellung dieser Eigenschaft können Sie mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Wenn die Eigenschaft MultiRow auf True eingestellt ist, ergibt sich die Anzahl der Zeilen aus der Breite und der Anzahl der Registerkartenzungen. Die Anzahl der Zeilen kann sich ändern, wenn die Größe des Steuerelements geändert wird oder weitere Registerkarten zu dem Steuerelement hinzugefügt werden.

Wenn die Eigenschaft MultiRow auf False eingestellt ist und die Gesamtbreite aller Registerkartenzungen die Breite des Steuerelements übersteigt, werden auf der rechten Seite des Registersteuerelements Navigationsschaltflächen angezeigt. Mit Hilfe dieser Navigationsschaltflächen können Sie alle Registerkarten des Registersteuerelements durchlaufen.


 MultiSelect-Eigenschaft (Mehrfachauswahl)

MultiSelect-Eigenschaft (Mehrfachauswahl)

Sie können mit der Eigenschaft MultiSelect angeben, ob und wie ein Benutzer mehrere Einträge in einem Listenfeld auf einem Formular auswählen kann.

Einstellung

Die Eigenschaft MultiSelect verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Keine | 0 | (Standardeinstellung) Mehrfachauswahl ist nicht möglich.
Einzeln | 1 | Mehrere Elemente werden ausgewählt bzw. ihre Auswahl wird aufgehoben, indem Sie mit der Maus darauf klicken oder die LEERTASTE drücken.
Erweitert | 2 | Mehrere Elemente werden durch Klicken mit der Maustaste bei gleichzeitigem Drücken von UMSCHALT oder durch Drücken von UMSCHALT+PFEILTASTE zur Erweiterung der Auswahl vom vorher ausgewählten Element bis zum aktuellen Element ausgewählt. Sie können Elemente auch durch Ziehen mit der Maus auswählen. Das Gedrückthalten von STRG und das Klicken auf ein Element wählt dieses Element aus bzw. hebt die Auswahl auf.

Sie können die Eigenschaft MultiSelect im Eigenschaftenfenster des Listenfelds, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann nur in der Formularentwurfsansicht eingestellt werden.

Anmerkung

Sie können die Eigenschaft ListIndex verwenden, um den Index des ausgewählten Elements zurückzugeben. Wenn die Eigenschaft MultiSelect auf Erweitert oder Einzeln eingestellt ist, können Sie die Selected-Eigenschaft oder die Auflistung ItemsSelected des Listenfelds verwenden, um die ausgewählten Elemente zu bestimmen. Außerdem enthält das Listenfeld-Steuerelement in diesem Fall immer den Wert Null.

Wenn die Eigenschaft MultiSelect auf Erweitert eingestellt ist, wird die vom Benutzer vorgenommene Auswahl gelöscht, indem Sie eine erneute Abfrage für das Listenfeld durchführen.


 Name-Eigenschaft (Name)

Name-Eigenschaft (Name)

Mit Hilfe der Name-Eigenschaft können Sie einen Zeichenfolgenausdruck angeben oder ermitteln, der den Namen eines AccessObject-Objekts, eines Steuerelements oder eines Reference-Objekts identifiziert.

Einstellung

Ein gültiger Name muss den Microsoft Access-Konventionen zur Objektbenennung entsprechen. Für Microsoft Access-Objekte kann der Name maximal 64 Zeichen enthalten. Für Steuerelemente kann er maximal 255 Zeichen lang sein.

Für Objekte stellen Sie die Name-Eigenschaft ein, indem Sie in der Entwurfsansicht im Menü Datei auf Speichern klicken und einen gültigen Namen eingeben. Sie ändern den Namen eines bestehenden Objekts im Datenbankfenster, indem Sie auf den Namen klicken und dann entweder im Menü Bearbeiten auf Umbenennen oder erneut auf den Namen klicken. Sie können den Namen auch ändern, indem Sie mit der rechten Maustaste darauf klicken und dann im Kontextmenü auf Umbenennen klicken. Um den Namen eines vorhandenen Objekts zu ändern, wenn das Objekt geöffnet ist, klicken Sie im Menü Datei auf Speichern unter/Exportieren.

Für einen Bereich oder ein Steuerelement können Sie diese Eigenschaft im Eigenschaftenfenster, mit einem Makro oder in Visual Basic festlegen. Sie können die Name-Eigenschaft in Ausdrücken für Objekte verwenden.

Sie können diese Eigenschaft nur in der Entwurfsansicht einstellen.

Anmerkung Für ein Reference-Objekt ist diese Eigenschaft in allen Ansichten schreibgeschützt.

Anmerkungen

Der Standardname für neue Objekte besteht aus dem Objektnamen und einem eindeutigen Integer. Das erste neue Formular heißt z. B. Formular1, das zweite Formular2 usw. Ein Formular darf nicht denselben Namen wie ein Systemobjekt, z. B. das Screen-Objekt, haben.

Für ein ungebundenes Steuerelement besteht der Standardname aus dem Steuerelementtypen und einer eindeutigen Zahl des Typs Integer. Ist das erste Steuerelement, das Sie einem Formular hinzufügen, z.B. ein Textfeld, dann ist die Einstellung seiner Eigenschaft Name entsprechend Text1.

Für ein gebundenes Steuerelement besteht der Standardname aus dem Namen des Feldes der zugrunde liegenden Datenherkunft. Wenn Sie ein Steuerelement erstellen, indem Sie ein Feld aus der Feldliste ziehen, wird die Einstellung der Eigenschaft Feldname des Feldes in das Einstellungsfeld der Eigenschaft Name des Steuerelements kopiert.

Sie können einem Steuerelement oder einem Bereich keinen der Namen "Form" oder "Report" geben.

Für zwei Steuerelemente kann im gleichen Formular, Bericht oder in der gleichen Datenzugriffsseite nicht derselbe Name verwendet werden, jedoch können Steuerelemente in unterschiedlichen Formularen, Berichten oder Datenzugriffsseiten dieselben Namen haben. Ein Steuerelement und ein Bereich desselben Formulars dürfen nicht denselben Namen haben.


 NavigationButtons-Eigenschaft (Navigationsschaltflächen)

NavigationButtons-Eigenschaft (Navigationsschaltflächen)

Mit der Eigenschaft NavigationButtons können Sie angeben, ob Navigationsschaltflächen und ein Datensatznummernfeld in einem Formular angezeigt werden.

Einstellung

Die Eigenschaft NavigationButtons verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Das Formular verfügt über Navigationsschaltflächen und ein Datensatznummernfeld.
Nein | False (0) | Das Formular verfügt weder über Navigationsschaltflächen noch über ein Datensatznummernfeld.

Sie können die Eigenschaft NavigationButtons im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Navigationsschaltflächen bieten die Möglichkeit, auf effiziente Weise zum ersten, vorigen, nächsten, letzten oder zu einem leeren (neuen) Datensatz zu gelangen. Das Datensatznummernfeld zeigt die Nummer des aktuellen Datensatzes an. Die Gesamtzahl der Datensätze wird unmittelbar neben den Navigationsschaltflächen angezeigt. Sie können im Datensatznummernfeld eine Zahl eingeben, um direkt zu einem bestimmten Datensatz zu gelangen.

Wenn Sie die Navigationsschaltflächen aus einem Formular entfernen und eigene Navigationshilfsmittel für das Formular erstellen möchten, können Sie benutzerdefinierte Navigationsschaltflächen erstellen und zum Formular hinzufügen. Weitere Informationen zum Erstellen von benutzerdefinierten Navigationsschaltflächen finden Sie unter Navigieren zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung von Visual Basic.


 NewRecord-Eigenschaft

NewRecord-Eigenschaft

Mit Hilfe der Eigenschaft NewRecord können Sie bestimmen, ob der aktuelle Datensatz ein neuer Datensatz ist.

Einstellung

Die Eigenschaft NewRecord verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Der aktuelle Datensatz ist neu.
False (0) | Der aktuelle Datensatz ist nicht neu.

Die Eigenschaft NewRecord ist in der Formularansicht und in der Datenblattansicht schreibgeschützt. In der Entwurfsansicht steht sie nicht zur Verfügung. Diese Eigenschaft steht nur bei Verwendung eines Makros oder von Visual Basic zur Verfügung.

Anmerkung

Wenn sich ein Benutzer zu einem neuen Datensatz bewegt hat, ist die Eigenschaft NewRecord auf True eingestellt, unabhängig davon, ob der Benutzer mit der Bearbeitung des Datensatzes begonnen hat oder nicht.


 NewRowOrCol-Eigenschaft (NeueZeileOderSpalte)

NewRowOrCol-Eigenschaft (NeueZeileOderSpalte)

Mit der Eigenschaft NewRowOrCol können Sie angeben, ob ein Bereich und dessen zugehörige Daten in einem mehrspaltigen Bericht oder mehrspaltigen Formular in einer neuen Zeile oder Spalte gedruckt werden. Sie können diese Eigenschaft z.B. verwenden, um in einem mehrspaltigen Bericht jeden Gruppenkopf als Überschrift einer neuen Spalte zu drucken.

Anmerkung Die Eigenschaft NewRowOrCol betrifft weder Seitenköpfe noch Seitenfüße.

Einstellung

Die Eigenschaft NewRowOrCol verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keine | 0 | (Standardeinstellung) Die Zeilen- oder Spaltenumbrüche werden durch die Einstellungen im Dialogfeld Seitenformat (wird angezeigt, nachdem Sie im Menü Datei auf Seitenformat geklickt haben) und durch den auf der Seite verfügbaren Platz bestimmt.
Vor Bereich | 1 | Microsoft Access beginnt mit dem Drucken des aktuellen Bereichs (der Bereich, für den Sie die Eigenschaft einstellen, z.B. ein Gruppenkopfbereich) in einer neuen Zeile oder Spalte. Der nächste Bereich, z.B. ein Detailbereich, wird in derselben Zeile oder Spalte gedruckt.
Nach Bereich | 2 | Microsoft Access beginnt mit dem Drucken des aktuellen Bereichs, z.B. eines Gruppenkopfbereichs, in der aktuellen Zeile oder Spalte. Mit dem Drucken des nächsten Bereichs, z.B. eines Detailbereichs, beginnt Microsoft Access in der nächsten Zeile oder Spalte.
Vor & Nach | 3 | Microsoft Access beginnt mit dem Drucken des aktuellen Bereichs in einer neuen Zeile oder Spalte und mit dem Drucken des nächsten Bereichs in der nächsten Zeile oder Spalte.

Sie können diese Eigenschaft im Eigenschaftenfenster des Bereichs, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaft NewRowOrCol nur in der Formularentwurfsansicht oder der Berichtsentwurfsansicht einstellen.

Anmerkung

Die folgenden Einträge sind Beispieleinstellungen für einen Gruppenkopfbereich eines mehrspaltigen Berichts. Im Dialogfeld Seitenformat muss auf der Registerkarte Spalten unter Spaltenlayout das Opionsfeld Nach unten, dann quer aktiviert sein.

Beispieleinstellung | Ergebnis
Vor Bereich | Der Gruppenkopf wird ab dem Anfang einer neuen Spalte gedruckt.
Nach Bereich | Der Detailbereich wird ab dem Anfang einer neuen Spalte gedruckt.
Vor & Nach | Der Gruppenkopf wird in einer eigenen Spalte und der Detailbereich ab dem Anfang einer neuen Spalte gedruckt.

Bereiche eines Formulars oder Berichts werden normalerweise von oben nach unten auf einer Seite gedruckt. Die Standardeinstellung der Option Spaltenlayout lautet Quer, dann nach unten. Sollen die Bereiche in mehreren Spalten auf einer Seite gedruckt werden, klicken Sie im Dialogfeld Seitenformat auf der Registerkarte Spalten unter Spaltenlayout auf Nach unten, dann quer.

Wenn Sie die Eigenschaft NewRowOrCol auf Vor Bereich einstellen, wirkt sich die Ausrichtung der Seite (Hoch- oder Querformat) darauf aus, wie der Bereich gedruckt wird. Wenn Sie im Dialogfeld Seitenformat in der Registerkarte Spalten unter Spaltenlayout auf Quer, dann nach unten klicken, beginnt Microsoft Access mit dem Drucken des Bereichs am Anfang einer neuen Zeile. Wenn Sie auf Nach unten, dann quer klicken, beginnt Microsoft Access mit dem Drucken des Bereichs am Anfang einer neuen Spalte.


 NewValues-Eigenschaft (NeueWerte)

NewValues-Eigenschaft (NeueWerte)

Mit Hilfe der Eigenschaft NewValues können Sie angeben, wie Felder vom Typ AutoWert hochgezählt werden, wenn einer Tabelle neue Datensätze hinzugefügt werden.

Anmerkung Die Eigenschaft NewValues betrifft nur Felder vom Typ AutoWert.

Einstellung

Die Eigenschaft NewValues verwendet folgende Einstellungen.

Einstellung | Beschreibung
Inkrement | (Voreinstellung) Der Wert von Feldern vom Typ AutoWert wird für neue Datensätze um 1 hochgezählt.
Zufall | Dem Wert von Feldern vom Typ AutoWert wird eine zufällige Zahl des Typs Long Integer für neue Datensätze zugewiesen.

Sie können diese Eigenschaft im Eigenschaftenfenster der Tabelle in der Tabellenentwurfsansicht einstellen, indem Sie unter Feldeigenschaften auf die Registerkarte Allgemein klicken.

Anmerkung

Wenn Sie eine Datenbank replizieren, werden Felder vom Typ AutoWert auf Zufall eingestellt, damit neue Datensätze, die in andere Replikate eingegeben werden, eindeutige Werte erhalten.


 NumeralShapes-Eigenschaft

NumeralShapes-Eigenschaft

Sprachspezifische Informationen

You can use the NumeralShapes property to specify or determine numeral shapes to be displayed and printed in a combo box, label, list box, or text box.

Setting

The NumeralShapes property uses the following settings.

Setting | Visual Basic | Description
System | 0 | Numeral shapes determined by the Numeral Shapes system setting.
Arabic | 1 | Arabic digit shapes will be used to display and print numerals.
Hindi | 2 | Hindi digit shapes will be used to display and print numerals.
Context | 3 | Numeral shapes determined by Unicode context rules for adjacent text.

You can set this property by using the property sheet or Visual Basic.

For more information about right-to-left properties, see Learn more about right-to-left properties in Microsoft Access 2000.


 Object-Eigenschaft

Object-Eigenschaft

Mit der Eigenschaft Object können Sie in Visual Basic einen Verweis auf das ActiveX-Objekt zurückgeben, das einem verknüpften oder eingebetteten OLE-Objekt eines Steuerelements zugeordnet ist. Über diesen Verweis können Sie auf die Eigenschaften des OLE-Objekts zugreifen oder dessen Methoden aufrufen.

Einstellung

Die Eigenschaft Object gibt einen Verweis auf ein ActiveX-Objekt zurück. Mit der Anweisung Set können Sie dieses ActiveX-Objekt einer Objektvariablen zuweisen. Der Typ des zurückgegebenen Objektverweises hängt davon ab, mit welcher Anwendung das OLE-Objekt erstellt wurde.

Die Eigenschaft Object ist in allen Ansichten schreibgeschützt.

Anmerkung

Wenn Sie ein OLE-Objekt in ein Microsoft Access-Formular einbetten oder verknüpfen, können Sie die Eigenschaften einstellen, die den Typ des Objekts sowie das Verhalten des Steuerelements festlegen, das als Container dient. Allerdings ist es Ihnen nicht möglich, die Eigenschaften des OLE-Objekts direkt einzustellen bzw. zu lesen oder dessen Methoden direkt anzuwenden, wie Sie dies können, wenn Sie mit Automatisierung arbeiten. Die Eigenschaft Object gibt einen Verweis auf ein Automatisierungsobjekt zurück, das dem verknüpften oder eingebetteten OLE-Objekt entspricht. Mit Hilfe dieses Verweises können Sie das OLE-Objekt ändern, indem Sie dessen Eigenschaften einstellen bzw. lesen oder dessen Methoden anwenden. Microsoft Excel ist z.B. eine COM-Komponente, die Automatisierung unterstützt. Wenn Sie ein Microsoft Excel-Tabellenblatt in ein Microsoft Access-Formular eingebettet haben, können Sie mit der Eigenschaft Object einen Verweis auf das Worksheet-Objekt einstellen, das diesem Tabellenblatt entspricht. Danach können Sie jede Eigenschaft und Methode des Worksheet-Objekts verwenden.

Informationen, welche Eigenschaften und Methoden von einem ActiveX-Objekt unterstützt werden, finden Sie in der Dokumentation der Anwendung, mit der das OLE-Objekt erstellt wurde.


 ObjectPalette-Eigenschaft (Objektpalette)

ObjectPalette-Eigenschaft (Objektpalette)

Die Eigenschaft ObjectPalette gibt die Palette an, die in der Anwendung verwendet wurde, mit der folgendes Objekt erstellt wurde:

  • Ein OLE-Objekt das in einem gebundenen Objektfeld, einem Diagramm oder einem Objektfeld enthalten ist.

  • Eine Bitmap oder eine andere Grafik, die mit Hilfe der Eigenschaft Picture in eine Befehlsschaltfläche, ein Bild-Steuerelement oder eine Umschaltfläche geladen wird.

Einstellung

Microsoft Access stellt die Eigenschaft ObjectPalette auf einen Wert des Typs String ein, der die Paletteninformationen enthält. Diesen Wert können Sie verwenden, um die Eigenschaft PaintPalette eines Formulars oder Berichts einzustellen.

Für die folgenden Objekte, Ansichten und Steuerelemente ist die Einstellung der Eigenschaft ObjectPalette schreibgeschützt. In den anderen Ansichten steht die Einstellung dieser Eigenschaft für diese Steuerelemente nicht zur Verfügung.

Objekt | Ansicht | Steuerelement
Formulare | Formularentwurfsansicht und Formularansicht | Befehlsschaltfläche, Diagramm, Bild-Steuerelement, Umschaltfläche und Objektfeld
 | Formularansicht | Gebundenes Objektfeld
Reports | Berichtsentwurfsansicht | Befehlsschaltfläche, Diagramm, Bild-Steuerelement Umschaltfläche und Objektfeld. Die Einstellung dieser Eigenschaft ist für ein gebundenes Objektfeld eines Berichts in keiner Ansicht verfügbar.

Sie können die Einstellung dieser Eigenschaft nur in einem Makro oder in Visual Basic verwenden.

Ist für die Anwendung, die dem OLE-Objekt, der Bitmap oder der Grafik anderen Typs zugeordnet ist, keine Palette festgelegt, wird die Eigenschaft ObjectPalette auf eine leere Zeichenfolge eingestellt.

Anmerkung

Die Einstellung der Eigenschaft ObjectPalette macht die Palette der mit dem OLE-Objekt, der Bitmap oder der Grafik anderen Typs verbundenen Anwendung für die Eigenschaft PaintPalette eines Formulars oder eines Berichts verfügbar. Damit z.B. die in Microsoft Graph verwendete Palette verfügbar ist, wenn Sie ein Formular in Microsoft Access erstellen, stellen Sie die Eigenschaft PaintPalette des Formulars auf den Wert der Eigenschaft ObjectPalette eines existierenden Diagramm-Steuerelements ein.

Anmerkung Microsoft Windows kann nur jeweils eine aktive Palette verwenden. Sie können in Microsoft Access mehrere Grafiken in einem Formular verwalten, die alle eine andere Farbpalette verwenden. Mit Hilfe der Eigenschaften PaintPalette und PaletteSource geben Sie an, welche Farbpalette ein Formular bei der Anzeige von Grafiken verwenden soll.


 ObjectVerbs-Eigenschaft

ObjectVerbs-Eigenschaft

Mit der Eigenschaft ObjectVerbs können Sie in Visual Basic die Liste der Verben ermitteln, die ein OLE-Objekt unterstützt.

Einstellung

Die Einstellung der Eigenschaft ObjectVerbs ist ein Datenfeld aus Zeichenfolgen, dessen erstes Element den Index 0 hat.

Diese Eigenschaft steht in der Entwurfsansicht nicht zur Verfügung und ist in den anderen Ansichten schreibgeschützt.

Anmerkung

Sie können die Eigenschaft ObjectVerbs zusammen mit der Eigenschaft ObjectVerbsCount verwenden, um eine Liste der Verben anzuzeigen, die von einem OLE-Objekt unterstützt werden. Die Eigenschaft Verb verwendet diese Liste der Verben, um festzustellen, welcher Vorgang ausgeführt werden soll, nachdem ein OLE-Objekt aktiviert wurde (indem die Eigenschaft Action auf acOLEActivate eingestellt wurde).

Die Einstellung der Eigenschaft Verb entspricht der Position eines bestimmten Verbs innerhalb der Liste der Verben, die von der Eigenschaft ObjectVerbs zurückgegeben wurde. Die Einstellung 1 gibt z.B. das erste Verb der Liste an (Visual Basic-Befehl ObjectVerbs(0) bzw. das erste Verb des Datenfelds der Eigenschaft ObjectVerbs), 2 gibt das zweite Verb der Liste an (Visual Basic-Befehl ObjectVerbs(1) bzw. das zweite Verb des Datenfelds der Eigenschaft ObjectVerbs), usw.

Das erste Verb des Datenfelds der Eigenschaft ObjectVerbs, das von dem Visual Basic-Befehl ObjectVerbs(0) aufgerufen wird, ist das Standardverb. Für den Fall, dass die Eigenschaft Verb nicht eingestellt wurde, gibt dieses Verb den Vorgang an, der ausgeführt wird, sobald das OLE-Objekt aktiviert wurde.

Anwendungen, die OLE-Objekte offenlegen, enthalten im Allgemeinen im Menü Bearbeiten den Befehl Objekt. Wenn der Benutzer auf diesen Befehl zeigt, werden die Verben des Objekts in einem Untermenü angezeigt. Sie können die Eigenschaften ObjectVerbs und ObjectVerbsCount verwenden, um eine Liste der Verben auf einem Formular oder Bericht (anstatt in einem Menü) anzuzeigen.

Die Liste der Verben, die ein Objekt unterstützt, hängt vom Zustand des Objekts ab. Wenn Sie die Liste der Verben aktualisieren möchten, die ein Objekt unterstützt, stellen Sie die Eigenschaft Action des Steuerelements auf acOLEFetchVerbs ein. Achten Sie darauf, dass Sie die Liste der Verben immer erst aktualisieren, bevor Sie sie dem Benutzer Liste zur Verfügung stellen.


 ObjectVerbsCount-Eigenschaft

ObjectVerbsCount-Eigenschaft

Mit der Eigenschaft ObjectVerbsCount können Sie in Visual Basic ermitteln, wie viele Verben von einem OLE-Objekt unterstützt werden.

Einstellung

Die Einstellung der Eigenschaft ObjectVerbsCount ist ein Wert des Datentyps Integer, der die Anzahl der Elemente angibt, die zu dem Datenfeld der Eigenschaft ObjectVerbs gehören.

Diese Eigenschaft steht in der Entwurfsansicht nicht zur Verfügung und ist in den anderen Ansichten schreibgeschützt.

Anmerkung

Die Liste der Verben, die ein Objekt unterstützt, hängt vom Zustand des Objekts ab. Wenn Sie die Liste der unterstützten Verben aktualisieren möchten, stellen Sie die Eigenschaft Action des Steuerelements auf acOLEFetchVerbs ein.


 Objekteigenschaften

Objekteigenschaften

Die Objekteigenschaften stellen allgemeine Informationen zu den Objekten bereit, deren Namen im Datenbankfenster angezeigt werden.

Anmerkung Die Objekteigenschaften sind in Microsoft Access-Datenbanken (.mdb) für sämtliche Objekte verfügbar, in Access-Projekten (.adp) jedoch nur für Formulare, Datenzugriffsseiten, Makros, Module und Berichte.

Einstellung

Sie haben folgende Möglichkeiten, die Eigenschaften eines Objekts anzuzeigen und dessen Eigenschaften Description und Attributes einzustellen:

  • Klicken Sie im Datenbankfenster auf ein Objekt und dann in der Symbolleiste Datenbank auf Eigenschaften [image] .

  • Klicken Sie im Datenbankfenster auf ein Objekt und dann im Menü Ansicht auf Eigenschaften.

  • Klicken Sie im Datenbankfenster mit der rechten Maustaste auf ein Objekt, und klicken Sie dann im Kontextmenü auf Eigenschaften.

Bei Access-Datenbanken (.mdb) können Sie die Objekteigenschaften auch in Visual Basic angeben oder ermitteln. Die Objekteigenschaften von Access-Projekten (.adp) sind in Visual Basic nicht verfügbar.

Anmerkung Sie können nur die Eigenschaften Description und Attributes eingeben oder bearbeiten. Die anderen Objekteigenschaften werden von Microsoft Access eingestellt und sind schreibgeschützt.

Anmerkung

Die Objekte im Datenbankfenster, für die Eigenschaften angezeigt werden können, sind: Tabellen, Abfragen, Formulare, Datenzugriffsseiten, Berichte, Makros und Module. Jede Klasse von Objekten der Datenbank wird innerhalb der DAO-Auflistung Containers durch ein eigenes DAO-Objekt Document dargestellt. Beispielsweise enthält die jeweilige Containers-Auflistung ein Document-Objekt, das alle Formulare der Datenbank darstellt.

Die folgenden Objekteigenschaften stehen über das Datenbankfenster zur Verfügung.

Eigenschaft | Beschreibung
Name | Dies ist der Name des Objekts und enthält die Einstellung der Eigenschaft Name des Objekts.
Type | Dies ist der Objekttyp. Microsoft Access-Objekttypen sind: Formular, Datenzugriffsseite, Makro, Modul, Abfrage, Bericht und Tabelle.
Description | Dies ist die Beschreibung des Objekts, die mit dem Wert identisch ist, auf den die Description-Eigenschaft des Objekts eingestellt ist. Sie können die Description-Eigenschaft des Objekts auch im Eigenschaftenfenster des Objekts festlegen. Die Beschreibung eines Objekts wird im Datenbankfenster auch neben dem Namen des Objekts angezeigt, wenn Sie im Menü Ansicht auf Details klicken.
Created | Dies ist das Datum, an dem das Objekt erstellt wurde. Bei Tabellen oder Abfragen entspricht diese Eigenschaft der Eigenschaft DateCreated.
Modified | Dies ist das Datum, an dem das Objekt zuletzt bearbeitet wurde. Bei Tabellen oder Abfragen entspricht diese Eigenschaft der Eigenschaft LastUpdated.
Owner | Dies ist der Besitzer des Objekts. Weitere Informationen finden Sie unter der Eigenschaft Owner.
Attributes | Diese Eigenschaft gibt an, ob das Objekt ausgeblendet oder sichtbar ist und es in einem Datenbank-Replikat replizierbar ist. Wenn Sie das Attribut Ausgeblendet auf True einstellen (indem Sie das Kontrollkästchen Ausgeblendet aktivieren), wird das Objekt nicht im Datenbankfenster angezeigt. Wenn Sie ausgeblendete Objekte im Datenbankfenster anzeigen möchten, klicken Sie im Menü Extras auf Optionen, klicken auf die Registerkarte Ansicht und aktivieren dann das Kontrollkästchen Ausgeblendete Objekte. Das Symbol eines ausgeblendeten Objekts wird danach im Datenbankfenster abgeblendet angezeigt. Wenn Sie das Attribut Ausgeblendet später deaktivieren, wird das Objekt wieder im Datenbankfenster sichtbar.


 ODBCConnectStr-Eigenschaft (ODBCVerbindung)

ODBCConnectStr-Eigenschaft (ODBCVerbindung)

Sie können die Eigenschaft ODBCConnectStr in einer SQL-Pass-Through-Abfrage verwenden, um die ODBC-Verbindungszeichenfolge (ODBC = Open Database Connectivity) für die Abfrage anzugeben.

Anmerkung Die Eigenschaft ODBCConnectStr gilt nur für Pass-Through-Abfragen.

Einstellung

Geben Sie die ODBC-Verbindungszeichenfolge ein, welche die Verbindung zu der SQL-Datenbank angibt, die Sie verwenden möchten.

Sie können diese Eigenschaft mit Hilfe des Abfrage-Eigenschaftenfensters oder in Visual Basic festlegen.

Sie können auch den ODBC-Verbindungszeichenfolgen-Generator verwenden, um die ODBC-Verbindungszeichenfolge für diese Eigenschaft einzustellen. Dieser Editor stellt eine Verbindung zum SQL-Datenbank-Server her und beendet die Verbindung, nachdem die ODBC-Verbindungszeichenfolge erstellt wurde.

Anmerkung

Die Standardeinstellung für diese Eigenschaft ist die Zeichenfolge "ODBC;", die von Microsoft Access wieder hergestellt wird, wenn Sie eine bestehende Einstellung löschen. Ist die Eigenschaft ODBCConnectStr auf "ODBC;" eingestellt, so werden Sie von Microsoft Access zur Eingabe einer Verbindungszeichenfolge aufgefordert, sobald die Abfrage verwendet, aber die Verbindungszeichenfolge nicht gespeichert wird. Sie müssen eine Verbindungszeichenfolge im Einstellungsfeld der Eigenschaft ODBCConnectStr eingeben, wenn Microsoft Access die Verbindungszeichenfolge speichern soll.

Tipp Kennen Sie die vollständige Verbindungszeichenfolge für die SQL-Datenbank, so geben Sie diese im Einstellungsfeld der Eigenschaft ODBCConnectStr ein. Sie vermeiden dadurch das wiederholte Eingeben der Verbindungszeichenfolge im Dialogfeld zum Herstellen der ODBC-Verbindung, wenn Sie die Abfrage verwenden.

Die Verbindungszeichenfolge ist für verschiedene Typen von ODBC-Datenquellen unterschiedlich. Damit Sie z.B. eine Verbindung zur Datenquelle PersonalAbt auf dem Server PERSSRVR (einem Microsoft SQL Server) mit Hilfe der Anmeldeinformation (ID) Schmidt und dem Kennwort Sesam herstellen können, verwenden Sie die folgende Verbindungszeichenfolge.

ODBC;DSN=PersonalAbt;SERVER=PERSSRVR;UID=Schmidt;PWD=Sesam

Weitere Informationen über den Zugriff auf Daten in ODBC-Datenbanken finden Sie in Kapitel 15, "Empfangen und Analysieren von Daten" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Programmierhandbuch beziehen können, klicken Sie auf [image] .


 ODBCTimeout-Eigenschaft (ODBCWartezeit) (Microsoft Access)

ODBCTimeout-Eigenschaft (ODBCWartezeit) (Microsoft Access)

Mit der Eigenschaft ODBCTimeout können Sie angeben, wie viele Sekunden Microsoft Access wartet, bevor ein Zeitüberschreitungsfehler auftritt, wenn eine Abfrage einer ODBC-Datenbank (ODBC = Open Database Connectivity) ausgeführt wird.

Einstellung

Die Eigenschaft ODBCTimeout entspricht einem Wert vom Typ Integer, der die Anzahl der zu wartenden Sekunden angibt. Die Voreinstellung beträgt 60 Sekunden. Ist die Eigenschaft auf 0 eingestellt, so tritt keine Zeitüberschreitung auf.

Sie können diese Eigenschaft im Abfrageeigenschaftenfenster oder in Visual Basic festlegen.

Anmerkung

Verwenden Sie eine ODBC-Datenbank, z.B. einen Microsoft SQL Server, so können aufgrund der Netzwerkauslastung oder der starken Beanspruchung des ODBC-Servers Verzögerungen auftreten. Mit Hilfe der Eigenschaft ODBCTimeout können Sie angeben, wie lange Microsoft Access auf eine Netzwerkverbindung warten soll, bevor ein Zeitüberschreitungsfehler auftritt.

Weitere Informationen über den Zugriff auf Daten in ODBC-Datenbanken finden Sie in Kapitel 15, "Empfangen und Analysieren von Daten" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Programmierhandbuch beziehen können, klicken Sie auf [image] .


 OldValue-Eigenschaft

OldValue-Eigenschaft

Mit der Eigenschaft OldValue können Sie den unbearbeiteten Wert eines gebundenen Steuerelements ermitteln.

Einstellung

Die Eigenschaft OldValue enthält unbearbeitete Daten aus einem gebundenen Steuerelement und ist in allen Ansichten schreibgeschützt.

Sie können auf diese Eigenschaft nur in einem Makro oder in Visual Basic zugreifen.

Der Wert der Eigenschaft OldValue kann mit Hilfe der folgenden Syntax einer Variablen zugewiesen werden:

OriginalWert = Formulare!Kunden!BezahlterBetrag.OldValue

Anmerkung

Microsoft Access verwendet die Eigenschaft OldValue, um den ursprünglichen Wert eines gebundenen Steuerelements zu speichern. Bearbeiten Sie ein gebundenes Steuerelement in einem Formular, so werden die Änderungen erst gespeichert, wenn Sie zu einem anderen Datensatz wechseln. Die Eigenschaft OldValue enthält die unbearbeitete Version der zugrunde liegenden Daten.

Sie können eine eigene Funktion zum Rückgängigmachen der letzten Operation implementieren, indem Sie die Einstellung der Eigenschaft OldValue einem Steuerelement zuweisen. Das folgende Beispiel zeigt, wie Sie alle Änderungen von Textfeld-Steuerelementen in einem Formular rückgängigmachen können.

Sub btnUndo_Click()
    Dim ctlTextfeld As Control
    For Each ctlTextfeld in Me.Controls
    If ctlTextfeld.ControlType = acTextfeld Then
        ctlTextfeld.Value = ctlTextfeld.OldValue
    End If
    Next ctlTextfeld
End Sub

Wurde das Steuerelement nicht bearbeitet, so hat dieser Code keine Auswirkung. Wenn Sie zu einem anderen Datensatz wechseln, wird die Datensatzquelle aktualisiert, so dass der aktuelle Wert und die Eigenschaft OldValue übereinstimmen.

Die Einstellung der Eigenschaft OldValue hat denselben Datentyp wie das Feld, an welches das Steuerelement gebunden ist.


 OLEClass-Eigenschaft (OLE)

OLEClass-Eigenschaft (OLE)

Mit der Eigenschaft OLEClass können Sie eine Typbeschreibung des OLE-Objekts abrufen, das in einem Diagramm-Steuerelement oder in einem ungebundenen Objektfeld enthalten ist.

Einstellung

Diese Eigenschaft wird im Eigenschaftenfenster des Steuerelements automatisch auf einen Zeichenfolgenausdruck eingestellt, wenn Sie ein OLE-Objekt zu einem Formular hinzugefügt haben, indem Sie im Menü Einfügen auf Objekt geklickt haben. Die Einstellung der Eigenschaft OLEClass ist in allen Ansichten schreibgeschützt.

Anmerkung Wenn Sie mit Automatisierung (früher als OLE-Automatisierung bezeichnet) arbeiten und einen Namen angeben müssen, um auf das OLE-Objekt zu verweisen, verwenden Sie die Eigenschaft Class.

Anmerkung

Die Eigenschaften OLEClass und Class ähneln sich zwar, sind aber nicht identisch. Die Einstellung der Eigenschaft OLEClass ist eine allgemeine Beschreibung des OLE-Objekts, während die Einstellung der Eigenschaft Class der Name ist, mit dem in Visual Basic auf das OLE-Objekt verwiesen wird. Beispiele für die Einstellung der Eigenschaft OLEClass sind: Microsoft Excel Chart, Microsoft Word Document und Paintbrush Picture.


 OLEData-Eigenschaft

OLEData-Eigenschaft

Mit der Eigenschaft OLEData können Sie Daten aus einem ungebundenen Objektfeld in ein anderes oder aus einem ActiveX-Steuerelement in ein anderes kopieren.

Einstellung

Steuerelementname.OLEData

Die Eigenschaft OLEData verwendet die folgenden Einstellungen:

Einstellung | Beschreibung
Steuerelementname | Erforderlich. Der Name des ungebundenen Objektfeld-Steuerelements.
OLEData | Erforderlich. Die Daten in einem ungebundenen Objektfeld oder ActiveX-Steuerelement.

Die Eigenschaft OLEData ist nur in Visual Basic verfügbar. Für ActiveX-Steuerelemente kann die Eigenschaft OLEData eines ActiveX-Steuerelements nur in der Entwurfsansicht auf die Eigenschaft OLEData eines anderen ActiveX-Steuerelements eingestellt werden.

Anmerkung

Sie können diese Eigenschaft verwenden, um in einem ungebundenen Objektfeld Daten anzuzeigen, die auf den Daten in einem anderen ungebundenen Objektfeld basieren.

Wenn Sie die Eigenschaft OLEData eines ActiveX-Steuerelements auf den Wert der Eigenschaft OLEData eines anderen ActiveX-Steuerelements einstellen, wird das erste ActiveX-Steuerelement zu einer weiteren Instanz des zweiten ActiveX-Steuerelements. Das Ergebnis der folgenden Eigenschaftenzuweisung besteht z.B. darin, dass das Hierarchieansicht-Steuerelement in ein Kalender-Steuerelement geändert wird:

Me!HierarchieansichtSteuerelement1.OLEData = Me!KalenderSteuerelement1.OLEData


 OLEType-Eigenschaft (OLETyp)

OLEType-Eigenschaft (OLETyp)

Mit der Eigenschaft OLEType können Sie ermitteln, ob ein Steuerelement ein OLE-Objekt enthält und, sofern dies der Fall ist, ob das Objekt verknüpft oder eingebettet ist.

Einstellung

Die Eigenschaft OLEType verwendet die folgenden Einstellungen.

Einstellung | Konstante | Beschreibung
Verknüpft | acOLELinked (0) | Das Steuerelement enthält ein verknüpftes Objekt. Alle Daten des Objekts werden von der Anwendung verwaltet, mit der das Objekt erstellt wurde.
Eingebettet | acOLEEmbedded (1) | Das Steuerelement enthält ein eingebettetes Objekt. Alle Daten des Objekts werden von Microsoft Access verwaltet.
Keines | acOLENone (3) | Das Steuerelement enthält kein OLE-Objekt.

Die Eigenschaft OLEType ist in allen Ansichten schreibgeschützt.

Anmerkung

Wenn Sie ein OLE-Objekt erstellen, können Sie über die Eigenschaft OLETypeAllowed ermitteln, welchen Typ von Objekt ein Steuerelement enthalten kann.


 OLETypeAllowed-Eigenschaft (ZugelasseneOLEObjektart)

OLETypeAllowed-Eigenschaft (ZugelasseneOLEObjektart)

Mit der Eigenschaft OLETypeAllowed können Sie angeben, welchen Typ von OLE-Objekt ein Steuerelement enthalten kann.

Einstellung

Die Eigenschaft OLETypeAllowed verwendet die folgenden Einstellungen.

Einstellung | Konstante | Beschreibung
Verknüpft | acOLELinked (0) | Das Steuerelement kann nur ein verknüpftes Objekt enthalten.
Eingebettet | acOLEEmbedded (1) | Das Steuerelement kann nur ein eingebettetes Objekt enthalten.
Beides | acOLEEither (2) | (Standardeinstellung) Das Steuerelement kann entweder ein verknüpftes oder ein eingebettetes Objekt enthalten.

Sie können die Eigenschaft OLETypeAllowed im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen. Die Standardeinstellung dieser Eigenschaft können Sie mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung Bei ungebundenen Objektfeldern und bei Diagrammen können Sie die Einstellung der Eigenschaft OLETypeAllowed nicht mehr ändern, nachdem das entsprechende Objekt erstellt wurde. Bei gebundenen Objektfeldern dagegen können Sie die Einstellung ändern, nachdem das Objekt erstellt wurde. Änderungen, die Sie an der Einstellung der Eigenschaft OLETypeAllowed vornehmen, wirken sich nur auf neue Objekte aus, die Sie zu dem Steuerelement hinzufügen.

Anmerkung

Wenn Sie wissen möchten, welchen Typ das OLE-Objekt hat, das in einem Steuerelement enthalten ist, können Sie die Eigenschaft OLEType verwenden.


 OpenArgs-Eigenschaft (Öffnungsargumente)

OpenArgs-Eigenschaft (Öffnungsargumente)

Mit der Eigenschaft OpenArgs können Sie den Zeichenfolgeausdruck ermitteln, der durch das Argument Öffnungsargumente der Methode OpenForm angegeben wurde, die das jeweilige Formular geöffnet hat.

Einstellung

Diese Eigenschaft steht nur in einem Makro oder in Visual Basic zur Verfügung und in Visual Basic wiederum nur mit der Methode OpenForm des Objekts DoCmd. Diese Eigenschaft ist in allen Ansichten schreibgeschützt.

Anmerkung

Wenn Sie die Eigenschaft OpenArgs verwenden möchten, öffnen Sie mit der Methode OpenForm des Objekts DoCmd ein Formular und stellen das Argument Öffnungsargumente auf den gewünschten Zeichenfolgeausdruck ein. Die Einstellung der Eigenschaft OpenArgs kann dann in Code des Formulars verwendet werden, wie z.B. in der Open-Ereignisprozedur. Sie können die Einstellung dieser Eigenschaft auch in einem Makro, z.B. in einem Öffnen-Makro, oder in einem Ausdruck abfragen, z.B. in einem Ausdruck, der die Eigenschaft ControlSource eines Steuerelements des Formulars einstellt.

Nehmen Sie z.B. an, das Formular, das Sie öffnen, ist eine als Endlosformular gestaltete Kundenliste. Soll der Fokus auf einen ganz bestimmten Kundendatensatz verschoben werden, sobald das Formular geöffnet wurde, können Sie wie folgt vorgehen: Stellen Sie die Eigenschaft OpenArgs auf den Namen des Kunden ein; verwenden Sie dann in einem Öffnen-Makro die Aktion SuchenDatensatz, um den Fokus auf den Datensatz des Kunden zu verschieben, dessen Namen Sie angegeben haben.


 Operator-Eigenschaft (FormatCondition-Objekt)

Operator-Eigenschaft (FormatCondition-Objekt)

Mit der Operator-Eigenschaft können Sie den Operatorwert für die bedingte Formatierung oder Gültigkeitsprüfung eines FormatCondition-Objekts zurückgeben.

Einstellung

Die Operator-Eigenschaft gibt eine der folgenden eingebauten Konstanten zurück.

acBetween (0) | acLessThan (5)
acEqual (2) | acLessThanOrEqual (7)
acGreaterThan (4) | acNotBetween (1)
acGreaterThanOrEqual (6) | acNotEqual (3)

Die Operator-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Die eingebauten Konstanten der Operator-Eigenschaft werden in Verbindung mit den Expression1- und Expression2-Eigenschaften sowie der Add-Methode des FormatConditions-Objekts für bedingte Formatierung und Gültigkeitsprüfung verwendet.


 OptionValue-Eigenschaft (Optionswert)

OptionValue-Eigenschaft (Optionswert)

Jedes Steuerelement einer Optionsgruppe hat einen numerischen Wert, den Sie mit der Eigenschaft OptionValue einstellen können. Ist das Steuerelement ausgewählt, so wird diese Zahl der Optionsgruppe zugewiesen. Ist die Optionsgruppe an ein Feld gebunden, so wird der Wert der Eigenschaft OptionValue des ausgewählten Steuerelements in dem Feld gespeichert.

Die Optionsgruppe Region ist z.B. an das Feld Region einer Tabelle gebunden. Die Schaltfläche Europa hat die Einstellung 1 für die Eigenschaft OptionValue, die Schaltfläche Asien hat die Einstellung 2, und die Schaltfläche Afrika hat die Einstellung 3. Wird eine dieser Schaltflächen ausgewählt, so entspricht der Wert der Optionsgruppe Region der Einstellung der Eigenschaft OptionValue für das ausgewählte Steuerelement. In diesem Fall, da die Optionsgruppe Region an das Feld Region gebunden ist, ist der Wert dieses Feldes in der Tabelle ebenfalls 2.

Anmerkung Die Eigenschaft OptionValue gilt nur für die Kontrollkästchen-, Optionsfeld- und Umschaltfläche-Steuerelemente einer Optionsgruppe.

Einstellung

Die Eigenschaft OptionValue enthält einen Wert vom Typ Long Integer oder einen numerischen Ausdruck, der einem Steuerelement innerhalb eines Optionsgruppen-Steuerelements zugeordnet ist.

Sie können die Eigenschaft OptionValue im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wenn Sie nicht selbst die Eigenschaft OptionValue ändern, erhält das erste Steuerelement in einer Optionsgruppe den Wert 1, das zweite Steuerelement den Wert 2 usw.

Die Eigenschaft OptionValue ist nur verfügbar, wenn das Steuerelement innerhalb eines Optionsgruppen-Steuerelements abgelegt wurde. Befindet sich ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld nicht in einer Optionsgruppe, so hat das Steuerelement die Eigenschaft OptionValue nicht. Statt dessen verfügen alle derartigen Steuerelemente über die Eigenschaft ControlSource. Der Wert eines ausgewählten Steuerelements ist True (-1), und der Wert eines nicht ausgewählten Steuerelements ist False (0).


 OrderBy-Eigenschaft (SortiertNach)

OrderBy-Eigenschaft (SortiertNach)

Mit der Eigenschaft OrderBy können Sie angeben, wie Datensätze in einem Formular, einer Abfrage, einem Bericht oder einer Tabelle sortiert werden sollen.

Anmerkung In einem Microsoft Access-Projekt (.adp) wird diese Eigenschaft ignoriert. Zum Festlegen der Sortierreihenfolge müssen Sie die ServerFilter-Eigenschaft verwenden.

Einstellung

Die Eigenschaft OrderBy ist ein Zeichenfolgenausdruck, der den Namen des Feldes oder der Felder angibt, nach dem oder denen die Datensätze sortiert werden sollen. Wenn Sie mehrere Feldnamen angeben, müssen Sie die Namen durch Semikolons (;) voneinander trennen.

Wenn Sie die Eigenschaft OrderBy durch das Eingeben eines oder mehrerer Feldnamen einstellen, sind die Datensätze in aufsteigender Reihenfolge sortiert. Auch in Visual Basic werden diese Felder standardmäßig in aufsteigender Reihenfolge sortiert.

Falls Sie Datensätze in absteigender Reihenfolge sortieren möchten, geben Sie DESC am Ende des Zeichenfolgenausdrucks ein. Sie ordnen z.B. Kundendatensätze in absteigender Reihenfolge nach dem Namen der Kontaktperson, indem Sie die Eigenschaft OrderBy auf Kontaktperson DESC einstellen.

Sie können die Eigenschaft OrderBy im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Für Berichte muss die Eigenschaft OrderByOn auf Ja eingestellt werden, damit die Sortierreihenfolge angewendet wird, die in der Eigenschaft OrderBy des Objekts angegeben ist. Bei Formularen wählen Sie das Feld aus, nach dem die Datensätze sortiert werden sollen, und klicken Sie in der Symbolleiste auf die entsprechende Sortieren-Schaltfläche, oder zeigen Sie im Menü Datensätze auf Sortierung, und klicken Sie dann im Untermenü auf den entsprechenden Befehl. Sie können die Eigenschaft OrderByOn für Formulare und für Berichte auch in Visual Basic einstellen.

Durch das Einstellen der OrderBy-Eigenschaft für einen geöffneten Bericht werden die Close- und Open-Ereignisprozeduren des Berichts ausgeführt.

Anmerkung Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die Eigenschaften RecordSource, Filter, OrderBy und OrderByOn. Bei Formularen und Berichten werden geerbte Filter nicht automatisch angewendet, wenn ein Objekt geöffnet wird.


 OrderByOn-Eigenschaft (SortierungAktiv)

OrderByOn-Eigenschaft (SortierungAktiv)

Mit der Eigenschaft OrderByOn können Sie angeben, ob die Einstellung der Eigenschaft OrderBy eines Objekts angewendet wird.

Anmerkung In einem Microsoft Access-Projekt (.adp) wird diese Eigenschaft ignoriert. Zum Festlegen der Sortierreihenfolge müssen Sie die ServerFilter-Eigenschaft verwenden.

Einstellung

Die Eigenschaft OrderByOn verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Einstellung der OrderBy-Eigenschaft wird angewendet, wenn das Objekt geöffnet wird.
Nein | False (0) | (Voreinstellung) Die Einstellung der OrderBy-Eigenschaft wird nicht angewendet, wenn das Objekt geöffnet wird.

Für Berichte können Sie die OrderByOn-Eigenschaft im Eigenschaftenfenster des Berichts, in einem Makro oder in Visual Basic einstellen.

Für alle anderen Objekte können Sie die Eigenschaft OrderByOn einstellen, indem Sie in der Symbolleiste auf eine der Schaltflächen zum Sortieren klicken oder Visual Basic verwenden.

Anmerkung

Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die Eigenschaften RecordSource, Filter, OrderBy, OrderByOn und FilterOn.


 OrganizeInFolder-Eigenschaft

OrganizeInFolder-Eigenschaft

Mit Hilfe der OrganizeInFolder-Eigenschaft können Sie angeben oder ermitteln, ob alle Hilfsdateien, beispielsweise Bilddateien, in einen separaten Ordner oder zusammen mit der Datenzugriffsseite gespeichert werden.

Einstellung

Die OrganizeInFolder-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Hilfsdateien werden in einem eigenen Ordner verwaltet, wenn Sie das Dokument als Datenzugriffsseite speichern.
Nein | False (0) | Die Hilfsdateien werden im gleichen Ordner wie die Datenzugriffsseite gespeichert.

Die OrganizeInFolder-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Der neue Ordner wird innerhalb des Ordners erstellt, in dem Sie die Webseite gespeichert haben, und wird nach dem Dokument benannt. Falls lange Dateinamen verwendet werden, wird ein Suffix an den Ordnernamen angehängt. Die FolderSuffix-Eigenschaft gibt das Ordnersuffix für die jeweils ausgewählte bzw. installierte Sprachunterstützung oder das Standardordnersuffix zurück.

Wenn Sie ein Dokument speichern, das ursprünglich mit einer anderen Einstellung der OrganizeInFolder-Eigenschaft gespeichert worden ist, verschiebt Microsoft Access die Hilfsdateien je nach eingestelltem Wert automatisch in den oder aus dem Ordner.

Falls Sie keine langen Dateinamen verwenden (d. h. wenn die UseLongFileNames-Eigenschaft auf False gesetzt ist), speichert Microsoft Access die Hilfsdateien automatisch in einem separaten Ordner. Die Dateien können nicht im gleichen Ordner wie die Webseite gespeichert werden.


 Orientation-Eigenschaft

Orientation-Eigenschaft

Sprachspezifische Informationen

You can use the Orientation property to specify or determine the view orientation for tables, queries, forms, and reports.

Setting

The Orientation property uses the following settings.

Setting | Visual Basic | Description
Left-to-Right | 0 | Sets the view orientation to left to right.
Right-to-Left | 1 | Sets the view orientation to right to left.

You can set this property by using the property sheet or Visual Basic.

Remarks

The Orientation property directly influences how tables and queries are displayed, The appearance of forms and reports is initially determined by the Orientation property, but you can subsequently change controls and the layout of menu bars.


 OutputAllFields-Eigenschaft (AlleFelderAusgeben)

OutputAllFields-Eigenschaft (AlleFelderAusgeben)

Sie können die Eigenschaft OutputAllFields verwenden, um alle Felder in der der Abfrage zugrunde liegenden Datenherkunft und in der Feldliste eines Formulars oder Berichts anzuzeigen. Die Einstellung dieser Eigenschaft ist die einfachste Möglichkeit zum Anzeigen aller Felder, ohne dass das Feld Anzeigen im Abfrageentwurfsbereich für jedes Feld in der Abfrage aktiviert werden muss.

Anmerkung Die Eigenschaft OutputAllFields gilt nur für Anfüge-, Tabellenerstellungs- und Auswahlabfragen.

Einstellung

Die Eigenschaft OutputAllFields verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Zeigt alle Felder in den zugrunde liegenden Tabellen und in der Feldliste eines Formulars oder Berichts an.
Nein | (Voreinstellung) Zeigt nur Felder an, bei denen das Feld Anzeigen im Abfrageentwurfsbereich aktiviert ist.

Sie können diese Eigenschaft nur im Abfrage-Eigenschaftenfenster einstellen.

Anmerkung Ein Sternchen (*) in der SQL-Anweisung an Stelle eines Feldnamens entspricht der Einstellung der Eigenschaft OutputAllFields auf Ja.

Anmerkung

Ist die Eigenschaft OutputAllFields auf Ja eingestellt, so müssen Sie lediglich die Felder in den Abfrageentwurfsbereich einfügen, nach denen Sie sortieren oder für die Sie Kriterien festlegen möchten.

Wenn Sie einen Filter als Abfrage speichern, stellt Microsoft Access die Eigenschaft OutputAllFields auf Ja ein.


 Page-, Pages-Eigenschaft (Seite, Seiten)

Page-, Pages-Eigenschaft (Seite, Seiten)

Mit den Eigenschaften Page und Pages können Sie Informationen zurückgeben, die benötigt werden, um auf einem Formular oder Bericht Seitenzahlen zu drucken. Sie können diese Eigenschaften z.B. verwenden, um im Seitenfuß eines Berichts "Seite n von nn" zu drucken.

  • Die Eigenschaft Page gibt die aktuelle Seitenzahl an, wenn ein Formular oder ein Bericht gedruckt wird.

  • Die Eigenschaft Pages gibt die Gesamtzahl der Seiten eines Formulars oder Berichts an.

Einstellung

Sie können die Eigenschaft Page zwar auf einen Wert des Typs Integer einstellen, verwenden diese Eigenschaft aber normalerweise, um Informationen zu den Seitenzahlen zurückzugeben. Beide Eigenschaften geben einen Integer-Wert zurück, wenn sie in einem Ausdruck verwendet werden.

Sie können die Eigenschaften Page und Pages in einem Ausdruck, in einem Makro oder in Visual Basic verwenden.

Diese Eigenschaften sind nur in der Seitenansicht oder beim Drucken verfügbar.

Die Eigenschaft Pages ist immer schreibgeschützt.

Anmerkung

Damit Sie in einem Makro oder in Visual Basic auf die Eigenschaft Pages verweisen können, muss das Formular oder der Bericht ein Textfeld enthalten, dessen Eigenschaft ControlSource auf einen Ausdruck eingestellt ist, in dem Pages verwendet wird. Beispielsweise können Sie die Eigenschaft ControlSource für ein Textfeld, das sich in einem Seitenfuß befindet, auf einen der folgenden Ausdrücke einstellen.

Ausdruck | Es wird gedruckt
=Seite | Eine Seitenzahl (z.B. 1, 2, 3) im Seitenfuß.
="Seite " & Seite & " von " & Seiten | "Seite n von nn" (z.B. Seite 1 von 5, Seite 2 von 5) im Seitenfuß.
=Seiten | Die Gesamtzahl der Seiten des Formulars oder Berichts (z.B. 5).


 PageCount-Eigenschaft (Seitenzahl)

PageCount-Eigenschaft (Seitenzahl)

Mit der PageCount-Eigenschaft können Sie die Anzahl der Seiten in einem Snapshot ermitteln.

Einstellung

Die PageCount-Eigenschaft ist ein Long-Wert, der die Anzahl der Seiten in einem Snapshot wiedergibt.

Diese Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Wenn Sie versuchen, die PageCount-Eigenschaft zu verwenden und keine gültige Snapshot-Datei geöffnet ist, tritt ein Fehler auf.


 PageHeader-, PageFooter-Eigenschaft (Seitenkopf, Seitenfuß)

PageHeader-, PageFooter-Eigenschaft (Seitenkopf, Seitenfuß)

Mit den Eigenschaften PageHeader und PageFooter können Sie angeben, ob der Seitenkopf bzw. Seitenfuß eines Berichts auf derselben Seite gedruckt werden soll wie der Berichtskopf bzw. der Berichtsfuß. Wenn der Berichtskopf eines Berichts ein Deckblatt ist, können Sie z.B. verhindern, dass auf der ersten Seite des Berichts ein Seitenkopf gedruckt wird, der eine Seitenzahl enthält.

Einstellung

Die Eigenschaften PageHeader und PageFooter verwenden die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Alle Seiten | 0 | (Standardeinstellung) Der Seitenkopf oder -fuß wird auf allen Seiten des Berichts gedruckt.
Außer Berichtskopf | 1 | Der Seitenkopf oder -fuß wird nicht auf derselben Seite wie der Berichtskopf gedruckt.
Außer Berichtsfuß | 2 | Der Seitenkopf oder -fuß wird nicht auf derselben Seite wie der Berichtsfuß gedruckt. Microsoft Access druckt den Berichtsfuß auf einer neuen Seite.
Außer Berichtskopf/-fuß | 3 | Der Seitenkopf oder -fuß wird nicht auf einer Seite gedruckt, die einen Berichtskopf oder Berichtsfuß hat. Microsoft Access druckt den Berichtsfuß auf einer neuen Seite.

Sie können diese Eigenschaften im Eigenschaftenfenster des Berichts, in einem Makro oder in Visual Basic einstellen.

Sie können die Eigenschaften PageHeader und PageFooter nur in der Berichtsentwurfsansicht einstellen.

Anmerkung

Microsoft Access druckt den Seitenkopf oder Seitenfuß eines Berichts normalerweise auf jeder Seite des Berichts (einschließlich der ersten und der letzten Seite).

Klicken Sie in der Entwurfsansicht eines Berichts im Menü Ansicht auf Seitenkopf/-fuß, um den Seitenkopf- und den Seitenfußbereich anzuzeigen.

Anmerkung Beim Drucken von Formularen werden Seitenköpfe und Seitenfüße immer auf allen Seiten gedruckt.


 PageIndex-Eigenschaft (SeiteIndex)

PageIndex-Eigenschaft (SeiteIndex)

Mit der PageIndex-Eigenschaft können Sie die Position angeben oder ermitteln, die ein Page-Objekt innerhalb einer Pages-Auflistung einnimmt. Die Eigenschaft PageIndex gibt die Reihenfolge an, in der die Seiten (Registerkarten) eines Registersteuerelements angezeigt werden.

Einstellung

Die Einstellung der Eigenschaft PageIndex ist ein Wert des Datentyps Integer, der zwischen 0 und dem um 1 verringerten Wert liegt, den die Eigenschaft Count der Pages-Auflistung hat.

Sie können die Eigenschaft PageIndex im Eigenschaftenfenster eines Page-Objekts, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft PageIndex kann in jeder Ansicht eingestellt werden.

Anmerkung

Wenn Sie den Wert der Eigenschaft PageIndex ändern, ändert sich die Position, die ein Page-Objekt in der Pages-Auflistung einnimmt, und ändert sich damit die Reihenfolge, in der die Seiten eines Registersteuerelements angezeigt werden.

Sie können die Reihenfolge der Page-Objekte einer Pages-Auflistung auch im Dialogfeld Seitenreihenfolge ändern. Dieses Dialogfeld wird angezeigt, wenn Sie in der Entwurfsansicht mit der rechten Maustaste auf das Registersteuerelement und anschließend auf Seitenreihenfolge klicken.


 Painting-Eigenschaft (Bildschirm aktualisieren)

Painting-Eigenschaft (Bildschirm aktualisieren)

Mit der Eigenschaft Painting können Sie angeben, ob die Darstellung von Formularen oder Berichten aktualisiert werden soll.

Einstellung

Die Eigenschaft Painting kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True (-1) | (Standardeinstellung) Das Formular oder der Bericht wird aktualisiert.
False (0) | Das Formular oder der Bericht wird nicht aktualisiert.

Sie können diese Eigenschaft in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann nur in der Formularansicht eingestellt werden und steht in den anderen Ansichten nicht zur Verfügung.

Anmerkung

Die Eigenschaft Painting ähnelt der Aktion Echo. Jedoch unterbindet die Eigenschaft Painting die Aktualisierung eines einzelnen Formulars oder Berichts, während die Aktion Echo die Aktualisierung aller offenen Fenster in einer Anwendung unterbindet.

Die Einstellung der Eigenschaft Painting für ein Formular oder einen Bericht auf False unterbindet auch die Aktualisierung aller Steuerelemente (ausgenommen Unterformular- oder Unterbericht-Steuerelemente) in einem Formular oder einem Bericht. Damit die Aktualisierung eines Unterformular- oder Unterbericht-Steuerelements unterbunden wird, stellen Sie die Eigenschaft Painting für das Unterformular oder den Unterbericht auf False ein. (Beachten Sie, dass Sie die Eigenschaft Painting für das Unterformular oder den Unterbericht einstellen und nicht für das Unterformular- oder Unterbericht-Steuerelement.)

Die Eigenschaft Painting wird immer dann automatisch auf True eingestellt, wenn das Formular oder der Bericht den Fokus erhält oder verliert. Wenn Sie möchten, dass die an einem Formular oder Bericht bzw. an dessen Steuerelementen vorgenommenen Änderungen nicht zu sehen sind, können Sie diese Eigenschaft auf False einstellen, während mit dem Formular oder Bericht gearbeitet wird. Angenommen, ein Formular hat mehrere Steuerelemente, deren Größen automatisch angepasst werden, wenn die Größe des Formulars geändert wird. Wenn Sie nicht möchten, dass der Benutzer das Verschieben jedes Steuerelements sehen kann, können Sie die Eigenschaft Painting auf False einstellen, danach die Steuerelemente verschieben und dann Painting wieder auf True einstellen.


 PaintPalette-Eigenschaft (Farbpalette)

PaintPalette-Eigenschaft (Farbpalette)

Mit der Eigenschaft PaintPalette können Sie die Palette angeben, die für ein Formular oder einen Bericht verwendet werden soll.

Einstellung

Sie können die Eigenschaft PaintPalette in einem Makro oder in Visual Basic einstellen. Diese Eigenschaft muss auf einen Wert des Datentyps String eingestellt sein, der die Paletteninformationen enthält.

Sie können die Eigenschaft PaintPalette einstellen, indem Sie ihr in einem Makro oder in Visual Basic den Wert der Eigenschaft ObjectPalette zuweisen, indem Sie die Eigenschaft PaletteSource einstellen (in diesem Fall stellt Microsoft Access die Eigenschaft PaintPalette automatisch auf den Wert von PaletteSource ein) oder indem Sie die Eigenschaft PaintPalette eines Formulars oder Berichts auf die Eigenschaft PaintPalette eines anderen Formulars oder Berichts einstellen.

Bei einem Formular können Sie die Eigenschaft PaintPalette in der Formularentwurfsansicht und der Formularansicht einstellen.

Bei einem Bericht können Sie die Eigenschaft PaintPalette nur in der Berichtsentwurfsansicht einstellen.

Anmerkung

Wenn Sie die Eigenschaft PaintPalette einstellen, legt Microsoft Access eine Kopie der von Ihnen angegebenen Palette an und speichert diese zusammen mit dem Formular oder Bericht. Die Palette ist dann verfügbar, wenn Sie das Formular oder den Bericht verändern.

Änderungen an der Palette, die Sie beim Einstellen der Eigenschaft PaintPalette angegeben haben, haben keine Auswirkungen auf die mit dem Formular oder dem Bericht gespeicherte Kopie der Palette. Möchten Sie diese Kopie der Palette aktualisieren, so müssen Sie den Code oder das Makro zum Einstellen der Eigenschaft PaintPalette erneut ausführen oder die Eigenschaft PaletteSource zurücksetzen, während das Formular oder der Bericht geöffnet ist.

Wenn Sie die Eigenschaft PaintPalette für ein Formular oder einen Bericht einstellen, aktualisiert Microsoft Access automatisch die zugehörige Eigenschaft PaletteSource. Analog dazu wird die Eigenschaft PaintPalette aktualisiert, wenn Sie die Eigenschaft PaletteSource für ein Formular oder einen Bericht einstellen. Wenn Sie z.B. eine benutzerdefinierte Palette mit Hilfe der Eigenschaft PaintPalette angeben, wird die Einstellung der Eigenschaft PaletteSource in (Benutzerdefiniert) geändert. Mit der Eigenschaft PaintPalette (die nur in einem Makro oder in Visual Basic verfügbar ist) wird die Palette des Formulars oder Berichts eingestellt. Die Eigenschaft PaletteSource ermöglicht es Ihnen, die Palette für das Formular oder den Bericht im Eigenschaftenfenster anzugeben, indem Sie eine vorhandene Grafikdatei verwenden.

Anmerkung Unter Microsoft Windows kann nur jeweils eine Farbpalette aktiv sein. Microsoft Access ermöglicht Ihnen, mehrere Grafiken in einem Formular zu verwalten, die jeweils eine andere Farbpalette haben. Mit den Eigenschaften PaintPalette und PaletteSource können Sie angeben, welche Farbpalette ein Formular beim Anzeigen von Grafiken verwenden soll.

Mit der Eigenschaft ObjectPalette können Sie die Palette einer Anwendung, die einem OLE-Objekt, einer Bitmap oder einer sonstigen, in einem Steuerelement eines Formulars oder Berichts enthaltenen Grafik zugeordnet ist, für die Eigenschaft PaintPalette verfügbar machen. Wenn Sie z.B. in Microsoft Access ein Formular erstellen und dafür die Palette zur Verfügung stellen möchten, die in Microsoft Graph verwendet wird, stellen Sie die Eigenschaft PaintPalette des Formulars auf den Wert der Eigenschaft ObjectPalette eines vorhandenen Diagramm-Steuerelements ein.


 PaletteSource-Eigenschaft (Palettenherkunft)

PaletteSource-Eigenschaft (Palettenherkunft)

Mit der Eigenschaft PaletteSource können Sie die Palette für ein Formular oder einen Bericht angeben.

Einstellung

Geben Sie den Pfad und Dateinamen eines der folgenden Dateitypen ein:

  • .DIB (Datei mit geräteunabhängiger Bitmap)

  • .PAL (Microsoft Windows-Palettendatei)

  • .ICO (Microsoft Windows-Symboldatei)

  • .BMP (Microsoft Windows Bitmap-Datei)

  • .WMF- oder .EMF-Datei oder sonstige Grafikdatei, für die Sie einen Grafikfilter haben

Die Standardeinstellung ist (Standard), d.h., die in Microsoft Access enthaltene Palette wird verwendet. Ändern Sie diese Einstellung durch Eingabe eines Pfades und Dateinamens, so zeigt die Eigenschafteneinstellung das Wort (Benutzerdefiniert) an.

Sie können diese Eigenschaft im Eigenschaftenfenster eines Formulars oder Berichts, in einem Makro oder in Visual Basic einstellen.

Bei einem Formular können Sie die Eigenschaft PaletteSource in der Formularentwurfsansicht und in der Formularansicht einstellen. In den anderen Ansichten steht die Einstellung dieser Eigenschaft nicht zur Verfügung.

Bei einem Bericht können Sie die Eigenschaft PaletteSource nur in der Berichtsentwurfsansicht einstellen. In den anderen Ansichten steht die Einstellung dieser Eigenschaft nicht zur Verfügung.

Anmerkung

Unter Microsoft Windows kann nur jeweils eine Farbpalette aktiv sein. Mit Microsoft Access können Sie mehrere Grafiken in einem Formular verwalten, die jeweils eine andere Farbpalette haben. Mit den Eigenschaften PaletteSource und PaintPalette geben Sie an, welche Farbpalette ein Formular für das Anzeigen von Grafiken verwenden soll.

Wenn Sie die Eigenschaft PaletteSource für ein Formular oder einen Bericht einstellen, aktualisiert Microsoft Access automatisch die zugehörige Eigenschaft PaintPalette. Analog dazu wird die Eigenschaft PaletteSource aktualisiert, wenn Sie die Eigenschaft PaintPalette für ein Formular oder einen Bericht einstellen. Wenn Sie z.B. eine benutzerdefinierte Palette mit Hilfe der Eigenschaft PaintPalette angeben, wird die Einstellung der Eigenschaft PaletteSource in (Benutzerdefiniert) geändert. Mit der Eigenschaft PaintPalette (die nur in einem Makro oder in Visual Basic verfügbar ist) wird die Palette des Formulars oder Berichts eingestellt. Die Eigenschaft PaletteSource ermöglicht es Ihnen, die Palette für das Formular oder den Bericht im Eigenschaftenfenster anzugeben, indem Sie eine vorhandene Grafikdatei verwenden.


 Parent-Eigenschaft (Hauptobjekt)

Parent-Eigenschaft (Hauptobjekt)

Sie können die Parent-Eigenschaft verwenden, um auf das Hauptobjekt eines Steuerelements, eines Bereichs oder eines Steuerelements zu verweisen, das andere Steuerelemente enthält. Die Parent-Eigenschaft gibt ein Steuerelementobjekt zurück, falls das Hauptobjekt ein Steuerelement ist, oder ein AccessObject-Objekt, falls das Hauptobjekt ein Microsoft Access-Objekt ist.

Einstellung

Die Parent-Eigenschaft verweist auf ein AccessObject-Objekt oder ein Steuerelementobjekt und ist in allen Ansichten schreibgeschützt.

Anmerkung

Sie können die Eigenschaft Parent verwenden, um zu ermitteln, welches Formular oder welcher Bericht momentan das Hauptobjekt ist, wenn Sie ein Unterformular oder einen Unterbericht haben, das bzw. der in mehrere Formulare oder Berichte eingefügt wurde.

Sie können z. B. ein Unterformular mit dem Namen Bestelldetail sowohl in ein Formular als auch in einen Bericht einfügen. Das folgende Beispiel verwendet die Eigenschaft Parent zum Verweisen auf das Feld Bestell-Nr, das sowohl im Hauptformular als auch im Hauptbericht enthalten ist. Sie können diesen Ausdruck in ein gebundenes Steuerelement des Unterformulars eingeben.

= Parent![Bestell-Nr]

Die Eigenschaft Parent eines Bezeichnungsfeld-Steuerelements entspricht dem Steuerelement, mit dem das Bezeichnungsfeld verknüpft ist. Die Eigenschaft Parent eines Kontrollkästchens, eines Optionsfelds oder einer Umschaltfläche einer Optionsgruppe entspricht dem Namen des Optionsgruppen-Steuerelements. Die Eigenschaft Parent eines Optionsgruppen-Steuerelements entspricht dem Namen des Formulars.


 Path-Eigenschaft

Path-Eigenschaft

Mit Hilfe der Path-Eigenschaft können Sie den Ort bestimmen, an dem Daten für ein Microsoft Access-Projekt (.adp) oder eine Microsoft Access-Datenbank (.mdb) gespeichert werden.

Einstellung

Die Path-Eigenschaft ist ein Zeichenfolgenausdruck, der den Pfadnamen zu dem Speicherort angibt, an dem die Daten für eine Access-Datenbank gespeichert sind.

Diese Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Mit Hilfe der Path-Eigenschaft können Sie den Speicherort von Informationen bestimmen, die von den CurrentProject- bzw. CodeProject-Objekten eines Projekts oder einer Datenbank gespeichert werden.


 Picture-Eigenschaft (Bild)

Picture-Eigenschaft (Bild)

Sie können die Eigenschaft Picture verwenden, um eine Bitmap oder eine Grafik anderen Typs anzugeben, die auf einer Befehlsschaltfläche, einem Bild-Steuerelement, einer Umschaltfläche, einer Seite auf einem Registersteuerelement oder auf einem Formular bzw. Bericht als Hintergrundbild angezeigt werden soll. Eine Schaltfläche kann entweder eine Beschriftung oder ein Bild anzeigen.

Einstellung

Die Eigenschaft Picture enthält entweder (Bitmap) oder den Pfad und den Dateinamen einer Bitmap oder einer Grafik anderen Typs, die angezeigt werden soll.

Sie können diese Eigenschaft wie folgt einstellen:

  • Im jeweiligen Eigenschaftenfenster. Klicken Sie auf die Generator-Schaltfläche [image] rechts neben dem Eigenschaftenfeld (bei Befehlsschaltflächen und Umschaltflächen). Wenn Sie eine Bitmap aus der Liste Verfügbare Bilder auswählen, wird die Eigenschaft auf (Bitmap) eingestellt.

  • Mit einem Makro.

  • Mit Visual Basic. Sie können einen Zeichenfolgeausdruck verwenden, der den Pfad und den Namen der Grafik enthält, wie im folgenden Beispiel:
    btnLogoAnzeigen.Picture = "c:\Windows\Winlogo.bmp"

  • Mit dem Befehl Grafik aus dem Menü Einfügen (für Bild-Steuerelemente eines Formulars oder Berichts), um eine Bitmap oder eine Grafik anderen Typs auszuwählen.

Die Standardeinstellung ist (keine). Sobald die jeweilige Grafik in das Objekt geladen wurde, wird die Eigenschaft entweder auf (Bitmap) oder auf den Pfad und den Dateinamen der Grafik eingestellt. Wenn Sie (Bitmap) oder den Pfad und den Dateinamen der Grafik aus der Einstellung der Eigenschaft löschen, wird das Bild aus dem Objekt gelöscht und die Eigenschaft wieder auf (keine) eingestellt.

Ist die Eigenschaft PictureType auf Eingebettet eingestellt, wird die Grafik zusammen mit dem Objekt gespeichert.

Anmerkung

Sie können benutzerdefinierte Bitmaps mit Hilfe von Microsoft Paintbrush oder einer anderen Anwendung erstellen, die Bitmap-Dateien erstellen kann. Eine Bitmap-Datei muss eine der Dateinamenerweiterungen .bmp, .ico oder .dib haben. Sie können auch Grafikdateien verwenden, die im .wmf- oder .emf-Format vorliegen, oder Grafikdateien anderen Typs, für die Sie Grafikfilter besitzen. Formulare, Berichte und Bild-Steuerelemente unterstützen alle Grafiken. Befehlsschaltflächen und Umschaltflächen unterstützen nur Bitmaps.

Schaltflächen können entweder eine Beschriftung oder ein Bild anzeigen. Wenn Sie einer Schaltfläche beides zuweisen, wird das Bild angezeigt, die Beschriftung jedoch nicht. Wird das Bild gelöscht, wird wieder die Beschriftung angezeigt. Microsoft Access stellt das Bild auf der Schaltfläche zentriert dar und schneidet überstehende Teile ab, wenn das Bild größer ist als die Schaltfläche.

Tipp Wenn Sie eine Befehlsschaltfläche oder Umschaltfläche erstellen möchten, die sowohl eine Beschriftung als auch ein Bild hat, können Sie die gewünschte Beschriftung als Teil der Bitmap erstellen und die Bitmap der Eigenschaft Picture des Steuerelements zuweisen.


 PictureAlignment-Eigenschaft (Bildausrichtung)

PictureAlignment-Eigenschaft (Bildausrichtung)

Sie können mit der Eigenschaft PictureAlignment angeben, wo in einem Bild-Steuerelement oder in einem Formular oder Bericht ein Hintergrundbild erscheinen soll.

Einstellung

Die Eigenschaft PictureAlignment verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Oben links | 0 | Das Bild wird in der oberen linken Ecke des Bild-Steuerelements, des Formularfensters oder der Seite eines Berichts angezeigt.
Oben rechts | 1 | Das Bild wird in der oberen rechten Ecke des Bild-Steuerelements, des Formularfensters oder der Seite eines Berichts angezeigt.
Mitte | 2 | (Voreinstellung) Das Bild wird mittig im Bild-Steuerelement, im Formularfenster oder auf der Seite eines Berichts angezeigt.
Unten links | 3 | Das Bild wird in der unteren linken Ecke des Bild-Steuerelements, des Formularfensters oder der Seite eines Berichts angezeigt.
Unten rechts | 4 | Das Bild wird in der unteren rechten Ecke des Bild-Steuerelements, des Formularfensters oder der Seite eines Berichts angezeigt.
Formularmitte | 5 | (Nur Formulare) Das Bild des Formulars wird horizontal im Verhältnis zur Breite des Formulars und vertikal im Verhältnis zur Höhe des Formulars zentriert.

Sie können die PictureAlignment-Eigenschaft mit dem Eigenschaftenfenster des Formulars oder Berichts, mit einem Makro oder mit Visual Basic einstellen.

Sie können die Standardeinstellung dieser Eigenschaft auch in den Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

Diese Eigenschaft kann in jeder Ansicht eingestellt werden.

Anmerkung

Die Einstellung Formularmitte richtet das Bild eines Formulars in der Mitte dieses Formulars aus. Alle anderen Einstellungen der Eigenschaft PictureAlignment richten das Bild eines Formulars in Bezug auf das Formularfenster aus. Wenn Sie sicherstellen möchten, dass das Bild eines Formulars ausschließlich auf dem Formular angezeigt bzw. nebeneinander angeordnet wird, sollten Sie die Eigenschaft PictureAlignment auf Formularmitte einstellen.

Für Berichte erscheint das Bild relativ zu einer vollständigen Seite und nicht relativ zur Größe des aktuellen Berichts. Wenn Ihr Bericht kleiner als eine vollständige Seite ist und Sie ein Bild an einer Stelle anzeigen möchten, die nicht über die Einstellungen der Eigenschaft PictureAlignment verfügbar ist, verwenden Sie stattdessen ein Bild-Steuerelement.

Wenn Sie die Eigenschaft PictureTiling auf Ja einstellen, erfolgt das Nebeneinanderanordnen des Bildes ab der Stelle, die die Einstellung der Eigenschaft PictureAlignment angibt.


 PictureData-Eigenschaft

PictureData-Eigenschaft

Sie können die Eigenschaft PictureData verwenden, um das Bild, das einem Formular, einem Bericht oder einem Steuerelement zugeordnet ist, in ein anderes Objekt zu kopieren, das die Eigenschaft Picture unterstützt.

Einstellung

Die Einstellung der Eigenschaft PictureData ist gleich der Eigenschaft PictureData eines anderen Bild-Steuerelements, einer anderen Befehlsschaltfläche oder Umschaltfläche, eines anderen Formulars oder Berichts.

Sie stellen diese Eigenschaft mit Visual Basic ein.

Anmerkung

Sie können diese Eigenschaft zum Anzeigen eines Formulars verwenden, das abhängig von Benutzeraktionen verschiedene Hintergrundbilder verwendet. Sie können z.B. ein Formular Kunden mit verschiedenen Hintergrundbildern für die Dateneingabe und für das Blättern öffnen.

Sie können auch die Eigenschaft PictureData zusammen mit dem Timer-Ereignis und der TimerInterval-Eigenschaft zur Ausführung einer einfachen Animation in einem Formular verwenden.


PicturePages-Eigenschaft (Bildseiten)

Sie können mit der Eigenschaft PicturePages angeben, auf welcher Seite oder welchen Seiten eines Berichts ein Bild angezeigt werden soll.

Einstellung

Die Eigenschaft PicturePages verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Alle Seiten | 0 | (Voreinstellung) Das Bild erscheint auf allen Seiten des Berichts.
Erste Seite | 1 | Das Bild erscheint nur auf der ersten Seite des Berichts.
Keine Seiten | 2 | Das Bild erscheint nicht im Bericht.

Sie können die Eigenschaft PicturePages mit dem Eigenschaftenfenster eines Berichts, mit einem Makro oder mit Visual Basic einstellen.


PictureSizeMode-Eigenschaft (Bildgrößenmodus)

Sie können mit der Eigenschaft PictureSizeMode angeben, wie die Größe eines Bildes für ein Formular oder einen Bericht eingestellt werden soll.

Einstellung

Die Eigenschaft PictureSizeMode verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Abschneiden | 0 | (Voreinstellung) Das Bild wird in seiner aktuellen Größe angezeigt. Wenn das Bild größer als das Formular oder der Bericht ist, wird es abgeschnitten.
Dehnen | 1 | Das Bild wird horizontal und vertikal gedehnt, um das gesamte Formular auszufüllen, auch wenn sein Originalverhältnis Höhe zu Breite verzerrt ist.
Zoomen | 3 | Das Bild wird bis zum maximal möglichen Umfang vergrößert, während sein Originalverhältnis Höhe zu Breite beibehalten wird.

Sie können die PictureSizeMode-Eigenschaft mit dem Eigenschaftenfenster des Formulars oder Berichts, mit einem Makro oder mit Visual Basic einstellen.

Anmerkung

Wenn ein kleines Bild für die Eigenschaft Picture eines Formulars oder Berichts verwendet wird, kann die Einstellung der Eigenschaft PictureSizeMode auf Dehnen oder Zoomen eine beträchtliche Verzerrung seiner Auflösung bewirken. Kleinere Bilder können mit Hilfe der Eigenschaft PictureTiling über das gesamte Formular oder den gesamten Bericht nebeneinandergelegt werden.


 PictureTiling-Eigenschaft (BildNebeneinander)

PictureTiling-Eigenschaft (BildNebeneinander)

Sie können mit der Eigenschaft PictureTiling angeben, ob ein Hintergrundbild über das gesamte Bild-Steuerelement, Formularfenster, Formular oder die Seite eines Berichts nebeneinandergelegt werden soll.

Einstellung

Die Eigenschaft PictureTiling verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Bild wird nebeneinandergelegt.
Nein | False (0) | (Voreinstellung) Das Bild wird nicht nebeneinandergelegt.

Sie können die PictureTiling-Eigenschaft mit dem Eigenschaftenfenster des Objekts, mit einem Makro oder mit Visual Basic einstellen.

Sie können die Standardeinstellung dieser Eigenschaft auch in den Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der DefaultControl-Methode einstellen.

Anmerkung

Sie können interessante Effekte erzielen, indem Sie ein Bild in ein Formular oder einen Bericht einfügen und die Eigenschaft PictureTiling auf Ja einstellen. Die Ausrichtung der nebeneinandergelegten Bilder wird durch die Einstellung der Eigenschaft PictureAlignment beeinflusst. Wenn z.B. die Eigenschaft PictureAlignment auf Oben links eingestellt ist, beginnt das Nebeneinanderlegen oben links im Bild-Steuerelement, Formularfenster oder auf der Seite eines Berichts.

Anmerkung Wenn die Eigenschaft PictureAlignment auf Formularmitte und die Eigenschaft PictureTiling auf Ja eingestellt ist, wird das Hintergrundbild eines Formulars auf dem Formular, nicht im Formularfenster nebeneinandergelegt.


 PictureType-Eigenschaft (Bildtyp)

PictureType-Eigenschaft (Bildtyp)

Mit der Eigenschaft PictureType können Sie angeben, ob Microsoft Access das Bild eines Objekts als verknüpftes oder als eingebettetes Objekt speichert.

Einstellungen

Die Eigenschaft PictureType kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Eingebettet | 0 | (Standardeinstellung) Das Bild wird in das Objekt eingebettet und wird Bestandteil der Datenbankdatei.
Verknüpft | 1 | Das Bild wird mit dem Objekt verknüpft. Microsoft Access speichert einen Zeiger auf die Stelle, an der das Bild auf dem Datenträger gespeichert ist.

Sie können die Eigenschaft PictureType im Eigenschaftenfenster des jeweiligen Objekts, mit einem Makro oder mit Visual Basic einstellen.

Diese Eigenschaft kann nur in der Formularentwurfsansicht oder der Berichtsentwurfsansicht eingestellt werden.

Für Steuerelemente können Sie die Standardeinstellung dieser Eigenschaft mit den Standardeigenschafteneinstellungen oder der Methode DefaultControl- in Visual Basic festlegen.

Anmerkung

Wenn diese Eigenschaft auf Eingebettet eingestellt ist, wird die Datenbank um die Größe der Bilddatei vergrößert, wobei diese Vergrößerung bei einigen .WMF-Dateien bis zum Doppelten der Größe der Bilddatei betragen kann. Wenn diese Eigenschaft auf Verknüpft eingestellt ist, wird die Datenbank nicht vergrößert, da Microsoft Access nur einen Zeiger auf die Stelle des Datenträgers speichert, an der sich die Bilddatei befindet.

Anmerkung Wenn eine verknüpfte Datei an eine andere Stelle des Datenträgers verschoben wurde, müssen Sie die Verknüpfung mit Hilfe der Eigenschaft Picture neu einrichten.

Für eingebettete Objekte speichert die Eigenschaft PictureData die einzelnen Bits, die das eigentliche Bild ergeben. Für verknüpfte Bilder speichert diese Eigenschaft den Pfad zu der Datei des Bildes.

Sie können ein verknüpftes Bild mit einer separaten Anwendung bearbeiten. Die an dem Bild vorgenommenen Änderungen werden in der Datenbank angezeigt, sobald das Objekt, das das Bild enthält, das nächste Mal angezeigt wird.


 PopUp-Eigenschaft

PopUp-Eigenschaft

Mit der Eigenschaft PopUp können Sie angeben, ob ein Formular als ein Popupformular geöffnet wird. Sie stellen z.B. die Eigenschaft PopUp eines Formulars auf Ja, dessen Eigenschaft Modal auf Ja und dessen Eigenschaft BorderStyle auf Dialog ein, um ein benutzerdefiniertes Dialogfeld zu erstellen.

Einstellung

Die Eigenschaft PopUp kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular wird als ein Popupformular in der Formularansicht geöffnet. Es wird vor allen anderen Microsoft Access-Fenstern angezeigt.
Nein | False (0) | (Standardeinstellung) Das Formular ist kein Popupformular.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Die Eigenschaft PopUp kann nur in der Formularentwurfsansicht eingestellt werden.

Anmerkung

Geben Sie die gewünschte Rahmenart in einem Popupformular mit der Eigenschaft BorderStyle an. In der Regel stellen Sie die Eigenschaft BorderStyle für Popupformulare auf Dünn ein.

Tipp Mit den Eigenschaften PopUp, Modal und BorderStyle können Sie ein benutzerdefiniertes Dialogfeld erstellen, indem Sie die Eigenschaft Modal auf Ja, die Eigenschaft PopUp auf Ja und die Eigenschaft BorderStyle auf Dialog einstellen.

Das Einstellen der Eigenschaft PopUp auf Ja bewirkt die Darstellung des Formulars als Popupformular nur dann, wenn Sie einen der folgenden Schritte ausführen:

  • Öffnen des Formulars in der Formularansicht aus dem Datenbankfenster.

  • Öffnen des Formulars in der Formularansicht mit einem Makro oder Visual Basic.

  • Wechseln von der Entwurfsansicht in die Formularansicht.

Ist die Eigenschaft PopUp auf Ja eingestellt, können Sie aus der Formularansicht nicht zu anderen Ansichten wechseln, da die Symbolleiste des Formulars nicht verfügbar ist. (Sie können bei einem Popupformular nicht aus der Formularansicht in die Datenblattansicht wechseln, auch nicht in einem Makro oder in Visual Basic.) Sie müssen das Formular schließen und erneut in der Entwurfsansicht oder Datenblattansicht öffnen.

Das Formular ist weder in der Entwurfsansicht noch in der Datenblattansicht, noch dann ein Popupformular, wenn Sie von der Datenblattansicht in die Formularansicht wechseln.

Anmerkung Sie können die Einstellung Dialog des Arguments Fenstermodus der Aktion ÖffnenFormular zum Öffnen eines Formulars verwenden, dessen Eigenschaften PopUp und Modal auf Ja eingestellt sind.

Tipp Wenn Sie in Microsoft Access ein Fenster maximieren, werden alle anderen Fenster ebenfalls maximiert, wenn Sie diese öffnen oder zu diesen wechseln. Popupformulare werden dagegen nicht maximiert. Wenn Sie möchten, dass ein Formular auch dann seine Größe behält, wenn andere Fenster maximiert sind, stellen Sie die Eigenschaft PopUp des Formulars auf Ja ein.


 PreviousControl-Eigenschaft

PreviousControl-Eigenschaft

Sie können die Eigenschaft PreviousControl zusammen mit dem Screen-Objekt verwenden, um eine Referenz an das Steuerelement zurückzugeben, das als letztes den Fokus erhalten hat.

Einstellung

Die Einstellung der Eigenschaft PreviousControl enthält eine Referenz auf das Steuerelement, das zuletzt den Fokus hatte. Sobald Sie eine Referenz auf das Steuerelement hergestellt haben, können Sie auf alle Eigenschaften und Methoden des Steuerelements zugreifen.

Diese Eigenschaft steht nur in einem Makro oder in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Wenn ein Formular geöffnet wurde, können Sie die Eigenschaft PreviousControl erst verwenden, nachdem mindestens zwei Steuerelemente des Formulars den Fokus erhalten haben. Microsoft Access meldet einen Fehler, wenn Sie diese Eigenschaft verwenden, aber erst ein Steuerelement des jeweiligen Formulars den Fokus erhalten hat.


 Primary-Eigenschaft (Primärschlüssel)

Primary-Eigenschaft (Primärschlüssel)

Mit der Eigenschaft Primary können Sie den Primärschlüssel für die Tabelle einstellen. Ein Primärschlüssel kennzeichnet jeden Datensatz in einer Tabelle eindeutig und unterbindet die Eingabe mehrfacher Werte in einem Primärschlüsselfeld.

Einstellung

Die Eigenschaft Primary verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Der ausgewählte Index stellt den Primärschlüssel dar.
Nein | False (0) | Der ausgewählte Index stellt nicht den Primärschlüssel dar.

Sie können die Eigenschaft Primary auf drei Arten einstellen:

  • In der Tabellenentwurfsansicht wählen Sie das Feld oder die Felder in der für den Primärschlüssel gewünschten Reihenfolge aus und klicken dann in der Symbolleiste auf Primärschlüssel [image] .

  • Im Fenster Indizes wählen Sie den Namen eines Indexes in der Spalte Indexname aus bzw. geben ihn dort ein und stellen dann die Eigenschaft Primary auf Ja ein.

  • In Visual Basic greifen Sie auf die Primary-Eigenschaft eines Indexes zu, indem Sie die ADO-Eigenschaft PrimaryKey verwenden.

Anmerkung

Microsoft Access erstellt einen Index für den Primärschlüssel der Tabelle und verwendet diesen zur Suche nach Datensätzen und zur Erstellung von Verknüpfungen zwischen Tabellen. Der Primärschlüsselindex erfordert einen Eintrag in jedem Primärschlüsselfeld und lässt keine Duplikate zu. Die Reihenfolge der Felder legt die Standard-Sortierreihenfolge der Tabelle fest.

Ist kein Primärschlüssel vorhanden, wenn Sie einen Tabellenentwurf speichern, so werden Sie von Microsoft Access in einem Dialogfeld gefragt, ob ein Primärschlüssel erstellt werden soll. Wählen Sie Ja, so wird der Tabelle ein Feld vom Datentyp AutoWert hinzugefügt (für das die Eigenschaft NewValues auf Inkrement eingestellt ist) und als Primärschlüssel festgelegt. Wählen Sie Nein, so wird kein Primärschlüssel erstellt.

Eine Tabelle ohne Primärschlüssel kann nicht in einer Beziehung verwendet werden. Such- bzw. Sortiervorgänge in dieser Tabelle können langsamer sein.


 PrintCount-Eigenschaft

PrintCount-Eigenschaft

Mit der Eigenschaft PrintCount können Sie ermitteln, wie oft die Eigenschaft OnPrint (BeimDrucken) des aktuellen Bereichs eines Berichts ausgewertet wurde.

Einstellung

Sie können diese Eigenschaft nur in dem Makro oder in der Visual Basic-Ereignisprozedur verwenden, auf das bzw. die die Eigenschaft OnFormat (BeimFormatieren) eines Bereichs eingestellt ist.

Der Wert, auf den die Eigenschaft PrintCount eingestellt ist, hat den Datentyp Long.

Diese Eigenschft ist in der Berichtsentwurfsansicht nicht verfügbar und in den anderen Ansichten schreibgeschützt.

Anmerkung

Microsoft Access erhöht die Eigenschaft PrintCount immer dann um 1, wenn die Einstellung der Eigenschaft OnPrint des aktuellen Bereichs ausgewertet wird. Sobald der nächste Bereich gedruckt wird, setzt Microsoft Access die Eigenschaft PrintCount auf 0 zurück.

Die Eigenschaft PrintCount wird z.B. um 1 erhöht, wenn die Eigenschaft KeepTogether (Zusammenhalten) des aktuellen Bereichs auf Nein eingestellt ist und der Bereich auf mehreren Seiten gedruckt wird. Wenn Sie z.B. einen Bericht drucken, der Bestellinformationen enthält, könnten Sie die laufende Summe der Bestellbeträge ermitteln. Im folgenden Beispiel ist gezeigt, wie Sie mit der Eigenschaft PrintCount dafür sorgen können, dass der Wert, der im Steuerelement Bestellbetrag steht, nur jeweils einmal zu der laufenden Summe addiert wird:

Private Sub Detail_Format(Cancel As Integer, FormatCount As Integer)
    If PrintCount = 1 Then
        LaufendeSumme = LaufendeSumme + Bestellbetrag
    End If
End Sub

In diesem Beispiel kann LaufendeSumme eine öffentliche Variable oder der Name eines ungebundenen Steuerelements sein, die bzw. das jedesmal, wenn ein Bereich gedruckt wird, um 1 erhöht wird.


 ProcBodyLine-Eigenschaft

ProcBodyLine-Eigenschaft

Die Eigenschaft ProcBodyLine gibt einen Wert des Datentyps Long zurück, der die Nummer der Zeile eines Standardmoduls oder eines Klassenmoduls angibt, in der die Definition (der Rumpf) einer bestimmten Prozedur beginnt. Die jeweilige Prozedurdefinition wird durch eine der folgenden Anweisungen eingeleitet:

  • Eine Sub-Anweisung.

  • Eine Function-Anweisung.

  • Eine Property Get-Anweisung.

  • Eine Property Let-Anweisung.

  • Eine Property Set-Anweisung.

Einstellung

Objekt.ProcBodyLine(ProzName, ProzTyp)

Die Eigenschaft ProcBodyLine verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Objekt | Ein Module-Objekt.
ProzName | Ein Zeichenfolgenausdruck, der den Namen einer Prozedur des Moduls angibt.
ProzTyp | Eine eingebaute Konstante, die den Typ der Prozedur angibt. Folgende Konstanten können verwendet werden.
 | Konstante | Beschreibung
 | vbext_pk_Get | Eine Property Get-Prozedur.
 | vbext_pk_Let | Eine Property Let-Prozedur.
 | vbext_pk_Proc | Eine Sub-Prozdur oder Funktion.
 | vbext_pk_Set | Eine Property Set-Prozedur.

Die Eigenschaft ProcBodyLine steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkung

Die Eigenschaft ProcBodyLine gibt eine Zahl zurück, die die Zeile angibt, in der die Prozedurdefinition beginnt. Im Gegensatz dazu gibt die Eigenschaft ProcStartLine eine Zahl zurück, die die Zeile angibt, in der die Prozedur von der vorhergehenden Prozedur des Moduls getrennt ist. Alle Kommentare und Kompilierungskonstanten, die vor der Prozedurdefinition (dem Rumpf der Prozedur) stehen, werden zwar als Teil der Prozedur angesehen, werden aber für die Eigenschaft ProcBodyLine ignoriert.

Anmerkung Die Eigenschaft ProcBodyLine macht keinen Unterschied zwischen Sub-Prozeduren und Funktionen, unterscheidet aber zwischen den Typen für Property-Prozeduren.


 ProcCountLines-Eigenschaft

ProcCountLines-Eigenschaft

Die ProcCountLines-Eigenschaft gibt einen Long-Wert zurück, der die Anzahl der Zeilen in einer festgelegten Prozedur in einem Standardmodul oder einem Klassenmodul enthält. Die Prozedur beginnt mit beliebigen Kommentaren und Kompilierungskonstanten, auf die unmittelbar die Definition der Prozedur folgt. Die Definition wird durch eine der folgenden Anweisungen gekennzeichnet:

  • Eine Sub-Anweisung.

  • Eine Function-Anweisung.

  • Eine Property Get-Anweisung.

  • Eine Property Let-Anweisung.

  • Eine Property Set-Anweisung.

Einstellung

Objekt.ProcCountLines(ProzName, ProzTyp)

Die ProcCountLines-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Object | Ein Module-Objekt.
Procname | Ein Zeichenfolgeausdruck, der den Namen einer Prozedur des Moduls angibt.
Prockind | Eine eingebaute Konstante, die den Typ der Prozedur angibt. Die Konstanten können folgenden Wert haben.
 | Konstante | Beschreibung
 | vbext_pk_Get | Eine Property Get-Prozedur.
 | vbext_pk_Let | Eine Property Let-Prozedur.
 | vbext_pk_Proc | Eine Sub-Prozedur oder Funktion.
 | vbext_pk_Set | Eine Property Set-Prozedur.

Die ProcCountLines-Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Die ProcCountLines-Eigenschaft gibt die Anzahl der Zeilen in einer Prozedur zurück. Die erste Zeile ist die Zeile, die von der ProcStartLine-Eigenschaft zurückgegeben wird. Die letzte Zeile ist die letzte Zeile der Prozedur. Die Prozedur kann mit End Sub, End Function oder End Property enden.

Anmerkung Die ProcCountLines-Eigenschaft behandelt Sub-Prozeduren und Funktionen ähnlich, unterscheidet aber zwischen den verschiedenen Property-Prozeduren.


 ProcOfLine-Eigenschaft

ProcOfLine-Eigenschaft

Die ProcOfLine-Eigenschaft gibt eine Zeichenfolge mit dem Namen der Prozedur zurück, die eine angegebene Zeile in einem Standardmodul oder einem Klassenmodul enthält. Das Hauptteil der Prozedur beginnt mit der Definition, die durch eine der folgenden Anweisungen gekennzeichnet ist:

  • Eine Sub-Anweisung.

  • Eine Function-Anweisung.

  • Eine Property Get-Anweisung.

  • Eine Property Let-Anweisung.

  • Eine Property Set-Anweisung.

Einstellung

Objekt.ProcOfLine(Zeile, PProzTyp)

Die ProcOfLine-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Object | Ein Module-Objekt.
Line | Ein Long-Wert, der die Nummer einer Zeile im Modul angibt.
Pprockind | Ein Long-Wert, der den Typ der Prozedur angibt, die die durch das Argument Zeile angegebene Zeile enthält. Wenn Sie den Wert der ProcOfLine-Eigenschaft zurückgeben, wird der Wert des Arguments Pprocline auf eine eingebaute Konstante gesetzt, die den Typ der Prozedur angibt, dem die Zeile angehört. Die Konstanten können folgende Werte haben.
 | Konstante | Wert | Beschreibung
 | vbext_pk_Get | 3 | Eine Property Get-Prozedur.
 | vbext_pk_Let | 1 | Eine Property Let-Prozedur.
 | vbext_pk_Proc | 0 | Eine Sub-Prozedur oder Funktion.
 | vbext_pk_Set | 2 | Eine Property Set-Prozedur.

Die ProcOfLine-Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Die ProcOfLine-Eigenschaft gibt für eine gegebene Zeilennummer den Namen der Prozedur zurück, die diese Zeile enthält. Da Kommentare und Kompilierungskonstanten, die der Definition einer Prozedur unmittelbar vorausgehen, als Bestandteil der Prozedur betrachtet werden, gibt die ProcOfLine-Eigenschaft unter Umständen den Namen einer Prozedur für eine Zeile zurück, die sich nicht im Text der Prozedur befindet. Die ProcStartLine-Eigenschaft gibt die Zeile an, mit der eine Prozedur beginnt; die ProcBodyLine-Eigenschaft gibt die Zeile an, mit der die Definition der Prozedur (der Text der Prozedur) beginnt.

Beachten Sie, dass das Argument Pprockind angibt, ob die Zeile zu einer Sub- Prozedur oder Funktion, einer Property Get-Prozedur, einer Property Let-Prozedur oder einer Property Set-Prozedur gehört. Um zu ermitteln, in welchem Prozedurtyp sich eine Zeile befindet, geben Sie eine Variable des Typs Long an die ProcOfLine-Eigenschaft weiter, und prüfen Sie anschließend den Wert dieser Variable.

Anmerkung Die ProcBodyLine-Eigenschaft behandelt Sub-Prozeduren und Funktionen ähnlich, unterscheidet aber zwischen den verschiedenen Property-Prozeduren.


 ProcStartLine-Eigenschaft

ProcStartLine-Eigenschaft

Die ProcStartLine-Eigenschaft gibt einen Wert Long zurück, der die Zeile angibt, in der eine angegebene Prozedur in einem Standardmodul oder einem Klassenmodul beginnt. Die Prozedur beginnt mit beliebigen Kommentaren und Kompilierungskonstanten, denen die Definition der Prozedur unmittelbar vorausgeht. Die Prozedur ist durch eine der folgenden Anweisungen gekennzeichnet:

  • Eine Sub-Anweisung.

  • Eine Function-Anweisung.

  • Eine Property Get-Anweisung.

  • Eine Property Let-Anweisung.

  • Eine Property Set-Anweisung.

Einstellung

Objekt.ProcStartLine(ProzName, ProzTyp)

Die ProcStartLine-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Object | Ein Module-Objekt.
Procname | Ein Zeichenfolgeausdruck, der den Namen einer Prozedur des Moduls angibt.
Prockind | Eine eingebaute Konstante, die den Typ der Prozedur angibt. Folgende Konstanten können verwendet werden.
 | Konstante | Beschreibung
 | vbext_pk_Get | Eine Property Get-Prozedur.
 | vbext_pk_Let | Eine Property Let-Prozedur.
 | vbext_pk_Proc | Eine Sub-Prozedur oder Funktion.
 | vbext_pk_Set | Eine Property Set-Prozedur.

Die ProcStartLine-Eigenschaft ist nur bei Verwendung von Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Die ProcStartLine-Eigenschaft gibt die Nummer der Zeile zurück, in der die angegebene Prozedur beginnt. Unter Umständen enthält der Beginn der Prozedur Kommentare oder Kompilierungskonstanten, die der Definition vorausgehen.

Um die Zeile zu ermitteln, in der die Definition der Prozedur beginnt, verwenden Sie die ProcBodyLine-Eigenschaft. Diese Eigenschaft gibt die Nummer der Zeile zurück, die mit einer Sub-, Function-, Property Get-, Property Let- oder Property Set-Anweisung beginnt.

Die ProcStartLine- und ProcBodyLine-Eigenschaften können denselben Wert haben, wenn die Definition der Prozedur zugleich die erste Zeile der Prozedur ist. Wenn dies nicht der Fall ist, gibt die ProcBodyLine-Eigenschaft einen höheren Wert zurück als die ProcStartLine-Eigenschaft.

Anmerkungen

  • Sie können den Beginn einer Prozedur müheloser ermitteln, wenn Sie das Kontrollkästchen Prozedurtrennlinie aktiviert haben. Diese Option fügt zwischen dem Ende einer Prozedur und dem Beginn der nächsten Prozedur eine Zeile ein. Die erste Zeile mit Code (oder die erste leere Zeile) unterhalb des Prozedurtrennzeichens ist die erste Zeile der folgenden Prozedur. Diese Zeile wird von der ProcStartLine-Eigenschaft zurückgegeben. Das Kontrollkästchen Prozedurtrennlinie befindet sich auf der Registerkarte Editor im Dialogfeld Optionen. Um das Dialogfeld zu öffnen, klicken Sie im Menü Extras auf Optionen. Aktivieren Sie zunächst das Kontrollkästchen Standardmäßig ganzes Modul anzeigen, bevor Sie das Kontrollkästchen Prozedurtrennlinie aktivieren.

  • Die ProcStartLine-Eigenschaft behandelt Sub-Prozeduren und Funktionen ähnlich, unterscheidet aber zwischen den verschiedenen Property-Prozeduren.


 ProductCode-Eigenschaft

ProductCode-Eigenschaft

Mit Hilfe der ProductCode-Eigenschaft können Sie die globale eindeutige Kennung (Globally Unique Identifier, GUID) von Microsoft Access ermitteln.

Einstellung

Die ProductCode-Eigenschaft ist ein Zeichenfolgenausdruck, der die GUID des Microsoft Access-Produkts angibt.

Diese Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 ProjectName-Eigenschaft

ProjectName-Eigenschaft

Mit der ProjectName-Eigenschaft können Sie den Namen Ihres Microsoft Access Application-Objekts angeben oder ermitteln.

Einstellung

Die Einstellung der ProjectName-Eigenschaft ist ein Zeichenfolgeausdruck, der den Namen Ihres Microsoft Access Application-Objekts angibt. Sie können die ProjectName-Eigenschaft nicht auf den Namen einer existierenden Klasse von Objekten einstellen, wie z. B. "Anwendung," "Formular," oder "Bericht". Wenn Sie eine Datenbank umwandeln, die den Namen einer existierenden Klasse von Objekten trägt, wird von Microsoft Access ein Unterstrich an den Namen angehängt, um Namenskonflikte zu vermeiden. Wenn Sie z. B. eine Datenbank namens "Anwendung" umwandeln, wird die Datenbank in Microsoft Access 2000 den Projektnamen "Anwendung_" erhalten.

Sie können die ProjectName-Eigenschaft sowohl im Dialogfeld Optionen (wird angezeigt, nachdem Sie im Menü Extras auf Optionen geklickt haben) auf der Registerkarte Weitere als auch in Visual Basic mit der Methode SetOption einstellen, z.B.:

Application.SetOption "Project Name", "DasAccessProjekt"

Anmerkung

Wenn Sie eine neue Datenbank erstellen, stellt Microsoft Access die Eigenschaft ProjectName auf den Dateinamen der Datenbank ein (ohne die Erweiterung .MDB). Wenn Sie den Dateinamen der Datenbank ändern, bleibt die Einstellung der Eigenschaft ProjectName ungeändert.

Wenn Sie die Eigenschaft ProjectName einstellen, wird der Name Ihres Application-Objekts im Dialogfeld Verweise angezeigt. Dieses Dialogfeld wird angezeigt, wenn Sie im Modulfenster im Menü Extras auf Verweise klicken.

Wenn Sie die Einstellung der Eigenschaft ProjectName ändern, liegt Ihr Projekt nicht länger im kompilierten Zustand vor. Um das Projekt zu rekompilieren, müssen Sie Ihre Datenbank schließen und erneut öffnen und dann im Menü Debuggen auf den Befehl Alle Module kompilieren und speichern klicken.

In einer anderen Anwendung, wie z.B. Microsoft Excel, können Sie den Projektnamen als Teil des vollständig formulierten Namens eines Elements angeben, das zu einem Microsoft Access-Projekt gehört. Die entsprechende Syntax lautet wie folgt: Projektname.Application.Forms!Formularname. Wenn Sie z.B. aus Microsoft Excel auf das Feld Nachname des zur Beispieldatenbank Nordwind gehörenden Formulars Personal verweisen möchten, aktivieren Sie den Verweis auf die Datenbank Nordwind und verwenden dann folgenden Verweis:

Dim strNachname As String
strNachname = Nordwind.Application.Formulare!Personal!Nachname

Sie können einen Verweis auf eine Microsoft Access-Datenbank erstellen, indem Sie im Dialogfeld Verweise (wird angezeigt, nachdem Sie im Modulfenster im Menü Extras auf Verweise geklickt haben) den Projektnamen (das Application-Objekt) aktivieren. Nachdem Sie den Projektnamen aktiviert haben, wird dieser auch im Objektkatalog in der Liste Projekt/Bibliothek angezeigt.


 ProjectType-Eigenschaft

ProjectType-Eigenschaft

Mit Hilfe der ProjectType-Eigenschaft können Sie den Typ des aktuell geöffneten Projekts durch die CurrentProject- bzw. CodeProject-Objekte bestimmen.

Einstellung

Die ProjectType-Eigenschaft gibt eine der folgenden eingebauten Konstanten zurück.

acADP (1) | acNull (0)
acMDB (2) |

Die ProjectType-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 Properties-Eigenschaft

Properties-Eigenschaft

Mit der Eigenschaft Properties können Sie einen Verweis auf das Properties-Auflistungsobjekt eines Steuerelements zurückgeben.

Anmerkung In Microsoft Access 2000 wurde die Properties-Eigenschaft durch die Properties (Properties-Auflistung)-Eigenschaft und die Properties (AccessObjectProperties-Auflistung)-Eigenschaft ersetzt. Die Properties-Eigenschaft ist in dieser Version von Microsoft Access lediglich aus Gründen der Abwärtskompatibilität enthalten.

Einstellung

Steuerelementname.Properties[.Methode oder Eigenschaft]

Die Eigenschaft Properties verwendet die folgenden Einstellungen:

Einstellung | Beschreibung
Steuerelementname | Erforderlich. Der Name des Steuerelements, auf dessen Properties-Auflistungsobjekt Sie verweisen möchten.
Properties | Erforderlich. Wird die Eigenschaft Properties ohne Angabe einer Methode oder Eigenschaft verwendet, gibt sie das Properties-Auflistungsobjekt zurück.
Methode oder Eigenschaft | Eine Methode oder Eigenschaft des Properties-Auflistungsobjekts. Die Eigenschaft Item (Auflistungen) ist die Standardeigenschaft für das Properties-Auflistungsobjekt.

Die Properties-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Das Properties-Auflistungsobjekt ist die Auflistung aller Eigenschaften eines Steuerelements. Sie können auf einzelne Elemente der Auflistung verweisen, indem Sie den Index des Elementobjekts oder einen Zeichenfolgeausdruck verwenden, der den Namen des Elementobjekts darstellt. Das erste Elementobjekt in der Auflistung besitzt den Indexwert 0, und die Gesamtanzahl der Elementobjekte in der Auflistung entspricht dem Wert der Count-Eigenschaft der Properties-Auflistung minus 1.


Properties-Eigenschaft (AccessObjectProperties-Auflistung)

Die Properties-Eigenschaft können Sie verwenden, um einen Verweis auf die AccessObjectProperties-Auflistung eines AccessObject-, CurrentProject- oder CodeProject-Objekts zurückzugeben.

Einstellung

Die AccessObjectProperties-Eigenschaft steht nur in Visual Basic zur Verfügung.

Anmerkungen

Das AccessObjectProperties-Auflistungsobjekt ist die Auflistung aller Eigenschaften eines AccessObject-, CurrentProject- oder CodeProject-Objekts. Sie können auf einzelne Elemente der Auflistung verweisen, indem Sie den Index des Elementobjekts oder einen Zeichenfolgenausdruck verwenden, der den Namen des Elementobjekts darstellt. Das erste Elementobjekt in der Auflistung besitzt den Indexwert 0, und die Gesamtanzahl der Elementobjekte in der Auflistung entspricht dem Wert der Count-Eigenschaft der AccessObjectProperties-Auflistung minus 1.


 Properties-Eigenschaft (Properties-Auflistung)

Properties-Eigenschaft (Properties-Auflistung)

Mit der Properties-Eigenschaft können Sie einen Verweis auf die Properties-Auflistung eines Formulars, eines Berichts oder eines Steuerelements zurückgeben .

Einstellung

Die Properties-Eigenschaft ist nur bei Verwendung von Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Das Properties-Auflistungsobjekt ist die Auflistung aller Eigenschaften eines Formulars, Berichts oder Steuerelements. Sie können auf einzelne Elemente der Auflistung verweisen, indem Sie den Index des Elementobjekts oder einen Zeichenfolgenausdruck verwenden, der den Namen des Elementobjekts darstellt. Das erste Elementobjekt in der Auflistung besitzt den Indexwert 0, und der Wert des letzten Elementobjekts in der Auflistung entspricht dem Wert der Count-Eigenschaft der Properties-Auflistung minus 1.


 PrtDevMode-Eigenschaft

PrtDevMode-Eigenschaft

Mit der Eigenschaft PrtDevMode können Sie Informationen zum Modus des Druckgeräts festlegen oder zurückgeben, die für ein Formular oder einen Bericht im Dialogfeld Drucken angegeben sind.

Anmerkung Es wird dringend geraten, dass Sie im Win32 Software Development Kit nachschlagen, um sich die vollständige Dokumentation der Eigenschaften PrtDevMode, PrtDevNames und PrtMip anzusehen.

Einstellung

Die Einstellung der Eigenschaft PrtDevMode ist eine 94 Bytes lange Struktur, die die Struktur DEVMODE spiegelt, die im Win32 Software Development Kit definiert ist. Ausführliche Informationen zu den Elementen der Eigenschaft PrtDevMode finden Sie im Win32 Software Development Kit.

Die Eigenschaft PrtDevMode besteht aus den folgenden Elementen.

Element | Beschreibung
DeviceName | Eine Zeichenfolge, die bis zu 32 Bytes lang ist und den Namen des Gerätes angibt, das der Treiber unterstützt (z.B. "HP LaserJet IIISi", wenn der Hewlett-Packard LaserJet IIISi der angegebene Drucker ist). Jeder Druckertreiber hat eine eindeutige Zeichenfolge.
SpecVersion | Ein Integer-Wert, der die Versionsnummer angibt, die die Struktur DEVMODE im Win32 Software Development Kit hat.
DriverVersion | Ein Integer-Wert, der die Versionsnummer des Druckertreibers angibt, die vom Entwickler des Druckertreibers zugewiesen wurde.
Size | Ein Integer-Wert, der in Bytes die Größe der Struktur DEVMODE angibt. (Dieser Wert enthält nicht das optionale Element dmDriverData für gerätespezifische Daten, das auf diese Struktur folgen kann.) Wenn eine Anwendung nur den treiberunabhängigen Teil der Daten verarbeitet, können Sie mit Hilfe dieses Elements die Länge dieser Struktur ermitteln, ohne unterschiedliche Versionen berücksichtigen zu müssen.
DriverExtra | Ein Integer-Wert, der in Bytes die Größe des optionalen Elements dmDriverData für gerätespezifische Daten angibt, das auf diese Struktur folgen kann. Verwendet eine Anwendung keine gerätespezifischen Informationen, stellen Sie dieses Element auf 0 ein.
Fields | Ein Long-Wert, der angibt, welche der restlichen Elemente der Struktur DEVMODE initialisiert wurden. Dieser Wert kann eine beliebige Kombination bestimmter Konstanten oder ein unbestimmter Wert sein. Welche Konstanten verfügbar sind, finden Sie unter Konstanten für das Element Fields.
Orientation | Ein Integer-Wert, der die Ausrichtung des Papiers angibt, entweder 1 (Hochformat) oder 2 (Querformat).
PaperSize | Ein Integer-Wert, der die Größe des Papiers angibt, auf dem gedruckt wird. Wenn Sie dieses Element auf 0 oder 256 einstellen, werden die Länge und Breite des Papiers von den Elementen PaperLength bzw. PaperWidth angegeben. Andernfalls können Sie das Element PaperSize auf einen vordefinierten Wert einstellen. Die verfügbaren Werte finden Sie unter Werte für das Element PaperSize.
PaperLength | Ein Integer-Wert, der die Papierlänge in Einheiten von 1/10 Millimetern angibt. Dieses Element setzt die Papierlänge außer Kraft, die vom Element PaperSize für benutzerdefinierte Papiergrößen oder für Geräte, wie z.B. Nadeldrucker, angegeben ist, die auf Papier unterschiedlicher Größe drucken können.
PaperWidth | Ein Integer-Wert, der die Papierbreite in Einheiten von 1/10 Millimetern angibt. Dieses Element setzt die Papierbreite außer Kraft, die vom Element PaperSize angegeben wird.
Scale | Ein Integer-Wert, der den Faktor angibt, um den die gedruckte Ausgabe maßstäblich verkleinert oder vergrößert wird. Die scheinbare Seitengröße ergibt sich aus der physikalischen Seitengröße multipliziert mit dem Faktor Scale/100. Z.B. würde ein Stück Papier, das 210 x 297 mm (DIN A4) misst, bei einem Scale-Wert von 50 so viele Daten enthalten wie eine Seite, die 420 x 594 mm misst, da die Ausgabetexte und -grafiken mit der halben Originalhöhe und -breite gedruckt werden.
Copies | Ein Integer-Wert, der die Anzahl der zu druckenden Kopien angibt, sofern der Drucker wiederholte Kopien unterstützt.
DefaultSource | Ein Integer-Wert, der den Standardschacht angibt, aus dem das Papier zugeführt wird. Die verfügbaren Werte finden Sie unter Werte für das Element DefaultSource.
PrintQuality | Ein Integer-Wert, der die Druckerauflösung angibt. Die möglichen Werte sind -4 (hoch), -3 (mittel), -2 (niedrig) und -1 (Entwurf).
Color | Ein Integer-Wert, der für einen Farbdrucker angibt, ob die Ausgabe in Farbe gedruckt wird. Die möglichen Werte sind 1 (Farbe) und 2 (monochrom).
Duplex | Ein Integer-Wert, der für einen Drucker, der doppelseitig drucken kann, angibt, ob die Ausgabe auf beiden Papierseiten gedruckt wird. Die möglichen Werte sind 1 (einfach), 2 (horizontal) und 3 (vertikal).
YResolution | Ein Integer-Wert, der die y-Auflösung des Druckers in Punkten pro Zoll (Dots Per Inch = DPI) angibt. Wenn der Drucker dieses Element initialisiert, legt das Element PrintQuality die x-Auflösung des Druckers in DPI fest.
TTOption | Ein Integer-Wert, der angibt, wie TrueType-Schriftarten gedruckt werden. Die verfügbaren Werte finden Sie unter Werte für das Element TTOption.
Collate | Ein Integer-Wert, der angibt, ob mit Sortierung gearbeitet werden soll, wenn mehrere Kopien gedruckt werden. Unsortierte Kopien können schneller und effizienter gedruckt werden, da die Daten nur einmal zum Drucker gesendet werden.
FormName | Eine Zeichenfolge aus maximal 16 Zeichen, die die Größe des zu verwendenden Papiers angibt, z.B. "US-Letter" oder "A4".
Pad | Ein Long-Wert, der verwendet wird, um Lücken, Zeichen oder Werte für zukünftige Versionen aufzufüllen.
Bits | Ein Long-Wert, der die Farbauflösung des Anzeigegeräts in Bits pro Pixel angibt.
PW | Ein Long-Wert, der die Breite der sichtbaren Geräteoberfläche (Bildschirm oder Drucker) in Pixeln angibt.
PH | Ein Long-Wert, der die Höhe der sichtbaren Geräteoberfläche (Bildschirm oder Drucker) in Pixeln angibt.
DFI | Ein Long-Wert, der den Anzeigemodus des Geräts angibt.
DFR | Ein Long-Wert, der für einen bestimmten Modus die Frequenz des Anzeigegeräts in Hertz (Bildwiederholungen pro Sekunde) angibt.

Sie können die PrtDevMode-Eigenschaft in Visual Basic einstellen.

Die Einstellung dieser Eigenschaft kann in der Entwurfsansicht gelesen und geschrieben werden. In den anderen Ansichten ist sie schreibgeschützt.

Vorsicht Es gibt Druckertreiber, die unmittelbar hinter der Struktur DEVMODE gerätespezifische Daten einfügen. Daher muss sichergestellt sein, dass die oben beschriebenen DEVMODE-Daten nicht mehr als 94 Bytes umfassen.

Anmerkung

Die Struktur DEVMODE wird nur von Druckern verwendet, die die Funktion ExtDeviceMode exportieren.

Aus einer Anwendung können die von einem Drucker unterstützten Papiergrößen und -bezeichnungen abgerufen werden, indem die Funktion DeviceCapabilities mit den Werten DC_PAPERS, DC_PAPERSIZE und DC_PAPERNAMES aufgerufen wird.

Bevor aus einer Anwendung das Element TTOption eingestellt wird, sollte die Anwendung die Funktion DeviceCapabilities mit dem Wert DC_TRUETYPE aufrufen, um zu ermitteln, wie der jeweilige Druckertreiber TrueType-Schriftarten verwenden kann.


PrtDevNames-Eigenschaft

Mit der Eigenschaft PrtDevNames können Sie Informationen zu dem Drucker einstellen oder zurückgeben, der im Dialogfeld Drucken für ein Formular oder einen Bericht ausgewählt ist.

Anmerkung Es ist dringend angeraten, dass Sie im Win32 Software Development Kit nachschlagen, um sich die vollständige Dokumentation der Eigenschaften PrtDevMode, PrtDevNames und PrtMip anzusehen.

Einstellung

Die Eigenschaft PrtDevNames ist eine Struktur variabler Länge, die die Struktur DEVNAMES spiegelt, die im Win32 Software Development definiert ist.

Die Eigenschaft PrtDevNames besteht aus den folgenden Elementen.

Element | Beschreibung
DriverOffset | Gibt den Versatz (Offset) an, der zwischen dem Beginn der Struktur und einer Zeichenfolge liegt, die durch den Wert Null begrenzt ist und den Dateinamen (ohne Erweiterung) des Gerätetreibers angibt. Mit dieser Zeichenfolge wird angegeben, welcher Drucker zunächst im Dialogfeld Drucken angezeigt wird.
DeviceOffset | Gibt den Versatz an, der zwischen dem Beginn der Struktur und einer Zeichenfolge liegt, die durch den Wert Null begrenzt ist und den Namen des Gerätes angibt. Diese Zeichenfolge kann maximal 32 Bytes lang sein (das Null-Zeichen eingeschlossen) und muss mit dem Element DeviceName der Struktur DEVMODE übereinstimmen.
OutputOffset | Gibt den Versatz an, der zwischen dem Beginn der Struktur und einer Zeichenfolge liegt, die durch den Wert Null begrenzt ist und für das physikalische Ausgabemedium (Ausgabekanal) den MS-DOS-Namen des Geräts angibt, z.B. "LPT1:".
Default | Gibt an, ob die in der Struktur DEVNAMES angegebenen Zeichenfolgen den Standarddrucker kennzeichnen. Ist Default auf 1 eingestellt und stimmen alle Werte der Struktur DEVNAMES mit denen des aktuellen Standarddruckers überein, wird der ausgewählte Drucker, bevor das Dialogfeld Drucken angezeigt wird, auf den Standarddrucker eingestellt. Default wird auf 1 eingestellt, wenn der aktuelle Standarddrucker ausgewählt wurde.

Wenn Sie im Dialogfeld Drucken im Bereich Drucker eine Option auswählen, stellt Microsoft Access die PrtDevNames-Eigenschaft ein. Sie können diese Eigenschaft auch in Visual Basic einstellen.

Anmerkung

Microsoft Access verwendet die Struktur DEVNAMES dazu, das Dialogfeld Drucken zu initialisieren. Wenn der Benutzer auf OK klickt, um das Dialogfeld zu schließen, werden die Informationen über den ausgewählten Drucker in der Eigenschaft PrtDevNames zurückgegeben.


 PrtMip-Eigenschaft

PrtMip-Eigenschaft

Sie können die Eigenschaft PrtMip in Visual Basic verwenden, um die Informationen zum Gerätemodus einzustellen oder zurückzugeben, die für ein Formular oder für einen Bericht im Dialogfeld Drucken angegeben sind.

Einstellung

Die Einstellung der Eigenschaft PrtMip ist eine 28 Bytes lange Struktur, die Einstellungen enthält, die im Dialogfeld Seitenformat auf der Registerkarte Ränder für ein Formular oder für einen Bericht gelten.

Die Eigenschaft PrtMip hat die folgenden Elemente.

Element | Beschreibung
LeftMargin, RightMargin, TopMargin, BottomMargin | Ein Long-Wert, der in Twips den Abstand angibt, der zwischen dem Seitenrand und dem zu druckenden Element liegt.
DataOnly | Ein Long-Wert, der die Elemente angibt, die gedruckt werden sollen. Ist dieser Wert gleich True (-1), werden nur die Daten gedruckt, die zu einer Tabelle oder Abfrage in der Datenblattansicht oder zu einem Formular oder Bericht gehören. Bezeichnungen, die Rahmen der Steuerelemente, Gitternetzlinien und Grafikelemente, wie z.B. Linien und Kästchen, werden unterdrückt. Ist dieser Wert gleich False (0), werden Daten, Bezeichnungen und Grafikelemente gedruckt.
ItemsAcross | Ein Long-Wert, der für mehrspaltige Berichte oder Etiketten die Anzahl der Spalten pro Seite angibt. Dieses Element ist identisch mit dem Wert des Feldes Spaltenanzahl (im Dialogfeld Seitenformat auf der Registerkarte Spalten unter Rastereinstellungen).
RowSpacing | Ein Long-Wert, der in Einheiten von 1/20 Punkt den horizontalen Abstand angibt, der zwischen zwei Detailbereichen liegt.
ColumnSpacing | Ein Long-Wert, der in Twips den vertikalen Abstand angibt, der zwischen zwei Detailbereichen liegt.
DefaultSize | Ein Long-Wert. Ist dieser Wert gleich True, wird die Größe verwendet, die der Detailbereich in der Entwurfsansicht hat. Ist dieser Wert gleich False, werden die Werte verwendet, die von den Elementen ItemSizeWidth und ItemSizeHeight angegeben werden.
ItemSizeWidth | Ein Long-Wert, der in Twips die Breite des Detailbereichs angibt. Dieses Element ist identisch mit dem Wert des Feldes Breite (im Dialogfeld Seitenformat auf der Registerkarte Spalten unter Spaltengröße).
ItemSizeHeight | Ein Long-Wert, der in Twips die Höhe des Detailbereichs angibt. Dieses Element ist identisch mit dem Wert des Feldes Höhe (im Dialogfeld Seitenformat auf der Registerkarte Spalten unter Spaltengröße).
ItemLayout | Ein Long-Wert, der für Spalten ein horizontales (1953) oder vertikales (1954) Layout angibt. Dieses Element ist identisch mit dem Wert von Quer, dann nach unten bzw. Nach unten, dann quer (im Dialogfeld Seitenformat auf der Registerkarte Spalten unter Spaltenlayout).
FastPrint | Reserviert.
Datasheet | Reserviert.

Die Einstellung der Eigenschaft PrtMip kann in der Entwurfsansicht gelesen und geschrieben werden. In den anderen Ansichten ist sie schreibgeschützt.


ReadingOrder-Eigenschaft

Sprachspezifische Informationen

You can use the ReadingOrder property to specify or determine the reading order of words in text.

Setting

The ReadingOrder property uses the following settings.

Setting | Visual Basic | Description
Context | 0 | Reading order is determined by the language of the first character entered. If a right-to-left language character is entered first, reading order is right to left. If a left-to-right language character is entered first, reading order is left to right.
Left-to-Right | 1 | Sets the reading order to left to right.
Right-to-Left | 2 | Sets the reading order to right to left.

You can set this property by using the property sheet or Visual Basic.

Remarks

In a combo box or list box, the ReadingOrder property determines reading order behavior for both the text box and list box components of the control.

For more information about right-to-left properties, see Learn more about right-to-left properties in Microsoft Access 2000.


 ReadyState-Eigenschaft

ReadyState-Eigenschaft

Mit der ReadyState-Eigenschaft können Sie den Status der Datei ermitteln, die in ein Snapshot-Steuerelement geladen wird.

Einstellung

Die ReadyState-Eigenschaft ist ein Integer-Wert, der den Ladestatus einer Snapshot-Datei angibt.

Einstellung | Beschreibung
0 | Das Snapshot-Steuerelement wurde nicht initialisiert.
1 | Das Snapshot-Steuerelement wird geladen.
2 | Das Snapshot-Steuerelement wurde geladen, doch die Snapshot-Datei wird gegenwärtig übertragen.
4 | Das Snapshot-Steuerelement hat die Übertragung der Snapshot-Datei beendet.

Die ReadyState-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Wenn die SnapshotPath-Eigenschaft unter Verwendung des Eigenschaftenfensters des Steuerelements eingerichtet wurde, gibt die ReadyState-Eigenschaft in jedem Fall mindestens den Wert 2 zurück, auch wenn die SnapshotPath-Eigenschaft später durch das Programm auf eine Zeichenfolge der Länge Null gesetzt wird.

Die Verwendung dieser Eigenschaft bietet sich an, wenn die SnapshotPath-Eigenschaft eine HTTP- oder FTP-Adresse für eine Snapshot-Datei enthält. In diesem Fall wird die Datei asynchron übertragen, und Sie können mit der ReadyState-Eigenschaft ermitteln, wann die Übertragung abgeschlossen ist und der Snapshot angezeigt wird.


 RecordLocks-Eigenschaft (DatensätzeSperren)

RecordLocks-Eigenschaft (DatensätzeSperren)

Mit der Eigenschaft RecordLocks können Sie angeben, wie Datensätze gesperrt werden und was passiert, wenn zwei Benutzer versuchen, gleichzeitig denselben Datensatz zu bearbeiten. Wenn Sie einen Datensatz bearbeiten, kann Microsoft Access diesen Datensatz automatisch sperren, um Veränderungen durch andere Benutzer zu verhindern, bevor Sie die Bearbeitung abgeschlossen haben.

  • Formulare. Gibt an, wie Datensätze in der zugrunde liegenden Tabelle oder Abfrage gesperrt werden, wenn Daten in einer Mehrbenutzerdatenbank aktualisiert werden.

  • Berichte. Gibt an, ob Datensätze in der zugrunde liegenden Tabelle oder Abfrage gesperrt werden, während ein Bericht angezeigt oder gedruckt wird.

  • Abfragen. Gibt an, wie Datensätze in einer Abfrage (in der Regel eine Aktionsabfrage in einer Mehrbenutzerdatenbank) gesperrt werden, während die Abfrage ausgeführt wird.

Anmerkung Die RecordLocks-Eigenschaft gilt nur für Formulare, Berichte oder Abfragen in einer Microsoft Access-Datenbank (.mdb).

Einstellung

Die Eigenschaft RecordLocks verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Keine Sperrungen | 0 | (Voreinstellung) In Formularen können mehrere Benutzer denselben Datensatz gleichzeitig bearbeiten. Dies wird auch als "eingeschränktes" Sperren bezeichnet. Versuchen zwei Benutzer gleichzeitig, Änderungen am selben Datensatz zu speichern, so zeigt Microsoft Access dem Benutzer, der den Datensatz als zweiter speichern wollte, eine Meldung an. Dieser Benutzer kann dann die Änderungen am Datensatz verwerfen, den Datensatz in die Zwischenablage kopieren oder die Änderungen des anderen Benutzers ersetzen. Diese Einstellung wird in der Regel in schreibgeschützten Formularen oder in Einzelbenutzerdatenbanken verwendet. Sie wird auch in Mehrbenutzerdatenbanken verwendet, um mehreren Benutzern die gleichzeitige Änderung desselben Datensatzes zu ermöglichen. In Berichten werden Datensätze nicht gesperrt, während der Bericht angezeigt oder gedruckt wird. In Abfragen werden Datensätze nicht gesperrt, während die Abfrage ausgeführt wird.
Alle Datensätze | 1 | Alle Datensätze in der zugrunde liegenden Tabelle oder Abfrage werden gesperrt, während das Formular in der Formularansicht oder Datenblattansicht geöffnet ist, der Bericht angezeigt oder gedruckt oder die Abfrage ausgeführt wird. Die Benutzer können Datensätze zwar lesen, aber erst dann bearbeiten, hinzufügen oder löschen, wenn das Formular geschlossen, der Bericht gedruckt oder die Abfrage ausgeführt ist.
Bearbeitete Datensätze | 2 | (Nur Formulare und Abfragen) Eine Seite von Datensätzen wird gesperrt, sobald ein Benutzer die Bearbeitung eines Feldes im Datensatz beginnt, und bleibt gesperrt, bis der Benutzer zu einem anderen Datensatz wechselt. Demzufolge kann ein Datensatz nur jeweils von einem Benutzer bearbeitet werden. Dies wird auch als "vollständiges" Sperren bezeichnet.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung Wenn die RecordLocks-Eigenschaft eines geöffneten Formulars oder Berichts geändert wird, führt dies zu einer automatischen Neuerstellung der Datensatzgruppe.

Anmerkung

Sie können auch die Einstellung Keine Sperrungen für Formulare verwenden, wenn nur eine Person die zugrunde liegenden Tabellen oder Abfragen verwendet oder sämtliche Änderungen an den Daten vornimmt.

In einer Mehrbenutzerdatenbank können Sie die Einstellung Keine Sperrungen verwenden, wenn Sie eingeschränktes Sperren verwenden und Benutzer beim Zugriff auf den gleichen Datensatz in einem Formular warnen möchten. Sie können die Einstellung Bearbeiteter Datensatz verwenden, wenn Sie verhindern möchten, dass mehrere Benutzer Daten gleichzeitig bearbeiten können.

Sie können die Einstellung Alle Datensätze verwenden, wenn Sie sicherstellen müssen, dass keine Änderungen an den Daten vorgenommen werden, nachdem Sie angefangen haben, einen Bericht anzuzeigen oder zu drucken bzw. eine Anfüge-, Lösch-, Tabellenerstellungs- oder Aktualisierungs-Abfrage auszuführen.

In der Formularansicht oder Datenblattansicht wird für jeden gesperrten Datensatz ein [image] im Datensatzmarkierer angezeigt.

Tipp Sie können die Voreinstellung der Eigenschaft RecordLocks für Formulare ändern, indem Sie zuerst im Menü Extras auf Optionen klicken, dann im Dialogfeld Optionen auf die Registerkarte Weitere klicken und anschließend im Gruppenfeld Standard bei Datensatzsperrung die gewünschte Option auswählen.

Daten in einem Formular, einem Bericht oder einer Abfrage aus einer ODBC-Datenbank (Open Database Connectivity) werden unabhängig von der tatsächlichen Einstellung der Eigenschaft RecordLocks behandelt, als ob die Einstellung Keine Sperrungen ausgewählt ist.


 RecordSelectors-Eigenschaft (Datensatzmarkierer)

RecordSelectors-Eigenschaft (Datensatzmarkierer)

Mit der Eigenschaft RecordSelectors können Sie angeben, ob ein Formular in der Formularansicht Datensatzmarkierer anzeigen soll.

Einstellung

Die Eigenschaft RecordSelectors kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Jeder Datensatz verfügt über einen Datensatzmarkierer.
Nein | False (0) | Kein Datensatz verfügt über einen Datensatzmarkierer.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Sie können diese Eigenschaft zur Entfernung von Datensatzmarkierern verwenden, wenn Sie ein Formular als ein benutzerdefiniertes Dialogfeld oder als eine Palette erstellen oder verwenden. Sie können diese Eigenschaft auch für Formulare verwenden, deren Eigenschaft DefaultView auf Einzelnes Formular eingestellt ist.

Der Datensatzmarkierer zeigt beim Bearbeiten eines Datensatzes das Symbol Ungespeicherter Datensatz [image] an. Ist die Eigenschaft RecordSelectors auf Nein und die Eigenschaft RecordLocks auf Bearbeiteter Datensatz (der Datensatz ist "pessimistisch" gesperrt, d.h, nur eine Person kann den jeweiligen Datensatz bearbeiten) eingestellt, gibt es keinen sichtbaren Hinweis darauf, dass der Datensatz gesperrt ist.


 Recordset-Eigenschaft

Recordset-Eigenschaft

Mit Hilfe der Recordset-Eigenschaft können Sie das ADO-Objekt Recordset oder das DAO-Objekt Recordset angeben oder abrufen, welches die Datenherkunft eines Formulars darstellt.

Anmerkung Diese Eigenschaft kann nicht mit ODBCDirect-Datensatzgruppentypen in DAO verwendet werden.

Einstellung

Die Recordset-Eigenschaft gibt das Recordset-Objekt zurück, das die in einem Formular angezeigten Daten bereitstellt. Basiert ein Formular z. B. auf einer Abfrage, so entspricht ein Verweis auf die Recordset-Eigenschaft dem Kopieren eines Recordset-Objekts unter Verwendung derselben Abfrage. Anders als bei Verwendung der RecordsetClone-Eigenschaft werden Währungsänderungen, die in der Form Recordset-Eigenschaft vorgenommen werden, automatisch im aktuellen Datensatz des Formulars wiedergegeben.

Diese Eigenschaft steht nur bei Verwendung von Visual Basic zur Verfügung.

Anmerkungen

Wenn in einer Microsoft Access-Datenbank (.mdb) auf eine Datensatzgruppe verwiesen wird, wird eine DAO-Datensatzgruppe zurückgegeben, in einem Microsoft Access-Projekt (.adp) wird hingegen eine ADO-Datensatzgruppe zurückgegeben.

Das Lese-/Schreibverhalten eines Formulars, dessen Recordset-Eigenschaft mit Hilfe von Visual Basic eingestellt wurde, wird durch den Typ der Datensatzgruppe (ADO oder DAO) und den Typ der Daten (Jet oder SQL) bestimmt, die in der durch die Eigenschaft identifizierten Datensatzgruppe enthalten sind.

Typ der Datensatzgruppe | Basierend auf SQL-Daten | Basierend auf Jet-Daten
ADO | Lesen/Schreiben (1) | Schreibgeschützt
DAO | Entfällt | Lesen/Schreiben

(1) Anmerkung Die ADO Recordset.CursorLocation-Eigenschaft muss auf adUseClient eingestellt sein. Die UniqueTable-Eigenschaft ist bei Client/Server im Eigenschaftenfenster verfügbar, jedoch nicht bei Access-Datenbanken (.mdb). Dort muss diese Eigenschaft in Visual Basic-Code eingestellt werden.

Global rstLieferanten As ADODB.Recordset
Sub MakeRW()
    DoCmd.OpenForm "Lieferanten"
    Set rstLieferanten = New ADODB.Recordset
    rstLieferanten.CursorLocation = adUseClient
    rstLieferanten.Open "Select * From Lieferanten", CurrentProject.Connection, adOpenKeyset, adLockOptimistic
    Set Forms("Lieferanten").Recordset = rstLieferanten
    Forms("Lieferanten").UniqueTable = "Lieferanten"
End Sub

Die Recordset-Eigenschaft wird für folgende Aufgaben verwendet:

  • Binden mehrerer Formulare an eine gemeinsame Datengruppe. Dadurch können mehrere Formulare synchronisiert werden. Beispiel:
    Set Me.Recordset = Formulare!Form1.Recordset

  • Anwenden von Methoden am Recordset-Objekt, die in Formularen nicht unmittelbar unterstützt werden. Zum Beispiel können Sie die Recordset-Eigenschaft verwenden, wenn Sie mit der ADO-Methode Find oder der DAO-Methode Find einen angepassten Dialog zum suchen eines Datensatzes verwenden wollen.

  • Zusammenfassen einer Gruppe von Änderungen, die mehrere Formulare betrifft, durch eine Transaktion (die rückgängig gemacht werden kann).

Wenn ein neues Recordset-Objekt geöffnet wird, ist der erste Datensatz der aktuelle Datensatz.

ADO-Methoden und Eigenschaften | DAO-Methoden und Eigenschaften
Find, Move oder andere Move-Methoden | FindFirst, FindNext, FindLast, FindPrevious, Move oder andere Move-Methoden

Anmerkung Um die RecordSource-Eigenschaft eines Formulars zu ändern, müssen Sie die Set-Anweisung verwenden. Änderungen an der Recordset-Eigenschaft eines Formulars wirken sich auch auf die RecordSource-, RecordsetType- und RecordLocks-Eigenschaften aus. Außerdem werden eventuell einige datenbezogene Eigenschaften außer Kraft gesetzt; so zum Beispiel die Filter-, FilterOn-, OrderBy- und OrderByOn-Eigenschaften.


 RecordsetClone-Eigenschaft

RecordsetClone-Eigenschaft

Sie können die Eigenschaft RecordsetClone verwenden, um auf ein Objekt Recordset zu verweisen, das von der Eigenschaft RecordSource eines Formulars angegeben wird.

Einstellung

Die Einstellung der Eigenschaft RecordsetClone eines Formulars stellt eine Kopie der Abfrage oder Tabelle dar, die dem Formular zugrundeliegt und von der Einstellung der Eigenschaft RecordSource des Formulars festgelegt wird. Basiert ein Formular z.B. auf einer Abfrage, so entspricht ein Verweis auf die Eigenschaft RecordsetClone dem Kopieren eines Recordset-Objekts unter Verwendung derselben Abfrage. Wenn Sie dann für das Formular einen Filter anwenden, wird das Recordset-Objekt der Filterung angepasst.

Die Eigenschaft RecordsetClone ist nur in Visual Basic verfügbar und ist in allen Ansichten schreibgeschützt.

Anmerkung

Verwenden Sie die Eigenschaft RecordsetClone, wenn Sie mit den Datensätzen eines Formulars unabhängig von diesem Formular arbeiten möchten. Sie verwenden z.B. die Eigenschaft RecordsetClone, wenn Sie eine Methode wie z.B. die DAO-Methoden Find einsetzen möchten, die nicht für Formulare verwendet werden kann.

Wenn ein neues Recordset-Objekt geöffnet wird, ist dessen erster Datensatz der aktuelle Datensatz. Wenn Sie eine der Find-Methoden oder eine der Move-Methoden verwenden, um einen beliebigen Datensatz des jeweiligen Recordset-Objekts zum aktuellen Datensatz zu erklären, müssen Sie den aktuellen Datensatz im Recordset-Objekt mit dem aktuellen Datensatz des Formulars synchronisieren. Dazu weisen Sie den Wert der DAO-Eigenschaft Bookmark der Bookmark-Eigenschaft des Formulars zu.

Mit Hilfe der RecordCount-Eigenschaft können Sie die Anzahl der Datensätze eines Recordset-Objekts ermitteln. Das folgende Beispiel zeigt, wie Sie die RecordCount- und RecordsetClone-Eigenschaften kombinieren können, um die Datensätze eines Formulars zu zählen:

Formulare!Bestellungen.RecordsetClone.MoveLast
MsgBox "Mein Formular enthält " _
    & Formulare!Bestellungen.RecordsetClone.RecordCount
    & " Datensätze.", vbInformation, " Datensatzanzahl "

Anmerkung Sobald Sie das Formular geschlossen oder die Eigenschaft RecordSource des Formulars geändert haben, ist das Recordset-Objekt nicht mehr gültig. Wenn Sie später auf das Recordset-Objekt oder auf vorher gespeicherte Lesezeichen des Formulars oder des Recordset-Objekts verweisen, tritt ein Fehler auf.


 RecordsetType-Eigenschaft (Recordsettyp)

RecordsetType-Eigenschaft (Recordsettyp)

Mit der RecordsetType-Eigenschaft können Sie den Typ der Datensatzgruppe angeben, die einem Formular verfügbar gemacht wird. Wenn z. B. Daten in gebundenen Steuerelementen nicht bearbeitet werden sollen, wenn ein Formular sich in der Formularansicht oder der Datenblattansicht befindet, können Sie die Eigenschaft RecordsetType auf Snapshot setzen.

Einstellung

Die RecordsetType-Eigenschaft verwendet die folgenden Einstellungen in einer Microsoft Access-Datenbank (.mdb).

Einstellung | Visual Basic | Beschreibung
Dynaset | 0 | (Standardeinstellung) Sie können gebundene Steuerelemente auf der Basis einer einzigen Tabelle oder von Tabellen mit einer 1:1-Beziehung bearbeiten. Bei Steuerelementen, die an Felder gebunden sind, welche auf Tabellen mit einer 1:n-Beziehung basieren, können Sie Daten im Verknüpfungsfeld auf der "1-Seite" der Beziehung nur bearbeiten, wenn die Aktualisierungsweitergabe zwischen den Tabellen aktiviert ist. Weitere Informationen finden Sie unter Aktualisieren von Datensätzen aus einer Abfrage.
Dynaset (Unregelmäßige Aktualisierungen) | 1 | Alle Tabellen und an ihre Felder gebundenen Steuerelemente können bearbeitet werden.
Snapshot | 2 | Tabellen oder an deren Felder gebundene Steuerelemente können nicht bearbeitet werden.

Die RecordsetType-Eigenschaft verwendet die folgenden Einstellungen in einem Microsoft Access-Projekt (.adp).

Einstellung | Visual Basic | Beschreibung
Snapshot | 3 | Es können keine Tabellen oder an ihre Felder gebundenen Steuerelemente bearbeitet werden.
Aktualisierbarer Snapshot | 4 | (Standardeinstellung) Alle Tabellen und an ihre Felder gebundenen Steuerelemente können bearbeitet werden.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung Wenn die RecordsetType-Eigenschaft eines geöffneten Formulars oder Berichts geändert wird, führt dies zu einer automatischen Neuerstellung der Datensatzgruppe.

Anmerkung

Sie können Formulare erstellen, die auf mehreren zugrunde liegenden Tabellen basieren, an deren Felder Steuerelemente in den Formularen gebunden sind. Abhängig von der Einstellung der RecordsetType-Eigenschaft können Sie einschränken, welche gebundenen Steuerelemente bearbeitet werden können.

Zusätzlich zu dem von der RecordsetType-Eigenschaft bereitgestellten Bearbeitungssteuerelement verfügt jedes Steuerelement in einem Formular über eine Locked-Eigenschaft, mit der Sie angeben können, ob das Steuerelement und die ihm zugrunde liegenden Daten bearbeitet werden können. Ist die Locked-Eigenschaft auf "Ja" eingestellt, können die Daten nicht bearbeitet werden.


 RecordSource-Eigenschaft (Datenherkunft)

RecordSource-Eigenschaft (Datenherkunft)

Sie können die Eigenschaft RecordSource zur Einstellung der Herkunft der Daten für ein Formular oder einen Bericht verwenden. Sie können Daten aus einer Tabelle, Abfrage oder SQL-Anweisung anzeigen. Möchten Sie z.B. Daten aus der Tabelle Personal in einem Formular anzeigen und bearbeiten, so stellen Sie die Eigenschaft RecordSource des Formulars auf Personal ein. Anschließend können Sie die Steuerelemente des Formulars oder Berichts an bestimmte Felder der Tabelle Personal binden, indem Sie die Eigenschaft ControlSource des jeweiligen Steuerelements auf den Namen eines Feldes der Tabelle einstellen. Sie können z.B. ein Steuerelement an das Feld Nachname der Tabelle Personal binden, indem Sie die Eigenschaft ControlSource des Steuerelements auf Nachname einstellen.

Einstellung

Die Einstellung der Eigenschaft RecordSource kann ein Tabellenname, ein Abfragename oder eine SQL-Anweisung sein. Sie können z.B. die folgenden Einstellungen verwenden.

Beispieleinstellung | Beschreibung
Personal | Ein Tabellenname, der als Herkunft der Daten die Tabelle Personal angibt.
SELECT Bestellungen.Bestelldatum FROM Bestellungen; | Eine SQL-Anweisung, die als Herkunft der Daten das Feld Bestelldatum der Tabelle Bestellungen angibt. Sie können ein Steuerelement des Formulars oder Berichts an das Feld Bestelldatum der Tabelle Bestellungen binden, indem Sie die Eigenschaft ControlSource des Steuerelements auf Bestelldatum einstellen.

Sie können die Eigenschaft RecordSource im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Verwenden Sie in Visual Basic einen Zeichenfolgenausdruck, um diese Eigenschaft einzustellen.

Anmerkung Das Ändern der Datenherkunft eines geöffneten Formulars oder Berichts bewirkt, dass die zugrunde liegenden Daten automatisch erneut abgefragt werden. Wenn die Recordset-Eigenschaft eines Formulars zur Laufzeit festgelegt wird, wird die RecordSource-Eigenschaft des Formulars aktualisiert.

Anmerkung

Nachdem Sie ein Formular oder einen Bericht erstellt haben, können Sie die Herkunft der Daten ändern, indem Sie die Eigenschaft RecordSource ändern. Die Eigenschaft RecordSource ist auch hilfreich, wenn Sie ein wiederverwendbares Formular oder einen wiederverwendbaren Bericht erstellen möchten. Sie können z.B. ein Formular erstellen, das einen Standardentwurf enthält, dann das Formular kopieren und die Eigenschaft RecordSource ändern, um Daten aus einer anderen Tabelle, Abfrage oder SQL-Anweisung anzuzeigen.

Das Begrenzen der Anzahl an Datensätzen, die sich in der Datenherkunft eines Formulars befinden, kann das Leistungsverhalten verbessern (insbesondere beim Ausführen der Anwendung im Netzwerk). Sie können z.B. die Eigenschaft RecordSource eines Formulars auf einen SQL-Ausdruck einstellen, der einen Datensatz zurückgibt, und die Datenherkunft abhängig von den vom Benutzer gewählten Kriterien ändern.


References-Eigenschaft

Mit der References-Eigenschaft können Sie auf die Auflistung References und die zugehörigen Eigenschaften, Methoden und Ereignisse zugreifen.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Die Auflistung References entspricht der Liste der Referenzen aus dem Dialogfeld Verweise. Um dieses Dialogfeld zu öffnen, klicken Sie im Menü Extras auf Verweise. Jedes Reference-Objekt stellt einen ausgewählten Verweis aus der Liste dar. Verweise, die im Dialogfeld Verweise angezeigt werden, aber nicht ausgewählt wurden, sind nicht in der Auflistung References enthalten.


RepeatSection-Eigenschaft (BereichWiederholen)

Sie können mit der Eigenschaft RepeatSection angeben, ob ein Gruppenkopf auf der nächsten Seite oder über der nächsten Spalte wiederholt wird, wenn eine Gruppe mehr als eine Seite oder Spalte umfasst.

Anmerkung Die Eigenschaft RepeatSection betrifft nur die Gruppenköpfe in einem Bericht.

Einstellung

Die Eigenschaft RepeatSection verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Der Gruppenkopf wird wiederholt.
Nein | False (0) | (Voreinstellung) Der Gruppenkopf wird nicht wiederholt.

Sie können die Eigenschaft RepeatSection mit dem Eigenschaftenfenster des Gruppenkopfbereichs, mit einem Makro oder über Visual Basic einstellen.

Anmerkung

Wird ein Bericht gedruckt, der einen Unterbericht enthält, legt die Eigenschaft RepeatSection des Unterberichts fest, ob die Gruppenköpfe des Unterberichts über alle Seiten bzw. Spalten hinweg wiederholt werden.


 ReplicationConflictFunction-Eigenschaft

ReplicationConflictFunction-Eigenschaft

Die Eigenschaft ReplicationConflictFunction ermöglicht es Ihnen, mit Hilfe von benutzerdefiniertem Konfliktlösungscode Datenkonflikte zu lösen, die bei der Synchronisierung zwischen Replikaten auftreten. Wenn Sie diese Eigenschaft einstellen und der jeweilige Benutzer eine Konfliktlösung anfordert, ruft Microsoft Access an Stelle des eingebauten Konfliktlösers Ihre Konfliktlösungsfunktion auf.

Einstellungen

Stellen Sie die Eigenschaft ReplicationConflictFunction auf eine Textzeichenfolge ein, d.h. auf den Namen der Function-Prozedur, die Sie aufrufen möchten. Beachten Sie, dass diese Einstellung mit dem Namen einer Function-Prozedur identisch sein muss und nicht der Name einer Sub-Prozedur sein kann. Wird die Eigenschaft ReplicationConflictFunction nicht eingestellt, ruft Microsoft Access den eingebauten Konfliktlöser auf.

Wenn Sie die Einstellung dieser Eigenschaft zum ersten Mal in Visual Basic festlegen, müssen Sie die Eigenschaft zunächst erstellen und dann an die Properties-Auflistung des benutzerdefinierten Document-Objekts anfügen. Sie sollten in Ihre Prozedur Fehlerbehandlungscode zum Testen für den Fall einbeziehen, dass die Eigenschaft in der Properties-Auflistung noch nicht vorhanden ist. Weitere Informationen finden Sie unter der Methode CreateProperty.

Wenn Sie die Eigenschaft ReplicationConflictFunction erstellen und anfügen, müssen Sie auch den Wert True (-1) für das optionale Argument DDL der Methode CreateProperty angeben. Dieses Argument stellt sicher, dass Benutzer das neue Property-Objekt nur dann ändern oder löschen können, wenn sie über dbSecWriteDef-Berechtigungen verfügen. Falls Sie den Wert True für dieses Argument nicht angeben, wird der benutzerdefinierte Konfliktlösungscode nicht aufgerufen.

Um die Steuerung an den eingebauten Konfliktlöser zurückzugeben, entfernen Sie die Eigenschaft ReplicationConflictFunction aus der Properties-Auflistung.

Sie können diese Eigenschaft auch auf der Registerkarte Anpassen des Dialogfelds Eigenschaften von Datenbankname hinzufügen oder löschen. Klicken Sie zum Öffnen dieses Dialogfelds im Menü Datei auf Datenbankeigenschaften.

Anmerkung

Wurde der gleiche Datensatz einer replizierten Datenbank in einem oder mehreren Replikaten geändert, treten beim Synchronisieren eines Replikats mit der Replikatgruppe Konflikte auf. Wenn Sie diese Konflikte lösen möchten, ruft Microsoft Access den eingebauten Konfliktlöser auf. Der Assistent zeigt dem Benutzer jeden Konflikt an. Dieser muss manuell bestimmen, welcher geänderte Datensatz die richtigen Daten enthält.

Wenn Sie die Konfliktlösung für Ihre Anwendung automatisieren möchten, können Sie benutzerdefinierte Prozeduren zum Lösen von Konflikten schreiben und dann den eingebauten Funktionsumfang außer Kraft setzen, indem Sie die Eigenschaft ReplicationConflictFunction einstellen. Erstellen Sie eine Funktion, die als Zugang zum Konfliktlösungscode fungiert. Stellen Sie anschließend die Eigenschaft ReplicationConflictFunction auf den Namen dieser Funktion ein.

Wenn Sie benutzerdefinierten Konfliktlösungscode schreiben, muss dieser auch Entwurfs- und Datenfehler bei der Replikation behandeln. Um ein Beispiel anzuzeigen, öffnen Sie die Assistentendatenbank WZCNF80.MDA im Ordner OFFICE, und sehen Sie sich den Quellcode an.


 Reports-Eigenschaft

Reports-Eigenschaft

Mit der Reports-Eigenschaft können Sie auf die Auflistung Reports und die zugehörigen Eigenschaften zugreifen.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Die Auflistung Reports enthält alle gegenwärtig geöffneten Berichte in einer Microsoft Access-Datenbank (.mdb) oder einem Microsoft Access-Projekt (.adp).


 Required-Eigenschaft (Eingabe erforderlich)

Required-Eigenschaft (Eingabe erforderlich)

Mit der Eigenschaft Required können Sie angeben, ob ein Wert in einem Feld erforderlich ist oder nicht. Ist diese Eigenschaft auf Ja eingestellt, so müssen Sie bei der Eingabe von Daten in einem Datensatz einen Wert in dem Feld oder in einem an dieses Feld gebundenen Steuerelement eingeben, wobei der Wert ungleich Null sein muss. Sie möchten z.B. sicherstellen, dass ein Steuerelement namens Nachname in jedem Datensatz einen Wert enthält. Wenn Sie Nullwerte in einem Feld zulassen möchten, müssen Sie nicht nur die Eigenschaft Required auf Nein einstellen, sondern, falls es eine Gültigkeitsregel gibt, muss diese auch explizit angeben "Ist Null Oder (...andere Gültigkeitsregeln...)".

Anmerkung Die Eigenschaft Required gilt nicht für Felder vom Typ AutoWert.

Einstellung

Die Eigenschaft Required verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Feld erfordert einen Wert.
Nein | False (0) | (Voreinstellung) Das Feld erfordert keinen Wert.

Sie können diese Eigenschaft für alle Tabellenfelder (mit Ausnahme von Feldern des Datentyps AutoWert) im Eigenschaftenfenster der Tabelle oder in Visual Basic einstellen.

Anmerkung Sie greifen auf die Eigenschaft Required eines Feldes in Visual Basic zu, indem Sie die DAO-Eigenschaft Required verwenden.

Anmerkung

Die Eigenschaft Required wird auf Tabellenebene durch die Microsoft Jet-Datenbank-Engine erzwungen. Wenn Sie diese Eigenschaft auf Ja einstellen, muss das Feld einen Wert erhalten oder bereits enthalten, falls es über den Fokus verfügt, wenn der Benutzer Daten in einer Tabelle (oder in einem Formular oder Datenblatt, das auf der Tabelle basiert) eingibt, wenn ein Makro oder Visual Basic den Wert des Feldes einstellt oder Daten in die Tabelle importiert werden.

Sie können die Eigenschaften Required und AllowZeroLength verwenden, um zwischen nicht bestehenden Informationen (als leere Zeichenfolge (" ") im Feld gespeichert) und möglicherweise bestehenden, aber unbekannten Informationen (als Null-Wert im Feld gespeichert) zu unterscheiden. Stellen Sie die Eigenschaft AllowZeroLength auf Ja ein, so ist eine leere Zeichenfolge ein gültiger Eintrag für ein Feld, unabhängig von der Einstellung der Eigenschaft Required. Stellen Sie die Eigenschaft Required auf Ja und die Eigenschaft AllowZeroLength auf Nein ein, so müssen Sie einen Wert in dem Feld eingeben, und eine leere Zeichenfolge ist kein gültiger Eintrag.

Tipp Sie müssen ein Eingabeformat verwenden, wenn Daten in einem Feld eingegeben werden, um zwischen der Anzeige eines Null-Wertes und einer leeren Zeichenfolge zu unterscheiden. So könnte z.B. die Zeichenfolge "Keine" angezeigt werden, wenn eine leere Zeichenfolge eingegeben wird.

Die folgende Tabelle zeigt die zu erwartenden Ergebnisse an, wenn Sie die Einstellungen der Eigenschaften Required und AllowZeroLength kombinieren.

Required | AllowZeroLength | Benutzeraktion | Gespeicherter Wert
Nein | Nein | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | Null Null (nicht zulässig)
Nein | Ja | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | Null Null Leere Zeichenfolge
Ja | Nein | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | (nicht zulässig) (nicht zulässig) (nicht zulässig)
Ja | Ja | Drückt EINGABETASTE Drückt LEERTASTE Gibt eine leere Zeichenfolge ein | (nicht zulässig) Leere Zeichenfolge Leere Zeichenfolge

Wenn Sie die Eigenschaft Required für ein Feld in einer Tabelle, das bereits Daten enthält, auf Ja einstellen, können Sie mit Microsoft Access prüfen, ob das Feld in allen bestehenden Datensätzen einen Wert enthält. Sie können aber auch fordern, dass ein Wert in diesem Feld für alle neuen Datensätze eingegeben wird, wenn bereits Datensätze mit Null-Werten in diesem Feld existieren.

Anmerkung Damit Sie eine Beziehung zwischen verknüpften Tabellen erzwingen können, die keine Null-Werte zulassen, stellen Sie die Eigenschaft Required des Feldes Fremdschlüssel in der verknüpften Tabelle auf Ja ein. Die Jet-Datenbank-Engine sorgt dann dafür, dass ein verknüpfter Datensatz in der übergeordneten Tabelle existiert, bevor Sie einen Datensatz in der untergeordneten Tabelle erstellen können. Stellt das Fremdschlüsselfeld einen Teil des Primärschlüssels der untergeordneten Tabelle dar, so ist diese Maßnahme nicht erforderlich, da ein Primärschlüsselfeld keinen Null-Wert enthalten kann.


 ResyncCommand-Eigenschaft (ResyncBefehl)

ResyncCommand-Eigenschaft (ResyncBefehl)

Mit Hilfe der ResyncCommand-Eigenschaft können Sie die SQL-Anweisung oder die gespeicherte Prozedur angeben oder ermitteln, die in einem aktualisierbaren Snapshot einer Tabelle verwendet wird.

Einstellung

Die ResyncCommand-Eigenschaft ist ein Zeichenfolgenausdruck und gibt eine SQL-Anweisung oder gespeicherte Prozedur wieder, die ihre Parameter von den Schlüsselspalten der eindeutigen Tabelle im Ausgabecursor bezieht, wobei ? als Parametermarkierer dient.

Sie können diese Eigenschaft im Eigenschaftenfenster oder mit Visual Basic einstellen.

Anmerkungen

Die Parameter müssen in Zahl und Reihenfolge mit der Gruppe der Schlüsselspalten für die Tabelle übereinstimmen, die durch die UniqueTable-Eigenschaft identifiziert wird. Der Zweck der ResyncCommand-Eigenschaft ist es, die "korrigierten" Werte einer Zeile in einer Datensatzgruppe zu übernehmen, nachdem eine Aktualisierung durchgeführt wurde, einschließlich der Aktualisierung einer verknüpften Spalte. Vergleichen Sie hierzu Beispiel 1 im Beispielthema.

Wenn bei Datenzugriffsseiten oder Formularen, die auf Ansichten oder nicht-parameterisierten SQL-Abfragen mit einer Verknüpfung basieren, die ResyncCommand-Eigenschaft gleich Null ist, ermittelt Microsoft Access eine geeignete Abfrage für die Resync-Operation. Bei Datenzugriffsseiten oder Formularen, die auf gespeicherten Prozeduren oder parameterisierten SQL-Anweisungen basieren, kann Access während der Laufzeit keine geeignete Resync-Abfrage bestimmen, so dass der Benutzer die ResyncCommand-Zeichenfolge selbst eingeben muss, um die richtige Reihen-Fixup-Korrektur zu erhalten. Falls die ResyncCommand-Eigenschaft leer ist und Access keine geeignete Abfrage ermitteln kann, wird nach einer Aktualisierung oder Ergänzung die standardmäßige ADO-Operation Resync (zur Anzeige der aktuellen Werte) durchgeführt.


 ReturnsRecords-Eigenschaft

ReturnsRecords-Eigenschaft

Sie verwenden die Eigenschaft ReturnsRecords in einer SQL Pass-Through-Abfrage, um anzugeben, ob die Abfrage Datensätze zurückgeben soll. Lautet die Pass-Through-Abfrage z.B. SELECT*FROM PERSONAL, und stellen Sie die Eigenschaft ReturnsRecords auf Ja ein, so werden alle Datensätze der Angestellten im Abfragedatenblatt angezeigt.

Anmerkung Die Eigenschaft ReturnsRecords gilt nur für Pass-Through-Abfragen.

Einstellung

Die Eigenschaft ReturnsRecords verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Voreinstellung) Die Abfrage gibt Datensätze zurück (wie eine Auswahlabfrage).
Nein | False (0) | Die Abfrage gibt keine Datensätze zurück (wie eine Aktionsabfrage).

Sie können diese Eigenschaft im Abfrage-Eigenschaftenfenster oder in Visual Basic einstellen.

Tipp Sie können auf die Eigenschaft ReturnsRecords einer Pass-Through-Abfrage in Visual Basic zugreifen, sollten aber besser die DAO-Eigenschaft ReturnsRecords verwenden.

Anmerkung

Mit einer Pass-Through-Abfrage können Datensätze zurückgegeben , oder verändert werden, und es können Datenbankobjekte erstellt oder Aktionen (vergleichbar wie eine Aktionsabfrage) ausgeführt werden.

Wenn Sie die Eigenschaft ReturnsRecords auf Ja einstellen, können Sie die Pass-Through-Abfrage in einer anderen Abfrage oder als Grundlage für ein Kombinationsfeld, Listenfeld, Formular oder für einen Bericht verwenden. Stellen Sie die Eigenschaft ReturnsRecords dagegen auf Nein ein, dann können Sie die Abfrage nicht als Grundlage für ein Objekt oder Steuerelement verwenden, da keine Datensätze zurückgegeben werden.


 RowHeight-Eigenschaft (Zeilenhöhe)

RowHeight-Eigenschaft (Zeilenhöhe)

Sie können die Eigenschaft RowHeight verwenden, um die Höhe aller Zeilen in der Datenblattansicht einzustellen.

Anmerkung Die Eigenschaft RowHeight gilt für alle Felder in der Datenblattansicht und für Formular-Steuerelemente, wenn sich das Formular in der Datenblattansicht befindet.

Einstellung

Sie stellen die Eigenschaft RowHeight in der Datenblattansicht ein, indem Sie den unteren Rand des Datensatzmarkierers ziehen oder im Menü Format auf Zeilenhöhe klicken. Wenn Sie die Eigenschaft RowHeight mit Hilfe des Befehls Zeilenhöhe einstellen, wird der Wert in Punkten angegeben.

In Visual Basic entspricht die Einstellung der Eigenschaft RowHeight einem Wert vom Datentyp Long Integer, der die Zeilenhöhe des Datenblatts in Twips angibt. Zur Einstellung der Standardhöhe für die aktuelle Schriftart können Sie die Eigenschaft RowHeight auf True (-1) einstellen.


 RowSourceType-, RowSource-Eigenschaften (Herkunftstyp, Datensatzherkunft)

RowSourceType-, RowSource-Eigenschaften (Herkunftstyp, Datensatzherkunft)

Sie können die Eigenschaften RowSourceType und RowSource zusammen verwenden, um Microsoft Access mitzuteilen, wie Daten für ein Listenfeld, ein Kombinationsfeld oder ein ungebundenes OLE-Objekt (z.B. ein Diagramm) bereitgestellt werden sollen. Wenn Sie z.B. in einem Listenfeld Datenzeilen anzeigen möchten, die aus einer Abfrage namens Kundenliste stammen, stellen Sie die Eigenschaft RowSourceType des Listenfelds auf Tabelle/Abfrage und dessen Eigenschaft RowSource auf die Abfrage namens Kundenliste ein.

Einstellung

Die Eigenschaft RowSourceType hat die folgenden Einstellungen.

Einstellung | Beschreibung
Tabelle/Abfrage | (Standardeinstellung) Die Daten stammen aus einer Tabelle, Abfrage oder SQL-Anweisung, die von der Einstellung der Eigenschaft RowSource festgelegt wurde.
Wertliste | Die Daten entsprechen einer Liste von Einträgen, die von der Einstellung der Eigenschaft RowSource festgelegt wurden.
Feldliste | Die Daten entsprechen einer Liste von Feldnamen einer Tabelle, Abfrage oder SQL-Anweisung, die von der Einstellung der Eigenschaft RowSource festgelegt wurde.

Anmerkung Sie können die Eigenschaft RowSource auch mit einer benutzerdefinierten Funktion einstellen. Der Funktionsname wird ohne vorstehendes Gleichheitszeichen (=) und ohne nachfolgendes Klammernpaar eingegeben. Geben Sie bestimmte Code-Argumente der Funktion an, um Microsoft Access mitzuteilen, wie das Steuerelement gefüllt werden soll.

Die Einstellung der Eigenschaft RowSource ist abhängig von der Einstellung der Eigenschaft RowSourceType.

Einstellung von RowSourceType | Zugehörige Einstellung von RowSource
Tabelle/Abfrage | Der Name einer Tabelle bzw. einer Abfrage oder eine SQL-Anweisung.
Wertliste | Eine Liste von Einträgen mit Semikolons (;) als Trennzeichen.
Feldliste | Der Name einer Tabelle bzw. einer Abfrage oder eine SQL-Anweisung.

Anmerkung Wird die Eigenschaft RowSourceType auf eine benutzerdefinierte Funktion eingestellt, dann kann die Eigenschaft RowSource leer gelassen werden.

Sie können die Eigenschaften RowSourceType und RowSource im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Für solche Felder, deren Eigenschaft DisplayControl auf Kombinationsfeld oder Listenfeld eingestellt ist, können Sie diese Eigenschaft für Tabellenfelder in der Tabellenentwurfsansicht auf der Registerkarte Nachschlagen im Bereich Feldeigenschaften einstellen.

Anmerkung Microsoft Access stellt diese Eigenschaft automatisch ein, wenn Sie in der Tabellenentwurfsansicht Nachschlage-Assistent als Datentyp für ein Feld auswählen.

Stellen Sie in Visual Basic die Eigenschaft RowSourceType unter Verwendung eines Zeichenfolgenausdrucks auf einen der folgenden Werte ein: "Table/Query", "Value List" oder "Field List". Sie können einen Zeichenfolgenausdruck auch verwenden, um den Wert der Eigenschaft RowSource einzustellen. Sie stellen die Eigenschaft RowSourceType auf eine benutzerdefinierte Funktion ein, indem Sie den Namen der Funktion eingeben.

Anmerkung

Verfügen Sie über eine begrenzte Anzahl an Werten, die sich nicht ändern, so können Sie die Eigenschaft RowSourceType auf Wertliste einstellen und dann die Werte eingeben, die in der Liste in der Eigenschaft RowSource enthalten sind.

Wenn Sie eine benutzerdefinierte Funktion erstellen, um Elemente in ein Listenfeld oder Kombinationsfeld einzufügen, ruft Microsoft Access die Funktion mehrmals auf, um die benötigten Informationen zu erhalten. Benutzerdefinierte Funktionen für RowSourceType werden in einem ganz bestimmten Funktionsformat geschrieben.


 RunningSum-Eigenschaft (LaufendeSumme)

RunningSum-Eigenschaft (LaufendeSumme)

Sie können die Eigenschaft RunningSum zur Berechnung von einzelnen Datensätzen oder Gruppen-Gesamtsummen in einem Bericht verwenden. Die Eigenschaft RunningSum legt fest, ob ein Textfeld in einem Bericht eine laufende Gesamtsumme anzeigt, und lässt Sie den Bereich einstellen, über den Werte aufsummiert werden. Sie können z. B. Ihre Daten nach Monaten gruppieren und die Summe aller Monatsumsätze im Gruppenfuß anzeigen. Sie können die laufende Summe der kumulierten Umsätze für den gesamten Bericht (Januar-Umsätze im Januar-Gruppenfuß, Umsätze für Januar plus Februar im Februar-Gruppenfuß usw.) anzeigen, indem Sie ein Textfeld in den Gruppenfuß einfügen, das die Umsatzsumme anzeigt, und dessen Eigenschaft RunningSum auf ÜberAlles einstellen.

Anmerkung Die Eigenschaft RunningSum gilt nur für Textfelder eines Berichts.

Einstellung

Die Eigenschaft RunningSum hat die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Nein | 0 | (Standardeinstellung) Das Textfeld zeigt die Daten des zugrunde liegenden Feldes für den aktuellen Datensatz an.
Über Gruppe | 1 | Das Textfeld zeigt eine laufende Summe von Werten auf gleicher Gruppierungsebene an. Der Wert wird solange summiert, bis zu einer anderen Gruppierungsebene gewechselt wird.
Über Alles | 2 | Das Textfeld zeigt eine laufende Summe von Werten auf gleicher Gruppierungsebene an. Der Wert wird bis zum Ende des Berichts aufsummiert (kumuliert).

Sie können die Eigenschaft RunningSum im Eigenschaftenfenster des Textfelds, in einem Makro oder in Visual Basic einstellen. Sie können die Eigenschaft RunningSum nur in der Entwurfsansicht einstellen.

Anmerkung

Setzen Sie das Textfeld in den Detailbereich, um Ergebniswerte für einzelne Datensätze zu berechnen. Stellen Sie z. B. die Eigenschaft ControlSource für das Textfeld auf =1 ein, wenn Sie die im Detailbereich eines Berichts erscheinenden Datensätze nummerieren möchten, und stellen Sie die Eigenschaft RunningSum auf Über Gruppe ein.

Setzen Sie das Textfeld in einen Gruppenkopf oder Gruppenfuß, um Ergebniswerte für einzelne Gruppen zu berechnen.

Sie können bis zu 10 ineinander verschachtelte Gruppierungsebenen in einem Bericht verwenden.


 ScaleHeight-, ScaleWidth-Eigenschaften

ScaleHeight-, ScaleWidth-Eigenschaften

Sie können die Eigenschaften ScaleHeight und ScaleWidth verwenden, um die Anzahl der Einheiten für die horizontale und vertikale Abmessung der Seite anzugeben, wenn die Methoden Circle, Line, PSet oder Print verwendet werden, während ein Bericht in der Seitenansicht angezeigt, gedruckt oder die Ausgabe in einer Datei gespeichert wird.

Einstellung

  • Die Eigenschaft ScaleHeight gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die Anzahl der Einheiten für die vertikale Abmessung der Seite einstellt.

  • Die Eigenschaft ScaleWidth gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die Anzahl der Einheiten für die horizontale Abmessung der Seite einstellt.

Die Standardeinstellungen sind die interne Höhe und Breite einer Berichtsseite in Twips.

Sie können die Eigenschaften ScaleHeight und ScaleWidth in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Mit Hilfe der Eigenschaften ScaleHeight und ScaleWidth können Sie eine benutzerdefinierte Koordinatenskala zum Zeichnen oder Drucken erstellen. Beispielsweise definiert die Anweisung ScaleHeight = 100 die Innenhöhe des Bereichs zu 100 Einheiten, d. h. eine vertikale Einheit entspricht 1/100 der Höhe.

Verwenden Sie die Eigenschaft ScaleMode, um einen Maßstab auf der Basis einer Standardmaßeinheit, wie z. B. Punkt, Pixel, Zeichen, Zoll, Millimeter oder Zentimeter, zu definieren.

Wenn Sie für die Eigenschaften ScaleHeight und ScaleWidth positive Werte angeben, werden die Koordinatenwerte von oben nach unten und von links nach rechts größer. Wenn Sie negative Werte angeben, werden die Koordinatenwerte von unten nach oben und von rechts nach links größer.

Wenn Sie diese Eigenschaften und die verwandten Eigenschaften ScaleLeft und ScaleTop verwenden, können Sie ein vollständiges Koordinatensystem mit positiven und negativen Koordinaten einrichten. Diese vier Skalierungseigenschaften und die Eigenschaft ScaleMode stehen in folgender Wechselwirkung miteinander:

  • Wenn Sie eine andere Skalierungseigenschaft auf einen beliebigen Wert einstellen, wird die Eigenschaft ScaleMode automatisch auf den Wert 0 eingestellt.

  • Wenn Sie für die Eigenschaft ScaleMode einen größeren Wert als 0 einstellen, werden die Werte für die Eigenschaften ScaleHeight und ScaleWidth in die neue Maßeinheit geändert, und für die Eigenschaften ScaleLeft und ScaleTop wird automatisch der Wert 0 eingestellt. Darüber hinaus ändern sich auch die Einstellungen der Eigenschaften CurrentX und CurrentY entsprechend den neuen Koordinaten der aktuellen Position.

Sie können auch die Methode Scale verwenden, um die Eigenschaften ScaleHeight, ScaleWidth, ScaleLeft und ScaleTop in einer einzigen Anweisung einzustellen.

Anmerkung Die Eigenschaften ScaleHeight und ScaleWidth sind nicht mit den Eigenschaften Height und Width identisch.


 ScaleLeft-, ScaleTop-Eigenschaften

ScaleLeft-, ScaleTop-Eigenschaften

Sie können die Eigenschaften ScaleLeft und ScaleTop verwenden, um die horizontalen und vertikalen Koordinaten der Position des linken und oberen Seitenrandes anzugeben, wenn die Methoden Circle, Line, PSet oder Print verwendet werden, während ein Bericht in der Seitenansicht angezeigt, gedruckt oder die Ausgabe in einer Datei gespeichert wird.

Einstellung

  • Die Eigenschaft ScaleLeft gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die Anzahl der Einheiten für die horizontale Koordinate des linken Randes einer Seite angibt. Die Standardeinstellung ist 0.

  • Die Eigenschaft ScaleTop gibt einen Wert vom Datentyp Single in einem numerischen Ausdruck an, der die Anzahl der Einheiten für die vertikale Koordinate des oberen Randes einer Seite angibt. Die Standardeinstellung ist 0.

Sie können die Eigenschaften ScaleLeft und ScaleTop in einem Makro oder in einer Visual Basic-Ereignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Wenn Sie diese Eigenschaften und die verwandten Eigenschaften ScaleHeight und ScaleWidth verwenden, können Sie ein vollständiges Koordinatensystem mit positiven und negativen Koordinaten einrichten. Diese vier Skalierungseigenschaften und die Eigenschaft ScaleMode stehen in folgender Wechselwirkung miteinander:

  • Wenn Sie eine andere Skalierungseigenschaft auf einen beliebigen Wert einstellen, wird die Eigenschaft ScaleMode automatisch auf den Wert 0 eingestellt.

  • Wenn Sie für die Eigenschaft ScaleMode einen größeren Wert als 0 einstellen, werden die Werte für die Eigenschaften ScaleHeight und ScaleWidth in die neue Maßeinheit geändert, und für die Eigenschaften ScaleLeft und ScaleTop wird automatisch der Wert 0 eingestellt. Darüber hinaus ändern sich auch die Einstellungen der Eigenschaften CurrentX und CurrentY entsprechend den neuen Koordinaten der aktuellen Position.

Sie können auch die Methode Scale verwenden, um die Eigenschaften ScaleHeight, ScaleWidth, ScaleLeft und ScaleTop in einer einzigen Anweisung einzustellen.

Anmerkung Die Eigenschaften ScaleLeft und ScaleTop sind nicht mit den Eigenschaften Left und Top identisch.


 ScaleMode-Eigenschaft

ScaleMode-Eigenschaft

Sie können die Eigenschaft ScaleMode in Visual Basic verwenden, um die Maßeinheit für die Koordinaten auf einer Seite anzugeben, wenn die Methoden Circle, Line, PSet oder Print verwendet werden, während ein Bericht in der Seitenansicht angezeigt, gedruckt oder die Ausgabe in einer Datei gespeichert wird.

Einstellung

Die Eigenschaft ScaleMode verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
0 | Mindestens eine der Eigenschaften ScaleHeight, ScaleWidth, ScaleLeft und ScaleTop ist auf einen benutzerdefinierten Wert eingestellt.
1 | (Standardeinstellung) Twip
2 | Punkt
3 | Pixel
4 | Zeichen (horizontal = 120 Twips je Einheit; vertikal = 240 Twips je Einheit)
5 | Zoll
6 | Millimeter
7 | Zentimeter

Die Einstellung der Eigenschaft ist ein Wert vom Typ Integer.

Sie können die Eigenschaft ScaleMode in einem Makro oder in einer Visual BasicEreignisprozedur einstellen, die in der Einstellung der Eigenschaft OnPrint eines Bereichs angegeben ist.

Anmerkung

Wenn Sie die verwandten Eigenschaften ScaleHeight, ScaleWidth, ScaleLeft und ScaleTop verwenden, können Sie ein vollständiges Koordinatensystem mit positiven und negativen Koordinaten einrichten. Diese vier Skalierungseigenschaften stehen mit der Eigenschaft ScaleMode in folgender Wechselwirkung:

  • Wenn Sie eine andere Skalierungseigenschaft auf einen beliebigen Wert einstellen, wird die Eigenschaft ScaleMode automatisch auf den Wert 0 eingestellt.

  • Wenn Sie für die Eigenschaft ScaleMode einen größeren Wert als 0 einstellen, werden die Werte für die Eigenschaften ScaleHeight und ScaleWidth in die neue Maßeinheit geändert, und für die Eigenschaften ScaleLeft und ScaleTop wird automatisch der Wert 0 eingestellt. Darüber hinaus ändern sich auch die Einstellungen der Eigenschaften CurrentX und CurrentY entsprechend den neuen Koordinaten der aktuellen Position.


 Screen-Eigenschaft

Screen-Eigenschaft

Mit der Screen-Eigenschaft können Sie einen Verweis auf das Screen-Objekt und die zugehörigen Eigenschaften zurückgeben.

Einstellung

Diese Eigenschaft ist nur in Visual Basic verfügbar und ist schreibgeschützt.

Anmerkung

Verwenden Sie das Screen-Objekt, um auf ein bestimmtes Formular, einen bestimmten Bericht oder ein bestimmtes Steuerelement zu verweisen, das bzw. der den Fokus hat.


 ScreenTip-Eigenschaft (SteuerelementTip-Text)

ScreenTip-Eigenschaft (SteuerelementTip-Text)

Mit der ScreenTip-Eigenschaft können Sie den Text angeben oder ermitteln, der angezeigt wird, wenn sie den Cursor über ein Hyperlink-Steuerelement bewegen.

Einstellung

Die ScreenTip-Eigenschaft ist ein Zeichenfolgenausdruck, der in Form eines QuickInfo-Felds angezeigt wird.

Sie können die ScreenTip-Eigenschaft mit der ScreenTip-Eigenschaft in Visual Basic festlegen.

Anmerkung Die ScreenTip-Eigenschaft können Sie entweder im Eigenschaftenfenster eines Steuerelements, mit einem Makro oder in Visual Basic festlegen.

Anmerkungen

Wenn Sie den Cursor über ein Hyperlink-Steuerelement bewegen, dessen ScreenTip-Eigenschaft eingestellt ist, ändert Microsoft Access den Cursor in eine aufwärts gerichtete Hand und zeigt die Zeichenfolge an, die durch die ScreenTip-Eigenschaft definiert ist. Durch Klicken auf das Steuerelement wird das Objekt oder die Webseite angezeigt, auf die der Link verweist.

Weitere Informationen über Hyperlinkadressen und deren Format finden Sie unter den Themen HyperlinkAddress-Eigenschaft und ScreenTip-Eigenschaft.


ScrollBarAlign-Eigenschaft

Sprachspezifische Informationen

You can use the ScrollBarAlign to specify or determine the alignment of a vertical scroll bar.

Setting

The ScrollBarAlign property uses the following settings.

Setting | Visual Basic | Description
System | 0 | Vertical scroll bar is placed on the left if the form or report Orientation property is right to left; and on the right if the form or report Orientation property is left to right.
Right | 1 | Aligns vertical scroll bar on the right side of the control.
Left | 2 | Aligns vertical scroll bar on the left side of the control.

You can set this property by using the property sheet or Visual Basic.

Remarks

For combo and list boxes, ScrollBarAlign also controls the placement of the box button above the scroll bar.

For more information about right-to-left properties, see Learn more about right-to-left properties in Microsoft Access 2000.


 ScrollBars-Eigenschaft (Bildlaufleisten)

ScrollBars-Eigenschaft (Bildlaufleisten)

Mit der Eigenschaft ScrollBars können Sie angeben, ob Bildlaufleisten auf einem Formular oder in einem Textfeld-Steuerelement angezeigt werden sollen.

Einstellung

Die Eigenschaft ScrollBars kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Nein (Formulare) Keine (Textfelder) | 0 | (Standardeinstellung für Textfelder) Es werden keine Bildlaufleisten im Formular oder Textfeld angezeigt.
Nur horizontal (Formulare) | 1 | Horizontale Bildlaufleisten werden im Formular angezeigt. Nicht anwendbar auf Textfelder.
Nur vertikal (Formulare) Vertikal (Textfelder) | 2 | Vertikale Bildlaufleisten werden im Formular oder Textfeld angezeigt.
In beide Richtungen (Formulare) | 3 | (Standardeinstellung für Formulare) Vertikale und horizontale Bildlaufleisten werden im Formular angezeigt. Nicht anwendbar auf Textfelder.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars oder Steuerelements, in einem Makro oder in Visual Basic einstellen.

Bei einem Textfeld können Sie die Standardeinstellung dieser Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

Anmerkung

Ist Ihr Formular größer als das verfügbare Anzeigefenster, können Sie die Eigenschaft ScrollBars verwenden, um dem Benutzer die Ansicht des gesamten Formulars zu ermöglichen.

Mit der Eigenschaft NavigationButtons können Sie die Navigation zwischen Datensätzen steuern.


 Section-Eigenschaft (Bereich)

Section-Eigenschaft (Bereich)

Sie können die Eigenschaft Section verwenden, um einen Bereich eines Formulars oder Berichts zu bezeichnen und den Zugriff auf die Eigenschaften dieses Bereichs zu ermöglichen. Sie können auch Steuerelemente durch den Bereich eines Formulars oder Berichts bezeichnen, auf dem das Steuerelement erscheint.

Einstellung

Die Einstellung der Eigenschaft Section ist ein Wert des Datentyps lnteger, der einem bestimmten Bereich entspricht. Sie können Werte des Typs Integer oder die unten genannten Konstanten verwenden. Der Vorteil der Verwendung der Konstanten ist, dass Ihr Code einfacher gelesen werden kann.

Einstellung | Konstante | Beschreibung
0 | acDetail | Formulardetailbereich oder Berichtsdetailbereich
1 | acHeader | Formular- oder Berichtskopfbereich
2 | acFooter | Formular- oder Berichtsfußbereich
3 | acPageHeader | Formular- oder Berichtsseitenkopfbereich
4 | acPageFooter | Formular- oder Berichtsseitenfußbereich
5 | acGroupLevel1Header | Gruppierungsebene 1 Kopfbereich (nur Berichte)
6 | acGroupLevel1Footer | Gruppierungsebene 1 Fußbereich (nur Berichte)
7 | acGroupLevel2Header | Gruppierungsebene 2 Kopfbereich (nur Berichte)
8 | acGroupLevel2Footer | Gruppierungsebene 2 Fußbereich (nur Berichte)

Wenn ein Bericht zusätzliche Bereiche für Gruppierungsebenen hat, werden die Kopf-/Fußbereichsnummern fortlaufend ab 9 nummeriert.

Die Eigenschaft Section ist in allen Ansichten schreibgeschützt.

Für Formulare und Berichte entspricht die Eigenschaft Section einem Datenfeld aller bestehenden Bereiche des Formulars oder Berichts, die mit der Bereichszahl festgelegt wird. So verweist Section(0) z.B. auf den Detailbereich eines Formulars und Section(3) auf den Seitenkopfbereich eines Formulars.

Sie können auch durch einen Namen auf einen Bereich verweisen. Die folgenden Anweisungen sind identisch und verweisen auf den Bereich Detail0 des Formulars Kunden.

Formulare!Kunden.Section(acDetail).Visible
Formulare!Kunden.Section(0).Visible
Formulare!Kunden.Detail0.Visible

Anmerkung

Bei Formularen und Berichten müssen Sie die Eigenschaft Section mit anderen Eigenschaften, die für Formular- oder Berichtsbereiche gelten, kombinieren. Das folgende Beispiel zeigt, wie Sie auf die Eigenschaft Visible des Seitenkopfbereichs des Formulars Kunden verweisen.

Formulare!Kunden.Section(acPageHeader).Visible
Formulare!Kunden.Section(3).Visible

Für Steuerelemente können Sie die Eigenschaft Section verwenden, um zu ermitteln, in welchem Bereich eines Formulars oder Berichts sich ein Steuerelement befindet. Im folgenden Beispiel wird mit Hilfe der Eigenschaft Section ermittelt, welcher Bereich das Steuerelement Kunden-Code enthält.

Dim intBereichsnummer As Integer
intBereichsnummer = Formulare!Kunden![Kunden-Code].Section


 Selected-Eigenschaft

Selected-Eigenschaft

Sie können mit der Eigenschaft Selected in Visual Basic für ein Element eines Listenfelds ermitteln, ob es ausgewählt ist.

Einstellung

Die Eigenschaft Selected ist ein auf Null basierendes Datenfeld, das für jeden Eintrag eines Listenfelds angibt, ob er ausgewählt ist oder nicht.

Einstellung | Beschreibung
True (-1) | Das Listenfeldelement ist ausgewählt.
False (0) | Das Listenfeldelement ist nicht ausgewählt.

Sie können die Eigenschaft Selected über Visual Basic abrufen oder einstellen.

Diese Eigenschaft ist nur zur Laufzeit verfügbar.

Anmerkung

Wenn die Eigenschaft MultiSelect eines Listenfeld-Steuerelements auf Keine eingestellt ist, kann nur für ein Element die Eigenschaft Selected auf True eingestellt sein. Wenn die Eigenschaft MultiSelect eines Listenfeld-Steuerelements auf Einzeln oder Erweitert eingestellt ist, kann die Eigenschaft Selected für jedes Element auf True eingestellt sein. Die Eigenschaft Value eines Mehrfachauswahl-Listenfelds, das an ein Feld gebunden ist, ist immer auf Null eingestellt. Sie können die Eigenschaft Selected oder die Auflistung ItemsSelected verwenden, um die ausgewählten Elemente zu bestimmen.

Sie können die Eigenschaft Selected verwenden, um Elemente eines Listenfelds über Visual Basic auszuwählen. Der folgende Ausdruck wählt z.B. das fünfte Element der Liste aus:

Me!Listbox.Selected(4) = True


 SelHeight-, SelWidth-Eigenschaften

SelHeight-, SelWidth-Eigenschaften

Mit Hilfe der Eigenschaft SelHeight können Sie die Anzahl der markierten Zeilen (Datensätze) im aktuellen Auswahlrechteck des Datenblatts einer Tabelle, einer Abfrage oder eines Formulars bzw. die Anzahl der markierten Datensätze in einem Endlosformular festlegen oder bestimmen. Mit Hilfe der Eigenschaft SelWidth können Sie die Anzahl der markierten Spalten (Felder) im aktuellen Auswahlrechteck festlegen oder bestimmen. Wenn Sie z.B. in der Datenblattansicht der Tabelle Kunden eine Gruppe von Zeilen und Spalten markiert haben, können Sie über die Eigenschaften SelHeight und SelWidth die Anzahl der Zeilen und Spalten im Auswahlrechteck bestimmen.

Einstellung

  • Die Eigenschaft SelHeight. Ein Wert des Datentyps Long Integer zwischen 0 und der Anzahl von Datensätzen im Datenblatt oder Endlosformular. Die Einstellung dieser Eigenschaft definiert die Anzahl der markierten Zeilen im Auswahlrechteck bzw. die Anzahl der markierten Datensätze im Endlosformular oder gibt sie zurück.

  • Die Eigenschaft SelWidth. Ein Wert des Datentyps Long Integer zwischen 0 und der Anzahl von Spalten im Datenblatt. Die Einstellung dieser Eigenschaft definiert die Anzahl der markierten Spalten im Auswahlrechteck oder gibt sie zurück.

Diese Eigenschaften sind in der Entwurfsansicht nicht verfügbar. Sie stehen nur bei Verwendung eines Makros oder von Visual Basic zur Verfügung.

Anmerkung

Besteht keine Markierung, geben diese Eigenschaften den Wert 0 zurück. Wird eine dieser Eigenschaften auf 0 eingestellt, wird die Markierung aus dem Datenblatt oder Formular entfernt.

Wenn Sie (mit Hilfe der Datensatzmarkierer) einen oder mehrere Datensätze im Datenblatt markiert haben, können Sie die Einstellung der Eigenschaft SelWidth nicht ändern (Sie können sie jedoch auf 0 einstellen). Wenn Sie (über die Spaltenüberschriften) eine oder mehrere Spalten markiert haben, können Sie die Einstellung der Eigenschaft SelHeight nicht ändern (Sie können sie jedoch auf 0 einstellen).

Sie können diese Eigenschaften in Verbindung mit den Eigenschaften SelTop und SelLeft verwenden, um die aktuelle Position des Auswahlrechtecks im Datenblatt festzulegen oder zu bestimmen. Liegt keine Markierung vor, geben die Eigenschaften SelTop und SelLeft die Zeilen- und Spaltennummer der Zelle, die den Fokus besitzt, zurück.

Die Eigenschaften SelHeight und SelWidth enthalten die Position der rechten unteren Ecke des Auswahlrechtecks. Die Werte der Eigenschaften SelTop und SelLeft bestimmen die linke obere Ecke des Auswahlrechtecks.


 SelTop-, SelLeft-Eigenschaften

SelTop-, SelLeft-Eigenschaften

Mit Hilfe der Eigenschaft SelTop können Sie festlegen oder bestimmen, welche Zeile (welcher Datensatz) im aktuellen Auswahlrechteck des Datenblatts einer Tabelle, einer Abfrage oder eines Formulars ganz oben steht bzw. welcher markierte Datensatz in einem Endlosformular ganz oben steht. Mit Hilfe der Eigenschaft SelLeft können Sie festlegen oder bestimmen, welche Spalte (welches Feld) im aktuellen Auswahlrechteck ganz links steht. Wenn Sie z.B. in der Datenblattansicht der Tabelle Kunden eine Gruppe von Zeilen und Spalten markiert haben, können Sie über die Eigenschaften SelTop und SelLeft die erste Zeile und erste Spalte bestimmen, die im Auswahlrechteck markiert ist.

Einstellung

  • Die Eigenschaft SelTop. Ein Wert des Datentyps Long Integer zwischen 1 und der Anzahl von Datensätzen im Datenblatt oder Endlosformular. Die Einstellung dieser Eigenschaft definiert die Nummer der obersten Zeile im aktuellen Auswahlrechteck bzw. die Nummer des obersten markierten Datensatzes im Endlosformular oder gibt sie zurück.

  • Die Eigenschaft SelLeft. Ein Wert des Datentyps Long Integer zwischen 1 und der Anzahl von Spalten im Datenblatt. Die Einstellung dieser Eigenschaft definiert die Nummer der Spalte, die im aktuellen Auswahlrechteck ganz links angeordnet ist, oder gibt sie zurück.

Diese Eigenschaften sind in der Entwurfsansicht nicht verfügbar. Sie stehen nur bei Verwendung eines Makros oder von Visual Basic zur Verfügung.

Anmerkung

Liegt keine Markierung vor, geben diese Eigenschaften die Zeilen- und Spaltennummer der Zelle, die den Fokus besitzt, zurück.

Wenn Sie (mit Hilfe der Datensatzmarkierer) einen oder mehrere Datensätze im Datenblatt markiert haben, können Sie die Einstellung der Eigenschaft SelLeft nicht ändern. Wenn Sie (über die Spaltenüberschriften) eine oder mehrere Spalten markiert haben, können Sie die Einstellung der Eigenschaft SelTop nicht ändern.

Sie können diese Eigenschaften in Verbindung mit den Eigenschaften SelHeight und SelWidth verwenden, um die aktuelle Größe des Auswahlrechtecks festzulegen oder zu bestimmen. Die Eigenschaften SelTop und SelLeft bestimmen die Position der oberen linken Ecke des Auswahlrechtecks. Die Eigenschaften SelHeight und SelWidth legen die untere rechte Ecke des Auswahlrechtecks fest.


 SelLength-, SelStart-, SelText-Eigenschaften (AuswahlLänge, AuswahlBeginn, AuswahlText)

SelLength-, SelStart-, SelText-Eigenschaften (AuswahlLänge, AuswahlBeginn, AuswahlText)

Sie können diese Eigenschaften für Aufgaben wie z. B. das Positionieren der Einfügemarke, Herstellen eines Einfügebereichs, Auswählen von Teilzeichenfolgen in einem Textfeld- oder Kombinationsfeld-Steuerelement und Löschen von Text verwenden.

  • Die Eigenschaft SelLength gibt die Anzahl der markierten Zeichen in einem Textfeld oder im Textfeldbereich eines Kombinationsfelds an oder ermittelt diese.

  • Die Eigenschaft SelStart gibt den Startpunkt des markierten Textes oder, wenn kein Text ausgewählt ist, die Position der Einfügemarke an oder ermittelt diese.

  • Die Eigenschaft SelText gibt eine Zeichenfolge mit dem markierten Text zurück. Wurde kein Text markiert, enthält die Eigenschaft SelText den Wert Null.

Einstellung

  • Die Eigenschaften SelLength und SelStart verwenden einen Integer im Bereich von 0 bis zur Gesamtanzahl der Zeichen in einem Textfeld oder im Textfeldbereich eines Kombinationsfelds.

  • Die Eigenschaft SelText verwendet einen Zeichenfolgenausdruck, der den im Steuerelement markierten Text enthält. Wenn das Steuerelement markierten Text enthält und diese Eigenschaft eingestellt ist, wird der markierte Text durch die neue Einstellung von SelText ersetzt.

Sie können die Eigenschaften SelLength und SelStart nur mit einem Makro oder in Visual Basic einstellen. Die Eigenschaft SelText ist schreibgeschützt.

Anmerkung

Sie können diese Eigenschaften für ein Steuerelement nur einstellen oder zurückgeben, wenn das Steuerelement über den Fokus verfügt. Um den Fokus auf ein Steuerelement zu setzen, können Sie die Methode SetFocus verwenden.

Das Einstellen der Eigenschaft SelLength auf eine negative Zahl löst einen Laufzeitfehler aus.

Das Einstellen der Eigenschaft SelStart auf eine Zahl, die größer als die Anzahl der Zeichen im Steuerelement ist, stellt die Eigenschaft auf die bestehende Textlänge ein.

Das Ändern der Eigenschaft SelStart bricht die Auswahl ab, setzt eine Einfügemarke in den Text und stellt die Eigenschaft SelLength auf 0 ein.


 ServerFilter-Eigenschaft

ServerFilter-Eigenschaft

Mit der ServerFilter-Eigenschaft können Sie eine Untermenge an Datensätzen definieren, die angezeigt werden soll, wenn ein Serverfilter auf ein Formular oder einen Bericht innerhalb eines Microsoft Access-Projekts (.adp) oder einer Datenzugriffsseite in einem Microsoft Access-Projekt (.adp) oder in einer Microsoft Access-Datenbank (.mdb) angewendet wird.

Einstellung

Die ServerFilter-Eigenschaft ist ein Zeichenfolgenausdruck, der aus einer WHERE-Klausel ohne das WHERE-Schlüsselwort besteht. Beispielsweise definiert der folgende Visual Basic-Code einen Filter, durch den nur Kunden in den USA angezeigt werden, und wendet ihn an:

Me.ServerFilter = "Land = 'USA'"
Me.ServerFilterByForm = True

Die einfachste Methode zur Einstellung dieser Eigenschaft ist die Verwendung des Eigenschaftenfensters eines Formulars oder Berichts. Für ein Formular oder einen Bericht können Sie diese Eigenschaft auch mit Visual Basic festlegen.

Zur Einstellung der ServerFilter-Eigenschaft müssen Sie zunächst einen der folgende Schritte durchführen:

  • Legen Sie den Wert der Eigenschaft im Eigenschaftenfenster des Formulars fest.

  • Legen Sie die Eigenschaft in Visual Basic fest, indem Sie folgendes tippen:
    Forms(0).ServerFilter = "Feldname = Wert"

Anmerkung Die Einstellung der ServerFilter-Eigenschaft hat keine Auswirkungen auf die ADO-Eigenschaft Filter.

Anmerkungen

Mit der ServerFilter-Eigenschaft können Sie auch einen Filter speichern, um ihn zu einem späteren Zeitpunkt anzuwenden. Filter werden zusammen mit den Objekten gespeichert, in denen sie erstellt wurden. Sie werden automatisch geladen, wenn das Objekt geöffnet wird, werden jedoch nicht automatisch angewendet.

Um einen gespeicherten Filter auf ein Formular anzuwenden, klicken Sie entweder in der Symbolleiste auf Serverfilter anwenden [image] , im Menü Datensätze auf Filter/Sortierung, oder setzen Sie die ServerFilterByForm-Eigenschaft mit Hilfe eines Makros oder Visual Basic auf True (-1).

Die Schaltfläche Serverfilter anwenden zeigt den Status der ServerFilter- und ServerFilterByForm-Eigenschaften an. Die Schaltfläche ist solange deaktiviert, bis ein Filter vorhanden ist, der angewendet werden kann. Wenn momentan ein vorhandener Filter angewendet wird, wird die Schaltfläche Serverfilter anwenden in gedrücktem Zustand dargestellt.

Um einen Filter automatisch beim Öffnen eines Formulars anzuwenden, definieren Sie in der Einstellung der OnOpen-Ereigniseigenschaft eines Formulars entweder ein Makro, das die AnwendenFilter-Aktion verwendet, oder eine Ereignisprozedur, die die ApplyFilter-Methode des DoCmd-Objekts anwendet. In beiden Fällen wird das Formular im Fenster Formularbasierter Serverfilter geöffnet.

Einen Serverfilter können Sie nur entfernen, indem Sie mit Hilfe von Visual Basic die ServerFilterByForm-Eigenschaft auf False (0) festlegen oder sämtliche Filterkriterien im Fenster Formularbasierter Serverfilter löschen und dann auf Serverfilter anwenden klicken.

Wenn die ServerFilter-Eigenschaft in der Formular-Entwurfsansicht festgelegt wird, versucht Microsoft Access nicht, den SQL-Ausdruck zu überprüfen. Falls der SQL-Ausdruck ungültig ist, tritt beim Anwenden des Filters ein Fehler auf.

Anmerkungen

  • Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die RecordSource-, Filter-, ServerFilter-, OrderBy- und OrderByOn-Eigenschaften.

  • Die Einstellung der ServerFilter-Eigenschaft wird ignoriert, wenn die Datenherkunft des Formulars eine Gespeicherte Prozedur ist.


 ServerFilterByForm-Eigenschaft (FormularbasierterServerFilter)

ServerFilterByForm-Eigenschaft (FormularbasierterServerFilter)

Mit der ServerFilterByForm-Eigenschaft können Sie angeben oder ermitteln, ob ein Formular im Fenster Formularbasierter Serverfilter geöffnet wird.

Einstellung

Die ServerFilterByForm-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Formular wird im Fenster Formularbasierter Serverfilter geöffnet.
 |  | Anmerkung Wenn die ServerFilterByForm-Eigenschaft True anzeigt, ist die Funktion Formularbasierter Filter deaktiviert.
Nein | False (0) | (Standardeinstellung) Das Formular wird nicht im Fenster Formularbasierter Serverfilter geöffnet.

Die einfachste Methode zur Einstellung der ServerFilterByForm-Eigenschaft ist die Verwendung des Eigenschaftenfensters eines Formulars. Sie können diese Eigenschaft auch mit Visual Basic einstellen.

Zur Einstellung der ServerFilterByForm-Eigenschaft müssen Sie zunächst einen der folgende Schritte durchführen:

  • Legen Sie den Wert der Eigenschaft im Eigenschaftenfenster des Formulars fest.

  • Legen Sie die Eigenschaft in Visual Basic fest, indem Sie folgendes tippen:
    Forms(0).ServerFilterByForm = True

Wenn die ServerFilter-Eigenschaft einmal eingestellt wurde, können Sie diese Eigenschaft auch einstellen, indem Sie in der Symbolleiste Formularansicht oder der Symbolleiste Filter/Sortieren auf Serverfilter anwenden [image] klicken.

Anmerkungen

Um einen gespeicherten Filter auf ein Formular anzuwenden, klicken Sie auf die Schaltfläche Serverfilter anwenden, oder setzen Sie mit Hilfe eines Makros oder Visual Basic die ServerFilterByForm-Eigenschaft auf True (-1).

Die Schaltfläche Serverfilter anwenden zeigt den Status der ServerFilter- und ServerFilterByForm-Eigenschaften an. Die Schaltfläche ist solange deaktiviert, bis ein Filter vorhanden ist, der angewendet werden kann. Wird momentan ein vorhandener Filter angewendet, wird die Schaltfläche in gedrücktem Zustand dargestellt. Wenn ein Filter beim Öffnen eines Formulars automatisch angewendet werden soll, geben Sie in der OnOpen-Ereigniseigenschaft des Formulars entweder ein Makro an, das die AnwendenFilter-Aktion verwendet, oder eine Ereignisprozedur, die die ApplyFilter-Methode des DoCmd-Objekts verwendet.

Filter können entfernt werden, indem Sie mit Hilfe von Visual Basic die ServerFilterByForm-Eigenschaft auf False (0) setzen oder sämtliche Filterkriterien im Fenster Formularbasierter Serverfilter löschen und dann auf Serverfilter anwenden klicken.

Anmerkungen

  • Wenn ein neues Objekt erstellt wird, erbt es von der Tabelle oder Abfrage, auf deren Basis es erstellt wurde, die RecordSource-, Filter-, ServerFilter-, OrderBy- und OrderByOn-Eigenschaften. Bei Formularen und Berichten werden vererbte Filter beim Öffnen eines Objekts nicht automatisch angewendet.

  • Die Einstellung der ServerFilterByForm-Eigenschaft wird ignoriert, wenn die Datenherkunft des Formulars eine gespeicherte Prozedur ist.


 ShortcutMenu-Eigenschaft (Kontextmenü)

ShortcutMenu-Eigenschaft (Kontextmenü)

Mit der Eigenschaft ShortcutMenu können Sie angeben, ob ein Kontextmenü angezeigt wird, wenn Sie mit der rechten Maustaste auf ein Objekt eines Formulars klicken. Sie können z. B. die Anzeige eines Kontextmenüs deaktivieren, um den Benutzer daran zu hindern, Daten in der dem Formular zugrunde liegenden Datenherkunft zu ändern, indem er einen der Filterbefehle aus dem Kontextmenü des Formulars verwendet.

Einstellung

Die Eigenschaft ShortcutMenu kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Kontextmenüs werden angezeigt.
Nein | False (0) | Kontextmenüs werden nicht angezeigt.

Sie können diese Eigenschaft im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Diese Eigenschaft steuert die Anzeige der Kontextmenüs eines Formulars sowie der Kontextmenüs aller Steuerelemente des Formulars. Wenn die Eigenschaft ShortcutMenu auf Nein eingestellt ist, werden keine Kontextmenüs angezeigt, wenn Sie mit der rechten Maustaste auf ein Formular oder eines seiner Steuerelemente klicken.

Wenn Sie einen Assistenten entwickeln, blenden Sie ggf. die Kontextmenüs in Ihren Assistentenformularen aus, um die Benutzer an der Anzeige oder Verwendung zu hindern. Dies trifft besonders auf Formulare zu, die Auswahlmöglichkeiten anbieten. Die Eigenschaft ShortcutMenu ist z. B. für das Formular Start in der Beispieldatenbank Nordwind auf Nein eingestellt. Dies hindert die Benutzer daran, Kontextmenüs für das Formular oder die Steuerelemente des Formulars anzuzeigen.


 ShortcutMenuBar-Eigenschaft (Kontextmenüleiste)

ShortcutMenuBar-Eigenschaft (Kontextmenüleiste)

Mit der Eigenschaft ShortcutMenuBar können Sie das Kontextmenü angeben, das angezeigt wird, wenn Sie mit der rechten Maustaste auf ein Formular, einen Bericht oder ein Steuerelement eines Formulars klicken. Wenn Sie ein Kontextmenü erstellen möchten, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken auf Anpassen. Weitere Informationen über das Erstellen benutzerdefinierter Symbolleisten finden Sie unter Erstellen eines benutzerdefinierten Kontextmenüs für die aktuelle Datenbank.

Anmerkung Die Eigenschaft ShortcutMenuBar betrifft nur Steuerelemente eines Formulars, keine Steuerelemente eines Berichts.

Mit der Eigenschaft ShortcutMenuBar können Sie auch ein Menüleistenmakro angeben, mit dem ein Kontextmenü für ein Datenblatt, ein Formular, ein Steuerelement eines Formulars oder einen Bericht angezeigt wird.

Anmerkung In früheren Versionen von Microsoft Access haben Sie ein benutzerdefiniertes Kontextmenü erstellt, indem Sie die Eigenschaft ShortcutMenuBar auf den Namen eines Menüleistenmakros eingestellt und anschließend eine Makrogruppe erstellt haben, die die Befehle des Kontextmenüs enthält. Diese Implementierung eines Kontextmenüs wird auch von Microsoft Access 2000 unterstützt. Es wird jedoch dringend empfohlen, dass Sie benutzerdefinierte Kontextmenüs mit Hilfe des Dialogfelds Anpassen erstellen. Dieses Dialogfeld wird angezeigt, wenn Sie im Menü Ansicht auf Symbolleisten zeigen und dann auf Anpassen klicken.

Einstellung

Geben Sie den Namen des Kontextmenüs ein, das angezeigt werden soll. Als Kontextmenü kann jede Befehlsleiste dienen, deren Eigenschaft Type auf Popup eingestellt ist. Wenn Sie der Eigenschaft ShortcutMenuBar keinen Wert zuweisen, zeigt Microsoft Access entweder das jeweilige eingebaute Standardkontextmenü oder das globale Kontextmenü der Anwendung an. Wenn Sie die Eigenschaft ShortcutMenuBar auf einen Wert einstellen, der nicht den Namen eines vorhandenen Kontextmenüs oder Menüleistenmakros angibt, hat das Formular, das Steuerelement des Formulars oder der Bericht kein Kontextmenü (das Standardkontextmenü wird nicht angezeigt).

Sie können diese Eigenschaft im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft mit einem Zeichenfolgenausdruck ein, der gleich dem Namen des Kontextmenüs ist, das angezeigt werden soll.

Soll das eingebaute Kontextmenü für eine Datenbank, ein Formular, ein Steuerelement eines Formulars oder einen Bericht mit Hilfe eines Makros oder in Visual Basic angezeigt werden, stellen Sie die Eigenschaft auf eine leere Zeichenfolge (" ") ein.

Anmerkung

Sie erstellen ein benutzerdefiniertes Kontextmenü, indem Sie zunächst eine Symbolleiste erstellen, die alle Befehle enthält, die zu Ihrem benutzerdefinierten Kontextmenü gehören sollen. Anschließend öffnen Sie das Dialogfeld Symbolleisteneigenschaften, indem Sie die Symbolleiste im Dialogfeld Anpassen aktivieren und dann auf die Schaltfläche Eigenschaften klicken. Im Dialogfeld Symbolleisteneigenschaften stellen Sie die Eigenschaft Type auf Popup ein. Danach steht diese Symbolleiste im Eigenschaftenfenster eines Formulars, eines Steuerelements eines Formulars oder eines Berichts im Einstellungsfeld der Eigenschaft ShortcutMenuBar zur Verfügung.

Wenn Sie die Eigenschaft ShortcutMenuBar mit dem Objekt Application verwenden, können Sie ein benutzerdefiniertes Kontextmenü als globales Kontextmenü anzeigen. Wenn Sie die Eigenschaft ShortcutMenuBar eines Formulars, eines Steuerelements eines Formulars oder eines Berichts der Datenbank eingestellt haben, wird an Stelle des globalen Kontextmenüs der Datenbank das benutzerdefinierte Kontextmenü dieses Objekt angezeigt. Wenn Sie für ein bestimmtes Formular, Steuerelement eines Formulars oder einen bestimmten Bericht ein anderes benutzerdefiniertes Kontextmenü anzeigen möchten, stellen Sie dessen Eigenschaft ShortcutMenuBar auf das gewünschte Kontextmenü ein. Wenn das Formular, das Steuerelement des Formulars oder der Bericht den Fokus hat, wird das benutzerdefinierte Kontextmenü dieses Objekts angezeigt, sobald der Benutzer mit der rechten Maustaste geklickt hat. Andernfalls wird das globale Kontextmenü der Datenbank angezeigt.

Kontextmenüs stehen für kein Objekt zur Verfügung, wenn die Eigenschaft AllowShortcutMenus auf False (0) eingestellt ist.


 ShowNavigationButtons-Eigenschaft

ShowNavigationButtons-Eigenschaft

Mit der ShowNavigationButtons-Eigenschaft können Sie angeben oder ermitteln, ob Navigationsschaltflächen im Snapshot Viewer-Steuerelement verfügbar sind.

Einstellung

Die ShowNavigationButtons-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Navigationsschaltflächen des Steuerelements werden angezeigt.
Nein | False (0) | Die Navigationsschaltflächen des Steuerelements werden nicht angezeigt.

Sie können die ShowNavigationButtons-Eigenschaft über das Eigenschaftenfenster des Steuerelements oder in Visual Basic einstellen.

Anmerkung

Wenn diese Eigenschaft auf "Nein" gesetzt ist, ist die einzige Möglichkeit zur Navigation zwischen Seiten in einem Snapshot die Verwendung des Popup-Menüs des Steuerelements oder die Festlegung der CurrentPage-Eigenschaft in Visual Basic für Applikationen.


 SizeMode-Eigenschaft (Größenanpassung)

SizeMode-Eigenschaft (Größenanpassung)

Sie können die Eigenschaft SizeMode verwenden, um anzugeben, wie die Größe eines Bildes oder eines anderen Objekts in einem gebundenen Objektfeld, einem Objektfeld oder einem Bild-Steuerelement angepasst wird.

Einstellung

Die Eigenschaft SizeMode verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Abschneiden | acOLESizeClip (0) | (Standardeinstellung) Zeigt das Objekt in der tatsächlichen Größe an. Wenn das Objekt größer ist als das Steuerelement, wird sein Bild an den Rändern des Steuerelements abgeschnitten.
Dehnen | acOLESizeStretch (1) | Passt die Größe des Objekts so an, dass das Steuerelement ganz ausgefüllt ist. Diese Einstellung kann die Proportionen des Objekts verzerren.
Zoomen | acOLESizeZoom (3) | Zeigt das Objekt vollständig an, nachdem dessen Größe so angepasst wurde, dass es entweder in der Höhe oder in der Breite den Rahmen des Diagramms oder Objekts genau ausfüllt, ohne die Proportionen des Objekts zu verzerren. Diese Einstellung kann zusätzlichen Platz im Steuerelement hinterlassen, falls das Steuerelement angepasst wird.

Die Eigenschaft SizeMode können Sie in einem Eigenschaftenfenster, in einem Makro oder mit Visual Basic einstellen. Die Standardeinstellung dieser Eigenschaft können Sie in den Standardeigenschafteneinstellungen eines Steuerelements oder mit Hilfe der Methode DefaultControl in Visual Basic festlegen.

Tipp Verwenden Sie die Einstellung Abschneiden, um das Objekt am schnellsten anzuzeigen. Sie können die Einstellung Dehnen für Balken- und Liniendiagramme verwenden, bei denen die Größenanpassung nicht beachtet werden muss. Dagegen können Kreise und Abbildungen von Fotos durch diese Einstellung verzerrt werden.


 SnapshotPath-Eigenschaft

SnapshotPath-Eigenschaft

Mit der SnapshotPath-Eigenschaft können Sie den Pfad zur Snapshot-Datei angeben oder ermitteln, die im Snapshot Viewer-Steuerelement angezeigt werden soll.

Einstellung

Die SnapshotPath-Eigenschaft ist ein String-Wert, der den vollständig qualifizierten Pfad und Dateinamen der Snapshot-Datei enthält, die im Steuerelement angezeigt werden soll. Die Eigenschaft kann auf den Namen einer Snapshot-Datei auf einem lokalen Computer, einer Datei auf einem Netzwerk oder einer Datei in einer HTTP- oder FTP-Adresse gesetzt werden.

Sie können die SnapshotPath-Eigenschaft mit dem Eigenschaftenfenster des Steuerelements oder in Visual Basic einstellen.

Anmerkung

Wenn Sie die SnapshotPath-Eigenschaft auf eine Zeichenfolge der Länge Null oder den Namen einer nicht vorhandenen Datei setzen, wird im Steuerelement nichts angezeigt. Wenn Sie diese Eigenschaft auf den Namen einer Datei setzen, die keine Snapshot-Datei ist, wird ein Snapshot-Dateisymbol mit einem roten "X" im Steuerelement angezeigt.

Da das Steuerelement HTTP- und FTP-Adressen unterstützt, kann das Steuerelement unter Umständen nicht ermitteln, ob die SnapshotPath-Eigenschaft zum Zeitpunkt der Einrichtung gültig ist. Mit der ReadyState-Eigenschaft können Sie ermitteln, ob eine gültige Snapshot-Datei in das Steuerelement geladen wurde.


 SortOrder-Eigenschaft (Sortierreihenfolge)

SortOrder-Eigenschaft (Sortierreihenfolge)

Sie können die Eigenschaft SortOrder zur Einstellung der Sortierreihenfolge für Felder und Ausdrücke in einem Bericht verwenden. Wenn Sie beispielsweise eine Lieferantenliste drucken, können Sie die Datensätze alphabetisch nach dem Firmennamen sortieren.

Einstellung

Die Eigenschaft SortOrder verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Aufsteigend | False (0) | (Standardeinstellung) Die Werte werden in aufsteigender Reihenfolge (A-Z, 0-9) sortiert.
Absteigend | True (-1) | Die Werte werden in absteigender Reihenfolge (Z-A, 9-0) sortiert.

Sie können die Eigenschaft SortOrder im Dialogfeld Sortieren und gruppieren eines Berichts, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie die Eigenschaft SortOrder in der Berichtsentwurfsansicht oder in der Ereignisprozedur Open eines Berichts unter Verwendung der Eigenschaft GroupLevel ein.


 Source-Eigenschaft (Quelle)

Source-Eigenschaft (Quelle)

Sie können die Eigenschaft Source verwenden, um die Verbindungszeichenfolge für die Datenherkunft und Quelldatenbank für die Eingabetabelle oder -abfrage einer Abfrage anzugeben. Dies ist erforderlich, wenn Sie auf Daten in einer externen Tabelle zugreifen möchten, ohne die Tabelle zu verknüpfen.

Anmerkung Das Verwenden der Eigenschaft Source und der Eigenschaft SourceConnectStr für den Zugriff auf ODBC-Tabellen ist erheblich langsamer als die Verwendung verknüpfter Tabellen.

Einstellung

Sie stellen die Eigenschaft Source mit Hilfe eines Zeichenfolgenausdrucks ein. Sie können diese Eigenschaft nicht direkt im Code einstellen. Sie wird eingestellt, sobald Sie eine neue Abfrage mit Hilfe einer SQL-Anweisung erstellen. Die FROM-Klausel in der SQL-Anweisung entspricht der Einstellung der Eigenschaft Source.

Die folgenden Beispiele zeigen, wie Sie die Eigenschaft Source verwenden können, um zu verschiedenen Typen externer Datenbanken zu verbinden.

Datenbanktyp | Angabe | Beispieleinstellung
Microsoft Access | Pfad und Datenbankname. Microsoft Access fügt die Dateinamenerweiterung automatisch hinzu. | C:\Konten\Kunden
dBASE | Datenbanktyp und Pfad. Eine Liste der Kennzeichner finden Sie in der Beschreibung der ADO-Eigenschaft Connect. | dBASE IV;DatabaseTable=C:\DBDATA
SQL Server (ODBC) Name der Herkunfts-
datenbank und alle zusätzlich vom Produkt benötigten Informationen, z.B. Anmeldeidentifikation (ID) und Kennwort. Sie können auch den ODBC-Verbindungszeichenfolgen-Generator zur Erstellung der Verbindungszeichenfolge verwenden. 		ODBC;DSN=powernet;UID=andyk;
PWD=kennwort;
DATABASE=umsatz;

Sie können diese Eigenschaft im Feldlisten-Eigenschaftenfenster einer Abfrage einstellen.

Sie können diese Eigenschaft auch in der SQL-Ansicht des Abfragefensters mit Hilfe der FROM- und IN-Klauseln in der SQL-Anweisung einstellen.

Anmerkung

Wenn alle Eingabetabellen in einer Abfrage aus derselben externen Datenbank stammen, verwenden Sie die Eigenschaften SourceConnectStr und SourceDatabase der Abfrage, anstatt die Eigenschaft Source für jede Eingabetabelle oder -abfrage einzeln einzustellen.


 SourceConnectStr-, SourceDatabase-Eigenschaften (Herkunftsverbindung, Herkunftsdatenbank)

SourceConnectStr-, SourceDatabase-Eigenschaften (Herkunftsverbindung, Herkunftsdatenbank)

Sie können diese Eigenschaften verwenden, um auf externe Daten zuzugreifen, wenn Sie die externen Tabellen nicht mit Ihrer Datenbank verknüpfen können.

  • SourceConnectStr — Mit dieser Eigenschaft können Sie den Namen der Anwendung angeben, die zur Erstellung einer externen Datenbank verwendet werden soll.

  • SourceDatabase — Mit dieser Eigenschaft können Sie die externe Datenbank angeben, in der sich die Eingabetabellen oder -Abfragen für eine Abfrage befinden.

Anmerkung Die Eigenschaften SourceConnectStr und SourceDatabase gelten für alle Abfragen, mit Ausnahme von Datendefinition, Pass-Through- und Union-Abfragen.

Einstellung

Sie verwenden einen Zeichenfolgenausdruck, um den Wert der Eigenschaften SourceConnectStr und SourceDatabase einzustellen.

Sie können diese Eigenschaften im Abfrage-Eigenschaftenfenster oder in der SQL-Ansicht des Abfragefensters einstellen. In der SQL-Anweisung entsprechen die Eigenschaften der IN-Klausel.

Anmerkung Wenn Sie auf mehrere Datenbankquellen zugreifen möchten, verwenden Sie die Eigenschaft Source statt der Eigenschaften SourceConnectStr und SourceDatabase.

Anmerkung

Sie müssen die Eigenschaften SourceConnectStr und SourceDatabase verwenden, um auf Tabellen in externen Datenbanken zuzugreifen, welche in Anwendungen erstellt wurden, in denen keine verknüpften Tabellen verwendet werden.

Es folgen Beispiele für diese Eigenschaftseinstellungen:

  • Bei einer Microsoft Access-Datenbank entspricht die Einstellung der Eigenschaft SourceDatabase dem Pfad und Datenbanknamen (z.B. C:\KONTEN\KUNDEN). Microsoft Access fügt die Dateinamenerweiterung automatisch hinzu. Die Eigenschaft SourceConnectStr verfügt über keinen Wert für eine Microsoft Access-Datenbank.

  • Bei einer von einem Produkt wie Paradox erstellten Datenbank entspricht die Einstellung der Eigenschaft SourceDatabase dem Pfad (z.B. C:\PARADOX\DATEN). Die Einstellung der Eigenschaft SourceConnectStr entspricht dem Kennzeichner des Datenbanktyps (z.B. Paradox 3.x;). Eine Liste der Kennzeichner finden Sie unter der Beschreibung der ADO-Eigenschaft Connect.

  • Das folgende Beispiel verwendet dBASE IV-Tabellen im Verzeichnis C:\DBDATEN als Datenquelle für die Abfrage.
    SELECT Kunde.FIRMENNAME, Aufträge.AUFTRAGSNR, Aufträge.AUFTRDATUM
FROM Kunde INNER JOIN Aufträge
ON Kunde.KUNDENNR = Aufträge.KUNDENNR
IN 'C:\Dbdata'[dBASE IV;];

  • Bei einer ODBC-Datenbank (ODBC = Open Database Connectivity) entspricht die Einstellung der Eigenschaft SourceConnectStr dem Namen der Quelldatenbank zusammen mit weiteren vom Produkt benötigten Informationen, z.B. Anmeldeinformationen (ID) und Kennwort. Bei einer Datenbank des Microsoft SQL Server könnte die Einstellung z.B. folgendermaßen aussehen:
    ODBC;DSN=Locatech;UID=jace;PWD=Kennwort;DATABASE=Umsatz;

Die Eigenschaft SourceDatabase verfügt über keinen Wert für eine ODBC-Datenbank.

Weitere Informationen über den Zugriff auf Daten in ODBC-Datenbanken finden Sie in Kapitel 15, "Empfangen und Analysieren von Daten" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Klicken Sie hierauf [image] , um weitere Informationen über den Bezug des Microsoft Office 2000/Visual Basic Programmierhandbuchs zu erhalten.


 SourceDoc-Eigenschaft (Herkunftsdokument)

SourceDoc-Eigenschaft (Herkunftsdokument)

Mit der Eigenschaft SourceDoc können Sie die Datei angeben, zu der eine Verknüpfung hergestellt oder die eingebettet werden soll, wenn Sie in Visual Basic mit der Eigenschaft Action ein verknüpftes oder eingebettetes Objekt erstellen.

Einstellung

Geben Sie für ein eingebettetes Objekt den vollständigen Pfad und den Namen der Datei an, die Sie als Vorlage verwenden möchten, und stellen Sie die Eigenschaft Action auf acOLECreateEmbed ein.

Geben Sie für ein verknüpftes Objekt den vollständigen Pfad und den Namen der Datei an, zu der eine Verknüpfung hergestellt werden soll, und stellen Sie die Eigenschaft Action auf acOLECreateLink ein.

Sie können diese Eigenschaft in einem Eigenschaftenfenster, in einem Makro oder mit Visual Basic einstellen.

Anmerkung Obwohl diese Eigenschaft im Eigenschaftenfenster erscheint, wird sie erst wirksam, nachdem die Eigenschaft Action in einem Makro oder mit Visual Basic eingestellt wurde.

Anmerkung

Verwenden Sie die Eigenschaft SourceDoc, um die Datei anzugeben, zu der eine Verknüpfung hergestellt werden soll, und die Steuerelementeigenschaft SourceItem, um die aus der Datei gewünschten Daten anzugeben. Wenn Sie eine Verknüpfung zu dem gesamten Objekt herstellen möchten, dürfen Sie keinen Wert für die Eigenschaft SourceItem angeben.

Bei der Erstellung eines verknüpften ungebundenen Objekts wird die Einstellung der Eigenschaft SourceItem des Steuerelements mit der Einstellung seiner Eigenschaft SourceDoc verkettet. In der Formularansicht, der Datenblattansicht und der Seitenansicht besteht die Einstellung der Eigenschaft SourceItem des Steuerelements aus einer leeren Zeichenfolge (" ") und die Einstellung seiner Eigenschaft SourceDoc aus dem vollständigen Pfad zu der verknüpften Datei, gefolgt von einem Ausrufezeichen (!) oder einem umgekehrten Schrägstrich (\) und der Einstellung der Eigenschaft SourceItem, wie im folgenden Beispiel gezeigt:

"C:\Arbeit\Quart1\Umsatz.xls!R1C1:R30C15"


 SourceItem-Eigenschaft (Herkunftselement)

SourceItem-Eigenschaft (Herkunftselement)

Mit der Eigenschaft SourceItem können Sie die aus einer Datei stammenden Daten angeben, die verknüpft werden sollen, wenn Sie ein verknüpftes OLE-Objekt erstellen.

Einstellung

Sie stellen die Eigenschaft SourceItem ein, indem Sie Daten in solchen Einheiten angeben, die von der Anwendung ausgewertet werden können, von der das Objekt bereitgestellt wird. Wenn Sie z. B. mit Microsoft Excel verknüpfen, geben Sie als Einstellung der Eigenschaft SourceItem einen Verweis auf eine Zelle oder einen Zellbereich (z. B. Z1S1 oder Z3S4:Z9S22) bzw. einen benannten Bereich an (z. B. Erträge).

Anmerkung Informationen zur Syntax, die zu verwenden ist, um eine Dateneinheit eines bestimmten Objekts zu beschreiben, finden Sie in der Dokumentation der Anwendung, mit der das Objekt erstellt wurde.

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft mit einem Zeichenfolgenausdruck ein.

Anmerkung

Damit Sie diese Eigenschaft verwenden können, muss die Eigenschaft OLETypeAllowed auf Verknüpft oder Beides eingestellt sein. Verwenden Sie die Eigenschaft SourceDoc des Steuerelements, um die Datei anzugeben, mit der verknüpft werden soll.


 SourceObject-Eigenschaft (Herkunftsobjekt)

SourceObject-Eigenschaft (Herkunftsobjekt)

Sie können die Eigenschaft SourceObject zur Bezeichnung des Formulars oder des Berichts verwenden, das oder der die Herkunft des Unterformulars oder des Unterberichts eines Formulars oder eines Berichts darstellt. Sie können diese Eigenschaft auch für verknüpfte Objektfelder verwenden, um den vollständigen Pfad und Namen der Datei anzugeben, die die mit dem Objektfeld verknüpften Daten enthält.

Einstellung

Geben Sie im Eigenschaftenfenster des Steuerelements den Namen des Formulars oder des Berichts an, das oder der die Herkunft des Unterformulars oder des Unterberichts darstellt. Wenn Sie ein Unterformular bzw. einen Unterbericht durch Ziehen aus dem Datenbankfenster in ein Formular bzw. einen Bericht einfügen, wird die Eigenschaft SourceObject im Eigenschaftenfenster automatisch eingestellt.

Bei Objektfeldern wird die Eigenschaft SourceObject automatisch eingestellt, wenn Sie den Befehl Objekt aus dem Menü Einfügen zum Einfügen eines verknüpften OLE-Objekts verwenden.

Bei einem Unterformular oder einem Unterbericht können Sie diese Eigenschaft im Eigenschaftenfenster des Steuerelements mit einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft über einen Zeichenfolgenausdruck ein, der den Namen eines Formulars oder eines Berichts darstellt.

Für verknüpfte Objektfelder kann die Eigenschaft SourceObject in keiner Ansicht eingestellt werden.

Anmerkung Sie können die Eigenschaft SourceObject nicht in den Ereignissen Open oder Format eines Berichts verändern oder einstellen.

Anmerkung

Wenn Sie die Einstellung für die Eigenschaft SourceObject im Eigenschaftenfenster eines Unterformulars bzw. Unterberichts löschen, verbleibt das Steuerelement zwar auf dem Formular, ist aber nicht mehr an das Herkunftsformular oder den Herkunftsbericht gebunden.


 SpecialEffect-Eigenschaft (Spezialeffekt)

SpecialEffect-Eigenschaft (Spezialeffekt)

Mit der Eigenschaft SpecialEffect können Sie angeben, ob einem Bereich oder Steuerelement eine besondere Formatierung zugewiesen wird.

Einstellung

Die Eigenschaft SpecialEffect verwendet die folgenden Einstellungen.

Einstellung | Beispiel | Visual Basic | Beschreibung
Flach |  | 0 | Das Objekt wird flach und in den Standardfarben des Systems oder in benutzerdefinierten Farben angezeigt, die in der Entwurfsansicht eingestellt wurden.
Erhöht |  | 1 | Das Objekt ist oben und links hervorgehoben und hat unten und rechts einen Schatten.
Vertieft |  | 2 | Das Objekt hat oben und links einen Schatten und ist unten und rechts hervorgehoben.
Graviert |  | 3 | Das Objekt hat eine vertiefte Linie um das Steuerelement.
Schattiert |  | 4 | Das Objekt hat einen Schatten unterhalb und rechts des Steuerelements.
Unterstrichen |  | 5 | Das Objekt hat eine vertiefte Linie unterhalb des Steuerelements.

Sie können diese Eigenschaft mit der Schaltfläche Spezialeffekt in der Symbolleiste Formatierung (Formular/Bericht), im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

Bei Steuerelementen können Sie die Standardeinstellung für diese Eigenschaft mit Hilfe der Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen.

Anmerkung

Die Einstellung der Eigenschaft SpecialEffect hat Auswirkungen auf die Einstellungen der verwandten Eigenschaften BorderStyle, BorderColor und BorderWidth. Ist z. B. die Eigenschaft SpecialEffect auf Erhöht eingestellt, werden die Einstellungen der Eigenschaften BorderStyle, BorderColor und BorderWidth ignoriert. Ebenso kann das Ändern oder Einstellen der Eigenschaften BorderStyle, BorderColor und BorderWidth bewirken, dass Microsoft Access die Einstellung der Eigenschaft SpecialEffect auf Flach ändert.

Anmerkung Wenn Sie die Eigenschaft SpecialEffect eines Textfelds auf Schattiert einstellen, verringert sich die Höhe des Textanzeigebereichs. Sie können die Eigenschaft Height des Textfelds ändern, um den Textanzeigebereich wieder zu vergrößern.


 StartupForm-Eigenschaft

StartupForm-Eigenschaft

Mit Hilfe der Eigenschaft StartupForm können Sie den Namen des Formulars festlegen, das beim ersten Öffnen Ihrer Datenbank geöffnet wird. Über diese Eigenschaft können Sie z.B. ein angegebenes Formular anzeigen, das ein Menü mit allen Formularen, Abfragen und Berichten enthält, die beim Öffnen der Datenbank innerhalb einer Microsoft Access-Anwendung verfügbar sind.

Einstellung

Die Eigenschaft StartupForm ist ein Zeichenfolgenausdruck, der dem Namen eines Formulars in der aktuellen Datenbank entspricht.

Am einfachsten stellen Sie diese Eigenschaft über die Option Formular anzeigen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die Eigenschaft StartupForm mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein, oder Sie erstellen die Eigenschaft auf folgende Weise:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe der CreateProperty-Methode hinzufügen und an die Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp), können Sie die Eigenschaft mit Hilfe der Add-Methode der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Anmerkung

Die Eigenschaft StartupForm ist der Aktion ÖffnenFormular im Makro AutoExec vorzuziehen. Da Microsoft Access das Makro AutoExec ausführt, nachdem die Starteigenschaften analysiert wurden, ist es empfehlenswert, dass Ihre Anwendung keine Aktion ÖffnenFormular in ihrem Makro AutoExec verwendet, wenn die Eigenschaft StartupForm eingestellt ist.

Ist diese Eigenschaft leer, wird die Standard-Datenbankeneinstellung von Microsoft Access verwendet (das Datenbankfenster wird geöffnet).

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 StartupMenuBar-Eigenschaft

StartupMenuBar-Eigenschaft

Mit Hilfe der Eigenschaft StartupMenuBar können Sie eine benutzerdefinierte Menüleiste festlegen, die als globale Menüleiste für Ihre Anwendung verwendet werden soll. Mit Hilfe der Eigenschaft StartupMenuBar können Sie z.B. eine benutzerdefinierte Menüleiste anzeigen, die kein Menü Zugriffsrechte enthält. Dadurch können die Benutzer auf die Befehle des Menüs Zugriffsrechte nicht über die Menüleiste zugreifen. Sie können auch ein Menüleistenmakro festlegen, das die benutzerdefinierte Menüleiste anzeigt, die Sie als globale Menüleiste verwenden möchten.

Einstellung

Die Eigenschaft StartupMenuBar ist ein Zeichenfolgenausdruck, der dem Namen einer benutzerdefinierten Menüleiste oder eines Menüleistenmakros in der aktuellen Datenbank entspricht.

Am einfachsten stellen Sie diese Eigenschaft über die Option Menüleiste im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die Eigenschaft StartupMenuBar mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein, oder Sie erstellen die Eigenschaft auf folgende Weise:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe der CreateProperty-Methode hinzufügen und an die Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp), können Sie die Eigenschaft mit Hilfe der Add-Methode der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Anmerkung

Wenn Sie die Eigenschaft StartupMenuBar einstellen, verwenden Sie keine Aktion SetzenWert im Makro AutoExec, um die Eigenschaft MenuBar für das Objekt Application einzustellen. Da Microsoft Access das Makro AutoExec ausführt, nachdem die Starteigenschaften analysiert wurden, ersetzt die im Makro AutoExec festgelegte globale Menüleiste die durch die Eigenschaft StartupMenuBar festgelegte Menüleiste.

Sie können benutzerdefinierte Menüleisten auch über die Eigenschaft MenuBar für Formulare und Berichte erstellen. Diese benutzerdfinierten Menüleisten werden beim Öffnen eines bestimmten Formulars bzw. eines bestimmten Berichts angezeigt. Sie ersetzen in diesen Fällen die globale Menüleiste.

Ist die Eigenschaft StartupMenuBar leer (Standardeinstellung), zeigt Microsoft Access die eingebaute Menüleiste an. Ist diese Eigenschaft auf den Namen einer benutzerdefinierten Menüleiste eingestellt, hat die Einstellung der Eigenschaft AllowFullMenus keine Auswirkung (die eingebauten Menüs werden durch die globale Menüleiste ersetzt).

Das Einstellen dieser Eigenschaft hat dieselbe Auswirkung wie das Einstellen der Eigenschaft MenuBar des Objekts Application (nur dass die Einstellung der Eigenschaft MenuBar sofort wirksam wird).

Ist das Kontrollkästchen Access-Spezialtasten verwenden im Dialogfeld Start aktiviert oder die Eigenschaft AllowSpecialKeys auf True (-1) eingestellt, können die Benutzer STRG+F11 drücken, um zwischen der globalen Menüleiste und der eingebauten Menüleiste umzuschalten.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 StartupShortcutMenuBar-Eigenschaft

StartupShortcutMenuBar-Eigenschaft

Mit Hilfe der Eigenschaft StartupShortcutMenuBar können Sie ein benutzerdefiniertes Kontextmenü festlegen, um es als globales Kontextmenü für Ihre Anwendung zu verwenden. Sie können auch ein Menüleistenmakro festlegen, welches das benutzerdefinierte Konextmenü anzeigt, das Sie als globales Kontextmenü verwenden möchten.

Einstellung

Die Eigenschaft StartupShortcutMenuBar ist ein Zeichenfolgenausdruck, der dem Namen eines benutzerdefinierten Kontextmenüs oder eines Menüleistenmakros, das ein benutzerdefiniertes Kontextmenü anzeigt, entspricht.

Am einfachsten stellen Sie diese Eigenschaft über die Option Kontextmenüleiste im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die Eigenschaft StartupShortcutMenuBar mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein, oder Sie erstellen die Eigenschaft auf folgende Weise:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe der CreateProperty-Methode hinzufügen und der Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp), können Sie die Eigenschaft mit der Add-Methode der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Anmerkung

Wenn Sie die Eigenschaft StartupShortcutMenuBar einstellen, verwenden Sie keine Aktion SetzenWert im Makro AutoExec, um die Eigenschaft ShortcutMenuBar für das Objekt Application einzustellen. Da Microsoft Access das Makro AutoExec ausführt, nachdem die Starteigenschaften analysiert wurden, ersetzt das im Makro AutoExec festgelegte globale Kontextmenü das durch die Eigenschaft StartupShortcutMenuBar festgelegte Kontextmenü.

Sie können benutzerdefinierte Kontextmenüs auch über die Eigenschaft ShortcutMenuBar für Formulare, Berichte und Steuerelemente in Formularen erstellen. Diese benutzerdefinierten Kontextmenüs werden angezeigt, wenn Sie mit der rechten Maustaste auf ein bestimmtes Formular bzw. einen bestimmten Bericht oder ein Steuerelement in einem Formular klicken. Sie ersetzen in diesen Fällen das globale Kontextmenü.

Ist diese Eigenschaft leer, zeigt Microsoft Access die eingebauten Kontextmenüs an.

Das Einstellen dieser Eigenschaft hat dieselbe Auswirkung wie das Einstellen der Eigenschaft ShortcutMenuBar des Objekts Application (nur dass die Einstellung der Eigenschaft ShortcutMenuBar sofort wirksam wird).

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 StartupShowDBWindow-Eigenschaft

StartupShowDBWindow-Eigenschaft

Mit Hilfe der Eigenschaft StartupShowDBWindow können Sie festlegen, ob das Datenbankfenster beim Öffnen Ihrer Anwendungsdatenbank angezeigt werden soll oder nicht. Sie können z.B. ein Hauptformular öffnen, wenn sich Ihre Anwendungsdatenbank öffnet, und das Datenbankfenster ausblenden.

Einstellung

Die Eigenschaft StartupShowDBWindow verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Zeigt beim Start das Datenbankfenster an.
False (0) | Zeigt das Datenbankfenster beim Start nicht an.

Am einfachsten stellen Sie diese Eigenschaft über die Option Datenbankfenster anzeigen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die Eigenschaft StartupShowDBWindow mit Hilfe eines Makros oder Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein, oder Sie erstellen die Eigenschaft auf folgende Weise:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe der CreateProperty-Methode hinzufügen und der Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp), können Sie die Eigenschaft mit Hilfe der Add-Methode der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Anmerkung

Sie können die Eigenschaft StartupShowDBWindow auf False einstellen, um das Datenbankfenster auszublenden, so dass der Benutzer die Tabellen, Abfragen, Makros und Module in Ihrer Datenbank nicht sehen kann.

Ist das Kontrollkästchen Access-Spezialtasten verwenden im Dialogfeld Start aktiviert oder die Eigenschaft AllowSpecialKeys auf True (-1) eingestellt, können die Benutzer F11 drücken, um das Datenbankfenster anzuzeigen.

Selbst wenn Sie sowohl die Eigenschaft StartupShowDBWindow als auch die Eigenschaft AllowSpecialKeys auf False setzen, ist es möglich, dass ein Benutzer trotzdem auf das Datenbankfenster zugreifen kann. Dies kann passieren, wenn ein Benutzer mehrmals versucht, ein- und dieselbe Datenbank über die Liste der zuletzt verwendeten Datenbanken zu öffnen, die automatisch zusammen mit dem Menü Datei angezeigt wird. Um zu verhindern, dass Benutzer auf diese Liste zugreifen, ersetzen Sie das Menü Datei durch Ihr eigenes, benutzerdefiniertes Menü.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 StartupShowStatusBar-Eigenschaft

StartupShowStatusBar-Eigenschaft

Mit Hilfe der Eigenschaft StartupShowStatusBar können Sie festlegen, ob die Statusleiste beim Öffnen der Anwendungsdatenbank angezeigt werden soll oder nicht. Sie können über die Eigenschaft StartupShowStatusBar z.B. die Anzeige der Statusleiste verhindern, wenn Sie in Ihrer Anwendung keine Statusmeldungen anzeigen möchten.

Einstellung

Die Eigenschaft StartupShowStatusBar verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
True (-1) | Zeigt die Statusleiste beim Start an.
False (0) | Zeigt die Statusleiste beim Start nicht an.

Am einfachsten stellen Sie diese Eigenschaft über die Option Statusleiste anzeigen im Dialogfeld Start ein. Dieses Dialogfeld wird geöffnet, indem Sie im Menü Extras auf Start klicken. Sie können diese Eigenschaft auch unter Verwendung eines Makros oder von Visual Basic einstellen.

Um die Eigenschaft StartupShowStatusBar mit Hilfe eines Makros oder von Visual Basic einzustellen, stellen Sie zunächst entweder die Eigenschaft einmalig im Dialogfeld Start ein, oder Sie erstellen die Eigenschaft auf folgende Weise:

  • In einer Microsoft Access-Datenbank (.mdb) können Sie die Eigenschaft mit Hilfe der CreateProperty-Methode hinzufügen und der Properties-Auflistung des Database-Objekts anfügen.

  • In einem Microsoft Access-Projekt (.adp), können Sie die Eigenschaft mit Hilfe der Add-Methode der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Anmerkung

Das Einstellen dieser Eigenschaft wirkt sich nur für die aktuelle Datenbank auf die Anzeige der Statusleiste aus. Sie können auch für alle Microsoft Access-Datenbanken steuern, ob die Statusleiste standardmäßig angezeigt oder ausgeblendet wird. Hierzu klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Ansicht. Danach aktivieren oder deaktivieren Sie unter Zeigen das Kontrollkästchen Statusleiste. In der aktuellen Datenbank wird in den folgenden Fällen keine Statusleiste angezeigt: wenn das Kontrollkästchen Statusleiste im Dialogfeld Optionen deaktiviert ist; wenn das Kontrollkästchen Statusleiste anzeigen im Dialogfeld Start deaktiviert ist; oder wenn die Eigenschaft StartupShowStatusBar auf False eingestellt ist.

Die Einstellung dieser Eigenschaft wird erst beim nächsten Öffnen der Anwendungsdatenbank wirksam.


 StatusBarText-Eigenschaft (Statusleistentext)

StatusBarText-Eigenschaft (Statusleistentext)

Mit der Eigenschaft StatusBarText können Sie den Text angeben, der in der Statusleiste angezeigt wird, wenn ein Steuerelement ausgewählt ist.

Anmerkung Die Eigenschaft StatusBarText betrifft nur Steuerelemente eines Formulars, nicht Steuerelemente eines Berichts.

Einstellung

Sie stellen die Eigenschaft StatusBarText mit Hilfe eines bis zu 255 Zeichen langen Zeichenfolgenausdrucks ein.

Sie können diese Eigenschaft im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung Die Länge des Textes, der in der Statusleiste angezeigt werden kann, hängt von Ihrer Hardware und Ihrem Grafikmodus ab.

Anmerkung

Sie können die Eigenschaft StatusBarText verwenden, um bestimmte Informationen zu einem Steuerelement bereitzustellen. Hat z. B. ein Textfeld den Fokus, so kann ein kurzer Hinweis dem Benutzer mitteilen, welche Art von Daten einzugeben sind.

Anmerkung Sie können auch die Eigenschaft ControlTipText verwenden, um für ein Steuerelement einen Bildschirmtipp anzuzeigen.

Wenn Sie ein Steuerelement erstellen, indem Sie ein Feld aus der Feldliste ziehen, wird der Wert in der Eigenschaft Description eines Feldes in die Eigenschaft StatusBarText kopiert.

Bei einem Steuerelement, das einen Hyperlink enthält, wird in der Statusleiste die Hyperlinkadresse angezeigt, wenn sich der Mauszeiger auf dem Steuerelement befindet und das Kontrollkästchen Hyperlink-Adressen in Statusleiste anzeigen aktiviert ist. Sie finden dieses Kontrollkästchen im Dialogfeld Optionen auf der Registerkarte Hyperlinks/HTML. Sie öffnen dieses Dialogfeld, indem Sie im Menü Extras auf Optionen klicken. Wenn Sie das Steuerelement bearbeiten, wird in der Statusleiste der Text angezeigt, auf den die Eigenschaft StatusBarText eingestellt ist.


 Style-Eigenschaft (Microsoft Access)

Style-Eigenschaft (Microsoft Access)

Mit der Style-Eigenschaft können Sie die Darstellung von Registerkarten in einem Registersteuerelement angeben oder ermitteln.

Einstellung

Die Style-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Register | acTabs | (Standardeinstellung) Registerkarten werden als Registerkarten angezeigt.
Schaltflächen | acButtons | Registerkarten werden als Schaltflächen angezeigt.
Keine | acNone | Im Steuerelement werden keine Registerkarten angezeigt.

Sie können die Style-Eigenschaft mit dem Eigenschaftenfenster des Steuerelements, einem Makro oder in Visual Basic einstellen.

Sie können die Standardeinstellung dieser Eigenschaft auch in den Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der DefaultControl-Methode in Visual Basic einstellen.

Sie können die Style-Eigenschaft in einer beliebigen Ansicht einstellen.

Anmerkung

Wenn die Style-Eigenschaft des Registersteuerelements auf "Register" oder "Schaltflächen" gesetzt ist, wird die Darstellung der Registerkarten durch die Eigenschaften TabFixedHeight, TabFixedWidth und MultiRow festgelegt.

Wenn Sie die Bewegungen eines Benutzers zwischen Registerkarten vollständig kontrollieren möchten, können Sie die Style-Eigenschaft des Registersteuerelements auf "Keine" setzen. In früheren Versionen von Microsoft Access wurden durch die Verwendung mehrseitiger Formulare Assistentendialoge erstellt. Jetzt können Sie ein Registersteuerelement verwenden, um Ihren eigenen Assistenten zu erstellen. Jede Seite des Assistenten ist auf einer separaten Seite eines Registersteuerelements enthalten, dessen Style-Eigenschaft auf "Keine" gesetzt ist.


 SubAddress-Eigenschaft

SubAddress-Eigenschaft

Mit Hilfe der SubAddress-Eigenschaft können Sie eine Position angeben oder ermitteln, die sich in dem Zieldokument befindet, das in der Address-Eigenschaft angegeben ist. Die Einstellung der SubAddress-Eigenschaft kann Folgendes sein: ein Objekt einer Microsoft Access-Datenbank, eine Textmarke eines Microsoft Word-Dokument, ein benannter Bereich eines Microsoft Excel-Tabellenblatts, eine Folie einer Microsoft PowerPoint-Präsentation oder eine Position in einem HTML-Dokument.

Einstellung

Die SubAddress-Eigenschaft ist ein Zeichenfolgenausdruck für die HyperlinkSubAddress-Eigenschaft eines benannten Speicherplatzes in dem Zieldokument, das in der HyperlinkAddress-Eigenschaft angegeben ist.

Sie können die HyperlinkSubAddress-Eigenschaft mit der SubAddress-Eigenschaft in Visual Basic einstellen.

Anmerkung Die HyperlinkSubAddress-Eigenschaft können Sie entweder im Eigenschaftenfenster eines Steuerelements mit einem Makro oder in Visual Basic festlegen.

Anmerkungen

Wenn Sie den Cursor über einer Befehlsschaltfläche, einem Bild-Steuerelement oder einem Bezeichnungsfeld-Steuerelement bewegen, dessen HyperlinkAddress-Eigenschaft festgelegt ist, ändert sich der Cursor in eine nach oben zeigende Hand. Wenn Sie auf das Steuerelement klicken, wird das Objekt oder die Webseite angezeigt, das bzw. die für den Hyperlink angegeben ist.

Weitere Informationen über Hyperlinkadressen und deren Format finden Sie unter den Themen HyperlinkAddress-Eigenschaft und HyperlinkSubAddress-Eigenschaft.


 SubdatasheetExpanded-Eigenschaft (UnterdatenblattErweitert)

SubdatasheetExpanded-Eigenschaft (UnterdatenblattErweitert)

Mit Hilfe der SubdatasheetExpanded-Eigenschaft können Sie den gespeicherten Status aller Unterdatenblätter in einer Tabelle oder in einer Abfrage angeben oder ermitteln.

Anmerkung Die SubdatasheetExpanded-Eigenschaft gilt nur für Tabellen und Abfragen in einer Microsoft Access-Datenbank (.mdb).

Einstellung

Die SubdatasheetExpanded-Eigenschaft verwendet folgende Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Der gespeicherte Status aller Unterdatenblätter der Tabelle wird eingeblendet.
Nein | False (0) | (Standardeinstellung) Der gespeicherte Status aller Unterdatenblätter der Tabelle wird geschlossen.

Die einfachste Methode zum Festlegen der SubdatasheetExpanded-Eigenschaft ist die Verwendung des Tabellen-Eigenschaftenfensters. Sie können diese Eigenschaft auch mit Hilfe von Visual Basic festlegen.

Um die SubdatasheetExpanded-Eigenschaft mit Hilfe von Visual Basic festzulegen, müssen Sie zunächst einen der folgenden Schritte durchführen:

  • Legen Sie die Eigenschaft in der Tabellenentwurfsansicht fest, indem Sie im Menü Ansicht auf Eigenschaften zeigen.

  • Erstellen Sie die Eigenschaft mit Hilfe der DAO-Methode CreateProperty.

Anmerkungen

Der Wert der SubdatasheetExpanded-Eigenschaft wird im Eigenschaftenfenster Tabelleneigenschaften angezeigt.

Die SubdatasheetExpanded- und SubdatasheetHeight-Eigenschaften haben Wirkung auf das Unterformular-Steuerelement, wenn das Formular in der Datenblattansicht ist.


 SubdatasheetHeight-Eigenschaft (Unterdatenblatthöhe)

SubdatasheetHeight-Eigenschaft (Unterdatenblatthöhe)

Mit Hilfe der SubdatasheetHeight-Eigenschaft können Sie die Anzeigehöhe beim Einblenden eines Unterdatenblattes angeben oder ermitteln.

Anmerkung Die SubdatasheetHeight-Eigenschaft gilt nur für Tabellen und Abfragen in einer Microsoft Access-Datenbank (.mdb).

Einstellung

Die SubdatasheetHeight-Eigenschaft ist ein numerischer Ausdruck, der die Standardhöhe angibt, die im Unterdatenblatt angezeigt wird.

Die einfachste Methode zur Einstellung der SubdatasheetExpanded-Eigenschaft ist die Verwendung des Tabellen-Eigenschaftenfensters. Sie können diese Eigenschaft auch mit Hilfe von Visual Basic einstellen. In Visual Basic wird der Wert der Eigenschaft in Twips ausgedrückt.

Um die SubdatasheetHeight-Eigenschaft mit Hilfe von Visual Basic festzulegen, müssen Sie zunächst einen der folgenden Schritte durchführen:

  • Stellen Sie die Eigenschaft in der Tabellenentwurfsansicht ein, indem Sie im Menü Ansicht auf Eigenschaften zeigen.

  • Erstellen Sie die Eigenschaft mit Hilfe der DAO-Methode CreateProperty.

Anmerkung

Wenn das Unterdatenblatt mehr Datensätze enthält, als die Höheneinstellung darstellen kann, wird eine vertikale Bildlaufleiste angezeigt.

Die Einstellung der SubdatasheetHeight-Eigenschaft enthält die Zeile Neuer Datensatz, wenn das Hinzufügen neuer Datensätze zulässig ist. Sie schließt nicht die Spaltenkopfzeile und den Bildlaufleistenbereich ein.

Die SubdatasheetHeight- und SubdatasheetExpanded-Eigenschaften haben Wirkung auf das Unterformular-Steuerelement, wenn das Formular in der Datenblattansicht ist.


 SubdatasheetName-Eigenschaft (Unterdatenblattname)

SubdatasheetName-Eigenschaft (Unterdatenblattname)

Mit Hilfe der SubdatasheetName-Eigenschaft können Sie die Tabelle oder Abfrage angeben oder ermitteln, die an das Unterdatenblatt gebunden ist.

Anmerkung Die SubdatasheetName-Eigenschaft gilt nur für Tabellen und Abfragen in einer Microsoft Access-Datenbank (.mdb).

Einstellung

Die SubdatasheetName-Eigenschaft ist ein Zeichenfolgenausdruck, der den Namen der an das Unterdatenblatt gebundenen Tabelle oder Abfrage wiedergibt.

Die einfachste Methode zur Einstellung der SubdatasheetName-Eigenschaft ist die Verwendung des Tabellen-Eigenschaftenfensters. Sie können diese Eigenschaft auch mit Hilfe von Visual Basic einstellen.

Um die SubdatasheetName-Eigenschaft mit Hilfe von Visual Basic einzustellen, müssen Sie zunächst einen der folgenden Schritte durchführen:

  • Stellen Sie die Eigenschaft in der Tabellenentwurfsansicht ein, indem Sie im Menü Ansicht auf Eigenschaften zeigen.

  • Erstellen Sie die Eigenschaft mit Hilfe der DAO-Methode CreateProperty.


 TabFixedHeight-, TabFixedWidth-Eigenschaften (RegisterFesteHöhe, RegisterFesteBreite)

TabFixedHeight-, TabFixedWidth-Eigenschaften (RegisterFesteHöhe, RegisterFesteBreite)

Mit den Eigenschaften TabFixedHeight und TabFixedWidth können Sie die Höhe und die Breite der Registerkarten eines Registersteuerelement angeben oder ermitteln.

Einstellung

Die Einstellungen der Eigenschaften TabFixedHeight und TabFixedWidth sind Werte, die die Höhe und die Breite von Registerkarten in der Maßeinheit angeben, die in der Systemsteuerung von Windows im Dialogfeld Eigenschaften von Ländereinstellungen festgelegt ist. Wenn Sie diese Eigenschaften auf 0 einstellen, werden die Registerkarten automatisch an die Höhe und die Breite angepasst, die die Inhalte der Registerkarten beanspruchen.

Sie können diese Eigenschaften im Eigenschaftenfenster des Registersteuerelements, in einem Makro oder in Visual Basic einstellen.

Die Standardeinstellungen dieser Eigenschaften können Sie mit Hilfe der Standardeigenschafteneinstellungen eines Steuerelements oder in Visual Basic mit der Methode DefaultControl einstellen.

In Visual Basic werden diese Eigenschaften auf Werte des Datentyps Long Integer eingestellt. Diese Werte geben die Höhe bzw. die Breite der Registerkarten in Twips an und können in jeder Ansicht eingestellt werden.

Anmerkung Wenn Sie eine andere Maßeinheit verwenden möchten als die, die im Dialogfeld Eigenschaften von Ländereinstellungen festgelegt ist, geben Sie die Einheit an (z.B. 5 cm oder 3 Zoll).

Anmerkung

Die Farbe eines Registersteuerelements können Sie nicht ändern. Wenn die Registerkarten nicht die volle Breite des Registersteuerelements überdecken, wird der Bereich angezeigt, der hinter den Registerkarten liegt. Wenn Sie ein Registersteuerelement auf einem Objekt anordnen, das eine andere Farbe hat als das Registersteuerelement, sollten Sie dafür sorgen, dass die Registerkarten den Hintergrundbereich des Steuerelements überdecken.


 TabIndex-Eigenschaft (Reihenfolgenposition)

TabIndex-Eigenschaft (Reihenfolgenposition)

Mit der Eigenschaft TabIndex können Sie die Position eines Steuerelements in der Reihenfolge der Steuerelemente eines Formulars angeben.

Anmerkung Die Eigenschaft TabIndex betrifft nur die Steuerelemente eines Formulars, nicht die Steuerelemente eines Berichts.

Einstellung

Sie können die Eigenschaft TabIndex auf eine Ganzzahl einstellen, die die Position des Steuerelements innerhalb der Reihenfolge der Steuerelemente im Formular darstellt. Gültige Einstellungen liegen im Bereich von 0 für die erste Position bis zur Gesamtanzahl an Steuerelementen minus 1 für die letzte Position. Verfügt ein Formular z.B. über drei Steuerelemente, von denen jedes über die Eigenschaft TabIndex verfügt, so sind 0, 1 und 2 gültige Einstellungen für die Eigenschaft TabIndex.

Das Einstellen der Eigenschaft TabIndex auf eine Ganzzahl kleiner als 0 gibt einen Fehler zurück.

Sie können diese Eigenschaft im Eigenschaftenfenster eines Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung Sie können die Reihenfolge der Steuerelemente eines Formulars auch einstellen, indem Sie im Menü Ansicht auf den Befehl Aktivierreihenfolge klicken. Auch dadurch wird die Eigenschaft TabOrder der Steuerelemente eingestellt.

Anmerkung

Standardmäßig weist Microsoft Access die Reihenfolge der Steuerelemente den Steuerelementen in der Reihenfolge zu, in der Sie sie in einem Formular erstellen. Ein neues Steuerelement erhält die letzte Position in der Reihenfolge der Steuerelemente. Wenn Sie die Einstellung der Eigenschaft TabIndex eines Steuerelements ändern, um die Reihenfolge der Steuerelemente anzupassen, legt Microsoft Access automatisch neue Einstellungen der Eigenschaft TabIndex für die anderen Steuerelemente fest, um eingefügte oder gelöschte Steuerelemente zu berücksichtigen.

In der Formularansicht verbleiben unsichtbare oder deaktivierte Steuerelemente in der Reihenfolge der Steuerelemente, werden jedoch übersprungen, wenn Sie TAB drücken.

Das Verändern der Reihenfolge anderer Steuerelemente im Formular hat keine Auswirkungen, wenn Sie die Zugriffstaste eines Steuerelements drücken. Haben Sie z.B. eine Zugriffstaste für das Bezeichnungsfeld eines Textfelds erstellt, so wird der Fokus immer dann auf das Textfeld gesetzt, wenn Sie die Zugriffstaste des Bezeichnungsfelds drücken, auch bei geänderter Einstellung der Eigenschaft TabIndex für das Textfeld.

Wenn Sie eine Zugriffstaste für ein Steuerelement drücken, wie z.B. ein Bezeichnungsfeld, das nicht über die Eigenschaft TabIndex verfügt (und daher nicht in der Reihenfolge der Steuerelemente ist), wird der Fokus auf das nächste Steuerelement in der Reihenfolge der Steuerelemente gesetzt, das den Fokus erhalten kann.


 TabStop-Eigenschaft (InReihenfolge)

TabStop-Eigenschaft (InReihenfolge)

Mit der Eigenschaft TabStop können Sie angeben, ob Sie TAB dazu verwenden können, den Fokus in der Formularansicht auf ein Steuerelement zu setzen.

Anmerkung Die Eigenschaft TabStop betrifft nur die Steuerelemente eines Formulars, nicht die Steuerelemente eines Berichts.

Diese Eigenschaft betrifft keine Kontrollkästchen-, Optionsfeld- oder Umschaltfläche-Steuerelemente, die zu einer Optionsgruppe gehören. Sie betrifft nur die Optionsgruppe selbst.

Einstellung

Die Eigenschaft TabStop kann eine der folgenden Einstellungen annehmen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Sie können den Fokus durch Drücken von TAB zum Steuerelement bewegen.
Nein | False (0) | Sie können den Fokus nicht durch Drücken von TAB zum Steuerelement bewegen.

Sie können diese Eigenschaft im Eigenschaftenfenster eines Steuerelements, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Wenn Sie ein Steuerelement in einem Formular erstellen, weist Microsoft Access dem Steuerelement automatisch eine Position in der Reihenfolge der Steuerelemente des Formulars zu. Ein neues Steuerelement erhält die letzte Position in der Reihenfolge der Steuerelemente. Soll ein Steuerelement nicht verfügbar sein, wenn Sie mit TAB den Fokus auf die Steuerelemente in einem Formular setzen, so müssen Sie die Eigenschaft TabStop des Steuerelements auf Nein einstellen.

In der Formularansicht verbleiben unsichtbare oder deaktivierte Steuerelemente in der Reihenfolge der Steuerelemente, werden jedoch übersprungen, wenn Sie sich durch Drücken von TAB durch die Steuerelemente bewegen, auch wenn deren Eigenschaft TabStop auf Ja eingestellt ist.

Solange die Eigenschaft Enabled eines Steuerelements auf Ja eingestellt ist, können Sie auf das Steuerelement klicken oder eine Zugriffstaste verwenden, um sie zu wählen, unabhängig von der Einstellung der Eigenschaft TabStop. Sie können z.B. die Eigenschaft TabStop einer Befehlsschaltfläche auf Nein einstellen, um Benutzer daran zu hindern, die Schaltfläche durch Drücken von TAB auszuwählen. Die Benutzer können aber weiterhin auf die Befehlsschaltfläche klicken, um sie zu wählen.


 Tag-Eigenschaft (Marke)

Tag-Eigenschaft (Marke)

Mit der Eigenschaft Tag können Sie beliebige Zusatzinformationen zu einem Formular, einem Bericht, einer Datenzugriffsseite, einem Bereich oder einem Steuerelement speichern, die von Ihrer Anwendung benötigt werden.

Einstellung

Sie können einen Zeichenfolgenausdruck mit bis zu 2048 Zeichen eingeben. Die Standardeinstellung ist eine leere Zeichenfolge (" ").

Sie können diese Eigenschaft im Eigenschaftenfenster des Objekts, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Im Gegensatz zu anderen Eigenschaften hat die Einstellung der Eigenschaft Tag keine Auswirkungen auf die Attribute eines Objekts.

Sie können diese Eigenschaft verwenden, um einem Objekt eine kennzeichnende Zeichenfolge zuzuweisen, ohne andere Eigenschafteneinstellungen zu verändern oder andere Nebeneffekte auszulösen. Die Eigenschaft Tag erweist sich als hilfreich, wenn Sie die Kennzeichnung eines Formulars, Berichts, einer Datenzugriffsseite, eines Bereichs oder Steuerelements überprüfen müssen, die als Variable an eine Prozedur übergeben wird.


 Text-Eigenschaft

Text-Eigenschaft

Mit der Eigenschaft Text können Sie den Text einstellen oder zurückgeben, der sich in einem Textfeld oder im Textfeldteil eines Kombinationsfelds befindet.

Einstellung

Sie können die Eigenschaft Text auf den Text einstellen, den Sie im Steuerelement anzeigen möchten. Mit der Eigenschaft Text können Sie auch den Text lesen, den das Steuerelement momentan enthält.

Sie können diese Eigenschaft nur in einem Makro oder in Visual Basic einstellen bzw. lesen.

Anmerkung Damit die Eigenschaft Text eines Steuerelements eingestellt oder zurückgegeben werden kann, muss das Steuerelement den Fokus haben. Zum Setzen des Fokus auf ein Steuerelement können Sie die Methode SetFocus oder die Aktion GeheZuSteuerelement verwenden.

Anmerkung

Solange das Steuerelement den Fokus besitzt, enthält die Eigenschaft Text die momentan im Steuerelement vorhandenen Textdaten. Die Eigenschaft Value enthält die zuletzt für das betreffende Steuerelement gespeicherten Daten. Wenn Sie den Fokus auf ein anderes Steuerelement einstellen, werden die Daten des Steuerelements aktualisiert, und die Eigenschaft Value wird auf den neuen Wert eingestellt. Die Einstellung der Eigenschaft Text ist anschließend so lange nicht mehr verfügbar, bis das Steuerelement erneut den Fokus erhält. Wenn Sie im Menü Datensätze auf Datensatz speichern klicken, um die Daten des Steuerelements zu speichern, ohne dass der Fokus verschoben wird, sind die Einstellungen der Eigenschaften Text und Value identisch.


 TextToDisplay-Eigenschaft (Anzeigetext)

TextToDisplay-Eigenschaft (Anzeigetext)

Mit Hilfe der TextToDisplay-Eigenschaft können Sie den Anzeigetext für einen Hyperlink angeben oder ermitteln.

Einstellung

Die TextToDisplay-Eigenschaft ist ein Zeichenfolgenausdruck, der den Text repräsentiert, der als Hyperlink angezeigt wird.

Die TextToDisplay-Eigenschaft kann im Eigenschaftenfenster oder mit Hilfe von Visual Basic eingestellt werden.


 TimerInterval-Eigenschaft (Zeitgeberintervall)

TimerInterval-Eigenschaft (Zeitgeberintervall)

Mit der Eigenschaft TimerInterval können Sie in Millisekunden die Länge des Intervalls angeben, das zwischen zwei Timer-Ereignissen eines Formulars liegen soll.

Einstellung

Die Einstellung der Eigenschaft TimerInterval ist ein Wert des Typs Long Integer zwischen 0 und 2.147.483.647.

Sie können diese Eigenschaft im Eigenschaftenfenster des jeweiligen Formulars, mit einem Makro oder mit Visual Basic einstellen.

Anmerkung Aus Visual Basic stellen Sie die Eigenschaft TimerInterval in der Ereignisprozedur ein, die nach Eintreten des Ereignisses Load ausgeführt wird.

Anmerkung

Wenn Sie Visual Basic-Code in Intervallen ausführen möchten, deren Länge durch die Eigenschaft TimerInterval angegeben ist, fügen Sie diesen Code in die Timer-Ereignisprozedur des entsprechenden Formulars ein. Wenn Sie z. B. alle 30 Sekunden Datensätze erneut abfragen möchten, können Sie wie folgt vorgehen: Sie schreiben den Code, mit dem die Datensätze wiederholt abgefragt werden, in die Timer-Ereignisprozedur des Formulars; danach stellen Sie die Eigenschaft TimerInterval auf 30000 ein.


 Toolbar-Eigenschaft (Symbolleiste)

Toolbar-Eigenschaft (Symbolleiste)

Mit der Eigenschaft Toolbar können Sie die Symbolleiste angeben, die für ein Formular oder einen Bericht verwendet werden soll. Um eine solche Symbolleiste zu erstellen, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Anpassen. Weitere Informationen, wie benutzerdefinierte Symbolleisten erstellt werden, finden Sie unter Erstellen einer benutzerdefinierten Symbolleiste für die aktuelle Datenbank.

Einstellung

Die Einstellung der Eigenschaft Toolbar ist der Name der benutzerdefinierten Symbolleiste, die Sie anzeigen möchten. Wenn Sie keinen Wert für die Eigenschaft Toolbar angeben, zeigt Microsoft Access die eingebaute Symbolleiste (Standardsymbolleiste) des Formulars oder Berichts an.

Sie können die Eigenschaft Toolbar im Eigenschaftenfenster des Formulars oder Berichts, in einem Makro oder in Visual Basic einstellen.

In Visual Basic stellen Sie diese Eigenschaft mit einem Zeichenfolgenausdruck ein, der den Namen der Symbolleiste angibt, die angezeigt werden soll.

Wenn Sie bei einem Formular oder Bericht die eingebaute Symbolleiste in einem Makro oder in Visual Basic anzeigen möchten, stellen Sie die Eigenschaft Toolbar auf eine leere Zeichenfolge (" ") ein.

Anmerkung

Wenn Sie die Eigenschaft Toolbar eingestellt haben, zeigt Microsoft Access die angegebene benutzerdefinierte Symbolleiste an, sobald das Formular oder der Bericht geöffnet ist. Diese Symbolleiste wird danach immer dann angezeigt, wenn das Formular oder der Bericht den Fokus hat.


 TopValues-Eigenschaft (Spitzenwerte)

TopValues-Eigenschaft (Spitzenwerte)

Sie können die Eigenschaft TopValues verwenden, um eine bestimmte Anzahl oder einen bestimmten Prozentsatz an Datensätzen zurückzugeben, die den angegebenen Kriterien genügen. Sie können beispielsweise die 10 Spitzenwerte oder die obersten 25 Prozent aller Werte in einem Feld zurückgeben.

Anmerkung Die Eigenschaft TopValues gilt nur für Anfüge-, Tabellenerstellungs- und Auswahlabfragen.

Einstellung

Die Einstellung der Eigenschaft TopValues entspricht einem Integer-Wert, der die genaue Anzahl an zurückzugebenden Werten oder den Prozentsatz an zurückzugebenden Datensätzen (eine Zahl mit einem %-Zeichen) angibt. Um z.B. die 10 größten Werte zurückzugeben, stellen Sie die Eigenschaft TopValues auf 10 ein; wenn die ersten 10 Prozent der Werte zurückgeben möchten, stellen Sie die Eigenschaft TopValues auf 10 % ein.

Sie können diese Eigenschaft nicht direkt im Code einstellen. Sie wird in der SQL-Ansicht des Abfragefensters eingestellt, indem Sie in der SQL-Anweisung die TOP n or TOP n PERCENT-Klausel verwenden.

Sie können die TopValues-Eigenschaft auch im Abfrage-Eigenschaftenfenster oder im Feld Top Values Spitzenwerte, Listenfeld in der Symbolleiste Abfragedatenblatt einstellen.

AnmerkungDie Eigenschaft TopValues im Abfrageeigenschaftenfenster und in der Symbolleiste Abfrageentwurf ist ein Kombinationsfeld, das eine Liste von Werten und Prozentwerten enthält. Sie können einen dieser Werte auswählen oder eine gültige Einstellung im Textfeld dieses Steuerelements eingeben.

Anmerkung

In der Regel verwenden Sie die Einstellung der Eigenschaft TopValues zusammen mit sortierten Feldern. Das Feld, für das Spitzenwerte angezeigt werden sollen, muss das am weitesten links stehende Feld sein, in dem das Feld Sortieren im Entwurfsbereich einer Abfrage aktiviert ist. Bei aufsteigender Sortierreihenfolge werden die untersten Datensätze zurückgegeben, bei absteigender Sortierreihenfolge die obersten Datensätze. Wenn Sie angeben, dass eine bestimmte Anzahl an Datensätzen zurückgegeben werden soll, werden alle Datensätze mit Werten, die dem Wert des letzten Datensatzes entsprechen, ebenfalls zurückgegeben.

Nehmen Sie z.B. an, dass eine Gruppe von Angestellten die folgenden Umsatzsummen erzielt hat.

Umsatz | Verkaufsberater
90,000 | Leverling
80,000 | Peacock
70,000 | Davolio
70,000 | King
60,000 | Suyama
50,000 | Buchanan

Wenn Sie die Eigenschaft TopValues auf 3 einstellen und das Feld Umsatz absteigend sortieren, gibt Microsoft Access die folgenden vier Datensätze zurück.

Umsatz | Verkaufsberater
90,000 | Leverling
80,000 | Peacock
70,000 | Davolio
70,000 | King

Anmerkung Damit die höchsten oder niedrigsten Werte ohne Anzeige von Duplikaten zurückgegeben werden, stellen Sie die Eigenschaft UniqueValues im Eigenschaftenfenster der Abfrage auf Ja ein.


 Transparent-Eigenschaft (Transparent)

Transparent-Eigenschaft (Transparent)

Mit der Eigenschaft Transparent können Sie angeben, ob eine Befehlsschaltfläche sichtbar oder transparent ist.

Tipp Verwenden Sie die Eigenschaft BackStyle, um andere Steuerelemente ein- oder auszublenden.

Einstellung

Die Eigenschaft Transparent verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Die Schaltfläche ist transparent.
Nein | False (0) | (Standardeinstellung) Die Schaltfläche ist sichtbar.

Sie können diese Eigenschaft im Eigenschaftenfenster der Befehlsschaltfläche, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Sie können diese Eigenschaft verwenden, um eine transparente Befehlsschaltfläche über einem anderen Steuerelement zu positionieren. Sie können z. B. mehrere transparente Schaltflächen über einem Bild positionieren, das in einem Bildrahmen angezeigt wird, und verschiedene Makros oder Visual Basic-Ereignisprozeduren ausführen, wenn der Benutzer auf unterschiedliche Teile des Bildes klickt.

Anmerkung Sie können eine Schaltfläche ausblenden und deaktivieren, indem Sie die Eigenschaft Visible verwenden. Um eine Schaltfläche zu deaktivieren, ohne sie auszublenden, verwenden Sie die Eigenschaft Enabled. Um eine Schaltfläche nur dann auszublenden, wenn ein Formular oder Bericht gedruckt wird, verwenden Sie die Eigenschaft DisplayWhen.


 TripleState-Eigenschaft (DreifacherStatus)

TripleState-Eigenschaft (DreifacherStatus)

Sie können mit der Eigenschaft TripleState angeben, wie Null-Werte von einem Kontrollkästchen, einer Umschaltfläche oder einem Optionsfeld angezeigt werden sollen.

Anmerkung Die Eigenschaft TripleState gilt nicht für die angegebenen Steuerelemente, wenn diese innerhalb eines Optionsgruppen-Steuerelements verwendet werden.

Einstellung

Die Eigenschaft TripleState verwendet die folgenden Einstellungen:

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Das Steuerelement durchläuft verschiedene Stadien für Ja-, Nein- und Null-Werte. Das Steuerelement wird abgeblendet dargestellt, wenn seine Eigenschaft Value auf Null eingestellt ist.
Nein | False (0) | (Standardeinstellung) Das Steuerelement durchläuft Stadien für Ja- und Nein-Werte. Null-Werte werden wie Nein-Werte angezeigt.

Sie können die Eigenschaft TripleState im Eigenschaftenfenster eines Steuerelements, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann in allen Ansichten eingestellt werden.


 Type-Eigenschaft

Type-Eigenschaft

Die Eigenschaft Type gibt an, ob ein Modul ein Standardmodul oder ein Klassenmodul ist.

Einstellung

Die Eigenschaft Type steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.

Ist das Modul ein Standardmodul, hat die Eigenschaft Type den Wert acStandardModule bzw. 0. Ist das Modul ein Klassenmodul, hat die Eigenschaft Type den Wert acClassModule bzw. 1.


 Type-Eigenschaft (AccessObject-Objekt)

Type-Eigenschaft (AccessObject-Objekt)

Mit Hilfe der Type-Eigenschaft können Sie den Wert eines AccessObject-Objekttyps zurückgeben.

Einstellung

Die Type-Eigenschaft gibt eine der folgenden eingebauten Konstanten zurück.

acDataAccessPage (6) | acQuery (1)
acDiagram (8) | acReport (3)
acForm (2) | acServerView (7)
acMacro (4) | acStoredProcedure (9)
acModule (5) | acTable (0)

Die Type-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 Type-Eigenschaft (FormatCondition-Objekt)

Type-Eigenschaft (FormatCondition-Objekt)

Mit Hilfe der Type-Eigenschaft können Sie den Wert eines FormatCondition-Objekttyps zurückgeben.

Einstellung

Die Type-Eigenschaft gibt eine der folgenden eingebauten Konstanten zurück.

acExpression (1) | acFieldHasFocus (2)
acFieldValue (0) |

Die Type-Eigenschaft steht nur in Visual Basic zur Verfügung und ist schreibgeschützt.


 UnderlineHyperlinks-Eigenschaft

UnderlineHyperlinks-Eigenschaft

Mit der UnderlineHyperlink-Eigenschaft können Sie angeben oder ermitteln, ob Hyperlinks innerhalb des Application-Objekts bei der Anzeige unterstrichen werden sollen.

Einstellung

Die UnderlineHyperlink-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Hyperlinks werden unterstrichen.
Nein | False (0) | Hyperlinks werden nicht unterstrichen.

Sie können die UnderlineHyperlink-Eigenschaft über die DefaultWebOptions-Eigenschaft oder die SetOption-Methode unter Verwendung von Visual Basic einstellen.

Sie können die Einstellung zum Unterstreichen von Hyperlinks im Dialogfeld Weboptionen festlegen oder ändern. Um dieses Dialogfeld anzuzeigen, klicken Sie im Menü Extras auf Optionen. Klicken Sie auf die Registerkarte Allgemein und dann auf die Schaltfläche Weboptionen.

Anmerkung

Mit der DefaultWebOptions-Eigenschaft legen Sie die DefaultWebOptions-Objekteigenschaften des Application-Objekts fest.


 Unique-Eigenschaft (Eindeutig)

Unique-Eigenschaft (Eindeutig)

Mit der Eigenschaft Unique können Sie angeben, dass ein Index die Eindeutigkeit der Daten im Schlüsselindex der Tabelle erfordert.

Einstellung

Die Eigenschaft Unique verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Der Index entspricht einem Schlüsselindex (eindeutig).
Nein | False (0) | Der Index entspricht keinem Schlüsselindex.

Sie können diese Eigenschaft im Dialogfeld Indizes in der Tabellenentwurfsansicht oder mit Visual Basic einstellen.

Anmerkung Sie greifen auf die Unique-Eigenschaft eines Indexes mit Hilfe von Visual Basic zu, indem Sie die ADO-Eigenschaft Unique verwenden.

Anmerkung

Ein Schlüsselindex optimiert die Suche nach Datensätzen. Er setzt sich aus einem oder mehreren Feldern zusammen, die alle Datensätze in einer Tabelle in einer vordefinierten Reihenfolge eindeutig anordnen. Besteht der Index aus einem Feld, so müssen die Werte in diesem Feld eindeutig sein. Besteht der Index aus mehreren Feldern, so kann jedes Feld mehrfache Werte enthalten, aber jede Kombination von Werten aller indizierten Felder muss eindeutig sein. Ein Index ohne Schlüssel verfügt über Felder mit Werten, die nicht unbedingt eindeutig sind.

Ein Index entspricht dem Primärindex für eine Tabelle, wenn dessen Eigenschaft Primary auf Ja eingestellt ist. Jede Tabelle kann nur über einen primären Index verfügen.


 UniqueRecords-Eigenschaft (EindeutigeDatensätze)

UniqueRecords-Eigenschaft (EindeutigeDatensätze)

Mit der Eigenschaft UniqueRecords können Sie angeben, ob nur eindeutige Datensätze zurückgegeben werden sollen, die auf allen Feldern der zugrunde liegenden Datenquelle basieren, und nicht nur auf den in der Abfrage vorhandenen Feldern.

Anmerkung Die Eigenschaft UniqueRecords gilt nur für Anfüge- und Tabellenerstellungs-Aktionsabfragen und Auswahl-Abfragen.

Einstellung

Die Eigenschaft UniqueRecords verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Gibt keine mehrfach vorkommenden Datensätze zurück.
Nein | (Voreinstellung) Gibt mehrfach vorkommende Datensätze zurück.

Sie können die UniqueRecords-Eigenschaft im Abfrage-Eigenschaftenfenster oder in der SQL-Ansicht des Abfragefensters festlegen.

Anmerkung Sie stellen diese Eigenschaft ein, wenn Sie eine neue Abfrage mit Hilfe einer SQL-Anweisung erstellen. Das DISTINCTROW-Prädikat entspricht der Einstellung der UniqueRecords-Eigenschaft. Das DISTINCT-Prädikat entspricht der Einstellung der UniqueValues-Eigenschaft.

Anmerkung

Sie können die Eigenschaft UniqueRecords verwenden, wenn Daten nicht zurückgegeben werden sollen, die auf mehrfach vorhandenen Datensätzen basieren, und nicht nur auf doppelt vorhandenen Feldern. Microsoft Access interpretiert einen Datensatz als eindeutig, solange sich der Wert in einem Feld des Datensatzes vom Wert desselben Feldes in einem anderen Datensatz unterscheidet.

Die Eigenschaft UniqueRecords ist nur wirksam, wenn Sie mehrere Tabellen in der Abfrage verwenden und Felder aus den in der Abfrage verwendeten Tabellen auswählen. Die Eigenschaft UniqueRecords wird ignoriert, wenn die Abfrage nur eine Tabelle umfasst.

Die Beziehung zwischen den Eigenschaften UniqueRecords und UniqueValues besteht darin, dass immer nur eine der beiden Eigenschaften auf Ja eingestellt werden kann. Stellen Sie z.B. die Eigenschaft UniqueRecords auf Ja ein, so stellt Microsoft Access die Eigenschaft UniqueValues automatisch auf Nein ein. Sie können jedoch beide Eigenschaften auf Nein einstellen. Sind beide Eigenschaften auf Nein eingestellt, werden alle Datensätze zurückgegeben.


 UniqueTable-Eigenschaft (EindeutigeTabelle)

UniqueTable-Eigenschaft (EindeutigeTabelle)

Mit der UniqueTable-Eigenschaft können Sie angeben oder ermitteln, welche Tabelle in den folgenden Situationen aktualisierbar ist:

  • Ein Formular oder eine Datenzugriffsseite ist an eine Mehr-Tabellen-Sicht oder eine Gespeicherte Prozedur in einem Microsoft Access-Projekt (.adp) gebunden.

  • Eine Datenzugriffsseite ist an eine Mehr-Tabellen-Abfrage oder ein Makro in einem Microsoft Access-Projekt (.adp) gebunden.

Einstellung

Die UniqueTable-Eigenschaft ist ein Zeichenfolgenausdruck, der für die aktualisierbare eindeutige Tabelle steht.

Sie können diese Eigenschaft im Eigenschaftenfenster oder in Visual Basic festlegen.

Anmerkungen

Die UniqueTable-Eigenschaft identifiziert die "n"-Tabelle einer Verknüpfung. Wenn Sie die UniqueTable-Eigenschaft nicht einstellen können, ist ein Formular schreibgeschützt, das an eine Ansicht, gespeicherte Prozedur oder SQL-Zeichenfolge gebunden ist, welche eine Verknüpfung enthält. Außerdem ist das mit View.Open bzw. StoredProc.Run erstellte Datenblatt im Fall einer Verknüpfung schreibgeschützt (da es hierbei keine Möglichkeit zum Festlegen der UniqueTable-Eigenschaft gibt). Sobald Sie die UniqueTable-Eigenschaft festgelegt haben, sind nur Felder aus dieser Tabelle aktualisierbar, und Einfüge- und Löschoperationen können nur an dieser Tabelle vorgenommen werden.

Ein Formular oder eine Datenzugriffsseite, das/die auf einem Verknüpfungscursor basiert, muss eine Zeichenfolge für die UniqueTable-Eigenschaft besitzen, damit die Datensatzgruppe ein aktualisierbarer Snapshot ist. Bei der eindeutigen Tabelle handelt es sich um diejenige Tabelle der zugrunde liegenden Abfrage, deren Zeilen mit denen im Cursor 1:1 übereinstimmen. In einer einfachen Verknüpfung "Patienten - Ärzte" ist Patienten die eindeutige Tabelle, da jede Zeile des Cursors einer Zeile der Tabelle Patienten entspricht. Beachten Sie, dass eine n:n-Verknüpfung keine gültige UniqueTable-Eigenschaft besitzt und somit schreibgeschützt ist. Die UniqueTable-Eigenschaft wird bei einer Datenzugriffsseite als RecordsetDef-Objekt offengelegt und dient folgenden Zwecken:

Erzwingen der richtigen Semantik für Aktualisierbarkeit:

  • Die Schlüsselspalten der eindeutigen Tabelle müssen in der Auswahlliste der den Cursor bildenden Abfrage vorhanden sein; dies gilt sogar für SQL Server. (Informationen zu anderen Datenquellen finden Sie im Abschnitt "Hinweis" des Themas ResyncCommand-Eigenschaft.)

  • Durch das Löschen einer Zeile in einem Verknüpfungscursor wird diese nur aus der eindeutigen Tabelle gelöscht.

  • Das Einfügen einer Zeile in einen Verknüpfungscursor ist nur für die eindeutige Tabelle zulässig

  • Das Aktualisieren einer Zeile in einem Verknüpfungscursor ist nur für Felder der eindeutigen Tabelle zulässig.

Bereitstellen der richtigen Parameterwerte für die Resync-Abfrage. Die UniqueTable-Eigenschaft eines Formulars oder eines RecordsetDef-Objekts unterstützt die Schreibweise catalog.owner.tablename, um eine Basistabelle bei Bedarf gegenüber anderen in demselben Cursor vollständig zu qualifizieren. Wenn beispielsweise dbo.Autoren mit einem Cursor zu Benutzer1.Autoren verknüpft wurde, muss die eindeutige Tabelle als dbo.Autoren bzw. Benutzer1.Autoren angegeben werden.

Ist bei einem Verknüpfungscursor die UniqueTable-Eigenschaft leer, wird die Datensatzgruppe auf "schreibgeschützt" zurückgesetzt, und bei jedem Bearbeitungsversuch wird ein Signalton mit der Statusmeldung "This Recordset is not updatable because the UniqueTable property is not set" ausgegeben. Wenn eine nicht leere UniqueTable-Eigenschaft vorliegt, stellen Sie diese (sowie bei Bedarf die UniqueSchema- und die UniqueCatalog-Eigenschaft) auf das zugrunde liegende Recordset- oder Rowset-Objekt ein. Anschließend durchlaufen und kennzeichnen Sie jede Spalte, die mit der UniqueTable-Eigenschaft nicht übereinstimmt, als "schreibgeschützt".

Bei Einfüge- und Aktualisierungsoperationen sind nur die Felder der eindeutigen Tabelle zum Bearbeiten verfügbar. Wenn der Benutzer versucht, Daten in diese Felder einzugeben, wird ein Signalton und die Meldung "Nur die Felder der eindeutigen Tabelle können bearbeitet werden." ausgegeben. Wurde die UniqueTable-Eigenschaft falsch eingestellt, so geschieht dies bei allen Spalten.

Einstellen von "UniqueTable" bei einer einzigen Tabelle

Bei einer Datensatzgruppe, die auf einer Ansicht oder einer SQL-Zeichenfolge basiert, sollen Spalten mit Serverausdrücken weiterhin mit eigenem Resync-Befehl bearbeitet werden können. Auch bei einer gespeicherten Prozedur möchte der Benutzer möglicherweise einen eigenen Resync-Befehl bereitstellen, sogar wenn nur eine einzige Tabelle vorliegt. Aus diesen Gründen sollte die UniqueTable-Eigenschaft bei einer einzigen Tabelle immer eingestellt werden. (QBU erlaubt das Einstellen eines Resync-Befehls nur, wenn UniqueTable eingestellt wurde.)


 UniqueValues-Eigenschaft (KeineDuplikate)

UniqueValues-Eigenschaft (KeineDuplikate)

Sie können die Eigenschaft UniqueValues verwenden, wenn Sie Datensätze ausschließen möchten, die mehrfach vorkommende Daten in den in der Datenblattansicht angezeigten Feldern enthalten. Enthält z.B. die Ausgabe einer Abfrage mehrere Felder, so muss die Kombination der Werte aller Felder für einen gegebenen Datensatz eindeutig sein, damit der Datensatz in die Ergebnisgruppe aufgenommen wird.

Anmerkung Die Eigenschaft UniqueRecords gilt nur für Anfüge- und Tabellenerstellungs-Aktionsabfragen und Auswahlabfragen.

Einstellung

Die Eigenschaft UniqueRecords verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Ja | Zeigt nur die Datensätze an, in denen die Werte aller in der Datenblattansicht angezeigten Felder eindeutig sind.
Nein | (Voreinstellung) Zeigt alle Datensätze an.

Sie können die UniqueValues-Eigenschaft im Abfrage-Eigenschaftenfenster oder in der SQL-Ansicht des Abfragefensters einstellen.

Anmerkung Sie stellen diese Eigenschaft ein, wenn Sie eine neue Abfrage mit Hilfe einer SQL-Anweisung erstellen. Das DISTINCT-Prädikat entspricht der Einstellung der UniqueValues-Eigenschaft. Das DISTINCTROW-Prädikat entspricht der Einstellung der UniqueRecords-Eigenschaft.

Anmerkung

Stellen Sie die Eigenschaft UniqueValues auf Ja ein, so können die Ergebnisse der Abfrage nicht aktualisiert werden, und nachfolgende Änderungen durch andere Benutzer werden nicht angezeigt.

Der Zusammenhang zwischen den Eigenschaften UniqueValues und UniqueRecords besteht darin, dass immer nur eine der beiden Eigenschaften auf Ja eingestellt werden kann. Stellen Sie z.B. die Eigenschaft UniqueValues auf Ja ein, so stellt Microsoft Access die Eigenschaft UniqueRecords automatisch auf Nein ein. Sie können jedoch beide Eigenschaften auf Nein einstellen. Sind beide Eigenschaften auf Nein eingestellt, werden alle Datensätze zurückgegeben.

Tipp Wenn Sie die Anzahl der Vorkommen eines Wertes in einem Feld zählen möchten, erstellen Sie eine Berechnungsabfrage.


 UpdateOptions-Eigenschaft

UpdateOptions-Eigenschaft

Mit der UpdateOptions-Eigenschaft können Sie angeben, wie ein verknüpftes OLE-Objekt aktualisiert wird.

Einstellung

Die UpdateOptions-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Automatisch | acOLEUpdateAutomatic (0) | (Standardeinstellung) Das Objekt wird bei jeder Änderung der verknüpften Daten aktualisiert.
Manuell | acOLEUpdateManual (2) | Das Objekt wird nur aktualisiert, wenn die Action-Eigenschaft des Steuerelements auf acOLEUpdate gesetzt ist oder die Verknüpfung mit dem Befehl OLE/DDE Links aus dem Menü Bearbeiten aktualisiert wird.

Sie können die UpdateOptions-Eigenschaft in einem Eigenschaftenfenster, einem Makro oder in Visual Basic einstellen. Sie können die Standardeinstellung für diese Eigenschaft mit den Standardeigenschafteneinstellungen eines Steuerelements oder der DefaultControl-Methode in Visual Basic einstellen.

Die Einstellung der UpdateOptions-Eigenschaft ist auch über den Befehl OLE/DDE-Verknüpfungen im Menü Bearbeiten verfügbar.

Anmerkung

Im Normalfall wird das Objekt mit jeder Änderung der verknüpften Daten automatisch aktualisiert. Sie können aber Microsoft Access anweisen, die Daten nur auf entsprechende Anweisung zu aktualisieren. Wenn z. B. andere Benutzer auf verknüpfte Tabellenkalkulationsdaten in einem Formular zugreifen oder diese ändern können, können Sie mit dieser Eigenschaft angeben, dass die verknüpften Daten nur aktualisiert werden, wenn die Datenbank im Einzelbenutzermodus geöffnet wird.

Wenn die UpdateOptions-Eigenschaft auf Manuell gesetzt ist, werden auf der Grundlage der Einstellung im Feld Intervall für Anzeigeaktualisierung auf der Registerkarte Weitere des Dialogfelds Optionen keine Aktualisierungen ausgeführt. Um dieses Dialogfeld anzuzeigen, klicken Sie im Menü Extras auf Optionen.

Anmerkung Wenn die Daten eines Objekts geändert werden, tritt das Ereignis Updated ein.

Im folgenden Beispiel wird die UpdateOptions-Eigenschaft für ein ungebundenes Objektfeld mit der Bezeichnung OLE1 auf manuelle Aktualisierung gesetzt. Anschließend wird die Eigenschaft Action verwendet, um eine Aktualisierung des OLE-Objekts im Steuerelement zu erzwingen.

OLE1.UpdateOptions = acOLEUpdateManual
OLE1.Action = acOLEUpdate


UseLongFileNames-Eigenschaft

Mit der UseLongFileNames-Eigenschaft können Sie angeben oder ermitteln, ob lange Dateinamen verwendet werden, wenn ein Dokument als Datenzugriffsseite gespeichert wird.

Einstellung

Die UseLongFileNames-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Lange Dateinamen werden möglichst immer verwendet, wenn das Dokument als Datenzugriffsseite gespeichert wird.
Nein | False (0) | Das DOS-Dateinamenformat (8.3) wird verwendet.

Die UseLongFileNames-Eigenschaft steht nur in Visual Basic zur Verfügung.

Anmerkungen

Wenn Sie keine langen Dateinamen verwenden und Hilfsdateien zur Datenzugriffsseite vorhanden sind, speichert Microsoft Access diese Dateien automatisch in einem separaten Ordner. Andernfalls ermitteln Sie mit Hilfe der OrganizeInFolder-Eigenschaft, ob Hilfsdateien in einem separaten Ordner gespeichert sind.


 UserControl-Eigenschaft

UserControl-Eigenschaft

Mit der Eigenschaft UserControl können Sie ermitteln, ob die aktuelle Microsoft Access-Anwendung von dem Benutzer oder über Automatisierung, früher OLE Automatisierung genannt, von einer anderen Anwendung gestartet wurde.

Einstellung

Die Eigenschaft UserControl kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True (-1) | Die aktuelle Anwendung wurde vom Benutzer gestartet.
False (0) | Die aktuelle Anwendung wurde von einer anderen Anwendung über Automatisierung gestartet.

Die Einstellung der Eigenschaft UserControl können Sie nur mit Visual Basic ermitteln.

Diese Eigenschaft ist in allen Ansichten schreibgeschützt, wenn der Benutzer die Anwendung Access startet. Wenn Microsoft Access über die OLE-Automatisierung gestartet wird, kann die UserControl-Eigenschaft in Visual Basic eingestellt werden.

Anmerkung

Wenn eine Anwendung vom Benutzer gestartet wurde, werden sowohl die Eigenschaft Visible als auch die Eigenschaft UserControl des Objekts Application auf True eingestellt. Wenn die Eigenschaft UserControl auf True eingestellt ist, kann die Eigenschaft Visible des Objekts nicht auf False eingestellt werden.

Wenn das Objekt Application über Automatisierung erstellt wurde, sind die Eigenschaften Visible und UserControl des Objekts auf False eingestellt.


 UseTransaction-Eigenschaft (TransaktionVerwenden)

UseTransaction-Eigenschaft (TransaktionVerwenden)

Mit der Eigenschaft UseTransaction können Sie angeben oder ermitteln, ob eine Aktionsabfrage als eine Transaktion ausgeführt wird. Es gibt Situationen, in denen Abfragen erheblich schneller ausgeführt werden, wenn diese Eigenschaft auf Nein eingestellt ist.

Einstellung

Die Eigenschaft UseTransaction verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Die Abfrage wird als eine Transaktion ausgeführt.
Nein | False (0) | Die Abfrage wird nicht als eine Transaktion ausgeführt.

Sie können die UseTransaction-Eigenschaft im Eigenschaftenfenster der Abfrage oder in Visual Basic festlegen. Um diese Eigenschaft in einer Microsoft Access-Datenbank (.mdb) mit Visual Basic festzulegen, müssen Sie sie zunächst zu einer Properties-Auflistung eines QueryDef-Objekts hinzufügen, indem Sie die CreateProperty-Methode verwenden.

Anmerkung

Wenn die Eigenschaft UseTransaction einer Tabellenerstellungsabfrage, Löschabfrage, Anfügeabfrage oder Aktualisierungsabfrage auf Ja eingestellt ist, speichert die Microsoft Jet-Datenbank-Engine die zurückgegebenen Datensätze in einem Cache-Speicher und, sofern erforderlich, die Ergebnisse auf der Festplatte in einer temporären Datenbank. Sobald die Abfrage beendet wurde, liest die Jet-Datenbank-Engine die Datensätze aus der temporären Datenbank und schreibt sie zurück in die ursprüngliche Datenbank.

Sie können das Leistungsverhalten bei entsprechenden Umständen erheblich verbessern, indem Sie die Eigenschaft UseTransaction auf Nein einstellen. Wenn die Eigenschaft UseTransaction auf Nein eingestellt ist, wird der Benutzer niemals auf Probleme stoßen, die ihre Ursache in zu vielen Sperranforderungen haben. Außerdem speichert die Jet-Datenbank-Engine die Ergebnisse einer Abfrage nicht in einer temporären Datenbank, wodurch sich eine erhebliche Verbesserung des Leistungsverhaltens ergibt.

Wird eine Abfrage als eine Transaktion ausgeführt, kann dies eine Verschlechterung des Leistungsverhaltens bewirken, wenn eine große Anzahl an Datensätzen in die temporäre Datenbank geschrieben wird. Wenn eine Lösch- oder Aktualisierungsabfrage in einer gemeinsam genutzten Datenbank ausgeführt wird, werden außerdem viele Sperranforderungen ausgelöst. Dies kann nicht nur ein schlechteres Leistungsverhalten zur Folge haben, sondern bei einigen Netzwerkbetriebssystemen (wie z.B. Netware) dazu führen, dass die Abfrage fehlschlägt, wenn mehr als 10.000 Sperranforderungen erforderlich sind.

Wenn eine Transaktion nicht erfolgreich beendet werden kann, wird eine Fehlermeldung angezeigt, und Sie haben die Möglichkeit, alle Änderungen zu speichern.

Wenn die UseTransaction-Eigenschaft auf Nein eingestellt ist, können Sie eine gesamte Transaktion nur dadurch zurücksetzen, dass Sie in Visual Basic die RollbackTrans-ADO-Methode bzw. die RollBack-DAO-Methode verwenden.


 ValidationRule-, ValidationText-Eigenschaften (Gültigkeitsregel, Gültigkeitsmeldung)

ValidationRule-, ValidationText-Eigenschaften (Gültigkeitsregel, Gültigkeitsmeldung)

Mit der Eigenschaft ValidationRule können Sie angeben, welche Anforderungen die Eingabedaten in einem Datensatz, Feld oder Steuerelement erfüllen müssen. Für den Fall, dass eingegebene Daten die mit der Eigenschaft ValidationRule festgelegten Regeln verletzen, können Sie mit der Eigenschaft ValidationText eine Meldung festlegen, die dem Benutzer angezeigt wird.

Anmerkung Die Eigenschaften ValidationRule und ValidationText gelten nicht für Kontrollkästchen-, Optionsfeld- und Umschaltfläche-Steuerelemente, die sich in einer Optionsgruppe befinden. Sie gelten nur für die Optionsgruppe selbst.

Einstellung

Geben Sie einen Ausdruck für die Einstellung der Eigenschaft ValidationRule und Text für die Einstellung der Eigenschaft ValidationText ein. Der Wert der Eigenschaft ValidationRule kann maximal 2048 Zeichen lang sein. Der Wert der Eigenschaft ValidationText kann maximal 255 Zeichen lang sein.

Für Steuerelemente können Sie die ValidationRule-Eigenschaft auf jeden gültigen Ausdruck festlegen. Bei Feld- und Datensatz-Gültigkeitsregeln darf der Ausdruck keine benutzerdefinierten Funktionen, Domänenaggregat- oder Aggregatfunktionen, die Eval-Funktion oder die CurrentUser-Methode sowie Verweise auf Formulare, Abfragen oder Tabellen enthalten. Außerdem dürfen Feld-Gültigkeitsregeln keine Verweise auf andere Felder enthalten. Bei Datensätzen können Ausdrücke Verweise auf Felder in derselben Tabelle enthalten.

Sie können die Eigenschaften ValidationRule und ValidationText wie folgt einstellen:

  • Im Bereich Feldeigenschaften der Tabellenentwurfsansicht (für Feld-Gültigkeitsregeln).

  • Im Eigenschaftenfenster einer Tabelle, indem Sie in der Tabellenentwurfsansicht im Menü Ansicht auf Eigenschaften klicken (für Datensatz-Gültigkeitsregeln).

  • Im Eigenschaftenfenster eines Steuerelements in einem Formular.

  • In einem Makro oder in Visual Basic. Verwenden Sie in Visual Basic einen Zeichenfolgenausdruck, um diese Eigenschaften einzustellen.

Für Tabellenfelder und Datensätze können Sie diese Eigenschaft in Visual Basic auch mit der DAO-Eigenschaft ValidationRule einstellen.

Anmerkung

Microsoft Access überprüft Werte automatisch daraufhin, ob sie mit dem Datentyp eines Feldes verträglich sind. Dadurch unterbindet Microsoft Access beispielsweise die Eingabe von Text in einem numerischen Feld. Genauere Regeln können Sie mit der Eigenschaft ValidationRule festlegen.

Wenn Sie die Eigenschaft ValidationRule einstellen, aber nicht die Eigenschaft ValidationText, zeigt Microsoft Access eine Standard-Fehlermeldung an, falls die Gültigkeitsregel verletzt wird. Stellen Sie dagegen die Eigenschaft ValidationText ein, so wird der von Ihnen eingegebene Text als Fehlermeldung angezeigt.

Wird z.B. ein Datensatz für einen neuen Angestellten hinzugefügt, so können Sie die Eigenschaft ValidationRule so einstellen, dass im Feld Startdatum des Angestellten nur Werte zwischen dem Gründungsdatum der Firma und dem heutigen Datum eingegeben werden können. Wenn sich das eingegebene Datum nicht in diesem Bereich befindet, können Sie mit der Eigenschaft ValidationText die Meldung "Startdatum ist falsch." ausgeben.

Wenn Sie ein Steuerelement durch Ziehen eines Feldes aus der Feldliste erstellen, bleibt die Feld-Gültigkeitsregel wirksam, obwohl sie im Eigenschaftenfenster im Einstellungsfeld der Eigenschaft ValidationRule des Steuerelements nicht angezeigt wird. Dies liegt daran, dass Feld-Gültigkeitsregeln von dem Steuerelement übernommen werden, das an das Feld gebunden ist.

Gültigkeitsregeln für Steuerelemente, Felder und Datensätze werden wie folgt angewendet:

  • Gültigkeitsregeln für Felder und Steuerelemente werden angewendet, wenn Sie die Daten bearbeiten und das Feld oder Steuerelement den Fokus abgibt.

  • Gültigkeitsregeln für Datensätze werden angewendet, wenn Sie zu einem anderen Datensatz wechseln.

  • Wenn Sie Gültigkeitsregeln für ein Feld und für ein Steuerelement erstellen, das an dieses Feld gebunden ist, werden beide Gültigkeitsregeln angewendet, wenn Sie Daten bearbeiten und das Steuerelement den Fokus abgibt.

Die folgende Tabelle enthält Beispiele für Ausdrücke, die in den Eigenschaften ValidationRule und ValidationText angegeben werden können.

ValidationRule | ValidationText
<> 0 | Eingabewert muss ungleich Null sein.
> 1000 Or Is Null | Eingabe muss leer oder größer als 1000 sein.
Like "A????" | Eingabe muss 5 Zeichen lang sein und mit dem Buchstaben A beginnen.
>= #1/1/96# And <#1/1/97# | Eingabe muss ein Datum im Jahr 1996 sein.
DLookup("[Kunden-Code]", "Kunden", "[Kunden-Code] = Formulare![Kunden]![Kunden-Code]") Is Null | Eingabe muss eindeutiger Kunden-Code sein (Domänenaggregatfunktionen sind nur für Gültigkeitsüberprüfungen auf Formularebene zulässig).

Wenn Sie eine Gültigkeitsregel für ein Feld erstellen, lässt Microsoft Access normalerweise nicht zu, dass ein Null-Wert in dem Feld gespeichert wird. Sollen Null-Werte gespeichert werden können, so fügen Sie der Gültigkeitsregel Ist Null hinzu, wie z.B. in "<> 8 Oder Ist Null". Stellen Sie außerdem sicher, dass die Eigenschaft Required auf Nein eingestellt ist.

Sie können Feld- oder Datensatz-Gültigkeitsregeln nicht für Tabellen einstellen, die nicht mit Microsoft Access (sondern z.B. mit dBASE, Paradox oder SQL Server) erstellt wurden. Bei derartigen Tabellen können Sie Gültigkeitsregeln nur für Steuerelemente erstellen.


 Value-Eigenschaft (Wert) (Microsoft Access)

Value-Eigenschaft (Wert) (Microsoft Access)

Mit der Value-Eigenschaft können Sie ermitteln oder angeben, ob ein Steuerelement aktiviert bzw. gewählt ist, welcher Wert oder welche Option innerhalb des Steuerelements ausgewählt ist, welcher Text in einem Textfeld-Steuerelement enthalten ist oder wie der Wert einer benutzerdefinierten Eigenschaft lautet.

  • Kontrollkästchen-, Optionsfeld- und Umschaltfläche-Steuerelement. Ermittelt oder gibt an, ob das Steuerelement aktiviert bzw. gewählt ist oder nicht.

  • Kombinationsfeld-, Listenfeld- und Optionsgruppe-Steuerelement. Ermittelt oder gibt an, welcher Wert oder welche Option im Steuerelement ausgewählt ist.

  • Textfeld-Steuerelement. Ermittelt den Text im Textfeld oder gibt ihn an.

  • Registersteuerelement. Ermittelt das ausgewählte Page-Objekt oder gibt es an.

  • Eingebaute Eigenschaften. Ermittelt den Wert einer eingebauten Eigenschaft eines AccessObject-Objekts oder gibt ihn an.

Einstellung

Die Value-Eigenschaft verwendet die folgende Einstellung (abhängig vom angegebenen Steuerelement).

Steuerelement | Einstellung | Beschreibung | Visual Basic
Kontrollkästchen | True False | Das Kontrollkästchen ist aktiviert. (Standardeinstellung) Das Kontrollkästchen ist deaktiviert. | True (-1) False (0)
Kombinationsfeld | [Der Text im Textfeldbereich des Steuerelements] | Dies kann der Einstellung der Text-Eigenschaft des Steuerelements entsprechen (muss es aber nicht). Die aktuelle Einstellung der Text-Eigenschaft entspricht dem im Textfeldbereich des Kombinationsfeldes angezeigten Wert. Die Value-Eigenschaft wird nur dann auf die Einstellung der Text-Eigenschaft eingestellt, wenn dieser Text gespeichert wird. |
Listenfeld | [Der Wert des Listenfeldeintrags] | Der Wert in der gebundenen Spalte für den in der Liste ausgewählten Eintrag. |
Optionsfeld | True False | Das Optionsfeld ist gewählt. (Standardeinstellung) Das Optionsfeld ist nicht gewählt. | True False
Optionsgruppe | [Die Einstellung der OptionValue-Eigenschaft] | Die Einstellung der OptionValue-Eigenschaft für das gewählte Steuerelement in der Gruppe |
Textfeld | [Der Wert der Text-Eigenschaft des Steuerelements] | Die Text-Eigenschaft gibt die formatierte Zeichenfolge zurück. Die Einstellung dieser Eigenschaft kann sich von der Einstellung der Value-Eigenschaft für ein Textfeld-Steuerelement unterscheiden. Die Text-Eigenschaft entspricht dem aktuellen Inhalt des Steuerelements. Die Value-Eigenschaft entspricht dem gespeicherten Wert des Textfeld-Steuerelements. Die Text-Eigenschaft ist immer dann aktuell, wenn das Steuerelement den Fokus hat. |
Umschaltfläche | True False | Die Umschaltfläche ist gewählt (gedrückt). Die Umschaltfläche ist nicht gewählt (nicht gedrückt). | True False
Registersteuerelement | [Ein Wert vom Typ Integer, der die Indexnummer des momentan ausgewählten Page-Objekts darstellt] | Die Value-Eigenschaft eines Registersteuerelements enthält die Indexnummer des aktuellen Page-Objekts. Jedes Register in einem Registersteuerelement hat ein Page-Objekt. Das erste Page-Objekt weist immer die Indexnummer 0 auf, das zweite die Indexnummer 1 usw. |
Gebundenes Objektfeld- oder Diagramm-Steuerelement |  | Die Value-Eigenschaft für ein gebundenes Objektfeld- oder ein gebundenes Diagramm-Steuerelement wird auf den Wert des Feldes eingestellt, an das das Steuerelement gebunden ist. Da diese Felder normalerweise OLE-Objekte oder Diagrammobjekte enthalten, die als Binärdaten gespeichert werden, ist dieser Wert normalerweise ohne Bedeutung. |
ActiveX-Steuerelement |  | Einige ActiveX-Steuerelemente unterstützen die Value-Eigenschaft. Die Einstellung der Value-Eigenschaft eines Kalender-Steuerelements ist beispielsweise das momentan ausgewählte Datum im Steuerelement. Weitere Informationen finden Sie im Handbuch zu dem jeweiligen ActiveX-Steuerelement. |
Benutzerdefinierte Eigenschaften | Ein Ausdruck vom Typ Long oder ein Zeichenfolgenausdruck, der für den Wert der benutzerdefinierten Eigenschaft steht | Die Value-Eigenschaft einer benutzerdefinierten Eigenschaft enthält den Wert der angegebenen benutzerdefinierten Eigenschaft eines AccessObject-Objekts. Weitere Informationen über benutzerdefinierte Eigenschaften finden Sie in den Themen zum AccessObject-Objekt, zum AccessObjectProperty-Objekt und zur AccessObjectProperties-Auflistung. |

Sie können diese Eigenschaft in einem Makro oder in Visual Basic einstellen.

Anmerkung

  • Die Value-Eigenschaft gibt die Standardeigenschaft eines Steuerelements zurück oder stellt sie ein, also die Eigenschaft, die angenommen wird, wenn Sie keinen Eigenschaftsnamen explizit angeben. Da der Standardwert des Textfeldes dem Wert der Text-Eigenschaft entspricht, können Sie im folgenden Beispiel auf die Einstellung der Text-Eigenschaft verweisen, ohne den Namen der Eigenschaft explizit anzugeben.
    Formulare!frmKunden!txtNachname = "Schmidt"

Dies bedeutet, dass die beiden folgenden Anweisungen gleichwertig sind.

Formulare!frmKunden!optKreditOK.Value = True
Formulare!frmKunden!optKreditOK = True

Anmerkung Die Value-Eigenschaft entspricht nicht der DefaultValue-Eigenschaft. Diese gibt den Wert an, der einer Eigenschaft beim Erstellen eines neuen Datensatzes zugewiesen wird.

  • Die Value-Eigenschaft kann auch die Standardeigenschaft einer benutzerdefinierten Eigenschaft zurückgeben oder einstellen, also die Eigenschaft, die angenommen wird, wenn Sie keinen Eigenschaftsnamen explizit angeben. Dies bedeutet, dass die beiden folgenden Anweisungen gleichwertig sind.
    CurrentProject.AllFormulare!optKreditOK.Value = True
CurrentProject.AllFormulare!optKreditOK = True


 VBE-Eigenschaft (Microsoft Access)

VBE-Eigenschaft (Microsoft Access)

Mit der VBE-Eigenschaft können Sie einen Verweis auf das aktuelle VBE-Objekt und dessen Eigenschaften zurückgeben. Die Eigenschaft VBE des Application-Objekts stellt den Editor von Microsoft Visual Basic für Applikationen dar.

Einstellung

[Anwendung.]VBE[.Eigenschaft]

Die Eigenschaft VBE verwendet die folgenden Einstellungen.

Einstellung | Beschreibung
Anwendung | Optional. Das Application-Objekt.
VBE | Erforderlich. Bei Verwendung ohne Angabe einer Eigenschaft wird das VBE-Objekt zurückgegeben.
Eigenschaft | Eine Eigenschaft des VBE-Objekts.

Die VBE-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Wenn Sie einen Verweis auf das VBE-Objekt eingerichtet haben, können Sie auf alle Eigenschaften und Methoden des Objekts zugreifen. Um einen Verweis auf das VBE-Objekt zu erstellen, klicken Sie im Menü Extras auf Verweise, während Sie sich im Modul Entwurfsansicht befinden. Erstellen Sie anschließend im Dialogfeld Verweise einen Verweis auf die Objektbibliothek von Microsoft Visual Basic für Applikationen Extensibility 5.3. Aktivieren Sie dazu das entsprechende Kontrollkästchen. Microsoft Access kann diesen Verweis für Sie erstellen, wenn Sie eine Konstante der Objektbibliothek von Microsoft Visual Basic für Applikationen Extensibility 5.3 verwenden, um die VBE-Eigenschaft eines Objekts festzulegen oder als Argument für die VBE-Methode eines Objekts.


 Verb-Eigenschaft

Verb-Eigenschaft

Mit der Eigenschaft Verb können Sie den Vorgang angeben, der ausgeführt werden soll, wenn ein OLE-Objekt aktiviert wurde, indem die Eigenschaft Action des zugehörigen Steuerelements auf acOLEActivate eingestellt wurde.

Einstellung

Sie stellen die Eigenschaft Verb ein, indem Sie einen Wert des Datentyps Integer angeben, der die Position angibt, die ein Verb in der Liste der Verben einnimmt, die von der Eigenschaft ObjectVerbs zurückgegeben wird. Sie können die Eigenschaft Verb auf 1 einstellen, um das erste Verb der Liste anzugeben, Sie können die Eigenschaft auf 2 einstellen, um das zweite Verb der Liste anzugeben, usw.

Sie können die Eigenschaft Verb im Eigenschaftenfenster des Steuerelements, in einem Makro oder in Visual Basic einstellen. Die Standardeinstellung dieser Eigenschaft können Sie mit Hilfe der Standardeigenschafteneinstellungen oder in Visual Basic mit der Methode DefaultControl einstellen.

Wenn Sie nicht die Eigenschaft ObjectVerbs verwenden, um ein bestimmtes Verb anzugeben, können Sie die Eigenschaft Verb auf einen der folgenden Werte einstellen, um den auszuführenden Vorgang anzugeben. Diese Werte entsprechen den Standardverben, die von allen Objekten unterstützt werden.

Konstante | Beschreibung
acOLEVerbPrimary (0) | Führt den Standardvorgang des Objekts aus.
acOLEVerbShow (-1) | Aktiviert das Objekt zum Bearbeiten.
acOLEVerbOpen (-2) | Öffnet das Objekt in einem eigenen Anwendungsfenster.
acOLEVerbHide (-3) | Blendet bei einem eingebetteten Objekt die Anwendung aus, mit der das Objekt erstellt wurde.

Für Objekte einiger Anwendungen können Sie auch die folgenden Werte verwenden.

Konstante | Beschreibung
acOLEVerbInPlaceUIActivate (-4) | Aktiviert das Objekt zur Bearbeitung innerhalb des Steuerelements. Die Menüs und Symbolleisten des OLE-Servers werden auch im OLE-Container zur Verfügung gestellt.
acOLEVerbInPlaceActivate (-5) | Aktiviert das Objekt innerhalb des Steuerelements. Die Menüs und Symbolleisten des OLE-Servers sind im OLE-Container nicht verfügbar.

Anmerkung

Jedes Objekt unterstützt eine eigene Gruppe von Verben. Viele Objekte unterstützen z. B. die Verben Bearbeiten und Abspielen. Mit den Eigenschaften ObjectVerbs und ObjectVerbsCount können Sie ermitteln, welche Verben von einem Objekt unterstützt werden.

Microsoft Access verwendet automatisch das Standardverb eines Objekts, wenn der Benutzer auf ein Objekt doppelklickt, dessen Eigenschaft AutoActivate auf Doppelklicken eingestellt ist.


Vertical-Eigenschaft (Vertikal)

Mit der Vertical-Eigenschaft können Sie ein Formular-Steuerelement für vertikale Anzeige und Bearbeitung oder ein Bericht-Steuerelement für vertikale Anzeige und vertikales Drucken einstellen.

Einstellungen

Die Eigenschaft Vertical verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | Vertikaler Text kann angezeigt, bearbeitet und gedruckt werden.
Nein | False (0) | Vertikaler Text kann nicht angezeigt, bearbeitet oder gedruckt werden. (Standardeinstellung)

Sie können die Vertical-Eigenschaft im Eigenschaftenfenster, in einem Makro oder in Visual Basic einstellen.

Anmerkung

Sie können angeben, wie vertikaler Text im Steuerelement angezeigt, bearbeitet oder gedruckt werden soll, indem Sie die Vertical-Eigenschaft einstellen. Wenn sie auf Ja eingestellt wird, befindet sich der Anfangspunkt für die Texteingabe in der oberen rechten Ecke des Steuerelements (und der Endpunkt in der unteren linken Ecke). Bei der Verwendung von Zeichen mit voller Schriftbreite sind Anzeige- und Druckrichtung identisch mit derjenigen des Steuerelements für horizontalen Text. Bei der Verwendung von Zeichen mit halber Schriftbreite wird die Richtung um 90° nach rechts gedreht. Der Cursor wird in einem Steuerelement für vertikalen Text ebenfalls um 90° nach rechts gedreht.

Anmerkung Die Textmarkierung mit Tastenkombinationen ist bei einem Steuerelement für vertikalen Text und einem Steuerelement für horizontalen Text unterschiedlich. Tastenkombinationen und ihre Wirkung auf die Bereichsmarkierung werden nachstehend beschrieben.

Tastenkombination | Markierter Bereich
UMSCHALT+NACH-OBEN | Vertikal: Ein Zeichen vor dem Cursor. Horizontal: Eine Zeile vor dem Cursor.
UMSCHALT+NACH-UNTEN | Vertikal: Ein Zeichen hinter dem Cursor. Horizontal: Eine Zeile hinter dem Cursor.
UMSCHALT+NACH-RECHTS | Vertikal: Eine Zeile hinter dem Cursor. Horizontal: Ein Zeichen vor dem Cursor.
UMSCHALT+NACH-LINKS | Vertikal: Eine Zeile vor dem Cursor. Horizontal: Ein Zeichen hinter dem Cursor.


 Visible-Eigenschaft (Application-Objekt)

Visible-Eigenschaft (Application-Objekt)

Mit der Eigenschaft Visible eines Application-Objekts können Sie angeben bzw. ermitteln, ob die entsprechende Microsoft Access-Anwendung minimiert ist.

Einstellung

Die Eigenschaft Visible kann eine der folgenden Einstellungen annehmen.

Einstellung | Beschreibung
True (-1) | Die Anwendung ist sichtbar.
False (0) | Die Anwendung ist nicht sichtbar.

Die Eigenschaft Visible eines Application-Objekts können Sie nur mit Visual Basic einstellen. Sie können die Standardeinstellung für diese Eigenschaft mit den Standardeigenschafteneinstellungen des Steuerelements oder der Methode DefaultControl in Visual Basic einstellen

Anmerkung

Wenn eine Anwendung vom Benutzer gestartet wurde, werden sowohl die Eigenschaft Visible als auch die Eigenschaft UserControl des Objekts Application auf True eingestellt. Wenn die Eigenschaft UserControl auf True eingestellt ist, kann die Eigenschaft Visible des Objekts nicht auf False eingestellt werden.

Wenn das Objekt Application über Automatisierung (früher OLE-Automatisierung genannt) erstellt wurde, sind die Eigenschaften Visible und UserControl des Objekts auf False eingestellt.

Anmerkung Ist die Eigenschaft Visible eines Application-Objekts auf False eingestellt, ist die Anwendung zwar minimiert, aber nicht für den Benutzer ausgeblendet.


 Visible-Eigenschaft (Sichtbar) (Microsoft Access)

Visible-Eigenschaft (Sichtbar) (Microsoft Access)

Mit der Visible-Eigenschaft können Sie ein Formular, einen Bericht, den Bereich eines Formulars oder Berichts, eine Datenzugriffsseite oder ein Steuerelement einblenden oder ausblenden. Diese Eigenschaft bietet sich an, wenn Sie den Zugriff auf Informationen in einem Formular verwalten möchten, ohne dass das Formular sichtbar sein soll. Sie könnten z. B. den Wert eines Steuerelements auf einem verborgenen Formular als Kriterium für eine Abfrage verwenden.

Einstellung

Die Visible-Eigenschaft verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | (Standardeinstellung) Das Objekt ist sichtbar.
Nein | False (0) | Das Objekt ist nicht sichtbar.

Sie können diese Eigenschaft über das Eigenschaftenfenster des Objekts (für Bereiche und alle Steuerelemente, mit Ausnahme von Seitenwechseln), ein Makro oder in Visual Basic einstellen.

Für Formulare, Berichte und Datenzugriffsseiten müssen Sie diese Eigenschaft mit einem Makro oder in Visual Basic einstellen.

Für Steuerelemente können Sie die Standardeinstellung für diese Eigenschaft mit den Standardeigenschafteneinstellungen eines Steuerelements oder der DefaultControl-Methode in Visual Basic einstellen.

Anmerkung

Die Visible-Eigenschaft wirkt sich nicht auf Spalten in der Datenblattansicht aus. Um anzugeben, ob eine Spalte in der Datenblattansicht sichtbar sein soll, verwenden Sie die ColumnHidden-Eigenschaft.

Zum Ausblenden eines Objekts während des Druckens verwenden Sie die DisplayWhen-Eigenschaft.

Mit der Visible-Eigenschaft können Sie ein Steuerelement auf einem Formular oder Bericht ausblenden, indem Sie die Eigenschaft in ein Makro oder eine Ereignisprozedur aufnehmen, das bzw. die ausgeführt wird, wenn das Current-Ereignis eintritt. So können Sie z. B. in Abhängigkeit vom Gesamtumsatz den Glückwunsch an eine Vertriebsmitarbeiterin neben dem monatlichen Gesamtumsatz anzeigen oder verbergen.

Anmerkung Es gibt auch eine Visible-Eigenschaft für das Application-Objekt. Damit kann die Anwendung verborgen werden. Diese Eigenschaft kann nur in Visual Basic festgelegt werden.


 WebOptions-Eigenschaft

WebOptions-Eigenschaft

Mit der WebOptions-Eigenschaft können Sie auf das WebOptions-Objekt und dessen zugehörige Eigenschaften verweisen.

Einstellung

Die WebOptions-Eigenschaft steht in Visual Basic zur Verfügung und ist schreibgeschützt.

Anmerkungen

Verwenden Sie die Eigenschaften des WebOptions-Objekts, um Weboptionen für die aktive Datenzugriffsseite einzustellen.


 WhatsThisButton-Eigenschaft (SchaltflächeDirekthilfe)

WhatsThisButton-Eigenschaft (SchaltflächeDirekthilfe)

Mit der Eigenschaft WhatsThisButton können Sie angeben, ob zu der Titelleiste eines Formulars eine Direkthilfe-Schaltfläche [image] hinzugefügt werden soll.

Anmerkung Sie können eine Direkthilfe-Schaltfläche nur dann in der Titelleiste eines Formulars anzeigen, wenn die Eigenschaft MinMaxButtons auf Keine eingestellt ist.

Einstellung

Die Eigenschaft WhatsThisButton verwendet die folgenden Einstellungen.

Einstellung | Visual Basic | Beschreibung
Ja | True (-1) | In der Titelleiste wird eine Direkthilfe-Schaltfläche angezeigt.
Nein | False (0) | (Standardeinstellung) In der Titelleiste wird keine Direkthilfe-Schaltfläche angezeigt.

Sie können die Eigenschaft WhatsThisButton im Eigenschaftenfenster des Formulars, in einem Makro oder in Visual Basic einstellen.

Diese Eigenschaft kann nur in der Formularentwurfsansicht eingestellt werden.

Anmerkung

Sobald in der Titelleiste eines Formulars auf die Direkthilfe-Schaltfläche geklickt wurde, wird der Fragezeichen-Mauszeiger angezeigt. Mit diesem Mauszeiger können Sie auf ein Steuerelement klicken, um auf dessen benutzerdefiniertes Hilfethema zuzugreifen, das in der Eigenschaft HelpContextID des Steuerelements angegeben ist. Wenn es kein benutzerdefiniertes Hilfethema für das Steuerelement gibt, wird das benutzerdefinierte Hilfethema des Formulars angezeigt. Wenn es weder für das Formular noch für das Steuerelement ein benutzerdefiniertes Hilfethema gibt, wird die Microsoft Access-Hilfe angezeigt.


WillContinue-Eigenschaft

Mit der WillContinue-Eigenschaft können Sie ermitteln, ob der aktuelle Bereich auf der nächsten Seite fortgesetzt wird.

Einstellung

Die WillContinue-Eigenschaft wird durch Microsoft Access festgelegt und ist in allen Ansichten schreibgeschützt.

Wert | Beschreibung
True (-1) | Der aktuelle Bereich wird auf der folgenden Seite fortgesetzt.
False (0) | Der aktuelle Bereich wird nicht auf der folgenden Seite fortgesetzt.

Sie können den Wert der WillContinue-Eigenschaft mit einem Makro oder in Visual Basic ermitteln.

Anmerkung

Mit dieser Eigenschaft können Sie ermitteln, ob bestimmte Steuerelemente, je nach dem Wert der Eigenschaft, angezeigt oder verborgen werden sollen. So verfügen Sie z. B. über eine verborgene Beschriftung in der Kopfzeile einer Seite mit dem Text "Fortsetzung auf der nächsten Seite". Wenn der Wert der Eigenschaft WillContinue auf True gesetzt wurde, können Sie die verborgene Beschriftung sichtbar machen.


 WindowHeight, WindowWidth-Eigenschaften (FensterHöhe, Fensterbreite)

WindowHeight, WindowWidth-Eigenschaften (FensterHöhe, Fensterbreite)

Sie können diese Eigenschaften verwenden, um die Höhe und Breite eines Formulars oder einer Datenzugriffsseite in Twips zurückzugeben.

Einstellung

Die Einstellungen der Eigenschaft WindowHeight und WindowWidth sind Werte vom Typ Integer.

Diese Eigenschafteneinstellungen sind schreibgeschützt und nur in einem Makro oder in Visual Basic verfügbar.

Anmerkung

Die Eigenschaft WindowHeight wird von der oberen linken Ecke des Formulars oder der Datenzugriffsseite zur unteren linken Ecke gemessen. Die Eigenschaft WindowWidth wird von der oberen linken Ecke des Formulars oder der Datenzugriffsseite zur oberen rechten Ecke gemessen.


 Zoom-Eigenschaft

Zoom-Eigenschaft

Mit der Zoom-Eigenschaft können Sie den Anzeigestatus für einen Snapshot angeben oder ermitteln.

Einstellung

Die Zoom-Eigenschaft ist ein Integer-Wert zwischen 0 und 8, der den Anzeigestatus für eine Snapshot-Seite als Prozentsatz der tatsächlichen Seitengröße angibt.

Konstante | Beschreibung
snapZoomToFit | (Standardeinstellung) Die Seite wird auf die volle Größe gezoomt.
snapZoomToFill | Die Seite wird auf den verfügbaren Platz im Steuerelement gezoomt.
snapZoom200Percent | Die Seite wird mit dem Faktor 200% gezoomt.
snapZoom150Percent | Die Seite wird mit dem Faktor 150% gezoomt.
snapZoom100Percent | Die Seite wird mit dem Faktor 100% gezoomt.
snapZoom75Percent | Die Seite wird mit dem Faktor 75% gezoomt.
snapZoom50Percent | Die Seite wird mit dem Faktor 50% gezoomt.
snapZoom25Percent | Die Seite wird mit dem Faktor 25% gezoomt.
snapZoom10Percent | Die Seite wird mit dem Faktor 10% gezoomt.

Sie können die Zoom-Eigenschaft mit dem Eigenschaftenfenster des Steuerelements oder in Visual Basic einstellen.

Wenn Sie diese Eigenschaft auf einen ungültigen Wert setzen, tritt ein Fehler auf.

Anmerkung

Wenn die AllowContextMenu-Eigenschaft auf Ja gesetzt ist, können Sie die Zoom-Eigenschaft auch über das Popup-Menü des Steuerelements festlegen.


Verzeichnis der Anweisungen

Das folgende Verzeichnis listet alle Anweisungen (mit Ausnahme der SQL-Anweisungen) in alphabetischer Reihenfolge auf.

A-M

AppActivate (VBA) | DeleteControl
Beep (VBA) | DeleteReportControl
Call (VBA) | DeleteSetting (VBA)
ChDir (VBA) | Dim (VBA)
ChDrive (VBA) | Do...Loop (VBA)
Close (VBA) | End (VBA)
Const (VBA) | Erase (VBA)
Date (VBA) | Error (VBA)
DDE | Exit (VBA)
DDEExecute | FileCopy (VBA)
DDEPoke | For Each...Next (VBA)
DDETerminate | For...Next (VBA)
DDETerminateAll | Function (VBA)
Declare (VBA) | Get (VBA)
DefBool (VBA) | GoSub...Return (VBA)
DefByte (VBA) | GoTo (VBA)
DefCur (VBA) | If...Then...Else (VBA)
DefDate (VBA) | Input # (VBA)
DefDbl (VBA) | Kill (VBA)
DefInt (VBA) | Let (VBA)
DefLng (VBA) | Line Input # (VBA)
DefObj (VBA) | Lock (VBA)
DefSng (VBA) | LSet (VBA)
DefStr (VBA) | Mid (VBA)
DefType (VBA) | MidB (VBA)
DefVar (VBA) | MkDir (VBA)

N-Z

Name (VBA) | Resume (VBA)
On Error (VBA) | Return (VBA)
On...GoSub (VBA) | RmDir (VBA)
On...GoTo (VBA) | RSet (VBA)
Open (VBA) | SaveSetting (VBA)
Option Base (VBA) | Seek (VBA)
Option Compare (VBA) | SelectCase (VBA)
Option Explicit (VBA) | SendKeys (VBA)
Option Private (VBA) | Set (VBA)
Print # (VBA) | SetAttr (VBA)
Private (VBA) | Static (VBA)
Property Get (VBA) | Stop (VBA)
Property Let (VBA) | Sub (VBA)
Property Set (VBA) | Time (VBA)
Public (VBA) | Type (VBA)
Put (VBA) | Unlock (VBA)
Randomize (VBA) | While...Wend (VBA)
ReDim (VBA) | Width # (VBA)
Rem (VBA) | With (VBA)
Reset (VBA) | Write # (VBA)


 DDEExecute-Anweisung

DDEExecute-Anweisung

Mit der Anweisung DDEExecute können Sie einen Befehl von einer Client-Anwendung über einen geöffneten DDE-Kanal (DDE= dynamischer Datenaustausch) an eine Server-Anwendung senden.

Angenommen, Sie haben einen DDE-Kanal in Microsoft Access geöffnet, um Textdaten einer Microsoft Excel-Tabelle in eine Microsoft Access-Datenbank zu übertragen. Verwenden Sie die Anweisung DDEExecute, um den Befehl Neu an Microsoft Excel zu senden, mit dem Sie angeben, dass Sie eine neue Tabelle anlegen möchten. In diesem Beispiel dient Microsoft Access als Client-Anwendung und Microsoft Excel als Server-Anwendung.

Syntax

DDEExecute Kanalnummer, Befehl

Die Anweisung DDEExecute verwendet die folgenden Argumente:

Argument | Beschreibung
Kanalnummer | Eine Kanalnummer, die lange Ganzzahl, die von der Funktion DDEInitiate zurückgegeben wird.
Befehl | Ein Zeichenfolgenausdruck, der einen Befehl angibt, den die Server-Anwendung erkennt. In der Dokumentation der Server-Anwendung finden Sie eine Liste dieser Befehle.

Anmerkung

Der Wert des Arguments Befehl ist abhängig von der Anwendung und dem Thema, die beim Öffnen des Kanals Kanalnummer angegeben wurden. Wenn Kanalnummer keine Ganzzahl ist, die einem geöffneten Kanal entspricht, oder wenn die andere Anwendung den genannten Befehl nicht ausführen kann, tritt ein Fehler auf.

Von Visual Basic aus können Sie die Anweisung DDEExecute nur verwenden, um Befehle an eine andere Anwendung zu senden. Weitere Informationen über das Senden von Befehlen an Microsoft Access aus einer anderen Anwendung finden Sie unter Verwenden von Microsoft Access als DDE-Server.

Tipp Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


 DDEPoke-Anweisung

DDEPoke-Anweisung

Mit der Anweisung DDEPoke können Sie über einen geöffneten DDE-Kanal (DDE = dynamischer Datenaustausch) Textdaten aus einer Client-Anwendung an eine Server-Anwendung senden.

Wenn z. B. ein offener DDE-Kanal zwischen Microsoft Access und Microsoft Excel existiert, können Sie mit der Anweisung DDEPoke Text von einer Microsoft Access-Datenbank in eine Microsoft Excel-Tabelle übertragen. In diesem Beispiel dient Microsoft Access als Client-Anwendung und Microsoft Excel als Server-Anwendung.

Syntax

DDEPoke Kanalnummer, Element, Daten

Die Anweisung DDEPoke verwendet die folgenden Argumente:

Argument | Beschreibung
Kanalnummer | Eine Kanalnummer, eine Ganzzahl, die von der Funktion DDEInitiate zurückgegeben wird.
Element | Ein Zeichenfolgenausdruck, der den Namen eines Datenelements darstellt, das von der durch die Funktion DDEInitiate angegebenen Anwendung erkannt wird. In der Dokumentation der Anwendung finden Sie eine Liste der möglichen Elemente.
Daten | Eine Zeichenfolge, welche die Daten enthält, die an die andere Anwendung gesendet werden.

Anmerkung

Der Wert des Arguments Element ist abhängig von der beim Öffnen des Kanals Kanalnummer angegebenen Anwendung und dem angegebenen Thema. Element kann z. B. einen Bereich von Zellen in einer Microsoft Excel-Tabelle darstellen.

Bei der Zeichenfolge, die das Argument Daten darstellt, muss es sich um eine alphanumerische Textzeichenfolge handeln. Andere Formate werden nicht unterstützt. Daten könnte z. B. eine Zahl sein, die in eine Zelle in einem bestimmten Bereich einer Microsoft Excel-Tabelle eingetragen werden soll.

Wenn Kanalnummer keine Ganzzahl ist, die einem geöffneten Kanal entspricht, oder wenn die andere Anwendung die angegebenen Daten nicht erkennt oder akzeptiert, tritt ein Laufzeitfehler auf.

Tipp Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


 DDETerminate-Anweisung

DDETerminate-Anweisung

Mit der Anweisung DDETerminate können Sie einen angegebenen DDE-Kanal (DDE = dynamischer Datenaustausch) schließen.

Wenn Sie z. B. einen DDE-Kanal zur Datenübertragung zwischen Microsoft Excel und Microsoft Access geöffnet haben, können Sie die Anweisung DDETerminate zum Schließen dieses Kanals verwenden, nachdem die Übertragung beendet ist.

Syntax

DDETerminate Kanalnummer

Anmerkung

Das Argument Kanalnummer gibt die Kanalnummer des zu schließenden Kanals an. Es verweist auf einen mit der Funktion DDEInitiate geöffneten Kanal. Wenn Kanalnummer keine Ganzzahl ist, die der Nummer eines geöffneten Kanals entspricht, tritt ein Laufzeitfehler auf.

Sobald ein Kanal geschlossen ist, tritt bei allen nachfolgenden DDE-Funktionen oder -Anweisungen, die auf diesen Kanal zugreifen, ein Laufzeitfehler auf.

Die Anweisung DDETerminate hat keine Auswirkung auf aktive DDE-Verknüpfungsausdrücke in Feldern von Formularen oder Berichten.

Tipp Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


 DDETerminateAll-Anweisung

DDETerminateAll-Anweisung

Mit der Anweisung DDETerminateAll können Sie alle geöffneten DDE-Kanäle (DDE = dynamischer Datenaustausch) schließen.

Wenn Sie z. B. zwei DDE-Kanäle zwischen Microsoft Excel und Microsoft Access geöffnet haben, einen zum Abrufen von Systeminformationen über Microsoft Excel und einen zum Übertragen von Daten, dann können Sie mit der Anweisung DDETerminateAll beide Kanäle gleichzeitig schließen.

Syntax

DDETerminateAll

Anmerkung

Das Verwenden der Anweisung DDETerminateAll entspricht dem Ausführen der Anweisung DDETerminate für alle geöffneten Kanalnummern. Ähnlich wie DDETerminate hat auch die Anweisung DDETerminateAll keinen Einfluss auf aktive DDE-Verknüpfungsausdrücke in Feldern von Formularen oder Berichten.

Die Anweisung DDETerminateAll löst keinen Laufzeitfehler aus, wenn bei der Ausführung keine DDE-Kanäle geöffnet sind.

Tipps

  • Wenn Sie eine Prozedur unterbrechen, die einen dynamischen Datenaustausch durchführt, bleiben möglicherweise Kanäle unbeabsichtigt geöffnet. Sie vermeiden das unnötige Belegen von System-Ressourcen, indem Sie während der Fehlersuche in Code, der einen dynamischen Datenaustausch durchführt, die Anweisung DDETerminateAll in Ihrem Code oder im Direktfenster (unterer Teil) des Testfensters ausführen.

  • Wenn Sie Objekte einer anderen Anwendung aus Microsoft Access heraus bearbeiten möchten, bietet sich Automatisierung an.


Info über die Abfrage des Tabellenanalyse-Assistenten

1 2 3 4


Info über die Abfrage des Tabellenanalyse-Assistenten


Argumente für die Aktion "AnwendenFilter" (1)

Argument | Einstellung
Filtername |
Bedingung | [Firma] Wie "[AÀÁÂÃÄ]*"


Argumente für die Aktion "AnwendenFilter" (2)

Argument | Einstellung
Filtername |
Bedingung | [Firma] Wie"B*"


Argumente für die Aktion "AnwendenFilter" (3)

Argument | Einstellung
Filtername |
Bedingung | [Firma] Wie "[CÇ]*"


Argumente für die Aktion "AnwendenFilter" (4)

Argument | Einstellung
Filtername |
Bedingung | [Firma] Wie "[ZÆØÅ]*"


Argumente für die GeheZuSteuerelement-Aktion

Argument | Einstellung
Steuerelementname | Firma


Zuweisen eines Filters unter Verwendung eines Makros - Beispiel

Das folgende Makro enthält eine Gruppe von Aktionen. Jede Aktion filtert die Datensätze für das Formular Kundentelefonliste. Das Makro zeigt die Verwendung der Aktionen AnwendenFilter, AnzeigenAlleDatensätze und GeheZuSteuerelement. Außerdem zeigt es die Verwendung von Bedingungen, um zu ermitteln, welche Umschaltfläche in einer Optionsgruppe des Formulars gewählt wurde. Jeder Aktionszeile ist eine Umschaltfläche zugeordnet. Diese wählt entweder die Gruppe von Datensätzen, die mit A, B, C usw. anfangen, oder alle Datensätze.

Klicken Sie auf den Aktionsnamen, um die Argumente für jede Aktion anzuzeigen.

Bedingung | Aktion | Kommentar
 |  | Dem AfterUpdate-Ereignis der Optionsgruppe CompanyNameFilter zugeordnet.
[Filter für Firma] =1 | AnwendenFilter | Filter für Firmen, deren Namen mit A, À, Á, Â, Ã oder Ä anfangen.
[Filter für Firma] =2 | AnwendenFilter | Filter für Firmen, deren Namen mit B anfangen.
[Filter für Firma] =3 | AnwendenFilter | Filter für Firmen, deren Namen mit C oder Ç anfangen.
... Die Aktionszeilen für D bis Y haben das gleiche Format wie diejenigen für A bis C ...
[Filter für Firma] =26 | AnwendenFilter | Filter für Firmen, deren Namen mit Z, Æ, Ø oder Å anfangen.
[Filter für Firma] =27 | AnzeigenAlleDatensätze | Alle Datensätze anzeigen.
[DatensatzgruppeDuplizieren].[RecordCount]>0 | GeheZuSteuerelement | Wenn Datensätze für den ausgewählten Buchstaben zurückgegeben werden, wird der Fokus auf das Firma-Steuerelement gesetzt.


Überprüfen der Gültigkeit von Daten unter Verwendung eines Makros - Beispiel

Das folgende Gültigkeitsmakro überprüft die in das Formular Lieferanten eingegebenen Postleitzahlen. Es zeigt die Verwendung der Aktionen StoppMakro, Warnmeldung, AbbrechenEreignis und GeheZuSteuerelement. Ein bedingter Ausdruck überprüft das in einen Datensatz des Formulars eingegebene Land und die Postleitzahl. Wenn die Postleitzahl nicht im richtigen Format für das betreffende Land eingegeben wird, zeigt das Makro ein Meldungsfeld an und bricht das Speichern des Datensatzes ab. Danach kehrt es zum Postleitzahl-Steuerelement zurück, damit Sie den Fehler korrigieren können.

Klicken Sie auf den Namen einer Aktion, um die Argumente für jede Aktion anzuzeigen.

Bedingung | Aktion | Kommentar
 |  | Zugeordnet zur Eigenschaft VorAktualisierung des Formulars Lieferanten.
IstNull([Land]) | StoppMakro | Wenn Land gleich Null ist, kann die Postleitzahl nicht überprüft werden
[Land] In ("Frankreich","Italien","Spanien") Und Länge([Postleitzahl]) <> 5 | Meldung | Wenn die Postleitzahl nicht fünfstellig ist, eine Meldung anzeigen und...
... | AbbrechenEreignis | ... das Ereignis abbrechen.
 | GeheZuSteuerelement |
[Land] In ("Australien","Singapur") Und Länge([Postleitzahl]) <> 4 | Meldung | Wenn die Postleitzahl nicht vierstellig ist, eine Meldung anzeigen und...
... | AbbrechenEreignis | ... das Ereignis abbrechen.
 | GeheZuSteuerelement |
([Land] = "Kanada") Und ([Postleitzahl] Nicht Wie"[A-Z][0-9][A-Z] [0-9][A-Z][0-9]") | Meldung | Wenn die Postleitzahl nicht korrekt für Kanada ist, eine Meldung anzeigen und...
... | AbbrechenEreignis | ... das Ereignis abbrechen.


Argumente für die Aktion "Meldung" (1)

Argument | Einstellung
Meldung | Die Postleitzahl muss fünfstellig sein.
Signalton | Ja
Typ | Information
Titel | Fehler in Postleitzahl


Argumente für die Aktion "Meldung" (2)

Argument | Einstellung
Meldung | Die Postleitzahl muss vierstellig sein.
Signalton | Ja
Typ | Information
Titel | Fehler in Postleitzahl


Argumente für die Aktion "Meldung" (3)

Argument | Einstellung
Meldung | Die Postleitzahl ist nicht gültig. Beispiel für eine kanadische Postleitzahl: H1J 1C3
Signalton | Ja
Typ | Information
Titel | Fehler in Postleitzahl


Argumente für die GeheZuSteuerelement-Aktion

Argument | Einstellung
Steuerelementname | Postleitzahl


 ÖffnenDatenzugriffsseite-Aktion

ÖffnenDatenzugriffsseite-Aktion

Mit der Aktion ÖffnenDatenzugriffsseite können Sie eine Datenzugriffsseite in der Seitenansicht oder der Entwurfsansicht öffnen.

Einstellung

Die Aktion ÖffnenDatenzugriffsseite verwendet die folgenden Argumente.

Aktionsargument | Beschreibung
Datenzugriffsseite | Der Name des zu öffnenden Formulars. Im Makrofensters, im Abschnitt Aktionsargumente zeigt das Feld Datenzugriffsseite alle Formulare der aktuellen Datenbank an. Dieses Argument ist erforderlich. Wenn Sie ein Makro, das die Aktion ÖffnenDatenzugriffsseite enthält, in einer Bibliotheksdatenbank ausführen, sucht Microsoft Access das Formular mit diesem Namen zuerst in der Bibliotheksdatenbank und dann in der aktuellen Datenbank.
Ansicht | Die Ansicht, in der die Datenzugriffsseite geöffnet wird. Klicken Sie im Feld Ansicht auf Datenzugriffsseitenansicht bzw. Entwurfsansicht. Die Standardeinstellung ist Datenzugriffsseitenansicht.

Anmerkungen

Diese Aktion ist vergleichbar mit dem Klicken auf die Schaltfläche Öffnen bzw. die Schaltfläche Entwurf im Datenbankfenster, nachdem eine Datenzugriffsseite in der Registerkarte Seiten ausgewählt wurde.

Tipp Sie können eine Datenzugriffsseite im Datenbankfenster markieren und sie in eine Makroaktionszeile ziehen. Dadurch wird automatisch eine Aktion ÖffnenDatenzugriffsseite erstellt, die die Datenzugriffsseite in der Browse-Ansicht öffnet.

Zum Ausführen der Aktion ÖffnenDatenzugriffsseite in Visual Basic verwenden Sie die OpenDataAccessPage-Methode des DoCmd-Objekts.


Setzen des Wertes eines Steuerelements unter Verwendung eines Makros - Beispiel

Das folgende Makro öffnet das Formular Artikel hinzufügen über eine Schaltfläche im Formular Lieferanten. Es zeigt die Verwendung der Aktionen Echo, Schließen, ÖffnenFormular, SetzenWert und GeheZuSteuerelement. Die Aktion SetzenWert setzt das Steuerelement Lieferanten-Nr im Formular Artikel auf den aktuellen Lieferanten im Formular Lieferanten. Danach verschiebt die Aktion GeheZuSteuerelement den Fokus auf das Feld Kategorie-Nr, in dem Sie Daten für den neuen Artikel eingeben können.

Klicken Sie auf den Aktionsnamen, um die Argumente für jede Aktion anzuzeigen.

Aktion | Kommentar
 | Der Schaltfläche Artikel hinzufügen im Formular Lieferanten zugeordnet.
Echo | Bildschirmaktualisierung anhalten, während das Makro ausgeführt wird (Echo ist ausgeschaltet).
Schließen | Das Formular Artikelliste schließen.
ÖffnenFormular | Das Formular Artikel öffnen.
SetzenWert | Das Steuerelement Lieferanten-Nr auf den aktuellen Lieferanten im Formular Lieferanten setzen.
GeheZuSteuerelement | Zum Steuerelement Kategorie-Nr gehen.


Argumente für die Aktion "Echo"

Argument | Einstellung
Echo | Nein
Statusleistentext |


Argumente für die Meldung-Aktion

Argument | Einstellung
Meldung | Gehen Sie zum Datensatz des Lieferanten, dessen Produkte Sie anzeigen möchten, und drücken Sie dann die Schaltfläche Artikel (Übersicht) erneut.
Signalton | Ja
Typ | Ohne Symbol
Titel | Wählen Sie einen Lieferanten aus.


Argumente für die ÖffnenFormular-Aktion

Argument | Einstellung
Formularname | Artikelliste
Ansicht | Formular
Filtername |
Bedingung | [Lieferanten-Nr] = [Formulare]![Lieferanten]![Lieferanten-Nr]
Datenmodus | Nur lesen
Fenstermodus | Normal


Argumente für die Aktion "Positionieren"

Argument | Einstellung
Rechts | 2 cm
Unten | 4,5 cm
Breite |
Höhe |


Argumente für die Schließen-Aktion

Argument | Einstellung
Objekttyp | Formular
Objektname | Artikelliste
Speichern | Nein


Argumente für die Aktion "ÖffnenFormular"

Argument | Einstellung
Formularname | Artikel
Ansicht | Formular
Filtername |
Bedingung |
Datenmodus | Hinzufügen
Fenstermodus | Normal


Argumente für die Aktion "SetzenWert"

Argument | Einstellung
Feld | [Formulare]![Artikel]![Lieferanten-Nr]
Ausdruck | Lieferanten-Nr


Argumente für die Aktion "GeheZuSteuerelement"

Argument | Einstellung
Steuerelementname | Kategorie-Nr


Synchronisieren von Formularen unter Verwendung eines Makros - Beispiel

Das folgende Makro öffnet das Formular Artikelliste, das die Artikel des aktuellen Lieferanten in der unteren rechten Ecke des Formulars Lieferanten anzeigt. Das Makro zeigt die Verwendung der Aktionen Echo, Warnmeldung, GeheZuSteuerelement StoppMakro, ÖffnenFormular und Positionieren. Außerdem zeigt es die Verwendung eines bedingten Ausdrucks bei den Aktionen Warnmeldung, GeheZuSteuerelement und StoppMakro.

Klicken Sie auf den Aktionsnamen, um die Argumente für jede Aktion anzuzeigen.

Bedingung | Aktion | Kommentar
 |  | Der Schaltfläche Artikelübersicht im Formular Lieferanten zugeordnet.
 | Echo | Bildschirmaktualisierung anhalten, während das Makro ausgeführt wird (Echo ist ausgeschaltet).
IstNull([Lieferanten-Nr]) | Meldung | Wenn es keinen aktuellen Lieferanten im Formular Lieferanten gibt, eine Meldung anzeigen ...
 | GeheZuSteuerelement | Den Fokus auf das Firma-Steuerelement setzen.
... | StoppMakro | ... und das Makro anhalten.
 | ÖffnenFormular | Das Formular Artikelliste öffnen und die Artikel des aktuellen Lieferanten anzeigen.
 | Positionieren | Das Formular Artikelliste unten rechts im Formular Lieferanten positionieren.


AllDataAccessPages-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllDataAccessPages-Auflistung aus.

Sub AllDataAccessPages()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentProject
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllDataAccessPages-Auflistung suchen.
    For Each obj In dbs.AllDataAccessPages
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllDatabaseDiagrams-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllDatabaseDiagrams-Auflistung aus.

Sub AllDatabaseDiagrams()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentData
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllDatabaseDiagrams-Auflistung suchen.
    For Each obj In dbs.AllDatabaseDiagrams
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllForms-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllForms-Auflistung aus.

Sub AllForms()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentProject
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllForms-Auflistung suchen.
    For Each obj In dbs.AllForms
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllMacros-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllMacros-Auflistung aus.

Sub AllMacros()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentProject
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllMacros-Auflistung suchen.
    For Each obj In dbs.AllMacros
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllModules-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllModules-Auflistung aus.

Sub AllModules()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentProject
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllModules-Auflistung suchen.
    For Each obj In dbs.AllModules
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllQueries-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllQueries-Auflistung aus.

Sub AllQueries()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentData
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllQueries-Auflistung suchen.
    For Each obj In dbs.AllQueries
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllReports-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllReports-Auflistung aus.

Sub AllReports()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentProject
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllReports-Auflistung suchen.
    For Each obj In dbs.AllReports
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllStoredProcedures-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllProcedures-Auflistung aus.

Sub AllStoredProcedures()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentData
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllStoredProcedures-Auflistung suchen.
    For Each obj In dbs.AllStoredProcedures
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllTables-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllTables-Auflistung aus.

Sub AllTables()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentData
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllTables-Auflistung suchen.
    For Each obj In dbs.AllTables
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


AllViews-Auflistung: Beispiel

Das folgende Beispiel gibt den Namen jedes geöffneten AccessObject-Objekts in der AllViews-Auflistung aus.

Sub AllViews()
    Dim obj As AccessObject, dbs As Object
    Set dbs = Application.CurrentData
    ' Nach geöffneten AccessObject-Objekten in
    ' der AllViews-Auflistung suchen.
    For Each obj In dbs.AllViews
        If obj.IsLoaded = TRUE then
            ' Name von obj ausgeben.
            Debug.Print obj.Name
        End If
    Next obj
End Sub


 DataAccessPages-Auflistung

DataAccessPages-Auflistung

Die DataAccessPages-Auflistung enthält alle Datenzugriffsseiten, die in einem Microsoft Access-Projekt (.adp) oder einer Access-Datenbank (.mdb) momentan geöffnet sind.

Anmerkungen

Verwenden Sie die DataAccessPages-Auflistung in Visual Basic oder in einem Ausdruck, um auf momentan geöffnete Datenzugriffsseiten zu verweisen. So können Sie z.B. die DataAccessPages-Auflistung in einer Schleife durchlaufen, um die Werte der Eigenschaften einzelner Datenzugriffsseiten in der Auflistung einzustellen oder zurückzugeben.

Tipp Eine Auflistung lässt sich am besten mit einer For Each...Next-Anweisung durchlaufen.

Sie können auf ein einzelnes DataAccessPage-Objekt in der DataAccessPages-Auflistung entweder über seinen Namen oder durch Angabe seines Indexes innerhalb der Auflistung verweisen. Wenn Sie auf eine bestimmte Datenzugriffsseite in der DataAccessPages-Auflistung verweisen möchten, empfiehlt sich die Verwendung des Namens, da der Index sich ändern kann.

Die DataAccessPages-Auflistung wird beginnend mit 0 indiziert. Wenn Sie auf eine Datenzugriffsseite über ihren Index verweisen, ist DataAccessPages(0) die erste geöffnete Datenzugriffsseite, DataAccessPages(1) die zweite geöffnete Datenzugriffsseite usw. Haben Sie zuerst Seite 1 und anschließend Seite 2 geöffnet, wird auf Seite 2 in der DataAccessPages-Auflistung über ihren Index als DataAccessPages(1) verwiesen. Haben Sie danach Seite 1 geschlossen, wird auf Seite 2 in der DataAccessPages-Auflistung über ihren Index als DataAccessPages(0) verwiesen.

Anmerkung Zum Auflisten aller (geöffneten und geschlossenen) Datenzugriffsseiten der Datenbank durchlaufen Sie die AllDataAccessPages-Auflistung des CurrentProject-Objekts in einer Schleife. Anschließend können Sie die Name-Eigenschaft jedes einzelnen AccessObject-Objekts verwenden, um den Namen einer Datenzugriffsseite zurückzugeben.

Es ist nicht möglich, der DataAccessPages-Auflistung ein DataAccessPage-Objekt hinzuzufügen oder aus ihr zu löschen.


Properties-Auflistung: Beispiel

Das folgende Beispiel durchläuft die Forms-Auflistung und gibt den Namen jedes geöffneten Formulars in dieser Auflistung aus. Anschließend durchläuft es die Properties-Auflistung jedes Formulars und gibt den Namen jeder Eigenschaft und jeden Wert aus.

Sub AllOpenForms()
    Dim frm As Form, prp As Property

    ' Forms-Auflistung durchlaufen.
    For Each frm In Forms
        ' Namen des Formulars ausgeben.
        Debug.Print frm.Name
        ' Properties-Auflistung jedes Formulars durchlaufen.
        For Each prp In frm.Properties
            ' Namen jeder Eigenschaft ausgeben.
            Debug.Print prp.Name; " = "; prp.Value
        Next prp
    Next frm
End Sub


Info über das Hinzufügen eines gebundenen Objekts zu einem Formular oder Bericht

Ein gebundenes Objekt kann zu einem Formular oder Bericht über Einfügen oder über eine Verknüpfung hinzugefügt werden.

Wird ein Objekt in ein Formular oder einen Bericht eingefügt, speichert Microsoft Access das Objekt in der Datenbankdatei - ein eingefügtes Objekt ist deshalb immer verfügbar. Wenn Sie das Objekt oder den Pfad zum grafischen Objekt innerhalb des Formulars oder Berichts ändern, finden diese Änderungen am Objekt in der Datenbank statt.

Wenn Sie eine Verknüpfung zu einem Objekt herstellen, können Sie das Objekt innerhalb des Formulars oder Berichts anzeigen und Änderungen vornehmen, aber alle Änderungen am Objekt werden nicht in der Datenbankdatei, sondern in der ursprünglichen Objektdatei gespeichert. Sie können die Objektdatei natürlich auch separat modifizieren. In diesem Fall werden die zuletzt vorgenommenen Änderungen angezeigt, wenn Sie das Formular bzw. den Bericht das nächste Mal öffnen. Objektverknüpfungen sind bei der Einbindung sehr großer Dateien sinnvoll, die Sie nicht in die Datenbankdatei übernehmen möchten. Auch für Dateien, die Sie in mehreren Formularen oder Berichten verwenden möchten, lassen sich Verknüpfungen vorteilhaft einsetzen. Allerdings müssen Sie jede Verknüpfung neu erstellen, wenn das verknüpfte Objekt verschoben wird.

Zurück zu Hinzufügen eines gebundenen Objekts zu einem Formular oder Bericht


Info über das Hinzufügen eines Bildes oder eines anderen Objekts zu einem Formular, Bericht oder einer Datenzugriffsseite

Wie Sie ein Bild oder Objekt hinzufügen, hängt davon ab, ob Sie mit einem Formular, Bericht oder einer Datenzugriffsseite arbeiten.

Formulare und Berichte

Sie können Objekte, die Sie in anderen Anwendungen erstellt haben, ganz oder teilweise zu einem Microsoft Access-Formular oder -Bericht hinzufügen. Es besteht z. B. die Möglichkeit, ein mit Microsoft Paint erstelltes Bild, eine mit Microsoft Excel erstellte Tabelle oder ein mit Word erstelltes Dokument einzufügen. Dabei können Sie alle Informationen oder nur ausgewählte Informationen aus einer Datei hinzufügen.

In Formularen und Berichten wird ein gebundenes Objekt in einer Tabelle gespeichert. Wenn Sie zu einem neuen Datensatz wechseln, ändert sich das im Formular oder Bericht angezeigte Objekt. Sie können z. B. für jeden Mitarbeiter Ihres Unternehmens ein Bild als gebundenes Objekt speichern. Ein ungebundenes Objekt wird dagegen im Entwurf des Formulars oder Berichts gespeichert. Wenn Sie zu einem neuen Datensatz wechseln, ändert sich das Objekt in diesem Fall nicht. Beispielsweise können Sie ein mit Microsoft Paint erstelltes Logo auf diese Weise in ein Formular oder einen Bericht einfügen.

Datenzugriffsseiten

Sie können Grafikobjekte zu einer Datenzugriffsseite hinzufügen. Eine Grafik verknüpfen Sie mit einer Datenzugriffsseite, indem Sie den Pfad für die Grafik in ein Feld eingeben und dann diesem Feld ein Bild-Steuerelement zuordnen. Dieses Verfahren unterscheidet sich von dem bei Formularen und Berichten verwendeten Verfahren, weil das Grafikobjekt selbst nicht in einer Tabelle gespeichert werden kann, sondern nur der Pfad zur Grafik. In einer Datenzugriffsseite können Sie auch ungebundene Grafikobjekte (beispielsweise ein Logo oder Banner) einfügen, deren Anzeige sich nicht ändert, wenn Sie zu einem neuen Datensatz wechseln.

Zurück zu Hinzufügen eines Bildes oder eines anderen Objekts zu einem Formular, Bericht oder einer Datenzugriffsseite


Info über das Hinzufügen eines ungebundenen Objekts zu einem Formular oder Bericht

Sie können ungebundene Objekte als eingefügte oder verknüpfte Objekte zu einem Formular oder Bericht hinzufügen.

Wird ein Objekt eingefügt, speichert Microsoft Access das Objekt in der Datenbankdatei - ein eingefügtes Objekt ist deshalb immer verfügbar. Wenn Sie das Objekt innerhalb des Formulars oder Berichts ändern, finden diese Änderungen am Objekt in der Datenbank statt.

Wenn Sie eine Verknüpfung zu einem Objekt herstellen, können Sie das Objekt innerhalb des Formulars oder Berichts anzeigen und Änderungen daran vornehmen, aber alle Änderungen am Objekt werden nicht in der Datenbankdatei, sondern in der ursprünglichen Objektdatei gespeichert. Sie können die Objektdatei natürlich auch separat modifizieren. In diesem Fall werden die zuletzt vorgenommenen Änderungen angezeigt, wenn Sie das Formular bzw. den Bericht das nächste Mal öffnen. Objektverknüpfungen sind bei der Einbindung sehr großer Dateien sinnvoll, die Sie nicht in die Datenbankdatei übernehmen möchten. Auch für Dateien, die Sie in mehreren Formularen oder Berichten verwenden möchten, lassen sich Verknüpfungen vorteilhaft einsetzen. Allerdings müssen Sie jede Verknüpfung neu erstellen, wenn das verknüpfte Objekt verschoben wird.

Zurück zu Hinzufügen eines ungebundenen Objekts


 Info über das Berechnen einer Summe, eines Mittelwerts, einer Anzahl oder einer anderen Summe für Datensätze in einer Abfrage

Info über das Berechnen einer Summe, eines Mittelwerts, einer Anzahl oder einer anderen Summe für Datensätze in einer Abfrage

Unter Verwendung der Zeile Funktion in der Entwurfsansicht einer Abfrage können Sie die Summe, den Mittelwert, die Anzahl, einen Minimal- oder Maximalwert, eine Abweichung oder eine Standardabweichung auf der Basis von Werten in einem oder mehreren Feldern für alle Datensätze in einer Abfrage oder für eine oder mehrere Gruppen von Datensätzen berechnen. Unter Verwendung der Zeile Kriterien können Sie Kriterien hinzufügen, die die Ergebnisse der Berechnung beeinflussen.

Anmerkung Sie können zum Berechnen der Summe, des Mittelwerts, der Anzahl oder von Minimal- oder Maximalwerten in einem Feld auch den Auswahlabfrage-Assistent verwenden; wenn Sie jedoch Kriterien hinzufügen möchten, müssen Sie den Entwurfsbereich einer Abfrage verwenden.

Zurück zu Berechnen einer Summe, eines Mittelwerts, einer Anzahl oder einer anderen Summe für Datensätze in einer Abfrage


 Info über das Komprimieren einer Access-Datenbank oder eines Access-Projekts

Info über das Komprimieren einer Access-Datenbank oder eines Access-Projekts

Beginnend mit dieser Version kombiniert Microsoft Access nun das Komprimieren und Reparieren von Microsoft Access-Datenbanken und fasst beide Operationen in einem Prozess zusammen. Allerdings werden Microsoft Access-Projekte durch Access nur komprimiert und nicht repariert.

Komprimieren einer Access-Datenbank oder eines Access-Projekts Wenn Sie Daten oder Objekte in einer Access-Datenbank löschen, oder wenn Sie Objekte eines Access-Projekts löschen, kann dies zur Fragmentierung der Access-Datenbank bzw. des Access-Projekts und zu einer ineffizienten Nutzung des Festplattenspeichers führen. Beim Komprimieren der Access-Datenbank bzw. des Access-Projekts wird eine Kopie der Datei angelegt und die Speicherung der Datei auf der Festplatte neu organisiert.

Das Komprimieren optimiert gleichermaßen die Leistung von Access-Datenbanken und Access-Projekten. Allerdings betrifft das Komprimieren eines Access-Projekts nicht diejenigen Datenbankobjekte — beispielsweise Tabellen oder Sichten — die sich in der Microsoft SQL Server-Datenbank anstatt im Access-Projekt selber befinden. Außerdem hat das Komprimieren keine Auswirkung auf AutoWert-Felder in einem Access-Projekt. Bei einer Access-Datenbank mit einer Tabelle, die ein AutoWert-Feld enthält, führt das Komprimieren der Datenbank hingegen zum Zurücksetzen des AutoWert-Feldinhalts, wenn zuvor Datensätze am Ende der Tabelle gelöscht wurden. Der AutoWert-Wert des nächsten Datensatzes, der hinzugefügt wird, ist um Eins größer als der AutoWert-Wert des letzten nicht gelöschten Datensatzes in der Tabelle.

Reparieren einer Access-Datenbank In den meisten Fällen findet Microsoft Access heraus, ob eine Access-Datenbank beschädigt ist, wenn Sie versuchen, die Datenbank zu öffnen. In diesen Fällen wird Ihnen die Möglichkeit angeboten, die Datenbank zu komprimieren. In einigen Situationen kann es vorkommen, dass Microsoft Access die Beschädigung einer Access-Datenbank nicht feststellt. Wenn eine Access-Datenbank ein unvorhersehbares Verhalten zeigt, sollten Sie sie komprimieren.

Das Komprimieren einer in einer früheren Version erstellten Access-Datenbank konvertiert diese nicht in das Access 2000-Format. Der folgende Hyperlink führt zu weiteren Informationen über das Konvertieren einer in einer früheren Version erstellten Access-Datenbank.

Wenn Sie eine (gemeinsam genutzte) Mehrbenutzer-Datenbank komprimieren, die sich auf einem Server oder in einem gemeinsam genutzten Ordner befindet, sollten Sie sicherstellen, dass außer Ihnen kein anderer die Datenbank geöffnet hat. Sie müssen über die Berechtigungen Öffnen/Ausführen und Exklusiv für eine Access-Datenbank verfügen, um sie komprimieren zu können. Der folgende Hyperlink führt zu weiteren Informationen über das Zuweisen von Berechtigungen.

Zurück zum Thema Komprimieren einer Access-Datenbank oder eines Access-Projekts


 Info über das Bedingte Formatieren eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht

Info über das Bedingte Formatieren eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht

Enthält ein Steuerelement in einem Formular oder Bericht Werte, die überwacht werden sollen, so können Sie unterschiedliche Werte in dem Steuerelement einfacher verfolgen, indem Sie sich der bedingten Formatierung bedienen. Sie können beispielsweise das Steuerelement veranlassen, eine grüne Hintergrundfarbe anzuzeigen, falls der Umsatz Ihre Schätzung übertrifft, oder eine rote Hintergrundfarbe, falls der Umsatz hinter den Erwartungen zurückbleibt. Des weiteren können Sie Text fett, kursiv oder unterstrichen formatieren, oder Sie können ein Steuerelement aktivieren bzw. deaktivieren, wenn es einem von Ihnen festgelegten Kriterium entspricht oder nicht.

Durch Verwendung der bedingten Formatierung können Sie dem Steuerelement ansehen, inwieweit dessen Werte mit einer Konstanten oder dem Ergebnis eines Ausdrucks übereinstimmen. Zur Festlegung der Formatierungskriterien unter Bezugnahme auf Daten in Steuerelementen oder unter Einbeziehung mehrerer Gruppen von Bedingungen können Sie logische Ausdrücke verwenden. Der folgende Hyperlink führt zu weiteren Informationen über das Erstellen eines Ausdrucks.

Bei der Definiton bedingter Formatierungen können Sie sich auf Werte in einem Steuerelement, beliebige Ausdrücke mit Verweisen auf andere Steuerelemente, benutzerdefinierte VBA (Visual Basic für Applikationen) -Funktionen oder auf das Steuerelement mit dem aktuellen Eingabefokus beziehen. So können Sie beispielsweise bedingte Formatierungen festlegen, die den Hintergrund eines Felds rot färben, wenn das Gehalt eines Angestellten den Betrag von 100.000 DM übersteigt. Oder Sie legen ein Format fest, das den im Feld Stadt enthaltenenText grün färbt und kursiv darstellt, wenn ein Kunde in Seattle wohnt.

Wenn sich der Wert eines Steuerelements ändert und der angegeben Bedingung nicht mehr genügt, kehrt Microsoft Access zur Standardformatierung für das Steuerelement zurück. Eine bedingte Formatierung gilt für ein Steuerelement solange, bis sie gelöscht wird. Das trifft auch zu, wenn keine der Bedingungen erfüllt ist und die angegebene Formatierung nicht angezeigt wird.

Anmerkung Platzhalterzeichen — wie z.B. das Sternchen (*), das Fragezeichen (?) oder ein anderes Symbol — können bei der Definition von Kriterien nicht als Ersatz für Zeichen in Text- oder Zahlenangaben verwendet werden.

Zurück zum Thema Bedingtes Formatieren eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht


 Konvertieren einer Access 2000-Datenbank in das Access 97-Format

Konvertieren einer Access 2000-Datenbank in das Access 97-Format

Sie können eine Microsoft Access 2000-Datenbank in eine Access 97-Datenbank konvertieren, sofern es sich nicht um ein Mitglied einer Replikatgruppe handelt. Jede für Access 2000 spezifische Funktionalität geht verloren, wenn Sie die Datenbank in das Access 97-Format umwandeln.

Beim Konvertieren einer Access 2000-Datenbank in eine Access 97-Datenbank werden die folgenden Änderungen in der konvertierten Datenbank durchgeführt.

  • Hyperlinks zu Datenzugriffsseiten gehen verloren.

  • Daten einer Access 2000-Datenbank mit Unicode-Bezug werden möglicherweise nicht korrekt konvertiert. Access 97 verwendet nur Zeichen einer einzigen Codepage — einem nummerierten Satz von 256 Zeichen. Beispielsweise kann sich eine Access 97-Datenbank auf die Verwendung von ANSI-Zeichen beschränken. Während der Konvertierung bestimmt die Sortierreihenfolge der ursprünglichen Access 2000-Datenbank, welchen Zeichensatz die resultierende Access 97-Datenbank verwenden kann. Alle nicht in dieser Menge enthaltenen Zeichen werden nicht korrekt umgewandelt.

  • Eine Access 2000-Datenbank mit einer Tabelle, deren Feldgröße-Eigenschaft den Wert Dezimal aufweist, kann nicht in das Access 97-Format umgewandelt werden. Sie müssen der Feldgröße-Eigenschaft einen anderen Wert zuweisen (beispielsweise Single oder Double), oder Sie müssen den Datentyp des Felds in Währung ändern, bevor Sie die Datenbank erfolgreich konvertieren können.

Wenn Sie eine geschützte Access-Datenbank konvertieren, sind für das Benutzerkonto, das Sie zum Anmelden verwenden, folgende Berechtigungen notwendig:

  • Die Berechtigung zum Öffnen/Ausführen und zum exklusiven Öffnen für die Datenbank selbst sowie die Berechtigung zum Entwurf lesen für alle Objekte in der Datenbank.

  • Zum Sichern der konvertierten Datenbank müssen Sie sie in Microsoft Access 97 öffnen und Sicherheit auf Benutzerebene verwenden.

Wenn Sie für die Access-Datenbank einen Kennwortschutz eingerichtet haben, können Sie die Konvertierung der Datenbank durchführen, ohne das Kennwort zu entfernen. Haben Sie den VBA-Code (Microsoft Visual Basic für Applikationen) durch ein Kennwort geschützt, so müssen Sie dieses Kennwort in der Visual Basic-Umgebung bereitstellen.


 Info über das Kopieren eines Datenbankobjekts

Info über das Kopieren eines Datenbankobjekts

Ein existierendes Datenbankobjekt in einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt kann problemlos angepasst werden, indem eine Kopie des Objekts erstellt und anschließend diese Kopie modifiziert wird.

In der Regel erbt eine Kopie des Datenbankobjekts die mit dem ursprünglichen Datenbankobjekt verbundenen Eigenschaften. Allerdings erbt die Kopie einer Tabelle eines Access-Projekts nicht die Indizes, Einschränkungen und Trigger der ursprünglichen Tabelle, und Sie müssen diese Attribute für die Kopie neu erstellen. Wenn Sie eine Kopie einer Tabelle oder Abfrage einer Access-Datenbank erstellen und ein Unterdatenblatt der Tabelle oder Abfrage in die Kopie übernehmen möchten, müssen Sie die Kopie öffnen und das Unterdatenblatt einfügen.

Wenn Sie nur die Struktur einer Tabelle und nicht die Tabelle selbst und ihre Daten kopieren möchten, oder wenn Sie die Daten einer Tabelle an eine vorhandene andere Tabelle anhängen möchten, verwenden Sie den Befehl Kopieren, um die Tabelle zu kopieren.

Sie können ein Datenbankobjekt aus dem Datenbankfenster einer Access-Datenbank oder eines Access-Projekts auf eine andere geöffnete Access-Datenbank bzw. ein anderes geöffnetes Access-Projekt ziehen. Sie können eine Tabelle, Abfrage oder einen Bericht kopieren, indem Sie das Objekt aus dem Datenbankfenster auf eine andere Microsoft-Anwendung ziehen.

Sie können außerdem einige Datenbankobjekte als Objekte eines anderen Typs speichern.

Zurück zum Thema Kopieren eines Datenbankobjekts


 Info über das Erstellen einer benutzerdefinierten Hilfe für ein Formular, einen Bericht oder ein Steuerelement

Info über das Erstellen einer benutzerdefinierten Hilfe für ein Formular, einen Bericht oder ein Steuerelement

Es gibt verschiedene Möglichkeiten, einem Microsoft Access-Formular, -Bericht oder -Steuerelement ein Hilfesystem hinzuzufügen. Wenn Sie Tipps für Steuerelemente anzeigen möchten, indem Sie den Mauszeiger auf das entsprechende Steuerelement bewegen, können Sie die SteuerelementTipp-Text-Eigenschaft verwenden. Sie können auch mit der Statusleistentext-Eigenschaft nützliche Informationen zu einem Formular oder Steuerelement in der Statusleiste anzeigen. Darüber hinaus können Sie Tipps für neue, selbst erstellte Symbolleistenschaltflächen erstellen.

Wenn Sie die Hilfe für ein Steuerelement nur dann angezeigt werden soll, wenn Sie auf die Schaltfläche Direkthilfe [image] und anschließend auf das entsprechende Steuerelement klicken, können Sie unter Verwendung eines Text-Editors oder Textverarbeitungsprogramms eine Hilfedatei erstellen. (Das Programm muss Dokumente im .RTF-Format speichern können.)Dann können Sie die Hilfedatei mit dem Microsoft Help Workshop kompilieren und einem Steuerelement über die Eigenschaften Hilfedatei und Hilfekontext-ID zuordnen.

Für Formular und Berichte kann eine erweiterte Form der Hilfe erstellt werden, die durch Drücken auf F1 angezeigt wird und unter Verwendung der Eigenschaften Hilfedatei und Hilfekontext-ID des Formulars oder Berichts festgelegt wird. Um die Hilfedatei für diesen Typ von Hilfe zu erstellen, können Sie entweder Microsoft Help Workshop oder Microsoft HTML Help Workshop verwenden.

Anmerkungen

  • Sie können Microsoft Help Workshop von der Microsoft-Website für den Support (Microsoft Technical Support) auf Ihren Computer laden.

  • Microsoft HTML Help Workshop ist Bestandteil von Microsoft Office 2000 Developer.

  • Weitere Informationen über das Erstellen eines benutzerdefinierten Hilfesystems finden Sie im Abschnitt "Hinzufügen eines Hilfesystems zu benutzerdefinierten Anwendungen" im Microsoft Office 2000/Visual Basic Programmierhandbuch. Erkundigen Sie sich danach, wie Sie eine Kopie dieses Buches erhalten können.

Zurück zum Thema Erstellen einer benutzerdefinierten Hilfe für ein Formular, einen Bericht oder ein Steuerelement


 Info über das Erstellen eines Ausdrucks

Info über das Erstellen eines Ausdrucks

Wenn Sie einen Ausdruck erstellen, fügen Sie Bezeichner, Werte und Operatoren zu einer Einheit zusammen, die ein Ergebnis hervorbringt. Ausdrücke können so einfach wie ein arithmetischer Ausdruck sein, wie z.B. (1 + 1), der ein numerisches Ergebnis hervorbringt (2). Sie können auch komplexe Datenoperationen durchführen, wie der folgende Ausdruck für eine Gültigkeitsregel, der einen Fehler erzeugt, wenn der Wert des Feldes Land "Frankreich", "Italien" oder "Spanien" ist und das Feld Postleitzahl weniger oder mehr als fünf Zeichen enthält:

= [Land] In ("Frankreich", "Italien", "Spanien") And Len([Postleitzahl])<>5

Sie können einen Ausdruck entweder mit dem Ausdrucks-Generator erstellen, oder Sie können ihn selbst erstellen, indem Sie die Elemente des Ausdrucks entsprechend zusammenführen.

Zurück zum Thema Erstellen eines Ausdrucks


 Info über das Erstellen eines Feldes, das Werte in Tabellen nachschlägt oder auflistet

Info über das Erstellen eines Feldes, das Werte in Tabellen nachschlägt oder auflistet

Nachschlagelisten

Die am häufigsten verwendete Nachschlageliste zeigt Werte an, die in einer verknüpften Tabelle nachgeschlagen wurden. Das Feld Lieferanten-Nr in der Tabelle Artikel aus der Beispieldatenbank Nordwind zeigt diese Nachschlageliste an:

Informationen aus der Tabelle "Lieferanten", angezeigt in der Nachschlageliste in der Tabelle "Artikel"

Diese Liste wird durch Nachschlagen der Lieferanten-Nr-Werte aus der Tabelle Lieferanten und Anzeigen der entsprechenden Lieferantennamen erstellt. Das Auswählen eines Wertes aus einer Nachschlageliste legt für den Wert Fremdschlüssel im aktuellen Datensatz (Lieferenten-Nr in der Tabelle Artikel) den Wert des Primärschlüssels des entsprechenden Datensatzes in der verknüpften Tabelle (Lieferanten-Nr in der Tabelle Lieferanten) fest. Damit wird eine Verbindung zur verknüpften Tabelle erzeugt, um die Lieferantennamen im Datensatz anzuzeigen, jedoch nicht zu speichern. Der Fremdschlüssel (Lieferanten-Nr) wird gespeichert, jedoch nicht angezeigt. Aus diesem Grund werden Änderungen an den Daten in der Tabelle Lieferanten sowohl in der Liste als auch in den Datensätzen in der Tabelle Artikel wiedergegeben. Sie müssen ein Nachschlagelistenfeld aus der Tabelle definieren, die den Fremdschlüssel enthalten und die Nachschlageliste anzeigen wird. In diesem Beispiel würde das Nachschlagelistenfeld von der Tabelle Artikel definiert.

Wertlisten

Eine Wertliste sieht genauso aus wie eine Nachschlageliste, besteht jedoch aus einer festen Gruppe von Werten, die Sie beim Erstellen der Liste eingeben. Verwenden Sie Wertlisten nur für Werte, die sich nicht häufig ändern und die nicht in einer Tabelle gespeichert werden müssen. Ein Beispiel für eine Wertliste ist z. B. eine Liste für ein Anredefeld mit den Werten Herr, Frau oder Fräulein. Diese Liste erstellt keine Verbindung zu einer verknüpften Tabelle. Wenn Sie daher einen der ursprünglichen Werte aus der Liste später ändern, wird diese Änderung nicht in Datensätzen widergespiegelt, die vor dem Durchführen dieser Änderung hinzugefügt worden sind.

Sie können neue Nachschlagelisten- oder Wertlistenfelder sowohl in der Entwurfsansicht einer Tabelle als auch in der Datenblattansicht einer Tabelle erstellen. Wenn aber das Feld, das Sie als Fremdschlüssel für ein Nachschlagefeld verwenden möchten, bereits existiert, müssen Sie die Tabelle dieses Feldes in der Entwurfsansicht öffnen, um das Nachschlagefeld zu definieren. Wenn Sie zum Beispiel eine Artikeltabelle haben, in der bereits ein Lieferanten-Nr-Feld definiert ist und Sie dieses Feld in ein Nachschlagefeld ändern möchten, um Lieferantennamen aus Ihrer Lieferantenttabelle anzuzeigen, müssen Sie die Tabelle Artikel in der Entwurfsansicht öffnen, um die Lieferanten-Nr in ein Nachschlagefeld zu ändern.

Zurück zu Erstellen eines Feldes, das Werte in Tabellen nachschlägt oder auflistet


 Info über das Erstellen von Formularen auf der Basis mehrerer Tabellen

Info über das Erstellen von Formularen auf der Basis mehrerer Tabellen

Die Verwendung eines Formular-Assistenten ist die schnellste und einfachste Möglichkeit, ein Formular zu erstellen, das Daten aus mehreren Tabellen zusammenführt. Ein Formular-Assistent beschleunigt den Tabellenerstellungsvorgang, da er alle Basisaufgaben für Sie durchführt. Im ersten Bildschirm eines Formular-Assistenten können Sie die Felder auswählen, die Ihr Formular enthalten soll. Diese Felder können aus einer oder mehreren Tabellen stammen. Wenn Sie zum Erstellen eines Formulars auf der Basis mehrerer Tabellen einen Formular-Assistenten verwenden, erstellt Microsoft Access hinter dem Formular eine SQL-Anweisung. Die SQL-Anweisung beinhaltet Informationen dazu, welche Tabellen und Felder verwendet werden sollen.

Einfaches Formular auf der Basis mehrerer Tabellen

Mit einem Formular-Assistenten können Sie ein Formular erstellen, das Daten aus mehreren Tabellen als "einfaches Formular" oder als "hierarchisches Formular" anzeigt. Ein Beispiel für ein einfaches Formular ist ein Formular, das Artikel und Lieferanten anzeigt.

Einfaches Formular auf der Basis mehrerer Tabellen

Hierarchisches Formular auf der Basis mehrerer Tabellen

Ein hierarchisches Formular ist ein Formular mit einem oder mehreren Unterformularen. Verwenden Sie Unterformulare, wenn Sie Daten aus Tabellen anzeigen möchten, die eine 1:n-Beziehung haben. Sie können z. B. ein Formular Kategorien mit Daten aus einer Kategorien- und aus einer Artikeltabelle definieren.

Hierarchisches Formular auf der Basis mehrerer Tabellen

Synchronisierte Formulare

Sie können Ihre Daten auch ohne Verwendung eines Unterformulars hierarchisch darstellen. Angenommen, Sie haben ein Formular mit sehr vielen Steuerelementen und nicht genügend Platz für ein Unterformular. In diesem Fall können Sie mit Hilfe eines Formular-Assistenten synchronisierte Formulare erstellen. Wenn Sie in einem Formular auf eine Befehlsschaltfläche klicken, wird ein anderes Formular geöffnet, das mit dem Datensatz im ersten Formular synchronisiert ist.

Zurück zu Erstellen eines Formulars auf der Basis mehrerer Tabellen


 Gruppen

Gruppen

Sie können verschiedene Typen von Datenbankobjekten in einer Gruppe organisieren. Eine Gruppe besteht aus Verknüpfungen mit den Datenbankobjekten, die zu ihr gehören; das Hinzufügen eines Objekts zu einer Gruppe ändert nicht den tatsächlichen Speicherort dieses Objekts. Wenn Sie auf die Objekt-Leiste klicken und dann auf das Symbol für einen bestimmten Objetktyp, wird jedes Datenbankobjekt dieses Typs in der Objekt-Liste - selbst wenn dieses Objekt ebenfalls zu einer Gruppe gehört, angezeigt. Wenn Sie auf die Gruppen-Leiste im Datenbankfenster klicken und dann auf das Symbol Ihrer Gruppe, werden alle Datenbankobjekte, die Sie zu der Gruppe hinzugefügt haben, in der Objekt-Liste angezeigt.

Sie können miteinander in Beziehung stehende Objekte verschiedener Typen in einer Gruppe anordnen. So können Sie beispielsweise ein Formular mit mehreren Unterformularen leichter verwalten, wenn Sie eine Gruppe erstellen, die das Hauptformular enthält, die Unterformulare und die Tabellen oder Abfragen, auf denen sie basieren. Sie können außerdem eine Gruppe für die Formulare und Berichte erstellen, die Sie am häufigsten verwenden; wenn Sie auf das Symbol dieser Gruppe klicken, werden sowohl die Formulare als auch die Berichte in der ObjektListe im Datenbankfenster angezeigt.


 Anpassen der Anwendungsumgebung mit Hilfe von Microsoft Access-Benutzerprofilen

Anpassen der Anwendungsumgebung mit Hilfe von Microsoft Access-Benutzerprofilen

Microsoft Access stellt Datenbankeinstellungen und Startoptionen zur Verfügung, mit denen Sie in der Regel all Ihren Anforderungen gerecht werden können. Wenn Sie jedoch Anwendungen entwickeln, können Sie zum Anpassen der Umgebung Ihrer Anwendung die Vorteile eines Access-Benutzerprofils nutzen.

Ein Benutzerprofil ist eine spezielle Gruppe von Windows-Registrierungsschlüsseln, die Sie erstellen können, um Standardeinstellungen für Access und die Microsoft Jet-Datenbank-Engine zu überschreiben und um zusätzliche Laufzeitoptionen festzulegen. Später können Sie dieses Access-Benutzerprofil beim Starten Ihrer Anwendung mit der Befehlszeilenoption /profile angeben.

Access-Benutzerprofile können beispielsweise folgenden Zwecken dienen:

  • Verhindern, dass andere Benutzer Standardeinstellungen für Access durch Ändern von Datenbankeigenschaften und Startoptionen ändern und damit Konflikte mit den Anforderungen Ihrer Anwendung hervorrufen.

  • Sicherstellen, dass andere Programme, die Microsoft Jet verwenden, nicht die benutzerdefinierten Einstellungen überschreiben, wenn es sich um eine Anwendung handelt, die weitergegeben wird.

  • Testen Ihrer Anwendung mit unterschiedlichen Konfigurationen.

Anmerkung Ein Benutzerprofil, das Sie für den Start von Access auf der Befehlszeilenebene verwenden, ist etwas anderes als das Benutzerprofil, das zur Anmeldung beim Betriebssystem definiert worden ist. Ein Access-Benutzerprofil gilt nur für Access und nur dann, wenn Sie Access von der Befehlszeile her starten. Ein für das Betriebssystem definiertes Benutzerprofil gilt für jede unter Kontrolle des Betriebssystems ausgeführte Anwendung und dient der Verwaltung der Systemdaten individueller Benutzer.


 Info über das Definieren von Standardwerten

Info über das Definieren von Standardwerten

Unter Verwendung der Standardwert-Eigenschaft können Sie einen Wert festlegen, der beim Hinzufügen eines neuen Datensatzes automatisch eingegeben wird. Wenn z. B. die meisten Ihrer Lieferanten aus München stammen, können Sie für das Feld Stadt der Tabelle Lieferanten den Standardwert München festlegen. Sie können den Standardwert akzeptieren oder durch einen neuen Wert überschreiben.

Sie können die DefaultValue-Eigenschaft für ein Feld in der Tabellenentwurfsansicht oder für ein Steuerelement in der Formularentwurfsansicht festlegen. In der Entwurfsansicht für Datenzugriffsseiten verwenden Sie die Value-Eigenschaft. In der Regel werden Sie den Standardwert in der Tabellenentwurfsansicht hinzufügen, da dieser Wert auf Steuerelemente angewendet wird, die auf diesem Feld basieren (vorausgesetzt, Sie erstellen die Steuerelemente nach dem Festlegen der Eigenschaft in der Tabellenentwurfsansicht). Wenn es sich um ein ungebundenes Steuerelement handelt, oder wenn das Steuerelement auf Daten aus einer verknüpften (externen) Tabelle basiert, müssen Sie den Standardwert für das Steuerelement im Formular oder auf der Datenzugriffsseite festlegen.

Zurück zu Definieren eines Standardwerts, der automatisch in ein Feld oder Steuerelement eingegeben wird


 Info über das Definieren des Anzeigeformats für ein Feld oder Steuerelement

Info über das Definieren des Anzeigeformats für ein Feld oder Steuerelement

Unter Verwendung der Format-Eigenschaft können Sie das Datenanzeigeformat für ein Feld oder ein Steuerelement festlegen. Sie können z. B. festlegen, dass alle Datumsangaben unter Verwendung des Tag/Monat/Jahr-Formats oder eines anderen Formats angezeigt werden sollen. Sie können aus einer Liste vordefinierter Formate für Felder vom Datentyp AutoWert, Zahl, Währung, Datum/Uhrzeit und Ja/Nein wählen oder ein benutzerdefiniertes Format verwenden. Sie können für jedes Feld, das nicht vom OLE-Objekt-Datentyp ist, ein beliebiges Format definieren.

Sie können die Format-Eigenschaft in der Tabellenentwurfsansicht, der Abfrageentwurfsansicht, der Formularentwurfsansicht oder der Berichtsentwurfsansicht einstellen. In der Regel stellen Sie die Eigenschaft für das Feld in der Tabellenentwurfsansicht ein. Auf diese Weise wird die Einstellung automatisch auf das Feld in der Abfrage und auf Steuerelemente in einem Formular oder Bericht angewendet, die an dieses Feld gebunden sind (vorausgesetzt, Sie erstellen die Steuerelemente nach dem Einstellen der Eigenschaft in der Tabellenentwurfsansicht). In bestimmten Fällen kann es jedoch erforderlich sein, die Eigenschaft in der Abfrageentwurfsansicht, der Formularentwurfsansicht oder der Berichtsentwurfsansicht einzustellen. Dies ist z. B. der Fall, wenn Sie in einem Tabellendatenblatt ein anderes Format als in einem Bericht anzeigen möchten. Sie können in diesem Fall die Format-Eigenschaft für das Feld in der Abfrageentwurfsansicht einstellen und dann Ihren Bericht auf die Abfrage basieren. Wenn Sie ein ungebundenes Steuerelement verwenden, müssen Sie die Format-Eigenschaft in der Entwurfsansicht für Berichte oder Formulare einstellen.

Anmerkung Wenn Sie Literalzeichen erstellen möchten, die das Eingeben von Daten in einem vordefinierten Format erleichtern, können Sie an Stelle eines Datenanzeigeformats ein Eingabeformat verwenden. Klicken Sie auf [image] , wenn Sie Informationen zu den Unterschieden zwischen einem Anzeigeformat und einem Eingabeformat wünschen.

Zurück zu Definieren des Datenanzeigeformats für ein Feld oder ein Steuerelement


 Info über das Definieren der Anzahl der Dezimalstellen, die in einem Feld oder Steuerelement angezeigt werden sollen

Info über das Definieren der Anzahl der Dezimalstellen, die in einem Feld oder Steuerelement angezeigt werden sollen

Unter Verwendung der DecimalPlaces-Eigenschaft können Sie die Anzahl der Dezimalstellen festlegen, die in einem Feld vom Datentyp Zahl oder Währung oder in einem Steuerelement mit Daten vom Typ Zahl oder Währung angezeigt werden sollen. Sie können die DecimalPlaces-Eigenschaft in der Tabellenentwurfsansicht, der Abfrageentwurfsansicht, der Formularentwurfsansicht oder der Berichtsentwurfsansicht einstellen. In der Regel werden Sie die Eigenschaft für das Feld in der Tabellenentwurfsansicht einstellen. Auf diese Weise wird die Einstellung automatisch auf das Feld in der Abfrageentwurfsansicht und auf Steuerelemente in einem Formular oder Bericht angewendet, die an das Feld gebunden sind (vorausgesetzt, Sie erstellen die Steuerelemente nach dem Einstellen der Eigenschaft in der Tabellenentwurfsansicht). In bestimmten Fällen kann es jedoch erforderlich sein, die Eigenschaft in der Abfrageentwurfsansicht, der Formularentwurfsansicht oder der Berichtsentwurfsansicht einzustellen, z. B.,wenn Sie in einem Tabellendatenblatt eine andere Anzahl von Dezimalstellen anzeigen möchten als in einem Bericht. In diesem Fall können Sie die Eigenschaft für das Feld in der Abfrageentwurfsansicht einstellen und dann Ihren Bericht auf die Abfrage basieren. Wenn Sie ein ungebundenes Steuerelement verwenden, müssen Sie die DecimalPlaces-Eigenschaft in der Entwurfsansicht für Formulare oder Berichte einstellen.

Zurück zu Definieren der Anzahl der Dezimalstellen, die in einem Feld oder Steuerelement angezeigt werden sollen


 Info über das Löschen einer Gruppe von Datensätzen mit einer Abfrage

Info über das Löschen einer Gruppe von Datensätzen mit einer Abfrage

Mit einer einzelnen Löschabfrage können Sie Datensätze aus einer einzelnen Tabelle, aus mehreren Tabellen mit einer 1:1-Beziehung oder aus mehreren Tabellen mit einer 1:n-Beziehung löschen, wenn die Option Löschweitergabe an Detaildatensatz aktiviert ist (z. B. alle Kunden aus Irland sowie deren Aufträge). Wenn Sie jedoch zusammen mit der Tabelle auf der 1-Seite die Tabelle auf der n-Seite einbeziehen müssen, müssen Sie die Abfrage zum Hinzufügen von Kriterien zweimal ausführen, da eine Abfrage nicht gleichzeitig Datensätze aus der Primärtabelle und den verknüpften Tabellen löschen kann.

Sie erkennen eine 1:n-Beziehung in der Entwurfsansicht für Abfragen an den Verknüpfungen zwischen Tabellen. Wennn ein Ende einer Verknüpfung mit dem Unendlichkeitssymbol geknennzeichnet ist [image], handelt es sich um eine 1:n-Beziehung. Wenn beide Enden mit einer 1 gekennzeichnet sind, handelt es sich um eine 1:1-Beziehung.

Zurück zu Löschen von einer Gruppe von Datensätzen mit einer Abfrage


 Info über das Festlegen einer alternativen Schriftart für die Ersatzschriftartunterstützung

Info über das Festlegen einer alternativen Schriftart für die Ersatzschriftartunterstützung

Es kann vorkommen, dass Sie in einem Datenblatt, Formular oder Bericht Zeichen darstellen müssen, die von der Standardschriftart nicht unterstützt werden. Wenn die Daten beispielsweise sowohl Zeichen in lateinischer Schrift als auch Zeichen einer asiatischen Schrift enthalten, unterstützt die von Ihnen verwendete Standardschriftart möglicherweise die asiatischen Schriftzeichen nicht.

Die Unterstützung doppelter Schriftarten ermöglicht es Ihnen, eine Ersatzschriftart festzulegen. Wenn die Standardschriftart ein bestimmtes Zeichen nicht enthält, verwendet Microsoft Access zur Anzeige des Zeichens die Ersatzschriftart. Schriftgrad und Schriftbreite des Zeichens stimmen mit Schriftgrad und Schriftbreite der in diesem Bereich des Datenblatts, Formulars oder Berichts verwendeten Standardschriftart überein.

Anmerkung Wenn Ihre Daten nur Zeichen nichtasiatischer Schriften, beispielsweise englische, griechische oder russische Schriftzeichen, sowie außerdem die Zeichen einer bestimmten asiatischen Schrift enthalten, sollten Sie eine Ersatzschriftart festlegen. Microsoft Office stellt zwar eine Universalschriftart, die Schriftart Arial Unicode MS, bereit, die alle im Unicode 2.1 -Standard definierten Zeichen und Symbole enthält. Aber zur Gewährleistung eines besseren Leistungsverhaltens sollten Sie diese Schriftart nur bei entsprechendem Bedarf verwenden.

Der folgende Hyperlink führt zu weiteren Informationen über die Unterstützung von Unicode-Zeichen und die Schriftart Arial Unicode MS.

Der folgende Hyperlink führt zu weiteren Informationen über die Untersützung von Mehrsprachigkeit in Microsoft Office.

Zurück zum Thema Festlegen einer alternativen Schriftart für die Ersatzschriftartunterstützung


 Info über Feldeigenschaften

Info über Feldeigenschaften

Für jedes Feld gibt es eine Gruppe von Eigenschaften, mit denen Sie festlegen, wie die Daten in einem Feld gespeichert, behandelt oder angezeigt werden. Sie können z. B. festlegen, wie viele Zeichen maximal in ein Textfeld eingegeben werden dürfen. Dazu stellen Sie die Feldgröße-Eigenschaft eine Feldes ein. Zum Einstellen von Feldeigenschaften zeigen Sie eine Tabelle in der Entwurfsansicht an, wählen das Feld im oberen Teil des Fensters aus und wählen dann im unteren Teil des Fensters die gewünschte Eigenschaft.

Welche Eigenschaften für ein Feld zur Verfügung stehen, ist abhängig von dem für das Feld ausgewählten Datentyp.

Tipp Wenn Sie in einem Formular oder Bericht ein gebundenes Steuerelement durch Ziehen eines Feldes aus der Feldliste erstellen, kopiert Microsoft Access bestimmte Eigenschaften von diesem Feld auf das Steuerelement. Auf dieses Weise können Sie sicherstellen, dass Ihre Einstellungen konsistent sind, wenn Sie Felder zu einem Formular oder Bericht hinzufügen. Klicken Sie auf [image] , wenn Sie weitere Informationen wünschen.

Zurück zu Einstellen von Feldeigenschaften zum Anpassen der Einstellungen zum Speichern, Behandeln und Anzeigen von Daten


 Zusatzinfo: Gruppieren von Datensätzen in einer Datenzugriffsseite nach Maßgabe der ersten n Zeichen eines Textwerts

Zusatzinfo: Gruppieren von Datensätzen in einer Datenzugriffsseite nach Maßgabe der ersten n Zeichen eines Textwerts

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datentypen, die zur Gruppierung von Datensätzen anhand von Präfixzeichen erforderlich sind

Anmerkungen zur Seitenansicht (bzw. Anzeige in Microsoft Internet Explorer) einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Anmerkungen zur Entwurfsansicht einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Optionen für Eigenschaften im Feld Sortieren und gruppieren

Datentypen, die zur Gruppierung von Datensätzen anhand von Präfixzeichen erforderlich sind

Wenn Sie Datensätze nach den ersten n Zeichen (bzw. dem Präfix) eines Textfelds gruppieren, muss das zum Gruppieren verwendete Steuerelement an ein Feld gebunden sein, das einen der folgenden Datentypen aufweist: den Datentyp Text, wenn es sich um ein Feld in einer Microsoft Access-Datenbank (.mdb) handelt, oder einen der Datentypen char, varchar, nchar oder nvarchar, wenn sich das Feld auf ein Microsoft Access-Projekt (.adp) bezieht.

Zurück zum Anfang

Anmerkungen zur Seitenansicht (bzw. Anzeige in Microsoft Internet Explorer) einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Um Datensätze anhand der ersten n Zeichen zu gruppieren, benötigen Sie zwei Steuerelemente, die an das Feld gebunden sind, das zum Gruppieren verwendet wird. Das eine Steuerelement dient dazu, die Datensätze nach Maßgabe der angegebenen Zahl von Präfixzeichen zu gruppieren und die Präfixzeichen anschließend anzuzeigen. Das zweite Steuerelement, das der nächstniedrigeren Gruppierungsebene zugeordnet ist, wird zum Sortieren der Datensätze verwendet und zeigt den tatsächlichen Feldwert an.

Im folgenden Beispiel stammen die Datensätze aus der Tabelle Artikel. Auf der ersten Gruppierungsebene werden die Datensätze nach dem ersten Buchstaben der Artikelbezeichnung (Feld Artikelname) gruppiert. Auf der nächstniedrigeren Gruppierungsebene sortiert die Seite die Datensätze nach den tatsächlichen Werten im Feld Artikelname und zeigt sie entsprechend an.

Seitenansicht (bzw. Internet Explorer-Ansicht) einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Zurück zum Anfang

Anmerkungen zur Entwurfsansicht einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Die folgende Abbildung zeigt das Layout der Beispielseite in der Entwurfsansicht.

Entwurfsansicht einer Seite, die ihre Datensätze nach den Anfangszeichen eines Feldwerts gruppiert

Zurück zum Anfang

Optionen für Eigenschaften im Feld Sortieren und gruppieren

Die folgende Tabelle listet die Eigenschaften auf, deren Einstellungen für die Beispielseite im Feld Sortieren und gruppieren festgelegt wurden. Wenn Sie für die Standardsortierung-Eigenschaft weder den Wert Aufsteigend noch Absteigend angeben, sortiert Microsoft Access die Datensätze in aufsteigender Reihenfolge.

Eigenschaft | Gruppendatensatzquelle Artikel-Artikelname | Gruppendatensatzquelle Artikel
Beschriftungsbereich | Nein | Ja
Gruppenkopf | Ja | Ja
Gruppenfuß | Nein | Nein
Datensatznavigationsbereich | Ja | Ja
Standardmäßig erweitert | Nein | Nein
Datenseitengröße | 3 | 3
Gruppieren nach | Anfangszeichen | Jedem Wert
Intervall | 1.0 | 1.0
Standardsortierung | GruppierungArtikelname | Artikelname

Anmerkung Bei Gruppierung nach einem Feld erzeugt Access einen Aliasnamen für das Steuerelement. Dabei wird dem Namen des Steuerelements das Präfix "Gruppierung" in der Steuerelementinhalt-Eigenschaft vorangestellt. Beispiel: GruppierungArtikelname: Artikelname. Bei Verweisen auf dieses Steuerelement in einem Ausdruck oder dem Wert einer Eigenschaft müssen Sie diesen Aliasnamen verwenden.

Zurück zum Anfang

Zurück zum Thema Gruppieren von Datensätzen in einer Datenzugriffsseite nach Maßgabe der ersten n Zeichen eines Textwerts


 Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach Intervallen von Werten des Datentyps "Autowert", "Währung" oder "Zahl"

Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach Intervallen von Werten des Datentyps "Autowert", "Währung" oder "Zahl"

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datentypen, die zur Gruppierung nach Intervallen von Werten des Typs Autowert, Währung oder Zahl erforderlich sind

Anmerkungen zur Seitenansicht (bzw. der Internet Explorer-Ansicht) einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Anmerkungen zur Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Optionen für Eigenschaften im Dialogfeld Sortieren und gruppieren

Datentypen, die zur Gruppierung nach Intervallen von Werten des Typs Autowert, Währung oder Zahl erforderlich sind

Wenn Sie Datensätze nach Intervallen von Werten des Typs Autowert, Währung oder Zahl gruppieren, muss das zum Gruppieren verwendete Steuerelement an ein Feld gebunden sein, das einen der folgenden Datentypen ausweist: Autowert, Währung oder Zahl, wenn es sich um ein Feld in einer Microsoft Access -Datenbank (.mdb) handelt, oder einen der Datentypen decimal, numeric, int, smallint, tinyint, money, smallmoney, float oder real, wenn sich das Feld auf ein Microsoft Access-Projekt (.adp) bezieht.

Zurück zum Anfang

Anmerkungen zur Seitenansicht (bzw. der Internet Explorer-Ansicht) einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Um Datensätze anhand eines Intervalls zu gruppieren, benötigen Sie zwei Steuerelemente, die an das Feld gebunden sind, das zum Gruppieren verwendet wird. Das eine Steuerelement dient dazu, die Datensätze nach Maßgabe des Intervalls zu gruppieren und die Feldwerte anschließend als Intervalle anzuzeigen. Das zweite Steuerelement, das der nächstniedrigeren Gruppierungsebene zugeordnet ist, wird zum Anzeigen der vollständigen Feldwerte verwendet. In dem folgenden Beispiel stammen die Datensätze aus einer Abfrage namens Umsätze. Die Datensätze werden über ein Steuerelement, das an ein Feld namens Umsatzbetrag gebunden ist, nach Intervallen von 100 Dollar gruppiert. Auf der nächstniedrigeren Gruppierungsebene sortiert die Seite die Datensätze nach den tatsächlichen Werten im Feld Umsatzbetrag und zeigt sie dann an.

Seitenansicht (bzw. Internet Explorer-Ansicht) einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Zurück zum Anfang

Anmerkungen zur Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Die folgende Abbildung zeigt das Layout der Beispielseite in der Entwurfsansicht.

Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Intervallen von 100 Dollar gruppiert

Zurück zum Anfang

Optionen für Eigenschaften im Dialogfeld Sortieren und gruppieren

Die folgende Tabelle listet die Eigenschaften auf, deren Einstellungen für die Beispielseite im Feld Sortieren und gruppieren festgelegt wurden. Wenn Sie für die Standardsortierung-Eigenschaft weder den Wert Aufsteigend oder Absteigend angeben, sortiert Microsoft Access die Datensätze in aufsteigender Reihenfolge.

Eigenschaft | Gruppendatensatzquelle Umsätze-Umsatzbetrag | Gruppendatensatzquelle Umsätze
Beschriftungsbereich | Nein | Ja
Gruppenkopf | Ja | Ja
Gruppenfuß | Nein | Nein
Datensatznavigationsbereich | Ja | Ja
Standardmäßig erweitert | Nein | Nein
Datenseitengröße | 3 | 3
Gruppieren nach | Intervall | Jedem Wert
Intervall | 100 | 1.0
StandardSortierung | GruppierungUmsatzbetrag | Umsatzbetrag

Anmerkung Bei Gruppierung nach einem Feld erzeugt Access einen Aliasnamen für das Steuerelement. Dabei wird dem Namen des Steuerelements das Präfix "Gruppierung" in der Steuerelementinhalt-Eigenschaft vorangestellt. Beispiel: GruppierungUmsatzbetrag: Umsatzbetrag. Bei Verweisen auf dieses Steuerelement in einem Ausdruck oder dem Wert einer Eigenschaft müssen Sie diesen Aliasnamen verwenden.

Zurück zum Anfang

Zurück zum Thema Gruppieren von Datensätzen einer Datenzugriffsseite nach Intervallen von Werten des Typs Autowert, Währung oder Zahl


 Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach datums- oder uhrzeitangabenbezogenen Intervallen

Zusatzinfo: Gruppieren von Datensätzen einer Datenzugriffsseite nach datums- oder uhrzeitangabenbezogenen Intervallen

Diese Seite enthält Übersichtsinformationen zu folgenden Themen:

Datentypen, die zur Gruppierung von Datensätzen einer Datenzugriffsseite nach datums- oder uhrzeitangabenbezogenen Intervallen erforderlich sind

Anmerkungen zur Seitenansicht (bzw. der Internet Explorer-Ansicht) einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

Anmerkungen zur Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

Optionen für Eigenschaften im Dialogfeld Sortieren und gruppieren

Datentypen, die zur Gruppierung von Datensätzen einer Datenzugriffsseite nach datums- oder uhrzeitangabenbezogenen Intervallen erforderlich sind

Wenn Sie Datensätze nach datums- oder zeitangabenbezogenen Intervallen gruppieren, muss das zum Gruppieren verwendete Steuerelement an ein Feld gebunden sein, das einen der folgenden Datentypen aufweist: den Datentyp Datum/Uhrzeit, wenn es sich um ein Feld in einer Microsoft Access-Datenbank (.mdb) handelt, oder entweder datetime oder smalldatetime, wenn sich das Feld auf ein Microsoft Access-Projekt (.adp) bezieht.

Zurück zum Anfang

Anmerkungen zur Seitenansicht (bzw. der Internet Explorer-Ansicht) einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

Um Datensätze nach datums- oder zeitangabenbezogenen Intervallen zu gruppieren, benötigen Sie zwei Steuerelemente. Das eine Steuerelement, das zum Gruppieren verwendet wird, ist an das Feld gebunden, das die Datums- oder zeitbezogene Angabe enthält. Dieses Element ist nicht sichtbar. Das zweite Steuerelement ist sichtbar und an einen Ausdruck gebunden, der das datums- oder zeitangabenbezogene Intervall zurückgibt. Im folgenden Beispiel stammen die Werte aus einer Abfrage namens Übersicht. Die Seite verwendet ein nicht sichtbares Steuerelement, das an das Feld Lieferdatum gebunden ist, um die Datensätze innerhalb der höheren Gruppeneben nach Monaten zu gruppieren. Innerhalb derselben Gruppierungsebene gibt es ein weiteres Steuerelement, das sichtbar ist und an einen Ausdruck gebunden, der einen in Monaten ausgedrückten Intervallwert für den Inhalt des Felds Lieferdatum zurückgibt.

Seitenansicht einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

Zurück zum Anfang

Anmerkungen zur Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

In der Entwurfsansicht der Beispielseite können Sie das ausgeblendete Steuerelement sehen, das der Gruppierung der Datensätze auf der ersten Gruppierungsebene dient.

Entwurfsansicht einer Datenzugriffsseite, die ihre Datensätze nach Monatsintervallen gruppiert

Zurück zum Anfang

Optionen für Eigenschaften im Feld Sortieren und gruppieren

Die folgende Tabelle listet die Eigenschaften auf, deren Einstellungen für die Beispielseite im Feld Sortieren und gruppieren festgelegt wurden. Wenn Sie für die Standardsortierung-Eigenschaft weder den Wert Aufsteigend noch Absteigend angeben, sortiert Microsoft Access die Datensätze in aufsteigender Reihenfolge.

Eigenschaft | Gruppendatensatzquelle Übersicht-Lieferdatum | Gruppendatensatzquelle Übersicht
Beschriftungsbereich | Nein | Ja
Gruppenkopf | Ja | Ja
Gruppenfuß | Nein | Nein
Datensatznavigationsbereich | Ja | Ja
Standardmäßig erweitert | Nein | Nein
Datenseitengröße | 3 | 3
Gruppieren nach | Jahr | Qrtl
Intervall | 1.0 | 1.0
Standardsortierung | GruppierungLieferdatum | Lieferdatum

Anmerkung Bei Gruppierung nach einem Feld erzeugt Access einen Aliasnamen für das Steuerelement. Dabei wird dem Namen des Steuerelements das Präfix "Gruppierung" in der ControlSource-Eigenschaft vorangestellt. Beispiel: GruppierungLieferdatum: Lieferdatum. Bei Verweisen auf dieses Steuerelement in einem Ausdruck oder dem Wert einer Eigenschaft müssen Sie diesen Aliasnamen verwenden.

Zurück zum Anfang

Zurück zum Thema Gruppieren von Datensätzen einer Datenzugriffsseite nach datums- oder zeitangabenbezogenen Intervallen


 Info über Indizes in einer Access-Datenbank

Info über Indizes in einer Access-Datenbank

Ein Index beschleunigt das Suchen und Sortieren von Datensätzen in Microsoft Access. Microsoft Access verwendet Indizes in einer Tabelle, vergleichbar mit einem Index in einem Buch: zum Suchen nach Daten sucht Access im Index nach der Position der Daten. Sie können Indizes auf der Basis eines einzelnen Feldes oder mehrerer Felder erstellen. Indizes über mehrere Felder erlauben das Differenzieren zwischen Datensätzen, die im ersten Feld identische Werte enthalten.

Auswählen der zu indizierenden Felder

Es empfiehlt sich, die Felder zu indizieren, in denen Sie häufig suchen, die Sie sortieren oder die Sie in Abfragen mit Feldern in anderen Tabellen verknüpfen. Indizes können jedoch bestimmte Aktionsabfragen, wie z. B. Anfügeabfragen, verlangsamen, wenn zum Durchführen dieser Operationen die Indizes für viele Felder aktualisiert werden müssen.

Der Primärschlüssel einer Tabelle wird automatisch indiziert. Felder, deren Datentyp OLE-Objekt lautet, können nicht indiziert werden. Für alle anderen Felder sollten Sie einen Index in Erwägung ziehen, wenn alle der folgenden Bedingungen vorliegen:

  • Der Datentyp des Feldes lautet Text, Zahl, Währung oder Datum/Uhrzeit.

  • Sie gehen davon aus, dass Sie nach Werten suchen müssen, die in diesem Feld gespeichert sind.

  • Sie gehen davon aus, dass Sie Werte in diesem Feld sortieren werden.

  • Sie gehen davon aus, dass in diesem Feld viele verschiedene Werte gespeichert werden. Wenn viele Werte im Feld identisch sind, wird ein Index Abfragen nicht deutlich beschleunigen.

Zusammengesetzte Indizes

Wenn Sie davon ausgehen, dass Sie häufig in zwei oder mehr Feldern gleichzeitig suchen oder diese gleichzeitig sortieren müssen, können Sie einen Index erstellen, der beide Felder kombiniert. Angenommen, Sie legen häufig in der gleichen Abfrage Kriterien für die Felder Nachname und Vorname fest, ziehen Sie in einem solchen Fall in Erwägung, über beide Felder einen zusammengesetzten Index zu erstellen.

Wenn Sie eine Tabelle über einen zusammengesetzten Index sortieren, sortiert Microsoft Access zuerst über das im Index zuerst definierte Feld. Wenn es Datensätze mit identischen Werten in diesem ersten Feld gibt, sortiert Microsoft Access anschließend über das zweite im Index definierte Feld u.s.w.

Zurück zu Erstellen eines Indexes zum schnelleren Suchen und Sortieren von Datensätzen


 Info über das Erstellen von Eingabeformaten

Info über das Erstellen von Eingabeformaten

Mit Hilfe der Eingabeformat-Eigenschaft können Sie ein Eingabeformat (gelegentlich auch als "Feldvorlage" bezeichnet) erstellen, das Literalzeichen anzeigt, die festlegen, wie Daten in ein Feld oder Steuerelement eingegeben werden. Das folgende Eingabeformat legt z. B. fest, dass der Benutzer Telefonnummern so eingeben muss, dass die Ziffern einer amerikanischen Ortskennzahl und einer anschließenden Rufnummer entsprechen und dass an jeder Leerstelle ausschließlich Zahlen eingegeben werden können. Der Benutzer füllt dann nur noch die Leerstellen aus.

Eingabeformat für eine Telefonnummer

Sie können die Eingabeformat-Eigenschaft in der Tabellenentwurfsansicht, der Abfrageentwurfsansicht oder der Formularentwurfsansicht einstellen. In der Regel stellen Sie die Eigenschaft für das Feld in der Tabellenentwurfsansicht ein. Auf diese Weise wird sichergestellt, dass das Eingabeformat automatisch auf das Feld in der Abfrageentwurfsansicht und auf Steuerelemente in einem Formular oder Bericht angewendet wird, die an das Feld gebunden sind (vorausgesetzt, Sie erstellen das Steuerelement nach dem Einstellen der Eigenschaft in der Tabellenentwurfsansicht). Angenommen, Sie möchten das Eingabeformat in einer Tabelle weglassen, in einem Textfeld jedoch verwenden. Wenn Sie in diesem Fall ein ungebundenes Steuerelement verwenden, müssen Sie die Eingabeformat-Eigenschaft in der Entwurfsansicht für das Formular einstellen.

Anmerkung Wenn Sie festlegen möchten, wie gespeicherte Daten angezeigt werden sollen, können Sie an Stelle eines Eingabeformats ein Anzeigeformat verwenden. Zum Anzeigen von Informationen zum Unterschied zwischen einem Anzeigeformat und einem Eingabeformat klicken Sie auf [image] , wenn Sie Informationen über den Unterschied zwischen einem Anzeigeformat und einem Eingabeformat wünschen.

Zurück zu Erstellen eines Eingabeformats zum Steuern der Eingabe von Daten in ein Feld oder Steuerelement


 Info über das Durchführen von Berechnungen in einer Abfrage

Info über das Durchführen von Berechnungen in einer Abfrage

Sie können Berechnungen in einer Abfrage mit Hilfe folgender Berechnungsarten durchführen:

  • Vordefinierte Berechnungen, Funktionen genannt, um die folgenden Werte für Datensatzgruppen oder alle Datensätze in der Abfrage zu ermitteln: Summe, Mittelwert, Anzahl, Minimum, Maximum, Standardabweichung oder Varianz.

  • Eine benutzerdefinierte Berechnung, um für die einzelnen Datensätze, die Daten aus einem oder mehreren Feldern verwenden, Berechnungen mit Zahlen, Datumsangaben und Textwerten durchzuführen. Für diese Art von Berechnungen müssen Sie ein neues berechnetes Feld direkt im Entwurfsbereich erstellen.

Statt das Ergebnis einer Berechnung anzuzeigen, können Sie es auch folgendermaßen verwenden:

  • Als Kriterium, um die Datensätze zu bestimmen, die von der Abfrage ausgewählt werden oder für die eine Aktion durchgeführt werden soll.

  • Um die Daten einer Aktualisierungsabfrage zu aktualisieren.

Zurück zu Durchführen von Berechnungen in einer Abfrage


 Info über Popupformulare und benutzerdefinierte Dialogfelder

Info über Popupformulare und benutzerdefinierte Dialogfelder

Popupformulare

Sie können ein Popupformular erstellen, um Informationen anzuzeigen oder den Benutzer zur Dateneingabe aufzufordern. Ein Popupformular wird stets gegenüber anderen geöffneten Formularen im Vordergrund angezeigt, auch wenn ein anderes Formular aktiv ist. Ein Popupformular kann gebunden oder nicht gebunden sein. Bei einem nicht gebundenen Popupformular können Sie, solange es geöffnet ist, auf andere Objekte und Menübefehle zugreifen. Sie können z. B. einem Lieferantenformular eine Befehlsschaltfläche hinzufügen, die das Popupformular Artikel öffnet. Das Popupformular zeigt dann die Artikel des im Formular Lieferanten ausgewählten Lieferanten an.

Benutzerdefinierte Dialogfelder

Wenn ein Popupformular gebunden ist, können Sie nur dann auf andere Objekte oder Menübefehle zugreifen, wenn Sie das Formular ausblenden oder schließen. Ein gebundenes Popupformular wird als benutzerdefiniertes Dialogfeld bezeichnet. Sie können z. B. ein benutzerdefiniertes Dialogfeld erstellen, das fragt, welchen Bericht Sie drucken möchten.

Weitere Informationen zur Verwendung von Formularen und zum Anzeigen von Informatinen finden Sie unter "Verwenden von Formularen zum Sammeln, Filtern und Anzeigen von Informationen" unter Erstellen von Anwendungen mit Formularen und Berichten.

Zurück zu Erstellen eines Popupformulars oder eines benutzerdefinierten Dialogfeldes


Info über das Wiederherstellen von Symbol- und Menüleisten oder einzelnen Schaltflächen, Befehlen oder Menüs

Sie können unterschiedliche Aspekte einer eingebauten Menüleiste wiederherstellen:

  • Vollständiges Wiederherstellen einer Symbol- oder Menüleiste mit allen Standardeinstellungen, wenn die ursprünglichen Schaltflächen oder Menüs und Befehle und die ursprünglichen Eigenschafteneinstellungen wiederhergestellt werden sollen. Microsoft Access stellt dabei auch die Eigenschafteneinstellungen der Symbol- oder Menüleiste (wie z.B. die Bildschirmposition und die Größe der Leiste oder ob dieses standardmäßig ein- oder ausgeblendet ist) wieder her.

  • Wiederherstellen aller Originalschaltflächen oder -menüs (einschließlich der Kontextmenüs), ohne dass dabei die Eigenschaften der Symbol- oder Menüleiste (wie z.B. deren Bildschirmposition oder Größe) wiederhergestellt werden.

  • Wiederherstellen einer einzelnen Schaltfläche, eines Befehls oder eines Menüs (nicht jedoch eines einzelnen Kontextmenüs), ohne dass alle übrigen Symbol- und Menüleisteneinstellungen verändert werden. Wenn Sie eine einzelne Schaltfläche, einen Befehl oder ein Menü wiederherstellen, wird dessen Originalzustand wiederhergestellt.

Zurück zu Wiederherstellen von Symbol- und Menüleisten oder einzelnen Schaltflächen, Befehlen oder Menüs


 Info über das Einschränken der Verwendung oder das Überprüfen der Gültigkeit von Daten

Info über das Einschränken der Verwendung oder das Überprüfen der Gültigkeit von Daten

Microsoft Access unterstützt eine Reihe von Möglichkeiten, festzulegen, wie Daten in Ihre Datenbank eingegeben werden sollen. Sie können z. B. die Eingabe von Daten in ein Feld beschränken. Dazu definieren Sie eine Gültigkeitsregel für dieses Feld. Wenn dann Daten in das Feld eingegeben werden, die die Regel nicht einhalten, zeigt Microsoft Access eine Fehlermeldung an, die dem Benutzer mitteilt, welche Art von Einträgen für dieses Feld zugelassen sind. Eine weitere Möglichkeit zum Steuern der Dateneingabe ist das Erstellen eines Eingabeformats, das die Art der Werte einschränkt, die an bestimmten Positionen in ein Feld eingegeben werden können. Diese einfachen Formen von Gültigkeitsprüfungen und Einschränkungen können Sie durch Einstellen von Eigenschaften für Felder in Tabellen oder durch Einstellen von Eigenschaften für Steuerelemente in Formularen durchführen.

In der Regel werden Sie Datengültigkeitsprüfungen und Einschränkungen für die Dateneingabe durch Einstellen von Feldeigenschaften in der Tabellenentwurfsansicht definieren. Auf diese Weise sparen Sie Zeit, da jedes Mal, wenn Sie das Feld in einem Formular verwenden, die Gültigkeitsprüfung für das Feld und andere Eigenschaften auch für die im Formular durchgeführte Dateneingabe gültig ist.

Wenn jedoch die Daten, die in ein Steuerelement in einem Formular eingegeben werden, nicht an ein Feld in einer Tabelle gebunden sind und Sie die Dateneingabe in dieses Steuerelement einschränken oder überprüfen möchten, müssen Sie die entsprechenden Eigenschaften im Formular definieren. Darüber hinaus gibt es Situationen, in denen Sie komplexere Gültigkeitsprüfungen durchführen müssen. Dazu benötigen Sie Makros oder Visual Basic für Applikationen-Code zusammen mit einem Formular. Dies ist z. B. dann der Fall, wenn Sie in der Lage sein möchten, eine Gültigkeitsregel zu überschreiben oder Werte aus unterschiedlichen Tabellen zu vergleichen.

Zurück zu Einschränken der Verwendung oder Überprüfen der Gültigkeit von Daten


 Einstellen einer Hyperlinkbasis für eine Access-Datenbank oder ein Access-Projekt

Einstellen einer Hyperlinkbasis für eine Access-Datenbank oder ein Access-Projekt

Wenn Sie in einer Microsoft Access-Datenbank oder in einem Microsoft Access-Projekt einen Hyperlink erstellen, können Sie den Pfad für das Hyperlinkziel auf eine feste Adresse festlegen, die das Ziel durch eine vollständige Adresse - beispielsweise C:\DokumenteUmsätze.doc identifiziert (absoluter Hyperlink) - oder Sie können eine relative Pfadadresse angeben und damit einen relativen Hyperlink definieren. Die Pfadangabe eines relativen Hyperlinks lässt sich recht einfach ändern, indem Sie die Hyperlinkbasis der Access-Datenbank oder des Access-Projekts modifizieren. Als Wert der HyperlinkBasis-Eigenschaft einer Access-Datenbank oder eines Access-Projekts kann eine URL-Adresse, eine Netzwerkadresse oder die Adresse einer Datei auf Ihrer Festplatte angegeben werden.

Angenommen, Sie möchten Hyperlinks zu Webseiten auf einem Intranet-Server in Ihrer Access-Datenbank oder in Ihrem Access-Projekt verwenden. Wenn Sie für die Hyperlinkbasis den Wert http://Servername1 festlegen, können Sie einen Hyperlink als relativen Link erstellen, beispielsweise Webseite.htm. Durch Klicken auf diesen Hyperlink wird die Webseite mit der Adresse http://Servername1/Webseite.htm geöffnet. Sollten Sie anschließend die Webseiten auf einen anderen Intranet-Server verschieben, dann brauchen Sie nur den Wert der HyperlinkBasis-Eigenschaft in http://Servername2 umzuändern, um alle relativen Hyperlinks in der Access-Datenbank oder im Access-Projekt entsprechend anzupassen.

Zurück zum Einstellen einer Hyperlinkbasis für eine Access-Datenbank oder ein Access-Projekt


 Zusatzinfo: Verwenden einer Access-Datenbank in mehreren Versionen von Microsoft Access

Zusatzinfo: Verwenden einer Access-Datenbank in mehreren Versionen von Microsoft Access

In manchen Fällen können nicht alle Benutzer einer gemeinsam genutzten Microsoft Access-Datenbank gleichzeitig auf Microsoft Access 2000 umstellen. Sie können die Datenbank mit anderen Benutzern in unterschiedlichen Versionen von Microsoft Access gleichzeitig nutzen, ohne die Originaldatenbank ändern zu müssen. Dazu können Sie Teile Ihrer Datenbank auf Microsoft Access 2000 umstellen, um die Vorteile vieler neuer Features nutzen zu können, während gleichzeitig Benutzer früherer Versionen von Microsoft Access die unveränderte Originalversion der Datenbank verwenden können. Die Benutzer aller Versionen nutzen die gleichen Daten gemeinsam.

Sie können diese Strategie sowohl für Access-Datenbanken in einer Datei als auch für eine Front-End/Back-End-Anwendung einsetzen. Um eine in Form einer einzigen Datei vorliegende Access-Datenbank in mehreren Versionen von Microsoft Access zu verwenden, konvertieren Sie die Datenbank in eine Front-End/Back-End-Anwendung. Die Daten im Back-End bleiben im Format der ältesten Microsoft Access-Version, während Sie eine Front-End-Anwendung verwenden, die in das Access 2000-Format konvertiert wurde.

Um eine Front-End/Back-End-Anwendung mit mehreren Versionen von Microsoft Access zu verwenden, konvertieren Sie den Front-End-Teil der Anwendung.

Zurück zum Thema Verwenden einer Access-Datenbank in mehreren Versionen von Microsoft Access


 Info über die Verwendung von Dateieigenschaften zum Suchen nach Dateien

Info über die Verwendung von Dateieigenschaften zum Suchen nach Dateien

Dateieigenschaften sind Detailinformationen zu einer Datei, die das Identifizieren der Datei erleichtern, wie z. B. ein beschreibender Titel, der Name des Verfassers, das Thema und Schlüsselwörter zur Identifizierung von Themen und anderen wichtigen Informationen in der Datei. Sie können Dateieigenschaften für die Datenbank, in der Sie arbeiten und für jede andere beliebige Microsoft Access-Datenbank, ein beliebiges Microsoft Access-Projekt oder eine beliebige Datenzugriffsseite erstellen.

Es gibt drei unterschiedliche Arten von Dateieigenschaften, die Sie zum Suchen nach Dateien einsetzen können:

Integrierte Dateieigenschaften Integrierte Dateieigenschaften sind Eigenschaften (wie z. B. Autor, Titel und Thema), die bereits angelegt sind, und für die Sie einen Wert eingeben können. Sie können z. B. den Namen des Autors der Datenbank eingeben und später nach allen Datenbanken suchen, die von dieser Person erstellt worden sind.

Benutzerdefinierte Dateieigenschaften Sie können benutzerdefinierte Dateieigenschaften erstellen, die einen beliebigen Wert enthalten können, den Sie zuweisen. Sie können z. B. eine Datenbankeigenschaft erstellen, die die Versionsnummer Ihrer Datenbank speichert.

Automatisch aktualisierte Dateieigenschaften Statistiken, wie z. B. die Größe der Datenbank, das Datum der Erstellung und das Datum der letzten Änderung, die automatisch für Sie verwaltet werden. Sie können zum Beispiel nach allen Datenbanken suchen, die nach dem 3. März 1998 erstellt worden oder gestern geändert worden sind.


 Informationen zum Einschränken der Verwendung oder Überprüfen der Gültigkeit von Dateneinträgen in Tabellen

Informationen zum Einschränken der Verwendung oder Überprüfen der Gültigkeit von Dateneinträgen in Tabellen

Microsoft Access unterstützt eine Reihe von Möglichkeiten zum Steuern der Dateneingabe in Felder in einer Tabelle.

Man sollte dabei zunächst berücksichtigen, ob der für ein Feld festgelegte Datentyp für dieses Feld geeignet ist. Felder vom Datentyp Datum/Uhrzeit lassen z. B. nur die Eingabe gültiger Datums- und Zeitformate zu. Wenn Sie gerade ein Feld vom Datentyp Text für Datums- und Zeitangaben verwenden, überlegen Sie, ob sich für dieses Feld nicht eher der Datentyp Datum/Uhrzeit eignet.

Es gibt darüber hinaus weitere Eigenschaften, die Sie für ein Feld einstellen können, um die Werte festzulegen, die in dieses Feld eingegeben werden können.

  • Für Felder vom Datentyp Zahl können Sie unter einer Reihe von Feldgrößen wählen und damit Art und Bereich der Werte bestimmen, die eingegeben werden dürfen.

  • Für Felder vom Datentyp Text können Sie festlegen, wie viele Zeichen maximal eingegeben werden dürfen.

  • Für Felder aller Datentypen, ausgenommen Felder vom Datentyp AutoWert (die ihre Daten selbst erzeugen), können Sie festlegen, dass die Dateneingabe obligatorisch ist.

  • Für Felder vom Datentyp Text, Datum/Uhrzeit und Zahl können Sie ein Eingabeformat mit Leerstellen definieren, die ausgefüllt werden, und bestimmen, welche Werte an diesen Leerstellen eingegeben werden dürfen.

  • Für Felder aller Datentypen, mit Ausnahme von Feldern vom Datentyp OLE-Objekt, können Sie die Eingabe von Duplikaten in ein Feld oder in eine Kombination mehrerer Felder verhindern.

Sie können außerdem zwei Arten von Gültigkeitsregeln definieren: Gültigkeitsregeln für Felder und Gültigkeitsregeln für Datensätze. Gültigkeitsregeln sind Regeln, die festlegen, welche Daten akzeptiert werden.

  • Eine Gültigkeitsregel für ein Feld wird auf ein Feld angewendet, sobald der Benutzer das Feld verlässt. Sie können z. B. für ein Feld vom Datentyp Zahl die Gültigkeitsregel >=10 Und <=100 definieren, wenn Sie möchten, dass in dieses Feld nur Werte von 10 bis 100 eingegeben werden können.

  • Eine Gültigkeitsregel für einen Datensatz bestimmt, wann ein vollständiger Datensatz gespeichert werden kann. Im Gegensatz zu Gültigkeitsregeln für Felder können Gültigkeitsregeln für Datensätze auch auf andere Felder derselben Tabelle verweisen. Daher können Sie diese auch zum Vergleichen von Werten in unterschiedlichen Feldern verwenden. Sie können z. B. den Ausdruck [Lieferdatum]<=[Bestelldatum]+30 als Gültigkeitsregel für die Tabelle Bestellungen definieren. Diese Regel stellt sicher, dass das Datum, das in das Feld Lieferdatum eingegeben wird, nicht später als 30 Tage nach dem Datum im Feld Bestelldatum liegt.

Für beide Arten von Gültigkeitsregeln können Sie eine Meldung definieren, die angezeigt wird, wenn die Regel beim Eingeben der Daten nicht eingehalten wird, und dem Benutzer mitteilt, welche Daten er eingeben darf.

Zurück zu Überprüfen der Gültigkeit oder Einschränken der Verwendung von Dateneinträgen in Tabellen


 Info über das Überprüfen der Gültigkeit von Werten in einem Feld, Datensatz oder Steuerelement

Info über das Überprüfen der Gültigkeit von Werten in einem Feld, Datensatz oder Steuerelement

Zum Überprüfen eines Wertes, der in ein Feld, einen Datensatz oder ein Steuerelement eingegeben wird, erstellen Sie eine Gültigkeitsregel und definieren dann den Text, der angezeigt werden soll, wenn die eingegebenen Daten nicht dieser Regel entsprechen. Sie können z. B. eine Regel erstellen, die festlegt, dass nur Datumsangaben aus dem Jahr 1996 eingegeben werden dürfen.

Microsoft Access unterstützt mehrere Möglichkeiten zum Definieren von Gültigkeitsregeln. Das vorliegende Thema enthält Informationen zu folgenden Punkten:

Gültigkeitsregeln für Felder

Gültigkeitsregeln für Datensätze

Gültigkeitsregeln für Steuerelemente

Gültigkeitsüberprüfung auf Formularebene mit Makros oder Visual Basic für Applikationen

Gültigkeitsregeln für Felder

Mit Hilfe einer Gültigkeitsregel für ein Feld können Sie sicherstellen, dass die in ein Feld eingegebenen Daten korrekt sind. Eine Gültigkeitsregel für ein Feld überprüft den in ein Feld eingegebenen Wert, sobald der Benutzer das Feld verlässt. Wird die Gültigkeitsregel nicht eingehalten, wird eine von Ihnen definierte Meldung angezeigt. Gültigkeitsregeln für ein Feld werden in einer Tabelle definiert.

Zurück zum Anfang

Gültigkeitsregeln für Datensätze

Eine Gültigkeitsregel für einen Datensatz bestimmt, wann ein vollständiger Datensatz gespeichert werden kann. Im Gegensatz zu Gültigkeitsregeln für ein Feld können Gültigkeitsregeln für einen Datensatz auf andere Felder verweisen. Aus diesem Grund eignen sie sich zum Vergleichen von Werten aus unterschiedlichen Feldern in einer Tabelle. Gültigkeitsregeln für einen Datensatz werden in einer Tabelle definiert.

Zurück zum Anfang

Gültigkeitsregeln für Steuerelemente

Sie können auch eine Gültigkeitsregel für ein Steuerelement in einem Formular definieren. In der Regel werden Sie die Gültigkeitsregel für das Feld in der Tabelle definieren, da Gültigkeitsregeln für ein Feld automatisch auch für Steuerelemente gelten, die auf dem jeweiligen Feld basieren (vorausgesetzt, Sie haben das Steuerelement nach dem Definieren der Gültigkeitsregel in der Tabellenentwurfsansicht erstellt). Wenn es sich jedoch um ein ungebundenes Steuerelement handelt, oder wenn das Steuerelement auf Daten in einer verknüpften (externen) Tabelle basiert, müssen Sie die Gültigkeitsregel im Steuerelement definieren. Dies gilt auch dann, wenn die Gültigkeitsregel auf Felder oder Steuerelemente in anderen Formularen verweist, oder wenn die Gültigkeitsregel Aggregatfunktionen für Domänen, Aggregatfunktionen, benutzerdefinierte Funktionen oder die Funktionen AktuellerBenutzer oder Auswerten enthält.

Zurück zum Anfang

Gültigkeitsüberprüfung auf Formularebene mit Makros oder Visual Basic für Applikationen

In bestimmten Situationen müssen Sie zum Durchführen von komplexen Gültigkeitsprüfungen Makros oder Visual Basic für Applikationen-Code zusammen mit einem Formular verwenden. Auf diese Weise können Sie z. B. Ihre Gültigkeitsregel unter bestimmten Bedingungen außer Kraft setzen oder Werte aus unterschiedlichen Tabellen vergleichen.

Zurück zum Anfang


Info über die Windows-Registrierung

Microsoft Access speichert die erforderlichen Initialisierungsinformationen in der Windows-Registrierung. Die Windows-Registrierung ist eine zentrale Datenbank, die Windows zum Konfigurieren der Software und Hardware verwendet, die in Ihrer Windows-Umgebung ausgeführt wird. Die Registrierung ist vergleichbar mit den .INI-Dateien unter Windows 3.x: Jeder Teilschlüssel in der Registrierung ähnelt einem der Abschnitte (unter einer Überschrift in eckigen Klammern) in einer .INI-Datei, und die Einträge unter den einzelnen Registrierungsteilschlüsseln ähneln den Einträgen unter einer .INI-Datei-Überschrift.


 Info über das Arbeiten mit SQL in Abfragen, Formularen, Berichten, Makros und Modulen

Info über das Arbeiten mit SQL in Abfragen, Formularen, Berichten, Makros und Modulen

Mit Hilfe von SQL (Structured Query Language - strukturierte Abfragesprache) können Sie relationale Datenbanken, wie z. B. Microsoft Access, abfragen, aktualisieren und verwalten. Wenn Sie eine Abfrage in der Entwurfsansicht erstellen, erzeugt Microsoft Access im Hintergrund die zugehörigen SQL-Anweisungen. Sie können diese SQL-Anweisungen in der SQL-Ansicht anzeigen oder bearbeiten. Nachdem Sie an einer Abfrage Änderungen in der SQL-Ansicht vorgenommen haben, sieht die Abfrage beim Anzeigen in der Entwurfsansicht möglicherweise anders aus als zuvor.

Manche Abfragen können nicht im Entwurfsbereich erstellt werden. Für SQL Pass-Through-Abfragen, Datendefinitionsabfagen und Union-Abfragen müssen Sie die SQL-Anweisungen direkt in der SQL-Ansicht erstellen.

Darüber hinaus können Sie SQL-Anweisungen überall dort in Microsoft Access eingeben, wo Sie einen Tabellen-, Abfrage- oder Feldnamen eingeben können. In einigen Fällen gibt Microsoft Access die SQL-Anweisung für Sie ein. Wenn Sie z. B. mit Hilfe eines Assistenten ein Formular oder einen Bericht erstellen, das bzw. der Daten aus mehreren Tabellen abruft, erstellt Microsoft Access automatisch eine SQL-Anweisung, die als Einstellung der Eigenschaft Datenherkunft des Formulars oder Berichts verwendet wird. Beim Erstellen eines Listen- oder Kombinationsfelds mit Hilfe eines Assistenten verwendet Microsoft Access die erzeugte SQL-Anweisung als Einstellung der Eigenschaft Datensatzherkunft des entsprechenden Listen- oder Kombinationsfelds. Außerdem können Sie SQL-Anweisungen im Abfrageentwurfsbereich von Unterabfragen, als Argument SQL-Anweisung der Makroaktion AusführenSQL und im Programmcode verwenden.

Zurück zu Arbeiten mit SQL in Abfragen, Formularen, Berichten, Makros und Modulen


Arbeiten mit MDE-Dateien

Was möchten Sie tun?

Informationen über MDE-Dateien

Eine Microsoft Access-Datenbank als MDE-Datei speichern

Informationen, wie andere Formen der Datensicherheit bei einer als MDE-Datei gespeicherten Access-Datenbank verwendet werden

Informationen zum Speichern einer replizierten Access-Datenbank als MDE-Datei

Informationen zum Speichern einer Access-Datenbank, die auf eine andere Datenbank als MDE-Datei verweist


 Anfügen von Datensätzen mit AutoWert-Feldern

Anfügen von Datensätzen mit AutoWert-Feldern

Je nachdem, wie Sie eine Anfügeabfrage entwerfen, fügt Microsoft Access automatisch neue Werte für das Feld vom Typ AutoWert hinzu oder übernimmt die Werte aus der Originaltabelle.

  • Wenn Microsoft Access die Werte für das Feld vom Datentyp AutoWert automatisch hinzufügen soll, ziehen Sie dieses Feld beim Erstellen der Abfrage nicht in den Abfrageentwurfsbereich.

    Auf diese Weise fügt Microsoft Access Datensätze an und fügt automatisch Werte in das Feld vom Typ AutoWert ein. Der erste angefügte Datensatz erhält einen Wert, der um 1 größer ist, als der bisher größte im Feld vom Datentyp AutoWert enthaltene Wert (dies gilt auch dann, wenn der Datensatz, der den größten Wert im Feld vom Typ AutoWert enthält, bereits gelöscht wurde).

  • Wenn Sie die Werte aus dem Feld vom Typ AutoWert der Originaltabelle beibehalten möchten, ziehen Sie das Feld beim Erstellen der Abfrage in den Abfrageentwurfsbereich.

    Verwenden Sie dagegen die erste Methode, wenn das Feld vom Typ AutoWert der Tabelle, an die Sie anfügen, ein Primärschlüssel ist und außerdem die Originaltabelle und die Tabelle, an die Sie anfügen, im AutoWert-Feld Duplikatwerte enthalten.


 Verwenden von AutoNachschlagen in einer Abfrage, um Daten automatisch einzugeben

Verwenden von AutoNachschlagen in einer Abfrage, um Daten automatisch einzugeben

Sie können eine Abfrage auf der Basis mehrerer Tabellen entwerfen, die für einen neuen Datensatz bestimmte Feldwerte automatisch eingibt. Wenn Sie in der Abfrage oder in einem/einer auf der Abfrage basierenden Formular, Bericht oder Datenzugriffsseite einen Wert in das Verknüpfungsfeld eingeben, schlägt Microsoft Access in vorhandenen Informationen nach und trägt solche ein, die mit diesem Wert verknüpft sind. Wenn Sie z. B. den Wert in einem Verknüpfungsfeld zwischen einer Tabelle Kunden und einer Tabelle Bestellungen (üblicherweise eine Kundenkennung, wie z. B. Kunden-Code) kennen, können Sie den Kunden-Code eingeben und Microsoft Access alle weiteren Informationen für diesen Kunden eintragen lassen. Wenn keine übereinstimmenden Informationen gefunden werden, zeigt Microsoft Access eine Fehlermeldung an, sobald der Datensatz den Fokus nicht mehr hat.

Eingeben eines Wertes in ein Verknüpfungsfeld

Die verbleibenden Daten werden abgerufen

Die Option AutoNachschlagen setzt bestimmte Bedingungen voraus:

  • Die Abfrage muss auf mehr als einer Tabelle basieren, und die Tabellen müssen eine 1-n-Beziehung haben. (Referenzielle Integrität ist nicht notwendig.)

  • Das Verknüpfungsfeld auf der "1"-Seite der Beziehung muss über einen eindeutigen Index verfügen. Dies bedeutet, dass dieses Feld ein Primärschlüssel ist oder dass für die Eigenschaft Indiziert des Feldes in der Entwurfsansicht für Tabellen die Einstellung Ja (Ohne Duplikate) festgelegt ist.

  • Das Verknüpfungsfeld, das Sie dem Entwurfsbereich hinzufügen, muss aus der Tabelle auf der "n"-Seite der 1:n-Beziehung stammen (d.h. dies ist der Fremdschlüssel für diese Tabelle). Die Option AutoNachschlagen kann nur dann verwendet werden, wenn dieses Feld kein Primärschlüssel ist und dessen Eigenschaft Indiziert nicht auf Ja (Ohne Duplikate) eingestellt ist. Ziehen Sie z. B. in einer Abfrage auf der Basis der Tabellen Kunden und Bestellungen das Feld Kunden-Code aus der Tabelle Bestellungen, und nicht aus der Tabelle Kunden, in den Entwurfsbereich.

  • Der Wert, den Sie in das Verknüpfungsfeld auf der "n"-Seite eingeben, muss auf der "1"-Seite bereits existieren.

Wenn der Wert des Verknüpfungsfeldes auf der "n"-Seite der Beziehung einem Datensatz hinzugefügt oder in einem Datensatz geändert wird, sucht Microsoft Access automatisch nach den zugehörigen Werten in der Tabelle auf der "1"-Seite der Beziehung und zeigt diese an.

Während Sie das Verknüpfungsfeld auf der "n"-Seite einer Beziehung immer aktualisieren können, können Sie das Verknüpfungsfeld auf der "1"-Seite der Beziehung nur aktualisieren, wenn Sie beim Definieren der Beziehung zwischen den Tabellen die Option Aktualisierungsweitergabe aktiviert haben. In jedem Fall berechnet Microsoft Access beim Aktualisieren von Daten automatisch immer alle Funktionen oder Ausdrücke in der Abfrage neu, die von den aktualisierten Daten abhängen.


 Optionen für Sprachen mit Rechts-nach-links-Schreibrichtung

Optionen für Sprachen mit Rechts-nach-links-Schreibrichtung

Sprachspezifische Informationen

To enable the right-to-left features in Microsoft Access 2000, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95. Learn about system or special requirements for right-to-left languages.

When languages such as Arabic, Farsi, Hebrew, and Urdu are enabled for editing, you have several features available to you to make working in a right-to-left or bidirectional environment easier.

More information

Learn about bidirectional fonts

Learn about checking the spelling of bidirectional text

Learn about using bidirectional text in expressions

Learn about right-to-left features compatibility

Change the default for a right-to-left feature

Use database calendars

Use right-to-left sort orders

Import, export, and link right-to-left tables in text formats

Learn about code page and text layout support for right-to-left HTML files

Change table direction

Change query direction

Use right-to-left features in forms and reports

Set right-to-left properties in controls

Convert reports saved as text files to ANSI characters

Use right-to-left features in data access pages

About creating macros in right-to-left applications

About creating modules in right-to-left applications


 Arbeiten mit Null-Werten unter Verwendung von berechneten Feldern - Beispiele

Arbeiten mit Null-Werten unter Verwendung von berechneten Feldern - Beispiele

Geben Sie den jeweiligen Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der aktuellen Abfrage.

Ausdruck | Beschreibung
AktuellesLand: Wenn(IstNull([Land]), " ", [Land]) | Mit Hilfe der Funktionen Wenn und IstNull wird eine leere Zeichenfolge im Feld AktuellesLand angezeigt, wenn das Feld Land Null enthält; ansonsten wird der Inhalt des Feldes Land angezeigt.
Bearbeitungszeit: Wenn(IstNull([Lieferdatum] - [Versanddatum]), "Überprüfen auf fehlendes Datum", [Lieferdatum] - [Versanddatum]) | Mit Hilfe der Funktionen Wenn und IstNull wird im Feld Bearbeitungszeit die Meldung Überprüfen auf fehlendes Datum angezeigt, wenn der Wert einer der beiden Felder Lieferdatum oder Versanddatum Null ist; ansonsten wird die Differenz der beiden Felder angezeigt.
Halbjahresverkäufe: Nz([Verkäufe 1. Quartal],0) + Nz([Verkäufe 2. Quartal],0) | Zeigt im Feld Halbjahresverkäufe den Gesamtbetrag der Werte der Felder Verkäufe 1. Quartal und Verkäufe 2. Quartal an, wobei mit der Funktion Nz zunächst die Nullwerte in 0 konvertiert werden.
Wenn(IstNull([Einzelpreis]),0,[Einzelpreis]) | Wandelt einen Nullwert im Feld Einzelpreis in 0 um.

Anmerkung Wenn Sie einen arithmetischen Operator (+, -, *, /) in einem Ausdruck verwenden, in dem der Wert eines der Felder Null ist, dann ist das Ergebnis des gesamten Ausdrucks Null. Wenn in einem der Felder, die Sie im Ausdruck verwendet haben, Datensätze mit einem Nullwert vorkommen, können Sie diesen mit Hilfe der Funktion Nz, wie in der obigen Tabelle gezeigt, konvertieren. Zum Anzeigen weiterer Informationen zur Funktion Nz klicken Sie auf [image] .


 Unterabfragen in berechneten Feldern - Beispiel

Unterabfragen in berechneten Feldern - Beispiel

Geben Sie den Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der aktuellen Abfrage.

Ausdruck | Beschreibung
Kat: (SELECT [Kategoriename] FROM [Kategorien] WHERE [Artikel].[Kategorie-Nr]=[Kategorien].[Kategorie-Nr]) | Zeigt Kategoriename an, wenn Kategorie-Nr der Tabelle Kategorien mit Kategorie-Nr der Tabelle Artikel identisch ist.


 Beispiele zur Verwendung von SQL und Domänenaggregatfunktinen in berechneten Feldern

Beispiele zur Verwendung von SQL und Domänenaggregatfunktinen in berechneten Feldern

Geben Sie den jeweiligen Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der, aktuellen Abfrage.

Ausdruck | Beschreibung
Count(*) | Verwendet die Funktion Count zum Zählen der Anzahl der Datensätze in der Abfrage, einschließlich Datensätze mit Null-Feldern (leeren Feldern).
FrachtkostenProzentsatz: Summe([Frachtkosten])/Summe
([Zwischensumme]) * 100 		Zeigt im Feld FrachtkostenProzentsatz den Prozentsatz in den einzelnen Zwischensummen an, indem die Summe der Werte im Feld Frachtkosten durch die Summe der Werte im Feld Zwischensumme dividiert wird. (In diesem Beispiel wird die Summe-Funktion verwendet.)

Die Zeile Funktion muss im Entwurfsbereich angezeigt werden, und für die Zelle Funktion dieses Feldes muss Ausdruck eingestellt werden.

Wenn die Format-Eigenschaft des Feldes auf Prozentzahl eingestellt ist, brauchen Sie *100 nicht anzugeben.
MittelwertFrachtkosten: DomMittelwert("[Frachtkosten]", "[Bestellungen]") | Verwendet die DomMittelwert-Funktion zum Anzeigen des mittleren Rabatts, der für alle in einer Summenabfrage zusammengefassten Bestellungen gewährt wird.

Zum Anzeigen weiterer Informationen zu Domänenaggregatfunktionen klicken Sie auf [image] .


 Durchführen von arithmetischen Operationen in berechneten Feldern - Beispiele

Durchführen von arithmetischen Operationen in berechneten Feldern - Beispiele

Geben Sie den jeweiligen Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der aktuellen Abfrage.

Ausdruck | Beschreibung
Hauptfrachtkosten: [Frachtkosten] * 1.1 | Zeigt im Feld Hauptfrachtkosten die Frachtkosten, zuzüglich 10 %, an.
Preis: [Anzahl] * [Einzelpreis] | Zeigt im Feld Preis das Produkt der Werte in den Feldern Anzahl und Einzelpreis an.
Zustellzeit: [Lieferdatum] - [Versanddatum] | Zeigt im Feld Zustellzeit die Differenz zwischen den Werten der Felder Lieferdatum und Versanddatum an.
Gesamtlagerbestand: [Lagerbestand]+[Bestellte Einheiten] | Zeigt im Feld Gesamtlagerbestand die Summe der Werte in den Feldern Lagerbestand und Bestellte Einheiten an.
FrachtkostenProzentsatz: Summe([Frachtkosten])/Summe ([Zwischensumme]) * 100 | Zeigt im Feld FrachtkostenProzentsatz den Prozentsatz der Frachtkosten in den einzelnen Zwischensummen an, indem die Summe der Werte im Feld Frachtkosten durch die Summe der Werte im Feld Zwischensumme dividiert wird. (In diesem Beispiel wird die Funktion Summe verwendet.) Die Zeile Funktion muss im Entwurfsbereich angezeigt werden, und für die Zelle Funktion dieses Feldes muss Ausdruck eingestellt werden. Wenn die Eigenschaft Format des Feldes auf Prozentzahl eingestellt ist, brauchen Sie *100 nicht anzugeben.

Anmerkung Wenn Sie einen arithmetischen Operator (+, -, *, /, ^) in einem Ausdruck verwenden, in dem der Wert eines der Felder Null ist, ist das Ergebnis des gesamten Ausdrucks Null. Wenn in einem der Felder, die Sie im Ausdruck verwendet haben, Datensätze mit einem Nullwert vorkommen, können Sie diesen mit Hilfe der Funktion Nz folgendermaßen konvertieren:

Nz([Lagerbestand],0)+Nz([BestellteEinheiten],0)

Zum Anzeigen weiterer Informationen zur Funktion Nz klicken Sie auf [image] .


 Bearbeiten und Berechnen von Datumswerten in berechneten Feldern - Beispiele

Bearbeiten und Berechnen von Datumswerten in berechneten Feldern - Beispiele

Geben Sie den jeweiligen Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der aktuellen Abfrage.

Ausdruck | Beschreibung
Bearbeitungszeit: DatDiff("t", [Bestelldatum], [Versanddatum]) | Mit Hilfe der Funktion DatDiff wird im Feld Bearbeitungszeit die Anzahl der Tage angezeigt, die zwischen dem Bestell- und dem Versanddatum liegen.
Einstellungsjahr: DatTeil("jjjj",[Einstellungsdatum]) | Mit Hilfe der Funktion DatTeil wird im Feld Einstellungsjahr das Jahr angezeigt, in dem der jeweilige Mitarbeiter eingestellt wurde.
Datum( )- 30 | Mit Hilfe der Funktion Datum wird das Datum angezeigt, das 30 Tage vor dem aktuellen Datum liegt.


 Beispiele zum Manipulieren von Textwerten in berechneten Feldern

Beispiele zum Manipulieren von Textwerten in berechneten Feldern

Geben Sie den jeweiligen Ausdruck im Abfrageentwurfsbereich in die Zelle Feld ein. Die Felder, auf die Sie im Ausdruck verweisen, befinden sich in den Tabellen oder Abfragen der aktuellen Abfrage.

Ausdruck Beschreibung

VollständigerName: [Vorname] & " " & [Nachname] | Zeigt die Werte aus den Feldern Vorname und Nachname durch ein Leerzeichen voneinander getrennt im Feld VollständigerName an.
Adresse2: [Ort] & " " & [Region] & " " & [PLZ] | Zeigt die Werte aus den Feldern Ort, Region und PLZ durch Leerzeichen voneinander getrennt im Feld Adresse2 an.
ProductInitial: Left([Artikelname], 1) | Verwendet die Left-Funktion zum Anzeigen des ersten Zeichens des Wertes aus dem Feld Artikelname im Feld ProductInitial.
TypeCode: Right([AssetCode], 2) | Verwendet die Right-Funktion zum Anzeigen der letzten beiden Zeichen des Wertes aus dem Feld AssetCode im Feld TypeCode.
Ortskennzahl: Mid([Telefon],2,3) | Verwendet die Mid-Funktion zum Anzeigen der drei Zeichen beginnend ab dem 2. Zeichen des Wertes aus dem Feld Telefon im Feld Ortskennzahl.


 Farb-Editor

Farb-Editor

Der Farb-Editor ist ein Microsoft Access-Tool, mit dessen Hilfe Sie Farben aus der Palette auswählen oder benutzerdefinierte Farben erstellen können, die Sie speichern und für Formulare und Berichte verwenden können.

Sie starten diesen Editor, indem Sie im Eigenschaftenfenster neben der entsprechenden Eigenschaft auf die Generator-Schaltfläche [image] klicken.


Komplexe optimierbare Ausdrücke - Beispiele

Diese Beispiele setzen voraus, dass Sie Indizes für die Felder Nachname und Einstellungsdatum, jedoch nicht für die Felder Mittelinitiale oder Vorname erstellt haben. Die nachstehende Tabelle zeigt Beispiele für Kombinationen aus einfachen Ausdrücken und den Optimierungsmöglichkeiten des Ergebnisses auf.

Optimierbarer Ausdruck | Operator | Optimierbarer Ausdruck | Ergebnis
[Nachname]="Schmidt" | Und | [Einstellungsdatum]<#30.12.90# | Optimierbar mit Rushmore
[Nachname]="Schmidt" | Oder | [Einstellungsdatum]<#30.12.90# | Optimierbar mit Rushmore

Optimierbarer Ausdruck | Operator | Nichtoptimierbarer Ausdruck | Ergebnis
[Nachname]="Schmidt" | Und | [Mittelinitiale]="C" | Teilweise optimierbar (Rushmore kann nicht verwendet werden)
[Nachname]="Schmidt" | Oder | [Mittelinitiale]="C" | Nicht optimierbar

Nichtoptimierbarer Ausdruck | Operator | Nicht optimierbarer Ausdruck | Ergebnis
[Vorname]="Hans" | Und | [Mittelinitiale]="C" | Teilweise optimierbar (Rushmore kann nicht verwendet werden)
[Vorname]="Hans" | Oder | [Mittelinitiale]="C" | Nicht optimierbar


Was muss beim Entwerfen oder Ändern von Abfragen in einer Mehrbenutzerumgebung berücksichtigt werden?

Wenn Sie eine Abfrage zum Durchführen von Entwurfsänderungen öffnen und ein anderer Benutzer Änderungen am Entwurf vornimmt, bevor Sie fertig sind, zeigt Microsoft Access eine Meldung an, die angibt, dass der Entwurf seit dem Beginn Ihrer Arbeit geändert worden ist. Jetzt können Sie entweder die neuen Änderungen durch Ihre Änderungen ersetzen oder Ihre Version der Abfrage unter einem anderen Namen speichern. Wenn andere Benutzer die Abfrage zum Anzeigen von Daten verwenden, während Sie den Entwurf ändern, sehen diese Benutzer die Änderungen nicht sofort, sondern erst nach dem Schließen und erneuten Öffnen der Abfrage.


 Überlegungen zum Festlegen von Optionen im Dialogfeld "Start"

Überlegungen zum Festlegen von Optionen im Dialogfeld "Start"

  • Die Startoptionen gelten nur für die aktuelle Microsoft Access-Datenbank oder das aktuelle Microsoft Access-Projekt.

  • Wenn Sie im Dialogfeld Start eine Einstellung festlegen, legen Sie automatisch die entsprechende Eigenschaft für die Access-Datenbank oder das Access-Projekt fest. Zum Anzeigen einer Liste dieser Eigenschaften klicken Sie auf [image] .

  • Die Starteigenschaften überschreiben nicht die Eigenschafteneinstellungen für eine bestimmte Symbol- oder Menüleiste, ein Kontextmenü, ein Formular oder einen Bericht. Die Optionen Menüleiste und Kontextmenüleiste aus dem Dialogfeld Start überschreiben z.B. nicht die Eigenschafteneinstellungen für bestimmte Formulare oder Berichte, die eine benutzerdefinierte Menüleiste oder ein Kontextmenü enthalten. Wenn Sie daher ein Formular oder einen Bericht öffnen, zeigt Microsoft Access die in diesem Formular oder Bericht eingebundene benutzerdefinierte Menüleiste, und nicht die im Dialogfeld Start festgelegte globale Menüleiste, an.

  • Sie können das Dialogfeld Start an Stelle eines oder zusätzlich zu einem AutoExec-Makro verwenden. Ein AutoExec-Makro wird nach dem Ausführen der Startoptionen ausgeführt. Vermeiden Sie daher im Makro die Verwendung von Aktionen, die eine der Einstellungen, die durch die Startoptionen festgelegt wurde, ändert. Wenn Sie z.B. im Dialogfeld Start im Feld Formular/Seite anzeigen und gleichzeitig in einem AutoExec-Makro unter Verwendung der Aktion ÖffnenFormular ein Formular angeben, zeigt Microsoft Access zuerst das im Dialogfeld Start angegebene und gleich anschließend das in der Aktion ÖffnenFormular angegebene Formular an.

  • Wenn in einer Access-Datenbank Sicherheit auf Benutzerebene festgelegt wurde, können Sie verhindern, dass andere Benutzer die Einstellungen im Dialogfeld Start ändern. Dazu müssen Sie sicherstellen, dass diese Benutzer für die Datenbank nicht über die Berechtigung "Administrator" verfügen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Um die Einstellungen für die Startoptionen zu umgehen, halten Sie beim Öffnen der Datenbank die UMSCHALTTASTE gedrückt.


 Konvertieren von Access Basic-Code in Visual Basic

Konvertieren von Access Basic-Code in Visual Basic

In Microsoft Access 95 hat Visual Basic für Applikationen die Programmiersprache Access Basic ersetzt, die in den Versionen 1.x und 2.0 von Microsoft Access verwendet wurde. Visual Basic ist größtenteils identisch mit Access Basic, und Microsoft Access führt beim Konvertieren Ihrer Datenbank die wichtigsten Codekonvertierungen automatisch durch.

Der Konvertierungsvorgang nimmt jedoch einige Änderungen an Ihrem Code vor, die Sie kennen sollten. Einige zusätzliche Änderungen müssen Sie noch selbst vornehmen, damit Ihre Anwendungen in Microsoft Access 2000 korrekt ausgeführt wird.

Anmerkung Der Befehlszeilenschalter /runtime steht in der Stand-Alone-Version und der Office Professional Edition von Microsoft Access 2000 nicht zur Verfügung, dafür jedoch in der Office Developer Edition von Microsoft Access 2000.

Aufrufen der Windows-API (Schnittstelle für die Anwendungsprogrammierung)

Wenn Ihr bestehender Access Basic-Code der Version 1.x oder 2.0 Aufrufe der Windows-Schnittstelle für die Anwendungsprogrammierung (API) durchführt, ändern Sie ggf. diese Aufrufe beim Konvertieren der Datenbank. Die Versionen 1.x und 2.0 von Microsoft Access sind 16-Bit-Anwendungen und werden auf 16-Bit-Versionen von Windows ausgeführt. Microsoft Access 2000 dagegen ist eine 32-Bit-Anwendung und benötigt eine 32-Bit-Version von Windows - d.h. Windows 95 oder Windows NT.

Überprüfen Sie alle Declare-Anweisungen daraufhin, dass sie auf die richtigen 32-Bit-DLL-Dateien (Dynamic Link Libraries) verweisen. Die 32-Bit-Version von Windows enthält z.B. die Datei USER32.DLL; in früheren Windows-Versionen hatte diese DLL den Namen USER.DLL. Weitere Informationen finden Sie unter Konvertieren von Code, der eine DLL aufruft.

Einige Funktionsnamen in der Windows-API haben sich geändert. Darüber hinaus unterscheiden die Funktionen der 32-Bit-Windows-API zwischen Groß- und Kleinschreibung. Eine ausführliche Beschreibung finden Sie im Microsoft Win32 Software Development Kit.

Einige Eigenschaften und optionale Argumente werden exakt eingegeben

Bestimmte Eigenschaften, die in früheren Versionen von Microsoft Access Werte des Datentyps Variant lieferten, geben nun Zeichenfolgen zurück. Code, der solche Eigenschaften enthält, wird nun schneller ausgeführt; wenn Sie jedoch eine Datenbank aus einer früheren Version von Microsoft Access in Microsoft Access 2000 konvertieren, müssen Sie überprüfen, ob durch diese neuen Rückgabewerte keine Fehler eingeführt werden.

Darüber hinaus müssen einige optionale Argumente, die in früheren Versionen von Microsoft Access den Datentyp Variant aufwiesen, nun exakt eingegeben werden. Davon sind die folgenden Methoden, Eigenschaften und Funktionen betroffen: die GoToPage-Methode eines Form-Objekts, die OpenCurrentDatabase-, Echo-, Quit-, CreateForm-, CreateReport-, CreateControl- und CreateReportControl-Methode des Application-Objekts, die Column-Eigenschaft eines Kombinations- oder Listenfeldes und die Aggregatfunktionen für Domänen. Enthält Ihr Code eines dieser Elemente, sollten Sie überprüfen, dass beim Konvertieren Ihrer Datenbank keine Fehler eingeführt werden.

Zur Überprüfung auf Fehler kompilieren Sie zunächst den gesamten Code in der Datenbank. Überprüfen Sie dann, ob bei Ausführung Ihres Codes Laufzeitfehler auftreten. Die folgenden beiden Fehler treten am ehesten auf: "Typ nicht passend" oder "Ungültige Verwendung von Null".

Sie sollten auch überprüfen, ob sich beim Konvertieren einer Datenbank keine stillen Fehler eingeschlichen haben. Die RecordSource-Eigenschaft eines Steuerelements lieferte bisher z.B. einen Wert des Datentyps Variant, gibt jetzt jedoch eine Zeichenfolge zurück. Eine Zeichenfolge kann im Gegensatz zu einem Wert des Datentyps Variant keinen Wert Null enthalten. Code in einer konvertierten Datenbank, der überprüft, ob der Wert der RecordSource-Eigenschaft gleich Null ist, wird nicht mehr korrekt ausgeführt, da der Wert dieser Eigenschaft niemals Null ist.

Private Sub Form_Load()
    If IsNull(Me.RecordSource) Then
        Me.Recordsource = "Personal"
    End If
End Sub

In Microsoft Access 2000 gibt die IsNull-Funktion niemals True für den Wert der RecordSource-Eigenschaft zurück. Wurde RecordSource nicht bereits im vorherigen Beispiel eingestellt, ist ihr Wert eine leere Zeichenfolge, die IsNull-Funktion liefert den Wert False, und die Prozedur geht niemals in das If...Then-Konstrukt, um die RecordSource-Eigenschaft einzustellen.

Um den Code im vorangehenden Beispiel zu korrigieren, überprüfen Sie mit Hilfe der Len-Funktion die Länge der Zeichenfolge, die von der RecordSource-Eigenschaft zurückgegeben wird, und bestimmen so, ob es sich um eine leere Zeichenfolge handelt. Die folgende Zeile korrigiert den Code im vorangehenden Beispiel:

If Len(Me.RecordSource) = 0 Then
    ' Restliche Prozedur hier eingeben.

Änderungen an Modulen

In den Versionen 1.x und 2.0 von Microsoft Access wurden Module als globale Module bezeichnet, wenn sie allgemeine, keinem bestimmten Formular- oder Berichtsmodul zugeordnete Prozeduren enthielten. In Microsoft Access 2000 heißen solche Module Standardmodule.

Microsoft Access 2000 enthält Klassenmodule, mit denen Sie benutzerdefinierte Objekte erstellen können. Jede öffentliche Prozedur in einem Klassenmodul wird zu einer Methode oder Eigenschaft des benutzerdefinierten Objekts, wenn Sie eine neue Instanz der Klasse erstellen. Klassenmodule existieren sowohl eigenständig als auch in Verbindung mit Formularen und Berichten. Weitere Informationen über Klassenmodule finden Sie unter Programmieren mit Klassenmodulen.

Die CurrentDb-Funktion im Vergleich zu DBEngine(0)(0)

Verwenden Sie die CurrentDb-Methode an Stelle von DBEngine(0)(0), um eine Objektvariable vom Typ Connection zurückzugeben, die auf die aktuelle Datenbank verweist. Die CurrentDb-Funktion erstellt eine weitere Instanz der aktuellen Datenbank, während sich DBEngine(0)(0) auf die geöffnete Kopie der aktuellen Datenbank bezieht. Die Verwendung von DBEngine(0)(0) beschränkt Ihre Möglichkeiten, mehrere Variablen vom Typ Database, die sich auf die aktuelle Datenbank beziehen, zu verwenden.

Da DBEngine(0)(0) noch unterstützt wird, ändert Microsoft Access Ihren Code bei der Konvertierung nicht. Es empfiehlt sich jedoch, diese Änderungen an Ihrem Code selbst durchzuführen, um eventuellen Konflikten in einer Mehrbenutzerumgebung vorzubeugen.

Die CurDir-Funktion

Das Verhalten der CurDir-Funktion hat sich gegenüber der Version 1.x bzw. 2.0 entsprechend der Art und Weise geändert, wie Anwendungen mit Windows 95 kommunizieren. Da jede Anwendung einen eigenen aktuellen Ordner besitzt, hat das Festlegen des aktuellen Ordners in Windows 98 durch Doppelklicken auf ein Symbol keine Auswirkung auf den aktuellen Ordner in Microsoft Access. In Microsoft Access 2000 gibt die CurDir-Funktion immer den aktuellen Pfad zurück.

Zuweisen eines OLE-Objekts zu einer Variablen

Wenn Sie OLE-Objekte oder andere binäre Daten im Code bearbeiten, speichern Sie die binären Daten in einem Byte-Datenfeld. In den Versionen 1.x und 2.0 von Microsoft Access wurden OLE-Objekte oder andere binäre Daten bis zu 64 KB Größe Zeichenfolgenvariablen zugewiesen, um die Objekte oder Daten im Code bearbeiten zu können. Auch die von der GetChunk-Methode zurückgegebenen Daten wurden Zeichenfolgenvariablen zugewiesen. Visual Basic stellt jedoch den Datentyp Byte sowie Byte-Funktionen, wie LeftB und RightB, zur Verfügung. Speichern Sie daher binäre Daten in Microsoft Access 2000 nicht in Zeichenfolgenvariablen, sondern in einem Byte-Datenfeld, und bearbeiten Sie sie mit den Byte-Funktionen.

Deklarieren von DDE-Kanälen als "Variant" oder "Long"

Wenn Sie mit Hilfe der DDEInitiate-Funktion einen DDE-Kanal öffnen, können Sie die Variable zum Speichern der Kanalnummer - ein Wert vom Typ Long - entweder als Wert vom Datentyp Variant oder Long deklarieren. Da die Kanalnummer in den Versionen 1.x und 2.0 von Microsoft Access ein Wert vom Typ Integer ist, ändern Sie alle Deklarationsanweisungen in Ihrem Code, die zum Speichern der Kanalnummer eine Variable vom Typ Integer erstellen.

Fehlschlagen der Konvertierung einer Zeichenfolge, wenn diese ein Prozentzeichen (%) enthält

Sie können einer Variablen oder einem Feld mit einem numerischen Datentyp keine Zeichenfolge zuweisen, die ein Prozentzeichen enthält, wie z.B.:

Dim intX As Double
    intX = "10"             ' Zuweisung ist korrekt.
    intX = "10%"            ' Zuweisung führt zu einem Fehler.

Die hWnd-Eigenschaft

Wenn Sie in Ihrem Code mit Hilfe der hWnd-Eigenschaft eine Fensterkennnummer (Handle) eines Formulars oder Berichts an eine Windows-Routine übergeben möchten, übergeben Sie den Wert direkt an die Routine. Es ist nicht sinnvoll, den Wert dieser Eigenschaft einer Variablen zuzuweisen. Beispiel:

If Not IsZoomed(Screen.ActiveForm.hWnd) Then
    DoCmd.Maximize
EndIf

In den Versionen 1.x und 2.0 von Microsoft Access war die hWnd-Eigenschaft eines Formulars oder Berichts ein Wert vom Typ Integer. In Microsoft Access 2000 ist hWnd ein Wert vom Typ Long. Ändern Sie daher Ihren Code so, dass er solche Werte korrekt verarbeitet.

DAO-Eigenschaftenobjekte im Vergleich zu Microsoft Access-Eigenschaftenobjekten

Sie können in Ihrem Code nicht mit Objektvariablen auf die Category-Eigenschaft verweisen. Die Category-Eigenschaft wird für Form-, Report- und Control-Objekte nicht mehr unterstützt.

Die Parent-Eigenschaft

Wenn Sie in Microsoft Access 2000 die Parent-Eigenschaft eines Steuerelements im Code oder in einem Ausdruck eines Formulars oder Berichts verwenden, wird in der Regel das Form- oder Report-Objekt, welches das Steuerelement enthält, zurückgegeben. Wenn beispielsweise Kategorie-Nr ein Textfeld im Formular Kategorien ist, gibt der Code Formulare!Kategorien![Kategorie-Nr].Parent einen Verweis auf das Formular Kategorien zurück. Dabei gibt es zwei Ausnahmen: für ein zugeordnetes Bezeichnungsfeld gibt die Parent-Eigenschaft jetzt das Steuerelement zurück, dem das Bezeichnungsfeld zugeordnet ist, und für Steuerelemente einer Optionsgruppe wird jetzt das Optionsgruppen-Steuerelement zurückgegeben.

Aufrufen von Code in Microsoft Access-Assistenten

Wenn Code in Version 1.x- oder Version 2.0-Anwendungen Prozeduren in Microsoft Access-Assistenten aufruft, erstellen Sie nach dem Konvertieren der Anwendung einen Verweis von der Anwendung auf die Assistentendatenbank, die die betreffenden Prozeduren enthält. Weitere Informationen zum Einrichten von Verweisen finden Sie unter Einstellen von Verweisen auf Typbibliotheken.

In Microsoft Access, Version 2.0, wurde nicht zwischen Assistenten und Bibliotheken unterschieden, so dass ihr globaler Code immer der aktuellen Dankbank zur Verfügung steht. In Microsoft Access 2000 werden Assistenten und andere Add-Ins nicht mehr als Bibliotheken behandelt. Da sich bei den Assistenten außerdem von einer Version zur nächsten größere Änderungen ergeben können, kann es vorkommen, dass Sie bestimmte Codeteile neu schreiben müssen, um den Code nach dem Umstellen auf eine neue Microsoft Access-Version an die Änderungen anzupassen.

Wenn Code, wie z.B. die Wählhilfe, in den Microsoft Access-Assistenten nicht mehr unterstützt wird, wurde dessen Funktionalität der Datei UTILITY.MDA, einer speziellen Bibliotheksdatenbank in Microsoft Access, hinzugefügt. Ein Verweis auf diese Bibliothek wird automatisch beim Konvertieren einer Datenbank nach Microsoft Access 2000 hinzugefügt.

Einrichten eines Verweises auf eine Microsoft Access-Datenbank

In Microsoft Access 2000 können Sie keinen Verweis auf eine Datenbank einrichten, die mit einer früheren Version von Microsoft Access erstellt wurde. Konvertieren Sie die Datenbank in eine Microsoft Access 2000 (Version 9.0)-Datenbank, um einen Verweis auf sie einzurichten.

Behandeln von Automatisierungsfehlern

In den Versionen 1.x und 2.0 von Microsoft Access geben COM-Komponenten, die Automatisierung unterstützen (früher OLE-Automatisierungs-Server genannt), einen einzelnen Fehler zurück. Visual Basic aktiviert nun eine COM-Komponente so, dass fehlerspezifische Fehlerinformationen zurückgegeben werden. Wenn Ihre bestehenden Datenbanken Code enthalten, der nur einen einzigen OLE-Automatisierungsfehler behandelt, aktualisieren Sie den Code so, dass die jetzt zurückgegebenen spezielleren Fehlercodes berücksichtigt werden.

Microsoft Access-Fehler und die Error-Funktion

In Microsoft Access 2000 verwenden Sie die Eigenschaften des Err-Objekts, um Informationen über Fehler zu erhalten.

Wenn ein Microsoft Access-Fehler auftritt, erhalten Sie die Fehlernummer und Fehlerbeschreibung, indem Sie die Number- und die Description-Eigenschaft des Err-Objekts wie im folgenden Beispiel verwenden:

Debug.Print Err.Number, Err.Description

Um Informationen über Microsoft Access-, Visual Basic- oder DAO-Fehler zurückzugeben, verwenden Sie die AccessError-Methode. Mit dieser Methode erhalten Sie Informationen über einen Fehler unabhängig davon, ob dieser tatsächlich aufgetreten ist.

Ausrufezeichen- oder Punkt-Operator in Verweisen auf DAO-Felder

Wenn Sie den . (Punkt)-Operator beim Verweisen auf ein Field-Objekt eines Recordset-Objekts in Anwendungen verwendet haben, die in den Versionen 1.x und 2.0 von Microsoft Access erstellt wurden, verwenden Sie in diesen Verweisen jetzt den ! (Ausrufezeichen)-Operator. Wenn Sie weiterhin den . (Punkt)-Operator verwenden möchten, richten Sie im Dialogfeld Verweise einen Verweis auf die Microsoft DAO 2.5/3.5-Kompatibilitätsbibliothek ein. Sie öffnen dieses Dialogfeld, indem Sie in der Modul-Entwurfsansicht im Menü Extras auf Verweise klicken.

Konvertierte ActiveX-Steuerelemente

Wenn Ihre Anwendung ActiveX-Steuerelemente enthält (früher "OLE-Steuerelemente" oder "Zusatzsteuerelemente" genannt), die in Version 2.0 eingerichtet wurden, stellen Sie ggf. das Schlüsselwort ByVal den Argumenten voran, die an Ereignisprozeduren übergeben werden, welche von ActiveX-Steuerelementen aufgerufen werden, wie z.B.:

Sub MonatWechseln_Click(ByVal intAktuellesJahr As Integer)

Sie können herausfinden, ob ein Argument als Wert (by Value) übergeben werden muss, indem Sie in der Modul-Entwurfsansicht im Menü Debuggen auf Kompilieren von Projektname klicken. Wenn Sie folgende Fehlermeldung erhalten, stellen Sie dem Argument das Schlüsselwort ByVal voran: "Ereignisprozedurdeklaration stimmt nicht mit Beschreibung des gleichnamigen Ereignisses überein."

Da die Datentypüberprüfung von Argumenten in Microsoft Access 2000 verbessert wurde, wird in neuen Ereignisprozeduren, die für ActiveX-Steuerelemente erstellt werden, bei Bedarf automatisch das Schlüsselwort ByVal eingefügt.

Aufrufen von Prozeduren in Formular- und Berichtsmodulen

In den Versionen 1.x und 2.0 von Microsoft Access konnten Sie eine in einem Formular oder Bericht definierte Prozedur nicht von einer beliebigen Stelle aufrufen, sondern nur innerhalb des betreffenden Formular- oder Berichtsmoduls. In Microsoft Access 2000 können Sie eine öffentliche Prozedur in einem Formular- oder Berichtsmodul von jeder beliebigen Prozedur der aktuellen Datenbank aus aufrufen. Geben Sie hierzu für die Prozedur den Klassennamen des Formular- oder Berichtsmoduls an. Beispielsweise können Sie die Prozedur AnzeigeMeldung, die im Modul des Formulars Bestellungen definiert ist, folgendermaßen aufrufen:

Form_Bestellungen.AnzeigeMeldung

Fügen Sie Prozeduren, die außerhalb eines Formulars oder Berichts aufgerufen werden, am besten einem Standardmodul und nicht einem Formular- oder Berichtsmodul hinzu.

Verweisen auf Formulare, Berichte und Steuerelemente aus dem Testfenster

Beim Testen von Code und bei der Fehlersuche geben Sie alle im Testfenster verwendeten Verweise auf Objekte vollständig an, es sei denn, Sie haben die Ausführung in einem Formular- oder Berichtsmodul unterbrochen. Dies bedeutet, dass Sie im Direktbereich des Testfensters den Code Formulare!Kategorien![Kategorie-Nr] statt lediglich [Kategorie-Nr] verwenden müssen, um sich auf das Steuerelement Kategorie-Nr des Formulars Kategorien in der Formularansicht zu beziehen, auch wenn Kategorien das aktuelle Formular ist.

Ebenso können Sie mit dem Schlüsselwort Me nur dann im Testfenster einen Verweis auf ein Objekt in einem Formular oder Bericht in der Entwurfsansicht erstellen, wenn Sie die Codeausführung im Formular oder Bericht unterbrochen haben.

Konvertieren von Formularen und Berichten, die ActiveX-Steuerelemente enthalten

Wenn Sie eine Microsoft Access-Datenbank der Version 2.0 zur Verwendung in Microsoft Access 2000 (Version 9.0) konvertieren, werden ActiveX-Steuerelemente in Formularen und Berichten unter Umständen nicht automatisch konvertiert. Microsoft Access 2.0 unterstützt 16-Bit-OLE-Zusatzsteuerelemente, die Version 9.0 dagegen ausschließlich 32-Bit-ActiveX-Steuerelemente.

Wenn Sie eine Datenbank konvertieren, die ein Formular oder einen Bericht mit einer 16-Bit-Version eines ActiveX-Steuerelements enthält, und die 32-Bit-Version in Ihrem System noch nicht vorhanden ist, zeigt Microsoft Access eine Fehlermeldung an. Für jedes ActiveX-Steuerelement, das Sie aktualisieren möchten, muss eine 32-Bit-Version vorhanden und in der Systemregistrierung eingetragen sein. Speichern Sie das Formular oder den Bericht dann in der konvertierten Datenbank, schließen Sie die Datenbank, und öffnen Sie sie erneut.

Aufbereiten einer Datenbank, die mit einer früheren Version von Microsoft Access erstellt wurde

Wenn Sie eine große Datenbank aufbereiten, die mit der Version 1.x oder 2.0 von Microsoft Access erstellt wurde, diese aber nicht in Microsoft Access 2000 konvertieren, vergrößern Sie ggf. die maximale Puffergröße über die Standardeinstellung hinaus. Um diese Einstellung zu ändern, öffnen Sie die Systemregistrierung, und gehen Sie zu dem Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.0\Engines\Jet 2.x. Erstellen Sie einen neuen Teilschlüssel namens ISAM, und erstellen Sie innerhalb dieses Teilschlüssels den neuen DWORD-Wert MaxBufferSize. Setzen Sie diesen Wert auf 1024 (dezimal). Weitere Informationen zum Bearbeiten der Registrierung finden Sie in der Microsoft Windows-Dokumentation.

Umbenennen einer Datenbank

Wenn Sie eine Datenbank umbenennen, wird kompilierter Code in der Datenbank dekompiliert. Zum erneuten Kompilieren des Codes und zum Speichern aller Module in kompiliertem Zustand, öffnen Sie die Datenbank, öffnen Sie ein Modul in der Entwurfsansicht, und klicken Sie im Menü Debuggen auf Kompilieren von Projektname.

Zeitangaben in Abfragekriterien

Nach dem Konvertieren einer Datenbank aus den Versionen 1.x oder 2.0 nach Microsoft Access 2000 geben Abfragen mit Kriterien, die auf bestimmten Zeitangaben in Feldern vom Typ Datum/Uhrzeit basieren, möglicherweise andere Ergebnisse zurück als in den früheren Versionen. Dies kann auch vorkommen, wenn Sie Tabellen einer Datenbank aus den Versionen 1.x oder 2.0 mit einer Microsoft Access 2000-Datenbank verknüpfen; hiervon ist lediglich der Zeitteil von Feldern vom Typ Datum/Uhrzeit betroffen.

Visual Basic-Funktionen, die in Ausdrücken nicht unterstützt werden

Die folgenden sechs Visual Basic-Funktionen können nicht mehr in Ausdrücken außerhalb einer benutzerdefinierten Sub-Prozedur oder Funktion verwendet werden:

EOF | Loc
FileAttr | LOF
FreeFile | Seek

Wenn Sie eine dieser Funktionen in einem Ausdruck außerhalb einer Prozedur verwenden möchten, können Sie die Funktion von einer benutzerdefinierten Funktion aus aufrufen, die wiederum im Ausdruck aufgerufen wird.

Zeilennummern in Visual Basic-Prozeduren

Sie können Anweisungen in Visual Basic-Prozeduren nur Zeilennummern bis 65529 zuweisen. Wenn eine aus Microsoft Access, Version 1.x oder 2.0, konvertierte Anwendung höhere Zeilennummern als 65529 enthält, passen Sie diese so an, dass sie im gültigen Bereich liegen.

Die Schaltflächen "Nächste Prozedur" und "Vorherige Prozedur"

Die Schaltflächen Nächste Prozedur und Vorherige Prozedur, die sich in den Versionen 1.x und 2.0 von Microsoft Access auf der Symbolleiste Modul befinden, sind in Microsoft Access 2000 nicht mehr verfügbar. Das Konvertieren einer Datenbank der Versionen 1.x oder 2.0 mit einer benutzerdefinierten Symbolleiste, die eine dieser Schaltflächen enthält, verursacht zwar keinen Fehler, doch beim Klicken auf die Schaltflächen reagieren diese nicht.

Fehler "Nicht genügend Speicher" beim Konvertieren großer Datenbanken

Visual Basic für Applikationen ist auf 1082 Module pro Datenbank beschränkt, wobei Formulare und Berichte jeweils ein Modul enthalten. Um dieses Problem zu beheben, verringern Sie die Anzahl der Objekte in Ihrer Datenbank, oder teilen Sie die Anwendung in mehrere Datenbanken auf. Wenn Ihre Module sehr viel Code enthalten, speichern Sie diesen nach Möglichkeit in Bibliotheksdatenbanken.

Formatieren von Null-Werten und leeren Zeichenfolgen

In Microsoft Access, Version 2.0, können Sie mit der Format-Funktion einen Wert für eine leere Zeichenfolge und einen anderen Wert für einen Null-Wert zurückgeben. Ebenso können Sie mit der Format-Eigenschaft automatisch Felder in der Tabellen-Datenblattansicht oder Steuerelemente in einem Formular oder Bericht formatieren. Beispielsweise können Sie den folgenden Formatausdruck in der Format-Funktion verwenden, um den entsprechenden Zeichenfolgenwert aus dem Code zurückzugeben:

Dim var As Variant, strX As String
' Zuweisen eines Wertes an strX und Übergeben an die Format-Funktion.
var = Format(strX, "@;LZ;Null")

Testen Sie in Microsoft Access 2000 selbst auf den Null-Wert, und geben Sie dann ergebnisabhängig den entsprechenden Wert zurück. Beispielsweise können Sie die IIf-Funktion in einem Ausdruck zusammen mit der Format-Funktion wie folgt verwenden:

var = IIf(IsNull(strX),"Null", Format(strX, "@;LZ"))

Diese Änderung ist nur dann von Bedeutung, wenn Sie mit der Format-Funktion einen Wert abhängig davon formatieren, ob es sich um eine leere Zeichenfolge oder einen Null-Wert handelt. Andere Formatausdrücke in der Format-Funktion können genauso wie in früheren Versionen verwendet werden.

Wenn Sie eine Datenbank von Microsoft Access, Version 2.0, nach Microsoft Access 2000 konvertieren, ändern Sie den Code und die Eigenschafteneinstellungen so, dass diese Methoden verwendet werden. Sie können die Format-Eigenschaft in der Tabellen-Datenblattansicht nicht verwenden, um zwischen Null-Werten und leeren Zeichenfolgen zu unterscheiden.


 Konvertieren von Bibliotheksdatenbanken und Add-Ins

Konvertieren von Bibliotheksdatenbanken und Add-Ins

Wenn Sie mit Add-Ins oder Bibliotheksdatenbanken arbeiten möchten, die in früheren Microsoft Access-Versionen erstellt wurden, konvertieren Sie diese in das Microsoft Access 2000 (Version 9.0)-Format, bevor Sie sie mit Anwendungen, die in Microsoft Access 2000 erstellt worden sind, einsetzen können.

Unter Umständen müssen Sie auch einige Änderungen an den Objekten, Makros und Prozeduren Ihrer Bibliotheksdatenbanken und Add-Ins vornehmen, damit diese korrekt ausgeführt werden.

Weitere Informationen zu Bibliotheksdatenbanken finden Sie in Kapitel 10, "Die Windows-API and andere DLL's", im Microsoft Office 2000/Visual Basic Handbuch für Programmierer oder unter Einstellen von Verweisen auf Typbibliotheken. Um zu erfahren, wie Sie das Microsoft Office 2000/Visual Basic Handbuch für Programmierer erhalten können, klicken Sie auf [image] .

Verweisen auf und Laden von Bibliotheksdatenbanken

Bevor Sie eine Bibliothek in Microsoft Access 2000 verwenden können, müssen Sie für jede Anwendung, die die Bibliotheksdatenbank verwendet, einen Verweis darauf einrichten. Sie richten einen Verweis ein, indem Sie beim Arbeiten in der Modul-Entwurfsansicht im Menü Extras auf Verweise klicken. Die referenzierte Datenbank muss sich im Microsoft Access 2000-Format befinden.

Eine Bibliotheksdatenbank enthält ausschließlich Visual Basic-Code, den Sie aus jeder Anwendung aufrufen können, die auf die entsprechende Bibliothek verweist. In den Versionen 1.x und 2.0 von Microsoft Access haben Sie eine Bibliotheksdatenbank beim Starten geladen, indem Sie im Bereich Libraries der .INI-Datei einen Eintrag eingefügt haben. Die Informationen, die in den Versionen 1.x und 2.0 in einer .INI-Datei gespeichert wurden, befinden sich in den höheren Versionen überwiegend in der Windows-Registrierung. Sie brauchen jedoch keinen Windows-Registrierungsschlüssel zu erstellen, um mit einer Bibliotheksdatenbank arbeiten zu können.

Zirkelbezüge zwischen Bibliotheken

In den Versionen 1.x und 2.0 von Microsoft Access sind Zirkelbezüge zwischen Bibliotheken möglich. Diese sind in höheren Microsoft Access-Versionen jedoch nicht mehr zulässig. Das bedeutet, dass Sie keinen Verweis von Bibliothek B auf Bibliothek A erstellen können, wenn Sie bereits einen Verweis von Bibliothek A auf Bibliothek B eingerichtet haben.

Aufrufen von benutzerdefinierten Add-Ins aus Menüs und Symbolleisten

In den Versionen 1.x und 2.0 von Microsoft Access werden Add-Ins automatisch im Untermenü Add-Ins des Menüs Datei angezeigt. In höheren Microsoft Access-Versionen befindet sich das Untermenü Add-Ins im Menü Extras. In Microsoft Access 2000 können Sie auch aus jeder Symbolleiste und aus jedem Menü auf Add-Ins verweisen.


 Konvertieren von Tastaturbefehle-/SendKeys-Tastenkombinationen

Konvertieren von Tastaturbefehle-/SendKeys-Tastenkombinationen

Wenn Sie eine Datenbank der Versionen 1.x und 2.0 von Microsoft Access in Microsoft Access 2000 konvertieren, müssen Sie ggf. aufgrund von Änderungen in einigen Dialogfeldern und Menüs die SendKeys-Anweisung oder die Aktion Tastaturbefehle neu implementieren. So wurde z.B. das Untermenü Add-Ins vom Menü Datei zum Menü Extras verschoben, und die früheren Untermenüs Importieren, Exportieren und Einbinden des Menüs Datei wurden in das Untermenü Externe Daten und den Befehl Speichern unter/Exportieren umgewandelt. Da derartige Änderungen mit großer Wahrscheinlichkeit in jeder neuen Version von Microsoft Access vorkommen werden, ist es sinnvoll, die SendKeys-Anweisung und die Aktion Tastaturbefehle zum Ausführen von Befehlen oder zum Ausfüllen von Dialogfeldern möglichst ganz zu vermeiden.

Die folgenden Tipps helfen Ihnen dabei, die Anweisung SendKeys und die Aktion Tastaturbefehle weitgehend zu vermeiden:

  • Bevor Sie die Anweisung SendKeys oder die Aktion Tastaturbefehle zum Ausführen eines Menübefehls verwenden, überprüfen Sie, ob Sie eine äquivalente Makroaktion oder Visual Basic-Methode verwenden können. Für die meisten Befehle, die üblicherweise mit Hilfe von Menübefehl oder Option ausgeführt werden, gibt es eine entsprechende Aktion oder Methode. Sie können jetzt z.B. die Methode Dropdownfeld eines Kombinationsfelds an Stelle des Codes SendKeys "{F4}" verwenden.

  • Gibt es für einen Menübefehl keine äquivalente Aktion oder Methode, so verwenden Sie an Stelle der Anweisung SendKeys oder der Aktion Tastaturbefehle die Aktion AusführenBefehl, um den Menübefehl auszuführen.

  • Vermeiden Sie es, mit der SendKeys-Anweisung oder der Aktion Tastaturbefehle Optionen im Dialogfeld Optionen einzustellen. Neue Versionen von Microsoft Access enthalten neue und geänderte Optionen, so dass der Code in Ihrer SendKeys-Anweisung bzw. Ihrer Aktion Tastaturbefehle nicht mehr fehlerfrei ausgeführt werden kann. Verwenden Sie stattdessen die GetOption- und die SetOption-Methode.

  • Wenn Sie mit Hilfe der Anweisung SendKeys eine Aktion ausführen möchten, ziehen Sie es in Erwägung, für die Werte der Anweisung Verweise auf die eingebauten Tastencode-Konstanten zu verwenden oder Konstanten zu deklarieren. Das Definieren von Tastenanschlägen als Konstanten erleichtert Ihnen zukünftig das Aktualisieren des Codes.

  • In Microsoft Access, Version 2.0, können Sie das Argument Tastenfolge der Aktion Tastaturbefehle in Anführungszeichen einschließen, obgleich dies nicht erforderlich ist. Wenn Sie dieses Argument in zukünftigen Microsoft Access-Versionen in Anführungszeichen einschließen, verwenden Sie doppelte Anführungszeichen, wie z.B. in Michael ""Mike"" Sommer. Ein Fehler kann auch dann auftreten, wenn das Argument Tastenfolge syntaktisch falsch ist, falsch geschriebenen Text oder andere Werte enthält, die für das Fenster, zu dem die Tastenfolge gesendet wird, ungeeignet sind.


 Erstellen eines gebundenen HTML-Steuerelements in einer Datenzugriffsseite

Erstellen eines gebundenen HTML-Steuerelements in einer Datenzugriffsseite

Anmerkung Sie können ein gebundenes HTML-Steuerelement benutzen, um Daten aus einem Feld in einer Datenbank oder eines Ausdrucksergebnis anzuzeigen.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Gebundener HTML-Text Gebundener HTML-Text (Steuerelement) .

  3. Um das Steuerelement an ein Feld zu binden, klicken Sie in der Feldliste auf das Feld, das den HTML-Code enthält, und ziehen Sie es dann auf die Datenzugriffsseite.

  4. Legen Sie das Feld anschließend innerhalb der Datenzugriffsseite dort ab, wo sich die obere linke Ecke des gebundenen HTML-Steuerelements befinden soll.


 Erstellen von Objektvariablen

Erstellen von Objektvariablen

In Microsoft Access können Sie eine Objektvariable als Objekt bestimmten Typs, als Object oder als Variant deklarieren. Zu den Objekten bestimmten Typs gehören: Microsoft Access-Objekte, Datenzugriffsobjekte (DAO), Visual Basic Collection-Objekte, Instanzen eines Klassenmoduls sowie Automatisierungsobjekte (früher "OLE-Automatisierungsobjekte" genannt). Im folgenden Beispiel sind verschiedene Objekte bestimmten Typs aufgeführt, die Sie verwenden können.

Dim frmBestellformular As Form        ' Deklariert ein Form-Objekt.
    Dim tdfBestellungen As TableDef       ' Deklariert ein TableDef-Objekt.
      Dim colElemente As New Collection     ' Neues Collection-Objekt.
        Dim obj As New Klasse1                ' Neue Instanz eines Klassenmoduls.
          Dim appXL As Excel.Application        ' Automatisierungsobjekt.

            Anmerkung Wenn Sie in der Deklaration einer Objektvariablen das Schlüsselwort New verwenden, wird ein neues Objekt erstellt und die Variable automatisch so eingestellt, dass sie auf dieses Objekt zeigt. Daher ist es nicht erforderlich, die Set-Anweisung zu verwenden.

              In einem Formularmodul oder Berichtsmodul können Sie das Schlüsselwort Me verwenden, um auf das Formular oder den Bericht zu verweisen, zu dem das Modul gehört. Mit dem Schlüsselwort Me können Sie das jeweils aktuelle Formular ansprechen, ohne dessen vollständigen Verweis angeben zu müssen.

              Die folgende Prozedur könnten Sie z.B. in einem Standardmodul verwenden, um die Farbe des Detailbereichs eines Formulars zu wechseln.

              Sub FormularfarbeWechseln(frmAktuell As Form)
    frmAktuell.Section(acDetail).BackColor = RGB(Rnd * 256, _
       Rnd * 256, Rnd * 256)
End Sub

              Sie können diese Prozedur aus einem Formularmodul aufrufen und dabei das Schlüsselwort Me als Argument an die Prozedur übergeben. Das Schlüsselwort Me entspricht dem Formular, von dem aus die Prozedur aufgerufen und für das die Prozedur ausgeführt wird.

              Z.B. könnten Sie diese Prozedur aus der Click-Ereignisprozedur eines Formularbereichs aufrufen. Stellen Sie dazu die Eigenschaft OnClick des Detailbereichs auf [Ereignisprozedur] ein, und erstellen Sie im Modul des Formulars folgende Sub-Prozedur.

              Private Sub Detail_Click()
    FormularfarbeWechseln Me
End Sub

              Wenn das Formular den Namen Bestellungen hätte, könnten Sie diese Prozedur auch mit der folgenden Anweisung aufrufen.

              FormularfarbeWechseln Formulare!Bestellungen

              Ein Vorteil der Verwendung des Schlüsselworts Me besteht darin, dass Sie auf ein Formular verweisen können, ohne dessen Namen wissen zu müssen.


Ausdrücke, die Textwerte als Kriterien verwenden - Beispiele

Feld | Ausdruck | Beschreibung
Ort | "London" | Zeigt die nach London versendeten Bestellungen an.
Ort | "London" Oder "Hedge End" | Verwendet den Operator Oder, um die nach London oder Hedge End versendeten Bestellungen anzuzeigen.
Versanddatum | Zwischen #5.1.95# Und #10.1.95# | Verwendet den Operator Zwischen...Und, um die Bestellungen anzuzeigen, die zwischen dem 5. Und 10. Januar 95 versendet wurden.
Versanddatum | #2.2.95# | Zeigt die Bestellungen an, die am 2. Februar 95 versendet wurden.
Bestimmungsland | In("Kanada", "UK") | Verwendet den Operator In, um die nach Kanada oder Großbritannien versendeten Bestellungen anzuzeigen.
Bestimmungsland | Nicht "USA" | Verwendet den Operator Nicht, um die Bestellungen anzuzeigen, die in andere Länder als die USA versendet werden.
Empfänger | Wie "S*" | Zeigt die Bestellungen an, die an Kunden gesendet werden, deren Name mit dem Buchstaben "S" beginnt.
Firma | >="N" | Zeigt die Bestellungen an, die an Firmen mit Anfangsbuchstaben von "N" bis "Z" gesendet werden.
Bestell-Nr. | Rechts([Bestell-Nr], 2)="99" | Verwendet die Funktion Rechts, um die Bestellungen anzuzeigen, deren Bestell-Nr. mit "99" endet.
Firma | Länge([Firma])>Wert(30) | Verwendet die Funktionen Länge und Wert, um die Bestellungen der Firmen anzuzeigen, deren Name länger als 30 Zeichen ist.


Ausdrücke, die das Ergebnis einer Domänen-Aggregatfunktion als Kriterium verwenden - Beispiele

Feld | Ausdruck | Beschreibung
Frachtkosten | >(DomStAbw("[Frachtkosten]", "Bestellungen") + DomMittelwert("[Frachtkosten]", "Bestellungen")) | Verwendet die Funktionen DomMittelwert und DomStAbw. Zeigt alle Bestellungen an, deren Frachtkosten über dem Durchschnittswert liegen, zuzüglich der Standardabweichung für Frachtkosten.
Menge | >DomMittelwert("[Anzahl]", "Bestelldetails") | Verwendet die Funktion DomMittelwert, um die Artikel anzuzeigen, welche in Stückzahlen bestellt werden, die über den Durchschnittsbestellmengen liegen.

Um weitere Informationen zur Verwendung von Aggregatfunktionen für Domänen anzuzeigen, klicken Sie auf [image] .


Ausdrücke, die das Ergebnis von Unterabfragen als Kriterium verwenden - Beispiele

Feld | Ausdruck | Anzeige
Einzelpreis | (SELECT [Einzelpreis] FROM [Artikel] WHERE [Artikelname] = "Anissirup") | Artikel, deren Preis mit dem von Anissirup identisch ist
Einzelpreis | >(SELECT AVG([Einzelpreis]) FROM [Artikel]) | Artikel, deren Einzelpreis über dem Durchschnitt liegt
Gehalt | > ALL (SELECT [Gehalt] FROM [Personal] WHERE ([Position] LIKE "*Manager*") OR ([Position] LIKE "*Direktor*")) | Die Gehälter der Verkaufsrepräsentanten, die höher sind als diejenigen der Mitarbeiter, deren Position "Manager" oder "Direktor" lautet
Bestellsumme: [Einzelpreis]* [Anzahl] | > ALL (SELECT AVG([Einzelpreis] * [Anzahl]) FROM [Bestelldetails]) | Bestellungen, deren Summen über dem durchschnittlichen Bestellwert liegen


Ausdrücke, die Datumsangaben berechnen oder bearbeiten und das Ergebnis als Kriterium verwenden - Beispiele

Feld | Ausdruck | Beschreibung
Lieferdatum | Zwischen Datum( ) Und DatAdd("m", 3, Datum( )) | Verwendet den Operator Zwischen...Undund die Funktionen DatAdd und Datum. Zeigt die Bestellungen an, deren Lieferdatum innerhalb der nächsten drei Monate ab dem heutigen Datum liegt.
Bestelldatum | < Datum( )- 30 | Verwendet die Funktion Datum, um die Bestellungen anzuzeigen, die mehr als 30 Tage zurückliegen.
Bestelldatum | Jahr([Bestelldatum])=1996 | Verwendet die Funktion Jahr, um die Bestellungen aus dem Jahr 1996 anzuzeigen.
Bestelldatum | DatTeil("q", [Bestelldatum])=4 | Verwendet die Funktion DatTeil, um die Bestellungen des vierten Quartals anzuzeigen.
Bestelldatum DatSeriell(Jahr
([Bestelldatum]),
Monat([Bestelldatum])+1, 1)-1 		Verwendet die Funktionen DatSeriell, Jahr und Monat, um für die einzelnen Monate jeweils die Bestellungen des letzten Tages anzuzeigen.
Bestelldatum Jahr([Bestelldatum])=
Jahr(Jetzt()) Und Monat([Bestelldatum])=
Monat(Jetzt()) 		Verwendet die Funktionen Jahr und Monat sowie den Operator Und, um die Bestellungen des aktuellen Jahres und Monats anzuzeigen.


Ausdrücke, die einen Teil eines Feldwertes als Kriterium verwenden - Beispiele

Feld | Ausdruck | Anzeige
Empfänger | Wie "S*" | Bestellungen, die an Kunden gesendet werden, deren Namen mit "S" beginnen.
Empfänger | Wie "*Importe" | Bestellungen, die an Kunden gesendet werden, deren Namen mit "Importe" enden.
Empfänger | Wie "[A-D]*" | Bestellungen, die an Kunden gesendet werden, deren Namen mit den Buchstaben "A" bis "D" beginnen.
Empfänger | Wie "*ar*" | Bestellungen, die an Kunden gesendet werden, deren Namen die Buchstabenfolge "ar" enthalten.
Empfänger | Wie "Maison Dewe?" | Bestellungen, die an einen Kunden gesendet werden, dessen erster Teil des Namens "Maison" lautet, gefolgt von einem zweiten Teil mit fünf Buchstaben, der mit "Dewe" beginnt und dessen letzter Buchstabe unbekannt ist.


 Ausdrücke, die den Wert eines leeren Feldes (leere Zeichenfolge) als Kriterium verwenden - Beispiele

Ausdrücke, die den Wert eines leeren Feldes (leere Zeichenfolge) als Kriterium verwenden - Beispiele

Um weitere Informationen zur Verwendung von Nullwerten und leeren Zeichenfolgen anzuzeigen, klicken Sie auf [image] .

Feld | Ausdruck | Beschreibung
Region | Ist Null | Zeigt die Bestellungen der Kunden an, für die das Feld Region Null enthält (leer ist).
Region | Ist Nicht Null | Zeigt die Bestellungen der Kunden an, für die das Feld Region einen Wert enthält.
Fax | " " | Zeigt die Bestellungen der Kunden an, die kein Faxgerät besitzen. Im Feld Telefax ist dann an Stelle eines Nullwertes eine leere Zeichenfolge angegeben.


Unterschiede bei der Verwendung mehrerer Seiten oder Registerkarten in einem Formular

Sie haben zwei Möglichkeiten, ein mehrseitiges Formular zu erstellen. Sie können hierzu entweder ein Registerkarten- oder ein Seitenwechsel-Steuerelement verwenden.

Ein Registerkarten-Steuerelement stellt die einfachste und effektivste Art dar, ein Formular mit mehreren Seiten zu erstellen. Dabei sind sämtliche Seiten Bestandteil eines einzigen Steuerelements. Um auf eine andere Seite zu gelangen, klicken Sie auf eine der Registerkarten.

Registerkarten-Steuerelement mit zwei Registerkarten

Verwenden Sie ein Seitenwechsel-Steuerelement, um zwischen den Steuerelementen eines Formulars durch eine horizontale Linie eine Trennung vorzunehmen. Wenn Sie die BILD-AUF- oder BILD-AB-TASTE drücken, führt Microsoft Access einen Bildlauf zur Seite vor bzw. nach dem Seitenwechsel-Steurelement durch.

Zurück zu Erstellen eines Formulars mit mehreren Seiten oder Registerkarten


 Gültigkeitsprüfung von Daten mit einem Makro: Beispiel

Gültigkeitsprüfung von Daten mit einem Makro: Beispiel

Es kann vorkommen, dass Sie Gültigkeitsregeln verwenden möchten, die von komplexen Bedingungen abhängig sind. Sie können dann je nach Bedingung verschiedene Aktionen durchführen. Da z.B. in verschiedenen Ländern unterschiedliche Regeln für Postleitzahlen gelten, kann eine Datenbank, die Postleitzahlen vieler Länder speichert, sich nicht auf eine einfache Gültigkeitsregel verlassen, um zu gewährleisten, dass eine Postleitzahl korrekt eingegeben wurde.

Sie können jedoch ein Makro erstellen, das überprüft, welches Land im Steuerelement Land eingegeben wurde, und dann darauf achtet, dass der in das Steuerelement Postleitzahl eingegebene Wert die richtigen Merkmale für dieses Land besitzt.

Erstellen Sie zunächst ein Makro, das verschiedene Meldungen, abhängig vom Wert des Steuerelements Land und von der Länge des Eintrags im Steuerelement Postleitzahl, anzeigt.

Überprüfen der Gültigkeit von Daten unter Verwendung eines Makros

Öffnen Sie dann das Formular, das die Steuerelemente enthält, in der Entwurfsansicht, und stellen Sie schließlich die Ereigniseigenschaft BeforeUpdate des Formulars auf den Namen des Makros ein. Verwenden Sie die Formulareigenschaft an Stelle der Steuerelementeigenschaft, da sich die Gültigkeitsprüfung auf zwei verschiedene Steuerelemente im Formular bezieht.

Wenn Sie nun das Formular verwenden, um einen neuen Lieferanten hinzuzufügen, führt Microsoft Access das Gültigkeitsmakro aus, nachdem Sie die Eingabe des neuen Datensatzes beendet haben, jedoch noch bevor der Datensatz in der Tabelle Lieferanten gespeichert wird. Wenn eine der Bedingungen des Makros erfüllt ist, zeigt Access die entsprechende Meldung an und speichert den Datensatz nicht in der Tabelle.


 Datendefinitionsabfragen - Beispiele

Datendefinitionsabfragen - Beispiele

Erstellen einer Tabelle

Die folgende Datendefinitionsabfrage verwendet die Anweisung CREATE TABLE, um eine Tabelle mit dem Namen Freunde zu erstellen. Die Anweisung schließt die Namen und Datentypen aller Felder der Tabelle ein und weist dem Feld Code einen Index zu, der es als Primärschlüssel kennzeichnet.

CREATE TABLE Freunde
([Code] integer,
[Nachname] text,
[Vorname] text,
[Geburtstag] date,
[Telefon] text,
[Bemerkungen] memo,
CONSTRAINT [Index1] PRIMARY KEY ([Code]));

Erstellen eines Index

Die folgende Datendefinitionsabfrage verwendet die Anweisung CREATE INDEX, um einen Mehr-Felder-Index auf der Basis der Felder Nachname und Vorname zu erstellen.

CREATE INDEX NeuerIndex
ON Freunde ([Nachname] ASC, [Vorname] DESC);


 Kriterienausdrücke für Abfragen oder Spezialfilter - Beispiele

Kriterienausdrücke für Abfragen oder Spezialfilter - Beispiele

Sie können einen Kriterienausdruck in der Zelle der Zeile Kriterien im Fenster Spezialfilter/-sortierung oder im Abfrage-Entwurfsbereich verwenden.

Anmerkung Sie können auch benutzerdefinierte Kriterienausdrücke in einem Feld im Fenster Formularbasierter Filter oder die Ausdrücke aus der Liste in den Feldern verwenden.

Was möchten Sie tun?

Beispiele für Ausdrücke ansehen, die Textwerte als Kriterien verwenden

Beispiele für Ausdrücke ansehen, die Datumsangaben berechnen oder ändern und die Ergebnisse dann als Kriterien verwenden

Beispiele für Ausdrücke ansehen, die den Wert eines leeren Feldes (Null oder eine leere Zeichenfolge) als Kriterium verwenden

Beispiele für Ausdrücke ansehen, die einen Teil eines Feldwertes als Kriterium verwenden

Beispiele für Ausdrücke ansehen, die das Ergebnis einer Aggregatfunktion für Domänen als Kriterium verwenden

Beispiele für Ausdrücke ansehen, die die Ergebnisse von Unterabfragen als Kriterien verwenden

Beispiele für die Verwendung mehrerer Kriterien in einem oder mehreren Feldern einer Abfrage ansehen


 Ausdrücke, die Werte unter Verwendung eines berechneten Feldes in einer Abfrage berechnen oder bearbeiten - Beispiele

Ausdrücke, die Werte unter Verwendung eines berechneten Feldes in einer Abfrage berechnen oder bearbeiten - Beispiele

Sie können den gewünschten Ausdruck für das berechnete Feld in der Zelle Feld im Abfrageentwurfsbereich eingeben.

Ausdruck für ein berechnetes Feld

Was möchten Sie tun?

Informationen zum Erstellen eines Ausdrucks erhalten

Weitere Informationen zu berechneten Feldern erhalten

Beispiele von Ausdrücken anzeigen, die Text ändern

Beispiele von Ausdrücken anzeigen, die arithmetische Operationen durchführen

Beispiele von Ausdrücken anzeigen, die Datumsangaben ändern und berechnen

Beispiele von Ausdrücken anzeigen, die mittels SQL-Aggregatfunktionen oder Aggregatfunktionen für Domänen die Anzahl, die Summe oder den Mittelwert von Werten berechnen

Beispiele von Ausdrücken zum Arbeiten mit leeren Feldern (Nullwerten) anzeigen

Ein Beispiel für einen Ausdruck anzeigen, der eine Unterabfrage verwendet


Ausdrücke in SQL-Anweisungen - Beispiele

Wie die folgenden Beispiele verdeutlichen, können Sie Ausdrücke an verschiedenen Stellen in einer SQL-Anweisung verwenden. Die Ausdrücke sind rot gekennzeichnet.

Ausdruck | Ergebnis
SELECT [Vorname], [Nachname] FROM [Personal] WHERE [Nachname]="Davolio"; | Zeigt die Werte in den Feldern Vorname und Nachname für die Angestellten an, deren Nachname Davolio lautet.
SELECT [Artikel-Nr], [Artikelname] FROM [Artikel] WHERE [Kategorie-Nr]= Formulare![Artikel]![Kategorie-Nr]; | Zeigt die Werte in den Feldern Artikel-Nr und Artikelname der Tabelle Artikel für die Datensätze an, in denen der Wert im Feld Kategorie-Nr mit dem Wert im Feld Kategorie-Nr des geöffneten Formulars Artikel übereinstimmt.
SELECT Avg([Endpreis]) AS [Durchschnittsendpreis] FROM [Bestelldetails] WHERE [Endpreis]>1000; | Berechnet den durchschnittlichen Endpreis für Bestellungen, für die im Feld Endpreis ein Wert größer als 1000 eingetragen ist, und zeigt diesen in einem Feld namens Durchschnittsendpreis an.
SELECT [Kategorie-Nr],Count([Artikel-Nr]) AS [AnzahlArtikel-Nr] FROM [Artikel] GROUP BY [Kategorie-Nr] HAVING Count([Artikel-Nr])>10; | Zeigt in einem Feld namens AnzahlArtikel-Nr die Gesamtanzahl der Artikel für die Kategorien mit mehr als 10 Artikeln an.


Berichte, die jede Gruppe in einer neuen Zeile oder Spalte beginnen - Beispiele

In mehrspaltigen Berichten können Sie Gruppenüberschriften hervorheben, indem Sie sie entweder von oben nach unten links auf der Seite oder quer am oberen Rand der Seite positionieren. In den folgenden Beispielen für Berichte wird Kategorie-Nr als Gruppenkopf und Artikelname als Detaildatensatz verwendet.

Bericht, in dem jeder Gruppenkopf in einer neuen Zeile gedruckt wird

Um den vorstehenden Bericht zu erstellen, fügen Sie das Textfeld für Kategorie-Nr in den Gruppenkopf und das Textfeld für Artikelname in den Detailbereich ein. Anschließend setzen Sie die Eigenschaft NeueZeileOderSpalte des Kopfes Kategorie-Nr auf Vor & Nach und stellen die folgenden Eigenschaften auf der Registerkarte Spalten im Dialogfeld Seitenformat (Befehl Seitenformat im Menü Datei) ein:

Gruppe | Eigenschaft | Einstellung
Rastereinstellungen | Spaltenanzahl | 3
Spaltengröße | Breite | Die Breite einer Spalte im Detailbereich, z.B. 50,8 mm (2 Zoll)
 | Höhe | Die Höhe einer Zeile, z.B. 6,4 mm (0,25 Zoll)
Spaltenlayout | Quer, dann nach unten | Gewählt

Um den Bericht im folgenden Beispiel zu erstellen, verwenden Sie denselben Entwurf wie im vorhergehenden Beispiel, setzen jedoch die Eigenschaft NeueZeileOderSpalte des Gruppenkopfs Kategorie-Nr auf Vor Bereich und stellen Spaltenlayout im Dialogfeld Seitenformat auf Nach unten, dann quer ein.

Bericht, in dem jeder Gruppenkopf in einer neuen Spalte gedruckt wird


Einfache optimierbare Ausdrücke - Beispiele

Wenn Sie Indizes für die Felder Nachname, Alter und Einstellungsdatum der Tabelle Personal erstellt haben, handelt es sich bei den folgenden Ausdrücken um einfache optimierbare Ausdrücke:

  • [Nachname]="Schmidt"

  • [Alter]>=21

  • #30.12.90#<[Einstellungsdatum]

  • Personal.[Nachname]=Kunden.[Nachname]

  • [Nachname] In ("Schmidt", "Maier", "Müller")

  • [Alter] Zwischen 18 Und 65


 Union-Abfragen - Beispiele

Union-Abfragen - Beispiele

Union-Abfragen kombinieren Felder aus mehreren Tabellen oder Abfragen in einem Feld. Die folgenden Beispiele zeigen eine Basis-Union-Abfrage sowie Union-Abfragen, die Datensätze sortieren, Felder umbenennen und doppelte Datensätze zurückgeben.

Das vorliegende Thema bietet Informationen zu folgenden Punkten:

Basic-Union-Abfrage

Sortieren in einer Union-Abfrage

Umbenennen von Feldern in einer Union-Abfrage

Zurückgeben doppelter Datensätze in einer Union-Abfrage

Basic-Union-Abfrage

Die folgende Union-Abfrage besteht aus zwei SQL SELECT-Anweisungen. Es werden alle Firmen und Orte Brasiliens zurückgegeben, die sowohl in der Tabelle Lieferanten als auch in der Tabelle Kunden vorkommen.

Zusammenfassen von Daten aus zwei oder mehr Tabellen unter Verwendung einer Union-Abfrage

Zurück zum Anfang

Sortieren in einer Union-Abfrage

Die folgende Union-Abfrage wählt alle Firmen und Orte aus, die sowohl in der Tabelle Lieferanten als auch in der Tabelle Kunden vorkommen, und sortiert die Daten alphabetisch nach dem Ort:

SELECT [Firma], [Ort]
FROM [Lieferanten]

UNION SELECT [Firma], [Ort]
FROM [Kunden]
ORDER BY [Ort];

Zurück zum Anfang

Umbenennen von Feldern in einer Union-Abfrage

Die folgende Union-Abfrage benennt das Feld Firma in der Abfrageausgabe in Lieferant/Kunde um:

SELECT [Firma] AS [Lieferant/Kunde], [Ort]
FROM [Lieferanten]

UNION SELECT [Firma] AS [Lieferant/Kunde], [Ort]
FROM [Kunde];

Zurück zum Anfang

Wiedergabe von doppelten Datensätzen in einer Union-Abfrage

Die folgende Union-Abfrage verwendet die Anweisung UNION ALL, um alle Datensätze, einschließlich der doppelten Datensätze, abzurufen:

SELECT [Firma], [Ort]
FROM [Lieferanten]
UNION ALL
SELECT [Firma], [Ort]
FROM [Kunden];

Zurück zum Anfang

Weitere Informationen

Arbeiten mit SQL in Abfragen, Formularen, Berichten, Makros und Modulen

Möglichkeiten zum Zusammenführen von Daten aus mehreren Tabellen oder Abfragen in einer Abfrage


 Textfeld, das beim Drucken von Formularen und Berichten automatisch vergrößert oder verkleinert wird - Beispiele

Textfeld, das beim Drucken von Formularen und Berichten automatisch vergrößert oder verkleinert wird - Beispiele

Sie können Textfelder für jeden Datensatz in vertikaler Ausrichtung an die Größe der Daten im Feld anpassen. Dazu legen Sie für die Eigenschaften Vergrößerbar und Verkleinerbar die Einstellung Ja fest. Ein Memo-Feld kann z.B. Werte enthalten, die sehr lang sind. Sie können das Textfeld so groß machen, dass der größte Teil der Einträge in das Feld passt, und für die Eigenschaft Vergrößerbar die Einstellung Ja festlegen, damit das Textfeld beim Drucken des Formulars oder Berichts gegebenenfalls an noch längere Einträge angepasst wird. Wenn ein Feld in einigen Datensätzen keine Werte enthält, können Sie für die Eigenschaft Verkleinerbar die Einstellung Ja festlegen, wenn Sie verhindern möchten, dass Leerzeilen angezeigt werden.

Wenn ein Textfeld vergrößert oder verkleinert wird, ändert sich die vertikale Ausdehnung des gesamten Bereichs entsprechend. Aus diesem Grund sind die Position und die Höhe des Textfelds im Verhältnis zu den benachbarten Steuerelementen wichtig.

Textfeld, das an die Größe des höchsten Steuerelements in derselben Zeile angepasst wird

Wenn neben einem Textfeld ein Bezeichnungsfeld angezeigt ist, kann das Textfeld nicht mehr als bis auf die Höhe der anderen Steuerelemente in derselben Zeile verkleinert werden. Das Bezeichnungsfeld enthält immer einen Wert (seine Beschriftung), d.h. auch dann, wenn das Textfeld keinen Wert enthält. Das Textfeld wird in diesem Fall nur bis auf die Höhe des Bezeichnungsfelds verkleinert.

Vergleich von Textfeldern in der Entwurfsansicht und in einem gedruckten Bericht


 Formular

Formular

Ein Formular ist ein Microsoft Access-Datenbankobjekt, auf dem Sie Steuerelemente anordnen können, um Vorgänge auszulösen oder Daten in Felder einzugeben bzw. in Feldern anzuzeigen oder zu bearbeiten.


 Formularbereich

Formularbereich

Ein Formularbereich ist ein Bestandteil eines Formulars, d.h. ein Kopfbereich, ein Fußbereich oder ein Detailbereich.

Sie können Bereichseigenschaften einstellen, die Attribute eines Formulars sind, und das Aussehen oder Verhalten eines bestimmten Bereichs festlegen. Sie können z.B. die Eigenschaft CanGrow so einstellen, dass der jeweilige Bereich in vertikaler Richtung vergrößert wird, damit alle Daten gedruckt werden, die der Bereich enthält. Bereichseigenschaften werden in der Formularentwurfsansicht eingestellt.


 Optimieren der Abfrageleistung

Optimieren der Abfrageleistung

Es gibt mehrere Möglichkeiten, die Ausführungsgeschwindigkeit Ihrer Abfragen zu steigern. Zusätzlich zu den in den nachfolgenden Tipps genannten Möglichkeiten können Sie bestimmte Abfragen in Ihrer Datenbank mit dem Assistenten zur Leistungsanalyse analysieren. Zum Anzeigen von Informationen zur Verwendung des Assistenten zur Leistungsanalyse klicken Sie auf [image] .

  • Komprimieren Sie Ihre Datenbank. Das Komprimieren kann Abfragen beschleunigen, da die Datensätze in einer Tabelle so neu angeordnet werden, dass sie sich in benachbarten Datenbankseiten befinden und nach dem Primärschlüssel der Tabelle sortiert sind. Dies verbessert die Leistung bei sequentiellen Suchen in den Datensätzen einer Tabelle, da zum Abrufen aller gesuchten Datensätze nur die Mindestanzahl an Datenbankseiten durchsucht werden muss. Nach dem Komprimieren der Datenbank führen Sie jede Abfrage durch, um diese auf der Basis der aktualisierten Tabellenstatistiken zu kompilieren.

  • Indizieren Sie alle zum Festlegen von Kriterien für die Abfrage verwendeten Felder sowie Indexfelder auf beiden Seiten einer Verknüpfung, oder erstellen Sie eine Beziehung zwischen diesen Feldern. Wenn Sie Beziehungen erstellen, erstellt die Microsoft Jet-Datenbank-Engine einen Index im Fremdschlüssel, wenn dieser nicht bereits existiert, oder verwendet den vorhandenen Index.

    Anmerkung Die Microsoft Jet-Datenbank-Engine optimiert automatisch eine Abfrage, die eine Microsoft Access-Tabelle auf Ihrem Festplattenlaufwerk und eine ODBC-Server-Tabelle verknüpft, wenn die Microsoft Access-Tabelle klein ist und die verknüpften Felder indiziert sind. In diesem Fall verbessert Microsoft Access die Leistung dadurch, dass nur die erforderlichen Datensätze vom Server angefordert werden. Stellen Sie sicher, dass Tabellen, die Sie aus unterschiedlichen Quellen verknüpfen, in den Verknüpfungsfeldern indiziert sind.

  • Wählen Sie beim Definieren eines Feldes in einer Tabelle den kleinsten für die Daten im Feld geeigneten Datentyp. Verwenden Sie außerdem für Felder, die Sie verknüpfen, den gleichen oder einen kompatiblen Datentyp, wie z.B. AutoWert und Zahl (wenn für die Eigenschaft Feldgröße (FieldSize) die Einstellung Long Integer festgelegt ist).

  • Fügen Sie beim Erstellen einer Abfrage nur die wirklich benötigten Felder hinzu. Deaktivieren Sie für Felder, die zum Festlegen von Kriterien verwendet werden, das Kontrollkästchen Anzeigen, wenn diese Felder nicht angezeigt werden sollen.

  • Speichern Sie die SQL-Anweisung als Abfrage, wenn für die Eigenschaft Datenherkunft (RecordSource) eines Formulars oder eines Berichts eine SQL-Anweisung festgelegt wurde, und legen Sie dann den Namen der Abfrage als Einstellung für die Eigenschaft Datenherkunft fest. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Vermeiden Sie die Verwendung von berechneten Feldern in Unterabfragen. Wenn Sie zu einer Abfrage eine Abfrage, die ein berechnetes Feld enthält, hinzufügen, kann dies die Leistung in der übergeordneten Abfrage verringern. Im nachstehenden Beispiel wird die Abfrage A1 als Eingabe für Abfrage A2 verwendet:
    A1: SELECT IIF([Spalte1]="Ja","Bestellung bestätigt","Bestellung nicht bestätigt") AS X FROM Tabelle1;
A2: SELECT * FROM A1 WHERE X="Bestellung bestätigt";

Da der Wenn-Ausdruck (IIf) in A1 nicht optimiert werden kann, kann auch A2 nicht optimiert werden. Wenn ein in einer Unterabfrage verschachtelter Ausdruck nicht optimiert werden kann, kann die gesamte Abfrage nicht optimiert werden.

Erstellen Sie die Abfrage daher folgendermaßen:

A1: SELECT * FROM Tabelle1 WHERE Spalte1 = "Ja";

Wenn in der Ausgabe Ausdrücke erforderlich sind, versuchen Sie, diese in einem Steuerelement in einem Formular oder Bericht abzulegen. Sie können z.B. die vorstehende Abfrage in eine Parameterabfrage ändern, die den Benutzer auffordert, einen Wert aus Spalte1 einzugeben, und dann ein Formular oder einen Bericht auf der Abfrage basieren lassen. Im Formular oder Bericht können Sie dann einen berechneten Wert hinzufügen, der abhängig vom Wert in Spalte1 z.B. "Hallo" oder "Tschüs" zurückgibt.

Erstellen Sie die Abfrage wie folgt:

PARAMETERS [Geben Sie Ja ein, wenn Sie bestätigte Bestellungen ansehen möchten, für unbestätigte Bestellungen geben Sie Nein ein.] Text;
SELECT *
FROM MeineTabelle
WHERE Spalte1 = [Geben Sie Ja ein, wenn Sie bestätigte Bestellungen ansehen möchten, für unbestätigte Bestellungen geben Sie Nein ein.];

Geben Sie im berechneten Steuerelement im Formular oder Bericht Folgendes ein:

=IIF([Spalte1]="Ja","Bestellung bestätigt","Bestellung nicht bestätigt")

  • Legen Sie beim Gruppieren von Datensätzen nach Werten in einem verknüpften Feld für das Feld, das sich in der gleichen Tabelle befindet, wie das Feld, für das Sie Berechnungen durchführen (oder eine Aggregatfunktion ausführen) Gruppierung fest. Wenn Sie z.B. in der Beispieldatenbank Nordwind eine Abfrage erstellen, die die Werte im Feld Anzahl aus der Tabelle Bestelldetails addiert und die Ergebnisse nach Bestell-Nr gruppiert, geben Sie Gruppierung für das Feld Bestell-Nr in der Tabelle Bestelldetails an. Wenn Sie Gruppierung für das Feld Bestell-Nr in der Tabelle Bestellungen angeben, muss Microsoft Access vor dem Ausführen der Aggregatfunktion erst alle Datensätze verknüpfen. Im anderen Fall wird erst die Aggregatfunktion ausgeführt und anschließend werden nur die erforderlichen Felder verknüpft.

    Verwenden Sie Gruppierung immer in möglichst wenigen Feldern, um die Geschwindigkeit zu optimieren. Als Alternative hierzu können Sie auch in entsprechenden Fällen die Funktion ErsterWert verwenden. Zum Anzeigen weiterer Informationen zur Funktion ErsterWert klicken Sie auf [image] .

    Wenn eine Berechnungsabfrage eine Verknüpfung beinhaltet, können Sie die Datensätze auch in einer Abfrage gruppieren und diese Abfrage dann zu einer separaten Abfrage hinzufügen, die die Verknüpfung vornimmt. Dies führt in einigen Abfragen zu einer Verbesserung der Leistung.

  • Vermeiden Sie einschränkende Abfragekriterien in berechneten und nichtindizierten Feldern.

    Verwenden Sie optimierbare Kriterienausdrücke. Um Informationen zum Optimieren von Kriterien unter Verwendung der Rushmore-Technologie anzuzeigen, klicken Sie auf [image] .

  • Wenn sie Kriterien zum Begrenzen von Werten in einem Feld verwenden, das in einer Verknüpfung zwischen Tabellen mit einer 1:n-Beziehung verwendet wird, testen Sie, wann die Abfrage schneller ausgeführt wird: wenn das Kriterium auf der "1"-Seite oder auf der "n"-Seite der Verknüpfung festgelegt wird. In manchen Abfragen wird eine bessere Leistung erzielt, wenn das Kriterium nicht zur "n"-Seite sondern zur "1"-Seite der Verknüpfung hinzugefügt wird.

  • Indizieren Sie Felder, die Sie zum Sortieren verwenden.

  • Wenn Ihre Daten sich nicht häufig ändern, verwenden Sie zum Erstellen von Tabellen auf der Basis von Abfrageergebnissen eine Tabellenerstellungsabfrage. Verwenden Sie an Stelle von Abfragen die resultierenden Tabellen als Basis für Formulare, Berichte oder andere Abfragen, und stellen Sie sicher, dass Sie Indizes entsprechend der hier genannten Richtlinien hinzufügen.

  • Vermeiden Sie die Verwendung von Domänen-Aggregatfunktionen, wie z.B. DomWert, wenn Sie auf Daten aus einer Tabelle zugreifen möchten, die nicht in der Abfrage enthalten ist. Domänen-Aggregatfunktionen sind Microsoft Access-spezifisch, d.h., die Jet-Datenbank-Engine kann Abfragen, die Domänen-Aggregatfunktionn enthalten, nicht optimieren. Fügen Sie stattdessen die Tabelle zur Abfrage hinzu, auf die die Funktion zugegriffen hat, oder erstellen Sie eine Unterabfrage.

  • Verwenden Sie beim Erstellen einer Kreuztabellenabfrage möglichst immer feste Spaltenüberschriften. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Verwenden Sie in indizierten Feldern die Operatoren Zwischen...Und, In und das Gleichheitszeichen ( = ).

  • Für Mengenaktualisierungsabfragen in ODBC-Datenbanken optimieren Sie die Leistung auf dem Server. Dazu legen Sie für die Eigenschaft BeiFehlerAbbrechen die Einstellung Ja fest. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkung Zum Anzeigen von Tipps zum Optimieren der Leistung einer externen SQL-Datenbank klicken Sie auf [image] .


Ausgeblendete Eigenschaften

Im Objektmodell für Microsoft Access 2000 Visual Basic sind bestimmte Eigenschaften ausgeblendet, da deren Funktionalität durch die in der folgenden Liste aufgeführten neuen Sprachelemente ersetzt wurde. Diese Eigenschaften werden nur aus Gründen der Abwärtskompatibilität unterstützt. Für neuen Code sollten Sie die in Microsoft Access 2000 enthaltenen Ersatzfunktionen verwenden. Um verborgene Objekte im Objektkatalog anzuzeigen, klicken Sie mit der rechten Maustaste auf das Fenster Objektkatalog, und klicken Sie dann im Kontextmenü auf Ausgeblendete Elemente anzeigen.

Objekt | Verborgene Eigenschaft | Ersatz
Form | AllowEditing, DefaultEditing | AllowAdditions, AllowDeletions, AllowEdits, DataEntry
Form | AllowUpdating | RecordsetType
BoundObjectFrame, CheckBox, ComboBox, Image, Label, Line, ListBox, ObjectFrame, OptionButton, OptionGroup, Rectangle, SubForm, TextBox | BorderLineStyle | BorderStyle
Form | Dynaset | RecordsetClone
Form, Report | MaxButton, MinButton | MinMaxButtons (nur Form)
Form | ShowGrid | DatasheetGridlinesBehavior


 Überlegungen beim Verwenden einer Abfrage, die Datensätze löscht

Überlegungen beim Verwenden einer Abfrage, die Datensätze löscht

  • Wenn Sie Datensätze mit Hilfe einer Löschabfrage löschen, können Sie diese Operation nicht mehr rückgängig machen. Daher sollten Sie die Daten, die von der Abfrage zum Löschen ausgewählt werden, vor dem Ausführen der Abfrage überprüfen. Klicken Sie hierzu in der Symbolleiste auf Abfrageansicht [image] , um die Abfrage in der Datenblattansicht anzuzeigen.

  • Sie sollten jederzeit über Sicherungskopien Ihrer Daten verfügen. Wenn Sie versehentlich noch benötigte Datensätze löschen, können Sie diese mit den Sicherungskopien wiederherstellen.

  • In einigen Fällen führt das Ausführen einer Löschabfrage dazu, dass Datensätze in verknüpften Tabellen gelöscht werden, auch wenn diese nicht in die Abfrage einbezogen waren. Dies kann dann der Fall sein, wenn Ihre Abfrage nur die Tabelle auf der "1"-Seite einer 1:n-Beziehung enthält und Sie für diese Beziehung die Löschweitergabe aktiviert haben. Wenn Sie Datensätze aus dieser Tabelle löschen, werden auch Datensätze aus der Tabelle auf der "n"-Seite gelöscht. Um weitere Informationen zur Löschweitergabe anzuzeigen, klicken Sie auf [image] .

  • Wenn eine Löschabfrage mehr als eine Tabelle beinhaltet, wie z. B. eine Abfrage, die doppelte Datensätze aus einer der Tabellen löscht, muss für die Keine Duplikate-Eigenschaft der Abfrage die Einstellung Ja festgelegt werden. Zum Anzeigen weiterer Informationen zum Einstellen der Keine Duplikate-Eigenschaft klicken Sie auf [image] .


 Index

Index

Ein Index ist ein Microsoft Access-Feature, das Such- und Sortiervorgänge für eine Tabelle beschleunigt. Einen Index können Sie auf zwei Arten aus einem Feld erstellen: in der Entwurfsansicht einer Tabelle im Fenster Indizes oder dadurch, dass Sie die Eigenschaft Indiziert des Feldes auf Ja einstellen.

Anmerkung Eine Tabelle wird automatisch nach dem Feld indiziert, das als Primärschlüssel festgelegt ist. Aus einem Feld, das einen der Datentypen Memo oder OLE-Objekt hat, kann kein Index erstellt werden.


Sprachspezifische Eigenschaften und Methoden

Das Objektmodell für Microsoft Access 2000 Visual Basic enthält neue sprachspezifische Schlüsselwörter für den Einsatz bei asiatischen und von rechts nach links gerichteten Sprachen. Die Verfügbarkeit dieser sprachspezifischen Schlüsselwörter hängt von der gewählten oder installierten Sprachunterstützung ab. Weitere Informationen zu sprachspezifischen Features finden Sie unter Sprachspezifische Information.

Sprachspezifische Eigenschaften und Methoden

Die folgende Liste enthält Eigenschaften und Methoden, die nur in asiatischen oder in von rechts nach links gerichteten Sprachen zur Verfügung stehen.

Eigenschaft oder Methode | Objekt
FELineBreak | TextBox
FuriganaControl | TextBox
IMEHold/HoldKanjiConversionMode | ComboBox, ListBox, TextBox
IMEMode/KanjiConversionMode | ComboBox, Label, ListBox, TextBox
IMESentenceMode | ComboBox, Label, ListBox, TextBox
KeyboardLanguage | ComboBox, TextBox
NumeralShapes | ComboBox, Label, ListBox, TextBox
Orientation | Form
PostalAddress | TextBox
ReadingOrder | CheckBox, ComboBox, CommandButton, Label, ListBox, OptionButton, TextBox, ToggleButton
ScrollBarAlign | ComboBox, ListBox, TextBox


Methoden mit neuen Argumenten

Der folgenden Methode wurden Argumente für Microsoft Access 2000 hinzugefügt.

TransferText


 Vermeiden von Benennungskonflikten

Vermeiden von Benennungskonflikten

Nachstehend sind einige weitere Benennungskonflikte aufgeführt, die in Microsoft Access Fehler verursachen können.

Prozeduren und Variablen in Standardmodulen und Klassenmodulen

Wenn in Microsoft Access ein Standardmodul und ein Klassenmodul eine öffentliche Prozedur mit demselben Namen enthalten, bewirkt ein Verweis ohne Pfadangabe auf die Prozedur, dass immer die Prozedur im Standardmodul aufgerufen wird. Wenn Sie eine Prozedur aufrufen möchten, die sich im Klassenmodul befindet, müssen Sie die Prozedur mit dem Klassennamen näher bestimmen. Dasselbe gilt für gleichnamige Variablen in Standard- und Klassenmodulen.

Wenn z.B. das Modul eines Formulars namens Bestellungen eine Funktion namens AnzahlBestellungen enthält, können Sie die Funktion wie folgt aufrufen.

Form_Bestellungen.AnzahlBestellungen

Gleichnamige Variablen mit unterschiedlichem Gültigkeitsbereich

Wenn Sie eine Modulebenenvariable deklarieren, die denselben Namen hat wie eine Prozedurebenenvariable in einer Prozedur dieses Moduls, müssen Sie die Modulebenenvariable mit dem Namen des Moduls näher bestimmen. Dies gilt für Standardmodule und Klassenmodule.

Z.B. könnten Sie in einem Standardmodul namens Wichtige Funktionen auf Modulebene und auf Prozedurebene die Variable varBereich deklarieren. Sie können dann auf die Modulebenenvariable verweisen, indem Sie diese wie folgt näher bestimmen: [Wichtige Funktionen].varBereich.

Am besten vermeiden Sie es, im selben Modul gleichnamige Variablen zu verwenden.

Konstanten-, Variablen- und Prozedurnamen in Klassennmodulen

Es ist nicht möglich, einer Konstanten, Variablen oder Prozedur in einem Formular- oder Berichtsmodul einen Namen zu geben, der mit dem Namen einer Methode oder Eigenschaft des Formulars oder Berichts identisch ist. Wenn Sie z.B. eine Sub-Prozedur namens Name erstellen, meldet Microsoft Access einen Kompilierzeitfehler, da das Formular bereits die Eigenschaft Name hat.


Neue Objekte in Microsoft Access 97

Die folgende Liste enthält Objekte, die Visual Basic in Microsoft Access 97 hinzugefügt wurden.

Objekte | Beschreibung
Assistant | Funktionalität für den neuen Office-Assistenten
Page, Pages | Funktionalität für das neue Registersteuerelement


Neue Ereignisse in Microsoft Access 97

Die folgende Liste enthält Ereignisse, die Visual Basic in Microsoft Access 97 hinzugefügt wurden.


Neue Methoden in Microsoft Access 97

Die folgende Liste enthält Methoden, die Microsoft Access 97 hinzugefügt wurden.

Add (Pages-Auflistung)

AddFromFile (Module-Objekt)

AddFromFile (References-Auflistung)

AddFromGUID

AddFromString

AddToFavorites

CreateEventProc

DefaultControl

DeleteLines

InsertLines

 Find

Follow

FollowHyperlink

HyperlinkPart

RefreshDatabaseWindow

Remove (Pages-Auflistung)

Remove (References-Auflistung)

ReplaceLine

RunCommand


Neue Methoden (nach Objekt)

Die folgende Liste enthält Methoden (nach Objektname sortiert), die vorhandenen Objekten in Microsoft Access 2000 hinzugefügt wurden.

Objekt | Methode
AccessObjectProperties | Add Remove
Application | CreateAccessProject CreateDataAccessPage GetHiddenAttribute NewAccessProject OpenAccessProject SetHiddenAttribute
Code Project, Current Project | CloseConnection OpenConnection
DataAccessPage | ApplyTheme
DoCmd | AddMenu OpenDataAccessPage OpenDiagram OpenStoredProcedure OpenView
FormatCondition | Delete Modify
FormatConditions | Add Delete
Hyperlink | CreateNewDocument
WebOptions | UseDefaultFolderSuffix


Neue Eigenschaften in Microsoft Access 97

Die folgende Liste enthält Eigenschaften, die Microsoft Access 97 hinzugefügt wurden.

A-G

CountOfDeclarationLines

CountOfLines

DatasheetBackColor

 DatasheetForeColor

FailOnError

H-P

HasModule

Hyperlink

HyperlinkAddress

HyperlinkSubAddress

IsVisible

Kind

Lines

Major

MDE

 Minor

MousePointer

MultiRow

PageIndex

ProcBodyLine

ProcCountLines

ProcOfLine

ProcStartLine

ProjectName

Q-Z

Style

TabFixedHeight

TabFixedWidth

 Toolbar

UseTransaction


 Neue Eigenschaften (nach Objekt)

Neue Eigenschaften (nach Objekt)

Die folgende Liste enthält Eigenschaften (nach Objektname sortiert), die vorhandenen Objekten in Microsoft Access 2000 hinzugefügt wurden.

Objekt | Eigenschaft
AccessObject | FullName IsLoaded Properties Property (AccessObjectProperties-Auflistung) Type (AccessObject-Objekt)
Application | AnswerWizard CodeData CodeProject COMAddIns CurrentData CurrentProject DataAccessPages DefaultWebOptions FeatureInstall FileSearch LanguageSettings ProductCode Properties Property (Properties-Auflistung) VBE
CodeData, CurrentData | AllDatabaseDiagrams AllQueries AllReports AllStoredProcedures AllTables AllViews
CodeProject, CurrentProject | AllDataAccessPages AllForms AllMacros AllModules AllReports BaseConnectionString Connection FullName IsConnected ProjectType Properties Property (AccessObjectProperties-Auflistung)
DataAccessPage | ConnectionString Document WebOptions
DefaultWebOptions | AlwaysSaveInDefaultEncoding CheckIfOfficeHTMLEditor DownloadComponents Encoding FolderSuffix FollowedHyperlinkColor HyperlinkColor LocationOfComponents OrganizeInFolder UnderlineHyperlinks UseLongFileNames
Form | InputParameters MaxRecButton Recordset ResyncCommand ServerFilter ServerFilterByForm UniqueTable
FormatCondition | Enabled (FormatCondition-Objekt) Expression1 Expression2 Operator (FormatCondition-Objekt) Type (FormatCondition-Objekt)
Hyperlink | Address EmailSubject ScreenTip SubAddress TextToDisplay
Screen | ActiveDataAccessPage
WebOptions | DownloadComponents Encoding FolderSuffix LocationOfComponents OrganizeInFolder UseLongFileNames

Microsoft Office-Eigenschaften

Um die Liste der neuen Eigenschaften in der Microsoft Office 9.0-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Office Visual Basic-Referenz.

Wenn Sie die von Microsoft Office bereitgestellten Objekte verwenden möchten, richten Sie bei geöffnetem Visual Basic-Editor einen Verweis auf die Microsoft Office 9.0-Objektbibliothek ein, indem Sie im Menü Extras auf Verweise klicken und das entsprechende Kontrollkästchen aktivieren.

Microsoft Visual Basic-Editor-Eigenschaften

Um die Liste der neuen Eigenschaften in der Microsoft Visual Basic for Applications Extensibility 5.3-Objektbibliothek anzuzeigen, öffnen Sie in der Hilfe unter Inhalt die Microsoft Visual Basic-Referenz.

Wenn Sie die vom Microsoft Visual Basic-Editor bereitgestellten Objekte verwenden möchten, richten Sie einen Verweis auf die Microsoft Visual Basic for Applications Extensibility 5.3-Objektbibliothek ein. Zu diesem Zweck öffnen Sie den Visual Basic-Editor, klicken im Menü Extras auf Verweise und aktivieren dann das entsprechende Kontrollkästchen.


 Automatisierung

Automatisierung

In Microsoft Access können Sie ein Automatisierungs-Objekt (früher unter der Bezeichnung "OLE-Automatisierung" bekannt) erstellen, indem Sie mit dem Schlüsselwort New eine Objektvariable deklarieren, oder indem Sie die Funktion CreateObject oder GetObject verwenden.

Microsoft Access unterstützt Automatisierung auf zwei Arten. Microsoft Access ist eine COM-Komponente. D.h., dass Sie aus Microsoft Access heraus auf Objekte, die von anderen Anwendungen bereitgestellt werden, zugreifen und mit diesen Objekten arbeiten können. Und das bedeutet auch, dass Sie aus einer anderen Anwendung, die Automatisierung (früher unter der Bezeichnung "OLE-Automatisierung" bekannt) unterstützt, auf Microsoft Access-Objekte zugreifen und mit diesen arbeiten können.

Anmerkung Bevor Sie Microsoft Access oder eine andere Anwendung als Komponente verwenden können, müssen Sie einen Verweis auf die Objektbibliothek der Anwendung einstellen. Weitere Informationen, wie Verweise aktiviert werden, finden Sie in der Hilfe unter "Aktivieren von Referenzen".

Wenn Sie Microsoft Access z.B. als Komponente verwenden, können Sie mit Microsoft Excel-Objekten arbeiten. Sie erstellen dazu in Microsoft Access ein neues Microsoft Excel-Objekt, auf das Sie mit einer Objektvariablen zeigen. Die Eigenschaften des Objekts sowie dessen Methoden können Sie dann so einstellen bzw. so aufrufen, wie Sie das bei jedem anderen Objekt tun können. Eine neue Instanz der Microsoft Excel-Klasse Application können Sie wie folgt erstellen.

Dim appXL As New Excel.Application
' Oder
Dim appXL As Excel.Application
Set appXL = CreateObject("Excel.Application")

Wenn Microsoft Excel bereits läuft, können Sie mit der Funktion GetObject eine Objektvariable so einstellen, dass sie auf die aktuelle Instanz der Microsoft Excel-Klasse Application zeigt.

Dim appXL As Excel.Application
Set appXL = GetObject( , "Excel.Application")

Weitere Informationen zu dem Objekt Application finden Sie im Hilfeindex unter "Application-Objekt".

Wenn Sie Microsoft Access als Komponente verwenden, können Sie aus anderen Anwendungen heraus auf Microsoft Access-Objekte zugreifen. Z.B. können Sie aus Microsoft Excel heraus ein Microsoft Access-Formular öffnen und dazu verwenden, Daten anzuzeigen, die in einer Microsoft Excel-Arbeitsmappe stehen. Das folgende Beispiel erstellt aus Microsoft Excel heraus ein neues Microsoft Access-Objekt.

Dim appAccess As New Access.Application

Wenn Microsoft Access bereits läuft, verwenden Sie die Funktion GetObject, um mit einer Objektvariablen auf die aktuelle Instanz der Microsoft Access-Klasse Application zu zeigen.


 Öffnen einer in einer früheren Version erstellten Access-Datenbank, ohne diese zu konvertieren

Öffnen einer in einer früheren Version erstellten Access-Datenbank, ohne diese zu konvertieren

Dieses Thema enthält Referenzinformationen über:

Wann empfiehlt es sich, eine Access-Datenbank zu aktivieren?

Aufwärtskompatibilität

Tabellenstruktur

Symbolleisten und Menüleisten

Aktivieren einer gesicherten Access-Datenbank

Größe einer aktivierten Access-Datenbank

Codekompatibilität

Wann empfiehlt sich eine Aktivierung?

Möglicherweise möchten Sie eine Microsoft Access-Datenbank in einer Mehrbenutzerumgebung aktivieren, in der nicht alle Benutzer gleichzeitig auf Microsoft Access 2000 umstellen können. In dieser Situation muss eine Datenbank gleichzeitig in verschiedenen Versionen von Microsoft Access verwendet werden, und Benutzer, die bereits auf Microsoft Access 2000 umgestellt haben, können eine Datenbank in einem Format einer früheren Version aktivieren. Wenn ein Microsoft Access 2000-Benutzer die Datenbank aktiviert, bleibt das Originalformat erhalten, so dass Benutzer früherer Versionen von Microsoft Access diese weiterhin verwenden können. Wenn z.B. eine gemeinsam genutzte Datenbank in Microsoft Access, Version 2.0, erstellt worden ist, kann sie in Microsoft Access, Version 2.0, verwendet und in Microsoft Access 2000 aktiviert werden.

Zurück zum Anfang

Aufwärtskompatibilität

Sie können eine Microsoft Access-Datenbank, Version 2.0, eine Access 95-Datenbank oder eine Access 97-Datenbank aktivieren, so dass Sie sie in Microsoft Access 2000 verwenden können. Wenn Sie zum Aktivieren einer Access-Datenbank einer früheren Version Microsoft Access 2000 verwenden, können Sie Datenbankobjekte anzeigen und Datensätze hinzufügen, löschen oder ändern. Sie können jedoch nicht den Entwurf von Objekten ändern. Zum Ändern des Entwurfs vorhandener Objekte oder zum Hinzufügen neuer Objekte müssen Sie die Datenbank in der Version von Microsoft Access öffnen, in der sie erstellt worden ist. Sie können eine Microsoft Access 2000-Datenbank nicht in einer früheren Version von Microsoft Access öffnen.

Anstatt eine Datenbank zu aktivieren, können Sie auch Front-End/Back-End-Anwendungen in Microsoft Access, Version 2.0, Access 95, Access 97 und Access 2000 gemeinsam nutzen, vorausgesetzt, dass die Back-End-Datenbank in der ältesten der verwendeten Microsoft Access-Versionen verwaltet wird. Um weitere Informationen zur Verwendung einer Microsoft Access-Datenbank in mehreren Versionen von Microsoft Access anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Tabellenstruktur

In einer Access-Datenbank einer früheren Version können Sie keine Access 2000-Tabelle verknüpfen oder importieren. Sie können jedoch eine Access 2000-Tabelle in eine Access-Datenbank einer früheren Version exportieren. Außerdem können Sie Daten aus einer Access 2000-Tabelle ausschneiden oder kopieren und in eine Tabelle einer früheren Version von Microsoft Access einfügen.

Zurück zum Anfang

Neues Symbol- und Menüleistenformat

Microsoft Access 97 und höher unterstützt eine neue Art von Symbol- und Menüleisten. Wenn Sie eine Microsoft Access 95-Datenbank in Microsoft Access 2000 aktivieren, werden benutzerdefinierte Symbolleisten in Symbolleisten im neuen Format konvertiert, die Konvertierung wird jedoch nicht gespeichert. Benutzerdefinierte Menüleisten werden als Menüleisten im neuen Format interpretiert, die Menüleistenmakros werden jedoch nicht konvertiert, aber weiterhin unterstützt.

Zurück zum Anfang

Aktivieren einer gesicherten Access-Datenbank

Falls Ihre Access-Datenbank gesichert ist, können Sie sicherstellen, dass ihre Datensicherheit erhalten bleibt, indem Sie die Arbeitsgruppeninformationsdatei in Access 2000 erneut einrichten. Wenn Sie die Arbeitsgruppeninformationsdatei nicht erneut einrichten können, können Sie den Arbeitsgruppen-Administrator verwenden, um die Arbeitsgruppeninformationsdatei einer früheren Version der gesicherten Datenbank einzubinden; es wird jedoch empfohlen, dass Sie die Arbeitsgruppeninformationsdatei in Access 2000 konvertieren, bevor Sie sie einbinden. So lange Sie die Datenbank mit ihren ursprünglichen Arbeitsgruppeninformationen verwenden, bleibt ihre gesamte Datensicherheit erhalten, mit Ausnahme der Berechtigungen für die Module. In Access 2000 können Sie Code von Visual Basic für Applikationen (VBA) mit einem Kennwort schützen. Weitere Informationen zu Aktivieren einer gesicherten Datenbank anzeigen.

Zurück zum Anfang

Größe einer aktivierten Access-Datenbank

Ihre Access-Datenbank kann beim Aktivieren größer werden. Wenn Sie eine Datenbank bereits in einer früheren Version von Microsoft Access aktiviert haben, und wenn Sie sie dann in Access 2000 erneut aktivieren, wird die Größe des Visual Basic-Projekts noch weiter zunehmen. In sehr seltenen Fällen, wenn Sie eine Microsoft Access-Datenbank der Version 2.0 in Microsoft Access 95, anschließend in Microsoft Access 97 und schließlich erneut in Microsoft Access 2000 aktiviert haben, muss das Visual Basic-Projekt Informationen im Format jeder dieser Versionen speichern.

Zurück zum Anfang

Codekompatibilität

Microsoft Access 2000 unterstützt nicht die DAO 2.5/3.x-Kompatibilitätsbibliothek. Falls Sie versuchen, eine Access-Datenbank zu aktivieren, in der der Code ältere Versionen von DAO-Objekten, -Methoden und -Eigenschaften enthält, für die die DAO 2.5/3.x-Kompatibilitätsbibliothek benötigt wird, wird eine Meldung angezeigt, dass beim Aktivieren der Datenbank Kompilierfehler aufgetreten sind. Aktualisieren Sie den Code, bevor Sie die Access-Datenbank aktivieren, damit die DAO 2.5/3.x-Kompatibilitätsbibliothek nicht benötigt wird. Um weitere Informationen zur Kompatibilität von Visual Basic in früheren Versionen von Microsoft Access und Visual Basic in Microsoft Access 2000 anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Um Informationen zum Aktivieren einer Access-Datenbank anzuzeigen, klicken Sie auf [image] .


 Optimieren der Leistung von Formularen und Unterformularen

Optimieren der Leistung von Formularen und Unterformularen

Es gibt verschiedene Möglichkeiten, Ihre Formulare schneller ausführen zu lassen. Wenn Sie eine Microsoft Access-Datenbank verwenden, können Sie zusätzlich zu den nachfolgenden Tipps den Leistungsanalyse-Assistenten verwenden, um bestimmte Formulare in Ihrer Datenbank zu analysieren. Zum Anzeigen weiterer Informationen zum Verwenden des Leistungsanalyse-Assistenten klicken Sie auf [image] .

Leistungstips

  • Vermeiden Sie überlappend angeordnete Steuerelemente.

  • Verwenden Sie Bitmaps und andere Grafikobjekte so selten wie möglich.

  • Konvertieren Sie Objektfelder, die Grafiken anzeigen, in Bild-Steuerelemente.

  • Verwenden Sie schwarzweiße an Stelle von farbigen Bitmaps.

  • Schließen Sie Formulare, die nicht benötigt werden.

  • Wenn die zugrunde liegende Datenherkunft viele Datensätze enthält und Sie das Formular hauptsächlich zum Eingeben neuer Datensätze verwenden, stellen Sie die Eigenschaft DatenEingeben des Formulars auf Ja ein, so dass das Formular mit einem leeren Datensatz geöffnet wird. Wenn Sie ein Formular öffnen und dabei alle Datensätze anzeigen, muss Microsoft Access in jedem Datensatz lesen, bevor der leere Datensatz am Ende der Datensatzgruppe angezeigt werden kann.

  • Sortieren Sie die Datensätze in einer zugrunde liegenden Abfrage nur dann, wenn die Sortierreihenfolge von Bedeutung ist, insbesondere in Abfragen, die auf mehreren Tabellen basieren.

  • Basieren Sie Unterformulare auf Abfragen anstatt auf Tabellen oder SQL-Anweisungen, und fügen Sie nur die Felder aus der Datenherkunft hinzu, die Sie unbedingt benötigen. Zusätzliche Felder können die Leistung des Unterformulars verringern.

  • Indizieren Sie alle Felder in dem Unterformular, die mit dem Hauptformular verknüpft sind.

  • Indizieren Sie alle Felder des Unterformulars, die für Kriterien verwendet werden.

  • Stellen Sie die Eigenschaften BearbeitenZulassen, AnfügenZulassen und LöschenZulassen des Unterformulars auf Nein ein, wenn die Datensätze in dem Unterformular nicht bearbeitet werden, oder stellen Sie die Eigenschaft Datensatzgruppentyp auf Snapshot ein.

  • Entfernen Sie nicht benötigten Code aus Formularen, indem Sie die Formulareigenschaft EnthältModul auf Nein einstellen. Diese Eigenschaft gibt an, ob ein Formular ein Formularmodul besitzt. Ein Formular ohne Formularmodul lässt sich schneller laden und benötigt weniger Speicherplatz. Wenn weder das Formular noch die Steuerelemente des Formulars Ereignisprozeduren verwenden, benötigt das Formular kein Formularmodul. Wenn Ihre Anwendung z.B. ein Übersichtsformular ausschließlich dazu verwendet wird, um zu anderen Formularen zu wechseln, anstatt Befehlsschaltflächen mit Ereignisprozeduren zu nutzen, können Sie Befehlsschaltflächen mit Makros oder Hyperlinks verwenden. Sie können in einem Formular, das kein Formularmodul besitzt, trotzdem Code verwenden, indem Sie Funktionen aus einem Standardmodul mit Hilfe eines Ausdrucks aufrufen. (Sub-Prozeduren können nicht verwendet werden, da sie nicht über einen Ausdruck aufgerufen werden können.) Definieren Sie hierzu eine Funktion in einem Standardmodul, und rufen Sie die Funktion dann über eine Ereigniseigenschaft des Formulars oder Steuerelements auf. Um z.B. mit Hilfe einer Befehlsschaltfläche eine Funktion aufzurufen, die ein Formular öffnet, weisen Sie der Eigenschaft BeimKlicken der Befehlsschaltfläche einen Ausdruck, wie z.B. =OpenDataEntry(), zu.

    Anmerkung Wenn Sie sich entschließen, den Code sämtlicher Ereignisprozeduren eines Formulars zu löschen, müssen Sie die Eigenschaft EnthältModul auf Nein einstellen, um das Formularmodul vollständig zu entfernen.


 Einfache und komplexe optimierbare Ausdrücke und Rushmore-Optimierung

Einfache und komplexe optimierbare Ausdrücke und Rushmore-Optimierung

Microsoft Access kann einfache oder komplexe Ausdrücke in der Zeile Kriterien des Entwurfsbereichs für Abfragen oder in einer WHERE-Klausel in einer SQL-SELECT-Anweisung optimieren. Für bestimmte Arten komplexer Ausdrücke kann Microsoft Access Rushmore verwenden. Dabei handelt es sich um eine Datenzugriffstechnologie, mit der die Microsoft Jet-Datenbank-Engine einen höheren Optimierungsgrad erzielt.

Einfache optimierbare Ausdrücke

Ein einfacher optimierbarer Ausdruck kann ein vollständiger Ausdruck oder ein Teil eines Ausdrucks sein. Die folgenden Formen sind möglich:

Indiziertes Feld Vergleichsoperator Ausdruck

[Bestelldatum]=#09/15/96#

oder

Ausdruck Vergleichsoperator Indiziertes Feld

#11/1/96#<[Einstellungsdatum]

In einem einfachen optimierbaren Ausdruck:

  • Indiziertes Feld kann entweder ein Feld mit einem eigenen Index oder das erste Feld in einem zusammengesetzten Index sein.

  • Vergleichsoperator muss einer der folgenden Operatoren sein: <, >, =, <=, >=, <>, Zwischen…Und, Wie, In.

  • Ausdruck kann ein beliebiger gültiger Ausdruck, einschließlich Konstanten, Funktionen und Feldern aus anderen Tabellen sein.

Zum Anzeigen von Beispielen für einfache optimierbare Ausdrücke klicken Sie auf [image] .

Komplexe Ausdrücke

Ein komplexer Ausdruck wird durch Kombinieren von zwei einfachen Ausdrücken mit dem Und-Operator oder dem Oder-Operator erstellt. Ein komplexer Ausdruck kann folgendermaßen aussehen:

Einfacher Ausdruck Und Einfacher Ausdruck

oder

Einfacher Ausdruck Oder Einfacher Ausdruck

Ein komplexer Ausdruck ist ganz oder teilweise optimierbar, abhängig davon, ob beide einfachen Ausdrücke optimierbar sind und davon, welcher Operator zum Kombinieren der beiden verwendet wurde. Ein komplexer Ausdruck kann mit Rushmore-Technologie optimiert werden, wenn alle drei der folgenden Bedingungen zutreffen:

  • Der Ausdruck verwendet zum Verbinden der beiden Kriterien den Und-Operator oder den Oder-Operator.

  • Beide Kriterien bestehen aus einfachen optimierbaren Ausdrücken.

  • Beide Ausdrücke enthalten indizierte Felder. Die Felder können einzeln indiziert oder Teil eines zusammengesetzten Index sein.

Anmerkung Sie können zusammengesetzte Indizes optimieren, wenn Sie die indizierten Felder in der Reihenfolge abfragen, in der sie im Fenster Indizes aufgeführt sind, beginnend beim ersten indizierten Feld über die benachbarten Felder (bis zu maximal 10 Felder). Wenn Sie z. B. einen zusammengesetzten Index haben, der die Felder Nachname und Vorname enthält, können Sie eine Abfrage über Nachname oder über Nachname und Vorname, nicht jedoch über Vorname optimieren.

Die folgende Tabelle kennzeichnet den Optimierungsgrad für unterschiedliche Kombinationen einfacher Ausdrücke in Abfragekriterien.

Ausdruck | Operator | Ausdruck | Abfrageergebnis
Optimierbar | Und | Optimierbar | Vollständig optimierbar (unter Verwendung von Rushmore)
Optimierbar | Oder | Optimierbar | Vollständig optimierbar (unter Verwendung von Rushmore)
Optimierbar | Und | Nicht optimierbar | Teilweise optimierbar (ohne Rushmore)
Optimierbar | Oder | Nicht optimierbar | Nicht optimierbar
Nicht optimierbar | Und | Nicht optimierbar | Nicht optimierbar
Nicht optimierbar | Oder | Nicht optimierbar | Nicht optimierbar
-- | Nicht | Optimierbar | Nicht optimierbar
-- | Nicht | Nicht optimierbar | Nicht optimierbar

Sie können zum Gruppieren einfacher Ausdrücke auch Klammern verwenden. Die voranstehenden Regeln gelten auch für kombinierte Ausdrücke, die mit Klammern zusammengefasst sind.

Sobald Sie einfache optimierbare Ausdrück zu komplexen Ausdrücken zusammengefasst haben, können diese komplexen Ausdrücke wieder zu noch komplexeren Ausdrücken zusammengefasst werden, die ebenfalls nach den oben stehenden Regeln optimiert werden können.

Zum Anzeigen von Beispielen zu komplexen optimierbaren Ausdrücken klicken Sie auf [image] .

Anmerkungen

  • Die Count-Funktion ist besonders optimiert für Abfragen, die Rushmore-Technolgie verwenden. Klicken Sie auf [image] .

    , wenn sie weitere Informationen zur Count-Funktion wünschen.
  • Rushmore-Abfragen funktionieren zusammen mit Microsoft Access-Tabellen, sowie mit Microsoft FoxPro- und dBASE-Tabellen (.DBF-Dateien). Sie können Rushmore nicht zusammen mit ODBC-Datenquellen verwenden, da Microsoft Access diese Abfragen nicht lokal verarbeitet sondern an die ODBC-Datenquelle sendet.


 Reihenfolge der Ereignisse für Steuerelemente in Formularen

Reihenfolge der Ereignisse für Steuerelemente in Formularen

Ereignisse treten für Steuerelemente in Formularen ein, wenn Sie den Fokus zu einem Steuerelement bewegen, und wenn Sie in einem Steuerelement Daten ändern und aktualisieren.

Bewegen des Fokus zu einem Steuerelement

Wenn Sie den Fokus zu einem Steuerelement in einem Formular bewegen (indem Sie z. B. ein Formular öffnen, das ein oder mehrere aktive Steuerelemente enthält, oder indem Sie zu einem anderen Steuerelement auf diesem Formular gehen), treten die Enter- und GotFocus-Ereignisse in folgender Reihenfolge ein:

Enter Þ GotFocus

Wenn Sie ein Formular öffnen, treten diese Ereignisse nach den Ereignissen auf, die dem Öffnen des Formulars zugeordnet sind (wie z.B. Open, Activate und Current), wobei die folgende Reihenfolge gilt:

(Formular) Open Þ (Formular) Activate Þ (Formular) Current Þ (Steuerelement) Enter Þ (Steuerelement) GotFocus

Wenn der Fokus ein Steuerelement in einem Formular verlässt (wenn Sie z. B. ein Formular schließen, das ein oder mehrere aktive Steuerelemente enthält, oder zu einem anderen Steuerelement auf demselben Formular gehen), treten die Ereignisse Exit und LostFocus in folgender Reihenfolge ein:

Exit Þ LostFocus

Wenn Sie ein Formular schließen, treten die Ereignisse Exit und LostFocus vor den Ereignissen ein, die dem Schließen des Formulars zugeordnet sind (wie z.B. Unload, Deactivate und Close), wobei die folgende Reihenfolge gilt:

(Steuerelement) Exit Þ (Steuerelement) LostFocus Þ (Formular) Unload Þ (Formular) Deactivate Þ (Formular) Close

Ändern und Aktualisieren von Daten in einem Steuerelement

Wenn Sie in einem Steuerelement auf einem Formular Daten eingeben oder ändern und den Fokus dann zu einem anderen Steuerelement bewegen, treten die Ereignisse BeforeUpdate und AfterUpdate ein:

BeforeUpdate Þ AfterUpdate

Die Ereignisse Exit und LostFocus für das geänderte Steuerelement treten nach den Ereignissen BeforeUpdate und AfterUpdate ein:

BeforeUpdate Þ AfterUpdate Þ Exit Þ LostFocus

Wenn Sie den Text in einem Textfeld oder im Textfeldteil eines Kombinationsfelds ändern, tritt das Ereignis Change ein. Es tritt immer dann ein, wenn sich der Inhalt des Steuerelements ändert, und zwar jeweils bevor Sie zu einem anderen Steuerelement oder Datensatz gehen (und somit bevor die Ereignisse BeforeUpdate und AfterUpdate eintreten). Die folgende Sequenz von Ereignissen tritt für jede Taste ein, die Sie in einem Textfeld oder im Textfeldteil eines Kombinationsfelds drücken:

KeyDown Þ KeyPress Þ Change Þ KeyUp

Das Ereignis NotInList tritt ein, wenn Sie in ein Kombinationsfeld einen Wert eingeben, der nicht in der Kombinationsfeldliste steht, und danach versuchen, zu einem anderen Steuerelement oder Datensatz zu gehen. Es tritt nach den Tastaturereignissen und dem Ereignis Change für das Kombinationsfeld ein, jedoch vor sonstigen Steuerelement- oder Formularereignissen. Ist die Eigenschaft LmitToList des Kombinationsfelds auf Ja eingestellt, tritt unmittelbar nach dem Ereignis NotInList das Ereignis Error für das Formular ein:

KeyDown Þ KeyPress Þ Change Þ KeyUp Þ NotInList Þ Error

Zum Anzeigen weiterer Informationen zu Ereignissen klicken Sie auf [image] .


 Ereignisreihenfolge für Formulare und Unterformulare

Ereignisreihenfolge für Formulare und Unterformulare

Ereignisse treten für ein Formular ein, wenn Sie ein Formular öffnen oder schließen, sich zwischen Formularen bewegen oder mit Daten in einem Formular arbeiten.

Öffnen und Schließen von Formularen

Wenn Sie ein Formular öffnen, tritt für das Formular die folgende Sequenz von Ereignissen ein:

Open Þ Load Þ Resize Þ Activate Þ Current

Wenn sich keine aktiven Steuerelemente in dem Formular befinden, tritt das GotFocus-Ereignis für das Formular ebenfalls ein, und zwar nach dem Activate-Ereignis und vor dem Current-Ereignis.

Wenn Sie ein Formular schließen, tritt für das Formular die folgende Sequenz von Ereignissen ein:

Unload Þ Deactivate Þ Close

Wenn sich keine aktiven Steuerelemente in dem Formular befinden, tritt das LostFocus-Ereignis für das Formular ebenfalls ein, und zwar nach dem Unload-Ereignis und vor dem Deactivate-Ereignis.

Bewegen zwischen Formularen

Wenn Sie zwischen zwei geöffneten Formularen wechseln, tritt für das erste Formular das Deactivate-Ereignis und für das zweite das Activate-Ereignis ein:

Deactivate (Formular 1) Þ Activate (Formular 2)

Das Deactivate-Ereignis für ein Formular tritt ebenfalls ein, wenn Sie von dem Formular zu einem anderen Fenster in Microsoft Access wechseln. Das Deactivate-Ereignis tritt jedoch nicht ein, wenn Sie zu einem Dialogfeld, zu einem Formular, dessen PopUp-Eigenschaft auf Ja eingestellt ist, oder zu einem Fenster in einer anderen Anwendung wechseln.

Anmerkung Ein Open-Ereignis tritt nicht ein, wenn Sie sich zu einem bereits geöffneten Formular bewegen, selbst wenn Sie sich zu dem Formular bewegt haben, indem Sie eine OpenForm-Aktion ausgeführt haben.

Arbeiten mit Daten in einem Formular

Formular- und Steuerelementereignisse treten ein, wenn Sie sich zwischen Datensätzen in dem Formular bewegen und Daten ändern. So tritt beispielsweise die folgende Sequenz von Ereignissen ein, wenn Sie ein Formular erstmals öffnen:

(Formular) Open Þ (Formular) Load Þ (Formular) Resize Þ (Formular) Activate Þ (Formular) Current Þ (Steuerelement) Enter Þ (Steuerelement) GotFocus

Wenn Sie ein Formular schließen, tritt in ähnlicher Weise die folgende Sequenz von Ereignissen ein:

(Steuerelement) Exit Þ (Steuerelement) LostFocus Þ (Formular) Unload Þ (Formular) Deactivate Þ (Formular) Close

Wenn Sie Daten in einem Steuerelement geändert haben, treten sowowhl für das Steuerelement als auch für das Formular die BeforeUpdate- und AfterUpdate-Ereignisse vor dem Exit-Ereignis für das Steuerelement ein. Um weitere Informationen über die Ereignisreihenfolge für Steuerelemente in Formularen zu erhalten, klicken Sie auf [image] .

Arbeiten mit Unterformularen

Wenn Sie ein Formular öffnen, das ein Unterformular enthält, werden das Unterformular und seine Datensätze vor dem Hauptformular geladen. Daher treten die Ereignisse für das Unterformular und seine Steuerelemente (z. B. Open, Current, Enter und GotFocus) vor den Ereignissen für das Formular ein. Für Unterformulare tritt jedoch kein Activate-Ereignis ein, so dass das Öffnen eines Hauptformulars nur für das Hauptformular ein Activate-Ereignis auslöst.

Wenn Sie ein Formular schließen, das ein Unterformular enthält, werden in ähnlicher Weise das Unterformular und seine Datensätze nach dem Formular geunloadet. Für Unterformulare tritt kein Deactivate-Ereignis ein, so dass das Schließen eines Hauptformulars nur für das Hauptformular ein Deactivate-Ereignis auslöst. Die Ereignisse für die Steuerelemente, das Formular und das Unterformular treten in der folgenden Reihenfolge ein:

  1. Ereignisse für die Steuerelemente des Unterformulars (z. B. Exit und LostFocus)

  2. Ereignisse für die Steuerelemente des Formulars (einschließlich des Unterformular-Steuerelements)

  3. Ereignisse für das Formular (z. B. Deactivate und Close)

  4. Ereignisse für das Unterformular

Um weitere Informationen über Ereignisse anzuzeigen, klicken Sie auf [image] .


 Reihenfolge der Ereignisse für Tastenanschläge und Mausklicks

Reihenfolge der Ereignisse für Tastenanschläge und Mausklicks

Tastaturereignisse treten für Formulare und Steuerelemente ein, wenn Sie Tasten drücken oder Tastenanschläge senden, solange das Formular oder Steuerelement den Fokus hat. Mausereignisse treten für Formulare, Formularbereiche und Steuerelemente auf Formularen ein, wenn Sie die Maustasten drücken, solange sich der Mauszeiger auf einem Formular, Bereich oder Steuerelement befindet, oder wenn Sie den Mauszeiger über ein Formular, einen Bereich oder ein Steuerelement bewegen.

Tastaturereignisse

Wenn Sie eine Taste drücken und wieder loslassen, solange der Fokus auf einem Steuerelement des Formulars liegt (oder Sie zum Senden eines Tastenanschlags die Aktion Tastaturbefehle oder die Anweisung SendKeys verwenden), tritt die folgende Sequenz von Ereignissen ein:

KeyDown Þ KeyPress Þ KeyUp

Wenn Sie eine Taste drücken und wieder loslassen oder einen Tastenanschlag aus dem ANSI-Zeichensatz senden, treten die Ereignisse KeyDown, KeyPress und KeyUp alle ein. Wenn Sie eine Taste drücken und gedrückt halten, die dem ANSI zugeordnet ist, treten die Ereignisse KeyDown und KeyPress solange wiederholt abwechselnd ein (KeyDown, KeyPress, KeyDown, KeyPress usw.), bis Sie die Taste wieder loslassen; danach tritt dann das Ereignis KeyUp ein. Zum Anzeigen einer Liste der Zeichen aus dem ANSI-Zeichensatz klicken Sie auf [image] und auf [image] .

Wenn Sie eine Taste drücken und wieder loslassen, die nicht dem ANSI-Zeichensatz zugeordnet ist, treten die KeyDown- und KeyUp-Ereignisse ein. Wenn Sie eine Taste drücken und gedrückt halten, die nicht dem ANSI-Zeichensatz zugeordnet ist, tritt das KeyDown-Ereignis solange wiederholt auf, bis Sie die Taste wieder loslassen; danach tritt dann das KeyUp-Ereignis ein.

Wenn das Drücken einer Taste ein anderes Ereignis für ein Steuerelement auslöst, tritt dieses andere Ereignis nach dem Ereignis KeyPress, jedoch vor dem Ereignis KeyUp ein. Ändert ein Tastenanschlag z.B. den Text in einem Textfeld, wodurch das Ereignis Change ausgelöst wird, tritt die folgende Sequenz von Ereignissen ein:

KeyDown Þ KeyPress Þ Change Þ KeyUp

Bewirkt ein Tastenanschlag eine Verschiebung des Fokus von einem Steuerelement zu einem anderen, tritt für das erste Steuerelement das KeyUp-Ereignis ein, für das zweite Steuerelement treten die KeyPress- und KeyUp-Ereignisse ein. Wenn Sie z. B. in einem Steuerelement Daten ändern und danach die Tabulatortaste drücken, um zum nächsten Steuerelement zu gehen, tritt die folgende Sequenz von Ereignissen ein:

  • Erstes Steuerelement:

    KeyUp Þ BeforeUpdate Þ AfterUpdate Þ Exit Þ LostFocus

  • Zweites Steuerelement:

    Enter Þ GotFocus Þ KeyPress Þ KeyUp

Mausereignisse

Wenn Sie eine Maustaste drücken und wieder loslassen, solange sich der Mauszeiger auf dem Steuerelement eines Formulars befindet, tritt für das Steuerelement die folgende Sequenz von Ereignissen ein:

MouseDown Þ MouseUp Þ Click

Liegt der Fokus auf einem Steuerelement und klicken Sie auf ein anderes Steuerelement, um den Fokus auf dieses zweite Steuerelement zu setzen, tritt die folgende Sequenz von Ereignissen ein:

  • Erstes Steuerelement:

    Exit Þ LostFocus

  • Zweites Steuerelement:

    Enter Þ GotFocus Þ MouseDown Þ MouseUp Þ Click

Wenn Sie zu einem anderen Datensatz gehen und dann auf ein Steuerelement klicken, tritt vor dem Ereignis Enter für das Steuerelement das Ereignis Current für das Formular ein.

Durch das Doppelklicken auf ein Steuerelement treten die beiden Ereignisse DblClick und Click ein. Wenn Sie z.B. auf ein Steuerelement doppelklicken, bei dem es sich nicht um eine Befehlsschaltfläche handelt, tritt für dieses Steuerelement die folgende Sequenz von Ereignissen ein:

MouseDown Þ MouseUp Þ Click Þ DblClick Þ MouseUp

Wenn Sie auf eine Befehlsschaltfläche doppelklicken, tritt nach diesen Ereignissen ein zweites Ereignis Click ein.

Das Ereignis MouseMove für ein Formular, einen Bereich oder ein Steuerelement tritt ein, wenn Sie den Mauszeiger über das Formular, den Bereich oder das Steuerelement bewegen. Dieses Ereignis ist unabhängig von den anderen Mausereignissen.

Um weitere Informationen zu Tastaturereignissen anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zu Mausereignissen anzuzeigen, klicken Sie auf [image] .


 Reihenfolge der Ereignisse für Datensätze in Formularen

Reihenfolge der Ereignisse für Datensätze in Formularen

Ereignisse treten für Datensätze in Formularen ein, wenn Sie den Fokus zu einem Datensatz bewegen, Daten in einem Datensatz aktualisieren, einen bestehenden Datensatz bzw. bestehende Datensätze löschen oder einen neuen Datensatz erstellen.

Bewegen des Fokus zu Datensätzen und Aktualisieren von Daten in Datensätzen

Wenn Sie den Fokus zu einem bestehenden Datensatz in einem Formular bewegen, in dem Datensatz Daten eingeben oder ändern und den Fokus dann zu einem anderen Datensatz bewegen, tritt die folgende Sequenz von Ereignissen für das Formular ein:

(Formular) Current Þ (Formular) BeforeUpdate Þ (Formular) AfterUpdate Þ (Formular) Current

Wenn Sie den Datensatz verlassen, dessen Daten sich geändert haben, und noch bevor Sie zum nächsten Datensatz gehen, treten für das Steuerelement mit dem Fokus die Ereignisse Exit und LostFocus ein. Diese Ereignisse treten nach den Ereignissen BeforeUpdate und AfterUpdate für das Formular ein, so dass sich die folgende Sequenz von Ereignissen ergibt:

(Formular) BeforeUpdate Þ (Formular) AfterUpdate Þ (Steuerelement) Exit Þ (Steuerelement) LostFocus Þ (Formular) Current

Während Sie in einem Formular den Fokus von einem Steuerelement zu einem anderen bewegen, treten für die Steuerelemente jeweils Ereignisse ein. In den folgenden Fällen tritt z.B. jeweils die genannte Sequenz von Ereignissen ein:

  • Öffnen eines Formulars und Ändern der Daten in einem Steuerelement:

    (Formular) Current Þ (Steuerelement) Enter Þ (Steuerelement) GotFocus Þ (Steuerelement) BeforeUpdate Þ (Steuerelement) AfterUpdate

  • Bewegen des Fokus zu einem anderen Steuerelement:

    (Steuerelement1) Exit Þ (Steuerelement1) LostFocus Þ (Steuerelement2) Enter Þ (Steuerelement2) GotFocus

  • Bewegen des Fokus zu einem anderen Datensatz:

    (Formular) BeforeUpdate Þ (Formular) AfterUpdate Þ (Steuerelement2) Exit Þ (Steuerelement2) LostFocus Þ (Formular) Current.

Zum Anzeigen weiterer Informationen zur Reihenfolge der Ereignisse für Steuerelemente in Formularen klicken Sie auf [image] .

Löschen von Datensätzen

Wenn Sie einen Datensatz löschen, treten für das Formular die folgenden Ereignisse ein, und Microsoft Access zeigt ein Dialogfeld an, worin Sie aufgefordert werden, den Löschvorgang zu bestätigen:

Delete Þ BeforeDelConfirm Þ AfterDelConfirm

Wenn Sie das Ereignis Delete abbrechen, treten die Ereignisse BeforeDelConfirm und AfterDelConfirm nicht ein, und das Dialogfeld wird nicht angezeigt.

Erstellen eines neuen Datensatzes

Wenn Sie den Fokus in einem Formular zu einem neuen (leeren) Datensatz bewegen und dann einen neuen Datensatz erstellen, indem Sie Text in ein Steuerelement eingeben, tritt die folgende Sequenz von Ereignissen ein:

(Formular) Current Þ (Steuerelement) Enter Þ (Steuerelement) GotFocus Þ (Formular) BeforeInsert Þ (Formular) AfterInsert

Die Ereignisse BeforeUpdate und AfterUpdate für die Steuerelemente im Formular und für den neuen Datensatz treten nach dem Ereignis BeforeInsert und vor dem Ereignis AfterInsert ein.

Zum Anzeigen weiterer Informationen zu Ereignissen klicken Sie auf [image] .


 Reihenfolge der Ereignisse für Berichte und Berichtsbereiche

Reihenfolge der Ereignisse für Berichte und Berichtsbereiche

Ereignisse treten für Berichte und Berichtsbereiche ein, wenn Sie einen Bericht öffnen, um ihn zu drucken oder in der Seitenansicht anzusehen, oder wenn Sie einen Bericht schließen.

Ereignisse für Berichte

Wenn Sie einen Bericht öffnen, um ihn zu drucken oder in der Seitenansicht anzusehen, und später den Bericht schließen oder zu einem anderen Fenster in Microsoft Access gehen, tritt für den Bericht die folgende Sequenz von Ereignissen ein:

Open Þ Activate Þ Close Þ Deactivate

Wenn Sie zwischen zwei geöffneten Berichten wechseln, tritt für den ersten Bericht das Ereignis Deactivate und für den zweiten Bericht das Ereignis Activate ein:

(Bericht1) Deactivate Þ (Bericht 2) Activate

Das Deactivate-Ereignis für einen Bericht tritt auch dann ein, wenn Sie von dem Bericht zu einem anderen Fenster in Access wechseln. Es tritt jedoch nicht ein, wenn Sie zu einem Dialogfeld, zu einem Formular, dessen PopUp-Eigenschaft auf Ja eingestellt ist, oder zu einem Fenster in einer anderen Anwendung wechseln.

Wenn Sie einen Bericht öffnen, der auf einer Abfrage basiert, löst Access das Open-Ereignis vor Ausführung der zugrunde liegenden Abfrage aus. Daher können Sie die Kriterien für den Bericht mit Hilfe eines Makros oder einer Ereignisprozedur festlegen, die auf das Open-Ereignis reagiert. Das Makro oder die Ereignisprozedur könnte z. B. ein benutzerdefiniertes Dialogfeld öffnen, in das Sie die Berichtskriterien eingeben.

Ereignisse für Berichtsbereiche

Wenn Sie einen Bericht drucken oder in der Seitenansicht ansehen, treten nach den Ereignissen Open und Activate für den Bericht und vor den Ereignissen Close und Deactivate des Berichts die Ereignisse Format und Print für die Berichtsbereiche ein:

(Bericht) Open Þ (Bericht) Activate Þ (Berichtsbereich) Format Þ (Berichtsbereich) Print Þ (Bericht) Close Þ (Bericht) Deactivate

Darüber hinaus können während oder nach dem Formatieren, jedoch vor dem Ereignis Print, die folgenden Ereignisse eintreten:

  • Das Retreat-Ereignis tritt ein, wenn Access während der Berichtsformatierung zu einem vorherigen Bereich zurückkehrt.

  • Das Ereignis NoData tritt ein, wenn der Bericht keine Datensätze anzeigt.

  • Das Ereignis Page tritt nach dem Formatieren und vor dem Drucken ein. Mit Hilfe dieses Ereignisses können Sie das Aussehen des gedruckten Berichts individuell gestalten.

Um weitere Informationen zu Ereignissen anzuzeigen, klicken Sie auf [image] .


 Abfragefelder

Abfragefelder

Ein Abfragefeld enthält Daten aus einer Tabelle, die mit der Abfrage verknüpft ist. Für ein Abfragefeld werden standardmäßig alle Eigenschaften übernommen, die das eigentliche Feld in der zugrunde liegenden Tabelle oder Abfrage hat. Wenn z.B. in einem Tabellenentwurf für ein Feld namens Bestelldatum in dessen Eigenschaft Format das Anzeigeformat Datum, mittel angegeben ist, wird das Feld Bestelldatum in der Datensatzgruppe der Abfrage als mittleres Datum formatiert. Da die Eigenschaften des zugrunde liegenden Feldes die Standardeinstellungen sind, werden sie nicht im Eigenschaftenfenster angezeigt.

Wenn Sie in der Tabellenansicht eine Feldeigenschaft ändern, wird diese Änderung automatisch für das Abfragefeld übernommen. Wenn Sie dagegen eine Eigenschaft innerhalb der Abfrage ändern, wird die im Tabellenentwurf angegebene Einstellung der Eigenschaft außer Kraft gesetzt. Wenn Sie später die Einstellung der Eigenschaft im Tabellenentwurf ändern, wird diese Änderung nicht für die Abfrage übernommen.

Die Eigenschaften für Abfragefelder können Sie in der Entwurfsansicht einer Abfrage in deren Fenster Feldeigenschaften einstellen.

Wenn Sie in der Entwurfsansicht einer Abfrage für ein Abfragefeld das Fenster Feldeigenschaften öffnen möchten, klicken Sie in der Symbolleiste Abfrage Datenblatt auf Eigenschaften [image] .


Empfehlungen für eine Filtermethode zur Verwendung in einer Tabelle, einer Abfrage oder einem Formular

Auswahlbasierter Filter, Formularbasierter Filter und Auswahlausschließender Filter bieten die einfachste Möglichkeit, Datensätze zu filtern. Verwenden Sie die Auswahlbasierter Filter-Methode, wenn Sie im Formular, Unterformular oder Datenblatt ein Auftreten des Wertes leicht suchen und auswählen können, der in den gefilterten Datensätzen enthalten sein soll. Wenn Sie die Werte, nach denen Sie suchen, aus einer Liste wählen möchten, ohne durch alle Datensätze im Datenblatt oder Formular zu blättern, oder wenn Sie mehrere Kriterien gleichzeitig angeben möchten, verwenden Sie die Formularbasierter Filter-Methode. Verwenden Sie die Auswahlausschließender Filter-Methode, wenn der Fokus auf einem Feld in einem Formular oder Datenblatt ist und Sie lediglich den genauen Wert, nach dem Sie suchen, oder den Ausdruck, dessen Ergebnis Sie als Kriterium verwenden wollen, eingeben möchten. Für komplexe Filter verwenden Sie die Spezialfilter/-sortierung-Methode.

Anmerkung In einem Bericht können Sie die oben beschriebenen Filtermethoden nicht verwenden. Ein Bericht kann jedoch (ebenso wie ein Formular) einen Filter übernehmen. Klicken Sie auf [image] , wenn Sie weitere Informationen wünschen.

Zurück zu Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular


Bericht

Ein Bericht ist ein Microsoft Access-Datenbankobjekt, das Informationen enthält, die entsprechend Ihren Angaben formatiert und zusammengestellt sind. Beispiele für Berichte sind Zusammenfassungen von Umsätzen, Telefonverzeichnisse oder Adressenetiketten.


 Berichtsbereich

Berichtsbereich

Ein Berichtsbereich ist ein Bestandteil eines Berichts, d.h. ein Kopfbereich, ein Fußbereich oder ein Detailbereich.

Sie können Bereichseigenschaften einstellen, die Attribute eines Berichts sind, und das Aussehen oder Verhalten eines bestimmten Bereichs festlegen. Sie können z.B. die Eigenschaft CanGrow so einstellen, dass der jeweilige Bereich in vertikaler Richtung vergrößert wird, damit alle Daten gedruckt werden, die der Bereich enthält. Bereichseigenschaften werden in der Entwurfsansicht eines Berichts eingestellt.


 Anforderungen an den Einsatz von Abfragen als Filter

Anforderungen an den Einsatz von Abfragen als Filter

Wenn Sie eine Abfrage als Filter verwenden möchten, muss die Abfrage bestimmten Anforderungen genügen.

  • Die Abfrage muss auf derselben zugrunde liegenden Tabelle oder Abfrage basieren, wie das Datenblatt oder Formular, in dem Sie sie anwenden möchten.

  • Die Abfrage darf keine weiteren Tabellen oder Abfragen enthalten.

  • Es muss sich um eine Auswahlabfrage (keine Kreuztabellenabfrage oder Aktionsabfrage) handeln.

  • Die Abfrage darf keine Felder enthalten, die Summen berechnen, zählen oder eine andere Art von Berechnung für Werte in einem Feld durchführen.


 Beseitigen von Fehlern in Visual Basic-Code

Beseitigen von Fehlern in Visual Basic-Code

Das Testen von Code ist ein Vorgang, mit dem Sie Fehler in Ihrem Visual Basic-Code suchen und beheben können. Es gibt drei verschiedene Fehlertypen, die während der Ausführung Ihres Codes auftreten können:

  • Kompilierzeitfehler treten als Ergebnis von falsch konstruiertem Code auf, beispielsweise wenn Sie vergessen haben, Anweisungspaare (wie If und End If oder For und Next) auszugleichen, oder wenn ein Programmierfehler vorliegt, der gegen die Regeln von Microsoft Visual Basic verstößt (wie ein falsch geschriebenes Wort, fehlendes Trennzeichen oder nicht übereinstimmende Datentypen).

    Zu den Kompilierzeitfehlern gehören auch Syntaxfehler ein, wobei es sich um Grammatik- oder Zeichensetzungsfehler handelt. Hierunter fallen nicht übereinstimmende Klammern oder eine falsche Anzahl von Argumenten, die einer Funktion übergeben wurden.

  • Laufzeitfehler treten auf, nachdem mit der Ausführung der Anwendung begonnen wurde. Zu den Laufzeitfehlern gehören z.B. Versuche einer unzulässigen Operation, wie eine Division durch Null oder das Schreiben in eine nicht vorhandene Datei.

  • Logische Fehler treten auf, wenn die Anwendung nicht wie vorgesehen ausgeführt wird und falsche Ergebnisse liefert.

Um Ihnen dabei zu helfen, alle drei Fehlertypen auszuschließen und die Ausführung Ihres Codes zu überwachen, stellt Ihnen der Visual Basic-Editor Fehlerbehandlungstools zur Verfügung, mit denen Sie den Code schrittweise durchlaufen, die Werte von Ausdrücken und Variablen untersuchen oder überwachen sowie Prozeduraufrufe verfolgen können.

Anmerkung Um die meisten der Fehlerbehandlungstools von Microsoft Access verwenden zu können, müssen Sie die Ausführung Ihres Codes unterbrechen. Zum Anzeigen von Informationen klicken Sie auf [image] .


 Gültigkeitsbereich und Sichtbarkeit

Gültigkeitsbereich und Sichtbarkeit

Der Gültigkeitsbereich auf Prozedurebene gilt für Variablen und Konstanten, die innerhalb einer Prozedur deklariert sind. Der Gültigkeitsbereich auf öffentlicher oder privater Modulebene gilt für Variablen, Konstanten, benutzerdefinierte Typen und Declare-Anweisungen, die am Anfang eines Moduls stehen, sowie für Sub-, Function-, Property Get-, Property Let- und Property Set-Prozeduren, die in diesem Modul deklariert sind. Weitere Informationen finden Sie im Hilfeindex unter "Declare-Anweisung" und "Property-Prozeduren".

Der folgenden Tabelle können Sie entnehmen, welche Gültigkeitsbereiche unterschiedliche Elemente in den beiden Gültigkeitsebenen haben.

Gültigkeitsebene | Typ des Elements | Gültigkeitsbereich | Anmerkungen
Prozedurebene | Variable | Privat |
 | Konstante | Privat |
Modulebene | Variable | Privat, es sei denn, sie ist als Public deklariert |
 | Konstante | Privat, es sei denn, vor ihr steht das Schlüsselwort Public. | In einem Klassenmodul können keine öffentlichen Konstanten deklariert werden.
 | Declare-Anweisung | Öffentlich, es sei denn, vor ihr steht das Schlüsselwort Private. | In einem Klassenmodul muss vor einer Declare-Anweisung das Schlüsselwort Private stehen.
 | Benutzerdefinierter Typ | Öffentlich, es sei denn, vor ihm steht das Schlüsselwort Private. | Vor benutzerdefinierten Typen, die in einem Klassenmodul deklariert sind, muss das Schlüsselwort Private stehen.
 | Prozedur | Öffentlich, es sei denn, vor ihr steht das Schlüsselwort Private. | Ereignisprozeduren in Klassenmodulen sind standardmäßig privat.

Anmerkungen

  • Öffentliche Elemente, die in einem Standardmodul definiert sind, stehen allen Prozeduren der aktuellen Datenbank sowie allen Prozeduren einer Datenbank zur Verfügung, aus der auf diese Elemente verwiesen wird. Dies trifft nur dann nicht zu, wenn das Modul die Anweisung Option Private Module enthält. Ist dies der Fall. stehen die öffentlichen Elemente nur den Prozeduren der aktuellen Datenbank zur Verfügung.

  • Klassenmodule sind standardmäßig privat. Öffentliche Elemente, die in einem Klassenmodul definiert sind, stehen nur den Prozeduren der aktuellen Datenbank zur Verfügung; aus anderen Datenbanken kann nicht auf sie verwiesen werden. Beachten Sie, dass Formular- und Berichtsmodule Klassenmodule sind.

  • Variablen, Konstanten, Prozeduren, benutzerdefinierte Typen und Declare-Anweisungen, die in einer Microsoft Access-Datenbank definiert sind, stehen nur für Microsoft Access-Projekte, nicht für Projekte in anderen Anwendungen zur Verfügung.

  • Wenn Sie auf eine Modulebenenvariable oder Prozedur in einem Klassenmodul verweisen möchten, geben Sie den Klassennamen vor der Variablen an. Haben Sie z.B. die Modulebenenvariable varBestellungen im Klassenmodul Klasse1 deklariert, so verweisen Sie auf die Modulebenenvariable mit Klasse1.varBestellungen. Dies ist erforderlich, wenn Sie die Variable in einem Standardmodul oder im Testfenster verwenden. Schließen Sie den Klassennamen des Formulars in eckige Klammern ein, wenn der Formularname aus mehreren Worten besteht.

  • Eine in einem Klassenmodul deklarierte Modulebenenvariable bleibt so lange im Gültigkeitsbereich, wie eine Instanz der Klasse vorhanden ist. Sobald Sie die Instanz der Klasse löschen, ist die Variable nicht mehr im Gültigkeitsbereich.

  • Wenn Sie in einem Standardmodul eine Modulebenenvariable initialisiert haben, behält sie ihren Wert bei, bis ihr ein anderer Wert zugewiesen, der Code zurückgesetzt oder die Datenbank geschlossen wird - und zwar jeweils unabhängig davon, ob Code ausgeführt wird oder nicht.

  • Wenn Sie in einem Klassenmodul und in einem Standardmodul Prozeduren mit demselben Namen erstellen, wird immer die Prozedur im Standardmodul aufgerufen - es sei denn, Sie geben vor dem Prozedurnamen den Klassennamen des Klassenmoduls an.


 Soll ein Feld des Datentyps "Zahl" oder "Währung" erstellt werden?

Soll ein Feld des Datentyps "Zahl" oder "Währung" erstellt werden?

Microsoft Access stellt zum Speichern von Daten mit numerischen Werten zwei Felddatentypen bereit: Zahl und Währung.

Verwenden Sie ein Feld des Datentyps Zahl, um numerische Daten zu speichern, die für mathematische Berechnungen herangezogen werden sollen. Eine Ausnahme bilden Berechnungen von Geldwerten oder Berechnungen, die eine hohe Genauigkeit erfordern. Die Art und Größe der numerischen Werte, die in einem Feld des Datentyps Zahl gespeichert werden können, wird mit der Einstellung der Eigenschaft Feldgröße festgelegt. Die Feldgröße Byte speichert z.B. nur ganze Zahlen (keine Dezimalzahlen) von 0 bis 255 und benötigt 1 Byte Speicherplatz.

Verwenden Sie ein Feld des Datentyps Währung, um bei Berechnungen ein Abrunden zu verhindern. Ein Feld des Datentyps Währung ist auf bis zu 15 Stellen links und 4 Stellen rechts vom Dezimalkomma genau. Dieser Datentyp benötigt 8 Byte Speicherplatz.

Felder des Datentyps Zahl und Währung stellen außerdem vordefinierte Anzeigeformate bereit. Mit Hilfe der Eigenschaft Format können Sie ein vorgegebenes Format auswählen oder ein benutzerdefiniertes Format erstellen. Um Informationen zum Erstellen eines benutzerdefinierten Formats anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zum Erstellen eines Feldes des Datentyps Zahl oder Währung zu erhalten, klicken Sie auf [image] .


 Soll ein Feld des Datentyps "Text" oder "Memo" erstellt werden?

Soll ein Feld des Datentyps "Text" oder "Memo" erstellt werden?

Microsoft Access stellt zum Speichern von Daten mit Text oder Kombinationen aus Text und Zahlen folgende zwei Felddatentypen bereit: Text und Memo.

Verwenden Sie den Datentyp Text, um Daten zu speichern, wie z.B. Namen, Adressen und Zahlen, die keine Berechnungen erfordern (z.B. Telefonnummern, Artikelnummern oder Postleitzahlen). In einem Feld dieses Datentyps können bis zu 255 Zeichen gespeichert werden, die Standardfeldgröße beträgt jedoch 50 Zeichen. Die maximale Zeichenanzahl, die in ein Feld des Datentyps Text eingegeben werden kann, wird mit der Eigenschaft Feldgröße festgelegt.

Verwenden Sie den Datentyp Memo, wenn Sie mehr als 255 Zeichen speichern müssen. In einem Feld dieses Datentyps können bis zu 64.000 Zeichen gespeichert werden. Wenn Sie formatierten Text oder umfangreiche Dokumente speichern möchten, erstellen Sie ein Feld des Datentyps OLE. Zum Anzeigen von Informationen zu Feldern des Datentyps OLE klicken Sie auf [image] .

Sowohl der Datentyp Text als auch der Datentyp Memo speichern nur die in das Feld eingegebenen Zeichen. Leerzeichen für nichtbenötigte Positionen im Feld werden nicht gespeichert.

Um weitere Informationen zum Erstellen eines Feldes des Datentyps Text oder Memo zu erhalten, klicken Sie auf [image] .


 Sollte beim Erstellen eines Listenfeldes, eines Dropdownlistenfeldes oder eines Kombinationsfeldes mit einem Assistenten eine Tabelle oder Abfrage verwendet werden?

Sollte beim Erstellen eines Listenfeldes, eines Dropdownlistenfeldes oder eines Kombinationsfeldes mit einem Assistenten eine Tabelle oder Abfrage verwendet werden?

Meistens können Sie eine Tabelle als Datensatzquelle für ein Listenfeld, ein Dropdownlistenfeld oder ein Kombinationsfeld verwenden, wenn Sie dieses mit Hilfe eines Assistenten erstellen. Verwenden Sie eine Abfrage in den folgenden Fällen:

  • Wenn das Listenfeld, das Dropdownlistenfeld oder das Kombinationsfeld berechnete Felder enthalten soll. Sie können z. B. einen Vor- und einen Nachnamen miteinander verketten, indem Sie den folgenden Ausdruck eingeben: Name: [Vorname] & " "& [Nachname]. Dieses berechnete Feld können Sie in einer Abfrage definieren und es dann in das Listenfeld, das Dropdownlistenfeld oder das Kombinationsfeld einbeziehen.

  • Wenn das Listenfeld, das Dropdownlistenfeld oder das Kombinationsfeld Felder aus mehreren Tabellen enthalten soll.

Wenn Sie in einem Formular mit einem Assistenten Felder aus einer Tabelle oder Abfrage auswählen, erstellt Microsoft Access eine SQL-Anweisung, die auf den ausgewählten Feldern basiert, und ordnet sie der Eigenschaft Datensatzherkunft des Listen- oder Kombinationsfeldes zu. Wenn Sie auf einer Datenzugriffsseite mit einem Assistenten Felder aus einer Tabelle oder Abfrage auswählen, legt Access die ListRowSource-Eigenschaft des Listenfeldes oder des Dropdownlistenfeldes auf die von Ihnen ausgewählte Tabelle oder Abfrage fest.

Anmerkung Assistenten stehen in Einzel-Datenzugriffsseiten oder dann, wenn eine Datenzugriffsseite auf eine andere Datenbank als die gerade geöffnete zeigt, nicht zur Verfügung. In diesem Fall müssen Sie selbst ein Listenfeld oder ein Dropdownlistenfeld erstellen.


Snapshot Viewer-Steuerelement

Ein ActiveX-Steuerelement (SNAPVIEW.OCX), mit dessen Hilfe Sie einen Snapshot-Bericht in Microsoft Internet Explorer, Version 3.0 oder höher, oder in einer Anwendung, die ActiveX-Steuerelemente unterstützt, anzeigen können, wie z. B. Microsoft Access oder Microsoft Visual Basic für Applikationen.


 Sortieren und gruppieren-Fenster

Sortieren und gruppieren-Fenster

Mit Hilfe des Fensters Sortieren und gruppieren können Sie eine Reihenfolge für Ihre Daten angeben und die Gruppierungsebenen für einen Bericht definieren.

Das Fenster Sortieren und gruppieren wird angezeigt, nachdem Sie in der Symbolleiste auf Sortieren und gruppieren [image] geklickt haben.


Tabelle

Eine Tabelle ist fundamentaler Bestandteil eines relationalen Datenbank-Managementsystems. In Microsoft Access ist eine Tabelle ein Objekt, das Daten in Datensätzen (Zeilen) und Feldern (Spalten) speichert. Die Daten gehören üblicherweise einer bestimmten Kategorie an, so z. B. der Kategorie "Personal" oder "Bestellungen".


 Tabellenfelder

Tabellenfelder

Tabellenfelder sind eigenständige Informationselemente, die in einer Tabelle einen Datensatz bilden. Sie können die Darstellungsweise von Daten festlegen, Standardwerte angeben und Such- sowie Sortiervorgänge beschleunigen, indem Sie in der Entwurfsansicht einer Tabelle im Bereich Feldeigenschaften die dort aufgeführten Feldeigenschaften einstellen.

Microsoft Access verwendet die jeweiligen Feldeigenschaften, wenn Sie Daten anzeigen oder bearbeiten. Beispielsweise wirken sich die Werte, auf die Sie die Eigenschaften Format, Eingabeformat und Beschriftung eingestellt haben, darauf aus, wie die Felder der Tabelle oder der durch eine Abfrage erstellten Tabelle angezeigt werden. Für Steuerelemente auf neuen Formularen oder Berichten, die auf der Tabelle basieren, werden standardmäßig die Einstellungen dieser Eigenschaften übernommen. Sie können weitere Eigenschaften einstellen, um Regeln für Daten festzulegen oder für Felder die Eingabe von Daten zu erzwingen. Diese Regeln werden von Microsoft Access immer dann beachtet, wenn Sie Daten zu der Tabelle hinzufügen oder Daten in ihr bearbeiten.

Gehen Sie wie folgt vor, um eine Tabelle in der Entwurfsansicht zu öffnen: Wechseln Sie zum Datenbankfenster, klicken Sie auf die Registerkarte Tabellen, wählen Sie die Tabelle aus, die Sie öffnen möchten, und klicken Sie dann auf Entwurf.


Welche Art von Rahmen sollte verwendet werden, und sollte ein Objekt in ein Formular eingefügt oder mit dem Formular verknüpft werden?

Beispiel- objekt | Typ des zu verwendenden Steuerelements | Eingefügt oder verknüpft?
Ein Logo in einem Rechnungsbericht, das nicht aktualisiert werden muss | Bildsteuerelement | Eingefügt (wenn der Speicherplatz kein Problem darstellt; anderenfalls verknüpft)
Ein Bild in einem Formular oder Bericht, das vermutlich aktualisiert wird | Ungebundenes Objektfeld | Eingefügt
Teil einer Microsoft Excel-Tabelle in einem Verkaufsbericht | Ungebundenes Objektfeld | Verknüpft
Ein Bild für jede/n in einer Tabelle Mitarbeiter gespeicherte/n Mitarbeiter/in | Gebundenes Objektfeld | Eingefügt
Lebensläufe der Mitarbeiter/innen (als Word-Dokument erstellt und gespeichert), die in einem Formular Mitarbeiter zur Verfügung gestellt werden | Gebundenes Objektfeld | Verknüpft und als Symbol angezeigt

Microsoft Access aktualisiert verknüpfte Objekte in einem Bericht automatisch, wenn Sie diesen in der Vorschau anzeigen oder ausdrucken. In Formularen findet eine Aktualisierung wie in der folgenden Tabelle dargestellt statt.

Objekttyp | Eigenschaft | Aktualisierung bei
Ungebundenes Objektfeld | Objektaktualisierung: Automatisch Gesperrt: Nein | Das Formular wird geöffnet.
Gebundenes Objektfeld | Objektaktualisierung: Automatisch Aktiviert: Ja Gesperrt: Nein | Das gebundene Objektfeld erhält den Fokus.


Verwenden einer Access-Datenbank in mehreren Versionen von Microsoft Access

Was möchten Sie tun?

Verwenden einer aus einer Datei bestehenden Access-Datenbank in mehreren Versionen von Microsoft Access

Verwenden einer Front-End/Back-End-Anwendung in mehreren Versionen von Microsoft Access

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Verwenden des Upsizing-Assistenten

Was möchten Sie tun?

Weitere Informationen über das Upsizing einer Microsoft Access-Datenbank anzeigen

Weitere Informationen darüber anzeigen, wann ein Upsizing einer Microsoft Access-Datenbank auf Microsoft SQL Server sinnvoll ist

Treffen von Vorbereitungen für das Upsizing einer Microsoft Access-Datenbank

Weitere Informationen über ODBC-Datenquellen anzeigen

Eingeben von Medien und Größen für Datenbanken und Transaktionsprotokolle

Auswählen von Tabellen für ein Upsizing

Auswählen von Tabellenattributen für ein Upsizing

Auswählen der Methode für das Upsizing Ihrer Anwendung

Informationen darüber anzeigen, wie der Upsizing-Assistent SQL-Syntax von einer Microsoft Access-Datenbank in ein Microsoft Access-Projekt konvertiert


 Was ist neu bei Microsoft Access-Projekten?

Was ist neu bei Microsoft Access-Projekten?

  • Einfaches Erstellen von Client/Server-Anwendungen Ein Microsoft Access-Projekt (.adp) ist ein neuer Access-Dateityp, der dank der OLE DB-Komponentenarchitektur einen effizienten, formatspezifischen Zugriff auf Microsoft SQL Server-Datenbanken ermöglicht. Mit Hilfe von Access-Projekten können Sie problemlos Client/Server-Anwendungen erstellen.

  • Arbeiten mit Access-Projekten Das Arbeiten mit einem Microsoft Access-Projekt ähnelt stark dem Umgang mit einer Access-Datenbank. Der Prozess der Erstellung von Formularen, Berichten, Datenzugriffsseiten, Makros und Modulen ist der gleiche. Wenn Sie sich mit einer SQL Server-Datenbank verbinden, können Sie mit Hilfe der Microsoft SQL Server-Designtools Tabellen, Sichten, gespeicherte Prozeduren und Datenbankdiagramme anzeigen, erstellen, ändern oder löschen.

  • Anwenden der Microsoft Data Engine (MSDE) MSDE ist eine neue Technologie, die eine mit Microsoft SQL Server 7.0 kompatible lokale Datenspeicherung ermöglicht. Sie können sich MSDE als eine Art alternative Client/Server-Datenbank-Engine zur Microsoft Jet-Datenbank-Engine für Dateiserver vorstellen. Sie wurde für den Einsatz auf kleineren Computersystemen entwickelt und optimiert, beispielsweise für Einzelplatz-Computer oder kleine Workgroup-Server.

  • Upsizing von Daten und Objekten mit Hilfe des Upsizing-Assistenten Der Upsizing-Assistent gewährleistet das Upsizing einer Microsoft Access-Datenbank (.mdb) auf eine neue oder vorhandene Microsoft SQL Server 6.5/7.0-Datenbank oder auf ein neues Microsoft Access-Projekt (.adp) durch Upsizing der Daten und Datendefinitionen sowie Migration der Datenbankobjekte.


 Info über das Aktualisieren von Daten in einer Abfrage, deren Tabellen eine 1:n-Beziehung haben

Info über das Aktualisieren von Daten in einer Abfrage, deren Tabellen eine 1:n-Beziehung haben

Wenn eine Abfrage auf einer 1:n-Beziehung basiert, können Sie die Daten u. U. in den Abfrageergebnissen nicht bearbeiten. Die nachstehende Tabelle zeigt die Feldarten, die Sie möglicherweise nicht ändern können, sowie ggf. alternative Methoden zum Aktualisieren der Daten.

Feldart | Lösung
Verknüpfungsfeld von der "1"-Seite | Aktivieren Sie zwischen beiden Tabellen die Option Aktualisierungsweitergabe an Detailfeld. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
Neue Datensätze, wenn das Verknüpfungsfeld auf der "n"-Seite nicht im Datenblatt angzeigt wird. | Fügen Sie das Verknüpfungsfeld von der "n"-Seite zu Ihrer Abfrage hinzu, um das Hinzufügen neuer Datensätze zu Ihrer Abfrage zuzulassen.
Verknüpfungsfeld von der "n"-Seite, nach dem Aktualisieren von Daten auf der "1"-Seite | Speichern Sie den Datensatz; anschließend können Sie Änderungen am Verknüpfungsfeld der "n"-Seite vornehmen.
Leeres Feld aus der Tabelle auf der "1"-Seite einer 1:n-Beziehung mit einer Inklusionsverknüpfung | Geben Sie Werte in Felder aus einer Tabelle auf der "n"-Seite ein, jedoch nur dann, wenn das verknüpfte Feld von der "1"-Seite für diesen Datensatz einen Wert enthält.
Neue Datensätze, wenn der gesamte eindeutige Schlüssel einer ODBC-Tabelle nicht ausgegeben wird | Wählen Sie alle Primärschlüsselfelder von ODBC-Tabellen aus, um das Einfügen von Daten in diese Felder zuzulassen.


 Welche Art eines AutoWert-Felds soll erstellt werden?

Welche Art eines AutoWert-Felds soll erstellt werden?

Microsoft Access stellt den Datentyp AutoWert bereit, um Felder zu erstellen, die beim Hinzufügen eines Datensatzes automatisch eine Zahl eingeben. Nachdem für einen Datensatz eine Zahl erstellt wurde, kann diese nicht gelöscht oder geändert werden. Ein Feld des Datentyps AutoWert kann drei Zahlentypen erstellen: fortlaufende Nummern, die sich jeweils um den Wert 1 erhöhen, Zufallszahlen und Replikations-IDs (die auch als GUIDS, Globally Unique Identifiers, bezeichnet werden). AutoWerte, die fortlaufende Nummern erstellen, werden am häufigsten verwendet und bieten sich als Primärschlüssel für Tabellen an. AutoWerte mit Zufallszahlen erstellen zu jedem Datensatz einer Tabelle eine eindeutige Zufallszahl. AutoWerte, die Replikations-IDs erstellen, werden bei der Datenbankreplikation verwendet, um eindeutige Bezeichner zum Synchronisieren von Replikaten zu erstellen. Weitere Informationen zu AutoWerten, die Replikationsnummern erstellen, und deren Einsatzmöglichkeiten anzeigen.

Um weitere Informationen zum Erstellen eines Feldes des Datentyps AutoWert zu erhalten, klicken Sie auf [image] .


Arbeiten mit einer Datenbank

Was möchten Sie tun?

Die Startübersicht anpassen

Eine Übersicht über Datenbanken anzeigen

Informationen zu Tabellen anzeigen: Definition und Funktionsweise

Informationen zu Abfragen anzeigen: Definition und Funktionsweise

Informationen zu Formularen anzeigen: Definition und Funktionsweise

Informationen zu Berichten anzeigen: Definition und Funktionsweise

Informationen zu Datenzugriffsseiten anzeigen: Definition und Funktionsweise

Informationen zu Makros anzeigen: Definition und Funktionsweise


Arbeiten mit Microsoft Access-Projekten

Was möchten Sie tun?

Die Verwendung von Microsoft Access-Projekten kennenlernen

Informationen über Microsoft Access-Projekte erhalten

Informationen über OLEDB und Datenverknüpfungen erhalten

Informationen über die Microsoft Data Engine (MSDE) erhalten

Informationen über die Verwendung von Microsoft SQL Server-Datenbank-Utilities in Microsoft Access erhalten

Die Performance von Microsoft Access-Projekten optimieren

Dokumentationen verwenden

Informationen über die Microsoft SQL Server-Dokumentation erhalten

Informationen über das Nordwind-Access-Beispielprojekt und Microsoft SQL Server-Datenbanken

Upsizing von einer Access-Datenbank auf ein Access-Projekt vornehmen

Upsizing der Microsoft Access-Datenbank

Den Upsizing-Assistenten verwenden

Daten freigeben und aktualisieren

Informationen über den Einsatz von Microsoft Access-Projekten in Mehrbenutzerumgebungen erhalten

Die Anzahl der in einem Formular oder Datenblatt eines Access-Projekts abgerufenen Datensätze bestimmen

Informationen über das Aktualisieren von Daten in einem Microsoft Access-Projekt oder in einer Datenzugriffsseite

Unterschiede zwischen Microsoft Access-Datenbanken und Microsoft Access-Projekten kennenlernen

Eine Gegenüberstellung der Datenbankobjekte einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts sehen

Eine Gegenüberstellung der Datentypen einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts sehen

Eine Gegenüberstellung der Trennzeichen, Operatoren, Konstanten und Platzhalterzeichen einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts sehen

Eine Gegenüberstellung der SQL-Syntax einer Microsoft Access-Datenbank und eines Microsoft Access-Projekts sehen

Eine Gegenüberstellung der Funktionen von Visual Basic für Applikationen und Microsoft SQL Server Transact-SQL sehen


 Ereignisprozedurkonstanten

Ereignisprozedurkonstanten

AfterDelConfirm-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis AfterDelConfirm verwenden:

  • acDelete

  • acDeleteCancel

  • acDeleteOK

  • acDeleteUserCancel

BeforeDelConfirm-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis BeforeDelConfirm verwenden:

  • acDataAdded

  • acDataErrContinue

  • acDataErrDisplay

Masken-Konstanten für Maustasten

Sie können die folgenden Masken-Konstanten für Maustasten mit Ereignisprozeduren für die Ereignisse MouseDown, MouseUp und MouseMove verwenden:

  • acLeftButton

  • acMiddleButton

  • acRightButton

Masken-Konstanten für Tasten

Sie können die folgenden Masken-Konstanten für Tasten mit Ereignisprozeduren für die Ereignisse KeyDown, KeyUp, MouseDown, MouseUp und MouseMove verwenden:

  • acAltMask

  • acCtrlMask

  • acShiftMask

NotInList-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis NotInList verwenden:

  • acDataErrAdded

  • acDataErrContinue

  • acDataErrDisplay

Error-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis Error verwenden:

  • acDataErrContinue

  • acDataErrDisplay

Updated-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis Updated verwenden:

  • acOLEChanged

  • acOLEClosed

  • acOLERenamed

  • acOLESaved

ApplyFilter-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis ApplyFilter verwenden:

  • acApplyFilter

  • acCloseFilterWindow

  • acShowAllRecords

Filter-Ereignisprozedurkonstanten

Sie können die folgenden Konstanten mit Ereignisprozeduren für das Ereignis Filter verwenden:

  • acFilterAdvanced

  • acFilterByForm


Tastaturcode-Konstanten

Sie können die folgenden Konstanten zur Darstellung von Tastaturwerten verwenden. Diese Konstanten können in Microsoft Access in den Ereignisprozeduren für die Ereignisse KeyDown und KeyUp verwendet werden.

vbKey0 | vbKeyF5 | vbKeyNumpad4
vbKey1 | vbKeyF6 | vbKeyNumpad5
vbKey2 | vbKeyF7 | vbKeyNumpad6
vbKey3 | vbKeyF8 | vbKeyNumpad7
vbKey4 | vbKeyF9 | vbKeyNumpad8
vbKey5 | vbKeyF10 | vbKeyNumpad9
vbKey6 | vbKeyF11 | vbKeyO
vbKey7 | vbKeyF12 | vbKeyP
vbKey8 | vbKeyF13 | vbKeyPageDown
vbKey9 | vbKeyF14 | vbKeyPageUp
vbKeyA | vbKeyF15 | vbKeyPause
vbKeyAdd | vbKeyF16 | vbKeyPrint
vbKeyB | vbKeyG | vbKeyQ
vbKeyBack | vbKeyH | vbKeyR
vbKeyC | vbKeyHelp | vbKeyRButton
vbKeyCancel | vbKeyHome | vbKeyReturn
vbKeyCapital | vbKeyI | vbKeyRight
vbKeyClear | vbKeyInsert | vbKeyS
vbKeyControl | vbKeyJ | vbKeySelect
vbKeyD | vbKeyK | vbKeySeparator
vbKeyDecimal | vbKeyL | vbKeyShift
vbKeyDelete | vbKeyLButton | vbKeySnapshot
vbKeyDivide | vbKeyLeft | vbKeySpace
vbKeyDown | vbKeyM | vbKeySubtract
vbKeyE | vbKeyMButton | vbKeyT
vbKeyEnd | vbKeyMenu | vbKeyTab
vbKeyEscape | vbKeyMultiply | vbKeyU
vbKeyExecute | vbKeyN | vbKeyUp
vbKeyF | vbKeyNumlock | vbKeyV
vbKeyF1 | vbKeyNumpad0 | vbKeyW
vbKeyF2 | vbKeyNumpad1 | vbKeyX
vbKeyF3 | vbKeyNumpad2 | vbKeyY
vbKeyF4 | vbKeyNumpad3 | vbKeyZ


 Aktionskonstanten

Aktionskonstanten

Sie können diese Konstanten verwenden, wenn Sie mit Hilfe von Visual Basic eine Methode des DoCmd-Objekts ausführen. Das Verwenden dieser Konstanten mit einer Methode des DoCmd-Objekts entspricht der Ausführung der entsprechenden Aktion in einem Makro. Beachten Sie, dass die DoMenuItem-Methode veraltet ist. Verwenden Sie in Microsoft Access 2000 stattdessen die RunCommand-Methode und ihre zugehörigen Konstanten. Die folgenden mit einem Sternchen (*) gekennzeichneten Konstanten wurden durch andere Konstanten ersetzt, können jedoch in Verbindung mit der bzw. den aufgelisteten Methoden nach wie vor verwendet werden.

DoCmd-Objektkonstanten | Verwendung in Verbindung mit
acActiveDataObject | GoToRecord
acAdd | OpenQuery, OpenTable, OpenStoredProcedure, OpenView
acAll | FindRecord
acAnywhere | FindRecord
acCopy | DoMenuItem
acCurrent | FindRecord
acCut | DoMenuItem
acDiagram | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acDataAccessPage | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acDataAccessPageBrowse | OpenDataAccessPage
acDataAccessPageDesign | OpenDataAccessPage
acDataForm | GoToRecord
acDataQuery | GoToRecord
acDataServerView | GoToRecord
acDataStoredProcedure | GoToRecord
acDataTable | GoToRecord
acDefault | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save,SelectObject
acDelete | DoMenuItem
acDesign | OpenForm
acDialog | OpenForm
acDown | FindRecord
acDraft | PrintOut
acEdit | OpenQuery, OpenTable, OpenStoredProcedure, OpenView
acEditMenu | DoMenuItem
acEntire | FindRecord
acExit* | Quit (DoCmd-Objekt), Quit (Application-Objekt)
acExport | TransferDatabase, TransferSpreadsheet
acExportDelim | TransferText
acExportFixed | TransferText
acExportHTML | TransferText
acExportMerge | TransferText
acFile | DoMenuItem
acFirst | GoToRecord
acFilterNormal | ApplyFilter
acForm | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acFormAdd | OpenForm
acFormatASP | OutputTo
acFormatDAP | OutputTo, SendObject
acFormatHTML | OutputTo, SendObject
acFormatIIS | OutputTo
acFormatRTF | OutputTo, SendObject
acFormatSNP | OutputTo
acFormatTXT | OutputTo, SendObject
acFormatXLS | OutputTo, SendObject
acFormBar | DoMenuItem
acFormDS | OpenForm
acFormEdit | OpenForm
acFormPropertySettings | OpenForm
acFormReadOnly | OpenForm
acGoTo | GoToRecord
acHidden | OpenForm
acHigh | PrintOut
acIcon | OpenForm
acImport | TransferDatabase, TransferSpreadsheet
acImportDelim | TransferText
acImportFixed | TransferText
acImportHTML | TransferText
acLast | GoToRecord
acLink | TransferDatabase, TransferSpreadsheet
acLinkDelim | TransferText
acLinkFixed | TransferText
acLinkHTML | TransferText
acLow | PrintOut
acMacro | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acMedium | PrintOut
acMenuCheck | SetMenuItem
acMenuGray | SetMenuItem
acMenuUncheck | SetMenuItem
acMenuUngray | SetMenuItem
acMenuVer1X | DoMenuItem
acMenuVer20 | DoMenuItem
acMenuVer70 | DoMenuItem
acModule | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acNew | DoMenuItem
acNewRec | GoToRecord
acNext | GoToRecord
acNormal | OpenForm
acObject | DoMenuItem
acObjectUpdate | DoMenuItem
acObjectVerb | DoMenuItem
acOutputDataAccessPage | OutputTo
acOutputForm | OutputTo
acOutputModule | OutputTo
acOutputQuery | OutputTo
acOutputReport | OutputTo
acOutputTable | OutputTo
acPages | PrintOut
acPaste | DoMenuItem
acPreview | OpenForm
acPrevious | GoToRecord
acPrintAll | PrintOut
acPrompt* | Close, Quit (DoCmd-Objekt), Quit (Application-Objekt)
acQuery | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acQuitPrompt | Quit (DoCmd-Objekt), Quit (Application-Objekt)
acQuitSaveAll | Quit (DoCmd-Objekt), Quit (Application-Objekt)
acQuitSaveNone | Quit (DoCmd-Objekt), Quit (Application-Objekt)
acReadOnly | OpenQuery, OpenTable, OpenStoredProcedure, OpenView
acRecordsMenu | DoMenuItem
acRefresh | DoMenuItem
acReport | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acSaveForm | DoMenuItem
acSaveFormAs | DoMenuItem
acSave* | Quit (DoCmd-Objekt), Quit (Application-Objekt)
acSaveNo | Close
acSavePrompt | Close
acSaveRecord | DoMenuItem
acSaveYes | Close
acSearchAll | FindRecord
acSelectAllRecords | DoMenuItem
acSelection | PrintOut
acSelectRecord | DoMenuItem
acSendDataAccessPage | SendObject
acSendForm | SendObject
acSendModule | SendObject
acSendNoObject | SendObject
acSendQuery | SendObject
acSendReport | SendObject
acSendTable | SendObject
acServerFilter | ApplyFilter
acServerView | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acSpreadsheetTypeExcel3 | TransferSpreadsheet
acSpreadsheetTypeExcel4 | TransferSpreadsheet
acSpreadsheetTypeExcel5 | TransferSpreadsheet
acSpreadsheetTypeExcel7 | TransferSpreadsheet
acSpreadsheetTypeExcel8 | TransferSpreadsheet
acSpreadsheetTypeExcel9 | TransferSpreadsheet
acSpreadsheetTypeLotusWK1 | TransferSpreadsheet
acSpreadsheetTypeLotusWK3 | TransferSpreadsheet
acSpreadsheetTypeLotusWK4 | TransferSpreadsheet
acSpreadsheetTypeLotusWJ2 - nur japanische Version | TransferSpreadsheet
acStart | FindRecord
acStoredProcedure | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acTable | Close, CopyObject, DeleteObject, Rename, RepaintObject, Save, SelectObject, TransferDatabase
acToolbarNo | ShowToolbar
acToolbarWhereApprop | ShowToolbar
acToolbarYes | ShowToolbar
acUndo | DoMenuItem
acUp | FindRecord
acViewDesign | OpenQuery, OpenReport, OpenStoredProcedure, OpenTable, OpenView
acViewNormal | OpenQuery, OpenReport, OpenStoredProcedure, OpenTable, OpenView
acViewPreview | OpenQuery, OpenReport, OpenStoredProcedure, OpenTable, OpenView
acWindowNormal | OpenForm


 Diverse Konstanten

Diverse Konstanten

Die folgenden Listen nennen diverse eingebaute Konstanten, die von Microsoft Access bereitgestellt werden.

Konstanten für Listen- und Kombinationsfelder

Mit Hilfe der folgenden Konstanten können Sie ein Listen- oder Kombinationsfeld unter Verwendung einer Funktion ausfüllen. Sie verwenden diese Konstanten bei einer Funktion, die die Einstellung der RowSourceType-Eigenschaft ist, indem Sie ein spezielles Funktionsformat verwenden.

acLBClose | acLBGetRowCount
acLBEnd | acLBGetValue
acLBGetColumnCount | acLBInitialize
acLBGetColumnWidth | acLBOpen
acLBGetFormat |

Konstanten für die SysCmd-Methode

Die folgenden Konstanten können Sie bei der SysCmd-Methode verwenden:

acDataAccessPage | acSysCmdAccessVer
acDefault | acSysCmdClearHelpTopic
acDiagram | acSysCmdClearStatus
acForm | acSysCmdGetObjectState
acMacro | acSysCmdGetWorkgroupFile
acModule | acSysCmdIniFile
acObjStateDirty | acSysCmdInitMeter
acObjStateNew | acSysCmdProfile
acObjStateOpen | acSysCmdRemoveMeter
acQuery | acSysCmdRuntime
acReport | acSysCmdSetStatus
acServerView | acSysCmdUpdateMeter
acStoredProcedure | acTable
acSysCmdAccessDir |

Konstanten für die ControlType-Eigenschaft sowie die CreateControl- und die CreateReportControl-Methode

Mit Hilfe einer der folgenden Konstanten können Sie bei der ControlType-Eigenschaft sowie der CreateControl- und der CreateReportControl-Methode den Steuerelementtyp angeben:

acBoundObjectFrame | acOptionButton
acCheckBox | acOptionGroup
acComboBox | acPage
acCommandButton | acPageBreak
acCustomControl | acRectangle
acImage | acSubform
acLabel | acTabCtl
acLine | acTextBox
acListBox | acToggleButton
acObjectFrame |

Konstanten für die Section-Eigenschaft sowie die CreateControl- und die CreateReportControl-Methode

Mit Hilfe einer der folgenden Konstanten können Sie bei der Section-Eigenschaft sowie der CreateControl- und der CreateReportControl-Methode einen Bereich eines Formulars oder Berichts angeben:

acDetail | acGroupLevel2Header
acFooter | acHeader
acGroupLevel1Footer | acPageFooter
acGroupLevel1Header | acPageHeader
acGroupLevel2Footer |

OLE-Konstanten

Die folgende Tabelle nennt die OLE-Konstanten sowie die Sprachelemente, bei denen diese Konstanten verwendet werden können.

OLE-Konstanten | Verwendung bei
acOLEActivate | Action-Eigenschaft
acOLEActivateDoubleClick | AutoActivate-Eigenschaft
acOLEActivateGetFocus | AutoActivate-Eigenschaft
acOLEActivateManual | AutoActivate-Eigenschaft
acOLEChanged | Updated-Ereignis
acOLEClose | Action-Eigenschaft
acOLEClosed | Updated-Ereignis
acOLECopy | Action-Eigenschaft
acOLECreateEmbed | Action-Eigenschaft
acOLECreateFromFile (identisch mit acOLECreateLink) | Action-Eigenschaft
acOLECreateLink | Action-Eigenschaft
acOLECreateNew (identisch mit acOLECreateEmbed) | Action-Eigenschaft
acOLEDelete | Action-Eigenschaft
acOLEDisplayContent | DisplayType-Eigenschaft
acOLEDisplayIcon | DisplayType-Eigenschaft
acOLEEither | OLETypeAllowed-Eigenschaft
acOLEEmbedded | OLEType-Eigenschaft, OLETypeAllowed-Eigenschaft
acOLEFetchVerbs | Action-Eigenschaft
acOLEInsertObjDlg | Action-Eigenschaft
acOLELinked | OLEType-Eigenschaft, OLETypeAllowed-Eigenschaft
acOLENone | OLEType-Eigenschaft
acOLEPaste | Action-Eigenschaft
acOLEPasteSpecialDlg | Action-Eigenschaft
acOLERenamed | Updated-Ereignis
acOLESaved | Updated-Ereignis
acOLESizeAutoSize (wird nicht verwendet) | SizeMode-Eigenschaft
acOLESizeClip | SizeMode-Eigenschaft
acOLESizeStretch | SizeMode-Eigenschaft
acOLESizeZoom | SizeMode-Eigenschaft
acOLEUpdate | Action-Eigenschaft
acOLEUpdateAutomatic | UpdateOptions-Eigenschaft
acOLEUpdateFrozen (wird nicht verwendet) | UpdateOptions-Eigenschaft
acOLEUpdateManual | UpdateOptions-Eigenschaft
acOLEVerbHide | Verb-Eigenschaft
acOLEVerbInPlaceActivate | Verb-Eigenschaft
acOLEVerbInPlaceUIActivate | Verb-Eigenschaft
acOLEVerbOpen | Verb-Eigenschaft
acOLEVerbPrimary | Verb-Eigenschaft
acOLEVerbShow | Verb-Eigenschaft

Konstanten für die SpecialEffect-Eigenschaft

Die folgende Liste nennt die Konstanten, mit deren Hilfe Sie den Status der SpecialEffect-Eigenschaft angeben oder ermitteln können. Die Konstanten acEffectNormal, acEffectRaised und acEffectSunken können auch bei der DatasheetCellsEffect-Eigenschaft verwendet werden.

acEffectChisel | acEffectRaised
acEffectEtched | acEffectShadow
acEffectNormal | acEffectSunken

Konstanten für Gitternetzlinien

Die folgende Liste nennt die Konstanten, mit deren Hilfe Sie den Status des Gitternetzlinieneffekts bei einem Objekt in der Datenblattansicht angeben oder ermitteln können. Diese Konstanten können bei der DatasheetGridlinesBehavior-Eigenschaft verwendet werden.

acGridlinesBoth | acGridlinesNone
acGridlinesBothV2 | acGridlinesVert
acGridlinesHoriz |

Typ-Konstanten

Die folgende Liste nennt die Konstanten, mit deren Hilfe Sie ermitteln können, ob es sich bei dem aktuellen Modul um ein Standardmodul oder ein Klassenmodul handelt. Diese Konstanten können bei der Type-Eigenschaft verwendet werden.

acClassModule acStandardModule

Konstanten für die HyperlinkPart-Funktion

Die folgenden Konstanten können Sie bei der HyperlinkPart-Funktion verwenden:

acAddress | acFullAddress
acDisplayedValue | acScreenTip
acDisplayText | acSubAddress

Konstanten für Prozeduren

Die folgenden Konstanten können Sie bei der ProcStartLine-, ProcBodyLine-, ProcOfLine- und der ProcCountLines-Eigenschaft verwenden.

vbext_pk_Get | vbext_pk_Proc
vbext_pk_Let | vbext_pk_Set

Konstanten für die Kind-Eigenschaft

Die folgenden Konstanten können Sie bei der Kind-Eigenschaft des Reference-Objekts verwenden:

vbext_rk_Project vbext_rk_TypeLib

Konstanten für bedingte Formatierung

Die folgenden Konstanten können Sie bei der Type-Eigenschaft des FormatCondition-Objekts verwenden:

acExpression | acFieldValue
acFieldHasFocus |


 RunCommand-Konstanten

RunCommand-Konstanten

Sie können diese Konstanten in Visual Basic in Verbindung mit der RunCommand-Methode verwenden. Die Verwendung dieser Konstanten in Verbindung mit der RunCommand-Methode entspricht dem Bereitstellen des Wertes für die Aktion AusführenBefehl in einem Makro.

Anmerkungen Die Konstante acCmdDebugWindow führt den Menübefehl Direktfenster aus.

Für die in der folgenden Liste mit Sternchen (* oder **) angegebenen Konstanten besteht eine bestimmte Einschränkung im Hinblick darauf, wann sie bei der RunCommand-Methode verwendet werden können.

  • *Nur bei aktivem Objektkatalog verfügbar.

  • **Menüelemente sind sowohl in der VBE- als auch in der Nicht-VBE-Ansicht verfügbar.

Die in Kursivschrift angegebenen Konstanten wurden nur aus Gründen der Abwärtskompatibilität in die Liste aufgenommen.

acCmdAboutMicrosoftAccess | acCmdGoContinue | acCmdRename
acCmdAddWatch | acCmdGoForward | acCmdRenameColumn
acCmdAdvancedFilterSort | acCmdHideColumns | acCmdRepairDatabase
acCmdAlignBottom | acCmdHidePane | acCmdReplace**
acCmdAlignLeft | acCmdHideTable | acCmdReportHdrFtr
acCmdAlignRight | acCmdHorizontalSpacingDecrease | acCmdReset
acCmdAlignToGrid | acCmdHorizontalSpacingIncrease | acCmdResolveConflicts
acCmdAlignTop | acCmdHorizontalSpacingMakeEqual | acCmdRowHeight
acCmdAlignToShortest | acCmdHyperlinkDisplayText | acCmdRun
acCmdAlignToTallest | acCmdImport | acCmdRunMacro
acCmdAnalyzePerformance | acCmdIndent | acCmdRunOpenMacro
acCmdAnalyzeTable | acCmdIndexes | acCmdSave**
acCmdAnswerWizard | acCmdInsertActiveXControl | acCmdSaveAllModules
acCmdApplyDefault | acCmdInsertChart | acCmdSaveAs**
acCmdApplyFilterSort | acCmdInsertFile | acCmdSaveAsASP
acCmdAppMaximize | acCmdInsertFileIntoModule | acCmdSaveAsHTML
acCmdAppMinimize | acCmdInsertHyperlink | acCmdSaveAsIDC
acCmdAppMove | acCmdInsertLookupColumn | acCmdSaveAsQuery
acCmdAppRestore | acCmdInsertLookupField | acCmdSaveAsReport
acCmdAppSize | acCmdInsertObject | acCmdSaveLayout
acCmdArrangeIconsAuto | acCmdInsertPage | acCmdSaveModuleAsText
acCmdArrangeIconsByCreated | acCmdInsertPicture | acCmdSaveRecord
acCmdArrangeIconsByModified | acCmdInsertProcedure | acCmdSelectAll
acCmdArrangeIconsByName | acCmdInsertQueryColumn | acCmdSelectAllRecords
acCmdArrangeIconsByType | acCmdInsertRows | acCmDSelectDataAccessPage
acCmdAutoCorrect | acCmdInsertTableColumn | acCmdSelectForm
acCmdAutoDial | acCmdInvokeBuilder | acCmdSelectRecord
acCmdAutoFormat | acCmdJoinProperties | acCmdSelectReport
acCmdBookmarksClearAll | acCmdLastPosition | acCmdSend
acCmdBookmarksNext | acCmdLayoutPreview | acCmdSendToBack
acCmdBookmarksPrevious | acCmdLineUpIcons | acCmdSetControlDefaults
acCmdBookmarksToggle | acCmdLinkTables | acCmdSetDatabasePassword
acCmdBringToFront | acCmdListConstants | acCmdSetNextStatement
acCmdCallStack | acCmdLoadFromQuery | acCmdShowAllRelationships
acCmdChangeToCheckBox | acCmdMacroConditions | acCmdShowDirectRelationships
acCmdChangeToComboBox | acCmdMacroNames | acCmdShowMembers
acCmdChangeToImage | acCmdMicrosoftAccessHelpTopics | acCmdShowNextStatement
acCmdChangeToLabel | acCmdMicrosoftOnTheWeb | acCmdShowOnlyWebToolbar
acCmdChangeToListBox | acCmdMicrosoftScriptEditor | acCmdShowPaneDiagram
acCmdChangeToOptionButton | acCmdMoreWindows | acCmdShowPaneGrid
acCmdChangeToTextBox | acCmdNewDatabase | acCmdShowPaneView
acCmdChangeToToggleButton | acCmdNewObjectAutoDataAccessPage | acCmdShowTable
acCmdClearAll | acCmdNewObjectAutoForm | acCmdSingleStep
acCmdClearAllBreakpoints | acCmdNewObjectAutoReport | acCmdSizeToFit
acCmdClearGrid | acCmdNewObjectClassModule | acCmdSizeToFitForm
acCmdClearItemDefaults | acCmdNewObjectDataAccessPage | acCmdSizeToGrid
acCmdClose | acCmdNewObjectDiagram | acCmdSizeToNarrowest
acCmdCloseWindow | acCmdNewObjectForm | acCmdSizeToWidest
acCmdColumnWidth | acCmdNewObjectMacro | acCmdSnapToGrid
acCmdCompactDatabase | acCmdNewObjectModule | acCmdSortAscending
acCmdCompileAllModules | acCmdNewObjectQuery | acCmdSortDescending
acCmdCompileAndSaveAllModules | acCmdNewObjectReport | acCmdSortingAndGrouping
acCmdCompileLoadedModules | acCmdNewObjectStoredProcedure | acCmdSpelling
acCmdCompleteWord | acCmdNewObjectTable | acCmdSQLView
acCmdControlWizardsToggle | acCmdNewObjectView | acCmdStartupProperties
acCmdConvertDatabase | acCmdObjBrwFindWholeWordOnly* | acCmdStepOut
acCmdConvertMacrosToVisualBasic | acCmdObjBrwGroupMembers* | acCmdStepOver
acCmdCopy** | acCmdObjBrwHelp* | acCmdStepToCursor
acCmdCopyHyperlink | acCmdObjBrwShowHiddenMembers* | acCmdStopLoadingPage
acCmdCreateMenuFromMacro | acCmdObjBrwViewDefinition* | acCmdSubformDatasheet
acCmdCreateRelationship | acCmdObjectBrowser* | acCmdSynchronizeNow
acCmdCreateReplica | acCmdOLEDDELinks | acCmdTabControlPageOrder
acCmdCreateShortcut | acCmdOLEObjectConvert | acCmdTableNames
acCmdCreateShortcutMenuFromMacro | acCmdOLEObjectDefaultVerb | acCmdTabOrder
acCmdCreateToolbarFromMacro | acCmdOpenDatabase | acCmdTestValidationRules
acCmdCut** | acCmdOpenHyperlink | acCmdTileHorizontally
acCmdDataAccessPageBrowse | acCmdOpenNewHyperlink | acCmdTileVertically
acCmdDataAccessPageDesignView | acCmdOpenSearchPage | acCmdToggleBreakpoint
acCmdDatabaseProperties | acCmdOpenStartPage | acCmdToggleFilter
acCmdDataEntry | acCmdOpenTable | acCmdToolbarControlProperties
acCmdDatasheetView | acCmdOpenURL | acCmdToolbarsCustomize**
acCmdDateAndTime | acCmdOptions** | acCmdTransparentBackground
acCmdDebugWindow | acCmdOutdent | acCmdTransparentBorder
acCmdDelete** | acCmdOutputToExcel | acCmdUndo**
acCmdDeletePage | acCmdOutputToRTF | acCmdUnfreezeAllColumns
acCmdDeleteQueryColumn | acCmdOutputToText | acCmdUnhideColumns
acCmdDeleteRecord | acCmdPageHdrFtr | acCmdUserAndGroupAccounts
acCmdDeleteRows | acCmdPageNumber | acCmdUserAndGroupPermissions
acCmdDeleteTab | acCmdPageSetup | acCmdUserLevelSecurityWizard
acCmdDeleteTableColumn | acCmdParameterInfo | acCmdVerticalSpacingDecrease
acCmdDeleteWatch | acCmdPaste** | acCmdVerticalSpacingIncrease
acCmdDesignView | acCmdPasteAppend | acCmdVerticalSpacingMakeEqual
acCmdDiagramAddRelatedTables | acCmdPasteSpecial | acCmdViewCode
acCmdDiagramAutosizeSelectedTables | acCmdPreviewEightPages | acCmdViewDataAccessPages
acCmdDiagramDeleteRelationship | acCmdPreviewFourPages | acCmdViewDetails
acCmdDiagramLayoutDiagram | acCmdPreviewOnePage | acCmdViewDiagrams
acCmdDiagramLayoutSelection | acCmdPreviewTwelvePages | acCmdViewFieldList
acCmdDiagramModifyUserDefinedView | acCmdPreviewTwoPages | acCmdViewForms
acCmdDiagramNewLabel | acCmdPrimaryKey | acCmdViewGrid
acCmdDiagramNewTable | acCmdPrint** | acCmdViewLargeIcons
acCmdDiagramRecalculatePageBreaks | acCmdPrintPreview | acCmdViewList
acCmdDiagramRelationshipLabels | acCmdProcedureDefinition | acCmdViewMacros
acCmdDiagramViewPageBreaks | acCmdProperties | acCmdViewModules
acCmdDocMaximize** | acCmdPublish | acCmdViewQueries
acCmdDocMinimize** | acCmdPublishDefaults | acCmdViewReports
acCmdDocMove** | acCmdQueryAddToOutput | acCmdViewRuler
acCmdDocRestore** | acCmdQueryParameters | acCmdViewSmallIcons
acCmdDocSize** | acCmdQueryTotals | acCmdViewStoredProcedure
acCmdDocumenter | acCmdQueryTypeAppend | acCmdViewTableColumnNames
acCmdDuplicate | acCmdQueryTypeCrosstab | acCmdViewTableColumnProperties
acCmdEditHyperlink | acCmdQueryTypeDelete | acCmdViewTableKeys
acCmdEditingAllowed | acCmdQueryTypeMakeTable | acCmdViewTableNameOnly
acCmdEditRelationship | acCmdQueryTypeSelect | acCmdViewTables
acCmdEditTriggers | acCmdQueryTypeSQLDataDefinition | acCmdViewTableUserView
acCmdEditWatch | acCmdQueryTypeSQLPassThrough | acCmdViewToolbox
acCmdEncryptDecryptDatabase | acCmdQueryTypeSQLUnion | acCmdViewVerifySQL
acCmdEnd | acCmdQueryTypeUpdate | acCmdViewViews
acCmdExit | acCmdQuickInfo | acCmdWindowArrangeIcons
acCmdFavoritesAddTo | acCmdQuickPrint | acCmdWindowCascade
acCmdFavoritesOpen | acCmdQuickWatch | acCmdWindowHide
acCmdFieldList | acCmdRecordsGoToFirst | acCmdWindowSplit
acCmdFilterByForm | acCmdRecordsGoToLast | acCmdWindowUnhide
acCmdFilterBySelection | acCmdRecordsGoToNew | acCmdWordMailMerge
acCmdFilterExcludingSelection | acCmdRecordsGoToNext | acCmdZoom10
acCmdFind** | acCmdRecordsGoToPrevious | acCmdZoom100
acCmdFindNext** | acCmdRecoverDesignMaster | acCmdZoom150
acCmdFindNextWordUnderCursor | acCmdRedo | acCmdZoom200
acCmdFindPrevious | acCmdReference | acCmdZoom25
acCmdFindPrevWordUnderCursor | acCmdRefresh | acCmdZoom50
acCmdFitToWindow | acCmdRefreshPage | acCmdZoom75
acCmdFont | acCmdRegisterActiveXControls | acCmdZoomBox
acCmdFormatCells | acCmdRelationships | acCmdZoomSelection
acCmdFormHdrFtr | acCmdRemove |
acCmdFormView | acCmdRemoveFilterSort |
acCmdFreezeColumn | acCmdRemoveTable |
acCmdGoBack |  |


 Zugriffsrechtekonstanten

Zugriffsrechtekonstanten

Sie können Datenbankobjekten über Visual Basic Berechtigungen zuweisen:

acSecFrmRptExecute | acSecMacReadDef
acSecFrmRptReadDef | acSecMacWriteDef
acSecFrmRptWriteDef | acSecModReadDef
acSecMacExecute | acSecModWriteDef

Anmerkung Die mit acSec beginnenden Konstanten stehen nur in Visual Basic zur Verfügung, um Berechtigungen für Datenbankobjekte einzustellen.


Aktionsabfrage

Ein Aktionsabfrage ändert Daten oder kopiert Daten. Zu den Aktionsabfragen gehören Anfüge-, Lösch-, Tabellenerstellungs- und Aktualisierungsabfragen. Im Gegensatz dazu ändert oder kopiert eine Auswahlabfrage keine Daten, sondern sie stellt eine Frage und gibt eine Gruppe von Datensätzen zurück.

Typ der Aktionsabfrage | Beschreibung
Anfügeabfrage | Fügt die Datensätze der Ergebnisgruppe einer Abfrage an eine Tabelle an.
Löschabfrage | Löscht alle Datensätze, die den von Ihnen formulierten Kriterien entsprechen.
Tabellenerstellungsabfrage | Erstellt aus der Ergebnisgruppe der Abfrage eine neue Tabelle.
Aktualisierungsabfrage | Nimmt Änderungen an allen Datensätzen vor, die den von Ihnen formulierten Kriterien entsprechen.


 ActiveX-Steuerelement (Formular)

ActiveX-Steuerelement (Formular)

Neben den eingebauten Steuerelementen, die in der Toolbox angezeigt werden, unterstützt Microsoft Access ActiveX-Steuerelemente (früher als Zusatzsteuerelemente oder OLE-Steuerelemente bezeichnet). Ein ActiveX-Steuerelement ist wie ein eingebautes Steuerelement ein Objekt, das Sie auf ein Formular setzen können, um die Interaktion eines Benutzers mit einer Anwendung zu ermöglichen oder zu erweitern. ActiveX-Steuerelemente verfügen über Ereignisse und können in andere Steuerelemente eingefügt werden. Diese Steuerelemente besitzen die Dateinamenerweiterung .OCX. Das Kalender-Steuerelement ist ein Beispiel für ein ActiveX-Steuerelement.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem ActiveX-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem ActiveX-Steuerelement auf einer Datenzugriffsseite finden Sie unter ActiveX-Steuerelement (Datenzugriffsseiten).


 ActiveX-Steuerelement (Datenzugriffsseiten)

ActiveX-Steuerelement (Datenzugriffsseiten)

Neben den eingebauten Steuerelementen, die in der Toolbox angezeigt werden, unterstützt Microsoft Access ActiveX-Steuerelemente (früher als "Zusatzsteuerelemente" oder "OLE-Steuerelemente" bezeichnet). Ein ActiveX-Steuerelement ist wie ein eingebautes Steuerelement ein Objekt, das Sie in ein Formular einfügen können, um die Interaktion eines Benutzers mit einer Anwendung zu ermöglichen oder zu erweitern. ActiveX-Steuerelemente verfügen über Ereignisse und können in andere Steuerelemente integriert werden. Diese Steuerelemente besitzen die Dateinamenerweiterung .OCX. Das Kalender-Steuerelement ist ein Beispiel für ein ActiveX-Steuerelement.

Steuerelement: | Tool:
Kalender-Steuerelement | ActiveX-Steuerelement


Gebundenes Steuerelement

Ein gebundenes Steuerelement ist ein auf einem Formular oder Bericht angeordnetes Steuerelement, dessen Inhalt aus einem Feld der zugrunde liegenden Tabelle, Abfrage oder SQL-Anweisung stammt. (Die Eigenschaft ControlSource des Steuerelements ist auf den Namen eines Feldes der Tabelle, Abfrage oder SQL-Anweisung eingestellt.) So kann z.B. ein Textfeld, das den Nachnamen eines Mitarbeiters anzeigt, an das Feld Nachname der Tabelle Personal gebunden sein.


 Gebundener HTML-Text-Steuerelement

Gebundener HTML-Text-Steuerelement

Mit Hilfe des gebundener HTML-Text-Steuerelements können Sie HTML-Code in einem Feld einer Tabelle speichern. Wenn die Datenzugriffsseite die Werte in diesem Feld anzeigt, führt der HTML-Code die angegebenen Aktionen aus.

Tool:
Gebundener HTML-Text-Steuerelement

Wird ein Feld oder eine Spalte als gebundener HTML-Text-Steuerelement in eine Datenzugriffsseite eingefügt, so wird der Inhalt des Feldes als HTML aufbereitet und kann nicht bearbeitet werden.

Anmerkungen

  • Sie können das gebundener HTML-Text-Steuerelement zum Standard-Steuerelement für eine gruppierte Datenzugriffsseite machen. Stellen Sie die DefaultControlType-Eigenschaft der Datenzugriffsseite auf Bound HTML ein.

  • Sie können ein gebundener HTML-Text-Steuerelement zum Anzeigen von Berechnungen und allen Daten einer gruppierten Datenzugriffsseite verwenden. Bei der Verwendung von HTML-Steuerelementen wird die Seite in Microsoft Internet Explorer 5 schneller geladen.

  • Zum Sortieren oder Filtern nach gebundener HTML-Text-Steuerelementen in der Seitenansicht oder in Internet Explorer 5 können Sie nicht die Navigationsschaltfläche verwenden.


 Gebundener Hyperlink-Steuerelement

Gebundener Hyperlink-Steuerelement

Mit Hilfe des gebundener Hyperlink-Steuerelements können Sie einem Textfeld auf einer Datenzugriffsseite einen gebundenen Hyperlink hinzufügen.

Tool:
Gebundener Hyperlink-Steuerelement

Sie können einen gebundenen Hyperlink verwenden, wenn jeder Datensatz einer Tabelle eine unterschiedliche Hyperlinkadresse besitzen soll. Während Sie von einem Datensatz zu einem anderen wechseln, können Sie auf den Hyperlink klicken und so bei jedem Datensatz zu einer anderen Webseite gelangen.


 Gebundenes Objektfeld-Steuerelement

Gebundenes Objektfeld-Steuerelement

Ein Gebundenes Objektfeld-Steuerelement zeigt ein Bild, ein Diagramm oder ein OLE-Objekt an, das in einer Tabelle einer Microsoft Access-Datenbank gespeichert ist. Wenn Sie z.B. Bilder Ihrer Mitarbeiterinnen und Mitarbeiter in einer Microsoft Access-Tabelle gespeichert haben, können Sie diese mit Hilfe eines gebundenen Objektfelds auf einem Formular oder Bericht anzeigen.

Steuerelement: | Tool:

Anmerkung

Ein Steuerelement dieses Typs ermöglicht es Ihnen, das jeweilige Objekt von einem Formular oder Bericht aus zu erstellen oder zu bearbeiten, indem Sie den OLE-Server verwenden.

Ein gebundenes Objektfeld ist an ein Feld der jeweils zugrunde liegenden Tabelle gebunden.

Das Feld der zugrunde liegenden Tabelle, an das das Objektfeld gebunden ist, muss den Datentyp OLE-Objekt haben.

In einem gebundenen Objektfeld wird für jeden Datensatz ein anderes Objekt angezeigt. In dem gebundenen Objektfeld können verknüpfte oder eingebettete Objekte angezeigt werden. Wenn Sie Objekte anzeigen möchten, die nicht in einer zugrunde liegenden Tabelle gespeichert sind, verwenden Sie ein ungebundenes Objektfeld-Steuerelement oder ein Bild-Steuerelement.


 Diagramm-Steuerelement (Formulare und Berichte)

Diagramm-Steuerelement (Formulare und Berichte)

Mit einem Diagramm-Steuerelement können Sie ein Diagramm einbetten, in dem Microsoft Access-Daten angezeigt werden, die zu einem Formular oder Bericht gehören. Sie können das Diagramm dann mit Hilfe von Microsoft Graph von Ihrem Formular oder Bericht aus bearbeiten.

Steuerelement:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Bild-, Office-Diagramm- oder Office-Tabellenblatt-Steuerelement für dynamisches HTML, die auf einer Datenzugriffsseite verwendet werden. Weitere Informationen zu diesen Steuerelementen finden Sie unter Bild-, Hotspot-, Office-Diagramm- bzw. Office-Tabellenblatt-Steuerelement (Datenzugriffsseiten).

Anmerkung

Wenn Sie ein Diagramm-Steuerelement auf einem Formular oder Bericht anordnen, startet Microsoft Access den Diagramm-Assistenten, um Sie beim Erstellen des Diagramms zu unterstützen.

Anmerkung Wenn Sie ein Diagramm einbetten oder verknüpfen möchten, das Daten enthält, die aus einer anderen Anwendung stammen, verwenden Sie ein ungebundenes Objektfeld-Steuerelement oder ein gebundenes Objektfeld-Steuerelement.


 Kontrollkästchen-Steuerelement (Formulare und Berichte)

Kontrollkästchen-Steuerelement (Formulare und Berichte)

Ein Kontrollkästchen auf einem Formular oder Bericht ist ein eigenständiges Steuerelement, das einen Wert Ja/Nein aus der zugrunde liegenden Datenquelle anzeigt.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Kontrollkästchen-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Weitere Informationen zu einem Kontrollkästchen auf einer Datenzugriffsseite finden Sie unter Kontrollkästchen-Steuerelement (Datenzugriffsseiten).

Anmerkung

Wenn Sie ein Kontrollkästchen, das an ein Feld Ja/Nein gebunden ist, aktivieren bzw. deaktivieren, zeigt Microsoft Access den Wert in der zugrunde liegenden Tabelle so an, wie es der Einstellung der Eigenschaft Format des Feldes entspricht (Ja/Nein, Wahr/Falsch oder Ein/Aus).

Sie können Kontrollkästchen auch in einer Optionsgruppe verwenden, um Werte anzuzeigen, unter denen gewählt werden kann.

Darüber hinaus kann ein ungebundenes Kontrollkästchen in einem benutzerdefinierten Dialogfeld verwendet werden, um eine Eingabe des Benutzers entgegenzunehmen.


 Kontrollkästchen-Steuerelement (Datenzugriffsseiten)

Kontrollkästchen-Steuerelement (Datenzugriffsseiten)

Ein Kontrollkästchen auf einer Datenzugriffsseite ist ein gebundenes Steuerelement, das einen Wert Ja/Nein aus der zugrunde liegenden Datenquelle anzeigt.

Steuerelement: | Tool:
Kontrollkästchen | Kontrollkästchen-Steuerelement

Anmerkungen

Wenn Sie ein Kontrollkästchen, das an ein Feld Ja/Nein gebunden ist, aktivieren bzw. deaktivieren, zeigt Microsoft Access den Wert in der zugrunde liegenden Tabelle so an, wie es der Einstellung der Format-Eigenschaft des Feldes entspricht (Ja/Nein, Wahr/Falsch oder Ein/Aus).

Sie können Kontrollkästchen auch in einer Optionsgruppe verwenden, um Werte anzuzeigen, unter denen gewählt werden kann.

Darüber hinaus kann ein ungebundenes Kontrollkästchen in einem benutzerdefinierten Dialogfeld verwendet werden, um eine Eingabe des Benutzers entgegenzunehmen.


 Kombinationsfeld-Steuerelement (Formulare)

Kombinationsfeld-Steuerelement (Formulare)

Ein Kombinationsfeld-Steuerelement ist eine Kombination aus einem Textfeld und einem Listenfeld. Ein Kombinationsfeld können Sie immer dann verwenden, wenn es sowohl möglich sein soll, einen Wert einzugeben, als auch, einen Wert aus einer vordefinierten Liste auszuwählen.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Dropdownlistenfeld-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Dropdownlistenfeld-Steuerelement auf einer Datenzugriffsseite finden Sie unter Dropdownlistenfeld-Steuerelement (Datenzugriffsseite).

Anmerkung

In der Formularansicht zeigt Microsoft Access die Liste erst an, nachdem Sie auf den Dropdownpfeil des Kombinationsfelds geklickt haben.

Sind in dem Moment, in dem Sie das Tool Kombinationsfeld auswählen, die Steuerelement-Assistenten aktiviert, können Sie das Kombinationsfeld mit einem Assistenten erstellen. Sie aktivieren oder deaktivieren die Steuerelement-Assistenten, indem Sie in der Symbolleiste auf das Tool Steuerelement-Assistenten [image] klicken.

Die Einstellung der Eigenschaft LimitToList gibt an, ob Sie auch Werte eingeben können, die nicht in der Liste enthalten sind.

Die Liste kann aus einer oder mehreren Spalten bestehen, wobei die Spalten mit oder ohne Überschriften angezeigt werden können.


 Befehlsschaltfläche-Steuerelement (Formulare)

Befehlsschaltfläche-Steuerelement (Formulare)

Eine Befehlsschaltfläche auf einem Formular kann einen Vorgang oder eine Gruppe von Vorgängen auslösen. Sie könnten z.B. eine Befehlsschaltfläche erstellen, über die ein anderes Formular geöffnet werden kann. Damit eine Befehlsschaltfläche einen Vorgang auslöst, müssen Sie ein Makro oder eine Ereignisprozedur schreiben und das Makro oder die Prozedur der Eigenschaft OnClick der Befehlsschaltfläche zuweisen.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Befehlsschaltfläche-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Befehlsschaltfläche-Steuerelement auf einer Datenzugriffsseite finden Sie unter Befehlsschaltfläche-Steuerelement (Datenzugriffsseiten).

Anmerkung

Sie können auf einer Befehlsschaltfläche entweder Text oder ein Bild anzeigen, indem Sie entweder die Eigenschaft Caption oder die Eigenschaft Picture der Schaltfläche entsprechend einstellen.

Tipp Mit dem Befehlsschaltflächen-Assistenten können Sie über 30 verschiedene Arten von Befehlsschaltflächen erstellen. Microsoft Access erstellt dann sowohl die Schaltfläche als auch die Ereignisprozedur für Sie.


 Befehlsschaltflächen-Steuerelement (Datenzugriffsseiten)

Befehlsschaltflächen-Steuerelement (Datenzugriffsseiten)

Eine Befehlsschaltfläche auf einer Datenzugriffsseite kann einen Vorgang oder eine Gruppe von Vorgängen auslösen. Auf einer Datenzugriffsseite wird Code, der in JavaScript oder Visual Basic Script geschrieben wurde, einer Befehlsschaltfläche unter Verwendung von Microsoft Script Editor zugewiesen.

Steuerelement: | Tool:
Befehlsschaltfläche | Befehlsschaltflächen-Steuerelement

Anmerkungen

Sie können auf einer Befehlsschaltfläche Text anzeigen, indem Sie deren Value-Eigenschaft entsprechend festlegen.


 Kreuztabellenabfrage

Kreuztabellenabfrage

Eine Kreuztabellenabfrage erstellt Summen aus den Werten in jeder Zeile und Spalte. Sie berechnet für Datensätze die Summe, den Mittelwert, die Anzahl oder eine andere Funktion und gruppiert das Ergebnis dann nach zwei Informationsarten: eine auf der linken Seite des Datenblatts nach unten und eine entsprechend den Spaltenüberschriften des Datenblatts nach rechts. Beispielsweise ist die zur Beispieldatenbank Nordwind gehörende Abfrage Quartalsbestellungen nach Artikeln eine Kreuztabellenabfrage.


 Dropdownlisten-Steuerelement (Datenzugriffsseiten)

Dropdownlisten-Steuerelement (Datenzugriffsseiten)

Das Dropdownlisten-Steuerelement auf einer Datenzugriffsseite ist eine Kombination aus einem Textfeld und einem Listenfeld. Eine Dropdownliste können Sie immer dann verwenden, wenn es sowohl möglich sein soll, einen Wert anzuzeigen, als auch, einen Wert aus einer vordefinierten Liste auszuwählen.

Steuerelement: | Tool:
Kombinationsfeld | Dropdownlisten-Steuerelement

Anmerkungen

In der Seitenansicht zeigt Microsoft Access die Liste erst an, nachdem Sie auf den Pfeil der Dropdownliste geklickt haben.

Wenn die Steuerelement-Assistenten aktiviert sind, während Sie das Tool Dropdownliste auswählen, , können Sie die Dropdownliste mit einem Assistenten erstellen. Die Steuerelement-Assistenten aktivieren bzw. deaktivieren Sie, indem Sie in der Toolbox auf das Tool Steuerelement-Assistenten [image] klicken.

Sie können keine Werte eingeben, die in der Liste nicht enthalten sind.

Die Liste kann aus einer oder mehreren Spalten bestehen, wobei die Spalten mit oder ohne Überschriften angezeigt werden können.


 Unterformular/Unterbericht-Steuerelement

Unterformular/Unterbericht-Steuerelement

Ein Unterformular/-bericht-Steuerelement bewirkt, dass ein Formular in ein anderes Formular oder ein Bericht in einen anderen Bericht eingebettet wird.

Steuerelement: | Tool:

Sie können z.B. ein Formular zusammen mit einem Unterformular verwenden, um 1:n-Beziehungen auszuwerten und zu verwenden, wie etwa für eine Artikelkategorie mit den Einträgen, die in diese Kategorie fallen. Für diesen Fall können auf dem Hauptformular die Kategorie-Nr, der Kategoriename und eine Beschreibung und auf dem Unterformular die Artikel angezeigt werden, die für diese Kategorie verfügbar sind.

Tipp Anstatt zuerst das Hauptformular zu erstellen und dann das Unterformular-Steuerelement hinzuzufügen, können Sie gleichzeitig Haupt- und Unterformular mit einem Assistenten erstellen. Außerdem können Sie einen Unterbericht oder ein Unterformular erstellen, indem Sie ein bereits vorhandenes Formular oder einen bereits vorhandenen Bericht aus dem Datenbankfenster auf das Hauptformular oder den Hauptbericht ziehen.


 Erweiterungssteuerelement

Erweiterungssteuerelement

Mit Hilfe des Erweiterungssteuerelements können Sie einer Datenzugriffsseite eine Schaltfläche für Erweitern/Reduzieren hinzufügen.

Tool:

Anmerkung

Dieses Steuerelement ermöglicht es dem Benutzer, Datensätze, die unter einem anderen Datensatz gruppiert wurden, anzuzeigen oder auszublenden.


 Hotspotbild-Steuerelement

Hotspotbild-Steuerelement

Mit Hilfe des Hotspotbild-Steuerelements können Sie einer Datenzugriffsseite ein ungebundenes Bild hinzufügen.

Tool:
Hotspotbild-Steuerelement

Anmerkungen

Mit Hilfe des Hotspotbild-Steuerelements können Sie einer Datenzugriffsseite ein Bild hinzufügen. Beim Klicken auf dieses Bild wird eine andere Webseite angezeigt, die sich auf Ihrer Festplatte, im Web oder an einem anderen Speicherort befindet. Wenn Sie ein Hotspotbild-Steuerelement erstellen, wählen Sie das Bild, das auf der Seite angezeigt werden soll, sowie die Adresse aus, zu der der Sprung erfolgen soll.

  • Das Dialogfeld Grafik einfügen zeigt eine Liste von Grafiken an, die als Bild ausgewählt werden können.

  • Das Dialogfeld Hyperlink einfügen ermöglicht es dem Benutzer, die Datei oder Webseite auszuwählen, die mit dem Bild-Steuerelement verknüpft werden soll.

Wenn der Mauszeiger in der Seitenansicht über das Bild bewegt wird, ändert er sich in eine Hand und weist so darauf hin, dass es sich bei dem Bild um eine Verknüpfung handelt, auf die Sie klicken können, um zu einer anderen Seite zu gelangen. Darüber hinaus können Sie eine QuickInfo und alternativen Text für das Bild definieren.


 Hyperlink-Steuerelement (Datenzugriffsseite)

Hyperlink-Steuerelement (Datenzugriffsseite)

Mit Hilfe des Hyperlink-Steuerelements können Sie einer Datenzugriffsseite einen Hyperlink hinzufügen.

Tool:

Wenn das Hyperlink-Steuerelement in eine Datenzugriffsseite eingefügt wird, zeigt Microsoft Access das Dialogfeld Hyperlink einfügen an. In diesem Dialogfeld kann der Benutzer die Datei oder Webseite auswählen, die mit dem Hyperlink-Steuerelement verknüpft werden soll.


 Bild-Steuerelement (Formulare und Berichte)

Bild-Steuerelement (Formulare und Berichte)

Mit einem Bild-Steuerelement kann ein Bild zu einem Formular oder Bericht hinzugefügt werden. Sie können z.B. ein Bild-Steuerelement für ein Logo auf einem als Rechnung dienenden Bericht anordnen.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Bild-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Bild-Steuerelement auf einer Datenzugriffsseite finden Sie unter Bild-Steuerelement (Datenzugriffsseite).

Anmerkung

Für ein ungebundenes Bild können Sie ein Bild-Steuerelement oder ein ungebundenes Objektfeld-Steuerelement verwenden. Der Vorteil eines Bild-Steuerelements liegt darin, dass es schneller angezeigt wird. Der Vorteil eines Objektfeld-Steuerelements liegt darin, dass Sie das jeweilige Objekt direkt vom Formular oder Bericht aus bearbeiten können.


 Bild-Steuerelement (Datenzugriffsseiten)

Bild-Steuerelement (Datenzugriffsseiten)

Mit einem Bild-Steuerelement kann ein Bild zu einer Datenzugriffsseite hinzugefügt werden. So können Sie z. B. ein Bild-Steuerelement für ein Logo auf einer Eingabeseite für Umsätze anordnen.

Steuerelement: | Tool:
Bild-Steuerelement | Bildfeld-Steuerelement

Anmerkungen

Für ein ungebundenes Bild können Sie ein Bild-Steuerelement oder ein ungebundenes Objektfeld verwenden. Der Vorteil eines Bild-Steuerelements liegt darin, dass es schneller angezeigt wird.


 Bezeichnungsfeld-Steuerelement (Formulare und Berichte)

Bezeichnungsfeld-Steuerelement (Formulare und Berichte)

Bezeichnungsfelder auf einem Formular oder Bericht zeigen beschreibenden Text an, wie z.B. Überschriften, Beschriftungen oder kurze Anleitungen. Bezeichnungsfelder haben bestimmte Merkmale:

  • Bezeichnungsfelder zeigen keine Werte aus Feldern oder Ausdrücken an.

  • Bezeichnungsfelder sind immer ungebunden.

  • Bezeichnungsfelder ändern sich nicht, wenn Sie von einem Datensatz zu einem anderen Datensatz wechseln.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Bezeichnung-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Bezeichnung-Steuerelement auf einer Datenzugriffsseite finden Sie unter Bezeichnung-Steuerelement (Datenzugriffsseiten).

Anmerkung

Ein Bezeichnungsfeld kann einem anderen Steuerelement zugeordnet sein. Wenn Sie ein Textfeld erstellen, besitzt dieses z.B. ein zugeordnetes Bezeichnungsfeld, das eine Beschriftung für das Textfeld anzeigt. Dieses Bezeichnungsfeld wird in der Datenblattansicht eines Formulars als Spaltenüberschrift angezeigt.

Wenn Sie ein Bezeichnungsfeld mit dem Tool Bezeichnung erstellen, ist das Bezeichnungsfeld eigenständig, d.h., es ist keinem anderen Steuerelement zugeordnet. Eigenständige Bezeichnungsfelder können Sie für bestimmte Informationen, wie z.B. den Titel eines Formulars oder Berichts, oder anderen beschreibenden Text verwenden. In der Datenblattansicht werden eigenständige Bezeichnungsfelder nicht angezeigt.


 Bezeichnungsfeld-Steuerelement (Datenzugriffsseiten)

Bezeichnungsfeld-Steuerelement (Datenzugriffsseiten)

Bezeichnungsfelder auf einer Datenzugriffsseite zeigen beschreibenden Text an, wie z. B. Überschriften, Beschriftungen oder kurze Anleitungen. Bezeichnungsfelder haben bestimmte Merkmale:

  • Bezeichnungsfelder zeigen keine Werte aus Feldern oder Ausdrücken an.

  • Bezeichnungsfelder ändern sich nicht, wenn Sie von einem Datensatz zu einem anderen wechseln.

Steuerelement: | Tool:
Bezeichnungsfeld | Bezeichnungsfeld-Steuerelement

Anmerkungen

Ein Bezeichnungsfeld kann einem anderen Steuerelement zugeordnet sein. Wenn Sie ein Textfeld erstellen, besitzt dieses z. B. ein zugeordnetes Bezeichnungsfeld, das eine entsprechende Beschriftung anzeigt.

Wenn Sie ein Bezeichnungsfeld mit dem Tool Bezeichnung erstellen, ist das Bezeichnungsfeld eigenständig, d. h., es ist keinem anderen Steuerelement zugeordnet. Eigenständige Bezeichnungsfelder können Sie für bestimmte Informationen, wie z. B. den Titel, oder anderen beschreibenden Text verwenden.


 Linie-Steuerelement (Formulare und Berichte)

Linie-Steuerelement (Formulare und Berichte)

Ein Linie-Steuerelement zeigt auf einem Formular oder Bericht eine horizontale, vertikale oder diagonale Linie an.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Linie-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Linie-Steuerelement auf einer Datenzugriffsseite finden Sie unter Linie-Steuerelement (Datenzugriffsseiten).

Anmerkung

Mit der Schaltfläche Rahmenbreite [image] können Sie die Liniendicke ändern. Mit der Schaltfläche Rahmenfarbe [image] können Sie die Farbe der Linie ändern oder die Linie transparent machen. Die Linienart der Linie (Punkte, Strichlinien usw.) können Sie mit der Eigenschaft BorderStyle ändern.


 Linie-Steuerelement (Datenzugriffsseiten)

Linie-Steuerelement (Datenzugriffsseiten)

Ein Linie-Steuerelement zeigt auf einer Datenzugriffsseite eine horizontale, vertikale oder diagonale Linie an.

Steuerelement: | Tool:
Linie | Linie-Steuerelement

Anmerkungen

Mit der Height-Eigenschaft können Sie die Linienstärke ändern. Mit Linien-/Rahmenfarbe [image] können Sie die Farbe der Linie ändern oder die Linie transparent machen.


 Listenfeld-Steuerelement (Formulare)

Listenfeld-Steuerelement (Formulare)

Ein Listenfeld-Steuerelement zeigt eine Liste von Werten oder Alternativen an. Meistens ist es schneller und einfacher, einen Wert aus einer Liste zu wählen, statt ihn jedesmal neu einzugeben. Eine Auswahlliste unterstützt außerdem dabei, dass jeweils der korrekte Wert in ein Feld eingegeben wird.

Steuerelement: | Tool:

Die Liste eines Listenfelds besteht aus Datenzeilen. Diese Zeilen wiederum können aus einer oder mehreren Spalten bestehen, die mit oder ohne Überschriften angezeigt werden können.

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Listenfeld-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Listenfeld-Steuerelement auf einer Datenzugriffsseite finden Sie unter Listenfeld-Steuerelement (Datenzugriffsseiten).

Anmerkung

Wenn ein mehrspaltiges Listenfeld gebunden ist, speichert Microsoft Access nur die Werte einer Spalte.

Mit Hilfe eines ungebundenen Listenfelds können Sie einen Wert speichern, den Sie für ein anderes Steuerelement verwenden möchten. Sie können z.B. ein ungebundenes Listenfeld verwenden, um die Werte eines anderen Listenfelds oder Werte in einem benutzerdefinierten Dialogfeld zu begrenzen. Sie könnten ein ungebundenes Listenfeld außerdem verwenden, um anhand des Wertes, den Sie aus dem Listenfeld gewählt haben, nach einem Datensatz zu suchen.

Sie sollten statt eines Listenfelds ein Kombinationsfeld verwenden, wenn eine der folgenden Bedingungen zutrifft: Auf Ihrem Formular ist nicht genügend Platz vorhanden, um ein Listenfeld anzuzeigen; Sie möchten in der Lage sein, sowohl neue Werte einzugeben als auch die in der Liste aufgeführten Werte auszuwählen.


 Listenfeld-Steuerelement (Datenzugriffsseiten)

Listenfeld-Steuerelement (Datenzugriffsseiten)

Ein Listenfeld-Steuerelement zeigt eine Liste von Werten oder Alternativen an. Meistens ist es schneller und einfacher, einen Wert aus einer Liste zu wählen, statt ihn jedesmal neu einzugeben. Eine Auswahlliste unterstützt außerdem dabei, dass jeweils der richtige Wert in ein Feld eingegeben wird.

Steuerelement: | Tool:
Listenfeld | Listenfeld-Steuerelement

Die Liste eines Listenfeldes besteht aus Datenzeilen. Diese Zeilen wiederum können aus einer oder mehreren Spalten bestehen, die mit oder ohne Überschriften angezeigt werden können.

Anmerkungen

Wenn ein mehrspaltiges Listenfeld gebunden ist, speichert Microsoft Access nur die Werte einer Spalte.

Mit Hilfe eines ungebundenen Listenfeldes können Sie einen Wert speichern, den Sie für ein anderes Steuerelement verwenden möchten. So können Sie z. B. ein ungebundenes Listenfeld verwenden, um die Werte eines anderen Listenfeldes oder die Werte in einem benutzerdefinierten Dialogfeld zu begrenzen. Sie könnten ein ungebundenes Listenfeld außerdem verwenden, um anhand des Wertes, den Sie im Listenfeld ausgewählt haben, nach einem Datensatz zu suchen.

Wenn auf einem Formular nicht genügend Platz vorhanden ist, um ein Listenfeld anzuzeigen, sollten Sie stattdessen eine Dropdownliste verwenden.


 Video-Steuerelement

Video-Steuerelement

Mit Hilfe des Video-Steuerelements können Sie einer Datenzugriffsseite eine Videodatei (.AVI oder .MOV) hinzufügen.

Tool:
Video-Steuerelement

Anmerkungen

Wenn dieses Steuerelement einer Datenzugriffsseite hinzugefügt wird, zeigt Microsoft Access das Dialogfeld Video einfügen an. Dort wählen Sie den Namen der Videodatei aus, die an dieses Steuerelement gebunden werden soll.

Sie können angeben, ob die Wiedergabe des Videos beim Öffnen der Datenzugriffsseite oder dann beginnen soll, wenn die Maus über das Video-Steuerelement bewegt wird.


 Office Chart-Steuerelement

Office Chart-Steuerelement

Mit Hilfe des Office Chart-Steuerelements können Sie einer Datenzugriffsseite ein Diagramm hinzufügen.

Tool:
Office Chart-Steuerelement

Anmerkungen

Mit Hilfe von Microsoft Office Chart, einer Microsoft Office-Webkomponente, können Sie dynamische, interaktive Diagramme in einer Datenzugriffsseite erstellen, die Sie in Websites für die Anzeige in einem Browser zur Verfügung stellen können. So können Sie z.B. ein Diagramm erstellen und dazu die Daten einer Tabelle verwenden, in der Umsatzzahlen gespeichert sind. Wenn Sie die Umsatzzahlen aktualisieren, wird auch das Diagramm aktualisiert, so dass sich die Benutzer immer die aktuellsten Informationen auf ihren Webseiten anschauen können.

Zum Erstellen eines Diagramms auf einer Datenzugriffsseite ist Microsoft Internet Explorer 5 oder höher erforderlich, doch Benutzer mit Internet Explorer, Version 4.x oder höher, können das Diagramm anzeigen und nach Datenänderungen das aktualisierte Diagramm sehen.


 Office Spreadsheet-Steuerelement

Office Spreadsheet-Steuerelement

Mit Hilfe des Office Spreadsheet-Steuerelements können Sie einer Datenzugriffsseite einige Features einer Microsoft Excel-Kalkulationstabelle hinzufügen.

Tool:
Office Spreadsheet-Steuerelement

Anmerkungen

Sie können einer Datenzugriffsseite ein Spreadsheet-Steuerelement hinzufügen, um dort einige der gleichen Möglichkeiten bereitzustellen, die eine Microsoft Excel-Tabelle dem Benutzer bietet. Unter anderem können Sie Werte eingeben, Formeln hinzufügen und Filter zuweisen. Erstellen Sie mit der unten angebenen Prozedur eine Kalkulationstabelle, in der Sie Ausgangsdaten eingeben oder Daten von einer Webseite oder aus einer Textdatei importieren. Wenn Sie innerhalb der Tabelle Daten aus anderen Steuerelementen der Datenzugriffsseite verwenden möchten, müssen Sie auf diese Steuerelemente in den entsprechenden Zellen der Kalkulationstabelle verweisen.


 Optionsfeld-Steuerelement (Formulare und Berichte)

Optionsfeld-Steuerelement (Formulare und Berichte)

Ein Optionsfeld auf einem Formular oder Bericht ist ein eigenständiges Steuerelement, das einen Wert Ja/Nein aus der zugrunde liegenden Datenquelle anzeigt.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Optionsfeld-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Optionsfeld-Steuerelement auf einer Datenzugriffsseite finden Sie unter Optionsfeld-Steuerelement (Datenzugriffsseiten).

Anmerkung

Wenn Sie ein Optionsfeld, das an ein Feld Ja/Nein gebunden ist, aktivieren bzw. deaktivieren, zeigt Microsoft Access den Wert in der zugrunde liegenden Tabelle so an, wie es der Einstellung der Eigenschaft Format des Feldes entspricht (Ja/Nein, Wahr/Falsch oder Ein/Aus).

Sie können Optionsfelder auch in einer Optionsgruppe verwenden, um Werte anzuzeigen, unter denen gewählt werden kann.

Darüber hinaus kann ein ungebundenes Optionsfeld in einem benutzerdefinierten Dialogfeld verwendet werden, um eine Eingabe des Benutzers entgegenzunehmen.


 Optionsfeld-Steuerelement (Datenzugriffsseiten)

Optionsfeld-Steuerelement (Datenzugriffsseiten)

Ein Optionsfeld auf einer Datenzugriffsseite ist ein eigenständiges Steuerelement, das einen Wert Ja/Nein aus der zugrunde liegenden Datenquelle anzeigt.

Steuerelement: | Tool:
Optionsfeld |

Anmerkungen

Wenn Sie ein Optionsfeld, das an ein Feld Ja/Nein gebunden ist, aktivieren bzw. deaktivieren, zeigt Microsoft Access den Wert in der zugrunde liegenden Tabelle so an, wie es der Einstellung der Format-Eigenschaft des Feldes entspricht (Ja/Nein, Wahr/Falsch oder Ein/Aus).

Sie können Optionsfelder auch in einer Optionsgruppe verwenden, um Werte anzuzeigen, unter denen gewählt werden kann.

Darüber hinaus kann ein ungebundenes Optionsfeld in einem benutzerdefinierten Dialogfeld verwendet werden, um eine Eingabe des Benutzers entgegenzunehmen.


 Optionsgruppe-Steuerelement (Formulare und Berichte)

Optionsgruppe-Steuerelement (Formulare und Berichte)

Eine Optionsgruppe auf einem Formular oder Bericht zeigt eine begrenzte Anzahl an Alternativen an. Eine Optionsgruppe erleichtert die Auswahl eines Wertes, da Sie lediglich auf den gewünschten Wert klicken müssen. In einer Optionsgruppe kann immer nur ein Wert aktiviert sein.

Eine Optionsgruppe besteht aus einem Gruppenrahmen und mehreren Kontrollkästchen, Umschaltflächen oder Optionsfeldern.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Optionsgruppe-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Optionsgruppe-Steuerelement auf einer Datenzugriffsseite finden Sie unter Optionsgruppe-Steuerelement (Datenzugriffsseiten).

Anmerkung

Wenn eine Optionsgruppe an ein Feld gebunden ist, dann ist nur der Gruppenrahmen selbst an das Feld gebunden, nicht die Kontrollkästchen, Umschaltflächen oder Optionsfelder innerhalb des Rahmens. Statt die Eigenschaft ControlSource jedes Steuerelements der Optionsgruppe einzustellen, stellen Sie die Eigenschaft OptionValue jedes Kontrollkästchens, jeder Umschaltfläche oder jedes Optionsfelds auf eine Zahl ein, die sinnvoll für das Feld ist, an das der Gruppenrahmen gebunden ist. Sobald Sie eine Option einer Optionsgruppe ausgewählt haben, stellt Microsoft Access das Feld, an das die Optionsgruppe gebunden ist, auf den Wert ein, den die Eigenschaft OptionValue der ausgewählten Option hat.

Anmerkung Für die Eigenschaft Optionswert wird eine Zahl festgelegt, da der Wert einer Option nur eine Zahl, kein Text, sein kann. Microsoft Access speichert diese Zahl in der zugrunde liegenden Tabelle. Im vorstehenden Beispiel können Sie zum Anzeigen des Namens der Versandfirma an Stelle einer Zahl in der Tabelle Bestellungen eine separate Tabelle namens Versandfirma erstellen, die die Namen der Versandfirmen enthält. Anschließend wandeln Sie das Feld VersandÜber der Tabelle Bestellungen in ein Nachschlage-Feld um, über das die entsprechenden Daten aus der Tabelle Versandfirmen gelesen werden.

Darüber hinaus kann eine Optionsgruppe auf einen Ausdruck eingestellt sein oder ungebunden sein. Eine ungebundene Optionsgruppe können Sie in einem benutzerdefinierten Dialogfeld verwenden, um eine Eingabe des Benutzers entgegenzunehmen und ausgehend vom eingegebenen Wert einen bestimmten Vorgang auszulösen.


 Optionsgruppe-Steuerelement (Datenzugriffsseiten)

Optionsgruppe-Steuerelement (Datenzugriffsseiten)

Eine Optionsgruppe auf einer Datenzugriffsseite zeigt eine begrenzte Anzahl an Alternativen an. Eine Optionsgruppe erleichtert die Auswahl eines Wertes, da Sie lediglich auf den gewünschten Wert klicken müssen. In einer Optionsgruppe kann immer nur ein Wert aktiviert sein.

Eine Optionsgruppe besteht aus einem Gruppenrahmen und mehreren Kontrollkästchen, Umschaltflächen oder Optionsfeldern.

Steuerelement: | Tool:
Optionsgruppe |

Anmerkungen

Ist eine Optionsgruppe an ein Feld gebunden, so ist nur der Gruppenrahmen selbst an das Feld gebunden, nicht die Kontrollkästchen, Umschaltflächen oder Optionsfelder innerhalb des Rahmens. Statt die ControlSource-Eigenschaft jedes Steuerelements der Optionsgruppe einzustellen, stellen Sie die Value-Eigenschaft jedes Kontrollkästchens, jeder Umschaltfläche oder jedes Optionsfeldes auf eine Zahl ein, die sinnvoll für das Feld ist, an das der Gruppenrahmen gebunden ist. Sobald Sie eine Option einer Optionsgruppe ausgewählt haben, stellt Microsoft Access das Feld, an das die Optionsgruppe gebunden ist, auf den Wert ein, den die Value-Eigenschaft der ausgewählten Option hat.

Ausgewählte Option in einer Optionsgruppe

Anmerkung Für die Value-Eigenschaft wird eine Zahl festgelegt, da der Wert einer Optionsgruppe nur eine Zahl und kein Text sein kann. Microsoft Access speichert diese Zahl in der zugrunde liegenden Tabelle. Im vorstehenden Beispiel können Sie zum Anzeigen des Namens der Versandfirma statt einer Zahl in der Tabelle Bestellungen eine separate Tabelle namens Versandfirmen erstellen, die die Namen der Versandfirmen enthält. Anschließend wandeln Sie das Feld VersandÜber der Tabelle Bestellungen in ein Nachschlage-Feld um, über das die entsprechenden Daten aus der Tabelle Versandfirmen gelesen werden.

Darüber hinaus kann eine Optionsgruppe auf einen Ausdruck eingestellt oder ungebunden sein. Eine ungebundene Optionsgruppe können Sie in einem benutzerdefinierten Dialogfeld verwenden, um eine Eingabe des Benutzers entgegenzunehmen und ausgehend vom eingegebenen Wert einen bestimmten Vorgang auszulösen.


 Page

Page

Ein Page-Objekt entspricht einer einzelnen Seite in einem Registersteuerelement.

Jedes Page-Objekt kann eines oder mehrere Steuerelemente, wie z.B. Textfelder oder Optionsfelder enthalten. Die Steuerelemente in einem Page-Objekt gehören zur Auflistung Controls dieses Page-Objekts. Um mit einem Steuerelement in einem Page-Objekt arbeiten zu können, müssen Sie innerhalb der Auflistung Controls des Objekts Page auf dieses Steuerelement verweisen.

Mit dem Registersteuerelement können Sie ein Einzelformular oder ein Dialogfeld erstellen, das verschiedene Registerkarten enthält. Auf den zugehörigen Seiten können Sie zusammengehörige Optionen oder Daten gruppieren. Mit Hilfe eines Registersteuerelements können Sie z.B. auf einem Formular Personal allgemeine von persönlichen Informationen trennen.

Steuerelement: | Tool:


 Seitenwechsel-Steuerelement

Seitenwechsel-Steuerelement

Ein Seitenwechsel-Steuerelement kennzeichnet auf einem Formular oder Bericht den Anfang einer neuen Bildschirm- oder Druckseite.

Steuerelement: | Tool:

Anmerkung

Auf einem Formular ist ein Seitenwechsel nur dann aktiv, wenn Sie die Eigenschaft DefaultView des Formulars auf Einzelnes Formular eingestellt haben. Seitenumbrüche wirken sich nicht auf das Datenblatt eines Formulars aus.

Drücken Sie in der Formularansicht die BILD-AUF- oder BILD-AB-TASTE, um zum vorherigen bzw. nächsten Seitenwechsel zu gelangen.

Sie sollten Seitenumbrüche über oder unter anderen Steuerelementen anordnen. Wenn Sie einen Seitenwechsel in dieselbe Zeile wie ein anderes Steuerelement setzen, werden die Daten dieses Steuerelements geteilt.


Parameterabfrage

Eine Parameterabfrage ist eine Auswahlabfrage, die die Flexibilität einer anderen Abfrage erweitert, indem sie den Benutzer jedesmal, wenn die Abfrage ausgeführt wird, dazu auffordert, bestimmte Kriterien einzugeben. Eine Parameterabfrage ist genaugenommen kein eigener Abfragetyp, sondern sie erweitert lediglich die Flexibilität einer anderen Abfrage.


 Office PivotTable-Steuerelement

Office PivotTable-Steuerelement

Mit Hilfe des Office PivotTable-Steuerelements können Sie einer Datenzugriffsseite eine Pivot-Liste hinzufügen.

Tool:
Office PivotTable-Steuerelement

Erstellen einer PivotTable-Liste in einer Datenzugriffsseite

Was ist ein PivotTable-Formular ?


 Datensatznavigation-Steuerelement

Datensatznavigation-Steuerelement

Mit Hilfe des Datensatznavigation-Steuerelements können Sie einer Datenzugriffsseite Datensatznavigation hinzufügen.

Tool:
Datensatznavigation-Steuerelement

Anmerkungen

Das Datensatznavigation-Steuerelement kann Schaltflächen für folgende Aufgaben enthalten:

Erster Datensatz | Vorheriger Datensatz | Nächster Datensatz
Letzter Datensatz | Neuer Datensatz | Löschen
Datensatz speichern | Rückgängig | Aufsteigend sortieren
Absteigend sortieren | Auswahlbasierter Filter | Filter umschalten


 Rechteck-Steuerelement (Formulare und Berichte)

Rechteck-Steuerelement (Formulare und Berichte)

Ein Rechteck-Steuerelement zeigt auf einem Formular oder Bericht ein Rechteck an.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Rechteck-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Rechteck-Steuerelement auf einer Datenzugriffsseite finden Sie unter Rechteck-Steuerelement (Datenzugriffsseite).

Anmerkung

Sie können ein Rechteck und die darin enthaltenen Steuerelemente als Einheit verschieben, indem Sie den Mauszeiger diagonal über das gesamte Rechteck ziehen, um alle Steuerelemente auszuwählen. Die gesamte Auswahl kann dann an eine neue Position verschoben werden.


 Rechteck-Steuerelement (Datenzugriffsseiten)

Rechteck-Steuerelement (Datenzugriffsseiten)

Ein Rechteck-Steuerelement zeigt auf einer Datenzugriffsseite ein Rechteck an.

Steuerelement: | Tool:
Rechteck | Rechteck-Steuerelement

Anmerkungen

Sie können ein Rechteck und die darin enthaltenen Steuerelemente als Einheit verschieben, indem Sie den Mauszeiger diagonal über das gesamte Rechteck ziehen, um alle Steuerelemente auszuwählen. Die gesamte Auswahl kann dann an eine neue Position verschoben werden.


 Lauftext-Steuerelement

Lauftext-Steuerelement

Mit Hilfe des Lauftext-Steuerelements können Sie einer Datenzugriffsseite animierten Text hinzufügen.

Tool:
Lauftext-Steuerelement

Anmerkungen

Mit Hilfe eines Lauftext-Steuerelements, das oft als Laufrahmen bezeichnet wird, können Sie auf einer Datenzugriffsseite sich bewegenden Text anzeigen. Lauftext zieht die Aufmerksamkeit auf eine Textzeile, wie z.B. eine Schlagzeile oder eine wichtige Bekanntmachung. Den in einem Feld einer Datenbank enthaltenen Text zeigen Sie an, indem Sie das Lauftext-Steuerelement an das Feld binden. Sie können Lauftext individuell anpassen, indem Sie Optionen, wie die Laufrichtung, die Geschwindigkeit und die Art der Bewegung, einstellen.

Einige Webbrowser können keinen Lauftext anzeigen. In diesen Fällen wird eine normale Textzeile im Steuerelement angezeigt.


Auswahlabfrage

Eine Auswahlabfrage stellt Fragen über die Daten, die in Ihrer Datenbank gespeichert sind, und gibt das Ergebnis der Abfrage zurück, ohne Änderungen an den Daten vorzunehmen. Sobald die Ergebnisgruppe angezeigt wird, können Sie die Daten, die in den zugrunde liegenden Tabellen gespeichert sind, sehen und in einigen Fällen auch bearbeiten. Im Gegensatz dazu nimmt eine Aktionsabfrage Änderungen an den jeweiligen Daten vor.


SQL-spezifische Abfrage

Eine SQL-spezifische Abfrage ist ein Abfrage, die nur dadurch erstellt werden kann, dass in der SQL-Ansicht eine SQL-Anweisung geschrieben wird. Union-Abfragen, SQL Pass-Through-Abfragen und Datendefinitionsabfragen gehören zu den SQL-spezifischen Abfragen.

SQL-spezifische Abfrage | Beschreibung
Union-Abfrage | Eine SQL-spezifische Auswahlabfrage, die einander entsprechende Felder aus mehreren Tabellen oder Abfragen in einer Tabelle kombiniert. Eine Union-Abfrage, die z.B. auf den Tabellen Kunden und Lieferanten basiert, liefert als Ergebnis ein Snapshot, das alle betroffenen Datensätze aus beiden Tabellen enthält.
Pass-Through-Abfrage | Eine SQL-spezifische Abfrage, die Befehle direkt an einen SQL-Datenbank-Server (wie z.B. Microsoft SQL Server) sendet. Mit einer SQL Pass-Through-Abfrage arbeiten Sie mit den Tabellen auf dem Server, statt diese mit Ihrer Microsoft Access-Datenbank zu verknüpfen.
Datendefinitionsabfrage | Eine SQL-spezifische Abfrage, die einen Index erstellen oder löschen bzw. eine Tabelle erstellen, ändern oder löschen kann.


 Registersteuerelement

Registersteuerelement

Ein Registersteuerelement enthält mehrere Seiten, auf denen Sie andere Steuerelemente anordnen können, wie z.B. Textfelder oder Optionsfelder. Sobald ein Benutzer auf eine Registerkarte geklickt hat, wird die zugehörige Seite zur aktiven Seite.

Mit einem Registerkarten-Steuerelement können Sie ein Formular oder Dialogfeld erstellen, das mehrere Registerkarten enthält, wobei Sie auf jeder dieser Registerkarten zusammengehörende Optionen oder Daten gruppieren können. Sie können z.B. auf dem Formular Personal ein Registerkarten-Steuerelement verwenden, um allgemeine und persönliche Informationen voneinander zu trennen.

Steuerelement: | Tool:


 Textfeld-Steuerelement (Formulare und Berichte)

Textfeld-Steuerelement (Formulare und Berichte)

Ein Textfeld auf einem Formular oder Bericht zeigt Daten an, die aus einer Datenquelle stammen. Ein Textfeld dieses Typs wird als gebundenes Textfeld bezeichnet, da es an Daten eines Feldes gebunden ist. Textfelder können auch ungebunden sein. Sie können z.B. ein ungebundenes Textfeld erstellen, um das Ergebnis einer Berechnung anzuzeigen oder eine Eingabe des Benutzers entgegenzunehmen. Die Daten eines ungebundenen Textfelds werden nicht in der jeweiligen Datenbank gespeichert.

Steuerelement: | Tool:

Anmerkung Dieses Steuerelement ist nicht identisch mit dem Textfeld-Steuerelement für dynamisches HTML, das auf einer Datenzugriffsseite verwendet wird. Informationen zu einem Textfeld-Steuerelement auf einer Datenzugriffsseite finden Sie unter Textfeld-Steuerelement (Datenzugriffsseiten).


 Textfeld-Steuerelement (Datenzugriffsseiten)

Textfeld-Steuerelement (Datenzugriffsseiten)

Ein Textfeld auf einer Datenzugriffsseite zeigt Daten an, die aus einer Datenquelle stammen. Ein Textfeld dieses Typs wird als gebundenes Textfeld bezeichnet, da es an Daten eines Feldes gebunden ist. Textfelder können auch ungebunden sein. So können Sie z. B. ein ungebundenes Textfeld erstellen, um das Ergebnis einer Berechnung anzuzeigen oder eine Eingabe des Benutzers entgegenzunehmen. Die Daten eines ungebundenen Textfeldes werden nicht in der jeweiligen Datenbank gespeichert.

Steuerelement: | Tool:
Textfeld | Textfeld-Steuerelement


 Umschaltfläche-Steuerelement

Umschaltfläche-Steuerelement

Ein Umschaltfläche-Steuerelement auf einem Formular oder Bericht ist ein eigenständiges Steuerelement, mit dem ein Wert Ja/Nein aus der jeweils zugrunde liegenden Datenquelle angezeigt wird.

Steuerelement: | Tool:

Anmerkung

Wenn Sie auf eine Umschaltfläche klicken, die an ein Feld Ja/Nein gebunden ist, zeigt Microsoft Access den Wert in der zugrunde liegenden Tabelle so an, wie es der Einstellung der Eigenschaft Format des Feldes entspricht (Ja/Nein, Wahr/Falsch oder Ein/Aus).

Umschaltflächen eignen sich besonders, um in einer Optionsgruppe zusammen mit anderen Schaltflächen verwendet zu werden.

Darüber hinaus kann eine Umschaltfläche in einem benutzerdefinierten Dialogfeld verwendet werden, um eine Eingabe des Benutzers entgegenzunehmen.


 Ungebundenes Objektfeld-Steuerelement

Ungebundenes Objektfeld-Steuerelement

Ein ungebundenes Objektfeld-Steuerelement zeigt ein Bild, ein Diagramm oder ein OLE-Objekt an, das nicht in einer Tabelle gespeichert ist. Sie können z. B. mit einem ungebundenen Objektfeld ein Diagramm anzeigen, das Sie mit Microsoft Graph erstellt und gespeichert haben.

Steuerelement: | Tool:

Anmerkung

Mit diesem Steuerelement können Sie aus einem Microsoft Access-Formular oder -Bericht heraus ein Objekt mit einer anderen Anwendung erstellen oder mit der Anwendung bearbeiten, mit der das Objekt ursprünglich erstellt wurde.

Wenn Sie Objekte anzeigen möchten, die in einer Microsoft Access-Datenbank gespeichert sind, verwenden Sie ein gebundenes Objektfeld-Steuerelement.

In einem ungebundenen Objektfeld wird für jeden Datensatz dasselbe Objekt angezeigt.

In einem ungebundenen Objektfeld kann ein verknüpftes oder ein eingebettetes Objekt angezeigt werden.

Tipp Sie können sowohl ein ungebundenes Objektfeld als auch ein Bild-Steuerelement dazu verwenden, auf einem Formular oder Bericht ein ungebundenes Bild anzuzeigen. Der Vorteil eines ungebundenen Objektfelds liegt darin, dass Sie das jeweilige Objekt direkt vom Formular oder Bericht aus bearbeiten können. Ein Bild-Steuerelement hat dagegen den Vorteil, dass es schneller angezeigt wird.


 Info über Befehlszeilenoptionen

Info über Befehlszeilenoptionen

Sie können automatisch eine Datenbank öffnen, ein Makro ausführen, den Namen eines Benutzerkontos oder ein Kennwort eingeben und andere Optionen ausführen lassen, wenn Sie beim Starten von Microsoft Access in der Befehlszeile Optionen angeben.

Sie können Befehlszeilenoptionen für Microsoft Access entweder im Windows Startmenü oder für eine Verknüpfung angeben. Wenn Sie im Windows Startmenü Befehlszeilenoptionen angeben, wird Microsoft Access mit den angegebenen Optionen gestartet, wenn Sie das Menü Start verwenden. Wenn Sie Befehlszeilenoptionen für eine Verknüpfung angeben, wird Microsoft Access bei deren Verwendung mit den angegebenen Optionen gestartet. Um Microsoft Access auf andere Weise zu starten, können Sie mehrere Verknüpfungen erstellen und diese dem Windows Startmenü hinzufügen oder auf dem Desktop bzw. in einem Ordner ablegen. Weitere Informationen finden Sie in der Hilfe für Windows unter "Verknüpfungen".

Zurück zu Starten von Microsoft Access mit Befehlszeilenoptionen


Info über das Erstellen einer Datenbank

Microsoft Access bietet zwei Möglichkeiten zum Erstellen einer Datenbank. Sie können eine leere Datenbank erstellen und danach Tabellen, Formulare, Berichte und andere Objekte hinzufügen. Dies ist die flexibelste Methode; sie erfordert jedoch, dass Sie jedes Datenbankelement einzeln definieren. Alternativ können Sie einen Datenbank-Assistenten verwenden, um in einer Operation die erforderlichen Tabellen, Formulare und Berichte für den ausgewählten Datenbanktyp zu erstellen. Dies ist die einfachste Methode, um mit dem Erstellen einer Datenbank zu beginnen. Beide Methoden erlauben, dass Sie Ihre Datenbank nach dem Erstellen zu einem beliebigen Zeitpunkt ändern und erweitern.

Zurück zu Erstellen einer Datenbank


Info über das Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular

Wenn Sie eine Sortierreihenfolge in der Formular- oder Datenblattansicht angeben, können Sie einfache Sortierungen vornehmen, d. h. Sie können alle Datensätze in aufsteigender oder absteigender Reihenfolge (nicht jedoch in beiden Reihenfolgen) sortieren. Wenn Sie eine Sortierreihenfolge in der Entwurfsansicht einer Abfrage oder im Fenster Spezialfilter/-sortierung angeben, können Sie komplexe Sortierungen vornehmen, d. h. Sie können Datensätze über einige Felder in aufsteigender Reihenfolge, über andere Felder in absteigender Reihenfolge sortieren.

Unabhängig davon, wo Sie die Sortierreihenfolge festlegen, speichert Microsoft Access die Sortierreihenfolge, wenn Sie das Formular oder Datenblatt speichern. Die Sortierreihenfolge wird automatisch wieder angewendet, wenn Sie das Objekt erneut öffnen, oder es einem neuen Formular oder Bericht zu Grunde legen.

Zurück zu Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular.


Verwenden von integrierten Treibern, ODBC-Treibern und ODBC-Datenquellen

Was möchten Sie tun?

Weitere Informationen zu den Unterschieden zwischen ODBC-Treibern und integrierten Treibern für externe Daten anzeigen

Weitere Informationen zu ODBC-Datenquellen anzeigen

ODBC-Datenquellen einrichten


 Öffnen von Berichts-Snapshots

Öffnen von Berichts-Snapshots

  1. Starten Sie den Windows Explorer.

  2. Suchen Sie den Ordner, der den Berichts-Snapshot enthält.

  3. Doppelklicken Sie auf das Snapshot-Symbol.

Weitere Informationen über das Öffnen von Berichts-Snapshots.


Arbeiten mit Berichts-Snapshots und dem Snapshot-Viewer

Was möchten Sie tun?

Informationen über Berichts-Snapshots und den Snapshot-Viewer erhalten

Einen Berichts-Snapshot erstellen

Einen Berichts-Snapshot unter Verwendung der AusgabeIn-Aktion erstellen und im Web publizieren

Einen Berichts-Snapshot in einer E-Mail-Nachricht unter Verwendung der SendenObjekt-Aktion versenden


Hinzufügen eines gebundenen Objekts zu einem Formular oder Bericht

Was möchten Sie tun?

Ein Objekt erstellen und einfügen

Ein vorhandenes Objekt einfügen

Einen Teil eines vorhandenen Objekts einfügen

Auf einem Formular eine Verknüpfung zu einem vorhandenen Objekt erstellen

Eine Verknüpfung zu einem Teil eines vorhandenen Objekts erstellen

Beispiele zur Verwendung ungebundener, gebundener, eingefügter und verknüpfter Objekte einfügen

Nicht sicher, welche Auswahl Sie treffen sollen?


Hinzufügen oder Manipulieren von Feldern

Was möchten Sie tun?

Felder zum Entwurfsbereich in einer Abfrage hinzufügen

Ein Feld im Entwurfsbereich in einer Abfrage verschieben

Ein Feld aus dem Entwurfsbereich in einer Abfrage entfernen

Ein Feld im Entwurfsbereich in einer Abfrage hinzufügen

Ein Feld im Ergebnis einer Abfrage ein- oder ausblenden

Den Namen eines Feldes ändern

Eigenschaften für eine Abfrage, für ihre Felder oder ihre Feldlisten einstellen

Informationen zur Verwendung des Sternchens im Abfrageentwurfsbereich anzeigen

Unter Verwendung einer Abfrage Berechnungen durchführen oder Feldwerte manipulieren


Hinzufügen, Entfernen oder Formatieren eines Formularkopfes, eines Seitenkopfes oder eines anderen Bereichs

Was möchten Sie tun?

Einen Formularkopf und -fuß oder einen Seitenkopf und -fuß hinzufügen

Die Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Formular oder Bericht ändern

Ein Formular, einen Bericht, einen Bereich oder ausgewählte Steuerelemente unter Verwendung vordefinierter Formate formatieren


Hinzufügen, Entfernen oder Formatieren eines Berichtskopfes, eines Seitenkopfes oder eines anderen Bereichs

Was möchten Sie tun?

Einen Berichtskopf oder -fuß hinzufügen oder entfernen

Die Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Formular oder Bericht ändern

Ein Formular, einen Bericht, einen Bereich oder ausgewählte Steuerelemente unter Verwendung vordefinierter Formate formatieren


Hinzufügen, Entfernen oder Formatieren eines Kopf-, Fuß- oder sonstigen Bereichs in einer Datenzugriffsseite

Was möchten Sie tun?

Einen ungebundenen Bereich zu einer Datenzugriffsseite hinzufügen, die noch keinen besitzt

Einen Gruppenkopf hinzufügen

Zwei Gruppenköpfe zusammenführen

Einen Gruppenfuß hinzufügen oder entfernen

Einen Beschriftungsbereich für eine Gruppe hinzufügen oder entfernen

Einen Navigationsbereich für eine Gruppe hinzufügen oder entfernen

Die Größe eines Kopf-, Fuß- oder sonstigen Bereichs ändern

Eine Datenzugriffsseite mit Hilfe eines Designs formatieren


Hinzufügen eines ungebundenen Objekts zu einem Formular oder Bericht

Was möchten Sie tun?

Ein Objekt erstellen und einfügen

Ein vorhandenes Objekt einfügen

Einen Teil eines vorhandenen Objekts einfügen

Eine Verknüpfung zu einem vorhandenen Objekt erstellen

Eine Verknüpfung zu einem Teil eines vorhandenen Objekts erstellen

Beispiele zur Verwendung ungebundener, gebundener, eingefügter und verknüpfter Objekte anzeigen

Sind Sie nicht sicher, welche Auswahl Sie treffen sollen?


 Hinzufügen eines ungebundenen Bildes zu einem Formular, einem Bericht oder einer Datenzugriffsseite

Hinzufügen eines ungebundenen Bildes zu einem Formular, einem Bericht oder einer Datenzugriffsseite

Wie Sie ein Bild zu einem Formular, einem Bericht oder einer Datenzugriffsseite hinzufügen, hängt davon ab, wie das Bild verwendet werden soll und ob Sie in einem Formular, einem Bericht oder einer Datenzugriffsseite arbeiten.

Dieses Thema enthält Referenzinformationen über:

Formulare und Berichte

Datenzugriffsseiten

Formulare und Berichte

Wie Sie ein ungebundenes Bild hinzufügen, hängt davon ab, ob Sie es als ein Hintergrundbild (Wasserzeichen), das das gesamte Fenster ausfüllt, oder als Bild, das in einem Steuerelement erscheint, anzeigen möchten. Wenn Sie ein Hintergrundbild hinzufügen möchten, verwenden Sie die Bild-Eigenschaft (Picture) des Formulars oder Berichts. Wenn Sie ein Bild zu einem Steuerelement hinzufügen möchten, verwenden Sie ein Bild-Steuerelement oder ein ungebundenes Objektfeld.

Welches Steuerelement Sie für ein Bild im Vordergrund verwenden, ein Bild-Steuerelement oder ein Objektfeld, hängt davon ab, ob Sie das Bild direkt im Formular oder Bericht bearbeiten möchten oder nicht. Wenn Sie das Bild nicht aktualisieren müssen, können Sie es unter Verwendung eines Bild-Steuerelements hinzufügen. Wenn das Bild jedoch aktualisiert werden muss, fügen Sie es unter Verwendung eines Objektfelds hinzu. Wenn Sie das Bild dann bearbeiten möchten, doppelklicken Sie im Formular oder Bericht auf das Objekt, um die Anwendung zu öffnen, in der Sie das Objekt erstellt haben. Für die meisten ungebundenen Bilder sollten Sie in der Regel eher ein Bild-Steuerelement verwenden, da diese wesentlich schneller geladen werden als Objektfelder.

Sie können Bilder in ein Formular oder einen Bericht einfügen oder mit einem Formular oder einem Bericht verknüpfen. Wenn Sie ein Bild in ein Formular oder einen Bericht einfügen, speichert Microsoft Access das Bild in Ihrer Datenbankdatei. Eingefügte Objekte stehen jederzeit zur Verfügung. Wenn Sie das Bild im Formular oder Bericht ändern, ändert sich das Bild in Ihrer Datenbank.

Wenn Sie eine Verknüpfung zu einem Bild erstellen, können Sie das Bild direkt im Formular oder Bericht anzeigen und ändern, die Änderungen werden jedoch in der Original-Objektdatei, nicht in der Datenbankdatei durchgeführt. Sie können die Objektdatei auch separat ändern; dies bewirkt, dass die letzten Änderungen beim nächsten Öffnen des Formulars oder Berichts angezeigt werden. Das Verknüpfen eines Bildes eignet sich in erster Linie für umfangreiche Dateien, die Sie nicht zu Ihrer Datenbank hinzufügen möchten, und für Dateien, die Sie in mehreren Formularen und Berichten verwenden möchten. Sobald ein verknüpftes Objekt verschoben wird, muss jedoch die Verknüpfung wiederhergestellt werden.

Zurück zum Anfang

Datenzugriffsseiten

Wie Sie ein ungebundenes Bild zu einer Datenzugriffsseite hinzufügen, hängt davon ab, ob Sie es als ein Hintergrundbild (Wasserzeichen), das das gesamte Fenster ausfüllt, oder als Bild, das in einem Steuerelement erscheint, anzeigen möchten. Wenn Sie ein Hintergrundbild zu einer Datenzugriffsseite hinzufügen möchten, können Sie das Bild mit Hilfe der Optionen im Menü Format einsetzen. Möchten Sie hingegen ein Bild hinzufügen, das in einem Steuerelement erscheint, verwenden Sie das Bild-Steuerelement.

Nachdem Sie ein Bild in eine Datenzugriffsseite eingefügt haben, können Sie es nicht mehr bearbeiten. Beim Einsetzen des Bildes in die Datenzugriffsseite wird das Bild den Hilfsdateien hinzugefügt, die zu der Datenzugriffsseite gehören; das Bild wird nicht in der Datenzugriffsseite gespeichert. Wenn Sie eine Datenzugriffsseite an einen anderen 'Speicherort verschieben wollen, kopieren Sie sie nicht, sondern speichern Sie die Datenzugriffsseite am neuen Speicherort. Das Bild wird dann automatisch ebenfalls dort gespeichert.

Zurück zum Anfang

Zurück zu Hinzufügen eines ungebundenen Bildes


Analysieren oder Verwalten Ihrer Access-Datenbank

Was möchten Sie tun?

Ein Übersichtsformular mit Hilfe des Übersichts-Managers erstellen

Ein mit dem Datenbank-Assistenten erstelltes Übersichtsformular ändern

Festlegen, wie Microsoft Access eine Datenbank oder Anwendung starten soll

Daten importieren oder verknüpfen

Eine Tabelle unter Verwendung des Tabellenanalyse-Assistenten in verknüpfte Tabellen aufteilen

Entwurfsmerkmale für Datenbankobjekte anzeigen oder drucken

Die Datenbankleistung mit Hilfe des Leistungsanalyse-Assistenten optimieren

Eine Datenbank komprimieren, um den mit Dateien belegten und den freien Festplattenplatz zu defragmentieren

Eine Datenbank beim Schließen automatisch komprimieren

Ein Replikat Ihrer Datenbank erstellen


Berechnen der Summe, des Durchschnitts, der Anzahl oder einer anderen Funktion für die Datensätze in einer Abfrage

Was möchten Sie tun?

Funktionen für alle Datensätze in einer Abfrage durchführen

Funktionen für Datensatzgruppen in einer Abfrage durchführen

Weitere Informationen zu den verschiedenen Funktionen und deren Einsatzmöglichkeiten erhalten

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Ändern eines Feldnamens in einer Abfrage

Ändern eines Feldnamens in einer Abfrage

Sie können ein Feld in einer Abfrage umbenennen, wenn Sie den Inhalt des Feldes genauer beschreiben möchten. Dies ist besonders dann hilfreich, wenn Sie ein neues berechnetes Feld definieren oder eine Summe, eine Anzahl oder eine andere Funktion für ein vorhandenes Feld berechnen lassen. Wenn Sie in einem solchen Fall keinen Namen eingeben, weist Microsoft Access Namen wie z.B. Ausdr1 oder Summe von Stückzahl zu. Der neue Feldname muss den Benennungskonventionen für Objekte entsprechen.

Was möchten Sie tun?

Neue Feldnamen durch Ändern dieser Namen im Entwurfsbereich anzeigen

Neue Feldnamen durch Ändern der Einstellung der Eigenschaft Beschriftung anzeigen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Erstellen und Verwalten eines Übersichtsformulars

Wenn Sie zum Erstellen einer Datenbank den Datenbank-Assistenten verwenden, erstellt Microsoft Access automatisch eine Übersicht, die das Bewegen in der Datenbank erleichtert. Diese Übersicht enthält Schaltflächen zum Öffnen von Formularen und Berichten (oder zum Öffnen weiterer Übersichten, die das Öffnen zusätzlicher Formulare und Berichte erlauben), zum Beenden von Microsoft Access oder zum Anpassen der Übersicht an spezielle Erfordernisse. Sie können eine ähnliche Übersicht mit Hilfe des Übersichts-Managers erstellen.

Was möchten Sie tun?

Ein Übersichtsformular unter Verwendung des Übersichts-Managers erstellen

Eine neue Übersicht, die aus der Eröffnungsübersicht geöffnet werden kann, erstellen

Eine bestehende Übersicht ändern

Die beim Öffnen der Datenbank automatisch angezeigte Übersicht ändern

Eine Übersicht löschen


Berechnen von Summen, Durchführen anderer Berechnungen oder Manipulieren von Feldwerten

Was möchten Sie tun?

Unter Verwendung einer Abfrage Berechnungen durchführen oder Feldwerte manipulieren

Informationen zum Arbeiten mit leeren Feldern in Abfragen anzeigen

Eine Kreuztabellenabfrage ohne Verwendung eines Assistenten erstellen

Ein Beispiel für eine Kreuztabellenabfrage anzeigen


Konvertieren einer gesicherten Datenbank aus einer früheren Version von Microsoft Access

Was möchten Sie tun?

Informationen zum Konvertieren einer gesicherten Datenbank aus einer früheren Version von Microsoft Access erhalten

Eine gesicherte Datenbank aus Microsoft Access Version 2.0 konvertieren, wenn alle Benutzer auf Microsoft Access 2000 aktualisieren

Eine gesicherte Datenbank aus Microsoft Access 95 oder 97 konvertieren, wenn alle Benutzer auf Microsoft Access 2000 aktualisieren

Informationen zur gemeinsamen Nutzung einer gesicherten Datenbank aus einer früheren Microsoft Access-Version in mehreren verschiedenen Versionen von Microsoft Access erhalten

Eine Arbeitsgruppen-Informationsdatei aus einer früheren Version von Microsoft Access konvertieren


Kopieren oder Verschieben von Elementen

Diese Seite enthält Hyperlinks zu folgenden Themenbereichen:

Kopieren oder Verschieben von Daten

Kopieren und Einfügen mehrerer Elemente

Kopieren oder Verschieben einer Access-Datendatei, eines Datenbankobjekts oder eines anderen Elements

Kopieren oder Verschieben von Daten

Daten von einem Feld in ein anderes kopieren oder verschieben

Daten aus mehreren Feldern in der Datenblattansicht kopieren oder verschieben

Datensätze in ein Datenblatt kopieren oder verschieben

Datensätze in ein Formular kopieren oder verschieben

Datensätze aus Microsoft Access in eine andere Anwendung kopieren oder verschieben

Datensätze aus einer anderen Anwendung in Microsoft Access kopieren oder verschieben

Zurück zum Anfang

Kopieren und Einfügen mehrerer Elemente

Informationen zum Zusammenstellen und Einfügen mehrerer Elemente

Zusammenstellen und Einfügen mehrerer Elemente

Alle Elemente aus der Office-Zwischenablage löschen

Den Inhalt der Office-Zwischenablage anzeigen

Bestimmte Elemente aus der Office-Zwischenablage einfügen

Zurück zum Anfang

Kopieren oder Verschieben einer Access-Datendatei, eines Datenbankobjekts oder eines anderen Elements

Kopieren oder verschieben einer Access-Datenbank oder eines Microsoft Access.Projekts

Kopieren oder verschieben eines Feldes, eines Steuerelements, eines Textabschnitts, einer Makroaktion oder eines anderen Elements

Informationen zum Kopieren von Datenbankobjekten

Kopieren von Datenbankobjekten mit dem Befehl Kopieren

Kopieren von Datenbankobjekten mit dem Befehl Speichern unter

Zurück zum Anfang


Erstellen von Benutzer- oder Gruppenkonten und Erteilen von Berechtigungen

Umgang mit Benutzer- und Gruppenkonten

Umgang mit Berechtigungen


Erstellen einer Aktionsabfrage

Was möchten Sie tun?

Eine Tabellenerstellungsabfrage erstellen

Eine Löschabfrage erstellen

Eine Anfügeabfrage erstellen

Eine Aktualisierungsabfrage erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Erstellen von Diagrammen in Formularen oder Berichten

In den meisten Fällen erstellen Sie ein Diagramm mit Hilfe des Diagramm-Assistenten. Auf Basis der von Ihnen festgelegten Daten bestimmt der Diagramm-Assistent, ob die Daten aller Felder in einem einzigen globalen Diagramm dargestellt werden sollen oder ob für jeden Datensatz ein separates Diagramm angezeigt wird. Auf diese Weise können Sie beim Blättern von einem Datensatz zum nächsten immer ein anderes Diagramm sehen, das nur die Daten aus dem aktuellen Datensatz darstellt. Wenn der Diagramm-Assistent ein globales Diagramm für alle Daten erstellt, Sie jedoch Diagramme für jeden einzelnen Datensatz wünschen, können Sie das Diagramm mit einem bestimmten Datensatz verknüpfen.

Um den Diagramm-Assistenten nutzen zu können, muss Microsoft Graph 2000 installiert sein. Sie können ein Diagramm auch erstellen, indem Sie ein vorhandenes Diagramm aus einer externen Datei hinzufügen.

Was möchten Sie tun?

Ein neues Diagramm zu einem Formular oder Bericht hinzufügen

Ein vorhandenes Diagramm in einem Formular oder Bericht mit einem bestimmten Datensatz verknüpfen

Ein vorhandenes Diagramm zu einem Formular oder Bericht hinzufügen

Informationen über Diagramme in Formularen, Berichten und Datenzugriffsseiten erhalten


Erstellen einer benutzerdefinierten Hilfe für ein Formular, einen Bericht oder ein Steuerelement

Was möchten Sie tun?

Ein benutzerdefiniertes QuickInfo (InfoFeld) für eine Symbolleistenschaltfläche erstellen

Direkthilfe-Tipps für Symbolleistenschaltflächen oder Menübefehle erstellen

Einen Tipp für ein Steuerelement in einem Formular erstellen

Statusleistentext für ein Steuerelement oder Formular hinzufügen

Hilfethemen erstellen, die angezeigt werden, wenn Sie auf die Schaltfläche Direkthilfe in einem Formular klicken

Einem Formular die Schaltfläche Direkthilfe hinzufügen

Eine kompilierte Hilfedatei erstellen, die benötigte Informationen zu einem Formular, Bericht oder Steuerelement anzeigt, wenn F1 gedrückt wird

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Erstellen eines Formulars ohne Assistenten

Unter Verwendung der Schritte im vorliegenden Thema können Sie mit der Erstellung eines Formulars beginnen und das Formular fertig stellen. Sie können viele dieser Schritte für die Erstellung beliebiger Formulare verwenden. Andere Schritte verwenden Sie nur für eine bestimmte Art von Formular, z. B. ein Formular, das Daten aus mehr als einer Tabelle anzeigt. Verwenden Sie nur die Schritte, die für die Art von Formular relevant sind, das Sie gerade erstellen möchten. Für andere Aufgaben bezüglich der Erstellung von Formularen ziehen Sie den Antwort-Assistenten zurate.

Anzeigen von Beispielen zur Definition und Funktionsweise von Formularen

  1. Starten eines Formulars

    Erstellen eines leeren Formulars und Auswählen einer Datenquelle

    Anzeigen von Beispielen zu unterschiedlichen Tools, die Sie zum Entwerfen eines Formulars verwenden können

  2. Hinzufügen von Kopf- und Fußzeilen

    Anzeigen von Informationen zur Verwendung von Bereichen in einem Formular

    Hinzufügen oder Entfernen eines Formularkopfes und -fußes oder eines Seitenkopfes und -fußes

    Ändern der Größe einer Kopfzeile, Fußzeile oder eines anderen Bereiches

  3. Anzeigen von Daten, Text und Funktionen im Formular

    Anzeigen von Informationen zum Anzeigen von Daten, Text und Funktionen in Textfeldern, Bezeichnungsfeldern und anderen Steuerelementen

    Anzeigen von Daten aus der zugrunde liegenden Tabelle oder Abfrage in einem Textfeld

    Anzeigen eines Titels oder eines anderen beschreibenden Textes in einem Bezeichnungsfeld

    Berechnen einer Funktion für einen Datensatz in einem Textfeld

    Anzeigen einer Liste von Werten, die Sie aus einem Listenfeld auswählen können

    Automatisieren einer Aufgabe, wie z. B. das Öffnen eines anderen Formulars, durch Hinzufügen einer Befehlsschaltfläche

    Anzeigen weiterer Informationen zu Bezeichnungen, Textfeldern und anderen Steuerelementen

  4. Formatieren, Verschieben, Vergrößern/Verkleinern und Ausrichten von Bezeichnungen, Textfeldern und anderen Steuerelementen

    Formatieren von Text in einer Bezeichnung, einem Textfeld oder einem anderen Steuerelement (fett, kursiv oder unterstrichen)

    Gleichzeitiges Ändern von Schriftart, Schriftgrad oder Linienbreite für alle Texte und Linien im Formular

    Verschieben eines Textfeldes oder eines anderen Steuerelements zusammen mit der entsprechenden Bezeichnung

    Ändern der Größe eines Feldes

    Ausrichten von Bezeichnungen, Textfeldern und anderen Steuerelementen aneinander

  5. Anzeigen von Datensätzen aus einer verknüpften Tabelle in einem Unterformular

    Anzeigen von Beispielen zur Definition und Funktionsweise von Unterformularen

    Erstellen eines Unterformulars

  6. Vornehmen letzter Anpassungen

    Überprüfen des Formularentwurfs in der Formularansicht oder der Datenblattansicht


 Erstellen eines Listenfeldes, Kombinationsfeldes oder einer Dropdownliste, das Werte abruft

Erstellen eines Listenfeldes, Kombinationsfeldes oder einer Dropdownliste, das Werte abruft

Um ein Listenfeld, eine Dropdownliste oder ein Kombinationsfeld zu erstellen, das Werte abruft, müssen Sie folgende Entscheidungen treffen:

  • Woher sollen die Einträge für die Liste kommen?

  • Was soll Microsoft Access mit einem im Listenfeld, Kombinationsfeld oder in einer Dropdownliste ausgewählten Eintrag tun?

Die Einträge für ein Listenfeld, Kombinationsfeld oder eine Dropdownliste können aus einer festen Wertliste stammen, die Sie beim Erstellen des Listenfeldes, Kombinationsfeldes oder einer Dropdownliste eingeben (sinnvoll, wenn die Liste sich nicht oft ändert), oder aus einer Datenherkunft (sinnvoll, wenn die Liste regelmäßig aktualisiert werden soll). Sie können beispielsweise eine feste Liste für ein Listenfeld verwenden, das die Einträge Herr, Frau und Firma enthalten soll. Wenn Sie dagegen in einem Formular Artikel eine sich häufig ändernde Liste der Lieferanten der einzelnen Artikel in einem Listenfeld anzeigen möchten, legen Sie ihm eine Datenherkunft zugrunde. Das Listenfeld ruft Werte aus der Tabelle Lieferanten ab und zeigt eine aktualisierte Lieferantenliste an, aus der Sie auswählen können.

Listenfeld mit Werten aus der Lieferanten-Tabelle

Wenn ein Benutzer einen Eintrag in einem Listenfeld, Kombinationsfeld oder eine Dropdownliste auswählt, kann Microsoft Access zwei unterschiedliche Aufgaben ausführen: Access kann entweder den ausgewählten Wert in einer Tabelle speichern (die nicht identisch ist mit der Tabelle, aus der die Listeneinträge stammen) oder diesen Wert an ein anderes Steuerelement übergeben. Wählt beispielsweise ein Benutzer bei der vorstehenden Abbildung aus dem Listenfeld Lieferant den Eintrag "Pavlova, Ltd." aus, ruft Access den Wert des Primärschlüssels (Lieferanten-Nr) für Pavlova, Ltd. in der Tabelle Lieferanten ab und setzt das Feld Lieferanten-Nr (den Fremdschlüssel) für den aktuellen Datensatz in der Tabelle Lieferanten auf den gleichen Wert. Dieser Wert wird gespeichert. Da Access einen auf einer Auswahl im Listenfeld basierender Wert speichert, ist das Listenfeld gebunden. (Beachten Sie, dass der aus der Tabelle Lieferanten stammende Wert Firma im Listenfeld zwar angezeigt, doch nicht gespeichert wird.)

Wenn Access dagegen den im Listenfeld, Kombinationsfeld oder einer Dropdownliste ausgewählten Eintrag dazu verwenden soll, den Inhalt eines anderen Steuerelements bzw. anderer Steuerelemente im Formular festzulegen, erstellen Sie ein ungebundenes Listenfeld, Kombinationsfeld oder eine ungebundene Dropdownliste. Sie können beispielsweise mit Hilfe eines ungebundenen Listenfeldes oder einer ungebundene Dropdownliste einen Detaildatensatz in einer Datenzugriffsseite suchen. Oder Sie erstellen ein Listen- oder Kombinationsfeld, mit dem Sie die Datensätze in einem anderen Listen- oder Kombinationsfeld in dem Formular filtern.

Weitere Informationen

Erstellen von gebundenen und ungebundenen Kombinationsfeldern, Dropdownlisten und Listenfeldern


Erstellen und Anzeigen von Datenzugriffsseiten

Was möchten Sie tun?

Einen Überblick über Zweck und Funktionsweise von Datenzugriffsseiten erhalten

Informationen über Strategien zur Erstellung von Datenzugriffsseiten erhalten

Eine Datenzugriffsseite erstellen

Eine Seite in der Datenzugriffsseitenansicht oder im Internet Explorer öffnen

Eine Datenzugriffsseite in Web-Ordnern oder auf Web-Servern veröffentlichen

Seiten zur Fehlerbehandlung beim Entwurf von Datenzugriffsseiten


Erstellen, Ändern oder Anzeigen der Ergebnisse einer Abfrage

Was möchten Sie tun?

Einen Überblick über Abfragen und deren Funktionsweise anzeigen

Eine Abfrage erstellen

Eine Abfrage öffnen oder ausführen

Eine Abfrage anpassen

Eine Abfrage entwerfen oder ändern


Erstellen, Ändern oder Drucken von Berichten

Was möchten Sie tun?

Einen Überblick über Berichte und deren Funktionsweise anzeigen

Einen Bericht erstellen

Einen Bericht öffnen

Einen Bericht anpassen

Einen Bericht in der Seitenansicht anzeigen

Einen Bericht drucken


Erstellen eines Formulars auf der Basis mehrerer Tabellen

Was möchten Sie tun?

Einen Formular-Assistenten verwenden, um ein einfaches Formular, ein Formular mit einem oder mehreren Unterformularen oder ein synchronisiertes Formular zu erstellen

Ein Unterformular zu einem vorhandenen Formular hinzufügen

Die Datensätze in zwei vorhandenen Formularen synchronisieren

Ein eigenes Formular erstellen und eine Abfrage als Datenherkunft für dieses Formular verwenden

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Erstellen oder Ändern von Makros

Was möchten Sie tun?

Einen Überblick darüber erhalten, was Makros sind und wie sie funktionieren

Ein Makro erstellen

Eine Makrogruppe erstellen


Erstellen oder Ändern von Prozeduren in Modulen

Was möchten Sie tun?

Einen Überblick darüber erhalten, was Module sind und wie sie funktionieren

Näheres zu Prozeduren erfahren


Erstellen oder Ändern von Beziehungen

Was möchten Sie tun?

Informationen zu Beziehungen in einer Datenbank anzeigen

Beziehungen zwischen Tabellen definieren

Vorhandene Beziehungen anzeigen

Beziehungen mit Hilfe der Tastatur verwalten


Erstellen eines Berichts ohne Assistenten

Unter Verwendung der Schritte im vorliegenden Thema können Sie mit der Erstellung eines Berichts beginnen und den Bericht fertigstellen. Sie verwenden viele dieser Schritte für jeden Bericht, den Sie erstellen. Andere Schritte verwenden Sie nur für eine bestimmte Art von Bericht, z. B. ein Bericht, der Datensätze nach Kategorien gruppiert oder Funktionen berechnet. Verwenden Sie nur die Schritte, die für die Art von Bericht relevant sind, den Sie gerade erstellen möchten. Für andere Aufgaben bezüglich der Erstellung von Berichten ziehen Sie den Antwort-Assistenten zurate.

Anzeigen von Beispielen zur Definition und Funktionsweise von Berichten

  1. Starten eines Berichts

    Erstellen eines leeren Berichts und Auswählen einer Datenquelle

    Anzeigen von Beispielen zu unterschiedlichen Tools, die Sie zum Entwerfen eines Berichts verwenden können

  2. Sortieren oder Gruppieren der Daten in Ihrem Bericht

    Anzeigen eines Beispiels gruppierter Datensätze in einem Bericht

    Sortieren von Datensätzen

    Gruppieren von Datensätzen

    Ändern der Sortier- oder Gruppierreihenfolge

  3. Hinzufügen von Kopf- und Fußzeilen

    Anzeigen von Informationen zur Verwendung von Bereichen in einem Bericht

    Hinzufügen eines Berichtkopfes oder -fußes oder eines Seitenkopfes oder -fußes

    Ändern der Größe einer Kopfzeile, Fußzeile oder eines anderen Bereichs

  4. Anzeigen von Daten, Text und Funktionen im Bericht

    Anzeigen von Informationen zum Anzeigen von Daten, Text und Funktionen in Textfeldern, Bezeichnungen und anderen Steuerelementen

    Anzeigen von Daten aus der zugrunde liegenden Tabelle oder Abfrage in einem Textfeld

    Anzeigen eines Titels oder eines anderen beschreibenden Textes in einer Bezeichnung

    Berechnen einer Funktion für einen Datensatz in einem Textfeld

    Berechnen einer Funktion für eine Gruppe von Datensätzen oder für alle Datensätze in einem Textfeld

    Anzeigen des aktuellen Datums in einem Textfeld

    Anzeigen der Seitenzahl in einem Textfeld

    Weitere Informationen zu Textfeldern, Bezeichnungen und anderen Steuerelementen

  5. Formatieren, Verschieben, Vergrößern/Verkleinern und Ausrichten von Bezeichnungen, Textfeldern und anderen Steuerelementen

    Formatieren von Text in einer Bezeichnung, einem Textfeld oder einem anderen Steuerelement (fett, kursiv oder unterstrichen)

    Gleichzeitiges Ändern von Schriftart, Schriftgrad oder Linienbreite für alle Texte und Linien im Formular

    Verschieben eines Textfeldes oder eines anderen Steuerelements zusammen mit der entsprechenden Bezeichnung

    Ändern der Größe eines Bezeichnung, eines Textfeldes oder eines anderen Steuerelements

    Ausrichten von Bezeichnungen, Textfeldern und anderen Steuerelementen aneinander

  6. Berichtsvorschau anzeigen oder Drucken des Berichts

    Festlegen von Seitenrändern und der Seitenausrichtung

    Berichtsvorschau anzeigen

    Drucken des Berichts


Erstellen einer SQL-Abfrage

Was möchten Sie tun?

Weitere Informationen zu SQL-Abfragen anzeigen

Eine Union-Abfrage erstellen

Eine SQL Pass-Through-Abfrage erstellen

Eine Datendefinitionsabfrage erstellen

Eine Unterabfrage erstellen


Erstellen Ihrer ersten Prozedur

Was möchten Sie tun?

Eine benutzerdefinierte Funktion erstellen

Eine benutzerdefinierte Sub-Prozedur erstellen

Eine Ereignisprozedur erstellen

Bei Verwendung einer Prozedur, einer Anweisung oder Methode in Visual Basic-Code Argumente festlegen


Erstellen oder Ändern von Kennwörtern

Was möchten Sie tun?

Informationen zum Erstellen oder Ändern von Kennwörtern erhalten

Informationen zum Verknüpfen von Tabellen aus einer kennwortgeschützten Datenbank erhalten

Ein Datenbankkennwort festlegen

Ein Datenbankkennwort entfernen

Ein Kennwort für ein Sicherheitskonto auf Benutzerebene erstellen oder ändern

Ein Kennwort für ein Sicherheitskonto auf Benutzerebene löschen

Den Visual Basic für Applikationen-Code (VBA-Code) mit einem Kennwort schützen


 Erstellen einer neuen Tabelle auf der Basis vorhandener Daten

Erstellen einer neuen Tabelle auf der Basis vorhandener Daten

Microsoft Access bietet zwei Möglichkeiten zum Erstellen einer Tabelle auf der Basis vorhandener Daten:

  • Sie können Daten aus einer anderen Microsoft Access-Datenbank oder Daten in unterschiedlichen Dateiformaten aus anderen Programmen importieren bzw. miteinander verknüpfen.

  • Sie können eine Tabellenerstellungsabfrage ausführen, um eine Tabelle auf der Basis der Daten der aktuellen Tabelle zu erstellen. Sie können z.B. Tabellenerstellungsabfragen verwenden, um alte Datensätze zu archivieren, Sicherungskopien von Ihren Tabellen zu erstellen, eine Gruppe von Datensätzen für den Export in eine andere Datenbank auszuwählen oder um auf ihrer Grundlage Berichte zu erstellen, in denen Daten eines bestimmten Zeitraums angezeigt werden.

Was möchten Sie tun?

Eine Tabelle durch Importieren oder Verknüpfen von Daten erstellen

Eine neue Tabelle unter Verwendung einer Tabellenerstellungsabfrage erstellen


Anpassen einer Abfrage zur Duplikatsuche

Was möchten Sie tun?

Felder hinzufügen

Felder entfernen

Die Datensätze sortieren

Anmerkung Sie können eine Abfrage zur Duplikatsuche nicht in eine Löschabfrage konvertieren, um Duplikate zu löschen. Eine Abfrage zur Duplikatsuche gibt den Originaldatensatz sowie sämtliche vorhandene Duplikate des Datensatzes zurück, so dass Sie entscheiden können, welche Version Sie löschen möchten. Wenn Sie eine solche Abfrage in eine Löschabfrage konvertieren, werden das Original und die Duplikate gelöscht.

Es gibt jedoch eine Möglichkeit, Duplikate automatisch zu löschen und die Originale beizubehalten. Zum Anzeigen von Informationen klicken Sie auf [image] .


Anpassen einer Abfrage zur Inkonsistenzsuche

Was möchten Sie tun?

Felder hinzufügen

Felder entfernen

Felder verschieben


Debuggen von Makros

Was möchten Sie tun?

Ein Makro schrittweise ausführen, um Probleme darin ausfindig zu machen

Fehler in Makros behandeln


Debuggen von Visual Basic-Code

Was möchten Sie tun?

Über Fehlerbehandlung nachlesen

Mit Hilfe eines Haltepunktes die Ausführung von Visual Basic-Code unterbrechen

Visual Basic-Code schrittweise durchlaufen

Die Werte von Ausdrücken und Variablen untersuchen

In Visual Basic-Code einen Überwachungsausdruck festlegen

Visual Basic-Prozeduraufrufe beim Debuggen von Visual Basic-Code verfolgen

Bei der Arbeit mit Microsoft Visual Basic den Direktbereich verwenden


Wählen zwischen einem Datenanzeigeformat und einem Eingabeformat

Microsoft Access unterstützt zwei Feldeigenschaften, die ähnliche Ergebnisse produzieren: die Eigenschaft Format und die Eigenschaft Eingabeformat.

Verwenden Sie die Eigenschaft Format, wenn Daten in einem einheitlichen Format angezeigt werden sollen. Wenn Sie für die Eigenschaft Format für ein Feld vom Datentyp Datum/Uhrzeit den Wert Datum, mittel einstellen, werden alle Datumsangaben in der Form 12. Jan. 96 angezeigt. Wenn ein Benutzer dann z. B. ein Datum im Format 12.01.95 (oder in einem beliebigen anderen gültigen Format) eingibt, konvertiert Microsoft Access die Anzeige beim Speichern automatisch in das Format Datum, mittel.

Die Eigenschaft Format beeinflusst nur die Anzeige eines Wertes, nicht die Art wie dieser Wert in der Tabelle gespeichert wird. Außerdem wird ein Anzeigeformat erst nach dem Speichern eingegebener Daten wirksam. Im Feld wird jedoch kein Hinweis auf das Eingabeformat angezeigt. Wenn Sie bereits beim Eingeben steuern möchten, wie die Anzeige der Daten aussehen soll, verwenden Sie zusätzlich zur Eigenschaft Format oder an Stelle dieser Eigenschaft ein Eingabeformat. Wenn Daten immer genau so angezeigt werden sollen, wie sie eingegeben werden, legen Sie die Eigenschaft Format nicht fest.

Für Felder vom Datentyp Zahl, Währung, Datum/Uhrzeit, AutoWert und Ja/Nein stehen vordefinierte Formate zur Verfügung, und Sie können für diese Felder benutzerdefinierte Formate erstellen. Für Felder vom Datentyp Text, Memo oder Hyperlink stehen keine vordefinierten Formate zur Verfügung, Sie können jedoch auch hier benutzerdefinierte Formate erstellen. Für Felder vom Datentyp OLE-Objekt können Sie kein Anzeigeformat definieren.

Verwenden Sie die Eigenschaft Eingabeformat, wenn Sie Leerstellen definieren möchten, die im Feld durch Literalzeichen ersetzt werden. Wenn z. B. alle Telefonnummern, die Sie in ein Feld eingeben, dasselbe Format haben, können Sie ein Eingabeformat erstellen, das wie in der nachstehenden Abbildung gezeigt aussieht.

Eingabeformate mit Leerstellen zum Ausfüllen

Bei Verwendung eines Eingabeformats wird gewährleistet, dass die Daten in das definierte Format passen. Darüber hinaus können Sie die Art der Werte festlegen, die an jeder Leerstelle eingegeben werden dürfen. Das vorstehend gezeigte Eingabeformat legt z. B. fest, dass alle Einträge genau so viele Ziffern enthalten müssen, wie für eine in den USA gültige Telefonnummer mit Ortsnetzkennzahl erforderlich ist, und dass an jeder Leerstelle nur Ziffern eingegeben werden dürfen.

Wenn Sie für ein Feld sowohl ein Anzeigeformat als auch ein Eingabeformat festlegen, verwendet Microsoft Access das Eingabeformat beim Hinzufügen oder Bearbeiten von Daten und die Anzeigeformateinstellung zum Festlegen, auf welche Art die Daten nach dem Speichern des Datensatzes angezeigt werden. Achten Sie darauf, dass es nicht zu Konflikten kommt, wenn Sie sowohl die Eigenschaft Format als auch die Eigenschaft Eingabeformat verwenden.

Weitere Informationen

Verwenden der Eigenschaft Format zum Festlegen von Anzeigeformaten

Verwenden der Eigenschaft Eingabeformat zum Steuern der Dateneingabe


Bearbeiten von Diagrammen in Formularen oder Berichten

Was möchten Sie tun?

Informationen über das Ändern von Diagrammen in Formularen oder Berichten

Die Größe eines Diagramms in einem Formular oder Bericht ändern

Das Erscheinungsbild eines Diagramms in einem Formular oder Bericht ändern

Die Daten in der zugrunde liegenden Tabelle oder sonstigen Datenherkunft eines Formulars oder Berichts ändern

Die Datensatzherkunft-Abfrage in einem Formular oder Bericht ändern

Das Diagramm in einem Formular oder Bericht unter Verwendung des Diagramm-Assistenten neu erstellen

Ein Diagramm in in einem Formular oder Bericht anpassen


 Verwenden von Tastenkombinationen zum Bearbeiten von Text oder Daten

Verwenden von Tastenkombinationen zum Bearbeiten von Text oder Daten

Anmerkung Wenn die Einfügemarke nicht sichtbar ist, drücken Sie F2, um sie anzuzeigen.

Tastenkombination | Bewegen der Einfügemarke in einem Feld
NACH-RECHTS | Um ein Zeichen nach rechts
STRG+NACH-RECHTS | Um ein Wort nach rechts
NACH-LINKS | Um ein Zeichen nach links
STRG+NACH-LINKS | Um ein Wort nach links
ENDE | An das Ende des Feldes; in einzeiligen Feldern
STRG+ENDE | An das Ende des Feldes; in mehrzeiligen Feldern
POS1 | An den Anfang des Feldes; in einzeiligen Feldern
STRG+POS1 | An den Anfang des Feldes; in mehrzeiligen Feldern

Tastenkombination | Kopieren, Verschieben oder Löschen von Text
STRG+C | Kopieren der Auswahl in die Zwischenablage
STRG+X | Ausschneiden der Auswahl und Kopieren in die Zwischenablage
STRG+V | Einfügen des Inhalts der Zwischenablage an der Einfügemarke
RÜCKTASTE | Löschen der Auswahl oder des Zeichens links von der Einfügemarke
ENTF | Löschen der Auswahl oder des Zeichens rechts von der Einfügemarke
STRG+ENTF | Löschen aller Zeichen rechts von der Einfügemarke

Tastenkombination | Rückgängigmachen von Änderungen
STRG+Z oder ALT+RÜCKTASTE | Rückgängigmachen einer Eingabe
ESC | Rückgängigmachen von Änderungen im aktuellen Feld oder aktuellen Datensatz; wenn in beiden geändert worden ist, drücken Sie zweimal ESC, um zuerst die Änderungen im aktuellen Feld und dann die Änderungen im aktuellen Datensatz rückgängig zu machen

Tastenkombination | Eingeben von Daten in die Datenblatt- oder die Formularansicht
STRG+Semikolon (;) | Einfügen des aktuellen Datums
STRG+Doppelpunkt (:) | Einfügen der aktuellen Uhrzeit
STRG+ALT+LEERTASTE | Einfügen des Standardwertes für ein Feld
STRG+Apostroph (') | Einfügen des Wertes aus demselben Feld im vorherigen Datensatz
STRG+Pluszeichen (+) | Hinzufügen eines neuen Datensatzes
STRG+Minuszeichen (-) | Löschen des aktuellen Datensatzes
UMSCHALT+EINGABETASTE | Speichern der Änderungen am aktuellen Datensatz
LEERTASTE | Wechseln zwischen den Werten in einem Kontrollkästchen oder einem Optionsfeld
STRG+EINGABETASTE | Einfügen eine neuen Zeile

Tastenkombination | Aktualisieren von Feldern mit aktuellen Daten
F9 | Neuberechnen der Felder im Fenster
UMSCHALT+F9 | Erneutes Durchführen einer Abfrage in den zugrunde liegenden Tabellen. In einem Unterformular ist für dieses erneute Abfragen nur die dem Unterformular zugrunde liegende Tabelle erforderlich
F9 | Aktualisieren des Inhalts eines Nachschlagefeldes in Form eines Listen- oder eines Kombinationsfeldes


Exportieren von Daten oder Datenbankobjekten in einem anderen Datenbank- oder Dateiformat

Was möchten Sie tun?

Informationen über das Exportieren erhalten

Informationen über das Exportieren von Daten oder Datenbankobjekten in einem anderen Datenbank- oder Dateiformat

Übersicht über die Formate, in die Sie exportieren können

Datenbankobjekte exportieren oder per E-Mail versenden

Datenbankobjekte in eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt exportieren

Ein Datenbankobjekt als Anlage einer E-Mail-Nachricht versenden

Eine Datenzugriffsseite im Text einer E-Mail-Nachricht versenden

Exportieren in externe Dateien oder Datenbanken

Eine Tabelle oder Abfrage in eine Paradox- oder dBase-Datei exportieren

Eine Tabelle oder Abfrage in eine SQL-Datenbanktabelle oder andere ODBC-Datenquelle exportieren

Eine Tabelle oder Abfrage in eine Textdatei mit Trennzeichen oder mit festgelegtem Format exportieren

Informationen über Import/Export-Spezifikationen und schema.ini-Dateien

Exportieren in eine Webseite

Informationen über die drei verschiedenen Webseitentypen, die Microsoft Access erzeugt

Informationen über Client/Server-Produkte und Plattformen für Webseiten

Eine Datenzugriffsseite erstellen

Ein Datenblatt in statisches HTML-Format exportieren

Ein Datenblatt in servergeneriertes HTML-Format exportieren

Einen Bericht in statisches HTML-Format exportieren

Webseiten veröffentlichen

Aus einer Datenzugriffsseite in Microsoft Excel exportieren

Eine PivotTable-Liste auf einer Seite in einen PivotTable-Bericht in Microsoft Excel exportieren

Eine Kalkulationstabelle auf einer Seite in eine Microsoft Excel-Arbeitsmappe exportieren

Daten mit Microsoft Word austauschen bzw. in Word exportieren

Daten aus einem Datenblatt mit Hilfe des Microsoft Word-Seriendruck-Assistenten zusammenführen

Ein Datenblatt in eine Microsoft Word-Datenquellendatei für Seriendruck exportieren

Die Ausgabe eines Datenbankobjekts als Rich Text Format-Datei speichern

Die Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Word laden

Exportieren in Microsoft Excel oder eine andere Tabellenkalkulation

Ein Datenblatt in eine Tabellenkalkulationsdatei exportieren

Die Ausgabe eines Datenblatts, Formulars oder Berichts als Microsoft Excel-Datei speichern

Die Ausgabe eines Datenblatts, Formulars oder Berichts in Microsoft Excel laden

Exporte automatisieren

Makros oder Visual Basic-Code verwenden, um das Exportieren von Daten zu automatisieren


Suchen und Ersetzen von Daten

Was möchten Sie tun?

Informationen über das Suchen und Ersetzen von Daten erhalten

Einen Datensatz in einem Datenblatt oder Formular per Bildlauf suchen

Einen Datensatz nach seiner Datensatznummer suchen

Das Dialogfeld Suchen verwenden

Das Dialogfeld Suchen und Ersetzen verwenden

Einen Filter in einer Microsoft Access-Datenbank verwenden

Eine Abfrage in einer Microsoft Access-Datenbank verwenden

Einen Filter in einem Microsoft Access-Projekt verwenden

Eine Abfrage in einem Microsoft Access-Projekt verwenden

Die Geschwindigkeit beim Suchen/Ersetzen optimieren


Anfordern von Hilfe im Visual Basic-Editor

Was möchten Sie tun?

Hilfe zu Visual Basic erhalten

Visual Basic-Codebeispiele von der Hilfe in das Code-Fenster kopieren


 Gruppieren von Datensätzen nach Werten in einem Gruppierungsfeld auf einer Datenzugriffsseite

Gruppieren von Datensätzen nach Werten in einem Gruppierungsfeld auf einer Datenzugriffsseite

Informationen über das Gruppieren von Datensätzen auf einer Datenzugriffsseite.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Falls sich die gewünschten Felder noch nicht in dem Bereich befinden, müssen Sie der Seite die Felder entweder als gebundene HTML-Steuerelemente hinzufügen oder als gebundene Textfelder hinzufügen.

    Anmerkungen

    • Die Seite wird in der Datenzugriffsseitenansicht und in Microsoft Internet Explorer schneller geladen, wenn Sie gebundene HTML-Steuerelemente verwenden.

    • Falls in der Seite kein Bereich existiert, können Sie einen ungebundenen Bereich hinzufügen.
  3. Überzeugen Sie sich, dass das Steuerelement, nach dem Sie gruppieren möchten, ausgewählt ist.

  4. Führen Sie einen der folgenden Schritte durch:
    • Um nach einem Feld in einer Tabelle oder Abfrage zu gruppieren, klicken Sie auf Höher stufen [image] auf der Symbolleiste.

    • Um nach einer Tabelle oder Abfrage zu gruppieren, klicken Sie auf Nach Tabelle gruppieren [image] auf der Symbolleiste.

    Microsoft Access fügt einen Gruppenkopf mit einem Erweiterungssteuerelement sowie einen Datensatznavigationsbereich mit einem Datensatznavigationssteuerelement hinzu. Wenn Sie nach einem Feld gruppiert haben, verschiebt Access das Steuerelement, nach dem gruppiert wurde, in den Gruppenkopf. Falls Sie nach einer Tabelle oder Abfrage gruppiert haben, verschiebt Access alle Steuerelemente, auch an Felder in dieser Tabelle oder Abfrage gebundene sowie an Nachschlagefelder gebundene Steuerelemente, in den Gruppenkopf.

  5. Wiederholen Sie die Schritte 3 und 4, bis so viele Gruppierungsebenen vorhanden sind, wie Sie benötigen.

Anmerkungen

  • Verwenden Sie die Schaltfläche Höherstufen, wenn Sie nach einem Steuerelement gruppieren wollen, das Werte enthält, die von mehreren Datensätzen genutzt werden. Beispiel: Gruppieren Sie in der Tabelle Bestellungen nach Bestimmungsland. Falls Sie weitere Steuerelemente in den Gruppenkopf einfügen, gruppiert Microsoft Access nach jedem Steuerelement im Gruppenkopf. Fügen Sie beispielsweise ein an das Feld Bestimmungsregion gebundenes Feld in den Kopfbereich Bestellungen/Bestimmungsland ein, verwendet Access zum Gruppieren der Datensätze die Werte in beiden Steuerelementen, Bestimmungsland und Bestimmungsregion.

  • Verwenden Sie die Schaltfläche Nach Tabelle gruppieren, wenn die Seite Felder aus zwei Tabellen oder Abfragen enthält, die eine 1:n-Beziehung haben, und Sie nach der Tabelle oder Abfrage auf der "1"-Seite der Beziehung gruppieren wollen. Beispiel: In einer Seite, die Felder aus den Tabellen Bestellungen und Bestelldetails enthält, gruppieren Sie nach der Tabelle Bestellungen. Wenn Sie Datensätze mit Nach Tabelle gruppieren gruppieren, gruppiert und sortiert Access die Datensätze nach dem Primärschlüssel der Tabelle - in diesem Fall Bestell-Nr.

  • Beim Gruppieren nach einem Steuerelement erstellt Access einen Aliasnamen für das Steuerelement, indem dem Namen des Steuerelements in der Steuerelementinhalt-Eigenschaft das Präfix "Gruppierung" vorangestellt wird; beispielsweise GruppierungVersanddatum: Versanddatum. Wenn Sie sich in einem Ausdruck auf dieses Steuerelement beziehen, müssen Sie den Aliasnamen verwenden.

  • Sie können für jede Gruppierungsebene eine andere Standard-Sortierreihenfolge angeben.

  • Wenn auf einer Seite zwei oder mehr Gruppierungsebenen vorhanden sind, können Sie die Daten nur in der Datenzugriffsseitenansicht oder in Internet Explorer anzeigen. Sie können keine Daten hinzufügen, bearbeiten oder löschen.


 Info über das Umbenennen eines Feldes

Info über das Umbenennen eines Feldes

Das Ändern eines Feldnamens im Entwurfsbereich für Abfragen ändert die Spaltenüberschrift in der Datenblattansicht der Abfrage. Wenn Sie ein neues Objekt, wie z. B. ein neues Formular, einen Bericht oder eine Datenzugriffsseite auf der Basis der Abfrage erstellen, verwendet das neue Objekt den neuen Feldnamen. Wenn Sie z. B. ein Steuerelement zum Anzeigen des umbenannten Feldes erstellen, wird der neue Feldname als Steuerelementname und für das Bezeichnungsfeld des Steuerelements verwendet. Der Feldname in der zugrunde liegenden Tabelle ändert sich jedoch ebenso wenig, wie der Name in Formularen oder Berichten, die vor dem Ändern des Feldnamens auf der Abfrage basierten.

Anmerkung Das Ändern eines Feldnamens im Entwurfsbereich der aktuellen Abfrage hat keinen Einfluss auf die Datenblattansicht der Abfrage, wenn die Eigenschaft Beschriftung für dieses Feld in der zugrunde liegenden Tabelle oder Abfrage festgelegt worden ist.

Wenn der neue Feldname nur für Datenblattspalten, oder Beschriftungen in Formularen, Berichten und Datenzugriffsseiten verwendet werden soll, können Sie auch die Eigenschaft Beschriftung für das Feld ändern, anstatt das Feld im Entwurfsbereich umzubenennen.

Zurück zu Ändern eines Feldnamens in einer Abfrage


Info über das Verhindern von Duplikatdatensätzen

Microsoft Access interpretiert einen Datensatz dann als eindeutig, wenn sich der Wert eines beliebigen Feldes des Datensatzes vom Wert im selben Feld jedes anderen Datensatzes unterscheidet. In einer Abfrage werden in der Regel nicht alle Felder aus den Datensätzen der zugrunde liegenden Tabellen oder Abfragen angezeigt. Wenn daher das Feld, das zwei Datensätze voneinander unterscheidet, nicht im Abfrageentwurfsbereich enthalten ist, kann es so aussehen, als enthielte die Abfrage Duplikatdatensätze. Wenn Sie z. B. dem Abfrageentwurfsbereich nur die Felder Nachname und Land hinzufügen, scheint die Abfrage Duplikatdatensätze zu enthalten, wenn mehrere Mitarbeiter denselben Nachnamen haben und im selben Land leben. Diese Datensätze sind in der zugrunde liegenden Tabelle jedoch keine Duplikatdatensätze, da das Feld Personal-Nr für jeden Datensatz eindeutig ist.

Sie können eindeutige Datensätze, basierend auf allen Feldern in der zugrunde liegenden Tabelle oder Abfrage und nicht nur auf den im Abfrageentwurfsbereich enthaltenen Feldern, anzeigen. Sie können auch eindeutige Datensätze, basierend auf den im Abfrageentwurfsbereich enthaltenen Feldern, anzeigen. Bei beiden Einstellungen gilt, dass bei Vorhandensein von Duplikaten nur jeweils ein Datensatz angezeigt wird, und nicht alle entsprechenden Duplikate.

Zurück zu Verhindern der Anzeige von Duplikatdatensätzen in Abfrageergebnissen


Hinzufügen von ungebundenen Bildern zu Formularen, Berichten oder Datenzugriffsseiten

Was möchten Sie tun?

Beispiele dafür sehen, in welchen Fällen ungebundene, gebundene, eingefügte oder verknüpfte Objekte in Formularen oder Berichten zu verwenden sind

Hintergrundbilder hinzufügen

Ein Hintergrundbild zu einem Formular hinzufügen

Ein Hintergrundbild zu einem Bericht hinzufügen

Ein Hintergrundbild zu einer Datenzugriffsseite hinzufügen

Hintergrundbilder zu Steuerelementen hinzufügen

Ein Hintergrundbild unter Verwendung eines Bild-Steuerelements zu einem Formular, einem Bericht oder einer Datenzugriffsseite hinzufügen

Ein Bild unter Verwendung eines ungebundenen Objektfeldes erstellen und zu einem Formular oder einem Bericht hinzufügen

Ein vorhandenes Bild unter Verwendung eines ungebundenen Objektfeldes zu einem Formular oder einem Bericht hinzufügen

Einen Ausschnitt aus einem vorhandenen Bild unter Verwendung eines ungebundenen Objektfeldes zu einem Formular oder einem Bericht hinzufügen

Verknüpfungen zu Bildern erstellen

Eine Verknüpfung zu einem vorhandenen Bild unter Verwendung eines ungebundenen Objektfeldes in einem Formular oder einem Bericht erstellen

Eine Verknüpfung zu einem Ausschnitt aus einem vorhandenen Bild unter Verwendung eines ungebundenen Objektfeldes in einem Formular oder einem Bericht erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Info darüber, wie Access für Sie eine Abfrage erstellt

Info darüber, wie Access für Sie eine Abfrage erstellt

Microsoft Access kann in vielen Fällen eine Abfrage für Sie erstellen, so dass Sie diese nicht völlig neu erstellen müssen.

  • Um eine Abfrage als Basis für ein Formular, einen Bericht oder eine Datenzugriffsseite zu verwenden, versuchen Sie, diese mit einem Formular-, Berichts- oder Datenzugriffsseiten-Assistenten zu erstellen. Diese erstellen das Formular, den Bericht oder die Datenzugriffsseite, und wenn diese(r) auf mehr als einer Tabelle basiert, erstellen sie auch die zugrunde liegende SQL-Anweisung. Bei Bedarf können Sie diese SQL-Anweisung als Abfrage speichern.

  • Um unabhängig ausgeführte Abfragen oder solche, auf denen mehrere Formulare, Berichte oder Datenzugriffsseiten basieren, möglichst einfach zu erstellen, verwenden Sie einen der Abfrage-Assistenten. Diese übernehmen alle grundlegenden Aufgaben für Sie, nachdem Sie von Ihnen Antworten auf eine Reihe von Fragen erhalten haben. Auch wenn Sie bereits eine Vielzahl von Abfragen erstellt haben, empfiehlt sich die Verwendung eines Assistenten, wenn Sie die Abfrage schnell entwerfen möchten. Anschließend können Sie zur Entwurfsansicht wechseln, um die Abfrage an Ihre Erfordernisse anzupassen.

  • Um Abfragen aus bereits von Ihnen erstellten Filtern unter Verwendung eines formularbasierten Filters, eines auswahlbasierten Filters oder der Methode Auswahlausschließender Filter zu erstellen, speichern Sie den Filter als Abfrage.

Erst wenn keine dieser Methoden Ihren Anforderungen entspricht, müssen Sie eine Abfrage ganz neu in der Entwurfsansicht erstellen.

Zurück zu Erstellen einer Abfrage


Importieren oder Verknüpfen von Daten und Importieren von Datenbankobjekten

Was möchten Sie tun?

Informationen zu Importen und Verknüpfungen

Informationen über das Importieren oder Verknüpfen von Daten und das Importieren von Datenbankobjekten

Mehr Informationen erhalten, um besser entscheiden zu können, ob Tabellen importiert oder verknüpft werden sollen

Übersicht über die Datenherkünfte, aus denen Microsoft Access importieren kann bzw. zu denen Verknüpfungen möglich sind

Datenbankobjekte importieren

Tabellen aus einer anderen Microsoft Access-Datenbank oder einem anderen Microsoft Access-Projekt importieren oder verknüpfen

Datenbankobjekte aus einer anderen Microsoft Access-Datenbank oder einem anderen Microsoft Access-Projekt importieren oder verknüpfen

HTML-Dateien oder Web-Komponenten importieren oder verknüpfen

(Schreibgeschützte) HTML-Tabellen und -Listen importieren oder verknüpfen

(Schreibgeschützte) Daten auf einem FTP- oder HTTP-Server importieren oder verknüpfen

Eine Webseite oder Textdatei in eine Kalkulationstabelle auf einer Datenzugriffsseite importieren

Daten aus anderen Programmen bzw. anderen Dateiformaten importieren oder verknüpfen

Informationen über die Importfehlertabelle

dBASE-Dateien importieren oder verknüpfen

Paradox-Tabellen importieren oder verknüpfen

SQL-Datenbanktabellen oder Daten aus anderen ODBC-Datenherkünften importieren oder verknüpfen

Daten aus Microsoft Outlook oder Microsoft Exchange Server importieren oder verknüpfen

Daten aus einer Kalkulationstabelle importieren oder verknüpfen

Eine Textdatei mit Trennzeichen oder eine Textdatei fester Breite importieren oder verknüpfen

Informationen über Import/Export-Spezifikationen und schema.ini-Dateien

Eine Microsoft Works-Datenbank importieren

Verknüpfte Tabellen verwalten

Die Tabelle MSysConf in einer Microsoft Access-Datenbank mit verknüpften SQL-Datenbanken verwenden

Die Verknüpfung mit einer verknüpften Tabelle in einer Microsoft Access-Datenbank löschen

Dateinamen und -pfade von verknüpften Tabellen in einer Microsoft Access-Datenbank anzeigen, aktualisieren oder ändern

Eigenschaften von verknüpften Tabellen in einer Microsoft Access-Datenbank umbenennen und festlegen

Die optimale Performance bei verknüpften Tabellen in einer Microsoft Access-Datenbank erzielen

Importieren automatisieren

Das Importieren von Daten mit Hilfe eines Makros oder unter Verwendung von Visual Basic-Code automatisieren


Ausblenden oder Deaktivieren von Text oder Steuerelementen auf Datenzugriffsseiten

Was möchten Sie tun?

Ein Steuerelement deaktivieren oder für Daten in einem Textfeld oder anderen Steuerelement den Schreibschutz aktivieren

Ein Textfeld oder anderes Steuerelement ein- oder ausblenden


 Ändern eines Filters im Fenster "Spezialfilter/-sortierung"

Ändern eines Filters im Fenster "Spezialfilter/-sortierung"

Wenn Sie im Fenster Spezialfilter/-sortierung in einer Tabelle, einer Abfrage oder einem Formular arbeiten, können Sie den Entwurf des Filters und den Entwurfsbereich ändern.

Was möchten Sie im Entwurfsbereich tun?

Ein Feld hinzufügen

Ein Feld zwischen anderen Feldern hinzufügen

Ein Feld verschieben

Eine Spalte hinzufügen

Ein Feld oder eine Spalte entfernen

Spaltenbreiten ändern

Eine Kriterienzeile hinzufügen oder löschen

Kriterien eingeben

Eine Sortierreihenfolge für die gefilterten Datensätze festlegen

Alles im Entwurfsbereich löschen


Ändern eines Filters im Fenster "Formularbasierter Filter" in einer Tabelle, einer Abfrage oder einem Formular

Sie können zum Ändern des Filters andere Werte zu leeren Feldern hinzufügen, die die gefilterten Datensätze enthalten sollen, Werte in einem Feld löschen oder ändern oder eine der folgenden Änderungen vornehmen.

Was möchten Sie zum Ändern des Filters tun?

Alle Felder im Fenster Formularbasierter Filter löschen

Eine Registerkarte Oder am unteren Rand des Fensters Formularbasierter Filter löschen

Einen Ausdruck eingeben


 Verschieben, Vergrößern/Verkleinern, Ausrichten und Formatieren von Textfeldern oder Steuerelementen in einem Formular oder Bericht

Verschieben, Vergrößern/Verkleinern, Ausrichten und Formatieren von Textfeldern oder Steuerelementen in einem Formular oder Bericht

In Formularen und Berichten verwenden Sie zum Anzeigen von Daten aus Feldern Textfelder und andere Steuerelemente, denen Sie beschreibenden Text und dekorative Linien hinzufügen können.

Was möchten Sie tun?

Ein Steuerelement und das zugehörige Bezeichnungsfeld verschieben

Ein Steuerelement oder das zugehörige Bezeichnungsfeld getrennt verschieben

Zwei oder mehr Steuerelemente gleichzeitig verschieben

Ein Steuerelement vor oder hinter andere Steuerelemente verschieben

Die Größe eines Steuerelements ändern

Die Größe eines Steuerelements an seinen Inhalt anpassen

Mehrere Steuerelemente auf eine gemeinsame Größe anpassen

Steuerelemente unter Verwendung des Rasters einheitlich vergrößern oder verkleinern

Steuerelemente aneinander ausrichten

Steuerelemente am Raster ausrichten

Gleiche Abstände zwischen Steuerelementen festlegen

Den Abstand zwischen Steuerelementen erhöhen oder verringern

Die Ausrichtung von Text in einem Steuerelement ändern

Das Format von Daten in einem Steuerelement ändern

Gruppensteuerelemente

Ein Formular, einen Bericht, einen Bereich oder markierte Steuerelemente unter Verwendung vordefinierter Formate formatieren


Verschieben, Größenanpassung, Ausrichten und Formatieren von Text oder Steuerelementen auf einer Datenzugriffsseite

Was möchten Sie tun?

Den Text in einem Bezeichnungsfeld, Textfeld oder anderem Steuerelement fett, kursiv oder unterstrichen formatieren

Ein Textfeld oder anderes Steuerelement mit seinem Bezeichnungsfeld verschieben

Die Größe eines Bezeichnungsfeldes, Textfeldes oder anderen Steuerelements verändern

Textfelder und andere Steuerelemente ausrichten

Ein Datensatznavigationssteuerelement anpassen


 Verwenden von Tastenkombinationen zum Bewegen in der Datenblattansicht

Verwenden von Tastenkombinationen zum Bewegen in der Datenblattansicht

Taste(n) | Gehen zu einem bestimmten Datensatz
F5 | Anzeigen des Feldes Datensatznummer; geben Sie dann die gewünschte Datensatznummer ein, und drücken Sie die EINGABETASTE.

Taste(n) | Bewegen zwischen Feldern und Datensätzen
TAB oder NACH-RECHTS | Bewegen zum nächsten Feld
ENDE | Bewegen zum letzten Feld im aktuellen Datensatz, im Navigationsmodus
UMSCHALT+TAB oder NACH-LINKS | Bewegen zum vorherigen Feld
POS1 | Bewegen zum ersten Feld im aktuellen Datensatz, im Navigationsmodus
NACH-UNTEN | Bewegen zum aktuellen Feld im nächsten Datensatz
STRG+NACH-UNTEN | Bewegen zum aktuellen Feld im letzten Datensatz, im Navigationsmodus
STRG+ENDE | Bewegen zum letzten Feld im letzten Datensatz, im Navigationsmodus
NACH-OBEN | Bewegen zum aktuellen Feld im vorherigen Datensatz
STRG+NACH-OBEN | Bewegen zum aktuellen Feld im ersten Datensatz, im Navigationsmodus
STRG+POS1 | Bewegen zum ersten Feld im ersten Datensatz, im Navigationsmodus

Taste(n) | Bewegen zu einer anderen Datenseite auf dem Bildschirm
BILD-AB | Blättern um einen Bildschirm nach unten
BILD-AUF | Blättern um einen Bildschirm nach oben
STRG+BILD-AB | Blättern um einen Bildschirm nach rechts
STRG+BILD-AUF | Blättern um einen Bildschirm nach links

Mehr erfahren über Neuanordnen von Spalten.

Mehr erfahren über Auswählen von Feldern und Datenätzen in der Datenblattansicht.


 Verwenden von Tastenkombinationen zum Bewegen in der Formularansicht

Verwenden von Tastenkombinationen zum Bewegen in der Formularansicht

Taste(n) | Gehen zu einem bestimmten Datensatz
F5 | Anzeigen des Feldes Datensatznummer; geben Sie dann die gewünschte Datensatznummer ein, und drücken Sie die EINGABETASTE.

Taste(n) | Bewegen zwischen Feldern und Datensätzen
TAB | Bewegen zum nächsten Feld
UMSCHALT+TAB | Bewegen zum vorherigen Feld
ENDE | Bewegen zum letzten Feld im aktuellen Datensatz, im Navigationsmodus
STRG+ENDE | Bewegen zum letzten Feld im letzten Datensatz, im Navigationsmodus
POS1 | Bewegen zum ersten Feld im aktuellen Datensatz, im Navigationsmodus
STRG+POS1 | Bewegen zum ersten Feld im ersten Datensatz, im Navigationsmodus
STRG+BILD-AB | Bewegen zum aktuellen Feld im nächsten Datensatz
STRG+BILD-AUF | Bewegen zum aktuellen Feld im vorherigen Datensatz

Taste(n) | Bewegen in mehrseitigen Formularen
BILD-AB | Bewegen um eine Seite nach unten. Am Ende des Datensatzes: Bewegen zur entsprechenden Seite des nächsten Datensatzes
BILD-AUF | Bewegen um eine Seite nach oben. Am Ende des Datensatzes: Bewegen zur entsprechenden Seite des vorherigen Datensatzes

Taste(n) | Bewegen zwischen Hauptformular und Unterformular
TAB | Aufrufen des Unterformulars aus dem vorherigen Feld im Hauptformular
UMSCHALT+TAB | Aufrufen des Unterformulars aus dem nächsten Feld im Hauptformular
STRG+TAB | Verlassen des Unterformulars und Bewegen zum nächsten Feld im Hauptformular oder zum nächsten Datensatz
STRG+UMSCHALT+TAB | Verlassen des Unterformulars und Bewegen zum vorherigen Feld im Hauptformular oder zum vorherigen Datensatz


Schützen von Microsoft Access-Anwendungen durch Ausblenden von Objekten im Datenbankfenster und mit Hilfe von Startoptionen

Was möchten Sie tun?

Objekte im Datenbankfenster ausblenden

Das Aussehen und Verhalten von Datenbanken oder Anwendungen beim Starten festlegen


Schützen von Microsoft Access-Datenbankdateien (.mdb) mit einem Kennwort oder Verschlüsselung

Was möchten Sie tun?

Eine Datenbank durch Festlegen eines Datenbankkennwortes schützen

Ein Datenbankkennwort entfernen

Informationen über das Verknüpfen von Tabellen aus kennwortgeschützten Datenbanken erhalten

Eine Datenbank verschlüsseln oder entschlüsseln


Schützen von Datenzugriffsseiten

Was möchten Sie tun?

Informationen über das Schützen von Datenzugriffsseiten erhalten

Informationen über das Schützen von Zellen in Kalkulationstabellen auf Datenzugriffsseiten erhalten


Schützen von Visual Basic für Applikationen-Code mit einem Kennwort oder durch Erstellen einer MDE-Datei

Was möchten Sie tun?

Informationen über das Schützen von Visual Basic für Applikationen-Code erhalten

Visual Basic für Applikationen-Code mit einem Kennwort schützen

Mit MDE-Dateien arbeiten


Schützen von Microsoft Access-Datenbanken und zugehöriger Tabellen, Abfragen, Formulare, Berichte und Makros mit Sicherheit auf Benutzerebene

Was möchten Sie tun?

Eine Datenbank unter Verwendung von Sicherheit auf Benutzerebene schützen

Eine Datenbank schützen, ohne dass Benutzer sich anmelden müssen

Die Sicherheit auf Benutzerebene entfernen

Mit Arbeitsgruppen-Informationsdateien arbeiten

Mit Benutzer- und Gruppenkonten arbeiten

Mit Berechtigungen arbeiten

Eine geschützte Datenbank aus einer früheren Version von Microsoft Access konvertieren


Veröffentlichen von Webseiten

Was möchten Sie tun?

Informationen über die drei verschiedenen Webseitentypen erhalten, die Microsoft Access erzeugt

Eine Datenzugriffsseite in Web-Ordnern oder auf einem Web-Server bereitstellen

Server-generierte HTML-Dateien in Web-Ordnern oder auf einem Web-Server bereitstellen

Statische HTML-Dateien in Web-Ordnern oder auf einem Web-Server bereitstellen


Informationen über Visual Basic-Module

Was möchten Sie tun?

Eine Übersicht darüber erhalten, was Module sind und wie sie funktionieren

Näheres zu Prozeduren erfahren

Visual Basic-Code ausführen

Mit Hilfe von Visual Basic-Code mit Daten und Datenbankobjekten arbeiten


 Entfernen einer Schaltfläche oder eines anderen Steuerelements aus der Reihenfolge in einem Formular

Entfernen einer Schaltfläche oder eines anderen Steuerelements aus der Reihenfolge in einem Formular

Es gibt zwei Möglichkeiten, eine Schaltfläche oder ein anderes Steuerelement aus der Reihenfolge zu entfernen. Wenn Sie das Steuerelement aus der Reihenfolge entfernen, jedoch trotzdem in der Lage sein möchten, es zu markieren, setzen Sie die Eigenschaft InReihenfolge für dieses Steuerelement auf Nein.

Wenn Sie das Steuerelement bis zum Eintreten einer bestimmten Bedingung deaktivieren möchten, verwenden Sie die Eigenschaft Aktiviert zusammen mit der Eigenschaft NachAktualisierung.

Was möchten Sie tun?

Das Steuerelement aus der Reihenfolge entfernen, ohne es zu deaktivieren

Das Steuerelement deaktivieren


Zurücksetzen aller Standardeinstellungen für eine integrierte Symbol- oder Menüleiste

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Klicken Sie in der Registerkarte Symbolleisten auf Eigenschaften.

  3. Wählen Sie im Feld Ausgewählte Symbolleiste den Namen der Symbol- oder Menüleiste, für die Sie die Standardeinstellungen zurücksetzen möchten.

  4. Klicken Sie auf die Schaltfläche Standardeinstellungen wiederherstellen.

Die Schaltfläche Standardeinstellungen wiederherstellen steht erst dann zur Verfügung, wenn Microsoft Access feststellt, dass die ausgewählte Symbol- oder Menüleiste geändert worden ist.


Schützen einer Microsoft Access-Datenbank

Was möchten Sie tun?

Informationen über das Schützen einer Microsoft Access-Datenbank erhalten

Eine Microsoft Access-Datenbankdatei (.mdb) mit einem Kennwort oder Verschlüsselung schützen

Eine Microsoft Access-Datenbank und zugehörige Tabellen, Abfragen, Formulare, Berichte und Makros mit Sicherheit auf Benutzerebene schützen

Visual Basic für Applikationen-Code mit einem Kennwort oder durch Erstellen einer MDE-Datei schützen

Datenzugriffsseiten schützen

Eine Microsoft Access-Anwendung durch Ausblenden von Objekten im Datenbankfenster und mit Hilfe von Startoptionen schützen

Kennwörter erstellen oder ändern


 Verwenden von Tastenkombinationen zum Markieren von Text oder Daten

Verwenden von Tastenkombinationen zum Markieren von Text oder Daten

Taste(n) | Markieren von Text in einem Feld
UMSCHALT+NACH-RECHTS | Erweitern der Markierung um ein Zeichen nach rechts
STRG+UMSCHALT+NACH-RECHTS | Erweitern der Markierung um ein Wort nach rechts
UMSCHALT+NACH-LINKS | Erweitern der Markierung um ein Zeichen nach links
STRG+UMSCHALT+NACH-LINKS | Erweitern der Markierung um ein Wort nach links

Anmerkung Zum Aufheben einer Markierung verwenden Sie die jeweils entgegengesetzte Pfeiltaste.

Taste(n) | Markieren eines Feldes oder Datensatzes
TAB | Markieren des nächsten Feldes
F2 | Wechseln zwischen Bearbeitungsmodus (Einfügemarke wird angezeigt) und Navigationsmodus
UMSCHALT+LEERTASTE | Wechseln zwischen dem Markieren des aktuellen Datensatzes und dem Markieren des ersten Feldes im aktuellen Datensatz im Navigationsmodus
UMSCHALT+NACH-OBEN | Erweitern der Markierung auf den vorherigen Datensatz, wenn der aktuelle Datensatz markiert ist
UMSCHALT+NACH-UNTEN | Erweitern der Markierung auf den nächsten Datensatz, wenn der aktuelle Datensatz markiert ist
STRG+A oder STRG+UMSCHALT+LEERTASTE | Markieren aller Datensätze

Auswählen von Feldern und Datensätzen in der Datenblattansicht.

Taste(n) | Erweitern einer Markierung
F8 | Aktivieren des Erweiterungsmodus (in der unteren rechten Ecke des Fensters wird ERW angezeigt); durch wiederholtes Drücken von F8 wird die Markierung auf das Wort, das Feld, den Datensatz (nur in der Datenblattansicht) bzw. auf alle Datensätze erweitert
NACH-LINKS oder NACH-RECHTS | Erweitern einer Markierung auf benachbarte Felder in derselben Zeile in der Datenblattansicht
NACH-OBEN oder NACH-UNTEN | Erweitern einer Markierung auf benachbarte Zeilen in der Datenblattansicht
UMSCHALT+F8 | Rückgängigmachen der zuletzt vorgenommenen Markierung
ESC | Deaktivieren des Erweiterungsmodus

Taste(n) | Markieren und Verschieben einer Spalte in der Datenblattansicht
STRG+LEERTASTE | Markieren der aktuellen Spalte oder Aufheben der Spaltenmarkierung (nur im Navigationsmodus)
UMSCHALT+NACH-RECHTS | Markieren der Spalte rechts von der aktuellen Spalte, wenn diese markiert ist
UMSCHALT+NACH-LINKS | Markieren der Spalte links von der aktuellen Spalte, wenn diese markiert ist
STRG+UMSCHALT+F8 | Aktivieren des Verschiebemodus; Anschließend drücken Sie NACH-RECHTS oder NACH-LINKS, um ausgewählte Spalten nach rechts oder links zu verschieben Mehr erfahren über Neuanordnen von Spalten


Gemeinsame Nutzung von Access-Datenbanken im Netzwerk

Was möchten Sie tun?

Methoden zur gemeinsamen Nutzung von Datenbanken

Informationen über die gemeinsame Nutzung von Microsoft Access-Datenbanken im Netzwerk erhalten

Eine Access-Datenbank auf einem Netzwerkserver gemeinsam nutzen

Eine Access-Datenbank ohne Netzwerkserver gemeinsam nutzen

Eine Access-Datenbank in ihre Daten und ihre Objekte aufteilen

Informationen über die drei verschiedenen Webseitentypen erhalten, die Microsoft Access erzeugt

Den Aktenkoffer zum Replizieren von Access-Datenbanken verwenden

Arbeiten in einer Mehrbenutzerumgebung

Informationen über das Bearbeiten von Daten in einer Access-Datenbank in einer Mehrbenutzerumgebung erhalten

Informationen über das Speichern von Entwurfsänderungen in einer gemeinsam genutzten Access-Datenbank erhalten

Möglichkeiten zum Öffnen von Access-Datenbanken erfahren

Festlegen, ob eine Access-Datenbank standardmäßig im Modus für gemeinsame Nutzung oder im Exklusivmodus geöffnet wird

Tipps zum Bearbeiten von Access-Datenbankobjekten in einer Mehrbenutzerumgebung erhalten

Möglichkeiten zur Optimierung der Mehrbenutzer-Performance von Access-Datenbanken erfahren

Umgang mit dem Sperren von Datensätzen

Informationen zur Auswahl einer Strategie zum Sperren von Datensätzen in einer Mehrbenutzerumgebung erhalten

Die Standardstrategie zum Sperren von Datensätzen in Access-Datenbanken in einer Mehrbenutzerumgebung festlegen

Informationen zur Vermeidung von Konflikten beim Sperren von Datensätzen in Access-Datenbanken in einer Mehrbenutzerumgebung erhalten

Die Standardebene des Sperrens von Datensätzen in Access-Datenbanken in einer Mehrbenutzerumgebung festlegen

Die Einstellungen für das Daten- und Anzeigeaktualisierungsintervall für Mehrbenutzerumgebungen und ODBC in Access-Datenbanken festlegen

Anzeigen von aktuellen Daten

Die aktuellsten Daten einer Access-Datenbank in der Datenblatt- oder Formularansicht anzeigen

Die Einstellung ändern, wie oft Daten einer Access-Datenbank in der Datenblatt- oder Formularansicht automatisch aktualisiert werden

Automatisch den neusten Datensatz in einer Access-Datenbank in einem Formular anzeigen

Automatisch den neusten Datensatz in der Datenzugriffsseitenansicht anzeigen


Sortieren oder Gruppieren von Datensätzen in einem Bericht

Was möchten Sie tun?

Datensätze in einem Bericht sortieren

Datensätze in einem Bericht gruppieren

Die Sortier- oder Gruppierreihenfolge in einem Bericht ändern

Ein zusätzliches Sortier- oder Gruppierfeld oder einen Ausdruck zum Sortieren oder Gruppieren in einen Bericht einfügen

Ein Feld oder einen Ausdruck zum Sortieren oder Gruppieren aus einem Bericht löschen

Die Daten in einer Gruppe auf einer Seite oder in einer Spalte auf einer Seite zusammenhalten

Einen Gruppenkopf auf einer anderen Seite oder in einer anderen Spalte wiederholen

Probleme behandeln, die beim Sortieren oder Gruppieren in einem Bericht auftreten


Sortieren und Gruppieren von Datensätzen auf einer Datenzugriffsseite

Was möchten Sie tun?

Eine Standard-Sortierreihenfolge für Datensatzgruppen festlegen

Datensätze auf einer Seite gruppieren

Die Anzahl von Datensätzen festlegen, die in einer Gruppe angezeigt werden

Festlegen, ob eine Gruppe standardmäßig erweitert oder reduziert wird


Überprüfen der Rechtschreibung von Daten

Was möchten Sie tun?

Die Rechtschreibung von Daten in der Datenblattansicht überprüfen

Die Rechtschreibung von Daten in der Formularansicht überprüfen

Die Rechtschreibung eines Datenbankobjekts im Datenbankfenster überprüfen

Ein benutzerdefiniertes Wörterbuch für die Rechtschreibprüfung auswählen


Verwenden von Tastenkombinationen in der Seitenansicht und Layout-Vorschau

Taste(n) | Operationen in Dialogfeldern und Fenstern
P oder STRG+P | Öffnen des Dialogfeldes Drucken
S | Öffnen des Dialogfeldes Seitenformat
Z | Vergrößern oder Verkleinern eines Teils einer Seite
C oder ESC | Seitenansicht oder Layout-Vorschau abbrechen

Taste(n) | Anzeigen bestimmter Seiten
F5 | Anzeigen des Feldes Seitenzahl; geben Sie dann die gewünschte Seitenzahl ein, und drücken Sie die EINGABETASTE
BILD-AB oder NACH-UNTEN | Anzeigen der nächsten Seite (wenn An Fenster anpassen ausgewählt ist)
BILD-AUF oder NACH-OBEN | Anzeigen der vorherigen Seite (wenn An Fenster anpassen ausgewählt ist)

Taste(n) | Bewegen in der Seitenansicht und Layout-Vorschau
NACH-UNTEN | Durchführen eines Bildlaufs nach unten in kleinen Schritten
BILD-AB | Durchführen eines Bildlaufs um eine Seite nach unten
STRG+NACH-UNTEN | Bewegen zum unteren Seitenrand
NACH-OBEN | Durchführen eines Bildlaufs nach oben in kleinen Schritten
BILD-AUF | Durchführen eines Bildlaufs um eine Seite nach oben
STRG+NACH-OBEN | Bewegen zum oberen Seitenrand
NACH-RECHTS | Durchführen eines Bildlaufs nach rechts in kleinen Schritten
ENDE oder STRG+NACH-RECHTS | Bewegen zum rechten Seitenrand
STRG+ENDE | Bewegen zur unteren rechten Ecke der Seite
NACH-LINKS | Durchführen eines Bildlaufs nach links in kleinen Schritten
POS1 oder STRG+NACH-LINKS | Bewegen zum linken Seitenrand
STRG+POS1 | Bewegen zur oberen linken Ecke der Seite


Verwenden von Unterdatenblättern

Was möchten Sie tun?

Informationen zur Verwendung von Unterdatenblättern anzeigen

Ein Unterdatenblatt in eine Tabelle oder Abfrage in einer Microsoft Access-Datenbank einfügen oder es ändern

Ein Unterdatenblatt erweitern oder reduzieren

Ein Unterdatenblatt aus einer Tabelle oder Abfrage in einer Access-Datenbank entfernen

Ein oder mehrere Unterformulare erstellen

Ein Unterformular löschen

Ein Unterdatenblatt drucken


 Überprüfen der Gültigkeit von Werten, die in ein Feld, einen Datensatz oder ein Steuerelement eingegeben werden

Überprüfen der Gültigkeit von Werten, die in ein Feld, einen Datensatz oder ein Steuerelement eingegeben werden

Zum Überprüfen der Gültigkeit eines in ein Feld, einen Datensatz oder ein Steuerelement eingegebenen Wertes können Sie eine Gültigkeitsregel erstellen. Zum Durchführen einer komplexeren Gültigkeitsüberprüfung in einem Formular können Sie ein Makro oder Visual Basic für Applicationen-Code verwenden.

Was möchten Sie tun?

Eine Gültigkeitsregel für ein Feld erstellen

Eine Gültigkeitsregel für einen Datensatz erstellen

Eine Gültigkeitsregel für ein Steuerelement erstellen

Eine komplexe Gültigkeitsprüfung unter Verwendung eines Makros oder von Visual Basic für Applikationen erstellen

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


 Überprüfen der Gültigkeit von Daten oder Einschränken der Dateneingabe in Tabellen

Überprüfen der Gültigkeit von Daten oder Einschränken der Dateneingabe in Tabellen

Sie können steuern, wie Daten in ein Feld in einer Tabelle eingegeben werden sollen. Dazu wählen Sie den entsprechenden Datentyp und die Feldgröße aus. Darüber hinaus können Sie Eigenschaften wie z. B. Eingabeformat und Gültigkeitsregeln festlegen, die die Eingabe von Daten in ein Feld vorgeben.

Was möchten Sie tun?

Weitere Informationen zum Wählen des für ein Feld geeigneten Datentyps anzeigen

Die Feldgröße für ein Feld vom Datentyp Zahl oder Text festlegen

Festlegen, dass in ein Feld Daten eingegeben werden müssen

Ein Eingabeformat zum Steuern der Dateneingabe definieren

Die Eingabe von Duplikatwerten in ein Feld verhindern

Eine Gültigkeitsregel für ein Feld definieren

Eine Gültigkeitsregel für einen Datensatz definieren

Sie wissen nicht, für welche Option Sie sich entscheiden sollen?


Erste Schritte mit Microsoft Access 2000, wenn Sie frühere Versionen von Microsoft Access verwendet haben

Wozu möchten Sie Informationen anzeigen?

Was ist neu in Microsoft Access 2000?

Womit möchten Sie beginnen?

Verwenden einer Microsoft Access-Datenbank in mehreren Versionen von Microsoft Access

Konvertieren einer Datenbank


Erste Schritte mit Microsoft Access 2000, wenn Sie bereits andere Datenbank- oder Tabellenkalkulationsprogramme verwendet haben

Wozu möchten Sie Informationen anzeigen?

Beziehungen in einer Datenbank

Arbeiten mit anderen Anwendungen

Womit möchten Sie beginnen?

Importieren oder Verknüpfen von Daten aus anderen Programmen und mit anderen Dateiformaten

Aufteilen einer Tabelle in verknüpfte Tabellen unter Verwendung des Tabellenanalyse-Assistenten

Erstellen einer Datenbank


Erste Schritte mit Microsoft Access 2000, wenn Sie zum ersten Mal mit einer Datenbank arbeiten

Wozu möchten Sie Informationen anzeigen?

Datenbanken: Definition und Funktionsweise

Tabellen: Definition und Funktionsweise

Abfragen: Definition und Funktionsweise

Formulare: Definition und Funktionsweise

Berichte: Definition und Funktionsweise

Datenzugriffsseiten: Definition und Funktionsweise

Makros: Definition und Funktionsweise

Module: Definition und Funktionsweise

Beziehungen in einer Datenbank

Womit möchten Sie beginnen?

Erstellen einer Datenbank


 Was ist ein gebundenes HTML-Text-Steuerelement?

Was ist ein gebundenes HTML-Text-Steuerelement?

Es ist möglich, HTML-Code in einem Feld in einer Tabelle zu speichern, damit die darin festgelegten Aktionen durchführt werden, wenn die Datenzugriffsseite die Werte in diesem Feld anzeigt. Dies erreichen Sie, indem Sie ein gebundenes HTML-Text-Steuerelement an ein Feld vom Datentyp Text oder Memo in einer Microsoft Access-Datenbank (.mdb) oder an eine Spalte vom Typ text, ntext oder varchar in einem Microsoft Access-Projekt (.adp) binden. Falls der HTML-Text länger ist, binden Sie das gebundene HTML-Text-Steuerelement an ein Feld vom Datentyp Memo (Access-Datenbank) bzw. vom Datentyp text oder ntext (Access-Projekt). Wenn das Feld oder die Spalte als gebundenes HTML-Steuerelement auf einer Datenzugriffsseite platziert wird, wird der Inhalt des Feldes als HTML-Code ausgeführt und lässt sich nicht ändern.

Beispiel: Falls der Wert in einem Feld <font color=red>red Text</font> ist und Sie die DataFormatAs-Eigenschaft auf HTML einstellen, wird der Text in Rot dargestellt, wenn Sie die Datenzugriffsseite in der Datenzugriffsseitenansicht anzeigen. Ist die DataFormatAs-Eigenschaft auf Text eingestellt, dann wird im Steuerelement <font color=red>red Text</font> als Wert angezeigt.

Anmerkungen

  • Sie können das gebundene HTML-Text-Steuerelement als Standardsteuerelement für gruppierte Datenzugriffsseiten einrichten. Stellen Sie dazu die DefaultControlType-Eigenschaft der Datenzugriffsseite auf Gebundener HTML-Text ein.

  • Außerdem können Sie mit einem gebundenen HTML-Text-Steuerelement Berechnungen und alle Daten auf einer gruppierten Datenzugriffsseite anzeigen. Die Seite wird in Microsoft Internet Explorer 5 schneller geladen, wenn Sie HTML-Steuerelemente verwenden.

Weitere Informationen

Erstellen von gebundenen HTML-Text-Steuerelementen auf Datenzugriffsseiten


Was ist neu bei Microsoft Access 2000?

Zu welchem Gebiet möchten Sie Informationen anzeigen?

Mit Datenzugriffsseiten arbeiten

Mit Microsoft Access-Projekten arbeiten

Im Internet oder einem Intranet arbeiten

Mit Daten und Datenbankentwürfen arbeiten

Im Datenbankfenster arbeiten

Programmieren mit Visual Basic

Datenbanken schützen, verwalten und konvertieren

Formulare und Berichte erstellen und anpassen

Mit Replizierung von Datenbanken arbeiten

Mit den Beispielanwendungen arbeiten

Symbolleisten, Menüleisten und Kontextmenüs verwenden und anpassen

Mit Makros arbeiten

Mit anderen Anwendungen arbeiten

Was ist neu bei Microsoft Office 2000?


Verwenden von Tastenkombinationen im Datenbankfenster

Taste(n) | Bearbeiten der und Bewegen in der Objektliste
F2 | Umbenennen des markierten Objekts
NACH-UNTEN | Bewegen um eine Zeile nach unten
BILD-AB | Bewegen um ein Fenster nach unten
ENDE | Bewegen zum letzten Objekt
NACH-OBEN | Bewegen um eine Zeile nach oben
BILD-AUF | Bewegen um ein Fenster nach oben
POS1 | Bewegen zum ersten Objekt

Taste(n) | Bewegen zwischen Objekten und Öffnen von Objekten
STRG+TAB | Bewegen durch die Objektleiste von oben nach unten
UMSCHALT+STRG+TAB | Bewegen durch die Objektleiste von unten nach oben
ENTER oder ALT+O | Öffnen der markierten Tabelle oder Abfrage in der Datenblattansicht bzw. des markierten Formulars in der Formularansicht
EINGABETASTE | Öffnen des markierten Berichts in der Seitenansicht
EINGABETASTE | Öffnen der ausgewählten Datenzugriffsseite in der Seitenansicht
EINGABETASTE | Ausführen des markierten Makros
STRG+EINGABETASTE oder ALT+D | Öffnen der markierten Tabelle, Abfrage, des Formulars, Berichts, der Datenzugriffsseite oder des Moduls in der Entwurfsansicht
ALT+N | Erstellen einer neuen Tabelle, einer Abfrage, eines Formulars, eines Berichts, einer Datenzugriffsseite, eines Makros oder eines Moduls
F5 | Aktualisieren des Datenbankfensters
STRG+G | Anzeigen des Direktfensters im Visual Basic-Editor


Arbeiten mit Kombinationsfeldern

Was möchten Sie tun?

Das Kombinationsfeld verschieben

Die Größe des Kombinationsfelds ändern

Fehler bei Problemen mit dem Kombinationsfeld beseitigen

Informationen zu Eigenschaften anzeigen, mit denen das Kombinationsfeld verändert werden kann


Arbeiten mit Befehlsschaltflächen

Was möchten Sie tun?

Die Befehlsschaltfläche verschieben

Die Größe der Befehlsschaltfläche ändern

Ein Bild zur Befehlsschaltfläche hinzufügen

Die Beschriftung der Befehlsschaltfläche ändern

Die Ereignisprozedur anzeigen, die vom Befehlsschaltflächen-Assistenten erstellt wurde


Arbeiten mit importierten oder verknüpften Dateien

Was möchten Sie tun?

Eine Tabelle anpassen

Importprobleme beheben

Eigenschaften für eine verknüpfte Tabelle einstellen


Arbeiten mit Listenfeldern

Was möchten Sie tun?

Das Listenfeld verschieben

Die Größe des Listenfelds ändern

Fehler bei Problemen mit dem Listenfeld beseitigen

Informationen zu Eigenschaften anzeigen, mit denen das Listenfeld verändert werden kann


Arbeiten mit Nachschlagefeldern

Was möchten Sie tun?

Informationen zu Eigenschaften erhalten, die ich verwenden kann, um ein Nachschlagefeld zu ändern

Informationen zu Nachschlagefeldern und deren Funktionsweise erhalten


Arbeiten mit Optionsgruppen

Was möchten Sie tun?

Die Optionsgruppe verschieben

Die Größe der Optionsgruppe ändern

Fehler bei Problemen mit der Optionsgruppe beseitigen


Verwendung des Benutzerdatensicherheits-Assistenten

Was möchten Sie tun?

Tipps zur Verwendung des Benutzerdatensicherheits-Assistenten erhalten

Informationen über Microsoft Access-Arbeitsgruppen erhalten

Informationen über die Organisation von Sicherheitskonten erhalten

Informationen darüber erhalten, wie Berechtigungen funktionieren und wer sie vergeben kann

Typen von Berechtigungen

Informationen zum Erstellen und Ändern von Kennwörtern erhalten


Arbeiten mit Unterformularen

Was möchten Sie tun?

Das Unterformular-Steuerelement verschieben

Die Größe des Unterformular-Steuerelements ändern

Das Layout des Unterformulars ändern

Fehler bei Problemen mit dem Unterformular beseitigen


Arbeiten mit dem Datenblatt einer Kreuztabellenabfrage

Was möchten Sie tun?

Schriftart oder Schriftschnitt, Schriftgrad oder Schriftfarbe ändern

Den Gitternetzlinienstil oder die Hintergrundfarbe ändern

Die Zeilenhöhe ändern

Die Spaltenbreite ändern

Das gesamte Datenblatt oder die markierten Datensätze drucken

Anmerkung In einer Kreuztabellenabfrage können Sie keine Daten bearbeiten.


Arbeiten mit Daten aus mehreren Tabellen

Was möchten Sie tun?

Einen Überblick über die Möglichkeiten, Daten aus mehreren Tabellen oder Abfragen in einer Abfrage zusammenzubringen, anzeigen

Mehrere Tabellen und Abfragen in einer Abfrage verknüpfen

Einen Überblick über Verknüpfungsarten und deren Auswirkung auf Abfrageergebnisse anzeigen

Den Typ einer Verknüpfung zwischen Tabellen und Abfragen in einer Abfrage ändern


Arbeiten mit Daten in der Datenzugriffsseitenansicht

Was möchten Sie tun?

Daten hinzufügen, bearbeiten oder löschen

Mit Hilfe der Navigationsschaltflächen in der Datenzugriffsseitenansicht zwischen Datensätzen wechseln

Einen neuen Datensatz in der Datenzugriffsseitenansicht hinzufügen

Felder oder Datensätze in der Datenzugriffsseitenansicht auswählen

Die Daten in einem Feld in der Datenzugriffsseitenansicht bearbeiten

Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen in der Datenzugriffsseitenansicht rückgängig machen

Die neuesten Daten in der Datenzugriffsseitenansicht anzeigen

Eine Hyperlinkadresse in der Datenzugriffsseitenansicht eingeben

Den Pfad zu einem Bild in der Datenzugriffsseitenansicht hinzufügen, ändern oder löschen

Datensätze speichern oder löschen

Einen Datensatz in der Datenzugriffsseitenansicht speichern

Einen Datensatz in der Datenzugriffsseitenansicht löschen

Daten sortieren und filtern

Daten in der Datenzugriffsseitenansicht sortieren

Bestimmte Daten unter Verwendung eines Filters in der Datenzugriffsseitenansicht finden

Einen vorhandenen Filter auf Daten in der Datenzugriffsseitenansicht anwenden

Einen Filter entfernen, um alle Datensätze in der Datenzugriffsseitenansicht anzuzeigen

Tastenkombinationen verwenden

Tastenkombinationen in der Datenzugriffsseitenansicht verwenden


Arbeiten mit Duplikaten in der Abfrage-Datenblattansicht

Was möchten Sie tun?

Duplikate löschen

Die Daten in einem Feld bearbeiten

Das gesamte Datenblatt oder die markierten Datensätze drucken


Arbeiten mit Makros in Visual Basic

Was möchten Sie tun?

Makros in Microsoft Visual Basic konvertieren

In einer Visual Basic-Prozedur eine Makroaktion ausführen

Eine Liste der Makroaktionen anzeigen, zu denen keine entsprechenden DoCmd-Methoden vorliegen


Arbeiten mit Objekten in Visual Basic unter Verwendung des Objektkatalogs

Was möchten Sie tun?

Im Objektkatalog eine Methode oder Eigenschaft finden

Mit Hilfe des Objektkatalogs Methoden- oder Eigenschaftensyntax in ein Modul einfügen


Arbeiten mit Beziehungen

Was möchten Sie tun?

Informationen zu Beziehungen in einer Tabelle anzeigen

Vorhandene Beziehungen anzeigen

Beziehungen zwischen Tabellen definieren

Eine n:n-Beziehung zwischen Tabellen definieren

Den Standardverknüpfungstyp für eine Beziehung zwischen Tabellen festlegen

Eine vorhandene Beziehung bearbeiten

Eine Beziehung löschen

Eine Tabelle aus dem Fenster Beziehungen entfernen

Den Entwurf einer Tabelle im Fenster Beziehungen ändern

Informationen zur referenziellen Integrität anzeigen

Informationen zu Aktualisierungs- und Löschweitergaben anzeigen

Beziehungen mit Hilfe der Tastatur verwalten

Unterdatenblätter verwenden

Beziehungen ausdrucken


Arbeiten mit Unterberichten

Was möchten Sie tun?

Das Unterbericht-Steuerelement verschieben

Die Größe des Unterbericht-Steuerelements ändern


Arbeiten mit nicht übereinstimmenden Datensätzen in der Abfrage-Datenblattansicht

Was möchten Sie tun?

Einen nicht übereinstimmenden Datensatz löschen

Einen übereinstimmenden Datensatz in der anderen Tabelle hinzufügen

Das gesamte Datenblatt oder die markierten Datensätze drucken


Umgang mit Benutzer- und Gruppenkonten

Was möchten Sie tun?

Sicherheitskonten verstehen

Informationen über die Organisation von Sicherheitskonten erhalten

Konten erstellen, Benutzer hinzufügen und Informationen ausdrucken

Ein Sicherheitsadministratorkonto erstellen

Ein Sicherheitsbenutzerkonto erstellen

Ein Sicherheitsgruppenkonto erstellen

Benutzer zu Sicherheitsgruppenkonten hinzufügen

Informationen über Sicherheitsbenutzer- und Sicherheitsgruppenkonten ausdrucken

Konten löschen und Benutzer entfernen

Benutzer aus Sicherheitsgruppenkonten entfernen

Ein Sicherheitsbenutzerkonto löschen

Ein Sicherheitsgruppenkonto löschen

Mit Kennwörtern arbeiten

Ein Kennwort für ein Sicherheitskonto erstellen oder ändern

Ein Kennwort für ein Sicherheitskonto löschen

Eigentumsrechte anzeigen oder übertragen

Das Eigentum an einzelnen Objekten in einer gesicherten Datenbank anzeigen oder übertragen

Das Eigentum an einer ganzen Datenbank an einen anderen Administrator übertragen


Mit Arbeitsgruppen-Informationsdateien arbeiten

Was möchten Sie tun?

Arbeitsgruppen-Informationsdateien verstehen

Informationen über Microsoft Access-Arbeitsgruppen erhalten

Informationen über die Bereitstellung einer geschützten Anwendung und Arbeitsgruppe für Benutzer erhalten

Arbeitsgruppen-Informationsdateien erstellen und sich einer Arbeitsgruppe anschließen

Eine neue Microsoft Access-Arbeitsgruppen-Informationsdatei erstellen

Sich einer Arbeitsgruppe unter Verwendung des Arbeitsgruppen-Administrators anschließen

Mehrere Arbeitsgruppen einrichten, die dieselbe geschützte Datenbank verwenden

Informationen über das Einrichten der Sicherheit auf Benutzerebene für eine bestimmte Access-Datenbank erhalten

Anmelden bei einer Arbeitsgruppen-Informationsdatei

Sich bei einer Microsoft Access-Arbeitsgruppe anmelden

Die Anmeldung bei Microsoft Access obligatorisch einführen

Das Anmeldedialogfeld deaktivieren

Arbeitsgruppen-Informationsdateien wiederherstellen oder wiederaufbauen

Eine beschädigte oder gelöschte Microsoft Access-Arbeitsgruppen-Informationsdatei wiederherstellen

Eine Arbeitsgruppen-Informationsdatei aus den Benutzer- und Gruppennamen und den Identifikationskennungen wiederaufbauen


 #Const-Anweisung

#Const-Anweisung

In Microsoft Access können Sie eine öffentliche bedingte Kompilierkonstante im Deklarationsbereich eines Moduls definieren. Eine öffentliche Kompilierkonstante ist für alle Module der aktuellen Datenbank gültig, jedoch in keiner anderen Datenbank.

Sie können eine öffentliche Kompilierkonstante auch deklarieren, indem Sie im Menü Extras auf Optionen klicken und anschließend auf die Registerkarte Weitere klicken. Geben Sie die Konstante in das Feld Bedingte Kompilierungsargumente ein.

Geben Sie z. B. folgenden Ausdruck in das Feld Bedingte Kompilierungsargumente ein:

conDebug = 1

In jedem Modul können Sie in dessen Code öffentliche Kompilierkonstanten verwenden. Sie können z. B. ein #If...Then...#Else-Konstrukt erstellen, um optional Code für eine Testversion auszuführen.

#If conDebug = 1 Then
    .        ' Code für Testversion ausführen.
    .
    .
#Else
    .        ' Optimierten Code ausführen.
    .
    .
#End If

Wenn Sie mehrere öffentliche bedingte Kompilierkonstanten erstellen möchten, deklarieren Sie diese in separaten Zeilen im Deklarationsbereich. Trennen Sie sie im Feld Bedingte Kompilierungsargumente durch Doppelpunkte. Sie können z. B. die folgenden bedingten Kompilierkonstanten in das Feld Bedingte Kompilierungsargumente eingeben.

conActiveLanguage = 1 : conDebug = 1

Sie können einen logischen Operator verwenden, um beide Konstanten in ein #If...Then...#Else-Konstrukt aufzunehmen. Im folgenden Beispiel wird das erste Codestück nur ausgeführt, wenn beide Konstanten den Wert 1 haben, so dass der Ausdruck, der beide Konstanten enthält, wahr ist.

#If (conActiveLanguage = 1 And conDebug = 1) Then
    .        ' Testcode für aktive Sprachversion ausführen.
    .
    .
#Else
    .        ' Anderes Codestück ausführen.
    .
    .
#End If

Wenn eine oder beide Konstanten einen anderen Wert haben, wird der Code im #Else-Teil des Konstrukts ausgeführt. Wenn Sie ändern möchten, welcher Codeblock ausgeführt wird, ändern Sie einfach die Werte der Konstanten.

Anmerkungen

  • Eine bedingte Kompilierkonstante wird immer mit einer textbasierten Methode zum Zeichenfolgenvergleich ausgewertet. Dies entspricht der Verwendung einer Anweisung Option Compare Text im Modul. Die Auswertung wird auch dann vorgenommen, wenn das Modul eine Anweisung Option Compare Database enthält.

  • Beim Schreiben von Code für die bedingte Kompilierung ist es möglicherweise übersichtlicher, jeweils nur eine Prozedur statt aller Prozeduren im Modul anzuzeigen. Wenn Sie die Art der Anzeige des Codes ändern möchten, wählen Sie aus dem Menü Extras den Befehl Optionen, und klicken Sie auf die Registerkarte Editor. Deaktivieren Sie unter Fenstereinstellungen das Kontrollkästchen Standardmäßig ganzes Modul anzeigen.


 Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung) - Ereignisprozeduren

Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Activate oder Deactivate-Ereignis eintritt, stellen Sie die Eigenschaft OnActivate bzw. OnDeactivate auf [Ereignisprozedur] ein und klicken dann auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Form_Activate( )

Private Sub Report_Activate( )

Private Sub Form_Deactivate( )

Private Sub Report_Deactivate( )

Anmerkung

Sie können die Ereignisprozeduren für Activate und Deactivate zum Anzeigen und Ausblenden benutzerdefinierter Symbolleisten verwenden. Wenn Sie zum Ausblenden einer benutzerdefinierten Symbolleiste die Ereignisprozedur für Deactivate verwenden, müssen Sie sicherstellen, dass die Symbolleiste als Reaktion auf das formularbezogene Ereignis Unload ausgeblendet wird, da das Ereignis Deactivate nicht eintritt, wenn ein Formular oder Bericht geschlossen wird. Verwenden Sie zum Anzeigen oder Ausblenden einer Symbolleiste in einem Formular nicht das Ereignis GotFocus oder LostFocus, da diese nicht für Formulare ausgelöst werden, die aktivierte Steuerelemente enthalten.

Die Ereignisse Activate und Deactivate können nicht unterbunden werden.


Activate-, Deactivate-Ereignis (Aktivierung, Deaktivierung) - Beispiel

Das nachstehende Beispiel zeigt, wie eine benutzerdefinierte Symbolleiste namens EigeneSymbolleiste angezeigt wird, wenn ein Formular den Fokus erhält, und wie diese ausgeblendet wird, wenn der Fokus an ein anderes Fenster abgegeben wird.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das eine benutzerdefinierte Symbolleiste namens EigeneSymbolleiste enthält.

Private Sub Form_Activate()
    ' Die benutzerdefinierte Symbolleiste anzeigen.
    DoCmd.ShowToolbar "EigeneSymbolleiste", acToolbarYes
End Sub

Private Sub Form_Deactivate()
    ' Die benutzerdefinierte Symbolleiste ausblenden.
    DoCmd.ShowToolbar "EigeneSymbolleiste", acToolbarNo
End Sub


 Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung) - Makros

Activate-, Deactivate-Ereignisse (Aktivierung, Deaktivierung) - Makros

Zum Ausführen eines Makros bei Eintreten des Activate oder Deactivate-Ereignisses stellen Sie die Eigenschaft OnActivate bzw. OnDeactivate auf den Namen des Makros ein.

Anmerkung

Sie können in einem Makro für das Activate- oder Deactivate-Ereignis die ShowToolbar-Aktion verwenden, um eine benutzerdefinierte Symbolleiste anzuzeigen oder auszublenden. Verwenden Sie das Activate- oder Deactivate-Ereignis zum Anzeigen bzw. Ausblenden von benutzerdefinierten Symbolleisten, wenn Sie gleichzeitig mehrere Formulare geladen haben. Wenn Sie nur ein Formular geladen haben, können Sie die Ereignisse Open und Close verwenden.

Wenn Sie zum Ausblenden einer benutzerdefinierten Symbolleiste ein Makro für das Ereignis Deactivate verwenden, müssen Sie sicherstellen, dass die Symbolleiste als Reaktion auf das formularbezogene Ereignis Unload ausgeblendet wird, da das Ereignis Deactivate beim Schließen eines Formulars nicht eintritt. Verwenden Sie zum Ausblenden einer Symbolleiste nicht das Ereignis GotFocus oder LostFocus, da diese Ereignisse nicht in Formularen ausgelöst werden, die aktivierte Steuerelemente enthalten.

Die Aktion CancelEvent kann in einem Makro für das Activate- bzw. Deactivate-Ereignis nicht verwendet werden.


 ApplyFilter-Ereignis (AnwendenFilter) - Ereignisprozeduren

ApplyFilter-Ereignis (AnwendenFilter) - Ereignisprozeduren

Wenn Sie eine Ereignisprozedur erstellen möchten, die ausgeführt wird, sobald das Ereignis ApplyFilter eingetreten ist, stellen Sie die Eigenschaft OnApplyFilter auf [Ereignisprozedur] ein und klicken auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Form_ApplyFilter(Cancel As Integer, ApplyType As Integer)

Eine ApplyFilter-Ereignisprozedur hat folgende Argumente.

Argument | Beschreibung
Cancel | Die Einstellung dieses Arguments gibt an, ob der Filter zugewiesen werden soll. Wenn Sie das Argument Cancel auf True (-1) einstellen, wird der Filter nicht zugewiesen. Sie können auch die Methode CancelEvent des Objekts DoCmd verwenden, um dafür zu sorgen, dass der Filter nicht zugewiesen wird.
ApplyType | Dieses Argument gibt den Vorgang an, der das Eintreten des Ereignisses ApplyFilter bewirkt hat. Das Argument ApplyType ist auf eine der folgenden eingebauten Konstanten eingestellt:
 | Konstante | Wert
 | acShowAllRecords | 0
 | acApplyFilter | 1
 | acCloseFilterWindow | 2
 | acApplyServerFilter | 3
 | acCloseServerFilterWindow | 4

Anmerkung

Mit einer ApplyFilter-Ereignisprozedur können Sie bestimmte Steuerelemente eines Formulars anzeigen bzw. ausblenden oder aktivieren bzw. deaktivieren, wenn der Filter zugewiesen oder entfernt wird. Wenn z.B. einem Formular namens Bestellungen ein Filter zugewiesen ist, der dafür sorgt, dass nur die bereits bezahlten Bestellungen angezeigt werden, könnten Sie die Felder Betrag, MWSt und Gesamtbetrag ausblenden, solange das Argument ApplyType den Wert acApplyFilter hat, und diese Felder wieder anzeigen, sobald das Argument ApplyType den Wert acShowAllRecords hat.

Sie können eine ApplyFilter-Ereignisprozedur auch verwenden, um Vorgänge rückgängig zu machen, die als Reaktion auf das Ereignis Filter ausgeführt wurden. Dies ist insbesondere dann hilfreich, wenn der Benutzer das Fenster für die Filterdefinition geschlossen hat, ohne einen Filter zu erstellen (das Argument ApplyType hat dann den Wert acCloseFilterWindow bzw. acCloseServerFilterWindow).


ApplyFilter-Ereignis (AnwendenFilter) - Ereignisprozedur: Beispiel

Das folgende Beispiel zeigt, wie Sie die Steuerelemente Betrag, MWSt und Gesamtbetrag eines Formular namens Bestellungen ausblenden können, wenn der zugewiesene Filter die Datensätze so begrenzt, dass nur die Bestellungen angezeigt werden, deren Rechnungen beglichen wurden.

Sie können dieses Beispiel ausprobieren, indem Sie die folgende Ereignisprozedur zu einem Formular namens Bestellungen hinzufügen, das die Steuerelemente Betrag, MWSt und Gesamtbetrag enthält. Führen Sie einen Filter aus, der nur die Bestellungen anzeigt, die bereits bezahlt sind.

Private Sub Form_ApplyFilter(Cancel As Integer, ApplyType As Integer)
    If Not IsNull(Me.Filter) And (InStr(Me.Filter, "Bestellungen.Bezahlt=-1")>0 _
            Or InStr(Me.Filter, "Bestellungen.Bezahlt=True")>0)Then
        If ApplyType = acApplyFilter Then
            Formulare!Bestellungen!Betrag.Visible = False
            Formulare!Bestellungen!MWSt.Visible = False
            Formulare!Bestellungen!Gesamtbetrag.Visible = False
        ElseIf ApplyType = acShowAllRecords Then
            Formulare!Bestellungen!Betrag.Visible = True
            Formulare!Bestellungen!MWSt.Visible = True
            Formulare!Bestellungen!Gesamtbetrag.Visible = True
        End If
    End If
End Sub


 ApplyFilter-Ereignis (AnwendenFilter) - Makros

ApplyFilter-Ereignis (AnwendenFilter) - Makros

Soll ein Makro ausgeführt werden, wenn das Ereignis ApplyFilter eintritt, stellen Sie die Eigenschaft OnApplyFilter auf den Namen des Makros ein.

Anmerkungen

Sie können einen Filter prüfen oder die Kriterien ändern, die der Benutzer eingegeben hat, indem Sie in dem AnwendenFilter-Makro in einer Makrobedingung den Wert der Filter- bzw. ServerFilter-Eigenschaft lesen oder mit der Aktion SetzenWert den Wert der Eigenschaft einstellen.

Sie können in einem AnwendenFilter-Makro die Aktion AbbrechenEreignis verwenden, um die Zuweisung des Filters abzubrechen. In einer Bedingung können Sie die Werte bestimmter Steuerelemente des Formulars prüfen und gezielt den jeweils geeigneten Filter zuweisen. Angenommen, auf dem Formular Bestellungen gibt es ein Kontrollkästchen namens HatUnerledigteBestellungen. Wenn dieses Kontrollkästchen aktiviert ist, könnten Sie einen Filter zuweisen, der dafür sorgt, dass auf dem Formular die Datensätze angezeigt werden, die unerledigte Bestellungen enthalten. Ist das Kontrollkästchen deaktiviert, können Sie die Zuweisung des Filters abbrechen und eine Meldung anzeigen, die mitteilt, dass es keine unerledigten Bestellungen gibt.


 BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe) - Ereignisprozeduren

BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis BeforeInsert oder AfterInsert eintritt, stellen Sie die Eigenschaft BeforeInsert bzw. AfterInsert auf [Ereignisprozedur] ein und klicken dann auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Form_BeforeInsert(Cancel As Integer)

Private Sub Form_AfterInsert( )

Die Ereignisprozedur für das Ereignis BeforeInsert hat das folgende Argument.

Argument | Beschreibung
Cancel | Diese Einstellung legt fest, ob das Ereignis BeforeInsert eintritt. Wenn Sie das Argument Cancel auf True (-1) einstellen, wird das Ereignis BeforeInsert unterbunden.

Anmerkung

Das Ereignis AfterInsert kann nicht unterbunden werden.


BeforeInsert-, AfterInsert-Ereignisprozeduren (VorEingabe, NachEingabe) - Beispiel

Das nachstehende Beispiel zeigt, wie Sie mit einer Ereignisprozedur für das Ereignis BeforeInsert überprüfen können, ob ein Benutzer einen neuen Datensatz erstellen möchte, und wie Sie mit einer Ereignisprozedur für AfterInsert die Datenherkunft für das Formular Personal erneut abfragen, sobald ein neuer Datensatz hinzugefügt wurde.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular mit dem Namen Personal hinzu, das auf einer Tabelle oder Abfrage basiert. Wechseln Sie zur Datenblattansicht des Formulars, und versuchen Sie, einen Datensatz einzufügen.

Private Sub Form_BeforeInsert(Cancel As Integer)
    If MsgBox("Datensatz hier einfügen?", vbOKCancel) = vbCancel Then
        Cancel = True
    End If
End Sub

Private Sub Form_AfterInsert()
    Formulare!Personal.Requery
End Sub


 BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe) - Makros

BeforeInsert-, AfterInsert-Ereignisse (VorEingabe, NachEingabe) - Makros

Wenn beim Eintreten des BeforeInsert oder AfterInsert-Ereignisses ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft BeforeInsert bzw. AfterInsert auf den Namen des Makros ein.

Anmerkung

Mit diesen Makros können Sie Meldungen oder nützliche Informationen anzeigen. Mit einem Makro für das Ereignis BeforeInsert können Sie z.B. Daten anzeigen, die der Benutzer beim Eingeben eines neuen Datensatzes benötigt.

In einem Makro für das BeforeInsert-Ereignis kann die Aktion CancelEvent verwendet werden, um das Erstellen eines neuen Datensatzes zu unterbinden. Wenn Sie die Aktion CancelEvent in einem Makro für BeforeInsert verwenden, kehrt der Fokus zum neuen, leeren Datensatz zurück (das Zeichen, das der Benutzer eingegeben hat, ist gelöscht).

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis AfterInsert nicht eingesetzt werden.


 BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung) - Ereignisprozeduren

BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des BeforeUpdate- oder AfterUpdate-Ereignisses ausgeführt wird, indem Sie die Eigenschaft BeforeUpdate bzw. AfterUpdate auf [Ereignisprozedur] einstellen und dann auf die Generator-Schaltfläche [image] klicken.

Syntax

Private Sub Form_BeforeUpdate (Cancel As Integer)

Private Sub Steuerelementname_BeforeUpdate (Cancel As Integer)

Private Sub Form_AfterUpdate ( )

Private Sub Steuerelementname_AfterUpdate ( )

Die Ereignisprozedur für das Ereignis BeforeUpdate hat folgende Argumente:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen BeforeUpdate-Ereignisprozedur Sie ausführen möchten.
Cancel | Die Einstellung gibt an, ob das Ereignis BeforeUpdate eintritt. Das Einstellen von Cancel auf True (-1) unterbindet das Ereignis BeforeUpdate.

Die Ereignisprozedur für das Ereignis AfterUpdate hat das folgende Argument:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, auf das sich die AfterUpdate-Ereignisprozedur auswirkt.

Anmerkung

Das Ereignis AfterUpdate kann nicht unterbunden werden.

Sie können eine Ereignisprozedur für das Ereignis AfterUpdate verwenden, um eine andere Seite des Formulars anzuzeigen oder den Fokus auf ein bestimmtes Steuerelement oder einen bestimmten Datensatz zu bewegen. Wenn der Benutzer z. B. in das Steuerelement Kategorie eines Formulars einen Wert eingibt, können Sie in der Ereignisprozedur für das Ereignis AfterUpdate mit der Methode GoToPage den Fokus auf die Seite des Formulars bewegen, auf der sich die Steuerelemente dieser Kategorie befinden.


BeforeUpdate-, AfterUpdate-Ereignisprozeduren (VorAktualisierung, NachAktualisierung) - Beispiel

Dieses Beispiel zeigt, wie Sie mit einer Ereignisprozedur für das Ereignis BeforeUpdate überprüfen können, ob ein Artikelname bereits eingegeben wurde. Nachdem der Benutzer in das Feld Artikelname einen Artikelnamen eingegeben hat, wird der Wert mit dem Feld Artikelname der Tabelle Artikel verglichen. Stimmen die Werte überein, wird der Benutzer in einer Meldung darauf hingewiesen, dass der Artikel bereits in der Datenbank enthalten ist.

Sie können dieses Beispiel testen, indem Sie die folgende Ereignisprozedur zu einem Formular namens Artikel hinzufügen, das ein Textfeld namens Artikelname enthält.

Private Sub ProductName_BeforeUpdate(Cancel As Integer)
    If(Not IsNull(DLookup("[Artikelname]", _
        "Artikel", "[Artikelname] ='" _
        & Me!Artikelname & "'"))) Then
        MsgBox "Dieser Artikel wurde bereits in die Datenbank eingegeben."
        Cancel = True
        Me!Artikelname.Undo
    End If
End Sub


 BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung) - Makros

BeforeUpdate-, AfterUpdate-Ereignisse (VorAktualisierung, NachAktualisierung) - Makros

Sie können beim Eintreten des BeforeUpdate- oder AfterUpdate-Ereignisses ein Makro ausführen, indem Sie die Eigenschaft BeforeUpdate oder AfterUpdate auf den Namen des Makros einstellen. Microsoft Access führt dann das Makro für ein Steuerelement oder Formular aus, bevor bzw. nachdem die Daten im Steuerelement oder im aktuellen Datensatz des Formulars aktualisiert sind. Werden die Daten im Steuerelement oder Datensatz nicht aktualisiert, wird das Makro nicht ausgeführt.

Anmerkung

Sie können Makros für das Ereignis BeforeUpdate verwenden, wenn Sie alle Gültigkeitsüberprüfungen für ein Formular in einer Makrogruppe speichern oder einen Ausdruck für die Gültigkeitsregel in mehreren Formularen verwenden.

Sie haben z. B. ein Formular, in dem der Benutzer den Namen eines Landes in das Steuerelement Land und die entsprechende Postleitzahl in das Steuerelement Postleitzahl eingibt. In diesem Fall können Sie bedingte Ausdrücke im Makro verwenden, um sicherzustellen, dass sich die Werte entsprechen, die in die Steuerelemente eingegeben wurden. Wenn der Benutzer dann in das Steuerelement Postleitzahl ungültige Werte eingibt, wird eine Meldung angezeigt.

Sie können ein Makro für das AfterUpdate-Ereignis verwenden, um eine andere Seite des Formulars anzuzeigen oder den Fokus auf ein bestimmtes Steuerelement oder einen bestimmten Datensatz zu bewegen. Wenn der Benutzer z. B. in das Steuerelement Kategorie eines Formulars einen Wert eingibt, können Sie in einem Makro für das BeforeUpdate-Ereignis mit der Aktion GeheZuSeite den Fokus auf die Seite des Formulars bewegen, auf der die Steuerelemente dieser Kategorie enthalten sind.

Sie können in einem Makro für das Ereignis AfterUpdate die Aktion AbbrechenEreignis verwenden, um die Aktualisierung zu unterbinden. Wenn dieses Makro einem Steuerelement zugeordnet ist, setzt die Aktion AbbrechenEreignis den Fokus auf das Steuerelement zurück, und die vom Benutzer eingegebenen Daten verbleiben im Steuerelement.

Wenn ein Makro für das Ereignis BeforeUpdate einem Formular zugeordnet ist, in dem es bei jeder Datensatzänderung ausgeführt wird, setzt die Aktion AbbrechenEreignis den Fokus auf den Datensatz zurück.

In einem Makro für das Ereignis AfterUpdate können Sie die Aktion AbbrechenEreignis nicht verwenden, um das Ereignis AfterUpdate zu unterbinden.


 Change-Ereignis (Änderung) - Ereignisprozeduren

Change-Ereignis (Änderung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die bei Eintreten des Change-Ereignisses ausgeführt wird, stellen Sie die Eigenschaft Bei Änderung auf [Ereignisprozedur] ein und klicken dann auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Steuerelementname_Change( )

Eine Ereignisprozedur für das Change-Ereignis hat das folgende Argument.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen Change-Ereignisprozedur ausgeführt werden soll.

Anmerkung

Das Change-Ereignis kann nicht unterbunden werden.

Um sich wiederholende Ereignisse zu verhindern, erstellen Sie für ein Steuerelement, das seinen Inhalt ändert (z. B. durch Einstellen der Eigenschaft Text für das Steuerelement) keine Ereignisprozedur für das Change-Ereignis. Wenn Sie eine solche Ereignisprozedur trotzdem erstellen, müssen Sie eine Variable festlegen, die weitere Änderungen so lange verhindert, bis die jeweils aktuelle Änderung abgeschlossen ist.


Change (Änderung)-Ereignisprozedur - Beispiel

Das folgende Beispiel zählt die Anzahl der Zeichen, die in ein Textfeld eingegeben wurden. Wurden mehr als drei Zeichen eingegeben, wird eine Meldung angezeigt und der Zähler auf 0 zurückgesetzt.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular namens Bestellungen hinzu, das ein Textfeld namens Region enthält.

Private Sub Region_Change()
    ' Variable als statisch deklarieren, damit ihr Wert von einem
    ' Aufruf zum nächsten erhalten bleibt.
    Static intBuchstabe As Integer

    ' Prüfen, wie viele Zeichen eingegeben wurden.
    ' Bei mehr als drei Zeichen den Wert des Textfelds zurücksetzen.
    If intBuchstabe < 3 Then
        intBuchstabe = intBuchstabe + 1
    Else
        MsgBox "Es sind nur drei Zeichen erlaubt."
        intBuchstabe = 0
        Formulare!Bestellungen!Region.Undo
    End If
End Sub


 Change-Ereignis (Änderung) - Makros

Change-Ereignis (Änderung) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses Change stellen Sie die Eigenschaft Change auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis Change zum Synchronisieren der Daten zweier Steuerelemente verwenden. Wenn in einem Steuerelement eine Änderung eintritt, kann ein zweites entsprechend angepasst werden.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Change nicht eingesetzt werden.


 Click-Ereignis (Klicken) - Ereignisprozeduren

Click-Ereignis (Klicken) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Click ausgeführt wird, indem Sie die Eigenschaft Beim Klicken auf [Ereignisprozedur] einstellen und dann auf die Aufbauen-Schaltfläche [image] klicken.

Syntax

Private Sub Form_Click

Private Sub Steuerelementname_Click

Die Ereignisprozedur für das Ereignis Click hat folgendes Argument:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen Click-Ereignisprozedur Sie ausführen möchten.

Anmerkung

Wenn der Benutzer auf ein Listenfeld doppelklickt, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

MouseDown Þ MouseUp Þ Click Þ DblClick

Bei anderen Steuerelementen ist die Reihenfolge der Ereignisse ähnlich. Wenn Sie Ereignisprozeduren für diese zusammengehörenden Ereignisse erstellen, muss der Code in den Ereignisprozeduren aufeinander abgestimmt sein. Die Ereignisprozedur für DblClick darf z. B. keinen Code enthalten, der die Aktionen unterbindet, die in der Ereignisprozedur für Click ausgeführt werden.

Das Ereignis Click kann nicht unterbunden werden.


Click-Ereignisprozeduren (Klicken) - Beispiel

In diesem Beispiel wird die Ereignisprozedur für das Ereignis Click dem Kontrollkästchen Schreibgeschützt zugeordnet. Die Ereignisprozedur stellt die Eigenschaften Enabled und Locked eines anderen Steuerelements des Formulars ein, nämlich des Textfelds Summe. Wenn der Benutzer auf das Kontrollkästchen klickt, überprüft die Ereignisprozedur, ob das Kontrollkästchen aktiviert oder deaktiviert ist und stellt dann die Eigenschaften des Textfelds entsprechend ein, um die Bearbeitung zuzulassen oder nicht zuzulassen.

Sie können dieses Beispiel testen, indem Sie die folgende Ereignisprozedur zu einem Formular hinzufügen, das ein Kontrollkästchen namens Schreibgeschützt und ein Textfeld namens Summe enthält.

Private Sub Schreibgeschützt_Click()
    With Me!Summe
        If Me!Schreibgeschützt = True Then    ' Wenn aktiviert,
            .Enabled = False                ' Bearbeitung nicht zulassen.
            .Locked = True
        Else                                    ' Wenn deaktiviert,
            .Enabled = True                ' Bearbeitung zulassen.
            .Locked = False
        End If
    End With
End Sub


 Click-Ereignis (Klicken) - Makros

Click-Ereignis (Klicken) - Makros

Sie können beim Eintreten des Ereignisses Click ein Makro ausführen, indem Sie die Eigenschaft Beim Klicken auf den Namen des Makros einstellen.

Anmerkung

Sie verwenden die Makros für das Ereignis Click häufig, um die Aktionen für jede Befehlsschaltfläche eines Formulars auszuführen. Der Benutzer kann z. B. beim Klicken auf eine Befehlsschaltfläche eines Formulars einen Bericht mit den Datensätzen des Formulars drucken. Durch Klicken auf eine andere Befehlsschaltfläche kann er ein damit zusammenhängendes Formular öffnen.

In einem Makro für das Ereignis Click können Sie die Aktion AbbrechenEreignis nicht verwenden, um das Ereignis Click zu unterbinden.


 Current-Ereignis (Anzeigen) - Ereignisprozeduren

Current-Ereignis (Anzeigen) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Current ausgeführt wird. Dazu stellen Sie die Eigenschaft OnCurrent auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_Current( )

Anmerkung

Sie können die Ausführung dieses Ereignisses nicht mit der Methode CancelEvent des Objekts DoCmd unterbinden. Es ist jedoch möglich, mit der Methode GoToRecord des Objekts DoCmd zu einem anderen Datensatz zu springen.


Current-Ereignisprozeduren (Anzeigen) - Beispiele

Im folgenden Beispiel überprüft eine Ereignisprozedur für das Ereignis Current den Status eines Optionsfelds namens Auslaufartikel. Wenn der Benutzer dieses Feld aktiviert, wird die Hintergrundfarbe des Feldes Artikelname auf Rot eingestellt, um anzuzeigen, dass der Artikel ausgelaufen ist.

Sie können dieses Beispiel testen, indem Sie die folgende Ereignisprozedur zu einem Formular hinzufügen. Das Formular muss ein Optionsfeld namens Auslaufartikel und ein Textfeld namens Artikelname enthalten.

Private Sub Form_Current()
    If Me!Auslaufartikel Then
        Me!Artikelname.BackColor = 255
    EndIf
End Sub

Das folgende Beispiel stellt die Eigenschaft Caption eines Formulars auf das Feld Lieferantenname ein. Während der Fokus von einem Datensatz auf den nächsten gesetzt wird, zeigt die Titelleiste jeweils den aktuellen Lieferantennamen an.

Um dieses Beispiel zu testen, fügen Sie die folgende Ereignisprozedur zu einem Formular hinzu. Das Formular muss ein Textfeld namens Lieferantenname enthalten.

Private Sub Form_Current()
    Me.Caption = Me!Lieferantenname
End Sub


 Current-Ereignis (Anzeigen) - Makros

Current-Ereignis (Anzeigen) - Makros

Sie können beim Eintreten des Ereignisses Current ein Makro ausführen, indem Sie die Eigenschaft OnCurrent auf den Namen des Makros einstellen.

Anmerkung

In einem Makro für das Ereignis Current können Sie die Aktion AbbrechenEreignis nicht verwenden, um das Ereignis Current zu unterbinden. Sie können jedoch die Aktion GeheZuDatensatz verwenden, um den Fokus auf einen anderen Datensatz zu setzen.


 DblClick-Ereignis (Doppelklicken) - Ereignisprozeduren

DblClick-Ereignis (Doppelklicken) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses DblClick ausgeführt wird, indem Sie die Eigenschaft Beim Doppelklicken auf [Ereignisprozedur] einstellen und dann auf die Aufbauen-Schaltfläche [image] klicken.

Syntax

Private Sub Form_DblClick(Cancel As Integer)

Private Sub Steuerelementname_DblClick(Cancel As Integer)

Die Ereignisprozedur für das Ereignis DblClick hat folgende Argumente:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen DblClick-Ereignisprozedur Sie ausführen möchten.
Cancel | Die Einstellung bestimmt, ob das Ereignis DblClick eintritt. Das Einstellen von Cancel auf True (-1) unterbindet das Ereignis DblClick.

Anmerkung

Sie können die Ereignisprozedur für das Ereignis DblClick verwenden, um das Standardverhalten eines Steuerelements beim Doppelklicken zu ändern. So können Sie z. B. die Ereignisprozedur vor dem Starten eines OLE-Servers als Reaktion auf das Doppelklicken auf ein eingebettetes Objekt ausführen. Die Ereignisprozedur kann dann eine Meldung mit der Frage anzeigen, ob das Objekt gedruckt oder bearbeitet werden soll. Sie können das Objekt mit einer benutzerdefinierten Funktion drucken. Wenn der Benutzer das Objekt drucken möchte, anstatt es zu bearbeiten, können Sie das Objekt drucken und dann mit dem Argument Cancel das Starten des OLE-Servers unterbinden.

Wenn Sie Ereignisprozeduren für die Ereignisse MouseDown, MouseUp, Click und DblClick erstellen, achten Sie darauf, dass der Code aufeinander abgestimmt ist. So sollte z. B. die Click-Ereignisprozedur keinen Code enthalten, der Aktionen unterbindet, die von der DblClick-Ereignisprozedur ausgeführt werden.

Wenn Sie auf eine Befehlsschaltfläche doppelklicken, treten die folgenden Ereignisse in der angegebenen Reihenfolge ein:

MouseDown Þ MouseUp Þ Click Þ DblClick Þ MouseUp Þ Click

Sie können das Eintreten des zweiten Ereignisses Click verhindern, indem Sie das Argument Cancel auf True (-1) einstellen oder in der DblClick-Ereignisprozedur die Methode CancelEvent des Objekts DoCmd verwenden. Wenn Sie die Ausführung des zweiten Ereignisses Click nicht unterbinden, wird der Code in der Click-Ereignisprozedur erneut ausgeführt. Das folgende Beispiel unterbindet das zweite Ereignis Click:

Private Sub BefSF_DblClick(Cancel As Integer)
    Cancel = True        ' Das zweite Click-Ereignis unterbinden.
End Sub


DblClick-Ereignisprozeduren (Doppelklicken) - Beispiel

Dieses Beispiel zeigt, wie Sie mit einer DblClick-Ereignisprozedur ein Formular öffnen, das Datensätze einer Tabelle anzeigt, die die Datenquelle eines Kombinationsfelds ist. Wenn der Benutzer auf das Kombinationsfeld Verkaufsberater im Formular Bestellungen doppelklickt, führt dies zur Anzeige des Formulars Personal mit dem Datensatz für den im Kombinationsfeld ausgewählten Angestellten.

Sie können dieses Beispiel testen, indem Sie zu einem Formular namens Bestellungen die nachstehende Ereignisprozedur hinzufügen. Das Formular muss ein Kombinationsfeld namens Personal-Nr enthalten, das als Datenquelle dieselbe Tabelle wie das Formular Angestellte hat (bzw. eine Abfrage, die auf dieser Tabelle basiert).

Private Sub Personal_Nr_DblClick(Cancel As Integer)
    DoCmd.OpenForm "Personal", , , _
        "[Personal-Nr] = Formulare!Bestellungen![Personal-Nr]"
End Sub


 DblClick-Ereignis (Doppelklicken) - Makros

DblClick-Ereignis (Doppelklicken) - Makros

Sie können beim Eintreten des Ereignisses DblClick ein Makro ausführen, indem Sie die Eigenschaft Beim Doppelklicken auf den Namen des Makros einstellen.

Anmerkung

Durch Ausführen eines Makros beim Eintreten des Ereignisses DblClick können Sie das Standardverhalten eines Steuerelements beim Doppelklicken ändern. Sie können ein Makro z. B. vor dem Starten eines OLE-Servers als Reaktion auf das Doppelklicken auf ein eingebettetes Objekt ausführen. Das Makro kann dann eine Meldung mit der Frage anzeigen, ob das Objekt gedruckt oder bearbeitet werden soll. Sie können das Objekt mit einer benutzerdefinierten Funktion drucken.

Mit dem Ereignis DblClick können Sie veranlassen, dass ein Dialogfeld auch durch Doppelklicken auf ein Steuerelement an Stelle von Klicken auf OK geschlossen werden kann. Das Makro für das Ereignis DblClick muss die Aktion Schließen für das Dialogfeld ausführen. Soll das Makro das Dialogfeld nur ausblenden, können Sie mit der Aktion SetzenWert die Eigenschaft Sichtbar des Dialogfelds auf Nein einstellen.

Sie können in einem Makro für das Ereignis DblClick die Aktion AbbrechenEreignis verwenden, um das Standardverhalten des Steuerelements beim Doppelklicken zu unterbinden. Wenn der Benutzer das weiter oben erwähnte OLE-Objekt nicht bearbeiten, sondern drucken wollte, würden Sie das Objekt mit einer benutzerdefinierten Funktion drucken und dann mit der Aktion AbbrechenEreignis das Öffnen der OLE-Anwendung unterbinden.


 Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung) - Ereignisprozeduren

Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Delete, BeforeDelConfirm oder AfterDelConfirm eintritt, stellen Sie die Eigenschaft Beim Löschen, Vor Löschbestätigung bzw. Nach Löschbestätigung auf [Ereignisprozedur] ein und klicken dann auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Form_Delete(Cancel As Integer)

Private Sub Form_BeforeDelConfirm(Cancel As Integer, Response As Integer)

Private Sub Form_AfterDelConfirm(Status As Integer)

Die Ereignisprozedur für das Ereignis Delete hat das folgende Argument.

Argument | Beschreibung
Cancel | Diese Einstellung legt fest, ob das Ereignis Delete eintritt. Wenn Sie das Argument Cancel auf True (-1) einstellen, wird das Ereignis Delete unterbunden.

Die Ereignisprozedur für das Ereignis BeforeDelConfirm hat die folgenden Argumente.

Argument | Beschreibung
Cancel | Diese Einstellung legt fest, ob das Ereignis BeforeDelConfirm eintritt. Wenn Sie das Argument Cancel auf True einstellen, wird das Ereignis BeforeDelConfirm unterbunden und das Dialogfeld zum Bestätigen des Löschvorgangs nicht angezeigt. Wenn das Ereignis unterbunden wird, werden die ursprünglichen Datensätze wiederhergestellt, das Ereignis AfterDelConfirm tritt aber trotzdem ein. Wenn Cancel auf True eingestellt wird, wird das Argument Response ignoriert.
 | Wenn Sie Cancel auf False (0) einstellen (dies ist die Voreinstellung), verwendet Microsoft Access den Wert des Arguments Response, um den Typ der Antwort auf das Ereignis Delete zu ermitteln.
Response | Diese Einstellung legt fest, ob Microsoft Access das Dialogfeld zum Bestätigen des Löschvorgangs für einen Datensatz anzeigt. Das Argument Response kann die folgenden eingebauten Konstanten annehmen:
 | Konstante | Beschreibung
 | acDataErrContinue | Die Verarbeitung wird ohne Anzeige des Dialogfelds zum Bestätigen des Löschvorgangs fortgesetzt. Wenn Sie das Argument Cancel auf False und das Argument Response auf acDataErrContinue einstellen, löscht Microsoft Access die Datensätze, ohne den Benutzer zur Bestätigung aufzufordern.
 | AcDataErrDisplay | (Voreinstellung) Zeigt das Dialogfeld zum Bestätigen des Löschvorgangs an.

Die Ereignisprozedur für das Ereignis AfterDelConfirm hat das folgende Argument:

Argument | Beschreibung
Status | Diese Einstellung gibt an, ob ein Datensatz gelöscht wurde oder nicht. Das Argument Status kann eine der folgenden eingebauten Konstanten annehmen:
 | Konstante | Beschreibung
 | acDeleteOK | Gibt an, dass der Löschvorgang erfolgreich ausgeführt wurde.
 | AcDeleteCancel | Gibt an, dass der Löschvorgang in Visual Basic abgebrochen wurde.
 | AcDeleteUserCancel | Gibt an, dass der Löschvorgang vom Benutzer abgebrochen wurde.

Anmerkung

Das Ereignis AfterDelConfirm kann nicht unterbunden werden.

Mit diesen Ereignissen können Sie festlegen, wie Datensätze gelöscht werden. Wenn ein Benutzer beispielsweise einen Datensatz (z. B. einen Personalstammdatensatz) löscht, tritt das Ereignis Delete ein. Sie können in die Ereignisprozedur für das Ereignis Delete Code einfügen, der die Daten aus den Feldern Personal-Nr und Name in temporären Variablen speichert. Bei Eintreten des Ereignisses BeforeDelConfirm können Sie die Anzeige des Dialogfelds zum Bestätigen des Löschvorgangs verhindern, indem Sie das Argument Response auf acDataErrContinue einstellen. Dies erlaubt das Anzeigen eines benutzerdefinierten Dialogfelds. Wenn das Ereignis AfterDelConfirm eintritt und das Argument Status auf acDeleteOK eingestellt ist, können Sie die temporären Variablen löschen oder die Personaldaten in einer anderen Tabelle speichern.


Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisprozeduren (Löschen, VorLöschBestätigung, NachLöschBestätigung) - Beispiele

Das nachstehende Beispiel zeigt, wie Sie verhindern können, dass ein Benutzer Datensätze aus einer Tabelle löscht.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das auf einer Tabelle basiert. Wechseln Sie zur Datenblattansicht des Formulars, und versuchen Sie, einen Datensatz zu löschen.

Private Sub Form_Delete(Cancel As Integer)
    Cancel = True
    MsgBox "Dieser Datensatz kann nicht gelöscht werden."
End Sub

Das folgende Beispiel zeigt, wie Sie unter Verwendung der Ereignisprozedur für das Ereignis BeforeDelConfirm die Anzeige des Dialogfelds zum Bestätigen des Löschvorgangs unterdrücken und beim Löschen des Datensatzes stattdessen ein benutzerdefiniertes Dialogfeld anzeigen. Es zeigt außerdem, wie Sie mit einer AfterDelConfirm-Ereignisprozedur eine Meldung anzeigen, die angibt, ob der Löschvorgang auf übliche Weise ausgeführt oder in Visual Basic bzw. durch den Benutzer abgebrochen wurde.

Zum Testen dieses Beispiels fügen Sie die folgende Ereignisprozedur zu einem Formular hinzu, das auf einer Tabelle oder Abfrage basiert:

Private Sub Form_BeforeDelConfirm(Cancel As Integer, _
        Response As Integer)
    ' Verhindert, dass das Standarddialogfeld zum
    ' Bestätigen von Löschvorgängen angezeigt wird.
    Response = acDataErrContinue
    ' Anzeigen eines benutzerdefinierten Dialogfelds.
    If MsgBox("Diesen Datensatz löschen?", vbOKCancel) = vbCancel Then
        Cancel = True
    End If
End Sub

Private Sub Form_AfterDelConfirm(Status As Integer)
    Select Case Status
        Case acDeleteOK
            MsgBox "Der Löschvorgang wurde normal ausgeführt."
        Case acDeleteCancel
            MsgBox "Der Löschvorgang wurde vom Programm abgebrochen."
        Case acDeleteUserCancel
            MsgBox "Der Löschvorgang wurde vom Benutzer abgebrochen."
    End Select
End Sub


 Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung) - Makros

Delete-, BeforeDelConfirm-, AfterDelConfirm-Ereignisse (Löschen, VorLöschBestätigung, NachLöschBestätigung) - Makros

Wenn beim Eintreten des Ereignisses Delete, BeforeDelConfirm oder AfterDelConfirm ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Beim Löschen, Vor Löschbestätigung bzw. Nach Löschbestätigung auf den Namen des Makros ein.

Anmerkung

Mit einem Makro für das Ereignis Delete können Sie ein Dialogfeld anzeigen, das den Benutzer vor dem Löschen eines Datensatzes zur Bestätigung des Löschvorgangs auffordert.

Mit einem Makro für das Ereignis BeforeDelConfirm oder AfterDelConfirm können Sie immer dann reagieren, wenn der Benutzer einen Datensatz löscht. Makros für die Ereignisse BeforeDelConfirm und AfterDelConfirm können jedoch nicht das Argument einstellen, das festlegt, ob das Dialogfeld zum Bestätigen des Löschvorgangs angezeigt werden soll, noch kann ein solches Makro den Status eines Löschvorgangs zurückgeben. Daher werden für diese Ereignisse in der Regel eher Ereignisprozeduren eingesetzt.

Sie können in einem Makro für das Ereignis Delete die Aktion AbbrechenEreignis verwenden, um den Löschvorgang abzubrechen.

Die Aktion AbbrechenEreignis kann auch in einem Makro für das Ereignis BeforeDelConfirm eingesetzt werden, um den Löschvorgang für alle gelöschten Datensätze abzubrechen. In diesem Fall wird das Dialogfeld zum Bestätigen des Löschvorgangs nicht eingeblendet. Das Ereignis AfterDelConfirm tritt jedoch auch dann ein, wenn Sie das Ereignis BeforeDelConfirm unterbinden.

Die Aktion AbbrechenEreignis kann nicht in einem Makro für das Ereignis AfterDelConfirm eingesetzt werden.


 Dirty-Ereignis (Geändert) - Ereignisprozeduren

Dirty-Ereignis (Geändert) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Dirty-Ereignis eintritt, legen Sie die OnDirty-Eigenschaft auf [Ereignisprozedur] fest und klicken auf die Schaltfläche Generator [image] .

Syntax

Private Sub Form_Dirty(Cancel As Integer )

Die Dirty-Ereignisprozedur verwendet das folgende Argument.

Argument | Beschreibung
Cancel | Diese Einstellung legt fest, ob das Dirty-Ereignis eintritt. Wenn Sie das Argument Cancel auf True (-1) einstellen, wird das Dirty-Ereignis unterbunden. Sie können das Eintreten des Ereignisses auch mit der CancelEvent-Methode des DoCmd-Objekts unterbinden.

Anmerkungen

Das Unterbinden des Dirty-Ereignisses entspricht dem Drücken von ESC und bewirkt, dass die Änderungen am aktuellen Datensatz rückgängig gemacht werden.


Dirty-Ereignis (Geändert) - Ereignisprozeduren: Beispiel

Das folgende Beispiel aktiviert die Schaltfläche btnRückgängig, sobald Daten geändert wurden. Die BearbeitenRückgängig( )-Funktion wird vom Dirty-Ereignis der Textfeld-Steuerelemente aufgerufen. Beim Klicken auf die aktivierte Schaltfläche btnRückgängig wird der ursprüngliche Wert des Steuerelements mit Hilfe der OldValue-Eigenschaft wiederhergestellt.

Private Sub Form_Dirty()
    If Me.Dirty Then
        Me!btnRückgängig.Enabled = True     ' Schaltfläche aktivieren.
    Else
        Me!btnRückgängig.Enabled = False    ' Schaltfläche deaktivieren.
    End If
End Sub

Sub btnRückgängig_Click()
    Dim ctlC As Control
        ' Für jedes Steuerelement.
        For Each ctlC in Me.Controls
            If ctlC.ControlType = acTextBox Then
                ' Alten Wert wiederherstellen.
                ctlC.Value = ctlC.OldValue
            End If
        Next ctlC
End Sub


 Dirty-Ereignis (Geändert) - Makros

Dirty-Ereignis (Geändert) - Makros

Zum Ausführen eines Makros bei Eintreten des Dirty-Ereignisses stellen Sie die OnDirty-Eigenschaft auf den Namen des Makros ein.

Anmerkungen

Sie können mit Hilfe eines Dirty-Makros überprüfen, ob ein Benutzer über die Berechtigung zum Ändern des betreffenden Datensatzes verfügt. Mit einer Meldung kann der Benutzer aufgefordert werden, seine ID für die Gültigkeitsüberprüfung einzugeben.


 Enter-, Exit-Ereignisse (Hingehen, Verlassen) - Ereignisprozeduren

Enter-, Exit-Ereignisse (Hingehen, Verlassen) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Enter oder Exit ausgeführt wird, indem Sie die Eigenschaft Beim Hingehen oder Beim Verlassen auf [Ereignisprozedur] einstellen und auf die Generator-Schaltfläche [image] klicken.

Syntax

Private Sub Steuerelementname_Enter( )

Private Sub Steuerelementname_Exit(Cancel As Integer)

Die Ereignisprozedur für das Ereignis Enter hat folgendes Argument:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen Enter-Ereignisprozedur Sie ausführen möchten.

Die Ereignisprozedur für das Ereignis Exit hat das folgende Argument:

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen Exit-Ereignisprozedur Sie ausführen möchten.
Cancel | Die Einstellung bestimmt, ob das Ereignis Exit eintritt. Das Einstellen von Cancel auf True (-1) unterbindet das Ereignis Exit.

Anmerkung

Sie können das Ereignis Enter nicht unterbinden.


Enter-, Exit-Ereignisprozeduren (Hingehen, Verlassen) - Beispiel

In diesem Beispiel werden dem Textfeld Nachname zwei Ereignisprozeduren zugeordnet. Die Enter-Ereignisprozedur zeigt in einer Meldung den Datentyp an, der in das Textfeld eingegeben werden kann. Die Exit-Ereignisprozedur zeigt ein Dialogfeld an, in dem der Benutzer gefragt wird, ob Änderungen gespeichert werden sollen, bevor der Fokus auf ein anderes Steuerelement gesetzt wird. Wenn der Benutzer auf die Schaltfläche Nein klickt, wird das Argument Cancel auf True (-1) gesetzt. Dadurch bewegt sich der Fokus in das Textfeld, ohne dass die Änderungen zuvor gespeichert werden. Wenn der Benutzer Ja wählt, werden die Änderungen gespeichert, und der Fokus wird auf ein anderes Steuerelement gesetzt.

Sie können dieses Beispiel ausprobieren, indem Sie die folgende Ereignisprozedur zu einem Formular hinzufügen, das ein Textfeld namens Nachname enthält.

Private Sub Nachname_Enter()
    MsgBox "Geben Sie Ihren Nachnamen ein."
End Sub

Private Sub Nachname_Exit(Cancel As Integer)
    Dim strMld As String

    strMldg = "Sie haben '" & Me!Nachname _      & "' als Nachnamen " _
    & "eingegeben." & vbCrLf & "Ist der Nachname richtig?"
    If MsgBox(strMldg, vbYesNo) = vbNo Then
        Cancel = True            ' Exit unterbinden.
    Else
        Exit Sub                    ' Änderungen speichern und Exit zulassen.
    End If
End Sub


 Enter-, Exit-Ereignisse (Hingehen, Verlassen) - Makros

Enter-, Exit-Ereignisse (Hingehen, Verlassen) - Makros

Sie können beim Eintreten des Ereignisses Enter oder Exit ein Makro ausführen, indem Sie die Eigenschaft Beim Hingehen oder Beim Verlassen auf den Namen des Makros einstellen.

Anmerkung

Wenn das Ereignis Enter oder Exit eintritt, können Sie ein Makro ausführen, das mit der Aktion GeheZuSteuerelement die Reihenfolge auf der Basis der aktuellen Daten im Steuerelement ändert. Wenn der Benutzer z. B. in das Feld Familienstand den Wert Ledig eingibt, wird der Fokus nicht auf das Feld Ehepartner/in gesetzt.

Sie können in einem Makro für das Ereignis Exit die Aktion AbbrechenEreignis verwenden, um das Verlassen des Steuerelements zu unterbinden. In einem Makro für das Ereignis Enter können Sie die Aktion AbbrechenEreignis nicht verwenden, jedoch können Sie die Aktion GeheZuSteuerelement einsetzen, um den Fokus auf ein anderes Steuerelement zu setzen.


 Error-Ereignis (Fehler) - Ereignisprozeduren

Error-Ereignis (Fehler) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die bei Eintreten des Ereignisses Error ausgeführt wird, stellen Sie die Eigenschaft Bei Fehler auf [Ereignisprozedur] ein und klicken dann auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_Error(DataErr As Integer, Antwort As Integer)

Private Sub Report_Error(DataErr As Integer, Antwort As Integer)

Die Ereignisprozedur für das Ereignis Error hat die folgenden Argumente.

Argument | Beschreibung
DataErr | Der vom Objekt Err bei Auftreten eines Fehlers zurückgegebene Fehlercode. Verwenden Sie das Argument DataErr zusammen mit der Funktion Error zum Zuordnen der Nummer zur entsprechenden Fehlermeldung.
Antwort | Diese Einstellung gibt an, ob eine Fehlermeldung angezeigt wird oder nicht. Das Argument Antwort kann eine der folgenden eingebauten Konstanten sein.
 | Konstante | Beschreibung
 | acDataErrContinue | Ignorieren des Fehlers und Fortsetzen ohne Anzeige der Microsoft Access-Standardfehlermeldung. Sie können an Stelle der Standardfehlermeldung eine benutzerdefinierte Fehlermeldung angeben.
 | acDataErrDisplay | (Standardeinstellung) Anzeigen der Microsoft Access-Standardfehlermeldung.

Anmerkungen

Sie können das Ereignis Error nicht unterbinden.


Error-Ereignisprozedur (Fehler) - Beispiel

Das nachstehende Beispiel zeigt, wie Sie eine Standardfehlermeldung durch eine benutzerdefinierte Fehlermeldung ersetzen können. Wenn Microsoft Access eine Fehlermeldung zurückgibt, die mitteilt, dass ein doppelter Schlüssel (Fehlercode 3022) entdeckt wurde, zeigt diese Ereignisprozedur eine Meldung an, die dem jeweiligen Benutzer anwendungsspezifischere Informationen gibt.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu. Das Formular muss auf einer Tabelle basieren, in der als Schlüssel für jeden Datensatz eine eindeutige Personalnummer existiert.

Private Sub Form_Error(DataErr As Integer, Response As Integer)
    Const conDoppelterSchlüssel = 3022
    Dim strMldg As String

    If DataErr = conDoppelterSchlüssel Then
        Response = acDataErrContinue
        strMldg = "Jeder Personaldatensatz muss eine eindeutige " _
        & "Personalnummer enthalten. Bitte überprüfen Sie Ihre Daten."
        MsgBox strMldg
    End If
End Sub


 Error-Ereignis (Fehler) - Makros

Error-Ereignis (Fehler) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses Error stellen Sie die Eigenschaft Bei Fehler auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis Error zum Anzeigen einer allgemeinen Meldung bei Eintreten eines Laufzeitfehlers verwenden. Da Makros jedoch weder den Fehlercode zurückgeben noch ermitteln können, welcher Fehler auftrat, eignet sich für dieses Ereignis in der Regel eher der Einsatz einer Ereignisprozedur.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Error nicht eingesetzt werden.


 Filter-Ereignis - Ereignisprozeduren

Filter-Ereignis - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die bei Eintreten des Filter-Ereignisses ausgeführt wird, legen Sie die OnFilter-Eigenschaft auf [Ereignisprozedur] fest und klicken auf die Schaltfläche Generator.

Syntax

Private Sub Form_Filter(Cancel As Integer, Filtertyp As Integer)

Die Filter-Ereignisprozedur verwendet die folgenden Argumente.

Argument | Beschreibung
Cancel | Die Einstellung ermittelt, ob das Filterfenster geöffnet werden soll. Wenn das Argument Cancel auf True (-1) festgelegt wird, verhindert dies das Öffnen des Filterfensters. Sie können das Öffnen des Filterfensters auch mit der CancelEvent-Methode des DoCmd-Objekts unterbinden.
Filtertyp | Das Filterfenster, das der Benutzer zu öffnen versucht. Das Argument Filtertyp kann eine der folgenden eingebauten Konstanten sein:
 | Konstante | Wert
 | acFilterByForm | 0
 | acFilterAdvanced | 1
 | acServerFilterByForm | 2

Anmerkungen

Mit Hilfe der Filter-Ereignisprozedur können Sie bestimmte Steuerelemente im Fenster Formularbasierter Filter bzw. Formularbasierter Serverfilter deaktivieren oder ausblenden, um zu verhindern, dass diese in Filterkriterien verwendet werden. Beispielsweise soll das Formular Bestellungen immer Datensätze anzeigen, für die im FälligeSumme-Steuerelement ein Wert enthalten ist, unabhängig von dessen Größe. Dann können Sie dieses Steuerelement in der Filter-Ereignisprozedur deaktivieren oder ausblenden, und es anschließend in der ApplyFilter-Ereignisprozedur aktivieren oder anzeigen. Das Deaktivieren und Ausblenden von Steuerelementen im Fenster Formularbasierter Filter bzw. Formularbasierter Serverfilter erfolgt am besten in der Filter-Ereignisprozedur statt im Filter-Makro. Auf diese Weise können Sie nämlich das Argument Filtertyp überprüfen, um festzustellen, ob der Benutzer eines dieser beiden Fenster geöffnet hat. In einer Microsoft Access-Datenbank (.mdb) werden alle Felder eines Formulars selbst dann im Fenster Spezialfilter/-sortierung angezeigt, wenn die Steuerelemente deaktiviert oder ausgeblendet sind.


Filter-Ereignis - Ereignisprozedur: Beispiel

Das folgende Beispiel zeigt, wie das Steuerelement Gesamtbetrag eines Formulars namens Bestellungen deaktiviert werden kann, sobald der Benutzer versucht, einen Filter zu erstellen. Der Benutzer kann dann nicht nach diesem Feld filtern. Jeder Datensatz, der im Feld Gesamtbetrag einen Wert enthält und den anderen Filterkriterien entspricht, wird im gefilterten Formular angezeigt. Außerdem wird der Benutzer in diesem Beispiel gezwungen, das Fenster Formularbasierter Filter zu verwenden. Das Fenster Spezialfilter/-sortierung kann er nicht öffnen.

Sie können dieses Beispiel ausprobieren, indem Sie die folgende Ereignisprozedur zu einem Formular namens Bestellungen hinzufügen, das das Steuerelement Gesamtbetrag enthält. Versuchen Sie, mit dem Fenster Spezialfilter/-sortierung einen Filter zu erstellen, der auf dem Steuerelement Gesamtbetrag basiert. Versuchen Sie dann, denselben Filter mit dem Fenster Formularbasierter Filter zu erstellen.

Private Sub Form_Filter(Cancel As Integer, FilterType As Integer)
    If FilterType = acFilterByForm Then
        Formulare!Bestellungen!Gesamtbetrag.Enabled = False
    ElseIf FilterType = acFilterAdvanced Then
        MsgBox "Dieses Formular lässt sich am besten mit dem Befehl bzw. " _
            & "der Schaltfläche 'Formularbasierter Filter' filtern.", vbOKOnly + vbInformation
        Cancel = True
    End If
End Sub


 Filter-Ereignis - Makros

Filter-Ereignis - Makros

Soll ein Makro ausgeführt werden, wenn das Filter-Ereignis eintritt, stellen Sie die OnFilter-Eigenschaft auf den Namen des Makros ein.

Anmerkungen

Die Filter- bzw. ServerFilter-Eigenschaft können Sie in einem Filter-Makro mit der Aktion SetzenWert einstellen. Dies ermöglicht Ihnen das Anpassen der Filterkriterien, die der Benutzer sieht, wenn eines der Fenster Formularbasierter Filter, Spezialfilter/-sortierung oder Formularbasierter Serverfilter angezeigt wird.

Mit der Aktion AbbrechenEreignis können Sie in einem Filter-Makro das Öffnen des Filterdefinitionsfensters abbrechen.


 Format-Ereignis (Formatieren) - Ereignisprozeduren

Format-Ereignis (Formatieren) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Format ausgeführt wird, indem Sie die Eigenschaft Bei Formatierung auf [Ereignisprozedur] einstellen und dann auf die Aufbauen-Schaltfläche [image] klicken.

Syntax

Private Sub Bereichsname_Format(Cancel As Integer, FormatCount As Integer)

Die Ereignisprozedur für das Ereignis Format hat folgende Argumente:

Argument | Beschreibung
Bereichsname | Der Name des Bereichs im Bericht, dessen Format-Ereignisprozedur ausgeführt werden soll.
Cancel | Die Einstellung bestimmt, ob das Ereignis Format eintritt. Das Einstellen von Cancel auf True (-1) unterbindet das Formatieren des Bereichs.
FormatCount | Ein Wert vom Typ Integer, der angibt, wie oft das Ereignis Format für einen Bereich eingetreten ist. Wenn z. B. ein Bereich nicht auf eine Seite passt und ein Teil davon auf die nächste Seite des Berichts verschoben wird, wird das Argument FormatCount auf den Wert 2 gesetzt.

Anmerkung

Wenn Sie das Formatieren unterbinden, formatiert Microsoft Access den Bereich nicht für den Ausdruck, sondern druckt stattdessen den nächsten Bereich. Mit dieser Ereignisprozedur können Sie einen Bereich in einem Bericht überspringen, ohne dass beim Drucken des Berichts eine leere Fläche auf der Seite erscheint.


Format-Ereignisprozeduren (Formatieren) - Beispiel

Dieses Beispiel blendet einen Glückwunsch neben einem berechneten Steuerelement ein- oder aus, in dem die Umsätze pro Verkaufsberater angezeigt werden. In Berichtsbereichen, in denen die Umsätze das gesetzte Ziel überschreiten, zeigt ein Bezeichnungsfeld namens Glückwunsch vor dem Drucken des Bereichs folgenden Text an: "Glückwunsch! Sie haben Ihr Verkaufsziel überschritten." In Bereichen des Berichts, in denen das Verkaufsziel höher ist als die Umsätze, wird dieses Bezeichnungsfeld ausgeblendet.

Sie können dieses Beispiel testen, indem Sie zu einem Bericht die nachstehende Ereignisprozedur hinzufügen. Der Bericht muss ein Bezeichnungsfeld namens Meldung, ein Textfeld namens Gesamtsumme (ein berechnetes Steuerelement mit der Summe der Umsätze) sowie einen Detailbereich namens Umsätze enthalten.

Private Sub Umsätze_Format(Cancel As Integer, _
        FormatCount As Integer)
    Const conVerkaufsziel = 1000
    If Me!Gesamtsumme > conVerkaufsziel Then
        Me!Meldung.Visible = True
    Else
        Me!Meldung.Visible = False
    End If
End Sub


 Format-Ereignis (Formatieren) - Makros

Format-Ereignis (Formatieren) - Makros

Sie können beim Eintreten des Ereignisses Format ein Makro ausführen, indem Sie die Eigenschaft Bei Formatierung auf den Namen des Makros einstellen.

Anmerkung

Sie können mit der Eigenschaft Formatierungsanzahl überprüfen, ob das Ereignis Format für einen Bereich mehrmals eingetreten ist. Wenn z. B. ein Bereich nicht auf eine Seite des Berichts passt und sich ein Teil davon auf die nächste Seite verschiebt, tritt das Ereignis Format für jede Seite ein, und die Eigenschaft Formatierungsanzahl wird auf den Wert 2 eingestellt. Sie können anhand der Einstellung der Eigenschaft Formatierungsanzahl prüfen, wie oft ein Makro für das Ereignis Format pro Bereich ausgeführt wird.

Sie können in einem Makro für das Ereignis Format mit der Aktion AbbrechenEreignis das Formatieren eines Bereichs unterbinden. Microsoft Access formatiert den Bereich dann nicht für den Ausdruck, sondern druckt stattdessen den nächsten Bereich. Mit der Aktion AbbrechenEreignis kann ein Bereich in einem Bericht übersprungen werden, ohne dass beim Drucken des Berichts eine leere Fläche auf der Seite erscheint.


 GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust) - Ereignisprozeduren

GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die bei Eintreten des Ereignisses GotFocus oder LostFocus ausgeführt wird, stellen Sie die Eigenschaft Bei Fokuserhalt bzw. Bei Fokusverlust auf [Ereignisprozedur] ein und klicken auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Form_GotFocus( )

Private Sub Steuerelementname_GotFocus( )

Private Sub Form_LostFocus( )

Private Sub Steuerelementname_LostFocus( )

Die Ereignisprozeduren für GotFocus und LostFocus haben das folgende Argument.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen GotFocus- oder LostFocus-Ereignisprozedur ausgeführt werden soll.

Anmerkung

Mit einer Ereignisprozedur für LostFocus können Sie eingegebene Daten in dem Moment überprüfen, in dem der Benutzer den Fokus eines Steuerelements verschiebt. Darüber hinaus können Sie Bedingungen aufheben oder ändern, die Sie in der GotFocus-Ereignisprozedur des Objekts formuliert haben.

Die Ereignisprozeduren für GotFocus und LostFocus können außerdem zum Aktivieren, Deaktivieren, Ausblenden und Anzeigen anderer Objekte eingesetzt werden.

Die Ereignisse GotFocus und LostFocus können nicht unterbunden werden.


GotFocus-, LostFocus-Ereignis (Fokuserhalt-, Fokusverlust-Ereignisprozeduren) - Beispiel

Das nachstehende Beispiel zeigt eine Meldung in einem Bezeichnungsfeld an, wenn ein Optionsfeld den Fokus erhält.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular namens Kontakte hinzu. Dieses Formular muss ein Optionsfeld namens OptionJa und ein Bezeichnungsfeld namens BezeichnungJa enthalten.

Private Sub OptionJa_GotFocus()
    Me!BezeichnungJa.Caption = "Optionsfeld 'Ja' hat den Fokus."
End Sub

Private Sub OptionJa_LostFocus()
    Me!BezeichnungJa.Caption = ""        ' Bezeichnung löschen.
End Sub


 GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust) - Makros

GotFocus-, LostFocus-Ereignisse (Fokuserhalt, Fokusverlust) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses GotFocus oder LostFocus stellen Sie die Eigenschaft Bei Fokuserhalt bzw. Bei Fokusverlust auf den Namen des Makros ein.

Anmerkung

Mit einem Makro für das Ereignis LostFocus können Sie eingegebene Daten in dem Moment überprüfen, in dem der Benutzer den Fokus von einem Steuerelement auf ein anderes verschiebt. Außerdem können Sie Bedingungen aufheben oder ändern, die Sie in dem Makro für das Ereignis GotFocus des Objekts eingestellt haben.

Makros für die Ereignisse GotFocus und LostFocus können außerdem zum Aktivieren, Deaktivieren, Ausblenden und Anzeigen anderer Objekte eingesetzt werden.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis GotFocus bzw. LostFocus nicht eingesetzt werden.


 Initialize-Ereignis (Initialisieren) - Ereignisprozedur

Initialize-Ereignis (Initialisieren) - Ereignisprozedur

Um die Ereignisprozedur für das Ereignis Initialize zu erstellen, öffnen Sie das Klassenmodul, und klicken Sie im Feld Objekt auf Class. Klicken Sie anschließend im Feld Prozedur auf Initialize.

Syntax

Private Sub Class_Initialize( )

Anmerkung

Sie können mit dieser Ereignisprozedur Code ausführen, wenn eine Instanz der Klasse erstellt wird, oder Daten initialisieren, die von der Instanz der Klasse verwendet werden.

Das Ereignis Initialize tritt ein, wenn Sie eine neue Instanz einer Klasse mit Hilfe des Schlüsselworts New erstellen. Angenommen, die Klasse BenutzerObjekt ist definiert. Das folgende Beispiel zeigt, wie Sie in einem Standardmodul Code hinzufügen können, der eine neue Instanz der Klasse BenutzerObjekt erstellt.

Dim obj As BenutzerObjekt
Set obj = New BenutzerObjekt

Wenn Sie die Prozedur ausführen, die diesen Code enthält, erstellt Visual Basic eine neue Instanz der Klasse BenutzerObjekt, und das Ereignis Initialize tritt ein.

Beim Deklarieren einer Objektvariablen unter Verwendung des Schlüsselwortes New tritt das Ereignis Initialize ein, wenn Sie eine Instanz einer Klasse erstellen, indem Sie eine Eigenschaft einstellen oder zurückgeben oder eine im Klassenmodul definierte Methode anwenden. Angenommen, Sie haben die Funktion AuflistenNamen im Klassenmodul BenutzerObjekt definiert. Um diese Funktion von einem anderen Modul aus auszuführen, qualifizieren Sie die Funktion mit dem Namen des Klassenmoduls, wie im folgenden Beispiel dargestellt:

BenutzerObjekt.AuflistenNamen

Das Qualifizieren der Funktion mit dem Namen des Klassenmoduls erstellt eine Instanz des Klassenmoduls, und das Ereignis Initialize tritt ein.


Initialize-, ItemAdded-, ItemRemoved-, Terminate-Ereignisprozeduren - Beispiel

Das folgende Beispiel enthält Ereignisprozeduren für die Ereignisse ItemAdded und ItemRemoved. Damit Sie dieses Beispiel testen können, erstellen Sie zuerst ein neues Klassenmodul, indem Sie im Menü Einfügen auf Klassenmodul klicken. Fügen Sie den folgenden Code in das Klassenmodul ein, und speichern Sie das Modul als VerwEreignisse.

' Objektvariable deklarieren, die die References-Auflistung
' darstellt.
Public WithEvents evtVerweise As References

' Initialisieren der Variablen evtVerweise, wenn Instanz
' der Klasse erstellt wird.
Private Sub Class_Initialize()
    Set evtVerweise = Application.References
End Sub

' evtVerweise auf Nothing einstellen, wenn Instanz der Klasse
' entfernt wird.
Private Sub Class_Terminate()
    Set evtVerweise = Nothing
End Sub

' Meldung anzeigen, wenn Verweis hinzugefügt wird.
Private Sub evtVerweise_ItemAdded(ByVal Reference As _
_        Access.Reference)
    MsgBox "Verweis auf " & Reference.Name & " wurde hinzugefügt."
End Sub

' Meldung anzeigen, wenn Verweis entfernt wird.
Private Sub evtVerweise_ItemRemoved(ByVal Reference As _
       Access.Reference)
    MsgBox "Verweis auf " & Reference.Name & " wurde entfernt."
End Sub

Die folgende Funktion fügt einen angegebenen Verweis hinzu. Wenn der Verweis hinzugefügt wird, wird die in der Klasse VerwEreignisse definierte Ereignisprozedur ItemAdded ausgeführt.

Um beispielsweise einen Verweis auf das Kalender-Steuerelement einzustellen, können Sie die Zeichenfolge "C:\Windows\System\Mscal.ocx" übergeben, falls diese auf Ihrem Computer den Pfad für das Kalender-Steuerelement korrekt angibt.

' Neue Instanz der Klasse VerwEreignisse erstellen.
Dim objVerwEreignisse As New VerwEreignisse

' Dateiname und Pfad der Typbibliothek an die Prozedur übergeben.
Function HinzufügenVerweis(strDateiname As String) As Boolean
    Dim ref As Reference

    On Error GoTo Error_HinzufügenVerweis
    ' Neuen Verweis auf Variable vom Typ References erstellen.
    Set ref = objVerwEreignisse.evtVerweise.AddFromFile(strDateiname)
    HinzufügenVerweis = True

Exit_HinzufügenVerweis:
    Exit Function

Error_HinzufügenVerweis:
    MsgBox Err & ": " & Err.Description
    HinzufügenVerweis = False
    Resume Exit_HinzufügenVerweis
End Function

Die folgende Funktion entfernt einen angegebenen Verweis. Wenn der Verweis entfernt wird, wird die in der Klasse VerwEreignisse definierte Ereignisprozedur ItemRemoved ausgeführt.

Um beispielsweise einen Verweis auf das Kalender-Steuerelement zu entfernen, können Sie die Zeichenfolge "CalendarObjects" übergeben; das ist der Name des Reference-Objekts, der das Kalender-Steuerelement darstellt.

Function EntfernenVerweis(strVerwName As String) As Boolean
    Dim ref As Reference

    On Error GoTo Error_EntfernenVerweis
    ' Objekt zurückgeben, das den bestehenden Verweis darstellt.
    Set ref = objVerwEreignisse.evtVerweise(strVerwName)
    ' Verweis aus Auflistung entfernen.
    ObjVerwEreignisse.evtVerweise.Remove ref
    EntfernenVerweis = True

Exit_EntfernenVerweis:
    Exit Function

Error_EntfernenVerweis:
    MsgBox Err & ": " & Err.Description
    EntfernenVerweis = False
    Resume Exit_EntfernenVerweis
End Function


 ItemAdded-Ereignis - Ereignisprozeduren

ItemAdded-Ereignis - Ereignisprozeduren

Um eine Ereignisprozedur zu erstellen, die beim Eintreten des Ereignisses ItemAdded ausgeführt wird, führen Sie die im Abschnitt "Anmerkung" dieses Themas beschriebenen Schritte durch.

Syntax

Private Sub evtVerweise_ItemAdded(Verweis)

Die Ereignisprozedur ItemAdded verwendet die folgenden Argumente.

Argument | Beschreibung
evtVerweise | Eine Objektvariable, die die Auflistung References darstellt. Deklarieren Sie diese Objektvariable mit Hilfe des Schlüsselworts WithEvents in einem Klassenmodul.
Verweis | Das Reference-Objekt, das zur Auflistung References hinzugefügt wurde.

Anmerkung

Die Ereignisprozedur ItemAdded kann Code enthalten, den Sie ausführen möchten, wenn ein Verweis auf eine Typbibliothek zum Projekt hinzugefügt wird. Sie können von Visual Basic aus einen Verweis hinzufügen, indem Sie mit den Methoden AddFromFile oder AddFromGUID ein Reference-Objekt zur Auflistung References hinzufügen.

So erstellen Sie die Ereignisprozedur ItemAdded:

  1. Deklarieren Sie unter Verwendung des Schlüsselworts WithEvents im Deklarationsbereich eines Klassenmoduls eine Objektvariable vom Typ References. Microsoft Access definiert mit dieser Objektvariablen die Ereignisprozedur für das Ereignis ItemAdded. Die folgende Code-Zeile zeigt eine typische Deklaration mit WithEvents:
    Public WithEvents evtVerweise As References
  2. Erstellen Sie im Klassenmodul eine Ereignisprozedurdefinition, indem Sie im Modulfenster im Feld Objekt den Namen der Objektvariablen vom Typ References auswählen. Wenn Sie z. B. die im vorherigen Schritt gezeigte Deklaration verwenden, sehen Sie im Dropdownlistenfeld Objekt den Eintrag evtVerweise. Wählen Sie dann im Feld Prozedur das Ereignis ItemAdded aus.

  3. Fügen Sie den Code hinzu, der ausgeführt werden soll, wenn das Ereignis eintritt. Wenn Sie z. B. ein Meldungsfeld mit der Information anzeigen möchten, dass ein Verweis zum Projekt hinzugefügt wurde, fügen Sie den entsprechenden Code zur Ereignisprozedur hinzu.

  4. Weisen Sie die Auflistung References der Objektvariablen vom Typ References zu, die Sie mit dem Schlüsselwort WithEvents deklariert haben. Diese Zuweisungsanweisung muss sich in einer Prozedur befinden, die ausgeführt wird, bevor das Ereignis ItemAdded eintritt.

    Beispielsweise können Sie diese Anweisung im Ereignis Initialize des Klassenmoduls verwenden, in dem Sie die Objektvariable deklariert haben. Wenn Sie dann eine Instanz der Klasse erstellen, wird die Objektvariable automatisch initialisiert. Wenn Sie die Objektvariable evtVerweise verwenden, sieht die Ereignisprozedur wie folgt aus:

    Private Sub Class_Initialize()
    Set evtVerweise = Application.References
End Sub

Anmerkung Wenn Sie die vorherigen Schritte bereits ausgeführt haben, um eine Ereignisprozedur für das Ereignis ItemRemoved zu erstellen, brauchen Sie diese für das Ereignis ItemAdded nicht mehr zu wiederholen. Sie können dieselbe Objektvariable vom Typ References für beide Ereignisse verwenden.

Um das Ereignis ItemAdded auszulösen, erstellen Sie den neuen Verweis mit Hilfe der Objektvariablen vom Typ References, die Sie mit dem Schlüsselwort WithEvents deklariert haben.

So fügen Sie einen Verweis hinzu und lösen das Ereignis aus:

  1. Erstellen Sie in einem Standardmodul eine neue Instanz der Klasse, in der Sie die Objektvariable vom Typ References deklariert haben. Wenn der Klassenname z. B. VerwEreignisse lautet, können Sie mit der folgenden Deklarationsanweisung eine neue Instanz der Klasse erstellen und sie einer Objektvariablen zuweisen. Diese Anweisung kann auf Modulebene oder in einer Prozedur vorkommen.
    Dim objVerwEreignisse As New VerwEreignisse
  2. Erstellen Sie in einer Sub-Prozedur oder einer Funktion ein neues References-Objekt, indem Sie die Methode AddFromFile oder AddFromGUID der Objektvariablen verwenden, welche die Auflistung References darstellt (evtVerweise). Da das Ereignis ItemAdded im Klassenmodul in Verbindung mit einer bestimmten Objektvariablen vom Typ References definiert ist, definieren Sie das neue Reference-Objekt unter Verwendung dieser Variablen. Andernfalls tritt das Ereignis nie ein.

Beachten Sie, dass Sie die Objektvariable vom Typ References zusammen mit dem Namen der Klasse angeben müssen, in der sie deklariert wird.

Wenn Sie die vorhergehenden Schritte vollständig ausgeführt haben, können Sie einen neuen Verweis etwa mit der folgenden Prozedur hinzufügen:

Function HinzufügenVerweis(strDateiname As String)
    Dim ref As Reference
    ' Neue Instanz der Klasse VerwEreignisse erstellen.
    Dim objVerwEreignisse As New VerwEreignisse
    ' Verweis auf Variable der References-Auflistung erstellen,
    ' die in der Klasse VerwEreignisse definiert wurde.
    Set ref = objVerwEreignisse.evtVerweise.AddFromFile(strDateiname)
End Function

Anmerkungen

  • Die Prozedur, welche die Objektvariable vom Typ References initialisiert, muss im selben Gültigkeitsbereich liegen wie die Deklaration der Objektvariablen. Wenn Sie z. B. die Objektvariable vom Typ References als Private in einem Klassenmodul deklariert haben, initialisieren Sie die Variable in einer Prozedur im gleichen Klassenmodul.

  • Sie können die Ereignisprozedur ItemAdded nur in einem Klassenmodul verwenden.

  • Wenn Sie eine Variable auf Modulebene so deklariert haben, dass sie die Auflistung References darstellt, können Sie mit dieser Variablen Ereignisprozedurdefinitionen für das Ereignis ItemAdded und das Ereignis ItemRemoved erstellen.

  • Wenn mehrere ItemAdded-Ereignisprozeduren im selben Projekt vorkommen, werden beim Eintreten des Ereignisses alle Ereignisprozeduren ausgeführt, jedoch in keiner festgelegten Reihenfolge. Es ist daher empfehlenswert, in jedem Projekt nur eine Ereignisprozedur ItemAdded zu erstellen und in ihr den gesamten Code aufzunehmen, der beim Eintreten des Ereignisses ausgeführt werden soll.

  • Das Ereignis ItemAdded tritt ein, nachdem der Verweis zum Projekt hinzugefügt wurde.


 ItemRemoved-Ereignis - Ereignisprozeduren

ItemRemoved-Ereignis - Ereignisprozeduren

Um eine Ereignisprozedur zu erstellen, die beim Eintreten des Ereignisses ItemRemoved ausgeführt wird, führen Sie die im Abschnitt "Anmerkung" dieses Themas beschriebenen Schritte durch.

Syntax

Private Sub evtVerweise_ItemRemoved(Verweise )

Die Ereignisprozedur ItemRemoved verwendet die folgenden Argumente.

Argument | Beschreibung
evtVerweise | Eine Objektvariable, die die Auflistung References darstellt. Deklarieren Sie diese Objektvariable mit Hilfe des Schlüsselworts WithEvents in einem Klassenmodul.
Verweis | Das Reference-Objekt, das aus der Auflistung References entfernt wurde.

Anmerkung

Die Ereignisprozedur ItemRemoved kann Code enthalten, den Sie ausführen möchten, wenn ein Verweis auf eine Typbibliothek aus dem Projekt entfernt wird. Sie können von Visual Basic aus einen Verweis entfernen, indem Sie mit der Methode Remove ein Reference-Objekt aus der Auflistung References entfernen.

So erstellen Sie die Ereignisprozedur ItemRemoved:

  1. Deklarieren Sie unter Verwendung des Schlüsselworts WithEvents im Deklarationsbereich eines Klassenmoduls eine Objektvariable vom Typ References. Microsoft Access definiert mit dieser Objektvariablen die Ereignisprozedur für das Ereignis ItemRemoved. Die folgende Codezeile zeigt eine typische WithEvents-Deklaration:
    Public WithEvents evtVerweise As References
  2. Erstellen Sie im Klassenmodul eine Ereignisprozedurdefinition, indem Sie im Modulfenster im Feld Objekt den Namen der Objektvariablen vom Typ References auswählen. Wenn Sie z. B. die im vorherigen Schritt gezeigte Deklaration verwenden, sehen Sie im Dropdownlistenfeld Objekt den Eintrag evtVerweise. Wählen Sie dann im Feld Prozedur das Ereignis ItemRemoved aus.

  3. Fügen Sie den Code hinzu, der ausgeführt werden soll, wenn das Ereignis eintritt. Wenn Sie z. B. ein Meldungsfeld mit der Information anzeigen möchten, dass ein Verweis aus dem Projekt entfernt wurde, fügen Sie den entsprechenden Code zur Ereignisprozedur hinzu.

  4. Weisen Sie die Auflistung References der Objektvariablen vom Typ References zu, die Sie mit dem Schlüsselwort WithEvents deklariert haben. Diese Zuweisungsanweisung muss sich in einer Prozedur befinden, die ausgeführt wird, bevor das Ereignis ItemRemoved eintritt.

    Beispielsweise können Sie diese Anweisung im Ereignis Initialize des Klassenmoduls verwenden, in dem Sie die Objektvariable deklariert haben. Wenn Sie dann eine Instanz der Klasse erstellen, wird die Objektvariable automatisch initialisiert. Wenn Sie die Objektvariable evtVerweise verwenden, sieht die Ereignisprozedur wie folgt aus:

    Private Sub Class_Initialize()
Set evtVerweise = Application.References
End Sub

Anmerkung Wenn Sie die vorherigen Schritte bereits ausgeführt haben, um eine Ereignisprozedur für das Ereignis ItemAdded zu erstellen, brauchen Sie diese für das Ereignis ItemRemoved nicht mehr zu wiederholen. Sie können dieselbe Objektvariable vom Typ References für beide Ereignisse verwenden.

Um das Ereignis ItemRemoved auszulösen, entfernen Sie den neuen Verweis mit Hilfe der Objektvariablen vom Typ References, die Sie mit dem Schlüsselwort WithEvents deklariert haben.

So entfernen Sie einen Verweis und lösen das Ereignis aus:

  1. Erstellen Sie in einem Standardmodul eine neue Instanz der Klasse, in der Sie die Objektvariable vom Typ References deklariert haben. Wenn der Klassenname z. B. VerwEreignisse lautet, können Sie mit der folgenden Deklarationsanweisung eine neue Instanz der Klasse erstellen und sie einer Objektvariablen zuweisen. Diese Anweisung kann auf Modulebene oder in einer Prozedur vorkommen.
    Dim objVerwEreignisse As New VerwEreignisse
  2. Erstellen Sie in einer Sub-Prozedur oder einer Funktion ein neues References-Objekt, indem Sie die Methode Remove der Objektvariablen verwenden, welche die Auflistung References darstellt (evtVerweise). Da das Ereignis ItemRemoved im Klassenmodul in Verbindung mit einer bestimmten Objektvariablen vom Typ References definiert ist, definieren Sie das neue Reference-Objekt unter Verwendung dieser Variablen. Andernfalls tritt das Ereignis nie ein.

Beachten Sie, dass Sie die Objektvariable vom Typ References zusammen mit dem Namen der Klasse angeben müssen, in der sie deklariert wird.

Wenn Sie die vorhergehenden Schritte vollständig ausgeführt haben, können Sie einen bestehenden Verweis etwa mit der folgenden Prozedur entfernen:

Function EntfernenVerweis(strVerwName As String)
    Dim ref As Reference
    ' Neue Instanz der Klasse VerwEreignisse erstellen.
    Dim objVerwEreignisse As New VerwEreignisse

    ' Verweis auf Variable der References-Auflistung erstellen,
    ' die in der Klasse VerwEreignisse definiert wurde.
    Set ref = objVerwEreignisse.evtVerweise(strVerwName)
    objVerwEreignisse.evtVerweise.Remove ref
End Function

Anmerkungen

  • Die Prozedur, welche die Objektvariable vom Typ References initialisiert, muss im selben Gültigkeitsbereich liegen wie die Deklaration der Objektvariablen. Wenn Sie z. B. die Objektvariable vom Typ References als Private in einem Klassenmodul deklariert haben, initialisieren Sie die Variable in einer Prozedur im gleichen Klassenmodul.

  • Sie können die Ereignisprozedur ItemRemoved nur in einem Klassenmodul verwenden.

  • Wenn Sie eine Variable auf Modulebene so deklariert haben, dass sie die Auflistung References darstellt, können Sie mit dieser Variablen Ereignisprozedurdefinitionen für das Ereignis ItemRemoved und das Ereignis ItemAdded erstellen.

  • Wenn mehrere ItemRemoved-Ereignisprozeduren im selben Projekt vorkommen, werden beim Eintreten des Ereignisses alle Ereignisprozeduren ausgeführt, jedoch in keiner festgelegten Reihenfolge. Es ist daher empfehlenswert, in jedem Projekt nur eine Ereignisprozedur ItemRemoved zu erstellen und in ihr den gesamten Code aufzunehmen, der beim Eintreten des Ereignisses ausgeführt werden soll.

  • Das Ereignis ItemRemoved tritt ein, nachdem der Verweis auf das Projekt entfernt wurde.


 KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf) - Ereignisprozeduren

KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn eines der Ereignisse KeyDown oder KeyUp eintritt, stellen Sie die Eigenschaft Bei Taste Ab oder Bei Taste Auf auf [Ereignisprozedur] ein und klicken dann auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_KeyDown(KeyCode As Integer, Shift As Integer)

Private Sub Steuerelementname_KeyDown(KeyCode As Integer, Shift As Integer)

Private Sub Form_KeyUp(KeyCode As Integer, Shift As Integer)

Private Sub Steuerelementname_KeyUp(KeyCode As Integer, Shift As Integer)

Die Ereignisse KeyDown und KeyUp haben die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen KeyUp- oder KeyDown-Ereignisprozedur ausgeführt werden soll.
KeyCode | Ein Tastencode, wie z. B. vbKeyF1 (die F1-TASTE) oder vbKeyHome (die POS1-TASTE). Zum Festlegen von Tastencodes verwenden Sie die im Objektkatalog aufgeführten eingebauten Konstanten. Durch Festlegen der Einstellung 0 für KeyCode können Sie verhindern, dass ein Objekt einen Tastenanschlag empfängt.
Shift | Der Status der UMSCHALT-, STRG- und ALT-TASTE zu dem Zeitpunkt, an dem das Ereignis eintritt. Wenn Sie das Argument Shift auswerten müssen, können Sie eine der folgenden eingebauten Konstanten als Bit-Maske verwenden:
 | Konstante | Beschreibung
 | acShiftMask | Bitmaske für UMSCHALT.
 | acCtrlMask | Bitmaske für STRG.
 | acAltMask | Bitmaske für ALT.

Anmerkung

Zum Prüfen, ob eine Bedingung erfüllt ist, weisen Sie jedes Ergebnis zuerst einer temporären Variablen des Datentyps Integer zu und vergleichen dann das Argument Shift mit einer eingebauten Konstante. Zum Testen, ob das Ergebnis der Bedingung größer 0 ist, verwenden Sie den Operator And zusammen mit dem Argument Shift. Ist dies der Fall, wurden die UMSCHALT-, die STRG- oder die ALT-TASTE gedrückt, wie im folgenden Beispiel gezeigt:

ShiftDown = (Shift And acShiftMask) > 0

In einer Ereignisprozedur können Sie beliebige kombinierte Bedingungen prüfen. Beispiel:

If ShiftDown And CtrlDown Then
.    '  Folgende Anweisungen ausführen, wenn UMSCHALT und STRG gedrückt sind.
.
.
End If

Mit Hilfe der KeyDown- und der KeyUp-Ereignisprozeduren können Sie für jedes Zeichen testen, ob die Groß- oder die Kleinschreibungsversion gedrückt wurde. Dazu werten Sie sowohl das Argument KeyCode als auch das Argument Shift aus. Das Argument KeyCode gibt an, welche Taste tatsächlich gedrückt wurde (A und a werden hier als dieselbe Taste interpretiert). Das Argument Shift gibt den Status von SHIFT+Taste an und ergibt daher A oder a.

Verwenden Sie die Ereignisprozeduren KeyDown und KeyUp für Tastaturprozeduren, wenn Sie sowohl auf das Drücken als auch das Loslassen einer Taste reagieren müssen.

Sie können auf bestimmte in einem Formular gedrückte Tasten unabhängig davon reagieren, welches Steuerelement den Fokus hat. Angenommen, Sie möchten, dass die Tastenkombination STRG+X in einem Formular immer die gleiche Aktion ausführt. Um sicherzustellen, dass ein Formular alle Tastaturereignisse, auch die, die für Steuerelemente eintreten, vor deren Eintreten für die Steuerelemente empfängt, legen Sie für die Eigenschaft Tastenvorschau des Formulars die Einstellung Ja fest. Mit dieser Einstellung treten alle Tastaturereignisse zuerst für das Formular und dann für das Steuerelement ein, das den Fokus hat. Sie können in den Ereignissen KeyDown, KeyPress und KeyUp des Formulars auf bestimmte Tastenkombinationen reagieren. Sie können verhindern, dass ein Steuerelement Tastenanschläge empfängt, auf die Sie reagiert haben. Dazu legen Sie für das Argument KeyCode der Ereignisse KeyDown und KeyUp und (wenn die Taste eine ANSI-Taste ist) für das Argument KeyAscii des Ereignisses KeyPress den Wert 0 fest. Wenn Sie nicht möchten, dass das Steuerelement die Tastenanschläge empfängt, müssen Sie für alle 3 Argumente den Wert 0 einstellen.

Sie können die Argumente für die Ereignisse KeyDown, KeyPress und KeyUp zusammen mit den Argumenten für die Ereignisse MouseDown, MouseUp und MouseMove verwenden, um Ihre Anwendung für Tastatur- und Maus-Benutzer gleich einzustellen.

Die Ereignisse KeyDown und KeyUp können nicht unterbunden werden.


KeyDown-, KeyUp-Ereignisprozeduren (TasteAb, TasteAuf) - Ereignisprozeduren-Beispiel

Das nachstehende Beispiel ermittelt, ob die Taste UMSCHALT, STRG oder ALT gedrückt wurde.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das ein Textfeld namens TastenAuswert enthält.

Private Sub TastenAuswert_KeyDown(KeyCode As Integer,_     Shift As Integer)
    Dim intUmschaltGedr As Integer, intAltGedr As Integer
    Dim intStrgGedr As Integer

    ' Bit-Masken einsetzen, um die gedrückte Taste zu ermitteln.
    intUmschaltGedr = (Shift And acShiftMask) > 0
    intAltGedr = (Shift And acAltMask) > 0
    intStrgGedr = (Shift And acCtrlMask) > 0
    ' Per Meldung dem Benutzer mitteilen, welche Taste gedrückt wurde.
    If intUmschaltGedr Then MsgBox "Sie haben UMSCHALT gedrückt."
    If intAltGedr Then MsgBox "Sie haben ALT gedrückt."
    If intStrgGedr Then MsgBox "Sie haben STRG gedrückt."
End Sub


 KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf) - Makros

KeyDown-, KeyUp-Ereignisse (TasteAb, TasteAuf) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses KeyDown oder KeyUp stellen Sie die Eigenschaft Bei Taste Ab bzw. Bei Taste Auf auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis KeyDown bzw. KeyUp so einsetzen, dass es immer dann reagiert, wenn der Benutzer eine Taste drückt oder loslässt, während ein Formular oder Steuerelement den Fokus hat. Da Makros jedoch nicht den Tastencode zurückgeben und nicht feststellen können, welche Taste gedrückt wurde, werden für diese Ereignisse in der Regel eher Ereignisprozeduren verwendet.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis KeyDown bzw. KeyUp nicht eingesetzt werden.


 KeyPress-Ereignis (Taste) - Ereignisprozeduren

KeyPress-Ereignis (Taste) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis KeyPress eintritt, stellen Sie die Eigenschaft Bei Taste auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_KeyPress(KeyAscii As Integer)

Private Sub Steuerelementname_KeyPress(KeyAscii As Integer)

Das Ereignis KeyPress hat die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen KeyPress-Ereignisprozedur ausgeführt werden soll.
KeyAscii | Gibt einen numerischen ANSI-Code zurück. Das Argument KeyAscii wird als Referenz übergeben. Wird dieses Argument geändert, wird ein anderes Zeichen an das Objekt gesendet. Bei Verwendung des Wertes 0 für KeyAscii wird der Tastenanschlag annulliert, so dass das Objekt nicht erkennt, dass eine Taste gedrückt wurde.

Anmerkung

Eine Ereignisprozedur für das Ereignis KeyPress eignet sich zum Abfangen von Tastenanschlägen, die in ein Textfeld oder ein Kombinationsfeld eingegeben werden. Sie erlaubt das Überprüfen von Tastenanschlägen auf Gültigkeit oder das Formatieren eingegebener Zeichen. Wird der Wert des Arguments KeyAscii geändert, ändert sich das angezeigte Zeichen.

Mit dem folgenden Ausdruck können Sie das Argument KeyAscii in ein Zeichen umwandeln.

Chr(KeyAscii)

Anschließend können Sie das Zeichen als Zeichenfolge verarbeiten und mit dem folgenden Ausdruck in eine ANSI-Nummer zurückübersetzen, die vom Steuerelement erkannt werden kann.

KeyAscii = Asc(Zeichen)

Anmerkung Die ANSI-Nummer für die Tastenkombination STRG+@ lautet 0. Da Microsoft Access einen KeyAscii-Wert von 0 als Zeichenfolge der Länge Null (" ") interpretiert, sollten Sie die Tastenkombination STRG+@ in Ihren Anwendungen vermeiden.

Sie können, unabhängig davon, welches Steuerelement den Fokus hat, auf bestimmte im geöffneten Formular gedrückte Tasten reagieren. Sie können z. B. festlegen, dass mit der Tastenkombination STRG+X auf einem Formular immer dieselbe Aktion ausgeführt werden soll. Wenn Sie sicherstellen möchten, dass ein Formular alle Tastaturereignisse, d. h. auch die, die für Steuerelemente eintreten, vor deren Eintreten für die Steuerelemente empfängt, stellen Sie die Eigenschaft Tastenvorschau des Formulars auf Ja ein. Mit dieser Eigenschafteneinstellung treten alle Tastaturereignisse zuerst für das Formular und dann für das Steuerelement ein, das den Fokus hat. Sie können in den Ereignissen KeyDown, KeyPress und KeyUp des Formulars auf bestimmte Tastenanschläge reagieren. Sie können verhindern, dass ein Steuerelement Tastenanschläge empfängt, auf die Sie reagiert haben, und dass für das Steuerelement Tastaturereignisse eintreten. Dazu stellen Sie das Argument KeyCode sowohl für das Ereignis KeyDown als auch für das Ereignis KeyUp auf 0 und das Argument KeyAscii für das Ereignis KeyPress auf 0 ein. Wenn Sie verhindern möchten, dass das Steuerelement Tastenanschläge empfängt, müssen Sie alle drei Argumente auf 0 einstellen.

Sie können die Argumente für die Ereignisse KeyDown, KeyPress und KeyUp zusammen mit den Argumenten für die Ereignisse MouseDown, MouseUp und MouseMove verwenden, wenn Ihre Anwendung sowohl für Tastatur- als auch für Mausbenutzer einfach zu handhaben sein soll.

Das Ereignis KeyPress kann nicht in einer Ereignisprozedur, jedoch in einem Makro unterbunden werden.


KeyPress (Taste)-Ereignisprozedur - Ereignisprozeduren-Beispiel

Das nachstehende Beispiel konvertiert Text, der in ein Textfeld eingegeben wird, während der Eingabe zeichenweise in Großbuchstaben.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das ein Textfeld namens Region enthält.

Private Sub Region_KeyPress(KeyAscii As Integer)
    Dim strZeichen As String

    ' Umwandeln des ANSI-Wertes in eine Zeichenfolge.
    strZeichen = Chr(KeyAscii)
    ' Umwandeln des Zeichens in einen Großbuchstaben und dann in
    ' einen ANSI-Wert.
    KeyAscii = Asc(UCase(strZeichen))
End Sub


 KeyPress-Ereignis (Taste) - Makros

KeyPress-Ereignis (Taste) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses KeyPress stellen Sie die Eigenschaft Bei Taste auf den Namen des Makros ein.

Anmerkung

Mit einem Makro für das Ereignis KeyPress können Sie immer dann reagieren, wenn der Benutzer eine ANSI-Taste drückt, während ein Formular oder ein Steuerelement den Fokus hat. Da Makros jedoch weder den ANSI-Tastencode zurückgeben noch feststellen können, welche Taste gedrückt wurde, werden für dieses Ereignis in der Regel eher Ereignisprozeduren verwendet.

Sie können in einem Makro für das Ereignis KeyPress die Aktion AbbrechenEreignis verwenden, wenn Sie die Reaktion auf die Taste oder Tastenkombination abbrechen möchten. Sie können z. B. das Eingeben bestimmter ANSI-Zeichen in ein Steuerelement unter bestimmten Bedingungen unterbinden.


 Load-, Unload-Ereignisse (Laden, Entladen) - Ereignisprozeduren

Load-, Unload-Ereignisse (Laden, Entladen) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Load oder Unload eintritt, stellen Sie die Eigenschaft Beim Laden bzw. Beim Entladen auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_Load( )

Private Sub Form_Unload(Cancel As Integer)

Das Ereignis Unload hat das folgende Argument.

Argument | Beschreibung
Cancel | Einstellung, die angibt, ob das Formular entladen werden soll. Wenn Sie das Argument Cancel auf True (-1) einstellen, wird das Entladen des Formulars verhindert.

Anmerkung

Sie können in der Ereignisprozedur für das Ereignis Load eines Formulars einen Initialisierungscode verwenden. Sie können z. B. Standardeinstellungen für Steuerelemente festlegen und die auf Formularebene definierten Variablen initialisieren.

Das Ereignis Load kann nicht unterbunden werden.

Sie können in der Ereignisprozedur für das Ereignis Unload einen Code zur Plausibilitätsprüfung auf Formularebene verwenden, den Sie möglicherweise zum Schließen des Formulars oder Speichern der enthaltenen Daten in einer Datei benötigen.

Wenn das Argument Cancel für ein gebundenes Formular auf den Wert True eingestellt ist, kann es sein, dass Sie die Steuerung nicht wieder an die restliche Anwendung zurückgeben können.


Load-, Unload- Ereignis (Laden, Entladen) - Ereignisprozeduren-Beispiel

Das nachstehende Beispiel zeigt das aktuelle Datum beim Laden des Formulars in der Beschriftung des Formulars an.

Zum Testen dieses Beispiels fügen Sie die folgende Ereignisprozedur zu einem Formular hinzu:

Private Sub Form_Load()
    Me.Caption = Date
End Sub

Das nächste Beispiel fordert den Benutzer auf, zu bestätigen, dass das Formular geschlossen werden soll.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu. Schließen Sie das Formular in der Formularansicht, um das Dialogfeld anzuzeigen, und klicken Sie dann auf Ja oder Nein.

Private Sub Form_Unload(Cancel As Integer)
    If MsgBox("Formular schließen?", vbYesNo) = vbYes Then
        Exit Sub
    Else
        Cancel = True
    End If
End Sub


 Load-, Unload-Ereignisse (Laden, Entladen) - Makros

Load-, Unload-Ereignisse (Laden, Entladen) - Makros

Wenn beim Eintreten des Ereignisses Load oder Unload ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Beim Laden bzw. Beim Entladen auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis Load erstellen, das nach dem Öffnen eines Formulars Aktionen für die Steuerelemente oder Datensätze eines Formulars ausführt. Sie können z. B. Standardeinstellungen für Steuerelemente festlegen.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Load nicht eingesetzt werden.

Sie können die Aktion AbbrechenEreignis in einem Makro für das Ereignis Unload verwenden, wenn Sie das Entladen von Datensätzen unterbinden möchten. Damit wird auch das Schließen des Formulars unterbunden.

Wenn ein Makro für das Ereignis Unload die Aktion AbbrechenEreignis ausführt, können Sie das Formular nicht mehr schließen. Sie müssen entweder den Zustand korrigieren, der zum Ausführen der Aktion AbbrechenEreignis führte, oder Sie müssen das Makro öffnen und die Aktion AbbrechenEreignis löschen. Wenn es sich um ein gebundenes Formular handelt, können Sie weder das Makro öffnen noch in anderen Fenstern der Anwendung arbeiten.


 MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf) - Ereignisprozeduren

MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis MouseDown oder MouseUp eintritt, stellen Sie die Eigenschaft Bei Maustaste Ab bzw. Bei Maustaste Auf auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_MouseDown(Button As Integer, Shift As Integer, X As Single, Y As Single)

Private Sub Steuerelementname_MouseDown(Button As Integer, Shift As Integer, X As Single, Y As Single)

Private Sub Form_MouseUp(Button As Integer, Shift As Integer, X As Single, Y As Single)

Private Sub Steuerelementname_MouseUp(Button As Integer, Shift As Integer, X As Single, Y As Single)

Die Ereignisse MouseDown oder MouseUp haben die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen MouseDown- oder MouseUp-Ereignisprozedur ausgeführt werden soll.
Button | Die Taste, die gedrückt (MouseDown) oder losgelassen (MouseUp) wurde und das Ereignis ausgelöst hat. Wenn Sie das Argument Button auswerten müssen, können Sie eine der folgenden eingebauten Konstanten als Bit-Maske verwenden:
 | Konstante | Beschreibung
 | acLeftButton | Bit-Maske für die linke Maustaste.
 | AcRightButton | Bit-Maske für die rechte Maustaste.
 | AcMiddleButton | Bit-Maske für die mittlere Maustaste.
Shift | Der Status der Taste UMSCHALT, STRG und ALT, den diese hatten, als die durch das Argument Button angegebene Taste gedrückt oder losgelassen wurde. Wenn Sie das Argument Shift auswerten müssen, können Sie eine der folgenden eingebauten Konstanten als Bit-Maske verwenden:
 | Konstante | Beschreibung
 | acShiftMask | Bit-Maske für UMSCHALT.
 | acCtrlMask | Bit-Maske für STRG.
 | acAltMask | Bit-Maske für ALT.
X, Y | Die x- und y-Koordinaten für die aktuelle Position des Mauszeigers. X und Y werden immer in Twips angegeben.

Anmerkung Wird eine Maustaste gedrückt, während sich der Mauszeiger auf einem Formular oder Steuerelement befindet, empfängt dieses Objekt alle Mausereignisse bis einschließlich des letzten der Ereignisse MouseUp. Dies bedeutet, dass sich die Argumente X und Y nicht immer auf das Objekt beziehen, an das sie gesendet werden.

Anmerkung

Zum Prüfen, ob eine Bedingung erfüllt ist, weisen Sie jedes Ergebnis zuerst einer temporären Variablen des Datentyps Integer zu und gleichen dann das Argument Shift oder Button gegen eine eingebaute Konstante ab. Verwenden Sie zum Testen, ob das Ergebnis der Bedingung größer 0 ist und damit angibt, dass die linke, die rechte oder die mittlere Taste gedrückt wurde, das Argument Button zusammen mit dem Operator And. Beispiel:

LinksUnten = (Button And acLeftButton) > 0

In einer Ereignisprozedur können Sie beliebige kombinierte Bedingungen prüfen. Beispiel:

If UmschaltGedrückt And StrgGedrückt Then
    ' Diese Schritte ausführen, wenn UMSCHALT und STRG
    ' gedrückt sind.
    .
    .
EndIf

Anmerkung Das für die Ereignisse MouseDown und MouseUp verwendete Argument Button unterscheidet sich von dem für das Ereignis MouseMove verwendeten Argument Button. Für die Ereignisse MouseDown und MouseUp gibt das Argument Button je Ereignis genau eine Taste an. Das heißt, wenn Sie zwei Maustasten drücken, treten zwei Ereignisse MouseDown (und MouseUp) mit jeweils unterschiedlichem Wert für das Argument Button ein. Für das Ereignis MouseMove gibt das Argument Button den aktuellen Status aller Maustasten an.

Sie können die Argumente für die Ereignisse KeyDown, KeyPress und KeyUp zusammen mit den Argumenten für die Ereignisse MouseDown, MouseUp und MouseMove verwenden, wenn Ihre Anwendung sowohl für Tastatur- als auch für Mausbenutzer einfach zu handhaben sein soll.

Die Ereignisse MouseDown und MouseUp können nicht unterbunden werden.


MouseDown-, MouseUp-Ereignis (MaustasteAb, MaustasteAuf) - Ereignisprozeduren-Beispiel

Das nachstehende Beispiel zeigt, wie Sie feststellen können, welche Maustaste das Ereignis MouseDown ausgelöst hat.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu.

Private Sub Form_MouseDown(Button As Integer, Shift As Integer,X As Single, Y As Single)
    If Button = acLeftButton Then _
        MsgBox "Sie haben die linke Maustaste gedrückt."
    If Button = acRightButton Then _
        MsgBox "Sie haben die rechte Maustaste gedrückt."
    If Button = acMiddleButton Then _
        MsgBox "Sie haben die mittlere Maustaste gedrückt."
End Sub


 MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf) - Makros

MouseDown-, MouseUp-Ereignisse (MaustasteAb, MaustasteAuf) - Makros

Wenn beim Eintreten des Ereignisses MouseDown oder MouseUp ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Bei Maustaste Ab bzw. Bei Maustaste Auf auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis MouseDown oder MouseUp verwenden, um immer dann zu reagieren, wenn der Benutzer auf einem Formular oder Steuerelement eine Maustaste drückt bzw. loslässt. Da Makros jedoch weder Maustastencodes zurückgeben noch feststellen können, welche Maustaste gedrückt wurde, werden für dieses Ereignis in der Regel eher Ereignisprozeduren verwendet.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis MouseDown bzw. MouseUp nicht eingesetzt werden, mit einer Ausnahme: Sie können die Aktion AbbrechenEreignis in einem Makro für das Ereignis MouseDown verwenden, wenn Sie das Ereignis unterbinden möchten, das beim Drücken der rechten Maustaste eintritt. Sie können z. B. die Anzeige eines Kontextmenüs unterbinden und stattdessen ein benutzerdefiniertes Kontextmenü anzeigen.


 MouseMove-Ereignis (Mausbewegung) - Ereignisprozeduren

MouseMove-Ereignis (Mausbewegung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis MouseMove eintritt, stellen Sie die Eigenschaft Bei Mausbewegung auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single)

Private Sub Steuerelementname_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single)

Das Ereignis MouseMove hat die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen MouseMove-Ereignisprozedur ausgeführt werden soll.
Button | Der Status der Maustaste beim Eintreten des Ereignisses. Wenn Sie das Argument Button auswerten müssen, können Sie eine der folgenden eingebauten Konstanten als Bit-Maske verwenden:
 | Konstante | Beschreibung
 | acLeftButton | Bit-Maske für die linke Maustaste.
 | acRightButton | Bit-Maske für die rechte Maustaste.
 | acMiddleButton | Bit-Maske für die mittlere Maustaste.
Shift | Der Status der Tasten UMSCHALT, STRG und ALT, den diese hatten, als die durch das Argument Button angegebene Taste gedrückt oder losgelassen wurde. Wenn Sie das Argument Shift auswerten müssen, können Sie eine der folgenden eingebauten Konstanten als Bit-Maske verwenden:
 | Konstante | Beschreibung
 | acShiftMask | Bitmaske für UMSCHALT.
 | acCtrlMask | Bitmaske für STRG.
 | acAltMask | Bitmaske für ALT.
X, Y | Die x- und y-Koordinaten für die aktuelle Position des Mauszeigers. X und Y werden immer in Twips angegeben.

Anmerkung

Zum Prüfen, ob eine Bedingung erfüllt ist, weisen Sie jedes Ergebnis zuerst einer temporären Variablen des Datentyps Integer zu und gleichen dann das Argument Shift oder Button gegen eine eingebaute Konstante ab. Verwenden Sie zum Testen, ob das Ergebnis der Bedingung größer 0 ist und damit angibt, dass die linke, die rechte oder die mittlere Taste gedrückt wurde, das Argument Button zusammen mit dem Operator And. Beispiel:

LinksUnten = (Button And acLeftButton) > 0

In einer Ereignisprozedur können Sie beliebig kombinierte Bedingungen prüfen. Beispiel:

If UmschaltGedrückt And StrgGedrückt Then
    .' Diese Schritte ausführen, wenn UMSCHALT und STRG
    .' gedrückt sind.
    .
EndIf

Anmerkung Das für die Ereignisse MouseDown und MouseUp verwendete Argument Button unterscheidet sich von dem für das Ereignis MouseMove verwendeten Argument Button. Für das Ereignis MouseMove gibt das Argument Button den aktuellen Status aller Maustasten an. Ein einzelnes Ereignis MouseMove kann eine beliebige Kombination der Maustasten angeben (einige, alle oder keine Maustaste gedrückt). Wenn Sie z. B. beim Bewegen der Maus sowohl die linke als auch die rechte Maustaste drücken, hat das Argument Button den Wert 3 (1 + 2). Für die Ereignisse MouseDown und MouseUp gibt das Argument Button je Ereignis genau eine Taste an.

Sie können die Argumente für die Ereignisse KeyDown, KeyPress und KeyUp zusammen mit den Argumenten für die Ereignisse MouseDown, MouseUp und MouseMove verwenden, wenn Ihre Anwendung sowohl für Tastatur- als auch für Mausbenutzer einfach zu handhaben sein soll. Angenommen, Sie möchten den Fokus der Tastatur mit dem Mausfokus abstimmen. Diese sind in der Regel identisch. Wenn Sie den Mauszeiger z. B. zuerst auf ein Textfeld setzen und dann mit der Maustaste klicken, werden sowohl der Tastaturfokus als auch der Mausfokus an das Textfeld vergeben. Das Bewegen des Mauszeigers über ein Steuerelement bewirkt jedoch nicht, dass dieses Steuerelement den Tastaturfokus erhält. Sie müssen mit einer Maustaste klicken, eine der Navigationstasten auf der Tastatur verwenden oder den Fokus in einer Ereignisprozedur für MouseMove auf das Steuerelement setzen.

Da das Ereignis MouseMove für jeden Bereich des Formulars, über den der Mauszeiger bewegt wird, eintritt, kann es bei unkontrollierten Bewegungen zu einer Unzahl von MouseMove-Ereignissen kommen. Sie können sicherstellen, dass ein Steuerelement oder ein Bereich, für den das Ereignis MouseMove einmal eingetreten ist, keine weiteren Ereignisse erhält, so lange der Mauszeiger sich noch auf diesem Bereich des Formulars befindet. Dazu deklarieren und prüfen Sie eine Modulvariable, die angibt, ob das Ereignis MouseMove für dieses Steuerelement oder diesen Formularbereich bereits eingetreten ist oder nicht.

Sie können das Ereignis MouseMove nicht unterbinden.


MouseMove-Ereignis (Mausbewegung) - Ereignisprozeduren-Beispiel

Im nachstehenden Beispiel wird ermittelt, wo sich der Mauszeiger befindet und ob die linke Maustaste und/oder die Taste UMSCHALT gedrückt sind. Während Sie die Maus bewegen, werden in einem Bezeichnungsfeld die x- und die y-Koordinate der Mauszeigerposition angezeigt.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das ein Bezeichnungsfeld namens Koordinaten enthält.

Private Sub Detailbereich_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single)
    Dim intUmschaltUnten As Integer, intLinkeMaustaste As Integer

    Me!Koordinaten.Caption = X & ", " & Y
    ' Bit-Masken einsetzen, um den Status der Umschalttaste und der
    ' linken Maustaste zu ermitteln.
    intUmschaltUnten = Shift And acShiftMask
    intLinkeMaustaste = Button And acLeftButton
    ' Prüfen, ob sowohl die Umschalttaste als auch die linke Maustaste
    ' gedrückt sind.
    If intUmschaltUnten And intLinkeMaustaste > 0 Then
        MsgBox "Umschalttaste und linke Maustaste wurden gedrückt."
    End If
End Sub


 MouseMove-Ereignis (Mausbewegung) - Makros

MouseMove-Ereignis (Mausbewegung) - Makros

Wenn beim Eintreten des Ereignisses MouseMove ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Bei Mausbewegung auf den Namen des Makros ein.

Anmerkung

Sie können ein Makro für das Ereignis MouseMove einsetzen, um immer dann zu reagieren, wenn der Benutzer die Maus auf einem Formular oder Steuerelement bewegt. Da Makros aber weder den Maustastencode zurückgeben noch die Koordinaten des Mauszeigers während einer Bewegung ermitteln können, verwenden Sie in der Regel für dieses Ereignis eher Ereignisprozeduren.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis MouseMove nicht eingesetzt werden.


 NoData-Ereignis (OhneDaten) - Ereignisprozeduren

NoData-Ereignis (OhneDaten) - Ereignisprozeduren

Wenn Sie eine Ereignisprozedur erstellen möchten, die ausgeführt wird, sobald das Ereignis NoData eingetreten ist, stellen Sie die Eigenschaft OnNoData auf [Ereignisprozedur] ein und klicken auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Report_NoData(Cancel As Integer)

Eine NoData-Ereignisprozedur hat das folgende Argument.

Argument | Beschreibung
Cancel | Die Einstellung dieses Arguments gibt an, ob der Bericht gedruckt wird. Wird das Argument Cancel auf True (-1) eingestellt, wird der Bericht nicht gedruckt. Sie können auch die Methode CancelEvent des Objekts DoCmd verwenden, um das Drucken des Berichts abzubrechen.


NoData-Ereignis (OhneDaten) - Ereignisprozedur - Beispiel

Das folgende Beispiel zeigt, wie Sie das Drucken eines Berichts abbrechen können, der keine Daten enthält. Es wird ein Meldungsfeld angezeigt, das dem Benutzer mitteilt, dass der Druckvorgang abgebrochen wurde.

Sie können dieses Beispiel ausprobieren, indem Sie die folgende Ereignisprozedur zu einem Bericht hinzufügen. Versuchen Sie, den Bericht auszuführen, wenn er keine Daten enthält.

Private Sub Report_NoData(Cancel As Integer)
    MsgBox "Der Bericht enthält keine Daten." _
        & chr(13) & "Das Drucken wird abgebrochen. " _
        & chr(13) & "Überprüfen Sie die Datenquelle für " _
        & chr(13) & "den Bericht. Stellen Sie sicher, dass " _
        & chr(13) & "Sie die richtigen Kriterien eingeben  " _
        & chr(13) & "(z. B. einen gültigen Datums- " _
        & chr(13) & "bereich),." vbOKOnly + vbInformation
    Cancel = True
End Sub


 NoData-Ereignis (OhneDaten) - Makros

NoData-Ereignis (OhneDaten) - Makros

Soll ein Makro ausgeführt werden, wenn das Ereignis NoData eintritt, stellen Sie die Eigenschaft OnNoData auf den Namen des Makros ein.

Anmerkung

Wenn Sie verhindern möchten, dass ein leerer Bericht gedruckt wird, können Sie das Drucken in einem NoData-Makro mit der Aktion AbbrechenEreignis abbrechen.


 NotInList-Ereignis (NichtInListe) - Ereignisprozeduren

NotInList-Ereignis (NichtInListe) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis NotInList auftritt, stellen Sie die Eigenschaft Bei Nicht in Liste auf [Ereignisprozedur] ein und klicken dann auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Steuerelementname_NotInList(NewData As String, Response As Integer)

Ereignisprozeduren für das Ereignis NotInList haben folgende Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen NotInList-Ereignisprozedur ausgeführt werden soll.
NewData | Eine Zeichenfolge, die Microsoft Access zum Übergeben des vom Benutzer in das Textfeld des Kombinationsfelds eingegebenen Textes an die Ereignisprozedur verwendet.
Response | Diese Einstellung gibt an, wie auf das Ereignis NotInList reagiert wurde. Das Argument Response kann die folgenden eingebauten Konstanten annehmen:
 | Konstante | Beschreibung
 | acDataErrDisplay | (Voreinstellung) Zeigt dem Benutzer die Standardmeldung an. Vewenden Sie diese Konstante, wenn Sie verhindern möchten, dass der Benutzer zum Listenfeld des Kombinationsfelds einen neuen Wert hinzufügen kann.
 | AcDataErrContinue | Zeigt dem Benutzer nicht die Standardmeldung an. Verwenden Sie diese Konstante, wenn Sie eine benutzerdefinierte Meldung anzeigen möchten. Sie können in der Ereignisprozedur z. B. ein benutzerdefiniertes Dialogfeld anzeigen, in dem der Benutzer gefragt wird, ob der neue Eintrag gespeichert werden soll. Wenn die Antwort Ja lautet, kann die Ereignisprozedur den neuen Eintrag zum Listenfeld hinzufügen und das Argument Response auf acDataErrAdded einstellen. Lautet die Antwort Nein, kann die Ereignisprozedur das Argument Response auf acDataErrContinue einstellen.
 | AcDataErrAdded | Zeigt dem Benutzer keine Meldung an, erlaubt jedoch in der Ereignisprozedur für das Ereignis NotInList das Hinzufügen des Eintrags zum Listenfeld des Kombinationsfelds. Nach dem Hinzufügen des Eintrags aktualisiert Microsoft Access die Liste durch erneutes Abfragen des Kombinationsfelds. Microsoft Access vergleicht dann erneut die Zeichenfolge mit dem Listenfeld des Kombinationsfelds und speichert den Wert des Arguments NewData in dem Feld, an das das Kombinationsfeld gebunden ist. Befindet sich die Zeichenfolge nicht im Listenfeld, zeigt Microsoft Access eine Fehlermeldung an.

Anmerkung

Sie können für das Ereignis NotInList eine Ereignisprozedur erstellen, die dem Benutzer erlaubt, einen neuen Eintrag zum Listenfeld eines Kombinationsfelds hinzuzufügen. Beispielsweise können Sie einen Datensatz zu der Tabelle hinzufügen, die die Werte der Liste zur Verfügung stellt, oder einen Wert zu der Wertliste hinzufügen, auf der das Kombinationsfeld basiert.

Wenn Sie einen neuen Eintrag zu dem Listenfeld eines Kombinationsfelds hinzufügen möchten, muss Ihre Ereignisprozedur den Wert des Arguments NewData zu der Datenquelle des Kombinationsfelds hinzufügen. Wie Sie dies tun, ist abhängig vom Typ der Datenquelle des Kombinationsfelds. Diese wird in den Eigenschaften Rohdatenquellentyp und Rohdatenquelle für das Kombinationsfeld festgelegt. Im Beispiel zu diesem Thema fügt die Ereignisprozedur den neuen Wert zu der Wertliste eines Kombinationsfelds hinzu.

Wenn Sie zulassen möchten, dass der Benutzer den zu Beginn in das Kombinationsfeld eingegebenen Wert ändert (z. B. in einem benutzerdefinierten Dialogfeld), stellen Sie den Wert des Kombinationsfelds auf den neuen, in das benutzerdefinierte Dialogfeld eingegebenen Eintrag ein. Damit wird der neue Wert in dem Feld gespeichert, an das das Kombinationsfeld gebunden ist. Wenn Sie das Argument Response auf acDataErrContinue einstellen, fügt Microsoft Access den neuen Wert zu der Liste des Kombinationsfelds hinzu.


NotInList-Ereignisprozedur (NichtInListe) - Beispiel

Das nachstehende Beispiel verwendet das Ereignis NotInList, um einen Eintrag zu einem Kombinationsfeld hinzuzufügen.

Zum Testen dieses Beispiels erstellen Sie auf einem Formular ein Kombinationsfeld namens Farben. Stellen Sie die Eigenschaft LimitToList des Kombinationsfelds auf Ja ein. Zum Füllen des Kombinationsfelds stellen Sie die Eigenschaft RowSourceType auf Wertliste ein und geben als Einstellung für die Eigenschaft RowSource eine Liste aus Werten an, die jeweils durch ein Semikolon voneinander getrennt sind. Sie können z. B. folgende Werte für diese Eigenschaft bereitstellen: Rot; Grün; Blau.

Anschließend fügen Sie die nachstehende Ereignisprozedur zum Formular hinzu. Wechseln Sie zur Formularansicht, und geben Sie in das Textfeld des Kombinationsfelds einen neuen Wert ein.

Private Sub Farben_NotInList(NewData As String, _
        Response As Integer)
    Dim ctl As Control

    ' Zurückgeben des Control-Objekts, das auf das Kombinationsfeld zeigt.
    Set ctl = Me!Farben
    ' Den Benutzer fragen, ob ein neuer Wert hinzugefügt werden soll.
    If MsgBox("Wert fehlt. Hinzufügen?",          vbOKCancel) = vbOK Then
        ' Einstellen des Arguments Response, um anzugeben,
        ' dass die Daten hinzugefügt werden.
        Response = acDataErrAdded
        ' Hinzufügen der Zeichenfolge aus dem Argument NewData
        ' zur Datenquelle (Eigenschaft RowSource/Datensatzherkunft).
        ctl.RowSource = ctl.RowSource & ";" & NewData
    Else
    ' Der Benutzer hat "Abbrechen" gewählt,: die Fehlermeldung
    ' unterdrücken und die Änderungen rückgängig machen.
        Response = acDataErrContinue
        ctl.Undo
    End If
End Sub

Anmerkung Das hier gezeigte Beispiel fügt einen Eintrag zu einem ungebundenen Kombinationsfeld hinzu. Wenn Sie einen Eintrag zu einem gebundenen Kombinationsfeld hinzufügen, fügen Sie einen Wert zu einem Feld der zugrunde liegenden Datenherkunft hinzu. In den meisten Fällen können Sie nicht einfach ein Feld zu einem neuen Datensatz hinzufügen. Abhängig von der Struktur der Daten in der Tabelle müssen Sie jedoch in bestimmten Fällen ein oder mehrere Felder hinzufügen, um bestimmte Anforderungen an die Daten zu erfüllen. Ein neuer Datensatz muss z. B. immer Werte für alle Felder enthalten, die den Primärschlüssel bilden. Wenn Sie dynamisch Einträge zu einem gebundenen Kombinationsfeld hinzufügen möchten, gehen Sie wie folgt vor: Fordern Sie den Benutzer auf, Daten für alle erforderlichen Felder einzugeben, speichern Sie den neuen Datensatz, und fragen Sie dann das Kombinationsfeld erneut ab, um den neuen Wert anzuzeigen.


 NotInList-Ereignis (NichtInListe) - Makros

NotInList-Ereignis (NichtInListe) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses NotInList stellen Sie die Eigenschaft Bei Nicht in Liste auf den Namen des Makros ein.

Anmerkung

In einem Makro für das Ereignis NotInList können Sie zum Listenfeld des Kombinationsfelds einen neuen Wert hinzufügen. Dazu öffnen Sie bei Eintreten des Ereignisses NotInList ein benutzerdefiniertes Dialogfeld und stellen ein Steuerelement des Dialogfelds auf den neuen Wert ein. Dieses Steuerelement sollte an das Feld der Tabelle oder Abfrage gebunden sein, auf der das Kombinationsfeld basiert. Speichern Sie den Datensatz im benutzerdefinierten Kombinationsfeld, und führen Sie dann für das Kombinationsfeld erneut eine Abfrage aus.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis NotInList nicht eingesetzt werden.


 Open-, Close-Ereignisse (Öffnen, Schließen) - Ereignisprozeduren

Open-, Close-Ereignisse (Öffnen, Schließen) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Open oder Close ausgeführt wird, indem Sie die Eigenschaft Beim Öffnen bzw. Beim Schließen auf [Ereignisprozedur] einstellen und auf die Aufbauen-Schaltfläche [image] klicken.

Syntax

Private Sub Form_Open(Cancel As Integer)

Private Sub Report_Open(Cancel As Integer)

Private Sub Form_Close( )

Private Sub Report_Close( )

Die Ereignisprozedur Open hat das folgende Argument.

Argument | Beschreibung
Cancel | Die Einstellung bestimmt, ob das Öffnen eines Formulars oder Berichts eintritt. Das Einstellen von Cancel auf True (-1) unterbindet das Öffnen eines Formulars oder Berichts.

Anmerkung

Sie können das Ereignis Close nicht unterbinden.

Wenn Sie in einer Ereignisprozedur für das Ereignis Open auf Steuerelemente verweisen möchten, setzen Sie zunächst den Fokus mit der Methode SetFocus, der Methode GoToRecord oder der Methode GoToControl des Objekts DoCmd auf das entsprechende Steuerelement oder den entsprechenden Datensatz.

Wenn in einer Anwendung jeweils nur ein Formular geladen werden kann, können Sie in die Ereignisprozedur für das Ereignis Open eines Formulars Code zum Ein- oder Ausblenden einer Symbolleiste einfügen. Das folgende Beispiel zeigt beim Öffnen des Formulars die Symbolleiste Symbolleiste1 an:

Sub Form_Open(Cancel As Integer)
    DoCmd.ShowToolbar "Symbolleiste1", acToolbarYes
End Sub


Open-, Close-Ereignisprozeduren (Öffnen, Schließen) - Beispiel

Dieses Beispiel zeigt, wie Sie das Öffnen eines Formulars unterbinden können, wenn der Benutzer auf die Schaltfläche Nein klickt. Ein Meldungsfeld mit der Aufforderung, Bestelldetails anzugeben, wird angezeigt. Klickt der Benutzer auf Nein, wird das Formular Bestelldetails nicht geöffnet.

Sie können dieses Beispiel testen, indem Sie die folgende Ereignisprozedur zu einem Formular hinzufügen:

Private Sub Form_Open (Cancel As Integer)
    Dim intRückgabewert As Integer
    intRückgabewert = MsgBox("Bestelldaten eingeben?", vbYesNo)
    Select Case intRückgabewert
        Case vbYes
            ' Formular "Bestelldetails" öffnen.
            DoCmd.OpenForm "Bestelldetails"
        Case vbNo
            MsgBox "Bestelldetails müssen bis 17.00 Uhr eingegeben sein."
            Cancel = True                ' Ereignis Open unterbinden.
    End Select
End Sub


 Open-, Close-Ereignisse (Öffnen, Schließen) - Makros

Open-, Close-Ereignisse (Öffnen, Schließen) - Makros

Sie können beim Eintreten des Ereignisses Open oder Close ein Makro ausführen, indem Sie die Eigenschaft Beim Öffnen oder Beim Schließen auf den Namen des Makros einstellen.

Anmerkung

Sie können in einem Makro für das Ereignis Open mit der Aktion AbbrechenEreignis das Öffnen eines Formulars oder Berichts unterbinden. Die Aktion AbbrechenEreignis kann nicht in einem Makro für das Ereignis Close verwendet werden, jedoch in einem Makro, das beim Eintreten des Ereignisses Unload ausgeführt wird. Dadurch wird das Schließen des Formulars unterbunden.

Wenn ein Makro für das Ereignis Open auf Steuerelemente verweisen soll, setzen Sie zunächst den Fokus auf das entsprechende Steuerelement oder den Datensatz. Soll z. B. mit der Aktion SetzenWert in einem Makro für das Ereignis Open der Wert eines Steuerelements eines Formulars festgelegt werden, greifen Sie zunächst mit der Aktion GeheZuSteuerelement bzw. GeheZuDatensatz auf das Steuerelement oder den Datensatz zu, in dem das Steuerelement enthalten ist.


 Page-Ereignis (Seite) - Ereignisprozeduren

Page-Ereignis (Seite) - Ereignisprozeduren

Wenn Sie eine Ereignisprozedur erstellen möchten, die ausgeführt wird, sobald das Ereignis Page eingetreten ist, stellen Sie die Eigenschaft Bei Seite auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Report_Page( )

Anmerkung

Sie können das Ereignis Page nicht abbrechen.


Page-Ereignis (Seite) - Ereignisprozedur - Beispiel

Das folgende Beispiel zeigt, wie Sie mit der Methode Line einen Rahmen um eine Berichtsseite ziehen können. Die Eigenschaften ScaleWidth und ScaleHeight geben standardmäßig die interne Breite und Höhe des Berichts zurück.

Private Sub Report_Page()
    Me.Line(0, 0)-(Me.ScaleWidth, Me.ScaleHeight), , B
End Sub


 Page-Ereignis (Seite) - Makros

Page-Ereignis (Seite) - Makros

Soll ein Makro ausgeführt werden, wenn das Ereignis Page eintritt, stellen Sie die Eigenschaft Bei Seite auf den Namen des Makros ein.

Anmerkung

Auf das Ereignis Page reagieren Sie meist nicht mit einem Page-Makro, sondern mit einer Page-Ereignisprozedur. Dies liegt daran, dass Sie normalerweise die Methoden Line, Circle und PSet in der Page-Ereignisprozedur verwenden, um für die Seite die gewünschten Grafikelemente zu erstellen.

Die Aktion AbbrechenEreignis können Sie in einem Page-Makro nicht verwenden.


 Print-Ereignis (Drucken) - Ereignisprozeduren

Print-Ereignis (Drucken) - Ereignisprozeduren

Sie können eine Ereignisprozedur erstellen, die beim Eintreten des Ereignisses Print ausgeführt wird. Dazu stellen Sie die Eigenschaft Beim Drucken auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Bereichsname_Print(Cancel As Integer, PrintCount As Integer)

Die Ereignisprozedur für das Ereignis Print hat folgende Argumente:

Argument | Beschreibung
Bereichsname | Der Name des Bereichs im Bericht, dessen Print-Ereignisprozedur ausgeführt werden soll.
Cancel | Die Einstellung bestimmt, ob das Drucken des Bereichs eintritt. Das Setzen des Arguments Cancel auf True (-1) unterbindet das Drucken des Bereichs
PrintCount | Ein Wert vom Typ Integer, der angibt, ob das Ereignis Print mehrmals für einen Datensatz eingetreten ist. Wenn z. B. ein Teil eines Datensatzes auf einer Seite gedruckt wird und der Rest auf der nächsten Seite, tritt das Ereignis Print zweimal ein, und Microsoft Access stellt das Argument PrintCount auf den Wert 2 ein.

Anmerkung

Sie können das Drucken eines Bereichs unterbinden, indem Sie das Argument Cancel auf True (-1) einstellen oder die Methode CancelEvent des Objekts DoCmd verwenden. Microsoft Access druckt eine leere Fläche an der Stelle auf der Seite, an der der Bereich erschienen wäre. Mit der Methode CancelEvent oder dem Argument Cancel können Sie einen Datensatz in einem Bericht überspringen, so dass beim Drucken des Berichts eine leere Fläche auf der Seite erscheint.

Anmerkung Sie können mit einer Ereignisprozedur für das Ereignis Print keine Eigenschaften für Objekte einstellen.


Print-Ereignisprozeduren (Drucken) - Beispiel

Dieses Beispiel überprüft das Argument PrintCount und ermittelt, wie oft das Ereignis Print eingetreten ist. Wenn es mehrmals eingetreten ist, wird das Ereignis Print für den Bereich unterbunden.

Sie können das Beispiel testen, indem Sie die folgende Ereignisprozedur zu einem Bericht hinzufügen. Der Bericht muss einen Bereich namens Kundendetails enthalten.

Private Sub Kundendetails_Print(Cancel As Integer, _
        PrintCount As Integer)
    If PrintCount > 1 Then Cancel = True
End Sub


 Print-Ereignis (Drucken) - Makros

Print-Ereignis (Drucken) - Makros

Sie können beim Eintreten des Ereignisses Print ein Makro ausführen, indem Sie die Eigenschaft Beim Drucken auf den Namen des Makros einstellen.

Anmerkung

Sie können mit der Eigenschaft Druckanzahl überprüfen, ob das Ereignis Print für einen Datensatz mehrmals eingetreten ist. Wenn z. B. ein Teil eines Datensatzes auf einer Seite und der Rest auf der nächsten Seite gedruckt wird, tritt das Ereignis Print zweimal ein, und die Eigenschaft Druckanzahl ist auf den Wert 2 eingestellt. Sie können die Einstellung der Eigenschaft Druckanzahl überprüfen, wenn Makros für das Ereignis Print nur einmal für einen Datensatz ausgeführt werden sollen (z. B. Makros, die die Summen für die Datensätze einer Seite in dem Seitenfuß anzeigen).

Sie können in einem Makro für das Ereignis Print mit der Aktion AbbrechenEreignis das Drucken eines Bereichs unterbinden. Microsoft Access druckt dann eine leere Fläche an der Stelle auf der Seite, an der beim Drucken des Berichts der entsprechende Bereich erschienen wäre. Mit der Aktion AbbrechenEreignis können Sie einen Bereich eines Berichts überspringen, so dass beim Drucken des Berichts eine leere Fläche auf der Seite erscheint.

Ein Makro für das Ereignis Print wird nur für Bereiche ausgeführt, die tatsächlich gedruckt werden.

Anmerkung Sie können mit einem Makro für das Ereignis Print keine Eigenschaften für Objekte einstellen.


 Resize-Ereignis (Größenänderung) - Ereignisprozeduren

Resize-Ereignis (Größenänderung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Resize eintritt, stellen Sie die Eigenschaft Bei Größenänderung auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_Resize( )

Anmerkung

Wenn Sie den Bildschirm bei jedem Ändern der Größe eines Formulars aktualisieren möchten, verwenden Sie die Methode Repaint in einer Ereignisprozedur für das Ereignis Resize.

Das Ereignis Resize kann nicht unterbunden werden.


Resize-Ereignis (Größenänderung) - Ereignisprozeduren-Beispiel

Das nachstehende Beispiel zeigt, wie mit einer Ereignisprozedur für das Ereignis Resize ein Formular nach dem Vergrößern auf Vollbildgröße aktualisiert wird. Wenn der Benutzer auf eine Befehlsschaltfläche mit der Bezeichnung Maximieren klickt, wird das Formular in Vollbildgröße angezeigt und das Ereignis Resize ausgelöst.

Zum Testen dieses Beispiels fügen Sie die nachstehenden Ereignisprozeduren zu einem Formular namens Kontakte hinzu, das eine Befehlsschaltfläche namens Maximieren enthält.

Private Sub Maximieren_Click()
    DoCmd.Maximize
End Sub

Private Sub Form_Resize()
    Formulare!Kontakte.Repaint
End Sub


 Resize-Ereignis (Größenänderung) - Makros

Resize-Ereignis (Größenänderung) - Makros

Wenn beim Eintreten des Ereignisses Resize ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Bei Größenänderung auf den Namen des Makros ein.

Anmerkung

Wenn Sie den Bildschirm bei jedem Ändern der Größe eines Formulars aktualisieren möchten, verwenden Sie die Aktion AktualisierenObjekt in dem Makro für das Ereignis Resize.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Resize nicht eingesetzt werden.


 Retreat-Ereignis (Rücknahme) - Ereignisprozeduren

Retreat-Ereignis (Rücknahme) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Retreat eintritt, stellen Sie die Eigenschaft OnRetreat auf [Ereignisprozedur] ein und klicken auf die Generator-Schaltfläche [image] .

Syntax

Private Sub Bereichsname_Retreat( )

Das Ereignis Retreat hat das folgende Argument.

Argument | Beschreibung
Bereichsname | Der Name des Bereichs des Berichts, dessen Retreat-Ereignisprozedur ausgeführt werden soll.

Anmerkung

Das Ereignis Retreat kann nicht unterbunden werden.


 Retreat-Ereignis (Rücknahme) - Makros

Retreat-Ereignis (Rücknahme) - Makros

Wenn beim Eintreten des Ereignisses Retreat ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft OnRetreat auf den Namen des Makros ein.

Anmerkung

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Retreat nicht eingesetzt werden.


 Terminate-Ereignis (Beenden) - Ereignisprozedur

Terminate-Ereignis (Beenden) - Ereignisprozedur

Um die Ereignisprozedur für das Ereignis Terminate zu erstellen, öffnen Sie das Klassenmodul und klicken Sie im Feld Objekt auf Class. Klicken Sie anschließend im Feld Prozedur auf Terminate.

Syntax

Private Sub Class_Terminate( )

Anmerkung

Um einen Verweis auf eine Instanz einer Klasse aus dem Speicher zu entfernen, können Sie die Variable, der der Verweis zugewiesen ist, auf Nothing einstellen. Angenommen, Sie haben z.B. eine Instanz der Klasse KundeObjekt erstellt und der Objektvariablen obj zugewiesen. Wenn Sie obj auf Nothing einstellen, wird der Verweis gelöscht. Sobald alle Verweise auf die Instanz der Klasse aus dem Speicher entfernt worden sind, tritt das Ereignis Terminate ein.

Ein Verweis auf eine Instanz einer Klasse wird auch dann aus dem Speicher entfernt, wenn die Objektvariable, der sie zugeordnet ist, nicht mehr im Gültigkeitsbereich liegt. Dies ist z.B. dann der Fall, wenn die Variable in einer Prozedur definiert wurde und die Prozedur die Ausführung beendet hat. Wenn die Variable auf Modulebene in einem Standardmodul definiert wurde, liegt sie nicht mehr im Gültigkeitsbereich, wenn der Code zurückgesetzt wird. Werden alle Verweise auf eine Instanz einer Klasse auf diese Weise entfernt, tritt das Ereignis Terminate ebenfalls ein.

Das Ereignis Terminate wird nicht ausgelöst, wenn Instanzen einer Klasse aus dem Speicher entfernt wurden, weil Microsoft Access fehlerhaft beendet wurde. Wenn Ihr Code z.B. die Methode Quit des Microsoft Access-Objekts Application aufruft, bevor alle bestehenden Instanzen der Klasse aus dem Speicher entfernt wurden, wird das Ereignis Terminate für diese Klasse nicht ausgelöst.


 Timer-Ereignis (Zeitgeber) - Ereignisprozeduren

Timer-Ereignis (Zeitgeber) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Timer eintritt, stellen Sie die Eigenschaft Bei Zeitgeber auf [Ereignisprozedur] ein und klicken auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Form_Timer( )

Anmerkung

Das Ereignis Timer kann nicht unterbunden werden.


Timer-Ereignis (Zeitgeber-) Ereignisprozeduren-Beispiel

Das nachstehende Beispiel zeigt eine Digitaluhr, die Sie auf einem Formular anzeigen können. Die aktuelle Uhrzeit auf der Basis der Systemuhr Ihres Computers wird in einem Bezeichnungsfeld-Steuerelement angezeigt.

Zum Testen dieses Beispiels fügen Sie die nachstehende Ereignisprozedur zu einem Formular hinzu, das ein Bezeichnungsfeld namens Uhr enthält. Stellen Sie die Eigenschaft TimerInterval des Formulars auf 1000 Millisekunden ein, um die Uhr jede Sekunde zu aktualisieren.

Private Sub Form_Timer()
    Uhr.Caption = Time        ' Aktualisieren der Zeitanzeige.
End Sub


 Timer-Ereignis (Zeitgeber) - Makros

Timer-Ereignis (Zeitgeber) - Makros

Wenn beim Eintreten des Ereignisses Timer ein Makro ausgeführt werden soll, stellen Sie die Eigenschaft Bei Zeitgeber auf den Namen des Makros ein.

Anmerkung

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Timer nicht eingesetzt werden. Wenn Sie jedoch für die Eigenschaft Zeitgeberintervall des Formulars die Einstellung 0 festlegen, tritt das Ereignis Timer nicht ein.


 Updated-Ereignis (OLEAktualisierung) - Ereignisprozeduren

Updated-Ereignis (OLEAktualisierung) - Ereignisprozeduren

Zum Erstellen einer Ereignisprozedur, die ausgeführt wird, wenn das Ereignis Updated eintritt, stellen Sie die Eigenschaft Bei Aktualisierung auf [Ereignisprozedur] ein und klicken dann auf die Aufbauen-Schaltfläche [image] .

Syntax

Private Sub Steuerelementname_Updated(Code As Integer)

Ereignisprozeduren für das Ereignis Updated haben die folgenden Argumente.

Argument | Beschreibung
Steuerelementname | Der Name des Steuerelements, dessen Updated-Ereignisprozedur ausgeführt werden soll.
Code | Diese Einstellung gibt an, wie das OLE-Objekt aktualisiert wurde. Das Argument Code kann die folgenden eingebauten Konstanten annehmen:
 | Konstante | Beschreibung
 | acOLEChanged | Gibt an, dass sich die Daten des Objekts geändert haben.
 | AcOLESaved | Gibt an, dass die Daten des Objekts von der Anwendung gespeichert wurden, mit der das Objekt erstellt wurde. Dies ist in der Regel dann der Fall, wenn der Benutzer auf den Befehl Aktualisieren der Anwendung oder einen anderen in dieser Anwendung zum Aktualisieren verfügbaren Befehl geklickt hat.
 | AcOLEClosed | Gibt an, dass die Datei, die die Daten des Objekts enthält, in der Anwendung, von der das Objekt erstellt wurde, geschlossen wurde.
 | AcOLERenamed | Gibt an, dass die Datei, die die Daten des Objekts enthält, in der Anwendung, von der das Objekt erstellt wurde, umbenannt wurde.

Anmerkung

Um zu überprüfen, ob die Daten des Objekts seit dessen letzter Speicherung geändert wurden, stellen Sie in der Ereignisprozedur für das Ereignis Updated eine öffentliche Variable ein, die angibt, ob das Objekt gespeichert werden muss. Wenn Sie das OLE-Objekt speichern, setzen Sie die Variable zurück.

Das Ereignis Updated kann nicht unterbunden werden.


 Updated-Ereignis (OLEAktualisierung) - Makros

Updated-Ereignis (OLEAktualisierung) - Makros

Zum Ausführen eines Makros bei Eintreten des Ereignisses Updated stellen Sie die Eigenschaft Bei Aktualisierung auf den Namen des Makros ein.

Anmerkung

In einem Makro für das Ereignis Updated können Sie eine Meldung erstellen, die immer dann angezeigt wird, wenn die Daten in einem OLE-Objekt aktualisiert wurden. Da Makros jedoch nicht den Code zurückgeben, anhand dessen ermittelt werden kann, wie das OLE-Objekt aktualisiert wurde, werden für dieses Ereignis in der Regel eher Ereignisprozeduren verwendet.

Die Aktion AbbrechenEreignis kann in einem Makro für das Ereignis Updated nicht eingesetzt werden.


Microsoft Office-Assistent - Beispiel

Die folgende Funktion erstellt eine benutzerdefinierte Sprechblase für einen Office-Assistenten und bestimmt, wie der Benutzer auf die Sprechblase reagiert hat:

Function AssistantBalloon(Optional varCheck As Variant, Optional varLabel As Variant)
    Dim bch As BalloonCheckbox
    Dim intI As Integer
    Dim intRückgabe As Integer
    Dim strPrüfen(5) As String
    Dim strListe As String

    ' Neue Sprechblase erstellen.
    Set bal = Assistant.NewBalloon
    ' Sprechblasentyp festlegen.
    bal.BalloonType = msoBalloonTypeButtons
    ' Festlegen, dass die Sprechblase gebunden ist.
    bal.Mode = msoModeModal

    ' Assistent anzeigen.
    If Assistant.Visible = False Then Assistant.Visible = True
    ' Prüfen, ob erstes Argument übergeben wurde.
    If Not IsMissing(varCheck) Then
        ' Wenn zu groß, auf maximale Kontrollkästchenanzahl (5)
        ' einstellen.
        If varCheck > 6 Then
            varCheck = 5
        End If
        ' Texteigenschaft auf Buchstaben einstellen.
        For intI = 1 To varCheck
            bal.Checkboxes(intI).Text = Chr(64 + intI)
        Next intI
    End If

    If Not IsMissing(varLabel) Then
        ' Wenn zu groß, auf maximale Bezeichnungsfelderanzahl (5)
        ' einstellen.
        If varLabel > 6 Then
            varLabel = 5
        End If
        For intI = 1 To varLabel
            ' Texteigenschaft auf Buchstaben einstellen.
            bal.Labels(intI).Text = Chr(64 + intI)
        Next intI
    End If
    ' Rückgabewert speichern.
    intRückgabe = bal.Show

    intI = 0
    ' Bestimmen, ob und wenn ja welche Kontrollkästchen aktiviert
    ' wurden.
    For Each bch In bal.Checkboxes
        If bch.Checked = True Then
            strPrüfen(intI) = bch.Text
            strListe = strListe & "'" & strPrüfen(intI) & "'" & Chr(32)
        End If
        intI = intI + 1
    Next
    If Len(strListe) <> 0 Then
        MsgBox "Sie haben folgende Kontrollkästchen aktiviert " & _
        strListe & "."
    End If
    ' Bestimmen, ob und wenn ja welches Bezeichnungsfeld markiert
    ' wurde.
    If intRückgabe > 0 Then
        MsgBox "Sie haben das folgende Bezeichnungsfeld markiert " & _
        bal.Labels(intRückgabe).Text & "."
    End If
End Function

Sie können diese Funktion im Testfenster folgendermaßen ausführen:

? AssistantBalloon(4, 5)


Kopieren einer Befehlsleiste - Beispiel

Das nachstehende Beispiel kopiert eine Befehlsleiste und die entsprechenden Steuerelemente in eine neue Befehlsleiste. Sie geben in die NeuenNamenEingeben-Prozedur den Namen für die zu kopierende und den Namen für die neue Befehlsleiste ein. Diese Prozedur ruft die allgemeine CopyCommandBar-Funktion auf, die zum Erstellen der neuen Befehlsleiste die von Ihnen eingegebenen Namen verwendet.

Sub NeuenNamenEingeben()
    CopyCommandBar "Menüleiste", "Neue Menüleiste"
End Sub

Function CopyCommandBar(strOrigCBName As String, _
        strNewCBName As String) As Boolean
    ' Diese Prozedur kopiert die in der Variablen
    ' strOrigCBName genannte Befehlsleiste in die neue in der
    ' Variablen strNewCBName genannte Befehlsleiste.
    Dim cbrOriginal As CommandBar, intOrigCount As Integer
    Dim cbrCopy As CommandBar, cbrCtl As CommandBarControl

    On Error GoTo CBCopy_Err

    Set cbrOriginal = CommandBars(strOrigCBName)
    intOrigCount = cbrOriginal.Controls.Count
    Set cbrCopy = CommandBars.Add(strNewCBName)
    ' Sicherstellen, dass die neue Befehlsleiste angezeigt wird.
    cbrCopy.Visible = True

    For Each cbrCtl In cbrOriginal.Controls
        cbrCtl.Copy cbrCopy
    Next cbrCtl
Exit Function

CBCopy_Err:
    MsgBox Err.Description
    Exit Function
End Function


Erstellen einer benutzerdefinierten Befehlsschaltfläche - Beispiel

Das folgende Beispiel erstellt eine benutzerdefinierte Befehlsschaltfläche in einer Befehlsleiste, die Sie angeben. Sie geben den Namen der Befehlsleiste, zu der Sie die neue Schaltfläche hinzufügen möchten, und den Namen für die neue Schaltfläche in die Prozedur BefehlsleisteUndSchaltflächeFestlegen ein. Diese Prozedur ruft die allgemeine Funktion CreateCustomButton auf, die die von Ihnen eingegebenen Namen verwendet, um die benutzerdefinierte Befehlsschaltfläche zur Befehlsleiste hinzuzufügen.

Sub BefehlsleisteUndSchaltflächeFestlegen()
    CreateCustomButton "Menüleiste", "Benutzerdefinierte Schaltfläche 1"
End Sub

Function CreateCustomButton(strBarName As String, _
        strName As String) As Integer
    Dim cmdBar As CommandBar, cmdBarCustomButton As _
        CommandBarButton

    Set cmdBar = CommandBars(strBarName)
    ' Anzeigen der Befehlsleiste, sofern diese nicht bereits angezeigt wird.
    If cmdBar.Visible = False Then cmdBar.Visible = True

    On Error Resume Next

    Set cmdBarCustomButton = cmdBar.Controls(strName)
    If Err <> 0 Then
        ' Benutzerdefinierte Schaltfläche existiert noch nicht; wird erstellt.
        Set cmdBarCustomButton = cmdBar.Controls _
            .Add(msoControlButton, , , , True)
    End If
    With cmdBarCustomButton
        .Caption = strName
        .BeginGroup = True
        .OnAction = "=msgbox(""Hallo alle"")"
        ' Makro oder benutzerdefinierte Funktion hier ausführen.
        .Style = msoButtonCaption
    End With
End Function


HTML-Vorlagendatei (Beispiel)

<HTML>

<!--Das nachfolgende Token legt den Objektnamen in der Titelleiste des Webbrowsers ab.-->

<TITLE><!--AccessTemplate_Title--></TITLE>

<!--Die nachfolgende HTML-Marke ändert die Standardhintergrundfarbe des Webbrowsers in eine andere Farbe.-->

<BODY BACKGROUND = "gray.jpg">

<!--Das nachfolgende Token legt die gesamte Objektausgabe in der Marke <BODY> ab.-->

<!--AccessTemplate_Body-->

</BODY>

<BR><BR>

<!--Die nachfolgenden vier Tokens erstellen vier Navigationsschaltflächen, die das Springen zur ersten, zur vorherigen, zur nächsten und zur letzten Seite eines Berichts erlauben.-->

<A HREF = "<!--AccessTemplate_FirstPage-->">First</A>

<A HREF = "<!--AccessTemplate_PreviousPage-->">Previous</A>

<A HREF = "<!--AccessTemplate_NextPage-->">Next</A>

<A HREF = "<!--AccessTemplate_LastPage-->">Last</A>

<!--Das nachfolgende Token fügt den Text "Seite n" ein, wobei n die aktuelle Seitenzahl ist.-->

<P ALIGN = CENTER>Seite <!--AccessTemplate_PageNumber-->.</P>

<!--Die nachfolgende HTML-Marke fügt am unteren Rand der Webseite ein Firmenlogo ein.-->

<IMG SRC = "company_logo.jpg">

</HTML>


AccessError-Methode - Beispiel

Die folgende Funktion gibt eine Fehlerzeichenfolge für eine beliebige gültige Fehlernummer zurück:

Function Fehlerzeichenfolge(lngFehler As Long) As String
    Const conAnwFehler = "Anwendungs- oder "
        & "objektdefinierter Fehler"

    On Error Resume Next
    Err.Raise lngFehler
    If Err.Description = conAnwFehler Then
        Fehlerzeichenfolge = AccessError(lngFehler)
    ElseIf Err.Description = "" Then
        MsgBox "Dieser Nummer ist keine " & _
        "Fehlerzeichenfolge zugeordnet."
    Else
        Fehlerzeichenfolge = Err.Description
    End If
End Function


 Choose-Funktion (Wahl)

Choose-Funktion (Wahl)

Sie können die Choose-Funktion auch in einem berechneten Steuerelement in einem Microsoft Access-Formular oder -Bericht verwenden. Sie können mit der Choose-Funktion z. B. den Wert für ein Steuerelement auf der Basis des Wertes eines anderen Feldes festlegen. Dazu legen Sie für die Steuerelementinhalt-Eigenschaft des Steuerelements einen Ausdruck fest, der die Choose-Funktion enthält. Mit dem Ausdruck im folgenden Beispiel können Sie die Steuerelementinhalt-Eigenschaft eines Steuerelements einstellen, das auf dem Wert im Feld VersandÜber aus einer Tabelle Bestellungen basiert.

=Choose([VersandÜber], "Speedy", "United", "Federal")

    Wenn das Feld VersandÜber im vorstehenden Beispiel den Wert 1 enthält, gibt die Choose-Funktion die erste Zeichenfolge, "Speedy", zurück. Wenn es den Wert 2 enthält, gibt die Funktion die zweite Zeichenfolge, "United", zurück usw. Wenn VersandÜber den Wert 0 enthält, gibt die Choose-Funktion eine Null zurück.

    Das nächste Beispiel zeigt, wie Sie sicherstellen können, dass eine Zeichenfolge zurückgegeben wird, auch wenn das Feld den Wert 0 enthält.

    =Choose([VersandÜber] + 1, "Keiner", "Speedy", "United", "Federal")

      Anmerkung In einem Visual Basic-Modul können Sie zum Zurückgeben eines Wertes aus einer Reihe von Auswahlmöglichkeiten die noch leistungsstärkere Select Case-Anweisung verwenden.


Choose-Funktion (Wahl) - Beispiel

Sie können die Funktion Choose für ein berechnetes Steuerelement verwenden, dessen Wert durch den Wert bestimmt wird, den ein bestimmtes Feld einer Tabelle Ihrer Datenbank hat. Nehmen Sie z. B. an, eine Tabelle namens Versandfirmen enthält ein Feld namens Firmen-Nr. Sie könnten dann auf einem Formular ein berechnetes Steuerelement erstellen, in dem ausgehend vom Wert des Feldes Firmen-Nr der Name der jeweiligen Versandfirma angezeigt wird.

=Choose([Firmen-Nr]; "Speedy"; "United"; "Federal")


 Command-Funktion (Befehl)

Command-Funktion (Befehl)

Zum Ändern eines Befehlszeilenarguments nach dem Öffnen einer Datenbank klicken Sie im Menü Extras auf Optionen. Geben Sie im Dialogfeld Optionen in der Registerkarte Weitere im Feld Befehlszeilenargumente ein neues Argument ein. Die Funktion Command gibt jetzt das neue Argument zurück, das Sie eingegeben haben.

Wird die Funktion Command in einem anderen Kontext als in einem Modul in Visual Basic-Code verwendet, müssen Sie hinter dem Funktionsnamen leere runde Klammern angeben. Wenn Sie die Funktion Command z. B. in einem Textfeld in einem Formular verwenden, müssen Sie für die Eigenschaft ControlSource des Textfelds einen Ausdruck festlegen, der wie folgt aussieht:

=Command()


Command-Funktion (Befehl) - Beispiel

Das folgende Beispiel zeigt, wie Microsoft Access mit einem Befehlszeilenargument aufgerufen und der Wert dieses Arguments mit Hilfe der Funktion Command zurückgegeben wird.

Zum Testen dieses Beispiels klicken Sie in Windows auf die Schaltfläche Start und dann auf Ausführen. Geben Sie im Dialogfeld Ausführen Folgendes vollständig als eine Zeile ein. (Sie müssen die einzelnen Teile der Befehlszeile in Anführungszeichen setzen).

"C:\Programme\Microsoft Office\Office\Msaccess.exe" "C:\Programme\Microsoft Office\Office\Beispiele\Nordwind.mdb" _/cmd "Bestellungen"

Als nächstes öffnen Sie ein neues Modul in der Beispieldatenbank Nordwind und fügen die folgende Funktion hinzu.

Function BefehlszeilePrüfen()
    ' Wert prüfen, der von der Funktion Command
    ' zurückgegeben wird.
    If Command = "Bestellungen" Then
        DoCmd.OpenForm "Bestellungen"
    ElseIf Command = "Personal" Then
        DoCmd.OpenForm "Personal"
    Else
        Exit Function
    End If
End Function

Wenn Sie diese Funktion aufrufen, öffnet Microsoft Access das Formular Bestellungen.

Sie können ein Makro namens AutoExec erstellen, um diese Funktion automatisch aufzurufen, wenn die Datenbank geöffnet wird. Weitere Informationen zum Ausführen einer Aktion beim Öffnen einer Datenbank finden Sie unter Ausführen einer Aktion beim ersten Öffnen einer Datenbank.


DateAdd-Funktion (DatAdd) - Beispiel

Das folgende Beispiel zeigt Ihnen, wie Sie ein berechnetes Steuerelement mit Hilfe der Funktion DateAdd erstellen können, um das Versanddatum einer bestimmten Bestellung anzuzeigen (in diesem Fall dreißig Tage nach dem Bestelldatum). Nehmen Sie an, ein auf einer Tabelle namens Bestellungen basierendes Formular enthält ein Feld namens Bestelldatum. Sie können ein weiteres Textfeld auf dem Formular erstellen, um das Versanddatum anzuzeigen, indem Sie die Eigenschaft ControlSource dieses Textfelds wie im folgenden Beispiel einstellen.

= DatAdd("t"; 30;[Bestelldatum])


DateDiff-Funktion (DatDiff) - Beispiel

In den folgenden Beispielen wird mit Hilfe der Funktion DateDiff die Anzahl an Kalenderwochen zwischen der ersten Woche des Jahres und heute bzw. die Anzahl an Tagen seit dem 1. Februar 1996 berechnet.

Debug.Print DateDiff("ww", "1-1", Now())
Debug.Print DateDiff("y", #1-Feb-1996#, Now())

Das nächste Beispiel zeigt die Verwendung der Funktion DateDiff in einem Abfrageausdruck. Nehmen Sie an, eine Tabelle namens Bestellungen enthält die beiden Felder Bestelldatum und Versanddatum. Sie können ein berechnetes Feld in einer Abfrage erstellen, um die verstrichene Zeit zwischen dem Bestelldatum und dem Versanddatum für jede Bestellung anzuzeigen. Erstellen Sie im Abfragefenster eine neue Abfrage, indem Sie die Tabelle Bestellungen hinzufügen und das Feld Bestell-Nr auf den Abfrageentwurfsbereich ziehen. Geben Sie folgende Zeile in eine leere Zelle der Zeile Feld an, um ein berechnetes Feld zu erstellen.

TageVerstrichen: DatDiff("y"; [Bestelldatum]; [Versanddatum])


DatePart-Funktion (DatTeil) - Beispiel

Im folgenden Beispiel wird die Funktion DatePart verwendet, um Kriterien für eine Auswahlabfrage anzugeben. Nehmen Sie z. B. an, Sie möchten eine Abfrage erstellen, die auf einer Tabelle namens Bestellungen basiert und alle Bestellungen auflistet, die im 1. Quartal 1996 aufgegeben wurden. Wenn Ihre Tabelle Bestellungen die Felder Bestell-Nr und Bestelldatum enthält, können Sie das Feld Bestell-Nr auf die erste Zelle des Abfrageentwurfsbereichs ziehen und folgende Zeile in die Zelle Kriterien darunter eingeben.

(DatTeil("q"; [Bestelldatum]) = 1) Und (DatTeil("yyyy"; [Bestelldatum]) = 1996)


 Date-Funktion (Datum)

Date-Funktion (Datum)

Sie können das aktuelle Datum in ein Formular oder einen Bericht einfügen, indem Sie im Menü Einfügen auf Datum und Zeit klicken. Dieser Befehl erstellt ein Textfeld auf einem Formular oder Bericht und stellt die Eigenschaft ControlSource des Textfelds auf einen Ausdruck ein, der die Funktion Date enthält. Wie der Ausdruck konkret aussieht, hängt davon ab, welches Format Sie für die Anzeige des Datums gewählt haben. Dieser Befehl ist nur in der Formularentwurfsansicht und der Berichtsentwurfsansicht verfügbar.

Sie können die Funktion Date auch in einem Abfrageausdruck oder in einem Makro verwenden. Allerdings müssen Sie bei jeder Verwendung außerhalb eines Visual Basic-Moduls die Klammern hinter der Funktion hinzufügen, wie im Ausdruck Datum().


DateSerial-, Day-, Month- und Year-Funktion (DatSeriell, Tag, Monat und Jahr) - Beispiel

Im folgenden Beispiel wird die Funktion DateSerial zusammen mit den Funktionen Year, Month und Day verwendet, um die Anzahl der Tage eines Monats zurückzugeben. Sie können entweder ein Datum oder eine Zeichenfolge an die Funktion TageImMonat übergeben.

Function TageImMonat(dteDatum As Date) As Integer
    Dim intDays As Integer

    ' Einen Monat hinzufügen; Tagesdatum voneinander subtrahieren, um die Differenz zu ermitteln.
    intTage = DateSerial(Year(dteDatum), _
        Month(dteDatum) + 1, Day(dteDatum)) _
        DateSerial(Year(dteDatum), _
        Month(dteDatum), Day(dteDatum))
    TageImMonat = intTage
    Debug.Print intTage
End Function

In der folgenden Sub-Prozedur sind verschiedene Möglichkeiten angegeben, wie die Funktion TageImMonat aufgerufen werden kann.

Sub TageImMonatAufrufen()
    Dim intTage As Integer
    intTage = TageImMonat(#4/1/96#)
    intTage = TageImMonat("1.4.96")
    intTage = TageImMonat("1. April 1996")
End Sub


Date-Funktion (Datum) - Beispiel

Sie können die Funktion Date für ein berechnetes Steuerelement verwenden, indem Sie die Eigenschaft ControlSource des Steuerelements so einstellen wie im folgenden Beispiel.

= Date()

Sie können die Funktion Date auch verwenden, um die Kriterien einer Abfrage festzulegen. Verfügen Sie z. B. über eine Tabelle namens Bestellungen, die das Feld Bestelldatum enthält, können Sie für die Tabelle Bestellungen eine Abfrage erstellen, die alle Datensätze zurückgibt, deren Bestelldatum zwischen dem 1.4.95 und dem Datum von heute liegt. Geben Sie dazu Folgendes in die Zelle Kriterien ein, die sich unter dem Feld Bestelldatum befindet.

Zwischen #01.04.95# Und Datum()


DAvg-Funktion (DomMittelwert) - Beispiel

Dieses Beispiel gibt die durchschnittlichen Frachtkosten von Bestellungen zurück, die nach dem 1. Januar 1996 nach Großbritannien versandt wurden. Das Argument Domäne gibt die Tabelle Bestellungen an. Das Argument Kriterien begrenzt die sich ergebende Datensatzgruppe auf Datensätze, bei denen Bestimmungsland gleich Großbritannien und Versanddatum ein Datum nach oder gleich dem 1.1.96 ist. Mit dem Schlüsselwort AND werden die Felder in der Zeichenfolge des Arguments Kriterien voneinander getrennt. Alle Datensätze, die in der Berechnung mit der Funktion DAvg verwendet werden, erfüllen beide Kriterien.

Dim dblX As Double
dblX = DAvg("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = 'Großbritannien' AND [Versanddatum] > #1-1-96#")

Das nächste Beispiel berechnet einen Durchschnittswert mit Hilfe der Variablen strLand im Argument Kriterien. Im Zeichenfolgenausdruck befinden sich Hochkommas, d.h. wenn alle Zeichenfolgen verkettet sind, wird das Zeichenfolgenliteral Großbritannien in Hochkommas gesetzt. In diesem Beispiel wird das Schlüsselwort OR verwendet, um die einzelnen Felder zu trennen. Dieses Beispiel gibt alle Datensätze zurück, die entweder eines oder beide Kriterien erfüllen.

Dim dblX As Double, strLand As String
strLand = "Großbritannien"
dblX = DAvg("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = '" & strLand & "' OR " & _
    "[Versanddatum] < #1-1-96#")


DCount-Funktion (DomAnzahl) - Beispiele

Dieses Beispiel gibt die Anzahl der Bestellungen zurück, die nach dem 1. Januar 1996 nach Großbritannien versandt wurden. Die Domäne ist die Tabelle Bestellungen. Das Argument Kriterien beschränkt die sich ergebende Datensatzgruppe auf Datensätze, bei denen Bestimmungsland gleich Großbritannien ist und das Versanddatum nach dem 1.1.96 liegt.

intX = DCount("[Lieferdatum]", "Bestellungen", _
    "[Bestimmungsland] = 'UK' AND [Lieferdatum] > #1-1-95#")

Im nächsten Beispiel wird im Argument Kriterien der aktuelle Wert des Kombinationsfelds Bestimmungsland übergeben. Die Werte im Kombinationsfeld Bestimmungsland stammen aus dem Feld Bestimmungsland in der Tabelle Bestellungen. Beachten Sie, dass der Bezug auf das Steuerelement nicht in den Anführungszeichen steht, die für Zeichenfolgen verwendet werden. Dadurch wird sichergestellt, dass Microsoft Access bei jedem Aufruf der Funktion DCount die aktuellen Daten vom Steuerelement erhält.

intX = DCount("[Lieferdatum]", "Bestellungen", "[Bestimmungsland] = '" _
    & Formulare!Bestellungen![Bestimmungsland] & "'AND [Lieferdatum] > #1-1-95#")


 Unterschiedliche Formate für unterschiedliche Zeichenfolgenwerte (Format-Funktion)

Unterschiedliche Formate für unterschiedliche Zeichenfolgenwerte (Format-Funktion)

In Microsoft Access, Versionen 1.x und 2.0, konnten Sie unter Verwendung der Funktion Format einen Wert für eine Zeichenfolge der Länge Null und einen anderen Wert für einen Null-Wert zurückgeben. Sie konnten mit der Funktion Format z.B. einen Formatausdruck zum Zurückgeben des entsprechenden Zeichenfolgenwertes aus dem Code heraus verwenden, der wie folgt aussieht:

Dim varX As Variant, varStrX As Variant
' Zuweisen eines Wertes zu varStrX und Übergeben an die Funktion Format.
varX = Format(varStrX, "@;ZLS;Null")

In Microsoft Access 97 und Microsoft Access 2000 müssen Sie separat auf einen Null-Wert prüfen und dann den entsprechenden Wert auf der Basis des Ergebnisses zurückgeben. Dazu können Sie z.B. die IIf-Funktion in einem Ausdruck mit der Format-Funktion wie folgt verwenden:

varX = IIf(IsNull(varStrX),"Null", Format(varStrX, "@;ZLS"))

Diese Änderung gilt nur, wenn Sie die Funktion Format zum Formatieren einer Zeichenfolge verwenden, die abhängig davon ist, ob es sich um eine Zeichenfolge der Länge Null oder um einen Null-Wert handelt. Andere Formatausdrücke, die zusammen mit der Funktion Format verwendet werden, werden wie in den vorherigen Versionen eingesetzt.

Wenn Sie eine Datenbank von einer der Microsoft Access-Versionen 1.x oder 2.0 in Microsoft Access 2000 konvertieren, müssen Sie den Code ändern, um separat auf einen Null-Wert zu prüfen.


DLookup-Funktion (DomWert) - Beispiel

Diese Beispiel gibt Namensinformationen aus dem Feld Firma aus dem Datensatz zurück, der die Bedingungen im Argument Kriterien erfüllt. Die Domäne ist die Tabelle Versandfirmen. Das Argument Kriterien beschränkt die resultierende Datensatzgruppe auf Datensätze, bei denen Firmen-Nr gleich 1 ist.

Dim varX As Variant
varX = DLookup("[Firma]", "Versandfirmen", "[Firmen-Nr] = 1")

Das folgende Beispiel aus der Tabelle Versandfirmen verwendet das Formular-Steuerelement Firmen-Nr, um das Argument Kriterien für DLookup anzugeben. Beachten Sie, dass der Verweis auf das Steuerelement nicht in den Anführungszeichen steht, die die Zeichenfolge kennzeichnen. Dadurch wird sichergestellt, dass Microsoft Access bei jedem Aufruf von DLookup die aktuellen Werte vom Steuerelement erhält.

Dim varX As Variant
varX = DLookup("[Firma]", "Versandfirmen", "[Firmen-Nr] =" _
    & Formulare![Formular1]![Firmen-Nr])

Das nächste Beispiel verwendet die Variable intSuche, um den Wert zu ermitteln.

Dim intSuche As Integer, varX As Variant
intSuche = 1
varX = DLookup("[Firma]", "Versandfirmen", _
    "[Firmen-Nr] = " & intSuche)


DMin-, DMax-Funktionen (DomMin, DomMax) - Beispiel

Dieses Beispiel gibt den kleinsten und den größten Wert aus dem Feld Frachtkosten für Bestellungen zurück, die nach Großbritannien versandt wurden. Als Domäne wird die Tabelle Bestellungen verwendet. Das Argument Kriterien beschränkt die resultierende Datensatzgruppe auf die Datensätze, bei denen Bestimmungsland gleich Großbritannien ist.

Dim curX As Currency, curY As Currency
curX = DMin("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = 'UK'")
curY = DMax("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = 'UK'")

Im nächsten Beispiel enthält das Argument Kriterien den aktuellen Wert eines Textfelds Bestelldatum. Das Textfeld ist an ein Feld Bestelldatum in der Tabelle Bestellungen gebunden. Der Verweis auf das Steuerelement steht nicht in den Anführungszeichen ("), die für die Zeichenfolgen verwendet werden. Dadurch wird sichergestellt, dass Microsoft Access bei jedem Aufruf von DMax den aktuellen Wert vom Steuerelement abruft.

Dim curX As Currency
curX = DMax("[Frachtkosten]", "Bestellungen", "[Bestelldatum] = #" _
    & Formulare!Bestellungen!Bestelldatum & "#")

Im nächsten Beispiel enthält der Kriterienausdruck eine Variable dteBestelldatum. Beachten Sie, dass der Zeichenfolgenausdruck #-Zeichen enthält, die das Datum umschließen, wenn die Zeichenfolgen verkettet werden.

Dim dteBestelldatum As Date, curX As Currency
dteBestelldatum = #3/30/95#
curX = DMin("[Frachtkosten]", "Bestellungen", _
    "[Bestelldatum] = #" & dteBestelldatum & "#")


DoEvents-Funktion (Ereignisse)

In Microsoft Access wird die Funktion DoEvents ignoriert, wenn Sie sie wie folgt verwenden:

  • In einer benutzerdefinierten Funktion oder in einer Prozedur, die ein Feld in einer Abfrage, einem Formular oder einem Bericht berechnet.

  • In einer benutzerdefinierten Funktion, die eine Liste erstellt, mit der ein Kombinationsfeld, ein Listenfeld oder ein OLE-Objekt gefüllt wird.

Wenn Sie die Funktion DoEvents in diesen Fällen einsetzen, gibt Microsoft Access die Steuerung nicht an das Betriebssystem ab.


DoEvents-Funktion - Beispiel

Im nachstehenden Beispiel wird die Funktion DoEvents dazu verwendet, während der Ausführung einer Schleife die Steuerung an das Betriebssystem zurückzugeben. Die Funktion DoEvents gibt immer 0 zurück.

Sub LangeSchleife()
    Dim intI As Integer

    For intI = 1 To 1500             ' Schleife beginnen.
        If intI Mod 100 = 0 Then    ' Wenn die Schleife
                                            ' 100mal ausgeführt wurde ,
            DoEvents                        ' Steuerung an Betriebssystem
                                            ' übergeben..
            Debug.Print intI
        End If
    Next intI                            ' Schleifenzähler erhöhen.
End Sub


DStDev-, DStDevP-Funktionen (DomStAbw, DomStAbwG) - Beispiele

Dieses Beispiel gibt Abschätzungen der Standardabweichung für die Population und für eine Populationsstichprobe für diejenigen Bestellungen zurück, die nach Großbritannien versandt wurden. Die Domäne ist die Tabelle Bestellungen. Das Argument Kriterien beschränkt die resultierende Datensatzgruppe auf Datensätze, bei denen Bestimmungsland gleich Großbritannien ist.

Dim dblX As Double, dblY As Double
' Stichprobenschätzung.
dblX = DStDev("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = 'UK'")
' Populationsschätzung.
dblY = DStDevP("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = 'UK'")

Das nächste Beispiel berechnet die gleichen Schätzungen mit Hilfe der Variablen strLand im Argument Kriterien. Im Zeichenfolgenausdruck befinden sich Hochkommas ('), d.h. wenn alle Zeichenfolgen verkettet sind, wird das Zeichenfolgenliteral Großbritannien in Hochkommas gesetzt.

Dim strLand As String, dblX As Double, dblY As Double
strLand = "UK"
dblX = DStDev("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = '" & strLand & "'")
dblY = DStDevP("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = '" & strLand & "'")


DSum-Funktion (DomSumme) - Beispiele

Dieses Beispiel summiert die Werte aus dem Feld Frachtkosten für Bestellungen auf, die nach Großbritannien versandt wurden. Die Domäne ist die Tabelle Bestellungen. Das Argument Kriterien beschränkt die resultierende Datensatzgruppe auf Datensätze, bei denen Bestimmungsland gleich Großbritannien ist.

Dim curX As Currency
curX = DSum("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = 'UK'")

Das nächste Beispiel berechnet eine Summe mit zwei unterschiedlichen Kriterien. Der Zeichenfolgenausdruck enthält Hochkommas (') und #-Zeichen, so dass bei der Verkettung der Zeichenfolgen das Zeichenfolgenliteral in Hochkommas und das Datum in #Zeichen gesetzt wird.

Dim curX As Currency
curX = DSum("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = 'UK' AND [Lieferdatum] > #1-1-95#")

Sie können eine Domänenfunktion in der Zeile Aktualisieren einer Aktualisierungsabfrage verwenden. Nehmen Sie z.B. an, dass Sie die aktuellen Umsätze eines Produkts in der Tabelle Artikel verfolgen möchten. Sie können der Tabelle Artikel ein neues Feld Aktuelle Umsatzzahlen hinzufügen und eine Aktualisierungsabfrage starten , um die korrekten Werte zu berechnen und die Datensätze zu aktualisieren. Erstellen Sie eine neue Abfrage, der die Tabelle Artikel zugrunde liegt, und wählen Sie aus dem Menü Abfrage den Befehl Aktualisieren. Fügen Sie dem Abfrageentwurfsbereich das Feld Aktuelle Umsatzzahlen hinzu, und geben Sie Folgendes in die Zeile Aktualisieren ein:

DomSumme("[Menge]*[Einzelpreis]"; "Bestelldetails"; "[Artikel-Nr] = " _
    & [Artikel-Nr])

Wenn die Abfrage ausgeführt wird, berechnet Microsoft Access die Gesamtsumme der Umsätze für jedes Produkt aus den Informationen in der Tabelle Bestelldetails. Die Summe der Umsätze für jedes Produkt wird in die Tabelle Artikel eingetragen.


DVar-, DVarP-Funktionen (DomVarianz, DomVarianzen) - Beispiele

Dieses Beispiel gibt die Abschätzungen der Varianz für eine Population und für eine Populationsstichprobe für Bestellungen zurück, die nach Großbritannien versandt wurden. Die Domäne ist die Tabelle Bestellungen. Das Argument Kriterien beschränkt die resultierende Datensatzgruppe auf Datensätze, bei denen Bestimmungsland gleich Großbritannien ist.

Dim dblX As Double, dblY As Double
' Stichprobenschätzung.
dblX = DVar("[Frachtkosten]", "Bestellungen", _
    "[Bestimmungsland] = 'Großbritannien'")
' Populationsschätzung.
dblY = DVarP("[Frachtkosten]", "Bestellungen", _
"[Bestimmungsland] = 'Großbritannien'")

Das nächste Beispiel gibt Schätzungen mit Hilfe der Variablen strLand im Argument Kriterien zurück. Im Zeichenfolgenausdruck befinden sich Hochkommas ('), d.h. wenn alle Zeichenfolgen verkettet sind, wird das Zeichenfolgenliteral Großbritannien in Hochkommas gesetzt.

Dim strLand As String, dblX As Double
strLand = "UK"
dblX = DVar("[Frachtkosten]", "Bestellungen", "[Bestimmungsland] = '" _
    & strLand & "'")


Eval-Funktion (Auswerten) - Beispiel

Im folgenden Beispiel wird angenommen, dass Sie eine Reihe von 50 Funktionen als A1, A2 usw. definiert haben. Mit Hilfe der Funktion Eval wird jede Funktion der Reihe aufgerufen.

Sub Aufrufreihe()
    Dim intI As Integer

    For intI = 1 To 50
        Eval("A" & intI & "()")
    Next intI
End Sub

Das nächste Beispiel löst das Ereignis Click aus, als ob der Benutzer auf eine Schaltfläche eines Formulars geklickt hätte. Falls der Wert der Eigenschaft OnClick der Schaltfläche mit einem Gleichheitszeichen (=) beginnt (was bedeutet, dass es sich um den Namen einer Funktion handelt), ruft die Funktion Eval diese Funktion auf. Dies entspricht dem Auslösen des Ereignisses Click. Beginnt der Wert nicht mit einem Gleichheitszeichen, muss es sich um einen Makronamen handeln. Die Methode RunMacro des Objekts DoCmd führt dann das genannte Makro aus.

Dim ctl As Control, varTemp As Variant

Set ctl = Formulare!Kontakte!cmdHilfe
If (Left(ctl.OnClick, 1) = "=") Then
    varTemp = Eval(Mid(ctl.OnClick,2))
Else
    DoCmd.RunMacro ctl.OnClick
End If


Fix-Funktion

Wenn Sie die Funktion Fix verwenden, um in einer Tabellenerstellungsabfrage ein neues Feld zu erstellen, erhält das neue Feld den Datentyp dbDouble. Sie können den Datentyp mit der DAO-Eigenschaft Type ermitteln.


GUIDFromString-Funktion - Beispiel

Das folgende Beispiel wandelt mit der Funktion GUIDFromString eine Zeichenfolge in einen GUID-Wert um. Die Zeichenfolge ist ein GUID-Wert, der als Zeichenfolge in der replizierten Tabelle Personal gespeichert ist. Das Feld s_GUID ist ein ausgeblendetes Feld, das in einer replizierten Datenbank zu jeder replizierten Tabelle hinzugefügt wird.

Sub ÜberprüfenGUIDTyp()
    Dim dbs As Database, rst As Recordset

    Set dbs = CurrentDb
    Set rst = dbs.OpenRecordset("Personal")
    Debug.Print rst!s_GUID
    Debug.Print TypeName(rst!s_GUID)
    Debug.Print TypeName(GuidFromString(rst!s_GUID))
End Sub


 IIf-Funktion

IIf-Funktion

Sie können die IIf-Funktion (Immediate If) auch in einem berechneten Steuerelement in einem Microsoft Access-Formular oder -Bericht verwenden. Mit der IIf-Funktion können Sie einen Ausdruck auswerten und einen von zwei Werten - abhängig davon, ob die Auswertung des Ausdrucks Wahr (-1) oder Falsch (0) ergibt - zurückgeben. Sie können mit IIf z. B. ein Feld in einem Formular untersuchen und ermitteln, ob dessen Wert gleich Null ist. Wenn dies der Fall ist, könnte die Funktion eine leere Zeichenfolge zurückgeben. Wenn das Feld einen Wert ungleich Null enthält, könnte die Funktion den Inhalt des Feldes zurückgeben.

Das folgende Beispiel überprüft das Feld Bestimmungsland in einer Tabelle Bestellungen und gibt eine leere Zeichenfolge zurück, wenn das Feld den Wert Null enthält.

=IIf(IstNull(Formulare!Bestellungen![Bestimmungsland]), "", _
     Formulare!Bestellungen![Bestimmungsland])

In Visual Basic wertet die IIf-Funktion sowohl das Argument wahr als auch das Argument falsch aus, auch wenn nur einer der Werte zurückgegeben wird. In einem Microsoft Access-Formular oder -Bericht wertet IIf entweder wahr oder falsch aus. Bei Verwendung von IIf in einem berechneten Steuerelement, einem Abfrageausdruck oder einem Makro kommt es daher nicht zu unerwünschten Nebeneffekten, zu denen es beim Auswerten beider Argumente kommen könnnte.

Anmerkung Die Microsoft Access-Funktion Nz konvertiert Nullwerte in 0, in eine leere Zeichenfolge oder in einen anderen Wert, den Sie angeben. Wenn Ihr Ausdruck Nullwerte verarbeitet, können Sie an Stelle der IIf-Funktion auch die Nz-Funktion verwendet.

Die IIf-Funktion eignet sich eher für Ausdrücke in einem Formular oder Bericht als für Visual Basic-Code. In Visual Basic bietet die noch leistungsstärkere Anweisung If...Then...Else mehr Flexibilität.


IIf-Funktion - Beispiel

In diesem Beispiel wird die Funktion IIf zur Auswertung eines Feldes namens Bestellmenge verwendet. Die Funktion gibt das Wort "Groß" zurück, falls der Betrag größer als 1000 ist; andernfalls gibt sie das Wort "Klein" zurück. Sie können den folgenden Ausdruck in die Eigenschaft ControlSource eines berechneten Steuerelements eintragen.

= IIf([Bestellmenge] > 1000, "Groß", "Klein")


InputBox-Funktion (Eingabefeld)

Sie können keine Hilfedatei aus einem Dialogfeld öffnen, das mit der Funktion InputBox in Microsoft Access erstellt wurde. Wenn Sie Werte für die Argumente Hilfedatei und Kontext angeben, werden diese nicht beachtet, und im Eingabefeld ist keine Schaltfläche Hilfe vorhanden. Microsoft Access erzeugt allerdings keinen Fehler.


InputBox-Funktion (Eingabefeld) - Beispiel

Im folgenden Beispiel wird mit der Funktion InputBox der Name des Benutzers zurückgegeben. Beachten Sie, dass Sie eine Hilfedatei nicht aus einem Dialogfeld öffnen können, das mit der Funktion InputBox in Microsoft Access erstellt wurde.

Sub Begrüßung()
    Dim strEingabe As String, strMldg As String

    strMldg = "Geben Sie Ihren Namen ein."
    strEingabe = InputBox(Prompt:=strMldg, Title:="Benutzerinfo", XPos:=2000, YPos:=2000)
    MsgBox "Hallo " & strEingabe
End Sub


IsDate-Funktion (IstDatum) - Beispiel

Dieses Beispiel fordert den Benutzer auf, eine Zeichenfolge einzugeben. Die Funktion IsDate wird verwendet, um zu ermitteln, ob die Zeichenfolge in ein Datum umgewandelt werden kann. Anschließend wird eine entsprechende Meldung angezeigt.

Sub DatumPrüfen()
    Dim strDatum As String

    strDatum = InputBox("Geben Sie eine Zeichenfolge ein, die Sie" & _
          " als Datum anzeigen möchten.")
    ' Die Variable testen.
    If IsDate(strDatum) Then
        ' Wenn die Zeichenfolge ein Datum ist, wird sie
        ' formatiert und in einem Dialogfeld angezeigt.
        MsgBox "Das Datum lautet: " & Format(DateValue(strDatum), _
            "Long Date")
    Else
        MsgBox "Der von Ihnen eingegebene Wert ist kein Datum."
    End If
End Sub


IsNull-Funktion (IstNull) - Beispiel

Das folgende Beispiel verwendet die IsNull-Funktion, um zu ermitteln, ob der Wert eines Steuerelements Null ist. Wenn dies der Fall ist, wird der Benutzer mit einer Meldung aufgefordert, Daten einzugeben. Wenn der Wert ungleich Null ist, zeigt eine Meldung den Wert des Steuerelements an.

Sub SteuerelementWert(ctlText As Control)
    Dim strMldg As String

    ' Prüfen, ob das Steuerelement ein Textfeld ist.
    If ctlText.ControlType = acTextBox Then
        ' Ist der Wert des Steuerelements gleich Null,
        ' den Benutzer zur Eingabe von Daten auffordern.
        If IsNull(ctlText.Value) Then
           strMldg = "Im Feld '" & ctlText.Name & "' befinden sich " & _
           "keine Daten." & vbCrLf & _
           "Bitte geben Sie jetzt Daten für dieses Feld ein."
                If MsgBox(strMldg, vbQuestion) = vbOK Then
                    Exit Sub
                End If
        ' Ist der Wert ungleich Null, wird er angezeigt.
        Else
            MsgBox (ctlText.Value)
        End If
    End If
End Sub


IsObject-Funktion: Beispiel

Das folgende Beispiel verwendet die Funktion IsObject, um zu prüfen, ob ein an die Funktion übergebenes Argument ein Objekt ist.

Sub AufObjektPrüfen(varTest As Variant)
    Dim varX as Variant

    If IsObject(varTest) Then
        Set varX = varTest
    Else
        varX = varTest
    End If
End Sub


LoadPicture-Methode - Beispiel

Im folgenden Beispiel wird die LoadPicture-Methode verwendet, um eine Metadatei in ein ActiveX-Steuerelement zu laden, das sich auf einem Formular namens Personal befindet.

Sub GrafikAnzeigen()
    Const strConPfadZuDenBitmaps = "C:\Programme\MSOffice\Office\Bitmaps\Styles\"

    ' Objektvariablen des Typs Picture und Control deklarieren.
    Dim objBild As Object, ctl As Control

    ' Control-Variable so einstellen, dass sie auf das
    ' ActiveX-Steuerelement des Formulars verweist.
    Set ctl = Formulare!Personal!EinZusatzsteuerelement
    ' Den Rückgabewert von LoadPicture dem Picture-Objekt zuweisen.
    Set objBild = LoadPicture(strConPfadZuDenBitmaps & "Globus.wmf")
    ' Die Eigenschaft Picture des ActiveX-Steuerelements einstellen.
    Set ctl.Picture = objBild
End Sub


 MsgBox-Funktion (Meldung)

MsgBox-Funktion (Meldung)

Mit der Funktion MsgBox können Sie in Microsoft Access eine formatierte Fehlermeldung erstellen, ähnlich den eingebauten Fehlermeldungen, die von Microsoft Access angezeigt werden.

Anmerkung In Access 2000 erlaubt diese Funktion nicht die Verwendung des At-Zeichens (@) zum Trennen einer Zeichenfolge in Abschnitte.

Im folgenden Beispiel wird ein formatiertes Dialogfeld mit einer in Abschnitte unterteilten Zeichenfolge angezeigt.

MsgBox "Falsche Schaltfläche!" & chr(13) _
    & "Diese Schaltfläche funktioniert nicht." & chr(13) -
    & "Versuchen Sie es mit einer anderen.", vbOKOnly + vbExclamation

Anmerkung Wenn Sie in Microsoft Access ein Meldungsfeld ohne Symbol anzeigen möchten, geben Sie keine Konstante an, die ein Symbol bezeichnet, oder geben Sie für das Argument Schaltflächen den Wert 0 an, wie im folgenden Beispiel.

    MsgBox "Keine Symbole enthalten.", 0


MsgBox-Funktion (Meldung) - Beispiel

Im folgenden Beispiel wird mit der Funktion MsgBox eine formatierte Fehlermeldung in Microsoft Access erstellt. Mit dem @-Zeichen werden die verschiedenen Abschnitte der Fehlermeldung voneinander getrennt.

Sub BenutzerMeldung()
    Dim strMldg As String, strEingabe As String

    ' Zeichenfolge initialisieren.
    strMldg = "Zahl außerhalb des Bereichs.@Sie haben eine Zahl " & _
          "eingegeben, die kleiner als 1 oder größer als 10 ist. " & _
          "@Klicken Sie auf 'OK', um die Zahl erneut einzugeben."
    ' Benutzer zur Eingabe auffordern.
    strEingabe = InputBox("Geben Sie eine Zahl zwischen 1 und 10 ein.")
    ' Ermitteln, ob Benutzer "Abbrechen" gewählt hat.
    If strEingabe <> "" Then
        ' Wert der Benutzereingabe testen.
        Do While strEingabe < 0 or strEingabe > 10
            If MsgBox( strMldg, vbOkCancel, "Fehler!") = vbOk Then
                strEingabe = InputBox("Geben Sie eine Zahl zwischen " & _
          "1 und 10 ein.")
            Else
                Exit Sub
            End If
        Loop
        ' Korrekte Benutzereingabe anzeigen.
        MsgBox "Sie haben die Zahl " & strEingabe & " eingegeben."
    Else
        Exit Sub
    End If
End Sub


Now-Funktion (Jetzt) - Beispiel

Sie können die Funktion Now für ein berechnetes Steuerelement verwenden, um das aktuelle Systemdatum und die aktuelle Systemzeit zurückzugeben. Sie können z. B. ein Textfeld erstellen und dessen Eigenschaft ControlSource auf den folgenden Ausdruck einstellen.

= Jetzt()


Nz-Funktion - Beispiel

Das folgende Beispiel wertet ein Steuerelement eines Formulars aus und gibt eine von zwei Zeichenfolgen zurück, basierend auf dem Wert des Steuerelements. Sofern der Wert des Steuerelements gleich Null ist, verwendet die Prozedur die Funktion Nz, um den Wert Null in eine leere Zeichenfolge umzuwandeln.

Sub WertPrüfen()
    Dim frm As Form, ctl As Control
    Dim varErgebnis As Variant

    ' Die Form-Objektvariable einstellen, die auf das Formular
    ' "Bestellungen" zeigt.
    Set frm = Formulare!Bestellungen
    ' Die Control-Objektvariable einstellen, die auf
    ' "BestellungenRegion" zeigt.
    Set ctl = frm!BestellungenRegion
    ' Das Ergebnis ausgehend vom Wert des Steuerelements wählen.
    varErgebnis = IIf(Nz(ctl.Value) = "", "Kein Wert", "Der Wert ist " _
    & ctl.Value)
    ' Das Ergebnis anzeigen.
    MsgBox varErgebnis
End Sub


Partition-Funktion (Bereich) - Beispiel (MDB)

Sie können die Funktion Partition im Abfrageentwurfsbereich und in der SQL-Ansicht des Abfragefensters verwenden. Im Abfrageentwurfsbereich können Sie die Funktion Partition in einem berechneten Feld oder zur Angabe von Kriterien für eine Auswahlabfrage verwenden.

Das folgende Beispiel zeigt, wie Sie mit der Funktion Partition ein berechnetes Feld erstellen können, in dem aufgelistet wird, wie viele Datensätze in einen bestimmten Bereich fallen. Nehmen Sie an, eine Tabelle Bestellungen enthält ein Feld Frachtkosten. Erstellen Sie im Abfragefenster eine neue Abfrage Summe, indem Sie die Tabelle Bestellungen hinzufügen und in der Symbolleiste Abfrage Datenblatt auf die Schaltfläche Funktionen klicken. Ziehen Sie das Feld Frachtkosten auf die erste Zelle der Zeile Feld des Abfrageentwurfsbereichs, und stellen Sie den Wert der Zelle Funktion auf Anzahl ein. Geben Sie in eine andere Zelle der Zeile Feld den folgenden Ausdruck ein.

Bereich: Bereich([Frachtkosten]; 0; 1000; 50)

Setzen Sie die Zelle Funktionen unterhalb dieses Feldes auf Gruppierung, und führen Sie die Abfrage aus. Die Funktion Partition gibt elf Bereiche (0:99, 100:199, 200:299 usw.) zurück. Die Abfrage zeigt die Anzahl der Bestellungen, deren Frachtkosten in den jeweiligen Bereich fallen.

Das nächste Beispiel zeigt Ihnen, wie Sie die Funktion Partition in der SQL-Ansicht des Abfragefensters verwenden können. Im Beispiel wird eine Kreuztabellenabfrage erstellt, die ein Feld Frachtkosten einer Tabelle Bestellungen auswertet. Es wird die Anzahl an Bestellungen jedes Kunden berechnet, deren Frachtkosten innerhalb von verschiedenen Bereichen liegen. Die Bereiche sind durch die Argumente der Funktion Partition definiert: start = 0, stop = 1000, intervall = 50.

Geben Sie den folgenden Ausdruck in der SQL-Ansicht ein. Wenn Sie diese Abfrage ausführen, wird jeder Bereich als Spaltenüberschrift angezeigt.

TRANSFORM Count(Bestellungen.[Bestell-Nr]) AS [AnzahlBestell-Nr]
SELECT Bestellungen.[Kunden-Code]
FROM Bestellungen
GROUP BY Bestellungen.[Kunden-Code]
PIVOT Partition(Int([Frachtkosten]), 0, 1000, 50)


StringFromGUID-Funktion - Beispiel

Das folgende Beispiel gibt den Wert des Steuerelements s_GUID auf dem Formular Personal als Zeichenfolge zurück und weist ihn einer Zeichenfolgenvariablen zu. Das Steuerelement s_GUID ist an das Feld s_GUID gebunden, ein Systemfeld, das in einer replizierten Datenbank zu jeder replizierten Tabelle hinzugefügt wird.

Sub ZeichenfolgenwertVonGUID()
    Dim ctl As Control, strGUID As String

    Set ctl = Formulare!Personal![s_GUID]
    Debug.Print TypeName(ctl.Value)
    strGUID = StringFromGUID(ctl.Value)
    Debug.Print TypeName(strGUID)
End Sub


 Switch-Funktion (Schalter)

Switch-Funktion (Schalter)

Sie können die Switch-Funktion auch in einem berechneten Steuerelement in einem Microsoft Access-Formular oder -Bericht verwenden. Sie können mit der Switch-Funktion z. B. den Wert eines Steuerelements auf der Basis eines Wertes eines anderen Feldes setzen. Dazu legen Sie für die Steuerelementinhalt-Eigenschaft des Steuerelements einen Ausdruck fest, der die Switch-Funktion enthält.

Im folgenden Beispiel gibt die Switch-Funktion eine Zeichenfolge zurück, die den Namen einer Versandfirma auf der Basis des Wertes aus dem Feld Frachtkosten angibt. Wenn der Wert im Feld Frachtkosten unter DM 50,00 liegt, gibt die Switch-Funktion die Versandfirma "Speedy" zurück. Ist der Wert größer oder gleich DM 50,00 jedoch kleiner oder gleich DM 100,00, gibt Switch "United" zurück. Ist der Wert größer als DM 100,00, gibt die Funktion die Versandfirma "Federal" zurück.

=Switch([Frachtkosten] < 50, "Speedy", ([Frachtkosten] >= 50 _
     und [Frachtkosten] <= 100), "United", [Frachtkosten] > 100, _
     "Federal")

Anmerkung In Visual Basic können Sie auch die leistungsstärkere Select Case-Anweisung verwenden, um einen Wert aus einer Reihe mehrerer Auswahlmöglichkeiten zurückzugeben.


Switch-Funktion (Schalter) - Beispiel

Im folgenden Beispiel wird mit Hilfe der Funktion Switch die passende Sprache für die jeweils angegebene Stadt ermittelt. Dies geschieht auf Basis der Werte, die die Felder Bestimmungsland und Ort der Tabelle Bestellungen haben. Sie können den folgenden Ausdruck für ein berechnetes Steuerelement eines Formulars oder Berichts eingeben. Der Ausdruck wird zur besseren Übersichtlichkeit in mehreren Zeilen angezeigt; Sie können ihn auch in eine Zeile schreiben.

= Switch([Ort] = "Madrid"; "Spanisch";
    [Ort] = "Berlin"; "Deutsch";
    [Ort] = "Turin"; "Italienisch";
    [Bestimmungsland] = "Frankreich"; "Französisch";
    Wahr; "Englisch")

Ist die Stadt Madrid, gibt Switch "Spanisch" zurück; ist die Stadt Berlin, gibt die Funktion "Deutsch" zurück; usw. Entspricht die Stadt keiner der aufgeführten Städte, aber das Land ist Frankreich, gibt die Funktion "Französisch" zurück. Ist die fragliche Stadt nicht in der Liste aufgeführt, gibt die Funktion Switch "Englisch" zurück.


Timer-Funktion (Zeitgeber) - Beispiel

Sie können die Funktion Timer verwenden, um in Ihrer Microsoft Access-Anwendung die für Vorgänge und Ereignisse benötigte Zeit zu messen. Setzen Sie dazu unmittelbar vor und hinter den Vorgang, dessen Zeit Sie messen möchten, je eine Timer-Funktion. Die folgende Beispielprozedur erwartet als Argument den Namen einer Abfrage. In der Prozedur wird dann berechnet, wie lange es dauert, die Abfrage auszuführen.

Sub Abfragedauer (strAbfrage As String)
    Dim sngStart As Single, sngEnde As Single
    Dim sngDauer As Single

    sngStart = Timer                        ' Startzeit festhalten.
    DoCmd.OpenQuery strAbfrage, acNormal    ' Abfrage ausführen.
    sngEnde = Timer                            ' Endzeit festhalten.
    sngDauer = Format(sngEnde - sngStart, "Fixed")    ' Zeitdauer formatieren.
    MsgBox ("Die Abfrage '" & strAbfrage & "' wurde in " & sngDauer _
        & " Sekunden ausgeführt.")
End Sub


 Time-Funktion (Zeit)

Time-Funktion (Zeit)

Sie können die aktuelle Uhrzeit in ein Formular oder einen Bericht einfügen, indem Sie im Menü Einfügen auf Datum und Zeit klicken. Dieser Befehl erstellt ein Textfeld auf einem Formular oder Bericht und stellt die Eigenschaft ControlSource des Textfelds auf einen Ausdruck ein, der die Funktion Time enthält. Wie der Ausdruck konkret aussieht, hängt davon ab, welches Format Sie für die Anzeige der Zeit gewählt haben. Dieser Befehl ist nur in der Formularentwurfsansicht und der Berichtsentwurfsansicht verfügbar.

Sie können die Funktion Time auch in einem Abfrageausdruck oder in einem Makro verwenden. Allerdings müssen Sie bei jeder Anwendung außerhalb eines Visual Basic-Moduls die Klammern hinter der Funktion hinzufügen, wie im Ausdruck Zeit().


Time-Funktion (Zeit) - Beispiel

Sie können die Funktion Time für ein berechnetes Steuerelement verwenden, um die aktuelle Systemzeit zurückzugeben. Sie können z. B. ein Textfeld erstellen und dessen Eigenschaft ControlSource auf den folgenden Ausdruck einstellen.

= Zeit()


TypeName-Funktion - Beispiel

Das folgende Beispiel erstellt mehrere Objektvariablen und übergibt sie an die Funktion TypeName.

Sub Objekttypen()
    Dim dbs As Database, tdf As TableDef
    Dim fld As Field

    ' Die aktuelle Datenbank abrufen.
    Set dbs = CurrentDb()
    ' Das TableDef-Objekt zurückgeben, das auf die
    ' Tabelle 'Bestellungen' zeigt.
    Set tdf = dbs.TableDefs("Bestellungen")
    ' Das Field-Objekt zurückgeben, das auf das Feld
    ' 'Bestelldatum' zeigt.
    Set fld = tdf.Fields("Bestelldatum")
    ' Für jedes Objekt den von TypeName zurückgegebenen
    ' Wert anzeigen.
    Debug.Print TypeName(dbs)
    Debug.Print TypeName(tdf)
    Debug.Print TypeName(fld)
End Sub


 Hinzufügen einer Aktion zu einem Makro

Hinzufügen einer Aktion zu einem Makro

  1. Klicken Sie im Makrofenster in der Spalte Aktion auf die erste leere Zeile. Wenn Sie eine Aktion zwischen zwei Aktionszeilen einfügen möchten, klicken Sie auf den Markierer für die Aktionszeile unter der Zeile, in die Sie die neue Aktion einfügen möchten, und klicken Sie in der Symbolleiste auf Zeilen einfügen [image] .

  2. Klicken Sie in der Spalte Aktion auf den Pfeil, um die Aktionsliste anzuzeigen.

  3. Klicken Sie auf die gewünschte Aktion.

  4. Geben Sie einen Kommentar für die Aktion ein. Kommentare sind optional.

  5. Geben Sie bei Bedarf im unteren Teil des Fensters Argumente für die Aktion an. Um Tipps zum Setzen von Aktionsargumenten anzuzeigen, klicken Sie auf [image] .

Tipp Für Aktionsargumente, deren Einstellung der Name eines Datenbankobjekts ist, können Sie das Argument setzen, indem Sie das Objekt aus dem Datenbankfenster in das Argumentfeld Objektname der Aktion ziehen. Sie können z.B. das Argument Objektname der Aktion AuswählenObjekt für den Namen eines Formulars setzen, indem Sie das Formular in das Argumentfeld ziehen. Klicken Sie dazu im Menü Fenster auf Vertikal, um das Makrofenster und das Datenbankfenster so zu positionieren, dass sie nebeneinander auf dem Bildschirm angeordnet sind. Klicken Sie anschließend im Datenbankfenster unter Objekte auf den gewünschten Objekttyp und dann auf das Objekt. Ziehen Sie danach das Objekt in das Argumentfeld. Durch Ziehen des Objekts wird außerdem das Argument Objekttyp gesetzt.


 Hinzufügen der Direkthilfe zu einem Formular

Hinzufügen der Direkthilfe zu einem Formular

Sie können diese Vorgehensweise für ein benutzerdefiniertes Dialogfeld verwenden oder dann, wenn Sie die Titelleiste eines bestimmten Formulars deaktiviert bzw. die Schaltfläche Direkthilfe [image] aus der Titelleiste des Formulars entfernt haben.

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars anzuzeigen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft SchaltflächeDirekthilfe auf Ja.

Anmerkung Falls Sie im Einstellungsfeld der Eigenschaft Hilfedatei des Formulars keine benutzerdefinierte Hilfedatei angegeben haben, wird die Microsoft Access-Hilfedatei angezeigt, wenn Sie auf die Schaltfläche Direkthilfe [image] und anschließend auf das Formular oder ein Steuerelement des Formulars klicken. Weitere Informationen über das Erstellen einer benutzerspezifischen Hilfe für die Schaltfläche Direkthilfe.


 Erstellen eines ungebundenen Kontrollkästchens, Optionsfelds oder einer Umschaltfläche

Erstellen eines ungebundenen Kontrollkästchens, Optionsfelds oder einer Umschaltfläche

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das gewünschte Steuerelement in der Toolbox. Wenn Sie nicht sicher sind, welches das richtige Steuerelement ist, positionieren Sie den Zeiger auf einem der Steuerelemente, so dass die QuickInfo angezeigt wird.

    Anmerkung Umschaltflächen sind in Datenzugriffsseiten nicht verfügbar.

  3. Klicken Sie in dem Formular, in dem Bericht oder auf der Datenzugriffsseite auf die Stelle, an der das Steuerelement eingefügt werden soll. Wenn Sie das Steuerelement in eine Optionsgruppe in einem Formular oder Bericht einfügen möchten, markiert Microsoft Access die Optionsgruppe beim Darüberbewegen des Zeigers, um anzuzeigen, dass das Steuerelement Teil der Optionsgruppe wird.


Hinzufügen einer Spalte zum Entwurfsbereich einer Abfrage oder eines Spezialfilters

  1. Klicken Sie auf eine beliebige Stelle in der Spalte, auf deren rechter Seite Sie eine neue Spalte einfügen möchten.

  2. Klicken Sie im Menü Einfügen auf Spalte einfügen.


 Erstellen einer Befehlsschaltfläche, die eine E-Mail-Nachricht erstellt, wenn darauf geklickt wird

Erstellen einer Befehlsschaltfläche, die eine E-Mail-Nachricht erstellt, wenn darauf geklickt wird

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Wenn das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist, klicken Sie darauf, um die Steuerelement-Assistenten auszuschalten.

  3. Klicken Sie in der Toolbox auf das Tool Befehlsschaltfläche Das Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der die Befehlsschaltfläche platziert werden soll.

  5. Stellen Sie sicher, dass die Befehlsschaltfläche markiert ist, und klicken Sie danach in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für diese Befehlsschaltfläche zu öffnen.

  6. Klicken Sie in der Eigenschaft HyperlinkAdresse auf die Editor-Schaltfläche [image] .

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf E-Mail-Adresse.

  8. Geben Sie im Feld Text anzeigen als den Anzeigetext des Hyperlinks ein. Microsoft Access zeigt im Feld automatisch den Wert der Eigenschaft Beschriftung der Befehlsschaltfläche an.

  9. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink führt. Wenn Sie das Textfeld Infofelder leer lassen, zeigt Access die E-Mail-Adresse als Infofelder an.

  10. Geben Sie im Feld E-Mail-Adresse eine E-Mail-Adresse ein, oder klicken Sie in der Liste Zuletzt verwendete E-Mail-Adressen auf eine Adresse.

  11. Geben Sie im Feld Betreff die Informationen ein, die im Betreff-Feld der E-Mail-Nachricht angezeigt werden sollen.

    Anmerkung Es kann vorkommen, dass einige Webbrowser und E-Mail-Programme die Betreffzeile nicht erkennen.

  12. Klicken Sie auf OK.

    Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf die Befehlsschaltfläche, zeigen im Kontextmenü auf Hyperlink und klicken auf Öffnen. Wenn Sie auf den Hyperlink klicken, öffnet Access das Mailprogramm und erstellt eine neue Nachricht, in der Adresse und Betreff eingefügt sind.


 Erstellen einer Befehlsschaltfläche mit einem Hyperlink zu einer bestehenden Datei oder Webseite

Erstellen einer Befehlsschaltfläche mit einem Hyperlink zu einer bestehenden Datei oder Webseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Wenn das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist, klicken Sie darauf, um die Steuerelement-Assistenten auszuschalten.

  3. Klicken Sie in der Toolbox auf das Tool Befehlsschaltfläche Das Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der die Befehlsschaltfläche platziert werden soll.

  5. Stellen Sie sicher, dass die Befehlsschaltfläche markiert ist, und klicken Sie danach in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für diese Befehlsschaltfläche zu öffnen.

  6. Klicken Sie in der Eigenschaft HyperlinkAdresse auf die Editor-Schaltfläche [image] .

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Datei oder Webseite.

  8. Geben Sie im Feld Text anzeigen als den Anzeigetext des Hyperlinks ein. Microsoft Access zeigt im Feld automatisch den Wert der Eigenschaft Beschriftung der Befehlsschaltfläche an.

  9. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink führt. Wenn Sie das Textfeld Infofelder leer lassen, zeigt Access die Hyperlinkadresse (und Unteradresse) als Infofelder an.

  10. Geben Sie die Datei oder die Webseite, zu der Sie wechseln möchten, auf eine der folgenden Arten an:
    • Geben Sie im Feld Dateityp oder Webseite einen Pfad oder einen URL ein.

    • Klicken Sie unter Oder aus Liste auswählen auf Zuletzt verwendet, Besuchte Webseiten oder Eingefügte Hyperlinks. Klicken Sie anschließend auf ein Element in der Liste.

    • Klicken Sie auf Datei, um auf dem lokalen Computer, in einem Netzwerk oder auf einem FTP- oder HTTP-Server, auf den Sie zugreifen können, eine Datei zu suchen.

    • Klicken Sie auf Webseite, um eine Seite im Internet oder in einem Intranet zu suchen. Wenn Sie von Microsoft Internet Explorer oder einem anderen Webbrowsers zu Microsoft Access wechseln, setzt Access den URL der aktuell geöffneten Webseite in die Felder Dateityp oder Webseite.
  11. Um zu einer bestimmten Position in einer HTML-Datei oder zu einem Objekt in einer Microsoft Access-Datenbank (.mdb) oder in einem Microsoft Access-Projekt (.adp) zu wechseln, klicken Sie auf Textmarke. Klicken Sie in der Liste auf die gewünschte Textmarke oder das gewünschte Objekt und anschließend auf OK.

  12. Klicken Sie im Dialogfeld Hyperlink einfügen auf OK.

    Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf die Befehlsschaltfläche, zeigen im Kontextmenü auf Hyperlink und klicken danach auf Öffnen.


 Erstellen einer neuen Datenzugriffsseite und einer Befehlsschaltfläche mit einem Hyperlink zu dieser Seite

Erstellen einer neuen Datenzugriffsseite und einer Befehlsschaltfläche mit einem Hyperlink zu dieser Seite

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Wenn das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist, klicken Sie darauf, um die Steuerelement-Assistenten auszuschalten.

  3. Klicken Sie in der Toolbox auf das Tool Befehlsschaltfläche Das Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der die Befehlsschaltfläche platziert werden soll.

  5. Stellen Sie sicher, dass die Befehlsschaltfläche markiert ist, und klicken Sie danach in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für diese Befehlsschaltfläche zu öffnen.

  6. Klicken Sie in der Eigenschaft HyperlinkAdresse auf die Editor-Schaltfläche [image] .

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Neue Seite erstellen.

  8. Geben Sie im Feld Text anzeigen als den Anzeigetext des Hyperlinks ein. Microsoft Access zeigt im Feld automatisch den Wert der Eigenschaft Beschriftung der Befehlsschaltfläche an.

  9. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink führt. Wenn Sie das Textfeld Infofelder leer lassen, zeigt Access die Hyperlinkadresse als Infofelder an.

  10. Geben Sie im Feld Name des neuen Dokuments einen Namen für die Seite ein.

    Tipp Sie können einen anderen Dokumenttyp erstellen, z. B. eine Word-Datei oder eine Excel-Arbeitsmappe, indem Sie die aus drei Buchstaben bestehende Erweiterung für den zu erstellenden Dateityp eingeben. Sie können jedoch keine Microsoft Access-Datenbank (.mdb) und kein Microsoft Access-Projekt (.adp) erstellen.

  11. Microsoft Access erstellt eine neue Seite im aktuellen Ordner. Um einen anderen Pfad festzulegen, klicken Sie auf Ändern.

  12. Klicken Sie unter Zeitpunkt der Bearbeitung auf eine Option. Sie können die neue Seite sofort oder erst später bearbeiten.

  13. Klicken Sie auf OK.

    Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf die Befehlsschaltfläche, zeigen im Kontextmenü auf Hyperlink und klicken danach auf Öffnen.


 Erstellen einer Befehlsschaltfläche mit einem Hyperlink zu einem Objekt in der aktuellen Datenbank

Erstellen einer Befehlsschaltfläche mit einem Hyperlink zu einem Objekt in der aktuellen Datenbank

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Wenn das Tool Steuerelement-Assistenten [image] in der Toolbox aktiviert ist, klicken Sie darauf, um die Steuerelement-Assistenten auszuschalten.

  3. Klicken Sie in der Toolbox auf das Tool Befehlsschaltfläche Das Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular auf die Stelle, an der die Befehlsschaltfläche platziert werden soll.

  5. Stellen Sie sicher, dass die Befehlsschaltfläche markiert ist, und klicken Sie danach in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für diese Befehlsschaltfläche zu öffnen.

  6. Klicken Sie in der Eigenschaft HyperlinkAdresse auf die Editor-Schaltfläche [image] .

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Aktuelle Datenbank.

  8. Geben Sie im Feld Text anzeigen als den Anzeigetext des Hyperlinks ein. Microsoft Access zeigt im Feld automatisch den Wert der Eigenschaft Beschriftung der Befehlsschaltfläche an.

  9. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink führt. Wenn Sie das Textfeld Infofelder leer lassen, zeigt Access die Unteradresse des Hyperlinks als Infofelder an.

  10. Klicken Sie in der Liste auf das Datenbankobjekt, zu dem Sie wechseln möchten.

  11. Klicken Sie auf OK.

    Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf die Befehlsschaltfläche, zeigen im Kontextmenü auf Hyperlink und klicken danach auf Öffnen.

Anmerkung Um eine Verknüpfung zu einem Objekt in einer anderen Datenbank herzustellen, erstellen Sie eine Verknüpfung zu der Datenbankdatei und klicken danach auf Textmarke, um das Objekt auszuwählen.


 Hinzufügen eines Datenbankobjekts zu einer Gruppe

Hinzufügen eines Datenbankobjekts zu einer Gruppe

  1. Wechseln Sie zum Datenbankfenster, falls dies noch nicht geschehen ist. Sie können von beliebigen anderen Fenstern zum Datenbankfenster wechseln, indem Sie F11 drücken.

  2. Klicken Sie mit der rechten Maustaste auf das Datenbankobjekt, das Sie zu der Gruppe hinzufügen möchten. Sie können mit der rechten Maustaste auch auf eine Verknüpfung in einer Gruppe klicken, um sie zu einer anderen Gruppe hinzuzufügen.

  3. Zeigen Sie im Kontextmenü auf Zur Gruppe hinzufügen, und klicken Sie dann auf den Namen der Gruppe, der das Objekt hinzugefügt werden soll.

Anmerkungen

  • Beim Hinzufügen eines Objekts zu einer Gruppe wird in der Gruppe eine Verknüpfung zu dem Objekt erzeugt; der tatsächliche Speicherort des Objekts wird jedoch nicht verändert. Wenn Sie beispielsweise ein Formular zu einer Gruppe hinzufügen und dann im Datenbankfenster unter Objekte auf Formulare [image] klicken, befindet sich das Formular immer noch in der Liste aller Formulare.

  • Objekte oder Verknüpfungen können Sie einer Gruppe auch einfach hinzufügen, indem Sie sie aus der Liste Objekte auf das Symbol der gewünschten Gruppe ziehen.


 Erstellen eines Unterberichts durch Hinzufügen eines existierenden Berichts zu einem anderen existierenden Bericht

Erstellen eines Unterberichts durch Hinzufügen eines existierenden Berichts zu einem anderen existierenden Bericht

Wenn der Unterbericht mit dem Hauptbericht verknüpft werden soll, müssen Sie zuvor sicherstellen, dass Sie die korrekten Tabellenbeziehungen eingerichtet haben. Zum Anzeigen von Informationen klicken Sie auf [image] .

  1. Öffnen Sie den Bericht, den Sie als Hauptbericht verwenden möchten, in der Entwurfsansicht.

  2. Stellen Sie sicher, dass in der Toolbox das Tool Steuerelement-Assistenten [image] gedrückt ist.

  3. Drücken Sie F11, um zum Datenbankfenster zu wechseln.

  4. Ziehen Sie einen Bericht oder ein Datenblatt aus dem Datenbankfenster in den gewünschten Bereich des Hauptberichts.

Microsoft Access fügt dem Bericht ein Unterbericht-Steuerelement hinzu.

Anmerkungen

  • Um Informationen zum Verweisen auf den Wert eines Steuerelements in einem Unterbericht anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zur Fehlerbehandlung bei Unterberichten anzuzeigen, klicken Sie auf [image] .


 Hinzufügen von Feldern zum Entwurfsbereich einer Abfrage oder eines Spezialfilters

Hinzufügen von Feldern zum Entwurfsbereich einer Abfrage oder eines Spezialfilters

In einer Abfrage fügen Sie nur die Felder hinzu, deren Daten Sie anzeigen möchten, für die Sie Kriterien festlegen möchten, oder nach denen Sie gruppieren oder sortieren möchten. In einem Spezialfilter fügen Sie nur die Felder hinzu, die Sie zum Sortieren oder zum Festlegen von Kriterien verwenden möchten. Microsoft Access zeigt daraufhin automatisch alle Felder in den gefilterten Ergebnissen an.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht oder öffnen Sie ein Formular oder ein Datenblatt, und zeigen Sie das Fenster Spezialfilter/-sortierung an.

  2. Stellen Sie sicher, dass in einer Abfrage die Feldliste für die Tabelle oder Abfrage, die die gewünschten Felder enthält, im oberen Teil des Fensters erscheint. Sie können eine Tabelle oder Abfrage hinzufügen, wenn die benötigte Feldliste nicht in der Abfrage enthalten ist.

    Wie wird's gemacht?

    Im Fenster Spezialfilter/-sortierung zeigt Microsoft Access automatisch die Feldliste für die zugrunde liegende Tabelle, Abfrage oder SQL-Anweisung an. In diesem Fenster können Sie keine weiteren Tabellen oder Abfragen hinzufügen.

  3. Markieren Sie ein Feld oder mehrere Felder in der Feldliste, und ziehen Sie dieses bzw. diese in die Spalten im Raster.

    Wie wird's gemacht?


Hinzufügen oder Ändern einer Sortierreihenfolge

Was möchten Sie tun?

Datensätze unter Verwendung des Entwurfsbereichs einer Abfrage sortieren

Kriterien festlegen, wenn im Entwurfsbereich das Sternchen verwendet wird

Informationen zum Sortieren von Datensätzen anzeigen

Eine Sortierreihenfolge aus einer Tabelle, einer Abfrage oder einem Formular entfernen


 Erstellen eines Formulars mit mindestens zwei Seiten (Bildschirm)

Erstellen eines Formulars mit mindestens zwei Seiten (Bildschirm)

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Seitenwechsel

  3. Klicken Sie im Formular auf die Stelle, an der Sie den Seitenwechsel einfügen möchten. Positionieren Sie den Seitenwechsel ober- oder unterhalb eines Steuerelements, um zu vermeiden, dass die Daten in diesem Steuerelement auf zwei Seiten aufgeteilt werden.

    Microsoft Access kennzeichnet den Seitenwechsel am linken Rand des Formulars durch eine kurze, gepunktete Linie.

    Anmerkung Wenn Sie möchten, dass alle Seiten gleich groß sind und in jedem Fenster immer nur jeweils eine Seite angezeigt wird, müssen Sie das Formular so entwerfen, dass jeder Seitenwechsel den gleichen Abstand zum nächsten Seitenwechsel hat. Dazu positionieren Sie die Steuerelemente für den Seitenwechsel mit Hilfe des vertikalen Lineals.

  4. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen, und dann im Einstellungsfeld der Eigenschaft Zyklus auf Aktuelle Seite. Wenn die Eigenschaft Zyklus auf Aktuelle Seite festgelegt ist, können Sie nicht durch Drücken von TAB von einer Seite zur vorherigen oder zur nächsten Seite wechseln.

  5. Entfernen Sie die vertikale Bildlaufleiste, indem Sie die Eigenschaft Bildlaufleisten auf Nur Horizontal oder Nein einstellen.

  6. Wechseln Sie zur Formularansicht, um das Formular zu testen und seine Größe so zu ändern, dass nur jeweils eine Seite angezeigt wird. Sie können durch Drücken von BILD-AUF oder BILD-AB von einer Seite zur vorherigen oder zur nächsten Seite wechseln.

Anmerkungen

  • In der Entwurfsansicht können Sie auch andere Eigenschaften einstellen. So können Sie beispielsweise die Eigenschaft Rahmenart auf Dünn einstellen, damit die Größe des Formulars nicht geändert werden kann, oder die Eigenschaft MinMaxSchaltflächen auf Keine einstellen, so dass das Formular keine Minimieren- und Maximieren-Schaltflächen enthält. Darüber hinaus können Sie auf jeder Seite eine Befehlsschaltfläche hinzufügen, mit deren Hilfe Sie den Fokus auf die nächste oder die vorherige Seite verschieben können. Das Formular Personal (Seitenwechsel) in der Beispieldatenbank Nordwind enthält ein Beispiel für diese Art einer Befehlsschaltfläche. Um dieses Formular anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE des Office-Ordners, und öffnen Sie dann das Formular Personal (Seitenwechsel) in der Entwurfsansicht.

  • Ein Seitenwechsel ist in der Formularansicht nur sichtbar, wenn Sie für die Eigenschaft Standardansicht die Einstellung Einzelnes Formular festgelegt haben.

  • Wenn ein Formular in der Formularansicht angezeigt wird, kennzeichnet ein Seitenwechsel die Stelle, an die sich das Formular bewegt, wenn Sie durch Drücken von BILD-AUF oder BILD-AB einen Bildlauf durchführen. In gedruckten Formularen kennzeichnet ein Seitenwechsel den Anfang einer neuen Seite innerhalb eines Bereichs. Zum Einfügen eines Seitenwechsels am Anfang jedes neuen Bereichs verwenden Sie die Eigenschaft NeueSeite des Bereichs.


 Erstellen eines Bildes, das beim Anklicken eine E-Mail-Nachricht erzeugt

Erstellen eines Bildes, das beim Anklicken eine E-Mail-Nachricht erzeugt

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in einem Formular oder Bericht in der Toolbox auf die Schaltfläche Bild Bildrahmen-Steuerelement .

    Auf einer Datenzugriffsseite klicken Sie auf die Schaltfläche Hotspotbild Hotspotbild-Steuerelement .
  3. Klicken Sie auf die Stelle, an der Sie das Bild erstellen möchten.

  4. Suchen Sie im Dialogfeld Grafik einfügen das gewünschte Bild aus, und klicken Sie dann auf OK.

    Microsoft Access fügt ein Bild-Steuerelement zu dem Formular oder Bericht hinzu.

    Anmerkung Falls Sie ein Hotspotbild auf einer Datenzugriffsseite erstellen, fahren Sie mit Schritt 6 fort.

  5. Stellen Sie in dem Formular oder Bericht sicher, dass das Bild-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das zugehörige Eigenschaftenfenster für das Steuerelement zu öffnen.

  6. Klicken Sie in der Hyperlink-Adresse-Eigenschaft auf die Generator-Schaltfläche [image] , um das Dialogfeld Hyperlink einfügen zu öffnen.

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf E-Mail-Adresse.

  8. Klicken Sie auf Bildschirmtipp, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Bildschirmtipp leer lassen, zeigt Microsoft Access die E-Mail-Adresse als Text des Bildschirmtipps an.

  9. Geben Sie im Feld E-Mail-Adresse eine E-Mail-Adresse ein, oder wählen Sie eine Adresse aus der Liste Zuletzt verwendete E-Mail-Adressen aus.

  10. Geben Sie im Feld Betreff die Information ein, die in der Betreffzeile der E-Mail-Nachricht erscheinen soll.

    Anmerkung Manche Webbrowser und E-Mail-Programme erkennen die Betreffzeile möglicherweise nicht.

  11. Klicken Sie auf OK.

    Um die Verknüpfung in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bild, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen. Um die Verknüpfung auf einer Datenzugriffsseite zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf das Bild. Microsoft Access öffnet Ihr E-Mail-Programm und erstellt eine neue Nachricht mit bereits eingetragenen Adressen- und Betreff-Informationen.


 Erstellen eines Bildes als Hyperlink zu einer vorhandenen Datei oder Webseite

Erstellen eines Bildes als Hyperlink zu einer vorhandenen Datei oder Webseite

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in einem Formular oder Bericht in der Toolbox auf die Schaltfläche Bild Bildrahmen-Steuerelement .

    Auf einer Datenzugriffsseite klicken Sie auf die Schaltfläche Hotspotbild Hotspotbild-Steuerelement .
  3. Klicken Sie auf die Stelle, an der Sie das Bild erstellen möchten.

  4. Suchen Sie im Dialogfeld Grafik einfügen das gewünschte Bild aus, und klicken Sie dann auf OK.

    Microsoft Access fügt ein Bild-Steuerelement zu dem Formular oder Bericht hinzu.

    Anmerkung Falls Sie ein Hotspotbild auf einer Datenzugriffsseite erstellen, fahren Sie mit Schritt 6 fort.

  5. Stellen Sie in dem Formular oder Bericht sicher, dass das Bild-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das zugehörige Eigenschaftenfenster zu öffnen.

  6. Klicken Sie in der Hyperlink-Adresse-Eigenschaft auf die Generator-Schaltfläche [image] , um das Dialogfeld Hyperlink einfügen zu öffnen.

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Datei oder Webseite.

  8. Klicken Sie auf Bildschirmtipp, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Bildschirmtipp leer lassen, zeigt Microsoft Access die Hyperlinkadresse und/oder Subadresse als Text des Bildschirmtipps an.

  9. Geben Sie die Datei oder Webseite, zu der die Verknüpfung erstellt werden soll, mit einer der folgenden Methoden an:
    • Geben Sie im Feld Dateityp oder Webseite einen Pfad oder einen URL ein.

    • Klicken Sie unter Oder aus Liste auswählen auf Zuletzt verwendet, Besuchte Webseiten oder Eingefügte Hyperlinks. Klicken Sie dann auf ein Objekt in der Liste.

    • Klicken Sie auf Datei, um nach einer Datei auf Ihrem lokalen Rechner, im Netzwerk oder auf einem verfügbaren FTP- oder HTTP-Server zu suchen.

    • Klicken Sie auf Webseite, um nach einer Seite im Internet oder in einem Intranet zu suchen. Wenn sie von Microsoft Internet Explorer oder einem anderen Webbrowser zu Microsoft Access wechseln, trägt Access den URL der zu diesem Zeitpunkt geöffneten Webseite in das Feld Dateityp oder Webseite ein.
  10. Um zu einer bestimmten Stelle in einer HTML-Datei oder zu einem Objekt in einer Microsoft Access-Datenbank (.mdb) oder einem Microsoft Access-Projekt (.adp) zu gelangen, klicken Sie auf Textmarke. Klicken Sie in der Liste auf die gewünschte Textmarke oder das gewünschte Objekt und dann auf OK.

  11. Klicken Sie im Dialogfeld Hyperlink einfügen auf OK.

    Um die Verknüpfung in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bild, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie auf Öffnen.Um die Verknüpfung auf einer Datenzugriffsseite zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf das Bild.


 Erstellen einer neuen Datenzugriffsseite und eines Bildes, das als Hyperlink zu dieser Seite dient

Erstellen einer neuen Datenzugriffsseite und eines Bildes, das als Hyperlink zu dieser Seite dient

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in einem Formular oder Bericht in der Toolbox auf die Schaltfläche Bild Bildrahmen-Steuerelement .

    Auf einer Datenzugriffsseite klicken Sie auf die Schaltfläche Hotspotbild Hotspotbild-Steuerelement .

  3. Klicken Sie auf die Stelle, an der Sie das Bild erstellen möchten.

  4. Suchen Sie im Dialogfeld Grafik einfügen das gewünschte Bild aus, und klicken Sie dann auf OK.

    Microsoft Access fügt dem Formular oder Bericht ein Bild-Steuerelement hinzu.

    Anmerkung Falls Sie ein Hotspotbild auf einer Datenzugriffsseite erstellen, fahren Sie mit Schritt 6 fort.

  5. Stellen Sie in dem Formular oder Bericht sicher, dass das Bild-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das zugehörige Eigenschaftenfenster zu öffnen.

  6. Klicken Sie in der Hyperlink-Adresse-Eigenschaft auf die Generator-Schaltfläche [image] , um das Dialogfeld Hyperlink einfügen zu öffnen.

  7. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Neue Seite erstellen.

  8. Klicken Sie auf Bildschirmtipp, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Bildschirmtipp leer lassen, zeigt Microsoft Access die Hyperlinkadresse und/oder Subadresse als Text des Bildschirmtipps an.

  9. Geben Sie im Feld Name des neuen Dokuments einen Namen für die neue Datenzugriffsseite ein.

    Tipp Sie können auch andere Dokumenttypen erstellen - beispielsweise Microsoft Word-Dateien oder Microsoft Excel-Kalkulationstabellen - indem Sie die drei Zeichen lange Dateierweiterung für den gewünschten Dateityp mit eingeben. Sie können so jedoch weder eine Microsoft Access-Datenbank (.mdb) noch ein Microsoft Access-Projekt (.adp) erzeugen.

  10. Microsoft Access erstellt das neue Dokument in dem aktuellen Ordner. Um einen anderen Speicherort anzugeben, klicken Sie auf Ändern.

  11. Wählen Sie eine Option unter Zeitpunkt der Bearbeitung aus. Sie können das neue Dokument sofort oder erst zu einem späteren Zeitpunkt bearbeiten.

  12. Klicken Sie auf OK.

    Um die Verknüpfung in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bild, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.Um die Verknüpfung auf einer Datenzugriffsseite zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf das Bild.


 Erstellen eines Bildes, das als Hyperlink zu einem Objekt in der aktuellen Datenbank dient

Erstellen eines Bildes, das als Hyperlink zu einem Objekt in der aktuellen Datenbank dient

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Bild Bild und dann auf die Stelle, an der Sie das Bild erstellen möchten.

  3. Suchen Sie im Dialogfeld Grafik einfügen das gewünschte Bild aus, und klicken Sie dann auf OK.

    Microsoft Access fügt dem Formular oder Bericht ein Bild-Steuerelement hinzu.

  4. Stellen Sie sicher, dass das Bild-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das zugehörige Eigenschaftenfenster zu öffnen.

  5. Klicken Sie in der Hyperlink-Adresse-Eigenschaft auf die Generator-Schaltfläche [image] , um das Dialogfeld Hyperlink einfügen zu öffnen.

  6. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Aktuelle Datenbank.

  7. Klicken Sie auf Bildschirmtipps, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Bildschirmtipps leer lassen, zeigt Microsoft Access den Objektnamen als Text des Bildschirmtipps an.

  8. Wählen Sie aus der Liste das Datenbankobjekt, zu dem Sie den Hyperlink erstellen wollen.

  9. Klicken Sie auf OK.

    Um den Hyperlink zu testen, klicken Sie mit der rechten Maustaste auf das Bild, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.

Anmerkung Um eine Verknüpfung mit einem Objekt in einer anderen Datenbank zu bilden, erstellen Sie einen Link zu der Datenbankdatei, und klicken Sie dann auf Textmarke, um das Objekt auszuwählen.


 Hinzufügen eines vorhandenen Formulars zu einem anderen Formular zum Erstellen eines Formulars mit Unterformular

Hinzufügen eines vorhandenen Formulars zu einem anderen Formular zum Erstellen eines Formulars mit Unterformular

Stellen Sie vor dem Ausführen der nachfolgenden Schritte sicher, dass Sie Ihre Tabellenbeziehungentable korrekt definiert haben.

  1. Öffnen Sie das Formular, das Sie als Hauptformular verwenden möchten, in der Entwurfsansicht. Dies ist in der Regel ein Formular auf der Basis einer Tabelle oder Abfrage auf der "1"-Seite einer 1:n-Beziehung.

  2. Stellen Sie sicher, dass in der Toolbox das Tool Steuerlement-Assistenten [image] aktiviert ist.

  3. Drücken Sie F11, um zum Datenbankfenster zu wechseln.

  4. Ziehen Sie ein Formular, eine Tabelle oder eine Abfrage aus dem Datenbankfenster in das Hauptformular.

    Microsoft Access fügt zum Formular ein Unterformular-Steuerelement hinzu. Wenn Sie ein Formular aus der Formularansicht gezogen haben, zeigt Microsoft Access das Unterformular in dieser Ansicht an. Wenn Sie ein Formular herausgezogen haben, das in Datenblattansicht, als Tabelle oder als Abfrage angezeigt wurde, zeigt Microsoft Access das Unterformular als Datenblatt an.

Anmerkungen

  • Um Informationen zum Ändern des Layouts eines Unterformulars anzuzeigen, klicken Sie auf [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung in Unterformularen klicken Sie auf [image] .


 Hinzufügen einer Tabelle oder einer Abfrage zu einer Abfrage

Hinzufügen einer Tabelle oder einer Abfrage zu einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Klicken Sie auf der Symbolleiste auf Tabelle anzeigen [image] .

  3. Klicken Sie im Dialogfeld Tabelle anzeigen auf die Registerkarte, auf der die Objekte aufgeführt sind, die Sie hinzufügen möchten. Befindet sich die benötigte Tabelle in einer anderen Datenbank oder Anwendung, müssen Sie die Tabelle zuerst mit der aktiven Datenbank verknüpfen.

    Wie wird's gemacht?

  4. Klicken Sie auf den Namen des Objekts, das Sie zur Abfrage hinzufügen möchten. Zum gleichzeitigen Markieren mehrerer Objekte halten Sie die STRG-TASTE gedrückt und klicken dann nacheinander auf die einzelnen Objektnamen. Zum Markieren eines Objektblocks klicken Sie auf den ersten Namen des Objektblocks, halten die UMSCHALTTASTE gedrückt und klicken dann auf den letzten Namen des Blocks.

  5. Klicken Sie auf Hinzufügen und dann auf Schließen.

Anmerkungen

  • Sie können zum Hinzufügen einer Tabelle oder Abfrage zu einer Abfrage auch den Tabellen- bzw. Abfragenamen aus dem Datenbankfenster in den oberen Teil der Entwurfsansicht für Abfragen ziehen.

  • Wenn eine Abfrage auf mehreren Tabellen oder Abfragen basiert, müssen diese verknüpft sein. Zum Anzeigen von Informationen zum Verknüpfen von Tabellen klicken Sie auf [image] .


 Hinzufügen eines Textfeldes oder anderen Steuerelements zu einer bestehenden Gruppe

Hinzufügen eines Textfeldes oder anderen Steuerelements zu einer bestehenden Gruppe

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Halten Sie die UMSCHALTTASTE gedrückt, und wählen Sie das Steuerelement aus, das Sie der Gruppe hinzufügen möchten, und klicken Sie dann auf eine beliebiges Steuerelement in der Gruppe, um die Gruppe auszuwählen.

  3. Klicken Sie im Menü Format auf Gruppierung.


 Hinzufügen eines Überwachungsausdrucks zum Überwachungsfenster des Visual Basic-Editors

Hinzufügen eines Überwachungsausdrucks zum Überwachungsfenster des Visual Basic-Editors

  1. Öffnen Sie eine Prozedur im Code-Fenster.

  2. Klicken Sie im Menü Debuggen auf Überwachung hinzufügen.

  3. Wenn ein Ausdruck bereits im Code-Fenster markiert wurde, wird er automatisch im Dialogfeld angezeigt. Wird kein Ausdruck angezeigt, geben Sie den Ausdruck ein, der ausgewertet werden soll. Bei diesem Ausdruck kann es sich um eine Variable, eine Eigenschaft, einen Funktionsaufruf oder um jeden anderen gültigen Ausdruck handeln.

    Statt einen Ausdruck einzugeben, können Sie ihn auch im Code-Fenster markieren und in das Überwachungsfenster ziehen.

  4. Um den Bereich auszuwählen, für den der Ausdruck ausgewertet werden soll, wählen Sie unter Kontext einen Modul- und Prozedurkontext aus.

    Anmerkung Wählen Sie den für Ihre Anforderungen geeignetsten, kleinsten Gültigkeitsbereich. Die Auswahl aller Prozeduren oder Module kann die Codeausführung verlangsamen.

  5. Um zu definieren, wie das System auf den Überwachungsausdruck reagieren soll, wählen Sie unter Überwachungsarten eine Option aus.
    • Um den Wert des Überwachungsausdrucks anzuzeigen, klicken Sie auf Ausdruck untersuchen.

    • Um die Ausführung anzuhalten, wenn der Ausdruck als Wahr ausgewertet wird, klicken Sie auf Ausführung unterbrechen, wenn Wert 'Wahr' wird.

    • Um die Ausführung anzuhalten, wenn sich der Wert des Ausdrucks ändert, klicken Sie auf Ausführung unterbrechen, wenn Wert sich ändert.

Bei der Codeausführung zeigt das Überwachungsfenster den Wert des eingestellten Ausdrucks an. Um einen Überwachungsausdruck zu ändern, markieren Sie ihn im Überwachungsfenster, und klicken Sie dann im Menü Debuggen auf Überwachung bearbeiten. Um den Überwachungsausdruck zu löschen, klicken Sie im Dialogfeld Überwachung bearbeiten auf Löschen.


 Ändern der Bewegungsrichtung von Lauftext auf einer Datenzugriffsseite

Ändern der Bewegungsrichtung von Lauftext auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Lauftext-Steuerelement aus, und klicken Sie dann auf Eigenschaften [image] auf der Symbolleiste, um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn der Text im Steuerelement von rechts nach links laufen soll, klicken Sie auf Links im Einstellungsfenster für die Eigenschaft Richtung.

    • Damit der Text im Steuerelement von links nach rechts läuft, klicken Sie auf Rechts im Einstellungsfenster für die Eigenschaft Richtung.

    • Damit der Text im Steuerelement von oben nach unten läuft, klicken Sie auf Abwärts im Einstellungsfenster für die Eigenschaft Richtung.

    • Damit der Text im Steuerelement von unten nach oben läuft, klicken Sie auf Aufwärts im Einstellungsfenster für die Eigenschaft Richtung.


 Ändern der Größe eines Bildes in einem Bild-Steuerelement auf einer Datenzugriffsseite

Ändern der Größe eines Bildes in einem Bild-Steuerelement auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Bild-Steuerelement aus.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  4. Geben Sie in den Einstellungsfeldern der Height- und Width- Eigenschaften die gewünschten Maße in Pixel (px), Zentimetern (cm), Zoll (in) oder Punkt (pt) für das Bild an, das im Bild-Steuerelement angezeigt werden soll.


 Optimieren der Access-Datenbankperformance unter Verwendung des Leistungsanalyse-Assistenten

Optimieren der Access-Datenbankperformance unter Verwendung des Leistungsanalyse-Assistenten

Mit Hilfe des Leistungsanalyse-Assistenten können Sie die Leistung von Microsoft Access-Datenbanken optimieren. Sie können auch die Performance von Microsoft Access-Projekten optimieren; der Leistungsanalyse-Assistent steht jedoch nur in Access-Datenbanken zur Verfügung.

  1. Öffnen Sie die Access-Datenbank, die Sie optimieren möchten.

  2. Zeigen Sie im Menü Extras auf Analyse, und klicken Sie dann auf Leistung.

  3. Klicken Sie auf die Registerkarte für den Typ des Datenbankobjekts, das Sie optimieren möchten. Klicken Sie auf die Registerkarte Alle Objekttypen, um eine Liste aller Datenbankobjekte gleichzeitig anzuzeigen.

  4. Wählen Sie die Namen der zu optimierenden Datenbankobjekte aus. Klicken Sie auf Alle auswählen, um alle Datenbankobjekte der Liste auszuwählen.

  5. Wiederholen Sie die Schritte 3 und 4 so oft, bis Sie alle Objekte ausgewählt haben, die Sie optimieren möchten, und klicken Sie dann auf OK.

    Es wird eine Liste mit drei Arten von Optimierungen angezeigt: Empfehlungen, Vorschläge und Ideen. Wenn Sie auf ein Element der Liste Analyseergebnisse klicken, werden Informationen zu der vorgeschlagenen Optimierung im Feld Anmerkungen zur Analyse unter der Liste angezeigt. Optimierungsvorschläge besitzen mögliche Nachteile, die Sie bedenken sollten, bevor Sie die Optimierung durchführen. Eine Beschreibung der Nachteile wird angezeigt, wenn Sie auf einen Optimierungsvorschlag in der Liste klicken; lesen Sie dann die Informationen im Feld Anmerkungen zur Analyse. Microsoft Access kann Optimierungsempfehlungen und -vorschläge für Sie durchführen. Angegebene Ideen zur Optimierung müssen Sie selbst durchführen.

  6. Klicken Sie auf jede Optimierungsempfehlung oder jeden Optimierungsvorschlag, die/den Sie ausführen möchten, und klicken Sie dann auf Optimieren. Der Leistungsanalyse-Assistent führt daraufhin die Optimierungen durch und markiert sie dann entsprechend. Fahren Sie damit so lange fort, bis der Leistungsanalyse-Assistent alle gewünschten Optimierungsempfehlungen und -vorschläge vollständig durchgeführt hat.

    Wenn Sie alle Optimierungsempfehlungen oder -vorschläge ausführen möchten, klicken Sie auf Alle auswählen und dann auf Optimieren.

    Wenn Sie eine Idee zur Optimierung ausführen möchten, klicken Sie auf die Optimierung, und befolgen Sie anschließend die im Feld Anmerkungen zur Analyse angezeigten Anweisungen.

Anmerkung Der Leistungsanalyse-Assistent macht keine Vorschläge dazu, wie Sie die Leistung von Microsoft Access selbst oder von dem System, auf dem Microsoft Access ausgeführt wird, verbessern können. Zum Anzeigen weiterer Vorschläge zur Leistungsverbesserung in anderen, vom Leistungsanalyse-Assistent nicht behandelten Bereichen, klicken Sie auf [image] .


 Auswählen eines anderen Designs für die Datenzugriffsseite

Auswählen eines anderen Designs für die Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite, für die Sie ein neues Design auswählen möchten, in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Design.

  3. Klicken Sie in der Liste Design auswählen auf das gewünschte Design.


 Anwenden eines Designs auf eine vorhandene Datenzugriffsseite

Anwenden eines Designs auf eine vorhandene Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite, auf die Sie ein Design anwenden möchten, in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Design.

  3. Klicken Sie in der Liste Design auswählen auf das Design, das Sie anwenden möchten.

  4. Wählen Sie die gewünschten Optionen aus.

    Um Hilfe zu einer Option zu erhalten, klicken Sie auf das Fragezeichen [image] und dann auf die Option.


 Anwenden eines Designs auf eine neue Datenzugriffsseite

Anwenden eines Designs auf eine neue Datenzugriffsseite

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie in der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neue Seite auf Seiten-Assistent, und folgen Sie den Anweisungen im Assistenten.

  4. Aktivieren Sie im letzten Bildschirm im Assistenten das Kontrollkästchen Möchten Sie Ihrer Seite ein Design zuweisen?.


 Zuweisen einer Zugriffstaste zu einem Bezeichnungsfeld oder einer Schaltfläche in einem Formular oder Bericht

Zuweisen einer Zugriffstaste zu einem Bezeichnungsfeld oder einer Schaltfläche in einem Formular oder Bericht

Wenn Sie einem Bezeichnungsfeld oder einer Schaltfläche eine Zugriffstaste zugewiesen haben, können Sie durch die Tastenkombination ALT + einen gewählten Buchstaben den Fokus auf das dem Bezeichnungsfeld zugeordnete Steuerelement oder auf die Schaltfläche setzen.

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Bezeichnungsfeld oder die Schaltfläche, dem/der Sie die Zugriffstaste zuweisen möchten, ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements zu öffnen.

  3. Geben Sie im Einstellungsfeld der Caption-Eigenschaft direkt vor dem Zeichen, das Sie als Zugriffstaste verwenden möchten, ein Kaufmännisches Und-Zeichen (&) ein.


Umgang mit Berechtigungen

Was möchten Sie tun?

Informationen zur Funktionsweise von Berechtigungen und zu den Personen erhalten, die sie zuweisen können

Informationen über die verschiedenen Typen von Berechtigungen erhalten

Berechtigungen für eine Datenbank und vorhandene Tabellen, Abfragen, Formulare, Berichte und Makros zuweisen oder entfernen

Standardberechtigungen für neue Tabellen, Abfragen, Formulare, Berichte und Makros zuweisen

Anderen Personen die Berechtigung erteilen, meine Abfragen anzuzeigen und auszuführen, jedoch nicht Daten oder die Abfragestruktur zu verändern

Die Standardberechtigungen für alle neuen Abfragen ändern

Informationen über die RunPermissions-Eigenschaft erhalten


 Erstellen einer kompilierten Hilfedatei, die nach Drücken von F1 angezeigt wird

Erstellen einer kompilierten Hilfedatei, die nach Drücken von F1 angezeigt wird

  1. Erstellen Sie die Quelldatei mit Hilfe eines beliebigen Text-Editors oder Textverarbeitungsprogramms. Weitere Informationen zum Erstellen der Quelldatei finden Sie in der Hilfe, die im Lieferumfang von Microsoft Help Workshop enthalten ist. Speichern Sie die Quelldatei anschließend im .RTF-Format.

  2. Kompilieren Sie die Hilfedatei mit Hilfe von Microsoft Help Workshop.

  3. Zeigen Sie das Eigenschaftenfenster des Formulars oder Berichts an, und geben Sie im Einstellungsfeld der HelpFile-Eigenschaft den Dateinamen der kompilierten Hilfedatei an.

    Anmerkung Es ist sinnvoll, die Hilfedatei in dem Ordner zu speichern, in dem sich auch Ihre Anwendung befindet. Auf diese Weise ist die Einstellung der HelpFile-Eigenschaft für alle Benutzer/innen, die mit Ihrer Anwendung arbeiten, geeignet und gibt diesen dennoch die Möglichkeit, die Anwendung in einem Ordner ihrer Wahl zu installieren. Wenn Sie als Einstellung für diese Eigenschaft keinen Pfad angeben, sucht Microsoft Access in dem Ordner nach der Hilfedatei, in dem Ihre Anwendung installiert wurde.

  4. Geben Sie im Einstellungsfeld der HelpContextID-Eigenschaft des Formulars oder Berichts die Nummer des Themas (eine Zahl ungleich 0) ein, das angezeigt wird, wenn ein/e Benutzer/in F1 drückt. Dieses Thema dient im Allgemeinen als Unterstützung für das gesamte Formular oder den gesamten Bericht.

  5. Geben Sie im Einstellungsfeld der HelpcontextID-Eigenschaft eines beliebigen Steuerelements im Formular, das den Fokus erhalten kann, die Nummer des Themas ein, das angezeigt wird, wenn ein/e Benutzer/in F1 drückt. Dieses Thema stellt dann Hilfe zu diesem speziellen Steuerelement zur Verfügung.

Anmerkungen

  • Sie müssen die als Einstellung der HelpContextID-Eigenschaft angegebenen Werte den Kontextzeichenfolgen Ihres Hilfesystems zuordnen. Weitere Informationen finden Sie in der Hilfe, die im Lieferumfang von Microsoft Help Workshop enthalten ist.

  • Wenn beim Drücken von F1 ein Steuerelement den Fokus besitzt, dem kein benutzerdefiniertes Hilfethema zugeordnet ist, wird das benutzerdefinierte Hilfethema des Formulars angezeigt. Wenn auch das Formular kein benutzerdefiniertes Hilfethema besitzt, zeigt Microsoft Access das Dialogfeld Office-Assistent an.

  • Sie können keine benutzerdefinierte Hilfe über den Office-Assistenten anzeigen.

  • Hilfedateien können Sie auch mit Microsoft HTML Help Workshop erstellen. Weitere Informationen über das Erstellen von eigenen Hilfedateien finden Sie unter "Adding Help to Your Custom Solution" im Microsoft Office 2000/Visual Basic-Programmierhandbuch. Hinweise zum Bezug dieses Buches.


 Automatisieren des Importierens, Exportierens und Verknüpfens von Daten unter Verwendung von Makros

Automatisieren des Importierens, Exportierens und Verknüpfens von Daten unter Verwendung von Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Wählen Sie eine der folgenden Möglichkeiten:

    Um Daten zwischen der aktuellen Microsoft Access-Datenbank und einer anderen Datenbank zu importieren, exportieren oder zu verknüpfen, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf TransferDatenbank.

    Um Daten zwischen der aktuellen Access-Datenbank und einer Tabellenkalkulationsdatei zu importieren, exportieren oder zu verknüpfen, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf TransferArbeitsblatt.

    Um Daten zwischen der aktuellen Access-Datenbank und einer Textdatei zu importieren, exportieren oder zu verknüpfen, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf TransferText.

  3. Geben Sie die entsprechenden Argumente für die Aktion an.

  4. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  5. Führen Sie das Makro aus.

    Wie wird's gemacht?

Um weitere Informationen über die Aktion TransferDatenbank zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über die Aktion TransferArbeitsblatt zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über die Aktion TransferText zu erhalten, klicken Sie auf [image] .


Automatisieren des Importierens, Exportierens und Verknüpfens von Daten unter Verwendung von Visual Basic

  1. Erstellen Sie eine Visual Basic-Prozedur.

    Wie wird's gemacht?

  2. Wählen Sie eine der folgenden Möglichkeiten:

    Um Daten zwischen der aktuellen Microsoft Access-Datenbank und einer anderen Datenbank zu importieren, exportieren oder zu verknüpfen, verwenden Sie die Methode TransferDatabase, so dass Sie die Aktion TransferDatenbank in der Prozedur ausführen können.

    Wie wird's gemacht?

    Um Daten zwischen der aktuellen Microsoft-Datenbank und einer Tabellenkalkulationsdatei zu importieren, exportieren oder zu verknüpfen, verwenden Sie die TransferSpreadsheet-Methode, so dass Sie die Aktion TransferArbeitsblatt in der Prozedur ausführen können.

    Um Daten zwischen der aktuellen Microsoft-Datenbank und einer Textdatei zu importieren, exportieren oder zu verknüpfen, verwenden Sie die TransferText-Methode, so dass Sie die Aktion TransferText in der Prozedur ausführen können.

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Um weitere Informationen über die TransferDatabase-Methode zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über die Aktion TransferArbeitsblatt zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über die Aktion TransferText zu erhalten, klicken Sie auf [image] .


 Automatisches Komprimieren von Access-Datenbanken oder Access-Projekten beim Schließen

Automatisches Komprimieren von Access-Datenbanken oder Access-Projekten beim Schließen

Microsoft Access kann eine Microsoft Access-Datenbank oder ein Microsoft Access-Projekt bei jedem Schließen automatisch komprimieren.

  1. Öffnen Sie die Access-Datenbank oder das Access-Projekt, das Microsoft Access automatisch komprimieren soll.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Allgemein.

  4. Aktivieren Sie das Kontrollkästchen Beim Schließen komprimieren.

Anmerkung Eine Komprimierung erfolgt nicht, wenn Sie eine (freigegebene) Mehrbenutzerdatenbank schließen, die noch von einem anderen Benutzer verwendet wird.


 Automatisches Anzeigen der aktuellen Datensätze eines Formulars unter Verwendung eines Makros

Automatisches Anzeigen der aktuellen Datensätze eines Formulars unter Verwendung eines Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Klicken Sie in einer leeren Aktionszeile in der Aktionsliste auf AktualisierenDaten.

    Um die Datensätze eines Steuerelements, das auf einer Tabelle oder Abfrage basiert, zu aktualisieren, geben Sie für das Argument Steuerelementname den Namen des entsprechenden Steuerelements an. Um die Daten eines gesamten Formulars zu aktualisieren, lassen Sie das Argument Steuerelementname frei.

  3. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  4. Führen Sie das Makro aus.

    Wie wird's gemacht?

Um weitere Informationen über die Aktion AktualisierenDaten zu erhalten, klicken Sie auf [image] .


 Automatisches Anzeigen der aktuellen Datensätze eines Formulars unter Verwendung von Visual Basic

Automatisches Anzeigen der aktuellen Datensätze eines Formulars unter Verwendung von Visual Basic

  1. Erstellen Sie eine Visual Basic-Prozedur.

    Wie wird's gemacht?

  2. Fügen Sie der Prozedur die Methode Requery für das Formular oder Steuerelement hinzu, dessen Datensätze Sie aktualisieren möchten. Um beispielsweise die aktuellen Datensätze eines Kombinationsfelds namens Kategorie-Nr anzuzeigen, fügen Sie der Prozedur die folgende Methode hinzu:
    Me![Kategorie-Nr].Requery

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Um weitere Informationen zur Requery-Methode zu erhalten, klicken Sie auf [image] .


 Binden eines leeren Formulars oder Berichts an Daten einer Tabelle oder einer anderen Datenherkunft

Binden eines leeren Formulars oder Berichts an Daten einer Tabelle oder einer anderen Datenherkunft

  1. Doppelklicken Sie in der Entwurfsansicht eines Formulars oder in der Entwurfsansicht eines Berichts auf den Formularmarkierer bzw. den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  2. Klicken Sie auf den Pfeil neben dem Einstellungsfeld der Eigenschaft Datenherkunft, und treffen Sie eine Auswahl aus einer Liste mit Tabellen oder Abfragen.

  3. Fügen Sie dem Formular oder Bericht mit Hilfe der Feldliste bestimmte Steuerelemente hinzu, die an die Felder in der Datenherkunft gebunden sind.

Wechseln Sie zur Formularansicht bzw. zur Datenblattansicht, um die Daten im Formular anzuzeigen. Wechseln Sie zur Seitenansicht, um die Daten im Bericht anzuzeigen.


 Berechnen einer Summe, eines Durchschnittswertes, einer Anzahl oder einer anderen Funktion für alle Datensätze in einer Abfrage

Berechnen einer Summe, eines Durchschnittswertes, einer Anzahl oder einer anderen Funktion für alle Datensätze in einer Abfrage

  1. Erstellen Sie in der Entwurfsansicht eine Auswahlabfrage. Fügen Sie die Tabellen hinzu, deren Datensätze Sie in die Berechnung einbeziehen möchten. Fügen Sie dann die Felder hinzu, für die Sie Berechnungen durchführen und Kriterien festlegen möchten.

  2. Klicken Sie auf der Symbolleiste auf Funktionen [image] .

    Microsoft Access zeigt daraufhin die Zeile Funktion im Entwurfsbereich an.

  3. Klicken Sie für jedes Feld im Entwurfsbereich auf die entsprechende Zelle in der Zeile Funktion, und klicken Sie dann auf eine der folgenden Aggregatfunktionen: Summe, Mittelwert, Min, Max, Anzahl, StAbw oder Varianz.

    Aggregatfunktionen in der Zeile "Funktion" auswählen

    Um Informationen zu den einzelnen Aggregatfunktionen zu erhalten, klicken Sie auf [image] . (Um spezielle Anhaltspunkte zur Verwendung der Funktionen First und Last zu erhalten, klicken Sie auf [image] .

  4. Geben Sie ggf. Kriterien ein, um das Ergebnis der Berechnung zu beeinflussen.

    Wie wird's gemacht?

  5. Sortieren Sie das Ergebnis, wenn Sie dies wünschen.

    Wie wird's gemacht?

  6. Klicken Sie in der Symbolleiste auf Ansicht [image] , um das Ergebnis anzuzeigen.

Wenn das Ergebnis nicht dem entspricht, was Sie erwartet haben, klicken Sie auf [image] .

Anmerkungen

  • Wenn Sie für ein Feld eine Aggregatfunktion verwenden, verknüpft Microsoft Access den Funktions- mit dem Feldnamen und gibt dem Feld im Datenblatt den so entstandenen Namen (z.B. Mittelwert von Frachtkosten). Um Informationen zum Umbenennen solcher Felder zur leichteren Bestimmung Ihres Inhalts zu erhalten, klicken Sie auf [image] .

  • Wenn Sie ein berechnetes Feld, das eine oder mehrere Aggregatfunktionen enthält, einer Abfrage hinzufügen, in der Sie für sämtliche Datensätze Funktionen ausführen, müssen Sie in der Zeile Funktion die Zelle für das berechnete Feld auf Ausdruck einstellen.


 Berechnen einer Summe, eines Durchschnittswertes, einer Anzahl oder einer anderen Funktion für Datensatzgruppen in einer Abfrage

Berechnen einer Summe, eines Durchschnittswertes, einer Anzahl oder einer anderen Funktion für Datensatzgruppen in einer Abfrage

  1. Erstellen Sie in der Entwurfsansicht eine Auswahlabfrage. Fügen Sie die Tabellen hinzu, deren Datensätze Sie in die Berechnung einbeziehen möchten. Fügen Sie dann die Felder hinzu, für die Sie Berechnungen durchführen, Gruppierungen definieren oder Kriterien festlegen möchten.

  2. Klicken Sie auf der Symbolleiste auf Funktionen [image] .

    Microsoft Access zeigt daraufhin die Zeile Funktion im Entwurfsbereich an.

  3. Lassen Sie in der Zeile Funktion für das Feld oder die Felder, das bzw. die Sie gruppieren möchten, Gruppierung stehen.

  4. Klicken Sie für jedes zu berechnende Feld auf die entsprechende Zelle in der Zeile Funktion, und klicken Sie dann auf eine der folgenden Aggregatfunktionen: Summe, Mittelwert, Min, Max, Anzahl, StAbw oder Varianz.

    Aggregatfunktionen in der Zeile "Funktion" auswählen

    Um Informationen zu den einzelnen Aggregatfunktionen zu erhalten, klicken Sie auf [image] . (Um spezielle Anhaltspunkte zur Verwendung der Funktionen First und Last zu erhalten, klicken Sie auf [image] .

  5. Geben Sie ggf. Kriterien ein, um das Ergebnis der Berechnung zu beeinflussen.

    Wie wird's gemacht?

  6. Sortieren Sie das Ergebnis, wenn Sie möchten.

    Wie wird's gemacht?

  7. Klicken Sie in der Symbolleiste auf Ansicht [image] , um das Ergebnis anzuzeigen.

Wenn das Ergebnis nicht dem entspricht, was Sie erwartet haben, klicken Sie auf [image] .

Anmerkungen

  • Wenn Sie für ein Feld eine Aggregatfunktion verwenden, verknüpft Microsoft Access den Funktions- mit dem Feldnamen und gibt dem Feld im Datenblatt den so entstandenen Namen (z.B. Mittelwert von Frachtkosten). Um Informationen zum Umbenennen solcher Felder zur leichteren Bestimmung Ihres Inhalts zu erhalten, klicken Sie auf [image] .

  • Wenn Sie ein berechnetes Feld hinzufügen, dessen Ausdruck eine oder mehrere Aggregatfunktionen enthält, müssen Sie in der Zeile Funktion die Zelle für das berechnete Feld auf Ausdruck einstellen.

  • Um eine Kreuztabellenabfrage zu erstellen, die Funktionsergebnisse bezogen auf den linken Rand und die erste Zeile des Datenblattes gruppiert, klicken Sie auf [image] .

  • Die Abfrage Umsätze nach Kategorie für 1995 der Nordwind-Datenbank enthält ein Beispiel zur Berechnung einer Summe für Datensatzgruppen. Um diese Abfrage anzuschauen, öffnen Sie die Nordwind-Datenbank im Unterordner BEISPIEL des Office-Ordners, und öffnen Sie dann die Abfrage Umsätze nach Kategorie für 1995 in der Entwurfsansicht. Um Informationen zum Öffnen der Nordwind-Datenbank zu erhalten, klicken Sie auf [image] .


 Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer gruppierten Datenzugriffsseite

Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer gruppierten Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Falls der Ausdruck Bezüge auf Feldnamen enthält, müssen die Felder in der Datendefinition der Seite aufgeführt sein. Sie können entweder die Felder als gebundene HTML-Steuerelemente zu der Seite hinzufügen oder die Felder als gebundene Textfelder hinzufügen.

    Tipp Die Seite wird in der Seitenansicht und in Microsoft Internet Explorer schneller geladen, wenn Sie gebundene HTML-Steuerelemente verwenden.

  3. Erstellen Sie ein neues Steuerelement, indem Sie auf Gebundenes HTML-Text-Steuerelement Gebundenes HTML-Steuerelement oder Textfeld Textfeld-Steuerelement in der Toolbox klicken und dann die Maustaste an der Stelle loslassen, an der die linke obere Ecke des Steuerelements auf der Seite angeordnet werden soll.

  4. Um das Eigenschaftenfenster anzuzeigen, stellen Sie sicher, dass das Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  5. Geben Sie im Einstellfeld der ControlSource-Eigenschaft einen Aliasnamen und einen geeigneten Ausdruck ein. Um Bezüge zu Feldern auf der Datenzugriffsseite herzustellen, verwenden Sie die Feldnamen in dem Ausdruck. Beispiel: Wenn Sie den Verkaufspreis für einen Datensatz in der Tabelle Bestelldetails berechnen wollen, geben Sie Folgendes ein:

    Verkaufspreis: Einzelpreis*Count

    Wenn Sie keinen Aliasnamen angeben, müssen Sie ein Gleichheitszeichen (=) vor den Ausdruck setzen. Access trägt dann automatisch einen Aliasnamen ein, beispielsweise Expr1.

Anmerkungen

  • Falls die Werte der in dem Ausdruck enthaltenen Felder in der Seitenansicht oder in Internet Explorer nicht angezeigt werden sollen, können Sie die Steuerelemente ausblenden oder die Steuerelemente löschen. Auch wenn Sie nach der Definition des Ausdrucks die Steuerelemente wieder löschen, bleiben die Felder in der Datendefinition der Seite erhalten.

  • Wenn eine Datenzugriffsseite auf einer Abfrage basiert, können Sie den Ausdruck auch in die der Seite zugrunde liegende Abfrage einfügen. Bei der Berechnung von Summen aus Datensatzgruppen ist es einfacher, den Namen eines berechneten Feldes zu verwenden.

  • Zeigen Sie Beispiele für weitere Ausdrücke an, die Sie zur Berechnung von Werten für einen Datensatz verwenden können.

  • Weitere Informationen über das Erstellen von Ausdrücken in Microsoft Access-Datenbanken (.mdb) anzeigen.

  • Weitere Informationen über das Erstellen von Ausdrücken in Microsoft Access-Projekten (.adp) anzeigen.

  • Verwenden Sie für komplexere Berechnungen mit Tabellenkalkulationsfunktionen das Tabellen-Steuerelement.


 Ändern, Hinzufügen oder Löschen bedingter Formatierungen für ein Steuerelement

Ändern, Hinzufügen oder Löschen bedingter Formatierungen für ein Steuerelement

  1. Öffnen Sie das Formular in der Entwurfsansicht oder Formularansicht bzw. den Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement ausgewählt ist, und klicken Sie dann im Menü Format auf Bedingte Formatierung.

  3. Führen Sie einen der folgenden Schritte durch:
    • Um eine bestehende Bedingung zu ändern, wählen Sie die Schriftart, Farbe oder sonstige Formatierung aus, die Sie anwenden möchten.

    • Um eine neue Bedingung hinzuzufügen, klicken Sie auf Hinzufügen.

    • Um eine oder mehrere Bedingungen zu entfernen, klicken Sie auf Löschen, und aktivieren Sie dann das Kontrollkästchen der Bedingung(en), die Sie löschen möchten.
  4. Klicken Sie auf OK.

Anmerkung Bedingte Formatierung wird bei der Ausgabe bzw. beim Exportieren eines Formulars oder eines Berichtes in ein anderes Dateiformat nicht beibehalten.


 Ändern der Farbe eines Steuerelements, das den Fokus in einem Formular hat

Ändern der Farbe eines Steuerelements, das den Fokus in einem Formular hat

  1. Öffnen Sie das Formular in der Entwurfsansicht oder in der Formularansicht.

  2. Vergewissern Sie sich, dass das Steuerelement ausgewählt ist, und klicken Sie dann im Menü Format auf Bedingte Formatierung.

  3. Klicken Sie im Bereich Bedingung x des Dialogfeldes Bedingte Formatierung auf Feld hat Fokus im ersten Feld.

  4. Wählen Sie die Schriftart, Farbe oder sonstige Formatierungen aus, die das Feld annehmen soll, wenn es den Fokus hat.

Anmerkung Wenn Sie das Dialogfeld Bedingte Formatierung öffnen, zeigt es die aktuelle Standardformatierung für das ausgewählte Steuerelement an, beispielsweise die Farbe und Schriftart sowie sämtliche Ausdrücke, die Sie für dieses Feld möglicherweise definiert haben.


 Ändern der Breite einer Spalte im Entwurfsbereich einer Abfrage oder eines Spezialfilters

Ändern der Breite einer Spalte im Entwurfsbereich einer Abfrage oder eines Spezialfilters

  1. Bewegen Sie den Zeiger in der Entwurfsansicht für Abfragen oder im Fenster Spezialfilter/-sortierung auf den rechten Rand des Spaltenmarkierers der Spalte, die Sie ändern möchten, bis der Zeiger in Form eines Doppelpfeils erscheint.

  2. Ziehen Sie den Rand nach links, wenn Sie die Spalte schmaler machen möchten, oder nach rechts, wenn Sie die Spalte verbreitern möchten (oder doppelklicken Sie darauf, um die Spalte dem längsten sichtbaren Eintrag des Entwurfsbereichs anzupassen).

    Ziehen Sie den rechten Rand einer Spalte, um die Spaltenbreite zu ändern

Anmerkungen

  • Zum gleichzeitigen Anpassen der Breite mehrerer Spalten markieren Sie die Spalten. Dazu ziehen Sie über die Spaltenmarkierer dieser Spalten. Anschließend wenden Sie das vorstehend beschriebene Verfahren an.

  • Das Anpassen von Spaltenbreiten in der Entwurfsansicht oder im Fenster Spezialfilter/-sortierung hat keinen Einfluss auf die Spaltenbreite in der Datenblattansicht der Abfrage oder des Filters.


 Ändern der Standardeinstellung für neue Steuerelemente in Formularen oder Berichten auf der Basis eines vorhandenen Steuerelements

Ändern der Standardeinstellung für neue Steuerelemente in Formularen oder Berichten auf der Basis eines vorhandenen Steuerelements

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Markieren Sie das Steuerelement mit den Eigenschaften, die Sie als Standardeinstellungen verwenden möchten.

  3. Klicken Sie im Menü Format auf Standardsteuerelementeinstellungen.

    Microsoft Access legt die Standardeigenschaften für diesen Steuerelementtyp auf der Basis des markierten Steuerelements fest.

Tipp Sie können die Formateigenschaften eines Steuerelements für ein anderes Steuerelement kopieren. Dazu klicken Sie in der Symbolleiste auf Format übertragen [image] . Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Ändern der Standardeinstellung für neue Steuerelemente in Formularen oder Berichten mit Hilfe des Eigenschaftenfensters

Ändern der Standardeinstellung für neue Steuerelemente in Formularen oder Berichten mit Hilfe des Eigenschaftenfensters

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement für den Steuerelementtyp, den Sie ändern möchten. Klicken Sie zum Beispiel auf das Steuerelement Textfeld Textfeld-Steuerelement , wenn Sie die Standardsteuerelementeinstellung für Textfelder ändern möchten.

  3. Klicken Sie auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

    Microsoft Access ändert die Titelleiste des Eigenschaftenfensters so, dass ersichtlich wird, dass Sie das Eigenschaftenfenster für die Standardeigenschaften für diesen Steuerelementtyp geöffnet haben.

  4. Ändern Sie im Eigenschaftenfenster die gewünschten Eigenschafteneinstellungen.


Ändern der beim Öffnen der Datenbank automatisch angezeigten Übersicht

  1. Öffnen Sie die Datenbank.

  2. Führen Sie eine der folgenden Aktionen aus, um das Dialogfeld Übersichts-Manager zu öffnen:
    • Wenn Sie die Übersicht unter Verwendung des Datenbank-Assistenten erstellt haben, klicken Sie in der Eröffnungsübersicht auf Übersichtselemente ändern.

    • Wenn Sie die Übersicht unter Verwendung des Übersichts-Managers erstellt haben, klicken Sie im Menü Extras auf Add-Ins und dann auf Übersichts-Manager.
  3. Wenn die Übersicht, die Sie als Eröffnungsübersicht verwenden möchten, im Feld Übersichtsseiten angezeigt wird, klicken Sie darauf, andernfalls erstellen Sie die Übersicht.

    Wie wird's gemacht?

  4. Klicken Sie auf Standard.

    Beim nächsten Öffnen der Datenbank zeigt Microsoft Access automatisch die angegebene Übersicht an.


Ändern einer bestehenden Übersicht

  1. Öffnen Sie die Datenbank.

  2. Führen Sie eine der folgenden Aktionen aus, um das Dialogfeld Übersichts-Manager zu öffnen:
    • Wenn Sie die Übersicht unter Verwendung des Datenbank-Assistenten erstellt haben, klicken Sie in der Eröffnungsübersicht auf Übersichtselemente ändern.

    • Wenn Sie die Übersicht unter Verwendung des Übersichts-Managers erstellt haben, klicken Sie im Menü Extras auf Add-Ins und dann auf Übersichts-Manager.
  3. Klicken Sie auf die Übersicht, die Sie bearbeiten möchten, und dann auf Bearbeiten.

  4. Klicken Sie in der Übersicht auf das Element, das Sie ändern möchten, und führen Sie dann eine der folgenden Aktionen aus:
    • Klicken Sie auf Bearbeiten, wenn Sie den Text eines Elements, den von diesem Element ausgeführten Befehl oder das Objekt ändern möchten, das beim Klicken auf die jeweilige Schaltfläche geöffnet oder ausgeführt werden soll.

    • Klicken Sie auf Neu, wenn Sie ein Element hinzufügen möchten. Geben Sie den Text für das Element ein, und klicken Sie anschließend im Feld Befehl auf einen Befehl. Abhängig davon, auf welchen Befehl Sie klicken, zeigt Microsoft Access unterhalb des Feldes Befehl ein weiteres Feld an. Klicken Sie in diesem Feld gegebenenfalls auf ein Element. Wenn Sie z.B. im Feld Befehl auf einen der Formularbefehle geklickt haben, klicken Sie auf den Namen des Formulars, das Sie öffnen möchten.

    • Klicken Sie auf Löschen, wenn Sie ein Element löschen möchten.

    • Klicken Sie auf Aufwärts oder Abwärts, wenn Sie ein Element verschieben möchten.
  5. Klicken Sie auf Schließen, wenn Sie die gewünschten Änderungen durchgeführt haben.


 Ändern der Beschriftung eines Feldes aus einer Abfrage

Ändern der Beschriftung eines Feldes aus einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Klicken Sie im Entwurfsbereich auf eine beliebige Stelle in der Spalte des Feldes, dessen Beschriftung Sie ändern möchten. Klicken Sie anschließend auf der Symbolleiste auf Eigenschaften [image] .

  3. Geben Sie im Einstellungsfeld für die Eigenschaft Beschriftung die neue Beschriftung des Feldes ein.


 Ändern eines Feldnamens in der Datenblattansicht

Ändern eines Feldnamens in der Datenblattansicht

  1. Öffnen Sie die Tabelle in der Datenblattansicht.

  2. Doppelklicken Sie auf den Feldmarkierer des Feldes, das Sie ändern möchten.

    Anmerkung Wenn für dieses Feld die Eigenschaft Beschriftung eingestellt wurde, unterscheidet sich der im Feldmarkierer angezeigte Text möglicherweise vom tatsächlichen Feldnamen. Doppelklicken Sie in einem solchen Fall auf den Feldmarkierer, wird der Beschriftungstext durch den Feldnamen ersetzt. Wenn Sie dann fortfahren, bearbeiten Sie den Feldnamen, und wenn Sie die EINGABETASTE drücken, um diese Änderung zu speichern, wird der Beschriftungstext gelöscht. Soll der Beschriftungstext nicht gelöscht werden, drücken Sie nach dem Doppelklicken auf den Feldmarkierer sofort ESC, um die Bearbeitung abzubrechen. Um Informationen zum Verwenden der Eigenschaft Beschriftung anzuzeigen, klicken Sie auf [image] .

  3. Geben Sie den neuen Feldnamen entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Drücken Sie die EINGABETASTE, um den neuen Namen zu speichern.

Vorsicht Wenn in Ausdrücken oder Visual Basic für Applikationen-Code Verweise auf ein Feld enthalten sind, dessen Name Sie geändert haben, aktualisieren Sie alle Verweise mit dem neuen Namen.


 Ändern eines Feldnamens in der Entwurfsansicht

Ändern eines Feldnamens in der Entwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Feldnamen, den Sie ändern möchten.

  3. Geben Sie den neuen Feldnamen entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Symbolleiste auf Speichern [image] , um Ihre Änderungen zu speichern.

Vorsicht Wenn in Ausdrücken oder Visual Basic für Applikationen-Code Verweise auf ein Feld enthalten sind, dessen Name Sie geändert haben, aktualisieren Sie alle Verweise mit dem neuen Namen.


 Ändern des Formats der Daten in einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

Ändern des Formats der Daten in einem Textfeld oder anderen Steuerelement in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Format auf eine der vordefinierten Formateinstellungen. Sie können ein eigenes Format erstellen, wenn das vordefinierte Format Ihren Erwartungen nicht entspricht. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkungen

Um die Konsistenz zwischen verschiedenen Anwendungen sicherzustellen, verwendet Microsoft Access die in der Microsoft Windows-Systemsteuerung für einige vordefinierte Zahlen- und Datum-/Uhrzeitformate festgelegten Ländereinstellungen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Für Steuerelemente, in denen Zahlen angezeigt werden, können Sie auch die Einstellung der Eigenschaft Dezimalstellenanzeige setzen.


 Ändern des Datenformats eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht, wenn bestimmte Kriterien erfüllt sind

Ändern des Datenformats eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht, wenn bestimmte Kriterien erfüllt sind

  1. Öffnen Sie das Formular in der Entwurfsansicht oder Formularansicht bzw. den Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement ausgewählt ist, und klicken Sie dann im Menü Format auf Bedingte Formatierung.

  3. Führen Sie einen der folgenden Schritte durch:
    • Um Werte in dem ausgewählten Steuerelement als Formatierungskriterien zu verwenden, klicken Sie im ersten Feld auf Feldwert ist, danach auf den Vergleichstext im zweiten Feld, und geben Sie anschließend einen Wert im dritten (und vierten) Feld ein. Sie können als Wert eine Konstante oder einen Ausdruck eingeben.

    • Wenn Sie einen Ausdruck als Formatierungskriterium verwenden möchten (um Daten oder eine andere Bedingung als die Werte in den ausgewählten Steuerelementen zu bewerten), klicken Sie im ersten Feld auf Ausdruck ist, und geben Sie dann den Ausdruck im zweiten Feld ein. Der Ausdruck muss einen logischen Wert von Wahr oder Falsch zurückgeben. Informationen zum Erstellen eines Ausdrucks.
  4. Wählen Sie die Schriftart, Farbe oder sonstige Formatierung aus, die Sie verwenden möchten.

    Microsoft Access wendet die ausgewählte Formatierung nur dann an, wenn der Wert im Steuerelement die Bedingung erfüllt oder der Ausdruck einen Wert von TRUE zurückgibt.

  5. Um eine weitere Bedingung hinzuzufügen, klicken Sie auf Hinzufügen, und wiederholen Sie dann die Schritte 3 und 4.

    Sie können bis zu drei Bedingungen angeben. Wenn keine der drei Bedingungen erfüllt wird, behält das Steuerelement die ursprüngliche Formatierung.

Anmerkung Falls mehr als eine angegebene Bedingung erfüllt wird, wendet Access nur die Formatierung der ersten wahren Bedingung an.


 Optimieren der Leistung der Methode "Formularbasierter Filter" für alle Tabellen, Abfragen und Formulare

Optimieren der Leistung der Methode "Formularbasierter Filter" für alle Tabellen, Abfragen und Formulare

Diese Einstellungen haben für alle Tabellen und Abfragen sowie für alle Textfeld-Steuerelemente Gültigkeit, für die für die Eigenschaft FilterAnwenden (FilterLookup) die Einstellung Datenbankstandard festgelegt ist. Um weitere Informationen zum Einstellen dieser Eigenschaft anzuzeigen, klicken Sie auf [image] .

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Bearbeiten/Suchen, und stellen Sie dann die Standards für formularbasierte Filter entsprechend der gewünschten Leistung ein.
    • Wenn es zu lange dauert, die Werteliste nur in nichtindizierten Feldern anzuzeigen, versuchen Sie, die Listen auf indizierte Felder zu beschränken. Dazu deaktivieren Sie die Kontrollkästchen Lokalen nichtindizierten Feldern und ODBC-Feldern. Wenn es zu lange dauert, die Listen in indizierten Feldern anzuzeigen, deaktivieren Sie das Kontrollkästchen Lokalen indizierten Feldern ebenfalls, da in diesem Fall zu viele Datensätze indiziert sind, und die Listen daher nicht schnell angezeigt werden können.

      Anmerkung Wenn Sie dasselbe nichtindizierte Feld wiederholt zum Filtern von Datensätzen verwenden, können Sie den Filtervorgang und andere Suchoperationen unter Umständen beschleunigen, indem Sie indizieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Wenn die Listen nicht die Werte aus indizierten oder nichtindizierten Feldern anzeigen, prüfen Sie ob die entsprechenden Kontrollkästchen unter Liste anzeigen von Werten in aktiviert sind, oder versuchen Sie die im Feld Keine Listen anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird aufgeführte Anzahl zu erhöhen, so dass diese gleich oder größer der maximalen Anzahl von Datensätzen in einem beliebigen nichtindizierten Feld der zugrunde liegenden Tabelle ist.

Anmerkung Um Informationen dazu, welchen Unterschied Microsoft Access beim Lesen indizierter Felder und nichtindizierter Felder macht, und wie sich dies auf das Feld Keine Listen anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird auswirkt, anzuzeigen, klicken Sie auf [image] .


 Optimieren der Leistung der Methode "Formularbasierter Filter" für ein bestimmtes Formular

Optimieren der Leistung der Methode "Formularbasierter Filter" für ein bestimmtes Formular

Sie können für jedes Textfeld-Steuerelement in einem Formular festlegen, ob die im Feld gespeicherten Werte in der entsprechenden Liste im Fenster Formularbasierter Filter angezeigt werden sollen oder nicht.

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Zeigen Sie das Eigenschaftenfenster für ein beliebiges Textfeld-Steuerelement an.

    Wie wird's gemacht?

  3. Legen Sie im Einstellungsfeld für die Eigenschaft FilterAnwenden (FilterLookup) die Einstellung für die gewünschte Leistung fest.
    • Wenn es zu lange dauert, die Liste im Fenster Formularbasierter Filter anzuzeigen, legen Sie für die Eigenschaft FilterAnwenden entweder die Einstellung Nie oder die Einstellung Datenbankstandard fest, und führen Sie dann im Dialogfeld Optionen (Menü Extras) die entsprechenden Änderungen durch. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Wenn die Liste im Fenster Formularbasierter Filter nicht die in diesem Feld gespeicherten Werte anzeigt, stellen Sie sicher, dass für die Eigenschaft FilterAnwenden nicht die Einstellung Nie festgelegt ist. Legen Sie die Einstellung Datenbankstandard oder die Einstellung Immer fest, und führen Sie dann im Dialogfeld Optionen (Menü Extras) die entsprechenden Änderungen durch. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Ändern der Abfrage in der Eigenschaft "Datensatzherkunft" für ein Diagramm in einem Formular oder Bericht

Ändern der Abfrage in der Eigenschaft "Datensatzherkunft" für ein Diagramm in einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Vergewissern Sie sich, dass das Diagramm markiert ist, und klicken Sie dann auf Eigenschaften [image] .

  3. Klicken Sie auf das Einstellungsfeld der Eigenschaft Datensatzherkunft und dann auf die Generator-Schaltfläche [image] rechts neben dem Einstellungsfeld der Eigenschaft, um den Abfrage-Generator zu öffnen.

    Der Abfrage-Generator zeigt die Datensatzherkunft-Abfrage in der Entwurfsansicht an.

  4. Ändern Sie die Abfrage.

    Zum Anzeigen einer Vorschau der durchgeführten Änderungen klicken Sie im Menü Ansicht auf Datenblatt.

  5. Schließen Sie den Abfrage-Generator.

  6. Zum Anzeigen der Änderungen am Diagramm öffnen Sie das Formular in der Formularansicht oder den Bericht in der Seitenansicht.

Wenn das Ändern der Datensatzherkunft-Abfrage nicht zum gewünschten Ergebnis führt, können Sie versuchsweise die Daten in der zugrunde liegenden Tabelle oder anderer Datenherkunft ändern. Um weitere Informationen zum Ändern von Daten in der zugrunde liegenden Tabelle oder anderer Datenherkunft anzuzeigen, klicken Sie auf [image] .


 Ändern des Anfangswertes eines AutoWert-Feldes

Ändern des Anfangswertes eines AutoWert-Feldes

Bei einer neuen Tabelle, die keine Datensätze enthält, können Sie den Anfangswert eines Feldes vom Typ AutoWert ändern, sofern seine Eigenschaft NeueWerte auf Inkrement eingestellt ist. Bei einer Tabelle, die Datensätze enthält, können Sie mit Hilfe dieses Verfahrens auch den nächsten, einem Feld vom Typ AutoWert zugewiesenen Wert in einen anderen Wert ändern.

  1. Erstellen Sie eine temporäre Tabelle mit einem einzigen Feld des Datentyps Zahl. Stellen Sie dessen Eigenschaft Feldgröße auf Long Integer ein, und geben Sie ihm denselben Namen wie dem Feld vom Typ AutoWert in der Tabelle, dessen Wert Sie ändern möchten.

    Wie wird's gemacht?

  2. Geben Sie in der Datenblattansicht einen Wert in das Zahlenfeld der temporären Tabelle ein, der um 1 niedriger ist als der Anfangswert, den Sie dem Feld vom Typ AutoWert zuweisen möchten. Möchten Sie z.B., dass das Feld vom Typ AutoWert mit 100 beginnt, geben Sie in das Zahlenfeld 99 ein.

  3. Erstellen Sie eine Anfügeabfrage, und führen Sie sie aus, um die temporäre Tabelle an die Tabelle anzufügen, deren AutoWert-Wert Sie ändern möchten.

    Wie wird's gemacht?

    Anmerkung Verfügt Ihre Originaltabelle über einen Primärschlüssel, müssen Sie diesen vorübergehend löschen, bevor Sie die Anfügeabfrage ausführen. Enthält Ihre Originaltabelle ferner Felder, deren Eigenschaft EingabeErforderlich auf Ja eingestellt ist, deren Eigenschaft Indiziert auf Ja (Ohne Duplikate) eingestellt ist und deren Eigenschaft Gültigkeitsregel (gilt auch für Datensätze) so eingestellt ist, dass Nullwerte in Feldern verhindert werden, müssen Sie diese Einstellungen vorübergehend deaktivieren.

  4. Löschen Sie die temporäre Tabelle.

  5. Löschen Sie den durch die Anfügeabfrage angefügten Datensatz.

  6. Mussten Sie in Schritt 3 Eigenschafteneinstellungen deaktivieren, kehren Sie wieder zu den ursprünglichen Einstellungen zurück.

Wenn Sie einen Datensatz in die verbleibende Tabelle eingeben, verwendet Microsoft Access ein Feld vom Typ AutoWert, dessen Wert um 1 größer ist als der Wert, den Sie in die temporäre Tabelle eingegeben haben.

Anmerkung Möchten Sie die Datenbank komprimieren, nachdem Sie den Anfangswert für AutoWert geändert haben, fügen Sie der Tabelle zunächst unbedingt mindestens einen Datensatz hinzu. Unterlassen Sie dies, wird beim Komprimieren der Datenbank der AutoWert für den nächsten hinzugefügten Datensatz auf 1 höher als der höchste vorhergehende Wert gesetzt. Enthielt die Tabelle keine Datensätze, als Sie den Anfangswert neu eingestellt haben, wird durch das Komprimieren der AutoWert für den nächsten hinzugefügten Datensatz auf 1 gesetzt; enthielt die Tabelle Datensätze, als Sie den Anfangswert neu eingestellt haben, und war der höchste vorangehende Wert 50, wird das Komprimieren den AutoWert für den nächsten hinzugefügten Datensatz auf 51 setzen.


 Ändern des Layouts eines Unterformulars, das in der Datenblattansicht angezeigt wird

Ändern des Layouts eines Unterformulars, das in der Datenblattansicht angezeigt wird

In der Formularansicht des Hauptformulars können Sie folgende Änderungen vornehmen:

  • Zum Ändern der Breite einer Spalte ziehen Sie am rechten Rand des Spaltenmarkierers. Um die Größe der Spalte automatisch an die enthaltenen Daten anzupassen, doppelklicken Sie auf den rechten Rand des Spaltenmarkierers.

  • Zum Ändern der Reihenfolge der Spalten klicken Sie auf eine Spaltenüberschrift, um die Spalte zu markieren. Klicken Sie dann erneut auf die Spaltenüberschrift, halten Sie die Maustaste gedrückt, und ziehen Sie die Spalte an eine neue Position.

  • Zum Ändern der Höhe aller Zeilen ziehen Sie am unteren Rand des Zeilenmarkierers.

  • Zum Ausblenden einer Spalte klicken Sie auf eine beliebige Stelle der Spalte und dann im Menü Format auf Spalten ausblenden.

  • Zum Einblenden einer ausgeblendeten Spalte klicken Sie im Menü Format auf Spalten einblenden und aktivieren dann das Kontrollkästchen für die Spalte, die Sie einblenden möchten.

  • Zum Fixieren einer Spalte klicken Sie auf eine beliebige Stelle der Spalte und dann im Menü Format auf Spalten fixieren.

Anmerkungen

  • Zum Ändern der Gesamthöhe des Unterformulars ändern Sie in der Entwurfsansicht des Hauptformulars die Höhe des Unterformular-Steuerelements.
  • Falls die EntwurfsänderungenZulassen-Eigenschaft des Hauptformulars auf Alle Ansichten eingestellt ist, können Sie den Entwurf des Unterformular-Datenblattes mithilfe des Eigenschaftenblattes in der Formularansicht ändern.


 Ändern des Layouts eines Unterformulars, das als Einzel- oder als Endlosformular angezeigt wird

Ändern des Layouts eines Unterformulars, das als Einzel- oder als Endlosformular angezeigt wird

  1. Öffnen Sie das Hauptformular in der Entwurfsansicht. Das Unterformular wird in der Entwurfsansicht im Unterformular-Steuerelement angezeigt.

  2. Stellen Sie sicher, dass das Unterformular-Steuerelement markiert ist. Danach können Sie erneut auf das Steuerelement klicken, um das Formular, einen Bereich oder ein Steuerelement auszuwählen. Dabei verfahren Sie genauso, als würden Sie das Unterformular aus der Entwurfsansicht des Datenbankfensters öffnen.

  3. Führen Sie die gewünschten Änderungen am Entwurf des Unterformulars durch.

  4. Um Änderungen am Unterformular-Steuerelement vorzunehmen, wenn beispielsweise seine Größe geändert oder Eigenschaften eingestellt werden sollen, klicken Sie zunächst auf den Rand des Steuerelements, um es zu markieren.

  5. Wechseln Sie zur Formularansicht, um die Änderungen anzuzeigen.

Anmerkungen

  • Wenn Sie die Breite eines als Unterformular angezeigten Formulars ändern, müssen Sie auch die Breite des Unterformular-Steuerelements im Hauptformular ändern.

  • Falls die EntwurfsänderungenZulassen-Eigenschaft des Hauptformulars auf Alle Ansichten eingestellt ist, können Sie den Entwurf des Unterformulars mit Hilfe des Eigenschaftenfensters in der Formularansicht ändern. Sie können jedoch keine Änderungen am Unterformular-Steuerelement vornehmen.


Ändern des Entwurfs einer Tabelle im Fenster "Beziehungen"

  1. Klicken Sie im Fenster Beziehungen mit der rechten Maustaste auf die gewünschte Tabelle und dann auf Tabelle entwerfen.

  2. Ändern Sie die Tabellendefinition wie gewünscht.


 Ändern des Titelleistentextes eines Formulars in der Formularansicht

Ändern des Titelleistentextes eines Formulars in der Formularansicht

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Beschriftung den Text für die Titelleiste ein.

  4. Um den Text in der Titelleiste anzuzeigen, wechseln Sie zur Formularansicht.

Tipp Wenn die Titelleiste keinen Text enthalten soll, geben Sie im Einstellungsfeld der Eigenschaft Beschriftung ein Leerzeichen ein.


 Ändern der Verknüpfungsart für ein Bild oder ein anderes Objekt in einem Formular oder Bericht

Ändern der Verknüpfungsart für ein Bild oder ein anderes Objekt in einem Formular oder Bericht

Wenn Sie eine Verknüpfung zu einem in einer anderen Anwendung erstellten Objekt erstellen, erstellt Microsoft Access standardmäßig eine automatische Verknüpfung. Sie können die Verknüpfungsart in manuell ändern oder umgekehrt.

Anmerkung Diese Verknüpfungsart ist nicht identisch mit einem Hyperlink, der in einem Formular oder Bericht zum Springen zu einem anderen Dokument, einem anderen Objekt oder einer anderen Seite verwendet wird. Zum Anzeigen weiterer Informationen zu Hyperlinks klicken Sie auf [image] .

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Formular-Entwurfsansicht oder der Berichts-Entwurfsansicht auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Klicken Sie im Menü Bearbeiten auf OLE/DDE-Verknüpfungen.

  3. Klicken Sie im Feld Verknüpfungen auf die Verknüpfung, die Sie ändern möchten. Zum Markieren mehrerer Verknüpfungen halten Sie STRG gedrückt, und klicken dann nacheinander auf jede einzelne Verknüpfung.

  4. Klicken Sie auf Automatisch oder Manuell.

Anmerkungen

  • Wenn Sie Änderungen an einer Verknüpfung für ein gebundenes Objektfeld vornehmen, ändern Sie die Verknüpfung nur für den aktuellen Datensatz. Zum Durchführen einer Änderung in einem anderen Datensatz gehen Sie zu diesem und wiederholen die Änderung.

  • Dieses Verfahren gilt nur für Bilder in Objektfeldern und in gebundenen Objektfeldern. Hintergrundbilder und Bilder in Bild-Steuerelementen werden immer automatisch aktualisiert.


 Auswählen von Feldern für eine neue Tabelle aus bereits bestehenden Tabellen

Auswählen von Feldern für eine neue Tabelle aus bereits bestehenden Tabellen

  • Wählen Sie mit Hilfe des Tabellen-Assistenten Felder für Ihre Tabelle aus einer Vielzahl vordefinierter Tabellen aus, wie Geschäftskontakte, Haushaltsinventar oder medizinische Daten.

    Erstellen einer Tabelle mit Hilfe des Tabellen-Assistenten


 Ändern der Geschwindigkeit von Lauftext auf einer Datenzugriffsseite

Ändern der Geschwindigkeit von Lauftext auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Lauftext-Steuerelement aus, und klicken Sie dann auf Eigenschaften [image] auf der Symbolleiste, um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Klicken Sie im Einstellungsfeld der TrueSpeed-Eigenschaft auf Wahr.

  4. Geben Sie im Einstellungsfeld der ScrollDelay-Eigenschaft ein, wie viele Millisekunden Verzögerung zwischen den Wiederholungen des Lauftextes liegen sollen.

  5. Geben Sie im Einstellungsfeld der ScrollAmount-Eigenschaft ein, um wie viele Pixel sich der Lauftext in der im Einstellungsfeld der ScrollDelay-Eigenschaft angegebenen Zeitspanne weiterbewegen soll. Die ScrollAmount-Eigenschaft gibt somit den Abstand zwischen den Textwiederholungen an.

Anmerkung Wenn die TrueSpeed-Eigenschaft auf Wahr eingestellt ist, wird die Geschwindigkeit des Lauftextes durch die ScrollDelay- und ScrollAmount-Eigenschaften bestimmt. Ist beispielsweise die ScrollDelay-Eigenschaft auf 65 und die ScrollAmount-Eigenschaft auf 10 eingestellt, rückt der Lauftext alle 65 Millisekunden um 10 Pixel vor. Falls die TrueSpeed-Eigenschaft auf False eingestellt ist, beträgt die kürzeste Verzögerung zwischen den Textwiederholungen 60 Millisekunden.


 Löschen aller Felder im Fenster "Formularbasierter Filter"

Löschen aller Felder im Fenster "Formularbasierter Filter"

  • Klicken Sie in der Symbolleiste auf Alles löschen [image] .


 Löschen des Entwurfsbereichs in einer Abfrage oder einem Spezialfilter

Löschen des Entwurfsbereichs in einer Abfrage oder einem Spezialfilter

  • Klicken Sie in der Abfrageentwurfsansicht oder im Fenster Spezialfilter/-sortierung im Menü Bearbeiten auf Alles löschen.


 Kombinieren von Daten in Feldern aus zwei oder mehr Tabellen unter Verwendung einer Union-Abfrage

Kombinieren von Daten in Feldern aus zwei oder mehr Tabellen unter Verwendung einer Union-Abfrage

Union-Abfragen kombinieren einander entsprechende Felder mehrerer Tabellen oder Abfragen in einem Feld. Wenn Sie eine Union-Abfrage ausführen, gibt diese die Datensätze einander entsprechender Felder der zugehörigen Tabellen oder Abfragen aus.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Neue Abfrage und dann auf OK.

  3. Klicken Sie im Dialogfeld Tabelle anzeigen auf Schließen, ohne Tabellen oder Abfragen hinzuzufügen.

  4. Zeigen Sie im Menü Abfrage auf SQL-spezifisch, und klicken Sie dann auf Union.

  5. Geben Sie SQL SELECT-Anweisungen an, die Sie entweder mit der Operation UNION kombinieren, um keine doppelten Datensätze zurückzugeben, oder mit der Operation UNION ALL, um doppelte Datensätze zuzulassen.

    Anmerkung Jede SELECT-Anweisung muss die gleiche Anzahl Felder zurückgeben, und zwar in identischer Reihenfolge. Die Datentypen der zusammengehörenden Felder müssen kompatibel sein, mit einer Ausnahme: Sie können ein Zahlen- und ein Textfeld als einander entsprechende Felder verwenden.

    Union-Abfragen kombinieren Daten aus zwei oder mehr Tabellen

    Um Informationen zu SELECT-Anweisungen anzuzeigen, klicken Sie auf [image] . Um Informationen zu den Operationen UNION und UNION ALL anzuzeigen, klicken Sie auf [image] .

  6. Wenn Sie in einer Union-Abfrage sortieren möchten, geben Sie hinter der letzten SELECT-Anweisung eine ORDER BY-Klausel an. Geben Sie in der ORDER BY-Klausel den Namen des Feldes an, nach dem sortiert werden soll. Dieser Feldname muss aus der ersten SELECT-Anweisung stammen. Um Informationen zur ORDER BY-Klausel anzuzeigen, klicken Sie auf [image] .

  7. Um das Ergebnis der Abfrage anzuzeigen, klicken Sie in der Symbolleiste auf Abfrageansicht [image] .

Vorsicht Wenn Sie eine Union-Abfrage in einen anderen Abfragetyp, wie z.B. eine Auswahlabfrage, umwandeln, verlieren Sie die gerade eingegebene SQL-Anweisung.

Anmerkungen

  • Die Abfrage Kunden und Lieferanten nach Standort der Datenbank Nordwind ist ein Beispiel für eine Union-Abfrage. Um sich diese Abfrage anzusehen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL im Office-Ordner, und öffnen Sie die Abfrage Kunden und Lieferanten nach Standort in der Entwurfsansicht. Um Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .

  • Eine Union-Abfrage übernimmt die Spaltennamen der ersten Tabelle oder SELECT-Anweisung. Wenn Sie ein Feld des Ergebnisses umbenennen möchten, verwenden Sie die AS-Klausel, um einen Alias für das Feld zu erstellen. Zum Anzeigen eines Beispiels klicken Sie auf [image] .


 Komprimieren von nicht geöffneten Access-Datenbanken oder Access-Projekten

Komprimieren von nicht geöffneten Access-Datenbanken oder Access-Projekten

  1. Schließen Sie die aktuelle Microsoft Access-Datenbank oder das aktuelle Microsoft Access-Projekt. Falls Sie eine (freigegebene) Mehrbenutzer-Datenbank komprimieren möchten, die sich auf einem Server oder in einem freigegebenen Ordner befindet, stellen Sie sicher, dass sie kein anderer Benutzer geöffnet hat.

  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie dann auf Datenbank komprimieren und reparieren.

  3. Geben Sie im Dialogfeld Datenbank komprimieren die Access-Datenbank oder das Access-Projekt an, das Sie komprimieren möchten, und klicken Sie dann auf Komprimieren.

  4. Geben Sie im Dialogfeld Datenbank komprimieren nach den Namen, das Laufwerk und den Ordner für die komprimierte Access-Datenbank bzw. das Access-Projekt an.

  5. Klicken Sie auf Speichern.

    Wenn Ihre Angaben für den Namen, das Laufwerk und den Ordner mit den bisherigen Angaben identisch sind und die Access-Datenbank bzw. das Access-Projekt erfolgreich komprimiert wurde, ersetzt Microsoft Access die Originaldatei durch die komprimierte Version.

Anmerkung Sie können den Komprimierungsvorgang stoppen, indem Sie STRG+UNTBR oder ESC drücken.


 Komprimieren der aktuellen Access-Datenbank bzw. des Access-Projekts

Komprimieren der aktuellen Access-Datenbank bzw. des Access-Projekts

  1. Wenn Sie eine (freigegebene) Mehrbenutzer-Datenbank komprimieren, die sich auf einem Server oder in einem freigegebenen Ordner befindet, stellen Sie sicher, dass kein anderer Benutzer diese Datenbank geöffnet hat.
  2. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie dann auf Datenbank komprimieren und reparieren.

Anmerkung Sie können den Komprimierungsvorgang stoppen, indem Sie STRG+UNTBR oder ESC drücken.


 Konvertieren einer Datenbank einer früheren Version in Microsoft Access 2000

Konvertieren einer Datenbank einer früheren Version in Microsoft Access 2000

  1. Erstellen Sie eine Sicherungskopie der Access-Datenbank, die Sie konvertieren möchten, und bewahren Sie diese so lange auf, bis Sie die in Microsoft Access 2000 konvertierte Version wie gewünscht einsetzen können.

  2. Schließen Sie die Microsoft Access-Datenbank, die Sie konvertieren möchten.

    Falls es sich bei der Access-Datenbank um eine Mehrbenutzer-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass kein anderer Benutzer diese Datenbank geöffnet hat.

  3. Zeigen Sie in Microsoft Access 2000 im Menü Extras auf Datenbank-Dienstprogramme, dann auf Datenbank konvertieren, und klicken Sie danach auf In aktuelle Access-Datenbankversion.

  4. Wählen Sie im Dialogfeld Datenbank konvertieren von die Datenbank aus, die Sie konvertieren möchten, und klicken Sie dann auf Konvertieren.

  5. Führen Sie im Dialogfeld Datenbank konvertieren in einen der folgenden Schritte aus:
    • Geben Sie einen neuen Namen (ohne .mdb-Erweiterung) für die Microsoft Access 2000-Datenbankdatei ein.

    • Wählen Sie einen anderen Standort für die Microsoft Access 97-Datenbankdatei. (In diesem Fall können Sie den alten Namen beibehalten oder ändern.)

    Sie können eine Access-Datenbank nicht in eine Datei mit dem gleichen Namen und Speicherort wie die Original-Datenbank konvertieren.

  6. Klicken Sie auf Speichern.

Microsoft Access konvertiert die Datenbank in das Access 2000-Format.

Informationen über das Konvertieren einer replizierten Datenbank.

Anmerkungen

  • Sie können eine gesicherte Access-Datenbank konvertieren. Danach werden jedoch die Module nicht mehr durch Sicherheitsmaßnahmen auf Benutzerebene gesichert. Sie können die Module in der konvertierten Access-Datenbank sichern, indem Sie den Visual Basic für Applikationen-Code (VBA-Code) mit einem Kennwort schützen.

  • Wenn Sie eine frühere Version einer Microsoft Access-Datenbank konvertieren, die verknüpfte Tabellen enthält, müssen Sie sicherstellen, dass sich die externen Tabellen in dem Ordner befinden, in dem sie sich ursprünglich befunden haben. Wenn Microsoft Access die mit der zu konvertierenden Datenbank verknüpften Tabellen nicht findet, können Sie die konvertierte Datenbank nicht verwenden. Nach dem Konvertieren der Access-Datenbank können Sie die Tabellen verschieben und unter Verwendung des Tabellenverknüpfungs-Managers neu verknüpfen. Beim Konvertieren einer Datenbank mit verknüpften Tabellen werden die verknüpften Tabellen nicht konvertiert.

  • Sie können eine frühere Version einer Access-Datenbank auch konvertieren, indem Sie in eine neue Access 2000-Datenbank ihre Datenbankobjekte importieren. Diese Methode können Sie verwenden, wenn nicht alle Objekte aus der Datenbank der früheren Version in die Access 2000-Datenbank übernommen werden sollen.


 Konvertieren von Code, der eine DLL aufruft

Konvertieren von Code, der eine DLL aufruft

Aufrufen von Prozeduren der Windows API (Application Programming Interface = Schnittstelle für die Anwendungsprogrammierung)

Wenn eine in früheren Versionen von Microsoft Access erstellte Datenbank Prozeduren des Microsoft Windows API (Application Programming Interface) aufruft, müssen Sie einige Veränderungen in Ihrem Code vornehmen, wenn Sie eine Datenbank, die im Format der Version 2.0 oder früher vorliegt, in das Microsoft Access 2000-Format konvertieren.

Das Windows API besteht aus einer Gruppe von DLLs (Dynamic-Link Libraries), die systembezogene Prozeduren enthalten. Dazu zählen Funktionen, Meldungen, Datenstrukturen, Datentypen und Anweisungen, die Sie beim Erstellen von Anwendungen verwenden können, die unter Windows 95 oder Windows NT lauffähig sind. Damit Sie diese Prozeduren von Visual Basic aus aufrufen können, müssen Sie diese zuerst mit entsprechenden Declare-Anweisungen deklarieren. Sie können diese Prozeduren dann wie jede andere Prozedur aufrufen.

Die Versionen 1.x und 2.0 von Microsoft Access sind 16-Bit-Anwendungen und laufen unter 16-Bit-Versionen von Microsoft Windows. Microsoft Access 2000 ist eine 32-Bit-Anwendung und läuft nur unter Windows 95 und Windows NT. Sollte Ihr vorhandener Access Basic-Code Prozeduren eines 16-Bit-Windows API aufrufen, müssen Sie die zugehörigen Aufrufe anpassen, wenn Sie Ihre Datenbank für Microsoft Access 2000 konvertieren. Die folgende Liste gibt einige Tipps zur Konvertierung Ihres Codes.

  • Überprüfen Sie alle Declare-Anweisungen, um sicherzustellen, dass sie auf die korrekten DLLs verweisen. Die folgende Tabelle zeigt die neuen Namen der 32-Bit-Windows-DLLs.

    16-Bit-Windows-DLL | 32-Bit-Windows-DLL
    User.dll | User32.dll
    Kernel.dll | Kernel32.dll
    GDI.dll | GDI32.dll

  • Die Namen einiger Funktionen des 32-Bit-Windows API wurden geändert. Außerdem beachten Funktionen des 32-Bit-Windows API die Groß- und Kleinschreibung. Stellen Sie sicher, dass Sie den Prozedurnamen und den Aliasnamen korrekt eingegeben haben.

  • Einige Funktionen haben in dem 32-Bit-Windows API neue Parameterdatentypen. Mit Hilfe der weiter unten in diesem Thema aufgeführten Referenzen können Sie ermitteln, welche Funktionsaufrufe Sie aktualisieren müssen.

  • Wenn es auf Ihrem Computer eine 16-Bit- und eine 32-Bit-DLL gibt, die denselben Namen haben, versucht Microsoft Access möglicherweise, eine Funktion der 16-Bit-DLL aufzurufen, wenn das Verzeichnis, in dem diese sich befindet, in Ihrem Pfad vor dem Verzeichnis aufgeführt ist, das die neue Version enthält.

  • Einige 32-Bit-DLLs enthalten Funktionen mit etwas unterschiedlichen Versionen, um sowohl Unicode- als auch ANSI-Zeichenfolgen verarbeiten zu können. Ein A am Ende des Funktionsnamens gibt die ANSI-Version an. Ein W am Ende des Funktionsnamens gibt die Unicode-Version an. Wenn die Funktion Argumente des Typs String erwartet, versuchen Sie, dem Funktionsnamen ein A anzufügen.

Weitere Informationen über die Verwendung von 32-Bit-Windows API-Prozeduren und das Portieren Ihrer bestehenden Datenbankanwendungen in 32-Bit-Microsoft Access 2000 finden Sie in den folgenden Ressourcen:

  • Der Windows API-Viewer, verfügbar in der Microsoft Office 2000, Developer Edition, enthält die Visual Basic-Syntax für alle 32-Bit-Deklarationen, -Datentypen und -Konstanten.

  • Das Microsoft Office 2000 Resource Kit enthält Informationen über das Portieren Ihrer auf der 16-Bit-Version von Microsoft Office basierenden Lösungen, einschließlich der Anwendungen, die mit früheren Versionen von Microsoft Access entwickelt wurden, zu 32-Bit-Lösungen.

  • Das Microsoft Win32 Software Development Kit stellt die kompletten Referenzinformationen für 32-Bit-Windows API-Prozeduren bereit.

Aufrufen von Code anderer DLLs

Wenn Ihre Datenbankanwendung Prozeduren anderer DLLs aufruft und Sie Ihre Datenbank für Microsoft Access 2000 konvertieren, müssen Sie 32-Bit-Versionen dieser DLLs erstellen oder erlangen und alle erforderlichen Veränderungen an Ihrem Code vornehmen.

Wenn Sie keine 32-Bit-Version einer DLL erhalten können, benötigen Sie eine dazwischenliegende DLL, die 32-Bit-Aufrufe in 16-Bit-Aufrufe konvertieren kann. Weitere Informationen finden Sie in den oben aufgelisteten Ressourcen.


 Konvertieren globaler Makros zu Visual Basic

Konvertieren globaler Makros zu Visual Basic

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] .

  2. Klicken Sie auf den Namen des Makros, das Sie konvertieren möchten.

  3. Klicken Sie im Menü Datei auf Speichern unter.

  4. Klicken Sie im Dialogfeld Speichern unter auf Modul und dann auf OK.

  5. Wählen Sie im Dialogfeld Makro konvertieren die gewünschten Optionen aus, und klicken Sie dann auf Konvertieren.


 Konvertieren von Makros in einem Formular oder Bericht zu Visual Basic

Konvertieren von Makros in einem Formular oder Bericht zu Visual Basic

  1. Öffnen Sie das Formular oder den Bericht in der Formular-Entwurfsansicht bzw. der Berichts-Entwurfsansicht.

  2. Zeigen Sie im Menü Extras auf Makros, und klicken Sie dann auf Makros des Formulars zu Visual Basic konvertieren oder auf Makros des Berichts zu Visual Basic konvertieren.


 Konvertieren eines OLE-Objekts in einem Formular oder Bericht in eine höhere Version dieses Objekts

Konvertieren eines OLE-Objekts in einem Formular oder Bericht in eine höhere Version dieses Objekts

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Zeigen Sie im Menü Bearbeiten auf den entsprechenden Objekt-Befehl (beispielsweise auf Workheet Object für ein Microsoft Excel-Objekt), und klicken Sie dann auf Konvertieren.

  3. Klicken Sie im Dialogfeld Konvertieren auf die Version, in die Sie das Objekt konvertieren möchten. Sie könnten beispielsweise ein Graph 3.0-Objekt in ein Graph 5.0-Objekt konvertieren.


 Konvertieren eines gebundenen Bildes oder eines anderen Objekts in einem Formular in ein Bild

Konvertieren eines gebundenen Bildes oder eines anderen Objekts in einem Formular in ein Bild

  1. Öffnen Sie das Formular in der Formularansicht.

  2. Klicken Sie auf das Objekt und dann auf Kopieren [image] .

  3. Klicken Sie im Menü Bearbeiten auf Inhalte einfügen.

  4. Klicken Sie im Listenfeld Als auf Bild oder auf eine der Bitmap-Optionen, je nachdem, ob Sie eine Metadatei oder ein Bitmap erstellen möchten.

  5. Microsoft Access konvertiert das Objekt in ein Bild. Das gebundene Objektfeld verbleibt im Formular, Sie können jedoch aus dem Formular nicht mehr die Anwendung (die OLE-Server-Anwendung) öffnen, die zum Erstellen des Objekts verwendet wurde. Handelt es sich um ein Klangobjekt, verbleibt nur das Symbol im Formular. Bei einem Videoobjekt verbleibt nur der Rahmen für das Video. Sie können den Klang oder das Video nicht mehr abspielen.

Anmerkungen

  • Wenn Sie Änderungen an einem Objekt in einem gebundenen Objektfeld vornehmen, ändern Sie das Objekt nur für den aktuellen Datensatz. Zum Durchführen einer Änderung in einem anderen Datensatz gehen Sie zu diesem Datensatz und wiederholen die Änderung.

  • Wenn Sie das Objekt wie oben beschrieben in ein Bild konvertieren, wird das Formular schneller geöffnet. Wenn Sie lediglich verhindern möchten, dass andere Benutzer ein Objekt bearbeiten Leistung dabei keine Rolle spielt, können Sie stattdessen für das Objektfeld für die Eigenschaft Gesperrt (Locked) die Einstellung Ja und für die Eigenschaft Aktiviert (Enabled) die Einstellung Nein festlegen.


 Konvertieren eines ungebundenen Bildes oder eines anderen Objekts, damit dieses in Formularen oder Berichten nicht bearbeitet werden kann

Konvertieren eines ungebundenen Bildes oder eines anderen Objekts, damit dieses in Formularen oder Berichten nicht bearbeitet werden kann

  1. Öffnen Sie das Formular in der Formular-Entwurfsansicht oder den Bericht in der Berichts-Entwurfsansicht.

  2. Klicken Sie auf das Objekt.

  3. Zeigen Sie im Menü Format auf Ändern zu, und klicken Sie dann auf Bild.

    Microsoft Access konvertiert das Objektfeld in ein Bild-Steuerelement. Das Objekt verbleibt im Formular oder Bericht, Sie können jedoch nicht mehr die Anwendung (die OLE-Server-Anwendung), die zum Erstellen des Objekts verwendet wurde, aus dem Formular oder Bericht öffnen. Handelt es sich um ein Klangobjekt, verbleibt nur das Symbol im Formular. Bei einem Videoobjekt verbleibt nur der Rahmen für das Video. Sie können den Klang oder das Video nicht mehr abspielen.


 Kopieren oder Verschieben einer Access-Datenbank oder eines Access-Projekts

Kopieren oder Verschieben einer Access-Datenbank oder eines Access-Projekts

  1. Schließen Sie die Microsoft Access-Datenbank oder das Microsoft Access-Projekt. Falls Sie in einer Mehrbenutzerumgebung arbeiten, bestätigen Sie, dass alle Benutzer die Datenbank geschlossen haben.

  2. Suchen Sie die Datenbankdatei (.mdb) oder die Projektdatei (.adp) im Arbeitsplatz oder im Windows Explorer, und klicken Sie dann darauf.

    Um weitere zu kopierende oder zu verschiebende Dateien auszuwählen, halten Sie STRG gedrückt, und klicken Sie auf die einzelnen Dateien.

  3. Um die Datei zu kopieren, klicken Sie im Menü Bearbeiten auf Kopieren.

    Um die Datei zu verschieben, klicken Sie im Menü Bearbeiten auf Ausschneiden.

  4. Öffnen Sie den Ordner oder Datenträger, in/auf dem Sie die Datei ablegen möchten.

  5. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Um den Einfügevorgang wieder rückgängig zu machen, klicken Sie im Menü Bearbeiten auf Rückgängig: Kopieren bzw. Rückgängig: Verschieben.

Anmerkungen

  • Wenn Sie eine Access-Datenbank oder ein Access-Projekt kopieren oder verschieben, die bzw. das Verknüpfungen zu Datenzugriffsseiten enthält, belässt Access die Seiten in ihrem ursprünglichen Ordner und aktualisiert automatisch die Verknüpfungen zu den Seiten, so dass sie weiterhin wie gewohnt funktionieren.

  • Wenn Sie eine Access-Projektdatei kopieren oder verschieben, wird dabei nicht die Microsoft SQL Server-Datenbank kopiert bzw. verschoben, mit der das Access-Projekt verbunden ist.

Tipp Ist die Zielablage für die Datei bereits sichtbar, können Sie die Datei schnell verschieben, indem Sie sie auf die neue Zielablage ziehen, oder sie kopieren, indem Sie beim Ziehen STRG gedrückt halten.


 Kopieren von Datenbankobjekten mit dem Befehl Kopieren

Kopieren von Datenbankobjekten mit dem Befehl Kopieren

  1. Klicken Sie im Datenbankfenster unter Objekte auf den Typ des Datenbankobjekts, das Sie kopieren wollen.

  2. Klicken Sie in der Objektliste auf das Objekt und dann in der Symbolleiste auf Kopieren [image] .

  3. Wenn Sie das Objekt in eine andere Microsoft Access-Datenbank oder ein anderes Microsoft Access-Projekt kopieren, schließen Sie zunächst die aktuelle Access-Datenbank bzw. das aktuelle Access-Projekt, und öffnen Sie dann die Access-Datenbank bzw. das Access-Projekt, in die bzw. das Sie das Objekt einfügen möchten.

  4. Klicken Sie, während das Datenbankfenster angezeigt wird, in der Symbolleiste auf Einfügen [image] .

  5. Geben Sie im Dialogfeld Einfügen als die erforderlichen Informationen ein. Das neue Objekt muss einen eindeutigen Namen erhalten und den Benennungsregeln für Objekte von Microsoft Access entsprechen. Falls Sie in einer Access-Datenbank arbeiten, die ein Hauptentwurf (Designmaster) ist, und das neue Objekt zu anderen Datenbanken repliziert werden soll, aktivieren Sie das Kontrollkästchen Dieses Objekt replizieren.

Anmerkungen

  • Beim Kopieren einer Tabelle können Sie im Dialogfeld Tabelle einfügen als angeben, ob Sie nur die Tabellenstruktur, die Struktur und die Daten oder die Daten in eine vorhandene Tabelle einfügen möchten.

  • Wenn Sie mit dieser Methode eine Kopie einer Datenzugriffsseite erstellen, fordert Microsoft Access Sie auf, einen Namen für die neue HTML-Datei anzugeben.

  • Weitere Informationen über das Speichern von Änderungen an einer freigebenen Access-Datenbank

  • Falls Sie beim Kopieren der Daten einer Tabelle auf Probleme stoßen, klicken Sie auf [image] . Eine große Anzahl an Datensätzen in einer Access-Datenbank lässt sich möglicherweise einfacher mit Hilfe einer Anfügeabfrage kopieren. Weitere Informationen erhalten Sie durch Klicken auf [image] .


 Erstellen eines Hyperlinks durch Einfügen des Hyperlinks aus einem Microsoft Office-Dokument

Erstellen eines Hyperlinks durch Einfügen des Hyperlinks aus einem Microsoft Office-Dokument

  1. Öffnen Sie ein Microsoft Office-Dokument, das einen definierten Hyperlink enthält.

  2. Klicken Sie mit der rechten Maustaste auf den definierten Hyperlink, den Sie kopieren möchten. Zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Hyperlink kopieren.

    Anmerkung Stellen Sie beim Kopieren eines definierten Hyperlinks aus einem Office-Dokument sicher, dass nur der Hyperlink selbst kopiert wird. Wenn Sie nicht zum Hyperlink gehörende Zeichen davor und/oder dahinter mitkopieren, verknüpft Microsoft Access mit dem markierten Text statt mit der Adresse des Hyperlinks.

  3. Wechseln Sie zu Microsoft Access, und öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  4. Klicken Sie im Menü Bearbeiten auf Als Hyperlink einfügen.

    Microsoft Access fügt dem Formular oder Bericht ein Bezeichnungsfeld hinzu. Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.


 Verschieben einer Aktion in einem Makro

Verschieben einer Aktion in einem Makro

  1. Klicken Sie im Makrofenster auf den Markierer für die Aktionszeile.

  2. Klicken Sie erneut auf den Markierer, und ziehen Sie die Zeile an eine neue Position.


 Umbenennen einer Access-Datenbank oder eines Access-Projekts

Umbenennen einer Access-Datenbank oder eines Access-Projekts

  1. Schließen Sie die Microsoft Access-Datenbank oder das Microsoft Access-Projekt. Falls Sie in einer Mehrbenutzerumgebung arbeiten, stellen Sie sicher, dass alle Benutzer die Datenbank geschlossen haben.

  2. Klicken Sie in der Symbolleiste auf Öffnen [image] .

  3. Suchen Sie im Dialogfeld Öffnen die Access-Datenbank oder das Access-Projekt, die/das Sie umbenennen wollen, und klicken Sie dann mit der rechten Maustaste auf die Datei.

  4. Klicken Sie im Kontextmenü auf Umbenennen.

  5. Geben Sie den neuen Namen ein. Die Erweiterung .mdb oder .adp brauchen Sie nur dann mit einzugeben, wenn Sie Microsoft Windows so eingerichtet haben, dass MS-DOS-Dateinamenerweiterungen bei bekannten Dateitypen angezeigt werden. Drücken Sie die EINGABETASTE.

    Der Dateiname kann (einschließlich Leerzeichen) bis zu 255 Zeichen lang sein.

Anmerkung Sie können eine Access-Datenbank oder ein Access-Projekt auch außerhalb von Access umbenennen. Schließen Sie die Datei, klicken Sie im Windows Explorer oder Arbeitsplatz mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Umbenennen.


 Eingeben eines Hyperlinks durch Einfügen von Text aus einem Microsoft Office-Dokument

Eingeben eines Hyperlinks durch Einfügen von Text aus einem Microsoft Office-Dokument

  1. Öffnen Sie das Microsoft Office-Dokument, mit dem Sie eine Verknüpfung herstellen möchten, beispielsweise ein Microsoft Word-Dokument.

  2. Markieren Sie den Text, mit dem Sie eine Verknüpfung herstellen möchten.

    Anmerkung Durch Markieren von Text können Sie einen Hyperlink zu einer Datenzugriffsseite erstellen, jedoch nicht zu anderen Microsoft Access-Objekten.

  3. Klicken Sie im Menü Bearbeiten auf Kopieren.

  4. Wechseln Sie zu Microsoft Access und führen Sie einen der folgenden Schritte durch:
    • In einer Microsoft Access-Datenbank (.mdb) öffnen Sie die Tabelle oder Abfrage in der Datenblattansicht.

    • In einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) öffnen Sie das Formular in der Datenblattansicht oder in der Formularansicht.
  5. Setzen Sie die Einfügemarke in dem Datenblatt in das Hyperlink-Feld in dem Formular in das Textfeld bzw. andere Steuerelement, das Hyperlinks annimmt.

  6. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Microsoft Access fügt den Hyperlink dem Feld oder Steuerelement hinzu. In einem Formular oder Datenblatt können Sie auf den Hyperlink klicken, um das Zieldokument oder die Webseite zu öffnen.


 Erstellen eines Hyperlinks durch Einfügen von Text aus einem Microsoft Office-Dokument

Erstellen eines Hyperlinks durch Einfügen von Text aus einem Microsoft Office-Dokument

  1. Öffnen Sie das Microsoft Office-Dokument, mit dem Sie eine Verknüpfung herstellen möchten, beispielsweise ein Microsoft Word-Dokument.

    Anmerkung Sie können einen Hyperlink unter Verwendung eines in einer Datenzugriffsseite markierten Textes erstellen, nicht jedoch mit Text aus anderen Microsoft Access-Objekten.

  2. Markieren Sie den Text, mit dem Sie verknüpfen möchten.
  3. Klicken Sie im Menü Bearbeiten auf Kopieren.

  4. Wechseln Sie zu Microsoft Access, und öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  5. Klicken Sie im Menü Bearbeiten auf Als Hyperlink einfügen.

    Microsoft Access fügt dem Formular oder Bericht ein Bezeichnungsfeld hinzu. Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.


 Erstellen eines Wertlistenfelds in der Datenblattansicht

Erstellen eines Wertlistenfelds in der Datenblattansicht

  1. Öffnen Sie die Tabelle in der Datenblattansicht.

  2. Um ein Wertlistenfeld in die Tabelle einzufügen, klicken Sie auf die Spalte, vor der Sie es hinzufügen möchten, und dann im Menü Einfügen auf Nachschlagespalte.

  3. Wählen Sie im ersten Dialogfeld des Nachschlage-Assistenten die Option zum Eingeben der gewünschten Werte aus.

  4. Klicken Sie auf Weiter, und folgen Sie den Anweisungen in den übrigen Dialogfeldern Nachschlage-Assistent.

    Wenn die Arbeit mit dem Nachschlage-Assistenten beendet ist, wird das Wertlistenfeld dem Datenblatt hinzugefügt. Das neue Wertlistenfeld erhält standardmäßig einen Namen im Format Feld#, wobei # für eine Zahl steht. Sie können diesen Namen bei Bedarf ändern. Um Informationen zum Ändern eines Feldnamens in der Datenblattansicht anzuzeigen, klicken Sie auf [image] .

Anmerkung Wenn Sie den Nachschlage-Assistenten zum Erstellen einer Liste fester Werte verwenden, legt Microsoft Access bestimmte Eigenschaften auf der Basis der von Ihnen im Assistenten getroffenen Auswahlen fest. Wenn Sie das Feld erstellt haben und es einem Formular hinzufügen, kopiert Microsoft Access die Felddefinition in das Formular. Das Kombinations- oder Listenfeld wird automatisch erstellt. Wenn Sie jedoch die Definition des Feldes in der Tabelle ändern, nachdem Sie es einem Formular hinzugefügt haben, werden diese Änderungen im Formular nicht widergespiegelt. Löschen Sie in einem solchen Fall das Feld aus dem Formular, und fügen Sie es erneut hinzu. Zum Anzeigen von Informationen zu den Eigenschaften, die der Nachschlage-Assistent festlegt, klicken Sie auf [image] .


 Erstellen eines Wertlistenfelds in der Entwurfsansicht

Erstellen eines Wertlistenfelds in der Entwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Um das Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] .

    Um das Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile.

  3. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

  4. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Nachschlage-Assistent aus.

  5. Klicken Sie im ersten Dialogfeld des Nachschlage-Assistenten auf die Option zum Eingeben der gewünschten Werte.

  6. Klicken Sie auf Weiter, und folgen Sie den Anweisungen in den übrigen Dialogfeldern Nachschlage-Assistent.

Anmerkung Wenn Sie den Nachschlage-Assistenten zum Erstellen einer Liste fester Werte verwenden, legt Microsoft Access bestimmte Eigenschaften auf der Basis der von Ihnen im Assistenten getroffenen Auswahlen fest. Wenn Sie das Feld erstellt haben und es einem Formular hinzufügen, kopiert Microsoft Access die Felddefinition in das Formular. Das Kombinations- oder Listenfeld wird automatisch erstellt. Wenn Sie jedoch die Definition des Feldes in der Tabelle ändern, nachdem Sie es einem Formular hinzugefügt haben, werden diese Änderungen im Formular nicht widergespiegelt. Löschen Sie in einem solchen Fall das Feld aus dem Formular, und fügen Sie es erneut hinzu. Zum Anzeigen von Informationen zu den Eigenschaften, die der Nachschlage-Assistent festlegt, klicken Sie auf [image] .


Erstellen aller Tabellen, Formulare und Berichte für eine Datenbank in einer Operation

  • Erstellen Sie mit Hilfe des Datenbank-Assistenten alle Tabellen, Formulare und Berichte, die für eine gesamte Datenbank erforderlich sind. Der Datenbank-Assistent erstellt eine Datenbank. Er kann nicht verwendet werden, um einer bereits bestehenden Datenbank neue Tabellen, Formulare oder Berichte hinzuzufügen.

    Erstellen einer Datenbank mit Hilfe des Datenbank-Assistenten


 Arbeiten mit Tabellen oder Indizes unter Verwendung einer SQL-Datendefinitionsabfrage

Arbeiten mit Tabellen oder Indizes unter Verwendung einer SQL-Datendefinitionsabfrage

Verwenden Sie SQL-Datendefinitionsabfragen, um in der aktuellen Datenbank Tabellen zu erstellen, zu löschen oder zu ändern oder um Indizes zu erstellen.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Entwurfsansicht und dann auf OK.

  3. Klicken Sie im Dialogfeld Tabelle anzeigen auf Schließen, ohne Tabellen oder Abfragen hinzuzufügen.

  4. Zeigen Sie im Menü Abfrage auf SQL-spezifisch, und klicken Sie dann auf Datendefinition.

  5. Geben Sie die SQL-Anweisung für Ihre Datendefinitionsabfrage ein. Eine Datendefinitionsabfrage besteht immer nur aus einer einzigen Datendefinitionsanweisung. Microsoft Access unterstützt die folgenden Datendefinitionsanweisungen:
    • CREATE TABLE erstellt eine Tabelle. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • ALTER TABLE fügt einer bestehenden Tabelle ein neues Feld oder CONSTRAINT hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • DROP löscht eine Tabelle aus einer Datenbank oder entfernt einen Index aus einem Feld bzw. einer Gruppe von Feldern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • CREATE INDEX erstellt einen Index für ein Feld oder eine Gruppe von Feldern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .
  6. Um die Abfrage auszuführen, klicken Sie in der Symbolleiste auf Ausführen [image] .

Vorsicht Wenn Sie eine Datendefinitionsabfrage in einen anderen Abfragetyp, wie z.B. eine Auswahlabfrage, umwandeln, verlieren Sie die gerade eingegebene SQL-Anweisung.

Anmerkungen

  • Zum Anzeigen von Beispielen für Datendefinitionsabfragen klicken Sie auf [image] .

  • Um Objekte in ODBC-Datenbank-Servern wie z.B. Microsoft FoxPro zu erstellen oder zu ändern, verwenden Sie SQL Pass-Through-Abfragen statt Datendefinitionsabfragen.


 Erstellen einer Parameterabfrage, die Kriterien von einem benutzerdefinierten Dialogfeld erhält

Erstellen einer Parameterabfrage, die Kriterien von einem benutzerdefinierten Dialogfeld erhält

Sie können zum Eingeben von Kriterien für die einem Formular, einem Bericht oder einer Webseite zugrunde liegende Abfrage ein benutzerdefiniertes Dialogfeld verwenden, wenn Sie z.B. bestimmen möchten, welche Datensätze ein gedruckter Bericht enthalten soll.

  1. Erstellen oder öffnen Sie die Abfrage, die ihre Kriterienwerte aus dem Dialogfeld sammeln soll.

  2. Stellen Sie sicher, dass die Abfrage die Tabellen enthält, die Sie verwenden möchten.

  3. Fügen Sie dem Abfrageentwurfsbereich die Felder hinzu, die den einzelnen Steuerelementen des Dialogfelds, das für die Eingabe von Kriterienwerten vorgesehen ist, zugeordnet sind. Geben Sie für jedes dieser Felder in die Zelle Kriterien einen Ausdruck ein, der Microsoft Access anweist, sich auf das entsprechende Steuerelement im Dialogfeld für die Kriterienwerte zu beziehen. Wenn Sie beim Erstellen des Ausdrucks Hilfe benötigen, verwenden Sie den Ausdrucks-Generator. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  4. Fügen Sie dem Entwurfsbereich der Abfrage die Felder hinzu, deren Werte zurückgegeben werden sollen.

Sie können z.B. ein Dialogfeldformular namens Kunden-Info mit einem Steuerelement für das Feld Kunden-Code erstellen. Wenn Sie einen Kunden-Code in das Dialogfeld eingeben, soll die Abfrage die korrekten Angaben zur Firma, zur Adresse und zum Ort des Kunden ausgeben. Um diese Abfrage zu erstellen, gehen Sie folgendermaßen vor:

  • Fügen Sie dem Abfrageentwurfsbereich das Feld Kunden-Code hinzu. Geben Sie in die Zelle Kriterien für dieses Feld den Ausdruck ein, der Microsoft Access anweist, sich auf das Steuerelement Kunden-Code im Dialogfeld für die Kriterienwerte, welches die Abfrage verwendet, zu verweisen. In diesem Fall geben Sie folgenden Ausdruck ein: Formulare![Kunden-Info]![Kunden-Code].

  • Fügen Sie dem Abfrageentwurfsbereich die folgenden Felder hinzu, deren Werte zurückgegeben werden sollen, basierend auf dem Wert des Feldes Kunden-Code: Firma, Adresse und Ort.

Weitere Informationen zur Verwendung von Formularen zum Sammeln und Anzeigen von Informationen finden Sie in "Verwenden von Formularen zum Sammeln, Anzeigen und Filtern von Informationen" in Erstellen von Anwendungsprogrammen mit Formularen und Berichten.


 Erstellen einer leeren Datenzugriffsseite

Erstellen einer leeren Datenzugriffsseite

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie auf der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neue Datenzugriffsseite auf Entwurfsansicht.

  4. Klicken Sie auf OK.

Microsoft Access zeigt die Datenzugriffsseite in der Entwurfsansicht an, in der Sie die Seite bearbeiten können.


 Erstellen eines gebundenen Listenfeldes, Kombinationsfeldes oder einer Dropdownliste, das/die Daten aus einer Tabelle oder Abfrage in einem Microsoft Access-Projekt oder einer Datenzugriffsseite abruft

Erstellen eines gebundenen Listenfeldes, Kombinationsfeldes oder einer Dropdownliste, das/die Daten aus einer Tabelle oder Abfrage in einem Microsoft Access-Projekt oder einer Datenzugriffsseite abruft

  1. Erstellen Sie ein Formular, einen Bericht oder eine Datenzugriffsseite auf der Basis einer Datenherkunft, die ein Fremdschlüssel-Feld enthält.

  2. Vergewissern Sie sich, dass in der Toolbox das Steuerelement-Assistent-Tool [image] gedrückt ist.

    Anmerkung Assistenten sind nicht verfügbar, wenn Sie eigenständige Datenzugriffsseiten verwenden, oder wenn Sie in einer Datenzugriffsseite auf eine andere Datenbank als die aktuell geöffnete verweisen. In diesen Fällen müssen Sie das Listenfeld oder die Dropdownliste selbst erstellen.

  3. Klicken Sie auf das Listenfeld-Steuerelement Listenfeld-Steuerelement , Kombinationsfeld-Steuerelement oder Dropdownlisten-Steuerelement und klicken Sie dann auf die Stelle, an der Sie das Steuerelement in dem Formular, dem Bericht oder der Datenzugriffsseite platzieren wollen.

  4. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Wenn der Assistent fragt, wie Sie die Werte für die Liste erhalten möchten, wählen Sie die Option zum Nachschlagen der Werte in einer Tabelle oder Abfrage.

  5. Wenn in einem Formular oder Bericht der Assistent fragt, ob der Wert in dem Feld gespeichert werden soll, wählen Sie die Option zum Speichern des Wertes in dem Feld und Auswählen des Feldes in der Liste.

  6. Klicken Sie im letzten Dialogfeld des Assistenten auf Fertig stellen.

  7. Auf einer Datenzugriffsseite klicken Sie auf der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das Steuerelement zu öffnen. Wählen Sie im Einstellungsfeld des Steuerelementinhalts das Feld aus, an welches das Listenfeld oder die Dropdownliste gebunden werden soll.

Anmerkungen

  • Klicken Sie hier, um Informationen über die Eigenschaften zu erhalten, welche die Funktionsweise von Listenfeldern und Kombinationsfeldern in Formularen festlegen [image] .

  • Klicken Sie hier, um Informationen über die Eigenschaften zu erhalten, welche die Funktionsweise von Listenfeldern und Kombinationsfeldern in Datenzugriffsseiten festlegen [image] .


 Erstellen eines gebundenen Listen- oder Kombinationsfelds in einem Formular, das Daten einer Access-Datenbank anzeigt

Erstellen eines gebundenen Listen- oder Kombinationsfelds in einem Formular, das Daten einer Access-Datenbank anzeigt

Sie können ein gebundenes Listen- oder Kombinationsfeld erstellen, das Informationen aus einem Nachschlagefeld in einer Tabelle in einer Microsoft Access-Datenbank (.mdb) abruft. In Microsoft Access-Projekten (.adp) gibt es keine Nachschlagefelder in den Tabellen, jedoch können Sie ein gebundenes Listenfeld, Kombinationsfeld oder eine Dropdownliste erstellen, das bzw. die Daten ohne Verwendung eines Nachschlagefelds anzeigt.

  1. Erstellen Sie ein Nachschlagefeld in der Entwurfsansicht für Tabellen.

    Wie wird's gemacht?

    Anmerkung Sie können ein Nachschlagelistenfeld oder -kombinationsfeld erstellen, ohne ein Nachschlagefeld zu erstellen. Wenn Sie aber ein Nachschlagefeld in einer Tabelle erstellen, brauchen Sie das Listen- oder Kombinationsfeld nur einmal zu erstellen. Sie können dann in jedem beliebigen Formular dieselbe Nachschlageliste verwenden. Falls Sie nicht beabsichtigen, dieselbe Nachschlageliste in mehreren Formularen zu verwenden, können Sie den Listenfeld- oder Kombinationsfeld-Assistenten in der Entwurfsansicht für Formulare verwenden.

  2. Führen Sie einen der folgenden Schritte durch:
    • Erstellen Sie ein neues Formular, das auf einer Datenherkunft basiert, welche das in Schritt 1 erstellte Nachschlagefeld enthält. Microsoft Access erstellt dann automatisch das Nachschlagelistenfeld oder -kombinationsfeld.

    • Öffnen Sie ein bestehendes Formular, das auf einer Datenherkunft basiert, welche das in Schritt 1 erstellte Nachschlagefeld enthält. Klicken Sie in der Entwurfsansicht des Formulars in der Symbolleiste auf Feldliste [image] , um die Feldliste anzuzeigen, und ziehen Sie das Nachschlagefeld aus der Feldliste in das Formular. Microsoft Access erstellt dann automatisch das Nachschlagelistenfeld oder -kombinationsfeld.
  3. Wechseln Sie zur Formularansicht, um das Listen- oder Kombinationsfeld zu testen.

Anmerkungen

  • Zum Anzeigen von Informationen zu Eigenschaften, die die Arbeitsweise eines Listen- oder Kombinationsfelds festlegen, klicken Sie auf [image] .

  • Wenn Sie mit Hilfe eines Assistenten ein Listenfeld oder Kombinationsfeld erstellen, das auf einer Tabelle oder Abfrage basiert, erzeugt Microsoft Access auf der Basis der von Ihnen ausgewählten Felder eine SQL-Anweisung und stellt dann die Datensatzherkunft-Eigenschaft für das Steuerelement auf diese SQL-Anweisung ein. Falls das Listen- oder Kombinationsfeld nicht in der gewünschten Reihenfolge sortiert ist, können Sie die SQL-Anweisung ändern, indem Sie auf die Generator-Schaltfläche [image] neben Datensatzherkunft klicken. Klicken Sie hier, um weitere Informationen zum Festlegen einer Sortierreihenfolge im SQL-Anweisungs-Generator zu erhalten [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung bei Listen- und Kombinationsfeldern klicken Sie auf [image] .


 Hinzufügen eines gebundenen Objektfelds in einem Formular oder Bericht

Hinzufügen eines gebundenen Objektfelds in einem Formular oder Bericht

  1. Falls noch nicht geschehen, erstellen Sie ein Feld in einer Tabelle, und legen Sie für dieses Feld in einer Microsoft Access-Datenbank (.mdb) den Datentyp OLE-Objekt, in einem Microsoft Access-Projekt (.adp) dagegen den Datentyp Image fest.

    Wie wird's gemacht?

  2. Erstellen Sie ein Formular oder einen Bericht (oder öffnen Sie ein vorhandenes Formular oder einen vorhandenen Bericht), dessen Datenherkunft das Feld vom Datentyp OLE-Objekt bzw. die Spalte vom Datentyp Image enthält.

  3. Klicken Sie in der Formular-Entwurfsansicht oder der Berichts-Entwurfsansicht in der Symbolleiste auf Feldliste [image] , um die Feldliste anzuzeigen.

  4. Ziehen Sie das OLE-Objekt-Feld bzw. die Image-Spalte aus der Feldliste in das Formular oder den Bericht.

    Microsoft Access erstellt ein an das OLE-Objekt-Feld bzw. die Image-Spalte gebundenes Objektfeld.

Anmerkung Wenn Sie das gebundene Objektfeld bereits erstellt haben, können Sie dieses an ein Feld in einer zugrunde liegenden Datenherkunft binden. Dazu stellen Sie die Steuerelementinhalt-Eigenschaft für das gebundene Objektfeld auf den Namen des Feldes ein.


 Erstellen eines gebundenen Lauftext-Steuerelements, das Daten auf einer Datenzugriffsseite anzeigt

Erstellen eines gebundenen Lauftext-Steuerelements, das Daten auf einer Datenzugriffsseite anzeigt

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Lauftext-Steuerelement Lauftext-Steuerelement .

  3. Klicken Sie in der Symbolleiste auf Feldliste [image] , um die Feldliste einzublenden.

  4. Ziehen Sie ein ausgewähltes Feld aus der Feldliste auf die Datenzugriffsseite. Setzen Sie die linke obere Ecke des Symbols an die Stelle, an der die linke obere Ecke des Lauftext-Steuerelements stehen soll.


 Erstellen eines gebundenen Textfelds

Erstellen eines gebundenen Textfelds

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Feldliste [image] . Die Feldliste wird angezeigt. Sind in einem Formular oder Bericht die Schaltfläche und der Befehl Feldliste nicht verfügbar, müssen Sie das Formular oder den Bericht an eine Datenherkunft binden. Falls die Feldliste in einer Datenzugriffsseite leer ist, müssen Sie die Seite mit einer Datenbank verbinden.

  3. Führen Sie einen der folgenden Schritte durch:
    • Wählen Sie in der Feldliste eines Formulars oder Berichts ein oder mehrere Felder aus.
    Auswahl | Aktion
    Ein Feld | Klicken Sie auf das gewünschte Feld.
    Mehrere benachbarte Felder | Klicken Sie auf das erste Feld, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf das letzte Feld.
    Nicht benachbarte Felder | Halten Sie die STRG-TASTE gedrückt, und klicken Sie dann auf die Felder, die sie auswählen wollen.
    Alle Felder | Doppelklicken Sie auf die Titelleiste der Feldliste.

    • Wählen Sie auf einer Datenzugriffsseite in der Feldliste ein Feld, eine Tabelle oder eine Abfrage aus.
    Auswahl | Aktion
    Ein Feld | Klicken Sie auf das Feld.
    Eine Tabelle oder Abfrage | Klicken Sie in der Toolbox auf das Tool Steuerelement-Assistenten [image] , falls es noch nicht aktiviert ist, und klicken Sie dann auf die Tabelle oder Abfrage.
  4. Führen Sie einen der folgenden Schritte durch:
    • Ziehen Sie das Feld oder die Felder aus der Feldliste, und positionieren Sie es/sie im Formular oder Bericht.

    • Ziehen Sie das Feld, die Tabelle oder die Abfrage aus der Feldliste, und positionieren Sie es/sie auf der Datenzugriffsseite. Klicken Sie im Dialogfeld Layout-Assistent auf Einzelne Steuerelemente.

    Anmerkung Sie müssen das Feld bzw. die Felder aus der Feldliste ziehen. Wenn Sie zuerst auf das Feld oder die Felder in der Feldliste klicken und danach in das Formular, den Bericht oder auf die Datenzugriffsseite klicken, erstellt Microsoft Access das Steuerelement nicht.

    Access fügt für jedes Feld, das Sie in der Feldliste auswählen, ein Textfeld im Formular, Bericht oder auf der Datenzugriffsseite ein. Jedes Textfeld ist an ein Feld in der zugrunde liegenden Datenquelle gebunden. Außerdem erhält jedes Textfeld standardmäßig ein zugeordnetes Bezeichnungsfeld.

  5. Passen Sie die Größe des Textfelds an die Daten an, die Sie darin anzeigen möchten.

  6. Ändern Sie gegebenenfalls den Text des Bezeichnungsfelds.

  7. Wechseln Sie zur Formularansicht, Datenblattansicht, Datenzugriffsseitenansicht oder Seitenansicht, um das Steuerelement zu überprüfen.

Anmerkung Zu Textfeldern mit mehreren Textzeilen in Formularen können Sie eine vertikale Bildlaufleiste hinzufügen.

Wie wird's gemacht?


 Erstellen von datengebundenen Kontrollkästchen, Umschaltflächen oder Optionsfeldern

Erstellen von datengebundenen Kontrollkästchen, Umschaltflächen oder Optionsfeldern

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie auf das gewünschte Steuerelement in der Toolbox. Wenn Sie nicht sicher sind, welches das richtige Steuerelement ist, positionieren Sie den Zeiger auf einem der Steuerelemente, so dass die QuickInfo angezeigt wird.

    Anmerkung Umschaltflächen sind in Datenzugriffsseiten nicht verfügbar.

  3. Klicken Sie in der Symbolleiste auf Feldliste [image] . Die Feldliste wird angezeigt. Sind in einem Formular oder Bericht die Schaltfläche und der Befehl Feldliste nicht verfügbar, müssen Sie das Formular oder den Bericht an eine Datenherkunft binden. Falls die Feldliste in einer Datenzugriffsseite leer ist, müssen Sie die Seite mit einer Datenbank verbinden.

  4. Klicken Sie in der Feldliste auf das entsprechende Feld (in einer Microsoft Access-Datenbank ein Feld vom Datentyp Ja/Nein, in einem Microsoft Access-Projekt eine Spalte vom Datentyp Bit), und ziehen Sie es in das Formular, den Bericht oder die Datenzugriffsseite.

    Anmerkung Sie müssen die Felder aus der Feldliste ziehen. Wenn Sie auf die Felder in der Feldliste klicken und danach in das Formular, den Bericht oder die Datenzugriffsseite klicken, wird das Steuerelement nicht gebunden.

  5. Ändern Sie gegebenenfalls den Text des Bezeichnungsfelds.

  6. Wechseln Sie zur Formularansicht, Datenblattansicht, Datenzugriffsseitenansicht oder Seitenansicht, um das Steuerelement zu überprüfen.

Tipp Wenn Sie häufiger das gleiche Ja/Nein-Feld bzw. die gleiche Bit-Spalte in verschiedenen Formularen und Berichten einer Datenbank als Kontrollkästchen anzeigen, können Sie die Eigenschaft Steuerelement anzeigen des Feldes so einstellen, dass beim Ziehen des Feldes aus der Feldliste automatisch ein Kontrollkästchen erstellt wird. (Sie brauchen nicht vorher auf das Kontrollkästchen-Steuerelement zu klicken. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


Erstellen von Spalten - Beispiel

Das folgende Beispiel erstellt eine neue Tabelle mit zwei neuen Spalten. Eine der Spalten wird auf AutoWert eingestellt. Diese Spalte wird von der Prozedur außerdem als Primärschlüssel der Tabelle festgelegt.

Anmerkung Die AutoIncrement-Eigenschaft ist in einem ADP über den im Lieferumfang von Microsoft Access 2000 enthaltenen SQL-Provider nicht verfügbar. Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Sub NeueTabelle()
    Dim tbl As New ADOX.Table
    Dim cat As New ADOX.Catalog
    Dim idx As New ADOX.Index

    ' Verweis auf aktuelle Datenbank zurückgeben.
    Set cat.ActiveConnection = CurrentProject.Connection
       With tbl
        .Name = "Kontakte"
        With .Columns
            .Append "Kontakt-Nr", adInteger
            .Append "Kontaktperson", , 50

        ' Falls in einem ADP, die folgende With-Klausel weglassen.
          With ![Kontakt-Nr]
                Set .ParentCatalog = cat
                .Properties("AutoIncrement")=True
         End With
        End With
    End With

    ' Primärschlüsselindex erstellen.
    idx.Name = "Primärschlüssel"

    ' Indexspalte anfügen.
    idx.Columns.Append "Kontakt-Nr", adInteger

     ' PrimaryKey-Eigenschaft einstellen.
    idx.PrimaryKey = True
    ' Index anfügen.
    tbl.Indexes.Append idx
    ' TableDef-Objekt anfügen.
    cat.Tables.Append tbl

    Set tbl = Nothing
    Set cat = Nothing
End Sub


Erstellen einer Befehlsschaltfläche, die einen Hyperlink auf einem Formular oder Bericht darstellt

Was möchten Sie tun?

Eine Verknüpfung zu einer bestehenden Datei oder Webseite erstellen

Eine Verknüpfung zu einer Tabelle, einer Abfrage, einem Formular, einem Bericht oder einer Datenzugriffsseite in der aktuellen Datenbank erstellen

Eine neue Datenzugriffsseite und einen Hyperlink zu dieser Seite erstellen

Einen Hyperlink erstellen, der das E-Mail-Programm öffnet und eine Nachricht an die angegebene E-Mail-Adresse erstellt


 Erstellen einer Befehlsschaltfläche ohne Verwendung eines Assistenten

Erstellen einer Befehlsschaltfläche ohne Verwendung eines Assistenten

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent aktiviert ist. Dadurch wird der Assistent deaktiviert.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular oder auf der Datenzugriffsseite auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Vergewissern Sie sich, dass Sie die Befehlsschaltfläche ausgewählt haben, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Befehlsschaltfläche zu öffnen.

  6. In Formularen geben Sie im Einstellungsfeld der BeimKlicken-Eigenschaft den Namen des Makros oder der Ereignisprozedur ein, das/die beim Klicken auf die Schaltfläche ausgeführt werden soll. Sie können auch auf die Generator-Schaltfläche [image] klicken, um den Makro-Generator oder den Code-Generator zu verwenden. In Datenzugriffsseiten können Sie mit Hilfe des Microsoft Skript-Editors einer Befehlsschaltfläche in JScript oder in Microsoft Visual Basic Scripting Edition (VBScript) geschriebenen Code zuordnen. So erstellen Sie Ereignisprozeduren für Befehlsschaltflächen auf Datenzugriffsseiten.

  7. Wenn Sie auf der Schaltfläche Text anzeigen möchten, geben Sie diesen in Formularen in das Einstellungsfeld der Beschriftung-Eigenschaft, in Datenzugriffsseiten in das Einstellungsfeld der Value-Eigenschaft ein. In Formularen können Sie auf der Schaltfläche statt des Textes auch ein Bild anzeigen.

    Wie wird's gemacht?

Tipp Um in einem Formular eine Befehlsschaltfläche zu erstellen, die ein Makro ausführt, ziehen Sie das entsprechende Makro vom Datenbankfenster in die Entwurfsansicht des Formulars.

Klicken Sie hier, um einen Überblick über die Ereignisse und Ereignisprozeduren zu erhalten [image] .


 Erstellen einer Befehlsschaltfläche unter Verwendung eines Assistenten

Erstellen einer Befehlsschaltfläche unter Verwendung eines Assistenten

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent nicht bereits aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Befehlsschaltflächen-Steuerelement Befehlsschaltflächen-Steuerelement .

  4. Klicken Sie im Formular oder auf der Datenzugriffsseite auf die Stelle, an der Sie die Befehlsschaltfläche einfügen möchten.

  5. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Befehlsschaltfläche in der Entwurfsansicht anzuzeigen.

Anmerkung In eigenständigen Datenzugriffsseiten, oder wenn Sie eine Datenzugriffsseite auf eine andere Datenbank als die zu diesem Zeitpunkt geöffnete verweisen, sind Assistenten nicht verfügbar. Der Befehlsschaltflächen-Assistent ist ebenfalls nicht verfügbar, wenn die Datenzugriffsseite nicht an eine Tabelle oder Abfrage gebunden ist. Wenn keine Assistenten zur Verfügung stehen, müssen Sie die Befehlsschaltflächen selbst erstellen.


 Erstellen eines benutzerdefinierten Dialogfelds

Erstellen eines benutzerdefinierten Dialogfelds

  1. Erstellen Sie das Formular. Es kann eine beliebige Zusammenstellung von Steuerelementen enthalten.

  2. Doppelklicken Sie in der Entwurfsansicht für Formulare auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft PopUp auf Ja.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft Gebunden auf Ja.

  5. Klicken Sie im Einstellungsfeld der Eigenschaft Rahmenart auf Dialog. Wenn Sie die Einstellung Dialog wählen, besitzt das Formular einen breiten Rahmen und kann lediglich eine Titelleiste und ein Systemmenü enthalten. Das Formular kann nicht maximiert, minimiert oder sonst in der Größe verändert werden.

  6. Erstellen Sie ein Makro oder eine Ereignisprozedur, das bzw. die das Formular öffnet.

  7. Ordnen Sie das Makro oder die Ereignisprozedur einem Formular oder Bericht zu, indem Sie den Makro- bzw. Ereignisprozedurnamen als Einstellung der entsprechenden Ereigniseigenschaft angeben. Geben Sie beispielsweise den Namen des Makros bzw. der Ereignisprozedur in das Einstellungsfeld der Eigenschaft BeimKlicken einer Befehlsschaltfläche ein.

Anmerkungen

  • Ein benutzerdefiniertes Dialogfeld enthält üblicherweise eine oder mehrere Befehlsschaltflächen, mit deren Hilfe Makros oder Ereignisprozeduren ausgeführt werden, welche die in das Dialogfeld eingegebenen Informationen zum Ausführen anderer Aktionen verwenden. Diese Schaltflächen werden meist OK und Abbrechen genannt. Sie können steuern, welche Schaltfläche den Fokus besitzt und welche die Funktion der Schaltfläche Abbrechen übernimmt, indem Sie die Eigenschaften Standard und Abbrechen dieser Befehlsschaltflächenarten einstellen. Um weitere Informationen über die Eigenschaft Standard zu erhalten, klicken Sie auf [image] . Um weitere Informationen über die Eigenschaft Abbrechen zu erhalten, klicken Sie auf [image] .

  • Um ein benutzerdefiniertes Dialogfeld auf dem Bildschirm zu positionieren, öffnen Sie das Formular in der Entwurfsansicht, zeigen Sie das Microsoft Access-Fenster als Vollbild an, positionieren Sie das Dialogfeld an der gewünschten Stelle, und speichern Sie es dann. Das Dialogfeld wird beim Öffnen an dieser Stelle angezeigt (unter der Bedingung, dass die Eigenschaft AutomatischZentrieren auf Nein eingestellt ist).

  • Um Informationen über andere Eigenschaften anzuzeigen, die Sie für ein benutzerdefiniertes Dialogfeld einstellen möchten, klicken Sie auf [image] .

  • Um Informationen über das Erstellen eines benutzerdefinierten Dialogfelds anzuzeigen, das Sie zur Eingabe von Berichtskriterien auffordert, klicken Sie auf [image] .

  • Klicken Sie hier, um Informationen zum Erstellen von gespeicherten Prozeduren anzuzeigen, die ihre Kriterien über selbst definierte Dialogfelder in Microsoft Access-Datenbanken (.mdb) erhalten [image] . Um Informationen zum Erstellen von gespeicherten Prozeduren anzuzeigen, die ihre Kriterien über selbst definierte Dialogfelder in Microsoft Access-Projekten (.adp) erhalten, klicken Sie hier [image] .

  • Wenn Sie das Formular sowohl als normales Formular als auch als Dialogfeld verwenden möchten, können Sie es mit Hilfe der Einstellung Dialog der Aktion ÖffnenFormular temporär als Dialogfeld öffnen, anstatt die oben beschriebene Vorgehensweise auszuführen. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Erstellen von Gruppen

Erstellen von Gruppen

  1. Wechseln Sie zum Datenbankfenster, falls dies noch nicht geschehen ist. Sie können von beliebigen anderen Fenstern zum Datenbankfenster wechseln, indem Sie F11 drücken.

  2. Klicken Sie auf die Gruppen-Leiste.

  3. Klicken Sie mit der rechten Maustaste an eine beliebige Stelle unter der Gruppen-Leiste. Klicken Sie im Kontextmenü auf Neue Gruppe.

  4. Geben Sie im FeldNeuer Gruppenname einen Namen für die neue Gruppe ein.


Erstellen benutzerdefinierter Datenbankeigenschaften, die zum Suchen von Microsoft Access-Datenbanken oder Microsoft Access-Projekten verwendet werden

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften, während die Datenbank geöffnet ist.

  2. Klicken Sie auf die Registerkarte Anpassen, und geben Sie dann Werte für die neue Eigenschaft in die Felder Name, Typ und Wert ein.

  3. Klicken Sie auf Hinzufügen.

  4. Wenn Sie alle gewünschten Eigenschaften hinzugefügt haben, klicken Sie auf OK.


 Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer Datenzugriffsseite, die für Dateneingaben verwendet wird

Berechnen einer Summe oder eines anderen Wertes für einen Datensatz auf einer Datenzugriffsseite, die für Dateneingaben verwendet wird

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Fügen Sie die Steuerelemente hinzu, welche die für die Berechnung zu verwendenden Daten enthalten, falls diese sich noch nicht auf der Datenzugriffsseite befinden.

  3. Klicken Sie in der Toolbox auf das Steuerelement Office Spreadsheet Office Spreadsheet-Steuerelement , und lassen Sie die Maustaste an der Stelle los, an der die obere linke Ecke des Kalkulationstabellen-Steuerelement auf der Datenzugriffsseite platziert werden soll.

  4. Geben Sie in beliebige Zellen der Kalkulationstabelle Formeln ein, die mittels der HTML-Funktion Dokument auf die für die Berechnung verwendeten Felder verweisen und die jeweilige Rechenoperation enthalten, die an den Feldwerten ausgeführt werden soll, ausgedrückt als Kombination von Operatoren, Bezeichnern und Werten.

    Beispiel Um den Wert im Feld Anzahl mit dem Wert im Feld Einzelpreis zu multiplizieren, geben Sie Folgendes ein:

    =document.Anzahl.value*document.Einzelpreis.value

    Beispiel Um den Wert im Feld Einzelpreis mit einem in der Tabellenzelle C1 gespeicherten Prozentwert zu multiplizieren, geben Sie Folgendes ein:

    =$C$1*document.Einzelpreis.value

Anmerkungen

  • Um den Namen einer Tabelle zu erfahren, wählen Sie das entsprechende Steuerelement aus, und zeigen Sie das Eigenschaftenfenster an. Der Name der Tabelle steht in der Titelleiste des Eigenschaftenfensters.

  • Weitere Beispiele für Formeln anzeigen, die sich auf Steuerelemente auf Datenzugriffsseiten beziehen.

  • Sie können Kalkulationstabellenfunktionen verwenden, die in Microsoft Access nur mittels dieses Steuerelements zur Verfügung stehen.

  • Wahrscheinlich soll der berechnete Wert in einem Bereich angezeigt werden, der im Aussehen mit den anderen Steuerelementen auf der Seite übereinstimmt. Dazu können Sie das Erscheinungsbild des Tabellen-Steuerelements verändern, so dass es wie ein Textfeld-Steuerelement aussieht.


 Erstellen von Datenzugriffsseiten mit AutoSeite

Erstellen von Datenzugriffsseiten mit AutoSeite

AutoSeite erstellt eine Datenzugriffsseite, die alle Felder (ausgenommen Felder für Bilder) und Datensätze der zugrunde liegenden Tabelle, Abfrage oder Sicht enthält.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie auf der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neue Datenzugriffsseite auf AutoSeite: Einspaltig. Auf der erstellten Datenzugriffsseite steht jedes Feld in einer neuen Zeile und hat auf der linken Seite ein Bezeichnungsfeld.

  4. Klicken Sie auf die Tabelle, Abfrage oder Sicht, welche die Daten enthält, die der Seite zugrunde liegen sollen.

  5. Klicken Sie auf OK.

    Falls das Aussehen der erstellten Seite nicht Ihren Wünschen entspricht, können Sie in der Entwurfsansicht die Seite verändern.

Anmerkungen

  • Microsoft Access wendet das standardmäßige Design auf die Seite an. Falls Sie bisher keine Auswahl eines Standarddesigns getroffen haben, verwendet Access das Design Geradlinig.

  • Beim Erstellen einer Datenzugriffsseite mit AutoSeite speichert Microsoft Access die Seite automatisch als HTML-Datei im aktuellen Ordner und fügt dem Datenbankfenster eine Verknüpfung zu der Seite hinzu. Um den Pfad zu der Datei anzuzeigen, bewegen Sie im Datenbankfenster den Zeiger über die Verknüpfung.


 Umwandeln einer vorhandenen Webseite in eine Datenzugriffsseite

Umwandeln einer vorhandenen Webseite in eine Datenzugriffsseite

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie auf der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neue Datenzugriffsseite auf Bestehende Webseite.

  4. Klicken Sie auf OK.

  5. Suchen Sie im Dialogfeld Webseite suchen die Webseite oder HTML-Datei, die Sie öffnen möchten.

  6. Klicken Sie auf Öffnen.

Microsoft Access zeigt die Datenzugriffsseite in der Entwurfsansicht an, in der Sie die Seite bearbeiten können.

Anmerkungen

  • Wenn Sie eine Webseite in Microsoft Access speichern, erstellt Access im Datenbankfenster eine Verknüpfung zu der HTML-Datei.

  • Sie können eine Webseite suchen, indem Sie die Schaltfläche Im Web suchen im Dialogfeld Webseite suchen betätigen. Eine Kopie der Seite können Sie mit Hilfe des Befehls Speichern unter im Menü Datei in Internet Explorer speichern und dann mit der oben beschriebenen Methode in der Entwurfsansicht öffnen.


 Erstellen von Datenzugriffsseiten mit Hilfe eines Assistenten

Erstellen von Datenzugriffsseiten mit Hilfe eines Assistenten

  1. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] .

  2. Klicken Sie auf der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neue Datenzugriffsseite auf Seiten-Assistent.

  4. Klicken Sie auf die Tabelle, Abfrage oder Sicht, welche die Daten enthält, die der Datenzugriffsseite zugrunde liegen sollen.

    Anmerkung Diesen Schritt müssen Sie nicht sofort durchführen - sie können die Datenherkünfte für die Seite auch im Assistenten festlegen.

  5. Klicken Sie auf OK.

  6. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.

    Falls das Aussehen der erstellten Seite nicht Ihren Wünschen entspricht, können Sie in der Entwurfsansicht die Seite verändern.

Anmerkung Beim Erstellen einer Datenzugriffsseite mit einem Assistenten speichert Microsoft Access die Seite automatisch als HTML-Datei im aktuellen Ordner und fügt dem Datenbankfenster eine Verknüpfung zu der Seite hinzu. Um den Pfad zu der Datei anzuzeigen, bewegen Sie im Datenbankfenster den Zeiger auf die Verknüpfung.


Selbstständiges Erstellen von Datenzugriffsseiten

Die in diesem Thema beschriebenen Schritte sollen Sie vom Beginn bis zum Abschluss durch den Vorgang der Erstellung von Datenzugriffsseiten leiten. Manche dieser Schritte führen Sie bei der Erstellung aller Arten von Datenzugriffsseiten durch. Andere verwenden Sie nur, wenn Sie eine bestimmte Seitenart erstellen - zum Beispiel eine Seite, die Datensätze nach Kategorien gruppiert oder Summen berechnet. Sie müssen jeweils nur die Schritte durchführen, die für die zu erstellende Seitenart erforderlich sind. Informationen zu anderen Aufgaben im Zusammenhang mit der Erstellung von Datenzugriffsseiten finden Sie im Antwort-Assistenten.

Überblick über Zweck und Funktionsweise von Datenzugriffsseiten

Informationen über das Gruppieren von Datensätzen auf einer Datenzugriffsseite

Informationen über die Verwendung von Datenzugriffsseiten zur Dateneingabe

  1. Mit der Erstellung der Datenzugriffsseite beginnen

    Eine leere Datenzugriffsseite erstellen

  2. Daten, Text und Summen auf Datenzugriffsseiten anzeigen

    Informationen über das Anzeigen von Daten, Text und Summen in Textfeldern, Beschriftungsfeldern oder anderen Steuerelementen erhalten

    Informationen über das Anzeigen von Daten zur mit Hilfe der Feldliste erhalten

    Daten aus einer Tabelle oder Abfrage anzeigen

    Einen Titel oder andere Informationstexte anzeigen

    Eine Summe für einen Datensatz berechnen

    Eine Summe für eine Gruppe von Datensätzen berechnen

    Eine Gesamtsumme berechnen

    Weitere Informationen über Textfelder, Bezeichnungsfelder und andere Steuerelemente erhalten

  3. Die Daten auf der Datenzugriffsseiten sortieren oder gruppieren

    Die Standard-Sortierreihenfolge für Datensätze festlegen

    Die Größe eines Kopfbereichs, Fußbereichs oder sonstigen Bereichs ändern

    Datensätze auf einer Seite gruppieren, die nur zum Anzeigen von Daten verwendet wird

  4. Bezeichnungsfelder, Textfelder und andere Steuerelemente formatieren, verschieben, in der Größe verändern und ausrichten

    Text in Bezeichnungsfeldern, Textfeldern und anderen Steuerelementen fett, kursiv oder unterstrichen formatieren

    Textfelder oder andere Steuerelemente mit ihren Bezeichnungsfeldern verschieben

    Die Größe von Bezeichnungsfeldern, Textfeldern und anderen Steuerelementen ändern

    Textfelder und andere Steuerelemente ausrichten

    Ein Datensatznavigationssteuerelement anpassen

  5. Eine Datenzugriffsseite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer anzeigen

    Eine Datenzugriffsseite in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer öffnen

    Zwischen Ansichten einer geöffneten Seite wechseln

  6. Eine Datenzugriffsseite veröffentlichen, um sie anderen Benutzern zur Verfügung zu stellen

    Informationen über das Freigeben einer Datenbank erhalten, mit der eine Datenzugriffsseite verbunden ist

    Eine Datenzugriffsseite in Webordnern oder auf Webservern veröffentlichen


 Anlegen einer Datenbank unter Verwendung des Datenbank-Assistenten

Anlegen einer Datenbank unter Verwendung des Datenbank-Assistenten

  1. Wenn beim Starten von Microsoft Access automatisch ein Dialogfeld mit Optionen zum Anlegen einer neuen Datenbank oder Öffnen einer bestehenden Datenbank angezeigt wird, klicken Sie auf Datenbank-Assistent und dann auf OK.

    Wenn Sie bereits eine Datenbank geöffnet oder das Dialogfeld geschlossen haben, das beim Starten von Microsoft Access angezeigt wird, klicken Sie in der Symbolleiste auf Neue Datenbank [image] .

  2. Doppelklicken Sie in der Registerkarte Datenbanken auf das Symbol für den Datenbanktyp, den Sie erstellen möchten.

  3. Geben Sie einen Namen und einen Standort für die Datenbank ein.

  4. Klicken Sie auf Anlegen, um mit der Definition der neuen Datenbank zu beginnen.


 Erstellen einer Datenbank ohne Verwendung eines Assistenten

Erstellen einer Datenbank ohne Verwendung eines Assistenten

  1. Beim Starten von Microsoft Access wird automatisch ein Dialogfeld mit Optionen zum Erstellen einer neuen Datenbank oder Öffnen einer bestehenden Datenbank angezeigt. Klicken Sie auf Leere Datenbank und dann auf OK.

    Wenn Sie bereits eine Datenbank geöffnet oder das Dialogfeld geschlossen haben, das beim Starten von Microsoft Access angezeigt wird, klicken Sie in der Symbolleiste auf Neue Datenbank [image] , und doppelklicken Sie dann in der Registerkarte Allgemein auf das Symbol Leere Datenbank.

  2. Geben Sie einen Namen und einen Standort für die Datenbank ein, und klicken Sie auf Anlegen.

Nachdem Sie eine leere Datenbank erstellt haben, müssen Sie die Objekte für Ihre Datenbank definieren.


 Erstellen und Einfügen eines gebundenen Objekts in einem Formular

Erstellen und Einfügen eines gebundenen Objekts in einem Formular

  1. Erstellen Sie gegebenenfalls ein gebundenes Objektfeld in einem Formular.

    Wie wird's gemacht?

  2. Wechseln Sie zur Formularansicht oder zur Datenblattansicht.

  3. Gehen Sie zu dem Datensatz, in den Sie das Objekt einfügen möchten, und klicken Sie in einer Microsoft Access-Datenbank (.mdb) auf das OLE-Objektfeld, in einem Microsoft Access-Projekt (.adp) dagegen auf eine Image-Spalte.

  4. Klicken Sie im Menü Einfügen auf Objekt.

  5. Klicken Sie im Dialogfeld Objekt einfügen auf Neu erstellen, falls noch nicht ausgewählt, und dann im Feld Objekttyp auf den Typ des Objekts, das Sie erstellen möchten.

  6. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich beispielsweise dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  7. Klicken Sie auf OK.

  8. Erstellen Sie das Objekt unter Verwendung der in Schritt 5 ausgewählten Anwendung, und führen Sie dann einen der folgenden Schritte durch:
    • Wenn Sie das Objekt an der vorgesehenen Stelle erstellt haben, klicken Sie außerhalb des gebundenen Objektfeldes auf das Formular. Sie können Microsoft Access beenden, indem Sie im Menü Datei auf Beenden klicken.

    • Falls das Objekt, das Sie erstellt haben, in einem anderen Fenster geöffnet wurde, klicken Sie im Menü Datei der OLE-Server-Anwendung auf Beenden. Werden Sie aufgefordert, das Dokument zu aktualisieren, klicken Sie auf OK.
  9. Wenn Sie sich in der Formularansicht befinden, zeigt Microsoft Access das Objekt an. In der Datenblattansicht zeigt Microsoft Access den Namen des Objekts an, beispielsweise Bitmap-Bild.

  10. Doppelklicken Sie auf das Objekt, wenn Sie es bearbeiten möchten.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Sie können ein gebundenes Objekt auch in das Datenblatt einer Tabelle oder Abfrage einfügen. Dazu wählen Sie einfach das Feld, in das Sie das Objekt einfügen möchten (dies muss ein OLE-Objekt-Feld oder eine Image-Spalte sein) und führen dann die Schritte 4 bis 9 durch. Zum Anzeigen des Objekts müssen Sie in einem Formular oder Bericht ein gebundenes Objektfeld erstellen.


 Erstellen und Einfügen eines ungebundenen Objekts in einem Formular oder Bericht

Erstellen und Einfügen eines ungebundenen Objekts in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Formularentwurfsansicht oder einen Bericht in der Berichtsentwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Objektfeld [image] .

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Objekt einfügen möchten.

  4. Klicken Sie im Dialogfeld Objekt einfügen gegebenenfalls auf Neu erstellen und dann im Feld Objekttyp auf den gewünschten Objekttyp.

  5. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich beispielsweise dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  6. Klicken Sie auf OK. Microsoft Access erstellt ein ungebundenes Objektfeld.

  7. Erstellen Sie das Objekt unter Verwendung der in Schritt 4 ausgewählten Anwendung, und führen Sie dann einen der folgenden Schritte durch:

    • Wenn Sie das Objekt an der vorgesehenen Stelle erstellt haben, klicken Sie außerhalb des ungebundenen Objektfeldes auf das Formular. Sie können Microsoft Access beenden, indem Sie im Menü Datei auf Beenden klicken.

    • Falls das Objekt, das Sie erstellt haben, in einem anderen Fenster geöffnet wurde, klicken Sie im Menü Datei der OLE-Server-Anwendung auf Beenden. Werden Sie aufgefordert, das Dokument zu aktualisieren, klicken Sie auf OK.

Wenn Sie das Objekt bearbeiten möchten, doppelklicken Sie darauf.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Häufig werden Sie wahrscheinlich ein ungebundenes Objekt in der Formularentwurfsansicht bzw. der Berichtsentwurfsansicht bearbeiten. Wenn Sie das Objekt in der Formularansicht bearbeiten möchten, legen Sie für das Objektfeld für die Eigenschaft Aktiviert (Enabled) die Einstellung Ja und für die Eigenschaft Gesperrt (Locked) die Einstellung Nein fest.


 Erstellen eines Feldes, das in einer Abfrage benutzerdefinierte Berechnungen durchführt oder Feldwerte bearbeitet

Erstellen eines Feldes, das in einer Abfrage benutzerdefinierte Berechnungen durchführt oder Feldwerte bearbeitet

Sie können ein neues Feld erstellen, das die Ergebnisse einer Berechnung, die Sie über einen Ausdruck definiert haben, anzeigt.

  1. Öffnen Sie die Abfrage in der Entwurfsansicht.

  2. Führen Sie einen der folgende Schritt durch:
    • Geben Sie einen Ausdruck in eine leere Zelle der Zeile Feld ein. Wenn im Ausdruck ein Feldname enthalten ist, müssen Sie diesen in eckige Klammern setzen.

    Eckige Klammern um Feldnamen in Ausdrücken

    • Wenn Sie beim Erstellen des Ausdrucks Hilfe benötigen, verwenden Sie den Ausdrucks-Generator. Um ihn anzuzeigen, klicken Sie mit der rechten Maustaste auf die Zeile Feld, in die Sie das berechnete Feld einfügen, und klicken Sie dann auf Erstellen. Um Informationen zur Arbeitsweise des Ausdrucks-Generators zu erhalten, klicken Sie auf [image] .

      Nachdem Sie die EINGABETASTE gedrückt haben oder zu einer anderen Zelle gegangen sind, gibt Microsoft Access den Standardfeldnamen AusdrN ein, wobei N eine ganze Zahl darstellt, die für jedes neue Ausdrucksfeld der Abfrage um 1 erhöht wird. Der Name, dem ein Doppelpunkt folgt, wird vor dem Ausdruck angezeigt. Im Datenblatt stellt dieser Name die Spaltenüberschrift dar.

    Ersetzen von Ausdr1, um den Standardfeldnamen des Ausdrucks zu ändern

    Sie können AusdrN durch einen aussagekräftigeren Namen, wie z. B. NeuerPreis, ersetzen.

  3. Wenn der Ausdruck eine oder mehrere Aggregatfunktionen (Summe, Mittelwert, Anzahl, Min, Max, StAbw oder Varianz) enthält und sich im Entwurfsbereich ein anderes Feld oder mehrere andere Felder befinden, die Sie zum Gruppieren verwenden möchten, klicken Sie in der Symbolleiste auf Funktionen [image] (es sei denn, die Zeile Funktion wird bereits angezeigt). Lassen Sie in der Zeile Funktion das Gruppierungsfeld Gruppierung stehen, und ändern Sie im berechneten Feld Gruppierung in Ausdruck.

    Um Datensätze zu gruppieren, fügen Sie die Felder Gruppierung und Ausdruck in die Zeile Funktion ein

  4. Sie haben folgende Möglichkeiten, die Abfrage gegebenenfalls zu vervollständigen:
    • Geben Sie Kriterien ein, um die Berechnung zu beeinflussen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Sortieren Sie das Ergebnis. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    • Legen Sie Feldeigenschaften, wie z. B. Format, fest (da das Feld nicht die Eigenschaften der zugrunde liegenden Tabelle übernimmt). Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Anmerkungen

  • In der Abfrage Bestelldetails 2 der Nordwind-Datenbank finden Sie ein Beispiel für ein berechnetes Feld mit dem Namen Endpreis. In der Abfrage Bestellungen (Gesamtpreise) ist ein berechnetes Feld namens Gesamtpreis enthalten, das Berechnungen mit Datensatzgruppen durchführt. Um diese Abfragen anzuschauen, öffnen Sie die Nordwind-Datenbank im Unterordner BEISPIEL des Office-Ordners, und öffnen Sie die Abfrage Bestelldetails 2 bzw. Bestellungen (Gesamtpreise) in der Entwurfsansicht. Um Informationen zum Öffnen der Nordwind-Datenbank anzuzeigen, klicken Sie auf [image] .

  • Um einen Ausdruck komplett einzugeben oder anzuschauen, ohne einen Bildlauf durchführen zu müssen, drücken Sie die Tastenkombination UMSCHALT+F2. Daraufhin wird das Dialogfeld Zoom angezeigt.

  • Zum Anzeigen von Beispielen für Ausdrücke klicken Sie auf [image] .


 Erstellen eines Feldes, das Daten aus einer anderen Tabelle nachschlägt, in der Entwurfsansicht

Erstellen eines Feldes, das Daten aus einer anderen Tabelle nachschlägt, in der Entwurfsansicht

  1. Öffnen Sie in der Entwurfsansicht die Tabelle, in der Sie das Nachschlagefeld hinzufügen möchten.

  2. Führen Sie einen der folgenden Schritte aus:
    • Um ein neues Feld in die Tabelle einzufügen, klicken Sie auf die Zeile, über der Sie es hinzufügen möchten, und dann in der Symbolleiste auf Zeilen einfügen [image] . Um ein neues Feld am Tabellenende hinzuzufügen, klicken Sie auf die erste leere Zeile. Geben Sie in der Spalte Feldname den Namen des Feldes entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein.

    • Wenn das Feld, das Sie als Fremdschlüssel für das Nachschlagefeld verwenden möchten, bereits vorhanden ist, klicken Sie auf die Zeile dieses Feldes. Wenn Sie z.B. eine Tabelle Artikel haben, für die bereits ein Feld Lieferanten-Nr definiert ist, und Sie dieses in ein Nachschlagefeld zum Anzeigen von Lieferantennamen aus der Tabelle Lieferanten verwenden möchten, klicken Sie auf die Zeile des Feldes Lieferanten-Nr.
  3. Klicken Sie in der Spalte Felddatentyp auf den Pfeil, und wählen Sie Nachschlage-Assistent aus.

  4. Klicken Sie auf die Option zum Nachschlagen der Werte in einer Tabelle oder Abfrage.

  5. Klicken Sie auf Weiter, und folgen Sie den Anweisungen in den übrigen Dialogfeldern Nachschlage-Assistent.

    Wenn Sie auf die Schaltfläche Fertig stellen klicken, erstellt Microsoft Access das Nachschlagefeld und stellt bestimmte Eigenschaften auf der Basis der von Ihnen im Assistenten getroffenen Auswahlen ein. Wenn Sie ein Nachschlagefeld erstellt haben und es einem Formular hinzufügen, kopiert Microsoft Access die Felddefinition in das Formular. Das Kombinations- oder Listenfeld wird automatisch erstellt. Wenn Sie jedoch die Definition eines Nachschlage- oder Wertlistenfeldes in der Tabelle ändern, nachdem Sie es einem Formular hinzugefügt haben, werden diese Änderungen im Formular nicht widergespiegelt. Löschen Sie in einem solchen Fall das Feld aus dem Formular, und fügen Sie es erneut hinzu. Zum Anzeigen von Informationen zu den Eigenschaften, die der Nachschlage-Assistent einstellt, klicken Sie auf [image] .

Anmerkung Sie können ein Nachschlagefeld auch einer Tabelle hinzufügen, die Werte aus derselben Tabelle anzeigt, in der das Nachschlagefeld enthalten ist. Das Feld Vorgesetzte(r) in der Tabelle Personal der Beispieldatenbank Nordwind ist z.B. ein Nachschlagefeld, das Daten aus den Feldern Vorname und Nachname durch Nachschlagen der entsprechenden Personalnummer in derselben Tabelle anzeigt.


 Erstellen eines Feldes, das Daten aus einer anderen Tabelle nachschlägt, in der Datenblattansicht

Erstellen eines Feldes, das Daten aus einer anderen Tabelle nachschlägt, in der Datenblattansicht

  1. Öffnen Sie in der Datenblattansicht die Tabelle, in der Sie das Nachschalgefeld hinzufügen möchten.

  2. Um das Nachschlagefeld in die Tabelle einzufügen, klicken Sie auf die Spalte, vor der Sie es hinzufügen möchten, und dann im Menü Einfügen auf Nachschlagespalte.

  3. Wählen Sie im ersten Dialogfeld des Nachschlage-Assistenten die Option zum Nachschlagen der Werte in einer Tabelle oder Abfrage.

  4. Klicken Sie auf Weiter, und folgen Sie den Anweisungen in den übrigen Dialogfeldern Nachschlage-Assistent.

    Wenn die Arbeit mit dem Nachschlage-Assistenten beendet ist, wird das Nachschlagefeld dem Datenblatt hinzugefügt. Das neue Nachschlagefeld erhält standardmäßig einen Namen aus dem Datenblatt, Feld#, wobei # für eine Zahl steht. Sie können diesen Namen bei Bedarf ändern. Um Informationen zum Ändern eines Feldnamens in der Datenblattansicht anzuzeigen, klicken Sie auf [image] .

Anmerkungen

  • Wenn Sie den Nachschlage-Assistenten zum Erstellen einer Nachschlageliste einsetzen, stellt Microsoft Access bestimmte Eigenschaften auf der Basis der von Ihnen im Assistenten getroffenen Auswahlen ein. Wenn Sie ein Nachschlagefeld erstellt haben und es einem Formular hinzufügen, kopiert Microsoft Access die Felddefinition in das Formular. Das Kombinations- oder Listenfeld wird automatisch erstellt. Wenn Sie jedoch die Definition des Feldes in der Tabelle ändern, nachdem Sie es einem Formular hinzugefügt haben, werden diese Änderungen im Formular nicht widergespiegelt. Löschen Sie in einem solchen Fall das Feld aus dem Formular, und fügen Sie es erneut hinzu. Zum Anzeigen von Informationen zu den Eigenschaften, die der Nachschlage-Assistent einstellt, klicken Sie auf [image] .

  • Sie können ein Nachschlagefeld auch einer Tabelle hinzufügen, die Werte aus derselben Tabelle anzeigt, in der das Nachschlagefeld enthalten ist. Das Feld Vorgesetzte(r) in der Tabelle Personal der Beispieldatenbank Nordwind ist z.B. ein Nachschlagefeld, das Daten aus den Feldern Vorname und Nachname durch Nachschlagen der entsprechenden Personalnummer in derselben Tabelle anzeigt.


 Erstellen eines Feldes zum Speichern des Pfades von Bildern

Erstellen eines Feldes zum Speichern des Pfades von Bildern

  1. Erstellen Sie ein Feld in einer Tabelle, und stellen Sie den Datentyp des Feldes in einer Microsoft Access-Datenbank auf Text ein, in einem Microsoft Access-Projekt auf varchar. So fügen Sie ein Feld in der Entwurfsansicht zu einer Microsoft Access-Datenbank hinzu. So fügen Sie eine Spalte in eine Tabelle in einem Microsoft Access-Projekt ein.

  2. Geben Sie in der Datenblattansicht in dem von Ihnen erstellten Feld den Pfad zu dem Bild (Dateiformate .bmp, .jpeg, .gif, .dib, .wmf oder .emf) ein.


 Erstellen eines Filters, der Datensätze auf ungruppierten Datenzugriffsseiten sucht

Erstellen eines Filters, der Datensätze auf ungruppierten Datenzugriffsseiten sucht

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Wenn die Felder, die Sie anzeigen wollen, sich noch nicht in dem Bereich befinden, fügen Sie die Felder als gebundene Textfelder hinzu. Achten Sie darauf, auch das Feld hinzuzufügen, das Sie zum Filtern der Datensätze verwenden wollen.

    Anmerkung Falls die Seite nicht in Bereiche unterteilt ist, fügen Sie einen ungebundenen Bereich hinzu.

  3. Klicken Sie in der Toolbox auf das Steuerelement Dropdownliste.

  4. Ziehen Sie unter Verwendung der rechten Maustaste das Feld, dessen Werte Sie zum Filtern der Datensätze verwenden wollen, aus der Feldliste.

  5. Klicken Sie im Kontextmenü auf Gruppenfilter-Steuerelement.

  6. Passen Sie das Datensatznavigationssteuerelement an. Beispielsweise sind auf einer Datenzugriffsseite, die jeweils nur einen einzelnen Datensatz sucht, nicht alle Schaltflächen verfügbar. Sie können nur die Schaltflächen Neu, Löschen, Speichern, Rückgängig und Hilfe auf der Datensatznavigationsleiste anzeigen.

    Testen Sie den Filter in der Datenzugriffsseitenansicht oder in Microsoft Internet Explorer. Sobald Sie einen Wert in der Dropdownliste ausgewählt haben, werden auf der Seite alle Datensätze angezeigt, die diesen Wert enthalten, und die Datensatznavigationsleiste wird aktiviert.


 Erstellen eines Formulars unter Verwendung von AutoFormular

Erstellen eines Formulars unter Verwendung von AutoFormular

AutoFormular erzeugt ein Formular, das sämtliche Felder und Datensätze der zugrunde liegenden Tabelle bzw. Abfrage anzeigt. Falls die von Ihnen ausgewählte Datenherkunft verknüpfte Tabellen oder Abfragen aufweist, enthält das Formular auch alle Felder und Datensätze von diesen Datenherkünften.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie in der Symbolleiste des Datenbankfensters auf die Schaltfläche Neu.

  3. Klicken Sie im Dialogfeld Neues Formular auf einen der folgenden Assistenten:
    • AutoFormular: Einspaltig Jedes Feld wird in einer separaten Zeile mit einem Bezeichnungsfeld links daneben angezeigt.

    • AutoFormular: Tabellarisch Die Felder jedes Datensatzes erscheinen in einer Zeile, die Bezeichnungsfelder werden am oberen Rand des Formulars angezeigt.

    • AutoFormular: Datenblatt Die Felder jedes Datensatzes erscheinen im Zeilen/Spaltenformat mit einem Datensatz pro Zeile und einem Feld pro Spalte. Die Feldnamen werden oberhalb jeder Spalte angezeigt.
  4. Klicken Sie auf die Tabelle oder Abfrage mit den Daten, auf denen Sie das Formular basieren möchten.

  5. Klicken Sie auf OK.

Microsoft Access wendet das von Ihnen zuletzt verwendete AutoFormat auf das Formular an. Falls Sie bis dahin noch kein Formular mit einem Assistenten erstellt oder den Befehl AutoFormat im Menü Format noch nicht eingesetzt haben, wird das Standard-AutoFormat verwendet.

Tipp Sie können auch ein einspaltiges AutoFormular auf Basis der geöffneten Datenherkunft oder der im Datenbankfenster ausgewählten Datenherkunft erstellen. Klicken Sie auf AutoFormular im Menü Einfügen, oder klicken Sie auf den Pfeil neben der Schaltfläche Neues Objekt in der Symbolleiste und dann auf AutoFormular. Falls die von Ihnen ausgewählte Datenherkunft verknüpfte Tabellen aufweist, fügt AutoFormular ein Unterformular-Steuerelement hinzu, das die verknüpften Tabellen in Form von Datenblättern und Unterdatenblättern anzeigt.


 Erstellen eines Formulars mit einem Unterformular, das ein weiteres Unterformular enthält

Erstellen eines Formulars mit einem Unterformular, das ein weiteres Unterformular enthält

Stellen Sie vor dem Ausführen der nachfolgenden Schritte sicher, dass Sie Ihre Tabellenbeziehungen korrekt definiert haben.

Mit Hilfe der nachstehend beschriebenen Schritte können Sie ein Formular und zwei Unterformularebenen mit einer 1:n-Beziehung erstellen. Das Hauptformular hat eine 1:n-Beziehung zum ersten Unterformular, und das erste Unterformular hat eine 1:n-Beziehung zum zweiten Unterformular.

  1. Erstellen Sie ein Formular mit einem Unterformular.

    Wie wird's gemacht?

    Anmerkung Aktivieren Sie die Option Tabellarisch (das Äquivalent zur Formularansicht), wenn der Assistent fragt, welches Layout Sie für das Unterformular wünschen. Wenn Sie die Option Datenblatt wählen, können Sie in das Unterformular kein weiteres Unterformular einfügen.

  2. Stellen Sie sicher, dass in der Entwurfsansicht für das Hauptformular das Unterformular-Steuerelement markiert ist. Wenn es markiert ist, können Sie erneut auf das Steuerelement klicken, um das Formular, einen Bereich oder ein Steuerelement auszuwählen. Dabei verfahren Sie genauso, als würden Sie das Unterformular aus der Entwurfsansicht des Datenbankfensters öffnen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Verwenden Sie den Unterformular-Assistenten zum Erstellen des zweiten Unterformulars.

      Wie wird's gemacht?

    • Ziehen Sie ein Formular, eine Tabelle oder eine Abfrage aus dem Datenbankfenster in das Unterformular.

      Microsoft Access erstellt jetzt innerhalb des ersten Unterformulars ein weiteres Unterformular sowie ein Formular für das Unterformular.

  4. Wechseln Sie zur Formularansicht, um das Formular und die Unterformulare anzuzeigen.

Anmerkungen

  • Zum Anzeigen von Informationen zum Ändern des Layouts eines Unterformulars klicken Sie auf [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung in Unterformularen klicken Sie auf [image] .


 Erstellen eines leeren Formulars und Auswählen einer Datenherkunft

Erstellen eines leeren Formulars und Auswählen einer Datenherkunft

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neues Formular auf Entwurfsansicht.

  4. Klicken Sie auf den Namen der Tabelle oder einer anderen Datenherkunft, in der die Daten für das Formular enthalten sind. Sollen im Formular keine Daten enthalten sein (z.B. wenn Sie ein Formular als Übersicht zum Öffnen anderer Formulare oder Berichte oder aber ein benutzerdefiniertes Dialogfeld erstellen möchten), wählen Sie aus dieser Liste nichts aus.

    Anmerkung Soll ein Formular erstellt werden, das Daten aus mehreren Tabellen verwendet, basieren Sie es auf einer Abfrage.

  5. Klicken Sie auf OK.

Microsoft Access zeigt das Formular in der Entwurfsansicht an. Weitere Informationen zu den möglichen Optionen in der Entwurfsansicht erhalten Sie durch Klicken auf [image] .


 Gleichzeitiges Erstellen eines Formulars und eines Unterformulars

Gleichzeitiges Erstellen eines Formulars und eines Unterformulars

Stellen Sie vor dem Ausführen der nachfolgenden Schritte sicher, dass Sie Ihre Tabellenbeziehungen korrekt definiert haben.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Doppelklicken Sie im Dialogfeld Neues Formular im Listenfeld auf Formular-Assistent.

  4. Wählen Sie im ersten Dialogfeld des Assistenten aus dem Listenfeld eine Tabelle oder eine Abfrage. Wählen Sie z.B. die Tabelle Kategorien (die "1"-Seite der 1:n-Beziehung), wenn Sie ein Formular Kategorien zum Anzeigen der Artikel aller Kategorien in einem Unterformular erstellen möchten.

  5. Doppelklicken Sie auf die Felder, die Sie aus dieser Tabelle oder Abfrage verwenden möchten.

  6. Wählen Sie in demselben Dialogfeld des Assistenten aus dem Listenfeld eine weitere Tabelle oder Abfrage. Wählen Sie, um beim oben genannten Beispiel zu bleiben, die Tabelle Artikel (die "n"-Seite der 1:n-Beziehung für das Formular Kategorien aus dem genannten Beispiel).

    Anmerkung Es spielt keine Rolle, welche Tabelle oder Abfrage Sie zuerst auswählen.

  7. Doppelklicken Sie auf die Felder, die Sie aus dieser Tabelle oder Abfrage verwenden möchten.

  8. Wenn Sie vor dem Starten des Assistenten die Beziehungen festgelegt haben und jetzt auf Weiter klicken, fragt der Assistent, welche Tabelle oder Abfrage Sie anzeigen möchten. Klicken Sie für das oben genannte Beispiel zum Erstellen des Formulars Kategorien auf Nach Kategorien.

  9. Aktivieren Sie in demselben Dialogfeld des Assistenten die Option Formular mit Unterformular(en).

  10. Folgen Sie den Anweisungen in den verbleibenden Dialogfeldern des Assistenten. Wenn Sie auf Fertig stellen klicken, erstellt Microsoft Access zwei Formulare, eins für das Hauptformular mit dem Unterformular-Steuerelement und eins für das Unterformular.

Anmerkungen

  • Um Informationen zum Ändern des Layouts eines Unterformulars anzuzeigen, das mit einem Assistenten erstellt wurde, klicken Sie auf [image] .

  • Um Informationen zur Problembehandlung in Unterformularen anzuzeigen, klicken Sie auf [image] .


 Erstellen eines Formulars mit zwei Unterformularen

Erstellen eines Formulars mit zwei Unterformularen

Stellen Sie vor dem Ausführen der nachfolgenden Schritte sicher, dass Sie Ihre Tabellenbeziehungen korrekt definiert haben.

Mit dem nachstehend beschriebenen Verfahren können Sie ein Formular mit zwei Unterformularen erstellen, die eine 1:m:n-Beziehung haben. Das Hauptformular hat eine 1:m-Beziehung zum ersten Unterformular, und das erste Unterformular hat eine 1:n-Beziehung zum zweiten Unterformular.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Doppelklicken Sie im Dialogfeld Neues Formular im Listenfeld auf Formular-Assistent.

  4. Wählen Sie im ersten Dialogfeld des Assistenten die Tabelle oder Abfrage für das Hauptformular. Angenommen, Sie möchten ein Formular Kunden mit zwei Unterformularen erstellen: einem Unterformular Bestellungen und einem Unterformular Bestelldetails. Wählen Sie in diesem Fall die Tabelle Kunden (die "1"-Seite der 1:m-Beziehung).

  5. Doppelklicken Sie auf die Felder, die Sie aus dieser Tabelle oder Abfrage verwenden möchten.

  6. Wählen Sie in demselben Dialogfeld die Tabelle oder Abfrage für das erste Unterformular. Wählen Sie, um beim oben genannten Beispiel zu bleiben, die Tabelle Bestellungen (die "n"-Seite der ersten 1:n-Beziehung), und doppelklicken Sie dann auf die Felder, die Sie aus dieser Tabelle oder Abfrage verwenden möchten.

    Anmerkung Es spielt keine Rolle, welche Tabelle oder Abfrage Sie zuerst wählen.

  7. Wählen Sie in demselben Dialogfeld die Tabelle oder Abfrage für das zweite Unterformular. Wählen Sie, um beim oben genannten Beispiel zu bleiben, die Tabelle Bestelldetails (die "n"-Seite der zweiten 1:n-Beziehung), und doppelklicken Sie dann auf die Felder, die Sie aus dieser Tabelle oder Abfrage verwenden möchten.

  8. Wenn Sie vor dem Starten des Assistenten die Beziehungen festgelegt haben und jetzt auf Weiter klicken, fragt der Assistent, welche Tabelle oder Abfrage Sie anzeigen möchten. Klicken Sie für das oben genannte Beispiel zum Erstellen des Formulars Kunden auf Nach Kunden.

  9. Aktivieren Sie in demselben Dialogfeld des Assistenten die Option Formular mit Unterformular.

  10. Folgen Sie den Anweisungen in den verbleibenden Dialogfeldern des Assistenten. Wenn Sie auf Fertig stellen klicken, erstellt Microsoft Access ein Hauptformular mit zwei Unterformular-Steuerelementen sowie zwei weitere Formulare, eins für jedes Unterformular.

Anmerkungen

  • Wenn Sie zum Erstellen eines Formulars mit zwei Unterformularen einen Assistenten verwenden, synchronisiert Microsoft Access die Unterformulare automatisch durch Zuordnen einer Ereignisprozedur zur Eigenschaft BeimAnzeigen des ersten Unterformulars. Sie können diese Ereignisprozedur kopieren und ändern, wenn Sie weitere Unterformulare mit diesem Formular synchronisieren möchten. Zum Anzeigen dieser Ereignisprozedur öffnen Sie das erste Unterformular in der Entwurfsansicht, doppelklicken auf den Formularmarkierer und klicken dann neben dem Einstellungsfeld für die Eigenschaft BeimAnzeigen auf die Generator-Schaltfläche [image] .

  • Das Formular Kundenbestellungen in der Beispieldatenbank Nordwind ist ein Formular mit zwei Unterformularen. Um dieses Formular anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIEL des Office-Ordners und dann das Formular Kundenbestellungen in der Entwurfsansicht. Um weitere Informationen zum Öffnen der Nordwind-Datenbank anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zum Ändern des Layouts eines Unterformulars anzuzeigen, das mit einem Assistenten erstellt wurde, klicken Sie auf [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung in Unterformularen klicken Sie auf [image] .


 Erstellen eines Formulars mit einem Assistenten

Erstellen eines Formulars mit einem Assistenten

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neues Formular auf den Assistenten, den Sie verwenden möchten. Eine Beschreibung des Assistenten wird links im Dialogfeld angezeigt.

  4. Klicken Sie auf den Namen der Tabelle oder einer anderen Datenherkunft, in der die Daten für das Formular enthalten sind.

    Anmerkung Sie können diesen Schritt übergehen, wenn Sie auf die Option Formular-Assistent klicken. Die Datenherkunft für das Formular können Sie im Assistenten angeben.

  5. Klicken Sie auf OK.

  6. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten, wenn Sie in Schritt 3 auf Formular-Assistent, Diagramm-Assistent oder Pivot-Tabelle geklickt haben. Wenn Sie auf AutoFormular: Einspaltig, AutoFormular: Tabellarisch oder AutoFormular: Datenblatt geklickt haben, erstellt Microsoft Access automatisch Ihr Formular.

    Wenn das Formular nicht das gewünschte Aussehen hat, können Sie es in der Entwurfsansicht ändern.

    Wie wird's gemacht?

Anmerkung Wenn Sie entweder im Formular-Assistenten oder unter Verwendung des Befehls AutoFormat im Menü Format in der Entwurfsansicht auf eine der AutoFormular-Optionen klicken, verwendet Microsoft Access das zuletzt festgelegte AutoFormat.


 Erstellen eines Filters, der Datensätze auf gruppierten Datenzugriffsseiten sucht

Erstellen eines Filters, der Datensätze auf gruppierten Datenzugriffsseiten sucht

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Falls sich die gewünschten Felder noch nicht in dem Bereich befinden, müssen Sie der Seite die Felder entweder als gebundene HTML-Steuerelemente hinzufügen oder als gebundene Textfelder hinzufügen. Achten Sie darauf, auch das Feld hinzuzufügen, das Sie zum Filtern der Datensätze verwenden wollen.

    Anmerkungen

    • Die Seite wird in der Datenzugriffsseitenansicht und in Internet Explorer schneller geladen, wenn Sie gebundene HTML-Steuerelemente verwenden.

    • Falls die Seite nicht in Bereiche unterteilt ist, fügen Sie einen ungebundenen Bereich hinzu.
  3. Überzeugen Sie sich, dass das an das Feld gebundene Steuerelement, nach dem die Datensätze gefiltert werden sollen, ausgewählt ist.

  4. Führen Sie einen der folgenden Schritte durch:
    • Um lediglich auf der Basis des einen Feldes zu gruppieren, klicken Sie in der Symbolleiste auf Höher stufen [image] .

    • Um auf der Basis der ganzen Tabelle oder Abfrage zu gruppieren, die das Feld enthält, klicken Sie in der Symbolleiste auf Nach Tabelle gruppieren [image] .

    Microsoft Access fügt einen Gruppenkopf mit einem Erweiterungs-Steuerelement und einen Datensatznavigationsbereich mit einem Datensatznavigationssteuerelement ein. Wenn Sie nach einem Feld gruppiert haben, verschiebt Access das der Gruppierung zugrunde liegende Steuerelement in den Gruppenkopf. Haben Sie nach einer Tabelle oder Abfrage gruppiert, verschiebt Access alle Steuerelemente, auch an Felder in dieser Tabelle oder Abfrage gebundene oder an Nachschlagefelder gebundene Steuerelemente, in den Gruppenkopf.

  5. Klicken Sie in der Toolbox auf das Steuerelement Dropdownliste.

  6. Ziehen Sie unter Verwendung der rechten Maustaste das Feld, dessen Werte Sie zum Filtern der Datensätze verwenden wollen, aus der Feldliste in den in Schritt 4 erstellten Gruppenkopf.

  7. Klicken Sie im Kontextmenü auf Gruppenfilter-Steuerelement.

Die folgenden Schritte sind optional. Damit werden Features entfernt, die standardmäßig zu einer gruppierten Seite hinzugefügt werden, jedoch bei der Verwendung des Gruppenfilter-Steuerelements überflüssig sind.

  8. Wählen Sie das Erweiterungs-Steuerelement in dem Kopfbereich aus, der das Filter-Steuerelement enthält, und drücken Sie ENTF.

  9. Wählen Sie den Datensatznavigationsbereich für die Gruppierungsebene aus, die das Filter-Steuerelement enthält, und drücken Sie ENTF. Access löscht den Bereich sowie das darin enthaltene Navigationssteuerelement.

  10. Passen Sie das Datensatznavigationssteuerelement für die niedrigere Gruppierungsebene an. Blenden Sie beispielsweise die Schaltflächen zum Hinzufügen und Löschen von Datensätzen aus.

Anmerkungen

  • Falls der Gruppenkopf auch ein Steuerelement zur Berechnung von Summen oder anderen Mengen enthält, zeigt das berechnete Steuerelement jeweils die korrekte Summe bzw. sonstige Menge für die Datensatzgruppe an, die Sie mit Hilfe des Gruppenfilters ausgewählt haben.

  • Gruppenfilter können auf mehreren Gruppierungsebenen gleichzeitig eingerichtet werden. Beispielsweise können Sie einen Gruppenfilter für das Feld Land erstellen, auf der nächsttieferen Gruppierungsebene eine Gruppenfilter für das Feld Ort usw.


 Erstellen eines Eingabeformats für ein Steuerelement

Erstellen eines Eingabeformats für ein Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Markieren Sie ein Textfeld oder ein Kombinationsfeld, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster dieses Steuerelements zu öffnen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Geben Sie die Definition für das Eingabeformat ein. Zum Anzeigen von Informationen zum Definieren eines Eingabeformats klicken Sie auf [image] .

    • Klicken Sie in einer Microsoft Access-Datenbank (.mdb) auf die Aufbauen-Schaltfläche [image] im Einstellungsfeld der Eigenschaft Eingabeformat, um den Eingabeformat-Assistenten zu starten, und folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.


 Gleichzeitiges Erstellen einer neuen Datenzugriffsseite und eines Links zu dieser Seite

Gleichzeitiges Erstellen einer neuen Datenzugriffsseite und eines Links zu dieser Seite

  1. Öffnen Sie ein Formular in der Formularentwurfsansicht, einen Bericht in der Berichtsentwurfsansicht oder eine Datenzugriffsseite in der Datenzugriffsseiten-Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Hyperlink.

  3. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Neue Seite erstellen.

  4. Geben Sie im Feld Text anzeigen als den Text ein, der in dem Feld bzw. Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die Hyperlinkadresse und/oder Subadresse als Anzeigetext.

  5. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Benutzer den Mauszeiger auf den Hyperlink bewegt. Wenn Sie das Feld Quickinfotext leer lassen, zeigt Microsoft Access die Hyperlinkadresse und/oder Subadresse als QuickInfo an.

  6. Geben Sie im Feld Name des neuen Dokuments einen Namen für die neue Datenzugriffsseite ein.

    Tipp Sie können auch andere Dokumenttypen erstellen - beispielsweise Microsoft Word-Dateien oder Microsoft Excel-Kalkulationstabellen - indem Sie die drei Zeichen lange Dateinamenserweiterung für den gewünschten Dateityp mit eingeben. Sie können so jedoch weder eine Microsoft Access-Datenbank (.mdb) noch ein Microsoft Access-Projekt (.adp) erzeugen.

  7. Microsoft Access erstellt die neue Seite in dem aktuellen Ordner. Um einen anderen Speicherort anzugeben, klicken Sie auf Ändern.

  8. Wählen Sie eine Option unter Zeitpunkt der Bearbeitung aus. Sie können die neue Seite sofort oder erst zu einem späteren Zeitpunkt bearbeiten.

  9. Klicken Sie auf OK.

    Auf Datenzugriffsseiten fügt Microsoft Access den Hyperlink in einem Hyperlink-Steuerelement ein. In Formularen oder Berichten wird der Hyperlink in einem Bezeichnungsfeld eingefügt. Um den Hyperlink auf einer Datenzugriffsseite zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf den Hyperlink. Um den Hyperlink in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.


 Erstellen eines Hyperlinks zu einem Objekt in der aktuellen Datenbank

Erstellen eines Hyperlinks zu einem Objekt in der aktuellen Datenbank

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Hyperlink einfügen [image] .

  3. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Seite in dieser Datenbank.

  4. Geben Sie im Feld Text anzeigen als den Text ein, der in dem Feld bzw. Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access den Objekttyp und den Objektnamen als Anzeigetext.

  5. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Quickinfotext leer lassen, zeigt Microsoft Access den Objekttyp und den Objektnamen als QuickInfo an.

  6. Wählen Sie aus der Liste das Datenbankobjekt, zu dem Sie den Hyperlink erstellen wollen.

  7. Klicken Sie auf OK.

    Microsoft Access fügt den Hyperlink in einem Bezeichnungsfeld hinzu. Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen.

Anmerkung Um eine Verknüpfung mit einem Objekt in einer anderen Datenbank zu bilden, erstellen Sie einen Link zu der Datenbankdatei, und klicken Sie dann auf Textmarke, um das Objekt auszuwählen.


 Erstellen eines Hyperlinks, der beim Anklicken eine E-Mail-Nachricht erzeugt

Erstellen eines Hyperlinks, der beim Anklicken eine E-Mail-Nachricht erzeugt

  1. Öffnen Sie ein Formular in der Formularentwurfsansicht, einen Bericht in der Berichtsentwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Hyperlink.

  3. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf E-Mail-Adresse.

  4. Geben Sie im Feld Text anzeigen als den Text ein, der in dem Feld bzw. Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die E-Mail-Adresse als Anzeigetext.

  5. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Mauszeiger auf den Hyperlink bewegt wird. Wenn Sie das Feld Quickinfotext leer lassen, zeigt Microsoft Access die E-Mail-Adresse als QuickInfo an.

  6. Geben Sie im Feld E-Mail-Adresse eine E-Mail-Adresse ein, oder wählen Sie eine Adresse aus der Liste Zuletzt verwendete E-Mail-Adressen aus.

  7. Geben Sie im Feld Betreff die Information ein, die in der Betreffzeile der E-Mail-Nachricht erscheinen soll.

    Anmerkung Manche Webbrowser und E-Mail-Programme erkennen die Betreffzeile möglicherweise nicht.

  8. Klicken Sie auf OK.

    Auf Datenzugriffsseiten fügt Microsoft Access den Hyperlink in einem Hyperlink-Steuerelement ein. In Formularen oder Berichten wird der Hyperlink in einem Bezeichnungsfeld eingefügt. Um den Hyperlink auf einer Datenzugriffsseite zu testen, wechseln Sie zur Datenzugriffsseitenansicht, und klicken Sie auf den Hyperlink. Um den Hyperlink in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie dann auf Öffnen. Microsoft Access öffnet Ihr E-Mail-Programm und erstellt eine neue Nachricht, in der die Adresse und der Betreff bereits eingetragen sind.


 Erstellen eines Hyperlinks zu einer Webseite unter Verwendung eines Bildes auf einer Datenzugriffsseite

Erstellen eines Hyperlinks zu einer Webseite unter Verwendung eines Bildes auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Hotspotbild Hotspotbild-Steuerelement .

  3. Klicken Sie auf die Stelle in der Datenzugriffsseite, an der das Bild eingefügt werden soll.

  4. Wählen Sie im Dialogfeld Grafik einfügen das Bild aus, das Sie in die Seite einfügen möchten. Sie können die Dateiformate .bmp, .wmf, .emf, .gif und .jpeg verwenden.

  5. Klicken Sie auf OK.

  6. Geben Sie im Dialogfeld Hyperlink einfügen die Internet-Adresse ein, mit der das Bild verknüpft werden soll, oder wählen Sie sie aus der Liste aus.

  7. Klicken Sie auf OK.


 Erstellen eines Makros

Erstellen eines Makros

  1. Klicken Sie im Datenbankfenster unter Objekte auf Makros [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie in der Spalte Aktion auf das erste Feld und anschließend auf den Pfeil, um die Aktionsliste anzuzeigen.

  4. Klicken Sie auf die gewünschte Aktion.

  5. Geben Sie einen Kommentar für die Aktion ein. Kommentare sind optional, erleichtern jedoch das Verstehen und Warten eines Makros.

  6. Geben Sie bei Bedarf im unteren Teil des Fensters Argumente für die Aktion an. Um Tipps zum Setzen von Aktionsargumenten anzuzeigen, klicken Sie auf [image] .

  7. Wenn Sie weitere Aktionen zum Makro hinzufügen möchten, gehen Sie in eine andere Aktionszeile und wiederholen die Schritte 3 bis 6. Microsoft Access führt die Aktionen in der Reihenfolge aus, in der Sie sie eingetragen haben.

Tipp Um schnell ein Makro zu erstellen, das eine Aktion für ein bestimmtes Datenbankobjekt ausführt, ziehen Sie das Objekt aus dem Datenbankfenster in eine Aktionszeile des Makrofensters. Sie können z.B. ein Formular in eine Aktionszeile ziehen, wenn Sie ein Makro erstellen möchten, das ein Formular öffnet. Dazu klicken Sie im Menü Fenster auf Vertikal, um das Makrofenster und das Datenbankfenster nebeneinander auf dem Bildschirm zu positionieren. Dann klicken Sie im Datenbankfenster unter Objekte auf den gewünschten Objekttyp, klicken auf das Objekt und ziehen es anschließend in eine Aktionszeile. Wenn Sie ein Makro oder eine gespeicherte Prozedur in eine Aktionszeile ziehen, wird eine Aktion zum Ausführen des Makros bzw. der Prozedur hinzugefügt. Wenn Sie hingegen Datenbankobjekte in eine Aktionszeile ziehen, wird eine Aktion zum Öffnen des jeweiligen Objekts hinzugefügt.


 Erstellen eines nicht gebundenen Popupformulars

Erstellen eines nicht gebundenen Popupformulars

  1. Erstellen Sie das Formular. Es kann eine beliebige Zusammenstellung von Steuerelementen enthalten.

  2. Doppelklicken Sie in der Entwurfsansicht für Formulare auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft PopUp auf Ja.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft Rahmenart auf Dünn, wenn Sie möchten, dass die Größe des Formulars nicht geändert werden kann; gehen Sie ansonsten zum nächsten Schritt weiter. Wenn Sie die Einstellung Dünn wählen, können Sie das Popupformular zwar verschieben, aber nicht seine Größe ändern.

  5. Erstellen Sie ein Makro oder eine Ereignisprozedur, das bzw. die das Formular öffnet.

    Anmerkung Zum Anzeigen eines Beispiels für eine Ereignisprozedur, die ein nicht gebundenes Popupformular anzeigt, klicken Sie auf die Aufbauen-Schaltfläche [image] neben dem Einstellungsfeld der Eigenschaft BeimKlicken der Schaltfläche Produkte im Formular Lieferanten der Beispielanwendung Nordwind.

  6. Ordnen Sie das Makro oder die Ereignisprozedur einem Formular oder Bericht zu, indem Sie den Makro- bzw. Ereignisprozedurnamen als Einstellung der entsprechenden Ereigniseigenschaft angeben. Geben Sie z.B. den Namen des Makros bzw. der Ereignisprozedur in das Einstellungsfeld der Eigenschaft BeimKlicken einer Befehlsschaltfläche ein.

Anmerkungen

  • Um ein Popupformular auf dem Bildschirm zu positionieren, öffnen Sie es in der Entwurfsansicht, zeigen Sie das Microsoft Access-Fenster als Vollbild an, positionieren Sie das Formular an der gewünschten Stelle, und speichern Sie es dann. Das Formular wird beim Öffnen an dieser Stelle angezeigt (unter der Bedingung, dass die Eigenschaft Automatisch zentrieren auf Nein eingestellt ist und Sie die Position nicht bereits in der Ereignisprozedur festgelegt haben, die das Popupformular öffnet).

  • Um Informationen zu anderen Eigenschaften anzuzeigen, die Sie für ein Popupformular einstellen möchten, klicken Sie auf [image] .


 Erstellen eines zusammengesetzten Indexes

Erstellen eines zusammengesetzten Indexes

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Klicken Sie in der Symbolleiste auf Indizes [image] .

  3. Geben Sie in der ersten leeren Zeile der Spalte Indexname einen Namen für den Index ein. Sie können den Index nach einem der Indexfelder benennen oder einen anderen geeigneten Namen eingeben.

  4. Klicken Sie auf den Pfeil in der Spalte Feldname, und markieren Sie das erste Feld für den Index.

  5. Markieren Sie in der nächsten Zeile der Spalte Feldname das zweite Feld für den Index. (Lassen Sie in dieser Zeile das Feld Indexname leer.) Wiederholen Sie diesen Schritt, bis Sie alle Felder markiert haben, die Sie indizieren möchten. Sie können bis zu 10 Felder verwenden.

Anmerkung Die Sortierreihenfolge ist standardmäßig Aufsteigend. Wählen Sie im Fenster Indizes unter Sortierreihenfolge die Option Absteigend, wenn Sie die Daten im entsprechenden Feld in absteigender Reihenfolge sortieren möchten.


Erstellen einer neuen Übersicht, die aus der Eröffnungsübersicht geöffnet werden kann

  1. Öffnen Sie die Datenbank.

  2. Führen Sie eine der folgenden Aktionen aus, um das Dialogfeld Übersichts-Manager zu öffnen:
    • Wenn Sie die Übersicht unter Verwendung des Datenbank-Assistenten erstellt haben, klicken Sie in der Eröffnungsübersicht auf Übersichtselemente ändern.

    • Wenn Sie die Übersicht unter Verwendung des Übersichts-Managers erstellt haben, klicken Sie im Menü Extras auf Add-Ins und dann auf Übersichts-Manager.
  3. Klicken Sie auf Neu.

  4. Geben Sie einen Namen für die neue Übersicht an, und klicken Sie dann auf OK.

    Microsoft Access fügt die Übersicht zum Feld Übersichtsseiten hinzu.

  5. Klicken Sie auf die neue Übersicht und dann auf Bearbeiten.

  6. Klicken Sie auf Neu.

  7. Geben Sie den Text für das erste Übersichtselement im Feld Text ein, und klicken Sie dann im Feld Befehl auf einen Befehl. Geben Sie z.B. Anzeigen des Formulars Musiker ein, und klicken Sie dann im Feld Befehl auf Formular im Bearbeitungsmodus öffnen.

  8. Abhängig davon, auf welchen Befehl Sie klicken, zeigt Microsoft Access unterhalb des Feldes Befehl ein weiteres Feld an. Klicken Sie in diesem Feld gegebenenfalls auf ein Element. Wenn Sie z.B. in Schritt 7 auf Formular im Bearbeitungsmodus öffnen geklickt haben, klicken Sie nun im Feld Formular auf den Namen des Formulars, das Sie öffnen möchten, z.B. Musiker, und dann auf OK.

  9. Wiederholen Sie die Schritte 6 bis 8, bis Sie alle Elemente zur Übersicht hinzugefügt haben. Wenn Sie ein Element bearbeiten oder löschen möchten, klicken Sie im Feld Elemente auf dieser Übersicht auf das entsprechende Element und dann auf Bearbeiten oder Löschen. Wenn Sie ein Element verschieben möchten, klicken Sie im Feld auf dieses Element und dann auf Aufwärts oder Abwärts.

  10. Klicken Sie auf Schließen, wenn Sie die Übersicht wie gewünscht erstellt haben.


 Erstellen einer Optionsgruppe ohne Verwendung eines Assistenten

Erstellen einer Optionsgruppe ohne Verwendung eines Assistenten

  1. Öffnen Sie ein Formular in der Entwurfsansicht, öffnen Sie einen Bericht in der Entwurfsansicht oder öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent aktiviert ist. Dadurch wird der Assistent deaktiviert.

  3. Klicken Sie in der Toolbox auf das Steuerelement Optionsgruppenfeld [image] .

  4. Sie haben dann folgende Möglichkeiten:
    • Wenn Sie eine ungebundene Optionsgruppe erstellen möchten, klicken Sie auf die Stelle, an der der Gruppenrahmen eingefügt werden soll.

    • Wenn Sie eine gebundene Optionsgruppe erstellen möchten, klicken Sie in der Symbolleiste auf Feldliste [image] , um die Feldliste anzuzeigen. Ziehen Sie das gewünschte Feld oder die Spalte aus der Feldliste auf das Formular, den Bericht oder die Datenzugriffsseite. Felder und Spalten werden in der Optionsgruppe als Textfelder platziert. Ist auf einem Formular oder Bericht die Schaltfläche bzw. der Befehl Feldliste nicht verfügbar, müssen Sie das Formular oder den Bericht unter Verwendung der Eigenschaft Datenherkunft an eine Datenquelle binden. Wenn auf einer Datenzugriffsseite die Feldliste leer ist, müssen Sie für die Seite eine Verbindung zu einer Datenbank herstellen.

    Anmerkung Sie müssen das Feld oder die Spalte aus der Feldliste ziehen. Wenn Sie in der Feldliste zuerst auf das Feld klicken und danach auf das Formular, den Bericht oder die Datenzugriffsseite klicken, wird das Steuerelement nicht gebunden.

  5. Klicken Sie in der Toolbox des Formulars oder des Berichts auf das Steuerelement Kontrollkästchen Kontrollkästchen-Steuerelement , das Steuerelement Optionsfeld [image] oder das Steuerelement Umschaltflächen [image] . Klicken Sie in der Toolbox der Datenzugriffsseite auf das Steuerelement Optionsfeld [image] . Klicken Sie dann innerhalb des Gruppenrahmens auf die Stelle, an der die obere linke Ecke des Kontrollkästchens, Optionsfeldes oder der Umschaltfläche angezeigt werden soll. Sobald der Benutzer den Mauszeiger in einem Formular oder Bericht auf den Gruppenrahmen stellt, markiert Microsoft Access die Optionsgruppe, um anzuzeigen, dass das einzufügende Steuerelement Teil der Optionsgruppe wird.

    Wenn Access das erste Steuerelement innerhalb einer Optionsgruppe auf einem Formular oder Bericht erstellt, wird für die OptionValue-Eigenschaft des Steuerelements der Wert 1 festgelegt. Auf einer Datenzugriffsseite müssen Sie für die Value-Eigenschaft jeder Schaltfläche eine Zahl oder einen Text festlegen, der eine Bedeutung für das Feld hat, an das der Gruppenrahmen gebunden ist.

  6. Wiederholen Sie Schritt 5 für jedes Steuerelement, das der Optionsgruppe hinzugefügt werden soll. Auf einem Formular oder Bericht stellt Access die Eigenschaft Option Value der zweiten Option auf 2, der dritten Option auf 3 usw. ein.

Anmerkungen

  • Um Informationen zum Ausrichten der Steuerelemente im Gruppenrahmen auf Formularen und Berichten zu erhalten, klicken Sie auf [image] . Um Informationen zum Ausrichten der Steuerelemente im Gruppenrahmen auf Datenzugriffsseiten zu erhalten, klicken Sie auf [image] .

  • Um Informationen zum Ausrichten der Steuerelemente auf Formularen und Berichten zu erhalten, klicken Sie auf [image] .

  • Um die Dateneingabe zu erleichtern, können Sie die am häufigsten ausgewählte Option als Standardoption angeben.

    Wie wird's gemacht?

  • Wenn Sie ein Kontrollkästchen, Optionsfeld oder eine Umschaltfläche außerhalb einer Optionsgruppe erstellen und später der Optionsgruppe hinzufügen möchten, müssen Sie das Steuerelement ausschneiden und in die Optionsgruppe einfügen (wählen Sie vor dem Einfügen den Optionsgruppenrahmen aus). Beim Ausschneiden und Einfügen legt Microsoft Access die Eigenschaft Option Value für das entsprechende Steuerelement auf einem Formular oder Bericht auf -1 fest. Sie müssen diese dann noch auf den gewünschten Wert einstellen. Wenn Sie ein bereits vorhandenes Steuerelement in einen Gruppenrahmen einfügen, wird dieses Steuerelement nicht Teil der Optionsgruppe.


 Erstellen einer Optionsgruppe in einem Formular oder Bericht mit Hilfe eines Assistenten

Erstellen einer Optionsgruppe in einem Formular oder Bericht mit Hilfe eines Assistenten

Wenn Sie in einer Microsoft Access-Datenbank optimale Ergebnisse erzielen möchten, erstellen Sie Optionsgruppen nur für Felder vom Datentyp Zahl (deren Eigenschaft Feldgröße auf Integer oder Long Integer gesetzt ist) oder für Felder vom Datentyp Ja/Nein. Erstellen Sie in einem Microsoft Access-Projekt Optionsgruppen nur für Spalten mit den Datentypen Int, SmallInt, TinyInt und Bit. Verwenden Sie für Felder oder Spalten anderer Datentypen ein Listenfeld, eine Dropdownliste oder ein Kombinationsfeld.

  1. Öffnen Sie ein Formular in der Entwurfsansicht, oder öffnen Sie einen Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement-Assistenten-Tool [image] , falls der Steuerelement-Assistent noch nicht aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Steuerelement Optionsgruppenfeld [image] .

  4. Klicken Sie im Formular oder Bericht auf die Stelle, an der die obere linke Ecke der Optionsgruppe positioniert werden soll.

  5. Folgen Sie den Anleitungen in den Dialogfeldern des Assistenten. Klicken Sie im letzten Dialogfeld auf Beenden, um die Optionsgruppe in der Entwurfsansicht anzuzeigen.


 Erstellen eines Bildes, das als Hyperlink dient

Erstellen eines Bildes, das als Hyperlink dient

Sie können ein Bild auf einem Formular, in einem Bericht oder auf einer Datenzugriffsseite als Hyperlink verwenden. In einem Bericht funktionieren Hyperlinks zwar bei der Anzeige in Microsoft Access nicht, sie können jedoch verwendet werden, wenn Sie den Bericht in Microsoft Word, Microsoft Excel oder HTML anzeigen.

Was möchten Sie tun?

Erstellen eines Bildes als Hyperlink zu einer vorhandenen Datei oder Webseite

Erstellen einer neuen Datenzugriffsseite und eines Bildes, das als Hyperlink zu dieser Seite dient

Erstellen eines Bildes, das als Hyperlink zwischen zwei Datenzugriffsseiten dient

Erstellen eines Bildes, das in der aktuellen Datenbank als Hyperlink zu einer Tabelle, zu einem Formular, Bericht oder zu einer Datenzugriffsseite dient

Erstellen eines Bildes als Hyperlink, der beim Anklicken das E-Mail-Programm öffnet und eine E-Mail-Nachricht zur angegebenen Adresse erstellt


Erstellen von Sichten/Prozeduren/Abfragen - Beispiel

Dieses Beispiel erstellt eine Aktionsabfrage und eine Standard-Auswahlabfrage und führt beide Abfragen aus. Zu diesem Zweck erstellt sie ein ADO-Befehlsobjekt und fügt es an die ADO-Auflistungen Procedures und Views an.

Anmerkungen

Zur Zeit wird das Erstellen von Prozeduren und Sichten in ADPs bei der im Lieferumfang von Microsoft Access 2000 enthaltenen Version des SQL-Providers nicht unterstützt. Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Zur Ausführung dieser Prozedur ist die RunQuery-Funktion erforderlich.

Sub AbfrageXErstellen()
    Dim catNordwind As New ADOX.Catalog
    Dim cdSicht As New ADODB.Command
    Dim cdProz As New ADODB.Command
    Dim tblTemp As New ADOX.Table

    Set catNordwind.ActiveConnection = CurrentProject.Connection

    With catNordwind
        Set cdProz.ActiveConnection = CurrentProject.Connection
        Set cdSicht.ActiveConnection = CurrentProject.Connection

        With tblTemp
            .Name = "tblTemp"
            With .Columns
                .Append "Personal-Nr", adInteger
                .Append "Nachname", adVarWChar
                .Append "Vorname", adVarWChar
            End With
        End With
        .Tables.Append tblTemp

        ' Neue Aktionsabfrage erstellen.
        cdProz.CommandText = "Insert Into tbltemp " _
          & "([Personal-Nr], Nachname, Vorname) Select [Personal-Nr], " _
          & "Nachname, Vorname From Personal Where Position =" _
          & "'Vertriebsmitarbeiter'"

        ' An Datenbank anfügen.
        .Procedures.Append "TmptblAuffüllen", cdProz

        RunQuery "TmptblAuffüllen"

        ' Neue Auswahlabfrage erstellen
        cdSicht.CommandText = "SELECT * FROM tblTemp"
        .Views.Append "NeueAbfrage", cdSicht

        RunQuery "NeueAbfrage"

 ' Neue Objekte löschen, da dies eine Demonstration ist.
        .Views.Delete "NeueAbfrage"
        .Procedures.Delete "TmptblAuffüllen"
        .Tables.Delete tblTemp.Name
    End With
    Set catNordwind = Nothing
End Sub

Function RunQuery(qryName As String)
    Dim qryTemp As Object
    Dim cat As New ADOX.Catalog
    Dim intAnzDatensätze As Integer

    Set cat.ActiveConnection = CurrentProject.Connection

    On Error Resume Next
    Set qryTemp = cat.Procedures(qryName)
    If Err.Number <> 0 Then
        Set qryTemp = cat.Views(qryName)
        Err.Number = 0
    End If
    On Error GoTo 0

    If TypeOf qryTemp Is ADOX.View Then
        ' Wenn Auswahlabfrage Anzahl der Datensätze anzeigt
        Debug.Print "Anzahl der Datensätze in " & qryName
          Debug.Print DLookup("Count(*)", qryName)
    Else
        ' Wenn Aktionsabfrage betroffene Datensätze anzeigt
        qryTemp.Command.Execute intAnzDatensätze
        Debug.Print "Anzahl der betroffenen Datensätze"
          Debug.Pring intAnzDatensätze
    End If

    Set cat = Nothing
    Set qryTemp = Nothing

End Function


 Erstellen eines Berichts unter Verwendung von "AutoBericht"

Erstellen eines Berichts unter Verwendung von "AutoBericht"

AutoBericht erstellt einen Bericht, in dem alle Felder und Datensätze der zugrunde liegenden Tabelle oder Abfrage angezeigt werden.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Berichte [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neuer Bericht auf einen der folgenden Assistenten:
    • AutoBericht: Einspaltig. Jedes Feld wird in einer eigenen Zeile mit einer Beschriftung auf der linken Seite angezeigt.

    • AutoBericht: Tabellarisch. Die Felder eines Datensatzes werden in einer Zeile angezeigt, wobei die Beschriftungen sich am oberen Rand der Seite befinden.
  4. Klicken Sie auf die Tabelle oder Abfrage, die die Daten enthält, auf denen Ihr Bericht basieren soll.

  5. Klicken Sie auf OK.

    Microsoft Access weist dem Bericht das zuletzt verwendete AutoFormat zu. Wenn Sie bisher noch keinen Bericht mit einem Assistenten erstellt oder den Befehl AutoFormat im Menü Format noch nicht verwendet haben, wird das AutoFormat Standard verwendet.

Tipp Sie können auch einen einspaltigen Bericht erstellen, dessen Basis die geöffnete Tabelle oder Abfrage oder aber die im Datenbankfenster ausgewählte Tabelle oder Abfrage ist. Klicken Sie im Menü Einfügen auf AutoBericht oder in der Symbolleiste auf den Pfeil neben der Schaltfläche Neues Objekt und dann auf AutoBericht. Berichte, die mit diesem Verfahren erstellt werden, enthalten weder einen Berichtskopf und -fuß noch einen Seitenkopf und -fuß.


 Erstellen eines leeren Berichts und Auswählen einer Datenherkunft

Erstellen eines leeren Berichts und Auswählen einer Datenherkunft

  1. Klicken Sie im Datenbankfenster unter Objekte auf Berichte [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neuer Bericht auf Entwurfsansicht.

  4. Klicken Sie auf den Namen der Tabelle oder Abfrage, die die Daten enthält, auf denen Ihr Bericht basieren soll. (Wählen Sie keinen Eintrag aus dieser Liste, wenn Sie einen ungebundenen Bericht erstellen möchten.)

    Tipp Zum Erstellen eines Berichts auf der Basis von Daten aus mehreren Tabellen verwenden Sie eine Abfrage.

  5. Klicken Sie auf OK.

    Microsoft Access zeigt den Bericht in der Entwurfsansicht an. Um Informationen zu den Arbeitsmöglichkeiten in der Entwurfsansicht anzuzeigen, klicken Sie auf [image] .


 Erstellen eines Berichts mit einem Assistenten

Erstellen eines Berichts mit einem Assistenten

  1. Klicken Sie im Datenbankfenster unter Objekte auf Berichte [image] .

  2. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Dialogfeld Neuer Bericht auf den Assistenten, den Sie verwenden möchten. Auf der linken Seite des Dialogfelds wird eine Beschreibung des jeweiligen Assistenten angezeigt.

  4. Klicken Sie auf die Tabelle oder Abfrage, die die Daten für den gewünschten Bericht enthält.

    Anmerkung Microsoft Access verwendet diese Tabelle oder Abfrage als Standarddatenherkunft für den Bericht. Sie können jedoch die Datenherkunft im Assistenten ändern und Felder aus anderen Tabellen und Abfragen auswählen.

  5. Klicken Sie auf OK.

  6. Wenn Sie in Schritt 3 auf Berichts-Assistent, Diagramm-Assistent oder Etiketten-Assistent geklickt haben, folgen Sie den in den Dialogfeldern des Assistenten gegebenen Anweisungen. Wenn Sie auf AutoBericht: Einspaltig oder AutoBericht: Tabellarisch klicken, erstellt Microsoft Access Ihren Bericht.

    Sieht das Ergebnis nicht wie gewünscht aus, können Sie in der Entwurfsansicht den Bericht ändern.


 Erstellen eines ungebundenen Lauftext-Steuerelements auf einer Datenzugriffsseite

Erstellen eines ungebundenen Lauftext-Steuerelements auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Lauftext Lauftext-Steuerlement .

  3. Klicken Sie in der Datenzugriffsseite auf die Stelle, an der die linke obere Ecke des Lauftext-Steuerlements platziert weden soll. Microsoft Access erstellt ein Steuerelement in der Standardgröße. Wenn Sie ein Lauftext-Steuerelement in einer bestimmten Größe erstellen möchten, klicken Sie auf die Datenzugriffsseite und ziehen Sie das Element, bis es die gewünschte Größe hat.

  4. Markieren Sie im Lauftext-Steuerelement den Standardtext, und geben Sie dann den Text ein, der angezeigt werden soll.


 Erstellen separater Tabellen für mehrere Datensatzmengen anhand einer SQL Pass-Through-Abfrage

Erstellen separater Tabellen für mehrere Datensatzmengen anhand einer SQL Pass-Through-Abfrage

  1. Erstellen Sie nach dem Anlegen einer SQL Pass-Through-Abfrage eine Tabellenerstellungsabfrage, die auf der SQL Pass-Through-Abfrage basiert.

    Wie wird's gemacht?

  2. Fügen Sie der Tabellenerstellungsabfrage alle Felder der SQL Pass-Through-Abfrage hinzu, indem Sie das Sternchen (*) in den Entwurfsbereich ziehen.

    Beim Ausführen der Tabellenerstellungsabfrage erhalten Sie für jedes Ergebnis eine Tabelle. Die erste Tabelle besitzt den in der Abfrage definierten Namen; die nachfolgenden Tabellen erhalten den gleichen Namen, verkettet mit einer fortlaufenden Nummer, die bei 1 beginnt. Wenn Sie z.B. möchten, dass für vier Ergebnisgruppen vier Tabellen erstellt werden, wobei Sie als Tabellenname Neue Tabelle auswählen, erhalten die Tabellen die Namen Neue Tabelle, Neue Tabelle1, Neue Tabelle2 und Neue Tabelle3.


 Erstellen eines einfachen Indexes

Erstellen eines einfachen Indexes

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie einen Index erstellen möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein in das Einstellungsfeld für die Eigenschaft Indiziert und dann auf Ja (Duplikate möglich) oder Ja (Ohne Duplikate).

    Klicken Sie auf Ja (Ohne Duplikate), wenn Sie sicherstellen möchten, dass es nicht zwei oder mehr Datensätze mit identischen Einträgen in einem bestimmten Feld gibt.


 Erstellen eines Unterformulars und Hinzufügen zu einem vorhandenen Formular

Erstellen eines Unterformulars und Hinzufügen zu einem vorhandenen Formular

Stellen Sie vor dem Ausführen der nachfolgenden Schritte sicher, dass Sie Ihre Beziehungen korrekt definiert haben.

  1. Öffnen Sie das Formular, dem Sie das Unterformular hinzufügen möchten, in der Entwurfsansicht.

  2. Stellen Sie sicher, dass in der Toolbox das Tool Steuerelement-Assistenten [image] aktiviert ist.

  3. Klicken Sie in der Toolbox auf das Tool Unterformular/-bericht [image] .

  4. Klicken Sie im Formular auf die Stelle, an der Sie das Unterformular einfügen möchten.

  5. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.

  6. Wenn Sie auf Fertig stellen klicken, fügt Microsoft Access Ihrem Formular ein Unterformular-Steuerelement hinzu. Darüber hinaus wird ein separates Formular für das Unterformular erstellt.

Anmerkungen

  • Um Informationen zum Ändern des Layouts eines Unterformulars anzuzeigen, das mit dem Assistenten erstellt wurde, klicken Sie auf [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung in Unterformularen klicken Sie auf [image] .


 Erstellen eines Unterberichts in einem existierenden Bericht

Erstellen eines Unterberichts in einem existierenden Bericht

Wenn der Unterbericht mit dem Hauptbericht verknüpft werden soll, müssen Sie zuvor sicherstellen, dass Sie die Tabellenbeziehungen korrekt eingerichtet haben. Zum Anzeigen von Informationen klicken Sie auf [image] .

  1. Öffnen Sie den Bericht, den Sie als Hauptbericht verwenden möchten, in der Entwurfsansicht.

  2. Stellen Sie sicher, dass in der Toolbox das Tool Steuerelement-Assistenten [image] gedrückt ist.

  3. Klicken Sie in der Toolbox auf das Tool Unterformular/-bericht [image] .

  4. Klicken Sie im Bericht auf die Stelle, an der Sie den Unterbericht einfügen möchten.

  5. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten.

Wenn Sie auf die Schaltfläche Fertig stellen klicken, fügt Microsoft Access Ihrem Bericht ein Unterbericht-Steuerelement hinzu. Darüber hinaus wird ein separater Bericht erstellt und als Unterbericht angezeigt.

Anmerkungen

  • Um Informationen zum Verweisen auf den Wert eines Steuerelements in einem Unterbericht anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zur Fehlerbehandlung bei Unterberichten anzuzeigen, klicken Sie auf [image] .


 Erstellen eines Übersichtsformulars unter Verwendung des Übersichts-Managers

Erstellen eines Übersichtsformulars unter Verwendung des Übersichts-Managers

Wenn Sie zum Erstellen einer Datenbank den Datenbank-Assistenten verwenden, erstellt dieser eine Übersicht, die das Bewegen in Formularen und Berichten Ihrer Datenbank erleichtert. Wenn Sie eine solche Übersicht für eine manuell erstellte Datenbank erstellen möchten, können Sie den Übersichts-Manager verwenden.

  1. Zeigen Sie im Menü Extras auf Add-Ins, und klicken Sie dann auf Übersichts-Manager.

  2. Klicken Sie auf Ja, wenn Microsoft Access fragt, ob Sie eine Übersicht erstellen möchten.

  3. Klicken Sie im Dialogfeld Übersichts-Manager auf Bearbeiten.

  4. Geben Sie im Dialogfeld Übersichtsseite bearbeiten im Feld Übersichtsname einen Namen für die Übersicht ein, und klicken Sie dann auf Neu.

  5. Geben Sie im Dialogfeld Übersichtselement bearbeiten im Feld Text den Text für die erste Schaltfläche in der Übersicht ein, und klicken Sie dann im Feld Befehl auf einen Befehl. Geben Sie z.B. Artikel überarbeiten im Feld Text ein, und klicken Sie dann im Feld Befehl auf Formular im Bearbeitungsmodus öffnen.

  6. Abhängig davon, auf welchen Befehl Sie klicken, zeigt Microsoft Access unterhalb des Feldes Befehl ein weiteres Feld an. Klicken Sie in diesem Feld gegebenenfalls auf ein Element. Wenn Sie z.B. in Schritt 5 im Feld Befehl auf Formular im Bearbeitungsmodus öffnen geklickt haben, klicken Sie nun im Feld Formular auf den Namen des Formulars, das Sie öffnen möchten, z.B. Artikel überarbeiten, und dann auf OK.

  7. Wiederholen Sie die Schritte 4 bis 6, bis Sie alle Elemente zur Übersicht hinzugefügt haben. Wenn Sie ein Element bearbeiten oder löschen möchten, klicken Sie im Feld Elemente auf dieser Übersicht auf das entsprechende Element und dann auf Bearbeiten oder Löschen. Wenn Sie ein Element verschieben möchten, klicken Sie im Feld auf dieses Element und dann auf Aufwärts oder Abwärts.

  8. Klicken Sie auf Schließen.

Anmerkungen

  • Sie können mit dem Übersichts-Manager eine Übersicht erstellen, die zu anderen Übersichten verzweigt. Verwenden Sie die oben beschriebenen Schritte zum Erstellen einer oder mehrerer Übersichten. Zum Definieren einer Übersicht als Standardübersicht, die immer dann automatisch angezeigt wird, wenn eine Datenbank geöffnet wird, klicken Sie im Dialogfeld Übersichts-Manager auf den Namen dieser Übersicht und dann auf Standard. Wenn eine Übersicht zu einer anderen Übersicht verzweigen soll, wählen Sie im oben beschriebenen Schritt 5 im Feld Befehl den Befehl Zur Übersicht gehen, und geben Sie dann die Übersicht an, zu der verzweigt werden soll.

  • Wenn Sie eine Übersicht mit dem Übersichts-Manager erstellen, erstellt Microsoft Access eine Tabelle mit einer Beschreibung der Funktionsweise aller Elemente in der Übersicht. Wenn Sie zu einem späteren Zeitpunkt im Formularentwurf Änderungen am Übersichtsformular vornehmen, arbeitet Ihre Anwendung möglicherweise nicht mehr richtig. Wenn Sie davon ausgehen, dass umfassende Änderungen am Übersichtsformular möglich sein können, ist es empfehlenswert, das Formular ganz neu zu erstellen und dann als Startformular zu definieren. Weitere Informationen zum Entwerfen eines Startformulars finden Sie im Handbuch Erstellen von Anwendungsprogrammen mit Formularen und Berichten unter "Erstellen einer Anwendung".


 Erstellen einer Tabelle durch Eingeben von Daten in ein Datenblatt

Erstellen einer Tabelle durch Eingeben von Daten in ein Datenblatt

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie unter Objekte auf Tabellen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  3. Doppelklicken Sie auf Datenblattansicht. Ein leeres Datenblatt wird angezeigt. Die Standard-Spaltennamen lauten Feld1, Feld2 usw.

  4. Benennen Sie alle Spalten um, die Sie verwenden möchten: Doppelklicken Sie auf den Spaltennamen, geben Sie einen Namen entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein, und drücken Sie die EINGABETASTE.

  5. Sie können jederzeit weitere Spalten einfügen: Klicken Sie auf die Spalte, vor der eine neue Spalte eingefügt werden soll, und dann im Menü Einfügen auf Spalte. Benennen Sie die Spalte entsprechend der Beschreibung in Schritt 4 um.

  6. Geben Sie die gewünschten Daten in das Datenblatt ein.

    Geben Sie die einzelnen Datenarten in separate Spalten ein (in Microsoft Access wird jede Spalte als Feld bezeichnet). Wenn Sie z.B. Namen eingeben, geben Sie Vor- und Nachnamen in separate Spalten ein. Wenn Sie Datum, Uhrzeit oder Zahlen eingeben, verwenden Sie bei der Eingabe ein konsistentes Format, damit Microsoft Access einen entsprechenden Datentyp und ein entsprechendes Anzeigeformat für die Spalte erstellen kann. Alle Spalten, die leer bleiben, werden beim Speichern des Datenblatts gelöscht.

  7. Wenn Sie in alle zu verwendenden Spalten Daten eingegeben haben, klicken Sie in der Symbolleiste auf Speichern [image] , um das Datenblatt zu speichern.

  8. Microsoft Access fragt, ob Sie einen Primärschlüssel erstellen möchten. Wenn Sie keine Daten, wie z.B. Artikelnummern oder Personalnummern, eingegeben haben, anhand derer die einzelnen Zeilen der Tabelle eindeutig identifiziert werden können, klicken Sie auf Ja. Haben Sie jedoch Daten eingegeben, anhand derer jede Zeile eindeutig identifiziert werden kann, können Sie dieses Feld als Primärschlüssel festlegen.

    Wie wird's gemacht?

Microsoft Access weist jedem Feld (jeder Spalte) einen Datentyp auf der Basis der eingegebenen Daten zu. Wenn Sie die Definition eines Feldes weiter anpassen möchten, z.B. um den Datentyp zu ändern oder um eine Gültigkeitsregel zu definieren, verwenden Sie die Entwurfsansicht.

Anmerkung Neben dem Umbenennen und Einfügen von Spalten können Sie jederzeit, vor oder nach dem Speichern des neuen Datenblatts, Spalten löschen oder neu anordnen. Um Informationen zum Löschen einer Spalte anzuzeigen, klicken Sie auf [image] . Um Informationen zum Neuanordnen von Spalten anzuzeigen, klicken Sie auf [image] .


 Erstellen einer Tabelle in der Entwurfsansicht

Erstellen einer Tabelle in der Entwurfsansicht

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie unter Objekte auf Tabellen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  3. Doppelklicken Sie auf Entwurfsansicht.

  4. Definieren Sie die einzelnen Felder Ihrer Tabelle.

    Wie wird's gemacht?

  5. Definieren Sie ein Primärschlüsselfeld, bevor Sie die Tabelle speichern.

    Wie wird's gemacht?

    Anmerkung Das Definieren eines Primärschlüssels ist nicht unbedingt erforderlich, jedoch zu empfehlen. Wenn Sie keinen Primärschlüssel definieren, fragt Microsoft Access, ob beim Speichern der Tabelle ein solcher erstellt werden soll. Zum Anzeigen von Informationen zu Primärschlüsseln klicken Sie auf [image] .

  6. Wenn Sie die Tabelle speichern möchten, klicken Sie in der Symbolleiste auf Speichern [image] . Geben Sie einen Namen für die Tabelle entsprechend den Microsoft Access-Konventionen zur Objektbenennung ein, und klicken Sie dann auf OK.

Anmerkung Zum Anzeigen von Informationen zu Eigenschaften, mit denen Sie die Felder einer Tabelle anpassen können, klicken Sie auf [image] .


Eine Tabelle selbst erstellen

Die Arbeitsschritte in diesem Thema führen Sie von Anfang bis Ende durch den Erstellungsprozess einer Tabelle. Viele dieser Arbeitsschritte werden Sie beim Erstellen jeder Tabelle ausführen. Die anderen benötigen Sie, wenn Sie eine Tabelle entwerfen, die einen bestimmten Datentyp enthalten soll, oder wenn Sie das Erscheinungsbild eines Feldes definieren. Sie müssen nur die Arbeitsschritte ausführen, die für den Datentyp oder die Felddefinitionen Ihrer gerade zu erstellenden Tabelle von Bedeutung sind. Bei anderen Aufgaben, die mit dem Erstellen von Tabellen zusammenhängen, fragen Sie den Antwort-Assistenten.

Beispiele zur Definition und Funktionsweise von Tabellen anzeigen

1 Tabelle erstellen

Eine Tabelle selbst unter Verwendung der Entwurfsansicht erstellen

Beispiele zu den Arten von Tools anzeigen, mit denen Sie beim Entwurf einer Tabelle arbeiten müssen

2 Felder, die Daten enthalten, der Tabelle hinzufügen

Ein Feld für Text oder Memos erstellen

Ein Feld für Zahlen oder Währung erstellen

Ein Feld für Datum oder Zeit erstellen

Ein Feld erstellen, das Werte in Tabellen nachschlägt oder auflistet

3 Definieren, wie ein Feld angezeigt wird oder Daten behandelt

Anzahl der in einem Feld anzuzeigenden Dezimalstellen definieren

Eine Eingabemaske erstellen, die steuert, wie Daten in ein Feld eingegeben werden

Beispiele zu Eingabemasken anzeigen

Einen Standardwert definieren, der automatisch in ein Feld eingegeben wird

Beispiele zu Standardwerten in Feldern anzeigen

Gültigkeitsregeln definieren, die steuern, welche Werte in ein Feld eingegeben werden können

Beispiele zu Gültigkeitsregeln für Felder anzeigen

4 Primärschlüssel zur eindeutigen Identifikation von Datensätzen erstellen

Primärschlüssel festlegen oder ändern

5 Index zum schnelleren Suchen und Sortieren von Datensätzen erstellen

Einfachen Index erstellen

Zusammengesetzten Index erstellen

6 Beziehungen definieren, um Daten aus zwei oder mehr Tabellen zusammenzuführen

Beziehungen zwischen Tabellen definieren

Standardverknüpfungstyp für eine Beziehung zwischen zwei Tabellen definieren

7 Letzte Anpassungen vornehmen

Einen Feldnamen in der Entwurfsansicht ändern

Ein Feld in der Entwurfsansicht der Tabelle verschieben

Ein Feld in der Entwurfsansicht aus einer Tabelle löschen


 Tabellen aus Daten automatisch erstellen

Tabellen aus Daten automatisch erstellen

  • Geben Sie Daten direkt in ein leeres Datenblatt ein. Wenn Sie das neue Datenblatt speichern, analysiert Microsoft Access die Daten und weist jedem Feld automatisch den entsprechenden Datentyp und das entsprechende Format zu.

    Erstellen einer Tabelle durch Eingeben von Daten in ein Datenblatt


 Erstellen einer Tabelle unter Verwendung des Tabellen-Assistenten

Erstellen einer Tabelle unter Verwendung des Tabellen-Assistenten

  1. Wechseln Sie zum Datenbankfenster. Durch Drücken von F11 können Sie von jedem anderen Fenster zum Datenbankfenster wechseln.

  2. Klicken Sie unter Objekte auf Tabellen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  3. Doppelklicken Sie auf Tabellen-Assistent.

  4. Folgen Sie den Anweisungen in den Dialogfeldern Tabellen-Assistent.

Anmerkung Wenn Sie die erstellte Tabelle ändern oder erweitern möchten, können Sie dies in der Entwurfsansicht erledigen, nachdem Sie die Arbeit mit dem Tabellen-Assistenten beendet haben.


Erstellen einer neuen Tabelle - Beispiel

Das folgende Beispiel erstellt ein neues Table-Objekt und fügt es an die Tables-Auflistung der aktuellen Datenbank an.

Anmerkung Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Sub NeueTabelle()
    Dim cat As New ADOX.Catalog, tbl As New ADOX.Table

    ' Verweis auf aktuelle Datenbank zurückgeben.
    Set cat.ActiveConnection = CurrentProject.connection

    tbl.Name = "Kontakte"

    ' Spalte für Tabelle definieren.
    tbl.Columns.Append "Kontaktperson", adVarWChar, 40

    ' Table-Objekt an Tables-Auflistung von Catalog anfügen.
    cat.Tables.Append tbl
    cat.Tables.Refresh
    Set cat = Nothing
End Sub


 Erstellen eines ungebundenen Listenfeldes, Kombinationsfeldes oder eines Dropdownlistenfeldes mit festen Werten

Erstellen eines ungebundenen Listenfeldes, Kombinationsfeldes oder eines Dropdownlistenfeldes mit festen Werten

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass in der Toolbox das Tool Steuerelement-Assistenten [image] aktiviert ist.

    Anmerkung Assistenten sind auf einer Datenzugriffsseite, für die keine Verbindung besteht, nicht verfügbar. Sie sind ebensowenig verfügbar, wenn Sie eine Datenzugriffsseite nicht auf die aktuell geöffnete Datenbank verweisen. In diesen Fällen müssen Sie das Listenfeld bzw. das Dropdownlistenfeld ohne die Hilfe des Assistenten erstellen.

  3. Klicken Sie in der Toolbox auf eines der Listenfeld-Steuerelemente Listenfeld-Steuerelement , Dropdownliste oder Kombinationsfeld .

  4. Klicken Sie im Formular oder auf der Datenzugriffsseite auf die Stelle, an der Sie das Listenfeld, das Dropdownlistenfeld oder das Kombinationsfeld einfügen möchten.

  5. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten. Wenn Sie vom Assistenten nach der Herkunft der Listeneinträge gefragt werden, wählen Sie die Option aus, die angibt, dass Sie die Werte für die Liste selbst eingeben. Wenn Sie gefragt werden, ob Sie den Wert speichern oder zur späteren Verwendung behalten möchten, wählen Sie die letztere Option aus.

Anmerkungen

  • Um weitere Informationen zu den Eigenschaften anzuzeigen, die festlegen, wie ein Listenfeld oder Kombinationsfeld auf einem Formular funktioniert, klicken Sie auf [image] . Um weitere Informationen zu den Eigenschaften anzuzeigen, die festlegen, wie ein Listenfeld oder Kombinationsfeld auf einer Datenzugriffsseite funktioniert, klicken Sie auf [image] .

  • Zum Anzeigen von Informationen zur Problembehandlung bei Listenfeldern, Dropdownlistenfeldern und Kombinationsfeldern klicken Sie auf [image] .


 Erstellen eines ungebundenen Listenfeldes, Kombinationsfeldes oder eines Dropdownlistenfeldes mit Werten aus einer Tabelle oder Abfrage

Erstellen eines ungebundenen Listenfeldes, Kombinationsfeldes oder eines Dropdownlistenfeldes mit Werten aus einer Tabelle oder Abfrage

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder aber eine Datenzugriffsseite in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass in der Toolbox das Tool Steuerelement-Assistenten [image] aktiviert ist.

    Anmerkung Assistenten sind auf einer Datenzugriffsseite, für die keine Verbindung besteht, nicht verfügbar. Sie sind ebensowenig verfügbar, wenn Sie eine Datenzugriffsseite nicht auf die aktuell geöffnete Datenbank verweisen. In diesen Fällen müssen Sie das Listenfeld oder das Dropdownlistenfeld selbst erstellen.

  3. Klicken Sie in der Toolbox auf das Steuerelement Listenfeld Listenfeld-Steuerelement , auf das Steuerelement Dropdownliste oder auf das Steuerelement Kombinationsfeld .

  4. Klicken Sie im Formular oder auf einer Datenzugriffsseite auf die Stelle, an der Sie das Listenfeld, das Dropdownlistenfeld oder das Kombinationsfeld einfügen möchten.

  5. Folgen Sie den Anweisungen in den Dialogfeldern des Assistenten. Wenn Sie vom Assistenten nach der Herkunft der Listeneinträge gefragt werden, wählen Sie die Option aus, die angibt, dass die Werte aus einer Tabelle oder Abfrage abgerufen werden sollen. Wenn Sie gefragt werden, ob Sie den Wert speichern oder zur späteren Verwendung behalten möchten, wählen Sie die letztere Option aus.

Anmerkungen

  • Um weitere Informationen zu den Eigenschaften anzuzeigen, die festlegen, wie ein Listenfeld oder Kombinationsfeld auf einem Formular funktioniert, klicken Sie auf [image] . Um weitere Informationen zu den Eigenschaften benötigen, die festlegen, wie ein Listenfeld oder Kombinationsfeld auf einer Datenzugriffsseite funktioniert, klicken Sie auf [image] .

  • Wenn Sie ein Listen- oder Kombinationsfeld auf einem Formular auf der Basis einer Tabelle oder Abfrage mit einem Assistenten erstellen, erzeugt Microsoft Access, basierend auf den ausgewählten Feldern, eine SQL-Anweisung und legt diese für die Eigenschaft Datensatzherkunft des Steuerelements fest. Wenn die Sortierreihenfolge des Listen- oder Kombinationsfelds nicht Ihren Vorstellungen entspricht, können Sie die SQL-Anweisung ändern, indem Sie auf die Schaltfläche Generator [image] neben der Eigenschaft Datensatzherkunft klicken. Zum Anzeigen von Informationen über das Festlegen einer Sortierreihenfolge im SQL-Anweisungs-Generator, klicken Sie auf [image] .

  • Wenn Sie auf einer Datenzugriffsseite ein Dropdownlistenfeld mit Hilfe eines Assistenten auf der Basis einer Tabelle oder Abfrage erstellen, stellt Access automatisch die ListRowSource-Eigenschaft für die Tabelle ein, die Sie im Assistenten angegeben haben. Wenn das Dropdownlistenfeld nicht auf die gewünschte Weise sortiert ist, erstellen Sie eine Abfrage mit der neuen Sortierreihenfolge und wählen dann die Abfrage im Einstellungsfenster der ListRowSource-Eigenschaft aus.

  • Um Informationen zur Problembehandlung bei Listenfeldern, Dropdownlistenfeldern und Kombinationsfeldern anzuzeigen, klicken Sie auf [image] .


 Erstellen eines ungebundenen Textfelds

Erstellen eines ungebundenen Textfelds

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Textfeld-Steuerelement Textfeld-Steuerelement .

  3. Klicken Sie auf eine beliebige Stelle im Formular, Bericht oder auf der Datenzugriffsseite, um ein Textfeld in Standardgröße zu erstellen, oder ziehen Sie das Textfeld so, dass es die gewünschte Größe erhält.


 Erstellen eines Microsoft Access-Benutzerprofils

Erstellen eines Microsoft Access-Benutzerprofils

So erstellen Sie ein Microsoft Access-Benutzerprofil

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE.

  3. Fügen Sie drei verschachtelte Teilschlüssel hinzu. Verwenden Sie dazu das folgende Format, um Eindeutigkeit sicherzustellen: \Firma\Anwendung\Versionsnummer der Anwendung.

  4. Erstellen Sie für den Teilschlüssel \Versionsnummer der Anwendung alle Teilschlüssel neu, die sich unter \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access befinden und die Werte enthalten, die Sie ändern möchten (nicht jedoch den Teilschlüssel \Profiles, den Sie in Schritt 7 erstellen werden). Kopieren Sie dann die entsprechenden Werte für jeden Teilschlüssel.

  5. Ändern Sie die gewünschten Werte.

  6. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access.

  7. Fügen Sie einen neuen Teilschlüssel hinzu, und geben Sie diesem den Namen \Profiles.

  8. Fügen Sie eine Zeichenfolge zum Teilschlüssel \Profiles hinzu, und geben Sie diesem den Namen, den Sie in der Befehlszeile verwenden möchten.

  9. Geben Sie für die Daten des Wertes eine Zeichenfolge ein, die auf die Position der in Schritt 3 erstellten Teilschlüssel verweist: \SOFTWARE\Firma\Anwendung\Versionsnummer der Anwendung.

  10. Erstellen Sie eine Befehlszeile für Ihre Anwendung, die den in Schritt 8 festgelegten Namen in doppelten Anführungszeichen (") angibt. Beispiel: MSAccess.exe /profile "Profil1" "Name der Anwendung.mdb"

So überschreiben Sie Standardeinstellungen für die Microsoft Jet 4.0-Datenbank-Engine für Access

  1. Wechseln Sie zum Profilunterschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Firma\Anwendung\Versionsnummer der Anwendung.

  2. Erstellen Sie einen Teilschlüssel namens \Jet\4.0\Engines.

  3. Führen Sie für jeden eingebauten Treiber, dessen Einstellungen Sie überschreiben möchten, folgende Schritte aus:

    Fügen Sie dem in Schritt 2 erstellten Teilschlüssel einen entsprechenden Teilschlüssel hinzu; wenn Sie z. B. die Jet Paradox-Einstellungen überschreiben möchten, fügen Sie einen Teilschlüssel mit dem Namen "Paradox" hinzu.

    Fügen Sie diesem Teilschlüssel Werte des entsprechenden Namens und Typs hinzu, und legen Sie dann die Einstellungen fest.

    • Sie können Ihre Teilschlüssel und Werte anhand der Teilschlüssel und Werte in \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines festlegen.

Anmerkungen

  • Mit Hilfe des Arguments acSysCmdProfile der SysCmd-Methode können Sie feststellen, ob Ihre Anwendung Ihr Access-Benutzerprofil richtig geladen hat (der Benutzer kann z. B. versehentlich Ihre Anwendung aus dem Windows Explorer öffnen und die Befehlszeilenoption /profile umgehen). Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können auch die DAO-Methode (Datenzugriffsobjekt) DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • In einer Microsoft Access-Datenbank oder in einem Microsoft Access-Projekt können Sie einen Registrierungsschlüssel auf drei verschiedene Arten einstellen, es darf jedoch immer nur ein Wert verwendet werden. In einem solchen Fall hat ein Access-Benutzerprofil Vorrang vor einer Einstellung einer Microsoft Access-Datenbank oder eines Projekts, die wiederum Vorrang vor einer Microsoft Jet-Einstellung hat. Die nachstehende Tabelle verdeutlicht diese Vorrangstellungen, wobei die Einstellung ODBC ConnectionTimeout als Beispiel verwendet wird.
    Reihenfolge | Position | Registrierungseinstellung unter \HKEY_LOCAL_MACHINE\SOFTWARE…
    1 | Benutzerprofil | \Firma\Anwendung\Versionsnummer der Anwendung\ODBC\ConnectionTimeout=100
    2 Microsoft Access \Microsoft\Office\9.0\Access\Jet\4.0\Engines
    \ODBC\ConnectionTimeout=300
    3 Microsoft Jet \Microsoft\Jet\4.0\Engines
    \ODBC\ConnectionTimeout=600

    Wenn Sie Ihre Anwendung unter Verwendung einer Befehlszeile starten, die das Access-Benutzerprofil angibt, verwendet Microsoft Access für ConnectionTimeout den Wert 100. Wenn Sie Ihre Anwendung ohne das Access-Benutzerprofil starten, verwendet Microsoft Access für ConnectionTimeout den Wert 300.


 Erstellen einer Gültigkeitsregel für ein Steuerelement

Erstellen einer Gültigkeitsregel für ein Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Gültigkeitsregel die Gültigkeitsregel ein, oder klicken Sie in einer Microsoft Access-Datenbank (.mdb) auf die Aufbauen-Schaltfläche [image] , wenn Sie zum Erstellen der Gültigkeitsregel den Ausdrucks-Generator verwenden möchten.

    Zum Anzeigen von Beispielen für Gültigkeitsregeln klicken Sie auf [image] .

  4. Geben Sie im Einstellungsfeld der Eigenschaft Gültigkeitsmeldung die Fehlermeldung ein, die angezeigt werden soll, wenn die eingegebenen Daten nicht der Gültigkeitsregel entsprechen.

Anmerkungen

  • Wenn Sie zum Eingeben eines Ausdrucks in das Einstellungsfeld einer Eigenschaft mehr Platz benötigen, drücken Sie UMSCHALT+F2, um das Dialogfeld Zoom zu öffnen.

  • Wenn Sie in einer Access-Datenbank die Eigenschaft Gültigkeitsregel für das Feld in der Entwurfsansicht für Tabellen einstellen und diese Eigenschaft auch für ein an das Feld gebundenes Steuerelement einstellen, wendet Microsoft Access beide Regeln an. Die Gültigkeitsregel für das Steuerelement setzt die Gültigkeitsregel für das Feld nicht außer Kraft.

  • Access überprüft die Gültigkeit der Daten in einem Feld, sobald Sie Daten ändern und versuchen, das Feld zu verlassen, den Datensatz zu speichern, zu einer anderen Ansicht zu wechseln oder das Formular zu schließen.


 Erstellen von Direkthilfe-Tipps für Formulare oder Steuerelemente

Erstellen von Direkthilfe-Tipps für Formulare oder Steuerelemente

  1. Erstellen Sie die Quelldatei mit Hilfe eines beliebigen Text-Editors oder Textverarbeitungsprogramms. Weitere Informationen über das Erstellen der Quelldatei finden Sie in der Hilfe, die im Lieferumfang von Microsoft Help Workshop enthalten ist. Speichern Sie die Quelldatei anschließend im .RTF-Format.

  2. Kompilieren Sie die Hilfedatei unter Verwendung von Microsoft Help Workshop.

  3. Zeigen Sie das Eigenschaftenfenster des Formulars an, und geben Sie im Einstellungsfeld der Eigenschaft Hilfedatei den Dateinamen der kompilierten Hilfedatei an.

    Anmerkung Es ist sinnvoll, die Hilfedatei in dem Ordner zu speichern, in dem sich auch Ihre Anwendung befindet. Auf diese Weise ist die Einstellung der Eigenschaft Hilfedatei für alle Benutzer/innen, die mit Ihrer Anwendung arbeiten, geeignet und gibt diesen dennoch die Möglichkeit, die Anwendung in einem Ordner ihrer Wahl zu installieren. Wenn Sie als Einstellung für diese Eigenschaft keinen Pfad angeben, sucht Microsoft Access in dem Ordner nach der Hilfedatei, in dem Ihre Anwendung installiert wurde.

  4. Geben Sie im Einstellungsfeld der Eigenschaft Hilfekontext-ID des Formulars die Nummer des Themas (eine Zahl ungleich 0) ein, das angezeigt wird, wenn ein/e Benutzer/in auf die Schaltfläche Direkthilfe [image] und anschließend auf den Hintergrund des Formulars klickt. Dieses Thema dient im Allgemeinen als Unterstützung für das gesamte Formular.

  5. Geben Sie im Einstellungsfeld der Eigenschaft Hilfekontext-ID für jedes Steuerelement im Formular, das den Fokus erhalten kann, die Nummer des Themas ein, das angezeigt wird, wenn ein/e Benutzer/in auf die Schaltfläche Direkthilfe [image] und anschließend auf das entsprechende Steuerelement klickt.

Anmerkungen

  • Sie müssen die als Einstellung der Eigenschaft Hilfekontext-ID angegebenen Werte den Kontextzeichenfolgen Ihres Hilfesystems zuordnen. Weitere Informationen finden Sie in der Hilfe, die im Lieferumfang von Microsoft Help Workshop enthalten ist.

  • Falls einem Steuerelement kein benutzerdefiniertes Hilfethema zugeordnet ist, wird das benutzerdefinierte Hilfethema des Formulars angezeigt, wenn der Benutzer oder die Benutzerin auf die Schaltfläche Direkthilfe [image] und dann auf das entsprechende Steuerelement klickt. Wenn auch das Formular kein benutzerdefiniertes Hilfethema besitzt, zeigt Microsoft Access das Dialogfeld Office-Assistent an.

  • Wenn Sie die Kontext-ID des Hilfethemas als positive Zahl eingeben, dann erscheint das Hilfethema in einem Hilfefenster in Vollanzeige. Wenn Sie vor die Kontext-ID ein Minuszeichen (-) setzen, dann wird das Hilfethema in einem Popupfenster angezeigt. Es ist wichtig zu beachten, dass für die Kontext-ID bei der Autorisierung in Microsoft Help Workshop keine negative Zahl angegeben ist. Sie müssen das Minuszeichen hinzufügen, wenn Sie die Eigenschaft so einstellen möchten, dass das Hilfethema in einem Popupfenster angezeigt wird.

  • Sie können keine benutzerdefinierten Direkthilfe-Tipps über den Office-Assistenten anzeigen.


 Erstellen eines Ausdrucks ohne den Ausdrucks-Generator

Erstellen eines Ausdrucks ohne den Ausdrucks-Generator

Sie können einen Ausdruck erstellen, indem Sie Bezeichner, Operatoren und Werte miteinander verbinden, um das gewünschte Ergebnis zu erhalten. Der folgende Ausdruck vergrößert den im Formular Bestellungen im Steuerelement Frachtkosten angezeigten Wert um 10 Prozent:

= [Formulare]![Bestellungen]![Frachtkosten] * 1,1

In diesem Ausdruck ist:

  • [Formulare]![Bestellungen]![Frachtkosten] ein Bezeichner, der auf den Wert im Formular Bestellungen im Steuerelement Frachtkosten verweist.

  • * der Operator für Multiplikation.

  • 1,1 der Wert, mit dem Microsoft Access den Wert des Steuerelements Frachtkosten multipliziert.

Je nach gewünschtem Ergebnis haben Sie viele unterschiedliche Möglichkeiten, Bezeichner, Operatoren und Werte miteinander zu verbinden. Sie können Ausdrücke verwenden, um Zeichenfolgen miteinander zu verketten, numerische Werte zu addieren oder miteinander zu multiplizieren, Funktionen aufzurufen, auf Objekte und deren Werte zu verweisen und viele andere Operationen ausführen.

Einige Ausdrücke erzeugen ein Ergebnis des Typs Wahr oder Falsch. Wenn Sie z.B. einen Ausdruck in die Spalte für Bedingungen eines Makros eingeben, führt Microsoft Access die angegebene Aktion nur aus, wenn der Ausdruck wahr ist. Der folgende Ausdruck ist nur dann wahr, wenn im Formular Personal im Steuerelement Land der angezeigte Wert 'UK' ist:

Formulare![Personal]![Land] = "UK"

Um weitere Informationen über das Verwenden von Bezeichnern in Ausdrücken zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über Operatoren zu erhalten, klicken Sie auf [image] .

Um weitere Informationen über das Verwenden von Werten in Ausdrücken zu erhalten, klicken Sie auf [image] .


 Anpassen von Microsoft Excel-Treibereinstellungen

Anpassen von Microsoft Excel-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Excel    , und nehmen Sie die gewünschten Änderungen vor.

    Zum Anzeigen von Informationen zu Microsoft Excel-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesen Teilschlüsseln haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf Microsoft Excel-Daten die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Microsoft Access 2000 Gültigkeit haben, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Excel ändern. Wenn der Teilschlüssel \Excel nicht existiert, erstellen Sie diesen und fügen dann die gewünschten Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen von Exchange-Treibereinstellungen

Anpassen von Exchange-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange, und nehmen Sie die gewünschten Änderungen vor.

    Wenn Sie weitere Informationen zu Treibereinstellungen in Exchange benötigen, klicken Sie auf [image] .

  3. Beenden Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access und starten Sie es neu, damit die neuen Einstellungen wirksam werden.

Wichtig Änderungen an den Einstellungen dieses Teilschlüssels betreffen alle Programme, die auf dem Computer installiert sind und die Microsoft Jet Datenbank-Engine verwenden, um auf Microsoft Exchange-Daten zuzugreifen. Neben Microsoft Access 2000 sind davon Microsoft Excel 2000, Microsoft Visual Basic, Version 6.0 oder höher, und möglicherweise noch weitere Programme betroffen. Wenn Sie Änderungen vornehmen möchten, die nur für Access 2000 gelten, wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Exchange, und ändern Sie die Werte dort. Wenn der Teilschlüssel \Exchange nicht vorhanden ist, erstellen Sie ihn, und fügen Sie dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt, DAO) Application.DBEngine.SetOption verwenden, um dynamisch Microsoft Jet-Registrierungswerte zur Laufzeit für eine Sitzung zu ändern, ohne dabei permanent die Werte in der Registrierung von Windows zu ändern. Um weitere Informationen zu erhalten, klicken Sie auf [image] .


 Anpassen von dBASE-Treibereinstellungen

Anpassen von dBASE-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase, und nehmen Sie die gewünschten Änderungen vor.

    Zum Anzeigen von Informationen zu Microsoft dBASE-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesen Teilschlüsseln haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf dBASE-Daten die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Microsoft Access 2000 Gültigkeit haben, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Xbase ändern. Wenn der Teilschlüssel \Xbase nicht existiert, erstellen Sie diesen und fügen Sie dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen von HTML-Treibereinstellungen

Anpassen von HTML-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Text, und nehmen Sie die gewünschten Änderungen vor.

    Zum Anzeigen von Informationen zu HTML-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Miccrosoft Access und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an Einstellungen in diesen Teilschlüsseln haben für alle auf dem Computer installierten Programme Gültigkeit, die zum Zugreifen auf HTML-Daten die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Microsoft Access 2000 Gültigkeit haben, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Text ändern. Wenn der Teilschlüssel \Text nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 2.x

Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 2.x

Anmerkung Die Einstellungen für die Microsoft Jet-Datenbank-Engine gelten nur für Microsoft Access-Datenbanken, nicht für Microsoft Access-Projekte.

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x    , und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu Namen, Typen und Standardwerten für die Einstellungen der Microsoft Jet 2.x-Datenbank-Engine klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es neu, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf Microsoft Access-Datenbanken der Versionen 1.x und 2.0 die Microsoft Jet-Datenbank-Engine verwenden. Zusätzlich zu Microsoft Access sind dies Microsoft Excel, Microsoft Visual Basic und unter Umständen weitere Programme. Wenn Sie Änderungen durchführen möchten, die nur für Microsoft Access gelten, wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Jet 2.x und ändern dort die gewünschten Werte. Wenn der Teilschlüssel \Jet 2.x nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 4.0

Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 4.0

Anmerkung Die Einstellungen für die Microsoft Jet-Datenbank-Engine gelten nur für Microsoft Access-Datenbanken, nicht für Microsoft Access-Projekte (Ausnahmen: beim Importieren, Verknüpfen oder Exportieren von Daten oder Datenbankobjekten eines Access-Projekts).

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft \Jet\4.0\Engines\Jet 4.0, und nehmen Sie die gewünschten Änderungen vor.

    Zum Anzeigen von Informationen zu Namen, Typen und Standardwerten für die Einstellungen der Microsoft Jet 4.0-Datenbank-Engine klicken Sie auf [image] .

  3. Beenden Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es neu, damit die neuen Einstellungen wirksam werden.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel gelten für alle auf dem Computer installierten Programme, die für den Zugriff auf Microsoft Access 2000-Datenbanken die Microsoft Jet-Datenbank-Engine verwenden. Zusätzlich zu Microsoft Access sind dies Microsoft Excel 2000, Microsoft Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen durchführen möchten, die nur für Microsoft Access gelten, wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Jet 4.0 und ändern dort die Werte. Wenn der Teilschlüssel \Jet 4.0 nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO (Datenzugriffsobjekt)-Methode Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 3.x

Anpassen der Einstellungen für die Microsoft Jet-Datenbank-Engine, Version 3.x

Anmerkung Die Einstellungen für die Microsoft Jet-Datenbank-Engine gelten nur für Microsoft Access-Datenbanken, nicht für Microsoft Access-Projekte.

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x, und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu den Namen, Typen und Standardwerten für Einstellungen für die Microsoft Jet 3.x-Datenbank-Engine klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es dann neu, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel gelten für alle auf dem Computer installierten Programme, die für den Zugriff auf Microsoft Access 95- oder Microsoft Access 97-Datenbanken die Microsoft Jet-Datenbank-Engine verwenden. Zusätzlich zu Microsoft Access sind dies Microsoft Excel, Visual Basic und unter Umständen weitere Programme. Wenn Sie Änderungen durchführen möchten, die nur für Microsoft Access gelten, wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Jet 3.x und ändern dort die gewünschten Werte. Wenn der Teilschlüssel \Jet 3.x nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen von Lotus-Treibereinstellungen

Anpassen von Lotus-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus, und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu Lotus-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf Lotus 1-2-3-Daten die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Access 2000 gelten, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Lotus ändern. Wenn der Teilschlüssel \Lotus nicht existiert, erstellen Sie diesen und fügen dann die gewünschten Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen von ODBC-Treibereinstellungen

Anpassen von ODBC-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\ODBC    , und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu den Namen, Typen und Standardwerten für ODBC-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf ODBC-Datenbanken die Microsoft Jet-Datenbank-Engine verwenden. Zusätzlich zu Microsoft Access 2000 sind dies Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen durchführen möchten, die nur für Access 2000 gelten, wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\ODBC und ändern dort die gewünschten Werte. Wenn der Teilschlüssel \ODBC nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Festlegen, ob OLE-Verknüpfungen im OLE-Format der Version 2.x oder der Version 1.x gespeichert werden sollen

Festlegen, ob OLE-Verknüpfungen im OLE-Format der Version 2.x oder der Version 1.x gespeichert werden sollen

Sie können festlegen, ob Microsoft Access OLE-Verknüpfungen im OLE-Format der Version 2.x, in dem sowohl relative als auch absolute Verweise auf Verknüpfungsquellen oder im Format der Version 1.x, in dem nur absolute Verweise gespeichert werden, ablegen soll. (Ein absoluter Verweis auf eine Verknüpfungsquelle erhält Daten aus einem Objekt, das als Datei gespeichert ist. Ein relativer Verweis auf eine Verknüpfungsquelle erhält Daten aus einem Objekt, das in ein Dokument eingebettet sein kann.) In einer Umgebung, in der sowohl Microsoft Access 2000 als auch Microsoft Accesss 1.x-Versionen verwendet werden, legen Sie für diese Option die Einstellung 1 fest, um Konsistenz für OLE-Verknüpfungsoperationen in Microsoft Access 1.x-Datenbanken zu gewährleisten.

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie in der Registrierung zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Office\9.0\Access.

  3. Doppelklicken Sie auf den Teilschlüssel \Options. Wenn der Eintrag AllowOLE1LinkFormat in der Spalte Name im rechten Ausschnitt des Registrierungseditors bereits aufgeführt ist, fahren Sie mit Schritt 6 fort.

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

  5. Geben Sie AllowOLE1LinkFormat ein, und drücken Sie dann die EINGABETASTE.

  6. Doppelklicken Sie auf AllowOLE1LinkFormat, und geben Sie dann im Feld Wert den Wert 1 ein, wenn Sie im Verknüpfungsformat von OLE 1.x speichern möchten, oder geben Sie 0 ein, wenn Sie im Verknüpfungsformat von OLE 2.x speichern möchten.

  7. Verlassen Sie den Registrierungseditor.

  8. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.


 Anpassen von Paradox-Treibereinstellungen

Anpassen von Paradox-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox, und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu Paradox-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf Paradox-Dateien die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Access 2000 gelten, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Paradox ändern. Wenn der Teilschlüssel \Paradox nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anpassen von Text-Treibereinstellungen

Anpassen von Text-Treibereinstellungen

  1. Starten Sie den Registrierungseditor.

    Wie wird's gemacht?

  2. Wechseln Sie zum Teilschlüssel \HKEY_LOCAL_MACHINE
    \SOFTWARE\Microsoft\Jet\4.0\Engines\Text    , und führen Sie die gewünschten Änderungen durch.

    Zum Anzeigen von Informationen zu Text-Treibereinstellungen klicken Sie auf [image] .

  3. Verlassen Sie den Registrierungseditor.

  4. Beenden Sie Microsoft Access, und starten Sie es erneut, um die neuen Einstellungen in Kraft zu setzen.

Wichtig Änderungen an den Einstellungen in diesem Teilschlüssel haben für alle auf dem Computer installierten Programme Gültigkeit, die für den Zugriff auf Textdaten die Microsoft Jet-Datenbank-Engine verwenden. Dies sind zusätzlich zu Microsoft Access 2000 die Programme Microsoft Excel 2000, Visual Basic, Version 6.0 oder höher, und unter Umständen weitere Programme. Wenn Sie Änderungen vornehmen möchten, die nur für Access 2000 Gültigkeit haben, müssen Sie die Werte im Teilschlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0\Engines
\Text ändern. Wenn der Teilschlüssel \Text nicht existiert, erstellen Sie diesen und fügen dann die Werte hinzu.

Anmerkung Sie können auch die DAO-Methode (Datenzugriffsobjekt) Application.DBEngine.SetOption verwenden, wenn Sie Microsoft Jet-Registrierungseinstellungen während der Laufzeit für eine einzelne Sitzung dynamisch ändern möchten, ohne gleichzeitig die Einstellungen in der Windows-Registrierung permanent zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Definieren des Datenanzeigeformats für ein Feld in der Entwurfsansicht für Abfragen

Definieren des Datenanzeigeformats für ein Feld in der Entwurfsansicht für Abfragen

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Setzen Sie im Abfrageentwurfsbereich die Einfügemarke in die Spalte für das Feld, das Sie formatieren möchten. Sie können die Einfügemarke in jede der Zeilen für dieses Feld setzen.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für dieses Feld zu öffnen.

  4. Klicken Sie auf der Registerkarte Allgemein in das Einstellungsfeld für die Eigenschaft Format und dann auf eines der vorderfinierten Formate. Wenn keines der vordefinierten Formate Ihren Anforderungen genügt, können Sie für jeden Feldtyp, ausgenommen jedoch Felder vom Typ OLE-Objekt, ein benutzerdefiniertes Format erstellen. Zum Anzeigen von Informationen zum Erstellen eines benutzerdefinierten Formats klicken Sie auf [image] .

Anmerkung Um anwendungsübergreifende Konsistenz zu gewährleisten, verwendet Microsoft Access für bestimmte vordefinierte Zahlen- und Datum-/Zeitformate die in der Windows-Systemsteuerung festgelegten Ländereinstellungen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Definieren eines Eingabeformats für ein Feld in einer Tabelle

Definieren eines Eingabeformats für ein Feld in einer Tabelle

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie ein Eingabeformat definieren möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein auf die Aufbauen-Schaltfläche [image] neben dem Eigenschaftenfeld Eingabeformat, um den Eingabeformat-Assistenten zu starten. Folgen Sie dannn den Anweisungen in den Dialogfeldern des Assistenten.

Anmerkung Sie können die Eingabeformatdefinition auch ohne Verwendung des Assistenten in das Eigenschaftenfenster eingeben. In der Regel ist es am einfachsten, den Assistenten zu verwenden, für Felder vom Datentyp Zahl und Währung müssen Sie die Eingabeformatdefinition jedoch manuell eingeben. Zum Anzeigen von Informationen dazu, wie Sie ein Eingabeformat manuell definieren, klicken Sie auf [image] .


 Festlegen der Anzahl der Dezimalstellen, die für ein Steuerelement angezeigt werden sollen

Festlegen der Anzahl der Dezimalstellen, die für ein Steuerelement angezeigt werden sollen

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Stellen Sie sicher, dass das Steuerelement, das Sie ändern möchten, markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für das Steuerelement zu öffnen.

  3. Klicken Sie auf das Einstellungsfeld für die Eigenschaft Dezimalstellenanzeige und dann auf den Pfeil. Wählen Sie anschließend die gewünschte Anzahl der Dezimalstellen aus.

    Die Eigenschaft Dezimalstellenanzeige unterstützt eine Standardeinstellung, Automatisch, und die Möglichkeit, 0 bis 15 Dezimalstellen festzulegen. Wenn die Einstellung Automatisch festgelegt ist, zeigen Felder, für die Eigenschaft Format eine der Einstellungen Währung, Festkommazahl, Standardzahl, Prozentzahl und Exponentialzahl festgelegt ist, zwei Dezimalstellen an. Die Eigenschaft Dezimalstellenanzeige hat nur Gültigkeit, wenn die Eigenschaft Format eingestellt ist. Zum Anzeigen von Informationen zum Definieren des Anzeigeformats für ein Feld klicken Sie auf [image] .

Anmerkung Die Einstellung der Eigenschaft Dezimalstellenanzeige gilt nur für die Anzahl der Dezimalstellen, die angezeigt werden, nicht für die Anzahl der Dezimalstellen, die gespeichert werden. Wenn Sie z.B. für ein Feld vom Datentyp Zahl, für das für die Eigenschaft Feldgröße die Einstellung Integer festgelegt ist, für die Eigenschaft Dezimalstellenanzeige den Wert 2 festlegen, wird die Zahl mit zwei Dezimalstellen angezeigt. Da jedoch nur ganze Zahlen (Integerwerte) gespeichert werden, werden die beiden Dezimalstellen in Form von Nullen gespeichert. Zum Ändern der Anzahl der Dezimalstellen, die gespeichert werden sollen, müssen Sie die Einstellung der Eigenschaft Feldgröße für das Feld ändern. Um Informationen zum Einstellen der Eigenschaft Feldgröße eines Feldes anzuzeigen, klicken Sie auf [image] .


 Festlegen der Anzahl der Dezimalstellen, die für ein Feld in der Entwurfsansicht für Abfragen angezeigt werden sollen

Festlegen der Anzahl der Dezimalstellen, die für ein Feld in der Entwurfsansicht für Abfragen angezeigt werden sollen

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Setzen Sie die Einfügemarke im Abfrageentwurfsbereich in die Spalte für das Feld, das Sie ändern möchten. Sie können die Einfügemarke in jede der Zeilen für dieses Feld setzen.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für dieses Feld zu öffnen.

  4. Klicken Sie auf der Registerkarte Allgemein auf den Pfeil neben dem Eigenschaftenfeld Dezimalstellenanzeige und dann auf die gewünschte Anzahl der Dezimalstellen.

    Die Eigenschaft Dezimalstellenanzeige unterstützt eine Standardeinstellung, Automatisch, und die Möglichkeit, 0 bis 15 Dezimalstellen festzulegen. Wenn die Einstellung Automatisch festgelegt ist, zeigen Felder, für die Eigenschaft Format eine der Einstellungen Währung, Festkommazahl, Standardzahl, Prozentzahl und Exponentialzahl festgelegt ist, zwei Dezimalstellen an. Die Eigenschaft Dezimalstellenanzeige hat nur Gültigkeit, wenn die Eigenschaft Format eingestellt ist. Um Informationen zum Definieren des Anzeigeformats für ein Feld anzuzeigen, klicken Sie auf [image] .

Anmerkung Die Einstellung der Eigenschaft Dezimalstellenanzeige gilt nur für die Anzahl der Dezimalstellen, die angezeigt werden, nicht für die Anzahl der Dezimalstellen, die gespeichert werden. Wenn Sie z.B. für ein Feld vom Datentyp Zahl, für das für die Eigenschaft Feldgröße die Einstellung Integer festgelegt ist, für die Eigenschaft Dezimalstellenanzeige den Wert 2 festlegen, wird die Zahl mit zwei Dezimalstellen angezeigt. Da jedoch nur ganze Zahlen (Integerwerte) gespeichert werden, werden die beiden Dezimalstellen in Form von Nullen gespeichert. Zum Ändern der Anzahl der Dezimalstellen, die gespeichert werden sollen, müssen Sie die Einstellung der Eigenschaft Feldgröße für das Feld ändern. Um Informationen zum Einstellen der Eigenschaft Feldgröße eines Feldes anzuzeigen, klicken Sie auf [image] .


 Definieren des Datenanzeigeformats für ein Feld in der Tabellenentwurfsansicht

Definieren des Datenanzeigeformats für ein Feld in der Tabellenentwurfsansicht

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, das Sie formatieren möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein auf den Pfeil neben dem Eigenschaftenfeld Format und dann auf eines der vordefinierten Formate. Wenn keines der vordefinierten Formate Ihren Anforderungen genügt, können Sie für jeden Felddatentyp, ausgenommen jedoch Felder vom Typ OLE-Objekt, ein benutzerdefiniertes Format erstellen. Zum Anzeigen von Informationen zum Erstellen eines benutzerdefinierten Formats klicken Sie auf [image] .

Anmerkung Um anwendungsübergreifende Konsistenz zu gewährleisten, verwendet Microsoft Access für bestimmte vordefinierte Zahlen- und Datum-/Zeitformate die in der Windows 95-Systemsteuerung festgelegten Ländereinstellungen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Definieren eines Eingabeformats für ein Feld in einer Abfrage

Definieren eines Eingabeformats für ein Feld in einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Setzen Sie die Einfügemarke im Abfrageentwurfsbereich in die Spalte für das Feld, das Sie ändern möchten. Sie können die Einfügemarke in jede der Zeilen für dieses Feld setzen.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für dieses Feld zu öffnen.

  4. Klicken Sie auf der Registerkarte Allgemein auf die Aufbauen-Schaltfläche [image] neben dem Eigenschaftenfeld Eingabeformat, um den Eingabeformat-Assistenten zu starten. Folgen Sie dann den Anweisungen in den Dialogfeldern des Assistenten.

Anmerkung Sie können die Eingabeformatdefinition auch ohne Verwendung des Assistenten in das Eigenschaftenfenster eingeben. In der Regel ist es am einfachsten, den Assistenten zu verwenden, für Felder vom Datentyp Zahl und Währung müssen Sie die Eingabeformatdefinition jedoch manuell eingeben. Zum Anzeigen von Informationen dazu, wie Sie ein Eingabeformat manuell definieren, klicken Sie auf [image] .


 Festlegen der Anzahl der Dezimalstellen, die für ein Feld in der Tabellenentwurfsansicht angezeigt werden sollen

Festlegen der Anzahl der Dezimalstellen, die für ein Feld in der Tabellenentwurfsansicht angezeigt werden sollen

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für die Sie die Anzahl der Dezimalstellen festlegen möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Allgemein auf den Pfeil neben dem Eigenschaftenfeld Dezimalstellenanzeige und dann auf die gewünschte Anzahl der Dezimalstellen.

    Die Eigenschaft Dezimalstellenanzeige unterstützt eine Standardeinstellung, Automatisch, und die Möglichkeit, 0 bis 15 Dezimalstellen festzulegen. Wenn die Einstellung Automatisch festgelegt ist, zeigen Felder für die Eigenschaft Format eine der Einstellungen Währung, Festkommazahl, Standardzahl, Prozentzahl und Exponentialzahl festgelegt ist, zwei Dezimalstellen an. Die Eigenschaft Dezimalstellenanzeige hat nur Gültigkeit, wenn die Eigenschaft Format eingestellt ist. Um Informationen zum Definieren des Anzeigeformats für ein Feld anzuzeigen, klicken Sie auf [image] .

Anmerkung Die Einstellung der Eigenschaft Dezimalstellenanzeige gilt nur für die Anzahl der Dezimalstellen, die angezeigt werden, nicht für die Anzahl der Dezimalstellen, die gespeichert werden. Wenn Sie z.B. für ein Feld vom Datentyp Zahl, für das für die Eigenschaft Feldgröße die Einstellung Integer festgelegt ist, für die Eigenschaft Dezimalstellenanzeige den Wert 2 festlegen, wird die Zahl mit zwei Dezimalstellen angezeigt. Da jedoch nur ganze Zahlen (Integerwerte) gespeichert werden, werden die beiden Dezimalstellen in Form von Nullen gespeichert. Zum Ändern der Anzahl der Dezimalstellen, die gespeichert werden sollen, müssen Sie die Einstellung der Eigenschaft Feldgröße für das Feld ändern. Zum Anzeigen von Informationen zum Einstellen der Eigenschaft Feldgröße eines Feldes klicken Sie auf [image] .


Ändern oder Löschen benutzerdefinierter Datenbankeigenschaften

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften, während die Datenbank geöffnet ist.

  2. Klicken Sie auf die Registerkarte Anpassen.

  3. Klicken Sie in der Spalte Name des Feldes Eigenschaften auf den Namen der Eigenschaft, die Sie ändern oder löschen möchten.

  4. Um die Eigenschaft zu ändern, geben Sie die gewünschten Änderungen in die Felder Typ oder Wert ein und klicken dann auf Ändern.

    Um die Eigenschaft zu löschen, klicken Sie auf Löschen.

Anmerkung Wenn Sie versuchen, den Namen der Eigenschaft zu ändern, wird diese zu einer neuen Eigenschaft, und Sie können sie nur noch hinzufügen. Wenn Sie den Namen einer Eigenschaft ändern möchten, löschen Sie die vorhandene Eigenschaft, und fügen Sie sie mit dem neuen Namen wieder hinzu.


 Löschen einer Access-Datenbank oder eines Access-Projekts

Löschen einer Access-Datenbank oder eines Access-Projekts

  1. Schließen Sie die Microsoft Access-Datenbank oder das Microsoft Access-Projekt. Stellen Sie in einer Mehrbenutzerumgebung sicher, dass alle Benutzer die Access-Datenbank geschlossen haben.

  2. Klicken Sie in der Symbolleiste auf Öffnen [image] .

  3. Suchen Sie im Dialogfeld Öffnen die Access-Datenbank bzw. das Access-Projekt, das Sie löschen möchten. Klicken Sie dann mit der rechten Maustaste auf die Datei.

  4. Klicken Sie im Kontextmenü auf Löschen.

Anmerkungen

  • Falls Sie die Datei doch noch benötigen, sehen Sie im Papierkorb nach. Die gelöschte Datei bleibt so lange im Papierkorb, bis Sie diesen leeren.

  • Wenn Sie eine Access-Datenbank oder ein Access-Projekt löschen, die bzw. das eine Datenzugriffsseite enthält, werden damit nicht die HTML-Dateien der Seite gelöscht.

  • Wenn Sie ein Access-Projekt löschen, löschen Sie damit nicht die Microsoft SQL Server-Datenbank, mit der das Access-Projekt verbunden ist.

  • Sie können eine Access-Datenbank oder ein Access-Projekt auch außerhalb von Access löschen. Schließen Sie die Datei, und klicken Sie in Windows Explorer oder unter Arbeitsplatz mit der rechten Maustaste auf die Datei. Klicken Sie dann im Kontextmenü auf Löschen.


 Automatisches Löschen von doppelten Datensätzen aus einer Tabelle

Automatisches Löschen von doppelten Datensätzen aus einer Tabelle

In den nachstehend aufgeführten Schritten werden Sie eine Kopie der Struktur der Tabelle erstellen, die Duplikate enthält; für alle Felder, die Duplikate enthalten, den Primärschlüssel erstellen und anschließend eine Anfügeabfrage zum Anfügen von der Originaltabelle an die neue Tabelle durchführen. Da Felder, für die Primärschlüssel hergestellt wurden, keine doppelten Datensätze enthalten können, wird durch dieses Verfahren eine Tabelle ohne doppelte Datensätze erstellt.

So erstellen Sie eine neue Tabelle

  1. Klicken Sie im Datenbankfenster unter Objekte auf Tabellen [image] .

  2. Klicken Sie auf den Namen der Tabelle, aus der Sie doppelte Datensätze löschen möchten.

  3. Klicken Sie in der Symbolleiste auf Kopieren [image] .

  4. Klicken Sie in der Symbolleiste auf Einfügen [image] .

  5. Geben Sie im Dialogfeld Tabelle einfügen als einen Namen für die kopierte Tabelle ein, klicken Sie auf Nur Struktur und dann auf OK.

  6. Öffnen Sie die neue Tabelle in der Entwurfsansicht, und wählen Sie das Feld bzw. die Felder aus, das/die in der kopierten Tabelle Duplikate enthielt(en).

  7. Klicken Sie in der Symbolleiste auf Primärschlüssel [image] , um auf der Basis der ausgewählten Felder einen Primärschlüssel zu erstellen.

  8. Speichern und schließen Sie die Tabelle.

So fügen Sie nur eindeutige Datensätze an die neue Tabelle an

  1. Erstellen Sie eine neue Abfrage auf der Basis der Originaltabelle mit den Duplikaten.

  2. Klicken Sie in der Abfrageentwurfsansicht auf Abfragetyp [image] in der Symbolleiste und dann auf Anfügeabfrage.

  3. Klicken Sie im Dialogfeld Anfügen im Listenfeld Tabellenname auf den Namen der neuen Tabelle und dann auf OK.

  4. Fügen Sie alle Felder aus der Originaltabelle zum Abfrageentwurfsbereich hinzu. Klicken Sie dazu auf das Sternchen (*).

  5. Klicken Sie in der Symbolleiste auf Ausführen [image] .

  6. Klicken Sie auf Ja, wenn Sie die Meldung erhalten, dass die Zeilen nun angefügt werden.

  7. Klicken Sie auf Ja, wenn die Meldung angezeigt wird, dass Microsoft Access nicht alle Datensätze in der Anfügeabfrage anfügen kann. Dies bedeutet, dass nur eindeutige Datensätze zur neuen Tabelle hinzugefügt und alle Duplikate ignoriert werden.

  8. Um das Ergebnis anzuzeigen, öffnen Sie die Tabelle, indem Sie zunächst im Datenbankfenster unter Objekte auf Tabellen [image] klicken und dann in der Symbolleiste des Datenbankfensters auf Öffnen klicken.

  9. Wenn Sie sicher sind, dass die neue Tabelle die korrekten, eindeutigen Datensätze enthält, können Sie die Originaltabelle löschen, und der neuen Tabelle den Namen der gelöschten Tabelle geben.


 Löschen eines Feldes aus einer Tabelle in der Datenblattansicht

Löschen eines Feldes aus einer Tabelle in der Datenblattansicht

  1. Öffnen Sie die Tabelle in der Datenblattansicht.

  2. Klicken Sie auf den Feldmarkierer der Spalte, die Sie löschen möchten.

  3. Klicken Sie im Menü Bearbeiten auf Spalten löschen.

Anmerkungen

  • Wenn andere Datenbankobjekte Verweise auf ein gelöschtes Feld enthalten, löschen Sie diese Verweise ebenfalls. Enthält ein Bericht z. B. ein an ein gelöschtes Feld gebundenes Steuerelement, ist Microsoft Access nicht in der Lage, die Felddaten zu finden, und zeigt eine Fehlermeldung an.

  • Ein Feld, das Teil einer Beziehung ist, kann nicht gelöscht werden. Um das Feld zu löschen, löschen Sie zuerst die Beziehung.


 Löschen eines Feldes aus einer Tabelle in der Entwurfsansicht

Löschen eines Feldes aus einer Tabelle in der Entwurfsansicht

  1. Öffnen Sie die Tabelle in der Entwurfsansicht.

  2. Markieren Sie das Feld bzw. die Felder, das/die Sie löschen möchten.

    Um ein einziges Feld zu markieren, klicken Sie auf den Zeilenmarkierer des entsprechenden Feldes.

    Um eine Gruppe von Feldern zu markieren, ziehen Sie die Maus über die Zeilenmarkierer der entsprechenden Felder.

  3. Klicken Sie in der Symbolleiste auf Zeilen löschen [image] .

Anmerkungen

  • Wenn andere Datenbankobjekte Verweise auf ein gelöschtes Feld enthalten, löschen Sie diese Verweise ebenfalls. Enthält ein Bericht z. B. ein an ein gelöschtes Feld gebundenes Steuerelement, ist Microsoft Access nicht in der Lage, die Felddaten zu finden, und zeigt eine Fehlermeldung an.

  • Ein Feld, das Teil einer Beziehung ist, kann nicht gelöscht werden. Um das Feld zu löschen, löschen Sie zuerst die Beziehung.


 Löschen eines Bildes oder eines anderen Objekts aus einem Formular oder Bericht

Löschen eines Bildes oder eines anderen Objekts aus einem Formular oder Bericht

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt oder ein Bild-Steuerelement, klicken Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Drücken Sie ENTF.

    Wenn das Objekt gebunden ist, entfernt Microsoft Access dieses aus dem gebundenen Objektfeld und dem zugrunde liegenden Datensatz, das Objektfeld verbleibt jedoch im Formular oder Bericht. Wenn das Objekt ein ungebundenes Objektfeld oder ein Bild-Steuerelement ist, entfernt Microsoft Access sowohl das Objekt als auch das Steuerelement.

Anmerkung Wenn Sie ein gebundenes Objektfeld und alle im zugrunde liegenden Feld gespeicherten Objekte löschen möchten, löschen Sie das gebundene Objektfeld in der Formular- oder der Berichts-Entwurfsansicht. Löschen Sie dann in einer Microsoft Access-Datenbank (.mdb) das Feld vom Datentyp OLE-Objekt in der Tabellenentwurfsansicht. Löschen Sie in einem Microsoft Access-Projekt (.adp) die Image-Spalte in der Ansicht Spalteneigenschaften des Datenbankdiagramms.


 Löschen von Datensätzen aus einer einzigen Tabelle oder aus mehreren Tabellen einer 1:1-Beziehung

Löschen von Datensätzen aus einer einzigen Tabelle oder aus mehreren Tabellen einer 1:1-Beziehung

Zum Anzeigen von Informationen, was beim Einsatz einer Abfrage, die Datensätze löscht, unbedingt berücksichtigt werden muss, klicken Sie auf [image] .

  1. Erstellen Sie eine neue Abfrage auf der Basis der Tabellen, aus denen Sie Datensätze löschen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Löschen.

  3. Ziehen Sie in den Tabellen, aus denen Sie Datensätze löschen möchten, das Sternchen (*) aus der Feldliste in den Abfrageentwurfsbereich.

    In der Zelle Löschen unter diesen Feldern wird jetzt Von angezeigt, wie in der folgenden Abbildung dargestellt.

  4. Zum Festlegen von Kriterien zum Löschen von Datensätzen ziehen Sie die Felder in den Entwurfsbereich, für die Sie Kriterien festlegen möchten.

    In der Zelle Löschen unter diesen Feldern wird jetzt Bedingung angezeigt, wie in der folgenden Abbildung dargestellt.

    Festlegen von Kriterien zum Löschen von Datensätzen

  5. Geben Sie in der Zelle Kriterien für die Felder, die Sie in den Entwurfsbereich gezogen haben, die gewünschten Kriterien ein.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  6. Zum Anzeigen der Datensätze, die gelöscht werden, klicken Sie in der Symbolleiste auf Abfrageansicht [image] . Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie ggf. Änderungen durch.

  7. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Datensätze zu löschen.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.


 Löschen von Datensätzen unter Verwendung einer Abfrage, die beide Tabellen einer 1:n-Beziehung enthält

Löschen von Datensätzen unter Verwendung einer Abfrage, die beide Tabellen einer 1:n-Beziehung enthält

Zum Anzeigen von Informationen dazu, was beim Einsatz einer Abfrage, die Datensätze löscht, unbedingt berücksichtigt werden muss, klicken Sie auf [image] .

  1. Erstellen Sie eine neue Abfrage auf der Basis von Tabellen, aus denen Sie Datensätze löschen oder für die Sie Kriterien festlegen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Löschen.

  3. Ziehen Sie in der Tabelle mit den verknüpften Datensätzen (auf der "n"-Seite der 1:n-Beziehung) das Sternchen (*) aus der Feldliste in den Abfrageentwurfsbereich.

    In der Zelle Löschen unter diesem Feld wird jetzt Von angezeigt, wie in der folgenden Abbildung dargestellt.

  4. Ziehen Sie aus der Primärtabelle (auf der "1"-Seite der 1:n-Beziehung) die Felder in den Entwurfsbereich, für die Sie Kriterien festlegen möchten.

    In der Zelle Löschen unter diesem Feld wird jetzt Bedingung angezeigt, wie in der folgenden Abbildung dargestellt.

    Festlegen von Kriterien zum Löschen von Datensätzen aus beiden Seiten einer 1:n-Beziehung

  5. Geben Sie in der Zelle Kriterien für die Felder, die Sie in den Entwurfsbereich gezogen haben, die gewünschten Kriterien ein.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  6. Zum Anzeigen der Datensätze, die gelöscht werden, klicken Sie in der Symbolleiste auf Abfrageansicht [image] . Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie hier ggf. Änderungen durch.

  7. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Datensätze in der Tabelle der "n"-Seite zu löschen.

  8. Wählen Sie die Feldliste aller Tabellen auf der "n"-Seite aus, und drücken Sie die ENTF-TASTE, um sie aus der Abfrage zu entfernen.

  9. Wenn die Abfrage nur noch auf der Primärtabelle basiert und im Entwurfsbereich nur noch das Feld enthalten ist, für das Sie Kriterien festlegen möchten, klicken Sie erneut auf Ausführen [image] . Microsoft Access löscht dann die festgelegten Datensätze aus der Tabelle auf der "1"-Seite.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.


 Löschen von Datensätzen unter Verwendung einer Abfrage, die nur die "1"-Tabelle in einer 1:n-Beziehung enthält

Löschen von Datensätzen unter Verwendung einer Abfrage, die nur die "1"-Tabelle in einer 1:n-Beziehung enthält

Wenn Sie eine Löschabfrage basierend auf der Tabelle auf der "1"-Seite einer 1:n-Beziehung ausführen und dabei für diese Beziehung die Löschweitergabe aktiviert haben, löscht Microsoft Access auch die verknüpften Datensätze aus der Tabelle auf der "n"-Seite. Zum Anzeigen von Informationen dazu, was beim Einsatz einer Abfrage, die Datensätze löscht, unbedingt berücksichtigt werden muss, klicken Sie auf [image] .

  1. Erstellen Sie eine neue Abfrage auf der Basis der Tabelle auf der "1"-Seite, aus der Sie Datensätze löschen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Abfrageentwurfsansicht für Abfragen in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Löschen.

  3. Ziehen Sie das Sternchen (*) aus der Feldliste der Tabelle in den Abfrageentwurfsbereich.

    In der Zelle Löschen unter diesem Feld wird jetzt Von angezeigt, wie in der folgenden Abbildung dargestellt.

  4. Um Kriterien für die zu löschenden Datensätze festzulegen, ziehen Sie die Felder in den Entwurfsbereich, für die Sie Kriterien angeben möchten.

    In der Zelle Löschen unter diesem Feld wird jetzt Bedingung angezeigt, wie in der folgenden Abbildung dargestellt.

    Festlegen von Kriterien zum Löschen von Datensätzen

  5. Geben Sie in der Zelle Kriterien für die Felder, die Sie in den Entwurfsbereich gezogen haben, die gewünschten Kriterien ein.

    Um Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .

  6. Zum Anzeigen der Datensätze, die gelöscht werden, klicken Sie in der Symbolleiste auf Abfrageansicht [image] . Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie ggf. Änderungen durch.

  7. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Datensätze zu löschen.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.


Löschen einer Übersicht

  1. Öffnen Sie die Datenbank.

  2. Führen Sie eine der folgenden Aktionen aus, um das Dialogfeld Übersichts-Manager zu öffnen:
    • Wenn Sie die Übersicht unter Verwendung des Datenbank-Assistenten erstellt haben, klicken Sie in der Eröffnungsübersicht auf Übersichtselemente ändern.

    • Wenn Sie die Übersicht unter Verwendung des Übersichts-Managers erstellt haben, klicken Sie im Menü Extras auf Add-Ins und dann auf Übersichts-Manager.
  3. Klicken Sie im Feld Übersichtsseiten auf die Übersicht, die Sie löschen möchten, und dann auf Löschen.


Löschen einer Registerkarte "Oder" im Fenster "Formularbasierter Filter"

  1. Klicken Sie auf die Registerkarte Oder, die Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Tabstopp löschen.


 Löschen eines Textfeldes oder anderen Steuerelements aus einer Gruppe in einem Formular oder Bericht

Löschen eines Textfeldes oder anderen Steuerelements aus einer Gruppe in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf ein beliebiges Steuerelement in der Gruppe, um die Gruppe zu markieren.

  3. Markieren Sie das Steuerelement, das Sie löschen möchten.

  4. Drücken Sie die ENTF-TASTE.

Anmerkung Die Gruppe ist nach dem Löschen des Steuerelements immer noch vorhanden. Dies ist allerdings nicht der Fall, wenn nur noch ein Steuerelement in der Gruppe bleibt. Wenn eine Gruppe nur über zwei Steuerelemente verfügt und eines davon gelöscht wird, wird damit auch die ganze Gruppe gelöscht.


 Deaktivieren eines Textfeldes oder anderen Steuerelements in der Formularansicht oder Aktivieren von Schreibschutz für die Daten in einem Steuerelement

Deaktivieren eines Textfeldes oder anderen Steuerelements in der Formularansicht oder Aktivieren von Schreibschutz für die Daten in einem Steuerelement

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster zu öffnen.

  3. Führen Sie eine der folgenden Anweisungen oder beide aus:
    • Wenn Sie das Steuerelement vollständig deaktivieren möchten, so dass es abgeblendet ist und nicht den Fokus erhalten kann, setzen Sie für die Eigenschaft Aktiviert die Einstellung Nein.

    • Wenn Sie für die Daten im Steuerelement Lesezugriff, aber keinen Schreibzugriff ermöglichen möchten, setzen Sie für die Eigenschaft Gesperrt die Einstellung Ja. Wenn Sie für die Eigenschaft Aktiviert die Einstellung Nein und für die Eigenschaft Gesperrt die Einstellung Ja setzen, wird das Steuerelement nicht abgeblendet angezeigt, aber es kann den Fokus nicht erhalten.

Anmerkungen

  • Sie können die Eigenschaft Aktiviert zusammen mit der Eigenschaft NachAktualisierung verwenden, wenn Sie ein Steuerelement so lange deaktivieren möchten, bis ein Benutzer Text eingibt oder ein anderes Steuerelement markiert. So können Sie z.B. festlegen, dass eine Befehlsschaltfläche erst nach dem Eingeben von Text in ein anderes Textfeld aktiviert werden soll. Sie können die Eigenschaft NachAktualisierung für das Textfeld verwenden, um eine Ereignisprozedur oder ein Makro aufzurufen, die/das die Befehlsschaltfläche aktiviert.

  • Zum Anzeigen weiterer Informationen zu den Eigenschaften Aktiviert und NachAktualisierung sowie darüber, wie Sie diese zusammen einsetzen, klicken Sie auf [image] .

  • Wenn Sie festlegen möchten, dass ein Steuerelement nicht in der Reihenfolge der Steuerelemente enthalten ist, das Markieren dieses Steuerelements aber dennoch möglich sein soll, setzen Sie für die Eigenschaft InReihenfolge die Einstellung Nein.


 Automatisches Anzeigen aller Felder aus der einer Abfrage zugrunde liegenden Tabelle oder Abfrage

Automatisches Anzeigen aller Felder aus der einer Abfrage zugrunde liegenden Tabelle oder Abfrage

Sie können alle Felder anzeigen, ohne Sie dem Entwurfsbereich hinzufügen zu müssen.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Markieren Sie die Abfrage, indem Sie auf eine beliebige Stelle in der Entwurfsansicht für Abfragen außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  4. Legen Sie für die Eigenschaft AlleFelderausgeben die Einstellung Ja fest.

Anmerkungen

  • Wenn Sie die Datensätze, die die Abfrage ausgibt, durch Festlegen von Kriterien begrenzen möchten, oder wenn Sie im Entwurfsbereich ein berechnetes Feld oder eine Sortierreihenfolge festlegen möchten, müssen Sie die für diese Zwecke erforderlichen Felder zum Entwurfsbereich hinzufügen. Stellen Sie sicher, dass für diese Felder das Kontrollkästchen Anzeigen deaktiviert ist, da diese sonst in den Abfrageergebnissen zweimal angezeigt werden.

  • Sie können die Standardeinstellung für die Eigenschaft AlleFelderAusgeben für alle neuen Abfragen ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Anzeigen einer benutzerdefinierten Feldbeschreibung in der Statusleiste einer Abfrage

Anzeigen einer benutzerdefinierten Feldbeschreibung in der Statusleiste einer Abfrage

Sie können die Feldbeschreibung anpassen, die angezeigt wird, wenn Sie in den Abfrageergebnissen auf ein Feld klicken.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Klicken Sie im Entwurfsbereich auf das Feld, dessen Beschreibung Sie ändern möchten, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Feldes anzuzeigen.

  3. Geben Sie im Einstellungsfeld für die Eigenschaft Beschreibung die Beschreibung ein, die in den Abfrageergebnissen in der Statusleiste für dieses Feld angezeigt werden soll. Die Beschreibung kann maximal 255 Zeichen lang sein.

Die neue Beschreibung wird in der Statusleiste angezeigt, sobald Sie in der Datenblattansicht für Abfragen auf das entsprechende Feld klicken.


 Vermeiden von doppelten Datensätzen in einer Abfrage, die auf Feldern der zugrunde liegenden Tabelle basiert

Vermeiden von doppelten Datensätzen in einer Abfrage, die auf Feldern der zugrunde liegenden Tabelle basiert

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Wählen Sie die Abfrage aus, indem Sie in der Abfrageentwurfsansicht an eine beliebige Stelle außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  4. Setzen Sie die Eigenschaft Eindeutige Datensätze auf Ja.

Anmerkungen

  • Die Eigenschaft Eindeutige Datensätze hat nur dann eine Wirkung, wenn Sie für die Abfrage mehr als eine Tabelle verwenden und Felder aus diesen Tabellen auswählen.

  • Wenn die Eigenschaft Eindeutige Datensätze auf Ja eingerichtet ist, setzt Microsoft Access die Eigenschaft Keine Duplikate automatisch auf Nein.

  • Alternativ zur Einstellung der Eigenschaft Eindeutige Datensätze können Sie dem Designbereich auch ein Feld hinzufügen, das die Datensätze voneinander unterscheidet.


 Verhindern von Duplikatdatensätzen in einer Abfrage basierend auf Feldern im Abfrageentwurfsbereich

Verhindern von Duplikatdatensätzen in einer Abfrage basierend auf Feldern im Abfrageentwurfsbereich

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Markieren Sie die Abfrage, indem Sie auf eine beliebige Stelle in der Entwurfsansicht für Abfragen außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  4. Legen Sie für die Eigenschaft KeineDuplikate die Einstellung Ja fest.

    Wenn die Abfrageergebnisse mehrere Felder enthalten, werden nur Datensätze angezeigt, für die die Kombination der Werte aus allen Feldern eindeutig ist.

  5. Zum Anzeigen der Abfrageergebnisse klicken Sie in der Symbolleiste auf Ansicht [image] .

Anmerkung Wenn für die Eigenschaft KeineDuplikate die Einstellung Ja festgelegt ist, wird für die Eigenschaft EindeutigeDatensätze automatisch die Einstellung Nein festgelegt.


 Standardmäßiges Ein- oder Ausblenden von Systemobjekten im Datenbankfenster

Standardmäßiges Ein- oder Ausblenden von Systemobjekten im Datenbankfenster

Microsoft Access erstellt automatisch Systemobjekte, wenn Sie eine neue Datenbank erstellen.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Ansicht.

  3. Aktivieren oder deaktivieren Sie unter Erweitern das Kontrollkästchen Systemobjekte.


 Erneutes Anwenden eines Filters zum Abfragen der neuesten Datensatzgruppe

Erneutes Anwenden eines Filters zum Abfragen der neuesten Datensatzgruppe

Wenn Sie in einer Mehrbenutzerdatenbank mit gefilterten Daten arbeiten, können Sie den Filter gelegentlich anwenden, wenn Sie feststellen möchten, welche Datensätze seit dem letzten Öffnen des Formulars oder Datenblatts und dem Anwenden des Filters hinzugefügt, gelöscht oder geändert worden sind.

  • Zeigen Sie die gefilterten Datensätze in einem Datenblatt, Unterdatenblatt, Formular oder Unterformular an, und klicken Sie dann im Menü Datensätze auf Filter anwenden.


 Anzeigen eines Meldungsfelds unter Verwendung eines Makros

Anzeigen eines Meldungsfelds unter Verwendung eines Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Klicken Sie in einer leeren Aktionszeile in der Aktionsliste auf Warnmeldung, und geben Sie dann die Argumente für die Aktion an.

  3. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  4. Führen Sie das Makro aus.

    Wie wird's gemacht?

Um weitere Informationen zur Aktion Warnmeldung zu erhalten, klicken Sie auf [image] .


Anzeigen einer Meldung unter Verwendung von Visual Basic

  1. Erstellen Sie eine Visual Basic-Prozedur.

    Wie wird's gemacht?

  2. Fügen Sie der Prozedur eine Zuweisungsanweisung hinzu, die den von der Funktion MsgBox zurückgegebenen Wert einer Variablen zuweist. Die Funktion gibt unterschiedliche Werte zurück, je nachdem, auf welche Schaltfläche der Benutzer oder die Benutzerin im Meldungsfeld klickt. Ihre Prozedur kann dann, basierend auf dem zurückgegebenen Wert, unterschiedliche Operationen durchführen.

    Die folgende Zuweisungsanweisung führt z.B. die Funktion MsgBox aus, die eine Meldung anzeigt, und weist dann den von der Funktion zurückgegebenen Wert der Variablen RückgabeWert zu:

    RückgabeWert = MsgBox("Weiter?", vbOKCancel)

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Um Informationen zur Funktion MsgBox zu erhalten, klicken Sie auf [image] .


 Anzeigen der Tabelle Einfügefehler

Anzeigen der Tabelle Einfügefehler

  1. Klicken Sie im Datenbankfenster einer Microsoft Access-Datenbank unter Objekte auf Tabellen [image] .

  2. Doppelklicken Sie auf Einfügefehler.


 Anzeigen eines Bildes oder eines anderen Objekts in einem Formular oder Bericht als Symbol

Anzeigen eines Bildes oder eines anderen Objekts in einem Formular oder Bericht als Symbol

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Zeigen Sie im Menü Bearbeiten auf den entsprechenden Objekt-Befehl (z.B. auf Worksheet Object für ein Microsoft Excel-Objekt), und klicken Sie dann auf Konvertieren.

  3. Aktivieren Sie im Dialogfeld Konvertieren das Kontrollkästchen Als Symbol.

Anmerkung Das Anzeigen eines Objekts als Symbol spart in der Regel sehr viel Speicherplatz, da in einem solchen Fall der OLE-Server (die Anwendung, die zum Erstellen des Objekts verwendet wurde) das Objekt mit Informationen sendet, die nur aus dem Symbol und nicht aus dem vollständigen Objekt bestehen.


 Anzeigen des Wertes einer Variablen oder eines Ausdrucks im Code-Fenster des Visual Basic-Editors bei unterbrochenem Code

Anzeigen des Wertes einer Variablen oder eines Ausdrucks im Code-Fenster des Visual Basic-Editors bei unterbrochenem Code

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Editor.

  3. Stellen Sie sicher, dass unter Code-Einstellungen das Kontrollkästchen Automatische Daten-Tips aktiviert ist.

Ist Automatische Daten-Tips aktiviert, können Sie den Wert einer Variablen oder eines Ausdrucks überprüfen, solange der Code unterbrochen ist. Setzen Sie den Mauszeiger auf eine Variable oder einen Ausdruck, um ihren/seinen aktuellen Wert anzuzeigen.


 Anzeigen einer Webseite in einem Formular

Anzeigen einer Webseite in einem Formular

Bevor Sie einem Formular das Microsoft Web Browser-Steuerelement hinzufügen können, müssen Sie Microsoft Internet Explorer, Version 3.0 oder höher, installiert haben. Informationen zum Installieren von Microsoft Internet Explorer anzeigen.

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Tool Weitere Steuerelemente ActiveX-Steuerelement .

    Ein Menü wird angezeigt, das alle registrierten ActiveX-Steuerelemente in Ihrem System auflistet.

  3. Klicken Sie im Menü der ActiveX-Steuerelemente auf Microsoft Webbrowser.

  4. Klicken Sie im Formular auf die Stelle, an der Sie das Steuerelement einfügen möchten.

  5. Verschieben Sie das Steuerelement, und ändern Sie seine Größe, falls notwendig.


 Erstellen eines Hyperlinks durch Ziehen einer Internet-Verknüpfung

Erstellen eines Hyperlinks durch Ziehen einer Internet-Verknüpfung

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Wechseln Sie zu einer Internet-Verknüpfung (einem Symbol auf dem Desktop oder einem Element im Ordner VERLAUF des Windows Explorers).

  3. Markieren Sie die Internet-Verknüpfung.

  4. Ziehen Sie die Markierung mit Hilfe der rechten Maustaste auf das Formular oder den Bericht.

    Microsoft Access fügt dem Formular oder Bericht ein Bezeichnungsfeld hinzu. Um die Verknüpfung zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie im Kontextmenü auf Hyperlink, und klicken Sie auf Öffnen.


 Bearbeiten eines gebundenen Bildes oder eines anderen Objekts in einem Formular

Bearbeiten eines gebundenen Bildes oder eines anderen Objekts in einem Formular

  1. Öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt).

  2. Gehen Sie zu dem Datensatz, der das zu bearbeitende Objekt enthält.

  3. Doppelklicken Sie auf das Objekt.

    Microsoft Access öffnet die Anwendung, in der das Objekt erstellt wurde (die OLE-Server-Anwendung), sofern diese verfügbar ist. Die Anwendung wird möglicherweise in einem separaten Fenster geöffnet, oder Sie können das Objekt an Ort und Stelle bearbeiten (direkte Bearbeitung).

    Anmerkung Wenn Sie auf ein Klang- oder ein Videoobjekt doppelklicken, führt Microsoft Access das Objekt aus. Um diese Objekttypen zum Bearbeiten zu öffnen, klicken Sie auf das Objekt und dann im Menü Bearbeiten auf den entsprechenden Objekt-Befehl. Zeigen Sie z.B. auf den Befehl Medien-Clip-Objekt und dann im Untermenü auf einen der Befehle Öffnen oder Bearbeiten.

  4. Führen Sie die gewünschten Änderungen und dann einen der folgenden Schritte aus:
    • Wenn Sie das Objekt direkt bearbeiten, klicken Sie außerhalb des gebundenen Objektfelds. Wenn Sie versehentlich im Menü Datei auf Beenden klicken, wird Microsoft Access beendet.

    • Wenn Sie das Objekt in einem separaten Fenster bearbeiten, klicken Sie im Menü Datei dieser OLE-Server-Anwendung auf Beenden. Klicken Sie auf OK, wenn Sie aufgefordert werden, das Dokument zu aktualisieren.

Anmerkungen

  • Zum Bearbeiten eines Objekt in einem gebundenen Objektfeld muss für die Eigenschaft Aktiviert für dieses Objektfeld die Einstellung Ja und für die Eigenschaft Gesperrt die Einstellung Nein festgelegt sein.

  • Sie können festlegen, welche Aktion ausgeführt werden soll, wenn Sie auf ein Objekt doppelklicken. Dazu stellen Sie für das gebundene Objekt die Eigenschaften Verb und Objektaktivierung ein. Sie können z.B. festlegen, ob Sie das Objekt, anstatt es direkt zu bearbeiten, lieber in einem separaten Fenster öffnen möchten. Zum Anzeigen von Informationen zur Eigenschaft Verb klicken Sie auf [image] . Um Informationen zur Eigenschaft Objektaktivierung anzuzeigen, klicken Sie auf [image] .


 Bearbeiten eines ungebundenen Bildes oder eines anderen Objekts in einem Formular oder Bericht

Bearbeiten eines ungebundenen Bildes oder eines anderen Objekts in einem Formular oder Bericht

  1. Öffnen Sie das Formular in der Formularentwurfsansicht oder den Bericht in der Berichtsentwurfsansicht.

  2. Doppelklicken Sie auf das Objekt.

  3. Microsoft Access öffnet die Anwendung, in der das Objekt erstellt wurde (die OLE-Server-Anwendung), sofern diese verfügbar ist.

    Anmerkung Wenn Sie auf ein Klang- oder ein Videoobjekt doppelklicken, führt Microsoft Access das Objekt aus. Um diese Objekte zum Bearbeiten zu öffnen, klicken Sie auf das Objekt und dann im Menü Bearbeiten auf den entsprechenden Objekt-Befehl. Zeigen Sie z.B. auf den Befehl Medien-Clip-Objekt und dann im Untermenü auf einen der Befehle Öffnen oder Bearbeiten.

  4. Nehmen Sie die gewünschten Änderungen vor, und gehen Sie dann nach einer der folgenden Methoden vor:
    • Wenn Sie das Objekt an dieser Stelle bearbeiten möchten, klicken Sie außerhalb des ungebundenen Objektfeldes auf das Formular. Wenn Sie im Menü Datei auf Beenden klicken, wird damit Microsoft Access beendet.

    • Wenn Sie das Objekt in einem eigenen Fenster bearbeiten, klicken Sie in der OLE-Serveranwendung im Menü Datei auf Beenden. Klicken Sie auf OK, wenn Sie aufgefordert werden, das Dokument zu aktualisieren.

Anmerkungen

  • In den meisten Fällen möchten Sie ein ungebundenes Objekt direkt in der Entwurfsansicht eines Formulars oder Berichts bearbeiten. Wenn Sie das Objekt jedoch auch in der Formularansicht bearbeiten möchten, legen Sie für das Objektfeld für die Eigenschaft Aktiviert (Enabled) die Einstellung Ja und für die Eigenschaft Gesperrt (Locked) die Einstellung Nein fest.

  • Dieses Verfahren gilt nur für Bilder in Objektfeldern, nicht für Bild-Steuerelemente. Ein Bild in einem Bild-Steuerelement hat keine Verbindung zur Quellanwendung, in der es erstellt wurde.


 Einfügen eines vorhandenen gebundenen Objekts in ein Formular

Einfügen eines vorhandenen gebundenen Objekts in ein Formular

  1. Erstellen Sie in einem Formular ein gebundenes Objektfeld.

    Wie wird's gemacht?

  2. Wechseln Sie zur Formularansicht oder zur Datenblattansicht.

  3. Gehen Sie zu dem Datensatz, in den Sie das Objekt einfügen möchten, und klicken Sie in einer Microsoft Access-Datenbank (.mdb) auf das Feld vom Datentyp OLE-Objekt oder in einem Microsoft Access-Projekt (.adp) auf die Image-Spalte.

  4. Klicken Sie im Menü Einfügen auf Objekt.

  5. Klicken Sie im Dialogfeld Objekt einfügen auf Aus Datei erstellen, und geben Sie dann den Pfad für die Datei an. Klicken Sie auf Durchsuchen, wenn Sie den Pfad nicht kennen.

  6. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z.B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  7. Klicken Sie auf OK.

    Wenn Sie sich in der Formularansicht befinden, zeigt Microsoft Access das Objekt an. In der Datenblattansicht zeigt Microsoft Access den Namen des Objekts an, z.B. Bitmap.

  8. Doppelklicken Sie auf das Objekt, wenn Sie es bearbeiten möchten.

Anmerkungen

  • Wenn die Anwendung, aus der Sie kopieren, OLE-Drag & Drop-Bearbeitung unterstützt, können Sie die Datei direkt aus dem Windows Explorer oder vom Desktop ziehen, anstatt den Befehl Objekt zu verwenden.

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Sie können ein gebundenes Objekt auch in eine Tabelle oder in das Datenblatt einer Abfrage einfügen. Dazu markieren Sie einfach das Feld, in das Sie das Objekt einfügen möchten (dies muss ein Feld vom Datentyp OLE-Objekt oder eine Bildspalte sein) und führen dann die Schritte 4 bis 7 aus. Zum Anzeigen des Objekts müssen Sie in einem Formular oder Bericht ein gebundenes Objektfeld erstellen.


 Einfügen eines vorhandenen ungebundenen Objekts in ein Formular oder einen Bericht

Einfügen eines vorhandenen ungebundenen Objekts in ein Formular oder einen Bericht

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder einen Bericht in der Berichts-Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Objektfeld [image] .

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Objekt einfügen möchten.

  4. Klicken Sie im Dialogfeld Objekt einfügen auf Aus Datei erstellen, und geben Sie dann einen Pfad für die Datei an. Klicken Sie auf Durchsuchen, wenn Sie den Pfadnamen nicht kennen.

  5. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z.B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  6. Klicken Sie auf OK.

Microsoft Access erstellt ein Objektfeld und zeigt das Objekt im Rahmen an. Wenn Sie das Objekt bearbeiten möchten, doppelklicken Sie darauf.

Anmerkungen

  • Wenn die Anwendung, aus der Sie kopieren, OLE-Drag & Drop-Bearbeitung unterstützt, können Sie die Datei direkt aus dem Windows Explorer oder vom Desktop ziehen, anstatt das Objektfeld-Steuerelement zu verwenden.

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • In vielen Fällen möchten Sie ein ungebundenes Objekt in der Formular-Entwurfsansicht bzw. der Berichts-Entwurfsansicht bearbeiten. Wenn Sie das Objekt in der Formularansicht bearbeiten möchten, legen Sie für das Objektfeld für die Eigenschaft Aktiviert die Einstellung Ja und für die Eigenschaft Gesperrt die Einstellung Nein fest.


 Einfügen eines Teils eines vorhandenen gebundenen Objekts in ein Formular

Einfügen eines Teils eines vorhandenen gebundenen Objekts in ein Formular

Mit den nachfolgenden Schritten können Sie Teile eines vorhandenen Dokuments kopieren, wenn die Anwendung, aus der Sie kopieren, OLE unterstützt.

  1. Erstellen Sie in einem Formular ein gebundenes Objektfeld.

    Wie wird's gemacht?

  2. Wechseln Sie zu der Anwendung, in der das Objekt erstellt wurde, und markieren Sie die Informationen, die Sie einfügen möchten. Öffnen Sie z. B. Microsoft Excel, und markieren Sie einen Zellbereich.

  3. Klicken Sie im Menü Bearbeiten auf Kopieren.

  4. Wechseln Sie zurück zu Microsoft Access, gehen Sie zur Formularansicht oder zur Datenblattansicht und dann zu dem Datensatz, in den Sie das Objekt einfügen möchten. Klicken Sie dann in einer Microsoft Access-Datenbank (.mdb) auf das Feld vom Datentyp OLE-Objekt oder in einem Microsoft Access-Projekt (.adp) auf die Image-Spalte.

  5. Klicken Sie in der Symbolleiste auf Einfügen [image] .

    Anmerkung Wenn Sie das Objekt als Symbol anzeigen oder den Objekttyp festlegen möchten, unter dem Sie das Objekt ablegen möchten, klicken Sie im Menü Bearbeiten auf Inhalte einfügen. Zum Anzeigen von Informationen zum Befehl Inhalte einfügen klicken Sie auf [image] .

    Wenn Sie sich in der Formularansicht befinden, zeigt Microsoft Access das Objekt an. In der Datenblattansicht zeigt Microsoft Access den Namen des Objekts an, z. B. Microsoft Excel-Tabelle.

  6. Doppelklicken Sie auf das Objekt, wenn Sie es bearbeiten möchten.

Anmerkungen

  • Wenn die Anwendung, aus der Sie kopieren, Drag & Drop-Bearbeitung für OLE unterstützt, können Sie die markierten Informationen aus dieser Anwendung in der Formularansicht in das Feld ziehen.

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Sie können ein gebundenes Objekt auch in das Datenblatt einer Tabelle oder Abfrage einfügen. Dazu markieren Sie einfach das Feld, in das Sie das Objekt einfügen möchten (dies muss ein Feld vom Datentyp OLE-Objekt oder eine Bildspalte sein) und klicken dann in der Symbolleiste auf Einfügen [image] . Zum Anzeigen des Objekts müssen Sie in einem Formular oder Bericht ein gebundenes Objektfeld erstellen.


 Einfügen eines Teils eines vorhandenen ungebundenen Objekts in ein Formular oder einen Bericht

Einfügen eines Teils eines vorhandenen ungebundenen Objekts in ein Formular oder einen Bericht

Mit den nachfolgenden Schritten können Sie Teile eines vorhandenen Dokuments kopieren, wenn die Anwendung, aus der Sie kopieren, OLE unterstützt.

  1. Öffnen Sie die Datei in der Anwendung, in der Sie erstellt wurde, und markieren Sie die Informationen, die Sie einfügen möchten. Öffnen Sie z. B. Microsoft Excel, und markieren Sie einen Zellbereich.

  2. Klicken Sie im Menü Bearbeiten auf Kopieren.

  3. Wechseln Sie zu Microsoft Access.

  4. Klicken Sie in der Formular-Entwurfsansicht oder der Berichts-Entwurfsansicht in der Symbolleiste auf Einfügen [image] .

Microsoft Access erstellt ein Objektfeld und zeigt das Objekt im Rahmen an. Wenn Sie das Objekt bearbeiten möchten, doppelklicken Sie darauf.

Anmerkung Wenn Sie das Objekt als Symbol anzeigen oder den Objekttyp festlegen möchten, unter dem das Objekt abgelegt werden soll, klicken Sie im Menü Bearbeiten auf Inhalte einfügen. Zum Anzeigen von Informationen zum Befehl Inhalte einfügen klicken Sie auf [image] .

Anmerkungen

  • Wenn die Anwendung, aus der Sie kopieren, OLE-Drag & Drop-Bearbeitung unterstützt, können Sie markierte Informationen aus dieser Anwendung in die Entwurfsansicht eines Microsoft Access-Formulars oder Berichts ziehen. In diesem Fall erstellt Microsoft Access ein Objektfeld und fügt die markierten Informationen in den Rahmen ein.

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • In vielen Fällen möchten Sie ein ungebundenes Objekt in der Formular-Entwurfsansicht bzw. der Berichts-Entwurfsansicht bearbeiten. Wenn Sie das Objekt in der Formularansicht bearbeiten möchten, legen Sie für das Objektfeld für die Eigenschaft Aktiviert die Einstellung Ja und für die Eigenschaft Gesperrt die Einstellung Nein fest.


 Aufbereiten einer in einer früheren Version erstellten Datenbank in Microsoft Access 2000

Aufbereiten einer in einer früheren Version erstellten Datenbank in Microsoft Access 2000

  1. Klicken Sie in der Symbolleiste auf Datenbank öffnen [image] .

  2. Klicken Sie auf die Access-Datenbank der früheren Version, die Sie aufbereiten möchten, und dann auf Öffnen.

  3. Klicken Sie im Dialogfeld Datenbank konvertieren/öffnen auf Datenbank öffnen.

In Microsoft Access 2000 wird die Datenbank der früheren Version aufbereitet, ohne permanente Änderungen an dieser Datenbank vorzunehmen. Eine aufbereitete Datenbank kann weiterhin in der Version von Microsoft Access geöffnet werden, in der sie erstellt worden ist.

Anmerkung Sie können eine geschützte Datenbank aktivieren.


 Stellen zur Angabe von Kriterien, um zu bestimmen, wann Berechnungen durchgeführt werden

Stellen zur Angabe von Kriterien, um zu bestimmen, wann Berechnungen durchgeführt werden

Die Stelle im Abfrage-Entwurfsbereich, an der Sie Kriterien angeben, bestimmt, wann die Berechnung durchgeführt wird.

Anmerkung Zwar zeigen die folgenden Beispiele lediglich Abfragen, die Aggregatfunktionen berechnen, diese Hinweise gelten jedoch gleichermaßen für berechnete Felder.

  • Um Gruppierungen vor der Durchführung von Berechnungen an Datensatzgruppen einzuschränken, geben Sie die Kriterien in den Feldern Gruppierung ein.

    Festlegen von Gruppierungskriterien, die bei der Durchführung von Berechnungen berücksichtigt werden

  • Damit nach durchgeführter Berechnung nur ausgewählte Ergebnisse zurückgegeben werden, geben Sie die Kriterien in dem Feld an, das die Berechnung enthält. Diese Regel gilt unabhängig davon, ob Sie die Berechnung für einzelne Datensätze, Gruppen von Datensätzen oder sämtliche Datensätze durchführen.

    Durchführen von Berechnungen mit anschließender Rückgabe ausgewählter Resultate

  • Um die Datensätze einzugrenzen, bevor sie gruppiert werden und bevor die Berechnung durchgeführt wird, fügen Sie in den Entwurfsbereich das Feld ein, dessen Datensätze eingeschränkt werden sollen, und geben Sie die Kriterien in die Zelle Kriterien des Feldes ein. Falls Sie in der gleichen Abfrage Aggregatfunktionen berechnen, setzen Sie die Zelle Funktion für das Feld, das die Kriterien enthält, auf Bedingung. Diese Regel gilt unabhängig davon, ob Sie die Berechnung für einzelne Datensätze, Gruppen von Datensätzen oder sämtliche Datensätze durchführen. (Microsoft Access deaktiviert automatisch das Kontrollkästchen Erweitern.)

    Im folgenden Beispiel wird das Feld Endpreis erweitert zweimal verwendet, einerseits zur Einschränkung der Datensätze und andererseits zur Berechnung der Aggregatfunktion. Sie können die Datensätze jedoch auch mit einem anderen Feld einschränken, indem Sie dieses Feld in den Entwurfsbereich ziehen und dessen Zelle Funktion auf Bedingung setzen.

    Einschränken der Datensätze und Berechnen der Aggregatfunktion unter Verwendung des gleichen Feldes

Anmerkung Um Beispiele für Kriterienausdrücke anzuzeigen, klicken Sie auf [image] .


Eingeben eines Hyperlinks durch Einfügen des Hyperlinks oder der Hyperlinkadresse in eine Datenzugriffsseite

  1. Wechseln Sie zu einem Hyperlink oder zu einer Hyperlinkadresse. Gehen Sie dazu nach einer der folgenden Methoden vor:
    • Öffnen Sie das Dokument, das den Hyperlink oder die Hyperlinkadresse enthält.

    • Wechseln Sie in einem Webbrowser, wie z. B. Microsoft Internet Explorer, zu der Seite, die den Hyperlink oder die Hyperlinkadresse enthält.
  2. Gehen Sie nach der der folgenden Methoden vor:
    • Markieren Sie in dem Dokument den definierten Hyperlink oder die Hyperlinkadresse, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

    • Markieren Sie im Webbrowser die Adresse im Feld Adresse, oder markieren Sie eine gültige Hyperlinkadresse auf einer beliebigen Stelle auf einer Seite. Klicken Sie mit der rechten Maustaste auf die Markierung, und klicken Sie dann im Kontextmenü auf Kopieren oder Verknüpfung kopieren.
  3. Öffnen Sie im Webbrowser eine Datenzugriffsseite.

  4. Platzieren Sie die Einfügemarke in dem Textfeld, in dem Hyperlinks für die Seite zulässig sind.

  5. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Auf einer Datenzugriffsseite wird das Textfeld, in das Sie eine Hyperlinkadresse enigeben, nicht automatisch als Hyperlink formatiert. Prüfen Sie, ob die Adresse an einer anderen Stelle auf der Seite als Hyperlink formatiert ist.

Tipp Klicken Sie auf der Symbolleiste von Internet Explorer auf die Schaltfläche Aktualisieren, um zu prüfen, ob die Hyperlinkadresse als formatierter Hyperlink angezeigt wird.


 Eingeben eines Hyperlinks in der Formular- oder Datenblattansicht, der eine E-Mail-Nachricht erstellt

Eingeben eines Hyperlinks in der Formular- oder Datenblattansicht, der eine E-Mail-Nachricht erstellt

  1. Gehen Sie nach einer der folgenden Methoden vor:
    • Öffnen Sie die Tabelle oder Abfrage einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblatt- oder der Formularansicht.
  2. Platzieren Sie auf dem Datenblatt, in dem Textfeld oder in dem Kombinationsfeld die Einfügemarke in dem Hyperlink-Feld, für das Hyperlinks zulässig sind.

  3. Klicken Sie in der Symbolleiste auf Hyperlink einfügen [image] .

  4. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf E-Mail-Adresse.

  5. Geben Sie in das Feld Text anzeigen als den Text ein, der in dem Feld oder in dem Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die E-Mail-Adresse und den Betreff als Anzeigetext.

  6. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Zeiger über den Hyperlink bewegt wird. Wenn Sie das Feld QuickInfotext leer lassen, dann zeigt Microsoft Access die E-Mail-Adresse und den Betreff als QuickInfo an.

  7. Geben Sie in das Feld E-Mail-Adresse eine E-Mail-Adresse ein. Sie können auch eine Adresse aus der Liste Zuletzt verwendete E-Mail-Adressen auswählen.

  8. Geben Sie in das Feld Betreff den Text ein, der im entsprechenden Feld der E-Mail-Nachricht angezeigt werden soll.

    Anmerkung Einige Webbrowser und E-Mail-Programme erkennen die Betreffzeile nicht.

  9. Klicken Sie auf OK.

    Wenn Sie auf den Hyperlink klicken, öffnet Microsoft Access Ihr E-Mail-Programm und erstellt eine neue Nachricht, bei der bereits die Adresse und die Betreffzeile ausgefüllt sind.


 Eingeben eines Hyperlinks in eine vorhandene Datei oder Webseite mit Hilfe der Schaltfläche "Hyperlink einfügen"

Eingeben eines Hyperlinks in eine vorhandene Datei oder Webseite mit Hilfe der Schaltfläche "Hyperlink einfügen"

  1. Gehen Sie nach einer der folgenden Methoden vor:
    • Öffnen Sie die Tabelle oder Abfrage einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblatt- oder Formularansicht.
  2. Platzieren Sie auf dem Datenblatt, in dem Textfeld oder in dem Kombinationsfeld die Einfügemarke in dem Hyperlink-Feld, für das Hyperlinks zulässig sind.

  3. Klicken Sie auf der Symbolleiste auf Hyperlink einfügen [image] .

  4. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Datei oder Webseite.

  5. Geben Sie in das Feld Text anzeigen als den Anzeigetext für den Hyperlink ein. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die Hyperlinkadresse als Anzeigetext.

  6. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Zeiger über den Hyperlink bewegt wird. Wenn Sie das Feld QuickInfotext leer lassen, dann zeigt Microsoft Access die Hyperlinkadresse als QuickInfo an.

  7. Geben Sie die Datei oder die Webseite an, zu der Sie eine Verbindung herstellen möchten. Gehen Sie dazu nach einer der folgenden Methoden vor:
    • Geben Sie in das Feld Datei oder Webseite einen Pfad oder einen URL ein.

    • Klicken Sie unter Oder aus Liste auswählen auf Zuletzt verwendet, Besuchte Webseiten oder Eingefügte Hyperlinks. Klicken Sie dann auf ein Element in der Liste.

    • Klicken Sie auf Datei, um eine Datei auf Ihrer Festplatte oder im Netzwerk zu suchen.

    • Klicken Sie auf Webseite, um eine Seite im Internet oder auf einem Intranet zu suchen.
  8. Wenn Sie in einer HTML-Datei an eine bestimmte Stelle oder zu einem Objekt gelangen möchten, klicken Sie in einer Microsoft Access-Datenbank (.mdb) oder in einem Microsoft Access-Projekt (.adp) auf Textmarke. Klicken Sie in der Liste auf die gewünschte Textmarke oder das Objekt, und klicken Sie dann auf OK.

  9. Klicken Sie im Dialogfeld Hyperlink einfügen auf OK.

    Microsoft Access fügt den Hyperlink zu dem Feld oder Steuerelement hinzu. Zum Öffnen des Zieldokuments, der Webseite oder des Objekts klicken Sie auf den Hyperlink.


 Gleichzeitiges Erstellen einer neuen Datenzugriffsseite und eines Hyperlinks zu dieser Seite

Gleichzeitiges Erstellen einer neuen Datenzugriffsseite und eines Hyperlinks zu dieser Seite

  1. Gehen Sie nach einer der folgenden Methoden vor:
    • Öffnen Sie die Tabelle oder Abfrage einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblatt- oder der Formularansicht.
  2. Platzieren Sie die Einfügemarke auf dem Datenblatt, in dem Textfeld oder in dem Kombinationsfeld in dem Hyperlink-Feld, für das Hyperlinks zulässig sind.

  3. Klicken Sie auf der Symbolleiste auf Hyperlink einfügen [image] .

  4. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Neue Seite erstellen.

  5. Geben Sie in das Feld Text anzeigen als den Anzeigetext für das Feld oder das Textfeld ein. Wenn Sie das Feld leer lassen, verwendet Microsoft Access die Hyperlinkadresse als Anzeigetext.

  6. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Zeiger über den Hyperlink bewegt wird. Wenn Sie das Feld QuickInfotext leer lassen, dann zeigt Microsoft Access die Hyperlinkadresse als QuickInfo an.

  7. Geben Sie in das Feld Name des neuen Dokuments einen Namen sowie drei Buchstaben für die Dateinamenerweiterung ein, die den Dateityp angibt, den Sie erstellen möchten. Wenn Sie die Erweiterung weglassen oder .htm oder .html eingeben, dann erstellt Microsoft Access eine neue Datenzugriffsseite.

  8. Microsoft Access erstellt das neue Dokument im aktuellen Ordner. Wenn Sie einen anderen Speicherort angeben möchten, klicken Sie auf Ändern.

  9. Wählen Sie unter Zeitpunkt der Bearbeitung eine Option. Sie können das neue Dokument sofort oder aber zu einem späteren Zeitpunkt bearbeiten.

  10. Klicken Sie auf OK.

    Microsoft Access fügt den Hyperlink zu dem Feld oder zu dem Steuerelement hinzu. Klicken Sie zum Öffnen des Zieldokuments auf den Hyperlink.


 Eingeben eines Hyperlinks zu einem Objekt in der aktuellen Datenbank in der Formular- oder Datenblattansicht

Eingeben eines Hyperlinks zu einem Objekt in der aktuellen Datenbank in der Formular- oder Datenblattansicht

  1. Gehen Sie nach einer der folgenden Methoden vor:
    • Öffnen Sie die Tabelle oder Abfrage einer Microsoft Access-Datenbank (.mdb) in der Datenblattansicht.

    • Öffnen Sie das Formular in einer Access-Datenbank oder in einem Microsoft Access-Projekt (.adp) in der Datenblatt- oder in der Formularansicht.
  2. Platzieren Sie die Einfügemarke auf dem Datenblatt, in dem Textfeld oder in dem Kombinationsfeld in dem Hyperlink-Feld, für das Hyperlinks zulässig sind.

  3. Klicken Sie auf der Symbolleiste auf Hyperlink einfügen [image] .

  4. Klicken Sie im Dialogfeld Hyperlink einfügen unter Link zu auf Aktuelle Datenbank.

  5. Geben Sie in das Feld Text anzeigen als den Text ein, der in dem Feld oder in dem Textfeld angezeigt werden soll. Wenn Sie das Feld leer lassen, verwendet Microsoft Access den Objekttyp und -namen als Anzeigetext.

  6. Klicken Sie auf Infofelder, und geben Sie den Text ein, der angezeigt werden soll, wenn der Zeiger über den Hyperlink bewegt wird. Wenn Sie das Feld QuickInfotext leer lassen, dann zeigt Microsoft Access den Objekttyp und -namen als QuickInfo an.

  7. Markieren Sie in der Liste das Datenbankobjekt, für das Sie eine Verknüpfung herstellen möchten.

  8. Klicken Sie auf OK.

    Microsoft Access fügt den Hyperlink zu dem Feld oder Steuerelement hinzu. Zum Öffnen des Zielobjekts klicken Sie auf den Hyperlink.


 In Microsoft Access verfügbare Felddatentypen

In Microsoft Access verfügbare Felddatentypen

In der folgenden Tabelle sind alle in Microsoft Access verfügbaren Felddatentypen sowie deren Verwendung und Speichergröße im Überblick aufgeführt.

Datentyp | Verwendung | Größe
Text | Text oder eine Kombination aus Text und Zahlen, z. B. Adressen. Auch Zahlen, die keine Berechnungen erfordern, z. B. Telefonnummern, Teilenummern oder Postleitzahlen. Um weitere Informationen über das Definieren eines Textfeldes zu erhalten, klicken Sie auf [image] . | Max. 255 Zeichen Microsoft Access speichert nur die in ein Feld eingegebenen Zeichen, nicht aber Leerzeichen für nicht verwendete Stellen in einem Textfeld. Um die maximale Anzahl der Zeichen zu steuern, die eingegeben werden können, legen Sie die Feldgröße-Eigenschaft fest.
Memo | Längerer Text und Zahlen, z. B. Anmerkungen und Beschreibungen. Um weitere Informationen über das Definieren eines Feldes des Typs Memo zu erhalten, klicken Sie auf [image] . | Max. 64.000 Zeichen
Zahl | Numerische Daten für mathematische Berechnungen außer Geldberechnungen (verwenden Sie dazu den Typ "Währung"). Legen Sie die Feldgröße-Eigenschaft fest, um den spezifischen Zahlentyp zu definieren. Um weitere Informationen über das Definieren eines Feldes des Typs Zahl zu erhalten, klicken Sie auf [image] . | 1, 2, 4 oder 8 Byte. 16 Byte nur für Replikations-ID (GUID). Um weitere Informationen über das Ändern von Zahlenfeldgrößen zu erhalten, klicken Sie auf [image] .
Datum/Uhrzeit | Datums- und Zeitangaben Um weitere Informationen über das Definieren eines Feldes des Typs Datum/Uhrzeit zu erhalten, klicken Sie auf [image] . | 8 Byte.
Währung | Währungswerte. Verwenden Sie den Datentyp Währung, um ein Abrunden bei Berechnungen zu verhindern. Auf 15 Stellen links und auf 4 Stellen rechts des Dezimalkommas genau. Um weitere Informationen über das Definieren eines Feldes des Typs Währung zu erhalten, klicken Sie auf [image] . | 8 Byte.
AutoWert | Eindeutige sequenzielle (jeweils um 1 ansteigende) Zahlen oder Zufallszahlen, die beim Hinzufügen eines Datensatzes eingefügt werden. Um weitere Informationen über das Definieren eines Feldes des Typs AutoWert zu erhalten, klicken Sie auf [image] . | 4 Byte. 16 Byte nur für Replikations-ID (GUID).
Ja/Nein | Felder enthalten nur einen von zwei Werten, z. B. Ja/Nein, True/False, Ein/Aus. Um weitere Informationen über das Definieren eines Ja/Nein-Feldes zu erhalten, klicken Sie auf [image] . | 1 Bit.
OLE-Objekt | Unter Verwendung des OLE-Protokolls in anderen Programmen erstellte Objekte (z. B. Microsoft Word-Dokumente, Microsoft Excel-Tabellenblätter, Bilder, Klänge oder andere Binärdaten), die in einer Microsoft Access-Tabelle verknüpft oder eingebettet werden können. Sie müssen ein gebundenes Objektfeld in einem Formular oder Bericht verwenden, um das OLE-Objekt anzuzeigen. Um weitere Informationen über das Definieren eines Feldes des Typs OLE-Objekt zu erhalten, klicken Sie auf [image] . | Bis zu 1 GB (begrenzt durch Festplattenkapazität).
Hyperlink | Ein Feld, das Hyperlinks speichert. Ein Hyperlink kann ein UNC-Pfad oder ein URL sein. Um weitere Informationen über das Definieren eines Feldes des Typs Hyperlink zu erhalten, klicken Sie auf [image] . | Max. 64.000 Zeichen
Nachschlage-Assistent | Erstellt ein Feld, das Ihnen die Auswahl eines Wertes aus einer anderen Tabelle oder aus einer Werteliste mit Hilfe eines Kombinationsfeldes ermöglicht. Durch Auswählen dieser Option in der Datentypliste wird ein Assistent gestartet, der dieses Feld für Sie erstellt. Um weitere Informationen über das Definieren eines Nachschlagefeldes zu erhalten, klicken Sie auf [image] . | Gleiche Größe wie das Feld "Primärschlüssel", das auch das Nachschlagefeld ist; normalerweise 4 Byte.

Anmerkung Die Datentypen Zahl, Datum/Uhrzeit, Währung und Ja/Nein liefern vordefinierte Anzeigeformate. Legen Sie die Format-Eigenschaft fest, um aus den für jeden Datentyp verfügbaren Formaten auszuwählen. Sie können auch für alle Datentypen ein benutzerdefiniertes Anzeigeformat erstellen, außer für den Datentyp OLE-Obejkt. Um Informationen über das Definieren eines benutzerdefinierten Anzeigeformats zu erhalten, klicken Sie auf [image] .


Erstellen eines Listen- oder Kombinationsfelds in einem Formular, das seine Einträge von einer Funktion erhält

Dieses Verfahren ist dann sinnvoll, wenn sich die Werte einer Liste ständig ändern oder wenn die Werte nicht in einer Datenbank gespeichert werden. Sie können z. B. eine Funktion schreiben, die in ein Listenfeld eine Liste mit Datumsangaben einfügt, wobei jedes Datum in einer bestimmten Anzahl von Tagen auf das aktuelle Datum folgt.

  1. Erstellen Sie die Funktion. Um Informationen zum Erstellen der Funktion anzuzeigen, klicken Sie auf [image] .

  2. Erstellen Sie das Listen- oder Kombinationsfeld, und öffnen Sie sein Eigenschaftenfenster.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Herkunftstyp den Namen der Funktion ein. Setzen Sie kein Gleichheitszeichen vor den Funktionsnamen.

  4. Lassen Sie das Einstellungsfeld der Eigenschaft Datensatzherkunft leer.


 Filtern von Datensätzen unter Verwendung des Fensters "Spezialfilter/-sortierung"

Filtern von Datensätzen unter Verwendung des Fensters "Spezialfilter/-sortierung"

  1. Öffnen Sie eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht oder ein Formular in der Formularansicht.

  2. Klicken Sie in das Datenblatt, Unterdatenblatt, Formular oder Unterformular, das Sie filtern möchten.

  3. Zeigen Sie im Menü Datensätze auf Filter, und klicken Sie dann auf Spezialfilter/-sortierung.

  4. Fügen Sie das/die Feld(er) zum Entwurfsbereich hinzu, das/die Sie zum Festlegen von Werten oder anderen Kriterien, die der Filter zum Abrufen der Datensätze verwenden wird, benötigen.

    Wie wird's gemacht?

  5. Zum Festlegen einer Sortierreihenfolge klicken Sie auf die Zelle Sortierung für ein Feld. Anschließend klicken Sie auf den Pfeil und wählen dann eine Sortierreihenfolge.

    Microsoft Access sortiert zuerst das äußere, linke Feld im Entwurfsbereich, dann das Feld rechts daneben usw.

  6. Geben Sie in der Zelle Kriterien für die Felder, die Sie ausgewählt haben, den Wert ein, nach dem Sie suchen, oder geben Sie einen Ausdruck ein.

    Um weitere Informationen zum Eingeben von Kriterien anzuzeigen, klicken Sie auf [image] .

  7. Klicken Sie zum Anwenden des Filters in der Symbolleiste auf Filter anwenden [image] .

Anmerkungen

  • Wenn Sie eine Tabelle oder ein Formular speichern, speichert Microsoft Access auch die Filter. Sie können die Filter bei Bedarf beim nächsten Öffnen der Tabelle oder des Formulars erneut anwenden.

  • Wenn Sie eine Abfrage speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter, fügt jedoch nicht die Filterkriterien zum Abfragebereich hinzu. Sie können die Filter nach dem Öffnen und Ausführen der Abfrage erneut anwenden.

  • Falls Sie einen Filter für ein Unterdatenblatt oder Unterformular erstellt haben, ist dieser Filter ebenfalls verfügbar, wenn Sie die Tabelle oder das Formular für das Unterdatenblatt bzw. Unterformular separat öffnen.

  • Um Informationen zum Erstellen eines Formulars oder Berichts auf der Basis der gefilterten Daten anzuzeigen, klicken Sie auf [image] .

  • Sie müssen einen Filter nicht vollkommen neu erstellen, sondern können auch eine vorhandene Abfrage als Filter verwenden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Filtern von Datensätzen durch Eingeben von Kriterien direkt in ein Formular oder in ein Datenblatt

Filtern von Datensätzen durch Eingeben von Kriterien direkt in ein Formular oder in ein Datenblatt

  1. Öffnen Sie eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht oder ein Formular in der Formularansicht.

    Um Datensätze in einem Unterdatenblatt zu filtern, klicken Sie zunächst auf das Erweiterungssymbol, um das Unterdatenblatt anzuzeigen.

  2. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie den Feldwert, den die gefilterten Datensätze enthalten sollen, genau angeben möchten, klicken Sie mit der rechten Maustaste auf das Feld in dem Datenblatt, Unterdatenblatt, Formular oder Unterformular, das Sie filtern, und geben dann im Kontextmenü im Feld Filter nach den Wert ein. Um z. B. alle Datensätze abzurufen, die im Feld Ort den Wert London enthalten, geben Sie im Feld Filter nach den Wert London ein.

    • Wenn Sie komplexere Kriterien eingeben möchten, geben Sie den vollständigen Ausdruck unter Verwendung der entsprechenden Kombination aus Bezeichnern, Operatoren, Platzhalterzeichen und Werten ein, um das gewünschte Ergebnis zu erzielen. Um z. B. alle Datensätze abzurufen, in denen das Feld Kontaktperson irgendwo im Titel das Wort "Marketing" enthält, klicken Sie mit der rechten Maustaste auf das Feld Kontaktperson und geben dann im Feld Filter nach den Eintrag *Marketing* ein. Wenn Sie nur die Datensätze für Bestellungen anzeigen möchten, die mehr als 15 Tage nach dem eigentlichen Lieferdatum versendet wurden, geben Sie den Ausdruck [Versanddatum]-[Lieferdatum]>15 ein. (Im letzten Beispiel brauchen Sie nicht mit der rechten Maustaste auf ein bestimmtes Feld zu klicken, um den Ausdruck einzugeben. In einem Datenblatt mit Unterdatenblättern müssen Sie jedoch zunächst in das Blatt klicken, das Sie filtern wollen.)

      Zum Anzeigen von Beispielen zu Kriterienausdrücken klicken Sie auf [image] . Zum Anzeigen von weiteren Informationen zu Platzhalterzeichen klicken Sie auf [image] .

  3. Führen Sie einen der folgenden Schritte aus:
    • Drücken Sie zum Anwenden des Filters und Schließen des Kontextmenüs die EINGABETASTE.

    • Drücken Sie zum Anwenden des Filters und Offenlassen des Kontextmenüs (zum Angeben weiterer Kriterien für das Feld) TAB. Geben Sie neue Kriterien ein, und drücken Sie dann erneut TAB. Wiederholen Sie diese Schritte bis Sie die gewünschten Datensätze erhalten.

Anmerkungen

  • Wenn Sie eine Tabelle oder ein Formular speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter. Sie können die Filter bei Bedarf beim nächsten Öffnen der Tabelle oder des Formulars erneut anwenden.

  • Wenn Sie eine Abfrage speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter, fügt jedoch nicht die Filterkriterien zum Abfragebereich hinzu. Sie können die Filter nach dem Öffnen und Ausführen der Abfrage erneut anwenden.


 Filtern von Datensätzen durch Auswählen von Werten in einem Formular oder Datenblatt

Filtern von Datensätzen durch Auswählen von Werten in einem Formular oder Datenblatt

  1. Suchen Sie in einem Feld, in einem Formular, Datenblatt oder Unterdatenblatt nach einem Auftreten des Wertes, den die Datensätze in den Filterergebnissen enthalten sollen.

  2. Wählen Sie den Wert aus, und klicken Sie dann in der Symbolleiste auf Auswahlbasierter Filter [image] . Die Art der Auswahl des Wertes bestimmt, welche Datensätze der Filter ausgibt. Um weitere Informationen zum Auswählen von Werten anzuzeigen, klicken Sie auf [image] .

    Wiederholen Sie Schritt 2, bis Sie die gewünschte Datensatzgruppe festgelegt haben.

Anmerkungen

  • Wenn Sie eine Tabelle oder ein Formular speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter. Sie können die Filter bei Bedarf beim nächsten Öffnen der Tabelle oder des Formulars erneut anwenden.

  • Wenn Sie eine Abfrage speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter, fügt jedoch nicht die Filterkriterien zum Abfragebereich hinzu. Sie können die Filter nach dem Öffnen und Ausführen der Abfrage erneut anwenden.

  • Falls Sie einen Filter für ein Unterdatenblatt oder Unterformular erstellt haben, ist dieser Filter ebenfalls verfügbar, wenn Sie die Tabelle oder das Formular für das Unterdatenblatt bzw. Unterformular separat öffnen.

  • Sie können auch Datensätze herausfiltern, die einen bestimmten Wert nicht enthalten. Dazu klicken Sie nach dem Auswählen eines Wertes mit der rechten Maustaste auf den Wert und klicken dann auf Auswahlausschließender Filter.

  • Um Informationen zum Erstellen eines Formulars oder Berichts auf der Basis der gefilterten Daten anzuzeigen, klicken Sie auf [image] .


 Filtern von Datensätzen durch Eingeben von Werten in einer leeren Ansicht oder in Ihrem Formular oder Datenblatt

Filtern von Datensätzen durch Eingeben von Werten in einer leeren Ansicht oder in Ihrem Formular oder Datenblatt

  1. Öffnen Sie eine Tabelle, eine Abfrage oder ein Formular in der Datenblattansicht oder ein Formular in der Formularansicht.

    Um Datensätze in einem Unterdatenblatt zu filtern, zeigen Sie zunächst das Unterdatenblatt durch Klicken auf das Erweiterungssymbol an.

  2. Klicken Sie in der Symbolleiste auf Formularbasierter Filter [image] , um zum Fenster Formularbasierter Filter zu wechseln.

    Sie können Kriterien für das Formular, Unterformular, Hauptdatenblatt und jedes Unterdatenblatt angeben, das angezeigt wird. Jedes Unterdatenblatt und jedes Unterformular besitzt seine eigenen Registerkarten Suchen nach und Oder.

  3. Klicken Sie auf das Feld, in dem Sie die Kriterien festlegen möchten, die die Datensätze, die herausgefiltert werden sollen, erfüllen müssen.

  4. Wählen Sie zum Eingeben der Kriterien in das Feld den Wert aus der Liste aus (wenn die Feldliste Feldwerte enthält), oder geben Sie den Wert in das Feld ein.
    • Zum Suchen nach Datensätzen, in denen ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld aktiviert oder deaktiviert ist, klicken Sie auf das Kontrollkästchen oder die Schaltfläche, bis sie wie gewünscht angezeigt wird. Um zu einer neutralen Position zurückzukehren, so dass es nicht als Kriterium zum Filtern von Daten verwendet wird, klicken Sie weiter auf das Kontrollkästchen oder die Schaltfläche, bis diese abgeblendet erscheint.

    • Zum Suchen nach Datensätzen, in denen ein bestimmtes Feld leer oder nicht leer ist, geben Sie IstNull oder IstNichtNull in das Feld ein. (Sie können diese Optionen aus der Liste für Felder vom Datentyp Memo, OLE-Objekt oder Hyperlink sowie für berechnete Felder und Abfragen auswählen.)

    • Zum Suchen nach Datensätzen, die einen Kriterienausdruck verwenden, geben Sie den Ausdruck direkt oder unter Verwendung des Ausdrucks-Generators in das entsprechende Feld ein. Zum Anzeigen von Beispielen für Ausdrücke klicken Sie auf [image] .

      Wenn Sie Werte in mehr als einem Feld angeben, gibt der Filter nur Datensätze aus, die in allen dieser Felder identische Werte enthalten.

  5. Zum Angeben von Alternativwerten, die Datensätze, die in den Filterergebnissen enthalten sein sollen, enthalten können, klicken Sie auf die Registerkarte Oder für das Datenblatt, Unterdatenblatt, Formular oder Unterformular, das Sie filtern, und geben weitere Werte ein.

    Der Filter gibt Datensätze aus, wenn sie alle auf der Registerkarte Suchen nach angegebenen Werte oder alle auf der ersten Registerkarte Oder oder der zweiten Registerkarte Oder angegebenen Werte enthalten.

  6. Klicken Sie in der Symbolleiste auf Filter anwenden [image] .

Anmerkungen

  • Wenn Sie eine Tabelle oder ein Formular speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter. Sie können die Filter bei Bedarf beim nächsten Öffnen der Tabelle oder des Formulars erneut anwenden.

  • Falls Sie einen Filter für ein Unterdatenblatt oder Unterformular erstellt haben, ist dieser Filter ebenfalls verfügbar, wenn Sie die Tabelle oder das Formular für das Unterdatenblatt bzw. Unterformular separat öffnen.

  • Wenn Sie eine Abfrage speichern, speichert Microsoft Access auch die von Ihnen erstellten Filter, fügt jedoch nicht die Filterkriterien zum Abfrageentwurfsbereich hinzu. Sie können die Filter nach dem Öffnen und Ausführen der Abfrage erneut anwenden.

  • Um Informationen zum Erstellen eines Formulars oder Berichts auf der Basis der gefilterten Daten anzuzeigen, klicken Sie auf [image] .


 Suchen nach nicht übereinstimmenden Datensätzen in unterschiedlichen Tabellen unter Verwendung eines Abfrage-Assistenten

Suchen nach nicht übereinstimmenden Datensätzen in unterschiedlichen Tabellen unter Verwendung eines Abfrage-Assistenten

Unter Verwendung des Abfrage-Assistenten zur Inkonsistenzsuche können Sie in einer Tabelle nach Datensätzen suchen, für die es in einer anderen Tabelle keine verknüpften Datensätze gibt. Auf diese Weise können Sie z. B. nach Kunden suchen, für die keine Bestellungen vorliegen.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Abfrage-Assistent zur Inkonsistenzsuche.

  3. Klicken Sie auf OK.

  4. Folgen Sie den Anleitungen, die in den Dialogfeldern des Assistenten angezeigt werden. Im letzten Dialogfeld können Sie wählen, ob Sie die Abfrage ausführen oder die Struktur der Abfrage in der Entwurfsansicht anzeigen möchten.

    Entspricht das Ergebnis der Abfrage nicht genau Ihren Vorstellungen, können Sie den Assistenten erneut ausführen oder die Abfrage in der Entwurfsansicht ändern. Um weitere Informationen zum Ändern einer Abfrage in der Entwurfsansicht anzuzeigen, klicken Sie auf [image] .


 Verwenden eines Makros zum Einfügen eines Seitenwechsels in einem Bericht, wenn eine Bedingung erfüllt ist

Verwenden eines Makros zum Einfügen eines Seitenwechsels in einem Bericht, wenn eine Bedingung erfüllt ist

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf Seitenwechsel [image] , und klicken Sie dann im Berichtsbereich auf die Stelle, an der ein bedingter Seitenwechsel eingefügt werden soll.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , und vergeben Sie dann im Feld Name einen Namen für das Steuerelement, das den Seitenwechsel auslöst.

  4. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  5. Klicken Sie in einer leeren Aktionszeile in der Aktionsliste auf SetzenWert.

  6. Geben Sie für das Argument Feld den Bezeichner für die Visible-Eigenschaft des Steuerelements für Seitenwechsel an. Wenn der Name des Steuerelements z. B. Seitenwechsel lautet, setzen Sie das Argument Feld auf [Seitenwechsel].[Sichtbar].

  7. Setzen Sie das Argument Ausdruck auf Nein.

  8. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  9. Stellen Sie in der Berichts-Entwurfsansicht die OnFormat-Eigenschaft des Seitenkopfbereichs des Berichts auf den Namen des Makros ein.

    Dadurch wird das Steuerelement für Seitenwechsel ausgeblendet, wenn die einzelnen Seiten des Berichts formatiert werden, damit kein Seitenwechsel innerhalb einer Seite erfolgt.

  10. Erstellen Sie ein zweites Makro, das die Visible-Eigenschaft des Steuerelements für Seitenwechsel auf Ja einstellt, wenn ein bedingter Ausdruck erfüllt ist.

Wählen Sie eine Aktion aus, die ausgeführt werden soll, wenn eine Bedingung erfüllt ist, die Sie festlegen

  11. Klicken Sie auf Speichern, um das Makro zu speichern.

  12. Wählen Sie den Bereich aus, in dem der Seitenwechsel platziert worden ist, und geben Sie für die OnFormat-Eigenschaft des Bereichs den Namen des zweiten Makros an. Wenn Sie das vorangehende Beispiel verwenden, um einen Seitenwechsel anzuzeigen, wenn für das Zähler-Steuerelement im Detailbereich 10 eingetragen ist, stellen Sie die OnFormat-Eigenschaft im Detailbereich auf den Namen des zweiten Makros ein.

Wenn die Bedingung erfüllt ist, wird der Seitenwechsel eingefügt. Daraufhin blendet das Makro, das dem Seitenkopf zugeordnet ist, das Steuerelement für Seitenwechsel solange aus, bis die Bedingung erneut erfüllt ist.


 Verwenden von Visual Basic zum Erzwingen eines Seitenwechsels in einem Bericht, wenn eine bestimmte Bedingung erfüllt ist

Verwenden von Visual Basic zum Erzwingen eines Seitenwechsels in einem Bericht, wenn eine bestimmte Bedingung erfüllt ist

  1. Öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf Seitenwechsel [image] und dann auf den Berichtsbereich, in dem der bedingte Seitenwechsel hinzugefügt werden soll.

  3. Öffnen Sie die Seitenkopf_Format-Ereignisprozedur des Berichts.

    Wie wird's gemacht?

  4. Fügen Sie in der Ereignisprozedur eine Zuweisungsanweisung hinzu, die für die Eigenschaft Sichtbar des Seitenwechselsteuerelements die Einstellung Nein festlegt. Fügen Sie z. B. die folgende Zuweisungsanweisung hinzu, wenn der Name des Steuerelements BedingterSeitenewechsel lautet:
    Me![BedingterSeitenwechsel].Visible = False

    Diese Anweisung blendet das Seitenwechselsteuerelement aus, wenn der Bericht mit der Formatierung der einzelnen Seiten beginnt. Auf diese Weise wird die Seite nicht umbrochen.

  5. Fügen Sie in der Formatereignisprozedur des Bereichs, zu dem Sie den Seitenwechsel hinzugefügt haben, Visual Basic-Code hinzu, der für die Eigenschaft Sichtbar die Einstellung Ja festlegt, wenn eine Bedingung erfüllt ist. Angenommen, Sie möchten im Detailbereich einen Seitenwechsel anzeigen, wenn der Wert des Zählersteurelements 10 lautet, so dass die ersten 10 Datensätze auf der ersten Seite gedruckt werden. Fügen Sie in diesem Fall den folgenden Code zur Detailbereich_Format-Ereignisprozedur hinzu:
    If Me![Zähler] = 10 Then
    Me![BedingterSeitenwechsel].Visible = True
End If

Wenn die Bedingung erfüllt ist, wird ein Seitenwechsel hinzugefügt. Nach dem Seitenwechsel blendet die Ereignisprozedur, die dem Seitenkopf zugewiesen ist, das Seitenwechsel-Steuerelement so lange aus, bis die Bedingung erneut erfüllt ist.


Anzeigen von Informationen zur Microsoft Outlook-Installation

  1. Starten Sie Microsoft Outlook.

  2. Klicken Sie im Menü ? auf Info über Microsoft Outlook.

  3. Klicken Sie auf Sicherheitsinfo.

Jetzt werden am oberen Rand Informationen bei einer Firmen-, Arbeitsgruppen- oder Nur Internet-Mail-Installation angezeigt.


 Gruppieren von Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

Gruppieren von Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Wählen Sie die Steuerelemente aus, die Sie zu einer Gruppierung hinzufügen möchten. Auswählen benachbarter Steuerelemente. Auswählen nicht benachbarter oder überlappender Steuerelemente.

  3. Klicken Sie im Menü Format auf Gruppierung.

Anmerkung Zum Erstellen einer Gruppierung müssen Sie mehr als ein Steuerelement auswählen.


 Gruppieren von Datensätzen nach den ersten n Zeichen in einem Textwert auf einer Datenzugriffsseite

Gruppieren von Datensätzen nach den ersten n Zeichen in einem Textwert auf einer Datenzugriffsseite

Informationen zum Gruppieren von Datensätzen nach den ersten n Zeichen (oder Anfangszeichen).

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Erstellen Sie eine gruppierte Datenzugriffsseite.

  3. Stellen Sie sicher, dass an das Feld, das Sie zum Gruppieren nach Anfangszeichen verwenden möchten, zwei Steuerelemente gebunden sind.

  4. Stellen Sie sicher, dass das Steuerelement, das Sie verwenden möchten, um nach Anfangszeichen zu gruppieren, ausgewählt ist.

  5. Klicken Sie in der Symbolleiste auf Höher stufen [image] .

    Microsoft Access fügt einen Gruppenkopf hinzu, der ein Steuerelement zum Einblenden enthält, und einen Datensatznavigationsbereich, der ein Datensatznavigationssteuerelement enthält. Access verschiebt das Steuerelement, das Sie zur Gruppe hinzugefügt haben, in den Gruppenkopf.

  6. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Feld Sortieren und gruppieren anzuzeigen.

  7. Klicken Sie auf die Gruppendatensatzquelle, die Sie nach Anfangszeichen gruppieren möchten.

  8. Stellen Sie die folgenden Eigenschaften ein:
    • Legen Sie für GruppierenNach die Einstellung Anfangszeichen fest.

    • Legen Sie für Intervall die Anzahl der Zeichen fest, über die Sie gruppieren möchten.
  9. Legen Sie die Standardsortierreihenfolge für die anderen Gruppierungsebenen auf der Seite fest.

Anmerkung Wenn Sie über ein Steuerelement gruppieren, erstellt Access für das Steuerelement einen Alias. Dazu wird in der Eigenschaft ControlSource zum Namen des Steuerelements das Präfix "GruppierungVon" hinzugefügt. Z. B.: GruppierungVonArtikel: Artikel. Wenn Sie in einem Ausdruck oder in einer Eigenschaft auf dieses Steuerelement verweisen, müssen Sie den Alias verwenden.


 Gruppieren nach fortlaufenden oder numerischen Werten oder nach Währungsangaben in einem Bericht

Gruppieren nach fortlaufenden oder numerischen Werten oder nach Währungsangaben in einem Bericht

Wenn Sie Datensätze nach einem Feld gruppieren, das Auto-, Währungs- oder numerische Werte speichert, stellen Sie die Eigenschaft GruppierenNach auf einen der in der folgenden Tabelle aufgelisteten Bereiche ein. In einer Microsoft Access-Datenbank (.mdb) speichern Sie Werte mit Autowerten in einem Feld des Typs AutoWert, Währungswerte in einem Feld des Typs Währung und numerische Werte in einem Feld des Typs Zahl. In einem Microsoft Access-Projekt (.adp), speichern Sie Währungswerte in einer Spalte des Typs money oder smallmoney und numerische Werte in einer Spalte des Typs decimal, numeric, int, smallint, tinyint, float oder real. Wenn Sie die Eigenschaft GruppierenNach auf Intervall setzen, können Sie die Eigenschaft Intervall auf eine beliebige Zahl festlegen, sofern diese für die Werte in dem Feld, nach dem Sie gruppieren, gültig ist. Wenn Sie für die Eigenschaft GruppierenNach die Einstellung Jedem Wert festlegen, ist als Einstellung für Intervall nur der Wert 1 möglich.

Einstellung | Gruppierung der Datensätze nach
Jedem Wert | demselben Wert im Feld oder Ausdruck
Intervall | Werten innerhalb eines von Ihnen angegebenen Intervalls

Microsoft Access beginnt Gruppen für Felder des Datentyps AutoWert, Währung und Zahl jeweils mit 0. Wenn Sie z. B. die Eigenschaft GruppierenNach auf Intervall einstellen und die Eigenschaft Intervall wiederum auf 5, gruppiert Microsoft Access die Datensätze wie folgt: 0 bis 4, 5 bis 9, 10 bis 14 usw.

Bericht, der Währungswerte in Intervallen von 100 gruppiert

Die folgende Tabelle listet die Angaben zum Sortieren und gruppieren für diesen Bericht auf. Umsatz in der ersten Zeile der Spalte Feld/Ausdruck des Fensters Sortieren und gruppieren gruppiert die Datensätze in Intervallen von 250. Umsatz in der zweiten Zeile sortiert die Datensätze innerhalb jedes 250 DM-Intervalls nach wachsenden Beträgen.

Feld/ Ausdruck | Sortier- reihenfolge | Gruppen- kopf | Gruppen- fuß | Gruppieren nach | Intervall | Zusammen- halten
Umsatz | Aufsteigend | Nein | Ja | Intervall | 250 | Ganze Gruppe
Umsatz | Aufsteigend | Nein | Nein | Jedem Wert | 1 | Nein

Anmerkung Der Bericht Umsatzsummen nach Anzahl in der Beispieldatenbank Nordwind gruppiert Datensätzen in Intervallen von 1.000. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und anschließend den Bericht Umsatzsummen nach Anzahl in der Entwurfsansicht. Um weitere Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Informationen zum Gruppieren von Datensätzen über Datum- oder Uhrzeitwerte in einem Bericht

Informationen zum Gruppieren von Datensätzen über Datum- oder Uhrzeitwerte in einem Bericht

Wenn Sie Datensätze in einem Feld gruppieren, das Datum- oder Uhrzeitwerte enthält, legen Sie für die Eigenschaft GruppierenNach einen der in der nachstehenden Tabelle aufgeführten Bereiche fest. In einer Microsoft Access-Datenbank (.MDB) speichern Sie Datum- oder Zeitwerte in einem Feld mit einem Datentyp Datum/Uhrzeit. In einem Microsoft Access-Projekt (.ADP) speichern Sie sie in einer Spalte mit einem Datentyp Datetime oder Smalldatetime. Für alle Bereiche außer Jedem Wert können Sie für die Eigenschaft Intervall eine beliebige, für die Werte in dem Feld oder Ausdruck, über das/den Sie gruppieren, gültige Zahl festlegen. Wenn Sie für die Eigenschaft GruppierenNach die Eigenschaft Jedem Wert festlegen, hat die Eigenschaft Intervall den Wert 1.

Einstellung der Eigenschaft "GruppierenNach" | Gruppieren von Datensätzen mit
Jedem Wert | dem gleichen Wert im Feld oder Ausdruck.
Jahr | Datumsangaben im selben Kalenderjahr.
Quartal | Datumsangaben im selben Quartal.
Monat | Datumsangaben im selben Monat.
Woche | Datumsangaben in derselben Woche.
Tag | Datumsangaben am selben Tag.
Stunde | Zeitangaben in derselben Stunde.
Minute | Zeitangaben in derselben Minute.

Bericht, der Datumswerte nach Jahr und Quartal sortiert

Die folgende Tabelle zeigt die wichtigsten Gruppier- und Sortierspezifikationen für diesen Bericht. Versanddatum in der ersten Zeile der Spalte Feld/Ausdruck im Dialogfeld Sortieren und gruppieren sortiert die Datensätze nach Jahr. Versanddatum in der zweiten Zeile gruppiert die Datensätze für jedes Jahr nach Quartal.

Feld/Ausdruck | Sortier- reihenfolge | Gruppenkopf | Gruppenfuß | Gruppieren Nach | Intervall | Zusammenhalte
Versand- datum | Aufsteigend | Ja | Ja | Jahr | 1 | Ganze Gruppe
Versand- Datum | Aufsteigend | Nein | Ja | Quartal | 1 | Nein

Anmerkungen

  • Zum Drucken des Jahres oder Quartals anstatt eines bestimmten Datums verwenden Sie die DatTeil-Funktion oder die Format-Funktion.

  • Zum Zählen der Anzahl der gelieferten Bestellungen verwenden Sie die Anzahl-Funktion.

  • Der Bericht Zusammenfassung der Jahresumsätze in der Beispieldatenbank Nordwind druckt Quartalsergebnisse für jedes Jahr. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind im Unterordner Samples unter Ihrem Office-Ordner. Anschließend öffnen Sie den Bericht Zusammenfassung der Jahresumsätze in der Entwurfsansicht. Zum Anzeigen von Informationen zum Öffnen der Datenbank Nordwind klicken Sie auf [image] .

  • Der Bericht Zusammenfassung der Quartalsumsätze in der Beispieldatenbank Nordwind zeigt Umsätze aus mehreren Jahren, nach Quartal sortiert. Zum Anzeigen dieses Berichts öffnen Sie die Datenbank Nordwind im Unterordner Beispiele unter Ihrem Office-Ordner und dann den Bericht Zusammenfassung der Quartalsumsätze in der Entwurfsansicht.


 Gruppieren von Datensätzen nach Textwerten in einem Bericht

Gruppieren von Datensätzen nach Textwerten in einem Bericht

Wenn Sie Datensätze nach einem Feld gruppieren, das Textwerte speichert, können Sie die Eigenschaft GruppierenNach auf einen der in der folgenden Tabelle aufgelisteten Bereiche einstellen. In einer Microsoft Access-Datenbank(.mdb) speichern Sie Textwerte in einem Feld des Datentyps Text. In einem Microsoft Access-Projekt (.adp) speichern Sie Textwerte in einer Spalte mit dem Datentyp char, varchar, nchar oder nvarchar. Wenn Sie die Eigenschaft GruppierenNach auf Anfangszeichen setzen, können Sie die Eigenschaft Intervall auf eine beliebige Zahl festlegen, sofern diese für den Wert in dem Feld, nach dem Sie gruppieren, gültig ist. Wenn Sie für die Eigenschaft GruppierenNach die Einstellung Jedem Wert festlegen, ist als Einstellung für Intervall nur der Wert 1 möglich.

Einstellung | Gruppieren der Datensätze nach
Jedem Wert | demselben Wert im Feld oder Ausdruck
Anfangszeichen | den ersten n übereinstimmenden Zeichen im Feld oder Ausdruck

Bericht, der alle Datensätze nach dem ersten Buchstaben des Produktnamens gruppiert

Die folgende Tabelle listet die Angaben zum Sortieren und gruppieren für diesen Bericht auf. Artikelname in der ersten Zeile der Spalte Feld/Ausdruck des Fensters Sortieren und gruppieren gruppiert die Datensätze nach dem ersten Buchstaben der Artikelnamen. Artikelname in der zweiten Zeile sortiert die Datensätze alphabetisch nach Artikelnamen.

Feld/ Ausdruck | Sortier- reihenfolge | Gruppen- kopf | Gruppen- fuß | Gruppieren nach | Intervall | Zusammen- halten
Artikelname | Aufsteigend | Ja | Ja | Anfangszeichen | 1 | Ganze Gruppe
Artikelname | Aufsteigend | Nein | Nein | Jedem Wert | 1 | Nein

Anmerkungen

  • Mit Hilfe der Funktion Links können Sie den ersten Buchstaben jeder Gruppe in den Gruppenkopf drucken. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Sie können sich den Bericht Alphabetische Artikelliste in der Beispieldatenbank Nordwind ansehen. Um diesen Bericht anzuzeigen, öffnen Sie die Datenbank Nordwind im Unterordner BEISPIELE Ihres Office-Ordners und anschließend den Bericht Alphabetische Artikelliste in der Entwurfsansicht. Um weitere Informationen zum Öffnen der Datenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Gruppieren von Datensätzen über Intervalle von AutoWerten, Währungswerten oder numerischen Werten auf einer Datenzugriffsseite

Gruppieren von Datensätzen über Intervalle von AutoWerten, Währungswerten oder numerischen Werten auf einer Datenzugriffsseite

Informationen zum Gruppieren von Datensätzen über Intervalle von Währungswerten.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Erstellen Sie eine gruppierte Datenzugriffsseite.

  3. Stellen Sie sicher, dass an das Feld, das Sie zum Gruppieren nach Intervall verwenden möchten, zwei Steuerelemente gebunden sind.

    Sie verwenden das eine Feld zum Gruppieren und das andere zum Anzeigen des tatsächlichen Wertes.

  4. Stellen Sie sicher, dass das Steuerelement, das Sie zum Gruppieren verwenden möchten aktiviert ist.

  5. Klicken Sie in der Symbolleiste auf Höher stufen [image] .

    Microsoft Access fügt einen Gruppenkopf hinzu, der ein Steuerelement zum Einblenden enthält, und einen Datensatznavigationsbereich, der ein Datensatznavigationssteuerelement enthält. Access verschiebt das Steuerelement, das Sie zur Gruppe hinzugefügt haben, in den Gruppenkopf.

  6. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  7. Klicken Sie auf die Gruppendatensatzquelle, die Sie nach Intervall gruppieren möchten.

  8. Legen Sie für die Eigenschaft GruppierenNach die Einstellung Intervall fest.

  9. Legen Sie für die Eigenschaft Intervall eine beliebige für die Werte in dem Feld, über das Sie gruppieren, gültige Zahl fest.

  10. Legen Sie die Standardsortierreihenfolge für die anderen Gruppierungsebenen auf der Seite fest.

Anmerkung Wenn Sie über ein Steuerelement gruppieren, erstellt Microsoft Access für das Steuerelement einen Alias. Dazu wird in der Eigenschaft ControlSource zum Namen des Steuerelements das Präfix "GruppierungVon" hinzugefügt. Z. B.: GruppierungVonBetrag: Betrag. Wenn Sie in einem Ausdruck oder in einer Eigenschaft auf dieses Steuerelement verweisen, müssen Sie den Alias verwenden.


 Gruppieren von Datensätzen über Intervalle von Datums- oder Uhrzeitwerten auf einer Datenzugriffsseite

Gruppieren von Datensätzen über Intervalle von Datums- oder Uhrzeitwerten auf einer Datenzugriffsseite

Informationen zum Gruppieren von Datensätzen nach Monat.

Erstellen des gruppierten Berichts und Festlegen des Gruppierungsintervalls

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Erstellen Sie eine gruppierte Datenzugriffsseite.

  3. Stellen Sie sicher, dass das Steuerelement, das Sie verwenden möchten, um nach Datums- oder Uhrzeitintervall zu gruppieren, ausgewählt ist.

  4. Klicken Sie in der Symbolleiste auf Höher stufen [image] .

    Microsoft Access fügt einen Gruppenkopf hinzu, der ein Steuerelement zum Einblenden enthält, und einen Datensatznavigationsbereich, der ein Datensatznavigationssteuerelement enthält. Access verschiebt auch das Steuerelement, das Sie zur Gruppierung in den Gruppenkopf hinzugefügt haben.

  5. Klicken Sie in der Symbolleiste auf Sortieren und gruppieren [image] , um das Dialogfeld Sortieren und gruppieren anzuzeigen.

  6. Klicken Sie auf die Gruppendatensatzquelle, die Sie nach Datums- oder Uhrzeitintervall gruppieren möchten.

  7. Klicken Sie für die Eigenschaft Gruppieren nach auf einen Wert in der Liste. Sie können Gruppendatensätze über Werte im selben Kalenderjahr, demselben Monat, derselben Woche, demselben Tag, derselben Stunde oder derselben Minute gruppieren.

  8. Legen Sie für die Eigenschaft Intervall eine beliebige für die Werte in dem Feld, über das Sie gruppieren, gültige Zahl fest.

    Wenn Sie z. B. für GruppierenNach die Einstellung Monat festgelegt haben, sind 1, 2, 3, 4 oder 6 gültige Werte für Intervall.

  9. Legen Sie die Standardsortierreihenfolge für die anderen Gruppierungsebenen auf der Seite fest.

Erstellen eines Steuerelementes, das die Feldwerte als Intervall anzeigt

In bestimmten Fällen möchten Sie vielleicht ein Steuerelement erstellen, dass die Werte in dem Feld, über das Sie als Intervall gruppiert haben, in der Seitenansicht oder in Microsoft Internet Explorer anzeigt.

  1. Fügen Sie ein gebundenes HTML-Steuerelement für den Ausdruck hinzu. Dazu klicken Sie in der Toolbox auf Gebundener HTML-Text Gebundener HTML-Text und dann im Gruppenkopf, in dem sich das Steuerelement befindet, das Sie über ein Intervall gruppiert haben.

  2. Stellen Sie sicher, dass das gebundene HTML-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  3. Geben Sie den Alias für den Ausdruck gefolgt von einem Doppelpunkt und dem gewünschten Ausdruck in das Eigenschaftenfeld ControlSource ein. Wenn Sie z. B. über Versanddatum gruppiert haben und für die Eigenschaft Gruppieren Nach die Einstellung Monat und für die Eigenschaft Intervall die Einstellung 1 festgelegt haben, geben Sie den folgenden Ausdruck ein, um die Werte im Feld GruppierungVonVersanddatum als Monatsangabe in drei Buchstaben anzugeben:

    Monat: Format(GruppierungVonVersanddatum, "mmm")

Anmerkung Wenn Sie über ein Steuerelement gruppieren, erstellt Access für das Steuerelement einen Alias. Dazu wird in der Eigenschaft ControlSource zum Namen des Steuerelements das Präfix "GruppierungVon" hinzugefügt. Z. B.: GruppierungVonVersanddatum: Versanddatum. Wenn Sie in einem Ausdruck oder in einer Eigenschaft auf dieses Steuerelement verweisen, müssen Sie den Alias verwenden.

Ausblenden des Steuerelements, über das Sie gruppiert haben

Sie können den Wert im Steuerelement, über das Sie gruppiert haben in der Seitenansicht oder in Microsoft Internet Explorer auch ausblenden.

  1. Stellen Sie sicher, dass das Steuerelement, über das Sie nach Datums- oder Uhrzeitintervall gruppiert haben ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  2. Legen Sie für die Eigenschaft Visible des Steuerelements die Einstellung Hidden fest.


Hilfethema steht nicht zur Verfügung

Das Hilfethema kann nicht angezeigt werden, da die Hilfe oder die Hilfe für Visual Basic für Applikationen nicht gefunden, nicht installiert oder entfernt wurde.

So installieren Sie die Hilfe und die Hilfe für Visual Basic für Applikationen

  1. Doppelklicken Sie in der Microsoft Windows-Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen oder entfernen, und führen Sie dann einen oder beide der folgenden Schritte aus:
    • Erweitern Sie Microsoft Access für Windows in der Liste der Funktionen, und klicken Sie auf das Symbol neben Hilfe, um die Installationsoptionen anzuzeigen.

    • Erweitern Sie Office Tools in der Liste der Funktionen, und klicken Sie dann auf das Symbol neben Visual Basic-Hilfe, um die Installationsoptionen anzuzeigen.
  4. Klicken Sie auf Vom Arbeitsplatz starten oder auf Vom Netzwerk ausführen, und klicken Sie dann auf Update durchführen.

Anmerkung Wenn Sie beim Installieren von Microsoft Access die Installationsoption Benutzerdefiniert verwendet und die Hilfedateien gelöscht haben, um Festplattenplatz zu sparen, müssen Sie das Setup-Programm erneut ausführen und Microsoft Access erneut installieren, um die fehlenden Hilfedateien wiederherzustellen.


 Ein- oder Ausblenden eines Feldes in den Ergebnissen einer Abfrage

Ein- oder Ausblenden eines Feldes in den Ergebnissen einer Abfrage

Sie können dem Entwurfsbereich der Abfrage ein Feld hinzufügen, das Sie zum Festlegen von Kriterien oder einer Sortierreihenfolge verwenden möchten, ohne jedoch die Daten aus diesem Feld in den Ergebnissen der Abfrage anzuzeigen.

  • Aktivieren (Häkchen) oder deaktivieren (leeres Feld) Sie in der Entwurfsansicht für Abfragen im Entwurfsbereich das Feld Anzeigen, um das entsprechende Feld anzuzeigen bzw. auszublenden.

Anmerkungen

  • Wenn Sie basierend auf der Abfrage ein Formular, einen Bericht oder eine Datenzugriffsseite erstellen möchten und für die Eigenschaft Alle Felder ausgeben der Abfrage die Einstellung Nein festgelegt ist, müssen Sie alle Felder anzeigen, für die Sie in dem Formular, dem Bericht oder der Datenzugriffseite gebundene Steuerelemente erstellen möchten.

  • Wenn Sie eine Abfrage schließen, verschiebt Microsoft Access alle ausgeblendeten Felder in die rechten Spalten des Entwurfsbereichs.


 Ein- oder Ausblenden von Warnmeldungen unter Verwendung eines Makros

Ein- oder Ausblenden von Warnmeldungen unter Verwendung eines Makros

  1. Öffnen Sie ein bestehendes Makro im Makrofenster.

    Wie wird's gemacht?

  2. Fügen Sie an der Stelle im Makro, an der Sie die Anzeige von gebundenen Warnmeldungen unterbrechen oder fortsetzen möchten, die Aktion SetWarnings ein.

    Wie wird's gemacht?

  3. Um die Anzeige von Warnmeldungen vorübergehend zu unterbrechen, setzen Sie das Argument Warnmeldungen An auf Nein. Um die Warnmeldungen wieder anzuzeigen, setzen Sie das Argument auf Ja.

  4. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  5. Führen Sie das Makro aus.

    Wie wird's gemacht?

Wenn die Ausführung des Makros beendet ist, wird die Anzeige der Warnmeldungen automatisch fortgesetzt.


 Ein- oder Ausblenden von Warnmeldungen unter Verwendung von Visual Basic

Ein- oder Ausblenden von Warnmeldungen unter Verwendung von Visual Basic

  1. Öffnen Sie eine Funktion oder Sub-Prozedur im Code-Fenster.

  2. Verwenden Sie an der Stelle in der Prozedur, an der Sie die Anzeige von gebundenen Warnmeldungen unterbrechen oder fortsetzen möchten, die Methode SetWarnings, um die SetWarnings-Aktion auszuführen.

    Wie wird's gemacht?

  3. Um die Anzeige von Warnmeldungen vorübergehend zu unterbrechen, setzen Sie das Argument Warnmeldungen An auf False. Um die Warnmeldungen wieder anzuzeigen, setzen Sie das Argument auf True.

  4. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Wenn die Ausführung des Codes beendet ist, wird die Anzeige der Warnmeldungen automatisch fortgesetzt.

Um weitere Informationen über die Methode SetWarnings zu erhalten, klicken Sie auf [image] .


 Es erscheint eine Meldung bei dem Versuch, Daten in der Seitenansicht einzugeben.

Es erscheint eine Meldung bei dem Versuch, Daten in der Seitenansicht einzugeben.

Wenn Sie versuchen, ein Feld nach dem Ändern von Daten zu verlassen, überprüft Microsoft Access die Daten, um sicherzustellen, dass der eingegebene Wert in diesem Feld zulässig ist. Ist der Wert nicht erlaubt, zeigt Microsoft Access eine Warnmeldung an. Um das Feld verlassen zu können, müssen Sie entweder die Daten in einen gültigen Wert ändern oder Ihre Änderungen rückgängig machen.

Ein Wert kann aus folgenden Gründen in einem Feld nicht zulässig sein:

  • Der Wert ist nicht kompatibel zum Datentyp des Feldes. Wenn Sie einen Wert eingeben, der nicht mit dem Datentyp übereinstimmt, versucht Microsoft Access, den Eintrag in den korrekten Datentyp umzuwandeln. Es gibt jedoch Daten, die nicht in andere Datentypen umgewandelt werden können. So können z. B. keinen Namen in einem Feld vom Datentyp Zahl in einer Microsoft Access-Datenbank oder in einem Feld vom Datentyp Smallint in einem Microsoft Access-Projekt speichern.

  • Die Daten verletzen eine der Regeln in der Eigenschaft Gültigkeitsregel (ValidationRule) des Feldes.

  • In das Feld müssen Daten eingegeben werden. Sie haben jedoch versucht, es leer zu lassen.

  • Das für die Eigenschaft VorAktualisierung (BeforeUpdate) angegebene Gültigkeitsmakro hat die Aktualisierung abgebrochen.

Microsoft Access führt auch eine Überprüfung der Daten durch, wenn Sie einen ganzen Datensatz verlassen. Bevor ein Datensatz gespeichert wird, stellt Microsoft Access sicher, dass keine der Gültigkeitsregeln in der Eigenschaft Gültigkeitsregel des Datensatzes verletzt wird. Wenn die Tabelle, die Sie gerade bearbeiten, einen Primärschlüssel oder einen eindeutigen Index besitzt, achtet Microsoft Access auch darauf, dass der Wert des Feldes bzw. der Felder im gerade bearbeiteteten Datensatz nicht mit dem eines anderen Datensatzes der Tabelle identisch ist. Wenn der Datensatz nicht gespeichert werden kann, müssen Sie entweder die notwendigen Korrekturen vornehmen oder auf Rückgängig: Datensatz [image] klicken.


 Die Meldung "Zu wenige Parameter. Erwartet:" wird angezeigt

Die Meldung "Zu wenige Parameter. Erwartet:" wird angezeigt

Diese Meldung wird unter Umständen angezeigt, wenn eine zum Dateityp IDC exportierte Parameterabfrage nicht die Datentypen besitzt, die im Dialogfeld Abfrageparameter angegeben wurden.

Um das Problem zu lösen, führen Sie folgende Schritte durch:

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] .

  2. Klicken Sie auf den Namen der Parameterabfrage, die Sie ändern wollen, und klicken Sie dann auf Entwurf in der Symbolleiste des Datenbankfensters.

  3. Klicken Sie im Menü Abfrage auf Parameter.

  4. Geben Sie im Dialogfeld Abfrageparameter explizit den Datentyp jedes Parameters in Ihrer Abfrage an, und klicken Sie auf OK, wenn Sie dies ausgeführt haben.

  5. Speichern Sie die Abfrage, und führen Sie sie aus.


 Einfügen eines Feldes im Entwurfsbereich einer Abfrage oder eines Spezialfilters

Einfügen eines Feldes im Entwurfsbereich einer Abfrage oder eines Spezialfilters

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht, oder öffnen Sie ein Formular oder Datenblatt, und zeigen Sie das Fenster Spezialfilter/-sortierung an.

  2. Ziehen Sie das Feld aus der Feldliste in die Spalte im Entwurfsbereich, in die Sie es einfügen möchten.


 Anzeigen des aktuellen Wertes während des Debuggens von Visual Basic-Code

Anzeigen des aktuellen Wertes während des Debuggens von Visual Basic-Code

  1. Unterbrechen Sie die Ausführung Ihres Visual Basic-Codes.

    Wie wird's gemacht?

  2. Markieren Sie den Ausdruck, dessen Wert Sie anzeigen möchten.

  3. Klicken Sie in der Symbolleiste Debug auf Aktuellen Wert anzeigen [image] .

Microsoft Access zeigt das Dialogfeld Aktuellen Wert anzeigen an, in dem Sie den Ausdruck und seinen aktuellen Wert sehen können. Klicken Sie im Dialogfeld auf Hinzufügen, um den Ausdruck der Liste der Überwachungsausdrücke im Überwachungsbereich des Visual Basic-Editors hinzuzufügen.


 Erstellen einer Verknüpfung in einem Formular zu einem vorhandenen gebundenen Objekt

Erstellen einer Verknüpfung in einem Formular zu einem vorhandenen gebundenen Objekt

  1. Erstellen Sie in einem Formular ein gebundenes Objektfeld.

    Wie wird's gemacht?

  2. Wechseln Sie zur Formularansicht oder zur Datenblattansicht.

  3. Gehen Sie zu dem Datensatz, mit dem Sie das Objekt verknüpfen möchten, und klicken Sie dann in einer Microsoft Access-Datenbank (.MDB) oder in der Image-Spalte in einem Microsoft Access-Projekt (.ADP) auf das Feld vom Datentyp OLE-Objekt .

  4. Klicken Sie im Menü Einfügen auf Objekt.

  5. Klicken Sie im Dialogfeld Objekt einfügen auf Aus Datei erstellen, und geben Sie dann den Pfad für die Datei an. Klicken Sie auf Durchsuchen, wenn Sie den Namen des Pfads nicht kennen.

  6. Aktivieren Sie das Kontrollkästchen Verknüpfen.

  7. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z. B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  8. Klicken Sie auf OK.

    Wenn Sie sich in der Formularansicht befinden, zeigt Microsoft Access das Objekt an. In der Datenblattansicht zeigt Microsoft Access den Namen des Objekts an, z. B. "Bitmap".

  9. Doppelklicken Sie auf das Objekt, wenn Sie es bearbeiten möchten.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Sie können ein gebundenes Objekt auch in das Datenblatt einer Tabelle oder Abfrage einfügen. Dazu wählen Sie einfach das Feld, in das Sie das Objekt einfügen möchten (dies muss ein Feld vom Datentyp OLE-Objekt oder eine Bildspalte sein) und führen dann die Schritte 4 bis 8 aus. Zum Anzeigen des Objekts müssen Sie in einem Formular oder Bericht ein gebundenes Objektfeld erstellen.

  • Verknüpfungen zu einem Objekt sind standardmäßig automatische Verknüpfungen, d.h., wenn Sie das Objekt außerhalb von Microsoft Access aktualisieren, werden die Änderungen auch im Formular oder Bericht automatisch angezeigt. Wenn Sie selbst bestimmen möchten, wann die Verknüpfung aktualisiert werden soll, können Sie von automatischer Verknüpfung zu manueller Verknüpfung wechseln.

    Wie wird's gemacht?


 Erstellen einer Verknüpfung in einem Formular oder Bericht zu einem vorhandenen ungebundenen Objekt

Erstellen einer Verknüpfung in einem Formular oder Bericht zu einem vorhandenen ungebundenen Objekt

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder einen Bericht in der Berichts-Entwurfsansicht.

  2. Klicken Sie in der Toolbox auf das Steuerelement Objektfeld [image] .

  3. Klicken Sie im Formular oder Bericht auf die Stelle, an der Sie das Objekt einfügen möchten.

  4. Klicken Sie im Dialogfeld Objekt einfügen auf Aus Datei erstellen, und geben Sie dann einen Pfad für die Datei an. Klicken Sie auf Durchsuchen, wenn Sie den Pfadnamen nicht kennen.

  5. Aktivieren Sie das Kontrollkästchen Verknüpfen.

  6. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z. B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  7. Klicken Sie auf OK.

Microsoft Access erstellt ein Objektfeld und zeigt das Objekt im Rahmen an. Wenn Sie das Objekt bearbeiten möchten, doppelklicken Sie darauf.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • In vielen Fällen möchten Sie ein ungebundenes Objekt in der Formular-Entwurfsansicht bzw. der Berichts-Entwurfsansicht bearbeiten. Wenn Sie das Objekt auch in der Formularansicht bearbeiten möchten, legen Sie dann für das Objektfeld für die Eigenschaft Aktiviert die Einstellung Ja und für die Eigenschaft Gesperrt die Einstellung Nein fest.

  • Verknüpfungen zu einem Objekt sind standardmäßig automatische Verknüpfungen, d.h., wenn Sie das Objekt außerhalb von Microsoft Access aktualisieren, werden die Änderungen dann beim nächsten Öffnen des Formulars oder Berichts automatisch angezeigt. Wenn Sie selbst bestimmen möchten, wann die Verknüpfung aktualisiert werden soll, können Sie von automatischer Verknüpfung zu manueller Verknüpfung wechseln.

    Wie wird's gemacht?


 Erstellen einer Verknüpfung in einem Formular zu einem vorhandenen gebundenen Objekt

Erstellen einer Verknüpfung in einem Formular zu einem vorhandenen gebundenen Objekt

Mit den nachfolgenden Schritten können Sie Teile eines vorhandenen Dokuments verknüpfen, wenn die Anwendung, mit der Sie verknüpfen, OLE unterstützt.

  1. Erstellen Sie in einem Formular ein gebundenes Objektfeld.

    Wie wird's gemacht?

  2. Wechseln Sie zu der Anwendung, in der das Objekt erstellt wurde, und markieren Sie die Informationen, die Sie verknüpfen möchten. Öffnen Sie z. B. Microsoft Excel, und markieren Sie einen Zellbereich.

  3. Klicken Sie im Menü Bearbeiten auf Kopieren.

  4. Lassen Sie die Anwendung geöffnet, und wechseln Sie zurück zu Microsoft Access. Wechseln Sie zur Formularansicht oder zur Datenblattansicht, gehen Sie zu dem Datensatz, in den Sie das Objekt einfügen möchten, und klicken Sie dann in einer Microsoft Access-Datenbank (.MDB) oder in der Image-Spalte in einem Microsoft Access-Projekt (.ADP) auf das Feld vom Datentyp OLE-Objekt.

  5. Klicken Sie im Menü Bearbeiten auf Inhalte einfügen.

  6. Klicken Sie im Dialogfeld Inhalte einfügen auf Verknüpfung einfügen und dann im Listenfeld Als auf den Typ für das einzufügende Objekt. Zum Anzeigen weiterer Informationen zu diesen Optionen klicken Sie auf [image] .

  7. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z. B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  8. Klicken Sie auf OK.

    Wenn Sie sich in der Formularansicht befinden, zeigt Microsoft Access das Objekt an. In der Datenblattansicht zeigt Microsoft Access den Namen des Objekts an, z. B. Microsoft Excel 7.0-Tabelle.

  9. Doppelklicken Sie auf das Objekt, wenn Sie es bearbeiten möchten.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • Sie können ein gebundenes Objekt auch in das Datenblatt einer Tabelle oder Abfrage einfügen. Dazu markieren Sie einfach das Feld, in das Sie das Objekt einfügen möchten (dies muss ein Feld vom Datentyp OLE-Objekt oder eine Bildspalte sein) und klicken dann im Menü Bearbeiten auf Inhalte einfügen. Führen Sie anschließend die Schritte 6 bis 8 aus. Zum Anzeigen des Objekts müssen Sie in einem Formular oder Bericht ein gebundenes Objektfeld erstellen.

  • Verknüpfungen zu einem Objekt sind standardmäßig automatische Verknüpfungen, d.h., wenn Sie das Objekt außerhalb von Microsoft Access aktualisieren, werden die Änderungen auch im Formular oder Bericht automatisch angezeigt. Wenn Sie selbst bestimmen möchten, wann die Verknüpfung aktualisiert werden soll, können Sie von automatischer Verknüpfung zu manueller Verknüpfung wechseln.

    Wie wird's gemacht?


 Erstellen einer Verknüpfung in einem Formular oder Bericht zu einem Teil eines vorhandenen ungebundenen Objekts

Erstellen einer Verknüpfung in einem Formular oder Bericht zu einem Teil eines vorhandenen ungebundenen Objekts

Mit den nachfolgenden Schritten können Sie Teile eines vorhandenen Dokuments verknüpfen, wenn die Anwendung, aus der Sie kopieren, OLE unterstützt.

  1. Öffnen Sie die Datei in der Anwendung, in der sie erstellt wurde, und markieren Sie die Informationen, zu denen Sie eine Verknüpfung erstellen möchten. Öffnen Sie z. B. Microsoft Excel und markieren Sie einen Zellbereich.

  2. Klicken Sie im Menü Bearbeiten auf Kopieren.

  3. Lassen Sie die Anwendung geöffnet, und wechseln Sie zu Microsoft Access.

  4. Klicken Sie in der Formular- oder Berichtsentwurfsansicht im Menü Bearbeiten auf Inhalte einfügen.

  5. Klicken Sie im Dialogfeld Inhalte einfügen auf Verknüpfung einfügen und dann in der Liste Als auf den Objekttyp, in dem das Objekt eingefügt werden soll. Zum Anzeigen weiterer Informationen zu diesen Optionen klicken Sie auf [image] .

  6. Aktivieren Sie das Kontrollkästchen Als Symbol darstellen, wenn Sie an Stelle des Objekts ein Symbol des Objekts anzeigen möchten. Das Anzeigen eines Objekts als Symbol eignet sich z. B. dann, wenn ein Objekt zusätzliche Informationen enthält, die nicht angezeigt werden müssen. Außerdem wird bedeutend weniger Festplattenspeicher belegt, wenn ein Objekt als Symbol angezeigt wird.

  7. Klicken Sie auf OK.

Microsoft Access erstellt ein Objektfeld und zeigt das Objekt im Rahmen an. Wenn Sie das Objekt bearbeiten möchten, doppelklicken Sie darauf.

Anmerkungen

  • Nach dem Einfügen des Objekts können Sie die Größe und die Proportionen ändern.

    Wie wird's gemacht?

  • In einen Formular können Sie ein ungebundenes Objekt in der Entwurfsansicht bearbeiten. Um das Objekt auch in der Formularansicht zu bearbeiten, öffnen Sie das Formular in der Entwurfsansicht und legen für das Objektfeld für die Eigenschaft Aktiviert die Einstellung Ja und für die Eigenschaft Gesperrt die Einstellung Nein fest.

  • Verknüpfungen zu einem Objekt sind standardmäßig automatische Verknüpfungen, d.h., wenn Sie das Objekt außerhalb von Microsoft Access aktualisieren, werden die Änderungen beim nächsten Öffnen des Formulars oder Berichts automatisch angezeigt. Wenn Sie selbst bestimmen möchten, wann die Verknüpfung aktualisiert werden soll, können Sie von automatischer Verknüpfung zu manueller Verknüpfung wechseln.

    Wie wird's gemacht?


 Definieren eines gebundenen HTML-Steuerelements als Standardsteuerelement für eine Datenzugriffsseite

Definieren eines gebundenen HTML-Steuerelements als Standardsteuerelement für eine Datenzugriffsseite

Beim Verwenden von gebundenen HTML-Steuerelementen in einer Datenzugriffsseite werden Seiten in der Seitenansicht oder in Internet Explorer möglicherweise schneller geladen. Sie können jedoch die in HTML-Steuerelementen angezeigten Werte nicht bearbeiten.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Bearbeiten auf Seite auswählen.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] . Microsoft Access zeigt das Eigenschaftenfenster an.

  4. Legen Sie für die Eigenschaft DefaultControlType die Einstellung Bound HTML fest.


Festlegen von Microsoft Access-Laufzeitoptionen

  1. Erstellen Sie ein Microsoft Access-Benutzerprofil.

    Wie wird's gemacht?

  2. Erstellen Sie unter dem Access-Benutzerprofilteilschlüssel einen Teilschlüssel namens \Run-Time Options.

  3. Erstellen Sie unter dem Teilschlüssel \Run-Time Options Teilschlüssel, die die folgenden Einstellungen für Ihre Anwendung festlegen.
    Windows-
    Registrierungseinstellung     		Funktion
    AppTitleBar | Text, der in der Titelleiste des Hauptfensters Ihrer Anwendung angezeigt wird.
    AppIcon | Symbol, das in der Titelleiste Ihrer Anwendung zu finden ist und angezeigt wird, wenn die Anwendung auf Symbolgröße verkleinert ist.
    AppHelpFile | Standard-Hilfedatei, die aufgerufen wird, wenn ein Benutzer die Hilfe zum ersten Mal startet.
    AppStartupScreen | Der Begrüßungsbildschirm oder die Bitmap-Datei, der/die angezeigt wird, wenn Ihre Anwendung startet.

Anmerkungen

  • Verwenden Sie die Einstellungen AppTitleBar und AppIcon, um die Access-Titelleiste und das Symbol durch einen speziellen Titel und ein spezielles Symbol für Ihre Anwendung zu ersetzen. Die Einstellungen AppTitleBar und AppIcon entsprechen den Starteigenschaften Anwendungstitel und Anwendungssymbol. Um weitere Informationen zum Einstellen von Starteigenschaften anzuzeigen, klicken Sie auf [image] .

  • Verwenden Sie die Einstellung AppHelpFile zum Angeben einer speziellen Hilfedatei für Ihre Anwendung.

  • Verwenden Sie die Einstellung AppStartupScreen zum Anzeigen eines Begrüßungsbildschirms, der Ihre Anwendung beim Starten eindeutig identifiziert und ankündigt. Ein Begrüßungsbildschirm ist nicht identisch mit einem Startformular. Er wird vor dem Startformular angezeigt, das Sie möglicherweise im Dialogfeld Start festgelegt haben.

  • Zum Erstellen eines Begrüßungsbildschirms können Sie auch eine Bitmap verwenden, die denselben Namen wie Ihre Anwendung, jedoch mit der Erweiterung .BMP, hat. Diese Datei müssen Sie in dem Ordner ablegen, in dem sich auch Ihre Anwendung befindet. Anschließend verwenden Sie Windows Explorer zum Erstellen einer Verknüpfung für Ihre Anwendung, die den Namen der Bitmap in der Befehlszeile angibt, und geben den Namen der Anwendung dann in das Feld Ziel(Registerkarte Tastenkombination, Dialogfeld Verknüpfungseigenschaften) ein. Beispiel:

    "C:\Programm\Microsoft Office\Office\MSAccess.exe C:\Eigene Dateien\STEUERN.MDB"

    Access sucht beim Öffnen der Anwendung nach einer Datei und verwendet diese, sofern vorhanden, als Begrüßungsbildschirm. Die Laufzeitoption AppStartupScreen hat Vorrang vor einem auf diese Weise angegebenen Begrüßungsbildschirm.


 Ändern eines Filters unter Verwendung einer der Methoden "Auswahlbasierter Filter" oder "Auswahlauschließender Filter"

Ändern eines Filters unter Verwendung einer der Methoden "Auswahlbasierter Filter" oder "Auswahlauschließender Filter"

Sie können zum Ändern des Filters weitere Kriterien hinzufügen oder vorhandene Kriterien ändern.

  1. Wenn Sie eine Datensatzgruppe, auf die ein Filter angewendet wurde, weiter eingrenzen möchten, beginnen Sie mit Schritt 2. Wenn Sie die zuvor für einen Filter festgelegten Kriterien ändern möchten, entfernen Sie zunächst den Filter (sofern dieser angewendet ist).

    Wie wird's gemacht?

  2. Wählen Sie in der Formular- oder der Datenblattansicht einen Wert in dem Formular, Unterformular, Datenblatt oder Unterdatenblatt aus, den Sie als Kriterium verwenden möchten, und klicken Sie dann in der Symbolleiste auf Auswahlbasierter Filter [image] , oder klicken Sie mit der rechten Maustaste auf den Wert, und klicken Sie dann im Kontextmenü auf Auswahlausschließender Filter. Wiederholen Sie diesen Vorgang, bis Sie die gewünschte Datensatzgruppe erhalten.

Anmerkung Sie können zum Ändern der Kriterien und zum Angeben von Alternativkriterien (ein Kriterium oder ein anderes) auch zum Fenster Formularbasierter Filter oder zum Fenster Spezialfilter/-sortierung wechseln.


 Ändern eines Filters unter Verwendung der Methode "Filter nach"

Ändern eines Filters unter Verwendung der Methode "Filter nach"

Sie können zum Ändern des Filters weitere Kriterien hinzufügen oder vorhandene Kriterien ändern.

  1. Wenn Sie eine Datensatzgruppe, auf die ein Filter angewendet wurde, weiter eingrenzen möchten, beginnen Sie mit Schritt 2. Wenn Sie die zuvor für den Filter festgelegten Kriterien ändern möchten, entfernen Sie zunächst den Filter (sofern dieser angewendet ist).

    Wie wird's gemacht?

  2. Führen Sie in der Formular- oder der Datenblattansicht einen der folgenden Schritte aus:
    • Klicken Sie mit der rechten Maustaste auf das Feld im Hauptformular, Datenblatt, Unterformular oder Unterdatenblatt, für das Sie Kriterien festlegen möchten, und geben Sie dann im Kontextmenü im Feld Filter nach den Wert ein, den Sie als Kriterium verwenden möchten.

    • Klicken Sie mit der rechten Maustaste auf ein beliebiges Feld im Hauptformular, Datenblatt, Unterformular oder Unterdatenblatt, und geben Sie im Feld Filter nach, den Ausdruck ein, den Sie als Kriterium verwenden möchten.
  3. Drücken Sie TAB, und wiederholen Sie Schritt 2, bis Sie die gewünschten Datensätze erhalten.

    Zum Anzeigen weiterer Informationen zur Verwendung der Methode Filter nach klicken Sie auf [image] .

Anmerkung Sie können zum Ändern der Kriterien auch zum Fenster Formularbasierter Filter oder zum Fenster Spezialfilter/-sortierung wechseln.


 Verschieben eines Feldes im Entwurfsbereich in einer Abfrage oder einem Spezialfilter

Verschieben eines Feldes im Entwurfsbereich in einer Abfrage oder einem Spezialfilter

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht, oder öffnen Sie ein Formular oder Datenblatt, und zeigen Sie das Fenster Spezialfilter/-sortierung an.

  2. Markieren Sie die Spalte, die Sie verschieben möchten.
    • Zum Markieren einer Spalte klicken Sie auf deren Spaltenmarkierer.

    • Zum Markieren mehrerer angrenzender Spalten ziehen Sie über deren Spaltenmarkierer.

    Ändern der Feldreihenfolge in einer Abfrage durch Verschieben

  3. Klicken Sie erneut auf den Markierer einer der markierten Spalten, und ziehen Sie dann das Feld oder die Felder an die neue Position.

    Das verschobene Feld und alle Felder rechts von diesem Feld werden nach rechts verschoben.


 Ändern der Größe eines Textfeldes oder eines anderen Steuerelements in einer Gruppe in einem Formular oder Bericht

Ändern der Größe eines Textfeldes oder eines anderen Steuerelements in einer Gruppe in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf eines der Steuerelemente in der Gruppe, um die vollständige Gruppe auszuwählen.

  3. Klicken Sie auf das Steuerelement, dessen Größe Sie ändern möchten.

  4. Ziehen Sie an den Ziehpunkten zum Ändern der Größe, bis das Steuerelement die gewünschte Größe hat.

    Ziehpunkte zur Größenänderung an einem Steuerelement

Anmerkungen

  • Wenn Sie geringe Änderungen an der Größe eines Steuerelements vornehmen möchten, ist es u. U. einfacher, die UMSCHALTTASTE und die entsprechende Pfeiltaste zu drücken.

  • Wenn Sie die Größe eines Steuerelements in einer Gruppe ändern, wird das Rechteck um die Gruppe automatisch angepasst, so dass es um alle Steuerelemente passt.

  • Zum Ändern der Größe aller Steuerelemente in einer Gruppe können Sie an den Ziehpunkten des Rechtecks um die Gruppe ziehen.

  • Wenn die Option Am Raster ausrichten aktiviert ist, wird das Rechteck um die Gruppe beim Ändern der Größe am Raster ausgerichtet. Die Steuerelemente in der Gruppe werden nicht am Raster ausgerichtet.


 Verschieben eines Textfeldes oder eines anderen Steuerelements in einer Gruppe in einem Formular oder Bericht

Verschieben eines Textfeldes oder eines anderen Steuerelements in einer Gruppe in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf eines der Steuerelemente in der Gruppe, um die vollständige Gruppe auszuwählen.

  3. Klicken Sie auf das Steuerelement, das Sie verschieben möchten.

  4. Führen Sie einen der folgenden Schritte durch:
    • Setzen Sie zum Verschieben des Steuerelements zusammen mit dem zugeordneten Bezeichnungsfeld den Zeiger auf den Rahmen (nicht auf den Ziehpunkt zum Verschieben) des Steuerelements, bis sich der Zeiger in eine geöffnete Hand ändert, und ziehen Sie das Steuerelement und das Bezeichnungsfeld anschließend an die gewünschte Position.

    Cursor in Form einer geöffneten Hand

    • Setzen Sie den Zeiger auf den Ziehpunkt in der linken oberen Ecke des Steuerelements oder Bezeichnungsfeldes des Steuerelements oder aber des Bezeichnungsfeldes, wenn Sie diese getrennt verschieben möchten. Wenn sich der Zeiger in eine nach oben zeigende Hand ändert, ziehen Sie am Steuerelement oder Bezeichnungsfeld.

    Cursor in Form einer nach oben zeigenden Hand

Anmerkungen

  • Wenn Sie ein Steuerelement in kleinen Schritten verschieben möchten, ist es u. U. einfacher, die STRG-TASTE und die entsprechende Pfeiltaste zu drücken.

  • Wenn Sie ein Steuerelement in einer Gruppe verschieben, wird das Rechteck um die Gruppe automatisch angepasst, so dass es um alle Steuerelemente passt.

  • Wenn die Option Am Raster ausrichten aktiviert ist, wird das Rechteck um die Gruppe beim Verschieben am Raster ausgerichtet. Die Steuerelemente in der Gruppe werden nicht am Raster ausgerichtet.


 Bewegen zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung eines Makros

Bewegen zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung eines Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Wählen Sie eine der folgenden Möglichkeiten:

    Um den Fokus auf ein bestimmtes Steuerelement oder Feld im aktuellen Datensatz zu verlagern, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf GeheZuSteuerelement, und geben Sie dann für das Argument Steuerelementname den Namen des Steuerelements an, zu dem Sie gelangen möchten.

    Um sich einen bestimmten Datensatz zum aktuellen Datensatz zu machen, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf GeheZuDatensatz, und legen Sie dann die entsprechenden Argumente fest.

    Um den Fokus im aktiven Formular auf das erste Steuerelement einer bestimmten Formularseite zu verlagern, klicken Sie in der Aktionsliste einer leeren Aktionszeile auf GeheZuSeite, und legen Sie dann die entsprechenden Argumente fest.

  3. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  4. Führen Sie das Makro aus.

    Wie wird's gemacht?

Zum Anzeigen weiterer Informationen zur GeheZuSteuerelement-Aktion klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zur GeheZuDatensatz-Aktion klicken Sie auf [image] .

Zum Anzeigen weiterer Informationen zur GeheZuSeite-Aktion klicken Sie auf [image] .


 Navigieren zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung von Visual Basic

Navigieren zwischen Steuerelementen, Datensätzen und Formularseiten unter Verwendung von Visual Basic

  1. Öffnen Sie die Ereignisprozedur für das entsprechende Ereignis im Code-Fenster.

    Wie wird's gemacht?

    Um z.B. auf ein Klicken mit der Maus auf eine Befehlsschaltfläche zu reagieren, öffnen Sie die Ereignisprozedur Click der Schaltfläche.

  2. Wählen Sie eine der folgenden Möglichkeiten:

    Um den Fokus auf ein bestimmtes Steuerelement oder Feld im aktuellen Datensatz zu verlagern, führen Sie die Methode GoToControl in der Prozedur aus, wobei Sie für das Argument Steuerelementname den Namen des Steuerelements angeben, zu dem Sie gelangen möchten.

    Wie wird's gemacht?

    Um sich zu einem bestimmten oder einem neuen Datensatz zu bewegen, fügen Sie die Methode GoToRecord in die Prozedur ein, so dass Sie die GeheZuDatensatz-Aktion ausführen können.

    Um sich zu einer bestimmten Formularseite zu bewegen, fügen Sie die Methode GoToPage in die Prozedur ein, so dass Sie die GeheZuSeite-Aktion ausführen können.

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Tipp Sie können mit Hilfe von Visual Basic für Applikationen auch Datensätze suchen oder sich zwischen ihnen bewegen, indem Sie das Objekt Recordset sowie die Methode Seek oder eine Move- oder Find-Methode verwenden.

Um weitere Informationen zur Aktion GeheZuSteuerelement zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zur Aktion GeheZuDatensatz zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zur Aktion GeheZuSeite zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zum Objekt Recordset und dessen Methoden zu erhalten, klicken Sie auf [image] .


 Verwenden eines Makros zur Anzeige von Detaildatensätzen beim Bewegen zwischen Datensätzen in einem Formular

Verwenden eines Makros zur Anzeige von Detaildatensätzen beim Bewegen zwischen Datensätzen in einem Formular

  1. Öffnen Sie das erste Formular in der Entwurfsansicht.

  2. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  3. Klicken Sie in einer leeren Aktionszeile auf ÖffnenFormular in der Aktionsliste.

  4. Geben Sie für das Argument Formularname den Namen des zweiten Formulars an, und setzen Sie dann das Argument Bedingung, um die gewünschten Detaildatensätze im zweiten Formular anzuzeigen. Wenn Sie ein Beispiel dafür sehen möchten, klicken Sie auf [image] .

  5. Stellen Sie in der Formular-Entwurfsansicht die Ereigniseigenschaft BeimAnzeigen des Formulars auf den Makronamen ein.


 Verwenden von Visual Basic zum Anzeigen von Detaildatensätzen beim Bewegen zwischen Datensätzen in einem Formular

Verwenden von Visual Basic zum Anzeigen von Detaildatensätzen beim Bewegen zwischen Datensätzen in einem Formular

  1. Öffnen Sie das erste Formular in der Entwurfsansicht.

  2. Öffnen Sie die Ereignisprozedur Form_Current des Formulars.

    Wie wird's gemacht?

  3. Fügen Sie der Ereignisprozedur Visual Basic-Code hinzu, um im zweiten Formular die Datensätze anzuzeigen, deren Feldwerte mit denen eines entsprechenden Felds im ersten Formular übereinstimmen.

Um ein Beispiel vorzuführen, in dem mit Hilfe von Visual Basic Detaildatensätze beim Bewegen zwischen Datensätzen in einem Formular angezeigt werden, klicken Sie auf [image] .


 Öffnen einer Abfrage in der Entwurfsansicht

Öffnen einer Abfrage in der Entwurfsansicht

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] .

  2. Klicken Sie auf die Abfrage, die Sie öffnen möchten, und dann auf Entwurf auf der Symbolleiste des Datenbankfensters.

Anmerkungen

  • Wenn ein Formular, ein Bericht oder eine Datenzugriffsseite auf einer Abfrage basiert, können Sie die Abfrage öffnen, um deren Entwurf direkt vom Formular, vom Bericht oder von der Datenzugriffsseite aus zu ändern. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Sie eine Abfrage in der SQL-Ansicht gespeichert haben, zeigt Microsoft Access diese Ansicht wieder an, wenn Sie für diese Abfrage erneut auf der Symbolleiste des Datenbankfensters auf Entwurf klicken.


 Übersicht über den Office-Assistenten

Übersicht über den Office-Assistenten

Wenn Sie von Microsoft Access aus Microsoft Office-Objekte verwenden möchten, stellen Sie zuerst einen Verweis auf die Microsoft Office-Objektbibliothek ein. Klicken Sie dazu in der Modul-Entwurfsansicht im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen neben Microsoft Office 9.0 Object Library.

Wenn Sie diesen Verweis nicht einstellen, erhalten Sie den Kompilierzeitfehler "Benutzerdefinierter Typ nicht definiert", wenn Sie versuchen, Objekte der Microsoft Office-Objektbibliothek zu verwenden.

Nachdem Sie einen Verweis auf die Microsoft Office-Objektbibliothek eingestellt haben, können Sie die Objekte, Eigenschaften und Methoden von Microsoft Office im Objektkatalog anzeigen. Beim Programmieren des Office-Assistenten können Sie die Objekte Assistant, Balloon, BalloonCheckbox und BalloonLabel sowie die Auflistungen BalloonCheckboxes und BalloonLabels verwenden.

Die folgenden Eigenschaften des Assistant-Objekts sind in Microsoft Access nicht verfügbar, obwohl sie in anderen Microsoft Office-Anwendungen möglicherweise verwendet werden können:

  • FeatureTips-Eigenschaft

  • HighPriorityTips-Eigenschaft

  • KeyboardShortcutTips-Eigenschaft

  • MouseTips-Eigenschaft

Anmerkung Der Office-Assistent steht in der Laufzeitversion von Microsoft Access nicht zur Verfügung.


 Übersicht über Befehlsleisten

Übersicht über Befehlsleisten

Wenn Sie in Microsoft Access 2000 mit Befehlsleisten programmieren möchten, stellen Sie zuerst einen Verweis auf die Microsoft Office Object Library ein. Klicken Sie dazu in der Modul-Entwurfsansicht im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen neben Microsoft Office 9.0 Object Library.

Nachdem Sie einen Verweis auf die Microsoft Office Object Library eingestellt haben, können Sie die Objekte, Eigenschaften und Methoden von Microsoft Office im Objektkatalog anzeigen. Beim Programmieren von Befehlsleisten können Sie die Objekte CommandBar, CommandBarControl, CommandBarButton, CommandBarComboBox und CommandBarPopup sowie die Auflistungen CommandBars und CommandBarControls verwenden.


Der gedruckte Bericht enthält Leerseiten.

Enthält der Bericht oder das gedruckte Formular nur am Ende eine Leerseite, stellen Sie sicher, dass die Eigenschaft Höhe für den Berichts- oder Formularfuß auf Null eingestellt ist. Um Informationen zum Einstellen von Eigenschaften anzuzeigen, klicken Sie auf [image] .

Handelt es sich bei allen anderen Seiten ebenfalls um Leerseiten, müssen Sie sicherstellen, dass die Gesamtbreite des Formulars oder Berichts zuzüglich der Breiten der linken und rechten Ränder die im Dialogfeld Seitenformat (Menü Datei) angegebene Papiergröße nicht überschreitet. Als Richtlinie können Sie die folgende Formel verwenden:

Formular- oder Berichtsbreite + linker Rand + rechter Rand <= Papiergröße

Zum Anpassen des Formulars oder Berichts stehen Ihnen die beiden folgenden Möglichkeiten zur Verfügung:

  • Verringern der Breite des Formulars oder Berichts.

    Wie wird's gemacht?

  • Verkleinern der Ränder oder Ändern der Seitenausrichtung.

    Wie wird's gemacht?


 Anzeigen eines Berichts in der Layoutvorschau

Anzeigen eines Berichts in der Layoutvorschau

Die Layoutvorschau bietet die Möglichkeit einer schnellen Überprüfung des Layouts eines Berichts. Microsoft Access stellt dabei nur so viele Daten aus der zugrunde liegenden Tabelle oder Abfrage dar, dass Sie das spätere Aussehen des Berichts erkennen können. Wenn Sie jedoch prüfen möchten, ob die Daten im Bericht richtig sind, verwenden Sie die Seitenansicht. Zum Anzeigen von Informationen klicken Sie auf [image] .

  • Klicken Sie aus der Entwurfsansicht des Berichts heraus in der Symbolleiste auf den Pfeil neben der Ansichtsschaltfläche und dann auf Layoutvorschau.

Anmerkungen

  • Basiert der Bericht auf einer Abfrage, bei der Sie zur Eingabe von Parametern aufgefordert werden, klicken Sie nur auf OK, ohne Werte einzugeben. Microsoft Access ignoriert die Parameter, wenn Sie Layoutvorschau wählen.

  • Sie können mit Hilfe der Navigationsschaltflächen am unteren Rand des Seitenansichtsfensters zu einer anderen Seite gelangen. Auf der aktuellen Seite können Sie sich mit Hilfe der Bildlaufleisten oder, wenn Sie über eine Microsoft IntelliMouse verfügen, mit der Radtaste bewegen.

  • Um Informationen zur Ansicht des Berichts bei verschiedenen Zoom-Stufen anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zur gleichzeitigen Ansicht mehrerer Seiten anzuzeigen, klicken Sie auf [image] .


 Anzeigen von Datensätzen in der Vorschau, auf die sich Tabellenerstellungs-, Lösch-, Anfüge- oder Aktualisierungsabfragen beziehen

Anzeigen von Datensätzen in der Vorschau, auf die sich Tabellenerstellungs-, Lösch-, Anfüge- oder Aktualisierungsabfragen beziehen

  • Klicken Sie in der Abfrage-Entwurfsansicht auf Ansicht [image] auf der Symbolleiste, um die Abfrage in der Datenblattansicht anzuzeigen.
    Abfrage | Anzeige im Datenblatt
    Aktualisierungsabfrage | Die zu aktualisierenden Felder
    Löschabfrage | Die zu löschenden Datensätze
    Tabellenerstellungsabfrage | Die in die neue Tabelle aufzunehmenden Felder
    Anfügeabfrage | Die zu einer anderen Tabelle hinzuzufügenden Datensätze


 Anzeigen der Daten eines Berichts in der Seitenansicht

Anzeigen der Daten eines Berichts in der Seitenansicht

So zeigen Sie einen Bericht aus der Entwurfsansicht heraus in der Seitenansicht an

  • Klicken Sie aus der Entwurfsansicht heraus in der Symbolleiste auf Seitenansicht [image] .

So zeigen Sie im Datenbankfenster einen Bericht in der Seitenansicht an

  1. Klicken Sie im Datenbankfenster unter Objekte auf Berichte [image] .

  2. Wählen Sie den Bericht aus, den Sie in der Seitenansicht anzeigen möchten.

  3. Klicken Sie in der Symbolleiste des Datenbankfensters auf die Schaltfläche Vorschau .

Anmerkungen

  • Sie können mit Hilfe der Navigationsschaltflächen am unteren Rand des Seitenansichtsfensters zu einer anderen Seite gelangen. Auf der aktuellen Seite können Sie sich mit Hilfe der Bildlaufleisten oder, wenn Sie über eine Microsoft IntelliMouse verfügen, mit der Radtaste bewegen.

  • Um Informationen zur Ansicht des Berichts bei verschiedenen Zoom-Stufen anzuzeigen, klicken Sie auf [image] .

  • Um Informationen zur gleichzeitigen Ansicht mehrerer Seiten anzuzeigen, klicken Sie auf [image] .


 Drucken eines Formulars aus dem Datenbankfenster

Drucken eines Formulars aus dem Datenbankfenster

  1. Klicken Sie unter Objekte auf Formulare [image] .

  2. Wählen Sie das zu druckende Formular aus.

  3. Klicken Sie im Menü Datei auf Drucken.

  4. Wählen Sie im Dialogfeld Drucken die gewünschten Druckoptionen.

  5. Klicken Sie auf OK.

Microsoft Access druckt das Formular in der Ansicht, die in dessen Eigenschaft Standardansicht angegeben ist.

Tipp Wenn Sie ein Formular drucken möchten, ohne im Dialogfeld Drucken Optionen anzugeben, klicken Sie in der Symbolleiste auf Drucken [image] .


 Drucken eines Formulars aus der Entwurfsansicht, Formularansicht oder Datenblattansicht

Drucken eines Formulars aus der Entwurfsansicht, Formularansicht oder Datenblattansicht

  1. Klicken Sie im Menü Datei auf Drucken.

  2. Wählen Sie im Dialogfeld Drucken die gewünschten Druckoptionen.

Wie Microsoft Access das Formular druckt, ist von der Ansicht abhängig, aus der es gedruckt wird.

Aus | Drucken des Formulars
Entwurfsansicht | In der Formularansicht.
Formularansicht | In der Formularansicht.
Datenblattansicht | Als Datenblatt.

Tipp Wenn Sie ein Formular drucken möchten, ohne im Dialogfeld Drucken Optionen anzugeben, klicken Sie in der Symbolleiste auf Drucken [image] .


 Beenden von Microsoft Access

Beenden von Microsoft Access

  • Klicken Sie im Menü Datei auf Schließen.

    Beim Beenden von Microsoft Access werden die Änderungen automatisch gespeichert. Wenn Sie jedoch seit der letzten Änderung den Entwurf beliebiger Datenbankobjekte geändert haben, fragt Microsoft Access, ob Sie die Änderungen vor dem Beenden speichern möchten.

Vorsicht Wird Microsoft Access plötzlich beendet, kann Ihre Datenbank beschädigt werden. Beenden Sie daher Microsoft Access, wann immer dies möglich ist, wie oben beschrieben.


 Wiederherstellen einer Verknüpfung zu einem Hintergrundbild in einem Formular oder einem Bericht

Wiederherstellen einer Verknüpfung zu einem Hintergrundbild in einem Formular oder einem Bericht

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder einen Bericht in der Berichts-Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer oder den Berichtsmarkierer, um das Eigenschaftenfenster für das Formular oder den Bericht zu öffnen.

  3. Geben Sie im Einstellungsfeld der Eigenschaft Bild den korrekten Pfad für das Bild ein.


 Wiederherstellen einer Verknüpfung zu einem Bild in einem Bild-Steuerelement auf einem Formular oder einem Bericht

Wiederherstellen einer Verknüpfung zu einem Bild in einem Bild-Steuerelement auf einem Formular oder einem Bericht

  1. Öffnen Sie ein Formular in der Formular-Entwurfsansicht oder einen Bericht in der Berichts-Entwurfsansicht.

  2. Stellen Sie sicher, dass das Bild-Steuerelement ausgewählt ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] .

  3. Geben Sie im Einstellungsfeld der Eigenschaft Bild den korrekten Pfad für das Bild ein.


 Wiederherstellen oder Ändern der Verknüpfung zu einem Bild in einem gebundenen Objektfeld oder einem Objektfeld in einem Formular oder einem Bericht

Wiederherstellen oder Ändern der Verknüpfung zu einem Bild in einem gebundenen Objektfeld oder einem Objektfeld in einem Formular oder einem Bericht

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Entwurfsansicht für Formulare oder der Entwurfsansicht für Berichte auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Klicken Sie im Menü Bearbeiten auf OLE/DDE-Verknüpfungen.

  3. Klicken Sie im Listenfeld Verknüpfungen auf die Verknüpfung, die Sie wiederherstellen oder ändern möchten.

  4. Klicken Sie auf Herkunft ändern.

  5. Wählen Sie im Dialogfeld Herkunft ändern den neuen Dateinamen. Möglicherweise müssen Sie zum Suchen nach der Datei zu einem anderen Laufwerk und/oder Ordner wechseln.

  6. Klicken Sie auf Öffnen, um die Verknüpfung zu vervollständigen und das Dialogfeld Herkunft ändern zu schließen, und klicken Sie dann im Dialogfeld Verknüpfungen auf Schließen.

Anmerkung Wenn Sie Änderungen an einer Verknüpfung für ein gebundenes Objektfeld vornehmen, ändern Sie die Verknüpfung nur für den aktuellen Datensatz. Zum Durchführen einer Änderung in einem anderen Datensatz gehen Sie zu diesem Datensatz und wiederholen die Änderung.


Festlegen der Aktivierreihenfolge für Textfelder oder andere Steuerelemente auf einer Datenzugriffsseite

Was möchten Sie tun?

Ändern der Aktivierreihenfolge

Entfernen eines Textfeldes oder eines anderen Steuerelements aus der Aktivierreihenfolge


 Entfernen eines Textfeldes oder eines anderen Steuerelements aus der Aktivierreihenfolge eines Formulars

Entfernen eines Textfeldes oder eines anderen Steuerelements aus der Aktivierreihenfolge eines Formulars

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster anzuzeigen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft InReihenfolge auf Nein.

Anmerkung Wenn die Eigenschaft Aktiviert für ein Steuerelement auf Ja gesetzt ist, können Sie dieses auch dann markieren, wenn die Eigenschaft InReihenfolge auf Nein gesetzt ist.


 Entfernen des Standarddesigns für neue Datenzugriffsseiten

Entfernen des Standarddesigns für neue Datenzugriffsseiten

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Design.

  3. Klicken Sie in der Liste Design auswählen auf (Kein Design).

  4. Klicken Sie auf Als Standard festlegen.

  5. Klicken Sie auf Ja.


 Löschen eines Feldes aus dem Entwurfsbereich in einer Abfrage oder einem Spezialfilter

Löschen eines Feldes aus dem Entwurfsbereich in einer Abfrage oder einem Spezialfilter

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht, oder öffnen Sie ein Formular oder Datenblatt, und zeigen Sie das Fenster Spezialfilter/-sortierung an.

  2. Wählen Sie ein Feld aus, indem Sie auf den Spaltenmarkierer des Feldes klicken und anschließend die ENTF-TASTE drücken.

Anmerkung Wenn Sie ein Feld aus dem Entwurfsbereich löschen, wird dieses nur aus dem Entwurf der Abfrage oder des Filters entfernt. Dabei werden weder das Feld noch die enthaltenen Daten aus der zugrunde liegenden Tabelle bzw. dem gefilterten Ergebnis gelöscht.


 Entfernen einer Tabelle oder Abfrage aus einer Abfrage

Entfernen einer Tabelle oder Abfrage aus einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Markieren Sie im oberen Teil der Entwurfsansicht für Abfragen die Tabelle oder Abfrage, die Sie löschen möchten. Klicken Sie dazu auf eine beliebige Stelle in der Feldliste dieser Tabelle oder Abfrage, und drücken Sie dann auf die ENTF-TASTE.

    Felder, die Sie aus der Feldliste in den Entwurfsbereich gezogen haben, werden ebenfalls aus der Abfrage entfernt. Die Tabelle oder Abfrage wird jedoch nicht aus der Datenbank gelöscht.


 Entfernen eines Textfeldes oder eines anderen Steuerelements aus einer Gruppe in einem Formular oder Bericht

Entfernen eines Textfeldes oder eines anderen Steuerelements aus einer Gruppe in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht oder einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf eines der Steuerelemente in der Gruppe, um die vollständige Gruppe auszuwählen.

  3. Klicken Sie im Menü Format auf Gruppierung aufheben.

  4. Klicken Sie auf den Formularhintergrund, wenn Sie die Auswahl der Steuerelemente in der Gruppe, die bisher in der Gruppe enthalten waren, rückgängig machen möchten.

  5. Wählen Sie die Steuerelemente aus, die jetzt in der Gruppe enthalten sein sollen. Informationen zum Auswählen benachbarter Steuerelemente. Informationen zum Auswählen nicht benachbarter oder überlappender Steuerelemente.

  6. Klicken Sie im Menü Format auf Gruppieren.


 Entfernen eines Designs aus einer vorhandenen Datenzugriffsseite

Entfernen eines Designs aus einer vorhandenen Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite, aus der Sie das Design entfernen möchten, in der Entwurfsansicht.

  2. Klicken Sie im Menü Format auf Design.

  3. Klicken Sie in der Liste Design auswählen auf (Kein Design).


 Löschen oder Umbenennen einer Gruppe

Löschen oder Umbenennen einer Gruppe

  1. Wechseln Sie ggf. zum Datenbankfenster. Um von einem beliebigen anderen Fenster zum Datenbankfenster zu wechseln, können Sie auch F11 drücken.

  2. Klicken Sie auf die Gruppenleiste, um die Gruppen anzuzeigen, und klicken Sie dann mit der rechten Maustaste auf die Gruppe, die Sie löschen oder umbenennen möchten.

  3. Führen Sie einen der folgenden Schritte aus:

    Klicken Sie zum Löschen der Gruppe im Kontextmenü auf Gruppe entfernen.

    Klicken Sie zum Umbenennen der Gruppe im Kontextmenü auf Gruppe umbenennen, und geben Sie dann im Feld Neuer Gruppenname einen neuen Namen ein.


 Umbenennen eines Feldes in einer Abfrage

Umbenennen eines Feldes in einer Abfrage

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Setzen Sie die Einfügemarke links neben den ersten Buchstaben des Feldnamens im Entwurfsbereich.

  3. Geben Sie den neuen Namen ein, gefolgt von einem Doppelpunkt.

    Ändern einer Feldüberschrift, die in einer Anfrage angezeigt wird

Anmerkung Falls Sie den von Microsoft Access automatisch zugewiesenen Feldnamen Ausdr1 (oder Ausdr2 usw.) ändern möchten, ersetzen Sie nur den Namen, nicht den nach dem Doppelpunkt folgenden Ausdruck.


 Umbenennen oder Löschen einer Datenbankobjektverknüpfung in einer Gruppe

Umbenennen oder Löschen einer Datenbankobjektverknüpfung in einer Gruppe

  1. Wechseln Sie ggf. zum Datenbankfenster. Um von einem beliebigen anderen Fenster zum Datenbankfenster zu wechseln, können Sie auch F11 drücken.

  2. Klicken Sie auf die Gruppenleiste, und klicken Sie dann mit der rechten Maustaste auf die Gruppe, die die Datenbankobjektverknüpfung enthält, die Sie löschen oder umbenennen möchten.

  3. Klicken Sie mit der rechten Maustaste auf die Verknüpfung.

  4. Führen Sie einen der folgenden Schritte aus:

    Klicken Sie zum Löschen der Verknüpfung im Kontextmenü auf Löschen [image].

    Klicken Sie zum Umbenennen der Verknüpfung im Kontextmenü auf Umbenennen, und geben Sie dann einen neuen Namen für die Verknüpfung ein.

Anmerkungen
  • Wenn Sie eine Datenbankobjektverknüpfung aus einer Gruppe löschen, wird nur die Verknüpfung mit diesem Objekt, nicht das Objekt selbst gelöscht. Wenn Sie z. B. eine Formularverknüpfung aus Ihrer Gruppe löschen und dann im Datenbankfenster unter [image] Objekte auf Formulare klicken, wird dieses Formular weiterhin in der Liste aller Formulare angezeigt.

  • Beim Umbenennen einer Datenbankobjektverknüpfung in einer Gruppe wird nur der Name der Verknüpfung, nicht der Name des Objekts geändert.


 Umbenennen einer Tabelle oder Abfrage, die einer Abfrage hinzugefügt wurde

Umbenennen einer Tabelle oder Abfrage, die einer Abfrage hinzugefügt wurde

Sie können in einer Abfrage mehrere Kopien der gleichen Tabelle oder Abfrage umbenennen.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Klicken Sie auf eine beliebige Stelle in der zweiten Kopie der Feldliste für die Tabelle oder Abfrage, und klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  3. Geben Sie in das Einstellungsfeld für die Eigenschaft Alias einen neuen Namen für die Tabelle oder Abfrage ein.

Anmerkung Das Umbenennen von Kopien einer Tabelle oder Abfrage in einer Abfrage benennt nicht automatisch die zugrunde liegende Tabelle oder Abfrage um.


 Direktes Ausführen eines Makros

Direktes Ausführen eines Makros

Sie haben folgende Möglichkeiten, ein Makro direkt auszuführen:

  • Um ein Makro aus dem Makrofenster auszuführen, klicken Sie auf der Symbolleiste auf Ausführen [image] .

  • Um ein Makro aus dem Datenbankfenster auszuführen, klicken Sie auf Makros [image] , und doppelklicken Sie dann auf einen Makronamen.

  • Um ein Makro an einer beliebigen anderen Stelle in Microsoft Access auszuführen, zeigen Sie im Menü Extras auf Makro und klicken dann auf Makro ausführen. Klicken Sie anschließend im Feld Makroname auf einen Makronamen.

Anmerkung Normalerweise wird ein Makro nur zum Testen direkt ausgeführt. Anschließend können Sie das Makro einem Formular, einem Bericht oder einem Steuerelement zuordnen, um es als Antwort auf ein Ereignis auszuführen, oder Sie können zum Ausführen des Makros einen benutzerdefinierten Menübefehl erstellen.


 Ausführen eines Makros in einer Makrogruppe

Ausführen eines Makros in einer Makrogruppe

Sie können ein Makro, das sich in einer Makrogruppe befindet, auf folgende Arten ausführen:

  • Geben Sie das Makro als Einstellung einer Ereigniseigenschaft für ein Formular oder einen Bericht oder als Argument Makroname der Aktion AusführenMakro an. Verwenden Sie für den Verweis auf das Makro die folgende Syntax:

    Makrogruppenname.Makroname

    Die folgende Einstellung der Ereigniseigenschaft führt z. B. ein Makro mit dem Namen Kategorien aus einer Makrogruppe namens Formularübersichtsschaltflächen aus:

    Formularübersichtsschaltflächen.Kategorien

  • Zeigen Sie im Menü Extras auf Makro, klicken Sie auf Makro ausführen, und wählen Sie das gewünschte Makro aus der Liste Makroname. Wenn Makronamen in Listen angezeigt werden, ist für jedes Makro einer Makrogruppe ein Eintrag vorhanden.

  • Führen Sie ein Makro, das sich in einer Makrogruppe befindet, von einer Visual Basic-Prozedur aus, indem Sie die Methode RunMacro des Objekts DoCmd angeben. Verwenden Sie zur Bezugnahme auf das Makro die weiter oben angegebene Syntax.


 Ausführen einer Tabellenerstellungs-, Anfüge-, Lösch- oder Aktualisierungsabfrage

Ausführen einer Tabellenerstellungs-, Anfüge-, Lösch- oder Aktualisierungsabfrage

  1. Öffnen Sie die Abfrage in der Entwurfsansicht.

  2. Um die Datensätze anzuzeigen, auf welche sich die Abfrage auswirkt, klicken Sie in der Symbolleiste auf Abfrageansicht [image] , und überprüfen Sie dann die Datensätze. Um Informationen darüber zu erhalten, was jeweils angezeigt wird, klicken Sie auf [image] . Um zur Abfrageentwurfsansicht zurückzukehren, klicken Sie in der Symbolleiste erneut auf Abfrageansicht [image] . Führen Sie hier ggf. Änderungen durch.

  3. Klicken Sie in der Symbolleiste auf Ausführen [image] , um die Abfrage auszuführen.

Anmerkung Zum Unterbrechen einer gestarteten Abfrage drücken Sie STRG+UNTBR.

Um Informationen zu den Ergebnissen einer Tabellenerstellungs-, einer Anfüge- oder einer Löschabfrage anzuzeigen, klicken Sie auf [image] .

Um Informationen zu den Ergebnissen einer Aktualisierungsabfrage anzuzeigen, klicken Sie auf [image] .


 Speichern einer Kopie eines PivotTable-Datenformulars

Speichern einer Kopie eines PivotTable-Datenformulars

Wenn Sie damit rechnen, zu einem späteren Zeitpunkt, zu dem Sie keinen Datenzugriff mehr haben, ein PivotTable-Formular bearbeiten zu müssen, speichern Sie eine Kopie der Daten mit dem PivotTable-Formular. Beachten Sie, dass das Speichern von Daten zu einer erheblichen Vergrößerung des Formulars führen kann. Daher muss unbedingt genügend Festplattenspeicher zur Verfügung stehen.

  1. Öffnen Sie das Formular, das die Pivot-Tabelle enthält, in der Formularansicht.

  2. Klicken Sie auf die Schaltfläche PivotTable-Objekt bearbeiten.

  3. Klicken Sie im Microsoft Excel-Menü Daten auf Daten aktualisieren.

  4. Klicken Sie im Menü Daten auf PivotTable- und PivotChart-Bericht, um den PivotTable-Assistenten erneut zu starten.

  5. Klicken Sie auf Optionen.

  6. Wählen Sie unter Datenquellenoptionen die Option Daten mit Tabellenlayout speichern aus.

  7. Klicken Sie auf OK.

  8. Klicken Sie auf Fertig stellen.

  9. Setzen Sie Ihre Arbeit mit dem PivotTable-Formular fort, oder schließen Sie es und kehren zum Formular in Microsoft Access zurück, indem Sie im Microsoft Excel-Menü Datei auf Schließen & Zurückkehren zu Pivot-Formular klicken.

Anmerkung Die Änderungen, die an mit einem PivotTable-Formular gespeicherten Daten vorgenommen wurden, gelten nur für dieses Formular, nicht jedoch für Daten in der zugrunde liegenden Tabelle.


 Speichern einer Kopie eines Datenbankobjekts unter einem anderen Objekttyp

Speichern einer Kopie eines Datenbankobjekts unter einem anderen Objekttyp

  1. Wenn es sich bei dem Datenbankobjekt, das als anderer Objekttyp gespeichert werden soll, um eine Tabelle oder eine Ansicht handelt, schließen Sie das Objekt.

  2. Ist das Datenbankobjekt geöffnet und im Datenbankfenster ausgewählt, klicken Sie im Menü Datei auf Speichern unter.

    Ist das Objekt nicht geöffnet, klicken Sie im Datenbankfenster auf Objekte und anschließend auf den gewünschten Objekttyp. Wählen Sie das Objekt aus und klicken Sie dann im Menü Datei auf Speichern unter.

  3. Geben Sie im Dialogfeld Speichern unter in das Kästchen Objektnamen speichern in einen eindeutigen Namen unter Beachtung der Microsoft Access-Benennungsregeln für Objekte ein und klicken Sie dann auf den gewünschten Objekttyp. Wenn Sie sich in einer Microsoft Access-Datenbank befinden, welche ein Designmaster ist, und das neue Objekt in andere Datenbanken replizieren möchten, aktivieren Sie das Kontrollkästchen Dieses Objekt replizieren.

Anmerkungen

  • Sie können eine Tabelle, eine Ansicht oder eine Abfrage als Formular oder als Bericht speichern. Das dadurch entstehende Objekt entspricht Objekten, die unter Verwendung von AutoFormular beziehungsweise AutoBericht erstellt werden.

  • Sie können Formulare als Bericht und Makros als Visual Basic-Modul speichern. Berichte, Datenzugriffsseiten oder Module können jedoch nicht als andere Objekttypen gespeichert werden.

  • Der Befehl Speichern unter ist nicht verfügbar, wenn eine gespeicherte Prozedur oder ein Datenbankdiagramm im Datenbankfenster in einem Access-Projekt ausgewählt wurde.

  • Weitere Informationen zum Thema Speichern von Änderungen an freigegebenen Access-Datenbanken.


 Speichern eines Datenbankobjekts unter Verwendung eines Makros

Speichern eines Datenbankobjekts unter Verwendung eines Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Klicken Sie in einer leeren Aktionszeile in der Aktionsliste auf Speichern und geben Sie für das Argument Objekttyp den Typ des zu speichernden Objekts und für das Argument Objektname den Namen des Objekts an.

  3. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  4. Führen Sie das Makro aus.

    Wie wird's gemacht?

    Um beispielsweise ein Formular durch Klicken auf eine Befehlsschaltfläche im Formular zu speichern, geben Sie für die OnClick-Eigenschaft der Schaltfläche den Namen des Makros an.

Um weitere Informationen zur Aktion Speichern zu erhalten, klicken Sie auf [image] .


 Speichern eines Datenbankobjekts unter Verwendung einer Ereignisprozedur

Speichern eines Datenbankobjekts unter Verwendung einer Ereignisprozedur

  1. Öffnen Sie die Ereignisprozedur für das entsprechende Ereignis im Code-Fenster.

    Wie wird's gemacht?

    Um beispielsweise ein Formular durch Klicken auf eine Befehlsschaltfläche im Formular zu speichern, öffnen Sie die Ereignisprozedur Click der Schaltfläche.

  2. Verwenden Sie die Save-Methode, um die Aktion Speichern in der Prozedur ausführen zu können, und geben Sie für das Argument Objekttyp den Typ des zu speichernden Objekts und für das Argument Objektname den Namen des Objekts an.

    Wie wird's gemacht?

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Um weitere Informationen zur Aktion Speichern zu erhalten, klicken Sie auf [image] .


 Speichern einer SQL-Anweisung für ein Formular oder einen Bericht als Abfrage

Speichern einer SQL-Anweisung für ein Formular oder einen Bericht als Abfrage

Wenn Sie die SQL-Anweisung, die die Einstellung der Eigenschaft Datenherkunft eines Formulars oder Berichts anzeigt, als Abfrage speichern, können Sie diese unabhängig ausführen oder neue Formulare und Berichte dieser Abfrage zugrunde legen.

  1. Öffnen Sie ein Formular in der Formularentwurfsansicht oder einen Bericht in der Berichtsentwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer oder auf den Berichtsmarkierer, um das Eigenschaftenfenster des Formulars oder Berichts zu öffnen.

  3. Klicken Sie neben dem Einstellungsfeld der Eigenschaft Datenherkunft auf die Generator-Schaltfläche [image] , um die Abfrageentwurfsansicht anzuzeigen.

  4. Klicken Sie in der Symbolleiste auf Speichern [image] .

  5. Geben Sie im Dialogfeld Speichern unter einen Namen ein, der den Microsoft Access-Konventionen zur Objektbenennung entspricht, und klicken Sie dann auf OK.

    Microsoft Access fügt die Abfrage zu Abfragen [image] unter Objekte im Datenbankfenster hinzu.


 Verwenden des Befehls Speichern unter zum Kopieren eines Datenbankobjekts

Verwenden des Befehls Speichern unter zum Kopieren eines Datenbankobjekts

  1. Wenn es sich bei dem Datenbankobjekt, das Sie speichern möchten, um eine Tabelle, ein Modul oder eine Ansicht handelt, schließen Sie das Objekt.

  2. Ist das Datenbankobjekt geöffnet und im Datenbankfenster ausgewählt, klicken Sie im Menü Datei auf Speichern unter.

    Ist dies nicht der Fall, klicken Sie im Datenbankfenster zunächst auf den entsprechenden Objekttyp, anschliessend auf das Objekt selbst und dann im Menü Datei auf Speichern unter.

  3. Geben Sie im Dialogfeld Speichern unter einen eindeutigen Namen unter Beachtung der Microsoft Access-Benennungsregeln für Objekte ein, und klicken Sie dann auf OK. Wenn Sie sich in einer Microsoft Access-Datenbank befinden, bei der es sich um einen Designmaster handelt, und das neue Objekt in andere Datenbanken replizieren möchten, aktivieren Sie das Kontrollkästchen Dieses Objekt replizieren.

    Um weitere Information zum Exportieren von Objekten und Daten zu erhalten, klicken Sie auf [image] .

Anmerkungen

  • Bei Verwendung dieser Prozedur zur Erstellung einer Kopie einer Datenzugriffsseite werden Sie von Microsoft Access zur Eingabe eines Namens für die neue HTML-Datei aufgefordert.

  • Weitere Informationen über Speichern von Änderungen an freigegebenen Access-Datenbanken


 Anpassen der Größe und der Proportionen eines Bildes, das in einem Bild-Steuerelement oder Objektfeld angezeigt wird

Anpassen der Größe und der Proportionen eines Bildes, das in einem Bild-Steuerelement oder Objektfeld angezeigt wird

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.
  2. Stellen Sie sicher, dass das Bild-Steuerelement, das gebundene Objektfeld oder das ungebundene Objektfeld ausgewählt ist.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster anzuzeigen.

  4. Klicken Sie im Einstellungsfeld für die Eigenschaft Größenanpassung auf eine der folgenden Einstellungen:
    • Abschneiden Zeigt das Bild in der tatsächlichen Größe an. Ist das Bild größer als der Bereich innerhalb des Steuerelements, so wird es abgeschnitten.

    • Dehnen Passt die Größe des Bildes dem Bereich innerhalb des Steuerelements an. Bei dieser Einstellung ist das Bild möglicherweise verzerrt.

    • Zoomen Zeigt das gesamte Bild an, nachdem seine Größe entweder in der Höhe oder in der Breite dem Bereich innerhalb des Steuerelements angepasst worden ist. Bei dieser Einstellung wird das Bild nicht verzerrt.


Markieren von Feldern, die zum Entwurfsbereich einer Abfrage oder eines Spezialfilters hinzugefügt werden sollen

Aufgabe | Ausführung
Markieren eines Feldes | Klicken Sie auf den Feldnamen.
Markieren eines Felderblocks | Klicken Sie auf das erste Feld des Blocks, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf das letzte Feld.
Markieren von nicht angrenzenden Feldern | Halten Sie die STRG-TASTE gedrückt, während Sie nacheinander auf die gewünschten Felder klicken.
Markieren aller Felder | Doppelklicken Sie auf die Titelleiste der Feldliste, oder klicken Sie auf das Sternchen (*). (Zum Anzeigen weiterer Informationen zur Verwendung des Sternchens klicken Sie auf [image] .

Anmerkungen

  • Nach dem Markieren von Feldern in der Feldliste müssen Sie diese in den Entwurfsbereich ziehen.

  • Wenn Sie mehrere Felder gleichzeitig in den Entwurfsbereich ziehen, fügt Microsoft Access jedes Feld in eine separate Spalte ein. Wenn Sie das Sternchen in den Entwurfsbereich ziehen, fügt Microsoft Access den Tabellen- oder Abfragenamen in eine Spalte ein und fügt dem Namen einen Punkt und ein Sternchen hinzu (z. B. Kategorien.*). Das Datenblatt sieht nach jeder dieser Operationen gleich aus.

  • Sie können Felder statt durch Ziehen auch durch Doppelklicken auf den Feldnamen in der Feldliste oder durch Markieren im Listenfeld in der Zeile Feld des Entwurfsbereichs in den Entwurfsbereich einfügen.


 Ändern der Anzahl der Durchläufe von Lauftext auf einer Datenzugriffsseite

Ändern der Anzahl der Durchläufe von Lauftext auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Lauftext-Steuerelement aus, klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Damit ununterbrochen ein Bildlauf durch den Text durchgeführt werden kann, geben Sie im Einstellungsfeld Loop -1 ein.

    • Damit eine bestimmte Anzahl an Bildläufen durch einen Text durchgeführt wird, geben Sie im Einstellungsfeld Loop eine Ganzzahl ein. Stellen Sie zum Beispiel die Loop-Eigenschaft auf 5, werden fünf Durchläufe durch den Text durchgeführt.


 Ändern der Bewegung von Lauftext auf einer Datenzugriffsseite

Ändern der Bewegung von Lauftext auf einer Datenzugriffsseite

  1. Öffnen Sie eine Datenzugriffsseite in der Entwurfsansicht.

  2. Wählen Sie das Lauftext-Steuerelement aus, klicken Sie dann in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster des Steuerelements anzuzeigen.

  3. Führen Sie einen der folgenden Schritte aus:
    • Damit der Bildlauf ununterbrochen wie ein Börsenticker in dem Steuerelement durchgeführt wird, klicken Sie im Einstellungsfeld Behavior auf scroll.

    • Damit der Text vom Anfangspunkt zum gegenüber liegenden Rand des Steuerelements verschoben werden kann und auf dem Bildschirm bleibt, klicken Sie im Einstellungsfeld Behavior auf slide.

    • Damit der Text sich zwischen dem Anfangspunkt und dem Rand des Steuerelements hin und her bewegen kann und sich dabei zu jedem Zeitpunkt auf dem Bildschirm befindet, klicken Sie im Einstellungsfeld Behavior auf alternate.


 Auswählen eines einzelnen Textfeldes oder eines anderen Steuerelements in einer Gruppe

Auswählen eines einzelnen Textfeldes oder eines anderen Steuerelements in einer Gruppe

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf ein beliebiges Steuerelement in der Gruppe, um die Gruppe auszuwählen.

  3. Klicken Sie auf das Steuerelement, das Sie auswählen möchten.

Anmerkungen

  • Beim Auswählen eines einzelnen Steuerelements aus einer Gruppe stehen im Eigenschaftenfenster alle Eigenschaften dieses Steuerelements zur Verfügung.

  • Wenn Sie auf ein beliebiges Steuerelement innerhalb einer Gruppe klicken, um die gesamte Gruppe auszuwählen, werden im Eigenschaftenfenster nur die Eigenschaften angezeigt, die alle Steuerelemente innerhalb der Gruppe besitzen.


 Senden von Befehlen an eine SQL-Datenbank unter Verwendung einer SQL Pass-Through-Abfrage

Senden von Befehlen an eine SQL-Datenbank unter Verwendung einer SQL Pass-Through-Abfrage

SQL Pass-Through-Abfragen in Microsoft Access senden Befehle direkt an einen ODBC-Datenbank-Server, wie z. B. Microsoft FoxPro. Mit Hilfe von SQL Pass-Through-Abfragen arbeiten Sie direkt mit den Tabellen des Servers, anstatt sie zu verknüpfen.

  1. Klicken Sie im Datenbankfenster unter Objekte auf Abfragen [image] und dann auf Neu in der Symbolleiste des Datenbankfensters.

  2. Klicken Sie im Dialogfeld Neue Abfrage auf Neue Abfrage und dann auf OK.

  3. Klicken Sie im Dialogfeld Tabelle anzeigen auf Schließen, ohne Tabellen oder Abfragen hinzuzufügen.

  4. Zeigen Sie im Menü Abfrage auf SQL-spezifisch, und klicken Sie dann auf Pass-Through.

  5. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  6. Stellen Sie im Eigenschaftenfenster die Eigenschaft ODBC-Verbindung ein, um Informationen über die Datenbank anzugeben, zu der Sie eine Verbindung herstellen möchten. Sie können die Verbindungsinformationen entweder direkt eingeben oder auf die Generator-Schaltfläche [image] klicken. Geben Sie dann die Informationen zu dem Server ein, zu dem Sie eine Verbindung herstellen möchten.

    Details zur Syntax Ihrer Abfrage finden Sie in der Dokumentation des SQL-Datenbank-Servers, an den Sie Ihre Abfrage senden möchten.

  7. Wenn es sich bei der Abfrage um einen Typ handelt, der keine Datensätze zurückgibt, legen Sie die Eigenschaft Liefert Datensätze auf Nein fest.

  8. Geben Sie Ihre SQL Pass-Through-Abfrage im Fenster SQL Pass-Through-Abfrage ein.

  9. Um die Abfrage auszuführen, klicken Sie in der Symbolleiste auf Ausführen [image] . (Zum Ausführen einer SQL Pass-Through-Abfrage, die Datensätze zurückgibt, klicken Sie stattdessen in der Symbolleiste auf Abfrageansicht [image] .)

    Gegebenenfalls fordert Microsoft Access weitere Informationen zu Ihrer Microsoft SQL-Server-Datenbank an.

    Vorsicht Wenn Sie eine SQL Pass-Through-Abfrage in einen anderen Abfragetyp, wie z. B. eine Auswahlabfrage, umwandeln, verlieren Sie die eingegebene SQL-Anweisung.

Anmerkungen

  • SQL Pass-Through-Abfragen eignen sich zum Ausführen von gespeicherten Prozeduren auf einem ODBC-Server.

  • Wenn Sie für die Eigenschaft ODBC-Verbindung keine Verbindungszeichenfolge angeben oder eine bestehende löschen, verwendet Microsoft Access die Standardzeichenfolge ODBC. In diesem Fall fordert Microsoft Access Sie bei jedem Ausführen der Abfrage auf, Verbindungsinformationen einzugeben.

  • Einige SQL Pass-Through-Abfragen können außer Daten auch Nachrichten zurückgeben. Wenn Sie die Eigenschaft Meldungen protokollieren der Abfrage auf Ja einstellen, erstellt Microsoft Access eine Tabelle mit allen zurückgegebenen Meldungen. Der Tabellenname setzt sich aus dem Benutzernamen, einem Bindestrich ( - ) und einer fortlaufenden Nummer, die bei 00 beginnt, zusammen. Für den Standard-Benutzernamen ADMIN z. B. lauten die zurückgegebenen Tabellen ADMIN - 00, ADMIN - 01 usw.

    Wenn Sie eine SQL Pass-Through-Abfrage erstellen, die mehrere Ergebnisgruppen zurückgibt, können Sie für jedes Ergebnis eine eigene Tabelle erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Angeben von Argumenten beim Verwenden einer Prozedur, Anweisung oder Methode in Visual Basic-Code

Angeben von Argumenten beim Verwenden einer Prozedur, Anweisung oder Methode in Visual Basic-Code

  • Bestimmen Sie die Argumente unmittelbar nach dem Namen der Prozedur, Anweisung oder Methode. Setzen Sie die Argumente bei einer Funktion-Prozedur oder -Methode, die einen Wert zurückgibt, in Klammern. Wenn Sie mehr als ein Argument festlegen, trennen Sie sie jeweils durch ein Komma.

Die folgende Close-Methode des DoCmd-Objekts schließt zum Beispiel das Formular Produkte hinzufügen. Sie akzeptiert zwei Argumente, acForm and "Produkte hinzufügen":

DoCmd.Close acForm, "Artikel hinzufügen"

Da die Close-Methode keinen Wert zurückgibt, werden die Argumente nicht in Klammern gesetzt.

Tipp Mit Hilfe des Objektkatalogs können Sie in den Visual Basic-Code die Syntax von Methoden oder Eigenschaften einschließlich Argumente einfügen. Der Objektkatalog fügt benannte Argumente ein, die Sie in beliebiger Reihenfolge angeben können. Sie können entweder diese benannten Argumente verwenden oder die benannten Argumente durch Standardargumente ersetzen. Um weitere Informationen zur Verwendung des Objektkatalogs zu erhalten, klicken Sie auf [image] . Um weitere Informationen zur Verwendung von benannten Argumenten zu erhalten, klicken Sie auf [image] .


 Ändern des Standardverhaltens der EINGABETASTE, der Pfeiltasten, von TAB und der Einfügemarke

Ändern des Standardverhaltens der EINGABETASTE, der Pfeiltasten, von TAB und der Einfügemarke

Legen Sie die Optionen zum Standardverhalten fest, um das Verhalten der angegebenen Tasten beim Bewegen innerhalb von und zwischen einzelnen Feldern zu ändern.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Tastatur.

  3. Wählen Sie unter Cursor mit Eingabetaste bewegen, Funktion der Pfeiltasten und Cursorverhalten bei Eintritt in Feld die gewünschten Optionen, und aktivieren bzw. deaktivieren Sie dann das Kontrollkästchen Cursor stoppt bei erstem/letztem Feld.

Anmerkungen

  • Damit Microsoft Access die unter Cursorverhalten bei Eintritt in Feld gewählte Option verwendet, muss Funktion der Pfeiltasten auf Nächstes Feld gesetzt sein.

  • Diese Einstellungen gelten nicht für Datenzugriffsseiten.


 Festlegen der Standardsprache für die Sortierreihenfolge einer Datenbank

Festlegen der Standardsprache für die Sortierreihenfolge einer Datenbank

Legen Sie die alphabetische Sortierreihenfolge fest, die Microsoft Access beim Erstellen einer neuen Datenbank verwenden soll.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Allgemein.

  3. Klicken Sie im Feld Sortierreihenfolge bei neuer DB auf die Sprache, die verwendet werden soll.

Anmerkungen

  • Um die Sortierreihenfolge einer vorhandenen Datenbank auf die auf der Registerkarte Allgemein ausgewählte Sprache zurückzusetzen, komprimieren Sie diese Datenbank.

  • Manche Sprachen, die in früheren Microsoft Access-Versionen in der Liste Sortierreihenfolge bei neuer DB separat aufgeführt wurden, sind nun in der Sortierreihenfolge Allgemein enthalten.

  • Enthält die Datenbank verknüpfte Tabellen aus einer Datenbank, in der eine anderssprachige Sortierreihenfolge gilt, so verwendet Microsoft Access die Sortierreihenfolge Ihrer Datenbank an Stelle der Reihenfolge der Datenbank, in der die Tabelle gespeichert ist.

  • Bei der Synchronisierung von Replikaten in einer Microsoft Access-Datenbank und einer Microsoft SQL Server-Datenbank treten möglicherweise Synchronisierungskonflikte auf, wenn in den beiden Datenbanken unterschiedliche Sprachen für die Sortierreihenfolge gelten.


 Ändern des Standardordners für neue Microsoft Access-Datenbanken, -Projekte oder -Seiten

Ändern des Standardordners für neue Microsoft Access-Datenbanken, -Projekte oder -Seiten

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Allgemein.

  3. Geben Sie im Feld Standarddatenbankordner den Pfadnamen eines gültigen Ordners ein, in dem Sie neue Microsoft Access-Datenbank-Dateien, Microsoft Access-Projekt-Dateien oder Datenzugriffsseiten sowie alle zugehörigen Dateien speichern möchten, und klicken Sie dann auf OK.

    Anmerkung Für Datenzugriffsseiten gilt diese Option nur dann, wenn beim Erstellen und Speichern der Seite gleichzeitig eine Access-Datenbank oder ein Access-Projekt geöffnet ist. Andernfalls wird die Seite im Standardordner für Ihr System gespeichert.


 Einstellen der Ränder und anderer Optionen für die Seiteneinrichtung einer Datenzugriffsseite

Einstellen der Ränder und anderer Optionen für die Seiteneinrichtung einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Datei auf Seite einrichten.

  3. Legen Sie im Dialogfeld Seitenformat Optionen für Papierformat, Kopf- und Fußzeilen, Seitenorientierung und Ränder fest.


 Festlegen von Druckereinrichtungsoptionen für Tabellen, Abfragen, Formulare oder Berichte

Festlegen von Druckereinrichtungsoptionen für Tabellen, Abfragen, Formulare oder Berichte

  1. Öffnen Sie das Datenbankobjekt in einer der folgenden Ansichten:
    • Öffnen Sie eine Tabelle oder Abfrage in der Datenblattansicht oder der Seitenansicht.

    • Öffnen Sie ein Formular oder einen Bericht in einer beliebigen Ansicht (oder im Datenbankfenster).

    Anmerkung Die Druckereinrichtungsoptionen sind bei Makros oder Modulen nicht verfügbar.

  2. Klicken Sie im Menü Datei auf Seitenformat.

  3. Klicken Sie auf die folgenden Registerkarten, um die gewünschten Optionen festzulegen:
    • Ränder. Seitenränder einstellen und Festlegung, ob nur Daten gedruckt werden (für Formulare und Berichte) oder Überschriften gedruckt werden (für Tabellen und Abfragen).

    • Seite. Ausrichtung, Papiergröße, Papierzufuhr und Drucker einstellen.

    • Spalten. Anzahl, Breite und Layout von Spalten (für Formulare und Berichte) einstellen.
  4. Klicken Sie auf OK.

    Microsoft Access speichert die Einstellungen der Druckereinrichtungsoptionen zusammen mit einem Formular oder Bericht, so dass Sie diese Optionen für ein gegebenes Formular oder einen bestimmten Bericht nur einmal festzulegen brauchen. Für Tabellen, Abfragen und Module müssen Sie die Druckereinrichtungsoptionen dagegen vor jedem Druckvorgang neu festlegen.


 Einstellen von Datenzugriffsseiteneigenschaften in Visual Basic

Einstellen von Datenzugriffsseiteneigenschaften in Visual Basic

DataAccessPage-Objekte sind Microsoft Access-Objekte. Eigenschaften für diese Objekte können Sie in einer Sub-Prozedur, einer Funktion oder einer Ereignisprozedur einstellen.

So stellen Sie eine Eigenschaft für eine Datenzugriffsseite ein

Verweisen Sie in der DataAccessPages-Auflistung auf die einzelne Datenzugriffsseite, gefolgt von dem Namen der Eigenschaft und ihrem Wert. Um z. B. die Visible-Eigenschaft der Datenzugriffsseite Kunden auf True (-1) einzustellen, verwenden Sie die folgende Codezeile:

DataAccessPages!Kunden.Visible = True

Anmerkungen

  • Zu jeder Eigenschaft, die Sie einstellen möchten, können Sie folgende Informationen im Hilfeindex nachschlagen:
    • Ob die Eigenschaft in Visual Basic eingestellt werden kann.

    • Welche Werte zum Einstellen der Eigenschaft verwendet werden sollten. Oft verwenden Sie andere Einstellungen, wenn Sie eine Eigenschaft in Visual Basic statt im Eigenschaftenfenster einstellen. Wenn die Eigenschafteneinstellungen z. B. in einer Liste ausgewählt werden, müssen Sie für jede Auswahl den jeweiligen Wert oder seine numerische Entsprechung verwenden.


 Einstellen von Formular-, Berichts- und Steuerelementeigenschaften in Visual Basic

Einstellen von Formular-, Berichts- und Steuerelementeigenschaften in Visual Basic

Form-, Report- und Control-Objekte sind Microsoft Access-Objekte. Eigenschaften für diese Objekte können Sie in einer Sub-Prozedur, einer Funktion oder einer Ereignisprozedur einstellen. Darüber hinaus können Sie Eigenschaften für Bereiche in Formularen und Berichten einstellen.

So stellen Sie eine Eigenschaft für ein Formular oder einen Bericht ein

Verweisen Sie in der Forms- bzw. der Reports-Auflistung auf das einzelne Formular bzw. den einzelnen Bericht, gefolgt von dem Namen der Eigenschaft und ihrem Wert. Um z. B. die Visible-Eigenschaft des Formulars Kunden auf True (-1) einzustellen, verwenden Sie die folgende Codezeile:

Formulare!Kunden.Visible = True

Sie können eine Eigenschaft für ein Formular oder einen Bericht auch im Modul des Objekts unter Verwendung der Me-Eigenschaft des Objekts einstellen. Code, der die Me-Eigenschaft verwendet, wird schneller ausgeführt als Code, der einen vollständigen Objektnamen enthält. Um z. B. im Formularmodul Kunden die RecordSource-Eigenschaft des Formulars Kunden auf eine SQL-Anweisung einzustellen, die sämtliche Datensätze zurückgibt, deren Eintrag im Feld Firma mit "A" anfängt, verwenden Sie die folgende Codezeile:

Me!RecordSource = "SELECT * FROM Kunden " _
    & "WHERE Firma Like 'A*'"

So stellen Sie eine Eigenschaft für ein Steuerelement ein

Verweisen Sie auf das Steuerelement in der Controls-Auflistung des Form- oder Report-Objekts, auf dem es sich befindet. Sie können auf die Controls-Auflistung implizit oder explizit verweisen; der Code wird bei einem impliziten Verweis jedoch schneller ausgeführt. In den folgenden Beispielen wird die Visible-Eigenschaft eines Textfeldes namens Kunden-Nr im Formular Kunden eingestellt:

' Schnelleres Verfahren.
Me![Kunden-Nr].Visible = True
' Langsameres Verfahren.
Formulare!Kunden.Controls![Kunden-Nr].Visible = True

Am schnellsten stellen Sie eine Eigenschaft für ein Steuerelement im Objektmodul unter Verwendung der Me-Eigenschaft ein. Mit dem folgenden Code können Sie die Visible-Eigenschaft eines Textfeldes namens Kunden-Nr im Formular Kunden umschalten:

With Me![Kunden-Nr]
    .Visible = Not .Visible
End With

So stellen Sie eine Eigenschaft für einen Formular- oder Berichtsbereich ein

Verweisen Sie in der Forms- bzw. der Reports-Auflistung auf das Formular bzw. den Bericht, gefolgt von der Section-Eigenschaft und der Ganzzahl bzw. der Konstante, die den Bereich kennzeichnet. Im folgenden Beispiel wird die Visible-Eigenschaft des Bereichs Seitenkopf im Formular Kunden auf False (0) eingestellt:

Formulare!Kunden.Section(3).Visible = False
Me!Section(acPageHeader).Visible = False

Anmerkungen

  • Zu jeder Eigenschaft, die Sie einstellen möchten, können Sie folgende Informationen im Hilfeindex nachschlagen:
    • Ob die Eigenschaft in Visual Basic eingestellt werden kann.

    • Die Ansichten, in denen die Eigenschaft eingestellt werden kann. Nicht alle Eigenschaften können in allen Ansichten eingestellt werden. So können Sie z. B. die BorderStyle-Eigenschaft eines Formulars nur in der Formular-Entwurfsansicht einstellen.

    • Welche Werte zum Einstellen der Eigenschaft verwendet werden sollten. Oft verwenden Sie andere Einstellungen, wenn Sie eine Eigenschaft in Visual Basic statt im Eigenschaftenfenster einstellen. Wenn die Eigenschafteneinstellungen z. B. in einer Dropdownliste ausgewählt werden, müssen Sie für jede Auswahl den jeweiligen Wert oder seine numerische Entsprechung verwenden.
  • Zum Einstellen der Standardeigenschaften für Steuerelemente in Visual Basic verwenden Sie die DefaultControl-Methode.


 Einstellen von Optionen in Visual Basic

Einstellen von Optionen in Visual Basic

Mit der SetOption- und der GetOption-Methode können Sie aus Code heraus Optionswerte im Dialogfeld Optionen einstellen bzw. zurückgeben. Um das Dialogfeld Optionen anzuzeigen, klicken Sie im Menü Extras auf Optionen.

In den folgenden Tabellen sind die Namen aller Optionen aufgeführt, die über Code eingestellt oder zurückgegeben werden können, geordnet nach den Registerkarten, auf denen sich die Optionen im Dialogfeld Optionen befinden. Weiter ist für jede Option das Zeichenfolgenargument angegeben, das Sie der SetOption- oder der GetOption-Methode übergeben.

Anmerkungen

Wenn Ihre Datenbank mit einer Microsoft Access-Version in einer anderen Sprache als derjenigen, in der Sie sie erstellt haben, ausgeführt werden soll, müssen Sie die Argumente für die GetOption- und die SetOption-Methode in Englisch mit ausliefern (diese sind hinter dem deutschen Argument jeweils in Klammern angegeben).

Einige Optionen stehen nur in einer Microsoft Access-Datenbank (.mdb) bzw. in einem Access-Projekt (.adp) zur Verfügung. Diese Ausnahmen sind mit (nur MDB) bzw. (nur ADP) gekennzeichnet.

Registerkarte "Ansicht"

Optionstext | Zeichenfolgenargument
Anzeigen |
Statusleiste | Statuszeile anzeigen (Show Status Bar)
Start-Dialogfeld | Start-Dialogfeld anzeigen (Show Startup Dialog Box)
Neue Objektverknüpfungen | Neue Objektverknüpfungen anzeigen (Show New Object Shortcuts)
Ausgeblendete Objekte | Ausgeblendete Objekte anzeigen (Show Hidden Objects)
Systemobjekte | Systemobjekte anzeigen (Show System Objects)
Fenster in Taskleiste | Fenster in Taskleiste anzeigen (Use Taskbar For Each Document)
Im Makroentwurf anzeigen |
Namenspalte | Spalte 'Makroname' einblenden (Show Macro Names Column)
Bedingungsspalte | Spalte 'Bedingung' einblenden (Show Conditions Column)
Klickoptionen im Datenbankfenster | Klickverhalten des Datenbank-Explorer (Database Explorer Click Behavior)
Ersatzschriftartunterstützung | Schriftartenwechsel zulassen (Enable Font Switching)
Ersatzschriftart benutzen | Schriftart ersetzen (Substitute Font Name)

Registerkarte "Allgemein"

Optionstext | Zeichenfolgenargument
Druckbereiche |
Linker Rand | Linker Rand (Left Margin)
Rechter Rand | Rechter Rand (Right Margin)
Oberer Rand | Oberer Rand (Top Margin)
Unterer Rand | Unterer Rand (Bottom Margin)
Standarddatenbankordner | Standarddatenbankordner (Default Database Directory)
Audiofeedback | Audiofeedback (Provide Feedback With Sound)
Liste zuletzt geöffneter Dateien | MRU-Dateiliste zulassen (Enable MRU File List)
Anzahl zuletzt geöffneter Dateien | Größe der MRU-Dateiliste (Size of MRU File List)
Sortierreihenfolge bei neuer DB (nur MDB) | Sortierreihenfolge bei neuer DB (New Database Sort Order)
Beim Schließen komprimieren | Automatisch komprimieren (Auto Compact)
Komprimieren, wenn Verkleinerung um mind. folgenden Prozentsatz möglich | Prozentangabe für automatisches Komprimieren (Auto Compact Percentage)
Objektnamen-AutoKorrektur (nur MDB) |
Informationen aufzeichnen | Objektnamen-Autokorrektur-Änderungen aufzeichnen (Track Name AutoCorrect Info)
Ausführen | Objektnamen-Autokorrektur ausführen (Perform Name AutoCorrect)
Änderungen protokollieren | Objektnamen-Autokorrektur-Änderungen protokollieren (Log Name AutoCorrect Changes)

Schaltfläche "Weboptionen" (Registerkarte "Allgemein")

Die Optionen in Kursivschrift sind aus Gründen der Abwärtskompatibilität aufgeführt. Mit Ausnahme der Option Hyperlink-Adressen in Statusleiste anzeigen sind alle anderen Optionen ausgeblendet, können jedoch mit der SetOption-Methode eingestellt werden. Weitere Informationen zu Weboptionen finden Sie unter DefaultWebOptions.

Optionstext | Zeichenfolgenargument
Hyperlinkfarbe | Hyperlinkfarbe (Hyperlink Color)
Farbe für besuchten Hyperlink | Farbe für besuchten Hyperlink (Followed Hyperlink color)
Hyperlinks unterstreichen | Hyperlinks unterstreichen (Underline Hyperlinks)
Hyperlink-Adressen in Statusleiste anzeigen | Anmerkung Nicht gültig für Microsoft Access 2000. Adresse wird in QuickInfos angezeigt.
HTML-Vorlage | HTML-Vorlage (HTML Template)
Datenquellenname | Datenquellenname (Data Source Name)
Benutzername | Benutzername (User Name)
Benutzerkennwort | Kennwort (Password)
Server-URL | Active Server Pages URL
Sitzungstimeout (min) | Active Server Pages-Sitzungs-Timeout (Active Server Pages Session Timeout)

Registerkarte "Bearbeiten/Suchen"

Optionstext | Zeichenfolgenargument
Suchen/Ersetzen-Standard | Suchen/Ersetzen-Standard (Default Find/Replace Behavior)
Bestätigen |
Datensatzänderungen | Datensatzänderung bestätigen (Confirm Record Changes)
Löschen von Dokumenten | Objektlöschen bestätigen (Confirm Document Deletions)
Aktionsabfragen (nur MDB) | Aktionsabfragen bestätigen (Confirm Action Queries)
Liste anzeigen von Werten in (nur MDB) |
Lokalen indizierten Feldern | Indizierte Werte anzeigen (Show Values In Indexed)
Lokalen nicht indizierten Feldern | Nicht indizierte Werte anzeigen (Show Values In Non-Indexed)
ODBC-Feldern | ODBC-Werte anzeigen (Show Values In Remote)
Keine Listen anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird | Wertanzeigemaximum (Show Values Limit)
Liste anzeigen von Werten in (nur ADP) |
Datensätzen im lokalen Snapshot | Datensätze in lokalem Snapshot anzeigen (Show Values In Snapshot)
Datensätzen auf dem Server | Datensätze auf dem Server anzeigen (Show Values In Server)
Keine Listen anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird | Wertanzeigemaximum (Show Values Limit)

Registerkarte "Tastatur"

Optionstext | Zeichenfolgenargument
Cursor mit Eingabetaste bewegen | Markierung mit Eingabetaste bewegen (Move After Enter)
Cursorverhalten bei Eintritt in Feld | Cursorverhalten bei Eintritt in Feld (Behavior Entering Field)
Funktion der Pfeiltasten | Funktion der Pfeiltasten (Arrow Key Behavior)
Cursor stoppt bei erstem/letztem Feld | Cursor stoppt bei erstem/letztem Feld (Cursor Stops at First/Last Field)

Registerkarte "Datenblatt"

Optionstext | Zeichenfolgenargument
Standardfarben |
Schriftart | Standardschriftfarbe (Default Font Color)
Hintergrund | Standardhintergrundfarbe (Default Background Color)
Gitternetzlinien | StandardGitternetzlinienfarbe (Default Gridlines Color)
StandardGitternetzlinien |
Horizontal | Horizontale Gitternetzlinien (Default Gridlines Horizontal)
Vertikal | Vertikale Gitternetzlinien (Default Gridlines Vertical)
Standardspaltenbreite | Standardspaltenbreite (Default Column Width)
Standardschriftart |
Schriftart | Standardschriftart (Default Font Name)
Schriftschnitt | Standardschriftbreite (Default Font Weight)
Größe | Standardschriftgröße (Default Font Size)
Kursiv | Standardschrift kursiv (Default Font Italic)
Unterstrichen | Standardschrift unterstrichen (Default Font Underline)
Standardzelleffekt | Standard-Feldeffekt (Default Cell Effect)
Animationen anzeigen | Animationen anzeigen (Show Animations)

Registerkarte "Formulare/Berichte"

Optionstext | Zeichenfolgenargument
Markierungsverhalten | Objektmarkierung (Selection Behavior)
Formularvorlage | Formularvorlage (Form Template)
Berichtsvorlage | Berichtsvorlage (Report Template)
Ereignisprozedur immer verwenden | Ereignisprozedur immer verwenden (Always Use Event Procedures)

Registerkarte "Weitere" (nur MDB)

Optionstext | Zeichenfolgenargument
DDE-Anfragen ignorieren | DDE-Anfragen ignorieren (Ignore DDE Requests)
DDE-Aktualisierung ermöglichen | DDE-Aktualisierung ermöglichen (Enable DDE Refresh)
Standardöffnungsmodus | Öffnungsmodus für Datenbanken (Default Open Mode for Databases)
Befehlszeilenargumente | Befehlszeilenargumente (Command-Line Arguments)
OLE/DDE-Timeout (s) | OLE/DDE-Timeout (s) (OLE/DDE Timeout (Sec))
Anzahl der Datenaktualisierungsversuche | Anzahl d. Datenaktualisierungsversuche (Number of Update Retries)
Intervall für ODBC-Anzeigeaktualisierung (s) | ODBC-Anzeigeaktualisierungsintervall (s) (ODBC Refresh Interval (Sec))
Intervall für Anzeigeaktualisierung (s) | Anzeigeaktualisierungsintervall (s) (Refresh Interval (Sec))
Intervall für Datenaktualisierung (ms) | Datenaktualisierungsintervall (ms) (Update Retry Interval (Msec))
Standard bei Datensatzsperrung | Standard bei Datensatzsperrung (Default Record Locking)
DB mit Sperrung auf Datensatzebene öffnen | DB mit Sperrung auf Datensatzebene öffnen (Use Record Level Locking)

Registerkarte "Weitere" (nur ADP)

Optionstext | Zeichenfolgenargument
DDE-Anfragen ignorieren | DDE-Anfragen ignorieren (Ignore DDE Requests)
DDE-Aktualisierung ermöglichen | DDE-Aktualisierung ermöglichen (Enable DDE Refresh)
Vorgabe der max. Datensätze | Reihengrenzwert (Row Limit)
Login und Kennwort speichern | Login und Kennwort speichern (Save Login And Password)
Befehlszeilenargumente | Befehlszeilenargumente (Command-Line Arguments)
OLE/DDE-Timeout (s) | OLE/DDE-Timeout (s) (OLE/DDE Timeout (Sec))

Registerkarte "Tabellen/Abfragen" (nur MDB)

Optionstext | Zeichenfolgenargument
Standardfeldgröße |
Text | Standardtextfeldgröße (Default Text Field Size)
Zahl | Standardzahlenfeldgröße (Default Number Field Size )
Standardfeldtyp | Standardfeldtyp (Default Field Type)
AutoIndex bei Importieren/Erstellen | AutoIndex bei Importieren/Erstellen (AutoIndex On Import/Create)
Tabellennamen anzeigen | Tabellennamen anzeigen (Show Table Names)
Alle Felder ausgeben | Alle Felder ausgeben (Output All Fields)
AutoVerknüpfung aktivieren | AutoVerknüpfung aktivieren (Enable AutoJoin)
Ausführungsberechtigungen | Ausführungsberechtigungen (Run Permissions)

Anmerkung Achten Sie beim Entwickeln einer Datenbankanwendung, eines Add-Ins, einer Bibliotheksdatenbank oder einer referenzierten Datenbank darauf, dass die Option Fehlerbehebung auf 2 (Bei unbehandelten Fehlern anhalten) eingestellt ist, sobald Sie die Fehlersuche im Code beendet haben.

Der Wert, den Sie der SetOption-Methode als Argument Einstellung übergeben, hängt vom einzustellenden Optionstyp ab. Die folgende Tabelle liefert einige Richtlinien für die Optionseinstellung.

Entspricht die Option | Dann entspricht das Argument Einstellung
Einem Textfeld | Einer Zeichenfolge
Einem Kontrollkästchen | Einem booleschen Wert: True (-1) oder False (0)
Einem Optionsfeld in einer Optionsgruppe oder einer Option in einem Kombinationsfeld oder einem Listenfeld | Einer Ganzzahl, die der Optionsposition in der Optionsgruppe oder Liste entspricht (und bei Null [0] beginnt)


 Einstellen der Eigenschaften von ActiveX Data Objects in Visual Basic

Einstellen der Eigenschaften von ActiveX Data Objects in Visual Basic

ADO (ActiveX Data Objects)-Objekte ermöglichen es Ihnen, die Struktur einer Datenbank und der darin enthaltenen Daten von Visual Basic aus zu bearbeiten. Viele ADO-Objekte entsprechen Objekten, die Sie in Ihrer Datenbank sehen können; z.B. entspricht ein Table-Objekt einer Microsoft Access-Tabelle, und ein Field-Objekt entspricht einem Feld in einer Tabelle.

Die meisten Eigenschaften, die Sie für ADO-Objekte einstellen können, sind ADO-Eigenschaften. Diese Eigenschaften werden von der Microsoft Jet-Datenbank-Engine definiert und in jeder Anwendung, die die Jet-Datenbank-Engine enthält, auf die gleiche Weise eingestellt. Einige Eigenschaften, die Sie für ADO-Objekte einstellen können, werden von Microsoft Access definiert und von der Jet-Datenbank-Engine nicht automatisch erkannt. Wie Eigenschaften von ADO-Objekten eingestellt werden, hängt davon ab, ob eine Eigenschaft von der Jet-Datenbank-Engine oder von Microsoft Access definiert wurde.

Einstellen von ADO-Eigenschaften für ADO-Objekte

Um eine von der Jet-Datenbank-Engine definierte Eigenschaft einzustellen, verweisen Sie in der ADO-Hierarchie auf das betreffende Objekt. Am einfachsten und schnellsten gehen Sie hierbei vor, indem Sie zunächst Objektvariablen erstellen, die auf die verschiedenen Objekte, mit denen Sie arbeiten, verweisen. In den nachfolgenden Codeschritten verweisen Sie dann auf diese Objektvariablen. Beispielsweise erstellt der folgende Code ein neues Table-Objekt und stellt dessen Name-Eigenschaft ein:

Dim tbl As New ADOX.Table
Dim cnn As ADODB.Connection
Set cnn = CurrentProject.Connection
tbl.Name = "Kontakte"

Einstellen von Microsoft Access-Eigenschaften für ADO-Objekte

Wenn Sie eine von Microsoft Access definierte Eigenschaft einstellen, die jedoch ein ADO-Objekt betrifft, erkennt die Jet-Datenbank-Engine diese nicht automatisch als gültige Eigenschaft. Beim ersten Einstellen der Eigenschaft erstellen Sie zuerst die Eigenschaft und fügen sie dann an die Properties-Auflistung des Objekts an, für das sie gilt. Sobald sich die Eigenschaft in der Properties-Auflistung befindet, kann sie genauso wie jede ADO-Eigenschaft eingestellt werden.

Wird die Eigenschaft zum ersten Mal in der Benutzeroberfläche eingestellt, so wird sie automatisch zur Properties-Auflistung hinzugefügt, und Sie können sie wie üblich einstellen.

Wenn Sie Prozeduren schreiben, um von Microsoft Access definierte Eigenschaften einzustellen, erstellen Sie Fehlerbehandlungscode zur Überprüfung, ob die einzustellende Eigenschaft in der Properties-Auflistung bereits vorhanden ist. Weitere Informationen finden Sie im Hilfethema zur Add-Methode oder in den Themen zu bestimmten Eigenschaften.

Denken Sie beim Erstellen einer Eigenschaft daran, zuerst die Type-Eigenschaft anzugeben, bevor Sie sie an die Properties-Auflistung anfügen. Sie können die Type-Eigenschaft anhand der Informationen festlegen, die im Abschnitt "Einstellungen" des Hilfethemas zu einer Eigenschaft aufgeführt sind. Die folgende Tabelle enthält Richtlinien, mit denen sich die korrekte Einstellung der Type-Eigenschaft ermitteln lässt.

Eigenschafteneinstellung | Erforderliche Einstellung der Type-Eigenschaft
Eine Zeichenfolge | adLongVarWChar or adVarWChar
True/False | adBoolean
Eine Ganzzahl | adInteger

In der folgenden Tabelle sind einige von Microsoft Access definierte Eigenschaften aufgeführt, die ADO-Objekte betreffen.

ADO-Objekt | Von Microsoft Access definierte Eigenschaften
Connection | AppTitle, AppIcon, StartupShowDBWindow, StartupShowStatusBar, AllowShortcutMenus, AllowFullMenus, AllowBuiltInToolbars, AllowToolbarChanges, AllowBreakIntoCode, AllowSpecialKeys, Replicable, ReplicationConflictFunction
Table | DatasheetBackColor, DatasheetCellsEffect, DatasheetFontHeight, DatasheetFontItalic, DatasheetFontName, DatasheetFontUnderline, DatasheetFontWeight, DatasheetForeColor, DatasheetGridlinesBehavior, DatasheetGridlinesColor, Description, FrozenColumns, RowHeight, ShowGrid
QueryDef | DatasheetBackColor, DatasheetCellsEffect, DatasheetFontHeight, DatasheetFontItalic, DatasheetFontName, DatasheetFontUnderline, DatasheetFontWeight, DatasheetForeColor, DatasheetGridlinesBehavior, DatasheetGridlinesColor, Description, FailOnError, FrozenColumns, LogMessages, MaxRecords, RecordLocks, RowHeight, ShowGrid, UseTransaction
Field | Caption, ColumnHidden, ColumnOrder, ColumnWidth, DecimalPlaces, Description, Format, InputMask


 Einstellen der Eigenschaften von Datenzugriffsobjekten in Visual Basic

Einstellen der Eigenschaften von Datenzugriffsobjekten in Visual Basic

Datenzugriffsobjekte (Data Access Objects = DAO) ermöglichen es Ihnen, die Struktur einer Datenbank und der darin enthaltenen Daten von Visual Basic aus zu bearbeiten. Viele DAO-Objekte entsprechen Objekten, die Sie in einer Datenbank sehen können; z.B. entspricht ein TableDef-Objekt einer Microsoft Access-Tabelle, und ein Field-Objekt entspricht einem Feld in einer Tabelle.

Die meisten Eigenschaften, die Sie für DAO-Objekte einstellen können, sind DAO-Eigenschaften. Diese Eigenschaften werden von der Microsoft Jet-Datenbank-Engine definiert und in jeder Anwendung, die die Jet-Datenbank-Engine enthält, auf die gleiche Weise eingestellt. Einige Eigenschaften, die Sie für DAO-Objekte einstellen können, werden von Microsoft Access definiert und von der Jet-Datenbank-Engine nicht automatisch erkannt. Wie Eigenschaften von DAO-Objekten eingestellt werden, hängt davon ab, ob eine Eigenschaft von der Jet-Datenbank-Engine oder von Microsoft Access definiert wurde.

Einstellen von DAO-Eigenschaften für DAO-Objekte

Um eine von der Jet-Datenbank-Engine definierte Eigenschaft einzustellen, verweisen Sie in der DAO-Hierarchie auf das betreffende Objekt. Am einfachsten und schnellsten gehen Sie hierbei vor, indem Sie zunächst Objektvariablen erstellen, die für die verschiedenen Objekte, mit denen Sie arbeiten, stehen. In den nachfolgenden Codeschritten verweisen Sie dann auf diese Objektvariablen. Beispielsweise erstellt der folgende Code ein neues TableDef-Objekt und stellt dessen Name-Eigenschaft ein:

Dim dbs As Database, tdf As TableDef
Set dbs = CurrentDb
Set tdf = dbs.CreateTableDef
tdf.Name = "Kontakte"

Einstellen von Microsoft Access-Eigenschaften für DAO-Objekte

Wenn Sie eine von Microsoft Access definierte Eigenschaft einstellen, die jedoch ein DAO-Objekt betrifft, erkennt die Jet-Datenbank-Engine diese nicht automatisch als gültige Eigenschaft. Beim ersten Einstellen der Eigenschaft erstellen Sie zuerst die Eigenschaft und fügen sie dann an die Properties-Auflistung des Objekts an, für das sie gilt. Sobald sich die Eigenschaft in der Properties-Auflistung befindet, kann sie genauso wie jede DAO-Eigenschaft eingestellt werden.

Wird die Eigenschaft zum ersten Mal in der Benutzeroberfläche eingestellt, so wird sie der Properties-Auflistung automatisch hinzugefügt, und Sie können sie wie üblich einstellen.

Wenn Sie Prozeduren schreiben, um von Microsoft Access definierte Eigenschaften einzustellen, erstellen Sie Fehlerbehandlungscode zur Überprüfung, ob die einzustellende Eigenschaft in der Properties-Auflistung bereits vorhanden ist. Weitere Informationen finden Sie im Hilfethema zur CreateProperty-Methode oder in den Themen zu bestimmten Eigenschaften.

Denken Sie beim Erstellen einer Eigenschaft daran, zuerst die Type-Eigenschaft anzugeben, bevor Sie sie an die Properties-Auflistung anfügen. Sie können die Type-Eigenschaft anhand der Informationen festlegen, die im Abschnitt "Einstellungen" des Hilfethemas zu einer Eigenschaft aufgeführt sind. Die folgende Tabelle enthält Richtlinien, mit denen sich die korrekte Einstellung der Type-Eigenschaft ermitteln lässt.

Eigenschafteneinstellung | Erforderliche Einstellung der Type-Eigenschaft
Eine Zeichenfolge | dbText
True/False | dbBoolean
Eine Ganzzahl | dbInteger

In der folgenden Tabelle sind einige von Microsoft Access definierte Eigenschaften aufgeführt, die DAO-Objekte betreffen.

DAO-Objekt | Von Microsoft Access definierte Eigenschaften
Database | AppTitle, AppIcon, StartupShowDBWindow, StartupShowStatusBar, AllowShortcutMenus, AllowFullMenus, AllowBuiltInToolbars, AllowToolbarChanges, AllowBreakIntoCode, AllowSpecialKeys, Replicable, ReplicationConflictFunction
Container vom Typ SummaryInfo | Title, Subject, Author, Manager, Company, Category, Keywords, Comments, Hyperlink Base (Beachten Sie die Registerkarte Zusammenfassung des Dialogfeldes Datenbankname Eigenschaften (Menü Datei, Befehl Datenbankeigenschaften.)
Container vom Typ UserDefined | (Beachten Sie die Registerkarte Zusammenfassung des Dialogfeldes Datenbankname Eigenschaften (Menü Datei, Befehl Datenbankeigenschaften.)
TableDef | DatasheetBackColor, DatasheetCellsEffect, DatasheetFontHeight, DatasheetFontItalic, DatasheetFontName, DatasheetFontUnderline, DatasheetFontWeight, DatasheetForeColor, DatasheetGridlinesBehavior, DatasheetGridlinesColor, Description, FrozenColumns, RowHeight, ShowGrid
QueryDef | DatasheetBackColor, DatasheetCellsEffect, DatasheetFontHeight, DatasheetFontItalic, DatasheetFontName, DatasheetFontUnderline, DatasheetFontWeight, DatasheetForeColor, DatasheetGridlinesBehavior, DatasheetGridlinesColor, Description, FailOnError, FrozenColumns, LogMessages, MaxRecords, RecordLocks, RowHeight, ShowGrid, UseTransaction
Field | Caption, ColumnHidden, ColumnOrder, ColumnWidth, DecimalPlaces, Description, Format, InputMask


 Einstellen von Starteigenschaften in Visual Basic

Einstellen von Starteigenschaften in Visual Basic

In einer Microsoft Access-Datenbank (.mdb) sind Starteigenschaften die Eigenschaften eines Database-Objekts. Bei einem Database-Objekt handelt es sich um ein von der Microsoft Jet-Datenbank-Engine bereitgestelltes DAO-Objekt (Data Access Object, Datenzugriffsobjekt). Da jedoch Microsoft Access die Starteigenschaften definiert, werden diese von der Jet-Datenbank-Engine nicht automatisch erkannt. Falls zuvor keine Starteigenschaft eingestellt wurde, müssen Sie sie erstellen und der Properties-Auflistung des Database-Objekts hinzufügen.

In einem Microsoft Access-Projekt (.adp) sind Starteigenschaften die Eigenschaften eines CurrentProject-Objekts. Genau wie bei dem Database-Objekt in einer Access-Datenbank (.mdb) werden Starteigenschaften von der Jet-Datenbank-Engine nicht automatisch erkannt. Falls zuvor keine Starteigenschaft eingestellt wurde, müssen Sie sie erstellen und der AccessObjectProperties-Auflistung des CurrentProject-Objekts hinzufügen.

Beim Einstellen von Starteigenschaften in Visual Basic sollten Sie Fehlerbehandlungscode einbeziehen, um zu überprüfen, ob die betreffende Eigenschaft in der Properties- bzw. der AccessObjectProperties-Auflistung vorhanden ist. Weitere Informationen zum Einstellen der von Microsoft Access definierten Eigenschaften finden Sie unter Einstellen der Eigenschaften von Datenzugriffsobjekten in Visual Basic oder Einstellen der Eigenschaften von ActiveX Data-Objekten in Visual Basic.

Die Namen der Starteigenschaften unterscheiden sich von dem Text, der im Dialogfeld Start (Menü Extras, Befehl Start) angezeigt wird. Die nachstehende Tabelle gibt den Namen jeder Starteigenschaft so an, wie er in Visual Basic-Code verwendet wird.

Text im Dialogfeld "Start" | Name der Eigenschaft
Anwendungstitel | AppTitle
Anwendungssymbol | AppIcon
Formular/Seite anzeigen | StartupForm
Datenbankfenster anzeigen | StartupShowDBWindow
Statusleiste anzeigen | StartupShowStatusBar
Menüleiste | StartupMenuBar
Kontextmenüleiste | StartupShortcutMenuBar
Unbeschränkte Menüs anzeigen | AllowFullMenus
Standardkontextmenüs zulassen | AllowShortcutMenus
Eingebaute Symbolleisten zulassen | AllowBuiltInToolbars
Symbolleisten- und Menüänderungen zulassen | AllowToolbarChanges
Codeansicht nach Fehler zugelassen | AllowBreakIntoCode
Access-Spezialtasten verwenden | AllowSpecialKeys


 Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung eines Makros

Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung eines Makros

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Klicken Sie in einer leeren Aktionszeile auf SetzenWert in der Aktionsliste.

  3. Stellen Sie das Argument Item auf den Bezeichner für das Steuerelement ein, dessen Wert festgelegt werden soll, und stellen Sie anschließend das Argument Expression auf den Bezeichner für das Steuerelement ein, dessen Wert Sie dem ersten Steuerelement zuweisen möchten.

    Zuweisen des Werts eines Steuerelements zu einem anderen Steuerelement

  4. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  5. Führen Sie das Makro aus.

    Wie wird's gemacht?

Anmerkung Je nach Kontext müssen Sie möglicherweise qualifizierte Bezeichner für die Steuerelemente verwenden. Um weitere Informationen über die Verwendung von Bezeichnern in Ausdrücken zu erhalten, klicken Sie auf [image] .


 Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung von Visual Basic

Einstellen des Werts eines Steuerelements basierend auf dem Wert eines anderen Steuerelements unter Verwendung von Visual Basic

  1. Erstellen Sie eine Visual Basic-Prozedur.

    Wie wird's gemacht?

  2. Fügen Sie der Prozedur eine Zuweisungsanweisung hinzu, indem Sie den Bezeichner für das Steuerelement, dessen Wert Sie festlegen möchten, dann ein Gleichheitszeichen (=) und schließlich den Bezeichner für das Steuerelement, dessen Wert Sie dem ersten Steuerelement zuweisen möchten, angeben.

    Um sich auf den Wert eines Steuerelements in einem aktuellen Formular zu beziehen, geben Sie das Schlüsselwort Me ein, gefolgt vom Operator ! und dem Namen des Steuerelements. Die folgende Anweisung weist z. B. dem Steuerelement Versandort im aktuellen Formular den Wert des Steuerelements Ort im aktuellen Formular zu:

    Me![Versandort] = Me![Ort]

    Um sich auf den Wert eines Steuerelements in einem anderen Formular zu beziehen, müssen Sie den vollständigen Bezeichner des Steuerelements angeben. Der folgende Bezeichner bezieht sich z. B. auf das Steuerelement Versandort im Formular Versandformular:

    Formulare![Versandformular]![Versandort]

  3. Führen Sie die Prozedur aus.

    Wie wird's gemacht?

Um weitere Informationen über den Verweis auf den Wert eines Steuerelements anzuzeigen, klicken Sie auf [image] .


 Den Wert einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung eines Makros einstellen

Den Wert einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung eines Makros einstellen

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Klicken Sie in einer leeren Aktionszeile auf SetzenWert in der Aktionsliste.

  3. Stellen Sie das Argument Item auf den Bezeichner für die Eigenschaft ein, deren Wert festgelegt werden soll, und stellen Sie anschließend das Argument Expression auf den Wert ein, den Sie der Eigenschaft zuweisen möchten.

    Einstellen eines Wertes basierend auf einem Ereignis

  4. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  5. Gehen Sie zu dem Formular oder Bericht, öffnen Sie das Eigenschaftenfenster für das Objekt, dessen Ereignis das Makro starten soll, und stellen Sie die Ereigniseigenschaft auf den Namen des Makros ein.

Um ein Beispiel für das Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis anzuzeigen, klicken Sie auf [image] .


 Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung von Visual Basic

Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis unter Verwendung von Visual Basic

  1. Erstellen Sie die Ereignisprozedur für das Ereignis.

    Wie wird's gemacht?

  2. Fügen Sie der Prozedur eine Zuweisungsanweisung hinzu, indem Sie den Bezeichner für die Eigenschaft eingeben, dessen Wert Sie festlegen möchten, dann ein Gleichheitszeichen (=) und schließlich den zuzuweisenden Wert.

    Um sich auf die Eigenschaft eines Steuerelements im aktuellen Formular zu beziehen, geben Sie das Schlüsselwort Me an, gefolgt vom Operator !, dem Namen des Steuerelements, dem . (dot)-Operator und dem Namen der Eigenschaft. Die folgende Anweisung weist z. B der Eigenschaft Visibledes Steuerelements Fälligkeitsdatum im aktuellen Formular den Wert False zu:

    Me![Fälligkeitsdatum].Visible = False

    Um sich auf die Eigenschaft eines Steuerelements in einem anderen Formular zu beziehen, müssen Sie den vollständigen Bezeichner des Steuerelements angeben. Der folgende Bezeichner bezieht sich z. B. auf die Visible-Eigenschaft des Steuerelements Fälligkeitsdatum im Formular Versandformular:

    Formulare![Versandformular]![Fälligkeitsdatum].Visible

Um weitere Informationen über die Bezugnahme auf eine Eigenschaft zu erhalten, klicken Sie auf [image] .

Um ein Beispiel für das Einstellen des Werts einer Eigenschaft als Reaktion auf ein Ereignis anzuzeigen, klicken Sie auf [image] .


 Einstellen eines Überwachungsausdrucks in Visual Basic-Code

Einstellen eines Überwachungsausdrucks in Visual Basic-Code

Wenn Sie die Ausführung des Visual Basic-Codes unterbrechen, können Sie die Werte von Überwachungsausdrücken im Überwachungsbereich des Visual Basic-Editors beobachten. Sie können auch den aktuellen Wert eines Ausdrucks anzeigen, der nicht als Überwachungsausdruck festgelegt wurde.

Was möchten Sie tun?

Einen Überwachungsausdruck dem Überwachungsbereich des Visual Basic-Editors hinzufügen

Den aktuellen Wert einer Variablen anzeigen


 Hinzufügen und Anzeigen von Kontextmenüs

Hinzufügen und Anzeigen von Kontextmenüs

Microsoft Access 2000 stellt eine Benutzeroberfläche zum Hinzufügen und Ändern von Kontextmenüs zur Verfügung. Wenn Sie ein benutzerdefiniertes Kontextmenü hinzufügen möchten, fügen Sie im Dialogfeld Anpassen eine Symbolleiste hinzu. Zum Öffnen dieses Dialogfelds zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken dann auf Anpassen. Anschließend verwenden Sie das Dialogfeld Symbolleisteneigenschaften, um den Typ der Symbolleiste in Popup zu ändern. Wenn Sie ein Kontextmenü löschen möchten, ändern Sie dessen Typ in Menüleiste oder Symbolleiste, und löschen Sie dieses anschließend. Sie können in Visual Basic beliebige Kontextmenüs hinzufügen, ändern und löschen.

Eingebaute und benutzerdefinierte Kontextmenüs werden in der Symbolleiste Kontextmenüs angezeigt, die verfügbar ist, wenn Sie das Kontrollkästchen Kontextmenüs im Dialogfeld Anpassen aktivieren. Sie können mit Hilfe der Symbolleiste Kontextmenüs Befehlsschaltflächen und Menüelemente zu Kontextmenüs hinzufügen oder aus diesen entfernen. Beachten Sie jedoch, dass Sie zum Verweisen auf ein Kontextmenü in Visual Basic die Syntax CommandBars("Kontextmenüname") verwenden. Der Code CommandBars("Kontextmenüs") ist ohne Bedeutung.

Sie können eine Ereignisprozedur verwenden, um ein Kontextmenü als Reaktion auf ein Klicken mit der rechten Maustaste anzuzeigen. Das folgende Beispiel zeigt das benutzerdefinierte Kontextmenü "KundenFormularKontextmenü" an, wenn der Benutzer mit der rechten Maustaste auf einen leeren Bereich oder einen Datensatzmarkierer in einem Formular klickt.

Private Sub Form_Click(Button As Integer, Shift As Integer, _
        X As Single, Y As Single)
    Dim cmdBar As CommandBar
    Dim intRechts As Integer

    Set cmdBar = CommandBars("KundenFormularKontextmenü")
    intRechts = (Button and acRightButton) > 0
        If intRechts Then
            cmdBar.ShowPopup 200, 200
        End If
End Sub


 Ein- oder Ausblenden von Datensätzen einer Gruppe auf einer Datenzugriffsseite

Ein- oder Ausblenden von Datensätzen einer Gruppe auf einer Datenzugriffsseite

  • Klicken Sie auf das Erweiterungssymbol neben der Gruppenüberschrift.


 Anpassen der Größe und der Proportionen eines Hintergrundbilds in einem Formular oder Bericht

Anpassen der Größe und der Proportionen eines Hintergrundbilds in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer beziehungsweise den Berichtsmarkierer, um das Eigenschaftenfenster zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Bildgrößenmodus auf eine der folgenden Einstellungen:
    • Abschneiden Zeigt das Bild in der tatsächlichen Größe an. Ist das Bild größer als das Formular beziehungsweise der Bericht, so wird es abgeschnitten.

    • Dehnen Passt die Größe des Bildes dem Bereich innerhalb des Formulars beziehungsweise des Berichts an. Bei dieser Einstellung ist das Bild möglicherweise verzerrt.

    • Zoomen Zeigt das gesamte Bild an, nachdem seine Größe entweder in der Höhe oder in der Breite dem Bereich innerhalb des Formulars beziehungsweise des Berichts angepasst worden ist. Bei dieser Einstellung wird das Bild nicht verzerrt.

    Anmerkung Wenn Sie für die BildNebeneinander-Eigenschaft die Einstellung Ja festgelegt haben, stellen Sie die Bildgrößenmodus-Eigenschaft auf Abschneiden ein.


 Sortieren von Datensätzen in der Formular- oder der Datenblattansicht

Sortieren von Datensätzen in der Formular- oder der Datenblattansicht

Zum Anzeigen einer Liste der Themen, die beim Sortieren von Datensätzen zu berücksichtigen sind, klicken Sie auf [image] .

  1. Klicken Sie in der Formularansicht oder Datenblattansicht auf das Feld, nach dem Sie Datensätze sortieren möchten. Um Datensätze in einem Unterformular zu sortieren, klicken auf das Feld, nach dem Sie sortieren wollen. Um Datensätze in einem Unterdatenblatt zu sortieren, zeigen Sie das Unterdatenblatt an, indem Sie auf dessen Erweiterungssymbol klicken, und klicken Sie dann auf das Feld.

  2. Führen Sie eine der folgenden Aktionen aus:
    • Wenn Sie in aufsteigender Reihenfolge sortieren möchten, klicken Sie auf Sortierung Aufsteigend [image] .

    • Wenn Sie in absteigender Reihenfolge sortieren möchten, klicken Sie auf Sortierung Absteigend [image] .

Anmerkungen

  • Wenn Sie in der Datenblattansicht das Unterdatenblatt eines Datensatzes sortieren, sortiert Microsoft Access alle Unterdatenbläter auf dieser Ebene.

  • In einem Formular können Sie immer nur nach einem einzelnen Feld sortieren. In einem Datenblatt oder Unterdatenblatt können Sie gleichzeitig zwei oder mehrere angrenzende Spalten markieren und diese dann sortieren. Microsoft Access sortiert Datensätze beginnend bei der ersten markierten Spalte von links. Wenn Sie das Formular oder das Datenblatt speichern, speichert Microsoft Access gleichzeitig auch die Sortierreihenfolge.


 Sortieren von Datensätzen unter Verwendung des Entwurfsbereichs einer Abfrage oder eines Spezialfilters

Sortieren von Datensätzen unter Verwendung des Entwurfsbereichs einer Abfrage oder eines Spezialfilters

Bevor Sie eine Sortierreihenfolge festlegen, sollten Sie verschiedenes berücksichtigen. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht oder zeigen Sie für eine Tabelle, Abfrage oder ein Formular das Fenster Spezialfilter/-sortierung an.

  2. Wenn Sie mehrere Felder sortieren möchten, ordnen Sie zunächst die Felder im Entwurfsbereich in der Reihenfolge an, in der Sie die Sortierungen ausführen möchten. Microsoft Access sortiert zunächst im äußersten linken Feld, dann im nächsten Feld rechts davon usw. Um zum Beispiel zuerst im Feld
    Nachname
    und dann im Feld
    Vorname
    zu sortieren, muss sich das Feld
    Nachname
    links vom Feld
    Vorname
    im Raster befinden.

  3. Klicken Sie in der Zeile Sortierung der zu sortierenden Felder jeweils auf eine Option.

  4. Um die Ergebnisse der Abfrage anzuzeigen, klicken Sie in der Symbolleiste auf Abfrageansicht [image] .


 Angeben eines Befehlszeilenarguments, das in Visual Basic-Code verwendet werden kann

Angeben eines Befehlszeilenarguments, das in Visual Basic-Code verwendet werden kann

Beim Starten von Microsoft Access von der Befehlszeile aus können Sie die Befehlszeilenoption /cmd verwenden, um ein Befehlszeilenargument anzugeben, das in Visual Basic-Code verwendet werden kann.

Um Informationen zur Befehlszeilenoption /cmd anzuzeigen, klicken Sie auf [image] .


 Festlegen des Datentyps eines Parameters in einer Parameterabfrage

Festlegen des Datentyps eines Parameters in einer Parameterabfrage

  1. Klicken Sie nach dem Erstellen einer Parameterabfrage in der Abfrageentwurfsansicht im Menü Abfrage auf Parameter.

  2. Geben Sie unter Parameter in der ersten Zelle die erste Eingabeaufforderung ein, die Sie im Abfrageentwurfsbereich angegeben haben.

  3. Klicken Sie dann rechts davon in der Zelle Felddatentyp auf den gewünschten Datentyp.

  4. Wiederholen Sie die Schritte 2 und 3 für jeden Parameter, für den Sie einen Datentyp festlegen möchten.


 Festlegen eines Standardwerts, der automatisch in ein Kombinationsfeld eines Formulars eingetragen wird

Festlegen eines Standardwerts, der automatisch in ein Kombinationsfeld eines Formulars eingetragen wird

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Klicken Sie, nachdem Sie das Kombinationsfeld ausgewählt haben, in der Symbolleiste auf Eigenschaften [image] .

  3. Geben Sie [Kombinationsfeldname].ItemData(n) in das Einstellungsfeld der Eigenschaft Standardwert ein, wobei n für die Zeile steht, die Sie als Standardwert verwenden möchten. Die Eigenschaft ItemData basiert auf Null; geben Sie also ItemData(0) ein, wenn Sie möchten, dass die erste Zeile der Liste zum Standardwert wird. Um zum Beispiel die erste Zeile des Kombinationsfelds Lieferantenauswahl zum Standardeintrag für das Kombinationsfeld zu machen, geben Sie in das Einstellungsfeld der Eigenschaft Standardwert [Lieferantenauswahl].ItemData(0) ein.

Anmerkung Wenn Sie einen Standardwert für ein Nachschlagekombinationsfeld in der Entwurfsansicht für Microsoft Access-Datenbanktabellen (.mdb) festlegen möchten, geben Sie in die Eigenschaft Standardwert einen Standardwert für das Fremdschlüsselfeld ein. Enthält eine Tabelle Artikel zum Beispiel das Fremdschlüsselfeld Lieferanten-Nr, klicken Sie auf dieses Feld und geben in das Einstellungsfeld der Eigenschaft Standardwert im unteren Teil des Fensters eine gültige Lieferantennummer ein. Wenn Sie dieses Feld das nächste Mal einem Formular hinzufügen, stellt Microsoft Access automatisch den Standardwert für das Feld ein.


 Definieren eines Standardwertes in der Tabellenentwurfsansicht

Definieren eines Standardwertes in der Tabellenentwurfsansicht

  1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

  2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie einen Standardwert definieren möchten.

  3. Klicken Sie im unteren Teil des Fensters auf der Registerkarte Einstellungen auf das Einstellungsfeld für die Eigenschaft Standardwert, und geben Sie dann den Standardwert (z. B. Köln) oder einen Ausdruck (z. B. Datum()) ein.

    Zum Anzeigen von Beispielen für Standardwerte klicken Sie auf [image] .

Anmerkungen

  • Das Einstellen der Eigenschaft Standardwert für ein Feld hat keinen Einfluss auf bereits vorhandene Daten. Sie können jedoch den aktuellen Wert in einem Feld durch den Standardwert ersetzen. Dazu drücken Sie die Tastenkombination STRG+ALT+LEERTASTE.

  • Wenn Sie einen Standardwert für ein Feld vom Datentyp Ja/Nein in einer Datenbank festlegen, die auf internationaler Ebene eingesetzt wird, können Sie vor dem Wert ein Gleichheitszeichen angeben. Microsoft Access zeigt den Wert dann in der jeweiligen Landessprache an. Geben Sie z. B. =Ja ein, wenn Sie möchten, dass Microsoft Access auf einem für die USA eingestellten Computer Yes anzeigt. Wenn Sie den Wert sehen möchten, müssen Sie für das Feld für die Eigenschaft SteuerelementAnzeigen den Wert Textfeld oder Kombinationsfeld festlegen.


 Festlegen des Zeitintervalls bis zum Anzeigen eines ODBC Timeout-Fehlers

Festlegen des Zeitintervalls bis zum Anzeigen eines ODBC Timeout-Fehlers

Eine Abfrage auf der Basis einer ODBC-Datenbank kann auf Grund umfangreichen Netzwerkverkehrs oder extremer Nutzung des ODBC-Servers verzögert werden.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht.

  2. Markieren Sie die Abfrage, indem Sie auf eine beliebige Stelle in der Entwurfsansicht für Abfragen außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster für die Abfrage anzuzeigen.

  4. Legen Sie für die Eigenschaft ODBCWartezeit die Anzahl der Sekunden fest, die die Abfrage vor dem Anzeigen eines Timeout-Fehlers warten soll. Standardmäßig wartet die Abfrage 60 Sekunden.

Anmerkung Wenn Sie für die Eigenschaft die Einstellung 0 festlegen, tritt kein Timeout-Fehler auf.


 Festlegen einer Strategie für das Sperren von Datensätzen für eine Abfrage in einer Mehrbenutzerumgebung

Festlegen einer Strategie für das Sperren von Datensätzen für eine Abfrage in einer Mehrbenutzerumgebung

Sie können beim Bearbeiten eines Datensatzes in den Abfrageergebnissen alle Datensätze aus der zugrunde liegenden Tabelle sperren oder nur den Datensatz, den Sie bearbeiten. Somit können die anderen Benutzer, während Sie den Datensatz in den Abfrageeergebnissen bearbeiten, diesen nicht in der zugrunde liegenden Tabelle ändern.

  1. Öffnen Sie eine Abfrage in der Entwurfsansicht. Stellen Sie in einer Mehrbenutzerumgebung sicher, dass alle Benutzer die Abfrage, die zugrunde liegende Tabelle oder Abfrage sowie andere auf der Abfrage basierende Objekte geschlossen haben.

  2. Markieren Sie die Abfrage, indem Sie auf eine beliebige Stelle in der Entwurfsansicht außerhalb des Entwurfsbereichs und der Feldlisten klicken.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  4. Klicken Sie auf die gewünschte Einstellung der Eigenschaft DatensätzeSperren.

    Um Informationen zum Festlegen einer Standardeinstellung für diese Eigenschaft anzuzeigen, die für alle Abfragen gelten soll, klicken Sie auf [image] .

Um weitere Informationen zum Festlegen einer Strategie für das Sperren von Datensätzen anzuzeigen, klicken Sie auf [image] .


Dokumentieren von Zusammenfassungsinformationen einer Microsoft Access-Datenbank oder eines Microsoft Access-Projekts

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften, während die Datenbank geöffnet ist.

  2. Klicken Sie auf die Registerkarte Zusammenfassung und geben Sie beliebig viele der benötigten Informationen ein.

    Um Hilfe zu einer Option anzuzeigen, klicken Sie auf das Fragezeichen [image] und dann auf die Option.

  3. Klicken Sie auf OK.

Anmerkung Für jedes Element, das Sie in der Registerkarte Datei-Info ausfüllen, werden die zugehörigen Eigenschaften automatisch eingestellt. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .


 Festlegen eines Rahmens und einer Titelleiste für ein Popupformular oder benutzerdefiniertes Dialogfeld

Festlegen eines Rahmens und einer Titelleiste für ein Popupformular oder benutzerdefiniertes Dialogfeld

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Rahmenart auf eine der Einstellungen. Um Informationen zu den Einstellungen zu erhalten, klicken Sie auf [image] . Um Informationen zum Erstellen von Popupformularen und benutzerdefinierten Dialogfeldern zu erhalten, klicken Sie auf [image] .


 Festlegen, ob eine Datenzugriffsseite für die Dateneingabe geöffnet wird

Festlegen, ob eine Datenzugriffsseite für die Dateneingabe geöffnet wird

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Bearbeiten auf Seite auswählen.

  3. Klicken Sie in der Symbolleiste auf Eigenschaften [image] . Microsoft Access zeigt die Seiteneigenschaften im Eigenschaftenfenster an.

  4. Stellen Sie die DataEntry-Eigenschaft auf Wahr.

Wenn Sie die Datenzugriffsseite in Seitenansicht oder in Internet Explorer öffnen, wird auf der Seite ein neuer leerer Datensatz angezeigt.


 Festlegen, ob die Größe eines Formulars verändert werden kann

Festlegen, ob die Größe eines Formulars verändert werden kann

In den meisten Fällen ist es erwünscht, dass ein Formular in der Größe verändert werden kann. Verwenden Sie die folgende Vorgehensweise für Popupformulare und benutzerdefinierte Dialogfelder, deren Größe nicht geändert werden soll.

  1. Öffnen Sie das Formular in der Entwurfsansicht.

  2. Doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  3. Klicken Sie im Einstellungsfeld der Eigenschaft Rahmenart auf Keine, Dünn oder Dialog. Um weitere Informationen zu diesen Einstellungen zu erhalten, klicken Sie auf [image] .

Anmerkung Um Informationen zum Erstellen von PopupfFormularen und benutzerdefinierten Dialogfeldern zu erhalten, klicken Sie auf [image] .


Wählen, welches E-Mail-Konto zum Versenden einer Nachricht verwendet wird

Anmerkung Dieses Verfahren gilt nur, wenn Microsoft Outlook im Modus Nur Internet installiert wurde. Weitere Informationen darüber, wie Sie Informationen zur Installation von Microsoft Outlook erhalten.

  1. Zeigen Sie die Kopfzeile durch Anhängen eines Datenbankobjekts an eine E-Mail-Nachricht beziehungsweise Versenden einer Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht an.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie im Feld Nachricht senden über auf das gewünschte Konto und dann auf Schließen.


 Starten des Ausdruckseditors in einem Eigenschaftenfenster oder im Makrofenster

Starten des Ausdruckseditors in einem Eigenschaftenfenster oder im Makrofenster

  1. Klicken Sie auf das Einstellungsfeld der Eigenschaft oder auf das Argumentfeld, das den Ausdruck beinhaltet.

  2. Klicken Sie auf die Schaltfläche Generator [image] neben dem Einstellungsfeld der Eigenschaft oder dem Argumentfeld.

    Verfügt eine Eigenschaft über mehr als einen mit ihr verbundenen Generator, zeigt Microsoft Access das Dialogfenster Generator auswählen an. Klicken Sie auf Ausdrucksgenerator und auf OK.

Anmerkung Wenn das Einstellungsfeld der Eigenschaft oder das Argumentfeld, von dem aus Sie den Ausdrucksgenerator starten, bereits einen Wert enthält, wird der Wert automatisch in das Ausdrucksfeld kopiert.


 Starten des Ausdrucksgenerators im Abfrageentwurf oder in einer Makrobedingung

Starten des Ausdrucksgenerators im Abfrageentwurf oder in einer Makrobedingung

Sie können den Ausdrucksgenerator in einem Feld oder einer Zelle Kriterien in der Abfrage-Entwurfsansicht oder in der Spalte für Bedingungen des Makrofensters starten.

  1. Klicken Sie mit der rechten Maustaste auf die Stelle, an der Sie den Ausdruck einfügen möchten.

  2. Klicken Sie im Kontextmenü auf Erstellen.

Anmerkung Wenn die Zelle oder die Spalte Bedingung, in der Sie den Ausdrucksgenerator starten, bereits einen Wert enthält, wird der Wert automatisch in das Ausdrucksfeld kopiert.


 Starten von Microsoft Access mit Befehlszeilenoptionen aus dem Windows-Menü "Start"

Starten von Microsoft Access mit Befehlszeilenoptionen aus dem Windows-Menü "Start"

  1. Klicken Sie in Windows auf die Schaltfläche Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Taskleiste.

  2. Klicken Sie auf die Registerkarte Programme im Menü "Start" und dann auf Erweitert.

  3. Doppelklicken Sie auf den Ordner PROGRAMME.

  4. Doppelklicken Sie dann auf den Microsoft Office-Ordner (oder auf den Namen des Unterordners, in dem Microsoft Access installiert ist). Wenn Microsoft Access nicht in einem Unterordner des Menüs Start installiert ist, können Sie diesen Schritt überspringen.

  5. Klicken Sie mit der rechten Maustaste auf das Verknüpfungssymbol für das Microsoft Access-Programm. Klicken Sie dann auf Eigenschaften und anschließend auf die Registerkarte Verknüpfung.

  6. Klicken Sie im Textfeld Ziel rechts neben den Microsoft Access-Startbefehl, und geben Sie dann die gewünschten Befehlszeilenoptionen ein.

    Die folgende Befehlszeile z. B. startet Microsoft Access und öffnet die Nordwind-Datenbank für exklusiven Zugriff.

"C:\Programme\Microsoft Office\Office\MSAccess.exe" "C:\Programme\Microsoft Office\Office\Beispiele\Nwind.mdb" /excl

Zum Anzeigen der Liste mit Befehlszeilenoptionen klicken Sie auf [image] .


 Starten von Microsoft Access mit Befehlszeilenoptionen über eine Verknüpfung

Starten von Microsoft Access mit Befehlszeilenoptionen über eine Verknüpfung

  1. Öffnen Sie den Ordner, in dem Microsoft Access installiert ist (standardmäßig der Unterordner OFFICE des Ordners MICROSOFT OFFICE im Ordner PROGRAMME auf Laufwerk C).

  2. Klicken Sie mit der rechten Maustaste auf das Microsoft Access-Programmsymbol und dann auf Verknüpfung erstellen.

  3. Klicken Sie mit der rechten Maustaste auf das soeben erstellte Verknüpfungssymbol, dann auf Eigenschaften und schließlich auf die Registerkarte Verknüpfung.

  4. Klicken Sie in das Textfeld Ziel rechts neben den Microsoft Access-Startbefehl, und geben Sie dann die gewünschten Befehlszeilenoptionen ein.

    Die folgende Befehlszeile z. B. startet Microsoft Access und öffnet die Nordwind-Datenbank für exklusiven Zugriff.

"C:\Programme\Microsoft Office\Office\MSAccess.exe" "C:\Programme\Microsoft Office\Office\Beispiele\Nwind.mdb" /excl

Zum Anzeigen der Liste mit Befehlszeilenoptionen klicken Sie auf [image] .

Anmerkung Nach dem Erstellen einer Verknüpfung können Sie diese auf Ihrem Desktop oder in einem Ordner ablegen oder zum Menü Start hinzufügen. Weitere Informationen hierzu finden Sie in der Windows-Hilfe unter dem Stichwort "Verknüpfungen".

Sie können auch Verknüpfungen erstellen, um beliebige Microsoft Access-Datenbankobjekte direkt von Windows aus zu öffnen.

Um weitere Informationen hierzu anzuzeigen, klicken Sie auf [image] .


 Schrittweises Durchlaufen von Visual Basic-Code

Schrittweises Durchlaufen von Visual Basic-Code

Das schrittweise Durchlaufen Ihres Visual Basic-Codes kann hilfreich sein, um einen auftretenden Fehler ausfindig zu machen. Sie können erkennen, ob jede einzelne Codezeile die von Ihnen erwarteten Ergebnisse liefert.

  1. Unterbrechen Sie die Codeausführung.

    Wie wird's gemacht?

    Microsoft Access zeigt die Codezeile an, in der die Ausführung unterbrochen wurde.

  2. Führen Sie einen der folgenden Schritte aus:
    • Um jede Codezeile sowie den Code einer von einer anderen Prozedur aufgerufenen Prozedur schrittweise zu durchlaufen, klicken Sie in der Symbolleiste Debuggen auf Einzelschritt [image] .

    • Um jede Codezeile schrittweise zu durchlaufen, andere aufgerufene Prozeduren dagegen als Ganzes auszuführen, klicken Sie in der Symbolleiste Debuggen auf Prozedurschritt [image] .

    • Um den Code vor der aktuellen Codezeile auszuführen und dann zu unterbrechen, so dass Sie jede Codezeile schrittweise durchlaufen können, klicken Sie im Menü Debuggen auf Ausführen bis Cursor.

    • Um den Rest der aktuellen Prozedur auszuführen und danach zur nächsten Codezeile in der vorhergehenden Prozedur im Aufrufbaum zurückzukehren, klicken Sie in der Symbolleiste auf Rücksprung [image] .

Anmerkung Sie können Einzelschritt [image] verwenden, ohne die Codeausführung zu unterbrechen. Setzen Sie den Cursor im Visual Basic Editor-Code-Fenster in die Prozedur, die schrittweise durchlaufen werden soll, und klicken Sie dann in der Symbolleiste auf Einzelschritt [image].

Sie können zwischen diesen Einzelschritt-Typen wechseln. Welchen Typ Sie wählen, hängt davon ab, welche Codeabschnitte Sie analysieren möchten.


 Verwenden eines Haltepunkts zum Unterbrechen der Ausführung von Visual Basic-Code

Verwenden eines Haltepunkts zum Unterbrechen der Ausführung von Visual Basic-Code

Wenn Sie die Ausführung von Visual Basic für Applikationen-Code unterbrechen, wird der Code zwar weiterhin ausgeführt, zwischen den laufenden Anweisungen jedoch angehalten. Während die Codeausführung unterbrochen ist, können Sie Testaufgaben ausführen, wie zum Beispiel die aktuellen Variablenwerte überprüfen und jede Codezeile einzeln ausführen. Damit Microsoft Visual Basic Ihre Codeausführung anhält, können Sie einen Haltepunkt setzen.

  1. Setzen Sie die Einfügemarke im Visual Basic Editor-Code-Fenster an eine Codezeile, die noch kein Haltepunkt oder noch keine Deklaration ist.

  2. Klicken Sie in der Symbolleiste Debuggen auf Haltepunkt ein/aus [image] .

Um einen Haltepunkt zu löschen, setzen Sie die Einfügemarke an die Codezeile, an der ein Haltepunkt gesetzt wurde, und klicken Sie dann in der Symbolleiste Debuggen auf Haltepunkt ein/aus [image] . Um die Codeausführung fortzusetzen, klicken Sie im Menü Ausführen auf Fortsetzen.

Anmerkung Sie können die Codeausführung auch unterbrechen, indem Sie einer Prozedur eine Stop-Anweisung hinzufügen oder indem Sie STRG+UNTBR drücken, während der Code ausgeführt wird.


 Wechseln zwischen den Ansichten einer Abfrage

Wechseln zwischen den Ansichten einer Abfrage

Eine Abfrage kann in drei Ansichten angezeigt werden: in der Abfrageentwurfsansicht, der Datenblattansicht und der SQL-Ansicht.

  1. Klicken Sie in der Symbolleiste auf den Pfeil neben Abfrageansicht [image] .

  2. Klicken Sie in der Dropdownliste auf die gewünschte Ansicht.


 Verfolgen von Visual Basic-Prozeduraufrufen während der Fehlerbehandlung in Visual Basic-Code

Verfolgen von Visual Basic-Prozeduraufrufen während der Fehlerbehandlung in Visual Basic-Code

Wenn Sie die Ausführung von Visual Basic-Code unterbrechen, während Sie die Fehlerbehandlung (Debugging) im Code ausführen, können Sie mit Hilfe des Dialogfelds Aufrufe eine Liste der Prozeduren anzeigen, die gestartet, doch noch nicht beendet wurden.

  1. Unterbrechen Sie die Ausführung Ihres Visual Basic-Codes.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste Debuggen auf Aufrufeliste... .

In Microsoft Access werden die zuletzt aufgerufenen Prozeduren oben auf der Liste angezeigt, und zwar zuerst die letzte, dann die vorletzte usw. Um die Anweisung anzuzeigen, die die nächste Prozedur auf der Liste aufruft, klicken Sie auf Anzeigen.


 Ein- und Ausschalten von Bestätigungsmeldungen

Ein- und Ausschalten von Bestätigungsmeldungen

Sie können Bestätigungsmeldungen für Datensatzänderungen, für Dokumentlöschvorgänge oder für Aktionsabfragen in Microsoft Access-Datenbanken ein- oder ausschalten.

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Klicken Sie auf die Registerkarte Bearbeiten/Suchen.

  3. Aktivieren oder deaktivieren Sie unter Bestätigen die zutreffenden Kontrollkästchen.

Anmerkung Diese Einstellungen gelten nicht für Datenzugriffsseiten.


 Aktualisieren einer manuell erstellten Verknüpfung zu einem Bild oder einem anderen Objekt in einem Formular oder Bericht

Aktualisieren einer manuell erstellten Verknüpfung zu einem Bild oder einem anderen Objekt in einem Formular oder Bericht

Diese Verknüpfungsart ist nicht identisch mit einem Hyperlink, der in einem Formular oder Bericht zum Springen zu einem anderen Dokument, einem anderen Objekt oder einer anderen Seite verwendet wird. Um weitere Informationen zu Hyperlinks anzuzeigen, klicken Sie auf [image] .

  1. Führen Sie einen der folgenden Schritte aus:
    • Handelt es sich um ein ungebundenes Objekt, klicken Sie in der Formular-Entwurfsansicht oder der Berichts-Entwurfsansicht auf das Objekt.

    • Handelt es sich um ein gebundenes Objekt, öffnen Sie das Formular in der Formularansicht (oder öffnen Sie ein Datenblatt), suchen Sie den Datensatz, den Sie ändern möchten, und klicken Sie dann auf das Objekt.
  2. Klicken Sie im Menü Bearbeiten auf OLE/DDE-Verknüpfungen.

  3. Klicken Sie im Listenfeld Verknüpfungen auf die Verknüpfung, die Sie aktualisieren möchten. Zum Markieren mehrerer Verknüpfungen halten Sie STRG gedrückt und klicken dann nacheinander auf jede einzelne Verknüpfung.

  4. Klicken Sie auf Jetzt aktualisieren.

Anmerkung Dieses Verfahren gilt nur für Bilder in ungebundenen Objektfeldern und gebundenen Objektfeldern. Hintergrundbilder und Bilder in Bild-Steuerelementen werden immer automatisch aktualisiert.


 Aktualisieren einer auf Werten in einer anderen Tabelle basierenden Tabelle mittels einer Abfrage

Aktualisieren einer auf Werten in einer anderen Tabelle basierenden Tabelle mittels einer Abfrage

  1. Erstellen Sie eine Aktualisierungsabfrage, die die zu aktualisierende Tabelle und die Tabelle mit den Werten enthält, die Sie kopieren möchten. Zum Anzeigen von Informationen zum Erstellen einer Aktualisierungsabfrage klicken Sie auf [image] .

  2. Wenn die Tabellen nicht bereits verknüpft sind, verknüpfen Sie diese über die Felder, die verwandte Informationen enthalten. Zum Anzeigen von Informationen über Verknüpfungen klicken Sie auf [image] .

    Wenn Sie z.B. Daten aus dem Feld Artikelname aus der Tabelle Artikel in eine andere Tabelle kopieren möchten, verknüpfen Sie die beiden Tabellen über den Primärschlüssel, der z.B. Artikel-Nr lauten kann.

  3. Geben Sie in die Zelle Aktualisieren für die zu aktualisierenden Felder einen Ausdruck gemäß folgender Syntax ein:

    [Tabellenname].[Feldname]

    Tabellenname und Feldname bezeichnen die Tabelle und das Feld, dessen Daten Sie kopieren. Wenn Sie z.B. Daten aus dem Feld Artikelname aus der Tabelle Artikel kopieren, geben Sie [Artikel].[Artikelname] in die Zelle Aktualisieren ein.


 Aufheben der Gruppierung von Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

Aufheben der Gruppierung von Textfeldern oder anderen Steuerelementen in einem Formular oder Bericht

  1. Öffnen Sie ein Formular in der Entwurfsansicht beziehungsweise einen Bericht in der Entwurfsansicht.

  2. Klicken Sie auf ein beliebiges Steuerelement in der Gruppe, um die Gruppe zu wählen.

  3. Klicken Sie im Menü Format auf Gruppierung aufheben.

Anmerkung

  • Gruppierungen von Steuerelementen können nur dann aufgehoben werden, wenn eine einzelne Gruppe ausgewählt wurde.

  • Beim Aufheben von Gruppierungen von Steuerelementen wird das Gruppenrechteck gelöscht, und alle Steuerelemente werden automatisch markiert.


 Gruppieren von Datensätzen in einem Ausdruck auf einer Datenzugriffsseite

Gruppieren von Datensätzen in einem Ausdruck auf einer Datenzugriffsseite

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Erstellen Sie eine gruppierte Datenzugriffsseite.

  3. Wenn der Ausdruck auf Feldnamen verweist, bestehen zwei Möglichkeiten: entweder Sie fügen die Felder der Seite als gebundene HTML-Steuerelemente hinzu oder Sie fügen die Felder als gebundene Textfelder hinzu.

    Tipp Die Seite wird in Seitenansicht und im Microsoft Internet Explorer schneller geladen, wenn Sie gebundene HTML-Steuerelemente verwenden.

  4. Fügen Sie für den Ausdruck ein gebundenes HTML-Steuerelement hinzu, indem Sie auf der Schaltfläche auf Gebundener HTML-Text Gebundenes HTML-Steuerelement und anschließend in den für das Steuerelement gewünschten Bereich klicken.

  5. Vergewissern Sie sich, dass das Steuerelement markiert ist, und klicken Sie dann auf der Symbolleiste auf Eigenschaften [image] , um dessen Eigenschaftenfenster anzuzeigen.

  6. Geben Sie für den Ausdruck einen Alias ein, gefolgt von einem Doppelpunkt und dem Ausdruck, der im Einstellungsfeld der Steuerelementinhalt-Eigenschaft stehen soll. In diesem Beispiel ist VollerName der Alias für den Ausdruck:

    VollerName: =Vorname & " " & Nachname

  7. Klicken Sie auf der Schaltfläche auf Heraufstufen [image] , wobei das gebundene HTML-Steuerelement markiert bleibt.

    Microsoft Access fügt einen Gruppenkopf hinzu, der ein erweitertes Steuerelement enthält, und einen Datensatznavigationsbereich, der ein Datensatznavigationssteuerelement enthält. Microsoft Access verschiebt das von Ihnen gruppierte Steuerelement zum Gruppenkopf.

Anmerkungen

  • Jedes Feld, in das Sie einen Ausdruck verweisen, muss der Datendefinition der Seite hinzugefügt werden. Das Feld wird der Datendefinition automatisch hinzugefügt, wenn Sie ein an dieses Feld gebundenes Steuerelement erstellen. Sollen die Werte dieser Steuerelemente weder in Seitenansicht noch im Microsoft Internet Explorer angezeigt werden, können Sie entweder die Steuerelemente ausblenden oder die Steuerelemente löschen. Auch wenn Sie ein Steuerelement löschen, das in ein Feld gebunden ist, das in einem Ausdruck auf der Seite verwendet wird, wird es nicht aus der Datendefinition der Seite gelöscht.

  • Wenn Sie ein Steuerelement gruppieren, erstellt Microsoft Access einen Alias für das Steuerelement, indem es dem Namen des Steuerelements in der Steuerelementinhalt-Eigenschaft das Präfix "Gruppierung" hinzufügt; zum Beispiel GruppierungVollerName: VollerName. Wenn Sie dieses Steuerelement in einen Ausdruck oder eine Eigenschaft verweisen, müssen Sie den Alias verwenden.


 Verwenden einer Front-End/Back-End-Anwendung mit mehreren Versionen von Microsoft Access

Verwenden einer Front-End/Back-End-Anwendung mit mehreren Versionen von Microsoft Access

Wenn Ihre Microsoft Access-Datenbank bereits eine Front-End/Back-End-Anwendung ist, müssen Sie nur das Front-End in Microsoft Access 97 konvertieren.

  1. Verändern Sie die Back-End-Datenbank nicht.

  2. Konvertieren Sie die Front-End Datenbank in Microsoft Access 97.

  3. Führen Sie den Tabellenverknüpfungs-Manager aus (Befehl Datenbank-Dienstprogramme im Menü Extras), um die neue Microsoft Access 97-Front-End-Datenbank mit den Tabellen in der Back-End-Datenbank aus der früheren Version zu verknüpfen. Sie können dann die Microsoft Access 97-Front-End-Datenbank so erweitern, dass neue Features für die Benutzer unterstützt werden, die bereits auf Microsoft Access 97 umgestellt haben.


 Erstellen eines Hyperlinks zu einer bestehenden Datei oder Webseite unter Verwendung der Schaltfläche "Hyperlink einfügen"

Erstellen eines Hyperlinks zu einer bestehenden Datei oder Webseite unter Verwendung der Schaltfläche "Hyperlink einfügen"

  1. Öffnen Sie ein Formular in der Entwurfsansicht, einen Bericht in der Entwurfsansicht oder eine Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Einfügen auf Hyperlink.

  3. Klicken Sie im Dialogfeld Hyperlink einfügen auf bestehende Datei oder Webseite unter Link zu.

  4. Geben Sie in das Dialogfeld Text anzeigen als den Anzeigetext für den Hyperlink ein. Wenn Sie das Feld nicht ausfüllen, verwendet Microsoft Access die Hyperlinkadresse und/oder -Unteradresse als Anzeigetext.

  5. Klicken Sie auf Infofelder und geben Sie dann den Text ein, der erscheinen soll, wenn sich der Mauszeiger über den Hyperlink bewegt. Wenn Sie das Feld Quickinfotext leer lassen, zeigt Microsoft Access die Hyperlinkadresse und/oder -Unteradresse als QuickInfo an.

  6. Geben Sie die Datei oder Webseite an, zu der Sie mit einem der folgenden Verfahren eine Verknüpfung herstellen möchten:
    • Geben Sie im Textfeld Dateityp oder Webseite einen Pfad oder eine URL ein.

    • Klicken Sie unter Oder aus Liste auswählen auf Zuletzt verwendet, Besuchte Webseiten oder Eingefügte Hyperlinks. Klicken Sie anschließend auf einen Eintrag in der Liste.

    • Klicken Sie auf Datei, um auf Ihrem lokalen Computer, einem Netzwerk oder allen verfügbaren ftp- oder http-Servern eine Datei zu suchen.

    • Klicken Sie auf Webseite, um eine Seite im Internet oder einem Intranet zu suchen. Wenn Sie vom Microsoft Internet Explorer oder anderen Webbrowsern zu Microsoft Access wechseln, legt Microsoft Access den Titel und die URL der tatsächlich geöffneten Webseite in den Dialogfeldern Anzuzeigender Text und Dateityp oder Webseite ab.
  7. Um zu einer bestimmten Position in einer HTML-Datei, einem Objekt in einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt zu gehen, klicken Sie auf Textmarke. Klicken Sie in der Liste auf die gewünschte Textmarke oder das gewünschte Objekt und dann auf OK.

  8. Klicken Sie OK im Feld Hyperlink einfügen.

    Microsoft Access fügt auf einer Datenzugriffsseite einen Hyperlink in ein Hyperlink-Steuerelement. In einem Formular oder einem Bericht fügt es den Hyperlink in ein Bezeichnungsfeld ein. Um die Verknüpfung zu testen, wechseln Sie in die Seitenansicht und klicken Sie auf den Hyperlink. Um die Verknüpfung in einem Formular oder Bericht zu testen, klicken Sie mit der rechten Maustaste auf das Bezeichnungsfeld, zeigen Sie dann im Kontextmenü auf Hyperlink und klicken Sie dann auf Öffnen.


 Erstellen der ODBC-Verbindungszeichenfolge für eine SQL Pass-Through-Abfrage

Erstellen der ODBC-Verbindungszeichenfolge für eine SQL Pass-Through-Abfrage

  1. Öffnen Sie eine SQL Pass-Through-Abfrage.

  2. Klicken Sie in der Symbolleiste auf Eigenschaften [image] , um das Eigenschaftenfenster der Abfrage anzuzeigen.

  3. Klicken Sie im Eigenschaftenfenster auf die Generator-Schaltfläche [image] rechts neben dem Einstellungsfeld der Eigenschaft ODBC-Verbindung, und geben Sie dann Informationen über den Server ein, zu dem Sie eine Verbindung herstellen möchten.

  4. Wenn Sie aufgefordert werden, das Kennwort in der Verbindungszeichenfolge zu speichern, klicken Sie auf Ja, wenn das Kennwort und die Anmeldung in der Verbindungszeichenfolge gespeichert werden soll.

Anmerkung Die Standardeinstellung für die ODBC-Verbindungszeichenfolge lautet ODBC. Nachdem der Editor die ODBC-Verbindungszeichenfolge erstellt hat, wird diese im Eigenschaftenfenster der Abfrage als Einstellung der Eigenschaft ODBC-Verbindung angegeben.


 Verwenden einer aus einer Datei bestehenden Microsoft Access-Datenbank in mehreren Versionen von Microsoft Access

Verwenden einer aus einer Datei bestehenden Microsoft Access-Datenbank in mehreren Versionen von Microsoft Access

Damit Sie eine Microsoft Access-Datenbank verwenden können, die eine Datei in verschiedenen Versionen von Microsoft Access ist, konvertieren Sie sie in eine Front-End/Back-End-Anwendung. Die Daten verbleiben in der ältesten Access-Version und Sie verwenden ein Front-End, das in Access 97 konvertiert worden ist.

  1. Konvertieren Sie die Microsoft Access-Datenbank unter Angabe eines neuen Namens in Microsoft Access 97.

  2. Verwenden Sie den Assistenten zur Datenbankaufteilung, um die konvertierte Datenbank in eine Front-End/Back-End-Anwendung zu konvertieren.

  3. Löschen Sie die vom Assistenten zur Datenbankaufteilung erstellte Back-End-Datenbank. Wenn Sie möchten, dass die Daten in der ursprünglichen Datenbank verbleiben, verwenden Sie die ursprüngliche Datenbank als Back-End-Datenbank. Die Back-End-Datenbank sollte in der ältesten Microsoft Access-Version sein, die verwendet wird.

  4. Führen Sie den Tabellenverknüpfungs-Manager aus (Befehl Datenbank-Dienstprogramme im Menü Extras), um die neue Microsoft Access 97-Front-End-Datenbank mit den Tabellen in der Back-End-Datenbank aus der früheren Version zu verknüpfen. Sie können dann die Microsoft Access 97-Front-End-Datenbank so erweitern, dass neue Features für die Benutzer unterstützt werden, die bereits auf Microsoft Access 97 umgestellt haben. Benutzer früherer Versionen von Microsoft Access können weiterhin die Datenbank der früheren Version verwenden. Sind die Back-End-Tabellen zum Beispiel im Format Microsoft Access, Version 2.0, abgespeichert, können Sie bis zu drei Versionen von Microsoft Access verwenden: Microsoft Access, Version 2.0 (verwenden Sie die ursprüngliche Datenbank), Microsoft Access 95 und 97 (verwenden Sie eine aufbereitete Version der ursprünglichen Datenbank oder eine konvertierte Front-End-Datenbank).


 Verwenden des Registrierungseditors

Verwenden des Registrierungseditors

Achtung Viele der Microsoft Access-Registrierungseinstellungen werden automatisch hinzugefügt, wenn Sie Microsoft Access installieren. Das Ändern der installierten Einstellungen kann unerwartete Ergebnisse hervorrufen und unter Umständen sogar das Neuinstallieren von Microsoft Access erforderlich machen. Es wird dringend empfohlen, die Einstellungen in der Windows-Registrierung nicht zu ändern. Wenn Sie jedoch Registrierungseinstellungen oder -optionen ändern müssen, verwenden Sie dazu den Registrierungseditor von Windows, und ändern Sie nur die Einstellungen oder Optionen, die in den nachstehenden Themen ausdrücklich dokumentiert sind. Geänderte Einstellungen haben erst nach dem Beenden und erneuten Starten von Microsoft Access Gültigkeit. Erstellen Sie vor dem Durchführen von Änderungen unbedingt eine Sicherungskopie der gesamten Registrierung oder zumindest des Teils, den Sie bearbeiten möchten. Weitere Informationen finden Sie im Hilfeindex des Registrierungseditors (verfügbar über die Menüleiste des Registrierungseditors) unter "Sichern der Registrierung".

  1. Um den Registrierungseditor auszuführen, klicken Sie in Windows auf die Schaltfläche Start und anschließend auf Ausführen, geben Sie regedit ein und klicken Sie dann auf OK.

  2. Navigieren Sie zum entsprechenden Registrieungsteilschlüssel. Die beiden wichtigsten Teilschlüssel, die Microsoft Access betreffen sind:
    • \HKEY_LOCAL_MACHINE\SOFTWARE
      \Microsoft\Office\9.0\Access

    • \HKEY_LOCAL_MACHINE\SOFTWARE
      \Microsoft\Jet\4.0

    Wenn sich links vom Teilschlüssel ein Pluszeichen (+) befindet, enthält dieser Registrierungsteilschlüssel weitere Teilschlüssel. Um den Wert/die Werte eines Registrierungsteilschlüssel zu bearbeiten, doppelklicken Sie zum Öffnen auf das Registrierungseditorfenster und doppelklicken Sie dann im rechten Fenster des Registrierungseditorfensters auf den Wert, den Sie bearbeiten möchten. In manchen Fällen müssen möglicherweise neue Teilschlüssel oder Werte hinzugefügt werden. Information zum Hinzufügen neuer Teilschlüssel und Werte finden Sie im Hilfeindex des Registrierungseditors.

Wichtig Die Teilschlüssel, die unter dem Teilschlüssel \Microsoft\Office\9.0\Access angezeigt werden, gelten nur für Microsoft Access 2000. Die Teilschlüssel, die unter dem Teilschlüssel \Microsoft\Jet\4.0 angezeigt werden, gelten für die Microsoft Jet Datenbank-Engine, die Microsoft Access für den Datenzugriff verwendet. Änderungen an diesen Einstellungen haben Einfluss auf Microsoft Access 2000 und andere Programme, die die Microsoft Jet-Datenbank-Engine verwenden, wie z.B. Microsoft Excel 2000, Microsoft Visual Basic 6.0 oder höher und eventuell weitere. Zum Ändern von Einstellungen für die Microsoft Jet-Datenbank-Engine, die nur für Microsoft Access gelten, ändern Sie die Einstellungen im Teilchlüssel \HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Office\9.0\Access\Jet\4.0.


 Verwenden eines Assistenten zum Erstellen eines PivotTable-Formulars

Verwenden eines Assistenten zum Erstellen eines PivotTable-Formulars

  1. Klicken Sie im Datenbankfenster unter Objekte auf Formulare [image] .

  2. Klicken Sie im Datenbankfenster auf Neu.

  3. Klicken Sie im Dialogfeld Neues Formular auf PivotTable-Assistent und dann auf OK.

  4. Folgen Sie den Anleitungen des Assistenten.

    Um weitere Informationen zu PivotTable-Formularen und deren Verwendung zu erhalten, klicken Sie auf [image] .

Anmerkungen

  • Das Formular
    Umsatzanalyse
    in der Beispieldatenbank
    Nordwind
    enthält ein Beispiel für ein PivotTable-Formular. Öffnen Sie im Office-Ordner im Unterordner Samples die Datenbank Nordwind, um sich dieses PivotTable-Formular anzusehen, und öffnen Sie dann das Formular
    Umsatzanalyse
    in der Entwurfsansicht.

  • Die Quelldaten, welche das PivotTable-Formular verwendet, werden nicht automatisch mit dem PivotTable-Formular gespeichert. Statt dessen aktualisieren Sie das PivotTable-Formular jedesmal, wenn Sie sie verwenden möchten, was bedeutet, dass Sie Zugriff auf die gespeicherten Daten benötigen. Wenn Sie wissen, dass die Bearbeitung des PivotTable-Formulars dann erforderlich ist, wenn Sie keinen Zugriff auf die Daten besitzen, speichern Sie eine Kopie der Daten zusammen mit dem PivotTable-Formular. Um weitere Informationen zu diesem Thema zu erhalten, klicken Sie auf [image] .

  • Zum Bearbeiten des PivotTable-Formulars können Sie Microsoft Excel verwenden und die Microsoft Excel-Hilfe zu PivotTable-Berichten aufrufen. Wenn Sie sich in der Formularansicht, befinden, können Sie die Microsoft Access-Hilfe zu PivotTable-Formularen aufrufen.


 Verwenden des Microsoft Office-Assistenten in Microsoft Access

Verwenden des Microsoft Office-Assistenten in Microsoft Access

Wenn Sie von Microsoft Access aus Microsoft Office-Objekte, z.B. den Office-Assistenten, verwenden möchten, stellen Sie zuerst einen Verweis auf die Microsoft Office-Objektbibliothek ein. Klicken Sie dazu im Modul Entwurfsansicht im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen neben Microsoft Office 9.0 Object Library.

Wenn Sie diesen Verweis nicht einstellen, erhalten Sie den Kompilierzeitfehler "Benutzerdefinierter Typ nicht definiert", wenn Sie versuchen, Objekte der Microsoft Office-Objektbibliothek zu verwenden.

Anmerkung Der Office-Assistent steht in der Laufzeitversion von Microsoft Access nicht zur Verfügung.


 Verwenden von Befehlsleisten

Verwenden von Befehlsleisten

Wenn Sie in Microsoft Access 2000 Entwurfsänderungen an Befehlsleisten vornehmen möchten, verwenden Sie das Dialogfeld Anpassen. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie anschließend auf Anpassen. Sie können dieses Dialogfeld zum Hinzufügen und Ändern von Menüleisten, Symbolleisten und Kontextmenüs sowie zum Hinzufügen beliebiger eingebauter Menüelemente oder Symbolleistenschaltflächen zu einer dieser Befehlsleistenarten verwenden. Sie können mit diesem Dialogfeld jedoch nur benutzerdefinierte Befehlsschaltflächen oder Menüelemente zu einer Befehlsleiste hinzufügen. Wenn Sie benutzerdefinierte Bearbeitungsfelder, Dropdownlistenfelder oder Kombinationsfelder zu einer Befehlsleiste hinzufügen möchten, verwenden Sie Visual Basic.


 Verwenden des Microsoft Office-Befehlsleisten-Objektmodells in Microsoft Access

Verwenden des Microsoft Office-Befehlsleisten-Objektmodells in Microsoft Access

Wenn Sie in Microsoft Access 2000 mit Befehlsleisten programmieren möchten, stellen Sie zuerst einen Verweis auf die Microsoft Office Object Library ein. Klicken Sie dazu in der Modul-Entwurfsansicht im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen neben Microsoft Office 9.0 Object Library.


 Die Gültigkeit von Daten unter Verwendung eines Makros überprüfen

Die Gültigkeit von Daten unter Verwendung eines Makros überprüfen

  1. Erstellen Sie ein Makro.

    Wie wird's gemacht?

  2. Stellen Sie sicher, dass im Makrofenster auf der Symbolleiste Bedingungen [image] gedrückt ist.

  3. Geben Sie in der Spalte Bedingung einer leeren Aktionszeile eine Gültigkeitsbedingung ein.

  4. Klicken Sie in der Spalte Aktion in der Aktionsliste auf die Aktion, die Sie ausführen möchten, wenn die Gültigkeitsbedingung wahr ist.

  5. Geben Sie für alle weiteren Aktionen, die Sie ausführen möchten, wenn die Gültigkeitsbedingung wahr ist, in der Spalte Bedingung drei Auslassungspunkte (...) ein, gefolgt von der entsprechenden Aktion in der Spalte Aktion. Es ist z.B. meistens sinnvoll, für jede Gültigkeitsbedingung nach dem Ausführen beliebiger anderer Aktionen die Aktion CancelEvent auszuführen.

  6. Klicken Sie auf Speichern [image] , um das Makro zu speichern.

  7. Öffnen Sie ein Formular in der Entwurfsansicht.

  8. Stellen Sie die Ereignisprozedur für das Ereignis, mit dem Sie die Überprüfung der Gültigkeit starten möchten, auf den Namen des Makros ein. Um die Gültigkeitsprüfung zu starten, wenn zum Beispiel ein Steuerelement aktualisiert wird, stellen Sie die BeforeUpdate-Ereignisprozedur des Steuerelements auf dem Namen des Makros ein.

    Tipp Um die Gültigkeit von Daten zu überprüfen, bevor ein Datensatz als Ganzes aktualisiert wird, ordnen Sie das Gültigkeitsmakro dem BeforeUpdate-Ereignis des Formulars und nicht dem des Steuerelements zu.

Um ein Beispiel zur Überprüfung der Gültigkeit von Daten mit Hilfe eines Makros anzuzeigen, klicken Sie auf [image] .

Um Informationen zu den Ereignissen zu erhalten, die zum Überprüfen der Gültigkeit von Daten verwendet werden, klicken Sie auf [image] .

Um Informationen zur Reihenfolge der Gültigkeitsprüfung für Steuerelemente und Felder zu erhalten, klicken Sie auf [image] .


 Überprüfen der Gültigkeit von Daten unter Verwendung einer Ereignisprozedur

Überprüfen der Gültigkeit von Daten unter Verwendung einer Ereignisprozedur

  1. Öffnen Sie ein Formular in der Entwurfsansicht.

  2. Erstellen Sie die Ereignisprozedur für das Ereignis, mit dem Sie die Gültigkeitsprüfung starten möchten.

    Wie wird's gemacht?

    Um die Gültigkeitsprüfung zu starten, wenn z.B. ein Steuerelement aktualisiert wird, erstellen Sie eine Ereignisprozedur für das BeforeUpdate-Ereignis des Steuerelements.

  3. Fügen Sie der Ereignisprozedur Visual Basic für Applikationen-Code hinzu, der die Gültigkeitsbedingung angibt, sowie Operationen, die ausgeführt werden sollen, wenn die Bedingungen verletzt werden.

Tipps

  • Meistens ist es sinnvoll, das Ereignis, das die Gültigkeitsprüfung startet, abzubrechen, nachdem die Operationen ausgeführt wurden. Sie können auch mehrere Ereignisse abbrechen, indem Sie das Argument Cancel der Ereignisprozedur auf True setzen.

  • Um die Gültigkeit von Daten zu überprüfen, bevor der Datensatz als Ganzes aktualisiert wird, fügen Sie den Code der BeforeUpdate-Ereignisprozedur des Formulars und nicht der des Steuerelements hinzu.

Um ein Beispiel zur Überprüfung der Gültigkeit von Daten mit Hilfe einer Ereignisprozedur anzuzeigen, klicken Sie auf [image] .

Um Informationen über die Ereignisse zu erhalten, die zum Überprüfen der Gültigkeit von Daten verwendet werden, klicken Sie auf [image] .

Um Informationen über die Reihenfolge der Gültigkeitsprüfung für Steuerelemente und Felder zu erhalten, klicken Sie auf [image] .


Anzeigen der Attribute einer Datenbankdatei

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften, während die Datenbank geöffnet ist.

  2. Klicken Sie auf die Registerkarte Allgemein.


 Anzeigen einer Liste von Datenbankobjekten in der aktuellen Access-Datenbank oder im aktuellen Access-Projekt

Anzeigen einer Liste von Datenbankobjekten in der aktuellen Access-Datenbank oder im aktuellen Access-Projekt

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften, während die Microsoft Access-Datenbank oder das Microsoft Access-Projekt geöffnet ist.

  2. Klicken Sie auf die Registerkarte Inhalt.


 Anzeigen der Ergebnisse einer Tabellenerstellungs-, Anfüge- oder Löschabfrage

Anzeigen der Ergebnisse einer Tabellenerstellungs-, Anfüge- oder Löschabfrage

  1. Klicken Sie in der Symbolleiste auf Datenbankfenster [image] .

  2. Klicken Sie im Datenbankfenster unter Objekte auf Tabellen [image] .

  3. Klicken Sie auf die Tabelle, die Sie erstellt oder geändert haben, und klicken Sie dann auf der Symbolleiste des Datenbankfensters auf Öffnen.


 Anzeigen der Ergebnisse einer Auswahl- oder Kreuztabellenabfrage

Anzeigen der Ergebnisse einer Auswahl- oder Kreuztabellenabfrage

Microsoft Access zeigt die Ergebnisse einer Auswahl- oder Kreuztabellenabfrage in einem Datenblatt an. Sie können das Datenblatt entweder von der Abfrageentwurfsansicht aus öffnen oder durch Klicken auf Öffnen in der Symbolleiste des Datenbankfensters.

Aufgabe | Ausführung
Öffnen des Datenblatts aus der Abfrage- Entwurfsansicht | Klicken Sie in der Symbolleiste auf Abfrageansicht [image] .
Öffnen des Datenblatts aus dem Datenbankfenster | Klicken Sie unter Objekte auf Abfragen [image] , doppelklicken Sie auf den Abfragenamen oder wählen Sie die Abfrage aus, und klicken Sie dann auf der Symbolleiste des Datenbankfensters auf Öffnen.

Um die Abfrage abzubrechen, drücken Sie STRG+UNTBR. (Dies funktioniert möglicherweise nicht bei sehr umfangreichen Abfragen.)


 Anzeigen der Ergebnisse einer Aktualisierungsabfrage

Anzeigen der Ergebnisse einer Aktualisierungsabfrage

  1. Klicken Sie in der Abfrageentwurfsansicht in der Symbolleiste auf den Pfeil neben Abfragetyp [image] , und klicken Sie dann auf Auswahl.

  2. Klicken Sie in der Symbolleiste auf Abfrageansicht [image] .


Warum kann ich die Symbolleiste nicht anpassen?

Wenn Sie eine Symbolleiste nicht anpassen können, stellen Sie sicher, dass im Dialogfeld Symbolleisteneigenschaften das Kontrollkästchen Anpassen zulassen aktiviert ist. So lassen Sie das Anpassen einer Symbolleiste zu.

Wenn im Menü Ansicht der Befehl Symbolleisten deaktiviert ist, müssen Sie vielleicht die Einstellungen im Dialogfeld Start ändern oder vorübergehend umgehen.

So ändern Sie die Einstellungen

Klicken Sie im Menü Extras auf Start, und aktivieren Sie das Kontrollkästchen Symbolleisten- und Menüänderungen zulassen. Schließen Sie die Datenbank, und öffnen Sie sie erneut.

So umgehen Sie vorübergehend die Einstellungen im Dialogfeld Start

Sie können alle Einstellungen im Dialogfeld Start vorübergehend umgehen, anstatt die Optionen zurückzusetzen. Halten Sie beim Öffnen der Datenbank die Bypass-Taste (die UMSCHALTTASTE) gedrückt.


Warum kann ich eine Symbol- oder Menüleiste oder ein Kontextmenü nicht ein- oder ausblenden?

Wenn Sie eine Symbolleiste, Menüleiste oder ein Kontextmenü nicht ein- oder ausblenden können, stellen Sie sicher, dass im Dialogfeld Symbolleisteneigenschaften das Kontrollkästchen Einblenden/Ausblenden zulassen aktiviert ist. So lassen Sie das Ein- oder Ausblenden von Symbolleisten, Menüleisten oder Kontextmenüs zu.


Warum ist meine Symbolleiste abgeschnitten?

Es kann sein, dass einige Schaltflächen nicht auf der Symbolleiste angezeigt werden, weil nicht genügend Platz vorhanden ist. Klicken Sie am Ende der Symbolleiste auf Weitere Schaltflächen [image] , um eine Liste weiterer Schaltflächen anzuzeigen.

Vielleicht besteht nicht genügend Platz zur Anzeige aller Schaltflächen, weil sich zwei Symbolleisten in derselben Zeile befinden. Um weitere Schaltflächen anzuzeigen, können Sie die Größe der Symbolleiste ändern oder die Symbolleiste verschieben, damit sie sich in einer eigenen Zeile oder an eine anderen Position befindet.


 Erstellen einer Ereignisprozedur

Erstellen einer Ereignisprozedur

Microsoft Access erleichtert das Ausführen von Code als Reaktion auf eine vom Benutzer ausgeführte Aktion. Wenn Sie eine Ereigniseigenschaft für ein Formular, einen Bericht oder ein Steuerelement auf [Ereignisprozedur] einstellen, erstellt Microsoft Access automatisch die Vorlage für die Ereignisprozedur. Sie müssen nur noch den Code hinzufügen, der als Reaktion auf ein bestimmtes Ereignis im Formular, Bericht oder Steuerelement ausgeführt werden soll. So kann beispielsweise Code ausgeführt werden, wenn ein Benutzer auf eine Befehlsschaltfläche klickt oder Daten ändert.

  1. Öffnen Sie ein Formular oder einen Bericht in der Formular-Entwurfsansicht bzw. der Berichts-Entwurfsansicht.

  2. Zeigen Sie das Eigenschaftenfenster für das Formular oder den Bericht oder aber einen Bereich oder ein Steuerelement im Formular oder Bericht an.

  3. Klicken Sie auf die Registerkarte Ereignis.

  4. Klicken Sie auf die Ereigniseigenschaft für das Ereignis, das die Prozedur starten soll. Um z.B. die Ereignisprozedur für das Ereignis Change anzuzeigen, klicken Sie auf die Eigenschaft Bei Änderung.

  5. Klicken Sie auf die Generator-Schaltfläche [image] neben dem Einstellungsfeld der Eigenschaft, um das Dialogfeld Generator auswählen anzuzeigen.

  6. Doppelklicken Sie auf Code-Generator, um die Anweisungen Sub und End Sub im Formularmodul oder im Berichtsmodul anzuzeigen. Diese Anweisungen definieren (deklarieren) die Ereignisprozedur.

    Microsoft Access deklariert automatisch die Ereignisprozeduren für jedes Objekt und Ereignis in einem Formular- oder Berichtsmodul mit dem Schlüsselwort Private, um anzuzeigen, dass auf die Prozedur nur andere Prozeduren in diesem Modul zugreifen können.

  7. Fügen Sie der Ereignisprozedur den Code hinzu, der beim Eintreten des Ereignisses ausgeführt werden soll. Um z.B. über den Computerlautsprecher einen Signalton zu erzeugen, wenn sich Daten im Textfeld Firma ändern, fügen Sie der Ereignisprozedur Firma_Change die Anweisung Beep folgendermaßen hinzu:
    Private Sub Firma_Change()

    Beep

End Sub

    Diese Ereignisprozedur wird jedesmal ausgeführt, wenn das Ereignis Change für das Objekt eintritt.


 Erstellen einer benutzerdefinierten Sub-Prozedur

Erstellen einer benutzerdefinierten Sub-Prozedur

  1. Öffnen Sie ein neues Modul.
    • Um ein neues Standardmodul zu öffnen, klicken Sie im Datenbankfenster unter Objekte auf Module [image] und dann auf Neu. Um ein vorhandenes Standardmodul zu öffnen, klicken Sie unter Objekte auf Module [image], wählen Sie das zu öffnende Modul aus, und klicken Sie dann auf Entwurf.

    • Um ein Formularmodul oder ein Berichtsmodul zu öffnen, öffnen Sie das Formular oder den Bericht in der Entwurfsansicht, und klicken Sie dann in der Symbolleiste auf Code [image] .

    • Um ein neues Klassenmodul zu öffnen, das keinem Formular oder Bericht zugeordnet ist, klicken Sie im Datenbankfenster im Menü Einfügen auf Klassenmodul. Um ein vorhandenes Klassenmodul zu öffnen, klicken Sie im Datenbankfenster auf Module [image], wählen Sie das zu öffnende Modul aus, und klicken Sie dann in der Symbolleiste des Datenbankfensters auf Entwurf.
  2. Deklarieren Sie die Prozedur, indem Sie die Anweisung Sub eingeben.

  3. Geben Sie einen Prozedurnamen und direkt dahinter in Klammern alle Argumente für die Prozedur ein. Die folgende Deklaration für die Sub-Prozedur AnzeigenEreignis legt z.B. (Ereignisname As String) als Argument fest:
    Sub AnzeigenEreignis(Ereignisname As String)

  4. Fügen Sie den Visual Basic-Code hinzu, der die Operation durchführt, die die Prozedur ausführen soll.

Zum Anzeigen von Informationen zur Sub-Anweisung klicken Sie auf [image] . Um Informationen zum Schreiben von Sub-Prozeduren anzuzeigen, klicken Sie auf [image] .


 Erstellen einer benutzerdefinierten Funktion

Erstellen einer benutzerdefinierten Funktion

  1. Öffnen Sie ein neues Modul.
    • Um ein neues Standardmodul zu öffnen, klicken Sie im Datenbankfenster unter Objekte auf Module [image] und dann auf Neu. Um ein vorhandenes Standardmodul zu öffnen, klicken Sie unter Objekte auf Module [image], wählen Sie das zu öffnende Modul aus, und klicken Sie dann auf Entwurf.

    • Um ein Formularmodul oder ein Berichtsmodul zu öffnen, öffnen Sie das Formular oder den Bericht in der Entwurfsansicht, und klicken Sie dann in der Symbolleiste auf Code [image] .

    • Um ein neues Klassenmodul zu öffnen, das keinem Formular oder Bericht zugeordnet ist, klicken Sie im Datenbankfenster im Menü Einfügen auf Klassenmodul. Um ein vorhandenes Klassenmodul zu öffnen, klicken Sie im Datenbankfenster unter Objekte auf Module [image], wählen Sie das zu öffnende Modul aus, und klicken Sie dann auf Entwurf.
  2. Deklarieren Sie die Funktion, indem Sie die Function-Anweisung eingeben.

  3. Geben Sie einen Funktionsnamen und direkt dahinter in Klammern alle Argumente für die Funktion ein. Die folgende Deklaration für die IsLoaded-Funktion legt z.B. strFormName als Argument fest:
    Function IsLoaded(strFormName As String) As Boolean

  4. Fügen Sie den Visual Basic-Code hinzu, der die Operation oder Berechnung durchführt, die die Funktion ausführen soll.

Zum Anzeigen von Informationen zur Function-Anweisung klicken Sie auf [image] .


 SQL-Aggregatfunktionen

SQL-Aggregatfunktionen

Die SQL-Aggregatfunktionen ähneln den Aggregatfunktionen für Domänen, werden jedoch in einem anderen Zusammenhang verwendet. In Microsoft Access können Sie die SQL-Aggregatfunktionen in einer SQL-Anweisung verwenden, die Sie in der SQL-Ansicht des Abfragefensters erstellt haben, oder in einer SQL-Anweisung in Visual Basic-Code. Umgekehrt können Aggregatfunktionen für Domänen direkt aus Visual Basic-Code aufgerufen werden.

Sie können SQL-Aggregatfunktionen und Aggregatfunktionen für Domänen in Abfrageausdrücken im Abfrageentwurfsbereich verwenden. SQL-Aggregatfunktionen sind sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen.

Sie können beide Typen von Aggregatfunktionen auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.


Datenereignisse

Datenereignisse treten ein, wenn Daten in einem Formular oder Steuerelement eingegeben, gelöscht oder geändert werden, oder wenn sich der Fokus von einem Datensatz zu einem anderen bewegt.

Ereignis | Ereigniseigenschaft | Eintritt
AfterDelConfirm | AfterDelConfirm (Formulare) | Wenn Sie das Löschen von Datensätzen bestätigen und die Datensätze tatsächlich gelöscht wurden, oder nachdem die Löschvorgänge abgebrochen wurden.
AfterInsert | AfterInsert (Formulare) | Nachdem ein neuer Datensatz zur Datenbank hinzugefügt wurde.
AfterUpdate | AfterUpdate (Formulare, Steuerelemente) | Nachdem ein Steuerelement oder ein Datensatz aktualisiert wurde. Dieses Ereignis tritt ein, wenn das Steuerelement oder der Datensatz den Fokus verliert, oder wenn Sie im Menü Datensätze auf Datensatz speichern klicken. Dieses Ereignis tritt für neue und bestehende Datensätze ein.
BeforeDelConfirm | BeforeDelConfirm (Formulare) | Nachdem einer oder mehrere Datensätze gelöscht wurden, jedoch bevor Microsoft Access das Dialogfeld zum Bestätigen oder Abbrechen des Löschvorgangs anzeigt. Dieses Ereignis tritt nach dem Ereignis Delete ein.
BeforeInsert | BeforeInsert (Formulare) | Bei Eingabe des ersten Zeichens in einen neuen Datensatz, aber bevor der Datensatz zur Datenbank hinzugefügt wird.
BeforeUpdate | BeforeUpdate (Formulare, Steuerelemente) | Bevor ein Steuerelement oder Datensatz aktualisiert wird. Dieses Ereignis tritt ein, wenn das Steuerelement oder der Datensatz den Fokus verliert, oder wenn Sie im Menü Datensätze auf Datensatz speichern klicken. Dieses Ereignis tritt für neue und bestehende Datensätze ein.
Change | OnChange (Steuerelemente) | Wenn sich der Inhalt eines Textfelds oder des Textfeldbereichs in einem Kombinationsfeld ändert; z.B. wenn Sie ein Zeichen in ein Steuerelement eingeben oder die Eigenschaft Text des Steuerelements in einem Makro oder in Visual Basic ändern.
Current | OnCurrent (Formulare) | Wenn sich der Fokus zu einem Datensatz bewegt, der dadurch zum aktuellen Datensatz wird, oder wenn Sie die zugrunde liegenden Daten eines Formulars erneut abfragen. Dieses Ereignis tritt ein, wenn ein Formular erstmals geöffnet wird, und wenn sich der Fokus von einem Datensatz zu einem anderen bewegt. Es tritt auch dann ein, wenn Sie die zugrunde liegenden Daten eines Formulars erneut abfragen - z.B. dann, wenn Sie im Menü Datensätze auf Filter/Sortierung entfernen klicken oder die Aktion AnzeigenAlleDatensätze oder die Aktion AktualisierenDaten verwenden.
Delete | OnDelete (Formulare) | Wenn ein Datensatz gelöscht wird, aber bevor der Löschvorgang bestätigt und durchgeführt wird.
Dirty | OnDirty (Formulare) | Wenn sich der Inhalt eines Formulars oder des Textbereichs in einem Kombinationsfeld ändert. Es tritt auch ein, wenn Sie in einem Registersteuerelement von einer Seite zu einer anderen wechseln.
NotInList | OnNotInList (Steuerelemente) | Wenn ein Wert in ein Kombinationsfeld eingegeben wird, der sich nicht in der Kombinationsfeldliste befindet.
Updated | OnUpdated (Steuerelemente) | Wenn die Daten eines OLE-Objekts geändert wurden.


Fehlerereignisse und zeitabhängige Ereignisse

Die folgenden Ereignisse werden zur Fehlerbehandlung und Synchronisation von Daten in Formularen und Berichten verwendet.

Ereignis | Ereigniseigenschaft | Eintritt
Error | OnError (Formulare, Berichte) | Wenn ein Laufzeitfehler in Microsoft Access erzeugt wird, während Sie sich im Formular oder Bericht befinden. Hierzu zählen auch Fehler der Microsoft Jet-Datenbank-Engine, jedoch keine Laufzeitfehler in Visual Basic. (Da Makros die Fehlerart nicht feststellen können, verwenden Sie normalerweise Visual Basic-Ereignisprozeduren für dieses Ereignis.)
Timer | OnTimer (Formulare) | Wenn das Zeitintervall verstrichen ist, das in der Eigenschaft Zeitgeberintervall des Formulars angegeben wurde. Sie können das Ereignis Timer verwenden, um Daten in einer Mehrbenutzerumgebung synchronisiert zu halten, indem Sie Daten in regelmäßigen Abständen erneut abfragen oder aktualisieren.


Filterereignisse

Filterereignisse treten ein, wenn Sie einen Filter in einem Formular anwenden oder erstellen.

Ereignis Ereigniseigenschaft Eintritt
ApplyFilter OnApplyFilter (Formulare) Wenn Sie im Menü Datensätze auf Filter anwenden oder in der Befehlsleiste auf eine der Schaltflächen Filter anwenden bzw. Serverfilter anwenden klicken. Dadurch wird der zuletzt (mit einer der Schaltflächen Formularbasierter Filter bzw. Formularbasierter Serverfilter oder im Fenster Filter) erstellte Filter angewendet.

Wenn Sie auf Auswahlbasierter Filter bzw. Formularbasierter Serverfilter klicken, nachdem Sie im Menü Datensätze auf Filter gezeigt haben, oder in der Befehlsleiste auf die Schaltfläche Auswahlbasierter Filter klicken. Dadurch wird ein Filter angewendet, der von der aktuellen Auswahl im Formular abhängt.

Wenn Sie im Menü Datensätze auf Filter/Sortierung entfernen oder in der Befehlsleiste auf die Schaltfläche Filter entfernen klicken. Dadurch werden alle Filter (oder Sortierungen) entfernt, die momentan auf das Formular angewendet werden.

Wenn Sie das Fenster Filter oder Formularbasierter Filter schließen.
Filter OnFilter (Formulare) Wenn Sie auf Formularbasierter Filter bzw. Formularbasierter Serverfilter klicken, nachdem Sie im Menü Datensätze auf Filter gezeigt haben, oder in der Befehlsleiste auf eine der Schaltflächen Formularbasierter Filter bzw. Formularbasierter Serverfilter klicken. Dadurch wird das Dialogfeld Formularbasierter Filter geöffnet, in dem Sie schnell einen auf den Feldern des Formulars basierenden Filter erstellen können.

Wenn Sie auf Spezialfilter/-sortierung klicken, nachdem Sie im Menü Datensätze auf Filter gezeigt haben. Dadurch wird das Fenster Filter geöffnet, in dem Sie komplexe Filter für das Formular erstellen können.


Fokusereignisse

Fokusereignisse treten ein, wenn ein Formular oder ein Steuerelement den Fokus verliert oder erhält oder ein Formular oder Bericht aktiv oder inaktiv wird.

Ereignis | Ereigniseigenschaft | Eintritt
Activate | OnActivate (Formulare, Berichte) | Wenn ein Formular oder Bericht zum aktiven Fenster wird.
Deactivate | OnDeactivate (Formulare, Berichte) | Wenn ein anderes Microsoft Access-Fenster zum aktiven Fenster wird, jedoch bevor es zum aktiven Fenster wird. Das Ereignis Deactivate tritt nicht ein, wenn sich der Fokus zum Fenster einer anderen Anwendung, einem Dialogfeld oder einem Popupformular bewegt.
Enter | OnEnter (Steuerelemente) | Bevor ein Steuerelement von einem Steuerelement im gleichen Formular oder beim Öffnen des Formulars den Fokus erhält. Dieses Ereignis tritt vor dem Ereignis GotFocus ein.
Exit | OnExit (Steuerelemente) | Unmittelbar bevor ein Steuerelement den Fokus an ein anderes Steuerelement desselben Formulars verliert. Dieses Ereignis tritt vor dem Ereignis LostFocus ein.
GotFocus | OnGotFocus (Formulare, Steuerelemente) | Wenn ein Steuerelement oder ein Formular ohne aktive oder aktivierte Steuerelemente den Fokus erhält. Ein Formular kann den Fokus nur erhalten, wenn alle sichtbaren Steuerelemente des Formulars deaktiviert sind oder das Formular keine Steuerelemente enthält.
LostFocus | OnLostFocus (Formulare, Steuerelemente) | Wenn ein Formular oder Steuerelement den Fokus verliert. Ein Formular kann den Fokus nur erhalten, wenn alle sichtbaren Steuerelemente des Formulars deaktiviert sind oder das Formular keine Steuerelemente enthält.


Tastaturereignisse

Tastaturereignisse treten ein, wenn Sie auf der Tastatur eingeben, oder wenn Tastenfolgen mit der Aktion Tastaturbefehle oder der Anweisung SendKeys übergeben werden.

Ereignis Ereigniseigenschaft Eintritt
KeyDown OnKeyDown (Formulare, Steuerelemente) Wenn Sie eine Taste der Tastatur drücken, während ein Steuerelement oder ein Formular über den Fokus verfügt. Ein Formular kann den Fokus nur erhalten, wenn alle sichtbaren Steuerelemente des Formulars deaktiviert sind oder das Formular keine Steuerelemente enthält.

Das Ereignis KeyDown tritt auch ein, wenn Sie mit der Aktion Tastaturbefehle in einem Makro oder mit der Anweisung SendKeys in Visual Basic eine Tastatureingabe an ein Formular oder Steuerelement senden.

Ein Formular erhält auch alle KeyDown-Ereignisse (auch für Steuerelemente), bevor sie für die Steuerelemente eintreten, wenn Sie die Eigenschaft Tastenvorschau des Formulars auf Ja einstellen.

Wenn Sie eine Taste gedrückt halten, tritt das Ereignis KeyDown wiederholt ein.
KeyPress OnKeyPress (Formulare, Steuerelemente) Wenn Sie eine Taste oder Tastenkombination, die ein Standard-ANSI-Zeichen erzeugt, drücken und wieder loslassen, während ein Steuerelement oder Formular über den Fokus verfügt. Ein Formular kann den Fokus nur erhalten, wenn alle sichtbaren Steuerelemente des Formulars deaktiviert sind oder das Formular keine Steuerelemente enthält.

Sie können das Ereignis KeyPress z.B. verwenden, um auf Tastatureingaben in einem Textfeld oder Kombinationsfeld zu antworten. Verwenden Sie für Tastatureingaben, die von KeyPress nicht erkannt werden (wie z.B. Funktionstasten oder Pfeiltasten) die Ereignisse KeyDown und KeyUp.

Das Ereignis KeyPress tritt auch ein, wenn Sie eine Tastatureingabe, die ein Standard-ANSI-Zeichen erzeugt, mit der Aktion Tastaturbefehle in einem Makro oder mit der Anweisung SendKeys in Visual Basic an ein Formular oder Steuerelement senden.

Ein Formular erhält auch alle KeyPress-Ereignisse (auch für Steuerelemente), bevor sie für die Steuerelemente eintreten, wenn Sie die Eigenschaft Tastenvorschau des Formulars auf Ja einstellen.

Wenn Sie eine Taste gedrückt halten, tritt das Ereignis KeyPress wiederholt ein.
KeyUp OnKeyUp (Formulare, Steuerelemente) Wenn Sie eine gedrückte Taste loslassen, während ein Steuerelement oder ein Formular über den Fokus verfügt. Das Objekt mit dem Fokus erhält alle Tastatureingaben. Ein Formular kann den Fokus nur erhalten, wenn alle sichtbaren Steuerelemente des Formulars deaktiviert sind oder das Formular keine Steuerelemente enthält.

Das Ereignis KeyUp tritt auch ein, wenn Sie eine Tastatureingabe mit der Aktion Tastaturbefehle in einem Makro oder mit der Anweisung SendKeys in Visual Basic an ein Formular oder Steuerelement senden.

Ein Formular erhält auch alle KeyUp-Ereignisse (auch für Steuerelemente), bevor sie für die Steuerelemente eintreten, wenn Sie die Eigenschaft Tastenvorschau des Formulars auf Ja einstellen.

Wenn Sie eine Taste gedrückt halten, tritt das Ereignis KeyUp ein, nachdem alle zugehörigen KeyDown- und KeyPress-Ereignisse eingetreten sind.


 Mausereignisse

Mausereignisse

Mausereignisse treten bei Mausaktionen ein, wenn Sie z.B. eine Maustaste gedrückt halten oder darauf klicken.

Ereignis | Ereigniseigenschaft | Eintritt
Click | OnClick (Formulare, Steuerelemente) | Für ein Steuerelement tritt das Ereignis ein, wenn Sie im Steuerelement die linke Maustaste kurz drücken und loslassen (klicken). Für ein Formular tritt das Ereignis ein, wenn Sie auf einen Datensatzmarkierer oder auf eine Stelle klicken, die keinem Bereich und keinem Steuerelement angehört.
DblClick | OnDblClick (Formulare, Steuerelemente) | Für ein Steuerelement tritt das Ereignis ein, wenn Sie im Steuerelement oder seinem Bezeichnungsfeld die linke Maustaste zweimal kurz drücken und loslassen (doppelklicken). Für ein Formular tritt dieses Ereignis ein, wenn Sie in einem leeren Bereich oder auf einen Datensatzmarkierer eines Formulars doppelklicken.
MouseDown | OnMouseDown (Formulare, Steuerelemente) | Wenn Sie eine Maustaste drücken, während sich der Zeiger in einem Formular oder Steuerelement befindet. Das Abbrechen des Ereignisses MouseDown mit der Aktion AbbrechenEreignis in einem Makro für ein Formular oder ein Steuerelement verhindert, dass das Kontextmenü angezeigt wird, wenn Sie mit der rechten Maustaste auf das Formular oder Steuerelement klicken.
MouseMove | OnMouseMove (Formulare, Steuerelemente) | Wenn Sie den Mauszeiger über ein Formular, einen Formularbereich oder ein Steuerelement bewegen.
MouseUp | OnMouseUp (Formulare, Steuerelemente) | Wenn Sie eine gedrückte Maustaste loslassen, während sich der Zeiger in einem Formular oder Steuerelement befindet.


Druckereignisse

Druckereignisse treten ein, wenn ein Bericht gedruckt oder für das Drucken formatiert wird.

Ereignis | Ereigniseigenschaft | Eintritt
Format | OnFormat (Berichte) | Wenn Microsoft Access ermittelt, welche Daten in einen Berichtsbereich gehören, jedoch bevor Microsoft Access den Bereich für die Seitenansicht oder zum Drucken formatiert. Ihr Makro oder Ihre Ereignisprozedur kann die Daten aus dem aktuellen Datensatz verwenden, um das Seitenlayout zu ändern.
NoData | OnNoData (Berichte) | Wenn Microsoft Access einen Bericht, der keine Daten enthält, zum Drucken formatiert hat (der Bericht ist an eine leere Datensatzgruppe gebunden), jedoch bevor der Bericht gedruckt wird. Sie können dieses Ereignis verwenden, um das Drucken eines leeren Berichts abzubrechen.
Page | OnPage (Berichte) | Wenn Microsoft Access eine Seite zum Drucken formatiert hat, jedoch bevor die Seite gedruckt wird.
Print | OnPrint (Berichte) | Wenn Microsoft Access die Daten in einem Berichtsabschnitt formatiert hat, jedoch bevor der Abschnitt gedruckt wird.
Retreat | OnRetreat (Berichte) | Wenn Microsoft Access in andere Berichtsbereiche auf einer Seite "zurückblättern" muss, um weitere Formatierungsvorgänge durchzuführen. Dieses Ereignis tritt nach dem Ereignis Format des Bereichs, jedoch vor dem Ereignis Print ein. Das Ereignis Retreat tritt für einen Bereich dann ein, wenn Microsoft Access den Bereich sichert. Sie können dadurch alle Änderungen rückgängig machen, die Sie während des Ereignisses Format für den Bereich durchgeführt haben.


Fensterereignisse

Fensterereignisse treten ein, wenn Sie ein Formular oder einen Bericht öffnen, ändern oder schließen.

Ereignis | Ereigniseigenschaft | Eintritt
Close | OnClose (Formulare, Berichte) | Wenn ein Formular oder Bericht geschlossen und am Bildschirm nicht mehr wird.
Load | OnLoad (Formulare) | Wenn ein Formular geöffnet und seine Datensätze angezeigt werden. Dieses Ereignis tritt vor dem Ereignis Current ein, jedoch nach dem Ereignis Open.
Open | OnOpen (Formulare, Berichte) | Wenn ein Formular geöffnet wird, jedoch bevor der erste Datensatz angezeigt wird. Wenn ein Bericht geöffnet wird, jedoch bevor er gedruckt wird.
Resize | OnResize (Formulare) | Wenn sich die Größe eines Formulars ändert. Dieses Ereignis tritt auch ein, wenn ein Formular zum ersten Mal angezeigt wird.
Unload | OnUnload (Formulare) | Wenn ein Formular geschlossen und seine Datensätze entladen werden, jedoch bevor es vom Bildschirm entfernt wird. Dieses Ereignis tritt vor dem Ereignis Close ein.


Tasten zum Versenden von E-Mail-Nachrichten

Taste(n) | Zweck
ALT+D+E+A | Senden des aktiven Datenbankobjekts als E-Mail-Nachricht Informieren Sie sich darüber, wie Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder über das Senden einer Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht.
STRG+UMSCHALT+B | Öffnen des Adressbuches
ALT+K | Überprüfen der Namen in den Feldern An, Cc und Bcc anhand des Adressbuches
TAB | Auswählen des nächsten Feldes im E-Mail-Kopf oder im Text der Nachricht, wenn das letzte Feld im E-Mail-Kopf aktiv ist
UMSCHALT+TAB | Auswählen des vorherigen Feldes oder der vorherigen Schaltfläche im E-Mail-Kopf


 Tasten zum Arbeiten mit der Hilfe

Tasten zum Arbeiten mit der Hilfe

Ist die Hilfe nicht geöffnet, drücken Sie F1. Wenn Sie über den Office-Assistenten Hilfethemen suchen, können Sie Hilfethemen mit Tasten auswählen.

Dieses Thema enthält Referenzinformationen zu:

Arbeiten im Hilfefenster

Bewegen im Navigationsbereich

Bewegen im Themenbereich

Arbeiten im Hilfefenster

Taste(n) | Zweck
F6 | Wechseln zwischen Navigationsbereich und Themenbereich
ALT+O | Anzeigen des Menüs Optionen, um auf einen beliebigen Befehl der Hilfesymbolleiste zuzugreifen
ALT+LEERTASTE | Anzeigen des Systemmenüs des Programms
ALT+F4 | Schließen des aktiven Hilfefensters

Zurück zum Anfang

Bewegen im Navigationsbereich

Taste(n) | Zweck
STRG+TAB | Wechseln zur nächsten Registerkarte
STRG+UMSCHALT+TAB | Wechseln zur vorherigen Registerkarte
ALT+I | Wechseln zur Registerkarte Inhalt
ALT+A | Wechseln zur Registerkarte Antwort-Assistent
ALT+I | Wechseln zur Registerkarte Index
EINGABETASTE | Öffnen oder Schließen eines ausgewählten Buches bzw. Öffnen eines ausgewählten Hilfethemas
NACH-UNTEN-TASTE | Auswählen des nächsten Buches oder Hilfethemas
NACH-OBEN-TASTE | Auswählen des vorherigen Buches oder Hilfethemas

Zurück zum Anfang

Bewegen im Themenbereich

Taste(n) | Zweck
ALT+NACH-LINKS | Zurückgehen zu einem zuvor angezeigten Hilfethema
ALT+NACH-RECHTS | Vorwärtsgehen zu einem zuvor angezeigten Hilfethema
TAB | Wechseln zum ersten oder nächsten Hyperlink
UMSCHALT+TAB | Wechseln zum letzten oder vorherigen Hyperlink
EINGABETASTE | Aktivieren des ausgewählten Hyperlinks
ESC | Schließen des Popupfensters
NACH-OBEN-TASTE | Bildlauf zum Anfang eines Hilfethemas
NACH-UNTEN-TASTE | Bildlauf zum Ende eines Hilfethemas
BILD-NACH-OBEN | Bildlauf in größeren Schritten zum Anfang eines Hilfethemas
BILD-NACH-UNTEN | Bildlauf in größeren Schritten zum Ende eines Hilfethemas
POS1 | Springen zum Anfang eines Hilfethemas
ENDE | Springen zum Ende eines Hilfethemas
STRG+P | Drucken des aktiven Hilfethemas
STRG+A | Markieren des gesamten Hilfethemas
STRG+C | Kopieren der markierten Elemente in die Zwischenablage

Zurück zum Anfang


Verwenden von Tastenkombinationen in der Entwurfsansicht für die Datenzugriffsseite

Taste(n) | Bearbeiten von Steuerelementen
UMSCHALT+EINGABE | Hinzufügen eines Steuerelements zu einem Bereich Informieren Sie sich hierzu unter Ablegen eines Textfeldes oder eines anderen Steuerelements auf einer Datenzugriffsseite unter Verwendung der Tastatur.
STRG+C | Kopieren des ausgewählten Steuerelements in die Zwischenablage
STRG+X | Ausschneiden des ausgewählten Steuerelements in die Zwischenablage
STRG+V | Einfügen des Inhalts der Zwischenablage in die obere linke Ecke des ausgewählten Bereichs
STRG+NACH-RECHTS | Verschieben des ausgewählten Steuerelements um ein Pixel nach rechts (ohne Rücksicht auf das Seitenraster)
STRG+NACH-LINKS | Verschieben des ausgewählten Steuerelements um ein Pixel nach links (ohne Rücksicht auf das Seitenraster)
STRG+NACH-OBEN | Verschieben des ausgewählten Steuerelements um ein Pixel nach oben (ohne Rücksicht auf das Seitenraster)
STRG+NACH-UNTEN | Verschieben des ausgewählten Steuerelements um ein Pixel nach unten (ohne Rücksicht auf das Seitenraster)

Taste(n) | Hinzufügen von Tabellen und Feldern
ALT+H und EINGABETASTE | In der Feldliste: Hinzufügen von Tabellen und Feldern zur Seite


 Verwenden von Tastenkombinationen zum Navigieren in Unterdatenblättern

Verwenden von Tastenkombinationen zum Navigieren in Unterdatenblättern

Taste(n) | Gehen zu einem bestimmten Datensatz
F5 | Im Unterdatenblatt: Springen zum Datensatzzählerfeld; geben Sie dort die Nummer des gewünschten Datensatzes ein, und drücken Sie die EINGABETASTE

Taste(n) | Ein- und Ausblenden des Unterdatenblattes
STRG+UMSCHALT+NACH-UNTEN | Im Datenblatt: Einblenden des Unterdatenblattes für den Datensatz
STRG+UMSCHALT+NACH-OBEN | Ausblenden des Unterdatenblattes

Taste(n) | Navigieren zwischen Datenblatt und Unterdatenblatt
TAB | Wechseln zum Unterdatenblatt aus dem letzten Feld des vorherigen Datensatzes im Datenblatt
UMSCHALT+TAB | Wechseln zum Unterdatenblatt aus dem ersten Feld des nächsten Datensatzes im Datenblatt
STRG+TAB | Verlassen des Unterdatenblattes und Wechseln zum ersten Feld des nächsten Datensatzes im Datenblatt
STRG+UMSCHALT+TAB | Verlassen des Unterdatenblattes und Wechseln zum letzten Feld des vorherigen Datensatzes im Datenblatt
TAB | Im letzten Feld des Unterdatenblattes: Wechseln zum nächsten Feld im Datenblatt
NACH-UNTEN-TASTE | Im Datenblatt: Umgehen des Unterdatenblattes und Wechseln zum nächsten Datensatz im Datenblatt
NACH-OBEN-TASTE | Im Datenblatt: Umgehen des Unterdatenblattes und Wechseln zum vorherigen Datensatz im Datenblatt

Anmerkung Zum Navigieren zwischen den Feldern und Datensätzen in einem Unterdatenblatt können Sie die gleichen Tastenkombinationen wie in der Datenblattansicht verwenden.

Informieren Sie sich über die Verwendung der Tastatur zum Neuanordnen von Spalten.

Informieren Sie sich über das Auswählen von Feldern und Datensätzen in der Datenblattansicht.


Datenbanken: Definition und Funktionsweise 1

Eine Datenbank ist eine Sammlung von Informationen zu einem bestimmten Thema oder Zweck, wie z.B. dem Verfolgen von Bestellungen oder dem Verwalten einer Musiksammlung. Wenn Ihre Datenbank nicht oder nur teilweise in einem Computer gespeichert ist, müssen Sie die Informationen aus den verschiedenen Quellen selbst koordinieren und organisieren.

Speichern von Daten auf Papier, nicht in einem Computer


Datenbanken: Definition und Funktionsweise 2

Mit Microsoft Access können Sie alle Informationen in einer einzigen Datenbankdatei verwalten. Dort speichern Sie Ihre Daten in separaten Tabellen. Die Tabellendaten können Sie in Online-Formularen anzeigen, ergänzen und aktualisieren, mit Hilfe von Abfragen suchen und abrufen sowie in Berichten analysieren oder mit einem bestimmten Layout ausdrucken. Erstellen Sie Datenzugriffsseiten, damit Benutzer die Daten einer Datenbank über das Internet oder ein Intranet anzeigen, aktualisieren oder analysieren können.

Ein Formular, ein Bericht, eine Abfrage und eine Datenzugriffsseite zeigen Daten aus derselben Tabelle an


Datenbanken: Definition und Funktionsweise 3

Zum Speichern Ihrer Daten erstellen Sie eine Tabelle für jeden gewünschten Informationstyp. Um Daten aus mehreren Tabellen in einer Abfrage, einem Formular, einem Bericht oder einer Datenzugriffsseite zusammenzufassen, definieren Sie Beziehungen zwischen den Tabellen.

Zwei Tabellen mit jeweils dem Feld "Kunden-Nr", über das die beiden Tabellen zusammenhängen


Datenbanken: Definition und Funktionsweise 4

Um nur die Daten (selbst aus mehreren Tabellen) zu suchen und abzurufen, die den angegebenen Bedingungen entsprechen, erstellen Sie eine Abfrage. Diese kann auch Daten aus mehreren Datensätzen aktualisieren oder löschen sowie integrierte oder benutzerdefinierte Berechnungen an Ihren Daten durchführen.

Abfrage mit Feldern aus zwei Tabellen


Datenbanken: Definition und Funktionsweise 5

Um Daten mühelos direkt in einer Tabelle anzuzeigen, einzugeben und zu ändern, erstellen Sie ein Formular. Wenn Sie ein Formular öffnen, ruft Microsoft Access die Daten aus einer oder mehreren Tabellen ab und zeigt sie auf dem Bildschirm mit dem Layout an, das Sie im Formular-Assistenten ausgewählt oder ganz neu erstellt haben.

Formular mit einem Informationsdatensatz und der Schaltfläche "Rechnung drucken"


Datenbanken: Definition und Funktionsweise 6

Um Ihre Daten zu analysieren oder in einer bestimmten gedruckten Form darzustellen, erstellen Sie einen Bericht. So können Sie z.B. einen Bericht, der Daten gruppiert und Berechnungen durchführt, und einen zweiten Bericht mit anderen Daten drucken, die zum Drucken von Adressetiketten formatiert sind.

Berichte berechnen Summen, zeigen Diagramme an oder erstellen Adressetiketten


Datenbanken: Definition und Funktionsweise 7

Um Daten im Internet oder in einem Intranet für interaktives Erstellen von Berichten, Dateneingabe oder -analyse zur Verfügung zu stellen, verwenden Sie eine Datenzugriffsseite. Microsoft Access ruft die Daten aus einer oder mehreren Tabellen ab und zeigt sie auf dem Bildschirm mit dem im Seiten-Assistenten ausgewählten oder mit einem ganz neu erstellten Layout an. Benutzer können unter Verwendung von Features der Datenzugriffsseite mit den Daten interaktiv arbeiten.

Gruppierte Datenzugriffsseite mit Erweiterungsschaltflächen und Symbolleisten zur Datensatznavigation


Datenbanken: Definition und Funktionsweise 8

Weitere Informationen

Tabellen: Definition und Funktionsweise

Abfragen: Definition und Funktionsweise

Formulare: Definition und Funktionsweise

Berichte: Definition und Funktionsweise

Datenzugriffsseiten: Definition und Funktionsweise


 Anzeigen eines Kombinationsfelds aus einer Tabelle als Textfeld in einer Abfrage

Anzeigen eines Kombinationsfelds aus einer Tabelle als Textfeld in einer Abfrage

Wenn die Art der Anzeige des Feldes in der Abfrage geändert wird, beeinflusst diese Änderung nicht die Art der Anzeige des Feldes in der zugrunde liegenden Tabelle.

  1. Öffnen Sie die Abfrage in der Entwurfsansicht.

  2. Klicken Sie im Entwurfsbereich der Abfrage mit der rechten Maustaste auf eine beliebige Stelle in der Spalte des zu ändernden Feldes und dann im Kontextmenü auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Nachschlagen.

  4. Klicken Sie im Einstellungsfeld der Eigenschaft Steuerelement anzeigen auf Textfeld.


Beispiel für eine Kreuztabellenabfrage

1 2


Beispiel für eine Kreuztabellenabfrage 1

Kreuztabellenabfragen berechnen eine Summe, einen Durchschnitt, eine Anzahl oder eine andere Funktion für Daten, die nach zwei Informationstypen gruppiert sind: entlang der linken Seite des Datenblatts und entlang der oberen Seite.

Vergleich zwischen Kreuztabellen- und Auswahlabfrage


Beispiel für eine Kreuztabellenabfrage 2

Sie können eine Kreuztabellenabfrage mit einem Assistenten oder ganz neu im Abfrageentwurfsbereich erstellen. Im Entwurfsbereich geben Sie an, welche Feldwerte zu Spalten- bzw. Zeilenüberschriften werden und welche Feldwerte summiert, gezählt oder auf andere Weise berechnet werden sollen.

Beispiel für das Ausfüllen des Abfrageentwurfsbereichs für eine Kreuztabellenabfrage

Weitere Informationen

Erstellen einer Kreuztabellenabfrage unter Verwendung eines Assistenten

Erstellen einer Kreuztabellenabfrage ohne Verwendung eines Assistenten


Beispiel für gruppierte Datensätze in einem Bericht 1

Vergleich zwischen gruppierten und nicht gruppierten Datensätzen


Beispiel für gruppierte Datensätze in einem Bericht 2

Einstellen der Gruppenkopf- und Gruppenfußeigenschaften im Dialogfeld "Sortieren und gruppieren"


Beispiel für gruppierte Datensätze in einem Bericht 3

Ein Kopf auf einer Gruppierungsebene tritt zusammen mit einem Fuß auf derselben Ebene auf

Weitere Informationen

Sortieren von Datensätzen in einem Bericht

Gruppieren von Datensätzen in einem Bericht

Ändern der Sortier- oder Gruppierreihenfolge in einem Bericht

Löschen eines Feldes oder Ausdrucks für das Sortieren oder Gruppieren in einem Bericht


Formulare: Definition und Funktionsweise 1

Sie können Formulare für viele Zwecke verwenden.

Formular zur Dateneingabe, Übersichtsformular und Dialogfeld


Formulare: Definition und Funktionsweise 2

Die meisten Informationen in einem Formular stammen aus einer zugrunde liegenden Datenherkunft. Andere Informationen sind im Formularentwurf gespeichert.

Informationstypen in einem Formular: Text, Daten, Berechnungen und Grafiken


Formulare: Definition und Funktionsweise 3

Sie erstellen die Verknüpfung zwischen einem Formular und seiner Datenherkunft mit Hilfe grafischer Objekte, Steuerelemente genannt. Der am häufigsten zur Anzeige und Eingabe von Daten verwendete Steuerelementtyp ist das Textfeld.

Beziehung zwischen einem Formular und seiner zugrunde liegenden Datenherkunft

Weitere Informationen

Erstellen eines Formulars

Erstellen eines Popupformulars oder benutzerdefinierten Dialogfeldes

Erstellen und Verwalten eines Übersichtsformulars


Informationen zur Abfrage des Tabellenanalyse-Assistenten 1

Der Tabellenanalyse-Assistent teilt eine Tabelle mit Duplikaten in getrennte Tabellen auf, in denen jeder Informationstyp nur einmal gespeichert ist. Auf diese Weise wird die Datenbank kleiner, effizienter und lässt sich leichter aktualisieren. Nachdem der Assistent die Daten aufgeteilt hat, erstellt er eine Abfrage, damit Sie die Daten weiterhin anzeigen und damit arbeiten können.

Zwei aus einer Tabelle erstellte Tabellen mit der Abfrage, die die Daten wieder zusammenfasst


Die Abfrage des Tabellenanalyse-Assistenten 2

Diese Abfrage können Sie verwenden, um Daten aus mehr als einer Tabelle gleichzeitig zu aktualisieren. Die Abfrage bietet noch weitere zeitsparende Features, mit denen Sie die Zuverlässigkeit Ihrer Daten erhöhen können.

Automatische Aktualisierungen in einer Abfrage sowie in Formularen, Berichten und Datenzugriffsseiten, die auf der Abfrage basieren


Die Abfrage des Tabellenanalyse-Assistenten 3

Die Abfrage übernimmt von den neuen Tabellen Nachschlagefelder, mit deren Hilfe Sie Feldwerte ändern können, indem Sie die Werte einfach aus einer Liste auswählen, statt sie exakt eingeben zu müssen.

Nachschlagen in Listen in Abfragen


Die Abfrage des Tabellenanalyse-Assistenten 4

Formulare und Berichte, die zuvor auf der ursprünglichen Tabelle basierten, basieren nun automatisch auf der Abfrage, da der Assistent den Namen der ursprünglichen Tabelle der Abfrage zuweist und die Tabelle umbenennt. Bei Datenzugriffseiten, die auf der ursprünglichen Tabelle basieren, müssen Sie in der Datenherkunft-Eigenschaft den Tabellennamen manuell in den Namen der Abfrage ändern.

Formular mit einer von der Abfrage übernommenen Nachschlageliste


Verknüpfungstypen und ihre Auswirkungen auf die Abfrageergebnisse 1

Eine Verknüpfungslinie zwischen Tabellen oder Abfragen in einer Abfrage zeigt Microsoft Access, wie die Daten zusammenhängen. Der Verknüpfungstyp gibt an, welche Datensätze die Abfrage auswählt oder bearbeitet.

Verknüpfungslinie und ihre Auswirkung auf die Abfrageergebnisse


Verknüpfungstypen und ihre Auswirkungen auf die Abfrageergebnisse 2

Microsoft Access erstellt automatisch Verknüpfungslinien zwischen Tabellen, deren Beziehung (Verbindung zwischen gemeinsamen Feldern) vorher definiert wurde. Wurden vorher keine Beziehungen definiert, so können Sie die Verbindungslinie manuell erstellen, indem Sie ein Feld aus einer Tabelle auf das entsprechende Feld der anderen Tabelle ziehen.

Verknüpfungslinie zwischen Feldlisten in einer Abfrage


Verknüpfungstypen und ihre Auswirkungen auf die Abfrageergebnisse 3

Der Standardverknüpfungstyp wählt nur diejenigen Datensätze aus den verknüpften Tabellen oder Abfragen aus, deren verknüpfte Felder identische Werte enthalten. Wenn die Werte identisch sind, kombiniert die Abfrage die beiden übereinstimmenden Datensätze und zeigt sie in den Ergebnissen als einen Datensatz an.

Abfrageergebnisse aus einer Exklusionsverknüpfung


Verknüpfungstypen und ihre Auswirkungen auf die Abfrageergebnisse 4

Dialogfeld "Verknüpfungseigenschaften" zum Ändern von Verknüpfungstypen


Verknüpfungstypen und ihre Auswirkungen auf die Abfrageergebnisse 5

Abfrageergebnisse aus einer Inklusionsverknüpfung

Weitere Informationen

Ändern des Verknüpfungtyps zwischen Tabellen und Abfragen in einer Abfrage

Verknüpfen mehrerer Tabellen und Abfragen in einer Abfrage

Zusammenfassen von Daten aus mehreren Tabellen oder Abfragen in einer Abfrage


Abfragen: Definition und Funktionsweise 1

Sie verwenden Abfragen, um Daten auf mehrere Arten anzuzeigen, zu ändern und zu analysieren. Sie können sie auch als Datenherkunft für Formulare, Berichte und Datenzugriffsseiten verwenden.

Mehr-Tabellen-Abfrage, Kreuztabellenabfrage und Abfrage für Berechnungen


Abfragen: Definition und Funktionsweise 2

Der häufigste Abfragetyp ist eine Auswahlabfrage. Eine Auswahlabfrage liest Daten aus einer oder mehreren Tabellen unter Berücksichtigung der von Ihnen angegebenen Kriterien und zeigt sie in der gewünschten Reihenfolge an.

So lesen Abfragen Daten aus Tabellen und zeigen sie an


Abfragen: Definition und Funktionsweise 3

Abfrage in Entwurfs- und Datenblattansicht

Weitere Informationen

Erstellen einer Abfrage


Berichte: Definition und Funktionsweise 1

Mit einem Bericht können Sie Ihre Daten wirkungsvoll in gedruckter Form präsentieren. Da Sie Größe und Darstellung aller Bestandteile eines Berichts bestimmen, können Sie die Informationen wie gewünscht anzeigen.

Adressetiketten, Bericht mit gruppierten Datensätzen und Bericht mit Diagramm


 Berichte: Definition und Funktionsweise 2

Die meisten Informationen in einem Bericht stammen aus einer zugrunde liegenden Tabelle, Abfrage oder SQL-Anweisung, der Herkunft der Berichtsdaten. Andere Berichtsinformationen sind im Berichtsentwurf gespeichert.

Informationstypen in einem Bericht: Text, Daten und Ausdrücke


Berichte: Definition und Funktionsweise 3

Beziehung zwischen einem Bericht und der zugrunde liegenden Datenherkunft

Weitere Informationen

Erstellen eines Berichts

Erstellen von Adressetiketten

Erstellen eines Diagramms


Bereiche eines Formulars 1

Sie können die Funktionalität eines Formulars erhöhen, indem Sie einen oder mehrere Bereiche hinzufügen. Alle Formulare haben einen Detailbereich, doch kann ein Formular auch einen Formularkopf-, Seitenkopf-, Seitenfuß- und Formularfußbereich enthalten.

Bereiche eines Formulars in der Entwurfsansicht


Bereiche eines Formulars 2

Diese Abbildung zeigt das Formular Artikel hinzufügen aus dem vorhergehenden Bildschirm in der Formularansicht und als Ausdruck an.

Bereiche eines Formulars in der Formularansicht und als Ausdruck


Bereiche eines Formulars 3

Bereiche eines Unterformulars in Formular- und Entwurfsansicht

Weitere Informationen

Hinzufügen oder Entfernen eines Formularkopfes und -fußes oder eines Seitenkopfes und -fußes

Ändern der Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Formular


Bereiche eines Berichts 1

Die Informationen in einem Bericht lassen sich in Bereiche unterteilen. Jeder Bereich erfüllt einen bestimmten Zweck und wird auf der Seite und im Bericht in klar definierter Reihenfolge gedruckt.

Bereiche eines Berichts in einem Ausdruck


Bereiche eines Berichts 2

In der Entwurfsansicht sind Bereiche als Streifen dargestellt; jeder Bereich im Bericht ist einmal zu sehen. Im gedruckten Bericht wiederholen sich einige Bereiche möglicherweise häufig. Sie bestimmen, welche Informationen in den einzelnen Bereichen angezeigt werden, indem Sie Steuerelemente, wie z.B. Bezeichnungsfelder und Textfelder, hinzufügen.

Bereiche eines Berichts in der Entwurfsansicht


Bereiche eines Berichts 3

Durch Gruppieren von Datensätzen, die einen Wert gemeinsam haben, können Sie Zwischensummen berechnen und einen Bericht lesbarer machen. In diesem Bericht sind die an demselben Tag gesendeten Bestellungen zusammen gruppiert.

Gruppenkopf- und -fußbereich in der Entwurfsansicht und einem gedruckten Bericht

Weitere Informationen

Hinzufügen oder Entfernen eines Berichtskopfes und -fußes oder eines Seitenkopfes und -fußes

Ändern der Größe eines Kopfes, Fußes oder eines anderen Bereichs in einem Bericht

Gruppieren von Datensätzen in einem Bericht


Tabellen: Definition und Funktionsweise 1

Eine Tabelle ist eine Sammlung von Daten zu einem bestimmten Thema, wie z.B. Artikel oder Lieferanten. Wenn Sie für jedes Thema eine separate Tabelle verwenden, vermeiden Sie doppelte Daten. Die Datensicherung wird dadurch effizienter, und Fehler bei der Eingabe werden reduziert.

Tabellen "Lieferanten" und "Artikel"


Tabellen: Definition und Funktionsweise 2

In Tabellen sind Daten in Spalten (Feldern) und Zeilen (Datensätzen) organisiert.

Datensätze und Felder in Tabellen


Tabellen: Definition und Funktionsweise 3

Ein gemeinsames Feld verbindet zwei Tabellen in der Weise, dass Microsoft Access die Daten aus beiden Tabellen gleichzeitig zum Anzeigen, Bearbeiten oder Drucken verwenden kann.

Gemeinsames Feld, das zwei Dateien verbindet


Tabellen: Definition und Funktionsweise 4

In der Tabellenentwurfsansicht können Sie eine Tabelle völlig neu erstellen oder Felder einer vorhandenen Tabelle hinzufügen, löschen oder anpassen.

Bereiche in der Tabellenentwurfsansicht zum Arbeiten mit Feldern, Datentypen und Primärschlüsseln


Tabellen: Definition und Funktionsweise 5

In der Datenblattansicht können Sie einer Tabelle Daten hinzufügen, Daten bearbeiten, ansehen oder auf eine andere Weise mit ihnen arbeiten. Darüber hinaus können Sie Datensätze aus Tabellen, die mit der aktuellen Tabelle zusammenhängen, anzeigen, indem Sie Unterdatenblätter innerhalb des Hauptdatenblattes anzeigen. Mit gewissen Einschränkungen können Sie mit den Daten in Unterdatenblättern in vielerlei Hinsicht genauso wie mit Daten im Hauptdatenblatt arbeiten.

Tools zum Arbeiten mit Daten in der Datenblattansicht

Weitere Informationen

Erstellen einer Tabelle

Möglichkeiten zum Anpassen einer Tabelle

Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle


Möglichkeiten zum Anpassen eines Formulars 1

Mit den folgenden Verfahren können Sie ein mit einem Assistenten erstelltes Formular anpassen oder ein Formular ganz neu erstellen.

Aufgaben, die in der Formular-Entwurfsansicht ausgeführt werden können


Möglichkeiten zum Anpassen einer Abfrage 1

Sie können eine Abfrage in der Abfrage-Entwurfsansicht anpassen und verschiedene Änderungen daran vornehmen.

Möglichkeiten zum Ändern einer Abfrage in der Entwurfsansicht


Möglichkeiten zum Anpassen einer Abfrage 2

Wenn die benötigten Daten in der Abfrage nicht enthalten sind, fügen Sie eine Tabelle oder Abfrage hinzu; fügen Sie anschließend dem Entwurfsbereich die Felder hinzu, mit denen Sie arbeiten möchten.

Hinzufügen von Tabellen oder Abfragen und Feldern zum Abfrageentwurfsbereich


Möglichkeiten zum Anpassen einer Abfrage 3

Addieren Sie die Werte in einem Feld, oder führen Sie andere Berechnungen mit den Daten durch, indem Sie den Typ der durchzuführenden Berechnung angeben.

Zum Durchführen einer vordefinierten Berechnung für die Werte in einem Feld klicken Sie in der Symbolleiste auf Funktionen, um im Entwurfsbereich die Zeile Funktion anzuzeigen.

Definieren von Berechnungen und Gruppierungen im Abfrageentwurfsbereich


Möglichkeiten zum Anpassen einer Abfrage 4

Beschränken Sie die in den Abfrageergebnissen angezeigten oder in eine Berechnung einbezogenen Datensätze, indem Sie Kriterien festlegen.

Festlegen von Kriterien im Abfrageentwurfsbereich


Möglichkeiten zum Anpassen einer Abfrage 5

Sortieren Sie die Abfrageergebnisse, indem Sie im Entwurfsbereich eine Sortierreihenfolge festlegen.

Festlegen einer Sortierreihenfolge im Abfrageentwurfsbereich

Weitere Informationen

Erstellen einer Abfrage


Möglichkeiten zum Anpassen eines Berichts 1

Mit den folgenden Verfahren können Sie einen mit einem Assistenten erstellten Bericht anpassen oder einen Bericht ganz neu erstellen.

Aufgaben, die in der Bericht-Entwurfsansicht ausgeführt werden können


Möglichkeiten zum Anpassen einer Tabelle 1

In der Tabellenentwurfsansicht können Sie eine Tabelle auf viele verschiedene Arten anpassen.

Verschiedene Möglichkeiten zum Anpassen einer Tabelle in der Entwurfsansicht


Möglichkeiten zum Anpassen einer Tabelle 2

In der Tabellenentwurfsansicht können Sie Felder hinzufügen oder löschen, oder Sie können Felder durch das Einstellen von Eigenschaften anpassen.

Öffnen einer Tabelle in der Entwurfsansicht


Möglichkeiten zum Anpassen einer Tabelle 3

Wenn Sie zusätzliche Daten in einer Tabelle verfolgen möchten, fügen Sie weitere Felder hinzu. Falls ein vorhandener Feldname nicht aussagekräftig genug ist, können Sie das Feld umbenennen.

Hinzufügen und Umbenennen von Feldern


Möglichkeiten zum Anpassen einer Tabelle 4

Mit dem Festlegen eines Felddatentyps wird definiert, welche Art von Daten in ein Feld eingegeben werden können. So können Sie z.B. in ein Feld vom Datentyp Währung keinen Text eingeben. Durch Auswählen des entsprechenden Datentyps können Sie sicherstellen, dass die eingegebenen Daten die richtige Form für das Sortieren, Berechnen und andere Operationen aufweisen.

Festlegen von Datentypen


Möglichkeiten zum Anpassen einer Tabelle 5

Feldeigenschaften sind eine Gruppe von Eigenschaften, die zusätzliche Möglichkeiten zur Steuerung der Funktionsweise eines Feldes bieten. Wenn Sie beispielsweise - je nach den Ländereinstellungen in der Windows-Systemsteuerung - bei einem Feld vom Datentyp Zahl oder Währung für die Format-Eigenschaft die Einstellung Währung festlegen, werden automatisch 1.000er-Trennzeichen, ein Währungszeichen und zwei Dezimalstellen angezeigt (1.234,50 DM).

Einstellen von Feldeigenschaften


Möglichkeiten zum Anpassen einer Tabelle 6

Zum Identifizieren aller Datensätze in Ihrer Tabelle verwenden Sie eine eindeutige Kennung, einen sogenannten Primärschlüssel. Dieser erlaubt, vergleichbar mit einem Autonummernschild, die eindeutige Identifizierung eines Datensatzes.

Festlegen eines Primärschlüssels

Weitere Informationen

Hinzufügen eines Feldes zu einer Tabelle in der Entwurfsansicht

Ändern eines Feldnamens in einer Tabelle

Einstellen von Feldeigenschaften zum Anpassen der Einstellungen zum Speichern, Behandeln und Anzeigen von Daten

Welche Primärschlüsselart soll verwendet werden?


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage 1

Abfrageentwurfsbereich mit alternativen Kriterien für ein Feld

Weitere Informationen

Kriterienausdrücke für Abfragen oder Filter - Beispiele

Wo werden Kriterien für das Durchführen von Berechnungen angegeben?


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage 2

Abfrageentwurfsbereich mit zwei Kriterien, die beide einem Feld entsprechen müssen

Weitere Informationen

Kriterienausdrücke für Abfragen oder Filter - Beispiele

Wo werden Kriterien für das Durchführen von Berechnungen angegeben?


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage 3

Abfrageentwurfsbereich mit alternativen Kriterien für zwei Felder

Weitere Informationen

Kriterienausdrücke für Abfragen oder Filter - Beispiele

Wo werden Kriterien für das Durchführen von Berechnungen angegeben?


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage 4

Abfrageentwurfsbereich mit Kriterien, die zwei Feldern entsprechen müssen

Weitere Informationen

Kriterienausdrücke für Abfragen oder Filter - Beispiele

Wo werden Kriterien für das Durchführen von Berechnungen angegeben?


Möglichkeiten zum Bestimmen von mehreren Kriterien in einer Abfrage 5

Abfrageentwurfsbereich mit Und- und Oder-Kriterien für drei Felder

Weitere Informationen

Kriterienausdrücke für Abfragen oder Filter - Beispiele

Wo werden Kriterien für das Durchführen von Berechnungen angegeben?


Möglichkeiten zum Arbeiten mit Daten in einem Formular 1

In der Formularansicht stehen Ihnen alle Tools zur Verfügung, die Sie zum Arbeiten mit Daten benötigen.

Aufgaben, die in der Formularansicht ausgeführt werden können


Möglichkeiten zum Arbeiten mit Daten in einem Formular 2

Tools zum Wechseln von Ansichten sowie zum Drucken, Anzeigen in der Seitenansicht, Ausschneiden, Kopieren, Einfügen und Prüfen der Rechtschreibung von Daten


Möglichkeiten zum Arbeiten mit Daten in einem Formular 3

Tools zum Sortieren, Filtern, Suchen und Ersetzen von Daten


Möglichkeiten zum Arbeiten mit Daten in einem Formular 4

Tools zum Hinzufügen und Löschen von Datensätzen

Weitere Informationen

Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Bearbeiten der Daten in einem Feld

Suchen nach einem Wert in einem Feld

Ersetzen eines Wertes in einem Feld

Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 1

Es gibt viele Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage.

Möglichkeiten zum Arbeiten mit dem Datenblatt einer Abfrage


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 2

Tools zum Ausschneiden, Kopieren, Einfügen, Prüfen der Rechtschreibung und Drucken von Daten sowie deren Anzeigen in der Seitenansicht


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 3

Tools zum Sortieren, Filtern und Suchen von Daten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 4

Tools zum Hinzufügen und Löschen von Datensätzen


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 5

Verschieben, Ausblenden, Fixieren und Ändern der Größe von Spalten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 6

Navigieren zwischen Datensätzen


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Abfrage 7

Während Sie sich die Abfrageergebnisse ansehen, können Sie Daten, die mit den Datensätzen im Datenblatt zusammenhängen, anzeigen, indem Sie ein Unterdatenblatt für diese Daten einfügen. Abgesehen von gewissen Einschränkungen können Sie mit den Daten eines Unterdatenblattes in vielerlei Hinsicht genauso wie mit den Daten des Hauptdatenblattes arbeiten, z.B. Daten filtern und sortieren.

Anzeigen von Unterdatenblättern

Weitere Informationen

Kopieren oder Verschieben von Daten

Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Bearbeiten der Daten in einem Feld

Suchen nach einem Wert in einem Feld

Ersetzen eines Wertes in einem Feld

Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 1

In der Datenblattansicht einer Tabelle gibt es viele Möglichkeiten zum Arbeiten mit Daten.

Möglichkeiten zum Arbeiten mit Daten in einem Datenblatt


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 2

Tools zum Ausschneiden, Kopieren, Einfügen, Prüfen der Rechtschreibung und Drucken von Daten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 3

Tools zum Sortieren, Filtern, Suchen und Ersetzen von Daten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 4

Tools zum Hinzufügen und Löschen von Datensätzen


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 5

Einfügen, Benennen und Löschen von Spalten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 6

Verschieben, Ausblenden, Fixieren und Ändern der Größe von Spalten


Möglichkeiten zum Arbeiten mit Daten im Datenblatt einer Tabelle 7

Anzeigen von Unterdatenblättern im Hauptdatenblatt

Weitere Informationen

Kopieren oder Verschieben von Daten

Erstellen eines Filters in einer Tabelle, einer Abfrage oder einem Formular

Bearbeiten der Daten in einem Feld

Suchen nach einem Wert in einem Feld

Ersetzen eines Wertes in einem Feld

Sortieren von Datensätzen in einer Tabelle, einer Abfrage oder einem Formular


Hinzufügen oder Manipulieren von Feldern

Was möchten Sie tun?

Ein Feld hinzufügen

Ein Feld kopieren

Ein Feld verschieben

Ein Feld umbenennen

Durch Umbenennen eines Feldes entstandene Fehler beheben

Ein Feld löschen


Ändern des Erscheinungsbildes der Datenblattansicht

Was möchten Sie tun?

Schriftart, Schriftstil, Schriftgröße und Farbe in der Datenblattansicht ändern

Gitternetzlinienstil und Hintergrundfarbe in der Datenblattansicht ändern

Standardwerte für das Erscheinungsbild der Datenblattansicht festlegen

Die Größe einer Spalte in der Datenblattansicht ändern

Spalten in der Datenblattansicht verschieben

Spalten in der Datenblattansicht fixieren oder die Fixierung von Spalten aufheben

Spalten in der Datenblattansicht ausblenden

In der Datenblattansicht ausgeblendete Spalten einblenden

Die Größe von Zeilen in der Datenblattansicht ändern


Erstellen, Ändern oder Eingeben von Daten in Tabellen

Was möchten Sie tun?

Einen Überblick über Tabellen und deren Funktionsweise anzeigen

Eine Tabelle erstellen

Eine Tabelle öffnen

Neue Daten in der Datenblatt- oder Formularansicht hinzufügen

Eine Tabelle anpassen


Definieren oder Anzeigen von Beziehungen

Was möchten Sie tun?

Das Fenster Beziehungen anzeigen

Beziehungen definieren

Eine n:n-Beziehung zwischen Tabellen definieren

Vorhandene Beziehungen anzeigen

Beziehungen mit Hilfe der Tastatur verwalten

Das Fenster Beziehungen drucken


Exportieren von Objekten

Was möchten Sie tun?

Daten in eine andere Datenbank oder ein anderes Dateiformat exportieren

Die Ausgabe eines Datenblatts, eines Formulars oder eines Berichts in Microsoft Excel laden

Die Ausgabe eines Objekts als Microsoft Excel-Datei oder als Datei im .RTF-Format speichern


Importieren von Daten

Was möchten Sie tun?

Daten importieren oder verknüpfen

Probleme behandeln, die beim Importieren von Text oder Kalkulationstabellen auftreten


Verknüpfen von Daten

Was möchten Sie tun?

Daten importieren oder verknüpfen

Die Verknüpfung zu einer verknüpften Tabelle löschen

Probleme behandeln, die beim Arbeiten mit verknüpften Tabellen auftreten

Den Dateinamen und den Pfad für verknüpfte Tabellen anzeigen, aktualisieren oder ändern


Arbeiten mit Daten in der Datenblattansicht

Was möchten Sie tun?

Neue Daten in der Datenblatt- oder der Formularansicht hinzufügen

Felder und Datensätze in der Datenblattansicht auswählen

Daten kopieren oder verschieben

Probleme behandeln, die beim Einfügen von Daten auftreten

Das Erscheinungsbild der Datenblattansicht ändern

Die neuesten Daten in der Datenblatt- oder der Formularansicht anzeigen

Unter Verwendung des Feldes Feld auswählen in der Datenblattansicht zwischen Feldern in langen Datensätzen bewegen

Zugriffstasten zum Bearbeiten von Text oder Daten verwenden

Einen Datensatz in der Datenblatt- oder der Formularansicht löschen

Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen rückgängig machen

Den Wert einfügen, der sich im selben Feld des vorherigen Datensatzes befindet


Arbeiten in der Formularansicht

Was möchten Sie tun?

Neue Daten in der Datenblatt- oder der Formularansicht hinzufügen

Daten kopieren oder verschieben

Probleme behandeln, die beim Einfügen von Daten auftreten

Die neusten Daten in der Datenblatt- oder der Formularansicht anzeigen

Einen Datensatz in der Datenblatt- oder Formularansicht löschen

Änderungen beim Hinzufügen oder Bearbeiten von Datensätzen rückgängig machen


Kompilierkonstanten

  • Microsoft Access ist eine 32-Bit-Entwicklungsumgebung. Die Kompilierkonstante Win32 wird immer zu True (-1) ausgewertet, während die Konstante Win16 immer zu False (0) ausgewertet wird.


Erstellen, Ändern oder Eingeben von Daten in Formulare(n)

Was möchten Sie tun?

Eine Übersicht über Formulare und deren Funktionsweise anzeigen

Ein Formular erstellen

Ein Formular öffnen

Neue Daten in der Datenblattansicht oder der Formularansicht hinzufügen

Ein Formular anpassen


 Konstanten, Zeichenfolgen fester Länge, Datenfelder und Declare-Anweisungen sind nicht als öffentliche Elemente von Klassenmodulen zugelassen

Konstanten, Zeichenfolgen fester Länge, Datenfelder und Declare-Anweisungen sind nicht als öffentliche Elemente von Klassenmodulen zugelassen

  • In Microsoft Access existieren Klassenmodule sowohl selbstständig als auch in Verbindung mit Formularen und Berichten. Sie dürfen in einem Formularmodul oder Berichtsmodul keine Konstante, keine Zeichenfolge fester Länge und keine Declare-Anweisung als öffentlich deklarieren. Sie müssen die Deklaration mit dem Schlüsselwort Private einleiten.


 Unzulässige Verwendung des Schlüsselworts "New"

Unzulässige Verwendung des Schlüsselworts "New"

In Microsoft Access sind Formularmodule und Berichtsmodule Klassenmodule. Mit dem Schlüsselwort New können Sie eine neue Instanz eines Klassenmoduls erstellen und diese einer Objektvariablen zuweisen.

Um beispielsweise eine neue Instanz des Formularmoduls Formular_Bestellungen zu erstellen, verwenden Sie das Schlüsselwort New wie im folgenden Code.

Dim frmOrdersObject As New Formular_Bestellungen


 Element in diesem Formular bereits vorhanden

Element in diesem Formular bereits vorhanden

In Microsoft Access können Sie einen Bezeichner in einem Formularmodul und einem Berichtsmodul verwenden, wenn der Bezeichner denselben Namen wie eine Methode oder Eigenschaft des Formulars oder Berichts hat. Da z. B. ein Formular die RecordSource-Eigenschaft hat, bewirkt die folgende Prozedur, wenn sie sich im Modul des Formulars befindet, einen Fehler.

Sub RecordSource()         ' Erzeugt einen Fehler.
    .                            ' Beliebiger Code.
    .
    .
End Sub


ApplyFilter-Methode - Beispiel

Dieses Beispiel verwendet die Methode ApplyFilter, um nur jene Datensätze anzuzeigen, die im Feld Nachname den Namen "Buchwald" enthalten.

DoCmd.ApplyFilter , "Nachname = 'Buchwald'"


Close-Methode - Beispiel

Dieses Beispiel verwendet die Methode Close, um das Formular Bestellungen (Übersicht) zu schließen. Dabei werden alle Änderungen am Formular gespeichert, ohne zuvor nachzufragen.

DoCmd.Close acForm, "Bestellungen (Übersicht)", _
    acSaveYes


CopyObject-Methode - Beispiel

Dieses Beispiel verwendet die Methode CopyObject, um die Tabelle Personal zu kopieren und ihr in der aktuellen Datenbank einen neuen Namen zuzuweisen.

DoCmd.CopyObject, "Personalkopie", acTable, "Personal"


DeleteObject-Methode - Beispiel

Dieses Beispiel löscht die angegebene Tabelle.

DoCmd.DeleteObject acTable, "Alte Personaltabelle"


DoMenuItem-Methode - Beispiel

Dieses Beispiel verwendet die Methode DoMenuItem, um in einer Microsoft Access 95-Datenbank in der Formularansicht den Befehl Einfügen aus dem Menü Bearbeiten auszuführen.

DoCmd.DoMenuItem acFormBar, acEditMenu, acPaste, , _
    acMenuVer70

Das nächste Beispiel führt für eine Datenbank, die im Format von Microsoft Access, Version 2.0, vorliegt, in der Formularansicht den Befehl Vertikal aus dem Menü Fenster aus.

DoCmd.DoMenuItem acFormBar, 4, 0, , acMenuVer20


Echo-Methode (DoCmd-Objekt) - Beispiel

Dieses Beispiel verwendet die Methode Echo, um das Echo auszuschalten und während der Ausführung des Visual Basic-Codes den angegebenen Text in der Statusleiste anzuzeigen.

DoCmd.Echo False, "Visual Basic-Code wird ausgeführt."


FindRecord-Methode - Beispiel

Dieses Beispiel sucht im aktuellen Feld der Datensätze nach dem ersten Vorkommen des Namens "Schmitt". Die Zeichenfolgen "schmitt" und "Schmittchen" werden nicht gefunden.

DoCmd.FindRecord "Schmitt",, True,, True


GoToControl-Methode - Beispiel

Dieses Beispiel verwendet die Methode GoToControl, um den Fokus auf das Feld Personal-Nr zu setzen.

DoCmd.GoToControl "Personal-Nr"


GoToPage-Methode (DoCmd-Objekt) - Beispiel

Dieses Beispiel verwendet die Methode GoToPage, um den Fokus in der zweiten Seite des aktiven Formulars auf die mit dem horizontalen und vertikalen Versatz angegebene Position zu setzen.

DoCmd.GoToPage 2, 1440, 567


GoToRecord-Methode - Beispiel

Dieses Beispiel verwendet die Methode GoToRecord, um den siebten Datensatz im Formular Personal zum aktuellen Datensatz zu machen.

DoCmd.GoToRecord acDataForm, "Personal", acGoTo, 7


Hourglass-Methode - Beispiel

Dieses Beispiel verwendet die Methode Hourglass, um während der Ausführung Ihres Visual Basic-Codes eine Sanduhr (oder ein anderes gewähltes Symbol) anzuzeigen.

DoCmd.Hourglass True


MoveSize-Methode - Beispiel

Dieses Beispiel verschiebt das aktive Fenster und ändert seine Höhe, lässt aber die Fensterbreite unverändert.

DoCmd.MoveSize 1440, 2400, , 2000


OpenDataAccessPage-Methode - Beispiel

Das folgende Beispiel öffnet die Datenzugriffsseite für die Tabelle Personal in der Entwurfsansicht.

DoCmd.OpenDataAccessPage "Personal", 1


OpenForm-Methode - Beispiel

Dieses Beispiel öffnet das Formular Personal in der Formularansicht und zeigt nur die Datensätze an, in denen im Feld Nachname der Name "Buchwald" steht. Die angezeigten Datensätze können bearbeitet, und es können neue Datensätze hinzugefügt werden.

DoCmd.OpenForm "Personal", , ,"[Nachname] = 'Buchwald'"


OpenModule-Methode - Beispiel

Dieses Beispiel öffnet das Modul Dienstprogramme an der Funktion IsLoaded().

DoCmd.OpenModule "Dienstprogramme","IsLoaded"


OpenQuery-Methode - Beispiel

Dieses Beispiel öffnet die Abfrage Umsätze (Gesamt) in der Datenblattansicht und ermöglicht dem Benutzer das Anzeigen, aber nicht das Bearbeiten oder Hinzufügen von Datensätzen.

DoCmd.OpenQuery "Umsätze (Gesamt)", , acReadOnly


OpenReport-Methode - Beispiel

Dieses Beispiel druckt den Bericht Umsätze unter Verwendung der bestehenden Abfrage Berichtsfilter.

DoCmd.OpenReport "Umsätze", acViewNormal, _
    "Berichtsfilter"


OpenStoredProcedure-Methode - Beispiel

Das folgende Beispiel öffnet die Gespeicherte Prozedur Personal in der Entwurfsansicht.

DoCmd.OpenStoredProcedure "Personal", 1


OpenTable-Methode - Beispiel

Dieses Beispiel öffnet die Tabelle Personal in der Seitenansicht.

DoCmd.OpenTable "Personal", acViewPreview


OpenView-Methode - Beispiel

Das folgende Beispiel öffnet die Sicht Personal.

DoCmd.OpenView "Personal"


OutputTo-Methode - Beispiel

Dieses Beispiel gibt die Tabelle Personal im Rich Text-Format (.RTF) aus und öffnet die Datei in Microsoft Word für Windows.

DoCmd.OutputTo acOutputTable, "Personal", _
    acFormatRTF, "PERSONAL.RTF", True


PrintOut-Methode - Beispiel

Dieses Beispiel druckt zwei sortierte Exemplare von den ersten vier Seiten des aktiven Formulars oder Datenblatts.

DoCmd.PrintOut acPages, 1, 4, , 2


Quit-Methode (DoCmd-Objekt) - Beispiel

Dieses Beispiel zeigt ein oder mehrere Dialogfelder an, in denen Sie gefragt werden, ob geänderte Objekte vor dem Beenden von Microsoft Access gespeichert werden sollen.

DoCmd.Quit acQuitPrompt


Rename-Methode - Beispiel

Dieses Beispiel benennt die Tabelle Personal unter Verwendung des angegebenen Namens um.

DoCmd.Rename "Alte Personaltabelle", acTable, _
    "Personal"


RepaintObject-Methode - Beispiel

Dieses Beispiel aktualisiert das Formular Kunden.

DoCmd.RepaintObject acTable, "Kunden"


Requery-Methode (DoCmd-Objekt) - Beispiel

Dieses Beispiel verwendet die Methode Requery, um das Steuerelement Personalliste zu aktualisieren.

DoCmd.Requery "Personalliste"


RunMacro-Methode - Beispiel

Dieses Beispiel führt das Makro Umsätze drucken aus, mit dem der Umsatzbericht zweimal gedruckt wird:

DoCmd.RunMacro "Umsätze drucken", 2


RunSQL-Methode - Beispiel

Dieses Beispiel aktualisiert die Tabelle Personal. Dabei wird die Position aller Verkaufsleiter in Gebietsverkaufsleiter geändert.

DoCmd.RunSQL "UPDATE Personal " & _
    "SET Personal.Position = " & _
    "'Gebietsverkaufsleiter' " & _
    "WHERE Personal.Position = 'Verkaufsleiter';"


Save-Methode - Beispiel

Dieses Beispiel verwendet die Methode Save, um das Formular Neues Personal zu speichern. Das Formular muss geöffnet sein, wenn der Code ausgeführt wird, der diese Methode enthält.

DoCmd.Save acForm, "Neues Personal"


SelectObject-Methode - Beispiel

Dieses Beispiel markiert das Formular Kunden im Datenbankfenster.

DoCmd.SelectObject acForm, "Kunden", True


SendObject-Methode - Beispiel

Dieses Beispiel nimmt die Tabelle Personal im Microsoft Excel-Format in eine E-Mail-Nachricht auf und gibt die Zeilen An, Cc und Betreff der Nachricht an. Die Nachricht wird sofort ohne vorherige Bearbeitung gesendet.

DoCmd.SendObject acSendTable, "Personal", _
    acFormatXLS, "Nancy Davolio; Andreas Fuhlmann", _
    "Johannes Weber", , _
    "Aktuelle Personaltabelle", , False


SetMenuItem-Methode - Beispiel

Dieses Beispiel verwendet die Methode SetMenuItem, um den zweiten Befehl im ersten Menü der benutzerdefinierten Menüleiste für das aktive Fenster zu deaktivieren.

DoCmd.SetMenuItem 0, 1, , acMenuGray


SetWarnings-Methode - Beispiel

Dieses Beispiel schaltet die Anzeige von Systemmeldungen aus.

DoCmd.SetWarnings False


ShowToolbar-Methode - Beispiel

Dieses Beispiel zeigt die benutzerdefinierte Symbolleiste Symbolleiste1 in allen Microsoft Access-Fenstern an, die aktiviert werden.

DoCmd.ShowToolbar "Symbolleiste1", acToolbarYes


TransferDatabase-Methode - Beispiel

Dieses Beispiel importiert den Bericht NW-Umsätze für April aus der Microsoft Access-Datenbank NWVERKÄUFE.MDB in den Bericht Gesamtumsätze für April in die aktuelle Datenbank.

DoCmd.TransferDatabase acImport, "Microsoft Access", _
    "C:\DBS\NWVERKÄUFE.MDB", acReport, _
    "NW-Umsätze für April", "Gesamtumsätze für April"

Dieses Beispiel bindet die Tabelle Authors einer ODBC-Datenbank in die aktuelle Datenbank ein.

DoCmd.TransferDatabase acLink, "ODBC", _
    "ODBC;DSN=DataSource1;UID=User2;PWD=www;LANGUAGE=us_english;" _
    & "DATABASE=pubs", acTable, "Authors", "dboAuthors"


TransferSpreadsheet-Methode - Beispiel

Dieses Beispiel importiert die Daten aus dem angegebenen Bereich der Lotus-Kalkulationstabelle PERSNEU.WK3 in die Microsoft Access-Tabelle Personal. Dabei wird die erste Zeile der Kalkulationstabelle für die Feldnamen verwendet.

DoCmd.TransferSpreadsheet acImport, 3, _
    "Personal","C:\Lotus\Newemps.wk3", True, "A1:G12"


TransferText-Methode - Beispiel

Dieses Beispiel exportiert die Daten aus der Microsoft Access-Tabelle Externer Bericht in die Textdatei mit Trennzeichen APRIL.DOC unter Verwendung der Spezifikation Standardausgabe.

DoCmd.TransferText acExportDelim, "Standardausgabe", _
    "Externer Bericht", "C:\Txtfiles\April.doc"


 Add-Methode (CommandBarControls-Auflistung)

Add-Methode (CommandBarControls-Auflistung)

Sie können das Argument ID dieser Methode auf einen Wert vom Typ Integer einstellen, der einer eingebauten Befehlsschaltfläche oder einem Menüelement entspricht. Auf diese Weise erhält das neue Steuerelement das Aussehen und die Funktionalität der vorhandenen Befehlsschaltfläche oder des Menüelements.

Wenn Sie das Argument ID jedoch auf einen Wert vom Typ Integer einer Microsoft Office-Befehlsschaltfläche oder eines Microsoft Office-Menüelements einstellen, die/das von Microsoft Access geändert wurde (z.B. verwendet Microsoft Access ein anderes Bezeichnungsfeld, anderen Verknüpfungstext oder Text an Stelle eines Symbols), werden die von Microsoft Access vorgenommenen Änderungen an der Befehlsschaltfläche oder dem Menüelement nicht übernommen. Wenn Sie sicherstellen möchten, dass ein Steuerelement, das Sie einer Befehlsleiste hinzufügen, genau wie die Microsoft Access-Version des Steuerelements aussieht und funktioniert, verwenden Sie die Copy-Methode, um das Steuerelement auf die Befehlsleiste zu kopieren .


AddFromFile-, AddFromString-Methoden - Beispiel

Die folgende Funktion fügt mit den Methoden AddFromString und AddFromFile eine Zeichenfolge und den Inhalt einer Textdatei zu einem Standardmodul hinzu.

Function HinzufügenVonTextZuModul(strModulname As String, _
     strDateiname As String, strText As String) As Boolean
    Dim mdl As Module

    On Error GoTo Error_HinzufügenVonTextZuModul
    DoCmd.OpenModule strModulname
    Set mdl = Modules(strModulname)
    mdl.AddFromFile strDateiname
    mdl.AddFromString strText
    HinzufügenVonTextZuModul = True

Exit_HinzufügenVonTextZuModul:
    Exit Function

Error_HinzufügenVonTextZuModul:
    MsgBox Err & ": " & Err.Description
    HinzufügenVonTextZuModul = False
    Resume Exit_HinzufügenVonTextZuModul
End Function

Sie können diese Funktion etwa aus der folgenden Prozedur aufrufen. Erstellen Sie zunächst eine Textdatei mit dem Namen FUNKTIONEN.TXT, fügen Sie einige Visual Basic-Prozeduren hinzu, und speichern Sie die Datei im Verzeichnis Eigene Dateien. Fügen Sie dann die oben aufgeführte Funktion und die folgende Prozedur in ein neues Standardmodul in die Beispieldatenbank Nordwind ein. Führen Sie anschließend die folgende Prozedur aus:

Sub HinzufügenVonFunktionenAusText()
    Dim strModulname As String, strDateiname As String
    Dim strText As String

    strModulname = "Hilfsfunktionen"
    strDateiname = "C:\Eigene Dateien\Funktionen.txt"
    strText = "Public intX As Integer" & vbCrLf _
        & "Const conPfadname As String = " _
        & """C:\Programme\Microsoft Office\Office\Samples\"""
    If HinzufügenVonTextZuModul(strModulname, strDateiname, _
         strText) = True
     Then
        Debug.Print "Zeichenfolge und Dateiinhalt wurden " _
            & "erfolgreich hinzugefügt."
    Else
        Debug.Print "Zeichenfolge und Dateiinhalt wurden " _
            & "nicht erfolgreich hinzugefügt."
    End If
End Sub

Das folgende Beispiel erstellt ein neues Formular und fügt eine Zeichenfolge sowie den Inhalt der Datei FUNKTIONEN.TXT zu dessen Modul hinzu. Führen Sie die folgende Prozedur aus einem Standardmodul heraus aus:

Sub HinzufügenVonTextZuFormularmodul()
    Dim frm As Form, mdl As Module

    Set frm = CreateForm
    Set mdl = frm.Module
    mdl.AddFromString "Public intY As Integer"
    mdl.AddFromFile "C:\Eigene Dateien\Funktionen.txt"
End Sub


AddNew-Methode: Beispiel

Das folgende Beispiel erstellt einen neuen Datensatz in einer Tabelle Personal und speichert die Änderungen:

Sub AddNewRecord()

    Dim cnn As ADODB.Connection
    Dim rst As New ADODB.Recordset

    Set cnn = CurrentProject.Connection
    rst.Open "Personal", cnn, adOpenKeyset, adLockOptimistic, adCmdTableDirect

    With rst
        .AddNew                         ' Neuen Datensatz hinzufügen.
        !Nachname = "Gregory"           ' Daten hinzufügen.
        !Vorname = "Justin"
        !Geburtsdatum = #1/27/1970#
        .Update                         ' Änderungen speichern.
    End With

End Sub


AddNew-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt einen neuen Datensatz in der Tabelle Personal und speichert die Änderungen.

Sub AddNewRecord(ByVal rst As Recordset, _
    strNachname As String, strVorname As String)

    With rst
        .AddNew                            ' Neuen Datensatz hinzufügen.
        !Nachname = strNachname            ' Daten hinzufügen.
        !Vorname = strVorname
        .Update                            ' Änderungen speichern.
    End With
End Sub


Add-, Remove-Methoden (Pages-Auflistung) - Beispiel

Das folgende Beispiel fügt eine Seite zu einem Registersteuerelement auf einem Formular hinzu, das sich in der Entwurfsansicht befindet. Damit Sie dieses Beispiel testen können, erstellen Sie das neue Formular Formular1 mit dem Registersteuerelement RegCtl0. Fügen Sie den folgenden Code in ein Standardmodul ein, und führen Sie ihn aus.

Function HinzufügenSeite() As Boolean
    Dim frm As Form
    Dim tbc As TabControl, pge As Page

    On Error GoTo Error_HinzufügenSeite
    Set frm = Formulare!Formular1
    Set tbc = frm!RegCtl0
    tbc.Pages.Add
    HinzufügenSeite = True

Exit_HinzufügenSeite:
    Exit Function

Error_HinzufügenSeite:
    MsgBox Err & ": " & Err.Description
    HinzufügenSeite = False
    Resume Exit_HinzufügenSeite
End Function

Das folgende Beispiel entfernt Seiten aus dem Registersteuerelement.

Function EntfernenSeite() As Boolean
    Dim frm As Form
    Dim tbc As TabControl, pge As Page

    On Error GoTo Error_EntfernenSeite
    Set frm = Formulare!Formular1
    Set tbc = frm!RegCtl0
    tbc.Pages.Remove
    EntfernenSeite = True

Exit_EntfernenSeite:
    Exit Function

Error_EntfernenSeite:
    MsgBox Err & ": " & Err.Description
    EntfernenSeite = False
    Resume Exit_EntfernenSeite
End Function


 Add-Methode

Add-Methode

Elemente, die einer benutzerdefinierten Auflistung hinzugefügt werden, werden automatisch indiziert. Sie können auf ein bestimmtes Element über diesen Index verweisen. In einer Auflistung colAuflistung, die vier Objekte enthält, könnten Sie z.B. auf das dritte Element der Auflistung mit dem Ausdruck colAuflistung(3) verweisen.

Anmerkung Fügen Sie einem Collection-Objekt Elemente hinzu, so werden diese automatisch mit 1 beginnend indiziert. Bedenken Sie deshalb bei der Aufzählung eines Collection-Objekts, dass der Index mit 1 beginnt. Bei eingebauten Auflistungen ist dies möglicherweise anders, da diese meist beginnend mit 0 indiziert werden.

Wenn Sie einer benutzerdefinierten Auflistung ein Objekt hinzufügen, können Sie zusätzlich zum automatischen Index auch einen benutzerdefinierten Schlüssel für dieses Objekt angeben. In nachfolgenden Verweisen auf dieses Objekt können Sie sich auf den benutzerdefinierten Schlüssel beziehen. Sie können z.B. ein Objekt objLaufrad mit dem folgenden Schlüssel hinzufügen.

colAuflistung.Add Item := objLaufrad, key := ("A")

Sie können später auf dieses bestimmte Objekt in der Auflistung entweder als colAuflistung(A) verweisen oder seinen numerischen Index angeben.


AddToFavorites-Methode - Beispiel

Das folgende Beispiel stellt die Eigenschaft HyperlinkAddress einer Befehlsschaltfläche ein. Wenn der Benutzer auf die Befehlsschaltfläche klickt, wird die Adresse mit Hilfe der Methode AddToFavorites zum Ordner FAVORITEN hinzugefügt.

Damit Sie dieses Beispiel testen können, erstellen Sie ein neues Formular, und fügen Sie die Befehlsschaltfläche Befehl0 hinzu. Fügen Sie den folgenden Code in das Modul des Formulars ein. Wechseln Sie dann zur Formularansicht, und klicken Sie auf die Befehlsschaltfläche.

Private Sub Form_Load()
    Me!Befehl0.HyperlinkAddress = "http://www.microsoft.com/"
End Sub
Private Sub Command0_Click()
    Me!Befehl0.Hyperlink.AddToFavorites
End Sub


Append-Methode: Beispiel

Das folgende Beispiel erweitert die Columns-Auflistung eines Table-Objekts um eine neue Spalte:

Sub NewField()

    Dim cat As New ADOX.Catalog, tbl As ADOX.Table

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cat.ActiveConnection = CurrentProject.Connection
    Set tbl = cat.Tables("Personal")
    ' Neues Feld in Tabelle "Personal" erstellen.
    tbl.Columns.Append "Sozialversicherungsnr.", adVarWChar, 11
    ' Feld anhängen und Auflistung aktualisieren.
    cat.Tables.Refresh
End Sub


AppendChunk- und GetChunk-Methoden: Beispiel

Das folgende Beispiel fügt Daten an ein Feld mit dem Namen Bemerkungen in der Tabelle Personal an. Das Feld Bemerkungen hat den Datentyp Memo. Die Prozedur gibt dann den Inhalt des Feldes unter Verwendung der GetChunk-Methode zurück, fügt ihn zu den Daten hinzu und fügt dann die veränderten Daten mit der AppendChunk-Methode wieder an das Feld Bemerkungen an.

Sub AddToMemo()
Dim cnn As ADODB.Connection, rst As New ADODB.Recordset
Dim fldVorname As ADODB.Field
Dim fldNachname As ADODB.Field
Dim fldBemerkungen As ADODB.Field
Dim lngGröße As Long, strBlock As String

Set cnn = CurrentProject.Connection
rst.Open "Personal", cnn, adOpenKeyset, adLockOptimistic
With rst
Set fldBemerkungen = !Bemerkungen
Set fldVorname = !Vorname
Set fldNachname = !Nachname
Do Until .EOF
If IsNull(fldBemerkungen.Value) Then
strBlock = fldVorname & " " & fldNachname & " ist ein hervorragender Mitarbeiter."
!Bemerkungen = strBlock
.MoveNext
Else
lngGröße = Len(fldBemerkungen)
strBlock = fldBemerkungen.GetChunk(lngGröße)
strBlock = strBlock & " " & fldVorname & " " & fldNachname & " ist ein hervorragender Mitarbeiter."
!Bemerkungen = " "
!Bemerkungen.AppendChunk strBlock
.MoveNext
End If
Loop
End With
rst.Close
cnn.Close
End Sub


AppendChunk-, GetChunk-Methoden - Beispiel (MDB)

Das folgende Beispiel fügt Daten an ein Feld mit dem Namen Bemerkungen in der Tabelle Personal an. Das Feld Bemerkungen hat den Datentyp Memo. Die Prozedur gibt dann den Inhalt des Feldes unter Verwendung der Methode GetChunk zurück, fügt ihn zu den Daten hinzu und fügt dann die veränderten Daten mit der Methode AppendChunk wieder an das Feld Bemerkungen an.

Sub AnMemoAnfügen()
    Dim dbs As Database, rst As Recordset
    Dim fldBemerkungen As Field, fldVorname As Field
    Dim fldNachname As Field
    Dim lngGröße As Long, strBlock As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle erstellen.
    Set rst = dbs.OpenRecordset("Personal")
    ' Verweise auf Field-Objekte holen.
    Set fldBemerkungen = rst!Bemerkungen
    Set fldVorname = rst!Vorname
    Set fldNachname = rst!Nachname

    ' Schleife über alle Datensätze im Recordset.
    Do Until rst.EOF
        ' Überprüfen des Feldes "Bemerkungen" auf Daten.
        If IsNull(fldBemerkungen.Value) Then
            ' Wenn keine Daten vorhanden, nur AppendChunk-Methode verwenden.
            strBlock = fldVorname _
                & " " & fldNachname & " ist ein hervorragender Mitarbeiter!"
            With rst
                .Edit
                !Bemerkungen = strBlock
                .Update
                .MoveNext
            End With
        Else
            lngGröße = Len(fldBemerkungen)
            ' Suchen vorhandener Daten mit GetChunk.
            strBlock = fldBemerkungen.GetChunk(0, lngGröße)
            ' Daten ändern.
            strBlock = strBlock & "  " & fldVorname _
                & " " & fldNachname & " ist ein hervorragender Mitarbeiter!"
            With rst
                .Edit                             ' Bearbeitung aktivieren.
                !Bemerkungen = ""                 ' Feld aktivieren.
                ' Geänderte Daten anfügen.
                .Update                           ' Änderungen speichern.
                ' Zum nächsten Datensatz bewegen.
                .MoveNext                                                                                                              ' Zum nächsten Datensatz bewegen.
            End With
        End If
    Loop
    rst.Close
    Set dbs = Nothing
End Sub


Append-Methode - Beispiel (MDB)

Das folgende Beispiel definiert ein neues Field-Objekt und fügt dieses an die Fields-Auflistung eines TableDef-Objekts an.

Sub NeuesFeld()
    Dim dbs As Database, tdf As TableDef, fld As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    Set tdf = dbs.TableDefs!Personal
    ' Neues Feld in Tabelle "Personal" erstellen.
    Set fld = tdf.CreateField("Personalnummer", dbText, 11)
    ' Feld hinzufügen und Auflistung aktualisieren.
    tdf.Fields.Append fld
    tdf.Fields.Refresh
    Set dbs = Nothing
End Sub


BeginTrans-, CommitTrans- und Rollback-Methoden: Beispiel

Das folgende Beispiel ändert den Kategorientyp des aktuellen Datensatzes im Formular Kategorien und lässt sich diese Änderung durch den Benutzer bestätigen, bevor es die Änderungen unter Verwendung der CommitTrans-Methode speichert.

Dieses Beispiel setzt voraus, dass das Formular Kategorien geöffnet ist

Sub cmdSpeichern_OnClick()
    Dim rs as ADODB.Recordset
    Dim Antwort As Integer

    Set rs = Forms("Kategorien").Recordset
    With rs
        rs.ActiveConnection.BeginTrans
        !Kategorienname = "Getränke"
        .Update
        Antwort = Msgbox("Möchten Sie den aktuellen Wert von " & !Kategorienname & " wirklich ändern?", vbYesNo)
        If Antwort = vbNo Then
            rs.ActiveConnection.RollbackTrans
        Else
            rs.ActiveConnection.CommitTrans
        End If
    End With
End Sub

Das nächste Beispiel ändert die Berufsbezeichnung aller Vertriebsmitarbeiter in einer Tabelle Personal. Nachdem die BeginTrans-Methode eine Transaktion startet, die alle an der Tabelle Personal vorgenommenen Änderungen isoliert, speichert die CommitTrans-Methode diese Änderungen. Beachten Sie, dass Sie die Rollback-Methode verwenden können, um Änderungen rückgängig zu machen, die Sie mit der Update-Methode gespeichert haben. Das Beispiel illustriert außerdem, wie Sie mit Hilfe eines Flags Fehler behandeln lassen, die während einer Transaktion auftreten können.

Eine oder mehrere Tabellenseiten bleiben gesperrt, während der Benutzer festlegt, ob die Änderungen akzeptiert werden sollen oder nicht. Folglich ist diese Technik nicht empfehlenswert, sondern wird hier nur als Beispiel angeführt.

Sub TitelÄndern()
    Dim cnn As ADODB.Connection, rst As New ADODB.Recordset
    Dim strName As String, strMeldung As String, strEingabeaufforderung As String
    Dim fInTrans As Boolean

    On Error GoTo MitFehlerBeenden

    fInTrans = False
    strEingabeaufforderung = "Soll der Titel in Kundenbetreuer geändert werden?"

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cnn = CurrentProject.Connection
    ' Recordset-Objekt erstellen.
    rst.Open "Personal", cnn, adOpenKeyset, adLockOptimistic, adCmdTableDirect
    ' Beginn der Transaktion.
    cnn.BeginTrans
    fInTrans = True
    With rst
    .MoveFirst
    Do Until rst.EOF
        If !Title = "Vertreter" Then
            strName = !Nachname & ", " & !Vorname
            strMeldung = "Mitarbeiter: " & strName & vbCrLf & vbCrLf
            If MsgBox(strMeldung & strEingabeaufforderung, vbQuestion + _
                    vbYesNo, "Berufsbezeichnung ändern") = vbYes Then
                !Title = "Kundenbetreuer"
            End If
        End If
        ' Zum nächsten Datensatz wechseln.
        .MoveNext
    Loop
    End With
    If MsgBox("Sollen die Änderungen gespeichert werden?", vbQuestion + vbYesNo, _
            "Änderungen speichern") = vbYes Then
        cnn.CommitTrans         ' Änderungen festschreiben.
    Else
        cnn.RollbackTrans                ' Änderungen rückgängig machen.
    End If
Beenden:
    rst.Close
    Exit Sub
MitFehlerBeenden:
    MsgBox Err.Number & " " & Err.Description
    If fInTrans Then
        cnn.RollbackTrans
    End If
    Resume Beenden
End Sub


BeginTrans-, CommitTrans-, Rollback-Methoden - Beispiel (MDB)

Das folgende Beispiel verändert die Tätigkeitsbezeichnung aller Verkaufsrepräsentanten in der Tabelle Personal. Nachdem die Methode BeginTrans eine Transaktion gestartet hat, die alle Änderungen an der Tabelle Personal in einem Block vornimmt, speichert die Methode CommitTrans die Änderungen. Beachten Sie, dass die Methode Rollback verwendet werden kann, um Änderungen rückgängig zu machen, die mit der Methode Update gespeichert wurden. Das Beispiel zeigt auch, wie Fehler, die während der Transaktion auftreten können, mit Hilfe eines Flags verwaltet werden.

Eine oder mehrere Tabellenseiten bleiben gesperrt, während der Benutzer entscheidet, ob er die Änderungen akzeptiert oder nicht. Daher wird dieses Verfahren nicht empfohlen, sondern nur als Beispiel dargestellt.

Sub PositionÄndern()
    Dim wsp As Workspace, dbs As Database, rst As Recordset
    Dim strName As String, strMeldung As String, _
        strEingabe As String
    Dim fInTrans As Boolean

    On Error GoTo PositionÄndernFehler

    fInTrans = False
    strEingabe = "Position ändern zu Sachbearbeiter - Kundenwerbung?"
    ' Verweis auf Standardarbeitsbereichsobjekt holen.
    Set wsp = DBEngine.Workspaces(0)
    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle erstellen.
    Set rst = dbs.OpenRecordset("Personal", dbOpenTable)
    ' Beginn der Transaktion.
    wsp.BeginTrans
    fInTrans = True
    rst.MoveFirst
    Do Until rst.EOF
        If rst!Position = "Verkaufsrepräsentant" Then
            strName = rst!Nachname & ", " & rst!Vorname
            strMeldung = "Mitarbeiter: " & strName & vbCrLf & vbCrLf
            If MsgBox(strMeldung & strEingabe, vbQuestion + _
                    vbYesNo, "Position ändern") = vbYes Then
                ' Bearbeitung aktivieren.
                rst.Edit
                rst!Title = "Sachbearbeiter - Kundenwerbung"
                ' Änderungen speichern.
                rst.Update
            End If
        End If
        ' Zum nächsten Datensatz wechseln.
        rst.MoveNext
    Loop
    If MsgBox("Alle Änderungen speichern?", vbQuestion + vbYesNo, _
            " Änderungen speichern") = vbYes Then
        wsp.CommitTrans            ' Änderungen übernehmen.
    Else
        wsp.Rollback                ' Änderungen rückgängig machen.
    End If
ChangeTitleExit:
    rst.Close
    Set dbs = Nothing
    Set wsp = Nothing
    Exit Sub
PositionÄndernFehler:
    MsgBox "Fehler!"
    If fInTrans Then
        wsp.Rollback
    End If
    Resume ChangeTitleExit
End Sub


BuildCriteria-Methode - Beispiel

Im folgenden Beispiel wird der Benutzer aufgefordert, die ersten Buchstaben eines Artikelnamens einzugeben. Anschließend wird mit Hilfe der Methode BuildCriteria eine Kriterienzeichenfolge zusammengestellt, die auf den Eingaben des Benutzers basiert. Als nächstes übergibt die Prozedur diese Zeichenfolge als Argument an die Eigenschaft Filter des Formulars Produkte. Schließlich wird die Eigenschaft FilterOn eingestellt, damit der Filter zugewiesen wird.

Sub FilterEinstellen()
    Dim frm As Form, strMldg As String
    Dim strEingabe As String, strFilter As String

    ' Formular "Artikel" in der Formularansicht öffnen.
    DoCmd.OpenForm "Artikel"
    ' Die Form-Objektvariable einstellen, die auf das Formular
    ' "Artikel" zeigt.
    Set frm = Formulare!Artikel
    strMldg = "Geben Sie einen oder mehrere Buchstaben des " _
    & "Artikelnamens ein, gefolgt von einem Sternchen."
    ' Benutzer zur Eingabe von Text auffordern.
    strEingabe = InputBox(strMldg)
    ' Kriterienzeichenfolge erstellen.
    strFilter = BuildCriteria("Artikelname", dbText, strEingabe)
    ' Eigenschaft Filter einstellen, damit der Filter zugewiesen wird.
    frm.Filter = strFilter
    ' Eigenschaft FilterOn einstellen; das Formular enthält jetzt
    ' gefilterte Datensätze.
    frm.FilterOn = True
End Sub


CancelUpdate- und Update-Methoden: Beispiel

Das folgende Beispiel erstellt einen neuen Datensatz in einer Tabelle Personal, füllt diesen mit Werten und fordert den Benutzer zum Speichern der Änderungen auf. Wenn sich der Benutzer dafür entscheidet, die Änderungen nicht zu speichern, wird die Update-Methode abgebrochen.

Sub Neuer Datensatz()
    Dim cnn As ADODB.Connection, rst As New ADODB.Recordset

    ' Referenz auf aktuelle Verbindung ermitteln.
    Set cnn = CurrentProject.Connection
    rst.Open "Personal", cnn, adOpenKeyset, adLockOptimistic
    With rst
        ' Neuen Datensatz am Ende des Recordset-Objekts hinzufügen.
        .AddNew
        !Nachname = "Christopher"       ' Daten hinzufügen.
        !Vorname = "Kevin"
        !Geburtsdatum = #2/24/1970#        ' Geburtsdatum muss gültig sein

        ' Benutzer wird zum Speichern der Änderungen aufgefordert.
        If MsgBox("Sollen die Änderungen gespeichert werden?", vbYesNo) = vbNo Then
            ' Bei Auswahl von "Nein" Änderungen verwerfen.
            .CancelUpdate
        Else
            ' Bei Auswahl von "Ja" Änderungen speichern.
            .Update
        End If
    End With
    rst.Close
    Set cnn = Nothing
End Sub


CancelUpdate-, Update-Methoden - Beispiel (MDB)

Das folgende Beispiel erstellt einen neuen Datensatz in der Tabelle Personal, gibt Werte ein und fordert den Benutzer auf, die Änderungen zu speichern. Speichert der Benutzer die Änderungen nicht, wird die Methode Update abgebrochen.

Sub NeuerDatensatz()
    Dim dbs As Database, rst As Recordset

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    Set rst = dbs.OpenRecordset("Personal")
    With rst
        ' Neuen Datensatz am Ende des Recordset-Objekts anfügen.
        .AddNew
        !Nachname = "Christmann"        ' Daten hinzufügen.
        !Vorname = "Klaus"
    End With
    ' zum Speichern der Änderungen auffordern.
    If MsgBox("Änderungen speichern?", vbYesNo) = vbNo Then
        ' Wählt der Benutzer Nein, Änderungen rückgängig machen.
        rst.CancelUpdate
    Else
        ' Wählt der Benutzer Ja, Änderungen speichern.
        rst.Update
    End If
    rst.Close
    Set dbs = Nothing
End Sub


Circle-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Circle, um einen Kreis zu zeichnen, anschließend im Kreis einen Kreissektor zu erstellen und diesen rot zu färben.

Damit Sie dieses Beispiel in Microsoft Access testen können, erstellen Sie einen neuen Bericht. Stellen Sie die Eigenschaft OnPrint des Detailbereichs auf [Ereignisprozedur] ein. Geben Sie den folgenden Code in das Modul des Berichts ein, und wechseln Sie dann zur Seitenansicht.

Private Sub Detail_Print(Cancel As Integer, PrintCount As Integer)
    Const conPI = 3.14159265359
    Dim sngHCtr As Single, sngVCtr As Single
    Dim sngRadius As Single
    Dim sngStart As Single, sngEnd As Single

    ' Horizontale Mittelpunktposition.
    sngHCtr = Me.ScaleWidth / 2
    ' Vertikale Mittelpunktposition.
    sngVCtr = Me.ScaleHeight / 2
    ' Kreisradius.
    sngRadius = Me.ScaleHeight / 3
    ' Kreis zeichnen.
    Me.Circle(sngHCtr, sngVCtr), sngRadius
    ' Beginn des Kreissektors.
    sngStart = -0.00000001
    ' Ende des Kreissektors.
    sngEnd = -2 * conPI / 3
    ' Kreissektor rot färben.
    Me.FillColor = RGB(255,0,0)
    ' Kreissektor füllen.
    Me.FillStyle = 0
    ' Kreissektor innerhalb des Kreises zeichnen.
    Me.Circle(sngHCtr, sngVCtr) sngRadius, , sngStart, sngEnd
End Sub


Clone-Methode: Beispiel

Das folgende Beispiel erstellt ein Recordset-Objekt, indem es zunächst eine SQL-Anweisung auf einer Tabelle Personal ausführt und dann mit Hilfe der Clone-Methode eine Kopie des Recordset-Objekts generiert, so dass Lesezeichen von beiden Objekten gemeinsam genutzt werden können. Dieses Verfahren ist besonders hilfreich, wenn das Ergebnis einer Abfrage von mehr als einer Seite gleichzeitig verglichen werden soll.

Die Funktion liest den Wert der Bookmark-Eigenschaft des aktuellen Datensatzes und speichert ihn in einer Variablen. Im vorliegenden Fall ist der aktuelle Datensatz der zweite Datensatz des ursprünglichen Recordset-Objekts. Die Bookmark-Eigenschaft der Kopie des Recordset-Objekts erhält diese Zeichenfolge als Wert, so dass auch in diesem Recordset-Objekt als aktueller Datensatz der zweite Datensatz gilt. In beiden Datensatzgruppen sind die aktuellen Werte des Feldes Nachname identisch, wovon Sie sich durch entsprechende Ausgaben im Testfenster überzeugen können.

Sub CloneErstellen()
    Dim cnn As ADODB.Connection
    Dim rstPersonal As New ADODB.Recordset, rstDuplikat As ADODB.Recordset
    Dim fldName As ADODB.Field, varLesezeichen As Variant

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cnn = CurrentProject.Connection
    ' Recordset-Objekt vom Typ "dynaset" öffnen.
        rstPersonal.Open "SELECT * FROM Personal ORDER BY Nachname", _ cnn, adOpenKeyset, adLockOptimistic
    ' Kopie des Recordset-Objekts anlegen.
    Set rstDuplikat = rstPersonal.Clone
    Set fldName = rstPersonal.Fields!Nachname
    ' Aktuellen Datensatz festlegen.
    rstPersonal.MoveFirst
    ' Zum zweiten Datensatz wechseln.
    rstPersonal.MoveNext
    ' Wert der Bookmark-Eigenschaft lesen und aktuellen Feldwert ausgeben.
    If rstPersonal.Properties("Bookmarkable") Then
        varLesezeichen = rstPersonal.Bookmark
        Debug.Print fldName.Value
        ' Bookmark-Eigenschaft des Clone auf den gerade gelesenen Wert setzen.
            rstDuplikat.Bookmark = varLesezeichen
        Debug.Print fldName.Value
    End If

    rstPersonal.Close
    rstDuplikat.Close
    Set cnn = Nothing
End Sub


Clone-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt unter Verwendung einer SQL-Anweisung in einer Tabelle mit dem Namen Personal und verwendet dann die Methode Clone, um eine Kopie des Recordset-Objekts zu erstellen, so dass Lesezeichen von beiden Objekten gemeinsam genutzt werden können. Dieses Verfahren ist besonders hilfreich, wenn Sie das Abfrageergebnis an mehreren Punkten gleichzeitig vergleichen müssen.

Die Funktion liest den Wert der Eigenschaft Bookmark des aktuellen Datensatzes und speichert ihn in einer Zeichenfolgenvariablen; aktueller Datensatz ist in diesem Fall der zweite Datensatz des ursprünglichen Recordset-Objekts. Die Eigenschaft Bookmark des kopierten Recordset-Objekts wird auf diese Zeichenfolge eingestellt, so dass der zweite Datensatz auch in diesem Recordset-Objekt zum aktuellen Datensatz wird. Die aktuellen Werte des Feldes Nachname für beide Datensatzgruppen sind identisch, wie Sie selbst sehen können, wenn diese im Testfenster ausgegeben werden.

Sub KopieErstellen()
    Dim dbs As Database
    Dim rstPersonal As Recordset, rstKopie As Recordset
    Dim fldName As Field, varLesezeichen As Variant

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rstPersonal = dbs.OpenRecordset("SELECT * " _
        & "FROM Personal ORDER BY  Nachname")
    ' Recordset-Objekt kopieren.
    Set rstKopie = rstPersonal.Clone
    Set fldName = rstPersonal.Fields!Nachname
    ' Aktuellen Datensatz festlegen.
    rstPersonal.MoveFirst
    ' Zum zweiten Datensatz wechseln.
    rstPersonal.MoveNext
    ' Lesezeichen-Wert abrufen und aktuellen Feldwert ausgeben.
    If rstPersonal.Bookmarkable Then
        varLesezeichen = rstPersonal.Bookmark
        Debug.Print fldName.value
    Else
        ' Falls Recordset-Objekt Lesezeichen nicht unterstützt,
        ' Prozedur beenden.
        GoTo ExitCreateClone
    End If
    ' Eigenschaft "Bookmark" der Kopie auf erhaltenen Wert einstellen.
    rstKopie.Bookmark = varLesezeichen
    Debug.Print fldName.value

ExitCreateClone:
    rstPersonal.Close
    rstKopie.Close
    Set dbs = Nothing
End Sub


Close-Methode: Beispiel

Das folgende Beispiel erstellt ein Connection-Objekt, das einen Verweis auf die aktuelle Verbindung darstellt, und öffnet ein Recordset-Objekt des Typs "Tabelle" auf der Basis einer Datenbanktabelle Kunden. Die Prozedur verwendet die Close-Methode der Recordset-Objektvariablen, um die von dieser benutzten Speicherressourcen freizugeben. Die Set-Anweisung mit dem Schlüsselwort Nothing dient der Freigabe von Ressourcen, die von der Connection-Objektvariablen belegt wurden.

Sie können auch die Close-Methode des Connection-Objekts benutzen, um es zu schließen und den Speicher freizugeben. Die Close-Methode des Connection-Objekts schließt die in Microsoft Access geöffnete Datenbank nicht wirklich, sondern gibt nur die Ressourcen frei, die die Connection-Objektvariable belegt.

Die Benutzung der Close-Methode eines Objekts und das Festlegen der Objektvariablen auf den Wert Nothing sind gleichwertige Verfahren zur Speicherfreigabe.

Sub CloseVerwenden()
    Dim cnn As ADODB.Connection, rst As New ADODB.Recordset

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cnn = CurrentProject.Connection
    ' Recordset vom Typ "Tabelle" erstellen.
    rst.Open "Kunden",cnn

    ' Beliebiger Code

    ' Recordset schließen, um Speicher freizugeben.
    rst.Close
    ' Freigabe des von der Objektvariablen belegten Speichers.
    Set cnn = Nothing
End Sub


 CloseConnection-Methode

CloseConnection-Methode

Mit der CloseConnection-Methode können Sie die aktuelle Verbindung trennen, die zwischen dem CurrentProject-Objekt oder dem CodeProject-Objekt eines Microsoft Access-Projekts (.adp) bzw. einer Access-Datenbank (.mdb) auf der einen Seite und der Datenbank, die in der Verbindungszeichenfolge des Projekts angegeben wurde, auf der anderen Seite besteht.

Syntax

Objekt.CloseConnection

Die CloseConnection-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Ein Zeichenfolgenausdruck, der zum CurrentProject-Objekt oder CodeProject-Objekt ausgewertet wird.

Anmerkungen

Die CloseConnection-Methode schließt die aktuelle Verbindung des Access-Projekts, der Datenbank oder des Datenquellen-Steuerelements, gibt das ADO Connection-Objekt frei und legt die Connection-Eigenschaft auf Null fest. Die BaseConnectionString-Eigenschaft bleibt unverändert. Benutzern wird davon abgeraten, einen Aufruf der Art Datenquellen-Steuerelement.Connection.Close durchzuführen. Sie sollten stattdessen diese Methode verwenden.

Die CloseConnection-Methode erweist sich als nützlich, wenn Sie eine Microsoft Access-Datenbank von einer anderen Anwendung aus durch Automatisierung geöffnet haben.


CloseCurrentDatabase-Methode - Beispiel

Das folgende Beispiel öffnet über Automatisierung eine Microsoft Access-Datenbank von einer anderen Anwendung aus, erstellt ein neues Formular, speichert es und schließt anschließend die Datenbank.

Sie können diesen Code in jeder Anwendung, die als COM-Komponente fungieren kann, in ein Visual Basic-Modul eingeben. Sie könnten z. B. den folgenden Code aus Microsoft Excel oder Microsoft Visual Basic heraus ausführen.

Wenn der Programmbereich verlassen wird, in dem die Variable gültig ist, die auf das Objekt Application zeigt, wird auch die Microsoft Access-Instanz geschlossen, die der Variablen entspricht. Sie sollten diese Variable daher auf Modulebene deklarieren.

' Geben Sie folgende Zeile in den Deklarationsbereich des Moduls ein.
Dim appAccess As Access.Application

Sub FormularErstellen()
    Const strConPfadZuDenBeisp = "C:\Programme\Microsoft Office\Office\Samples\"

    Dim frm As Form, strDB As String

    ' Den Pfad der Datenbank angeben.
    strDB = strConPfadZuDenBeisp & "Nordwind.mdb"
    ' Neue Instanz von Microsoft Access erstellen.
    Set appAccess = CreateObject("Access.Application.9")
    ' Datenbank im Microsoft Access-Fenster öffnen.
    appAccess.OpenCurrentDatabase strDB
    ' Ein neues Formular erstellen.
    Set frm = appAccess.CreateForm
    ' Das neue Formular speichern.
    appAccess.DoCmd.Save , "NeuesFormular1"
    ' Die momentan geöffnete Datenbank schließen.
    appAccess.CloseCurrentDatabase
    Set AppAccess = Nothing
End Sub


 Close-Methode

Close-Methode

Enthält eine Visual Basic-Prozedur eine Objektvariable, welche die momentan in Microsoft Access geöffnete Datenbank darstellt, so bewirkt das Ausführen der Close-Methode auf diesem Objekt, dass der Gültigkeitsbereich der Variablen verlassen wird. Die Close-Methode hat keine Auswirkung auf die Datenbank, die im Microsoft Access-Datenbankfenster geöffnet ist.


Open-Methode (Connection)

Verwenden Sie in Microsoft Access CurrentProject.Connection, um einen Verweis auf die aktuelle Datenbank zurückzugeben, und weisen Sie diese wie im folgenden Beispiel einer Variablen vom Typ Connection zu.

Dim cnnCurrent As ADODB.Connection
Set cnnCurrent = CurrentProject.Connection

Verwenden Sie die Open-Methode einer Variablen vom Typ Connection, um eine andere als die aktuelle Datenbank aus Visual Basic zu öffnen.


CodeDb-Methode: Beispiel

Das folgende Beispiel verwendet die CodeDb-Methode, um ein Database-Objekt zurückzugeben, das auf eine Bibliotheksdatenbank verweist. Diese Bibliotheksdatenbank enthält eine Tabelle Fehler sowie den aktuell ausgeführten Code. Nachdem die CodeDb-Methode diese Informationen ermittelt hat, öffnet die GetErrorString-Funktion eine Datensatzgruppe des Typs "Tabelle" auf Grundlage der Tabelle Fehler. Anschließend extrahiert die Funktion eine Fehlermeldung aus einem Feld namens Fehlerdaten basierend auf dem der Funktion übergebenen Integer-Wertes.

Function FehlerzeichenfolgeErmitteln(ByVal intFehler As Integer) As String
    Dim dbs As Database, rst As RecordSet

    ' Variable verweist auf Datenbank, deren Code ausgeführt wird.
    Set dbs = CodeDb
    ' Recordset-Objekt des Typs "Tabelle" erstellen.
    Set rst = dbs.OpenRecordSet("Fehler", dbOpenTable)
    ' Index nach Primärschlüssel (Feld FehlerID) sortieren.
    rst.Index = "PrimaryKey"
    ' Fehlernummer suchen, die der GetErrorString-Funktion als Argument übergeben wurde.
    rst.Seek "=", intFehler
    ' Zugehörige Fehlermeldung zurückgeben.
    GetErrorString = rst.Fields!FehlerDaten.Value
    rst.Close
End Function


 CompactDatabase-Methode (MDB)

CompactDatabase-Methode (MDB)

Um eine Datenbank im Microsoft Access-Fenster zu komprimieren, zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie auf Datenbank komprimieren und reparieren.

Anmerkung: Die Methode CompactDatabase wandelt eine Access-Datenbank (.mdb) nicht vollständig von einer Version in die andere um. Lediglich das Datenformat wird umgewandelt. Von Microsoft Access definierte Objekte, z. B. Formulare und Berichte, werden nicht umgewandelt. Um eine Datenbank aus einer früheren Version umzuwandeln, zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie auf Datenbank komprimieren und reparieren.


CopyQueryDef-Methode - Beispiel (MDB)

Das folgende Beispiel verwendet die Methode CopyQueryDef, um eine Kopie eines QueryDef-Objekts zurückzugeben, das eine Abfrage mit dem Namen Rechnungen repräsentiert, und gibt die Eigenschaft SQL dieses QueryDef-Objekts aus.

Sub QueryDefKopie()
    Dim dbs As Database, rst As Recordset
    Dim qdfOriginal As QueryDef, qdfKopie As QueryDef

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf die Abfrage "Rechnungen" holen.
    Set qdfOriginal = dbs.QueryDefs!Rechnungen
    ' Recordset-Set vom Typ Dynaset öffnen.
    Set rst = qdfOriginal.OpenRecordset
    ' Kopie des ursprünglichen QueryDef-Objekts abrufen.
    Set qdfKopie = rst.CopyQueryDef
    ' Wert der Eigenschaft "SQL" der Kopie ausgeben.
    Debug.Print qdfKopie.SQL
    rst.Close
    Set dbs = Nothing
End Sub


CreateControl-, CreateReportControl-Methoden - Beispiel

Dieses Beispiel erstellt zunächst ein neues Formular, das auf der Tabelle Bestellungen basiert. Anschließend erstellt es mit Hilfe der CreateControl-Methode im Formular ein Textfeld-Steuerelement und ein zugeordnetes Bezeichnungsfeld-Steuerelement .

Sub NeueSteuerelemente()
    Dim frm As Form
    Dim ctlBezeichnungsfeld As Control, ctlText As Control
    Dim intDatenX As Integer, intDatenY As Integer
    Dim intBezeichnungsfeldX As Integer, intBezeichnungsfeldY As Integer

    ' Neues Formular mit Tabelle "Bestellungen" als Datenherkunft erstellen.
    Set frm = CreateForm
    frm.RecordSource = "Bestellungen"
    ' Positionswerte für neue Steuerelemente festlegen.
    intBezeichnungsfeldX = 100
    intBezeichnungsfeldY = 100
    intDatenX = 1000
    intDatenY = 100
    ' Ungebundenes Textfeld von Standardgröße im Detailbereich erstellen.
    Set ctlText = CreateControl(frm.Name, acTextBox, , "", "", _
        intDatenX, intDatenY)
    ' Untergeordnetes Bezeichnungsfeld-Steuerelement für Textfeld erstellen.
    Set ctlBezeichnungsfeld = CreateControl(frm.Name, acLabel, , _
         ctlText.Name, "NeuesBezeichnungsfeld", intBezeichnungsfeldX, _
         intBezeichnungsfeldY)
    ' Formular wiederherstellen.
    DoCmd.Restore
End Sub


CreateDataAccessPage-Methode: Beispiel

Das folgende Codefragment illustriert, wie Sie vorgehen könnten, um eine neue Datenzugriffsseite zu erstellen, mit dem HTML-Text der Seite zu arbeiten, dann eine Verknüpfung mit der Seite zu erstellen und sie auf der Festplatte zu speichern. Der Prozedurcode zeigt auch eine Möglichkeit, den Fall einer bereits vorhandenen Datei durch eine Fehlerbehandlung abzufangen:

Function DatenzugriffsseiteErstellen(strDateiname As String) As Boolean
    Dim dapNeueSeite As DataAccessPage

    Const SEITE_BEREITS_VORHANDEN As Long = 2023

    On Error GoTo FehlerBeimErstellen
    ' Neue Seite erstellen.
    Set dapNeueSeite = Application.CreateDataAccessPage(strDateiname, _
        True)
    ' Mit Hilfe der "Document"-Eigenschaft wird das Internet Explorer 5.0-
    ' Dokumentenobjekt ermittelt. Anschließend kann der HTML-Inhalt der Seite
    ' über die Internet Explorer-Objekte manipuliert werden.

    With dapNeueSeite.Document
        .All("HeadingText").innerText = "Diese Seite wurde " _
            & "programmgesteuert erstellt!"
        .All("HeadingText").Style.display = ""
        .All("BeforeBodyText").innerText = "Um die HTML-Elemente " _
            & "innerhalb einer Datnezugriffsseite manipulieren zu können, " _
            & "müssen Sie zunächst die 'Document'-Eigenschaft der Seite verwenden, " _
            & "um auf den HTML-Inhalt zugreifen zu können. "
            .All("BeforeBodyText").Style.display = ""
    End With

    ' Seite schließen und alle Änderungen speichern.
    DoCmd.Close acDataAccessPage, dapNeueSeite.Name, acSaveYes
    DatenzugriffsseiteErstellen = True
Beenden:
    Exit Function
FehlerBeimErstellen:
    If Err = SEITE_BEREITS_VORHANDEN Then
        ' Die in strDateiname angegebene Datei existiert bereits.
        ' Sie wird daher durch eine neue Seite ersetzt.
        If MsgBox("'" & strDateiname & " existiert bereits. Möchten Sie " _
            & "diese Seite durch eine neue leere Seite ersetzen?", vbYesNo, _
            "Vorhandene Seite ersetzen?") = vbYes Then
            Set dapNeueSeite = Application.CreateDataAccessPage(strDateiname, False)
            Resume Next
        Else
            DatenzugriffsseiteErstellen = False
            Resume Beenden
        End If
    Else
        DatenzugriffsseiteErstellen = False
        Resume Beenden
    End If
End Function

Das folgende Codefragment zeigt, wie die CreateDataAccessPageMethode verwendet werden kann, um mehrere Verknüpfungen mit einer einzigen Seite auf der Festplatte zu erstellen.

Sub Foo()
    Dim dapNeueSeite As DataAccessPage
    Set dapNeueSeite = _
        Application.CreateDataAccessPage("c:\footest.htm", True)
    DoCmd.Close acDataAccessPage, dapNeueSeite.Name, acSaveYes
    Set dapNeueSeite = _
        Application.CreateDataAccessPage("c:\footest.htm", False)
    DoCmd.Close acDataAccessPage, dapNeueSeite.Name, acSaveYes
End Sub


 CreateDatabase-Methode (MDB)

CreateDatabase-Methode (MDB)

Die Methode CreateDatabase in der DAO-Objektbibliothek erstellt eine neue Access-Datenbank (.mdb) aus Visual Basic, öffnet die neue Datenbank, fügt sie der Auflistung Databases hinzu und speichert sie auf der Festplatte.

Die Verwendung des Befehls CreateDatabase wirkt sich nicht auf die Datenbank aus, die momentan im Microsoft Access-Datenbankfenster geöffnet ist. Eine Datenbank, die Sie im Datenbankfenster geöffnet haben, bleibt weiterhin geöffnet und ist die erste Datenbank in der Databases-Auflistung.

Um eine Datenbank, die Sie mit Hilfe der Methode CreateDatabase erstellt haben, im Datenbankfenster zu öffnen, klicken Sie im Menü Datei auf Datenbank öffnen.


CreateDatabase-Methode - Beispiel

Das folgende Beispiel verwendet die Methode CreateDatabase, um eine neue, verschlüsselte Datenbank mit dem Namen NEUEDB.MDB zu erstellen.

Sub NeueDatenbank()
    Dim wspStandard As Workspace, dbs As Database
    Dim tdf As TableDef, fld1 As Field, fld2 As Field
    Dim idx As Index, fldIndex As Field

    Set wspStandard = DBEngine.Workspaces(0)
    ' Neue, verschlüsselte Datenbank erstellen.
    Set dbs = wspStandard.CreateDatabase("NeueDb.mdb", _
        dbLangGeneral, dbEncrypt)
    ' Neue Tabelle mit zwei Feldern erstellen.
    Set tdf = dbs.CreateTableDef("Kontakte")
    Set fld1 = tdf.CreateField("KontaktID", dbLong)
    fld1.Attributes = fld1.Attributes + dbAutoIncrField
    Set fld2 = tdf.CreateField("Kontaktperson", dbText, 50)
    ' Felder anfügen.
    tdf.Fields.Append fld1
    tdf.Fields.Append fld2
    ' Primärschlüsselindex erstellen.
    Set idx = tdf.CreateIndex("Primarschlüssel")
    Set fldIndex = idx.CreateField("KontaktID", dbLong)
    ' Index-Felder anfügen.
    idx.Fields.Append fldIndex
    ' Eigenschaft "Primary" einstellen.
    idx.Primary = True
    ' Index anfügen.
    tdf.Indexes.Append idx
    ' TableDef-Objekt anfügen.
    dbs.TableDefs.Append tdf
    dbs.TableDefs.Refresh
    Set dbs = Nothing
End Sub


CreateEventProc-, InsertLines-Methoden - Beispiel

Das folgende Beispiel erstellt ein neues Formular, fügt eine Befehlsschaltfläche hinzu und erstellt eine Click-Ereignisprozedur für die Befehlsschaltfläche.

Function ClickEreignisproz() As Boolean
    Dim frm As Form, ctl As Control, mdl As Module
    Dim lngZurück As Long

    On Error GoTo Error_ClickEreignisproz
    ' Neues Formular erstellen.
    Set frm = CreateForm
    ' Befehlsschaltfläche auf dem Formular erstellen.
    Set ctl = CreateControl(frm.Name, acCommandButton, , , , _
         1000, 1000)
    ctl.Caption = "Hier klicken"
    ' Verweis auf Formularmodul zurückgeben.
    Set mdl = frm.Module
    ' Ereignisprozedur hinzufügen.
    lngZurück = mdl.CreateEventProc("Click", ctl.Name)
    ' Text in den Prozedurrumpf einfügen.
    mdl.InsertLines lngZurück + 1, vbTab & "MsgBox ""Ruhig bleiben!"""
    ClickEreignisproz= True

Exit_ClickEreignisproz:
    Exit Function

Error_ClickEreignisproz:
    MsgBox Err & " :" & Err.Description
    ClickEreignisproz = False
    Resume Exit_ClickEreignisproz
End Function


CreateField-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt eine neue Tabelle mit zwei neuen Feldern, von denen eines ein AutoWert-Feld ist. Die Prozedur richtet dieses Feld als Primärschlüssel in der Tabelle ein.

Sub NeuesFeld()
    Dim dbs As Database
    Dim tdf As TableDef, fld1 As Field, fld2 As Field
    Dim idx As Index, fldIndex As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Erstellen einer neuen Tabelle mit zwei Feldern.
    Set tdf = dbs.CreateTableDef("Kontakte")
    Set fld1 = tdf.CreateField("KontaktID", dbLong)
    fld1.Attributes = fld1.Attributes + dbAutoIncrField
    Set fld2 = tdf.CreateField("Kontaktperson", dbText, 50)
    ' Felder anfügen.
    tdf.Fields.Append fld1
    tdf.Fields.Append fld2
    ' Primärschlüsselindex erstellen.
    Set idx = tdf.CreateIndex("Primärschlüssel")
    Set fldIndex = idx.CreateField("KontaktID", dbLong)
    ' Index-Felder anfügen.
    idx.Fields.Append fldIndex
    ' Eigenschaft "Primary" einstellen.
    idx.Primary = True
    ' Index anfügen.
    tdf.Indexes.Append idx
    ' TableDef-Objekt anfügen.
    dbs.TableDefs.Append tdf
    dbs.TableDefs.Refresh
    Set dbs = Nothing
End Sub


CreateForm-, CreateReport-Methoden - Beispiel

Das folgende Beispiel erstellt in der aktuellen Datenbank einen Bericht und verwendet dazu die im Dialogfeld Optionen auf der Registerkarte Formulare/Berichte in der Einstellung Berichtsvorlage angegebene Vorlage.

Sub NormalerBericht()
    Dim rpt As Report

    Set rpt = CreateReport                ' Minimierten Bericht erstellen.
    DoCmd.Restore                            ' Bericht wiederherstellen.
End Sub

Das nächste Beispiel erstellt in der Beispieldatenbank Nordwind ein neues Formular, das auf dem Formular Kunden basiert, und stellt dessen Eigenschaft RecordSource auf die Tabelle Kunden ein. Führen Sie diesen Code aus der Beispieldatenbank Nordwind heraus aus.

Sub NeuesFormular()
    Dim frm As Form

    ' Formular erstellen, das auf dem Formular "Kunden" basiert.
    Set frm = CreateForm( , "Kunden")
    DoCmd.Restore
    ' Eigenschaft "RecordSource" auf Tabelle "Kunden" einstellen.
    frm.RecordSource = "Kunden"
End Sub


AddFromFile-Methode (References-Auflistung) - Beispiel

Das folgende Beispiel erstellt einen Verweis auf eine angegebene Typbibliothek.

Function VerweisAusDatei(strDateiname As String) As Boolean
    Dim ref As Reference

    On Error GoTo Error_VerweisAusDatei
    ' Neuen Verweis erstellen.
    Set ref = References.AddFromFile(strDateiname)
    VerweisAusDatei = True

Exit_VerweisAusDatei:
    Exit Function

Error_VerweisAusDatei:
    MsgBox Err & ": " & Err.Description
    VerweisAusDatei = False
    Resume Exit_VerweisAusDatei
End Function

Sie können diese Funktion etwa aus der folgenden Prozedur aufrufen, die einen Verweis auf das Kalender-Steuerelement erstellt.

Sub ErstellenKalenderVerweis()
    If VerweisAusDatei("C:\Windows\System\Mscal.ocx") = True
    Then
        MsgBox "Verweis auf Kalender-Steuerelement wurde "_
            & "erfolgreich erstellt."
    Else
        MsgBox "Verweis auf Kalender-Steuerelement wurde nicht " _
            & "erfolgreich erstellt."
    End If
End Sub


CreateGroupLevel-Methode - Beispiel

Das folgende Beispiel erstellt im Bericht Bestellbericht eine Gruppierungsebene für das Feld Bestelldatum. Der Bericht, für den die Gruppierungsebene erstellt werden soll, muss in der Entwurfsansicht geöffnet sein. Da die Argumente Seitenkopf und Seitenfuß auf True (-1) eingestellt sind, erstellt die Methode einen Seitenkopf und einen Seitenfuß für die Gruppierungsebene. Anschließend wird die Größe von Seitenkopf und Seitenfuß angepasst.

Sub GruppierungsebeneErstellen()
    Dim varGruppierungsebene As Variant

    ' Neue Gruppierungsebene für Feld "Bestelldatum" erstellen.
    varGruppierungsebene = CreateGroupLevel("Bestellbericht", "Bestelldatum", _
        True, True)
    ' Höhe von Kopf-/Fußbereich einstellen.
    Reports!Bestellbericht.Section(acGroupLevel1Header).Height = 400
    Reports!Bestellbericht.Section(acGroupLevel1Footer).Height = 400
End Sub


CreateGroup-Methode (MDB)

Nachdem Sie ein neues Group-Objekt erstellt und es der Auflistung Groups eines Workspace- oder User-Objekts hinzugefügt haben, können Sie überprüfen, ob diese neue Gruppe angelegt wurde, indem Sie im Dialogfeld Benutzer- und Gruppenkonten auf der Registerkarte Gruppen das Listenfeld Name durchsehen. Dieses Dialogfeld wird angezeigt, wenn Sie im Menü Extras auf Sicherheit zeigen und auf Benutzer- und Gruppenkonten klicken.


CreateIndex-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Index-Objekt in der Tabelle Personal. Der neue Index besteht aus zwei Feldern, Nachname und Vorname.

Sub NeuerIndex()
    Dim dbs As Database, tdf As TableDef
    Dim idx As Index
    Dim fldNachname As Field, fldVorname As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf Tabelle "Personal" holen.
    Set tdf = dbs.TableDefs!Personal
    ' Verweis auf neuenIndex holen.
    Set idx = tdf.CreateIndex("GanzerName")
    ' Index-Felder erstellen und anfügen.
    Set fldNachname = idx.CreateField("Nachname", dbText)
    Set fldVorname = idx.CreateField("Vorname", dbText)
    idx.Fields.Append fldNachname
    idx.Fields.Append fldVorname
    ' Index-Objekt anfügen und Auflistung aktualisieren.
    tdf.Indexes.Append idx
    tdf.Indexes.Refresh
    Set dbs = Nothing
End Sub


Create-Methode - Beispiel

Das folgende Beispiel verwendet Create zum Erstellen einer neuen, verschlüsselten Datenbank namens NeueDb.mdb:

Anmerkung Die Create-Methode wird in ADPs durch den im Lieferumfang von Microsoft Access 2000 enthaltenen SQL-Provider nicht unterstützt. Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Sub NeueDatenbank()
    Dim cat As New ADOX.Catalog

 cat.Create "Provider=Microsoft.Jet.OLEDB.4.0;" _
   & "Data Source=NeueDb.mdb;" _
    & "Jet OLEDB:Encrypt Database=True"

    Set cat = Nothing
End Sub


 CreateProperty-Methode (MDB)

CreateProperty-Methode (MDB)

Microsoft Access definiert eine Reihe von Eigenschaften für Datenzugriffsobjekte. Diese Eigenschaften werden von der Microsoft Jet-Datenbank-Engine nicht automatisch erkannt. Wenn Sie Werte für eine von Microsoft Access definierte Eigenschaft in Visual Basic festlegen oder zurückgeben möchten, müssen Sie die Eigenschaft explizit der Auflistung Properties des Objekts hinzufügen, für das die Eigenschaft gilt. Sie können dazu die Methode CreateProperty verwenden, um die Eigenschaft zu erstellen, und sie anschließend an die Auflistung Properties anfügen.

Beispielsweise definiert Microsoft Access die Eigenschaft Description eines TableDef-Objekts. Wurde diese Eigenschaft von der Tabellenentwurfsansicht noch nicht eingestellt, müssen Sie die Eigenschaft mit Hilfe der Methode CreateProperty erstellen und dann der Auflistung Properties hinzufügen, um die Eigenschaft von Visual Basic aus einzustellen.

Eine von Microsoft Access definierte Eigenschaft wird automatisch der Auflistung Properties hinzugefügt, wenn sie zum ersten Mal im Microsoft Access-Fenster eingestellt wird. Wurde die Eigenschaft bereits auf diese Weise eingestellt, brauchen Sie sie nicht der Auflistung Properties hinzuzufügen.

Wenn Sie Code schreiben, um eine von Microsoft Access definierte Eigenschaft einzustellen, sollte dieser auch eine Fehlerbehandlungsroutine enthalten, die ein Property-Objekt erstellt, das diese Eigenschaft darstellt und sie an die Auflistung Properties anfügt, falls sie nicht bereits Bestandteil der Auflistung ist.

Wenn Sie auf eine von Microsoft Access definierte Eigenschaft in Visual Basic verweisen, müssen Sie explizit auf die Auflistung Properties verweisen. Sie würden z. B. auf die Eigenschaft AppTitle folgendermaßen verweisen, wenn sie Bestandteil der Auflistung Properties eines Database-Objekts wäre, das die aktuelle Datenbank darstellt.

Dim dbs As Database
Set dbs = CurrentDb
dbs.Properties!AppTitle = "Nordwind GmbH"

Anmerkung Sie brauchen nur die Microsoft Access-Eigenschaften zu erstellen und anzufügen, die auf DAO-Objekte zutreffen. Sie können andere Microsoft Access-Eigenschaften in Visual Basic einstellen, indem Sie die Standardsyntax Objekt.Eigenschaft verwenden.


CreateProperty-Methode - Beispiel (MDB)

Die erste Prozedur im folgenden Beispiel, die Funktion SetAccessProperty, ist eine generische Funktion, mit der Sie Eigenschaften einstellen können. Besitzt die einzustellende Eigenschaft bereits ein entsprechendes Property-Objekt in der Properties-Auflistung, setzt die Funktion die Eigenschaft einfach auf den gewünschten Wert. Andernfalls erstellt die Funktion zunächst das Property-Objekt und fügt es der Properties-Auflistung hinzu.

Die zweite Prozedur stellt die Eigenschaft Subject mit Hilfe der Funktion SetAccessProperty ein. Die Eigenschaft Subject ist eine Datenbankeigenschaft, die auch in der Registerkarte Allgemein des Dialogfelds Datenbankeigenschaften eingestellt werden kann. Sie öffnen das Dialogfeld, indem Sie im Menü Datei auf Datenbankeigenschaften klicken.

Die Eigenschaft Subject betrifft ein Datenzugriffsobjekt, nämlich das Document-Objekt SummaryInfo, das von Microsoft Access definiert wird. Existiert die Eigenschaft Subject in der Properties-Auflistung für das Document-Objekt SummaryInfo noch nicht, so fügt es die Funktion SetAccessProperty hinzu.

Function SetAccessProperty(obj As Object, strName As String, _
        intTyp As Integer, varEinstellung As Variant) As Boolean
    Dim prp As Property
    Const conEigNichtGef As Integer = 3270

    On Error GoTo FehlerSetAccessProperty
    ' Explizit auf die Auflistung "Properties" verweisen.
    obj.Properties(strName) = varEinstellung
    obj.Properties.Refresh
    SetAccessProperty = True

BeendenSetAccessProperty:
    Exit Function

FehlerSetAccessProperty:
    If Err = conEigNichtGef Then
        ' Eigenschaft erstellen, Typ festlegen, Anfangswert einstellen.
        Set prp = obj.CreateProperty(strName, intTyp, varEinstellung)
        ' Eigenschaft-Objekt an die Auflistung "Properties" anfügen.
        obj.Properties.Append prp
        obj.Properties.Refresh
        SetAccessProperty = True
        Resume BeendenSetAccessProperty
    Else
        MsgBox Err & ": " & vbCrLf & Err.Description
        SetAccessProperty = False
        Resume BeendenSetAccessProperty
    End If
End Function

Die folgende Prozedur ruft die Funktion SetAccessProperty auf, um die Eigenschaft Subject einzustellen.

Sub AufrufEigenschaftEinstellen ()
    Dim dbs As Database, ctr As Container, doc As Document
    Dim blnRückgabe As Boolean

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf Datenbank-Container holen.
    Set ctr = dbs.Containers!Databases
    ' Verweis auf Dokument "SummaryInfo" holen.
    Set doc = ctr.Documents!SummaryInfo
    blnRückgabe = SetAccessProperty(doc, _
        "Subject", dbText, "Geschäftskontakte")
    ' Rückgabewert auswerten.
    If blnRückgabe = True Then
        Debug.Print "Eigenschaft erfolgreich eingestellt."
    Else
        Debug.Print "Eigenschaft nicht erfolgreich eingestellt."
    End If
End Sub


CreateQueryDef-Methode - Beispiel (MDB)

Dieses Beispiel verwendet die CreateQueryDef-Methode zum Erstellen und Ausführen eines temporären und eines permanenten QueryDef-Objekts. Zum Ausführen dieser Prozedur ist die GetrstTempAbrufen-Funktion erforderlich.

Sub QueryDefXErstellen()

    Dim dbsNordwind As Database
    Dim qdfTemp As QueryDef
    Dim qdfNeu As QueryDef

    Set dbsNordwind = OpenDatabase("Nordwind.mdb")

    With dbsNordwind
        ' Temporäres QueryDef-Objekt erstellen.
        Set qdfTemp = .CreateQueryDef("", _
            "SELECT * FROM Personal")
        ' Recordset-Objekt öffnen und ausgeben.
        rstTempAbrufen qdfTemp
        ' Permanentes QueryDef-Objekt erstellen.
        Set qdfNeu = .CreateQueryDef("NeuesQueryDefObjekt", _
            "SELECT * FROM Kategorien")

' Recordset-Objekt öffnen und Bericht ausgeben.
        rstTempAbrufen qdfNeu
        ' Neues QueryDef-Objekt löschen, weil dies eine Demo ist.
        .QueryDefs.Delete qdfNeu.Name
        .Close
    End With

End Sub

Function rstTempAbrufen(qdfTemp As QueryDef)

    Dim rstTemp As Recordset

    With qdfTemp
        Debug.Print .Name
        Debug.Print "    " & .SQL
        ' Recordset-Objekt aus QueryDef-Objekt öffnen.
        Set rstTemp = .OpenRecordset(dbOpenSnapshot)

        With rstTemp
            ' Recordset-Objekt auffüllen und Anzahl der Datensätze
            ' ausgeben.

.MoveLast
            Debug.Print "    Anzahl der Datensätze = " & _
                .RecordCount
            Debug.Print
            .Close
        End With

    End With

End Function


CreateRelation-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Relation-Objekt, das eine Beziehung zwischen der Tabelle Kategorien und der Tabelle Artikel definiert. Die Tabelle Kategorien ist die Primärtabelle in der Beziehung, und die Tabelle Artikel ist die Fremdtabelle. Das Feld Kategorie-Nr ist der Primärschlüssel in der Tabelle Kategorien und ein Fremdschlüssel in der Tabelle Artikel.

Damit Sie dieses Beispiel in der Nordwind-Datenbank testen können, klicken Sie im Menü Extras auf Beziehungen, und löschen Sie die Beziehung zwischen der Tabelle Kategorien und der Tabelle Artikel. Schließen Sie das Fenster Beziehungen, und speichern Sie auf Aufforderung die aktuelle Konfiguration. Führen Sie die folgende Prozedur aus. Zeigen Sie dann das Fenster Beziehungen erneut an, und betrachten Sie die neue Beziehung.

Sub NeueBeziehung()
    Dim dbs As Database, rel As Relation, fld As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Neues Relation-Objekt erstellen und Fremdtabelle angeben.
    Set rel = dbs.CreateRelation("Kategorie-Nr", "Kategorien", "Artikel")
    ' Attribute zur Durchsetzung der referentiellen Integrität einstellen.
    rel.Attributes = dbRelationUpdatedbRelationUpdateCascade And dbRelationDeleteCascade
    ' Feld in Relation-Objekt erstellen.
    Set fld = rel.CreateField("Kategorie-Nr")
    ' Feldname in Fremdtabelle festlegen.
    fld.ForeignName = "Kategorie-Nr"
    ' Field-Objekt an Fields-Auflistung des Relation-Objekts anfügen.
    rel.Fields.Append fld
    ' Relation-Objekt an Relations-Auflistung anfügen.
    dbs.Relations.Append rel
    dbs.Relations.Refresh
    Set dbs = Nothing
End Sub


Erstellen einer neuen SQL-Datenbank

Die Create-Methode wird vom SQL Server-Provider für OLEDB und ADO in Microsoft Access 2000 nicht unterstützt. Sie können jedoch eine neue SQL-Datenbank in Visual Basic erstellen, indem Sie die SQL-Schlüsselwörter Create Database in Verbindung mit dem ADO-Objekt Command verwenden.


CreateTableDef-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues TableDef-Objekt und fügt dieses an die TableDefs-Auflistung der aktuellen Datenbank an.

Sub NeueTabelle()
    Dim dbs As Database, tdf As TableDef, fld As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf aktuelle Datenbank holen.
    ' TableDef-Objektvariable zurückgeben, die auf die neue Tabelle zeigt.
    Set tdf = dbs.CreateTableDef("Kontakte")
    ' Neues Feld in der Tabelle definieren.
    Set fld = tdf.CreateField("Kontaktperson", dbText, 40)
    ' Field-Objekt an Fields-Auflistung des TableDef-Objekts anfügen.
    tdf.Fields.Append fld
    tdf.Fields.Refresh
    ' TableDef-Objekt an TableDefs-Auflistung der Datenbank anfügen.
    dbs.TableDefs.Append tdf
    dbs.TableDefs.Refresh
    Set dbs = Nothing
End Sub


CreateUser-Methode (MDB)

Nachdem Sie ein neues User-Objekt erstellt und es der Auflistung Users eines Workspace- oder Group-Objekts hinzugefügt haben, können Sie überprüfen, ob dieser neue Benutzer existiert, indem Sie im Dialogfeld Benutzer- und Gruppenkonten in der Registerkarte Benutzer das Listenfeld Name durchsehen. Dieses Dialogfeld wird angezeigt, wenn Sie im Menü Extras auf Sicherheit zeigen und auf Benutzer- und Gruppenkonten klicken.


Erstellen von Tabellenindizes - Beispiel

Das folgende Beispiel erstellt ein neues Index-Objekt für eine Tabelle namens Personal. Der neue Index besteht aus zwei Feldern, Nachname und Vorname.

Anmerkung Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Sub NeuerIndex()
    Dim cat As New ADOX.Catalog, tbl As ADOX.Table
    Dim idx As New ADOX.Index

    ' Verweis auf aktuelle Datenbank zurückgeben.
    Set cat.ActiveConnection = CurrentProject.Connection
    ' Verweis auf Tabelle "Personal" zurückgeben.
    Set tbl = cat.Tables!Personal
    ' Verweis auf neuen Index zurückgeben.
    idx.Name = "VollständigerName"
    idx.Columns.Append "Nachname", adVarWChar
    idx.Columns.Append "Vorname", adVarWChar
    tbl.Indexes.Append idx

    ' Index-Objekt anfügen und Auflistung aktualisieren.
    tbl.Indexes.Refresh
    Set cat = Nothing
End Sub


CurrentDb-Methode: Beispiel

Das folgende Beispiel verwendet die CurrentDb-Methode, um eine Database-Objektvariable zu erhalten, deren Inhalt auf die aktuelle Datenbank verweist. Anschließend durchläuft das Beispiel eine Auflistung aller Felder der Tabelle Personal in dieser Datenbank.

Sub FelderAuflisten()
    Dim dbs As Database, tdf As TableDef, fld As Field

    ' Database-Objektvariable mit einer Referenz auf die aktuelle Datenbank wird zurückgegeben.
    Set dbs = CurrentDb
    ' TableDef-Objektvariable mit einer Referenz auf die Tabelle "Personal" wird zurückgegeben.
    Set tdf = dbs.TableDefs!Personal
    ' Auflistung der Felder der Tabelle "Personal" wird durchlaufen.
    For Each fld In tdf.Fields
        Debug.Print fld.Name
    Next fld
End Sub


Close-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein Database-Objekt, das auf die aktuelle Datenbank verweist, und öffnet ein Recordset-Objekt vom Typ Tabelle, das auf einer Tabelle mit dem Namen Kunden basiert. Die Prozedur wendet die Methode Close auf die Recordset-Objektvariablen an, um die verwendeten Speicherressourcen freizugeben. Sie verwendet die Set-Anweisung mit dem Schlüsselwort Nothing, um die von der Database-Objektvariablen verwendeten Ressourcen freizugeben.

Sie können auch die Methode Close des Database-Objekts verwenden, um es zu schließen und den Speicher freizugeben. Die Methode Close des Database-Objekts schließt die in Microsoft Access geöffnete Datenbank nicht, sondern gibt nur die von der Database-Objektvariablen verwendeten Ressourcen frei.

Das Verwenden der Methode Close eines Objekts und das Einstellen der Objektvariablen auf Nothing sind wirkungsgleiche Verfahren zum Freigeben des Speichers.

Sub CloseVerwenden()
    Dim dbs As Database, rst As Recordset

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle erstellen.
    Set rst = dbs.OpenRecordset("Kunden")
    .
    .
    .
    ' Recordset schließen, um Speicher freizugeben.
    rst.Close
    ' Von der Objektvariablen verwendeten Speicher freigeben.
    Set dbs = Nothing
End Sub


Refresh-Methode - Beispiel (MDB)

Das folgende Beispiel aktualisiert die Auflistung Indexes eines TableDef-Objekts. In einer Datenbank in einer Mehrbenutzer-Umgebung können Sie die Methode Refresh verwenden, um anzuzeigen, welche Änderungen andere Benutzer an den Index-Objekten in der Auflistung Indexes eines TableDef-Objekts vorgenommen haben.

Sub IndexAktualisieren()
    Dim dbs As Database, tdf As TableDef
    Dim idx As Index, fld As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    Set tdf = dbs.TableDefs!Personal
    tdf.Indexes.Refresh
    For Each idx In tdf.Indexes
        Debug.Print idx.Name; ":"
        For Each fld In idx.Fields
            Debug.Print "   "; fld.Name
        Next fld
    Next idx
    Set dbs = Nothing
End Sub


DefaultControl-Methode - Beispiel

Das folgende Beispiel erstellt ein neues Formular und verwendet die Methode DefaultControl, um ein Objekt Control zurückzugeben, das die Standardbefehlsschaltfläche darstellt. Die Prozedur stellt einige der Standardeigenschaften für die Befehlsschaltfläche ein und erstellt anschließend eine neue Befehlsschaltfläche auf dem Formular.

Sub StandardeigenschaftenEinstellen()
    Dim frm As Form, ctlStandard As Control, ctlNeu As Control

    ' Ein neues Formular erstellen.
    Set frm = CreateForm
    ' Das Control-Objekt zurückgeben, das der Standardbefehls-
    ' schaltfläche enstpricht.
    Set ctlStandard = frm.)DefaultControl(acCommandButton)
    ' Einige Standardeigenschaften einstellen.
    With ctlStandard
        .FontWeight = 700
        .FontSize = 12
        .Width = 3000
        .Height = 1000
    End With
    ' Eine neue Befehlsschaltfläche erstellen.
    Set ctlNeu = CreateControl(frm.Name, acCommandButton, , , , 500, 500)
    ' Die Beschriftung des Steuerelements angeben.
    ctlNeu.caption = "Neue Befehlsschaltfläche"
    ' Das Formular aktualisieren.
    DoCmd.Restore
End Sub


DefaultWorkspaceClone-Methode - Beispiel

Im folgenden Beispiel wird zunächst das standardmäßige Objekt Workspace dupliziert, anschließend werden die Eigenschaften jedes Objekts Workspace aufgelistet.

Sub ArbeitsbereichDuplizieren()
    Dim wrkStandard As Workspace, wrkDuplikat As Workspace
    Dim prp As Property
    On Error Resume Next
    ' Den Standardarbeitsbereich abrufen.
    Set wrkStandard = DBEngine.Workspaces(0)
    ' Den Standardarbeitsbereich duplizieren.
    Set wrkDuplikat = Application.DefaultWorkspaceClone
    ' Die Eigenschaften jedes Arbeitsbereichs anzeigen.
    For Each prp In wrkStandard.Properties
        Debug.Print ">>>"; prp.Name; "   "; prp.Value
    Next prp
    For Each prp In wrkDuplikat.Properties
        Debug.Print ">>>"; prp.Name; "   "; prp.Value
    Next prp
End Sub


Delete-Methode: Beispiel

Das folgende Beispiel erstellt eine Spalte innerhalb einer Tabelle und löscht anschließend die neue Spalte.

Sub SpalteLöschen()
    Dim cat As New ADOX.Catalog, tbl As ADOX.Table

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cat.ActiveConnection = CurrentProject.Connection
    Set tbl = cat.Tables!Personal
    ' Neues Column-Objekt anhängen.
    tbl.Columns.Append "MittleresInitial", adVarWChar, 2
    tbl.Columns.Refresh
    ' Neues Column-Objekt löschen.
    tbl.Columns.Delete "MittleresInitial"
tbl.Columns.Refresh
    Set cat = Nothing
End Sub


DeleteLines-Methode-, Lines-Eigenschaft - Beispiel

Das folgende Beispiel löscht die angegebene Zeile aus einem Modul.

Function ZeileLöschen(strModulname, strText As String) As Boolean
    Dim mdl As Module, lngAnzahlZeilen As Long
    Dim lngAnfzeile As Long, lngAnfspalte As Long
    Dim lngEndzeile As Long, lngEndspalte As Long
    Dim strTemp As String

    On Error GoTo Error_ZeileLöschen
    DoCmd.OpenModule strModulname
    Set mdl = Modules(strModulname)

    If mdl.Find(strText, lngAnfzeile, lngAnfspalte, lngEndzeile, lngEndspalte) Then
        lngAnzahlZeilen = Abs(lngEndzeile - lngAnfzeile) + 1
        strTemp = LTrim$(mdl.Lines(lngAnfzeile, lngAnzahlZeilen))
        strTemp = RTrim$(strTemp)
        If strTemp = strText Then
            mdl.DeleteLines lngAnfzeile, lngAnzahlZeilen
        Else
            MsgBox "Zeile enthält weiteren Text zusätzlich zu '" _
                & strText & "'."
        End If
    Else
        MsgBox "Text '" & strText & "' nicht gefunden."
    End If
    ZeileLöschen = True

Exit_ZeileLöschen:
    Exit Function

Error_ZeileLöschen:
    MsgBox Err & " :" & Err.Description
    ZeileLöschen = False
    Resume Exit_ZeileLöschen
End Function

Sie können diese Funktion etwa aus der folgenden Prozedur aufrufen, die im Modul Modul1 eine Konstantendeklaration sucht und löscht.

Sub LöschenKonstantePi()
    If ZeileLöschen("Modul1", "Const conPi = 3.14") Then
        Debug.Print "Deklaration der Konstanten Pi wurde erfolgreich gelöscht."
    Else
        Debug.Print "Deklaration der Konstanten Pi wurde nicht gelöscht."
    End If
End Sub


Delete-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein Feld in einer Tabelle und löscht das Feld wieder.

Sub FeldLöschen()
    Dim dbs As Database, tdf As TableDef
    Dim fldInitialen As Field

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    Set tdf = dbs.TableDefs!Personal
    ' Neues Field-Objekt erstellen.
    Set fldInitialen = tdf.CreateField("Initialen", dbText, 2)
    ' Neues Field-Objekt anfügen.
    tdf.Fields.Append fldInitialen
    ' Fields-Auflistung aktualisieren.
    tdf.Fields.Refresh
    ' Neues Field-Objekt löschen.
    tdf.Fields.Delete fldInitialen.Name
    tdf.Fields.Refresh
    Set dbs = Nothing
End Sub


Dropdown-Methode - Beispiel

Das folgende Beispiel zeigt Ihnen, wie Sie die Methode Dropdown in einer GotFocus-Ereignisprozedur verwenden können, die Liste eines Kombinationsfelds namens AnbieterID zu öffnen, sobald das Kombinationsfeld den Fokus erhalten hat.

Private Sub AnbieterID_GotFocus()
    Me!AnbieterID.Dropdown
End Sub


Echo-Methode (Application-Objekt) - Beispiel

Das folgende Beispiel verwendet die Methode Echo, um die Aktualisierung der Bildschirmanzeige zu verhindern, solange bestimmte Vorgänge durchgeführt werden. Während die Prozedur ein Formular öffnet und es minimiert, sieht der Benutzer lediglich das Sanduhr-Symbol, das auf die laufende Verarbeitung hinweist; der Bildschirm wird dagegen nicht aktualisiert. Nach Beendigung des Vorgangs ändert sich die Sanduhr wieder in einen Zeiger, und die Bildschirmaktualisierung wird erneut eingeschaltet.

Sub EchoAus()
    Application.Echo False
    DoCmd.Hourglass True
    DoCmd.OpenForm "Personal", acNormal
    DoCmd.Minimize
    Application.Echo True
    DoCmd.Hourglass False
End Sub


Edit-Methode - Beispiel (MDB)

Das folgende Beispiel öffnet ein Recordset-Objekt und sucht alle Datensätze, bei denen das Feld Position den Suchkriterien entspricht. Die Prozedur verwendet dann die Methode Edit, um den Datensatz für die weitere Bearbeitung vorzubereiten, ändert die Berufsbezeichnung und speichert die Änderung.

Sub PositionÄndern()
    Dim dbs As Database, rst As Recordset
    Dim strKriterien As String, strNeuePosition As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Suchkriterien festlegen.
    strKriterien = "Position = 'Verkaufsrepräsentant'"
    strNeuePosition = "Sachbearbeiter - Kundenwerbung"
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rst = dbs.OpenRecordset("Personal", dbOpenDynaset)
    ' Erstes Vorkommen suchen.
    rst.FindFirst strKriterien
    ' Schleife durchlaufen, bis keine passenden Datensätze mehr vorhanden sind.
    Do Until rst.NoMatch
        With rst
            .Edit                            ' Bearbeitung aktivieren.
            !Position = strNeuePosition    ' Position ändern.
            .Update                        ' Änderungen speichern.
            .FindNext strKriterien        ' Nächstes Vorkommen suchen.
        End With
    Loop
    rst.Close
    Set dbs = Nothing
End Sub

Tipp Das Verwenden einer Aktualisierungsabfrage zum Ändern von Daten ist effizienter. Beispielsweise erzielen Sie mit dem folgenden Code dasselbe Ergebnis:

Sub PositionÄndernSQL()
    Dim dbs As Database
    Dim strSQL As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' SQL-Zeichenfolge erstellen.
    strSQL = "UPDATE Personal SET Position = 'Sachbearbeiter - Kundenwerbung' " _
        & "WHERE Position = ' 'Verkaufsrepräsentant' "
    ' Aktionsabfrage ausführen.
    dbs.Execute strSQL
    ' Anzahl der aktualisierten Datensätze zurückgeben.
    Debug.Print dbs.RecordsAffected
    Set dbs = Nothing
End Sub


Execute-Methode: Beispiel

Das folgende Beispiel führt eine SQL-Anweisung aus und gibt die Anzahl der betroffenen Datensätze aus:

Sub AktualisierteDatensätze()
    Dim intBetroffeneDatensätze As Integer
    Dim strSQL As String

    strSQL = "UPDATE Personal SET Position = " _
        & "'Gruppenleiter Vertrieb' " _
        & "WHERE Position = 'Vertriebsmitarbeiter';"

    CurrentProject.Connection.Execute strSQL, intBetroffeneDatensätze
    Debug.Print intBetroffeneDatensätze
End Sub


Execute-Methode - Beispiel (MDB)

Das folgende Beispiel führt eine Aktionsabfrage aus und gibt die Anzahl der betroffenen Datensätze aus.

Sub AktualisierteDatensätze()
    Dim dbs As Database, qdf As QueryDef
    Dim strSQL As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    strSQL = "UPDATE Personal SET Position = " _
        & "'Senior-Verkaufsrepräsentant' " _
        & "WHERE Position = 'Verkaufsrepräsentant';"
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("PositionenAktualisieren", strSQL)
    ' Execute QueryDef.
    qdf.Execute
    Debug.Print qdf.RecordsAffected
    Set dbs = Nothing
End Sub


FieldSize-Methode - Beispiel (MDB)

Das folgende Beispiel verwendet die Methode FieldSize, um die Größe von zwei Feldern in der Tabelle Personal in Bytes zurückzugeben. Das Feld Bemerkungen hat den Datentyp Memo, und das Feld Foto hat den Datentyp OLE-Objekt.

Sub FeldgrößeBestimmen()
    Dim dbs As Database, rst As Recordset
    Dim fldBemerkungen As Field, fldFoto As Field
    Dim strSQL As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' SQL-Anweisung zur Rückgabe der Felder "Bemerkungen" und "Foto" erstellen.
    strSQL = "SELECT Bemerkungen, Foto FROM Personal;"
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rst = dbs.OpenRecordset(strSQL)
    Set fldBemerkungen = rst!Bemerkungen
    Set fldFoto = rst!Foto
    ' Zum ersten Datensatz wechseln.
    rst.MoveFirst
    Debug.Print "Feldgröße 'Bemerkungen'"; "    "; "Feldgröße 'Bemerkungen'Foto:"
    ' Größen der Felder für jeden Datensatz im Recordset-Objekt ausgeben.
    Do Until rst.EOF
        Debug.Print fldBemerkungen.FieldSize; "        "; fldFoto.FieldSize
        rst.MoveNext
    Loop
    rst.Close
    Set dbs = Nothing
End Sub


Find-Methode

Die ADO (ActiveX Data Objects)-Version der Find-Methode unterstützt nur Suchen in einzelnen Spalten. Aus diesem Grund ist es nicht möglich, Kriterien unter Verwendung der Schlüsselwörter "And" bzw. "Or" anzufügen.

Das Erstellen einer neuen Datensatzgruppe liefert häufig eine bessere Leistung und beschränkt die Suche nicht auf Einzelspaltenfilter.

Richtig:
rs.Find "Vorname = 'Nancy'"

Falsch:
rs.Find "Vorname = 'Nancy' And Nachname = 'Davolio'"


Find-Methode: Beispiel

Das folgende Beispiel generiert ein Recordset-Objekt vom Typ Dynaset und sucht dann mit Hilfe der Find-Methode nach dem ersten Datensatz, der den angegebenen Kriterien entspricht. Die Prozedur sucht anschließend nach den restlichen Datensätzen, die ebenfalls den Kriterien entsprechen.

Sub DatensatzFinden()
    Dim rst As New ADODB.Recordset
    Dim strKriterien As String

    ' Suchkriterien definieren.
    strKriterien = "[Bestimmungsland] = Großbritannien"
    ' Recordset-Objekt vom Typ Dynaset erstellen unter Verwendung der Tabelle "Bestellungen".
    rst.Open "Bestellungen", CurrenProject.Connection, adOpenKeyset, adLockOptimistic)
    ' Ersten passenden Datensatz suchen.
    rst.Find strKriterien
    ' Prüfen, ob Datensatz gefunden wurde.
    If rst.EOF Then
        MsgBox "Kein Datensatz gefunden."
    Else
        ' Weitere Datensätze suchen, die den Kriterien entsprechen.
        Do Until rst.EOF
            Debug.Print rst!Bestimmungsland; "   "; rst!Bestelldatum
            rst.Find strKriterien
        Loop
    End If
    rst.Close
End Sub


FindFirst-, FindLast-, FindNext-, FindPrevious-Methoden - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt vom Typ Dynaset und verwendet dann die Methode FindFirst zum Suchen des ersten Datensatzes, der den festgelegten Kriterien entspricht. Die Prozedur sucht dann nach weiteren Datensätzen, die ebenfalls den Kriterien entsprechen.

Sub DatensatzSuchen()
    Dim dbs As Database, rst As Recordset
    Dim strKriterien As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Suchkriterien definieren.
    StrKriterien = "[Bestimmungsland] = 'GB' And [Bestelldatum]" _
        & "[Bestelldatum] >= #1-1-96#"
    ' Recordset-Objekt vom Typ Dynaset erstellen, das auf der Tabelle
    ' "Bestellungen" basiert.
    Set rst = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
    ' Ersten übereinstimmenden Datensatz suchen.
    rst.FindFirst strKriterien
    ' Prüfen, ob der Datensatz gefunden wurde.
    If rst.NoMatch Then
        MsgBox "Kein Datensatz gefunden."
    Else
        ' Andere passende Datensätze suchen.
        Do Until rst.NoMatch
            Debug.Print rst!Bestimmungsland; "   "; rst!Bestelldatum
            rst.FindNext strKriterien
        Loop
    End If
    rst.Close
    Set dbs = Nothing
End Sub


Find-, ReplaceLine-Methoden - Beispiel

Die folgende Funktion sucht eine bestimmte Zeichenfolge in einem Modul und ersetzt die Zeile, in der sich die Zeichenfolge befindet, durch eine andere angegebene Zeile.

Function SuchenUndErsetzen(strModulname As String, strSuchText As String, _
    strNeuerText As String) As Boolean
    Dim mdl As Module
    Dim lngAnfangszeile As Long, lngAnfangsspalte As Long
    Dim lngEndzeile As Long, lngEndspalte As Long
    Dim strzeile As String, strNeueZeile As String
    Dim intChr As Integer, intVorher As Integer, intNachher As Integer
    Dim strLinks As String, strRechts As String

    ' Modul öffnen.
    DoCmd.OpenModule strModulname
    ' Verweis auf Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)

    ' Zeichenfolge suchen.
    If mdl.Find(strSuchtext, lngAnfangszeile, lngAnfangsspalte, lngEndzeile, )_
        lngEndspalte) Then
        ' Textzeile speichern, in der der Suchbegriff vorkommt.
        strZeile = mdl.Lines(lngAnfangszeile, Abs(lngEndzeile - lngAnfangszeile) + 1)
        ' Zeilenlänge ermitteln.
        intChr = Len(strZeile)
        ' Anzahl der Zeichen vor dem Suchbegriff ermitteln.
        intVorher = lngAnfangsspalte - 1
        ' Anzahl der Zeichen hinter dem Suchbegriff ermitteln.
        intNachher = intChr - CInt(lngEndspalte - 1)
        ' Zeichen links vom Suchbegriff speichern.

        strLinks = Left$(strZeile, intVorher)
        ' Zeichen rechts vom Suchbegriff speichern.
        strRechts = Right$(strZeile, intNachher)
        ' Zeichenfolge mit dem Ersatztext erstellen.
        strNeueZeile = strLinks & strNeuerText & strRechts
        ' Ursprüngliche Zeile ersetzen.
        mdl.ReplaceLine lngAnfangszeile, strNeueZeile
        SuchenUndErsetzen = True
    Else
        MsgBox "Text nicht gefunden."
        SuchenUndErsetzen = False
    End If

Exit_SuchenUndErsetzen:
    Exit Function

Error_SuchenUndErsetzen:

MsgBox Err & ": " & Err.Description
    SuchenUndErsetzen = False
    Resume Exit_SuchenUndErsetzen
End Function


FollowHyperlink-Methode - Beispiel

Die folgende Funktion fordert den Benutzer zur Eingabe einer Hyperlinkadresse auf und folgt dann dem Hyperlink.

Function HolenBenutzeradresse() As Boolean
    Dim strEingabe As String

    On Error GoTo Error_HolenBenutzeradresse
    strEingabe = InputBox("Geben Sie eine gültige Adresse ein")
    Application.FollowHyperlink strEingabe, , True
    HolenBenutzeradresse = True

Exit_HolenBenutzeradresse:
    Exit Function

Error_HolenBenutzeradresse:
    MsgBox Err & ": " & Err.Description
    HolenBenutzeradresse= False
    Resume Exit_HolenBenutzeradresse
End Function

Sie können diese Funktion etwa aus der folgenden Prozedur aufrufen.

Sub AufrufHolenBenutzeradresse()
    If HolenBenutzeradresse = True Then
        MsgBox "Dem Hyperlink wurde erfolgreich gefolgt."
    Else
        MsgBox "Dem Hyperlink konnte nicht gefolgt werden."
    End If
End Sub


Follow-Methode - Beispiel

Das folgende Beispiel stellt die Eigenschaft HyperlinkAddress einer Befehlsschaltfläche ein und öffnet den Hyperlink, wenn das Formular geladen wird.

Damit Sie dieses Beispiel testen können, erstellen Sie ein Formular und fügen Sie die Befehlsschaltfläche Befehl0 hinzu. Fügen Sie dann den folgenden Code in das Modul des Formulars ein, und wechseln Sie zur Formularansicht.

Private Sub Formular_Laden()
    Dim ctl As CommandButton

    Set ctl = Me!Befehl0
    With ctl
        .Visible = False
        .HyperlinkAddress = "http://www.microsoft.com/"
        .Hyperlink.Follow
    End With
End Sub


GetChunk-Methode

Nachdem die Ergebnisse der GetChunk-Methode einer Zeichenfolgenvariablen zugewiesen sind, können Sie die Visual Basic-Funktion Len verwenden, um die Anzahl an Zeichen in der Zeichenfolge zu ermitteln. Sie können auch die LenB-Funktion verwenden, um die Anzahl an verwendeten Bytes zu ermitteln, die zur Darstellung der Zeichenfolge verwendet werden.


GetRows-Methode: Beispiel

Das folgende Beispiel verwendet die GetRows-Methode, um eine zweidimensionale Matrix mit allen Datenzeilen in Form eines Recordset-Objekts zurückzugeben:

Sub Array_für_Zeilen()
    Dim rst As New ADODB.Recordset, strSQL As String
    Dim varDatensätze As Variant, intI As Integer, intJ As Integer

    ' SQL-Anweisung zur Auswahl der angeg. Felder erstellen.
    strSQL = "SELECT Vorname, Nachname, Einstellungsdatum " _
        & "FROM Personal"
    ' Recordset-Objekt von Typ "Dynaset" öffnen.
    rst.Open strSQL, CurrentProject.Connection, adOpenKeyset, adLockOptimistic
    ' Zum Ende der Datensatzgruppe bewegen.
    rst.MoveLast
    ' Zum ersten Datensatz zurückkehren.
    rst.MoveFirst
    ' Alle Zeilen in das Datenfeld übernehmen.
    varDatensätze = rst.GetRows(rst.RecordCount)
    ' Obergrenze der zweiten Dimension ermitteln.
    For intI = 0 To UBound(varDatensätze, 2)
        Debug.Print
        ' Obergrenze der ersten Dimension ermitteln.
        For intJ = 0 To UBound(varDatensätze, 1)
            ' Für jede Zeile des Datenfelds den Dateninhalt ausgeben.
            Debug.Print varDatensätze(intJ, intI)
        Next intJ
    Next intI
    rst.Close

End Sub


GetRows-Methode - Beispiel (MDB)

Das folgende Beispiel verwendet die Methode GetRows zur Rückgabe eines zweidimensionalen Datenfelds, das alle Datenzeilen eines Recordset-Objekts enthält.

Sub Zeilenfeld()
    Dim dbs As Database, rst As Recordset, strSQL As String
    Dim varDatensätze As Variant, intI As Integer, intJ As Integer

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' SQL-Anweisung zusammenstellen, die die angegebenen Felder zurückgibt.
    strSQL = "SELECT Vorname, Nachname, Einstellungsdatum " _
    & "FROM Personal"
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rst = dbs.OpenRecordset(strSQL)
    ' Bewegen zum Ende des Datensatzes.
    rst.MoveLast
    ' Zurück zum ersten Datensatz.
    rst.MoveFirst
    ' Alle Zeilen in einem Datenfeld zurückgeben.
    varDatensätze = rst.GetRows(rst.RecordCount)
    ' Obergrenze der zweiten Dimension ermitteln.
    For intI = 0 To UBound(varDatensätze, 2)
        Debug.Print
        ' Obergrenze der ersten Dimension ermitteln.
        For intJ = 0 To UBound(varDatensätze, 1)
            ' Daten jeder Datenfeld-Zeile ausgeben.
            Debug.Print varDatensätze(intJ, intI)
        Next intJ
    Next intI
    rst.Close
    Set dbs = Nothing
End Sub


 GetOption- und SetOption-Methode

GetOption- und SetOption-Methode

Sprachspezifische Informationen

Use these methods to inspect or set any of the options in the Options dialog box (Tools menu). This includes all of the options in the Right-to-Left tab that have been implemented for right-to-left and bidirectional use.


GetOption-, SetOption-Methoden - Beispiel

Das folgende Beispiel verwendet die Methode GetOption zur Rückgabe der Einstellung der Option Standardfeldtyp aus der Registerkarte Tabellen/Abfragen des Dialogfelds Optionen und speichert anschließend die Einstellung in einer Variablen. Ist die Option Standardfeldtyp momentan nicht auf Text eingestellt, fragt Microsoft Access den Benutzer in einem Dialogfeld, ob die Option auf Text eingestellt werden soll. Klickt der Benutzer auf Ja, ändert die Methode SetOption die Option.

Sub FeldgrößeÄndern()
    ' Die Konstante entspricht der Text-Einstellung für die Option
    ' Standardfeldtyp.
    Const conText = 0

    Dim varSize As Variant, intResponse As Integer
    Dim strMsg As String

    ' Aktuelle Einstellung ermitteln.
    varSize = Application.GetOption("Default Field Type")
    strMsg = "Standardfeldtyp auf Text einstellen?"
    If varSize <> conText Then
    ' Benutzer zum Ändern der Einstellung auffordern, wenn kein Text.
        If MsgBox(strMsg, vbYesNo) = vbYes Then
            ' Einstellung auf Text ändern.
            Application.SetOption "Default Field Type", conText
        End If
    End If
End Sub


GoToPage-Methode (Application-Objekt) - Beispiel

Das folgende Beispiel verwendet die Methode GoToPage, um den Fokus auf die zweite Seite des Formulars Kunden auf die Position zu setzen, die durch die Argumente rechts und unten festgelegt ist.

Formulare!Kunden.GoToPage 2, 1440, 600


HyperlinkPart-Methode - Beispiel

Das folgende Beispiel verwendet alle vier Konstanten des Arguments Teil, um die Informationen anzuzeigen, die die Methode HyperlinkPart für jeden Datensatz in einer Tabelle mit einem Hyperlink-Feld anzeigt. Um dieses Beispiel zu testen, fügen Sie die Prozedur AnzeigenHyperlinkTeile in den Deklarationsbereich eines Moduls ein. Sie können die Prozedur AnzeigenHyperlinkTeile vom Testfenster aus aufrufen und ihr den Namen einer Tabelle übergeben, die Hyperlinks enthält, sowie den Namen des Feldes, das die Hyperlinkdaten enthält. Beispiel:

AnzeigenHyperlinkTeile "HyperlinkTabelle1Name", "HyperlinkFeld1Name"

Sub AnzeigenHyperlinkTeile(strTabelle As String, strFeld As String)
    Dim rst As New ADODB.Recordset
    Dim strMsg As String

    rst.Open(strTabelle,currentproject.connection,_
        adOpenForwardOnly, adLockReadOnly)

    While Not rst.EOF        ' Für jeden Datensatz in der Tabelle.
        strMsg = "DisplayValue = " _
            & HyperlinkPart(rst(strFeld), acDisplayedValue) _
            & vbCrLf & "DisplayText = " _
            & HyperlinkPart(rst(strFeld), acDisplayText) _
            & vbCrLf & "Address = " _
            & HyperlinkPart(rst(strFeld), acAddress) _
            & vbCrLf & "SubAddress = " _
            & HyperlinkPart(rst(strFeld), acSubAddress) _
            & vbCrLf & "ScreenTip = " _
            & HyperlinkPart(rst(strFeld), acScreenTip) _
            & vbCrLf & "Full Address = " _
            & HyperlinkPart(rst(strFeld), acFullAddress)
        ' Von der  Methode "HyperlinkPart" zurückgegebene Teile anzeigen.
        MsgBox strMsg
        rst.MoveNext
    Wend
End Sub

Wenn Sie die Methode HyperlinkPart in einer Abfrage verwenden, ist das Argument Teil notwendig. Die folgende SQL-Anweisung verwendet z.B. die Methode HyperlinkPart, um Informationen über Daten zu liefern, die im Feld URL-Adresse der Tabelle Verknüpfungen gespeichert sind:

SELECT Links.URL, HyperlinkPart([URL],0)
AS Display, HyperlinkPart([URL],1)
AS Name, HyperlinkPart([URL],2)
AS Addr, HyperlinkPart([URL],3)
AS SubAddr, HyperlinkPart([URL],4)
AS ScreenTip
FROM Links;


InsertText-Methode - Beispiel

Das folgende Beispiel fügt eine Textzeichenfolge in ein Standardmodul ein.

Function EinfügenText(strModulname) As Boolean
    Dim mdl As Module, strText As String

    On Error GoTo Error_EinfügenText
    ' Modul öffnen.
    DoCmd.OpenModule strModulname
    ' Verweis auf Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
    ' Zeichenfolgenvariable initialisieren.
    strText = "Sub NachrichtAnzeigen()" & vbCrLf _
        & vbTab & "MsgBox ""Super!""" & vbCrLf _
        & "End Sub"
    ' Text in Modul einfügen.
    mdl.InsertText strText
    EinfügenText = True

Exit_EinfügenText:
    Exit Function

Error_EinfügenText:
    MsgBox Err & ": " & Err.Description
    EinfügenText = False
    Resume Exit_EinfügenText
End Function


Line-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Line zum Zeichnen eines roten Rechtecks jeweils 5 Pixel innerhalb des Randes des Berichts Personalbericht. Mit Hilfe der Funktion RGB wird die Linie rot dargestellt.

Damit Sie dieses Beispiel in Microsoft Access testen können, erstellen Sie einen neuen Bericht. Geben Sie den folgenden Code im Deklarationsbereich des Moduls des Berichts ein, und wechseln Sie dann zur Seitenansicht.

Private Sub Detail_Print(Cancel As Integer, PrintCount As Integer)
    ' Prozedur LinieZeichnen aufrufen.
    LinieZeichnen
End Sub

Sub LinieZeichnen()
    Dim rpt As Report, lngFarbe As Long
    Dim sngOben As Single, sngLinks As Single
    Dim sngBreite As Single, sngHöhe As Single

    Set rpt = Reports!Personalbericht
    ' Skalierung auf Pixel einstellen.
    rpt.ScaleMode = 3
    ' Obere Innenkante.
    sngOben = rpt.ScaleTop + 5
    ' Linke Innenkante.
    sngLinks = rpt.ScaleLeft + 5
    ' Breite der Innenkante.
    sngBreite = rpt.ScaleWidth - 10
    ' Höhe der Innenkante.
    sngHöhe = rpt.ScaleHeight - 10
    ' Rot färben.
    lngFarbe = RGB(255,0,0)
    ' Linie als Rechteck zeichnen.
    rpt.Line(sngOben, sngLinks) - (sngBreite, sngHöhe), lngFarbe, B
End Sub


Move-Methode: Beispiel

Das folgende Beispiel verwendet die Move-Methode, um in einem Recordset-Objekt den Datensatzzeiger um zwei Positionen vorwärts zu bewegen:

Sub VorwärtsBewegen()
    Dim rst As New ADODB.Recordset
    Dim strKriterien As String

    ' Recordset-Objekt von Typ "Dynaset" öffnen.
    rst.Open "SELECT * FROM Bestellungen ORDER BY Bestimmungsland;" _
, currentProject.connection, adOpenKeyset, adLockOptimistic
    rst.MoveLast
    rst.MoveFirst
    ' Anzahl der Datensätze im Recordset-Objekt ermitteln.
    If rst.RecordCount > 2 Then
        ' Zwei Zeilen vorwärts bewegen.
        rst.Move 2
        Debug.Print rst!Bestimmungsland
    End If
    rst.Close
End Sub


MoveFirst-, MoveLast-, MoveNext- und MovePrevious-Methode: Beispiel

Das folgende Beispiel verwendet die MoveLast-Methode zur Auffüllung des Recordset-Objekts mit Daten, so dass die Anzahl der Datensätze ermittelt werden kann. Die MoveFirst-Methode verschiebt anschließend den aktuellen Datensatzzeiger zum ersten Datensatz im Recordset-Objekt. Die Prozedur fordert den Benutzer zur Eingabe einer Zahl auf und verschiebt dann um die entsprechende Anzahl von Datensätzen vorwärts.

Sub DatensätzeDurchlaufen()
    Dim rst As New ADODB.Recordset, intI As Integer
    Dim intAnzahl As Integer

    rst.Open "Artikel", CurrentProject.Connection, adOpenKeyset, adLockOptimistic
    ' Recordset-Objekt mit Daten auffüllen.
    rst.MoveLast
    ' Zum ersten Datensatz zurückkehren.
    rst.MoveFirst
    ' Eingabe einer Zahl, die kleiner als die Anzahl der Datensätze ist.
    intAnzahl = InputBox("Geben Sie eine Zahl kleiner als " _
        & rst.RecordCount & " ein.")
    ' Um die entsprechende Zahl von Datensätzen vorrücken.
    For intI = 1 To intAnzahl
        rst.MoveNext
    Next intI
    Debug.Print rst!Artikelname
    rst.Close

End Sub


MoveFirst-, MoveLast-, MoveNext-, MovePrevious-Methoden - Beispiel (MDB)

Das folgende Beispiel verwendet die Methode MoveLast, um das Recordset-Objekt aufzufüllen, so dass die Datensätze gezählt werden können. Die Methode MoveFirst bewegt dann den aktuellen Datensatzzeiger auf den ersten Datensatz im Recordset-Objekt. Die Prozedur fordert den Benutzer auf, eine Zahl einzugeben, und bewegt dann den Datensatzzeiger um die angegebene Anzahl von Datensätzen vorwärts.

Sub BewegenZumDatensatz()
    Dim dbs As Database, rst As Recordset, intI As Integer
    Dim strAnzahl As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    Set rst = dbs.OpenRecordset("Artikel")
    ' Recordset-Objekt auffüllen.
    rst.MoveLast
    ' Zum ersten Datensatz zurückkehren.
    rst.MoveFirst
    ' Eingabe einer Zahl anfordern, die kleiner als die Anzahl der Datensätze ist.
    strAnzahl = InputBox("Bitte geben Sie eine Zahl ein, die kleiner ist als " _
        & rst.RecordCount & ".")
    ' Um die angegebene Anzahl von Datensätzen bewegen.
    For intI = 1 To strAnzahl
        rst.MoveNext
    Next intI
    Debug.Print rst!Artikel
    rst.Close
    Set dbs = Nothing
End Sub


Move-Methode - Beispiel (MDB)

Das folgende Beispiel verwendet die Methode Move, um sich in einem Recordset-Objekt zwei Zeilen vorwärts zu bewegen.

Sub VorwärtsBewegen()
    Dim dbs As Database, rst As Recordset
    Dim strKriterien As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rst = dbs.OpenRecordset("SELECT * FROM Bestellungen " _
        & "ORDER BY Bestimmungsland;")
    rst.MoveLast
    rst.MoveFirst
    ' Anzahl der Datensätze im Recordset-Objekt prüfen.
    If rst.RecordCount > 2 Then
        ' Zwei Zeilen vorwärts bewegen.
        rst.Move 2
        Debug.Print rst!Bestimmungsland
    End If
    rst.Close
    Set dbs = Nothing
End Sub


NewCurrentDatabase-Methode - Beispiel

Im folgenden Beispiel wird eine neue Microsoft Access-Datenbank über Automatisierung aus einer anderen Anwendung heraus erstellt. Anschließend wird in dieser Datenbank eine neue Tabelle erstellt.

Sie können diesen Code in jeder Anwendung, die als COM-Komponente fungieren kann, in ein Visual Basic-Modul eingeben. Sie könnten den Code z.B. aus Microsoft Excel, Microsoft Visual Basic oder Microsoft Access heraus ausführen.

Wenn der Programmbereich verlassen wird, in dem die Variable gültig ist, die auf das Application-Objekt zeigt, wird auch die Microsoft Access-Instanz geschlossen, die der Variablen entspricht. Sie sollten diese Variable daher auf Modulebene deklarieren.

' Fügen Sie folgende Zeile in den Deklarationsbereich
' des Moduls ein.
Dim appAccess As Access.Application

Sub NeueAccessDatenbank()
    Dim dbs As Object, tdf As Object, fld As Variant
    Dim strDB As String
    Const DB_Text As Long = 10
    Const FldLen As Integer = 40

    ' Die Zeichenfolge initialisieren, die den Pfad
    ' der Datenbank angibt.
    strDB = "C:\Eigene Dateien\NeueDB.mdb"
    ' Eine neue Instanz von Microsoft Access erstellen.
    Set appAccess = _
        CreateObject("Access.Application.9")
    ' Die Datenbank im Microsoft Access-Fenster öffnen.
    appAccess.NewCurrentDatabase strDB
    ' Die Database-Objektvariable einstellen.
    Set dbs = appAccess.CurrentDb
    ' Eine neue Tabelle erstellen.
    Set tdf = dbs.CreateTableDef("Kontakte")
    ' Ein Feld für die neue Tabelle erstellen.
    Set fld = tdf. _
        CreateField("Firmenname", DB_Text, FldLen)
    ' Das Field- und das TableDef-Objekt anfügen.
    tdf.Fields.Append fld
    dbs.TableDefs.Append tdf
    Set appAccess = Nothing
End Sub


Open-Methode: Beispiel

Das folgende Beispiel gibt eine Variable vom Typ Connection zurück, die auf die aktuelle Verbindung zeigt. Es öffnet dann eine andere Verbindung namens ANDERE.MDB mit Hilfe der Open-Methode. Schließlich durchläuft die Prozedur eine Auflistung aller Table-Objekte in beiden Datenbanken.

Um dieses Beispiel selbst durchzuführen, erstellen Sie eine neue Datenbank mit dem Namen ANDERE.MDB. Schließen Sie diese Datenbank, und speichern Sie sie in dem Verzeichnis, von dem aus der Code ausgeführt wird.

Sub AndereDBÖffnen()
    Dim cat As New ADOX.Catalog, catAndere As New ADOX.Catalog
    Dim cnnAndere As New ADODB.Connection
    Dim tbl As ADOX.Table

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cat.ActiveConnection = CurrentProject.Connection
    cnnAndere.Provider = "Microsoft.Jet.OLEDB.4.0"
    cnnAndere.Open "DATA SOURCE=Andere.mdb"
    ' Referenz auf Andere.mdb ermitteln.
    Set catAndere.ActiveConnection = cnnAndere
    ' Eine Auflistung aller Table-Objekte beider Datenbanken durchlaufen.
    Debug.Print CurrentProject.Connection.Properties("Data Source Name") & ":"
    For Each tbl In cat.Tables
        Debug.Print tbl.Name
    Next tbl
    Debug.Print vbCrLf & cnnAndere.Properties("Data Source Name") & ":"
    For Each tbl In catAndere.Tables
        Debug.Print tbl.Name
    Next tbl
    Set cat = Nothing
    Set cnnAndere = Nothing
    Set catAndere = Nothing
End Sub

Anmerkung Falls dieser Code in einem ADP ausgeführt wird, muss das Provider-Attribut auf den Wert "SQLOLEDB.1" gesetzt werden. Außerdem muss der Parameter ConnectionString der Open-Methode der Verbindung eine Referenz auf eine SQL-Datenbank darstellen.

Das folgende Beispiel öffnet ein Recordset-Objekt vom Typ "Keyset" und gibt die Anzahl der Objekte aus, die im Recordset-Objekt enthalten sind.

Sub USABestellungen()
    Dim rst As New ADODB.Recordset
    Dim strSQL As String

    strSQL = "SELECT * FROM Bestellungen WHERE [Bestimmungsland] = 'USA'"
    rst.Open strSQL, CurrentProject.Connection, adOpenKeyset, adLockOptimistic
    rst.MoveLast
    Debug.Print rst.RecordCount
    rst.Close
End Sub


 OpenConnection-Methode

OpenConnection-Methode

Mit der OpenConnection-Methode können Sie eine ADO-Verbindung mit einem vorhandenen Microsoft Access-Projekt (.adp) oder einer Access-Datenbank (.mdb) öffnen und das angebundene Projekt bzw. die Datenbank als aktuelles Access-Projekt bzw. aktuelle Datenbank im Microsoft Access-Fenster anzeigen.

Syntax

Objekt.OpenConnection [Verbindungszeichenfolge][, Benutzer-ID][, Kennwort]

Die OpenConnection-Methode verwendet die folgenden Argumente.

Argument | Beschreibung
Objekt | Das CurrentProject- oder CodeProject-Objekt.
Verbindungszeichenfolge | Ein Zeichenfolgenausdruck, der die Haupt-Verbindungszeichenfolge der Datenbank repräsentiert.
Benutzer-ID | Ein Zeichenfolgenausdruck, der den Namen des vorhandenen Access-Projekts (einschließlich des Pfadnamens und der Dateinamenerweiterung) bezeichnet. Sofern Ihr Netzwerk dies unterstützt, können Sie außerdem einen Netzwerkpfad der folgenden Art angeben: \\Server\Freigabe\Ordner\Dateiname.adp
Kennwort | Anmerkung Wenn Sie die Dateinamenerweiterung nicht angeben, wird automatisch .adp an den Dateinamen angehängt. Sie können diese Methode oder die OpenCurrentDatabase-Methode verwenden, um .adp-Dateien zu öffnen.

Anmerkungen

Die OpenConnection-Methode ähnelt der Open-Methode eines ADO Connection-Objekts. Diese Methode dient der Einrichtung der Übertragungswege zur Datenquelle. Nach erfolgreicher Ausführung dieser Methode ist die Verbindung funktionsbereit, die Connection-Eigenschaft und die BaseConnectionString-Eigenschaft sind definiert, und das Datenbank-Fenster bzw. die Datenzugriffsseite sollte mit Daten der neuen Verbindung aufgefüllt sein. Alle Parameter dieser Methode sind optional. Wenn keine Hauptverbindungszeichenfolge zur Verfügung gestellt wird, erfolgt die Verbindungseinrichtung unter Verwendung der zuletzt angegebenen Hauptverbindungszeichenfolge (aber der Benutzer muss zuerst CloseConnection aufrufen, bevor er erneut OpenConnection aufruft). Im Falle eines Access-Projekts kann die BaseConnectionString-Eigenschaft als Wert nur den SQL Server OLE DB Provider annehmen.


OpenCurrentDatabase-Methode - Beispiel

Im folgenden Beispiel wird eine Microsoft Access-Datenbank über Automatisierung aus einer anderen Anwendung heraus geöffnet. Anschließend wird in dieser Datenbank ein Formular geöffnet.

Sie können diesen Code in jeder Anwendung, die als COM-Komponente fungieren kann, in ein Visual Basic-Modul eingeben. Sie könnten den Code z.B. aus Microsoft Excel, Microsoft Visual Basic oder Microsoft Access heraus ausführen.

Wenn der Programmbereich verlassen wird, in dem die Variable gültig ist, die auf das Application-Objekt zeigt, wird auch die Microsoft Access-Instanz geschlossen, die der Variablen entspricht. Sie sollten diese Variable daher auf Modulebene deklarieren.

' Fügen Sie folgende Zeile in den Deklarationsbereich
' des Moduls ein.
Dim appAccess As Access.Application

Sub FormularAnzeigen()
    ' Die Zeichenfolge initialisieren, die den Pfad
    ' der Datenbank angibt.
    Const strConPfadZuDenBeispielen = "C:\Programme" _
        & "\Microsoft Office\Office\Access\Samples\Nordwind.mdb"

    strDB = strConPfadZuDenBeispielen & "Nordwind.mdb"
    ' Eine neue Instanz von Microsoft Access erstellen.
    Set appAccess = _
        CreateObject("Access.Application")
    ' Die Datenbank im Microsoft Access-Fenster öffnen.
    appAccess.OpenCurrentDatabase strConPfadZuDenBeispielen
    ' Das Formular "Bestellungen" öffnen.
    appAccess.DoCmd.OpenForm "Bestellungen"
End Sub


OpenDatabase-Methode (MDB)

Verwenden Sie in Microsoft Access die CurrentDb-Methode, um einen Bezug auf die aktuelle Datenbank zurückzugeben, und weisen Sie diese wie im folgenden Beispiel einer Variablen vom Typ Database zu:

Dim dbsAktuell As Database
Set dbsAktuell = CurrentDb

Verwenden Sie die OpenDatabase-Methode, um eine andere als die aktuelle Datenbank aus Visual Basic zu öffnen.


OpenDatabase-Methode - Beispiel (MDB)

Das folgende Beispiel gibt eine Datenbankvariable zurück, die auf die aktuelle Datenbank verweist. Anschließend wird unter Verwendung der Methode OpenDatabase eine andere Datenbank mit dem Namen ANDERE.MDB geöffnet. Die Prozedur durchläuft dann alle TableDef-Objekte in beiden Datenbanken.

Um dieses Beispiel selbst durchzuführen, erstellen Sie eine neue Datenbank mit dem Namen ANDERE.MDB. Schließen Sie diese Datenbank, und speichern Sie sie in dem Verzeichnis, von dem aus der Code ausgeführt wird.

Sub WeitereDatenbankÖffnen()
    Dim wsp As Workspace
    Dim dbs As Database, dbsAndereDB As Database
    Dim tdf As TableDef

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf Standardarbeitsbereich holen.
    Set wsp = DBEngine.Workspaces(0)
    ' Verweis auf ANDERE.MDB holen.
    Set dbsAndereDB = wsp.OpenDatabase("ANDERE.mdb")
    ' Alle TableDef-Objekte in jeder Datenbank durchlaufen.
    Debug.Print dbs.Name & ":"
    For Each tdf in dbs.TableDefs
        Debug.Print tdf.Name
    Next tdf
    Debug.Print
    Debug.Print dbsAndereDB.Name & ":"
    For Each tdf in dbsAndereDB.TableDefs
        Debug.Print tdf.Name
    Next tdf
    Set dbs = Nothing
    Set dbsAndereDB = Nothing
End Sub


OpenRecordset-Methode - Beispiel (MDB)

Das folgende Beispiel öffnet ein Recordset-Objekt vom Typ Dynaset und gibt die Anzahl der Datensätze im Recordset-Objekt aus.

Sub GBBestellungen()
    Dim dbs As Database, rst As Recordset
    Dim strSQL As String

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    strSQL = "SELECT * FROM Bestellungen WHERE [Bestimmungsland] = 'GB'"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    rst.Close
    Set dbs = Nothing
End Sub


Print-Methode

Die Visual Basic-Methode Print hat in Microsoft Access nur für das Debug-Objekt, niemals für ein Form-Objekt Gültigkeit. Das Debug-Objekt ist erforderlich, wenn Sie die Methode Print in Microsoft Access verwenden.

Die Visual Basic-Methode Print ist nicht mit der Microsoft Access-Methode Print identisch, die immer nur für ein Report-Objekt Gültigkeit hat.


Print-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Print, um Text im Bericht Bericht1 auszugeben. Mit den Methoden TextWidth und TextHeight wird der Text horizontal und vertikal zentriert.

Private Sub Detail_Format(Cancel As Integer, _
        FormatCount As Integer)
    Dim rpt as Report
    Dim strMeldung As String
    Dim intBreite As Integer, intHöhe As Integer

    Set rpt = Me
    strMeldung = "Hier ist die Meldung"
    With rpt
        'Skalierung auf Pixel sowie Eigenschaften FontName und
        'FontSize einstellen.
        .ScaleMode = 3
        .FontName = "Courier"
        .FontSize = 24
    End With
    ' Horizontale Breite.
    intBreite = Rpt.TextWidth(strMeldung)
    ' Vertikale Höhe.
    intHöhe = Rpt.TextHeight(strMeldung)
    ' Position des anzuzeigenden Textes berechnen.
    Rpt.CurrentX = (Rpt.ScaleWidth/2) - (intBreite/2)
    Rpt.CurrentY = (Rpt.ScaleHeight/2) - (intHöhe/2)
    ' Text auf Report-Objekt ausgeben.
    Rpt.Print strMeldung
End Sub


PSet-Methode - Beispiel

Das folgende Beispiel verwendet die Methode PSet zum Zeichnen einer Linie entlang der horizontalen Achse eines Berichts.

Damit Sie dieses Beispiel in Microsoft Access testen können, erstellen Sie einen neuen Bericht. Stellen Sie die Eigenschaft OnPrint des Detailbereichs auf [Ereignisprozedur] ein. Geben Sie den folgenden Code in das Modul des Berichts ein, und wechseln Sie dann zur Seitenansicht.

Sub Detail_Print(Cancel As Integer, PrintCount As Integer)
    Dim sngMittelp As Single, intI As Integer

' Skalierung auf Pixel setzen.
    Me.ScaleMode = 3
' Mittelpunkt berechnen.
    sngMittelp = Me.ScaleHeight / 2
    ' Schleife zum pixelweisen Zeichnen der Linie entlang der horizontalen Achse.
    For intI = 1 To Me.ScaleWidth
        Me.PSet(intI, sngMittelp)
    Next intI
End Sub


Quit-Methode (Application-Objekt) - Beispiel

Das folgende Beispiel zeigt die Click-Ereignisprozedur für eine Befehlsschaltfläche namens AnwBeenden. Nachdem der Benutzer auf diese Schaltfläche geklickt hat, fordert ihn ein Dialogfeld auf, seine Änderungen zu speichern. Danach beendet die Prozedur Microsoft Access.

Private Sub AnwBeenden_Click()
    Application.Quit acPrompt
End Sub


 Raise-Methode

Raise-Methode

Die Methode Raise erzeugt einen angegebenen Visual Basic-Fehler. Die Eigenschaften des Err-Objekts werden so eingestellt, als ob der Fehler im laufenden Code aufgetreten ist. Dies gilt jedoch nur für Visual Basic-Fehler, nicht für Microsoft Access-Fehler oder für Fehler der Microsoft Jet-Datenbank-Engine.

Wenn Sie die Methode Raise zusammen mit einer von Microsoft Access oder der Jet-Datenbank-Engine reservierten Fehlernummer verwenden, lautet der Wert der Eigenschaft Description für das Err-Objekt "Ungültiger Prozeduraufruf". Zum Anzeigen der beschreibenden Zeichenfolge für einen Microsoft Access- oder einen Jet-Datenbank-Engine-Fehler, der nicht im laufenden Code aufgetreten ist, verwenden Sie die Methode AccessError.

Die Methode AccessError verwendet einen Wert vom Datentyp Long, der eine Fehlernummer darstellt, und gibt die diesem Fehler zugeordnete beschreibende Zeichenfolge zurück.


Recalc-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Recalc, um Steuerelemente im Formular Bestellungen zu aktualisieren. Dieses Formular enthält das Textfeld Frachtkosten, das die Frachtkosten anzeigt, sowie ein berechnetes Steuerelement, das die Gesamtkosten der Bestellungen inklusive Fracht anzeigt. Wenn die Anweisung, die die Methode Recalc enthält, in die AfterUpdate-Ereignisprozedur des Textfelds Frachtkosten eingefügt wird, werden die Gesamtkosten einer Bestellung bei jeder Eingabe eines neuen Frachtbetrags neu berechnet.

Sub Frachtkosten_AfterUpdate()
    Me.Recalc
End Sub


Refresh-Methode: Beispiel

Das folgende Beispiel aktualisiert die Indexes-Auflistung eines Table-Objekts. Bei einer Datenbank, die in einer Mehrbenutzerumgebung verwendet wird, kann die Refresh-Methode dazu benutzt werden, die Änderungen an den Index-Objekten der Indexes-Auflistung eines Table-Objekts anzuzeigen, die von anderen Benutzern vorgenommen wurden.

Sub IndexAktualisieren()
    Dim cat As New ADOX.Catalog, tbl As ADOX.Table
    Dim idx As ADOX.Index, clm As ADOX.Column

    ' Referenz auf aktuelle Datenbank ermitteln.
    Set cat.ActiveConnection = CurrentProject.Connection
    Set tbl = cat.Tables!Personal
    tbl.Indexes.Refresh
    For Each idx In tbl.Indexes
        Debug.Print idx.Name; ":"
        For Each clm In idx.Columns
            Debug.Print "   "; clm.Name
        Next clm
    Next idx
    Set cat = Nothing
End Sub


RefreshDatabaseWindow-Methode - Beispiel

Das folgende Beispiel erstellt ein neues Formular, speichert es, und aktualisiert das Datenbankfenster.

Sub ErstellenFormularUndAktualisieren()
    Dim frm As Form

    Set frm = CreateForm
    DoCmd.Save , "NeuesFormular"
    RefreshDatabaseWindow
End Sub


RefreshTitleBar-Methode: Beispiel

Das folgende Beispiel weist der AppTitle-Eigenschaft der aktuellen Datenbank einen Wert zu und ruft die RefreshTitleBar-Methode zur Aktualisierung der Titelleiste auf.

Sub TitelÄndern()
 Dim obj As Object
 Const conEigenschNichtGefFehler = 3270

 On Error GoTo Fehlerbehandlung
 ' Database-Objektvariable mit Referenz auf die
 ' aktuelle Datenbank.
 Set dbs = CurrentDb
 ' Titelleiste ändern.
 dbs.Properties!AppTitle = "Adressdatenbank"
 ' Titelleiste auf dem Bildschirm aktualisieren.
 Application.RefreshTitleBar
 Exit Sub

FehlerBehandlung:
 If Err.Number = conEigenschNichtGefFehler Then
 Set obj = dbs.CreateProperty("AppTitle", dbText, "Adressdatenbank")
 dbs.Properties.Append obj
 Else
 MsgBox "Fehler: " & Err.Number & vbCrLf & Err.Description
 End If
 Resume Next
End Sub


Refresh-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Refresh, um die Datensätze der zugrunde liegenden Datenherkunft im Formular Kunden zu aktualisieren, sobald das Formular den Fokus erhält.

Private Sub Form_Activate()
    Me.Refresh
End Sub


Remove-Methode (References-Auflistung) - Beispiel

Die beiden folgenden Funktionen verwalten Verweise auf Kalender-Steuerelemente. Die erste Funktion fügt zur References-Auflistung einen Verweis auf das Kalender-Steuerelement hinzu. Die zweite Funktion entfernt den Verweis auf das Kalender-Steuerelement.

Function HinzufügenReferenz() As Boolean
    Dim ref As Reference, strDatei As String

    On Error GoTo Error_HinzufügenReferenz
    strDatei = "C:\Windows\System\Mscal.ocx"
    ' Verweis auf Kalender-Steuerelement erstellen.
    Set ref = References.AddFromFile(strDatei)
    HinzufügenReferenz = True

Exit_HinzufügenReferenz:
    Exit Function

Error_HinzufügenReferenz:
    MsgBox Err & ": " & Err.Description
    HinzufügenReferenz = False
    Resume Exit_HinzufügenReferenz
End Function

Function EntfernenReferenz() As Boolean
    Dim ref As Reference

    On Error GoTo Error_EntfernenReferenz
    Set ref = References!MSACAL
    ' Verweis auf Kalender-Steuerelement entfernen.
    References.Remove ref
    EntfernenReferenz= True

Exit_EntfernenReferenz:
    Exit Function

Error_EntfernenReferenz:
    MsgBox Err & ": " & Err.Description
    EntfernenReferenz = False
    Resume Exit_EntfernenReferenz
End Function


Repaint-Methode - Beispiel

Das folgende Beispiel verwendet die Methode Repaint zum Aktualisieren eines Formulars, sobald der Fokus darauf gesetzt wird.

Private Sub Form_Activate()
    Me.Repaint
End Sub


Requery-Methode (Steuerelement- oder Formular-Objekt) - Beispiel

Das folgende Beispiel verwendet die Methode Requery, um die Daten erneut abzufragen, die im Formular Personal im Listenfeld Angestelltenliste angezeigt werden.

Sub ListeErneutAbfragen()
    Dim ctlListe As Control

    ' Control-Objekt zurückgeben, das auf das Listenfeld zeigt.
    Set ctlListe = Formulare!Personal!Angestelltenliste
    ' Datenherkunft des Listenfelds erneut abfragen.
    ctlListe.Requery
End Sub


 Reset-Methode

Reset-Methode

Wenn Sie in Microsoft Access 2000 eine eingebaute Menüleiste oder Symbolleiste zurücksetzen möchten, können Sie das Dialogfeld Symbolleisteneigenschaften verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen. Klicken Sie anschließend im Dialogfeld Anpassen auf die Schaltfläche Eigenschaften. Wählen Sie im Feld Ausgewählte Symbolleiste die gewünschte eingebaute Menüleiste oder Symbolleiste, und klicken Sie dann auf die Schaltfläche Standardeinstellungen wiederherstellen. Sie können benutzerdefinierte Menüleisten oder Symbolleisten oder spezifische Kontextmenüs nicht zurücksetzen.

Die Schaltfläche Neu initialisieren im Dialogfeld Anpassen setzt die ausgewählte eingebaute Menüleiste oder Symbolleiste zurück, bzw. alle eingebauten Kontextmenüs, wenn Sie Kontextmenüs im Dialogfeld Anpassen auswählen. Der Befehl Neu initialisieren im Kontextmenü, das angezeigt wird, wenn Sie im geöffneten Dialogfeld Anpassen mit der rechten Maustaste auf ein bestimmtes eingebautes Steuerelement in einer Menüleiste oder Symbolleiste zeigen, setzt das Steuerelement in seinen ursprünglichen Zustand zurück. Die Schaltfläche Neu initialisieren und der Befehl Neu initialisieren entsprechen der Reset-Methode.

Die Schaltfläche Standardeinstellungen wiederherstellen setzt nicht nur das Bild, den Text und den ausgeführten Befehl von Menüleisten- oder Symbolleisten-Steuerelementen zurück, sondern stellt außerdem alle Originaleinstellungen für die Menüleiste oder Symbolleiste wieder her, einschließlich der ursprünglichen Position und des Anzeigezustands.


Open-Methode (Recordset)

Verwenden Sie in Microsoft Access die Connection-Eigenschaft des CurrentProject-Objekts, um wie im folgenden Beispiel auf die geöffnete Verbindung der aktuellen Datenbank zu verweisen.

Dim rsCurrent As ADODB.Recordset
rsCurrent.Open "Select * From Personal", _
    CurrentProject.Connection


RunCommand-Methode - Beispiel

Das folgende Beispiel verwendet die Methode RunCommand, um das Dialogfeld Optionen (im Menü Extras durch Klicken auf Optionen verfügbar) zu öffnen.

Function ÖffnenDialogfeldOptionen() As Boolean
    On Error GoTo Error_ÖffnenDialogfeldOptionen
    DoCmd.RunCommand acCmdOptions
    ÖffnenDialogfeldOptionen = True

Exit_ÖffnenDialogfeldOptionen:
    Exit Function

Error_ÖffnenDialogfeldOptionen:
    MsgBox Err & ": " & Err.Description
    ÖffnenDialogfeldOptionen = False
    Resume Exit_ÖffnenDialogfeldOptionen
End Function


Run-Methode - Beispiel

Im folgenden Beispiel wird eine benutzerdefinierte Sub-Prozedur in einem Modul einer Microsoft Access-Datenbank aus einer anderen Anwendung heraus ausgeführt, die als Active X Element dient.

Wenn Sie dieses Beispiel ausprobieren möchten, erstellen Sie eine Datenbank namens RUNCODE.MDB, und stellen Sie deren Eigenschaft ProjektName auf RUNCODE. Öffnen Sie ein neues Modul in der Datenbank, und geben Sie den folgenden Code ein. Speichern Sie das Modul, und schließen Sie die Datenbank.

Sub Begrüßung(strName As String)
    MsgBox("Hallo " & strName)
End Sub

Führen Sie nach diesem Schritt den folgenden Code in Microsoft Excel oder Microsoft Visual Basic aus. Prüfen Sie, ob Sie eine Referenz auf die Typbibliothek von Microsoft Access aktiviert haben. Klicken Sie dazu im Menü Extras auf Verweise, und aktivieren Sie im Dialogfeld Verweise den Eintrag Microsoft Access 9.0 Object Library.

' Fügen Sie folgende Zeile in den Deklarationsbereich
' des Moduls ein.
Dim appAccess As Access.Application

Sub AccessSubProzAusführen()
    ' Eine neue Instanz von Microsoft Access erstellen.
    Set appAccess = _
        CreateObject("Access.Application.9")
    ' Die Datenbank RunCode im Microsoft Access-Fenster öffnen.
    appAccess.OpenCurrentDatabase "C:\Eigene Dateien\RunCode.mdb", False
    ' Die Sub-Prozedur ausführen.
    appAccess.Run "Begrüßung", "Horst"
    Set appAccess = Nothing
End Sub


Scale-Methode - Beispiel

Das folgende Beispiel zeichnet eine Linie mit einer bestimmten Maßeinteilung, ändert diese dann mit der Methode Scale und zeichnet eine neue Linie mit der neuen Maßeinteilung.

Private Sub Detail_Print(Cancel As Integer, PrintCount As Integer)
    KreisZeichnen
End Sub

Sub KreisZeichnen()
    Dim sngHCtr As Single, sngVCtr As Single
    Dim sngNewH As Single, sngNewV As Single
    Dim sngRadius As Single

    ' Skalierung auf Pixel setzen.
    Me.ScaleMode = 3
    ' Horizontale Mittelpunktposition.
    sngHCtr = Me.ScaleWidth / 2
    ' Vertikale Mittelpunktposition.
    sngVCtr = Me.ScaleHeight / 2
    ' Kreisradius.
    sngRadius = Me.ScaleHeight / 3
    ' Kreis zeichnen.
    Me.Circle (sngHCtr, sngVCtr), sngRadius
    ' Neue horizontale Skalierung.
    sngNewH = Me.ScaleWidth * 0.9
    ' Neue vertikale Skalierung.
    sngNewV = Me.ScaleHeight * 0.9
    ' Wechseln auf die neue Skalierung.
    Me.Scale(0, 0)-(sngNewH, sngNewV)
    ' Kreis zeichnen.
    Me.Circle (sngHCtr + 100, sngVCtr), sngRadius, RGB(0, 256, 0)
End Sub


Seek-Methode - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Index-Objekt in der Tabelle Personal. Der neue Index besteht aus zwei Feldern, Nachname und Vorname. Die Prozedur verwendet dann die Methode Seek, um einen bestimmten Datensatz zu finden.

Sub NeuerIndex()
    Dim dbs As Database, tdf As TableDef, idx As Index
    Dim fldNachname As Field, fldVorname As Field, _
        rst As Recordset

    ' Verweis auf aktuelle Datenbank holen.
    Set dbs = CurrentDb
    ' Verweis auf Tabelle "Personal" holen.
    Set tdf = dbs.TableDefs!Personal
    ' Index-Objekt zurückgeben, das auf den neuen Index verweist.
    Set idx = tdf.CreateIndex("GanzerName")
    ' Index-Felder erstellen und anfügen.
    Set fldNachname = idx.CreateField("Nachname", dbText)
    Set fldVorname = idx.CreateField("Vorname", dbText)
    idx.Fields.Append fldNachname
    idx.Fields.Append fldVorname
    ' Index-Objekt anfügen.
    tdf.Indexes.Append idx
    tdf.Indexes.Refresh
    ' Recordset-Objekt vom Typ Tabelle öffnen.
    Set rst = dbs.OpenRecordset("Personal")
    ' Aktuellen Index auf neuen Index einstellen.
    rst.Index = idx.Name
    ' Gesuchten Datensatz angeben.
    rst.Seek "=", "Hofmann", "Klaus"
    If rst.NoMatch Then
        Debug.Print "Suche nicht erfolgreich!"
    Else
        Debug.Print "Suche erfolgreich."
    End If
    rst.Close
    Set dbs = Nothing
End Sub


SetFocus-Methode - Beispiel

Das folgende Beispiel verwendet die Methode SetFocus, um den Fokus auf das Textfeld Personal-Nr im Formular Personal zu setzen.

Formulare!Personal!Personal-Nr.SetFocus


SetPermissions-Methode

Die SetPermissions-Methode verwendet in Microsoft Access die folgenden Parameter.

Objekt | Objekttyp | Objekttyp-Nr
Forms | adPermObjProviderSpecific | {c49c842e-9dcb-11d1-9f0a-00c04fc2c2e0}
Reports | adPermObjProviderSpecific | {c49c8430-9dcb-11d1-9f0a-00c04fc2c2e0}
DataPages** | n/v | n/v
Macros | adPermObjProviderSpecific | {c49c842f-9dcb-11d1-9f0a-00c04fc2c2e0}
Modules * | adPermObjProviderSpecific | {c49c8432-9dcb-11d1-9f0a-00c04fc2c2e0}
Table | adPermObjTable | n/v
View | adPermObjView | n/v
Procedure | adPermObjProcedure | n/v

**Sicherheit wird bei DataPages nicht unterstützt

*Sicherheit bei Modulen steht nur für Microsoft Access-Versionen vor Access 2000 und nur bei Verwendung mit dem neuesten Jet-Provider zur Verfügung.


SetPermissions-Methode - Beispiel

Das folgende Beispiel zeigt, wie die Berechtigungen für ein Microsoft Access-Formular eingestellt werden.

Anmerkung SetPermissions wird in Access-Projekten (.ADP) bei der im Lieferumfang von Microsoft Access 2000 enthaltenen Version des SQL-Providers nicht unterstützt.


SizeToFit-Methode - Beispiel

Das folgende Beispiel erstellt ein neues Formular sowie eine neue Befehlsschaltfläche auf dem Formular. Die Prozedur stellt anschließend die Eigenschaft Caption des Steuerelements ein und passt die Größe des Steuerelements an die Beschriftung an.

Sub GrößeEinesNeuenSteuerelementsAnpassen()
    Dim frm As Form, ctl As Control

    ' Ein neues Formular erstellen.
    Set frm = CreateForm
    ' Eine neue Befehlsschaltfläche erstellen.
    Set ctl = CreateControl(frm.Name, _
        acCommandButton, , , , 500, 500)
    ' Die Anzeige des Formulars aktualisieren.
    DoCmd.Restore
    ' Die Eigenschaft Caption des Steuerelements einstellen.
    ctl.Caption = "Extrem lange Beschriftung für Steuerelement"
    ' Die Größe des Steuerelements an die Beschriftung anpassen.
    ctl.SizeToFit
End Sub


SysCmd-Methode - Beispiel

Das folgende Beispiel erstellt ein Recordset-Objekt vom Typ Snapshot, liest jeden Datensatz und zeigt einen Statusanzeiger an, der die aktuelle relative Position im Snapshot mitteilt.

Function DatensätzeLesen(strTabellenname As String) As Integer
    Const conBadArgs = -1
    Dim dbs As Database, rst As Recordset
    Dim lngAnzahl As Long, strMldg As String
    Dim varRückgabe As Variant, lngX As Long

    DatensätzeLesen = 0
    If strTabellenname <> "" Then
        DoCmd.Hourglass True
        Set dbs = CurrentDb
        On Error Resume Next
        Set rst = dbs.OpenRecordSet(strTabellenname)
        ' Anzahl der Datensätze abrufen.
        rst.MoveLast
        rst.MoveFirst
        If Err Then
            DatensätzeLesen = conBadArgs
        End If
        lngAnzahl = rst.RecordCount
        On Error GoTo 0
        If lngAnzahl Then
            strMldg = "Lese " & UCase$(strTabellenname) & "..."
            varRückgabe = SysCmd(acSysCmdInitMeter, strMldg, lngAnzahl)
            ' Meldung in Statusleiste anzeigen.
            For lngX = 1 To lngAnzahl
                varRückgabe = SysCmd(acSysCmdUpdateMeter, lngX)
            ' Statusanzeiger aktualisieren.
                .                           ' Aktion mit Datensatz ausführen.
                .
                .
                rst.MoveNext                ' Zum nächsten Datensatz gehen.
            Next lngX
            varRückgabe = SysCmd(acSysCmdClearStatus)
            GoSub CloseObjects
            DatensätzeLesen = lngAnzahl     ' Anzahl der Datensätze zurückgeben.
            Exit Function
        End If
    End If
    ' Nicht gefunden oder enthält keine Datensätze.
    strMldg = "Tabelle '" & strTabellenname & "'nicht gefunden oder " _
                & "enthält keine Datensätze.'"
    MsgBox strMldg, vbInformation, "DatensätzeLesen"
    GoSub CloseObjects
    Exit Function
CloseObjects:
    On Error Resume Next
    rst.Close
    dbs.Close
    On Error GoTo 0
    DoCmd.Hourglass False
    Return
End Function

Das nächste Beispiel zeigt, wie Sie mit Hilfe der Methode SysCmd mit der Aktion acSysCmdGetObjectState den Status des aktiven Datenbankobjekts ermitteln können.

Dim intObjType As Integer, strObjName As String, intObjState As Integer

intObjType = Application.CurrentObjectType
strObjName = Application.CurrentObjectName
intObjState = SysCmd(acSysCmdGetObjectState, intObjType, strObjName)
If intObjState <> 0 Then
    .
    .
    .
End If


TextHeight-, TextWidth-Methoden - Beispiel

Das folgende Beispiel verwendet die Methoden TextHeight und TextWidth, um die Höhe und die Breite des Bereichs zu ermitteln, der zum Drucken einer Textzeichenfolge in der aktuellen Schriftart des Berichts benötigt wird.

Damit Sie dieses Beispiel in Microsoft Access testen können, erstellen Sie einen neuen Bericht. Stellen Sie die Eigenschaft OnPrint des Detailbereichs auf [Ereignisprozedur] ein. Geben Sie den folgenden Code in das Modul des Berichts ein, und wechseln Sie dann zur Seitenansicht.

Private Sub Detail_Print(Cancel As Integer, _
    PrintCount As Integer)
    ' Maßeinheit auf Twips einstellen (Standardskalierung).
    Me.Scalemode = 1
    ' Name und Schriftgrad der Berichtsschriftart ausgeben.
    Debug.Print "Berichtsschriftart: "; Me.FontName
    Debug.Print "Berichtsschriftgrad: "; Me.FontSize
    ' Für die Textzeichenfolge benötigte Höhe und Breite ausgeben.
    Debug.Print "Texthöhe (Twips): "; _
        Me.TextHeight("Produktbericht")
    Debug.Print "Textbreite (Twips): "; _
        Me.TextWidth("Produktbericht")
End Sub


 TransferText-Aktion/-Methode

TransferText-Aktion/-Methode

Sprachspezifische Informationen

When Microsoft Access is enabled for right-to-left functionality, it provides an additional argument for the TransferText method and action. The Code Page argument has been added to the to the text file description.

TransferText method and action has the following additional argument.

Added Arguments | Description
Code Page | The name of the code page to import from, export to, or link to. You can select one of the code page names from the drop-down list.

Syntax

DoCmd.TransferText ([TransferType], [SpecificationName], [TableName], [FileName], [HasFieldNames], [HTMLTableName], [CodePage])

Argument | Description
codepage | Enter the numeric value associated with the desired code page. You can view the supported values in the Code page list box of the TransferText macro action.


Undo-Methode - Beispiel

Das folgende Beispiel zeigt, wie Sie die Methode Undo innerhalb der Change-Ereignisprozedur eines Steuerelements verwenden können, um das Feld Nachname auf den Originalwert zurückzusetzen, nachdem es geändert wurde.

Private Sub Nachname_Change()
    Me!Nachname.Undo
End Sub

Im nächsten Beispiel wird die Methode Undo verwendet, um alle in einem Formular vorgenommenen Änderungen zurückzusetzen, bevor das Formular aktualisiert wird.

Private Sub Form_BeforeUpdate(Cancel As Integer)
    Me.Undo
End Sub


 UpdateBatch-Methode

UpdateBatch-Methode

Mit Hilfe der UpdateBatch-Methode einer ADO-Datensatzgruppe können mehrere Datensatzgruppenaktualisierungen in einem einzigen Aufruf an den Server gesendet und damit die Verarbeitungszeiten für einige dieser Aktualisierungen wesentlich verkürzt werden. Dies trifft jedoch nicht bei Jet-Datenbanken zu. Wenn die UpdateBatch-Methode bei einer Jet-Datenbank (.MDB) verwendet wird, verarbeitet Jet jede Anweisung weiterhin einzeln. Deshalb hat der Einsatz der UpdateBatch-Methode normalerweise eine entgegengesetzte nachteilige Wirkung, da die Verarbeitungszeiten tatsächlich um mehr als 100% verlängert werden.


UseDefaultFolderSuffix-Methode: Beispiel

Dieses Beispiel legt das Standardsuffix als Ordnersuffix für die Datenzugriffsseite ("Lagerbestand") fest.

DataAccessPages("Lagerbestand").WebOptions.UseDefaultFolderSuffix


AccessObjectProperty-Objekt (AccessObjectProperties-Auflistung): Beispiel

Diese Beispiel illustriert, wie Sie ein Formular um benutzerdefinierte Eigenschaften unter Verwendung der AccessObjectProperties-Auflistung und der Add-Methode erweitern können.

Sub BenutzerdefinierteEigenschaftHinzufügen(strFormularname As String, _
                                  strEigenschaftsname As String, _
                                  varEigenschaftswert As Variant)
    ' Benutzerdefinierte Eigenschaften der "AccessObjectProperties"-
    ' Auflistung hinzufügen, die mit einem "AccessObject"-Objekt verknüpft ist.

    With CurrentProject.AllForms(strFormularname).Properties
        .Add strEigenschaftsname, varEigenschaftswert
    End With
End Sub


Application-Objekt - Beispiel

Das folgende Beispiel gibt einige aktuelle Eigenschafteneinstellungen des Objekts Application aus, stellt eine Option ein und beendet anschließend die Anwendung, wobei alle Objekte gespeichert werden.

Sub AnwendungsInformation()
    ' Name und Typ des aktuellen Objekts ausgeben.
    Debug.Print Application.CurrentObjectName
    Debug.Print Application.CurrentObjectType
    ' Option "Ausgeblendete Objekte anzeigen" unter "Anzeigen"
    ' auf Registerkarte "Ansicht" einstellen.
    Application.SetOption "Ausgeblendete Objekte anzeigen", True
    ' Microsoft Access beenden, alle Objekte speichern.
    Application.Quit acSaveYes
End Sub

Das nächste Beispiel zeigt, wie Sie Microsoft Access als COM-Komponente verwenden können. Erstellen Sie in Microsoft Excel, Visual Basic oder einer anderen Anwendung, die als COM-Komponente fungiert, einen Verweis auf Microsoft Access, indem Sie im Modulfenster im Menü Extras auf Verweise klicken. Aktivieren Sie das Kontrollkästchen neben Microsoft Access 9.0-Objektbibliothek. Geben Sie dann den folgenden Code in ein Visual Basic-Modul innerhalb dieser Anwendung ein, und rufen Sie die Prozedur GetAccessData auf.

Das folgende Beispiel übergibt einen Datenbanknamen und einen Berichtsnamen an eine Prozedur, die eine neue Instanz der Klasse Application erstellt, öffnet die Datenbank und gibt den angegebenen Bericht aus.

' Objektvariable im Deklarationsbereich des Moduls deklarieren.
    Dim appAccess As Access.Application

Sub AccessDatenHolen()
    Dim strDB As String
    Dim strBerichtName As String

    ' Zeichenfolge für den Datenbankpfad initialisieren.
    strDB = "C:\Program Files\Microsoft Office\Office\Samples\Nordwind.mdb"
    ' Zeichenfolge für den Berichtsnamen initialisieren.
    strBerichtName = "Katalog"
    PrintAccessBericht strDB, strBerichtName
End Sub

Sub PrintAccessBericht(strDB As String, _
     strBerichtName As String)
    ' Bezug auf Microsoft Access Application-Objekt
    ' zurückgeben.
    Set appAccess = New Access.Application
    ' Datenbank in Microsoft Access öffnen.
    appAccess.OpenCurrentDatabase strDB
    ' Bericht ausgeben.
    appAccess.DoCmd.OpenReport strBerichtName
    MsgBox "Klicken Sie auf OK, sobald" & strBerichtName & _
        " vollständig ausgegeben ist."
    appAccess.CloseCurrentDatabase
    Set appAccess = Nothing
End Sub


 CodeProject-Objekt

CodeProject-Objekt

Das CodeProject-Objekt verweist auf das Projekt zur Verwaltung der Codedatenbank eines Microsoft Access-Projekts (.adp) oder einer Access-Datenbank (.mdb).

Anmerkung

Das CodeProject-Objekt besitzt mehrere Auflistungen, die bestimmte AccessObject-Objekte innerhalb der Codedatenbank enthalten. Die folgende Tabelle listet die Namen aller Auflistungen, die durch ein Access-Projekt definiert sind, sowie die Typen der jeweils enthaltenen Objekte auf.

Auflistungen | Objekttyp
AllForms | Alle Formulare
AllReports | Alle Berichte
AllMacros | Alle Makros
AllModules | Alle Module
AllDataAccessPages | Alle Datenzugriffsseiten

Anmerkung Die Auflistungen der vorhergehenden Tabelle enthalten alle diesbezüglichen Objekte in der Datenbank und zwar unabhängig davon, ob sie geöffnet sind oder nicht.

So ist beispielsweise ein AccessObject-Objekt, das ein Formular repräsentiert, ein Element der AllForms-Auflistung, einer Auflistung von AccessObject-Objekten innerhalb der aktuellen Datenbank. Einzelne Formulare innerhalb der AllForms-Auflistung werden mit Null beginnend indiziert. Sie können auf ein einzelnes AccessObject-Objekt in der AllForms-Auflistung zugreifen, indem Sie entweder den Namen des Formulars oder den Index des Objekts innerhalb der Auflistung angeben. Wenn Sie auf ein bestimmtes Element der AllForms-Auflistung bezugnehmen möchten, ist die Namensreferenz vorzuziehen, da sich der Index des Elements ändern kann. Wenn der Objektnamen ein Leerzeichen enthält, muss der Name in eckige Klammern ([ ]) gesetzt werden.

Syntax | Beispiel
AllForms!Formularname | AllFormulare!Bestellformular
AllFormulare![Formularname] | AllFormulare![Formular Bestellungen]
AllForms("Formularname") | AllForms("Bestellformular")
AllForms(Index) | AllForms(0)


 Collection-Objekt

Collection-Objekt

In Microsoft Access kann ein Collection-Objekt aus einer Gruppe von Objekten beliebigen Typs bestehen. Sie können ein Collection-Objekt erstellen, das aus mehreren Objekten des gleichen Typs oder aus Objekten unterschiedlicher Typen besteht.

Die durch ein Collection-Objekt definierte Auflistung kann eine beliebige Kombination von Microsoft Access-Objekten, Datenzugriffsobjekten und Objekten von einer beliebigen anderen Anwendung enthalten, die ihre Objekte Microsoft Access zur Verfügung stellt. Sie können auch ein Collection-Objekt einer Auflistung hinzufügen, die durch ein Collection-Objekt definiert wird.

Die Auflistung kann auch benutzerdefinierte Objekte enthalten, die Sie in Microsoft Access erstellen. Sie können z.B. benutzerdefinierte Objekte mit benutzerdefinierten Methoden und Eigenschaften aus einem Formularmodul oder Berichtsmodul erstellen. Sie können dann diese Objekte einer durch ein Collection-Objekt definierten Auflistung hinzufügen und sie als Gruppe bearbeiten.


CommandBarControls-Auflistungsobjekt

Obwohl die meisten Microsoft Access-Auflistungen auf 0 basieren, basieren alle Befehlsleistenauflistungen auf 1. Beachten Sie jedoch, dass Sie die Syntax For Each...Next verwenden können, um die Objekte in einer Auflistung zu durchlaufen, ohne die speziellen Indexnummern zu berücksichtigen.


CommandBars-Auflistungsobjekt

Obwohl die meisten Microsoft Access-Auflistungen auf 0 basieren, basieren alle Befehlsleistenauflistungen auf 1. Beachten Sie jedoch, dass Sie die Syntax For Each...Next verwenden können, um die Objekte in einer Auflistung zu durchlaufen, ohne die speziellen Indexnummern zu berücksichtigen.


Connection-Objekt, Connections-Auflistung

Beim Arbeiten mit ActiveX Data-Objekten (ADO) in Microsoft Access benötigen Sie oft eine Objektvariable vom Typ Connection, die die Verbindung zum aktuellen Datenbank-Provider darstellt. Mit Hilfe der Connection-Eigenschaft des CurrentProject-Objekts können Sie ein Connection-Objekt für die zur Zeit bearbeitete Datenbank zurückgeben. Dieses Connection-Objekt wird automatisch an die Connections-Auflistung angefügt.

Angenommen, Sie arbeiten momentan mit der Beispieldatenbank Nordwind in Microsoft Access. Sie können ein Connection-Objekt erstellen, das eine Verknüpfung zum Provider für diese Datenbank herstellt. Zu diesem Zweck deklarieren Sie zunächst eine Objektvariable vom Typ Connection und verweisen diese dann auf das Connection-Objekt, das von der Connection-Eigenschaft des CurrentProject-Objekts zurückgegeben wird.

Dim cnn As ADODB.Connection
Set cnn = CurrentProject.Connection

Sie brauchen nicht den Namen des Providers zu kennen, um die aktuelle Datenbank verwenden zu können. Wenn Sie den Namen des aktuellen Providers erfahren möchten, überprüfen Sie die ConnectionString-Eigenschaft des Connection-Objekts, die den Providernamen und den Pfad zur Datenbank enthält. Um die Position des Connection-Objekts in der Connections-Auflistung zu ermitteln, durchlaufen Sie die Auflistung.

In Visual Basic-Code können Sie mehrere unabhängige Objektvariablen vom Typ Connection erstellen, um Verbindungen zu mehreren Datenbanken darzustellen. Auf diese Weise können Sie mehrere Datenbanken gleichzeitig mit Code bearbeiten. Außerdem ist es möglich, mehrere Objektvariablen vom Typ Connection zu erstellen und diese auf die aktuelle Datenbank zu verweisen.

Anmerkung Jeder Verweis auf die Connection-Eigenschaft gibt ein neues Connection-Objekt zurück, das auf die aktive Verbindung verweist. Wenn Sie mehrere Vorgänge, wie z.B. Transaktionen, für diese Verbindung durchführen möchten, müssen Sie das Connection-Objekt einer Variablen wie oben beschrieben zuweisen.


 Container-Objekt, Containers-Auflistung (MDB)

Container-Objekt, Containers-Auflistung (MDB)

Neben den durch die Microsoft Jet-Datenbank-Engine definierten Container-Objekten werden die folgenden fünf Container-Objekte durch Microsoft Access definiert.

Containername | Enthält Informationen über
Forms | Gespeicherte Formulare
Modules | Gespeicherte Module
Reports | Gespeicherte Berichte
DataAccessPages | Gespeicherte Datenzugriffsseiten
Scripts | Gespeicherte Makros

Bei den durch Microsoft Access definierten Container-Objekte handelt es sich um Microsoft Access-Datenbankobjekte und nicht um Datenzugriffsobjekte (Data Access Objects, DAO). Diese Container-Objekte liefern der Jet-Datenbank-Engine Informationen zu Microsoft Access-Objekten. Die Jet-Datenbank-Engine verwendet diese Informationen, um Zugriffsrechte für Microsoft Access-Datenbankobjekte genauso wie für DAO-Objekte zu implementieren.

Die durch Microsoft Access definierten Container-Objekte und die durch die Jet-Datenbank-Engine definierten Container-Objekte sind alle in der Containers-Auflistung in Microsoft Access enthalten.

Die Documents-Auflistung eines Container-Objekts enthält Document-Objekte, die für die einzelnen Objekte des Typs stehen, der durch das Container-Objekt beschrieben wird. So besitzt z.B. das Container-Objekt Forms eine Documents-Auflistung, die ein Document-Objekt entsprechend einem Formular namens Bestellungen enthalten kann.

Mit Ausnahme von Modules können Sie Container-Objekte verwenden, um Berechtigungen für Microsoft Access-Datenbankobjekte einzurichten und zu erzwingen. Zum Einrichten von Berechtigungen für ein Container-Objekt stellen Sie die UserName-Eigenschaft des Container-Objekts auf den Namen eines vorhandenen User- oder Group-Objekts ein. Anschließend stellen Sie die Permissions-Eigenschaft für das Container-Objekt ein.

Anmerkung Verwechseln Sie nicht die einzelnen Typen der Container-Objekte mit den gleichnamigen Auflistungstypen. Die Container-Objekte Forms und Reports enthalten jeweils Documents-Auflistungen. Diese wiederum enthalten einzelne Document-Objekte, die jedes gespeicherte Formular bzw. jeden gespeicherten Bericht darstellen. Die Forms- und die Reports-Auflistung dagegen verweisen nur auf geöffnete Formulare bzw. Berichte.

Aus Gründen der Abwärtskompatibilität ist der Modules-Container in Microsoft Access 2000 weiterhin vorhanden. Da die Sicherheit für Module jetzt jedoch durch das Feature "Schutz" in der Visual Basic-Umgebung gehandhabt wird, werden Berechtigungen und benutzerbezogene Eigenschaften für einzelne Module nicht mehr unterstützt.


Container-Objekt, Containers-Auflistung - Beispiel

Das folgende Beispiel gewährt Programmierern vollen Zugriff auf sämtliche Module einer Datenbank und allen anderen Benutzern den schreibgeschützten Zugriff auf Module:

Sub ModulberechtigungenEinstellen()
    Dim dbs As Database, wsp As Workspace, ctr As Container
    Dim grp As Group

    ' Bezug auf Standard-Arbeitsbereich zurückgeben.
    Set wsp = DBEngine.Workspaces(0)
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Modules-Container zurückgeben.
    Set ctr = dbs.Containers!Modules
    wsp.Groups.Refresh
    For Each grp In wsp.Groups
        ctr.UserName = grp.Name
        If ctr.UserName = "Programmierer" Then
            ctr.Permissions = ctr.Permissions Or dbSecFullAccess
        Else
            ctr.Permissions = ctr.Permissions Or acSecModReadDef
        End If
    Next grp
    Set dbs = Nothing
End Sub


Control-Objekt, Controls-Auflistung (Steuerelemente) - Beispiel

Das folgende Beispiel durchläuft alle Steuerelemente in der Auflistung Controls eines Formulars. Die Prozedur wird von einem Formularmodul aufgerufen. Das Objekt Form wird mit dem Schlüsselwort Me an die Prozedur übergeben. Die Prozedur stellt bestimmte Eigenschaften ein, falls das Steuerelement ein Textfeld ist.

' Prozedur TextfeldEigenschaftenEinstellen aufrufen.
TextfeldEigenschaftenEinstellen Me

Sub TextfeldEigenschaftenEinstellen(frm As Form)
    Dim ctl As Control

    ' Controls-Auflistung durchlaufen.
    For Each ctl In frm.Controls
        ' Prüfen, ob das Steuerelement ein Textfeld ist.
        If ctl.ControlType = acTextBox Then
            ' Eigenschaften des Steuerelements einstellen.
            With ctl
                .SetFocus
                .Enabled = True
                .Height = 400
                .SpecialEffect = 0
            End With
        End If
    Next ctl
End Sub


Erstellen eines Schlüssels - Beispiel

Das folgende Beispiel erstellt ein neues Key-Objekt, das eine Beziehung zwischen der Tabelle Kategorien und der Tabelle Artikel definiert. Die Tabelle Kategorien ist die Primärtabelle in der Beziehung und die Tabelle Artikel die Fremdtabelle. Das Feld Kategorie-Nr ist der Primärschlüssel der Tabelle Kategorien und ein Fremdschlüssel der Tabelle Artikel.

Um dieses Beispiel in der Beispieldatenbank Nordwind zu testen, klicken Sie im Menü Extras auf Beziehungen, und löschen Sie die Beziehung zwischen der Tabelle Kategorien und der Tabelle Artikel. Schließen Sie das Fenster Beziehungen, und speichern Sie die aktuelle Konfiguration bei der entsprechenden Eingabeaufforderung. Führen Sie die unten angegebene Prozedur aus. Zeigen Sie dann das Fenster Beziehungen erneut an, um sich die neue Beziehung anzusehen.

Anmerkung Zur Zeit wird das Erstellen von Fremdschlüsseln in ADPs bei der im Lieferumfang von Microsoft Access 2000 enthaltenen Version des SQL-Providers nicht unterstützt. Um dieses Beispiel verwenden zu können, muss ein Verweis auf "Microsoft ADO Ext. 2.1 for DDL and Security" eingerichtet werden.

Sub FremdschlüsselErstellen()
   Sub SchlüsselErstellen()
    Dim Bezg As New ADOX.Key
    Dim cat As New ADOX.Catalog
    cat.ActiveConnection = CurrentProject.Connection

    With Bezg
        .Name = "KatArt"
        .Type = adKeyForeign
        .RelatedTable = "Kategorien"
        .Columns.Append "Kategorie-Nr"
        .Columns("Kategorie-Nr").RelatedColumn = "Kategorie-Nr"
    End With
    cat.Tables("Artikel").Keys.Append Bezg
End Sub


CurrentProject-Objekt: Beispiel

Das folgende Beispiel druckt die aktuellen Werte einiger Eigenschaften des CurrentProject-Objekts und aktiviert anschließend eine Option zur Anzeige der ausgeblendeten Objekte der Anwendung:

Sub AnwendungsInfo()
    ' Name und Typ des aktuellen Objekts ausgeben.
    Debug.Print Application.CurrentProject.FullName
    Debug.Print Application.CurrentProject.ProjectType
    ' Option "Ausgeblendete Objekte anzeigen"
    ' der Registerkarte "Ansicht" aktivieren.
    Application.SetOption "Show Hidden Objects", True
End Sub

Im folgenden Beispiel wird gezeigt, wie Sie mit Hilfe von Automatisierung das CurrentProject-Objekt von einer anderen Microsoft Office-Anwendung aus verwenden können. Zunächst erzeugen Sie einen Verweis von der anderen Anwendung zu Microsoft Access, indem Sie im Modulfenster im Menü Extras auf Verweise klicken und das Kontrollkästchen neben Microsoft Access 9.0 Object Library aktivieren. Geben Sie dann den folgenden Code in einem Visual Basic-Modul innerhalb der anderen Anwendung ein und rufen Sie die HoleAccessDaten-Prozedur auf.

Das Beispiel übergibt einen Datenbanknamen und einen Berichtsnamen an eine Prozedur, die mit diesen Informationen eine neue Instanz der Application-Klasse erzeugt, die Datenbank öffnet und unter Verwendung des CurrentProject-Objekts und der AllReports-Auflistung das Vorhandensein des angegebenen Berichts überprüft.

Sub HoleAccessDaten()
' Deklarieren einer Objektvariablen im Deklarationsbereich eines Moduls
    Dim AnwAccess As Access.Application
    Dim strDB As String
    Dim strBerichtsName As String

    strDB = "C:\Programme\Microsoft "_
        & "Office\Office\Samples\Nordwind.mdb"
    strBerichtsName = InputBox("Geben Sie den Namen des zu prüfenden Berichts ein", _
        "Berichtsprüfung")
    PrüfeAccessBericht strDB, strBerichtsName
End Sub

Sub PrüfeAccessBericht(strDB As String, _
     strBerichtsName As String)
    ' Referenz auf das Microsoft Access Application-Object
    ' zurückgeben.
    Set AnwAccess = New Access.Application
    ' Datenbank in Microsoft Access öffnen.
    AnwAccess.OpenCurrentDatabase strDB
    ' Auf Vorhandensein des Berichts prüfen.
    On Error Goto ErrorHandler
    AnwAccess.CurrentProject.AllReports(strBerichtsName)
    MsgBox "Bericht " & strBerichtsName & _
        " ist in der Datenbank Nordwind vorhanden."
    AnwAccess.CloseCurrentDatabase
    Set AnwAccess = Nothing
Exit Sub
ErrorHandler:
    MsgBox "Bericht " & strBerichtsName & _
        " ist in der Datenbank Nordwind nicht vorhanden."
    AnwAccess.CloseCurrentDatabase
    Set AnwAccess = Nothing
End Sub


 DataAccessPage-Objekt

DataAccessPage-Objekt

Ein DataAccessPage-Objekt verweist auf eine bestimmte Microsoft Access Datenzugriffsseite.

Anmerkung

Ein DataAccessPage-Objekt ist ein Element der DataAccessPages-Auflistung, die eine Auflistung aller aktuell geöffneten Datenzugriffsseiten darstellt. Innerhalb der DataAccessPages-Auflistung werden einzelne Datenzugriffsseiten mit Null beginnend indiziert. Sie können auf ein einzelnes DataAccessPage-Objekt der DataAccessPages-Auflistung zugreifen, indem Sie entweder den Namen der Datenzugriffsseite oder den Index des Objekts innerhalb der Auflistung angeben. Wenn Sie auf eine bestimmte Datenzugriffsseite der DataAccessPages-Auflistung bezugnehmen möchten, ist die Namensreferenz vorzuziehen, da sich der Index der Seitenauflistung ändern kann. Wenn der Objektname ein Leerzeichen enthält, muss der Name in eckige Klammern ([ ]) gesetzt werden.

Syntax | Beispiel
DataAccessPages!Seitenname | DataAccessPages!Umsatzseite
DataAccessPages![Seitenname] | DataAccessPages![Seite Umsätze]
DataAccessPages("Seitenname") | DataAccessPages("Umsatzseite")
DataAccessPages(Index) | DataAccessPages(0)


DataAccessPage-Objekt (DataAccessPages-Auflistung): Beispiel

Das folgende Beispiel erstellt eine neue Datenzugriffsseite und belegte bestimmte Eigenschaften mit Werten:

Sub NeueDatenzugriffsseite()
    Dim dap As DataAccessPage
    ' Neue Datenzugriffsseite erstellen.
    Set dap = CreateDataAccessPage("C:\Eigene Dateien\Umsätze eingeben", _
            True)
    ' Tag-Eigenschaft der Datenzugriffsseite definieren.
    dap.Tag = "Datenzugriffsseite für die Eingabe von Umsätzen"
    ' Datenzugriffsseite wiederherstellen.
    DoCmd.Restore
End Sub

Das nächste Beispiel zählt die DataAccessPages-Auflistung auf und druckt die Namen aller in der DataAccessPages-Auflistung enthaltenen Datenzugriffsseiten aus.

Sub ListeAllerGeöffnetenDatenzugriffsseiten()
    Dim dap As DataAccessPage

    Set dbs = Application.CurrentProject
    ' Suche nach geöffneten Objekten in der "DataAccessPages"-Auflistung.
    For Each dap In dbs.AllDataAccessPages
        If dap.IsLoaded = TRUE then
            ' Seitennamen ausgeben.
            Debug.Print dap.Name
        End If
    Next dap
End Sub


 Database-Objekt, Databases-Auflistung (MDB)

Database-Objekt, Databases-Auflistung (MDB)

Wenn Sie mit Datenzugriffsobjekten von Microsoft Access arbeiten, benötigen Sie oftmals eine Database-Objektvariable, die die aktuelle Datenbank darstellt. Verwenden Sie die Funktion CurrentDb, um ein Database-Objekt für die aktuell geöffnete Datenbank zurückzugeben. Dieses Database-Objekt wird automatisch an die Databases-Auflistung angefügt.

Nehmen Sie z. B. an, dass Sie momentan mit der Beispieldatenbank Nordwind in Microsoft Access arbeiten. Sie können ein Database-Objekt erstellen, das auf diese Datenbank verweist, indem Sie zunächst eine Database-Objektvariable deklarieren und dieser dann das von der Funktion CurrentDb zurückgegebene Database-Objekt zuweisen.

Dim dbs As Database
Set dbs = CurrentDb

Sie müssen den Namen der Datenbank oder dessen Position in der Databases-Auflistung nicht kennen, um die aktuelle Datenbank verwenden zu können. Wenn Sie den Namen der aktuellen Datenbank ermitteln möchten, überprüfen Sie die Eigenschaft Name des Database-Objekts, die den Pfad und die Dateinamen der Datenbank enthält. Durchlaufen Sie alle Elemente der Auflistung, um die entsprechende Position in der Databases-Auflistung zu ermitteln.

Sie können nur jeweils eine Datenbank im Microsoft Access-Fenster öffnen. Allerdings können Sie mit Visual Basic-Code mehrere voneinander unabhängige Database-Objektvariablen erstellen, die mehrere geöffnete Datenbanken darstellen. Auf diese Weise können Sie mehrere Datenbanken gleichzeitig mit dem Code bearbeiten. Sie können auch mehrere Database-Objektvariablen erstellen und damit auf die aktuelle Datenbank verweisen.

Anmerkung Verwenden Sie in Ihrem Visual Basic-Code die Funktion CurrentDb, um ein Database-Objekt zurückzugeben, das auf die aktuelle Datenbank verweist, anstatt die Syntax DBEngine(0)(0) einzusetzen. Die CurrentDb-Funktion erstellt eine weitere Instanz der aktuellen Datenbank, während die Syntax DBEngine(0)(0) auf die geöffnete Kopie der aktuellen Datenbank verweist. Mit der Funktion CurrentDb können Sie mehrere Variablen vom Typ Database erstellen, die auf die aktuelle Datenbank verweisen. Die Syntax DBEngine(0)(0) wird zwar von Microsoft Access noch unterstützt, allerdings sollten Sie Ihren Code entsprechend anpassen, um möglichen Konflikten in einer Mehrbenutzerumgebung vorzubeugen.


Database-Objekt, Databases-Auflistung - Beispiel (MDB)

Das folgende Beispiel zeigt drei Möglichkeiten, wie ein Database-Objekt in Microsoft Access zurückgegeben werden kann. Die Prozedur gibt ein Database-Objekt zurück, das die aktuelle im Microsoft Access-Fenster geöffnete Datenbank repräsentiert. Anschließend erstellt die Prozedur eine andere Datenbank mit dem Namen NEUEDB.MDB und speichert diese auf der Festplatte. Dann öffnet die Prozedur eine bestehende Datenbank mit dem Namen ANDERE.MDB. Schließlich durchläuft die Prozedur alle Database-Objekte in der Databases-Auflistung.

Sub Datenbankverweise()
    Dim wsp As Workspace
    Dim dbsAktuelle As Database, dbsNeue As Database
    Dim dbsAndere As Database, dbs As Database

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbsAktuelle = CurrentDb
    ' Bezug auf Standard-Arbeistbereich zurückgeben.
    Set wsp = DBEngine.Workspaces(0)
    ' Neues Database-Objekt erstellen.
    Set dbsNeue = wsp.CreateDatabase("NEUEDB.MDB", dbLangGeneral)
    ' Eine andere (nicht die aktuelle) Datenbank
    ' öffnen.
    set dbsAndere = wsp.OpenDatabase("ANDERE.MDB")
    ' Alle geöffneten Datenbanken durchlaufen.
    For Each dbs in wsp.Databases
        Debug.Print dbs.Name
    Next dbs
    For Each dbs In wsp.Databases
        Set dbs = Nothing
    Next dbs
    Set wsp = Nothing
End Sub


 DBEngine-Objekt (MDB)

DBEngine-Objekt (MDB)

Microsoft Access bietet die Möglichkeit, Datenzugriffsobjekte (DAO) aus anderen Anwendungen mit Hilfe der Automatisierung (früher als "OLE-Automatisierung" bezeichnet) zu verändern. Wenn Sie Microsoft Access aus einer anderen Anwendung (etwa Visual Basic oder Microsoft Excel) heraus steuern, können Sie die Eigenschaft DBEngine des Microsoft Access-Objekts Application verwenden, um einen Verweis an das Objekt DBEngine zurückzugeben. Anschließend kann mit dem Objekt DBEngine auf alle DAO-Objekte und Auflistungen zugegriffen werden.


DBEngine-Objekt - Beispiel (MDB)

Das folgende Beispiel gibt alle Eigenschaften des DBEngine-Objekts aus:

Sub EngineEigenschaften()
    Dim prp As Property

    For Each prp In DBEngine.Properties
        Debug.Print prp.Name
    Next prp
End Sub


DefaultWebOptions-Objekt: Beispiel

Das folgende Beispiel prüft bei der Anzeige einer gespeicherten Datenzugriffsseite, ob Microsoft Office Web Components übertragen wurden, und setzt dementsprechend den Wert einer Kennzeichnung.

Set objAnwendungsWebOptionen = Application.DefaultWebOptions
With objAnwendungsWebOptionen
    If .DownloadComponents = True Then
        strKomponentenDownload = "Geladen"
    Else
        strKomponentenDownload = "Nicht geladen"
    End If
End With


DoCmd-Objekt - Beispiel

Das folgende Beispiel öffnet ein Formular in der Formularansicht und wechselt zu einem neuen Datensatz.

Sub AnzeigenNeuerDatensatz()
    DoCmd.OpenForm "Personal", acNormal
    DoCmd.GoToRecord , , acNewRec
End Sub


 Document-Objekt, Documents-Auflistung

Document-Objekt, Documents-Auflistung

Zusätzlich zu den Document-Objekten, die von der Microsoft Jet-Datenbank-Engine definiert wurden, werden die folgenden Document-Objekte von Microsoft Access definiert.

Document-Objekt | Container | Enthält Informationen über
Form (Formular) | Forms | das gespeicherte Formular
Macro (Makro) | Scripts | das gespeicherte Makro
Module (Modul) | Modules | das gespeicherte Modul
Report (Bericht) | Reports | den gespeicherten Bericht
DataAccessPage (Datenzugriffsseite) | DataAccessPages | die gespeicherte Datenzugriffsseite
SummaryInfo (Datei-Info) | Databases | die Zusammenfassung zu einem Datenbankdokument
UserDefined (Benutzerdefiniert) | Databases | benutzerdefinierte Eigenschaften

Die von Microsoft Access definierten Document-Objekte sind Microsoft Access-Datenbankobjekte und keine Datenzugriffsobjekte (DAO). Diese Document-Objekte liefern der Jet-Datenbank-Engine Informationen über Microsoft Access-Objekte. Die Jet-Datenbank-Engine verwendet diese Informationen, um Sicherheitsfunktionen für Microsoft Access-Datenbankobjekte zu implementieren (in der gleichen Weise wie auch für DAO-Objekte).

Die Documents-Auflistung eines Container-Objekts enthält Document-Objekte, die die einzelnen Objekte des Typs darstellen, der vom Container-Objekt beschrieben wird. Das Container-Objekt vom Typ Forms verfügt z. B. über eine Documents-Auflistung, die ein Document-Objekt enthalten kann, das einem Formular mit dem Namen Bestellungen entspricht.

Microsoft Access definiert zwei Document-Objekte im Container-Objekt für die Datenbanken: SummaryInfo und UserDefined.

Das Document-Objekt SummaryInfo erlaubt den programmgesteuerten Zugriff auf die Eigenschaften für die Dokumentzusammenfassung wie Title, Subject, Author, Keywords, Comments, Manager, Company, Category und Hyperlink Base. Sie können diese Eigenschaften auch in der Registerkarte Datei-Info des Dialogfelds Eigenschaften von Datenbank einstellen, das angezeigt wird, wenn Sie im Menü Datei auf Datenbankeigenschaften klicken.

Sie können diese Eigenschaften aus Visual Basic heraus nur einstellen, wenn Sie sie erstellen und an die Auflistung Properties des Document-Objekts SummaryInfo anfügen, sofern sie nicht bereits im Dialogfeld Eigenschaften von Datenbank eingestellt wurden. Nachdem eine Eigenschaft erstellt ist, müssen Sie explizit auf die Auflistung Properties verweisen, um sie einzustellen. Im folgenden Beispiel ist dok eine Objektvariable, die auf das Document-Objekt SummaryInfo verweist:

dok.Properties!Title = "Nordwind GmbH"

Weitere Informationen zur Erstellung und Einstellung von Eigenschaften, die durch Microsoft Access definiert werden, finden Sie im Hilfeindex unter "Property-Objekt" und "CreateProperty-Methode".

Das Document-Objekt UserDefined erlaubt den programmgesteuerten Zugriff auf die benutzerdefinierten Eigenschaften, die in der Registerkarte Anpassen des Dialogfelds Eigenschaften von Datenbank definiert sind. Sie können diese Eigenschaften auch in Visual Basic erstellen und an die Auflistung Properties des Document-Objekts UserDefined anfügen.

Anmerkung Verwechseln Sie die in der Auflistung Properties eines Database-Dokuments definierten Eigenschaften nicht mit den Eigenschaften, die in der Auflistung Properties eines Database-Objekts definiert sind. Sie können benutzerdefinierte Eigenschaften in beiden Properties-Auflistungen erstellen, aber nur diejenigen Eigenschaften, die für die Document-Objekte SummaryInfo oder UserDefined definiert sind, können im Dialogfeld Eigenschaften von Datenbank eingestellt werden.

Sie können Document-Objekte verwenden, um Berechtigungen für Microsoft Access-Datenbankobjekte einzurichten und durchzusetzen. Sie stellen Berechtigungen für ein Document-Objekt ein, indem Sie die Eigenschaft UserName des Objekts Document auf den Namen eines existierenden User- oder Group-Objekts und anschließend die Eigenschaft Permissions für das Document-Objekt einstellen.

Anmerkung Verwechseln Sie die einzelnen Typen von Container-Objekten nicht mit den gleichnamigen Auflistungstypen. Die Container-Objekte Forms und Reports enthalten jeweils Documents-Auflistungen, die wiederum die einzelnen Document-Objekte zur Darstellung aller gespeicherten Formulare oder Berichte enthalten. Die Auflistungen Forms und Reports beziehen sich nur auf geöffnete Formulare oder Berichte.


Document-Objekt, Documents-Auflistung - Beispiel (MDB)

Das folgende Beispiel gibt den Namen jedes Document-Objekts vom Typ Formular in der aktuellen Datenbank sowie das Datum der letzten Änderung aus.

Sub Dokumentänderungen()
    Dim dbs As Database, ctr As Container, doc As Document

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Forms-Container zurückgeben.
    Set ctr = dbs.Containers!Forms
    ' Elemente in Documents-Auflistung des Forms-
    ' Containers durchlaufen.
    For Each doc In ctr.Documents
    ' Namen des Document-Objekts und Wert der
    ' LastUpdated-Eigenschaft ausgeben.
        Debug.Print doc.Name; "    "; doc.LastUpdated
    Next doc
    Set dbs = Nothing
End Sub


Recordset-Objekt vom Typ "Dynaset" - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt vom Typ Dynaset und überprüft dann die Eigenschaft Updatable des Recordset-Objekts:

Sub AktuelleEinstellungen()
    Dim dbs As Database, rst As Recordset
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset für Tabelle "Personal" öffnen.
    Set rst = dbs.OpenRecordset("Personal", dbOpenDynaset)
    Debug.Print rst.Updatable
    rst.Close
    Set dbs = Nothing
End Sub


 Error-Objekt

Error-Objekt

Die Description-Eigenschaft eines Error-Objekts enthält die beschreibende Zeichenfolge, die einem bestimmten Fehler zugeordnet ist. Sie können die Description-Eigenschaft nur lesen, wenn der Fehler tatsächlich aufgetreten ist.

Zum Anzeigen der beschreibenden Zeichenfolge, die einem Fehler zugeordnet ist, wenn der Fehler nicht aufgetreten ist, verwenden Sie die Microsoft Access-Funktion AccessError. Die AccessError-Funktion verwendet eine Fehlernummer als Argument und gibt die entsprechende beschreibende Zeichenfolge zurück. Wenn Sie z.B. die beschreibende Zeichenfolge anzeigen möchten, die dem Fehler 3021 zugeordnet ist, verwenden Sie die AccessError-Funktion wie folgt:

Debug.Print AccessError(3021)

Microsoft Access gibt die beschreibende Zeichenfolge, die dem Fehler 3021 zugeordnet ist ("Kein aktueller Datensatz"), im Testfenster zurück.


Error-Objekt, Errors-Auflistung - Beispiel (MDB)

Das folgende Beispiel löst einen Fehler bei dem Versuch aus, ein Recordset-Objekt in der nicht bestehenden Tabelle Studenten zu öffnen. Die Fehlerinformationen sind sowohl im DAO-Objekt Error als auch im Visual Basic-Objekt Err gespeichert. Die Prozedur gibt den Wert der Eigenschaften Description, Source und Number des Error-Objekts und anschließend die Werte der entsprechenden Eigenschaften des Err-Objekts aus.

Beachten Sie, dass sich das letzte Error-Objekt in der Errors-Auflistung immer auf den gleichen Fehler beziehen muss wie das Err-Objekt. Das heißt, der Wert von Err.Number muss äquivalent zu Errors.Count - 1 sein. Wenn diese beiden Werte nicht übereinstimmen, sind die Informationen in der Errors-Auflistung möglicherweise nicht mehr aktuell. Verwenden Sie die Methode Refresh, um sicherzustellen, dass die Errors-Auflistung die aktuellsten Fehlerinformationen enthält.

Sub FehlerÜberprüfen()
    Dim dbs As Database, tdf As TableDef, rst As Recordset
    ' Objektvariable vom Typ Error für Durchlauf der
    ' Errors-Auflistung deklarieren.
    Dim errX As Error

    ' Fehler ignorieren.
    On Error Resume Next
    ' Fehler im Err-Objekt löschen.
    Err.Clear
    ' Errors-Auflistung aktualisieren.
    Errors.Refresh
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Versuch, Recordset-Objekt einer nicht bestehenden
    ' Tabelle zu öffnen.
    Set rst = dbs.OpenRecordset("Studenten")
    Debug.Print "DAO-Objekt Error:"
    ' Anzahl der Fehler in Errors-Auflistung ausgeben.
    Debug.Print ">>>Anzahl Fehler: "; Errors.Count
    ' Errors-Auflistung und wichtige Eigenschaften
    ' durchlaufen.
    For Each errX In DBEngine.Errors
        Debug.Print errX.Description
        Debug.Print errX.Source
        Debug.Print errX.Number
    Next errX
    Debug.Print
    Debug.Print "VBA-Objekt Err:"
    ' Entsprechende Eigenschaften des Err-Objekts
    ' anzeigen.
    Debug.Print Err.Description
    Debug.Print Err.Source
    Debug.Print Err.Number
    Set dbs = Nothing
End Sub


 Field-Objekt, Fields-Auflistung (MDB)

Field-Objekt, Fields-Auflistung (MDB)

Zusätzlich zu den Eigenschaften, die von der Microsoft Jet-Datenbank-Engine definiert wurden, kann ein Field-Objekt in der Fields-Auflistung eines QueryDef- oder TableDef-Objekts auch die folgenden von Microsoft Access-Anwendungen definierten Eigenschaften enthalten.

Weitere Einzelheiten über das Lesen und Einstellen dieser Eigenschaften finden Sie im Hilfeindex unter der jeweiligen Eigenschaft und unter "Property-Objekt".

Caption (Beschriftung) | DecimalPlaces (Dezimalstellen)
ColumnHidden (SpalteAusgeblendet) | Description (Beschreibung )
ColumnOrder (Spaltenreihenfolge) | Format (Format)
ColumnWidth (Spaltenbreite) | InputMask (Eingabeformat)


Field-Objekt, Fields-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Field-Objekt, stellt einige Eigenschaften des Objekts ein und fügt es an die Auflistung Fields eines TableDef-Objekts an. Die Prozedur durchläuft dann alle Felder in der Fields-Auflistung des TableDef-Objekts.

Sub NeuesFeld()
    Dim dbs As Database, tdf As TableDef
    Dim fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Neues Field-Objekt erstellen.
    Set fld = tdf.CreateField("Personalnummer")
    ' Eigenschaften "Type" und "Size" des Field-Objekts
    ' einstellen.
    fld.Type = dbText
    fld.Size = 11
    ' Feld anfügen.
    tdf.Fields.Append fld
    ' Alle Felder in Fields-Auflistung des TableDef-
    ' Objekts durchlaufen.
    For Each fld in tdf.Fields
        Debug.Print fld.Name
    Next fld
    Set dbs = Nothing
End Sub


FormatConditions-Auflistung und FormatCondition-Objekt: Beispiel

Das folgende Beispiel fügt einem Textfeld namens "Textfeld1" eine bedingte Formatierung hinzu und setzt einige Eigenschaften des neu hinzugefügten FormatCondition-Objekts fest.

With Forms("Formular1").Controls("Textfeld1").FormatConditions _
    .Add(acFieldValue, acGreaterThan, "=[Textfeld2]")
    .BackColor = RGB(255,255,255)
    .FontBold = True
    .ForeColor = RGB(255,0,0)
End With

Das folgende Beispiel definiert Eigenschaften einer bereits existierenden bedingten Formatierung eines Steuerelements namens "Textfeld1".

With forms("Formular1").Controls("Textfeld1").FormatConditions(1)
    .BackColor = RGB(255,255,255)
    .FontBold = True
    .ForeColor = RGB(255,0,0)
End With


Form-Objekt, Forms-Auflistung (Formulare) - Beispiel

Das folgende Beispiel erstellt ein neues Formular und stellt bestimmte Eigenschaften ein.

Sub NeuesFormular()
    Dim frm As Form

    ' Neues Formular erstellen.
    Set frm = CreateForm
    ' Formulareigenschaften einstellen.
    With frm
        .RecordSource = "Artikel"
        .Caption = "Formular: Artikel"
        .ScrollBars = 0
        .NavigationButtons = True
    End With
    ' Formular wiederherstellen.
    DoCmd.Restore
End Sub

Das nächste Beispiel durchläuft die Auflistung Forms und gibt die Namen aller Formulare in der Auflistung Forms aus. Dann durchläuft es die Auflistung Controls jedes Formulars und gibt die Namen aller auf dem Formular befindlichen Steuerelemente aus.

Sub AlleOffenenFormulare()
    Dim frm As Form, ctl As Control

    ' Forms-Auflistung durchlaufen.
    For Each frm In Forms
        ' Name des Formulars ausgeben.
        Debug.Print frm.Name
        ' Controls-Auflistung jedes Formulars durchlaufen.
        For Each ctl In frm.Controls
            ' Namen der Steuerelemente ausgeben.
            Debug.Print ">>>"; ctl.Name
        Next ctl
    Next frm
End Sub

Im folgenden Beispiel wird die Auflistung Forms in einem Ausdruck verwendet. In einem Formular Bestellungen mit einem Steuerelement Bestimmungsland können Sie mit der Funktion IIf einen Wert zurückgeben, der auf dem aktuellen Wert des Steuerelements basiert. Ist der Wert von Bestimmungsland gleich Null, so gibt der Ausdruck eine leere Zeichenfolge, andernfalls den Inhalt des Feldes zurück. Geben Sie den folgenden Ausdruck für die Eigenschaft Steuerelementinhalt eines Textfelds ein, das sich auf einem Formular befindet.

= IIf(IsNull(Formulare!Bestellungen!Bestimmungsland), "", _
     Formulare!Bestellungen!Bestimmungsland)


 Group-Objekt, Groups-Auflistung (MDB)

Group-Objekt, Groups-Auflistung (MDB)

Sie erstellen Group-Objekte, um Berechtigungen für Microsoft Access-Datenbankobjekte und für Datenzugriffsobjekte einzurichten und durchzusetzen. Sie können z. B. Zugriffsrechte für Formulare, Berichte und Makros erstellen.

Ein Group-Objekt verfügt über die Eigenschaft Name, die Sie zur Einstellung der Berechtigungen für ein Container- oder Document-Objekt verwenden können. Sie können z. B. den Wert der Eigenschaft Name eines Group-Objekts der Eigenschaft UserName eines Container- oder Document-Objekts zuweisen. Sie können die Eigenschaft Permissions des Container- oder Document-Objekts verwenden, um Berechtigungen für die Gruppe von Benutzern, die von der Eigenschaft UserName definiert wurden, festzulegen. Sie können auch die Eigenschaft Permissions lesen, um bestehende Berechtigungen für diese Gruppe zu ermitteln.


Group-Objekt, Groups-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues User-Objekt und fügt dieses an die Users-Auflistung eines Workspace-Objekts an. Anschließend wird ein neues Group-Objekt erstellt und an die Groups-Auflistung des Workspace-Objekts angefügt. Das neue Group-Objekt wird auch an die Groups-Auflistung des User-Objekts angefügt. Der neuen Gruppe werden dann die Berechtigungen "Bearbeiten" und "Löschen" für Module zugeteilt.

Wenn Sie Benutzer Gruppen zuweisen möchten, fügen Sie entweder ein User-Objekt an die Users-Auflistung eines Group-Objekts oder ein Group-Objekt an die Groups-Auflistung eines User-Objekts an. Unabhängig von der gewählten Option wird der angegebene Benutzer zur angegebenen Gruppe hinzugefügt.

Anmerkung Vermeiden Sie beim Programmieren unter Sicherheitsaspekten die Angabe von Kennwörtern und PID-Informationen im Code. Das folgende Beispiel dient nur Demonstrationszwecken.

Sub NeueMakrosGruppe()
    Dim wsp As Workspace, dbs As Database
    Dim usr As User, grp As Group, grpMitglied As Group
    Dim ctr As Container

    ' Bezug auf Standard-Arbeitsbereich zurückgeben.
    Set wsp = DBEngine.Workspaces(0)
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' User-Objekt erstellen und an Users-Auflistung des
    ' Workspace-Objekts anfügen.
    Set usr = wsp.CreateUser("Peter Gschwend", "123abc789xyz", "Password")
    wsp.Users.Append usr
    ' Group-Objekt erstellen und an Groups-Auflistung
    ' des Workspace-Objekts anfügen.
    Set grp = wsp.CreateGroup("Programmierer", "321xyz987abc")
    wsp.Groups.Append grp
    ' Group-Objekt an Groups-Auflistung des User-
    ' Objekts anfügen.
    Set grpMitglied = usr.CreateGroup("Programmierer")
    usr.Groups.Append grpMitglied
    ' Groups-Auflistung des User-Objekts aktualisieren.
    usr.Groups.Refresh
    ' Container-Objekt zurückgeben.
    Set ctr = dbs.Containers!Scripts
    ' Eigenschaft UserName des Container-Objekts
    ' einstellen.
    ctr.UserName = grpMitglied.Name
    ' Berechtigungen "Bearbeiten" und "Löschen" in
    ' allen Modulen für neue Gruppe hinzufügen.
    ctr.Permissions = ctr.Permissions Or acSecMacWriteDef
    Set dbs = Nothing
    Set wsp = Nothing
End Sub


 Hyperlink-Objekt: Beispiel

Hyperlink-Objekt: Beispiel

Das folgende Beispiel aktiviert den mit einer Befehlsschaltfläche des aktiven Formulars verknüpften Hyperlink.

Me!Befehl0.Hyperlink.Follow

Das folgende Beispiel weist der HyperlinkAddress-Eigenschaft einer Befehlsschaltfläche einen Wert zu und öffnet dann beim Laden des Formulars den Hyperlink.

Um dieses Beispiel zu testen, erstellen Sie ein Formular und fügen ihm eine Befehlsschaltfläche namen "Befehl0" hinzu. Fügen Sie außerdem den folgenden Code in das zugehörige Modul des Formulars ein, und wechseln Sie dann zur Formularansicht:

Private Sub FormularLaden()
    Dim ctl As CommandButton
    Set ctl = Me!Befehl0
    With ctl
        .Visible = False
        .HyperlinkAddress = "http://www.microsoft.com/"
        .Hyperlink.Follow
    End With
End Sub


Index-Objekt, Indexes-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt einen neuen Index für die Tabelle Personal:

Sub NeuerIndex()
    Dim dbs As Database, tdf As TableDef, idx As Index
    Dim fld1 As Field, fld2 As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    Set idx = tdf.CreateIndex("PersonalIndex")
    Set fld1 = idx.CreateField("Nachname")
    Set fld2 = idx.CreateField("Vorname")
    idx.Fields.Append fld1
    idx.Fields.Append fld2
    idx.Required = True
    tdf.Indexes.Append idx
    Set dbs = Nothing
End Sub


Module-Objekt, Modules-Auflistung - Beispiel

Das folgende Beispiel gibt einen Verweis auf ein Module-Objekt der Auflistung Modules zurück und druckt die Anzahl der Codezeilen des Moduls aus:

Function LinesInModule(strModulname As String) As Long
    Dim mdl As Module

    On Error GoTo Error_LinesInModule
    ' Modul öffnen.
    DoCmd.OpenModule strModulname
    ' Verweis auf "Module"-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
    ' Zahl der Zeilen des Moduls zurückgeben.
    LinesInModule = mdl.CountOfLines

Exit_LinesInModule:
    Exit Function

Error_LinesInModule:
    MsgBox Err & ": " & Err.Description
    ' Wenn Funktion fehlschlägt, -1 zurückgeben.
    LinesInModule = -1
    Resume Exit_LinesInModule
End Function


Page-Objekt, Pages-Auflistung - Beispiel

Die folgende Ereignisprozedur durchläuft alle Steuerelemente auf jeder Seite eines Registersteuerelements, wenn der Benutzer die entsprechende Seite auswählt.

Wenn Sie dieses Beispiel ausführen möchten, erstellen Sie ein neues Formular mit einem Registersteuerelement Registerstr0, und stellen Sie dessen Eigenschaft OnChange auf [Ereignisprozedur] ein. Fügen Sie den folgenden Code in das Modul des Formulars ein. Wechseln Sie in die Formularansicht, und klicken Sie auf die verschiedenen Registerkarten, um deren Steuerelemente zu durchlaufen.

Private Sub Registerstr0_Change()
    Dim tbc As Control, pge As Page
    Dim ctl As Control

    ' Verweis auf Registersteuerelement zurückgeben.
    Set tbc = Me!Registerstr0
    ' Verweis auf aktuell ausgewählte Seite zurückzugeben.
    Set pge = tbc.Pages(tbc.Value)
    ' Steuerelemente auf der aktuell ausgewählten Seite durchlaufen.
    Debug.Print pge.Name & " Steuerelemente:"
    For Each ctl In pge.Controls
        Debug.Print ctl.Name
    Next ctl
    Debug.Print
End Sub


Parameter-Objekt, Parameters-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt eine neue Parameterabfrage und übergibt Werte für diese Parameter:

Sub NeueParameterabfrage()
    Dim dbs As Database, qdf As QueryDef, rst As Recordset
    Dim prm As Parameter, strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' SQL-Zeichenfolge zusammenstellen.
    strSQL = "PARAMETERS [Erstes Bestelldatum] DateTime, " _
        & "[Letztes Bestelldatum] DateTime; SELECT * FROM Bestellungen " _
    & "WHERE ([Bestelldatum] Between [Erstes Bestelldatum] " _
        & "And [Letztes Bestelldatum]);"
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("Parameterabfrage", strSQL)
    ' Werte für die Parameter zuweisen.
    qdf.Parameters![Erstes Bestelldatum] = #01.04.96#
    qdf.Parameters![Letztes Bestelldatum] = #30.04.96#
    ' Recordset für QueryDef-Objekt öffnen.
    Set rst = qdf.OpenRecordset
    rst.MoveLast
    MsgBox "Abfrage lieferte " & rst.RecordCount & " Datensätze."
    rst.Close
    Set dbs = Nothing
End Sub


 Property-Objekt, Properties-Auflistung (MDB)

Property-Objekt, Properties-Auflistung (MDB)

In Microsoft Access existieren verschiedene Typen von Eigenschaften. Jede dieser Eigenschaften kann in Visual Basic-Code durch eine Variable für ein Property-Objekt dargestellt werden, und jede Eigenschaft ist ein Element einer Properties-Auflistung.

Eigenschaften, die auf Datenzugriffsobjekte (DAO) angewendet werden

  • Eingebaute Eigenschaften werden für alle Datenzugriffsobjekte (DAO) von der Microsoft Jet-Datenbank-Engine definiert.

  • Benutzerdefinierte Eigenschaften können einigen DAO-Objekten hinzugefügt werden. Hierzu zählen die DAO-Objekte Database, Index, QueryDef und TableDef sowie Field-Objekte in der Auflistung Fields eines QueryDef- oder TableDef-Objekts.

  • Einige von Microsoft Access definierte Eigenschaften werden auf DAO-Objekte angewendet. Diese Eigenschaften können gewöhnlich im Microsoft Access-Fenster oder von Visual Basic aus eingestellt werden. Die Jet-Datenbank-Engine kann diese Eigenschaften erst erkennen, wenn entsprechende Property-Objekte speziell erstellt und an die Properties-Auflistung angefügt werden. Diese Eigenschaften können auf die DAO-Objekte QueryDef und TableDef sowie auf Field-Objekte in der Auflistung Fields eines QueryDef- oder TableDef-Objekts angewendet werden. Eine Liste der von Microsoft Access definierten Eigenschaften finden Sie im Microsoft Access-Thema Zusatzinfo für die Objekte TableDef, QueryDef und Field.

Die von Microsoft Access definierten Eigenschaften, die auf DAO-Objekte angewendet werden, unterscheiden sich in mehreren Punkten von den durch die Jet-Datenbank-Engine definierten Eigenschaften.

Damit Sie auf eine benutzerdefinierte Eigenschaft oder eine von Microsoft Access definierte Eigenschaft verweisen können, müssen Sie explizit auf die Properties-Auflistung verweisen. Am schnellsten verweisen Sie mit folgender Syntax auf eine Microsoft Access-Eigenschaft:

Objekt.Properties!Eigenschaftsname

Im vorangehenden Beispiel ist Objekt ein DAO-Objekt, und Eigenschaftsname ist der Name einer Microsoft Access-Eigenschaft.

Sie können auch die folgende, etwas langsamere Syntax verwenden:

Objekt.Properties("Name")

Im Gegensatz dazu können Sie auf Eigenschaften, die von der Jet-Datenbank-Engine definiert wurden, ganz einfach unter Verwendung der Syntax Objekt.Name verweisen.

Stellen Sie den Wert einer von Microsoft Access definierten Eigenschaft zum ersten Mal ein, müssen Sie diese zuerst unter Verwendung der Methode CreateProperty erstellen. Die Eigenschaft Caption eines Field-Objekts z. B. ist eine von Microsoft Access definierte Eigenschaft. Wenn Sie vorher die Eigenschaft Caption nicht in der Tabellenentwurfsansicht eingestellt haben und die Eigenschaft das erste Mal aus Visual Basic-Code heraus einstellen, müssen Sie zuerst diese Eigenschaft unter Verwendung der Methode CreateProperty erstellen und dann an die Properties-Auflistung anfügen, bevor Sie deren Wert einstellen können.

Eine von Microsoft Access definierte Eigenschaft wird, wenn sie das erste Mal im Microsoft Access-Fenster eingestellt wird, automatisch an die Properties-Auflistung angefügt, so dass Sie die Eigenschaft nicht mit Code erstellen und anfügen müssen, wenn Sie eine Eigenschaft bereits in der Benutzeroberfläche eingestellt haben. Sie können die Eigenschaft Caption z. B. für eine Tabelle in der Datenblattansicht einstellen, indem Sie im Menü Format auf Schriftart klicken. Diese Eigenschaft wird dann in die Properties-Auflistung eines TableDef-Objekts aufgenommen, das auf diese Tabelle verweist.

Erst wenn Sie eine von Microsoft Access definierte Eigenschaft entweder in der Tabellenentwurfsansicht oder aus Visual Basic-Code heraus eingestellt haben, erscheint die Eigenschaft in der Properties-Auflistung. Wenn Sie diese Eigenschaften aus Visual Basic heraus einstellen, sollten Sie auch Code zur Fehlerbehandlung schreiben, der überprüft, ob die Eigenschaft in der Properties-Auflistung enthalten ist und der die Eigenschaft andernfalls erstellt und anfügt.

Eigenschaften, die auf Microsoft Access-Objekte angewendet werden

Wie DAO-Objekte enthält auch jedes Microsoft Access-Objekt eine Properties-Auflistung mit eingebauten Property-Objekten. Beispielsweise sind Property-Objekte, die auf ein Formular angewendet werden, Elemente der Properties-Auflistung des Objekts Form.

Sie können auch benutzerdefinierte Eigenschaften für Microsoft Access-Objekte erstellen. Es besteht z. B. die Möglichkeit, eine Eigenschaft mit dem Namen TextType zu erstellen, die auf ein Textfeld-Steuerelement angewendet wird.

Property-Objekte in den Properties-Auflistungen der Objekte Form, Report und Control unterscheiden sich von Property-Objekten für den Datenzugriff (DAO) dadurch, dass sie nicht über die Eigenschaft Inherited verfügen.

Sie können alle Property-Objekte in den Properties-Auflistungen der Objekte Form, Report und Control nacheinander durchlaufen. Das Microsoft Access-Objekt Application und das Bildschirm-Objekt verfügen jedoch über Properties-Auflistungen, deren Elemente nicht durchlaufen werden können. Darüber hinaus sind die Eigenschaften dieser Objekte schreibgeschützt.


Property-Objekt, Properties-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt eine Eigenschaft, die von Microsoft Access definiert, aber auf DAO-Objekte angewendet wird. Da die Microsoft Jet-Datenbank-Engine von Microsoft Access definierte Eigenschaften nicht erkennt, müssen Sie ein neues Property-Objekt erstellen und an die Properties-Auflistung anfügen, wenn Sie die Eigenschaft das erste Mal einstellen.

Sie können mit derselben Funktion eine benutzerdefinierte Eigenschaft für ein Microsoft Access-Objekt oder für ein DAO-Objekt erstellen.

Beachten Sie, dass Sie beim Erstellen der Eigenschaft die richtige Konstante für das Argument Typ angeben müssen. Wenn Sie sich nicht sicher sind, welchen Datentyp Sie verwenden müssen, lesen Sie im Hilfeindex unter der jeweiligen Eigenschaft nach.

Function AccessEigenschaftErstellen(obj As Object, strName As String, _
        intType As Integer, varSetting As Variant) As Boolean
    Dim prp As Property
    Const conEigenNichtGefunden As Integer = 3270

    On Error GoTo Fehler_AccessEigenschaftErstellen
    ' Expliziter Bezug auf Properties-Auflistung.
    obj.Properties(strName) = varSetting
    obj.Properties.Refresh
    AccessEigenschaftErstellen = True

Beenden_AccessEigenschaftErstellen:
    Exit Function

Fehler_AccessEigenschaftErstellen:
    If Err =conEigenNichtGefunden Then

        ' Eigenschaft erstellen, Typ kennzeichnen und
        ' Anfangswert einstellen.
        Set prp = obj.CreateProperty(strName, intType, varSetting)
        ' Property-Objekt an Properties-Auflistung
        ' anfügen.
        obj.Properties.Append prp
        obj.Properties.Refresh
        AccessEigenschaftErstellen = True
        Resume Beenden_AccessEigenschaftErstellen
    Else
        MsgBox Err & ": " & vbCrLf & Err.Description
        AccessEigenschaftErstellen = False
        Resume Beenden_AccessEigenschaftErstellen
    End If
End Function

Sie können diese Funktion etwa mit der folgenden Prozedur aufrufen:

Sub AufrufEigenschaftErstellen()
    Dim dbs As Database, tdf As TableDef
    Dim blnRückgabe As Boolean

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Funktion AccessEigenschaftErstellen aufrufen.
    blnRückgabe = AccessEigenschaftErstellen(tdf, _
        "DatenblattSchriftKursiv", dbBoolean, True)
    ' Rückgabewert auswerten.
    If blnRückgabe = True Then
        Debug.Print "Eigenschaft erfolgreich erstellt."
    Else
        Debug.Print "Eigenschaft nicht erfolgreich erstellt."
    End If
End Sub


 QueryDef-Objekt, QueryDefs-Auflistung (MDB)

QueryDef-Objekt, QueryDefs-Auflistung (MDB)

Zusätzlich zu den Eigenschaften, die von der Microsoft Jet-Datenbank-Engine definiert wurden, kann ein QueryDef-Objekt auch die folgenden von Microsoft Access-Anwendungen definierten Eigenschaften enthalten. Weitere Informationen zum Überprüfen und Einstellen von Eigenschaften finden Sie im Hilfeindex unter der betreffenden Eigenschaft und unter "Property-Objekt".

DatasheetFontItalic (DatenblattSchriftKursiv) | FrozenColumns (FixierteSpalten)
DatasheetFontHeight (DatenblattSchriftgröße) | LogMessages (MeldungenProtokollieren)
DatasheetFontName (DatenblattSchriftart) | RecordLocks (DatensätzeSperren)
DatasheetFontUnderline (DatenblattSchriftUnterstrichen) | RowHeight (Zeilenhöhe)
DatasheetFontWeight (DatenblattSchriftbreite) | ShowGrid (RasterEinblenden)
Description (Beschreibung) | TransaktionDurchführen


QueryDef-Objekt, QueryDefs-Auflistung - Beispiel (MDB)

Das folgende Beispiel überprüft, ob die Abfrage LetzteEinstellungen in der aktuellen Datenbank existiert und löscht diese ggf. aus der Auflistung QueryDefs. Anschließend erstellt die Prozedur ein neues QueryDef-Objekt und öffnet es in der Datenblattansicht.

Sub NeueAbfrage()
    Dim dbs As Database, qdf As QueryDef
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' QueryDefs-Auflistung aktualisieren.
    dbs.QueryDefs.Refresh
    ' Abfrage "LetzteEinstellungen" löschen, falls sie
    ' existiert.
    For Each qdf in dbs.QueryDefs
        If qdf.Name = "LetzteEinstellungen" Then
            dbs.QueryDefs.Delete qdf.Name
        End If
    Next qdf
    ' SQL-Zeichenfolge zum Auswählen aller Angestellten
    ' erstellen, die am 01.01.95 oder später
    ' eingestellt wurden.
    strSQL = "SELECT * FROM Personal WHERE Einstellungsdatum >= #01.01.95#;"
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("LetzteEinstellungen", strSQL)
    ' Abfrage in der Datenblattansicht öffnen.
    DoCmd.OpenQuery qdf.Name
    Set dbs = Nothing
End Sub


Recordset-Objekt, Recordsets-Auflistung - Beispiel (MDB)

Das folgende Beispiel öffnet ein Recordset-Objekt vom Typ Tabelle, ein Recordset-Objekt vom Typ Dynaset und ein Recordset-Objekt vom Typ Snapshot. Anschließend wird der Wert der Eigenschaft Updatable für die Recordset-Objekte angezeigt.

Sub NeueRecordsetObjekte()
    Dim dbs As Database, rst As Recordset
    Dim rstPersonal As Recordset, rstBestellungen As Recordset
    Dim rstArtikel As Recordset, strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle erstellen.
    Set rstPersonal = dbs.OpenRecordset("Personal", dbOpenTable)
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rstBestellungen = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
    ' Recordset-Objekt vom Typ Snapshot erstellen.
    Set rstArtikel = dbs.OpenRecordset("Artikel", dbOpenSnapshot)
    ' Wert der Eigenschaft "Updatable" für jedes
    ' Recordset-Objekt ausgeben.
    For Each rst In dbs.Recordsets
        Debug.Print rst.Name; "   "; rst.Updatable
    Next rst
' Alle Recordset-Variablen freigeben.
    rstPersonal.Close
    rstBestellungen.Close
    rstArtikel.Close
    Set dbs = Nothing
End Sub


Reference-Objekt, References-Auflistung - Beispiel

Das folgende Beispiel erstellt einen Verweis auf eine bestimmte Typbibliothek:

Function VerweisAusDatei(strDateiname As String) As Boolean
    Dim ref As Reference

    On Error GoTo Error_VerweisAusDatei
    Set ref = References.AddFromFile(strDateiname)
    VerweisAusDatei = True

Exit_VerweisAusDatei:
    Exit Function

Error_VerweisAusDatei:
    MsgBox Err & ": " & Err.Description
    VerweisAusDatei= False
    Resume Exit_VerweisAusDatei
End Function

Sie können diese Funktion aufrufen, indem Sie eine Prozedur ähnlich der folgenden verwenden, die einen Verweis auf das Kalender-Steuerelement erstellt:

Sub ErstellenKalenderVerweis()
    If VerweisAusDatei("C:\WINDOWS\SYSTEM\MSCAL.OCX") = True Then
        MsgBox "Verweis wurde erfolgreich eingestellt."
    Else
        MsgBox "Verweis konnte nicht eingestellt werden."
    End If
End Sub


Relation-Objekt, Relations-Auflistung - Beispiel (MDB)

Das folgende Beispiel entfernt zunächst die bestehende Beziehung zwischen der Tabelle Personal und der Tabelle Bestellungen und erstellt dann die Beziehung neu, indem ein neues Relation-Objekt erstellt wird.

Sub NeueBeziehung()
    Dim dbs As Database
    Dim fld As Field, rel As Relation

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bestehende PersonalBestellungen-Beziehung suchen.
    For Each rel In dbs.Relations
        If rel.TABLE = "Personal" And _
            rel.ForeignTable = "Bestellungen"
        Then
        ' Benutzer vor dem Löschen der Beziehung informieren.
        If MsgBox(rel.Name & " besteht bereits. " _
            & vbCrLf _
            & "Diese Beziehung wird gelöscht und " _
            & "neu erstellt.", vbOK) = vbOK
        Then
                dbs.Relations.Delete rel.Name
            ' Falls Benutzer "Abbrechen" wählt, Prozedur beenden.
            Else
                Exit Sub
            End If
        End If
    Next rel
    ' Neue Beziehung erstellen und deren Eigenschaften einstellen.
    Set rel = dbs.CreateRelation("PersonalBestellungen", "Personal", _
         "Bestellungen")
    ' Attribute des Relation-Objekts einstellen, um die
    ' referentielle Integrität zu gewährleisten.
    rel.Attributes = dbRelationDeleteCascade + dbRelationUpdateCascade
    ' Feld in der Fields-Auflistung des Relation-Objekts erstellen.
    Set fld = rel.CreateField("Personal-Nr")
    ' Name des Fremdschlüsselfelds bereitstellen.
    fld.ForeignName = "Personal-Nr"
    ' Feld an Relation-Objekt und Relation-Objekt an Datenbank anfügen.
    rel.Fields.Append fld
    dbs.Relations.Append rel
    MsgBox "Beziehung '" & rel.Name & "' erstellt."
    Set dbs = Nothing
End Sub


Report-Objekt, Reports-Auflistung (Berichte) - Beispiel

Das folgende Beispiel erstellt einen neuen Bericht und stellt einige Eigenschaften ein.

Sub NeuerBericht ()
    Dim rpt As Report

    ' Variable des Datentyps "Report" als Bezug _
    ' auf das neue Report-Objekt zurückgeben.
    Set rpt = CreateReport
    ' Eigenschaften des neuen Berichts einstellen.
    With rpt
        .RecordSource = "Artikel"
        .Caption = "Bericht: Artikel"
    End With
    ' Neuen Bericht wiederherstellen.
    DoCmd.Restore
End Sub

Das nächste Beispiel durchläuft die Auflistung Reports und gibt die Namen aller Berichte in der Auflistung Reports aus. Dann durchläuft es die Auflistung Controls jedes Berichts und gibt die Namen aller auf dem Bericht befindlichen Steuerelemente aus.

Sub AlleOffenenBerichte()
    Dim rpt As Report, ctl As Control

    ' Reports-Auflistung durchlaufen.
    For Each rpt In Reports
        ' Name des Berichts ausgeben.
        Debug.Print rpt.Name
        ' Controls-Auflistung jedes Berichts durchlaufen.
        For Each ctl In rpt.Controls
            ' Namen der Steuerelemente ausgeben.
            Debug.Print ">>>"; ctl.Name
        Next ctl
    Next rpt
End Sub


Screen-Objekt (Bildschirm) - Beispiel

Das folgende Beispiel verwendet das Objekt Screen, um den Namen des Formulars, das sich im aktiven Fenster befindet, und den Namen des Steuerelements, das auf diesem Formular aktiv ist, auszugeben.

Sub AktiveObjekte()
    Dim frm As Form, ctl As Control

    ' Form-Objekt zurückgeben, das auf das aktive Formular zeigt.
    Set frm = Screen.ActiveForm
    MsgBox frm.Name & " ist das aktive Formular."
    ' Control-Objekt zurückgeben, das auf das aktive Steuerelement zeigt.
    Set ctl = Screen.ActiveControl
    MsgBox ctl.Name & " ist das aktive Steuerelement " _
        & "in diesem Formular."
End Sub


Recordset-Objekt vom Typ "Snapshot" - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt vom Typ Snapshot aus einer SQL-Anweisung heraus und gibt dann den Wert der Eigenschaft Updatable des Recordset-Objekts aus. Da Recordset-Objekte vom Typ Snapshot nie aktualisierbar sind, ist der Wert dieser Eigenschaft immer False (0).

Sub Stammpersonal()
    Dim dbs As Database, qdf As QueryDef, rst As Recordset
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' SQL-Zeichenfolge erstellen.
    strSQL = "SELECT * FROM Personal WHERE Einstellungsdatum <= #01.01.95#;"
    ' Recordset-Objekt vom Typ Snapshot öffnen.
    Set rst = dbs.OpenRecordset(strSQL, dbOpenSnapshot)
    Debug.Print rst.Updatable
    rst.Close
    Set dbs = Nothing
End Sub


 TableDef-Objekt, TableDefs-Auflistung (MDB)

TableDef-Objekt, TableDefs-Auflistung (MDB)

Zusätzlich zu den Eigenschaften, die von der Microsoft Jet-Datenbank-Engine definiert wurden, kann ein TableDef-Objekt auch die folgenden, von Microsoft Access-Anwendungen definierten Eigenschaften enthalten. Weitere Informationen zum Überprüfen und Einstellen dieser Eigenschaften finden Sie im Hilfeindex unter der betreffenden Eigenschaft und unter Property-Objekt

DatasheetFontHeight | Description
DatasheetFontItalic | FrozenColumns
DatasheetFontName | RowHeight
DatasheetFontUnderline | ShowGrid
DatasheetFontWeight |


TableDef-Objekt, TableDefs-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues TableDef-Objekt, definiert darin ein Feld und fügt es an die TableDefs-Auflistung der aktuellen Datenbank an:

Sub NeueTabelle()
    Dim dbs As Database, tdf As TableDef, fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neues TableDef-Objekt erstellen.
    Set tdf = dbs.CreateTableDef("Kontakte")
    ' Neues Field-Objekt erstellen.
    Set fld = tdf.CreateField("Kontaktperson", dbText, 30)
    ' Neue Objekte anfügen.
    tdf.Fields.Append fld
    dbs.TableDefs.Append tdf
    Set dbs = Nothing
End Sub


Recordset-Objekt vom Typ "Tabelle" - Beispiel (MDB)

Das folgende Beispiel öffnet ein Recordset-Objekt vom Typ Tabelle und sucht dann einen angegebenen Datensatz:

Sub PersonalSuchen()
    Dim dbs As Database, tdf As TableDef
    Dim rst As Recordset, idx As Index
    Dim fldNachname As Field, fldVorname As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Neuen Index erstellen
    Set idx = tdf.CreateIndex("VollstName")
    ' Indexfelder erstellen und anfügen.
    Set fldNachname = idx.CreateField("Nachname", dbText)
    Set fldVorname = idx.CreateField("Vorname", dbText)
    idx.Fields.Append fldNachname
    idx.Fields.Append fldVorname
    ' Index-Objekt anfügen.
    tdf.Indexes.Append idx
    ' Recordset-Objekt vom Typ Tabelle öffnen.
    Set rst = dbs.OpenRecordset("Personal")
    ' Aktuellen Index auf neuen Index setzen.
    rst.Index = idx.Name
    ' Zu suchenden Datensatz angeben.
    rst.Seek "=", "Hofmann", "Klaus"
    If rst.NoMatch Then
        Debug.Print "Suche fehlgeschlagen."
    Else
        Debug.Print "Suche erfolgreich."
    End If
    rst.close
    Set dbs = Nothing
End Sub


 User-Objekt, Users-Auflistung (MDB)

User-Objekt, Users-Auflistung (MDB)

Sie erstellen User-Objekte, um Berechtigungen für Microsoft Access-Datenbankobjekte und für Datenzugriffsobjekte einzurichten und durchzusetzen. Sie können z.B. Zugriffsrechte für Formulare, Berichte und Makros festlegen.

Ein User-Objekt verfügt über eine Eigenschaft Name, die Sie zur Einstellung der Berechtigungen für Container- oder Document-Objekte verwenden können. Sie können z.B. den Wert der Eigenschaft Name eines User-Objekts der Eigenschaft UserName eines Container- oder Document-Objekts zuweisen. Sie können dann die Eigenschaft Permissions des Container- oder Document-Objekts verwenden, um Berechtigungen für den Benutzer einzurichten, der in der Eigenschaft UserName definiert ist. Sie können auch die Eigenschaft Permissions lesen, um bestehende Berechtigungen für diesen Benutzer zu ermitteln.


User-Objekt, Users-Auflistung - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues User-Objekt und fügt es an die Users-Auflistung eines Workspace-Objekts an. Anschließend wird ein neues Group-Objekt erstellt und an die Groups-Auflistung des Workspace-Objekts angefügt. Das neue User-Objekt wird auch an die Users-Auflistung des Group-Objekts angefügt. Der neue Benutzer erhält dann die Berechtigung zum Lesen von Daten aus Tabellen.

Wenn Sie die Benutzer den Gruppen zuweisen möchten, müssen Sie entweder ein User-Objekt an die Users-Auflistung eines Group-Objekts oder ein Group-Objekt an die Groups-Auflistung eines User-Objekts anfügen. Unabhängig von der gewählten Option wird der angegebene Benutzer zur angegebenen Gruppe hinzugefügt.

Anmerkung Vermeiden Sie beim Programmieren unter Sicherheitsaspekten die Angabe von Kennwörtern und PID-Informationen im Code. Das folgende Beispiel dient nur Demonstrationszwecken.

Sub NeuerTabellenbenutzer()
    Dim wsp As Workspace, dbs As Database
    Dim usr As User, grp As Group, usrMitglied As User
    Dim ctr As Container, doc As Document

    ' Bezug auf Standard-Arbeitsbereich zurückgeben.
    Set wsp = DBEngine.Workspaces(0)
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' User-Objekt erstellen und an Users-Auflistung des
    ' Workspace-Objekts anfügen.
    Set usr = wsp.CreateUser("Markus Wetter", "123abc456DEF", "EcoVin")
    wsp.Users.Append usr
    ' Group-Objekt erstellen und an Groups-Auflistung
    ' des Workspace-Objekts anfügen.
    Set grp = wsp.CreateGroup("Marketing", "321xyz654EFD")
    wsp.Groups.Append grp
    ' Neues User-Objekt an Users-Auflistung des neuen
    ' Group-Objekts anfügen.
    Set usrMitglied = grp.CreateUser("Markus Wetter")
    grp.Users.Append usrMitglied
    ' Users-Auflistung des Group-Objekts aktualisieren.
    grp.Users.Refresh
    ' Container-Objekt zurückgeben.
    Set ctr = dbs.Containers!Tables
    ' Eigenschaft UserName des Container-Objekts
    ' einstellen.
    ctr.UserName = usrMitglied.Name
    ' Berechtigung zum Abrufen von Daten aus allen
    ' Tabellen für den neuen Benutzer hinzufügen.
    ctr.Permissions = ctr.Permissions Or dbSecRetrieveData
    Set dbs = Nothing
    Set wsp = Nothing
End Sub


WebOptions-Objekt: Beispiel

Das folgende Beispiel prüft bei der Anzeige einer gespeicherten Datenzugriffsseite ("Inventar"), ob Microsoft Office Web Components übertragen wurden, und setzt dementsprechend den Wert eines Flags.

Set objWeboptionen = DataAccessPages("Inventar").WebOptions
With objWeboptionen
    If .DownloadComponents = True Then
        strCompDownload = "Geladen"
    Else
        strCompDownload = "Nicht geladen"
    End If
End With


AbsolutePosition-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel sucht einen Datensatz in einem Recordset-Objekt vom Typ Dynaset und ermittelt seine Positionsnummer.

Sub DatensatzPosition()
    Dim dbs As Database, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Recordset-Objekt vom Typ Dynaset zurückgeben.
    Set rst = dbs.OpenRecordset("SELECT * FROM Bestellungen WHERE " _
        & "Versanddatum >= #1-1-96#;")
    ' Erste Bestellung für München suchen.
    rst.FindFirst "Bestimmungsort = 'München'"
    ' Positionsnummer des Datensatzes ermitteln.
    Debug.Print rst.AbsolutePosition
    rst.Close
    Set dbs = Nothing
End Sub


ActiveControl-Eigenschaft - Beispiel

Der folgende Code weist der Variablen AktSteuerelement das aktive Steuerelement zu und führt dann in Abhängigkeit vom Wert der Eigenschaft Name des Steuerelements verschiedene Aktionen aus.

Dim AktSteuerelement As Control

Set AktSteuerelement = Screen.ActiveControl
If AktSteuerelement.Name = "txtKundenCode" Then
    .            ' Diese Aktion ausführen.
    .
    .
ElseIf AktSteuerelement.Name = "btnKundenDetails" Then
    .            ' Diese Aktion ausführen.
    .
    .
End If


 ActiveDataAccessPage-Eigenschaft

ActiveDataAccessPage-Eigenschaft

Mit der Eigenschaft ActiveDataAccessPage können Sie die Datenzugriffsseite, die den Fokus hat, identifizieren oder darauf verweisen.

Einstellung

Die Einstellung der Eigenschaft ActiveDataAccessPage enthält einen Verweis auf das DataAccessPage-Objekt, das zur Laufzeit den Fokus hat.

Diese Eigenschaft ist in einem Makro oder in Visual Basic verfügbar und schreibgeschützt.

Anmerkung

Verwenden Sie die Eigenschaft ActiveDataAccessPage, um auf eine aktive Datenzugriffsseite zusammen mit einer von deren Eigenschaften oder Methoden zu verweisen. Das folgende Beispiel zeigt die Einstellung der Eigenschaft Name der aktiven Datenzugriffsseite an:

Dim pgAktuelleSeite As DataAccessPage
Set pgAktuelleSeite = Screen.ActiveDataAccessPage
MsgBox "Die aktuelle Datenseite ist " & pgAktuelleSeite.Name

Wenn beim Verwenden der Eigenschaft ActiveDataAccessPage keine Datenzugriffsseite den Fokus hat, tritt ein Fehler auf.


ActiveDatasheet-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft ActiveDatasheet, um die Datenblattzelle zu ermitteln, die den Fokus hat. Sind mehrere Zellen markiert, ermittelt die Prozedur die Position der Zelle, in der sich die erste Zeile und die erste Spalte der Auswahl kreuzen.

Sub AuswahlAbrufen()
    Dim objDatasheet As Object
    Dim lngErsteZeile As Long, lngErsteSpalte As Long
    Const conKeinAktivesDatenblatt = 2484
    On Error GoTo AuswahlAbrufen_Fehler
    Set objDatasheet = Screen.ActiveDatasheet
    lngErsteZeile = objDatasheet.SelTop
    lngErsteSpalte = objDatasheet.SelLeft
    MsgBox "Das erste Element dieser Auswahl befindet sich in "_
        & "Zeile " & lngErsteZeile & ", Spalte " & lngErsteSpalte
AuswahlAbrufen_Bye:
    Exit Sub
AuswahlAbrufen_Fehler:
    If Err = conKeinAktivesDatenblatt Then
        Resume AuswahlAbrufen_Bye
    End If
End Sub


ActualSize-Eigenschaft

Die ADO-Eigenschaft ActualSize entspricht der FieldSize-Eigenschaft in DAO. Verwenden Sie ActualSize, wenn Sie in Visual Basic die Größe der Daten zurückgeben möchten, die tatsächlich in einem Feld gespeichert sind.


Alias-Eigenschaft (Alias) - Beispiel

Das folgende Beispiel stellt die Eigenschaft RecordSource für ein Formular auf eine SQL-Anweisung ein, welche die AS-Klausel verwendet, um Vorgesetzte als Alias für die Tabelle Personal anzugeben.

Dim strSQLAbrufen AS String
strSQLAbrufen = "SELECT Personal.Vorname, Personal.Nachname, " _
    & "Personal.Position, Vorgesetzte.Vorname, Vorgesetzte.Nachname FROM Personal " _
    & "INNER JOIN Personal AS Vorgesetzte " _
    & "ON Personal.[Vorgesetzte(r)] = Vorgesetzte.[Personal-Nr]; "
Formulare!Form1.RecordSource = strSQLAbrufen

Das nächste Beispiel verwendet eine Reflexivverknüpfung, um Angestellte und deren Vorgesetzte anzuzeigen. Es stellt die Eigenschaft Alias der Duplikattabelle Personal mit Hilfe der AS-Klausel auf Vorgesetzte ein. Sie geben diese SQL-Anweisung in der SQL-Ansicht des Abfragefensters ein.

SELECT Personal.Vorname, Personal.Nachname, Personal.Position, Vorgesetzte.Vorname, Vorgesetzte.Nachname
FROM Personal INNER JOIN Personal AS Vorgesetzte
ON Personal.[Vorgesetzte(r)] = Vorgesetzte.[Personal-Nr];


AllowBypassKey-Eigenschaft: Beispiel

Das folgende Beispiel zeigt eine Prozedur namens BypassEigenschaftEinstellen, die den Namen, Datentyp und gewünschten Wert der Eigenschaft übergibt, die neu eingestellt werden soll. Die Allzweckfunktion EigenschaftÄndern versucht, die gewünschte Einstellung der AllowBypassKey-Eigenschaft vorzunehmen. Falls die Eigenschaft nicht gefunden werden kann, wird sie unter Verwendung der CreateProperty-Methode an die Properties-Auflistung angehängt. Dies ist erforderlich, da die Eigenschaft erst hinzugefügt werden muss, bevor sie in der Properties-Auflistung erscheint.

Sub BypassEigenschaftEinstellen()
Const DB_Boolean As Long = 1
    EigenschaftÄndern "AllowBypassKey", DB_Boolean, False
End Sub

Function EigenschaftÄndern(strEigenschaftname As String, varEigenschafttyp As Variant, varEigenschaftwert As Variant) As Integer
    Dim dbs As Object, prp As Variant
    Const conEigenschaftNichtGefunden_Fehler = 3270

    Set dbs = CurrentDb
    On Error GoTo Fehlerbehandlung
    dbs.Properties(strEigenschaftname) = varEigenschaftwert
    EigenschaftÄndern = True

Beenden:
    Exit Function

Fehlerbehandlung:
    If Err = conEigenschaftNichtGefunden_Fehler Then    ' Eigenschaft wurde nicht gefunden.
        Set prp = dbs.CreateProperty(strEigenschaftname, _
            varEigenschafttyp, varEigenschaftwert)
        dbs.Properties.Append prp
        Resume Next
    Else
        ' Unbekannter Fehler.
        EigenschaftÄndern = False
        Resume Beenden
    End If
End Function


AllowFilters-Eigenschaft (FilterZulassen): Beispiel

Das folgende Beispiel zeigt eine Funktion, welche die AllowFilters-Eigenschaft eines Formulars ein- und ausschaltet.

Function FilterZulassenUmschalten() As Integer
    Formulare!Kunden.AllowFilters = Not Formulare!Kunden.AllowFilters
End Function


 AllPermissions-Eigenschaft (MDB)

AllPermissions-Eigenschaft (MDB)

Microsoft Access definiert vier Typen von Container-Objekten zusätzlich zu den Typen, die von der Microsoft Jet-Datenbank-Engine definiert werden: die Container-Objekte für Formulare, Berichte, Skripten oder Module. Die einzelnen Document-Objekte für Formulare, Berichte, Skripten oder Module sind Bestandteil der Documents-Auflistungen dieser Container-Objekte. Für diese Container- und Document-Objekte können Sie auch die Eigenschaft AllPermissions auf folgende Konstanten einstellen.

Konstante | Benutzer oder Gruppe kann
acSecFrmRptReadDef | das Formular oder den Bericht in der Entwurfsansicht öffnen, aber keine Änderungen vornehmen.
acSecFrmRptWriteDef | das Formular oder den Bericht in der Entwurfsansicht ändern oder löschen.
acSecFrmRptExecute | das Formular in der Formularansicht oder Datenblattansicht öffnen oder den Bericht in der Beispielansicht oder Seitenansicht drucken oder öffnen.
acSecMacReadDef | das Makrofenster öffnen und ein Makro anzeigen, aber keine Änderungen vornehmen.
acSecMacWriteDef | das Makro im Makrofenster ändern oder löschen.
acSecModReadDef | das Modul öffnen, aber keine Änderungen vornehmen.
acSecModWriteDef | den Inhalt eines Moduls ändern oder löschen.

Anmerkung acSecModReadDef und acSecModWriteDef wurden nur aus Gründen der Abwärtskompatibilität einbezogen. Da der Modulzugriff jetzt durch die Protection-Eigenschaft in der Visual Basic-Umgebung gesteuert wird, können diese Konstanten in Microsoft Access 2000 nicht mehr als Parameter verwendet werden.


AllPermissions-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel überprüft die Eigenschaft AllPermissions des Container-Objekts Forms und stellt fest, ob der von der Eigenschaft UserName festgelegte Benutzer Vollzugriff auf die Formulare hat.

Der Operator And ermittelt die momentan eingestellten Berechtigungen durch einen bitweisen Vergleich.

Sub AlleBerechtigungenPrüfen()
    Dim dbs As Database, ctr As Container

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Forms-Container zurückgeben.
    Set ctr = dbs.Containers!Forms
    ' Prüfen, ob Eigenschaft "AllPermissions" Vollzugriff einschließt.
    If (ctr.AllPermissions And dbSecFullAccess = _
            dbSecFullAccess) Then
        MsgBox "Benutzer " & ctr.UserName hat Vollzugriff _
            & " auf alle Formulare."
    End If
    Set dbs = Nothing
End Sub


AlwaysSaveInDefaultEncoding-Eigenschaft: Beispiel

Dieses Beispiel legt die Codierung zum Standardzeichensatz fest. Dieser Zeichensatz wird verwendet, wenn Sie eine Datenzugriffsseite als Webseite speichern.

Application.DefaultWebOptions.AlwaysSaveInDefaultEncoding = True


AppIcon und AppTitle-Eigenschaften - Beispiel

Das folgende Beispiel zeigt, wie Sie die Eigenschaften AppIcon und AppTitle einer Microsoft Access-Datenbank (.mdb) ändern können. Wurden diese Eigenschaften noch nicht definiert oder erstellt, so müssen Sie sie neu erstellen und mit Hilfe der CreateProperty-Methode der Properties-Auflistung anfügen.

Sub cmdHinzufügenEigenschaft_Click()
    Dim intX As Integer
    Const DB_Text As Long = 10
    intX = HinzufügenAnwEigenschaft("AppTitle", DB_Text, "Meine Anwendung")
    intX = HinzufügenAnwEigenschaft("AppIcon", DB_Text, "C:\WINDOWS\AUTOS.BMP")
    Application.RefreshTitleBar
End Sub

Function HinzufügenAnwEigenschaft(strName As String, varTyp As Variant, varWert As Variant) As Integer
    Dim dbs As Object, prp As Variant
    Const conPropNotFoundError = 3270

    Set dbs = CurrentDb
    On Error GoTo HinzufügenEigenschaft_Fehler
    dbs.Properties(strName) = varWert
    HinzufügenAnwEigenschaft = True

HinzufügenEigenschaft_Ende:
    Exit Function

HinzufügenEigenschaft_Fehler:
    If Err = conPropNotFoundError Then
      Set prp = dbs.CreateProperty(strName, varTyp, varWert)
      dbs.Properties.Append prp
      Resume
    Else
      HinzufügenAnwEigenschaft = False
      Resume HinzufügenEigenschaft_Ende
    End If
End Function


Application und DBEngine-Eigenschaften - Beispiel

Im folgenden Beispiel werden die DBEngine-Eigenschaften in einem Meldungsfeld angezeigt.

Private Sub Befehl1_Click()
    InfosZuAnwendAnzeigen Me
End Sub

Function InfosZuAnwendAnzeigen(obj As Object) As Integer
    Dim objApp As Object, intI As Integer, strEigensch As String
    On Error Resume Next
    ' Application-Eigenschaft des Formulars
    Set objApp = obj.Application
    MsgBox " Visible-Eigenschaft der Anwendung = " & objApp.Visible
    If objApp.UserControl = True Then
    For intI = 0 To objApp.DBEngine.Properties.Count - 1
        strEigensch = strEigensch & objApp.DBEngine.Properties(intI).Name & ", "
        Next intI
    End If
    MsgBox Left(strEigensch, Len(strEigensch) - 2) & ".", vbOK, "DBEngine-Eigenschaften"
End Function


Assistant-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft Assistant des Objekts Application, um verschiedene Eigenschaften und Methoden des Objekts Assistant zu bearbeiten. Wenn Sie dieses Beispiel ausführen möchten, fügen Sie den folgenden Code in den Deklarationsbereich eines Standardmoduls ein. Erstellen Sie unter Verwendung des Dialogfelds Verweise einen Verweis auf die Microsoft Office 9.0 Object Library. (Zum Öffnen des Dialogfelds klicken Sie im Menü Extras auf Verweise.) Klicken Sie anschließend auf eine beliebige Stelle in der Prozedur, und drücken Sie F5, um die Prozedur auszuführen.

Sub AnimateAssistant()
    Dim blnStatus As Boolean
    With Assistant
        ' Anzeigestatus des Assistenten speichern.
        blnStatus = .Visible
        ' Assistent einblenden.
        If blnStatus = False Then .Visible = True
        ' Animation des Assistenten.
        .Animation = msoAnimationAppear
        ' Die Eigenschaften "Item" und "FileName" des "Assistant"-
        ' Objekts anzeigen.
        MsgBox "Hallo, mein Name ist " & .Item & ". Ich wohne in " & _         FileName, , "Assistenteninformation:"
        ' Anzeigestatus des Assistenten auf ursprüngliche Einstellung
        ' zurücksetzen.
        .Visible = blnStatus
    End With
End Sub


Attributes-Eigenschaft (MDB)

Wenn Sie die Eigenschaft Attributes eines TableDef-Objekts auf dbHiddenObject einstellen, blendet Microsoft Access das TableDef-Objekt aus. Das TableDef-Objekt existiert in der Auflistung TableDefs. Sie können es jedoch im Datenbankfenster nicht sehen, selbst wenn Sie im Dialogfeld Optionen (aus dem Menü Extras) das Kontrollkästchen Ausgeblendete Objekte anzeigen aktiviert haben.

Um ein TableDef-Objekt zu erstellen, das ausgeblendet oder sichtbar sein kann, stellen Sie die Eigenschaft Attributes auf dbSystemObject ein. Sie können dann das TableDef-Objekt im Datenbankfenster sichtbar machen, indem Sie im Dialogfeld Optionen das Kontrollkästchen Ausgeblendete Objekte anzeigen aktivieren.


Attributes-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel überprüft die Eigenschaft Attributes für jede Tabelle in der aktuellen Datenbank und gibt die Namen der Systemtabellen und ausgeblendeten Tabellen aus, die von der Microsoft Jet-Datenbank-Engine bereitgestellt werden.

Der Operator And ermittelt durch einen bitweisen Vergleich, ob ein Attribut momentan gesetzt ist.

Sub AttributePrüfen()
    Dim dbs As Database, tdf As TableDef

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    For Each tdf In dbs.TableDefs
        ' Eigenschafteneinstellung und Konstante vergleichen.
        If (tdf.Attributes And dbSystemObject) Or _
                (tdf.Attributes And dbHiddenObject) Then
            Debug.Print tdf.Name
        End If
    Next tdf
    Set dbs = Nothing
End Sub


BaseConnectionString-Eigenschaft: Beispiel

Das folgende Beispiel zeigt die BaseConnectionString-Eigenschaft des aktuellen Projekts an:

Dim objAktuellesProjekt As Object
Set objAktuellesProjekt = Application.CurrentProject
MsgBox "Die aktuell gültige Hauptverbindungszeichenfolge lautet: " _
    & objAktuellesProjekt.BaseConnectionString


 BeginGroup-Eigenschaft

BeginGroup-Eigenschaft

Wenn Sie in Microsoft Access 2000 bestimmen möchten, ob ein Steuerelement auf einer Befehlsleiste sich am Anfang einer Gruppe von Steuerelementen befindet, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Eine Trennlinie wird vor dem Steuerelement auf der Befehlsleiste angezeigt. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen BeginGroup-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenüs in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Aktivieren Sie das Kontrollkästchen Eine Gruppe beginnen oder entfernen Sie die Markierung.

Die Trennlinie, die am Anfang einer Gruppe von Steuerelementen angezeigt wird, ist selbst kein Steuerelement und hat keinen Einfluss auf das Zählen oder Indizieren in der CommandBarControls-Auflistung.


BOF-, EOF-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel verwendet zuerst die Eigenschaft EOF eines Recordset-Objekts, um den aktuellen Datensatzzeiger hinter den letzten Datensatz im Recordset-Objekt zu verschieben, und dann die Eigenschaft BOF, um den aktuellen Datensatzzeiger vor den ersten Datensatz im Recordset-Objekt zu setzen.

Sub VorHinterDatei()
    Dim dbs As Database, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Datensatz für Tabelle Bestellungen öffnen.
    Set rst = dbs.OpenRecordset("Bestellungen")
    ' Wiederholen bis zum Dateiende.
    Do Until rst.EOF
        ' Zum nächsten Datensatz wechseln.
        rst.MoveNext
        .
        .
        .
    Loop
    ' Zum letzten Datensatz wechseln, um einen aktuellen Datensatz
    ' festzulegen.
    rst.MoveLast
    ' Wiederholen bis zum Dateianfang.
    Do Until rst.BOF
        rst.MovePrevious
        .
        .
        .
    Loop
    rst.Close
    Set dbs = Nothing
End Sub


Bookmark-Eigenschaft

Die Bookmark-Eigenschaft bezieht sich auf das Recordset-Objekt. Sie können Sie nur unter Verwendung von Visual Basic einstellen.

Anmerkung Verwechseln Sie diese Eigenschaft nicht mit der Microsoft Access-Eigenschaft Bookmark, die sich auf ein Form-Objekt bezieht und ein Lesezeichen für einen bestimmten Datensatz in der Tabelle oder Abfrage speichert, die dem Formular zugrundeliegt. Diese beiden Eigenschaften beeinflussen sich gegenseitig nicht. Sie können gleichzeitig unterschiedliche Lesezeichen in einem Formular und in einem Objekt Recordset verwenden.


Bookmark-Eigenschaft: Beispiel

Um folgendes Beispiel mit der Nordwind-Beipieldatenbank testen zu können, müssen Sie die Befehlsschaltfläche cmdKontaktSuchen in das Formular Lieferanten einfügen und dann zum Click-Ereignis der Schaltfläche den folgenden Code hinzufügen. Nach dem Anklicken der Schaltfläche wird der Benutzer dazu aufgefordert, einen Teil des Namens der gesuchten Kontaktperson einzugeben. Wird der Name gefunden, wird die Bookmark-Eigenschaft des Formulars durch die ADO-Eigenschaft Bookmark des Recordset-Objekts ersetzt, wodurch der Datensatz, der den Namen enthält, der aktuelle Datensatz des Formulars wird.

Private Sub cmdKontaktSuchen_Click()
 Dim rst As adodb.Recordset, strSuchkriterien As String
 strSuchkriterien = "[Kontakt] Like '*" & InputBox("Geben Sie " _
 & "die ersten Buchstaben des gesuchten Namens ein ") & "*'"

 Set rst = Me.RecordsetClone
 rst.FindFirst strSuchkriterien
 If rst.NoMatch Then
 MsgBox "Kein Eintrag"
 Else
 Me.Bookmark = rst.Bookmark
 End If
End Sub


BorderColor-, BackColor-, ForeColor-Eigenschaft (Rahmenfarbe, Hintergrundfarbe, Textfarbe) - Beispiel

Im folgenden Beispiel werden die Eigenschaften BorderColor, BackColor und ForeColor mit der Funktion RGB abhängig davon eingestellt, welchen Wert das Textfeld txtÜberfällig hat. Sie können diese Eigenschaften auch mit der Funktion QBColor einstellen. Wird der folgende Code in die Ereignisprozedur Form_Current( ) eingefügt, werden die Farbmerkmale für die Anzeige des Textfelds eingestellt, sobald der Benutzer das Formular öffnet oder zu einem anderen Datensatz wechselt.

Sub Form_Current()
    Dim curFälligerBetrag As Currency, lngSchwarz As Long
    Dim lngRot As Long, lngGelb As Long, lngWeiß As Long

    If Not IsNull(Me!txtÜberfällig.Value) Then
        curFälligerBetrag = Me!txtÜberfällig.Value
    Else
        Exit Sub
    End If
    lngRot = RGB(255, 0, 0)
    lngSchwarz = RGB(0, 0, 0)
    lngGelb = RGB(255, 255, 0)
    lngWeiß = RGB(255, 255, 255)
    If curFälligerBetrag > 100 Then
        Me!txtÜberfällig.BorderColor = lngRot
        Me!txtÜberfällig.ForeColor = lngRot
        Me!txtÜberfällig.BackColor = lngGelb
    Else
        Me!txtÜberfällig.BorderColor = lngSchwarz
        Me!txtÜberfällig.ForeColor = lngSchwarz
        Me!txtÜberfällig.BackColor = lngWeiß
    End If
End Sub


BuiltIn-Eigenschaft - Beispiel

Im folgenden Beispiel werden die Standardverweise der References-Auflistung ausgegeben:

Sub NurStandardverweise()
    Dim ref As Reference

    ' Die References-Auflistung in einer Schleife durchlaufen.
    For Each ref In References
        ' Die Eigenschaft BuiltIn auswerten.
        If ref.BuiltIn = True Then
            Debug.Print ref.Name
        End If
    Next ref
End Sub


 Calendar-Eigenschaft

Calendar-Eigenschaft

Sprachspezifische Informationen

The Calendar property specifies or determines a value that indicates the calendar to be used by Visual Basic date-related functions.

Setting

The Calendar property uses the following settings.

Setting | Visual Basic | Description
Gregorian | 0 | (Default) Gregorian calendar will be used for Visual Basic date-related calculations and formatting.
Hijri | 1 | Hijri calendar will be used Visual Basic date-related calculations and formatting.

Note Microsoft Access 2000 date-related processing is done in Visual Basic. When Access 2000 opens a database, the Calendar property for Visual Basic is set according to the value of the Calendar database property. If a Visual Basic procedure changes the Visual Basic Calendar property, it is the responsibility of the procedure to restore the Calendar setting needed by Access 2000 before quitting.

The language of Hijri month names is always Arabic. Hijri month names are always returned in full month name format.

For more information about the Calendar database property, see Use database calendars.


Calendar-Eigenschaft - Beispiel

The following example creates a function to convert dates strings between the supported calendar systems. The example code that follows uses the function to convert a Gregorian date string to the equivalent Hijri string in long date format.

Function ConvertDateString ( _
        ByRef StringIn As String, _
        ByVal OldCalendar As Integer, _
        ByVal NewCalendar As Integer, _
        ByRef NewFormat As String) As String
    Dim SavedCal As Integer
    Dim d As Date
    Dim s As String

    ' Save Access calendar to restore when finished
    SavedCal = Calendar

    ' Convert date to new calendar and format
    Calendar = OldCalendar    ' Change to StringIn calendar
    d = Cdate (StringIn)        ' Convert from String to Date
    Calendar = NewCalendar    ' Change to calendar of new string
    s = CStr(d)            ' Convert to short format String
    ConvertDateString = Format (s, NewFormat)    'Reformat
    Calendar = SavedCal
End Function

Call ConvertDateString function from a procedure to perform conversion…

Sub MySub
    Dim GregorianDate As String
    Dim HijriDate As String
    Dim GregorianCalendar As Integer
    Dim HijriCalendar As Integer
    Dim HijriFormat As String
    GregorianDate = #12/31/93#
    GregorianCalendar = 0
    HijriCalendar = 1
    HijriFormat = "Long Date"
    ' Returns 7/18/1414
    HijriDate = ConvertDateString (GregorianDate, _
        GregorianCalendar, HijriCalendar, HijriFormat)
End Sub


 Caption-Eigenschaft (Befehlsleisten)

Caption-Eigenschaft (Befehlsleisten)

Wenn Sie in Microsoft Access 2000 die Beschriftung für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen Caption-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie die gewünschte Beschriftung im Feld Name ein.

Wenn Sie die Einstellung der Caption-Eigenschaft eines Steuerelements im Dialogfeld Symbolleiste Steuerelementeigenschaften oder in Visual Basic anzeigen, wird das Und-Zeichen (&) für die Zugriffstaste angezeigt (z. B. &Einfügen). Wenn Sie in Visual Basic auf das Steuerelement verweisen, können Sie wählen, ob das Und-Zeichen angezeigt wird oder nicht. Die beiden folgenden Verweise haben z. B. dieselbe Bedeutung:

CommandBars("Menüleiste").Controls("Extras")
CommandBars("Menüleiste").Controls("&Extras")

Wenn Sie die Caption-Eigenschaft einstellen, müssen Sie das Und-Zeichen angeben, wenn Sie eine Zugriffstaste für das Steuerelement definieren möchten.


CheckIfOfficeIsHTMLEditor-Eigenschaft: Beispiel

Dieses Beispiel legt fest, dass zur Bearbeitung einer Webseite der im System definierte Standard-HTML-Editor (statt einer Office-Anwendung) benutzt werden soll.

Application.DefaultWebOptions.CheckIfOfficeIsHTMLEditor = False


CodeContextObject-Eigenschaft - Beispiel

In diesem Beispiel wird die Eigenschaft CodeContextObject in einer Funktion verwendet, um den Namen des Objekts zu ermitteln, in dem ein Fehler auftrat. Der Name des Objekts wird dann sowohl in der Titelleiste des Meldungsfelds als auch im eigentlichen Text der Fehlermeldung verwendet. Die Anweisung Error wird in der Ereignisprozedur Befehl1_Click() verwendet, um für dieses Beispiel den Fehler zu provozieren.

Private Sub Befehl1_Click()
    On Error GoTo Befehl1_Fehler
    Error 11            ' Den Fehler "Division durch 0" provozieren.
    Exit Sub

    Befehl1_Fehler:
        If FehlerMeldung("Ereignisprozedur Befehl1_Click()", vbYesNo + _
                vbInformation, Err) = vbYes Then
            Exit Sub
        Else
            Resume
        End If
End Sub

Function FehlerMeldung(strText As String, intTyp As Integer, _
        intFehlernummer As Integer) As Integer
    Dim objAktuell As Object
    Dim strMldgFeldTitel As String
    Set objAktuell = CodeContextObject
    strMldgFeldTitel = "Fehler in " & objAktuell.Name
    strText = strText & ": der Fehler mit der Nummer " & _
    intFehlernummer & " trat in " & objAktuell.Name & " auf."
    FehlerMeldung = MsgBox(strText, intTyp, strMldgFeldTitel)
    Err = 0
End Function


CollatingOrder-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel überprüft die Eigenschaft CollatingOrder für die aktuelle Datenbank.

Sub SortierreihenfolgePrüfen()
    Dim dbs As Database

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Eigenschaft "CollatingOrder" für die Datenbank überprüfen.
    Debug.Print dbs.CollatingOrder
    Set dbs = Nothing
End Sub


ColumnHeadings-Eigenschaft (FixierteSpaltenüberschriften) - Beispiel

Das folgende Beispiel erstellt vier Spaltenüberschriften (Qtl. 1, Qtl. 2, Qtl. 3, Qtl. 4) in der Datenblattansicht einer Kreuztabellenabfrage, durch die die Bestellungen je Artikel und Quartal aufgelistet werden. Sie geben diese Anweisung in der SQL-Ansicht des Abfragefensters ein.

TRANSFORM Sum(CCur(Bestelldetails.Einzelpreis * Bestelldetails.Anzahl * (1-[Rabatt])/100) * 100)
AS Produktmenge SELECT Artikel.Artikelname FROM Artikel
INNER JOIN (Bestellungen INNER JOIN Bestelldetails ON Bestellungen.[Bestell-Nr] = Bestelldetails.[Bestell-Nr]
ON Artikel.[Artikel-Nr]= Bestelldetails.[Artikel-Nr]
WHERE (((Bestellungen.Versanddatum) Between #1/1/96# And #12/31/96#))
GROUP BY Artikel.Artikelname PIVOT "Qtl " & DatePart("q",[Versanddatum],1,0);


ColumnHidden-Eigenschaft: Beispiel

Dieses Beispiel blendet das Feld Artikel-Nr des Formulars Artikel in der Datenblattansicht aus.

Formulare! Artikel![Artikel-Nr].ColumnHidden = -1

Das folgende Beispiel blendet auch das Feld Artikel-Nr der Tabelle Artikel in der Datenblattansicht aus. Zur Einstellung der ColumnHidden-Eigenschaft verwendet das Beispiel die Prozeduren SpalteAnzeigen und FeldeigenschaftFestlegen, die sich im Standardmodul der Datenbank befinden.

Dim dbs As Objekt
Set dbs = CurrentDb
SpalteAnzeigen dbs.TableDefs!Artikel.Fields!Artikel-Nr, False

Sub SpalteAnzeigen(fldSpaltenobjekt As Variant, intAnzeigen As Integer)
    ' Eigenschaft Set ColumnHidden setzen.
    FeldeigenschaftFestlegen fldSpaltenobjekt, "ColumnHidden", dbLong, Not intAnzeigen
End Sub

Sub FeldeigenschaftFestlegen(fldFeld As Variant, strEigenschaftname As String, _
    intEigenchafttyp As Integer, varEigenschaftwert As Variant)
    ' Feldeigenschaft setzen, ohne nicht behebbare Laufzeitfehler zu erzeugen.
    Const conEigenschaftNichtGefunden_Fehler = 3270
    Dim prpEigenschaft As Variant
    On Error Resume Next ' Fehler nicht abfangen.
    fldFeld.Properties(strEigenschaftname) = varEigenschaftwert
    If Err <> 0 Then ' Fehler beim Setzen des Wertes aufgetreten.
        If Err <> conEigenschaftNichtGefunden_Fehler Then
            On Error GoTo 0
            MsgBox "Eigenschaft konnte nicht eingestellt werden '" & strEigenschaftname _
            & "' in Feld '" & fldFeld.name & "'", 48, "FeldeigenschaftFestlegen"
        Else
            On Error GoTo 0
            Set prpEigenschaft = fldFeld.CreateProperty(strEigenschaftname, _
            intEigeneschafttyp, varEigenschaftwert)
            fldFeld.Properties.Append prpEigenschaft
        End If
    End If
End Sub


ColumnOrder-Eigenschaft: Beispiel

Das folgende Beispiel zeigt die Felder Artikelname und Liefereinheit in den ersten beiden Spalten in der Datenblattansicht des Formulars Artikel an.

Formulare! Artikel! Artikelname.ColumnOrder = 1
Formulare! Artikel! Liefereinheit.ColumnOrder = 2

Das nächste Beispiel zeigt die Felder Artikelname und Liefereinheit in den ersten beiden Spalten der Tabelle Artikel in der Datenblattansicht an. Zur Einstellung der ColumnOrder-Eigenschaft verwendet das Beispiel die Prozedur FeldEigEinstellen. Wird die Prozedur ausgeführt, während die Tabelle geöffnet ist, werden die Veränderungen erst nach dem erneuten Öffnen der Tabelle angezeigt.

Dim dbs As Database, tdfArtikel As TableDef
Set dbs = CurrentDb
Set tdfArtikel = dbs!Artikel
FeldEigEinstellen tdfArtikel!Artikelname, "ColumnOrder", dbLong, 2
FeldEigEinstellen tdfArtikel!Liefereinheit, "ColumnOrder", dbLong, 3

Sub FeldEigEinstellen(fldFeld As Field, strEigenschaftName As String, _
    intEigenschaftTyp As Integer, varEigenschaftWert As Variant)
    ' Feldeigenschaft einstellen, ohne Laufzeitfehler auszulösen, der zum Programmabbruch führt.
    Const conErrPropertyNotFound = 3270
    Dim proEigenschaft As Property
    On Error Resume Next ' Fehler nicht auffangen.
    fldField.Properties(strEigenschaftName) = varEigenschaftWert
    If Err <> 0 Then ' Fehler beim Festlegen des Wertes.
        If Err <> conErrPropertyNotFound Then
            On Error GoTo 0
            MsgBox " Eigenschaft konnte nicht gesetzt werden für '" & strEigenschaftName _
            & "' Feld '" & fldFeld.name & "'", 48, "FeldEigEinstellen"
        Else
            On Error GoTo 0
            Set proEigenschaft = fldField.CreateProperty(strEigenschaftName, _
            intEigenschaftTyp, varEigenschaftWert)
            fldFeld.Properties.Append proEigenschaft
        End If
    End If
End Sub


Column-, ColumnCount-Eigenschaften (Spalte, Spaltenanzahl) - Beispiel

Das folgende Beispiel verwendet die Eigenschaften Column und ColumnCount zum Ausgeben der Werte einer Listenfeldauswahl.

Sub Listenfeld_lesen()
    Dim intAnzSpalten As Integer, intI As Integer
    Dim frmKunde As Form

    Set frmKunde = Formulare!frmKunden
    If frmKunde![lstKundennamen].ItemsSelected.Count > 0 Then
        ' Auswahl getroffen?
        intAnzSpalten = frmKunde!lstKundennamen.ColumnCount
        Debug.Print "Das Listenfeld enthält "; intAnzSpalten; _
            IIf(intAnzSpalten = 1, " Spalte", " Spalten"); _
             " mit Daten."
        Debug.Print "Die aktuelle Auswahl enthält:"
        For intI = 0 To intAnzSpalten - 1
            ' Spaltendaten ausgeben.
            Debug.Print frmKunde!lstKundennamen.Column(intI)   '
        Next intI
    Else
        Debug.Print "Sie haben keinen Eintrag im Listenfeld ausgewählt."
    End If
End Sub


CommandBars-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft CommandBars des Objekts Application, um verschiedene Eigenschaften und Methoden des Auflistungsobjekts CommandBars zu bearbeiten. Wenn Sie dieses Beispiel ausführen möchten, fügen Sie den folgenden Code in den Deklarationsbereich eines Standardmoduls ein. Erstellen Sie unter Verwendung des Dialogfelds Verweise einen Verweis auf die Microsoft Office 9.0 Object Library. (Zum Öffnen des Dialogfelds klicken Sie im Menü Extras auf Verweise.) Klicken Sie anschließend auf eine beliebige Stelle in der Prozedur GetCommandBarInfo, und drücken Sie F5, um die Prozedur auszuführen.

Sub GetCommandBarInfo()
    Dim strBefehlsleistenname As String

    strBefehlsleistenname = InputBox("Geben Sie den Namen einer Befehlsleiste ein", "Abrufen der Befehlsleisteninformation", "Menu Bar")
    If Len(strBefehlsleistenname) > 0 Then
        CommandBarInfo strBefehlsleistenname
    End If
End Sub

Sub CommandBarInfo(strBefehlsleistenname As String)
    Dim cbr As CommandBar

    On Error Resume Next
    Set cbr = CommandBars(strBefehlsleistenname)
    If Err = 0 then
        With cbr
            MsgBox "Die Befehlsleiste '" & .Name & "' enthält " & _
                .Controls.Count & IIf(.Controls.Count = 1, " Steuerelement und ", _
                " Steuerelemente und ") & IIf(.BuiltIn, "ist eine", "ist keine") & _
                " eingebaute Symbolleiste", vbOKOnly, "'" & _
                .Name & "' Information:"
        End With
    Else
        MsgBox "Ungültiger Befehlsleistenname"
    End If
End Sub


 Type-Eigenschaft (Befehlsleisten)

Type-Eigenschaft (Befehlsleisten)

Wenn Sie in Microsoft Access 2000 den Typ einer benutzerdefinierten Menüleiste, Symbolleiste oder eines benutzerdefinierten Kontextmenüs ändern möchten, können Sie das Dialogfeld Symbolleisteneigenschaften verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen. Klicken Sie anschließend im Dialogfeld Anpassen auf die Schaltfläche Eigenschaften. Wählen Sie im Feld Ausgewählte Symbolleiste die gewünschte benutzerdefinierte Menüleiste, Symbolleiste oder das benutzerdefinierte Kontextmenü, und wählen Sie anschließend im Feld Typ den neuen Typ für die Menüleiste, Symbolleiste oder das Kontextmenü. Sie können den Typ von eingebauten Menüleisten, Symbolleisten oder Kontextmenüs nicht ändern.

Wenn Sie den Typ einer Befehlsleiste auf Popup einstellen, wird die Befehlsleiste aus der Liste Symbolleisten im Dialogfeld Anpassen entfernt. Sie wird in die Menüleiste verschoben, die angezeigt wird, wenn Sie das Feld Kontextmenü in der Liste Symbolleisten auswählen (diese Menüleiste zeigt alle Kontextmenüs in Microsoft Access an).


ConnectionString-Eigenschaft: Beispiel

Das folgende Beispiel zeigt den Wert der ConnectionString-Eigenschaft für die aktuell aktive Datenzugriffsseite an:

Dim objAktuelleSeite As Object
Set objAktuelleSeite = Application.DataAccessPages(0)
MsgBox "Die aktuell gültige Hauptverbindungszeichenfolge lautet: " _
    & objAktuelleSeite.ConnectionString


Connect-, SourceTableName-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel erstellt ein TableDef-Objekt in der angegebenen Datenbank. Die Prozedur stellt dann dessen Eigenschaften Connect und SourceTableName ein und fügt das Objekt zur TableDefs-Auflistung hinzu.

Sub HerkunftVerbinden()
    Dim dbs As Database, tdf As TableDef

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neues TableDef-Objekt erstellen.
    Set tdf = dbs.CreateTableDef("PDXAutor")
    ' Paradox-Tabelle "Autor" in Datenbank C:\PDX\Publish einbinden.
    tdf.Connect = "Paradox 4.X;Database=C:\PDX\Publish"
    tdf.SourceTableName = "Autor"
    dbs.TableDefs.Append tdf
    Set dbs = Nothing
End Sub


Container-, Permissions-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel ermittelt den Namen des Container-Objekts, zu dem ein Document-Objekt gehört, und stellt Berechtigungen entsprechend den festgelegten Gruppenkonten ein. Denken Sie daran, dass Sie ein einzelnes Benutzer- oder Gruppenkonto kennzeichnen, bevor Sie Berechtigungen für ein Objekt einstellen. Das folgende Beispiel setzt voraus, dass Sie eine Gruppe mit dem Namen Marketing definiert haben.

Microsoft Access definiert zusätzliche Container-Objekte über die von der Microsoft Jet-Datenbank-Engine definierten Objekte hinaus. Diese enthalten die Container-Objekte Forms, Reports, Scripts und Modules.

Der Operator Or ermittelt durch einen bitweisen Vergleich, ob ein Attribut momentan gesetzt ist.

Sub DokAnalyse(docUnbekannt As Document)
    Dim strContainerName As String

    ' Eigenschaft "UserName" auf gültiges, bestehendes Gruppenkonto einstellen.
    docUnbekannt.UserName = "Marketing"
    ' Wert der Eigenschaft "Container" abrufen.
    strContainerName = docUnbekannt.Container.Name
    Select Case strContainerName
        Case "Forms"
            ' Berechtigungen für das Document-Objekt "Form" festlegen.
            docUnbekannt.Permissions = docUnbekannt.Permissions Or _
                acSecFrmRptWriteDef
        Case "Reports"
            ' Berechtigungen für das Document-Objekt "Report" festlegen.
            docUnbekannt.Permissions = docUnbekannt.Permissions Or _
                acSecFrmRptExecute
        Case "Scripts"
            ' Berechtigungen für das Document-Objekt "Script" festlegen.
            docUnbekannt.Permissions = docUnbekannt.Permissions Or _
                acSecMacWriteDef
        Case "Modules"
            ' Berechtigungen für das Document-Objekt "Module" festlegen.
            docUnbekannt.Permissions = docUnbekannt.Permissions Or _
                acSecModReadDef
        Case Else
            Exit Sub
    End Select
End Sub


Context-Eigenschaft

Diese Eigenschaft wird in Microsoft Access nicht unterstützt.


ControlBox-Eigenschaft (MitSystemmenüfeld) - Beispiel

Dieses Beispiel stellt die Eigenschaft ControlBox im Formular Warnung auf False (0) ein.

Formulare!Warnung.ControlBox = False


ControlSource-Eigenschaft (Steuerelementinhalt) - Beispiel

Das folgende Beispiel stellt die Eigenschaft ControlSource für ein Textfeld namens Adressenteil auf ein Feld namens Ort ein.

Formulare!Kunden!Adressenteil.ControlSource = "Ort"

Das nächste Beispiel stellt die Eigenschaft ControlSource für ein Textfeld namens Erwartet auf den Ausdruck = Date() + 7 ein.

Me!Erwartet.ControlSource = "=Date() + 7"


ControlType-, AllowAdditions-, AllowDeletions-, AllowEdits-Eigenschaften (Steuerelementtyp, AnfügenZulassen, LöschenZulassen, BearbeitungenZulassen) - Beispiel

Das folgende Beispiel wertet die Eigenschaft ControlType für alle Steuerelemente eines Formulars aus. Für jedes Bezeichnungsfeld- und Textfeld-Steuerelement schaltet die Prozedur die jeweilige Eigenschaft SpecialEffect um. Wenn die Eigenschaft SpecialEffect des Bezeichnungsfeld-Steuerelements auf Schattiert und die Eigenschaft SpecialEffect des Textfeld-Steuerelements auf Normal eingestellt ist, und die Eigenschaften AllowAdditions, AllowDeletions und AllowEdits auf True eingestellt sind, wird die Variable intBearbMöglich umgeschaltet, um das Bearbeiten der zugrunde liegenden Daten zu erlauben.

Sub UmschaltSteuerelement(frm As Form)
    Dim ctl As Control
    Dim intI As Integer, intBearbMöglich As Integer
    Const conTransparent = 0
    Const conWhite = 16777215
    For Each ctl in frm.Controls
        With ctl
            Select Case .ControlType
                Case acLabel
                    If .SpecialEffect = acEffectShadow Then
                        .SpecialEffect = acEffectNormal
                        .BorderStyle = conTransparent
                        intBearbMöglich = True
                    Else
                        .SpecialEffect = acEffectShadow
                        intBearbMöglich = False
                    End If
                Case acTextBox
                    If .SpecialEffect = acEffectNormal Then
                        .SpecialEffect = acEffectSunken
                        .BackColor = conWhite
                    Else
                        .SpecialEffect = acEffectNormal
                        .BackColor = frm.Detail.BackColor
                    End If
            End Select
        End With
    Next ctl
    If intBearbMöglich = False Then
        With frm
            .AllowAdditions = False
            .AllowDeletions = False
            .AllowEdits = False
        End With
    Else
        With frm
            .AllowAdditions = True
            .AllowDeletions = True
            .AllowEdits = True
        End With
    End If
End Sub


CountOfLines-, CountOfDeclarationLines-Eigenschaften - Beispiel

Im folgenden Beispiel werden für ein Standardmodul, das zur Modules-Auflistung gehört, die Anzahl aller Zeilen sowie die Anzahl der Deklarationszeilen ermittelt. Zu beachten ist, dass die Modules-Auflistung nur Module enthält, die im Moduleditor geöffnet sind.

Function AnzahlModulzeilen(strModulname As String)
    Dim mdl As Module

    ' Das Modul öffnen, das zur Modules-Auflistung
    ' hinzugefügt werden soll.
    DoCmd.OpenModule strModulname
    ' Den Verweis auf das Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
    ' Die Anzahl der Zeilen des Moduls ausgeben.
    Debug.Print "Anzahl der Zeilen: ", mdl.CountOfLines
    ' Die Anzahl der Deklarationszeilen ausgeben.
    Debug.Print "Anzahl der Deklarationszeilen: ", _
        mdl.CountOfDeclarationLines
End Function


Count-Eigenschaft (Anzahl) - Beispiel

Im folgenden Beispiel wird die Eigenschaft Count zum Steuern einer Schleife verwendet, die Informationen über alle geöffneten Formulare sowie deren Steuerelemente ausgibt.

Sub AnzeigenFormularSteuerelem()
    Dim frm As Form, intI As Integer
    Dim intJ As Integer
    Dim intSteuerelem As Integer, intFormulare As Integer
    intFormulare = Forms.Count    ' Anzahl der geöffneten Formulare.
    If intFormulare > 0 Then
        For intI = 0 To intFormulare - 1
            Set frm = Forms(intI)
            Debug.Print frm.Name
            intSteuerelem = frm.Count
            If intSteuerelem > 0 Then
                For intJ = 0 To intSteuerelem - 1
                    Debug.Print vbTab; frm(intJ).Name
                Next intJ
            Else
                Debug.Print vbTab; "(Keine Steuerelemente)"
            End If
        Next intI
    Else
        MsgBox "Es ist kein Formular geöffnet.", vbExclamation, _
        "Steuerelemente der Formulare"
    End If
End Sub

Das nächste Beispiel ermittelt die Anzahl der Steuerelemente eines Formulars sowie eines Berichts und weist die jeweilige Zahl einer Variablen zu.

Dim intFormControls As Integer
Dim intReportControls As Integer
intFormControls = Formulare!Personal.Count
intReportControls = Reports!Frachtkosten.Count


CurrentObjectType-, CurrentObjectName-Eigenschaften - Beispiel

Das folgende Beispiel verwendet die Eigenschaften CurrentObjectType und CurrentObjectName zusammen mit der Funktion SysCmd, um zu ermitteln, ob das aktive Objekt das Formular Artikel ist und ob dieses Formular geöffnet ist und geändert, aber nicht gespeichert wurde. Wenn diese Bedingungen erfüllt sind, wird das Formular gespeichert und dann geschlossen.

Sub ArtikelPrüfen()
    Dim intZustand As Integer
    Dim intAktuellerTyp As Integer
    Dim strAktuellerName As String

    intAktuellerTyp = Application.CurrentObjectType
    strAktuellerName = Application.CurrentObjectName
    If intAktuellerTyp = acForm And strAktuellerName = " Artikel " Then
        intZustand = SysCmd(acSysCmdGetObjectState, intAktuellerTyp, _
             strAktuellerName)
        ' Formular "Artikel" wurde geändert, aber nicht gespeichert.
        If intZustand = acObjStateDirty + _
            acObjStateOpen Then
            ' Formular "Artikel" schließen und Änderungen speichern.
            DoCmd.Close intAktuellerTyp, _
                strAktuellerName, acSaveYes
        End If
    End If
End Sub


CurrentPage-, PageCount-Eigenschaften - Beispiel

Das folgende Beispiel zeigt, wie die Eigenschaften CurrentPage und PageCount verwendet werden, um zu einer Seite innerhalb einer Snapshot-Datei zu wechseln.

Sub Wechseln()
    Dim lngSeitenzahl As Long
    Dim snpCtl As SnapshotViewer
    Set snpCtl = Me.SnapShot1.Object
    lngSeitenzahl = InputBox("Bitte die gewünschte Snapshotseite eingeben")
    If IsNumeric(lngSeitenzahl) And Len(lngSeitenzahl) > 0 Then
        If lngSeitenzahl <= snpCtl.PageCount Then
            snpCtl.CurrentPage = lngSeitenzahl
        Else
            Msgbox "Bitte Wert eingeben zwischen 1 und " _
                & snpCtl.PageCount
            Exit Sub
        End If
    End If
End Sub


CurrentRecord-Eigenschaft - Beispiel

Das folgende Beispiel zeigt, wie Sie mit Hilfe der Eigenschaft CurrentRecord die Datensatznummer des aktuell angezeigten Datensatzes bestimmen können. Die allgemein verwendbare Prozedur AktuellerFormularDatensatz weist den Wert des aktuellen Datensatzes der Variablen lngDatensatznr zu.

Sub AktuellerFormularDatensatz(frm As Form)
    Dim lngDatensatznr As Long

    lngDatensatznr = frm.CurrentRecord
End Sub


CurrentSectionLeft-, CurrentSectionTop-Eigenschaften (AktuellerBereichLinks, AktuellerBereichOben) - Beispiel

Das folgende Beispiel zeigt die Einstellungen der Eigenschaften CurrentSectionLeft und CurrentSectionTop für ein Steuerelement in einem Endlosformular an. Wenn der Benutzer zu einem neuen Datensatz wechselt, werden die Eigenschafteneinstellungen des aktuellen Bereichs im Bezeichnungsfeld lblStatus im Kopfbereich des Formulars angezeigt.

Private Sub Form_Current()
    Dim intAktOben As Integer, intAktLinks As Integer

    intAktOben = Me.CurrentSectionTop
    intAktLinks = Me.CurrentSectionLeft
    Me!lblStatus.Caption = intAktLinks & " , " & intAktOben
End Sub


CurrentView-Eigenschaft (AktuelleAnsicht) - Beispiel

Im folgenden Beispiel wird mit der Unterroutine AktuelleAnsichtErmitteln ermittelt, ob das aktuelle Formular in der Formularansicht oder der Datenblattansicht angezeigt wird. Wird es in der Formularansicht angezeigt, wird dies dem Benutzer in einem Textfeld des Formulars mitgeteilt; wird es in der Datenblattansicht angezeigt, wird dieselbe Meldung in einem Meldungsfeld angezeigt.

AktuelleAnsichtErmitteln Me, "Wenden Sie sich an den Systemadministrator."

Sub AktuelleAnsichtErmitteln(frm As Form, strMeldung As String)
    Const conFormularansicht = 1
    Const conDatenblattansicht = 2
    Dim intAnsicht As Integer
    intAnsicht = frm.CurrentView
    Select Case intAnsicht
        Case conFormularansicht
            frm!TextfeldFürMeldung.SetFocus
            ' Die Meldung im Textfeld anzeigen.
            frm!TextfeldFürMeldung = strMeldung
        Case conDatenblattansicht
            ' Die Meldung in einem Meldungsfeld anzeigen.
            MsgBox strMeldung
    End Select
End Sub


AllowZeroLength-Eigenschaft (LeereZeichenfolge) - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Field-Objekt und stellt dessen Eigenschaft AllowZeroLength auf True (-1) ein.

Sub FeldlängeNull()
    Dim dbs As Database, tdf As TableDef, fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Neues Feld in Tabelle Personal erstellen.
    Set fld = tdf.CreateField("Partner/in", dbText, 15)
    ' Leere Zeichenfolgen im Feld zulassen.
    fld.AllowZeroLength = True
    ' Field-Objekt anfügen.
    tdf.fields.Append fld
    Set dbs = Nothing
End Sub


Bookmark-, Bookmarkable-Eigenschaften - Beispiel (MDB)

Im folgenden Beispiel werden alle Datensätze der Tabelle Personal vom Dateianfang bis zum Dateiende durchlaufen, wobei der Wert der Eigenschaft Bookmark für jeden Datensatz in einem Datenfeld gespeichert wird.

' Geben Sie folgende Anweisung im Deklarationsbereich des Moduls an.
Option Compare Binary

Sub Datensatzpositionen()
    Dim dbs As Database, rst As Recordset, fld As Field
    Dim intI As Integer
    ' Datenfeld zum Speichern der Lesezeichen deklarieren.
    Dim varDatensatz() As Variant

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Objekt vom Typ Tabelle öffnen.
    Set rst = dbs.OpenRecordset("Personal")
    ' Bezug auf Feld Nachname zurückgeben.
    Set fld = rst.Fields!Nachname
    ' Datenfeld mit dem Wert der Eigenschaft "RecordCount" als obere
    ' Grenze neu dimensionieren.
    ReDim varDatensatz(0 To rst.RecordCount - 1)
    intI = 0
    ' Eigenschaft "Bookmarkable" des Recordset-Objekts überprüfen.
    If rst.Bookmarkable Then
        Do Until rst.EOF
            ' Datenfeld mit Lesezeichen auffüllen.
            varDatensatz(intI) = rst.Bookmark
            ' Zähler hochzählen.
            intI = intI + 1
            rst.MoveNext
        Loop
    End If
    rst.Close
    Set dbs = Nothing
End Sub


Count-Eigenschaft (Anzahl) - Beispiel (MDB)

Das folgende Beispiel gibt die Namen und die Gesamtanzahl der Felder der Tabelle Bestellungen aus.

Sub Felderanzahl()
    Dim dbs As Database, tdf As TableDef
    Dim fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Bestellungen" zurückgeben.
    Set tdf = dbs.TableDefs!Bestellungen
    ' Felder in der Fields-Auflistung des TableDef-Objekts zählen.
    Debug.Print tdf.Fields.Count
    ' Namen aller Felder auflisten.
    For Each fld In tdf.Fields
        Debug.Print fld.Name
    Next fld
    Set dbs = Nothing
End Sub


DefaultValue-Eigenschaft (Standardwert) - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Field-Objekt und stellt dessen Eigenschaft DefaultValue ein. Die Prozedur fügt dann das neue Objekt der Fields-Auflistung der Tabelle Personal in der TableDefs-Auflistung der Datenbank hinzu.

Sub NeuesFeld()
    Dim dbs As Database, tdf As TableDef
    Dim fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Field-Objekt erstellen.
    Set fld = tdf.CreateField("Urlaubstage", dbText, 20)
    ' Feldeigenschaften einstellen.
    fld.DefaultValue = "10"
    ' Feld an Fields-Auflistung anfügen.
    tdf.Fields.Append fld
    Set dbs = Nothing
End Sub


 FieldSize-Eigenschaft (MDB)

FieldSize-Eigenschaft (MDB)

Die DAO-Eigenschaft FieldSize unterscheidet sich von der Microsoft Access-Eigenschaft Feldgröße, die in der Tabellenentwurfsansicht eingestellt wird. Die DAO-Eigenschaft FieldSize gibt die Anzahl der Bytes eines Field-Objekts des Datentyps Memo oder OLE-Objekt zurück.

Sie stellen die Microsoft Access-Eigenschaft Feldgröße ein, um die Größe eines Feldes in einer Tabelle zu begrenzen. Die Eigenschaft Feldgröße ist nur in der Tabellenentwurfsansicht verfügbar. Verwenden Sie in Visual Basic die Eigenschaft Size, um die Größe eines Feldes in einer Tabelle einzustellen.


Filter-Eigenschaft - Beispiel (MDB)

Der Benutzer wird im folgenden Beispiel aufgefordert, den herauszufilternden Ländernamen einzugeben. Dann wird die Eigenschaft Filter eines Recordset-Objekts vom Typ Dynaset eingestellt. Gibt der Benutzer z. B. "Italien" ein, so enthält die gefilterte Datensatzgruppe nur die Datensätze, in denen das Feld Bestimmungsland den Wert "Italien" hat.

Beachten Sie, dass zuerst ein Recordset-Objekt vom Typ Dynaset erstellt und dessen Eigenschaft Filter eingestellt wird, und dass dann ein zweites Recordset-Objekt vom Typ Dynaset geöffnet wird, das auf dem ersten Objekt basiert. Die Einstellung der Eigenschaft Filter des ersten Recordset-Objekts hat keine Wirkung auf die darin enthaltenen Datensätze, so dass Sie ein zweites Recordset-Objekt erstellen müssen, um die Wirkung des Filters zu sehen.

Sub RecordsetFilterEinstellen()
    Dim dbs As Database, strEingabe As String
    Dim rstBestellungen As Recordset, rstGefiltert As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Eingabe des zu filternden Wertes anfordern.
    strEingabe = InputBox("Geben Sie den Namen des Landes ein, " _
        & "das herausgefiltert werden soll.")
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rstBestellungen = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
    ' Filterbedingung festlegen.
    rstBestellungen.Filter = "[Bestimmungsland] = '" & strEingabe & "'"
    ' Gefiltertes Recordset-Objekt vom Typ Dynaset erstellen.
    Set rstGefiltert = rstBestellungen.OpenRecordset
    rstBestellungen.Close
    rstGefiltert.Close
    Set dbs = Nothing
End Sub

Tipp Meist ist es effizienter, das zweite Recordset-Objekt mit den gewünschten Bedingungen in einem Schritt zu erstellen. Wenn Sie wissen, welche Daten Sie auswählen möchten, ist es grundsätzlich effizienter, eine Datensatzgruppe mit einer SQL-Anweisung zu erstellen. Das folgende Beispiel zeigt, wie Sie nur eine Datensatzgruppe erstellen und die gleichen Ergebnisse wie im vorhergehenden Beispiel erhalten.

Sub CreateRecordsetWithSQL()
    Dim dbs As Database, rst As Recordset
    Dim strEingabe As String

    Set dbs = CurrentDb
    strEingabe = InputBox("Geben Sie den Namen des Landes ein, " _
        & "das herausgefiltert werden soll.")
    Set rst = dbs.OpenRecordset("SELECT * FROM " _
        & "Bestellungen WHERE Bestimmungsland = '" & strEingabe _
        & "';")
    rst.MoveLast
    MsgBox "Recordset contains " & rst.RecordCount & " records."
    rst.Close
    Set dbs = Nothing
End Sub


IgnoreNulls-, Unique-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel fügt einen neuen Index zu einem TableDef-Objekt hinzu und stellt die Eigenschaften IgnoreNulls und Unique auf True (-1) ein.

Sub NeuerIndex()
    Dim dbs As Database, tdf As TableDef
    Dim idx As Index, fldID As Field, fldName As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Artikel" zurückgeben.
    Set tdf = dbs.TableDefs!Artikel
    ' Index-Objekt zurückgeben, das auf den neuen Index verweist.
    Set idx = tdf.CreateIndex("IDName")
    ' Indexfelder erstellen und anfügen.
    Set fldID = idx.CreateField("[Artikel-Nr]")
    Set fldName = idx.CreateField("Artikelname")
    idx.Fields.Append fldID
    idx.Fields.Append fldName
    ' Index-Eigenschaften einstellen.
    idx.IgnoreNulls = True
    idx.Unique = True
    ' Neues Index-Objekt an Indexes-Auflistung anfügen.
    tdf.Indexes.Append idx
    Set dbs = Nothing
End Sub


Name-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel erstellt und benennt zwei neue TableDef-Objekte. Der Name des ersten TableDef-Objekts ist als Argument in der Methode CreateTableDef enthalten. Der Name des zweiten TableDef-Objekts wird unter Verwendung der Eigenschaft Name eingestellt, nachdem das TableDef-Objekt erstellt wurde.

Beachten Sie, dass Sie zuerst Felder in der Tabelle definieren müssen, bevor das TableDef-Objekt an die TableDefs-Auflistung angefügt werden kann.

Sub NeueTabellenBenennen()
    Dim dbs As Database
    Dim tdfDefinitionen As TableDef, tdfSynonyme As TableDef

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neues TableDef-Objekt erstellen.
    Set tdfDefinitionen = dbs.CreateTableDef("Definitionen")
    ' Zweites TableDef-Objekt erstellen.
    Set tdfSynonyme = dbs.CreateTableDef("")
    ' Eigenschaft "Name" des zweiten TableDef-Objekts einstellen.
    tdfSynonyme.Name = "Synonyme"
    .                            ' Felder erstellen.
    .
    .
    dbs.TableDefs.Append tdfDefinitionen
    dbs.TableDefs.Append tdfSynonyme
    Set dbs = Nothing
End Sub


ODBCTimeout-Eigenschaft (ODBCWartezeit) - Beispiel (MDB)

Das folgende Beispiel stellt die Eigenschaft ODBCTimeout auf 120 Sekunden ein, erstellt dann eine Abfrage und führt diese in einer Datenbank auf einem ODBC-Server aus.

Sub ZeitüberschreitungEinstellen()
    Dim dbs As Database
    Dim qdf As QueryDef, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("Alle Kunden", _
        "SELECT * FROM Kunden;")
    qdf.Connect = "ODBC;DSN=Personalabteilung;SERVER=HRSRVR: " _
        & "UID=Schmidt; PWD=Sesam"
    ' An Server anmelden und Abfrage ausführen.
    qdf.ODBCTimeout = 120
    Set rst = qdf.OpenRecordset()
    ' Operationen mit der Datensatzgruppe durchführen.
    .
    .
    .
    rst.Close
    Set dbs = Nothing
End Sub


Primary-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel überprüft die Eigenschaft Primary jedes Indexes in der Tabelle Artikel und gibt die Felder aus, aus denen sich der Primärschlüssel zusammensetzt.

Sub IndexPrüfen()
    Dim dbs As Database, tdf As TableDef, fld As Field
    Dim idx As Index

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Artikel" zurückgeben.
    Set tdf = dbs.TableDefs!Artikel
    ' Indexes-Auflistung des TableDef-Objekts durchlaufen.
    For Each idx In tdf.Indexes
        ' Eigenschaft "Primary" des Recordset-Objekts überprüfen.
        If idx.Primary Then
            For Each fld In idx.Fields
                Debug.Print fld.Name
            Next fld
        End If
    Next idx
    Set dbs = Nothing
End Sub


Required-Eigenschaft (Eingabe erforderlich) - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Index-Objekt in der Tabelle Personal und stellt die Eigenschaft Required für den Index ein. Der neue Index besteht aus zwei Feldern, Nachname und Vorname.

Sub NeuerIndex()
    Dim dbs As Database, tdf As TableDef, idx As Index
    Dim fldNachname As Field, fldVorname As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Neuen Index erstellen
    Set idx = tdf.CreateIndex("GanzerName")
    ' Index-Felder erstellen und anfügen.
    Set fldNachname = idx.CreateField("Nachname", dbText)
    Set fldVorname = idx.CreateField("Vorname", dbText)
    idx.Fields.Append fldNachname
    idx.Fields.Append fldVorname
    ' Sicherstellen, dass für jedes Feld im Index ein Wert eingegeben wird.
    idx.Required = True
    ' Index-Objekt anfügen.
    tdf.Indexes.Append idx
    Set dbs = Nothing
End Sub


ValidationRule-, ValidationText-Eigenschaften (Gültigkeitsregel, Gültigkeitseigenschaft) - Beispiel (MDB)

Das folgende Beispiel stellt die Eigenschaften ValidationRule und ValidationText für zwei Felder in der Tabelle Bestelldetails ein. Nachdem diese Eigenschaften einmal eingestellt sind, können Sie sie auch in der Tabellenentwurfsansicht anzeigen.

Sub ÜberprüfungEinstellen()
    Dim dbs As Database, tdf As TableDef
    Dim fldMenge As Field, fldRabatt As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Bestelldetails" zurückgeben.
    Set tdf = dbs.TableDefs![Bestelldetails]
    Set fldQuantity = tdf.Fields!Menge
    Set fldDiscount = tdf.Fields!Rabatt
    ' ValidationRule und ValidationText einstellen.
    fldMenge.ValidationRule = ">= 4"
    fldMenge.ValidationText = "Menge muß mindestens vier betragen.
    fldRabatt.ValidationRule = "Between .05 and .30"
    fldRabatt.ValidationText = "Rabatt muß zwischen 5% und 30% liegen.
    Set dbs = Nothing
End Sub


Datenbankeigenschaften: Beispiel

Im folgenden Beispiel können Sie eine benutzerdefinierte Eigenschaft einstellen oder erstellen, die im Dialogfeld Datenbankname Eigenschaften auf der Registerkarte Anpassen angezeigt wird. Sie können z.B. die Funktion BenutzerdefinierteEigenschaftEinstellen aufrufen, um eine neue Eigenschaft namens NameLetzterBenutzer zu dem Document-Objekt UserDefined der Datenbank hinzuzufügen. Die an die Funktion BenutzerdefinierteEigenschaftEinstellen übergebenen Argumente entsprechen den Argumenten, die erforderlich sind, um die CreateProperty-Methode auszuführen.

Dim strName As String, strWert As String

' Die Variable einstellen, die den Namen der
' Eigenschaft enthält.
strName = "NameLetzterBenutzer"
' Die Variable einstellen, die den Wert der
' Eigenschaft enthält.
strWert = InputBox("Geben Sie Ihren vollständigen Namen ein.")
If BenutzerdefinierteEigenschaftEinstellen(strName, dbText, strWert) <> True Then
    ' Bei dem Versuch, die Eigenschaft einzustellen,
    ' ist ein Fehler aufgetreten.
    MsgBox "Fehler beim Versuch, die Eigenschaft einzustellen."
End If

Function BenutzerdefinierteEigenschaftEinstellen(strEigenschName As String, strEigenschTyp _
 As Integer, strEigenschWert As String) As Integer

    Dim dbs As Database, cnt As Container
    Dim doc As Document, prp As Property

    Const conEigenschNichtGef = 3270 ' Fehler: Eigenschaft nicht gefunden.
    Set dbs = CurrentDb ' Database-Objekt definieren.
    Set cnt = dbs.Containers!Databases ' Container-Objekt definieren.
    Set doc = cnt.Documents!UserDefined ' Document-Objekt definieren.
    On Error GoTo Fehlerbehandlung
    doc.Properties.Refresh
    ' Die Property-Variable wird auf den Namen der
    ' benutzerdefinierten Eigenschaft eingestellt. Wenn
    ' dabei ein Fehler auftritt, heißt das, dass die
    ' Eigenschaft nicht existiert und daher erstellt
    ' und an die Properties-Auflistung des Document-
    ' Objekts angefügt werden muss.
    Set prp = doc.Properties(strEigenschName)
    '  Den Wert der benutzerdefinierten Eigenschaft einstellen.
    prp = strEigenschWert
    BenutzerdefinierteEigenschaftEinstellen = True

Beenden:
    Exit Function

Fehlerbehandlung:
    If Err = conEigenschNichtGef Then
        Set prp = doc.CreateProperty(strEigenschName, strEigenschTyp, strEigenschWert)
        doc.Properties.Append prp ' An die Auflistung anfügen.
        Resume Next
    Else ' Unbekannter Fehler.
        BenutzerdefinierteEigenschaftEinstellen = False
        Resume Beenden
    End If
End Function

Im nächsten Beispiel wird gezeigt, wie Informationen angezeigt werden können, die im Dialogfeld Datenbankname Eigenschaften auf der Registerkarte Zusammenfassung stehen. Der Titel, das Thema und der Autor der Anwendung werden in Textfeld-Steuerelementen eines Formular angezeigt. In diesem Beispiel gibt die Prozedur den Wert Unbestimmt zurück, wenn die Eigenschaft noch nicht eingestellt wurde. Wenn ein unbekannter Fehler auftritt, wird eine leere Zeichenfolge ("") zurückgegeben.

Private Sub Form_Open(Cancel As Integer)
    Dim strTitel As String, strThema As String, strAutor As String

    strTitel = "Title"
    strThema = "Subject"
    strAutor = "Author"

    Me!txtTitel = DateiInfoLesen(strTitel)
    Me!txtThema = DateiInfoLesen(strThema)
    Me!txtAutor = DateiInfoLesen(strAutor)
End Sub

Function DateiInfoLesen(strEigenschName As String) As String
    Dim dbs As Database, cnt As Container
    Dim doc As Document, prp As Property

    ' Fehler: Eigenschaft nicht gefunden.
    Const conEigenschNichtGef = 3270
    On Error GoTo Fehlerbehandlung
    Set dbs = CurrentDb
    Set cnt = dbs.Containers!Databases
    Set doc = cnt.Documents!SummaryInfo
    doc.Properties.Refresh
    DateiInfoLesen = doc.Properties(strEigenschName)

Beenden:
    Exit Function

Fehlerbehandlung:
    If Err = conEigenschNichtGef Then
        Set prp = doc.CreateProperty(strEigenschName, dbText, "Unbestimmt")
        ' An die Auflistung anfügen.
        doc.Properties.Append prp
        Resume
    Else
        ' Unbekannter Fehler.
        DateiInfoLesen = ""
        Resume Beenden
    End If
End Function


DatasheetBackColor und DatasheetForeColor (Eigenschaften DatenblattHintergrundfarbe und DatenblattVordergrundfarbe) - Beispiel

Im folgenden Beispiel wird die Prozedur TabEigenschEinstellen verwendet, um die Schriftfarbe einer Tabelle auf Dunkelblau und die Hintergrundfarbe der Tabelle auf Hellgrau einzustellen. Wenn beim Einstellen einer Eigenschaft der Fehler "Eigenschaft nicht gefunden" auftritt, wird die Eigenschaft mit der CreateProperty-Methode zur Properties-Auflistung des Objekts hinzugefügt.

Dim dbs As Object, objArtikel As Object
Const lngVordergrFarbe As Long = 8388608 ' Dunkelblau
Const lngHintergrFarbe As Long = 12632256 ' Hellgrau.
Const DB_Long As Long = 4

Set dbs = CurrentDb
Set objArtikel = dbs!Artikel
TabEigenschEinstellen objArtikel, "DatasheetBackColor", DB_Long, lngHintergrFarbe
TabEigenschEinstellen objArtikel, "DatasheetForeColor", DB_Long, lngVordergrFarbe

Sub TabEigenschEinstellen(objTabelle As TableDef, strEigenschName As String, _
    intEigenschTyp As Integer, varEigenschWert As Variant)
    Const conEigenschNichtGef = 3270
    Dim prpEigenschaft As Variant
    On Error Resume Next ' Fehler nicht auffangen.
    objTabelle.Properties(strEigenschName) = varEigenschWert
    If Err <> 0 Then ' Fehler beim Einstellen des Wertes.
        If Err <> conEigenschNichtGef Then
            ' Der Fehler ist nicht bekannt.
            MsgBox "Die Eigenschaft " & strEigenschName & " der Tabelle '" _
            & objTabelle.Name & "' konnte nicht eingestellt werden", vbExclamation, Err.Description
            Err.Clear
       Else
            ' Fehler "Eigenschaft nicht gefunden"; die Eigenschaft zur
            ' Auflistung hinzufügen.
            Set prpEigenschaft = objTabelle.CreateProperty(strEigenschName, _
            intEigenschTyp, varEigenschWert)
            objTabelle.Properties.Append prpEigenschaft
            Err.Clear
       End If
    End If
    objTabelle.Properties.Refresh
End Sub


DatasheetFontItalic und DatasheetFontUnderline-Eigenschaften: Beispiel

Das folgende Beispiel zeigt die Daten und Feldnamen des Formulars Artikel in der Datenblattansicht kursiv und unterstrichen an.

Formulare![Artikel].DatasheetFontItalic = True
Formulare![Artikel].DatasheetFontUnderline = True

Das nächste Beispiel zeigt die Daten und Feldnamen der Tabelle Artikel in der Datenblattansicht kursiv und unterstrichen an.

Zur Einstellung der Eigenschaften DatasheetFontItalic und DatasheetFontUnderline verwendet das Beispiel die Prozedur TabEigEinstellen, die sich im Standardmodul der Datenbank befindet.

Dim dbs As Object, objArtikel As Object
Const DB_Boolean As Long = 1
Set dbs = CurrentDb
Set objArtikel = dbs![Artikel]
TabEigEinstellen objArtikel, "DatasheetFontItalic", DB_Boolean, True
TabEigEinstellen objArtikel, "DatasheetFontUnderline", DB_Boolean, True

Sub TabEigEinstellen(objTabelle As TableDef, strEigName As String, _
    intEigTyp As Integer, varEigWert As Variant)
    ' Microsoft Access-definierte Tabelleneigenschaft ohne Auslösung eines
    ' Laufzeitfehlers einstellen, der zum Programmabbruch führt.
    Const conErrPropertyNotFound = 3270
    Dim proEigenschaft As Variant
    On Error Resume Next ' Keine Fehler auffangen.
    objTabelle.Properties(strEigName) = varEigWert
    If Err <> 0 Then ' Fehler beim Einstellen des Wertes.
        If Err <> conErrPropertyNotFound Then
            On Error GoTo 0
            MsgBox " Eigenschaft '" & strEigName _
            & "' konnte für Tabelle '" & TabObj.name & "' nicht eingestellt werden ", 48,              "TabEigEinstellen"
        Else
            On Error GoTo 0
            Set proEigenschaft = objTabelle.CreateProperty(strEigName, _
            intEigTyp, varEigWert)
            objTabelle.Properties.Append prpEigenschaft
        End If
    End If
    objTabelle.Properties.Refresh
End Sub


DatasheetFontName und DatasheetFontHeight-Eigenschaften: Beispiel

Das folgende Beispiel stellt in der Datenblattansicht der Tabelle Artikel die Schriftart auf MS Serif, die Punktgröße auf 10 und die Schriftbreite auf Mittel (500) ein.

Zur Einstellung dieser Eigenschaften verwendet das Beispiel die Prozedur TabEigEinstellen, welche im Beispiel für DatasheetFontItalic-, DatasheetFontUnderline-Eigenschaften gezeigt wird.

Dim dbs As Object, objArtikel As Object
Set dbs = CurrentDb
Const DB_Text As Long = 10
Const DB_Integer As Long = 3
Set objArtikel = dbs!Artikel
SetTableProperty objArtikel, "DatasheetFontName", DB_Text, "MS Serif"
SetTableProperty objArtikel, "DatasheetFontHeight", DB_Integer, 10
SetTableProperty objArtikel, "DatasheetFontWeight", DB_Integer, 500

Das nächste Beispiel nimmt dieselben Änderungen wie das vorherige Beispiel vor, während das Formular Artikel in der Datenblattansicht geöffnet ist.

Formulare!Artikel.DatasheetFontName = "MS Serif"
Formulare!Artikel.DatasheetFontHeight = 10
Formulare!Artikel.DatasheetFontWeight = 500


 DataType-Eigenschaft

DataType-Eigenschaft

Sprachspezifische Informationen

Microsoft Access 2000 has revised the DataType property so the Date/Time setting can accommodate the Hijri calendar.

Remarks

If Hijri is the current Visual Basic Calendar setting, Access 2000 stores date and time values for the Hijri years 100 to 9666. More specifically, the supported Hijri date range is 1/1/100 (Gregorian Aug 2, 718) through 4/3/9666 (Gregorian Dec 31, 9999).


DataUpdatable-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel erstellt zwei Recordset-Objekte aus der gleichen Tabelle, ein Recordset-Objekt vom Typ Dynaset und ein Recordset-Objekt vom Typ Snapshot. Die Prozedur überprüft dann die Eigenschaft DataUpdatable des Feldes Nachname in jedem Recordset-Objekt. Der Wert der Eigenschaft DataUpdatable entspricht True (-1) für das Recordset-Objekt vom Typ Dynaset und False (0) für das Recordset-Objekt vom Typ Snapshot.

Sub AktualisierbarkeitPrüfen()
    Dim dbs As Database
    Dim rstDynaset As Recordset, rstSnapshot As Recordset
    Dim fldDynaset As Field, fldSnapshot As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rstDynaset = dbs.OpenRecordset("Personal", _
        dbOpenDynaset)
    ' Recordset-Objekt vom Typ Snapshot öffnen.
    Set rstSnapshot = dbs.OpenRecordset("Personal", _
        dbOpenSnapshot)
    ' Field-Objektvariablen abrufen, die auf das Feld in jedem
    ' Recordset-Objekt zeigen.
    Set fldDynaset = rstDynaset.Fields!Nachname
    Set fldSnapshot = rstSnapshot.Fields!Nachname
    ' Aktuellen Datensatz abrufen.
    rstDynaset.MoveFirst
    rstSnapshot.MoveFirst
    ' Wert der Eigenschaft "DataUpdatable" für jedes Recordset-Objekt
    ' anzeigen.
    Debug.Print "DataUpdatable (Recordset vom Typ Dynaset): "; _
        fldDynaset.DataUpdatable
    Debug.Print "DataUpdatable (Recordset vom Typ Snapshot): "; _
        fldSnapshot.DataUpdatable
    rstDynaset.Close
    rstSnapshot.Close
    Set dbs = Nothing
End Sub


DateCreated-, LastUpdated-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel durchläuft alle QueryDef-Objekte in der Datenbank und listet diejenigen auf, die innerhalb der letzten sechzig Tage erstellt oder geändert wurden.

Sub AktualisierungZweiMonate()
    Dim dbs As Database, tdf As TableDef, qdf As QueryDef
    Dim strListe As String, dteSechzig As Date

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    dteVergangen = Date - 60
    ' Elemente der QueryDefs-Auflistung durchlaufen.
    For Each qdf In dbs.QueryDefs
        ' Eigenschaften "LastUpdated" und "DateCreated" auswerten.
        If (qdf.LastUpdated > dteSechzig) Or (qdf.DateCreated > dteSechzig) Then
            ' Liste erstellen.
            strListe = strListe & vbCrLf & qdf.Name
        End If
    Next qdf
    MsgBox strListe
    Set dbs = Nothing
End Sub


 DefaultValue-Eigenschaft

DefaultValue-Eigenschaft

Wenn die Einstellung der ADO-Eigenschaft DefaultValue ein Ausdruck ist, kann dieser keine benutzerdefinierten Funktionen, Microsoft Access-Aggregatfunktionen für Domänen, SQL-Aggregatfunktionen, die CurrentUser-Funktion, die Eval-Funktion oder Verweise auf Abfragen, Formulare oder andere Field-Objekte enthalten.


 DefaultValue-Eigenschaft (MDB)

DefaultValue-Eigenschaft (MDB)

Wenn Sie in Microsoft Access die DAO-Eigenschaft DefaultValue auf GenUniqueID() einstellen, um ein Feld vom Typ AutoWert zu erstellen, müssen Sie auch die Eigenschaft Attributes auf dbAutoIncrField einstellen. Stellen Sie die Eigenschaft Attributes nicht wie beschrieben ein, weist Microsoft Access dem Feld nicht den Datentyp AutoWert zu, und Sie erhalten einen Fehler, wenn Sie versuchen, die Tabelle in der Datenblattansicht anzuzeigen.

Das folgende Code-Beispiel zeigt, wie Sie ein Feld mit dem Datentyp AutoWert erstellen können, wenn eine TableDef-Objektvariable tdf und eine Field-Objektvariable fld gegeben sind.

Set fld = tdf.CreateField("Personal-Nr", dbLong)
fld.DefaultValue = "GenUniqueID()"
fld.Attributes = dbAutoIncrField
tdf.Fields.Append fld

Wenn die Einstellung der DAO-Eigenschaft DefaultValue ein Ausdruck ist, kann sie folgende Funktionen nicht enthalten: benutzerdefinierte Funktionen, Microsoft Access Aggregatfunktionen für Domänen, SQL-Aggregatfunktionen, die Funktion CurrentUser und die Funktion Eval. Außerdem kann sie keine Verweise auf Abfragen, Formulare oder andere Field-Objekte enthalten.


 DefinedSize-Eigenschaft

DefinedSize-Eigenschaft

Die ADO-Eigenschaft DefinedSize entspricht der Size-Eigenschaft in DAO sowie der Feldgröße-Eigenschaft in der Tabellenentwurfsansicht. Mit Hilfe der DefinedSize-Eigenschaft können Sie den Wert für Feldgröße in Visual Basic einstellen.

Anmerkung In Microsoft Access kann ein Feld vom Datentyp Memo maximal 2,14 GB an Informationen enthalten. Die Menge der Daten, die in einem Steuerelement eines Formulars oder Berichts angezeigt werden, ist jedoch durch die Kapazität des Systemspeichers begrenzt.


Description-Eigenschaft

Die Description-Eigenschaft betrifft das Error-Objekt und gibt eine dem Fehler zugeordnete Zeichenfolge zurück. Sie können darauf nur unter Verwendung von Visual Basic zugreifen.

Anmerkung Verwechseln Sie diese Eigenschaft nicht mit der Microsoft Access-Eigenschaft Description, die eine Tabelle oder Abfrage und die zugehörigen Felder beschreibt.


DestConnectStr-, DestinationDB-, DestinationTable-Eigenschaften (Zielverbindung, Zieldatenbank, Zieltabelle) - Beispiel

Das folgende Beispiel fügt die Datensätze in die Tabelle Kunden an die Tabelle Klienten in einer Microsoft Access-Datenbank namens Klienten im Verzeichnis C:\DATEN an. Sie können diese SQL-Anweisung in der SQL-Ansicht des Abfragefensters eingeben.

INSERT INTO Klienten IN 'C:\DATEN\KLIENTEN.MDB'
SELECT Kunden.[Firma], Kunden.Telefon
FROM Kunden;

Das nächste Beispiel erstellt eine neue Tabelle namens Kontakte in einer Paradox-Datenbank (Version 3.x) im Verzeichnis C:\PDOXDATA.

SELECT Kunden.Firma, Kunden.Telefon
INTO Kontakte IN 'C:\PDOXDATA' [Paradox 3.x;] FROM Kunden;


Dirty-Eigenschaft (Geändert) - Beispiel

Das folgende Beispiel aktiviert die Schaltfläche btnRückgängig, sobald Daten geändert wurden. Die Funktion BerarbeitenRückgängig( ) wird vom Ereignis AfterUpdate der Textfeld-Steuerelemente aufgerufen. Beim Klicken auf die aktivierte Schaltfläche btnRückgängig wird der ursprüngliche Wert des Steuerelements mit Hilfe der Eigenschaft OldValue wiederhergestellt.

Sub BearbeitenRückgängig()
    If Me.Dirty Then
        Me!btnRückgängig.Enabled = True          ' Schaltfläche aktivieren.
    Else
        Me!btnRückgängig.Enabled = False          ' Schaltfläche deaktivieren.
    End If
End Sub

Sub btnRückgängig ()
    Dim ctlC As Control
        ' Für jedes Steuerelement.
        For Each ctlC in Me.Controls
            If ctlC.ControlType = acTextBox Then
                ' Alten Wert wiederherstellen.
                ctlC.Value = ctlC.OldValue
            End If
        Next ctlC
End Sub


DistinctCount-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel gibt die Anzahl an eindeutigen Werten in den Indizes der Felder Bestell-Nr und Bestelldatum der Tabelle Bestellungen aus. Die Eigenschaft DistinctCount gibt die Anzahl der eindeutigen Werte eines Indexes nur dann sicher zurück, wenn dies unmittelbar nach Erstellung eines Indexes unter Verwendung der Methode CreateIndex geschieht, oder nachdem eine Datenbank unter Verwendung der Methode CompactDatabase komprimiert oder konvertiert wurde.

Sub Schlüsselanzahl()
    Dim dbs As Database, tdf As TableDef
    Dim idx As Index, fldBestellNr As Field, fldBestellDatum As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Bestellungen" zurückgeben.
    Set tdf = dbs.TableDefs!Bestellungen
    ' Neuen Index erstellen.
    Set idx = tdf.CreateIndex("BestellNrDatum")
    ' Index-Felder erstellen und anfügen.
    Set fldBestellDatum = idx.CreateField("Bestelldatum", dbDate)
    idx.Fields.Append fldBestellDatum
    ' Neuen Index anfügen.
    tdf.Indexes.Append idx
    ' Indexes-Auflistung aktualisieren.
    tdf.Indexes.Refresh
    ' Wert der Eigenschaft "DistinctCount" für den neuen Index
    ausgeben.
    Debug.Print idx.DistinctCount
    Set dbs = Nothing
End Sub


CurrentProject-Objekt, Document- und IsLoaded-Eigenschaft - Beispiel

Diese Prozedur zeigt, wie Text mit Hilfe von VBA-Code auf einer Datenzugriffsseite hinzugefügt wird. Die folgenden Informationen werden in den Argumenten für diese Prozedur angegeben:

strPageName | Der Name einer vorhandenen Datenzugriffsseite.
strID | Die ID-Eigenschaft (Attribut) für das Tag mit dem Text, den Sie bearbeiten möchten.
strText | Der einzufügende Text.
blnReplace | Legt fest, ob vorhandener Text im Tag ersetzt werden soll.

Function DAPTextEinfügen(strPageName As String, _
    strID As Variant, strText As String, _
    Optional blnReplace As Boolean = True) As Boolean

    Dim blnWurdeGeladen As Boolean

    On Error GoTo DAPTextEinfügen_Err

    ' Ermitteln, ob die Seite vorhanden und momentan geöffnet
    ' ist. Wenn sie nicht geöffnet ist, in der Entwurfsansicht
    ' öffnen.
    If DAPVorhanden(strPageName) = True Then
        If CurrentProject.AllDataAccessPages(strPageName) _
            .IsLoaded = False Then
            blnWurdeGeladen = False
            With DoCmd
                .Echo False
                .OpenDataAccessPage strPageName, _
                    acDataAccessPageDesign
            End With
        Else
            blnWurdeGeladen = True
        End If
    Else
        DAPTextEinfügen = False
        Exit Function
    End If

    ' Neuen Text zum angegebenen Tag hinzufügen.
    With DataAccessPages(strPageName).Document
        If blnReplace = True Then
            .All(strID).innerText = strText
        Else
            .All(strID).innerText = .All(strID).innerText & strText
        End If
        ' Sicherstellen, dass der Text sichtbar ist.
        With .All(strID).Style
            If .display = "none" Then .display = ""
        End With
    End With

    ' Anschließend löschen.
    With DoCmd
        If blnWurdeGeladen = True Then
        .Save
    Else
        .Close acDataAccessPage, strPageName, acSaveYes
        End If
    End With
    DAPTextEinfügen = True
DAPTextEinfügen_End:
    DoCmd.Echo True
    Exit Function
DAPTextEinfügen_Err:
    MsgBox "Error #" & Err.Number & ": " & Err.Description
    DAPTextEinfügen = False
    Resume DAPTextEinfügen_End
End Function


DownloadComponents-Eigenschaft: Beispiel

In diesem Beispiel werden die Office Web Components mit der angegebenen Webseite gedownloadet, falls sie nicht bereits installiert sind.

Application.DefaultWebOptions.DownloadComponents = True
Application.DefaultWebOptions.LocationOfComponents = _
    Application.CurrentProject & "\foo"


 Enabled-Eigenschaft (FormatCondition-Objekt)

Enabled-Eigenschaft (FormatCondition-Objekt)

Mit der Enabled-Eigenschaft können Sie den Status der bedingten Formatierung im FormatCondition-Objekt einstellen oder zurückgeben.

Einstellung

Die Einstellung der Enabled-Eigenschaft ist ein Wert des Datentyps Boolean, der angibt, ob die bedingte Formatierung aktiviert oder deaktiviert ist. True (-1) aktiviert die bedingte Formatierung. False (0) deaktiviert sie. Die Standardeinstellung ist True.

Die Enabled-Eigenschaft ist nur in Visual Basic verfügbar.

Anmerkung

Wenn die Enabled-Eigenschaft den Wert True hat, kann die bedingte Formatierung im Dialogfeld Bedingte Formatierung angezeigt werden. Dieses Dialogfeld öffnen Sie durch Klicken auf Bedingte Formatierung im Menü Format.


 Enabled-Eigenschaft (Befehlsleisten)

Enabled-Eigenschaft (Befehlsleisten)

Mit dieser Eigenschaft können Sie ein Menüelement oder eine Befehlsschaltfläche deaktivieren (abgeblendet darstellen) bzw. aktivieren. Diese Eigenschaft gilt für Menünamen, Untermenünamen und Elemente in Untermenüs. Die Enabled-Eigenschaft ersetzt die durch die SetzenMenüelement-Aktion und die SetMenuItem-Methode in Microsoft Access 95 vorgegebene Funktionalität.

Sie können ein Menüelement, das in Microsoft Access normalerweise aktiviert ist, deaktivieren, es ist aber nicht möglich, ein in Microsoft Access normalerweise deaktiviertes Menüelement zu aktivieren.


Enabled-, Locked-Eigenschaften (Aktiviert, Gesperrt) - Beispiel

Das folgende Beispiel schaltet die Eigenschaft Enabled einer Befehlsschaltfläche und die Eigenschaften Enabled und Locked eines Steuerelements abhängig vom Typ des im aktuellen Datensatz angezeigten Angestellten um. Ist der/die Angestellte ein Manager oder eine Managerin, so wird die Schaltfläche Gehaltdetails aktiviert und das Steuerelement PersAngaben freigegeben und aktiviert.

Sub Aktuelles_Formular()
    If Me!AngTyp = "Manager" Then
        Me!Gehaltdetails.Enabled = True
        Me!PersAngaben.Enabled = True
        Me!PersAngaben.Locked = False
    Else
        Me!Gehaltdetails.Enabled = False
        Me!PersAngaben.Enabled = False
        Me!PersAngaben.Locked = True
    End If
End Sub


Encoding-Eigenschaft: Beispiel

In diesem Beispiel wird überprüft, ob die Standard-Dokumentcodierung auf "Western" eingestellt ist.

If Application.DefaultWebOptions.Encoding = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Andere"
End If


Error-, ReadyState-, SnapshotPath-Eigenschaften - Beispiel

Das folgende Beispiel zeigt, wie die Error-, ReadyState- und SnapshotPath-Eigenschaften verwendet werden können, um eine Snapshot-Datei in ein Snapshot-Steuerelement zu laden. In diesem Beispiel stellt die Variable snpCtl ein Snapshot-Steuerelement in einem Formular dar, und strDateipfad steht für den vollständigen Pfad der anzuzeigenden Snapshot-Datei.

Function SnapshotdateiLaden(snpCtl As Object, strDateipfad As String) _
  As Boolean
    Const conSnpFinishedDownload As Integer = 4
    With snpCtl
        .SnapshotPath = strDateipfad
        Do While .ReadyState < conSnpFinishedDownload
            DoEvents
        Loop
        If .Error = 0 Then
            SnapshotdateiLaden = True
            Exit Function
        Else
            MsgBox "Fehler beim Laden der Snapshotdatei", _
                vbOKOnly, "Snapshotfehler = " & .Error
            SnapShotdateiLaden = False
        End If
    End With
End Function


Ereigniseigenschaften - Visual Basic-Beispiel

Das folgende Beispiel zeigt, wie Sie den im Steuerelement Land eingegebenen Wert verwenden können, um festzulegen, welches von zwei Makros ausgeführt werden soll, wenn Sie auf die Schaltfläche Länderbericht drucken klicken.

Private Sub Land_AfterUpdate ()
    If Land = "Deutschland" Then
        [Länderbericht drucken].OnClick = "DeutschlandberichtDrucken"
    ElseIf Land = "USA" Then
        [Länderbericht drucken].OnClick = "USABerichtDrucken"
    End If
End Sub


Ereigniseigenschaften und Objekte, auf die sie anwendbar sind

Ereigniseigenschaft | Anwendbar auf
AfterDelConfirm (NachLöschbestätigung) | Formulare
AfterInsert (NachEingabe) | Formulare
AfterUpdate (NachAktualisierung)* | Formulare, Steuerelemente (Gebundenes Objektfeld, Kontrollkästchen , Kombinationsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Textfeld, Umschaltfläche) auf Formularen
BeforeDelConfirm (VorLöschbestätigung) | Formulare
BeforeInsert (VorEingabe) | Formulare
BeforeUpdate (VorAktualisierung)* | Formulare, Steuerelemente (Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Textfeld, Umschaltfläche) auf Formularen
OnActivate (BeiAktivierung) | Formulare und Berichte
OnApplyFilter (BeiAngewendetemFilter) | Formulare
OnChange (BeiÄnderung) | Steuerelemente (Kombinationsfeld, Register, Textfeld) auf Formularen
OnClick (BeimKlicken)* | Formulare, Formularbereiche, Steuerelemente (Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Bild, Bezeichnungsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Rechteck, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnClose (BeimSchließen) | Formulare und Berichte
OnCurrent (BeimAnzeigen) | Formulare
OnDblClick (BeimDoppelklicken)* | Formulare, Formularbereiche, Steuerelemente (Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Bild, Bezeichnungsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Rechteck, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnDeactivate (BeiDeaktivierung) | Formulare und Berichte
OnDelete (BeimLöschen) | Formulare
OnDirty (BeiÄnderung) | Formulare
OnEnter (BeimHingehen)* | Steuerelemente (ActiveX, Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Optionsgruppe, Unterformular/Unterbericht, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnError (BeiFehler) | Formulare und Berichte
OnExit (BeimVerlassen)* | Steuerelemente (ActiveX, Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Optionsgruppe, Unterformular/Unterbericht, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnFilter (BeiFilter) | Formulare
OnFormat (BeimFormatieren) | Berichtsbereiche.
OnGotFocus (BeiFokuserhalt) | Formulare, Steuerelemente (ActiveX, Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnKeyDown (BeiTasteAb) | Formulare, Steuerelemente (Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnKeyPress (BeiTaste) | Formulare, Steuerelemente (Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnKeyUp (BeiTasteAuf) | Formulare, Steuerelemente (Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnLoad (BeiLaden) | Formulare
OnLostFocus (BeiFokusverlust) | Formulare, Steuerelemente (ActiveX, Gebundenes Objektfeld, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Listenfeld, Optionsfeld, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnMouseDown (BeiMaustasteAb) | Formulare, Formularbereiche, Steuerelemente (Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Bild, Bezeichnungsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Rechteck, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnMouseMove (BeiMausbewegung) | Formulare, Formularbereiche, Steuerelemente (Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Bild, Bezeichnungsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Rechteck, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnMouseUp (BeiMaustasteAuf) | Formulare, Formularbereiche, Steuerelemente (Gebundenes Objektfeld, Diagramm, Kontrollkästchen, Kombinationsfeld, Befehlsschaltfläche, Bezeichnungsfeld, Listenfeld, Optionsfeld, Optionsgruppe, Rechteck, Register, Textfeld, Umschaltfläche, Ungebundenes Objektfeld) auf Formularen
OnNoData (BeiOhneDaten) | Berichte
OnNotInList (BeiNichtInListe) | Steuerelemente (Kombinationsfeld) auf Formularen
OnOpen (BeimÖffnen) | Formulare und Berichte
OnPage (BeiSeite) | Berichte
BeimDrucken | Berichtsbereiche
OnResize (BeiGrößenänderung) | Formulare
OnRetreat (BeiRücknahme) | Berichtsbereiche
OnTimer (BeiZeitgeber) | Formulare
OnUnload (BeiEntladen) | Formulare
OnUpdated (BeiOLEAktualisierung) | Steuerelemente (ActiveX, Gebundenes Objektfeld, Ungebundenes Objektfeld) auf Formularen

* Diese Eigenschaften sind nicht auf Kontrollkästchen, Optionsfelder oder Umschaltflächen innerhalb einer Optionsgruppe anwendbar, sondern nur auf die Optionsgruppe selbst.


FastLaserPrinting-Eigenschaft (SchnellerLaserdruck) - Beispiel

Im folgenden Beispiel wird gezeigt, wie die Eigenschaft FastLaserPrinting des Berichts Rechnung eingestellt wird, wobei der Bericht in der Entwurfsansicht geöffnet ist:

DoCmd.OpenReport "Rechnung", acDesign
Reports!Invoice.FastLaserPrinting = True
DoCmd.Close acReport, "Rechnung", acSaveYes


FeatureInstall-Eigenschaft: Beispiel

In diesem Beispiel wird der eingestellte Wert der FeatureInstall-Eigenschaft überprüft. Wenn die Eigenschaft auf msoFeatureInstallNone eingestellt ist, zeigt der folgende Code ein Meldungsfeld an, das den Benutzer fragt, ob die Einstellung der Eigenschaft geändert werden soll. Antwortet der Benutzer mit "Ja", wird die Eigenschaft auf msoFeatureInstallOnDemand eingestellt. Das Beispiel verwendet eine Objektvariable mit der Bezeichnung "MyOfficeApp", die als Anwendungsobjekt dimensioniert ist.

With MyOfficeApp
    If .FeatureInstall = msoFeatureInstallNone Then
        Reply = MsgBox("Nichtinstallierte Features " _
            & "dieser Anwendung verursachen möglicherweise " & vbCrLf _
            & "einen Laufzeitfehler, wenn sie aufgerufen werden." _
            & vbCrLf & vbCrLf _
            & "Möchten Sie diese Einstellung so verändern" & vbCrLf _
            & "dass automatisch fehlende Features installiert werden?", _
            vbYesNo, "Feature-Installionseinstellungen")
            If Reply = vbYes Then
                .FeatureInstall = msoFeatureInstallOnDemand
            End If
    End If
End With


FeatureTips-Eigenschaft

Diese Eigenschaft steht in Microsoft Access nicht zur Verfügung.


FillColor-, FillStyle-Eigenschaften - Beispiel

Das folgende Beispiel verwendet die Methode Circle, um einen Kreis zu zeichnen und im Kreis einen Kreissektor zu erstellen. Anschließend werden die Eigenschaften FillColor und FillStyle verwendet, um den Kreissektor rot zu färben. Schließlich wird eine Linie von oben links zum Kreismittelpunkt gezeichnet.

Um das folgende Beispiel in Microsoft Access durchzuführen, erstellen Sie zuerst einen neuen Bericht. Stellen Sie dann die Eigenschaft OnPrint des Detailbereichs auf [Ereignisprozedur] ein. Geben Sie den folgenden Code in das Modul des Berichts ein, und wechseln Sie dann in die Seitenansicht.

Private Sub Detail_Print(Cancel As Integer, PrintCount As Integer)
    Const conPI = 3.14159265359

    Dim sngHMitte As Single, sngVMitte As Single, sngRadius As Single
    Dim sngStart As Single, sngEnde As Single

    sngHMitte = Me.ScaleWidth / 2            ' Horizontale Position
    ' des Mittelpunkts.
    sngVMitte = Me.ScaleHeight / 2            ' Vertikale Position
    ' des Mittelpunkts.
    sngRadius = Me.ScaleHeight / 3            ' Kreisradius.
    Me.Circle(sngHMitte, sngVMitte), sngRadius    ' Kreis zeichnen.
    sngStart = -0.00000001                    ' Beginn des Kreissektors.

sngEnde = -2 * conPI / 3                        ' Ende des Kreissektors.
    Me.FillColor = RGB(255,0,0)            ' Kreissektor rot färben.
    Me.FillStyle = 0                            ' Kreissektor füllen.
    ' Kreissektor innerhalb des Kreises zeichnen.
    Me.Circle(sngHMitte, sngVMitte), sngRadius, , sngStart, sngEnde

    ' Linie zum Kreismittelpunkt zeichnen.
    Dim intFarbe As Integer
    Dim sngOben As Single, sngLinks As Single
    Dim sngBreite As Single, sngHöhe As Single

    Me.ScaleMode = 3                            ' Maßeinheit auf Pixel
    ' einstellen.
    sngOben = Me.ScaleTop                        ' Oberer Innenrand.
    sngLinks = Me.ScaleLeft                    ' Linker Innenrand.
    sngBreite = Me.ScaleWidth / 2            ' Innenbreite.
    sngHöhe = Me.ScaleHeight / 2            ' Innenhöhe.
    intFarbe = RGB(255, 0, 0)                ' Farbe Rot verwenden.

    ' Linie zeichnen.
    Me.Line (sngOben, sngLinks)-(sngBreite, sngHöhe), intFarbe
End Sub


 Filter-Eigenschaft

Filter-Eigenschaft

Die Eigenschaft Filter wendet einen Filter auf ein Objekt Recordset an. Sie können sie nur unter Verwendung von Visual Basic einstellen.

Anmerkung Die Microsoft Access-Eigenschaft Filter wendet einen Filter auf ein Formular an. Sie können sie in einem Makro, in Visual Basic oder im Eigenschaftenfenster eines Formulars in der Formularentwurfsansicht einstellen.


FolderSuffix-Eigenschaft: Beispiel

Dieses Beispiel gibt das Ordnersuffix zurück, das von der Datenzugriffsseite ("Inventory") verwendet wird. Das Suffix wird in der Zeichenfolgenvariablen strFolderSuffix zurückgegeben.

strFolderSuffix = DataAccessPages("Inventar").WebOptions.FolderSuffix


FontBold-Eigenschaft (SchriftFett) - Beispiel

In der folgenden Print-Ereignisprozedur werden der Titel eines Berichts und das aktuelle Datum ab den Koordinaten auf dem Bericht fett ausgezeichnet gedruckt, die durch die Einstellungen der Eigenschaften CurrentX und CurrentY angegeben sind.

Private Sub Berichtskopf0_Print(Cancel As Integer, _
     PrintCount As Integer)
    Dim Datum1

    Datum1 = Date
    Me.Fontbold = True
    ' Berichtstitel fett drucken
    Me.Print("Umsatzverwaltungsbericht")
    Me.Print(Datum1)
End Sub


ForceNewPage-Eigenschaft (NeueSeite) - Beispiel

Im folgenden Beispiel wird der Wert, auf den die Eigenschaft ForceNewPage des Detailbereichs des Berichts Umsätze nach Jahr eingestellt ist, der Variablen intWertLesen zugewiesen.

Dim intWertLesen As Integer
intWertLesen = Reports![Umsätze nach Jahr].Section(acDetail).ForceNewPage


ForeignName-, ForeignTable-, Table-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel verwendet die Eigenschaften ForeignName, ForeignTable und Table, um eine Beziehung zwischen zwei bestehenden Tabellen zu erstellen, in diesem Fall zwischen Personal (Primärtabelle) und Bestellungen (Fremdtabelle) in der aktuellen Datenbank. Personal-Nr ist der Primärschlüssel in der Tabelle Personal und auch ein Fremdschlüssel in der Tabelle Bestellungen. Es handelt sich um eine 1:n-Beziehung, und die referenzielle Integrität wird erzwungen.

Der Operator And ermittelt die momentan eingestellten Berechtigungen durch einen bitweisen Vergleich.

Sub Neue Beziehung()
    Dim dbs As Database
    Dim fld As Field, rel As Relation

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bestehende PersonalBestellungen-Beziehung suchen.
    For Each rel In dbs.Relations
        If rel.Table = "Personal" _
            And rel.ForeignTable = "Bestellungen"
            Then
            ' Benutzer vor dem Löschen der Beziehung informieren.
            If MsgBox(rel.Name & " besteht bereits. " _
                & vbCrLf & "Diese Beziehung wird gelöscht und neu erstellt.", _
                    vbOK) = vbOK Then
                dbs.Relations.Delete rel.Name
            ' Falls Benutzer "Abbrechen" wählt, Prozedur beenden.
            Else
                Exit Sub
            End If
        End If
    Next rel
    ' Neue Beziehung erstellen und deren Eigenschaften einstellen.
    Set rel = dbs.CreateRelation("PersonalBestellungen")
    ' Eigenschaft "Table" einstellen.
    rel.Table = "Personal"
    ' Eigenschaft "ForeignTable" einstellen.
    rel.ForeignTable = "Bestellungen"
    ' Attribute des Relation-Objekts einstellen, um referentielle Integrität zu erzwingen.
    rel.Attributes = dbRelationDeleteCascade And dbRelationUpdateCascade
    ' Feld in der Fields-Auflistung der Beziehung erstellen.
    Set fld = rel.CreateField("[Personal-Nr]")
    ' Name des Fremdschlüsselfelds bereitstellen.
    fld.ForeignName = "[Personal-Nr]"
    ' Feld an Beziehung und Beziehung an Datenbank anfügen.
    rel.Fields.Append fld
    dbs.Relations.Append rel
    MsgBox "Beziehung '" & rel.Name & "' erstellt."
    Set dbs = Nothing
End Sub


Foreign-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel gibt den Wert der Eigenschaft Foreign für jeden Index in der Tabelle Bestellungen aus.

Sub ForeignEigenschaftPrüfen()
    Dim dbs As Database, tdf As TableDef, idx As Index

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Bestellungen" zurückgeben.
    Set tdf = dbs.TableDefs!Bestellungen
    ' Indexes-Auflistung der Tabelle "Bestellungen" durchlaufen.
    For Each idx In tdf.Indexes
        ' Wert der Eigenschaft "Foreign" ausgeben.
        Debug.Print idx.Name; "        "; idx.Foreign
    Next idx
    Set dbs = Nothing
End Sub


 Format-Eigenschaft - Datentyp "Datum/Uhrzeit"

Format-Eigenschaft - Datentyp "Datum/Uhrzeit"

Sie können die Eigenschaft Format auf vordefinierte Datums- und Zeitformate oder auf benutzerdefinierte Formate für die Datentypen Datum und Zeit einstellen.

Einstellung

Vordefinierte Formate

Die folgende Tabelle zeigt die vordefinierten Einstellungen der Eigenschaft Format für die Datentypen Datum/Uhrzeit.

Einstellung | Beschreibung
Standarddatum | (Standardeinstellung) Enthält der Wert nur ein Datum, so wird keine Uhrzeit angezeigt. Enthält der Wert nur eine Uhrzeit, so wird kein Datum angezeigt. Diese Einstellung ist eine Kombination der Einstellungen Datum, kurz und Zeit, lang. Beispiele: 03.04.93; 17:34:00; 03.04.93 17:34:00
Datum, lang | Entspricht der Einstellung Langes Datumsformat im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows. Beispiel: Samstag, 6. April 1996.
Datum, mittel | Beispiel: 03. Apr. 93.
Datum, kurz | Entspricht der Einstellung Kurzes Datumsformat im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows. Beispiel: 06.04.96. Warnung Bei der Einstellung Kurzes Datum wird davon ausgegangen, dass Daten zwischen dem 1.1.00 und 31.12.29 Daten des 21. Jahrhunderts darstellen (d. h. dass die Jahre als 2000 und 2029 angesehen werden). Bei Daten zwischen dem 1.1.30 und dem 31.12.99 wird davon ausgegangen, dass es sich um Daten des 20. Jahrhunderts handelt (d. h. dass die Jahre als 1930 und 1999 angesehen werden).
Zeit, lang | Entspricht der Einstellung auf der Registerkarte Zeitformat im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows. Beispiel: 17:34:23.
Zeit, 12Std | Beispiel: 05:34.
Zeit, 24Std | Beispiel: 17:34.

Benutzerdefinierte Formate

Sie können benutzerdefinierte Datums- und Zeitformate mit Hilfe der folgenden Symbole erstellen.

Symbol | Beschreibung
: (Doppelpunkt) | Zeit-Trennzeichen. Trennzeichen werden im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows eingestellt.
. (Punkt) | Datumstrennzeichen.
g | Entspricht dem vordefinierten Format Standarddatum.
t | Monatstag mit einer oder zwei Ziffern (1 bis 31).
tt | Monatstag mit zwei Ziffern (01 bis 31).
ttt | Die ersten drei Buchstaben des Wochentags (Son bis Sam).
tttt | Vollständiger Name des Wochentags (Sonntag bis Samstag).
ttttt | Entspricht dem vordefinierten Format Datum, kurz.
tttttt | Entspricht dem vordefinierten Format Datum, lang.
w | Wochentag (1 bis 7).
ww | Kalenderwoche (1 bis 53).
m | Monat des Jahres mit einer oder zwei Ziffern (1 bis 12).
mm | Monat des Jahres mit zwei Ziffern (01 bis 12).
mmm | Die ersten drei Buchstaben des Monats (Jan bis Dez).
mmmm | Vollständiger Name des Monats (Januar bis Dezember).
q | Datum als Quartal angezeigt (1 bis 4).
j | Kalendertag (1 bis 366).
jj | Die letzten zwei Ziffern der Jahreszahl (01 bis 99).
jjjj | Vollständige Jahreszahl (0100 bis 9999).
h | Stunde mit einer oder zwei Ziffern (0 bis 23).
hh | Stunde mit zwei Ziffern (00 bis 23).
n | Minute mit einer oder zwei Ziffern (0 bis 59).
nn | Minute mit zwei Ziffern (00 bis 59).
s | Sekunde mit einer oder zwei Ziffern (0 bis 59).
SMS | Sekunde mit zwei Ziffern (00 bis 59).
zzzzz | Entspricht dem vordefinierten Format Zeit, lang.
AM/PM | Zwölf-Stunden-Format mit den Großbuchstaben AM oder PM.
am/pm | Zwölf-Stunden-Format mit den Kleinbuchstaben am oder pm.
A/P | Zwölf-Stunden-Format mit den Großbuchstaben A oder P.
a/p | Zwölf-Stunden-Format mit den Kleinbuchstaben a oder p.
AMPM | Zwölf-Stunden-Format mit der Kennzeichnung für Vormittag/Nachmittag, wie im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows angegeben.

Die benutzerdefinierten Formate werden so angezeigt wie im Dialogfeld Eigenschaften von Ländereinstellungen in der Systemsteuerung von Windows angegeben. Benutzerdefinierte Formate, die mit dieser Einstellung nicht verträglich sind, werden ignoriert.

Anmerkung Wenn Sie zu einem benutzerdefinierten Format ein Komma oder ein anderes Trennzeichen hinzufügen möchten, geben Sie es in Anführungszeichen wie folgt ein: mmm t", "jjjj.


Format-Eigenschaft - Datentyp "Datum/Uhrzeit" - Beispiel

Nachfolgend werden Beispiele von benutzerdefinierten Datum/Uhrzeit-Formaten dargestellt.

Einstellung | Anzeige
ttt", "mmm t", "jjjj | Mon, Jun 3, 1996
mmmm tt", "jjjj | Juni 03, 1996
"Dies ist Woche Nummer "ww | Dies ist Woche Nummer 22
"Heute ist "tttt | Heute ist Dienstag

Sie können ein benutzerdefiniertes Format erstellen, das Jahresangaben bei Eingabe einer positiven Zahl um "A.D." (vor dem Jahr) bzw. bei Eingabe einer negativen Zahl um "v. Chr." (hinter dem Jahr) ergänzt. Wenn Sie dieses benutzerdefinierte Format testen möchten, erstellen Sie ein neues Tabellenfeld, stellen Sie den Datentyp auf Zahl ein, und geben Sie das folgende Datenformat ein:

"A.D. " #;# " v.Chr."

Positive Zahlen werden als Jahreszahlen mit vorgestelltem "A.D." (Anno Domini) angezeigt. Negative Zahlen werden als Jahreszahlen mit nachgestelltem "v. Chr." dargestellt.


 Format-Eigenschaft - Datentypen "Zahl" und "Währung"

Format-Eigenschaft - Datentypen "Zahl" und "Währung"

Sie können die Eigenschaft Format Datentypen Zahl und Währung auf vordefinierte oder benutzerdefinierte Zahlenformate einstellen.

Einstellung

Vordefinierte Formate

Die folgende Tabelle zeigt die vordefinierten Einstellungen der Eigenschaft Format für Zahlen.

Einstellung | Beschreibung
Allgemeine Zahl | (Standardeinstellung) Zeigt die Zahl wie eingegeben an.
Währung | Verwenden Sie das 1000er-Trennzeichen; befolgen Sie die in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Einstellungen für negative Beträge, Dezimal- und Währungssymbole und Dezimalstellen.
Euro | Verwenden Sie das Währungsformat mit dem Euro-Symbol ( [image] ), unabhängig von dem in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Währungssymbol.
Festkommazahl | Zeigt mindestens eine Ziffer an; befolgen Sie die in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Einstellungen für negative Beträge, Dezimal- und Währungssymbole und Dezimalstellen.
Standardzahl | Verwenden Sie das 1.000er-Trennzeichen; befolgen Sie die in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Einstellungen für negative Beträge, Dezimal- und Währungssymbole und Dezimalstellen.
Prozentzahl | Multiplizieren Sie den Wert mit 100 und fügen Sie das Prozentzeichen an (%); befolgen Sie die in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Einstellungen für negative Beträge, Dezimal- und Währungssymbole und Dezimalstellen.
Exponentialzahl | Verwendet die Standardschreibweise für Exponentialzahlen.

Benutzerdefinierte Formate

Benutzerdefinierte Zahlenformate können bis zu vier Bereichen enthalten, die jeweils durch ein Semikolon (;) als Listentrennzeichen voneinander getrennt sind. Jeder Bereich enthält die Formatangabe für einen anderen Zahlentyp.

Bereich | Beschreibung
Erster | Das Format für positive Zahlen.
Zweiter | Das Format für negative Zahlen.
Dritter | Das Format für leere Werte.
Vierter | Das Format für Null-Werte.

Beispielsweise können Sie das folgende benutzerdefinierte Format für Währung verwenden:

$#,##0.00[Grün];($#,##0.00)[Rot];"Zero";"Null"

Dieses Zahlenformat enthält vier Bereiche, die durch ein Semikolon voneinander getrennt sind. Für jeden Bereich wird ein anderes Format verwendet.

Wenn Sie mehrere Bereiche verwenden, aber nicht für jeden Bereich ein eigenes Format angeben, wird in den Bereichen ohne Formatangabe nichts angezeigt, oder es wird das Format des ersten Bereichs als Standardformat übernommen.

Sie können benutzerdefinierte Zahlenformate mit Hilfe der folgenden Symbole erstellen.

Symbol | Beschreibung
. (Punkt) | Dezimaltrennzeichen. Trennzeichen werden in der Systemsteuerung von Windows durch Doppelklicken auf Ländereinstellungen eingestellt.
, (Komma) | 1.000er-Trennzeichen.
0 | Platzhalter für eine Ziffer. Zeigt eine Ziffer oder 0 an.
# | Platzhalter für eine Ziffer. Zeigt eine Ziffer oder nichts an.
$ | Zeigt das Literalzeichen $ an.
% | Prozentsatz. Der Wert wird mit 100 multipliziert, und ein Prozentzeichen wird angefügt.
E- oder e- | Schreibweise für Exponentialzahlen mit einem Minuszeichen (-) vor negativen Exponenten und keinem Vorzeichen vor positiven Exponenten. Das Symbol muss zusammen mit anderen Symbolen verwendet werden, z. B. wie in 0.00E-00 oder 0.00E00.
E+ oder e+ | Schreibweise für Exponentialzahlen mit einem Minuszeichen vor negativen Exponenten und einem Pluszeichen (+) vor positiven Exponenten. Das Symbol muss zusammen mit anderen Symbolen verwendet werden, z. B. wie in 0.00E+00.

Anmerkung

Sie können die Eigenschaft DecimalPlaces verwenden, um die Standardzahl von Dezimalstellen für das vordefinierte Format anzuzeigen, das mit der Eigenschaft Format festgelegt wurde.

Die voreingestellten Währungs- und Euroformate richten sich nach den in der Windows-Systemsteuerung unter Ländereinstellungen festgelegten Einstellungen. Diese können aufgehoben werden, indem Sie Ihr eigenes Währungsformat definieren.


Format-Eigenschaft - Datentypen "Zahl" und "Währung" - Beispiel

Die folgenden Beispiele zeigen die vordefinierten Zahlenformate.

Einstellung | Daten | Anzeige
Allgemeine Zahl | 3456,789 -3456,789 DM 213,21 | 3456,789 -3456,789 DM 213,21
Währung | 3456,789 -3456,789 | DM 3.456,79 (DM 3.456,79)
Festkommazahl | 3456,789 -3456,789 3,56645 | 3456,79 -3456,79 3,57
Standardzahl | 3456,789 | 3.456,79
Prozentzahl | 3 0,45 | 300% 45%
Exponentialzahl | 3456,789 -3456,789 | 3,46E+03 -3,46E+03

Die folgenden Beispiele zeigen benutzerdefinierte Zahlenformate.

Einstellung | Beschreibung
0;(0);;"Null" | Zeigt positive Werte normal an; zeigt negative Werte in Klammern an; zeigt das Wort "Null" an, wenn der Wert Null ist.
+0,0;-0,0;0,0 | Zeigt ein Plus- (+) oder Minuszeichen (-) bei positiven bzw. negativen Zahlen an; zeigt 0,0 an, wenn der Wert Null ist.


 Format-Eigenschaft - Datentypen "Text" und "Memo"

Format-Eigenschaft - Datentypen "Text" und "Memo"

Sie können in der Eigenschaft Format verschiedene Sonderzeichen angeben, um benutzerdefinierte Formate für Felder vom Typ Text und Memo zu erstellen.

Einstellung

Sie können benutzerdefinierte Text- und Memo-Formate mit Hilfe der folgenden Sonderzeichen erstellen.

Symbol | Beschreibung
@ | Ein Textzeichen (kann auch ein Leerzeichen sein) muss angegeben werden.
& | Ein Textzeichen kann angegeben werden, muss aber nicht.
< | Alle Zeichen in Kleinbuchstaben.
> | Alle Zeichen in Großbuchstaben.

Benutzerdefinierte Formate für Felder vom Typ Text und Memo können aus maximal zwei Bereichen bestehen. Jeder Bereich enthält die Formatangabe für andere Daten in einem Feld.

Bereich | Beschreibung
Erster | Format für Felder mit Text.
Zweiter | Format für Felder mit leeren Zeichenfolgen und Null-Werten.

Soll z.B. in einem Textfeld-Steuerelement das Wort "Keine" angezeigt werden, wenn sich keine Zeichenfolge im Feld befindet, so geben Sie das benutzerdefinierte Format @;"Keine" als Einstellung der Eigenschaft Format des Steuerelements ein. Das Symbol @ bewirkt, dass der Text des Feldes angezeigt wird; der zweite Bereich bewirkt, dass das Wort "Keine" angezeigt wird, wenn das Feld eine leere Zeichenfolge oder einen Null-Wert enthält.

Anmerkung Sie können die Format-Funktion verwenden, um einen Wert für eine leere Zeichenfolge zurückzugeben und einen anderen für einen Null-Wert. In gleicher Weise können Sie die Format-Eigenschaft dazu verwenden, um Felder in der Datenblattansicht der Tabelle oder Steuerelemente auf einem Formular oder einem Bericht automatisch zu formatieren.


Format-Eigenschaft - Datentypen "Text" und "Memo" - Beispiel

Die folgenden Beispiele zeigen benutzerdefinierte Text- und Memo-Formate.

Einstellung | Daten | Anzeige
@@@-@@-@@@@ | 465043799 | 465-04-3799
@@@@@@@@@ | 465-04-3799 465043799 | 465-04-3799 465043799
> | davolio DAVOLIO Davolio | DAVOLIO DAVOLIO DAVOLIO
< | davolio DAVOLIO Davolio | davolio davolio davolio
@;"Unbekannt" | Null-Wert | Unbekannt
 | Leere Zeichenfolge | Unbekannt
 | Beliebiger Text | Derselbe Text wie der eingegebene


Format-Eigenschaft - Beispiel

Die folgenden drei Beispiele stellen die Eigenschaft Format mit Hilfe eines vordefinierten Formats ein.

Me![Datum].Format = "Medium Date"
Me![Uhrzeit].Format = "Long Time"
Me![Registriert].Format = "Yes/No"

Das nächste Beispiel stellt die Eigenschaft Format mit Hilfe eines benutzerdefinierten Formats ein. Dieses Format zeigt das Datum in der folgenden Form an: Jan 1996.

Formulare![Personal]![Einstellungsdatum].Format = "mmm yyyy"

Das folgende Beispiel zeigt eine Visual Basic-Funktion, die numerische Daten mit dem Format Währung und Textdaten vollständig in Großbuchstaben formatiert. Die Funktion wird vom Ereignis OnLostFocus des ungebundenen Steuerelements Steuerrückerstattung aufgerufen.

Function FormatierenWert() As Integer
    Dim varEingWert As Variant

    varEingWert = Formulare!Fragebogen!Steuerrückerstattung.Value
    If IsNumeric(varEingWert) = True Then
        Formulare!Fragebogen!Steuerrückerstattung.Format = "Currency"
    Else
        Formulare!Fragebogen!Steuerrückerstattung.Format = ">"
    End If
End Function


 Format-Eigenschaft - Datentyp "Ja/Nein"

Format-Eigenschaft - Datentyp "Ja/Nein"

Sie können die Eigenschaft Format für den Datentyp Ja/Nein auf die vordefinierten Formate Ja/Nein, Wahr/Falsch und An/Aus oder auf ein benutzerdefiniertes Format einstellen.

Einstellung

Microsoft Access verwendet ein Kontrollkästchen-Steuerelement als Standard-Steuerelement für den Datentyp Ja/Nein. Vordefinierte und benutzerdefinierte Formate werden nicht beachtet, wenn ein Kontrollkästchen-Steuerelement verwendet wird. Daher gelten diese Formate nur für Daten, die in einem Textfeld-Steuerelement angezeigt werden.

Vordefinierte Formate

Die Eigenschaft Format stellt die vordefinierten Formate Ja/Nein, Wahr/Falsch und An/Aus bereit. Ja, Wahr und An sind äquivalent, und Nein, Falsch und Aus sind äquivalent. Wenn Sie ein vordefiniertes Format angeben und dann einen äquivalenten Wert eingeben, wird das vordefinierte Format des äquivalenten Wertes angezeigt. Wenn Sie z.B. Wahr oder An in einem Textfeld-Steuerelement eingeben, dessen Eigenschaft Format auf Ja/Nein eingestellt ist, wird der Wert automatisch in Ja umgewandelt.

Benutzerdefinierte Formate

Der Datentyp Ja/Nein verwendet benutzerdefinierte Formate mit maximal drei Bereichen.

Bereich | Beschreibung
Erster | Dieser Bereich hat keine Auswirkung auf den Datentyp Ja/Nein. Ein Semikolon (;) muss jedoch als Platzhalter angegeben werden.
Zweiter | Der Text, der an Stelle der Werte Ja, Wahr oder An angezeigt werden soll.
Dritter | Der Text, der an Stelle der Werte Nein, Falsch oder Aus angezeigt werden soll.


Format-Eigenschaft - Datentyp "Ja/Nein" - Beispiel

Das folgende Beispiel zeigt ein benutzerdefiniertes Ja/Nein-Format für ein Textfeld-Steuerelement. Das Steuerelement zeigt für Ja, Wahr oder An das Wort "Immer" in Blau und für Nein, Falsch oder Aus das Wort "Niemals" in Rot an.

;"Immer"[Blau];"Niemals"[Rot]


Form-, Report-Eigenschaften (Formular, Bericht) - Beispiel

Das folgende Beispiel verweist mit Hilfe der Eigenschaften Form und Report auf je ein Steuerelement eines Unterformulars bzw. eines Unterberichts.

Dim curGesamtbetr As Currency
Dim curGesamtumsatz As Currency
curGesamtbetr = Formulare!Bestellungen!Bestelldetails.Form!Gesamtbetrag
curGesamtumsatz = Reports!Verkäufe!Personal.Report!Gesamtumsatz


FrozenColumns-Eigenschaft (FixierteSpalten) - Beispiel

Das folgende Beispiel verwendet die Eigenschaft FrozenColumns, um die Anzahl der in einer Tabelle in der Datenblattansicht fixierten Spalten einzustellen. Sind mehr als drei Spalten fixiert, so wird die Tabellengröße maximiert, so dass Sie so viele nicht fixierte Spalten wie möglich sehen können.

Sub FixierungPrüfen(tblName As String)
    Dim dbs As Object
    Dim tdf As Object
    Dim prp As Variant
    Const DB_Integer As Integer = 3
    Const conPropertyNotFound = 3270  ' Fehler: Eigenschaft nicht gefunden.
    Set dbs = CurrentDb      ' Aktuelle Datenbank bestimmen.
    Set td = db.TableDefs(tblName)      ' Objekt für Tabelle abrufen.
    DoCmd.OpenTable tblName, acNormal  ' Tabelle öffnen.
    tdf.Properties.Refresh
    On Error GoTo Frozen_Err
    If tdf.Properties("FrozenColumns") > 3 Then   ' Tabelleneigenschaft prüfen.
        DoCmd.Maximize
    End If
Frozen_Bye:
    Exit Sub
Frozen_Err:
    If Err = conPropertyNotFound Then      ' Eigenschaft nicht in Auflistung.
        Set prp = tdf.CreateProperty("FrozenColumns", DB_Integer, 1)
        tdf.Properties.Append prp
        Resume Frozen_Bye
    End If
End Sub


FullName-Eigenschaft (GanzerName) - Beispiel

Das folgende Beispiel durchläuft die AllDataAccessPages-Auflistung und gibt den Namen des Links und den Pfad jeder Datenzugriffsseite im aktuellen Projekt zurück.

Sub DruckeDAPPfadInfo()
    Dim dapObject As AccessObject
    For Each dapObject In CurrentProject.AllDataAccessPages
        Debug.Print "'" & dapObject.Name & _
        "' befindet sich in : " & dapObject.FullName
    Next dapObject
End Sub


FullPath-, GUID-, IsBroken-, Major-, Minor-Eigenschaften - Beispiel

Im folgenden Beispiel werden für jedes Reference-Objekt der References-Auflistung die Werte der Eigenschaften FullPath, GUID, IsBroken, Major und Minor ausgegeben:

Sub EigenschaftenDerVerweise()
    Dim ref As Reference

    ' Die References-Auflistung in einer Schleife
    ' durchlaufen.
    For Each ref In References
        ' Die Eigenschaft IsBroken auswerten.
        If ref.IsBroken = False Then
            Debug.Print "Name: ", ref.Name
            Debug.Print "FullPath: ", ref.FullPath
            Debug.Print "Version: ", ref.Major & "." & ref.Minor
        Else
            Debug.Print "GUID eines ungültigen Verweises:"
            Debug.Print ref.GUID
        End If
    Next ref
End Sub


Gruppierungseigenschaften - Beispiel

Das folgende Beispiel stellt die Eigenschaft SortOrder und die Gruppierungseigenschaften für die erste Gruppierungsebene im Bericht Artikel nach Kategorie ein, um eine alphabetische Artikelliste zu erstellen.

Private Sub Report_Open(Cancel As Integer)
    ' Eigenschaft SortOrder (Sortierreihenfolge) auf aufsteigend einstellen.
    Me.GroupLevel(0).SortOrder = False
    ' Eigenschaft GroupOn (GruppierenNach)auf Anfangszeichen einstellen.
    Me.GroupLevel(0).GroupOn = 1
    ' Eigenschaft GroupInterval (Intervall) auf 1 einstellen.
    Me.GroupLevel(0).GroupInterval = 1
    ' Eigenschaft KeepTogether(Zusammenhalten) auf "Mit 1. Detaildatensatz" einstellen.
    Me.GroupLevel(0).KeepTogether = 2
End Sub


Height-, Width-Eigenschaften (Höhe, Breite) - Beispiel

Im folgenden Code wird die Größe einer Befehlsschaltfläche so geändert, dass eine quadratische Schaltfläche mit einer Kantenlänge von 1 Zoll entsteht (die Standardmaßeinheit ist in Visual Basic Twips; 1.440 Twips sind 1 Zoll):

Me!cmdSchaltfläche.Height = 1440    ' 1440 Twips = 1 Zoll.
Me!cmdSchaltläche.Width = 1440


HelpContextID-, HelpFile-Eigenschaft (Hilfekontext-ID, Hilfedatei) - Gilt für

HelpContextID-Eigenschaft

HelpFile-Eigenschaft


 HelpContextId-Eigenschaft (Befehlsleisten)

HelpContextId-Eigenschaft (Befehlsleisten)

Wenn Sie in Microsoft Access 2000 die HelpContextId-Eigenschaft für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen HelpContextId-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie im Feld Hilfe-KontextID die Kennnummer des gewünschten Hilfethemas ein.


 HelpContextID-, HelpFile-Eigenschaften

HelpContextID-, HelpFile-Eigenschaften

Die Eigenschaften HelpContext und HelpFile betreffen das Objekt Error. Sie können darauf nur unter Verwendung von Visual Basic zugreifen.

Anmerkung Verwechseln Sie diese Eigenschaften nicht mit den Microsoft Access-Eigenschaften HelpContextID und HelpFile. Diese Eigenschaften sind verwandt, betreffen aber nur Formulare, Berichte und Steuerelemente. Sie können sie in Visual Basic, in einem Makro oder im Eigenschaftenfenster in der Formularentwurfsansicht oder Berichtentwurfsansicht einstellen.


 HelpFile-Eigenschaft

HelpFile-Eigenschaft

Wenn Sie in Microsoft Access 2000 die HelpFile-Eigenschaft für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen HelpFile-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie im Feld Hilfedatei den Namen der gewünschten Hilfedatei ein.


HideDuplicates-Eigenschaft (Duplikateausblenden) - Beispiel

Im folgenden Beispiel wird der Wert, auf den die Eigenschaft HideDuplicates des Textfelds Kategoriename eingestellt ist, der Variablen intAktWert zugewiesen.

Dim intaktWert As Integer
intaktWert = Me!Kategoriename.HideDuplicates


HighPriorityTips-Eigenschaft

Diese Eigenschaft steht in Microsoft Access nicht zur Verfügung.


hWnd-Eigenschaft - Beispiel

Im folgenden Beispiel wird die Eigenschaft hWnd zusammen mit der Windows API-Funktion IsZoomed verwendet, um zu ermitteln, ob ein Fenster maximiert ist.

' Geben Sie die folgende Anweisung als eine Zeile in
' den Deklarationsbereich des Modulfensters ein.
Declare Function IsZoomed Lib "user32" (ByVal hWnd As Long) As Long

Sub Form_Activate()
    Dim intWindowHandle As Long
    intWindowHandle = Screen.ActiveForm.hWnd
    If Not IsZoomed(intWindowHandle) Then
        DoCmd.Maximize
    End If
End Sub


Hyperlink-Eigenschaft: Beispiel

In der Prozedur HyperlinkErstellen des folgenden Beispiels werden die Hyperlink-Eigenschaften eines Befehlsschaltfläche-, Bezeichnungsfeld- oder Bild-Steuerelements auf die Adresse und Unteradresse eingestellt, die an die Prozedur übergeben werden. Das Argument für die Einstellung der Adresse ist ein optionales Argument, da für ein Hyperlink zu einem Objekt der aktuellen Datenbank nur die Einstellung der Unteradresse verwendet wird. Wenn Sie dieses Beispiel testen möchten, erstellen Sie ein Formular mit zwei Textfeld-Steuerelementen (txtAdresse und txtUnteradresse) sowie einer Befehlsschaltfläche (cmdLinkFolgen) und fügen folgenden Code in das Modul des Formulars ein:

Private Sub cmdLinkFolgen_Click()
    HyperlinkErstellen Me!cmdLinkFolgen, Me!txtUnteradresse, _
         Me!txtAdresse
End Sub

Sub HyperlinkErstellen(ctlAusgewählt As Control, _
    strUnteradresse As TextBox, Optional strAdresse As TextBox)
    Dim hlk As Hyperlink
    Select Case ctlAusgewählt.ControlType
        Case acLabel, acImage, acCommandButton
            Set hlk = ctlAusgewählt.Hyperlink
            With hlk
                If Not IsMissing(strAdresse) Then
                    .Address = strAdresse
                Else
                    .Address = ""
                End If
                .SubAddress = strUnteradresse
                .Follow
                .Address = ""
                .SubAddress = ""
            End With
        Case Else
            MsgBox "Das Steuerelement '" & ctlAusgewählt.Name_
                 & "' unterstützt keine Hyperlinks."
    End Select
End Sub


 Id-Eigenschaft

Id-Eigenschaft

Die Id-Eigenschaft kann nur beim Erstellen eines neuen Steuerelements eingestellt werden. Stellen Sie das Argument ID der Add-Methode der CommandBarControls-Auflistung auf einen Wert vom Typ Integer ein, der einer eingebauten Befehlsschaltfläche oder einem Menüelement bzw. einer der entsprechenden eingebauten Konstanten entspricht, die in Microsoft Access mit der RunCommand-Methode verwendet werden. Für ein AktiveX-Steuerelement stellen Sie das Argument ID auf 1 ein, oder lassen Sie es leer.

Mit der Id-Eigenschaft können Sie den Wert vom Typ Integer bestimmen, der einem eingebauten Steuerelement entspricht. Wenn Sie z. B. den Integer-Wert bestimmen möchten, der dem Befehl Einfügen im Menü Bearbeiten der Hauptmenüleiste entspricht, verwenden Sie den folgenden Verweis:

CommandBars("Menu Bar").Controls("Bearbeiten")._
Controls("Einfügen").Id


ImageHeight-, ImageWidth-Eigenschaft - Beispiel

Das folgende Beispiel fordert den Benutzer dazu auf, den Namen einer Bitmap einzugeben, und weist diese Bitmap dann der Eigenschaft Picture des Bild-Steuerelements Bild1 zu. Die Eigenschaften ImageHeight und ImageWidth werden zur Größenänderung des Bild-Steuerelements in Abhängigkeit zur Größe der Bitmap verwendet.

Sub NeuesBildAbrufen(frm As Form)
    Dim ctlBild As Control
    Set ctlBild = frm!Bild1
    ctlBild.Picture = InputBox("Pfad und Dateiname" _
        & "für neue Bitmap?")
    ctlBild.Height = ctlBild.ImageHeight
    ctlBild.Width = ctlBild.ImageWidth
End Sub


IMESentenceMode-Eigenschaft

Sprachspezifische Informationen

You can use the IMESentenceMode property specify or determine the IME Sentence Mode of fields of a table or controls of a form that switch when the focus moves.

Setting

The IMESentenceMode property uses the following settings.

Setting | Description | Visual Basic
Normal | (Default) Set IME Sentence Mode to “Normal” mode. | 0
Plural | Set IME Sentence Mode to “Plural” mode. | 1
Speaking | Set IME Sentence Mode to “Speaking” mode. | 2
No Conversion | Doesn’t set IME Sentence Mode. | 3

You can set this property by using the property sheet, a macro, or Visual Basic.

Remarks

Normal mode

Use this mode when creating a literary Japanese document.

Plural mode

Use this mode when entering name or address data. In this mode, two additional dictionaries are available. The “Biographical/Geographical Dictionary” contains names not covered in the normal dictionary and the “Postal Code Dictionary”, useful in creating addresses. (Factory setting.)

Speaking mode

Use this mode when entering data that contains conversational language.

No Conversion

In this mode, inputted characters are settled without conversion.


Index-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel stellt den Index für ein Recordset-Objekt vom Typ Tabelle auf den Primärschlüssel ein. "PrimaryKey" ist der Standardname eines Index-Objekts, wenn der Index dem Primärschlüssel entspricht, der in der Tabellenentwurfsansicht eingestellt wurde. Anschließend wird der Benutzer zur Eingabe eines Wertes aufgefordert, der für die Suche verwendet wird, und es wird nach einem Datensatz mit dem passenden Schlüsselfeldwert gesucht. Beachten Sie, dass der aktuelle Index eingestellt sein muss, bevor bestimmte Operationen, wie die Methode Seek, auf einem Recordset-Objekt vom Typ Tabelle durchgeführt werden können.

Sub PrimärschlüsselVerwenden()
    Dim dbs As Database, rst As Recordset
    Dim fld As Field, strEingabe As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle erstellen.
    Set rst = dbs.OpenRecordset("Bestellungen", dbOpenTable)
    ' Aktuellen Index einstellen.
    rst.Index = "PrimaryKey"
    strEingabe = InputBox("Geben Sie die zu suchende Bestell-Nr ein.")
    ' Datensatz suchen.
    rst.Seek "=", strEingabe
    If Not rst.NoMatch Then
        For Each fld in rst.Fields
            Debug.Print fld.Name; "   "; fld.Value
        Next fld
    End If
    rst.Close
    Set dbs = Nothing
End Sub


 Inherited-Eigenschaft (MDB)

Inherited-Eigenschaft (MDB)

Microsoft Access definiert eine Reihe von Eigenschaften, die Datenzugriffsobjekte betreffen. Da diese Eigenschaften von Microsoft Access definiert werden, werden sie von der Microsoft Jet-Datenbank-Engine nicht automatisch erkannt. Sie können diese Eigenschaften unter Verwendung von Visual Basic nur einstellen, wenn Sie die Eigenschaften zuerst mit Hilfe der Methode CreateProperty erstellen und dann an die Auflistung Properties des Objekts anfügen. Weitere Informationen finden Sie im Hilfeindex unter "Property-Objekt".

Wenn Sie ein Objekt erstellen, das auf einem anderen Objekt basiert, übernimmt das abgeleitete Objekt die Eigenschaften des ursprünglichen Objekts. Sie können die Eigenschaft Inherited verwenden, um festzustellen, ob eine dieser Eigenschaften für das zugehörige Objekt erstellt wurde oder ob die Eigenschaft von einem anderen Objekt übernommen wurde.

Nehmen Sie z.B. an, Sie möchten die Microsoft Access-Eigenschaft DatasheetFontName für ein Objekt TableDef einstellen. Wenn Sie diese Eigenschaft zum ersten Mal einstellen, müssen Sie ein entsprechendes Property-Objekt erstellen und an die Auflistung Properties des Objekts TableDef anfügen. Die Eigenschaft Inherited des neuen Property-Objekts gibt in diesem Fall False (0) zurück.

Wenn Sie dann ein neues QueryDef-Objekt erstellen, das auf der Tabelle basiert, die dem Objekt TableDef entspricht, wird die Eigenschaft DatasheetFontName in die Auflistung Properties des Objekts QueryDef aufgenommen. Die Eigenschaft Inherited eines Property-Objekts für dieses Objekt gibt in diesem Fall True (-1) zurück.


Inherited-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel erstellt ein Property-Objekt in der Properties-Auflistung eines TableDef-Objekts und erstellt dann ein neues QueryDef-Objekt, das auf der gleichen Tabelle basiert. Das Property-Objekt wird automatisch in der Properties-Auflistung des neuen QueryDef-Objekts übernommen. Anschließend überprüft die Prozedur die Eigenschaft Inherited für die Property-Objekte in den Properties-Auflistungen der beiden Objekte TableDef und QueryDef.

Im folgenden Beispiel wird die Microsoft Access-Eigenschaft DatasheetFontItalic erstellt und an die Properties-Auflistung des Objekts TableDef angefügt. Die Eigenschaft DatasheetFontItalic wird nicht von der Microsoft Jet-Datenbank-Engine definiert, sondern von Microsoft Access. Dennoch wird die Eigenschaft auf DAO-Objekte angewendet. Um diese Eigenschaft aus Visual Basic-Code einstellen zu können, erstellen Sie deshalb zuerst ein Property-Objekt, das dieser Eigenschaft entspricht, und fügen es an die Properties-Auflistung des DAO-Objekts an. Die Eigenschaft muss nur erstellt werden, wenn Sie sie zum ersten Mal einstellen.

Sub InheritedPrüfen()
    Dim dbs As Database, tdf As TableDef, qdf As QueryDef
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Bestellungen" zurückgeben.
    Set tdf = dbs.TableDefs!Bestellungen
    ' Funktion AccessEigenschaftEinstellen aufrufen.
    If AccessEigenschaftEinstellen(tdf, "DatasheetFontItalic", _
            dbBoolean, True) = True Then
    ' QueryDef-Objekt erstellen, das auf der Tabelle "Bestellungen"
    ' basiert.
        strSQL = "SELECT * FROM Bestellungen WHERE [Bestimmungsland]= 'USA';"
        Set qdf = dbs.CreateQueryDef("USABestellungen", strSQL)
    ' Property-Objekt zurückgeben, das auf die Eigenschaft verweist.
        Debug.Print "Wert von Inherited, TableDef-Objekt:", _
            tdf.Properties!DatasheetFontItalic.Inherited
        Debug.Print "Wert von Inherited, QueryDef-Objekt:", _
            qdf.Properties!DatasheetFontItalic.Inherited
            ExitInheritedPrüfen
    Else
        MsgBox "Eigenschaft nicht erfolgreich gesetzt."
        ExitInheritedPrüfen
    End If

ExitInheritedPrüfen:
    Set dbs = Nothing
    Exit Sub
End Sub

Diese Prozedur ruft die folgende Funktion auf, die die Eigenschaft einstellt, indem sie sie, falls notwendig, in der Properties-Auflistung erstellt:

Function AccessEigenschaftEinstellen(obj As Object, strName As String, _
        intTyp As Integer, varEinstellung As Variant) As Boolean
    Dim prp As Property
    Const conEigNichtGef As Integer = 3270

    On Error GoTo FehlerAccessEigenschaftEinstellen
    ' Explizit auf die Properties-Auflistung verweisen.
    obj.Properties(strName) = varEinstellung
    obj.Properties.Refresh
    AccessEigenschaftEinstellen = True

BeendenAccessEigenschaftEinstellen:
    Exit Function

FehlerAccessEigenschaftEinstellen:
    If Err = conEigNichtGef Then
        ' Eigenschaft erstellen, Typ festlegen, Anfangswert einstellen.
        Set prp = obj.CreateProperty(strName, intTyp, varEinstellung)
        ' Eigenschaft-Objekt an die Properties-Auflistung anfügen.
        obj.Properties.Append prp
        obj.Properties.Refresh
        AccessEigenschaftEinstellen = True
        Resume BeendenAccessEigenschaftEinstellen
    Else
        MsgBox Err & ": " & vbCrLf & Err.Description
        AccessEigenschaftEinstellen = False
        Resume BeendenAccessEigenschaftEinstellen
    End If
End Function


Inherit-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel stellt die Eigenschaft Inherit des Container-Objekts Forms auf True (-1) und dann die Eigenschaft Permissions so ein, dass Benutzern Vollzugriff auf alle Formulare unter Verwendung der Sicherheitsfunktionen gewährt wird. Alle neuen Document-Objekte des Typs Form übernehmen diese Berechtigungen. Die Prozedur erstellt anschließend ein neues Form-Objekt und zeigt die Berechtigungen für das Objekt an.

Beachten Sie den Unterschied zwischen dem Container-Objekt Forms und der Forms-Auflistung. Das Container-Objekt Forms enthält alle Document-Objekte vom Typ Form in der Datenbank; die Forms-Auflistung enthält nur die momentan geöffneten Formulare.

Der Operator Or ermittelt die momentan eingestellten Berechtigungen durch einen bitweisen Vergleich.

Sub Formularberechtigungen()
    Dim dbs As Database, ctrForms As Container
    Dim docForm As Document, frmNeu As Form

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Forms-Container zurückgeben.
    Set ctrForms = dbs.Containers!Forms
    ' Eigenschaft "Inherit" einstellen.
    ctrForms.Inherit = True
    ' Zu übernehmende Berechtigungen festlegen.
    ctrForms.Permissions = ctrForms.Permissions Or_
        acSecFrmRptWriteDef
    ' Neues Formular erstellen.
    Set frmNeu = CreateForm()
    ' Formular speichern.
    DoCmd.Save , "Bestellformular"
    ' Document-Objekt zurückgeben, das mit dem neuen Formular verbunden
    wird.
    Set docForm = ctrForms.Documents!Bestellformular
    ' Berechtigungen der Container- und Document-Objekte vergleichen.
    If docForm.Permissions <> ctrForms.Permissions Then
        MsgBox "Fehler!"
    Else
        MsgBox "Berechtigungen erfolgreich übernommen."
    End If
    Set dbs = Nothing
End Sub


InputMask-Eigenschaft (Eingabeformat) - Beispiel (Hilfreiche Eingabeformate)

Die folgende Tabelle enthält hilfreiche Eingabeformate und zeigt, welche Werte Sie jeweils eingeben können.

Eingabeformat | Beispielwerte
(0000) 000-0000 | (0231) 721-4642
(9999) 000-0000! | (0231) 721-4642
 | ( ) 721-4642
(0000) AAA-AAAA | (0231) 721-HUGO
#999 | -20
 | 2000
>L???L?000L0 | GELBGE339M3
 | MAI R 452B7
>L0L 0L0 | T2F 8M4
00000-9999 | 98115-
 | 98115-3007
>L<?????????????? | Petra
 | Kruggel
ISBN 0-&&&&&&&&&-0 | ISBN 1-55615-507-7
>LL00000-0000 | DB51392-0493


InSelection-Eigenschaft (InAuswahl) - Beispiel

In der folgenden Funktion wird mit der Eigenschaft InSelection ermittelt, ob auf dem angegebenen Formular das Steuerelement strSteuElemName ausgewählt ist.

Gehen Sie wie folgt vor, wenn Sie diese Funktion testen möchten: Kopieren Sie die Funktion IstSteuElemAusgewählt in den Deklarationsbereich eines Codemoduls der Nordwind-Beispieldatenbank, öffnen Sie das Formular Kunden in der Entwurfsansicht, wählen Sie das Steuerelement Firma aus, und geben Sie dann folgende Zeile in das Testfenster ein:

? IstSteuElemAusgewählt (Formulare!Kunden, "Firma")

Function IstSteuElemAusgewählt(frm As Form, _
     strSteuElemName As String) As Integer
    Dim intI As Integer, ctl As Control
    If frm.CurrentView <> 0 Then
        ' Das Formular ist nicht in der Entwurfsansicht geöffnet.
        Exit Function
    Else
        For intI = 0 To frm.Count - 1
            Set ctl = frm(intI)
            If ctl.InSelection = True Then
                ' Ist das gewünschte Steuerelement ausgewählt?
                If UCase(ctl.Name) = UCase(strSteuElemName) Then
                    IstSteuElemAusgewählt = True
                    Exit Function
                End If
            Else
                IstSteuElemAusgewählt = False
            End If
        Next intI
    End If
End Function


InsideHeight, InsideWidth-Eigenschaften - Beispiel

Das folgende Beispiel zeigt, wie Sie mit Hilfe der Eigenschaften InsideHeight und InsideWidth die Innenhöhe und -breite eines Formulars mit der Höhe und Breite des Formularfensters vergleichen können. Entsprechen die Abmessungen des Fensters nicht der Größe des Formulars, wird die Größe des Fensters an die Höhe und Breite des Formulars angepasst.

Sub FestlegenFenstergröße(frm As Form)
    Dim intFensterhöhe As Integer
    Dim intFensterbreite As Integer
    Dim intGesamthöheFormular As Integer
    Dim intGesamtbreiteFormular As Integer
    Dim intHöheKopfbereich As Integer
    Dim intHöheDetailbereich As Integer
    Dim intHöheFußbereich As Integer

    ' Höhe des Formulars bestimmen.
    intHöheKopfbereich = frm.Section(acHeader).Height
    intHöheDetailbereich = frm.Section(acDetail).Height
    intHöheFußbereich = frm.Section(acFooter).Height
    intGesamthöheFormular = intHöheKopfbereich _
        + intHöheDetailbereich + intHöheFußbereich
    ' Breite des Formulars bestimmen.
    intGesamtbreiteFormular = frm.Width
    ' Höhe und Breite des Fensters bestimmen.
    intFensterhöhe = frm.InsideHeight
    intFensterbreite = frm.InsideWidth

    If intFensterbreite <> intGesamtbreiteFormular Then
        frm.InsideWidth = intGesamtbreiteFormular
    End If
    If intFensterhöhe <> intGesamthöheFormular Then
        frm.InsideHeight = intGesamthöheFormular
    End If
End Sub


IsVisible-Eigenschaft - Beispiel

Im folgenden Beispiel wird die Eigenschaft IsVisible eines Textfelds verwendet, um zu steuern, wann ein Linie-Steuerelement auf einem Bericht angezeigt wird. Der Bericht basiert auf der Tabelle Artikel und enthält drei Steuerelemente, deren hier aufgeführte Eigenschaften wie folgt eingestellt sind.

Eigenschaft | Linie-Steuerelement | Textfeld 1 | Textfeld 2
Name | Linie0 | Kategorie-Nr | Artikelname
ControlSource |  | Kategorie-Nr | Artikelname
HideDuplicates |  | Ja | Nein
Left | 0 | 0 | 5,0
Top | 0 | 0,3 | 0,3
Width | 10,0 | 2,5 | 2,5

Fügen Sie folgenden Code in das Codemodul des Berichts ein. Zeigen Sie dann den Bericht an, um zu sehen, wie die Formatierung der Linie durch die Eigenschaft IsVisible gesteuert wird:

Private Sub Detailbereich_Print(Cancel As Integer, PrintCount As Integer)
    If Me![Kategorie-Nr].IsVisible Then
        Me!Linie0.Visible = True
    Else
        Me!Linie0.Visible = False
    End If
End Sub


ItemData-Eigenschaft - Beispiel

Das folgende Beispiel gibt den Wert der gebundenen Spalte für jede ausgewählte Zeile im Listenfeld Personalliste des Formulars Personal aus. Die MultiSelect-Eigenschaft des Listenfeldes muss auf Einzeln oder Erweitert eingestellt sein.

Sub AusgewählteZeilen()
    Dim ctlListe As Control, varElement As Variant

    'Control-Objektvariable, die auf das Listenfeld zeigt, zurückgeben.
    Set ctlListe = Formulare!Personal!Personalliste
    ' Ausgewählte Elemente durchlaufen.
    For Each varElement in ctlListe.ItemsSelected
        ' Wert der gebundenen Spalte ausgeben.
        Debug.Print ctlListe.ItemData(varElement)
    Next varElement
End Sub


ItemsSelected-Eigenschaft - Beispiel

Das folgende Beispiel gibt den Wert der gebundenen Spalte für jede ausgewählte Zeile im Listenfeld Namen des Formulars Kontakte aus. Zum Testen dieses Beispiels erstellen Sie das Listenfeld, und stellen Sie seine BoundColumn-Eigenschaft nach Belieben und seine MultiSelect-Eigenschaft auf Einzeln oder Erweitert ein. Wechseln Sie zur Formularansicht, wählen Sie mehrere Zeilen im Listenfeld aus, und führen Sie dann den folgenden Code aus:

Sub GebundeneDaten()
    Dim frm As Form, ctl As Control
    Dim varElem As Variant

    Set frm = Formulare!Kontakte
    Set ctl = frm!Namen
    For Each varElem In ctl.ItemsSelected
        Debug.Print ctl.ItemData(varElem)
    Next varElem
End Sub

Das nächste Beispiel verwendet dasselbe Listenfeld-Steuerelement, gibt jedoch die Werte jeder Spalte für jede ausgewählte Zeile im Listenfeld statt nur der Werte in der gebundenen Spalte aus.

Sub AlleAusgewähltenDaten()
    Dim frm As Form, ctl As Control
    Dim varElem As Variant, intI As Integer

    Set frm = Formulare!Kontakte
    Set ctl = frm!Namen
    For Each varElem In ctl.ItemsSelected
        For intI = 0 To ctl.ColumnCount - 1
            Debug.Print ctl.Column(intI, varElem)
        Next intI
        Debug.Print
    Next varElem
End Sub


KeepTogether-Eigenschaft (Zusammenhalten) - Beispiel

Im folgenden Beispiel wird der Wert, auf den die Eigenschaft KeepTogether des Detailbereichs eines Berichts eingestellt ist, der Variablen intWertLesen zugewiesen.

Dim intWertLesen As Integer
intWertLesen = Me.Section(acDetail).KeepTogether


KeyboardShortcutTips-Eigenschaft

Diese Eigenschaft steht in Microsoft Access nicht zur Verfügung.


KeyPreview-Eigenschaft (Tastenvorschau) - Beispiel

Im folgenden Beispiel wird die Eigenschaft KeyPreview in der Load-Ereignisprozedur des Formulars auf True (-1) eingestellt. Dies bewirkt, dass jedes Tastaturereignis zunächst an das Formular und erst dann an die entsprechenden Steuerelemente gesendet wird. In der KeyDown-Ereignisprozedur des Formulars wird dann das Argument KeyCode ausgewertet, um zu ermitteln, ob eine der Tasten F2, F3 oder F4 gedrückt wurde.

Private Sub Form_Load()
    Me.KeyPreview = True
End Sub

Private Sub Form_KeyDown(KeyCode As Integer, Shift As Integer)
    Select Case KeyCode
        Case vbKeyF2
            ' F2-Tastenereignisse verarbeiten.
        Case vbKeyF3
            ' F3-Tastenereignisse verarbeiten.
        Case vbKeyF4
            ' F4-Tastenereignisse verarbeiten.
        Case Else
    End Select
End Sub


Bezeichnungsausrichtung-Eigenschaft, TextAlign-Eigenschaft (Textausrichtung) - Gilt für

Bezeichnungsausrichtung-Eigenschaft

TextAlign-Eigenschaft


LabelAlign-, TextAlign-Eigenschaften

Sprachspezifische Informationen

Microsoft Access 2000 has modified the LabelAlign and TextAlign properties by adding context sensitive behavior to the General alignment choice.

Remarks

For general alignment, text in the control will be right aligned if the first character is a right-to-left language character, and left aligned if the first character is a left-to-right language character. In a combo box or list box, TextAlign determines alignment behavior for both the text box and list box components of the control.

For more information about right-to-left properties, see Learn more about right-to-left properties in Microsoft Access 2000.


LabelX-, LabelY-Eigenschaften

Sprachspezifische Informationen

Microsoft Access 2000 has modified the LabelX and LabelY property behavior for right-to-left controls.

Remarks

The LabelX and LabelY properties specify the placement of the label for a new control. If the orientation is left to right for a form or report, LabelX and LabelY behavior matches standard Microsoft Access left-to-right orientation. For more information about orientation, see the Orientation property.

If orientation is right to left, the origin of the coordinate system for LabelX and LabelY is the upper right corner of the attached control. A negative number for LabelX places the label to the right of the control. A negative number for LabelY places the label above the control.

For General and Right alignment when orientation is RTL, LabelX and LabelY specify the location of the upper-right corner of the label relative to the upper-right corner of the label’s attached control. For Left and Center alignment, LabelX and LabelY specify the location of the upper-left corner and top center, respectively, of the label relative to the upper-right corner of the label’s attached control.


LastModified-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel ermittelt den zuletzt veränderten Datensatz in einer Datensatzgruppe und setzt für diesen Datensatz ein Lesezeichen.

Sub ZuetztGeänderterDatensatz()
    Dim dbs As Database, rst As Recordset, varLesezeichen As Variant

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rst = dbs.OpenRecordset("SELECT * FROM Bestellungen " _
        & "ORDER BY [Bestimmungsland];")
    With rst
        .FindFirst "Bestimmungsland = 'GB'"
        ' Datensatz ändern und Änderungen speichern.
        .Edit
        !Bestimmungsland = "USA"
        .Update
    End With
    ' Überprüfen, ob die Datensatzgruppe Lesezeichen unterstützt.
    If rst.Bookmarkable Then
        ' Lesezeichen auf den zuletzt geänderten Datensatz setzen.
        varLesezeichen = rst.LastModified
        ' Zum zuletzt geänderten Datensatz wechseln.
        rst.Bookmark = varLesezeichen
    End If
    rst.Close
    Set dbs = Nothing
End Sub


Left-, Top-Eigenschaften (Links, Oben) - Beispiel

Im folgenden Beispiel wird die Einstellung der Eigenschaft Left des aktuellen Berichts geprüft. Ist der Wert kleiner als die Breite, die der Rand mindestens haben soll, werden die Eigenschaften NextRecord und PrintSection auf False (0) eingestellt. Außerdem wechselt der Bereich dann weder zum nächsten Datensatz, noch wird der nächste Bereich gedruckt.

Sub Detail_Format(Cancel As Integer, FormatCount As Integer)
Const conLinkerRand = 1880
' Wenn die Eigenschaft "Left" auf einen Wert kleiner
' als 1880 Twips eingestellt ist, soll weder zum
' nächsten Datensatz gewechselt noch der nächste
' Bereich gedruckt werden.
    If Me.Left < conLinkerRand Then
        Me.NextRecord = False
        Me.PrintSection = False
    End If
End Sub


ListCount-, ListRows-Eigenschaften (Listenzähler, Zeilenanzahl) - Beispiel

Das folgende Beispiel verwendet die Eigenschaft ListCount, um die Anzahl der Zeilen im Listenfeldteil des Kombinationsfelds Kundenliste im Formular Kunden zu ermitteln. Anschließend stellt es die Eigenschaft ListRows so ein, dass eine bestimmte Anzahl an Zeilen in der Liste angezeigt wird.

Sub Kundenlistengröße()
    Dim Listenfeld As Control

    Set Listenfeld = Formulare!Kunden!Kundenliste
    With Listenfeld
        If .ListCount < 8 Then
            .ListRows = .ListCount
        Else
            .ListRows = 8
        End If
    End With
End Sub


LocationOfComponents-Eigenschaft: Beispiel

In diesem Beispiel wird der Pfad zu dem Ort festgelegt, von dem Office-Komponenten gedownloadet werden können.

Application.DefaultWebOptions.LocationOfComponents = _
    Application.Path & Application.PathSeparator & "foo"


LockEdits-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel öffnet ein Recordset-Objekt vom Typ Dynaset und stellt dessen Eigenschaft LockEdits auf False (0) ein. Dies aktiviert das eingeschränkte Sperren, so dass andere Benutzer die Datenbanksätze jederzeit ändern können. Microsoft Access löst einen auffangbaren Fehler aus, wenn die Daten geändert werden, bevor Sie die Methode Update verwenden.

Sub SperrstatusAnzeigen()
    Dim dbs As Database, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rst = dbs.OpenRecordset("Kunden", dbOpenDynaset)
    rst.LockEdits = False
    On Error Goto ErrorSperrstatusAnzeigen
    ' Bearbeitung aktivieren.
    rst.Edit
    .                        ' Datensätze ändern.
    .
    .
    rst.Update            ' Änderungen zu speichern versuchen.

ExitLockEdits:
    rst.Close
    Set dbs = Nothing
    Exit Sub

ErrorSperrstatusAnzeigen:
        If Err.Number = 3197 Then
            MsgBox "Daten wurden von anderem Benutzer geändert."
            Resume Next
        Else
            MsgBox "Anderer Fehler."
            Resume ExitSperrstatusAnzeigen
        End If
End Sub


LoginTimeout-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel stellt die Eigenschaft LoginTimeout auf 120 Sekunden ein, erstellt dann eine Abfrage und führt diese in einer Datenbank auf einem ODBC-Server aus.

Sub Anmelden()
    Dim dbs As Database
    Dim qdf As QueryDef, rst As Recordset

    ' Wartezeit auf 120 Sekunden einstellen.
    DBEngine.LoginTimeout = 120
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("Gesamtes Personal", _
        "SELECT * FROM Personal;")
    qdf.Connect = "ODBC;DSN=Personalabteilung; " _
        & "Database=HRSRVR; UID=Sschmidt; PWD=Sesam"
    ' An Server anmelden und Abfrage ausführen.
    Set rst = qdf.OpenRecordset()
    ' Operationen mit der Datensatzgruppe durchführen.
    .
    .
    .
    rst.Close
    Set dbs = Nothing
End Sub


MDE-Eigenschaft: Beispiel

Im folgenden Beispiel wird mit der Funktion IstMDEDatei die Eigenschaft MDE der aktuellen Datenbank geprüft:

Dim dbs As Object
Set dbs = CurrentDb
If IstMDEDatei(dbs) <> True Then
    ' Den eigenen Code der Datenbank verarbeiten.
End If

Function IstMDEDatei(dbs as Object) As Boolean
    Dim strMDE As String
    On Error Resume Next
    strMDE = dbs.Properties("MDE")
    If Err = 0 AND strMDE = "T" Then
        ' Dies ist eine MDE-Datenbank.
        IstMDEDatei = True
    Else
        IstMDEDatei = False
    End if
End Function


MenuBar-Eigenschaft (Menüleiste) - Beispiel

Das folgende Beispiel stellt die Eigenschaft MenuBar auf ein Menüleistenmakro mit dem Namen Kundenmenü ein.

Formulare!Kunden.MenuBar = "Kundenmenü"

Um die eingebaute Menüleiste für das Formular oder die globale Menüleiste der Anwendung anzuzeigen, stellen Sie die Eigenschaft MenuBar auf eine leere Zeichenfolge (" ") ein.

Formulare!Kunden.MenuBar = ""


Me-Eigenschaft - Beispiel

Das folgende Beispiel zeigt, wie Sie die Beschriftung des Formulars Kunden durch eine benutzerdefinierte Beschriftung ersetzen. Die Unterroutine BeschriftungÄndern übergibt als Argument die Eigenschaft Me (die für das Objekt Form steht), um das aktive Formular anzugeben. Da die Prozedur BeschriftungÄndern die Überschrift des aktiven (und keines bestimmten) Formulars ändert, kann sie auch aus anderen Prozeduren in einer Anwendung aufgerufen werden.

BeschriftungÄndern Me, InputBox("Neue Bezeichnung "
    & "für das Formular")

Sub BeschriftungÄndern(frmAktFormular As _
    Form, strCaption As String)
' Beschriftung ändern.
    If TypeName(frmCurrentForm.Caption) = "Null" Then
        frmCurrentForm.Caption = strCaption
        Exit Sub
    End If
    If UCase(strCaption) _
            <> UCase(frmCurrentForm.Caption) Then
        frmCurrentForm.Caption = strCaption
    End If
End Sub


Module-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft Module, um die Methode Beep im Ereignis Open des Formulars einzufügen.

Dim strFormularÖffnenCode As String
Dim mdl As Module

Set mdl = Formulare!MyForm.Module
strFormularÖffnenCode = "Sub Form_Open(Cancel As Integer)" _
    & vbCrLf & "Beep" & vbCrLf & "End Sub"
    With mdl
        .InsertText strFormularÖffnenCode
    End With


MouseTips-Eigenschaft

Diese Eigenschaft steht in Microsoft Access nicht zur Verfügung.


 Name-Eigenschaft (Befehlsleisten)

Name-Eigenschaft (Befehlsleisten)

Wenn Sie in Microsoft Access 2000 den Namen einer benutzerdefinierten Menüleiste, Symbolleiste oder eines benutzerdefinierten Kontextmenüs ändern möchten, können Sie das Dialogfeld Symbolleisteneigenschaften verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen. Klicken Sie anschließend im Dialogfeld Anpassen auf die Schaltfläche Eigenschaften. Wählen Sie im Feld Ausgewählte Symbolleiste die gewünschte benutzerdefinierte Menüleiste, Symbolleiste oder das benutzerdefinierte Kontextmenü, und geben Sie dann im Feld Symbolleistenname den neuen Namen ein. Sie können den Namen von eingebauten Menüleisten, Symbolleisten oder Kontextmenüs nicht ändern.


NewRecord-Eigenschaft - Beispiel

Das folgende Beispiel zeigt, wie Sie mit Hilfe der Eigenschaft NewRecord bestimmen können, ob der aktuelle Datensatz ein neuer Datensatz ist. Die Prozedur NeueDatensatzmarke stellt den aktuellen Datensatz auf die Variable intNeuerDatensatz ein. Ist der Datensatz neu, wird dies dem Benutzer über eine Meldung angezeigt. Sie können diese Prozedur ausführen, wenn das Ereignis Current für ein Formular eintritt.

Sub NeueDatensatzmarke(frm As Form)
    Dim intNeuerDatensatz As Integer

    intNeuerDatensatz = frm.NewRecord
    If intNeuerDatensatz = True Then
    MsgBox "Sie befinden sich in einem neuen Datensatz." _
        & "@Möchten Sie neue Daten hinzufügen?" _
        & "@Falls nicht, gehen Sie zu einem bestehenden Datensatz."
    End If
End Sub


NewRowOrCol-Eigenschaft (NeueZeileOderSpalte) - Beispiel

Im folgenden Beispiel wird die Einstellung der Eigenschaft NewRowOrCol der Variablen intWertLesen zugewiesen.

Dim intWertLesen As Integer
intWertLesen = Me.Section(1).NewRowOrCol

Im nächsten Beispiel werden zwei Layouts eines Berichts vorgestellt. In beiden Layouts werden die Daten in 4 Gruppen unterteilt (Kopf1 bis Kopf4). Jede Gruppe besteht aus 3 bis 6 Datensätzen, und jeder Datensatz besteht aus den Feldern a und b. Die beiden Layouts unterscheiden sich nur in der Einstellung der Option Spaltenlayout (im Dialogfeld Seitenformat auf der Registerkarte Spalten) und in den Werten ihrer Eigenschaft NewRowOrCol. Auf der Registerkarte Spalten muss unter Spaltengröße das Feld Breite auf die tatsächliche Breite des Feldes eingestellt sein. Weil die Eigenschaft NewRowOrCol auf Vor Bereich eingestellt ist, muss außerdem der Seitenkopfbereich größer als 0 sein. Nur dann ist gewährleistet, dass die Einstellung Nach unten, dann quer einwandfrei funktioniert.

  • Spaltenlayout - Quer, dann nach unten

    Kopf1

    1a 1b2a 2b3a 3b4a 4b

    5a 5b

    Kopf2

    1a 1b2a 2b3a 3b4a 4b

    Kopf3

    1a 1b2a 2b3a 3b

    Kopf4

    1a 1b2a 2b3a 3b4a 4b

    5a 5b6a 6b

  • Rastereinstellungen - Spaltenanzahl auf 4 eingestellt

  • NewRowOrCol-Eigenschafteneinstellung für Gruppenkopfbereich - Vor & Nach
  • Spaltenlayout - Nach unten, dann quer

    Kopf1Kopf2Kopf3Kopf4

    1a 1b1a 1b1a 1b1a 1b

    2a 2b2a 2b2a 2b2a 2b

    3a 3b3a 3b3a 3b3a 3b

    4a 4b4a 4b4a 4b

    5a 5b5a 5b

    6a 6b

  • Rastereinstellungen - Spaltenanzahl auf 4 eingestellt

  • NewRowOrCol-Eigenschafteneinstellung für Gruppenkopfbereich - Vor Bereich


NoMatch-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel verwendet die Eigenschaft NoMatch, um festzustellen, ob ein Aufruf der Methode FindFirst erfolgreich gewesen ist.

Function LandBestimmen() As Integer
    Dim dbs As Database, rst As Recordset
    Dim strLand As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rst = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
    strLand = InputBox("Bitte Land eingeben.")
    rst.FindFirst "[Bestimmungsland]= '" & strLand & "'"
    If rst.NoMatch Then
        LandBestimmen = False
    Else
        LandBestimmen = True
        Debug.Print rst![Bestell-Nr]
    End If
    rst.Close
    Set dbs = Nothing
End Function


ObjectPalette-, PaintPalette-Eigenschaft (Objektpalette, Farbpalette) - Beispiel

Das folgende Beispiel stellt die Eigenschaft PaintPalette des Formulars Wasser auf die Eigenschaft ObjectPalette des Steuerelements Ozean des Formulars BilderAnzeigen ein. (Ozean kann ein gebundenes Objektfeld, eine Befehlsschaltfläche, ein Diagramm, eine Umschaltfläche oder ein Objektfeld sein.)

Formulare!Wasser.PaintPalette = _
     Formulare!BilderAnzeigen!Ozean.ObjectPalette

Mit Hilfe der Eigenschaften ObjectPalette und PaintPalette kann die Farbpalette, die von einem geöffneten Formular verwendet wird, zur Laufzeit aus dem Programm geändert werden. Diese Eigenschaften werden häufig verwendet, um die Eigenschaft PaintPalette des aktuellen Formulars auf die Farbpalette einer Grafik einzustellen, die in dem Steuerelement angezeigt wird, das den Fokus hat.

Sie verwenden z.B. ein Formular mit einem Bild des Ozeans, das viele blaue Farbtöne enthält, sowie mit einem Bild des Sonnenuntergangs, das viele rote Farbtöne enthält. Da Microsoft Windows nur jeweils eine aktive Farbpalette unterstützt, wird ein Bild erheblich besser aussehen als das andere. Das folgende Beispiel verwendet das Ereignis Enter eines Steuerelements, um die Eigenschaft PaintPalette des Formulars auf die Eigenschaft ObjectPalette des Steuerelements einzustellen, so dass die Grafik, die den Fokus hat, optimal dargestellt wird.

Sub OzeanBild_Enter()
    Me.PaintPalette = Me!OzeanBild.ObjectPalette
End Sub

Sub SonnenuntergangBild_Enter()
    Me.PaintPalette = Me!SonnenuntergangBild.ObjectPalette
End Sub


Objekteigenschaften: Beispiel

Im folgenden Beispiel wird die Sub-Prozedur ObjekteigenschaftenDrucken verwendet, um die Werte der Objekteigenschaften eines Objekts im Testfenster anzuzeigen. An die Sub-Prozedur werden der Typ und der Name des Objekts als Argumente übergeben.

    Dim strObjekttyp As String
    Dim strObjektname As String
    Dim strMldg As String

    strMldg = "Geben Sie den Objekttyp ein (in englisch, " _
        & "d. h. Forms, Scripts, Modules, Reports oder Tables)."
    ' Den Objekttyp erfragen.
    strObjekttyp = InputBox(strMldg)
    strMldg = "Geben Sie den Namen eines Formulars, eines " _
        & "Makros, eines Moduls, eines Berichts oder einer Tabelle ein."
    ' Den Benutzer zur Eingabe des Objektnamens auffordern.
    strObjektname = InputBox(strMldg)
    ' Den Typ und den Namen des Objekts an die Subprozedur
    ' ObjekteigenschaftenDrucken übergeben.
    ObjekteigenschaftenDrucken strObjekttyp, strObjektname

Sub ObjekteigenschaftenDrucken(strObjekttyp As String, strObjektname _
    As String)
    Dim dbs As Database, ctr As Container, doc As Document
    Dim intI As Integer
    Dim strTabZeichen As String
    Dim prp As Property

    Set dbs = CurrentDb
    strTabZeichen = vbTab
    ' Die Container-Objektvariable einstellen.
    Set ctr = dbs.Containers(strObjekttyp)
    ' Die Document-Objektvariable einstellen.
    Set doc = ctr.Documents(strObjektname)
    doc.Properties.Refresh
    ' Den Namen des Objekts im Testfenster anzeigen.
    Debug.Print doc.Name
    ' Jede Objekteigenschaft im Testfenster anzeigen.
    For Each prp in doc.Properties
        Debug.Print strTabZeichen & prp.Name & " = " & prp.Value
    Next
End Sub


ObjectVerbs-, ObjectVerbsCount-Eigenschaften - Beispiel

Im folgenden Beispiel werden die Verben zurückgegeben, die von dem OLE-Objekt unterstützt werden, das dem als Argument ctlOLE übergebenen Steuerelement zugewiesen ist. Jedes Verb wird in einem Meldungsfeld angezeigt.

Sub VerbenlisteLesen(frm As Form, OLE1 As Control)
    Dim intX As Integer, intAnzahlVerben As Integer
    Dim strVerbenliste As String

    ' Die Liste der Verben aktualisieren.
    With frm!ctlOLE
        .Action = acOLEFetchVerbs
        intAnzahlVerben = .ObjectVerbsCount
        For intX = 0 To intAnzahlVerben - 1
            strVerbenliste = strVerbenliste &.ObjectVerbs(intX) & "; "
        Next intX
    End With

    ' Die Verben in einem Meldungsfeld anzeigen.
    MsgBox Left(strVerbenliste, Len(strVerbenliste) - 1)
End Sub


Object-Eigenschaft - Beispiel

Im folgenden Beispiel wird die Eigenschaft Object eines Objektfelds namens OLE1 verwendet. Der Name und die Adressinformationen des Kunden werden in ein eingebettetes Word-Dokument eingefügt, das als Serienbrief formatiert ist, der Platzhalter für den Namen und die Adressinformationen sowie im Briefrumpf einen vorformulierten Text enthält. Die Prozedur ersetzt für jeden Datensatz die Platzhalterinformationen und druckt den Serienbrief. Es wird keine Kopie des jeweils gedruckten Serienbriefes gespeichert.

Sub SerienbriefDrucken_Click()
    Dim objWord As Object
    Dim strKunde As String, strStraße As String
    Dim strOrt As String, strRegion As String

    ' Die Eigenschaft Object des Steuerelements einer
    ' Variablen zuweisen.
    Set objWord = Me!OLE1.Object.Application.Wordbasic
    ' Die Adresse des Kunden den entsprechenden
    ' Variablen zuweisen.
    strKunde = Me!Firma
    strStraße = Me!Straße
    strOrt = Me!Ort & ", "
    If Not IsNull(Me!Region) Then
        strRegion = Me!Region
    Else
        strRegion = Me!Land
    End If
    ' Das ActiveX-Steuerelement aktivieren.
    Me!OLE1.Action = acOLEActivate
    With objWord
        .StartOfDocument
        ' Zum ersten Platzhalter bewegen.
        .LineDown 2
        ' Den Text des Platzhalters hervorheben.
        .EndOfLine 1
        ' Den Namen des Kunden einfügen.
        .Insert strKunde
        ' Zum nächsten Platzhalter bewegen.
        .LineDown
        .StartOfLine
        ' Den Text des Platzhalters hervorheben.
        .EndOfLine 1
        ' Die Straße einfügen.
        .Insert strStraße
        ' Zum letzten Platzhalter bewegen.
        .LineDown
        .StartOfLine
        ' Den Text des Platzhalters hervorheben.
        .EndOfLine 1
        ' Den Ort und die Region einfügen.
        .Insert strOrt & strRegion
        .FilePrint
        .FileClose
    End With
    Set objWord = Nothing
End Sub


OldValue-Eigenschaft (AlterWert) - Beispiel

Das folgende Beispiel überprüft, ob neu in ein Feld eingegebene Daten mehr als 10 Prozent vom ursprünglichen Wert abweichen. Beträgt die Änderung mehr als 10 Prozent, so wird der ursprüngliche Wert mit Hilfe der Eigenschaft OldValue wiederhergestellt. Diese Prozedur könnte vom Ereignis Before Update des Steuerelements, das die zu überprüfenden Daten enthält, aufgerufen werden.

Sub FeldÜberprüfen()
    Dim curNeuerWert As Currency,
    Dim curOriginalwert As Currency
    Dim curÄnderung As Currency, strMldg As String

    curNeuerWert = Formulare!Artikel!Einzelpreis
    curOriginalwert = Formulare!Artikel!Einzelpreis.OldValue
    curÄnderung = Abs(curNeuerWert - curOriginalwert)
    If curÄnderung > (curOriginalwert * .1) Then
        strMldg = "Mehr als 10 Prozent Abweichung vom alten Einzelpreis." _
        & "Alter Wert wird wiederhergestellt."
        MsgBox strMldg, vbExclamation, "Änderung unzulässig."
        Formulare!Artikel!Einzelpreis = curOriginalwert
    End If
End Sub


OLEType-Eigenschaft (OLEObjektart) - Beispiel

Das folgende Beispiel zeigt, wie das Dialogfeld Objekt einfügen angezeigt und, wenn im Dialogfeld Objekt einfügen auf die Schaltfläche Abbrechen geklickt wurde, eine Fehlermeldung ausgegeben werden kann.

Sub ObjektEinfügen_Click()
    Dim conAbbrechenGeklickt As Integer

    ' Wenn der Benutzer auf "Abbrechen" geklickt hat,
    ' wird eine Fehlermeldung angezeigt.
    conAbbrechenGeklickt = 2001
    On Error GoTo FehlerDurchAbbrechen
    If OLE1.OLEType = acOLENone Then
        ' Es wurde kein OLE-Objekt erstellt.
        ' Das Dialogfeld "Objekt einfügen" anzeigen.
        OLE1.Action = acOLEInsertObjDlg
    End If
    Exit Sub

FehlerDurchAbbrechen:
    If Err = conAbbrechenGeklickt Then ' Die Meldung anzeigen.
        MsgBox "Sie haben auf 'Abbrechen' geklickt; " _
            & "es wurde kein Objekt erstellt."
    End If
    Resume Next
End Sub


 OnAction-Eigenschaft

OnAction-Eigenschaft

Wenn Sie in Microsoft Access 2000 die OnAction-Eigenschaft für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen OnAction-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie im Feld Bei Aktion das Makro oder die Sub-Prozedur ein, das/die Sie ausführen möchten.

Mit der OnAction-Eigenschaft können Sie nur Makros oder Sub-Prozeduren ausführen. Wenn Sie ein Makro ausführen möchten, wählen Sie es aus der Dropdownliste des Feldes Bei Aktion aus, oder geben Sie seinen Namen in das Feld ein. Wenn Sie eine Sub-Prozedur ausführen möchten, geben Sie ihren Namen in folgender Form in das Feld ein =Subname( ).

Sie können die OnAction-Eigenschaft auch auf einen Ausdruck einstellen. Der Ausdruck kann eine eingebaute oder benutzerdefinierte Sub-Prozedur oder eine Kombination von Sub-Prozeduren enthalten. Beim Auswerten eines Ausdrucks führt Microsoft Access alle Operationen in dem Ausdruck aus. Der folgende Ausdruck führt z.B. die benutzerdefinierte Sub-Prozedur CustomControlProc aus:

=CustomControlProc()

In Visual Basic erwartet die OnAction-Eigenschaft eine Zeichenfolge als Einstellung. Wenn Sie die Eigenschaft auf einen Ausdruck einstellen möchten, müssen Sie ihr daher eine Zeichenfolge übergeben, die den Ausdruck enthält. Beim Übergeben der Zeichenfolge ist es erforderlich, Zeichenfolgen innerhalb der Zeichenfolge in Anführungszeichen (") anzugeben. (Beachten Sie, dass eine im Ausdruck enthaltene Zeichenfolge im Feld Bei Aktion im Dialogfeld Symbolleiste Steuerelementeigenschaften nur einen Satz von Anführungszeichen besitzt.) Stellen Sie außerdem sicher, dass Sie das Gleichheitszeichen (=) verwenden, um anzugeben, dass die Zeichenfolge einen Ausdruck enthält. Da Ihre Sub-Prozedur keine Argumente enthalten muss, vergessen Sie nicht die Klammern [( )] in der Zeichenfolge. Sie können die OnAction-Eigenschaft mit der folgenden Zeichenfolge auf den vorherigen Ausdruck einstellen:

"=CustomControlProc()"

Beachten Sie, dass Sie die OnAction-Eigenschaft auf den Namen eines Makros oder einer Sub-Prozedur einstellen müssen; Sie können keinen Namen einer Funktion als Einstellung verwenden.

Für benutzerdefinierte Befehlsleisten-Steuerelemente müssen Sie diese Eigenschaft einstellen, damit das Steuerelement eine Aktion ausführen kann. Wenn Sie diese Eigenschaft für ein eingebautes Steuerelement einstellen, überschreibt die Einstellung der OnAction-Eigenschaft die Aktionen, die das Steuerelement normalerweise ausführt, d.h., mit eingebauten Steuerelementen können Sie andere als die Standardaktionen ausführen. Das Steuerelement wird im Grunde zu einem AktiveX-Steuerelement.


OpenArgs-Eigenschaft (Öffnungsargumente) - Beispiel

Im folgenden Beispiel wird die Eigenschaft OpenArgs verwendet, um das Formular Personal so zu öffnen, dass der Datensatz einer bzw. eines bestimmten Angestellten angezeigt wird. Außerdem wird in dem Beispiel gezeigt, wie die Eigenschaft OpenArgs mit der Methode OpenForm eingestellt wird. Sie können diese Prozedur je nach Bedarf ausführen, z.B. wenn für ein benutzerdefiniertes Dialogfeld, in das neue Informationen zu einer bzw. einem Angestellten eingegeben werden, das Ereignis AfterUpdate auftritt.

Sub ÖffnenMitCallahan()
    DoCmd.OpenForm "Personal", acNormal, , , acReadOnly, _
     , "Callahan"
End Sub

Sub Form_Open(Cancel As Integer)
    Dim strAngestName As String
    ' Wenn die Eigenschaft OpenArgs den Namen einer bzw.
    ' eines Angestellten enthält, soll der entsprechende
    ' Personaldatensatz gesucht und auf dem Formular angezeigt
    ' werden. Enthält die Eigenschaft OpenArgs z.B. "Callahan",
    ' erfolgt ein Sprung zum ersten "Callahan"-Datensatz.
    strAngestName = Formulare!Personal.OpenArgs
    If Len(strAngestName) > 0 Then
        DoCmd.GoToControl "Nachname"
        DoCmd.FindRecord strAngestName, , True, , True, , True
    End If
End Sub

Im nächsten Beispiel wird die Methode FindFirst verwendet, um nach der bzw. dem Angestellten zu suchen, deren bzw. dessen Name in der Eigenschaft OpenArgs angegeben ist.

Private Sub Form_Open(Cancel As Integer)
    If Not IsNull(Me.OpenArgs) Then
        Dim strAngestName As String
        strAngestName = Me.OpenArgs
        Dim RS As Recordset
        Set RS = Me.RecordsetClone
        RS.FindFirst "Nachname = '" & strAngestName & "'"
        If Not RS.NoMatch Then
            Me.Bookmark = RS.Bookmark
        End If
    End If
End Sub


OrdinalPosition-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel ändert die Einstellung für die Eigenschaft OrdinalPosition des ersten Feldes in der Tabelle Artikel. Wenn Sie die Tabelle vor und nach Durchführung dieses Beispiels in der Datenblattansicht überprüfen, werden Sie feststellen, dass das Feld Artikel-Nr von der ersten in die letzte Spalte verschoben wurde.

Sub PositionEinstellen()
    Dim dbs As Database, tdf As TableDef
    Dim fldErstes As Field, fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Artikel" zurückgeben.
    Set tdf = dbs.TableDefs!Artikel
    ' Bezug auf erstes Feld in der Tabelle zurückgeben.
    Set fldErstes = tdf.Fields(0)
    ' Eigenschaft "OrdinalPosition" auf die letzte Position in
    ' der Auflistung einstellen.
    fldErstes.OrdinalPosition = tdf.Fields.Count
    ' Fields-Auflistung aktualisieren.
    tdf.Fields.Refresh
    ' Alle Felder durchlaufen und die Feldposition ausgeben.
    For Each fld In tdf.Fields
        Debug.Print fld.Name, fld.OrdinalPosition
    Next fld
    Set dbs = Nothing
End Sub


OrganizeInFolder-Eigenschaft: Beispiel

In diesem Beispiel wird festgelegt, dass alle Bilddateien im gleichen Ordner abgelegt werden wie das Dokument, wenn es als Webseite gespeichert wird.

Application.DefaultWebOptions.OrganizeInFolder = False


OutputAllFields-Eigenschaft (AlleFelderAusgeben) - Beispiel

Das folgende Beispiel verwendet ein Sternchen in einer SQL-Anweisung, um alle Felder in der Tabelle Versandfirmen auszuwählen. Anschließend werden die Felder in Textfeldern in einem Formular angezeigt, indem die Eigenschaft ControlSource der Textfelder auf die Namen der einzelnen Felder in der Abfrage eingestellt wird.

Dim strSQLAbrufen AS String
strSQLAbrufen = "SELECT * FROM Versandfirmen"
Formulare!Form1.RecordSource = strSQLAbrufen
Text1.ControlSource = "Firmen-Nr"
Text2.ControlSource = "Firmenname"

In der Ausgabe der nächsten SQL-Anweisung werden die Werte der Felder Firma und Artikelname in aufsteigender Reihenfolge sortiert und alle Felder der Tabellen Lieferanten und Artikel in den Feldlisten und in der Datenblattansicht angezeigt. Sie geben diese SQL-Anweisung in der SQL-Ansicht des Abfragefensters ein.

SELECT * FROM Lieferanten INNER JOIN Artikel
ON Lieferanten.[Lieferanten-Nr] = Artikel.[Lieferanten-Nr]
ORDER BY Lieferanten.[Firmenname], Artikel.[Artikelname];


PageHeader-, PageFooter-Eigenschaft (Seitenkopf, Seitenfuß) - Beispiel

Im folgenden Beispiel wird die Eigenschaft PageHeader eines Berichts auf Außer Berichtskopf eingestellt. Sie können dieses Beispiel ausführen, indem Sie folgende Zeile für einen Bericht namens Bericht1 in das Testfenster eingeben.

Reports!Bericht1.PageHeader = 1


Page-, Pages-Eigenschaft (Seite, Seiten) - Beispiel

Im folgenden Beispiel wird eine Meldung angezeigt, die mitteilt, wie viele Seiten der Bericht umfasst. Damit dieses Beispiel funktionieren kann, muss der Bericht ein Textfeld enthalten, dessen Eigenschaft ControlSource auf den Ausdruck =Seiten eingestellt ist. Kopieren Sie den folgenden Code in die Page-Ereignisprozedur des Berichts Alphabetische Artikelliste, um dieses Beispiel zu testen.

Dim intSeitenGesamt As Integer, strMldg As String
intSeitenGesamt = Me.Pages
strMldg = "Dieser Bericht hat " & intSeitenGesamt & " Seiten."
MsgBox strMldg


Painting-Eigenschaft (Bildschirm aktualisieren) - Beispiel

Dieses Beispiel verwendet die Eigenschaft Painting zur Aktivierung oder Deaktivierung der Formularaktualisierung in Abhängigkeit von der Einstellung der Variablen PaintingWert auf True (-1) oder False (0). Ist die Formularaktualisierung deaktiviert, zeigt Microsoft Access solange das Sanduhr-Symbol an, bis die Aktualisierung wieder aktiviert wurde.

Function PaintingEinst (frmName As Form,_
     ByVal SetPainting As Integer) As Integer
    frmName.Painting = PaintingWert
    If PaintingWert = False Then    'Formularaktualisierung ist deaktiviert.
        DoCmd.Hourglass True            'Sanduhr-Symbol anzeigen.
    Else
        DoCmd.Hourglass False        'Sanduhr-Symbol nicht anzeigen.
    End If
End Function


 Parameter-Eigenschaft

Parameter-Eigenschaft

Wenn Sie in Microsoft Access 2000 die Parameter-Eigenschaft für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen Parameter-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie die gewünschten Parameterinformationen im Feld Parameter ein.


Parent-Eigenschaft: Beispiel

Das folgende Beispiel verwendet die Eigenschaft Parent zur Untersuchung des Hauptobjekts des Bezeichnungsfeld-Steuerelements SpeedyBezFeld, des Kontrollkästchen-Steuerelements Speedy und der Optionsgruppe Versand via.

Dim frm As Form
Dim ctl As Control
Set frm = Formulare!Bestellungen
Set ctl = frm.[SpeedyBezFeld]
' Liefert den Namen des Steuerelements, das dem Bezeichnungsfeld
' zugeordnet ist.
MsgBox "Übergeordnetes Steuerelement: " & ctl.Parent.Name
Set ctl = frm.Speedy
' Liefert den Namen des Steuerelements, in dem das Steuerelement
' enthalten ist.
MsgBox "Übergeordnetes Steuerelement: " & ctl.Parent.Name
Set ctl = frm.VersandVia
' Liefert den Namen des Formulars, auf dem sich das Optionsgruppen-
' Steuerelement befindet.
MsgBox "Übergeordnetes Steuerelement: " & ctl.Parent.Name

Das nächste Beispiel gibt auch den Namen des Formulars zurück, das das Optionsgruppen-Steuerelement enthält.

MsgBox Formulare!Bestellungen! _
    [SpeedyBezFeld].Parent.Parent.Parent.Name


PercentPosition-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel drückt die aktuelle Position eines Datensatzes in einer Datensatzgruppe in Prozent aus und zeigt diese dann in einem Meldungsfeld an.

Sub RelativeDatensatzposition()
    Dim dbs As Database, rst As Recordset
    Dim strEingabe As String, strSQL As String

    strSQL = "SELECT * FROM Artikel ORDER BY Artikelname;"
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rst = dbs.OpenRecordset(strSQL, dbOpenDynaset)
    ' Zum Ende der Datensatzgruppe.
    rst.MoveLast
    ' Zurück zum Anfang der Datensatzgruppe.
    rst.MoveFirst
    ' Benutzer zum Eingeben des Artikelnamens auffordern.
    strEingabe = InputBox("Geben Sie den vollständigen Artikelnamen ein.")
    ' Erstes Vorkommen suchen.
    rst.FindFirst "[Artikelname] = '" & strEingabe & "'"
    ' Aktuelle Position in Prozent anzeigen.
    MsgBox("Die aktuelle Position im Datensatz ist " _
        & rst.PercentPosition & "%.")
    rst.Close
    Set dbs = Nothing
End Sub


 Permissions-Eigenschaft (MDB)

Permissions-Eigenschaft (MDB)

Microsoft Access definiert vier Typen von Container-Objekten zusätzlich zu den Typen, die von der Microsoft Jet-Datenbank-Engine definiert werden: die Container-Objekte für Formulare, Berichte, Skripten oder Module. Die einzelnen Document-Objekte für Formulare, Berichte, Skripten oder Module sind Bestandteil der Documents-Auflistungen dieser Container-Objekte. Für diese Container- und Document-Objekte können Sie auch die Eigenschaft Permissions auf die folgenden Konstanten einstellen.

Konstante | Benutzer oder Gruppe kann
acSecFrmRptReadDef | das Formular oder den Bericht in der Entwurfsansicht öffnen, aber keine Änderungen vornehmen.
acSecFrmRptWriteDef | das Formular oder den Bericht in der Entwurfsansicht ändern oder löschen.
acSecFrmRptExecute | das Formular in der Formularansicht oder Datenblattansicht öffnen oder den Bericht in der Beispielansicht oder Seitenansicht drucken oder öffnen.
acSecMacReadDef | das Makrofenster öffnen und ein Makro anzeigen, aber keine Änderungen vornehmen.
acSecMacWriteDef | das Makro im Makrofenster ändern oder löschen.
acSecModReadDef | das Modul öffnen, aber keine Änderungen vornehmen.
acSecModWriteDef | den Inhalt eines Moduls ändern oder löschen.
acSecMacExecute | das Makro ausführen.

Anmerkung acSecModReadDef und acSecModWriteDef wurden nur aus Gründen der Abwärtskompatibilität einbezogen. Da der Modulzugriff jetzt durch die Protection-Eigenschaft in der Visual Basic-Umgebung gesteuert wird, können diese Konstanten in Microsoft Access 2000 nicht mehr als Parameter verwendet werden.


Permissions-, UserName-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel fügt ein neues Benutzerkonto hinzu, indem ein User-Objekt erstellt und an die Users-Auflistung des Standardarbeitsbereichs angefügt wird. Anschließend werden Berechtigungen für alle Tabellen in der Datenbank für den neuen Benutzer eingestellt. Die Prozedur stellt zuerst die Eigenschaft UserName eines Container-Objekts vom Typ Tables auf den Namen des neuen Benutzers und dann die Eigenschaft Permissions auf die passenden Berechtigungen ein.

Der Operator And ermittelt durch einen bitweisen Vergleich, ob ein Attribut momentan gesetzt ist.

Anmerkung Vermeiden Sie beim Programmieren unter Sicherheitsaspekten die Angabe von Kennwörtern und PID-Informationen im Code. Das folgende Beispiel dient nur Demonstrationszwecken.

Function BerechtigungenEinstellen(strName As String, strPID As String, _
        strKennwort As String) As Boolean
    Dim dbs As Database, ctrTabellen As Container
    Dim wspStandard As Workspace, usrNeu As User

    On Error GoTo ErrorBerechtigungenEinstellen
    ' Bezug auf Standard-Arbeitsbereich zurückgeben.
    Set wspStandard = DBEngine.Workspaces(0)
    ' User-Objekt erstellen und Name, PID und Kennwort festlegen.
    Set usrNeu = wspStandard.CreateUser(strName, _             strPID, strPassword)
    ' An Users-Auflistung des Standardarbeitsbereichs anfügen.
    wspStandard.Users.Append usrNeu
    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tables-Container zurückgeben.
    Set ctrTabellen = dbs.Containers!Tabellen
    ctrTabellen.UserName = usrNeu.Name
    ' Berechtigungen des neuen Benutzers für Tabellen festlegen.
    ctrTabellen.Permissions = dbSecInsertData _
        And dbSecReplaceData And dbSecDeleteData
    BerechtigungenEinstellen= True

ExitBerechtigungenEinstellen
    Set dbs = Nothing
    Exit Function

ErrorBerechtigungenEinstellen
    MsgBox Err & ": " & Err.Description
    BerechtigungenEinstellen = False
    Resume ExitBerechtigungenEinstellen
End Function

Die folgende Prozedur fordert den Benutzer auf, seinen Namen und sein Kennwort einzugeben, und erstellt einen PID-Wert.

Sub NeuerBenutzerAufforderung()
    Dim strName As String, strKennwort As String
    Dim intR As Integer, strPID As String
    Dim blnRückgabe As Boolean

    ' Benutzer zur Eingabe von Name und Kennwort auffordern.
    strName = InputBox("Geben Sie Ihren Namen ein.")
    strPassword = InputBox("Geben Sie ein Kennwort mit " _         & "maximal 14 Zeichen ein.")
    ' Zufallszahlengenerator aufrufen.
    Randomize
    ' PID-Zeichenfolge erstellen.
    For intR = 0 To 19
        strPID = strPID & Chr$(Int(256 * Rnd))
    Next intR
    ' Funktion BerechtigungenEinstellen aufrufen.
    blnRückgabe = BerechtigungenEinstellen(strName, strPID, strKennwort)
End Sub


PictureData-Eigenschaft - Beispiel

Das folgende Beispiel verwendet drei Bild-Steuerelemente zur Animation einer Schmetterlingsabbildung quer über ein Formular. Das Bild-Steuerelement Ausgeblendet1 enthält das Bild eines Schmetterlings mit erhobenen Flügeln, und das Bild-Steuerelement Ausgeblendet2 enthält ein Bild des gleichen Schmetterlings mit gesenkten Flügeln. Die Eigenschaft Visible (Sichtbar) beider Bild-Steuerelemente ist auf False (0) eingestellt. Die Eigenschaft TimerInterval (Zeitgeberintervall) ist auf 200 eingestellt. Jedesmal, wenn das Ereignis Timer (Zeitgeber) auftritt, ändert sich das Bild im Bild-Steuerelement Sichtbar1 mit Hilfe der Eigenschaft PictureData der ausgeblendeten Bild-Steuerelemente, und das sichtbare Bild-Steuerelement wird um 200 Twips nach rechts bewegt. Das sichtbare Bild-Steuerelement wird wieder zur linken Seite des Formulars verschoben, wenn der Wert seiner Eigenschaft Left größer als die in der öffentlichen Variablen gfrmWidth gespeicherte Breite des Formulars ist. Der Wert von gfrmWidth wird im Ereignis Open des Formulars auf Me.Width eingestellt.

Private Sub Form_Timer()
    Static intBild As Integer
    Select Case intBild
        Case Is = 1
            Me!Sichtbar1.PictureData = Me!Ausgeblendet1.PictureData
        Case Is = 2
            Me!Sichtbar1.PictureData = Me!Ausgeblendet2.PictureData
        Case Else
    End Select
    If intBild = 2 Then intBild = 0
    intBild = intBild + 1
    If (Me!Sichtbar1.Left > gfrmWidth) Then Me!Sichtbar1.Left = 0
    Me!Sichtbar1.Left = Me!Sichtbar1.Left + 200
End Sub


 Position-Eigenschaft

Position-Eigenschaft

Sie können die Position-Eigenschaft nicht auf die eingebaute Konstante msoBarPopup einstellen. Wenn Sie ein Kontextmenü erstellen möchten, verwenden Sie das Argument Position der Add-Methode der CommandBars-Auflistung.


PostalAddress-Eigenschaft

Sprachspezifische Informationen

You can use the PostalAddress property to specify or determine the postal code and the Customer Barcode data corresponding to the address information displayed in a specified field/textbox. The PostalAddress wizard enables the setting of these properties.

Setting

For processing the conversion, correct settings are necessary for all properties of field/textbox that will contain postal code, address, Customer Barcode data.

For settings, use section 1 to 3, delimiting with semicolon (;).

Setting for field/textbox for Postal code

Specifies the type of postal code for the field/textbox.

Section | Description
1 | Specifies field/textbox for Prefecture names
2 | Specifies field/textbox for City/Ward/County
3 | Specifies field/textbox for Street/Town/Village

Setting for field/textbox for address

Specifies the field/textbox contains a postal code or Customer Barcode data.

Section | Description
1 | Specifies field/textbox for postal code
2 | Specifies field/textbox for Customer Barcode data

Note Two semicolons are required at the end of the value.

Setting for field/textbox for Customer Barcode data

Specifies the type of Customer Barcode data in the field/textbox. This setting is the same as the field/textbox for postal code.

Section | Description
1 | Specifies field/textbox for Prefecture names
2 | Specifies field/textbox for City/Ward/County
3 | Specifies field/textbox for Street/Town/Village

Remarks

The postal code consist of 3 address items; Prefecture, City/Ward/County, Street/Town/Village. Sections in PostalAddress property of field/textbox for a postal code can be omitted. The following table shows how to omit sections from the property setting.

Property Settings | Address input in field/textbox
 | Address1 | Address2 | Address3
Address1 | Prefecture+City/Ward/County+Street/Town/Village |  |
Address1; | Prefecture |  |
;Address1 | City/Ward/County+Street/Town/Village |  |
;Address1; | City/Ward/County |  |
;;Address1 | Street/Town/Village |  |
Address1;Address2 | Prefecture | City/Ward/County+Street/Town/Village |
Address1;Address1 | Prefecture+City/Ward/County+Street/Town/Village |  |
Address1;Address2; | Prefecture | City/Ward/County |
Address1;Address1; | Prefecture+City/Ward/County |  |
;Address1;Address2 | City/Ward/County | Street/Town/Village |
;Address1;Address1 | City/Ward/County+Street/Town/Village |  |
Address1;Address2;Address3 | Prefecture | City/Ward/County | Street/Town/Village
Address1;Address2;Address2 | Prefecture | City/Ward/County+Street/Town/Village |
Address1;Address1;Address2 | Prefecture+City/Ward/County | Street/Town/Village |
Address1;Address1;Address1 | Prefecture+City/Ward/County+Street/Town/Village |  |

The postal code converter program has been developed and licensed by Advanced Giken Corporation for Microsoft Corporation.


PreviousControl-Eigenschaft - Beispiel

Im folgenden Beispiel wird eine Meldung angezeigt, wenn das Steuerelement, das als vorletztes den Fokus erhalten hat, nicht das Textfeld txtLetzterEintrag ist.

Function DatenVerarbeiten() As Integer
    Dim ctlPrevious As Control
    ' Fehler "Kein vorheriges Steuerelement".
    Const conKeinVorherigesSteuerelement = 2483
    On Error GoTo Verarbeitung_Fehler
    Set ctlPrevious = Screen.PreviousControl
    If ctlPrevious.Name = "txtLetzterEintrag" Then
        ' Die Daten hier verarbeiten.
            .
            .
            .
        DatenVerarbeiten = True
    Else
        ' Den Fokus auf txtLetzterEintrag setzen und eine Meldung anzeigen.
        Me!txtLetzterEintrag.SetFocus
        MsgBox "Geben Sie hier einen Wert ein."
        DatenVerarbeiten = False
    End If
Verarbeitung_Ende:
    Exit Function
Verarbeitung_Fehler:
    If Err = conKeinVorherigesSteuerelement Then
        Me!txtLetzterEintrag.SetFocus
        MsgBox "Geben Sie einen Wert ein, der verarbeitet werden soll."
        DatenVerarbeiten = False
    End If
    Resume Verarbeitung_Ende
End Function


 PrimaryKey-Eigenschaft

PrimaryKey-Eigenschaft

Wenn Sie in Microsoft Access einen Primärschlüssel für eine Tabelle in der Tabellenentwurfsansicht festlegen, wird er automatisch als Primärschlüsselindex definiert.


 Primary-Eigenschaft (MDB)

Primary-Eigenschaft (MDB)

Wenn Sie in Microsoft Access einen Primärschlüssel für eine Tabelle in der Tabellenentwurfsansicht einstellen, wird der Primärschlüssel automatisch als primärer Index definiert.


ProcOfLine-Eigenschaft - Beispiel

In der folgenden Funktion werden die Namen aller Prozeduren aufgelistet, die zu dem jeweils angegebenen Modul gehören:

Function AlleProzeduren(strModulname As String)
    Dim mdl As Module
    Dim lngAnzahl As Long, lngAnzahlDekl As Long, lngI As Long
    Dim strProzName As String, astrProzNamen() As String
    Dim intI As Integer, strMldg As String
    Dim lngR As Long

    ' Das angegebene Module-Objekt öffnen.
    DoCmd.OpenModule strModulname
    ' Den Verweis auf das Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
    ' Die Anzahl der Zeilen des Moduls ermitteln.
    lngAnzahl = mdl.CountOfLines
    ' Die Anzahl der Zeilen des Deklarationsabschnitts
    ' des Moduls ermitteln.
    lngAnzahlDekl = mdl.CountOfDeclarationLines
    ' Den Namen der ersten Prozedur ermitteln.
    strProzName = mdl.ProcOfLine(lngAnzahlDekl + 1, lngR)
    ' Die Zählervariable initialisieren.
    intI = 0
    ' Das Datenfeld neu dimensionieren.
    ReDim Preserve astrProzNamen(intI)
    ' Den Namen der ersten Prozedur im Datenfeld speichern.
    astrProzNamen(intI) = strProzName
    ' Für jede Zeile, die auf den Deklarationsbereich
    ' folgt, den Namen der Prozedur ermitteln.
    For lngI = lngAnzahlDekl + 1 To lngAnzahl
        ' Den Prozedurnamen mit dem Wert der Eigenschaft
        ' ProcOfLine vergleichen.
        If strProzName <> mdl.ProcOfLine(lngI, lngR) Then
            ' Den Zähler inkrementieren.
            intI = intI + 1
            strProzName = mdl.ProcOfLine(lngI, lngR)
            ReDim Preserve astrProzNamen(intI)
            ' Den eindeutigen Prozedurnamen im Datenfeld speichern.
            astrProzNamen(intI) = strProzName
        End If
    Next lngI
    strMldg = "Prozeduren des Moduls '" & strModulname & "': " _
        & vbCrLf & vbCrLf
    For intI = 0 To UBound(astrProzNamen)
        strMldg = strMldg & astrProzNamen(intI) & vbCrLf
    Next intI
    ' In einem Dialogfeld die Namen aller Prozeduren
    ' des Moduls auflisten.
    MsgBox strMldg
End Function

Sie können diese Funktion mit einer Prozedur aufrufen, die wie folgt aussieht:

Sub AlleProzedurenAbrufen()
    AlleProzeduren "Dienstprogramme"
End Sub


ProcStartLine-, ProcBodyLine-, ProcCountLines-Eigenschaften - Beispiel

Die folgende Funktion schreibt Informationen zu einer bestimmten Prozedur eines Moduls in das Testfenster:

Function InfosZuProzZeile(strModulname As String, strProzName As String)
    Dim mdl As Module
    Dim lngAnfZeile As Long, lngDefZeile As Long
    Dim lngAnzahl As Long, lngEndeProz As Long

    ' Das angegebene Module-Objekt öffnen.
    DoCmd.OpenModule strModulname
    ' Den Verweis auf das Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
        ' Die Zeilen der Prozedur zählen.
    lngAnzahl = mdl.ProcCountLines(strProzName, vbext_pk_Proc)
    ' Die Nummer der Anfangszeile ermitteln.
    lngAnfZeile = mdl.ProcStartLine(strProzName, vbext_pk_Proc)
    ' Die Nummer der Zeile ermitteln, in der die
    ' Prozedurdefinition beginnt.
    lngDefZeile = mdl.ProcBodyLine(strProzName, vbext_pk_Proc)
    Debug.Print
        ' Alle Zeilen der Prozedur ausgeben, die vor der
    ' ersten Definitionszeile stehen.
    Debug.Print "Die Zeilen vor der Prozedur '" & strProzName & "': "
    Debug.Print mdl.Lines(lngAnfZeile, lngDefZeile - lngAnfZeile)

    ' Die Nummer der letzten Zeile der Prozedur ermitteln.
    lngEndeProz = (lngDefZeile + lngAnzahl - 1) - Abs(lngDefZeile - lngAnfZeile)

    ' Alle zur Definition der Prozedur gehörenden
    ' Zeilen ausgeben.
    Debug.Print "Definitionszeilen: "
    Debug.Print mdl.Lines(lngDefZeile, (lngEndeProz - lngDefZeile) + 1)
End Function

Sie können diese Funktion in der Beispieldatenbank Nordwind aus einer Prozedur aufrufen, die wie folgt aussieht:

Sub ProzInfosAbrufen()
    InfosZuProzZeile "Dienstprogramme", "IsLoaded"
End Sub


Properties-Eigenschaft (Properties-Auflistung) - Beispiel

Das folgende Beispiel zeigt die Properties-Auflistung des geöffneten Bestellformulars und druckt den Namen jeder Eigenschaft und ihren Wert.

Sub AktuelleEigenschaftenEinstellungen()
    Dim frm As Object, prp As Integer
    Set frm = Application.Forms("Bestellungen")
    ' Properties-Auflistung aufzählen.
    For prp = 0 To frm.Properties.Count - 1
        ' Name von Eigenschaft und Wert drucken.
        Debug.Print frm.Properties(prp).Name & " = " _
            & frm.Properties(prp).Value
    Next prp
End Sub


Properties-Eigenschaft - Beispiel

Die folgende Prozedur verwendet die Eigenschaft Properties, um alle Eigenschaften der Steuerelemente eines Formulars im Testfenster zu drucken. Wenn Sie diesen Code ausführen möchten, fügen Sie eine Befehlsschaltfläche mit dem Namen cmdEigenschaftenAuflisten zu einem Formular hinzu, und fügen Sie den folgenden Code in den Deklarationsbereich des Formulars ein. Klicken Sie auf die Befehlsschaltfläche, um die Liste der Eigenschaften im Testfenster zu drucken.

Sub cmdEigenschaftenAuflisten_Click()
    ListControlProps Me
End Sub

Sub ListControlProps(frm As Form)
    Dim ctl As Control, prp As Property

    On Error GoTo props_err
    For Each ctl In frm.Controls
        Debug.Print ctl.Properties("Name")
        For Each prp In ctl.Properties
            Debug.Print vbTab & prp.Name & " = " & prp.Value
        Next prp
    Next ctl

props_bye:
    Exit Sub

props_err:
    If Err = 2187 Then
        Debug.Print vbTab & prp.Name & " = Nur zur Entwurfszeit verfügbar."
        Resume Next
    Else
        Debug.Print vbTab & prp.Name & " = Fehler aufgetreten: " & Err
        Resume Next
    End If
End Sub


 Protection-Eigenschaft

Protection-Eigenschaft

Wenn Sie in Microsoft Access 2000 die verschiedenen Optionen der Protection-Eigenschaft einstellen möchten, die verhindern oder erlauben, dass Benutzer eine Menüleiste, Symbolleiste oder ein benutzerdefiniertes Kontextmenü anpassen, können Sie das Dialogfeld Symbolleisteneigenschaften verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen. Klicken Sie anschließend im Dialogfeld Anpassen auf die Schaltfläche Eigenschaften. Wählen Sie im Feld Ausgewählte Symbolleiste die gewünschte Menüleiste, Symbolleiste oder das gewünschte benutzerdefinierte Kontextmenü, und verwenden Sie dann das Kombinationsfeld Andocken und die Kontrollkästchen Anpassen zulassen, Größenanpassung zulassen, Verschieben zulassen und Einblenden/Ausblenden zulassen, um den gewünschten Schutz einzurichten. Für benutzerdefinierte Kontextmenüs steht lediglich die Option Anpassen zulassen zur Verfügung.


PrtDevMode-Eigenschaft - Beispiel

Im folgenden Beispiel wird die Eigenschaft PrtDevMode verwendet, um für einen Bericht die benutzerdefinierte Seitengröße zu prüfen:

Type str_DEVMODE
    strGZF As String * 94
End Type

Type type_DEVMODE
    strDeviceName As String * 16
    intSpecVersion As Integer
    intDriverVersion As Integer
    intSize As Integer
    intDriverExtra As Integer
    lngFields As Long
    intOrientation As Integer
    intPaperSize As Integer
    intPaperLength As Integer
    intPaperWidth As Integer
    intScale As Integer
    intCopies As Integer
    intDefaultSource As Integer
    intPrintQuality As Integer
    intColor As Integer
    intDuplex As Integer
    intResolution As Integer
    intTTOption As Integer
    intCollate As Integer
    strFormName As String * 16
    lngPad As Long
    lngBits As Long
    lngPW As Long
    lngPH As Long
    lngDFI As Long
    lngDFr As Long
End Type

Sub BenutzerdefinierteSeitePrüfen(rptName As String)
    Dim GeräteZF As str_DEVMODE
    Dim DM As type_DEVMODE
    Dim strGerätemodus As String
    Dim rpt As Report
    Dim intAntwort As Integer
    ' Den Bericht in der Entwurfsansicht öffnen.
    DoCmd.OpenReport rptName, acDesign
    Set rpt = Reports(rptName)
    If Not IsNull(rpt.PrtDevMode) Then
        strGerätemodus = rpt.PrtDevMode          ' Die Struktur DEVMODE lesen.
        GeräteZF.strGZF = strGerätemodus
        LSet DM = GeräteZF
        If DM.intPaperSize = 256 Then
            ' Die benutzerdefinierte Seitengröße anzeigen.
            intAntwort = MsgBox("Die aktuelle" _                 & "benutzerdefinierte Seite hat folgende Maße " _
                & "Länge " & DM.intPaperLength / 100 _                  & " cm, " _
                & "Breite " & DM.intPaperWidth / 100 _                  & " cm. " _
                & "Möchten Sie diese Einstellungen ändern?", 4)
        Else
            ' Die Maße sind momentan nicht benutzerdefiniert.
            intAntwort = MsgBox("Der Bericht " _                 & "hat keine benutzerdefinierte" _                 &  Seitengröße."_
                & "Möchten Sie eine definieren?", 4)
        End If
        If intAntwort = 6 Then
            ' Der Benutzer möchte die Einstellungen ändern.
            ' Das Element Fields initialisieren.
            DM.lngFields = DM.lngFields Or _              DM.intPaperSize Or DM.intPaperLength _
                Or DM.intPaperWidth
            DM.intPaperSize = 256    ' Benutzerdefinierte Seite.
            ' Die Länge und die Breite abfragen.
            DM.intPaperLength =_               InputBox("Geben Sie die Seitenlänge " _
                & "in cm ein.") * 100
            DM.intPaperWidth =_               InputBox("Geben Sie die Seitenbreite " _
                & "in cm ein.") * 100
            LSet GeräteZF = DM        ' Die Eigenschaft aktualisieren.
            Mid(strGerätemodus, 1, 94) = GeräteZF.strGZF
            rpt.PrtDevMode = strGerätemodus
        End If
    End If
End Sub

Das folgende Beispiel zeigt, wie die Ausrichtung eines Berichtes geändert werden kann. In diesem Beispiel wird die Ausrichtung von Hochformat in Querformat oder von Querformat in Hochformat geändert (je nach momentaner Ausrichtung des Berichtes).

Sub AusrichtungWechseln(strName As String)
    Const DM_HOCHFORMAT = 1
    Const DM_QUERFORMAT = 2
    Dim GeräteZF As str_DEVMODE
    Dim DM As type_DEVMODE
    Dim strGerätemodus As String
    Dim rpt As Report
    ' Den Bericht in der Entwurfsansicht öffnen.
    DoCmd.OpenReport strName, acDesign
    Set rpt = Reports(strName)
    If Not IsNull(rpt.PrtDevMode) Then
        strGerätemodus = rpt.PrtDevMode
        GeräteZF.strGZF = strGerätemodus
        LSet DM = GeräteZF
        DM.lngFields = DM.lngFields Or DM.intOrientation    ' Das Element Fields initialisieren.
        If DM.intOrientation = DM_HOCHFORMAT Then
            DM.intOrientation = DM_QUERFORMAT
        Else
            DM.intOrientation = DM_HOCHFORMAT
        End If
        LSet GeräteZF = DM                ' Die Eigenschaft aktualisieren.
        Mid(strGerätemodus, 1, 94) = GeräteZF.strGZF
        rpt.PrtDevMode = strGerätemodus
    End If
End Sub


PrtMip-Eigenschaft - Beispiel

Das folgende Beispiel zur Eigenschaft PrtMip verdeutlicht, wie ein Bericht mit zwei horizontalen Spalten eingerichtet wird.

Type str_PRTMIP
    strGZF As String * 28
End Type
Type type_PRTMIP
    xLeftMargin As Long
    yTopMargin As Long
    xRightMargin As Long
    yBotMargin As Long
    fDataOnly As Long
    xWidth As Long
    yHeight As Long
    fDefaultSize As Long
    cxColumns As Long
    yColumnSpacing As Long
    xRowSpacing As Long
    rItemLayout As Long
    fFastPrint As Long
    fDatasheet As Long
End Type

Sub PrtMipSpalten(strName As String)
    Dim PrtMipZeichenfolge As str_PRTMIP
    Dim PM As type_PRTMIP
    Dim rpt As Report
    Const PM_HORIZONTALESPALTEN = 1953
    Const PM_VERTIKALESPALTEN = 1954
    DoCmd.OpenReport strName, acDesign
    Set rpt = Reports(strName)
    PrtMipZeichenfolge.strGZF = rpt.PrtMip
    LSet PM = PrtMipZeichenfolge
    ' 2 Spalten erstellen.
    PM.intColumns = 2     ' 0,25 Zoll zwischen 2 Zeilen.
    PM.intRowSpacing = 0.25 * 1440     ' 0,5 Zoll zwischen 2 Spalten.
    PM.intColumnSpacing = 0.5 * 1440
    PM.intItemLayout = PM_HORIZONTALESPALTEN

    LSet PrtMipZeichenfolge = PM        ' Die Eigenschaft aktualisieren.
    rpt.PrtMip = PrtMipZeichenfolge.strGZF
End Sub

Das nächste Beispiel zur Eigenschaft PrtMip zeigt, wie alle Ränder auf 1 Zoll eingestellt werden können.

Sub RänderAufStandardEinstellen(strName As String)
    Dim PrtMipZeichenfolge As str_PRTMIP
    Dim PM As type_PRTMIP
    Dim rpt As Report
    DoCmd.OpenReport strName, acDesign
    Set rpt = Reports(strName)
    PrtMipZeichenfolge.strGZF = rpt.PrtMip
    LSet PM = PrtMipZeichenfolge
    PM.intLeftMargin = 1 * 1440    ' Die Ränder einstellen.
    PM.intTopMargin = 1 * 1440
    PM.intRightMargin = 1 * 1440
    PM.intBotMargin = 1 * 1440
    LSet PrtMipZeichenfolge = PM    ' Die Eigenschaft aktualisieren.
    rpt.PrtMip = PrtMipZeichenfolge.strGZF
End Sub


QueryTimeout-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel stellt die Eigenschaft QueryTimeout der aktuellen Datenbank ein.

Sub ZeitüberschreitungEinstellen()
    Dim dbs As Database

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    dbs.QueryTimeout = 120
    Set dbs = Nothing
End Sub


Error-, PageCount-, SnapshotPath-Eigenschaften (Fehler, SeitenZahl, SnapshotPfad) und ReadyStateChange-Ereignis - Beispiele

Das folgende Beispiel verwendet eine SelectCase-Anweisung in der ReadyStateChange-Ereignisprozedur eines Snapshot-Steuerelements, um den Status der ReadyState-Eigenschaft zu ermitteln. Wenn eine Snapshot-Datei erfolgreich in das Steuerelement geladen wird, wird ein Meldungsfeld mit Angaben zum Dateipfad und zur Seitenzahl angezeigt. Tritt beim Laden des Snapshots jedoch ein Fehler auf, wird eine spezifische Fehlerbehandlungsprozedur aufgerufen, die Informationen zu dem aufgetretenen Fehler anzeigt. Am Anfang der Prozedur werden Konstanten für jeden möglichen Wert der ReadyState-Eigenschaft definiert.

Private Sub Snapshot1_ReadyStateChange(ByVal ReadyState As Long)
    Const conSnpNichtInitialisiert = 0
    Const conSnpWirdGeladen = 1
    Const conSnpBeimDownloaden = 2
    Const conSnpDownloadBeendet = 4
    Select Case ReadyState
        Case conSnpNichtInitialisiert
            ' Snapshot-Steuerelement ist nicht initialisiert.
        Case conSnpWirdGeladen
            ' Snapshot-Steuerelement wird geladen.
        Case conSnpBeimDownloaden
            ' Snapshot-Steuerelement wird geladen, aber die Snapshot-Datei
            ' wird noch gedownloadet.
        Case conSnpDownloadBeendet
            ' Laden des Snapshots ist abgeschlossen.
        With Snapshot1
            If .Error = 0 Then
                ' Snapshot-Datei erfolgreich in das Steuerelement geladen.
                    Msgbox .SnapshotPath & _
                    " wurde erfolgreich in das " _
                    & "Snapshot Viewer-Steuerelement geladen." & vbCrLf & vbCrLf _
                    & "Diese Snapshot-Datei umfasst" & .PageCount _
                    & " Seiten."
            Else
                ' Fehler beim Laden der Snapshot-Datei aufgetreten.
                Call HandleSnapError(.SnapshotPath, .Error)
                Exit sub
            End If
        End With
    End Select
End Sub

Sub HandleSnapError(strFile As String, lngError As Long)
    Dim strError As String
    Select Case lngError
        Case 2500
            strError = "Fehler " & CStr(lngError) & ": Ungültiger Wert."
        Case 2501
            strError = "Fehler " & CStr(lngError) & ": Ungültige Seite."
        Case 2502
            strError = "Fehler " & CStr(lngError) & _
                ": Fehlende oder ungültige Snapshot-Datei."
        Case 2503
            strError = "Fehler " & CStr(lngError) & _
                ": Eigenschaft ist schreibgeschützt."
        Case 2504
            strError = "Fehler " & CStr(lngError) & _
                ": Vorgang auf Benutzerwunsch abgebrochen."
        Case 2505
            strError = "Fehler " & CStr(lngError) & _
                ": Zur Anzeige dieser Snapshot-Datei benötigen Sie" _
                & "eine aktuellere Version des Snapshot Viewer-Steuerelements."
        Case 2506
            strError = "Fehler " & CStr(lngError) & _
                ": Während des Druckvorgangs trat ein Fehler auf."
        Case 2507
            strError = "Fehler " & CStr(lngError) & _
                ": Beim Öffnen der Snapshot-Datei trat ein Fehler auf."
        Case 2508
            strError = "Fehler " & CStr(lngError) & ": Nicht genügend Speicher."
        Case 2509
            strError = "Fehler " & CStr(lngError) & _
                ": Während des Öffnungsvorgangs der Snapshot-Datei  trat " _
                & "beim Schreiben in eine Temporärdatei ein Fehler auf."
        Case 2510
            strError = "Fehler " & CStr(lngError) & _
                ": Es sind keine Drucker installiert, oder es ist" _
                & "kein Standarddrucker ausgewählt."
        Case Else
            strError = "Fehler " & CStr(lngError) & _
                ": Ein unbekannter Fehler ist aufgetreten."
    End Select

    MsgBox strError & " Datei: " & strFile
End Sub


RecordCount-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt, das auf der Tabelle Bestellungen basiert, und ermittelt dann die Anzahl der Datensätze im Recordset-Objekt.

Sub DatensätzeZählen()
    Dim dbs As Database, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle öffnen.
    Set rst = dbs.OpenRecordset("Bestellungen")
    Debug.Print rst.RecordCount
    rst.Close
    Set dbs = Nothing
End Sub


RecordsAffected-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel gibt die Anzahl der Datensätze aus, die von einer Aktionsabfrage aktualisiert wurden.

Sub AktualisierteDatensätze()
    Dim dbs As Database, qdf As QueryDef
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    strSQL = "UPDATE Personal SET Position = " _
        & "'Gebiets-Verkaufsrepräsentant' WHERE Position = ''Verkaufsrepräsentant';"
    ' Neues QueryDef-Objekt erstellen.
    Set qdf = dbs.CreateQueryDef("PositionAktualisieren", strSQL)
    ' QueryDef-Objekt ausführen.
    qdf.Execute
    Debug.Print qdf.RecordsAffected
    Set dbs = Nothing
End Sub


RecordsetClone-Eigenschaft: Beispiel

Das folgende Beispiel verwendet die Eigenschaft RecordsetClone, um ein Recordset-Objekt aus dem Formular Bestellungen zu erstellen und dann die Namen der Felder im Direktfenster auszugeben.

Sub FeldnamenAusgeben()
    Dim rst As Recordset, intI As Integer
    Dim fld As Field

    Set rst = Me.RecordsetClone
    For Each fld in rst.Fields
         ' Feldnamen drucken.
         Debug.Print fld.Name
    Next
End Sub

Das nächste Beispiel verwendet die Eigenschaft RecordsetClone und das Recordset-Objekt, um den Datensatz einer Datensatzgruppe mit dem aktuellen Datensatz eines Formulars zu synchronisieren. Wenn ein Firmenname aus einem Kombinationsfeld ausgewählt ist, wird die Methode FindFirst verwendet, um den Datensatz für diese Firma zu finden, und die DAO-Eigenschaft Bookmark des Recordset-Objekts wird der Eigenschaft Bookmark des Formulars zugewiesen, was bewirkt, dass das Formular den gefundenen Datensatz anzeigt.

Sub Lieferanten_Nr_AfterUpdate()
    Dim rst As Recordset
    DimstrGesuchterName As String

    Set rst = Me.RecordsetClone
    strGesuchterName = Str(Me![Lieferanten-Nr])
    rst.FindFirst "[Lieferanten-Nr] = " & strGesuchterName
         If rst.NoMatch Then
             MsgBox " Datensatz nicht gefunden "
         Else
             Me.Bookmark = rst.Bookmark
         End If
    rst.Close
End Sub


RecordsetType-Eigenschaft (Recordsettyp) - Beispiel

Im folgenden Beispiel können Datensätze nur dann aktualisiert werden, wenn die Benutzer-ID ADMIN lautet. In diesem Codebeispiel wird die Eigenschaft RecordsetType auf Snapshot eingestellt, wenn die öffentliche Variable gstrBenutzerID nicht den Wert ADMIN hat.

Sub Form_Open(Cancel As Integer)
    Const conSnapshot = 2
    If gstrBenutzerID <> "ADMIN" Then
        Formulare!Personal.RecordsetType = conSnapshot
    End If
End Sub


Recordset-Eigenschaft: Beispiel

Im folgenden Beispiel wird die Recordset-Eigenschaft verwendet, um eine Kopie des Recordset-Objekts aus dem aktuellen Formular zu erzeugen und dann die Feldnamen im Testfenster auszugeben.

Sub Print_Field_Names()
    Dim rst As DAO.Recordset, intI As Integer
    Dim fld As Field

    Set rst = Me.Recordset
    For Each fld in rst.Fields
        ' Feldnamen drucken.
        Debug.Print fld.Name
    Next
End Sub

Das nächste Beispiel verwendet die Recordset-Eigenschaft und das Recordset-Objekt zum Synchronisieren des Datensatzes einer Datensatzgruppe mit dem aktuellen Datensatz des Formulars. Wenn ein Firmenname aus einem Kombinationsfeld ausgewählt wird, wird die FindFirst-Methode verwendet, um den Datensatz für diese Firma zu suchen und das Formular den gefundenen Datensatz anzeigen zu lassen.

Sub Lieferanten_Nr_AfterUpdate()
    Dim rst As DAO.Recordset
    Dim strSearchName As String

    Set rst = Me.Recordset
    strSearchName = Str(Me![Lieferanten-Nr])
    rst.FindFirst "[Lieferanten-Nr] = " & strSearchName
        If rst.NoMatch Then
            MsgBox "Datensatz nicht gefunden."
        End If
    rst.Close
End Sub

Der folgende Code hilft bei der Bestimmung, welcher Datensatzgruppentyp bei unterschiedlichen Bedingungen von der Recordset-Eigenschaft zurückgegeben wird.

Sub CheckRSType()
    Dim rs as Object

    Set rs=Forms(0).Recordset
    If TypeOf rs Is DAO.Recordset Then
    MsgBox "DAO Recordset"
    ElseIf TypeOf rs is ADODB.Recordset Then
    MsgBox "ADO Recordset"
    End If
End Sub


RecordSource-Eigenschaft (Datenherkunft) - Beispiel

Das folgende Beispiel stellt die Eigenschaft RecordSource eines Formulars auf die Tabelle Kunden ein.

Formulare!frmKunden.RecordSource = "Kunden"

Das nächste Beispiel ändert die Datenherkunft eines Formulars auf einen einzelnen Datensatz der Tabelle Kunden, abhängig vom ausgewählten Firmennamen im Kombinationsfeld-Steuerelement cmboFirma. Das Kombinationsfeld wird durch eine SQL-Anweisung gefüllt, die den Kunden-Code (in der gebundenen Spalte) und den Firmennamen zurückgibt. Der Kunden-Code hat den Datentyp Text.

Sub cmboFirma_AfterUpdate()
    Dim strNeuerDS As String
    strNeuerDS = "SELECT * FROM Kunden " _
        & " WHERE [Kunden-Code] = '" _
        & Me!cmboFirma.Value & "'"
    Me.RecordSource = strNeuerDS
End Sub


ReplicationConflictFunction-Eigenschaft - Beispiel

Die folgende Funktion stellt eine Microsoft Access-Eigenschaft bei einem Datenzugriffsobjekt ein. Mit Hilfe dieser Funktion können Sie dann die Eigenschaft ReplicationConflictFunction einstellen. Wenn diese Eigenschaft in der Properties-Auflistung des benutzerdefinierten Document-Objekts UserDefined nicht bereits vorhanden ist, erstellt Microsoft Access die Eigenschaft automatisch und fügt sie an die Auflistung an. Beachten Sie, dass Sie zum Einstellen dieser Eigenschaft den Wert True (-1) für das optionale Argument blnDDL angeben müssen.

Function EinstellenAccessEigenschaft(obj As Object, _
        strName As String, intTyp As Integer, _
        varEinstellung As Variant, Optional blnDDL _
        As Boolean)
    Dim prp As Property
    Const intEigNichtGefunden As Integer = 3270

    On Error GoTo Fehler_EinstellenAccessEigenschaft
    ' Expliziter Verweis auf die Properties-Auflistung.
    obj.Properties(strName) = varEinstellung
    obj.Properties.Refresh
    EinstellenAccessEigenschaft = True

Exit_EinstellenAccessEigenschaft:
    Exit Function

Error_EinstellenAccessEigenschaft:
    If Err = intEigNichtGefunden Then
        ' Überprüfen, ob optionales Argument übergeben
         ' wurde.
        If Not IsMissing(blnDDL) Then
            ' Eigenschaft erstellen, Typ kennzeichnen,
            ' Anfangswert einstellen, DDL anzeigen.
            Set prp = obj.CreateProperty(strName, _
            intTyp, varEinstellung, blnDDL)
        Else
            ' Eigenschaft erstellen, Typ kennzeichnen,
            ' Anfangswert einstellen.
            Set prp = obj.CreateProperty(strName, _
            intTyp, varEinstellung)
        End If
        ' Property-Objekt an Properties-Auflistung
        ' anfügen.
        obj.Properties.Append prp
        obj.Properties.Refresh
        EinstellenAccessEigenschaft = True
        Resume Exit_EinstellenAccessEigenschaft
    Else
        MsgBox Err & ": " & vbCrLf & Err.Description
        EinstellenAccessEigenschaft = False
        Resume Exit_EinstellenAccessEigenschaft
    End If
End Function

Die folgende Prozedur ruft die Funktion EinstellenAccessEigenschaft auf, um die Eigenschaft ReplicationConflictFunction einzustellen:

Sub EinstellenKonfliktlöser()
    Dim dbs As Database, ctr As Container, doc As Document
    Dim blnRückgabe As Boolean

    ' Verweis auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Verweis auf den Databases-Container zurückgeben.
    Set ctr = dbs.Containers!Databases
    ' Verweis auf Document-Objekt UserDefined
    ' zurückgeben.
    Set doc = ctr.Documents!userdefined
    blnRückgabe = EinstellenAccessEigenschaft(doc, _
        "ReplicationConflictFunction", dbText, _
        "BenutzerdefinierterKonfliktlöser", True)
    ' Rückgabewert auswerten.
    If blnRückgabe = True Then
        Debug.Print "Eigenschaft erfolgreich " & _
        "eingestellt."
    Else
        Debug.Print "Eigenschaft nicht erfolgreich " & _
        "eingestellt."
    End If
End Sub


ResyncCommand- und UniqueTable-Eigenschaften (ResyncBefehl und Eindeutige Tabelle) - Beispiel

In diesen Szenarien werden zwei SQL Server-Tabellen vorausgesetzt, Patienten und Ärzte, mit einer 1:n-Beziehung von Ärzte zu Patienten. Beide Tabellen besitzen eine ID-Spalte als Primärschlüssel.

Tabelle "Patienten"

Spalte | Datentyp | Attribute
ID | int | Identität, Primärschlüssel
NachName | varchar(30) | nicht Null
VorName | varchar(20) | nicht Null
PrimärArzt | int | Null, Fremdschlüssel auf Ärzte(ArztID)

Tabelle "Ärzte"

Spalte | Datentyp | Attribute
ArztID | int | Identität, Primärschlüssel
ArztName | varchar(30) | nicht Null, Eindeutig
ArztTel | char(15) | nicht Null

Der Benutzer möchte nun eine aktualisierbare Datenblattansicht mit den Daten der Patienten und ihrer Ärzte erstellen. Die Tabelle soll folgende Daten enthalten:

ID | NachName | VorName | PrimärArzt | ArztName | ArztTel
1 | Jonas | Peter | 10 | Brinkmann | (206) 882-8080
2 | Wilhelm | Johannes | 20 | Marcus | (206) 936-4321
3 | Robens | Georg | 20 | Marcus | (206) 936-4321
4 | Krämer | David | 10 | Brinkmann | (206) 882-8080

Dieses Formular basiert auf einer logischen Abfragestruktur:

SELECT P.ID, P.NachName, P.VorName, P.PrimärArzt, D.ArztName, _
    D.ArztTel FROM Patienten P JOIN Ärzte D ON _
    ( P.PrimärArzt = D.ArztID)

Benutzeraktionen

  1. Der Benutzer möchte dem Patienten Georg Robens Dr. Sommer als Arzt zuweisen (ein vorhandener Arzt mit gegenwärtig keinen Patienten). Dazu gibt er Dr. Sommers ArztID-Wert 30 in die Spalte PrimärArzt in Zeile 3 ein. Als Ergebnis soll in dieser Zeile unter ArztName "Sommer" sowie Dr. Sommers Telefonnummer erscheinen.

    Anmerkung Normalerweise wird PrimärArzt als Nachschlagefeld definiert, so dass der Microsoft Access-Benutzer einen Namen aus einer Dropdownliste auswählen kann und die ID für Dr. Sommer nicht auswendig wissen muss. In diesem Fall wäre wahrscheinlich keine eigene Spalte ArztName vorhanden - der Name würde in der Spalte PrimärArzt angezeigt. Trotzdem muss natürlich nach der Aktualisierung Dr. Sommers richtige Telefonnummer angezeigt werden.

  2. Der Benutzer klickt auf die * - Zeile, um einen neuen Patienten aufzunehmen und ihn Dr. Brinkmann zuzuordnen. Da die Spalte ID Werte aus der Tabelle Patienten anzeigt, sollte die Benutzeroberfläche in der ersten Zelle eine Anmerkung wie etwa "(AutoNummer)" anzeigen und keine Eingaben des Benutzers zulassen. Der Benutzer gibt den Vornamen und den Nachnamen des Patienten sowie einen vorhandenen ArztID-Wert in der Spalte PrimärArzt ein. Ein neuer Datensatz wird in die Tabelle Patienten eingefügt, die Spalte ID wird mit den soeben generierten Werten aktualisiert und in der Tabelle angezeigt, und die Werte in den Spalten ArztName und ArztTel werden in den vorhandenen Daten nachgeschlagen und eingesetzt.

  3. Nun möchte der Benutzer den Datensatz von Peter Jonas löschen. Dazu wählt er die entsprechende Zeile aus und wählt danach Löschen. Der Datensatz von Peter Jonas wird aus der Tabelle Patienten gelöscht; der Cursor entfernt die Zeile, versucht jedoch nicht, den Datensatz von Dr. Brinkmann aus der Tabelle Ärzte zu löschen. (In diesem Fall würde ein Serverfehler erzeugt, falls DRI durchgesetzt würde; selbst wenn die Datenbank dies durchsetzen würde, würde das Löschen des Datensatzes von Dr. Brinkmann die Integrität der Daten in Zeile 4 verletzen, weswegen der Cursor keinen solchen Versuch unternehmen kann.)


RowHeight-, ColumnWidth-Eigenschaften (Zeilenhöhe, Spaltenbreite) - Beispiel

Das folgende Beispiel verändert die Zeilenhöhe der Tabelle Kunden in der Datenblattansicht so, dass zwei Datenzeilen (450 Twips) angezeigt werden, und stellt die Breite der Spalte Straße auf 1,5 Zoll (2160 Twips) ein. Diese Eigenschafteneinstellungen werden wirksam, wenn die Tabelle Kunden das nächste Mal in der Datenblattansicht geöffnet wird.

Zur Einstellung der Eigenschaften RowHeight und ColumnWidth verwendet das Beispiel die Prozedur TabEigEinstellen, die im Beispiel für die Eigenschaften DatasheetFontItalic und DatasheetFontUnderline gezeigt wird, sowie die Prozedur FeldEigEinstellen, welche im Beispiel für die Eigenschaft ColumnHidden gezeigt wird.

Dim dbs As Object, tdKunden As Object Const DB Long As Long = 4 Const DB Integer as Integer = 3
Set dbs = CurrentDb
Set tdKunden = dbs![Kunden]
TabEigEinstellen tdKunden, "RowHeight", DB Long, 450
FeldEigEinstellen tdKunden![Straße], "ColumnWidth", DB Integer, 2160

Im nächsten Beispiel wird die Einstellung wirksam, wenn das Formular Kunden in der Datenblattansicht geöffnet ist. Die Zeilenhöhe wird auf 450 Twips eingestellt, und die Größe der Spalte wird der Größe des sichtbaren Textes angepaßt.

Formulare![Kunden].RowHeight = 450
Formulare![Kunden]![Straße].ColumnWidth = -2


RowSourceType-, RowSource-Eigenschaften (Herkunftstyp, Datensatzherkunft) - Beispiel (Einstellungen)

Die folgenden Beispiele zeigen Einstellungen der Eigenschaft RowSource für jede Einstellung der Eigenschaft RowSourceType.

Wenn RowSourceType auf "Wertliste" eingestellt ist

Ist die Eigenschaft RowSourceType auf Wertliste eingestellt, zeigt die folgende Tabelle gültige Einstellungen für die Eigenschaften RowSource und ColumnCount sowie eine Darstellung der sich ergebenden Liste.

Einstellung für RowSource | Liste
Mo;Di;Mi (ColumnCount = 1) | Einspaltige Liste mit drei Zeilen
1;Montag;2;Dienstag;3;Mittwoch;4;Donnerstag (ColumnCount = 2) | Zweispaltige Liste mit vier Zeilen
Land;Hauptstadt;China;Peking;Brasilien;Brasilia (ColumnCount = 2, ColumnHeads = Ja) | Zweispaltige Liste mit einer Zeile Spaltenüberschriften und zwei Zeilen Daten

Wenn RowSourceType auf "Tabelle/Abfrage" eingestellt ist

Ist die Eigenschaft RowSourceType auf Tabelle/Abfrage eingestellt, so können Sie die Eigenschaft RowSource auf einen Tabellen- oder Abfragenamen (z.B. Kategorieliste) einstellen.

Nachfolgend wird eine gültige SQL-Anweisung für eine zweispaltige Liste dargestellt, die auf der Tabelle Kategorien basiert.

SELECT [Kategorie-Nr], Kategoriename FROM Kategorien ORDER BY Kategoriename;

Definieren die Abfrage Kategorieliste und die SQL-Anweisung die gleiche Gruppe von Datensätzen, so sieht die Liste der Eigenschafteneinstellungen wie folgt aus:

Wenn RowSourceType auf "Feldliste" eingestellt ist

Ist die Eigenschaft RowSourceType auf Feldliste eingestellt und die Eigenschaft RowSource auf Kundenliste (die im vorherigen Beispiel beschriebene Abfrage), so sieht die resultierende Liste wie folgt aus:

Wenn RowSourceType auf eine benutzerdefinierte Funktion eingestellt ist

Ist die Eigenschaft RowSourceType auf den Namen einer benutzerdefinierten Funktion eingestellt, kann die Einstellung der Eigenschaft RowSource leer bleiben. Eine benutzerdefinierte Funktion namens MDBsAnzeigen, die ein Kombinationsfeld mit den Namen aller Datenbanken des aktuellen Verzeichnisses füllt, wird in das Eigenschaftenfenster z.B. wie folgt eingegeben.


RowSourceType-, RowSource-Eigenschaften (Herkunftstyp, Datensatzherkunft) - Beispiel (Visual Basic)

Das folgende Beispiel stellt die Eigenschaft RowSourceType für ein Kombinationsfeld auf Table/Query und die Eigenschaft RowSource auf eine Abfrage namens Personalliste ein.

Formulare!Personal!cmboNamen.RowSourceType = "Table/Query"
Formulare!Personal![cmboNamen].RowSource = "Personalliste"


 RowSourceType-Eigenschaft (benutzerdefinierte Funktion) - Werte für das Argument Code

RowSourceType-Eigenschaft (benutzerdefinierte Funktion) - Werte für das Argument Code

Die von Ihnen in Visual Basic geschriebene Funktion muss fünf Argumente akzeptieren. Das erste Argument muss als Steuerelement deklariert sein, und die verbleibenden Argumente müssen als Werte vom Typ Variant deklariert sein. Die Funktion selbst muss einen Wert vom Typ Variant zurückgeben.

Syntax

Function Funktionsname(Feld As Control,ID As Variant,Zeile As Variant,Spalte As Variant,Code As Variant) As Variant

Die Funktion hat die folgenden 5 erforderlichen Argumente.

Argument | Beschreibung
Feld | Eine Steuerelementvariable, die auf das zu füllende Listenfeld oder Kombinationsfeld verweist.
ID | Ein eindeutiger Wert, der das zu füllende Steuerelement kennzeichnet. Dies ist hilfreich, wenn Sie die gleiche benutzerdefinierte Funktion für mehrere Listenfelder oder Kombinationsfelder verwenden möchten und zwischen diesen unterscheiden müssen. (Das Beispiel stellt diese Variable auf den Wert der Funktion Timer ein.)
Zeile | Die zu füllende Zeile (Zeilenindex beginnt mit Null).
Spalte | Die zu füllende Spalte (Spaltenindex beginnt mit Null).
Code | Eine eingebaute Konstante die die Art der angeforderten Informationen festlegt.

Anmerkung Da Microsoft Access eine benutzerdefinierte Funktion mehrmals aufruft, um Elemente zu einer Liste hinzuzufügen, müssen Sie Informationen zwischen den Aufrufen bewahren. Die beste Möglichkeit dazu bietet die Verwendung von Static-Variablen.

Microsoft Access ruft die benutzerdefinierte Funktion wiederholt mit jeweils verschiedenen Werten im Argument Code auf, um die für die Funktion benötigten Informationen anzugeben. Für das Argument Code können die folgenden eingebauten Konstanten verwendet werden.

Konstante | Bedeutung | Funktion gibt zurück
acLBInitialize | Initialisieren | Wert ungleich 0, wenn die Funktion die Liste füllen kann; andernfalls False (0) oder Null.
acLBOpen | Öffnen | ID-Wert ungleich 0, wenn die Funktion die Liste füllen kann; andernfalls False oder Null.
acLBGetRowCount | Anzahl an Zeilen | Anzahl an Zeilen in der Liste (kann 0 sein); -1, falls unbekannt.
acLBGetColumnCount | Anzahl an Spalten | Anzahl an Spalten in der Liste (immer ungleich 0); muss dem Wert aus dem Eigenschaftenfenster entsprechen.
acLBGetColumnWidth | Spaltenbreite | Breite (in Twips) der Spalte, festgelegt vom Argument Spalte; -1, um die Standardbreite zu verwenden.
acLBGetValue | Listeneintrag | Der in der Zeile und Spalte anzuzeigende Listeneintrag, festgelegt von den Argumenten Zeile und Spalte.
acLBGetFormat | Formatzeichenfolge | Formatzeichenfolge, die zur Formatierung des in der Zeile und Spalte anzuzeigenden Listeneintrags verwendet wird, festgelegt von den Argumenten Zeile und Spalte; oder -1, um das Standardformat zu verwenden
acLBEnd | Ende (der letzte Aufruf einer benutzerdefinierten Funktion verwendet immer diesen Wert) | Nichts.
AcLBClose | (Nicht verwendet) | (Nicht verwendet)

Microsoft Access ruft Ihre benutzerdefinierte Funktion einmal für acLBInitialize, acLBOpen, acLBGetRowCount und acLBGetColumnCount auf (Initialisieren der benutzerdefinierten Funktion, Öffnen der Abfrage und Festlegen der Zeilen- und Spaltenanzahl).

Microsoft Access ruft Ihre benutzerdefinierte Funktion zweimal für acLBGetColumnWidth auf (einmal zum Festlegen der Gesamtbreite des Listenfelds oder Kombinationsfelds und ein zweites Mal zum Einstellen der Spaltenbreite).

Wie oft Ihre benutzerdefinierte Funktion für acLBGetValue und acLBGetFormat (Abrufen von Listeneinträgen und Formatieren von Zeichenfolgen) aufgerufen wird, ist variabel und hängt von der Anzahl an Einträgen, von Bildläufen des Benutzers und anderen Faktoren ab.

Microsoft Access ruft die benutzerdefinierte Funktion für acLBEnd auf, wenn das Formular geschlossen wird, oder immer dann, wenn das Listenfeld oder Kombinationsfeld abgefragt wird.

Wann immer ein bestimmter Wert (z. B. die Anzahl an Spalten) angefordert wird, bewirkt die Rückgabe von Null oder eines ungültigen Wertes, dass Microsoft Access den Aufruf der benutzerdefinierten Funktion mit diesem Code beendet.

Tipp Sie können die Select Case-Codestruktur aus dem Beispiel als Vorlage für Ihre eigenen benutzerdefinierten Funktionen verwenden, die für die Eigenschaft RowSourceType vorgesehen sind.


RowSourceType-Eigenschaft (Herkunftstyp) - Beispiel

Die folgende benutzerdefinierte Funktion gibt eine Liste der nächsten vier Montage, die dem heutigen Datum folgen, zurück. Damit diese Funktion aus dem Listenfeld-Steuerelement aufgerufen werden kann, geben Sie MontageAuflisten als Einstellung der Eigenschaft RowSourceType an, und lassen Sie die Eigenschaft RowSource leer.

Function MontageAuflisten(Feld As Control,ID As Variant,, _     Zeile As Variant,Spalte As Variant,Code As Variant)_      As Variant
    Dim intOffset As Integer
    Select Case Code
        Case acLBInitialize            ' Initialisieren.
            MontageAuflisten = True
        Case acLBOpen                    ' Öffnen.
            MontageAuflisten = Timer        ' Eindeutige ID.
        Case acLBGetRowCount                ' Zeilen lesen.
            MontageAuflisten = 4
        Case acLBGetColumnCount    ' Spalten lesen.
            MontageAuflisten = 1
        Case acLBGetColumnWidth        ' Spaltenbreite abrufen.
            MontageAuflisten = -1        ' Standardbreite verwenden.
        Case acLBGetValue                ' Die Daten lesen.
            intOffset = Abs((9 - Weekday(Now))Mod 7)
            MontageAuflisten = Format(Now() + _              intOffset + 7 * Zeile,"d. mmmm")
    End Select
End Function

Im nächsten Beispiel wird ein statisches Datenfeld verwendet, um die Namen der Datenbanken im aktuellen Verzeichnis zu speichern. Sie rufen diese Funktion auf, indem Sie MDBsAnzeigen als Einstellung der Eigenschaft RowSourceType eingeben und die Eigenschaft RowSource leer lassen.

Function MDBsAnzeigen(Feld As Control, ID As Variant, _      Zeile As Variant, Spalte As Variant, _       Code As Variant) As Variant
    Static DBs(127) As String, Einträge As Integer
    Dim Ergebniswert As Variant
    Ergebniswert = Null
    Select Case Code
        Case acLBInitialize                ' Initialisieren.
            Einträge = 0
            DBs(Einträge ) = Dir("*.MDB")
            Do Until DBs(Einträge) = "" Or Einträge >= 127
                Einträge = Einträge+1
                DBs(Einträge) = Dir
            Loop
            Ergebniswert = Einträge
        Case acLBOpen                        ' Öffnen.
            ' Eindeutige ID für Steuerelement erzeugen.             Ergebniswert = Timer
        Case acLBGetRowCount            ' Die Anzahl der Zeilen lesen.
            Ergebniswert = Einträge
        Case acLBGetColumnCount    ' Die Anzahl der Spalten lesen.
            Ergebniswert = 1
        Case acLBGetColumnWidth    ' Die Spaltenbreite.
            ' -1 besagt: Standardbreite verwenden.            Ergebniswert = -1
        Case acLBGetValue                    ' Die Daten abrufen.
            Ergebniswert = DBs(Zeile)
        Case acLBEnd                        ' Ende.
            Erase DBs
    End Select
    MDBsAnzeigen = Ergebniswert
End Function


RunningSum-Eigenschaft (LaufendeSumme) - Beispiel (Umsatzbericht)

Das folgende Beispiel zeigt einen Umsatzbericht mit zwei Gruppierungsebenen: Monat und Art der Lebensmittel. Jedes Textfeld im Gruppenfuß für die Art der Lebensmittel (Januar Schokoladen, Januar Fleisch usw.) enthält den folgenden Ausdruck:

=Sum([Umsatz])

Die Eigenschaft RunningSum jedes Textfelds wird auf einen der drei folgenden Werte eingestellt: Nein, Über Gruppe oder Über Alles.

Gruppierungsebenen | Nein | Über Gruppe | Über Alles
Monat: Januar
Art der Lebensmittel: Schokoladen
02. Jan | 25 |  |
22. Jan | 75 |  |
Januar Schokoladen | 100 | Jan Lebensm. 100 | Umsatz bisher 100
Art der Lebensmittel: Fleisch
03. Jan | 90 |  |
20. Jan | 60 |  |
Januar Fleisch | 150 | Jan Lebensm. 250 | Umsatz bisher 250
Monat: Februar
Art der Lebensmittel: Schokoladen
05. Feb | 70 |  |
19. Feb | 80 |  |
Februar Schokoladen | 150 | Feb Lebensm. 150 | Umsatz bisher 400
Art der Lebensmittel: Fleisch
12. Feb | 150 |  |
22. Feb | 100 |  |
Februar Fleisch | 250 | Feb Lebensm. 400 | Umsatz bisher 650


RunningSum-Eigenschaft (LaufendeSumme) - Beispiel (Visual Basic)

Das folgende Beispiel stellt die Eigenschaft RunningSum für ein Textfeld namens Gesamtumsatz auf 2 (Über Alles) ein.

Reports!rptUmsatz!Gesamtumsatz.RunningSum = 2


RunPermissions-Eigenschaft (Ausführungsberechtigung) - Beispiel

Das folgende Beispiel stellt eine Auswahlabfrage dar, die auf der Tabelle Kategorien basiert und es allen Benutzern ermöglicht, die Berechtigungen des Besitzers für die Abfrage zu übernehmen. Sie geben diese SQL-Anweisung in der SQL-Ansicht des Abfragefensters ein.

SELECT Kategorien.[Kategorie-Nr], Kategorien.Kategoriename, Kategorien.Beschreibung
FROM Kategorien WITH OWNERACCESS OPTION;


Selected-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft Selected, um ausgewählte Elemente des Listenfelds lstQuelle zum Listenfeld lstZiel zu übertragen. Die Eigenschaft RowSourceType des Listenfelds lstZiel ist auf Wertliste eingestellt, und die Eigenschaft RowSource des Steuerelements wird aus allen im Steuerelement lstQuelle ausgewählten Elementen gebildet. Die Eigenschaft MultiSelect des Listenfelds lstQuelle ist auf Erweitert eingestellt. Die Funktion CopySelected( ) wird durch die Befehlsschaltfläche cmdElementeKopieren aufgerufen.

Sub cmdElementeKopieren_Click()
    CopySelected Me
End Sub

Function CopySelected(frm As Form) As Integer
    Dim ctlQuelle As Control
    Dim ctlZiel As Control
    Dim strElemente As String
    Dim intAktuelleZeile As Integer
    Set ctlQuelle = frm!lstQuelle
    Set ctlZiel = frm!lstZiel
    For intAktuelleZeile = 0 To ctlQuelle.Listcount - 1
        If ctlQuelle.Selected(intAktuelleZeile) Then
            strElemente = strElemente & ctlQuelle.Column(0, intAktuelleZeile) & ";"
        End If
    Next intAktuelleZeile
    ' Eigenschaft RowSource des Zielsteuerelements
    ' zurücksetzen.
    ctlZiel.RowSource = ""
    ctlZiel.RowSource = strElemente
End Function


SelHeight-, SelWidth-, SelTop- und SelLeft-Eigenschaften - Beispiel

Das folgende Beispiel zeigt, wie Sie mit Hilfe der Eigenschaften SelHeight, SelWidth, SelTop und SelLeft in der Datenblattansicht die Position und Größe eines Auswahlrechtecks bestimmen können. Die Prozedur SetHeightWidth weist den Variablen lngAnzZeilen, lngAnzSpalten, lngObereZeile und lngLinkeSpalte die Höhe und Breite des aktuellen Auswahlrechtecks zu und zeigt diese Werte in einem Meldungsfeld an.

Sub FestlegenHöheBreite(frm As Form)
    Dim lngAnzZeilen As Long, lngAnzSpalten As Long
    Dim lngObereZeile As Long, lngLinkeSpalte As Long
    Dim strMeldung As String

    If frm.CurrentView = 2 Then        'Formular ist in Datenblattansicht.
        lngAnzZeilen = frm.SelHeight        'Anzahl der markierten Zeilen.
        lngAnzSpalten = frm.SelWidth        'Anzahl der markierten                                                 ' Spalten.
        lngObereZeile = frm.SelTop            'Oberste Zeile markiert.
        lngLinkeSpalte = frm.SelLeft        ' Spalte links außen                                                 ' markiert.
        strMeldung = "Anzahl Zeilen: " & lngAnzZeilen & vbCrLf
        strMeldung = strMeldung & "Anzahl Spalten: " & lngAnzSpalten & vbCrLf
        strMeldung = strMeldung & "Obere Zeile: " & lngObereZeile & vbCrLf
        strMeldung = strMeldung & "Linke Spalte: " & lngLinkeSpalte
        MsgBox strMeldung
    End If
End Sub


SelLength-, SelStart-, SelText-Eigenschaften (AuswahlLänge, AuswahlBeginn, AuswahlText) - Beispiel

Das folgende Beispiel verwendet zwei Ereignisprozeduren, um einen vom Benutzer angegebenen Text zu suchen. Der zu suchende Text wird in der Load-Ereignisprozedur des Formulars eingestellt. Die Click-Ereignisprozedur für die Schaltfläche Suchen (auf diese klickt der Benutzer, um die Suche zu starten) fordert vom Benutzer den zu suchenden Text an und markiert den Text im Textfeld, falls die Suche erfolgreich war.

Sub Form_Load()
    Dim ctlSuchtext As Control
    Set ctlSuchtext = Formulare!Formular1!Textfeld1
    ctlSuchtext.SetFocus      ' Fokus auf Textfeld setzen.
    ctlSuchtext.Text = "Diese Firma bestellt zweimal jährlich große Mengen " _
        & "Knoblauch, Oregano, Chili und Kreuzkümmel."
End Sub

Sub Suchen_Click()
    Dim strSuche As String, intWo As Integer
    Dim ctlSuchtext As Control
    ' Suchzeichenfolge vom Benutzer holen.
    With Me!Textfeld1
        strSuche = InputBox("Geben Sie den Suchtext ein:")
        ' Zeichenfolge im Text suchen.
        intWo = InStr(.Value, strSuche)
        If intWo Then
            ' Falls gefunden.
            .SetFocus
            .SelStart = intWo - 1
            .SelLength = Len(strSuche)
        Else
            ' Benutzer benachrichtigen.
            MsgBox "Zeichenfolge nicht gefunden."
        End If
    End With
End Sub


ShortcutMenu-Eigenschaft (Kontextmenü) - Beispiel

Das folgende Beispiel deaktiviert das Kontextmenü für das Formular Rechnung sowie für dessen Steuerelemente:

Formulare!Rechnung.ShortcutMenu = False


 ShortcutText-Eigenschaft

ShortcutText-Eigenschaft

Wenn Sie in Microsoft Access 2000 den Verknüpfungstext einstellen möchten, der rechts neben einem eingebauten Schaltflächen-Steuerelement in einem Menü, Untermenü oder Kontextmenü angezeigt wird, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Schaltflächen-Steuerelement, dessen ShortcutText-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie den gewünschten Verknüpfungstext im Feld Verknüpfungstext ein. Sie können diese Eigenschaft für alle eingebauten Schaltflächen-Steuerelemente in Microsoft Access, nicht aber für benutzerdefinierte Schaltflächen-Steuerelemente einstellen.

Das Einstellen dieser Eigenschaft in Microsoft Access bewirkt lediglich, dass der Verknüpfungstext neben dem Steuerelement angezeigt wird. Wenn Sie Verknüpfungstext für ein eingebautes Steuerelement ändern oder hinzufügen, kann der dem Steuerelement zugeordnete Befehl nicht mit diesem Shortcut oder dieser Tastenkombination ausgeführt werden. Wenn Sie den Befehl ausführen möchten, weisen Sie den Shortcut oder die Tastenkombination in einem AutoKeys-Makro einem Makro zu, das die AusführenBefehl-Aktion zum Ausführen des Befehls verwendet.

Für benutzerdefinierte Befehle können Sie keinen Verknüpfungstext neben dem Steuerelement anzeigen. Sie können aber das AutoKeysmakro verwenden, um einen Shortcut oder eine Tastenkombination zuzuweisen, der/die die gleiche Gruppe von Aktionen ausführt wie das Makro oder die Funktion, auf das/die die OnAction-Eigenschaft des Steuerelements eingestellt ist. Weisen Sie die Taste oder Tastenkombination der gewünschten Gruppe von Makroaktionen zu, oder verwenden Sie die AusführenMakro- oder AusführenCode-Aktionen, um das gewünschte Makro bzw. die gewünschte Funktion für diese Taste oder Tastenkombination auszuführen.


 Size-Eigenschaft (MDB)

Size-Eigenschaft (MDB)

Die Eigenschaft Size ist äquivalent mit der Eigenschaft Feldgröße in der Tabellenentwurfsansicht. Sie können die Eigenschaft Feldgröße nicht unter Verwendung von Visual Basic einstellen, sondern müssen stattdessen die Eigenschaft Size verwenden.

In Microsoft Access kann ein Feld vom Datentyp Memo bis zu 1,2 GB an Informationen aufnehmen. Microsoft Access zeigt allerdings nur die ersten 32 KB der Daten in einem Steuerelement eines Formulars oder Berichts an.


Size-, Type-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel erstellt ein neues Field-Objekt und stellt dessen Eigenschaften Size und Type ein. Die Prozedur fügt dann das neue Objekt an die Fields-Auflistung der Tabelle Personal in der TableDefs-Auflistung der Datenbank an.

Sub NeuesField()
    Dim dbs As Database, tdf As TableDef
    Dim fld As Field

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Bezug auf Tabelle "Personal" zurückgeben.
    Set tdf = dbs.TableDefs!Personal
    ' Field-Objekt erstellen.
    Set fld = tdf.CreateField("Urlaubstage")
    ' Feldeigenschaften einstellen.
    fld.Type = dbText
    fld.Size = 20
    ' Feld an Fields-Auflistung anfügen.
    tdf.Fields.Append fld
    Set dbs = Nothing
End Sub

Sie können auch die Methode CreateField zur Einstellung der Eigenschaften Name, Type und Size verwenden, wenn Sie Name, Typ und Größe als Argumente angeben.

Set fld = tdfPersonal.CreateField("Urlaubstage", dbText, 20)


OutputTo- und SendObject-Methoden, Snapshot-Objekttyp: Beispiele

Im folgenden Beispiel wird eine Snapshot-Datei auf einen Datenträger gespeichert oder in eine E-Mail-Nachricht eingebettet ausgegeben, je nach dem im Argument intOutputTO angegebenen Wert. Im Deklarationsbereich des Moduls sind zwei globale Konstanten definiert, mit denen die gewünschte Ausgabeform festgelegt wird. Wenn das Argument intOutputTO die Konstante conSaveSnapshotToDisk enthält, wird die Datei an dem Ort und unter dem Dateinamen gespeichert, der im Argument strPath angegeben ist. Enthält das Argument intOutputTO die Konstante conSaveSnapshotToMail, wird die Datei in eine E-Mail-Nachricht mit der Adresse eingebettet, die im Argument strRecipName angegeben ist. Das Argument strName ist der Name eines Report-Objekts in der aktuellen Datenbank. Das Argument strPath ist der vollständige Pfad- und Dateiname für die auf den Datenträger zu speichernde Snapshot-Datei.

Const conSaveSnapshotToDisk As Integer = 1
Const conSaveSnapshotToMail As Integer = 2

Sub OutputSnapshotFile(intOutputTO As Integer, _
    strName As String, Optional strPath As String, _
    Optional strRecipName As String)

    Dim strOutputFormat As String
    DoCmd.Hourglass True
    strOutputFormat = "Snapshot Format"

    Select Case intOutputTO
        Case conSaveSnapshotToDisk
            If Len(strPath) > 0 Then
                DoCmd.OutputTo acOutputReport, _
                    strName, strOutputFormat, strPath
            Else
                DoCmd.Hourglass False
                Exit Sub
            End If
        Case conSaveSnapshotToMail
            If Len(strRecipName) > 0 Then
                DoCmd.SendObject acSendReport, _
                    strName, strOutputFormat, strRecipName
            Else
                DoCmd.Hourglass False
                Exit Sub
            End If
        Case Else
    End Select
    DoCmd.Hourglass False
End Sub


Sort-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel verwendet die Eigenschaft Sort zur Einstellung der Sortierreihenfolge eines Recordset-Objekts vom Typ Dynaset, das auf der Tabelle Bestellungen basiert. Die Datensätze in der Datensatzgruppenvariablen rstSortiert werden alphabetisch nach dem Bestimmungsland angeordnet.

Beachten Sie, dass zuerst ein Recordset-Objekt vom Typ Dynaset erstellt und dessen Eigenschaft Sort eingestellt wird, und dass dann ein zweites Recordset-Objekt vom Typ Dynaset geöffnet wird, das auf dem ersten Objekt basiert. Die Einstellung der Eigenschaft Sort des ersten Recordset-Objekts hat keine Wirkung auf die darin enthaltenen Datensätze, so dass Sie ein zweites Recordset-Objekt erstellen müssen, um die Wirkung des Sorrtiervorgangs zu sehen.

Sub NachLandSortieren()
    Dim dbs As Database
    Dim rstBestellungen As Recordset, rstSortiert As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Dynaset erstellen.
    Set rstBestellungen = dbs.OpenRecordset("Bestellungen", dbOpenDynaset)
    ' Sortierreihenfolge festlegen.
    rstBestellungen.Sort = "Bestimmungsland"
    ' Zweites Recordset-Objekt vom Typ Dynaset erstellen.
    Set rstSortiert = rstBestellungen.OpenRecordset()
    ' Operationen mit der Datensatzgruppe durchführen.
    .
    .
    .
    rstBestellungen.Close
    rstSortiert.Close
    Set dbs = Nothing
End Sub

Tipp Meist ist es effizienter, das zweite Recordset-Objekt mit den gewünschten Bedingungen in einem Schritt zu erstellen. Wenn Sie wissen, welche Daten Sie auswählen möchten, ist es grundsätzlich effizienter, eine Datensatzgruppe mit einer SQL-Anweisung zu erstellen. Das folgende Beispiel zeigt, wie Sie nur eine Datensatzgruppe erstellen und die gleichen Ergebnisse wie im vorhergehenden Beispiel erhalten.

Sub RecordsetMitSQLErstellen()
    Dim dbs As Database, rst As Recordset
    Dim strSelect As String

    Set dbs = CurrentDb
    strSelect = "SELECT * FROM Bestellungen ORDER BY Bestimmungsland;"
    Set rst = dbs.OpenRecordset(strSelect)
    rst.MoveLast
    MsgBox "Datensatzgruppe enthält " & rst.RecordCount & " Sätze."
    rst.Close
End Sub


OLE-Objekteigenschaften - Beispiel

Im folgenden Beispiel wird mit einem ungebundenen Objektfeld namens OLE1 ein verknüpftes OLE-Objekt erstellt und die Größe des Steuerelements so angepasst, dass der gesamte Inhalt des Objekts angezeigt wird, wenn der Benutzer auf eine Befehlsschaltfläche klickt.

Sub Befehl1_Click
    OLE1.Class = "Excel.Sheet"    ' Den Klassennamen angeben.
    ' Den Typ des Objekts angeben.
    OLE1.OLETypeAllowed = acOLELinked     ' Die Quelldatei angeben.
    OLE1.SourceDoc = "C:\Excel\Oletext.xls"     ' Die Daten angeben, zu denen
                                            ' eine Verknüpf. hergest. werden soll.
    OLE1.SourceItem = "R1C1:R5C5"     ' Das verknüpfte Objekt erstellen.
    OLE1.Action = acOLECreateLink     ' Die Größe des Steuerelements anpassen.
    OLE1.SizeMode = acOLESizeZoom
End Sub


SourceField-, SourceTable-Eigenschaften - Beispiel (MDB)

Das folgende Beispiel erstellt ein Recordset-Objekt unter Verwendung einer SQL-Anweisung, die Alias-Namen für Felder in zwei unterschiedlichen Tabellen in der Datenbank erstellt. Das Beispiel gibt dann den Namen des Feldes, die Originaltabelle und das Originalfeld aus.

Sub HerkunftInfo()
    Dim dbs As Database, rst As Recordset, fld As Field
    Dim strSQL As String

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' SQL-Anweisung zusammenstellen.
    strSQL = "SELECT [Artikel-Nr] As ArtikelCode, " _
        & "Kategoriename As Artikeltyp FROM Kategorien " _
        & "INNER JOIN Artikel ON Categories.[Kategorie-Nr] " _
        & " = Artikel.[Kategorie-Nr];"
    ' Recordset-Objekt vom Typ Dynaset öffnen.
    Set rst = dbs.OpenRecordset(strSQL)
    For Each fld In rst.Fields
        ' Feldname ausgeben.
        Debug.Print "Feldname: "; fld.Name
        ' Name der Originaltabelle ausgeben.
        Debug.Print "Originaltabelle: "; fld.SourceTable
        ' Namen des Originalfelds ausgeben.
        Debug.Print "Originalfeld: "; fld.SourceField
        Debug.Print
    Next fld
    rst.Close
    Set dbs = Nothing
End Sub


SourceObject-Eigenschaft (Herkunftsobjekt) - Beispiel

Das folgende Beispiel zeigt den Namen des Formulars, das die Herkunft des Unterformular-Steuerelements Artikelliste darstellt, im Testfenster an.

Debug.Print Formulare!Kategorien! _
    [Artikelliste].SourceObject


 Source-Eigenschaft

Source-Eigenschaft

Die Eigenschaft Source betrifft das Error-Objekt und kann in Visual Basic nur gelesen werden.

Anmerkung Verwechseln Sie diese Eigenschaft nicht mit der Microsoft Access-Eigenschaft Source, die eine Abfrage betrifft und die Verbindungszeichenfolge für die Datenherkunft sowie die Quelldatenbank für die Abfrage oder für die Eingabetabelle der Abfrage angibt.


Source-Eigenschaft (Herkunft) - Beispiel

Das folgende Beispiel stellt die Eigenschaft RowSource für das Listenfeld Erstkontakt auf ein Feld in einer dBASE IV-Tabelle ein.

Dim strSQLAbrufen AS String
strSQLAbrufen = "SELECT Kunde.FIRMENNAME, Kunde.TELEFON FROM Kunde IN 'c:\dbdata'[dBASE IV;];"
Me.Erstkontakt.RowSource = strSQLAbrufen

Im nächsten Beispiel ist die Datenherkunft für die Abfrage eine dBASE IV-Tabelle mit dem Namen Kunden im Ordner C:\DBDATA. Sie können diese SQL-Anweisung in der SQL-Ansicht eines Abfragefensters eingeben.

SELECT Kunde.FIRMENNAME, Kunde.TELEFON
FROM Kunde IN 'c:\dbdata'[dBASE IV;];


SQL-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel erstellt eine Parameterabfrage, die auf der Tabelle Bestellungen basiert. Die Abfrage wählt alle Bestellungen aus, deren Bestelldatum in den Bereich zweier vom Benutzer eingegebener Termine fällt.

Sub BestellungenImZeitraum()
    Dim dbs As Database, qdf As QueryDef, rst As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Neue Abfrage erstellen.
    Set qdf = dbs.CreateQueryDef("BestellungenImZeitraum")
    ' SQL-Anweisung einschließlich Parametern zusammenstellen.
    qdf.SQL = "PARAMETERS [Anfang] DATETIME, [Ende] DATETIME; " & _
        "SELECT * FROM Bestellungen WHERE [Bestelldatum] BETWEEN " _
        & "[Anfang] AND [Ende];"
    qdf.Parameters("Anfang") = #1/1/96#
    qdf.Parameters("Ende") = #1/31/96#
    ' Recordset-Objekt vom Typ Snapshot aus einem QueryDef-Objekt
    ' erstellen.
    Set rst = qdf.OpenRecordset(dbOpenSnapshot)
    ' Operationen mit der Datensatzgruppe durchführen.
    .
    .
    .
    rst.Close
    Set dbs = Nothing
End Sub


Starteigenschaften: Beispiel

Das folgende Beispiel zeigt eine Prozedur mit dem Namen EinstellenStarteigenschaften, die den Namen der einzustellenden Eigenschaft, ihren Datentyp und die gewünschte Einstellung übergibt. Die allgemein verwendbare Prozedur ÄndernEigenschaft versucht, die Starteigenschaft einzustellen. Wird die Eigenschaft nicht gefunden, verwendet die Prozedur die Methode CreateProperty, um sie der Auflistung Properties anzufügen. Dies ist notwendig, da diese Eigenschaften erst dann in der Auflistung Properties angezeigt werden, wenn sie mindestens einmal eingestellt oder geändert wurden.

SubEinstellenStarteigenschaften()
Const DB_Text As Long = 10
Const DB_Boolean As Long = 1
    ChangeProperty "StartupForm", DB_Text, "Kunden"
    ChangeProperty "StartupShowDBWindow", DB_Boolean, False
    ChangeProperty "StartupShowStatusBar", DB_Boolean, False
    ChangeProperty "AllowBuiltinToolbars", DB_Boolean, False
    ChangeProperty "AllowFullMenus", DB_Boolean, True
    ChangeProperty "AllowBreakIntoCode", DB_Boolean, False
    ChangeProperty "AllowSpecialKeys", DB_Boolean, True
    ChangeProperty "AllowBypassKey", DB_Boolean, True
End Sub

Function ÄndernEigenschaft(strEigName As String, varEigTyp As Variant, varEigWert As Variant) As Integer
    Dim dbs As Object, Eig As Variant
    Const conEigNichtgefundenFehler = 3270

    Set dbs = CurrentDb
    On Error GoTo Change_Err
    dbs.Properties(strEigName) = varEigWert
    ÄndernEigenschaft = True

Ändern_Ende:
    Exit Function

Ändern_Fehler:
    If Err = conEigNichtgefundenFehler Then    ' Eigenschaft nicht gefunden.
        Set Eig = dbs.CreateProperty(strEigName, _
            varEigTyp, varEigWert)
        dbs.Properties.Append Eig
        Resume Next
    Else
        ' Unbekannter Fehler.
        ÄndernEigenschaft=False
        Resume Ändern_Ende
    End If
End Function


 State-Eigenschaft

State-Eigenschaft

Mit der State-Eigenschaft können Sie ein Häkchen neben einem Menüelement oder einer Befehlsschaltfläche hinzufügen oder entfernen. Diese Eigenschaft ersetzt die durch die SetzenMenüelement-Aktion und die SetMenuItem-Methode in Microsoft Access 95 vorgegebene Funktionalität.


 Style-Eigenschaft

Style-Eigenschaft

In Microsoft Access 2000 können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden, um das Anzeigeformat für ein Schaltflächensteuerelement in einer Befehlsleiste festzulegen. Zeigen Sie zum Anzeigen des Dialogfelds Anpassen im Menü Symbolleisten auf Ansicht, und klicken Sie auf Anpassen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an. Klicken Sie anschließend mit der rechten Maustaste auf das Steuerelement, für das Sie die Style-Eigenschaft festlegen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen. Suchen Sie anschließend das gewünschte Kontextmenü-Steuerelement auf der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Wählen Sie im Feld Stil das gewünschte Format aus.

Die Einstellungen im Feld Format entsprechen den eingebauten Konstanten, die als Einstellung der Style-Eigenschaft verwendet werden, wie im Folgenden dargestellt.

Einstellung im Feld Stil | Konstante der Style-Eigenschaft
Standard | msoButtonAutomatic
Nur Text (Immer) | msoButtonCaption
Nur Text (in Menüs) | msoButtonIcon
Symbol und Text | msoButtonIconAndCaption
Keine Beschriftung | msoComboNormal
Beschriftung anzeigen | msoComboLabel


TabIndex-Eigenschaft (Reihenfolgenposition) - Beispiel

Das folgende Beispiel kehrt die Reihenfolge der Steuerelemente eines Formulars mit einer Befehlsschaltfläche und einem Textfeld um. Da Text1 zuerst erstellt wurde, hat es den Wert 0 als Einstellung der Eigenschaft TabIndex, und Befehl1 hat den Wert 1.

Sub Form_Click()
    Me!Befehl1.TabIndex = 0
    Me!Text1.TabIndex = 1
End Sub


 Tag-Eigenschaft (Befehlsleisten)

Tag-Eigenschaft (Befehlsleisten)

Wenn Sie in Microsoft Access 2000 die Tag-Eigenschaft für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen Tag-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen; suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie im Feld Tag die gewünschten Informationen ein.


Tag-Eigenschaft (Marke) - Beispiel

Das folgende Beispiel verwendet die Eigenschaft Tag zur Anzeige von benutzerdefinierten Meldungen über Steuerelemente eines Formulars. Hat ein Steuerelement den Fokus, so wird ein beschreibender Text in einem Bezeichnungsfeld-Steuerelement namens lblMeldung angezeigt. Sie geben den Text für die Meldung an, indem Sie die Eigenschaft Tag für jedes Steuerelement auf eine kurze Textzeichenfolge einstellen. Erhält ein Steuerelement den Fokus, wird dessen Eigenschaft Tag der Eigenschaft Caption des Bezeichnungsfeld-Steuerelements zugewiesen. Dieses Beispiel zeigt den beschreibenden Text eines Textfelds namens txtBeschreibung sowie einer Befehlsschaltfläche namens cmdBefehl an, die sich auf einem Formular befinden.

Sub Form_Load()
    Dim frmMeldungen As Form
    Set frmMeldungen = Formulare!Formular1
    frmMeldungen!lblMeldung.Caption = ""         ' Den Text löschen.
    frmMeldungen!txtBeschreibung.Tag = "Hilfetext für das Textfeld."
    frmMeldungen!cmdBefehl.Tag = "Hilfetext für die Befehlsschaltfläche."
End Sub

Sub txtBeschreibung_GotFocus()
    Me!lblMeldung.Caption = Me!txtBeschreibung.Tag     ' Die Einstellung der Eigenschaft Tag als Beschriftung.
End Sub

Sub txtBeschreibung_LostFocus()
    Me!lblMeldung.Caption = ""
End Sub

Sub cmdBefehl_GotFocus()
    Me!lblMeldung.Caption = Me!cmdBefehl.Tag         ' Die Einstellung der Eigenschaft Tag als Beschriftung.
End Sub

Sub cmdBefehl_LostFocus()
    Me.lblMeldung.Caption = " "
End Sub


Text-Eigenschaft - Beispiel

Das folgende Beispiel verwendet die Eigenschaft Text, um eine Schaltfläche BtnNächste (Name btnNächste) zu aktivieren, sobald der Benutzer in das Textfeld txtName Text eingibt. Solange das Textfeld leer ist, bleibt die Schaltfläche Nächste deaktiviert.

Sub txtName_Change()
    btnNächste.Enabled = Len(Me!txtName.Text & "")<>0
End Sub


TimerInterval-Eigenschaft (Zeitgeberintervall) - Beispiel

Das folgende Beispiel zeigt, wie Sie eine blinkende Schaltfläche auf einem Formular erstellen, indem Sie auf der Schaltfläche ein Symbol anzeigen und ausblenden. Die Load-Ereignisprozedur des Formulars stellt die Eigenschaft TimerInterval des Formulars auf 1000 ein, so dass die Anzeige des Symbols einmal pro Sekunde umgeschaltet wird.

Sub Form_Load()
    Me.TimerInterval = 1000
End Sub

Sub Form_Timer()
    Static intBildAnzeigen As Integer
    If intBildAnzeigen Then
        ' Das Symbol anzeigen.
        Me!btnBild.Picture = "C:\Icons\Flash.ico"
    Else
        ' Das Symbol nicht anzeigen.
        Me!btnBild.Picture = ""
    End If
    intBildAnzeigen = Not intBildAnzeigen
End Sub


 TooltipText-Eigenschaft

TooltipText-Eigenschaft

Wenn Sie in Microsoft Access 2000 das QuickInfo (InfoFeld) für ein Steuerelement auf einer Befehlsleiste einstellen möchten, können Sie das Dialogfeld Symbolleiste Steuerelementeigenschaften für Befehlsleisten-Steuerelemente verwenden. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Anpassen, um das Dialogfeld Anpassen zu öffnen. Für Menüleisten- und Symbolleisten-Steuerelemente zeigen Sie die Menüleiste oder Symbolleiste an, und klicken Sie dann mit der rechten Maustaste auf das Steuerelement, dessen TooltipText-Eigenschaft Sie einstellen möchten. Für Kontextmenü-Steuerelemente aktivieren Sie das Kontrollkästchen Kontextmenü in der Registerkarte Symbolleisten des Dialogfelds Anpassen, suchen Sie dann das gewünschte Kontextmenü-Steuerelement in der angezeigten Menüleiste, und klicken Sie mit der rechten Maustaste auf das Steuerelement. Klicken Sie auf den Befehl Eigenschaften. Geben Sie im Feld QuickInfo den gewünschten Text ein.


TopValues-Eigenschaft (Spitzenwerte) - Beispiel

Das folgende Beispiel weist eine SQL-Zeichenfolge, die die zehn teuersten Artikel zurückgibt, der Eigenschaft RecordSource für ein Formular zu, das die zehn teuersten Artikel anzeigt.

Dim strSQLAbrufen As String
strSQLAbrufen = "SELECT TOP 10 Artikel.[Artikelname] " _
    & "AS DieZehnTeuerstenArtikel, Artikel.Einzelpreis FROM Artikel " _
    & "ORDER BY Artikel.[Einzelpreis] DESC;"
Me.RecordSource = strSQLAbrufen


 Type-Eigenschaft

Type-Eigenschaft

In Microsoft Access können Sie den Datentyp für ein Feld in der Tabellenentwurfsansicht und den Datentyp für einen Parameter im Dialogfeld Abfrageparameter einstellen. Diese Vorgänge entsprechen dem Einstellen der ADO-Eigenschaft Type für ein Field-Objekt bzw. ein Parameter-Objekt in Visual Basic.

Die folgende Tabelle listet die Konstanten der ADO-Eigenschaft Type und die entsprechenden Microsoft Access-Einstellungen für Feld- und Parameterdatentypen auf, wenn Sie diese in der Tabellenentwurfsansicht bzw. im Dialogfeld Abfrageparameter einstellen.

Stellen Sie beim Erstellen eines Tabellenfeldes mit dem Datentyp Zahl die Feldgröße-Eigenschaft ein, um festzulegen, welchen der sechs numerischen Datentypen das Feld aufweisen soll. Standardmäßig ist diese Eigenschaft auf Long Integer eingestellt. Die anderen Einstellungen sind Byte, Integer, Single, Double und Replikations-ID.

Konstante | Tabellenfeldeinstellung | Abfrageparametereinstellung
adBoolean | Ja/Nein | Yes/No
adUnsignedTinyInt | Zahl (Feldgröße = Byte) | Byte
adCurrency | Währung | Currency
adDate | Datum/Uhrzeit | Date/Time
adDouble | Zahl (Feldgröße = Double) | Double
adGUID | Zahl oder AutoWert (Feldgröße = Replikations-ID) | Nicht unterstützt
adSmallInt | Zahl (Feldgröße = Integer) | Integer
adInteger | Zahl (Feldgröße = Long Integer) | Long Integer
adInteger | AutoWert (Feldgröße = Long Integer) | Nicht unterstützt
adLongVarBinary | OLE-Objekt | OLE Object
 | Nicht unterstützt | Binary
adLongVarWChar | Memo | Memo
adSingle | Zahl (Feldgröße = Single) | Single
adVarWChar | Text | Text
adDecimal | Zahl (Feldgröße = Decimal) | Nicht unterstützt
adBinary | Nicht unterstützt | Binary
Nicht unterstützt | Nicht unterstützt | Value

Anmerkung In Access-Datenbanken (.MDB) entspricht der Parameterdatentyp Value keinem der durch die Microsoft Jet-Datenbank-Engine definierten Datentypen. Er entspricht jedoch dem für SQL reservierten Schlüsselwort VALUE, das zum Erstellen einer Parameterabfrage verwendet werden kann. In Microsoft Access- oder SQL-Abfragen kann VALUE als zulässiges Synonym für den Visual Basic-Datentyp Variant angesehen werden.


 Type-Eigenschaft (MDB)

Type-Eigenschaft (MDB)

In Microsoft Access können Sie den Datentyp für ein Feld in der Tabellenentwurfsansicht und für einen Parameter im Dialogfeld Abfrageparameter festlegen. Diese Aktionen sind gleichbedeutend mit dem Einstellen der DAO-Eigenschaft Type eines Field-Objekts oder eines Parameter-Objekts aus Visual Basic heraus.

Die folgende Tabelle enthält eine Liste der Konstanten der Type-Eigenschaft und die entsprechenden Einstellungen der Feld- und Parameterdatentypen in Microsoft Access, wenn Sie diese in der Tabellenentwurfsansicht oder im Dialogfeld Abfrageparameter einstellen.

Stellen Sie die Eigenschaft Feldgröße ein, wenn Sie ein Tabellenfeld vom Datentyp Zahl erstellen, um anzugeben, welchen der sechs möglichen numerischen Datentypen das Feld annehmen soll. Diese Eigenschaft wird standardmäßig auf Long Integer gesetzt. Andere Einstellungen sind Byte, Integer, Single, Double und ReplicationID.

Konstante | Einstellungen für Tabellenfelder | Einstellung für Abfrageparameter
dbBoolean | Ja/Nein | Ja/Nein
dbByte | Zahl (Feldgröße = Byte) | Byte
dbCurrency | Währung | Währung
dbDate | Datum/Uhrzeit | Datum/Uhrzeit
dbDouble | Zahl (Feldgröße = Double) | Double
dbGUID | Zahl oder AutoWert (Feldgröße = ReplicationID) | Nicht unterstützt
dbInteger | Zahl (Feldgröße = Integer) | Integer
dbLong | Zahl (Feldgröße = Long Integer) | Long Integer
 | AutoWert (Feldgröße = Long Integer) | Nicht unterstützt
dbLongBinary | OLE-Objekt | OLE-Objekt
 | Nicht unterstützt | Binär
dbMemo | Memo | Memo
dbSingle | Zahl (Feldgröße = Single) | Single
dbText | Text | Text
Nicht unterstützt | Nicht unterstützt | Wert

Anmerkung: Der Parameterdatentyp Wert hat keine Entsprechung bei den durch die Microsoft Jet-Datenbank-Engine definierten Datentypen. Er entspricht dem reservierten SQL-Wort VALUE, das verwendet werden kann, um eine Parameterabfrage zu erstellen. In Microsoft Access oder SQL-Abfragen ist VALUE ein gültiges Synonym für den Visual Basic-Datentyp Variant.


Type-Eigenschaft - Beispiel

Im folgenden Beispiel wird ermittelt, ob ein Module-Objekt einem Standardmodul oder einem Klassenmodul entspricht:

Function ModultypErmitteln(strModulname As String) As Integer
    Dim mdl As Module

    ' Das Modul öffnen, damit es zur Modules-Auflistung
    ' hinzugefügt wird.
    DoCmd.OpenModule strModulname
    ' Den Verweis auf das Module-Objekt zurückgeben.
    Set mdl = Modules(strModulname)
    ' Die Eigenschaft Type auswerten.
    If mdl.Type = acClassModule Then
        ' Den Kommentar einfügen.
        mdl.InsertLines 1, "' Klassenmodul."
        ModultypErmitteln = acClassModule
    Else
        ' Den Kommentar einfügen.
        mdl.InsertLines 1, "' Standardmodul."
        ModultypErmitteln = acStandardModule
    End If
End Function


UniqueRecords-Eigenschaft (EindeutigeDatensätze) - Beispiel

Die Abfrage in diesem Beispiel gibt eine Liste der Kunden aus der Tabelle Kunden zurück, die über mindestens eine Bestellung in der Tabelle Bestellungen verfügen.

Tabelle Kunden

Kundenname | Kunden-Code
Ernst Handel | ERNSH
Familia Arquibaldo | FAMIA
FISSA Fabrica Inter. Salchichas S.A. | FISSA
Folies gourmandes | FOLIG

Tabelle Bestellungen

Kunden-Code | Bestellung-Nr
ERNSH | 10698
FAMIA | 10512
FAMIA | 10725
FOLIG | 10763
FOLIG | 10408

Die folgende SQL-Anweisung gibt die Kundennamen in der anschließenden Tabelle zurück:

SELECT DISTINCTROW Kunden.Firma, Kunden.[Kunden-code]
FROM Kunden INNER JOIN Bestellungen
ON Kunden.[Kunden-Code] = Bestellungen.[Kunden-Code];
Zurückgegebene Kunden | Kunden-Code
Ernst Handel | ERNSH
Familia Arquibaldo | FAMIA
Folies gourmandes | FOLIG


UniqueValues-Eigenschaft (KeineDuplikate) - Beispiel

Die SELECT-Anweisung in diesem Beispiel gibt eine Liste der Länder zurück, in denen sich Kunden befinden. Da sich in jedem Land viele Kunden befinden können, können auch viele Datensätze in der Tabelle Kunden denselben Eintrag für das Land haben. Dennoch wird jedes Land nur einmal in den Abfrageergebnissen aufgeführt.

Dieses Beispiel verwendet die Tabelle Kunden, welche die folgenden Daten enthält.

Land | Firma
Brasilien | Familia Arquibaldo
Brasilien | Gourmet Lanchonetes
Brasilien | Hanari Carnes
Frankreich | Du monde entier
Frankreich | Folies gourmandes
Deutschland | Frankenversand
Irland | Hungry Owl All-Night Grocers

Die folgende SQL-Anweisung gibt die Länder in der nachfolgenden Tabelle zurück:

SELECT DISTINCT Kunden.Land
FROM Kunden;
Zurückgegebene Länder
Brasilien
Frankreich
Deutschland
Irland


Updatable-Eigenschaft - Beispiel (MDB)

Das folgende Beispiel fügt einen Datensatz einem Recordset-Objekt einen Datensatz hinzu, falls die Eigenschaft Updatable des Objekts auf True (-1) eingestellt ist.

Sub DatenAktualisieren()
    Dim dbs As Database, rstUnbekannt As Recordset

    ' Bezug auf aktuelle Datenbank zurückgeben.
    Set dbs = CurrentDb
    ' Recordset-Objekt vom Typ Tabelle öffnen.
    Set rstUnbekannt = dbs.OpenRecordset("Unbekannte Tabelle")
    ' Eigenschaft "Updatable" vor Hinzufügen eines neuen Datensatzes überprüfen.
    If rstUnbekannt.Updatable = True Then
        With rstUnbekannt
            .AddNew
            !Feld1 = "Neue Daten"
            .Update
        End With
    End If
    rstUnknown.Close
    Set dbs = Nothing
End Sub


UseLongFileNames-Eigenschaft: Beispiel

Dieses Beispiel macht die Verwendung langer Dateinamen als globalen Standard für die Anwendung rückgängig.

Application.DefaultWebOptions.UseLongFileNames = False


 ValidationRule-Eigenschaft (MDB)

ValidationRule-Eigenschaft (MDB)

Verwenden Sie die Datenzugriffseigenschaft ValidationRule, um Gültigkeitsregeln für ein Objekt Field, Recordset oder TableDef unter Verwendung von Visual Basic einzustellen.

Sie können Gültigkeitsregeln für ein Feld oder Steuerelement auch in der Benutzeroberfläche von Microsoft Access einstellen. Stellen Sie die Microsoft Access-Eigenschaft ValidationRule eines Feldes oder einer Tabelle in der Tabellenentwurfsansicht ein. Stellen Sie die Eigenschaft ValidationRule eines Steuerelements im Eigenschaftenfenster in der Formularentwurfsansicht ein.

In Microsoft Access darf der Zeichenfolgenausdruck, der von der Eigenschaft ValidationRule eines Field-Objekts angegeben wird, nicht auf benutzerdefinierte Funktionen, Aggregatfunktionen für Domänen, SQL-Aggregatfunktionen, die Funktion CurrentUser, die Funktion Eval oder Abfragen verweisen.


ValidationRule-, ValidationText-Eigenschaften (Gültigkeitsregel, Gültigkeitsmeldung) - Beispiel

Das folgende Beispiel erstellt eine Gültigkeitsregel für ein Feld, das nur die Eingabe von Werten größer als 65 zulässt. Wird eine kleinere Zahl als 65 eingegeben, so wird eine Meldung angezeigt. Die Eigenschaften werden mit der Funktion SetFieldValidation eingestellt.

Dim strTblName As String, strFldName As String
Dim strGültRegel As String
Dim strGültText As String, intX As Integer

strTblName = "Kunden"
strFldName = "Alter"
strGültRegel = ">= 65"
strGültText = "Geben Sie eine Zahl größer oder gleich 65 ein."
intX = SetFieldValidation(strTblName, strFldName, _
    strGültRegel, strGültText)

Function EinstellenFeldPrüfung(strTblName As String, _
    strFldName As String, strGültRegel As String, _
    strGültText As String) As Integer

    Dim dbs As Database, tdf As TableDef, fld As Field

    Set dbs = CurrentDb
    Set tdf = dbs.TableDefs(strTblName)
    Set fld = tdf.Fields(strFldName)
    fld.ValidationRule = strGültRegel
    fld.ValidationText = strGültText
End Function

Das nächste Beispiel verwendet die Funktion SetTableValidation zum Einstellen einer Gültigkeitsüberprüfung auf Datensatzebene. Die Regel stellt sicher, dass das Datum im Feld EndDat jünger als das Datum im Feld StartDat ist.

Dim strTblName As String, strGültRegel As String
Dim strGültText As String
Dim intX As Integer

strTblName = "Personal"
strGültRegel = "EndDat > StartDat"
strGültText = "Geben Sie einen Wert für EndDat ein, der nach StartDat liegt."
intX = EinstellenTabellenPrüfung (strTblName, strGültRegel, strGültText)

Function EinstellenTabellenPrüfung (strTblName As String, _
    strGültRegel As String, strGültText As String) _
    As Integer

    Dim dbs As Database, tdf As TableDef

    Set dbs = CurrentDb
    Set tdf = dbs.TableDefs(strTblName)
    tdf.ValidationRule = strGültRegel
    tdf.ValidationText = strGültText
End Function


Value-Eigenschaft (Wert) - Beispiel

Dieses Beispiel zeigt, wie Sie abhängig davon, ob das Kontrollkästchen Kredit im Formular Kunden aktiviert oder deaktiviert ist, eine von zwei Prozeduren aufrufen können.

Sub Zahlungsart()
    If Formulare!Kunden!Kredit.Value = False Then
        BarzahlungBearbeiten
    ElseIf Formulare!Kunden!Kredit.Value = True Then
        KreditzahlungBearbeiten
    End If
End Sub


VBE-Eigenschaft - Beispiel

In diesem Beispiel wird die Anzahl der Verweise angezeigt, die für das aktive Projekt verfügbar sind.

MsgBox "Anzahl der Verweise = " & VBE.ActiveVBProject _
    .References.Count


 Version-Eigenschaft (MDB)

Version-Eigenschaft (MDB)

Die Version-Eigenschaft eines Database-Objekts gibt die Version der Microsoft Jet-Datenbank-Engine zurück, die auf diese Datenbank zutrifft. Für Datenbanken, die in Microsoft Access 2000 erstellt oder in das Format dieser Version konvertiert wurden, gibt Version "4.0" zurück. Für Access 97- und Access 95-Datenbanken gibt Version "3.0" zurück. Wenn Sie zwischen den Datenbanken im Format von Microsoft Access 2000 und denjenigen im Format von Access 97 unterscheiden möchten, können Sie mit Hilfe der SysCmd-Funktion und der eingebauten Konstante acSysCmdAccessVer als Argument Aktion bestimmen, in welcher Version von Microsoft Access die Datenbank erstellt wurde. Bei einer Microsoft Access 2000-Datenbank gibt die SysCmd-Funktion den Wert "9.0" und bei einer Access 97-Datenbank "8.0" zurück.


 Über den Standardarbeitsordner

Über den Standardarbeitsordner

Wenn Sie die Dialogfelder Öffnen und Neu in Microsoft Access zum ersten Mal öffnen, ist der Ordner Eigene Dateien der Standardarbeitsordner (oder der aktive Ordner). Wenn Sie die Office Shortcut-Leiste installieren, ist der Ordner Eigene Dateien auch der Standardordner, der über die Schaltfläche Office-Dokument öffnen [image] in der Office Shortcut-Leiste und über den Befehl Office-Dokument öffnen im Windows Startmenü geöffnet wird.

Der Ordner Eigene Dateien befindet sich im Stammverzeichnis. Das Verzeichnis Persönlich ist ein Unterverzeichnis des Verzeichnisses von Windows NT Workstation. Diese Ordner bieten sich zum Speichern von Dokumenten, Arbeitsmappen, Präsentationen, Datenbanken und anderen Dateien, mit denen Sie arbeiten, an.

Zurück zu Standardarbeitsordner festlegen


 Auswirkungen durch das Ändern des Datentyps eines Feldes

Auswirkungen durch das Ändern des Datentyps eines Feldes

Es kann vorkommen, dass Sie Datentypen von Feldern, die bereits Daten enthalten, ändern müssen. Vielleicht haben Sie Daten importiert, und Microsoft Access hat nicht die gewünschten Datentypen festgelegt, oder der für ein Feld festgelegte Datentyp trifft nicht mehr zu.

Bevor Sie einen Datentyp konvertieren, berücksichtigen Sie die Auswirkungen, die diese Änderung auf Ihre gesamte Datenbank haben kann. Welche Abfragen, Formulare und Berichte verwenden das Feld, das konvertiert werden soll? Sie müssen möglicherweise Ausdrücke ändern, die vom geänderten Feld abhängig sind.

Die häufigsten Datentypänderungen lassen sich in die folgenden vier Kategorien unterteilen: Konvertieren von anderen Datentypen in den Datentyp Text, Konvertieren des Datentyps Text in den Datentyp Zahl, Währung, Datum/Uhrzeit oder Ja/Nein, Konvertieren zwischen den Datentypen Währung und Zahl oder zwischen Text und Memo sowie Ändern der Eigenschaft Feldgröße für Felder des Datentyps Zahl.

Dieses Thema enthält Referenzinformationen über:

Konvertieren von anderen Datentypen in den Datentyp "Text"

Konvertieren des Datentyps "Text" in den Datentyp "Zahl", "Währung", "Datum/Uhrzeit" oder "Ja/Nein"

Konvertieren zwischen den Datentypen "Währung" und "Zahl" oder zwischen "Text" und "Memo"

Ändern der Feldgröße-Eigenschaft für Felder des Typs Zahl

Konvertieren aus anderen Datentypen zu Text

Zwar müssen Zahlen, die für Berechnungen verwendet werden, in Feldern des Datentyps Zahl oder Währung gespeichert sein, doch kann ein ursprünglich nur aus Zahlen bestehendes Feld die Verwendung von Buchstaben oder anderen nichtnumerischen Zeichen erfordern. Sie haben z.B. ein Feld des Datentyps Zahl, in dem Codenummern gespeichert sind. Wenn Sie später Buchstaben, Bindestriche, Klammern oder andere nichtnumerische Zeichen als Teil des Codes einfügen möchten, ändern Sie den Felddatentyp in Text.

Microsoft Access konvertiert Zahlenwerte unter Verwendung des Formats Allgemeine Zahl und Datumswerte unter Verwendung des Formats Standarddatum in Text. Die konvertierten Werte enthalten keine Währungssymbole oder andere speziell formatierte Zeichen, die Sie für das Feld festgelegt haben.

Zurück zum Anfang

Konvertieren von Text zu Zahl, Währung, Datum/Uhrzeit oder Ja/Nein

Wenn in einem Feld des Datentyps Text Daten gespeichert sind und Sie das Feld in einen anderen Datentyp ändern möchten, konvertiert Microsoft Access Werte, die für den neuen Datentyp geeignet sind. Wenn Sie beispielsweise in einem Feld des Datentyps Text Zahlen gespeichert haben und mathematische Berechnungen mit Ihren Daten durchführen möchten, konvertieren Sie das Feld in den Datentyp Zahl oder Währung. Wenn alle im Feld gespeicherten Daten nur aus Zahlen bestehen, können Sie den Datentyp ändern, ohne dass Daten verloren gehen.

Beim Konvertieren des Datentyps Text in den Datentyp Zahl werden Dezimalkommas und 1.000er-Trennzeichen entsprechend interpretiert. Währungssymbole werden entsprechend den Ländereinstellungen in der Windows-Systemsteuerung interpretiert.

Beim Konvertieren des Datentyps Text in den Datentyp Datum/Uhrzeit werden die meisten Datums- und Zeitformate korrekt konvertiert und entsprechend den Ländereinstellungen in der Windows-Systemsteuerung interpretiert.

Beim Konvertieren des Datentyps Text in den Datentyp Ja/Nein werden die Wörter Ja, Wahr oder Ein in den Wert Ja konvertiert und die Wörter Nein, Falsch oder Aus in den Wert Nein. Um Ja oder Nein anzuzeigen, klicken Sie in der Tabellenentwurfsansicht auf die Registerkarte Nachschlagen, und stellen Sie die Eigenschaft SteuerelementAnzeigen auf Textfeld ein. (Sie können auch vom Datentyp Zahl in den Datentyp Ja/Nein konvertieren. Hierbei werden Nullwerte ("0" oder Null) in den Wert Nein und Nicht-Nullwerte in den Wert Ja konvertiert.)

Zurück zum Anfang

Konvertieren zwischen Währung und Zahl oder Text und Memo

Sie können jederzeit zwischen den Datentypen Währung und Zahl konvertieren. Speichern Sie Geldwerte immer unter Verwendung des Datentyps Währung, um sicherzustellen, dass Berechnungen korrekt ausgeführt werden. Dieser Datentyp sollte auch verwendet werden, wenn Sie zu einem Feld, das Zahlen mit bis zu vier Dezimalstellen enthält, viele Berechnungen ausführen möchten. Die Felder des Datentyps Währung verwenden ein Berechnungsverfahren mit Festkommarechnung, um Auf- und Abrundungsfehler zu vermeiden. Sie können auch jederzeit zwischen den Datentypen Text und Memo konvertieren. Wenn Sie beispielsweise längere Textwerte als ursprünglich beabsichtigt speichern möchten, können Sie ein Feld in den Datentyp Memo konvertieren. Wenn in einem Feld jedoch nicht mehr als 255 Zeichen gespeichert werden sollen, verwenden Sie den Datentyp Text.

Zurück zum Anfang

Ändern der Eigenschaft "Feldgröße" für Felder des Datentyps "Zahl"

Bei Feldern des Datentyps Zahl legt die Einstellung der Eigenschaft Feldgröße den zu verwendenden Zahlentyp fest: Byte, Integer, Long Integer, Single, Double, Dezimal oder Replikations-ID (GUID). Achten Sie beim Konvertieren eines Feldes in den Datentyp Zahl darauf, ob die Einstellung der Eigenschaft Feldgröße für die in dem Feld gespeicherten Werte geändert werden muss. Wenn Sie die Einstellung von einer großen Feldgröße in eine kleinere ändern, z.B. von Double in Integer, stellen Sie sicher, dass die neue Feldgröße die alten Werte aufnehmen kann. Wenn Sie für die Eigenschaft Feldgröße eine Einstellung wählen, die die in den aktuellen Werten enthaltene Anzahl an Dezimalstellen nicht zulässt, werden die Zahlen auf- bzw. abgerundet. So werden z.B. beim Ändern eines Feldes von Double in Long Integer Dezimalwerte auf die nächste ganze Zahl auf- bzw. abgerundet. Sind die Werte für die neue Feldgröße zu lang, werden sie gelöscht und durch Nullwerte ersetzt.

Zum Anzeigen einer Zusammenfassung der Ergebnisse von Datentypkonvertierungen klicken Sie auf [image] .

Zum Anzeigen von Informationen zu dem in den einzelnen Feldgrößen speicherbaren Wertebereich klicken Sie auf [image] .

Zurück zum Anfang


Festlegen der Anzeigeformate für länderspezifische Daten

Microsoft Access unterstützt eine Vielzahl internationaler Formate. Um anwendungsübergreifende Konsistenz zu gewährleisten, verwendet Microsoft Access für die in der nachstehenden Tabelle aufgeführten Zahlen- und Datum-/Zeitformate die in der Windows-Systemsteuerung festgelegten Ländereinstellungen.

Microsoft Access-Format | Registerkarte unter "Ländereinstellungen"
Standard (und andere Zahlenformate außer Währung) | Zahlen
Währung | Währung
Datum, kurz | Datum
Datum, lang | Datum
Zeit | Uhrzeit

Wenn Ihre Daten nicht in dem für Ihr Land gültigen Format erscheinen, ändern Sie die Einstellungen, die in der Systemsteuerung unter Ländereinstellungen festgelegt sind.

Anmerkung Das Austauschen von Daten zwischen Computern mit unterschiedlichen Ländereinstellungen kann zu Fehlern bei Daten vom Typ Währung führen. Wenn Sie das Format Währung verwenden, wird z. B. der Wert 5,47 kr auf einem für Dänemark eingestellten Computer auf einem für die USA eingestellten Computer in den Wert $5.47 konvertiert. Um derartige Fehler zu vermeiden, müssen Sie für Währungswerte ein benutzerdefiniertes Format, wie z. B. #,## kr, erstellen. Das benutzerdefinierte Format hat Vorrang vor den in der Windows-Systemsteuerung festgelegten Einstellungen. Ähnliche Probleme treten auf, wenn Sie Standardzahlen oder Standarddatum- bzw. -zeitangaben zwischen Computern mit unterschiedlichen Ländereinstellungen austauschen.


 Allgemeine Spezifikationen für Microsoft Access-Datenbanken

Allgemeine Spezifikationen für Microsoft Access-Datenbanken

Attribut | Maximalwert
Microsoft Access-Datenbank (.mdb)-Dateigröße | 2 Gigabyte. Da Ihre Datenbank aber verknüpfte Tabellen in anderen Dateien enthalten kann, ist die Gesamtgröße lediglich durch die verfügbare Speicherkapazität beschränkt.
Anzahl der Objekte in einer Datenbank | 32.768
Module (einschließlich Formular und Berichte, wenn die HasModule-Eigenschaft auf True gesetzt ist) | 1.000
Anzahl der Zeichen in einem Objektnamen | 64
Anzahl der Zeichen in einem Kennwort | 14
Anzahl der Zeichen in einem Benutzer- oder Gruppennamen | 20
Anzahl gleichzeitiger Benutzer | 255


Ergebnisse der Konvertierung von Felddatentypen

Die folgende Liste nennt die Ergebnisse und die Punkte, die bei üblichen Datentypkonvertierungen zu beachten sind, wenn die Tabelle Daten enthält.

Von | In | Ergebnis | Zu beachten
Allen Datentypen | AutoWert | Durch Microsoft Access nicht zugelassen | Nichts.
Text | Zahl, Währung, Datum/Uhrzeit, Ja/Nein | Konvertiert Text in entsprechende Werte | Stellen Sie sicher, dass die Werte dem neuen Datentyp entsprechen. Nichtzutreffende Werte werden gelöscht.
Memo | Text | Einfache Konvertierung | Daten, die die Einstellung der Eigenschaft Feldgröße überschreiten, werden abgeschnitten.
Zahl | Text | Konvertiert Werte in Text | Zahlen werden im Format Allgemeine Zahl angezeigt.
Zahl | Währung | Konvertiert Zahlen in Währungswerte | Stellen Sie sicher, dass die Werte dem neuen Datentyp entsprechen. Nichtzutreffende Werte werden gelöscht.
Datum/Uhrzeit | Text | Konvertiert Werte in Text | Datum oder Uhrzeit werden im Format Standarddatum angezeigt.
Währung | Text | Konvertiert Werte in Text | Text enthält keine Währungssymbole, wie z. B. DM.
Währung | Zahl | Einfache Konvertierung | Stellen Sie sicher, dass die Werte dem neuen Datentyp entsprechen. Nichtzutreffende Werte werden gelöscht.
AutoWert | Text | Konvertiert Werte in Text | Werte können je nach Einstellung der Eigenschaft Feldgröße abgeschnitten werden.
AutoWert | Zahl | Einfache Konvertierung | Werte können je nach Einstellung der Eigenschaft Feldgröße abgeschnitten werden.
Ja/Nein | Text | Konvertiert Werte in Text | Nichts.


 Konvertieren einer in früheren Versionen erstellten Access-Datenbank in Access 2000

Konvertieren einer in früheren Versionen erstellten Access-Datenbank in Access 2000

Zu folgenden Themen stehen Informationen zur Verfügung:

Zeitpunkt zum Konvertieren einer Access-Datenbank

Freigeben einer Access-Datenbank für Benutzer mit verschiedenen Versionen von Microsoft Access

Erstellen und Bearbeiten von Objekten

Ändern von Datenbankberechtigungen

Neue Symbol- und Menüleisten

Codekompatibilität

Verwenden von AusführenBefehl an Stelle von AusführenMenübefehl

Zeitpunkt zum Konvertieren einer Access-Datenbank

In der Regel werden Sie eine in früheren Versionen erstellte Microsoft Access-Datenbank in Microsoft Access 2000 konvertieren. Sie können eine in einer früheren Version erstellte Datenbank in Microsoft Access 2000 aktivieren, ohne sie zu konvertieren. Sie können jedoch den Entwurf von Objekten nicht ändern oder die Vorteile der meisten neuen Features von Microsoft Access 2000 nicht nutzen, bevor Sie die in der früheren Version erstellte Datenbank nicht konvertiert haben. Nach dem Konvertieren einer Access-Datenbank in Microsoft Access 2000 kann diese in früheren Versionen nicht mehr geöffnet werden. Sie können eine Access 2000-Datenbank nicht in eine Access 2.0- oder Access 95-Datenbank, aber in eine Access 97-Datenbank zurückkonvertieren. Um weitere Informationen zum Aktivieren einer Datenbank anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Freigeben einer Access-Datenbank für Benutzer mit verschiedenen Versionen von Microsoft Access

Wenn es sich bei der Access-Datenbank um eine Mehrbenutzerdatenbank handelt und nicht alle Benutzer gleichzeitig auf Microsoft Access 2000 umstellen können, haben Sie die Möglichkeit, Teile der Datenbank umstellen, um neue Features zu unterstützen, während die ursprüngliche Access-Datenbank unverändert bleibt. Um Informationen zur gemeinsamen Nutzung einer Datenbank in verschiedenen Versionen von Microsoft Access anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Erstellen und Bearbeiten von Objekten

Wenn Sie Microsoft Access 2000 verwenden, um eine in einer früheren Version erstellte Access-Datenbank zu aktivieren, können Sie Objekte in der Datenbank zum Anzeigen und Ändern von Daten verwenden. Sie können jedoch keine Änderungen an Datenbankobjekten speichern. Um den Entwurf eines Objekts zu ändern oder ein neues Objekt in der Access-Datenbank zu erstellen, müssen Sie die Datenbank entweder in der früheren Version öffnen oder sie in Microsoft Access 2000 konvertieren.

Zurück zum Anfang

Ändern von Datenbankberechtigungen

Wenn Sie in einer Access-Datenbank einer früheren Version Berechtigungen ändern oder hinzufügen möchten, müssen Sie diese in der früheren Version öffnen oder in Microsoft Access 2000 konvertieren. Um die Vorteile sämtlicher Sicherheitsfeatures von Microsoft Access 2000 nutzen zu können und gleichzeitig die Sicherheitsmerkmale der ursprünglichen Datenbank vollständig zu erhalten, müssen Sie die Benutzer- und Gruppenkonten sowie die Kennwörter in einer Microsoft Access 2000-Arbeitsgruppen-Informationsdatei neu erstellen. Siehe auch Konvertieren einer gesicherten Access-Datenbank.

Es ist nicht länger möglich, die Module durch Sicherheitsmaßnahmen auf Benutzerebene zu schützen; Sie können die Module jedoch durch Sichern des VBA-Codes (Visual Basic für Applikationen) mit einem Kennwort schützen.

Zurück zum Anfang

Neue Symbol- und Menüleisten

Microsoft Access 97 oder höher unterstützt eine neues Format von Symbol- und Menüleisten. Wenn Sie eine Microsoft Access 2.0 oder 95-Datenbank in Microsoft Access 2000 konvertieren, werden sowohl alle benutzerdefinierten als auch alle integrierten Symbolleisten automatisch in Symbolleisten des neuen Formats konvertiert. Benutzerdefinierte Menüleisten, die mit dem Microsoft Access 95-Menü-Editor oder auf der Basis von Makros erstellt wurden, werden beim Öffnen einer konvertierten Access-Datenbank als Menüleisten des neuen Formats interpretiert. Sie werden jedoch nicht automatisch konvertiert und können daher nicht unter Verwendung des Dialogfeldes Anpassen bearbeitet werden. Sie können zum Erstellen von Menüleisten im neuen Format, die auf Makros mit HinzufügenMenü-Aktionen basieren, die Unterbefehle Menü aus Makro erstellen und Kontextmenü aus Makro erstellen des Befehls Makro (Menü Extras) verwenden. Anschließend können Sie diese Menüleisten unter Verwendung des Dialogfeldes Anpassen bearbeiten. Siehe auch Konvertieren von Symbol- und Menüleisten.

Zurück zum Anfang

Codekompatibilität

Microsoft Access 2000 unterstützt die DAO 2.5/3.x-Kompatibilitätsbibliothek nicht. Wenn Sie versuchen, eine Access-Datenbank zu konvertieren, in der der Code frühere Versionen von DAO-Objekten, -Methoden und -Eigenschaften enthält, die auf der DAO 2.5/3.x-Kompatibilitätsbibliothek basieren, wird die Meldung angezeigt, dass bei der Konvertierung der Datenbank Kompilierfehler aufgetreten sind. Bevor Sie eine Access-Datenbank konvertieren, aktualisieren Sie den Code, so dass dieser nicht auf der DAO 2.5/3.x-Kompatibilitätsbibliothek basiert. Erhalten Sie dennoch eine Meldung, dass bei der Konvertierung Kompilierfehler aufgetreten sind, öffnen Sie die konvertierte Datenbank in Microsoft Access 2000, entfernen Sie den Verweis auf die fehlende DAO 2.5/3.x-Kompatibilitätsbibliothek, und fügen Sie einen Verweis auf die Microsoft DAO 3.6-Objektbibliothek ein.

Verwendet die Access-Datenbank Add-Ins oder Bibliotheksdatenbanken, die in einer früheren Version von Microsoft Access erstellt wurden, müssen Sie diese ebenfalls konvertieren. Um Informationen zu Änderungen an Methoden, Aktionen, Eigenschaften, Syntax und anderen Sprachelementen sowie zu Codekompatibilitäts- und Konvertierungsfragen anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang

Verwenden von AusführenBefehl an Stelle von AusführenMenübefehl

Die Aktion AusführenMenübefehl wurde in Microsoft Access 2000 durch die Aktion AusführenBefehl ersetzt. Um die Rückwärtskompatibilität zu gewährleisten, wird die Aktion AusführenMenübefehl weiterhin unterstützt. Wenn Sie eine Datenbank konvertieren, wird die Aktion AusführenMenübefehl automatisch in die Aktion AusführenBefehl konvertiert.

Um weitere Informationen zur Kompatibilität von VBA (Visual Basic für Applikationen) in Microsoft Access 95 und 97 sowie Microsoft Access 2000 anzuzeigen, klicken Sie auf [image] .

Zurück zum Anfang


Beispiel einer Reflexivverknüpfung

Um im Feld Vorgesetzte(r) an Stelle der Kennung der/des jeweiligen Vorgesetzen den Namen anzuzeigen, gehen Sie folgendermaßen vor:

  1. Fügen Sie der Abfrage im Entwurfsansicht die Tabelle Personal zweimal hinzu. Informationen über Umbenennen der zweiten Tabelle in der Abfrage anzeigen.

  2. Erstellen Sie die Verknüpfung, indem Sie das Feld Vorgesetzte(r) in der Feldliste der ersten Tabelle auf das Feld Personal-Nr in der Feldliste der zweiten Tabelle ziehen.

  3. Fügen Sie dem Entwurfsbereich die Felder Nachname, Vorname und Position aus der Feldliste der ersten Tabelle hinzu.

  4. Fügen Sie das Feld Nachname aus der Feldliste der zweiten Tabelle in den Entwurfsbereich ein. Um den Namen des Feldes von Nachname in Vorgesetze(r) zu ändern, stellen Sie die Eigenschaft Beschriftung im Eigenschaftenfenster dieses Feldes entsprechend ein. Um Informationen zum Ändern der Eigenschaft Beschriftung eines Feldes anzuzeigen, klicken Sie auf [image] .


Eingabeformate - Beispiele

Ein Eingabeformat wird in Feldern (in Tabellen und Abfragen) und in Text- und Kombinationsfeldern (in Formularen) verwendet. Es dient zum Formatieren von Daten und Steuern der Werte, die eingegeben werden dürfen. Ein Eingabeformat besteht aus Literalzeichen (wie z. B. Leerzeichen, Punkten, Strichen und Klammern), die auszufüllende Leerstellen voneinander trennen. Die Einstellung für die Eigenschaft Eingabeformat besteht aus Literalzeichen und Sonderzeichen, die die Art des Wertes bestimmen, der an einer bestimmten Position eingegeben werden darf. Eingabeformate werden in erster Linie für Felder vom Datentyp Text und Datum/Uhrzeit verwendet. Sie können sie jedoch auch für Felder vom Datentyp Zahl und Währung verwenden.

Dieses Thema enthält Referenzinformationen über:

Beispiele für Eingabeformate

Definieren von Eingabeformaten

Gültige Zeichen für Eingabeformate

Beispiele für Eingabeformate

Die nachstehende Tabelle zeigt einige nützliche Definitionen für Eingabeformate und Beispiele für Werte, die Sie in diese Formate eingeben können. Details zu den Symbolen, die zum Erstellen von Eingabeformaten verwendet werden, finden Sie in der Tabelle am Ende des vorliegenden Themas.

Eingabeformatdefinition | Beispiele für Werte
(00000) 000-0000 | (02206) 555-0248
(999) 999-9999! | (206) 555-0248
 | ( ) 555-0248
(00000) AAA-AAAA | (02206) 555-TELE
#999 | -20
 | 2000
>L????L?000L0 | GRÜN GR339M3
 | MAI R 452B7
>L0L 0L0 | T2F 8M4
00000-9999 | 98115-
 | 98115-3007
>L<?????????????? | Maria
 | Pierre
ISBN 0-&&&&&&&&&-0 | ISBN 1-55615-507-7
 | ISBN 0-13-964262-5
>LL00000-0000 | DB51392-0493

Zurück zum Anfang der Seite

Definieren von Eingabeformaten

Die Eingabeformatdefinition setzt sich aus bis zu drei durch Semikolons voneinander getrennte Bereiche zusammen, wie z. B. (999) 000-0000!;0;" ".

Bereich | Bedeutung
Erster | Das Eingabeformat.
Zweiter | Bestimmt, ob die Literalzeichen gespeichert werden sollen. 0 = speichert Literalzeichen mit dem eingegebenen Wert. 1 oder leer = speichert nur Zeichen, die an Leerstellen eingegeben werden.
Dritter | Zeichen, das im Eingabeformat an Stelle von Leerzeichen angezeigt wird. Sie können jedes beliebige Zeichen verwenden. Geben Sie " " (doppelte Anführungszeichen, Leerzeichen, doppelte Anführungszeichen) ein, wenn Sie ein Leerzeichen anzeigen möchten. Wenn Sie diesen Bereich leer lassen, wird der Unterstrich ( _ ) verwendet.

Zurück zum Anfang der Seite

Gültige Zeichen für Eingabeformate

Microsoft Access interpretiert Zeichen im ersten Bereich in der Eingabeformat-Eigenschaft wie in der nachstehenden Tabelle gezeigt. Zum Definieren eines Literalzeichens geben Sie ein beliebiges Zeichen ein, das nicht den in der Tabelle aufgeführten Zeichen entspricht und kein Leerzeichen oder Symbol ist. Wenn Sie eines der folgenden Zeichen als Literalzeichen definieren möchten, müssen Sie vor diesem Zeichen einen \ (umgekehrten Schrägstrich) eingeben.

Zeichen | Beschreibung
0 | Ziffer (0 bis 9, Eingabe erforderlich; Plus- [+] und Minuszeichen [-] sind nicht erlaubt).
9 | Ziffer oder Leerzeichen (Eingabe nicht erforderlich; Plus- und Minuszeichen sind nicht erlaubt).
# | Ziffer oder Leerzeichen (Eingabe nicht erforderlich; Leerstellen werden in Leerzeichen konvertiert, Plus- und Minuszeichen sind erlaubt).
L | Buchstabe (A bis Z, Eingabe erforderlich).
? | Buchstabe (A bis Z, Eingabe nicht erforderlich).
A | Buchstabe oder Ziffer (Eingabe erforderlich).
a | Buchstabe oder Ziffer (Eingabe nicht erforderlich).
& | Ein beliebiges Zeichen oder ein Leerzeichen (Eingabe erforderlich).
C | Ein beliebiges Zeichen oder ein Leerzeichen (Eingabe nicht erforderlich).
. , : ; - / | Platzhalter für Dezimalstellen und Trennzeichen für Tausender, Datum und Zeit. (Das eigentliche Zeichen ist abhängig von den in der Windows-Systemsteuerung unter Ländereinstellungen definierten Einstellungen.)
< | Bewirkt, dass alle nachfolgenden Zeichen in Kleinbuchstaben konvertiert werden.
> | Bewirkt, dass alle nachfolgenden Zeichen in Großbuchstaben konvertiert werden.
! | Bewirkt, dass die Anzeige im Eingabeformat von rechts nach links anstatt von links nach rechts erfolgt. Eingegebene Zeichen füllen das Eingabeformat immer von links nach rechts aus. Sie können das Ausrufezeichen-Symbol an jeder beliebigen Stelle im Eingabeformat einfügen.
\ | Bewirkt, dass das nachfolgende Zeichen als Literalzeichen angezeigt wird. Dieses Symbol wird verwendet, um eines der in dieser Tabelle aufgeführten Symbole als Literalzeichen anzuzeigen (\A wird z. B. einfach als A angezeigt).
Kennwort | Wenn Sie für die Eingabeformat (InputMask)-Eigenschaft die Einstellung Kennwort festlegen, wird ein Textfeld zum Eingeben eines Kennworts erstellt. Jedes Zeichen, das hier eingegeben wird, wird als das eingegebene Zeichen gespeichert, es wird jedoch ein Sternchen (*) angezeigt.

Zurück zum Anfang der Seite

Weitere Informationen

Erstellen eines Eingabeformats


 Beispiele für Standardwerte in Feldern

Beispiele für Standardwerte in Feldern

Feld | Ausdruck | Standardfeldwert
Menge | 1 | 1
Region | "MT" | MT
Region | "New York, N.Y." | New York, N.Y. (beachten Sie, dass Sie den Wert in Anführungszeichen setzen müssen, wenn er Satzzeichen enthält)
Fax | " " | Eine Zeichenfolge der Länge Null um anzugeben, dass dieses Feld standardmäßig leer sein soll
Bestelldatum | Datum( ) | Aktuelles Datum


 Hyperlinkadressen - Beispiele

Hyperlinkadressen - Beispiele

Die folgende Tabelle enthält Beispiele für Hyperlinkadressen. Beachten Sie, dass in URLs Schrägstriche und in UNC-Pfaden umgekehrte Schrägstriche verwendet werden.

Hyperlinkadresse | Beschreibung
Microsoft Corporation#http://www.microsoft.com# | Die Microsoft-Homepage im Web. Wird als "Microsoft Corporation" angezeigt.
#http://www.microsoft.com# | Die Microsoft-Homepage im Web.
#http://www.microsoft.com#sample# | Die Namensmarke "sample" in dem .HTML-Dokument für die Microsoft-Homepage.
#\\Nordwind\Public\Produkte.doc##Liste der ermässigten Produkte | Eine Microsoft Word-Datei namens Produkte.doc, die sich in dem freigegebenen Verzeichnis Public auf dem Nordwind-Server befindet. Als QuickInfo wird "Liste der ermäßigten Produkte" angezeigt.
Fortsetzung#C:\Windows\Personal\Resume.doc# | Eine Word-Datei namens Resume.doc, die sich im Ordner \Windows\Personal befindet. Wird als "Resume" angezeigt.
#C:\windows\Personal\Resume.doc# | Die Datei Resume.doc, die sich im Ordner \Windows\Personal befindet. Es wird der Pfadname angezeigt, da kein Anzeigetext vorhanden ist.
#C:\Windows\Personal\Resume.doc#Qualifikationen | Die Textmarke namens "Qualifikationen" in der Datei Resume.doc.
#C:\Windows\Personal\Nordwind.mdb#Form Lieferanten | Das Lieferantenformular in der Nordwind-Datenbank, das sich im Ordner \Windows\Personal befindet.
Lieferanten##Form Lieferanten#Klicken um Lieferanteninformationen anzuzeigen und zu bearbeiten | Das Lieferantenformular in der aktuellen Datenbank. Wird als "Lieferanten" mit dem QuickInfo "Klicken um Lieferanteninformationen anzuzeigen und zu bearbeiten" angezeigt.
#C:\Windows\Personal\1996 Umsatz.ppt#13 | Folie 13 der PowerPoint-Präsentation "1996 Umsatz", die sich im Ordner \Windows\Personal befindet.
#C:\Windows\Personal\Budget.xls#Sheet1!A2 | Zelle A2 in Blatt1 der Excel-Datei Budget.xls, die sich im Ordner \Windows\Personal befindet.

Um die Eingabe von Hyperlinkadressen zu vereinfachen, können Sie in Microsoft Access bestimmte Teile der Adresse weglassen. Zum Beispiel:

  • Wenn Sie http://example.microsoft.com eingeben, erkennt Microsoft Access das "http:"-Protokoll und übersetzt die Adresse in #http://example.microsoft.com#. (Sie müssen die Nummernzeichen (#) also nicht selbst eingeben.)

  • Wenn Sie auf ein Microsoft Access-Objekt in der aktuellen Datenbank verweisen möchten, müssen Sie lediglich den Namen des Objekts angeben, zu dem eine Verknüpfung hergestellt werden soll - der UNC-Pfad muss nicht angegeben werden. Sind mehrere Objekte mit demselben Namen vorhanden, verweist Microsoft Access der Reihenfolge nach auf folgende Objekte: Formulare, Berichte, Abfragen, Tabellen, Datenzugriffsseiten, Makros, Module, Sichten, Schemas, gespeicherte Prozeduren, SQL-verknüpfte Tabellen, verknüpfte Tabellen und Trigger. Sind beispielsweise sowohl ein Formular als auch eine Tabelle namens Aufträge vorhanden, verweist Microsoft Access auf das Formular Aufträge. Sie können einen bestimmten Objekttyp festlegen, indem Sie Objekttyp Objektname eingeben. Um also auf die Tabelle Aufträge und nicht auf das Formular Aufträge zu verweisen, geben Sie Tabelle Aufträge als Unteradresse ein. Setzt sich der Objekttyp aus mehreren Wörtern zusammen, lassen Sie die Leerzeichen zwischen den Wörtern weg; geben Sie also z. B. verknüpftetabelle Aufträge ein.

  • Enthält der eingegebene Text kein Nummernzeichen (#), kein Protokoll (wie "http:") und keinen Verweis auf ein Objekt in der aktuellen Datenbank, geht Microsoft Access davon aus, dass es sich um Anzeigetext handelt und fügt an denselben Text "http://" für die Adresse an. Wenn Sie z. B. example.microsoft.com eingeben, übersetzt Microsoft Access die Adresse in example.microsoft.com#http://example.microsoft.com#.


 Verweise auf Werte, die sich auf Datenzugriffsseiten befinden - Beispiele

Verweise auf Werte, die sich auf Datenzugriffsseiten befinden - Beispiele

Die folgende Tabelle enthält Beispiele für Ausdrücke, die in berechneten Steuerelementen auf Datenzugriffsseiten verwendet werden können.

Verwendeter Ausdruck | Anzeige auf der Seite
=Document.All("MSODSC").CurrentSection.ChildSection.HTMLContainer.Children("ArtikelNr") | Der Wert im ArtikelNr-Steuerelement im Abschnitt, der sich eine Gruppierungsebene unterhalb des aktuellen Abschnitts befindet.
=Document.All("MSODSC").CurrentSection.ParentSection.HTMLContainer.Children("Kunden-Code") | Der Wert im KundenCode-Steuerelement im Abschnitt, der sich eine Gruppierungsebene oberhalb des aktuellen Abschnitts befindet.
=Document.All("MSODSC").CurrentSection.Parent.Parent.HTMLContainer.Children("Land") | Der Wert im Land-Steuerelement im Abschnitt, der sich zwei Gruppierungsebenen oberhalb des aktuellen Abschnitts befindet.
=Document.All("Meine Kalkulationstabelle").Range("A1") | Die Werte im A1-Bereich des Office Spreadsheet-Steuerelements.

Die folgende Tabelle enthält Beispiele für Verweise auf Steuerelemente, die sich auf einer Seite eines Office Spreadsheet-Steuerelements befinden.

Verwendeter Ausdruck | Anzeige auf der Seite
=document.Anzahl.value*document.Einzelpreis.value | Das Ergebnis der Multiplikation des Wertes im Anzahl-Steuerelement mit dem Wert im Einzelpreis-Steuerelement.
=$C$1*document.Einzelpreis.value | Das Ergebnis der Multiplikation des Wertes im Einzelpreis-Steuerelement mit einem in Zelle C1 der Tabelle gespeicherten Prozentsatzes.


Gültigkeitsregeln für Felder in Tabellen und Steuerelementen auf Formularen - Beispiele

Gültigkeitsregel | Gültigkeitsmeldung
<>0 | Bitte geben Sie einen Wert ungleich Null ein.
0 Oder >100 | Der Wert muss gleich 0 oder größer 100 sein.
Wie "K???" | Der Wert muss 4 Zeichen lang sein und mit dem Buchstaben K beginnen.
<#01.01.96# | Geben Sie ein Datum vor 1996 ein.
>=#01.01.97# Und <#01.01.98# | Geben Sie ein Datum im Jahr 1997 ein.
StrComp(UCase([LastName]), [LastName],0) = 0 | Daten im Feld LastName müssen in Großbuchstaben eingegeben werden.

Informationen über Gültigkeitsregeln anzeigen.

Anmerkung Zum Anzeigen eines Beispiels für eine Gültigkeitsprüfung auf Formularebene unter Verwendung eines Makros oder einer Ereignisprozedur klicken Sie auf [image] .


Formular- und Berichtsspezifikationen

Attribut | Maximalwert
Anzahl der Zeichen in einem Bezeichnungsfeld | 2.048
Anzahl der Zeichen in einem Textfeld | 65.535
Breite des Formulars oder Berichts | 55,87 cm (22 Zoll)
Höhe eines Bereichs | 55,87 cm (22 Zoll)
Höhe aller Bereiche zuzüglich der Bereichsköpfe
(in der Entwurfsansicht) 		508 cm (200 Zoll)
Anzahl der Ebenen bei verschachtelten Formularen oder Berichten | 3
Anzahl der Felder oder Ausdrücke, die in einem Bericht sortiert oder gruppiert werden können | 10
Anzahl der Kopf- und Fußbereiche in einem Bericht 1 Berichtskopf/-fuß;
1 Seitenkopf/-fuß;
10 Gruppenköpfe/-füße
Anzahl der gedruckten Seiten in einem Bericht | 65.536
Anzahl der Steuerelemente und Bereiche, die während der Lebensdauer des Formulars bzw. Berichts insgesamt hinzugefügt werden können | 754


 Verwenden globaler Microsoft Access-Tastenkombinationen

Verwenden globaler Microsoft Access-Tastenkombinationen

Tastenkombination | Hilfe anzeigen
F1 | Zum Anzeigen des Office-Assistenten und der Microsoft Access-Hilfe; kontextsensitiver Hilfe über die ausgewählte Eigenschaft, das ausgewählte Steuerelement, die ausgewählte Makro-Aktion oder das ausgewählte Visual Basic-Schlüsselwort; oder Warnungen mit der Schaltfläche Hilfe
UMSCHALT+F1 | Zum Anzeigen von QuickInfo; wenn Sie UMSCHALT+F1 gedrückt haben, gehen Sie mit dem Mauszeiger zum Menübefehl, zur Symbolleistenschaltfläche oder zum Bildschirmbereich, und klicken Sie anschließend auf das entsprechende Element
UMSCHALT+F1 | Zum Anzeigen von QuickInfo in einem Dialogfeld, nachdem Sie die Option mit der Tastatur ausgewählt haben

Tastenkombination | Datenbanken öffnen
STRG+N | Zum Öffnen einer neuen Datenbank
STRG+O | Zum Öffnen einer vorhandenen Datenbank

Tastenkombination | Drucken und Speichern
STRG+P | Zum Drucken des aktuellen oder ausgewählten Objekts
STRG+S oder UMSCHALT+F12 oder ALT+UMSCHALT+F2 | Zum Speichern eines Datenbankobjekts
F12 oder ALT+F2 | Zum Öffnen des Dialogfelds Speichern unter

Tastenkombination | Verwenden eines Kombinations- oder Listenfeldes
F4 oder ALT+NACH-UNTEN | Zum Öffnen eines Kombinationsfeldes
F9 | Zum Aktualisieren des Inhalts eines Nachschlagefeld-Listen- oder -Kombinationsfeldes
NACH-UNTEN-TASTE | Zum Wechseln in die nächstuntere Zeile
BILD-AB | Zum Wechseln auf die nächste Seite
NACH-OBEN-TASTE | Zum Wechseln in die nächstobere Zeile
BILD-AUF | Zum Wechseln auf die vorherige Seite
TAB | Zum Verlassen des Kombinations- oder Listenfeldes

Tastenkombination | Suchen und Ersetzen von Text oder Daten
STRG+F | Zum Öffnen der Registerkarte Suchen im Dialogfeld Suchen und Ersetzen (nur Datenblattansicht und Formularansicht)
STRG+H | Zum Öffnen der Registerkarte Ersetzen im Dialogfeld Suchen und Ersetzen (nur Datenblattansicht und Formularansicht)
UMSCHALT+F4 | Zum Suchen des nächsten Vorkommens des Textes, der im Dialogfeld Suchen und Ersetzen angegeben wurde, wenn das Dialogfeld geschlossen ist (nur Datenblattansicht und Formularansicht)

Tastenkombination | Arbeiten in der Entwurfsansicht
F2 | Zum Wechseln zwischen Bearbeitungsmodus (mit angezeigtem Cursor) und Navigationsmodus
F5 | Zum Wechseln von der Entwurfsansicht für Formulare in die Formularansicht
F6 | Zum Wechseln zwischen oberem und unterem Fensterbereich (nur in der Entwurfsansicht von Tabellen, Makros und Abfragen und im Fenster Spezialfilter/-sortierung)

Tastenkombination | Bearbeiten von Steuerelementen in der Entwurfsansicht für Formulare und Berichte
UMSCHALT+EINGABETASTE Zum Hinzufügen eines Steuerelements zu einem Bereich

Informationen über Anordnen eines Textfeldes oder eines anderen Steuerelements auf einem Formular oder Bericht mit der Tastatur anzeigen

Informationen über Kopieren eines Textfelds oder eines anderen Steuerelements in einem Formular oder Bericht mit der Tastatur anzeigen
STRG+C | Zum Kopieren des ausgewählten Steuerelements in die Zwischenablage
STRG+X | Zum Ausschneiden des ausgewählten Steuerelements und zum Kopieren in die Zwischenablage
STRG+V | Zum Einfügen des Inhalts der Zwischenablage in die obere linke Ecke des ausgewählten Bereichs
STRG+NACH-RECHTS-TASTE | Zum Verschieben des ausgewählten Steuerelements nach rechts
STRG+NACH-LINKS-TASTE | Zum Verschieben des ausgewählten Steuerelements nach links
STRG+NACH-OBEN-TASTE | Zum Verschieben des ausgewählten Steuerelements nach oben
STRG+NACH-UNTEN-TASTE | Zum Verschieben des ausgewählten Steuerelements nach unten
UMSCHALT+NACH-UNTEN-TASTE | Zum Vergrößern der Höhe des ausgewählten Steuerelements
UMSCHALT+NACH-RECHTS-TASTE | Zum Vergrößern der Breite des ausgewählten Steuerelements
UMSCHALT+NACH-OBEN-TASTE | Zum Verringern der Höhe des ausgewählten Steuerelements
UMSCHALT+NACH-LINKS-TASTE | Zum Verringern der Breite des ausgewählten Steuerelements

Tastenkombination | Fensteroperationen
F11 oder ALT+F1 | Bringt das Datenbankfenster in den Vordergrund
STRG+F6 | Zum Wechseln zwischen geöffneten Fenstern
EINGABETASTE | Zum Wiederherstellen des ausgewählten minimierten Fensters, wenn alle Fenster minimiert werden
STRG+F8 | Zum Aktivieren des Wiederherstellen-Modus für das aktive Fenster, wenn es nicht maximiert ist. Drücken Sie die Pfeiltasten, um die Größe des Fensters zu ändern.
ALT+LEERTASTE | Zum Anzeigen des Systemmenüs
UMSCHALT+F10 | Zum Anzeigen des Kontextmenüs
STRG+W oder STRG+F4 | Zum Schließen des aktiven Fensters
ALT+F11 | Zum Wechseln zwischen dem Visual Basic Editor und dem vorigen aktiven Fenster
ALT+UMSCHALT+F11 | Zum Wechseln zwischen dem Microsoft Script Editor und dem vorigen aktiven Fenster

Tastenkombination | Verschiedenes
F2 | Zum Anzeigen der vollständigen Hyperlinkadresse für einen ausgewählten Hyperlink
F7 | Zum Durchführen der Rechtschreibprüfung
UMSCHALT+F2 | Zum Öffnen des Zoomfeldes, in dem Sie Ausdrücke und anderen Text mühelos in kleine Eingabebereiche eingeben können
ALT+EINGABETASTE | Zum Anzeigen eines Eigenschaftenfensters in der Entwurfsansicht
ALT+F4 | Zum Beenden von Microsoft Access, zum Schließen eines Dialogfelds oder Eigenschaftenfensters
STRG+F2 | Zum Aufrufen eines Editors
STRG+F11 | Zum Wechseln zwischen einer benutzerdefinierten Menüleiste und einer eingebauten Menüleiste


Wie erhalte ich die eingebauten Symbolleisten und Menüs zurück, wenn Sie nicht mehr angezeigt werden?

Wenn alle eingebauten Symbolleisten und einige eingebaute Menüs in allen Ansichten nicht mehr angezeigt werden, müssen Sie vielleicht die Einstellungen im Dialogfeld Start ändern oder vorübergehend umgehen.

So ändern Sie die Einstellungen

Klicken Sie im Menü Extras auf Start und danach auf Eingebaute Symbolleisten zulassen, um alle eingebauten Symbolleisten anzuzeigen, und auf Unbeschränkte Menüs anzeigen, um alle eingebauten Menüs anzuzeigen. Schließen Sie die Datenbank oder das Microsoft Access-Projekt, und öffnen Sie es erneut.

Wenn noch immer einige Menüs fehlen, kann es sein, dass sie aus der Menüleiste entfernt wurden. Sie können der Menüleiste ein bestimmtes eingebautes Menü erneut hinzufügen. Um weitere Informationen zu erhalten, klicken Sie auf [image] .

So umgehen Sie vorübergehend die Einstellungen im Dialogfeld Start

Sie können alle Einstellungen im Dialogfeld Start vorübergehend umgehen, anstatt die Optionen zurückzusetzen. Halten Sie beim Öffnen der Datenbank die Bypass-Taste (die UMSCHALTTASTE) gedrückt.


Syntax der Hyperlinkunteradresse

Dateityp
des Ziels
Eingabe
Microsoft Access Objekttyp und Objektname. Geben Sie beispielsweise Tabelle Kunden ein, um zur Tabelle Kunden zu wechseln.

Anmerkungen Wenn Sie den Objekttyp nicht angeben und mehrere Objekte desselben Namens bestehen, verwendet Microsoft Access folgende Reihenfolge, um das zu referenzierende Objekt zu bestimmen: Formulare, Berichte, Abfragen, Tabellen, Datenzugriffsseiten, Makros, Module, Ansichten, Schemas, gespeicherte Prozeduren, durch SQL verknüpfte Tabellen, verknüpfte Tabellen und Trigger. Wenn beispielsweise sowohl ein Formular Bestellungen wie auch eine Tabelle Bestellungen existieren, geht Access davon aus, dass die Referenz für das Formular Bestellungen gilt. Wenn Sie die Tabelle Bestellungen festlegen möchten, müssen Sie Tabelle Bestellungen eingeben.

Auf einem nicht englischsprachigem System erkennt Access den Objekttyp in Englisch und in der Landessprache; Hyperlinks, die unter Verwendung des Dialogfelds Hyperlink einfügen erstellt wurden, besitzen jedoch alle die englischsprachige Zeichenfolge für einen Objekttyp.
Microsoft Excel | Definierter Name oder Tabelle!Bereich. Geben Sie beispielsweise Tabelle1!A2 ein, um zur Zelle A2 in der Tabelle 1 zu wechseln.
Microsoft PowerPoint | Nummer einer Folie
Microsoft Word | Name einer Textmarke
HTML-Dokument | Name einer Textmarke (definiert mit Hilfe des Attributs NAME der <A>-Marke)


Makrospezifikationen

Attribut | Maximalwert
Anzahl der Aktionen in einem Makro | 999
Anzahl der Zeichen in einer Bedingung | 255
Anzahl der Zeichen in einem Kommentar | 255
Anzahl der Zeichen in einem Aktionsargument | 255


 Tipps zum Optimieren der Leistung von Microsoft Access und Ihres Systems

Tipps zum Optimieren der Leistung von Microsoft Access und Ihres Systems

Die folgenden Richtlinien helfen Ihnen, die Leistung von Microsoft Access auf Ihrem Computer zu optimieren:

  • Wenn Sie mit Datenbanken arbeiten, die nicht mit anderen Benutzern gemeinsam verwendet werden, installieren Sie Microsoft Access und alle Ihre Datenbanken auf Ihrer Festplatte anstatt auf einem Netzwerk-Server.

  • Wenn außer Ihnen kein anderer Benutzer die Datenbank verwendet, können Sie diese zur exklusiven Verwendung öffnen. Klicken Sie im Dialogfeld Öffnen auf den Pfeil neben der Schaltfläche Öffnen, und aktivieren Sie Exklusiv öffnen.

  • Stellen Sie mehr Speicher zur Verfügung, indem Sie alle nicht benötigten Anwendungen schließen.

  • Erhöhen Sie den Arbeitsspeicher (RAM) Ihres Computers. Wird auf dem Computer Microsoft Windows 95 oder höher ausgeführt, werden 24 MB Arbeitsspeicher empfohlen - 16 MB plus 8 MB Arbeitsspeicher zusätzlich für Microsoft Access. Wenn Sie auf Ihrem Computer Windows NT 4.0 oder höher ausführen, sind 40 MB Arbeitsspeicher empfehlenswert - 32 MB plus 8 MB Arbeitsspeicher zusätzlich für Microsoft Access.

  • Verwenden Sie den RAM nicht für eine RAM-Disk.

  • Löschen Sie regelmäßig unbenötigte Dateien und leeren Sie ebenfalls regelmäßig Ihren Papierkorb, komprimieren Sie Ihre Datenbanken, und defragmentieren Sie Ihre Festplatte mit dem Microsoft Windows-Defragmentierungsprogramm. Zum Starten des Windows-Defragmentierungsprogramms klicken Sie auf die Schaltfläche Start in Windows, zeigen Sie auf Programme, auf Zubehör, anschließend auf Systemprogramme, und klicken Sie schließlich auf Defragmentierung.

  • In den meisten Fällen funktionieren die Standardeinstellungen von Windows für den virtuellen Arbeitsspeicher optimal. In einigen Situationen kann ein Anpassen der Parameter für den virtuellen Arbeitsspeicher die Leistung jedoch verbessern. Wenn Sie alle unbenötigten Dateien bereits gelöscht haben und dennoch über ein Speicherproblem verfügen, ändern Sie die Standardeinstellungen für den virtuellen Arbeitsspeicher in den folgenden Fällen:
    • Ihnen steht wenig freier Speicherplatz auf dem Laufwerk, das aktuell für den virtuellen Arbeitsspeicher verwendet wird, zur Verfügung, Sie besitzen aber ein anderes lokales Laufwerk, auf dem genügend Speicherplatz verfügbar ist.

    • Ein anderes lokales Laufwerk ist verfügbar, das schneller als das aktuelle Laufwerk ist (es sei denn, dieses Laufwerk wird stark benutzt).

    In diesen Fällen erzielen Sie möglicherweise eine bessere Leistung, indem Sie ein anderes Laufwerk für den virtuellen Arbeitsspeicher angeben.

    Sie können auch eine bessere Leistung erzielen, indem Sie festlegen, dass der für den virtuellen Arbeitsspeicher verfügbare Festplattenspeicher mindestens 25 MB abzüglich des verfügbaren RAMs beträgt. Wenn Ihr Computer z.B. über 12 MB RAM verfügt, richten Sie mindestens 13 MB virtuellen Arbeitsspeicher ein. Es ist möglicherweise sinnvoll, noch mehr virtuellen Arbeitsspeicher einzurichten, wenn Sie mehrere große Anwendungen ausführen.

    Um die Windows-Parameter für den virtuellen Arbeitsspeicher zu ändern, doppelklicken Sie in der Windows-Systemsteuerung auf das Symbol System, klicken Sie anschließend auf die Registerkarte Leistungsmerkmale, klicken Sie auf Virtueller Arbeitsspeicher und dann auf Es gelten benutzerdefinierte Einstellungen für den virtuellen Speicher. Bestimmen Sie anschließend eine andere Festplatte, oder geben Sie einen Wert in das Feld Minimum ein, der mindestens 25 MB abzüglich des verfügbaren RAMs beträgt.

  • Wenn Sie eine Bitmap für ein Hintergrundbild (Vollbildhintergrund) für Ihren Windows-Desktop definiert haben, ersetzen Sie dieses durch einen einfarbigen Hintergrund oder eine Muster-Bitmap, oder lassen Sie den Hintergrund ohne Bitmap.

  • Wenn Sie normalerweise einen Bildschirmschoner verwenden, wählen Sie ein leeres Bild als Bildschirmschoner, oder lassen sie ihn ganz weg.

  • Entfernen Sie Software zur Festplattenkomprimierung, oder verlegen Sie Ihre Datenbanken auf ein nicht komprimiertes Laufwerk.

Weitere Informationen zur Leistungsoptimierung Ihrer Datenbank finden Sie in Kapitel 10, "Optimieren Ihrer Anwendung", in Erstellen von Anwendungsprogrammen mit Formularen und Berichten.


 Tipps zum Optimieren der Leistung externer SQL-Datenbanken

Tipps zum Optimieren der Leistung externer SQL-Datenbanken

Bestehen die Daten in Ihrer Front-End/Back-End-Anwendung nur aus Microsoft SQL Server-Tabellen, können Sie entweder ein Microsoft Access-Projekt oder eine Microsoft Access-Datenbank als Front-End für Ihre Anwendung verwenden. Sollen die Daten in der Front-End/Back-End-Anwendung jedoch sowohl Microsoft Access-Tabellen als auch Microsoft SQL Server-Tabellen enthalten, müssen Sie eine Access-Datenbank als Front-End verwenden.

Wenn Sie eine Verbindung zu einer externen SQL-Datenbank herstellen, erzielen Sie die besten Leistungsergebnisse, indem Sie zu den SQL-Tabellen eine Verknüpfung herstellen anstatt die Tabellen direkt zu öffnen. Sie können externe SQL-Tabellen nur unter Verwendung von Visual Basic-Code direkt öffnen. Verknüpfte Tabellen sind wesentlich schneller, leistungsstärker und effizienter als direkt geöffnete Tabellen.

Zusätzliche Tipps zur Leistungssteigerung

  • Rufen Sie nur die tatsächlich benötigten Daten ab. Entwerfen Sie Ihre Abfragen so, dass sie eine begrenzte Anzahl von Datensätzen abrufen, und wählen Sie nur die benötigten Felder aus, so dass Microsoft Access möglichst wenig Daten über das Netzwerk übertragen muss.

  • Verwenden Sie keine aktualisierbaren Ergebnisgruppen (Dynasets), wenn Sie nur einige Datensätze abrufen, die Daten nicht aktualisieren und die Änderungen anderer Benutzer nicht anzeigen müssen. Wenn Sie verhindern möchten, dass die Ergebnisgruppen in einem Formular aktualisiert werden, stellen Sie die Eigenschaft Datensatzgruppentyp des Formulars auf Snapshot ein. Snapshots lassen sich schneller öffnen als Dynasets, und Sie können auch schneller einen Bildlauf durchführen.

  • Beim Abrufen einer großen Anzahl von Datensätzen ist ein Dynaset schneller und effizienter als ein Snapshot. Um z.B. an das Ende eines Snapshots zu springen, muss die gesamte Ergebnisgruppe auf den lokalen Computer geladen werden, bei einem Dynaset dagegen müssen lediglich die Daten des letzten Bildschirms auf den lokalen Computer geladen werden. Die schnellste Möglichkeit zum Hinzufügen neuer Datensätze zu einer Tabelle, einem Formular oder einer Abfrage besteht darin, im Menü Datensätze auf Daten eingeben zu klicken (Daten eingeben ist jedoch nicht verfügbar, wenn die Eigenschaft Datensatzgruppentyp auf Snapshot eingestellt ist.).

  • Verwenden Sie Cache-Speicher. Wenn die zuletzt vom Server abgerufenen Daten erneut abgefragt werden, während die Anwendung ausgeführt wird, ist es schneller, eine große Menge von Daten (viele Zeilen) gleichzeitig abzurufen und diese im Cache-Speicher abzulegen, als viele einzelne Zeilen abzurufen. Microsoft Access-Formulare und -Datenblätter verwenden automatisch Cache-Speicher. Wenn Sie Daten unter Verwendung eines Recordset-Objekts abrufen, das in Microsoft Visual Basic erstellt wurde, können Sie mit Hilfe der CacheSize-Eigenschaft festlegen, wie viele Datensätze gleichzeitig in den lokalen Speicher geladen werden sollen.

  • Vermeiden Sie das Verwenden von Abfragen, die bewirken, dass eine Verarbeitung auf einem lokalen Client-Computer erfolgt. Wenn Sie auf externe Daten zugreifen, verarbeitet die Jet-Datenbank-Engine die Daten nur dann lokal, wenn die Operation vom externen Datenbank-Server nicht durchgeführt werden kann. Abfrageoperationen, die lokal ausgeführt werden (definiert durch die SQL-Befehle, die zu deren Implementierung verwendet werden), sind z.B. die folgenden:
    • JOIN-Operationen zwischen Tabellen aus unterschiedlichen Remote-Datenquellen. (Beachten Sie, dass bei einer Verknüpfung zwischen einer lokalen Tabelle oder Abfrage mit nur wenigen Datensätzen und einer Remote-Tabelle mit wesentlich mehr Datensätzen, deren Verknüpfungsfeld indiziert ist, Microsoft Access nur die Datensätze zurückgibt, die denen der lokalen Tabelle oder Abfrage entsprechen, und somit die Leistung der Abfrage bedeutend verbessert wird.)

    • JOIN-Operationen auf der Grundlage einer Abfrage mit dem DISTINCT-Prädikat oder einer GROUP BY-Klausel.

    • Inklusionsverknüpfungen, die eine Syntax enthalten, die der Server nicht unterstützt.

    • DISTINCT-Prädikate, die Operationen enthalten, die nicht entfernt verarbeitet werden können.

    • Der Operator Wie, wenn er zusammen mit Text- oder Memo-Feldern verwendet wird (wird unter Umständen von einigen Servern nicht unterstützt).

    • GROUP BY-Argumente und -Funktionen mit mehreren Ebenen, wie sie z.B. in Berichten mit mehreren Gruppierungsebenen verwendet werden.

    • GROUP BY-Argumente basierend auf einer Abfrage mit einem DISTINCT-Prädikat oder einer GROUP BY-Klausel.

    • Kreuztabellenabfragen, die mehrere Aggregatfunktionen mit Feld-, Zeilen- oder Spaltenüberschriften enthalten, welche wiederum Aggregatfunktionen oder eine benutzerdefinierte ORDER BY-Klausel enthalten.

    • Die Prädikate TOP n oder TOP n PERCENT.

    • Benutzerdefinierte Funktionen oder Operatoren bzw. Funktionen, die nicht vom Server unterstützt werden.

    • Komplexe Kombinationen aus INNER JOIN-, LEFT JOIN- oder RIGHT JOIN-Operationen in verschachtelten Abfragen.
  • Wenn Sie bei umfangreichen Aktualisierungsabfragen auf der Grundlage von ODBC-Datenquellen die Leistung auf dem Server optimieren möchten, legen Sie für die BeiFehlerAbbrechen-Eigenschaft die Einstellung Ja fest. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Aggregatfunktionen und andere Optionen in der Zeile "Funktion" des Entwurfsbereichs einer Abfrage

Aggregatfunktionen und andere Optionen in der Zeile "Funktion" des Entwurfsbereichs einer Abfrage

Neun der zwölf Optionen in der Zeile Funktion des Entwurfsbereichs einer Abfrage sind Aggregatfunktionen. In der folgenden Tabelle werden alle Funktionen, mit Ausnahme von ErsterWert und LetzterWert, erklärt. Um spezielle Anhaltspunkte zur Verwendung der Funktionen ErsterWert und LetzterWert zu erhalten, klicken Sie auf [image] Die übrigen drei Optionen der Liste werden in der zweiten Tabelle erläutert.

Anmerkung Datensätze, die Null-Werte enthalten, werden von Aggregatfunktionen in ihren Berechnungen nicht berücksichtigt. Die Funktion Anzahl gibt z.B. die Anzahl aller Datensätze zurück, die keine Null-Werte enthalten. Es gibt jedoch eine Möglichkeit, auch Null-Werte zu zählen. Wenn Sie Null-Werte in 0 umwandeln, können sie in einer Berechnung berücksichtigt werden. Um weitere Informationen zu erhalten, klicken Sie auf [image] .

Auswahl | Berechnung | Zu verwendende Felddatentypen
Summe | Summe der Werte eines Feldes | Zahl, Datum/Uhrzeit, Währung und AutoWert
Mittelwert | Durchschnitt der Werte eines Feldes | Zahl, Datum/Uhrzeit, Währung und AutoWert
Min | Niedrigster Wert eines Feldes | Text, Zahl, Datum/Uhrzeit, Währung und AutoWert
Max | Höchster Wert eines Feldes | Text, Zahl, Datum/Uhrzeit, Währung und AutoWert
Anzahl | Anzahl der Werte eines Feldes ohne Berücksichtigung von Null-Werten | Text, Memo, Zahl, Datum/Uhrzeit, Währung, AutoWert, Ja/Nein und OLE-Objekt
StAbw | Standardabweichung der Werte eines Feldes | Zahl, Datum/Uhrzeit, Währung und AutoWert
Varianz | Varianz der Werte eines Feldes | Zahl, Datum/Uhrzeit, Währung und AutoWert

Auswahl | Zweck
Gruppierung | Definieren der Gruppen, für die Sie die Berechnungen durchführen möchten. Um z.B. die Gesamtverkäufe nach Artikeln gruppiert anzuzeigen, wählen Sie Gruppierung für das Feld Artikelname aus.
Ausdruck | Erstellen eines berechneten Feldes, in dessen Ausdruck eine Aggregatfunktion angegeben wird. Normalerweise erstellen Sie ein berechnetes Feld, wenn Sie in einem Ausdruck mehrere Funktionen verwenden möchten.
Bedingung | Angeben von Kriterien für ein Feld, das nicht zum Definieren von Gruppierungen verwendet wird. Wenn Sie diese Option für ein Feld auswählen, blendet Microsoft Access dieses Feld im Abfrageergebnis durch Deaktivieren des Kontrollkästchens Anzeigen aus.


 Allgemeine Spezifikationen für Microsoft Access-Projekte

Allgemeine Spezifikationen für Microsoft Access-Projekte

Attribut | Maximum
Anzahl von Objekten in einem Microsoft Access-Projekt (.ADP) | 32.768
Module (einschließlich Formulare und Berichte, in denen für die Enthält Modul-Eigenschaft Ja eingestellt wurde) | 1.000
Anzahl der Zeichen in einem Objektnamen | 64


Abfragespezifikationen für Microsoft Access-Datenbanken

Attribut | Maximalwert
Anzahl der Durchsetzungsbeziehungen | 32 pro Tabelle abzüglich der Anzahl von Indizes, die für Felder oder Feldkombinationen bestehen und nicht in Beziehungen verwickelt sind.
Anzahl der Tabellen in einer Abfrage | 32
Anzahl der Felder in einer Datensatzgruppe | 255
Größe einer Datensatzgruppe | 1 Gigabyte
Sortierbeschränkung | 255 Zeichen in einem oder mehreren Feldern
Anzahl der Ebenen bei verschachtelten Abfragen | 50
Anzahl der Zeichen in einer Zelle des Abfrageentwurfsbereichs | 1.024
Anzahl der Zeichen für einen Parameter in einer Parameterabfrage | 255
Anzahl der ANDs in einer WHERE- oder HAVING-Klausel | 40
Anzahl der Zeichen in einer SQL-Anweisung | ungefähr 64.000


 Vergleiche zwischen AktualisierenObjekt-Aktion und RepaintObject-Methode; AnzeigenAlleDatensätze-Aktion und ShowAllRecords-Methode; AktualisierenDaten-Aktion sowie Requery-Methode und Refresh-Methode

Vergleiche zwischen AktualisierenObjekt-Aktion und RepaintObject-Methode; AnzeigenAlleDatensätze-Aktion und ShowAllRecords-Methode; AktualisierenDaten-Aktion sowie Requery-Methode und Refresh-Methode

Die folgende Tabelle bietet einen kurzen Vergleich zwischen der Aktion AktualisierenObjekt, der RepaintObject-Methode, der Repaint-Methode, der Aktion AnzeigenAlleDatensätze, der ShowAllRecords-Methode, der Aktion AktualisierenDaten, der Requery-Methode des DoCmd-Objekts, der Refresh-Methode sowie der Requery-Methode.

Aktion oder Methode | Beschreibung
Aktion AktualisierenObjekt
RepaintObject-Methode bzw. Repaint-Methode des DoCmd-Objekts 		Mit der Aktion AktualisierenObjekt, der RepaintObject-Methode oder der Repaint-Methode können Sie Steuerelemente in dem angegebenen Objekt aktualisieren. Auf diese Weise ist es nicht möglich, die Datenbank erneut abzufragen oder neue Datensätze anzuzeigen.
Aktion AnzeigenAlleDatensätze
ShowAllRecords-Methode 		Mit der Aktion AnzeigenAlleDatensätze können Sie die aktuellen Datensätze erneut abfragen und anzeigen sowie alle zugewiesenen Filter entfernen; dies geschieht nicht mit der Aktion AktualisierenDaten.
Aktion AktualisierenDaten
Requery-Methode des DoCmd-Objekts 		Mit der Aktion AktualisierenDaten bzw. der Requery-Methode können Sie die Quelle eines bestimmten Objekts oder eines seiner Steuerelemente aktualisieren. Die Aktion AktualisierenDaten bzw. die Requery-Methode führt einen der folgenden Vorgänge aus:

Erneutes Ausführen der Abfrage, auf der das Steuerelement oder Objekt basiert.

Anzeigen aller neuen oder geänderten Datensätze und Entfernen aller gelöschten Datensätze aus der Tabelle, auf der das Steuerelement bzw. Objekt basiert.
Refresh-Methode | Mit der Refresh-Methode können Sie die Datensätze der zugrunde liegenden Datenherkunft für ein angegebenes Formular oder Datenblatt sofort aktualisieren und dadurch die Änderungen anzeigen, die Sie oder andere Benutzer in einer Mehrbenutzerumgebung an den Daten vorgenommen haben. Die Refresh-Methode zeigt nur Änderungen, die an den aktuellen Datensätzen vorgenommen wurden, und keine neuen oder in der Datenherkunft gelöschten Datensätze an.
Requery-Methode
  • Mit der Requery-Methode können Sie die einem Formular oder Steuerelement zugrunde liegenden Daten aktualisieren, um Datensätze anzuzeigen, die neu sind oder seit der letzten Abfrage aus der Datenherkunft gelöscht wurden.

    Wenn Sie ein Steuerelement, das sich nicht im aktiven Objekt befindet, erneut abfragen möchten, verwenden Sie diese Methode und nicht die Aktion AktualisierenDaten oder die entsprechende Requery-Methode des DoCmd-Objekts.


Möglichkeiten zum Auswählen von Werten für einen Filter, die die Ausgabe von Datensätzen beeinflussen

Sie können einen Wert in einem Feld ganz oder teilweise auswählen und damit bestimmen, welche Datensätze der Filter ausgeben soll.

Auswahl | Aufgabe | Beispiel
Der gesamte Inhalt eines Feldes (oder Setzen der Einfügemarke in ein Feld, ohne etwas zu markieren) | Suchen nach Datensätzen, in denen der gesamte Inhalt des entsprechenden Feldes der Auswahl entspricht. | Wenn Sie im Feld Ort den Wert Berlin auswählen, gibt der Filter alle Datensätze aus, für die im Feld Ort der Wert Berlin eingetragen ist.
Einen Teil eines Wertes beginnend beim ersten Zeichen im Feld | Suchen nach Datensätzen, in denen der Wert im entsprechenden Feld mit den Zeichen beginnt, die Sie ausgewählt haben. | Wenn Sie im Feld Firma, das den Wert Französisches Restaurant enthält, nur die Zeichen Fran auswählen, gibt der Filter alle Datensätze aus, in denen der Firmenname mit den Zeichen Fran beginnt, also z.B. auch Franchi S.p.A. oder Frankenversand.
Einen Teil eines Wertes beginnend nach dem ersten Zeichen in einem Feld | Suchen nach Datensätzen, in denen alles oder ein beliebiger Teil im entsprechenden Feld mit den ausgewählten Zeichen identisch ist. | Wenn Sie im Feld Firma, das den Wert Asiatische Delikatessen enthält, die Zeichen Del auswählen, gibt der Filter alle Datensätze aus, in denen der Firmenname an einer beliebigen Stelle die Zeichen del enthält, also z.B. auch Ernst Handel, Galería del gastrónomo oder Que Delícia.


Technische Spezifikationen für Microsoft SQL Server-Datenbanken

Informationen zu technischen Spezifikationen für Microsoft SQL Server finden Sie in der SQL Server-Dokumentation. Zu diesen Spezifikationen gehören die Maximalgröße und die Höchstwerte für SQL Server-Objekte, minimale und maximale Werte für Konfigurationsoptionen sowie der Speicherbedarf für verschiedene SQL Server-Objekte. Siehe auch SQL Server-Dokumentation.


Tabellenspezifikationen für Microsoft Access-Datenbanken

Attribut | Maximalwert
Anzahl der Zeichen in einem Tabellennamen | 64
Anzahl der Zeichen in einem Feldnamen | 64
Anzahl der Felder in einer Tabelle | 255
Anzahl der geöffneten Tabellen | 2048. Die effektive Anzahl kann wegen interner Tabellen, die Microsoft Access öffnet, kleiner sein.
Tabellengröße | 1 Gigabyte
Anzahl der Zeichen in einem Feld vom Datentyp Text | 255
Anzahl der Zeichen in einem Feld vom Datentyp Memo | 65.535, wenn die Daten über die Benutzeroberfläche eingegeben werden; 1 Gigabyte, wenn die Daten programmgesteuert eingegeben werden.
Größe eines Feldes vom Datentyp OLE-Objekt | 1 Gigabyte
Anzahl der Indizes in einer Tabelle | 32
Anzahl der Felder in einem Index | 10
Anzahl der Zeichen in einer Gültigkeitsmeldung | 255
Anzahl der Zeichen in einer Gültigkeitsregel | 2.048
Anzahl der Zeichen in einer Tabellen- oder Feldbeschreibung | 255
Anzahl der Zeichen in einem Datensatz (ausgenommen Felder vom Datentyp Memo und OLE-Objekt) | 2.000
Anzahl der Zeichen in der Eigenschafteneinstellung eines Feldes | 255


Abfragetypen, die Sie in Microsoft Access erstellen können

Zu welchem Abfragetyp möchten Sie weitere Informationen?

Auswahlabfragen

Parameterabfragen

Kreuztabellenabfragen

Aktionsabfragen (Tabellenerstellungs-, Lösch-, Aktualisierungs- oder Anfügeabfragen)

SQL-Abfragen (Unions-, SQL Pass-Through-, Datendefinitions- oder Unterabfragen)

Zurück zu Erstellen einer Abfrage


 Benutzer können meine interaktive Datenzugriffsseite nicht öffnen.

Benutzer können meine interaktive Datenzugriffsseite nicht öffnen.

Um interaktive Daten von Microsoft Access auf der Datenzugriffsseite verwenden zu können, müssen Benutzer die Professional-, Premium- oder Standard-Ausgabe von Microsoft Office 2000 auf ihrem Computer installiert haben, oder sie müssen über eine Sitelizenz für Microsoft Office 2000 verfügen und die Webkomponenten installieren.

Um sicherzustellen, dass Benutzer in Ihrem Intranet die Webkomponenten installiert haben, können Sie festlegen, dass die Webkomponenten auf den Computer des Benutzers heruntergeladen werden, wenn dieser Ihre Datenzugriffsseite öffnet.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Extras auf Optionen, und klicken Sie anschließend auf die Registerkarte Allgemein.

  3. Klicken Sie auf Weboptionen, und klicken Sie anschließend auf die Registerkarte Dateien.

  4. Aktivieren Sie das Kontrollkästchen Office-Webkomponenten downloaden.

  5. Geben Sie im Feld Pfad den Pfad für den Dateiserver ein, z. B. File:\\Mein Server\Mein Ordner.

Anmerkung Benutzer müssen über Zugriff auf den Dateiserver verfügen. Webkomponenten können nicht heruntergeladen werden, wenn Firewalls vorhanden sind.


 Verwenden von Tastenkombinationen in der Seitenansicht

Verwenden von Tastenkombinationen in der Seitenansicht

Anmerkung Um die folgenden Tasten zu verwenden, drücken Sie wiederholt TAB, bis das Erweiterungssymbol oder die Datensatznavigationsleiste angezeigt wird. Wird derzeit ein PivotTable-Listen- oder ein Spreadsheet-Steuerelement angezeigt, drücken Sie STRG+TAB.

Taste | Zweck
LEERTASTE oder EINGABETASTE | Einblenden oder Ausblenden einer Gruppe von Datensätzen, die dem Erweiterungssymbol auf einer gruppierten Datenzugriffsseite entsprechen.
NACH-LINKS- oder NACH-RECHTS-TASTE | Auswählen einer Schaltfläche auf der Datensatznavigationsleiste.
LEERTASTE oder EINGABETASTE | Aktivieren der ausgewählten Schaltfläche auf der Datensatznavigationsleiste.


 Verwenden von Tastenkombinationen für die Dialogfelder "Öffnen", "Neue Datenbankdatei" und "Exportieren"

Verwenden von Tastenkombinationen für die Dialogfelder "Öffnen", "Neue Datenbankdatei" und "Exportieren"

Taste | Zweck
ALT+1 | Wechseln zum vorherigen Ordner ( [image] )
ALT+2 | Öffnen des Ordners, der sich eine Ebene über dem geöffneten Ordner befindet (Schaltfläche Aufwärts [image] )
ALT+3 | Schließen des Dialogfeldes und Öffnen der World Wide Web-Suchseite (Schaltfläche Im Web suchen [image] )
ALT+4 | Löschen des ausgewählten Ordners bzw. der ausgewählten Datei (Schaltfläche Löschen [image] )
ALT+5 | Erstellen eines neuen Unterordners in dem geöffneten Ordner (Schaltfläche Neuen Ordner erstellen [image] )
ALT+6 | Wechseln zwischen den Ansichten Liste, Details, Eigenschaften und Vorschau
ALT+7 | Anzeigen des Menüs Extras (Schaltfläche Extras)


Welche Assistenten werden installiert?

Zu folgenden Themen stehen Informationen zur Verfügung:

Assistenten, die installiert werden, wenn Sie im Setup-Programm die Komponente Standardassistenten auswählen

Assistenten, die installiert werden, wenn Sie im Setup-Programm die Komponente Weitere Assistenten auswählen

Assistenten, die installiert werden, wenn Sie im Setup-Programm die Komponente "Standardassistenten" auswählen

AutoWähler | HTML-Verknüpfungs-Assistent
AutoFormular-Assistent | Verknüpfungs-Assistent für Kalkulationstabellen
AutoFormat-Assistent | Textverknüpfungs-Assistent
AutoSeiten-Assistent | Listenfeld-Assistent
AutoBericht-Assistent | Nachschlage-Assistent
Kombinationsfeld-Assistent | Microsoft Word-Seriendruck-Assistent
Befehlsschaltflächen-Assistent | Seiten-Assistent
Kreuztabellenabfrage-Assistent | Seitenkombinationsfeld-Assistent
Datenbank-Assistent | Seitenbefehlsschaltflächen-Assistent
Export-Assistent | Seitenlistenfeld-Assistent
Feld-Generator | Bild-Generator
Formular-Assistent | PivotTable-Assistent
Exchange/Outlook-Import-Assistent | Assistent zum Drucken von Beziehungen
HTML-Import-Assistent | Bericht-Assistent
Import-Assistent für Kalkulationstabellen | Auswahlabfrage-Assistent
Textimport-Assistent | Übersichts-Manager
Etiketten-Assistent | Tabellen-Assistent
Exchange/Outlook-Verknüpfungs-Assistent |

Zurück zum Anfang

Assistenten, die installiert werden, wenn Sie im Setup-Programm die Komponente "Weitere Assistenten" auswählen

Add-In-Manager | Generator für ODBC-Verbindungszeichenfolgen
Assistent zur Datenbankaufteilung | Optionsgruppen-Assistent
Dokumentierer | Teilreplikations-Assistent
Abfrage-Assistent zur Duplikatsuche | Assistent zur Leistungsanalyse
Abfrage-Assistent zur Inkonsistenzsuche | Sicherheits-Assistent
Diagramm-Assistent | Unterformular/-berichts-Assistent
Eingabeformat-Assistent | Feldverknüpfungs-Assistent für Unterformulare/-berichte
Tabellenverknüpfungs-Manager | Tabellenanalyse-Assistent
Assistent zur Konvertierung eines Makros in ein Modul | Upsizing-Assistent
Microsoft SQL Server Datenbank-Assistent |

Zurück zum Anfang

Anmerkung Die folgenden Assistenten werden immer installiert: Farb-Generator, Ausdrucks-Generator und Abfrage-Generator.


Arbeiten mit dem Euro-Symbol

Microsoft Access 2000 bietet vollständige Unterstützung für das Anzeigen, Eingeben und Drucken des Euro-Symbols Euro-Symbol. Falls Sie Microsoft Windows 95 oder Microsoft Windows NT Workstation 4.0 verwenden, müssen Sie möglicherweise die Microsoft-Eurowährungsunterstützung auf Ihrem Computer hinzufügen.

Eingeben des Euro-Symbols Verwenden Sie zur Eingabe des Euro-Symbols [image] folgende Tasten:

Taste | Tastatur
ALT+0128 (Zifferntastenblock) | US-amerikanische Tastaturen
ALT GR+E | Europäische Tastaturen
ALT GR+Epsilon | Griechische Tastaturen
ALT GR+5 | Griechisch-lateinische und US-internationale Tastaturen
ALT+0136 (Zifferntastenblock) | Kyrillische Tastaturen

Anzeigen des Euro-Symbols Die Schriftarten, die zum Anzeigen des Euro-Symbols erforderlich sind, werden bei der Installation von Access installiert. Im Folgenden werden die Schriftarten aufgeführt, die zum Anzeigen des Euro-Symbols verwendet werden können:

Betriebssystem | Schriftarten
Microsoft Windows 95, Windows 98 | Arial, Courier, Tahoma, Times
Microsoft Windows NT oder Windows 2000 | Arial, Courier, Lucida Console, MS Sans Serif, Tahoma, Times

Drucken des Euro-Symbols Ist das Euro-Symbol in keiner der Druckerschriftarten enthalten, wird an Stelle des Euro-Symbols ein Kästchen gedruckt. Wenden Sie sich an den Druckerhersteller, um aktualisierte Druckerschriftarten zu erhalten, in denen das Euro-Symbol enthalten ist.


 ALL-, DISTINCT-, DISTINCTROW-, TOP-Prädikate

ALL-, DISTINCT-, DISTINCTROW-, TOP-Prädikate

In Microsoft Access entspricht das Verwenden des reservierten Wortes DISTINCT dem Einstellen der Eigenschaft UniqueValues auf Ja im Abfrage-Eigenschaftenfenster in der Abfrageentwurfsansicht.

Das Verwenden des reservierten Wortes DISTINCTROW entspricht dem Einstellen der Eigenschaft UniqueRecords auf Ja (den Standardwert) im Abfrage-Eigenschaftenfenster in der Abfrageentwurfsansicht.

Das Verwenden des reservierten Wortes TOP entspricht dem Einstellen der Eigenschaft TopValues im Abfrage-Eigenschaftenfenster in der Abfrageentwurfsansicht oder der Eingabe eines Wertes im Feld Spitzenwerte Listenfeld "Spitzenwerte" in der Symbolleiste Abfrage Datenblatt.

Das Verwenden des reservierten Wortes PERCENT entspricht dem Verwenden des Prozentzeichens (%) mit der Eigenschaft TopValues im Abfrage-Eigenschaftenfenster oder im Feld Spitzenwerte.


ALL-, DISTINCT-, DISTINCTROW-, TOP-Prädikate - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zwei neue Tabellen entsprechend dem nachstehenden Muster. Erstellen Sie dann eine neue Abfrage in der Datenbank Nordwind, und schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Tabelle "Kunden"

Vorname | Kunden-Nr
Hans | 1
Adam | 2
Ulla | 3
Hans | 4

Tabelle "Rechnungen"

Kunden-Nr | Rechnungs-Nr
1 | 1
1 | 2
2 | 3
2 | 4
2 | 5
4 | 6
4 | 7

Das folgende Beispiel liefert alle Datensätze, die durch eine Exklusionsverknüpfung der beiden Tabellen zurückgegeben wurden. Das Abfrageergebnis ist aktualisierbar.

SELECT ALL Vorname FROM Kunden INNER JOIN Rechnungen
ON Kunden.[Kunden-Nr] = Rechnungen.[Kunden-Nr];
Ergebnis | Aktualisierbar
Hans Hans Adam Adam Adam Hans Hans | Ja

Das folgende Beispiel wählt von den Datensätzen, die durch eine Exklusionsverknüpfung der beiden Tabellen zurückgegeben wurden, nur solche mit eindeutigen Werten aus. Das Abfrageergebnis ist nicht aktualisierbar.

SELECT DISTINCT Vorname FROM Kunden
    INNER JOIN Rechnungen
    ON Kunden.[Kunden-Nr] = Rechnungen.[Kunden-Nr];
Ergebnis | Aktualisierbar
Hans Adam | Nein

Das folgende Beispiel wählt nur die eindeutigen Datensätze aus, die durch eine Exklusionsverknüpfung der beiden Tabellen zurückgegeben wurden. Das Abfrageergebnis ist aktualisierbar.

SELECT DISTINCTROW Vorname FROM Kunden
    INNER JOIN Rechnungen
    ON Kunden.[Kunden-Nr] = Rechnungen.[Kunden-Nr];
Ergebnis | Aktualisierbar
Hans Adam Hans | Ja

Das folgende Beispiel wählt die ersten fünf Datensätze aus, die durch eine Exklusionsverknüpfung der beiden Tabellen zurückgegeben wurden. Das Abfrageergebnis ist aktualisierbar.

SELECT TOP 5 Vorname FROM Kunden
    INNER JOIN Rechnungen
    ON Kunden.[Kunden-Nr] = Rechnungen.[Kunden-Nr]
    ORDER BY Rechnungen.[Rechnungs-Nr];
Ergebnis | Aktualisierbar
Hans Hans Adam Adam Adam | Ja


ALTER TABLE-Anweisung - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Das folgende Beispiel fügt das Feld Gehalt mit dem Datentyp Currency zur Tabelle Personal hinzu.

ALTER TABLE Personal ADD COLUMN Gehalt CURRENCY;

    Das folgende Beispiel entfernt das Feld Gehalt aus der Tabelle Personal.

    ALTER TABLE Personal DROP COLUMN Gehalt;

      Sobald Sie die nächsten beiden Abfragen ausgeführt haben, klicken Sie im Menü Extras auf Beziehungen, um die geänderten Beziehungen anzuzeigen.

      Dieses Beispiel entfernt den bestehenden Fremdschlüssel aus der Tabelle Bestellungen.

      ALTER TABLE Bestellungen DROP CONSTRAINT PersonalBestellungen;

        Das nächste Beispiel fügt den Fremdschlüssel wieder der Tabelle Bestellungen hinzu.

        ALTER TABLE Bestellungen ADD CONSTRAINT PersonalBestellungen FOREIGN KEY ([Personal-Nr]) REFERENCES Personal ([Personal-Nr]);


 Avg-Funktion (Mittelwert)

Avg-Funktion (Mittelwert)

In Microsoft Access können Sie die Funktion Avg im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktion Avg auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktion Avg ist sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellen.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird anschließend im Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Nehmen Sie z.B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Frachtkosten und Ort enthält. Sie können eine Abfrage erstellen, welche die durchschnittlichen Frachtkosten aller Bestellungen für jeden Ort anzeigt, in den Ihre Firma Artikel ausgeliefert hat. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Ort auf den Abfrageentwurfsbereich. Die Zelle Funktion unterhalb des Feldes Ort muss auf Gruppieren nach eingestellt sein. Ziehen Sie das Feld Frachtkosten auf den Abfrageentwurfsbereich, und stellen Sie die darunter liegende Zelle Funktion auf Mittelwert ein. Wenn Sie die Abfrage ausführen, werden darin die durchschnittlichen Frachtkosten je Ort angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung.

SELECT Ort, Avg(Frachtkosten) AS AvgFrachtkosten FROM Bestellungen GROUP BY Ort;

Sie können eine SQL-Anweisung auch in Visual Basic-Code verwenden. Beispielsweise erstellt die folgende Prozedur aus der vorangehenden SQL-Anweisung ein Recordset-Objekt vom Typ Dynaset:

Sub AvgDerFrachtkosten()
    Dim dbs As Database, rst As Recordset, strSQL AS String
    Set dbs = CurrentDb
    strSQL = "SELECT Ort, Avg(Frachtkosten) AS AvgFrachtkosten FROM Bestellungen" _
        & "GROUP BY Ort;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing
End Sub

Wenn Sie die Funktion Avg in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der die Funktion Avg enthält. Um beispielsweise die durchschnittlichen Frachtkosten für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=Avg([Frachtkosten])

Verwenden Sie die Funktion Avg in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


Avg-Funktion (Mittelwert) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die ein Feld namens Frachtkosten enthält. Sie können die Funktion Avg verwenden, um die durchschnittlichen Frachtkosten für Bestellungen mit Frachtkosten über 100 DM zu berechnen. Geben Sie den folgenden Ausdruck in der SQL-Ansicht im Abfragefenster ein:

SELECT Avg([Frachtkosten]) AS [AvgFrachtkosten] FROM Bestellungen WHERE [Frachtkosten] > 100;

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das die durchschnittlichen Frachtkosten für alle zugrundeliegenden Datensätze in einem Formular anzeigt, das auf derselben Tabelle Bestellungen basiert. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestellungen ein. Geben Sie diesen Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Berechnung auf einige Datensätze beschränkt (z.B. auf Bestellungen über DM 100), stellen Sie die Eigenschaft Filter des Formulars ein:

=Avg([Frachtkosten])


 Between...And-Operator (Zwischen...Und)

Between...And-Operator (Zwischen...Und)

In Microsoft Access können Sie den Operator Between...And in einem Abfrageausdruck oder in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Sie können den Operator Between...And in der Zelle Kriterien im Abfrageentwurfsbereich verwenden, um eine Parameterabfrage zu erstellen. Der Operator Between...And ermöglicht Ihnen, den Benutzer zur Eingabe eines Wertebereichs aufzufordern, auf den die Abfrage beschränkt ist. Der für das Argument Wert1 eingegebene Ausdruck dient als Eingabeaufforderung für den Anfang des Wertebereichs, der für das Argument Wert2 eingegebene Ausdruck als Eingabeaufforderung für das Ende des Wertebereichs.

Nehmen Sie z.B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die ein Feld mit dem Namen Bestelldatum enthält. Erstellen Sie eine neue Abfrage im Abfrageentwurfsbereich, und ziehen Sie das Feld Bestelldatum auf die erste Zelle Feld im Entwurfsbereich. Geben Sie in der Zelle Kriterien die folgende Anweisung ein:

Zwischen [Anfangsdatum eingeben:] Und [Enddatum_eingeben:]

    Wenn Sie die Abfrage ausführen, erhalten Sie zuerst in einem Dialogfeld den Hinweis "Anfangsdatum eingeben:". Haben Sie in diesem Dialogfeld einen Wert eingegeben und auf OK geklickt, erhalten Sie in einem zweiten Dialogfeld den Hinweis "Enddatum eingeben:". Wenn Sie gültige Daten eingeben, sind im Ergebnis der Abfrage alle Werte im Feld Bestelldatum enthalten, die zwischen den eingegebenen Terminen liegen (einschließlich der beiden Termine).

    Sie können den Operator Between...And auch in einem berechneten Steuerelement verwenden, um festzustellen, ob der Wert des Steuerelements in einen angegebenen numerischen Bereich fällt. Das folgende Beispiel ermittelt, ob eine Bestellung an einen Ort innerhalb eines bestimmten PLZ-Gebiets versendet wurde. Liegt der Wert des Feldes PLZ zwischen 44135 und 44147, so gibt die Funktion IIf den Wert "Innenstadt" zurück, andernfalls den Wert "Vorort".

    = IIf([PLZ] Zwischen "44135" And "44147"; _
     "Innenstadt"; "Vorort")

    Hat eines der für den Operator Between...And bereitgestellten Argumente den Wert Null, so gibt der Operator Between...And den Wert Null zurück.


 Count-Funktion (Anzahl)

Count-Funktion (Anzahl)

In Microsoft Access können Sie die Funktion Count im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktion Count auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktion Count ist sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellt haben.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird dann im Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Am schnellsten können Sie alle Datensätze in einer Abfrage zählen, indem Sie die Funktion Count(*) in einem berechneten Feld in einer Abfrage verwenden.

Nehmen Sie z.B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Bestell-Nr und Bestimmungsland enthält. Sie können eine Abfrage erstellen, welche die Anzahl der in jeden Bestimmungsland gelieferten Bestellungen anzeigt. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Bestimmungsland auf den Abfrageentwurfsbereich. Stellen Sie die Zelle Funktion unterhalb des Feldes Bestimmungsland auf Gruppieren nach ein.

Erstellen Sie anschließend ein berechnetes Feld, indem Sie den folgenden Ausdruck in eine neue Zelle Feld eingeben:

AnzahlBestellungen: Count(*)

Stellen Sie dann die Zelle Funktion unterhalb dieses Feldes auf Ausdruck ein. Wenn Sie die Abfrage ausführen, wird die Anzahl der in jeden Ort gelieferten Bestellungen angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung:

SELECT Bestimmungsland, Count(*) AS AnzahlBestellungen
FROM Bestellungen GROUP BY Bestimmungsland;

Sie erzielen dasselbe Ergebnis, indem Sie das Feld Bestell-Nr auf den Abfrageentwurfsbereich ziehen und in der darunter liegenden Zelle Funktion auf Count klicken. Diese Abfrage ist ein wenig langsamer als die Abfrage mit Hilfe der Funktion Count(*). Beachten Sie die Unterschiede zur vorangehenden SQL-Anweisung:

SELECT Bestimmungsland, Count([Bestell-Nr]) AS AnzahlBestellungen
FROM Bestellungen GROUP BY Bestimmungsland;

Sie können eine SQL-Anweisung auch in Visual Basic-Code verwenden. Beispielsweise erstellt die folgende Prozedur aus der schnelleren der beiden vorangehenden SQL-Anweisungen ein Recordset-Objekt vom Typ Dynaset:

Sub AnzahlderBestellungen()
    Dim dbs As Database, rst As Recordset, strSQL AS String
    Set dbs = CurrentDb
    strSQL = "SELECT Bestimmungsland, Count(*) _
        AS AnzahlBestellungen FROM Bestellungen " _
        & "GROUP BY Bestimmungsland;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing
End Sub

Wenn Sie die Funktion Count in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der die Funktion Count(Anzahl) enthält. Um beispielsweise die Anzahl an Bestellungen für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=Count([Bestell-Nr])

Verwenden Sie die Funktion Count in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


Count-Funktion (Anzahl) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die ein Feld namens Bestimmungsland enthält. Sie können die Funktion Count zur Berechnung der Anzahl der nach Großbritannien versandten Bestellungen verwenden. Geben Sie den folgenden Ausdruck in der SQL-Ansicht im Abfragefenster ein:

SELECT Count([Bestimmungsland]) AS [GBBestellungen] FROM Bestellungen
WHERE [Bestimmungsland] = 'UK';

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das die Anzahl an Bestellungen in derselben Tabelle Bestellungen anzeigt. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestellungen ein. Geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Zählung auf einige Datensätze beschränkt (z. B. auf Bestellungen, die nach Großbritannien versandt worden sind), stellen Sie die Eigenschaft Filter des Formulars ein:

=Count([Bestimmungsland])


CREATE INDEX-Anweisung - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Das folgende Beispiel erstellt einen Index aus den Feldern Telefon privat und Durchwahl Büro der Tabelle Personal.

CREATE INDEX NeuerIndex ON Personal ([Telefon privat], _
    [Durchwahl Büro]);

Das folgende Beispiel erstellt einen Index aus dem Feld Kunden-Code für die Tabelle Kunden. Die Datensätze dürfen im Feld Kunden-Code keine identischen Werte enthalten, und Null-Werte sind nicht zulässig.

CREATE UNIQUE INDEX [Kunden-Nr] ON Kunden ([Kunden-Code]) _
    WITH DISALLOW NULL;

Um diesen Index zu löschen, müssen Sie die Anweisung DROP verwenden. Sie können den Index in der Tabellenentwurfsansicht nur dann löschen, wenn Sie auch die Beziehung zur Tabelle Kunden löschen. Die folgende Anweisung löscht den neuen Index mit Hilfe der DROP-Anweisung.

DROP INDEX [Kunden-Nr] ON Kunden;

Das folgende Beispiel erstellt einen Index für eine verknüpfte ODBC-Tabelle. Der neue Index ist der Remote-Datenbank nicht bekannt und wirkt sich auf diese in keiner Weise aus. Das folgende Beispiel funktioniert nicht, wenn Sie es in Microsoft Access nur einfügen; Sie müssen zuerst eine ODBC-verknüpfte Tabelle mit dem Namen BestelldetailsODBC erstellen.

CREATE UNIQUE INDEX [Bestell-Nr] ON BestelldetailsODBC _
    ([Bestell-Nr]);


CREATE TABLE-Anweisung, CONSTRAINT-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Das folgende Beispiel erstellt eine neue Tabelle mit zwei Feldern des Datentyps Text.

CREATE TABLE Tabelle1 (Vorname TEXT, _
    Nachname TEXT);

Das nächste Beispiel erstellt eine neue Tabelle mit zwei Feldern des Datentyps Text, einem Feld des Typs Datum/Uhrzeit und einem eindeutigen Index, der aus diesen drei Feldern besteht.

CREATE TABLE Tabelle2 (Vorname TEXT, _
    Nachname TEXT, Geburtsdatum DATETIME, _
    CONSTRAINT Tabelleneinschränkung UNIQUE (Vorname, _
    Nachname, Geburtsdatum));

Das folgende Beispiel erstellt eine neue Tabelle mit zwei Feldern des Typs Text und einem Feld des Datentyps Integer. Das Feld SozVNr ist der Primärschlüssel.

CREATE TABLE Tabelle3 (Vorname TEXT, _
    Nachname TEXT, SozVNr INTEGER
CONSTRAINT Feldeinschränkung PRIMARY KEY);


 DELETE-Anweisung

DELETE-Anweisung

In Microsoft Access wird keine Abfrageergebnisgruppe und kein Datenblatt erstellt, wenn Sie die Anweisung DELETE verwenden. Wenn Sie erfahren möchten, welche Datensätze gelöscht werden, sehen Sie sich zuerst das Datenblatt einer Auswahlabfrage an, welche dieselben Kriterien verwendet, und führen Sie dann eine Löschabfrage aus.


DELETE-Anweisung - Beispiel (MDB)

Um das folgende Beispiel durchzuführen, fügen Sie zuerst einige Datensätze zur Tabelle Personal hinzu Geben Sie in das Feld Position den Eintrag Auszubildender ein.

Dieses Beispiel löscht alle Sätze für Angestellte, deren Position mit Auszubildender angegeben ist. Enthält die FROM-Klausel nur eine Tabelle, müssen Sie den Tabellennamen in der DELETE-Anweisung nicht angeben.

DELETE * FROM Personal WHERE Position = 'Auszubildender';


DROP-Anweisung - Beispiel (MDB)

Um das folgende Beispiel durchzuführen, erstellen Sie für die Tabelle Personal in der Datenbank Nordwind zuerst einen Index mit dem Namen Index1 und dann eine neue Tabelle mit dem Namen Auszubildende. Erstellen Sie in der Beispieldatenbank Nordwind eine neue Abfrage und schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Das folgende Beispiel löscht den Index Index1 aus der Tabelle Personal.

DROP INDEX Index1 ON Personal;

Das nächste Beispiel löscht die Tabelle Auszubildende aus der Datenbank.

DROP TABLE Auszubildende;


 SQL-Ausdrücke

SQL-Ausdrücke

Viele Visual Basic-Funktionen können in SQL-Zeichenfolgen verwendet werden. Sie können Visual Basic-Funktionen wie folgt verwenden: in SQL-Zeichenfolgen, die in Visual Basic eingeschlossen sind, in der SQL-Ansicht des Abfragefensters oder im Rasterbereich des Abfrageentwurfs. Sie können auch eigene Visual Basic-Funktionen schreiben und in SQL-Zeichenfolgen verwenden.

In SQL-Zeichenfolgen eingeschlossene Funktionen müssen einen Wert zurückgeben, der eine Zeichenfolge darstellt oder vom Typ Variant ist. Die Funktion kann nur genau einmal ausgeführt werden. Sie können keine Funktion einschließen, die auf jeden Satz angewendet werden soll, da die SQL-Anweisung nur einmal an die Microsoft Jet-Datenbank-Engine übergeben wird. Beispielsweise können Sie keine Funktion erstellen, die einen Feldwert als Argument übernimmt.

Sie können Visual Basic-Funktionen in einer SQL-Anweisung verwenden, mit der Sie ein QueryDef-Objekt definieren, sowie im Code eines Recordset-Objekts vom Typ Dynaset oder Snapshot. Im Abfrageentwurfsbereich von Microsoft Access können Sie Visual Basic-Funktionen in SQL-Anweisungen, in Ausdrücken für Kriterien und in Ausdrücken für berechnete Felder angeben.


SQL-Ausdrücke: Beispiel

Das folgende Beispiel erzeugt ein Recordset-Objekt vom Typ Dynaset aus einer SQL-Anweisung. Die SQL-Anweisung schließt die Funktion Year in einer WHERE-Klausel ein, um nur Datensätze für Bestellungen zurückzugeben, die 1996 eingegangen sind.

Sub Bestellungen96()
    Dim dbs As Database, rst As Recordset, strSQL _
        AS String
    Dim fld As Field

    Set dbs = CurrentDb
    strSQL = "SELECT DISTINCTROW [Bestell-Nr], Bestelldatum " _
        & "FROM Bestellungen " _
        & "WHERE ((Year([Bestelldatum])=1996));"
    Set rst = dbs.OpenRecordset(strSQL, dbOpenDynaset)
    rst.MoveLast
    Debug.Print rst.RecordCount
End Sub

Das nächste Beispiel zeigt, wie Sie eine Visual Basic-Funktion in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters angeben können. Die folgende SQL-Anweisung definiert eine Abfrage, die das Feld Empfänger aus der Tabelle Bestellungen anzeigt, die Anzahl der Zeichen in diesem Feld für jeden Datensatz mit der Funktion Len berechnet und das Berechnungsergebnis in einer anderen Spalte anzeigt.

SELECT DISTINCTROW Empfänger, Len([Empfänger])_
    AS LängeEmpfänger
FROM Bestellungen;

Sie können dieselbe Abfrage im Abfrageentwurfsbereich erstellen. Erstellen Sie eine neue Abfrage, und fügen Sie die Tabelle Bestellungen hinzu. Ziehen Sie das Feld Empfänger in die Zelle Feld in der ersten Spalte des Entwurfsbereichs. Erstellen Sie in einer anderen Zelle Feld einen Ausdruck für ein berechnetes Feld, indem Sie den folgenden Ausdruck eingeben:

LängeEmpfänger: Len([Empfänger])


 First-, Last-Funktionen (ErsterWert, LetzterWert)

First-, Last-Funktionen (ErsterWert, LetzterWert)

In Microsoft Access können Sie die Funktionen First und Last im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktionen First und Last auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktionen First und Last sind sehr hilfreich in berechneten Steuerelementen in einem Bericht. Verfügen Sie z. B. über einen Bericht mit dem Namen Bestellung, der nach einem Feld mit dem Namen Bestimmungsland gruppiert und nach einem Feld mit dem Namen Bestelldatum sortiert ist, so können Sie die Funktionen First und Last in berechneten Steuerelementen verwenden, um den Bereich vom ersten bis zum letzten Bestelldatum für jede Gruppierung anzuzeigen. Damit Sie nach dem Feld Bestimmungsland gruppieren können, klicken Sie in der Symbolleiste Berichtsentwurf auf die Schaltfläche Sortieren und gruppieren [image] . Wählen Sie in der Spalte Feld/Ausdruck den Eintrag Bestimmungsland, und stellen Sie die Eigenschaften GroupHeader und GroupFooter auf Ja ein. Erstellen Sie in der Entwurfsansicht zwei neue Textfelder im Fußbereich für Bestimmungsland, und stellen Sie die Eigenschaft ControlSource für beide Felder auf die folgenden Ausdrücke ein:

=First([Bestelldatum])
=Last([Bestelldatum])

Wechseln Sie zur Seitenansicht, so sehen Sie jeweils das erste und letzte Bestelldatum für jede Gruppe von Bestellungen.

Anmerkungen Wenn Sie den ersten bzw. letzten Datensatz in einer Gruppe von Datensätzen in Access 2000 zurückgeben möchten, erstellen Sie eine Abfrage, die entweder aufsteigend oder absteigend sortiert und deren Eigenschaft TopValues auf 1 eingestellt ist. Weitere Informationen finden Sie unter dem Hilfethema "TopValues-Eigenschaft (Hohe Werte)". Aus Visual Basic können Sie auch eine sortierte Ergebnisgruppe der Abfrage erstellen und die DAO-Methoden MoveFirst oder MoveLast verwenden, um den ersten oder letzten Datensatz in einer Gruppe von Datensätzen zurückzugeben.

Bei Access-Projekten (.adp) werden die First- undLast -Funktionen ausgeführt, als ob die zugrundeliegenden Angaben nicht sortiert wären. Die Funktion gibt denn ersten Eintrag aus, der den in der Funktion festgelegten Kriterien entspricht und nicht den ersten oder letzten passenden Eintrag in den zugrundeliegenden Angaben.


 FROM-Klausel

FROM-Klausel

Wenn Sie einen Abfrage- oder Tabellennamen in der Klausel FROM einer SQL-Anweisung angeben, wird diese Abfrage oder Tabelle automatisch dem Abfragefenster hinzugefügt.

Analog dazu wird jede Tabelle oder Abfrage, die Sie dem Abfragefenster hinzufügen, in die Klausel FROM der entsprechenden SQL-Anweisung eingetragen.


 GROUP BY-Klausel

GROUP BY-Klausel

Das Angeben der Klausel GROUP BY in einer SQL-Anweisung entspricht dem Erstellen einer Berechnungsabfrage im Abfragefenster und dem Einstellen der Zelle Funktion für das zugehörige Feld auf Gruppieren nach.


GROUP BY-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel ermittelt für jeden Lieferanten den durchschnittlichen Einzelpreis aller Artikel und gruppiert die Preisliste nach Lieferanten.

SELECT [Lieferanten-Nr], Avg(Einzelpreis) AS DurchschnittEinzelpreis
FROM Artikel GROUP BY [Lieferanten-Nr];

Das folgende Beispiel ermittelt in jeder Kategorie den höchsten Einzelpreis eines Artikels.

SELECT [Kategorie-Nr], Max(Einzelpreis) AS MaxEinzelpreis
FROM Artikel GROUP BY [Kategorie-Nr];

Das folgende Beispiel ermittelt, wie viele Bestellungen jedem Angestellten in der Datenbank zugeordnet sind.

SELECT [Personal-Nr], Count([Bestell-Nr]) AS AnzahlBestellungen
FROM Bestellungen GROUP BY [Personal-Nr];


HAVING-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel ermittelt alle Lieferanten, deren Artikel einen durchschnittlichen Einzelpreis über 40 DM aufweisen.

SELECT [Lieferanten-Nr], Avg(Einzelpreis) AS DurchschnittEinzelpreis
FROM Artikel GROUP BY [Lieferanten-Nr]
HAVING (Avg(Einzelpreis)>40);

Das folgende Beispiel wählt alle Angestellten aus, die mehr als 100 Bestellungen entgegengenommen haben.

SELECT [Personal-Nr], Count([Bestell-Nr]) AS AnzahlBestellungen
FROM Bestellungen GROUP BY [Personal-Nr]
HAVING Count([Bestell-Nr]) > 100;


INNER JOIN-Operation - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel erstellt zwei Gleichheitsverknüpfungen: eine zwischen den Tabellen Bestelldetails und Bestellungen und eine andere zwischen den Tabellen Bestellungen und Personal. Beide Verknüpfungen sind erforderlich, da die Tabelle Personal keine Umsatzzahlen und die Tabelle Bestelldetails keine Personaldaten enthält. Die Abfrage erstellt eine Liste der Angestellten und ihrer Gesamtumsätze.

SELECT DISTINCTROW Sum(Einzelpreis * Anzahl)
    AS Umsatz, Vorname & " " & Nachname
    AS Name FROM Personal
    INNER JOIN(Bestellungen INNER JOIN [Bestelldetails]
    ON Bestellungen.[Bestell-Nr] = [Bestelldetails].[Bestell-Nr])
    ON Personal.[Personal-Nr] = Bestellungen.[Personal-Nr]
    GROUP BY Vorname & " " & Nachname;


In-Operator - Beispiel (MDB)

Um das folgende Beispiel in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel verwendet die Tabelle Bestellungen, um eine Abfrage mit Bestellungen zu erstellen, die nach Colchester, Hedge End oder London geliefert werden.

SELECT * FROM Bestellungen WHERE Ort In ('Colchester','Hedge End','London');


 In-Operator (In)

In-Operator (In)

In Microsoft Access können Sie den Operator In in einem Abfrageausdruck oder in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Sie können den Operator In in einem Abfrageausdruck verwenden, wenn Sie Kriterien angeben müssen. Nehmen Sie z.B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Bestimmungsland und Bestell-Nr enthält, und dass Sie eine Abfrage erstellen möchten, die alle Bestellungen auflistet, die in die Vereinigten Staaten, nach Kanada oder nach Großbritannien versendet wurden. Erstellen Sie eine neue Abfrage im Abfragefenster, und fügen Sie die Tabelle Bestellungen hinzu. Ziehen Sie das Feld Bestell-Nr und das Feld Bestimmungsland auf den Abfrageentwurfsbereich. Geben Sie den folgenden Ausdruck in der Zelle Kriterien unterhalb des Feldes Bestimmungsland ein:

In('USA'; 'Kanada'; 'Großbritannien')

Wenn Sie die Abfrage ausführen, werden alle Bestellungen angezeigt, die in eines dieser drei Länder versendet wurden.

Sie erzielen dasselbe Ergebnis, wenn Sie den folgenden Ausdruck in die Zelle Kriterien eingeben:

"USA" Oder "Kanada" Oder "Großbritannien"

Bei einer langen Kriterienliste ist es übersichtlicher, den Operator In an Stelle des Operators Or zu verwenden. Außerdem ist die SQL-Anweisung für den Ausdruck, der den Operator In verwendet, kürzer.

Sie können den Operator In in einem berechneten Steuerelement verwenden, um festzustellen, ob sich der Wert eines Feldes des aktuellen Datensatzes innerhalb einer Gruppe von Werten befindet. Sie können z.B. den Operator In zusammen mit der Funktion IIf verwenden, um festzustellen, ob der Wert eines Steuerelements aus einer Gruppe bestimmter Werte stammt. Im folgenden Beispiel gibt die Funktion IIf "Lokal" zurück, wenn der Wert im Feld Region WA, OR oder ID entspricht. Andernfalls gibt die Funktion "Nicht lokal" zurück.

=IIf([Region] In ('WA';'OR';'ID'); "Lokal"; _
     "Nicht lokal")


 INSERT INTO-Anweisung

INSERT INTO-Anweisung

Wenn Sie eine INSERT INTO...VALUES-Abfrage in der SQL-Ansicht erstellen, speichern, schließen und erneut öffnen, sehen Sie, dass Microsoft Access die Klausel VALUES in die Klausel SELECT umgewandelt hat. Dadurch werden die Ergebnisse der Abfrage nicht verändert.

Das Verwenden der Anweisung INSERT INTO entspricht der Einstellung der Eigenschaft DestinationTable im Eigenschaftenfenster einer Anfügeabfrage in der Abfrageentwurfsansicht.


INSERT INTO-Anweisung - Beispiel (MDB)

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Um das folgende Beispiel durchzuführen, erstellen Sie zuerst eine Kopie der Tabelle Kunden mit dem Namen NeuKunden. Das Beispiel wählt alle Datensätze der Tabelle NeuKunden aus und fügt sie zur Tabelle Kunden hinzu. Wenn Sie einzelne Felder nicht angeben, müssen die Feldnamen in der SELECT-Tabelle und in der INSERT INTO-Tabelle genau übereinstimmen.

INSERT INTO Kunden SELECT * FROM NeuKunden;

Das folgende Beispiel erstellt einen neuen Datensatz in der Tabelle Personal.

INSERT INTO Personal (Vorname, Nachname, Position)
    VALUES ('Harry', 'Washington', 'Auszubildender');

Das folgende Beispiel wählt aus der hypothetischen Tabelle Auszubildende alle Auszubildenden aus, die vor mehr als 30 Tagen eingestellt wurden, und fügt deren Datensätze zur Tabelle Personal hinzu.

INSERT INTO Personal SELECT Auszubildende.* FROM Auszubildende
    WHERE Einstellung < Now() - 30;

Sie können die INSERT INTO-Klausel verwenden, um Informationen in der Datenbank zu sichern, bevor sie geändert werden. Beispielsweise können Sie die Informationen in der Tabelle Personal sichern, unmittelbar bevor ein Benutzer Daten in der Tabelle ändert.

Um das folgende Beispiel durchzuführen, kopieren Sie zuerst im Datenbankfenster die Tabelle Personal wie folgt in eine neue Tabelle mit dem Namen Personalchronik: Klicken Sie auf die Tabelle, klicken Sie dann in der Symbolleiste zuerst auf Kopieren und dann auf Einfügen. Klicken Sie im Dialogfeld Tabelle einfügen als unter Einfügeoptionen auf Nur Struktur. Dadurch wird nur die Tabellenstruktur ohne Daten kopiert. Fügen Sie anschließend die folgende SQL-Anweisung in eine neue Abfrage ein, und speichern Sie die Abfrage als Sicherungsabfrage.

INSERT INTO Personalchronik (Vorname, Nachname, Position)
    VALUES (Formulare!Personal!Vorname, _
        Formulare!Personal!Nachname,Formulare!Personal!Position);

Öffnen Sie das Formular Personal in der Entwurfsansicht,, und stellen Sie die Eigenschaft VorAktualisierung des Formulars auf [Ereignisprozedur] ein. Geben Sie in die BeforeUpdate-Ereignisprozedur folgenden Code ein:

DoCmd.OpenQuery "Sicherungsabfrage"

Die bestehenden Daten in der Tabelle Personal werden jetzt jedesmal, bevor ein Benutzer Daten ändert, in die Sicherungstabelle kopiert.


IN-Klausel - Beispiel (MDB)

Die folgende Tabelle zeigt, wie Sie mit der IN-Klausel Daten aus einer externen Datenbank abrufen können. Die Beispiele gehen davon aus, dass die Tabelle Kunden in einer externen Datenbank gespeichert ist.

Anmerkung Die SQL-Klausel IN unterscheidet sich vom SQL-Operator In. Mit letzterem wird ermittelt, ob der Wert eines Ausdrucks mit einem Wert in einer angegebenen Liste übereinstimmt.

Externe Datenbank SQL-Anweisung
Microsoft Jet-Datenbank.

JETDATEN.MDB ist der Name der Jet-Datenbank mit der Tabelle Kunden.

 SELECT [Kunden-Code]
FROM Kunden
IN 'C:\Dokumente\JetDaten.mdb'
WHERE [Kunden-Code] Like 'A*';
Microsoft Excel-Arbeitsmappe (.XLS-Datei).

XLDATEN.XLS ist eine Microsoft Excel-Arbeitsmappe, die das Tabellenblatt Kunden enthält. KundenBereich ist ein benannter Bereich dieses Tabellenblatts. Beachten Sie, dass Sie ein Dollarzeichen ($) anfügen und den Namen in eckige Klammern einschließen müssen, wenn Sie das gesamte Tabellenblatt als Tabelle angeben möchten.

 SELECT [Kunden-Code], Firmenname
FROM [Kunden$]
IN 'C:\Dokumente\XLDaten.xls' 'EXCEL 5.0;'
WHERE [Kunden-Code] Like 'A*';

- oder -

SELECT [Kunden-Code], Firmenname
FROM KundenBereich
IN 'C:\Dokumente\XLDaten.xls' 'EXCEL 5.0;'
WHERE [Kunden-Code] Like 'A*';
dBASE III oder dBASE IV.

Um Daten aus einer dBASE III-Tabelle abzurufen, ersetzen Sie "dBASE IV "durch "dBASE III".

 SELECT KundenCode
FROM Kunden
IN C:\DBASE\DATEN\VERKAUF dBASE IV;
WHERE KundenCode Like A*;
dBASE III oder dBASE IV (mit DATABASE-Syntax).

Um Daten aus einer dBASE III -Tabelle abzurufen, ersetzen Sie "dBASE IV "durch "dBASE III".

 SELECT KundenCode
FROM Kunden
IN [dBASE IV;DATABASE=C:\DBASE\DATEN\VERKAUF;]
WHERE KundenCode Like A*;
Paradox 3.x oder 4.x.

Um Daten aus einer Paradox-Tabelle der Version 3.x abzurufen, ersetzen Sie "Paradox 4.x " durch "Paradox 3.x".

 SELECT [Kunden-Code]
FROM Kunden
IN C:\PARADOX\DATEN\VERKAUF Paradox 4.x;
WHERE [Kunden-Code] Like A*;
Paradox 3.x oder 4.x (mit DATABASE-Syntax).

Um Daten aus einer Paradox-Tabelle der Version 3.x abzurufen, ersetzen Sie "Paradox 4.x "durch "Paradox 3.x".

 SELECT [Kunden-Code]
FROM Kunden
IN [Paradox 4.x;DATABASE=C:\PARADOX\DATEN\VERKAUF;]
WHERE [Kunden-Code] Like A*;


LEFT JOIN-, RIGHT JOIN-Operationen - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Beispieldatenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel wählt alle Kunden aus (auch Kunden ohne Bestellungen).

SELECT Kunden.[Kunden-Code], Firma, [Bestell-Nr]
FROM Kunden
LEFT JOIN Bestellungen
ON Kunden.[Kunden-Code] = Bestellungen.[Kunden-Code]
ORDER BY [Bestell-Nr];

Das folgende Beispiel wählt alle Lieferanten aus (auch Lieferanten ohne Artikel). Bevor Sie dieses Beispiel durchführen, führen Sie die folgende Abfrage aus, um einen Datensatz zur Tabelle Lieferanten hinzuzufügen.

INSERT INTO Lieferanten (Firma, Kontaktperson, _
    Position)
VALUES ('Acme GmbH', 'Paulchen Löwe', _
    'Vertriebsmanager')

Erstellen Sie anschließend eine neue Abfrage, fügen Sie die folgende SQL-Anweisung in das SQL-Fenster ein, und führen Sie die Abfrage aus.

SELECT Lieferanten.[Lieferanten-Nr], Lieferanten.Firma, _
    Artikel.[Artikel-Nr], Artikel.Artikelname
    FROM Artikel RIGHT JOIN Lieferanten ON Artikel.[Lieferanten-Nr] = _
    Lieferanten.[Lieferanten-Nr]
    ORDER BY Artikel.[Lieferanten-Nr];

Um den Datensatz zu löschen, den Sie der Tabelle Lieferanten hinzugefügt haben, führen Sie folgende Abfrage aus:

DELETE * FROM Lieferanten
WHERE Firma = 'Acme GmbH';


 Like-Operator (Wie)

Like-Operator (Wie)

In Microsoft Access können Sie den Operator Like in einem Abfrageausdruck oder in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Sie können den Operator Like verwenden, um "ungenaue" oder "unscharfe" Kriterien im Abfrageentwurfsbereich anzugeben. Geben Sie z.B. Like "C*" in der Zelle Kriterien des Abfrageentwurfsbereichs ein, so gibt die Abfrage alle Feldwerte zurück, die mit dem Buchstaben C beginnen.

In einer Parameterabfrage können Sie den Operator Like verwenden, um den Benutzer zur Eingabe eines Suchmusters aufzufordern. Nehmen Sie z.B. an, dass Sie über eine Tabelle mit dem Namen Personal verfügen, die ein Feld mit dem Namen Nachname enthält. Erstellen Sie im Abfragefenster eine neue Abfrage, indem Sie die Tabelle Personal hinzufügen und das Feld Nachname auf den Entwurfsbereich ziehen. Geben Sie den folgenden Ausdruck in der Zelle Kriterien ein:

Like [Bitte die ersten Buchstaben des Namens eingeben:]&"*"

Wird die Abfrage ausgeführt, so wird ein Dialogfeld mit der Aufforderung an den Benutzer "Bitte die ersten Buchstaben des Namens eingeben:" angezeigt. Gibt der Benutzer Sch im Dialogfeld ein, so sucht die Abfrage nach dem Suchmuster Sch*, d.h. nach allen Namen, die mit den Buchstaben Sch beginnen.

Sie können den Operator Like in einem Ausdruck als Einstellung für die Eigenschaft ValidationRule verwenden. Sie können z.B. die Dateneingabe in einem Textfeld-Steuerelement auf eine ungenaue Angabe beschränken. Geben Sie in der Eigenschaft ValidationRule des Textfeldes folgenden Ausdruck ein:

Like "P[A-F]###"

Daten, die in diesem Textfeld eingegeben werden, müssen mit dem Buchstaben P beginnen, dem ein beliebiger Buchstabe zwischen A und F und anschließend drei Ziffern folgen müssen.


Like-Operator - Beispiel (MDB)

Das folgende Beispiel gibt eine Liste von Angestellten zurück, deren Namen mit den Buchstaben von A bis D beginnen. Um das Beispiel in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie dann das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

SELECT * FROM Personal WHERE Nachname Like '[A-D]*';


 Min-, Max-Funktionen (Min, Max)

Min-, Max-Funktionen (Min, Max)

In Microsoft Access können Sie die Funktionen Min und Max im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktionen Min und Max auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktionen Min und Max sind sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellt haben.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird dann in den Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Nehmen Sie z. B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Frachtkosten und Ort enthält. Sie können eine Abfrage erstellen, welche die minimalen Frachtkosten für die in jeden Ort gelieferten Bestellungen anzeigt. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Ort auf den Abfrageentwurfsbereich. Die Zelle Funktion unterhalb des Feldes Ort muss auf Gruppieren nach eingestellt sein. Ziehen Sie das Feld Frachtkosten auf den Abfrageentwurfsbereich, und stellen Sie die Zelle Funktion unterhalb dieses Feldes auf Min ein. Wenn Sie die Abfrage ausführen, werden die minimalen Frachtkosten für die in jeden Ort gelieferten Bestellungen angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung:

SELECT Ort, Min(Frachtkosten) AS MinFrachtkosten
FROM Bestellungen GROUP BY Ort;

Sie können eine SQL-Anweisung auch in Visual Basic-Code verwenden. Beispielsweise erstellt die folgende Prozedur aus der vorangehenden SQL-Anweisung ein Recordset-Objekt vom Typ Dynaset:

Sub MinDerFrachtkosten()
    Dim dbs As Database, rst As Recordset, strSQL_        As String

    Set dbs = CurrentDb
    strSQL = "SELECT Ort, Min(Frachtkosten) AS MinFrachtkosten FROM Bestellungen" _
    & "GROUP BY Ort;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing
End Sub

Wenn Sie die Funktionen Min und Max in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der eine dieser Funktionen enthält. Um beispielsweise die minimalen Frachtkosten für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=Min([Frachtkosten])

Verwenden Sie die Funktionen Min oder Max in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


Min-, Max-Funktionen (Min, Max) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die die Felder Frachtkosten und Bestimmungsland enthält. Sie können die Funktionen Min und Max verwenden, um die geringsten und die höchsten Frachtkosten der nach Großbritannien versandten Bestellungen zurückzugeben. Geben Sie die folgenden Ausdrücke in der SQL-Ansicht im Abfragefenster ein:

SELECT Min([Frachtkosten]) AS [MinFracht] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

SELECT Max([Frachtkosten]) AS [MaxFracht] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das die geringsten Frachtkosten für alle Datensätze in derselben Tabelle Bestellungen anzeigt. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestellungen ein. Geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Suche auf einige Datensätze beschränkt (z.B. auf Bestellungen, die nach Großbritannien versandt worden sind), stellen Sie die Eigenschaft Filter des Formulars ein:

=Min([Frachtkosten])


 ORDER BY-Klausel

ORDER BY-Klausel

In Microsoft Access sortiert die Klausel ORDER BY die angezeigten Daten nach einem oder mehreren bestimmten Feldern in aufsteigender oder absteigender Reihenfolge. Das Verwenden der Klausel ORDER BY entspricht dem Klicken auf Aufsteigend oder Absteigend in einer Zelle Sortieren im Abfrageentwurfsbereich.


ORDER BY-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Die folgenden SQL-Anweisungen verwenden die ORDER BY-Klausel, um Datensätze alphabetisch und anschließend nach Kategorien zu sortieren.

Das folgende Beispiel sortiert die Datensätze nach dem Feld Nachname in absteigender Reihenfolge (Z bis A).

SELECT Nachname, Vorname FROM Personal
    ORDER BY Nachname DESC;

Das folgende Beispiel sortiert die Datensätze zuerst nach dem Feld Kategorie-Nr und dann nach dem Feld Artikelname.

SELECT [Kategorie-Nr], Artikelname, Einzelpreis
    FROM Artikel ORDER BY [Kategorie-Nr], Artikelname;


 PARAMETERS-Deklaration

PARAMETERS-Deklaration

Bei einer Parameterabfrage werden Sie von Microsoft Access zur Eingabe der Kriterien aufgefordert, wenn die Abfrage ausgeführt wird. Dadurch können Sie eine Abfrage erstellen, die Datensätze auf der Basis benutzerdefinierter Kriterien zurückgibt.

Das Argument Name, das Sie zusammen mit der Deklaration PARAMETERS angeben, stellt den Text zur Verfügung, der in einem Dialogfeld angezeigt wird, wenn Sie die Abfrage ausführen. Microsoft Access erstellt dieses Dialogfeld automatisch für Sie.

Das Verwenden der Deklaration PARAMETERS in der SQL-Ansicht entspricht dem Definieren von Parametern in der Zelle Kriterien des Abfrageentwurfsbereichs.


PARAMETERS-Deklaration - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel fordert den Benutzer zur Eingabe des Nachnamens eines Angestellten auf und verwendet dann diese Eingabe als Abfragekriterium.

PARAMETERS [Geben Sie den Nachnamen ein:] Text;
SELECT *
FROM Personal
WHERE Nachname = [Geben Sie den Nachnamen ein:];

Das folgende Beispiel fordert den Benutzer zur Eingabe einer Kategorie-Nr auf und verwendet dann diese Eingabe als Abfragekriterium.

PARAMETERS [Geben Sie die Kategorie-Nr ein:] Value;
SELECT [Kategorie-Nr], Artikelname, _
    Count([Bestelldetails].[Bestell-Nr]) AS Summe
FROM Artikel
INNER JOIN [Bestelldetails] ON Artikel.[Artikel-Nr] = _
    [Bestelldetails].[Artikel-Nr]
GROUP BY [Kategorie-Nr], Artikelname
HAVING [Kategorie-Nr] = [Geben Sie die Kategorie-Nr ein:];


 PROCEDURE-Klausel

PROCEDURE-Klausel

Wenn Sie eine Klausel PROCEDURE in die SQL-Ansicht kopieren, löscht Microsoft Access die Klausel aus der SQL-Anweisung, sobald Sie zu einer anderen Ansicht wechseln. Das Löschen der Klausel PROCEDURE hat keine Auswirkungen auf die Abfrageergebnisse. Enthält die Klausel PROCEDURE Parameter, so ersetzt Microsoft Access das reservierte Wort PROCEDURE und das Argument Name durch das reservierte Wort PARAMETERS. Die definierten Parameter werden nicht entfernt.


SELECT...INTO-Anweisung - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel wählt alle Datensätze der Tabelle Personal aus und kopiert sie in eine neue Tabelle mit dem Namen PersonalBackup.

SELECT * INTO [PersonalBackup] FROM Personal;

Das folgende Beispiel erstellt eine neue Tabelle mit dem Namen Vertriebsmanager, die nur Personaldatensätze mit dem Eintrag Vertriebsmanager im Feld Position enthält.

SELECT Personal.Vorname, Nachname _
    INTO [Vertriebsmanager]
FROM Personal
WHERE Position = 'Vertriebsmanager';

Das folgende Beispiel erstellt eine Kopie der Tabelle Personal und speichert die neue Tabelle in der hypothetischen Datenbank BACKUP.MDB.

SELECT Personal.* INTO Personal IN Backup.mdb FROM Personal;

Das folgende Beispiel geht von einer Tabelle Vergütung mit den beiden Feldern Personal-Nr und Gehalt aus. Das Beispiel erstellt eine neue Tabelle mit Personal- und Gehaltsdaten für alle Auszubildenden. Die Tabellen Personal und Gehalt stehen in einer 1:1-Beziehung. Die neue Tabelle enthält alle Daten aus der Tabelle Personal und zusätzlich das Feld Gehalt aus der Tabelle Vergütung.

SELECT Personal.*, Gehalt INTO Auszubildende
FROM Personal
INNER JOIN Vergütung ON Personal.[Personal-Nr] = _
    Vergütung.[Personal-Nr]
WHERE Position = 'Auszubildender';


 SELECT-Anweisung

SELECT-Anweisung

Wenn Sie in Microsoft Access in der SQL-Ansicht im Abfragefenster arbeiten, werden Feldnamen (Feld1, Feld2) als Spaltenüberschriften in der Datenblattansicht verwendet. Verwenden Sie das reservierte Wort AS, um eine andere Spaltenüberschrift für eine Spalte im Datenblatt anzuzeigen. Wenn Sie das reservierte Wort AS verwenden, geben die Argumente Alias1 und Alias2 die Spaltennamen an, die beim Anzeigen der abgerufenen Daten in der Datenblattansicht verwendet werden. Das Verwenden der Klausel AS entspricht dem Einstellen der Eigenschaft Alias im Eigenschaftenfenster der Feldliste in der Abfrageentwurfsansicht.

Das folgende Beispiel verwendet den Titel "Geburtstag" als Überschrift für die Spalte des Ergebnisdatenblatts:

SELECT [Geburtsdatum] AS Geburtstag FROM Personal;

Wenn Sie Aggregatfunktionen oder Abfragen verwenden, die mehrdeutige oder mehrfach auftretende Feldnamen zurückgeben, müssen Sie die Klausel AS auch verwenden, um einen alternativen Namen für das Feld anzugeben. Das folgende Beispiel erstellt die Spaltenüberschrift "Personalstärke" in der Datenblattansicht:

SELECT COUNT([Personal-Nr])
AS [Personalstärke] FROM Personal;

Arbeiten Sie mit Datenzugriffsobjekten (DAO) in Visual Basic-Code, so werden die Argumente Feld1 und Feld2 verwendet, um die Field-Objekte im von der Abfrage zurückgegebenen Recordset-Objekt zu benennen. Wenn Sie das reservierte Wort AS angeben, geben die Argumente Alias1 und Alias2 die Spaltenüberschriften an, die als Namen für die Field-Objekte im resultierenden Recordset-Objekt zurückgegeben werden.


SELECT-Anweisung, FROM-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel wählt die Felder Nachname und Vorname aller Datensätze der Tabelle Personal aus.

SELECT Nachname, Vorname FROM Personal;

Das nächste Beispiel wählt alle Felder aus der Tabelle Personal aus.

SELECT * FROM Personal;

Das folgende Beispiel ermittelt, wie viele Datensätze einen Eintrag im Feld PLZ haben, und benennt das zurückgegebene Feld Summe.

SELECT Count(PLZ) AS Summe FROM Kunden;

Das folgende Beispiel zeigt den Einzelpreis der Artikel nach einer 10prozentigen Preiserhöhung an. Die ursprünglichen Einzelpreise werden in der Datenbank nicht geändert.

SELECT Artikelname, Einzelpreis _
    AS Current, Einzelpreis * 1.1 AS NeuerPreisvorschlag
FROM Artikel;

Das folgende Beispiel ermittelt die Anzahl der in der Datenbank gespeicherten Artikel sowie den durchschnittlichen und höchsten Einzelpreis.

SELECT Count(*) AS [Alle Artikel], Avg(Einzelpreis)
    AS [Durchschnittspreis], Max(Einzelpreis)
    AS [TeuersterArtikel] FROM Artikel;

Das folgende Beispiel zeigt für jeden Datensatz der Tabelle Artikel die Felder Artikelname und Einzelpreis an. Im Abfrageergebnis erscheint zwischen den beiden Feldern der Text "hat den Einzelpreis".

SELECT Artikelname, 'hat den Einzelpreis', _
    Einzelpreis FROM Artikel;


 StDev-, StDevP-Funktionen (StAbw, StAbwG)

StDev-, StDevP-Funktionen (StAbw, StAbwG)

In Microsoft Access können Sie die Funktionen StDev und StDevP im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktionen StDev und StDevP auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktionen StDev und StDevP sind sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellt haben.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird dann im Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Nehmen Sie z. B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Frachtkosten und Ort enthält. Sie können eine Abfrage erstellen, welche die Standardabweichung der Frachtkosten für die in jeden Ort gelieferten Bestellungen anzeigt. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Ort auf den Abfrageentwurfsbereich. Die Zelle Funktion unterhalb des Feldes Ort muss auf Gruppieren nach eingestellt sein. Ziehen Sie das Feld Frachtkosten auf den Abfrageentwurfsbereich, und stellen Sie die Zelle Funktion unterhalb dieses Feldes auf StDev ein. Wenn Sie die Abfrage ausführen, wird die Standardabweichung der Frachtkosten für die in jeden Ort gelieferten Bestellungen angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung:

SELECT Ort, StDev(Frachtkosten) AS StDevFrachtkosten
FROM Bestellungen GROUP BY Ort;

Einen SQL-Ausdruck können Sie auch in Visual Basic-Code verwenden. Z. B. erstellt der folgende Code ein Recordset-Objekt vom Typ Dynaset für den vorangegangenen SQL-Ausdruck:

Sub StDevDerFrachtkosten()
    Dim dbs As Database, rst As Recordset, strSQL AS String

    Set dbs = CurrentDb
    strSQL = "SELECT Ort, StDev(Frachtkosten)  " _
    & "AS StDevFrachtkosten, Ort FROM Bestellungen " _
    & "GROUP BY Ort;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing

Wenn Sie die Funktionen StDev oder StDevP in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der eine dieser Funktionen enthält. Um beispielsweise die Standardabweichung der Frachtkosten für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=StDev([Frachtkosten])

Verwenden Sie die Funktionen StDev oder StDevP in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


StDev-, StDevP-Funktionen (StAbw, StAbwG) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die die Felder Frachtkosten und Bestimmungsland enthält. Sie können die Funktionen StDev und StDevP verwenden, um die Standardabweichung der Frachtkosten der nach Großbritannien versandten Bestellungen zurückzugeben. Geben Sie die folgenden Ausdrücke in der SQL-Ansicht im Abfragefenster ein:

SELECT StDev([Frachtkosten]) AS [FrachtAbweichung] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

SELECT StDevP([Frachtkosten]) AS [FrachtAbweichungG] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das die Standardabweichung der Frachtkosten für alle Datensätze in derselben Tabelle Bestellungen anzeigt. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestellungen ein. Geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Suche auf einige Datensätze beschränkt (z. B. auf Bestellungen, die nach Großbritannien versandt worden sind), stellen Sie die Eigenschaft Filter des Formulars ein:

=StDev([Frachtkosten])


SQL-Unterabfragen - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel zeigt alle Bestellungen von rabattfreien Artikeln mit einem Bestellwert, der über dem Durchschnitt liegt.

SELECT [Bestell-Nr], (Einzelpreis * Anzahl) _
    AS Bestellwert FROM [Bestelldetails]
WHERE Rabatt = 0 AND (Einzelpreis * Anzahl) > _
    ALL(SELECT Avg(Einzelpreis * Anzahl)
    FROM [Bestelldetails]);

Das folgende Beispiel gibt zu jedem Artikel, dessen Einzelpreis mit dem von "Aniseed Syrup" übereinstimmt, den Namen und den Einzelpreis zurück.

SELECT Artikelname, Einzelpreis FROM Artikel
WHERE Einzelpreis = (SELECT Einzelpreis FROM [Artikel]
WHERE Artikelname = 'Aniseed Syrup');

Das folgende Beispiel gibt zu jedem Kunden, der im zweiten Quartal 1995 eine Bestellung aufgegeben hat, die Firma und die Kontaktperson zurück.

SELECT Kontaktperson, Firma, Position, Telefon
    FROM Kunden
WHERE [Kunden-Code] IN (SELECT [Kunden-Code] FROM Bestellungen
WHERE Bestelldatum
BETWEEN #04/1/95# AND #06/30/95#);

Das folgende Beispiel wählt die Namen aller Angestellten aus, die mindestens eine Bestellung verbucht haben. Dieser Vorgang kann auch mit einer Exklusionsverknüpfung ausgeführt werden.

SELECT Vorname, Nachname FROM Personal
WHERE EXISTS (SELECT [Bestell-Nr] FROM Bestellungen
WHERE Bestellungen.[Personal-Nr] = Personal.[Personal-Nr]);


 Sum-Funktion (Summe)

Sum-Funktion (Summe)

In Microsoft Access können Sie die Funktion Sum im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktion Sum auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktion Sum ist sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellt haben.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird dann im Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Nehmen Sie z. B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Frachtkosten und Ort enthält. Sie können eine Abfrage erstellen, welche die Summe der Frachtkosten für die in jeden Ort gelieferten Bestellungen anzeigt. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Ort auf den Abfrageentwurfsbereich. Die Zelle Funktion unterhalb des Feldes Ort muss auf Gruppieren nach eingestellt sein. Ziehen Sie das Feld Frachtkosten auf den Abfrageentwurfsbereich, und stellen Sie die Zelle Funktion unterhalb dieses Feldes auf Sum ein. Wenn Sie die Abfrage ausführen, wird die Summe der Frachtkosten je Ort angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung:

SELECT Ort, Sum(Frachtkosten) AS SumFrachtkosten
FROM Bestellungen GROUP BY Ort;

Sie können eine SQL-Anweisung auch in Visual Basic-Code verwenden. Beispielsweise erstellt die folgende Prozedur aus der vorangehenden SQL-Anweisung ein Recordset-Objekt vom Typ Dynaset:

Sub SumDerFrachtkosten()
    Dim dbs As Database, rst As Recordset, strSQL_         AS String

    Set dbs = CurrentDb
    strSQL = "SELECT Ort, Sum(Frachtkosten) AS SumFrachtkosten FROM Bestellungen " _
    & "GROUP BY Ort;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing

Wenn Sie die Funktion Sum in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der diese Funktion enthält. Um beispielsweise die Summe der Frachtkosten für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=Sum([Frachtkosten])

Verwenden Sie die Funktion Sum in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


Sum-Funktion (Summe) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, welche die Felder Bestell-Nr und Bestimmungsland enthält, sowie eine Tabelle mit dem Namen Bestelldetails, welche die Felder Einzelpreis und Anzahl enthält. Sie können die Funktion Sum verwenden, um den Gesamtumsatz der nach Großbritannien versandten Bestellungen zu berechnen. Geben Sie den folgenden Ausdruck in der SQL-Ansicht im Abfragefenster ein:

SELECT Sum([Einzelpreis]*[Anzahl]) AS [GesamtumsatzGB]
FROM Bestellungen INNER JOIN [Bestelldetails] ON Bestellungen.[Bestell-Nr] = [Bestelldetails].[Bestell-Nr]
WHERE ([Bestimmungsland] = 'Großbritannien');

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das den Gesamtumsatz für Datensätze in der Tabelle Bestelldetails anzeigt. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestelldetails ein. Geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Suche auf einige Datensätze beschränkt (z. B. auf Bestellungen, die nach Großbritannien versandt worden sind), stellen Sie die Eigenschaft Filter des Formulars ein:

=Sum([Einzelpreis]*[Menge])


TRANSFORM-Anweisung - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel erstellt eine Kreuztabellenabfrage, die die Artikelumsätze nach Monaten für ein vom Benutzer anzugebendes Jahr anzeigt. Die Monate werden von links nach rechts in Spalten angezeigt (pivotisiert), die Artikelnamen von oben nach unten in Zeilen.

PARAMETERS [Umsatz für das Jahr] LONG;
TRANSFORM Sum([Bestelldetails].Anzahl * _
    ([Bestelldetails].Einzelpreis - _
    ([Bestelldetails].Rabatt / 100) * _
    [Bestelldetails].Einzelpreis)) AS Umsatz
SELECT Artikelname FROM Bestellungen
INNER JOIN (Artikel INNER JOIN [Bestelldetails]
ON Artikel.[Artikel-Nr] = [Bestelldetails].[Artikel-Nr])
ON Bestellungen.[Bestell-Nr] = [Bestelldetails].[Bestell-Nr]
WHERE DatePart("yyyy", Bestelldatum) = _
    [Umsatz für das Jahr]
GROUP BY Artikelname
ORDER BY Artikelname
PIVOT DatePart("m", Bestelldatum);

Das folgende Beispiel erstellt eine Kreuztabellenabfrage, die für jeden Lieferanten die Artikelumsätze nach Quartal für ein vom Benutzer anzugebendes Jahr anzeigt. Die Quartalsnummern werden von links nach rechts in Spalten angezeigt (pivotisiert), die Lieferantennamen von oben nach unten in Zeilen.

PARAMETERS [Umsatz für das Jahr] LONG;
TRANSFORM Sum([Bestelldetails].Anzahl * _
    ([Bestelldetails].Einzelpreis - _
    ([Bestelldetails].Rabatt / 100) * _
    [Bestelldetails].Einzelpreis)) AS Umsatz
SELECT Firma FROM Bestellungen
INNER JOIN ((Lieferanten INNER JOIN Artikel ON Lieferanten.[Lieferanten-Nr] = Artikel.[Lieferanten-Nr])
INNER JOIN [Bestelldetails] ON Artikel.[Artikel-Nr] = _
    [Bestelldetails].[Artikel-Nr])
ON Bestellungen.[Bestell-Nr] = [Bestelldetails].[Bestell-Nr]
WHERE DatePart("yyyy", Bestelldatum) = _
    [Umsatz für das Jahr]
GROUP BY Firma
ORDER BY Firma
PIVOT "Quartal " & DatePart("q", Bestelldatum) _
    In ('Quartal 1', 'Quartal 2', 'Quartal 3', 'Quartal 4');


 UNION-Operation

UNION-Operation

In Microsoft Access können die Argumente der Operation UNION (Abfrage1, Abfrage2,...AbfrageN) eine Anweisung SELECT, der Name einer gespeicherten Microsoft Access-Abfrage oder der Name einer gespeicherten Microsoft Access-Tabelle (dem das reservierte Wort TABLE vorangestellt ist) sein.

Sie können eine Union-Abfrage nur in der SQL-Ansicht ansehen, nicht im Abfrageentwurfsbereich.


UNION-Operation - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel ruft die Namen und Orte aller Lieferanten und Kunden ab, die in Brasilien ansässig sind.

SELECT Firma, Ort FROM Lieferanten
WHERE Land = 'Brasilien'
UNION SELECT Firma, Ort FROM Kunden
WHERE Land = 'Brasilien';

Das folgende Beispiel ruft die Namen und Orte aller Lieferanten und Kunden ab, die in Brasilien ansässig sind, wobei das Abfrageergebnis nach Ort und Quelle sortiert wird.

SELECT Firma, Ort, 'Lieferant' AS Quelle
FROM Lieferanten
WHERE Land = 'Brasilien'
UNION SELECT Firma, Ort, 'Kunde'
FROM Kunden
WHERE Land = 'Brasilien'
ORDER BY Ort, Quelle;

Das folgende Beispiel ruft die Namen und Nummern aller Lieferanten und Kunden ab. Bei dieser UNION-Operation wird angenommen, dass beide Tabellen gleich viele Spalten aufweisen.

TABLE Kunden UNION TABLE Lieferanten;


 UPDATE-Anweisung

UPDATE-Anweisung

Da die UPDATE-Anweisung keine Ergebnisgruppe erzeugt, gibt es kein Abfrage-Datenblatt, das von Microsoft Access angezeigt werden kann, wenn Sie diese Anweisung verwenden.

Möchten Sie jede Änderung bestätigen, so können Sie aus dem Menü Bearbeiten des Formulars oder Datenblatts den Befehl Ersetzen an Stelle einer Aktualisierungsabfrage verwenden.


UPDATE-Anweisung - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Warnung Diese Beispiele ändern die Datenbank Nordwind. Erstellen Sie daher bei Bedarf zuerst eine Sicherungskopie der Beispieldatenbank.

Das folgende Beispiel ändert für alle Personaldatensätze, bei denen das Feld Vorgesetzte(r) momentan den Wert 2 aufweist, diesen Wert auf 5.

UPDATE Personal SET [Vorgesetzte(r)] = 5 WHERE [Vorgesetzte(r)] = _
    2;

Das folgende Beispiel erhöht den Wert des Feldes Einzelpreis für alle Nicht-Auslaufartikel des Lieferanten 8 um 10 Prozent.

UPDATE Artikel SET Einzelpreis = Einzelpreis * 1.1
WHERE [Lieferanten-Nr] = 8 AND Auslaufartikel = No;

Das folgende Beispiel reduziert den Einzelpreis aller von Tokyo Traders gelieferten Nicht-Auslaufartikel um 5 Prozent. Die Tabellen Produkte und Lieferanten stehen in einer n:1-Beziehung zueinander.

UPDATE Lieferanten INNER JOIN Artikel
ON Lieferanten.[Lieferanten-Nr] = Artikel.[Lieferanten-Nr] _
    SET Einzelpreis = Einzelpreis * .95
WHERE Firma = 'Tokyo Traders' _
    AND Auslaufartikel = No;


 Var-, VarP-Funktionen (Varianz, Varianzen)

Var-, VarP-Funktionen (Varianz, Varianzen)

In Microsoft Access können Sie die Funktionen Var und VarP im Abfrageentwurfsbereich, in einer SQL-Anweisung in der SQL-Ansicht des Abfragefensters oder in einer SQL-Anweisung in Visual Basic-Code verwenden. Sie können die Funktionen Var und VarP auch in einem berechneten Steuerelement in einem Formular oder Bericht verwenden.

Die Funktionen Var und VarP sind sehr hilfreich in Berechnungsabfragen und Kreuztabellenabfragen. Die Funktionsweise ist immer gleich, unabhängig davon, ob Sie die Abfrage im Abfrageentwurfsbereich oder als SQL-Anweisung in der SQL-Ansicht erstellt haben.

Im Abfrageentwurfsbereich können Sie eine neue Berechnungsabfrage erstellen, indem Sie auf Funktionen [image] in der Symbolleiste Abfrageentwurf klicken. Die Zeile Funktion wird dann im Entwurfsbereich eingefügt. Sie können die Zelle Funktion unterhalb eines Feldes auf die Aggregatfunktion einstellen, die auf den Daten in diesem Feld ausgeführt werden soll.

Nehmen Sie z. B. an, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die Felder mit den Namen Frachtkosten und Ort enthält. Sie können eine Abfrage erstellen, welche die Varianz der Frachtkosten für die in jeden Ort gelieferten Bestellungen anzeigt. Erstellen Sie eine neue Berechnungsabfrage, und ziehen Sie das Feld Ort auf den Abfrageentwurfsbereich. Die Zelle Funktion unterhalb des Feldes Ort sollte auf Gruppieren nach eingestellt sein. Ziehen Sie das Feld Frachtkosten auf den Abfrageentwurfsbereich, und stellen Sie die Zelle Funktion unterhalb dieses Feldes auf Var ein. Wenn Sie die Abfrage ausführen, wird die Varianz der Frachtkosten für die in jeden Ort gelieferten Bestellungen angezeigt.

Sie können die SQL-Anweisung für diese Abfrage anzeigen, indem Sie zur SQL-Ansicht wechseln. In diesem Beispiel erstellt Microsoft Access die folgende SQL-Anweisung:

SELECT Ort, Var(Frachtkosten) AS VarFrachtkosten
FROM Bestellungen GROUP BY Ort;

Sie können eine SQL-Anweisung auch in Visual Basic-Code verwenden. Beispielsweise erstellt die folgende Prozedur aus der vorangehenden SQL-Anweisung ein Recordset-Objekt vom Typ Dynaset:

Sub VarDerFrachtkosten()
    Dim dbs As Database, rst As Recordset, strSQL_         AS String

    Set dbs = CurrentDb
    strSQL = "SELECT Ort, Var(Frachtkosten) AS VarFrachtkosten FROM Bestellungen" _
    & "GROUP BY Ort;"
    Set rst = dbs.OpenRecordset(strSQL)
    rst.MoveLast
    Debug.Print rst.RecordCount
    Set dbs = Nothing
End Sub

Wenn Sie die Funktionen Var oder VarP in einem berechneten Steuerelement verwenden möchten, müssen Sie die Eigenschaft ControlSource des Steuerelements auf einen Ausdruck einstellen, der eine dieser Funktionen enthält. Um beispielsweise die Varianz der Frachtkosten für eine Gruppe von Bestellungen in einem Textfeld anzuzeigen, geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource des Textfelds ein:

=Var([Frachtkosten])

Verwenden Sie die Funktionen Var oder VarP in einem berechneten Steuerelement, so können Sie die Gruppe von Datensätzen, auf denen die Funktion ausgeführt wird, durch Einstellen der Eigenschaft Filter des Formulars einschränken.


Var-, VarP-Funktionen (Varianz, Varianzen) - Beispiel

Das folgende Beispiel setzt voraus, dass Sie über eine Tabelle mit dem Namen Bestellungen verfügen, die ein Feld namens Frachtkosten enthält. Sie können die Funktionen Var und VarP verwenden, um die Varianz (Abweichung vom Mittelwert) der Frachtkosten der nach Großbritannien versandten Bestellungen zu schätzen. Geben Sie die folgenden Ausdrücke in der SQL-Ansicht im Abfragefenster ein:

SELECT Var([Frachtkosten]) AS [FrachtvarianzGB] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

SELECT VarP([Frachtkosten]) AS [FrachtvarianzenGB] FROM Bestellungen WHERE [Bestimmungsland] = 'Großbritannien';

Das nächste Beispiel erstellt ein berechnetes Steuerelement, das die geschätzte Varianz der Frachtkosten für Datensätze in derselben Tabelle Bestellungen anzeigt. Öffnen Sie ein neues Formular, und stellen Sie dessen Eigenschaft RecordSource auf Bestellungen ein. Geben Sie den folgenden Ausdruck in der Eigenschaft ControlSource eines Textfelds im Formular ein. Damit eine Bedingung angewendet werden kann, welche die Suche auf einige Datensätze beschränkt (z.B. auf Bestellungen, die nach Großbritannien versandt worden sind), stellen Sie die Eigenschaft Filter des Formulars ein:

=Var([Frachtkosten])


 WHERE-Klausel

WHERE-Klausel

In Microsoft Access entsprechen die Bedingungen, die Sie in der Klausel WHERE in der SQL-Ansicht angegeben haben, den Kriterien in der Zelle Kriterien im Abfrageentwurfsbereich. Wenn Sie Kriterien im Abfrageentwurfsbereich eingeben, können Sie zur SQL-Ansicht wechseln, um die Klausel WHERE anzusehen.

Analog dazu können Sie, wenn Sie eine WHERE-Klausel in einer SQL-Anweisung in der SQL-Ansicht eingeben, zur Entwurfsansicht wechseln, um die Kriterien im Abfrageentwurfsbereich anzusehen, solange Sie keine Union-Abfrage erstellen. Union-Abfragen können nur in der SQL-Ansicht angezeigt werden.


WHERE-Klausel - Beispiel (MDB)

Um die folgenden Beispiele in Microsoft Access durchzuführen, erstellen Sie zuerst eine neue Abfrage in der Datenbank Nordwind. Schließen Sie das Dialogfeld Tabelle anzeigen, ohne eine Tabelle oder Abfrage anzugeben. Wechseln Sie zur SQL-Ansicht, fügen Sie das gewünschte Beispiel in das SQL-Fenster ein, und führen Sie die Abfrage aus.

Das folgende Beispiel wählt die Felder Nachname und Vorname aller Datensätze aus, in denen das Feld Nachname den Wert King hat.

SELECT Nachname, Vorname FROM Personal
WHERE Nachname = 'King';

Das folgende Beispiel wählt die Felder Nachname und Vorname für alle Angestellten aus, deren Nachname mit einem "S" beginnt.

SELECT Nachname, Vorname FROM Personal
WHERE Nachname Like 'S*';

Das folgende Beispiel wählt alle Artikel mit einem Einzelpreis zwischen 30 und 75 DM aus.

SELECT Artikelname, Einzelpreis FROM Artikel
WHERE (Einzelpreis >=30.00 And Einzelpreis <= 75.00);

Das folgende Beispiel wählt alle Artikel aus, deren Artikelnamen alphabetisch zwischen "Cha" and "Out" liegen (beide Bezeichnungen eingeschlossen). "Outback Lager" wird hierbei nicht abgerufen, weil "Outback Lager" alphabetisch hinter "Out" und daher außerhalb des angegebenen Bereichs liegt.

SELECT Artikelname, Einzelpreis FROM Artikel
WHERE Artikelname Between 'Cha' And 'Out';

Das folgende Beispiel wählt alle Bestellungen aus, die im ersten Halbjahr 1995 eingegangen sind.

SELECT [Bestell-Nr], Bestelldatum FROM Bestellungen
WHERE Bestelldatum Between #1-1-95# And #6-30-95#;

Das folgende Beispiel wählt alle Bestellungen aus, die in die Regionen Idaho, Oregon oder Washington geliefert wurden.

SELECT [Bestell-Nr], Region FROM Bestellungen
WHERE Region In ('ID', 'OR', 'WA');


 WITH OWNERACCESS OPTION-Deklaration

WITH OWNERACCESS OPTION-Deklaration

Sie können die Deklaration WITH OWNERACCESS OPTION in einer SQL-Anweisung angeben, um den Benutzern das Ausführen einer Abfrage und anschließende Ansehen der Ergebnisse auch dann zu ermöglichen, wenn die Benutzer nicht über Berechtigungen zum Zugriff auf die zugrunde liegenden Tabellen verfügen. Ist diese Option festgelegt, so verfügt ein Benutzer über die gleichen Berechtigungen wie der Besitzer der Abfrage.

Der Besitzer einer Abfrage auf einer Tabelle Personal kann z. B. die Deklaration WITH OWNERACCESS OPTION in der Definition der Abfrage angeben, die alle Felder mit Ausnahme von Feldern mit Personaladressen zurückgibt. Ein Benutzer, der keinen Lesezugriff auf die Tabelle Personal hat, kann die Abfrage ausführen und nur die Felder ansehen, die in der Abfrage enthalten sind. Damit verfügt der Benutzer über einen beschränkten Lesezugriff auf die Tabelle.

Das Verwenden dieser Deklaration entspricht der Einstellung der Eigenschaft RunPermissions auf Besitzer im Abfrage-Eigenschaftenfenster in der Abfrageentwurfsansicht. Das Unterlassen der Deklaration WITH OWNERACCESS OPTION entspricht der Einstellung der Eigenschaft RunPermissions auf Benutzer (die Standardeinstellung).


 Const-Anweisung

Const-Anweisung

Eine Konstante in einem Microsoft Access-Standardmodul ist standardmäßig privat. Leiten Sie sie jedoch mit dem Schlüsselwort Public ein, so steht sie auch in anderen Modulen der aktuellen Datenbank zur Verfügung. Sie ist auch für Module verfügbar, aus denen auf die aktuelle Datenbank verwiesen wird.

Eine Konstante, die in einem Klassenmodul definiert ist, ist in diesem Modul immer privat, und es ist nicht möglich, sie mit Hilfe des Schlüsselworts Public zu einer öffentlichen Variablen zu machen.


 Const-Anweisung: Beispiel

Const-Anweisung: Beispiel

In Microsoft Access können Sie im Deklarationsbereich eines Klassenmoduls keine öffentlichen Konstanten deklarieren. Konstanten in einem Klassenmodul müssen privat sein. Dagegen können Sie öffentliche und private Konstanten im Deklarationsbereich eines Standardmoduls deklarieren.

' In einem Klassenmodul.
Const conProvision As Single = .08

' In einem Standardmodul.
Const conFehlernummer As Integer = 91
Public Const conAdresse As String = _
    "Schönaustraße 9, 44227 Dortmund, Deutschland"


Dynamischer Datenaustausch (DDE) - Beispiel

Das folgende Beispiel stellt eine DDE-Verknüpfung zu Microsoft Excel her, trägt einige Werte in Zellen in der ersten Zeile einer neuen Tabelle ein und gibt die Werte als Diagramm aus. Zuerst öffnet die Funktion DDEInitiate einen Kanal und beginnt mit dem DDE-Datenaustausch. Dann sendet die Anweisung DDEExecute Microsoft Excel den Befehl zum Öffnen einer neuen Tabelle. Mit der Funktion DDERequest wird anschließend der Name der neu erstellten Tabelle von Microsoft Excel abgefragt. Ein neuer Kanal wird geöffnet, und die Anweisung DDEPoke sendet Microsoft Excel die auszugebenden Daten. Schließlich löst die Anweisung DDETerminate die DDE-Verknüpfung mit Microsoft Excel, und die Anweisung DDETerminateAll beendet alle aktiven DDE-Verknüpfungen.

Sub ExcelDDE()
    Dim intI As Integer, intKan1 As Integer
    Dim strThemen As String, strRückgabe As String, strTabellenname As String

' Fehlerbehandlungsroutine einrichten.
    On Error Resume Next

    ' Verknüpfung herstellen.
    intKan1 = DDEInitiate("Excel", "System")
    ' Falls Fehler auftritt, wurde Excel vielleicht
    If Err Then
        ' nicht gestartet. Fehler zurücksetzen
        Err = 0
        ' und Tabellenkalkulation starten.
        Shell "C:\EXCEL\EXCEL.EXE", 1
        ' Bei weiterem Fehler, Programm beenden.
        If Err Then Exit Sub
        ' Verknüpfung zur Tabelle herstellen.
        intKan1 = DDEInitiate("Excel", "System")
    End If

    ' Neue Tabelle anlegen.
    DDEExecute intKan1, "[New(1)]"
    ' Themenliste und Tabellennamen abrufen.
    strThemen = DDERequest(intKan1, "Selection")
    strTabellenname = Left(strThemen, InStr(1, strThemen, "!") - 1)
    ' DDE-Verknüpfung beenden.
    DDETerminate intKan1
    ' Verknüpfung zu neuer Tabelle herstellen.
    intKan1 = DDEInitiate("Excel", strTabellenname)
    For intI = 1 To 10                        ' Einige Werte in
        DDEPoke intKan1, "R1C" & intI, intI    ' erste Zeile eintragen.
    Next intI
    ' Diagramm erstellen.
    DDEExecute intKan1, "[Select(""R1C1:R1C10"")][New(2,2)]"
    ' Alle Verknüpfungen beenden.
    DDETerminateAll
End Sub


 Declare-Anweisung

Declare-Anweisung

In Microsoft Access sind Declare-Anweisungen standardmäßig öffentlich. In einem Standardmodul ist eine öffentliche Declare-Anweisung für alle Prozeduren der aktuellen Datenbank und für alle Prozeduren einer Datenbank verfügbar, aus der auf die Declare-Anweisung verwiesen wird. Sie können eine Declare-Anweisung mit dem Schlüsselwort Private einleiten, um sicherzustellen, dass sie außerhalb des aktuellen Moduls nicht verfügbar ist.

Wenn Sie eine Declare-Anweisung in einem Klassenmodul verwenden möchten, müssen Sie die Anweisung mit dem Schlüsselwort Private einleiten. Wenn Sie das Schlüsselwort Private nicht angeben, meldet Microsoft Access einen Kompilierzeitfehler.


Declare-Anweisung: Beispiel

In Microsoft Access können Sie die Anweisung Declare auf der Modulebene eines Standardmoduls verwenden, um einen Verweis auf eine externe Prozedur einer DLL-Datei (Dynamic Link Library) zu deklarieren. Standardmäßig ist die Anweisung Declare öffentlich. Wenn Sie die Anweisung Declare in einem Klassenmodul verwenden möchten, müssen Sie das Schlüsselwort Private vor die Anweisung setzen.

Im folgenden Beispiel wird ein Verweis auf eine Prozedur einer DLL-Datei deklariert und anschließend diese Prozedur aus Visual Basic aufgerufen.

' In einem Standardmodul.
Declare Sub MessageBeep Lib "User32" (ByVal intN As Integer)

' In einem Klassenmodul.
Private Declare Sub MessageBeep Lib "User32" (ByVal intN _
    As Integer)

' Sobald Sie mit einer Declare-Anweisung einen Verweis
' auf eine Prozedur einer DLL deklariert haben, können
' Sie die Prozedur ganz normal aus dem Code aufrufen.
Sub SystemBeep(intBeeps As Integer, sngPause As Single)
    Dim intI As Integer
    Dim sngStart As Single

    For intI = 1 To intBeeps
        ' Die Systemfunktion aufrufen.
        Call MessageBeep(intBeeps)
        ' Den Anfangszeitpunkt festhalten.
        sngStart = Timer
        ' Eine Pause zwischen den Beeps.
        Do While Timer < sngStart + sngPause
            ' Die Kontrolle an das Betriebssystem zurückgeben.
            DoEvents
        Loop
    Next intI
End Sub


DeleteControl-, DeleteReportControl-Methoden - Beispiel

Dieses Beispiel erstellt ein Formular mit einer Befehlsschaltfläche und zeigt eine Meldung an, in der der Benutzer gefragt wird, ob die Befehlsschaltfläche gelöscht werden soll. Wenn der Benutzer auf Ja klickt, wird die Befehlsschaltfläche gelöscht.

Sub BefehlsschaltflächeLöschen()
    Dim frm As Form, ctlNeu As Control
    Dim strMldg As String, intAntwort As Integer, intDialog As Integer

    ' Ein neues Formular erstellen und den Zeiger auf
    ' das Formular abrufen.
    Set frm = CreateForm
    ' Die neue Befehlsschaltfläche erstellen.
    Set ctlNeu = CreateControl(frm.Name, acCommandButton)
    ' Das Formular wiederherstellen.
    DoCmd.Restore
    ' Die Beschriftung festlegen.
    ctlNeu.Caption = "Neue Befehlsschaltfläche"
    ' Die Größe des Steuerelements festlegen.
    ctlNeu.SizeToFit
    ' Den Benutzer auffordern, das Steuerelement zu löschen.
    strMldg = "" & ctlNeu.Name &" wird gelöscht. Fortfahren?"
    ' Festlegen, welche Schaltflächen im Dialogfeld
    ' angezeigt werden sollen.
    intDialog = vbYesNo + vbCritical + vbDefaultButton2
    intAntwort = MsgBox(strMldg, intDialog)
    If intAntwort = vbYes Then
        ' Das Steuerelement löschen.
        DeleteControl frm.Name, ctlNeu.Name
    End If
End Sub


 Dim-Anweisung

Dim-Anweisung

Sie können das Schlüsselwort New in einer Dim-Anweisung verwenden, um eine Objektvariable eines bestimmten Typs zu deklarieren. Wenn Sie das Schlüsselwort New in Ihre Variablendeklaration einschließen, erstellen Sie automatisch ein neues Objekt und sorgen dafür, dass die Objektvariable auf das Objekt zeigt. Wenn Sie eine Objektvariable mit dem Schlüsselwort New deklarieren, können Sie daher auf die Anweisung Set verzichten.

Mit dem Schlüsselwort New können Sie eine Objektvariable so erstellen, dass sie auf ein Objekt beliebigen Typs zeigt. Wie das nächste Beispiel verdeutlicht, wird das Schlüsselwort New meistens verwendet, um eine neue Instanz einer Klasse oder ein neues Collection-Objekt zu erstellen.

' Eine Objektvariable so erstellen, dass sie auf ein neues Objekt zeigt.
Dim colInstanzen As New Collection

Das folgende Beispiel verdeutlicht, wie das Schlüsselwort New verwendet wird, um eine neue Instanz einer Klasse zu erstellen.

' Eine neue Instanz eines Klassenmoduls erstellen.
Dim obj As New Klasse1

Sie können das Schlüsselwort New zum Erstellen eines neuen Microsoft Access-Objekts aus einigen Komponenten verwenden, die Automatisierung unterstützen, die früher als OLE-Automatisierung bezeichnet wurde. Lesen Sie in der Dokumentation der betreffenden Komponente nach, ob diese Syntax unterstützt wird.

Aus einer anderen Komponente heraus können Sie z. B., sofern Sie einen Verweis auf die Microsoft Access-Typbibliothek eingerichtet haben, ein neues Microsoft Access-Objekt erstellen, indem Sie folgenden Code verwenden.

Dim appAccess As New Access.Application


 Function-Anweisung

Function-Anweisung

In Microsoft Access steht eine öffentliche Funktion allen Prozeduren der aktuellen Datenbank sowie allen Prozeduren einer Microsoft Access-Datenbank zur Verfügung, aus der auf die Funktion verwiesen wird. Für andere Anwendungen ist die Funktion dagegen nicht verfügbar.

Wenn Sie eine Funktion mit dem Schlüsselwort Private als privat deklarieren, steht diese Prozedur nur den anderen Prozeduren desselben Moduls zur Verfügung.

Ist eine Funktion in einem privaten Modul, wie z. B. einem Klassenmodul, als öffentlich deklariert, steht diese Prozedur allen anderen Prozeduren dieser Datenbank zur Verfügung; für andere Microsoft Access-Datenbanken ist sie dagegen nicht verfügbar.


 Option Compare-Anweisung

Option Compare-Anweisung

In Microsoft Access enthalten alle Module standardmäßig die Anweisung Option Compare Database im Deklarationsbereich. Diese Anweisung legt die Methode für den Zeichenfolgenvergleich in dem Modul auf die Methode fest, die für die gesamte Datenbank angegeben wurde.

Sie können die Zeichenfolgenvergleichsmethode für die Datenbank ändern, indem Sie aus dem Menü Extras den Befehl Optionen wählen und den Wert im Feld Sortierreihenfolge bei neuer DB in der Registerkarte Standard des Dialogfelds Optionen ändern. Standardmäßig ist dieser Wert auf Standard festgelegt, d.h., die Sortierung erfolgt unabhängig von der Groß-/Kleinschreibung basierend auf dem deutschen Alphabet.

Änderungen der Option Sortierreihenfolge bei neuer DB haben keinen Einfluss auf die Zeichenfolgenvergleichsmethode der aktuellen Datenbank. Sie beziehen sich nur auf Datenbanken, die erstellt wurden, nachdem die Option eingestellt wurde.

Sie können eine Zeichenfolgenvergleichsmethode für ein einzelnes Modul angeben, die sich von der für die Datenbank angegebenen Methode unterscheidet, indem Sie Option Compare Database in Option Compare Binary oder Option Compare Text ändern. Mit der Anweisung Option Compare Binary legen Sie fest, dass Zeichenfolgen basierend auf den ASCII-Werten verglichen werden, die den jeweiligen Zeichen entsprechen, so dass der Vergleich von der Groß-/Kleinschreibung abhängig ist. Bei Verwendung von Option Compare Text ist der Vergleich von der Groß-/Kleinschreibung unabhängig.

Anmerkung Wenn Sie die Eigenschaft Bookmark eines Recordset-Objekts verwenden, müssen Sie die Anweisung Option Compare Binary im Deklarationsbereich des Moduls angeben. Die Einstellung und der Rückgabewert der Eigenschaft Bookmark sind Datenfelder vom Typ Variant mit Daten vom Typ Byte. Wenn Sie eine Zeichenfolgenvergleichsmethode verwenden, die nicht zwischen Groß- und Kleinschreibung unterscheidet, verweist die Eigenschaft Bookmark möglicherweise auf den falschen Datensatz.


 Option Explicit-Anweisung

Option Explicit-Anweisung

In Microsoft Access können Sie sicherstellen, dass alle neuen Module automatisch die Anweisung Option Explicit enthalten. Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Modul, und aktivieren Sie die Option Variablen-Deklaration erforderlich.

Haben Sie diese Option einmal ausgewählt, wird sie automatisch für alle anderen Datenbanken, die Sie mit Microsoft Access erstellen oder öffnen, aktiviert.

Anmerkung Wenn Sie diese Option aktivieren, wird die Einstellung Option Explicit nur für neue Module übernommen. Sie müssen die Anweisung Option Explicit in den Deklarationsbereich aller existierenden Module eingeben. Sie können auch nach dem Öffnen des Moduls aus dem Menü Extras den Befehl Optionen wählen, auf die Registerkarte Modul klicken und die Option Variablen-Deklaration erforderlich aktivieren.


 Option Private-Anweisung

Option Private-Anweisung

Wenn Sie in Microsoft Access in einem Standardmodul die Anweisung Option Private angeben, stehen alle öffentlichen Variablen und Prozeduren des Moduls den anderen Prozeduren der aktuellen Datenbank weiterhin zur Verfügung. Für Prozeduren anderer Datenbanken sind sie dagegen nicht verfügbar.

Da Klassenmodule standardmäßig privat sind, hat das Einfügen einer Option Private-Anweisung in ein Klassenmodul zur Folge, dass ein Fehler auftritt.


 Property Get-Anweisung

Property Get-Anweisung

Sie können die Anweisung Property Get zur Definition einer Eigenschaftsprozedur verwenden, die den Wert einer Eigenschaft zurückgibt. Meist verwenden Sie wahrscheinlich die Anweisungen Property Get und Property Let zusammen, um eine Eigenschaft in einem Klassenmodul zu erstellen. Sie können z. B. eine Property Let-Prozedur in einem Klassenmodul definieren, um eine neue Eigenschaft einzustellen, und eine Property Get-Prozedur, um den Wert dieser Einstellung zurückzugeben. Wenn Sie eine neue Instanz dieser Klasse erstellen, verhalten sich die Eigenschaftsprozeduren wie benutzerdefinierte Eigenschaften des neuen Objekts. Weitere Informationen zu Klassenmodulen finden Sie im Hilfeindex unter "Klassenmodule".

Eigenschaftsprozeduren in einem Klassenmodul sind standardmäßig öffentlich und stehen somit für die Prozeduren aller anderen Module der aktuellen Datenbank zur Verfügung. Dies gilt nur dann nicht, wenn Sie das Schlüsselwort Private vor die Eigenschaftsprozeduren gesetzt haben.


 Property Let-Anweisung

Property Let-Anweisung

Sie können die Anweisung Property Let zur Definition einer Eigenschaftsprozedur verwenden, die den Wert einer Eigenschaft einstellt. Meist verwenden Sie wahrscheinlich die Anweisungen Property Get und Property Let zusammen, um eine Eigenschaft in einem Klassenmodul zu erstellen. Sie können z. B. eine Property Let-Prozedur in einem Klassenmodul definieren, um eine neue Eigenschaft einzustellen, und eine Property Get-Prozedur, um den Wert dieser Einstellung zurückzugeben. Wenn Sie eine neue Instanz dieser Klasse erstellen, verhalten sich die Eigenschaftsprozeduren wie benutzerdefinierte Eigenschaften des neuen Objekts. Weitere Informationen zu Klassenmodulen finden Sie im Hilfeindex unter "Klassenmodule".

Eigenschaftsprozeduren in einem Klassenmodul sind standardmäßig öffentlich und stehen somit für die Prozeduren aller anderen Module der aktuellen Datenbank zur Verfügung. Dies gilt nur dann nicht, wenn Sie das Schlüsselwort Private vor die Eigenschaftsprozeduren gesetzt haben.


 Public-Anweisung

Public-Anweisung

Standardmäßig sind Modulebenenvariablen in ihrem Modul privat. Soll eine solche Variable öffentlich sein, müssen Sie diese explizit mit der Anweisung Public deklarieren.

Modulebenenvariablen, die in Standardmodulen mit Public-Anweisungen deklariert sind, stehen in den Prozeduren aller Module der aktuellen Datenbank sowie in den Prozeduren aller Module einer Microsoft Access-Datenbank zur Verfügung, aus der auf die Variablen verwiesen wird. Für andere Anwendungen als Microsoft Access sind diese Variablen dagegen nicht verfügbar.

Wenn eine öffentliche Variable in einem Modul, das die Anweisung Option Private enthält, oder in einem Klassenmodul deklariert ist, steht die Variable in allen Prozeduren der aktuellen Datenbank zur Verfügung. In den Prozeduren anderer Datenbanken ist sie nicht verfügbar.

Anmerkung Die Anweisung Public kann nicht in einem Klassenmodul verwendet werden, um eine Konstante, eine Zeichenfolge fester Länge oder ein Datenfeld zu deklarieren. Wenn Sie eine Declare-Anweisung in ein Klassenmodul einfügen, müssen Sie diese außerdem mit dem Schlüsselwort Private einleiten. Weitere Informationen zu der Anweisung Declare finden Sie im Hilfeindex unter "Declare-Anweisung".


 Sub-Anweisung

Sub-Anweisung

In Microsoft Access steht eine öffentliche Sub-Prozedur, die Bestandteil eines Standardmoduls ist, in allen anderen Prozeduren der aktuellen Datenbank sowie in allen Prozeduren einer Microsoft Access-Datenbank zur Verfügung, aus der auf die Sub-Prozedur verwiesen wird. Für andere Anwendungen ist die Prozedur dagegen nicht verfügbar.

Wenn Sie eine Sub-Prozedur in einem beliebigen Modul als privat deklarieren, steht diese Prozedur ausschließlich in den anderen Prozeduren desselben Moduls zur Verfügung.

Wenn eine Sub-Prozedur in einem privaten Modul, wie z. B. einem Klassenmodul, als öffentlich deklariert ist, steht diese Prozedur allen anderen Prozeduren dieser Datenbank zu Verfügung. In den Prozeduren anderer Datenbanken ist sie nicht verfügbar.

Wenn Sie eine Ereignisprozedur für ein Formular oder einen Bericht erstellen, fügt Microsoft Access automatisch eine Codeschablone für eine Sub-Prozedur ein und stellt ihr das Schlüsselwort Private voran. Erstellen Sie z. B. auf einem neuen Formular eine Befehlsschaltfläche, stellen Sie deren Eigenschaft OnClick auf [Ereignisprozedur] ein, und klicken Sie auf die Editor-Schaltfläche [image] , um das Formularmodul anzuzeigen. Microsoft Access fügt den folgenden Code für Sie in das Modul ein.

Private Sub Befehl0_Click

End Sub

Sie können nun den Code eingeben, der ausgeführt werden soll, wenn das Ereignis Click für diese Schaltfläche eintritt.


Type-Anweisung

In Microsoft Access sind benutzerdefinierte Typen standardmäßig öffentlich. Es ist nicht möglich, in Klassenmodulen einen öffentlichen benutzerdefinierten Typ zu definieren. Wenn Sie einen benutzerdefinierten Typ in einem Klassenmodul deklarieren möchten, müssen Sie das Schlüsselwort Private vor die Anweisung Type setzen. Wenn Sie das Schlüsselwort Private nicht angeben, meldet Microsoft Access einen Kompilierzeitfehler.


 Ich kann einen Bericht-Snapshot nicht öffnen oder erstellen.

Ich kann einen Bericht-Snapshot nicht öffnen oder erstellen.

  • Möglicherweise verfügen Sie nicht über die Berechtigung zum Öffnen der Datei bzw. des Ordners, der die Datei enthält. Überprüfen Sie die Berechtigungen für die Datei bzw. den Ordner, oder wenden Sie sich an Ihren Systemadministrator.

  • Der Bericht-Snapshot ist zu umfangreich, und Sie verfügen nicht über genügend Festplattenspeicher. Stellen Sie mehr Festplattenspeicher bereit, so dass der gesamte Bericht-Snapshot auf Ihrer Festplatte gespeichert werden kann.

  • Bei der Datei handelt es sich nicht um einen Bericht-Snapshot. Eine Snapshotdatei besitzt die Erweiterung .SNP und liegt im Snapshotformat vor. Stellen Sie sicher, dass die Datei über die entsprechende Erweiterung und das entsprechende Format verfügt (klicken Sie im Windows Explorer mit der rechten Maustaste auf die Datei, und wählen Sie Eigenschaften aus; als Dateityp sollte Snapshotdatei angezeigt werden).

  • Snapshot Viewer ist nicht installiert. Snapshot Viewer wird von Microsoft Access 2000 gegebenenfalls automatisch installiert, wenn Sie erstmals einen Bericht-Snapshot erstellen. Möglicherweise wurde der Bericht-Snapshot jedoch nicht von Ihnen erstellt. Sie können Snapshot Viewer über das Setup-Programm installieren oder über eine WWW-Seite zum Herunterladen von Software, die sich auf der Microsoft Access-Entwicklerwebsite befindet.

  • Bei dem Versuch, den Bericht-Snapshot über eine Webseite zu öffnen, können Verbindungs- oder Timeoutprobleme auftreten, während der Bericht-Snapshot heruntergeladen wird. Versuchen Sie, das Problem zu beheben, indem Sie die Webseite erneut anzeigen oder den Webbrowser neu starten.


 Das Euro-Symbol wird in einem "Währung"-Feld auf einer Datenzugriffsseite nicht dargestellt

Das Euro-Symbol wird in einem "Währung"-Feld auf einer Datenzugriffsseite nicht dargestellt

Wenn Sie auf einer Datenzugriffsseite ein Feld anzeigen, dass den Datentyp Währung (Microsoft Access-Datenbank) oder Geld (Microsoft Access-Projekt) besitzt, verwendet die Seite das in der Windows-Systemsteuerung unter Ländereinstellungen festgelegte Währungssymbol des Computers, auf dem die Seite angezeigt wird. Das Feld erbt kein Format, weder Währungs- noch Euro-Formate, das für dieses Feld in der zugrunde liegenden Datensatzquelle festgelegt wurde.

Verwenden Sie einen Ausdruck, um das Euro-Symbol ( [image]) mit den Währungswerten auf einer Datenzugriffsseite anzuzeigen. Wenn ein Feld namens EuroWert beispielsweise Währungswerte enthält, können Sie den folgenden Ausdruck in der Steuerelementinhalt-Eigenschaft eines berechneten Steuerelements verwenden:

IIf(EuroValue>=0, Format(EuroValue," [image] #,##0.00"), Format((EuroValue*-1),"( [image] #,##0.00)"))


Ein Bezeichner verursacht einen Fehler.

Microsoft Access 97 oder höher unterstützt eine Reihe neuer Visual Basic-Schlüsselwörter, die jetzt nicht mehr als Bezeichner verwendet werden können. Dabei handelt es sich um die Schlüsselwörter AddressOf, Decimal, DefDec, Enum, Event, Friend, Implements, RaiseEvent, WithEvents. Wenn Sie eine in einer früheren Version erstellte Access-Datenbank in Microsoft Access 2000 konvertieren, verursachen vorhandene Bezeichner, die mit einem der neuen Visual Basic-Schlüsselwörter identisch sind, einen Kompilierfehler. Um dieses Problem zu beheben, ändern Sie die vorhandenen Bezeichner in Bezeichner, die nicht mit einem Schlüsselwort identisch sind.


 Eine Prozedur verursacht einen Fehler.

Eine Prozedur verursacht einen Fehler.

In Microsoft Access, Version 2.0, konnten Sie einen Namen für eine Prozedur angeben, der mit dem Namen für ein Modul identisch war. In Microsoft Access 97 oder höher dagegen dürfen eine Prozedur und ein Modul nicht denselben Namen besitzen. Um dieses Problem zu beheben, benennen Sie die Prozedur oder das Modul um. Sie können dieses Problem vermeiden, indem Sie für die Prozedur im VBA-Code (Visual Basic für Applikationen) einen vollständigen Pfadnamen verwenden.


 Die für ein Steuerelement festgelegte bedingte Formatierung ändert sich nicht erwartungsgemäß.

Die für ein Steuerelement festgelegte bedingte Formatierung ändert sich nicht erwartungsgemäß.

Wenn Sie eine bedingte Formatierung für ein Steuerelement festgelegt haben, wendet Microsoft Access die Formatierung an, wenn der Steuerelementwert oder andere ausgewertete Daten die von Ihnen angegebene Bedingung erfüllen.

  • Wenn Sie die Formatierungsbedingung für den im ausgewählten Steuerelement enthaltenen Text festlegen, indem Sie Feldwert ist im Dialogfeld Bedingte Formatierung auswählen, kann sich die Formatierung, z. B. eine Fettformatierung oder eine Schriftfarbe, ändern, wenn sich der Text im Steuerelement ändert.

  • Die Bedingte Formatierung besitzt Priorität gegenüber Formatierungen, die mit Hilfe von Formatierungsschaltflächen in der Symbolleiste direkt auf ein Steuerelement angewendet werden. Wird die angegebene Bedingung erfüllt, überschreibt die durch diese Bedingung festgelegte Formatierung die Standardformatierung.


Access wendet die bedingte Formatierung für ein Steuerelement in meinem Formular oder Bericht nicht korrekt an.

  • Überprüfen Sie, ob mehrere Bedingungen vorhanden sind. Wenn Sie mehrere Bedingungen angegeben haben und ein Wert mehreren Bedingungen entspricht, wendet Microsoft Access nur die Formatierung für die erste wahre Bedingung an.

  • Überprüfen Sie, ob sich Bedingungen überschneiden. Wenn Sie Bedingungen angegeben haben, die sich überschneiden, wendet Access nur das Format für die erste wahre Bedingung an. Wurde beispielsweise eine Bedingung festgelegt, die einen gelben Hintergrund auf Steuerelementwerte zwischen 100 und 200 anwendet, und eine weitere Bedingung, die einen roten Hintergrund auf Steuerelementwerte unter 120 anwendet, wird für die Steuerelementwerte zwischen 100 und 119 ein gelber Hintergrund angewendet. Sie sollten versuchen, sich überschneidende Bedingungen zu vermeiden.

  • Überprüfen Sie die Verweise auf das Steuerelement. Wenn Sie einen Ausdruck als Formatierungskriterium verwendet haben, sind möglicherweise die Verweise auf das Steuerelement in der Formel fehlerhaft. Siehe auch Erstellen eines Ausdrucks.


 Ich kann einen Bericht-Snapshot nicht in einer E-Mail senden.

Ich kann einen Bericht-Snapshot nicht in einer E-Mail senden.

  • Wenn der Unterbefehl Mailempfänger (als Anlage) des Befehls Senden an im Menü Datei nicht zur Verfügung steht, ist Ihr Mail-Programm möglicherweise nicht korrekt installiert, oder MAPI (Messaging Application Programming Interface) wird nicht unterstützt. Überprüfen Sie in der Dokumentation zu Ihrem Programm, ob MAPI unterstützt wird. Ist dies der Fall, installieren Sie das Mail-Programm erneut, um den Befehl Senden an verfügbar zu machen.

  • Möglicherweise wurde Ihr E-Mail-Programm so eingerichtet, dass Sie einen Bericht-Snapshot nicht programmgesteuert senden können. Dies ist z. B. der Fall, wenn das E-Mail-Programm die Eingabe von Informationen bei der Anmeldung erfordert. Microsoft Outlook kann beispielsweise so installiert werden, dass Sie bei der Anmeldung zur Angabe eines Benutzerprofils aufgefordert werden. Unter Umständen ist es also erforderlich, das E-Mail-Programm zu ändern.


 Bei dem Versuch, einen Bericht-Snapshot zu drucken, erhalte ich die Webseite an Stelle des Berichts.

Bei dem Versuch, einen Bericht-Snapshot zu drucken, erhalte ich die Webseite an Stelle des Berichts.

Wenn Sie einen Bericht-Snapshot über eine Webseite anzeigen, verwenden Sie nicht den Befehl Drucken im Menü Datei. Mit Hilfe des Befehls Drucken wird lediglich der Inhalt der Webseite gedruckt, nicht die einzelnen Seiten des Bericht-Snapshots. Verwenden Sie stattdessen die Schaltfläche Drucken [image], die sich rechts neben den Navigationsschaltflächen am unteren Rand des Fensters befindet, oder klicken Sie mit der rechten Maustaste auf den Bericht-Snapshot, und wählen Sie Drucken aus.


Warum kann Text in einem Feld mit einem Eingabeformat nicht gefunden oder ersetzt werden?

Wenn Sie einer Tabelle, die bereits Daten enthält, ein Eingabeformat hinzufügen, kann der Text möglicherweise nicht über die Dialogfelder Suchen und Ersetzen gefunden werden, wenn die Felddaten nicht den Kriterien des Eingabeformates entsprechen. Um dieses Problem zu lösen, können Sie das Eingabeformat entfernen, dann mit dem Dialogfeld Suchen bzw. Ersetzen arbeiten und anschließend das Eingabeformat wieder hinzufügen. Sie können aber auch die Daten des Feldes mit dem Eingabeformat so ändern, dass sie den Kriterien des Eingabeformates entsprechen.


 Warum kann vorhandener Text nicht gefunden oder ersetzt werden?

Warum kann vorhandener Text nicht gefunden oder ersetzt werden?

  • Wenn mit Hilfe der Dialogfelder Suchen und Ersetzen keine Datensätze gefunden werden, die den von Ihnen angegebenen Kriterien entsprechen, obwohl Sie sicher sind, dass solche Datensätze existieren, überprüfen Sie, ob das Feld, in dem der Suchvorgang durchgeführt wird, ein Nachschlagefeld ist. Ein Nachschlagefeld schlägt Werte in einer anderen Tabelle nach und speichert die Verweise auf diese Werte in der aktuellen Tabelle. Wenn es sich um ein Nachschlagefeld handelt, müssen Sie das Kontrollkästchen Formatierung beachten aktivieren, damit Microsoft Access die Datensätze findet.

  • Wenn Sie versuchen, Daten in einem Microsoft Access-Projekt zu suchen oder zu ersetzen, führt Access den Vorgang nur für die auf dem Client gespeicherten Daten aus. Wenn Ihr Datenblatt oder Formular die maximale Datensatzgrenze erreicht hat, befinden sich weitere Daten auf dem Server. Wenn Sie alle Daten auf dem Server suchen oder ersetzen möchten, setzen Sie die maximale Datensatzgrenze auf "Unbegrenzt". Verwenden Sie dazu die Schaltfläche für die maximale Datensatzgrenze rechts von den Navigationsschaltflächen.


 Ich kann die mit meiner Datenzugriffsseite verbundene HTML-Datei nicht finden.

Ich kann die mit meiner Datenzugriffsseite verbundene HTML-Datei nicht finden.

Die mit der Datenzugriffsseite verbundene HTML-Datei wurde umbenannt, verschoben oder gelöscht.

Obwohl es sich bei einer Datenzugriffsseite um ein Datenbankobjekt handelt, werden die meisten Informationen über eine Seite in der entsprechenden HTML-Datei gespeichert. Sie legen den Namen und den Pfad für diese HTML-Datei fest, wenn Sie zum ersten Mal eine Datenzugriffsseite erstellen. Microsoft Access verwaltet im Datenbankfenster eine Verknüpfung, die auf die Position der entsprechenden HTML-Datei in Ihrem Dateisystem verweist. Sie können den Pfad der HTML-Datei im Datenbankfenster anzeigen, indem Sie den Cursor zum Namen der Seite bewegen.

Wurde die HTML-Datei umbenannt oder verschoben, können Sie den ursprünglichen Namen der HTML-Datei wiederherstellen, die HTML-Datei zurück an ihre ursprüngliche Position verschieben oder die von Microsoft Access verwaltete Verknüpfung an den neuen Namen und Pfad anpassen (falls Microsoft Access die HTML-Datei nicht finden kann, klicken Sie in dem angezeigten Meldungsfeld auf Suchen).

Achtung Zwei oder mehrere Seiten in demselben oder in verschiedenen Microsoft Access-Datenbanken oder Microsoft Access-Projekten können auf dieselbe HTML-Datei verweisen, wenn die Seite z. B. kopiert oder importiert wurde. In diesem Fall sollten Sie die Seite im Datenseitendesigner ändern, so dass sie jeweils nur auf eine Access-Datenbank oder ein Access-Projekt verweist, um Probleme des gemeinsamen Zugriffs bzw. den Verlust von Entwurfsänderungen zu vermeiden.

Warnung Wurde die HTML-Datei gelöscht, können Sie die Seite nur wiederherstellen, wenn Sie über eine Sicherungskopie der HTML-Datei verfügen. Siehe auch Sichern einer Seite.


 Sie können das Eigenschaftenfenster in der Formular- oder Datenblattansicht nicht öffnen

Sie können das Eigenschaftenfenster in der Formular- oder Datenblattansicht nicht öffnen

Damit Sie das Eigenschaftenfenster öffnen können, wenn ein Formular in der Formularansicht oder der Datenblattansicht geöffnet ist, muss die AllowDesignChanges-Eigenschaft des Formulars auf Alle Ansichten gesetzt werden.


 Warum erhalte ich bei dem Versuch, eine verknüpfte Tabelle zu öffnen, die Meldung "Access konnte die Datei '<Dateiname>' nicht finden." ?

Warum erhalte ich bei dem Versuch, eine verknüpfte Tabelle zu öffnen, die Meldung "Access konnte die Datei '<Dateiname>' nicht finden." ?

Möglicherweise wurde die Datei mit der Tabelle, zu der eine Verbindung hergestellt werden soll, verschoben oder umbenannt, oder die Netzwerkverbindung besteht nicht mehr. Überprüfen Sie, ob Sie eine Verbindung zum Netzwerk herstellen können, indem Sie sich an Ihren Systemadministrator oder an den technischen Support wenden. Wurde die Datei verschoben oder umbenannt, verwenden Sie den Befehl Tabellenverknüpfungs-Manager, der im Untermenü Add-Ins des Menüs Extras zur Verfügung steht, um die Verknüpfung mit der Datei wiederherzustellen.

Wurde die Verknüpfung unter Verwendung eines Laufwerkbuchstabens für ein zugeordnetes Netzlaufwerk im Windows Explorer definiert, ist es möglich, dass sich der Laufwerkbuchstabe geändert hat oder in der aktuellen Sitzung nicht zugeordnet wurde. Definieren Sie die Verknüpfung erneut, indem Sie einen UNC (Universal Naming Convention)-Pfad verwenden. Hierbei handelt es sich um eine zuverlässige und konsistente Methode, damit Microsoft Access die Datenquelle mit der verknüpften Tabelle findet.


 Sie haben einen Filter in einem Unterdatenblatt erstellt, der jedoch keine Auswirkungen auf das Datenblatt hat, das das Unterdatenblatt anzeigt.

Sie haben einen Filter in einem Unterdatenblatt erstellt, der jedoch keine Auswirkungen auf das Datenblatt hat, das das Unterdatenblatt anzeigt.

Der Filter hat sich korrekt verhalten. Wenn Sie einen Filter in einem Unterdatenblatt erstellen, gilt der Filter nur für das Unterdatenblatt. Wenn Sie die Datensätze in dem Datenblatt filtern möchten, das das Unterdatenblatt anzeigt, klicken Sie auf dieses Datenblatt, und erstellen Sie anschließend den Filter.


Ich erhalte die Meldung "Der Assistent läuft nur, wenn die aktuelle Datenbank die Datenquelle für Ihre Seite ist."

  • Der Befehlsschaltflächen-Assistent steht nicht zur Verfügung, wenn es sich um eine unabhängige Datenzugriffsseite handelt. Darunter versteht man eine Seite, die geöffnet wird, ohne dass eine Datenbank geöffnet ist. Darüber hinaus steht dieser Assistent nicht zur Verfügung, wenn die Seite nicht an eine Tabelle oder Abfrage gebunden ist.

  • Der Listenfeld-/Dropdownlisten-Assistent steht für unabhängige Datenzugriffsseiten nicht zur Verfügung. Er steht außerdem nicht zur Verfügung, wenn die Seite mit einer Datenbank verbunden ist, bei der es sich nicht um die gegenwärtig geöffnete Datenbank handelt.


 Ich erhalte die Meldung "Die von Ihnen eingegebene Einstellung ist für diese Eigenschaft nicht zulässig."

Ich erhalte die Meldung "Die von Ihnen eingegebene Einstellung ist für diese Eigenschaft nicht zulässig."

Um einen Wert für eine Eigenschaft einzugeben, die über eine Dropdownliste verfügt, wählen Sie einen Wert aus der Liste aus. Informationen über gültige Werte für Eigenschaften, die nicht über eine Dropdownliste verfügen, erhalten Sie, indem Sie im Einstellungsfeld der Eigenschaft F1 drücken.

Wenn Sie einen Ausdruck für die Eigenschaft Steuerelementinhalt eingeben, stellen Sie sicher, dass folgende Bedingungen erfüllt sind:

  • Dem Ausdruck muss ein Gleichheitszeichen (=) oder ein Alias für den Ausdruck vorangestellt sein. Bei den folgenden Ausdrücken handelt es sich beispielsweise um gültige Einstellungen:

    =Menge*Einzelpreis

    Mengenpreis: Menge*Einzelpreis

  • Die Datenzugriffsseite muss an eine Tabelle, eine Abfrage oder eine andere Datenquelle gebunden werden, bevor Sie den Ausdruck eingeben. Sie können Ausdrücke nicht auf einer Datenzugriffsseite verwenden, die nicht gebunden ist.

  • Für die Eigenschaft ID eines berechneten Steuerelements muss ein eindeutiger Name festgelegt sein. Sie können keinen Namen verwenden, der in dem Ausdruck oder der ID eines anderen Steuerelements auf der Datenzugriffsseite bereits verwendet wird.


Ich erhalte die Meldung "Ungültiges Argument", obwohl ich scheinbar einen gültigen Wert für eine Eigenschaft eingebe.

In der Windows-Systemsteuerung ist unter Ländereinstellungen ein Land eingestellt, in dem nicht der Punkt (.) als Dezimaltrennzeichen verwendet wird. Die Einstellungen für Eigenschaften auf Datenzugriffsseiten erfordern jedoch, dass für alle Sprachen der Punkt als Dezimaltrennzeichen verwendet wird.


 Ich erhalte eine Fehlermeldung über s_Generation.

Ich erhalte eine Fehlermeldung über s_Generation.

Sie können diese Nachricht erhalten, wenn Sie in einer replizierten Datenbank eine Anfügeabfrage ausführen, die ein Sternchen (*) in der Zeile Feld der Entwurfsansicht enthält, um alle Felder einer der zugrunde liegenden Tabellen auszuwählen. Um dieses Problem zu vermeiden, entfernen Sie das Sternchen aus der Entwurfsansicht und fügen dann die Felder aus der Feldliste der Tabelle zur Entwurfsansicht hinzu.


 Ich kann eine Datenzugriffsseite in meinem Webbrowser nicht anzeigen.

Ich kann eine Datenzugriffsseite in meinem Webbrowser nicht anzeigen.

  • Möglicherweise verfügen Sie nicht über den richtigen Webbrowser.

    Um eine Datenzugriffsseite anzuzeigen oder über diese zu kommunizieren, muss Microsoft Internet Explorer 5 oder höher auf Ihrem Computer installiert sein. Darüber hinaus kann eine Seite zusätzliche Steuerelemente enthalten, z.B. Spreadsheets, PivotTable-Listen und Diagramme.

  • Ein anderer Benutzer verfügt über exklusiven Zugriff auf die Microsoft Access-Datenbank oder Microsoft SQL Server-Datenbank, mit der die Seite verbunden ist.

    Dies kann der Fall sein, wenn ein Datenbankadministrator eine Access-Datenbank oder SQL Server-Datenbank verwaltet und den Zugriff auf die Datenbank vorübergehend sperren muss oder wenn ein anderer Benutzer Objekte in einer freigegebenen Access-Datenbank entwirft. Warten Sie einige Minuten, und versuchen Sie anschließend erneut, die Seite anzuzeigen, oder wenden Sie sich an Ihren Datenbankadministrator.

  • Die Seite, oder eine PivotTable-Liste auf der Seite, ist mit einer nichtunterstützten OLE DB-Datenquelle verbunden.

    Eine Access- bzw. Microsoft SQL Server-Datenbank ist die einzige OLE DB-Datenquelle, zu der Sie von einer Seite aus eine Verbindung herstellen können. Die OLE DB-Verbindung zu der Seite muss von Ihnen oder von dem Autor der Seite geändert werden. Klicken Sie hierzu im Datenseitendesigner mit der rechten Maustaste auf das Datenbanksymbol in der Feldliste, und klicken Sie anschließend auf Verbindung.


Ich habe Probleme beim Einfügen oder Zurücksetzen eines Symbolbilds in einem Menü oder in einer Symbolleiste.

Für den Befehl wurde möglicherweise ein Format eingestellt, das Bilder nicht zulässt. Ändern Sie zunächst das Format des Befehls.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten und klicken Sie dann auf Anpassen.

  2. Zeigen Sie gegebenenfalls die Symbolleiste oder das Menü an, die/das den Befehl enthält, dessen Format Sie ändern möchten.

    Wie wird's gemacht?

  3. Lassen Sie das Dialogfeld Anpassen geöffnet. Klicken Sie in der Symbolleiste oder im Menü mit der rechten Maustaste auf den Befehl, dessen Format Sie ändern möchten.

  4. Klicken Sie im Kontextmenü auf Standard oder auf Symbol und Text.

Anmerkung In einem Menü bewirkt die Einstellung Standard, dass der Text und das Symbol (sofern vorhanden) eines Befehls angezeigt werden. In einer Symbolleiste oder Menüleiste wird bei Verwendung der Einstellung Standard nur das Symbolbild angezeigt.


 Entwurfsänderungen können an einer gemeinsam genutzten Access-Datenbank nicht gespeichert werden.

Entwurfsänderungen können an einer gemeinsam genutzten Access-Datenbank nicht gespeichert werden.

Wird eine Microsoft Access-Datenbank in einer Mehrbenutzerumgebung gemeinsam genutzt, werden Änderungen anders gespeichert als bei Access-Datenbanken, die nur von einem Benutzer verwendet werden. Weitere Informationen zum Speichern von Änderungen an einer gemeinsam genutzten Access-Datenbank.


 Ich erhalte eine Fehlermeldung, dass für eine Tabelle die Grenze von 32 Indizes überschritten ist.

Ich erhalte eine Fehlermeldung, dass für eine Tabelle die Grenze von 32 Indizes überschritten ist.

Wenn Ihre Microsoft Access 2.0-Datenbank eine Tabelle mit 32 oder mehr Indizes und Beziehungen enthält, erhalten Sie beim Konvertieren in Microsoft Access 2000 möglicherweise eine Fehlermeldung. Um diesen Fehler zu beheben, öffnen Sie Ihre Datenbank in Microsoft Access 2.0, und ändern Sie den Tabellenentwurf so, dass sich die Anzahl der Beziehungen für die Primärschlüsseltabelle verringert, oder entfernen Sie einige Indizes aus der Fremdschlüsseltabelle. Versuchen Sie anschließend erneut zu konvertieren.


 Ich erhalte beim Konvertieren einer großen Datenbank die Meldung, dass zu wenig Speicherplatz vorhanden ist.

Ich erhalte beim Konvertieren einer großen Datenbank die Meldung, dass zu wenig Speicherplatz vorhanden ist.

VBA (Visual Basic für Applikationen) unterstützt maximal 1.082 Module pro Microsoft Access-Datenbank, einschließlich der Formulare und Berichte, bei denen für die Eigenschaft EnthältModul (HasModule) die Einstellung Ja festgelegt wurde. Um dieses Speicherproblem zu beheben, reduzieren Sie die Anzahl der Objekte in Ihrer Access-Datenbank. Möglicherweise müssen Sie Ihre Anwendung in mehrere Datenbanken aufteilen. Wenn Ihre Module sehr viel Code enthalten, können Sie zum Speichern des Codes auch Bibliotheksdatenbanken verwenden.


 Ich habe eine Datenzugriffsseite als E-Mail-Nachricht gesendet, aber der Empfänger kann sie nicht lesen.

Ich habe eine Datenzugriffsseite als E-Mail-Nachricht gesendet, aber der Empfänger kann sie nicht lesen.

Um eine als E-Mail-Nachricht gesendete Datenzugriffsseite anzeigen zu können, muss der Mailempfänger wahlweise folgende Produkte bzw. Produktkombinationen verwenden, um die E-Mail-Nachricht zu lesen:

  • Microsoft Outlook 2000

  • Outlook Express, Version 5.0

  • Eine Kombination von Microsoft Outlook 98 und Microsoft Internet Explorer 5 oder höher

  • Eine Kombination von Outlook Express und Microsoft Internet Explorer 5 oder höher

Mailempfänger sollten sich an ihren Systemadministrator wenden, um Informationen über das Installieren und Aktualisieren diese Software zu erhalten.


Meine 16-Bit-API-Aufrufe werden nicht konvertiert.

Wenn ein Microsoft Access 2.0-Modul 16-Bit-API-Aufrufe enthält, erhalten Sie beim Konvertieren der Datenbank in Microsoft Access 2000 unter Umständen eine Fehlermeldung. Ändern Sie die API-Declare-Anweisungen in der konvertierten Datenbank in die entsprechenden 32-Bit-Anweisungen.

Siehe auch Konvertieren von Code, der DLL-Aufrufe enthält.


 Mein Code kann nicht kompiliert werden.

Mein Code kann nicht kompiliert werden.

Wenn Sie eine Microsoft Access 2.0-Datenbank in Microsoft Access 2000 konvertieren, konvertiert das Konvertierungs-Dienstprogramm Access Basic-Code in VBA-Code (Visual Basic für Applikationen). Wenn dabei Codeteile nicht erfolgreich konvertiert werden können, erhalten Sie unter Umständen nach dem Konvertieren in Microsoft Access 2000 eine Fehlermeldung.

Öffnen Sie in der konvertierten Access-Datenbank ein Modul in der Entwurfsansicht, und klicken Sie im Menü Debuggen auf Alle Module kompilieren. Microsoft Access unterbricht dann beim Kompilieren die Ausführung bei jeder Codezeile, die einen Fehler enthält. Zum Auflösen des Kompilierfehlers können Sie die Syntax dann entsprechend ändern.

In seltenen Fällen ist das Konvertierungs-Dienstprogramm nicht in der Lage, bestimmte Codestellen zu konvertieren. Es kann z.B. vorkommen, dass eine DoCmd-Anweisung nicht in eine DoCmd-Methode geändert wird. Sie erhalten unter Umständen auch Fehlermeldungen zu Kompilierfehlern, wenn Ihre Microsoft Access 2.0-Datenbank Syntaxfehler enthält. Aus diesem Grund empfiehlt es sich, alle Module der Datenbank, die in einer früheren Version erstellt worden ist, vor dem Konvertieren in Microsoft Access 2000 zu kompilieren.

Microsoft Access 2000 unterstützt die DAO 2.5/3.x-Kompatibilitätsbibliothek nicht. Wenn Sie versuchen, eine Access-Datenbank zu konvertieren, in der der Code frühere Versionen von DAO-Objekten, -Methoden und -Eigenschaften enthält, die auf der DAO 2.5/3.x-Kompatibilitätsbibliothek basieren, erhalten Sie die Meldung, dass bei der Konvertierung der Datenbank Kompilierfehler aufgetreten sind. Bevor Sie eine Access-Datenbank konvertieren, aktualisieren Sie den Code, so dass dieser nicht auf der DAO 2.5/3.x-Kompatibilitätsbibliothek basiert. Erhalten Sie dennoch eine Meldung, dass bei der Konvertierung Kompilierfehler aufgetreten sind, öffnen Sie die konvertierte Datenbank in Microsoft Access 2000, entfernen Sie den Verweis auf die fehlende DAO 2.5/3.x-Kompatibilitätsbibliothek, und fügen Sie einen Verweis auf die Microsoft DAO 3.6-Objektbibliothek ein. Um Informationen zu Änderungen an Methoden, Aktionen, Eigenschaften, Syntax und anderen Sprachelementen sowie zu Codekompatibilitäts- und Konvertierungsfragen anzuzeigen, klicken Sie auf [image] .


 Mein aus Microsoft Access, Version 2.0, konvertierter Bericht hat andere Ränder.

Mein aus Microsoft Access, Version 2.0, konvertierter Bericht hat andere Ränder.

Wenn Sie versuchen, einen aus Microsoft Access, Version 2.0, konvertierten Bericht, für den einige Ränder auf 0 gesetzt waren, in Microsoft Access 2000 zu drucken oder in der Seitenansicht anzuzeigen, kann es zu Problemen kommen, da beim Konvertieren eines Berichts der Version 2.0 Ränder nicht auf 0, sondern auf den für den Standarddrucker festgelegten Mindestrand gesetzt werden. Auf diese Weise soll verhindert werden, dass Daten aus dem Bericht beim Drucken im nicht druckbaren Bereich des Druckers gedruckt werden.

Zum Beheben dieses Problems reduzieren Sie die Spaltenbreite, Spaltenabstände oder die Anzahl der Spalten im Bericht so, dass die Spaltenbreite zuzüglich der Breite der Standardränder geringer als die Gesamtbreite des Papiers ist.


 Meine ActiveX-Steuerelemente (OLE-Zusatzsteuerelemente) werden nicht konvertiert.

Meine ActiveX-Steuerelemente (OLE-Zusatzsteuerelemente) werden nicht konvertiert.

Wenn Sie eine Microsoft Access-Datenbank, die ein ActiveX-Steuerelement enthält, in Microsoft Access 2000 konvertieren, erhalten Sie möglicherweise eine Fehlermeldung. Microsoft Access 2.0 unterstützt 16-Bit-ActiveX-Steuerelemente, während Microsoft Access 95 oder höher 32-Bit-ActiveX-Steuerelemente unterstützt. Microsoft Access kann ein 16-Bit-Steuerelement nur dann automatisch in die entsprechende 32-Bit-Version konvertieren, wenn eine 32-Bit-Version existiert und auf Ihrem Computer registriert ist.


 Ich kann die Daten in einem Feld in der Seitenansicht nicht bearbeiten.

Ich kann die Daten in einem Feld in der Seitenansicht nicht bearbeiten.

Es gibt verschiedene Arten von Feldern, die in der Seitenansicht nicht bearbeitet werden können. In den folgenden Feldern werden Werte angezeigt wie in anderen Feldern auch, diese Werte können jedoch nicht bearbeitet werden:

  • AutoWert-Felder Verfügt ein Feld über den Datentyp AutoWert in einer Microsoft Access-Datenbank bzw. über einen numerischen Datentyp mit angegebener Identität-Eigenschaft in einem Microsoft Access-Projekt, weist Access diesem Feld automatisch eine Nummer für jeden hinzugefügten Datensatz hinzu. Dieser Feldtyp wird häufig für Datensatznummern oder als Primärschlüssel verwendet. Access gibt automatisch einen Wert in das Feld ein.

  • Berechnete Felder In einer Access-Datenbank zeigen berechnete Felder von Access berechnete Werte an. Berechnete Felder basieren im Allgemeinen auf anderen Feldern in Ihren Tabellen, werden jedoch nicht in Tabellen gespeichert.

  • Gesperrte oder deaktivierte Felder Wurde für ein Steuerelement in einem Formular für die Eigenschaft Gesperrt die Einstellung Ja oder für die Eigenschaft Aktiviert die Einstellung Nein festgelegt, ist dieses für die Dateneingabe gesperrt bzw. deaktiviert.

  • Felder in einem gesperrten Datensatz Wenn Sie eine Access-Datenbank in einer Mehrbenutzerumgebung verwenden und ein Datensatz durch einen anderen Benutzer gesperrt wurde, können Sie die Daten in diesem Datensatz nicht ändern, bevor der betreffende Benutzer die Bearbeitung des Datensatzes beendet hat.

  • Felder in einem schreibgeschützten Formular oder einer gesperrten Datenbank Wenn in dem verwendeten Formular für die Eigenschaft Entwurfsänderungen zulassen die Einstellung Nein festgelegt wurde oder wenn die zugrunde liegenden Daten schreibgeschützt oder gesperrt sind.

  • Felder in einer gruppierten Datenzugriffsseite Eine gruppierte Datenzugriffsseite dient lediglich dem Anzeigen von Daten.

  • PivotTable-Listenfelder Eine PivotTable-Liste dient lediglich dem Anzeigen, nicht dem Bearbeiten von Daten. Sie können die Felder in einer PivotTable-Liste nicht bearbeiten.

Möglicherweise treten Probleme bei der Eingabe von Daten in einem Feld mit dem Datentyp Datum/Uhrzeit auf. Wenn Sie Datumswerte unter Verwendung von Schrägstrichen eingeben, vermeiden Sie nachgestellte Schrägstriche. Beispielsweise ist 1/3 eine gültige Eingabe, 1/3/ ist jedoch nicht gültig.


 Der Filter gibt zu viele Datensätze zurück.

Der Filter gibt zu viele Datensätze zurück.

Wenn der Filter zu viele Datensätze liefert, führen Sie die Aktion aus, die sich am besten für Ihre Situation eignet.

Formularbasierter Filter

  • Geben Sie einen Wert oder einen Ausdruck ein, oder wählen Sie aus der Liste der anderen Felder auf der Registerkarte Suchen nach einen Wert aus.

  • Löschen Sie einige der alternativen Kriterien, die Datensätze erfüllen können. Löschen Sie hierzu eine oder mehrere der Registerkarten Oder.

Auswahlbasierter Filter

  • Wählen Sie einen anderen Wert aus, den die Datensätze enthalten sollen, und klicken Sie dann in der Symbolleiste auf Auswahlbasierter Filter [image] . Wiederholen Sie diese Schritte solange, bis nur die gewünschten Datensätze angezeigt werden.

Auswahlausschließender Filter

  • Stellen Sie sicher, dass Sie nicht in mehreren Zeilen gleichzeitig Werte ausgewählt haben. Dies ist zwar möglich, aber Microsoft Access legt die Filterkriterien wie folgt aus: "Ausschließen des ersten ODER des zweiten ausgewählten Wertes" anstatt "Ausschließen des ersten UND des zweiten ausgewählten Wertes".

    Gehen Sie stattdessen folgendermaßen vor: Wählen Sie den ersten Wert, den Sie ausschließen möchten, klicken Sie mit der rechten Maustaste, und wählen Sie anschließend Auswahlausschließender Filter. Wählen Sie den nächsten Wert, den Sie ausschließen möchten, und wiederholen Sie dann den vorhergehenden Schritt.

  • Ändern Sie den Filter, indem Sie im Menü Datensätze auf Filter zeigen und dann auf Spezialfilter/-sortierung klicken. Geben Sie im Entwurfsbereich in der Zeile Kriterien den Wert Oder anstatt Und an.

Filter nach

  • Geben Sie im Feld Filter nach einen anderen Wert ein, und drücken Sie dann die EINGABETASTE. Wiederholen Sie diesen Schritt so oft, bis die gewünschten Datensätze angezeigt werden.

Fenster "Spezialfilter/-sortierung"

  • Fügen Sie dem Entwurfsbereich weitere Felder hinzu, und legen Sie für diese dann in der Zeile Kriterien die gewünschten Kriterien fest.

  • Löschen Sie eine oder mehrere der zusätzlichen Kriterienzeilen (der Oder-Zeilen), und verwenden Sie Ausdrücke mit Und an Stelle von Oder.


 Der Filter gibt die falschen Datensätze zurück.

Der Filter gibt die falschen Datensätze zurück.

Falls der Filter die falschen Datensätze liefert, stellen Sie sicher, dass Sie zum Angeben des gesuchten Wertes oder anderer Kriterien das korrekte Feld bzw. die korrekten Felder verwenden und den richtigen Wert bzw. die korrekten Kriterien eingegeben haben. Wenn Sie nach Feldern in verknüpften Tabellen filtern, müssen Sie bei den Werten, die Sie als Kriterien für diese Felder verwenden, die Groß-/Kleinschreibung beachten, d.h. die Schreibweise dieser Werte und die der Werte in der zugrunde liegenden Tabelle müssen übereinstimmen.

  • Wenn Sie Ausdrücke in einem der Fenster Formularbasierter Filter oder Spezialfilter/-sortierung verwenden, prüfen Sie, ob Sie die korrekten Operatoren verwenden.

  • Wenn Sie im Fenster Spezialfilter/-sortierung mehrere Kriterien angegeben haben, prüfen Sie, ob Sie dazu die korrekten Zeilen und Spalten im Entwurfsbereich verwendet haben.


Die Datensätze auf meiner Datenzugriffsseite wurden nicht wie gewünscht sortiert.

Stellen Sie die Eigenschaft DefaultSort korrekt für die Gruppendatensatzquelle ein.


 Uhrzeit- oder Datumswerte in meinen Abfragekriterien geben andere Ergebnisse zurück.

Uhrzeit- oder Datumswerte in meinen Abfragekriterien geben andere Ergebnisse zurück.

Wenn Sie eine Microsoft Access 2.0-Datenbank in Microsoft Access 2000 konvertieren, geben Abfragen mit Kriterien, die auf bestimmten Zeitwerten in Feldern vom Datentyp Datum/Uhrzeit basieren, unter Umständen andere Ergebnisse zurück, als in der früheren Version. Dies kann auch dann der Fall sein, wenn Sie Tabellen aus einer Microsoft Access 2.0-Datenbank mit einer Microsoft Access 2000-Datenbank verknüpfen. Dies betrifft jedoch nur den Zeitteil eines Feldes vom Datentyp Datum/Uhrzeit.

Abfragen, die Kriterien mit Datumswerten zwischen 1900 und 1929 enthalten, geben möglicherweise ebenfalls andere Ergebnisse zurück. Beispielsweise verweist das Datumskriterium #01/01/15# in Microsoft Access 2.0 und 95 auf den 1. Januar 1915; in Microsoft Access 97 oder höher verweist dasselbe Datumskriterium auf den 1. Januar 2015. Um dieses Problem zu umgehen, ergänzen Sie die Daten in Ihrem Kriterium um die Angabe des Jahrhunderts, z.B. #01/01/1915#.


 Ich habe in einer Access-Datenbank eine Beziehung zwischen zwei Tabellen definiert, es wird jedoch kein Unterdatenblatt angezeigt.

Ich habe in einer Access-Datenbank eine Beziehung zwischen zwei Tabellen definiert, es wird jedoch kein Unterdatenblatt angezeigt.

Wenn für die Unterdatenblattname-Eigenschaft einer Tabelle Automatisch eingestellt ist und wenn die Tabelle auf der "1"-Seite einer 1:n-Beziehung steht oder sich in einer 1:1-Beziehung befindet, dann wird von Microsoft Access automatisch ein Unterdatenblatt erstellt. Der Wert der Unterdatenblattname-Eigenschaft kann für eine spezifische Tabelle oder Abfrage in der Datenbank eingestellt werden. Für die Eigenschaft kann auch Keines festgelegt werden; in diesem Fall wird kein Unterdatenblatt erstellt. Wenn Sie zur Standardeinstellung zurückkehren möchten, setzen Sie den Wert der Unterdatenblattname-Eigenschaft wieder auf Automatisch zurück.


Die Felder auf der Datenzugriffsseite sind leer.

Folgende Erklärungen sind möglich:

  • Es handelt sich bei der angezeigten Datenzugriffsseite um ein Dateneingabeformular. Sie können in die leeren Felder eigene Daten eingeben.

  • Die Datenzugriffsseite enthält eine Dropdownliste, die bestimmt, welche Datensätze angezeigt werden. Wählen Sie aus der Dropdownliste eine Gruppe aus, deren Datensätze auf der Seite angezeigt werden sollen.


 Textfelder oder andere Steuerelemente können nicht gruppiert werden.

Textfelder oder andere Steuerelemente können nicht gruppiert werden.

Sie müssen mehrere Textfelder oder andere Steuerelemente gleichzeitig auswählen, um eine Steuerelementgruppe zu erstellen.

  • Wählen Sie zwei oder mehr Steuerelemente aus, und klicken Sie anschließend im Menü Format auf Gruppierung. Auswahl angrenzender Steuerelemente. Auswahl nichtangrenzender oder überlappender Steuerelemente.


Die Gruppierung ausgewählter Textfelder oder anderer Steuerelemente kann nicht aufgehoben werden.

Sie können die Gruppierung ausgewählter Textfelder oder anderer Steuerelemente nur aufheben, wenn jeweils nur eine Gruppe in dem Formular oder Bericht ausgewählt wurde.

  • Klicken Sie auf ein beliebiges Steuerelement in der Gruppe, um die Gruppe auszuwählen, und klicken Sie im Menü Format auf Gruppierung aufheben.


 In meinem Unterdatenblatt wird kein Fremdschlüssel oder keine übereinstimmenden Felder angezeigt.

In meinem Unterdatenblatt wird kein Fremdschlüssel oder keine übereinstimmenden Felder angezeigt.

Standardmäßig werden in einer Microsoft Access-Datenbank weder der Fremdschlüssel noch übereinstimmende Felder im Unterdatenblatt einer Tabelle oder Abfrage angezeigt. Sie können den Fremdschlüssel oder ein oder mehrere übereinstimmende Felder mit Hilfe des Befehls Spalten einblenden (im Menü Format) vorübergehend anzeigen. Beim nächsten Öffnen des Datenblatts, in dem das Unterdatenblatt enthalten ist, sind die Spalten jedoch wieder ausgeblendet. Durch das Ein- oder Ausblenden dieser Felder ändert sich die Anzeige des Unterdatenblattes, es wird jedoch keine Beziehung verändert.

In einem Formular können Sie auf einem Unterdatenblatt dann permanent den Fremdschlüssel oder übereinstimmende Felder anzeigen, wenn das Unterdatenblatt einem Unterformular entspricht und wenn es sich bei dem Herkunftsobjekt des Unterformulars um ein Formular handelt.


 Das Feld "Verknüpfen nach" wird leer angezeigt, wenn ich in einer Microsoft Access-Datenbank zu einer Abfrage ein Unterdatenblatt hinzufüge

Das Feld "Verknüpfen nach" wird leer angezeigt, wenn ich in einer Microsoft Access-Datenbank zu einer Abfrage ein Unterdatenblatt hinzufüge

Wenn Sie soeben die Abfrage erstellt haben, müssen Sie diese zuerst speichern. Fügen Sie dann das Unterdatenblatt hinzu, so dass die Felder der Abfrage im Feld Verknüpfen nach angezeigt werden.


 Auf meinem Unterdatenblatt werden für jede Zeile des Datenblatts dieselben Daten angezeigt

Auf meinem Unterdatenblatt werden für jede Zeile des Datenblatts dieselben Daten angezeigt

In einer Tabelle oder Abfrage einer Microsoft Access-Datenbank ist es erforderlich, das bzw. die übereinstimmende(n) Feld(er) anzugeben, die zwischen dem Datenblatt und dem Unterdatenblatt in den Feldern Verknüpfen von und Verknüpfen nach im Dialogfeld Unterdatenblatt einfügen (klicken Sie im Menü Einfügen auf Unterdatenblatt ) vorhanden sind. Diese Felder entsprechen den Verknüpfen von- und Verknüpfen nach-Eigenschaften des Datenblattes, das das Unterdatenblatt enthält.

In einem Formular müssen Sie das oder die übereinstimmende(n) Feld(er) zwischen dem Hauptformular und dem Unterformular in den Verknüpfen von- und Verknüpfen nach-Eigenschaften des Unterformular-Steuerelements auf dem Hauptformular angeben.


 Das Datenblatt, das ein Unterdatenblatt enthält, wird anders angezeigt als bei der letzten Speicherung

Das Datenblatt, das ein Unterdatenblatt enthält, wird anders angezeigt als bei der letzten Speicherung

Die Unterdatenblatt erweitert-Eigenschaft steuert den Zustand eines Unterdatenblattes in einer Tabelle oder einer Abfrage bzw. das Unterformular-Steuerelement in einem Formular. Sie können für die Eigenschaft Ja festlegen (erweiterte Anzeige aller Zeilen), indem Sie im Menü Format das Untermenü Unterdatenblatt öffnen und dann auf Alles einblenden klicken. Sie können Nein festlegen (reduzierte Anzeige aller Zeilen), indem Sie im Menü Format das Untermenü Unterdatenblatt öffnen und dann auf Alles ausblenden klicken. Wenn Sie auf eines oder mehrere Erweiterungssymbole klicken, um Unterdatenblätter für eine oder mehrere Zeilen im Datenblatt anzuzeigen, wird die SubdatasheetExpanded-Eigenschaft nicht verändert. Das ist auch dann nicht der Fall, wenn Sie auf alle Erweiterungssymbole klicken, um alle Unterdatenblätter anzuzeigen. Für die Eigenschaft ist trotzdem immer noch Nein festgelegt (reduzierte Anzeige aller Zeilen).


Ausblenden von Duplikatwerten, die in derselben Gruppe erscheinen

Stellen Sie für das Textfeld, das die auszublendenden Werte anzeigt, die Eigenschaft Duplikate ausblenden auf Ja ein.

Wie wird's gemacht?


Drucken des Gruppenkopfs in der Zeile, in der der erste Detaildatensatz erscheint

Für das Entwerfen eines Berichts mit einem Block-Layout stehen Ihnen die folgenden Möglichkeiten zur Verfügung:

  • Verwenden Sie zum Erstellen eines neuen Berichts den Berichts-Assistenten, und wählen Sie das Layout Block.

    Wie wird's gemacht?

  • Ändern Sie bei einem bestehenden Bericht dessen Entwurf, indem Sie doppelte Daten verbergen.

    Wie wird's gemacht?


Drucken der Datensätze eines Berichts in der Reihenfolge, in der sie in der zugrunde liegenden Datenquelle angezeigt werden

Die Sortierreihenfolge für einen Bericht stellen Sie im Fenster Sortieren und gruppieren ein.

Wie wird's gemacht?


Die Datensätze in den Gruppen des Berichts erscheinen nicht sortiert

Sie müssen eine Sortierreihenfolge für die Datensätze in einer Gruppe festlegen. Verwenden Sie hierzu in der Entwurfsansicht des Berichts das Fenster Sortieren und gruppieren. Wenn Sie z. B. die täglich ausgelieferten Bestellungen nach ihrer Bestellnummer sortieren möchten, gruppieren Sie nach dem Feld Versanddatum und sortieren nach dem Feld Bestell-Nr.

Wie wird's gemacht?


 Microsoft Access fordert im Bericht zur Eingabe unerwarteter Parameter auf.

Microsoft Access fordert im Bericht zur Eingabe unerwarteter Parameter auf.

Stellen Sie sicher, dass alle in den folgenden Bereichen des Berichtsentwurfs verwendeten Feldnamen richtig geschrieben sind und mit den Feldnamen der zugrunde liegenden Tabelle oder Abfrage übereinstimmen:

  • Eigenschaft Steuerelementinhalt gebundener Steuerelemente

  • Spalte Feld/Ausdruck im Fenster Sortieren und gruppieren

  • Ausdrücke in Steuerelementen oder im Fenster Sortieren und gruppieren

    Stellen Sie außerdem sicher, dass Aggregatfunktionen auf Feldnamen (nicht auf Steuerelementnamen) in der zugrunde liegenden Tabelle oder Abfrage verweisen. Zum Anzeigen von Informationen klicken Sie auf [image] .


 Sortieren der Datensätze gemäß der Arbeitssprache

Sortieren der Datensätze gemäß der Arbeitssprache

Stellen Sie in einer Microsoft Access-Datenbank (.mdb) die Sortierreihenfolge für die Datenbank im Dialogfeld Optionen auf die korrekte Sprache ein.

Wie wird's gemacht?


 Die Meldung "Der Ausdruck ist ungültig" erscheint

Die Meldung "Der Ausdruck ist ungültig" erscheint

Der von Ihnen eingegebene Ausdruck schließt den Namen eines Feldes ein, das nicht in der Datendefinition der Seite enthalten ist. Jedes Feld, auf das Sie in einem Ausdruck auf einer Datenzugriffsseite verweisen, muss in der Datendefinition der Seite enthalten sein. Um ein Feld zu der Datendefinition der Seite hinzuzufügen, ziehen Sie das Feld von der Feldliste auf die Datenzugriffsseite. Sollen die Werte in dem Feld nicht auf der Seite angezeigt werden, können Sie das an das Feld gebundene Steuerelement ausblenden oder löschen. Ein Feld, auf das in einem Ausdruck verwiesen wird, bleibt jedoch Bestandteil der Datendefinition der Seite, selbst wenn Sie das Steuerelement löschen.


Die Meldung "Undefinierte Funktion in einem Ausdruck" erscheint

Sie haben ein Steuerelement auf einer Datenzugriffsseite an ein berechnetes Feld gebunden, das eine Funktion verwendet, die auf Datenzugriffsseiten nicht unterstützt wird. Sehen Sie sich die Funktionsliste mit in Steuerelementen auf Datenzugriffsseiten und in den zugrunde liegenden Abfragen verwendeten Funktionen an.


 Die Meldung "Die Eigenschaft DefaultSort ist ungültig" erscheint

Die Meldung "Die Eigenschaft DefaultSort ist ungültig" erscheint

Geben Sie im Feld für die Eigenschaft Standardsortierung den Namen des Feldes oder der Felder ein, die sortiert werden sollen. Trennen Sie die Namen durch Kommas. Sie können im Anschluss an jeden Namen ein Leerzeichen und das Schlüsselwort ASC bzw. DESC eingeben, beispielsweise Auftragsdatum DESC, Auftragsnummer ASC. Wenn Sie die Reihenfolge nicht festlegen, sortiert Microsoft Access in aufsteigender Reihenfolge.

Ist das Steuerelement, das sortiert werden soll, an einen Ausdruck gebunden, müssen Sie den in der Eigenschaft Steuerelementinhalt angezeigten Alias für das Steuerelement eingeben. Wurde beispielsweise für die Eigenschaft Steuerelementinhalt des zu sortierenden Steuerelements GruppierungMengenpreis: Mengenpreis festgelegt, geben Sie GruppierungMengenpreis in der Eigenschaft Standardsortierung ein.


 Ich möchte eine HTML-Datei in Access öffnen, aber die Datei wird in einem anderen Office-Programm geöffnet

Ich möchte eine HTML-Datei in Access öffnen, aber die Datei wird in einem anderen Office-Programm geöffnet

Wenn Sie im Dialogfeld Öffnen (Menü Datei) eine Hypertext Markup Language (HTML)-Datei (also eine Webseite) auswählen und dann auf Öffnen klicken, oder wenn Sie auf diese Datei doppelklicken, dann wird die Datei in dem Programm geöffnet, in dem sie erstellt wurde. Wenn Sie zum Beispiel versuchen, eine Datei im HTML-Format zu öffnen, die in Microsoft Word erstellt wurde, dann wird die Datei nicht in Microsoft Access 2000 sondern in Word als Datenzugriffsseite geöffnet. Wenn Sie eine HTML-Datei öffnen möchten, die in einem anderen Office-Programm als Datenzugriffsseite erstellt wurde, klicken Sie im Dialogfeld Öffnen mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf In Microsoft Access öffnen.


Das Feld "Sortierreihenfolge bei neuer DB" im Dialogfeld "Optionen" enthält bestimmte Spracheinstellungen nicht mehr

Einige Sprachen, die bisher getrennt im Feld Sortierreihenfolge bei neuer DB auf der Registerkarte Standard im Dialogfeld Optionen (Menü Extras) aufgeführt waren, fallen nun unter die Einstellung der allgemeinen Sortierreihenfolge. Die allgemeine Sortierreihenfolge gilt für folgende Sprachen: Afrikaans, Albanisch, Arabisch, Baskisch, Bulgarisch, Weißrussisch, Katalanisch, Niederländisch, Englisch, Faröisch, Farsi, Deutsch - Standard, Griechisch, Hebräisch, Hindi, Indonesisch, Italienisch, Malaiisch, Portugiesisch, Russisch, Serbisch, Suaheli und Urdu.


 Die Datei, nach der Sie suchen, wird nicht im Dialogfeld "Öffnen" angezeigt.

Die Datei, nach der Sie suchen, wird nicht im Dialogfeld "Öffnen" angezeigt.

  • Geben Sie im Dialogfeld Öffnen den Namen der Datei in das Feld Dateiname ein, klicken Sie auf Extras und dann auf Suchen. Aktivieren Sie das Kontrollkästchen Unterordner durchsuchen, und klicken Sie dann auf Suche starten.

  • Stellen Sie sicher, dass Sie im Dialogfeld Öffnen im Feld Dateityp den korrekten Dateityp ausgewählt haben.

  • Stellen Sie sicher, dass die Einträge im Dialogfeld Suchen unter Weitere Kriterien definieren für die Dateien geeignet sind, nach denen Sie suchen. Um alle aktuellen Suchkriterien mit Ausnahme des Speicherortes der Datei zu löschen und den Wert auf den Standarddateityp zurückzusetzen, klicken Sie auf Neue Suche.

  • Stellen Sie sicher, dass Sie das korrekte Laufwerk und den korrekten Ordner durchsuchen.

  • Wenn Sie den Namen des Ordners nicht kennen, können Sie alle Ordner und Unterordner auf dem angegebenen Laufwerk durchsuchen. Klicken Sie im Dialogfeld Öffnen auf Extras, klicken Sie auf Suchen, und aktivieren Sie das Kontrollkästchen Unterordner durchsuchen.

  • Sie können im Dialogfeld Öffnen mehrere Pfade durchsuchen. Geben Sie die Pfade dazu in das Feld Dateiname ein. Trennen Sie die Pfade durch Semikolons. Geben Sie beispielsweise c:\Hausverwaltung;c:\Eigene Dokumente ein.

  • Wenn Sie nach einer Datei auf dem Netzwerk suchen und das Netzlaufwerk nicht im Feld Suchen in im Dialogfeld Öffnen angezeigt wird, klicken Sie auf Extras und dann auf Netzlaufwerk verbinden. Klicken Sie im Feld Laufwerk auf den Laufwerkbuchstaben, den Sie zum Verbinden mit dem Netzwerk verwenden möchten. Geben Sie in das Feld Pfad den Pfad ein, in dem sich die Datei auf dem Netzwerk befindet. Sie können auch nach Dateien auf einem Netzlaufwerk suchen, wenn Ihr Netzwerk UNC unterstützt. Geben Sie einfach den UNC-Pfad in das Feld Dateiname im Dialogfeld Öffnen ein. Geben Sie z. B. \\Pläne\Dokumente ein.


Das Kennwort, das Sie zum Öffnen einer Datei eingegeben habe, wird nicht akzeptiert.

  • Bei Kennwörtern muss die Groß-/Kleinschreibung beachtet werden (Groß- und Kleinbuchstaben müssen genau übernommen werden). Prüfen Sie, ob die FESTSTELLTASTE aktiviert ist.

  • Möglicherweise haben Sie das Kennwort falsch geschrieben. Geben Sie es erneut ein.


In der Datensatznavigationsleiste fehlen Schaltflächen.

Die Schaltflächen für diese Seite oder Gruppe wurden von dem Benutzer, der die Datenzugriffsseite erstellt hat, entfernt.


Hinzufügen eines übereinstimmenden Datensatzes in der anderen Tabelle

Sie müssen die Tabelle öffnen, die der Assistent nach nicht übereinstimmenden Datensätzen durchsucht hat (die zweite Tabelle, die Sie im Assistenten angegeben haben). Fügen Sie dann einen übereinstimmenden Datensatz hinzu.

Wie wird's gemacht?


Alle Datensätze werden im Unterformular angezeigt. Sie ändern sich nicht, wenn im Hauptformular von Datensatz zu Datensatz gewechselt wird

Verknüpfen Sie Ihr Hauptformular mit dem Unterformular. Verwenden Sie dazu die Eigenschaften VerknüpfenVon und VerknüpfenNach. Zum Anzeigen von Informationen zur Verknüpfung eines Hauptformulars mit einem Unterformular klicken Sie auf [image] .

Wenn Sie die Eigenschaften VerknüpfenVon und VerknüpfenNach bereits eingestellt haben, das Unterformular jedoch noch immer nicht funktioniert, stellen Sie sicher, dass keines der verwendeten Felder umbenannt oder gelöscht wurde. Stellen Sie ferner sicher, dass die Feldnamen richtig geschrieben wurden und es sich auch tatsächlich um Feldnamen handelt und nicht um die in der Eigenschaft Name festgelegten Steuerelementnamen.

Anmerkung Wenn Sie das Unterformular mit Hilfe eines Assistenten erstellt haben, verknüpft Microsoft Access das Hauptformular automatisch mit dem Unterformular. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Die Anfügeabfrage hat Daten an oder von nicht erwünschte(n) Felder(n) angefügt

Die Anfügeabfrage hat Daten an oder von nicht erwünschte(n) Felder(n) angefügt

So wählen Sie die Felder aus, deren Daten Sie anfügen möchten:

Fügen Sie die folgenden Felder zum Abfrage-Entwurfsbereich für Ihre Anfügeabfrage hinzu:

  • Felder, die Sie anfügen möchten

  • Felder, für die Sie Kriterien festlegen möchten

  • Felder, die dem Primärschlüssel der Tabelle entsprechen, an die Sie Datensätze anfügen

So wählen Sie die Felder aus, an die Sie Daten anfügen möchten:

  • Klicken Sie in der Zelle Anfügen an der Felder, deren Daten Sie anfügen möchten, auf den Namen des Feldes, an das Sie die Daten anfügen möchten.

Anmerkung Wenn Sie der Zeile Feld das Sternchen (*) hinzugefügt haben, wählen Sie in der Zeile Anfügen an das Sternchen aus. Alle Feldnamen in beiden Tabellen müssen identisch sein. Sie können in der Spalte, die das Sternchen enthält, keine Kriterien zum Auswählen von Datensätzen festlegen, Sie können jedoch Kriterien in einer separaten Spalte festlegen.


 Das Formular ist leer. Warum werden die Daten nicht angezeigt?

Das Formular ist leer. Warum werden die Daten nicht angezeigt?

Ein Formular kann aus einem der folgenden Gründe leer sein:

  • Das Formular ist möglicherweise nicht an eine zugrunde liegende Datenquelle gebunden. Wenn Sie ein Formular an eine zugrunde liegende Datenquelle binden möchten, öffnen Sie das Formular in der Entwurfsansicht. Doppelklicken Sie dann auf den Formularmarkierer, um das Eigenschaftsblatt zu öffnen. Im Einstellungsfeld der Datenherkunft-Eigenschaft klicken Sie auf eine Datenquelle in der Liste. Wenn es sich bei der Datenquelle um eine Abfrage handelt, klicken Sie auf die Generator-Schaltfläche [image] , um den Abfrage-Generator zu öffnen.

  • Das Formular ist ggf. an eine zugrunde liegende Datenherkunft gebunden, die keine Daten enthält. Überprüfen Sie die zugrunde liegende Datenherkunft, um sicherzustellen, dass sie Daten enthält.

  • Das Formular basiert vielleicht auf einer Abfrage, die keine Daten zurückgibt. Um zu sehen, ob die Abfrage Daten zurückgibt, doppelklicken Sie auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen. Klicken Sie dann auf die Generator-Schaltfläche neben dem Einstellungsfeld der Eigenschaft Datenherkunft und dann im Abfrage-Generator auf Ansicht Objekt anzeigen .

  • Möglicherweise wurde das Formular im Dateneingabemodus geöffnet. Ein im Dateneingabemodus geöffnetes Formular zeigt einen leeren Datensatz an, der Ihnen das Hinzufügen von Daten ermöglicht. Um alle Datensätze anzuzeigen, klicken Sie im Menü Datensätze auf den Befehl Filter/Sortierung entfernen.

  • Der Formularkopf oder der Formularfuß ist ggf. so groß, dass kein Platz mehr für den Detailbereich vorhanden ist.


 Warum wird ein Wert, der in das Kombinationsfeld in einem Formular eingegeben wird, nicht der Liste hinzugefügt?

Warum wird ein Wert, der in das Kombinationsfeld in einem Formular eingegeben wird, nicht der Liste hinzugefügt?

Um einen Wert automatisch zu der Liste in einem Formular hinzuzufügen, müssen Sie eine Ereignisprozedur schreiben und diese in die Eigenschaft BeiNichtInListe des Kombinationsfeldes einbinden.

Anmerkung Sie müssen für die Eigenschaft Nur Listeneinträge die Einstellung Ja festlegen, um das Ereignis NotInList verwenden zu können.


Die Meldung "Der Bezug des Namens "Name" kann nicht erkannt werden" wird angezeigt

Diese Meldung wird möglicherweise angezeigt, wenn Sie im Dialogfeld Abfrageparameter die Parameter nicht explizit deklariert haben, die Sie für eine Kreuztabellenabfrage oder eine Abfrage, auf der eine Kreuztabellenabfrage oder ein Diagramm basiert, verwenden. Um dieses Problem zu beheben, gehen Sie folgendermaßen vor:

  1. Geben Sie in der Abfrage, die den Parameter enthält, den Parameter und seinen Datentyp im Dialogfeld Abfrageparameter an. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  2. Stellen Sie in derselben Abfrage die Eigenschaft FixierteSpaltenüberschriften ein. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Warum kann das Format der Bezeichnungen im Diagramm des Formulars oder Berichts nicht geändert werden?

Warum kann das Format der Bezeichnungen im Diagramm des Formulars oder Berichts nicht geändert werden?

Wenn Sie zum Ändern des Formats der Bezeichnungen an den Achsen eines Diagramms Microsoft Graph verwenden, werden diese Änderungen beim Aktualisieren des Diagramms überschrieben. Wenn diese Änderungen permanent erhalten bleiben sollen, müssen Sie die in der Diagrammeigenschaft Datensatzherkunft definierte Abfrage ändern.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Vergewissern Sie sich, dass das Diagramm markiert ist, und klicken Sie dann auf Eigenschaften [image] .

  3. Klicken Sie neben dem Einstellungsfeld für die Eigenschaft Datensatzherkunft auf die Generator-Schaltfläche [image] .

  4. Ersetzen Sie in der Abfrage den Namen des Feldes, das Sie formatieren möchten, durch den Feldnamen und die Funktion Format.

    Beispielsweise können Sie es in einer Microsoft Access-Datenbank in Format([Bestelldatum];"JJ") ändern, wenn Sie das Format für dieses Datum im Diagramm ändern möchten. Zum Anzeigen weiterer Informationen zur Funktion Format klicken Sie auf [image] .

  5. Schließen Sie die Abfrage, und speichern Sie die Änderungen.

  6. Wechseln Sie zur Formularansicht oder zur Seitenansicht, um die Änderungen anzuzeigen.

Anmerkung Microsoft Graph unterstützt nicht alle von Microsoft Access unterstützten benutzerdefinierten Formate.


 Warum können im Unterformulardatenblatt keine Formularköpfe und -füße angezeigt werden?

Warum können im Unterformulardatenblatt keine Formularköpfe und -füße angezeigt werden?

Ein Formular oder Unterformular zeigt in der Datenblattansicht keinen Formularkopf und keinen Formularfuß an, auch wenn Sie diese in der Entwurfsansicht hinzugefügt haben. Sie können einen Formularkopf und einen Formularfuß in einem Unterformular anzeigen und es wie ein Datenblatt darstellen, indem Sie die Größe des Detailbereichs des Formulars an die Größe einer einzigen Zeile anpassen und die Eigenschaft Standardansicht des Unterformulars auf Endlosformulare einstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Warum können die Daten in einem Formular nicht bearbeitet werden?

Warum können die Daten in einem Formular nicht bearbeitet werden?

Unter Umständen können die Daten in einem Formular nicht bearbeitet werden. Dafür kann einer der folgenden Gründe vorliegen:

  • Das Formular wurde als schreibgeschütztes Formular erstellt. Sind die Eigenschaften Löschen zulassen, Anfügen zulassen und Bearbeiten zulassen des Formulars auf Nein eingestellt, können an den zugrunde liegenden Daten keine Änderungen vorgenommen werden.

  • Möglicherweise ist die Eigenschaft Gesperrt für ein oder mehrere Steuerelemente auf Ja eingestellt.

  • Möglicherweise arbeitet gleichzeitig ein anderer Benutzer mit dem Formular und die Eigenschaft Datensätze sperren des Formulars ist auf Alle Datensätze oder auf Bearbeiteter Datensatz eingestellt. In diesem Fall wird im Datensatzmarkierer der Indikator für einen gesperrten Datensatz [image] angezeigt. Warten Sie einen Augenblick, und versuchen Sie es dann erneut.

  • Vielleicht versuchen Sie, die Daten eines berechneten Steuerelements zu bearbeiten. Ein berechnetes Steuerelement zeigt das Ergebnis eines Ausdrucks an. Da die Daten in einem berechneten Steuerelement nicht gespeichert werden, können sie auch nicht bearbeitet werden.

  • Die dem Formular zugrunde liegende Abfrage oder SQL-Anweisung ist unter Umständen nicht aktualisierbar. Zum Anzeigen weiterer Informationen darüber, welche Arten von Abfragen in einer Microsoft Access-Datenbank (.mdb) aktualisierbar sind, klicken Sie auf [image] . Zum Anzeigen weiterer Informationen darüber, welche Arten von Abfragen in einem Microsoft Access-Projekt (.adp) aktualisierbar sind, klicken Sie auf [image] .


Beim Doppelklicken auf ein verknüpftes oder eingebettetes Objekt wird die Meldung "Datei kann nicht geöffnet werden" angezeigt

Microsoft Access zeigt diese Fehlermeldung an, wenn die Quelldatei für ein OLE-Objekt nicht geöffnet werden kann. Überprüfen Sie die folgenden Punkte:

  • Die zum Bearbeiten der Datei benötigte Anwendung ist auf Ihrem Computer installiert.

  • Sie verfügen über genügend Speicher, um die Quellanwendung auszuführen. Schließen Sie andere Anwendungen, um Speicherkapazität freizugeben.

  • Wird die Anwendung, die Sie zu öffnen versuchen, bereits ausgeführt, stellen Sie sicher, dass darin keine Dialogfelder geöffnet sind.

  • Handelt es sich um ein verknüpftes Objekt, stellen Sie sicher, dass es nicht bereits von einem anderen Benutzer geöffnet wurde.

  • Stellen Sie bei einem verknüpften Objekt in einem Formular außerdem sicher, dass der Name der Quelldatei sich nicht geändert hat oder die Quelldatei nicht an einen anderen Standort verschoben wurde. Um den Namen der Originaldatei zu sehen, klicken Sie auf das Objekt und anschließend im Menü Bearbeiten auf OLE/DDE-Verknüpfungen. Der Name der Originaldatei wird im Feld Verknüpfungen angezeigt. Wurde die Datei umbenannt oder an einen anderen Standort kopiert, klicken Sie auf die Verknüpfung im Feld Verknüpfungen und anschließend auf Quelle ändern, um die Verknüpfung wiederherzustellen.


 Warum kann eine verknüpfte Microsoft Visual FoxPro- oder dBASE-Tabelle nicht geöffnet oder aktualisiert werden?

Warum kann eine verknüpfte Microsoft Visual FoxPro- oder dBASE-Tabelle nicht geöffnet oder aktualisiert werden?

  • Wenn Sie eine .DBF-Datei verknüpfen und ihr eine Indexdatei (.IDX, .CDX, .NDX oder .MDX) zuordnen, benötigt Microsoft Access die Indexdatei zum Öffnen der verknüpften Tabelle. Wenn Sie Microsoft Visual FoxPro- oder dBASE-Indexdateien oder die von Microsoft Access erstellte Informationsdatei (.INF) löschen oder verschieben, sind Sie nicht mehr in der Lage, die verknüpfte Tabelle zu öffnen.

  • Wenn Sie eine Visual FoxPro- oder dBASE-Tabelle mit einem Memo-Feld verknüpfen, benötigt Microsoft Access die zugeordnete Memo-Datei (.DBT) zum Öffnen der verknüpften Tabelle. Wenn Sie diese Datei löschen oder verschieben, können Sie die verknüpfte Tabelle nicht mehr öffnen.

  • Wenn Sie die Daten Ihrer .DBF-Datei mit Hilfe von Microsoft Access aktualisieren, werden auch die Indexdateien entsprechend aktualisiert. Wenn Sie Daten mit Visual FoxPro oder dBASE aktualisieren, müssen Sie auch die zugeordneten Indizes mit Visual FoxPro bzw. dBASE aktualisieren. Microsoft Access kann mit einer verknüpften Tabelle nur dann arbeiten, wenn die angegebenen Indizes die aktuellen sind.

  • Sie können eine Visual FoxPro- oder dBASE-Tabelle nicht aktualisieren, wenn deren Datendateien (.DBF) oder Indexdateien (.IDX, .CDX, .NDX oder .MDX) schreibgeschützt sind. Um dies zu überprüfen, verwenden Sie den Arbeitsplatz oder den Windows Explorer zum Anzeigen des Ordners, auf dem sich die Dateien befinden. Klicken Sie mit der rechten Maustaste auf eine der Dateien, klicken Sie auf Eigenschaften und dann auf die Registerkarte Allgemein. Wenn das Kontrollkästchen Schreibgeschützt aktiviert ist, deaktivieren Sie es, und klicken Sie auf OK.

  • Wenn Ihre Visual FoxPro- oder dBASE-Tabellen auf einem schreibgeschützten Laufwerk oder einer CD-ROM gespeichert sind, kann Microsoft Access keine .INF-Datei in dem Ordner erstellen, in dem sich die .DBF-Dateien befinden, und Sie können die Tabellen nicht verknüpfen. Um eine Tabelle auf einem schreibgeschützten Laufwerk zu verknüpfen, müssen Sie den Pfad zu einem Laufwerk mit Lese-/Schreibzugriff angeben, den Microsoft Access zum Erstellen der .INF-Datei in der Windows-Registrierung verwenden soll. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Um eine dBASE 7-Tabelle (mit Lese-/Schreibzugriff) zu verknüpfen, muss die BDE (Borland Database Engine), Version 4.x oder höher, auf Ihrem Computer installiert sein. Ist die BDE 4.x oder höher nicht installiert, erhalten Sie sie durch Installation von dBASE 7 oder Delphi. Wenn Sie über ein ältere Version der BDE verfügen, die das dBASE 7-Dateiformat nicht unterstützt, können Sie die Engine über Borlands Seiten im World Wide Web aktualisieren. Selbst wenn Sie die BDE nicht auf Ihrem Computer installiert haben, können Sie dennoch eine Verknüpfung zu den Dateiformaten von dBASE III, IV und 5.0 herstellen.


 Warum kann eine verknüpfte Paradox-Tabelle nicht geöffnet oder aktualisiert werden?

Warum kann eine verknüpfte Paradox-Tabelle nicht geöffnet oder aktualisiert werden?

  • Wenn Sie eine Paradox-Tabelle verknüpfen, die einen Primärschlüssel besitzt, benötigt Microsoft Access die zugeordnete Indexdatei (.PX), um die verknüpfte Tabelle öffnen zu können. Wenn Sie eine Paradox-Tabelle mit einem Feld vom Datentyp Memo verknüpfen, benötigt Microsoft Access die zugeordnete Memo-Datei (.MB) zum Öffnen der verknüpften Tabelle. Wenn Sie diese Dateien löschen oder verschieben, sind Sie nicht mehr in der Lage, die verknüpfte Tabelle zu öffnen.

  • Wenn Sie eine Paradox-Tabelle ohne Primärschlüssel verknüpfen, können Sie die Daten der Tabelle nicht mit Microsoft Access aktualisieren. Wenn Sie jedoch möchten, dass die Tabelle aktualisiert werden kann, definieren Sie für die Tabelle einen Primärschlüssel in Paradox.

  • In einer verknüpften oder importierten Paradox-Tabelle gespeicherte OLE-Objekte können nicht in Microsoft Access geöffnet werden.

  • Sie können eine Tabelle nicht aktualisieren, wenn deren Datendateien (.DB) oder Indexdateien (.PX) schreibgeschützt sind. Um dies zu überprüfen, verwenden Sie den Arbeitsplatz oder Windows Explorer zum Anzeigen des Ordners, auf dem sich die Dateien befinden. Klicken Sie mit der rechten Maustaste auf eine der Dateien, klicken Sie auf Eigenschaften und dann auf die Registerkarte Allgemein. Wenn das Kontrollkästchen Schreibgeschützt aktiviert ist, deaktivieren Sie es, und klicken Sie auf OK.

  • Sie können eine Paradox-Tabelle nicht aktualisieren, wenn deren Datendatei (.DB) oder Indexdatei (.PX) schreibgeschützt ist. Um dies zu überprüfen, verwenden Sie den Arbeitsplatz oder Windows Explorer zum Anzeigen des Ordners, auf dem sich die Dateien befinden. Klicken Sie mit der rechten Maustaste auf eine der Dateien, klicken Sie auf Eigenschaften und dann auf die Registerkarte Allgemein. Wenn das Kontrollkästchen Schreibgeschützt aktiviert ist, deaktivieren Sie es, und klicken Sie auf OK.

  • Um eine Paradox 8.0-Tabelle (mit Lese-/Schreibzugriff) zu verknüpfen, muss die BDE (Borland Database Engine), Version 4.x oder höher, auf Ihrem Computer installiert sein. Ist die BDE 4.x oder höher nicht installiert, erhalten Sie sie durch Installation von Paradox 8.0 oder Delphi. Wenn Sie über ein ältere Version der BDE verfügen, die das Paradox 8-Dateiformat nicht unterstützt, können Sie die Engine über Borlands Seiten im World Wide Web aktualisieren. Selbst wenn Sie die BDE nicht auf Ihrem Computer installiert haben, können Sie dennoch Paradox 3.x, 4.x und 5.0-Tabellen (mit Schreibschutz) verknüpfen.

  • Wenn Sie eine Paradox-Tabelle verknüpfen, die sich auf einem Netzwerk-Server befindet und von mehreren Benutzern gemeinsam genutzt wird, müssen Sie den ParadoxNetPath-Schlüssel in der Windows-Registrierung auf den Pfad der Datei PARADOX.NET oder PDOXUSRS.NET setzen. Wenn Sie außerdem Paradox, Version 4.x, zum gemeinsamen Nutzen von Daten in Ihrer Arbeitsgruppe verwenden, müssen Sie den ParadoxNetStyle-Schlüssel auf 4.x setzen. Um weitere Informationen zu diesen Einstellungen anzuzeigen, klicken Sie auf [image] .

  • Wenn Sie Microsoft Access zum Verknüpfen von Paradox-Daten auf einem Netzwerk verwenden, während diese Daten von anderen Benutzern verwendet werden, müssen Sie sicherstellen, dass in der Registrierung alle drei Paradox-Einstellungen, ParadoxUserName, ParadoxNetPath und ParadoxNetStyle, definiert sind. Verwenden Sie die Einstellung ParadoxUserName zum Festlegen eines eindeutigen Benutzernamens für den Zugriff auf die gemeinsam genutzten Paradox-Daten. Verwenden Sie die Einstellung ParadoxNetPath zum Festlegen des vollständigen Pfades zu dem Ordner, der die Datei PARADOX.NET (für Paradox 3.x) oder die Datei PDOXUSRS.NET (für Paradox 4.x und 5.0) enthält. Die Einstellung ParadoxNetPath (einschließlich des Laufwerkbuchstabens) muss für alle Benutzer, die eine bestimmte Datenbank gemeinsam nutzen, identisch sein. Verwenden Sie die Einstellung ParadoxNetStyle zum Festlegen des Netzwerksperrmodus, der beim Zugriff auf Paradox-Daten gültig sein soll. Mögliche Werte sind 3.x für Paradox 3.x und 4.x für Paradox 4.x und 5.0. Weitere Informationen finden Sie im Paradox Network Administrator's Guide. Um weitere Informationen zum Festlegen dieser Einstellungen anzuzeigen, klicken Sie auf [image] .


 Warum kann eine verknüpfte SQL-Tabelle nicht geöffnet oder aktualisiert werden?

Warum kann eine verknüpfte SQL-Tabelle nicht geöffnet oder aktualisiert werden?

  • Microsoft Access benötigt einen eindeutigen Index zum Aktualisieren, Löschen oder Einfügen von Daten in einer verknüpften SQL-Tabelle oder -Sicht. Wenn Sie eine aktualisierbare Sicht eines Microsoft SQL-Servers oder eine SQL-Datenbanktabelle, die keinen eindeutigen Index besitzt, verknüpfen möchten, fordert Microsoft Access Sie auf, ein Feld oder mehrere Felder zum Erstellen eines eindeutigen Indexes auszuwählen. Microsoft Access überprüft jedoch nicht, ob das ausgewählte Feld bzw. die ausgewählten Felder die Datensätze eindeutig kennzeichnen. Befinden sich im Index, der von Microsoft Access erstellt wird, doppelte Werte, können Sie die entsprechenden Datensätze nicht aktualisieren.

    Wenn Sie vermuten, dass das ausgewählte Feld oder die ausgewählten Felder keinen eindeutigen Index erstellen lassen, löschen Sie die Verknüpfung mit der Tabelle, verknüpfen Sie sie dann erneut, und wählen Sie das passende Feld oder die passenden Felder aus, um einen eindeutigen Index zu erstellen.

    Als weitere Möglichkeit können Sie mit Microsoft Access einen Index erzeugen, indem Sie eine Datendefinitionsabfrage unter Verwendung der Anweisung Create Index erstellen. Achten Sie wiederum darauf, dass Sie ein Feld oder eine Feldkombination auswählen, das bzw. die die Datensätze eindeutig kennzeichnet. Enthält der erzeugte Index dennoch doppelte Werte, verlaufen sämtliche Aktualisierungen der Tabelle fehlerhaft. Verwenden Sie zum Löschen des Indexes eine weitere Datendefinitionsabfrage. Um weitere Informationen zum Erstellen einer solchen Datendefinitionsabfrage anzuzeigen, klicken Sie auf [image] .

  • Wenn Sie eine SQL-Tabelle mit einem eigenen eindeutigen Index verknüpfen, wobei der Index für ein Feld mit Gleitkommazahlen definiert ist, können Sie die Tabelle nicht aktualisieren. Da SQL-Server Gleitkommadaten mit unterschiedlicher Genauigkeit behandeln, kann es manchmal zum Genauigkeitsverlust kommen. Die tatsächliche Differenz ist meist so geringfügig, dass sie vernachlässigt werden kann. Wenn die Daten jedoch Bestandteil des Lesezeichens der SQL-Tabelle sind, kann es für Microsoft Access den Anschein haben, als seien die betroffenen Datensätze gelöscht.

  • Wenn beim Importieren, Verknüpfen oder Arbeiten mit einer SQL-Datenbanktabelle andere Fehler auftreten, kann dies an Ihren Zugriffsrechten auf dem SQL-Datenbank-Server oder an der Datenbank selbst liegen. Wenn Sie auf eine SQL-Datenbanktabelle nicht zugreifen können, wenden Sie sich an die SQL-Datenbankadministration.


 Warum können die Spalten im Diagramm eines Formulars oder Berichts nicht in der gewünschten Reihenfolge angeordnet werden?

Warum können die Spalten im Diagramm eines Formulars oder Berichts nicht in der gewünschten Reihenfolge angeordnet werden?

Wenn Sie die Daten in einer anderen Reihenfolge anordnen möchten, können Sie die in der Diagrammeigenschaft Datensatzherkunft definierte Abfrage ändern.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Vergewissern Sie sich, dass das Diagramm markiert ist, und klicken Sie dann auf Eigenschaften [image] .

  3. Klicken Sie neben dem Einstellungsfeld für die Eigenschaft Datensatzherkunft auf die Generator-Schaltfläche [image] .

  4. Ordnen Sie in der Abfrage die Felder, die sortiert werden sollen, in der gewünschten Reihenfolge von links nach rechts an.
  5. Schließen Sie die Abfrage, und speichern Sie die Änderungen.

  6. Wechseln Sie zur Formularansicht oder zur Seitenansicht, um die Änderungen anzuzeigen.


Es soll auf eine andere Spalte als die gebundene im Listen- oder Kombinationsfeld eines Formulars oder Berichts verwiesen werden

Um auf eine andere Spalte als die gebundene zu verweisen, verwenden Sie die Eigenschaft Spalte. Diese basiert auf der Spalte Null. Um z.B. in einem Kombinationsfeld namens Lieferantenauswahl des Formulars Artikel auf die zweite Spalte zu verweisen, verwenden Sie die folgende Syntax:

Formulare![Artikel]![Lieferantenauswahl].Spalte(1)


 Es sind nur die Daten einer Tabelle zu sehen. Wie können die Daten anderer Tabellen angezeigt werden?

Es sind nur die Daten einer Tabelle zu sehen. Wie können die Daten anderer Tabellen angezeigt werden?

Um die Daten mehrerer Tabellen anzuzeigen, muss das Formular auf einer Abfrage basieren, die die Daten der Tabellen zusammenführt. Um eine Abfrage auf Basis mehrerer Tabellen zu erstellen, ohne das Formular zu schließen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie in der Entwurfsansicht des Formulars auf den Formularmarkierer, um das Eigenschaftenfenster des Formulars zu öffnen.

  2. Klicken Sie neben dem Einstellungsfeld der Eigenschaft Datenherkunft auf die Generator-Schaltfläche [image] , um den Abfrage-Generator zu öffnen.

  3. Fügen Sie im Abfrage-Generator die Tabellen und Felder hinzu, die Sie in die zugrunde liegende Abfrage aufnehmen möchten, und schließen Sie den Abfrage-Generator.

Microsoft Access aktualisiert die Eigenschaft Datenherkunft, so dass die von Ihnen erstellte Abfrage verwendet wird.

Um Informationen zum Hinzufügen von Tabellen im Abfrage-Generator in einer Microsoft Access-Datenbank (.mdb) anzuzeigen, klicken Sie auf [image] . Um Informationen zum Hinzufügen von Feldern anzuzeigen, klicken Sie auf [image] .

Um Informationen zum Hinzufügen von Tabellen im Abfrage-Generator in einem Microsoft Access-Projekt (.adp) anzuzeigen, klicken Sie auf [image] . Wenn Sie Informationen zum Hinzufügen von Feldern benötigen, klicken Sie auf [image] .

Anmerkung Sie können ein Formular auf Basis mehrerer Tabellen auch mit Hilfe eines Assistenten erstellen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Warum kann aus dem Listenfeld, Kombinationsfeld oder der Dropdownliste oder kein Wert ausgewählt werden?

Vielleicht haben Sie den Feldnamen im Einstellungsfeld der Eigenschaft Steuerelementinhalt nicht richtig geschrieben. Mit Hilfe der Eigenschaft Datensatzherkunft (Formulare und Berichte) bzw. ListRowSource (Datenzugriffsseiten) legen Sie die Einträge fest, aus denen sich die Liste zusammensetzen soll. Wenn Sie auf einen Listeneintrag klicken, muss Microsoft Access wissen, an welcher Stelle der ausgewählte Wert gespeichert werden soll. Mit Hilfe der Eigenschaft Steuerelementinhalt legen Sie fest, an welcher Stelle die Werte gespeichert werden sollen.


Warum kann in das Kombinationsfeld eines Formulars kein neuer Wert eingegeben werden?

Die Eigenschaft NurListeneinträge wurde auf Ja eingestellt. Stellen Sie die Eigenschaft NurListeneinträge auf Nein ein, um in das Kombinationsfeld neue Werte eingeben zu können. Wird im Textfeldteil des Kombinationsfelds nicht die gebundene Spalte angezeigt, stellt Microsoft Access die Eigenschaft NurListeneinträge automatisch auf Ja ein.


Sie können Daten in der Kreuztabellenabfrage nicht aktualisieren

Daten in einer Kreuztabellenabfrage können nicht aktualisiert werden. Zum Anzeigen von Informationen darüber, wann Daten aus einer Abfrage aktualisiert werden können, klicken Sie auf [image] .


Sie können die Daten in Ihrer Abfrage nicht aktualisieren

Es gibt einige Abfragetypen und bestimmte Felder in Abfragen, die nicht aktualisiert werden können. Zum Anzeigen von Informationen darüber, wann Sie Daten aktualisieren können, klicken Sie auf [image] .


 Ein Diagramm in einem Formular oder Bericht erscheint abgeblendet oder ist leer.

Ein Diagramm in einem Formular oder Bericht erscheint abgeblendet oder ist leer.

Möglicherweise ist die Datensatzherkunft-Eigenschaft für ein Diagramm ungültig.

  1. Öffnen Sie das Formular in der Entwurfsansicht für Formulare oder den Bericht in der Entwurfsansicht für Berichte.

  2. Vergewissern Sie sich, dass das Diagramm markiert ist, und klicken Sie dann auf Eigenschaften [image] .

  3. Stellen Sie sicher, dass das Einstellungsfeld für die Eigenschaft Datensatzherkunft eine gültige Abfrage oder SQL-Anweisung enthält.

    Zum Anzeigen von Informationen über die Datensatzherkunft-Eigenschaft klicken Sie auf [image] .

  4. Wechseln Sie zur Formularansicht oder zur Seitenansicht, um die Änderungen anzuzeigen.

Wenn das Diagramm an einen Datensatz gebunden ist, enthält die Abfrage in der Datensatzherkunft-Eigenschaft des Diagramms möglicherweise kein Feld, das mit den Feldern in den LinkChildFields- und LinkMasterFields-Eigenschaften des Formulars oder Berichts übereinstimmt. Weitere Informationen über datensatzgebundene Diagramme anzeigen.


 Das Diagramm in einem Formular oder Bericht wurde geändert. Warum werden die Änderungen nicht gespeichert?

Das Diagramm in einem Formular oder Bericht wurde geändert. Warum werden die Änderungen nicht gespeichert?

Ein Diagramm besteht aus Informationen aus den folgenden Quellen, wobei die hier angeführte Rangfolge gilt:

  • Daten in der zugrunde liegenden Tabelle oder einer anderen Datensatzquelle.

  • Die Datensatzherkunft-Diagrammeigenschaft

  • Daten aus der Anwendung Microsoft Graph

Microsoft Access erzeugt dieses Diagramm bei jedem Drucken, beim Anzeigen in der Seitenansicht oder beim Wechseln zur Formularansicht neu. Aus diesem Grund können Änderungen am Diagramm, die Sie in Microsoft Graph vornehmen, durch die zugrunde liegenden Daten oder durch den Inhalt der Eigenschaft Datensatzherkunft überschrieben werden.

Berücksichtigen Sie beim Ändern eines Diagramms die folgenden Punkte:

  • Änderungen an den zugrunde liegenden Daten (z. B. am Format der Daten) haben Vorrang vor anderen Änderungen. Wenn jedoch die Eigenschaft Datensatzherkunft ein berechnetes Feld enthält (z. B. =Format([StartDatum];"MMM")), wird das Format vom Ergebnis der Berechnung und nicht von den zugrunde liegenden Daten bestimmt.

  • Änderungen in der Eigenschaft Datensatzherkunft, wie z. B. Änderungen am Titel und an Bezeichnungen des Diagramms, können von Änderungen überschrieben werden, die in den zugrunde liegenden Daten vorgenommen werden.

  • Änderungen, die in Microsoft Graph vorgenommen werden, wie z. B. Änderungen auf der Basis der Daten, können von Änderungen überschrieben werden, die Sie in der zugrunde liegenden Tabelle oder anderen Datensatzquelle oder aber in der Datensatzherkunft-Eigenschaft vornehmen.

Zum Anzeigen von Informationen über die Datensatzherkunft-Eigenschaft klicken Sie auf [image] .


Zeilen- oder Spaltenüberschriften enthalten nicht die korrekten Feldwerte

Stellen Sie sicher, dass für das Feld, dessen Werte Sie für Spaltenüberschriften verwenden möchten, im Abfrageentwurfsbereich in der Zeile Kreuztabelle der Eintrag Spaltenüberschrift enthalten ist, und dass Felder, deren Werte Sie als Zeilenüberschriften verwenden möchten, in der Zeile Kreuztabelle den Eintrag Zeilenüberschrift enthalten. Zum Ändern des Wertes in einer Zelle der Zeile Kreuztabelle klicken Sie auf die Zelle und dann auf einen Wert in der Liste. Wenn Sie nur bestimmte Werte als Spaltenüberschriften anzeigen möchten, stellen Sie die Abfrageeigenschaft FixierteSpaltenüberschrift ein. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Die Spalten, die die Abfrage ausgibt, sind nicht korrekt

Welches Problem liegt vor?

Die Abfrage gibt zu viele Spalten aus.

Die Abfrage gibt zu wenige Spalten aus.

Die Abfrage gibt nicht die gewünschten Spalten aus.


 Ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld wurde hinzugefügt, aber die Optionsgruppe ist nicht funktionsfähig

Ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld wurde hinzugefügt, aber die Optionsgruppe ist nicht funktionsfähig

Unter Umständen haben Sie das Steuerelement außerhalb der Optionsgruppe platziert. Wenn Sie ein Kontrollkästchen, eine Umschaltfläche oder ein Optionsfeld einer Optionsgruppe hinzufügen, markiert Microsoft Access die Optionsgruppe und zeigt damit an, dass das Steuerelement zu einem Bestandteil der Optionsgruppe wird. Ist die Optionsgruppe nicht markiert, setzen Sie das Steuerelement vermutlich zu nahe an den Rand der Optionsgruppe.


Erneutes Anzeigen der Datensätze nach Verwendung des Befehls "Daten eingeben"

  • Klicken Sie im Menü Datensätze auf Filter/Sortierung entfernen.


 Die Löschabfrage hat Datensätze aus der falschen Tabelle gelöscht

Die Löschabfrage hat Datensätze aus der falschen Tabelle gelöscht

Stellen Sie sicher, dass die Abfrage Folgendes enthält:

  • Die Tabelle, aus der Sie Datensätze löschen möchten. Ziehen Sie das Sternchen (*) aus der Feldliste dieser Tabelle in den Abfrage-Entwurfsbereich.

  • Das Feld oder die Felder, für das/die Sie Kriterien festlegen möchten. Ziehen Sie das gewünschte Feld bzw. die Felder aus der Feldliste der Tabelle in den Entwurfsbereich.

Im Abfrageentwurfsbereich wird in der Zeile Löschen entweder Von oder Bedingung angezeigt. Von wird in der Zeile Löschen der Tabelle angezeigt, aus der Sie Daten löschen. Bedingung wird in der Zeile Löschen für das/die Feld(er) angezeigt, für das/die Sie Kriterien festlegen.


 Das Bild in einem Formular oder Bericht erscheint verzerrt, wenn die Größe angepasst wird

Das Bild in einem Formular oder Bericht erscheint verzerrt, wenn die Größe angepasst wird

Um bei der Größenanpassung eines Bildes die Größenverhältnisse beizubehalten, verwenden Sie die Eigenschaft Bildgrößenmodus (für Hintergrundbilder) bzw. Größenanpassung (für gebundene Objektfelder, Objektfelder und Bild-Steuerelemente). Ist das Bild eine Bitmap, verwenden Sie am besten nicht die Einstellung Dehnen, sondern die Einstellung Zoomen. Vielleicht verwenden Sie an Stelle einer Bitmap auch eine Metadatei, deren Größe sich ohne Verzerrungen anpassen lässt. Zum Anzeigen von Informationen zur Verwendung von Metadateien an Stelle von Bitmaps klicken Sie auf [image] .


Das Kombinationsfeld enthält die Meldung "#Fehler?" bzw. ist leer

Sie haben vermutlich für eine der folgenden Eigenschaften in einem Formular oder Bericht eine falsche Einstellung festgelegt: Datensatzherkunft, Steuerelementinhalt, GebundeneSpalte, Spaltenbreiten, Spaltenanzahl. Zum Anzeigen von Informationen über diese und weitere Eigenschaften, die Sie in einem Listen- oder Kombinationsfeld verwenden können, klicken Sie auf [image] .


 #Fehler? oder #Name? wird in einem Steuerelement eines Formulars oder eines Berichts angezeigt

#Fehler? oder #Name? wird in einem Steuerelement eines Formulars oder eines Berichts angezeigt

#Fehler? oder #Name? kann in einem Steuerelement aus einer Vielzahl von Gründen heraus angezeigt werden. So beheben Sie das Problem:

  • Stellen Sie sicher, dass das in der Steuerelementinhalt-Eigenschaft des Steuerelements angegebene Feld nicht aus der zugrunde liegenden Tabelle oder aus einer anderen Datenquelle entfernt wurde.

  • Prüfen Sie, ob der Feldname in der Steuerelementinhalt-Eigenschaft des Steuerelements richtig angegeben wurde.

  • Wenn Sie einen Ausdruck in der Steuerelementinhalt-Eigenschaft des Steuerelements angegeben haben, sollten Sie sicherstellen, dass vor dem Ausdruck ein Gleichheitszeichen steht.

  • Stellen Sie sicher, dass in Ausdrücken Klammern um Referenzen auf Steuerelement- oder Feldnamen stehen, wenn diese Namen Leerstellen enthalten. Wenn zum Beispiel eine Subtraktion zwischen den Feldern Versanddatum und Bestelldatum ausgeführt werden soll, geben Sie den Ausdruck folgendermaßen ein: =[Bestelldatum]-[Versanddatum].

  • Wenn Sie eine der eingebauten Funktionen verwenden, sollten Sie sicherstellen, dass Sie die richtige Anzahl Argumente verwenden, dass die Argumente in der richtigen Reihenfolge stehen und dass Sie keine erforderlichen Satzzeichen weggelassen haben. Wenn Sie die richtige Syntax feststellen möchten, rufen Sie das entsprechende Hilfethema zur jeweils verwendeten Funktion auf.

  • Wenn Sie auf ein anderes Steuerelement verweisen, sollten Sie sicherstellen, dass Sie die richtige Syntax verwenden. Wenn Sie weitere Informationen zu Verweisen auf Steuerelemente benötigen, klicken Sie auf [image] .

  • Stellen Sie sicher, dass kein Zirkelbezug auf ein Steuerelement besteht. Wenn Sie zum Beispiel in der Name-Eigenschaft eines Steuerelements MeinSteuerelement angeben und dann im Einstellungsfeld der Steuerelementinhalt-Eigenschaft für das Steuerelement =[A]+[B]+[MeinSteuerelement] angeben, kann Microsoft Access diesen Ausdruck nicht verarbeiten.


Beim Verweisen auf Spalten in einem Listen- oder Kombinationsfeld treten unerwartete Ergebnisse auf

Mit der Eigenschaft Column können Sie auf eine Spalte in einem Listen- oder Kombinationsfeld Bezug nehmen. Diese Eigenschaft kann aus folgenden Gründen unerwartete Ergebnisse liefern:

  • Sie haben keine Indexnummer für die Eigenschaft Column angegeben. Die Indexnummer steht für die Spalte, auf die Sie verweisen. Column(0) verweist z.B. auf die erste Spalte eines Listen- oder Kombinationsfelds.

  • Sie haben die Indexnummer der falschen Spalte angegeben. Beachten Sie, dass die Indexnummern für die Eigenschaft Column bei 0 beginnen. Column(0) verweist auf die erste Spalte, Column(1) auf die zweite usw.

  • Sie führen eine numerische Berechnung direkt auf dem von der Eigenschaft Column zurückgegebenen Wert durch. Da die Eigenschaft Column einen Textwert zurückgibt, müssen Sie diesen zunächst in einen numerischen Wert umwandeln, bevor Sie eine numerische Berechnung durchführen können. Der folgende Ausdruck verwendet z.B. die Funktion CCur, um den von der Eigenschaft Column zurückgegebenen Wert in einen Wert des Typs Währung umzuwandeln, bevor er mit dem Wert des Feldes Menge multipliziert wird:

    [Menge] * CCur([PreisListenfeld].Column(1))

Um weitere Informationen zum Verweisen auf eine Spalte in einer Liste zu erhalten, klicken Sie auf [image] .


 Beim Kombinieren (Verketten) von Steuerelement- oder Feldwerten, Variablen oder Text in einem Ausdruck treten unerwartete Ergebnisse auf

Beim Kombinieren (Verketten) von Steuerelement- oder Feldwerten, Variablen oder Text in einem Ausdruck treten unerwartete Ergebnisse auf

Beim Verketten von Steuerelementwerten, Feldwerten oder Text in einem Ausdruck können aus folgenden Gründen unerwartete Ergebnisse auftreten:

  • Sie beziehen sich auf ein Steuerelement oder Feld, das den gleichen Namen wie das aktuelle Steuerelement besitzt. Dadurch kommt es zu einer zirkulären Abhängigkeit. Ändern Sie den Namen des Feldes oder Steuerelements.

  • Sie beziehen sich auf ein Steuerelement oder Feld, dessen Name Sie falsch geschrieben haben. Überprüfen Sie, ob der Name korrekt eingegeben wurde.

  • Sie beziehen sich auf ein Steuerelement oder Feld, das den gleichen Namen besitzt wie eine Eigenschaft. Verwenden Sie für das Steuerelement oder Feld den vollständigen Bezeichner. Um weitere Informationen zu Bezeichnern in Ausdrücken zu erhalten, klicken Sie auf [image] .

  • Microsoft Access wertet den Ausdruck nicht richtig aus, da ein Teil des Ausdrucks in eckige Klammern ([ ]), Hochkommata (') oder Anführungszeichen (") gesetzt werden muss. Überprüfen Sie, ob Klammern, Hochkommata oder Anführungszeichen erforderlich sind.

Um weitere Informationen zum Verketten von Werten in Textausdrücken zu erhalten, klicken Sie auf [image] .


Beim Eingeben von Datumswerten in einen Ausdruck treten unerwartete Ergebnisse auf

Microsoft Access kann unerwartete Ergebnisse liefern, wenn Sie einen Datumswert in einen Ausdruck eingeben, ohne ihn in Nummernzeichen (#) zu setzen. Um weitere Informationen zum Eingeben von Ausdrücken zu erhalten, klicken Sie auf [image] .


 Beim Durchführen von Operationen in Feldern mit leeren Werten treten unerwartete Ergebnisse auf

Beim Durchführen von Operationen in Feldern mit leeren Werten treten unerwartete Ergebnisse auf

Viele Operationen können unerwartete Ergebnisse liefern, wenn Sie sich mit Hilfe eines Ausdrucks auf ein Feld beziehen, das einen leeren Wert (Nullwert) enthält. Die Funktionen DCount oder DSum z.B. können unerwartete Ergebnisse liefern, wenn Sie Kriterienausdrücke verwenden, die sich auf ein Feld mit Nullwerten beziehen.

Um dieses Problem zu beseitigen, haben Sie folgende Möglichkeiten:

  • Übergeben Sie Feldwerte an die Funktion Nz im Ausdruck. Wenn diese Funktion einen Nullwert auswertet, gibt sie 0 oder eine leere Zeichenfolge zurück. Um weitere Informationen zur Funktion Nz zu erhalten, klicken Sie auf [image] .

  • Verwenden Sie die Funktionen IIf und IsNull, um zu überprüfen, ob ein Wert Null ist, und geben Sie dann einen geeigneten Wert zurück. Um weitere Informationen zur Funktion IIf zu erhalten, klicken Sie auf [image] . Um weitere Informationen zur Funktion IsNull zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zum Einstellen von Feldeigenschaften zu erhalten, die die Handhabung von leeren Feldern festlegen, klicken Sie auf [image] .


Wie wird Text konvertiert, damit der erste Buchstabe in Großbuchstaben erscheint?

Sie können Text so konvertieren, dass nur der erste Buchstabe groß geschrieben ist, indem Sie die Funktion StrConv verwenden.


 Beim Verweisen auf eine Eigenschaft oder ein Steuerelement in einem Unterformular oder Unterbericht werden unerwartete Ergebnisse angezeigt

Beim Verweisen auf eine Eigenschaft oder ein Steuerelement in einem Unterformular oder Unterbericht werden unerwartete Ergebnisse angezeigt

Microsoft Access kann unerwartete Ergebnisse liefern, wenn Sie beim Verweisen auf eine Eigenschaft oder ein Steuerelement in einem Unterformular oder Unterbericht nicht den korrekten Bezeichner verwenden.

Um auf eine Eigenschaft in einem Unterformular oder Unterbericht zu verweisen, müssen Sie einen vollständigen Bezeichner für das Formular oder den Bericht eingeben, indem Sie die Eigenschaft Formular oder Bericht eines Unterformulars oder Unterberichts verwenden. Beispielsweise verweist der folgende Bezeichner auf die Eigenschaft Visible des Unterformulars Bestellungen Unterformular:

Formulare![Bestellungen]![Bestellungen UnterformularSteuerelement].Formular.Visible

Für dieses Beispiel gilt:

  • Formulare![Bestellungen]![Bestellungen UnterformularSteuerelement] verweist auf das Unterformular-Steuerelement, das das Unterformular enthält.

  • Formulare![Bestellungen]![BestellungenUnterformularSteuerelement].Formular verweist auf das eigentliche Unterformular. Sie müssen die Eigenschaft Form festlegen, um auf das eigentliche Unterformular oder eine seiner Eigenschaften zu verweisen.

Im Gegensatz dazu müssen Sie die Eigenschaft Formular oder Bericht nicht verwenden, wenn Sie auf ein Steuerelement in einem Unterformular oder Unterbericht bzw. auf eine der Eigenschaften des Steuerelements verweisen. Beispielsweise verweist der folgende Bezeichner auf die Eigenschaft Visible des Steuerelements Rabatt im Unterformular Bestellungen Unterformular:

Formulare![Bestellungen]![Bestellungen UnterformularSteuerelement]![Rabatt].Visible

Um weitere Informationen zum Verweisen auf Formulare, Berichte, Unterformulare oder Unterberichte in einem Ausdruck zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zum Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft in einem Ausdruck zu erhalten, klicken Sie auf [image] .

Um weitere Informationen zu Bezeichnern in Ausdrücken zu erhalten, klicken Sie auf [image] .


Es wurde ein Filter in einem Unterformular erstellt. Warum wirkt der Filter nicht auch auf das Hauptformular?

Der Filter hat korrekt funktioniert. Wenn Sie einen Filter für ein Unterformular erstellen, gilt er nur für dieses Unterformular. Wenn Sie die Datensätze des Hauptformulars filtern möchten, klicken Sie auf das Hauptformular, und erstellen dann den Filter.


 Ich erhalte unerwarteterweise eine Aufforderung zum Eingeben eines Parameters

Ich erhalte unerwarteterweise eine Aufforderung zum Eingeben eines Parameters

Wenn Sie bei dem Versuch, eine Abfrage, einen Bericht oder eine Datenzugriffsseite auszuführen, unerwarteterweise eine Aufforderung zum Eingeben eines Parameters erhalten, liegt möglicherweise einer der folgenden Umstände vor:

  • Sie haben einen Parameter aus dem Abfrage-Entwurfsbereich, nicht jedoch im Dialogfeld Abfrageparameter gelöscht (im Befehl Parameter des Menüs Abfrage).

  • Sie haben ein Feld in der Abfrage, dem Bericht oder der Datenzugriffsseite, nicht jedoch in der/den der Abfrage zugrunde liegenden Tabelle(n) umbenannt oder falsch geschrieben.

  • Sie haben ein Feld verwendet, das auf ein berechnetes Feld verweist. Wenn ein Feld in der Abfrage eine Berechnung durchführt, müssen Sie sicherstellen, dass für das berechnete Feld im Abfrageentwurfsbereich das Kontrollkästchen Anzeigen aktiviert ist.


Die Spaltenüberschriften werden nicht in der gewünschten Reihenfolge angezeigt, oder es sollen einige Überschriften ausgeschlossen werden

Sie können festlegen, welche Spaltenüberschriften in welcher Reihenfolge angezeigt werden sollen. Dazu stellen Sie die Abfrageeigenschaft FixierteSpaltenüberschrift ein. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Löschen von doppelten Datensätzen, die mit dem Abfrage-Assistenten zur Duplikatsuche gefunden wurden

Löschen von doppelten Datensätzen, die mit dem Abfrage-Assistenten zur Duplikatsuche gefunden wurden

Sie können den doppelten Datensatz oder das Original direkt in der Datenblattansicht der Abfrage löschen. Dazu klicken Sie auf den Datensatz und dann in der Symbolleiste auf Datensatz löschen [image] .

Wenn Microsoft Access automatisch alle Duplikate löschen und das Original beibehalten soll, dürfen Sie nicht den Abfrage-Assistenten zur Duplikatsuche verwenden oder eine Abfrage zur Duplikatsuche in eine Löschabfrage umwandeln. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 In Microsoft Excel können keine Änderungen vorgenommen werden, obwohl auf die Schaltfläche zum Bearbeiten des PivotTable-Formulars geklickt wurde

In Microsoft Excel können keine Änderungen vorgenommen werden, obwohl auf die Schaltfläche zum Bearbeiten des PivotTable-Formulars geklickt wurde

Bevor Sie ein PivotTable-Formular bearbeiten können, müssen Sie die angezeigten Daten aktualisieren.

  1. Öffnen Sie das PivotTable-Formular in der Formularansicht.

  2. Klicken Sie auf die Schaltfläche PivotTable-Objekt bearbeiten.

  3. Klicken Sie im Microsoft Excel-Menü Daten auf Daten aktualisieren.

Jetzt sollten Sie in der Lage sein, das PivotTable-Formular zu bearbeiten.

Anmerkung Zum Bearbeiten des PivotTable-Formulars können Sie Microsoft Excel verwenden und die Microsoft Excel-Hilfe zu PivotTable-Berichten aufrufen. Wenn Sie die benötigten Informationen nicht in den Microsoft Excel-Hilfethemen finden, können Sie die Microsoft Access-Hilfe verwenden, wenn das PivotTable-Formular in Microsoft Access in der Formularansicht geöffnet ist.


Das PivotTable-Objekt kann nicht gefunden werden, wenn Microsoft Excel nicht über das Formular, das das PivotTable-Objekt enthält, geöffnet wird

Ein PivotTable-Objekt ist ein eingebettetes Objekt, das in Microsoft Access gespeichert ist. Wenn Sie ein PivotTable-Objekt mit Hilfe des Microsoft Excel PivotTable-Bericht-Assistenten bearbeiten möchten, klicken Sie zunächst im Microsoft Access-Formular auf die Schaltfläche PivotTable-Objekt bearbeiten. Nachdem Sie das PivotTable-Objekt in Microsoft Excel geöffnet haben, können Sie eine Kopie davon als Microsoft Excel PivotTable-Bericht speichern. Der PivotTable-Bericht in Excel und das PivotTable-Objekt im Microsoft Access-Formular sind jedoch nicht miteinander verknüpft. Wenn Sie das PivotTable-Objekt in Access ändern, werden die Änderungen im PivotTable-Bericht in Excel nicht angezeigt und umgekehrt. Die Daten sind somit nicht mehr konsistent.


 Die Meldung "Abfrage enthält zweideutige Inklusionsverknüpfungen" wird angezeigt

Die Meldung "Abfrage enthält zweideutige Inklusionsverknüpfungen" wird angezeigt

Dies kann auftreten, wenn Sie versuchen, eine Abfrage mit bestimmten Kombinationen von Verknüpfungen auszuführen. Ein Beispiel für die Ursachen eines solchen Konflikts sowie Informationen zu dessen Behebung finden Sie im Artikel Q124937, "Erklärung zur Fehlermeldung 'Zweideutige Inklusionsverknüpfung'" der Microsoft Knowledge Base. Um Informationen über den Zugriff auf die Knowledge Base oder auf andere technische Ressourcen, die online verfügbar sind, anzuzeigen, klicken Sie auf [image] .


 Warum werden beim Anfügen einer Kalkulationstabelle oder Textdatei Fehler gemeldet?

Warum werden beim Anfügen einer Kalkulationstabelle oder Textdatei Fehler gemeldet?

In einer Microsoft Access-Datenbank wird für die meisten Datensätze, die einen Fehler verursachen, einer Tabelle namens Importfehler eine Zeile hinzugefügt. Um die vollständige Liste der aufgetretenen Fehler anzuzeigen, öffnen Sie die Tabelle Importfehler im Datenbankfenster. Um weitere Informationen zu den Meldungen der Tabelle Importfehler anzuzeigen, klicken Sie auf [image] .

In einem Microsoft Access-Projekt wird keine Tabelle namens Importfehler erstellt. Verwenden Sie DTS (Data Transformation Services), um Daten schneller und flexibler zu importieren und umzuwandeln. Weitere Informationen finden Sie in der Microsoft SQL Server-Dokumentation.

Anzufügende Datensätze müssen zur Struktur der bestehenden Tabelle kompatibel sein. Die Felder müssen vom selben Datentyp sein wie die entsprechenden Felder der Zieltabelle, und sie müssen sich in derselben Reihenfolge befinden (es sei denn, Sie verwenden die erste Zeile der Datei als Feldnamen, wobei dann die Feldnamen übereinstimmen müssen).

Wenn Sie vermuten, dass sich das Problem auf die anzufügenden Daten bezieht, bearbeiten Sie Ihre Kalkulationstabelle oder Textdatei, und importieren Sie sie dann erneut. Andernfalls müssen Sie unter Umständen die Zieltabelle ändern. Sie können die Felder neu anordnen, Datentypen ändern oder eine Aktualisierungsabfrage (z.B. zum Neuformatieren oder Neuberechnen der Daten) oder eine Tabellenerstellungsabfrage (z.B. zum Teilen eines Feldes in zwei Felder oder Verbinden mehrerer Felder zu einem Feld) durchführen.

Dies sind die häufigsten Ursachen für das Auftreten von Fehlern:

  • Die Feldnamen in der Kalkulationstabelle oder Textdatei stimmen nicht mit den Feldnamen der Tabelle überein, an die Daten angehängt werden sollen.

  • Die Daten eines Feldes passen nicht zum Datentyp des Zielfeldes. Dies ist z.B. der Fall, wenn das Zielfeld vom Datentyp Datum/Uhrzeit in einer Access-Datenbank oder vom Datentyp datetime in einem Microsoft Access-Projekt ist, die Daten jedoch einen Textwert enthalten, den Microsoft Access nicht als Datum oder Uhrzeit identifizieren kann.

  • Die Daten eines numerischen Feldes sind für die Feldgröße des Zielfeldes zu lang. Beispielsweise wurde in einer Access-Datenbank für das Zielfeld die Eigenschaft Feldgröße auf Byte festgelegt, oder in einem Access-Projekt wurde der Datentyp tinyint für das Zielfeld bestimmt. Die Daten enthalten jedoch einen Wert, der größer als 255 ist.

  • Die importierten Datensätze enthalten doppelte Werte, die nicht im Feld des Primärschlüssels der Zieltabelle oder in einem beliebigen Tabellenfeld gespeichert werden können, für das in einer Access-Datenbank die Eigenschaft Indiziert auf Ja (Ohne Duplikate) eingestellt wurde bzw. für das in einem Access-Projekt die Option Doppelte Schlüssel ignorieren angegeben wurde.

  • Eine oder mehrere Zeilen der Textdatei oder Kalkulationstabelle enthalten mehr Felder als die Zieltabelle.

  • Die aus einer Microsoft Excel-Kalkulationstabelle importierten Datumsfelder sind um vier Jahre verschoben. Microsoft Excel für Windows verwendet das Datumssystem "1900", in dem serielle Zahlen von 1 bis 65.380 den Datumsangaben vom 01. Januar 1900 bis zum 31. Dezember 2078 entsprechen. Im Gegensatz hierzu verwendet Microsoft Excel für den Macintosh das Datumssystem "1904", in dem serielle Zahlen von 0 bis 63.918 den Datumsangaben vom 01. Januar 1904 bis zum 31. Dezember 2078 entsprechen.

    Ändern Sie vor dem Importieren der Daten das Datumssystem für die Microsoft Excel-Kalkulationstabelle, oder führen Sie nach dem Importieren der Daten eine Aktualisierungsabfrage durch, um die Datumsangaben zu korrigieren. Verwenden Sie in dieser Abfrage den Ausdruck [Name des Datumsfeldes] + 1462. Weitere Informationen zum Microsoft Excel-Datumssystem finden Sie in der Dokumentation zu Microsoft Excel.


 Warum werden beim Importieren einer Kalkulationstabelle oder Textdatei Fehler gemeldet?

Warum werden beim Importieren einer Kalkulationstabelle oder Textdatei Fehler gemeldet?

In einer Microsoft Access-Datenbank wird für die meisten Datensätze, die einen Fehler verursachen, einer Tabelle namens Importfehler eine Zeile hinzugefügt. Um die Liste der aufgetretenen Fehler anzuzeigen, öffnen Sie die Tabelle Importfehler im Datenbankfenster. Um weitere Informationen zu den Fehlermeldungen der Tabelle Importfehler anzuzeigen, klicken Sie auf [image] .

In einem Microsoft Access-Projekt wird keine Tabelle namens Importfehler erstellt. Verwenden Sie DTS (Data Transformation Services), um Daten schneller und flexibler zu importieren und umzuwandeln. Weitere Informationen finden Sie in der Microsoft SQL Server-Dokumentation.

Dies sind die häufigsten Ursachen für das Auftreten von Fehlern:

  • In einem Feld befinden sich Daten, die nicht dem Datentyp entsprechen, den Microsoft Access dem Feld zugewiesen hat. Sie haben z. B. versehentlich einen Wert vom Datentyp Text in ein Feld eingefügt, das nur Werte vom Datentyp Zahl oder Datum/Uhrzeit enthalten darf. Es könnte auch sein, dass eine Zeile Ihrer Textdatei oder Kalkulationstabelle Zusammenfassungsinformationen oder fremde Zeichen enthält.

    Wenn Sie sicher sind, dass Microsoft Access diesem Feld den korrekten Datentyp zugewiesen hat, bearbeiten Sie Ihre Textdatei oder Kalkulationstabelle, um die Fehler zu korrigieren, und importieren Sie sie erneut. Wiederholen Sie andernfalls den Importiervorgang, und geben Sie den passenden Datentyp an.

  • Microsoft Access hat einem Feld den falschen Datentyp zugewiesen. Jedem Feld wird ein Datentyp basierend auf den Daten der ersten importierten Zeile zugeordnet. Wenn z.B. ein Feld, das überwiegend aus Textwerten besteht, in der ersten Zeile eine Zahl enthält, wird diesem Feld in einer Access-Datenbank der Datentyp Zahl und in einem Access-Projekt der Datentyp numeric zugewiesen. In beiden Fällen kann Access die restlichen Datensätze nicht importieren.

    Wiederholen Sie den Importiervorgang, und geben Sie dabei den passenden Datentyp an.

  • Eine oder mehrere Zeilen der Textdatei oder Kalkulationstabelle enthalten mehr Felder als die erste Zeile. Die zweite Zeile einer Datei enthält z.B. ein zusätzliches Feldtrennzeichen, auf das ein Wert folgt, den Microsoft Access nicht in die neue Tabelle einordnen kann.

    Bearbeiten Sie Ihre Textdatei oder Kalkulationstabelle so, dass alle Zeilen die gleiche Anzahl von Feldern enthalten, und importieren Sie dann erneut.

  • Die aus einer Microsoft Excel-Kalkulationstabelle importierten Datumsfelder sind um vier Jahre verschoben. Microsoft Excel für Windows verwendet das Datumssystem "1900", in dem serielle Zahlen von 1 bis 65.380 den Datumsangaben vom 01. Januar 1900 bis zum 31. Dezember 2078 entsprechen. Im Gegensatz hierzu verwendet Microsoft Excel für den Macintosh das Datumssystem "1904", in dem serielle Zahlen von 0 bis 63.918 den Datumsangaben vom 01. Januar 1904 bis zum 31. Dezember 2078 entsprechen.

    Ändern Sie vor dem Importieren der Daten das Datumssystem für die Microsoft Excel-Kalkulationstabelle, oder führen Sie nach dem Importieren der Daten eine Aktualisierungsabfrage durch, um die Datumsangaben zu korrigieren. Verwenden Sie in dieser Abfrage den Ausdruck [Name des Datumsfeldes] + 1462. Weitere Informationen zum Microsoft Excel-Datumssystem finden Sie in der Dokumentation zu Microsoft Excel.


Ich benötige Hilfe beim Festlegen von Kriterien

Wobei benötigen Sie Hilfe?

Verstehen von Zweck und Funktionsweise von Kriterienausdrücken

Suchen nach Datensätzen, die ein Kriterium und/oder andere Kriterien für dasselbe oder unterschiedliche Felder erfüllen

Suchen nach Datensätzen, die Werte enthalten, die zwischen festgelegten Werten liegen oder größer als, kleiner als, gleich oder nicht gleich festgelegter Werte sind

Suchen nach Datensätzen, die mit bestimmten Zeichen oder Wörtern beginnen oder enden, oder die bestimmte Zeichen oder Wörter enthalten

Suchen nach Datensätzen, die einem Wert nicht entsprechen

Suchen nach Datensätzen, die einen Wert, und nicht leere Werte (Nullwerte) enthalten

Suchen nach Datensätzen, die keinen Wert enthalten

Suchen nach Datensätzen, die das aktuelle Datum enthalten

Suchen nach Datensätzen, die einen Wert aus einer Liste möglicher Werte enthalten

Einschränken der in eine Berechnung einbezogenen Werte

Extrahieren eines Teils eines Textfelds

Extrahieren eines Teils eines Datumsfelds

Beheben eines Problems bezüglich der Unverträglichkeit von Datentypen


 Es wird eine Meldung bezüglich einer Schlüsselverletzung angezeigt

Es wird eine Meldung bezüglich einer Schlüsselverletzung angezeigt

Eine Schlüsselverletzung tritt unter den folgenden Umständen auf:

  • Sie versuchen, eine Abfrage auszuführen, die Datensätze so anfügt, löscht oder aktualisiert, dass die Regeln der referenziellen Integrität für verknüpfte Tabellen verletzt werden.

  • Ihre Abfrage versucht, Datensätze anzufügen oder zu aktualisieren, die Primärschlüsselwerte enthalten, die bereits in der Zieltabelle enthalten sind.

Wenn Sie eine der beschriebenen Abfragen ausführen, werden die Datensätze, die die Schlüsselverletzung hervorrufen, nicht geändert.

Um die Datensätze dennoch zu ändern, so dass die referenzielle Integrität verletzt wird, können Sie die Beziehung zwischen den betroffenen Tabellen lösen oder die Option Mit referenzieller Integrität deaktivieren und die betroffenen Tabellen nacheinander ändern. In diesem Fall kann es jedoch zu Konflikten bei den Daten in den beiden Tabellen kommen, wenn die referenzielle Integrität später wieder aktiviert wird. Um weitere Informationen zur referenziellen Integrität anzuzeigen, klicken Sie auf [image] .

Um weitere Informationen zum Erstellen und Ändern von Primärschlüsseln anzuzeigen, klicken Sie auf [image] .


 Die Layout-Vorschau zeigt falsche Daten an.

Die Layout-Vorschau zeigt falsche Daten an.

Die Layout-Vorschau zeigt alle Bereiche eines Berichts mit einigen wenigen Datensätzen an. Die angezeigten Daten sind sortiert und gruppiert; Parameter, Kriterien oder Verknüpfungen in der zugrunde liegenden Abfrage werden jedoch ignoriert. So sind z. B. die Datensätze, die Sie in einer Gruppe sehen, nicht unbedingt die Datensätze, die tatsächlich in diese Gruppe gehören.

Um zu überprüfen, ob die Daten in einem Bericht richtig sind, verwenden Sie die Seitenansicht. Zum Anzeigen von Informationen klicken Sie auf [image] .


 Beim Auswählen eines Listenwertes wird dieser ausgeblendet, oder es wird eine Fehlermeldung angezeigt

Beim Auswählen eines Listenwertes wird dieser ausgeblendet, oder es wird eine Fehlermeldung angezeigt

Sie haben möglicherweise im Einstellungsfeld der Eigenschaft Gebundene Spalte (Formulare und Berichte) bzw. der Eigenschaft ListBoundField (Datenzugriffsseiten) die falsche Spalte angegeben. Die Eigenschaft Gebundene Spalte bzw. ListBoundField bestimmt die Spalte, deren Daten in dem Feld gespeichert werden, das im Einstellungsfeld der Eigenschaft Steuerelementinhalt festgelegt wurde. Enthält ein Kombinationsfeld in einem Formular oder Bericht z. B. eine Spalte Lieferanten-Nr und eine Spalte Firma, ist die Spalte Lieferanten-Nr (das Fremdschlüsselfeld) die gebundene Spalte, und zwar auch dann, wenn die Spalte Firma die einzige sichtbare Spalte ist.


 Wie wird eine Aktion in einem Makro vorübergehend deaktiviert?

Wie wird eine Aktion in einem Makro vorübergehend deaktiviert?

Das vorübergehende Deaktivieren einer Aktion ist z. B. dann hilfreich, wenn Sie in einem Makro nach Fehlern suchen. Es ist vergleichbar mit dem Ändern einer Zeile in einen Kommentar im Code von Visual Basic für Applikationen. Hierzu wird am Anfang der jeweiligen Code-Zeile ein einfaches Anführungszeichen (') eingegeben. Wenn Microsoft Access eine Aktion vorübergehend ignorieren soll, geben Sie in der Spalte Bedingung für diese Aktion Falsch ein.

Um weitere Informationen zum Eingeben einer Bedingung für eine Makroaktion anzuzeigen, klicken Sie auf [image] .


 Die Aktion "AusführenCode" führt kein Visual Basic-Modul aus

Die Aktion "AusführenCode" führt kein Visual Basic-Modul aus

Die Aktion AusführenCode dient zum Ausführen einer Funktion, nicht eines Moduls. In Microsoft Access werden Funktionen und nicht Module ausgeführt. Ersetzen Sie den Namen des Moduls durch den Namen der Funktion im Modul, die Sie ausführen möchten. Zum Ausführen einer Sub-Prozedur rufen Sie diese in der Funktion auf.

Zum Öffnen eines Moduls verwenden Sie die Aktion ÖffnenModul.


Tastenanschläge, die in einem Makro mit der Aktion Tastaturbefehle verwendet werden, werden nicht an das Dialogfeld gesendet

Da das Dialogfeld die Durchführung des Makros unterbricht, müssen Sie zur Vermeidung einer Unterbrechung die Aktion Tastaturbefehle vor der Aktion angeben, die das Dialogfeld öffnet, und das Argument Warten auf Nein setzen. Um weitere Informationen zur Aktion Tastaturbefehle anzuzeigen, klicken Sie auf [image] .


Microsoft Access zeigt beim Ausführen von Makros unerwünschte Meldungen an

Sie können Warnungen und andere Meldungen während der Durchführung eines Makros ausblenden, indem Sie im Makro die Aktion Warnmeldungen ausführen. Mit der Aktion Warnmeldungen können Sie die Meldungen auch wieder anzeigen. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Das Argument "Bedingung" in der Aktion "ÖffnenFormular" oder "ÖffnenBericht" erzeugt unerwartete Ergebnisse

Das Argument "Bedingung" in der Aktion "ÖffnenFormular" oder "ÖffnenBericht" erzeugt unerwartete Ergebnisse

Das Argument Bedingung einer Aktion ÖffnenFormular oder ÖffnenBericht kann in einem der nachstehend aufgeführten Fälle unerwartete Ergebnisse erzeugen:

  • Der Ausdruck Bedingung verwendet zum Verweisen auf den Wert eines Steuerelements oder einer Eigenschaft nicht die korrekte Syntax. Um weitere Informationen zum Verweisen auf den Wert eines Steuerelements anzuzeigen, klicken Sie auf [image] .

  • Das Argument Bedingung verwendet zum Verbinden des Wertes eines Feldes, eines Steuerelements oder einer Eigenschaft mit einer Literalzeichenfolge nicht die korrekte Syntax. Um weitere Informationen zu Werten in Ausdrücken anzuzeigen, klicken Sie auf [image] .

  • Die Aktion ÖffnenFormular oder ÖffnenBericht wird unter Verwendung der entsprechenden Visual Basic für Applikationen-Methoden in einer Prozedur ausgeführt, und das Argument Bedingung erscheint in der Liste der Argumente nicht an der richtigen Position. Wenn vor dem Argument Bedingung nicht die Argumente Ansicht und Filter angegeben wurden, muss als Platzhalter für jedes dieser Argumente ein Komma eingegeben werden.

    Um weitere Informationen zur Aktion ÖffnenFormular anzuzeigen, klicken Sie auf [image] . Zum Anzeigen weiterer Informationen zur Aktion ÖffnenBericht klicken Sie auf [image] .


 Wie wird Microsoft Visual Basic verwendet, um einen neuen Datensatz zu einer Tabelle hinzuzufügen?

Wie wird Microsoft Visual Basic verwendet, um einen neuen Datensatz zu einer Tabelle hinzuzufügen?

Sie können mit Hilfe von Code einen neuen Datensatz zu einer Tabelle oder einer Datensatzgruppe hinzufügen, indem Sie die Methoden AddNew und Update des Objekts Recordset verwenden. Weitere Informationen erhalten Sie durch Klicken auf [image] oder unter Erstellen von Anwendungsprogrammen mit Formularen und Berichten.


 Wie wird Visual Basic zum Ändern der einer Abfrage zugrunde liegenden SQL-Anweisung verwendet?

Wie wird Visual Basic zum Ändern der einer Abfrage zugrunde liegenden SQL-Anweisung verwendet?

Sie können die Eigenschaft SQL eines QueryDef-Objekts verwenden, um die einer Abfrage zugrunde liegende SQL-Anweisung zu ändern. Der folgende Visual Basic-Code ändert beispielsweise die der Abfrage Personalliste zugrunde liegende SQL-Anweisung, so dass die Abfrage alle Datensätze in der Tabelle Personal auswählt:

Dim DB As Database
Dim qryTest As QueryDef

Set DB = CurrentDb
Set qryTest = DB.QueryDefs("Personalliste")
qryTest.SQL = "SELECT * FROM Personal;"

Um weitere Informationen zur Eigenschaft SQL anzuzeigen, klicken Sie auf [image] .


Beim Verwenden einer Find-Methode treten unerwartete Ergebnisse auf

Die Methoden FindFirst, FindLast, FindNext und FindPrevious können aus folgenden Gründen unerwartete Ergebnisse erzeugen:

  • Die Syntax des Arguments Kriterien, das Sie festgelegt haben, um auf den Wert eines Steuerelements oder einer Eigenschaft zu verweisen, ist ungültig. Um weitere Informationen zum Verweisen auf den Wert eines Steuerelements anzuzeigen, klicken Sie auf [image] .

  • Die Syntax des Arguments Kriterien, das Sie festgelegt haben, um den Wert eines Feldes, eines Steuerelements oder einer Eigenschaft mit einem Zeichenfolgenliteral zu kombinieren, ist ungültig. Um weitere Informationen zu Werten in Ausdrücken anzuzeigen, klicken Sie auf [image] .

Die Methoden FindRecord und FindNext können unerwartete Ergebnisse erzeugen, wenn das Argument NurAktuellesFeld der Methode FindRecord auf acCurrent eingestellt ist. Verwenden Sie die Methode GoToControl, um den Fokus zu dem Steuerelement zu bewegen, das die gesuchten Daten enthält, bevor Sie die Methoden FindRecord oder FindNext verwenden.


 Beim Verwenden der IsLoaded-Funktion erhalte ich die Meldung "Sub oder Funktion nicht definiert."

Beim Verwenden der IsLoaded-Funktion erhalte ich die Meldung "Sub oder Funktion nicht definiert."

Die Funktion IsLoaded ist keine eingebaute Visual Basic-Funktion, sondern eine Beispielfunktion aus der Beispieldatenbank Nordwind. Wenn Sie die Funktion IsLoaded in Ihrer Datenbank verwenden möchten, öffnen Sie die Beispieldatenbank Nordwind, kopieren Sie die Funktion, und fügen Sie sie in ein Modul in Ihrer Datenbank ein.

Um weitere Informationen zum Öffnen der Beispieldatenbank Nordwind anzuzeigen, klicken Sie auf [image] .


 Beim Verweisen auf ein Tabellenfeld im Code erhalte ich die Meldung "Methode oder Datenelement nicht gefunden."

Beim Verweisen auf ein Tabellenfeld im Code erhalte ich die Meldung "Methode oder Datenelement nicht gefunden."

Microsoft Access zeigt diese Meldung an, wenn Sie den Operator . (Punkt) an Stelle des Operators ! verwenden, um direkt auf ein Tabellenfeld zu verweisen. Dieser Fehler wird z. B. durch die letzte Zeile des folgenden Visual Basic-Codes erzeugt:

Dim DB As Database
Dim tblTest As TableDef
Dim fldTest As Field

Set DB = CurrentDb
Set tblTest = DB.TableDefs("Kategorien")
Set fldTest = tblTest.[Kategorie-Nr]

Um das Problem zu beseitigen, ersetzen Sie den Operator . (Punkt) durch den Operator !, oder verweisen Sie auf das Feld als Element der Auflistung Fields. Sie können dazu eine der beiden folgenden Codezeilen verwenden, wobei die erste möglicherweise schneller zu Ergebnissen führt:

Set fldTest = tblTest![Kategorie-Nr]

Set fldTest = tblTest.Fields("Kategorie-Nr")

Um weitere Informationen zum Verwenden der Operatoren . (Punkt) und ! anzuzeigen, klicken Sie auf [image] .


 Erstellte Sub-Prozedur oder Funktion testen

Erstellte Sub-Prozedur oder Funktion testen

Sie können das Direktfenster im Visual Basic-Editor verwenden, um die Ergebnisse einer Funktion oder Sub-Prozedur zu prüfen. Wenn Sie z. B. den Wert anzeigen möchten, den die benutzerdefinierte Funktion NächsterMonatsErster zurückgibt, geben Sie der Reihenfolge nach ein Fragezeichen, ein Leerzeichen, den Namen der Funktion sowie ein beliebiges Argument, das in Klammern steht, ein:

? NächsterMonatsErster(Now)

Um weitere Informationen anzuzeigen, klicken Sie auf [image] .


 Microsoft Access zeigt beim Ausführen von Code unerwünschte Meldungen an

Microsoft Access zeigt beim Ausführen von Code unerwünschte Meldungen an

Sie können die Anzeige von Warnungen und anderen Meldungen während der Ausführung von Visual Basic-Code vorübergehend deaktivieren, indem Sie die Methode SetWarnings verwenden, um die Aktion Warnmeldungen auszuführen. Sie verwenden die Methode SetWarnings auch, um die Anzeige der Meldungen wieder zu aktivieren. Um weitere Informationen anzuzeigen, klicken Sie auf [image] .


Die AutoNachschlagen-Abfrage trägt keine Daten ein

AutoNachschlagen ist nur möglich, wenn verknüpfte Felder bestimmte Bedingungen erfüllen und wenn bestimmte Felder aus beiden Tabellen zum Abfrageentwurfsbereich hinzugefügt wurden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Die Option "Aktive Grafiken" wurde beim Zuweisen des Designs aktiviert. Warum sind die Grafiken trotzdem nicht animiert?

Designgrafiken werden nur animiert, wenn Sie die Datenzugriffsseite in einem Webbrowser, nicht in Access, anzeigen.


 Anstelle des Inhalts eines Objekts in einem Formular oder Bericht wird ein Symbol angezeigt

Anstelle des Inhalts eines Objekts in einem Formular oder Bericht wird ein Symbol angezeigt

  1. Öffnen Sie das Formular in der Entwurfsansicht, oder öffnen Sie den Bericht in der Entwurfsansicht.

  2. Klicken Sie auf das Symbol.

  3. Zeigen Sie im Menü Bearbeiten auf den entsprechenden Objekt-Befehl (z.B. für ein Microsoft Excel-Objekt auf Diagramm-Objekt), und klicken Sie dann auf Konvertieren.

  4. Deaktivieren Sie im Dialogfeld Konvertieren das Kontrollkästchen Als Symbol.


 Eine oder mehrere Spaltenüberschriften werden in den Abfrageergebnissen in Form von "<>" angezeigt

Eine oder mehrere Spaltenüberschriften werden in den Abfrageergebnissen in Form von "<>" angezeigt

Microsoft Access gibt für alle Nullwerte in Feldern, die in der Zeile Kreuztabelle den Eintrag Spaltenüberschrift enthalten, als Spaltenname die Zeichen "<>" aus. Führen Sie einen der folgenden Schritte aus, wenn Sie dies verhindern möchten:

  • Definieren Sie die Spaltenüberschriften manuell durch Einstellen der Abfrageeigenschaft FixierteSpaltenüberschrift. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Geben Sie im Entwurfsbereich in der Zeile Kriterien des Feldes für die Spaltenüberschrift Ist Nicht Null ein.

  • Verwenden Sie in der Zeile Kriterien des Feldes für die Spaltenüberschrift einen Ausdruck mit der Funktion Nz. Diese Funktion konvertiert Nullwerte in aussagekräftigere Werte, wie z. B. Unbekannt. Zum Anzeigen weiterer Informationen zur Funktion Nz klicken Sie auf [image] .


 Ich erhalte die Meldung "Operation muss eine aktualisierbare Abfrage verwenden."

Ich erhalte die Meldung "Operation muss eine aktualisierbare Abfrage verwenden."

Dieser Fehler tritt auf, wenn die Zeile Aktualisieren der aktuellen Abfrage ein Feld aus einer Kreuztabellenabfrage oder aus einer Auswahlabfrage enthält, in der für das Feld ein Aggregat berechnet wurde (unter Verwendung der Zeile Funktion oder einer Domänenfunktion in der Zeile Feld). Wenn Sie ein Feld unter Verwendung des Aggregats eines anderen Feldes aktualisieren möchten, müssen Sie das Aggregat in der Aktualisierungsabfrage selbst, nicht in einer anderen Abfrage berechnen.

  1. Entfernen Sie in der Abfrage-Entwurfsansicht der aktuellen Abfrage das Feld, das Sie aus einer Kreuztabellen- oder einer Auswahlabfrage (in der für das Feld ein Aggregat berechnet wurde) hinzugefügt haben.

  2. Geben Sie in der Zelle Aktualisieren für das Feld, das Sie aktualisieren möchten, eine Domänenfunktion ein, die dasselbe Aggregat berechnet, das für dieses Feld in der Auswahl- oder Kreuztabellenabfrage berechnet wurde.

    Angenommen, Sie haben in Ihrer Tabelle Artikel ein berechnetes Feld mit dem Namen Verkäufe Bisher und möchten dieses auf der Basis des Produkts aus den Feldern Anzahl und Einzelpreis der Tabelle Bestelldetails aktualisieren. Dazu fügen Sie das Feld zum Abfrageentwurfsbereich der Aktualisierungsabfrage hinzu und geben in die Zelle Aktualisieren die folgende Domänenfunktion ein:

    DomSumme("[Anzahl]*[Einzelpreis]";"Bestelldetails";"[Artikel-Nr]=" & [Artikel-Nr])

  3. Zum Ausführen der Abfrage klicken Sie in der Symbolleiste auf Ausführen [image] .

  4. Um das Ergebnis anzuzeigen, öffnen Sie die Tabelle. Klicken Sie dazu im Datenbankfenster unter Objekte auf Tabellen [image] , und klicken Sie in der Symbolleiste des Datenbankfensters auf Öffnen.


Warum ist die Farbwiedergabe in dem Bild oder Formular so schlecht?

Wurde das Bild, das Sie anzeigen, auf einem Computer erstellt, der über mehr Farben verfügt als der Computer, auf dem Sie das Bild anzeigen, verwendet Microsoft Windows an Stelle der Originalfarben Ersatzfarben. Dieser Prozess wird als Dithering bezeichnet. Dies ist z.B. der Fall, wenn Sie versuchen, ein Bild anzuzeigen, das mit 256 Farben erstellt wurde, Ihr Computer jedoch nur 16 Farben darstellt (Standard-VGA). Kann Ihr Computer mehr Farben darstellen, können Sie mit Hilfe der Eigenschaft Palettenherkunft eines Formulars oder Berichts Microsoft Access anweisen, die zum Erstellen des Bildes verwendete Farbpalette zu verwenden.

Wenn Sie in Formularen, die Popupformulare besitzen, Hintergrundbilder verwenden, ist es sinnvoll, die Eigenschaft Palettenherkunft beider Formulare auf denselben Wert einzustellen. Dies gilt sowohl, wenn beide Formulare über Hintergrundbilder verfügen, als auch dann, wenn nur das Formular oder nur das Popupformular ein Hintergrundbild besitzt. Windows kann jeweils nur mit einer Palette arbeiten. Wenn Sie also die Eigenschaft Palettenherkunft auf denselben Wert festlegen, stellen Sie damit sicher, dass die für das jeweilige Formular benötigten Farben verfügbar sind, wenn der Fokus zum Popupformular oder zurück zum Formular wechselt.

Um weitere Informationen zur Eigenschaft Palettenherkunft anzuzeigen, klicken Sie auf [image] .


Die Abfrage hat nicht die gewünschte Aktualisierung vorgenommen

  • Sie müssen eventuell die Aktualisierung anders vornehmen. Ändern Sie dazu den Ausdruck in der Zeile Aktualisieren. Um z. B. Gehälter um 5 % zu erhöhen, geben Sie in der Zeile Aktualisieren für das Feld Gehalt den Ausdruck [Gehalt]*1,05 ein. Zum Anzeigen weiterer Beispiele für Ausdrücke in Aktualisierungsabfragen klicken Sie auf [image] .

  • Wenn Sie die Daten eines falschen Feldes aktualisiert haben, legen Sie eine Aktualisierung für ein anderes Feld fest. Zum Festlegen einer Aktualisierung für ein Feld geben Sie den gewünschten Ausdruck in die Zeile Aktualisieren ein.


 Die Datensätze werden nicht in der gewünschten Reihenfolge ausgegeben

Die Datensätze werden nicht in der gewünschten Reihenfolge ausgegeben

  • Legen Sie gegebenenfalls eine Sortierreihenfolge fest. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

    Wenn Sie in einer Mehrbenutzerumgebung arbeiten, hat möglicherweise ein anderer Benutzer eine andere Sortierreihenfolge festgelegt. Sortierreihenfolgen werden zusammen mit der Abfrage gespeichert. Sie können die vorhandene Sortierreihenfolge durch die von Ihnen gewünschte Reihenfolge ersetzen.

  • Möglicherweise haben Sie die gewünschte Sortierreihenfolge für ein falsches Feld festgelegt. Löschen Sie die festgelegte Sortierreihenfolge, und legen Sie eine neue Sortierreihenfolge für das gewünschte Feld fest.

  • Möglicherweise haben Sie eine Sortierreihenfolge für das korrekte Feld, jedoch an Stelle von Aufsteigend die Reihenfolge Absteigend oder umgekehrt gewählt. Wählen Sie die korrekte Sortierreihenfolge.

  • Wenn Sie Sortierreihenfolgen für mehrere Felder festgelegt haben, müssen Sie unter Umständen die Felder im Abfrageentwurfsbereich neu anordnen, da Microsoft Access Mehrfachsortierungen von links nach rechts in der Reihenfolge durchführt, in der die Felder im Abfrageentwurfsbereich aufgeführt sind.

  • Möglicherweise ist das Feld, für das Sie die Sortierreihenfolge festgelegt haben, ausgeblendet. Wenn Sie das Feld zum Sortieren von Datensätzen anzeigen möchten, müssen Sie im Abfrageentwurfsbereich das Kontrollkästchen Anzeigen aktivieren.

  • In einem Hyperlink-Feld können Sie keine Sortierreihenfolge festlegen. Sie können einen Ausdruck jedoch mit Hilfe der HyperlinkPart-Funktion sortieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Zum Anzeigen weiterer Punkte, die beim Sortieren von Datensätzen berücksichtigt werden müssen, klicken Sie auf [image] .


Reduzieren von Leerraum in Berichten

Wenn ein Bericht zu viel Leerraum enthält, können Sie diesen verringern, indem Sie den Abstand zwischen Bereichen und Steuerelementen und innerhalb der Steuerelemente verkleinern.

So verringern Sie den Abstand zwischen Bereichen und Steuerelementen

  • Verkleinern Sie die Breite des Berichts.

    Wie wird's gemacht?

  • Verringern Sie die Höhe der Bereiche.

    Wie wird's gemacht?

  • Verkleinern Sie den Abstand zwischen Steuerelementen.

    Wie wird's gemacht?

So verringern Sie den Abstand innerhalb eines Unterformulars, Unterberichts oder Textfeldes

  • Stellen Sie die Eigenschaft Verkleinerbar des Steuerelements auf Ja ein.

    Wie wird's gemacht?


 Beim Versuch, Daten aus einem Unterformular auf dem Hauptformular anzuzeigen, werden die Meldungen #Error? oder #Name? angezeigt.

Beim Versuch, Daten aus einem Unterformular auf dem Hauptformular anzuzeigen, werden die Meldungen #Error? oder #Name? angezeigt.

Um einen Wert aus einem Unterformular auf einem Hauptformular anzuzeigen, erstellen Sie ein berechnetes Steuerelement mit der folgenden Syntax, das auf das Steuerelement des Unterformulars verweist:

=Formulare![Formularname]![Unterformularname]![Steuerelementname]

Angenommen, Sie verfügen über das Formular Bestellungen und das Unterformular Bestellungen. Im Formularfuß des Unterformulars befindet sich ein Textfeld mit der Bezeichnung Zwischensumme, das die Datensätze im Unterformular addiert. Um den Wert dieses Steuerelements auf dem Hauptformular anzuzeigen, verwenden Sie folgenden Ausdruck:

=Formulare![Bestellungen]![Bestellungen Subform]![Zwischensumme]

Zum Anzeigen weiterer Informationen zum Berechnen einer Gesamtsumme für eine Datensatzgruppe auf einem Formular klicken Sie auf [image] .

Wenn Sie diese Syntax bereits verwenden und trotzdem eine Fehlermeldung erhalten, stellen Sie sicher, dass die Namen des Formulars, des Unterformulars und des Steuerelements korrekt sind. Stellen Sie sicher, dass es sich bei den Namen, auf die Sie verweisen, um die Namen handelt, die in der Name-Eigenschaft für jedes Objekt angegeben wurden. Stellen Sie außerdem sicher, dass sich das Ausrufezeichen an den richtigen Stellen befindet.

Sie können auch den Ausdrucks-Generator verwenden, der Sie beim Verweisen auf andere Steuerelemente unterstützt. Zum Anzeigen weiterer Informationen über die Verwendung des Audrucks-Editors klicken Sie auf [image] .


Die Abfrage gibt nicht die gewünschten Datensätze aus

Welches Problem liegt vor?

Die Abfrage gibt zu viele Datensätze aus

Die Abfrage gibt zu wenige Datensätze aus

Die Abfrage gibt nicht die richtigen Datensätze aus


 Die Abfrage ist zu langsam

Die Abfrage ist zu langsam

Sie können die Abfrage mit folgenden Maßnahmen beschleunigen:

  • Starten Sie den Leistungsanalyse-Assistenten. Dieser wertet die Abfrage automatisch aus und macht Vorschläge zur Leistungsverbesserung. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Fügen Sie bestimmten Feldern in den zugrunde liegenden Tabellen Indizes hinzu. Um Informationen zu Indizes und deren Verwendungsmöglichkeiten anzuzeigen, klicken Sie auf [image] .

    Anmerkung Der Leistungsanalyse-Assistent macht Vorschläge zum Erstellen von Indizes und Beziehungen.

  • Ändern Sie den Abfrageentwurf, oder nehmen Sie andere Änderungen in Ihrer Datenbank vor, um die Leistung Ihrer Abfrage zu optimieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Ein Teil der Daten im PivotTable-Formular ist abgeschnitten, und es sind keine Bildlaufleisten vorhanden, um diesen Teil anzuzeigen

  • Um einen Bildlauf durch die Daten im PivotTable-Formular durchzuführen, klicken Sie auf die Schaltfläche PivotTable-Objekt bearbeiten, wodurch Microsoft Excel geöffnet wird. Dort wird das gesamte PivotTable-Formular angezeigt, und Sie können einen Bildlauf durch die Daten durchführen.


In meinem Unterbericht lassen sich die Spaltenüberschriften nicht ausdrucken

Microsoft Access druckt den Seitenkopf und Seitenfuß in einem Unterbericht nicht. Wenn Sie also die Bezeichnungsfelder für die Spaltenüberschriften im Seitenkopf des Unterberichts positionieren, werden diese nicht mitgedruckt, wenn Sie den Bericht drucken.

  • Wenn ein Unterbericht immer auf einer Seite gedruckt werden soll, können Sie die Bezeichnungsfelder für die Spaltenüberschriften im Berichtskopf des Unterberichts positionieren.

  • Wenn ein Unterbericht auf mehreren Seiten gedruckt werden kann, positionieren Sie die Bezeichnungsfelder für die Spaltenüberschriften im Gruppenkopf des Unterberichts, und stellen Sie die Eigenschaft BereichWiederholen für den Gruppenkopf auf Ja ein.


 Die arithmetische Berechnung im Abfrageentwurfsbereich gibt einen Nullwert (leeren Wert) aus

Die arithmetische Berechnung im Abfrageentwurfsbereich gibt einen Nullwert (leeren Wert) aus

Wenn Sie in einem Ausdruck, wie z. B. in [Lagerbestand]+[Bestellte Einheiten], einen arithmetischen Operator (z. B. +, -, *, /) verwenden und eines der Felder im Ausdruck einen Nullwert enthält, ist das Ergebnis des gesamten Ausdrucks ein Nullwert. Um dies zu vermeiden, können Sie Nullwerte in Nullen oder andere Zahlen konvertieren. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Der Filter gibt zu wenige Datensätze zurück.

Der Filter gibt zu wenige Datensätze zurück.

Liefert der Filter nicht genügend Datensätze, führen Sie die Aktion aus, die sich am besten für Ihre Situation eignet.

Formularbasierter Filter

  • Fügen Sie auf der Registerkarte Oder (am unteren Rand des Fensters) alternative Kriterien hinzu, die Datensätze erfüllen können.

  • Wenn Sie auf der Registerkarte Suchen nach oder Oder mehrere Kriterien angegeben haben, löschen Sie den Wert oder den Ausdruck, der die gesuchten Datensätze einschränkt.

Auswahlbasierter Filter

  • Entfernen Sie den Filter, wählen Sie einen zu suchenden Wert, und klicken Sie dann in der Symbolleiste auf Auswahlbasierter Filter [image] . Wiederholen Sie diese Schritte gegebenenfalls solange, bis alle gewünschten Datensätze angezeigt werden.

  • Wenn Sie einen auswahlbasierten Filter auf ein Kombinationsfeld anwenden, das seine Werte aus einer Werteliste erhält, prüfen Sie, ob die gebundene Spalte für das Kombinationsfeld die erste in der Liste angezeigte Spalte ist. Wenn dies nicht der Fall ist und Sie als Kriterium einen Teil eines Wertes aus der angezeigten Spalte des Kombinationsfelds gewählt haben, kann Microsoft Access die Kriterien nicht mit den Daten in der gebundenen Spalte vergleichen. Sie müssen entweder das Kombinationsfeld so ändern, dass die gebundene Spalte die erste angezeigte Spalte der Liste ist, oder das Kombinationsfeld mit Werten aus einer Tabelle oder Abfrage füllen.

Filter nach

  • Entfernen Sie den Filter, falls dieser aktiv ist, und geben Sie dann im Feld Filter nach einen anderen Wert oder Ausdruck an.

  • Wechseln Sie zum Fenster Spezialfilter/-sortierung, um zu prüfen, ob Sie mehrere Kriterien angegeben haben, die die Datensätze erfüllen müssen, oder ob Sie die falschen Kriterien angegeben haben.

Fenster "Spezialfilter/-sortierung"

  • Löschen Sie die Kriterien für ein oder mehrere Felder im Entwurfsbereich.

  • Fügen Sie zusätzliche Oder-Zeilen hinzu, in denen Sie alternative Kriterien festlegen können.

  • Verwenden Sie Ausdrücke mit Oder an Stelle von Und.


 Die Abfrage gibt zu wenige Datensätze aus

Die Abfrage gibt zu wenige Datensätze aus

Wenn die Abfrage auf mehr als einer Tabelle oder Abfrage basiert, überprüfen Sie die Verknüpfungseigenschaften aller Verknüpfungslinien zwischen diesen Tabellen/Abfragen. Verknüpfungseigenschaften legen fest, ob eine Tabelle oder Abfrage alle Datensätze oder nur die Datensätze, die den Datensätzen in einer anderen Tabelle entsprechen, zur Verfügung stellt.

Beispiele zu Verknüpfungstypen, zum Ändern derselben und zu deren Einfluss auf die Abfrageergebnisse
  • Wenn der zum Abrufen verwendete Verknüpfungstyp nur übereinstimmende Datensätze aus den beiden verknüpften Tabellen ausgibt, enthalten die Abfrageergebnisse nicht die Datensätze, in denen das verknüpfte Feld einen Nullwert enthält. Sie können einen Nullwert in "0", eine leere Zeichenfolge oder einen anderen festgelegten Wert umwandeln, damit diese Datensätze auch in den Abfrageergebnissen enthalten sind. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Möglicherweise haben Sie Kriterien festgelegt, die zu einschränkend sind. Wenn Sie z. B. in der Zeile Kriterien Kriterien für zwei unterschiedliche Felder festgelegt haben, wird ein Datensatz nur dann ausgegeben, wenn beide Kriterien erfüllt sind. Löschen Sie gegebenenfalls einige oder alle der Kriterien, wenn die Abfrage mehr Datensätze ausgeben soll.

  • Überprüfen Sie, ob Sie die vorhandenen Kriterien korrekt eingegeben haben. Prüfen Sie die Rechtschreibung, und ob überflüssige Leerzeichen oder zusätzliche Zeichen vorhanden sind. Stellen Sie sicher, dass Sie die Kriterien für das richtige Feld festgelegt haben, und dass dies die Kriterien sind, die die Datensätze erfüllen sollen.

  • Wenn ein Feldname einen Doppelpunkt enthält, müssen Sie den Namen in eckige Klammern setzen, wenn Sie in einem Ausdruck auf das Feld verweisen. Ansonsten interpretiert Microsoft Access den Feldnamen als literalen Textwert und ruft den gewünschten Datensatz nicht ab.

  • Sie können in den Kriterien Platzhalterzeichen verwenden, wenn Sie die gesuchten Feldinhalte nicht genau kennen oder nicht genau angeben möchten. Wenn Sie bereits Platzhalterzeichen eingesetzt haben und dennoch nicht die gewünschten Datensätze erhalten, haben Sie möglicherweise Platzhalterzeichen eines falschen Datentyps verwendet. Zum Anzeigen weiterer Informationen zu Platzhalterzeichen, klicken Sie auf [image] .

  • Fügen Sie zum Auswählen der Datensätze, mit denen Sie arbeiten möchten, Alternativkriterien hinzu. Sie können diese im Abfrageentwurfsbereich in der Zeile Oder oder in der Zeile Kriterien unter Verwendung von Ausdrücken mit dem Oder-Operator festlegen. Um Beispiele zur Verwendung von Alternativkriterien anzuzeigen, klicken Sie auf [image] .

  • Wenn Sie Kriterien zum Auswählen von Datensätzen verwenden, die in einem oder mehreren Feldern bestimmte Werte enthalten, erfüllen alle Datensätze mit Nullwerten dieses Kriterium nicht, und werden daher auch nicht ausgegeben. Geben Sie Ist Null in die Zeile Oder ein, wenn auch Datensätze mit Nullwerten ausgegeben werden sollen. Zum Anzeigen weiterer Informationen zu Nullwerten, klicken Sie auf [image] .


 Die Abfrage gibt zu viele Datensätze aus

Die Abfrage gibt zu viele Datensätze aus

  • Wenn Ihre Abfrage mehr als eine Tabelle oder Abfrage enthält, verbinden Sie diese gegebenenfalls mit einer Verknüpfungslinie. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

Wenn die Tabellen oder Abfragen bereits verknüpft sind, überprüfen Sie die Verknüpfungseigenschaften aller Verknüpfungslinien, um den jeweiligen Verknüpfungstyp zu ermitteln. Verknüpfungseigenschaften legen fest, ob eine Tabelle oder Abfrage alle Datensätze oder nur die Datensätze, die den Datensätzen in einer anderen Tabelle entsprechen, zur Verfügung stellt.

Beispiele zu Verknüpfungstypen, zum Ändern von Verknüpfungstypen und zu deren Einfluss auf die Abfrageergebnisse
  • Fügen Sie Kriterien zum Einschränken der Datensätze hinzu. Nur Datensätze, die die von Ihnen definierten Kriterien erfüllen, werden abgerufen. Um weitere Informationen zum Festlegen von Kriterien anzuzeigen, klicken Sie auf [image] .
    • Wenn Sie bereits Kriterien festgelegt haben, können Sie unter Verwendung des Operators Und weitere Kriterien für dasselbe Feld oder für andere Felder festlegen. Überprüfen Sie auch, ob die vorhandenen Kriterien korrekt eingegeben wurden. Prüfen Sie die Rechtschreibung, und ob überflüssige Leerzeichen oder zusätzliche Zeichen vorhanden sind. Stellen Sie sicher, dass Sie die Kriterien für das richtige Feld festgelegt haben, und dass dies die Kriterien sind, die die Datensätze bestimmen sollen. Entfernen Sie gegebenenfalls Alternativkriterien, die Sie in der Zeile Oder des Abfrageentwurfsbereichs oder in Kriterienausdrücken mit dem Operator Oder festgelegt haben. Um Beispiele zum Festlegen mehrerer Kriterien anzuzeigen, klicken Sie auf [image] .

    • Überprüfen Sie die Daten, nach denen Sie suchen. Enthalten diese zusätzliche Leerzeichen oder andere Sonderzeichen, muss dies beim Festlegen der Kriterien berücksichtigt werden. Sie können in den Kriterien Platzhalterzeichen verwenden, wenn Sie die gesuchten Feldinhalte nicht genau kennen oder nicht genau angeben möchten. Wenn Sie bereits Platzhalterzeichen eingesetzt haben und dennoch nicht die gewünschten Datensätze erhalten, haben Sie möglicherweise Platzhalterzeichen eines falschen Datentyps verwendet. Zum Anzeigen weiterer Informationen zu Platzhalterzeichen, klicken Sie auf [image] .

    • Wenn Sie in einer Auswahl-, einer Anfüge- oder einer Tabellenerstellungsabfrage in der Symbolleiste der Abfrageentwurfsansicht auf Spitzenwerte [image] klicken (oder im Eigenschaftenfenster der Abfrage die Eigenschaft Spitzenwerte einstellen), um eine bestimmte Anzahl der höchsten oder niedrigsten Werte in einem Feld auszugeben, gibt die Abfrage möglicherweise mehr als die gewünschte Anzahl von Datensätzen aus. Dies ist darauf zurückzuführen, dass auch alle Datensätze ausgegeben werden, die mit dem letzten Datensatz übereinstimmen. Daher gibt eine Abfrage, auch wenn Sie angegeben haben, dass nur die Mitarbeiter mit den beiden höchsten Gesamtumsatzsummen angezeigt werden sollen, alle drei der folgenden Datensätze aus, da die Abfrage nicht zwischen den beiden Gesamtumsatzsummen in Höhe von 50.000 unterscheidet.
      Personal-Nr. | Verkäufe
      1 | 60.000
      2 | 50.000
      3 | 50.000

      Wenn Sie nicht möchten, dass doppelte Werte zurückgegeben werden, stellen Sie die Eigenschaft Keine Duplikate im Eigenschaftenfenster der Abfrage auf Ja ein.

    Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


 Die Abfrage gibt nicht die richtigen Datensätze aus

Die Abfrage gibt nicht die richtigen Datensätze aus

  • Überprüfen Sie, ob die vorhandenen Kriterien korrekt eingegeben wurden. Überprüfen Sie die Rechtschreibung und ob unnötige Leerzeichen oder andere zusätzliche Zeichen vorhanden sind. Stellen Sie sicher, dass Sie die Kriterien für das richtige Feld festgelegt haben, und dass dies die Kriterien sind, die die Datensätze erfüllen sollen.

  • Stellen Sie sicher, dass Sie im oberen Teil der Abfrage-Entwurfsansicht die korrekten Tabellen und Abfragen hinzugefügt haben. Um Informationen zum Hinzufügen einer Tabelle oder Abfrage anzuzeigen, klicken Sie auf [image] . Um Informationen zum Löschen einer Tabelle oder Abfrage anzuzeigen, klicken Sie auf [image] .


 Die Ergebnisse einer Funktionsberechnung (Aggregatfunktion) in der Abfrage sind nicht korrekt

Die Ergebnisse einer Funktionsberechnung (Aggregatfunktion) in der Abfrage sind nicht korrekt

  • Datensätze, die in dem Feld, das Sie berechnen, Nullwerte (leere Werte) enthalten, werden bei der Berechnung nicht berücksichtigt. Um weitere Informationen zu Nullwerten und dazu, wie diese in Berechnungen einbezogen werden können, anzuzeigen, klicken Sie auf [image] .

  • Wenn die Abfrage die Berechnung nicht auf den korrekten Gruppen ausführt, stellen Sie sicher, dass die Zeile Funktion für Felder, die Sie für Gruppenberechnungen verwenden möchten, den Eintrag Gruppierung enthält. Um Informationen zum Durchführen von Gruppenberechnungen anzuzeigen, klicken Sie auf [image] .

  • Angenommen, Sie haben in einer Kreuztabellenabfrage zu wenige oder zu viele Gruppierungsfelder. In diesem Fall können Sie die als Zeilenüberschriften definierten Felder, die die Funktionsberechnungen in vertikaler Richtung gruppieren, hinzufügen, entfernen oder ändern. Stellen Sie sicher, dass Sie die korrekten Feldwerte als Spaltenüberschriften verwenden, die die Funktionsberechnungen in horizontaler Richtung gruppieren.

  • Durch die Position, an der Sie im Abfrageentwurfsbereich Kriterien festlegen, bestimmen Sie, ob Datensätze vor dem Gruppieren oder Durchführen von Berechnungen ausgenommen werden, ob Gruppen vor dem Durchführen der Berechnung ausgenommen werden oder ob nach dem Durchführen der Berechnung bestimmte Ergebnisse ausgeschlossen werden. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Stellen Sie sicher, dass Sie die korrekte Aggregatfunktion ausgewählt haben. Wählen Sie andernfalls eine andere Aggregatfunktion aus dem Listenfeld in der Zeile Funktion. Um weitere Informationen zu unterschiedlichen Aggregatfunktionen anzuzeigen, klicken Sie auf [image] .


Die Ergebnisse einer Funktionsberechnung (Aggregatfunktion) werden in einer falschen Spalte ausgegeben

Löschen Sie im Abfrageentwurfsbereich die Aggregatfunktion, die Sie in der Zeile Funktion dieses Feldes (Spalte) festgelegt haben, und wählen Sie eine Aggregatfunktion in einem anderen Feld.


Die Abfrage gibt nicht die gewünschten Spalten aus

  • Entfernen Sie im Abfrageentwurfsbereich die Felder, die die Abfrage nicht abrufen soll. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn Spalten fehlen, fügen Sie die entsprechenden Felder zum Abfrageentwurfsbereich hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Stellen Sie sicher, dass Sie die korrekten Tabellen und Abfragen zum Abrufen verwendet haben. Um Informationen zum Hinzufügen einer Tabelle oder Abfrage anzuzeigen, klicken Sie auf [image] . Um Informationen zum Entfernen einer Tabelle oder Abfrage anzuzeigen, klicken Sie auf [image] .


Die Abfrage gibt zu wenige Spalten aus

  • Fügen Sie weitere Felder zum Abfrageentwurfsbereich hinzu, oder fügen Sie dem Entwurfsbereich das Sternchen (*) hinzu, wenn die Abfrage automatisch alle Felder aus der zugrunde liegenden Tabelle oder Abfrage beinhalten soll. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Fügen Sie weitere Tabellen oder Abfragen und dann die gewünschten Felder hinzu. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Zeigen Sie ausgeblendete Felder an. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn das Kontrollkästchen Alle Felder ausgeben nicht aktiviert ist, werden nur die im Entwurfsbereich enthaltenen Felder in den Ergebnissen abgerufen. (Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Tabellen/Abfragen, wenn Sie prüfen möchten, ob diese Option aktiviert ist.) Ist dies der Fall, werden alle Felder aus der zugrundeliegenden Tabelle oder Abfrage in den Abfrageergebnissen angezeigt, auch wenn diese nicht zum Entwurfsbereich hinzugefügt wurden. Wenn Sie dann ein Feld hinzufügen, um z.B. Kriterien für dieses Feld festzulegen, müssen Sie für dieses Feld das Kontrollkästchen Anzeigen deaktivieren, da die entsprechende Spalte in den Abfrageergebnissen sonst zweimal angezeigt wird. Statt dessen können Sie jedoch auch das Kontrollkästchen Alle Felder ausgeben deaktivieren. Das Ändern dieser Option hat nur für die Eigenschafteneinstellung neuer Abfragen Gültigkeit, nicht für vorhandene Abfragen.


Die Abfrage gibt zu viele Spalten aus

  • Entfernen Sie im Abfrageentwurfsbereich die Felder, die nicht in den Abfrageergebnissen enthalten sein sollen, und entfernen Sie gegebenenfalls das Sternchen (*), wenn Sie es dem Entwurfsbereich hinzugefügt haben. Das Sternchen fügt automatisch alle Felder der zugrundeliegenden Tabelle zur Abfrage hinzu. Um weitere Informationen zum Entfernen von Feldern anzuzeigen, klicken Sie auf [image] .

  • Blenden Sie die Felder aus, die Sie in den Abfrageergebnissen nicht anzeigen möchten. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Überprüfen Sie, ob das Kontrollkästchen Alle Felder ausgeben aktiviert ist. (Dazu klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Tabellen/Abfragen). Wenn diese Option aktiviert ist, werden alle Felder aus der zugrunde liegenden Tabelle oder Abfrage in den Abfrageergebnissen angezeigt, auch wenn diese nicht zum Abfrageentwurfsbereich hinzugefügt wurden. Wenn Sie dann ein Feld separat zum Abfrageentwurfsbereich hinzufügen, um z.B. nur Kriterien für dieses Feld festzulegen, müssen Sie das Kontrollkästchen Anzeigen für dieses Feld deaktivieren, da die entsprechende Spalte in den Abfrageergebnissen sonst zweimal angezeigt wird. Sie können jedoch auch das Kontrollkästchen Alle Felder ausgeben deaktivieren. Das Ändern dieser Option hat nur für die Eigenschafteneinstellung neuer Abfragen Gültigkeit, nicht für vorhandene Abfragen.


Die Berechnungen in der Abfrage sind nicht korrekt

Welches Problem liegt vor?

Die Ergebnisse einer Berechnung in der Zeile "Funktion" der Abfrage sind nicht korrekt

Die Ergebnisse einer Berechnung in der Zeile "Funktion" im Abfrageentwurfsbereich werden in der falschen Spalte ausgegeben

Eine arithmetische Berechnung in einem berechneten Feld im Abfrageentwurfsbereich gibt einen Nullwert (leeren Wert) aus


Anpassen einer Kreuztabellenabfrage

Was möchten Sie tun?

Die Reihenfolge oder die Anzahl der Spaltenüberschriften ändern

Die Datensätze sortieren

Kriterien zur Begrenzung bestimmter Datensätze festlegen

Datensätze mit Nullwerten (leeren Werten) ausschließen, um "<>" als Spaltenüberschrift zu vermeiden


 Microsoft Access kann die Daten nicht einfügen. Warum nicht?

Microsoft Access kann die Daten nicht einfügen. Warum nicht?

In den meisten Fällen erstellt Microsoft Access die Tabelle Einfügefehler, wenn Daten ganz oder teilweise nicht in eine Microsoft Access-Datenbank eingefügt werden konnten. In diesem Fall zeigt Microsoft Access eine Meldung an, die mitteilt, dass die Daten zur Tabelle Einfügefehler hinzugefügt wurden. Weitere Informationen zum Anzeigen der Tabelle Einfügefehler erhalten Sie, indem Sie auf [image] klicken.

Nachfolgend sind verschiedene Gründe dafür aufgeführt, dass Microsoft Access Ihre Daten, oder einen Teil davon, nicht einfügt:

  • Sie haben versucht, ein oder mehrere Felder einzufügen, ohne vorher ein Ziel ausgewählt zu haben. Sie müssen das Feld bzw. die Felder, in das/die Sie Daten einfügen möchten, zuerst auswählen. Zum Anzeigen von Informationen zum Auswählen von Feldern klicken Sie auf [image] .

  • Sie haben versucht, mehr Felder in das Datenblatt einzufügen, als dieses enthält, bzw. als Sie Zielfelder ausgewählt haben. Microsoft Access fügt die zusätzlichen Felder nicht ein.

  • Sie haben versucht, einen Wert einzufügen, der nicht zum Datentyp des Feldes kompatibel ist. Sie haben z.B. versucht, eine Zeichenfolge, bestehend aus Buchstaben und Zahlen, in ein Feld des Datentyps Zahl in eine Microsoft Access-Datenbank oder in ein Feld des Datentyps smallint in ein Microsoft Access-Projekt einzufügen.

  • Sie haben versucht, Text einzufügen, der für das ausgewählte Feld zu lang ist. Die maximale Größe des Feldwertes wird durch die Einstellung der Feldgröße-Eigenschaft einer Access-Datenbank oder die Length-Spalteneigenschaft in einem Access-Projekt festgelegt. Überprüfen Sie diese Einstellung des Feldes in der Entwurfsansicht der Tabelle in einer Access-Datenbank oder in der Ansicht Spalteneigenschaften in einem Datenbankdiagramm in einem Access-Projekt.

  • Sie haben versucht, einen doppelten Wert in das Feld des Primärschlüssels der Tabelle einzufügen, in ein Feld, dessen Indiziert-Eigenschaft auf Ja (Ohne Duplikate) in einer Access-Datenbank eingestellt ist oder ein Feld mit einer eindeutigen Beschränkung oder einem eindeutigen Index in einem Access-Projekt. Überprüfen Sie diese Einstellung des Feldes in der Entwurfsansicht der Tabelle in einer Access-Datenbank oder der Spalteneigenschaftenansicht in einem Datenbankdiagramm in einem Access-Projekt.

  • Sie haben versucht, Daten in ein ausgeblendetes Feld einzufügen, was nicht zulässig ist. Um ausgeblendete Spalten wieder anzuzeigen, klicken Sie im Menü Format auf Spalten einblenden.

  • Sie haben versucht, Daten in einer Access-Datenbank aus einem deaktivierten Feld, einem gesperrten Feld, einem berechneten Feld oder einem AutoWert-Feld zu löschen bzw. sie dort einzufügen. Zum Anzeigen weiterer Informationen zu den genannten Feldarten klicken Sie auf [image] .

  • Sie verfügen nicht über die Berechtigungen, Daten im Datenbankobjekt hinzuzufügen oder zu bearbeiten.

  • Sie haben versucht, einen Wert einzufügen, der im ausgewählten Feld nicht zulässig ist, und zwar auf Grund der Einstellung der Eigenschaft Gültigkeitsregel, Eingabeformat, EingabeErforderlich (nur Access-Datenbank) oder LeereZeichenfolge (nur Access-Datenbank).

  • Das für die Eigenschaften VorAktualisierung oder BeimEinfügen angegebene Gültigkeitsmakro hat die Aktualisierung abgebrochen. Die Daten, die Sie versucht haben einzufügen, entsprachen nicht den Gültigkeitserfordernissen.


Problembehandlung beim Drucken und Ansehen von Berichten in der Seitenansicht

Wobei benötigen Sie Hilfe?

Der gedruckte Bericht enthält Leerseiten.

Der Bericht enthält zu viel Leerraum.

Die Layout-Vorschau zeigt falsche Daten an.

Microsoft Access fordert im Bericht zur Eingabe unerwarteter Parameter auf.

In meinem Unterbericht lassen sich die Spaltenüberschriften nicht ausdrucken.

Die Meldung #Error? oder #Name? wird in einem Steuerelement angezeigt.

In meinem Unterbericht wird statt mehrerer Spalten nur eine Spalte ausgedruckt.


 Es wird eine Meldung bezüglich unverträglicher Datentypen angezeigt

Es wird eine Meldung bezüglich unverträglicher Datentypen angezeigt

  • Stellen Sie sicher, dass die Kriterien, die Sie festgelegt haben, für den Datentyp gelten, den die in der zugrunde liegenden Tabelle oder Abfrage enthaltenen Daten haben. Wenn das Feld Mindestbestand z. B. ein Feld vom Datentyp Zahl ist, erhalten Sie einen Fehler, wenn Sie das Kriterium "50" eingeben, da Microsoft Access Werte in Anführungszeichen als Wert vom Datentyp Text und nicht Zahl interpretiert.

    Auch in folgenden Fällen tritt ein Datentypen-Konflikt auf:

    • Sie geben Kriterien für ein Nachschlagefeld an, wobei die Kriterien die Werte verwenden, die an Stelle ihrer zugehörigen Fremdschlüsselwerte in der Nachschlageliste angezeigt werden. Da die Fremdschlüsselwerte die Werte sind, die gerade in der zugrunde liegenden Tabelle gespeichert werden, sollten Sie sie beim Festlegen von Kriterien für ein Feld verwenden. Um weitere Informationen zu Nachschlagefeldern anzuzeigen, klicken Sie auf [image] .

    • Sie haben in einem Kriterium, das Sie für ein Feld vom Datentyp Währung angegeben haben, das Dollarzeichen ($) verwendet. Entfernen Sie das Dollarzeichen, und zeigen Sie dann das Ergebnis an.
  • Stellen Sie sicher, dass der Datentyp bei jedem Paar verknüpfter Felder in einer Abfrage für beide Felder identisch ist. Ändern Sie andernfalls den Datentyp entsprechend eines der Verknüpfungsfelder. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .


Es wird eine Meldung bezüglich der Verletzung einer Gültigkeitsregel angezeigt

Es kommt zu einem Gültigkeitsregelverstoß, wenn Sie versuchen, Datensätze zu aktualisieren oder anzufügen, die die für ein Feld oder einen Datensatz festgelegten Gültigkeitsregeln verletzen.

Um Informationen zum Überprüfen der Gültigkeit von Daten anzuzeigen, klicken Sie auf [image] .


 Ich möchte die Möglichkeit haben, alle Datensätze mit einer Parameterabfrage zurückzugeben.

Ich möchte die Möglichkeit haben, alle Datensätze mit einer Parameterabfrage zurückzugeben.

Geben Sie im Entwurfsbereich unter dem Feld, das die Eingabeaufforderung in der Zelle Kriterien enthält, [Eingabeaufforderung] Is Null in die Zelle Oder ein, wobei Eingabeaufforderung der Eingabeaufforderung aus der Zelle Kriterien für dieses Feld entspricht. Beispiel für das Feld CategoryID:

Zelle | Eingabe
Kriterien | Like [Eingabe Kategorie-ID:]
Oder | [Eingabe Kategorie-ID:] Is Null

Wenn Sie die Abfrage jetzt ausführen und keinen Wert in das Dialogfeld Parameterwerte eingeben eingeben, gibt die Abfrage alle Datensätze zurück.


 Ein Tabellenentwurf in einer Access-Datenbank kann nicht geändert werden.

Ein Tabellenentwurf in einer Access-Datenbank kann nicht geändert werden.

  • Falls ein anderer Benutzer die Tabelle geöffnet hat oder auf der Tabelle basierende Daten in einer Abfrage, einem Formular oder einem Bericht anzeigen lässt, können Sie keine Änderungen an dem Entwurf dieser Tabelle vornehmen. Microsoft Access teilt Ihnen mit, dass die Tabelle schreibgeschützt ist.

  • Möglicherweise verfügen Sie nicht über die Berechtigung zum Ändern des Entwurfs. Wurde die gemeinsam genutzte Microsoft Access-Datenbank, die Sie verwenden, geschützt, wird der Zugriff auf Objekte (abgesehen von Modulen) von dem Ersteller bzw. Verwalter der Datenbank geregelt. Über welche Berechtigungen Sie verfügen, hängt von der Gruppe ab, der Sie angehören.


 Ein Access-Datenbankobjekt kann nicht geöffnet werden.

Ein Access-Datenbankobjekt kann nicht geöffnet werden.

Möglicherweise verfügen Sie nicht über die Berechtigung zum Öffnen des Objekts. Wenn die gemeinsam genutzte Microsoft Access-Datenbank, die Sie verwenden, geschützt ist, wird der Zugriff auf Objekte (abgesehen von Modulen) durch die Mitarbeiter bzw. Mitarbeiterinnen geregelt, die die Datenbank erstellen oder verwalten. Sie besitzen unter Umständen die Berechtigung, ein Objekt anzuzeigen, aber nicht die, ein Objekt in der Entwurfsansicht zu öffnen oder zu aktualisieren. Ihre Berechtigungen sind möglicherweise über die Gruppe festgelegt, der Sie angehören.


 Tabellendaten in einer Access-Datenbank werden nicht anzeigt.

Tabellendaten in einer Access-Datenbank werden nicht anzeigt.

  • Sie können die Daten einer Tabelle nicht anzeigen, wenn ein anderer Benutzer die Tabelle in der Entwurfsansicht geöffnet hat. Warten Sie, bis die Tabelle wieder verfügbar ist. Wenn Sie eine Tabelle in der Entwurfsansicht öffnen, sollten Sie sie nur solange wie unbedingt nötig geöffnet haben, wenn andere mit der Tabelle bzw. mit Abfragen, Formularen oder Berichten, die auf der Tabelle basieren, arbeiten möchten.

  • Möglicherweise verfügen Sie nicht über die Berechtigung zum Anzeigen der Daten. Wenn die gemeinsam genutzte Microsoft Access-Datenbank, die Sie verwenden, geschützt ist, wird der Zugriff auf Objekte (abgesehen von Modulen) durch die Mitarbeiter bzw. Mitarbeiterinnen geregelt, die die Datenbank erstellen oder verwalten. Ihre Berechtigungen sind möglicherweise über die Gruppe festgelegt, der Sie angehören.


Warum vergrößert sich die Datenbank um wesentlich mehr als die Größe des hinzugefügten Objekts?

Die Datenmenge, die zum Darstellen eines Objekts verwendet wird, ist oftmals größer als das Objekt selbst. Um dieses Missverhältnis zu umgehen, können Sie in dem Formular oder Bericht an Stelle des Objekts selbst ein Symbol anzuzeigen, welches das Objekt darstellt. Wenn Sie ein Symbol anzeigen, sendet der OLE-Server (die Anwendung, die zum Erstellen des Objekts verwendet wird) nur die Informationen, die zum Anzeigen des Symbols benötigt werden. Wenn Sie auf das Symbol doppelklicken, wird der OLE-Server mit den Daten gestartet, die von dem Symbol dargestellt werden.

Um Informationen zum Anzeigen eines Objekts als Symbol anzuzeigen, klicken Sie auf [image] .


 Die eingefügten Daten befinden sich im falschen Feld. Warum?

Die eingefügten Daten befinden sich im falschen Feld. Warum?

  • Beim Einfügen von Datensätzen in ein Datenblatt positioniert Microsoft Access die Felder, unabhängig von den Feldnamen, in der Reihenfolge, in der sie in den Spalten des Datenblatts angezeigt werden. Wenn Sie möchten, dass die Daten entsprechend der Feldnamen eingefügt werden, fügen Sie sie in ein Formular in der Formularansicht ein.

  • Beim Einfügen von Datensätzen in ein Formular positioniert Microsoft Access diese, unabhängig von ihrer Reihenfolge im Formular, in Feldern mit dem gleichen Namen wie die Herkunftsfelder. Wenn jedoch keine übereinstimmenden Feldnamen vorhanden sind, werden die Daten entsprechend der Reihenfolge der Steuerelemente im Formular eingefügt, welche unter Umständen nicht die von Ihnen gewünschte Reihenfolge ist.


 Warum sortiert der Filter die Datensätze in der Tabelle, in der Abfrage oder im Formular nicht in der korrekten Reihenfolge?

Warum sortiert der Filter die Datensätze in der Tabelle, in der Abfrage oder im Formular nicht in der korrekten Reihenfolge?

Sie müssen unter Umständen die folgenden Maßnahmen ergreifen:

  • Fügen Sie eine Sortierreihenfolge hinzu, oder löschen Sie eine.

  • Sortieren Sie nach einem anderen Feld.

  • Ändern Sie die Sortierreihenfolge von Aufsteigend in Absteigend oder umgekehrt.

  • Ordnen Sie die Spalten im Entwurfsbereich des Fensters Spezialfilter/-sortierung neu an, und geben Sie dann eine neue Sortierreihenfolge auf der Grundlage eines oder mehrerer Felder an. Microsoft Access beginnt beim Sortieren der Datensätze mit der Spalte, die im Entwurfsbereich ganz links angeordnet ist.

Anmerkungen

  • Enthalten Felder des Text-Datentyps Zahlen, werden diese nicht in auf- oder absteigender Reihenfolge sortiert. Vielmehr wird beim Sortieren dieser Zahlen die folgende Regel angewandt: 1, 11, 12, 2, 20, 21 usw. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  • Wenn ein Feld, das Sie in aufsteigender Reihenfolge sortieren, Nullwerte enthält, erscheinen Datensätze mit diesen Werten in der Sortierreihenfolge an erster Stelle, noch vor Datensätzen, in deren Sortierfeld Textwerte oder numerische Werte stehen.

Zum Anzeigen weiterer Informationen zum Sortieren klicken Sie auf [image] .


Warum gibt der Filter in der Tabelle, in der Abfrage oder im Formular nicht die korrekten Datensätze aus?

Wie kann man das Problem am besten beschreiben?

Der Filter gibt zu viele Datensätze zurück.

Der Filter gibt zu wenige Datensätze zurück.

Der Filter gibt die falschen Datensätze zurück.


 Warum ist das Eigenschaftenfenster leer?

Warum ist das Eigenschaftenfenster leer?

Wenn das Eigenschaftenfenster angezeigt wird und Sie auf ein bereits markiertes Steuerelement klicken, wird der Inhalt des Eigenschaftenfensters gelöscht. Wenn Sie in das Steuerelement keinen Wert eingeben müssen, drücken Sie ESC, um das Eigenschaftenfenster erneut anzuzeigen. Andernfalls geben Sie einen Wert ein und drücken die EINGABETASTE.


Datensätze in indizierten und nicht indizierten Feldern werden im Fenster "Formularbasierter Filter" unterschiedlich gelesen

Wie viele Datensätze Microsoft Access liest, hängt davon ab, ob ein Feld indiziert ist oder nicht. Bei einem indizierten Feld liest Microsoft Access nur die eindeutigen Werte, also nicht alle Werte eines Feldes. Bei einem nicht indizierten Feld liest Microsoft Access dagegen alle Werte des Feldes. Übersteigt die Anzahl der gelesenen Datensätze die für die Anzeige maximal zulässige Anzahl (bestimmt durch die Einstellung für Keine Listen anzeigen, wenn mehr als diese Anzahl Zeilen gelesen wird), zeigt Microsoft Access die Werte dieses Feldes nicht in der Liste an. Demzufolge müssen Sie die Einstellung für diese Option ändern. Da Microsoft Access bei nicht indizierten Feldern nicht nur die eindeutigen, sondern alle Werte liest, wählen Sie als Einstellung für diese Option eine Zahl größer (oder gleich) der maximalen Anzahl von Datensätzen in jedem nicht indizierten Feld.

Anmerkung Wenn Microsoft Access die Liste in einem Feld anzeigen kann, werden auch für ein nicht indiziertes Feld nur die eindeutigen Werte angezeigt.


 Warum werden nicht alle Eigenschaften im Eigenschaftenfenster angezeigt?

Warum werden nicht alle Eigenschaften im Eigenschaftenfenster angezeigt?

Wenn Sie mehrere Steuerelemente markieren, doch die erwarteten Eigenschaften im Eigenschaftenfenster nicht angezeigt werden, haben Sie möglicherweise nicht das gewünschte Steuerelement markiert. Vielleicht haben Sie zusammen mit einer Gruppe von Textfeldern auch eine Linie markiert. Die Eigenschaften werden im Eigenschaftenfenster nur angezeigt, wenn sie für alle markierten Steuerelemente zutreffen. Um ein Steuerelement aus einer markierten Gruppe zu entfernen, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie auf das Steuerelement.


 Warum ist das Einstellungsfeld einer bestimmten Eigenschaft leer?

Warum ist das Einstellungsfeld einer bestimmten Eigenschaft leer?

Wenn die Einstellung einer bestimmten Eigenschaft für alle markierten Steuerelemente identisch ist, wird diese Einstellung im Eigenschaftenfenster angezeigt. Andernfalls ist das Einstellungsfeld dieser Eigenschaft leer. Sind mehrere Steuerelemente markiert, und Sie ändern im Eigenschaftenfenster die Einstellung einer Eigenschaft, wirkt sich diese Änderung auf alle markierten Steuerelemente aus.


 Warum stimmen die Eigenschafteneinstellungen des Steuerelements nicht mit den Einstellungen im Tabellenentwurf überein?

Warum stimmen die Eigenschafteneinstellungen des Steuerelements nicht mit den Einstellungen im Tabellenentwurf überein?

Die Eigenschafteneinstellungen eines gebundenen Steuerelements stimmen möglicherweise nicht mit den entsprechenden Einstellungen für das Feld der zugrunde liegenden Tabelle überein, an die das Steuerelement gebunden ist. Unterscheiden sich die Einstellungen, haben die Formular- oder Berichtseinstellungen in der Regel Vorrang vor den Tabelleneinstellungen. Sie treffen jedoch nur für das aktuelle Formular oder den aktuellen Bericht zu. Es empfiehlt sich, die Eigenschaften Format, Dezimalstellenanzeige, Eingabeformat, Gültigkeitsregel, Gültigkeitsmeldung und Standardwert nicht im Steuerelement, sondern in der zugrunde liegenden Tabelle oder Abfrage einzustellen. Auf diese Weise wird gewährleistet, dass beim Hinzufügen dieses Feldes zu einem Formular oder Bericht die Einstellungen immer konsistent sind. Zum Anzeigen weiterer Informationen zur Übernahme von Eigenschafteneinstellungen bei Steuerelementen klicken Sie auf [image] .


 Warum sind einige der Felder im Fenster "Formularbasierter Filter" nicht verfügbar?

Warum sind einige der Felder im Fenster "Formularbasierter Filter" nicht verfügbar?

Im Fenster Formularbasierter Filter sind die folgenden Feldtypen deaktiviert, da sie nicht zum Filtern von Datensätzen verwendet werden können:

  • Berechnete Steuerelemente in einem Formular.

  • Felder, die mit ungebundenen Steuerelementen oder ungebundenen Objektfeldern erstellt wurden.


Der im Kombinationsfeld in einem Formular oder Bericht angezeigte Text ist aus der falschen Spalte. Wie können Daten aus anderen Spalten angezeigt werden?

In einem mehrspaltigen Kombinationsfeld in einem Formular oder Bericht zeigt das Textfeld innerhalb des Kombinationsfeldes Daten aus der ersten sichtbaren Spalte der Liste an. Mit Hilfe der Eigenschaft Spaltenbreiten bestimmen Sie, welche Spalten sichtbar sind. Basiert ein Kombinationsfeld z.B. auf einer Abfrage, die ein Feld Lieferanten-Nr und ein Feld Firma (in dieser Reihenfolge) enthält, zeigt Microsoft Access dann das Feld Lieferanten-Nr im Textfeldteil des Kombinationsfeldes an, sofern Sie diesen nicht mit Hilfe der Eigenschaft Spaltenbreiten ausblenden. Um weitere Informationen zum Ausblenden einer Spalte in einem Listen- oder Kombinationsfeld anzuzeigen, klicken Sie auf [image] .


Methoden zum Anpassen eines Berichts 3

Hinzufügen von Feldern aus der Datenquelle eines Berichts


Methoden zum Anpassen eines Formulars 5

Hinzufügen von Feldern aus der Datenquelle eines Formulars


Methoden zum Anpassen eines Formulars 2

Ändern des Erscheinungsbildes eines Formulars


Methoden zum Anpassen eines Berichts 2

Ändern des Erscheinungsbildes eines Berichts


Methoden zum Anpassen eines Formulars 6

Ändern eines Steuerelements in einen anderen Steuerelementtyp

Weitere Informationen

Hinzufügen, Entfernen oder Formatieren eines Formularkopfes, Seitenkopfes oder eines anderen Bereichs

Verschieben, Anpassen der Größe, Ausrichten und Formatieren von Feldern oder Steuerelementen in einem Formular

Erstellen eines bestimmten Steuerelementtyps in einem Formular

Ändern eines Steuerelements in einem anderen Steuerelementtyp


Methoden zum Anpassen eines Berichts 6

Ändern des Textes oder der Daten, die in einem Steuerelement angezeigt werden

Weitere Informationen

Hinzufügen, Entfernen oder Formatieren eines Berichtkopfs, Seitenkopfs oder eines anderen Bereichs

Verschieben, Anpassen der Größe, Ausrichten und Formatieren von Feldern oder Steuerelementen in einem Bericht

Erstellen eines bestimmten Steuerelementtyps in einem Bericht

Sortieren von Datensätzen in einem Bericht

Gruppieren von Datensätzen in einem Bericht


Methoden zum Anpassen eines Formulars 4

Ändern des Textes oder der Daten, die in einem Steuerelement angezeigt werden


Methoden zum Anpassen eines Berichts 5

Ändern der Sortier- oder Gruppierreihenfolge für die Datensätze in einem Bericht


FastTips

Microsoft FastTips ist ein automatisierter, gebührenfreier Service, der schnell Antworten auf häufige technische Fragen bietet, und zwar 24 Stunden am Tag und an 7 Tagen in der Woche. In den USA rufen Sie einfach die Nummer (800) 936-4100 von einem Telefon mit Tonwahl aus an. Mit Hilfe der Telefontasten können Sie auf Eingabeaufforderungen reagieren und dann aufgezeichnete Antworten auf Ihre technischen Fragen abhören, einen Katalog mit verfügbaren Informationen abrufen und Faxbestellungen aufgeben. So können Sie zum Beispiel Application Notes oder häufig gewünschte Beiträge der Microsoft Knowledge Base anfordern. Dieser Dienst ist nur in den USA und Kanada verfügbar. Wenn Sie weitere Informationen benötigen, besuchen Sie die Microsoft-Website Ihres Landes (z. B. http://www.microsoft.com/germany).


 Ändern einer gespeicherten Suche

Ändern einer gespeicherten Suche

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie auf Extras und dann auf Suchen.

  3. Klicken Sie auf Gespeicherte Suchläufe.

  4. Klicken Sie auf den Namen der gespeicherten Suche, die Sie ändern möchten, und klicken Sie dann auf Öffnen.

  5. Klicken Sie im Feld Dateien suchen, die diesen Kriterien entsprechen auf die Kriterien, die Sie ändern möchten, und klicken Sie dann auf Löschen.

    Die Einstellungen für die gelöschten Suchkriterien werden im Feld Weitere Kriterien bestimmen angezeigt. Wenn Sie Ihre Meinung ändern, können Sie die gelöschten Suchkriterien durch Klicken auf Zur Liste hinzufügen wieder herstellen.

    Zum Löschen aller Suchkriterien und Starten mit den Standardsuchkriterien klicken Sie auf Neue Suche.

  6. Legen Sie unter Weitere Kriterien bestimmen neue Suchkriterien fest.

  7. Klicken Sie auf Zur Liste hinzufügen.

  8. Klicken Sie auf Suche speichern.

  9. Um die vorhandene gespeicherte Suche zu ersetzen, geben Sie den Namen dieser Suche ein, klicken auf OK und dann auf Ja.

    Um den geänderten Suchkriterien einen neuen Namen zu geben, geben Sie einen neuen Namen ein und klicken dann auf OK.

Anmerkungen

  • Sie können eine Datei nicht suchen, indem Sie in einer Datei aus einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt nach dem Text suchen.

  • Sie können eine gespeicherte Suche auch in den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras ändern.


Kopieren eines Bildes aus einem Grafikprogramm auf eine Symbolleistenschaltfläche oder auf einen Menübefehl

Um ein deutliches Bild zu erhalten, kopieren Sie eine Grafik, die dieselbe Größe hat wie ein eingebautes Schaltflächensymbol oder Menübefehlbild. Die Standardgröße für ein Schaltflächenbild beträgt 16 x 16 Pixel. Ein größeres Bild könnte verzerrt werden, weil es der Größe der Schaltfläche angepasst werden muss.

  1. Kopieren Sie im Grafikprogramm die Grafik in die Zwischenablage, die auf dem Schaltflächensymbol oder auf dem Menübefehl angezeigt werden soll.

    Wenn Sie das Format für die zu kopierende Grafik wählen können, wählen Sie Bitmap-Format (.BMP).

  2. Wechseln Sie zu Microsoft Access.

  3. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  4. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü mit dem Schaltflächensymbol oder dem Menübefehl an, das/den Sie ändern möchten.

  5. Öffnen Sie das Dialogfeld Anpassen, und führen Sie dann einen der folgenden Schritte aus:
    • Klicken Sie zum Einfügen des kopierten Bildes auf einer Symbolleistenschaltfläche (in der Symbolleiste) auf die Schaltfläche, die das zu ändernde Bild enthält, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren.

    • Klicken Sie zum Einfügen des kopierten Bildes auf einem Menübefehl auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl enthält, auf dem Sie das Bild einfügen möchten. Klicken Sie mit der rechten Maustaste auf den Menübefehl, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren.

Anmerkung Wenn Sie das Bild für einen Befehl in einem eingebauten Menü (z.B. im Menü Bearbeiten) ändern, wird das neue Bild in allen Ansichten angezeigt, in denen dieses Menü mit diesem Befehl eingeblendet wird.


Kopieren eines Bildes von einer Symbolleistenschaltfläche oder einem Menübefehl auf eine andere Symbolleistenschaltfläche oder einen anderen Menübefehl

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü mit dem Schaltflächensymbol oder Menübefehl an, das/den Sie kopieren möchten. Wenn Sie das Bild direkt in eine andere Symbolleiste oder Menüleiste kopieren, müssen Sie diese auch anzeigen.

  3. Öffnen Sie das Dialogfeld Anpassen, und führen Sie einen der folgenden Schritte aus:
    • Klicken Sie zum Kopieren eines Bildes auf einer Symbolleistenschaltfläche mit der rechten Maustaste (in der Symbolleiste) auf die Schaltfläche, die das zu kopierende Bild enthält, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren

    • Klicken Sie zum Kopieren eines Menübefehlbildes in der Menü- oder Symbolleiste auf den Menübefehl oder auf das Kontextmenü, das den zu kopierenden Befehl enthält. Klicken Sie mit der rechten Maustaste auf den Menübefehl, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren.
  4. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie zum Einfügen des kopierten Bildes auf einer Symbolleistenschaltfläche mit der rechten Maustaste (in der Symbolleiste) auf die Schaltfläche, auf der Sie das Bild einfügen möchten, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren.

    • Klicken Sie zum Einfügen des kopierten Bildes auf einem Menübefehl auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, in das Sie das Bild einfügen möchten. Klicken Sie mit der rechten Maustaste auf den Menübefehl, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol kopieren.

Anmerkung Wenn Sie das Bild für einen Befehl in einem eingebauten Menü (z.B. im Menü Bearbeiten) ändern, wird das neue Bild in allen Ansichten angezeigt, in denen das Menü mit diesem Befehl eingeblendet wird.


Bearbeiten eines Bildes auf einer Symbolleistenschaltfläche oder auf einem Menübefehl

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü mit dem Schaltflächensymbol oder Menübefehl an, das/den Sie ändern möchten.

  3. Öffnen Sie das Dialogfeld Anpassen, und führen Sie einen der folgenden Schritte aus:
    • Klicken Sie zum Bearbeiten eines Symbols auf einer Symbolleistenschaltfläche mit der rechten Maustaste auf die Symbolleiste, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol bearbeiten.

    • Klicken Sie zum Bearbeiten eines Bildes auf einem Menübefehl auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl mit dem zu bearbeitenden Bild enthält.

      Klicken Sie mit der rechten Maustaste auf den Menübefehl, und klicken Sie dann im Kontextmenü auf Schaltflächensymbol bearbeiten.

  4. Führen Sie die gewünschten Änderungen durch.

Anmerkung Wenn Sie das Bild für einen Befehl in einem eingebauten Menü (z.B. im Menü Bearbeiten) ändern, wird das neue Bild in allen Ansichten angezeigt, in denen dieses Menü mit diesem Befehl eingeblendet wird.


Microsoft Download Service (MSDL)

Das Microsoft Download Library (MSDL) umfasst Beispielprogramme, Gerätetreiber, Softwareupdates und Programmierhilfen. Der direkte Modemzugriff auf MSDL ist 24 Stunden am Tag und 365 Tage pro Jahr möglich. Wählen Sie in den USA die Nummer (425) 936-6735 oder in Kanada (905) 507-3022. Dieser Dienst ist nur in den USA und Kanada verfügbar. Wenden Sie sich außerhalb der USA und Kanada an Ihre zuständige Microsoft-Niederlassung, wenn Sie Informationen benötigen.

Anmerkung Der Service unterstützt Übertragungen mit 1200-, 2400-, 9600- oder 14.400-Baud, mit den Einstellungen keine Parität (no parity), 8 Datenbits und 1 Stoppbit.


Wiederherstellen der ursprünglichen Schaltflächen und Menüs in einer eingebauten Symbol- oder Menüleiste oder in einem Kontextmenü

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Wählen Sie auf der Registerkarte Symbolleisten den Namen der Symbol- oder Menüleiste aus, in der Sie die ursprünglichen Schaltflächen und Menüs wiederherstellen möchten. Zum Wiederherstellen aller Kontextmenüs wählen Sie die Symbolleiste Kontextmenüs.

    Anmerkung Das Aktivieren oder Deaktivieren eines Kontrollkästchens im Feld Symbolleisten blendet die entsprechende Symbol- oder Menüleiste ein bzw. aus.

  3. Klicken Sie auf Zurücksetzen.

Anmerkungen

  • Benutzerdefinierte Symbol- oder Menüleisten können nicht zurückgesetzt werden.

  • Wenn Sie in Microsoft Access arbeiten, werden die Menüs und Symbolleisten angepasst, so dass die Befehle angezeigt werden, die Sie am Häufigsten verwenden. Wenn Sie möchten, können Sie die Symbolleisten- und Menüanzeige zurücksetzen, so dass diese wieder wie beim ersten Starten von Access angezeigt werden.


 Suchkriterien zum Suchen nach Dateien

Suchkriterien zum Suchen nach Dateien

In das Feld Dateiname im Dialogfeld Öffnen (Menü Datei) können Sie die folgenden Suchkriterien zum Suchen der Datei eingeben.

Mögliche Eingabe | Beispieleingabe
Dateinamenteil | region, wenn Sie nach allen Dateinamen suchen möchten, die "region" enthalten.
Dateierweiterungen | *.txt, wenn Sie nach Textdateien suchen möchten.
Platzhalterzeichen | *land, wenn Sie nur Dateinamen finden möchten, die mit "land" enden oder Schmi?t ein, wenn Sie Dateinamen finden möchten, die entweder "Schmidt" oder "Schmitt" enthalten. Verwenden Sie ein Sternchen (*) für eine beliebige Anzahl von Zeichen oder ein Fragezeichen (?) für genau ein Zeichen.
Vollständiger Pfadname | C:\Hausverwaltung\Steuerzahlungen 1995. Wenn Sie einen Laufwerkbuchstaben, eine Freigabe oder einen Ordner angeben, aktualisiert das Programm automatisch die Position im Feld Suchen in, zeigt nur den Namen im Feld Dateiname an und öffnet dann die Datei.
Mehrere Pfadnamen | c:\Hausverwaltung;c:\Eigene Dokumente. Trennen Sie jeden Pfad durch ein Semikolon. Alle Ordner und Dateien von jedem Pfad, den Sie in das Feld Dateiname eingeben, werden angezeigt. Im Feld Suchen in wird nach alphabetischer Reihenfolge der erste Pfad angezeigt.

Anmerkungen

  • Wenn Sie einen vor kurzem verwendeten Eintrag erneut verwenden möchten, klicken Sie im Feld Dateiname auf den Dateinamen.

  • Sie können diese Suchkriterien auch in den Dialogfelden Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras verwenden.

  • Im Dialogfeld Webseite suchen können Sie einen Internet-Standort eingeben, um eine Webseite zu öffnen. Klicken Sie im Datenbankfenster unter Objekte auf Seiten [image] , und doppelklicken Sie dann auf Bearbeitet eine vorhandene Webseite. Geben Sie in das Feld Dateiname den HTTP URL ein, wie z. B. http://example.microsoft.com, um die Webseite zu öffnen.


Verwenden von Tastenkombinationen für Fenster und Dialogfelder

Tastenkombination | Verwenden eines Fensters
ALT+TAB | Zum Wechseln zum nächsten Programm
ALT+UMSCHALT+TAB | Zum Wechseln zum vorherigen Programm
STRG+ESC | Zum Anzeigen des Windows Start-Menüs
STRG+W | Zum Schließen des aktiven Datenbankfensters
STRG+F6 | Zum Wechseln zum nächsten Datenbankfenster
STRG+UMSCHALT+F6 | Zum Wechseln zum vorherigen Datenbankfenster

Tastenkombination | Verwenden eines Dialogfelds
STRG+TAB oder STRG+BILD-AB | Zum Wechseln zur nächsten Registerkarte in einem Dialogfeld
STRG+UMSCHALT+TAB oder STRG+BILD AUF | Zum Wechseln zur vorherigen Registerkarte in einem Dialogfeld
TAB | Zum Wechseln zur nächsten Option oder Optionsgruppe
UMSCHALT+TAB | Zum Wechseln zur vorherigen Option oder Optionsgruppe
Pfeiltasten | Zum Wechseln zwischen Optionen im ausgewählten Dropdownlistenfeld oder zwischen Optionen in einer Optionsgruppe
LEERTASTE | Zum Ausführen der Aktion, die der ausgewählten Schaltfläche zugewiesen ist; Kontrollkästchen markieren bzw. Markierung eines Kontrollkästchens entfernen
Taste für den Buchstaben, mit dem der Name der gewünschten Option beginnt (während ein Dropdownlistenfeld ausgewählt ist) | Zum Wechseln zu einer Option in einem Dropdownlistenfeld anhand des ersten Buchstabens des Optionsnamens
ALT+Buchstabentaste | Zum Auswählen einer Option, zum Aktivieren oder Deaktivieren eines Kontrollkästchens anhand des unterstrichenen Buchstabens im Optionsnamen
ALT+NACH-UNTEN | Zum Öffnen des ausgewählten Dropdownlistenfeldes
ESC | Zum Schließen des ausgewählten Dropdownlistenfeldes
EINGABETASTE | Zum Ausführen der Aktion, die der Standardschaltfläche des Dialogfelds zugewiesen ist
ESC | Zum Abbrechen des Befehls und zum Schließen des Dialogfelds

Tastenkombination | Bearbeitung in einem Textfeld
POS1 | Zum Gehen zum Anfang des Eintrags
ENDE | Zum Gehen zum Ende des Eintrags
PFEIL-NACH-LINKS bzw. PFEIL-NACH-RECHTS | Zum Verschieben eines Buchstabens nach links oder rechts
STRG+PFEIL-NACH-LINKS bzw. STRG+PFEIL-NACH-RECHTS | Zum Verschieben eines Wortes nach links oder rechts
UMSCHALT+POS1 | Zum Markieren von Text von der Einfügemarke bis zum Anfang des Eintrags
UMSCHALT+ENDE | Zum Markieren von Text von der Einfügemarke bis zum Ende des Eintrags
UMSCHALT+PFEIL-NACH-LINKS | Zum Markieren eines Zeichens links von der Einfügemarke
UMSCHALT+PFEIL-NACH-RECHTS | Zum Markieren eines Buchstabens rechts von der Einfügemarke
STRG+UMSCHALT+PFEIL-NACH-LINKS | Zum Markieren eines Wortes links von der Einfügemarke
STRG+UMSCHALT+PFEIL-NACH-RECHTS | Zum Markieren eines Wortes rechts von der Einfügemarke


Sie wissen, dass eine bestimmte Datei sich auf einem Laufwerk oder in einem Ordner befindet, können sie jedoch nicht sehen.

Die aktuellen Suchkriterien für das Dialogfeld Öffnen enthalten möglicherweise den korrekten Standort der Datei. Die Datei, nach der Sie suchen, wird jedoch unter Umständen durch die anderen festgelegten Kriterien ausgeschlossen. Versuchen Sie Folgendes:

  • Klicken Sie im Dialogfeld auf Extras. Klicken Sie anschließend auf Suchen und dann auf Löschen, um alle Kriterien mit Ausnahme des Standorts und des Standarddateityps zu löschen. Geben Sie gegebenenfalls vor dem Klicken von Suche starten neue Kriterien ein.

  • Klicken Sie im Dialogfeld im Feld Dateityp auf Alle Dateien.

  • Um alle Unterordner zu durchsuchen, klicken Sie im Dialogfeld auf Extras und dann auf Suchen. Aktivieren Sie dann das Kontrollkästchen Unterordner durchsuchen.

  • Die Datei ist möglicherweise verborgen. Zum Anzeigen aller Dateien, einschließlich Dateien mit der Erweiterung *.DLL und *.SYS, klicken Sie auf die Windows-Schaltfläche Start, zeigen auf Programme und klicken dann auf Windows Explorer. Klicken Sie im Menü Ansicht auf Optionen und dann in der Registerkarte Ansicht auf Alle Dateien anzeigen.

Anmerkung Sie können dies auch versuchen, wenn Sie in den Dialogfeldern Importieren und Verknüpfen aus dem Menü Datei oder den Dialogfeldern Datenbank konvertieren in, Datenbank komprimieren, MDE speichern unter und Datenbank ver-/entschlüsseln aus dem Menü Extras nach einer Datei suchen.


Wenn ich eine meiner gespeicherten Suchen verwende, finde ich viele der zuvor gefundenen Dateien nicht mehr.

Überprüfen Sie, ob die Suchkriterien ein Netzlaufwerk enthalten.

Wenn die Kriterien ein Netzlaufwerk enthalten, stellen Sie sicher, dass dieses noch zur Verfügung steht.

Wenn die Kriterien kein Netzlaufwerk enthalten, wurden die fehlenden Dateien seit dem letzten Durchführen dieser Suche möglicherweise gelöscht, umbenannt oder verschoben.


Datenbanken: Definition und Funktionsweise

1 2 3 4 5 6 7 8


Datenbanken: Definition und Funktionsweise


Werte für das Element DefaultSource

Wert | Bedeutung
1 | Oberer Schacht oder nur ein Schacht
2 | Unterer Schacht
3 | Mittlerer Schacht
4 | Manueller Einzug
5 | Schacht für Briefumschläge
6 | Manueller Einzug für Briefumschläge
7 | Automatischer Einzug
8 | Traktoreinzug
9 | Schacht für kleine Formate
10 | Schacht für große Formate
11 | Schacht mit großer Kapazität
14 | Kassettenschacht
256 | Ab hier gerätespezifische Schächte/Einzüge


Beispiel für eine Kreuztabellenabfrage


Beispiel für gruppierte Datensätze in einem Bericht

1 2 3


Beispiel für gruppierte Datensätze in einem Bericht


Konstanten für das Element Fields

Ein Druckertreiber unterstützt nur solche Elemente, die für die technischen Fähigkeiten des jeweiligen Druckers geeignet sind.

Konstante | Wert
DM_ORIENTATION | &H0000001
DM_PAPERSIZE | &H0000002
DM_PAPERLENGTH | &H0000004
DM_PAPERWIDTH | &H0000008
DM_SCALE | &H0000010
DM_COPIES | &H0000100
DM_DEFAULTSOURCE | &H0000200
DM_PRINTQUALITY | &H0000400
DM_COLOR | &H0000800
DM_DUPLEX | &H0001000
DM_YRESOLUTION | &H0002000
DM_TTOPTION | &H0004000
DM_COLLATE | &H0008000
DM_FORMNAME | &H0010000


Definition und Funktionsweise von Formularen

1 2 3


Definition und Funktionsweise von Formularen


 Auf der Datenzugriffsseite wird ein rotes X, ein leeres Bild oder gar kein Bild angezeigt.

Auf der Datenzugriffsseite wird ein rotes X, ein leeres Bild oder gar kein Bild angezeigt.

Wird an Stelle Ihrer Grafik ein rotes X, ein leeres Bild oder gar kein Bild angezeigt, kann dies folgende Gründe haben:

Ihre Browsereinstellungen sind nicht korrekt Obwohl alle Browser dieselbe Sprache (HTML) unterstützen, gibt es einige Unterschiede. Einige unterstützen verschiedene Versionen von HTML und verschiedene HTML-Erweiterungen. In Browsern können benutzerdefinierte Optionen festgelegt werden, z.B. Standardtext, Hintergrundfarben und ob Grafiken angezeigt werden sollen. Testen Sie Ihre Datenzugriffsseite in verschiedenen Browsern - von denen einige über das Web heruntergeladen werden können - und mit verschiedenen Monitoreinstellungen, um festzustellen, ob alle Elemente der Seite angezeigt werden.

Sie haben nicht das richtige Bildformat verwendet Wenn Sie eine Grafik mit einer Datenzugriffsseite verknüpfen und das Grafikformat von Ihrem Browser nicht unterstützt wird, wird die Grafik nicht angezeigt. Stellen Sie sicher, dass das verknüpfte Bild in einem Grafikformat vorliegt, das mit Ihrem Browser kompatibel ist. Die Grafikformate JPG und GIF sind mit den meisten Browsern kompatibel.


Verknüpfungstypen und ihre Auswirkungen auf Abfrageergebnisse

1 2 3 4 5


Verknüpfungstypen und ihre Auswirkungen auf Abfrageergebnisse


Möglichkeiten der Anpassung eines Berichts 4

Verschieben, Anpassen und Ausrichten von Steuerelementen


Möglichkeiten der Anpassung eines Formulars 3

Verschieben, Anpassen und Ausrichten von Steuerelementen


Von einem Unterbericht wird nur eine Spalte statt mehrerer Spalten gedruckt

Möglicherweise wird nur eine Spalte eines Unterberichts gedruckt, wenn Sie im Dialogfeld Seitenformat des Unterberichts auf der Registerkarte Spalten unter Spaltenlayout die Einstellung Nach unten, dann quer gewählt und im Hauptbericht die Eigenschaft Vergrößerbar für das Unterbericht-Steuerelement auf Ja eingestellt haben.

Sie können den Berichtsentwurf mit einem der folgenden Verfahren ändern:

  • Wählen Sie im Unterbericht unter Spaltenlayout die Einstellung Quer, dann nach unten, und behalten Sie im Hauptbericht die Einstellung Ja für die Eigenschaft Vergrößerbar des Unterbericht-Steuerelements bei. Dann wird das Steuerelement mehrere Spalten anzeigen und bei Bedarf erweitert werden.

  • Behalten Sie im Unterbericht unter Spaltenlayout die Einstellung Nach unten, dann quer bei. Passen Sie im Hauptbericht die Größe des Unterbericht-Steuerelements für die maximale Anzahl von Datensätzen an, und stellen Sie seine Eigenschaft Vergrößerbar auf Nein ein. Weil das Unterbericht-Steuerelement seine Größe nicht ändert, werden bei einer Überschreitung der maximalen Anzahl der Datensätze diejenigen abgeschnitten, die nicht in das Steuerelement passen.

Verwenden Sie nach Möglichkeit keinen Unterbericht. Fügen Sie stattdessen die Steuerelemente, die die Daten des Hauptberichts drucken, in einen Gruppenkopf oder den Seitenkopf und die Steuerelemente, die die Daten des Unterberichts drucken, in den Detailbereich ein.


Verschieben oder Kopieren eines Menüs in eine Menü- oder Symbolleiste

  1. Zeigen Sie die Menü- oder Symbolleiste mit dem Menü an, das Sie kopieren oder verschieben möchten, sowie die Leiste, in die Sie verschieben oder kopieren möchten.

  2. Führen Sie einen der folgenden Schritte aus:
    • Wenn das Dialogfeld Anpassen geöffnet ist, ziehen Sie zum Verschieben eines Menüs dieses an die neue Position in derselben oder einer anderen Menü- oder Symbolleiste. Wenn das Dialogfeld geschlossen ist, halten Sie beim Ziehen des Menüs an die neue Position die ALT-TASTE gedrückt.

    • Wenn das Dialogfeld Anpassen geöffnet ist, halten Sie zum Kopieren eines Menüs die STRG-TASTE gedrückt und ziehen dann das Menü an die neue Position in derselben oder in einer anderen Menü- oder Symbolleiste. Wenn das Dialogfeld geschlossen ist, halten Sie die Tasten STRG+ALT gedrückt und ziehen dann das Menü an die neue Position.


Wiederherstellen der ursprünglichen Einstellungen für ein eingebautes Menü

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menü- oder Symbolleiste an, die das Menü enthält, für das Sie die ursprünglichen Einstellungen wiederherstellen möchten.

  3. Lassen Sie das Dialogfeld Anpassen geöffnet. Klicken Sie in der Menü- oder Symbolleiste mit der rechten Maustaste auf das Menü, für das Sie die Einstellungen wiederherstellen möchten, und klicken Sie dann im Kontextmenü auf Zurücksetzen.

Anmerkungen

  • Wenn Sie ein Menü (z. B. das Menü Bearbeiten) wiederherstellen, wird dieses in allen Ansichten, in denen es angezeigt wird, wiederhergestellt.

  • Sie können auch die Standardbefehle der angepassten Menüs so wiederherstellen, wie Sie beim ersten Starten von Microsoft Access angezeigt wurden.


 Hinzufügen einer FTP-Site zur Liste der FTP-Speicherorte

Hinzufügen einer FTP-Site zur Liste der FTP-Speicherorte

Sie können in den Dialogfeldern Öffnen und Speichern eine FTP-Site der Liste FTP-Speicherorte hinzufügen. Dazu muss ein Unternehmen über ein Intranet- oder Internetzugriff verfügen. Diesen Zugriff erhalten Sie beispielsweise über das Unternehmensnetzwerk oder ein Modem und ein Internetkonto bei einem Dienstanbieter.

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf FTP-Adressen hinzufügen/ändern.

  3. Geben Sie im Feld Name der FTP-Site den Namen der FTP-Site ein, z.B. ftp.microsoft.com.
  4. Um sich anonym bei einer Site anzumelden, klicken Sie auf Anonym (bei manchen Sites ist dies nicht möglich).

    Um sich bei einer FTP-Site anzumelden, für die Sie Benutzerrechte besitzen, klicken Sie auf Benutzer, und geben Sie anschließend bei der Eingabeaufforderung Ihren Anmeldenamen und Ihr Kennwort ein.

  5. Klicken Sie auf Hinzufügen.


 Ändern des Anmeldenamens oder -kennworts für eine FTP-Site

Ändern des Anmeldenamens oder -kennworts für eine FTP-Site

Die Anmeldung bei einer FTP-Site kann bearbeitet werden. Dazu muss ein Unternehmen über ein Intranet- oder Internetzugriff verfügen. Diesen Zugriff erhalten Sie beispielsweise über das Unternehmensnetzwerk oder ein Modem und ein Internetkonto bei einem Dienstanbieter.

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf FTP-Speicherort.
  3. Klicken Sie mit der rechten Maustaste auf die FTP-Site, die Sie ändern möchten, und klicken Sie anschließend im Kontextmenü auf Ändern.

  4. Ändern Sie die gewünschten Optionen. Um weitere Informationen zu einem bestimmten Element des Dialogfelds FTP-Adressen hinzufügen/ändern zu erhalten, klicken Sie auf die Fragezeichenschaltfläche [image] und anschließend auf das Element.


Minimieren aller Programmfenster auf dem Windows-Desktop

  • Klicken Sie mit der rechten Maustaste auf den Hintergrund der Windows-Taskleiste, und klicken Sie dann im Kontextmenü auf Alle Fenster minimieren.


 Löschen einer FTP-Site aus der Liste der Internet-Sites

Löschen einer FTP-Site aus der Liste der Internet-Sites

  1. Klicken Sie im Menü Datei auf Öffnen [image] .

  2. Klicken Sie im Feld Suchen in auf FTP-Speicherort.

  3. Klicken Sie mit der rechten Maustaste auf die FTP-Site, die Sie entfernen möchten, und klicken Sie anschließend im Kontextmenü auf Entfernen.


Anzeigen von Text, von einem Symbol oder von Text und Symbol zusammen auf einer Symbolleistenschaltfläche

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbolleiste mit der zu ändernden Schaltfläche an.
  3. Lassen Sie das Dialogfeld Anpassen geöffnet. Klicken Sie mit der rechten Maustaste auf die Schaltfläche, die Sie ändern möchten, und klicken Sie dann im Kontextmenü auf die gewünschte Option.

Anmerkungen

  • Sie können nicht den Text und das Symbolformat für eine Schaltfläche ändern, die, wenn auf sie geklickt wird, eine Liste oder ein Menü anzeigt.

  • Wenn die Schaltfläche das Format Standard hat, zeigt das Menü beim Verschieben oder Kopieren der Schaltfläche in ein Menü automatisch den Befehlsnamen und das Symbol an (dies ist die Standardeinstellung für Menüs).


 Datei im Internet kann nicht geöffnet werden

Datei im Internet kann nicht geöffnet werden

Sie benötigen einen Zugriff auf das Internet, um Dateien in einer FTP-Site oder im World Wide Web zu öffnen. Diesen Zugriff erhalten Sie beispielsweise über das Unternehmensnetzwerk oder ein Modem und ein Internetkonto bei einem Dienstanbieter.

  • Wenn Sie über einen Zugriff auf das Internet verfügen und die Datei dennoch nicht öffnen können, ist die Site möglicherweise überlastet. Versuchen Sie, die Datei später zu öffnen.


Verwenden von Tastenkombinationen für Menüs

Tastenkombination | Verwenden eines Menüs
UMSCHALT+F10 | Zum Anzeigen des Kontextmenüs
F10 | Zum Aktivieren der Menüleiste
ALT+LEERTASTE | Zum Anzeigen des Menüs des Programmsymbols (in der Titelleiste des Programms)
NACH-UNTEN- bzw. NACH-OBEN-TASTE | Zum Auswählen des nächsten oder vorherigen Befehls, wenn das Menü oder Untermenü sichtbar ist
NACH-LINKS- bzw. NACH-RECHTS-TASTE | Zum Auswählen des Menüs links oder rechts neben dem aktiven Menü; oder, bei geöffnetem Untermenü, zum Wechseln zwischen dem Hauptmenü und dem Untermenü
POS1 bzw. ENDE | Zum Auswählen des ersten oder letzten Befehls im Menü oder Untermenü
ALT | Zum gleichzeitigen Schließen des geöffneten Menüs und des Untermenüs
ESC | Zum Schließen des angezeigten Menüs; oder, bei geöffnetem Untermenü, nur zum Schließen des Untermenüs


 Infos zur Microsoft Office Shortcut-Leiste

Infos zur Microsoft Office Shortcut-Leiste

Die Microsoft Office Shortcut-Leiste ermöglicht es, mit einem einzigen Mausklick auf die am häufigsten verwendeten Ressourcen zuzugreifen. Sie können schnell und einfach einen neuen Budget-Vorschlag starten, eine Dia-Präsentation suchen und öffnen, eine E-Mail-Nachricht senden, einen Termin planen oder in Microsoft Outlook eine Aufgabe, eine Notiz, einen Kontakt oder einen Journaleintrag erstellen.

Arbeiten mit der Office Shortcut-Leiste

Sie können die Office Shortcut-Leiste an jede beliebige Stelle auf dem Bildschirm ziehen, oder - wenn die Leiste verankert ist - können Sie die Leiste ausblenden, bis Sie sie benötigen, indem Sie im Menü Office Shortcut-Leiste [image] auf Automatisch im Hintergrund klicken. Wenn Sie die Office Shortcut-Leiste erneut anzeigen möchten, zeigen Sie einfach auf den Bereich, in dem sie verankert ist.

Wenn Sie über die Office Shortcut-Leiste schnell einen beliebigen Dateityp erstellen möchten (z.B. eine Office Sammelmappe oder eine Microsoft Excel-Arbeitsmappe) klicken Sie auf Neues Office-Dokument [image] . Klicken Sie auf die Registerkarte, die den Dateityp enthält, den Sie erstellen möchten, und doppelklicken Sie dann auf die gewünschte Datei oder Vorlage.

Zum schnellen Öffnen von Dateien über die Office Shortcut-Leiste klicken Sie auf Office-Dokument öffnen [image] , suchen die gewünschte Datei in der Ordnerliste und doppelklicken dann auf die Datei.

Anpassen der Office Shortcut-Leiste

Wenn Sie Office zum ersten Mal verwenden, enthält die Office Shortcut-Leiste nur die Symbolleiste Office. Weitere Schaltflächen und Symbolleisten sind verfügbar, aber ausgeblendet. Wenn Sie eine ausgeblendete Schaltfläche oder Symbolleiste anzeigen möchten, klicken Sie mit der rechten Maustaste auf den Hintergrund einer beliebigen Symbolleiste in der Office Shortcut-Leiste, und klicken Sie anschließend im Kontextmenü auf Benutzerdefiniert. Wenn Sie z. B. die Symbolleiste Desktop auf der Office Shortcut-Leiste anzeigen, können Sie Dateien und Programme auf dem Windows-Desktop leicht öffnen, auch wenn Sie den Desktop nicht sehen. Wenn Sie eine andere Symbolleiste auf der Office Shortcut-Leiste anzeigen möchten, klicken Sie auf das Symbol, das die Symbolleiste darstellt. Wenn Sie den Namen einer Schaltfläche oder Symbolleiste anzeigen möchten, positionieren Sie den Mauszeiger über dem Schaltflächen- oder Symbolleistensymbol, bis der Name angezeigt wird.

Sie können auch Ihre eigenen Symbolleisten und Schaltflächen hinzufügen. Wenn Sie häufig verwendete Dateien und Programme als Symbolleistenschaltflächen hinzufügen möchten, ziehen Sie diese aus dem Windows Explorer oder vom "Arbeitsplatz" auf die Office Shortcut-Leiste.

Installieren der Office Shortcut-Leiste

Wenn die Office Shortcut-Leiste nicht verfügbar ist, starten Sie Office-Setup erneut, und installieren Sie die Leiste. Wenn Sie die Office Shortcut-Leiste installieren, können Sie sie so konfigurieren, dass sie beim Starten von Windows automatisch ausgeführt wird. Informationen zum Installieren eines Programms oder einer Komponente von Office anzeigen.


 Speichern einer Datenzugriffsseite in einer FTP-Site

Speichern einer Datenzugriffsseite in einer FTP-Site

Dazu muss ein Unternehmen über ein Intranet verfügen, oder Sie müssen einen Zugriff auf eine Internet-Site haben, die das Speichern von Dateien unterstützt. Darüber hinaus müssen Sie über die Zugriffsrechte zum Speichern verfügen und die FTP-Site der Liste der FTP-Speicherorte hinzufügen. Um weitere Informationen zum Hinzufügen einer FTP-Site zur Liste der Internetsites zu erhalten, klicken Sie auf [image] .

  1. Wenn die Datenzugriffsseite, die Sie in einer FTP-Site speichern wollen, noch nicht geöffnet ist, öffnen Sie diese in der Seitenansicht oder der Entwurfsansicht. Die zu speichernde Seite kann eine neue Datenzugriffsseite, die noch nicht gespeichert wurde, oder eine vorhandene Datenzugriffsseite sein.

  2. Klicken Sie im Menü Datei auf Speichern unter.

  3. Geben Sie in das Dialogfeld Speichern unter einen Namen für die Verknüpfung mit der Datenzugriffsseite ein, und klicken Sie auf OK.

  4. Klicken Sie im Dialogfeld Als Datenzugriffsseite speichern im Feld Speichern in auf FTP-Speicherorte.

  5. Doppelklicken Sie in der Liste der FTP-Sites auf die gewünschte Site, und doppelklicken Sie anschließend auf den Speicherort, an dem Sie die Datenzugriffsseite speichern wollen.

    Anmerkung Sie benötigen Schreibberechtigungen für den FTP-Speicherort, um die Datenzugriffsseite dort zu speichern.

  6. Geben Sie in das Feld Dateiname einen Namen für die .HTM-Datei ein.

  7. Klicken Sie auf Speichern.


 Bedingungen und Werte im Dialogfeld "Suchen"

Bedingungen und Werte im Dialogfeld "Suchen"

Welche Bedingungen zur Verfügung stehen, ist abhängig von der ausgewählten Eigenschaft. Einige Bedingungen erfordern einen Wert. Wenn Sie eine Eigenschaft und eine Bedingung wählen und dann das Dialogfeld Wert zur Verfügung steht, erfordert die Bedingung einen Wert.

Sie können im Feld Wert Operatoren wie z.B. Und und Oder verwenden, um mehrere Werte voneinander zu trennen. Um z.B. nach Dateien zu suchen, deren Autor entweder Gabi oder Peter lautet, klicken Sie im Feld Eigenschaft auf Autor. Klicken Sie im Feld Bedingung auf Enthält Wörter, und geben Sie dann im Feld Wert den Ausdruck Gabi oder Peter ein.

Textwerte

Sie können im Feld Wert mit der Bedingung Enthält Wörter Platzhalterzeichen verwenden. Geben Sie ein Fragezeichen (?) ein, um nach einem einzelnen Zeichen zu suchen, oder geben Sie ein Sternchen (*) ein, wenn Sie nach einer Zeichenfolge suchen möchten. s?t findet z.B. "sat" und "set" und s*t findet "satt" und "sitzt".

Zahlenwerte

Wenn Sie die Bedingung Eine Zahl zwischen verwenden möchten, geben Sie im Feld Wert zwei Zahlen ein, zwischen denen der Wert liegen soll, und trennen diese durch und. Zum Beispiel geben Sie 1 und 5 ein.

Datumswerte

Wenn Sie die Bedingung Zeit zwischen verwenden möchten, geben Sie im Feld Wert zwei Datumsangaben ein, zwischen denen der Wert liegen soll, und trennen diese durch und. Zum Beispiel geben Sie 01. März 1996 und 30. März 1996 ein.

Anmerkung Sie können nicht nach einer Datei suchen, indem Sie in einer Datei aus einer Microsoft Access-Datenbank oder einem Microsoft Access-Projekt nach dem Text suchen.


Verwenden von Tastenkombinationen für Symbolleisten

Tastenkombination | Verwenden einer Symbolleiste
F10 | Zum Aktivieren der Menüleiste
STRG+TAB bzw. STRG+UMSCHALT+TAB | Zum Auswählen der nächsten oder vorherigen Symbolleiste
TAB bzw. UMSCHALT+TAB | Zum Auswählen der nächsten oder vorherigen Schaltfläche bzw. des nächsten oder vorherigen Menüs auf der Symbolleiste, wenn eine Symbolleiste aktiv ist
EINGABETASTE | Zum Öffnen des Menüs, während ein Menü auf der Symbolleiste ausgewählt ist
EINGABETASTE | Zum Ausführen der Aktion, die der Schaltfläche zugewiesen ist, wenn eine Schaltfläche ausgewählt ist
EINGABETASTE | Zum Eingeben von Text in ein Textfeld, wenn das Textfeld ausgewählt ist
NACH-UNTEN- oder NACH-OBEN-TASTE | Zum Wechseln zwischen den Optionen der Liste oder des Menüs, wenn ein Dropdownlistenfeld oder ein Dropdownmenü auf einer Schaltfläche ausgewählt ist; drücken Sie anschließend die EINGABETASTE, um die gewünschte Option auszuwählen


 Der Office-Assistent zeigt nicht das gewünschte Hilfethema an.

Der Office-Assistent zeigt nicht das gewünschte Hilfethema an.

Sprachspezifische Informationen

Wenn Sie das gewünschte Thema nicht finden, klicken Sie auf Office im Web. Damit wird der Webbrowser gestartet und eine Verbindung zu einer Website hergestellt, in der Sie nach weiterer Hilfe suchen können. Sie können auch beschreiben, wie Sie vorgegangen sind, um Hilfe zu erhalten. Ihre Fragen und Anmerkungen tragen dazu bei, zukünftige Versionen des Hilfesystems zu verbessern.


Der Office-Assistent lenkt ab.

Wählen Sie einen anderen Office-Assistenten Einige der Office-Assistenten sind aktiver als andere. Wenn Sie einen anderen Assistenten wählen möchten, klicken Sie mit der rechten Maustaste auf den Assistenten. Anschließend klicken Sie im Kontextmenü auf Assistent auswählen und dann auf der Registerkarte Katalog auf Zurück oder Weiter, um die verfügbaren Assistenten anzuzeigen. Der Office Logo-Assistent ist der ruhigste von allen Assistenten.

Einschränken der Bewegungen Klicken Sie auf den Assistenten und anschließend auf Optionen. Deaktivieren Sie dann auf der Registerkarte Optionen das Kontrollkästchen Verschieben, wenn im Weg. Damit werden auch die Bewegungen von unverankerten Symbolleisten eingeschränkt.

Verschieben des Assistenten Ziehen Sie den Assistenten an eine andere Position auf dem Bildschirm.

Ausblenden des Assistenten Klicken Sie im Menü ? auf Office-Assistenten ausblenden.

Deaktivieren des Assistenten Klicken Sie auf den Assistenten, und klicken Sie dann auf Optionen. Deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Office-Assistenten verwenden.

Deaktivieren der Soundeffekte des Assistenten Klicken Sie auf den Assistenten, und klicken Sie dann auf Optionen. Deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Sounds aktivieren.


 Beim Klicken auf einen Hyperlink wird eine Fehlermeldung angezeigt.

Beim Klicken auf einen Hyperlink wird eine Fehlermeldung angezeigt.

  • Das Ziel des Hyperlinks wurde möglicherweise gelöscht oder umbenannt.

  • Das Ziel des Hyperlinks wurde möglicherweise an einen anderen Speicherort verschoben. Wenn der Pfad des Ziels als fester Dateispeicherort erstellt wurde, der das Ziel mit seiner vollständigen Adresse angibt, z. B. C:\Eigene Dateien\Umsätze.doc, und das Ziel an einen anderen Speicherort verschoben wurde, wird die Verknüpfung aufgehoben. Um den Hyperlink zu ändern, klicken Sie mit der rechten Maustaste auf den Hyperlink, zeigen im Kontextmenü auf Hyperlink und klicken dann auf Hyperlink bearbeiten.

  • Wenn sich das Ziel des Hyperlinks im Internet befindet, benötigen Sie einen Internetzugang. Wenn Sie Zugriff auf das Internet haben, ist die Site möglicherweise ausgelastet. Versuchen Sie, die Datei später zu öffnen.

  • Wenn sich das Ziel des Hyperlinks im Intranet des Unternehmens befindet, prüfen Sie die Netzwerkverbindungen, und stellen Sie sicher, dass der Netzwerk-Server in Betrieb ist. Wenn Sie keinen Zugriff haben sollten, wenden Sie sich an den Administrator.


Wie kann ich nach dem Entfernen des Befehls "Symbolleisten" oder des Menüs "Ansicht" das Dialogfeld "Anpassen" anzeigen?

  • Zum Anpassen einer Symbolleiste, einer Menüleiste oder eines Kontextmenüs nach dem Entfernen des Befehls Symbolleisten aus dem Menü Ansicht oder dem Entfernen des Menüs Ansicht aus der Menüleiste klicken Sie mit der rechten Maustaste auf eine beliebige Symbol- oder Menüleiste und dann im Kontextmenü auf Anpassen.

  • Zum Wiederherstellen der ursprünglichen Gruppe von Befehlen, einschließlich des Befehls Symbolleisten, im Menü Ansicht klicken Sie mit der rechten Maustaste auf eine beliebige Symbol- oder Menüleiste und dann im Kontextmenü auf Anpassen. Klicken Sie mit der rechten Maustaste in der Registerkarte Ansicht auf die Menüleiste, und klicken Sie dann im Kontextmenü auf Zurücksetzen.

  • Zum Wiederherstellen aller Menüs und Befehle in der eingebauten Menüleiste, einschließlich des Menüs Ansicht, klicken Sie mit der rechten Maustaste auf eine beliebige Symbolleiste oder auf die Menüleiste, und klicken Sie anschließend im Kontextmenü auf Anpassen. Klicken Sie jetzt in der Registerkarte Symbolleisten auf den Namen Menüleiste und dann auf Zurücksetzen.


Werte für das Element PaperSize

Wert | Papiergröße
1 | US-Letter (8,5 x 11 Zoll)
2 | US-Letter klein (8,5 x 11 Zoll)
3 | US-Tabloid (11 x 17 Zoll)
4 | US-Ledger (17 x 11 Zoll)
5 | US-Legal (8,5 x 14 Zoll)
6 | US-Statement (5,5 x 8,5 Zoll)
7 | US-Exec. (7,25 x 10,5 Zoll)
8 | A3 (297 x 420 mm)
9 | A4 (210 x 297 mm)
10 | A4 klein (210 x 297 mm)
11 | A5 (148 x 210 mm)
12 | B4 (250 x 354 mm)
13 | B5 (182 x 257 mm)
14 | Folio (8,5 x 13 Zoll)
15 | Quarto (215 x 275 mm)
16 | 11 x 17 Zoll
18 | Note (8,5 x 11 Zoll)
19 | Briefumschlag #9 (3,875 x 8,875 Zoll)
20 | Briefumschlag #10 (4,125 x 9,5 Zoll)
21 | Briefumschlag #11 (4,5 x 10,375 Zoll)
22 | Briefumschlag #12 (4,25 x 11 Zoll)
23 | Briefumschlag #14 (5 x 11,5 Zoll)
24 | Blatt in Größe C (17 x 22 Zoll)
25 | Blatt in Größe D (22 x 34 Zoll)
26 | Blatt in Größe E (34 x 44 Zoll)
27 | Briefumschlag DL (110 x 220 mm)
28 | Briefumschlag C5 (162 x 229 mm)
29 | Briefumschlag C3 (324 x 458 mm)
30 | Briefumschlag C4 (229 x 324 mm)
31 | Briefumschlag C6 (114 x 162 mm)
32 | Briefumschlag C65 (114 x 229 mm)
33 | Briefumschlag B4 (250 x 353 mm)
34 | Briefumschlag B5 (176 x 250 mm
35 | Briefumschlag B6 (176 x 125 mm)
36 | Briefumschlag (110 x 230 mm)
37 | Briefumschlag Monarch (3,875 x 7,5 Zoll)
38 | Briefumschlag 6-3/4 (3,625 x 6,5 Zoll)
39 | US Std Endlospapier (14,875 x 11 Zoll)
40 | Deutsch Std Endlospapier (8,5 x 12 Zoll)
41 | Deutsch Legal Endlospapier (8,5 x 13 Zoll)
256 | Benutzerdefiniert


Sprachspezifische Informationen

Sprachspezifische Hilfethemen gelten nur, wenn das sprachspezifische Feature zur Verfügung steht. Informieren Sie sich, wie Sie in einer anderen Sprache arbeiten oder die Korrekturhilfen für eine andere Sprache installieren, oder fragen Sie die Systemadministration nach weiteren Einzelheiten.


 Möglichkeiten des Sendens von E-Mail-Nachrichten

Möglichkeiten des Sendens von E-Mail-Nachrichten

Sie haben die folgenden Möglichkeiten zum Einrichten von Nachrichtenoptionen, um festzulegen, wie die Ausgabe eines Datenbankobjekts oder einer Datenzugriffsseite übermittelt und die Antwort des Empfängers angefordert werden soll:

Einstellen der Wichtigkeits- und Vertraulichkeitstufen Sie können die Wichtigkeitsstufe einer Nachricht so einstellen, dass der Empfänger zum sofortigen Lesen der Nachricht aufgefordert wird. Wenn Sie eine Antwort auf die Nachricht zu einem bestimmten Datum und Zeitpunkt wünschen, können Sie eine Kennzeichnung einstellen, die den Empfänger an die Beantwortung erinnert. Sie können ferner die Vertraulichkeit des Nachrichteninhalts als privat, persönlich oder vertraulich angeben.

Einstellen der Sicherheitstufe Wenn Sie und die Empfänger der Nachricht Microsoft Exchange Server verwenden, können Sie eine Nachricht mit einer digitalen Unterschrift versehen oder die Nachricht verschlüsseln (codieren), um sicherzustellen, dass die Nachricht nur von den ausgewählten Empfängern gelesen wird.

Rückverfolgen von Nachrichten und Antworten Sie können Nachrichten zurückverfolgen, indem Sie eine Benachrichtigung empfangen, wenn die Nachricht übermittelt und vom Empfänger gelesen wurde. Um Nachrichten suchen, sortieren, filtern und gruppieren zu können, haben Sie die Möglichkeit, einer Nachricht ein Schlüsselwort oder einen Ausdruck zuzuweisen. Sie können einer Nachricht auch Abstimmungsschaltflächen hinzufügen, damit Dritte per E-Mail über einen Sachverhalt abstimmen können.

Einstellen von Übermittlungsoptionen Sie können mit Hilfe eines Ablaufdatums anzeigen, dass der Inhalt einer Nachricht nicht mehr aktuell ist. Ferner können Sie die Nachricht nach dem Senden in einem angegebenen Microsoft Outlook-Ordner speichern. Sie können auch angeben, dass andere Empfänger Antworten auf Ihre Nachrichten empfangen sollen.

Zurück zu Einstellen von Optionen zum Senden einer E-Mail-Nachricht


 Info über das Hinzufügen von Sicherheit zu Nachrichten

Info über das Hinzufügen von Sicherheit zu Nachrichten

Nachrichten, die Sie senden möchten, können Sie zwei Sicherheitsfunktionen hinzufügen. Sie können eine Nachricht mit einer digitalen Unterschrift versehen, um sicherzustellen, dass die Nachricht nicht von Dritten geändert wird. Oder Sie können die Nachricht verschlüsseln (codieren), um dafür zu sorgen, dass die Nachricht und ihre Anlagen nur für die ausgewählten Empfänger lesbar ist.

Sie müssen vom Systemadministrator ein Schlüsselwort für Ihre Sicherheitsdatei erhalten, um eine Nachricht zu verschlüsseln oder digital zu unterschreiben. Die Empfänger der Nachricht müssen ihre Kennwörter angeben, um die verschlüsselte Nachricht zu öffnen oder die digitale Unterschrift zu überprüfen.

Anmerkung Diese Sicherheitsfunktionen gelten nur für ein Unternehmen und nur dann, wenn Sie und die Empfänger für E-Mail-Nachrichten Microsoft Exchange Server verwenden. Der Systemadministrator muss die Sicherheitsfunktionen auf den Computern einrichten.

Zurück zu Hinzufügen von Sicherheit zu Nachrichten


 Erstellen eines Skripts in einer Webseite

Erstellen eines Skripts in einer Webseite

Microsoft Visual Basic Scripting Edition (VBScript) ist die Standardskriptsprache, die der Webseite hinzugefügt ist. Ändern der Standardskriptsprache.

  1. Öffnen Sie die Webseite in der Entwurfsansicht oder der Datenzugriffsseitenansicht.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Microsoft Skript-Editor.
  3. Schreiben Sie das Skript im Microsoft Skript-Editor. Weitere Informationen zum Microsoft Skript-Editor.


Hinzufügen von Sicherheit zu Nachrichten

Was möchten Sie tun?

Verschlüsseln aller ausgehenden Nachrichten

Hinzufügen einer digitalen Unterschrift an alle ausgehenden Nachrichten

Sind wissen nicht, für welche Option Sie sich entscheiden sollen?


Hinzufügen von Abstimmungsschaltflächen zu einer E-Mail-Nachricht

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie unter Abstimmungs- und Verlaufoptionen auf Abstimmungsschaltflächen verwenden, und klicken Sie dann auf die Namen der Abstimmungsschaltflächen, die in dem Feld angezeigt werden sollen.

    Um eigene Namen für Abstimmungsschaltflächen zu erstellen, löschen Sie die standardmäßigen Schaltflächennamen und geben den gewünschten Text ein. Trennen Sie den Text durch Semikolons. Beispiel: Klein;Groß;Sehr groß.

  4. Um die Abstimmungsrückmeldungen zu verfolgen, aktivieren Sie das Kontrollkästchen Gesendete Nachricht speichern. Geben Sie anschließend den Name des Ordners ein, in dem die Nachricht gespeichert werden soll.

Anmerkung

  • Informationen zu Abstimmungsrückmeldungen finden Sie in der Microsoft Outlook-Hilfe.

  • Dieser Vorgang ist nur möglich, wenn Sie Outlook im Modus Firma oder Arbeitsgruppe installiert haben. Weitere Informationen zum Abrufen von Informationen zur Outlook-Installation.


Zuweisen einer Nachricht zu einer Kategorie

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen und anschließend auf Kategorien.

  3. Aktivieren Sie in der Liste Verfügbare Kategorien die Kontrollkästchen neben den gewünschten Kategorien.

  4. Um eine neue Kategorie zu erstellen, klicken Sie auf die Schaltfläche Hauptkategorienliste.

  5. Geben Sie in das Feld Neue Kategorie einen Namen für die Kategorie ein, und klicken Sie anschließend auf Hinzufügen.

  6. Um weitere Kategorien zu erstellen, wiederholen Sie Schritt 5.

  7. Klicken Sie zweimal auf OK und dann auf Schließen.

Tipp Sie können ferner eine Nachricht einer Kategorie zuweisen, indem Sie auf Optionen klicken und dann in das Feld Kategorien den Namen der Kategorie eingeben. Wenn Sie so vorgehen, müssen Sie darauf achten, den Kategorienamen hinsichtlich Buchstabierung und Groß- und Kleinschreibung korrekt einzugeben. Sonst wird die Nachricht keiner Kategorie in der Hauptkategorienliste zugewiesen. Kategorien, die nicht in der Hauptkategorienliste enthalten sind, können keine Nachrichten zugewiesen werden.


Verzögern der Übermittlung einer Nachricht

Anmerkung Diese Funktion ist nur in Microsoft Exchange Server verfügbar.

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie unter Übermittlungsoptionen auf Übermittlung verzögern bis, und geben Sie das gewünschte Übermittlungsdatum ein.


 Veranlassen des Sendens von Antworten auf eine Nachricht an einen anderen Benutzer

Veranlassen des Sendens von Antworten auf eine Nachricht an einen anderen Benutzer

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Aktivieren Sie unter Übermittlungsoptionen das Kontrollkästchen Antworten senden an.

  4. Geben Sie den Namen eines anderen Benutzers ein, oder klicken Sie auf Namen auswählen, um Namen in einer Liste auszuwählen.

Anmerkung Sie können keine Antworten an eine persönliche Verteilerliste senden.


 Laden oder Entladen eines COM Add-In-Programms

Laden oder Entladen eines COM Add-In-Programms

Wenn Sie kein Entwickler sind, brauchen Sie kein Component Object Model (COM) Add-In zu laden oder zu entladen, da die meisten COM Add-Ins ein Installations-/Deinstallationsprogramm enthalten.

  1. Wenn Sie den Befehl COM Add-Ins bereits zum Menü Extras hinzugefügt haben, gehen Sie zu Schritt 6.

  2. Klicken Sie im Menüs Extras auf Anpassen und dann auf die Registerkarte Befehle.

  3. Klicken Sie im Feld Kategorien auf Extras.

  4. Ziehen Sie COM Add-Ins aus dem Feld Befehle in das Menü Extras. Wenn die Menübefehle angezeigt werden, zeigen Sie auf die Position, an der der Befehl COM Add-Ins im Menü angezeigt werden soll, und lassen Sie dann die Maustaste los.

  5. Klicken Sie auf Schließen.

  6. Klicken Sie im Menü Extras auf COM Add-Ins.

    Um ein Add-In zu laden, aktivieren Sie das Kontrollkästchen neben dem Namen des Add-Ins in der Liste Verfügbare Add-Ins.

    Wenn das gewünschte Add-In nicht in der Liste Verfügbare Add-Ins aufgeführt wird, klicken Sie auf Hinzufügen, suchen Sie das Add-In, und klicken Sie dann auf OK.

    Um ein Add-In aus dem Speicher zu entfernen, den Namen aber in der Liste beizubehalten, deaktivieren Sie das Kontrollkästchen neben dem Namen des Add-Ins.

    Um ein Add-In aus der Liste und aus der registrierten Liste der Add-Ins in der Registrierungsdatei zu entfernen, markieren Sie den Namen, und klicken Sie dann auf Entfernen.

Anmerkung Durch das Entladen oder Entfernen eines Add-Ins wird die Add-In-Datei nicht von Ihrem Computer entfernt.

Tipp Informationen zum Erstellen eines COM Add-In finden Sie im Microsoft Office 2000/Visual Basic Programmierhandbuch.


Ungültigmachen einer gesendeten Nachricht nach Ablauf eines angegebenen Datums

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie unter Übermittlungsoptionen auf Läuft ab nach, und geben Sie das gewünschte Ablaufdatum ein.


Kennzeichnen einer Nachricht als privat, persönlich oder vertraulich

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie in Nachrichteneinstellungen auf die gewünschte Vertraulichkeitsstufe.

Anmerkung Das Kennzeichnen einer Nachricht als Privat verhindert das Bearbeiten der Nachricht nach dem Senden.


Empfangen einer Benachrichtigung nach der Übermittlung einer Nachricht

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie in Abstimmungs- und Verlaufoptionen auf Die Übermittlung dieser Nachricht bestätigen.

Anmerkung

  • Diese Option gilt nur für die aktuelle Nachricht.

  • Dieser Vorgang ist nur möglich, wenn Sie Outlook im Modus Firma oder Arbeitsgruppe installiert haben. Informationen zum Abrufen von Informationen zur Outlook-Installation.


Empfangen einer Benachrichtigung nach der Übermittlung einer Nachricht

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie in Abstimmungs- und Verlaufoptionen auf Das Lesen dieser Nachricht bestätigen.

Anmerkung

  • Diese Option gilt nur für die aktuelle Nachricht.

  • Dieser Vorgang ist nur möglich, wenn Sie Outlook im Modus Firma oder Arbeitsgruppe installiert haben. Informationen zum Abrufen von Informationen zur Outlook-Installation.


Speichern einer Kopie der gesendeten Nachricht

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie in Übermittlungsoptionen auf Gesendete Nachricht speichern.

    Um einen Ordner anzugeben, in dem Sie die Nachricht speichern wollen, klicken Sie auf die Schaltfläche Durchsuchen.

Anmerkung Diese Option gilt nur für die aktuelle Nachricht.


Hinzufügen einer digitalen Unterschrift an alle ausgehenden Nachrichten

Diese Funktion gilt nur für ein Unternehmen und nur dann, wenn Sie und die Empfänger für E-Mail-Nachrichten Microsoft Exchange Server verwenden. Der Systemadministrator muss die Sicherheitsfunktionen auf den Computern einrichten.

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie in Sicherheit auf Digitale Signatur ausgehenden Nachrichten hinzufügen.


Verschlüsseln aller ausgehenden Nachrichten

Diese Funktion gilt nur für ein Unternehmen und nur dann, wenn Sie und die Empfänger für E-Mail-Nachrichten Microsoft Exchange Server verwenden. Der Systemadministrator muss die Sicherheitsfunktionen auf den Computern einrichten.

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Optionen.

  3. Klicken Sie unter Sicherheit auf Nachrichteninhalte und Anlagen verschlüsseln.


Einstellen der Wichtigkeitsstufe einer Nachricht

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Führen Sie einen der folgenden Schritte aus:

    Um eine Nachricht als sehr wichtig zu kennzeichnen, klicken Sie auf Wichtigkeit: Hoch [image].

    Um eine Nachricht als nicht wichtig zu kennzeichnen, klicken Sie auf Wichtigkeit: Niedrig [image].

    Um das Wichtigkeitsstufensymbol von einer Nachricht zu entfernen, klicken Sie erneut auf die Wichtigkeitsschaltfläche.

Anmerkung Um alle zu sendenden Nachrichten mit derselben Wichtigkeitsstufe zu kennzeichnen, klicken Sie in Einstellungen auf Optionen und dann auf die gewünschte Wichtigkeitsstufe.


Einstellen eines Nachrichtenkennzeichens

Durch das Kennzeichnen einer Nachricht können Sie entweder schnell eine Nachricht zur Nachverfolgung oder mit einer Anforderung an einen Dritten markieren. Wenn der Empfänger eine Nachricht mit einem Kennzeichen empfängt, wird ein Kommentar zum Zweck des Kennzeichens oben in der Nachricht angezeigt. Wenn Sie ein Fälligkeitsdatum einstellen, wird dieses ebenfalls angezeigt.

  1. Zeigen Sie die Nachrichtenkopfzeile an, indem Sie die Ausgabe eines Objekts an eine E-Mail-Nachricht anhängen oder eine Datenzugriffsseite als Hauptteil einer E-Mail-Nachricht senden.

  2. Klicken Sie auf Zur Nachverfolgung kennzeichnen [image].

  3. Wählen Sie im Feld Kennzeichnung in der Liste eines der Kennzeichen aus, oder geben Sie ein eigenes ein.

    Um ein bereits gesetztes Kennzeichen zu löschen, klicken Sie auf Löschen.

  4. Wählen Sie im Feld Fällig ein Datum aus oder geben Sie ein eigenes ein, um ein Fälligkeitsdatum festzulegen.


 Informationen über das Zuweisen von Nachrichten zu Kategorien

Informationen über das Zuweisen von Nachrichten zu Kategorien

Um Nachrichten suchen, sortieren, filtern und gruppieren zu können, haben Sie die Möglichkeit, Nachrichten einer Kategorie zuzuweisen. Eine Kategorie ist ein Schlüsselwort oder ein Satz. Mit Hilfe von Kategorien können Sie einen Überblick über verschiedene Elementtypen behalten, die miteinander verwandt, aber in verschiedenen Ordnern gespeichert sind.

Kategorien bieten auch eine Möglichkeit, Elemente zurückzuverfolgen, ohne diese in getrennten Ordnern abzulegen. Sie können z. B. geschäftliche und persönliche Aufgaben in derselben Aufgabenliste ablegen und die Kategorien Geschäftlich und Persönlich verwenden, um die Aufgaben getrennt anzuzeigen.

Outlook enthält eine Liste mit Kategorien, denen Sie Elemente zuweisen können, die Hauptkategorieliste genannt wird. Sie können diese Liste unverändert belassen oder ihr eigene Kategorien hinzufügen.

Elemente können mehr als einer Kategorie zugewiesen werden.

Weitere Informationen zu Kategorien finden Sie in der Outlook-Hilfe.

Nächster Schritt

Zuweisen von Nachrichten zu einer Kategorie


 Eine Datenzugriffsseite zeigt für die Sprache die falschen Zeichen an

Eine Datenzugriffsseite zeigt für die Sprache die falschen Zeichen an

Wenn eine Datenzugriffsseite für eine andere Sprache codiert ist, versucht Microsoft Access, die Sprache zu bestimmen. Wenn Access beim Öffnen der Seite in einem Browser die falschen Zeichen für diese Sprache anzeigt, können Sie die Sprache auswählen, von der Sie meinen, dass die Seite in dieser codiert sei. Einige Sprachen bieten mehrere Codierungen. Probieren Sie deshalb alle Codierungen, bis Sie den Text lesen können.

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Allgemein und anschließend auf Weboptionen.

  4. Klicken Sie im Dialogfeld Weboptionen auf die Registerkarte Kodierung.

  5. Wählen Sie unter Das aktuelle Dokument laden als die Sprache aus, von der Sie meinen, dass die Seite in dieser codiert ist.


 Die unterstützenden Dateien für eine Datenzugriffsseite sollen nicht länger in einem Ordner gespeichert werden.

Die unterstützenden Dateien für eine Datenzugriffsseite sollen nicht länger in einem Ordner gespeichert werden.

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, werden alle unterstützenden Dateien wie Aufzählungszeichen, Hintergrundstrukturen und Grafiken standardmäßig in einem getrennten Ordner gespeichert. Wenn Sie keinen getrennten Ordner wünschen, führen Sie die folgenden Schritte durch:

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Allgemein und anschließend auf Weboptionen.

  4. Klicken Sie im Dialogfeld Weboptionen auf die Registerkarte Dateien.

  5. Deaktivieren Sie unter Dateinamen und Speicherorte das Kontrollkästchen Unterstützende Dateien in einen Ordner speichern.


 Nach dem Speichern einer Datenzugriffsseite auf einem Dateiserver können andere Benutzer diese nicht finden oder anzeigen.

Nach dem Speichern einer Datenzugriffsseite auf einem Dateiserver können andere Benutzer diese nicht finden oder anzeigen.

Wenn Sie einen langen Dateinamen zum Speichern einer Datenzugriffsseite in der Entwurfsansicht verwenden, können Benutzer von Windows 3.1 diese Datenzugriffsseite weder finden noch öffnen, da Windows 3.1 nur kurze Dateinamen (mit höchstens 8 Zeichen plus 3 weiteren für die Erweiterung) erkennt. Um Dateien immer mit kurzen Dateinamen zu speichern, führen Sie die folgenden Schritte durch:

  1. Öffnen Sie die Datenzugriffsseite in der Entwurfsansicht.

  2. Klicken Sie im Menü Extras auf Optionen.

  3. Klicken Sie auf die Registerkarte Allgemein und anschließend auf Weboptionen.

  4. Klicken Sie im Dialogfeld Weboptionen auf die Registerkarte Dateien.

  5. Deaktivieren Sie unter Dateinamen und Speicherorte das Kontrollkästchen Wenn möglich, lange Dateinamen verwenden.


 Grafiken und Text einer Datenzugriffsseite sehen auf einem anderen Computer anders aus.

Grafiken und Text einer Datenzugriffsseite sehen auf einem anderen Computer anders aus.

Wenn eine Datenzugriffsseite nicht wie gewünscht angezeigt wird, überprüfen Sie die Browsereinstellungen. Obgleich alle Webbrowser dieselbe Sprache unterstützen (HTML) , gibt es unter den Browsern einige Unterschiede. Einige unterstützen andere Versionen von HTML und andere HTML-Erweiterungen. Ferner können in Browsern benutzerdefinierte Optionen eingestellt werden, wie z. B. Standardtext und Hintergrundfarben oder das Unterdrücken der Grafikanzeige. Testen Sie ggf. die Seite in verschiedenen Browsern, von denen einige aus dem Web gedownloadet werden können, und in verschiedenen Monitoreinstellungen, um zu sehen, ob alle Elemente der Seite angezeigt werden.


 Beim Kopieren und Einfügen von Elementen wird die Symbolleiste "Zwischenablage" nicht mehr angezeigt

Beim Kopieren und Einfügen von Elementen wird die Symbolleiste "Zwischenablage" nicht mehr angezeigt

Wenn Sie Symbolleiste Zwischenablage drei Mal hintereinander schließen, ohne die Schaltfläche Alle einfügen oder eine andere Schaltfläche zu verwenden, dann wird die Symbolleiste Zwischenablage nicht mehr automatisch angezeigt. Wenn Sie die Symbolleiste Zwischenablage wieder anzeigen möchten, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken Sie dann auf Zwischenablage. Sie können auch die Symbolleiste Zwischenablage erneut anzeigen, indem Sie ein Element zwei Mal hintereinander kopieren.

Wenn Sie die Symbolleiste Zwischenablage manuell anzeigen und auf Alle einfügen [image] oder auf ein einzelnes Element klicken, dann wird der Zähler zurückgesetzt. Von dem Zeitpunkt an wird die Symbolleiste Zwischenablage wieder automatisch angezeigt.


 Andere Teilnehmer einer Onlinebesprechung sehen auf dem Bildschirm ein Kreuzschraffurzeichen.

Andere Teilnehmer einer Onlinebesprechung sehen auf dem Bildschirm ein Kreuzschraffurzeichen.

Stellen Sie sicher, dass keine anderen Fenster die Microsoft Access-Datenbank, das Microsoft Access-Projekt oder die Datenzugriffsseite überlagern.

  • Beenden Sie nicht verwendete Programme.

  • Minimieren Sie andere Fenster auf dem Desktop.


 Zur Office-Zwischenablage können keine zusätzlichen Elemente hinzugefügt werden.

Zur Office-Zwischenablage können keine zusätzlichen Elemente hinzugefügt werden.

Möglicherweise haben Sie mehr als 12 Elemente kopiert Die Office-Zwischenablage kann maximal 12 Elemente aufnehmen. Enthält die Office-Zwischenablage bereits 12 Elemente und Sie kopieren ein weiteres Element, dann werden Sie in einer Meldung gefragt, ob das erste kopierte Element entfernt werden soll und das neue Element aufgenommen werden soll. Wenn Sie auf OK klicken, wird beim nächsten Kopieren eines Elements in einem beliebigen Programm automatisch das erste Element der Zwischenablage gelöscht und das neue Element hinzugefügt. Wenn Sie auf Abbrechen klicken, werden neue Elemente, die Sie kopieren, nicht zur Office-Zwischenablage hinzugefügt. Diese Meldung wird erst dann wieder angezeigt, wenn Sie die Office-Zwischenablage löschen und erneut auffüllen.

Möglicherweise haben Sie große Elemente kopiert Wenn Sie große Elemente in die Office-Zwischenablage kopieren, kann diese unter Umständen weniger als 12 Elemente aufnehmen. Wenn Sie erneut Elemente kopieren möchten, klicken Sie auf der Symbolleiste Zwischenablage auf Zwischenablage löschen [image] .


 Sicherungskopie einer Datenzugriffsseite kann nicht automatisch erstellt werden.

Sicherungskopie einer Datenzugriffsseite kann nicht automatisch erstellt werden.

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, wird nicht automatisch eine Sicherungskopie erstellt. Um eine Kopie der Datenzugriffsseite zu speichern, klicken Sie im Menü Datei auf Speichern unter. Geben Sie in das Feld Datenzugriffsseite <Objektname> Speichern in einen neuen Namen für die Datenzugriffsseite ein, und klicken Sie dann auf Speichern.


Ich kann einen Menübefehl, eine Symbolleistenschaltfläche oder eine Dialogfeldoption nicht finden

Das Menü ist möglicherweise nicht erweitert Wenn am unteren Rand des Menüs Pfeile Doppelte, nach unten zeigende Pfeile angezeigt werden, ist das Menüelement möglicherweise im erweiterten Menü verfügbar. Klicken Sie auf die Pfeile Doppelte, nach unten zeigende Pfeile, und klicken Sie dann auf den gewünschten Befehl. Sie können auch auf das Menü doppelklicken, um es zu erweitern. Oder Sie können angeben, dass Access alle Befehle für alle Menüs anzeigen soll.

Die Symbolleiste ist möglicherweise in derselben Reihe wie eine andere Symbolleiste Die Schaltfläche wird möglicherweise nicht auf der Symbolleiste angezeigt, weil nicht genügend Platz für alle Schaltflächen vorhanden ist. Klicken Sie auf Weitere Schaltflächen [image], und klicken Sie dann auf die gewünschte Schaltfläche. Sie können auch alle Schaltflächen auf der Symbolleiste anzeigen.

Möglicherweise ist die Microsoft Office-Komponente nicht installiert Führen Sie den Installer erneut aus, und installieren Sie die Komponente.

Möglicherweise ist eine andere Spracheinstellung eingestellt Der Befehl oder das Steuerelement wird nicht angezeigt, wenn das Bearbeiten für die Sprache, auf die sich der Befehl oder das Steuerelement bezieht, nicht aktiviert ist. Es ist erforderlich, das Bearbeiten für die Sprache zu aktivieren, in der Sie arbeiten möchten. Info über mehrsprachiges Bearbeiten und Tool-Kits für die Rechtschreibprüfung.


 Während einer Onlinebesprechung kann eine Access-Datenbank, ein Access-Projekt oder eine Datenzugriffsseite nicht auf dem lokalen Drucker gedruckt bzw. auf der Festplatte gespeichert werden.

Während einer Onlinebesprechung kann eine Access-Datenbank, ein Access-Projekt oder eine Datenzugriffsseite nicht auf dem lokalen Drucker gedruckt bzw. auf der Festplatte gespeichert werden.

Sie können nur die Microsoft Access-Datenbank, das Microsoft Access-Projekt oder die Datenzugriffsseite auf dem Drucker drucken oder der Festplatte speichern, mit der/dem die Onlinebesprechung initiiert wurde. Wenn Sie auf Drucken klicken, drucken Sie die Datei auf dem Drucker des Teilnehmers, der die Onlinebesprechung initiiert hat. Wenn Sie auf Speichern klicken, speichern Sie die Datei auf der Festplatte oder dem Server des Initiators und nicht auf Ihrer Festplatte oder Ihrem Server.

Wenn Sie eine Kopie der Datei wünschen, an der gemeinsam gearbeitet wird, bitten Sie den Initiator der Onlinebesprechung, Ihnen eine Kopie der Datei zu senden, oder kopieren Sie den Dokumentinhalt in eine Datei auf Ihrem Computer.

Anmerkung Speichern können Sie nur, wenn Sie die Kontrolle über die Access-Datendatei haben.


Elemente, die anderen Teilnehmern der Onlinebesprechung angezeigt werden, werden nicht angezeigt.

Die Einstellungen für die Bildschirmauflösung müssen denen der anderen Teilnehmer der Onlinebesprechung entsprechen. Einstellen der Bildschirmauflösung.


 Nach dem Verschieben einer Datenzugriffsseite an einen anderen Speicherort funktionieren einige Verknüpfungen nicht mehr.

Nach dem Verschieben einer Datenzugriffsseite an einen anderen Speicherort funktionieren einige Verknüpfungen nicht mehr.

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, werden alle Hilfsdateien, wie z. B. Aufzählungszeichen, Hintergrundstrukturen und Grafiken, standardmäßig in einem Hilfsordner gespeichert. Wenn Sie eine Datenzugriffsseite an einen anderen Speicherort kopieren oder verschieben, müssen Sie auch den Hilfsordner verschieben, damit alle Verknüpfungen mit der Seite beibehalten werden.


Ich möchte, dass die Menüs wie in Office 97 angezeigt werden

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen.

  2. Deaktivieren Sie das Kontrollkästchen Menüs zeigen zuletzt verwendete Befehle zuerst an.

Anmerkung Das Kontrollkästchen Menüs zeigen zuletzt verwendete Befehle zuerst an betrifft alle Microsoft Office-Programme.


 Beim Anmelden stehen die persönlichen Einstellungen nicht zur Verfügung.

Beim Anmelden stehen die persönlichen Einstellungen nicht zur Verfügung.

Das Benutzerprofil ist u. U. für das Betriebssystem nicht gültig Ein Benutzerprofil ist nur in dem Betriebssystem gültig, in dem es erstellt wurde. Ein Windows NT-Benutzerprofil kann z. B. nicht auf einem Windows 95-Computer verwendet werden. Wenn Ihr Benutzerprofil in Windows 95 erstellt wurde und Sie sich bei einem Windows NT-Computer anmelden, werden die persönlichen Einstellungen nicht angezeigt. Sie müssen sich bei einem Computer anmelden, der dasselbe Betriebssystem verwendet, mit dem das Benutzerprofil erstellt wurde.

Der Computer ist ggf. nicht für mehrere Benutzer konfiguriert Wenn Sie sich bei einem Windows 95-Computer anmelden, kann es sein, dass dieser keine Einstellungen für mehrere Benutzer zulässt. Damit mehrere Benutzer persönlich angepasste Einstellungen auf einem Windows 95-Computer verwenden können, gehen Sie so vor:

  1. Zeigen Sie im Windows Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf das Symbol Kennwörter Schlüsselbund , und klicken Sie dann auf die Registerkarte Benutzerprofile.

  3. Klicken Sie auf Benutzer können die Vorgaben und Desktop-Einstellungen ändern. Beim Anmelden werden in Windows die individuellen Einstellungen des Benutzers wiederhergestellt.

Das Benutzerkonto ist ggf. nicht aktiviert Der Systemadministrator hat ggf. das Benutzerkonto im Netzwerk nicht für die Verwendung servergespeicherter Benutzerprofile konfiguriert. Wenn beim Anmelden keine der persönlichen Einstellungen angezeigt wird, wenden Sie sich an den Systemadministrator.

Mehrfachanmeldungen unterscheiden sich je nach Betriebssystem Wenn Sie gleichzeitig bei mehr als einem Computer angemeldet sind, stehen die Änderungen, die Sie an den Einstellungen auf einem Computer vornehmen, auf Grund der Unterschiede bei den Betriebssystem ggf. nicht sofort auf dem anderen Computer zur Verfügung. Bei Windows 95- und Windows NT 4.0-Computern sind die Änderungen, die Sie auf dem letzten Computer vornehmen, von dem Sie sich abmelden, die Einstellungen, die in das Benutzerprofil kopiert und bei der nächsten Anmeldung verwendet werden. Auf Windows 2000-Computern werden die Änderungen an den Einstellungen sofort angezeigt, da das Benutzerprofil in regelmäßigen Abständen auf den Server kopiert wird.


Benutzerdefinierte Vorlagen werden in der falschen Registerkarte angezeigt.

Sie müssen benutzerdefinierte Vorlagen im entsprechenden Unterordner des Ordners Vorlagen speichern. Sie finden den Ordner Vorlagen an folgendem Speicherort:

Stammverzeichnis\Betriebssystem\Profiles\Benutzername\Anwendungsdaten\Microsoft\Vorlagen

Stammverzeichnis ist ein Serverspeicherort oder Verzeichnis auf einem Laufwerk, von dem alle anderen Ordner abzweigen (z. B. C:\). Betriebssystem ist der Betriebssystemordner (z. B. Windows oder Winnt) und Benutzername ist Ihr Benutzername.

Vorlagen im Ordner Vorlagen werden in der Registerkarte Allgemein angezeigt. Vorlagen in Unterordnern werden in Registerkarten angezeigt, die dieselben Namen haben wie die Unterorder. Wenn Sie z. B. unter dem Ordner Vorlagen den Unterordner Berichte erstellen, wird im Dialogfeld Neu (Menü Datei) die Registerkarte Berichte angezeigt.

Anmerkung In Windows 2000 lautet der Pfad für den Ordner Vorlagen so: Stammverzeichnis\Benutzer\Benutzername\Anwendungsdaten\Microsoft\Vorlagen.


Ich möchte das automatische Erweitern der Menüanzeigen deaktivieren

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen.

  2. Deaktivieren Sie das Kontrollkästchen Nach kurzer Verzögerung vollständige Menüs anzeigen.

Anmerkung Das Kontrollkästchen Nach kurzer Verzögerung vollständige Menüs anzeigen betrifft alle Microsoft Office-Programme.


 Der Name eines Hilfsordners einer Datenzugriffsseite hat eine andere Sprache.

Der Name eines Hilfsordners einer Datenzugriffsseite hat eine andere Sprache.

Wenn Sie eine Datenzugriffsseite in der Entwurfsansicht speichern, werden alle Hilfsdateien wie Aufzählungszeichen, Hintergrundstrukturen und Grafiken standardmäßig in einem Hilfsordner gespeichert. Der Name des Hilfsordners ist standardmäßig der Name der Datenzugriffsseite plus ein Unterstrich (_), ein Punkt (.) oder ein Bindestrich (-) und das Wort "files". Das Wort "files" wird in der Sprache der Version von Microsoft Office 2000 angezeigt, die zum Speichern der Datei als Datenzugriffsseite verwendet wird. Wenn Sie z. B. die deutsche Sprachversion von Office 2000 verwenden, um die Datei Seite1 als Datenzugriffsseite zu speichern, ist der Standardname des Hilfsordners Seite1_Dateien. Informationen zum Standardnamen von Hilfsordnern.

Anmerkung Wenn Sie eine Datenzugriffsseite mit einem kurzen Dateinamen (mit höchstens acht Zeichen plus drei Zeichen für die Erweiterung) speichern, indem Sie das Kontrollkästchen Wenn möglich, lange Dateinamen verwenden im Dialogfeld Weboptionen deaktivieren, hat der Hilfsordner den Namen der Datenzugriffsseite ohne den Zusatz "Dateien".


 Der Name eines Teilnehmers, der zu einer Onlinebesprechung eingeladen werden soll, ist nicht in der Liste enthalten.

Der Name eines Teilnehmers, der zu einer Onlinebesprechung eingeladen werden soll, ist nicht in der Liste enthalten.

Verbinden Sie sich mit einem anderen Server

  • Wählen Sie im Dialogfeld Anrufen in der Liste Verzeichnis ein anderes Verzeichnis.

Senden Sie an die Person eine E-Mail-Nachricht, oder rufen Sie sie an.

Informieren Sie die Person, dass Sie eine Onlinebesprechung starten wollen. Ermitteln Sie, bei welchem Verzeichnisserver die Person angemeldet ist, oder verwenden Sie den Computernamen oder die IP (Internet Protocol)-Adresse.


 Die Schaltfläche "Alle einfügen" ist nicht verfügbar

Die Schaltfläche "Alle einfügen" ist nicht verfügbar

In einigen Fällen ist auf der Symbolleiste der Zwischenablage die Schaltfläche Alle einfügen nicht verfügbar, obwohl einzelne Elemente zum Einfügen vorhanden sind:

In allen Microsoft Office-Programmen ist Alle einfügen nicht verfügbar, wenn ein einzelnes Element der Office-Zwischenablage nicht in das Programm eingefügt werden kann.

In Microsoft Access ist Alle einfügen nur auf Datenzugriffsseiten verfügbar.

Wenn die Schaltfläche Alle einfügen nicht verfügbar ist, können Sie möglicherweise trotzdem einzelne Elemente einfügen.


Die Symbolleiste der Zwischenablage ist nicht verfügbar

Möglicherweise verwenden Sie gerade ein anderes Programm als Microsoft Excel, Microsoft Word, Microsoft Access, Microsoft Outlook oder Microsoft PowerPoint Die Symbolleiste der Zwischenablage ist nur in Excel, Word, Access, Outlook und PowerPoint verfügbar, aber nicht im Visual Basic-Editor. Wenn die Office-Zwischenablage in einem Microsoft Office-Programm angezeigt wird, werden alle Elemente, die Sie in einem beliebigen Programm ausschneiden oder kopieren, automatisch in die Zwischenablage aufgenommen.

Möglicherweise sind die Befehle "Kopieren", "Ausschneiden" und "Einfügen" nicht verfügbar Die Schaltflächen Kopieren und Alle einfügen und die in der Symbolleiste der Zwischenablage vorhandenen Elemente sind in den Programmbereichen nicht verfügbar, in denen die Befehle Kopieren, Ausschneiden und Einfügen nicht verwendet werden können.


Abfragen: Definition und Funktionsweise

1 2 3


Abfragen: Definition und Funktionsweise


Anzeigen von Text oder von einem Symbol zusammen mit Text auf einem Menübefehl

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Menüleiste, das Kontextmenü oder die Symbolleiste mit dem zu ändernden Befehl an.

  3. Öffnen Sie gegebenenfalls das Dialogfeld Anpassen, und klicken Sie auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl enthält, den Sie ändern möchten.

  4. Klicken Sie mit der rechten Maustaste auf das Menü, und klicken Sie dann im Kontextmenü auf die gewünschte Option.

Anmerkungen

  • Einigen Befehlen ist kein Symbol zugeordnet. Diese können in einem Menü nur als Text dargestellt werden.

  • In einem Menü kann ein Befehl nie nur in Form eines Symbols dargestellt werden. Wenn ein Befehl jedoch das Format Standard hat, wird er beim Kopieren oder Verschieben in der entsprechenden Symbolleiste oder Menüleiste automatisch als Symbol angezeigt (dies ist die Standardeinstellung für Symbol- und Menüleisten).

  • Wenn Sie die Art und Weise, wie ein Befehl in einem eingebauten Menü (z.B. im Menü Bearbeiten) angezeigt wird, ändern, gilt diese Änderung in allen Ansichten, in denen dieses Menü mit diesem Befehl angezeigt wird.


Definition und Funktionsweise von Berichten

1 2 3


Definition und Funktionsweise von Berichten


Die Sprechblase des Office-Assistenten ist verschwunden

  • Möglicherweise wird ein Tipp oder eine Sprechblase mit einer Meldung vor einer anderen Sprechblase angezeigt. Schließen Sie die Sprechblase im Vordergrund, so dass Sie die dahinter liegende Sprechblase sehen können.

  • Einige Sprechblasen mit Meldungen werden automatisch geschlossen, wenn Sie im Microsoft Access-Fenster klicken. Dabei handelt es sich um Sprechblasen mit informativen Meldungen, die keine Antwort erfordern. Wenn Sie z. B. die Rechtschreibung überprüfen, wird eine Meldung angezeigt, die Sie darüber informiert, dass der Vorgang beendet ist. Sie können diese Meldungen nur durch Wiederholen der Aktion anzeigen, die sie hervorgerufen hat, z. B. indem Sie die Rechtschreibung erneut überprüfen.


 Ich kann nicht auf die Microsoft Office Update Website zugreifen

Ich kann nicht auf die Microsoft Office Update Website zugreifen

  • Wenn Sie den Befehl Office im Web (Menü ?) verwenden möchten, müssen Sie Zugriff auf das Internet haben, und zwar entweder über das Intranet der Firma, in der Sie arbeiten, oder über ein Modem, das an Ihren Computer oder am Netzwerk angeschlossen ist. Weiterhin müssen Sie über ein Internetkonto eines Internetdienstanbieters verfügen. Weitere Informationen finden Sie im Microsoft Office 2000 Resource Kit. Rufen Sie weitere Informationen darüber auf, wie Sie das Microsoft Office 2000 Resource Kit erhalten.

  • Die Einstellungen, die verwendet werden, um Ihren Computer mit dem Internet zu verbinden, sind möglicherweise nicht korrekt. Zum Überprüfen der Einstellungen doppelklicken Sie in der Windows-Systemsteuerung auf das Symbol Internet.

  • Möglicherweise funktioniert Ihr Modem nicht richtig. Weitere Informationen finden Sie in der Microsoft Windows-Hilfe unter dem Thema "Behandlung von Modem-Fehlern".

  • Die Microsoft Office Update Website ist möglicherweise vorübergehend nicht verfügbar. Wenn Sie auf andere Websites zugreifen können, warten Sie eine Weile, und versuchen Sie dann erneut, eine Verbindung herzustellen.


Bereiche eines Formulars

1 2 3


Bereiche eines Formulars


Bereiche eines Berichts

1 2 3


Bereiche eines Berichts


Tabellen: Definition und Funktionsweise

1 2 3 4 5


Tabellen: Definition und Funktionsweise


Werte für das Element TTOption

Wert | Bedeutung
1 | TrueType-Schriftarten werden als Grafik gedruckt. Dies ist die Standardeinstellung für Nadeldrucker.
2 | TrueType-Schriftarten werden als ladbare Schriftarten (Schriftarten, die zur Aufbereitung in den Arbeitsspeicher des Druckers geladen werden) heruntergeladen. Dies ist die Standardeinstellung für Hewlett-Packard-Drucker, die mit PCL (Printer Control Language) arbeiten.
3 | TrueType-Schriftarten werden durch Geräteschriftarten ersetzt. Dies ist die Standardeinstellung für PostScript-Drucker.


Möglichkeiten zum Anpassen eines Formulars

1 2 3 4 5 6


Möglichkeiten zum Anpassen eines Formulars


Möglichkeiten der Anpassung einer Abfrage

1 2 3 4 5


Möglichkeiten der Anpassung einer Abfrage


Möglichkeiten zum Anpassen eines Berichts

1 2 3 4 5 6


Möglichkeiten zum Anpassen eines Berichts


Möglichkeiten der Anpassung einer Tabelle

1 2 3 4 5 6


Möglichkeiten der Anpassung einer Tabelle


Möglichkeiten der Angabe mehrerer Kriterien in einer Abfrage

Ein Feld unter Verwendung von Or
Ein Feld unter Verwendung von And
Zwei Felder unter Verwendung von Or
Zwei Felder unter Verwendung von And
Drei Felder unter Verwendung von And und Or


Möglichkeiten der Angabe mehrerer Kriterien in einer Abfrage


Möglichkeiten zum Bearbeiten von Daten in einem Formular

1 2 3 4


Möglichkeiten zum Bearbeiten von Daten in einem Formular


Möglichkeiten des Arbeitens mit Daten eines Datenblatts einer Abfrage

1 2 3 4 5 6 7


Möglichkeiten des Arbeitens mit Daten eines Datenblatts einer Abfrage


Möglichkeiten des Arbeitens mit Daten eines Datenblatts einer Tabelle

1 2 2 4 5 6 7


Möglichkeiten des Arbeitens mit Daten eines Datenblatts einer Tabelle


Wiederherstellen des Erscheinungsbilds einer eingebauten Symbolleistenschaltfläche oder eines Menübefehls

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Anpassen.

  2. Zeigen Sie die Symbol- oder Menüleiste oder das Kontextmenü mit der Schaltfläche oder dem Menübefehl an, die/den Sie wiederherstellen möchten.
  3. Öffnen Sie gegebenenfalls das Dialogfeld Anpassen, und führen Sie dann einen der folgenden Schritte aus:
    • Klicken Sie zum Wiederherstellen einer Symbolleistenschaltfläche mit der rechten Maustaste (in der Symbolleiste) auf die Schaltfläche, die Sie wiederherstellen möchten, und klicken Sie dann im Kontextmenü auf Zurücksetzen.

    • Klicken Sie zum Wiederherstellen eines Menübefehls auf das Menü in der Menü- oder Symbolleiste, oder klicken Sie auf das Kontextmenü, das den Befehl enthält, den Sie wiederherstellen möchten. Klicken Sie mit der rechten Maustaste auf den Menübefehl, und klicken Sie dann im Kontextmenü auf Zurücksetzen.

Anmerkung Der Befehl Zurücksetzen steht nicht für eine Schaltfläche zur Verfügung, die, wenn auf sie geklickt wird, eine Liste anzeigt. Wenn Sie das Bild auf einer eingebauten Schaltfläche oder einem eingebauten Befehl geändert haben, können Sie nur das Originalbild wiederherstellen. Dazu klicken Sie mit der rechten Maustaste auf die Schaltfläche oder den Befehl, wobei das Dialogfeld Anpassen geöffnet sein muss. Anschließend klicken Sie im Kontextmenü auf Löschen.


Info über das Formatieren von Diagrammen

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik:

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.

Um dieses Thema über die Tastatur anzuzeigen, drücken Sie F6, um das Themenfenster zu aktivieren. Drücken Sie TAB, um die Grafik auszuwählen, und anschließend die EINGABETASTE.


 Eingeben von ¢, £, ¥, ® und anderer Zeichen, die sich nicht auf der Tastatur befinden

Eingeben von ¢, £, ¥, ® und anderer Zeichen, die sich nicht auf der Tastatur befinden

  1. Zeigen Sie im Windows Startmenü auf Programme, dann auf Zubehör, und klicken Sie anschließend auf Zeichenzuordnung.

    Wenn die Zeichenzuordnung nicht verfügbar ist, finden Sie in der Windows-Hilfe weitere Informationen zum Installieren einer Windows-Komponente.

  2. Wählen Sie im Feld Schriftart die Schrift, die das gewünschte Zeichen enthält.

  3. Klicken Sie in der Zeichenübersicht auf das gewünschte Zeichen.

  4. Klicken Sie auf Auswählen und dann auf Kopieren.

  5. Wechseln Sie zu Ihrer Datenbank, und positionieren Sie die Einfügemarke an die Stelle, an der Sie das Zeichen einfügen möchten.

  6. Klicken Sie auf Einfügen [image] .

  7. Wenn das Zeichen anders als das ausgewählte Zeichen aussieht, markieren Sie es, und weisen Sie ihm dieselbe Schriftart zu, die Sie in der Zeichenzuordnung ausgewählt haben.

Tipp In der Zeichenzuordnung werden die Tastenkombinationen angezeigt, die Sie in Microsoft Access zum Einfügen des ausgewählten Zeichens verwenden können. Zahlen in den Tastenkombinationen geben Sie über die Zehnertastatur ein, nicht über die normale Tastatur.