Info über Navigationsleisten

Um mehr über Navigationsleisten zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Festlegen einer Navigationsstruktur für ein Web

Sie können eine Navigationsstruktur für das aktuelle Web erstellen, indem Sie dessen relevante Seiten in der Navigationsansicht anordnen. Wenn Sie den Seiten in Ihrem Web dann Navigationsleisten hinzufügen, richtet FrontPage jede Navigationsleiste entsprechend dieser Struktur ein. Die Navigationsstruktur bestimmt, welche Hyperlinks in die Navigationsleiste übernommen werden, und mit den Seitentiteln wird die Beschriftung der Hyperlinks festgelegt:

Die Navigationsstruktur bestimmt, welche Hyperlinks in die Navigationsleiste übernommen werden

Die Navigationsansicht zeigt die Struktur Ihres aktuellen Webs, welche zumindest Ihre Homepage umfasst. Führen Sie in der Navigationsansicht einen oder mehrere der folgenden Schritte durch:

  • Wenn Sie der aktuellen Navigationsstruktur eine vorhandene Seite hinzufügen möchten, klicken Sie in der Ordnerliste auf die Seite, und ziehen Sie sie in der Struktur an die gewünschte Position.
  • Wenn Sie in der Navigationsstruktur eine Seite verschieben möchten, klicken Sie auf die Seite, und ziehen Sie diese an eine andere Position, wie beispielsweise unter oder neben eine andere Seite.
  • Um einer Seite einen aussagekräftigen Titel zu geben, klicken Sie mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Umbenennen, und bearbeiten Sie nun den Namen Ihren Wünschen entsprechend.
  • Wenn Sie unterhalb einer vorhandenen Seite eine neue Seite hinzufügen möchten, klicken Sie mit der rechten Maustaste auf die vorhandene Seite, und klicken Sie dann im Kontextmenü auf Neue Seite. Auf diese Weise können Sie beispielsweise eine Seite unterhalb Ihrer Homepage hinzufügen.
  • Um eine externe Seite (eine Seite, die sich nicht in Ihrem Web befindet) hinzuzufügen, klicken Sie mit der rechten Maustaste auf die Seite, der Sie den externen Hyperlink hinzufügen möchten, und geben Sie dann das Ziel des Hyperlinks im Feld URL ein.
  • Zum Löschen einer Seite aus der Navigationsstruktur klicken Sie auf die Seite, und drücken Sie dann die ENTF-TASTE. Klicken Sie auf Diese Seite aus allen Navigationsleisten entfernen.

Tipp Wenn Sie eine Seite zum Bearbeiten öffnen möchten, doppelklicken Sie darauf.

Für weitere Informationen darüber, welchen Einfluss die Navigationsstruktur auf die Navigationsleisten hat, lesen Sie Info über Navigationsleisten.


Hinzufügen einer Navigationsleiste zu einer Seite

Eine Navigationsleiste ist eine Zusammenstellung von Text- oder Schaltflächenhyperlinks, auf die der Sitebesucher klickt, um zu den Seiten Ihrer Website zu gelangen. Eine typische Navigationsleiste könnte Schaltflächen zur Homepage der Site und zu jeder der Hauptseiten der obersten Ebene enthalten. Wenn Sie einer Seite eine Navigationsleiste hinzufügen, erzeugt FrontPage die Navigationshyperlinks basierend auf der von Ihnen in der Navigationsansicht eingerichteten Navigationsstruktur.

Beim Hinzufügen einer FrontPage-Navigationsleiste haben Sie folgende Optionen:

  • Wählen Sie ein vertikales oder horizontales Layout die Ausrichtung der Navigationsleiste, verwenden Sie also beispielsweise eine horizontale Navigationsleiste im Kopf der Seite, und verwenden Sie eine vertikale Navigationsleiste entlang des Seitenrandes.
  • Wählen Sie die Art der Hyperlinks aus, die angezeigt werden sollen, wählen Sie also Text oder Schaltflächen (diese Option sollten Sie nur wählen, wenn Sie ein Design verwenden).
  • Wählen Sie, welche Hyperlinks in der Navigationsleiste angezeigt werden sollen:
    • Hyperlinks zu Seiten der gleichen Ebene wie die aktuelle Seite
    • Hyperlinks zu Seiten, die sich überhalb der aktuellen Seite befinden (übergeordnete Ebene)
    • Hyperlinks zu Seiten, die sich unterhalb der aktuellen Seite befinden (untergeordnete Ebene)
    • Hyperlinks zu den untergeordneten Seiten der Homepage
    • Hyperlinks zu Seiten, die sich auf der obersten Ebene des Webs befinden
    • Hyperlinks für „Zurück“ und „Weiter“, um das folgerichtige Blättern in Seiten der gleichen Ebene zu ermöglichen
    • Einen Hyperlink zur Homepage des Webs oder zur übergeordneten Seite einer Seite

      • Weitere Informationen zu diesen Optionen erhalten Sie, wenn Sie im Hilfethema Info über Navigationsleisten auf Navigationshyperlinks klicken.

Sie können jeder beliebigen Seite Navigationsleisten hinzufügen; wenn Sie jedoch schnell ein Navigationssystem für Ihr Web einrichten möchten, ziehen Sie die Verwendung von gemeinsamen Randbereichen mit Navigationsleisten in Betracht (wechseln Sie zum Hilfethema Info über Navigationleisten, und klicken Sie auf Navigationsleisten in einem gemeinsamen Randbereich).

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der die Navigationsleiste angezeigt werden soll. Klicken Sie beispielsweise in einen gemeinsamen Randbereich, um eine Navigationsleiste in einem gemeinsamen Randbereich zu platzieren.
  2. Klicken Sie im Menü Einfügen auf Navigationsleiste.
  3. Wählen Sie unter Hinzuzufügende Hyperlinks die Art der Hyperlinks aus, die in der Navigationsleiste angezeigt werden sollen.
  4. Geben Sie unter Orientierung an, ob die Navigationsleiste horizontal oder vertikal verlaufen soll und ob Text- oder Schaltflächenhyperlinks angezeigt werden sollen. Sie sollten sich nur dann für Schaltflächen entscheiden, wenn Sie ein Design verwenden.

Die Navigationsleiste wird der Seite hinzugefügt. Wenn dem Web ein Design zugewiesen wurde, werden für Schaltflächennavigationsleisten die zum Design gehörenden Schriftarten, Farben sowie alle weiteren Stilelemente verwendet.

Anmerkung Wenn die auf Ihrem Webserver installierten Servererweiterungen aus FrontPage 97 oder einer früheren Version stammen, stehen möglicherweise keine Navigationsleisten zur Verfügung.


Ändern, welche Seiten in einer Navigationsleiste angezeigt werden

Sie können die Hyperlinks ändern, die in einer Navigationsleiste angezeigt werden. Wenn in Ihrer Navigationsleiste beispielsweise die Schaltflächen für „Zurück“, „Weiter“ und „Homepage“ angezeigt werden, können Sie die Navigationsleiste so ändern, dass stattdessen Schaltflächen für die Seiten der obersten Ebene angezeigt werden.

Sie können in einer Navigationsleiste die folgenden Hyperlinks anzeigen:

  • Hyperlinks zu Seiten der gleichen Ebene wie die aktuelle Seite
  • Hyperlinks zu Seiten, die sich unterhalb der aktuellen Seite befinden (untergeordnete Ebene)
  • Hyperlinks zu Seiten, die sich überhalb der aktuellen Seite befinden (übergeordnete Ebene)
  • Hyperlinks zu den untergeordneten Seiten der Homepage
  • Hyperlinks zu Seiten, die sich auf der obersten Ebene des Webs befinden
  • Hyperlinks für „Zurück“ und „Weiter“, um das folgerichtige Blättern in Seiten der gleichen Ebene zu ermöglichen
  • Einen Hyperlink zur Homepage des Webs oder zur übergeordneten Seite einer Seite
  1. Doppelklicken Sie in der Seitenansicht auf die Navigationsleiste.
  2. Geben Sie unter Hinzuzufügende Hyperlinks die Hyperlinks an, die angezeigt werden sollen.

Anmerkung Wenn Sie eine Navigationsleiste in einem gemeinsamen Randbereich ändern, betreffen Ihre Änderungen alle Seiten, die diesen gemeinsamen Randbereich nutzen.


Herausnehmen einer Seite aus den Navigationsleisten

Wenn Sie Navigationsleisten auf Seiten hinzufügen, nimmt FrontPage, basierend auf der von Ihnen in der Navigationsansicht eingerichteten Navigationsstruktur, die relevanten Seiten in die Navigationsleisten auf. Sie können eine Seite jedoch auch aus den Navigationsleisten herausnehmen. Angenommen, Sie fügen einer Seite eine Navigationsleiste hinzu, die Hyperlinks zu allen Seiten der obersten Ebene Ihres Webs enthält. Wenn Sie nun verhindern möchten, dass Sitebesucher eine bestimmte Seite sehen, nehmen Sie diese aus allen Navigationsleisten heraus.

  1. Klicken Sie in der Navigationsansicht mit der rechten Maustaste auf die Seite, die Sie ausnehmen möchten.
  2. Klicken Sie im Kontextmenü auf In Navigationsleisten eingeschlossen, um das Häkchen zu entfernen.

Anmerkung Alle unterhalb der ausgeschlossenen Seite befindlichen Seiten (also alle untergeordneten Seiten) werden standardmäßig ebenfalls ausgeschlossen. Wenn Sie diese Einstellung ändern möchten, klicken Sie mit der rechten Maustaste auf eine untergeordnete Seite und klicken Sie dann im Kontextmenü auf In Navigationsleisten eingeschlossen, um das Häkchen hinzuzufügen.


Hinzufügen eines externen Hyperlinks zu einer Navigationsleiste

Sie können einer Navigationsleiste auch einen Hyperlink zu einer Seite hinzufügen, die sich nicht in Ihrem Web befindet (einen so genannten externen Hyperlink). Beispielsweise könnte sich in Ihrer Navigationsleiste ein Hyperlink befinden, der auf eine Internetsuchseite wie z. B. Yahoo! oder die Homepage einer anderen Website verweist.

  1. Klicken Sie in der Navigationsansicht mit der rechten Maustaste auf die Seite, auf der Sie den externen Hyperlink hinzufügen möchten, und klicken Sie dann im Kontextmenü auf Externer Hyperlink.
  2. Geben Sie im Feld URL den URL der Zielseite ein, oder führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Hyperlink zu einer Seite in einem anderen Web hinzufügen möchten, wechseln Sie zu dem Web, in dem sich die Zielseite befindet, und wählen Sie diese aus.
    • Wenn Sie einen Hyperlink zu einer Seite im World Wide Web hinzufügen möchten, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers die gewünschte Seite, und drücken Sie dann ALT+TAB, um zu FrontPage zurückzukehren. Die Adresse der Seite, die Sie soeben besucht haben, wird im Feld URL angezeigt.
    • Um einen Hyperlink zu einer Seite in einem Dateisystem hinzuzufügen, klicken Sie auf Datei Schaltfläche "Datei". Suchen Sie die gewünschte Seite in Ihrem lokalen Netzwerk, und markieren Sie die Seite.

Der Hyperlink wird Ihrer Navigationsstruktur hinzugefügt und mit Symbol für externen Hyperlink angezeigt. Sie können die Position des externen Hyperlinks in der Navigationsstruktur ändern, indem Sie darauf klicken und den Hyperlink an die gewünschte neue Position ziehen.


Ändern der Seitenbeschriftungen in einer Navigationsleiste

Wenn Sie einer Seite eine Navigationsleiste hinzufügen, verwendet FrontPage die Seitenbeschriftungen, die in der Navigationsansicht angezeigt werden, als Beschriftungen in der Navigatonsleiste. Sie können den Text, der in einer Navigationsleiste angezeigt wird, ändern, indem Sie in der Navigationsansicht die Seitenbeschriftungen ändern. Wenn Sie beispielsweise den Titel einer Seite geändert haben und die Navigationsleiste entsprechend anpassen möchten, können Sie die Seitenbeschriftung in der Navigationsleiste verändern, indem Sie diese in der Navigationsansicht aktualisieren.

  • Klicken Sie in der Navigationsansicht mit der rechten Maustaste auf die Seite, deren Beschriftung Sie ändern möchten, klicken Sie dann im Kontextmenü auf Umbenennen, und ändern Sie den Namen Ihren Vorstellungen entsprechend.

Anmerkung Wenn Sie eine Navigationsleiste in einem gemeinsamen Randbereich ändern, bezieht sich die Änderung auf alle Seiten, für die der gemeinsame Randbereich genutzt wird.


Ändern der Ausrichtung einer Navigationsleiste

Sie können ändern, ob eine Navigationsleiste horizontal (als Zeile mit Hyperlinks) oder vertikal (als Spalte mit Hyperlinks) angezeigt wird. Beispielsweise wird eine Navigationsleiste in einem gemeinsamen oberen Randbereich mit quer über die Seite verlaufenden Schaltflächen angezeigt. Sie können die Navigationsleiste nun in einen gemeinsamen linken Randbereich verschieben und die Ausrichtung so ändern, dass die Schaltflächen vertikal untereinander angezeigt werden.

  1. Doppelklicken Sie in der Seitenansicht auf die Navigationsleiste.
  2. Geben Sie unter Orientierung und Aussehen die Ausrichtung an, die die Navigationsleiste haben soll.

Anmerkung Wenn Sie eine Navigationsleiste in einem gemeinsamen Randbereich ändern, bezieht sich die Änderung auf alle Seiten, für die der gemeinsame Randbereich genutzt wird.


Anzeigen von Texthyperlinks oder Schaltflächen in einer Navigationsleiste

Sie können die Art der Hyperlinks (Texthyperlinks oder Schaltflächen), die in einer Navigationsleiste angezeigt werden, ändern. Schaltflächen können jedoch nur dann angezeigt werden, wenn Sie ein Design verwenden.

  1. Doppelklicken Sie in der Seitenansicht auf die Navigationsleiste.
  2. Geben Sie unter Orientierung an, ob Schaltflächen oder Texthyperlinks angezeigt werden sollen.

Anmerkung Wenn Sie eine Navigationsleiste in einem gemeinsamen Randbereich ändern, bezieht sich die Änderung auf alle Seiten, für die der gemeinsame Randbereich genutzt wird.


Ändern des Textformats einer Navigationsleiste

Sie können das Textformat einer Navigationsleiste, in der Texthyperlinks verwendet werden, ändern. Beispielsweise können Sie Farbe und Größe der verwendeten Schriftart ändern. Verwenden Sie jedoch Schaltflächen, können Sie das Textformat der Navigationsleiste nur ändern, indem Sie das Design ändern.

  • Klicken Sie in der Seitenansicht auf die Navigationsleiste, und formatieren Sie diese wie jeden anderen Text.

Anmerkung Wenn Sie eine Navigationsleiste in einem gemeinsamen Randbereich ändern, bezieht sich die Änderung auf alle Seiten, für die der gemeinsame Randbereich genutzt wird.


Ändern des Titels einer Datei

Der Titel einer Datei, und nicht der Dateiname, erscheint in den Seitenbannern und Navigationsleisten die Microsoft FrontPage erstellt, ebenso wie in der Titelleiste der meisten Webbrowser. Sie können den Titel einer Datei ändern ohne ihren Namen zu ändern.

  1. Klicken Sie in einer beliebigen Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf die Registerkarte Allgemein.
  2. Geben Sie im Feld Titel den Titel der Datei ein, der in den Seitenbannern und Navigationsleisten erscheinen soll.


Drucken der Navigationsstruktur eines Webs

Sie können die Navigationsstruktur des aktuellen Webs so drucken, wie sie in der Navigationsansicht angezeigt wird.

  1. Klicken Sie in der Navigationsansicht im Menü Datei auf Drucken.
  2. Geben Sie die Druckoptionen wie beispielsweise Name des Druckers und gewünschte Anzahl der Kopien an.

Tipp Wenn Sie prüfen möchten, wie die Navigationsstruktur gedruckt aussieht, klicken Sie im Menü Datei auf Seitenansicht.


Löschen einer Navigationsleiste von einer Seite

Sie können eine Navigationsleiste von einer Seite oder aus dem gemeinsamen Randbereich einer Seite löschen.

  • Klicken Sie in der Seitenansicht auf die Navigationsleiste, und drücken Sie dann die ENTF-TASTE.

Anmerkung Wenn Sie eine Navigationsleiste aus einem gemeinsamen Randbereich löschen, wird die Navigationsleiste auf allen Seiten gelöscht, für die der gemeinsame Randbereich genutzt wird.


Erstellen einer Sitemap nach Kategorien

Viele Websites verwenden Sitemaps, um es für Sitebesucher leichter zu machen, eine gewünschte Seite zu finden. Für ein persönliches Web oder ein anderes, kleines Web kann eine Sitemap einfach aus einer Liste von Hyperlinks zu allen Seiten des Webs bestehen. Sie können diese Art von Sitemap mithilfe der Inhaltsverzeichnis-Komponente erstellen.

Beim Präsenzweb einer Firma oder einem anderen großen Web enthält eine Sitemap in der Regel eine Liste von Hyperlinks auf Kategorien oder anderen logischen Gruppen, die unter logischen Stichwörtern angeordnet sind. Wenn Sie z. B. Anlagen verkaufen, dann könnte Ihre Sitemap Spalten mit Hyperlinks auf kleine Anlagen, große Anlagen und den Kundendienst enthalten. Sie können diese Art von Sitemap mithilfe von Kategorien erstellen. Bevor Sie dieses Verfahren anwenden, sollten Sie die Namen der Kategorien festlegen, die Sie für die Organisation Ihres Webs verwenden möchten.

Erstellen der Kategorien, die Sie für die Sitemap verwenden möchten.

Sie können diesen Schritt überspringen, wenn die auf Ihrer Sitemap zu verwendenden Kategorien bereits zur Liste der zur Verfügung stehenden Kategorien hinzugefügt worden sind.

  1. Klicken Sie in jeder Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf eine beliebige Datei, klicken Sie im Kontextmenü auf Eigenschaften, klicken Sie auf die Registerkarte Arbeitsgruppe, und klicken Sie dann auf Kategorien.
  2. Geben Sie im Feld Neue Kategorie den Namen einer Kategorie ein, die auf der Sitemap angezeigt werden soll, und klicken Sie dann auf Hinzufügen. Wiederholen Sie diesen Schritt für jede Kategorie, die auf der Sitemap angezeigt werden soll.

Kategorisieren der Dateien, die in den Kategorielisten der Sitemap angezeigt werden sollen.

  1. Klicken Sie in jeder Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Dateien, die Sie kategorisieren möchten, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie auf die Registerkarte Arbeitsgruppe
  2. Aktivieren Sie in der Liste Verfügbare Kategorien die Kontrollkästchen der Kategorien, in denen Sie die ausgewählten Datei gruppieren möchten. Sie können mehrere Kategorien auswählen, wodurch eine einzelne Datei in mehreren Kategorien Ihrer Sitemap auftreten kann.

Überprüfen der Dateiliste pro Kategorie der Sitemap.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Kategorien.

    2. Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in dem Bericht aufgenommen. Um Dateien in verborgenen Ordnern in Ihre Bericht mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  2. Der Bericht Kategorien listet alle Dateien in Ihrem Web auf. In der Spalte Kategorie werden ggf. die Kategorien angezeigt, in denen eine betreffende Datei angeordnet worden ist.

    Tipp Um nur die Dateien einer einzelnen Kategorie aufzuführen, klicken Sie auf der Symbolleiste Berichte auf die in der Liste Berichtseinstellungen aufgeführte Kategorie. Um die Symbolleiste Berichte anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Berichte.

Hinzufügen der Kategorienlisten zur Sitemap.

  1. Erstellen oder Öffnen einer Seite für die Sitemap:
    • Um eine neue Seite für die Sitemap zu erstellen, klicken Sie auf Neue Seite Schaltfläche "Neue Seite".
    • Um eine bestehende Seite zu öffnen, zu der die Sitemap hinzugefügt werden soll, klicken Sie auf Öffnen Schaltfläche "Öffnen", und suchen Sie dann nach der Seite, die Sie öffnen möchten.
  2. Bringen Sie in der Seitenansicht Ihrer Sitemap die Einfügemarke an die Stelle, wo Sie die erste Kategorieliste einfügen möchten.
  3. Geben Sie den Namen der Kategorie (z. B. „Kundendienst“) als Überschrift für die Liste von Dateien innerhalb dieser Kategorie ein.

    4. Tipp Um für die Kategorieüberschrift eine Formatierung anzuwenden, klicken Sie im Feld Formatvorlage auf die Formatvorlage für die Überschrift oder einen anderen Absatz, um diese auf den Kategorienamen anzuwenden.

  4. Zeigen Sie im Menü Einfügen auf Komponenten, und klicken Sie dann auf Kategorien.
  5. Aktivieren Sie in der Liste Kategorien, nach denen Dateien aufgelistet werden das Kontrollkästchen für die betreffende Kategorie.
  6. Klicken Sie im Feld Dateien sortieren nach auf Dokumenttitel, um die Liste alphabetisch nach Titel aufzulisten, oder auf Datum der letzten Änderung, um die Liste nach dem Dateidatum zu sortieren.

Wiederholen Sie diese Schritte für jede Kategorieliste, die auf der Sitemap angezeigt werden soll. Sie können die Kategorielisten auf der Sitemap leicht anordnen, wenn Sie diese in Tabellen ablegen.

Anmerkung Die Sitemap wird automatisch aktualisiert, wenn Sie Dateien zu einer Kategorie hinzufügen oder aus einer Kategorie entfernen.


Hinzufügen einer Liste von Dateien aus einer Kategorie zu einer Seite

Sie können mithilfe von Kategorien Ihre Dateien in logische Gruppen einteilen. So könnten Sie z. B. alle Dateien Ihres Webs, die etwas mit Einkauf zu tun haben (wie Katalog- und Produktseiten im Stammweb, Bilder im Ordner images und eine Preisdatenbank in einem anderen Ordner) in Kategorien mit den Bezeichnungen „Katalog“ und „Produkte“ klassifizieren. Außerdem könnten Sie die Produktseiten weiter kategorisieren, wie z. B. in Seiten für „kleine Anlagen“, „große Anlagen“ und „Freiluftanlagen“.

Wenn Sie die Dateien in Ihrem Web kategorisiert haben, können Sie dynamische Kategorielisten zu Ihren Webseiten hinzufügen. So könnten Sie auf einer Einkaufsseite drei Produktlisten unter den Kategorien „Kleine Anlagen“, „Große Anlagen“ und „Freiluftanlagen“ einfügen: Sitebesucher können dann auf ein Produkt in einer Liste klicken, um die Seite für das Produkt aus dem Produktkatalog anzuzeigen. Wenn Sie Produkte zu Ihrem Sortiment hinzufügen oder aus ihm entfernen und die dazugehörigen Produktseiten im Web hinzufügen oder aus ihm entfernen oder Dateien neu kategorisieren, werden die Kategorielisten auf der Einkaufsseite automatisch aktualisiert.

  1. Öffnen Sie in der Seitenansicht die Seite, zu der Sie eine Dateiliste in einer Kategorie hinzufügen möchten. Zeigen Sie im Menü Einfügen auf Komponenten, und klicken Sie dann auf Kategorien.
  2. Aktivieren Sie unter Kategorien, nach denen Dateien aufgelistet werden die Kontrollkästchen der Kategorien, die Sie in die Liste einschließen möchten.
  3. Klicken Sie im Feld Dateien sortieren nach auf Zuletzt geändert am, um die Liste nach dem Dateidatum zu sortieren, oder auf Dokumenttitel, um die Liste alphabetisch nach Titel oder Dateiname zu sortieren.
  4. Wählen Sie zusätzlich zu den Dokumenttiteln weitere Informationen aus, die zur Liste hinzugefügt werden sollen:
    • Um das Datum der letzten Änderung mit einzuschließen, aktivieren Sie das Kontrollkästchen Letztes Änderungsdatum der Datei.
    • Um Kommentare einzuschließen, die den Dateien beigefügt wurden, aktivieren Sie das Kontrollkästchen Zur Datei hinzugefügte Kommentare.

Tipps

  • Wenn Sie mehrere Kategorien aktivieren, werden die Dateien in der Liste nicht nach Kategorie angeordnet: stattdessen werden sie entweder nach dem Datum der letzten Änderung oder nach dem Dokumenttitel sortiert. Um einzelne Listen in verschiedenen Kategorien zu erstellen, aktivieren Sie in Schritt 2 nur eine Kategorie, und wiederholen Sie diese Prozedur, um eine gesonderte Liste für jede Kategorie zu erstellen, die auf der Seite angezeigt werden soll.
  • Sie können mithilfe von Tabellen einfach Spalten mit Kategorielisten auf einer Seite erstellen. Erstellen Sie eine Tabelle mit zwei Zeilen und so vielen Spalten, wie Sie Kategorien haben. Geben Sie den Namen jeder Kategorie in jeder Zelle der Kopfzeile ein, und fügen Sie dann nach diesem Verfahren eine Kategorieliste in jede Zelle der zweiten Tabellenzeile ein.


Erstellen eines Inhaltsverzeichnisses für ein Web

Sie können ein automatisch generiertes Inhaltsverzeichnis auf Basis der Navigationsstruktur Ihres Webs und auf der Basis von Seiten mit Hyperlinks, die nicht in der Navigatiosstruktur enthalten sind, erstellen. Ein Sitebesucher, der Ihr Web durchsucht, kann dann auf jeden Eintrag in der Tabelle klicken, um zu der betreffenden Seite oder Datei zu springen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, wo Sie ein Inhaltsverzeichnis erstellen möchten.

    2. Tipp Sie können das Inhaltsverzeichnis auf einer Seite, die auch noch anderen Inhalt enthält, oder auf einer eigenen Seite erstellen. Wenn Sie ein Inhaltsverzeichnis für ein großes Web erstellen möchten, sollten Sie ggf. eine spezielle Seite erstellen, die nur das Inhaltsverzeichnis enthält.

  2. Zeigen Sie im Menü Einfügen auf Komponenten, und klicken Sie dann auf Inhaltsverzeichnis.
  3. Geben Sie Feld URL der Startseite des Inhaltsverzeichnisses den relativen URL der Seite ein, die als Startpunkt für das Inhaltsverzeichnis verwendet werden soll, oder klicken Sie auf Durchsuchen, um die Seite zu ermitteln.

    4. Tipp Der Startpunkt bestimmt, welche Seiten im Inhaltsverzeichnis am weitesten links stehen. Seiten, auf die durch Hyperlinks auf der Startseite gezeigt wird, werden um eine Stufe im Inhaltsverzeichnis eingerückt.

  4. Wählen Sie im Feld Größe der Überschrift das Absatzformat der Überschrift (des Eintrags auf oberster Ebene, der Startseite) für das Inhaltsverzeichnis aus. Um die Startseite vom Inhaltsverzeichnis auszuschließen, klicken Sie auf Ohne.

    5. Tipp Wenn Sie ein Inhaltsverzeichnis auf derselben Seite wie dem Startpunkt des Verzeichnisses erstellen, dann besteht die Überschrift des Verzeichnisses aus einem Hyperlink auf dieselbe Seite. Wenn Sie z. B. ein Inhaltsverzeichnis auf der Seite Index.htm erstellen, und der Startpunkt dieses Verzeichnisses ist Index.htm (dieselbe Seite), dann besteht die Überschrift des Verzeichnisses aus einem Hyperlink auf Index.htm. Wenn Sie einen derartigen, ringförmigen Hyperlink als Überschrift des Inhaltsverzeichnisses ausschließen möchten, klicken Sie im Feld Schriftgröße der Überschriften auf Ohne.

Anmerkungen

  • Wenn Ihr Web Seiten enthält, auf die von mehreren Hyperlinks gezeigt wird, und Sie jede Seite nur einmal im Inhaltsverzeichnis aufgelistet haben möchten, aktivieren Sie das Kontrollkästchen Jede Seite nur einmal anzeigen.
  • Um Seiten mit einzuschließen, auf die kein Hyperlink in Ihrem Web zeigt, aktivieren Sie das Kontrollkästchen Seiten ohne eintreffende Hyperlinks anzeigen.
  • Um das Inhaltsverzeichnis jedesmal neu zu berechnen, wenn eine Seite in Ihrem Web bearbeitet wird, aktivieren Sie das Feld Inhaltsverzeichnis bei jeder Seitenbearbeitung aktualisieren. Das Neuberechnen eines Inhaltsverzeichnisses für ein großes Web kann ein zeitaufwendiger Prozess sein. Wenn Sie dieses Kontrollkästchen aktivieren, werden Sie möglicherweise feststellen, dass das Speichern von Seiten länger dauert. Falls Sie das Kontrollkästchen nicht aktivieren, können Sie das Inhaltsverzeichnis manuell regenerieren, indem Sie die Seite mit dem Inhaltsverzeichnis öffnen und speichern.
  • Um ein Inhaltsverzeichnis zu erstellen, das nach Kategorien anstelle der Navigationsstruktur organisiert ist, befolgen Sie die Vorgehensweisen zum Kategorisieren einer Datei und Hinzufügen einer Dateiliste aus einer Kategorie zu einer Seite.


Festlegen von Eigenschaften für ein Inhaltsverzeichnis

Sie können ein automatisch auf der Basis der Navigationsstruktur Ihres Webs generiertes Inhaltsverzeichnis erstellen. Ein Sitebesucher, der Ihr Web durchsucht, kann auf jeden Eintrag in der Tabelle klicken, um zu der betreffenden Seite oder Datei zu springen. Mit dem nachfolgenden Verfahren können Sie das Inhaltsverzeichnis formatieren, z. B. die Schriftgröße der Überschrift ändern oder das Inhaltsverzeichnis automatisch aktualisieren, wenn eine Webseite bearbeitet wird. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Inhaltsverzeichnis, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Inhaltsverzeichniseigenschaften.

  • Geben Sie im Feld URL der Startseite des Inhaltsverzeichnisses den relativen URL der Seite ein, die als Startpunkt für das Inhaltsverzeichnis verwendet werden soll, oder klicken Sie auf Durchsuchen, um die Seite zu ermitteln.

    • Tipp Der Startpunkt bestimmt, welche Seiten im Inhaltsverzeichnis am weitesten links stehen. Seiten, auf die durch Hyperlinks der Startseite gezeigt wird, werden um eine Ebene im Inhaltsverzeichnis eingerückt.

  • Wählen Sie im Feld Schriftgröße der Überschriften das Absatzformat der Überschrift (des Eintrags auf oberster Ebene, d. h. der Startseite) des Inhaltsverzeichnisses aus. Um die Startseite aus dem Inhaltsverzeichnis auszuschließen, klicken Sie auf Ohne.

    • Tipp Wenn Sie ein Inhaltsverzeichnis auf derselben Seite wie dem Startpunkt der Tabelle erstellen, dann besteht die Tabellenüberschrift aus einem Hyperlink auf dieselbe Seite. Wenn Sie z. B. ein Inhaltsverzeichnis auf der Seite Index.htm erstellen, und der Startpunkt dieser Tabelle ist Index.htm (dieselbe Seite), dann besteht die Tabellenüberschrift aus einem Hyperlink auf Index.htm. Wenn Sie einen derartigen ringförmigen Hyperlink als Überschrift des Inhaltsverzeichnisses vermeiden möchten, dann klicken Sie im Feld Schriftgröße der Überschriften auf Ohne

  • Aktivieren Sie das Kontrollkästchen Jede Seite nur einmal anzeigen, wenn Ihr Web Seiten enthält, auf die durch mehrere Hyperlinks verwiesen wird, und Sie derartige Seiten im Inhaltsverzeichnis jeweils nur einmal auflisten möchten.
  • Um Seiten mit einzuschließen, auf die keine Hyperlinks in Ihrem Web verweisen, aktivieren Sie das Kontrollkästchen Seiten ohne eintreffende Hyperlinks anzeigen.

Tipp Um das Inhaltsverzeichnis automatisch neu zu berechnen, wenn eine Seite in Ihrem Web bearbeitet wird, aktivieren Sie das Kontrollkästchen Inhaltsverzeichnis bei jeder Seitenbearbeitung aktualisieren. Das Neuberechnen eines Inhaltsverzeichnisses für ein großes Web kann ein zeitaufwendiger Prozess sein. Wenn Sie dieses Kontrollkästchen aktivieren, werden Sie möglicherweise feststellen, dass es länger dauert, Seiten zu speichern. Wenn Sie dieses Kontrollkästchen nicht aktualisieren, können Sie das Inhaltsverzeichnis auch regenerieren, indem Sie die Seite mit dem Inhaltsverzeichnis öffnen und speichern.


Neuerstellen eines Inhaltsverzeichnisses, wenn eine Seite bearbeitet wird

Sie können ein automatisch auf der Basis der Navigationsstruktur Ihres Webs generiertes Inhaltsverzeichnisses erstellen. Ein Sitebesucher, der Ihr Web durchsucht, kann auf jeden Eintrag der Tabelle klicken, um zu der betreffenden Seite oder Datei zu springen. Mit dem nachfolgenden Verfahren können Sie das Inhaltsverzeichnis automatisch neu berechnen, wenn irgendeine Seite in Ihrem Web bearbeitet wird.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Inhaltsverzeichnis, das Sie ändern möchten, und klicken Sie dann auf Inhaltsverzeichniseigenschaften.
  2. Aktivieren Sie das Kontrollkästchen Inhaltsverzeichnis bei jeder Seitenbearbeitung aktualisieren.

Anmerkung Das Neuberechnen eines Inhaltsverzeichnisses für ein großes Web kann ein zeitaufwendiger Prozess sein. Wenn Sie dieses Kontrollkästchen aktivieren, werden Sie möglicherweise feststellen, dass es länger dauert, Seiten zu speichern. Wenn Sie dieses Kontrollkästchen nicht aktualisieren, können Sie das Inhaltsverzeichnis manuell regenerieren, indem Sie die Seite mit dem Inhaltsverzeichnis öffnen und wieder speichern.


Speichern von Änderungen in der Navigationsansicht

Wenn Sie in der Navigationsansicht Änderungen an der Navigationsstruktur vornehmen, z. B. durch Hinzufügen oder Löschen einer Seite in der Struktur oder durch Erstellen einer neuen Seite, dann werden diese Änderungen automatisch gespeichert, wenn Sie zu einer anderen Ansicht als die Seitenansicht wechseln. Sie können jedoch Änderungen zu jeder Zeit speichern, um keine geleistete Arbeit zu verlieren.

  • Um Änderungen ohne Wechsel zu einer anderen Ansicht zu speichern, klicken Sie mit der rechten Maustaste auf den Hintergrund der Ansicht, und klicken Sie dann im Kontextmenü auf Änderungen übernehmen.


Info über Hyperlinks

Um mehr über Hyperlinks zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Erstellen eines Hyperlinks zu einer Seite oder einer Datei in einem Web

Sie können einen Hyperlink zu einem Ziel wie beispielsweise einer Seite oder einer Datei in einem Web erstellen. Wenn der Sitebesucher auf den Hyperlink klickt, wird das Ziel in seinem Webbrowser angezeigt. Beispielsweise können Sie Hyperlinks von Ihrer Homepage zu anderen Seiten im Web erstellen. Ebenso können Sie einen Hyperlink zu einem GIF-Bild erstellen.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen. Geben Sie beispielsweise „Meine Hobbies“ ein, und markieren Sie den Satz, um die Verknüpfung zu der Seite herzustellen, auf der Sie Ihre Hobbies beschreiben.

    2. Wenn Sie den Titel der Zielseite (z. B. Homepage) oder die Adresse der Datei (z. B. http://lokalerHost/DateiName) als Text des Hyperlinks verwenden möchten, positionieren Sie die Einfügemarke an der Stelle, an der Sie den Hyperlink einfügen möchten.

  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Wechseln Sie zu dem Web, in dem sich die Zielseite oder die Datei befindet, und markieren Sie die Seite oder die Datei.

Tipp Befindet sich die Zielseite oder -datei im aktuellen Web, klicken Sie in der Ordnerliste auf die Seite oder die Datei, und ziehen Sie diese dann auf die offene Seite, auf der der Hyperlink erstellt werden soll.


Erstellen eines Hyperlinks zu einer Seite oder einer Datei im World Wide Web

Sie können einen Hyperlink zu einer Seite oder einer Datei im World Wide Web erstellen. Wenn der Sitebesucher auf den Hyperlink klickt, wird die Zielseite oder -datei angezeigt. Beispielsweise können Sie einen Hyperlink zu einer Seite oder einem Bild in einer anderen Website erstellen.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen. Geben Sie beispielsweise „Homepage von Microsoft“ ein, und markieren Sie Ihre Eingabe.

    2. Wenn Sie den Titel der Zielseite (z. B. „Willkommen auf der Homepage der Microsoft GmbH“) oder die Adresse der Datei (z. B. http://www.microsoft.com/DateiName) als Hyperlinktext verwenden möchten, positionieren Sie die Einfügemarke an der Stelle, an der der Hyperlink eingefügt werden soll.

  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Klicken Sie auf World Wide Web Schaltfläche "World Wide Web".
  4. Suchen Sie mithilfe Ihres Webbrowsers die gewünschte Seite, und drücken Sie dann ALT+TAB, um zu Microsoft FrontPage zurückzukehren. Die Adresse der Seite, die Sie soeben besucht haben, wird nun im Feld URL angezeigt.


Erstellen eines Hyperlinks zu einer Seite oder einer Datei in einem Dateisystem

Sie können einen Hyperlink zu einer Seite oder einer Datei in einem Dateisystem erstellen. Wenn der Sitebesucher auf den Hyperlink klickt, wird die Zielseite oder -datei angezeigt. Beispielsweise können Sie einen Hyperlink zu einer Seite in einem Netzwerk erstellen.

Anmerkung Das Ziel des Hyperlinks sollte sich an einer Speicherposition befinden, die für alle Sitebesucher zugänglich ist, also beispielsweise auf einem Netzlaufwerk. Wenn Sie einen Hyperlink zu einer Seite oder einer Datei erstellen möchten, die sich auf Ihrem lokalen Laufwerk befindet, geben Sie einen UNC-Pfad (wie \\Computername\Share\Datei.htm) anstelle eines lokalen Pfades (wie C:\Share\Datei.htm) an. Andernfalls sucht, wenn der Sitebesucher auf den Hyperlink klickt, sein Webbrowser auf Laufwerk C:\ des Sitebesuchers nach der Datei und gibt höchstwahrscheinlich einen Fehler zurück.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen; geben Sie beispielsweise „Meine Hobbies“ ein, und markieren Sie die Eingabe.

    2. Wenn Sie die Adresse des Ziels als Hyperlinktext verwenden möchten (wie file://Computername/Share/Dateiname), positionieren Sie die Einfügemarke an der Stelle, an der der Hyperlink eingefügt werden soll.

  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Klicken Sie auf Datei Schaltfläche "Datei".
  4. Suchen Sie in Ihrem lokalen Netzwerk die Seite oder die Datei, die Sie verwenden möchten, und markieren Sie diese anschließend.


Erstellen eines Hyperlinks zu einer neuen Seite

Sie können einen Hyperlink zu einer Seite in einem Web oder einem Dateisystem erstellen. Wenn Sie diese Seite bisher noch nicht erstellt haben, können Sie sie zusammen mit dem Hyperlink hierzu erstellen. Wenn der Sitebesucher auf einen Hyperlink klickt, wird die Zielseite angezeigt. Beispielsweise können Sie Hyperlinks von Ihrer Homepage zu anderen Seiten im Web erstellen.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen. Geben Sie beispielsweise „Meine Hobbies“ ein, und markieren Sie den Satz, um die Verknüpfung zu der Seite herzustellen, auf der Ihre Hobbies beschrieben werden sollen.
  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Klicken Sie auf Neue Seite Schaltfläche "Neue Seite".
  4. Klicken Sie auf die Dokumentvorlage, die Sie bei der Erstellung der neuen Seite zu Grunde legen möchten.
  5. Führen Sie einen der folgenden Schritte durch:
    • Um die neue Seite sofort zu bearbeiten, klicken Sie auf OK.

      • FrontPage erstellt den Hyperlink und zeigt die neue Seite an, die Sie dann bearbeiten können. Der neu erstellte Hyperlink funktioniert erst, wenn Sie die neue Seite gespeichert haben.

    • Wenn Sie eine Aufgabe erstellen und auf diese Weise daran erinnert werden möchten, dass Sie die neue Seite zu einem späteren Zeitpunkt noch fertig stellen müssen, klicken Sie auf Nur eine Aufgabe hinzufügen, und klicken Sie dann auf OK.

      • Sie werden aufgefordert, die neue Seite zu speichern, und der Standardseitentitel und -dateiname werden angezeigt.

      • Wenn Sie den Seitentitel ändern möchten, klicken Sie auf Ändern, geben Sie den neuen Seitentitel ein, und klicken Sie dann auf OK.
      • Wenn Sie den Dateinamen ändern möchten, überschreiben Sie den Standarddateinamen im Feld Dateiname.
      • Klicken Sie auf Speichern. Sie können die Aufgabe der Bearbeitung dieser Seite jederzeit in der Aufgabenansicht zu Ende führen.


Erstellen eines Hyperlinks zu einem Office-Dokument

Sie können einen Hyperlink zu einem Microsoft Office-Dokument erstellen, einem Dokument also, das beispielsweise in Word, Excel oder PowerPoint erstellt wurde. Wenn der Sitebesucher auf den Hyperlink klickt, öffnet dessen Webbrowser die entsprechende Anwendung oder den entsprechenden Viewer und zeigt so das Dokument an. Bei einigen Webbrowsern wird das Dokument im Browserfenster angezeigt, einige öffnen hierfür ein separates Fenster.

Anmerkung Bevor Sie einen Hyperlink zu einer PowerPoint-Animation erstellen, müssen Sie das ActiveX-Steuerelement für Microsoft PowerPoint-Animationen hinzufügen, das zusammen mit PowerPoint installiert wird (siehe Hinzufügen eines ActiveX-Steuerelements).

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen. Geben Sie beispielsweise „Arbeitsblatt Budget“ ein, und markieren Sie die Eingabe.
  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn sich das Office-Dokument im aktuellen Web befindet, suchen Sie das Dokument, und markieren Sie es.
    • Befindet sich das Office-Dokument im lokalen Dateisystem, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie das Dokument, und markieren Sie es.

    Tipp Wenn sich das Office-Dokument im aktuellen Web befindet, klicken Sie in der Ordnerliste darauf, und ziehen Sie es dann auf die offene Seite, auf der der Hyperlink erstellt werden soll.


Erstellen einer Textmarke

Eine Textmarke ist eine Adresse oder ein ausgewählter Text auf einer Seite, den Sie markiert haben.

Sie können Textmarken als Ziel für einen Hyperlink verwenden. Wenn Sie den Sitebesucher beispielsweise auf einen bestimmten Absatz auf einer Seite verweisen möchten, fügen Sie einen Hyperlink mit einer Textmarke als Ziel hinzu. Wenn der Sitebesucher nun auf den Hyperlink klickt, wird der entsprechende Abschnitt der Seite anstelle des Seitenanfangs angezeigt.

Sie können auch eine oder mehrere Textmarken verwenden, um bestimmte Positionen auf einer Seite zu finden. Beispielsweise können Sie jeder Hauptüberschrift einer Seite eine Textmarke hinzufügen. Beim Bearbeiten der Seite können Sie nun schnell jeden Abschnitt finden, indem Sie sich zu der entsprechenden Textmarke bewegen.

Wenn eine Adresse (anstelle von Text) mit einer Textmarke versehen ist, wird die Textmarke mit einem Textmarkensymbol gekennzeichnet. Ist Text mit einer Textmarke versehen, wird dieser Text mit einer gestrichelten Linie angezeigt.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der Sie eine Textmarke erstellen möchten, oder markieren Sie den Text, dem Sie eine Textmarke zuweisen möchten.
  2. Klicken Sie im Menü Einfügen auf Textmarke.
  3. Geben Sie im Feld Name der Textmarke einen Namen für die Textmarke ein (Leerzeichen sind zulässig).


Erstellen eines Hyperlinks zu einer Textmarke

Eine Textmarke ist eine Adresse oder ausgewählter Text auf einer Seite, die bzw. den Sie gekennzeichnet haben. Sie können einen Hyperlink zu einer Textmarke erstellen, wenn Sie den Sitebesucher auf einen bestimmten Abschnitt einer Seite verweisen möchten. Wenn der Sitebesucher nun auf den Hyperlink klickt, wird der entsprechende Abschnitt der Seite anstelle des Seitenanfangs angezeigt.

Sie können Textmarken auch verwenden, um sich beispielsweise auf einer langen Seite zu bewegen, die fünf Überschriften enthält. Erstellen Sie für jede Überschrift eine Textmarke, und fügen Sie dann am Kopf der Seite ein Inhaltsverzeichnis ein, in dem diese Überschriften aufgeführt werden. Jeder Eintrag im Inhaltsverzeichnis ist ein Hyperlink, der eine mit einer Textmarke versehene Überschrift als Ziel hat.

Ein Hyperlink zu einer Textmarke, die auch als Anker bezeichnet wird, wird von einem Nummernzeichen (#) gekennzeichnet, das dem Ziel-URL vorangestellt wird.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen.

    2. Wenn Sie den Namen einer Textmarke als Hyperlinktext verwenden möchten, positionieren Sie die Einfügemarke an der Stelle, an der der Hyperlink eingefügt werden soll.

  2. Klicken Sie auf Hyperlink Schaltfläche "Hyperlink".
  3. Wählen Sie die Seite aus, die die Textmarke enthält.
  4. Klicken Sie im Feld Textmarke auf die Textmarke, die Sie als Ziel des Hyperlinks verwenden möchten.


Erstellen eines Hyperlinks zum Senden einer E-Mail

Sie können einen Hyperlink erstellen, mit dem eine E-Mail-Nachricht geöffnet und an die Adresse gerichtet wird, die Sie angeben. Wenn Sie beispielsweise Rückmeldungen von Ihren Sitebesuchern erhalten möchten, können Sie einen Hyperlink erstellen, mit dem eine E-Mail-Nachricht erstellt wird, die an Ihren E-Mail-Alias gerichtet ist.

Anmerkung Hyperlinks zu E-Mail-Adressen werden nicht von allen Webbrowsern unterstützt.

  1. Geben Sie in der Seitenansicht den Text ein, den Sie als Hyperlink verwenden möchten, und markieren Sie diesen; geben Sie beispielsweise „Senden Sie mir eine E-Mail“ ein, und markieren Sie die Eingabe.

    2. Wenn Sie stattdessen mailto:Adresse als Text des Hyperlinks verwenden möchten, positionieren Sie die Einfügemarke an der Stelle, an der der Hyperlink eingefügt werden soll.

  2. Klicken Sie auf die Schaltfläche Hyperlink Schaltfläche "Hyperlink".
  3. Klicken Sie auf die Schaltfläche E-Mail Schaltfläche "E-Mail".
  4. Geben Sie die E-Mail-Adresse ein, an die die Nachricht gesendet werden soll.


Prüfen des Ziels eines Hyperlinks

Beim Bearbeiten einer Seite können Sie einem Hyperlink folgen, um die Zielseite oder -datei zu öffnen. Nachdem Sie beispielsweise einen Hyperlink erstellt haben, folgen Sie diesem, um zu prüfen, ob er zum gewünschten Ziel führt.

Microsoft FrontPage verwendet abhängig vom Ziel unterschiedliche Verfahren, um einem Hyperlink zu folgen:

  • Handelt es sich bei dem Ziel um eine Seite, öffnet FrontPage die Seite zwecks Bearbeitung in der Seitenansicht.
  • Handelt es sich bei dem Ziel um eine Textmarke, öffnet FrontPage die Seite und führt einen Bildlauf zur Textmarke durch.
  • Handelt es sich bei dem Ziel um eine Datei, öffnet FrontPage die Datei im hiermit verbundenen Editor. Eine Textdatei öffnet FrontPage beispielsweise in Notepad.
  • Befindet sich das Ziel nicht im aktuellen Web, öffnet FrontPage eine Kopie der Zielseite oder -datei.

Klicken Sie in der Seitenansicht mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann im Kontextmenü auf Hyperlink folgen.

Tipps

  • Drücken und halten Sie die STRG-TASTE, und klicken Sie dann auf den Hyperlink, um diesem zu folgen.
  • Wenn Sie einem Hyperlink auf eine andere Seite gefolgt sind, klicken Sie auf Zurück Schaltfläche "Zurück", um zur Ausgangsseite zurückzukehren.


Wechseln zu einer Textmarke auf einer Seite

Sie können zu einer Textmarke wechseln, die Sie einer Seite hinzufügt haben. Wenn Sie beispielsweise jeder Abschnittsüberschrift auf einer langen Seite eine Textmarke hinzugefügt haben und nun einen bestimmten Abschnitt bearbeiten möchten, wechseln Sie zu der entsprechenden Textmarke.

  1. Klicken Sie in der Seitenansicht im Menü Einfügen auf Textmarke.
  2. Klicken Sie im Feld Weitere Textmarken auf dieser Seite auf die Textmarke, die Sie finden möchten.
  3. Klicken Sie auf Gehe zu.


Bearbeiten eines Hyperlinks

Sie können einen Hyperlink bearbeiten. Beispielsweise können Sie den Text von Klicken Sie hierauf, um eine Grafik anzuzeigen in Schauen Sie sich meine Lieblingsgrafik an ändern. Oder Sie können das Ziel eines Hyperlinks ändern (also die Seite oder die Datei, die angezeigt wird, wenn auf den Hyperlink geklickt wurde).

  • Führen Sie in der Seitenansicht einen der folgenden Schritte durch:
    • Wenn Sie den Text des Hyperlinks ändern möchten, markieren Sie den Text, und bearbeiten Sie ihn dann.
    • Wenn Sie das Ziel eines Hyperlinks ändern möchten, markieren Sie den Hyperlink, klicken Sie auf Hyperlink Schaltfläche "Hyperlink", und geben Sie dann einen anderen URL als Ziel an.


Festlegen der Farben für Hyperlinks

Sie können die Farben auswählen, die in einem Webbrowser für die Anzeige von Hyperlinks verwendet werden. Für einen Hyperlink können drei verschiedene Farben ausgewählt werden, die jeweils von dessen Status abhängig sind:

  • Hyperlink: ein Hyperlink, der noch nicht besucht wurde.
  • Aktiver Hyperlink: der Hyperlink, der aktuell gewählt wurde.
  • Besuchter Hyperlink: ein Hyperlink, dessen Ziel bereits gesichtet wurde.

Ob das Ziel eines Hyperlinks bereits gesichtet wurde, bestimmen Webbrowser anhand einer vorgegebenen Zeitdauer. In Microsoft Internet Explorer wird diese Zeitdauer beispielsweise vom Ordner „Verlauf“ vorgegeben; Sie geben an, wie lange die von Ihnen besuchten Seiten im Ordner Verlauf aufbewahrt werden sollen, also beispielsweise 20 Tage. Wenn Sie die Seite nun innerhalb von 20 Tagen erneut besuchen, wird der Hyperlink anhand seines Status als besuchter Hyperlink angezeigt. Wenn Sie die Seite nicht innerhalb von 20 Tagen erneut besuchen oder wenn Sie den Ordner Verlauf leeren, lautet der Status des Hyperlinks wieder auf Hyperlink.

Anmerkung Wenn für die Seite ein spezielles Design verwendet wurde, legen Sie die Hyperlinkfarben fest, indem Sie die Farben ändern, die in einem Design verwendet werden.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Hintergrund.
  2. Wählen Sie in den Feldern Hyperlink, Besuchter Hyperlink und Aktiver Hyperlink die Farben aus, die Sie verwenden möchten.


Hinzufügen von Schrifteffekten zu einem Hyperlink

Sie können einem Hyperlink Effekte hinzufügen, so dass sich die Schriftart ändert, wenn der Sitebesucher seinen Mauszeiger über den Hyperlink bewegt. Beispielsweise können Sie festlegen, dass sich die Schriftart des Hyperlinks in eine größere, eine fett oder rot formatierte Schrift ändert. Bewegen Sie Ihren Mauszeiger über diesen Hyperlink, um zu sehen, wie sich dessen Aussehen ändert. Diese Effekte werden für die gesamte Seite und nicht für einzelne Hyperlinks festgelegt.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Hintergrund.
  2. Aktivieren Sie unter Formatierung das Kontrollkästchen Hyperlink-Rollovereffekte aktivieren.
  3. Klicken Sie auf Rolloverformat.
  4. Legen Sie die Zeicheneigenschaften für die Hyperlinks auf der aktuellen Seite fest.

Anmerkungen

  • Sie können einem Hyperlink keine Effekte zuweisen, wenn die Seite basierend auf einem Design erstellt wurde.
  • Diese Funktion wird nicht von allen Webbrowsern unterstützt.


Löschen eines Hyperlinks

Sie können einen Hyperlink von einer Seite löschen.

  1. Markieren Sie den Hyperlink in der Seitenansicht.
  2. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie den Hyperlink vollständig, d. h. einschließlich des Hyperlinktextes löschen möchten, drücken Sie die ENTF-TASTE.
    • Wenn Sie den Hyperlinktext beibehalten, den hiermit verbundenen Hyperlink jedoch löschen möchten, markieren Sie den Hyperlink, und klicken Sie dann auf Hyperlink Schaltfläche "Hyperlink". Markieren Sie den Inhalt des Feldes URL, und drücken Sie dann die ENTF-TASTE.


Löschen einer Textmarke

Sie können eine Textmarke löschen.

  1. Klicken Sie in der Seitenansicht im Menü Einfügen auf Textmarke.
  2. Klicken Sie im Feld Weitere Textmarken auf dieser Seite auf die Textmarke, die Sie löschen möchten.
  3. Klicken Sie auf Gehe zu.
  4. Klicken Sie auf Löschen.


Hinzufügen eines Hotspots zu einer Grafik

Sie können Grafiken wie beispielsweise Bildern und animierten GIFs Hotspots hinzufügen. Ein Hotspot ist ein unsichtbarer Bereich auf einer Grafik, dem ein Hyperlink zugewiesen wurde. Wenn der Sitebesucher auf diesen Bereich klickt, wird das Ziel des Hyperlinks in dessen Webbrowser angezeigt. In Microsoft FrontPage können Hotspots die Form eines Rechtecks, eines Kreises oder eines Vielecks erhalten.

Eine Grafik mit einem oder mehreren Hotspots wird als Imagemap bezeichnet. In einem Imagemap befinden sich normalerweise Hinweise auf die Stellen, auf die der Besucher klicken kann. So könnte beispielsweise ein Autohersteller auf seiner Website seine neuesten Fahrzeugmodelle als Imagemap verwenden: wenn ein Sitebesucher auf ein Modell klickt, wird eine Seite mit einer detaillierten Beschreibung des Fahrzeugs angezeigt.

Beispiel für ein Imagemap

  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der SymbolleisteGrafik auf die Schaltfläche Hotspot, die der gewünschten Hotspotform entspricht:
    • Rechteckiger Hotspot Schaltfläche "Rechteckiger Hotspot"
    • Runder Hotspot Schaltfläche "Runder Hotspot"
    • Polygonförmiger Hotspot Schaltfläche "Polygonförmiger Hotspot"
  3. Ziehen Sie auf der Grafik ein Rechteck, einen Kreis oder ein Vieleck, abhängig von der gewählten Form. Um ein Vieleck zu zeichnen, klicken Sie auf die Position, an der sich die erste Ecke des Vielecks befinden soll, klicken Sie dann auf alle weiteren Positionen, an denen sich Ecken befinden sollen, und doppelklicken Sie schließlich, um das Vieleck fertig zu stellen.

    4. Wenn Sie die Maustaste loslassen, öffnet sich das Dialogfeld Hyperlink erstellen.

  4. Geben Sie das Ziel des Hyperlinks an:
    • Befindet sich das Ziel in einem Web, wechseln Sie zu dem Web und dem Ordner, in dem sich die Seite befindet, markieren Sie diese, und klicken Sie dann auf OK.
    • Wenn sich das Ziel in Ihrem lokalen Netzwerk befindet, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie die gewünschte Seite in Ihrem lokalen Netzwerk, und klicken Sie auf OK.
    • Handelt es sich um ein Ziel im World Wide Web, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers die gewünschte Seite, und drücken Sie dann ALT+TAB, um zu Microsoft FrontPage zurückzukehren. Die Adresse der Seite, die Sie besucht haben, wird nun im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn Sie möchten, dass eine E-Mail erstellt wird, wenn ein Sitebesucher auf die Grafik klickt, klicken Sie auf E-Mail Schaltfläche "E-Mail". Geben Sie die E-Mail-Adresse ein, an die die Nachricht gesendet werden soll, und klicken Sie auf OK.


Hinzufügen eines Texthotspots zu einer Grafik

Sie können Grafiken wie beispielsweise Bildern, animierten GIFs und Videoclips Texthotspots hinzufügen. Ein Texthotspot ist eine Textzeichenfolge, die Sie auf einer Grafik platziert und der Sie einen Hyperlink zugewiesen haben. Wenn der Sitebesucher auf den Text klickt, wird das Ziel des Hyperlinks in dessen Webbrowser angezeigt.

  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der SymbolleisteGrafik auf Text Schaltfläche "Text".
  3. Geben Sie in dem Textfeld, das nun auf der Grafik angezeigt wird, den gewünschten Text ein.

    4. Sie können:

    • die Größe des Textfeldes ändern, indem Sie auf die Ziehpunkte klicken und das Textfeld auf die gewünschte Größe ziehen.
    • das Textfeld verschieben, indem Sie auf dessen Rand klicken und das Textfeld an die gewünschte Position ziehen.
  4. Zum Festlegen eines Hyperlinks für den Text doppelklicken Sie auf eine Ecke des Textfeldes.
  5. Geben Sie das Ziel des Hotspots an:
    • Befindet sich das Ziel in einem Web, wechseln Sie zu dem Web und dem Ordner, im den sich die Seite befindet, markieren Sie diese, und klicken Sie dann auf OK.
    • Wenn sich das Ziel in Ihrem lokalen Netzwerk befindet, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie die gewünschte Seite in Ihrem lokalen Netzwerk, und klicken Sie auf OK.
    • Handelt es sich um ein Ziel im World Wide Web, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers die gewünschte Seite, und drücken Sie dann ALT+TAB, um zu Microsoft FrontPage zurückzukehren. Die Adresse der Seite, die Sie besucht haben, wird nun im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn Sie möchten, dass eine E-Mail erstellt wird, wenn ein Sitebesucher auf die Grafik klickt, klicken Sie auf E-Mail Schaltfläche "E-Mail". Geben Sie die E-Mail-Adresse ein, an die die Nachricht gesendet werden soll, und klicken Sie auf OK.


Markieren der Hotspots auf einer Grafik

Sie können Hotspots auf einer Grafik hervorheben, wenn die Umrisse der Hotspots, die die Grafik überlagern, beispielsweise schwierig zu erkennen sind.

  1. Klicken Sie in der Seitenansicht auf die Grafik.
  2. Klicken Sie auf der SymbolleisteGrafik auf Hotspots markieren Schaltfläche "Hotspots markieren". Klicken Sie erneut auf diese Schaltfläche, um die Grafik ohne Markierung anzuzeigen.


Bearbeiten, Verschieben, Löschen oder Ändern der Größe eines Hotspots auf einer Grafik

Sie können den URL eines Hotspots bearbeiten, oder Sie können den Hotspot verschieben, löschen oder dessen Größe ändern.

  1. Klicken Sie in der Seitenansicht auf die Grafik, um die Hotspots anzuzeigen.
  2. Klicken Sie auf einen Hotspot.
    • Wenn Sie den URL eines Hotspots bearbeiten möchten, doppelklicken Sie auf den Hotspot.
    • Zum Verschieben des Hotspots klicken Sie darauf und ziehen ihn dann an die gewünschte Position.
    • Um die Größe des Hotspots zu ändern, klicken Sie auf die Auswahlziehpunkte, und ziehen Sie den Hotspot hiermit auf die gewünschte Größe. Hierzu können Sie auch die Pfeiltasten verwenden.
    • Wenn Sie den Hotspot löschen möchten, drücken Sie die ENTF-TASTE.

Tipp Beim Verschieben eines Hotspots können Sie diesen an seine ursprüngliche Position zurücksetzen, indem Sie ESC drücken, während der Hotspot noch markiert ist.


Organisieren eines Intranets durch Unterwebs

Um mehr über das Organisieren eines Intranets zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Erstellen eines Webs

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Web.
  2. Wählen Sie in der Liste Websites die Vorlage oder den Assistenten aus, die oder den Sie für die Erstellung des neuen Webs verwenden möchten.
  3. Geben Sie im Feld Adresse des neuen Webs angeben den Namen des neuen Webs ein, oder wählen Sie einen aus.
  4. Wenn Sie Secure Sockets Layer (SSL) zur Absicherung von Transaktionen mit Ihrem neuen Web verwenden möchten, aktivieren Sie das Kontrollkästchen Sichere Verbindung notwendig (SSL).

Anmerkungen

  • Sie können ein neues Web auch durch Importieren eines bestehenden Webs von einem lokalen Computer, aus einem Netzwerk oder aus dem World Wide Web, oder durch Umwandeln eines Ordners in ein Web erstellen.
  • Das Verfahren zum Erstellen eines untergeordneten Webs ist das gleiche wie zum Erstellen eines Webs.


Importieren eines Webs

Sie können ein Quellverzeichnis mit Dateien von Ihrem lokalen Computer oder Netzwerk importieren. Sie können ebenfalls ein Web von einem Webserver auf Ihrem Computer, von einem Netzwerkserver oder aus dem World Wide Web importieren.

  1. Klicken Sie im Menü Datei auf Importieren.
    • Wenn Sie keine Webs in FrontPage geöffnet haben, wird das Dialogfeld Neu angezeigt, bei dem in der Liste Websites der Eintrag Webimport-Assistent markiert ist. Geben Sie im Feld Geben Sie den Standort des neuen Webs an den Namen des neuen Webs ein, das aus dem importierten Quellverzeichnis oder Web erstellt werden soll, und klicken Sie dann auf OK.
    • Wenn Sie gerade ein Web in FrontPage bearbeiten, wird das Dialogfeld Importieren angezeigt. Klicken Sie auf die Schaltfläche Aus einem Web.

    Der erste Bildschirm des Webimport-Assistenten wird angezeigt.

  2. Wählen Sie das Web aus, das Sie importieren möchten:
    • Um ein Quellverzeichnis mit Dateien von Ihrem lokalen Computer oder Netzwerk zu importieren, klicken Sie auf Von einem Quellordner mit Dateien auf einem lokalen Computer oder einem Netzwerk, und geben Sie dann im Feld Adresse den Pfad zum Verzeichnis ein. Oder klicken Sie auf Durchsuchen, um das Verzeichnis zu finden, und klicken Sie dann auf OK.

      • Tipp Wenn Sie das gesamte Verzeichnis einschließlich Unterordner und Unterwebs importieren möchten, aktivieren Sie das Kontrollkästchen Unterordner einschließen.

    • Um ein Web von einem Webserver zu importieren, klicken Sie auf Von einer Site im World Wide Web, und geben Sie dann im Feld Adresse den vollständigen URL der Startseite ein, die Sie importieren möchten. Die Startseite kann jede beliebige Seite im Web sein, nicht nur die Homepage.

      • Tipp Wenn Sie ein Web importieren möchten, das Secure Sockets Layer (SSL) für abgesicherte Transaktionen verwendet, aktivieren Sie das Kontrollkästchen Sichere Verbindung ist notwendig (SSL).

  3. Klicken Sie auf Weiter.

    4. Der zweite Bildschirm des Webimport-Assistenten wird angezeigt. Er hat je nach der in Schritt 2 gewählten Option dieser Prozedur eine unterschiedliche Anzeige.

  4. Legen Sie die zu importierenden Dateien fest:
    • Wenn Sie den Import von einem Quellverzeichnis mit Dateien auf einem lokalen Computer oder Netzwerk gewählt haben, dann zeigt die Liste Dateien die Dateien an, die importiert werden:
      • Um alle aufgelisteten Dateien zu importieren, klicken Sie auf Weiter.
      • Um bestimmte Dateien vom Import auszuschließen, markieren Sie diese, klicken Sie auf Ausschließen, und klicken Sie dann auf Weiter.
      • Um die Dateiliste durch die neuesten Informationen zu aktualisieren, klicken Sie auf Aktualisieren.
    • Wenn Sie den Import aus einem Web von einem Webserver gewählt haben, können Sie wahlweise Begrenzungen für die zu importierenden Dateien angeben:
      • Um Seiten zu importieren, die eine bestimmte Ebene von Hyperlinks unterhalb der Startseite liegen, aktivieren Sie das Kontrollkästchen Begrenzen auf diese Seite und, und geben Sie dann im Feld Untergeordnete Ebenen die Anzahl der Ebenen ein, die Sie importieren möchten.

        • Wenn Sie z. B. als Zahl der Ebenen 0 angeben, importiert FrontPage nur die Startseite, die Sie in Schritt 2 dieser Prozedur gewählt haben, sowie alle Bilder, Steuerelemente, Applets und andere Dateien auf dieser Seite. Geben Sie als Zahl der Ebenen 1 an, dann importiert FrontPage die Startseite und ihren Inhalt sowie alle Dateien (und Bilder, Steuerelemente, Applets usw. die in diesen Dateien enthalten sind), auf die durch Hyperlinks auf der Startseite verwiesen wird.

      • Um nicht mehr als einen bestimmten Betrag an Speicherplatz (z. B. 500 KB) durch den Import auf Ihrer Festplatte zu belegen, aktivieren Sie das Kontrollkästchen Begrenzen auf, und geben Sie dann im Feld KB den Betrag ein.
      • Um nur Text und Bilddateien zu importieren, ohne Steuerelemente, Applets und andere ähnliche Dateien, die auf der Seite enthalten sind, aktivieren Sie das Kontrollkästchen Begrenzen auf Text- und Bilddateien.

    Der letzte Bildschirm des Webimport-Assistenten wird angezeigt.

  5. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Wenn Sie ein festplattenbasiertes Web in ein bestehendes festplattenbasiertes Web importieren, fügt FrontPage nur die Dateien und Ordner des aktuellen festplattenbasierten Webs hinzu. Es wird kein neues, festplattenbasiertes Unterweb erstellt.
  • Wenn Sie eine Microsoft Access-Datenbank (Erweiterung .mdb) importieren, werden Sie aufgefordert, eine Datenbankverbindung zu erstellen.


Umwandeln eines festplattenbasierten Webs in ein serverbasiertes Web

Wenn Sie Ihren Computer erst nach der Installation von Microsoft FrontPage als Server konfiguriert haben, können Sie mithilfe der folgenden Prozedur Ihre festplattenbasierten Webs in serverbasierte Webs umwandeln.

  • Öffnen Sie Ihr festplattenbasiertes Web in FrontPage, und veröffentlichen Sie dann das Web über HTTP, indem Sie den URL Ihres Servers als Standort für die Veröffentlichung angeben.


Umwandeln eines Ordners in ein Web

Eine Neuigkeit für Microsoft FrontPage 2000 ist, dass Sie jeden Ordner in einem Web leicht in ein Unterweb umwandeln können. Da jedes Unterweb seine eigene Zusammenstellung von Berechtigungen dafür hat, wer es verändern, wer es durchsuchen und wer es verwalten darf, können Sie individuelle Unterwebs mit unterschiedlichen Berechtigungsstufen und Benutzergruppen einrichten.

Sie könnten z. B. verschiedene Unterwebs für Marketing und Personalwesen einrichten; innerhalb des Unterwebs Personalwesen könnten Sie verschiedene Unterwebs mit unterschiedlichen Berechtigungen für Stellenausschreibungen, Mitabeiterdaten und sogar für das Mitarbeiterhandbuch haben. Nur Mitarbeiter des Personalbüros könnten das Unterweb mit den Stellenausschreibungen aktualisieren, aber jeder in der Firma könnte es durchsuchen. Nur Führungskräfte im Personalwesen dürften das Unterweb für Mitarbeiterdaten durchsuchen und bearbeiten, während jeder in der Firma das Unterweb für Mitarbeiterprämien durchsuchen (aber nicht verändern) dürfte.

Warnung Wandeln Sie nicht den Stammordner (z. B. C: oder D:) der Festplatte Ihres Computers in ein Web um. Wenn Sie dies tun, könnte Ihre Festplatte unbrauchbar werden.

  • Klicken Sie mit der rechten Maustaste auf den Ordner, den Sie in ein Web umwandeln möchten, und klicken Sie dann im Kontextmenü auf In Web konvertieren.

Anmerkungen

  • Seiten, die andere Dateien enthalten, können nicht aktualisiert werden, wenn die eingeschlossenen Dateien sich ändern.
  • Hyperlinks auf Navigationsleisten könnten mit Seiten außerhalb des neuen Webs verknüpft sein.
  • Je umfangreicher der Inhalt des Ordners ist, desto länger wird es dauern, den Ordner in ein Web umzuwandeln. Bei einem großen Ordner kann dieser Prozess mehrere Minuten dauern.


Erstellen eines Ordners

Erstellen Sie einen Ordner in Ihrem Web um Ihre Seiten und Dateien zu ordnen. Sie können z. B. einen Ordner mit der Bezeichnung Multimedia erstellen, um Sounds, Videos, und ähnliches zu speichern. Wenn Sie einen Ordner in einem vorhanden Ordner erstellen möchten, dann wählen Sie diesen zunächst aus und führen dann die folgenden Schritte aus.

  1. Klicken Sie mit der rechten Maustaste in in die Ordnerliste, und klicken Sie dann im Kontextmenü auf Neuer Ordner.
  2. Geben Sie den Namen des neuen Ordners ein, und drücken Sie die EINGABETASTE.

Tipp Wenn Sie Dateien vor den Sitebesuchern verbergen wollen, erstellen Sie einen verborgenen Ordner für die Dateien.


Umbenennen eines Webs

Wenn Sie ein Web umbenennen, aktualisiert Microsoft FrontPage automatisch alle internen Hyperlinks und anderen Webeinstellungen durch den neuen Webnamen.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Allgemein.
  2. Geben Sie im Feld Webname einen neuen Namen für das Web ein.

Anmerkungen

  • Wird ein festplattenbasiertes Web umbenannt, wird der Pfad zum Web auf dem lokalen Computer oder im lokalen Netzwerk geändert. Wird ein serverbasiertes Web umbenannt, wird der URL des Webs auf dem Server geändert.
  • Wenn Sie ein Web nach seiner Veröffentlichung umbenennen, müssen Sie das gesamte Web unter einem neuen Namen erneut veröffentlichen. Hyperlinks aus anderen Websites auf Ihr altes Web werden nicht mehr funktionieren, daher sollten Sie darauf achten, dass Ihre Sitebesucher den neuen Pfad oder URL erfahren. Sie können auch den alten URL auf den neuen URL umleiten, indem Sie ein virtuelles Verzeichnis auf dem Server erstellen: Einzelheiten erhalten Sie in der Dokumentation zu Ihrem Server.


Kopieren eines Webs

Der Befehl Web veröffentlichen erlaubt es Ihnen, ein Web oder ein Unterweb entweder auf einen Speicherort im Dateisystem oder auf einen Server zu kopieren. Wenn Sie ein Web durch seine Veröffentlichung kopieren, hält Microsoft FrontPage alle Hyperlinks wie auch die Informationen über Designs des ursprünglichen Webs, über gemeinsame Randbereiche usw. aufrecht. Wenn Sie ein Web in einem anderen Web veröffentlichen, erstellt FrontPage das ursprüngliche Web als Unterweb zum Web, in dem die Veröffentlichung stattfindet.

Was möchten Sie tun?

Veröffentlichen eines Webs an einem Ort des lokalen Dateisystems

Veröffentlichen eines Webs mithilfe von HTTP


Öffnen eines Webs

  • Klicken Sie im Menü Datei auf Web öffnen, und führen Sie dann einen der folgenden Schritte durch:
    • Um ein festplattenbasiertes Web auf Ihrem lokalen Computer zu öffnen, geben Sie im Feld Ordnername den Pfad zum Ordner ein, der das Web enthält, und klicken Sie dann auf Öffnen.

      • Um z. B. ein Web mit dem Namen Nordwind zu öffnen, das auf dem Laufwerk C: im Ordner Meine Webs gespeichert ist, würden Sie C:\Meine Webs\Nordwind eingeben.

      Oder benutzen Sie das Feld Suchen in, um zum Ordner Meine Webs (oder irgendeinem anderen Ordner mit Webs) zu navigieren. Markieren Sie in der Liste der Webs das gewünschte Web, und klicken Sie dann auf Öffnen.

    • Um ein festplattenbasiertes Web auf einem Netzwerkcomputer zu öffnen, benutzen Sie das Feld Suchen in, um zu Netzlaufwerk und Ordner zu navigieren, der das Web enthält, das Sie öffnen möchten. Markieren Sie in der Liste der Webs das gewünschte Web, und klicken Sie dann auf Öffnen.

      • Tipp Um ein Netzlaufwerk zuzuordnen, ohne das Dialogfeld Web öffnen zu verlassen, klicken Sie auf Extras, und klicken Sie dann auf Netzlaufwerk verbinden.

    • Um ein Web auf einem Server zu öffnen, geben Sie im Feld Ordnername den URL zu diesem Web ein, und klicken Sie dann auf Öffnen.

      • Um z. B. ein Web mit dem Namen Nordwind auf einem Server mit dem Namen Mein Server zu öffnen, geben Sie http://Mein Server/Nordwind ein.

    • Um ein Unterweb zu öffnen, das in der Ordnerliste eines anderen Webs angezeigt wird, doppelklicken Sie auf das Unterweb.

Anmerkungen

  • Um ein Web zu öffnen, das Sie in letzter Zeit schon einmal geöffnet haben, klicken Sie im Dialogfeld Web öffnen auf den Dropdownpfeil rechts neben dem Feld Ordnername, klicken Sie auf das gewünschte Web, und klicken Sie dann auf Öffnen. Oder, falls Sie sich nicht im Dialogfeld Web öffnen befinden, zeigen Sie im Menü Datei auf Zuletzt geöffnete Webs, und klicken Sie dann auf das gewünschte Web.
  • Um das letzte Web, an dem Sie gearbeitet haben, jedesmal automatisch zu öffnen, wenn Sie FrontPage starten, klicken Sie im Menü Extras auf Optionen, und aktivieren Sie das Kontrollkästchen Zuletzt bearbeitetes Web automatisch öffnen.
  • Klicken Sie im Dialogfeld Web öffnen auf das Symbol auf der linken Seite (wie Verlauf, Favoriten oder Webordner), um ein Web an einem dieser Speicherungsorte zu öffnen.
  • Wenn Sie bereits ein Web geöffnet haben, wird jedes weitere Web in einem neuen FrontPage-Fenster geöffnet.


Umwandeln eines Webs in einen Ordner

Sie können jedes Web oder Unterweb in einen Ordner umwandeln. Da jedes Unterweb seine eigene Zusammenstellung von Berechtigungen hat, wer es bearbeiten, wer es durchsuchen und wer es verwalten darf, können Sie ein Unterweb in einen Ordner umwandeln, wenn Sie das Unterweb für jeden zugänglich machen möchten, der Berechtigungen in dem übergeordneten Web hat.

Warnung Wenn Sie ein Web oder Unterweb in einen Ordner umwandeln, können viele Einstellungen - z. B. Hyperlinks auf Navigationsleisten und Aufgaben - verloren gehen.

  • Klicken Sie in der Ordnerliste mit der rechten Maustaste auf das Web, das Sie in einen Ordner umwandeln möchten, und klicken Sie dann im Kontextmenü auf In Ordner konvertieren.

Anmerkungen

  • Seiten mit Designs können geändert werden, damit sie mit dem Design des übergeordneten Webs übereinstimmen.
  • Nur Benutzer mit der Berechtigung für den Zugriff auf das übergeordnete Web erhalten Zugriff auf den Inhalt des neuen Ordners.
  • Hyperlinks auf Navigationsleisten können verloren gehen.
  • Alle Aufgaben für das Web gehen verloren.
  • Je umfangreicher der Inhalt des Ordners ist, desto länger wird es dauern, den Ordner in ein Web umzuwandeln. Bei einem großen Ordner kann dieser Prozess mehrere Minuten dauern.


Speichern einer Seite in das aktuelle Web

Sie können eine Seite in das aktuelle Web speichern. Wenn Sie Grafiken, ActiveX-Steuerelemente, Sounddateien oder andere Objekte zur Seite hinzugefügt haben, werden Sie aufgefordert, diese an der selben Adresse wie die Seite zu speichern.

Selbst heutzutage erlauben die Internet-Standards nur die Verwendung von einfachen ASCII-Zeichen in URLs. Um sicherzustellen, dass alle Sitebesucher URLs folgen können, ohne Rücksicht auf die Sprache des jeweiligen Computers oder ein Betriebssystem nehmen zu müssen, sollten Sie in den URLs für Ihre Webs ebenfalls nur einfache ASCII-Zeichen verwenden. In Intranets lassen sich nicht-ASCII-Zeichen in einem Dateinamen dann verwenden, wenn der Server und jeder Client die gleiche Systemcodeseite benutzen.

  • Führen Sie einen der folgenden Schritte aus:
    • Wenn die Seite vorher noch nicht gespeichert worden ist, klicken Sie auf Speichern Schaltfläche "Speichern". Navigieren Sie zu der Adresse im Web, an der Sie die Seite speichern möchten, und geben Sie dann den Dateinamen der Seite in das Feld Dateiname ein. Klicken Sie auf Speichern.
    • Wenn die Seite im aktuellen Web geöffnet wurde, klicken Sie auf Speichern Schaltfläche "Speichern".
    • Wenn die Seite von einer Position außerhalb des aktuellen Webs geöffnet wurde, klicken Sie im Menü Datei auf Speichern unter. Navigieren Sie zu der Adresse im Web, an der Sie die Seite speichern möchten, und geben Sie dann den Namen der Datei in das Feld Dateiname ein. Klicken Sie auf Speichern.


Speichern einer Seite in ein anderes Web

Sie können eine Seite in ein anderes Web speichern.

Selbst heutzutage erlauben die Internet-Standards nur die Verwendung von einfachen ASCII-Zeichen in URLs. Um sicherzustellen, dass alle Sitebesucher URLs folgen können, ohne Rücksicht auf die Sprache des jeweiligen Computers oder ein Betriebssystem nehmen zu müssen, sollten Sie in den URLs für Ihre Webs ebenfalls nur einfache ASCII-Zeichen verwenden. In Intranets lassen sich nicht-ASCII-Zeichen in einem Dateinamen dann verwenden, wenn der Server und jeder Client die gleiche Systemcodeseite benutzen.

  1. Klicken Sie in der Seitenansicht im Menü Datei auf Speichern unter.
  2. Navigieren Sie zu dem Web, in dem Sie die Seite speichern möchten.
  3. Geben Sie in das Feld Dateiname den Namen der Datei ein.
  4. Wenn Sie den Seitentitel ändern möchten, klicken Sie auf Ändern, geben den neuen Titel ein und klicken Sie dann auf OK.
  5. Klicken Sie auf Speichern.


Speichern einer Seite in ein Dateisystem

Sie können eine Seite als .HTM-Datei in einem Dateisystem speichern, z. B. auf einem lokalen Laufwerk oder in einem Netzwerk. Wenn die Seite Grafiken, ActiveX-Steuerelemente, Sounddateien oder andere Objekte enthält, werden Sie aufgefordert, diese an derselben Adresse zu speichern wie die Seite.

Selbst heutzutage erlauben die Internet-Standards nur die Verwendung von einfachen ASCII-Zeichen in URLs. Um sicherzustellen, dass alle Sitebesucher URLs folgen können, ohne Rücksicht auf die Sprache des jeweiligen Computers oder ein Betriebssystem nehmen zu müssen, sollten Sie in den URLs für Ihre Webs ebenfalls nur einfache ASCII-Zeichen verwenden. In Intranets lassen sich nicht-ASCII-Zeichen in einem Dateinamen dann verwenden, wenn der Server und jeder Client die gleiche Systemcodeseite benutzen.

  1. Klicken Sie in der Seitenansicht im Menü Datei auf Speichern.
  2. Navigieren Sie zu der Adresse im Dateisystem, an der Sie die Seite speichern möchten.
  3. Geben Sie in das Feld Dateiname den Namen der Datei ein.
  4. Klicken Sie auf Speichern.


Importieren einer Datei oder eines Ordners

Wenn Sie eine Datei oder einen Ordner aus Ihrem lokalen Dateisystem, Ihrem Firmenintranet oder dem World Wide Web importieren, legt Microsoft FrontPage eine Kopie der Datei oder des Ordners in Ihrem Web ab. Sie können jeden der von Ihrem Betriebssystem unterstützten Dateitypen importieren. Sie können auch eine Liste mit Dateien und Ordnern erstellen, die zu einem späteren Zeitpunkt importiert werden sollen und die URLs der Dateien vor dem Importieren ändern.

Anmerkung Zum Importieren einer Datei oder eines Ordners in einen bestimmten Unterordner wählen Sie diesen Ordner vor dem Durchführen der folgenden Schritte aus der Ordnerliste aus.

  1. Klicken Sie im Menü Datei auf Importieren.
  2. Wählen Sie die Dateien oder Ordner aus, die Sie importieren möchten.
  3. Zum Importieren von Dateien klicken Sie auf Datei hinzufügen, und zeigen Sie dann im Dialogfeld Fügt Datei zur Importliste hinzu auf den Ordner, in dem die zu importierenden Dateien gespeichert sind. Wählen Sie die Dateien aus, und klicken Sie dann auf Öffnen.

    4. Anmerkung Um vor dem Importieren einer Datei deren URL zu ändern (um die Datei umzubenennen oder um den Ordner der Datei in Ihrem Web zu ändern), klicken Sie auf Ändern. Geben Sie in das Feld Dateipfad innerhalb Ihres Webs den URL relativ zum Stamm des aktuellen Web ein. Wenn Sie z. B. den URL Ordner2/Beispiel.htm eingeben, wird die Seite im Ordner2 direkt unter dem Stammordner des aktuellen Webs gespeichert. Nach dem Ändern des URL klicken Sie auf OK.

  4. Zum Importieren eines Ordners klicken Sie auf Ordner hinzufügen. Anschließend suchen Sie den Ordner im Dialogfeld Ordner suchen, wählen ihn aus und klicken dann auf OK.
  5. Zum Importieren einer Datei oder eines Ordners aus einer Website klicken Sie auf Aus einem Web und folgen dann den Anweisungen des Webimport-Assistenten.
  6. Zum Hinzufügen von Dateien aus anderen Ordnern, weiteren Ordnern oder von Dateien aus anderen Websites zum Listenfeld Importieren wiederholen Sie dieses Verfahren beginnend bei Schritt 3.
  7. Um die Liste der Importdateien zu speichern und die Dateien und Ordner später zu importieren, klicken Sie auf Schließen. Zum Starten des Importvorgangs in den ausgewählten Ordner (sofern vorhanden) im aktuellen Web klicken Sie auf OK.

Anmerkungen

  • Sie können den Importvorgang durch klicken auf Stopp abbrechen.
  • Wenn Sie eine Microsoft Access-Datenbank importieren (.MDB-Erweiterung), werden Sie aufgefordert, eine Datenbankverbindung herzustellen.
  • Um schnell eine Datei oder eine Auswahl von Dateien in das aktuelle Web zu importieren, ziehen Sie diese vom Windows-Explorer in die Ordnerliste.


Exportieren einer Datei oder eines Ordners

Am einfachsten exportieren Sie eine Datei oder einen Ordner, indem Sie mit der rechten Maustaste auf die Ordnerliste klicken. Anschließend klicken Sie auf Kopieren und fügen dann die Datei oder den Ordner im Windows-Explorer oder in einer anderen Anwendung ein.

  • Zum Exportieren einer Datei oder eines Ordners unter einem anderen Namen klicken Sie im Menü Datei auf Speichern unter und geben dann den neuen Namen in das Feld Dateiname ein.
  • Zum Exportieren einer Datei oder eines Ordners in einen anderen Pfad, in ein anderes Web oder an eine Netzwerkposition, klicken Sie im Menü Datei auf Speichern unter und gehen dann im Feld Speichern in zum entsprechenden Pfad, Server oder Netzwerkpfad.
  • Zum Exportieren einer Datei unter einem anderen Dateityp (um z. B. eine HTML-Seite (.HTM) als Vorlage in FrontPage (.TEM) oder als Active Server Page (.ASP) zu exportieren), klicken Sie im Menü Datei auf Speichern unter und dann im Listenfeld Dateityp auf den gewünschten Dateityp.
  • Zum Exportieren von Dateien oder eines Web in einen anderen Server- oder Webpfad, wählen Sie die Seiten aus, oder öffnen Sie das Web, das Sie exportieren möchten, und klicken Sie dann im Menü Datei auf Web veröffentlichen. Folgen Sie den Anweisungen des Dialogfeldes Web veröffentlichen, um die ausgewählten Dateien oder das Web durch Veröffentlichung zu exportieren.

Anmerkung Wenn Sie Dateien oder ein Web durch Veröffentlichung exportieren, repariert Microsoft FrontPage automatisch die Hyperlinks zwischen Dateien im selben Web oder einem Unterweb.


Verschieben einer Datei oder eines Ordners

Am einfachsten verschieben Sie eine Datei oder einen Ordner, indem Sie mit der rechten Maustaste in der Ordnerliste auf die Datei oder den Ordner klicken, dann klicken Sie auf Ausschneiden. Anschließend klicken Sie mit der rechten Maustaste auf das Ziel in der Ordnerliste oder im Windows-Explorer und zum Schluß klicken Sie auf Einfügen. Wenn Sie die Datei oder den Ordner in ein anderes Web oder ein Unterweb eingfügt haben, dann repariert Microsoft FrontPage automatisch die Hyperlinks zwischen den Seiten innerhalb des Ordners.


Umbenennen einer Datei oder eines Ordners

Wenn Sie eine Datei oder einen Ordner unter Verwendung des nachstehenden Verfahrens umbenennen, repariert Microsoft FrontPage automatisch alle Hyperlinks zu oder von der umbenannten Datei (oder den Dateien im umbenannten Ordner).

  1. Klicken Sie in der Ordnerliste mit der rechten Maustaste auf die Datei oder den Ordner, die/den Sie umbenennen möchten, und klicken Sie dann im Kontextmenü auf Umbenennen.
  2. Geben Sie einen neuen Namen für die Datei oder den Ordner ein.

Anmerkungen

  • Achten Sie beim Umbenennen einer Datei darauf, dass Sie nicht versehentlich die Dateierweiterung ändern oder weglassen (z. B. von INDEX.HTM in INDEX.ASP). Das Ändern oder Weglassen der Erweiterung einer Datei kann dazu führen, dass die Datei unbrauchbar wird.
  • Wenn Sie eine Datei oder einen Ordner unter Verwendung von Windows-Explorer umbenennen, werden Hyplerlinks zu und von dieser Datei (oder den Dateien in diesem Ordner) nicht automatisch repariert. Verwenden Sie zum Umbenennen von Dateien oder Ordnern in einem Web daher immer das oben beschriebene Verfahren.


Importieren von Grafiken in ein Web

Importieren Sie Bilder und Videoclips in ein Web, damit Sie schnell auf benötigte Dateien zugreifen können. So können Sie beispielsweise Bilder nacheinander Ihrem Web hinzufügen, indem Sie jeder Seite ein Bild hinzufügen und die Seite dann speichern. Wenn Sie allerdings im Voraus wissen, dass Sie eine bestimmte Gruppe von Bildern verwenden werden, können Sie diese alle auf einmal in einen Ordner importieren, den Sie in Ihrem Web angeben. Wenn Sie nun einer Seite ein Bild hinzufügen möchten, können Sie schnell hierauf zugreifen, ohne erst im Dateisystem danach suchen zu müssen.

  1. Markieren Sie in Windows Explorer die Grafiken, die Sie importieren möchten.

    2. Tipp Sie können eine Liste mit Dateien markieren, indem Sie auf die erste Datei klicken und dann bei gedrückter UMSCHALTTASTE auf die letzte Datei in der Liste klicken. Oder Sie können einzelne Dateien markieren, indem Sie STRG gedrückt halten und dann auf die gewünschten Dateien klicken.

  2. Klicken Sie mit der rechten Maustaste auf die markierten Dateien, und klicken Sie dann im Kontextmenü auf Kopieren.
  3. Wechseln Sie zu Microsoft FrontPage.
  4. Öffnen Sie in der Ordneransicht den Ordner, in den Sie die Grafiken importieren möchten.
  5. Klicken Sie mit der rechten Maustaste in den Dateienausschnitt, und klicken Sie dann im Kontextmenü auf Einfügen.

Tipp Sie können Grafiken auch importieren, indem Sie (beispielsweise auf dem Desktop) auf die gewünschten Dateien klicken und diese in die Ordnerliste oder den Dateienausschnitt von FrontPage ziehen.


Löschen von Seiten aus dem aktuellen Web

Sie können nicht benötigte Seiten aus dem aktuellen Web löschen.

  • Wählen Sie in der Ordneransicht die zu löschenden Seiten aus, und drücken Sie dann die ENTF-TASTE.

Tipp Sie können Dateien in fast allen Ansichten aus der Ordnerliste auswählen und löschen.


Erstellen einer neuen Seite in der Ordnerliste

Das Erstellen einer neuen Seite in der Ordnerliste ist ein einfacher Weg, neue Seiten in Ihrem Web hinzuzufügen.

  1. Klicken Sie in der Ordnerliste mit der rechten Maustaste auf den Ordner, in dem Sie die neue Seite erstellen möchten, und klicken Sie dann im Kontextmenü auf Neue Seite.
  2. Geben Sie den Namen der neuen Seite ein, und drücken Sie dann die EINGABETASTE.

Anmerkung

  • Wenn Sie mit der rechten Maustaste auf den Hintergrund der Ordnerliste klicken, ohne einen Ordner zu markieren, wird die neue Seite im Stammweb erstellt.
  • Wenn Ihr Web festlegt, dass alle Seiten Designs, gemeinsame Randbereiche oder Navigationsleisten verwenden, dann erbt die neue Seite diese Einstellungen vom Web, sobald Sie die Seite in der Seitenansicht bearbeiten.


Löschen eines Webs

Warnung Seien Sie vorsichtig beim Löschen eines Webs! Wenn Sie ein Web einmal gelöscht haben, ist es permanent zerstört und kann nicht wiederhergestellt werden. Haben Sie das Web durch Umwandeln eines Ordners auf Ihrem (oder einem anderen) Computer in ein Web erstellt, dann wird dieser Ordner und sein ganzer Inhalt auf diesem Computer permanent gelöscht, es sei denn, Sie legen es anders fest. Um den Inhalt eines Webs oder Unterwebs als Ordner auf dem Computer zu erhalten, wandeln Sie das Web zurück in einen Ordner um, bevor Sie das folgende Verfahren anwenden.

  • Um ein Web oder Unterweb, das Sie derzeit in Microsoft FrontPage bearbeiten, zu löschen, klicken Sie in der Ordnerliste mit der rechten Maustaste auf das Web oder Unterweb, und klicken Sie dann im Kontextmenü auf Löschen.

Anmerkung Sie können kein Unterweb löschen, es sei denn, Sie haben Administratorrechte auf dem übergeordneten Web.


Suchen von Text in einem Web

Sie können nach Text auf einer oder mehreren Seiten im aktuellen Web suchen. Sie können entweder das gesamte Web durchsuchen oder die Seiten auswählen, die Sie durchsuchen möchten.

  1. Wechseln Sie zur Ordneransicht.
  2. Wenn Sie nicht jede Seite im Web durchsuchen möchten, wählen Sie die Seiten aus, die Sie durchsuchen möchten.
  3. Klicken Sie im Menü Bearbeiten auf Suchen.
  4. Führen Sie einen der folgenden Schritte durch:
    • Um nach Text auf allen Seiten im aktuellen Web zu suchen, klicken Sie auf Alle Seiten.
    • Um nach Text auf Seiten zu suchen, die Sie ausgewählt haben, klicken Sie auf Markierte Seiten.
  5. Geben Sie im Feld Suchen nach den Text ein, nach dem Sie suchen möchten.
  6. Um nur nach Text zu suchen, wenn er mit einem ganzen Wort übereinstimmt, aktivieren Sie das Kontrollkästchen Nur ganzes Wort suchen.
  7. Um nur nach Text zu suchen, wenn er in der Groß-/Kleinschreibung mit dem eingegebenen Text übereinstimmt, aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten.
  8. Um nach Text im HTML-Code zu suchen, aktivieren Sie das Kontrollkästchen In HTML suchen. Sie können z. B. nach einem Text suchen, der auf der Seite weder sichtbar noch bearbeitbar ist, wie z. B. dem Seitentitel, der in den Seiteneigenschaften festgelegt wird.
  9. Klicken Sie auf Im Web suchen.
  10. Wenn FrontPage die Seiten auflistet, auf denen der Text gefunden wurde, führen Sie einen der folgenden Schritte durch:
    • Um eine Aufgabe für eine Seite hinzuzufügen, klicken Sie auf die Seite in der Liste, und klicken Sie dann auf Aufgabe hinzufügen. Sie können die Aufgabe jederzeit in der Aufgabenansicht erledigen.
    • Um eine Seite in der Seitenansicht zu öffnen, doppelklicken Sie auf die Seite in der Liste. Das erste Vorkommen des Textes wird invers dargestellt. Klicken Sie auf Weitersuchen, um das nächste Vorkommen zu suchen. Klicken Sie auf Zurück zum Web, um zur Liste der Seiten zurückzukehren.


Suchen und Ersetzen von Text in einem Web

Sie können nach einem Text auf einer oder mehreren Seiten im aktuellen Web suchen und diesen durch einen anderen Text ersetzen. Sie können entweder das gesamte Web durchsuchen oder die zu durchsuchenden Seiten auswählen.

  1. Wechseln Sie zur Ordneransicht.
  2. Wenn Sie nicht jede Seite im Web durchsuchen möchten, wählen Sie die Seiten aus, die Sie durchsuchen möchten.
  3. Klicken Sie im Menü Bearbeiten auf Ersetzen.
  4. Führen Sie einen der folgenden Schritte durch:
    • Um nach Text auf allen Seiten im aktuellen Web zu suchen, klicken Sie auf Alle Seiten.
    • Um nach Text auf Seiten zu suchen, die Sie ausgewählt haben, klicken Sie auf Markierte Seiten.
  5. Geben Sie im Feld Suchen nach den Text ein, nach dem Sie suchen möchten.
  6. Geben Sie im Feld Ersetzen durch den Ersetzungstext ein.
  7. Um nur nach Text zu suchen, wenn er mit einem ganzen Wort übereinstimmt, aktivieren Sie das Kontrollkästchen Nur ganzes Wort suchen.
  8. Um nur nach Text zu suchen, wenn er in der Groß-/Kleinschreibung mit dem eingegebenen Text übereinstimmt, aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten.
  9. Um nach Text im HTML-Code zu suchen, aktivieren Sie das Kontrollkästchen In HTML suchen. Sie können z. B. nach einem Text suchen, der auf der Seite weder sichtbar noch bearbeitbar ist, wie z. B. dem Seitentitel, der in den Seiteneigenschaften festgelegt wird.
  10. Klicken Sie auf Im Web suchen
  11. Wenn FrontPage die Seiten auflistet, auf denen der Text gefunden wurde, führen Sie einen der folgenden Schritte durch:
    • Um eine Aufgabe für eine Seite hinzuzufügen, klicken Sie auf die Seite in der Liste, und klicken Sie dann auf Aufgabe hinzufügen. Sie können die Aufgabe jederzeit in der Aufgabenansicht erledigen.
    • Um eine Seite in der Seitenansicht zu öffnen, doppelklicken Sie auf die Seite in der Liste. Das erste Vorkommen des Textes wird invers dargestellt. Sie können auf Ersetzen klicken, um dieses Vorkommen zu ersetzen, auf Weitersuchen klicken, um das nächste Vorkommen zu suchen, oder auf Alle ersetzen klicken, um alle Vorkommen auf der aktuellen Seite zu ersetzen.

      • Wenn Sie alle Vorkommen des Textes auf der Seite durchgesehen haben, werden Sie aufgefordert, die Seite zu speichern und zu schließen und dann mit der nächsten Seite, auf der der Text gefunden wurde, fortzufahren.


Info über Seiten

Um mehr über Seiten zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Info über Designs

Um mehr über Designs zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Anwenden eines Designs auf die aktuelle Seite

Ein Design ist eine Sammlung von einheitlichen Designelementen und Farbschemata. Sie können ein Design auf die aktuelle Seite anwenden, so dass diese ein attraktives Erscheinungsbild hat. Die Formatvorlagen, Farben und Grafiken des Designs ersetzen dann die derzeit verwendeten Einstellungen.

Nach Anwendung eines Designs auf die aktuelle Seite anstatt auf das ganze Web benutzt die Seite nicht mehr das Standarddesign des Webs. Daher wirken sich Designänderungen, die Sie auf das Web anwenden (Option Alle Seiten) nicht auf diese Seite aus, sondern nur auf diejenigen Seiten, welche die Standardeinstellungen verwenden. Um eine Seite für die Verwendung des Standarddesigns des Webs einzurichten, wenden Sie das Standarddesign auf die Seite an.

  1. Öffnen Sie in der Seitenansicht die Seite, auf die Sie ein Design anwenden möchten.
  2. Klicken Sie im Menü Format auf Design.

    3. Unter Design zuweisen an ist die Option Ausgewählte Seiten aktiviert.

  3. Klicken Sie in der Liste auf ein Design, das Sie anwenden möchten (um die Einstellungen des Standarddesigns für das Web anzuwenden, klicken Sie auf Standard). Eine Vorschau des Designs wird unter Beispiel für Design angezeigt.

    4. Sie können auch eine der folgenden Kontrollkästchen aktivieren, um das Erscheinungsbild des Designs festzulegen:

    • Um ein leuchtendes Farbschema zu verwenden, aktivieren Sie Lebendige Farben. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Farbeinstellungen zu verwenden.
    • Um eine lebendige Sammlung von Bannern, Schaltflächen, Aufzählungszeichen und anderen grafischen Elementen zu verwenden, aktivieren Sie das Kontrollkästchen Aktive Grafiken. Wählen Sie zum Beispiel diese Option, wenn Sie Hoverschaltflächen anstelle von einfachen Schaltflächen verwenden möchten. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Grafikeinstellungen zu verwenden.
    • Um ein Hintergrundbild zu verwenden, aktivieren Sie das Kontrollkästchen Hintergrundbild.
    • Um eine externe Dokumentvorlage zusammen mit dem Design zu verwenden (anstatt den HTML-Code der Seite neu zu formatieren, um das Design anzuwenden), aktivieren Sie das Kontrollkästchen CSS verwenden. Sie sollten diese Option ebenfalls verwenden, wenn Sie ein Design benutzen, in dem Sie die Formatvorlagen geändert haben. Dieses Leistungsmerkmal wird jedoch nicht von älteren Webbrowsern oder Servern mit FrontPage 98 unterstützt.

      • Anmerkung Wenn dieses Kontrollkästchen aktiviert ist, werden keine horizontalen Linien angezeigt.


Anwenden eines Designs auf ausgewählte Seiten

Ein Design ist eine Sammlung von einheitlichen Designelementen und Farbschemata. Sie können ein Design auf ausgewählte Seiten anwenden, so dass diese ein attraktives Erscheinungsbild haben. Die Formatvorlagen, Farben und Grafiken des Designs ersetzen dann die derzeit verwendeten Einstellungen.

Nach Anwendung eines Designs auf ausgewählte Seiten anstatt auf das ganze Web benutzen die Seiten nicht mehr das Standarddesign des Webs. Daher wirken sich Designänderungen, die Sie auf das Web anwenden (Option Alle Seiten) nicht auf diese ausgewählten Seiten aus, sondern nur auf diejenigen Seiten, welche die Standardeinstellungen verwenden. Um eine Seite für die Verwendung des Standarddesigns des Webs einzurichten, wenden Sie das Standarddesign auf die Seite an.

  1. Markieren Sie in der Ordneransicht die Seiten, auf die Sie ein Design anwenden möchten.
  2. Klicken Sie im Menü Format auf Design.
  3. Klicken Sie auf Ausgewählte Seiten.
  4. Klicken Sie in der Liste auf ein Design, das Sie anwenden möchten (um die Einstellungen des Standarddesigns für das Web anzuwenden, klicken Sie auf Standard). Eine Vorschau des Designs wird unter Beispiel für Design angezeigt.

    5. Sie können auch eine der folgenden Kontrollkästchen aktivieren, um das Erscheinungsbild des Designs festzulegen:

    • Um ein leuchtendes Farbschema zu verwenden, aktivieren Sie Lebendige Farben. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Farbeinstellungen zu verwenden.
    • Um eine lebendige Sammlung von Bannern, Schaltflächen, Aufzählungszeichen und anderen grafischen Elementen zu verwenden, aktivieren Sie das Kontrollkästchen Aktive Grafiken. Wählen Sie zum Beispiel diese Option, wenn Sie Hoverschaltflächen anstelle von einfachen Schaltflächen verwenden möchten. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Grafikeinstellungen zu verwenden.
    • Um ein Hintergrundbild zu verwenden, aktivieren Sie das Kontrollkästchen Hintergrundbild.
    • Um eine externe Dokumentvorlage zusammen mit dem Design zu verwenden (anstatt den HTML-Code der Seite neu zu formatieren, um das Design anzuwenden), aktivieren Sie das Kontrollkästchen CSS verwenden. Sie sollten diese Option ebenfalls verwenden, wenn Sie ein Design benutzen, in dem Sie die Formatvorlagen geändert haben. Dieses Leistungsmerkmal wird jedoch nicht von älteren Webbrowsern oder Servern mit FrontPage 98 unterstützt.

      • Anmerkung Wenn dieses Kontrollkästchen aktiviert ist, werden keine horizontalen Linien angezeigt.


Anwenden eines Designs auf ein Web

Ein Design ist eine Sammlung von einheitlichen Designelementen und Farbschemata. Sie können ein Design auf ein Web anwenden, so dass Ihre Webseiten ein attraktives Erscheinungsbild haben. Die Formatvorlagen, Farben und Grafiken des Designs ersetzen dann die derzeit verwendeten Einstellungen.

Wenn Sie ein Design für ein Web auswählen, wird dies zur Standardeinstellung für alle Seiten im Web und wird bei neuen Seiten automatisch angewendet.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie auf Alle Seiten.
  3. Klicken Sie in der Liste auf ein Design, das Sie anwenden möchten. Eine Vorschau des Designs wird unter Beispiel für Design angezeigt.

    4. Sie können auch eine der folgenden Kontrollkästchen aktivieren, um das Erscheinungsbild des Designs festzulegen:

    • Um ein leuchtendes Farbschema zu verwenden, aktivieren Sie Lebendige Farben. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Farbeinstellungen zu verwenden.
    • Um eine lebendige Sammlung von Bannern, Schaltflächen, Aufzählungszeichen und anderen grafischen Elementen zu verwenden, aktivieren Sie das Kontrollkästchen Aktive Grafiken. Wählen Sie zum Beispiel diese Option, wenn Sie Hoverschaltflächen anstelle von einfachen Schaltflächen verwenden möchten. Deaktivieren Sie dieses Kontrollkästchen, um die normalen Grafikeinstellungen zu verwenden.
    • Um ein Hintergrundbild zu verwenden, aktivieren Sie das Kontrollkästchen Hintergrundbild.
    • Um eine externe Dokumentvorlage zusammen mit dem Design zu verwenden (anstatt den HTML-Code der Seite neu zu formatieren, um das Design anzuwenden), aktivieren Sie das Kontrollkästchen CSS verwenden. Sie sollten diese Option ebenfalls verwenden, wenn Sie ein Design benutzen, in dem Sie die Formatvorlagen geändert haben. Dieses Leistungsmerkmal wird jedoch nicht von älteren Webbrowsern oder Servern mit FrontPage 98 unterstützt.

      • Anmerkung Wenn dieses Kontrollkästchen aktiviert ist, werden keine horizontalen Linien angezeigt.

Anmerkung Wenn Sie Designeinstellungen auf einzelne Seiten angewendet haben, verwenden diese Seiten nicht mehr das Standarddesign des Webs. Daher wirken sich Designänderungen, die Sie am Web vornehmen, nicht auf alle Seiten im Web aus, sondern nur auf diejenigen Seiten, welche diese Standardeinstellung benutzen. Um eine Seite für die Verwendung des Standarddesigns des Webs einzurichten, wenden Sie das Standarddesign auf die ausgewählte Seite an.


Ändern der in einem Design verwendeten Farben

Sie können die in einem bestimmten Design verwendeten Farben ändern. Im Design „Impressionen“ zum Beispiel sind die aktiven Hyperlinks grün; Sie können ihre Farbe auch in Rot ändern. Sie können auch die Farben anderer Seiten- und Textelemente ändern, wie die Farbe von Haupttext und Überschriften, von Bannertext, von Beschriftungen auf der Navigationsleiste, von Tabellenrahmen und vom Hintergrund. Außerdem hat jedes Design zwei Farbeinstellungen, normal und lebendig, und Sie können die Farben beider Einstellungen festlegen.

Wenn Sie ein vordefiniertes Design ändern, müssen Sie Ihre Änderungen als neues Design speichern: Sie können kein vordefiniertes Design überschreiben. Wenn Sie zum Beispiel das Design „Impressionen“ ändern, speichern Sie die Änderungen als neues Design unter dem Namen „MeinDesign“.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie in der Liste auf das Design, das Sie ändern möchten.
  3. Klicken Sie auf Ändern, klicken Sie auf Farben, und klicken Sie dann auf die Registerkarte Benutzerdefiniert.
  4. Geben Sie unter Farben des Designs an, ob Sie die Farben der normalen oder der lebendigen Farbeinstellung ändern möchten.
  5. Klicken Sie im Feld Element auf das Element, für das Sie die Farbe ändern möchten, und geben sie dann im Feld Farbe die gewünschte Farbe an.

    6. Wiederholen Sie die Schritte 4 und 5 für jedes Element, dessen Farbe Sie ändern möchten.

    Tipp Sie können auch Farben ändern, indem Sie das globale Farbschema ändern, anstatt für einzelne Elemente Farben auszuwählen. Wählen Sie auf der Registerkarte Farbskalen ein vordefiniertes Farbschema aus, oder erstellen Sie ein neues Farbschema auf der Registerkarte Farbenrad.

  6. Klicken Sie auf OK.
  7. Klicken Sie auf Speichern unter.
  8. Geben Sie einen Namen für das Design ein (es sei denn, Sie haben ein benutzerdefiniertes Design geändert), und klicken Sie dann auf OK.
  9. Wenden Sie das neue Design auf das Web oder auf ausgewählte Seiten an.


Ändern der in einem Design verwendeten Grafiken

Sie können die Grafiken, die in einem bestimmten Design verwendet werden, durch Ihre eigenen ersetzen. So können Sie zum Beispiel das Hintergrundbild, das im Design „Übergänge“ verwendet wird, durch eine selbst erstellte Grafik ersetzen. Sie können auch andere grafische Elemente ändern, wie Seitenbanner, Aufzählungszeichen, Navigationsschaltflächen und horizontale Linien. Ebenfalls können Sie die für diejenigen grafischen Elemente zu verwendene Schriftart festlegen, die zusammen mit Text angezeigt werden.

Außerdem hat jedes Design zwei Grafikeinstellungen, normal und aktiv, und Sie können die in jeder Grafikeinstellung zu verwendenden Grafiken festlegen. Wenn Sie dann ein Design anwenden, stellen Sie sicher, dass Sie die von Ihnen angepassten Grafikeinstellungen auswählen.

Wenn Sie ein vordefiniertes Design ändern, müssen Sie Ihre Änderungen als neues Design speichern: Sie können nicht ein vordefiniertes Design überschreiben. Wenn Sie zum Beispiel das Design „Übergänge“ ändern, speichern Sie die Änderungen als neues Design unter dem Namen „MeinDesign“.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie in der Liste auf das Design, das Sie ändern möchten.
  3. Klicken Sie auf Ändern, und klicken Sie dann auf Grafiken.
  4. Geben Sie unter Grafiken des Designs an, ob Sie die Grafiken in den normalen oder in den aktiven Grafikeinstellungen ändern möchten (wenn auf der Registerkarte Grafik die Option Hintergrundbild aktiviert ist, können Sie die Grafikeinstellungen nicht ändern).
  5. Klicken Sie auf der Registerkarte Grafik im Feld Element auf das grafische Element, das Sie ändern möchten.
  6. Geben Sie das Bild oder die Bilder an, die Sie verwenden möchten. Je nach ausgewähltem Element werden eine oder mehrere Optionen angezeigt. So können Sie zum Beispiel für Aufzählungsliste drei verschiedene Aufzählungszeichen definieren. Um eine Grafik im aktuellen Web oder Dateisystem zu finden, klicken Sie auf Durchsuchen.

    7. Wenn das ausgewählte grafische Element Text anzeigt, werden die Optionen in der Registerkarte Zeichen aktiviert, und Sie können die Schriftart ändern.

    Wiederholen Sie die Schritte 4, 5 und 6 für jedes grafische Element, das Sie ändern möchten.

  7. Klicken Sie auf OK.
  8. Klicken Sie auf Speichern unter.
  9. Geben Sie einen neuen Namen für das Design ein (es sei denn Sie haben ein benutzerdefiniertes Design geändert), und klicken Sie dann auf OK.
  10. Wenden Sie das neue Design auf das Web oder auf ausgewählte Seiten an.


Ändern der in einem Design verwendeten Schriftarten

Sie können die in einem bestimmten Design verwendeten Schriftarten verändern. So können Sie zum Beispiel die Schriftart von Haupttext und Überschriften im Design „Kapseln“ von Arial nach Times New Roman ändern. Wenn Sie jedoch die Schriftart ändern möchten, die in einem grafischen Element angezeigt wird (zum Beispiel die in Seitenbannern verwendete Schriftart), müssen Sie die Grafik ändern.

Wenn Sie ein vordefiniertes Design ändern, müssen Sie Ihre Änderungen als neues Design speichern: Sie können nicht ein vordefiniertes Design überschreiben. Wenn Sie zum Beispiel das Design „Kapseln“ ändern, speichern Sie die Änderungen als neues Design unter dem Namen „MeinDesign“.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie in der Liste auf das Design, das Sie ändern möchten.
  3. Klicken Sie auf Ändern, und klicken Sie dann auf Text.
  4. Klicken Sie im Feld Element auf die Formatvorlage, die Sie ändern möchten, und klicken Sie dann unter Schriftart auf die gewünschte Schriftart.

    5. Wiederholen Sie diesen Schritt für jede Formatvorlage, die Sie ändern möchten.

  5. Um die Formatvorlagen noch weitergehend zu ändern, zum Beispiel die Schriftattribute einer bestimmten Formatvorlage, klicken Sie auf Weitere Textformatvorlagen, ändern Sie die Formatvorlagen wie erforderlich, und klicken Sie dann auf OK, um zum Dialogfeld Design ändern zurückzukehren. Informationen über das Ändern von Formatvorlagen finden Sie unter Ändern einer Formatvorlage für eine Seite.

    6. Anmerkung Sie sehen das Ergebnis Ihrer Änderungen an Formatvorlagen erst, wenn Sie das Design mithilfe von Cascading Style Sheets anwenden (aktivieren Sie für die Zuweisung des Designs das Kontrollkästchen CSS verwenden). Diese Formatvorlagenänderungen werden nicht in der Vorschau Beispiel für Design wiedergegeben.

  6. Klicken Sie auf OK.
  7. Klicken Sie auf Speichern unter.
  8. Geben Sie einen Namen für das Design ein (es sei denn, Sie haben ein benutzerdefiniertes Design geändert), und klicken Sie dann auf OK.
  9. Wenden Sie das neue Design auf das Web oder auf ausgewählte Seiten an.


Erstellen eines neuen Designs

Um ein neues Design zu erstellen, müssen Sie ein bestehendes ändern und dann unter einem neuen Namen speichern. Sie können Farben, Grafiken und Formatvorlagen ändern:

  • Ändern Sie die normalen oder lebendigen Farbeinstellungen für Hyperlinks, Haupttext und Überschriften, Bannertext, Beschriftungen der Navigationsleiste, Tabellenrahmen und Hintergrund. Sie können zum Beispiel die Farbe von Hyperlinks von Rot auf Gelb ändern.
  • Ersetzen Sie Grafiken (Hintergrundbild, Seitenbanner, Aufzählungszeichen, Navigationsschaltflächen und horizontale Linien) durch Ihre eigenen Grafiken, in den normalen und den aktiven Grafikeinstellungen. Für grafische Elemente, die zusammen mit Text angezeigt werden, können Sie die Schriftart ändern.
  • Ändern Sie zum Beispiel die Formatvorlagen für Haupttext und Überschriften von Arial nach Times New Roman.
  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie in der Liste auf ein Design, möglichst auf eines, dessen Charakteristik dem Design, das Sie erstellen möchten, am ähnlichsten ist, damit Sie weniger Elemente ändern müssen.
  3. Klicken Sie auf Ändern.
  4. Führen Sie eine der folgenden Schritte durch, um das Design zu ändern:
    • Um die Farben zu ändern, klicken Sie auf Farben, und klicken Sie dann auf die Registerkarte Benutzerdefiniert.

      • Geben Sie unter Farben des Designs an, ob Sie die Farben für die normalen oder die lebendigen Farbeinstellungen ändern möchten. Klicken Sie im Feld Elemente auf das Element, für das Sie die Farbe ändern möchten, und geben Sie dann im Feld Farbe die gewünschte Farbe an. Wiederholen Sie diesen Schritt für jedes Element, und klicken Sie dann auf OK.

    • Um die Grafiken zu ändern, klicken Sie auf Grafiken.

      • Geben Sie unter Grafiken des Designs an, ob Sie die Grafiken für die normalen oder die aktiven Grafikeinstellungen ändern möchten. Klicken Sie auf der Registerkarte Grafik im Feld Element auf das Grafikelement, das Sie ändern möchten, und geben Sie dann das Bild oder die Bilder an, die Sie verwenden möchten, abhängig vom ausgewählten Element werden eine oder mehrere Optionen angezeigt. Um die Grafik im aktuellen Web oder Dateisystem zu finden, klicken Sie auf Durchsuchen. Wenn das ausgewählte Grafikelement Text anzeigt, sind die Optionen auf der Registerkarte Zeichen aktiviert, und Sie können die Schriftart ändern. Wiederholen Sie diesen Schritt für jedes grafische Element, und klicken Sie dann auf OK.

    • Um die Formatvorlagen zu ändern, klicken Sie auf Text.

      • Klicken Sie im Feld Element auf die Formatvorlage, die Sie ändern möchten, und klicken Sie unter Schriftart auf die zu verwendende Schriftart. Wiederholen Sie diesen Schritt für jede Formatvorlage, und klicken Sie dann auf OK.

  5. Um das Design zu speichern, klicken Sie auf Speichern unter, geben Sie einen Namen für das neue Design ein, und klicken Sie dann auf OK.


Entfernen eines Designs von ausgewählten Seiten

Sie können ein Design von ausgewählten Seiten entfernen. Dadurch werden die Formatvorlagen, Farben und Grafiken von den Seiten entfernt.

  1. Markieren Sie in der Ordneransicht die Seiten, von denen Sie ein Design entfernen möchten.
  2. Klicken Sie im Menü Format auf Design.
  3. Klicken Sie auf Ausgewählte Seiten.
  4. Klicken Sie in der Liste auf Kein Design.


Entfernen eines Designs von einem Web

Sie können ein Design entfernen, das dem aktuellen Web zugewiesen worden ist. Dadurch werden die Formatvorlagen, Farben und Grafiken von allen Seiten entfernt.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie auf Alle Seiten.
  3. Klicken Sie in der Liste auf Kein Design.

Anmerkung Wenn Sie ein Design auf ausgewählte Seiten angewendet haben (Seiten, die nicht die Standardeinstellungen des Webdesigns verwenden), müssen Sie das Design entfernen, indem Sie die einzelnen Seiten auswählen. Siehe Entfernen eines Designs von ausgewählten Seiten.


Installieren zusätzlicher Designs

Wenn Sie sich bei der Installation von Microsoft Office dafür entschieden hatten, nur die Standard Designs zu installieren, können Sie den Rest der verfügbaren Designs auch noch nachträglich installieren.

  1. Klicken Sie im Menü Format auf Design.
  2. Klicken Sie in der Liste auf Weitere Designs installieren.
  3. Klicken Sie zur Bestätigung auf Ja.


Info über gemeinsame Randbereiche

Um mehr über gemeinsame Randbereiche zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Festlegen gemeinsamer Randbereiche für alle Seiten in einem Web

Ein gemeinsamer Randbereich ist ein Seitenbereich, den eine oder mehrere Seiten in einem Web gemeinsam haben. In den gemeinsamen Randbereich setzen Sie Objekte, die auf jeder Seite angezeigt werden sollen, für die ein gemeinsamer Randbereich festgelegt wurde.

Sie können festlegen, welche gemeinsamen Randbereiche standardmäßig in einem Web verwendet werden sollen. Beispielsweise können Sie den oberen Rand als standardmäßigen gemeinsamen Randbereich definieren. Wenn Sie nun in Ihrem Web eine neue Seite erstellen, weist diese Seite automatisch den gemeinsamen oberen Randbereich auf.

Anmerkung Nachdem Sie standardmäßige gemeinsame Randbereiche für ein gesamtes Web eingerichtet haben, können Sie diese Einstellung für einzelne Seiten ändern.

  1. Klicken Sie im Menü Format auf Gemeinsame Randbereiche.
  2. Klicken Sie auf Alle Seiten.
  3. Wählen Sie die Randbereiche aus, die auf jeder Seite im aktuellen Web angezeigt werden sollen. Wenn Sie Oben oder Links wählen, können Sie auch angeben, dass Navigationsleisten eingefügt werden sollen. Weitere Informationen über Navigationsleisten und gemeinsame Randbereiche finden Sie unter Info über Navigationsleisten.

    4. Der gemeinsame Randbereich wird mithilfe von gestrichelten Linien gekennzeichnet, und Sie können nun die gewünschten Inhalte hinzufügen.

    Wenn Sie eine Navigationsleiste eingefügt haben, wird diese in dem gemeinsamen Randbereich angezeigt. Andernfalls wird ein Kommentar angezeigt, der besagt, dass Sie nun Inhalte hinzufügen können. Sie löschen diesen Kommentar, indem Sie ihn markieren und dann die ENTF-TASTE drücken.


Festlegen gemeinsamer Randbereiche für eine Seite

Ein gemeinsamer Randbereich ist ein Seitenbereich, den eine oder mehrere Seiten in einem Web gemeinsam haben. In einen gemeinsamen Randbereich übernehmen Sie Elemente, die auf jeder Seite Ihres Webs angezeigt werden sollen.

Sie können die gemeinsamen Randbereiche für jede Seite Ihres Webs festlegen. Wenn für ein Web der obere Rand als standardmäßiger gemeinsamer Randbereich festgelegt wurde, dieser Randbereich auf einer bestimmten Seite jedoch nicht angezeigt werden soll, können Sie den gemeinsamen Randbereich für diese Seite deaktivieren. Oder Sie können für ausgewählte Seiten eines Webs einen gemeinsamen Randbereich festlegen, und zwar auch dann, wenn das Web standardmäßig nicht über gemeinsame Randbereiche verfügt.

Für ein Web gilt beispielsweise als Standardeinstellung, dass der obere und untere Rand als gemeinsame Randbereiche verwendet werden. Sie setzen eine Navigationsleiste in den oberen Rand und einen Copyright-Hinweis in den unteren Rand. Auf drei Seiten soll jedoch der Copyright-Hinweis nicht angezeigt werden, also deaktivieren Sie für diese drei Seiten den unteren Rand.

  1. Klicken Sie in der Seitenansicht im Menü Format auf Gemeinsame Randbereiche.
  2. Klicken Sie auf Aktuelle Seite.
  3. Geben Sie die Ränder an, die auf dieser Seite angezeigt werden sollen.

    4. Abhängig von Ihren Einstellungen werden gemeinsame Randbereiche hinzugefügt oder entfernt. Bei neuen Randbereichen werden Platzhalterelemente wie beispielsweise ein Kommentar, ein Seitenbanner oder eine Navigationsleiste angezeigt.


Hinzufügen, Ändern oder Entfernen von Elementen in einem gemeinsamen Randbereich

Nachdem Sie einen gemeinsamen Randbereich festgelegt haben, können Sie diesem Inhalte hinzufügen. Sie können den Inhalt eines gemeinsamen Randbereichs auch an jedem beliebigen Punkt ändern oder entfernen. Beispielsweise können Sie einem gemeinsamen oberen Randbereich ein Seitenbanner hinzufügen, Sie können die Navigationsleiste ändern oder Text löschen.

  1. Öffnen Sie eine der Seiten, auf der sich der gemeinsame Randbereich befindet, den Sie ändern möchten.
  2. Klicken Sie in der Seitenansicht in den gemeinsamen Randbereich, der von einer gestrichelten Linie gekennzeichnet wird. Wenn Sie in den Bereich klicken, ändert sich die gestrichelte Linie in eine durchgezogene Linie.
  3. Nehmen Sie die gewünschten Änderungen am Inhalt des gemeinsamen Randbereichs vor. Geben Sie beispielsweise Text ein, oder fügen Sie ein Bild hinzu.
  4. Klicken Sie auf Speichern Schaltfläche "Speichern". Ihre Änderungen werden nun auf allen Seiten angezeigt, die über den gemeinsamen Randbereich verfügen.


Grundlegendes zu Frames und Framesseiten

Um mehr über Frames zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Erstellen einer Framesseite

Erstellen Sie eine Framesseite basierend auf einer Microsoft FrontPage-Vorlage für Framesseiten, und legen Sie dann die Startseite fest, die in jedem Frame angezeigt werden soll. Der hervorgehobene Rahmen zeigt den aktuellen Frame an.

Eine Framesseite ist eine spezielle Art von HTML-Seite, mit der das Browserfenster in unterschiedliche Bereiche, so genannte Frames, aufgeteilt wird, von denen jeder eine andere Seite anzeigen kann. Wenn Sie auf einer in dem einen Frame angezeigten Seite auf einen Hyperlink klicken, kann die Seite, auf die dieser Hyperlink verweist, in einem anderen Frame angezeigt werden.

Die Framesseite selbst enthält keine sichtbaren Inhalte: Sie ist lediglich ein Container, mit dem angegeben wird, welche anderen Seiten angezeigt werden und wie diese Seiten angezeigt werden.

Wenn Sie basierend auf einer der FrontPage-Dokumentvorlagen für Framesseiten eine Framesseite erstellen, wurde die Navigation zwischen den Frames bereits für Sie eingerichtet. Verwenden Sie beispielsweise die Framesseitenvorlage Inhaltsverzeichnis, wird beim Klicken auf einen Hyperlink im Inhaltsframe links eine Seite im rechts befindlichen Hauptframe (dem so genannten Zielframe) angezeigt.

  1. Zeigen Sie im Menü Datei auf Neu, klicken Sie auf Seite, und klicken Sie dann auf die Registerkarte Framesseiten.
  2. Klicken Sie auf eine der Dokumentvorlagen für Framesseiten.

    3. Tipp Wenn Sie auf eine Dokumentvorlage klicken, zeigt FrontPage eine Vorschau mit dem Frameslayout dieser Vorlage im Bereich Vorschau an. Darüber hinaus wird eine Zusammenfassung sowie ein Nutzungsvorschlag für die Vorlage im Bereich Beschreibung angezeigt.

Anmerkungen

  • Nachdem Sie eine Framesseite erstellt haben, müssen Sie die Startseite festlegen, die in jedem Frame angezeigt werden soll, wenn die Framesseite in einem Browser angezeigt wird. Andernfalls werden im Browser leere Frames angezeigt.
  • Sie können eigene, benutzerdefinierte Dokumentvorlagen für Framesseiten erstellen, diese der Registerkarte Framesseiten hinzufügen und dann gemeinsam mit Ihrer Arbeitsgruppe darauf zugreifen.
  • Sie können auch eine Framesseite erstellen, indem Sie eine Framesseite aus dem World Wide Web oder Ihrem Unternehmensintranet importieren. Hierbei werden lediglich die Framesseiten importiert und nicht die Startseiten, die anfänglich im jeweiligen Frame angezeigt werden.


Erstellen eines Hyperlinks, um eine Seite in einem anderen Frame anzuzeigen

Mit einer Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames vorgegeben. Wenn Sie in dem einen Frame auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, in einem anderen Frame angezeigt.

Wenn Sie auf einer Seite, die in einem Frame einer Framesseite angezeigt wird, auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, normalerweise in einem anderen Frame (dem so genannten Zielframe) angezeigt.

Auf Framesseiten, die Sie basierend auf FrontPage-Dokumentvorlagen für Framesseiten erstellen, wurde die Navigation zwischen den Frames bereits für Sie eingerichtet. Bei der Vorlage Inhaltsverzeichnis; wird beispielsweise mit allen Hyperlinks, die Sie auf der Seite im Inhaltsframe erstellen, automatisch eine Seite im Hauptframe angezeigt.

Anmerkung Bevor Sie das nachstehende Verfahren verwenden können, müssen Sie eine Framesseite erstellen und speichern und für den Frame, in dem Sie die Hyperlinks erstellen möchten, entweder die Startseite festlegen, die in diesem Frame angezeigt werden soll, oder in diesem Frame eine neue Seite erstellen.

  1. Öffnen Sie in der Seitenansicht die Framesseite, die Sie ändern möchten, klicken Sie auf die Registerkarte Normal, und klicken Sie dann auf die Seite, auf der Sie den Hyperlink erstellen möchten.
  2. Geben Sie den Text ein, oder wählen Sie die Grafik aus, die Sie als Hyperlink verwenden möchten, und klicken Sie dann auf die Schaltfläche Hyperlink einfügen Schaltfläche "Hyperlink einfügen".
  3. Wählen Sie im Dialogfeld Hyperlink erstellen die Seite aus, die Sie in dem anderen Frame (dem Zielframe) angezeigen möchten.


Löschen eines Frames

Verwenden Sie dieses Verfahren, um einen Frame aus einer Framesseite zu löschen.

  1. Öffnen Sie in der Seitenansicht die Framesseite, die Sie ändern möchten, klicken Sie auf die Registerkarte Normal, und wählen Sie dann den Frame aus, den Sie löschen möchten.
  2. Klicken Sie im Menü Frames auf Frame löschen.

Anmerkungen

  • Mit diesem Befehl wird nur der Frame aus der Framesseite gelöscht und nicht die Seite, die in dem Frame angezeigt wurde.
  • Jeder angrenzende Frame wird so vergrößert, dass er den Raum einnimmt, der durch das Löschen des Frames frei wurde.
  • Wenn die Framesseite nur einen Frame enthält, können Sie den letzten Frame nicht löschen. Die Seite, die im verbleibenden Frame angezeigt wird, nimmt das gesamte Browserfenster ein, wenn ein Sitebesucher diese anzeigt.


Bearbeiten des HTML-Codes einer Framesseite

Wenn Sie eine Framesseite in der Seitenansicht bearbeiten, können Sie den HTML-Code der Framesseite oder einer beliebigen anderen Seite, die in einem Frame angezeigt wird, bearbeiten.

  • Um den HTML-Code einer Framesseite zu bearbeiten, klicken Sie auf die Registerkarte HTML der Framesseite.
  • Um den HTML-Code der Seite zu bearbeiten, die in einem Frame angezeigt wird, klicken Sie auf die Seite und klicken dann auf die Registerkarte HTML.


Bearbeiten des HTML-Codes der Seite, die in einem Frame angezeigt wird

Wenn Sie eine Framesseite in der Seitenansicht bearbeiten, können Sie den HTML-Code der Seite, die in einem Frame angezeigt wird, ebenso bearbeiten wie den HTML-Code der Framesseite selbst.

  • Um den HTML-Code der Seite zu bearbeiten, die in einem Frame angezeigt wird, klicken Sie auf die Seite und klicken dann auf die Registerkarte HTML.
  • Um den HTML-Code einer Framesseite zu bearbeiten, klicken Sie auf die Registerkarte HTML der Framesseite.


Bearbeiten der in einem Frame angezeigten Seite in einem anderen Fenster

Während der Bearbeitung einer in einem Frame angezeigten Seite stellen Sie möglicherweise fest, dass der Frame zu klein ist, um die Seite bequem bearbeiten zu können. In diesem Fall können Sie die Seite zwecks Bearbeitung in einem neuen Vollbildfenster in der Seitenansicht öffnen.

  • Klicken Sie mit der rechten Maustaste an einer beliebigen Stelle auf die Seite, und klicken Sie dann im Kontextmenü auf Seite in neuem Fenster öffnen.


Umwandeln Ihrer Homepage in eine Framesseite

Beim Erstellen eines neuen Webs erstellt Microsoft FrontPage eine Datei mit Namen Index.htm (oder Default.htm, abhängig von Ihrem Server) als Ihre Homepage. Sie können diese Standardhomepage durch eine vorhandene Framesseite ersetzen.

  1. Klicken Sie in der Ordneransicht mit der rechten Maustaste auf Ihre aktuelle Homepage, klicken Sie im Kontextmenü auf Umbenennen, merken Sie sich den Namen der Seite, und geben Sie dann einen anderen Namen wie beispielsweise Default-alt.htm ein.
  2. Klicken Sie mit der rechten Maustaste auf die Framesseite, die Sie als Homepage verwenden möchten, klicken Sie wiederum im Kontextmenü auf Umbenennen, und geben Sie nun den ursprünglichen Namen Ihrer Homepage ein.

Anmerkung Wenn bei Ihrem Web gemeinsame Randbereiche oder Navigationsleisten verwendet werden oder wenn Sie bereits in der Navigationsansicht eine Navigationsstruktur erstellt haben, sollten Sie keine Framesseite als Homepage verwenden. Andernfalls könnte die Navigation in Ihrem Web schwierig werden, und die Seiten werden möglicherweise nicht ordnungsgemäß angezeigt.


Steuern wie Frames in einem Browser anzeigt werden

Sie können Bildlaufleisten oder Rahmen zwischen Frames ein- oder ausblenden, Sie können den Abstand zwischen Frames und die Breite der inneren Ränder von Frames angeben und die Größenänderung von Frames aktivieren oder deaktivieren.

In der folgenden Tabelle wird erläutert, wie Sie das Erscheinungsbild von Frames steuern können, wenn die in der Seitenansicht geöffnete Framesseite in einem Browser angezeigt wird.

Zweck | Aktion
Rahmen um Frames ein- oder ausblenden | Klicken Sie im Menü Datei auf Eigenschaften, klicken Sie auf die Registerkarte Frames, und aktivieren oder deaktivieren Sie das Kontrollkästchen Rahmen anzeigen.
Die Rahmenbreite zwischen Frames festlegen | Klicken Sie im Menü Datei auf Eigenschaften, klicken Sie auf die Registerkarte Frames, und geben Sie dann die Rahmenbreite in Pixel in das Feld Abstand ein.
Unsichtbare Frames erstellen | Klicken Sie im Menü Datei auf Eigenschaften, klicken Sie auf die RegisterkarteFrames, deaktivieren Sie das Kontrollkästchen Rahmen anzeigen, und setzen Sie dann den Wert im Feld Abstand auf 0.
Die Bildlaufleisten eines Frames ein- oder ausblenden | Klicken Sie mit der rechten Maustaste in den Frame, klicken Sie im Kontextmenü auf Frameeigenschaften, und wählen Sie dann die Einstellung Bildlaufleisten anzeigen.
Verhindern, dass Sitebesucher die Größe eines Frames ändern, wenn sie diesen in einem Browser anzeigen | Klicken Sie mit der rechten Maustaste in den Frame, klicken Sie im Kontextmenü auf Frame-Eigenschaften, und deaktivieren Sie das Kontrollkästchen Größe im Browser veränderbar.
Den Abstand zwischen dem Außenrand und dem Inhalt eines Frames einstellen | Klicken Sie mit der rechten Maustaste in den Frame, klicken Sie im Kontextmenü auf Frame-Eigenschaften, und geben Sie dann im Bereich Ränder die gewünschten Einstellungen für Breite und Höhe ein.
Die Größe eines Frames grafisch ändern | Klicken Sie auf den Rand des Frames, und ziehen Sie diesen auf die gewünschte Größe.
Die Größe eines Frames nummerisch ändern | Klicken Sie mit der rechten Maustaste in den Frame, klicken Sie im Kontextmenü auf Frame-Eigenschaften, und geben Sie dann im Bereich Framegröße die gewünschten Einstellungen für Spaltenbreite und Zeilenhöhe ein.


Ändern einer Dokumentvorlage für Framesseiten

Zum Lieferumfang von Microsoft FrontPage gehören einige Dokumentvorlagen für Framesseiten, die Sie ändern können, um Ihre eigenen, benutzerdefinierten Dokumentvorlagen zu erstellen.

  1. Zeigen Sie im Menü Datei auf Neu, klicken Sie auf Seite, und klicken Sie dann auf die Registerkarte Framesseiten.
  2. Klicken Sie auf die Framesseitenvorlage, die Sie ändern möchten, und klicken Sie dann auf OK.

    3. Tipp Wenn Sie auf eine Dokumentvorlage klicken, zeigt FrontPage eine Vorschau mit dem Frameslayout dieser Vorlage im Bereich Vorschau an. Darüber hinaus wird eine Zusammenfassung sowie ein Nutzungsvorschlag für die Dokumentvorlage im Bereich Beschreibung angezeigt.

  3. Bearbeiten Sie die Framesseite in der Seitenansicht, um so eine benutzerdefinierte Dokumentvorlage zu erstellen.

    4. Anmerkung Wenn Sie für einen beliebigen Frame eine Startseite festlegen, wird diese zur Standardstartseite des Frames in jeder Seite, die Sie basierend auf der Dokumentvorlage erstellen.

  4. Klicken Sie im Menü Datei auf Speichern unter.
  5. Klicken Sie im Feld Dateityp auf FrontPage Vorlage (*.tem).
  6. Geben Sie im Feld Datei einen Dateinamen für Ihre benutzerdefinierte Dokumentvorlage ein, und klicken Sie dann auf Speichern.
  7. Geben Sie im Dialogfeld Als Dokumentvorlage speichern im Feld Titel einen aussagekräftigen Titel für die Dokumentvorlage ein. Hierbei handelt es sich um den Titel, der in der Liste der Dokumentvorlagen auf der Registerkarte Framesseiten des Dialogfeldes Neu angezeigt wird.
  8. Geben Sie im Feld Beschreibung einen Text ein, der die Aktionen der Dokumentvorlage beschreibt. Dieser Text wird im Bereich Beschreibung der Registerkarte Framesseiten angezeigt.

Tipps

  • Um eine vorhandene benutzerdefinierte Dokumentvorlage zu ersetzen oder zu überschreiben, klicken Sie auf Durchsuchen und wählen anschließend im Feld Dokumentvorlagen die Dokumentvorlage aus, die Sie ersetzen möchten.
  • Um Ihrem aktuellen Web eine Dokumentvorlage hinzuzufügen, damit diese auch anderen Autoren zur Verfügung steht, die mit dem gleichen Web befasst sind, aktivieren Sie das Kontrollkästchen Vorlage im aktuellen Web speichern. FrontPage erstellt einen Ordner _Sharedtemplates im aktuellen Web und fügt diesem die neue Dokumentvorlage hinzu .


Ändern der Meldung "Ohne Frames" einer Framesseite

Ändern der Meldung „Ohne Frames“ einer Framesseite

Einige ältere Browser sind nicht in der Lage, Frames anzuzeigen. Stattdessen wird, wenn der Sitebesucher eine Framesseite in Ihrem Web öffnet, eine Meldung angezeigt, die besagt, dass keine Frames angezeigt werden können. Diese Meldung können Sie Ihren Vorstellungen entsprechend anpassen.

  1. Öffnen Sie hierzu die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Ohne Frames.
  2. Ändern Sie die Meldung Ihren Wünschen entsprechend. Sie können auch Grafiken, Tabellen oder jedes andere Objekt in die Meldung übernehmen, das Sie auch auf eine Seite setzen können.

Tipp Um den HTML-Code der Meldung „Ohne Frames“ direkt zu bearbeiten, klicken Sie auf die Registerkarte HTML der Framesseite.


Ändern der Zielframes auf einer Framesseite

Mit der Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames festgelegt. Wenn Sie in einem Frame auf einen Hyperlink klicken, wird die Seite, auf die der Hyperlink verweist, in einem anderen Frame angezeigt.

Wenn Sie auf einer Seite, die im Frame einer Framesseite angezeigt wird, auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, normalerweise in einem anderen Frame (dem so genannten Zielframe) der gleichen Framesseite angezeigt.

Auf Framesseiten, die Sie basierend auf FrontPage-Dokumentvorlagen für Framesseiten erstellen, wurden die Zielframes bereits für Sie eingerichtet. Bei der Dokumentvorlage Inhaltsverzeichnis wird beispielsweise mit allen Hyperlinks, die Sie auf der Seite im Inhaltsframe erstellen, automatisch eine Seite im Hauptframe angezeigt. Sie können den Zielframe für einen einzelnen Hyperlink deaktivieren oder den Standardzielframe für alle Hyperlinks auf der Seite ändern.

  1. Öffnen Sie hierzu die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal.
  2. Klicken Sie mit der rechten Maustaste auf den Hyperlink, den Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Hyperlinkeigenschaften.
  3. Klicken Sie auf Zielframe ändern Schaltfläche "Zielframe ändern".
  4. Im Dialogfeld Zielframe wird im Bereich Aktuelle Framesseite eine „Übersicht“ der Framesseite angezeigt. Klicken Sie auf den Frame, in dem die Seite angezeigt werden soll, auf die der in Schritt 2 ausgewählte Hyperlink verweist.
  5. Zum Kennzeichnen des Zielframes, den Sie als Standardzielframe für alle Hyperlinks auf der Seite ausgewählt haben, aktivieren Sie das Kontrollkästchen Als Seitenstandard festlegen. Alle Seiten, auf die Hyperlinks der aktuellen Seite verweisen, werden automatisch im angegebenen Zielframe geöffnet.

    6. Anmerkung Der Standardzielframe, den Sie hier bestimmen, gilt im aktuellen Frame auch für alle nachfolgenden Seiten, die Sie öffnen, oder neue Seiten, die Sie erstellen.


Öffnen einer Framesseite

Mit der Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames festgelegt. Wenn Sie in einem Frame auf einen Hyperlink klicken, wird die Seite, auf die der Hyperlink verweist, in einem anderen Frame angezeigt.

Eine Framesseite ist eine spezielle Art von HTML-Seite, mit der das Browserfenster in unterschiedliche Bereiche, so genannte Frames, aufgeteilt wird, von denen jeder eine andere Seite anzeigen kann. Wenn Sie auf einer Seite, die in einem Frame angezeigt wird, auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, in einem anderen Frame angezeigt.

Die Framesseite selbst enthält keine sichtbaren Inhalte: Sie ist lediglich ein Container, mit dem angegeben wird, welche anderen Seiten angezeigt werden und wie diese Seiten angezeigt werden.

Gehen Sie gemäß dem nachstehenden Verfahren vor, um eine vorhandene Framesseite in einer beliebigen Ansicht zu öffnen. Sie können dann die Größe und das Erscheinungsbild der Framesseite selbst ändern, und Sie können die einzelnen Seiten erstellen oder bearbeiten, die im jeweiligen Frame angezeigt werden.

  • Klicken Sie im Menü Datei auf Öffnen, und wählen Sie die Framesseite aus, die Sie öffnen möchten.

Tipp Wenn Sie die Seite, die in einem Frame angezeigt wird, in einem anderen Fenster bearbeiten möchten, klicken Sie mit der rechten Maustaste auf die Seite und klicken dann im Kontextmenü auf Seite in neuem Fenster öffnen.


Umbenennen eines Frames

Eine Framesseite, die mit der Framesseitenvorlage "Banner und Inhaltsverzeichnis" erstellt wurde. Sie enthält drei Frames mit den Bezeichnungen Banner, Inhaltsverzeichnis und Hauptframe.

Jeder Frame in einer Framesseite trägt einen eindeutigen Namen, der zum Einrichten der Navigation zwischen Frames benötigt wird. Wenn Sie beispielsweise in der Framesseitenvorlage Inhaltsverzeichnis, die zum Lieferumfang von Microsoft FrontPage gehört, links auf einen Hyperlink klicken, wird im Hauptframe rechts eine Seite angezeigt.

Wenn Sie die Framesseite basierend auf Inhaltsverzeichnis oder einer anderen Dokumentvorlage für Framesseiten erstellt haben, wurden die Namen der Frames bereits für Sie festgelegt. Diese Standardframesnamen können geändert werden.

  1. Öffnen Sie hierzu die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal.
  2. Klicken Sie mit der rechten Maustaste an beliebiger Stelle in den Frame, den Sie umbenennen möchten, und klicken Sie dann im Kontextmenü auf Frameeigenschaften.
  3. Geben Sie im Feld Name den neuen Namen des Frames ein.

Wichtig Wenn Sie einen Frame umbenennen, sind damit alle bestehenden Hyperlinks an beliebigen Positionen in Ihrem Web, die auf den alten Framenamen verweisen, außer Funktion gesetzt. Sie müssen jedes Auftreten eines solchen Hyperlinks in Ihrem Web finden, den Hyperlink bearbeiten und im Feld Zielframe den neuen Framenamen eingeben.


Ändern der Größe eines Frames

Wenn Sie die Größe eines Frames ändern, während Sie eine Framesseite bearbeiten, wird die Größe benachbarter Frames ebenfalls entsprechend geändert, um den sich hierbei ergebenden Raum auszufüllen. Das Ändern der Größe eines Frames hat keine Auswirkungen auf den Inhalt beliebiger Seiten, die in diesem Frame angezeigt werden, es ändert sich lediglich der Anteil der Seite, der gleichzeitig im Frame angezeigt werden kann.

  • Öffnen Sie die Framesseite, die Sie ändern möchten, in der Seitenansicht, klicken Sie auf den Rand eines beliebigen Frames, und ziehen Sie diesen auf die gewünschte Größe.
  • Sie können die Größe eines Frames auch präzise festlegen. Klicken Sie hierzu mit der rechten Maustaste in den Frame, klicken Sie im Kontextmenü auf Frameeigenschaften, und geben Sie dann im Bereich Framegröße in die Felder Breite und Höhe die gewünschten Werte ein. Sie können die Framegröße als festgelegte Anzahl Pixel oder als Prozentsatz der Größe des Browserfensters angeben, oder Sie können die Größe relativ zur Größe anderer Frames in der gleichen Zeile oder Spalte angeben.

Anmerkungen

  • Befindet sich der Frame in der gleichen Zeile wie ein anderer Frame, ändert sich das Feld Höhe zum Feld Zeilenhöhe. Ändern Sie also die Zeilenhöhe des aktuellen Frames, ändert sich auch die Zeilenhöhe jedes anderen Frames in dieser Zeile.
  • Ebenso ändert sich das Feld Breite zu Spaltenbreite, wenn der Frame Teil einer Spalte ist, und auch der Effekt ist der gleiche.
  • Bevor Sie die Art der Bemaßung eines Frames ändern (in Pixeln, als Prozentsatz oder relativ zu anderen Frames), bedenken Sie, welche Auswirkungen diese Änderung auf das Layout Ihres Entwurfs und das Verhalten der gesamten Framesseite hat, wenn diese in einem Browser angezeigt wird.
  • Um zu verhindern, dass ein Sitebesucher die Größe eines Frames ändert, wenn er die Framesseite in einem Browser anzeigt, klicken Sie mit der rechten Maustaste in den Frame, klicken im Kontextmenü auf Frameeigenschaften und deaktivieren das Kontrollkästchen Größe im Browser veränderbar.


Speichern einer Framesseite

Mit der Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames festgelegt. Wenn Sie in einem Frame auf einen Hyperlink klicken, wird die Seite, auf die der Hyperlink verweist, in einem anderen Frame angezeigt.

Eine Framesseite ist eine spezielle Art von HTML-Seite, die keinen sichtbaren Inhalt hat: Sie ist lediglich ein Container, der angibt, welche anderen Seiten angezeigt werden und wie diese Seiten angezeigt werden sollen. Sie können die Framesseite selbst speichern, und Sie können die einzelnen Seiten speichern, die in jedem Frame angezeigt werden.

  1. Klicken Sie hierzu in der Seitenansicht der Framesseite, die Sie speichern möchten, auf die Registerkarte Normal.
  2. Klicken Sie auf die Seite oder den Frame, in dem die Seite angezeigt wird, die Sie speichern möchten, und klicken Sie dann auf Speichern Schaltfläche "Speichern".

    3. Im Dialogfeld Speichern unter wird eine Vorschau des Layouts der Framesseite angezeigt. Was Sie speichern, wird von einem dunkelblauen Rahmen markiert:

    • Ist der gesamte äußere Rahmen der Framesseite markiert, speichern Sie die Framesseite selbst.
    • Ist ein einzelner Frame markiert, speichern Sie die Seite, die in diesem Frame angezeigt wird.
  3. Geben Sie im Feld Dateiname eine Namen ein, oder wählen Sie einen Namen für die markierte Framesseite oder für die Seite, die im markierten Frame angezeigt wird, aus.

Microsoft FrontPage wiederholt diese Abfolge für jede nicht gespeicherte neue Seite oder jede neue Framesseite, bis alle Seiten und die Framesseite gespeichert wurden.

Tipp Zum Ändern des Titels der Seite (das ist der Text, der in der Titelleiste eines Browser angezeigt werden soll) klicken Sie auf Ändern und geben dann im Dialogfeld Seitentitel festlegen den gewünschten neuen Seitentitel ein.


Speichern einer Framesseite als Dokumentvorlage

Gehen Sie gemäß dem nachstehenden Verfahren vor, wenn Sie Ihre eigenen benutzerdefinierten Framesseiten als Dokumentvorlagen speichern und der Liste hinzufügen möchten, die auf der Registerkarte Framesseiten angezeigt wird.

  1. Ändern Sie in der Seitenansicht die Framesseite, aus der Sie eine benutzerdefinierte Dokumentvorlage erstellen möchten.

    2. Anmerkung Wenn Sie für irgendeinen Frame eine Startseite festlegen, wird diese zur Standardstartseite des Frames auf jeder Seite, die Sie basierend auf der Dokumentvorlage erstellen.

  2. Klicken Sie im Menü Datei auf Speichern unter.
  3. Klicken Sie im Feld Dateityp auf FrontPage-Vorlage (*.tem).
  4. Geben Sie im Feld Datei einen Dateinamen für Ihre benutzerdefinierte Dokumentvorlage ein, und klicken Sie dann auf Speichern.
  5. Geben Sie im Feld Titel des Dialogfeldes Als Vorlage speichern einen aussagekräftigen Titel für die Vorlage ein. Hierbei handelt es sich um den Titel, der in der Liste der Dokumentvorlagen auf der Registerkarte Framesseiten des Dialogfeldes Neu angezeigt wird.
  6. Geben Sie im Feld Beschreibung einen Text ein, der die Aktionen der Dokumentvorlage beschreibt. Dieser Text wird im Bereich Beschreibung der Registerkarte Framesseiten angezeigt.

Tipps

  • Um eine vorhandene benutzerdefinierte Dokumentvorlage zu ersetzen oder zu überschreiben, klicken Sie auf Durchsuchen und wählen anschließend im Feld Dokumentvorlagen die Dokumentvorlage aus, die Sie ersetzen möchten.
  • Wenn Sie Ihrem aktuellen Web eine Dokumentvorlage hinzufügen möchten, damit diese auch anderen Autoren zur Verfügung steht, die mit dem gleichen Web befasst sind, aktivieren Sie das Kontrollkästchen Vorlage im aktuellen Web speichern. FrontPage erstellt dann einen Ordner _Sharedtemplates im aktuellen Web und fügt diesem die neue Dokumentvorlage hinzu.


Speichern der Seite, die in einem Frame angezeigt wird

Mit der Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames festgelegt. Wenn Sie in einem Frame auf einen Hyperlink klicken, wird die Seite, auf die der Hyperlink verweist, in einem anderen Frame angezeigt.

Eine Framesseite ist eine spezielle Art von HTML-Seite, die keinen sichtbaren Inhalt hat: Sie ist lediglich ein Container, der angibt, welche anderen Seiten angezeigt werden und wie diese Seiten angezeigt werden sollen. Sie können die Seite, die in einem Frame angezeigt wird, oder die Framesseite selbst speichern.

  1. Klicken Sie hierzu in der Seitenansicht der Framesseite, die Sie ändern möchten, auf die Registerkarte Normal.
  2. Klicken Sie auf die Seite oder den Frame, in dem die Seite angezeigt wird, die Sie speichern möchten, um sie oder ihn zu markieren, und klicken Sie dann im Menü Frames auf Seite speichern.
  3. Wenn Sie die Seite zuvor bereits gespeichert hatten, speichert Microsoft FrontPage alle von Ihnen vorgenommen Änderungen, ohne eine Bestätigung anzufordern.

    4. Wenn Sie die Seite vorher noch nicht gespeichert hatten, wird im Dialogfeld Speichern unter eine Vorschau des Layouts der Framesseite angezeigt. Ein dunkelblauer Rahmen kennzeichnet die aktuelle Seite im markierten Frame.

  4. Geben Sie im Feld Dateiname den gewünschten Namen ein, oder wählen Sie den entsprechenden Dateinamen für die Seite aus, die im markierten Frame in der Vorschau angezeigt wird.
  5. Wählen Sie im Feld Dateityp den Typ der Webseite aus, die Sie speichern möchten.
  6. Zum Ändern des Titels der Seite (das ist der Text, der in der Titelleiste eines Browser angezeigt werden soll) klicken Sie auf Ändern, und geben Sie dann im Dialogfeld Seitentitel festlegen den gewünschten neuen Seitentitel ein.

Tipp Wenn Sie eine Kopie der Seite speichern oder die Seite unter einem anderen Dateinamen, an einer anderen Speicherposition oder als anderen Dateityp (beispielsweise als Dokumentvorlage) ablegen möchten, klicken Sie, nachdem Sie eine Seite gespeichert haben, die in einem Frame angezeigt wird, im Menü Frames auf Speichern unter.


Festlegen von Framerändern

Sie können Bildlaufleisten oder Rahmen zwischen Frames ein- oder ausblenden, Sie können den Abstand zwischen Frames und die inneren Ränder von Frames angeben und die Größenänderung von Frames aktivieren oder deaktivieren.

Bei der Anzeige einer Framesseite in einem Browser wird der Abstand zwischen dem Rand eines Frames und dem Rand der Seite, die in dem Frame angezeigt wird, als Framerand bezeichnet.

  1. Öffnen Sie die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal.
  2. Klicken Sie mit der rechten Maustaste in den Frame, dessen Rand Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Frameeigenschaften.
  3. Legen Sie im Bereich Ränder die Breite und Höhe des Framerands in Pixel fest.

Anmerkungen

  • Wenn Framerahmen aktiviert sind, wird der Framerand von der Innenkante des Framerahmens anstatt von der Innenkante des Frames gemessen. Anders ausgedrückt, ein 3 Pixel breiter Framerahmen plus ein auf 12 Pixel gesetzter Framerand würde einem gesamten Framerand von 15 Pixeln entsprechen.
  • Wenn die im Frame angezeigte Seite ebenfalls über Ränder verfügt, werden die Ränder der Seite zum Framerand hinzuaddiert.


Festlegen des Abstands zwischen Frames

Sie können Bildlaufleisten oder Rahmen zwischen Frames ein- oder ausblenden, Sie können den Abstand zwischen Frames und die inneren Ränder von Frames angeben und die Größenänderung von Frames aktivieren oder deaktivieren.

Sie können den Abstand zwischen den Außenkanten benachbarter Frames angeben, wenn eine Framesseite in einem Browser angezeigt wird.

  1. Öffnen Sie hierzu die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal.
  2. Klicken Sie im Menü Datei auf Eigenschaften, und klicken Sie dann auf die Registerkarte Frames.
  3. Geben Sie im Feld Abstand den gewünschten Abstand in Pixel ein. Für die meisten Webbrowser gelten standardmäßig 2 Pixel.

Tipps

  • Wenn das Kontrollkästchen Rahmen anzeigen aktiviert ist, sind die Rahmen zwischen den Frames ebenso breit wie der Abstand zwischen den Frames.
  • Wenn Sie unsichtbare Frames erstellen möchten, deaktivieren Sie das Kontrollkästchen Rahmen anzeigen und setzen den Wert für Abstand auf 0.


Festlegen der Startseite, die in einem Frame angezeigt wird

Wenn eine Framesseite von einem frameskompatiblen Browser gedownloadet wird, liest dieser die Frame-Informationen und zeigt dann die Startseite jedes Frames an. Sie müssen also die Startseite angeben, die der Browser in jedem Frame anzeigen soll.

  • Öffnen Sie die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal. Klicken Sie in den Frame, dessen Startseite Sie festlegen möchten.
    • Wenn Sie eine bereits in Ihrem Web vorhandene Seite als Startseite dieses Frames auswählen möchten, klicken Sie im Frame auf Startseite festlegen, und wählen Sie dann die Seite aus, die angezeigt werden soll.
    • Wenn Sie eine neuen Seite erstellen und diese als Startseite für den Frame festlegen möchten, klicken Sie in diesem Frame auf Neue Seite. Microsoft FrontPage erstellt nun eine neue Seite im Frame, und diese neue Seite wird automatisch als Startseite des Frames festgelegt.

Tipp Wenn bereits eine Startseite festgelegt wurde und Sie diese ändern möchten, klicken Sie mit der rechten Maustaste in den Frame, klicken im Kontextmenü auf Frameeigenschaften und geben dann im Feld Startseite den URL der Startseite an, die angezeigt werden soll. Sie können auch auf Durchsuchen klicken, wenn Sie die Seite suchen möchten.


Einblenden oder Ausblenden von Framerahmen

Sie können Bildlaufleisten oder Rahmen zwischen Frames ein- oder ausblenden, Sie können den Abstand zwischen Frames und die inneren Ränder von Frames angeben und die Größenänderung von Frames aktivieren oder deaktivieren.

Sie können angeben, ob die Rahmen zwischen den Frames eingeblendet oder ausgeblendet werden sollen, wenn eine Framesseite in einem Browser angezeigt wird.

  1. Öffnen Sie hierzu die Framesseite, die Sie ändern möchten, in der Seitenansicht, und klicken Sie dann auf die Registerkarte Normal.
  2. Klicken Sie im Menü Datei auf Eigenschaften, und klicken Sie dann auf die Registerkarte Frames:
    • Zum Einblenden der Rahmen zwischen den Frames aktivieren Sie das Kontrollkästchen Rahmen anzeigen, und geben Sie anschließend im Feld Abstand die Breite für die Rahmen in Pixel ein. Der Standardwert für die meisten Webbrowser beträgt 2 Pixel.
    • Zum Ausblenden der Rahmen zwischen den Frames deaktivieren Sie das Kontrollkästchen Rahmen anzeigen.

Tipp Wenn Sie unsichtbare Frames erstellen möchten, deaktivieren Sie das Kontrollkästchen Rahmen anzeigen und setzen den Wert für Abstand auf 0.


Teilen eines Frames

Auf jeder Framesseite können Sie einen Frame horizontal oder vertikal teilen, um auf diese Weise zwei Frames zu erstellen.

  • Öffnen Sie die Framesseite, die Sie ändern möchten, in der Seitenansicht, halten Sie die STRG-TASTE gedrückt, und ziehen Sie den Rand eines beliebigen Frames in die gewünschte Position.

Anmerkungen

  • Wenn Sie einen Frame in zwei exakt gleich große Zeilen oder Spalten teilen möchten, klicken Sie im Menü Frames auf Frame teilen und wählen Sie dann die gewünschte Option.
  • Das Teilen eines Frames hat keinerlei Auswirkungen auf den Inhalt der Seite, die im Originalframe angezeigt wird.


Wechseln zwischen den Frames in einer Framesseite

Wenn Sie eine Framesseite in der Seitenansicht bearbeiten, können Sie immer nur eine Seite in einem Frame gleichzeitig bearbeiten. Der aktuelle Frame oder die aktuelle Framesseite wird von einem dunkelblauen Rand gekennzeichnet.

  • Klicken Sie in den Frame, den Sie ändern möchten, oder drücken Sie F6 oder UMSCHALT+F6, um den aktuellen Frame zu wechseln. Jedes Mal, wenn Sie in einen Frame klicken oder F6 oder UMSCHALT+F6 drücken, verschiebt sich die Markierung, um den aktuellen Frame zu kennzeichnen.


Anzeigen oder Bearbeiten einer Framesseite in einem Frame

In einem Frame kann eine weitere Framesseite angezeigt oder es kann auf diese verwiesen werden. Dies wird als „Verschachteln“ von Framesseiten bezeichnet (da sich diese verschachtelt im Frame einer anderen Framesseite befindet). Allerdings können Sie eine verschachtelte Framesseite nicht direkt anzeigen oder bearbeiten, wenn für die übergeordnete Framesseite die Registerkarte Normal gewählt wurde.

  • Wenn Sie sehen möchten, wie die übergeordnete Framesseite, die die verschachtelte(n) Framesseite(n) enthält, aussieht, wenn ein Sitebesucher sie in einem Browser anzeigt, klicken Sie auf die Registerkarte Vorschau.
  • Zum Bearbeiten einer in einem Frame verschachtelten Framesseite klicken Sie innerhalb des Frames auf die Schaltfläche Framesseite anzeigen. FrontPage öffnet nun die verschachtelte Framesseite in der Seitenansicht.


Arbeiten mit Cascading Stylesheets

Um mehr über Cascading Stylesheets zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Ändern einer Formatvorlage für eine Seite

Sie können die Formateigenschaften einer beliebigen HTML-Standardformatvorlage oder einer benutzerdefinierten Formatvorlage, die im Feld Formatvorlage aufgeführt ist, ändern. Sie können z. B. der Standardüberschrift „Überschrift 1“ eine rote Schriftart zuweisen. Die Änderung wird automatisch allen Elementen auf der Seite zugewiesen, die als Überschrift 1 ausgezeichnet sind.

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Klicken Sie im Menü Format auf Formatvorlage.
  2. Klicken Sie im Feld Liste auf die Formatvorlagenart, die Sie ändern möchten:
    • Zum Ändern einer benutzerdefinierten Formatvorlage, die Sie erstellt haben, klicken Sie auf Benutzerdefinierte Formatvorlagen.
    • Zum Ändern eines Standard-HTML-Tags klicken Sie auf Alle HTML-Tags.
  3. Doppelklicken Sie im Listenfeld Formatvorlagen auf die Formatvorlage, die Sie ändern möchten.
  4. Klicken Sie auf Format, und ändern Sie dann die Formateigenschaften:
    • Zum Festlegen von Schriftarteneigenschaften, wie z. B. Schriftartenfamilie, Schriftfarbe oder Zeichenabstand, klicken Sie auf Zeichen.
    • Zum Festlegen von Ausrichtung, Einrückung oder Abständen klicken Sie auf Absatz.
    • Zum Festlegen von Rahmen und Schattierungen klicken Sie auf Rahmen.
    • Zum Festlegen des Stils für Aufzählungszeichen oder Nummerierungen klicken Sie auf Nummerierung.
    • Zum Festlegen von Positionierungseigenschaften, wie z. B. Umbruchart, Position oder Z-Ordnung, klicken Sie auf Position.

Anmerkungen

  • Wenn die Seite mit einem externen Stylesheet verknüpft ist, kann die Liste der verfügbaren Formatvorlagen, die Sie zuweisen können (im Feld Formatvorlage aufgeführt), benutzerdefinierte Formatvorlagen (Vorlagen, vor denen ein Punkt oder andere Zeichen stehen, wie z. B. „.Formatvorlage1“ oder „Überschrift1.Formatvorlage1“) aus dem externen Stylesheet enthalten. Wenn Sie eine benutzerdefinierte Formatvorlage aus einem externen Stylesheet ändern möchten, müssen Sie das externe Stylesheet bearbeiten.
  • Dieses Verfahren ändert eine Formatvorlage für eine Seite durch Erstellen oder Bearbeiten eines integrierten Stylesheets in den HEAD-Tags der Seite. Die Formatvorlageninformationen werden im eingebetteten Stylesheet gespeichert.
  • Wenn die Seite auch mit einem externen Stylesheet verknüpft ist und das externe Stylesheet eine Formatvorlage gleichen Namens enthält, werden die Formateigenschaften beider Vorlagen beim Zuweisen zu einem Seitenelement zusammengeführt. Wenn z. B. die Formatvorlage „.Tipp“ im eingebetteten Stylesheet einen blauen Rahmen und im externen Stylesheet einen roten Hintergrund hinzufügt, wird beim Zuweisen der Formatvorlage „.Tipp“ sowohl ein blauer Rahmen als auch ein roter Hintergurnd zugewiesen. Wenn es Eigenschaften gibt, die sich widersprechen (wenn z. B. eine Vorlage einen grünen und die andere gleichen Namens einen schwarzen Rahmen zuweist), werden die Eigenschaften des eingebetteten Stylesheets verwendet und damit die Eigenschaften des externen Stylesheets überschrieben.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Erstellen einer Formatvorlage für eine Seite

Sie können eine neue Formatvorlage erstellen und zu den Standard-HTML-Formatvorlagen hinzufügen, die im Feld Formatvorlage aufgeführt sind. Autoren, die diese Seite bearbeiten, können die neue Formatvorlage dann für beliebige Elemente auf der Seite verwenden, einschließlich Text, Absätze, Bilder und Tabellen. Die neue Formatvorlage kann einem Seitenelement auch zusammen mit einer Standard-HTML-Formatvorlage zugewiesen werden. Das Ergebnis ist in diesem Fall eine Kombination der beiden Formatvorlagen.

Wenn Sie z. B. eine Formatvorlage namens „HGrot“ erstellt haben, die ein Seitenelement mit einem roten Hintergrund versieht, wird dieses im Feld Formatvorlage mit der Bezeichnung .HGrot aufgeführt. Wenn Sie die Formatvorlage „HGrot“ zuweisen, wird der Hintergrund des ausgewählten Seitenelements rot. Wenn Sie demselben Element eine Standard-HTML-Formatvorlage, wie z. B. „Überschrift1“, zuweisen, erhält das Seitenelement die Formate beider Vorlagen. Dies wird im Feld Formatvorlage mit der Bezeichnung Überschrift1.HGrot gekennzeichnet.

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Klicken Sie im Menü Format auf Formatvorlage.
  2. Klicken Sie auf Neu, und geben Sie dann in das Feld Name den Namen der neuen Formatvorlage ein.
  3. Klicken Sie auf Format, und geben Sie dann Formateigenschaften für die neue Formatvorlage ein:
    • Klicken Sie auf Zeichen, um Schriftarteneigenschaften, wie z. B. Schriftartenfamilie, Schriftfarbe oder Zeichenabstände festzulegen.
    • Klicken Sie auf Absatz, um Ausrichtung, Einrückung oder Abstände festzulegen.
    • Klicken Sie auf Rahmen, um Rahmen und Schattierungen festzulegen.
    • Klicken Sie auf Nummerierung, um das Format für Aufzählungszeichen und Nummerierungen festzulegen.
    • Klicken Sie auf Position, um Positionierungseigenschaften, wie z. B. Umbruchart, Position oder Z-Ordnung festzulegen.

Anmerkungen

  • Formatvorlagen, die Sie für eine bestimmte Seite festlegen, können nicht für andere Seiten verwendet werden. Wenn Sie Formatvorlagen erstellen möchten, die für beliebige oder alle Seiten eines Webs verwendet werden können, erstellen Sie ein externes Stylesheet (oder bearbeiten Sie ein externes Stylesheet). Dazu fügen Sie die gewünschten Formatvorlagen hinzu und verknüpfen Seiten mit dem externen Stylesheet.
  • Dieses Verfahren erstellt eine Formatvorlage für eine Seite durch Ablegen eines eingebetteten Stylesheets unter Verwendung von STYLE-Tags in den HEAD-Tags der Seite. Die Formatvorlage wird innerhalb des eingebettete Stylesheets als CSS-Klassenselektor gespeichert und in HTML auf der Seite als CLASS-Attribut zum HTML-Tag hinzugefügt.
  • Wenn die Seite auch mit einem externen Stylesheet verknüpft ist und das externe Stylesheet eine Formatvorlage gleichen Namens enthält, werden die Formateigenschaften dieser beiden Vorlagen kombiniert. Wenn z. B. die Formatvorlage „.Tipp“ im eingebetteten Stylesheet einen blauen Rahmen und im externen Stylesheet einen roten Hintergrund hinzufügt, wird beim Zuweisen der Formatvorlage „.Tipp“ sowohl ein blauer Rahmen als auch ein roter Hintergurnd zugewiesen. Wenn es Eigenschaften gibt, die sich widersprechen (wenn z. B. eine Vorlage einen grünen und die andere gleichen Namens einen schwarzen Rahmen zuweist), werden die Eigenschaften des eingebetteten Stylesheets verwendet und damit die Eigenschaften des externen Stylesheets überschrieben.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Löschen einer Formatvorlage von einer Seite

Im Feld Formatvorlage sind benutzerdefinierte Formatvorlagen, die Sie erstellt haben, durch einen vorangestellten Punkt gekennzeichnet (z. B. „.Formatvorlage1“), um diese von den Standard-HTML-Formatvorlagen unterscheiden zu können. Sie können beliebige Formatänderungen, die Sie an einer Standard-HTML-Formatvorlage vorgenommen haben, ebenfalls wieder entfernen.

Anmerkung Wenn die Seite mit einem externen Stylesheet verknüpft ist, kann die Liste der verfügbaren Formatvorlagen (im Feld Formatvorlage) auch benutzerdefinierte Formatvorlagen aus dem externen Stylesheet enthalten. Wenn Sie eine benutzerdefinierte Formatvorlage aus einem externen Stylesheet entfernen möchten, müssen Sie das externe Stylesheet bearbeiten.

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Klicken Sie im Menü Format auf Formatvorlage.
  2. Klicken Sie im Feld Liste auf Benutzerdefinierte Formatvorlagen.
  3. Klicken Sie im Listenfeld Formatvorlage auf die benutzerdefinierte Formatvorlage, die Sie löschen möchten, oder auf die Standard-HTML-Formatvorlage, aus der Sie benutzerdefinierte Formateigenschaften entfernen möchten, und klicken Sie dann auf Löschen.

Anmerkungen

  • Dieses Verfahren löscht eine Formatvorlage aus einer Seite durch Bearbeiten eines eingebetteten Stylesheets in den HEAD-Tags der Seite. Die benutzerdefinierten Formatvorlageninformationen oder die Formatänderungen an einer Standard-HTML-Formatvorlage werden im eingebetteten Stylesheet gespeichert.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Erstellen oder Ändern eines Klassen- oder ID-Selektors

Wenn Sie eine Formatvorlage für eine Seite unter Verwendung des Befehls Formatvorlage aus dem Menü Format erstellen oder ändern, speichert Microsoft FrontPage die Formatvorlage innerhalb des eingebetteten Stylesheets auf der Seite als Klassenselektor.

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Klicken Sie im Menü Format auf Formatvorlage.
    • Zum Erstellen eines neuen Klassenselektors klicken Sie auf Neu und geben dann in das Feld Name einen Punkt (.), gefolgt vom Selektornamen ein.
    • Zum Erstellen eines neuen ID-Selektors klicken Sie auf Neu und geben dann im Feld Name ein Nummernzeichen (#), gefolgt vom ID-Selektornamen ein (z. B. #Fußzeile).
    • Zum Ändern eines vorhandenen Klassen- oder ID-Selektors doppelklicken Sie im Feld Formatvorlage auf den entsprechenden Namen.
  2. Klicken Sie auf Format, und legen Sie dann die Formateigenschaften für den Klassen- oder den ID-Selektor fest:
    • Klicken Sie auf Zeichen, um Schriftarteneigenschaften, wie z. B. Schriftartenfamilie, Schriftfarbe oder Zeichenabstände festzulegen.
    • Klicken Sie auf Absatz, um Ausrichtung, Einrückung oder Abstände festzulegen.
    • Klicken Sie auf Rahmen, um Rahmen und Schattierungen festzulegen.
    • Klicken Sie auf Nummerierung, um das Format für Aufzählungszeichen und Nummerierungen festzulegen.
    • Klicken Sie auf Position, um Positionierungseigenschaften, wie z. B. Umbruchart, Position oder Z-Ordnung festzulegen.

Anmerkungen

  • Um einen Klassen- oder ID-Selektor in einem externen Stylesheet zu erstellen oder zu ändern, müssen Sie das externe Stylesheet bearbeiten.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Zuweisen einer Formatvorlage zu einem Seitenelement

Eine Formatvorlage enthält Formatinformationen, wie z. B. Schriftart, Hintergrundfarbe oder Rahmenart, die nahezu allen Elementen auf einer Seite zugewiesen werden können, einschließlich Text, Absätze, Bilder und Tabellen. Wenn Sie die Formatvorlage ändern, werden alle Seitenelemente, denen diese Vorlage zugewiesen ist, automatisch entsprechend aktualisiert.

Das Listenfeld Formatvorlage zeigt die Standard-HTML-Formatvorlagen, wie z. B. „Überschrift 1“, sowie alle für die Seite erstellten oder in einem mit der Seite verknüpften externen Stylesheet enthaltenen benutzerdefinierten Formatvorlagen an. Vor benutzerdefinierten Formatvorlagennamen steht in der Regel ein Punkt (.) oder ein anderes Zeichen, um diese von anderen unterscheiden zu können. z. B. „.HGrot“ oder „#Tipp“.

  • Um auf der Registerkarte Standard der Seitenansicht eine Formatvorlage zuzuweisen, wählen Sie das Seitenelement aus, dem Sie die Vorlage zuweisen möchten, und klicken dann im Feld Formatvorlage auf die gewünschte Formatvorlage.

Anmerkungen

  • Um einem Seitenelement einen Klassen- oder einen ID-Selektor zuzuweisen, klicken Sie mit der rechten Maustaste auf das Seitenelement. Anschließend klicken Sie im Kontextmenü auf Eigenschaften und dann auf Formatvorlage.
  • Wenn Sie eine benutzerdefinierte Formatvorlage aus einem integrierten oder einem externen Stylesheet zuweisen, wird diese Vorlage am Ende eines Standard-HTML-Formatvorlagennamens aus dem Feld Formatvorlage angefügt, und die Formate der benutzerdefinierten Vorlage werden mit den Formaten der Standard-HTML-Formatvorlage kombiniert. Die Formatvorlage wird in HTML auf der Seite als CLASS-Attribut zum HTML-Tag des entsprechenden Seitenelements hinzugefügt.

    • Wenn Sie z. B. einen Absatz mit der Formatvorlage „Überschrift2“ auswählen und dann eine benutzerdefinierte Formatvorlage namens „.HGrot“ zuweisen, die einen roten Hintergrund hinzufügt, wird die Formatvorlage im Feld Formatvorlage unter dem Namen Überschrift2.HGrot aufgeführt. FrontPage kombiniert die Formateigenschaften der beiden Formatvorlagen beim Zuweisen.

  • Zum Entfernen einer benutzerdefinierten Formatvorlage von einem Seitenelement, dem sie zugewiesen worden war, klicken Sie auf eine beliebige Standard-HTML-Formatvorlage im Feld Formatvorlage, z. B. auf „Überschrift1“ oder auf „Standard“.
  • Zum Kopieren einer Formatvorlage von einem Seitenelement auf ein anderes, wählen Sie das Seitenelement aus, dessen Formatvorlage Sie kopieren möchten. Anschließend klicken Sie auf Format übertragen Schaltfläche "Format übertragen" und dann auf das Seitenelement, dem Sie die Formatvorlage zuweisen möchten.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Zuweisen einer eingebetteten Formatvorlage zu einem Seitenelement

In Microsoft FrontPage 2000 werden bestimmte Formatierungsfunktionen jetzt automatisch als eingebettete Formatvorlagen zugewiesen. Wenn Sie z. B. einem normalen Absatz mithilfe des Befehls Rahmen und Schattierung aus dem Menü Format einen Rahmen zuweisen, schreibt FrontPage die Formatinformationen als eingebettetes Formatvorlagenattribut für den Absatztag (z. B. <p style="border-style: solid">).

Für bestimmte Seitenelemente, wie Tabellen oder Formularfelder, können Sie eingebettete Formatvorlagen folgendermaßen zuweisen:

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Wählen Sie das Seitenelement aus, das Sie ändern möchten, und klicken Sie dann im Menü Format auf Eigenschaften.
  2. Klicken Sie im Dialogfeld Eigenschaften dieses Elements auf Formatvorlage.

    3. Das Dialogfeld Formatvorlage ändern wird angezeigt.

  3. Klicken Sie auf Format, und legen Sie dann die Formateigenschaften fest, die Sie als eingebettete Formatvorlage zuweisen möchten:
    • Klicken Sie auf Zeichen, um Schriftarteneigenschaften, wie z. B. Schriftartenfamilie, Schriftfarbe oder Zeichenabstände festzulegen.
    • Klicken Sie auf Absatz, um Ausrichtung, Einrückung oder Abstände festzulegen.
    • Klicken Sie auf Rahmen, um Rahmen und Schattierungen festzulegen.
    • Klicken Sie auf Nummerierung, um das Format für Aufzählungszeichen und Nummerierungen festzulegen.
    • Klicken Sie auf Position, um Positionierungseigenschaften, wie z. B. Umbruchart, Position oder Z-Ordnung, festzulegen.

    Anmerkung Wenn das Feld Klasse oder ID einen Text oder eine Auswahl enthält, deaktivieren Sie das Feld vor dem Klicken auf OK. Andernfalls werden die Formate u. U. versehentlich über einen vorhandenen Klassen- oder ID-Selektor für diese Seite gespeichert.

Anmerkungen

  • Sie können eingebettete Formatvorlagen auch unter Verwendung der Befehle Rahmen und Schattierung, Position und Absatz aus dem Menü Format zuweisen. Einige Attribute werden jedoch unter Verwendung von CSS, andere unter Verwendung von HTML zugewiesen. Wenn Sie eingebettete Formatvorlagen allein unter Verwendung von CSS zuweisen möchten, führen Sie das oben beschriebene Verfahren durch.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Zuweisen eines Klassen- oder ID-Selektors

Wenn Sie eine Seite auf der Registerkarte Normal der Seitenansicht ändern, können Sie jedem beliebigen Element auf dieser Seite einen Klassen- oder ID-Selektor aus einem eingebetteten oder einem externen Stylesheet zuweisen. Klassenselektoren sind im Feld Formatvorlage aufgelistet. Am einfachsten weisen Sie einen Klassenselektor durch Auswählen des Seitenelements und Klicken auf den gewünschten Klassenselektor im Feld Formatvorlage zu.

Für bestimmte Seitenelemente, wie z. B. Tabellen oder Formularfelder, können Sie einen Klassen- oder ID-Selektor folgendermaßen zuweisen:

  1. Stellen Sie sicher, dass in der Seitenansicht die Registerkarte Normal ausgewählt ist. Wählen Sie das Seitenelement aus, das Sie ändern möchten, und klicken Sie dann im Menü Format auf Eigenschaften.
  2. Klicken Sie im Dialogfeld Eigenschaften dieses Elements auf Formatvorlage.

    3. Das Dialogfeld Formatvorlage ändern wird angezeigt.

  3. Geben Sie den Klassen- oder ID-Selektor, den Sie zuweisen möchten, folgendermaßen an:
    • Klicken Sie zum Zuweisen eines Klassenselektors aus dem eingebetteten Stylesheet der Seite auf das Feld Klasse, und klicken Sie dann in der Liste der verfügbaren Klassenselektoren auf den gewünschten Selektor.
    • Geben Sie zum Zuweisen eines Klassenselektors aus einem externen Stylesheet den Namen des Selektors in das Feld Klasse ein.
    • Geben Sie zum Zuweisen eines ID-Selektors den Namen des Selektors in das Feld ID ein.

Anmerkungen

  • Wenn Sie einen Klassenselektor aus einem eingebetteten oder einem externen Stylesheet zuweisen, wird dieser Selektor am Ende eines Standard-HTML-Formatvorlagennamens aus dem Feld Formatvorlage angefügt, und die Formate der benutzerdefinierten Vorlage werden mit den Formaten der Standard-HTML-Formatvorlage kombiniert. Der Klassenselektor wird in HTML auf der Seite als CLASS-Attribut zum HTML-Tag des entsprechenden Seitenelements hinzugefügt.

    • Wenn Sie z. B. einen Absatz mit dem Format „Überschrift2“ auswählen und dann einen Klassenselektor namens „.HGrot“ zuweisen, der einen roten Hintergrund hinzufügt, wird die Formatvorlage im Feld Formatvorlage unter dem Namen Überschrift2.HGrot aufgeführt. FrontPage kombiniert die Formateigenschaften der beiden Formatvorlagen beim Zuweisen.

  • Zum Entfernen eines Klassenselektors von einem Seitenelement, dem es zugewiesen worden war, klicken Sie im Feld Formatvorlage auf einen beliebigen Standard-HTML-Tag, z. B. auf „Überschrift1“ oder auf „Standard“.
  • Zum Kopieren eines Klassen- oder ID-Selektors von einem Seitenelement auf ein anderes, wählen Sie das Seitenelement aus, dessen Selektor Sie kopieren möchten. Anschließend klicken Sie auf Format übertragen Schaltfläche "Format übertragen" und dann auf das Seitenelement, dem Sie den Selektor zuweisen möchten.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Erstellen eines externen Stylesheets

Ein externes Stylesheet ist eine hervorragende Möglichkeit zum Garantieren der Konsistenz der Formatierungen in Ihrem Web. Gleichzeitig sparen Sie Zeit. Wenn Sie Seiten in Ihrem Web mit einem externen Stylesheet verknüpfen, können Sie problemlos Formatvorlagen aus diesem Stylesheet zuweisen: Klicken Sie einfach im Dialogfeld Formatvorlage auf die gewünschte Vorlage. Wenn Sie eine Formatvorlage ändern möchten, ändern Sie diese nur an einer Stelle - im externen Stylesheet. Die Änderung wird automatisch auf allen Seiten durchgeführt, die mit diesem Stylesheet verknüpft sind.

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Seite.
  2. Klicken Sie auf die Registerkarte Stylesheets, auf den gewünschten Stylesheet-Typ und dann auf OK.

    3. Microsoft FrontPage erstellt eine neue Stylesheet-Seite mit der Dateierweiterung .CSS und öffnet diese zum Bearbeiten in der Seitenansicht.

Tipps

  • Zum Erstellen oder Ändern von Formatvorlagen in einem Cascading Stylesheet geben Sie die Formatvorlageninformationen in der korrekten CSS-Syntax ein oder verwenden den Befehl Formatvorlage aus dem Menü Format (oder klicken Sie auf der Symbolleiste Formatvorlage auf Formatvorlage), um die Formatvorlage von FrontPage ändern zu lassen.
  • Speichern Sie das Stylesheet mit der Dateierweiterung .CSS.
  • Vor dem Zuweisen von Formatvorlagen aus einem externen Stylesheet zu einer Seite in Ihrem Web, müssen Sie die Seite mit dem externen Stylesheet verknüpfen.

Anmerkungen

  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Erstellen oder Bearbeiten eines eingebetteten Stylesheets

Ein eingebettetes Stylesheet ist ein Cascading Stylesheet, das in die HEAD-Tags einer Seite integriert ist. Formatvorlagen in einem eingebetteten Stylesheet können nur für diese Seite verwendet werden.

Wenn Sie eine Formatvorlage für eine Seite unter Verwendung des Befehls Formatvorlage aus dem Menü Format erstellen oder ändern, erstellt Microsoft FrontPage automatisch ein eingebettetes Stylesheet (sofern dieses nicht bereits existiert) und speichert die Formatvorlage als Klassenselektor mit dem eingebetteten Stylesheet.

Zum Bearbeiten der Formatvorlagen im eingebetteten Stylesheet verwenden Sie den Befehl Formatvorlage aus dem Menü Format.

Anmerkung Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Bearbeiten eines externen Stylesheets

  1. Doppelklicken Sie in der Ordnerliste auf das Cascading Stylesheet, das Sie öffnen möchten.

    2. Microsoft FrontPage öffnet das Stylesheet in der Seitenansicht.

  2. Klicken Sie im Menü Format auf Formatvorlage (oder klicken Sie auf der Symbolleiste Formatvorlage auf Formatvorlage).
  3. Im Dialogfeld Formatvorlage können Sie neue Klassenselektoren erstellen, vorhandene ändern oder löschen oder Standard-HTML-Tags (wie z. B. H1) CSS-Formateigenschaften zuweisen. Wenn Sie auf OK klicken, um das Dialogfeld zu schließen, schreibt FrontPage die Formateigenschaften unter Verwendung der korrekten Syntax zurück in das CSS.

    4. Wenn Sie mit der CSS-Syntax vertraut sind, können Sie den Text des Cascading Stylesheets auch direkt in der Seitenansicht bearbeiten. Sie können sogar nach Text in einem Stylesheet suchen und diesen ersetzen.

Anmerkungen

  • Vor dem Zuweisen von Formatvorlagen aus einem externen Stylesheet zu einer Seite in Ihrem Web, müssen Sie die Seite mit dem externen Stylesheet verknüpfen.
  • Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren.


Verknüpfen einer Seite mit einem externen Stylesheet

Wenn Sie eine Seite mit einem externen Cascading Stylesheet im Web verknüpfen, können die Formatvorlagen in diesem Stylesheet jedem beliebigen Element auf der Seite zugewiesen werden. Formatvorlagen aus einem verknüpften externen Stylesheet werden in der Liste der verfügbaren Formatvorlagen im Feld Formatvorlage angezeigt.

  1. Öffnen Sie in der Seitenansicht die Seite, die Sie mit dem Stylesheet verknüpfen möchten. Klicken Sie im Menü Format auf Links zu Stylesheet.
  2. Wählen Sie aus dem Listenfeld URL die Stylesheets aus, mit denen Sie die Seite verknüpfen möchten.

Tipps

  • Wenn das Listenfeld URL keine Stylesheets enthält, klicken Sie auf Hinzufügen. Anschließend suchen Sie im Dialogfeld Hyperlink auswählen nach dem Stylesheet, das Sie zur Liste hinzufügen möchten, und klicken dann auf OK.
  • Zum Verknüpfen aller Seiten in Ihrem Web mit den aus dem Listenfeld URL ausgewählten Stylesheets klicken Sie auf Alle Seiten.
  • Zum Entfernen eines Stylesheets aus dem Listenfeld URL markieren Sie dieses und klicken dann auf Entfernen.
  • Zum Ändern der Cascadingreihenfolge der Stylesheets im Listenfeld URL wählen Sie das Stylesheet aus, das Sie verschieben möchten, und klicken dann auf Nach oben oder Nach unten.


Bearbeiten des externen Stylesheets eines Designs

Wenn Sie das Kontrollkästchen CSS verwenden für ein Design aktivieren, das einem Web zugewiesen ist, erstellt FrontPage im Stammverzeichnis Ihres Webs eine Datei namens Design1.CSS, wobei Design der Name des Designs ist. Dies ist das Cascading Stylesheet für das Design. Wenn Sie das Design ändern, schreibt FrontPage die Änderungen automatisch auch zurück in das CSS des Designs. Sie können das Design auch direkt im CSS des Designs ändern. Dazu führen Sie Folgendes aus:

  1. Doppelklicken Sie in der Ordnerliste auf das Design-CSS.

    2. FrontPage öffnet das Stylesheet für das Design in der Seitenansicht.

  2. Klicken Sie im Menü Format auf Formatvorlage (oder klicken Sie auf der Symbolleiste Formatvorlage auf Formatvorlage).
  3. Im Dialogfeld Formatvorlage können Sie neue Klassenselektoren erstellen, vorhandene ändern oder löschen oder Standard-HTML-Tags (wie z. B. H1) CSS-Formateigenschaften zuweisen. Wenn Sie auf OK klicken, um das Dialogfeld zu schließen, schreibt FrontPage die Formateigenschaften unter Verwendung der korrekten Syntax zurück in das CSS für das Design.

    4. Wenn Sie mit der CSS-Syntax vertraut sind, können Sie den Text des Cascading Stylesheets auch direkt in der Seitenansicht bearbeiten. Sie können sogar nach Text in einem Stylesheet suchen und diesen ersetzen.


Suchen und Ersetzen von Text in einem Stylesheet

Wenn Sie ein externes Stylesheet in der Seitenansicht bearbeiten, können Sie in Selektoren, Attributen und Werten nach Text suchen und diesen ersetzen.

  1. Klicken Sie im Menü Bearbeiten auf Suchen oder Ersetzen.
  2. Geben Sie in das Feld Suchen nach den Text ein, nach dem Sie im CSS suchen und den Sie ersetzen möchten. Wenn Sie Text ersetzen, geben Sie den Ersatztext in das Feld Ersetzen durch ein.
  3. Legen Sie weitere Optionen zum Suchen und Ersetzen fest:
    • Klicken Sie auf Nach oben oder Nach unten, um die Suchrichtung ab der Einfügemarke festzulegen.
    • Klicken Sie auf Nur ganzes Wort suchen, wenn Sie nur ganze Wörter suchen und ersetzen möchten, die dem Text im Feld Suchen nach entsprechen, oder klicken Sie auf Groß-/Kleinschreibung beachten, wenn nur Text gesucht oder gefunden werden soll, dessen Groß-/Kleinschreibung dem Text im Feld Suchen nach entspricht.
  4. Klicken Sie auf Weitersuchen, um nach dem ersten Auftreten zu suchen.

    5. Microsoft FrontPage markiert das erste Auftreten des Suchbegriffs.

  5. Klicken Sie auf Weitersuchen, um nach dem nächsten Auftreten zu suchen, auf Ersetzen, um dieses Auftreten des Suchbegriffs zu ersetzen und weiter zu suchen, oder auf Alles ersetzen um automatisch jedes Auftreten des Suchbegriffs im CSS zu ersetzen.


Aktivieren oder Deaktivieren bestimmter Versionen von CSS

Bei Cascading Style Sheets (CSS-Dateien) handelt es sich um Erweiterungen, die im Zuge von HTML, Version 3.0, entwickelt wurden, um die Steuerungsmöglichkeiten für Gestaltungselemente zu verbessern und Webseiten mit einem breiter gefaßten Zugriffsangebot auszustatten. Mit CSS, Version 1.0, wurde das Konzept der Cascading Style Sheets zum Speichern von Gestaltungsinformationen eingeführt, die auf ein gesamtes Web angewendet werden können. Mit CSS, Version 2.0, wurden Effekte wie beispielsweise Positionierungsfelder und die Fähigkeit zum Stapeln von Seitenelementen auf der Vorder- oder Hintergrundebene eingeführt. Allerdings werden bestimmte Versionen von CSS von einigen Webbrowsern nicht unterstützt, so dass Seiten, die CSS-Verweise oder -Informationen enthalten, u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage ermöglicht Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie eine bestimmte Version von CSS aktivieren oder deaktivieren, oder wenn Sie Ihr Web für die Kompatibilität mit einem Browser optimieren, der eine bestimmte CSS-Version nicht unterstützt, stehen die Befehle, mit denen CSS eingesetzt wird, zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte Kompatibilität.
  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen CSS 1.0 (Formatierung), um die Befehle, die auf CSS, Version 1.0, zurückgreifen, wie beispielsweise das Hinzufügen von Leerraum vor oder nach einem Absatz, zu aktivieren oder zu deaktivieren.

    3. Anmerkung Wenn Sie das Kontrollkästchen CSS 1.0 (Formatierung) deaktivieren, deaktiviert FrontPage automatisch das Kontrollkästchen CSS 2.0 (Positionierung) und damit die Befehle, mit denen CSS, Version 2.0, eingesetzt wird.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen CSS 2.0 (Positionierung), um die Befehle, die auf CSS, Version 2.0, zurückgreifen, wie beispielsweise Positionierungsfelder oder Elemente in den Vordergrund setzen, zu aktivieren oder deaktivieren.

Anmerkungen

  • Bestimmte Versionen von CSS sind automatisch deaktiviert oder stehen bei bestimmten Browserkompatibilitätsoptionen nicht zur Verfügung. Wenn Sie den Standard außer Kraft setzen und eine bestimmte CSS-Version aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
    Browser | Browserversion | CSS 1.0 | CSS 2.0
Internet Explorer | 4.0 und höher | aktiviert | aktiviert
Internet Explorer | 3.0 und höher | aktiviert | deaktiviert
Netscape Navigator | 4.0 und höher | aktiviert | aktiviert
Netscape Navigator | 3.0 und höher | deaktiviert | deaktiviert
Sowohl Internet Explorer als auch Navigator | 4.0 und höher | aktiviert | aktiviert
Sowohl Internet Explorer als auch Navigator | 3.0 und höher | deaktiviert | deaktiviert
Microsoft WebTV | nicht verfügbar | deaktiviert | deaktiviert

  • Wenn Sie CSS 1.0 (Formatierung) deaktivieren oder eine Browserkompatitbilitätsoption wählen, mit der CSS 1.0 (Formatierung) deaktiviert wird, stehen die folgenden Befehle sowie alle Befehle, die unter CSS 2.0 (Positionierung) unten aufgeführt werden, nicht zur Verfügung:
    • Rahmen und Schattierung (Menü Format)
    • Formatvorlage (Menü Format)
    • Links zu Stylesheet (Menü Format)
    • Dialogfeld Formatvorlage ändern
    • Schaltfläche Farbe für Hervorhebung (Symbolleiste Format)
    • Kontrollkästchen CSS verwenden (Menü Format, Befehl Design)
  • Wenn Sie CSS 2.0 (Positionierung) deaktivieren oder eine Browserkompatibilitätsoption wählen, mit der CSS 2.0 (Positionierung) deaktiviert wird, stehen die folgenden Befehle nicht zur Verfügung:
    • Positionierungsfeld (Menü Einfügen)
    • Position (Menü Format)
    • Schaltfläche In den Vordergrund (Symbolleiste Grafik)
    • Schaltfläche In den Hintergrund (Symbolleiste Grafik)
    • Format Rahmen (Menü Format, Befehl Formatvorlage, Dialogfeld Neue Formatvorlage)
    • Alle Befehle auf der Symbolleiste Positionierung


Hinzufügen eines Seitenbanners zu einer Seite

Mithilfe eines Seitenbanners können Sie schnell Titel zu Ihren Seiten hinzufügen. Seitenbanner verwenden die Formatvorlagen und Grafiken eines Designs, sofern eins für die aktuelle Seite vorliegt. Liegt kein Design vor, zeigt das Seitenbanner lediglich Text an, den Sie formatieren können. Mithilfe eines Seitenbanners innerhalb eines gemeinsamen Randbereichs können Sie schnell Titel zu mehreren Seiten in einem Web hinzufügen.

Sie können Seitenbanner erst dann einsetzen, wenn Sie in der Navigationsansicht die Navigationsstruktur für Ihr Web festgelegt haben. (Ein Seitenbanner ist nur dann auf einer Seite sichtbar, wenn die Seite in die Navigationsstruktur eingebunden ist). Seitenbanner verwenden die Seitentitel aus der Navigationsansicht. Wenn Sie diesen Titel für einen Seite ändern, ändert sich auch die Beschriftung des Seitenbanners.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie ein Seitenbanner hinzufügen möchten, z. B. in einen gemeinsamen oberen Randbereich.
  2. Klicken Sie im Menü Einfügen auf Seitenbanner.
  3. Legen Sie fest, ob Sie das Seitenbanner als Bild oder unformatierten Text anzeigen möchten.
  4. Geben Sie in das Feld Seitenbannertext den Text ein, den Sie im Seitenbanner anzeigen möchten. Standardmäßig zeigt ein Seitenbanner den Seitentitel so an, wie er in der Navigationsansicht angezeigt wird.


Ändern eines Seitenbanners

Wenn Sie ein Seitenbanner zu einer Seite hinzugefügt haben, können Sie den darauf angezeigten Text ändern. Darüber hinaus können Sie festlegen, ob eine Grafik oder nur Text angezeigt werden soll.

Anmerkung Wenn Sie den auf einem Seitenbanner angezeigten Text ändern, ändert sich gleichzeitig der Titel der Seite in der Navigationsansicht.

  1. Doppelklicken Sie in der Seitenansicht auf das Seitenbanner.
  2. Legen Sie die Eigenschaften für das Seitenbanner fest.

Tipp Wenn das Seitenbanner nur Text enthält, können Sie diesen direkt auf der Seite bearbeiten.


Hinzufügen einer Zeitmarkierung zu einer Seite

Fügen Sie eine Zeitmarkierung zu einer Seite hinzu, wenn Sie die Zeit und/oder das Datum anzeigen möchten, zu der/dem eine Seite zuletzt geändert worden ist. Eine Zeitmarkierung kann einen Sitebesucher z. B. darüber informieren, ob die Informationen auf einer Seite seit seinem letzten Besuch geändert worden sind.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie die Zeitmarkierung einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Datum und Uhrzeit.
  3. Geben Sie den Typ der Zeitmarkierung an, die angezeigt werden soll.
  4. Geben Sie ein Format für das Datum und die Uhrzeit an.


Hinzufügen einer horizontalen Linie zu einer Seite

Sie können eine horizontale Linie zu einer Seite hinzufügen, um z. B. Text abzutrennen oder hervorzuheben. Nach dem Hinzufügen einer horizontalen Linie können Sie deren Eigenschaften ändern, um z. B. die Breite, Höhe, Ausrichtung oder Farbe anzupassen. Wenn Ihre Seite ein Design verwendet, verwendet die horizontale Linie eine Grafik, die dem Design entspricht, z. B.:

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Linie einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Horizontale Linie.
  3. Zum Ändern des Erscheinungsbildes der horizontalen Linie doppelklicken Sie auf die Linie und führen Sie dann einen oder mehrere der folgenden Schritte aus:
    • Geben Sie unter Breite die Breite der Linie als Prozentsatz von der Fensterbreite oder in Pixeln an.
    • Geben Sie unter Höhe die Anzahl der Pixel für die Höhe der Linie ein.
    • Geben Sie unter Ausrichtung die Ausrichtung der Linie auf der Seite an.
    • Wählen Sie im Feld Farbe eine Farbe für die Linie aus, wenn Sie keine schattierte Linie verwenden möchten.
    • Aktivieren Sie das Kontrollkästchen Durchgezogen, wenn die Linie durchgezogen werden soll. Deaktivieren Sie das Kontrollkästchen, wenn die Linie schattiert werden soll. Wenn Sie eine Farbe ausgewählt haben, wird die Linie durchgezogen und kann nicht schattiert werden.

    Anmerkung Wenn die aktuelle Seite ein Design verwendet, können Sie nur die Ausrichtung der Linie ändern.


Info über Listen

Um mehr über Listen zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Erstellen benutzerdefinierter Aufzählungszeichen

Sie können Grafiken erstellen und diese anstelle der Standard-Aufzählungszeichen (Kreise oder Quadrate) als Aufzählungszeichen verwenden. In der folgenden Liste werden zum Beispiel benutzerdefinierte Aufzählungszeichen verwendet:

Äpfel
Bananen
Orangen
  1. Erstellen Sie mit einem Grafikprogramm die als Aufzählungszeichen zu verwendende Grafik, und speichern Sie diese dann möglichst im Format GIF oder JPEG.
  2. Bringen Sie in der Seitenansicht von Microsoft FrontPage die Einfügemarke an die Stelle, wo Sie eine Liste erstellen möchten.
  3. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen, und klicken Sie dann auf die Registerkarte Grafische Aufzählungszeichen.
  4. Klicken Sie auf Bild angeben, und klicken Sie dann auf Durchsuchen, um die gerade erstellte Grafik zu finden und auszuwählen.
  5. Klicken Sie auf OK.
  6. Geben Sie jedes Element, das Sie zur Liste hinzufügen möchten, ein und drücken Sie jeweils die EINGABETASTE.
  7. Um die Liste zu beenden, drücken Sie zweimal die EINGABETASTE.

    8. Anmerkung Wenn Sie diese Seite speichern, werden Sie aufgefordert, das grafische Aufzählungszeichen im aktuellen Web im GIF- oder JPEG-Format zu speichern.


Erstellen einer Aufzählungsliste

Um eine nicht sequentielle Liste von Elementen anzuzeigen, erstellen Sie eine Aufzählungsliste. Es folgt ein Beispiel einer Aufzählungsliste:

  • Äpfel
  • Bananen
  • Orangen
  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, wo Sie eine Liste erstellen möchten.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen.
  3. Führen Sie einen der folgenden Schritte durch:
    • Um Standard-Aufzählungszeichen wie Kreise oder Quadrate zu verwenden, klicken Sie auf die Registerkarte Einfache Aufzählung, klicken Sie auf das Feld mit dem Aufzählungszeichen, das Sie verwenden möchten, und klicken Sie dann auf OK.
    • Um benutzerdefinierte Aufzählungszeichen zu verwenden, klicken Sie auf die Registerkarte Grafische Aufzählungszeichen, und klicken Sie auf Bild angeben. Klicken Sie auf Durchsuchen, um die gewünschte Grafik zu finden und auszuwählen. Klicken Sie auf OK.
    • Um Aufzählungszeichen aus dem aktuellen Design zu verwenden (sofern die Seite eines verwendet), klicken Sie auf die Registerkarte Grafische Aufzählungszeichen, und klicken Sie dann auf Bilder des aktuellen Designs verwenden.
  4. Geben Sie jedes Element ein, das Sie zur Liste hinzufügen möchten, und drücken Sie jeweils die EINGABETASTE. Wenn Sie das letzte Element eingegeben haben, drücken Sie zweimal die EINGABETASTE, um die Liste zu beenden.

Tipp Um schnell eine Aufzählungsliste zu erstellen, klicken Sie auf Aufzählung Schaltfläche "Aufzählung", und geben Sie dann die Elemente ein. Oder um Aufzählungszeichen zu einer Gruppe von Elementen hinzuzufügen, markieren Sie die Elemente, und klicken Sie dann auf Aufzählung Schaltfläche "Aufzählung". Hierbei wird das Standardformat für das Aufzählungszeichen verwendet. Wenn die Seite ein Design verwendet, werden die Aufzählungszeichen aus dem Design verwendet.


Erstellen einer nummerierten Liste

Um eine sequentielle Liste von Elementen anzuzeigen, erstellen Sie eine nummerierte Liste. Das folgende Verfahren gilt als Beispiel für eine nummerierte Liste.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Liste erstellen möchten.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen, und klicken Sie auf die Registerkarte Nummerierung.
  3. Klicken Sie auf das Feld mit dem Nummernformat, das Sie verwenden möchten, und klicken Sie dann auf OK.
  4. Geben Sie jedes Element ein, das Sie zur Liste hinzufügen möchten, und drücken Sie jeweils die EINGABETASTE. Wenn Sie das letzte Element eingegeben haben, drücken Sie zweimal die EINGABETASTE, um die Liste zu beenden.

Tipp Um schnell eine nummerierte Liste zu erstellen, klicken Sie auf Nummerierung Schaltfläche "Nummerierung", und geben Sie dann die Elemente ein. Oder um Nummern zu einer Gruppe von Elementen hinzuzufügen, markieren Sie die Elemente, und klicken Sie dann auf Nummerierung Schaltfläche "Nummerierung". Hierbei wird das Standard-Nummernformat verwendet.


Erstellen einer Definitionsliste

Sie können Begriffe und Definitionen im Format einer Definitionsliste anzeigen. Im allgemeinen wird der Begriff linksbündig angeordnet und seine Definition eingerückt. Die exakte Formatierung der Liste hängt vom verwendeten Webbrowser ab. Es folgt ein Beispiel einer Definitionsliste:

Begriff A
Dies ist die Definition von Begriff A
Begriff B
Dies ist die Definition von Begriff B.

Sie können auch nach Bedarf eine Formatierung hinzufügen; so können Sie zum Beispiel die Begriffe fett anzeigen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Liste erstellen möchten.
  2. Klicken Sie im Feld Formatvorlage auf Definierter Begriff, geben Sie den ersten Begriff der Liste ein, und drücken Sie dann die EINGABETASTE.

    3. Die nächste Zeile wird automatisch durch die Formatvorlage Definition formatiert.

  3. Geben Sie die Definition des Begriffes ein, und drücken Sie dann die EINGABETASTE.

    4. Oder um einen zweiten Absatz für die Definition hinzuzufügen, drücken Sie STRG+EINGABE. Die beiden Absätze werden durch einen Zeilenumbruch voneinander getrennt. Drücken Sie die EINGABETASTE, um mit dem nächsten Begriff fortzufahren.

    Die nächste Zeile wird automatisch durch die Formatvorlage Definierter Begriff formatiert.

    Wiederholen Sie die Schritte 2 und 3 für jeden weiteren Begriff und seine Definition.

  4. Um die Liste zu beenden, drücken Sie zweimal die EINGABETASTE.


Erstellen einer Gliederung

Sie können eine mehrstufige Liste im Format einer Gliederung erstellen, wie zum Beispiel:

  1. Kapitel
    1. Überschrift
      1. Zweite Überschrift
        1. Thema

          2. Absatz

        2. Thema
          1. Detail
          2. Detail

Diese Liste verwendet unterschiedliche Formatvorlagen für jede Ebene. Wenn eine Überschrift nur ein Element unter sich hat, können Sie das Element ohne Zahlen auflisten (beachten Sie, wie „Absatz“ oben angezeigt wird).

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Gliederung erstellen möchten.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen, und klicken Sie dann auf die Registerkarte Nummerierung.
  3. Klicken Sie auf das Feld mit dem Format von Zahlen oder Buchstaben, mit dem Sie beginnen möchten, und klicken Sie dann auf OK.
  4. Geben Sie jedes Element ein, das Sie zur Liste hinzufügen möchten, und drücken Sie jeweils die EINGABETASTE. Wenn Sie das letzte Element eingegeben haben, drücken Sie zweimal die EINGABETASTE, um die Liste zu beenden.
  5. Fügen Sie jedes Element auf der korrekten Ebene ein:
    • Um Elemente tiefer zur nächsten, nummerierten Ebene zu schieben, markieren Sie die Elemente, und klicken Sie dann zweimal auf Einzug vergrößern Schaltfläche "Einzug vergrößern".
    • Um Elemente als Absatz auf der aktuellen Ebene (ohne Aufzählungszeichen oder Nummerierung) zu formatieren, markieren Sie die Elemente, und klicken Sie dann einmal auf Einzug vergrößern Schaltfläche "Einzug vergrößern".
    • Um Elemente höher zur vorhergehenden Ebene zu verschieben, markieren Sie die Elemente, und klicken Sie dann einmal oder mehrfach, je nach Bedarf, auf Einzug verkleinern Schaltfläche "Einzug verkleinern".
  6. Um Nummernformate auf unterschiedliche Ebenen anzuwenden, markieren Sie ein Element auf einer Teilebene, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Listeneigenschaften. Klicken Sie auf der Registerkarte Nummerierung auf das Feld mit dem gewünschten Nummernformat.


Erstellen einer ausblendbaren Liste

Sie können eine ausblendbare Liste aus einer Aufzählungsliste oder nummerierten Liste mit mehreren Ebenen erstellen. Eine ausblendbare Liste erlaubt dem Sitebesucher, unterschiedliche Ebenen der Liste anzuzeigen oder zu verbergen, indem er auf ein Element doppelklickt.

Die folgende Liste ist ausblendbar. Um zu sehen, wie das funktioniert, klicken Sie auf B. Um den Rest der Liste auszublenden, klicken Sie auf Eins. Um die Liste einzublenden, klicken Sie auf Eins und dann wieder auf B.

  • Eins
    • A
    • B
      • 1
      • 2
      • 3
  • Zwei

Anmerkung Ausblendbare Listen werden von Microsoft Internet Explorer 4.0 oder höher unterstützt, aber auch von anderen Webbrowsern, sofern sie Dynamic HTML unterstützen.

  1. Erstellen Sie in der Seitenansicht eine mehrstufige Liste.
  2. Führen Sie einen der folgenden Schritte durch:
    • Um die gesamte Liste ausblendbar zu definieren, markieren Sie die gesamte Liste, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Listeneigenschaften.
    • Um nur eine Ebene der Liste ausblendbar zu definieren, markieren Sie die Elemente in der Ebene darunter, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Listeneigenschaften. Um zum Beispiel in der Musterliste weiter oben das Element B ausblendbar zu machen, würden Sie die Elemente 1, 2 und 3 markieren.
  3. Aktivieren Sie auf der angezeigten Registerkarte das Kontrollkästchen Ausblendbare Gliederung aktivieren.

    4. Anmerkung Wenn diese Option nicht angezeigt wird, haben Sie nicht alle Elemente der Liste bzw. der Ebene markiert.

  4. Wenn Sie die gesamte Liste markiert haben, und Sie die Liste ausgeblendet haben möchten, wenn die Seite zum ersten Mal im Webbrowser geöffnet wird, aktivieren Sie das Kontrollkästchen Anfangs ausgeblendet.


Erstellen einer mehrstufigen Liste

Sie können eine Liste erstellen, die mehrere verschachtelte Ebenen hat, wie zum Beispiel:

  • Überschrift
    • Thema A
    • Thema B
    • Thema C

      • Detail

  • Überschrift

Sie können auch Unterebenen erstellen, die nicht nummeriert oder mit Aufzählungszeichen versehen sind (beachten Sie die Art, wie „Detail“ weiter oben angezeigt wird).

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Liste erstellen möchten.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen.
  3. Führen Sie einen der folgenden Schritte durch:
    • Um eine Aufzählungsliste zu erstellen, klicken Sie auf die Registerkarte Einfache Aufzählung. Klicken Sie auf das Feld mit dem Aufzählungszeichenformat, mit dem Sie beginnen möchten, und klicken Sie dann auf OK.
    • Um eine nummerierte Liste zu erstellen, klicken Sie auf die Registerkarte Nummerierung. Klicken Sie auf das Feld mit dem Zahlen- oder Buchstabenformat, mit dem Sie beginnen möchten, und klicken Sie dann auf OK.
    • Um eine Liste mit benutzerdefinierten Aufzählungszeichen oder Aufzählungszeichen aus dem aktuellen Design zu erstellen, klicken Sie auf die Registerkarte Grafische Aufzählungszeichen. Klicken Sie auf die gewünschte Option, und klicken Sie, sofern Sie benutzerdefinierte Aufzählungszeichen verwenden, auf Durchsuchen, um die gewünschte Grafik zu finden und auszuwählen. Klicken Sie auf OK.
  4. Geben Sie jedes Element ein, das Sie zur Liste hinzufügen möchten, und drücken Sie jeweils die EINGABETASTE. Wenn Sie das letzte Element eingegeben haben, drücken Sie zweimal die EINGABETASTE, um die Liste zu beenden.
  5. Bringen Sie jedes Element auf die korrekte Ebene:
    • Um Elemente tiefer zur nächsten nummerierten oder mit Aufzählungszeichen versehenen Ebene zu verschieben, markieren Sie die Elemente, und klicken Sie dann zweimal auf Einzug vergrößern Schaltfläche "Einzug vergrößern"
    • Um Elemente als Absatz auf der aktuellen Ebene (ohne Aufzählungszeichen oder Nummerierung) zu formatieren, markieren Sie die Elemente, und klicken Sie dann einmal auf Einzug vergrößern Schaltfläche "Einzug vergrößern".
    • Um Elemente höher zur vorhergehenden Ebene zu verschieben, markieren Sie die Elemente, und klicken Sie dann einmal oder mehrfach, je nach Bedarf, auf Einzug verkleinern Schaltfläche "Einzug verkleinern".

Tipp Eine Unterebene kann ein unterschiedliches Nummerierungs- oder Aufzählungszeichenformat als die darüber gelegene Ebene haben. Um eine unterschiedliche Formatvorlage auf eine Unterebene anzuwenden, markieren Sie ein Element auf der Ebene, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Listeneigenschaften. Klicken Sie auf die Registerkarte, die dem Format entspricht, das Sie anwenden möchten, und legen Sie dann das Format fest.


Ändern der Eigenschaften einer Liste

Sie können die Eigenschaften einer Liste ändern. So können Sie zum Beispiel folgendes machen:

  • Ändern einer Aufzählungsliste in eine nummerierte Liste.
  • Ändern des Formats von derzeit verwendeten Aufzählungszeichen oder Nummerierungen.
  • Ausblendbarmachen einer Liste.

Beachten Sie, dass, wenn Sie ein Element in einer Liste ändern (wenn Sie zum Beispiel Aufzählungszeichen in Nummern ändern), die Änderung sich auf alle Elemente der betreffenden Ebene auswirken.

  1. Markieren Sie in der Seitenansicht die Listenelemente. Oder um die Eigenschaften von Elementen nur einer Unterebene zu ändern, markieren Sie die Elemente in dieser Unterebene.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen.
  3. Führen Sie einen der folgenden Schritte durch:
    • Um eine Liste dahingehend zu ändern, dass sie benutzerdefinierte Aufzählungszeichen oder Aufzählungszeichen aus einem Design verwendet, klicken Sie auf die Registerkarte Grafische Aufzählungszeichen, und wählen Sie die gewünschte Option aus. Wenn Sie benutzerdefinierte Aufzählungszeichen verwenden, klicken Sie auf Durchsuchen, um die gewünschte Grafik zu finden und auszuwählen.
    • Um eine Liste dahingehend zu ändern, dass sie einfache Aufzählungszeichen wie Kreise oder Quadrate verwendet, klicken Sie auf die Registerkarte Einfache Aufzählungszeichen, und klicken Sie dann auf das Feld, welches die gewünschten Aufzählungszeichen darstellt.
    • Um eine Liste dahingehend zu ändern, dass sie Buchstaben oder Zahlen verwendet, klicken Sie auf die Registerkarte Nummerierung, und klicken Sie dann auf das Feld, welches die gewünschten Buchstaben oder Zahlen darstellt.
    • Um eine Liste in ein anderes Format zu ändern wie eine Definitionsliste, klicken Sie auf die Registerkarte Sonstige, und klicken Sie dann auf das gewünschte Listenformat.


Entfernen von Nummern oder Aufzählungszeichen aus einer Liste

Sie können die Formatierung durch Nummern oder Aufzählungszeichen aus einer Liste mit Elementen entfernen.

  1. Markieren Sie in der Seitenansicht die Elemente in der Liste.
  2. Klicken Sie im Menü Format auf Nummerierung und Aufzählungen.
  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn die Liste Aufzählungszeichen verwendet, klicken Sie auf der Registerkarte Einfache Aufzählung auf das Feld ohne Aufzählungszeichen.
    • Wenn die Liste Nummern oder Buchstaben verwendet, klicken Sie auf der Registerkarte Nummerierung auf das Feld ohne Nummerierung.


Verwenden von Tabellen

Um mehr über Tabellen zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Erstellen von Tabellen

Um die verschiedenen Möglichkeiten zum Erstellen einer Tabelle kennen zu lernen, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Anpassen von Tabellen

Um zu erfahren, wie Tabellen angepasst werden, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Erstellen einer einfachen Tabelle

Sie können eine einfache Tabelle erstellen, indem Sie nur die Anzahl der Zeilen und Spalten angeben. Für die Tabelle werden Standardeigenschaften verwendet.

  1. Bringen Sie die Einfügemarke in der Seitenansicht an die Stelle, an der Sie die Tabelle einfügen möchten.
  2. Klicken Sie auf Tabelle einfügen Schaltfläche "Tabelle einfügen", und ziehen Sie dann mit der Maus nach unten und rechts, bis die für die Tabelle gewünschte Anzahl der Zeilen und Spalten angezeigt wird.


Erstellen einer Tabelle und Festlegen ihrer Eigenschaften

Sie können beim Erstellen einer Tabelle auch deren Eigenschaften angeben, wie z. B. Zeilen und Spalten, Größe und Ausrichtung, Rahmenattribute usw.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie die Tabelle einfügen möchten.
  2. Zeigen Sie im Menü Tabelle auf Einfügen, und klicken Sie dann auf Tabelle.
  3. Geben Sie im Feld Zeilen die Anzahl der gewünschten Zeilen ein.
  4. Geben Sie im Feld Spalten die Anzahl der gewünschten Spalten ein.
  5. Wählen Sie im Feld Ausrichtung die Position der Tabelle auf der Seite aus.
  6. Geben Sie im Feld Rahmenstärke die gewünschte Breite des Tabellenrahmens in Pixel ein. Wenn Sie keinen Rahmen wünschen, geben Sie 0 ein.
  7. Um den Textabstand in der Tabelle zu ändern (den Raum zwischen Rahmen und Inhalt einer Zelle), geben Sie im Feld Textabstand eine Zahl ein.
  8. Um den Zellenabstand in der Tabelle zu ändern (den Raum zwischen den Zellen), geben Sie im Feld Zellenabstand eine Zahl ein.
  9. Um die Tabellenbreite zu ändern, führen Sie eine der folgenden Aktionen durch:
    • Aktivieren Sie in Pixel, und geben Sie die für die Tabelle gewünschte Breite in Pixel ein.
    • Aktivieren Sie in Prozent, und geben Sie dann einen Prozentsatz der Bildschirmbreite ein, der für die Tabelle gelten soll. Wenn die Tabelle in einem Frame angezeigt werden soll, geben Sie einen Prozentsatz der Framebreite ein.

Anmerkung Die von Ihnen angegebenen Eigenschaften der neuen Tabelle werden bei der nächsten Erstellung einer Tabelle als Standardwerte verwendet.


Erstellen einer Tabelle durch Zeichnen

Sie können eine Tabelle erstellen, indem Sie die Tabelle und ihre Zellen zeichnen, anstatt die Anzahl der Zeilen und Spalten anzugeben.

Zeichnen einer Tabelle

Wenn Sie eine Tabelle zeichnen, können Sie leicht unregelmäßige Zeilen und Spalten erstellen.

  1. Klicken Sie in der Seitenansicht im Menü Tabelle auf Tabelle zeichnen.

    2. FrontPage öffnet die Symbolleiste Tabellen, auf der die Schaltfläche Tabelle zeichnen Schaltfläche "Tabelle zeichnen" aktiviert ist.

  2. Zeichnen Sie auf der Seite den äußeren Rand der Tabelle, indem Sie mit der Maus von der oberen linken zur unteren rechten Ecke ziehen.
  3. Um Zellen einzurichten, zeichnen Sie vertikale und horizontale Linien innerhalb der Tabelle.

    4. Um nicht gewünschte Linien wieder zu entfernen, klicken Sie auf der Symbolleiste Tabelle auf die Schaltfläche Radiergummi Schaltfläche "Radiergummi" , ziehen Sie den Mauszeiger über die unerwünschte Linie, und lassen Sie die Maustaste los, wenn die Linie rot wird.

  4. Wenn Sie mit dem Zeichnen der Tabelle fertig sind, klicken Sie auf der Symbolleiste Tabellen auf die Schaltfläche Tabelle zeichnen Schaltfläche "Tabelle zeichnen", damit die Schaltfläche deaktiviert wird.


Festlegen des Tabellenlayouts

Sie können das Layout einer Tabelle durch Ändern der folgenden Eigenschaften festlegen:

  • Ausrichtung der Tabelle relativ zur Seite
  • Textfluss um die Tabelle herum
  • Stärke des äußeren Tabellenrahmens
  • Textabstand (der Raum zwischen Text und Zellenrahmen)
  • Zellenabstand (die Entfernung zwischen Zellen in einer Tabelle)
  1. Klicken Sie mit der rechten Maustaste in der Seitenansicht auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabelleneigenschaften.
  2. Wählen Sie im Feld Ausrichtung die für die Tabelle zu verwendende Ausrichtung aus.
  3. Legen Sie im Feld Textfluss fest, ob der Text um die linke oder die rechte Seite der Tabelle herumfließen soll. Wenn der Text gar nicht um die Tabelle herumfließen soll, wählen Sie Standard aus.
  4. Geben Sie unter Rahmen im Feld Stärke die Breite des Rahmens in Pixel ein.
  5. Geben Sie im Feld Textabstand einen Pixelwert ein, der angibt, wie viel Raum zwischen Inhalt und innerem Rand von Zellen zugelassen ist.
  6. Geben Sie im Feld Zellenabstand einen Pixelwert ein, der angibt, wie viel Raum zwischen den Zellen in der Tabelle zugelassen ist.


Umwandeln von Text in eine Tabelle

Sie können Text in eine Tabelle umwandeln, wenn dieser begrenzt (d. h. durch Begrenzungszeichen in Zeilen und Spalten eingeteilt) wurde.

Wenn der Text nicht begrenzt ist, geben Sie an den Stellen Begrenzungszeichen ein, an denen Sie den Text in Spalten und Zeilen aufteilen möchten. Verwenden Sie z. B. Kommas, um Spalten aufzuteilen, und Absatzmarken, um das Zeilenende zu markieren.

So wird beispielsweise der folgende Text:

Name, Stadt, Alter
Los Angeles, Los Angeles, 30

Umgewandelt in:

Name | Stadt | Alter
Jeff Smith | Los Angeles | 30

Zusätzlich zum Umwandeln von Text in eine Tabelle mit Zeilen und Spalten können Sie auch eine Tabelle mit nur einer Zelle erstellen, die den gesamten, markierten Text aufnimmt. Wenn Sie z. B. eine Tabelle für das Seitenlayout verwenden, möchten Sie möglicherweise den gesamten Text in der Tabelle zusammenhalten.

  1. Markieren Sie in der Seitenansicht den Text, den Sie in eine Tabelle umwandeln möchten.
  2. Zeigen Sie im Menü Tabelle auf Umwandeln, und klicken Sie dann auf Text in Tabelle umwandeln.
  3. Geben Sie das verwendete Spaltentrennzeichen ein, oder klicken Sie auf Keines, um eine einzellige Tabelle zu erstellen.

Tipp Da HTML nicht direkt Tabulatorzeichen unterstützt, wird empfohlen, diese nicht als Textbegrenzungszeichen zu verwenden.


Umwandeln einer Tabelle in Text

Beim Umwandeln einer Tabelle in Text speichert Microsoft FrontPage jede Tabellenzelle in einen eigenen Absatz.

Beispielsweise wird die folgende Tabelle:

Name | Stadt | Alter
Jeff Smith | Los Angeles | 30

In die folgende Liste von Absätzen umgewandelt:

Name
Stadt
Alter
Jeff Smith
Los Angeles
30

  1. Markieren Sie in der Seitenansicht die Tabelle, die Sie umwandeln möchten.
  2. Zeigen Sie im Menü Tabelle auf Umwandeln, und klicken Sie dann auf Tabelle in Text umwandeln.


Löschen von Tabellenelementen

Sie können eine Tabelle oder ihre Elemente löschen

Zum Löschen einer | Führen Sie in der Seitenansicht Folgendes durch
Tabelle | Markieren Sie die zu löschende Tabelle, und drücken Sie dann die ENTF-TASTE.
Zelle | Markieren Sie die zu löschenden Zellen, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zellen löschen.
Zeile | Markieren Sie die zu löschenden Zeilen, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zellen löschen.
Spalte | Markieren die zu löschenden Spalten, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zellen löschen.
Tabellenbeschriftung | Markieren Sie die zu löschende Beschriftung, und drücken Sie dann auf die ENTF-TASTE.

Tipp Sie können auch markierte Zellen, Zeilen und Spalten löschen, indem Sie auf der Symbolleiste Tabellen auf die Schaltfläche Zellen löschen Schaltfläche "Zellen löschen" klicken. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Gleichmäßiges Verteilen von Zeilen und Spalten

Wenn Sie eine Tabelle mit unterschiedlichen Zeilenhöhen und Spaltenbreiten haben, können Sie die Höhe oder Breite von Zeilen oder Spalten ausgleichen.

  1. Markieren Sie in der Seitenansicht die Zeilen oder Spalten, deren Höhe oder Breite Sie ausgleichen möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zeilen gleichmäßig verteilen oder auf Spalten gleichmäßig verteilen.

Tipp Sie können markierte Zeilen oder Spalten auch gleichmäßig verteilen, indem Sie auf der Symbolleiste Tabellen auf die Schaltfläche Zeilen gleichmäßig verteilen Schaltfläche "Zeilen gleichmäßig verteilen" oder Spalten gleichmäßig verteilen Schaltfläche "Spalten gleichmäßig verteilen" klicken. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Formatieren von Kopfzeilen einer Tabelle

Um bestimmte Zellen in einer Tabelle hervorzuheben, wie z. B. die erste Zeile oder Spalte, können Sie die Zellen als Kopfzeilen der Tabelle formatieren. Standardmäßig werden Kopfzeilen in Fettschrift angezeigt. Sie können jedoch das Format der Tabellenkopfzeilen (th) ändern und zusätzliche Eigenschaften, wie z. B. Schattierung, für diese definieren.

 | Jan | Feb | Summe
Osten |  |  |
Westen |  |  |
Summe |  |  |
  1. Markieren Sie in der Seitenansicht die Zelle, Zeile oder Spalte, die Sie als Kopfzeile formatieren möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften.
  3. Aktivieren Sie das Kontrollkästchen Enthält Überschrift.


Verbergen eines Tabellenrahmens

Wenn Sie nicht möchten, dass ein Tabellenrahmen sichtbar ist, z. B. bei der Verwendung einer Tabelle zum Layout von Text und Grafiken auf einer Seite, können Sie den Tabellenrahmen verbergen. Dazu setzen Sie seine Stärke auf Null. Ein Webbrowser wird dann den Rahmen nicht anzeigen.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabelleneigenschaften.
  2. Geben Sie unter Rahmen im Feld Stärke den Wert 0 ein.

Tipp Um einen verborgenen Rahmen bei der Bearbeitung der Seite als gepunktete Linie zu sehen, klicken Sie auf Alle anzeigen Schaltfläche "Alle anzeigen".


Hinzufügen einer Zelle, Zeile oder Spalte

Nach der Erstellung einer Tabelle können Sie Zellen, Zeilen und Spalten ganz nach Bedarf hinzufügen.

Zum Einfügen einer | Führen Sie in der Seitanansicht Folgendes durch
Zelle | Bringen Sie die Einfügemarke in eine Zelle. Zeigen Sie im Menü Tabelle auf Einfügen, und klicken Sie dann auf Zelle. Eine neue Zelle wird links von der Zelle eingefügt.
Zeile | Markieren Sie eine Zeile. Zeigen Sie im Menü Tabelle auf Einfügen, und klicken Sie dann auf Zeilen oder Spalten. Klicken Sie auf Zeilen, geben Sie die Anzahl der einzufügenden Zeilen ein, und geben Sie an, wo sie zu plazieren sind.
Spalte | Markieren Sie eine Spalte. Zeigen Sie im Menü Tabelle auf Einfügen, und klicken Sie dann auf Zeilen oder Spalten. Klicken Sie auf Spalten, geben Sie die Anzahl der einzufügenden Spalten ein, und geben Sie an, wo sie zu plazieren sind.

Tipp Sie können auch Zeilen oder Spalten einfügen, indem Sie eine Zeile oder Spalte markieren und dann auf die Schaltfläche Zeilen einfügen Schaltfläche "Zeilen einfügen" oder Spalten einfügen Schaltfläche "Spalten einfügen" klicken. Eine neue Zeile wird über der markierten Zeile oder eine neue Spalte links von der markierten Spalte eingefügt. Um mehrere Zeilen oder Spalten einzufügen, markieren Sie genau so viele Zeilen oder Spalten, wie Sie einfügen möchten, es wird dieselbe Anzahl Zeilen oder Spalten wie die Zahl der von Ihnen markierten Zeilen oder Spalten eingefügt. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Einfügen einer Tabellenbeschriftung

Sie können eine Beschriftung, d. h. einen Titel, zu einer Tabelle hinzufügen, um ihr eine Bezeichnung zu geben oder ihren Inhalt für einen Sitebesucher zusammenzufassen. Eine Tabellenbeschriftung kann oberhalb oder unterhalb der Tabelle angezeigt werden. Sie können die Beschriftung wie jeden anderen Text nach Belieben ausrichten und formatieren.

  1. Bringen Sie in der Seitenansicht die Einfügemarke in die Tabelle.
  2. Zeigen Sie im Menü Tabelle auf Einfügen, und klicken Sie dann auf Beschriftung.
  3. Geben Sie den Text für Ihre Beschriftung ein.

Tipps

  • Um die Beschriftung unterhalb der Tabelle zu positionieren, klicken Sie mit der rechten Maustaste auf die Beschriftung, und klicken Sie dann im Kontextmenü auf Beschriftungseigenschaften. Klicken Sie auf Unter der Tabelle, und klicken Sie dann auf OK.
  • Um die Ausrichtung der Beschriftung zu ändern, markieren Sie die Beschriftung, und klicken Sie dann auf der Symbolleiste Format auf Rechtsbündig ausrichten Schaltfläche "Rechtsbündig ausrichten" oder Linksbündig ausrichten Schaltfläche "Linksbündig ausrichten".


Einfügen einer Tabelle innerhalb einer Tabelle

Sie können eine Tabelle innerhalb einer Tabelle einfügen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke in die Zelle, in der Sie eine Tabelle einfügen möchten.
  2. Klicken Sie auf Tabelle einfügen Schaltfläche "Tabelle einfügen", und ziehen Sie dann mit der Maus nach unten rechts, bis die gewünschte Anzahl der Zeilen und Spalten für die Tabelle angezeigt wird.


Zellen verbinden

Sie können zwei oder mehr nebeneinander liegende Zellen miteinander verbinden, um dadurch eine größere Zelle zu erhalten.

Anmerkung Dieser Befehl ist nur verfügbar, wenn zwei oder mehr nebeneinander liegende Zellen markiert werden und die markierten Zellen ein Rechteck darstellen.

  • Markieren Sie in der Seitenansicht eine Zeile, Spalte, oder eine Gruppe nebeneinander liegender Zellen, klicken Sie mit der rechten Maustaste auf die Markierung, und klicken Sie dann im Kontextmenü auf Zellen verbinden.

Tipp Sie können auch Zellen verbinden, indem Sie auf der Symbolleiste Tabellen auf Zellen verbinden Schaltfläche "Zellen verbinden" klicken. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Ändern eines Tabellenrahmens

Sie können die Farbe eines Tabellenrahmens ändern und die Stärke des äußeren Rahmens festlegen. Weiterhin können Sie den Raum zwischen den Zellen definieren.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabelleneigenschaften.
  2. Um die Entfernung zwischen den einzelnen Zellenrahmen zu ändern, geben Sie im Feld Textabstand eine Zahl in Pixel ein, um den Abstand zu erhöhen oder zu verringern.
  3. Um die Stärke des äußeren Tabellenrahmens zu ändern, geben Sie unter Rahmen im Feld Stärke eine Zahl in Pixel ein, um die Stärke des Tabellenrahmens zu vergrößern oder zu verkleinern. Wenn Sie 0 eingeben, wird der Tabellenrahmen unsichtbar.
  4. Um die Farbe des Tabellenrahmens zu ändern, führen Sie unter Rahmen einen der folgenden Schritte durch:
    • Um eine Farbe des Tabellenrahmens festzulegen, wählen Sie eine Farbe aus der Liste Farbe aus.
    • Um einen Rahmen mit zwei Farben festzulegen, was einen dreidimensionalen Effekt ergibt, wählen Sie jeweils eine Farbe aus den Listen Heller Rahmen und Dunkler Rahmen aus.

      • Die Farbe aus Farbe wird in dem Fall nicht verwendet. Wenn Sie jedoch nur eine Farbe entweder aus Heller Rahmen oder aus Dunkler Rahmen auswählen, wird die in Farbe ausgewählte Farbe als zweite Farbe verwendet.

    • Stellen Sie sicher, dass die Rahmenstärke größer als Null ist, andernfalls wird der Tabellenrahmen nicht angezeigt.


Ändern der Größe einer Zelle, Zeile oder Spalte

Sie können schnell die Größe einer Zelle, Zeile oder Spalte ändern, indem Sie deren Rahmen markieren und diesen mit der Maus zur gewünschten Länge oder Breite ziehen.

Größenänderung einer Spalte

Sie können auch markierte Zellen in ihrer Größe ändern, indem Sie Höhe und Breite angeben. Die Größe kann in Pixel oder als Prozentsatz der Tabellengröße angegeben werden.

  • Wenn eine Zellengröße in Pixel angegeben wird, bleibt ihre Größe konstant, unabhängig von der Größe der angezeigten Tabelle.
  • Wird die Zellengröße als Prozentsatz der Tabelle angegeben, ändert sie sich in Abhängigkeit von der Tabellengröße.
  • Wenn keine Höhe oder Breite angegeben ist, wird die Zelle entsprechend ihrem Inhalt dimensioniert.
  1. Markieren Sie in der Seitenansicht die Zellen, Zeilen oder Spalten, deren Größe Sie ändern möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften.
  3. Um die Breite anzugeben, aktivieren Sie das Kontrollkästchen Breite angeben, geben Sie einen Wert für die Breite der markierten Zelle ein, und aktivieren Sie dann entweder in Pixel oder in Prozent.
  4. Um die Höhe anzugeben, aktivieren Sie das Kontrollkästchen Höhe angeben, geben Sie einen Wert für die Höhe der markierten Zelle ein, und aktivieren Sie dann entweder in Pixel oder in Prozent.


Verändern der Größe einer Tabelle

Sie können schnell die Größe einer Tabelle verändern, indem Sie deren Rahmen markieren und die Tabelle mit der Maus auf die gewünschte Höhe oder Breite ziehen.

Verändern der Größe einer Tabelle

Sie können die Größe einer Tabelle ebenfalls durch Angabe ihrer Höhe und Breite verändern. Die Größe kann in Pixel oder als Prozentsatz der Seitengröße angegeben werden.

  • Wenn eine Tabellengröße in Pixel angegeben wird, bleibt diese unabhängig von der Größe der angezeigten Seite konstant.
  • Wenn eine Tabellengröße als Prozentsatz des Browserfensters angegeben wird, ändert sie sich abhängig von der Größe des Fensters.
  • Wenn keine Höhe oder Breite angegeben ist, wird die Tabellengröße an ihren Inhalt angepaßt.

Hinweis Wird eine Tabelle in einem Frame angezeigt, bezieht der Prozentsatz sich auf die Größe des Frame und nicht auf die gesamte Seite.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabelleneigenschaften.
  2. Um die Breite anzugeben, aktivieren Sie das Kontrollkästchen Breite angeben, geben Sie einen Wert für die Breite der markierten Zelle ein, und aktivieren Sie dann entweder in Pixel oder in Prozent.
  3. Um die Höhe anzugeben, aktivieren Sie das Kontrollkästchen Höhe angeben, geben Sie einen Wert für die Höhe der markierten Zelle ein, und aktivieren Sie dann entweder in Pixel oder in Prozent.


Markieren von Tabellenelementen

Wenn Sie mit Tabellen arbeiten, können Sie die gesamte Tabelle oder einzelne Elemente markieren. So können Sie z. B. eine Spalte markieren und dann für diese einheitliche Zelleneigenschaften festlegen.

Um folgendes Element zu markieren | Führen Sie in der Seitenansicht Folgendes durch
Tabelle | Klicken Sie auf eine beliebige Stelle innerhalb der Tabelle. Zeigen Sie im Menü Tabelle auf Markieren, und klicken Sie dann auf Tabelle. Oder bringen Sie den Mauszeiger auf die linke Seite der Tabelle, und doppelklicken Sie, wenn der Mauszeiger die Form eines Pfeils angenommen hat.
Zelle | Bringen Sie die Einfügemarke in eine Zelle, zeigen Sie im Menü Tabelle auf Markieren, und klicken Sie dann auf Zelle. Oder halten Sie die ALT gedrückt, und klicken Sie dann auf die Zelle. Um mehrere zusammenliegende Zellen zu markieren, ziehen Sie den Mauszeiger bei gedrückter Maustaste über die Zellen. Um nicht zusammenhängende Zellen zu markieren, halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf die Zellen.
Zeile | Bringen Sie den Mauszeiger über den linken Rand der Zeile, und klicken Sie, wenn der Mauszeiger die Form eines Pfeils angenommen hat. Um mehrere Zeilen zu markieren, ziehen Sie den Mauszeiger über die Zeilen.
Spalte | Bringen Sie den Mauszeiger über den oberen Rand der Spalte, und klicken Sie, wenn der Mauszeiger die Form eines Pfeils angenommen hat. Um mehrere Spalten zu markieren, ziehen Sie den Mauszeiger über die Spalten.
Tabellenbeschriftung | Bringen Sie den Mauszeiger links von der Beschriftung, und klicken Sie, wenn der Zeiger die Form eines Pfeils angenommen hat. Oder halten Sie die ALT gedrückt, und klicken Sie auf die Beschriftung.


Festlegen der Erstreckung von Zellen

Sie können die Breite oder Höhe einer Zelle anpassen, indem Sie die Anzahl von Zeilen und Spalten festlegen, die die Zelle umspannen soll. Durch Anpassen der Spannweite einer Zelle können Sie Zellen mit unterschiedlichen Höhen oder Breiten in einer Tabelle haben. So können Sie z. B. die Spannweite einer Zelle auf die Höhe von zwei Zeilen festlegen.

  1. Markieren Sie in der Seitenansicht die Zellen, Zeilen oder Spalten, für die Sie die Zellenspannweite festlegen möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften.
  3. Geben Sie im Feld Zeilenerstreckung die Anzahl von Zeilen an, die die Zellen umspannen sollen.
  4. Geben Sie im Feld Spaltenerstreckung die Anzahl von Spalten an, die die Zellen umspannen sollen.


Festlegen der Hintergrundfarbe einer Tabelle

Sie können die Hintergrundfarbe einer Tabelle festlegen. Dabei haben Sie die Möglichkeit, die Hintergrundfarbe für die gesamte Tabelle, für einzelne Zellen oder beides festzulegen. Wenn Sie die Hintergrundfarbe für einzelne Zellen und für die gesamte Tabelle festlegen, dann hat die Zellfarbe Vorrang. Im Beispiel weiter unten haben beide Tabellen Hintergrundfarben, doch die zweite Tabelle hat auch Hintergrundfarben für drei Zellen.

Festlegen von Hintergrundfarben für Tabellen und Zellen

Um eine Hintergrundfarbe festzulegen für eine | Führen Sie in der Seitenansicht Folgendes durch
Tabelle | Klicken Sie mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabelleneigenschaften. Wählen Sie unter Hintergrund aus der Liste Hintergrundfarbe eine Farbe für den Tabellenhintergrund aus.
Zelle | Markieren Sie die Zellen, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften. Wählen Sie unter Hintergrund aus der Liste Hintergrundfarbe eine Farbe für den Zellenhintergrund aus.

Tipp Sie können eine Hintergrundfarbe für eine markierte Tabelle oder Zellengruppe festlegen, indem Sie auf der Symbolleiste Tabellen auf Füllfarbe Schaltfläche "Füllfarbe" klicken. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Anzeigen eines Hintergrundbildes in einer Tabelle

Sie können in einer Tabelle ein Hintergrundbild anzeigen. Ein Hintergrundbild kann für eine ganze Tabelle oder für einzelne Zellen angezeigt werden. Wenn Sie Hintergrundbilder für beides definieren, hat der Zellenhintergrund Vorrang.

Name | Stadt
Jeff Smith | Los Angeles

Anmerkung Wenn Sie eine Hintergrundfarbe für die Tabelle festgelegt haben, ist diese nur sichtbar, wenn das Hintergrundbild eine transparente Farbe hat.

  1. Markieren Sie die Tabelle oder die Zellen, in denen Sie ein Hintergrundbild anzeigen möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften oder Tabelleneigenschaften, je nach Markierung.
  3. Aktivieren Sie das Kontrollkästchen Hintergrundbild verwenden, und klicken Sie dann auf Durchsuchen.
  4. Wählen Sie das Hintergrundbild aus:
    • Wenn sich das Bild in einem Web befindet, suchen Sie nach dem Web und dem Ordner auf, der das Bild enthält, markieren Sie das gewünschte Bild, und klicken Sie dann auf OK.
    • Wenn sich das Bild in Ihrem lokalen Netzwerk befindet, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie nach dem gewünschten Bild in Ihrem lokalen Netzwerk, und klicken Sie dann auf OK.
    • Wenn sich das Bild im World Wide Web befindet, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie in Ihrem Webbrowser nach dem gewünschten Bild, und wechseln Sie dann wieder zurück zu FrontPage. Der Speicherort der von Ihnen besuchten Seite wird im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn es sich bei dem Bild um ein ClipArt handelt, klicken Sie auf ClipArt, um die ClipArt Gallery von Microsoft anzuzeigen, klicken Sie mit der rechten Maustaste auf das gewünschte Bild, und klicken Sie dann im Kontextmenü auf Einfügen.

Anmerkung Sie können die Eigenschaften des Bildes festlegen, nachdem Sie es eingefügt haben. Klicken Sie in diesem Dialogfeld auf OK, klicken Sie mit der rechten Maustaste auf die Zelle, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften oder auf Tabelleneigenschaften, je nach Markierung.


Festlegen des Zellenlayouts

Sie können das Layout einer Zelle und ihres Inhalts durch Ändern der Zelleneigenschaften festlegen.

  1. Markieren Sie in der Seitenansicht die Zellen, für die Sie das Layout festlegen möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zelleneigenschaften.
  3. Wählen Sie in den Feldern Horizontale Ausrichtung und Vertikale Ausrichtung die für den Zelleninhalt gewünschte Ausrichtung aus.
  4. Um die Zellen als Kopfzeilenzellen zu definieren und hervorzuheben, aktivieren Sie Enthält Überschrift. Standardmäßig besteht die Hervorhebung aus Fettformatierung.
  5. Um zu verhindern, dass Webbrowser den Text in der Zelle umbrechen, aktivieren Sie das Kontrollkästchen Kein Umbruch.


Festlegen der Farbe eines Tabellenrahmens

Ein Tabellenrahmen kann eine oder zwei Farben haben. Wenn Sie zwei Farben verwenden, erhält der Rahmen ein dreidimensionales Aussehen.

Sie können Rahmenfarben für die gesamte Tabelle und für einzelne Zellen festlegen. Wenn Sie die Rahmenfarben für beide festlegen, hat die Zellenfarbe Vorrang.

Anmerkung Die Rahmenstärke muss größer als Null sein; anderfalls wird der Rahmen nicht angezeigt.

  1. Bringen Sie die Einfügemarke in der Seitenansicht in die Zelle oder Tabelle, für die Sie die Rahmenfarbe festlegen möchten.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann auf Zelleneigenschaften oder Tabelleneigenschaften, je nachdem, ob Sie die Rahmenfarbe für eine Zelle oder für eine Tabelle festlegen möchten.
  3. Führen Sie einen der folgenden Schritte durch:
    • Um eine Farbe für den Rahmen festzulegen, wählen Sie unter Rahmen aus der Liste Farbe eine Farbe aus.
    • Um einen zweifarbigen Rahmen für einen dreidimensionalen Effekt festzulegen, wählen Sie unter Rahmen aus den Listen Heller Rahmen und Dunkler Rahmen die entsprechenden Farben aus.

      • Die Farbe aus der Liste Farbe wird nicht benutzt. Wenn Sie jedoch nur eine Farbe entweder aus Heller Rahmen oder Dunkler Rahmen auswählen, wird die in der Liste Farbe ausgewählte Farbe als zweite Farbe verwendet.

    • Stellen Sie sicher, dass die Rahmenstärke größer als Null ist, andernfalls wird der Rahmen nicht angezeigt.


Zellen teilen

Sie können Zellen in Spalten oder Zeilen aufteilen, indem Sie diese teilen.

  1. Markieren Sie in der Seitenansicht die zu teilenden Zellen.
  2. Klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zellen teilen.
  3. Klicken Sie auf In Spalten teilen oder auf In Zeilen teilen.
  4. Geben Sie im Feld Anzahl der Spalten oder Anzahl der Zeilen die Anzahl der Spalten oder Zeilen ein, in die Sie die Zellen aufteilen möchten.

Tipp Sie können auch ausgewählte Zellen teilen, indem Sie auf der Symbolleiste Tabellen auf Zellen teilen Schaltfläche "Zellen teilen" klicken. Um die Symbolleiste Tabellen anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Tabellen.


Animieren eines Webs

Um mehr über das Animieren eines Webs zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Hinzufügen eines Soundeffekts zu einer Hoverschaltfläche

Verwenden Sie dieses Verfahren, wenn Sie einer bereits erstellten Hoverschaltfläche einen Soundeffekt hinzufügen möchten. Wenn der Sitebesucher auf die Hoverschaltfläche klickt oder mit der Maus hierauf zeigt, wird der Soundeffekt abgespielt.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Hoverschaltfläche, die Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Hoverschaltflächeneigenschaften.
  2. Klicken Sie auf Benutzerdefiniert.
  3. Wählen Sie im Bereich Sound abspielen die Aktion und den Soundeffekt aus:
    • Wenn der Soundeffekt abgespielt werden soll, wenn ein Sitebesucher auf die Hoverschaltfläche klickt, geben Sie den URL des Soundeffekts in das Feld Beim Klicken ein. Oder klicken Sie auf Durchsuchen, um den Soundeffekt zu suchen.
    • Wenn der Soundeffekt abgespielt werden soll, wenn ein Sitebesucher auf die Hoverschaltfläche zeigt, geben Sie den URL des Soundeffekts in das Feld Beim Hovern ein. Oder klicken Sie auf Durchsuchen, um den Soundeffekt zu suchen.

Anmerkung Da es sich bei Hoverschaltflächen eigentlich um Java-Applets handelt, können Sie nur Audiodateien als Soundeffekte verwenden, die im AU-Format (.au) vorliegen. Audiodateien im MIDI-Format (.midi) oder WAV-Format (.wav) können nicht eingebunden werden. Darüber hinaus müssen die AU-Dateien im Format 8-Bit, 8000 Hz, mono, u-law vorliegen.


Erstellen einer Laufschrift

Sie erstellen auf einer Seite eine Laufschrift, um eine horizontal durchlaufende Textmitteilung anzuzeigen, wie im nachstehenden Beispiel gezeigt:

Diese Laufschrift ist auf kontinuierliche Wiederholung und langsame Bewegung eingestellt.

  1. Klicken Sie in der Seitenansicht auf die Position, wo die Laufschrift erstellt werden soll, oder markieren Sie den Text, der in der Laufschrift angezeigt werden soll.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Laufschrift.
  3. Geben Sie im Feld Text die Textzeile ein, die in der Laufschrift angezeigt werden soll. Wenn Sie in Schritt 1 bereits auf der Seite befindlichen Text markiert haben, enthält das Feld Text den markierten Text.

Tipps

  • Wenn Sie anhand einer Vorschau prüfen möchten, wie die Laufschrift angezeigt wird, wenn der Besucher Ihrer Site im World Wide Web die Seite öffnet, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.
  • Sie können eine Laufschrift formatieren, um auf diese Weise die Richtung, die Geschwindigkeit, das Verhalten, die Ausrichtung, die Größe, die Anzahl der Wiederholungen und die Hintergrundfarbe einzustellen.
  • Sie können die Schriftart einer Laufschrift formatieren, um Schriftgröße, Schriftschnitt, Farbe und Zeichenabstand anzugeben.


Erstellen einer Hoverschaltfläche

Eine Hoverschaltfläche ist eine einfache Möglichkeit, um Ihrem Web ohne jegliche Skripterstellung eine Animation hinzuzufügen. Wie jede andere Schaltfläche verfügt auch eine Hoverschaltfläche über einen Hyperlink zu einer anderen Seite oder einer anderen Datei. Wenn ein Sitebesucher jedoch auf eine Hoverschaltfläche klickt oder zeigt, kann eine solche Schaltfläche auch zu leuchten beginnen, es kann eine benutzerdefinierte Grafik angezeigt oder ein Soundeffekt abgespielt werden.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der Sie eine Hoverschaltfläche erstellen möchten.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Hoverschaltfläche.
  3. Geben Sie im Feld Schaltflächentext die Textbeschriftung für die Hoverschaltfläche ein. Lassen Sie dieses Feld leer, wenn Sie eine benutzerdefinierte Grafik verwenden möchten, die bereits über eine Textbeschriftung verfügt.
  4. Geben Sie im Feld Hyperlink zu den URL der Seite oder der Datei ein, die angezeigt werden soll, wenn der Sitebesucher auf die Hoverschaltfläche klickt. Oder klicken Sie auf Durchsuchen, um die Seite oder die Datei zu suchen.

Tipps

  • Sie können ein Bild für eine Hoverschaltfläche festlegen, oder Sie können ein Bild für einen Hovereffekt auf einer Hoverschaltfläche festlegen.
  • Sie können Eigenschaften für eine Hoverschaltfläche festlegen, um Vorgaben für Textbeschriftung, Schriftgröße und Zeichen oder die Art der Spezialeffekte zu machen.
  • Sie können einer Hoverschaltfläche einen Soundeffekt hinzufügen, der abgespielt wird, wenn der Sitebesucher auf die Hoverschaltfläche klickt oder zeigt.
  • Wenn Sie anhand einer Vorschau prüfen möchten, wie die Hoverschaltfläche angezeigt wird, wenn der Besucher Ihrer Site im World Wide Web die Seite öffnet, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.


Erstellen eines Anzeigenwechslers

Ein Anzeigenwechsler ist wie eine sich drehende Reklametafel auf einer Webseite. Hierin werden in einer zeitlich festgelegten Reihenfolge Bilder angezeigt, wobei zwischen den einzelnen Bildern ein Übergangseffekt zum Einsatz kommt.

Im Normalfall verwenden Autoren Anzeigenwechsler, um kommerzielle Werbung auf Seiten zu platzieren.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der der Anzeigenwechsler erstellt werden soll.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Anzeigenwechsler.
  3. Klicken Sie für jedes Bild, das im Anzeigenwechsler angezeigt werden soll, auf Hinzufügen, und wählen Sie dann das Bild aus.
  4. Die Bilder, die Sie bereits hinzugefügt haben, und die Reihenfolge, in der die Bilder angezeigt werden, werden in der Liste im Feld Anzuzeigende Bilder aufgeführt. Zum Ändern der Reihenfolge markieren Sie den URL eines Bildes in der Liste, und klicken Sie dann auf Nach oben oder Nach unten.
  5. Wählen Sie im Feld Übergangseffekt den Effekt aus, der zwischen Bildern verwendet werden soll.

    6. Tipp Die beste Methode zur Auswahl eines Übergangseffekts besteht darin, einen Anzeigenwechsler zu erstellen, diesen in der Vorschau anzuzeigen und solange mit den verschiedenen Effekten zu experimentieren, bis Sie denjenigen finden, der Ihren Anforderungen entspricht. Um einen Anzeigenwechsler in der Vorschau zu betrachten, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.

  6. Wenn Sie für den Anzeigenwechsler einen Hyperlink erstellen möchten, geben Sie im Feld Hyperlink zu einen URL ein, oder klicken Sie auf Durchsuchen, um die Zielseite oder -datei zu suchen, auf die der Hyperlink verweisen soll.

Tipp Sie können Eigenschaften für einen Anzeigenwechsler festlegen, den Sie bereits erstellt haben, wenn Sie die angezeigten Bilder, den Übergangseffekt, die Standzeit jedes Bildes o. ä. einstellen möchten.


Formatieren einer Laufschrift

Mit einer Laufschrift wird eine durchlaufende Textmitteilung angezeigt. Sie können eine Laufschrift Ihren Anforderungen entsprechend anpassen, um exakt die gewünschten Effekte zu erzielen, wie im nachfolgenden Beispiel gezeigt:

Bei dieser Laufschrift erfolgt ein Wechsel zwischen Umlaufen und Einschieben, sie wird zweimal wiederholt, und es wird ein gelber Hintergrund verwendet, um sie von umgebendem Text abzuheben.

Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Laufschrift, die Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Laufschrifteigenschaften.

  • Geben Sie den gewünschten Text, den eine Laufschrift enthalten soll, in das Feld Text ein (hinsichtlich der Länge gibt es keinerlei Einschränkungen).
  • Wenn Sie die Richtung vorgeben möchten, in die sich der Text in einer Laufschrift bewegt, klicken Sie auf Links oder Rechts.
  • Um die Geschwindigkeit anzugeben, mit der sich der Text in einer Laufschrift bewegt, geben Sie im Feld Verzögerung die Verzögerung in Millisekunden ein, die eingehalten werden soll, bevor sich die Laufschrift zu bewegen beginnt, oder wählen Sie diese aus. Geben Sie im Feld Betrag die Schrittweite in Pixel ein, mit der sich die Laufschrift bewegen soll, oder wählen Sie einen Wert aus.
  • Wenn Sie die Art der Bewegung angeben möchten, die zur Animation des Textes in einer Laufschrift verwendet werden soll, klicken Sie auf Umlaufen, wenn die Laufschrift wie ein Börsenticker über den Bildschirm laufen soll, klicken Sie auf Einschieben, wenn die Laufschrift ins Blickfeld geschoben werden soll, oder klicken Sie auf Oszillieren, wenn die Laufschrift zwischen Umlaufen und Einschieben wechseln soll.
  • Um eine Laufschrift am umgebenden Text auszurichten, klicken Sie auf Oben, Mitte oder Unten.
  • Wenn Sie die Größe einer Laufschrift angeben möchten, aktivieren Sie die Kontrollkästchen Breite oder Höhe, geben Sie die Breite oder Höhe ein, und wählen Sie dann, ob die Breite oder Höhe in Pixel oder als Prozentsatz des Browserfensters angegeben wird.
  • Um anzugeben, wie viele Male der Texteffekt in einer Laufschrift wiederholt werden soll, aktivieren Sie das Kontrollkästchen Kontinuierlich, wenn die Laufschrift fortlaufend wiederholt werden soll. Wenn die Laufschrift nur mit einer festgelegten Häufigkeit angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Kontinuierlich, und geben Sie dann die Häufigkeit ein, mit der eine Laufschrift wiederholt werden soll.
  • Zum Festlegen der Hintergrundfarbe einer Laufschrift wählen Sie im Feld Hintergrundfarbe die gewünschte Farbe aus, die als Hintergrund des umlaufenden Textes der Laufschrift verwendet werden soll.

Tipp Sie können auch die Schriftart einer Laufschrift formatieren, um den Schriftschnitt, die Schriftgröße, die Schriftfarbe, den Zeichenabstand usw. einzustellen.


Formatieren der Schriftart einer Laufschrift

Sie können Ihre Laufschrift noch stärker hervorheben, indem Sie die Schriftart des Textes formatieren, der in der Laufschrift angezeigt wird. Sie können hierzu eine benutzerdefinierte Schriftart auswählen oder eine andere Schriftfarbe verwenden, wie im folgenden Beispiel dargestellt:

Für diese Laufschrift wurde als Schriftart Verdana, fett, kursiv und rot verwendet.

  • Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Laufschrift, die Sie formatieren möchten, und klicken Sie dann im Kontextmenü auf Zeichen.
    • Zum Formatieren von Schriftschnitt, Größe, Farbe oder Effekten ändern Sie die Einstellungen auf der Registerkarte Schrift.
    • Wenn Sie den Abstand zwischen den einzelnen Zeichen erhöhen oder verringern oder den Text höher oder tiefer stellen möchten, ändern Sie die Einstellungen auf der Registerkarte Zeichenabstand.

Tipp Sie können auch eine Laufschrift formatieren, um Eigenschaften wie den angezeigten Text, die Laufrichtung oder das Laufverhalten einzustellen.


Animieren eines Seitenelements

Sie können beinahe jedem Element auf einer Seite, d. h. Text, Absätzen, Bildern, Schaltflächen, Laufschrift usw. DHTML-Animationseffekte (Dynamic HTML) zuweisen und diesen Effekt mit einem auslösenden Ereignis verbinden, wie beispielsweise dem Klicken oder Zeigen mit der Maus, dem Laden einer Seite usw. Sie können auch eine Animation erstellen, bei der Text von der rechten Seite ins Blickfeld „fliegt“, wenn die Seite geladen wird, wie im folgenden Beispiel gezeigt:

Mithilfe einer DHTML-Animation „fliegt“ dieser Text von rechts ins Blickfeld, wenn die Seite geladen wird.

  1. Wählen Sie das Seitenelement aus, das Sie animieren möchten, und klicken Sie dann im Menü Format auf Dynamic HTML-Effekte.

    2. Hiermit wird die Symbolleiste DHTML-Effekte angezeigt.

  2. Klicken Sie im Feld Bei auf den nach unten weisenden Pfeil, und wählen Sie das Ereignis aus, mit dem die Animation ausgelöst werden soll:
    • Wenn die Animation gestartet werden soll, wenn der Sitebesucher auf das Seitenelement zeigt und einmal mit der rechten Maustaste klickt, wählen Sie Klicken.
    • Um die Animation zu starten, wenn der Sitebesucher auf das Seitenelement zeigt und mit der linken Maustaste doppelklickt, wählen Sie Doppelklicken.
    • Wenn die Animation gestartet werden soll, wenn der Sitebesucher auf das Seitenelement zeigt und den Mauszeiger hierauf belässt, wählen Sie Mouseover.
    • Um die Animation zu starten, wenn die Seite im Browser des Sitebesuchers geladen wird, wählen Sie Laden der Seite.

    Anmerkung Die im Feld Bei aufgeführten Ereignisse sind abhängig von der Art des ausgewählten Seitenelements.

  3. Klicken Sie im Feld Übernehmen auf den nach unten weisenden Pfeil, und wählen Sie dann die Art des Animationseffekts aus, den Sie verwenden möchten:
    • Um eine Animation zuzuweisen, mit der ein Seitenelement bewegt wird, klicken Sie auf Ausfliegen, Einfliegen, Wörter von oben, Elastisch oder eine der anderen Bewegungsanimationen.
    • Wenn Sie eine Animation zuweisen möchten, mit der das Aussehen eines Seitenelements geändert wird, wie beispielsweise das Ändern der Zeichenfarbe oder das Zuweisen eines Rahmeneffekts, klicken Sie auf Format.
    • Wenn Sie ein Bild ausgewählt haben und eine Animation zuweisen möchten, bei der abwechselnd dieses und ein anderes Bild angezeigt wird, klicken Sie auf Bild austauschen.

    Anmerkung Die im Feld Übernehmen aufgeführten Effekte sind abhängig vom ausgewählten Seitenelement und von der Art des auslösenden Ereignisses, das Sie in Schritt 2 gewählt haben.

  4. Klicken Sie im Feld Einstellungen auswählen auf den nach unten weisenden Pfeil, und wählen Sie dann die Einstellungen für den Effekt aus:
    • Wenn Sie in Schritt 3 die Animation Ausfliegen zugewiesen haben, wählen Sie die Richtung oder die Art der Bewegung aus, wie beispielsweise nach links oder Wörter nach rechts oben.
    • Wenn Sie sich in Schritt 3 für die Animation Formatierung entschieden haben, klicken Sie nun auf Schriftart wählen, um den Schriftschnitt, die Größe, die Farbe, die Effekte oder den Zeichenabstand zu ändern, oder klicken Sie auf Rahmen wählen, um den Rahmen oder die Schattierung zu ändern.
    • Wenn Sie ein Bild gewählt und sich in Schritt 3 für den Effekt Bild austauschen entschieden haben, klicken Sie auf Bild auswählen, und wählen Sie dann das Bild aus, das bei Eintreten des in Schritt 2 gewählten Ereignisses alternativ angezeigt werden soll.

    Anmerkung Die im Feld Einstellungen auswählen aufgeführten Einstellungen sind abhängig von der Art des gewählten Seitenelements und der Art des im Feld Übernehmen gewählten Effekts.

Tipps

  • Die beste Methode zur Auswahl der passenden Animation besteht darin, mit dem Zuweisen von Ereignissen und Effekten zu experimentieren und die Seite dann in einem Browser in der Vorschau zu betrachten. Um die Seite in der Vorschau zu betrachten, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.
  • Zum Entfernen eines Effekts klicken Sie auf der Symbolleiste DHTML-Effekte auf Effekt entfernen. Sie können eine Animation auch in der Seitenansicht entfernen, indem Sie das entsprechende Seitenelement markieren und dann STRG+LEER drücken.
  • Sie können eine Animation von einem Seitenelement auf ein anderes übertragen, in dem Sie die Funktion Format übertragen Schaltfläche "Format übertragen" verwenden. Markieren Sie das Element, dessen Animation Sie kopieren möchten, klicken Sie auf Format übertragen Schaltfläche "Format übertragen", und klicken Sie dann auf das Seitenelement, dem Sie die Animation zuweisen möchten.
  • Den meisten Seitenelementen können Sie auch mehrere Effekte zuweisen. Beispielsweise können Sie für Text eine Animation zusammenstellen, bei der dieser von rechts "einfliegt", wenn die Seite geladen wird, und der dann mit einem Rahmen umgeben wird, der angezeigt wird, wenn der Sitebesucher auf den Text klickt.


Erstellen eines Übergangseffekts für eine Seite oder ein Web

Sie können Spezialeffekte erstellen, die angezeigt werden, wenn ein Besucher Ihre Site öffnet oder verlässt oder eine bestimmte Seite lädt oder schließt. Bei der vorliegenden Seite wird beispielsweise ein 5 Sekunden dauernder Effekt mit Namen „Vertikal blenden“ verwendet, der angezeigt wird, wenn der Besucher die Seite zum ersten Mal öffnet. Mit einheitlich und umsichtig im gesamten Web eingesetzten Übergangseffekten können Sie wirkungsvolle Präsentationen nach Art einer Slide-Show mit professionellen Übergängen zwischen Seiten erstellen.

  1. Öffnen Sie in der Seitenansicht die Seite, für die Sie den Übergangseffekt anzeigen möchten. Klicken Sie im Menü Format auf Seitenübergang.
  2. Klicken Sie im Feld Ereignis auf das Ereignis, mit dem der Übergangseffekt ausgelöst werden soll. Klicken Sie beispielsweise auf Seite betreten, wenn der Übergangseffekt angezeigt werden soll, wenn der Sitebesucher die Seite zum ersten Mal öffnet.
  3. Klicken Sie im Feld Übergangseffekt auf die Art des Übergangseffekts, der verwendet werden soll, wenn die Seite angezeigt oder verlassen wird.

    4. Tipp Die beste Methode zum Auswählen eines Übergangseffekts besteht darin, einen Übergangseffekt zu erstellen, die Seite zu speichern und diese dann in Ihrem Browser in der Vorschau zu betrachten.

  4. Geben Sie im Feld Dauer die Zeit an, wie lange der Übergangseffekt dauern soll.

Tipp Wenn Sie ein bestimmtes Seitenelement beim Laden der Seite animieren möchten, markieren Sie das Seitenelement und klicken dann im Menü Format auf Dynamic HTML-Effekte. Klicken Sie auf der Symbolleiste DHTML-Effekte im Feld Bei auf Laden der Seite, und wählen Sie den Animationseffekt und die gewünschten Einstellungen in den anderen Feldern aus.


Festlegen von Eigenschaften für eine Hoverschaltfläche

Sie können die Textbeschriftung, den Standardhyperlink, die Effekte, die Farbe und die Größe einer Hoverschaltfläche ändern.

Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Hoverschaltfläche, die Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Hoverschaltflächeneigenschaften:

  • Wenn Sie die Textbeschriftung festlegen möchten, geben Sie die zu verwendende Beschriftung in das Feld Schaltflächentext ein. Wenn Sie eine lange Beschriftung eingeben, passen Sie die Breite der Hoverschaltfläche an die Länge der Beschriftung an.
  • Zum Festlegen des Standardhyperlinks geben Sie im Feld Hyperlink zu den URL der Seite oder der Datei ein, die angezeigt werden soll, wenn der Sitebesucher auf die Hoverschaltfläche klickt. Sie können auch auf Durchsuchen klicken, um die Seite oder die Datei zu suchen.
  • Um die Farbe festzulegen, die für die Schaltfläche verwendet werden soll, wenn diese anfänglich auf der Seite angezeigt wird, wählen Sie die gewünschte Farbe im Feld Schaltflächenfarbe aus.

    • Anmerkung Wenn Sie auf Benutzerdefiniert klicken und ein Bild auswählen, das für die Hoverschaltfläche verwendet werden soll, hat das Ändern der Schaltflächenfarbe keinerlei Effekt.

  • Zum Festlegen der Hintergrundfarbe der Schaltfläche wählen Sie im Feld Hintergrundfarbe eine Farbe für den Hintergrund der Hoverschaltfläche aus. Die Hintergrundfarbe kann zwar nicht transparent gemacht werden, Sie können jedoch die Hintergrundfarbe der Schaltfläche der Hintergrundfarbe der Seite entsprechend wählen.
  • Um den Hovereffekt festzulegen, wählen Sie im Feld Effekt den visuellen Effekt aus, der angezeigt wird, wenn der Sitebesucher auf die Schaltfläche zeigt.
  • Wenn Sie die Farbe des Hovereffekts festlegen möchten, wählen Sie diese im Feld Effektfarbe aus.
  • Zum Festlegen der Größe der Hoverschaltfläche ändern Sie die Einstellungen der Felder Breite und Höhe, indem Sie einen Wert in Pixel eingeben.

Tipps

  • Wenn Sie ein benutzerdefiniertes Bild für eine Hoverschaltfläche verwenden oder der Schaltflächentext ungewöhnlich lang ist, legen Sie die Breite und Höhe der Schaltfläche entsprechend der Breite und Höhe des Bildes oder der Länge des Schaltflächentexts fest.
  • Sie können auch ein Bild für eine Hoverschaltfläche festlegen oder ein Bild für einen Hovereffekt auf einer Hoverschaltfläche festlegen.
  • Sie können einer Hoverschaltfläche einen Soundeffekt hinzufügen, der abgespielt wird, wenn der Besucher auf die Hoverschaltfläche klickt oder auf diese zeigt.


Festlegen eines Bildes für eine Hoverschaltfläche

Sie können als Hintergrund einer Hoverschaltfläche ein Bild verwenden.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Hoverschaltfläche, und klicken Sie dann im Kontextmenü auf Hoverschaltflächeneigenschaften.
  2. Klicken Sie auf Benutzerdefiniert.
  3. Geben Sie im Feld Schaltfläche den URL des Bildes ein, das Sie als Hintergrund für die Hoverschaltfläche verwenden möchten, und klicken Sie dann auf OK. Sie können auch auf Durchsuchen klicken, um das Bild zu suchen.
  4. Geben Sie in den Feldern Breite und Höhe die Breite und Höhe des Bildes in Pixel ein, und klicken Sie auf OK. Die Größe der Hoverschaltfläche muss der Größe des Bildes entsprechen.

Tipp Sie können auch ein Bild für einen Hovereffekt auf einer Hoverschaltfläche festlegen. Wenn der Sitebesucher nun auf die Hoverschaltfläche zeigt, wird das Bild angezeigt, das für den Hovereffekt ausgewählt wurde.


Festlegen eines Bildes für einen Hovereffekt auf einer Hoverschaltfläche

Sie können ein Bild für einen Hovereffekt auf einer Hoverschaltfläche festlegen. Wenn der Sitebesucher nun auf die Hoverschaltfläche zeigt, wird dieses Bild angezeigt.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Hoverschaltfläche, und klicken Sie dann im Kontextmenü auf Hoverschaltflächeneigenschaften.
  2. Klicken Sie auf Benutzerdefiniert.
  3. Geben Sie im Feld Beim Hovern den URL des Bildes ein, das Sie für den Hovereffekt auf der Hoverschaltfläche verwenden möchten, und klicken Sie dann auf OK. Sie können auch auf Durchsuchen klicken, um das Bild zu suchen.
  4. Geben Sie in den Feldern Breite und Höhe die Breite und Höhe des Bildes in Pixel ein, und klicken Sie auf OK. Die Größe der Hoverschaltfläche muss der Größe des Bildes entsprechen, das Sie für den Hovereffekt verwenden.

Tipp Sie können auch ein Bild für eine Hoverschaltfläche festlegen.


Festlegen von Eigenschaften für einen Anzeigenwechsler

Sie können die Größe, den Übergangseffekt, die Standzeit und die Reihenfolge der Bilder in einem Anzeigenwechsler ändern.

Klicken Sie in der Seitenansicht mit der rechten Maustaste auf den Anzeigenwechsler, den Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Anzeigenwechslereigenschaften:

  • Wenn Sie die Größe des Anzeigenwechslers festlegen möchten, geben Sie die gewünschte Größe in Pixel in die Felder Breite und Höhe ein. Die Größe sollte dem größten Bild entsprechen, das im Anzeigenwechsler angezeigt wird.
  • Wenn Sie einen Übergangseffekt festlegen möchten, der zwischen einzelnen Bildern angezeigt werden soll, klicken Sie im Feld Übergangseffekt auf die Art des Übergangseffekts, der verwendet werden soll.

    • Tipp Die beste Methode zur Auswahl eines Übergangseffekts besteht darin, einen Anzeigenwechsler zu erstellen, diesen in der Vorschau anzuzeigen und solange mit den verschiedenen Effekten zu experimentieren, bis Sie denjenigen finden, der Ihren Anforderungen entspricht. Um einen Anzeigenwechsler in der Vorschau zu betrachten, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.

  • Zum Festlegen der Standzeit eines Bildes geben Sie im Feld Anzeigedauer jedes Bildes (Sekunden) die Anzeigedauer in Sekunden ein, die jedes Bild im Anzeigenwechsler angezeigt werden soll.
  • Wenn Sie den Standardhyperlink für einen Anzeigenwechsler festlegen möchten, geben Sie den URL der Zielseite des Hyperlinks in das Feld Hyperlink zu ein. Sie können auch auf Durchsuchen klicken, um die Seite oder die Datei zu suchen.
  • Um die Bilder festzulegen, die im Anzeigenwechsler angezeigt werden sollen, aktivieren Sie die Liste im Feld Anzuzeigende Bilder, in der die Bilder in der Reihenfolge aufgeführt werden, in der sie im Anzeigenwechsler angezeigt werden. Wenn Sie der Liste ein Bild hinzufügen möchten, klicken Sie auf Hinzufügen. Um ein Bild aus der Liste zu entfernen, klicken Sie auf Entfernen. Wenn Sie die Liste neu ordnen möchten, klicken Sie auf das Bild, das Sie verschieben möchten, und klicken dann auf Nach oben oder Nach unten.


Hervorheben animierter Elemente auf der Registerkarte "Normal" in der Seitenansicht

Hervorheben animierter Elemente auf der Registerkarte „Normal“ in der Seitenansicht

Wenn Sie eine Seite auf der Registerkarte Normal in der Seitenansicht bearbeiten, können Sie unter Seitenelementen, bei denen DHTML-Animationen (Dynamic HTML) oder Effekte (wie beispielsweise Text, der von der Seite „fliegt“, oder ein Bild, das sich ändert, wenn der Sitebesucher darauf klickt) verwendet werden, eine Hervorhebung aktivieren. Auf diese Weise können Sie auf den ersten Blick erkennen, bei welchen Seitenelementen DHTML-Animation oder Effekte verwendet werden.

  1. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf DHTML-Effekte, sofern dieser Menüpunkt nicht bereits mit einem Häkchen versehen ist.
  2. Klicken Sie auf der Symbolleiste DHTML-Effekte auf Dynamic HTML-Effekte hervorheben Schaltfläche "Dynamic HTML-Effekte hervorheben".

Tipps

  • Wenn Sie die Einzelheiten eines Effekts, der einem Element zugewiesen wurde, schnell anzeigen möchten, zeigen Sie auf das Element.
  • Sie können eine Animation von einem Seitenelement auf ein anderes übertragen, indem Sie die Funktion Format übertragen Schaltfläche "Format übertragen" verwenden. Markieren Sie das Element, dessen Animation Sie kopieren möchten, klicken Sie auf Format übertragen Schaltfläche "Format übertragen", und klicken Sie dann auf das Seitenelement, dem Sie die Animation zuweisen möchten.
  • Wenn Sie eine Animation von einem Seitenelement entfernen möchten, markieren Sie das Seitenelement und drücken STRG+LEER.


Ändern der Animation eines Seitenelements

Sie können beinahe jedem Element auf einer Seite, d. h. Text, Absätzen, Bildern, Schaltflächen, Laufschrift, Anzeigenwechseln usw. DHTML-Animationseffekte (Dynamic HTML) zuweisen und diesen Effekt mit einem auslösenden Ereignis verbinden, wie beispielsweise dem Klicken oder Zeigen mit der Maus, dem Laden einer Seite usw. Sie können auch eine Animation erstellen, bei der Text von der rechten Seite ins Blickfeld „fliegt“, wenn die Seite geladen wird, wie im folgenden Beispiel gezeigt:

Mithilfe einer DHTML-Animation „fliegt“ dieser Text von rechts ins Blickfeld, wenn die Seite geladen wird.

  1. Markieren Sie in der Seitenansicht das animierte Seitenelement, das Sie ändern möchten, und klicken Sie dann im Menü Format auf Dynamic HTML-Effekte.

    2. Hiermit wird die Symbolleiste DHTML-Effekte angezeigt.

  2. Klicken Sie im Feld Bei auf den nach unten weisenden Pfeil, und wählen Sie das Ereignis aus, mit dem die Animation ausgelöst werden soll:
    • Wenn die Animation gestartet werden soll, wenn der Sitebesucher auf das Seitenelement zeigt und einmal mit der rechten Maustaste klickt, wählen Sie Klicken.
    • Um die Animation zu starten, wenn der Sitebesucher auf das Seitenelement zeigt und mit der linken Maustaste doppelklickt, wählen Sie Doppelklicken.
    • Wenn die Animation gestartet werden soll, wenn der Sitebesucher auf das Seitenelement zeigt und den Mauszeiger hierauf belässt, wählen Sie Mouseover.
    • Um die Animation zu starten, wenn die Seite im Browser des Sitebesuchers geladen wird, wählen Sie Laden der Seite.

    Anmerkung Die im Feld Bei aufgeführten Ereignisse sind abhängig von der Art des ausgewählten Seitenelements.

  3. Klicken Sie im Feld Übernehmen auf den nach unten weisenden Pfeil, und wählen Sie dann die Art des Animationseffekts aus, den Sie verwenden möchten:
    • Um eine Animation zuzuweisen, mit der ein Seitenelement bewegt wird, klicken Sie auf Ausfliegen, Einfliegen, Wörter von oben, Elastisch oder eine der anderen Bewegungsanimationen.
    • Wenn Sie eine Animation zuweisen möchten, mit der das Aussehen eines Seitenelements geändert wird, wie beispielsweise das Ändern der Zeichenfarbe oder das Zuweisen eines Rahmeneffekts, klicken Sie auf Formatierung.
    • Wenn Sie ein Bild ausgewählt haben und eine Animation zuweisen möchten, bei der abwechselnd dieses und ein anderes Bild angezeigt wird, klicken Sie auf Bild austauschen.

    Anmerkung Die im Feld Übernehmen aufgeführten Effekte sind abhängig vom ausgewählten Seitenelement und von der Art des auslösenden Ereignisses, das Sie in Schritt 2 gewählt haben.

  4. Klicken Sie im Feld Einstellungen auswählen auf den nach unten weisenden Pfeil, und wählen Sie dann die Einstellungen für den Effekt aus:
    • Wenn Sie in Schritt 3 die Animation Ausfliegen zugewiesen haben, wählen Sie die Richtung oder die Art der Bewegung aus, wie beispielsweise nach links oder Wörter nach rechts oben.
    • Wenn Sie sich in Schritt 3 für die Animation Formatierung entschieden haben, klicken Sie nun auf Schriftart wählen, um den Schriftschnitt, die Größe, die Farbe, die Effekte oder den Zeichenabstand zu ändern, oder klicken Sie auf Rahmen wählen, um den Rahmen oder die Schattierung zu ändern.
    • Wenn Sie ein Bild gewählt und sich in Schritt 3 für den Effekt Bild austauschen entschieden haben, klicken Sie auf Bild auswählen, und wählen Sie dann das Bild aus, das bei Eintreten des in Schritt 2 gewählten Ereignisses alternativ angezeigt werden soll.

    Anmerkung Die im Feld Einstellungen auswählen aufgeführten Einstellungen sind abhängig von der Art des gewählten Seitenelements und der Art des im Feld Übernehmen gewählten Effekts.

Tipps

  • Zum Hervorheben von Seitenelementen, bei denen DHTML-Animation verwendet wird, klicken Sie auf der Symbolleiste DHTML-Effekte auf DHTML-Effekte hervorheben Schaltfläche "DHTML-Effekte hervorheben".
  • Wenn Sie die Einzelheiten einer DHTML-Animation, die einem Seitenelement zugewiesen wurde, schnell anzeigen möchten, zeigen Sie auf das Element.
  • Die beste Methode zur Auswahl der passenden Animation besteht darin, mit dem Zuweisen von Ereignissen und Effekten zu experimentieren und die Seite dann in einem Browser in der Vorschau zu betrachten. Um die Seite in der Vorschau zu betrachten, klicken Sie auf die Registerkarte Vorschau oder im Menü Datei auf Vorschau in Browser.
  • Zum Entfernen eines Effekts klicken Sie auf der Symbolleiste DHTML-Effekte auf Effekt entfernen. Sie können eine Animation auch in der Seitenansicht entfernen, indem Sie das entsprechende Seitenelement markieren und dann STRG+LEER drücken.
  • Sie können eine Animation von einem Seitenelement auf ein anderes übertragen, indem Sie die Funktion Format übertragen Schaltfläche "Format übertragen" verwenden. Markieren Sie das Element, dessen Animation Sie kopieren möchten, klicken Sie auf Format übertragen Schaltfläche "Format übertragen", und klicken Sie dann auf das Seitenelement, dem Sie die Animation zuweisen möchten.
  • Den meisten Seitenelementen können Sie auch mehrere Effekte zuweisen. Beispielsweise können Sie für Text eine Animation zusammenstellen, bei der dieser von rechts „einfliegt“, wenn die Seite geladen wird, und der dann mit einem Rahmen umgeben wird, wenn der Sitebesucher auf den Text klickt.


Entfernen einer Animation von einem Seitenelement

Wenn Sie einem Seitenelement eine DHTML-Animation (Dynamic HTML) oder einen Spezialeffekte zugewiesen haben, können Sie die Animation einfach entfernen, ohne das Seitenelement zu löschen. Wenn Sie beispielsweise eine Animation erstellt haben, bei der ein Absatz nach links von der Seite „fliegt“, wenn der Besucher darauf klickt, können Sie diese Animation entfernen, wobei der Absatz jedoch intakt bleibt.

  • Markieren Sie in der Seitenansicht das Seitenelement, von dem Sie eine Animation oder einen Effekt entfernen möchten, und drücken Sie dann STRG+LEER. Wenn die Symbolleiste DHTML-Effekte angezeigt wird, können Sie auch auf Effekt entfernen klicken.

Tipps

  • Zum Hervorheben von Seitenelementen, bei denen DHTML-Animation verwendet wird, klicken Sie auf der Symbolleiste DHTML-Effekte auf Dynamic HTML-Effekte hervorheben Schaltfläche "Dynamic HTML-Effekte hervorheben".
  • Sie können eine Animation von einem Seitenelement auf ein anderes übertragen, indem Sie die Funktion Format übertragen Schaltfläche "Format übertragen" verwenden. Markieren Sie das Element, dessen Animation Sie kopieren möchten, klicken Sie auf Format übertragen Schaltfläche "Format übertragen", und klicken Sie dann auf das Seitenelement, dem Sie die Animation zuweisen möchten.


Festlegen von Eigenschaften für einen Videoclip

Sie können angeben, wie ein Videoclip im Webbrowser eines Sitebesuchers abgespielt werden soll.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf den Videoclip, und klicken Sie dann im Kontextmenü auf Bildeigenschaften.
  2. Aktivieren Sie auf der Registerkarte Video das Kontrollkästchen Steuerelemente in Browser anzeigen, um im Webbrowser des Sitebesuchers Videosteuerelemente bereitzustellen, damit dieser die Möglichkeit hat, die Wiedergabe des Videoclips individuell zu steuern.

    3. Anmerkung Diese Funktion wird nicht von allen Webbrowsern unterstützt.

  3. Wenn der Videoclip jedes Mal abgespielt werden soll, wenn die Seite im Webbrowser des Sitebesuchers geladen wird, aktivieren Sie das Kontrollkästchen Beim Öffnen der Datei.
  4. Wenn der Videoclip immer dann abgespielt werden soll, wenn der Sitebesucher mit dem Mauszeiger hierauf zeigt, aktivieren Sie das Kontrollkästchen Wenn die Maus darauf zeigt.
  5. Geben Sie im Feld Durchläufe an, wie oft der Videoclip abgespielt werden soll, oder wählen Sie Kontinuierlich, wenn der Videoclip ständig abgespielt werden soll. Wenn zwischen den einzelnen Durchläufen eine Zeitverzögerung geschaltet werden soll, geben Sie die Verzögerung in Millisekunden in das Feld Durchlaufverzögerung ein.

Tipp Wenn Microsoft Internet Explorer auf Ihrem Computer installiert ist, können Sie prüfen, wie der Videoclip mit den aktuellen Einstellungen abgespielt wird, indem Sie auf die Registerkarte Vorschau klicken.


Hinzufügen eines Java-Applets

  1. Zeigen Sie im Menü Einfügen auf Erweitert, und klicken Sie dann auf Java-Applet.
  2. Geben Sie in das Feld Applet-Quelle den Namen der Java-Applet-Quelldatei ein. Java-Applet-Quelldateien haben in der Regel die Dateierweiterung CLASS.
  3. Geben Sie in das Feld Applet-Basis-URL den URL oder den Ordner ein, der die Java-Applet-Quelldatei enthält.
  4. Geben Sie in das Feld Meldung für Browser, die Java nicht unterstützen HTML- oder unformatierten Text ein, der an Stelle des Java-Applets angezeigt werden soll, wenn ein Browser Java-Applets nicht unterstützt.
  5. Klicken Sie unter Appletparameter für jeden Parameter, den Sie an das Java-Applet übergeben möchten, auf Hinzufügen, und geben Sie dann den Namen des Parameters und, sofern erforderlich, den Wert des Parameters ein.

    6. Anmerkung Da Java keine Möglichkeit zum Anzeigen der gültigen Eigenschaften und Werte eines bestimmten Applets bietet, suchen Sie diese Informationen in der im Lieferumfang des Java-Applets enthaltenen Dokumentation, und geben Sie dann die korrekten Parameternamen und gültigen Werte für jeden Parameter an.

  6. Geben Sie unter Größe und Layout die Ausrichtung, den Horizontal- und Vertikalabstand sowie die Breite und Höhe für das Java-Applet an.
  7. Wenn Sie als Inline-Formatvorlage für das Java-Applet Cascading Stylesheet-Eigenschaften angeben möchten, klicken Sie auf die Schaltfläche Formatvorlage.


Hinzufügen eines Videoclips

Sie können Ihrer Seite einen Videoclip hinzufügen. Hierbei können Sie jede Art von Videoclip verwenden, dessen Format von der Windows Medienwiedergabe verarbeitet werden kann.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der der Videoclip eingefügt werden soll.
  2. Zeigen Sie im Menü Einfügen auf Bild, und klicken Sie dann auf Video.
  3. Befindet sich die Videoclipdatei nicht in einem Web, klicken Sie auf die Schaltfläche Datei Schaltfläche "Datei".
  4. Suchen Sie die Videodatei, und wählen Sie sie aus.

Tipp Wenn Microsoft Internet Explorer auf Ihrem Computer installiert ist, können Sie auf die Registerkarte Vorschau klicken, um den Videoclip in der Vorschau zu betrachten.

Anmerkung Nicht alle Webbrowser unterstützen die Anzeige von Videoclips.


Festlegen eines Hintergrundsounds für eine Seite

Sie können für eine Seite einen Hintergrundsound festlegen. Dieser Sound wird wiedergegeben, wenn ein Sitebesucher die Seite öffnet. Sie können den Sound kontinuierlich wiedergeben oder angeben, wie oft er wiedergegeben werden soll.

Anmerkung Diese Funktion wird nicht von allen Webbrowsern unterstützt.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  2. Geben Sie auf der Registerkarte Allgemein unter Hintergrundsound im Feld Adresse die Sounddatei an, die Sie wiedergeben möchten, oder klicken Sie auf Durchsuchen, um nach der Datei zu suchen.
  3. Aktivieren Sie das Kontrollkästchen Kontinuierlich, wenn Sie den Sound kontinuierlich wiedergeben möchten.
  4. Deaktivieren Sie das Kontrollkästchen Kontinuierlich, wenn Sie festlegen möchten, wie oft der Sound wiedergegeben werden soll, und geben Sie die gewünschte Anzahl in das Feld Durchläufe ein.


Definieren einer Variablen

Definieren Sie eine Variable, die Sie auf Ihren Webseiten anzeigen möchten. Variablen eignen sich für Inhalte, die sich ändern können. Angenommen, Sie möchten überall in Ihrem Web auf ein Produkt verweisen, dessen Name sich ändern könnte. Dazu legen Sie für das Produkt eine Variable fest (legen Sie einen Namen und einen Wert fest, wie z. B. Produkt und NameDesProdukts 1.0) und legen diese dann auf den Seiten ab. Wenn sich der Name des Produkts ändert, ändern Sie einfach den Wert der von Ihnen definierten Variable. Anschließend wird der neue Produktname automatisch überall in Ihrem Web angezeigt.

  1. Klicken Sie im Menü Extras auf Webeinstellungen und dann auf die Registerkarte Parameter.
  2. Klicken Sie auf Hinzufügen.
  3. Geben Sie in das Feld Name einen Namen für die Variable ein.
  4. Geben Sie in das Feld Wert einen Wert für die Variable ein.


Anzeigen einer Seite auf einer anderen Seite

Sie können eine HTML-Seite auf einer anderen Seite im Web anzeigen, diese jedoch weiterhin als separate Seiten verwalten. Um z. B. auf mehreren Seiten im Web einen Copyright-Vermerk anzuzeigen, erstellen Sie eine Seite, die nur diesen Copyright-Vermerk enthält, und fügen diese auf den anderen Seiten ein. Wenn Sie den Copyright-Vermerk aktualisieren, aktualisieren Sie einfach diese eine Seite. Alle anderen Seiten, die den Copyright-Vermerk enthalten, werden automatisch aktualisiert.

Anmerkung Dieses Funktionsmerkmal steht nur für Seiten in einem Web zur Verfügung.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Seite einfügen möchten.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Seite einschließen.
  3. Geben Sie in das Feld Einzuschließende Seite den entsprechenden URL für die einzuschließende Seite ein, oder klicken Sie auf Durchsuchen, um nach der Datei zu suchen.


Einschließen einer Seite oder eines Bildes nach Zeitplan

Sie können festlegen, dass eine Seite oder ein Bild während eines bestimmten Zeitraums auf einer anderen Seite angezeigt werden soll. Dieses Funktionsmerkmal eignet sich für zeitabhängige Inhalte. Sie können z. B. während eines Urlaubswochenendes eine spezielle Anzeige zu einer Seite hinzufügen.

Sie können auch festlegen, dass eine Seite oder ein Bild außerhalb eines bestimmten Zeitraums zu einer Seite hinzugefügt wird. Sie können z. B. festlegen, dass vor und nach dem Urlaubswochenende eine bestimmte Anzeige auf der Seite erscheinen soll.

Anmerkung Zum Bestimmen des Zeitraums wird die Uhr des Webservers verwendet.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Seite oder ein Bild einfügen möchten.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Seite nach Zeitplan einschließen oder auf Bild nach Zeitplan einschließen.
  3. Geben Sie in das Feld Während des angegebenen Zeitintervalls den relativen URL der Seite oder des Bildes ein, die/das eingeschlossen werden soll, oder klicken Sie auf Durchsuchen, um danach zu suchen.
  4. Geben Sie unter Beginn das Jahr, den Monat, den Tag und die Zeit an, an dem die Seite oder das Bild das erste Mal angezeigt werden soll.
  5. Geben Sie unter Ende das Jahr, den Monat, den Tag und die Zeit an, an dem die Anzeige der Seite oder des Bildes beendet werden soll.
  6. Zum Festlegen einer Seite oder eines Bildes, die/das außerhalb des angegebenen Zeitraums angezeigt werden soll, geben Sie in das Feld Vor und nach dem angegebenen Zeitintervall den relativen URL der Seite oder des Bildes ein, die/das Sie einschließen möchten, oder klicken Sie auf Durchsuchen, um danach zu suchen.


Anzeigen einer Variablen auf einer Seite

Sie können den Wert einer Variablen auf einer Seite anzeigen. Die Variable kann entweder eine Systemvariable (wie z. B. der Name des Autors der Seite, der Name der Person, die die Seite zuletzt geändert hat, die Beschreibung der Seite oder der URL der Seite) oder eine Variable sein, die Sie definiert haben.

Variablen eigenen sich für Inhalte, die sich ändern können. Angenommen, Sie möchten überall in Ihrem Web auf ein Produkt verweisen, dessen Name sich u. U. ändern kann. Definieren Sie in diesem Fall eine Variable für das Produkt (dazu legen Sie einen Namen und einen Wert fest, wie z. B. Produkt und NameDesProdukts 1.0) fest und legen dann die Variable auf Ihren Seiten ab. Wenn sich der Name des Produkts ändert, ändern Sie einfach den Wert der von Ihnen definierten Variable. Anschließend wird der Produktname automatisch überall in Ihrem Web aktualisiert.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie eine Variable einfügen möchten.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Ersetzung.
  3. Klicken Sie im Feld Ersetzen durch auf eine Variable aus der Liste.


Festlegen von Eigenschaften für ein Java-Applet

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Java-Applet, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Java-Applet-Eigenschaften.
  2. Geben Sie in das Feld Meldung für Browser, die Java nicht unterstützen HTML- oder unformatierten Text ein, der auf Webbrowsern, die Java-Applets nicht unterstützen, an Stelle des Java-Applets angezeigt werden soll.
  3. Klicken Sie unter Appletparameter für jeden Parameter, den Sie an das Java-Applet übergeben möchten, auf Hinzufügen, und geben Sie dann den Namen des Parameters und, sofern erforderlich, den Wert des Parameters ein.

    4. Anmerkung Da Java keine Möglichkeit zum Anzeigen der gültigen Eigenschaften und Werte eines bestimmten Applets bietet, suchen Sie diese Informationen in der im Lieferumfang des Java-Applets enthaltenen Dokumentation, und geben Sie dann die korrekten Parameternamen und gültigen Werte für jeden Parameter an.

  4. Geben Sie unter Größe und Layout die Ausrichtung, den Horizontal- und Vertikalabstand sowie die Breite und Höhe für das Java-Applet an.
  5. Wenn Sie als Inline-Formatvorlage für das Java-Applet Cascading Stylesheet-Eigenschaften angeben möchten, klicken Sie auf die Schaltfläche Formatvorlage.


Hinzufügen eines Plug-Ins

  1. Zeigen Sie im Menü Einfügen auf Erweitert, und klicken Sie dann auf Plug-In.
  2. Geben Sie in das Feld Datenquelle den URL oder den Pfad des Plug-Ins ein, oder klicken Sie auf Durchsuchen, um nach dem Plug-In zu suchen.
  3. Geben Sie in das Feld Meldung für Browser, die Plug-Ins nicht unterstützen HTML- oder unformatierten Text ein, der in Webbrowsern, die keine Plug-Ins unterstützen, an Stelle des Plug-Ins angezeigt werden soll.
  4. Geben Sie unter Größe die Breite und Höhe des Plug-Ins an.
  5. Wenn das Plug-In beim Anzeigen der Seite in einem Webbrowser verborgen sein soll, aktivieren Sie das Kontrollkästchen Plug-In ausblenden.
  6. Geben Sie unter Layout die Ausrichtung, die Dicke der Rahmenlinie sowie Horizontal- und Vertikalabstand für das Plug-In ein.
  7. Wenn Sie als Inline-Formatvorlage für das Plug-In Cascading Stylesheet-Eigenschaften angeben möchten, klicken Sie auf die Schaltfläche Formatvorlage.


Festlegen von Eigenschaften für ein Plug-In

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Plug-In, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Plug-In-Eigenschaften.
  2. Geben Sie in das Feld Meldung für Browser, die Plug-Ins nicht unterstützen HTML- oder unformatierten Text ein, der in Webbrowsern, die keine Plug-Ins unterstützen, an Stelle des Plug-Ins angezeigt werden soll.
  3. Geben Sie unter Größe die Breite und Höhe des Plug-Ins an.
  4. Wenn das Plug-In beim Anzeigen der Seite in einem Webbrowser verborgen sein soll, aktivieren Sie das Kontrollkästchen Plug-In ausblenden.
  5. Geben Sie unter Layout die Ausrichtung, die Dicke der Rahmenlinie sowie Horizontal- und Vertikalabstand für das Plug-In ein.
  6. Wenn Sie als Inline-Formatvorlage für das Plug-In Cascading Stylesheet-Eigenschaften angeben möchten, klicken Sie auf die Schaltfläche Formatvorlage.


Hinzufügen eines ActiveX-Steuerelements

Mithilfe der neuesten Microsoft ActiveX-Steuerelemente aus dem Web können Sie nahezu alles von Kalendern bis zu Börsentickern zu Ihren Seiten hinzufügen. Besuchen Sie die Microsoft Site Builder Network-Toolssammlung unter http://www.microsoft.com/gallery/default.asp. Hier finden Sie Informationen und Möglichkeiten zum Downloaden der neuesten Steuerelemente.

  1. Zeigen Sie im Menü Einfügen auf Erweitert, und klicken Sie dann auf ActiveX-Steuerelement.
  2. Das Listenfeld Steuerelement auswählen zeigt eine Teilmenge der aktuell auf Ihrem Computer installierten Steuerelemente an. Klicken Sie auf das Steuerelement, das Sie einfügen möchten, und klicken Sie dann auf OK.

Tipp Sie können ActiveX-Steuerelemente aus der Liste der Steuerelemente, die Sie in Schritt 2 angezeigt haben, hinzufügen oder entfernen.


Festlegen von Eigenschaften für ein ActiveX-Steuerelement

  • Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das ActiveX-Steuerelement, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Eigenschaften: ActiveX-Steuerelement.

Anmerkung Die aufgeführten Eigenschaften gelten jeweils für die einzelnen ActiveX-Steuerelemente. Weitere Informationen zum Festlegen der Eigenschaften eines ActiveX-Steuerelements finden Sie in der im Lieferumfang des Steuerelements enthaltenen Dokumentation.


Hinzufügen oder Entfernen von ActiveX-Steuerelementen aus der Liste

Das Listenfeld Steuerelement auswählen in dem Dialogfeld ActiveX-Steuerelement einfügen zeigt eine Teilmenge der auf Ihrem Computer installierten Steuerelemente an. Sie können ActiveX-Steuerelemente zu dieser Liste hinzufügen oder aus ihr entfernen.

Mithilfe der neuesten Microsoft ActiveX-Steuerelemente aus dem Web können Sie nahezu alles von Kalendern bis zu Börsentickern zu Ihren Seiten hinzufügen. Besuchen Sie die Microsoft Site Builder Network-Toolssammlung unter http://www.microsoft.com/gallery/default.asp. Hier finden Sie Informationen und Möglichkeiten zum Downloaden der neuesten Steuerelemente.

  1. Zeigen Sie in der Seitenansicht im Menü Einfügen auf Erweitert, und klicken Sie dann auf ActiveX-Steuerelement.
  2. Klicken Sie auf Anpassen.
  3. Aktivieren Sie im Listenfeld Name des Steuerelements: die Kontrollkästchen der ActiveX-Steuerelemente, die Sie zur Verfügung stellen möchten, oder deaktivieren Sie die Kontrollkästchen der ActiveX-Steuerelemente, die nicht zur Verfügung stehen sollen.

Anmerkungen

  • Dieses Verfahren ermöglicht nicht das Installieren oder Entfernen von ActiveX-Steuerelementen auf Ihrem Computer. Wenn Sie ein ActiveX-Steuerelement downloaden, installieren, registrieren oder auf eine andere Art auf Ihrem Computer ablegen, wird dieses zum Listenfeld Name des Steuerelements: im Dialogfeld ActiveX-Steuerelementliste anpassen hinzugefügt. Ähnlich wird jedes ActiveX-Steuerelement, das Sie deinstallieren, löschen oder auf andere Art von Ihrem Computer entfernen, automatisch aus dem Listenfeld Name des Steuerelements: entfernt.
  • Einige ActiveX-Steuerelemente, die bekannterweise in FrontPage Fehler erzeugen, werden automatisch aus der Liste der verfügbaren Steuerelemente ausgeschlossen, auch wenn Sie auf Ihrem Computer installiert werden.


Erstellen einer Meldung für Browser ohne Java-Unterstützung

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Java-Applet, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Java-Applet-Eigenschaften.
  2. Geben Sie in das Feld Meldung für Browser, die Java nicht unterstützen HTML- oder unformatierten Text ein, der in Webbrowsern, die keine Java-Applets unterstützen, an Stelle des Java-Applets angezeigt werden soll.


Erstellen einer Meldung für Browser ohne Plug-In-Unterstützung

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Plug-In, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Plug-In-Eigenschaften.
  2. Geben Sie in das Feld Meldung für Browser, die Plug-Ins nicht unterstützen HTML- oder unformatierten Text ein, der in Webbrowsern, die keine Plug-Ins unterstützen, an Stelle des Plug-Ins angezeigt werden soll.


Verbergen eines Plug-Ins

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Plug-In, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Plug-In-Eigenschaften.
  2. Zum Verbergen des Plug-Ins, wenn ein Sitebesucher die Seite in einem Webbrowser anzeigt, aktivieren Sie das Kontrollkästchen Plug-In ausblenden.


Hinzufügen eines Entwurfszeit-Steuerelements

Entwurfszeit-Steuerelemente sind einzigartig. Wenn Sie ein Entwurfszeit-Steuerelement in der Seitenansicht zu einer Seite hinzufügen, wird es als Steuerelement (z. B. als Datenkopfzeilen-Steuerelement) angezeigt, das Sie programmieren und für das Sie Eigenschaften festlegen können. Ein Sitebesucher, der die Seite durchsucht, sieht jedoch die Ergebnisse der Ausgabe des Steuerelements, z. B. eine Tabelle mit den Ergebnissen einer Datenbankabfrage.

Sie können Entwurfszeit-Steuerelemente aus dem World Wide Web downloaden oder Entwurfszeit-Steuerelemente installieren, die Sie erworben haben. Nach dem Downloaden oder Installieren der Steuerelemente können Sie diese zu Ihren Seiten hinzufügen.

  1. Zeigen Sie im Menü Einfügen auf Erweitert, und klicken Sie dann auf Entwurfszeit-Steuerelement.
  2. Das Listenfeld Steuerelement auswählen zeigt eine Teilmenge der auf Ihrem Computer installierten Entwurfszeit-Steuerelemente an. Klicken Sie auf das Steuerelement, das Sie einfügen möchten, und klicken Sie dann auf OK.

Tipp Sie können Entwurfszeit-Steuerelemente zur Liste der Entwurfszeit-Steuerelemente hinzufügen oder entfernen, aus der Sie in Schritt 2 auswählen können.

Anmerkungen

  • Wenn Sie auf die Registerkarte HTML klicken, sehen Sie dass das Entwurfszeit-Steuerelement <!--METADATA>-Kommentar-Tags hinzufügt, die das Steuerelement identifizieren. Innerhalb der Kommentar-Tags befindet sich ein <OBJECT>-Tag, gefolgt vom Parameter und den Werten für das Steuerelement und Skripts, die das Steuerelement u. U. erzeugt.
  • Entwurfszeit-Steuerelemente, die auf Datenbindungen basieren, funktionieren in FrontPage u. U. nicht korrekt oder nur eingeschränkt. Informationen dazu, ob Sie ein Entwurfszeit-Steuerelement in FrontPage verwenden können, finden Sie in der Dokumentation zu diesem Steuerelement.


Festlegen von Eigenschaften für ein Entwurfszeit-Steuerelement

  • Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Entwurfszeit-Steuerelement, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Entwurfszeit-Steuerelement-Eigenschaften.

Anmerkung Die aufgeführten Eigenschaften gelten jeweils für die einzelnen Entwurfszeit-Steuerelemente. Weitere Informationen zum Festlegen der Eigenschaften eines Entwurfszeit-Steuerelements finden Sie in der im Lieferumfang des Steuerelements enthaltenen Dokumentation.


Hinzufügen oder Entfernen von Entwurfszeit-Steuerelementen aus der Liste

Das Listenfeld Steuerelementname im Dialogfeld Liste der Entwurfszeit-Steuerelemente anpassen zeigt alle auf Ihrem Computer installierten Entwurfszeit-Steuerelemente an. Sie können Entwurfszeit-Steuerelemente dieser Liste hinzufügen oder aus ihr entfernen.

  1. Zeigen Sie in der Seitenansicht im Menü Einfügen auf Erweitert, und klicken Sie dann auf Entwurfszeit-Steuerelement.
  2. Klicken Sie auf Anpassen.
  3. Aktivieren Sie im Listenfeld Steuerelementname die Kontrollkästchen der Entwurfszeit-Steuerelemente, die Sie zur Verfügung stellen möchten, oder deaktivieren Sie die Kontrollkästchen der Entwurfszeit-Steuerelemente, die nicht zur Verfügung stehen sollen.

Anmerkungen

  • Dieses Verfahren erlaubt nicht das Installieren oder Entfernen von Entwurfszeit-Steuerelementen auf Ihrem Computer. Wenn Sie ein Entwurfszeit-Steuerelement downloaden, installieren, registrieren oder auf eine andere Art auf Ihrem Computer ablegen, wird dieses automatisch zum Listenfeld Steuerelementname hinzugefügt. Ähnlich wird jedes Entwurfszeit-Steuerelement, das Sie deinstallieren, löschen oder auf andere Art von Ihrem Computer entfernen, automatisch aus dem Listenfeld Steuerelementname entfernt.


Auswählen der Skriptplattform für Entwurfszeit-Steuerelemente

Sie können festlegen, ob Entwurfszeit-Steuerelemente, die Skripts schreiben, diese auf dem Server oder auf dem Client ausführen sollen.

  1. Öffnen Sie die Seite, die die Entwurfszeit-Steuerelemente enthält (oder enthalten wird), in der Seitenansicht. Klicken Sie im Menü Datei auf Eigenschaften und dann auf die Registerkarte Allgemein.
  2. Klicken Sie im Feld Plattform auf Client, um das Skript auf dem Client auszuführen oder auf Server, um das Skript auf dem Server auszuführen.

Anmerkung Wenn ein bestimmtes Entwurfszeit-Steuerelement festlegt, dass das Steuerelement Skripts auf dem Server oder dem Client ausführen soll, haben die Einstellungen des Steuerelements Vorrang vor den Einstellungen, die Sie hier festgelegt haben.


Auswählen der Serverskriptsprache für ein Entwurfszeit-Steuerelement

Sie können festlegen, welche Skriptsprache Entwurfszeit-Steuerelemente verwenden sollen, die Serverskripts schreiben.

  1. Öffnen Sie die Seite, die die Entwurfszeit-Steuerelemente enthält (oder enthalten wird), in der Seitenansicht. Klicken Sie im Menü Datei auf Eigenschaften und dann auf die Registerkarte Allgemein.
  2. Wählen Sie im Feld Server die gewünschte Skriptsprache aus:
    • Klicken Sie auf Vom Web übernehmen, wenn Sie die Standardskriptsprache für das aktuelle Web verwenden möchten.
    • Klicken Sie auf JavaScript, wenn Sie JavaScript verwenden möchten.
    • Klicken Sie auf VBScript, wenn Sie VBScript verwenden möchten.

Anmerkung Wenn ein bestimmtes Entwurfszeit-Steuerelement festlegt, welche Skriptsprache es verwendet, haben die Einstellungen des Steuerelements Vorrang vor den Einstellungen, die Sie hier festlegen.


Auswählen der Clientskriptsprache für ein Entwurfszeit-Steuerelement

Sie können festlegen, welche Skriptsprache Entwurfszeit-Steuerelemente verwenden sollen, die Clientskripts schreiben.

  1. Öffnen Sie die Seite, die die Entwurfszeit-Steuerelemente enthält (oder enthalten wird), in der Seitenansicht. Klicken Sie im Menü Datei auf Eigenschaften und dann auf die Registerkarte Allgemein.
  2. Wählen Sie im Feld Client die gewünschte Skriptsprache aus:
    • Klicken Sie auf Vom Web übernehmen, wenn Sie die Standardskriptsprache für das aktuelle Web verwenden möchten.
    • Klicken Sie auf JavaScript, wenn Sie JavaScript verwenden möchten.
    • Klicken Sie auf VBScript, wenn Sie VBScript verwenden möchten.

Anmerkung Wenn ein bestimmtes Entwurfszeit-Steuerelement festlegt, welche Skriptsprache es verwendet, haben die Einstellungen des Steuerelements Vorrang vor den Einstellungen, die Sie hier festlegen.


Ein- oder Ausblenden von Entwurfszeit-Steuerelementen auf der Registerkarte "Normal" in der Seitenansicht

Ein- oder Ausblenden von Entwurfszeit-Steuerelementen auf der Registerkarte „Normal“ in der Seitenansicht

Entwurfszeit-Steuerelemente sind einzigartig. Wenn Sie ein Entwurfszeit-Steuerelement in der Seitenansicht zu einer Seite hinzufügen, wird es als Steuerelement (z. B. als Datenkopfzeilen-Steuerelement) angezeigt, das Sie programmieren und für das Sie Eigenschaften festlegen können. Ein Sitebesucher, der die Seite anzeigt, sieht jedoch die Ergebnisse der Ausgabe des Steuerelements, z. B. eine Tabelle mit den Ergebnissen einer Datenbankabfrage.

  • Zum Einblenden von Entwurfszeit-Steuerelementen zeigen Sie im Menü Einfügen auf Erweitert und klicken Sie dann auf Entwurfszeit-Steuerelemente einblenden. Das Symbol neben dem Befehlsnamen wird dann gedrückt angezeigt.
  • Zum Ausblenden von Entwurfszeit-Steuerelementen zeigen Sie im Menü Einfügen auf Erweitert und klicken Sie dann auf Entwurfszeit-Steuerelemente einblenden. Das Symbol neben dem Befehlsnamen wird jetzt nicht mehr gedrückt angezeigt. Anstatt Steuerelemente anzuzeigen, zeigt Microsoft FrontPage dann Text an, der das jeweilige Steuerelement beschreibt (dieser Text stammt aus dem ID-Tag des Steuerelements).


Info über Grafiken

Um mehr über Grafiken zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Auswirkungen von Grafiken auf ein Web

Wenn Sie mehr über die Auswirkungen von Grafiken auf ein Web erfahren möchten, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Hinzufügen eines Bildes aus einer Datei

Sie können Ihrer Seite ein Bild hinzufügen, das sich in Ihrem lokalen Dateisystem befindet. Bilder können die folgenden Dateiformate aufweisen: GIF (Standard und animiert), JPEG (Standard und progressiv), BMP (Windows und OS/2), TIFF, TGA, RAS, EPS, PCX, PNG, PCD (Kodak Photo CD) und WMF.

Beim Speichern der Seite fordert Microsoft FrontPage Sie auf, das Bild in Ihrem Web zu speichern. Handelt es sich bei dem Bild nicht um ein GIF- oder JPEG-Format, werden Bilder mit 256 oder weniger Einzelfarben automatisch in das GIF-Format, alle anderen in das JPEG-Format umgewandelt.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der das Bild eingefügt werden soll.
  2. Klicken Sie auf Grafik aus Datei einfügen Schaltfläche "Grafik aus Datei einfügen".
  3. Klicken Sie auf Datei Schaltfläche "Datei".
  4. Suchen Sie in Ihrem lokalen Dateisystem das Bild, das Sie einfügen möchten, und wählen Sie es aus. Sie können den Dateityp, der angezeigt weden soll, im Feld Dateityp angeben.


Hinzufügen eines Bildes aus einem Web

Sie können Ihrer Seite ein Bild aus dem aktuellen Web oder einem anderen Web hinzufügen. Bilder können die folgenden Dateiformate aufweisen: GIF (Standard und animiert), JPEG (Standard und progressiv), BMP (Windows und OS/2), TIFF, TGA, RAS, EPS, PCX, PNG, PCD (Kodak Photo CD) und WMF.

Beim Speichern der Seite fordert Microsoft FrontPage Sie auf, das Bild in Ihrem Web zu speichern. Handelt es sich bei dem Bild nicht um ein GIF- oder JPEG-Format, werden Bilder mit 256 oder weniger Einzelfarben automatisch in das GIF-Format, alle anderen in das JPEG-Format umgewandelt.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der das Bild eingefügt werden soll.
  2. Klicken Sie auf Grafik aus Datei einfügen Schaltfläche "Grafik aus Datei einfügen".
  3. Suchen Sie das Bild, und wählen Sie dann die Datei aus.


Hinzufügen eines Bildes von einer Site im World Wide Web

Sie können Ihrer Seite ein Bild von einer Site im World Wide Web hinzufügen. Dieses Bild kann Ihrem Web hinzugefügt werden, wenn Sie es in Ihrem Web speichern. Sie können sich auch entscheiden das Bild nicht in Ihrem Web zu speichern, in diesem Fall wird nicht das Bild selbst in Ihr Web eingefügt, sondern es wird ein Verweis auf das Bild auf der anderen Website erstellt. Daher wird, wenn das Bild von der anderen Website entfernt wird, dieses auch auf Ihrer eigenen Seite nicht mehr angezeigt.

Bilder können die folgenden Dateiformate aufweisen: GIF (Standard und animiert), JPEG (Standard und progressiv), BMP (Windows und OS/2), TIFF, TGA, RAS, EPS, PCX, PNG, PCD (Kodak Photo CD) und WMF.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der das Bild eingefügt werden soll.
  2. Klicken Sie auf Grafik aus Datei einfügen Schaltfläche "Grafik aus Datei einfügen".
  3. Geben Sie im Feld URL die genaue Adresse und den Namen des Bildes ein, das Sie einfügen möchten. Geben Sie beispielsweise http://www.microsoft.com/sample.gif ein.

    4. Oder klicken Sie auf die Schaltfläche World Wide Web Schaltfläche "World Wide Web", um Ihren Webbrowser zu starten und das gewünschte Bild zu suchen. Drücken Sie ALT+TAB, um zu Microsoft FrontPage zurückzukehren. Die Adresse der von Ihnen besuchten Seite wird im Feld URL angezeigt.

    Anmerkung Die im Feld URL angegebene Adresse muss sich auf das Bild und nicht auf deren HTML-Seite beziehen, ansonsten wird das Bild nicht auf Ihrer Seite angezeigt.

    Wenn auf der Seite im World Wide Web kein Hyperlink zu dem Bild angegeben wird, gehen Sie gemäß einer der folgenden Methoden vor:

    • Wenn Sie mit Version 4.x oder höher von Netscape Navigator arbeiten, klicken Sie mit der rechten Maustaste auf das Bild, klicken Sie im Kontextmenü auf Grafikadresse kopieren, kehren Sie zu FrontPage zurück, und überschreiben Sie den Text im Feld URL mit der kopierten Adresse.
    • Wenn Sie mit Microsoft Internet Explorer, Version 4.x oder höher, arbeiten, klicken Sie mit der rechten Maustaste auf das Bild, klicken Sie im Kontextmenü auf Kopieren, kehren Sie zu FrontPage zurück, klicken Sie auf Abbrechen, und fügen Sie das Bild nun direkt in Ihre Seite ein. Hiermit wird Ihrer Seite ein Verweis auf das Bild auf der jeweiligen Website hinzugefügt.


Hinzufügen eines ClipArt-Objekts

Microsoft FrontPage enthält die Microsoft ClipArt Gallery. Hiermit können Sie ClipArt-Objekte, Bilder und Videos zunächst in der Vorschau betrachten und dann die Objekte auswählen, die Sie auf Ihrer Seite verwenden möchten.

  1. Positionieren Sie in der Seitenansicht die Einfügemarke an der Stelle, an der das ClipArt-Objekt eingefügt werden soll.
  2. Zeigen Sie im Menü Einfügen auf Bild, und klicken Sie dann auf ClipArt.
  3. Durchsuchen Sie die Microsoft Clip Gallery nach dem gewünschten ClipArt-Objekt, klicken Sie mit der rechten Maustaste auf eine Grafik, und klicken Sie dann im Kontextmenü auf Einfügen.
  4. Schließen Sie die Microsoft Clip Gallery.


Ändern der Helligkeit eines Bildes

Sie können die Helligkeit eines Bildes erhöhen oder herabsetzen.

Mehr Helligkeit
Mehr Helligkeit 		Weniger Helligkeit
Weniger Helligkeit
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie die Helligkeit des Hintergrundbildes ändern möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Mehr Helligkeit Schaltfläche "Mehr Helligkeit", um die Helligkeit des Bildes zu erhöhen. Klicken Sie auf Weniger Helligkeit Schaltfläche "Weniger Helligkeit", wenn Sie die Helligkeit des Bildes zurücknehmen möchten.

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Ändern des Farbkontrasts eines Bildes

Sie können den Kontrast der Farben eines Bildes erhöhen oder herabsetzen, um beispielsweise die Schärfe eines Bildes zu verbessern.

Mehr Kontrast
Mehr Kontrast 		Weniger Kontrast
Weniger Kontrast
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie den Kontrast des Hintergrundbildes ändern möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Mehr Kontrast Schaltfläche "Mehr Kontrast ", um den Farbkontrast des Bildes zu erhöhen. Klicken Sie auf Weniger Kontrast Schaltfläche "Weniger Kontrast", wenn Sie den Kontrast herabsetzen möchten.

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Umwandeln eines Bildes in eine Schwarzweißgrafik

Sie können ein Bild in eine Schwarzweißgrafik (Graustufen) umwandeln.

Farbgrafik
Farbgrafik 		Schwarzweißgrafik
Schwarzweißgrafik
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie das Hintergrundbild in eine Schwarzweißgrafik umwandeln möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Schwarzweiß Schaltfläche "Schwarzweiß".

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Zuschneiden eines Bildes

Beim Zuschneiden eines Bildes entfernen Sie die Bereiche, die Sie nicht verwenden möchten. Durch Zuschneiden können Sie auch die Proportionen eines Bildes ändern; beispielsweise können Sie ein Bild so zuschneiden, dass es schmaler erscheint.

Vorher
Vorher 		Nachher
Nachher
  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der Symbolleiste Grafik auf Zuschneiden Schaltfläche "Zuschneiden".

    3. Über dem Bild erscheint ein Rechteck zum Zuschneiden.

  3. Klicken Sie nun auf die Ziehpunkte am Rechteck, und ziehen Sie diese, um die Größe des Rechtecks so zu ändern, dass der Teil des Bildes eingeschlossen wird, den Sie verwenden möchten. Wenn Sie selbst das Rechteck zum Zuschneiden zeichnen möchten, klicken Sie außerhalb des Rechtecks, jedoch innerhalb des Bildes, und zeichnen dann das Rechteck.
  4. Klicken Sie erneut auf Zuschneiden Schaltfläche "Zuschneiden", um den Bereich außerhalb des Rechtecks zum Zuschneiden zu entfernen.


Rotieren eines Bildes

Sie können ein Bild um 90° im oder gegen den Uhrzeigersinn rotieren.

Original | Linksherum rotieren | Rechtsherum rotieren
Original | Linksherum rotieren Linksherum rotieren | Rechtsherum rotieren Rechtsherum rotieren
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie das Hintergrundbild rotieren möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Linksherum rotieren Schaltfläche "Linksherum rotieren", um das Bild um 90° gegen den Uhrzeigersinn zu rotieren. Klicken Sie auf Rechtsherum rotieren Schaltfläche "Rechtsherum rotieren " , um das Bild um 90° im Uhrzeigersinn zu rotieren.

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Kippen eines Bildes

Sie können ein Bild horizontal kippen (wodurch das Bild auf den Kopf gestellt wird), oder Sie können es vertikal kippen (wodurch ein Spiegelbild erzeugt wird).

Original | Horizontal kippen | Vertikal kippen
Original | Horizontal kippen Horizontal kippen | Vertikal kippen Vertikal kippen
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie das Hintergrundbild kippen möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Vertikal kippen Schaltfläche "Vertikal kippen", um das Bild auf den Kopf zu stellen. Klicken Sie auf Horizontal kippen Schaltfläche "Horizontal kippen", um ein Spiegelbild des Bildes zu erstellen.

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Erzeugen eines verwaschenen Effekts für die Farben eines Bildes

Sie können für die Farben eines Bildes einen verwaschenen Effekt erzeugen, wobei der Farbkontrast des Bildes herabgesetzt und die Helligkeit erhöht wird. Diese Funktion erweist sich als nützlich, wenn Sie ein Wasserzeichen erstellen oder eine Grafik als Hintergrundbild verwenden möchten.

Original
Original 		Verwaschen
Verwaschen
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie für das Hintergrundbild einen verwaschenen Effekt erzeugen möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der SymbolleisteGrafik auf Verwaschen Schaltfläche "Verwaschen".

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Definieren einer Farbe im Bild als transparent

Sie können eine Farbe im Bild als transparent definieren, damit an allen Stellen, an denen diese Farbe auftritt, der Hintergrund durchscheint. Es kann jedoch immer nur jeweils eine Farbe als transparent definiert werden. Wenn Sie bei einem Bild, für das bereits eine Farbe als transparent definiert wurde, eine weitere Farbe auf transparent setzen, wird die ursprünglich als transparent definierte Farbe auf die Originalfarbe zurückgesetzt.

Beim Speichern der Seite fordert Microsoft FrontPage Sie auf, das Bild im GIF-Format zu speichern, und zwar auch dann, wenn das Originalbild im JPEG-Format vorgelegen hat (Transparenz wird im JPEG-Format nicht unterstützt). Wenn FrontPage das Bild aus einem anderen Dateiformat nach GIF konvertiert, reduziert sich möglicherweise die Anzahl der Farben im Bild und die Dateigröße wird erhöht.

Original
Original 		Transparente Farbe
Transparente Farbe
  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der SymbolleisteGrafik-auf Transparente Farbe festlegen Schaltfläche "Transparente Farbe festlegen".
  3. Klicken Sie im Bild auf die Farbe, die Sie als transparent definieren möchten.


Hinzufügen von Text zu einem Bild

Sie können einem Bild Text hinzufügen, wenn Sie dieses beispielsweise mit einer Beschriftung versehen möchten. Der von Ihnen hinzugefügte Text hat keine Auswirkungen auf die Bilddatei in Ihrem Web.

  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der SymbolleisteGrafik auf Text Schaltfläche "Text".
  3. Wenn das Bild im JPEG-Format vorliegt, fordert Microsoft FrontPage Sie auf, das Bild im GIF-Format zu speichern, da Text auf Bilder vom JPEG-Format nicht unterstützt wird. Wenn FrontPage das Bild nach GIF konvertiert, wird möglicherweise die Anzahl der Farben im Bild reduziert, und die Bilddatei wird größer. Klicken Sie auf OK.

    4. Wenn das Bild in einem anderen Format wie beispielsweise BMP vorliegt, fordert FrontPage Sie beim Speichern der Seite auf, das Bild als GIF zu speichern.

  4. Geben Sie den gewünschten Text in das Feld ein, das auf dem Bild angezeigt wird.
    • Sie können die Größe des Textfeldes ändern, indem Sie auf die Ziehpunkte klicken und das Feld hiermit auf die gewünschte Größe ziehen.
    • Sie können das Textfeld verschieben, indem Sie in das Innere des Feldes klicken und das Feld an die gewünschte Position ziehen.
    • Sie haben auch die Möglichkeit, den Text zu formatieren; beispielsweise können Sie die Schriftart oder die Schriftfarbe ebenso ändern wie bei normalem Text. Klicken Sie hierzu auf das Textfeld, und markieren Sie den Text.


Erneutes Einlesen eines Bildes

Erneut Einlesen eines Bildes

Beim erneuten Einlesen eines Bildes wird dessen Pixelgröße geändert, um diese an das aktuelle Anzeigeformat anzupassen. Wenn Sie beispielsweise die Größe eines Bildes auf 50% der Originalgröße reduzieren, wird das Bild zwar auf der Seite kleiner angezeigt, die Dateigröße bleibt jedoch gleich, denn mit der Größenänderung werden nur die HTML-Tags geändert, mit denen der Webbrowser informiert wird, wie er das Bild anzeigen soll. Wenn Sie das Bild jedoch erneut einlesen, wird auch die Dateigröße verringert und so dem kleineren Anzeigeformat angepasst.

Bevor Sie ein Bild erneut einlesen können, müssen Sie dessen Größe ändern.

  1. Klicken Sie in der Seitenansicht auf das Bild, dessen Größe Sie geändert haben.
  2. Klicken Sie auf der Symbolleiste Grafik auf Erneut einlesen Schaltfläche "Erneut einlesen".


Hinzufügen eines abgeschrägten Randes zu einem Bild

Sie können ein Bild mit einem abgeschrägten Rand versehen, um diesem ein hervorgehobenes, dreidimensionales Aussehen zu verleihen. Diese Funktion erweist sich als nützlich, wenn Sie das Bild als Schaltfläche verwenden möchten.

Original
Original 		Abgeschrägter Rand
Abgeschrägter Rand
  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie das Hintergrundbild mit einem abgeschrägten Rand versehen möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der Symbolleiste Grafik auf Abgeschrägter Rand Schaltfläche "Abgeschrägter Rand".

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Wiederherstellen eines Bildes

Wenn Ihnen die Ergebnisse einer Bildbearbeitung (wie beispielsweise Zuschnitt, Größenänderung, Drehung usw.) nicht gefallen, können Sie alle Änderungen, die Sie seit dem letzten Speichern oder seit dem Hinzufügen zur Seite an dem Bild vorgenommen haben, rückgängig machen.

  1. Klicken Sie in der Seitenansicht auf das Bild. Wenn Sie das Hintergrundbild wiederherstellen möchten, müssen Sie keine Auswahl treffen.
  2. Klicken Sie auf der SymbolleisteGrafik auf Wiederherstellen Schaltfläche "Wiederherstellen".

Tipp Zum Anzeigen der Symbolleiste Grafik zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Grafik.


Erstellen der Miniaturansicht eines Bildes

Sie können in FrontPage eine Miniaturansicht, also eine stark verkleinerte Version eines Bildes erstellen, auf die der Sitebesucher dann klicken kann, um über einen Hyperlink das Bild in Originalgröße anzuzeigen.

Eine Miniaturansicht erweist sich als nützlich, wenn sich in Ihrem Web ein sehr umfangreiches Bild befindet, für das, abhängig vom Computersystem des Sitebesuchers, mit erheblichen Downloadzeiten zu rechnen ist. Anstatt nun den Sitebesucher zu zwingen, ein großes Bild zu downloaden, stellen Sie eine Miniaturansicht desselben bereit, womit es dem Sitebesucher ermöglicht wird zu entscheiden, ob er das Bild in Originalgröße anzeigen möchte.

Klicken Sie auf die nachstehende Miniaturansicht, und klicken Sie dann auf die Schaltfläche Zurück, um zu diesem Hilfethema zurückzukehren:

Klicken Sie auf diese Miniaturansicht

  1. Klicken Sie in der Seitenansicht auf das Bild.
  2. Klicken Sie auf der SymbolleisteGrafik auf AutoMiniaturansicht Schaltfläche "AutoMiniaturansicht".

    3. FrontPage erstellt nun eine Miniaturansicht des Bildes sowie einen Hyperlink zum ursprünglichen Bild in Originalgröße.

    Anmerkung Die Schaltfläche AutoMiniaturansicht Schaltfläche "AutoMiniaturansicht" ist abgeblendet, wenn das von Ihnen gewählte Bild bereits kleiner als eine Miniaturansicht ist, wenn für das Bild ein Hyperlink oder ein Hotspot definiert wurde oder wenn es sich bei dem Bild um eine Animation handelt.

Tipp Sie können die Einstellungen für die Art und Weise ändern, wie Miniaturansichten erstellt werden, Sie können also beispielsweise eine andere Größe oder einen anderen Rahmen für Miniaturansichten festlegen.


Festlegen der Rahmeneigenschaften einer Grafik

Sie können ein Bild, eine animierte GIF-Grafik, ein ClipArt-Objekt oder einen Videoclip mit einem Rahmen versehen. Wenn Sie einen Standardhyperlink für die Grafik festlegen, setzt Microsoft FrontPage automatisch einen Rahmen um die Grafik, um den Sitebesuchern auf diese Weise anzuzeigen, dass sie auf die Grafik klicken können.

Sie können die Breite des Rahmens festlegen, oder, falls Sie keinen Rahmen wünschen, diesen entfernen. Standardmäßig ist die Farbe des Rahmens schwarz. Wenn Sie jedoch einen Standardhyperlink für die Grafik festgelegt haben, erhält der Rahmen die Farben, die Sie für Hyperlinks angegeben haben (diese Farben werden im Dialogfeld Seiteneigenschaften festgelegt).

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Grafik, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie dann auf die Registerkarte Erscheinungsbild.
  2. Geben Sie im Feld Dicke der Rahmenlinie einen Wert ein, um die Breite des Rahmens in Pixel anzugeben. Wenn Sie den Rahmen entfernen möchten, geben Sie 0 ein.


Öffnen eines Bildes zur Bearbeitung

Sie können ein Bild zum Bearbeiten öffnen. Zunächst müssen Sie jedoch angeben, welches Bildbearbeitungsprogramm verwendet werden soll, um die von Ihnen verwendeten Arten von Bilddateien, wie beispielsweise GIF, JPEG, BMP usw. zu bearbeiten.

  • Doppelklicken Sie in der Seitenansicht auf das Bild.

Anmerkung Wenn Sie auf eine animierte GIF-Grafik doppelklicken, öffnet FrontPage den Editor, den Sie für Standard-GIF-Dateien festgelegt haben; Sie können also keine andere Anwendung für animierte GIFs angeben.


Ändern der Größe einer Grafik

Sie können die Größe von Grafiken wie beispielsweise Bildern, animierten GIFs und Videoclips ändern. Hierbei können Sie die Größe einer Grafik ändern, indem Sie die Eigenschaften für Höhe und Breite ändern, oder Sie können die Größe der Grafik direkt auf der Seite ändern.

Mit dem Ändern der Größe einer Grafik werden die HTML-Tags geändert, mit denen ein Webbrowser informiert wird, wie er die Grafik anzeigen soll; die eigentliche Grafik wird hierdurch nicht geändert. Sie möchten beispielsweise die Downloadzeit einer Seite mit einem umfangreichen Bild verringern. Wenn Sie lediglich die Größe des Bildes ändern, nimmt dieses zwar auf dem Bildschirm des Sitebesuchers einen kleineren Bereich ein, doch die Dateigröße und damit die Downloadzeit wurde hiermit nicht geändert. Um die Dateigröße eines Bildes und dessen Downloadzeit zu verringert, müssen Sie das Bild erneut einlesen, nachdem Sie dessen Größe geändert haben.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Grafik, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie dann auf die Registerkarte Erscheinungsbild.
  2. Aktivieren Sie das Kontrollkästchen Größe angeben.
  3. Wenn Sie das Verhältnis von Höhe zu Breite beibehalten möchten, aktivieren Sie auch das Kontrollkästchen Seitenverhältnis beibehalten. Wenn Sie dieses Kontrollkästchen aktivieren und dann einen Pixelwert in eines der Felder Breite oder Höhe eingeben, ändert Microsoft FrontPage den Wert im jeweils anderen Feld automatisch, um die Proportionen der Grafik beizubehalten.
  4. Geben Sie an, ob Sie die Größenänderung in Pixel oder in Prozent vornehmen möchten, und geben Sie dann die entsprechenden Werte in die Felder Breite und Höhe ein.

Tipp Sie können die Größe der Grafik auch direkt ändern. Klicken Sie hierzu auf die Grafik, und ändern Sie deren Größe, indem Sie auf die Ziehpunkte klicken und die Grafik hiermit auf die gewünschte Größe ziehen. Wenn Sie die Größe ändern und gleichzeitig die Proportionen (das Seitenverhältnis) beibehalten möchten, ziehen Sie einen Eckziehpunkt. Verwenden Sie einen Seitenziehpunkt, wird die Grafik verzerrt.


Festlegen der Ausrichtung und des Abstands einer Grafik

Sie können angeben, wie Bilder und Videos auf der Seite angezeigt werden, indem Sie deren Ausrichtung und den horizontalen und vertikalen Abstand festlegen. Beispielsweise können Sie eine Ausrichtung wählen, mit der die Grafik am rechten Rand der Seite positioniert wird, wobei sich der Text links befindet. Oder Sie können den horizontalen Abstand auf 10 setzen, womit die Grafik links und rechts einen 10 Pixel breiten Rand erhält.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Grafik, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie dann auf die Registerkarte Erscheinungsbild.
  2. Klicken Sie im Feld Ausrichtung auf eine Option, um auf diese Weise anzugeben, wie die Grafik auf der Seite ausgerichtet werden soll. Um das Bild beispielsweise am linken Rand der Seite auszurichten und den Text rechts davon zu positionieren, klicken Sie auf Links. Sie können mit den einzelnen Optionen experimentieren, um die jeweiligen Effekte zu begutachten.
  3. Geben Sie im Feld Horizontalabstand ein, wie groß der Abstand in Pixel auf der rechten und linken Seite der Grafik sein soll.
  4. Geben Sie im Feld Vertikalabstand ein, wie groß der Abstand in Pixel auf der Ober- und Unterseite der Grafik sein soll.


Angeben des Textes, der anstelle einer Grafik angezeigt werden soll

Sie können alternativen Text angeben, Text also, der anstelle der Grafik angezeigt wird, wenn diese in einem Webbrowser nicht dargestellt werden kann. Bei einigen Webbrowsern wird der alternative Text auch angezeigt, während die Grafik gedownloaded wird oder wenn der Sitebesucher den Mauszeiger über die Grafik bewegt.

Zeigen Sie mit Ihrem Mauszeiger auf das nachstehende Bild, um dessen alternativen Text anzuzeigen:

Dies ist alternativer Text

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Grafik, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie nun auf die Registerkarte Allgemein.
  2. Geben Sie unter Alternative Darstellungsweisen im Feld Text den alternativen Text für die Grafik ein.


Angeben einer Grafikversion mit niedriger Auflösung

Sie können eine Grafikversion mit niedriger Auflösung anzeigen, während im Webbrowser des Sitebesuchers die Originalversion gedownloadet wird. Diese Funktion erweist sich als nützlich, wenn Sie über ein großes Bild oder ein Bild mit hoher Auflösung verfügen. Handelt es sich bei dem Bild um ein Imagemap, können Sitebesucher mit einer langsamen Internetverbindung bereits in der Version mit der niedrigen Auflösung auf Hotspots klicken und müssen nicht warten, bis der Download der Version der Grafik mit der hohen Auflösung abgeschlossen ist.

Erstellen Sie zunächst eine Version Ihres Bildes mit einer niedrigen Auflösung. Öffnen Sie hierzu das Bild in einem Grafikprogramm wie beispielsweise Microsoft Image Composer, und verringern Sie die Farbtiefe (Anzahl der Farben) im Bild. Je weniger Farben Sie für die Bildversion mit niedriger Auflösung angeben, desto schneller kann diese in einem Webbrowser angezeigt werden. Da die Version mit niedriger Auflösung als Platzhalter für das Original mit hoher Auflösung vorgesehen ist, sollten Sie die Höhe oder Breite des Bildes nicht ändern.

Anmerkung Diese Funktion wird nicht von allen Webbrowsern unterstützt.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Bild, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie nun auf die Registerkarte Allgemein.
  2. Geben Sie im Feld Niedrige Auflösung den Dateinamen für die alternative Bildversion mit niedriger Auflösung ein, oder klicken Sie auf Durchsuchen, um diese zu suchen:
    • Befindet sich das Bild in einem Web, wechseln Sie zu dem Web und dem Ordner, der das Bild enthält, und markieren Sie dann das gewünschte Bild.
    • Befindet sich das Bild in Ihrem lokalen Netzwerk, klicken Sie auf Datei Schaltfläche "Datei", und suchen Sie dann das gewünschte Bild in Ihrem lokalen Netzwerk.
    • Befindet sich das Bild im World Wide Web, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers das gewünschte Bild, und kehren Sie dann zu Microsoft FrontPage zurück. Die Adresse der von Ihnen besuchten Seite wird nun im Feld URL angezeigt.


Festlegen von Eigenschaften für die Erstellung von Miniaturansichten

Sie können angeben, wie Microsoft FrontPage Miniaturansichten von Bildern erstellen soll. Hierzu können Sie Eigenschaften für Größe und Rahmen von Miniaturansichten festlegen.

Anmerkung Die Änderungen, die Sie an den Eigenschaften für Miniaturansichten vornehmen, wirken sich nicht auf Miniaturansichten aus, die Sie bereits im Vorfeld erstellt haben.

  1. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte AutoMiniaturansicht.
  2. Klicken Sie im Feld Festlegen auf die Option, die Sie zur Angabe einer Größe verwenden möchten, und geben Sie dann im Feld Pixel den Wert in Pixeln ein.

    3. Wenn Miniaturansichten beispielsweise 75 Pixel breit sein sollen, klicken Sie auf Breite, und geben Sie dann 75 ein. Die Höhe der Miniaturansicht wird so bemessen, dass die Proportionen (das Seitenverhältnis) des Originalbildes erhalten bleiben. Alternativ können Sie Kürzere Seite wählen und dann beispielsweise 75 eingeben, damit die jeweils kürzere Seite einer Miniaturansicht, ungeachtet, ob Höhe oder Breite, immer 75 Pixel beträgt.

  3. Zum Angeben eines Rahmens wählen Sie Dicke der Rahmenlinie und geben dann im Feld Pixel einen Wert in Pixel für die Dicke der Rahmenlinie ein.
  4. Wenn Sie der Grafik einen abgeschrägten Effekt verleihen möchten, wählen Sie Abgeschrägte Kanten. Wenn Sie daneben auch die Dicke der Rahmenlinie vorgegeben haben, erhält die Miniaturansicht abgeschrägte Kanten auf der Innenseite des Rahmens.


Umwandeln eines Bildes in die Formate GIF, JPEG oder PNG

Sie können ein Bild in die Formate GIF, JPEG oder PNG umwandeln. Wenn Sie beispielsweise in einem im JPEG-Format vorliegenden Bild eine Farbe als transparent definieren möchten, müssen Sie das Bild zunächst in das GIF-Format konvertieren.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Bild, und klicken Sie dann im Kontextmenü auf Bildeigenschaften.
  2. Auf der Registerkarte Allgemein stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Wenn Sie das Bild in das GIF-Format umwandeln möchten, klicken Sie auf GIF. Möchten Sie das Bild während des Downloads mit zunehmender Genauigkeit anzeigen, wählen Sie Mit Zeilensprung.

      • Anmerkung In diesem Dialogfeld können Sie zwar keine Farbe als transparent definieren, Sie können jedoch das Kontrollkästchen Transparent deaktivieren, wenn für dieses Bild keine transparente Farbe gewünscht wird.

    • Wenn Sie das Bild in das JPEG-Format umwandeln möchten, klicken Sie auf JPEG. Sie können auch die Qualität des JPEG-Bildes angeben, indem Sie einen Wert zwischen 1 und 100 in das Feld Qualität eingeben. Hierbei gilt, je höher der Wert, desto niedriger die Komprimierungsrate und desto umfangreicher die Dateigröße. Im Feld Optimierungsdurchläufe können Sie die Anzahl der Durchläufe angeben, die von einem Webbrowser vorgenommen werden, um das Bild während des Downloads aufzulösen.

      • Anmerkung Optimierungsdurchläufe werden nicht von allen Webbrowsern unterstützt.

    • Wenn Sie das Bild in das PNG-Format umwandeln möchten, klicken Sie auf PNG.


Festlegen von Eigenschaften für ein Bild im GIF- oder JPEG-Format

Sie können für Bilder im GIF- und JPEG-Format Eigenschaften festlegen.

Für Bilder im GIF-Format können Sie angeben, ob eine Farbe als transparent definiert werden kann und ob das Bild mit Zeilensprung angezeigt werden soll (d. h. das Bild wird während des Downloads mit zunehmender Genauigkeit angezeigt).

Für Bilder im JPEG-Format können Sie die Qualität und die Anzahl der Optimierungsdurchläufe angeben. Je niedriger Sie den Wert für die Qualität ansetzen, desto stärker wird das Bild komprimiert und desto geringer fällt die Dateigröße aus. Die Anzahl der Optimierungsdurchläufe bezieht sich auf die Anzahl der Durchläufe, die in einem Webbrowser erfolgen, um das Bild während des Downloads aufzulösen.

  1. In der Seitenansicht haben Sie eine der folgenden Möglichkeiten:
    • Wenn Sie Eigenschaften für ein Bild festlegen möchten, klicken Sie mit der rechten Maustaste auf das Bild und klicken Sie dann im Kontextmenü auf Bildeigenschaften.
    • Wenn Sie Eigenschaften für ein Hintergrundbild festlegen möchten, klicken Sie mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, dann auf die Registerkarte Hintergrund und anschließend auf Eigenschaften.
    • Zum Festlegen von Eigenschaften für das Hintergrundbild einer Tabelle oder Zelle klicken Sie mit der rechten Maustaste auf die Tabelle oder Zelle, klicken Sie im Kontextmenü auf Tabelleneigenschaften oder Zelleneigenschaften und anschließend auf Eigenschaften.
  2. Auf der Registerkarte Allgemein haben Sie eine der folgenden Möglichkeiten:
    • Liegt das Bild im GIF-Format vor, können Sie angeben, ob das Bild mit Zeilensprung angezeigt werden soll, indem Sie die Option Mit Zeilensprung wählen. Wenn eine Farbe als transparent definiert wurde, ist das Kontrollkästchen Transparent aktiviert; Sie können diese Einstellung ändern, indem Sie das Kontrollkästchen deaktivieren.
    • Liegt das Bild im JPEG-Format vor, können Sie die Qualität des JPEG-Bildes angeben, indem Sie einen Wert zwischen 1 und 100 in das Feld Qualität eingeben. Im Feld Optimierungsdurchläufe geben Sie die Anzahl der Optimierungsdurchläufe ein, die in einem Webbrowser erfolgen sollen.

      • Anmerkung Optimierungsdurchläufe werden nicht von allen Webbrowsern unterstützt.


Hinzufügen eines Bildes als Schaltfläche "Abschicken" zu einem Formular

Hinzufügen eines Bildes als Schaltfläche „Abschicken“ zu einem Formular

Sie können an Stelle einer Schaltfläche Abschicken auch ein Bild zu einem Formular hinzufügen. Nach dem Ausfüllen des Formulars klickt der Sitebesucher zum Abschicken des Formulars auf das Bild. Daraufhin werden die Daten aus dem Formular einschließlich des Namens des Bildfeldes an die Formularbehandlungsroutine gesendet.

Sie können das Bildfeld zum Erstellen einer benutzerdefinierten Imagemap verwenden. Wenn ein Sitebesucher auf das Bildfeld klickt, um das Formular abzuschicken, werden die X- und Y-Koordinaten des Zeigers unter Verwendung des Koordinatensystems des Bildfelds an die Formularbehandlungsroutine übergeben. Auch wenn die Formularbehandlungsroutinen in Microsoft FrontPage die Koordinateninformationen nicht verwenden, können Sie ein benutzerdefiniertes Skript erstellen, das das Formular auf der Basis dieser Koordinaten verarbeitet.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie die Schaltfläche Abschicken ablegen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular und klicken Sie dann auf Bild.
  3. Wählen Sie das Bild aus:
    • Wenn sich das Bild in einem Web befindet, wechseln Sie zu dem Web und dem Ordner, in dem sich das Bild befindet, wählen Sie das gewünschte Bild aus, und klicken Sie dann auf OK.
    • Befindet sich das Bild in Ihrem lokalen Netzwerk, klicken Sie auf Datei Schaltfläche "Datei", gehen Sie zu dem Bild, das Sie aus Ihrem lokalen Netzwerk verwenden möchten, und klicken Sie dann auf OK.
    • Befindet sich das Bild im World Wide Web, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Gehen Sie in Ihrem Webbrowser zu dem gewünschten Bild, und wechseln Sie dann zurück zu FrontPage. Die Position der Seite, die Sie besucht haben, wird im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn es sich bei dem Bild um ein ClipArt handelt, klicken Sie auf ClipArt, um die Microsoft ClipArt Gallery anzuzeigen, klicken Sie mit der rechten Maustaste auf das gewünschte Bild, und klicken Sie dann im Kontextmenü auf Einfügen.
  4. Klicken Sie mit der rechten Maustaste auf das Bild, um dessen Eigenschaften einzustellen, und klicken Sie dann im Kontextmenü auf Formularfeldeigenschaften.
  5. Geben Sie in das Feld Name einen Namen ein, der das Bildfeld identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Festlegen eines Standardhyperlinks für eine Grafik

Sie können einen Standardhyperlink für eine Grafik wie beispielsweise ein Bild, ein animiertes GIF oder einen Videoclip festlegen. Wenn der Sitebesucher auf die Grafik klickt, wird in dessen Webbrowser das Ziel des Hyperlinks angezeigt. Wenn Sie beispielsweise eine Schaltfläche erstellen möchten, mit der Ihre Homepage angezeigt wird, fügen Sie der Seite eine Schaltflächengrafik hinzu, und geben Sie als Ziel des Standardhyperlinks für diese Schaltfläche die Adresse Ihrer Homepage an.

Wenn Sie Hotspots auf einer Grafik platzieren, gilt der Standardhyperlink für die Bereiche, die nicht Teil eines Hotspots sind.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Grafik, klicken Sie im Kontextmenü auf Bildeigenschaften, und klicken Sie dann auf die Registerkarte Allgemein.
  2. Geben Sie unter Standardhyperlink im Feld Adresse das Ziel ein, das Sie für den Standardhyperlink verwenden möchten. Oder klicken Sie auf Durchsuchen, um das Ziel zu suchen:
    • Befindet sich das Ziel in einem Web, wechseln Sie zu dem Web und dem Ordner, in dem sich die Seite befindet, markieren Sie diese, und klicken Sie dann auf OK.
    • Wenn sich das Ziel in Ihrem lokalen Netzwerk befindet, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie die gewünschte Seite in Ihrem lokalen Netzwerk, und klicken Sie auf OK.
    • Handelt es sich um ein Ziel im World Wide Web, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers die gewünschte Seite, und drücken Sie dann ALT+TAB, um zu Microsoft FrontPage zurückzukehren. Die Adresse der Seite, die Sie besucht haben, wird nun im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn Sie möchten, dass eine E-Mail erstellt wird, wenn ein Sitebesucher auf die Grafik klickt, klicken Sie auf E-Mail Schaltfläche "E-Mail". Geben Sie die E-Mail-Adresse ein, an die die Nachricht gesendet werden soll, klicken Sie auf OK, und klicken Sie dann nochmals auf OK.
  3. Soll das Ziel des Hyperlinks in einem speziellen Frame eingeblendet werden, klicken Sie auf Zielframe ändern Schaltfläche "Zielframe ändern", und geben Sie dann den Frame an.


Erstellen einer Seitenvorlage

Eine Vorlage ist eine vordefinierte Seite, die Seiteneinstellungen, Formate und Seitenelemente enthalten kann. Sie können auch eigene Seitenvorlagen und somit für Ihr Web schnell und konsistent Seiten erstellen. Vorlagen eignen sich besonders dann, wenn mehrere Autoren beteiligt sind, da sie helfen, konsistente Seiten zu erstellen.

Wenn z. B. alle Seiten am oberen Rand ein Firmenlogo und eine Beschreibung enthalten, können Sie eine Vorlage mit diesen Elementen erstellen. Anschließend verwenden Sie die Vorlage, wenn Sie eine neue Seite erstellen. Das Logo und die Beschreibung werden dann automatisch auf der Seite positioniert.

Wenn Sie eine Seitenvorlage erstellen, erstellen Sie eine Seite mit den gewünschten Einstellungen und Seitenelementen und speichern diese dann als Vorlage. Die Vorlage wird zusammen mit den anderen in FrontPage enthaltenen Vorlagen angezeigt. Wenn Sie eine neue Seite auf der Basis der von Ihnen erstellten Vorlage erstellen möchten, wählen Sie einfach Ihre Vorlage aus der Liste aus.

Anmerkung Eine Seite, der ein Design zugewiesen ist, kann als Vorlage gespeichert werden. Seiten, die unter Verwendung dieser Vorlage erstellt werden, verwenden entweder das Standarddesign des Webs oder ein spezielles Design, abhängig davon, wie das Design der ursprünglichen Seite zugewiesen worden ist. Angenommen, Sie erstellen eine Vorlage auf der Basis einer Seite mit einem Design und erstellen dann Seiten in einem Web, dessen Standarddesign „Impressionen“ lautet. Wenn die Seitenvorlage das Standarddesign verwendet, verwenden neue Seiten das Design „Impressionen“. Wenn die Seitenvorlage ein anderes Design verwendet, verwenden neuen Seiten auch dieses andere Design.

  1. Erstellen Sie in der Seitenansicht eine Seite mit den für die Vorlage gewünschten Einstellungen und Elementen. Erstellen Sie z. B. eine Seite, die allgemeinen Text, Kommentare usw. enthält.
  2. Klicken Sie im Menü Datei auf Speichern unter.
  3. Klicken Sie im Feld Speichern unter auf FrontPage-Vorlage (*.tem).
  4. Klicken Sie auf Speichern.
  5. Geben Sie in das Feld Titel einen Titel für die Vorlage ein, die zusammen mit den Standardvorlagen auf der Registerkarte Allgemein des Dialogfelds Neu angezeigt wird.
  6. Geben Sie in das Feld Name den Dateinamen der Vorlage ein. FrontPage verwendet automatisch die richtige Erweiterung.
  7. Geben Sie in das Feld Beschreibung eine Beschreibung der Vorlage ein, z. B. den Typ der Seiten, die mit dieser Vorlage erstellt werden. Wenn Sie eine neue Seite erstellen, wird diese Beschreibung nach dem Auswählen dieser Vorlage im Dialogfeld Neu angezeigt.


Festlegen einer Hintergrundfarbe für eine Seite

Sie können eine Hintergrundfarbe für eine Seite festlegen.

Anmerkung Wenn die Seite ein Design verwendet, ändern Sie die Hintergrundfarbe durch Ändern der im Design verwendeten Farben.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Hintergrund.
  2. Wählen Sie im Feld Hintergrund eine Hintergrundfarbe aus.


Festlegen eines Hintergrundbildes für eine Seite

Sie können für eine Seite ein Hintergrundbild festlegen. Alle Seitenelemente, so wie Text und Grafiken, werden über dem Hintergrundbild angezeigt. Sie können Bilder aus einem Web, aus einem Dateisystem, dem World Wide Web oder ClipArt verwenden. Sie können auch ein Wasserzeichen als Hintergrundbild verwenden, das sich beim Durchführen eines Bildlaufs in einer Seite nicht mit dieser bewegt. Wasserzeichen werden jedoch nicht von allen Webbrowsern unterstützt.

Anmerkung Wenn die Seite ein Design verwendet, ändern Sie das Hintergrundbild durch Ändern der im Design verwendeten Grafiken.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  2. Klicken Sie auf die Registerkarte Hintergrund.
  3. Aktivieren Sie das Kontrollkästchen Hintergrundbild, und klicken Sie dann auf Durchsuchen.
  4. Wählen Sie das Hintergrundbild aus:
    • Wenn sich das Bild in einem Web befindet, suchen Sie in diesem Web nach dem Ordner, der das Bild enthält, wählen Sie das Bild aus, und klicken Sie dann auf OK.
    • Wenn sich das Bild in Ihrem lokalen Netzwerk befindet, klicken Sie auf Datei Schaltfläche "Datei", suchen Sie im lokalen Netzwerk nach dem gewünschten Bild, und klicken Sie dann auf OK.
    • Wenn sich das Bild im World Wide Web befindet, klicken Sie auf World Wide Web Schaltfläche "World Wide Web". Suchen Sie mithilfe Ihres Webbrowsers nach dem gewünschten Bild, und wechseln Sie zurück zu Microsoft FrontPage. Die Adresse des Bildes, das Sie besucht haben, wird im Feld URL angezeigt. Klicken Sie auf OK.
    • Wenn es sich bei dem Bild um ein ClipArt handelt, klicken Sie zum Anzeigen der Microsoft ClipArt Gallery auf ClipArt und dann mit der rechten Maustaste auf das gewünschte Bild. Anschließend klicken Sie im Kontextmenü auf Einfügen.


Übernehmen des Hintergrunds und der Farben einer Seite für eine andere Seite

Wenn Sie das Hintergrundbild, die Hintergrundfarbe, Hyperlinkfarben und Textfarben für eine Seite festgelegt haben, können Sie diese Einstellungen für eine andere Seite im aktuellen Web übernehmen.

Anmerkung Wenn die aktuelle Seite ein Design verwendet, ist dieses Funktionsmerkmal deaktiviert.

  1. Öffnen Sie die Seite, für die Sie einen Hintergrund und Farben übernehmen möchten, in der Seitenansicht.
  2. Klicken Sie mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  3. Klicken Sie auf die Registerkarte Hintergrund.
  4. Aktivieren Sie das Kontrollkästchen Hintergrundinformationen von einer anderen Seite übernehmen.
  5. Klicken Sie auf Durchsuchen.
  6. Wählen Sie die Seite aus, die den gewünschten Hintergrund und die gewünschten Farben enthält.


Festlegen von Seitenrändern

Sie können die Größe des oberen und linken Randes einer Seite festlegen.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  2. Klicken Sie auf die Registerkarte Ränder.
  3. Aktivieren Sie zum Festlegen eines oberen Randes das Kontrollkästchen Oberen Rand angeben, und geben Sie dann einen Wert für die Höhe des Randes in Pixeln ein.
  4. Aktivieren Sie zum Festlegen eines linken Randes das Kontrollkästchen Linken Rand angeben, und geben Sie dann einen Wert für die Breite des Randes in Pixeln ein.


Formatieren von Text

Um zu erfahren, wie Text formatiert wird, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Formatieren von Text in Fettschrift

Sie können Text in Fettschrift darstellen, z. B. um eine Hervorhebung hinzuzufügen.

  • Markieren Sie in der Seitenansicht den Text, und klicken Sie dann auf Fett Schaltfläche "Fett".


Einfügen eines Sonderzeichens

Sie können ein Sonderzeichen oder ein Symbol, wie z. B. das Trademark-Symbol (™), einfügen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, wo Sie ein Zeichen einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Sonderzeichen.
  3. Klicken Sie auf das Zeichen, das Sie einfügen möchten, und klicken Sie dann auf Einfügen.
  4. Klicken Sie auf Schließen.


Hinzufügen von Rahmen um einen Text

Sie können um einen Text einen Rahmen anbringen und dann dessen Eigenschaften festlegen, wie z. B. Format, Farbe, Abstand und Stärke des Rahmens.

Das Format des Rahmens um diesen Absatz ist z. B. doppelte Linie und blaue Farbe.

Wenn Sie einen Rahmen hinzufügen, wird er beim ganzen Absatz angewendet. Wenn Sie z. B. einen Rahmen nur auf ein markiertes Wort anwenden, wird der ganze Absatz davon betroffen. Oder wenn Sie zwei Absätze markieren und dann einen Rahmen anwenden, erhält jeder Absatz einen eigenen Rahmen. Wenn ein Text durch Zeilenumbruch anstatt durch Absatzmarken getrennt ist, wird der Text als ein Absatz angesehen und erhält nur einen Rahmen.

  1. Markieren Sie in der Seitenansicht den Absatz, um den herum Sie einen Rahmen hinzufügen möchten.
  2. Klicken Sie im Menü Format auf Rahmen und Schattierung.
  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Rahmen mit vier Seiten haben möchten, klicken Sie unter Einstellung auf Kasten. Legen Sie die Eigenschaften für den Rahmen durch Klicken auf die Optionen unter Linienart, Farbe und Breite fest.
    • Um einen benutzerdefinierten Rahmen zu erstellen, klicken Sie unter Einstellung auf Anpassen. Ein benutzerdefinierter Rahmen kann Linien nur auf bestimmten Seiten und jede Seite eine unterschiedliche Linienart, Farbe und Breite haben. Klicken Sie im Feld Linienart auf eine Linienart. Sie können auch auf die Optionen unter Farbe und Breite klicken. Wenden Sie unter Vorschau den Rahmen auf eine oder mehrere Seiten an, indem Sie auf die Seiten des Diagramms oder auf die Schaltflächen klicken.
  4. Um den Textabstand (den Abstand zwischen Text und Rahmen) festzulegen, geben Sie unter Abstände in den Feldern Oben, Unten, Links und Rechts jeweils einen Wert in Punkten ein.


Festlegen der Schriftart für einen Text

Sie können die Schrift für einen markierten Text durch Auswahl von Schriftart, Formatierung, Größe und Farbe festlegen. Sie können auch verschiedene Effekte auf den Text anwenden, wie z. B. Durchstreichung und Kapitälchen.

  1. Markieren Sie in der Seitenansicht den Text, den Sie formatieren möchten, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zeichen.
  2. Formatieren Sie auf der Registerkarte Schrift den Text durch Auswahl von Optionen in den Feldern Schriftart, Schriftschnitt, Schriftgrad und Farbe. Sie können auch eine oder mehrere Optionen unter Effekte auswählen. Der Bereich Vorschau zeigt, wie der Text aussieht, wenn Ihre Einstellungen angewendet werden.

Tipp Sie können eine Formatvorlage (wie z. B. die Formatvorlage Normal) durch Ihre eigenen Schrifteinstellungen ändern, so dass Sie Ihre Einstellungen nur einmal festlegen müssen. Danach wenden Sie einfach die Formatvorlage auf neuen Text an, wodurch Ihre Schrifteinstellungen automatisch angewendet werden.


Vergrößern oder Verkleinern des Abstands zwischen Zeichen

Sie können den Abstand zwischen Zeichen vergrößern oder verkleinern, um den Text zusammenzuschieben oder auseinanderzuziehen.

  1. Markieren Sie in der Seitenansicht den Text, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zeichen.
  2. Klicken Sie auf die Registerkarte Zeichenabstand.
  3. Klicken Sie im Feld Abstand auf Erweitert oder Verengt, um den Textabstand zu ändern.
  4. Wählen Sie im Feld um eine Option aus, um anzugeben, wie groß der Textabstand sein soll.


Ausschneiden oder Löschen von Text

Schneiden Sie einen Text aus, oder löschen Sie ihn, um ihn von der Seite zu entfernen. Wenn Sie Text ausschneiden, wird er in die Zwischenablage kopiert, und Sie können ihn an anderer Stelle wieder einfügen. Wenn Sie den Text löschen, wird er nicht in die Zwischenablage kopiert.

  1. Markieren Sie in der Seitenansicht den Text.
  2. Um den Text auszuschneiden und in die Zwischenablage zu kopieren, klicken Sie auf Ausschneiden Schaltfläche "Ausschneiden".
  3. Um den Text zu löschen, drücken Sie die ENTF-TASTE.


Hinzufügen von Schattierung zu einem Text

Sie können Schattierung zu einem Text hinzufügen. Diese kann wie bei einem Seitenhintergrund aus einer Farbe oder einem Bild bestehen.

Beispielsweise können Sie die Schattierung verwenden, um einen Absatz hervorzuheben, wie hier dargestellt.

Eine Schattierung wird auf den gesamten Absatz angewendet. Wenn Sie z. B. Schattierung auf ein markiertes Wort anwenden, wird der gesamte Absatz schattiert. Text, der durch Zeilenumbruch anstatt durch Absatzmarken getrennt ist, wird als ein Absatz betrachtet.

  1. Markieren Sie in der Seitenansicht die Absätze, zu denen Sie eine Schattierung hinzufügen möchten.
  2. Klicken Sie im Menü Format auf Rahmen und Schattierung, und klicken Sie dann auf die Registerkarte Schattierung.
  3. Um die Hintergrundfarbe für den markierten Text festzulegen, wählen Sie im Feld Hintergrundfarbe eine Farbe aus.
  4. Um die Farbe für den markierten Text festzulegen, wählen Sie im Feld Vordergrundfarbe eine Farbe aus.
  5. Um ein Hintergrundbild für den markierten Text festzulegen, geben Sie im Feld Hintergrundbild Name und Speicherort des Bildes ein, oder klicken Sie auf Durchsuchen, um das Bild zu finden und auszuwählen.

    6. Festlegen der Eigenschaften für das Hintergrundbild:

    • Um die vertikale und horizontale Position des Bildes innerhalb des markierten Absatzes anzugeben, klicken Sie in den Feldern Vertikale Position und Horizontale Position auf die entsprechenden Optionen.
    • Klicken Sie im Feld Wiederholen auf eine Option, um anzugeben, wie das Bild unter dem markierten Text angeordnet werden soll. Um das Bild z. B. horizontal nebeneinander anzuordnen, klicken Sie auf Wiederholt-x.
    • Klicken Sie im Feld Verankerung auf eine Option, um festzulegen, ob das Hintergrundbild relativ zum Browserfenster fixiert werden oder ob es mit dem Dokument mitlaufen soll.


Festlegen der Textausrichtung

Sie können Text linksbündig, rechtsbündig oder zentriert auf der Seite ausrichten. Die Einstellung zur Ausrichtung wirkt sich auf jeden Text im Absatz aus.

  1. Markieren Sie in der Seitenansicht den Text, den Sie ausrichten möchten.
  2. Klicken Sie auf Linksbündig ausrichten Schaltfläche "Linksbündig ausrichten", Zentriert Schaltfläche "Zentriert" oder Rechtsbündig ausrichten Schaltfläche "Rechtsbündig ausrichten", um den Text auszurichten.

Tipp Sie können eine Formatvorlage (wie z. B. die Formatvorlage Normal) durch Ihre eigenen Einstellungen zur Ausrichtung ändern, so dass Sie Ihre Einstellungen nur einmal festlegen müssen. Danach wenden Sie einfach die Formatvorlage auf neuen Text an, wodurch Ihre Schrifteinstellungen automatisch angewendet werden.


Festlegen von Zeilen- und Absatzeinzug

Sie können angeben, wie Sie einen Absatz einziehen möchten. So können Sie z. B. die rechte oder linke Seite des Absatzes oder nur die erste Zeile einziehen.

  1. Markieren Sie in der Seitenansicht einen oder mehrere Absätze, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Absatz.
  2. Führen Sie unter Einzug einen der folgenden Schritte durch:
    • Um die linke Seite des Absatzes einzuziehen, geben Sie im Feld Vor dem Text einen Wert in Punkt ein.
    • Um die rechte Seite des Absatzes einzuziehen, geben Sie im Feld Nach dem Text einen Wert in Punkt ein.
    • Um die erste Textzeile im Absatz einzuziehen, geben Sie im Feld Erste Zeile einziehen einen Wert in Punkt ein.

Tipps

  • Um den Einzug eines markierten Absatzes schnell zu ändern, klicken Sie auf Einzug vergrößern Schaltfläche "Einzug vergrößern" oder Einzug verkleinern Schaltfläche "Einzug verkleinern".
  • Sie können eine Formatvorlage (wie z. B. die Formatvorlage Normal) durch Ihre Einstellungen des Einzugs ändern, so dass Sie Ihre persönlichen Einstellungen nur einmal festlegen müssen. Danach wenden Sie auf neuen Text einfach die Formatvorlage an, und Ihre Einstellungen des Einzugs werden automatisch angewendet.


Höher- oder Tieferstellen von Text

Sie können Text höher oder tiefer stellen, um z. B. eine Fußnote anzuzeigen. Sie können auch die Anzahl Punkte angeben, um die der Text höher oder tiefer gestellt werden soll, obwohl manche Webbrowser diese Einstellung nicht unterstützen und den Standardwert von einem Punkt verwenden könnten.

  1. Markieren Sie in der Seitenansicht den Text, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Zeichen.
  2. Klicken Sie auf die Registerkarte Zeichenabstand.
  3. Klicken Sie im Feld Position auf Höherstellen oder Tieferstellen.
  4. Geben Sie im Feld um eine Zahl ein, die angibt, um wie viel der Text höher oder tiefer gestellt werden soll.

    5. Anmerkung Manche Webbrowser stellen den Text nur um einen festen Betrag höher, unabhängig davon, welche Zahl Sie eingeben.


Unterstreichen von Text

Sie können Text unterstreichen, um z. B. eine Hervorhebung hinzuzufügen.

  • Markieren Sie in der Seitenansicht den Text, und klicken Sie dann auf Unterstrichen Schaltfläche "Unterschrichen".


Hinzufügen einer neuen Textzeile innerhalb eines Absatzes

Um eine neue Textzeile zum aktuellen Absatz hinzuzufügen, fügen Sie einen Zeilenumbruch ein. Der Text wird dann am Anfang der nächsten Zeile angezeigt, befindet sich aber immer noch im aktuellen Absatz. Zeilen, die durch Zeilenumbruch voneinander getrennt sind, werden ohne besonderen Leerraum zwischen ihnen angezeigt, so dass sie enger zusammenstehend angezeigt werden.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, wo Sie den Zeilenumbruch einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Wechsel.
  3. Klicken Sie auf Normaler Zeilenwechsel.

    4. Anmerkung Wenn Bilder in der Nähe eines Absatzes angezeigt werden, können Sie spezielle Zeilenumbrüche hinzufügen, bei denen die neue Zeile unterhalb der Grundlinie des Bildes anstatt unterhalb des Absatzes beginnt:

    • Um einen Zeilenumbruch unterhalb eines Bildes anzubringen, das linksbündig ausgerichtet ist, klicken Sie auf Linken Rand frei halten.
    • Um einen Zeilenumbruch unterhalb eines Bildes anzubringen, das rechtsbündig ausgerichtet ist, klicken Sie auf Rechten Rand frei halten.
    • Um einen Zeilenumbruch unterhalb von Bildern auf der linken und auf der rechten Seite anzubringen, klicken Sie auf Beide Ränder frei halten.

Tipp Sie können auch UMSCHALT+EINGABE drücken, um einen Zeilenumbruch einzufügen.


Anwenden einer Formatvorlage auf einen Absatz

Eine Formatvorlage ist eine Kombination von Zeichen- und Absatzeinstellungen. Sie können mit Formatvorlagen einen Text schnell und konsistent formatieren. Wenden Sie z. B. die Formatvorlage Überschrift 1 bei jeder Überschrift an, damit sie alle gleich aussehen. Die Verwendung von Formatvorlagen spart auch Zeit, da Sie, anstatt die Zeichen- und Absatzeinstellungen für jede einzelne Überschrift zu ändern, einfach die zu verwendende Formatvorlage angeben.

Zusätzlich zu Formatvorlagen für Überschriften können Sie auch die Formatvorlage Aufzählung verwenden, die Text einrückt und Aufzählungszeichen hinzufügt, sowie die Formatvorlage Nummerierung, die Text einrückt und die Absätze nummeriert.

Wenn Sie eine Formatvorlage auf Text anwenden, wird sie auf den gesamten Text im Absatz angewendet.

  1. Markieren Sie den Absatz in der Seitenansicht.
  2. Führen Sie einen der folgenden Schritte durch:
    • Klicken Sie im Feld Formatvorlage auf eine Formatvorlage.
    • Um schnell die Formatvorlage Aufzählung anzuwenden, klicken Sie auf Aufzählungszeichen Schaltfläche "Aufzählungszeichen".
    • Um schnell die Formatvorlage Nummerierung anzuwenden, klicken Sie auf Nummerierung Schaltfläche "Nummerierung".


Kopieren von Zeichen- und Absatzformatierung

Sie können die Formatierung markierter Zeichen oder eines Absatzes kopieren und diese auf anderen Text anwenden.

  • Wenn Sie die zu kopierenden Zeichen markieren, wird die Formatierung kopiert, die den einzelnen Zeichen zugewiesen wurde.
  • Wenn Sie einen Absatz markieren (Markierung einschließlich Absatzmarke), werden Absatzformatierung und Zeichenformatierung des Absatzes kopiert.

Sie haben z. B. einen Absatz mit der Formatvorlage Überschrift 2, und der Text ist unterstrichen. Wenn Sie ein Wort markieren und diese Formatierung auf anderen Text anwenden, wird der andere Text nur unterstrichen. Wenn Sie den gesamten Absatz markieren und die Formatierung auf anderen Text anwenden, wird dieser andere Text als Überschrift 2 formatiert und unterstrichen. Sie können ebenso einen Hyperlink mit dem Befehl Format übertragen kopieren. Markieren Sie ein Wort oder mehrere, klicken Sie dann auf Format übertragen, und markieren Sie anschließend den Text, dem sie den Hyperlink mit dem selben Ziel zuweisen möchten.

  1. Markieren Sie die Zeichen oder den Absatz, die die Formatierung enthalten, die Sie kopieren möchten.
  2. Klicken Sie auf Format übertragen Schaltfläche "Format übertragen", und markieren Sie den Text, auf den Sie die Formatierung anwenden möchten.

Tipp Um die ausgewählte Formatierung an mehreren Stellen zu kopieren, doppelklicken Sie auf Format übertragen Schaltfläche "Format übertragen". Klicken Sie erneut auf die Schaltfläche, wenn Sie fertig sind.


Festlegen des Abstands zwischen Zeilen und Absätzen

Sie können festlegen, wie Sie die Textabstände innerhalb eines Absatzes und zwischen Absätzen haben möchten. Beispielsweise können Sie einen Absatz so definieren, dass er nach oben einen Abstand von 6 Punkt und nach unten einen Abstand von 12 Punkt hat. Sie können auch den Abstand zwischen den Textzeilen innerhalb eines Absatzes anpassen, z. B. als Text mit doppeltem Zeilenabstand.

  1. Markieren Sie in der Seitenansicht einen oder mehrere Absätze, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Absatz.
  2. Legen Sie unter Abstand den Textabstand fest, indem Sie einen der folgenden Schritte durchführen:
    • Um den Leerraum oberhalb eines Absatzes festzulegen, geben Sie im Feld Vor einen Wert ein.
    • Um den Leerraum unterhalb eines Absatzes festzulegen, geben Sie im Feld Nach einen Wert ein.
    • Um den Leerraum zwischen den Textzeilen vertikal festzulegen, klicken Sie im Feld Zeilenabstand auf eine Option.
    • Um den Leerraum zwischen Wörtern festzulegen, geben Sie im Feld Wort einen Wert ein. FrontPage zeigt jedoch die Auswirkung dieser Einstellung auf der Seite nicht an, und manche Webbrowser unterstützen dieses Funktionsmerkmal nicht.

Tipp Sie können eine Formatvorlage (wie die Formatvorlage Normal) durch Ihre Einstellungen der Textabstände ändern, so dass Sie Ihre persönlichen Einstellungen nur einmal festlegen müssen. Danach wenden Sie bei neuem Text einfach die Formatvorlage an, und Ihre Einstellungen der Textabstände werden automatisch angewendet.


Entfernen einer Textformatierung

Sie können eine Formatierung, die Sie auf einen Text angewendet haben, schnell entfernen. Wenn Sie dies tun, wird der Text wieder auf die Standardeinstellungen seiner Formatvorlage zurückgeführt.

  1. Markieren Sie in der Seitenansicht den Text.
  2. Klicken Sie im Menü Format auf Formatierung entfernen.


Info über Farben

Um mehr über Farben zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Festlegen einer benutzerdefinierten Farbe für ein Seitenelement

Sie können für eine Vielzahl von Seitenelementen eine Farbe definieren:

  • Text.
  • Hintergrund von Seiten, Tabellen und Zellen.
  • Hyperlinks.
  • Tabellenrahmen.
  • Grafische Elemente, wie z. B. horizontale Linien, gehoverte Schaltflächen und Laufschriften.

Wenn Sie eine Farbe auswählen möchten, zeigt Microsoft FrontPage eine oder mehrere Farbpaletten an. Wenn diese Paletten jedoch nicht die gewünschte Farbe enthalten, können Sie eigene Farben definieren.

  1. Führen Sie in der Seitenansicht einen der folgenden Schritte aus:
    • Klicken Sie zum Festlegen der Farbe für ausgewählten Text mit der rechten Maustaste auf diesen Text, und klicken Sie dann im Kontextmenü auf Zeichen. Klicken Sie dann auf das Feld Farbe.
    • Klicken Sie zum Festlegen der Standardtextfarbe für die aktuelle Seite mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Hintergrund. Anschließend klicken Sie auf das Feld Text.
    • Klicken Sie zum Festlegen der Hintergrundfarbe für die aktuelle Seite mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften und dann in der Registerkarte Hintergrund auf Hintergrund.
    • Klicken Sie zum Festlegen der Standardhyperlinkfarben für die aktuelle Seite mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann in der der Registerkarte Hintergrund auf eines der Hyperlink-Felder.
    • Klicken Sie zum Festlegen der Farbe für einen Tabellenhintergrund oder -rahmen mit der rechten Maustaste auf die Tabelle und dann im Kontextmenü auf Tabelleneigenschaften. Klicken Sie auf eines der Felder Farbe oder Rahmen.
    • Klicken Sie zum Festlegen der Farbe für einen Zellhintergrund oder -rahmen mit der rechten Maustaste auf die Zelle und dann im Kontextmenü auf Zelleneigenschaften. Klicken Sie auf eines der Felder Farbe oder Rahmen.
    • Klicken Sie zum Festlegen der Farbe für ein grafisches Element mit der rechten Maustaste auf das Element, und klicken Sie dann im Kontextmenü auf den entsprechenden Eigenschaftenbefehl. Klicken Sie auf das entsprechende Farbfeld.
  2. Klicken Sie in dem Feld, in dem Sie die Farbe eines Seitenelements definieren auf Mehr Farben.
  3. Führen Sie eines der folgenden Verfahren aus:
    • Klicken Sie zum Auswählen einer Farbe aus der browsersicheren Palette auf eine Farbe.
    • Geben Sie zum Festlegen eines Hexadezimalwertes in das Feld Wert einen Wert ein. Geben Sie z. B. HEX={FF,33,00} ein.
    • Klicken Sie zum Auswählen einer Farbe auf dem Bildschirm auf Auswählen, und verwenden Sie dann das Pipettentool, um auf die Farbe zu klicken. Um z. B. eine Farbe aus einem Bild auf einer geöffneten Seite auszuwählen, klicken Sie im Bild auf eine Farbe.
    • Zum Erstellen eines Farbmittelwerts aus den Farben in einem bestimmten Bildschirmbereich, klicken Sie auf Auswählen und verwenden Sie dann das Pipettentool, um auf dem Bildschirm einen Rahmen um den gewünschten Bereich zu zeichnen.
    • Klicken Sie zum Auswählen einer anderen Farbe oder zum Festlegen einer Kombination für Farbe-Sättigung-Helligkeit oder für Rot-Grün-Blau auf Benutzerdefiniert. Klicken Sie unter Benutzerdefinierte Farben auf ein leeres Feld. Definieren Sie eine Farbe durch Eingeben einer Kombination von Werten oder Auswählen einer Farbe aus der Farbmatrix.


Festlegen einer benutzerdefinierten Farbe für ein Designelement

Sie können die Farben für einzelne in einem Design verwendete Elemente festlegen. Wenn Sie eine Farbe auswählen möchten, zeigt Microsoft FrontPage eine oder mehrere Farbpaletten an. Wenn die Paletten nicht die gewünschte Farbe enthalten, können Sie eigene Farben definieren.

Anmerkung Wenn Sie ein FrontPage-Design ändern, müssen Sie das geänderte Design als ein neues Design speichern.

  1. Klicken Sie im Menü Format auf Design.
  2. Wählen Sie das Design aus, für das Sie Farben festlegen möchten. Wenn das Design gerade verwendet wird, ist es am oberen Rand unter der Bezeichnung (Standard) aufgeführt.
  3. Klicken Sie auf Ändern, auf Farben und dann auf die Registerkarte Benutzerdefiniert.
  4. Klicken Sie im Feld Element auf das Element, für das Sie eine benutzerdefinierte Farbe festlegen möchten.
  5. Klicken Sie auf das Feld Farbe und dann auf Mehr Farben.
  6. Führen Sie eines der folgenden Verfahren aus:
    • Klicken Sie zum Auswählen einer Farbe aus der browsersicheren Palette auf eine Farbe.
    • Geben Sie zum Festlegen eines Hexadezimalwertes in das Feld Wert einen Wert ein. Geben Sie z. B. HEX={FF,33,00} ein.
    • Klicken Sie zum Auswählen einer Farbe auf dem Bildschirm auf Auswählen, und verwenden Sie dann das Pipettentool, um auf die Farbe zu klicken. Um z. B. eine Farbe aus einem Bild auf einer geöffneten Seite auszuwählen, klicken Sie im Bild auf eine Farbe.
    • Zum Erstellen eines Farbmittelwerts aus den Farben in einem bestimmten Bildschirmbereich, klicken Sie auf Auswählen und verwenden Sie dann das Pipettentool, um auf dem Bildschirm einen Rahmen um den gewünschten Bereich zu zeichnen.
    • Klicken Sie zum Auswählen einer anderen Farbe oder zum Festlegen einer Kombination für Farbe-Sättigung-Helligkeit oder für Rot-Grün-Blau auf Benutzerdefiniert. Klicken Sie unter Benutzerdefinierte Farben auf ein leeres Feld. Definieren Sie eine Farbe durch Eingeben einer Kombination von Werten oder Auswählen einer Farbe aus der Farbmatrix.
  7. Klicken Sie auf OK, klicken Sie erneut auf OK, und klicken Sie dann auf Ja, um das geänderte Design zu speichern.
  8. Wenn das von Ihnen geänderte Design ein FrontPage-Design ist, geben Sie einen neuen Namen für das geänderte Design ein und klicken Sie dann auf OK.


Festlegen einer benutzerdefinierten Farbe für eine Formatvorlage

Sie können die Farbe für die in einem Cascading Stylesheet definierten Styles festlegen. Wenn Sie eine Farbe auswählen möchten, zeigt Microsoft FrontPage eine oder mehrere Paletten an. Wenn die Paletten jedoch nicht die gewünschte Farbe enthalten, können Sie eigene Farben definieren.

  1. Klicken Sie im Menü Format auf Formatvorlage.
  2. Klicken Sie im Feld Formatvorlage auf die Formatvorlage, für die Sie eine Farbe festlegen möchten, und klicken Sie dann auf Ändern.
  3. Klicken Sie auf Format und dann auf Zeichen.
  4. Klicken Sie auf das Feld Farbe und dann auf Mehr Farben.
  5. Führen Sie eines der folgenden Verfahren aus:
    • Klicken Sie zum Auswählen einer Farbe aus der browsersicheren Palette auf eine Farbe.
    • Geben Sie zum Festlegen eines Hexadezimalwertes in das Feld Wert einen Wert ein. Geben Sie z. B. HEX={FF,33,00} ein.
    • Klicken Sie zum Auswählen einer Farbe auf dem Bildschirm auf Auswählen, und verwenden Sie dann das Pipettentool, um auf die Farbe zu klicken. Um z. B. eine Farbe aus einem Bild auf einer geöffneten Seite auszuwählen, klicken Sie im Bild auf eine Farbe.
    • Zum Erstellen eines Farbmittelwerts aus den Farben in einem bestimmten Bildschirmbereich, klicken Sie auf Auswählen und verwenden Sie dann das Pipettentool, um auf dem Bildschirm einen Rahmen um den gewünschten Bereich zu zeichnen.
    • Klicken Sie zum Auswählen einer anderen Farbe oder zum Festlegen einer Kombination für Farbe-Sättigung-Helligkeit oder für Rot-Grün-Blau auf Benutzerdefiniert. Klicken Sie unter Benutzerdefinierte Farben auf ein leeres Feld. Definieren Sie eine Farbe durch Eingeben einer Kombination von Werten oder Auswählen einer Farbe aus der Farbmatrix.


Info über Positionieren

Um mehr über Positionieren zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Ablegen eines Elements auf einer Seite durch absolutes Positionieren

Verwenden Sie absolutes Positionieren zum Ablegen eines Seitenelements (Text oder Grafiken) an einer genauen Position auf der Seite. Die Position des Elements ist relativ zur oberen linken Ecke des entsprechenden Containers (der Seite oder eines Positionierungsrahmens).

  1. Wenn die Symbolleiste Positionierung nicht angezeigt wird, zeigen Sie im Menü Ansicht auf Symbolleiste, und klicken Sie dann auf Positionierung.
  2. Fügen Sie in der Seitenansicht das Seitenelement oder den Text ein, das/den Sie positionieren möchten (die Position auf der Seite spielt dabei keine Rolle).
  3. Wählen Sie das Seitenelement aus, und klicken Sie dann auf der Symbolleiste Positionierung auf Absolut positionieren Schaltfläche "Absolut positionieren".
  4. Führen Sie einen der folgenden Schritte aus, um die Position des Elements festzulegen:
    • Verschieben Sie das Element. Zeigen Sie dazu auf einen Rahmen, bis der Cursor sich in einen Vierfachpfeil ändert, und ziehen Sie das Element an die neue Position.
    • Legen Sie Pixelkoordinaten fest. Dazu geben Sie einen Wert in das Feld Links (X-Koordinate) und in das Feld Oben (Y-Koordinate) der Symbolleiste Positionierung ein.

    Tipp Zum Festlegen der Z-Ordnung, d. h. der Position des Elements innerhalb der Ebenen der Seite, geben Sie einen Wert in das Feld Z-Index der Symbolleiste Positionierung ein. Ein positiver Wert gibt an, dass sich das Element in der Haupttextebene (Ebene 0) befindet, ein negativer Wert gibt an, dass es sich hinter dieser Ebene befindet.

Weitere Informationen zum Positionieren finden Sie unter Info über Positionieren.

Anmerkungen

  • Deaktivieren Sie beim Positionieren von Elementen die Option Tags anzeigen (klicken Sie im Menü Ansicht auf Tags anzeigen, um das Häkchen zu entfernen) und die Option Alle anzeigen (klicken Sie auf Alle anzeigen Schaltfläche "Alle anzeigen", wenn diese bereits aktiviert ist). Tags und nicht-druckbare Zeichen sind nicht Teil des Layouts, wenn Sie diese jedoch beim Bearbeiten auf dem Bildschirm anzeigen, ändern sie das in FrontPage angezeigte Layout. Deaktivieren Sie diese Funktionen, damit Ihr Layout dem näherkommt, was später in einem Webbrowser angezeigt werden wird, und wechseln Sie in FrontPage häufig zwischen den Ansichten Normal und Vorschau.
  • Das Seitenlayout kann sich bei Verwendung unterschiedlicher Bildschirmauflösungen ändern, auch wenn ein absolut positioniertes Elemente immer an den Koordinaten angezeigt wird, die Sie angeben. Um sicherzustellen, dass die Seite allen Besuchern ordnungsgemäß angezeigt wird, testen Sie die Anzeige mit unterschiedlichen Bildschirmauflösungen.
  • Verwenden Sie bei absoluter Positionierung kein DHTML, da dies zu unvorhersehbaren Ergebnissen führen kann.


Gruppieren von Elementen innerhalb eines Positionierungsfeldes

Zum Erstellen eines Bereichs, in dem Elemente gruppiert und als Einheit behandelt werden, legen Sie auf der Seite ein Positionierungsfeld ab und fügen dann zu diesem Feld absolut positionierte Elemente hinzu. Das Ergebnis ist ein Positionierungsfeld, das relativ zu anderen Seitenelementen positioniert ist, wobei jedoch das Layout der Elemente innerhalb des Feldes beibehalten wird, unabhängig von Änderungen an der Seite außerhalb des Feldes. Sie können z. B. ein Logo und Text innerhalb eines Positionierungsfeldes anordnen.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an eine Stelle, an der Sie ein Positionierungsfeld ablegen möchten, und drücken Sie dann zweimal die EINGABETASTE, um eine neue leere Zeile (eine Absatzmarke) einzufügen.
  2. Wählen Sie die leere Zeile aus, und klicken Sie dann im Menü Format auf Position.
  3. Klicken Sie unter Positionierungsart auf Relativ und dann auf OK.

    4. In der neuen Zeile wird ein Positionierungsfeld eingefügt.

  4. Wenn die Symbolleiste Positionierung nicht angezeigt wird, zeigen Sie im Menü Ansicht auf Symbolleisten und klicken dann auf Positionierung.
  5. Klicken Sie in das Positionierungsfeld und fügen Sie das gewünschte Seitenelement ein oder geben Sie den gewünschten Text ein.
  6. Wählen Sie das Seitenelement aus, und klicken Sie dann auf der Symbolleiste Positionierung auf Absolut positionieren Schaltfläche "Absolut positionieren".
  7. Führen Sie einen der folgenden Schritte aus, um die Position des Elements festzulegen:
    • Verschieben Sie das Element. Zeigen Sie dazu auf ein Feld, bis der Cursor sich in einen Vierfachpfeil ändert, und ziehen Sie das Element an die neue Position.
    • Legen Sie Pixelkoordinaten fest. Dazu geben Sie Werte in die Felder Links (X-Koordinate) und Oben (Y-Koordinate) der Symbolleiste Positionierung ein.

    Wiederholen Sie die Schritte 5, 6 und 7 für jedes Seitenelement, das Sie im Positionierungsfeld ablegen möchten.

  8. Legen Sie die Positionierungseigenschaften für das Positionierungsfeld oder die Seitenelemente fest.

Weitere Informationen zum Positionieren finden Sie unter Info über Positionieren.

Anmerkungen

  • Deaktivieren Sie beim Positionieren von Elementen die Option Tags anzeigen (klicken Sie im Menü Ansicht auf Tags anzeigen, um das Häkchen zu entfernen) und die Option Alle anzeigen (klicken Sie auf Alle anzeigen Schaltfläche "Alle anzeigen", wenn diese bereits aktiviert ist). Tags und nicht-druckbare Zeichen sind nicht Teil des Layouts, wenn Sie diese jedoch beim Bearbeiten auf dem Bildschirm anzeigen, ändern sie das in FrontPage angezeigte Layout. Deaktivieren Sie diese Funktionen, damit Ihr Layout dem näherkommt, was später in einem Webbrowser angezeigt werden wird, und wechseln Sie in der Seitenansicht häufig zwischen den Ansichten Standard und Vorschau.
  • Das Seitenlayout kann sich bei Verwendung unterschiedlicher Bildschirmauflösungen ändern, auch wenn ein absolut positioniertes Elemente immer an den Koordinaten angezeigt wird, die Sie angeben. Um sicherzustellen, dass die Seite allen Besuchern ordnungsgemäß angezeigt wird, testen Sie die Anzeige mit unterschiedlichen Bildschirmauflösungen.
  • Verwenden Sie bei absoluter Positionierung kein DHTML, da dies zu unvorhersehbaren Ergebnissen führen kann.


Festlegen der Eigenschaften eines positionierten Seitenelements

Nach dem Einfügen eines Positionierungsfeldes oder dem Positionieren eines Seitenelements können Sie die folgenden Positionierungseigenschaften einstellen:

  • Ändern der Positionierungsart des Seitenelements: Absolut (Positionieren des Elements an einer genauen Position), Relativ (Positionieren des Elements an einer Stelle relativ zu anderen Seitenelementen im Textfluss) oder Ohne (das Element wird als normales Seitenelement positioniert, z. B. zwischen zwei Absätzen verankert).
  • Festlegen der Art, wie Text und andere Seitenelemente das Seitenelement umfließen sollen (dabei wird ein frei positioniertes Seitenelement erstellt. Sie können einerseits verhindern, dass neben dem positionierten Element andere Elemente vorhanden sein dürfen oder andererseits das Element rechts oder links auf der Seite frei positionieren.
  • Festlegen der Z-Ordnung, d. h. der Position des Elements innerhalb der Ebenen der Seite. Der Textfluss befindet sich auf der Hauptseitenebene. Sie können ein absolut positioniertes Seitenelement hinter oder vor dieser Ebene positionieren.
  • Festlegen der Koordinaten der Seitenelemente relativ zur oberen linken Ecke seines Containers (wenn sich ein Element z. B. innerhalb einer Seite oder eines Positionierungsfeldes befindet) und Angeben der Abmessungen des Positionierungsfeldes. Sie können dazu die folgenden Einheiten verwenden:
    • Pixel (px)
    • Schriftgrad (em)
    • X-Höhe der Schrift (ex)
    • Zoll (in)
    • Zentimeter (cm)
    • Millimeter (mm)
    • Punkt (Pt), wobei ein Punkt 1/72 Zoll entspricht
    • Prozentsatz der Seitenhöhe oder -breite (%)

    Sie können für ein Positionierungsfeld die gleiche Breite wie für die Seite verwenden (dazu legen Sie für Breite den Wert 100% fest). Für die Höhe können Sie 20 Pixel festlegen (dazu legen Sie für Höhe den Wert 20 px fest).

Tipp Um die aktuellen Eigenschaften eines Seitenelements anzuzeigen, positionieren Sie den Mauszeiger über dem Element. Die Eigenschaften werden in Form einer QuickInfo angezeigt.

  1. Wählen Sie in der Seitenansicht das positionierte Element aus.

    2. Anmerkung Positionierungseinstellungen werden dem ausgewählten Element (dem Element, das mit Ziehpunkten angezeigt wird) zugewiesen. Wenn daher ein normales Seitenelement ausgewählt ist, werden diesem die Positionierungseinstellungen zugewiesen, die Sie festlegen, d. h. das Element wird entsprechend positioniert.

  2. Klicken Sie im Menü Format auf Position.
  3. Geben Sie unter Positionierungsart an, wie das Seitenelement positioniert werden soll.
  4. Legen Sie unter Umbruchart fest, wie Text und andere Seitenelement das Element umfließen sollen.
  5. Geben Sie zum Festlegen der Koordinaten des positionierten Elements unter Ort und Größe in den Feldern Oben und Links die Koordinaten der linken oberen Ecke des Positionierungsfeldes oder Elements ein.
  6. Geben Sie zum Festlegen der genauen Abmessungen des Positionierungsfeldes unter Ort und Größe die Höhe und Breite ein.
  7. Geben Sie zum Festlegen der Z-Ordnung (d. h. der Position des Elements innerhalb der Ebenen einer Seite) im Feld Z-Index auf der Symbolleiste Positionierung einen Wert ein. Ein positiver Wert gibt an, dass sich das Element in der Haupttextebene (Ebene 0) befindet; ein negativer Wert gibt an, dass es sich dahinter befindet.

Tipp Sie können unter Verwendung der Symbolleiste Positionierung auch mehrere Eigenschaften festlegen. Zeigen Sie zum Einblenden der Symbolleiste Positionierung im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Positionierung.


Auswählen eines positionierten Elements

Das Auswählen eines positionierten Elements kann schwieriger sein, als das Auswählen eines Seitenelements in der Haupttextebene. Wenn Sie z. B. ein Seitenelement auswählen möchten, dass sich hinter dem Textfluss befindet, werden beim Klicken auf dieses Seitenelement stattdessen die Seitenelemente im Textfluss ausgewählt.

Viele Typen von Seitenelementen, wie z. B. Grafiken, Formularfelder und andere Objekte, sind beim Anzeigen aller nicht-druckbaren Zeichen (Klicken auf Alle anzeigen Schaltfläche "Alle anzeigen") durch einen Anker gekennzeichnet. Der Anker wird im Textfluss dort angezeigt, wo Sie das Element ursprünglich eingefügt haben. Eine absolut positionierte Grafik wird z. B. am oberen Rand der Seite angezeigt, wenn Sie die Grafik jedoch ursprünglich am unteren Rand eingefügt haben, wird der Anker am unteren Rand angezeigt. Zum Auswählen des Objekts wählen Sie das entsprechende Ankersymbol aus.

Einige Seitenelemente, wie Text oder Tabellen, werden nicht durch ein Ankersymbol gekennzeichnet, und Sie müssen diese Elemente durch direktes Klicken auswählen.

Weitere Informationen zum Positionieren finden Sie unter Info über Positionieren.


Info über Formulare

Um mehr über Formulare zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Erstellen eines Formulars

Sie können an einer beliebigen Stelle auf einer Seite außerhalb eines bestehenden Formulars ein Formular erstellen. Microsoft FrontPage fügt einen rechteckigen, durch eine gestrichelte Linie begrenzten, Bereich ein, in dem Sie Text- und Formular-Felder hinzufügen können, wie z. B Textfelder, Optionsfelder, Kontrollkästchen, Dropdownmenüs, und Schaltflächen.

Eine Schaltfläche Abschicken und eine Schaltfläche Zurücksetzen werden ebenfalls zum Formular hinzugefügt. Der Sitebesucher kann nach dem Ausfüllen eines Formulars auf die Schaltfläche Abschicken klicken, um die eingegebenen Informationen an die von Ihnen eingerichtete Formularbehandlungsroutine zu senden. Zum Zurücksetzen des Formulars in den Originalzustand kann der Sitebesucher auf die Schaltfläche Zurücksetzen klicken. Dabei werden Texte, die der Besucher eingegeben hat, gelöscht und Auswahlen, die er getroffen hat, zurückgesetzt.

  • Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Formular.


Erstellen eines Formulars unter Verwendung eines Assistenten

Erstellen eines Formular unter Verwendung eines Assistenten

Sie können zum Erstellen eines Formulars auch den Formularseiten-Assistenten verwenden, der Sie auffordert, die folgenden Informationen anzugeben:

  • Die Daten, die Sie zusammenstellen möchten, die festlegen, welche Felder Sie in Ihrem Formular benötigen.
  • Das Layout für die Felder. Sie können das Formular in Absätzen oder Listen anordnen und auswählen, ob für das Layout der Seite Tabellen verwendet werden sollen.
  • Ob am Anfang der Seite ein Inhaltsverzeichnis angezeigt werden soll (nützlich für umfangreiche Formulare).
  • Wie die Formularergebnisse (die Daten, die nach dem Ausfüllen eines Formulars durch einen Sitebesucher zusammengestellt werden) gespeichert werden sollen. Der Assistent erlaubt das Speichern der Ergebnisse in einer Textdatei oder einer HTML-Datei oder das Verwenden eines benutzerdefinierten Skripts zum Behandeln der Ergebnisse. Wenn ein Sitebesucher im Formular auf die Schaltfläche Abschicken klickt, werden die Formularergebnisse an die Stelle gesendet, die Sie hier angeben.

Anhand dieser Informationen erstellt der Assistent Ihr Formular. Sie können es danach noch anpassen. Dazu bearbeiten Sie den Text und definieren Eigenschaften und Dateneingaberegeln für die Formularfelder.

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Seite.
  2. Klicken Sie in der Registerkarte Allgemein auf Formularseiten-Assistent, und klicken Sie dann auf OK.

    3. Der Formularseiten-Assistent wird geöffnet. Folgen Sie den Anweisungen, die auf dem Bildschirm angezeigt werden.


Erstellen eines Suchformulars

Wenn Ihr Web serverbasiert ist und Ihr Server die Servererweiterungen von Microsoft FrontPage ausführt, dann erstellt FrontPage automatisch einen Textindex, der auf den Wörtern basiert, die in allen Seiten Ihres Webs enthalten sind. Erstellen Sie ein Suchformular, damit Sitebesucher Ihr Web nach bestimmten Wörtern oder Phrasen durchsuchen können. Wenn ein Besucher ein Suchformular abschickt, dann prüft FrontPage den Textindex und zeigt eine gewichtete Liste von Hyperlinks auf Seiten an, die den gesuchten Text enthalten.

Tipp Der einfachste Weg, ein Suchformular zu erstellen, ist die Erstellung einer neuen Seite, die auf der Suchseitenvorlage beruht. Sie können die Vorlage mit Ihrem eigenen Einführungstext, mit Copyrightinformationen, Schaltflächenbeschriftungen usw. anpassen. Wenn Sie ein Suchformular zu einer bestehenden Seite mithilfe der folgenden Prozedur hinzufügen, achten Sie darauf, Hinweise zur Verwendung des Suchformulars für Sitebesucher aufzuschreiben, und erstellen Sie das Suchformular unmittelbar hinter dem erklärenden Text.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an die Stelle, wo Sie das Suchformular erstellen möchten. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Suchformular.
  2. Um ein Standardsuchformular auf der Basis der FrontPage-Voreinstellungen wie im obigen Beispiel zu erstellen, klicken Sie auf OK. Sie können das Suchformular später formatieren, falls Sie die Schaltflächenbeschriftungen ändern oder das Online-Eingabefeld breiter machen, die Suche auf ein bestimmtes Diskussionsweb eingrenzen oder das Suchergebnis formatieren möchten.

Anmerkungen

  • Wenn Sie eine Seite in einem Web speichern, fügt FrontPage neue Wörter zum Textindex für dieses Web hinzu. Der Textindex ist kumulativ: Neue Wörter werden zum Index hinzugefügt, alte jedoch nicht entfernt. Um einen neuen Textindex zu erstellen und um veraltete Wörter zu bereinigen, klicken Sie im Menü Extras auf Hyperlinks neu berechnen. Beachten Sie, dass diese Prozedur mehrere Minuten dauern kann, wenn Sie viele externe Hyperlinks haben, da sich FrontPage mit jedem verbinden und jeden überprüfen muss.
  • Ein Suchformular ermittelt annähernd 300 der häufigsten englischen Wörter nicht, wie z. B. „a,“ „the,“ usw.
  • Wenn Ihr Server die Dienste von Microsoft Internet Information Server (IIS) verwendet, benutzt das Suchformular Microsoft Index Server, um den Textindex zu durchsuchen. Index Server unterstützt in höherem Maße außerenglische Systeme und Dokumente von Microsoft Office.


Formatieren eines Suchformulars

Sie können ein Suchformular erstellen, mit dem Sitebesucher Ihr Web nach bestimmten Wörtern oder Begriffen durchsuchen können. Wenn das Standardsuchformular nicht Ihren Anforderungen entspricht, können Sie die Schaltflächenbeschriftungen ändern und das Onlinetextfeld verkürzen oder erweitern.

Klicken Sie mit der rechten Maustaste in der Seitenansicht auf das Suchformular, das Sie formatieren möchten, klicken Sie im Kontextmenü auf Suchformulareigenschaften, und klicken Sie dann auf die Registerkarte Suchformulareigenschaften:

  • Um die Beschriftung des Onlinetextfelds zu ändern, in das die Sitebesucher ihren Suchtext eingeben, geben Sie im Feld Beschriftung des Eingabefelds eine andere Beschriftung ein.
  • Um das Onlinetextfeld enger oder breiter zu machen, geben Sie eine kleinere oder größere Zahl im Feld Breite (in Zeichen) ein.

    • Anmerkung Das Ändern der Größe des Onlinetextfelds berührt nicht die Anzahl der Zeichen, die ein Sitebesucher in dem Feld eingeben kann. Wenn er mehr Zeichen eingibt, als in das Feld hineinpassen, dann gehen die überschüssigen Zeichen über den rechten Rand des Feldes hinaus, jedoch wird der gesamte vom Sitebesucher eingegebene Text mit dem Suchformular übertragen.

  • Um die Beschriftung der Schaltfläche Suche beginnen auf dem Suchformular zu ändern (d. h. die Schaltfläche, auf die ein Sitebesucher klickt, um die Suche an den Server abzuschicken), geben Sie im Feld Beschriftung für Schaltfläche „Suche beginnen“ eine andere Beschriftung ein.
  • Um die Beschriftung der Schaltfläche Zurücksetzen auf dem Suchformular zu ändern (d. h. die Schaltfläche, auf die ein Sitebesucher klickt, um den Text im Onlinetextfeld aus der vorherigen Suche wiederherzustellen, falls vorhanden), geben Sie eine andere Beschriftung im Feld Beschriftung für Schaltfläche „Löschen“ ein.


Formatieren von Suchergebnissen

Sie können ein Suchformular erstellen, damit ein Sitebesucher Ihr Web nach bestimmten Wörtern oder Begriffen durchsuchen kann. Wenn der Server im Textindex Ihres Webs den gesuchten Text findet, erhält der Besucher eine gewichtete Liste von Hyperlinks auf Seiten, die den gesuchten Text enthalten.

Zu dieser Liste mit Hyperlinks, die an den Besucher zurückgegeben wird, können Sie Trefferpunkte und Dateiinformationen hinzufügen.

Für WAIS:

Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Suchformular, das Sie formatieren möchten, klicken Sie im Kontextmenü auf Suchformulareigenschaften, und klicken Sie dann auf die Registerkarte Suchergebnisse:

  • Um die Treffer, d. h. die Qualität einer Übereinstimmung, mit einzuschließen, aktivieren Sie das Kontrollkästchen Treffer anzeigen. Je höher die Zahl der Treffer, desto größer ist die Übereinstimmung.
  • Um Datum und Uhrzeit der letzten Änderung einer Seite mit einzuschließen, aktivieren Sie das Kontrollkästchen Dateidatum anzeigen.
  • Um die Größe jeder Seite mit einzuschließen, aktivieren Sie das Kontrollkästchen Dateigröße anzeigen.

Für Index Server:

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Suchformular, das Sie formatieren möchten, klicken Sie im Kontextmenü auf Suchformulareigenschaften, und klicken Sie dann auf die Registerkarte Suchergebnisse.
  2. Wählen Sie im Bereich Zusätzliche Informationen die in der Suchergebnisliste angezeigt werden sollen die Formatoptionen aus:
  • Um Datum und Uhrzeit der letzten Änderung einer Seite mit einzuschließen, aktivieren Sie das Kontrollkästchen Datum der letzten Änderung
  • Um die Größe jeder Seite mit einzuschließen, aktivieren Sie das Kontrollkästchen Dateigröße in Bytes.
  • Um die Treffer, d. h. die Qualität einer Übereinstimmung, mit einzuschließen, aktivieren Sie das Kontrollkästchen Treffer. Je höher die Zahl der Treffer, desto größer ist die Übereinstimmung.
  • Für Microsoft Word, Microsoft Excel, und Microsoft PowerPoint: Um den Autor einer Diskussion einzuschließen, aktivieren Sie das Kontrollkästchen Autor des Dokuments.
  • Für Microsoft Word, Microsoft Excel, und Microsoft PowerPoint: Um die Kommentare zu einer Seite mit einzuschließen, aktivieren Sie das Kontollkästchen Kommentare.
  • Für Microsoft Word, Microsoft Excel, und Microsoft PowerPoint: Um das Thema eines Dokuments mit einzuschließen, aktivieren Sie das Kontrollkästchen Thema des Dokuments.
  • Um die Anzahl der Vorkommen des gesuchten Texts in den Dokumenten einzuschließen, aktivieren Sie das Kontrollkästchen Trefferanzahl.


Anzeigen einer Warnung, wenn ein Textindex veraltet ist

Wenn Ihr Web serverbasiert ist und Ihr Server die Servererweiterungen von Microsoft FrontPage ausführt, dann erstellt FrontPage automatisch einen Textindex, der auf den Wörtern basiert, die in allen Seiten Ihres Webs enthalten sind. Sie können ein Suchformular erstellen, damit Sitebesucher Ihr Web nach bestimmten Wörtern oder Begriffen durchsuchen können. Wenn ein Besucher ein Suchformular abschickt, dann prüft FrontPage den Textindex und zeigt eine gewichtete Liste mit Hyperlinks auf die Seiten an, die den gesuchten Text enthalten.

Wenn Sie eine Seite in einem Web speichern, fügt FrontPage alle neuen Wörter zum Textindex für dieses Web hinzu. Dieser Textindex ist kumulativ: Neue Wörter werden zum Index hinzugefügt, alte jedoch nicht aus ihm entfernt. Wenn Sie ein Web öffnen, können Sie festlegen, dass FrontPage eine Warnung anzeigen soll, wenn der Textindex für dieses Web veraltet ist und neu berechnet werden muss, um veraltete Wörter zu entfernen.

  1. Zeigen Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Allgemein.
  2. Aktivieren Sie das Kontrollkästchen Warnung anzeigen, wenn Textindex nicht aktuell ist.

Anmerkungen

  • Um einen neuen Textindex zu erstellen und veraltete Wörter zu löschen, klicken Sie im Menü Extras auf Hyperlinks neu berechnen. Beachten Sie, dass diese Prozedur mehrere Minuten dauern kann, wenn Sie viele externe Hyperlinks haben, da FrontPage sich mit jedem einzelnen verbinden und diesen überprüfen muss.
  • Ein Suchformular berücksichtigt ca. 300 der häufigsten englischen Wörter, wie zum Beispiel „a“, „the“ usw. nicht.
  • Wenn Ihr Server die Dienste von Microsoft Internet Information Server (IIS) verwendet und Sie auch Microsoft Index Server installiert haben, dann verwendet das Suchformular Index Server, um den Textindex zu durchsuchen. Index Server hat eine umfangreichere Unterstützung für das Durchsuchen außerenglischer Systeme und von Microsoft Office-Dokumenten. Da Index Server jedoch den Textindex in einem Hintergrundprozess aktualisiert (abhängig davon, wie Index Server konfiguriert ist), kann das Aktualisieren des Textindexes von meheren Minuten bis zu einigen Stunden oder mehr dauern.


Erstellen eines Benutzerregistrierungsformulars

Sie können den Zugriff auf ein geschütztes Web einschränken oder den Zugriff auf ein Web überwachen. Dazu erstellen Sie ein Formular zur Benutzerregistrierung, in dem Sitebesucher sich durch Eingeben eines Namens und eines Kennwortes anmelden.

  • Um ein Web zu schützen, legen Sie fest, welche Benutzer Zugriff auf das Web erhalten sollen. Dann authentifiziert die Formularbehandlungsroutine für Registrierung den Besucher anhand dieser Liste, um nur registrierten Benutzern den Zugriff zu gewähren.
  • Um den Zugriff auf ein Web zu überwachen, speichert die Formularbehandlungsroutine für Registrierung die Benutzernamen der Sitebesucher, die auf Ihr Web zugegriffen haben.

Anmerkung Windows NT-Sicherheit und Microsoft Internet Information Services (IIS) erlauben keine Registrierung mittels eines Webbrowsers.

Das Registrierungsformular muss im Stammweb gespeichert werden. Es darf nicht in der Website selbst gespeichert werden. Wenn die geschützte Website z. B. http://Stamm/Unterweb lautet, muss das Formular in STAMM gespeichert werden. Erstellen Sie das geschützte Web vor dem Erstellen dieses Formulars.

Am einfachsten erstellen Sie ein Registrierungsformular unter Verwendung der Dokumentvorlage für eine Benutzerregistrierungsseite.

  1. Öffnen Sie Ihr Stammweb.
  2. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Seite.
  3. Klicken Sie in der Registerkarte Allgemein auf Benutzerregistrierung, und klicken Sie dann auf OK.

    4. FrontPage erstelle ein Benutzerregistrierungsformular und weist diesem die Formularbehandlungsroutine für Registrierung zu.

  4. Klicken Sie mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  5. Klicken Sie auf Optionen und dann auf die Registerkarte Registrierung.
  6. Geben Sie in das Feld Name des Webs den Namen der geschützten Website ein.
  7. Klicken Sie auf die Registerkarte Dateiergebnisse. Die Datei, in der die Benutzernamen von Sitebesuchern gespeichert sind, wird im Feld Dateiname angezeigt. Standardmäßig befindet sich diese Datei im Ordner _private des Stammwebs.
  8. Klicken Sie auf OK und dann erneut auf OK.
  9. Passen Sie die Felder im Formular wie gewünscht an. Ändern Sie z. B. den Ausdruck [Name des Unterwebs] in den Namen Ihrer geschützten Website, passen Sie die Anwendungen im Formular an, und ändern Sie die Textbeschriftungen für die Felder.
  10. Klicken Sie auf die Schaltfläche Speichern Schaltfläche "Speichern", und speichern Sie Ihre Seite.

Wenn Sie ein Web schützen möchten, öffnen Sie das Web und führen Sie folgendes aus:

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Klicken Sie auf der Registerkarte Einstellungen auf Für dieses Web einmalige Berechtigungen verwenden und dann auf Übernehmen.
  3. Klicken Sie auf die Registerkarte Benutzer und dann auf Nur registrierte Benutzer haben Lesezugriff.
  4. Klicken Sie auf Hinzufügen.

    5. Anschließend fügen Sie die Benutzer zum Web hinzu. Dazu fügen Sie separat Benutzer mit Berechtigung zum Lesen, zum Verfassen oder zum Verwalten von Dokumenten hinzu. Sie fügen beispielsweise Benutzer mit Lesezugriff getrennt von denen mit Lese-/Schreibzugriff hinzu.

  5. Wenn Sie einen Webserver verwenden, der Domänenhierarchie unterstützt, wählen Sie im Feld Liste beziehen von die Domäne oder Gruppe aus, aus der Sie Benutzer auswählen möchten.
  6. Wählen Sie im Feld Namen einen Benutzernamen aus, oder geben Sie einen ein, und klicken Sie dann auf Hinzufügen.

    7. Wiederholen Sie die Schritte 5 und 6 für jeden Benutzer, den Sie für eine bestimmte Zugriffsart hinzufügen möchten.

  7. Geben Sie die Zugriffsart an, die Sie der Liste der Benutzer gewähren möchten, die Sie hinzufügen (browsen, Dokumente verfassen oder verwalten), und klicken Sie dann auf OK.

    8. Alle im Feld Namen hinzufügen aufgeführten Benutzer erhalten dieselbe Berechtigung. Um unterschiedliche Berechtigungen festzulegen, um z. B. einem Benutzer Browse-Zugriff und einem anderen die Berechtigung zum Verfassen von Dokumenten zu geben, wiederholen Sie die Schritte 4 bis 7 für jeden Benutzer.

Tipp Zum Überprüfen Ihres Benutzerregistrierungsformulars zeigen Sie die Vorschau in Ihrem Webbrowsers an. Dazu klicken Sie auf die Schaltfläche Vorschau in Browser Schaltfläche "Vorschau in Browser".


Erstellen einer Bestätigungsseite und Zuweisen dieser Seite zu einem Formular

Anstatt die Standardbestätigungsseite zu verwenden, können Sie eine eigene Bestätigungsseite erstellen. Erstellen Sie zunächst eine neue Seite in Ihrem Web, und definieren Sie diese dann als Bestätigungsseite für Ihr Formular.

Sie können auf Ihrer Bestätigungsseite den Inhalt von Formularfeldern anzeigen. Der Sitebesucher kann bestätigen, dass die Informationen korrekt eingegeben worden sind und ggf. zum Formular zurückkehren und es neu ausfüllen. Sie können die Bestätigungsseite auch personalisieren, in dem Sie z. B. in Ihrem Formular nach dem Namen des Besuchers fragen und diesen dann in der Bestätigungsseite anzeigen:

Sehr geehrter Herr Smith,
vielen Dank, dass Sie sich die Mühe gemacht haben, dieses Formular auszufüllen.

  1. Klicken Sie in der Seitenansicht auf die Schaltfläche Neue Seite Schaltfläche "Neue Seite".
  2. Geben Sie auf der Seite den Text ein, den Sie dem Sitebesucher nach dem Abschicken des Formulars anzeigen möchten.
  3. Um dem Besucher Informationen aus einem Formularfeld zur Bestätigung anzuzeigen, führen Sie die folgenden Schritte aus:
    • Setzen Sie den Cursor an die Stelle, an der Sie den Text anzeigen möchten. Sie können z. B. den Inhalt eines E-Mail-Adressenfeldes anzeigen und dem Besucher erlauben, die Informationen, die er eingegeben hat, zu bestätigen.
    • Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Bestätigungsfeld.
    • Geben Sie in das Feld Name des zu bestätigenden Formularfeldes den Namen des Feldes ein, aus dem Sie Informationen anzeigen möchten, und klicken Sie dann auf OK.

    Der Name des Feldes wird auf dem Formular in eckigen Klammern angezeigt. Wenn dem Besucher das Bestätigungsformular angezeigt wird, wird hier stattdessen die Eingabe des Besuchers angezeigt.

    Wiederholen Sie diesen Schritt für jedes Feld, das Sie anzeigen möchten.

  4. Klicken Sie auf Speichern [image].
  5. Geben Sie den URL und den Seitentitel ein, und klicken Sie dann auf Speichern.
  6. Um die Bestätigungsseite Ihrem Formular zuzuweisen, öffnen Sie die Seite, die Ihr Formular enthält. Dazu klicken Sie in der Ordnerliste auf die Datei.
  7. Klicken Sie mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  8. Klicken Sie auf Optionen und dann auf die Registerkarte Bestätigungsseite.
  9. Geben Sie in das Feld URL der Bestätigungsseite den Namen und die Position der gerade erstellten Bestätigungsseite ein, oder klicken Sie auf Durchsuchen, um danach zu suchen.

Tipps

  • Sie können zum Erstellen einer Bestätigungsseite auch die Vorlage für ein Bestätigungsseitenformular verwenden.
  • Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche <strong>Vorschau in Browser</strong> in Ihrem Browser an.


Hinzufügen eines Kontrollkästchens zu einem Formular

Fügen Sie Kontrollkästchen zu Ihrem Formular hinzu, wenn Sie möchten, dass ein Sitebesucher ein oder mehr Elemente oder gar kein Element auswählt. Klicken Sie zum Demonstrieren der Funktionsweise auf die nachfolgenden Kontrollkästchen.

Nach dem Ablegen eines Kontrollkästchens in Ihrem Formular weisen Sie diesem einen internen Namen zu. Ein interner Name wird nicht im Formular angezeigt, sondern identifiziert das Feld in den Formularergebnissen. Weisen Sie dem Kontrollkästchen einen Wert zu, und legen Sie fest, ob es standardmäßig aktiviert sein soll.

Wenn das Formular abgeschickt wird und das Kontrollkästchen im Formular aktiviert worden ist, sind der interne Name und der Wert des Kontrollkästchen in den Ergebnissen enthalten. Wenn das Kontrollkästchen nicht aktiviert worden ist, enthalten die Ergebnisse nur den internen Namen. Das Feld für den Wert ist dann leer.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie das Kontrollkästchen ablegen möchten. Zum Einfügen einer neuen Zeile können Sie die EINGABETASTE drücken.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird innerhalb des neuen Formulars eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Kontrollkästchen.
  3. Geben Sie die Beschriftung für das Kontrollkästchen direkt in das Formular ein.
  4. Doppelklicken Sie auf das Kontrollkästchen, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Name einen Namen ein, der das Kontrollkästchen identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  6. Geben Sie in das Feld Wert den Wert ein, den Sie dem Feld zuweisen möchten. Wenn das Kontrollkästchen aktiviert wird, wird dieser Wert in den Formularergebnissen ausgegeben und auf der Standardbestätigungsseite angezeigt.
  7. Klicken Sie unter Anfangszustand auf Aktiviert, wenn dieses Kontrollkästchen standardmäßig beim Öffnen des Formulars durch einen Sitebesucher aktiviert sein soll.

Tipp Wenn Sie für ein Kontrollkästchen eine Beschriftung erstellen, kann ein Sitebesucher das Kontrollkästchen durch Klicken auf das Kästchen oder auf den Begleittext aktivieren.


Hinzufügen eines Optionsfeldes zu einem Formular

Wenn Sie möchten, dass ein Sitebesucher eine Option aus einer Gruppe auswählen kann, fügen Sie Optionsfelder zu Ihrem Formular hinzu. Es kann immer nur ein Optionsfeld aus einer Gruppe ausgewählt werden. Klicken Sie auf die nachfolgenden Optionsfelder, um zu sehen, wie diese funktionieren.

Gruppe 1

 Gruppe 2

Nach dem Ablegen der Optionsfelder in Ihrem Formular weisen Sie jeder Optionsgruppe einen internen Namen und jedem einzelnen Optionsfeld einen Wert zu. Ein interner Name wird nicht im Formular angezeigt, er identifiziert jedoch die Optionsgruppe in den Formularergebnissen. Sie können für jede Optionsgruppe ein Optionsfeld festlegen, das standardmäßig ausgewählt werden soll.

Wenn das Formular abgeschickt wird, werden der Gruppenname und der dem ausgewählten Optionsfeld zugewiesene Wert zu den Formularergebnissen hinzugefügt. Wenn kein Optionsfeld ausgewählt ist, wird der Gruppenname hinzugefügt, das Feld für den Wert bleibt jedoch leer.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie das Optionsfeld ablegen möchten. Zum Einfügen einer neuen Zeile können Sie die EINGABETASTE drücken.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Optionsfeld.
  3. Geben Sie die Beschriftung für das Optionsfeld in das Formular ein.
  4. Doppelklicken Sie auf das Optionsfeld, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Gruppenname einen Namen ein, der die Optionsgruppe identifiziert, zu der das Optionsfeld gehört. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  6. Geben Sie in das Feld Wert den Wert ein, den Sie dem Feld zuweisen möchten. Wenn das Optionsfeld ausgewählt wird, wird dieser Wert in den Formularergebnissen ausgegeben und auf der Standardbestätigungsseite angezeigt.
  7. Klicken Sie unter Anfangszustand auf Ausgewählt, wenn das Optionsfeld standardmäßig beim Öffnen des Formulars durch einen Sitebesucher ausgewählt sein soll.

Wiederholen Sie dieses Verfahren für jedes Optionsfeld, das Sie zur Gruppe hinzufügen möchten.

Tipp Wenn Sie für ein Optionsfeld eine Beschriftung erstellen, kann ein Sitebesucher das Optionsfeld durch Klicken auf das Kästchen oder auf den Begleittext aktivieren.


Festlegen von Dateneingaberegeln für ein Optionsfeld

Sie können eine Dateneingaberegel (Gültigkeitsprüfung) festlegen, die fordert, dass ein Sitebesucher aus einer Optionsgruppe eine Auswahl trifft. Sie können z. B. eine Gruppe von Optionsfeldern verwenden, von denen keins standardmäßig ausgewählt ist. Wenn ein Sitebesucher versucht, das Formular abzuschicken, ohne eine Auswahl zu treffen, wird eine Meldung angezeigt. Wenn Sie eine Regel für ein Optionsfeld festlegen, gilt diese für alle Optionen in dieser Gruppe.

  1. Doppelklicken Sie in der Seitenansicht auf ein Optionsfeld in der Gruppe, für das Sie eine Regel festlegen möchten.
  2. Klicken Sie auf Gültigkeit.
  3. Um festzulegen, dass der Sitebesucher eines der Optionsfelder auswählen muss, wählen Sie Daten erforderlich.
  4. Geben Sie in das Feld Name der Gruppe einen Namen ein, der das Optionsfeld für den Sitebesucher identifiziert. Dieser Name wird dem Besucher in einer Meldung angezeigt, wenn er das Formular abschickt, ohne ein Optionsfeld aus dieser Gruppe ausgewählt zu haben. Der Sitebesucher erhält dann z. B. die Meldung „Bitte eine Option aus Name der Gruppe auswählen.“

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Hinzufügen einer benutzerdefinierten Schaltfläche zu einem Formular

Sie können eine benutzerdefinierte Schaltfläche zu einem Formular hinzufügen. Um dieser eine Aktion zuzuweisen, müssen Sie jedoch ein Skript erstellen oder schreiben. Sie können den HTML-Code so ändern, dass ein Skript eingefügt wird, oder ein Skript unter Verwendung des Skript-Assistenten erstellen.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie die Schaltfläche ablegen möchten. Zum Einfügen einer neuen Zeile können Sie die EINGABETASTE drücken.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird innerhalb des neuen Formulars eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Schaltfläche.
  3. Doppelklicken Sie auf die Schaltfläche, um deren Eigenschaften einzustellen.
  4. Geben Sie in das Feld Name einen Namen ein, der die Schaltfläche in den Formularergebnissen identifiziert.
  5. Geben Sie in das Feld Wert/Beschriftung den Text ein, der auf der Schaltfläche angezeigt wird.


Hinzufügen eines Dropdownmenüs zu einem Formular

Wenn Sie einem Sitebesucher erlauben möchten, Optionen aus einer Liste oder einem Menü auszuwählen, fügen Sie ein Dropdownmenü zu Ihrem Formular hinzu. Sie können die Eigenschaften des Menüs so einstellen, dass nur eine oder dass mehrere Auswahlen getroffen werden können. Klicken Sie auf die folgenden Dropdownmenüs, um deren Funktionsweise auszuprobieren.

Dieses Dropdownmenü erlaubt einem Sitebesucher, ein Element auszuwählen:

Dieses Dropdownmenü ist so groß, dass alle Auswahlen angezeigt werden und erlaubt dem Sitebesucher die Auswahl mehrerer Optionen:

Nach dem Ablegen eines Dropdownmenüs in Ihrem Formular weisen Sie diesem einen internen Namen zu und legen die Auswahl fest, die im Menü angezeigt werden sollen. Ein interner Name wird nicht im Formular angezeigt. Er identifiziert das Feld jedoch in den Formularergebnissen.

Wenn das Formular abgeschickt wird, wird der Name des Menüs gefolgt von einer Liste von Werten für die jeweiligen Auswahlen, zu den Formularergebnissen hinzugefügt.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie das Dropdownmenü einfügen möchten. Zum Hinzufügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Dropdownmenü.
  3. Geben Sie die Beschriftung für das Dropdownmenü direkt in das Formular ein.
  4. Doppelklicken Sie auf das Dropdownmenü, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Name einen Namen ein, der das Dropdownmenü identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  6. Fügen Sie die Optionen, die im Dropdownmenü angezeigt werden sollen, hinzu:
    • Klicken Sie auf Hinzufügen.
    • Geben Sie in das Feld Auswahl eine Option ein, die im Dropdownmenü angezeigt werden soll.
    • Wenn der Wert für diese Auswahl nicht mit dem im Dropdownfeld selbst angezeigten Wert identisch sein soll, wählen Sie Wert angeben und geben dann den Wert in das Feld ein. Eine Auswahl im Menü könnte z. B. Nein, der entsprechende Wert in den Formularergebnissen jedoch 2 lauten.
    • Klicken Sie unter Anfangszustand auf Ausgewählt, wenn diese Option standardmäßig beim Öffnen des Formulars durch einen Sitebesucher ausgewählt sein soll.
    • Klicken Sie auf OK.

    Wiederholen Sie diesen Schritt für jede Option, die Sie hinzufügen möchten.

    Sie können auch die Reihenfolge ändern, in der Optionen angezeigt werden. Dazu klicken Sie auf eine Option in der Liste und klicken dann auf eine der Schaltflächen Nach oben oder Nach unten.

  7. Geben Sie in das Feld Höhe ein, wie viele Textzeilen im Dropdownfeld angezeigt werden sollen. Wenn das Dropdownmenü z. B. drei Optionen enthält, können Sie für die Höhe den Wert 3 angeben, wenn alle 3 Optionen sichtbar sein sollen.
  8. Klicken Sie unter Mehrfachauswahl zulassen auf Ja, wenn Sie mehrere Auswahlen zulassen möchten. Wenn Sie auf Nein klicken, kann der Sitebesucher nur eine Auswahl treffen.


Festlegen von Dateneingaberegeln für ein Dropdownmenü

Sie können Dateneingaberegeln (Gültigkeitsüberprüfung) dafür festlegen, wie Sitebesucher Daten in ein Dropdownmenü eingeben sollen.

  • Sie können festlegen, dass Sitebesucher eine Auswahl treffen müssen. Wenn keine Auswahl getroffen wird, und ein Sitebesucher versucht, das Formular abzuschicken, wird eine Meldung angezeigt.
  • Sie können festlegen, dass das erste Element nicht ausgewählt werden darf, wenn dieses z. B. eine Anweisung, wie „Wählen Sie ein Element aus.“ ist.
  • Wenn das Dropdownmenü mehrere Auswahlen zulässt, können Sie eine Mindest- und eine Höchstzahl an Auswahlen definieren.
  1. Doppelklicken Sie in der Seitenansicht auf das Dropdownmenü für das Sie eine Gültigkeitsüberprüfung festlegen möchten.
  2. Klicken Sie auf Gültigkeit.
  3. Um festzulegen, dass ein Besucher in diesem Dropdownmenü eine Auswahl trifft, wählen Sie Daten erforderlich.
  4. Wenn für ein Dropdownmenü mehrere Auswahlen zugelassen sind, geben Sie zum Festlegen der Mindest- und Höchstzahl der zugelassenen Auswahlen Werte in die Felder Minimale Anzahl Elemente und Maximale Anzahl Elemente ein.
  5. Um zu verhindern, dass ein Sitebesucher das erste Element aus dem Dropdownmenü wählt, wählen Sie die Option Erstes Element nicht zulassen.
  6. Geben Sie in das Feld Anzuzeigender Name einen Namen ein, der das Dropdownmenü für den Sitebesucher identifiziert. Dieser Name wird in einer Meldung angezeigt, wenn der Besucher das Formular abschickt und die für das Dropdownmenü festgelegten Gültigkeitsregeln nicht erfüllt sind. Der Besucher sieht dann z. B. die Meldung „Bitte einen Wert für das Feld Anzuzeigender Name eingeben.“

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Hinzufügen eines einzeiligen Textfeldes zu einem Formular

Wenn Sie zulassen möchten, dass ein Sitebesucher eine Zeile mit Informationen eingibt, fügen Sie ein einzeiliges Textfeld zu Ihrem Formular hinzu. Geben Sie Text in das nachfolgende Textfeld ein, um zu sehen, wie dieses funktioniert.

Geben Sie Ihren vollständigen Namen ein:

Nach dem Hinzufügen eines einzeiligen Textfeldes zu Ihrem Formular weisen Sie diesem einen internen Namen zu. Ein interner Name wird nicht im Formular angezeigt, identifiziert das Feld jedoch in den Formularergebnissen.

Wenn das Formular abgeschickt wird, werden der Name und der Inhalt der Felder zu den Formularergebnissen hinzugefügt.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie das Textfeld ablegen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Einzeiliges Textfeld.
  3. Geben Sie die Beschriftung für das Textfeld direkt im Formular ein.
  4. Doppelklicken Sie auf das Textfeld, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Name einen Namen ein, der das Textfeld identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  6. Wenn direkt beim Öffnen des Formulars im Textfeld Text angezeigt werden soll, geben Sie den Text in das Feld Anfangswert ein.
  7. Geben Sie in das Feld Breite (in Zeichen) eine Zahl ein, die angibt, wie breit das Feld sein soll.


Hinzufügen eines Textfeldes mit Bildlauf zu einem Formular

Fügen Sie ein Textfeld mit Bildlauf zu Ihrem Formular hinzu, wenn Sie einem Sitebesucher erlauben möchten, mehrere Textzeilen einzugeben. Geben Sie in das nachfolgende Feld Text ein, um zu sehen, wie dies funktioniert.

Nach dem Hinzufügen eines Textfeldes mit Bildlauf zu Ihrem Formular weisen Sie diesem einen internen Namen zu und legen die Größe fest. Ein interner Name wird nicht im Formular angezeigt, er identifiziert das Feld in den Formularergebnissen.

Wenn das Formular abgeschickt wird, werden der Name und der Inhalt das Feldes zu den Formularergebnissen hinzugefügt.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie das Textfeld einfügen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Textfeld mit Bildlauf.
  3. Geben Sie die Beschriftung für das Textfeld direkt im Formular ein.
  4. Doppelklicken Sie auf das Textfeld, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Name einen Namen ein, der das Textfeld identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  6. Wenn direkt beim Öffnen des Formulars im Textfeld Text angezeigt werden soll, geben Sie den Text in das Feld Anfangswert ein.
  7. Geben Sie in das Feld Breite (in Zeichen) eine Zahl ein, die angibt, wie breit das Textfeld sein soll.
  8. Geben Sie in das Feld Anzahl Zeilen eine Zahl ein, die angibt, wie viele Textzeilen das Textfeld hoch sein soll.


Festlegen von Dateneingaberegeln für ein Textfeld

Sie können Dateneingaberegeln (Gültigkeitsprüfung) festlegen, die vorschreiben, wie ein Sitebesucher Daten in ein einzeiliges Textfeld oder ein Textfeld mit Bildlauf eingibt. Sie können folgendes festlegen:

  • Welcher Datentyp zugelassen ist (Text, Ganze Zahlen oder Zahlen) sowie das Format
  • Ob eine Eingabe in das Feld erfolgen muss
  • Die Mindest- und Höchstlänge des Eintrags
  • Bedingungen für die Daten

Sie können z. B. zum Abfragen der Telefonnummer eines Sitebesuchers ein einzeiliges Textfeld einrichten, dass nur Zahlen, Leerzeichen, Bindestriche und Klammern erlaubt.
Geben Sie Ihre Telefonnummer ein:

Zum Abfragen einer Kredikartennummer könnten Sie festlegen, dass nur Zahlen und in jedes Feld jeweils genau vier Zeichen eingegeben werden.
Geben Sie Ihre Kreditkartennummer ein: ---

  1. Doppelklicken Sie in der Seitenansicht auf das Textfeld, für das Sie Gültigkeitsregeln festlegen möchten.
  2. Klicken Sie auf Gültigkeit.
  3. Klicken Sie im Listenfeld Datentyp auf den Datentyp, den Sie für das Feld zulassen möchten: Keine Einschränkungen, Text, Ganze Zahl oder Zahl.
    • Wenn Sie die Daten auf Text beschränken, wählen Sie aus, welche Zeichen zugelassen sein sollen: Buchstaben, Ziffern, Leerraum (Leerzeichen, Tabs, Wagenrücklaufzeichen und Zeilenvorschübe) oder Andere (unterschiedliche Zeichen, wie z. B. Kommas und Bindestriche). Wenn Sie Andere wählen, geben Sie die Zeichen in das Feld ein.
    • Wenn Sie die Daten auf Werte vom Typ Ganze Zahl oder Nummer beschränken, geben Sie das Tausendertrennzeichen zum Gruppieren der Zahlen an. Sie können z. B. alle Satzzeichen deaktivieren und zum Gruppieren von Zahlen Punkte (wie in 123.456.789) oder Kommas (wie in 123,456,789) zulassen.
    • Wenn Sie die Daten auf Nummer beschränken, geben Sie das Dezimalzeichen an. Sie können für Gruppierung und Dezimal nicht dasselbe Zeichen verwenden.
  4. Um festzulegen, dass ein Sitebesucher, einen Wert in dieses Textfeld eingeben muss, wählen Sie Erforderlich.
  5. Um die Mindestzahl der im Textfeld zugelassenen Zeichen festzulegen, geben Sie einen Wert in das Feld Min. Länge ein.
  6. Um die Höchstzahl der im Textfeld zugelassenen Zeichen festzulegen, geben Sie einen Wert in das Feld Max. Länge ein.
  7. Um eine Werteinschränkung, wie z. B. eine Bedingung, die im Feld einen Wert größer 10 verlangt, festzulegen, wählen Sie Feld ist und klicken dann in der entsprechenden Liste auf die gewünschte Bedingung. Geben Sie in das Feld Wert einen Wert für die Einschränkung ein. Zum Festlegen einer zweiten Einschränkung wählen Sie Und und geben dann eine Bedingung und einen Wert an.

    8. Die Gültigkeitsregel verwendet nummerische Vergleiche, wenn es sich um Daten vom Datentyp Nummer oder Ganze Zahl handelt, und Vergleiche in alphabetischer Reihenfolge bei Daten vom Typ Text oder Keine Einschränkungen.

  8. Geben Sie in das Feld Namen anzeigen: einen Namen ein, der das Textfeld für den Sitebesucher identifiziert. Dieser Name wird in einer Meldung angezeigt, wenn der Besucher das Formular abschickt und die für das Textfeld festgelegten Gültigkeitsregeln nicht erfüllt sind. Der Besucher sieht dann z. B. die Meldung „Bitte einen Wert für das Feld Namen anzeigen: eingeben.“

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Hinzufügen einer Schaltfläche "Abschicken" zu einem Formular

Hinzufügen einer Schaltfläche „Abschicken“ zu einem Formular

Fügen Sie eine Schaltfläche Abschicken zum Formular hinzu, um dem Sitebesucher zu erlauben, ein Formular nach dem Ausfüllen abzuschicken. Wenn ein Formular abgeschickt wird, werden die Daten aus dem Formular an die Formularbehandlungsroutine gesendet. Dazu gehören auch der interne Name der Schaltfläche Abschicken und der Wert/die Beschriftung dieser Schaltfläche. Ein interner Name wird nicht im Formular angezeigt, sondern identifiziert das Feld in den Formularergebnissen.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie die Schaltfläche Abschicken ablegen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Schaltfläche.
  3. Doppelklicken Sie auf die Schaltfläche, um deren Eigenschaften einzustellen.
  4. Geben Sie in das Feld Name einen Namen ein, der die Schaltfläche identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  5. Klicken Sie unter Schaltflächentyp auf Abschicken.

    6. Der Beschriftungstext der Schaltfläche ändert sich standardmäßig in Abschicken. Sie können jedoch in das Feld Wert/Beschriftung auch eine andere Schaltflächenbeschriftung eingeben.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Hinzufügen einer Schaltfläche "Zurücksetzen" zu einem Formular

Hinzufügen einer Schaltfläche „Zurücksetzen“ zu einem Formular

Sie können eine Schaltfläche Zurücksetzen zu einem Formular hinzufügen, um einem Sitebesucher zu erlauben, die Standardeinstellungen des Formulars wiederherzustellen. Wenn Sie auf diese Schaltfläche klicken, werden Texte, die in Felder eingegeben worden sind, gelöscht und andere Auswahlen rückgängig gemacht. Wenn ein Feld jedoch standardmäßig Text enthält oder eine Option standardmäßig ausgewählt ist, werden beim Klicken auf die Schaltfläche Zurücksetzen diese Einstellungen wiederhergestellt.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie die Schaltfläche Zurücksetzen ablegen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Schaltfläche.
  3. Doppelklicken Sie auf die Schaltfläche, um deren Eigenschaften einzustellen.
  4. Geben Sie in das Feld Name einen Namen ein, der die Schaltfläche identifiziert. Dieser interne Name wird dem Benutzer auf der Standardbestätigungsseite angezeigt, die erscheint, wenn Sie zum Behandeln des Formulars an Stelle eines benutzerdefinierten Skripts eine Formularbehandlungsroutine verwenden.
  5. Klicken Sie unter Schaltflächentyp auf Zurücksetzen.

    6. Der Beschriftungstext der Schaltfläche ändert sich standardmäßig in Zurücksetzen. Sie können jedoch in das Feld Wert/Beschriftung auch eine andere Schaltflächenbeschriftung eingeben.


Hinzufügen eines verborgenen Feldes zu einem Formular

Zum Hinzufügen von Informationen zu den Formularergebnissen, die der Sitebesucher nicht sehen soll, fügen Sie verborgene Felder zu Ihrem Formular hinzu. Jedes verborgene Feld hat einen Namen und einen Wert. Wenn das Formular abgeschickt wird, werden die Namen und Werte verborgener Felder zusammen mit den Namen und Werten sichtbarer Felder zu den Formularergebnissen hinzugefügt.

Wenn Sie z. B. mehrere Formulare haben, die dieselbe Formularbehandlungsroutine verwenden, können Sie ein verborgenes Feld verwenden, um jedes Formular unter Verwendung eines eindeutigen Namens oder einer Nummer identifizieren zu können.

Anmerkung Die Standardbestätigungsseite zeigt verborgene Felder und deren Werte an. Wenn Sie verhindern möchten, dass der Sitebesucher diese Informationen sieht, erstellen Sie eine benutzerdefinierte Bestätigungsseite.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular und dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Erweitert.
  3. Klicken Sie auf Hinzufügen.
  4. Geben Sie in das Feld Name den Namen des verborgenen Feldes ein.
  5. Geben Sie in das Feld Wert den diesem Feld zugeordneten Wert ein. Dies kann ein beliebiger Text sein.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Ändern oder Entfernen eines verborgenen Feldes

Sie können verborgene Felder, die Sie zu einem Formular hinzugefügt haben, ändern oder entfernen. Verborgene Felder enthalten Informationen, die ein Sitebesucher in den Formularergebnissen nicht sehen soll.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular und dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Erweitert.
    • Zum Ändern eines verborgenen Feldes wählen Sie dieses aus der Liste aus und klicken dann auf Ändern. Bearbeiten Sie die Felder Name und Wert wie erforderlich, und klicken Sie dann auf OK.
    • Zum Entfernen eines verborgenen Feldes wählen Sie dieses aus der Liste und klicken Sie dann auf Entfernen.


Hinzufügen eines Kennwortfeldes zu einem Formular

Wenn Sie möchten, dass ein Sitebesucher zum Besuchen Ihrer Website ein Kennwort eingibt, fügen Sie ein Kennwortfeld zu Ihrem Registrierungsformular hinzu. Ein Kennwortfeld ist im Grunde nichts anderes als ein einzeiliges Textfeld. Wenn ein Sitebesucher Text in dieses eingibt, zeigen die meisten Webbrowser das Kennwort in Form von Sternchen an, um Geheimhaltung zu gewährleisten. Geben Sie etwas in das nachfolgende Kennwortfeld ein, um zu sehen, wie dieses funktioniert.

Geben Sie Ihr Kennwort ein:

Nach dem Ablegen des einzeiligen Textfeldes in Ihrem Formular weisen Sie diesem einen internen Namen zu. Ein interner Name wird nicht im Formular angezeigt, er identifiziert jedoch das Feld in den Formularergebnissen. Sie müssen das Textfeld darüber hinaus als Kennwortfeld kennzeichnen. Wenn das Formular abgeschickt wird, werden der Name und der Inhalt der Felder zu den Formularergebnissen hinzugefügt.

Anmerkung Ein Kennwortfeld wird nur überprüft, wenn Sie zum Behandeln der Formularergebnisse die Behandlungsroutine für Registrierungsformulare oder ein benutzerdefiniertes Skript verwenden.

  1. Klicken Sie in der Seitenansicht auf das Formular, in dem Sie ein Kennwortfeld ablegen möchten. Zum Einfügen einer neuen Zeile drücken Sie die EINGABETASTE.

    2. Anmerkung Wenn Sie ein Feld außerhalb eines Formulars ablegen, wird standardmäßig ein neuer Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen erstellt, und das Feld wird in das Formular eingefügt. Sie können diese Funktion deaktivieren, wenn Sie Felder mit Skripts und nicht Felder innerhalb von Formularen verwenden möchten.

  2. Zeigen Sie im Menü Einfügen auf Formular, und klicken Sie dann auf Einzeiliges Textfeld.
  3. Geben Sie die Beschriftung für das Kennwortfeld in das Formular ein.
  4. Doppelklicken Sie auf das Kennwortfeld, um dessen Eigenschaften einzustellen.
  5. Geben Sie in das Feld Name einen Namen ein, der das Kennwortfeld identifiziert.
  6. Geben Sie in das Feld Breite (in Zeichen) eine Zahl ein, die angibt, wie breit das Feld sein soll.
  7. Klicken Sie unter Kennwortfeld auf Ja.


Löschen eines Feldes aus einem Formular

Sie können bei Bedarf Felder aus einem Formular löschen.

  • Klicken Sie in der Seitenansicht auf das Feld, das Sie löschen möchten, und drücken Sie dann ENTFERNEN.


Erstellen einer auswählbaren Beschriftung für ein Feld in einem Formular

Sitebesucher können ein Kontrollkästchen oder Optionsfeld durch Klicken auf das Kästchen bzw. Feld aktivieren. Sie können jedoch auch eine auswählbare Beschriftung erstellen, die dem Sitebesucher erlaubt, die jeweilige Option auch durch Klicken auf den Beschriftungstext auszuwählen. Dies vereinfacht das Auswählen von Optionen und verbessert den Zugriff.

Es folgen zwei Kontrollkästchen. Neben dem ersten ist Text angezeigt, Sie können das Kontrollkästchen jedoch nur durch direktes Klicken auf das Kästchen aktivieren. Das zweite Kontrollkästchen kann durch Klicken auf das Kästchen oder die Beschriftung aktiviert werden.

Normale Beschriftung
  1. Geben Sie in der Seitenansicht neben dem Feld, für das Sie eine Beschriftung erstellen möchten, Text ein.
  2. Wählen Sie den Text und das Feld aus.
  3. Zeigen Sie im Menü Einfügen auf Formulare, und klicken Sie dann auf Beschriftung.

Anmerkung Dieses Funktionsmerkmal wird nur in Webbrowsern aktiviert, die Dynamisches HTML unterstützen, wie z. B. Microsoft Internet Explorer 4.0.


Festlegen einer Tastenkombination für ein Feld in einem Formular

Sie können für ein Feld in einem Formular eine Tastenkombination festlegen. Eine Tastenkombination erlaubt einem Sitebesucher das Auswählen eines Feldes in einem Formular unter Verwendung der Tastatur anstatt auf das Feld zu klicken. Die Tastenkombination wird in der Feldbeschriftung als unterstrichener Buchstabe angezeigt. Der Sitebesucher wählt das Feld durch Drücken der ALT-TASTE+ des unterstrichenen Buchstabens aus.

Um z. B. das nachstehende Feld auszuwählen, drücken Sie ALT+Z und dann die LEERTASTE.

Anmerkungen

  • Vor dem Festlegen einer Tastenkombination für ein Feld, müssen Sie eine Beschriftung für das Feld erstellen.
  • Dieses Funktionsmerkmal wird nur für Webbrowser aktiviert, die dynamisches HTML unterstützen, wie z. B. Microsoft Internet Explorer 4.0.
  1. Wählen Sie in der Seitenansicht einen Buchstaben aus der Beschriftung des Feldes aus.
  2. Klicken Sie auf Unterstreichen Schaltfläche "Unterstreichen",.


Festlegen der Aktivierreihenfolge in einem Formular

Sitebesucher können durch ein Formular navigieren: sie können durch Drücken der TAB-TASTE von einem Feld zu einem anderen gehen. Standardmäßig ist die Reihenfolge der Felder auf der Seite (von oben nach unten) die Reihenfolge, in der der Besucher sich durch Drücken der TAB-TASTE im Formular bewegen kann. Sie können jedoch auch eine andere Aktivierreihenfolge festlegen.

Anmerkung Nur Microsoft Internet Explorer 4.0 oder höher unterstützt eine benutzerdefinierte Aktivierreihenfolge. Andere Webbrowser und vorherige Versionen von Internet Explorer verwenden die Standard-Aktivierreihenfolge.

  1. Doppelklicken Sie in der Seitenansicht auf ein Feld, um dessen Eigenschaften zu bearbeiten.
  2. Geben Sie in das Feld Tab-Reihenfolge eine Zahl (1 - 999) ein, die die Aktivierreihenfolge für das ausgewählte Feld definiert. Wenn Sie für zwei oder mehr Felder dieselbe Zahl eingeben, kommt das erste dieser Felder auf der Seite in der Aktivierreihenfolge an erster Stelle. Um das Feld aus der Aktivierreihenfolge zu entfernen, geben Sie -1 ein.

Wiederholen Sie dieses Verfahren für jedes Feld, für das Sie die Aktivierreihenfolge festlegen möchten.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Ändern von Eigenschaften für ein Feld in einem Formular

Sie können Eigenschaften für Felder ändern:

  • Der Name des Feldes, wobei es sich um eine interne Referenz handelt, nicht um den Text, den Sie neben dem Feld in einem Formular anzeigen. Sie können z. B. den Standardnamen für ein einzeiliges Textfeld, T1, in Vorname ändern. Die Formularergebnisse enthalten diese Feldnamen.
  • Den Anfangswert oder -status des Feldes. Sie können z. B. den Text eingeben, der beim ersten Öffnen eines Formulars in einem Textfeld angezeigt wird, oder festlegen, ob eine Option standardmäßig ausgewählt ist oder nicht.
  • Der Wert des Feldes, der zusammen mit den Formularergebnissen zurückgegeben wird, wenn die Option ausgewählt wurde. Sie können z. B. den Standardwert für ein Optionsfeld, V1, in Ja ändern.
  • Die Position des Feldes in der Aktivierreihenfolge des Formulars.
  • Breite und Höhe eines Textfeldes.
  • Die Auswahl in einem Dropdownmenü.

Welche Eigenschaften Sie einstellen können, ist abhängig vom Typ des jeweiligen Feldes.

  1. Doppelklicken Sie in der Seitenansicht auf das Formularfeld.
  2. Ändern Sie die Einstellungen wie gewünscht.


Deaktivieren der automatischen Formularfunktionalität für Felder

Wenn Sie ein Formularfeld außerhalb eines Formularbereichs einfügen, erstellt Microsoft FrontPage standardmäßig einen Formularbereich mit den Schaltflächen Abschicken und Zurücksetzen und fügt dann das Feld innerhalb des Formulars ein. Wenn Sie Formularfelder in Skripten anstatt innerhalb von Formularen verwenden möchten, können Sie diese Funktion deaktivieren.

  1. Klicken Sie im Menü Extras auf Seitenoptionen.
  2. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Formularfelder automatisch mit einem Formular einfassen, um die automatische Formularerstellung zu deaktivieren.


Anzeigen der Ergebnisse eines Formulars

Sie können die Ergebnisse eines Formulars abhängig von der verwendeten Formularbehandlungsroutine unterschiedlich anzeigen. Sie können z. B. eine Text- oder eine HTML-Datei öffnen, oder die Ergebnisse anzeigen, die Sie per E-Mail-Nachricht erhalten haben.

Sie können auch die Ergebnisse eines Formulars anzeigen. Angenommen, Sie haben ein Formular, das als Gästebuch dient und die Ergebnisse in eine HTML-Datei speichert. Sie können diese Datei als Seite in Ihrer Website anzeigen, so dass andere Besucher diese ebenfalls sehen können.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.

    2. Das Dialogfeld Formulareigenschaften zeigt die Methode an, die Sie zum Speichern Ihrer Formularergebnisse verwenden.

  2. Wenn Sie Ihre Formularergebnisse in eine Datei speichern, notieren Sie sich den Namen und die Position der Datei, um diese öffnen zu können, oder um einen Hyperlink von einer anderen Seite zu dieser Datei herstellen zu können.


Festlegen der Informationen, die aus einem Formular zusammengestellt werden sollen

Sie können festlegen, welche Informationen Sie aus Ihrem Formular abrufen oder zusammenstellen möchten. Dazu wählen Sie die Felder aus, die in den Formularergebnissen angezeigt werden sollen. Darüber hinaus können Sie die folgenden Informationen einbeziehen:

  • Das Datum und die Zeit, an dem/zu der das Formular abgeschickt wurde
  • Den Namen oder die IP-Adresse des Computers des Sitebesuchers
  • Den Benutzernamen des Sitebesuchers
  • Den Typ des vom Sitebesucher verwendeten Webbrowsers
  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Optionen und dann auf die Registerkarte Gespeicherte Felder.

    3. Die Namen aller Felder im Formular sind im Listenfeld Zu speichernde Formularfelder aufgeführt.

    • Wählen Sie alle Felder aus, die Sie nicht in den Formularergebnissen speichern möchten, und drücken dann die ENTF-TASTE.
    • Zum Speichern des Datums oder der Zeit, an dem/zu dem das Formular mit den Ergebnissen abgeschickt wurde, wählen Sie aus den Listenfeldern Datumsformat und Uhrzeitformat die entsprechenden Formate aus.
    • Wählen Sie ggf. weitere Informationsarten aus, die Sie in den Formularergebnissen speichern möchten.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Speichern der Formularergebnisse unter Verwendung einer benutzerdefinierten Formularbehandlungsroutine

Sie können als Formularbehandlungsroutine ein eigenes, benutzerdefiniertes Skript (ISAPI, NSAPI oder CGI) verwenden. Dazu müssen auf Ihrem Webserver nicht die Microsoft FrontPage-Servererweiterungen installiert sein.

  1. Klicken Sie in der Ordneransicht mit der rechten Maustaste auf den Ordner, der Ihr Skript enthält, und klicken Sie dann im Kontextmenü auf Eigenschaften.
  2. Wählen Sie Ausführen von Skripts oder Programmen zulassen. Wenn Sie verhindern möchten, dass andere Benutzer die Dateien in diesem Verzeichnis sehen, deaktivieren Sie das Kontrollkästchen Durchsuchen von Dateien zulassen.
  3. Klicken Sie auf OK.
  4. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf Ihr Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  5. Klicken Sie auf Anderer Empfänger und dann in der Liste auf Benutzerdefiniertes ISAPI, NSAPI, CGI oder ASP-Skript.
  6. Klicken Sie auf Optionen.
  7. Geben Sie in das Feld Aktion den URL zur Formularbehandlungsroutine ein.
  8. Wählen Sie aus dem Feld Methode die Methode zum Abschicken von Informationen an die Formularbehandlungsroutine aus:
    • Die Methode GET codiert die Name/Wert-Paare des Formulars und weist der Servervariablen QUERY_STRING die Informationen zu.
    • Die Methode POST übergibt das Name/Wert-Paar als Eingabe direkt an die Behandlungsroutine für Formulare.
  9. Um die Standardcodierungsmethode application/x-www-form-urlencoded zu verwenden, lassen Sie das Feld Codierungstyp leer.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie die Vorschau in Ihrem Webbrowsers an. Dazu klicken Sie auf die Schaltfläche Vorschau in Browser Schaltfläche "Vorschau in Browser".


Speichern von Formularergebnissen in eine vorhandene Datenbank

Sie können Formularergebnisse (Daten, die ein Sitebesucher in Ihr Formular eingibt) in eine ODBC-kompatible Datenbank speichern. Wenn ein Sitebesucher ein Formular ausfüllt und abschickt, fügt Microsoft FrontPage die Daten direkt in Ihre Datenbank ein.

Vor dem Einrichten eines Formulars, dessen Ergebnisse in eine vorhandene Datenbank gespeichert werden sollen, müssen Sie eine Verbindung zur Datenbank einrichten:

  • Wenn eine Datenbank sich auf einem Webserver oder einem Netzwerkserver befindet, müssen Sie die Datenbank als System-DSN (System Data Source Name) einrichten. Zum Einrichten eines System-DSN verwenden Sie den ODBC-Datenquellen-Administrator.

    • Anschließend müssen Sie in FrontPage eine Datenbankverbindung zu dieser Datenbank einrichten. Zeigen Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Datenbank, und folgen Sie dann einem der folgenden Verfahren, beginnend bei Schritt 3:

    • Erstellen Sie eine neue Datenbankverbindung zu einer Datenquelle auf einem Webserver
    • Erstellen Sie eine neue Datenbankverbindung zu einem Datenbankserver in einem Netzwerk
  • Sie können die Datenbank in das aktuelle Web importieren und die Datenbankverbindung von FrontPage einrichten lassen. Kopieren Sie z. B. die Datenbankdatei aus dem Windows Explorer, und fügen Sie sie dann in der Ordneransicht in das aktuelle Web ein. Wenn FrontPage fragt, ob Sie eine Verbindung zu dieser Datenbank wünschen, geben Sie einen Namen für die Datenbank ein und klicken Sie dann auf Ja.
  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Datenbank.
  3. Klicken Sie auf Optionen.
  4. Wählen Sie auf der Registerkarte Datenbankergebnisse unter Datenbankverbindung benutzen die Datenbankverbindung für die Datenbank aus, die Sie verwenden möchten.
  5. Wählen Sie im Feld Tabelle für die Formularergebnisse die Tabelle aus, in der Sie die Formularergebnisdaten ablegen möchten.
  6. Klicken Sie auf die Registerkarte Gespeicherte Felder.

    7. Es werden alle Felder aus Ihrem Formular aufgelistet. Für jedes Feld müssen Sie die Spalte angeben, in der Sie die Daten speichern möchten. Sie können z. B. Telefonnummern Ihrer Sitebesucher im Feld namens Telefonnr. gesammelt haben und diese in der Spalte Telefon in Ihrer Datenbank speichern.

  7. Klicken Sie im Feld Zu speichernde Formularfelder auf ein Formularfeld und dann auf Ändern.
  8. Geben Sie im Feld Speichern in Datenbankfeld die Spalte an, in der Sie die Formularfelddaten speichern möchten, und klicken Sie dann auf OK. Die aufgelisteten Spalten entstammen der zuvor angegebenen Tabelle.

    9. Wiederholen Sie die Schritte 7 und 8 für jedes Formularfeld.

  9. Zum Speichern zusätzlicher Informationen (wie z. B. den Browsertyp des Sitebesuchers, den Namen des Remote-Computers, einen Zeitstempel oder den Benutzernamen) in Ihre Datenbank klicken Sie auf die Registerkarte Zusätzliche Felder und wiederholen die Schritte 7 und 8 für jedes zu speichernde Feld.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie die Vorschau in Ihrem Webbrowsers an. Dazu klicken Sie auf die Schaltfläche Vorschau in Browser Schaltfläche "Vorschau in Browser".


Senden von Formularergebnissen in einer E-Mail-Nachricht

Sie können Formularergebnisse (Daten, die ein Sitebesucher in Ihr Formular eingibt) in einer E-Mail-Nachricht senden. Jedes mal, wenn ein Sitebesucher ein Formular abschickt, werden die Ergebnisse des Formulars an die von Ihnen angegebene E-Mail-Adresse gesendet. Sie können für die Nachrichten auch andere Optionen konfigurieren, wie z. B. den Text für die Zeile Betreff und die Adresse für die Zeile Von (Antwort senden an).

Anmerkung Dieses Funktionsmerkmal wird nur unterstützt, wenn auf Ihrem Webserver die Microsoft FrontPage-Servererweiterungen installiert und korrekt für E-Mail konfiguriert sind. Wenn Sie Probleme mit diesem Funktionsmerkmal haben oder Fehlermeldungen erhalten, wenden Sie sich an den Server- oder Systemadministrator, um die Konfiguration ändern zu lassen.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Senden an.
  3. Geben Sie in das Feld E-Mail-Adresse die E-Mail-Adresse ein, an die die Formularergebnisse gesendet werden sollen.

    4. Anmerkung Wenn Sie nicht möchten, dass die Ergebnisse zusätzlich zum Versenden per E-Mail-Nachricht in eine Datei gespeichert werden, deaktivieren Sie das Kontrollkästchen Dateiname.

  4. Klicken Sie auf Optionen und dann auf die Registerkarte Ergebnisse per E-Mail versenden.

    5. Sie können Eigenschaften für die Ergebnis-E-Mail wie gewünscht einstellen, wie z. B. das Format des Texts und ob die Formularfeldnamen in die Ergebnisse einbezogen werden sollen.

  5. Geben Sie in das Feld Zeile "Betreff" den Text ein, der in der Zeile Betreff der E-Mail-Nachricht angezeigt werden soll. Wenn Sie dieses Feld leer lassen, lautet der Text in der Zeile Betreff standardmäßig „Formularergebnisse“.

    6. Wenn die Zeile Betreff der E-Mail-Nachricht die Ergebnisse aus einem Feld Ihres Formulars enthalten soll, wählen Sie Name des Formularfeldes und geben dann den Namen des Feldes in das Feld Zeile "Betreff" ein.

  6. Wenn Sie eine bestimmte E-Mail-Adresse als Absender der E-Mail-Nachricht (in der Zeile Von oder der Zeile Antwort senden an der E-Mail-Nachricht) angeben möchten, geben Sie diese Adresse in das Feld Zeile "Antworten senden an" ein.

    7. Wenn Ihr Formular jedoch ein Feld enthält, das die E-Mail-Adresse des Sitebesuchers anfordert, können Sie auch diese Adresse als Adresse des Absenders verwenden. Wählen Sie Name des Formularfeldes, und geben Sie dann in das Feld Zeile "Antworten senden an" den Namen des Formularfeldes ein.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Speichern von Formularergebnissen in eine Datei

Sie können die Formularergebnisse (Daten, die ein Sitebesucher in Ihr Formular eingibt) in eine Text- oder eine HTML-Datei speichern. Diese Datei befindet sich standardmäßig in _private, einem privaten Verzeichnis in Ihrem Web. Sie können diese Position und den Dateinamen bei Bedarf ändern. Sie können das Format der Textdatei auswählen und festlegen, ob die Feldnamen in die Formularergebnisse einbezogen werden sollen. Darüber hinaus können Sie eine zweite Datei angeben, in die Ergebnisse gespeichert werden sollen.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Senden an.

    3. Es werden der Standarddateiname und die Standardposition für die Ergebnisdatei angezeigt. Sie können den Dateinamen ändern. Dazu geben Sie den neuen Namen und die Position in das Feld Dateiname ein oder klicken auf Durchsuchen, um nach der Datei zu suchen.

  3. Klicken Sie auf Optionen und dann auf die Registerkarte Dateiergebnisse.
  4. Stellen Sie Eigenschaften für die Ergebnisdatei wie gewünscht ein.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie es durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Speichern von Formularergebnissen in eine neue Microsoft Access-Datenbank

Sie können Formularergebnisse (Daten, die ein Sitebesucher in Ihr Formular eingibt) in eine Datenbank speichern. Wenn ein Sitebesucher ein Formular ausfüllt und abschickt, fügt Microsoft FrontPage die Daten direkt in Ihre Datenbank ein.

Wenn Ihnen keine Datenbank zur Verfügung steht, um Formularergebnisse darin zu speichern, erstellt FrontPage eine neue Microsoft Access-Datenbank für Sie. FrontPage erstellt eine Tabelle unter Verwendung der Felder, die Sie bereits in Ihrem Formular als Spalten abgelegt haben.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  2. Klicken Sie auf Datenbank.
  3. Klicken Sie auf Optionen.
  4. Klicken Sie in der Registerkarte Datenbankergebnisse auf Datenbank erstellen.

    5. Nach dem Erstellen der Datenbank wird eine Bestätigungsmeldung angezeigt, die den Namen und die Adresse der Datenbank in Ihrem Web angibt. /_fpdb/FORMULAR.MDB gibt z. B. an, dass die Datenbank den Namen FORMULAR hat und sich im aktuellen Web im Ordner /fpdb befindet. FrontPage erstellt zum Ablegen der Datenbank standardmäßig den Ordner fpdb.

  5. Klicken Sie auf OK.

    6. FrontPage wählt automatisch die neue Datenbank als zu verwendende Datenbankverbindung und die Tabelle aus, in der die Formularergebnisse gespeichert werden sollen.

  6. Klicken Sie auf OK und dann erneut auf OK.

    7. Wenn die Erweiterung der aktuellen Seite .HTM lautet, fordert FrontPage Sie auf, die Dateierweiterung in .ASP umzubenennen, da die Datei sonst nicht ordnungsgemäß funktioniert.

Tipp Zum Überprüfen Ihres Formulars zeigen Sie die Vorschau in Ihrem Webbrowsers an. Dazu klicken Sie auf die Schaltfläche Vorschau in Browser Schaltfläche "Vorschau in Browser".


Info über Diskussionsgruppen

Um mehr über Diskussionsgruppen zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Festlegen von Eigenschaften für ein Diskussionsweb

Sie können für ein Diskussionsweb die folgenden Eigenschaften einstellen:

  • den Titel der Diskussionsgruppe,
  • das Diskussionswebverzeichnis, in dem Beiträge gespeichert werden sollen,
  • das Format für das Inhaltsverzeichnis,
  • ob die Farbe und das Hintergrunddesign einer anderen Seite in Ihrem Web verwendet werden sollen,
  • die Seiten, die in Beiträgen als Kopf und Fuß verwendet werden sollen,
  • ob Beiträge zusätzliche Informationen, wie z. B. Zeit und Datum enthalten sollen.
  1. Suchen Sie die Seite, die das Formular zum Bereitstellen von Beiträgen enthält, und öffnen Sie diese Seite. Wenn Sie den Diskussionsweb-Assistenten verwendet haben, enthält der Dateiname für diese Seite standardmäßig -post.
  2. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Formular, und klicken Sie dann im Kontextmenü auf Formulareigenschaften.
  3. Klicken Sie auf Optionen und dann auf die Registerkarte Diskussion.
  4. Stellen Sie die gewünschten Eigenschaften für die Diskussionsgruppe ein.
  5. Klicken Sie auf die Registerkarte Beitrag, und legen Sie dann Eigenschaften für Diskussionsbeiträge fest.


Verwalten von Diskussionsbeiträgen

Sie können die in einer Diskussionsgruppe bereitgestellten Beiträge verwalten. Sie können z. B. einen Beitrag, der beleidigende Sprache enthält, ändern.

  1. Klicken Sie im Menü Extras auf Webeinstellungen und dann auf die Registerkarte Erweitert.
  2. Wählen Sie die Option Dokumente in verborgenen Ordnern anzeigen.
  3. Klicken Sie auf OK.
  4. Klicken Sie auf Ja, um das Web zu aktualisieren.
  5. Klicken Sie auf Ansicht Ordner.
  6. Navigieren Sie zu dem Verzeichnis, das Sie für Diskussionsbeiträge festgelegt haben.

    7. Diskussionsbeiträge sind mit 0001.htm, 0002.htm usw. bezeichnet.

  7. Öffnen Sie die gewünschten Beiträge durch Doppelklicken auf den jeweiligen Dateinamen.
  8. Wenn Sie einen Beitrag mit beleidigendem Inhalt finden, löschen Sie diesen nicht. Geben Sie stattdessen eine Standardmeldung ein, die den Hauptteil des Beitrags ersetzt, wie z. B. „[Gelöschter Beitrag].“ Dadurch, das Sie die Meldung nicht löschen, bleiben Vorwärts- und Rückwärts-Hyperlinks zu anderen Beiträgen im Diskussionsfaden erhalten.


Erstellen einer Diskussionsgruppe

Erstellen Sie eine Diskussionsgruppe zum Einrichten eines Forums, in dem Sitebesucher miteinander kommunizieren können. Eine Diskussionsgruppe erlaubt Sitebesuchern das Bereitstellen und Beantworten von Beiträgen.

Am einfachsten erstellen Sie eine Diskussionsgruppe unter Verwendung des Diskussionsweb-Assistenten. Der Assistent fragt nach den Funktionen, die Sie verwenden möchten, erstellt ein Web und richtet Seiten für Sie ein. Nach dem Erstellen des Webs öffnen Sie die Seiten und passen sie an.

Wenn Ihr Diskussionsweb geschützt ist, können Sie Sitebesucher registrieren. Der Assistent erstellt ein Registrierungsformular für Sie. Sie müssen diese Seite öffnen, das Formular wie gewünscht anpassen und es dann im Stammweb speichern, in dem sich auch die Diskussionsgruppe befindet. Anschließend stellen Sie die Seite Besuchern zur Verfügung.

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Web.
  2. Klicken Sie in der Registerkarte Website auf Diskussionsweb-Assistent.
  3. Geben Sie in das Feld Geben Sie der Website einen Titel einen Namen für das neue Web ein, und klicken Sie dann auf OK.

    4. Der Diskussionsweb-Assistent wird geöffnet. Folgen Sie zum Erstellen einer Diskussionsgruppe den Anweisungen, die auf dem Bildschirm angezeigt werden.

Nachdem der Assistent Ihre Webseiten erstellt hat, können Sie diese beliebig anpassen. Wenn Ihre Diskussionsgruppe z. B. Kategorien hat, öffnen Sie die Seite zum Bereitstellen von Beiträgen und ändern die Auswahlen, die der Assistent für Sie im Kategorien-Dropdownmenü getroffen hat.

Tipp Zum Überprüfen Ihrer Diskussionsgruppe, zeigen Sie diese durch Klicken auf Vorschau in Browser Schaltfläche "Vorschau in Browser" in Ihrem Browser an.


Begrenzen einer Suche auf ein bestimmtes Diskussionsweb

Sie können ein Suchformular erstellen, mit dem ein Sitebesucher ein bestimmtes Diskussionsweb nach bestimmten Wörtern oder Begriffen durchsuchen kann. Wenn der Server den Suchtext im Textindex des angegebenen Diskussionswebs findet, dann sieht der Besucher eine gewichtete Liste von Hyperlinks auf die Seiten, die den Suchtext enthalten.

Für WAIS:

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Suchformular, das Sie formatieren möchten, klicken Sie im Kontextmenü auf Suchformulareigenschaften, und klicken Sie dann auf die Registerkarte Suchergebnisse.
  2. Geben Sie im Feld Zu durchsuchende Wortliste den Namen eines Diskussionsgruppen-Ordners ein, um die Suche auf diesen Ordner zu begrenzen.

Für Index Server:

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Suchformular, das Sie formatieren möchten, klicken Sie im Kontextmenü auf Suchformulareigenschaften, und klicken Sie dann auf die Registerkarte Suchergebnisse.
  2. Klicken Sie im Abschnitt Umfang der Suche auf Ordner, und geben Sie anschließend den Namen des Ordners ein, der das Diskussionsweb enthält, und auf den Sie die Suche begrenzen möchten.


Arbeiten mit Datenbanken

Um mehr über Datenbanken zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten

Bevor Sie den Datenbankergebnis-Assistenten ausführen, sollten Sie den Namen und den Typ der Datenbank festlegen, auf die Sie zugreifen möchten (z. B. eine Microsoft Access-Datenbank mit dem Namen Nordwind.mdb), sowie den Speicherort der Datenbank (z. B. im aktuellen Web, auf einem Datenbankserver usw.). Wenn Sie planen, eine Access-Datenbank zu verwenden, die Sie zum aktuellen Web hinzufügen möchten, importieren Sie diese Datenbank in das Web, bevor Sie den Assistenten ausführen. FrontPage erstellt automatisch eine Datenbankverbindung für die importierte Datenbank.

Nach Ausführung des Assistenten können Sie die Datenbankergebnisse ändern (z. B. die Sortierreihenfolge ändern oder ein anderes Feld aus der Datenbank hinzufügen), indem Sie den Assistent erneut aufrufen. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf den Datenbankergebnisbereich, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse. Der Assistent merkt sich Ihre Einstellungen, um zum Schritt des Assistenten zu springen, der die Einstellungen enthält, die Sie ändern möchten, klicken Sie auf Weiter.

Tipp FrontPage enthält eine Datenbank mit Namen Nordwind GmbH, die Sie verwenden können, um mit dem Datenbankergebnis-Assistenten Seiten zu erstellen, die sich auf Datenbanken beziehen. Wenn Sie noch nie eine Datenbank benutzt haben oder wenn Sie mit dem Erstellen von Seiten experimentieren möchten, die Daten eingeben, ohne dass Sie Ihre eigene „Live“-Datenbank ändern müssen, klicken Sie unter Schritt 1 weiter unten auf Verwenden einer Beispieldatenbankverbindung.

1. Verbinden Sie sich mit einer Datenbank

Verwenden einer Beispieldatenbankverbindung

Verwenden einer bestehenden Datenbankverbindung

Erstellen einer neuen Datenbankverbindung zu einer Datei oder einem Ordner im aktuellen Web

Erstellen einer neuen Datenbankverbindung mit einem System-DSN auf einem Webserver

Erstellen einer neuen Datenbankverbindung zu einem Datenbankserver in einem Netzwerk

Erstellen einer neuen Datenbankverbindung mithilfe einer benutzereigenen Definition

Einrichten oder Ändern von erweiterten Eigenschaften einer Datenbankverbindung

2. Wählen Sie eine Datenquelle aus, oder erstellen Sie eine benutzerdefinierte Abfrage

Auswählen einer Datensatzquelle aus einer Datenbank

Erstellen einer benutzerdefinierten Abfrage

3. Wählen Sie die anzuzeigenden Felder aus, und legen Sie erweiterte Optionen fest

Bearbeiten der Liste von Feldern, die in Datenbankergebnissen eingeschlossen werden sollen

Festlegen von Kriterien für das Filtern von Datenbankergebnissen

Auswählen der Felder eines Suchformulars

Festlegen der Sortierreihenfolge von Datenbankergebnissen

Bereitstellen von Standardwerten für Eingabeparameter

Einschränken der Anzahl zurückgegebener Datensätze

Erstellen einer Meldung, die anzuzeigen ist, wenn keine Datensätze zurückgegeben werden

4. Wählen Sie Optionen für die Formatierung der Datenbankergebnisse aus

Formatieren von Datenbankergebnissen als Tabelle

Formatieren von Datenbankergebnissen als Liste

Formatieren von Datenbankergebnissen als Dropdownliste

5. Zeigen Sie Datensätze zusammen an, oder teilen Sie diese in kleinere Gruppen auf

Anzeigen aller Datensätze zusammen oder Aufteilen der Datensätze in kleinere Gruppen

Hinzufügen eines Suchformulars


Ändern einer bestehenden Datenbankverbindung

Wenn die Datenbank, auf die eine Datenbankverbindung ursprünglich gezeigt hat, verschoben oder gelöscht worden ist, können sie mithilfe dieses Verfahrens die Datenbankverbindung auf eine andere Datenbank, einen anderen Speicherort oder Server richten. Sie können auch den Benutzernamen, das Kennwort oder irgendeine andere Eigenschaft der Verbindung mit Ausnahme ihres Namens ändern.

Anmerkung Wenn Sie den Speicherort oder die Datenquelle für eine bestehende Datenbankverbindung ändern, können die Seiten, die Datenbankergebnisse über diese Datenbankverbindung enthalten, Fehler anzeigen, wenn sie von einem Sitebesucher mithilfe eines Browsers angezeigt werden. Sie sollten entweder die Datenbankergebnisbereiche aus diesen Seiten löschen oder den Datenbankergebnis-Assistenten erneut aufrufen, um die betroffenen Bereiche zu aktualisieren.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Datenbank.
  2. Klicken Sie auf die Datenbankverbindung, die Sie ändern möchten, und klicken Sie dann auf Ändern.
  3. Führen Sie unter Lage der Datenbank folgende Schritte aus:
    • Um die Verbindung mit einer anderen Datei oder einem anderen Ordner im aktuellen Web herzustellen, klicken Sie auf Datei oder Ordner im aktuellen Web, klicken Sie auf Durchsuchen, und markieren Sie dann eine Datenbankdatei oder einen Datenbankordner.
    • Um die Verbindung mit einem anderen Systemdatenquellennamen (System-DSN) auf einem Webserver herzustellen, klicken Sie auf Datenquelle auf Webserver, klicken Sie auf Durchsuchen, und markieren Sie dann den System-DSN der Datenbank, auf die Sie zugreifen möchten.
    • Um die Verbindung mit einem anderen Datenbankserver in einem Netzwerk herzustellen, klicken Sie auf Anderer Datenbankserver im Netzwerk, klicken Sie auf Durchsuchen, und geben Sie dann den Typ der Datenbank, den Servernamen und den Datenbanknamen an, auf die Sie zugreifen möchten.

      • Anmerkung Sie müssen keinen Datenbanknamen eingeben, um sich mit einem Oracle-Datenbankserver zu verbinden.

    • Um die Verbindung mit einer anderen Datenbank mittels einer benutzereigenen Definition herzustellen, klicken Sie auf Benutzereigene Definition, klicken Sie auf Durchsuchen, und markieren Sie dann einen Dateidatenquellennamen (Datei-DSN) oder eine UDL-Datei (Universal Data Link) im Web. Oder, um eine benutzerdefinierte Verbindungzeichenfolge einzugeben, klicken Sie auf Benutzereigene Definition, klicken Sie auf Erweitert, und geben Sie dann die Verbindungszeichenfolge ein.


Entfernen einer Datenbankverbindung

Wenden Sie dieses Verfahren an, um eine bestehende Datenbankverbindung aus dem aktuellen Web zu entfernen.

Anmerkung Wenn Sie eine Datenbankverbindung aus einem Web entfernen, werden alle Seiten, die Datenbankergebnisbereiche für die gelöschte Datenbankverbindung enthalten, Fehlermeldungen anzeigen, wenn diese von einem Sitebesucher in einem Browser betrachtet werden. Sie sollten entweder die Datenbankergebnisbereiche aus den Seiten entfernen oder den Datenbankergebnis-Assistenten erneut ausführen, um die jeweiligen Bereiche mit einer anderen Datenbankverbindung zu verknüpfen.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Datenbank.
  2. Klicken Sie auf die Datenbankverbindung, die Sie entfernen möchten, und klicken Sie dann auf Entfernen.


Überprüfen einer Datenbankverbindung

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Datenbank.

    2. In der Liste der Datenbankverbindungen enthält die Spalte Status ein Fragezeichen (?), wenn die Verbindung noch nicht überprüft worden ist.

  2. Klicken Sie auf die Datenbankverbindung, die Sie überprüfen möchten, und klicken Sie dann auf Verifizieren.

Anmerkungen

  • Wenn FrontPage die Datenbankverbindung erfolgreich überprüft hat, wird das Fragezeichen in der Spalte Status in ein Häkchen geändert.
  • Wenn die Prüfung nicht erfolgreich verlaufen ist, klicken Sie auf Ändern, und passen Sie die Eigenschaften der Datenbankverbindung an.


Verwenden einer Access-Datenbank in einem Web

Microsoft FrontPage macht es Ihnen leicht, Informationen aus einer Microsoft Access-Datenbank in Ihrem Web zu verwenden. Sie können eine Access-Datenbank in Ihr Web importieren, oder Sie können sich mit einer Access-Datenbank verbinden, die als System-DSN (System Data Source Name, System-Datenquellenname) auf einem anderen Server definiert ist. Sie können dann mithilfe des Datenbankergebnis-Assistenten Informationen aus der Access-Datenbank auf den Seiten Ihres Webs anzeigen.

  • Um eine Access-Datenbank in ein Web zu importieren, kopieren Sie im Windows-Explorer die Access-Datenbankdatei (.mdb), die Sie importieren möchten, in die Zwischenablage, und fügen Sie dann die Datei in der Ordnerliste von FrontPage ein. FrontPage fragt Sie, ob Sie eine neue Datenbankverbindung erstellen möchten, und fordert Sie auf, einen Namen für die neue Verbindung einzugeben. Um die Informationen aus dieser Datenbank auf einer Seite anzuzeigen, führen Sie den Datenbankergebnis-Assistenten aus (zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse).
  • Wenn Sie eine Access-Datenbank in Ihr Web importieren, erstellt FrontPage einen Ordner mit dem Namen Fpdb und den Berechtigungen, dass der Ordner nicht in einem Webbrowser angezeigt werden kann. Um die Privatsphäre einer Datenbank zu schützen, verschieben Sie diese in den Fpdb-Ordner.
  • Um eine Access-Datenbank zu verwenden, die als System-DSN auf einem Webserver definiert ist, erstellen Sie eine neue Datenbankverbindung mit dem System-DSN auf dem Webserver.


Verwenden einer Excel-Datenbank in einem Web

Microsoft FrontPage macht es Ihnen leicht, Informationen aus einer Microsoft Excel-Datenbank in einem Web zu verwenden. Eine Excel-Datenbank ist ein Zellenbereich in einer Tabellenkalkulation, die als Datenbanktabelle definiert worden ist und einen Namen erhalten hat. Sie können eine Excel-Datenbank in ein Web importieren, oder Sie können sich mit einer Excel-Datenbank verbinden, die als System-Datenquellenname (System-DSN) auf einem Webserver definiert worden ist. Sie können dann mithilfe des Datenbankergebnis-Assistenten die Informationen aus der Excel-Datenbank auf den Seiten Ihres Webs anzeigen.

  • Um eine Excel-Datenbank in Ihr Web zu importieren, klicken Sie im Menü Datei auf Importieren, klicken Sie auf Datei hinzufügen, und wählen Sie dann die Datei, welche die Excel-Datenbank enthält, die Sie importieren möchten, aus.
  • Um die Ergebnisse aus einer Excel-Datenbank im aktuellen Web anzuzeigen, erstellen Sie eine neue Datenbankverbindung mit der Datei, welche die Excel-Datenbank enthält.
  • Um Ergebnisse aus einer Excel-Datenbank anzuzeigen, die auf einem anderen Server gespeichert ist, erstellen Sie eine neue Datenbankverbindung zum System-DSN auf dem Webserver.

Tipp Um eine Datenbanktabelle in einem Excel-Kalkulationsblatt zu definieren, markieren Sie einen Zellenbereich, zeigen Sie im Menü Einfügen auf Name, klicken Sie auf Definieren, und geben Sie dann einen Namen ein.


Erstellen einer Datenbankverbindung

Um Informationen aus einer Datenbank oder die Eingabe in eine Datenbank anzuzeigen, benutzt FrontPage eine Datenbankverbindung. Diese nennt den Namen, Speicherort und den Typ der Datenbank, auf die Sie zugreifen möchten.

Wenn Sie Informationen aus einer Datenbank Ihren Seiten mithilfe des Datenbankergebnis-Assistenten hinzufügen, können Sie in Schritt 1 des Assistenten eine bestehende Datenbankverbindung auswählen oder eine neue erstellen.

Sie können auch eine Datenbankverbindung ohne Hilfe des Datenbankergebnis-Assistenten wie folgt erstellen oder ändern:

  • Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Datenbank:
    • Um eine neue Datenbankverbindung zu erstellen, klicken Sie auf Hinzufügen, und befolgen Sie dann das entsprechende Verfahren, um eine neue Datenbankverbindung mit einer Datei oder einem Ordner im aktuellen Web zu erstellen, eine neue Datenbankverbindung mit einem System-DSN auf einem Webserver zu erstellen, eine neue Datenbankverbindung mit einem Datenbankserver in einem Netzwerk zu erstellen oder eine neue Datenbankverbindung mit einer benutzereigenen Definition zu erstellen.
    • Um eine bestehende Datenbankverbindung zu ändern, markieren Sie diese Verbindung in der Liste, klicken Sie auf Ändern, und befolgen Sie dann das Verfahren, um eine bestehende Datenbankverbindung zu ändern.


Importieren einer Datenbank

Sie können leicht eine Microsoft Access-Datenbank oder eine andere Datenbankdatei in das aktuelle Web importieren. Mithilfe des Datenbankergebnis-Assistenten können Sie dann Informationen aus der Datenbank auf den Seiten eines Webs anzeigen.

  • Um eine Datenbank in ein Web zu importieren, kopieren Sie mit dem Windows-Explorer die Datenbankdatei, die Sie importieren möchten, in die Zwischenablage, und fügen Sie die Datei dann in FrontPage in die Ordnerliste ein. FrontPage fragt, ob Sie eine neue Datenbankverbindung erstellen möchten, und fordert Sie dann auf, einen Namen für die neue Verbindung einzugeben.
  • Um Informationen aus der importierten Datenbank auf einer Seite anzuzeigen, führen Sie den Datenbankergebnis-Assistenten aus (zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse).
  • Wenn Sie eine Access-Datenbank in ein Web importieren, erstellt FrontPage einen Ordner mit dem Namen Fpdb und der Berechtigungsangabe, dass der Ordner nicht in einem Webbrowser angezeigt werden kann. Möchten Sie die Privatsphäre einer Datenbank schützen, verschieben Sie diese in den Fpdb-Ordner.


Erstellen eines Hyperlinks in einer Liste von Datenbankergebnissen

Sie können mithilfe eines Hyperlinks Eingabeparameter an eine Abfrage in einem Datenbankergebnisbereich übergeben. So können Sie zum Beispiel über den Datenbankergebnis-Assistenten leicht eine Seite erstellen, welche die Adressbuchdatenbank eines Unternehmens durchsucht und eine Liste von Namen, E-Mail-Adressen und Telefonnummern von jedem Mitglied einer Arbeitsgruppe anzeigt. Sie können dann einen Hyperlink auf jeden Namen in der Liste erstellen, über den ausführliche Informationen über die ausgewählte Person in einem anderen Datenbankergebnisbereich angezeigt werden.

Wenn ein Sitebesucher auf einen Namen in der Liste klickt, sendet der Hyperlink mithilfe seiner Parameter den Wert dieses Feldes an die Seite, auf welche der Hyperlink zeigt. Diese Seite kann dann den Wert in einer anderen Datenbankabfrage verwenden oder an einen Einkaufskorb senden und so weiter.

Anmerkung Sie können keinen Hyperlink in einem Datenbankergebnisbereich erstellen, der als Dropdownliste formatiert ist.

  1. Erstellen oder öffnen Sie in der Seitenansicht eine Seite, die einen als Tabelle oder Liste formatierten Datenbankergebnisbereich enthält.
  2. Markieren Sie das Feld, welches den Wert enthält, den Sie als Parameter übergeben möchten, und klicken Sie dann auf Hyperlink Schaltfläche "Hyperlink".
  3. Geben Sie im Dialogfeld Hyperlink erstellen den URL ein, oder markieren Sie die Seite, welche die Datenbankergebnisse anzeigen soll, klicken Sie auf Parameter, und klicken Sie dann auf Hinzufügen.
  4. Geben Sie im Feld Name den Namen des Feldes ein, das den als Parameter zu übergebenden Wert enthält, oder wählen Sie den Namen aus.

    5. Markieren Sie zum Beispiel Nachname, um den Wert des Feldes Nachname (zum Beispiel „Smith“) als Parameter an eine andere Seite zu übergeben.

    Anmerkung Das Feld Wert zeigt einen VBScript-Funktionsaufruf an, der den Wert des aktuellen Datensatzes ermittelt. Um diesen Funktionsaufruf durch einen konstanten Wert zu ersetzen (um zum Beispiel immer den Wert „Seattle“ für das Feld Ort zu übermitteln), geben Sie diesen Wert im Feld Wert ein.


Ändern der Bezeichnungen von Feldern, die in den Datenbankergebnissen angezeigt werden

Wenn Sie mithilfe des Datenbankergebnis-Assistenten eine Tabelle oder Liste mit Datenbankergebnissen auf einer Seite erstellt haben, können Sie die Feldbezeichnungen ändern, um „benutzerfreundliche“ Namen anstelle der Feldnamen aus der Datenbank zu verwenden. In einem als Tabelle formatierten Datenbankergebnisbereich werden die Feldbezeichnungen in Fettschrift oberhalb jeder Spalte angezeigt. Ist der Datenbankergebnisbereich als Liste formatiert, werden die Feldbezeichnungen in Fettschrift links vom Feldwert angezeigt.

  • Markieren Sie in der Seitenansicht die Feldbezeichnung, die Sie ändern möchten, und geben Sie dann eine andere Bezeichnung ein.


Ändern der in Datenbankergebnissen angezeigten Felder

Wenn Sie mithilfe des Datenbankergebnis-Assistenten eine Tabelle oder Liste mit Datenbankergebnissen auf einer Seite erstellt haben, können Sie die Auswahl der angezeigten Felder ändern, ohne den Assistenten erneut aufzurufen.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf das Feld, das Sie ändern möchten, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbank-Spaltenwert.
  2. Markieren Sie im Feld Anzuzeigende Spalte ein anderes Feld, das im Datenbankergebnisbereich anzuzeigen ist.


Arbeiten mit HTML

Um mehr über HTML zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Anzeigen oder Ausblenden der Farbcodierung von HTML

Wenn Sie eine Seite mithilfe der Registerkarte HTML in der Seitenansicht bearbeiten, codiert Microsoft FrontPage die gesamte HTML-Syntax farbig, um zwischen Tags, Attributen und Werten sowie Kommentaren und Skripten zu unterscheiden.

  • Klicken Sie zum Anzeigen der Farbcodierung mit der rechten Maustaste an beliebiger Stelle auf die Registerkarte HTML, und klicken Sie dann im Kontextmenü auf Farbcodierung anzeigen.
  • Um die Farbcodierung wieder auszublenden, nachdem der Befehl Farbcodierung anzeigen aktiviert wurde, klicken Sie erneut auf Farbcodierung anzeigen, um das Häkchen zu entfernen.

Tipp Wenn Sie die Farben ändern möchten, die FrontPage zum Anzeigen von HTML-Code verwendet, klicken Sie im Menü Extras auf Seitenoptionen, klicken Sie auf die Registerkarte Farbcodierung, und wählen Sie nun die Farben aus, die Sie verwenden möchten.


Bearbeiten des HTML-Codes einer Seite

Wenn Sie eine Seite auf der Registerkarte Normal in der Seitenansicht bearbeiten, können Sie auf die Registerkarte HTML wechseln, um den HTML-Code dieser Seite direkt zu bearbeiten. Sie können HTML-Code manuell eingeben, oder Sie können die Menübefehle, Eigenschaftendialogfelder und andere Werkzeuge in Microsoft FrontPage verwenden, um auf diese Weise Hilfe beim Erstellen und Bearbeiten von HTML-Code zu erhalten.

  • Zum Bearbeiten des HTML-Codes einer in der Seitenansicht geöffneten Seite klicken Sie auf die Registerkarte HTML, oder drücken Sie STRG+BILD-AUF (oder STRG+BILD-AB), um die Registerkarte HTML auszuwählen.
  • Zum Bearbeiten des HTML-Codes einer in der Seitenansicht geöffneten Framesseite klicken Sie auf die Registerkarte HTML der Framesseite.
  • Wenn Sie den HTML-Code einer offenen Seite bearbeiten möchten, die im Frame einer Framesseite angezeigt wird, klicken Sie auf die Seite und klicken Sie dann auf die Registerkarte HTML.


Suchen und Ersetzen von Text auf der Registerkarte "HTML" in der Seitenansicht

Suchen und Ersetzen von Text auf der Registerkarte „HTML“ in der Seitenansicht

Wenn Sie den HTML-Code einer Seite auf der Registerkarte HTML in der Seitenansicht bearbeiten, können Sie Text in Tags, Attributen, Werten, Kommentaren und Skripten suchen und ersetzen.

  1. Klicken Sie im Menü Bearbeiten auf Suchen oder Ersetzen.
  2. Geben Sie im Feld Suchen nach den Text ein, den Sie im HTML-Code suchen oder ersetzen möchten. Wenn Sie Text ersetzen möchten, geben Sie den Ersatztext in das Feld Ersetzen durch ein.
  3. Legen Sie die anderen Optionen zum Suchen und Ersetzen fest:
    • Klicken Sie auf Nach oben oder Nach unten, um die Suchrichtung relativ zur Position der Einfügemarke auf der Registerkarte HTML anzugeben.
    • Wenn Sie nur ein komplettes Wort suchen oder ersetzen möchten, das dem Text im Feld Suchen nach entspricht, oder wenn die Groß-/Kleinschreibung des Textes im Feld Suchen nach beachtet werden soll, aktivieren Sie die Kontrollkästchen Nur ganzes Wort suchen oder Groß-/Kleinschreibung beachten.
  4. Klicken Sie auf Weitersuchen, um das erste Vorkommen des Suchtextes zu finden.

    5. Microsoft FrontPage hebt das erste Vorkommen des Textes hervor.

  5. Klicken Sie auf Weitersuchen, um das nächste Vorkommen zu finden, auf Ersetzen, wenn Sie dieses Vorkommen ersetzen und das nächste finden möchten, oder auf Alles Ersetzen, um alle Vorkommen auf der offenen Seite zu ersetzen.

Tipp Wenn Sie ausgewählte Seiten oder alle Seiten in Ihrem Web durchsuchen möchten, können Sie auch Text im HTML-Code eines Webs suchen und ersetzen.


Suchen und Ersetzen von Text im HTML-Code eines Webs

Sie können Text in Tags, Attributen, Werten, Kommentaren und Skripten in HTML suchen und ersetzen. Wenn irgendwelche Seiten in der Seitenansicht geöffnet sind, speichern Sie diese, damit die jeweils aktuellste Version der Seite oder des Webs durchsucht wird.

Wenn Sie Text in HTML nur auf ausgewählten Seiten Ihres Webs suchen und ersetzen möchten, wechseln Sie zur Ordneransicht, und wählen Sie hier die Seiten aus der Dateiliste aus, bevor Sie fortfahren.

  1. Klicken Sie im Menü Bearbeiten auf Suchen oder Ersetzen.
  2. Geben Sie im Feld Suchen nach den Text ein, den Sie im HTML-Code suchen oder ersetzen möchten. Wenn Sie Text ersetzen möchten, geben Sie den Ersatztext in das Feld Ersetzen durch ein.
  3. Legen Sie den Bereich der Suchen- oder Ersetzenoperation fest:
    • Klicken Sie auf Alle Seiten, wenn Sie Text auf jeder Seite Ihres Webs suchen oder ersetzen möchten.
    • Klicken Sie auf Ausgewählte Seiten, wenn Sie nur auf den Seiten Text suchen oder ersetzen möchten, die Sie in der Ordneransicht ausgewählt haben.
  4. Legen Sie die anderen Optionen zum Suchen oder Ersetzen fest:
    • Klicken Sie auf Nach oben oder Nach unten, um die Suchrichtung anzugeben.
    • Wenn Sie nur ein komplettes Wort suchen oder ersetzen möchten, das dem Text im Feld Suchen nach entspricht, oder wenn die Groß-/Kleinschreibung des Textes im Feld Suchen nach beachtet werden soll, aktivieren Sie die Kontrollkästchen Nur ganzes Wort suchen oder Groß-/Kleinschreibung beachten.
  5. Aktivieren Sie das Kontrollkästchen In HTML suchen, und klicken Sie dann auf Weitersuchen (für ausgewählte Seiten) oder auf Im Web suchen (für ein komplettes Web), um das erste Vorkommen des Suchtextes zu finden.

    6. Im unteren Bereich des Dialogfelds führt Microsoft FrontPage jede Seite auf, die den Suchtext enthält, sowie die Anzahl der Vorkommen des Suchtextes auf jeder Seite.

    • Wenn Sie der Liste der Aufgaben in der Aufgabenansicht eine Aufgabe für jede Seite hinzufügen möchten, die den Suchtext enthält, markieren Sie die Seite und klicken dann auf Aufgabe hinzufügen.
    • Zum Bearbeiten einer Seite, die den Suchtext enthält, doppelklicken Sie in der Liste auf die Seite. Die ausgewählte Seite wird in der Seitenansicht geöffnet, und das erste Vorkommen des Suchtextes ist markiert. Klicken Sie auf Weitersuchen, um dieses Vorkommen zu übergehen und das nächste zu suchen, auf Zurück zum Web, um die Bearbeitung abzubrechen und die Liste der Vorkommen im Dialogfeld Suchen oder Ersetzen wiederherzustellen, auf Ersetzen, um dieses Vorkommen zu ersetzen und das nächste zu finden, oder auf Alles ersetzen, um jedes Vorkommen im Web zu ersetzen.

      • Anmerkung Wenn Sie auf Alles ersetzen klicken, fordert FrontPage Sie möglicherweise auf, die geöffnete Seite zu speichern und zu schließen, bevor der Suchtext auf anderen Seiten ersetzt wird.


Einblenden oder Ausblenden von HTML-Tags auf der Registerkarte "Normal" in der Seitenansicht

Einblenden oder Ausblenden von HTML-Tags auf der Registerkarte „Normal“ in der Seitenansicht

Wenn Sie eine Seite auf der Registerkarte Normal in der Seitenansicht bearbeiten, können Sie Markierungen ein- oder ausblenden, mit denen der Anfang und das Ende der zu Grunde liegenden HTML-Tags angezeigt wird, mit denen der ganze Text, alle Grafiken und anderen Seitenelemente eingeschlossen werden. Das Einblenden von HTML-Tags kann sich als nützlich erweisen, um Seitenelemente wie beispielsweise verschachtelte Tabellen, Textfelder usw. präziser positionieren zu können.

  • Klicken Sie zum Einblenden von HTML-Tags im Menü Ansicht auf Tags anzeigen.
  • Zum Ausblenden von HTML-Tags nach dem Aktivieren des Befehls Tags anzeigen klicken Sie erneut auf Tags anzeigen, um das Häkchen zu entfernen.

Tipp Wenn Sie den Mauszeiger auf einen HTML-Tag bewegen, zeigt Microsoft FrontPage ein Infofeld an, in dem der gesamte Text des Tags einschließlich seiner Attribute und Werte aufgeführt wird.


Einfügen von HTML-Code auf der Registerkarte "Normal" in der Seitenansicht

Einfügen von HTML-Code auf der Registerkarte „Normal“ in der Seitenansicht

Wenn Sie eine Seite auf der Registerkarte Normal in der Seitenansicht bearbeiten und den HTML-Code, den Microsoft FrontPage generiert, ergänzen möchten können Sie an der Einfügemarke HTML-Code Komponenten einfügen.

Tipp Sie können auf die Registerkarte HTML klicken, um den HTML-Code direkt mithilfe des mit Farbcodierung arbeitenden HTML-Editors zu bearbeiten, welcher die HTML-Syntax automatisch bei der Eingabe prüft.

  1. Zeigen Sie im Menü Einfügen auf Erweitert, und klicken Sie dann auf HTML.
  2. Geben Sie den unformatierten Text oder HTML ein, den Sie einfügen möchten. Dieser Text oder HTML wird von FrontPage beim Speichern der Seite weder auf Richtigkeit geprüft noch neu formatiert.

Anmerkungen

  • Wenn Sie auf Tags anzeigen im Menü Ansicht klicken, oder wenn Alle anzeigen Schaltfläche " Alle anzeigen" ausgewählt ist, wird der eingefügte Text oder HTML als ein HTML-Codesymbol HTML-Codesymbol angezeigt. Der eingefügte Text oder HTML wird jedoch auf der Registerkarte Vorschau oder wenn ein Sitebesucher die Seite durchsucht angezeigt.
  • FrontPage fügt den unformatierten Text oder HTML-Code den Sie eingeben zwischen den HTML-Codekomponenten <STARTSPAN> und <ENDSPAN> tags ein.
  • Um einen Kommentar in HTML einzufügen, der nur bei der Dokumenterstellung in FrontPage angezeigt wird, klicken Sie im Menü Einfügen auf Kommentar und geben Sie anschließend den Text des Kommentars ein (Sie brauchen nicht die umgebenden Kommentartags einzugeben).


Bewegen zu einer Zeilennummer auf der Registerkarte "HTML" in der Seitenansicht

Bewegen zu einer Zeilennummer auf der Registerkarte „HTML“ in der Seitenansicht

Wenn Sie HTML-Code auf der Registerkarte HTML in der Seitenansicht bearbeiten, können Sie mit der Einfügemarke zu einer bestimmten Zeilennummer in Ihrem Code springen.

  1. Klicken Sie mit der rechten Maustaste an einer beliebigen Stelle auf der Registerkarte HTML, und klicken Sie dann im Kontextmenü auf Gehe zu.
  2. Geben Sie im Feld Zeilennummer eingeben die Nummer der Zeile ein, zu der Sie sich bewegen möchten.


Ändern der HTML-Formatierung

Sie können ändern, wie Microsoft FrontPage den HTML-Code einer Seite formatiert, die auf der Registerkarte HTML in der Seitenansicht angezeigt wird. So können Sie zum Beispiel die Namen von HTML-Tags in Großbuchstaben und HTML-Attribute in Kleinbuchstaben anzeigen, um diese leichter unterscheiden zu können, also beispielsweise <FORM method="POST">.

  1. Öffnen Sie die Seite, die Sie ändern möchten, in der Seitenansicht. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte HTML-Quelltext.
  2. Wählen Sie aus, in welcher Weise die Formatänderung auf den HTML-Code angewendet werden sollen:
    • Wenn Sie die Formatierung des bereits auf der Seite vorhandenen HTML-Codes beibehalten wollen und Formatänderungen nur auf HTML-Code angewendet werden sollen, den Sie im Nachhinein einfügen oder schreiben, klicken Sie auf Bestehende HTML erhalten. Verwenden Sie diese Option, wenn Sie eine Seite bearbeiten, die mit einem anderen Editor erstellt wurden und Sie nicht möchten, dass FrontPage den ursprünglichen HTML-Code ändert.
    • Wenn die Formatänderungen beim Speichern und Aktualisieren der Seite auf den gesamten HTML-Code angewendet werden sollen, klicken Sie auf Unter Verwendung der folgenden Regeln neuformatieren. Beim Speichern der Seite nimmt FrontPage nun eine Neuformatierung des gesamten HTML-Codes auf der Seite entsprechend der neuen Formateinstellungen vor.
  3. Gehen Sie zum Ändern der Formatierung folgendermaßen vor:
    • Um die Namen von HTML-Tags in Kleinbuchstaben darzustellen, wählen Sie das Kontrollkästchen Tagnamen in Kleinbuchstaben.
    • Wenn Sie die Namen von HTML-Attributen in Kleinbuchstaben anzeigen möchten, aktivieren Sie das Kontrollkästchen Attributnamen in Kleinbuchstaben.
    • Um Zeilenumbrüche innerhalb von Tags zu gestatten, aktivieren Sie das Kontrollkästchen Zeilenwechsel innerhalb von Tags zulassen.
    • Zum Einstellen der Anzahl der Leerzeichen für den linken Einzug geben Sie im Feld Einzug die Anzahl der Leerzeichen ein bzw. wählen Sie den gewünschten Wert aus und klicken Sie dann auf Leerzeichen.
    • Um HTML-Code mit Tabstopps anstelle von Leerzeichen einzurücken, geben Sie im Feld Einzug die Anzahl der Tabstopps zum Einrücken des HTML-Codes ein und klicken dann auf Tabstopps.
    • Zum Einstellen der Position, an der HTML-Code am rechten Rand umbrochen wird, geben Sie im Feld Rechter Rand die Spaltenbreite in Zeichen ein, an der der HTML-Code auf der rechten Seite umbrochen werden soll, bzw. wählen Sie sie aus. Damit der HTML-Code beispielsweise in kleineren Zeilenlängen umbrochen wird, so dass Sie einen längeren Tag komplett anzeigen können, ohne einen horizontalen Bildlauf durchführen zu müssen, wählen Sie einen niedrigeren Wert wie beispielsweise 40. Um mit längeren HTML-Zeilen zu arbeiten, die über den Rand der Registerkarte HTML hinausgehen, geben Sie einen höheren Wert wie beispielsweise 100 ein oder wählen diesen aus.
    • Wenn Sie die HTML-Formatinformationen der aktuellen Seite auslesen und diese Einstellungen als Standard verwenden möchten, klicken Sie auf Von aktueller Seite übernehmen. Verwenden Sie diese Option, wenn Sie eine Seite bearbeiten, deren HTML-Code bereits in der gewünschten Weise formatiert ist und Sie möchten, dass diese Formatierungsoptionen auf jeden neuen HTML-Code angewendet werden, den Sie einfügen oder schreiben.

Anmerkungen

  • Die von Ihnen gewählten Einstellungen werden erst dann auf der Registerkarte HTML angezeigt, wenn Sie einmal zur Registerkarte Normal und wieder zurück gewechselt sind.
  • Die gewählten Einstellungen werden auf alle nachfolgenden neuen Seiten angewendet, die Sie erstellen.
  • Standardmäßig behält FrontPage die ursprüngliche HTML-Formatierung bei, wenn Sie die Seite speichern, und wendet die geänderten Formate nur bei neuem HTML-Code an, den Sie einfügen oder schreiben.
  • Wenn Sie die HTML-Formatierungseinstellungen auf die ursprünglichen Standardeinstellungen zurücksetzen möchten, klicken Sie auf Zurücksetzen.


Ändern der HTML-Formatierung bestimmter Tags

Sie können ändern, wie Microsoft FrontPage bestimmte HTML-Tags auf der Seite formatiert, die auf der Registerkarte HTML in der Seitenansicht angezeigt wird. Beispielsweise können Sie FrontPage anweisen, keine Endtags </p> einzufügen oder den Inhalt einzurücken und vor den Tags <h1> einen Zeilenumbruch hinzuzufügen.

  1. Öffnen Sie die Seite, die Sie ändern möchten, in der Seitenansicht. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte HTML-Quelltext.
  2. Wählen Sie aus, in welcher Weise die Formatänderung auf bestimmte Tags angewendet werden sollen:
    • Wenn Sie die Formatierung der bereits auf der Seite vorhandenen HTML-Tags beibehalten wollen und Formatänderungen nur auf HTML-Tags angewendet werden sollen, die Sie im Nachhinein einfügen oder schreiben, klicken Sie auf Bestehende HTML erhalten. Verwenden Sie diese Option, wenn Sie eine Seite bearbeiten, die mit einem anderen Editor erstellt wurde und Sie nicht möchten, dass FrontPage den ursprünglichen HTML-Code ändert.
    • Um die Formatänderungen auf alle Vorkommen bestimmter HTML-Tags auf der Seite anzuwenden, wenn die Seite gespeichert und aktualisiert wird, klicken Sie auf Unter Verwendung der folgenden Regeln neuformatieren. Wenn Sie die Seite speichern, nimmt FrontPage bei allen Vorkommen dieser bestimmten Tags im ursprünglichen HTML-Code der Seite eine Neuformatierung vor.
  3. Klicken Sie in der Liste Tags auf den Tag, den Sie ändern möchten, und geben Sie dann das Format für diesen Tag an:
    • Wenn Sie vor oder nach einem Tag einen Zeilenwechsel einfügen möchten, um den Tag besser vom umgebenden HTML-Code unterscheiden zu können, geben Sie die Anzahl der Zeilenwechsel in die Felder Vor Start/Vor Ende oder Nach Ende ein, oder wählen Sie einen Wert aus.
    • Wenn Sie Zeilenwechsel innerhalb eines Tags einfügen möchten, um den Tag besser von seinem Inhalt unterscheiden zu können, geben Sie die Anzahl der Zeilenwechsel in die Felder Nach Ende/Nach Start oder Vor Ende ein, oder wählen Sie einen Wert aus.
    • Zum Einrücken des Inhalts eines Tags links des Start- und Endtags aktivieren Sie das Kontrollkästchen Inhalt einrücken.
    • Um das Start- oder Endelement des Tags wegzulassen, aktivieren Sie das Kontrollkästchen Starttag unterdrücken oder Endtag unterdrücken. Abhängig vom gewählten Tag ist eine oder sind beide Optionen nicht verfügbar, wenn die HTML-Regeln das Unterdrücken des Start- oder Endelements dieses Tags nicht zulassen.
    • Wenn Sie die HTML-Formatinformationen der aktuellen Seite auslesen und diese Einstellungen als Standard verwenden möchten, klicken Sie auf Von aktueller Seite übernehmen. Verwenden Sie diese Option, wenn Sie eine Seite bearbeiten, deren HTML-Code bereits in der gewünschten Weise formatiert ist und Sie möchten, dass diese Formatierungsoptionen auf jeden neuen HTML-Code angewendet werden, den Sie einfügen oder schreiben.

Anmerkungen

  • Die von Ihnen gewählten Einstellungen werden erst dann auf der Registerkarte HTML angezeigt, wenn Sie einmal zur Registerkarte Normal und wieder zurück gewechselt sind.
  • Die gewählten Einstellungen werden auf alle nachfolgenden neuen Seiten angewendet, die Sie erstellen.
  • Standardmäßig behält FrontPage die ursprüngliche HTML-Formatierung bei, wenn Sie die Seite speichern, und wendet die geänderten Formate nur bei neuem HTML-Code an, den Sie einfügen oder schreiben.
  • Wenn Sie die HTML-Formateinstellungen auf die ursprünglichen Standardeinstellungen zurücksetzen möchten, klicken Sie auf Zurücksetzen.


Übernehmen der HTML-Formate einer Seite

Sie können ändern, wie Microsoft FrontPage den HTML-Code einer Seite formatiert, die auf der Registerkarte HTML in der Seitenansicht angezeigt wird. So können Sie zum Beispiel die Namen von HTML-Tags in Großbuchstaben und HTML-Attribute in Kleinbuchstaben anzeigen, um diese leichter unterscheiden zu können, also beispielsweise <FORM method="POST">. Die Formatinformationen der aktuellen Seite können Sie übernehmen und als Standard für allen nachfolgenden HTML-Code verwenden, den Sie auf dieser Seite einfügen oder schreiben.

  1. Öffnen Sie die Seite, die Sie ändern möchten, in der Seitenansicht. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte HTML-Quelltext.
  2. Wählen Sie aus, in welcher Weise die Formatänderungen auf den HTML-Code angewendet werden sollen:
    • Wenn Sie die Formatierung des bereits auf der Seite vorhandenen HTML-Codes beibehalten wollen und die Formatänderungen nur auf HTML-Code angewendet werden sollen, den Sie später einfügen oder schreiben, wählen Sie Bestehende HTML erhalten.
    • Wenn die Formatänderungen beim Speichern der Seite auf den gesamten HTML-Code angewendet werden sollen, klicken Sie auf Unter Verwendung der folgenden Regeln neuformatieren. Beim Speichern und Aktualisieren der Seite nimmt FrontPage nun eine Neuformatierung des gesamten HTML-Codes auf der Seite entsprechend den Formateinstellungen der aktuellen Seite vor.
  3. Klicken Sie auf Von aktueller Seite übernehmen.

Anmerkungen

  • Die von Ihnen gewählten Einstellungen werden erst dann auf der Registerkarte HTML angezeigt, wenn Sie einmal zur Registerkarte Normal und wieder zurück gewechselt sind.
  • Die gewählten Einstellungen werden auf alle nachfolgenden neuen Seiten angewendet, die Sie erstellen.
  • Standardmäßig behält FrontPage die ursprüngliche HTML-Formatierung bei, wenn Sie die Seite speichern, und wendet die geänderten Formate nur bei neuem HTML-Code an, den Sie einfügen oder schreiben.
  • Wenn Sie die HTML-Formateinstellungen auf die ursprünglichen FrontPage-Standardeinstellungen zurücksetzen möchten, klicken Sie auf Zurücksetzen.


Ändern der Farbcodierung von HTML

Wenn Sie eine Seite auf der Registerkarte HTML in der Seitenansicht bearbeiten, codiert Microsoft FrontPage die gesamte HTML-Syntax farbig, um zwischen Text auf der Seite, Tags, Attributnamen, Attributen, Werten, Kommentaren und Skripten zu unterscheiden. Sie können die von FrontPage für die Anzeige dieser Elemente verwendeten Farben Ihren Vorstellungen oder den Anforderungen der Arbeitsgruppe entsprechend ändern.

  1. Öffnen Sie die Seite, die Sie ändern möchten, in der Seitenansicht. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte Farbcodierung.
  2. Klicken Sie für jedes HTML-Element, das Sie ändern möchten, auf den Pfeil im Farbenfeld, um auf diese Weise die gewünschte Farbe auszuwählen. Wenn Sie eine benutzerdefinierte Farbe verwenden oder erstellen möchten, klicken Sie auf Weitere Farben und verwenden Sie das Werkzeug Auswählen.

Tipps

  • Die gewählten Einstellungen werden auf alle nachfolgenden neuen Seiten angewendet, die Sie erstellen.
  • Um die Farbcodierung auf die ursprünglichen Standardwerte zurückzusetzen, klicken Sie auf Farben zurücksetzen.
  • Wenn der HTML-Code auf der Registerkarte HTML in der Seitenansicht ohne Farbcodierung angezeigt wird, aktivieren Sie das Kontrollkästchen Farbcodierung anzeigen.


Öffnen oder Bearbeiten einer Active Server Page (.ASP)

Wenn Sie eine Active Server Page (ASP-Datei) in der Seitenansicht öffnen, können Sie diese auf der Registerkarte Normal anzeigen; zum Bearbeiten können Sie entweder die Registerkarte Normal oder die Registerkarte HTML verwenden.

Anmerkungen

  • Wird eine Active Server Page auf der Registerkarte HTML geöffnet, hat Microsoft FrontPage auf dieser Seite Fehler oder strukturelle Probleme erkannt, wie beispielsweise mehrere BODY-Tags oder fehlende Endtags. FrontPage öffnet die Seite auf der Registerkarte HTML, um unerwünschte Änderungen an der ursprünglichen ASP-Datei zu verhindern.
  • Active Server Pages werden auf der Registerkarte Vorschau möglicherweise nicht korrekt angezeigt. Wenn Sie die Seite aus dem Blickwinkel des Sitebesuchers anzeigen möchten, klicken Sie im Menü Datei auf Vorschau in Browser.


Aktivieren oder Deaktivieren von Dynamic HTML (DHTML)

Dynamic HTML (DHTML) ist eine von Microsoft entwickelte Erweiterung von HTML, Version 4.0, mit der Sie Spezialeffekte wie beispielsweise wortweise von der Seite „fliegenden“ Text oder einer sich drehenden Reklametafel ähnliche Übergangseffekte zwischen Seiten erstellen können. Einige Webbrowser unterstützen DHTML jedoch nicht, so dass Seiten, die DHTML-Code beinhalten u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage ermöglicht Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie DHTML aktivieren oder deaktivieren oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der DHTML nicht unterstützt, stehen die Befehle, mit denen DHTML eingesetzt wird, zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen, und dann auf die Registerkarte Kompatibilität.
  2. Zum Aktivieren oder Deaktivieren von DHTML aktivieren oder deaktivieren Sie das Kontrollkästchen Dynamic HTML.

Anmerkungen

  • In der folgenden Tabelle finden Sie eine Liste der Optionen für die Browserkompatibilität, bei denen DHTML automatisch aktiviert oder deaktiviert ist. Wenn Sie den Standard außer Kraft setzen und DHTML aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
    • Browser | Browserversion | DHTML
Internet Explorer | 4.0 und höher | aktiviert
Internet Explorer | 3.0 und höher | deaktiviert
Netscape Navigator | 4.0 und höher | aktiviert
Netscape Navigator | 3.0 und höher | deaktiviert
Sowohl Internet Explorer als auch Navigator | 4.0 und höher | aktiviert
Sowohl Internet Explorer als auch Navigator | 3.0 und höher | deaktiviert
Microsoft WebTV | nicht verfügbar | deaktiviert

  • Wenn Sie DHTML deaktivieren oder eine Browserkompatibilitätsoption wählen, mit der DHTML deaktiviert wird, stehen die folgenden Befehle und Einstellungen nicht zur Verfügung:
    • Dynamic HTML-Effekte (Menü Format)
    • Seitenübergang (Menü Format)
    • Kontrollkästchen Ausblendbare Gliederung aktivieren (Menü Format, Befehl Nummerierung und Aufzählungen)
    • Kontrollkästchen Hyperlink-Rollovereffekte aktivieren (Menü Datei, Befehl Eigenschaften, Registerkarte Hintergrund)


Festlegen von Eigenschaften auf der Registerkarte "HTML" in der Seitenansicht

Festlegen von Eigenschaften auf der Registerkarte „HTML“ in der Seitenansicht

Wenn Sie eine Seite auf der Registerkarte HTML in der Seitenansicht bearbeiten, können Sie sich von Microsoft FrontPage beim Festlegen der Eigenschaften für ein HTML-Tag helfen lassen, anstatt sich die gültigen Attribute und Werte zu merken und diese selbst einzugeben.

Wenn Sie beispielsweise einer Abbildung einen Rahmen hinzufügen möchten, können Sie border="1" in das <img>-Tag eingeben, was jedoch voraussetzt, dass Sie die gültigen Attribute und Werte für Abbildungstags kennen. Stattdessen können Sie jedoch auch das Dialogfeld Bildeigenschaften verwenden, um den Rahmen festzulegen, und FrontPage schreibt dann automatisch die Rahmeneinstellungen in der korrekten Syntax und unter Verwendung gültiger Werte in das <img>-Tag zurück. Im Gegensatz zu den Vorläuferversionen von FrontPage müssen Sie die Registerkarte HTML nun nicht mehr verlassen, um auf die Dialogfelder zum Festlegen von Eigenschaften für ein Tag zuzugreifen.

  1. Positionieren Sie die Einfügemarke auf der Registerkarte HTML in der Seitenansicht innerhalb des Tagnamens (nicht innerhalb eines Attributs oder eines Wertes) des Tags, für das Sie Eigenschaften festlegen möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Tageigenschaften.

    2. FrontPage zeigt nun das entsprechende Eigenschaftendialogfeld für dieses HTML-Tag an. Wenn Sie beispielsweise in das Tag für ein Formularfeldkontrollkästchen klicken, zeigt FrontPage das Dialogfeld Kontrollkästcheneigenschaften an.

  2. Legen Sie die gewünschten Eigenschaften fest. Im Dialogfeld können Sie unter den gültigen Attributen und Werten für dieses Tag wählen.

Wenn Sie auf OK klicken, um das Eigenschaftendialogfeld zu schließen, schreibt FrontPage den HTML-Code für dieses Tag unverzüglich um.


Beibehalten der ursprünglichen HTML-Formatierung einer Seite

Wenn Sie eine vorhandene Seite öffnen, einschließlich Seiten, die in anderen Editoren erstellt wurden, behält Microsoft FrontPage automatisch den Inhalt, die Syntax und die Formatierung des HTML-Codes dieser Seite bei, auch wenn dieser Fehler und nicht erkannte HTML-Syntax enthält. Speichern Sie die Seite, speichert FrontPage den gesamten neuen HTML-Code, den Sie geschrieben haben, mit allen benutzerdefinierten Formatierungen wie beispielsweise Einrückung, Groß- und Kleinschreibung von Tags usw. Der ursprüngliche HTML-Code der Seite wird jedoch nur dann geändert oder neu formatiert, wenn Sie ihn in FrontPage bearbeitet haben.

Wenn Sie die automatische Erhaltung von HTML außer Kraft setzen möchten, klicken Sie im Menü Extras auf Seitenoptionen, dann auf die Registerkarte HTML-Quelltext und anschließend auf Unter Verwendung der folgenden Regeln neuformatieren.


Drucken des HTML-Codes einer Seite

  • Klicken Sie in der Seitenansicht auf die Registerkarte HTML, und klicken Sie dann auf Drucken Schaltfläche "Drucken".


Hinzufügen einer System-META-Variablen zu einer Seite

Um Informationen zum HTTP-Kopf einer Seite hinzuzufügen, fügen Sie eine System-META-Variable hinzu. Diese Variable entspricht dem HTTP-EQUIV-Attribut im META-Tag und ist für Sitebesucher nicht sichtbar. Dieser META-Tag kann mehrere Anweisungen für einen Webbrowser enthalten, wie z. B. ein Ablaufdatum oder einen Wert zum Aktualisieren der Anzeige.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  2. Klicken Sie auf die Registerkarte Benutzerdefiniert.
  3. Klicken Sie unter Systemvariablen auf Hinzufügen.
  4. Geben Sie in das Feld Name den Namen der Variablen ein.
  5. Geben Sie in das Feld Wert den Wert der Variablen ein.


Hinzufügen einer benutzerdefinierten META-Variablen zu einer Seite

Um Informationen zum HTTP-Kopf einer Seite hinzuzufügen, fügen Sie eine benutzerdefinierte META-Variable hinzu. Diese Variable entspricht dem NAME-Attribut im META-Tag und ist für Sitebesucher nicht sichtbar. Dieser META-Tag kann mehrere Anweisungen für einen Webbrowser enthalten, wie z. B. ein Ablaufdatum oder einen Wert zum Aktualisieren der Anzeige.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, und klicken Sie dann im Kontextmenü auf Seiteneigenschaften.
  2. Klicken Sie auf die Registerkarte Benutzerdefiniert.
  3. Klicken Sie unter Benutzervariablen auf Hinzufügen.
  4. Geben Sie in das Feld Name den Namen der Variablen ein.
  5. Geben Sie in das Feld Wert den Wert der Variablen ein.


Festlegen von Browserkompatibilität für ein Web

Microsoft FrontPage erlaubt Ihnen festzulegen, mit welchen Browsern und Technologien Ihr Web kompatibel sein soll. Sie können z. B. Kompatibilität sowohl mit Microsoft Internet Explorer als auch mit Netscape Navigator oder mit allen Versionen von 3.0-Browsern festlegen.

Wenn Sie für Ihr Web Kompatibilität mit bestimmten Browsertechnologien oder -versionen festlegen, stehen Befehle, die von diesen Browsertechnologien oder -versionen nicht unterstützt werden, zum Zeitpunkt der Erstellung der Seiten in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Wählen Sie im Feld Browser die gewünschten Browser aus.

    3. Tipp Um Kompatibilität zu bestimmten Technologien oder Funktionsmerkmalen anstatt zu bestimmten Browsern festzulegen, klicken Sie auf Benutzerdefiniert und aktivieren oder deaktivieren dann unter Technologien die entsprechenden Kontrollkästchen für die einzelnen Technologien bzw. Funktionsmerkmale.

  3. Wählen Sie im Feld Browserversionen die gewünschten Browserversionen aus.

    4. Tipp Um Kompatibilität zu bestimmten Technologien oder Funktionsmerkmalen anstatt zu bestimmten Browsern festzulegen, klicken Sie auf Benutzerdefiniert und aktivieren oder deaktivieren dann unter Technologien die entsprechenden Kontrollkästchen für die einzelnen Technologien bzw. Funktionsmerkmale.

Anmerkungen

  • Die folgende Tabelle zeigt die Standardtechnologien und Funktionsmerkmale, die für jede Browserkompatibiltitskombination unterstützt werden. Wenn Sie die Standardeinstellungen überschreiben und eine von einem bestimmten Browser oder einer bestimmten Browserversion nicht unterstützte Technologie oder nicht unterstütztes Funktionsmerkmal aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
  • Sie können für ein Web Kompatibilität mit bestimmten Servern festlegen, während Sie das Web erstellen.

    Browser | Browserversion | ActiveX- Steuerelemente | VBScript | JavaScript | Java-Applets | Dynamisches HTML | Frames | CSS 1.0 | CSS 2.0
Internet Explorer | 4.0 und höher | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert
Internet Explorer | 3.0 und höher | aktiviert | aktiviert | aktiviert | aktiviert | deaktiviert | aktiviert | aktiviert | deaktiviert
Netscape Navigator | 4.0 und höher | deaktiviert | deaktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert
Netscape Navigator | 3.0 und höher | deaktiviert | deaktiviert | aktiviert | aktiviert | deaktiviert | aktiviert | deaktiviert | deaktiviert
Sowohl Internet Explorer als auch Navigator | 4.0 und höher | deaktiviert | deaktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert | aktiviert
Sowohl Internet Explorer als auch Navigator | 3.0 und höher | deaktiviert | deaktiviert | aktiviert | aktiviert | deaktiviert | aktiviert | deaktiviert | deaktiviert
Microsoft WebTV | nicht verfügbar | deaktiviert | deaktiviert | deaktiviert | deaktiviert | deaktiviert | deaktiviert | deaktviert | deaktiviert

  • Wenn Sie im Feld Browser eine der Optionen Nur Netscape Navigator, Sowohl Internet Explorer als auch Netscape Navigator oder Microsoft Web TV wählen, stehen die folgenden Befehle und Einstellungen nicht zur Verfügung:
    • Laufschrift (Menü Einfügen, Untermenü Komponente)
    • Video (Menü Einfügen, Untermenü Bild)
    • Tabellenhintergrundbild (Menü Tabelle, Untermenü Eigenschaften, Befehl Tabelle)
    • Zellenrahmen und -hintergrund (Menü Tabelle, Untermenü Eigenschaften, Befehl Zelle)
  • Wenn Sie im Feld Browser eine der Optionen Nur Microsoft Internet Explorer, Sowohl Internet Explorer als auch Netscape Navigator oder Microsoft Web TV wählen, steht die folgende Einstellung nicht zur Verfügung:
    • Kontrollkästchen Blinkend (Menü Format, Befehl Zeichen)


Festlegen von Serverkompatibilität für ein Web

Microsoft FrontPage erlaubt Ihnen, für Ihr Web Kompatibilität mit bestimmten Servern festzulegen. Sie können z. B. für Ihr Web Kompatibilität mit Microsoft Internet Information Server, Version 3.0 und höher, festlegen.

Wenn Sie für Ihr Web Kompatibilität mit einem bestimmten Server festlegen, stehen Befehle, die von diesem Server nicht unterstützt werden, zur Zeit der Erstellung der Seiten in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Wählen Sie im Feld Server den gewünschten Server aus.

    3. Anmerkung Wenn Sie Apache-Server auswählen, sind Active Server Pages standardmäßig deaktiviert.

  3. Wenn Sie für Ihr Web Kompatibilität zu einem Server festlegen möchten, der die FrontPage-Servererweiterungen verwendet, aktivieren Sie das Kontrollkästchen Mit Microsoft FrontPage-Servererweiterungen.

    4. Anmerkung Wenn Ihr Server die FrontPage-Servererweiterungen nicht verwendet und Sie dieses Kontrollkästchen aktivieren, stehen die folgenden Befehle nicht zur Verfügung:

    • Zugriffszähler (Menü Einfügen, Untermenü Komponente)
    • Suchformular (Menü Einfügen, Untermenü Komponente)
    • Bestätigungsfeld (Menü Einfügen, Untermenü Komponente)


Aktivieren oder Deaktivieren von ActiveX-Steuerelementen

Mithilfe von Microsoft ActiveX-Steuerelementen können Sie nahezu alles von Kalendern bis zu Börsentickern zu Ihren Webseiten hinzufügen. Einige Webbrowser unterstützen jedoch keine ActiveX-Steuerelemente, so dass Seiten, die ActiveX-Steuerelemente enthalten u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage erlaubt Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie ActiveX-Steuerelemente aktivieren oder deaktivieren, oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der ActiveX-Steuerelemente nicht unterstützt, stehen die Befehle zum Einfügen dieser Steuerelemente zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Zum Aktivieren oder Deaktivieren von ActiveX-Steuerelementen aktivieren oder deaktivieren Sie das Kontrollkästchen ActiveX-Steuerelemente.

Anmerkungen

  • Wenn Sie für Ihr Web im Feld Browser Kompatibilität mit Nur Netscape Navigator, Sowohl Internet Explorer als auch Navigator oder Microsoft Web TV festlegen, werden ActiveX-Steuerlemente standardmäßig deaktiviert. Wenn Sie die Standardeinstellung außer Kraft setzen und ActiveX-Steuerelemente aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
  • Besuchen Sie die Microsoft Site Builder Network-Toolssammlung unter http://www.microsoft.com/gallery/default.asp. Hier erhalten Sie weitere Informationen und können die neuesten Steuerelemente downloaden.
  • Wenn Sie ActiveX-Steuerelemente deaktivieren oder eine Browser-Kompatibilitätsoption auswählen, die ActiveX-Steuerelemente deaktiviert, stehen die folgenden Befehle nicht zur Verfügung:
    • ActiveX-Steuerelement (Menü Einfügen, Untermenü Erweitert)
    • Office Spreadsheet (Menü Einfügen, Untermenü Komponente)
    • Office PivotTabelle (Menü Einfügen, Untermenü Komponente)
    • Office Chart (Menü Einfügen, Untermenü Komponente)


Aktivieren oder Deaktivieren von VBScript

Sie können Microsoft VBScript in ihrem Web für nahezu alles von Formularen bis hin zu Datenbankabfragen verwenden. Einige Webbrowser unterstützten VBScript jedoch nicht, so dass Seiten, die VBScript enthalten, u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage erlaubt Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie VBScript aktivieren oder deaktivieren, oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der VBScript nicht unterstützt, stehen die Befehle zum Einfügen und Verwenden von VBScript zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Aktivieren oder deaktivieren Sie zum Aktivieren bzw. Deaktivieren von VBScript das Kontrollkästchen VBScript.

Anmerkung Wenn Sie für Ihr Web im Feld Browser Kompatibilität mit Nur Netscape Navigator, Sowohl Internet Explorer als auch Navigator oder Microsoft Web TV festlegen, wird VBScript standardmäßig deaktiviert. Wenn Sie die Standardeinstellung überschreiben und VBScript aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.


Aktivieren oder Deaktivieren von JavaScript

Sie können JavaScript in Ihrem Web für nahezu alles von Animation bis hin zu Anwendungen einsetzen. Einige Webbrowser unterstützen JavaScript jedoch nicht, so dass Seiten, die JavaScript enthalten, u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage erlaubt Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie JavaScript aktivieren oder deaktivieren, oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der JavaScript nicht unterstützt, stehen die Befehle zum Einfügen und Verwenden von JavaScript zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Aktivieren oder deaktivieren Sie zum Aktivieren bzw. Deaktivieren von JavaScript das Kontrollkästchen JavaScript.

Anmerkung Wenn Sie für Ihr Web im Feld Browser Kompatibilität mit Microsoft Web TV festlegen, wird JavaScript standardmäßig deaktiviert. Wenn Sie die Standardeinstellung überschreiben und JavaScript aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.


Aktivieren oder Deaktivieren von Java-Applets

Sie können Java-Applets in Ihrem Web für nahezu alles von Animation bis hin zu Anwendungen einsetzen. Einige Webbrowser unterstützen Java-Applets jedoch nicht, so dass Seiten, die Java-Applets enthalten, u. U. bei bestimmten Sitebesuchern nicht korrekt oder mit Fehlern angezeigt werden.

Microsoft FrontPage erlaubt Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie Java-Applets aktivieren oder deaktivieren, oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der Java-Applets nicht unterstützt, stehen die Befehle zum Einfügen und Verwenden von Java-Applets zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Aktivieren oder deaktivieren Sie zum Aktivieren bzw. Deaktivieren von Java-Applets das Kontrollkästchen Java-Applets.

Anmerkungen

  • Wenn Sie für Ihr Web im Feld Browser Kompatibilität mit Microsoft Web TV festlegen, werden Java-Applets standardmäßig deaktiviert. Wenn Sie die Standardeinstellung überschreiben und Java-Applets aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
  • Wenn Sie Java-Applets deaktivieren oder eine Browser-Kompatibilitätsoption auswählen, die Java-Applets deaktiviert, stehen die folgenden Befehle nicht zur Verfügung:
    • Java-Applet (Menü Einfügen, Untermenü Erweitert)
    • Anzeigenwechsler (Menü Einfügen, Untermenü Komponente)
    • Hoverschaltfläche (Menü Einfügen, Untermenü Komponente)


Aktivieren oder Deaktivieren von Frames

Eine Framesseite ist eine spezielle Art von HTML-Seite, die das Browserfenster in unterschiedliche Bereiche, sogenannte Frames unterteilt. Einige Webbrowser unterstützen jedoch keine Frames, so dass Framesseiten u. U. bei bestimmten Sitebesuchern nicht korrekt angezeigt werden.

Microsoft FrontPage erlaubt Ihnen festzulegen, zu welchen Browsern und Technologien Ihr Web kompatibel sein soll. Wenn Sie Frames aktivieren oder deaktivieren, oder wenn Sie für Ihr Web Kompatibilität mit einem Browser festlegen, der Frames nicht unterstützt, stehen die Befehle zum Einfügen und Verwenden von Frames zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität.
  2. Aktivieren oder deaktivieren Sie zum Aktivieren bzw. Deaktivieren von Frames das Kontrollkästchen Frames.

Anmerkungen

  • Wenn Sie für Ihr Web im Feld Browser Kompatibilität mit Microsoft Web TV festlegen, werden Frames standardmäßig deaktiviert. Wenn Sie die Standardeinstellung überschreiben und Frames aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
  • Wenn Sie Frames deaktivieren oder eine Browserkompatibilitätsoption wählen, die Frames deaktiviert, wird die Registerkarte Framesseiten im Dialogfeld Neu (Menü Datei, Untermenü Neu, Befehl Seite) beim Erstellen neuer Seiten nicht angezeigt.


Aktivieren oder Deaktivieren von Active Server Pages (.ASP)

Sie können die Verwendung von Active Server Pages (.ASP) für ein Web aktivieren oder deaktivieren.

  • Klicken Sie im Menü Extras auf Seitenoptionen und dann auf die Registerkarte Kompatibilität. Anschließend aktivieren oder deaktivieren Sie das Kontrollkästchen Active Server Pages.

Anmerkungen

  • Wenn Sie für Ihr Web im Feld Server Kompatibilität mit Apache-Server festgelegt haben, werden Active Server Pages standardmäßig deaktiviert. Wenn Sie die Standardeinstellung deaktivieren und Active Server Pages aktivieren, werden Ihre Seiten u. U. nicht korrekt oder mit Fehlern angezeigt.
  • Wenn Ihr Web bereits eine Datenbank verwendet und Sie Active Server Pages deaktivieren, stehen die Befehle Ergebnisse und Spaltenwert (Menü Einfügen, Untermenü Datenbank) nicht zur Verfügung.


Anzeigen einer Siteübersicht

Der Bericht Siteübersicht gibt Ihnen einen Überblick über wesentliche Statistiken Ihres Webs, wie z. B. die Anzahl und die Größe von Dateien und Bildern, die Anzahl und Typen von Hyperlinks, die Anzahl nicht abgeschlossener Aufgaben usw. Betrachten Sie die Übersicht als eine Bestandsaufnahme und Diagnose Ihres Webs in geraffter Form.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht.


Anzeigen von Hyperlinks von und zu jeder Seite im Web

Die Hyperlinkansicht bietet eine visuelle „Landkarte“ der Hyperlinks von und nach jeder Seite in einem Web. Klicken Sie auf der Ansichtenleiste auf das Symbol Hyperlinks, um zur Hyperlinkansicht zu wechseln, und klicken Sie dann in der Ordnerliste auf die gewünschte Seite.

Tipp Sie können die Hyperlinkansicht anpassen, um Seitentitel oder Verknüpfungen zu und von Bildern anzuzeigen oder zu verbergen usw.


Auflisten unterbrochener Hyperlinks

Es gibt nur wenige Dinge, die Sitebesucher mehr irritieren als unterbrochene Hyperlinks, d. h. Verknüpfungen, die nirgendwo hinführen oder auf „Sackgassen“ zeigen, Seiten oder Websites, die umbenannt, verschoben, gelöscht wurden oder andere URLs erhalten haben. Es gehört mit zu einer guten Webverwaltung, dass regelmäßig nach unterbrochenen Hyperlinks gesucht wird und diese dann entweder repariert oder gelöscht werden.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Um die Anzahl der unterbrochenen Hyperlinks in einem Web anzuzeigen, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht. In der Zeile Unterbrochene Hyperlinks zeigt die Spalte Anzahl die Zahl der unterbrochenen Hyperlinks im Web an.
  • Um eine detaillierte Liste der unterbrochenen Hyperlinks für ein Web anzuzeigen, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Unterbrochene Hyperlinks.

Tipps

  • Wenn Sie den Bericht Siteübersicht oder Unterbrochene Hyperlinks zum ersten Mal erstellen, wird die Anzahl der unterbrochenen Hyperlinks mit 0 angegeben, während die Anzahl der ungeprüften Hyperlinks gleich der Gesamtzahl der Hyperlinks im Web ist. Das liegt daran, dass Microsoft FrontPage alle Hyperlinks anfänglich als ungeprüft aufführt. Um Hyperlinks zu prüfen, klicken Sie im Menü Extras auf Hyperlinks neu berechnen.

    • Anmerkung Wenn es viele externe Hyperlinks in einem Web gibt, kann es mehrere Minuten dauern, bis FrontPage diesen Befehl ausgeführt hat, da es sich mit jeder externen Website verbinden muss, um den Hyperlink zu überprüfen.

  • Sie können im Bericht Siteübersicht auf die Zeile Unterbrochene Hyperlinks doppelklicken, um den Bericht Unterbrochene Hyperlinks anzuzeigen. In diesem Bericht können Sie folgende Schritte durchführen:
    • Doppelklicken Sie auf einen Hyperlink, um ihn zu öffnen und zu bearbeiten, und übertragen Sie die Änderung auf ausgewählte Seiten oder alle Seiten, auf denen der Hyperlink auftritt.
    • Um die Seite mit dem unterbrochenen Hyperlink zu bearbeiten, klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann im Kontextmenü auf Seite editieren.
    • Um eine Aufgabe zum Hyperlink hinzuzufügen, durch die jemand daran erinnert wird, diesen zu reparieren, klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.


Anzeigen der Aufgabenliste

  • Klicken Sie auf der Ansichtenleiste auf die Schaltfläche Aufgaben, um zur Aufgabenansicht zu wechseln, in der Name, Priorität, Status und andere Informationen pro Aufgabe im aktuellen Web aufgelistet werden.

Tipp Wenn der Befehl Aufgabenverlauf anzeigen nicht aktiviert ist, verbirgt Microsoft FrontPage die erledigten Aufgaben, immer wenn Sie die Aufgabenansicht aktualisieren oder zu einer anderen Ansicht wechseln. Um auch die erledigten Aufgaben anzuzeigen, klicken Sie mit der rechten Maustaste auf den Hintergrund in der Aufgabenansicht, und klicken Sie dann im Kontextmenü auf Aufgabenverlauf anzeigen, falls der Befehl noch nicht aktiviert ist.


Hinzufügen eines Zugriffszählers zu einer Seite

Ein Zugriffszähler registriert, wie oft eine Seite besucht wurde, und zeigt diese Zahl an. Fügen Sie z. B. einen Zugriffszähler zu Ihrer Homepage hinzu, damit sowohl Sie als auch Ihre Sitebesucher sehen können, wie oft Ihre Website besucht worden ist. Dazu das folgende Beispiel:

Sie sind Besucher: Zugriffszähler

Microsoft FrontPage unterstützt mehrere Arten von Zugriffszählern an. Sie können jedoch auch eine eigene Grafik verwenden, wenn Sie ein benutzerdefiniertes Bild im GIF-Format erstellen. Das Bild muss die Ziffern 0 bis 9 in gleichmäßigen Abständen enthalten.

Anmerkung Ein Zugriffszähler funktioniert nur für Seiten in einem Web, und er funktioniert nur dann, wenn auf Ihrem Webserver die FrontPage-Servererweiterungen installiert sind.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie den Zugriffszähler einfügen möchten.
  2. Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Zugriffszähler.
  3. Klicken Sie unter Stil des Zählers auf den Typ des Zugriffszählers, den Sie verwenden möchten. Wenn Sie auf Benutzerdefiniertes Bild klicken, geben Sie die relative Adresse der GIF-Datei an, z. B. BILDER/BENUTZERDEF.GIF.
  4. Um den Zähler auf eine spezielle Zahl zu setzen, wählen Sie Zähler zurücksetzen auf und geben dann die Zahl ein.
  5. Zum Anzeigen einer festen Anzahl von Ziffern im Zugriffszähler wählen Sie Feste Ziffernzahl und geben die Anzahl ein. Wenn Sie z. B. 005 anstatt 5 anzeigen möchten, wählen Sie diese Option und geben Sie dann 3 ein.

    6. [Zugriffszähler] wird auf der Seite als Platzhalter für den Zugriffszähler angezeigt. Um zu sehen, wie der Zugriffszähler Sitebesuchern angezeigt wird, klicken Sie auf die Registerkarte Vorschau, oder zeigen Sie die Vorschau der Seite in einem Webbrowser an.


Zurücksetzen eines Zugriffszählers auf Null

Wenn Sie einen Zugriffszähler zu einer Seite hinzugefügt haben, können Sie diesen auf Null zurücksetzen. Angenommen, Sie testen ein Web, nachdem Sie es veröffentlicht haben, um sicherzustellen, dass es ordnungsgemäß funktioniert, und stellen dabei fest, dass der Zugriffszähler durch Ihre eigenen Besuche hochgezählt wurde. Sie können den Zähler jetzt auf Null zurücksetzen, damit er neu beginnt und nur die Sitebesucher zählt.

  1. Doppelklicken Sie in der Seitenansicht auf [Zugriffszähler].
  2. Wählen Sie die Option Zähler zurücksetzen auf, und geben Sie dann in das Feld 0 ein.


Berechnen der Größe eines Webs

Der Bericht Siteübersicht zeigt die Anzahl und Gesamtgröße (in Kilobyte) aller Dateien Ihres Webs an, eingeschlossen Seiten, Bilder und Datenbanken.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht.

In der Zeile Alle Dateien zeigt die Spalte Anzahl die Zahl der Dateien und die Spalte Größe die Gesamtgröße (in Kilobyte) aller Dateien in Ihrem Web an.


Berechnen der Größe aller Bilder

Der Bericht Siteübersicht zeigt die Größe aller Bilder (GIFs, JPEGs, BMPs usw.) in Ihrem Web in Kilobyte an.

Anmerkung Wenn Ihr Web Bilder enthält, die in verborgenen Ordnern gespeichert sind, werden diese Bilder nicht in diesen Bericht eingeschlossen. Um Bilder in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht.

In der Zeile Bilder zeigt die Spalte Größe die Gesamtgröße aller Bilder in Ihrem Web an.


Zählen von Bildern

Der Bericht Siteübersicht zeigt die Gesamtzahl der Bilder (GIFs, JPEGs, BMPs usw.) in Ihrem Web an.

Anmerkung Wenn Ihr Web Bilder enthält, die in verborgenen Ordnern gespeichert sind, werden diese Bilder nicht in diesen Bericht eingeschlossen. Um Bilder in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht.

In der Zeile Bilder zeigt die Spalte Anzahl die Anzahl der Bilder in Ihrem Web an.


Auflisten von langsamen Seiten

Je mehr Text, Bilder, Steuerelemente und andere Elemente zu einer Seite hinzugefügt werden, umso langsamer ist der Download vom Webserver, wenn ein Sitebesucher die Seite aufsucht. Es ist empfehlenswert, die Seiten klein zu halten, damit deren Download schnell vonstatten geht. Beachten Sie die Verbindungsgeschwindigkeit Ihres Webpublikums: Geschieht der Zugriff von zu Hause aus über ein 28.8-Modem oder besteht eine Verbindung vom Arbeitsplatz über das Firmenintranet? Je langsamer die Verbindung ist, desto kleiner sollten die Seiten sein.

Microsoft FrontPage hilft Ihnen dabei, zu bestimmen, welche Seiten in Ihrem Web je nach Verbindungsgeschwindigkeit beim Download langsam sind. Die Berichte Siteübersicht und Langsame Seiten zeigen diese Informationen an.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht.

    2. In der Zeile Langsame Seiten zeigt die Spalte Anzahl die Zahl der langsamen Seiten in Ihrem Web an. Die Spalte Beschreibung führt die Downloadzeit und Modemgeschwindigkeit auf, die für die Definition einer langsamen Seite verwendet wurden.

  2. Um den Bericht Langsame Seiten anzuzeigen, in dem die langsamen Seiten Ihres Webs sowie die geschätzten Downloadzeiten angegeben werden, doppelklicken Sie auf die Zeile Langsame Seiten, oder zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Langsame Seiten.

Tipp Um die zur Berechnung einer langsamen Seite verwendete Verbindungsgeschwindigkeit und den Zeitwert zu definieren, klicken Sie im Menü Extras auf Optionen, klicken Sie auf die Registerkarte Berichtsansicht, und geben Sie dann neue Werte für „Langsame Seiten“ brauchen zum Downloaden mindestens und Angenommene Modemgeschwindigkeit ein.


Definieren von "langsamen Seiten" in der Berichtsansicht

Definieren von „langsamen Seiten“ in der Berichtsansicht

Wenn Microsoft FrontPage in der Berichtsansicht die Berichte Siteübersicht und Langsame Seiten berechnet, werden „langsame“ Seiten, d. h. solche, die nur langsam heruntergeladen werden, als Seiten definiert, die wenigstens 20 Sekunden für das Download bei einer Verbindungsgeschwindigkeit von 14.4 Baud benötigen. Sie können mit dem folgenden Verfahren die Standardzahl von Sekunden ändern, mit der FrontPage „langsame“ Seiten bei der Berechnung dieser Berichte definiert.

  1. Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Berichtsansicht.
  2. Wählen Sie im Feld Angenommene Modemgeschwindigkeit die Geschwindigkeit der Verbindung bei Ihrem Zielpublikum aus. Wenn Ihr Web z. B. von privaten Benutzern über Modemverbindungen durchsucht wird, wählen Sie 28,8 oder 56.6 aus. Wird Ihr Web in einem Firmenintranet von Benutzern mit dedizierten Netzwerkverbindungen durchsucht, wählen Sie T1 oder T3 aus.
  3. Geben Sie im Feld „Langsame Seiten“ brauchen zum Downloaden mindestens die Anzahl der Sekunden ein, mit der eine „langsame“ Seite bei der angenommenen Modemgeschwindigkeit definiert wird, oder wählen Sie eine Anzahl aus.

    4. Tipp Als eine allgemeine Richtlinie gilt, dass eine Seite, die mehr als 20 Sekunden für das Downloaden benötigt, ohne Rücksicht darauf, wie hoch die angenommene Verbindungsgeschwindigkeit ist, von den Webbenutzern als „langsam“ angesehen wird.


Sortieren von Dateien nach Datum

Microsoft FrontPage bietet Ihnen verschiedene Möglichkeiten, die Dateien eines Webs nach Datum zu sortieren.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Um Dateien anzuzeigen, die erst kürzlich zu Ihrem Web hinzugefügt wurden, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Kürzlich hinzugefügte Dateien.
  • Um Dateien anzuzeigen, die erst kürzlich geändert wurden, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Kürzlich geänderte Dateien.
  • Um ältere Dateien anzuzeigen, die möglicherweise veraltet sind oder übersehen wurden, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Ältere Dateien.

Tipps

  • Um die Anzahl der Tage zu ändern, anhand der ein Bericht berechnet, ob eine Datei kürzlich hinzugefügt wurde, kürzlich geändert wurde oder älteren Datums ist, klicken Sie auf der Symbolleiste Berichte im Feld Berichtseinstellungen auf die Anzahl der Tage.

    • Um die Symbolleiste Berichte anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Berichte.

  • Sie können in jedem Datumsbericht auf eine Datei doppelklicken, um sie zu öffnen und zu bearbeiten.
  • Sie können in jedem Datumsbericht eine Aufgabe zu einer Datei hinzufügen, durch die jemand daran erinnert wird, die Datei zu aktualisieren oder zu löschen, indem Sie auf die Datei doppelklicken und dann im Kontextmenü auf Aufgabe hinzufügen klicken.


Definieren von "älteren" Dateien in der Berichtsansicht

Definieren von „älteren“ Dateien in der Berichtsansicht

Wenn Microsoft FrontPage die Berichte Siteübersicht und Ältere Dateien in der Berichtsansicht berechnet, wird „älter“ für Dateien so definiert, dass diese 72 Tage oder länger nicht mehr geändert wurden. Sie können mit dem folgenden Verfahren die Standardzahl von Tagen ändern, mit der FrontPage den Begriff „älter“ bei der Berechnung dieser Berichte definiert.

  • Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Berichtsansicht. Geben Sie im Feld „Ältere Dateien“ sind mehr als die Anzahl der Tage ein, oder wählen Sie eine Anzahl aus.


Definieren von "zuletzt geöffneten" Dateien

Definieren von „zuletzt geöffneten“ Dateien

Wenn Microsoft FrontPage die Berichte Siteübersicht, Kürzlich hinzugefügte Dateien und Kürzlich geänderte Dateien in der Berichtsansicht berechnet, wird „kürzlich“ für Dateien so definiert, dass diese 30 Tage oder weniger alt sind. Sie können mit dem folgenden Verfahren die Standardzahl von Tagen ändern, mit der FrontPage den Begriff „kürzlich“ bzw. „zuletzt“ bei der Berechnung dieser Berichte definiert.

  • Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Berichtsansicht. Geben Sie im Feld „Zuletzt benutzte Seiten“ sind weniger als die Anzahl der Tage ein, oder wählen Sie eine Anzahl aus.


Suchen nach Fehlern auf einer Seite

Wenn Sie in Ihrem Web Microsoft FrontPage-basierte Komponenten verwendet haben, können Sie vor dem Veröffentlichen des Webs nach Fehlern in den Komponenten suchen.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Komponentenfehler.

    2. Seiten mit Fehlern werden aufgelistet, und in der Spalte Fehler wird eine Beschreibung der Fehler angezeigt.

  2. Zum Öffnen einer Seite, damit diese bearbeitet werden kann, doppelklicken Sie auf die Zeile.


Rechtschreibprüfung in einem Web

Sie können die Rechtschreibung auf allen Seiten oder auf ausgewählten Seiten im aktuellen Web prüfen. Microsoft FrontPage prüft die Rechtschreibung nur für Textelemente, die in der Seitenansicht auf der Registerkarte Normal bearbeitet werden können. Wenn Sie z. B. eine Komponente wie eine Hoverschaltfläche hinzufügen oder einen Seitentitel in den Seiteneigenschaften festlegen, wird die Rechtschreibung in diesen Elementen nicht geprüft.

Wenn FrontPage falsch geschriebene Wörter findet, können Sie diese auf zwei Arten korrigieren:

  • Fügen Sie eine Aufgabe für jede Seite hinzu, auf der FrontPage falsch geschriebene Wörter findet. Sie können die Rechtschreibung jederzeit korrigieren, indem Sie in die Aufgabenansicht wechseln und die einzelnen Aufgaben durchführen.
  • Korrigieren Sie die Rechtschreibung, unmittelbar nachdem FrontPage die Rechtschreibprüfung beendet hat. FrontPage zeigt eine Liste der Seiten mit falsch geschriebenen Wörtern an, und Sie können dann jede einzelne Seite korrigieren.
  1. Wechseln Sie in die Ordneransicht.
  2. Wenn Sie die Rechtschreibprüfung nicht auf jeder Seite im Web durchführen möchten, wählen Sie die Seiten aus, die Sie prüfen möchten.
  3. Klicken Sie auf Rechtschreibung Schaltfläche "Rechtschreibung".
  4. Führen Sie einen der folgenden Schritte durch:
    • Um die Rechtschreibung auf allen Seiten im aktuellen Web zu prüfen, klicken Sie auf Gesamtes Web.
    • Um die Rechtschreibung auf den von Ihnen ausgewählten Seiten zu prüfen, klicken Sie auf Markierte Seiten.
  5. Wenn Sie möchten, dass FrontPage eine Aufgabe für jede Seite mit falsch geschriebenen Wörtern hinzufügt, aktivieren Sie das Kontrollkästchen Für Seiten mit Rechtschreibfehlern je eine Aufgabe hinzufügen.
  6. Klicken Sie auf Beginnen.
  7. Wenn FrontPage die Seiten mit falsch geschriebenen Wörtern auflistet, führen Sie einen der folgenden Schritte durch:
    • Wenn Sie ausgewählt haben, dass Aufgaben für Seiten mit falsch geschriebenen Wörtern zu erstellen sind, werden die Aufgaben zur Aufgabenliste hinzugefügt. Um die Rechtschreibfehler später zu korrigieren, klicken Sie auf Abbrechen. Wenn Sie bereit sind, die Rechtschreibfehler zu korrigieren, wechseln Sie zur Aufgabenansicht, doppelklicken Sie auf eine Aufgabe mit der Bezeichnung Korrigiert Wörter mit Rechtschreibfehlern, und klicken Sie dann auf Aufgabe ausführen. FrontPage öffnet die Seite in der Seitenansicht und fordert Sie auf, die falsch geschriebenen Wörter zu korrigieren.
    • Um die Rechtschreibfehler zu korrigieren, doppelklicken Sie in der Liste auf eine Seite. FrontPage öffnet die Seite in der Seitenansicht und fordert Sie auf, die falsch geschriebenen Wörter zu korrigieren. Wenn Sie alle Textvorkommen auf der Seite durchgesehen haben, werden Sie aufgefordert, die Seite zu speichern und zu schließen und dann mit der nächsten Seite fortzufahren, auf der ein Rechtschreibfehler gefunden wurde.


Rechtschreibprüfung auf einer Seite

Sie können die Rechtschreibung auf der aktuellen Seite prüfen.

  1. Klicken Sie in der Seitenansicht auf Rechtschreibung Schaltfläche "Rechtschreibung".

    2. Wenn ein nicht erkanntes Wort gefunden wird, öffnet sich das Dialogfeld Rechtschreibung und zeigt das Wort im Feld Nicht im Wörterbuch an.

  2. Führen Sie einen der folgenden Schritte durch:
    • Um das falsch geschriebene Wort durch ein Wort aus der Liste Vorschläge zu ersetzen, klicken Sie auf das vorgeschlagene Wort, und klicken Sie dann auf Ändern. Um alle Vorkommen dieses Wortes zu korrigieren, klicken Sie auf Immer ändern.
    • Wenn Sie das Wort selbst korrigieren möchten, geben Sie das richtige Wort im Feld Ändern in ein, und klicken Sie dann auf Ändern. Um alle Vorkommen dieses Wortes zu korrigieren, klicken Sie auf Immer ändern.
    • Wenn das nicht erkannte Wort richtig geschrieben ist, klicken Sie auf Ignorieren, um dieses Vorkommen des Wortes zu ignorieren, oder klicken Sie auf Immer ignorieren, um alle Vorkommen dieses Wortes zu ignorieren. Klicken Sie auf Hinzufügen, um das Wort zu Ihrem benutzerdefinierten Wörterbuch hinzuzufügen.

    FrontPage zeigt nun das nächste, falsch geschriebene Wort an.

Anmerkungen

  • Wenn Sie auf Abbrechen klicken, werden bereits durchgeführte Änderungen nicht rückgängig gemacht.
  • Sie können keine Rechtschreibprüfung in eingeschlossenen Dateien durchführen. Sie müssen diese Dateien gesondert öffnen, um deren Rechtschreibung zu prüfen.


Auflisten von Komponentenfehlern

Teil einer guten Webverwaltung sollte es sein, regelmäßig nach Fehlern in FrontPage-Komponenten zu suchen und diese zu beheben. So könnte z. B. eine Inhaltsverzeichnis-Komponente einen Fehler melden, wenn Sie eine ungültige Seite (wie z. B. eine Seite, die inzwischen gelöscht wurde) als Ausgangspunkt der Tabelle auswählen.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Um die Anzahl von Fehlern in Komponenten eines Webs anzuzeigen, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht. In der Zeile Komponentenfehler zeigt die Spalte Anzahl die Zahl der Fehler in Webkomponenten an.
  • Um eine detaillierte Liste von Dateien anzuzeigen, die Fehler in Webkomponenten enthalten, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Komponentenfehler. Die Spalte Fehler bezeichnet die Komponenten und beschreibt die Fehler.

Tipps

  • Sie können im Bericht Siteübersicht auf die Zeile Komponentenfehler doppelklicken, um den Bericht Komponentenfehler anzuzeigen. In diesem Bericht können Sie folgende Schritte durchführen:
    • Doppelklicken Sie auf eine Seite, um sie zu öffnen und den Komponentenfehler zu beheben.
    • Um eine Aufgabe zum Fehler hinzuzufügen, durch die jemand daran erinnert wird, diesen zu beheben, klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.


Auflisten von Dateien nach Zuweisung

Wenn Sie Dateien unterschiedlichen Personen oder Arbeitsgruppen zugewiesen haben, können Sie mithilfe des Berichts Zugewiesen die Webdateien nach Zuweisung auflisten, das Datum anzeigen, an dem die Dateien jeweils zugewiesen wurden, wer sie zugewiesen hat und welche Kommentare zu den Dateien hinzugefügt wurden.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Klicken Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Zugewiesen.

Der Bericht Zugewiesen listet alle Webdateien auf. Die Spalte Zugewiesen zeigt die Person oder Arbeitsgruppe an, die einer Datei zugewiesen ist.

Tipps

  • Um den Bericht nach dem Datum zu sortieren, an dem die Dateien zugewiesen wurden, oder nach den Namen der Personen, die die Zuweisungen vorgenommen haben, klicken Sie auf die Spaltenüberschrift Zugewiesen am oder Zugewiesen von.
  • Um eine Datei einer Person oder Arbeitsgruppe zuzuweisen oder eine Zuweisung zu ändern, klicken Sie in der Spalte Zugewiesen auf die Zelle, klicken Sie erneut auf die Zelle, und geben Sie dann eine Person oder Arbeitsgruppe ein, oder wählen Sie eine aus.
  • Sie können mehrere Dateien auf einmal zuweisen. Markieren Sie im Bericht Zugewiesen die Dateien, die Sie zuweisen möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und wählen Sie dann im Feld Zugewiesen die Person oder Arbeitsgruppe aus, der Sie die Datei zuweisen möchten.
  • Um eine Datei zu öffnen und zu bearbeiten, doppelklicken Sie auf diese.
  • Um eine Aufgabe zu einer Datei hinzuzufügen, durch die jemand daran erinnert wird, diese zuzuweisen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.
  • Um einen Dateikommentar hinzuzufügen oder zu bearbeiten, klicken Sie in der Spalte Kommentare auf die Zelle, klicken Sie erneut auf die Zelle, und geben Sie dann den Kommentar ein.


Auflisten von Dateien nach Kategorie

Wenn Sie mithilfe von Kategorien die Dateien Ihres Webs in logischen Gruppen organisieren, wie z. B. „Produkte“ oder „Verkaufsberichte“, so können Sie den Bericht Kategorien verwenden, um die Dateien nach Kategorien aufzulisten.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Kategorien.

Der Bericht Kategorien listet alle Dateien eines Webs auf. In der Spalte Kategorie werden ggf. die Kategorien angezeigt, in denen die einzelnen Dateien angeordnet sind.

Tipps

  • Um die Dateien nur in einer Kategorie aufzulisten, klicken Sie auf der Symbolleiste Berichte in der Liste Berichtseinstellungen auf die betreffende Kategorie.

    • Um die Symbolleiste Berichte anzuzeigen, zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie dann auf Berichte.

  • In jedem Bericht Kategorien können Sie auf eine Datei doppelklicken, um sie zu öffnen und zu bearbeiten.
  • In jedem Bericht Kategorien können Sie eine Aufgabe zu einer Datei hinzufügen, die jemanden daran erinnert, die Datei zu kategorisieren, indem Sie mit der rechten Maustaste auf die Datei klicken und dann im Kontextmenü auf Aufgabe hinzufügen klicken.
  • Sie können mehrere Dateien auf einmal kategorisieren. Markieren Sie zu diesem Zweck im Bericht Kategorien die Dateien, die Sie kategorisieren möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und aktivieren Sie im Feld Verfügbare Kategorien die Kategorien für die ausgewählten Dateien.


Auflisten von Dateien nach Checkoutstatus

Wenn Ihr Web die Quellkontrolle für die Verwaltung von Dateien verwendet, indem diese von einem Server durch Checkout kontrolliert entnommen und durch Checkin dort wieder zurückgestellt werden, dann können Sie mithilfe des Berichts Checkoutstatus sofort erkennen, wer welche Dateien entnommen hat.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Checkoutstatus.

Der Bericht Checkoutstatus listet alle Webdateien auf. Die Spalte Ausgecheckt von zeigt, wer die Datei entnommen hat, die Spalte Version zeigt die letzte Version der entnommenen Datei, und die Spalte Gesperrt am zeigt das Datum, an dem die Datei durch Checkout entnommen (und damit „gesperrt“) wurde.

Tipps

  • Um den Bericht nach dem Datum, an dem die Dateien entnommen wurden, oder nach dem Namen der Personen, die ein Checkout durchgeführt haben, zu sortieren, klicken Sie auf die Spaltenüberschrift von Ausgecheckt von oder von Gesperrt am.
  • Um eine Datei, die nicht gesperrt ist, zu entnehmen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Auschecken.
  • Um eine Datei zu öffnen und zu bearbeiten, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Öffnen.
  • Um eine Aufgabe zur Datei hinzuzufügen, durch die jemand daran erinnert wird, entweder ein Checkin oder ein Checkout vorzunehmen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.
  • Um eine von Ihnen ausgecheckte Datei wieder einzuchecken, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Einchecken.


Auflisten von Dateien nach Veröffentlichungsstatus

Sie können mithilfe des Berichts Veröffentlichungsstatus sofort erkennen, ob eine Datei für die Veröffentlichung vorgesehen ist oder nicht. Sie können auch den Prüfstatus von Dateien anzeigen und den Veröffentlichungsstatus entsprechend ändern.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Veröffentlichungsstatus.

Der Bericht Veröffentlichungsstatus listet alle Dateien eines Webs auf. Die Spalte Veröffentlichen zeigt an, ob eine Datei für die Veröffentlichung vorgesehen ist oder nicht.

Tipps

  • Um den Veröffentlichungsstatus oder den Prüfstatus einer Datei zu ändern, klicken Sie in der Spalte Prüfstatus auf die Zelle Veröffentlichen, klicken Sie erneut auf die Zelle, und geben Sie dann einen anderen Veröffentlichungsstatus oder Prüfstatus ein, oder wählen Sie einen aus.
  • Sie können den Veröffentlichungsstatus oder Prüfstatus mehrerer Dateien auf einmal ändern. Markieren Sie im Bericht Veröffentlichungsstatus die Dateien, für die Sie den Veröffentlichungsstatus oder den Prüfstatus ändern möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und wählen Sie im Feld Prüfstatus den Prüfstatus für die markierten Dateien aus. Um die Dateien von der Veröffentlichung fernzuhalten, aktivieren Sie das Kontrollkästchen Diese Seite beim Veröffentlichen des Webs ausschließen.
  • Um eine Datei zu öffnen und zu bearbeiten, doppelklicken Sie auf diese.
  • Um eine Aufgabe zu einer Datei hinzuzufügen, durch die jemand daran erinnert wird, diese zu genehmigen oder zu prüfen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.


Auflisten von Dateien nach Prüfstatus

Sie können den Prüfstatus einer Datei festlegen, mit dem angegeben wird, welche Art von Prüfung die Datei benötigt, wie z. B. eine Codeprüfung für eine Active Server Page (.asp), oder wenn die Datei im Genehmigungsverfahren für die Freigabe zur Veröffentlichung steht. Wenn Sie für die Dateien in einem Web einen Prüfstatus festgelegt haben, können Sie mithilfe des Berichts Prüfstatus die Webdateien nach Prüfstatus sortieren, die Daten anzeigen, an denen die Dateien zuletzt geprüft wurden, und wer die Prüfung durchgeführt hat.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Klicken Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Prüfstatus.

Der Bericht Prüfstatus listet alle Webdateien auf.

Tipps

  • Um den Bericht alphabetisch nach Prüfstatus, Prüfdatum oder Prüfer zu sortieren, klicken Sie auf die entsprechende Spaltenüberschrift.
  • Um den Prüfstatus einer Datei zu ändern, klicken Sie in der Spalte Prüfstatus auf die Zelle, klicken Sie erneut auf die Zelle, und geben Sie einen Prüfstatus ein, oder wählen Sie einen aus.
  • Um eine Datei einer Person oder einer Arbeitsgruppe zuzuweisen, klicken Sie in der Spalte Zugewiesen auf die Zelle, klicken Sie erneut auf die Zelle, und geben Sie eine Person oder Arbeitsgruppe ein, oder wählen Sie eine aus.
  • Sie können den Prüfstatus für mehrere Dateien auf einmal festlegen oder mehrere Dateien auf einmal zuweisen. Markieren Sie im Bericht Prüfstatus die Dateien, für die Sie einen Prüfstatus festlegen oder die Sie zuweisen möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und markieren Sie dann im Feld Prüfstatus oder Zugewiesen den Prüfstatus oder die Person bzw. Arbeitsgruppe für die ausgewählten Dateien.
  • Um eine Datei zu öffnen und zu bearbeiten, doppelklicken Sie auf diese.
  • Um eine Aufgabe zu einer Datei hinzuzufügen, durch die jemand daran erinnert wird, diese zu prüfen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie im Kontextmenü auf Aufgabe hinzufügen.


Auflisten unverknüpfter Dateien

Zur ordentlichen Verwaltung eines Webs gehört es, gelegentlich zu überprüfen, ob es irgendwelche „Waisenkinder“ gibt, d. h. Seiten, die nicht von der Homepage aus über nachfolgende Hyperlinks erreicht werden können. Diese unverbundenen Seiten können veraltete oder nicht mehr benötigte Dateien sein, die zur Säuberung eines Webs gelöscht werden können. Es kann sich aber auch um Seiten handeln, die zur Navigationsstruktur des Webs in der Navigationsansicht hinzuzufügen sind oder zu denen Verknüpfungen über Hyperlinks hergestellt werden sollten.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  • Um die Anzahl der unverknüpften Dateien in Ihrem Web anzuzeigen, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Siteübersicht. In der Zeile Unverknüpfte Dateien zeigen die Spalten Anzahl und Größe die Anzahl und die Größe (in Kilobyte) der unverknüpften Dateien in Ihrem Web an.
  • Um eine Liste der unverknüpften Dateien in Ihrem Web anzuzeigen, zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Unverknüpfte Dateien.

Tipps

  • Sie können im Bericht Siteübersicht auf die Zeile Unverknüpfte Dateien doppelklicken, um den Bericht Unverknüpfte Dateien anzuzeigen.
  • Im Bericht Unverknüpfte Dateien können Sie auf eine Datei doppelklicken, um sie zu öffnen und zu bearbeiten.
  • Um im Bericht Unverknüpfte Dateien eine Aufgabe zu einer Datei hinzuzufügen, die jemanden daran erinnert, einen Hyperlink auf diese zu erstellen, klicken Sie mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Aufgabe hinzufügen.


Drucken einer Seite

Sie können die aktuelle Seite auf einem Drucker oder in eine Datei drucken. Hyperlinks und Bilder werden so gedruckt, wie sie in der Seitenansicht auf der Registerkarte Standard aussehen.

  1. Klicken Sie in der Seitenansicht auf Drucken Schaltfläche "Drucken".
  2. Legen Sie die gewünschten Druckoptionen fest, wie z. B. den Namen des Druckers, den Sie verwenden möchten, und die Anzahl der gewünschten Kopien.

Tipp Um zu sehen, wie die Seite aussehen wird, wenn sie gedruckt wird, klicken Sie im Menü Datei auf Seitenansicht. Diese Vorschau ist jedoch nicht ganz identisch mit der Ansicht in einem Webbrowser: die Seitenansicht paginiert und weist Seitenzahlen zu, Webbrowser dagegen nicht.


Prüfen des Veröffentlichungsstatus eines Webs

Sie können den Veröffentlichungsstatus aller Dateien eines Webs durch Erstellen eines Berichts überprüfen. Der Bericht Veröffentlichungsstatus gibt an, ob eine Datei mit Veröffentlichen oder Nicht veröffentlichen gekennzeichnet ist. Standardmäßig werden alle Dateien mit Veröffentlichen gekennzeichnet, sofern Sie nicht den Status ändern.

  • Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Veröffentlichungsstatus.

Die Spalte Veröffentlichen zeigt den Veröffentlichungsstatus jeder einzelnen Datei an.


Info über das Veröffentlichen

Um mehr über das Veröffentlichen zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Kennzeichnen von Seiten für das Veröffentlichen

Sie können angeben, welche Dateien Sie veröffentlichen möchten. Standardmäßig werden alle Dateien für das Veröffentlichen vorgesehen, jedoch können Sie diese Einstellung ändern. Wenn Sie zum Beispiel die Bearbeitung einer Seite noch nicht abgeschlossen haben, Ihre Website aber schon veröffentlichen möchten, können Sie verhindern, dass diese Seite veröffentlicht wird, indem Sie diese mit Nicht veröffentlichen kennzeichnen. Wenn Sie die Seite veröffentlichen möchten, kennzeichnen Sie diese mit Veröffentlichen.

Bestimmte Dateien sollten nicht erneut veröffentlicht werden, nachdem Sie zunächst Ihr Web veröffentlicht haben. So erstellen Sie beispielsweise zunächst ein Web mit einem Gästebuch und veröffentlichen dieses anschließend. Später aktualisieren Sie Ihre Webseiten — wenn Sie alle Ihre Dateien veröffentlichen, einschließlich der Datei, die Informationen des Gästebuchs aufzeichnet, speichern Sie ein leeres Gästebuch über dem vorhandenen und verlieren so alle Informationen. Weitere Beispiele beinhalten Seiten mit einem Zugriffszähler, Diskussionswebs und Kataloge (falls Sie Index Server verwenden).

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Veröffentlichungsstatus.

    2. Der Veröffentlichungsstatus aller Dateien im aktuellen Web wird angezeigt.

  2. Markieren Sie eine oder mehrere Dateien, klicken Sie mit der rechten Maustaste auf diese, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe.
  3. Tun Sie eines der folgenden Dinge:
    • Um zu verhindern, dass eine Datei veröffentlicht wird, aktivieren Sie das Kontrollkästchen Diese Seite beim Veröffentlichen des Webs ausschließen.
    • Um eine Seite für die Veröffentlichung zu kennzeichnen, deaktivieren Sie das Kontrollkästchen Diese Seite beim Veröffentlichen des Webs ausschließen.

Tipp Sie können in jeder beliebigen Ansicht mit der rechten Maustaste auf das Seitensymbol in der Ordnerliste klicken, im Kontextmenü auf Eigenschaften klicken, und dann auf die Registerkarte Arbeitsgruppe klicken.


Veröffentlichen eines Webs mittels HTTP

Sie veröffentlichen die Dateien Ihres aktuellen Webs, wenn Sie bereit sind, Ihr Web der Öffentlichkeit zu präsentieren, oder wenn Sie Dateien in Ihrem Web aktualisieren möchten. Sie können mithilfe von HTTP (HyperText Transfer Protocol) veröffentlichen, wenn die FrontPage-Servererweiterungen auf dem Webserver installiert sind, für den die Veröffentlichung vorgesehen ist.

Bevor Sie Ihr Web veröffentlichen, können Sie festlegen, welche Seiten Sie veröffentlichen möchten. Wenn Sie dann Ihr Web veröffentlichen, haben Sie die folgenden Optionen:

  • Nur die Dateien veröffentlichen, die sich geändert haben. FrontPage vergleicht die Dateien in Ihrem lokalen Web mit den Dateien auf dem Webserver, und nur diejenigen Dateien, die neuer als die auf dem Webserver sind, werden veröffentlicht. Dateien, die mit Nicht veröffentlichen gekennzeichnet sind, werden jedoch nicht veröffentlicht.
  • Alle Dateien veröffentlichen, mit Ausnahme derjenigen, die mit Nicht veröffentlichen gekennzeichnet sind. Die Dateien aus dem lokalen Web überschreiben alle entsprechenden Dateien auf dem Ziel-Webserver, selbst wenn die Dateien auf dem Webserver neueren Datums sind.
  • Alle Unterwebs veröffentlichen, sofern das aktuelle Web Unterwebs enthält. Alle Dateien und Ordner in Unterwebs werden zusätzlich zu denen im aktuellen Web rekursiv veröffentlicht.
  • Das Web mithilfe einer sicheren Verbindung (SSL) veröffentlichen. Verwenden Sie zum Beispiel diese Funktion, wenn der Webserver das Protokoll HTTPS für die Authentifizierung der Benutzer verwendet.
  1. Klicken Sie im Menü Datei auf Web veröffentlichen.
  2. Klicken Sie auf Optionen, um die Liste der Optionen einzublenden.
  3. Geben Sie an, ob Sie nur geänderte Seiten veröffentlichen möchten, oder alle Seiten.
  4. Um Unterwebs zu veröffentlichen, aktivieren Sie das Kontrollkästchen Untergeordnete Webs einschließen.
  5. Um mittels einer sicheren Verbindung zu veröffentlichen, aktivieren Sie das Kontrollkästchen Sichere Verbindung ist notwendig (SSL). Damit dieses Funktionsmerkmal verwendet werden kann, muss der Zielwebserver SSL unterstützen.
  6. Geben Sie im Feld Geben Sie die Adresse an, an der Ihr Web veröffentlicht werden soll: den Standort des Webservers ein, klicken Sie auf den Pfeil, um einen Standort auszuwählen, an dem Sie schon vorher veröffentlicht haben, oder klicken Sie auf Durchsuchen, um den Standort der Veröffentlichung zu finden.
  7. Klicken Sie auf Veröffentlichen.

    8. FrontPage veröffentlicht nun Ihr Web. Wenn Sie überprüfen möchten, ob Ihr Web erfolgreich veröffentlicht worden ist, klicken Sie auf den Hyperlink, der angezeigt wird, nachdem das Web veröffentlicht worden ist. Ihr Webbrowser wird dann die gerade von Ihnen veröffentlichte Site anzeigen.

    Wenn das Veröffentlichen mitten in der Operation abgebrochen wird, bleiben die Dateien, die bereits veröffentlicht worden sind, auf dem Ziel-Webserver bestehen.

Tipp Um nur geänderte Seiten an derselben Stelle zu veröffentlichen wie schon zuvor, klicken Sie auf Veröffentlichen Schaltfläche "Veröffentlichen".


Veröffentlichen eines Webs mittels FTP

Veröffentlichen Sie die Dateien Ihres aktuellen Webs, wenn Sie bereit sind, Ihr Web der Öffentlichkeit zu präsentieren, oder wenn Sie Dateien in Ihrem Web auf einem Remoteserver aktualisieren möchten.

Veröffentlichen Sie mittels FTP (File Transfer Protocol), wenn die FrontPage-Servererweiterungen nicht auf dem Webserver installiert sind, für den die Veröffentlichung vorgesehen ist. Sie müssen den Namen und Pfad des FTP-Servers kennen. Der Name des FTP-Servers ist der Domänenname des Webservers, für den die Veröffentlichung vorgesehen ist (zum Beispiel ftp.server.com). Der Verzeichnispfad ist der Ordner auf dem Server, in dem Ihr Web gespeichert ist (zum Beispiel /public_html). Wenn Sie sich nicht sicher sind, wie Ihr Benutzername, Ihr Kennwort oder der FTP-Standort lauten, setzen Sie sich mit Ihrem Internetdienstanbieter in Verbindung.

Bevor Sie Ihr Web veröffentlichen, können Sie festlegen, welche Seiten Sie veröffentlichen möchten. Wenn Sie dann Ihr Web veröffentlichen, haben Sie die folgenden Optionen:

  • Nur die Dateien veröffentlichen, die sich geändert haben. FrontPage vergleicht die Dateien auf Ihrem Computer mit den Dateien auf dem Webserver, und nur diejenigen Dateien, die neuer als die auf dem Webserver sind, werden veröffentlicht. Dateien, die mit Nicht veröffentlichen gekennzeichnet sind, werden jedoch nicht veröffentlicht.
  • Alle Dateien veröffentlichen, mit Ausnahme derjenigen, die mit Nicht veröffentlichen gekennzeichnet sind. Die Dateien aus dem lokalen Web überschreiben alle entsprechenden Dateien auf dem Ziel-Webserver, selbst wenn die Dateien auf dem Webserver neueren Datums sind.
  • Unterwebs veröffentlichen, sofern das aktuelle Web Unterwebs enthält. Alle Dateien und Ordner in Unterwebs werden zusätzlich zu denen im aktuellen Web rekursiv veröffentlicht.
  1. Klicken Sie im Menü Datei auf Web veröffentlichen.
  2. Klicken Sie auf Optionen, um die Liste der Optionen einzublenden.
  3. Geben Sie an, ob Sie nur geänderte Seiten veröffentlichen möchten, oder alle Seiten.
  4. Um Unterwebs zu veröffentlichen, aktivieren Sie das Kontrollkästchen Untergeordnete Webs einschließen.
  5. Geben Sie im Feld Geben Sie die Adresse an, an der Ihr Web veröffentlicht werden soll: den Standort des FTP-Webservers an (z. B. ftp://ftp.server.com/public_html) oder klicken Sie auf den Pfeil, um einen Standort auszuwählen, an dem Sie schon vorher veröffentlicht haben.

    Klicken auf Durchsuchen um den Ordner auf dem Server zu finden in dem Ihr Web gespeichert ist, ist beim Veröffentlichen mittels FTP nicht empfehlenswert, da Sie sich durch eine Ordnerstruktur bewegen müssen, die unter Umständen nicht übersichtlich ist.

  6. Klicken Sie auf Veröffentlichen.

    7. FrontPage veröffentlicht nun Ihr Web. Wenn Sie sich Ihr Web dann in Ihrem Webbrowser anzeigenlassen, können Sie überprüfen, ob alles erfolgreich veröffentlicht wurde.

    Da Sie auf einem Webserver veröffentlichen, der nicht die FrontPage-Servererweiterungen ausführt, werden Sie benachrichtigt, wenn Ihr Web Funktionsmerkmale enthält, welche die Servererweiterungen benötigen.

    Wenn das Veröffentlichen mitten in der Operation abgebrochen wird, bleiben die Dateien, die bereits veröffentlicht worden sind, auf dem Ziel-Webserver bestehen.

Tipp Um nur geänderte Seiten an derselben Stelle zu veröffentlichen wie schon zuvor, klicken Sie auf Veröffentlichen Schaltfläche "Veröffentlichen".


Hinzufügen oder Ändern eines FTP-Standorts

Nachdem Sie einen FTP-Standort eingerichtet haben, können Sie den FTP-Standort hinzufügen oder ändern wenn Sie das nächste Mal veröffentlichen.

Bevor Sie einen FTP-Standort ändern können, müssen Sie den Namen und Verzeichnispfad des FTP-Servers kennen. Der FTP-Servername ist der Domänenname des Webservers, auf dem Sie veröffentlichen (zum Beispiel ftp.server.com). Der Verzeichnispfad ist der Ordner auf dem Server, in dem Ihr Web gespeichert ist (zum Beispiel public_html). Wenn Sie sich nicht sicher sind, wie Ihr Benutzername, Ihr Kennwort oder der FTP-Standort lauten, setzen Sie sich mit Ihrem Internet-Dienstanbieter in Verbindung.

  1. Klicken Sie im Menü Datei auf Web veröffentlichen.
  2. Klicken Sie auf Optionen, um die Liste der Optionen einzublenden.
  3. Geben Sie an, ob Sie nur geänderte Seiten veröffentlichen möchten, oder alle Seiten.
  4. Um Unterwebs zu veröffentlichen, aktivieren Sie das Kontrollkästchen Untergeordnete Webs einschließen.
  5. Geben Sie in dem Feld Geben Sie an, wohin Ihr Web veröffentlicht werden soll: den Standort eines FTP-Webservers ein (z. B. ftp://ftp.server.com/public_html), oder klicken Sie auf den Pfeil, um einen Standort auszuwählen, an dem Sie schon vorher veröffentlicht haben.

    Klicken auf Durchsuchen um den Ordner auf dem Server zu finden in dem Ihr Web gespeichert ist, ist beim Veröffentlichen mittels FTP nicht empfehlenswert, da Sie sich durch eine Ordnerstruktur bewegen müssen, die unter Umständen nicht übersichtlich ist.

  6. Klicken Sie auf Veröffentlichen.

    7. FrontPage veröffentlicht nun Ihr Web. Wenn Sie überprüfen möchten, ob Ihr Web erfolgreich veröffentlicht worden ist, klicken Sie auf den Hyperlink, der angezeigt wird, nachdem das Web veröffentlicht worden ist. Ihr Webbrowser wird dann die gerade von Ihnen veröffentlichte Site anzeigen.

    Da Sie auf einem Webserver veröffentlichen, der nicht die FrontPage-Servererweiterungen ausführt, werden Sie benachrichtigt, wenn Ihr Web Funktionsmerkmale enthält, welche die Servererweiterungen benötigen.

    Wenn das Veröffentlichen mitten in der Operation abgebrochen wird, bleiben die Dateien, die bereits veröffentlicht worden sind, auf dem Zielwebserver bestehen.


Löschen einer veröffentlichten Datei oder eines veröffentlichten Ordners

Wenn Sie Ihr Web veröffentlichen, vergleicht FrontPage die aktuellen Dateien auf Ihrem lokalen Computer mit den Dateien auf dem Webserver. Um daher die Dateien auf dem Webserver zu verwalten (zum Beispiel, um alte Dateien oder Ordner zu beseitigen), löschen oder verschieben Sie die Dateien oder Ordner im Web auf Ihrem lokalen Computer, worauf FrontPage Sie zu diesen Dateien auf dem Webserver befragen wird, wenn Sie das nächste Mal veröffentlichen.


Veröffentlichen eines Webs an einem Ort des lokalen Dateisystems

Sie können Ihr Web in einem Ordner auf Ihrem lokalen Dateisystem oder einem UNC-Pfad veröffentlichen. So können Sie zum Beispiel eine Sicherungskopie Ihres gesamten Webs anfertigen, indem Sie es an einem neuen Standort auf Ihrer Festplatte wie C:\Backup veröffentlichen. Durch das Veröffentlichen eines Webs anstelle nur des Kopierens von Dateien wird sichergestellt, dass alle erforderlichen Dateien gesichert werden und in der korrekten Struktur vorliegen.

  1. Klicken Sie im Menü Datei auf Web veröffentlichen.
  2. Klicken Sie auf Optionen, um die Liste der Optionen einzublenden.
  3. Geben Sie an, ob Sie nur geänderte Seiten veröffentlichen möchten, oder alle Seiten.
  4. Um Unterwebs zu veröffentlichen, aktivieren Sie das Kontrollkästchen Untergeordnete Webs einschließen. Alle Dateien und Ordner von Unterwebs im aktuellen Web werden rekursiv veröffentlicht, zusätzlich zu den Dateien und Ordnern des aktuellen Webs.
  5. Geben Sie im Feld Geben Sie die Adresse an, an der Ihr Web veröffentlicht werden soll: den Pfad des Ordners in Ihrem Dateisystem ein, wie zum Beispiel C:\Backup oder \\Webs\MeinOrdner. Um den Ordner zu finden, klicken Sie auf Durchsuchen.
  6. Klicken Sie auf Veröffentlichen.

    7. FrontPage veröffentlicht nun Ihr Web.

    Wenn das Veröffentlichen mitten in der Operation abgebrochen wird, bleiben die Dateien, die bereits veröffentlicht worden sind, im Zielordner bestehen.

Tipp Um nur geänderte Seiten an derselben Stelle zu veröffentlichen wie schon zuvor, klicken Sie auf Veröffentlichen Schaltfläche "Veröffentlichen".


Verbergen einer Seite vor Webbrowsern

Wenn Sie verhindern möchten, dass der Sitebesucher bestimmte Seiten in einem Web sehen kann, wie z. B. externe Stylesheets oder Seiten, die in andere Seiten eingefügt werden sollen, können Sie diese verbergen. Dazu legen Sie sie im verborgenen Ordner _private ab. Dieser Ordner befindet sich in jedem Web.

  • Wählen Sie in der Ordneransicht die Seiten aus, die Sie verbergen möchten, und ziehen Sie sie dann in den Ordner_private. FrontPage aktualisiert automatisch alle Hyperlinks zu und von diesen Dateien entsprechend der neuen Adresse.

Tipp Sie können im Ordner _private Unterordner erstellen, um die Seiten zu strukturieren, da Webbrowser auch auf Unterordner im Ordner _private nicht zugreifen können.


Kennzeichnen einer Seite für eine Suchmaschine

Sie können Ihre Homepage mit Schlüsselwörtern indizieren, um Ihr Web für Suchmaschinen wie Yahoo! oder Alta Vista zugänglicher zu machen.

  1. Klicken Sie im Menü Datei auf Eigenschaften, und klicken Sie dann auf die Registerkarte Benutzerdefiniert.
  2. Klicken Sie unter Benutzervariablen auf Hinzufügen.
  3. Geben Sie im Feld Name den Wert keywords ein.
  4. Geben Sie im Feld Wert die Indexschlüsselwörter für Ihre Site ein, wobei Sie die einzelnen Wörter durch Komma trennen.
  5. Klicken Sie auf OK, um das Dialogfeld Benutzer-Metavariable zu schließen, und klicken Sie dann auf OK, um das Dialogfeld Seiteneigenschaften zu schließen.

Anmerkungen

  • FrontPage fügt die Indexschlüsselwörter zu den Metadaten der Seite hinzu. Klicken Sie in der Seitenansicht auf die Registerkarte HTML, um den von FrontPage generierten HTML-Code anzuzeigen.
  • Manche Suchmaschinen verwenden keine Schlüsselwörter in den Metadaten, oder sie verlangen ihren eigenen Registrierungsprozess. Setzen Sie sich mit den einzelnen Suchmaschinen in Verbindung, um die jeweiligen Richtlinien zu erfahren.


Verwalten eines Webs

Um zu erfahren, wie ein Web verwaltet wird, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Anzeigen von Informationen über den Server

Wenn Sie an einem serverbasierten Web arbeiten, können Sie Informationen über die Serversoftware anzeigen. Sie können auch feststellen, ob auf dem Server die Microsoft FrontPage-Servererweiterungen installiert worden sind, und falls dies so ist, welche Version.

  • Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Allgemein.


Verwenden Ihres Computers als Server

Wenn Sie Microsoft FrontPage installieren, wird geprüft, ob Sie auf Ihrem Computer einen Webserver installiert haben. Vorige FrontPage-Versionen haben einen Webserver standardmäßig installiert, so dass Sie wahrscheinlich bereits einen Webserver installiert haben, wenn Sie die vorige Version von FrontPage installiert haben.

Wenn Sie einen Webserver oder eine vorige FrontPage-Version oder die Servererweiterungen installiert haben, aktualisiert FrontPage automatisch die Servererweiterungen und führt Sie, sofern erforderlich, durch den Ablauf der Serverkonfiguration für die Verwendung der Servererweiterungen. Standardmäßig sind alle von Ihnen erstellten Webs serverbasiert.

Wenn Sie auf Ihrem Computer noch keinen Webserver installiert haben, installiert FrontPage die Servererweiterungen, konfiguriert sie aber nicht. Standardmäßig sind alle von Ihnen erstellten Webs in FrontPage festplattenbasiert. Verwenden Sie die folgende Prozedur, um Ihren Computer als Server zu konfigurieren, und erstellen Sie mit FrontPage serverbasierte Webs.

  1. Installieren Sie Serversoftware, wie zum Beispiel Microsoft Personal Web Server.
    • Wenn Sie Windows 98 oder Windows NT auf Ihrem Computer installiert haben, können Sie Microsoft Personal Web Server von der Produkt-CD installieren.
    • Wenn Sie Windows 95 auf Ihrem Computer installiert haben, können Sie Microsoft Personal Web Server aus Windows NT 4.0 Option Pack installieren. Sie können das Option Pack von der Microsoft Website downloaden.
  2. Nachdem Sie einen Server auf Ihrem Computer installiert haben, führen Sie Fpsrvadm aus, das Dienstprogramm zur Verwaltung der FrontPage Servererweiterungen, um Ihren Server für die Verwendung der Servererweiterungen zu konfigurieren. Wenn Ihr Server Windows NT Internet Information Server (IIS) ist, können Sie stattdessen FrontPage Microsoft Management Console (MMC) als Snap-In verwenden.

Anmerkungen

  • Wenn Sie diese Prozedur abgeschlossen haben, erstellt FrontPage standardmäßig serverbasierte Webs. Sie können weiterhin festplattenbasierte Webs öffnen und speichern, die Sie möglicherweise erstellt haben, bevor Sie Ihren Computer als Server konfiguriert haben. Um ein festplattenbasiertes Web in ein serverbasiertes Web umzuwandeln, veröffentlichen Sie das festplattenbasierte Web auf dem URL Ihres Servers.
  • Informationen über die Installation und Verwaltung der FrontPage Servererweiterungen erhalten Sie im FrontPage Server Extensions Resource Kit. Wenn die FrontPage Servererweiterungen auf Ihrem Computer installiert sind, können sie auf das Resource Kit standardmäßig auch über C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\Default.htm zugreifen. (Der Ordner nnnn ist nummerisch benannt nach der Sprache, in der Sie die FrontPage Servererweiterungen installiert haben. Bei einer Installation in US Englisch lautet zum Beispiel der Pfad C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1033\Default.htm).


Testen der Netzwerkverbindung

Wenn Sie Probleme mit dem Zugriff auf oder dem Öffnen von Webs auf einem Server haben, können Sie Ihre Netzwerkverbindung testen, um den Hostnamen, den Localhost, die IP-Adresse, das TCP/IP-Stack und die Winsock-Protokolleinstellungen zu ermitteln.

  1. Klicken Sie im Menü Hilfe auf Info, und klicken Sie dann auf Netzwerktest.
  2. Klicken Sie auf Test beginnen.


Aktivieren oder Deaktivieren der FrontPage-Servererweiterungen

Wenn ein Web serverbasiert ist, und der Server die Microsoft FrontPage-Servererweiterungen verwendet, können Sie die Funktionalität des Webs erweitern, indem Sie Seitenelemente wie Zugriffszähler, Suchformulare und Bestätigungsfelder hinzufügen. Um die Kompatibilität mit Servern sicherzustellen, die nicht die FrontPage-Servererweiterungen verwenden, können Sie Befehle, die auf dem Vorhandensein der Servererweiterungen auf dem Server beruhen, aktivieren oder deaktivieren. Wenn Sie die Servererweiterungen für ein Web deaktivieren, stehen die damit verbundenen Befehle zum Zeitpunkt der Erstellung in den FrontPage-Menüs nicht zur Verfügung (d. h. sie sind ausgeblendet).

  1. Zeigen Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte Kompatibilität.
  2. Wenn Sie Ihr Web für einen Server einrichten möchten, der die FrontPage-Servererweiterungen verwendet, aktivieren Sie das Kontrollkästchen Mit Microsoft FrontPage-Servererweiterungen.

    3. Anmerkung Wenn der Server die FrontPage-Servererweiterungen nicht verwendet, und Sie dieses Kontrollkästchen deaktivieren, stehen die folgenden Befehle nicht zur Verfügung:

    • Zugriffszähler (Menü Einfügen, Untermenü Komponente)
    • Bestätigungsfeld (Menü Einfügen, Untermenü Komponente)
    • Seite einschließen (Menü Einfügen, Untermenü Komponente)
    • Seite nach Zeitplan einschließen (Menü Einfügen, Untermenü Komponente)
    • Kategorien (Menü Einfügen, Untermenü Komponente)
    • Suchformular (Menü Einfügen, Untermenü Komponente)
    • Weitere Komponenten (Menü Einfügen, Untermenü Komponente)


Einstellen von Dateieigenschaften

Sie können Ihr Web effektiver verwalten, wenn Sie den Dateien detaillierte Eigenschaften hinzufügen. Sie können z. B. den Titel einer Datei ändern, einen Kommentar hinzufügen, der angibt, welche Aufgaben ausgeführt werden müssen, die Datei kategorisieren usw. Klicken Sie in einer beliebigen Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei(en), und klicken Sie dann im Kontextmenü auf Eigenschaften:

  • Zum Ändern des Titels einer Datei klicken Sie auf die Registerkarte Allgemein und geben dann in das Feld Titel einen Titel ein.
  • Zum Hinzufügen eines Kommentars zu einer Datei klicken Sie auf die Registerkarte Datei-Info und geben dann in das Feld Kommentare den gewünschten Kommentar zur Datei ein. Dateikommentare werden in mehreren Berichten in der Berichtsansicht angezeigt.
  • Zum Kategorisieren einer Datei klicken Sie auf die Registerkarte Arbeitsgruppe und aktivieren dann unter Verfügbare Kategorien die Kontrollkästchen der Kategorien, zu denen diese Datei gehört.
  • Um eine Datei einer Person oder einer Arbeitsgruppe zuzuweisen, klicken Sie auf die Registerkarte Arbeitsgruppe und geben dann in das Feld Zugewiesen die Person oder die Arbeitsgruppe ein (oder wählen Sie diese aus), der Sie die Datei zuweisen möchten.
  • Um den Prüfstatus einer Datei zu ändern, klicken Sie auf die Registerkarte Arbeitsgruppe und geben dann im Feld Prüfstatus den Prüfstatus der Datei ein (oder wählen diesen aus).
  • Um zu verhindern, dass eine Datei veröffentlicht wird, aktivieren Sie das Kontrollkästchen Diese Seite beim Veröffentlichen des Webs ausschließen.


Anzeigen von Dateiinformationen

Sie können Ihr Web effektiver verwalten, wenn Sie den Dateien detaillierte Eigenschaften hinzufügen, wie einen Titel, einen Kommentar, der angibt, welche Aufgaben ausgeführt werden müssen, usw. Verwenden Sie dieses Verfahren um detaillierte Eigenschaften und Dateiinformationen für eine Datei anzuzeigen, wie z. B. das Erstellungsdatum und wer sie erstellt hat. Klicken Sie in einer beliebigen Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Eigenschaften:

  • Zum Anzeigen der Bezeichnung und des Titels einer Datei, des Dateityps (Webseite oder Bild), der Dateigröße und der Speicherposition klicken Sie auf die Registerkarte Allgemein.
  • Zum Anzeigen des Datums an dem die Datei erstellt oder geändert wurde, und von wem sie geändert wurde, oder um die Kommentare anzuzeigen, die einer Datei hinzugefügt wurden, klicken Sie auf die Registerkarte Datei-Info.
  • Zum Anzeigen der Kategorien zu denen eine Datei gehört, des Namens der Person oder Arbeitsgruppe der eine Datei zugewiesen ist, oder des Prüf- bzw. der Veröffentlichungsstatus einer Datei, klicken Sie auf die Registerkarte Arbeitsgruppe.
  • Zum Anzeigen von Fehlern in den Komponenten einer Datei, klicken Sie auf die Registerkarte Fehler sofern sie vorhanden ist.


Hinzufügen eines Kommentars zur Datei-Info

Sie können zu jeder Datei in Ihrem Web Kommentare hinzufügen. Da die Dateikommentare für einen Sitebesucher, der Ihr Web durchsucht, unsichtbar sind, können Sie mithilfe dieser Kommentare Anmerkungen für sich selbst oder für einen Mitarbeiter über den Status einer Datei oder eine ausführlichere Beschreibung der Datei hinzufügen. Ein Webautor oder ein Webadministrator kann Ihre Kommentare in den Dateieigenschaften oder in verschiedenen Berichten in der Berichtsansicht anzeigen.

  1. Klicken Sie in jeder Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei, zu der Sie Kommentare hinzufügen möchten, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf die Registerkarte Datei-Info.
  2. Geben Sie im Feld Kommentare die Kommentare ein, die Sie hinzufügen möchten.


Erstellen eines verborgenen Ordners

Wenn Sie einen Ordner erstellen und vor den Namen eine Unterstrich setzen (z. B. _datenbank), dann ist der Ordner nur in den Ansichten von Microsoft FrontPage verborgen. Diese Ordner sind sinnvoll für Dateien die man in den Ansichten von FrontPage nicht sichtbar sein müssen; unabhängig davon kann der Inhalt dieser Ordner von Sitebesuchern, die das Web durchsuchen angezeigt werden. Wenn der Ordner in den Ansichten von FrontPage angezeigt werden soll, dann aktivieren sie das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen im Dialogfeld Webeinstellungen auf der Registerkarte Erweitert.

Wenn Sie ein neues Web erstellen, erstellt FrontPage automatisch einen verborgenen Ordner mit der Bezeichnung _private in dem Formularergebnisse gespeichert werden. Dieser verborgene Ordner, den FrontPage erstellt hat, kann von Sitebesuchern, die das Web durchsuchen nicht angezeigt werden. Um zusätzliche Ordner benötigen, die von Sitebesuchern nicht angezeigt werden können, können Sie Unterverzeichnisse unterhalb des Ordners _privateerstellen oder wenden Sie sich an den Webadministrator für Anweisungen zum Erstellen von verborgenen Ordnern.


Dateien und Ordner, die FrontPage für Ihr Web erstellt

Microsoft FrontPage erstellt für ein Web die folgenden Dateien und Ordner:

  • Den Bilderordner zum Speichern von Bildern, Videos und anderen Bildern.
  • Den Ordner _private zum Speichern von Formularergebnissen und anderen Dateien, die für Sitebesucher, die durch Ihr Web browsen, nicht sichtbar sein sollen.
  • FrontPage erstellt u. U. eine neue Homepage namens INDEX.HTM oder DEFAULT-HTM (je nach dem für das Web verwendeten Server).
  • Wenn Sie Bilddateien in Seiten einfügen, fordert FrontPage Sie beim Speichern des Webs auf, die Bilder, abhängig vom jeweiligen Format, in GIF- oder JPEG-Format zu speichern.
  • Wenn Sie das Kontrollkästchen CSS verwenden für ein einem Web zugewiesenes Design aktiviert haben, erstellt FrontPage im Stammverzeichnis Ihres Webs eine Datei namens Design1.CSS, wobei Design der Name des Designs ist.
  • Wenn Sie gemeinsam genutzte Vorlagen für ein Web erstellen, erstellt FrontPage in Ihrem Stammweb einen verborgenen Ordner namens _sharedtemplates.
  • Wenn Sie Hoverschaltflächen zu Ihren Seiten hinzufügen, erstellt FrontPage in Ihrem Stammweb Dateien namens FPHOVER.CLASS und FPHOVERX.CLASS.
  • Wenn Sie Anzeigenwechsler zu Ihren Seiten hinzufügen, erstellt FrontPage in Ihrem Stammweb Dateien namens FPROTATE.CLASS und FPROTATX.CLASS.
  • Wenn Sie Dynamisches HTML (DHTML) zum Animieren von Seitenelementen verwenden, erstellt FrontPage im Stammordner Ihres Webs eine Datei namens ANIMATE.JS.
  • Wenn Sie reduzierbare Gliederungen für Aufzählungen oder nummerierte Listen verwenden, erstellt FrontPage im Stammordner Ihres Webs eine Datei namens OUTLINE.JS.
  • Wenn Sie Datenbankfunktionalität zu einer Seite oder eine Datenverbindung zu einem Web hinzufügen, erstellt FrontPage im Stammordner Ihres Webs eine Datei namens GLOBAL.ASA. Diese Datei enthält Informationen zu den Datenverbindungen des Webs. Wenn bereits eine Datei namens GLOBAL.ASA existiert, fügt FrontPage die neuen Informationen einfach in diese Datei ein.

    • Wenn Sie eine Seite erstellen, die einen Datenbankergebnisbereich enthält, erstellt FrontPage einen Ordener namens fpclass (sofern dieser nicht bereits existiert) mit drei Dateien: FPDBLIB.INC, FPDBRGN1.INC und FPDBRGN2.INC. Diese Dateien enthalten die Active Server Pages-Skripts, die zum Implementieren der Datenbankfunktionalität auf Serverseite verwendet werden .

    Wenn Sie Formularergebnisse in eine Datenbank speichern, erstellt FrontPage einen Ordner namens _fpclass (sofern dieser nicht bereits existiert) und lädt in diesen Ordner eine Datei namens FPDBFORM.INC. Wenn Sie eine neue Datenbank für Formularergebnisse erstellen, oder wenn Sie die Beispieldatenverbindung des Datenbankergebnis-Assistenten verwenden, erstellt FrontPage einen Ordner namens Fpdb (sofern dieser nicht bereits existiert) und lädt Dateien mit der Erweiterung .MDB (Access-Datenbankdateien) in diesen Ordner.


Neuberechnen von Hyperlinks

Hyperlinks sollten in regelmäßigen Zeitabständen neu berechnet werden, wenn Sie die Anzeige der Hyperlinks im aktuellen Web aktualisieren möchten, um beispielsweise Änderungen, die in einer Umgebung mit mehreren Autoren kürzlich von anderen Autoren an einem Web vorgenommen wurden, zu übernehmen. Mit dem Neuberechnen von Hyperlinks werden auch andere Daten in FrontPage aktualisiert, beispielsweise werden nicht benötigte Designs gelöscht und Informationen von FrontPage-basierten Komponenten auf dem Server aktualisiert.

  1. Klicken Sie im Menü Extras auf Hyperlinks neu berechnen.
  2. Klicken Sie auf Ja, um den Befehl zu bestätigen.


Überprüfen von Hyperlinks

Eine der wichtigsten Aufgaben in der Verwaltung einer Website besteht darin zu überprüfen, ob Hyperlinks zu externen Zielen (zu Zielen, die sich außerhalb des Webs befinden) gültig sind. Nachdem Hyperlinks überprüft wurden, wird deren Status nicht geändert, bis Sie die Hyperlinks erneut überprüfen oder bis Sie das Web schließen und erneut öffnen.

Anmerkung Bevor Sie Hyperlinks überprüfen, sollten Sie alle geöffneten Seiten speichern.

  1. Klicken Sie in der Berichtsansicht auf der Symbolleiste Berichte auf Hyperlinks überprüfen Schaltfläche "Hyperlinks überprüfen".
  2. Klicken Sie auf Alle Hyperlinks überprüfen, und klicken Sie dann auf Beginnen.

    3. Hiermit wird der Status aller Hyperlinks im aktuellen Web angezeigt.


Korrigieren unterbrochener Hyperlinks

Bei der Bearbeitung eines Webs sollten Sie gelegentlich prüfen, ob sich im Web unterbrochene Hyperlinks befinden und diese gegebenenfalls korrigieren. Ein Hyperlink wird als unterbrochen betrachtet, wenn er über einen ungültigen Ziel-URL verfügt und einen Fehler zurückgibt, wenn der Sitebesucher hierauf klickt.

Es gibt unterschiedliche Gründe, warum ein Hyperlink möglicherweise über einen ungültigen URL verfügt; vielleicht hat sich bei der Eingabe des URLs ein Tippfehler eingeschlichen, oder wenn sich die Zielseite in einer anderen Website im World Wide Web befindet, wurde die Seite möglicherweise geändert oder entfernt.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Unterbrochene Hyperlinks.

    2. Hiermit werden alle unterbrochenen Hyperlinks im Web aufgeführt. Wenn sich das Ziel eines Hyperlinks nicht im aktuellen Web befindet, lautet der Status dieses Hyperlinks auf Unbekannt.

  2. Doppelklicken Sie auf einen Hyperlink mit dem Status Unterbrochen.
  3. Um die Seite zur Bearbeitung anzuzeigen, klicken Sie auf Seite bearbeiten.
  4. Wenn Sie den korrekten URL des Ziels kennen, bearbeiten Sie diesen im Feld Hyperlink ersetzen durch. Oder klicken Sie auf Durchsuchen, um die Seite oder Datei in einem Web, einem Dateisystem oder dem World Wide Web zu suchen.
  5. Wenn Sie alle Vorkommen dieses Hyperlinks in allen Seiten des aktuellen Webs korrigieren möchten, klicken Sie auf In allen Seiten ändern.
  6. Um andere Vorkommen dieses Hyperlinks in ausgewählten Seiten zu korrigieren, klicken Sie auf In ausgewählten Seiten ändern, und wählen Sie dann die gewünschten Seiten aus.
  7. Klicken Sie auf Ersetzen.

Wenn sich das Ziel des Hyperlinks nicht im aktuellen Web befindet, ändert sich der Status des Hyperlinks auf Unbekannt. Ist das Ziel gültig, wird der Hyperlink nicht länger im Bericht „Unterbrochene Hyperlinks“ angezeigt.


Löschen temporärer Dateien

Wenn Sie ein Web auf einem Server zum ersten Mal öffnen oder erstellen, erstellt Microsoft FrontPage auf Ihrer lokalen Festplatte temporäre Dateien, die Informationen zu den Dateien in diesem Web enthalten. Beim nächsten Öffnen des Webs sucht FrontPage in diesen temporären Dateien nach Informationen zu diesem Web, anstatt die Informationen vom Server zu holen (was das Öffnen eines umfassenden Webs deutlich verlangsamen würde).

Wenn Sie in einer Umgebung mit mehreren Webautoren arbeiten, die im gleichen Web Dateien hinzufügen, aus diesem entfernen oder umbenennen, können Ihre temporären Dateien gelegentlich nicht mehr aktuell oder nicht mehr mit den auf dem Server gespeicherten Webinformationen synchronisiert sein. Wenn dies der Fall ist, werden in Berichten u. U. nicht alle im Web enthaltenen Dateien angezeigt, oder bestimmte Hyperlinks funktionieren nicht mehr korrekt. Um dieses Problem zu beheben und Ihre lokalen temporären Dateien mit den neuesten Informationen vom Server zu synchronisieren, versuchen Sie, die nachfolgend genannten Schritte auszuführen, bis Ihre lokalen Webinformationen wieder mit dem Server synchronisiert sind.

  1. Klicken Sie auf Aktualisieren Schaltfläche "Aktualisieren".
  2. Klicken Sie im Menü Extras auf Hyperlinks neu berechnen. Dieser Vorgang kann in Webs mit vielen Hyperlinks länger dauern.
  3. Klicken Sie im Menü Extras auf Webeinstellungen und dann in der Registerkarte Erweitert auf Dateien löschen.

Anmerkung Wenn Sie temporäre Dateien für ein umfassendes Web löschen, kann das nächste Öffnen des Webs auf dem Server länger dauern, da FrontPage zum Neuerstellen Ihrer lokalen temporären Dateien Informationen vom Server kopieren muss.


Info über Sicherheit

Um mehr über Sicherheit zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Hinzufügen eines Benutzers zu einem Web und Festlegen von Berechtigungen

Ein Administrator kann Benutzer zu einem Web in FrontPage hinzufügen und eine der folgenden Berechtigungsstufen vergeben:

  • Lesen - Der Benutzer kann die Dateien im Web durchsuchen (Lesezugriff).
  • Verfassen - Der Benutzer kann die Dateien im Web durchsuchen und ändern (Lese-/Schreibzugriff).
  • Verwalten - Der Benutzer kann die Dateien im Web durchsuchen und ändern sowie das Web durch Hinzufügen und Entfernen von Benutzern verwalten (Vollzugriff).

Standardmäßig haben alle Unterwebs dieselben Berechtigungseinstellungen wie ihr übergeordnetes Web, Sie können jedoch spezielle Berechtigungen für ein Unterweb einrichten.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Wenn das Web ein Unterweb mit denselben Berechtigungen wie sein übergeordnetes Web ist, klicken Sie auf Für dieses Web einmalige Berechtigungen verwenden, und klicken Sie dann auf Übernehmen.
  3. Klicken Sie auf die Registerkarte Benutzer.
  4. Geben Sie an, ob Sie jeder Person oder nur registrierten Benutzern Lesezugriff für das Web erteilen möchten.
  5. Klicken Sie auf Hinzufügen.

    6. Danach fügen Sie die Benutzer zum Web hinzu, wobei Sie die Benutzer getrennt nach den Berechtigungen für Lesen, Verfassen und Verwalten eingeben. So fügen Sie zum Beispiel die Benutzer mit Lesezugriff getrennt von den Benutzer mit Lese-/Schreibzugriff hinzu.

  6. Falls Sie einen Windows NT Server verwenden, markieren Sie im Feld Liste beziehen von die Domäne oder Gruppe, aus der Sie Benutzer auswählen möchten.
  7. Wählen Sie in dem Feld Namen einen Benutzernamen aus oder geben Sie einen ein, und klicken Sie dann auf Hinzufügen.

    8. Wiederholen Sie die Schritte 6 und 7 für jeden Benutzer, den Sie mit einer bestimmten Zugriffsart hinzufügen möchten.

  8. Geben Sie die Zugriffsart für die Liste der Benutzer, die Sie hinzufügen, an (Lesen, Verfassen oder Verwalten), und klicken Sie dann auf OK.

    9. Dieselbe Berechtigung wird allen im Feld Namen hinzufügen aufgelisteten Benutzern erteilt. Um unterschiedliche Berechtigungen festzulegen, zum Beispiel den Lesezugriff für einen Benutzer und den Lese-/Schreibzugriff für einen anderen, wiederholen Sie die Schritte 5 bis 8 für jeden Benutzer.


Hinzufügen einer Benutzergruppe zu einem Web und Festlegen von Berechtigungen

Ein Administrator kann Benutzergruppen zu einem Web in FrontPage hinzufügen und dabei eine der folgenden Berechtigungsstufen vergeben:

  • Lesen - Die Benutzer dieser Gruppe können die Dateien im Web durchsuchen (Lesezugriff).
  • Verfassen - Die Benutzer dieser Gruppe können die Dateien im Web durchsuchen und ändern (Lese-/Schreibzugriff).
  • Verwalten - Die Benutzer dieser Gruppe können die Dateien im Web durchsuchen und ändern sowie das Web durch Hinzufügen und Entfernen von Benutzern verwalten (Vollzugriff).

Standardmäßig haben alle Unterwebs dieselben Berechtigungseinstellungen wie ihr übergeordnetes Web, Sie können jedoch spezielle Berechtigungen für ein Unterweb einrichten.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Wenn das Web ein Unterweb mit denselben Berechtigungen wie sein übergeordnetes Web ist, klicken Sie auf Für dieses Web einmalige Berechtigungen verwenden, und klicken Sie dann auf Übernehmen.
  3. Klicken Sie auf die Registerkarte Gruppen.
  4. Klicken Sie auf Hinzufügen.

    5. Danach fügen Sie die Benutzergruppen zum Web hinzu, wobei Sie die Gruppen getrennt nach den Berechtigungen für Lesen, Verfassen und Verwalten eingeben. So fügen Sie zum Beispiel die Gruppen mit Lesezugriff getrennt von den Gruppen mit Lese-/Schreibzugriff hinzu.

  5. Markieren Sie im Feld Liste beziehen von die Domäne, aus der Sie Benutzergruppen auswählen möchten.
  6. Wählen Sie in dem Feld Namen einen Gruppennamen aus oder geben Sie einen ein, und klicken Sie dann auf Hinzufügen.

    7. Wiederholen Sie die Schritte 5 und 6 für jede Gruppe, die Sie mit einer bestimmten Zugriffsart hinzufügen möchten.

  7. Geben Sie die Zugriffsart für die Liste der Gruppen, die Sie hinzufügen, an (Lesen, Verfassen oder Verwalten), und klicken Sie dann auf OK.

    8. Dieselbe Berechtigung wird allen im Feld Namen hinzufügen aufgelisteten Gruppen erteilt. Um unterschiedliche Berechtigungen festzulegen, zum Beispiel den Lesezugriff für eine Benutzergruppe und den Lese-/Schreibzugriff für eine andere, wiederholen Sie die Schritte 4 bis 7 für jede Gruppe.


Ändern von Berechtigungen für einen Benutzer

Ein Administrator kann die Berechtigung, die ein Benutzer für den Zugriff auf ein Web in FrontPage hat, ändern. Die Benutzer können eine der folgenden Berechtigungsstufen haben:

  • Lesen - Der Benutzer kann die Dateien im Web durchsuchen (Lesezugriff).
  • Verfassen - Der Benutzer kann die Dateien im Web durchsuchen und ändern (Lese-/Schreibzugriff).
  • Verwalten - Der Benutzer kann die Dateien im Web durchsuchen und ändern sowie das Web durch Hinzufügen und Entfernen von Benutzern verwalten (Vollzugriff).

Standardmäßig haben alle Unterwebs dieselben Berechtigungseinstellungen wie ihr übergeordnetes Web, Sie können jedoch spezielle Berechtigungen für ein Unterweb einrichten.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Wenn das Web ein Unterweb mit denselben Berechtigungen wie sein übergeordnetes Web ist, klicken Sie auf Für dieses Web einmalige Berechtigungen verwenden, und klicken Sie dann auf Übernehmen.
  3. Klicken Sie auf die Registerkarte Benutzer.
  4. Markieren Sie einen Benutzer, und klicken Sie dann auf Bearbeiten.
  5. Markieren Sie unter Benutzer darf die Zugriffsart, die Sie an den Benutzer vergeben möchten.


Ändern von Berechtigungen für eine Benutzergruppe

Ein Administrator kann die Berechtigung, die eine Benutzergruppe für den Zugriff auf ein Web in FrontPage hat, ändern. Die Benutzer einer Gruppe können eine der folgenden Berechtigungsstufen haben:

  • Lesen - Der Benutzer kann die Dateien im Web durchsuchen (Lesezugriff).
  • Verfassen - Der Benutzer kann die Dateien im Web durchsuchen und ändern (Lese-/Schreibzugriff).
  • Verwalten - Der Benutzer kann die Dateien im Web durchsuchen und ändern sowie das Web durch Hinzufügen und Entfernen von Benutzern verwalten (Vollzugriff).

Standardmäßig haben alle Unterwebs dieselben Berechtigungseinstellungen wie ihr übergeordnetes Web, Sie können jedoch spezielle Berechtigungen für ein Unterweb einrichten.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Wenn das Web ein Unterweb mit denselben Berechtigungen wie sein übergeordnetes Web ist, klicken Sie auf Für dieses Web einmalige Berechtigungen verwenden, und klicken Sie dann auf Übernehmen.
  3. Klicken Sie auf die Registerkarte Gruppen.
  4. Markieren Sie eine Gruppe, und klicken Sie dann auf Bearbeiten.
  5. Markieren Sie unter Benutzer darf die Zugriffsart, die Sie an den Benutzer vergeben möchten.


Entfernen eines Benutzers oder einer Benutzergruppe von einem Web

Ein Administrator kann einen Benutzer oder eine Benutzergruppe entfernen, um einen Zugriff durch sie auf ein Web in FrontPage zu verhindern.

Standardmäßig haben alle Unterwebs dieselben Berechtigungseinstellungen wie ihr übergeordnetes Web, Sie können jedoch spezielle Berechtigungen für ein Unterweb einrichten.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Berechtigungen.
  2. Wenn das Web ein Unterweb mit denselben Berechtigungen wie sein übergeordnetes Web ist, klicken Sie auf Für dieses Web einmalige Berechtigungen verwenden, und klicken Sie dann auf Übernehmen.
  3. Führen Sie einen oder mehrere der folgenden Schritte aus:
    • Um einen Benutzer zu entfernen, klicken Sie auf die Registerkarte Benutzer, klicken Sie dann in der Liste auf den entsprechenden Benutzer, und klicken Sie anschließend auf Entfernen.
    • Um eine Gruppe zu entfernen, klicken Sie auf die Registerkarte Gruppen, klicken Sie dann in der Liste auf die entsprechende Gruppe, und klicken Sie anschließend auf Entfernen.


Ändern eines Kennworts

Benutzer können ihre Kennwörter für den Zugriff auf FrontPage ändern. Dieses Funktionsmerkmal bezieht sich nur auf UNIX-Systeme, O’Reilly-Server unter Windows und Netscape-Server unter Windows.

  1. Zeigen Sie im Menü Extras auf Sicherheit, und klicken Sie dann auf Kennwort ändern.
  2. Geben Sie im Feld Altes Kennwort Ihr altes Kennwort ein.
  3. Geben Sie im Feld Neues Kennwort Ihr neues Kennwort ein, und geben Sie es dann im Feld Kennwort bestätigen noch einmal ein.


Festlegen der Standardschriftart für die Anzeige einer Sprache oder eines Zeichensatzes

Sie können die Standardschriftart für die Anzeige einer Sprache oder eines Zeichensatzes festlegen. FrontPage verwendet dann diese Standardschriftart zur Anzeige des Textes, wenn auf den Text keine Schriftart angewendet worden ist. Diese Einstellung wirkt sich nur auf die Art aus, wie Seiten in Microsoft FrontPage angezeigt, nicht wie diese in einem Webbrowser angezeigt werden.

  1. Klicken Sie im Menü Extras auf Seitenoptionen, und klicken Sie dann auf die Registerkarte Standardschriftart.
  2. Markieren Sie im Feld Sprache (Zeichensatz) die Sprache oder den Zeichensatz, für die oder den Sie eine Standardschriftart für die Anzeige festlegen möchten.
  3. Wählen Sie im Feld Standard-Proportionalschriftart eine Proportionalschriftart für die markierte Sprache oder den markierten Zeichensatz aus. Die Liste enthält alle proportionalen Schriftarten, die auf Ihrem Computer installiert sind.
  4. Wählen Sie im Feld Standardschriftart mit fester Zeichenbreite eine Schriftart mit fester Zeichenbreite für die markierte Sprache oder den markierten Zeichensatz aus (die Schriftart mit fester Zeichenbreite wird auch benutzt, um den Text auf der Registerkarte HTML in der Seitenansicht anzuzeigen). Die Liste enthält alle Schriftarten mit fester Zeichenbreite, die auf Ihrem Computer installiert sind. Wenn die markierte Sprache oder der markierte Zeichensatz keine Schriftarten mit fester Zeichenbreite unterstützt, steht diese Option nicht zur Verfügung.


Festlegen der Seitensprache

Die Codierung einer Seite kann sich auf mehrere Sprachen beziehen. So bezieht sich die Seitencodierung für „US/Westeuropäisch“ auf viele westliche Sprachen. So ist zum Beispiel Ihre Seitencodierung mehrsprachig, aber Ihre Seitensprache ist Englisch. Daher sollten Sie für Ihre Seiten die richtige Sprache angeben. Diese Einstellung legt die Sprache für die in FrontPage verwendete Rechtschreibprüfung im Hintergrund fest. Auch für fortschrittliche Suchmaschinen wird hiermit die Sprache der Seite angegeben, da Suchabfragen sich auf Inhalt in einer bestimmten Sprache beziehen können.

Wenn Sie keine Sprache angeben, ermittelt FrontPage die Sprache über Ihre Tastatur (wenn Sie eine Eingabe machen oder die Seite bearbeiten), oder aus der benutzerspezifischen Ländereinstellung auf Ihrem Computer.

Anmerkung Diese Einstellung überschreibt die Standardsprache für Rechtschreibung, die für nicht markierte Seiten verwendet wird.

  1. Klicken Sie in der Seitenansicht mit der rechten Maustaste auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Sprache.
  2. Markieren Sie im Feld Aktuelles Dokument markieren als die Sprache der Seite.


Ändern der Seitencodierung für das Speichern und Laden einer Seite

Ändern der Sprache der Seitencodierung für das Speichern und Laden einer Seite

Standardmäßig legt FrontPage die Codierung von Seiten auf der Basis Ihrer Tastatur fest, wenn Sie beginnen, etwas auf einer Seite einzugeben, oder es wird anhand der Standardcodierung des Webs ermittelt, in welchem Zeichensatz Seiten zu speichern und zu laden sind. Oder FrontPage verwendet die für Ihren Computer festgelegte Standardcodierung, wenn kein Web geöffnet ist. Sie können jedoch für einzelne Seiten eine unterschiedliche Codierung festlegen.

Speichern von Seiten

Die HTML-Codierung für das Speichern von Seiten sagt FrontPage, wie eine Seite zu speichern ist. Wenn zum Beispiel Zeichen auf einer Seite nicht durch die Standardcodierung erkannt werden, dann werden diese nicht erkannten Zeichen durch Einbetten zusätzlicher Informationen im HTML-Code der Seite gespeichert, was die Dateigröße anwachsen läßt. Während einige wenige Zeichen hierbei kein Problem bedeuten würden, werden Sie wahrscheinlich nicht wünschen, dass die Zeichen der gesamten Seite auf diese Art gespeichert werden, weswegen Sie die korrekte Codierung für die Seite angeben sollten. Wenn zum Beispiel die Standardcodierung für das Web „US/Westeuropäisch“ ist, die Seite aber mit griechischen Zeichen beschrieben ist, sollten Sie die Codierung für das Speichern der Seite auf Griechisch oder Mehrsprachig setzen.

Wenn Sie die Seite speichern, wird die von Ihnen festgelegte HTML-Seitencodierung im HTML-Code der Seite mit einbezogen, wodurch den Webbrowsern mitgeteilt wird, wie der Text auf der Seite zu lesen ist.

Aktualisieren von Seiten

Wenn der HTML-Code einer Seite keine Seitencodierung angibt, muss FrontPage die Seitencodierung erraten. Die Seite wird daher nicht korrekt angezeigt, wenn FrontPage falsch vermutet. Sie können die korrekte Codierung für das Aktualisieren der Seite festlegen.

Tipps

  • Wenn Seiten eine Mischung von Sprachen enthalten, dann ist Unicode eine adäquate Codierung: es enthält den grundlegenden lateinischen Zeichensatz, zuzüglich der Zeichen aus Sprachen aller Welt. Unicode entspricht der Mehrsprachenoption (UTF-8).
  • Um das neue Euro-Zeichen richtig anzuzeigen, muss die Seitencodierung entweder auf US/Westeuropäisch oder Unicode eingestellt sein.

Warnung! Wenn die aktuelle Seite falsch angezeigt wird, könnten Sie den Inhalt der Seite beschädigen, wenn Sie die Seite anstelle des Originals speichern.

  1. Klicken Sie in der Seitenansicht auf die Seite, klicken Sie im Kontextmenü auf Seiteneigenschaften, und klicken Sie dann auf die Registerkarte Sprache.
  2. Machen Sie unter HTML-Codierung folgendes:
    • Markieren Sie im Feld Dokument speichern als den Zeichensatz, in dem die aktuelle Seite zu speichern ist.
    • Markieren Sie im Feld Aktuelles Dokument neu laden als den Zeichensatz, in dem die aktuelle Seite zu aktualisieren ist, falls die aktuelle Seite den Text nicht korrekt anzeigt.


Festlegen der Sprache für Servermeldungen in einem Web

FrontPage ermittelt anhand der in einem Web festgelegten Sprache für Servermeldungen, in welcher Sprache bestimmte Meldungen von den FrontPage-Servererweiterungen angezeigt werden sollen. Diese Meldungen betreffen Fehler, die während der Bearbeitung einer Seite angezeigt werden, aber auch Fehler, die der Sitebesucher zu sehen bekommt, wie die Meldung über den Fehlschlag einer Suche oder eine Warnung aufgrund einer Datenprüfung. Die Servererweiterungen generieren auch HTML wie die Standardbestätigung oder Seiten mit Fehlermeldungen für Formulare in dieser Sprache.

Wenn Sie ein Web in einer anderen Sprache als die Ihres Computers erstellen, ändern Sie auch die Sprache für Servermeldungen in diesem Web. Sie können auch Unterwebs erstellen, um Ihren Inhalt nach Sprache organisieren.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Sprache.
  2. Markieren Sie im Feld Sprache für Servermeldungen die für Fehlermeldungen und HTML-Meldungen zu verwendende Sprache.


Festlegen der Standard-Seitencodierung für ein Web

FrontPage ermittelt anhand der Standard-Seitencodierung eines Webs die Sprache für neue Seiten. Auf Grund dieser Codierung wird dann festgelegt, wie eine Seite gespeichert wird. Sie können die Standard-Seitencodierung eines Webs ändern. Wenn Sie zum Beispiel Unicode vorziehen, ändern Sie die Seitencodierung in „Mehrsprachig (UTF-8)“.

Wenn Sie neue Seiten erstellen, prüft FrontPage die Standard-Seitencodierung gegenüber den Einstellungen der Tastatur. Falls Sie eine Standard-Seitencodierung festgelegt haben, die mit der Tastatur inkompatibel ist (zum Beispiel, die Standard-Seitencodierung ist „US/Westeuropäisch“, aber Sie verwenden eine griechische Tastatur), dann verwendet FrontPage stattdessen die Codierung der Tastatur für neue Seiten. Wenn Sie sich jedoch dazu entschließen, die Codierung der Tastatur zu ignorieren, vergleicht FrontPage stattdessen die Standard-Seitencodierung mit der Ihres Computers: wenn die beiden miteinander inkompatibel sind, verwendet FrontPage die Standard-Seitencodierung des Webs für neue Seiten.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Sprache.
  2. Markieren Sie im Feld Standard-Seitencodierung die gewünschte Einstellung für das aktuelle Web.
  3. Wenn Sie nicht möchten, dass FrontPage die Standard-Seitencodierung gegenüber der Tastatur prüft, aktivieren Sie das Kontrollkästchen Beim Festlegen der Codierung für neue Seiten Tastatureinstellung ignorieren.


Festlegen der Standardsprache für die Rechtschreibung in einem Web

Sie können die Sprache der standardmäßigen Rechtschreibprüfung für ein Web festlegen, und Sie können auch je nach Bedarf einzelne Seiten mit einer anderen Sprache markieren. Wenn zum Beispiel zwei Seiten in Deutsch und alle anderen in Englisch sind, dann setzen Sie die Standardsprache für die Rechtschreibung auf Englisch und markieren die zwei einzelnen Seiten als Deutsch. FrontPage wird dann für diese zwei Seiten die deutsche Rechtschreibprüfung und die englische Rechtschreibprüfung für das übrige Web verwenden.

  1. Klicken Sie im Menü Extras auf Seitenoptionen.
  2. Markieren Sie im Feld Standardsprache für Rechtschreibung auf der Registerkarte Allgemein die Standardsprache für die Rechtschreibung im aktuellen Web.


Öffnen einer Seite

Sie können eine Seite öffnen, um sie zu bearbeiten oder anzuzeigen.

  • Wenn sich die Seite im aktuellen Web befindet, doppelklicken Sie in einer beliebigen Ansicht auf das Symbol oder den Namen der Seite.
  • Wenn sich die Seite in einem anderen Web oder in Ihrem lokalen Dateisystem befindet, klicken Sie auf den Pfeil neben Öffnen Schaltfläche "Öffnen", klicken Sie auf Öffnen, wählen Sie die zu öffnende Datei aus, und klicken Sie dann auf Öffnen.


Erstellen einer neuen Seite

Erstellen Sie eine neue Seite in einem Web, oder erstellen Sie eine eigenständige HTML-Seite. Microsoft FrontPage bietet mehrere Vorlagen zum Erstellen unterschiedlicher Arten von Seiten:

  • Erstellen Sie eine leere Seite.
  • Erstellen Sie eine Seite mit einem bestimmten Layout, wie z. B. eine Seite mit mehreren Spalten.
  • Richten Sie eine Seite für eine bestimmte Funktion ein, z. B. für ein Inhaltsverzeichnis, ein Suchformular, ein Gästebuch usw.
  • Erstellen Sie eine Framesseite unter Verwendung eines von mehreren Frameformaten.
  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Seite.
  2. Klicken Sie auf die Registerkarte für die Vorlage, die Sie verwenden möchten, und klicken Sie dann auf die Vorlage. Eine Miniaturansicht oder eine Ausgabe des Assistenten wird im Bereich Vorschau angezeigt.

Tipp Klicken Sie zum Erstellen einer neuen leeren Seite basierend auf der Vorlage für eine Standardseite auf Neue Seite Schaltfläche "Neue Seite".


Öffnen eines neuen Fensters

Wenn ein Web in FrontPage geöffnet ist, können Sie ein anderes, separates FrontPage-Fenster für dasselbe Web öffnen. FrontPage unterscheidet zwischen den beiden Fenstern durch Anhängen einer Zahl nach dem Webnamen in der Anwendungstitelleiste jedes Fensters. Wenn kein Web geöffnet ist, öffnet FrontPage einfach ein anderes Fenster, ohne ein Web zu öffnen.

  • Klicken Sie im Menü Fenster auf Neues Fenster.


Abbrechen des Ladens einer Seite

Sie können das Laden einer Seite in Microsoft FrontPage abbrechen, wenn das Downloaden vom Webserver z. B. zu lange dauert.

  • Klicken Sie auf die Schaltfläche Stopp Schaltfläche "Stopp".


Rückgängig machen oder Wiederherstellen einer Aktion

Sie können eine beliebige Aktion, die Sie auf der Seite ausgeführt haben (wie z. B. Einfügen oder Ändern einer Tabelle), und außerdem auch einige Aktionen, die Sie an einem Web durchführen (wie das Löschen einer Seite aus der Struktur in der Navigationsansicht), wieder rückgängig machen. Microsoft FrontPage führt eine Liste der letzten 30 Aktionen und erlaubt das Rückgängigmachen jeder dieser Aktionen der Reihe nach. In ähnlicher Weise können Sie jede der letzten 30 Aktionen, die Sie über den Befehl Rückgängig rückgängig gemacht haben, wiederherstellen.

  • Um die letzte von Ihnen durchgeführte Aktion rückgängig zu machen, klicken Sie auf Rückgängig Schaltfläche "Rückgängig". Wenn Sie erneut auf Rückgängig klicken, macht FrontPage die Aktion rückgängig, die Sie davor ausgeführt habe, usw. nach der Liste.
  • Um eine andere Aktion oder Folge von Aktionen rückgängig zu machen, klicken Sie auf den Pfeil neben der Schaltfläche Rückgängig Schaltfläche "Rückgängig", um eine Liste der letzten Aktionen anzuzeigen, die Sie rückgängig machen können, und wählen Sie dann die Aktion(en) aus, die Sie rückgängig machen möchten.
  • Um die letzte, rückgängig gemachte Aktion wiederherzustellen, klicken Sie auf Wiederherstellen Schaltfläche "Wiederherstellen".
  • Um eine andere Aktion oder Folge von Aktionen wiederherzustellen, klicken Sie auf den Pfeil neben der Schaltfläche Wiederherstellen Schaltfläche "Wiederherstellen", um eine Liste der letzten, rückgängig gemachten Aktionen anzuzeigen, die wiederhergestellt werden können, und wählen Sie dann die rückgängig gemachte(n) Aktion(en) aus, die Sie wiederherstellen möchten.


Rückgängig machen oder Wiederherstellen einer Bearbeitung

Sie können eine oder mehrere Bearbeitungen, die Sie durchgeführt haben, wieder rückgängig machen. Wenn eine Aktion nicht rückgängig gemacht werden kann oder es nichts zum Rückgängigmachen gibt, dann steht der Befehl Rückgängig nicht zur Verfügung.

  1. Klicken Sie auf den Pfeil neben Rückgängig Schaltfläche "Rückgängig", um eine Liste der letzten Aktionen anzuzeigen, die rückgängig gemacht werden können, und klicken Sie dann auf die Aktion, die Sie rückgängig machen möchten. Wenn Sie eine Aktion rückgängig machen, müssen alle Aktionen, die in der Liste darüber stehen, ebenfalls rückgängig gemacht werden.
  2. Wenn Sie später entscheiden, dass Sie eine oder mehrere Aktionen doch nicht rückgängig machen möchten, klicken Sie auf den Pfeil neben Wiederherstellen Schaltfläche "Wiederherstellen", um eine Liste der letzten Aktionen anzuzeigen, die wiederhergestellt werden können, und klicken Sie dann auf die Aktion, die Sie wiederherstellen möchten. Wenn Sie eine Aktion wiederherstellen, müssen alle Aktionen, die in der Liste darüber stehen, ebenfalls wiederhergestellt werden.


Anzeigen von Informationen über das Programm und den Computer

Sie können prüfen, welche Version von Microsoft FrontPage auf Ihrem Computer installiert ist, und die Produkt-ID Ihres FrontPage-Exemplars ermitteln. Sie können auch Systeminformationen anzeigen und einen Test Ihrer Netzwerkverbindung durchführen.

  • Klicken Sie im Menü Hilfe auf Info.
  • Das Dialogfeld Info zeigt die Version und die Produkt-ID von FrontPage an.
  • Wenn Sie FrontPage zusammen mit einem serverbasierten Web verwenden, können Sie auf Netzwerktest klicken, um Ihre Netzwerkadresse, den Hostnamen, die IP-Adresse und den Localhost-Namen zu ermitteln.
  • Wenn Sie Systeminformationen ermitteln möchten, wie die Version von Windows, die RAM-Größe usw. klicken Sie auf Systeminfo.


Aktualisieren einer Seite oder einer Ansicht

Wenn Sie Microsoft FrontPage in einer Arbeitsgruppenumgebung mit mehreren Autoren verwenden oder mithilfe des Quellkontrollprojekts Dateien bei einem Server ein- und auschecken, müssen Sie eine Seite oder eine Ansicht aktualisieren, um sicherzugehen, dass Sie die neuesten Informationen haben. Wenn Sie z. B. einen Siteübersichtsbericht für Ihr Web erstellen und ein anderer Autor Seiten löscht, dann spiegelt der Bericht die letzten Änderungen erst wider, wenn die Berichtsansicht aktualisiert wird.

  • Um eine Seite oder Ansicht zu aktualisieren, klicken Sie auf Aktualisieren Schaltfläche "Aktualisieren".


Automatisches Öffnen des zuletzt bearbeiteten Webs beim Start von FrontPage

Wenn Sie feststellen, dass Sie gewöhnlich am selben Web arbeiten, bis es fertig gestellt ist, können Sie Microsoft FrontPage so einstellen, dass es beim Start automatisch das zuletzt bearbeitete Web öffnet.

  • Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Allgemein. Aktivieren Sie das Kontrollkästchen Zuletzt bearbeitetes Web automatisch öffnen.


Suchen von Text auf einer Seite

Sie können nach Text auf der aktuellen Seite suchen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an den Anfang der Seite. Oder, falls Sie den Text im HTML-Code finden möchten, klicken Sie auf die Registerkarte HTML, und bringen Sie die Einfügemarke an den Anfang der Seite.
  2. Klicken Sie im Menü Bearbeiten auf Suchen.
  3. Geben Sie im Feld Suchen nach den Text ein, nach dem Sie suchen möchten.
  4. Um nur nach Text zu suchen, wenn er mit einem ganzen Wort übereinstimmt, aktivieren Sie das Kontrollkästchen Nur ganzes Wort suchen.
  5. Um nach Text zu suchen, wenn er in der Groß-/Kleinschreibung mit dem eingegebenen Text übereinstimmt, aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten.
  6. Klicken Sie auf Weitersuchen.


Suchen und Ersetzen von Text auf einer Seite

Sie können nach einem Text auf der aktuellen Seite suchen und diesen durch einen anderen Text ersetzen.

  1. Bringen Sie in der Seitenansicht die Einfügemarke an den Anfang der Seite. Oder, falls Sie Text im HTML-Code suchen und ersetzen möchten, klicken Sie auf die Registerkarte HTML, und bringen Sie die Einfügemarke an den Anfang der Seite.
  2. Klicken Sie im Menü Bearbeiten auf Ersetzen.
  3. Geben Sie im Feld Suchen nach den Text ein, nach dem Sie suchen möchten.
  4. Geben Sie im Feld Ersetzen durch den Ersetzungstext ein.
  5. Um nur nach Text zu suchen, wenn er mit einem ganzen Wort übereinstimmt, aktivieren Sie das Kontrollkästchen Nur ganzes Wort suchen.
  6. Um nur nach Text zu suchen, wenn er in der Groß-/Kleinschreibung mit dem eingegebenen Text übereinstimmt, aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten.
  7. Führen Sie einen der folgenden Schritte durch:
    • Um nach der nächsten Textübereinstimmung zu suchen, klicken Sie auf Weitersuchen. Um diesen Text zu ersetzen, klicken Sie auf Ersetzen.
    • Um alle Vorkommen des Textes zu ersetzen, klicken Sie auf Alle ersetzen.


Tastenkombinationen

Häufig anfallende Aufgaben lassen sich schneller erledigen, wenn Sie hierfür Tastenkombinationen verwenden. Die Verfügbarkeit von Tastenkombinationen in Microsoft FrontPage ist davon abhängig, ob der Befehl, den Sie verwenden möchten, in der aktuell gewählten Ansicht verfügbar ist.

Tastenkombinationen für das Arbeiten mit Seiten
 Tastenkombinationen für das Formatieren von Text und Absätzen
Tastenkombinationen für das Bearbeiten und Verschieben von Text und Grafiken
Tastenkombinationen für das Markieren von Text und Grafiken
Tastenkombinationen für die Arbeit mit Menüs und Symbolleisten
 Tastenkombinationen für das Programmieren von Anwendungen
Tastenkombinationen für das Aufrufen der Hilfe

Tastenkombinationen für das Arbeiten mit Seiten

Zweck | Drücken Sie
Neue Seite erstellen | STRG+N
Seite öffnen | STRG+O
Auf einer Seite einen Hyperlink erstellen | STRG+K
Eine Seite in einem Webbrowser in der Vorschau betrachten | STRG+UMSCHALT+B
Seite drucken | STRG+P
Nicht druckbare Zeichen anzeigen | STRG+UMSCHALT+8
HTML-Tags anzeigen | STRG+ / (÷)
Seite aktualisieren | F5
Zwischen geöffneten Seiten wechseln | STRG+TAB (vorwärts) STRG+UMSCHALT+TAB (rückwärts)
Seite schließen | STRG+F4
Seite speichern | STRG+S
Microsoft FrontPage beenden | ALT+F4
Text auf einer Seite oder im HTML-Code suchen | STRG+F
Text auf Seiten oder im HTML-Code ersetzen | STRG+H
Die Rechtschreibung auf einer Seite prüfen | F7
Wort im Thesaurus nachschlagen | UMSCHALT+F7
Aktion abbrechen | ESC
Aktion rückgängig machen | STRG+Z oder ALT+RÜCKTASTE
Aktion wiederherstellen oder wiederholen | STRG+Y oder UMSCHALT+ALT+RÜCKTASTE

Zurück zum Anfang

Tastenkombinationen für das Formatieren von Text und Absätzen

Zweck | Drücken Sie
Schriftart ändern | STRG+UMSCHALT+A
Schriftgröße ändern | STRG+UMSCHALT+P
Fett formatieren | STRG+UMSCHALT+F
Unterstreichen | STRG+UMSCHALT+U
Kursiv formatieren | STRG+UMSCHALT+K
Hochstellen | STRG+PLUSZEICHEN
Tiefstellen | STRG+MINUSZEICHEN
Format kopieren | STRG+UMSCHALT+C
Format einfügen | STRG+UMSCHALT+V
Manuell definiertes Format entfernen | STRG+UMSCHALT+Z oder STRG+LEERTASTE
Absatz zentrieren | STRG+E
Absatz links ausrichten | STRG+L
Absatz rechts ausrichten | STRG+R
Absatz links einrücken | STRG+M
Absatz rechts einrücken | STRG+UMSCHALT+M
Formatvorlage zuweisen | STRG+UMSCHALT+S
Formatvorlage „Normal“ zuweisen | STRG+UMSCHALT+N
Formatvorlage „Überschrift 1“ zuweisen | STRG+ALT+1
Formatvorlage „Überschrift 2“ zuweisen | STRG+ALT+2
Formatvorlage „Überschrift 3“ zuweisen | STRG+ALT+3
Formatvorlage „Überschrift 4“ zuweisen | STRL+ALT+4
Formatvorlage „Überschrift 5“ zuweisen | STRG+ALT+5
Formatvorlage „Überschrift 6“ zuweisen | STRG+ALT+6
Formatvorlage „Liste“ zuweisen | STRG+UMSCHALT+L

Zurück zum Anfang

Tastenkombinationen für das Bearbeiten und Verschieben von Text und Grafiken

Zweck | Drücken Sie
Ein Zeichen nach links löschen | RÜCKTASTE
Ein Zeichen nach rechts löschen | ENTF
Ein Wort nach links löschen | STRG+RÜCK
Ein Wort nach rechts löschen | STRG+ENTF
Markierten Text ausschneiden und in der Zwischenablage speichern | STRG+X oder UMSCHALT+ENTF
Text oder Grafiken kopieren | STRG+C oder STRG+EINFG
Inhalt der Zwischenablage einfügen | STRG+V oder UMSCHALT+EINFG
Zeilenumbruch einfügen | UMSCHALT+EINGABE
Geschütztes Leerzeichen einfügen | STRG+UMSCHALT+LEERTASTE

Zurück zum Anfang

Tastenkombinationen zum Markieren von Text und Grafiken

Zum Erweitern einer Markierung | Drücken Sie
um ein Zeichen nach rechts | UMSCHALT+NACH-RECHTS
um ein Zeichen nach links | UMSCHALT+NACH-LINKS
bis zum Ende eines Wortes | STRG+UMSCHALT+NACH-RECHTS
bis zum Ende einer Zeile | UMSCHALT+ENDE
bis zum Anfang einer Zeile | UMSCHALT+POS1
um eine Zeile nach unten | UMSCHALT+NACH-UNTEN
um eine Zeile nach oben | UMSCHALT+NACH-OBEN
bis zum Ende eines Absatzes | STRG+UMSCHALT+NACH-UNTEN
bis zum Anfang eines Absatzes | STRG+UMSCHALT+NACH-OBEN
um eine Bildschirmseite nach unten | UMSCHALT+BILD-AB
um eine Bildschirmseite nach oben | UMSCHALT+BILD-AUF
über die gesamte Seite | STRG+A
Die Eigenschaften einer Markierung anzeigen | ALT+EINGABE
Eine Tabelle einfügen | UMSCHALT+STRG+ALT+T
Den Inhalt der nächsten Zelle markieren | TAB
Den Inhalt der vorherigen Zelle markieren | UMSCHALT+TAB
Eine Markierung auf benachbarte Zellen ausdehnen | Halten Sie die UMSCHALTTASTE gedrückt, und drücken Sie wiederholt die entsprechende Pfeiltaste
Eine Spalte markieren | Klicken Sie in die obere oder untere Zelle einer Spalte, halten Sie die UMSCHALTTASTE gedrückt, und drücken Sie dann wiederholt die NACH-UNTEN- oder NACH-OBEN-TASTE

Zurück zum Anfang

Tastenkombinationen für die Arbeit mit Menüs und Symbolleisten

Zweck | Drücken Sie
Kontextmenü anzeigen | UMSCHALT+F10
Menüleiste aktivieren | F10
Programmsymbolmenü anzeigen | ALT+LEERTASTE
Den nächsten oder den vorherigen Befehl in einem Menü oder Untermenü wählen | NACH-UNTEN-TASTE oder NACH-OBEN-TASTE (bei angezeigtem Menü oder Untermenü)
Sichtbares Menü und Untermenü gleichzeitig schließen | ALT
Sichtbares Menü schließen; oder, bei sichtbarem Untermenü, nur Untermenü schließen | ESC
AutoMiniaturansicht eines markierten Bildes erstellen | STRG+T

Zurück zum Anfang

Tastenkombinationen zum Programmieren von Anwendungen

Zweck | Drücken Sie
Makros anzeigen, bearbeiten oder ausführen | ALT+F8
Microsoft Script Editor anzeigen | UMSCHALT+ALT+F11
Microsoft Visual Basic Editor anzeigen | ALT+F11

Zurück zum Anfang

Tastenkombinationen für das Aufrufen der Hilfe

Zweck | Drücken Sie
Online-Hilfe anzeigen | F1
Kontextbezogene Hilfe anzeigen | UMSCHALT+F1

Zurück zum Anfang


Wechseln der Ansichten in FrontPage

Die Ansichtenleiste, die standardmäßig links vom Arbeitsbereich von Microsoft FrontPage angezeigt wird, erlaubt das schnelle Wechseln von einer Ansicht Ihres Webs in die andere. Um z. B. die Berichte über Ihr Web anzuzeigen, klicken Sie auf der Ansichtenleiste auf das Symbol Berichte. Um Seiten anzuzeigen oder zu bearbeiten, klicken Sie auf das Symbol Seite.

Sie können die Ansichten auch wechseln, indem Sie im Menü Ansicht auf die gewünschte Ansicht klicken.


Wechseln der Registerkarten in der Seitenansicht

Wenn Sie eine Seite in der Seitenansicht bearbeiten, können Sie über die Registerkarte Normal die Seite auf WYSIWYG-Art bearbeiten, über die Registerkarte HTML direkt HTML schreiben oder über die Registerkarte Vorschau eine Vorschau auf die Seite anzeigen, wie sie sich einem Sitebesucher darstellt. Wenn Sie Frames verwenden, stehen Ihnen in der Seitenansicht zwei weitere Registerkarten zur Verfügung: Ohne Frames und HTML der Framesseite. Die Registerkarte Ohne Frames zeigt die Nachricht an, die in einem Browser angezeigt wird, der keine Frames unterstützt. Die Registerkarte HTML der Framesseite zeigt den HTML-Code der Framesseite an.

  • Um zu einer anderen Registerkarte in der Seitenansicht zu wechseln, klicken Sie auf die Registerkarte. Oder drücken Sie STRG+BILD AUF oder STRG+BILD AB, um die Registerkarten mithilfe der Tastatur zu wechseln.


Anzeigen oder Verbergen der Ansichtenleiste

Die Ansichtenleiste, die standardmäßig links vom Arbeitsbereich von Microsoft FrontPage angezeigt wird, erlaubt das schnelle Wechseln von einer Ansicht Ihres Webs in die andere. Sie können die Ansichtenleiste verbergen, wenn Sie mehr Raum für die Anzeige von Seiten in der Seitenansicht, von Berichten in der Berichtsansicht usw. wünschen.

  • Um die Ansichtenleiste zu verbergen, klicken Sie auf das Menü Ansicht und dann auf Ansichtenleiste, um das Häkchen zu deaktivieren.
  • Um die Ansichtenleiste anzuzeigen, klicken Sie auf das Menü Ansicht und dann auf Ansichtenleiste, um das Häkchen zu aktivieren.


Anzeigen kleiner Symbole auf der Ansichtenleiste

Die Ansichtenleiste, die standardmäßig links vom Arbeitsbereich von Microsoft FrontPage angezeigt wird, erlaubt das schnelle Wechseln von einer Ansicht Ihres Webs in die andere. Standardmäßig werden große Symbole auf der Ansichtenleiste angezeigt, Sie können jedoch auch kleine Symbole anzeigen, falls Sie dies vorziehen.

  • Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle der Ansichtenleiste, und klicken Sie dann im Kontextmenü auf Kleine Symbole.


Anpassen von Ansichtsoptionen

Microsoft FrontPage erlaubt Ihnen, eine Vielzahl von Optionen für den Arbeitsbereich anzupassen. Um z. B. die Zugänglichkeit für Autoren zu verbessern, können Sie große Symbole auf Symbolleisten oder Tastenabkürzungen in den Quickinfos anzeigen. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen:

  • Um große Symbole auf Symbolleisten anzuzeigen, aktivieren Sie das Kontrollkästchen Große Symbole.
  • Um die Liste der Schriftarten im Feld Zeichen in der jeweils ausgewählten Schriftart selbst anzuzeigen (z. B. Verwendung von Arial Black zur Anzeige der Schriftart Arial Black), aktivieren Sie das Kontrollkästchen Schriftartennamen in Schriftart anzeigen.
  • Um Quickinfos, mit denen Schaltflächen auf Symbolleisten beschrieben werden, wenn mit der Maus auf sie gezeigt wird, anzuzeigen, aktivieren Sie das Kontrollkästchen QuickInfo auf Symbolleisten anzeigen.
  • Um die Tastenabkürzungen für Schaltflächen auf Symbolleisten anzuzeigen, wenn Sie mit der Maus auf eine Schaltfläche zeigen, aktivieren Sie das Kontrollkästchen Tastenkombinationen in QuickInfo anzeigen.


Anpassen der Seitenansicht

Sie können die Seitenansicht anpassen, um die Ordnerliste, Absatzmarken usw. anzuzeigen oder zu verbergen.

  • Um die Ordnerliste anzuzeigen oder zu verbergen, klicken Sie im Menü Ansicht auf Ordnerliste.
  • Um Absatzmarken auf der Registerkarte Normal anzuzeigen oder zu verbergen, klicken Sie auf Alle anzeigen Schaltfläche "Alle anzeigen".
  • Um HTML-Tags um Text, Bilder und andere Seitenelemente auf der Registerkarte Normal anzuzeigen oder zu verbergen, klicken Sie im Menü Ansicht auf Tags anzeigen.


Anpassen der Navigationsansicht

Wenn Sie eine Navigationsstruktur in der Navigationsansicht erstellen, können Sie die Art und Weise anpassen, wie diese Struktur angezeigt wird.

  • Um die Ansicht zu vergrößern oder zu verkleinern, klicken Sie mit der rechten Maustaste auf ihren Hintergrund, klicken Sie im Kontextmenü auf Zoom, und klicken Sie dann auf den Prozentsatz, um den Sie vergrößern oder verkleinern möchten.
  • Um die Größe einer umfangreichen Navigationsstruktur automatisch in die Ansicht einzupassen, klicken Sie mit der rechten Maustaste auf ihren Hintergrund, zeigen Sie im Kontextmenü auf Zoom, und klicken Sie dann auf Größe anpassen.
  • Um eine Navigationsstruktur zur leichteren Betrachtung zu drehen, klicken Sie mit der rechten Maustaste auf Hintergrund der Ansicht, zeigen Sie im Kontextmenü auf Drehen.
  • Um alle Unterbäume einzublenden, so dass Sie die gesamte Navigationsstruktur sehen können, klicken Sie mit der rechten Maustaste auf den Hintergrund der Ansicht, und zeigen Sie im Kontextmenü auf Alles einblenden.
  • Um nur die Seiten in einem Unterbaum anzuzeigen, klicken Sie mit der rechten Maustaste auf eine Seite in dem Unterbaum, den Sie anzeigen möchten, und klicken Sie dann im Kontextmenü auf Nur Unterbaum anzeigen.


Anpassen der Hyperlinkansicht

Die Hyperlinkansicht bietet eine visuelle „Landkarte“ der Hyperlinks zu und von jeder Seite in einem Web. Sie können die Hyperlinkansicht so anpassen, dass Seitentitel, Verknüpfungen von und zu Bildern usw. angezeigt werden. Klicken Sie auf der Ansichtenleiste auf das Symbol Hyperlinks, um zur Hyperlinkansicht zu wechseln:

  • Um Seitentitel anstelle von Dateinamen anzuzeigen, klicken Sie mit der rechten Maustaste auf den Hintergrund, und klicken Sie im Kontextmenü auf Seitentitel, um daneben ein Häkchen anzubringen. Wenn der Befehl kein Häkchen hat, werden in der Hyperlinkansicht die Dateinamen angezeigt.
  • Um Hyperlinks von einer Seite auf Bilder anzuzeigen, klicken Sie mit der rechten Maustaste auf den Hintergrund, und klicken Sie dann im Kontextmenü auf Hyperlinks zu Bildern, um daneben ein Häkchen anzubringen. Wenn der Befehl kein Häkchen hat, werden in der Hyperlinkansicht keine Verknüpfungen zu Bildern angezeigt.
  • Um wiederholte Hyperlinks anzuzeigen (d. h. mehrere Hyperlinks auf einer Seite, die alle auf dieselbe Seite zeigen), klicken Sie mit der rechten Maustaste auf den Hintergrund, und klicken Sie dann im Kontextmenü auf Wiederholte Hyperlinks, um daneben ein Häkchen anzubringen. Wenn der Befehl kein Häkchen hat, werden in der Hyperlinkansicht keine wiederholten Hyperlinks angezeigt.
  • Um Hyperlinks auf Textmarken innerhalb derselben Seite anzuzeigen, klicken Sie mit der rechten Maustaste auf den Hintergrund, und klicken Sie dann im Kontextmenü auf Hyperlinks innerhalb der Seite, um daneben ein Häkchen anzubringen. Wenn der Befehl kein Häkchen hat, werden in der Hyperlinkansicht keine Hyperlinks auf Textmarken innerhalb derselben Seite angezeigt.
  • Um eine andere Seite oder Datei in die Mitte der Hyperlinkansicht zu bringen, klicken Sie mit der rechten Maustaste auf die Seite oder Datei, und klicken Sie dann im Kontextmenü auf In die Mitte verschieben.


Anzeigen oder Verbergen von erledigten Aufgaben in der Aufgabenansicht

Wenn der Befehl Aufgabenverlauf anzeigen nicht aktiviert ist, verbirgt Microsoft FrontPage die erledigten Aufgaben, immer wenn Sie die Aufgabenansicht aktualisieren oder zu einer anderen Ansicht wechseln.

  • Um die erledigten Aufgaben anzuzeigen, klicken Sie mit der rechten Maustaste auf den Hintergrund in der Aufgabenansicht, und klicken Sie dann im Kontextmenü auf Aufgabenverlauf anzeigen.
  • Um die erledigten Aufgaben zu verbergen, wenn der Befehl Aufgabenverlauf anzeigen aktiviert ist, klicken Sie erneut auf Aufgabenverlauf anzeigen, um das Aktivierungshäkchen wieder zu entfernen.


Sortieren der Aufgabenliste

Sie können die Aufgaben nach Priorität, Status oder einer anderen Spalte in der Aufgabenliste sortieren.

  • Klicken Sie in der Aufgabenansicht auf eine Spaltenüberschrift, um die Aufgabenansicht nach den Werten dieser Spalte zu sortieren.
  • Klicken Sie ein zweites Mal auf die Spaltenüberschrift, um die Sortierreihenfolge umzukehren.


Anzeigen oder Verbergen von Gitterlinien in Berichten

  • Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Berichtsansicht. Aktivieren oder deaktivieren Sie das Kontrollkästchen Gitterlinien in den Berichtsansichten anzeigen.


Automatische Rechtschreibprüfung während der Eingabe

Sie können Microsoft FrontPage Ihre Rechtschreibung bei der Eingabe automatisch prüfen lassen. Falsch geschriebene Wörter werden mit einer Wellenlinie unterstrichen. Sie können die Anzeige der Rechtschreibfehler auch verbergen (d. h. die roten Wellenlinien werden nicht angezeigt). So können Sie z. B. die Rechtschreibfehler bis zum Ende der Seitenbearbeitung verbergen und dann anzeigen, wenn Sie bereit sind, sie zu verbessern.

  1. Klicken Sie im Menü Extras auf Seitenoptionen.
  2. Aktivieren Sie das Kontrollkästchen Rechtschreibung während der Eingabe prüfen auf der Registerkarte Allgemein.
  3. Wenn Sie nicht möchten, dass falsch geschriebene Wörter unterstrichen werden, aktivieren Sie das Kontrollkästchen Rechtschreibfehler in allen Dokumenten ausblenden.


Hinzufügen eines Webs oder einer Seite zur Favoritenliste

Sie können ein Web oder eine Seite zur Favoritenliste von Internet Explorer hinzufügen, wenn Sie das Web oder die Seite über Microsoft FrontPage öffnen oder speichern.

  • Klicken Sie in den Dialogfeldern Öffnen oder Speichern, die angezeigt werden, wenn Sie eine Seite öffnen oder speichern, oder wenn Sie ein Web öffnen, auf Extras, und klicken Sie dann auf Zu Favoriten hinzufügen.


Ein- oder Ausblenden von Dateien in verborgenen Ordnern

Der Inhalt verborgener oder privater Ordner in einem Web kann von Sitebesuchern, die im Web browsen, nicht angezeigt werden. Die Namen verborgener oder privater Ordner in einem Web beginnen mit einem Unterstrich (z. B. _private). Sie können Dateien in verborgenen Ordnern für Autoren, die im Web arbeiten, ein- oder ausblenden.

  1. Klicken Sie im Menü Extras auf Webeinstellungen und dann auf die Registerkarte Erweitert.
  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen, um Dateien in verborgenen Ordnern ein- oder auszublenden.


Anzeigen oder Verbergen der Statusleiste

Die Statusleiste am unteren Rand des Arbeitsbereichs von Microsoft FrontPage zeigt Informationen und Meldungen an. Wenn Sie z. B. in der Ordneransicht eine Datei markieren, zeigt die Statusleiste den vollen Pfad der Datei an. Wenn Sie eine Seite in der Seitenansicht öffnen, zeigt die Statusleiste Meldungen an, dass die Seite geladen wird und wie lange der Download der Seite dauert, wenn ein Sitebesucher auf diese Seite zugreift. FrontPage zeigt die Statusleiste standardmäßig an.

  • Um die Statusleiste zu verbergen, klicken Sie im Menü Extras auf Optionen, klicken Sie auf die Registerkarte Allgemein, und deaktivieren Sie dann das Kontrollkästchen Statusleiste einblenden.
  • Um die Statusleiste anzuzeigen, klicken Sie im Menü Extras auf Optionen, klicken Sie auf die Registerkarte Allgemein, und aktivieren Sie dann das Kontrollkästchen Statusleiste einblenden.


Anzeigen oder Verbergen von Rechtschreibfehlern

Wenn Sie eine Seite in der Seitenansicht bearbeiten, können Sie Microsoft FrontPage so einrichten, dass die Rechtschreibung automatisch während der Eingabe geprüft wird. Sie können auch festlegen, dass FrontPage die gefundenen Rechtschreibfehler verbirgt.

  • Klicken Sie im Menü Extras auf Seitenoptionen, klicken Sie auf die Registerkarte Rechtschreibung, und aktivieren Sie das Kontrollkästchen Rechtschreibfehler in allen Dokumenten ausblenden.


Anzeigen oder Anpassen von Symbolleisten

Symbolleisten enthalten die selben Befehle, wie sie auch in den Menüs von Microsoft FrontPage gefunden werden. Sie können Symbolleisten anzeigen oder ausblenden oder an eine beliebige Stelle im Arbeitsbereich verschieben. Sie können auch Befehle zu Symbolleisten hinzufügen oder aus ihnen entfernen oder auch eigene Symbolleisten erstellen.

  • Um eine Symbolleiste anzuzeigen oder auszublenden, zeigen Sie im Menü Ansicht auf Symbolleisten. Die Liste zeigt alle verfügbaren Symbolleisten an. Ein Häkchen neben einem Symbolleistennamen bedeutet, dass die Symbolleiste angezeigt wird. Um eine Symbolleiste anzuzeigen, deren Name kein Häkchen hat, klicken Sie auf den Namen. Um eine Symbolleiste auszublenden, klicken Sie auf den Namen der Symbolleiste, um das Häkchen zu deaktivieren.
  • Um eine Symbolleiste an eine andere Position auf dem Arbeitsbereich zu verschieben, klicken Sie auf die Titelleiste der Symbolleiste, und ziehen Sie dann die Symbolleiste bei gedrückter Maustaste an die neue Position.
  • Um die Symbolleisten Standard und Format auf der selben Zeile unterhalb der Menüs anzuzeigen, klicken Sie im Menü Extras auf Anpassen, klicken Sie auf die Registerkarte Optionen, und aktivieren Sie dann das Kontrollkästchen Standard- und Formatsymbolleiste teilen sich eine Zeile.
  • Um einen Befehl zu einer Symbolleiste aus einer anderen Symbolleiste hinzuzufügen, drücken Sie STRG, und ziehen Sie den Befehl auf die Symbolleiste.
  • Um einen Befehl zu einer Symbolleiste aus einem Menü hinzuzufügen, klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Befehle. Klicken Sie in der Liste Kategorien auf die Gruppe, die den Befehl enthält, den Sie hinzufügen möchten, und klicken Sie dann in der Liste Befehle auf den Befehl, und ziehen Sie ihn auf die Symbolleiste im Arbeitsbereich.
  • Um einen Befehl aus einer Symbolleiste zu entfernen, ziehen Sie ihn mit der Maus von der Symbolleiste, und lassen Sie die Maustaste an einer beliebigen Stelle im Arbeitsbereich los (nur nicht über einer anderen Symbolleiste).
  • Wenn Sie Befehle zu einer der standardmäßig vorhandenen Symbolleisten wie zur Symbolleiste Navigation hinzugefügt haben, können Sie den originalen Zustand der Symbolleiste wiederherstellen. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Symbolleisten. Markieren Sie im Feld Symbolleisten diejenige, die Sie wiederherstellen möchten, und klicken Sie dann auf Zurücksetzen.


Erstellen einer Symbolleiste

Wenn Sie feststellen, dass Sie gewisse Befehle öfter als andere verwenden, können Sie Ihre eigenen Symbolleisten erstellen, mit deren Hilfe Sie Ihren Arbeitsbereich in Microsoft FrontPage organisieren können.

  1. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Symbolleisten. Klicken Sie auf Neu.
  2. Geben Sie im Feld Name der Symbolleiste einen Namen für die neue Symbolleiste ein, und klicken Sie dann auf OK.

    3. FrontPage fügt die neue Symbolleiste zur Liste im Feld Symbolleisten hinzu und zeigt sie auch im Arbeitsbereich an.

  3. Klicken Sie auf die Registerkarte Befehle, und klicken Sie dann in der Liste Kategorien auf die Gruppe, die den Befehl enthält, den Sie auf der neuen Symbolleiste einfügen möchten.
  4. Klicken Sie in der Liste Befehle auf den Befehl, den Sie auf der neuen Symbolleiste einfügen möchten, und ziehen Sie ihn mit der Maus auf die im Arbeitsbereich angezeigte neue Symbolleiste.
  5. Wiederholen Sie die Schritte 3 und 4, bis Sie alle gewünschten Befehle auf der neuen Symbolleiste haben.

Tipps

  • Sie können einen Befehl zu einer Symbolleiste auch hinzufügen, indem Sie STRG drücken und den Befehl von einer anderen Symbolleiste auf die neue Symbolleiste ziehen.
  • Um eine benutzerdefinierte Symbolleiste umzubenennen oder zu löschen, klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Symbolleisten. Markieren Sie im Feld Symbolleisten die benutzerdefinierte Symbolleiste, die Sie umbenennen oder löschen möchten, und klicken Sie dann auf Umbenennen oder Löschen.


Anzeigen oder Anpassen von Menüs

Wenn Sie Microsoft FrontPage zum ersten Mal aufrufen, sehen Sie kurze Menüs, d. h. nur die grundlegenden Befehle werden in jedem Menü angezeigt. Während Sie mit dem Programm arbeiten, fügt FrontPage die von Ihnen am häufigsten benutzten Befehle zu der in den Menüs sichtbaren Sammlung hinzu.

Um nach einem Menübefehl zu suchen, der nicht sogleich angezeigt wird, klicken Sie auf den Pfeil Schaltfläche "Erweitern" in Kurzmenüs am unteren Rand eines Menüs. Dieses wird nun erweitert, um alle Befehle anzuzeigen. Sie können auf das Menü auch doppelklicken, um es zu erweitern. Wenn Sie auf einen Befehl eines erweiterten Menüs klicken, fügt FrontPage diesen Befehl zur kurzen Version des Menüs hinzu. Wenn Sie den Befehl für eine gewisse Zeit nicht verwenden, entfernt FrontPage ihn wieder aus dem Kurzmenü.

  • Um Kurzmenüs auszuschalten und immer alle Befehle in jedem Menü anzuzeigen, klicken Sie im Menü Extras auf Anpassen, klicken Sie auf die Registerkarte Optionen, und deaktivieren Sie dann das Kontrollkästchen Menüs zeigen zuletzt benutzte Befehle zuerst an.
  • Wenn Sie Kurzmenüs verwenden, können Sie festlegen, dass FrontPage die vollständigen Menüs anzeigt, wenn Sie ein Kurzmenü öffnen und ein wenig warten, bevor Sie auf einen Befehl klicken. Um dies zu erreichen, klicken Sie im Menü Extras auf Anpassen, klicken Sie auf die Registerkarte Optionen, und aktivieren Sie das Kontrollkästchen Nach kurzer Verzögerung vollständige Menüs anzeigen. Beachten Sie, dass dieses Kontrollkästchen deaktiviert (d. h. grau dargestellt) ist, wenn das Kontrollkästchen Menüs zeigen zuletzt benutzte Befehle zuerst an nicht aktiviert ist, um Kurzmenüs zu aktivieren.
  • Um die historischen Nutzungsdaten zu löschen, mit deren Hilfe FrontPage die Kurzmenüs mit den am häufigsten benutzen Befehlen aufbaut, klicken Sie im Menü Extras auf Anpassen, klicken Sie auf die Registerkarte Optionen, und klicken Sie dann auf Zurücksetzen.
  • Wenn ein Untermenü einen Ziehpunkt hat, können Sie es auf dem Bildschirm überall hin verschieben und somit eine frei verschiebbare Symbolleiste erstellen. Um das zu erreichen, zeigen Sie das Untermenü an, das Sie verschieben möchten, und ziehen Sie dann den Ziehpunkt am oberen Rand des Untermenüs mit der Maus an die neue Stelle. Verschiebbare Symbolleisten können in FrontPage aus den folgenden Untermenüs im Menü Einfügen erstellt werden:
    • Komponente
    • Formular
    • Erweitert


Animieren von Menüs

Sie können für das Öffnen von Menüs Animation verwenden. Wenn Sie auf einen Menünamen klicken oder auf diesen zeigen, kann das Menü von oben nach unten und von links nach rechts „aufklappen“, von oben nach unten „aufgleiten“ oder beide Effekte nach dem Zufallsprinzip anwenden.

  • Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf die Registerkarte Optionen. Wählen Sie in der Liste Menüanimationen die gewünschte Animation aus, oder klicken Sie auf Keine, um die Menüanimation zu deaktivieren.


Zuordnen eines Editors zu einem Dateityp

In Microsoft Windows wird jeder Dateityp (z. B. Bilddateien, wie GIFs, JPEGs und PNGs) einer Standardanwendung oder einem Editor zugeordnet. Microsoft Image Composer kann z. B. der Editor sein, der Bilddateien zugeordnet wird. Wenn Sie eine Datei zum Bearbeiten öffnen, wird diese im zugeordneten Standardeditor geöffnet.

In Microsoft FrontPage wird der Standardeditor für die meisten Dateitypen automatisch zugeordnet. Verwenden Sie das folgende Verfahren, wenn Sie einem neuen Dateityp einen Editor zuordnen möchten.

  1. Klicken Sie im Menü Extras auf Optionen, auf die Registerkarte Editoren konfigurieren und dann auf Hinzufügen.
  2. Geben Sie in das Feld Dateityp die 3 Zeichen lange Erweiterung des Dateityps ein, den Sie hinzufügen möchten, wie z. B. avi für audiovisuelle Dateien.
  3. Geben Sie in das Feld Editorname den Namen des Editors ein, den FrontPage zum Öffnen von Dateien dieses Typs verwenden soll.
  4. Geben Sie in das Feld Befehl den Pfad zur ausführbaren Datei (.EXE) für den Editor ein, oder klicken Sie auf Durchsuchen, um die Datei zu suchen.


Ändern des einem Dateityp zugeordneten Editors

In Microsoft Windows wird jeder Dateityp (z. B. Bilddateien, wie GIFs, JPEGs und PNGs) einer Standardanwendung oder einem Editor zugeordnet. Microsoft Image Composer kann z. B. der Editor sein, der Bilddateien zugeordnet wird. Wenn Sie eine Datei zum Bearbeiten öffnen, wird diese im zugeordneten Standardeditor geöffnet.

In Microsoft FrontPage wird der Standardeditor für die meisten Dateitypen automatisch zugeordnet. Verwenden Sie das folgende Verfahren, wenn Sie einen Editor für einen Dateityp ändern möchten. Sie könnten z. B. den Standardeditor für .TXT-Dateien von Editor in WordPad ändern.

  1. Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Editoren konfigurieren.
  2. Wählen Sie die Dateityp-/Editorzuordnung, die Sie ändern möchten, und klicken Sie dann auf Ändern.
  3. Geben Sie in das Feld Editorname den Namen des Editors ein, den FrontPage zum Öffnen von Dateien dieses Typs verwenden soll.
  4. Geben Sie in das Feld Befehl den Pfad zur ausführbaren Datei (.EXE) für den Editor ein, oder klicken Sie auf Durchsuchen, um die Datei zu suchen.


Entfernen der Zuordnung eines Editors zu einem Dateityp

In Microsoft Windows wird jeder Dateityp (z. B. Bilddateien, wie GIFs, JPEGs und PNGs) einer Standardanwendung oder einem Editor zugeordnet. Microsoft Image Composer kann z. B. der Editor sein, der Bilddateien zugeordnet wird. Wenn Sie eine Datei zum Bearbeiten öffnen, wird diese im zugeordneten Standardeditor geöffnet.

In Microsoft FrontPage sind die Standardeditorzuordnungen für die meisten Dateitypen bereits eingerichtet. Verwenden Sie dieses Verfahren, wenn Sie die Zuordnung eines Editors zu einem Dateityp entfernen möchten.

Anmerkung Wenn Sie die Zuordnung eines Editors zu einem Dateityp entfernen, können Sie Dateien dieses Typs während der Arbeit in FrontPage nicht mehr öffnen. Ordnen Sie daher nach dem Entfernen eines Editors dem Dateityp einen anderen Editor zu.

  1. Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Editoren konfigurieren.
  2. Wählen Sie die Dateityp-/Editorzuordnung, die Sie entfernen möchten, und klicken Sie dann auf Entfernen.


Öffnen einer Datei mit einem anderen Editor

Wenn Sie eine Datei in Microsoft FrontPage öffnen, dann wird diese mit dem Editor geöffnet, der dem entsprechenden Dateityp zugeordnet ist. Standardmäßig ist FrontPage der Editor, dem HTML-Seiten (.HTM) und Active Server Pages (.ASP), Editor ist der Standardeditor für Textdateien (.TXT), usw. Verwenden Sie dieses Verfahren um eine Datei in einem anderen Editor als dem Standardeditor, der der Datei zugeordnet ist, z. B. eine .ASP-Datei in Microsoft Visual InterDev oder eine .BMP-Datei in Microsoft Image Composer, zu öffnen.

  1. Klicken Sie in einer beliebigen Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei, und klicken Sie dann im Kontextmenü auf Öffnen mit...
  2. Wählen Sie den Editor aus mit dem Sie die Datei öffnen möchten.


Öffnen von Seiten in der Office-Anwendung, in der sie erstellt wurden

Wenn Sie eine Seite in einem Web öffnen, verwendet Microsoft FrontPage den Standardeditor, der dem Dateityp zugeordnet ist. Dabei handelt es sich für die meisten Seitentypen standardmäßig um FrontPage. Wenn Sie diese Einstellung überschreiben möchten, können Sie angeben, dass FrontPage automatisch die Seiten mit der Microsoft Office-Anwendung öffnet, die sie erstellt hat.

  • Klicken Sie im Menü Extras auf Optionen, klicken Sie auf die Registerkarte Editoren konfigurieren, und aktivieren Sie dann das Kontrollkästchen Webseiten in der Office-Anwendung öffnen, in der sie erstellt wurden.


Anzeigen einer Vorschau einer Seite in einem Webbrowser

Wenn Sie auf Ihrem Computer Microsoft Internet Explorer, Version 3.0 oder höher, installiert haben, können Sie schnell eine Vorschau der aktuellen Seite anzeigen, indem Sie in der Seitenansicht auf die Registerkarte Vorschau klicken.

Wenn Sie Microsoft Internet Explorer, Version 3.0 oder höher, nicht auf Ihrem Computer installiert haben, zeigt FrontPage die Registerkarte Vorschau nicht an. Klicken Sie in diesem Fall stattdessen in der Seitenansicht auf Vorschau in Browser Schaltfläche "Vorschau in Browser".


Automatisches Speichern von Seiten vor der Anzeige einer Vorschau in einem Browser

Bevor Sie die Vorschau einer Seite in der korrekten Form anzeigen, wie diese sich einem Sitebesucher in einem Browser darstellt, sollten Sie die Seite zunächst speichern. Sie können Microsoft FrontPage so einrichten, dass Seiten automatisch gespeichert werden, bevor eine Vorschau angezeigt wird.

  • Klicken Sie im Menü Datei auf Vorschau in Browser, und aktivieren Sie dann das Kontrollkästchen Seite automatisch speichern.


Hinzufügen eines Webbrowsers zur Vorschauliste

Sie können mit jedem auf Ihrem Computer installierten Webbrowser eine Seitenvorschau anzeigen. Microsoft FrontPage fügt automatisch jeden auf Ihrem Computer installierten Browser zur Liste der Browser hinzu, mit denen Sie eine Seitenvorschau anzeigen können. Mithilfe des folgenden Verfahrens können Sie einen Browser manuell zur Liste hinzufügen.

  1. Öffnen Sie in der Seitenansicht die Seite, für die Sie eine Vorschau anzeigen möchten. Klicken Sie im Menü Datei auf Vorschau in Browser.
  2. Wenn der Browser, mit dem Sie die Seitenvorschau anzeigen möchten, nicht in der Liste Browser enthalten ist, klicken Sie auf Hinzufügen.

    3. Tipp Um einen Webbrowser aus der Vorschauliste zu entfernen, markieren Sie diesen und klicken dann auf Löschen.

  3. Geben Sie im Feld Name den Namen des Webbrowser so ein, wie er in der Vorschauliste angezeigt werden soll.
  4. Geben Sie im Feld Befehl den Namen und Pfad der ausführbaren Datei des Webbrowsers ein, oder klicken Sie auf Durchsuchen, um die Datei zu ermitteln.


Festlegen der Vorschaufenstergröße

Wenn Sitebesucher Ihre Seite mit einem Webbrowser anzeigen, ist der Umfang, wie viel (oder wie wenig) in dem Browserfenster angezeigt wird, abhängig von der Bildschirmauflösung seines/ihres Computers. So kann z. B. ein Besucher, der seinen Browser bei einer Auflösung von 800x600 ausführt, einen größeren Teil der Seite anzeigen als bei 640x480 Pixel. Mithilfe des folgenden Verfahrens können Sie sehen, wie die Seite jeweils angezeigt wird, wenn der Webbrowser des Sitebesuchers auf eine unterschiedliche Bildschirmauflösung eingestellt wird.

  1. Öffnen Sie in der Seitenansicht die Seite, für die Sie eine Vorschau anzeigen möchten. Klicken Sie im Menü Datei auf Vorschau in Browser.
  2. Klicken Sie unter Fenstergröße auf die Bildschirmauflösung, die Sie für die Seitenvorschau simulieren möchten. Die angezeigten Optionen spiegeln die auf Ihrem Computer verfügbaren Auflösungen wider.

    3. Tipp Klicken Sie auf Standard, um die Seitenvorschau in einem Browserfenster anzuzeigen, das die Größe der Standardauflösung Ihres Computers hat.


Verwenden eines Makros

Sie können ein Makro für Ihr Web erstellen, ausführen, bearbeiten, testen oder löschen, ohne Microsoft FrontPage zu verlassen.

  • Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Makros:
  • Um ein neues Makro zu erstellen, geben Sie im Feld Makroname einen Namen ein, und klicken Sie dann auf Erstellen. FrontPage ruft den Visual Basic Editor auf, in dem Sie das Makro erstellen können.
  • Um ein Makro auszuführen, markieren Sie es in der Liste, und klicken Sie dann auf Ausführen.
  • Um ein Makro schrittweise zu überprüfen und zu testen, markieren Sie das Makro in der Liste, und klicken Sie dann auf Schrittweise prüfen. FrontPage ruft den Visual Basic Editor auf, in dem Sie das Makro testen können.
  • Um ein Makro zu bearbeiten, markieren Sie es in der Liste, und klicken Sie dann auf Bearbeiten. FrontPage ruft den Visual Basic Editor auf, in dem Sie das Makro bearbeiten können.
  • Um ein Makro zu löschen, markieren Sie es in der Liste, und klicken Sie dann auf Löschen.


Verwenden von Visual Basic Editor

Sie können mithilfe des Visual Basic Editors Makros, Anwendungen, Steuerelemente und Formulare für ein Web erstellen. Sie können sogar Webs erstellen und deren Struktur innerhalb einer Programmumgebung ändern. So können Sie z. B. mit dem Visual Basic Editor einen neuen Ordner erstellen und diesen dann in ein Web umwandeln.

  • Zeigen Sie im Menü Extras auf Makros, und klicken Sie dann auf Visual Basic Editor.


Verwenden von Microsoft Skript-Editor

Sie können mit dem Microsoft Skript-Editor Skripts in VBScript oder JavaScript zu Ihrem Web hinzufügen.

  • Zeigen Sie im Menü Extras auf Makros, und klicken Sie dann auf Microsoft Skript-Editor.


Festlegen des Verhaltens eines Add-Ins

Add-Ins sind ergänzende Programme, die die Möglichkeiten von Microsoft FrontPage durch Hinzufügen von benutzerdefinierten Befehlen und speziellen Funktionsmerkmalen erweitern. Sie können Add-Ins von unabhängigen Softwareanbietern erhalten oder Ihre eigenen benutzerdefinierten Add-Ins schreiben. Um mehr Informationen über Add-Ins für FrontPage zu erhalten bzw. zu downloaden, besuchen Sie die Office-Aktualisierungssite.

Nachdem Sie ein Add-In auf Ihrem Computer installiert haben, können Sie mithilfe des folgenden Verfahrens das Add-In registrieren, laden oder entladen oder sein Verhalten festlegen.

  • Klicken Sie im Menü Extras auf Add-Ins.

    • Das Dialogfeld COM-Add-Ins listet alle auf Ihrem Computer installierten Add-Ins auf und gibt deren Ladeverhalten an:

    • Um ein Add-In zu laden, klicken Sie auf den entsprechenden Eintrag in der Liste der verfügbaren Add-Ins, und aktivieren Sie das Kontrollkästchen Geladen/Entladen.
    • Um ein Add-In zu entladen, klicken Sie auf den entsprechenden Eintrag in der Liste der verfügbaren Add-Ins, und deaktivieren Sie das Kontrollkästchen Geladen/Entladen.

Tipp Wenn Sie ein Add-In laden, bleibt es geladen, bis Sie FrontPage schließen oder verlassen. Wenn Ihr System langsam ausgeführt wird oder wenig Hauptspeicher frei hat, entladen Sie das Add-In wieder gemäß obiger Beschreibung.


Zuweisen einer Aufgabe

In einer Arbeitsgruppenumgebung können Sie die Arbeitsabläufe effektiver verwalten, wenn Sie verschiedenen Mitgliedern des Teams Aufgaben zuteilen. Sie können eine Aufgabe einer Person, einer Arbeitsgruppe, einem Web oder einem anderen Objekt, das Sie in der Zuweisungsliste eingeben oder auswählen können, zuweisen.

  • Sie können eine Aufgabe beim Erstellen zuweisen. Geben Sie im Dialogfeld Neue Aufgabe einen Namen im Feld Zugewiesen ein, oder wählen Sie einen aus.
  • Sie können eine Aufgabe auch zuweisen, nachdem Sie diese erstellt haben. Klicken Sie in der Aufgabenansicht auf die Zelle in der Spalte Zugewiesen der zuzuweisenden Aufgabe, klicken Sie erneut auf die Zelle, und geben Sie einen Namen ein, oder wählen Sie ihn aus. Dadurch wird eine Zuweisung, die beim Erstellen der Aufgabe vorgenommen wurde, überschrieben.

    • Anmerkung Wenn eine Aufgabe als erledigt markiert wurde, kann sie nicht erneut zugewiesen werden.

Tipp Die Zuweisungsliste wird auch in der Berichtsansicht für das Zuweisen von Dateien verwendet. Dort können Sie jemandem eine Datei zuweisen, ohne eine bestimmte Aufgabe zu erstellen.


Markieren einer Aufgabe als erledigt

Sie können auf zweierlei Weisen eine Aufgabe als erledigt markieren:

  • Klicken Sie in der Aufgabenansicht mit der rechten Maustaste auf die Aufgabe, die Sie als erledigt markieren möchten, und klicken Sie dann im Kontextmenü auf Als erledigt markieren.
  • Wenn Sie eine Aufgabe ausgeführt haben, die einer Webseite zugeordnet ist, fragt FrontPage Sie beim ersten Mal, wenn Sie die Seite in der Seitenansicht speichern, ob Sie die Aufgabe als erledigt markieren möchten. Klicken Sie auf Ja.

Anmerkung Wenn Sie nicht möchten, dass FrontPage die erledigten Aufgaben in der Aufgabenansicht verbirgt, klicken Sie mit der rechten Maustaste auf den Hintergrund der Ansicht, und klicken Sie dann im Kontextmenü auf Aufgabenverlauf anzeigen, falls nicht bereits aktiviert.


Erstellen einer Aufgabe

Ein Web kann mithilfe von Aufgaben gepflegt und verwaltet werden. Sie können Aufgaben zuweisen, mit Priorität versehen sowie mit Seiten, Bildern, Sounds, anderen Office-Dokumenten oder anderen Dateien im Web verknüpfen.

Anmerkung Wenn Sie eine Aufgabe in der Seitenansicht erstellen, während Sie eine Seite bearbeiten, wird die neue Aufgabe automatisch mit der Seite verknüpft. Um eine Aufgabe mit einer Seite oder Datei in einer anderen Ansicht zu verknüpfen, markieren Sie die Datei, und erstellen Sie dann die Aufgabe.

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Aufgabe.
  2. Geben Sie im Feld Name der Aufgabe einen Namen für die Aufgabe ein.
  3. Geben Sie im Feld Zugewiesen den Namen der betreffenden Person ein, oder wählen Sie ihn aus.
  4. Geben Sie im Feld Beschreibung eine Beschreibung der Aufgabe ein.
  5. Klicken Sie im Bereich Priorität auf ein Maß für die Priorität der Aufgabe.

Anmerkung Das Feld Assoziiert mit zeigt ggf. den Namen einer der Aufgabe zugeordneten Datei an.


Ausführen einer Aufgabe

Eine Aufgabe kann mit einer beliebigen Datei in Ihrem Web verknüpft werden: einer Webseite, einem Bild, einem Sound, einem anderen Microsoft Office-Dokument usw.

  • Klicken Sie in der Aufgabenansicht mit der rechten Maustaste auf die Aufgabe, die Sie ausführen möchten, und klicken Sie dann im Kontextmenü auf Aufgabe ausführen.

Anmerkungen

  • Wenn Sie eine Aufgabe ausführen, die einer Seite zugeordnet ist, öffnet FrontPage diese Seite in der Seitenansicht.
  • Wenn Sie eine Aufgabe ausführen, die einem anderen Dateityp zugeordnet ist, öffnet FrontPage diese Datei im ihr zugeordneten Editor (z. B. Image Composer für .gif-Dateien, Word für .doc-Dateien, Notepad für .txt-Dateien usw.).


Prioritätsvergabe an Aufgaben

  • Sie können einer Aufgabe bei ihrer Erstellung eine Priorität verleihen. Klicken Sie im Dialogfeld Neue Aufgabe unter Priorität auf Hoch, Mittel oder Niedrig.
  • Sie können einer Aufgabe nach ihrer Erstellung auch eine andere Priorität verleihen. Klicken Sie in der Aufgabenansicht auf die Zelle in der Spalte Priorität für die Aufgabe, die eine andere Priorität erhalten soll, klicken Sie erneut auf die Zelle und dann entweder auf Hoch, Mittel oder Niedrig. Dadurch wird die bei der Erstellung der Aufgabe gesetzte Priorität überschrieben.

    • Anmerkung Wenn eine Aufgabe als erledigt markiert wurde, können Sie ihre Priorität nicht mehr ändern.

Wenn Sie einer Aufgabe keine Priorität verleihen, weist FrontPage ihr standardmäßig den Wert Mittel zu.


Ändern des Namens oder der Beschreibung einer Aufgabe

  • Klicken Sie in der Aufgabenansicht auf die Zelle entweder der Spalte Aufgabe oder Beschreibung, die Sie ändern möchten, und geben Sie dann den neuen Namen oder die neue Beschreibung ein.

Anmerkung Wenn eine Aufgabe als erledigt markiert wurde, können Sie die Beschreibung der Aufgabe ändern, aber nicht mehr ihren Namen.


Löschen einer Aufgabe

Halten Sie Ihre Aufgabenliste auf dem Laufenden, indem Sie erledigte oder veraltete Aufgaben regelmäßig löschen.

  • Klicken Sie in der Aufgabenansicht mit der rechten Maustaste auf die zu löschende Aufgabe, und klicken Sie dann im Kontextmenü auf Löschen.


Hinzufügen eines Kommentars zu einer Seite

Sie können einen Kommentar zu einer Seite hinzufügen, um z. B. Informationen für einen anderen Seitenautor bereitzustellen. Ein Kommentar hat dieselben Attribute wie das aktuelle Absatzformat, wird jedoch in einer anderen Farbe angezeigt. Kommentare werden zwar beim Bearbeiten einer Seite angezeigt, sie sind jedoch nicht im Webbrowser eines Sitebesuchers zu sehen, der die Seite durchsucht.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie einen Kommentar einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Kommentar.
  3. Geben Sie den Kommentar ein.

Tipp Zum Bearbeiten eines Kommentars doppelklicken Sie auf diesen.


Zuweisen einer Datei

In einer Arbeitsgruppenumgebung können Sie effektiver steuern, wer an welcher Aufgabe arbeitet, wenn Sie Dateien unterschiedlichen Personen oder Teams zuweisen. Eine Datei kann einer Person, einer Arbeitsgruppe, einem Web oder einem anderen Objekt, die oder das Sie im Zuweisungsbericht eingeben oder auswählen können, zugewiesen werden.

Anmerkung Wenn Ihr Web Dateien enthält, die in verborgenen Ordnern gespeichert sind, werden diese Dateien nicht in den Bericht mit einbezogen. Um diese Dateien in Ihre Berichte einzuschließen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Zugewiesen.
  2. Klicken Sie in der Berichtsansicht auf die Zelle in der Spalte Zugewiesen für die Datei, die Sie zuweisen möchten, klicken Sie erneut auf die Zelle, und geben Sie dann einen Namen ein, oder wählen Sie einen aus.

Tipps

  • Sie können mehrere Dateien zugleich zuweisen. Markieren Sie im Zuweisungsbericht die Dateien, die Sie zuweisen möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und wählen Sie dann im Feld Zugewiesen die Person oder Arbeitsgruppe aus, der Sie die Dateien zuweisen möchten.
  • Der Zuweisungsbericht wird auch in der Aufgabenansicht für die Zuweisung von Aufgaben verwendet. In der Aufgabenansicht kann einer Person eine Aufgabe zugewiesen werden, ohne dass diese einer bestimmten Datei zugeordnet ist.


Kategorisieren einer Datei

Sie können ein Web effektiver verwalten, wenn Sie Seiten, Bilder oder andere Dateien in Kategorien einteilen. So könnten Sie z. B. Seiten, die noch eine Genehmigung durch den Herausgeber benötigen, in einer Kategorie mit der Bezeichnung „Herausgeber“ oder alle Dateien in Ihrem Web, die mit dem Einkauf zu tun haben, in Kategorien mit den Bezeichnungen „Katalog“ und „Produkte“ klassifizieren.

Anmerkung Wenn Ihr Web Dateien in verborgenen Ordnern enthält, werden diese Dateien nicht in diesen Bericht eingeschlossen. Um Dateien in verborgenen Ordnern in Ihre Berichte mit einzubeziehen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Erweitert, und aktivieren Sie dann das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen.

  1. Zeigen Sie im Menü Ansicht auf Berichte, und klicken Sie dann auf Kategorien.
  2. Klicken Sie mit der rechten Maustaste auf die Datei, die Sie kategorisieren möchten, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe.
  3. Aktivieren Sie im Feld Verfügbare Kategorien die Kontrollkästchen der Kategorien dieser Datei. Sie können mehrere Kategorien aktivieren.

Tipps

  • Sie können mehrere Dateien auf einmal kategorisieren. Markieren Sie im Kategorienbericht die Dateien, die Sie kategorisieren möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und aktivieren Sie dann im Feld Elemente gehören zu diesen Kategorien die Kategorien für die markierten Dateien.
  • Sie können benutzerdefinierte Kategorien für eine Arbeitsgruppe erstellen und sie als Auswahlelemente in der Liste der Hauptkategorien hinzufügen. Um die Hauptkategorieliste zu ändern, klicken Sie mit der rechten Maustaste auf eine Datei, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe. Klicken Sie auf Kategorien, und fügen Sie dann Namen zur Liste hinzu oder löschen welche aus ihr.


Erstellen einer gemeinsam genutzten Vorlage

Wenn Sie in einer Umgebung mit mehreren Autoren arbeiten, können Sie Ihre eigenen, benutzerdefinierten Dokumentvorlagen erstellen und diese mit den anderen Autoren für die Arbeit am selben Web gemeinsam nutzen. Jeder, der das Web öffnet, kann neue Seiten erstellen, die auf der gemeinsamen Dokumentvorlage basieren, welche neben den Standardvorlagen im Dialogfeld Neu aufgeführt wird.

Sie könnten z. B. alle Webseiten mit einem bestimmten Cascading Stylesheet (mit der Dateinamenerweiterung .css) verknüpfen. Sie könnten eine Dokumentvorlage mit einer Verknüpfung zur Formatvorlage erstellen und dann diese Vorlage jedem zur Verfügung zu stellen, der an dem Web arbeitet. Anstatt Verknüpfungen zu Formatvorlagen manuell zu neuen Seiten hinzuzufügen, können die Autoren neue Seiten erstellen, welche bereits die Verknüpfungen enthalten, nur durch die Verwendung der gemeinsam genutzten Dokumentvorlage.

  1. Öffnen Sie in der Seitenansicht die Seite, die Sie als gemeinsam genutzte Dokumentvorlage speichern möchten, und klicken Sie dann im Menü Datei auf Speichern unter.
  2. Klicken Sie im Feld Dateityp auf FrontPage-Vorlage (*.tem).
  3. Geben Sie im Feld Dateiname einen Dateinamen für die Vorlage ein, und klicken Sie dann auf Speichern.
  4. Geben Sie im Dialogfeld Als Vorlage speichern im Feld Titel einen benutzerfreundlichen Titel für die Vorlage ein. Dieser Titel wird in der Liste der Vorlagen auf den Registerkarten im Dialogfeld Neu angezeigt.
  5. Geben Sie im Feld Beschreibung einen Text ein, der beschreibt, was die Dokumentvorlage bewirkt. Dies ist der Text, der auf den Registerkarten im Dialogfeld Neu im Bereich Beschreibung angezeigt wird.
  6. Aktivieren Sie das Kontrollkästchen Vorlage im aktuellen Web speichern.


Löschen einer gemeinsam genutzten Vorlage

Wenn Sie in einer Umgebung mit mehreren Autoren arbeiten, können Sie Ihre eigenen, benutzerdefinierten Dokumentvorlagen erstellen und diese mit den anderen Autoren für die Arbeit am selben Web gemeinsam nutzen. Jeder, der das Web öffnet, kann neue Seiten erstellen, die auf der gemeinsamen Dokumentvorlage basieren, welche neben den Standardvorlagen im Dialogfeld Neu aufgeführt wird. Wenden Sie das nachfolgende Verfahren an, wenn Sie eine bestehende gemeinsam genutzte Dokumentvorlage löschen möchten.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Erweitert.
  2. Aktivieren Sie das Kontrollkästchen Dokumente in verborgenen Ordnern anzeigen, und klicken Sie dann auf OK.
  3. Wenn FrontPage Sie fragt, ob Sie Ihr Web aktualisieren möchten, klicken Sie auf Ja.
  4. Der Ordner _sharedtemplates wird in der Ordnerliste angezeigt.
  5. Doppelklicken Sie in der Ordnerliste auf den Ordner _sharedtemplates, um ihn zu öffnen.
  6. Je nach Typ der gemeinsam genutzten Dokumentvorlagen (Seiten ohne Frames, Frameseiten oder Cascading Stylesheets (CSS)), die Sie erstellt haben, enthält der Ordner _sharedtemplates Unterordner, die den Namen der Registerkarten im Dialogfeld Neu entsprechen. Wenn Sie z. B. eine gemeinsam genutzte Vorlage für Seiten ohne Frames mit dem Namen MeineVorlage.tem erstellt haben, wird sie in einem Unterordner mit dem Namen pages gespeichert.
  7. Doppelklicken Sie auf den Unterordner (pages, frames oder css), der die gemeinsam genutzte Dokumentvorlage enthält, die Sie löschen möchten.
  8. Klicken Sie mit der rechten Maustaste auf den Ordner, der dem Namen der gemeinsam genutzten Vorlage entspricht, die Sie löschen möchten, und klicken Sie dann im Kontextmenü auf Löschen.

    9. Wenn Sie z. B. die gemeinsam genutzte Dokumentvorlage MeineVorlage.tem löschen möchten, löschen Sie den Ordner mit dem Namen MeineVorlage.tem.

  9. Wenn FrontPage Sie fragt, ob Sie die gemeinsam genutzte Dokumentvorlage löschen möchten, klicken Sie auf Ja.

Anmerkung Dieses Verfahren löscht nur die gemeinsam genutzte Vorlage aus der Liste der für ein Web verfügbaren Dokumentvorlagen. Es löscht nicht die Kopien der gemeinsam genutzten Vorlage, die auf lokalen Computern von Autoren erstellt wurden, die vorher das Web geöffnet haben; die Vorlage wird immer noch in der Liste der Dokumentvorlagen im Dialogfeld Neu angezeigt, wenn diese Autoren neue Seiten erstellen. Um die lokalen Versionen von gemeinsam genutzten Vorlagen zu entfernen, muss jeder Autor die entsprechenden Ordner mit gemeinsam genutzten Dokumentvorlagen im Ordner Anwendungsdaten\Microsoft\FrontPage\Pages auf seinem bzw. ihrem Computer löschen. Der genaue Speicherort dieses Ordners hängt vom Betriebssystem und dem Installationsverzeichnis des jeweiligen Autors ab.


Ändern einer gemeinsam genutzen Vorlage

Wenn Sie in einer Umgebung mit mehreren Autoren arbeiten, können Sie Ihre eigenen, benutzerdefinierten Dokumentvorlagen erstellen und diese mit den anderen Autoren für die Arbeit am selben Web gemeinsam nutzen. Jeder, der das Web öffnet, kann neue Seiten erstellen, die auf der gemeinsamen Dokumentvorlage basieren, welche neben den Standardvorlagen im Dialogfeld Neu aufgeführt wird. Wenden Sie das nachfolgende Verfahren an, wenn Sie eine bestehende gemeinsam genutzte Dokumentvorlage ändern möchten.

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Seite.
  2. Klicken Sie auf die Registerkarte (Allgemein, Frameseiten oder Stylesheets), die die gemeinsam genutzte Dokumentvorlage enthält, die Sie ändern möchten, und doppelklicken Sie in der Liste der Vorlagen auf die entsprechende Dokumentvorlage.

    3. FrontPage öffnet eine neue Seite, die auf der gemeinsam genutzten Dokumentvorlage basiert.

  3. Ändern Sie die neue Seite so, dass sie dem entspricht, was die gemeinsam genutzte Dokumentvorlage enthalten soll.
  4. Klicken Sie im Menü Datei auf Speichern unter, und klicken Sie im Feld Dateityp auf FrontPage-Vorlage (*.tem).
  5. Geben Sie im Feld Dateiname einen Dateinamen für die gemeinsam genutzte Vorlage ein, und klicken Sie dann auf Speichern.
  6. Geben Sie im Dialogfeld Als Vorlage speichern im Feld Titel einen benutzerfreundlichen Titel für die Vorlage ein. Dieser Titel wird in der Liste der Vorlagen auf den Registerkarten im Dialogfeld Neu angezeigt. Sie können den selben benutzerfreundlichen Titel eingeben, den Sie vorher benutzt haben, oder einen anderen.
  7. Geben Sie im Feld Beschreibung einen Text ein, der beschreibt, was die Dokumentvorlage bewirkt. Dies ist der Text, der auf den Registerkarten im Dialogfeld Neu im Bereich Beschreibung angezeigt wird. Sie können die selbe Beschreibung eingeben, die Sie vorher benutzt haben, oder eine andere.
  8. Aktivieren Sie das Kontrollkästchen Vorlage im aktuellen Web speichern.
  9. Wenn FrontPage Sie fragt, ob Sie die bestehende Vorlage ersetzen möchten, klicken Sie auf Ja.


Ändern der Zuweisungsliste

Sie können mithilfe der Zuweisungsliste Dateien und Aufgaben zuweisen. Immer wenn eine Datei oder Aufgabe einer Person oder einer Arbeitsgruppe zugewiesen wird, wird der Name zur Zuweisungsliste hinzugefügt (falls er nicht bereits dort vorhanden ist).

  1. Klicken Sie in der Berichtsansicht mit der rechten Maustaste auf eine Datei, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf Arbeitsgruppe.
  2. Klicken Sie auf Namen, und führen Sie dann einen der folgenden Schritte durch:
    • Um einen neuen Namen hinzuzufügen, geben Sie ihn im Feld Neuer Benutzername ein, und klicken Sie dann auf Hinzufügen.
    • Um einen Namen zu löschen, markieren Sie ihn, und klicken Sie dann auf Entfernen.
    • Um das Hinzufügen oder Löschen wieder rückgängig zu machen, klicken Sie auf Zurücksetzen, um die Liste in ihrem ursprünglichen Zustand wiederherzustellen.


Ändern der Hauptkategorieliste

Sie können ein Web effektiver verwalten, wenn Sie Seiten, Bilder oder andere Dateien in Kategorien einteilen. Kategorien können dazu beitragen, verwandte Webelemente zu verfolgen, die sich in unterschiedlichen Ordnern befinden können, oder um ungleiche Elemente im selben Ordner auseinander zu halten.

Sie können z. B. eine Kategorie mit der Bezeichnung „Katalog“ erstellen und dann für diese Kategorie eine Seite im Stammweb, drei Bilddateien im Ordner images und einen akustischen Effekt im Ordner Sounds klassifizieren. Wenn Sie dann Ihr Web in der Berichtsansicht nach Kategorien anzeigen, werden alle Katalogdateien zusammen in einer Gruppe angezeigt.

  1. Klicken Sie in der Berichtsansicht mit der rechten Maustaste auf eine Datei, klicken Sie im Kontextmenü auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe.
  2. Klicken Sie auf Kategorien, und führen Sie dann einen der folgenden Schritte durch:
    • Um eine neue Kategorie hinzuzufügen, geben Sie im Feld Neue Kategorie einen Namen ein, und klicken Sie dann auf Hinzufügen.
    • Um eine Kategorie zu löschen, markieren Sie diese, und klicken Sie dann auf Entfernen.
    • Um das Hinzufügen oder Löschen rückgängig zu machen, klicken Sie auf Zurücksetzen, um die Liste in ihrem ursprünglichen Zustand wiederherzustellen.


Senden einer Kopie einer Seite in einer E-Mail-Nachricht

Sie können eine Kopie der aktuellen Seite in einer E-Mail-Nachricht verschicken. Dieses Funktionsmerkmal steht jedoch nur zur Verfügung, wenn auf Ihrem Computer Microsoft Exchange, Microsoft Outlook oder ein anderes MAPI-kompatibles (Messaging Application Programming Interface) Mail-System installiert ist.

  1. Öffnen Sie in der Seitenansicht die Seite, die Sie senden möchten.
  2. Klicken Sie im Menü Datei auf Senden.

    3. FrontPage startet Ihren E-Mail-Editor und öffnet dann eine neue Nachricht mit der aktiven Seite als Anlage.

  3. Wählen Sie die Empfänger für die E-Mail-Nachricht aus, und geben Sie einen Betreff ein.
  4. Senden Sie die Nachricht.


Festlegen des Prüfstatus einer Datei

Ein Prüfstatus hilft Ihnen dabei, den Status von Seiten, Bildern und anderen Dateien zu bezeichnen, während diese für die Veröffentlichung vorbereitet werden. So könnte z. B. „Codeprüfung“ bedeuten, dass der Code einer Active Server Page (.asp) überprüft werden muss, „Rechtliche Prüfung“ könnte bedeuten, dass eine Seite von der Rechtsabteilung begutachtet werden muss, usw.

  • Klicken Sie in einer beliebigen Ansicht mit Ausnahme der Aufgabenansicht mit der rechten Maustaste auf die Datei, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe.
  • Wählen Sie im Listenfeld Prüfstatus einen Prüfstatus aus, oder geben Sie einen neuen ein.

Tipps

  • Sie können den Prüfstatus für mehrere Dateien auf einmal festlegen. Markieren Sie die Dateien, für die Sie einen Prüfstatus festlegen möchten, klicken Sie mit der rechten Maustaste, um das Kontextmenü anzuzeigen, und klicken Sie dann auf Eigenschaften. Klicken Sie auf die Registerkarte Arbeitsgruppe, und geben Sie im Feld Prüfstatus einen Prüfstatus ein, oder wählen Sie einen aus, den Sie für die markierten Dateien festlegen möchten.
  • Sie können auch die Prüfstatusliste ändern, um die speziellen Bedingungen, die für Ihr Team oder Ihre Firma gelten, mit einzuschließen.


Ändern der Prüfstatusliste

Der Prüfstatus hilft Ihnen, den Status einer Seite zu bezeichnen, während diese vom Entwurf bis zur Veröffentlichung voranschreitet. Microsoft FrontPage stellt vier Standardprüfstatusarten (Codeprüfung, Prüfung des Inhalts, Rechtliche Prüfung und Prüfung durch Manager) zur Verfügung, Sie können jedoch Ihren eigenen Prüfstatus auf folgende Weise hinzufügen:

  1. Klicken Sie mit der rechten Maustaste auf eine beliebige Datei, klicken Sie auf Eigenschaften, und klicken Sie dann auf die Registerkarte Arbeitsgruppe.
  2. Klicken Sie auf Status, und führen Sie dann einen der folgenden Schritte durch:
    • Um einen neuen Prüfstatus hinzuzufügen, geben Sie einen Namen im Feld Neuer Prüfstatus ein, und klicken Sie dann auf Hinzufügen.
    • Um einen Status zu löschen, markieren Sie ihn, und klicken Sie dann auf Entfernen.
    • Um das Hinzufügen oder Löschen wieder rückgängig zu machen, klicken Sie auf Zurücksetzen, um die Liste in ihrem ursprünglichen Zustand wiederherzustellen.


Info über die Quellcodeverwaltung

Um mehr über die Quellcodeverwaltung zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Aktivieren der integrierten Quellcodeverwaltung

Bevor Sie mit der in FrontPage integrierten Quellcodeverwaltung arbeiten können, müssen Sie sie aktivieren. Sie können die Quellcodeverwaltung nur aktivieren, wenn Sie über Verwaltungsberechtigungen verfügen.

Informationen über das Integrieren von Visual SourceSafe in FrontPage finden Sie unter „Übersicht über die Quellcodeverwaltung der Servererweiterungen“ im Microsoft FrontPage Server Extensions Resource Kit.

Anmerkung Es empfiehlt sich, alle Dateien in Ihrem Web zu schließen, bevor Sie die Quellcodeverwaltung aktivieren.

  1. Klicken Sie im Menü Extras auf Webeinstellungen.
  2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Einchecken und Auschecken von Dokumenten benutzen.


Auschecken einer Datei

Wenn Sie eine Datei auschecken, können nur Sie die Datei ändern. Andere Autoren können die zuletzt gespeicherte Version der Datei zwar zwecks Anzeige öffnen, können jedoch keine Änderungen hieran speichern.

  • Klicken Sie in der Ordnerliste in einer beliebigen Ansicht oder in der Ordneransicht mit der rechten Maustaste auf die Datei, die Sie auschecken möchten, und klicken Sie dann im Kontextmenü auf Auschecken.

Tipp Wenn Sie den Checkoutstatus von Dateien anzeigen möchten, zeigen Sie im Menü Ansicht auf Berichte und klicken Sie dann auf Checkoutstatus.


Einchecken einer Datei

Sie können eine Datei, die Sie bearbeitet haben, einchecken. Andere Autoren können diese Datei dann auschecken und Änderungen daran vornehmen.

  1. Klicken Sie in der Seitenansicht auf Speichern Schaltfläche "Speichern", um Ihre Änderungen zu speichern.
  2. Klicken Sie in einer beliebigen Ansicht in der Ordnerliste oder in der Ordneransicht mit der rechten Maustaste auf die Datei, die Sie einchecken möchten, und klicken Sie dann im Kontextmenü auf Einchecken.

Tipp Wenn Sie den Checkoutstatus von Dateien anzeigen möchten, zeigen Sie im Menü Ansicht auf Berichte und klicken Sie dann auf Checkoutstatus.


Rückgängig machen eines Dateicheckouts

Sie können das Auschecken einer Datei rückgängig machen. Die Datei wird dann wieder eingecheckt, ohne dass die Änderungen, die seit dem letzten Auschecken vorgenomen wurden, übernommen werden.

  • Klicken Sie in einer beliebigen Ansicht in der Ordnerliste oder in der Ordneransicht mit der rechten Maustaste auf die Datei, für die Sie das Auschecken rückgängig machen möchten, und klicken Sie dann im Kontextmenü auf Rückgängig: Auschecken.

Tipp Wenn Sie den Checkoutstatus von Dateien anzeigen möchten, zeigen Sie im Menü Ansicht auf Berichte und klicken Sie dann auf Checkoutstatus.


Hinzufügen einer Office Spreadsheet-Komponente

Wenn Sie eine Kalkulationstabelle zu Ihrem Web hinzufügen möchten, können Sie eine Microsoft Office Spreadsheet-Komponente zu einer Seite hinzufügen. Anschließend können Sie die Kalkulationstabelle in der Seitenansicht direkt bearbeiten und ihre Eigenschaften einstellen, auch wenn Sie Microsoft Excel auf Ihrem Computer nicht installiert haben.

  • Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Office Spreadsheet.

Anmerkung Sobald Sie ein Office Spreadsheet zu Ihrem Web hinzufügen, müssen auf dem Computer des Sitebesuchers die Microsoft Office Web Component-Steuerelemente installiert sein um die Kalkulationstabelle anzuzeigen. (Wenn die Steuerelemente nicht installiert sind, sieht der Sitebesucher nur ein Wasserzeichen.) Ein Sitebesucher muss auf seinem Computer Microsoft Office installiert haben oder Zugriff haben auf einen Microsoft Office Installationsserver, um an die Steuerelemente zu gelangen. Wenn der Sitebesucher Zugriff auf einen Office Installationsserver hat, legen sie die Codebasis der Datei msowc.cab auf dem Server fest, beispielsweise file:\\officeinstallationsserver\msowc.cab.

  • Wenn Sie nicht voraussehen können, ob ein Sitebesucher Zugriff auf einen Office Installationsserver hat, entfernen Sie den Pfad im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement, so dass der Sitebesucher keine Fehlermeldung erhält, die darauf hinweist, dass die Steuerelemente nicht vom dem angebenen Ort installiert werden können.
  • Der Standarddateipfad für die Steuerelemente wird im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement angezeigt. Der Standarddateipfad ist der Pfad von dem Microsoft Office installiert wurde. Dieser Standarddateipfad kann in Microsoft Excel oder Microsoft Access geändert werden. Wenn in Excel oder Access Änderungen an diesem Pfad vorgenommen werden, dann übernimmt FrontPage den Pfad der in diesen Anwendungen angegeben wurde.


Hinzufügen einer Office PivotTable-Komponente

Eine Microsoft Office PivotTable-Liste ist eine interaktive Tabelle, die zusammenfassende Daten aus einer Datenbank oder einer anderen Quelle anzeigt. Wenn Sie eine PivotTable-Liste für Ihr Web erstellen möchten, können Sie eine Office PivotTable-Komponente zu einer Seite hinzufügen. Sie können die Office PivotTable dann direkt in der Seitenansicht bearbeiten und ihre Eigenschaften einstellen, auch wenn Sie Microsoft Excel nicht auf Ihrem Computer installiert haben.

  • Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Office PivotTable.

Anmerkung Sobald Sie eine Office PivotTable zu Ihrem Web hinzufügen, müssen auf dem Computer des Sitebesuchers die Microsoft Office Web Component-Steuerelemente installiert sein, um die PivotTable anzuzeigen. (Wenn die Steuerelemente nicht installiert sind, sieht der Sitebesucher nur ein Wasserzeichen.) Ein Sitebesucher muss auf seinem Computer Microsoft Office installiert haben oder Zugriff haben auf einen Microsoft Office Installationsserver, um an die Steuerelemente zu gelangen. Wenn der Sitebesucher Zugriff auf einen Office Installationsserver hat, legen sie die Codebasis der Datei msowc.cab auf dem Server fest, beispielsweise file:\\officeinstallationsserver\msowc.cab.

  • Wenn Sie nicht voraussehen können, ob ein Sitebesucher Zugriff auf einen Office Installationsserver hat, entfernen Sie den Pfad im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement, so dass der Sitebesucher keine Fehlermeldung erhält, die darauf hinweist, dass die Steuerelemente nicht vom dem angebenen Ort installiert werden können.
  • Der Standarddateipfad für die Steuerelemente wird im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement angezeigt. Der Standarddateipfad ist der Pfad von dem Microsoft Office installiert wurde. Dieser Standarddateipfad kann in Microsoft Excel oder Microsoft Access geändert werden. Wenn in Excel oder Access Änderungen an diesem Pfad vorgenommen werden, dann übernimmt FrontPage den Pfad der in diesen Anwendungen angegeben wurde.


Hinzufügen einer Office Chart-Komponente

Wenn Sie ein Diagramm für Ihr Web erstellen möchten, können Sie eine Microsoft Office Chart-Komponente zu einer Seite hinzufügen. Anschließend können Sie das Diagramm in der Seitenansicht direkt bearbeiten und seine Eigenschaften einstellen, auch wenn Sie Microsoft Excel auf Ihrem Computer nicht installiert haben.

  • Zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie dann auf Office Chart.

Anmerkung Sobald Sie ein Office Chart zu Ihrem Web hinzufügen, müssen auf dem Computer des Sitebesuchers die Microsoft Office Web Component-Steuerelemente installiert sein, um das Diagramm anzuzeigen. (Wenn die Steuerelemente nicht installiert sind, sieht der Sitebesucher nur ein Wasserzeichen.) Ein Sitebesucher muss auf seinem Computer Microsoft Office installiert haben oder Zugriff haben auf einen Microsoft Office Installationsserver, um an die Steuerelemente zu gelangen. Wenn der Sitebesucher Zugriff auf einen Office Installationsserver hat, legen sie die Codebasis der Datei msowc.cab auf dem Server fest, beispielsweise file:\\officeinstallationsserver\msowc.cab.

  • Wenn Sie nicht voraussehen können, ob ein Sitebesucher Zugriff auf einen Office Installationsserver hat, entfernen Sie den Pfad im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement, so dass der Sitebesucher keine Fehlermeldung erhält, die darauf hinweist, dass die Steuerelemente nicht vom dem angebenen Ort installiert werden können.
  • Der Standarddateipfad für die Steuerelemente wird im Feld Codequelle: im Dialogfeld Eigenschaften von ActiveX-Steuerelement angezeigt. Der Standarddateipfad ist der Pfad von dem Microsoft Office installiert wurde. Dieser Standarddateipfad kann in Microsoft Excel oder Microsoft Access geändert werden. Wenn in Excel oder Access Änderungen an diesem Pfad vorgenommen werden, dann übernimmt FrontPage den Pfad der in diesen Anwendungen angegeben wurde.


Einfügen einer Datei auf einer Seite

Sie können nahezu jede Art textbasierter Datei auf einer Seite einfügen, wie z. B. .HTM-, .ASP-, .RTF- und .TXT-Dateien, sowie beliebige Microsoft Office-Dokumente.

  1. Setzen Sie in der Seitenansicht die Einfügemarke an die Stelle, an der Sie die Datei einfügen möchten.
  2. Klicken Sie im Menü Einfügen auf Datei.
  3. Klicken Sie im Feld Dateityp auf den Dateityp, den Sie einfügen möchten.
  4. Klicken Sie im Feld Suchen in auf das Verzeichnis, den Ordner oder die Netzwerkposition, die die Datei enthält. Doppelklicken Sie in der Ordnerliste auf Ordner, bis Sie den Ordner mit der gewünschten Datei gefunden haben, und klicken Sie dann auf Öffnen.


Neuigkeiten in Microsoft FrontPage 2000

Um mehr über Microsoft FrontPage 2000 zu erfahren, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Aktualisieren auf FrontPage 2000

Wenn Sie mehr über das Aktualisieren auf Microsoft FrontPage 2000 erfahren möchten, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Erhalten von Hilfe über einzelne Befehle, Schaltflächen und Dialogfelder

Wenn Sie sich nicht sicher sind, was ein bestimmter Befehl oder eine bestimmte Schaltfläche bewirkt oder mehr über eine Option in einem Dialogfeld wissen möchten, können Sie über QuickInfos Hilfe erhalten. Hierbei wird die Information über verschiedene Elemente am Bildschirm angezeigt.

  • Um Hilfe über einen bestimmten Befehl oder eine Schaltfläche zu erhalten, klicken Sie im Menü Hilfe auf Direkthilfe, und klicken Sie dann auf das Element, über das Sie Informationen wünschen.
  • Um Hilfe über eine Dialogfeldoption zu erhalten, klicken Sie auf das Fragezeichen in der oberen rechten Ecke des Dialogfelds, und klicken Sie dann auf die Option.


Kopieren von Beispielen aus der Hilfe

Wenn Sie ein Element in einem Hilfethema zu Microsoft FrontPage sehen, das Sie gern in einer Ihrer Webseiten einfügen würden, z. B. eine Tabelle, ein Formularfeld, eine Hoverschaltfläche oder einen Animationseffekt in Dynamic HTML, dann können Sie das Element aus der Hilfe kopieren und es in der Seitenansicht in einer Seite einfügen. Sie können dann das Hilfebeispiel mit eigenen Texten, Bildern, Beschriftungen usw. anpassen.

  1. Markieren Sie im Hilfethemenfenster das Element, das Sie kopieren möchten, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Kopieren.

    2. Anmerkung Wenn das Element, das Sie kopieren möchten, eine Tabelle, ein Formularfeld, eine Hoverschaltfläche oder ein anderes Element ist, das kein Text ist, beginnen Sie die Markierung beim Text unmittelbar davor und beenden die Markierung beim Text unmittelbar danach.

  2. Öffnen Sie in der Seitenansicht die Seite, auf die Sie das Element aus der Hilfe kopieren möchten. Bringen Sie die Einfügemarke an die Stelle, wo Sie das Element einfügen möchten, klicken Sie mit der rechten Maustaste, und klicken Sie dann im Kontextmenü auf Einfügen.


Glossar

Um einen Begriff im Glossar nachzuschlagen, klicken Sie auf die Grafik.

Klicken Sie auf die Grafik, wenn Sie dieses Thema anzeigen möchten.


Info über Farben

Sie können die Farbe für viele Seitenelemente festlegen:

  • Text.
  • Hintergrund von Seiten, Tabellen und Zellen.
  • Hyperlinks.
  • Tabellenrahmen.
  • Grafische Elemente, wie horizontale Linien, gehoverte Schaltflächen und Laufschriften.

Zum Festlegen der Farbe für ein einzelnes Element ändern Sie dessen Eigenschaften. Die Farbe für einen Text ist z. B. eine Zeicheneigenschaft. Sie können die Farbe auch für mehrere Seitenelemente (Textformatvorlagen, Hintergründe, Hyperlinks oder Tabellenrahmen) gleichzeitig festlegen. Dazu verwenden Sie Designs oder Cascading Stylesheets. Diese Funktionsmerkmale erlauben das Festlegen von Farbeigenschaften für Formatvorlagen oder Seitenelemente an einer Stelle. Anschließend werden diese Einstellungen auf alle Seiten angewendet, die dieses Design oder Stylesheet verwenden. Wenn Sie z. B. die Hyperlinkfarbe eines Designs ändern, wird die Farbe der Hyperlinks auf allen Seiten, die dieses Design verwenden, automatisch aktualisiert.

Auswählen von Farben

Immer, wenn Sie eine Farbe auswählen, werden die entsprechenden Paletten für Ihre Seite angezeigt:

  • Standardfarben zeigt die Palette mit den 16 Grundfarben an.
  • Benutzerdefinierte Farben zeigt von Ihnen festgelegte benutzerdefinierte Farben an.
  • Dokumentfarben zeigt die Farben an, die auf der aktuellen Seite verwendet werden.
  • Farben des Designs zeigt die vom aktuellen Design verwendeten Farben an.
  • Mehr Farben erlaubt Ihnen, eine Farbe zu definieren.

Festlegen benutzerdefinierter Farben

Sie haben mehrere Möglichkeiten, eine benutzerdefinierte Farbe festzulegen:

  • Auswählen einer Farbe aus einer browsersicheren Palette.
  • Festlegen einer Farbe durch Eingeben eines Hexadezimalwertes.
  • Auswählen einer Farbe auf dem Bildschirm, wie z. B. einer Farbe aus einem Bild auf einer geöffneten Seite.
  • Auswählen eines Bildschirmbereichs und Erstellen eines Farbmittelwerts aus diesem Bereich.
  • Eingeben einer Wertekombination für Farbe-Sättigung-Helligkeit oder Rot-Grün-Blau.
  • Auswählen einer Farbe aus einer Farbmatrix.

Alle benutzerdefinierten Farben werden gespeichert und stehen beim nächsten Arbeiten mit Microsoft FrontPage zur Verfügung.

Weitere Informationen

Info über Designs

Arbeiten mit Cascading Stylesheets

Festlegen einer benutzerdefinierten Farbe für ein Seitenelement

Festlegen einer benutzerdefinierten Farbe für ein Design

Festlegen einer benutzerdefinierten Farbe für eine Formatvorlage


Datenbank-Grundlagen

Denken Sie bei einer Datenbank an eine erweiterte Version einer Indexkartei. Eine Mitarbeiter-Telefonliste besteht zum Beispiel aus Indexkarten, die in der alphabetischen Reihenfolge der Mitarbeiter-Nachnamen sortiert sind. Jede Karte enthält Personalnummer, Nachname und Vorname des Mitarbeiters sowie seine Telefon-Nebenstelle in der Firma.

Eine Datenbank besteht aus Tabellen; jede Tabelle besteht aus einzelnen Datensätzen.

In der Datenbankterminologie wird jede Mitarbeiterkarte Datensatz genannt. Zusammen werden alle Karten der Indexkartei Tabelle oder Datensatzquelle genannt. Jedes Element auf der Karte wird Feld genannt. Auf einer Karte in der Mitarbeiter-Telefonliste wird der Vorname als ein Feld angesehen; der Nachname als ein weiteres Feld und so weiter. In einer Datenbank sind diese Felder in zwei Bereiche aufgeteilt: die Feldbezeichnung, welche das Feld identifiziert (zum Beispiel Nachname), und der Feldwert, der die eigentlichen Daten für das Feld darstellt (zum Beispiel „Smith“).

Eine Datenbank kann mehrere Tabellen haben. Zusätzlich zur Kartei der Mitarbeiter-Telefonliste könnten Sie beispielsweise auch Karteien für Kunden und Produkte haben. Sie können diese in derselben Datenbank als weitere Tabellen speichern.

Eine Datenbank kann auch mehrere Ansichten haben. Eine Ansicht besteht wie eine Tabelle aus Datensätzen und Feldern, kann aber auch Informationen aus anderen Tabellen enthalten. In Microsoft Access wird eine Ansicht Abfrage genannt, und sie kann Parameter entgegennehmen, durch welche die angezeigten Informationen verändert werden.

In Microsoft FrontPage 2000 können Sie den neuen Datenbankergebnis-Assistent verwenden, um Seiten zu erstellen, mit deren Hilfe der Sitebesucher nach bestimmten Informationen aus der Datenbank suchen und diese anzeigen kann; bei der Mitarbeiter-Telefonliste könnte er zum Beispiel die Nebenstelle eines bestimmten Mitarbeiters nachschlagen. Sie können auch Formulare erstellen, mit denen ein Besucher Informationen in einer Datenbank eingeben kann, zum Beispiel, um sich für eine E-Mail-Liste anzumelden oder ein Produkt zu bestellen.


Verbinden mit einer Datenbank

Bevor Sie die Informationen aus einer Datenbank auf Ihren Seiten verwenden können, müssen Sie eine Datenbankverbindung herstellen. Diese gibt den Namen, Speicherort und den Typ der Datenbank, auf die Sie zugreifen möchten, zusammen mit anderen ggf. erforderlichen Parametern an.

Eine Datenbankverbindung gibt den Speicherort und den Typ der Datenbank an.

Es gibt verschiedene Arten von Datenbankverbindungen:

  • Eine dateibasierte Verbindung zu einer Datenbank in Ihrem Web, wie zum Beispiel Microsoft Access. Wenn Sie eine Access-Datenbank in Ihr Web importieren, erstellt FrontPage automatisch eine Datenbankverbindung.
  • Ein System-Datenquellenname (System-DSN, Data Source Name) auf einem Webserver. Die Datenquelle kann eine dateibasierte Datenbank oder ein Datenbank-Verwaltungssystem (Database Management System, DBMS) sein.
  • Eine Netzwerkverbindung zu einem Datenbankserver. Hierbei handelt es sich um einen Computer, der nur die Aufgabe hat, große Datenbanken zu pflegen und zu verwalten.

Sie können auch eine benutzerdefinierte Verbindung mithilfe einer Datei oder einer Zeichenfolge erstellen, die alle notwendigen Informationen enthält.

Der Datenbankergebnis-Assistent erlaubt Ihnen die Verwendung einer bestehenden Datenbankverbindung oder das Erstellen einer neuen. Sie können eine Beispieldatenbank, Nordwind GmbH, verwenden, die Ihnen dabei hilft, die Datenbankkonzepte zu verstehen und mit der Datenbank zu experimentieren, ohne dass Sie Ihre eigene „Live“-Datenbank ändern müssen.


Erstellen von Hyperlinks mit Parametern

Nachdem Sie mithilfe des Datenbankergebnis-Assistenten Datenbankergebnisse auf einer Seite erstellt haben, können Sie Hyperlinks mit Parametern erstellen; das sind Hyperlinks, die Feldwerte oder andere Datenbankparameter von einer Seite an eine andere Seite senden, die Datenbankergebnisse enthält.

Erstellen Sie einen Hyperlink, der eine andere Seite mit Datenbankergebnissen anzeigt.

So können Sie zum Beispiel in der Telefonliste der Nordwind-Mitarbeiter einen Hyperlink auf den Nachnamen von Jeff Smith erstellen. Wenn ein Sitebesucher auf den Hyperlink klickt, sendet die Seite Jeffs Personalnummer (im Beispiel eine „1“) an einen Datenbankergebnisbereich auf einer anderen Seite. Auf der Zielseite zeigt der Datenbankergebnisbereich den gesamten Inhalt (d. h. alle Felder) eines Mitarbeiterdatensatzes an. Wenn die Seite einen Parameter mit der Bezeichnung Personalnummer und dem Wert „1“ empfängt, schlägt sie diesen Datensatz in der Datenbank nach und zeigt das Ergebnis für Jeff Smith an.


Filtern und Sortieren von Datenbankergebnissen

Der Datenbankergebnis-Assistent erlaubt das Filtern der Datenbankergebnisse, das heißt, es werden nur die Datensätze angezeigt, die bestimmten Kriterien entsprechen. Sie können zum Beispiel das Nordwind-Mitarbeiterergebnis so filtern, dass nur die Datensätze von Mitarbeitern angezeigt werden, deren Nachname Smith lautet. Wenn die Seite geladen wird, durchsucht der Assistent das Feld Nachname in der Personaltabelle und zeigt dann die Datensätze der Mitarbeiter an, bei denen der Wert des Feldes Nachname gleich „Smith“ ist.

Sie können Ergebnisse so filtern, dass nur Datensätze angezeigt werden, die bestimmten Kriterien entsprechen. Sie können die Ergebnisse auch nach jedem Feld sortieren.

Sie können auch die Sortierreihenfolge für Datenbankergebnisse festlegen. So können Sie zum Beispiel die Telefonliste der Nordwind-Mitarbeiter alphabetisch nach dem Nachnamen und dann nach dem Vornamen (sofern es mehr als einen Mitarbeiter mit demselben Nachnamen gibt) sortieren. Nachdem Sie die Felder ausgewählt haben, nach denen Sie die Felder sortieren möchten, und die Reihenfolge, in der die Felder sortiert werden sollen (aufsteigend oder absteigend), zeigt der Assistent die Datenbankergebnisse dementsprechend an.


Formatieren von Datenbankergebnissen

Der Datenbankergebnis-Assistent bietet eine Vielfalt von Formatierungsoptionen für den Datenbankergebnisbereich an. Sie können die Ergebnisse als Tabelle formatieren, wobei für jeden aus der Datenbank zurückgegebenen Datensatz eine Zeile gebildet wird. Standardmäßig enthalten die Spaltenüberschriften die Feldbezeichnungen, und die Spalten enthalten die Feldwerte. In der Telefonliste der Nordwind-Mitarbeiter heißen zum Beispiel die Spaltenüberschriften Nachname, Vorname und Durchwahl Büro. Sie können Rahmenlinien für die Tabelle anzeigen oder verbergen und die Spaltenüberschriften ändern oder löschen.

Datenbankergebnisse, formatiert als Tabelle, Liste oder Dropdownliste.

Sie können die Datenbankergebnisse auch als Liste formatieren, wobei jede Zeile eine Feldbezeichnung und einen Feldwert enthält. Standardmäßig fügt der Assistent horizontale Linien zwischen den Datensätzen ein, um diese deutlicher zu unterscheiden. Sie können aus einer Vielzahl von Listenformaten auswählen, einschließlich Aufzählungslisten und nummerierte Listen.

Schließlich können Sie die Datenbankergebnisse als einfache Dropdownliste formatieren, die für jeden Datensatz die Werte eines bestimmten Feldes anzeigt. Benutzen Sie diese Option, wenn Sie eine Dropdownliste zum Formular hinzufügen möchten oder wenn Sie die Datenbankergebnisse an einer einheitlichen Stelle auf einer Seite anzeigen möchten, die absolute Positionierung oder Animationseffekte mit Dynamic HTML verwendet. Sie könnten zum Beispiel eine Dropdownliste hinzufügen, die eine Liste von Mitarbeiternachnamen in einem Adressbuch anzeigt.


Auswählen von Informationen aus einer Datenbank

Nachdem Sie sich mit einer Datenbank verbunden haben, ermittelt der Datenbankergebnis-Assistent die Namen der Tabellen und Ansichten in dieser Datenbank. In der Nordwind-Datenbank gibt es zum Beispiel Tabellen für Personal, Kunden, Artikel und so weiter.

Wählen Sie eine Tabelle aus, die Sie verwenden möchten, und wählen Sie dann die Datensätze und Felder aus, die in das Datenbankergebnis eingeschlossen werden sollen.

Nachdem Sie eine Tabelle oder Ansicht ausgewählt haben, ermittelt der Assistent die Namen der in ihr enthaltenen Felder. In der Nordwind-Personaltabelle gibt es zum Beispiel die Felder Vorname, Nachname und Durchwahl Büro. Sie können dann die Felder auswählen, welche die Informationen enthalten, die Sie in dem Datenbankergebnisbereich anzeigen möchten.

Wenn ein Sitebesucher die Seite in einem Browser anzeigt, werden die ausgewählten Felder jedes Datensatzes in der Tabelle oder Ansicht im Datenbankergebnis angezeigt. So enthält zum Beispiel das Datenbankergebnis pro Mitarbeiter in der Nordwind-Personaltabelle eine Feldbezeichnung (etwa Nachname) und einen Feldwert (etwa „Smith“).

Wenn Sie mit Anweisungen in Structured Query Language (SQL) vertraut sind, können Sie eine benutzerdefinierte Abfrage erstellen (anstatt eine Tabelle oder eine Ansicht auszuwählen) und diese vom Assistenten überprüfen lassen.


Arbeiten mit Datenbanken


Datenbank-Grundlagen
Verbinden mit einer Datenbank
Auswählen von Informationen aus einer Datenbank
Filtern und Sortieren von Datenbankergebnissen
Formatieren von Datenbankergebnissen
Erstellen von Hyperlinks mit Parametern
Den Sitebesuchern die Suche nach Informationen überlassen
Den Sitebsuchern das Hinzufügen von Informationen überlassen


Den Sitebesuchern das Hinzufügen von Informationen überlassen

Sie können Formulare erstellen, die es Sitebesuchern erlauben, Informationen zu einer Tabelle in einer Datenbank hinzuzufügen. Ein allgemeines Beispiel ist ein Auftragsformular.

Erstellen Sie Formulare (zum Beispiel Auftragsformulare), die es Sitebesuchern erlauben, Informationen zu einer Datenbank hinzuzufügen.

Ein Sitebesucher gibt seine E-Mail-Adresse, seine Lieferadresse, Kreditkarteninformationen und so weiter ein. Wenn er auf Abschicken klickt, sendet das Formular die Informationen (d. h. die Feldbezeichnungen und die Feldwerte für jedes Informationselement) an eine Datenbank, wo sie als neuer Datensatz zu einer Tabelle hinzugefügt werden. Sie können die Informationen zu einer bestehenden Datenbank hinzufügen oder FrontPage eine erstellen lassen. Der Webserver sendet eine Bestätigungsmeldung oder eine Seite zurück, womit dem Besucher mitgeteilt wird, dass die Daten akzeptiert worden sind.


Den Sitebesuchern die Suche nach Informationen überlassen

Der Datenbankergebnis-Assistent erleichtert dem Sitebesucher die Suche nach Information in der Datenbank. Der Assistent kann ein Suchformular erstellen, mit dem Datensätze gefunden werden, die bestimmten Kriterien entsprechen, sowie einen Datenbankergebnisbereich darunter, der das Ergebnis der Suche anzeigt.

Erstellen Sie ein Suchformular, um Sitebesucher eine Datenbank nach bestimmten Informationen durchsuchen zu lassen.

Wenn zum Beispiel ein Sitebesucher, der zu der Seite gelangt ist, die Nebenstelle eines Mitarbeiter in der Nordwind-Datenbank nachschlagen möchte, kann er den Nachnamen des Mitarbeiters (zum Beispiel „Smith“) im Feld Suchen nach eingeben. Wenn er auf Suche beginnen klickt, weist FrontPage die Datenbank an, die Datensätze der Mitarbeiter zu suchen, bei denen der Wert des Feldes Nachname gleich „Smith“ ist, und dann nur diese Datensätze im Datenbankergebnisbereich anzuzeigen.


1 2 3 4 5


Ein Formular ist eine Sammlung von Feldern, in denen Sie Informationen von Personen zusammenstellen, die Ihre Website besuchen. Ein Sitebesucher füllt ein Formular aus, indem er Text in Felder eingibt, Optionsfelder und Kontrollkästchen aktiviert und Einträge aus Dropdownmenüs auswählt. Nach dem Ausfüllen des Formulars schickt der Sitebesucher die Daten, die er eingegeben hat, ab. Die Daten werden abhängig von der von Ihnen eingerichteten Formularbehandlungsroutine verarbeitet.

Schritte zum Erstellen eines Formulars:

  1. Entscheiden, welche Art von Informationen gesammelt werden sollen und Starten eines Formulars.
  2. Hinzufügen von Feldern zum Formular.
  3. Einrichten von Dateneingaberegeln für Ihre Formularfelder.
  4. Einrichten von Behandlungsroutinen zur Verarbeitung der Informationen, die Sie über das Formular sammeln.
  5. Einrichten einer Bestätigungsseite.

Im ersten Schritt entscheiden Sie, welche Art von Formular Sie erstellen möchten, und welche Art von Informationen Sie mit diesem Formular zusammenstellen möchten. Formulare haben unterschiedliche Funktionen:

  • Zusammenstellen von Kontaktinformationen.
  • Empfangen von Anfragen.
  • Sammeln von Bestell-, Versand- und Rechnungsinformationen.
  • Erhalten von Feedback.
  • Einrichten eines Gästebuchs.
  • Erlauben einer Suche in Ihrer Website durch Eingeben einer Abfrage.
  • Auffordern zum Anmelden an eine Website durch Eingabe eines Benutzernamens und Kennworts.

Wenn Sie entschieden haben, welche Art von Formular Sie erstellen möchten, können Sie mit einem leeren Formular beginnen und Felder zu diesem hinzufügen oder eine Vorlage oder einen Assistenten verwenden, um das Formular automatisch zu erstellen.

Weitere Informationen

Erstellen eines Formulars

Info über Diskussionsgruppen


Der zweite Schritt beim Erstellen eines Formulars ist das Hinzufügen von Feldern zum Formular. Formularfelder sind die einzelnen Felder in einem Formular, mit deren Hilfe Informationen zusammengestellt werden. Jeder Feldtyp hat eine andere Funktionsweise. Wählen Sie daher die Felder für Ihr Formular abhängig von der Art aus, wie Besucher Informationen eingeben sollen. Experimentieren Sie mit den folgenden Feldern, um deren Funktionsweise auszuprobieren.

Einzeiliges Textfeld
Verwenden Sie einzeilige Textfelder zum Sammeln einer kleineren Textmenge, wie z. B. ein Name oder eine Zahl.

Geben Sie Ihre E-Mail-Adresse ein: 		Optionsfelder
Verwenden Sie Optionsfelder, wenn Sie möchten, dass der Sitebesucher eine Option aus einer Gruppe auswählt.

A B C
Textfeld mit Bildlauf
Verwenden Sie ein Textfeld mit Bildlauf, um eine oder mehrere Textzeilen zu sammeln, wie z. B. einen Kommentar. Dieses Feld erlaubt das Eingeben unterschiedlich großer Texte und führt dazu einen Bildlauf durch.

Schreiben Sie in unser Gästebuch:
 Dropdownmenü
Verwenden Sie ein Dropdownmenü, wenn Sie dem Sitebesucher eine Liste von Auswahlmöglichkeiten anzeigen möchten. Dieses Feld hat eine ähnliche Funktion wie eine Gruppe von Optionsfeldern, nimmt jedoch auf Ihrem Formular weniger Platz weg. Sie können ein Dropdownmenü so konfigurieren, dass es eine oder mehrere Auswahlen erlaubt.

Wählen Sie einen Artikel:
Kontrollkästchen
Verwenden Sie Kontrollkästchen für optionale Elemente. Der Sitebesucher kann das Kontrollkästchen aktivieren oder deaktivieren. Er kann auch mehrere Elemente aktivieren.

 Schaltfläche
Verwenden Sie Schaltflächen, damit der Benutzer ein Formular nach dem Ausfüllen abschicken, Felder durch Zurücksetzen wieder löschen oder benutzerdefinierte Skripts ausführen kann.

Nach dem Ablegen von Feldern in Ihrem Formular können Sie für diese ähnlich wie für Text ein Layout festlegen. Sie können Zeilenumbrüche, Tabellen und Cascading Stylesheets verwenden oder Positionen festlegen. Geben Sie Text direkt in das Formular ein, um Feldbeschriftungen und Anweisungen festzulegen. Sie können für jedes einzelne Feld auch Eigenschaften festlegen, um z. B. die Länge eines Textfeldes festzulegen, um festzulegen, ob eine Option standardmäßig aktiviert sein soll, und um die Auswahl in einem Dropdownmenü festzulegen.

Weitere Informationen

Hinzufügen von Feldern zu einem Formular

Ändern von Eigenschaften für ein Feld in einem Formular

Erstellen einer auswählbaren Beschriftung für ein Feld in einem Formular

Festlegen einer Tastenkombination für ein Feld in einem Formular

Festlegen der Aktivierreihenfolge ineinem Formular


Der dritte Schritt beim Erstellen eines Formulars ist das Festlegen von Regeln, die vorschreiben, wie Daten in bestimmte Felder Ihres Formulars eingegeben werden. Diese Dateneingaberegeln, auch als Gültigkeitsprüfung bezeichnet, stellen sicher, dass der Benutzer das Formular ordnungsgemäß ausfüllt. Sie können z. B. ein Bestellformular für Ihre Produkte einrichten und so sicherstellen, dass Kundenname, -adresse und die Zahlungsinformationen korrekt eingegeben werden, da Sie sonst nicht in der Lage sind, die Bestellung zu bearbeiten.

Gültigkeitsprüfung für Textfelder

Sie können den erlaubten Datentyp festlegen und andere Kriterien für einzeilige Textfelder und Textfelder mit Bildlauf festlegen. Um z. B. eine Kreditkartennummer abzufragen, richten Sie ein einzeiliges Textfeld ein, das nur Zahlen und Bindestriche zulässt und verbieten Sie andere Zeichen. Sie können auch eine feste Anzahl von Zeichen vorschreiben, um sicherzustellen, dass der Besucher nicht versehentlich ein Zeichen vergisst.

Gültigkeitsprüfung für Optionsfelder

Sie können festlegen, dass aus einer Gruppe von Optionsfeldern eine Auswahl getroffen werden muss. Angenommen, Ihr Formular enthält zwei Optionsfelder, Ja und Nein. Wenn ein Sitebesucher das Formular abschickt, ohne eine dieser Optionen ausgewählt zu haben, wird eine Meldung angezeigt.

Gültigkeitsprüfung für Dropdownmenüs

Sie können festlegen, dass ein Sitebesucher eine Option aus einem Dropdownmenü wählen muss, eine Mindest- oder Maximalauswahl festlegen, oder verbieten, dass die erste Auswahlmöglichkeit aktiviert wird (verbieten Sie z. B. die Auswahl des ersten Elements, wenn es sich hierbei um eine Anweisung handelt, wie etwa „Wählen Sie ein Element“).

Weitere Informationen

Festlegen von Regeln für die Eingabe von Daten in Felder


Der vierte Schritt beim Erstellen eines Formulars ist das Einrichten der Art, wie die Ergebnisse behandelt werden. Nach dem Abschicken des Formulars durch einen Sitebesucher müssen Sie die eingegebenen Daten, d. h. die Formularergebnisse sammeln, um sie selber anzuzeigen, sie dem Besucher anzuzeigen oder sie weiterzuverarbeiten. Microsoft FrontPage bietet mehrere Formularbehandlungsroutinen, die die Formularergebnisse weiterverarbeiten.

  • Speichern der Ergebnisse in eine Text- oder eine HTML-Datei. Immer, wenn ein Sitebesucher ein Formular abschickt, fügt FrontPage die Ergebnisse an eine Datei an. Sie können diese Datei dann öffnen und die Ergebnisse anzeigen. Sie können z. B. ein Gästebuch für Ihre Website einrichten und festlegen, dass die Ergebnisse in eine HTML-Datei gespeichert werden sollen. Sie können einen Hyperlink zu der Datei erstellen, damit Sitebesucher sehen können, was andere Besucher geschrieben haben.
  • Senden der Ergebnisse in einer E-Mail-Nachricht. Jedes mal, wenn ein Sitebesucher ein Formular abschickt, sendet FrontPage Ihnen eine E-Mail-Nachricht mit den Formularergebnissen.
  • Speichern der Ergebnisse in eine Datenbank. Jedes mal, wenn ein Sitebesucher ein Formular abschickt, speichert FrontPage die Informationen in eine Datenbank. Wenn Sie z. B. ein Formular zum Zusammenstellen von Kontaktinformationen verwenden, können Sie diese direkt in Ihrer Kundendatenbank speichern.

Sie können Formularergebnisse jedoch auch mit benutzerdefinierten Skripts behandeln.

Anmerkung Wenn Sie anstatt eines benutzerdefinierten Skripts eine der Formularbehandlungsroutinen verwenden möchten, müssen auf dem Server, auf dem sich Ihre Website befindet, FrontPage-Servererweiterungen installiert sein.

FrontPage beinhaltet auch Formularbehandlungsroutinen für Diskussionsbeiträge und Benutzerregistrierungsformulare. Weitere Informationen finden Sie unter Info über Diskussionsgruppen und Info über Sicherheit.

Weitere Informationen

Sammeln von Formularergebnissen


Der letzte Schritt bei der Erstellung eines Formulars ist das Einrichten einer Bestätigungsseite. Dies ist die Seite, die dem Sitebesucher angezeigt wird, nachdem er ein Formular abgeschickt hat. Die Bestätigungsseite kann eine „Vielen Dank“-Nachricht und den Inhalt aus einem oder mehreren Formularfeldern enthalten. Der Sitebesucher kann bestätigen, ob die eingegebenen Informationen korrekt sind und ggf. zum Formular zurückkehren, um dieses erneut auszufüllen.

Wenn Sie zum Behandeln von Formularergebnissen kein benutzerdefiniertes Skript verwenden, zeigt Microsoft FrontPage automatisch eine Bestätigungsseite an. Wenn Sie keine eigene Bestätigungsseite erstellen, verwendet FrontPage die Standardseite, die eine Liste der Feldnamen aus dem Formular mit den entsprechenden Werten enthält. Das folgende Beispiel zeigt ein Formular und die Standardbestätigungsseite, die für dieses Formular angezeigt werden würde. Es werden die Standardfeldnamen (T1, T2, R1, C1 und B1) verwendet, Sie können diesen Feldern jedoch aussagekräftigere Namen geben, indem Sie die Feldeigenschaften ändern.

Formular

Name:

Adresse:

A B C

 Formularbestätigung

Vielen Dank für die folgenden Informationen:

T1: NameXY
T2: AdresseXY
R1: C
C1: EIN
B1: Abschicken

Weitere Informationen

Erstellen einer Bestätigungsseite und Zuweisen dieser Seite zu einem Formular

Ändern von Eigenschaften für ein Feld in einem Formular


Info über Formulare


Info über Diskussionsgruppen

Eine Diskussionsgruppe ist ein interaktives Web, in dem Sitebesucher Themen diskutieren. Dazu lesen sie Beiträge, die bereitgestellt werden, beantworten Beiträge und stellen neue Beiträge bereit. Die Besucher können auch mithilfe eines Suchformulars nach für sie interessanten Beiträgen suchen.

Eine Diskussionsgruppe kann die folgenden Funktionsmerkmale haben:

  • ein Inhaltsverzeichnis mit Hyperlinks zu Beiträgen in den Diskussionsthemen,
  • ein Suchformular zum Suchen nach einem bestimmten Wort oder Ausdruck in den Beiträgen,
  • ein Eingabeformular, in das der Besucher einen Beitrag eingibt, der bereitgestellt werden soll,
  • ein Diskussionsfaden, der dem Besucher erlaubt, auszuwählen, ob der Beitrag, den er bereitstellt, ein neues Diskussionsthema oberster Ebene oder eine Antwort auf einen anderen Beitrag sein soll,
  • eine Bestätigungsseite, die bestätigt, dass der Beitrag eines Besuchers bereitgestellt wurde,
  • ein Registrierungsformular, das dem Besucher erlaubt, sich im Web anzumelden, wenn die Diskussion geschützt ist.

Weitere Informationen

Erstellen einer Diskussionsgruppe

Verwalten von Diskussionsbeiträgen

Festlegen von Eigenschaften für ein Diskussionsweb

Info über Sicherheit


Eine Framesseite enthält keine sichtbaren Inhalte: Sie ist lediglich ein Behälter, in dem angegeben wird, welche anderen Seiten angezeigt werden und wie diese Seiten angezeigt werden. Wenn Sie auf einer Seite, die in dem einen Frame angezeigt wird, auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, normalerweise in einem anderen Frame, dem so genannten Zielframe, angezeigt.

Beispielsweise zeigt eine Framesseite, die unter Verwendung der Framesseitenvorlage „Banner und Inhaltsverzeichnis“ erstellt wurde, eigentlich vier Seiten gleichzeitig im Browser an: die Framesseite und die Seiten, die in jedem der drei Frames angezeigt werden. Wenn Sie im Inhaltsverzeichnisframe links auf einen Hyperlink klicken, wird die Seite, auf die dieser Hyperlink verweist, im Hauptframe geöffnet.

Mit einer Framesseite wird die Anzahl, das Layout und das Erscheinungsbild der Frames festgelegt. Wenn Sie in dem einen Frame auf einen Hyperlink klicken, wird die Seite, auf die der Link verweist, in einem anderen Frame angezeigt.


Sie können Frames löschen, in der Größe ändern oder teilen, indem Sie die Frameränder auswählen und ziehen. Sie können auch Folgendes steuern:

  • Den Abstand zwischen Frames.
  • Ob die Rahmen zwischen Frames angezeigt oder ausgeblendet werden sollen.
  • Die Breite der Ränder im Inneren von Frames.
  • Ob ein Frame in der Größe geändert werden kann.
  • Ob in einem Frame Bildlaufleisten angezeigt werden sollen.

Sie können die Bildlaufleisten in Frames ebenso wie die Rahmen zwischen Frames anzeigen oder ausblenden, Sie können den Abstand zwischen Frames und die Breite der Innenränder von Frames angeben, und Sie können die Möglichkeit zum Ändern der Größe eines Frames aktivieren und deaktivieren.


Sie erstellen eine Framesseite unter Verwendung der Framesseitenvorlagen von Microsoft FrontPage. In jeder dieser Vorlagen wurde die Navigation zwischen den Frames bereits für Sie eingerichtet. In der Framesseitenvorlage „Banner und Inhaltsverzeichnis“ wird beim Klicken auf einen Hyperlink im Inhaltsverzeichnisframe links beispielsweise eine Seite im Hauptframe rechts angezeigt.

Nachdem Sie eine Framesseite basierend auf einer Vorlage erstellt haben, müssen Sie nur noch die Startseite festlegen, die in jedem Frame angezeigt werden soll. Sie können hierfür eine bereits vorhandene Seite wählen, oder Sie können eine neue Seite erstellen. Anschließend können Sie die Seite direkt in ihrem Frame bearbeiten. Mit einem hervorgehobenen Rahmen wird angezeigt, welcher Frame aktuell markiert ist oder ob die Framesseite selbst markiert ist.

Anmerkung Wenn Sie zum Organisieren Ihres Webs Framesseiten und Frames verwenden, sollten Sie keine gemeinsamen Randbereiche oder Navigationsleisten einsetzen. Mit der Verwendung von gemeinsamen Randbereichen oder Navigationsleisten in Verbindung mit Frames gestaltet sich das Navigieren in der Website unnötig kompliziert.

Erstellen Sie eine Framesseite unter Verwendung einer Framesseitenvorlage, und legen Sie dann die Startseite fest, die in jedem Frame angezeigt werden soll. Der hervorgehobene Rahmen zeigt den aktuell markierten Frame an.


Grundlegendes zu Frames und Framesseiten


Was sind Frames und Framesseiten?
Wie funktionieren Frames und Framesseiten?
Welche Einsatzmöglichkeiten gibt es für Frames und Framesseiten?
So erstellen Sie eine Framesseite
So steuern Sie das Aussehen einer Framesseite


Eine Framesseite ist eine spezielle Art von HTML-Seite, mit der das Browserfenster in verschiedene Bereiche, so genannte Frames unterteilt wird, von denen jeder eine andere Seite anzeigen kann.

Beispielsweise enthält eine Framesseite, die basierend auf der Framesseitenvorlage „Banner und Inhaltsverzeichnis“ erstellt wurde, drei Frames, nämlich „Banner“, „Inhaltsverzeichnis“ und „Hauptframe“.

Eine Framesseite, die basierend auf der Microsoft FrontPage-Framesseitenvorlage "Banner und Inhaltsverzeichnis" erstellt wurde. Sie enthält drei Frames mit Namen "Banner", "Inhaltsverzeichnis" und "Hauptframe".


Framesseiten werden häufig für Kataloge und Artikellisten oder jede beliebige andere Art von Seiten verwendet, bei denen es sinnvoll ist, per Klick auf einen Hyperlink in dem einen Frame eine Seite in einem anderen Frame anzuzeigen. Autoren verwenden Framesseiten, da hierbei die Navigationsstruktur bereits integriert ist und sie über eine einheitliche (d. h. in der Struktur und im Layout der Frames einheitliche) Benutzeroberfläche verfügen.

Bei Framesseiten, die auf der Framesseitenvorlage „Banner und Inhaltsverzeichnis“ basieren, verwenden viele Unternehmen beispielsweise den Bannerframe, um ein Unternehmenslogo und die Hauptabteilungen anzuzeigen, auf die über das Web zugegriffen werden kann. Im folgenden Beispiel wird beim Klicken auf den Hyperlink mit der Beschriftung „Marketing“ im Bannerframe im Inhaltsverzeichnisframe eine Liste der Mitglieder des Marketingteams angezeigt. Klickt der Sitebesucher nun im Inhaltsverzeichnisframe auf ein Teammitglied, wird die Homepage dieser Person im Hauptframe angezeigt.

Mit einer Framessseite wird die Anzahl, das Layout und das Aussehen der Frames festgelegt. Wenn Sie in dem einen Frame auf einen Link klicken, wird die Seite, auf die der Link verweist, in einem anderen Frame angezeigt.


HTML ist die Abkürzung für HyperText Markup Language, welches die Standardprogrammiersprache für das Beschreiben der Inhalte und des Layouts von Seiten im World Wide Web ist. HTML besteht aus paarweise verwendeten Starttags und Endtags mit dazwischen befindlichen Attributen und Werten. Mit diesen Tags wird jedes Element auf einer Webseite beschrieben, also auch jeder Textabsatz, jede Tabelle und jede Abbildung.

Beispielsweise wird mit dem HTML-Code <H1 align="left">Willkommen!</H1> ein links ausgerichteter Absatz auf einer Seite beschrieben, der den Text „Willkommen!“ enthält und mit der Formatvorlage „Überschrift 1“ formatiert wurde. Das Tag </H1> gibt das Ende des Absatzes an.

Dynamic HTML (DHTML) ist eine von Microsoft entwickelte Erweiterung von HTML, Version 4.0, mit der Sie Spezialeffekte erzeugen können, wie beispielsweise Text, der wortweise „von der Seite fliegt“, oder Übergangseffekte zwischen Seiten ähnlich einer sich drehenden Reklametafel.

Wenn Sie Seiten auf der Registerkarte Normal in der Seitenansicht erstellen, sind keine Kenntnisse in HTML oder DHTML erforderlich; FrontPage ist ein WYSIWYG-Gestaltungstool (WYSIWYG - What You See Is What You Get), das den HTML-Code für Sie erstellt. Sie können Abbildungen, Steuerelemente, Skripts, Applets oder Hyperlinks einfügen, ohne dass Sie HTML-Code schreiben müssen. Wenn Sie jedoch die HTML-Tags sehen möchten, die FrontPage erstellt, können Sie diese ebenfalls auf der Registerkarte Normal in der Seitenansicht anzeigen.

Wenn Sie es vorziehen, den HTML-Code direkt zu schreiben und zu bearbeiten, wechseln Sie in der Seitenansicht auf die Registerkarte HTML.


Sie können HTML-Code direkt auf der Registerkarte HTML in der Seitenansicht bearbeiten, wobei Ihnen alle standardmäßigen Bearbeitungstools (z. B. Ausschneiden, Einfügen, Suchen und Ersetzen) zur Verfügung stehen. Sie können sich jedoch auch von FrontPage beim Festlegen der Eigenschaften eines HTML-Tags unterstützen lassen, so dass Sie sich die jeweils gültigen Attribute und Werte nicht merken und diese nicht selbst eingeben müssen.

Sie können mithilfe von Menübefehlen und Dialogfeldern HTML erstellen sowie mithilfe von Eigenschafts-Dialogfeldern HTML bearbeiten.

Wenn Sie einer Abbildung beispielsweise einen Rahmen hinzufügen möchten, können Sie in das Tag <IMG> zwar auch manuell border="1" eingeben, was jedoch voraussetzt, dass Sie die gültigen Attribute und Werte für Abbildungstags kennen. Stattdessen können Sie auch das Dialogfeld Bildeigenschaften zum Festlegen des Rahmens verwenden, woraufhin FrontPage automatisch die Rahmeneinstellungen in der korrekten Syntax und unter Verwendung gültiger Werte in das Tag <IMG> zurückschreibt. Im Gegensatz zu vorherigen Versionen von FrontPage müssen Sie die Registerkarte HTML nicht mehr schließen, um auf die Dialogfelder Eigenschaften zum Festlegen der Eigenschaften für ein Tag zugreifen zu können.


Sie können Seiten gezielt für die Kompatibilität mit bestimmten Browsern, Browserversionen, Servern und Technologien auslegen. In diesem Fall werden alle FrontPage-Befehle, mit denen nicht kompatibler HTML- oder anderer Code erstellt wird, ausgeblendet oder stehen Autoren beim Bearbeiten dieser Seite nicht zur Verfügung.

Wenn Sie z. B. Dynamic HTML (DHTML) für eine Seite deaktivieren, werden Befehle, die auf DHTML-Funktionen zurückgreifen, wie beispielsweise für Animationen, die Sie mit Dynamic HTML-Effekten erstellen, ausgeblendet oder stehen Autoren beim Bearbeiten der Seite nicht zur Verfügung.


Sie können ändern, wie FrontPage den HTML-Code einer Seite formatiert, die auf der Registerkarte HTML in der Seitenansicht angezeigt wird. Beispielsweise können Sie die Namen von HTML-Tags in Großbuchstaben und HTML-Attribute in Kleinbuchstaben darstellen, um beide besser auseinanderhalten zu können, wie z. B. in <FORM method="POST">. Sie können auch Zeilenumbrüche innerhalb von Tags zulassen und einen Wert für den linken Einzug sowie den rechten Rand angeben, an dem der HTML-Code umbrochen werden soll.

Sie können Tags in Klein- oder Großbustaben darstellen, ihnen unterschiedliche Farben zuweisen, den rechten Rand angeben und sogar den linken Einzug bestimmen.

FrontPage weist den Elementen des HTML-Codes automatisch verschiedene Farben zu, um zwischen Text auf einer Seite, Tags, Attributnamen, Attributwerten, Kommentaren und Skripts zu unterscheiden. Sie können die von FrontPage für diese Farbcodierung verwendeten Farben Ihren Vorstellungen oder den Anforderungen Ihrer Arbeitsgruppe entsprechend ändern, oder Sie können die Farbcodierung komplett ausschalten.


Sie können ändern, wie FrontPage bestimmte HTML-Tags auf einer Seite formatiert, die auf der Registerkarte HTML in der Seitenansicht angezeigt wird. Beispielsweise können Sie FrontPage anweisen, keine abschließenden </P>-Tags einzufügen oder den Inhalt einzurücken und vor <H1>-Tags jeweils einen Zeilenumbruch zu setzen.

Sie können die Formatierung für bestimmte Tags verändern und beispielsweise den Inhalt einrücken oder, falls zulässig, den abschließenden Tag weglassen.


Wenn Sie eine vorhandene Seite öffnen, einschließlich Seiten, die in anderen Editoren erstellt wurden, behält Microsoft FrontPage automatisch den Inhalt, die Syntax und die Formatierung des HTML-Codes dieser Seite bei, auch wenn dieser Fehler und nicht erkannte HTML-Syntax enthält. Speichern Sie die Seite, speichert FrontPage den gesamten neuen HTML-Code, den Sie geschrieben haben, mit allen benutzerdefinierten Formatierungen wie beispielsweise Einrückung, Groß- und Kleinschreibung von Tags usw. Der ursprüngliche HTML-Code der Seite wird jedoch nur dann geändert oder neu formatiert, wenn Sie ihn in FrontPage bearbeitet haben.

Wenn Sie die automatische Erhaltung von HTML außer Kraft setzen möchten, klicken Sie im Menü Extras auf Seitenoptionen, dann auf die Registerkarte HTML-Quelltext und anschließend auf Unter Verwendung der folgenden Regeln neuformatieren.


Arbeiten mit HTML


Info über HTML
Erhalten von bestehendem HTML-Code
Sicherstellen der Kompatibilität
Bearbeiten von HTML-Code
Ändern der HTML-Formatierung
Ändern der HTML-Formatierung bestimmter Tags


Info über Grafiken


Anwendungsgebiete für Grafiken
Grafikarten und -formate
Imagemaps
Effekte


Sie können Ihren Bildern einen oder mehrere der folgenden Effekte zuweisen:

Originalbild Originalbild | Text hinzufügen Text hinzufügen
Mehr Helligkeit Mehr Helligkeit | Weniger Helligkeit Weniger Helligkeit
Mehr Kontrast Mehr Kontrast | Wenigier Kontrast Weniger Kontrast
Schwarzweiß Schwarzweiß | Verwaschen Verwaschen
Abgeschrägte Kanten Abgeschrägte Kanten | Rahmen Rahmen
Originalbild Originalbild | Transparente Farbe festlegen Transparente Farbe festlegen
Linksherum rotieren Linksherum rotieren | Rechtsherum rotieren Rechtsherum rotieren
Horizontal kippen Horizontal kippen | Vertikal kippen Vertikal kippen

Wenn Sie mit einigen Effekten experimentiert haben und dann feststellen, dass die vorgenommenen Änderungen nicht Ihren Vorstellungen entsprechen, können Sie das Bild jederzeit auf die zuletzt gespeicherte Version zurücksetzen.

Weitere Informationen

Ändern der Größe einer Grafik

Zuschneiden eines Bildes


Sie können ein Imagemap erstellen, indem Sie Hotspots auf eine Grafik setzen. Bei einem Hotspot handelt es sich um einen unsichtbaren Bereich, von dem aus der Sitebesucher per Mausklick zu einem weiteren URL gelangt, den Sie hierfür definiert haben. Das Imagemap gibt Ihnen normalerweise Hinweise darauf, an welcher Stelle Sie klicken müssen. Sie haben für Ihr Unternehmen beispielsweise eine Webseite mit einem Bild der angebotenen Produkte erstellt. Dieses Bild enthält einen Hotspot auf jedem Produkt. Klickt nun der Sitebesucher auf ein Produkt, wird eine Seite mit einer detaillierten Erläuterung des Produkts angezeigt.

Sie können auch einen standardmäßigen Hyperlink für eine Grafik definieren, anstatt hierauf einen Hotspot zu erstellen. Beispielsweise möchten Sie eine Schaltfläche erstellen, die mit Ihrer Homepage verknüpft ist. Anstatt nun einen Hotspot um die gesamte Schaltfläche zu ziehen, können Sie einen Standardhyperlink für die Grafik definieren, der, wenn darauf geklickt wird, den Besucher zu Ihrer Homepage bringt.

Weitere Informationen

Erstellen eines Imagemap

Info über Hyperlinks


Animierte GIFs und Videos

Sie können animierte GIFs und Videos in Ihre Webseiten einbinden. Eine animierte GIF-Grafik, also die sequenzielle Anzeige von GIF-Bildern, kann in einem Grafikprogramm erstellt werden; darüber hinaus können Sie auch im World Wide Web animierte GIFs finden.

Sie können Ihrer Seite beliebige Videos hinzufügen, deren Format von der Windows Medienwiedergabe verarbeitet werden kann, wie z. B. Videos im AVI-Format. Darüber hinaus können Sie auch Optionen für die Wiedergabe von Videos festlegen, können also beispielsweise angeben, dass das Video einmal beim Öffnen der Seite abgespielt werden soll, Sie können das Video kontinuierlich laufen lassen, oder Sie können das Video abspielen lassen, wenn der Sitebesucher mit der Maus darauf zeigt. Die Animation im vorliegenden Beispiel wird einmal beim Öffnen der Seite abgespielt.

Bilder

Es können Bilder mit den folgenden Dateiformaten verwendet werden: GIF (Standard und animiert), JPEG (Standard und progressiv), BMP (Windows und OS/2), TIFF, TGA, RAS, EPS, PCX, PNG, PCD (Kodak Photo CD) und WMF. Im Allgemeinen werden für Webseiten die Formate GIF, JPEG und PNG verwendet.

Bilder im GIF-Format können bis zu 256 Farben umfassen. Ein nützlicher Aspekt von GIF-Bildern ist, dass Sie eine Farbe als transparent definieren können.

Das JPEG-Format wird häufig für fotorealistische Bilder mit bis zu 16,7 Millionen Farben verwendet. JPEG-Bilder sind praktisch, weil Sie die Dateikomprimierung steuern können, indem Sie die Bildqualität ändern. Je niedriger Sie die Qualität ansetzen, desto stärker kann die Datei komprimiert werden und desto kleiner wird die hieraus resultierende Datei.

Das PNG-Format ist eine Alternative für GIF und unterstützt ebenfalls transparente Farben für Bilder bis zu 16,7 Millionen Farben. Allerdings können einige Webbrowser PNG-Bilder nicht ohne ein spezielles Plugin anzeigen.

Wenn Sie einer Seite ein Bild hinzufügen, das nicht im Format GIF, JPEG oder PNG vorliegt, und die Seite dann speichern, wandelt Microsoft FrontPage das Bild automatisch in das GIF-Format um, wenn es 8 Bit Farben oder weniger umfasst, oder in JPEG, wenn es mehr als 8 Bit Farben aufweist.

Weitere Informationen

Hinzufügen einer Grafik zu einer Seite


Grafiken auf Webseiten dienen der Bereitstellung von Informationen, Illustrationen oder Bildern. Neben ihrem dekorativen Effekt können Grafiken auch nutzbringend eingesetzt werden, beispielsweise als Navigationsschaltflächen.

Anwendungsgebiete für Grafiken

Microsoft FrontPage enthält eine Vielzahl verschiedener Designs, bei denen für diese Seitenelemente unterschiedliche Grafiken verwendet werden. Sie können jedoch auch eigene Designs mit eigenen Grafiken entwickeln.

Weitere Informationen

Hinzufügen einer Grafik zu einer Seite

Festlegen eines Hintergrundbildes für eine Seite

Info über Designs

Erstellen von benutzerdefinierten Aufzählungszeichen


Auswirkungen von Grafiken auf ein Web

Die Größe des Webs wird erhöht

Wenn Sie Grafiken wie beispielsweise Bilder, Animationen oder Videos in Ihr Web einbinden, führt dies schnell zu einer erheblichen Steigerung der Webgröße. Größe, Qualität, Art und Anzahl von Grafiken sind daher wichtige Gesichtspunkte, wenn Ihr Internetdienstanbieter nur Webs bis zu einer bestimmten Größe gestattet. Hier einige Methoden, mit denen Sie die Größe Ihrer Bilddateien verringern können:

  • Verkleinern Sie ein großes Bild, indem Sie die Bildgröße ändern und das Bild anschließend erneut einlesen.

    • Mit dem Ändern der Bildgröße wird nur die Art der Anzeige im Webbrowser des Sitebesuchers geändert. Wenn Sie für ein großes Bild lediglich ein kleineres Anzeigeformat wählen, wird also die Dateigröße des Bildes nicht geändert. Zum Verringern der Dateigröße müssen Sie das Bild nach dem Ändern des Anzeigeformats erneut einlesen.

  • Wandeln Sie das Bild in das JPEG-Format um , und verringern Sie den Wert der Einstellung Qualität. Mit einem niedrigeren Wert wird die Dateikomprimierung erhöht und die Dateigröße verringert.
  • Erstellen Sie bei einem Bild mit hoher Auflösung eine Kopie des Bildes, und verringern Sie die Auflösung der Kopie mithilfe eines Grafikprogramms.

Der Download einiger Seiten erfolgt nur langsam

Grafiken können die Downloadzeiten für eine Seite erheblich erhöhen, insbesondere für Sitebesucher, die nur über eine langsame Internetverbindung verfügen. Hier einige Methoden, mit denen Sie Sitebesuchern den Download von Seiten mit Grafiken vereinfachen können:

  • Ändern Sie die Bildgröße umfangreicher Grafiken, und lesen Sie diese erneut ein.
  • Erstellen Sie eine Miniaturansicht.

    • Eine Miniaturansicht ist eine verkleinerte Version des Bildes, die sich schnell downloaden lässt. Durch betrachten der Miniaturansicht können Sitebesucher entscheiden, ob sie die Vollbildversion des Bildes downloaden möchten. Verwenden Sie hierzu die Funktion AutoMiniaturansicht, mit der automatisch eine Miniaturansicht mit einem Hyperlink zu Ihrem Originalbild erstellt wird.

  • Zeigen Sie eine Version der Grafik mit niedriger Auflösung, während die Originalversion gedownloaded wird.

    • Erstellen Sie in einem Grafikprogramm eine Version des Bildes, des Videos oder der animierten GIF-Grafik, mit einer niedrigeren Auflösung. Weisen Sie Microsoft FrontPage anschließend an, diese Version anzuzeigen, während die Originalversion gedownloaded wird. Obwohl sich mit dieser Option nicht die Zeit verkürzen lässt, die für den Download der Grafik benötigt wird, bieten Sie dem Sitebesucher hiermit zumindest etwas, was er zwischenzeitlich betrachten kann.

  • Zeigen Sie alternativen Text an.

    • Alternativer Text (ALT-Text) ist Text, der während des Downloads anstelle der Grafik angezeigt wird und womit die Sitebesucher informiert werden, was es schließlich zu sehen gibt.

Wenn Sie herausfinden möchten, für welche Seiten Ihres Webs lange Downloadzeiten benötigt werden, zeigen Sie im Menü Ansicht auf Berichte und klicken dann auf Langsame Seiten.


Sprachfaktoren bei internationalen Webs

Sie können auch in einer anderen Sprache als der Standardsprache Ihres Computers Seiten verfassen und bearbeiten. Zunächst basieren die Standardeinstellungen für Webs und Seiten auf der Standardsprache, die für Ihren Computer festgelegt worden ist. FrontPage erlaubt Ihnen jedoch, alternative Spracheinstellungen für Ihr Web und seine Seiten festzulegen. Dieses Thema gibt eine Übersicht über die Konzepte und Einstellungen in FrontPage, die beim Erstellen von Seiten in unterschiedlichen Sprachen und Codierungen von Nutzen sind.

Übersicht

Bei der Installation des Betriebssystems wird Ihr Computer mit einer Standardsprache eingerichtet. Diese legt die Sprache der Tastatur und die Codepage des Systems fest, eine HTML-Codierung, die von Anwendungen verwendet wird, die auf Ihrem Computer ausgeführt werden. System-Codepages und HTML-Codierungen können sich auf mehrere Sprachen beziehen. Die Computer in den Vereinigten Staaten und in Westeuropa verwenden die Codierung Windows-1252, aber diese Region enthält eine große Anzahl von Sprachen (Englisch, Deutsch, Spanisch, Französisch etc.).

Wenn Sie Webseiten erstellen, ermittelt FrontPage die Sprache und die Codierung neuer Seiten durch die Sprache der Tastatur. Die Codierung teilt FrontPage mit, wie die Informationen in einer Datei zu speichern sind. Alle Zeichen, die nicht Teil der aktuellen Codierung sind, werden als Verweise auf nummerische Unicodezeichen (wie &#20AC;) gespeichert. Diese Verweise auf nummerische Unicodezeichen machen die Datei größer und behindern die Lesbarkeit von HTML-Code. Der folgende HTML-Tag gibt die Codierung einer Seite an:

<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

Die Sprache einer Seite berührt nicht die Art, wie Informationen gespeichert werden, sondern teilt FrontPage mit, welche Rechtschreibprüfung zu verwenden ist, hilft den Webbrowsern bei der Feststellung, in welcher Schriftart eine Seite anzuzeigen ist, und unterstützt die erweiterte Indizierung. Der folgende HTML-Tag gibt die Sprache einer Seite an.

<meta http-equiv="Content-Language" content="en-us">

Erstellen von Seiten in einer anderen Sprache bei gleicher Codierung

Berücksichtigen Sie die folgenden Einstellungen, wenn Sie Seiten in einer anderen Sprache als der Standardsprache Ihres Computers erstellen, aber dennoch dieselbe Codierung verwenden. So ist zum Beispiel Ihre Codierung „US/Westeuropäisch“, und die Sprache Ihres Computers ist Englisch, aber Sie möchten Seiten in Deutsch erstellen.

Der einfachste Weg, Webseiten in einer anderen Sprache zu erstellen, ist das Auswechseln der Tastatur, denn diese legt die Sprache und Codierung für neue Seiten fest. Indem Sie weitere Tastaturen und Codepages installieren, ermöglichen Sie es FrontPage, Seiten in anderen Sprachen zu erstellen, die Ihr Computer andernfalls nicht unterstützen würde.

  • Die von den Servererweiterungen verwendete Sprache

    • Sie können die Sprache festlegen, die von den FrontPage-Servererweiterungen für die Anzeige von Meldungen verwendet wird. Einige Meldungen werden angezeigt, während Sie eine Seite bearbeiten. Andere Meldungen werden den Sitebesuchern angezeigt, wie zum Beispiel die Meldung über den Fehlschlag einer Suche oder eine Warnung nach Überprüfung eines Formulars. Die Servererweiterungen generieren auch HTML, die der Sitebesucher sieht, wie die Standardseiten für Bestätigung und Fehlschlag bei Formularen, die auf dieser Spracheinstellung basieren. Wenn also die Sprache auf Englisch eingestellt ist, Sie aber glauben, dass die Mehrheit Ihrer Sitebesucher deutsch sein werden, dann können Sie Deutsch als die Sprache auswählen, die von den Servererweiterungen verwendet wird.

  • Die Sprache der Benutzeroberfläche von FrontPage

    • Die Benutzeroberfläche von FrontPage wird in derselben Sprache wie die Standardsprache des Computers oder in der Sprache der von Ihnen erworbenen FrontPage-Version angezeigt. Vorlagen, Assistenten und Meldungen der Servererweiterungen werden ebenfalls in dieser Sprache angezeigt. Um eine andere Sprache für die Benutzeroberfläche von FrontPage zu verwenden, und Assistenten und Vorlagen in dieser Sprache verfügbar zu machen, können Sie eine FrontPage-Version in dieser Sprache kaufen oder, falls Ihr Unternehmen Sie mit Microsoft MultiLanguage Pack für Office 2000 ausgestattet hat, können Sie die Sprache der Benutzeroberfläche und Hilfe in Microsoft Office-Programmen wechseln.

  • Die Sprache einer Seite

    • Wenn Sie Verfasser in einer anderen Sprache sind, sollten Sie sicherstellen, dass andere Webbrowser und Suchmaschinen die Sprache Ihrer Seiten identifizieren und korrekt anzeigen können. Außerdem sollten Sie die Sprache für FrontPage identifizieren, damit Sie die Rechtschreibung prüfen und die Seiten korrekt speichern können. Geben Sie daher bei jeder Seite exakt die Sprache an. Die Standardeinstellung basiert auf der Sprache Ihrer Tastatur.

  • Standardsprache für die Rechtschreibung

    • Sie können die Sprache für die Standard-Rechtschreibprüfung in FrontPage festlegen. Bei Seiten, die nicht durch eine spezielle Sprache gekennzeichnet sind, prüft FrontPage die Rechtschreibung gemäß der Standardsprache für die Rechtschreibung.

Erstellen von Seiten in einer anderen Sprache und Codierung

Berücksichtigen Sie die folgenden zusätzlichen Einstellungen, wenn Sie Seiten in einer anderen Sprache und Codierung als dem Standard Ihres Computers erstellen, zusätzlich zu den im vorigen Abschnitt erwähnten Einstellungen. So ist zum Beispiel die Codierung Ihres Computers „US/Westeuropäisch“, und die Sprache ist Englisch, und Sie erstellen Seiten in Griechisch.

  • Die Standard-Seitencodierung eines Webs

    • Für jedes Web wird die Standard-Seitencodierung festgelegt und von FrontPage verwendet, um die anfängliche Codierung neuer Seiten anzugeben, sofern diese mit der aktuellen Tastatur kompatibel ist. Ist dies nicht der Fall, wird stattdessen die Codierung der Tastatur verwendet. Sie können aber auch die Codierung der Tastatur ignorieren, worauf FrontPage die Standard-Seitencodierung mit der des Computers vergleicht.

    Die Standard-Seitencodierung auf <keine> zu setzen, wird nicht empfohlen, da dann die Benutzer die Seitencodierung für jede neue Seiten einstellen müssten. Andernfalls würden Sonderzeichen, die nicht im einfachen ASCII-Zeichensatz enthalten sind, wie zum Beispiel das Zeichen für den Euro, nicht korrekt angezeigt werden.

  • Die Codierung für das Speichern von Seiten

    • Standardmäßig verwendet FrontPage die durch die Tastatur vorgegebene Seitencodierung, oder die Standardcodierung des Webs oder des Computers, um zu bestimmen, in welchem Zeichensatz neue Seiten zu speichern sind. Wenn die Zeichen auf einer Seite jedoch hauptsächlich in einem Zeichensatz sind, der sich von der Standard-Seitencodierung unterscheidet, dann können Sie eine andere Codierung für das Speichern einer einzelnen Seite angeben.

  • Auf Ihrem Computer verfügbare Codierungen

    • Wenn Sie mit einer Seite arbeiten möchten, deren Zeichensatz nicht in den Codepages Ihres Computers enthalten ist, müssen Sie das Sprachen-Pack Ihres Betriebssystems auf den Client- wie auch auf den Server-Computern installieren. FrontPage kann dann die Zeichen interpretieren und anzeigen. Wenn Sie zum Beispiel Windows 95 verwenden, installieren Sie die Unterstützung der Mehrsprachigkeit. Daraufhin können Webbrowser wie Microsoft Internet Explorer die Seite anzeigen, und die FrontPage-Servererweiterungen können die Hyperlinks in Ihren Webs pflegen. Sie können das Sprachen-Pack von der Microsoft Homepage herunterladen und dann der Verknüpfung zur Unterstützung der Mehrsprachigkeit von Internet Explorer folgen. Wenn Sie Windows NT verwenden, ist das Sprachen-Pack im Ordner „Langpack“ auf der Installations-CD zu finden.

Andere Optionen

  • Sie können die Standardschriftarten angeben, die in FrontPage für jeden Zeichensatz angezeigt werden, um der Standardschriftart in Ihrem Webbrowser zu entsprechen. Die Standardschriftart wird angezeigt, wenn keine andere Schriftart auf den Text angewendet worden ist. Sie können eine proportionale Schriftart und eine Schriftart mit fester Zeichenbreite (angezeigt auf der Registerkarte HTML) für die meisten Zeichensätze angeben.
  • Wenn eine Seite nicht korrekt angezeigt wird, weil ihre Codierung nicht im HTML-Code festgehalten wurde, können Sie für ein Neuladen der Seite die korrekte Codierung angeben.

Einschränkungen für Dialogfelder in FrontPage

Sie können Webseiten in den meisten Sprachen erstellen und bearbeiten. Die FrontPage-Dialogfelder können jedoch nur Eingaben empfangen und Inhalt anzeigen, wenn diese der Codepage Ihres Computersystems entsprechen. Wenn Ihr Computer zum Beispiel für „US/Westeuropäisch“ (Windows-1252) eingerichtet ist, werden Sie in Dialogfeldern wie Suchen für das Suchen nach Text keinen griechischen Text eingeben können. Auch werden die Seitentitel im Dialogfeld Seiteneigenschaften nicht korrekt angezeigt, wenn die Zeichen nicht in der entsprechenden Codepage dargestellt werden können.

URL-Einschränkungen

Selbst heutzutage erlauben die Internet-Standards nur die Verwendung von einfachen ASCII-Zeichen in URLs. Um sicherzustellen, dass alle Sitebesucher URLs folgen können, ohne Rücksicht auf die Sprache des jeweiligen Computers oder ein Betriebssystem nehmen zu müssen, sollten Sie in den URLs für Ihre Webs ebenfalls nur einfache ASCII-Zeichen verwenden. Aus diesem Grunde schlägt FrontPage, wann immer Sie ein neues Web, einen neuen Ordner oder eine neue Datei erstellen, einen Namen vor, der nur aus einfachen Zeichen besteht.

Die Version von Internet Explorer, die in FrontPage enthalten ist, hat damit begonnen, die internationalen URLs in Unicode (UTF-8) zu senden. URLs in Unicode können von Microsoft Internet Information Server (4.0) oder später verstanden werden. Wenn Ihr Web sich in einem Intranet befindet, und Sie sowohl die Client- als auch die Serversoftware kontrollieren können, sollten Sie in der Lage sein, internationale URLs zu verwenden.

Weitere Informationen

Festlegen der Standardschriftart für die Anzeige einer Sprache oder eines Zeichensatzes


Sprachfaktoren bei internationalen Webs

Um mehr über Sprachfaktoren zu erfahren, klicken Sie auf die Grafik.

Um dieses Thema anzuzeigen, klicken Sie auf die Grafik.


Hyperlinks können auf verschiedene Weisen gekennzeichnet werden. Webbrowser unterstreichen Texthyperlinks normalerweise und zeigen sie in einer anderen Farbe an. Beispielsweise könnte ein Hyperlink so aussehen. Sie können auch Effekte festlegen, so dass sich das Erscheinungsbild von Hyperlinks ändert, wenn ein Sitebesucher mit der Maus darauf zeigt, sich also beispielsweise die Schriftart des Hyperlinks ändert.

Hyperlinks auf einem Bild sind nicht immer sichtbar, jedoch kann ein Sitebesucher feststellen, ob sich ein Hyperlink auf einem Bild befindet, indem er den Mauszeiger darauf positioniert; in diesem Fall ändert der Mauszeiger nämlich sein Aussehen und nimmt im Allgemeinen die Form einer zeigenden Hand an. Positionieren Sie den Mauszeiger auf der folgenden Schaltfläche:

Der Mauszeiger ändert sein Aussehen und zeigt so einen Hyperlink an

Um einen Hyperlink noch mehr hervorzuheben, können Sie sowohl Text- als auch Bildhyperlinks dynamische HTML-Effekte hinzufügen. Weitere Informationen finden Sie unter Animieren des Web.

Ein Hyperlink sollte auch einen sichtbaren Hinweis darauf enthalten, wohin er führt; beispielsweise könnte der nachstehende Hyperlink die Homepage eines Webs zum Ziel haben:

Homepage

Hyperlink zu einer Homepage

Weitere Informationen

Festlegen der Farben für Hyperlinks

Hinzufügen von Schrifteffekten zu einem Hyperlink


Eine Textmarke ist eine Adresse oder eine Gruppe von Zeichen, die Sie auf einer Seite gekennzeichnet haben.

Sie können eine Textmarke als Ziel für einen Hyperlink verwenden. Beispielsweise möchten Sie für die Besucher Ihrer Site einen Verweis auf einen bestimmten Absatz auf einer anderen Seite bereitstellen. Wenn Sie nun einfach einen Hyperlink zu dieser Seite erstellen, wird der Anfang der Seite im Webbrowser angezeigt, und der Sitebesucher muss den betreffenden Absatz suchen. Günstiger ist es, eine Textmarke am Anfang des gewünschten Absatzes zu platzieren und einen Hyperlink zu dieser Textmarke zu erstellen. Auf diese Weise wird die Seite beginnend mit dem in Frage kommenden Absatz im Fenster des Webbrowsers angezeigt.

Eine Textmarke kann auch verwendet werden, um während des Bearbeitens einer Seite schnell zu einer bestimmten Position zu gelangen. Beispielsweise haben Sie auf einer langen Seite jeder Abschnittsüberschrift eine Textmarke hinzugefügt; beim Bearbeiten der Seite können Sie nun schnell zu einem bestimmten Abschnitt gelangen, indem Sie zu der entsprechenden Textmarke wechseln.

Textmarken können auch zum Erstellen eines Inhaltsverzeichnisses für eine lange Seite verwendet werden. Erstellen Sie beispielsweise eine Textmarke für jede Überschrift auf der Seite. Anschließend erstellen Sie am Anfang der Seite eine Liste mit Hyperlinks, die zu den jeweiligen Textmarken führen.

Weitere Informationen

Erstellen einer Textmarke

Erstellen eines Hyperlinks zu einer Textmarke


Umbenennen und Verschieben von Dateien in einem Web

Immer wenn Sie eine Datei in Ihrem Web umbenennen, prüft FrontPage, ob irgendwelche Hyperlinks auf diese Datei verweisen. Falls ja, aktualisiert FrontPage diese Hyperlinks mit dem neuen Dateinamen.

Wenn Sie eine Datei in Ihrem Web verschieben (beispielsweise in einen untergeordneten Ordner), aktualisiert FrontPage automatisch alle Hyperlinks zu dieser Datei entsprechend der neuen Speicherposition.

Prüfen und Korrigieren fehlerhafter Hyperlinks

Bevor Sie eine Website veröffentlichen, sollten Sie sie immer auf fehlerhafte Hyperlinks prüfen und vor allem auch die Hyperlinks überprüfen, die auf externe Ziele verweisen. Ein fehlerhafter Hyperlink ist ein Hyperlink mit einem ungültigen Ziel-URL; klickt der Sitebesucher auf einen solchen Hyperlink, wird in seinem Webbrowser eine Fehlermeldung angezeigt. Die Ursache kann einfach ein Tippfehler im URL oder ein URL sein, der auf eine Seite verweist, die Sie bereits aus dem Web gelöscht haben. Ist das Ziel eine andere Seite im World Wide Web, wurde diese Seite möglicherweise verschoben oder entfernt.

Zum Verwalten der Hyperlinks in einem Web können Sie FrontPage anweisen, die Hyperlinks zu überprüfen und deren Status anzuzeigen. Auf dieser Basis können alle fehlerhaften Hyperlinks schnell korrigiert oder aktualisiert werden.

Weitere Informationen

Korrigieren fehlerhafter Hyperlinks

Überprüfen von Hyperlinks


Ein Hyperlink ist eine Verbindung zwischen einer Seite und einem anderen Ziel wie beispielsweise einer anderen Seite oder einer anderen Position auf der gleichen Seite. Das Ziel ist häufig eine andere Webseite, es kann sich jedoch auch um ein Bild, eine E-Mail-Adresse, eine Datei (wie z. B. eine Multimediadatei oder ein Microsoft Office-Dokument) oder ein Programm handeln. Ein Hyperlink kann als Text oder als Bild vorliegen.

Wenn der Sitebesucher auf den Hyperlink klickt, wird dessen Ziel im Webbrowser angezeigt, geöffnet oder ausgeführt, abhängig von der Art des Ziels. Beispielsweise öffnet ein Hyperlink zu einer AVI-Datei diese Datei in einem entsprechenden Medienwiedergabeprogramm, und mit einem Hyperlink zu einer Seite wird diese Seite im Webbrowser angezeigt.

Im folgenden Beispiel ist das Wort „Dienste“ ein Hyperlink; wenn der Sitebesucher darauf klickt, wird die Seite „Dienste“ angezeigt.

Beispiel für einen Hyperlink

Weitere Informationen

Erstellen eines Hyperlinks


Ein Texthyperlink besteht einfach aus Text wie beispielsweise einem Wort oder einem Satz, dem ein Ziel-URL zugewiesen wurde. (Der nachstehende Hyperlink, Info über Grafiken, ist ein Beispiel hierfür.)

Ein Bildhyperlink ist ein Bild, dem mit einer von zwei Methoden ein Ziel-URL zugewiesen wurde:

  • Dem gesamten Bild kann ein Standardhyperlink zugewiesen werden. In diesem Fall kann der Sitebesucher auf einen beliebigen Teil des Bildes klicken, um dessen Ziel anzuzeigen. Ein Beispiel für ein Bild mit einem Standardhyperlink ist eine Schaltfläche.
  • Dem Bild können jedoch auch ein oder mehrere Hotspots, also Hyperlinkbereiche auf dem Bild, zugewiesen werden. Ein Bild, das Hotspots enthält, wird als Imagemap bezeichnet. Ein Imagemap kann beispielsweise ein Bild sein, das verschiedene Teile einer Website repräsentiert (wie z. B. die Homepage, einen Katalogbereich usw.). Der Sitebesucher klickt nun auf einen bestimmten Bereich des Imagemap, um so die entsprechende Seite anzuzeigen. Für weitere Informationen hierzu lesen Sie Info über Grafiken und klicken Sie dann auf Imagemaps.

Weitere Informationen

Erstellen eines Hyperlinks

Erstellen eines Imagemap


Info über Hyperlinks


Was ist ein Hyperlink
Was ist ein URL?
Texthyperlinks im Vergleich zu Bildhyperlinks
Wie Hyperlinks angezeigt werden
Anwendungsgebiete für Hyperlinks
Verwenden von Textmarken
Verwalten von Hyperlinks


Beim Erstellen eines Hyperlinks wird dessen Ziel als URL (Uniform Resource Locator) codiert, wie beispielsweise http://Beispiel.microsoft.com/neues.htm oder file://ComputerName/GemeinsamerOrdner/DateiName.htm. Ein URL enthält die Adresse eines Webservers oder eines Netzwerks, den Pfad und den Dateinamen. Mit dem URL wird darüber hinaus auch das Protokoll angegeben, mit dem die Datei verarbeitet wird, also beispielsweise HTTP, FTP oder FILE:

Bestandteile eines URLs

Ein Hyperlink kann absolut oder relativ sein:

  • Ein absoluter URL enthält die vollständige Adresse.
  • Bei einem relativen URL fehlen ein oder mehrere Teile. Die fehlenden Angaben werden der Seite entnommen, die den URL enthält. Wenn beispielsweise die Angaben für Protokoll oder Domäne fehlen, verwendet der Webbrowser das Protokoll und die Domäne der aktuellen Seite.

    • Es ist üblich, auf Seiten in einem Web relative URLs zu verwenden, die nur einen partiellen Pfad und den Dateinamen beinhalten. Wenn die Dateien auf einen anderen Server verschoben werden, sind alle Hyperlinks weiterhin funktionsfähig, sofern die relativen Positionen der Seiten unverändert bleiben. Beispielsweise verweist ein Hyperlink auf Produkte.htm auf eine Seite im gleichen Ordner; wenn beide Seiten nun in den gleichen Ordner auf einem anderen Server verschoben werden, ist der URL im Hyperlink nach wie vor korrekt.

Wenn Sie in FrontPage Hyperlinks erstellen, müssen Sie den Ziel-URL nicht kennen; stattdessen können Sie einfach die Seite oder die Datei in einem Web, einem Dateisystem oder im World Wide Web suchen, und FrontPage stellt dann den korrekten URL bereit. Wenn Sie einen Hyperlink zu einem Ziel im gleichen Web erstellen, erstellt FrontPage einen relativen URL. Wenn Sie eine Datei in einem Web umbenennen oder verschieben, aktualisiert FrontPage alle URLs, die auf diese Datei verweisen. Durch die Erzeugung von relativen URLs hilft FrontPage Ihnen, Zeit zu sparen und stellt sicher, dass Ihre Website übertragbar ist.


  • Navigieren in Ihrer Website. Sie sollten für Sitebesucher eine Möglichkeit bereitstellen, um sich nach dem Öffnen Ihrer Homepage auf die anderen Seiten in Ihrer Website zu bewegen. Bei vielen Sites wird hierfür eine Reihe von Schaltflächen oder Texthyperlinks verwendet, mit deren Hilfe der Sitebesucher auf die Hauptseiten einer Site gelangen kann:

    • Home Neuigkeiten Inhalt Suchen

    Sie können Ihre Website jedoch auch mit einem Inhaltsverzeichnis versehen, indem Sie eine Liste von Hyperlinks erstellen, die auf die jeweiligen Hauptseiten verweisen.

  • Verknüpfungen mit anderen Seiten, Dateien und Dokumenten. Mithilfe von Hyperlinks können Sie Verknüpfungen mit anderen Seiten und auch mit Bildern, Dateien und Microsoft Office-Dokumenten herstellen. Beispielsweise können Sie einen Hyperlink erstellen, mit dem ein Bild angezeigt wird, oder Sie können eine Liste mit Hyperlinks zu Ihren bevorzugten Websites im World Wide Web bereitstellen.
  • Erstellen einer E-Mail-Nachricht. Sie können einen Hyperlink erstellen, mit dem eine E-Mail-Nachricht an die von Ihnen angegebene Adresse erstellt werden kann. Wenn Sie beispielsweise Rückmeldungen von Ihren Sitebesuchern erhalten möchten, können Sie eine Verknüpfung erstellen, mit der eine E-Mail-Nachricht an die Adresse des Webmasters Ihrer Site gestartet wird.

Weitere Informationen

Info über Navigationsleisten

Erstellen eines Hyperlinks


Info über Listen

Sie können verschiedene Typen von Listen erstellen:

  • Aufzählungsliste zur Darstellung von ungeordneten Elementen. Es können Standard-Aufzählungszeichen (rund, quadratisch oder kreisförmig), von Ihnen erstellte, benutzerdefinierte Aufzählungszeichen oder Aufzählungszeichen aus einem Design (sofern für die Seite verfügbar) verwendet werden.
  • Nummerierte Liste zur Darstellung von sequentiellen Elementen. Sie können aus arabischen oder römischen Ziffern (Groß- oder Kleinschrift), oder aus Buchstaben (Groß- oder Kleinschrift) wählen.
  • Definitionsliste zur Darstellung einer Liste von Begriffen und Definitionen. Begriffe werden gewöhnlich linksbündig angezeigt, während die Definitionen eingerückt sind.
  • Verzeichnisliste zur Darstellung einer Abfolge kurzer Begriffe. Viele Webbrowser ignorieren dieses Format.
  • Menüliste zur Darstellung einer ungeordneten Liste kurzer Einträge. Viele Webbrowser ignorieren dieses Format.

Die exakte Formatierung einer Liste hängt vom Webbrowser des Sitebesuchers ab. Wenn auf der Seite ein Design verwendet wird, übernimmt die Liste Schriftart und Absatzformatierung aus dem Design.

Erstellen von komplexen Listen

Sie können Listen erstellen, die aus mehreren verschachtelten Ebenen und Absätzen bestehen und für jede Ebene unterschiedliche Listenformate verwenden. Außerdem können Sie ausblendbare Listen erstellen, in denen der Sitebesucher unterschiedliche Ebenen anzeigen oder verbergen kann, indem er auf die Titel klickt.

Die folgende Liste ist das Beispiel einer Liste mit mehreren Ebenen, wobei jede Ebene eine unterschiedliche Formatierung besitzt. Diese Liste ist auch ausblendbar; klicken Sie auf Thema B und dann auf Überschrift 1, um zu sehen, wie das funktioniert:

  1. Überschrift 1
    1. Thema A

      2. Absatz

    2. Thema B
      • Detail 1
      • Detail 2
  2. Überschrift 2

Weitere Informationen

Erstellen einer Liste


Neuigkeiten in Microsoft FrontPage 2000


Tools für das Bearbeiten von Webs
Aufrufen der Hilfe
Bearbeiten von HTML
Veröffentlichen
Integration von Datenbanken
Erweiterbarkeit und Programmierbarkeit
Änderungen an der FrontPage-Benutzeroberfläche
FrontPage und Office
Verwenden von FrontPage überall auf der Welt
Installation


Pixelgenaues Positionieren und Überlagern
Neu! Mithilfe des absoluten und relativen Positionierens können Sie Seitenelemente an beliebigen Stellen auf der Seite und auf verschiedenen Ebenen positionieren.
60 vorgefertigte Designs
Sie können aus 60 vorgefertigten Designs wählen, um einer einzelnen Seite, mehreren Seiten oder einer gesamten Website ein einheitliches Aussehen zu verleihen.
Anpassen von Designs
Neu! Sie können jedes beliebige der vorgefertigten Designs Ihren Vorstellungen entsprechend anpassen, d. h. Sie können die verwendeten Farben, Logos, Grafiken, Hintergründe und Aufzählungszeichen ändern, um auf diese Weise ein neues Design zu erstellen, das genau zu Ihrer Site passt.
Browserübergreifende DHTML-Animationseffekte
Fügen Sie Seiten Dynamic HTML-Effekte einschließlich Animationen sowie ausblendbare Gliederungen hinzu. Animationseffekte können in Microsoft Internet Explorer 4.0 und Netscape Navigator 4.0 angezeigt werden und erscheinen in Webbrowsern der Version 3 als statische Elemente.
Verbesserte Farbtools
Sie können Farben wählen oder benutzerdefinierte Farben erstellen. Mithilfe des Pipettentools können Sie eine Farbe von einer beliebigen Stelle auf dem Bildschirm wählen. Sie können auch eine Farbe aus einer websicheren Farbpalette wählen. Benutzerdefinierte Farben stehen überall da zur Verfügung, wo Sie eine Farbe angeben können, und werden über Bearbeitungssitzungen hinaus gespeichert.
Cascading Stylesheets
Verwenden Sie Cascading Stylesheets, um einer Seite eine an Ihre Vorstellungen angepasste und einheitliche Formatierung zuzuweisen. Sie können verschiedenen Seiten oder sogar einem gesamten Web externe Stylesheets zuweisen.
Verschachtelte Unterwebs
Neu! Mithilfe verschachtelter Unterwebs können Sie eine besser organisierte Webstruktur erstellen. Und Sie können für jedes Unterweb andere Zugriffsberechtigungen gewähren, wodurch es möglich wird, den Zugriff auf jedes Web einzeln zu kontrollieren.
Quellcodeverwaltung
Neu! Mit der Quellcodeverwaltung können Sie eine Datei in einem Web reservieren, so dass diese von keiner anderen Person bearbeitet werden kann. Hiermit lässt sich verhindern, dass andere Autoren Änderungen an Dateien speichern, die Sie gerade bearbeiten. Die Quellcodeverwaltung ermöglicht darüber hinaus, eine vorherige Version der Datei wiederherzustellen.
Workflowberichte
Neu! Sie können den Mitgliedern Ihres Teams Aufgaben für Seiten übertragen. Sie können zwecks Verwaltung Ihrer Webs auch Zustimmungsebenen und -stufen im Veröffentlichungsprozess einrichten und zuweisen.
Dokumenterstellung und -verwaltung
Mehrere Autoren können gleichzeitig Inhalte erstellen und diese Webs hinzufügen, wodurch es möglich wird, im Team zusammenzuarbeiten. Sie können Inhalte auch direkt auf dem Server erstellen, auf dem die FrontPage-Servererweiterungen ausgeführt werden, und Sie können Webs remote verwalten.
Hyperlinks werden automatisch korrigiert
Wenn Sie eine Seite oder eine Grafik in einem Web umbenennen oder verschieben, werden die Hyperlinks automatisch korrigiert. Das funktioniert auch innnerhalb von Microsoft Office.
Gezielte Weberstellung für bestimmte Webbrowser, Features und Server
Neu! Sie können ein Web gezielt für eine bestimmte Umgebung erstellen, wie beispielsweise einen bestimmten Webbrowser oder Webserver, die FrontPage-Servererweiterungen, ASP, DHTML, CSS, Java oder Skript. Hierbei sperrt FrontPage dann automatisch die Funktionen, die auf den Zielsystemen nicht verwendet werden können.
Personalisierte Menüs
Neu! In den Menüs werden nur die am häufigsten benötigten Befehle aufgeführt. Menüs können auf einfache Weise erweitert werden, um alle Befehle anzuzeigen, und sie werden darüber hinaus basierend auf IntelliSense-Regeln automatisch erweitert.
Personalisierte Symbolleisten
Neu! Um den Bildschirm übersichtlich zu halten, nutzen Symbolleisten den verfügbaren Platz gemeinsam basierend auf der jeweiligen Aufgabe und der aktuellen Ansicht, wobei nur die Symbolleisten angezeigt werden, die für die aktuelle Aufgabe relevant sind.
Anpassbare Symbolleisten
Neu! Sie können die von Ihnen gewünschten Schaltflächen in Symbolleisten aufnehmen, wobei Drag&Drop-Befehlssteuerelemente verwendet werden.
Format übertragen
Neu! Mit Format übertragen können Sie das Format des einen Textes schnell auf einen anderen übertragen.
Rechtschreibprüfung im Hintergrund
Neu! FrontPage 2000 unterstreicht falsch geschriebene oder unbekannte Wörter mit einer roten geschlängelten Linie. Sie können mit der rechten Maustaste auf diese Wörter klicken, um einen Vorschlag zur korrekten Schreibweise zu erhalten.
Vorgefertigte Webkomponenten
Neu! Fügen Sie mithilfe der FrontPage-Komponenten wie Kategorien-Komponente und der Office-Webkomponenten, zu denen die Tabellenkalkulation und die dynamischen PivotTable Ansichten sowie die Chart-Komponente gehören, erweiterte Funktionen direkt in Ihre Seiten ein.
Zum Erstellen von Webs wird kein Webserver benötigt
Neu! Zum Erstellen eines Webs benötigen Sie keinen Webserver; Sie können das Web auf Ihrer Festplatte und nach Fertigstellung auf einem Webserver veröffentlichen.
Webserververwaltung
FrontPage verwendet die gleiche Management-Konsole wie Windows NT und Internet Information Services, und Sie können Webs remote verwalten.
Profile wandernder Benutzer
Neu! Beim Einrichten der FrontPage-Arbeitsumgebung auf einem Server werden die Einstellungen für die Benutzer gespeichert, d. h. die Umgebung sieht für den Benutzer immer gleich aus, ungeachtet des Computers, von dem aus die Anmeldung erfolgte.


HTML-Hilfe
Neu! Die HTML-Hilfe ermöglicht Ihnen, Hilfethemen anzuzeigen, während Sie weiterhin in FrontPage arbeiten, was bedeutet, dass Sie die Verfahren schrittweise nachvollziehen können und Ihre Fragen schneller beantwortet werden.
Antwort-Assistent
Neu! Mit dem Antwort-Assistenten erhalten Sie nun schneller Antworten auf Ihre Fragen, da Sie die Fragen mit eigenen Worten formulieren können.


Erhalten von HTML-Quellcode
Neu! Wenn Sie bestehenden HTML-Code und Skripts (einschließlich ASP) in FrontPage bearbeiten, wird Ihr Code nicht geändert, auch nicht der Code, den Sie aus anderen Quellen einfügen. Die Reihenfolge von Tags und Kommentaren, die verwendete Groß-/Kleinschreibung und Leerzeichen bleiben erhalten.
Schnelles Einfügen von Code
Neu! Sie können Schaltflächen oder Dropdownmenüs verwenden, um Code direkt in den HTML-Code einer Seite einzufügen (auf der Registerkarte HTML in der Seitenansicht).
Personalisierte HTML-Formatierung
Neu! Sie können angeben, wie HTML-Code eingerückt werden soll, welche Farben für die Anzeige von Tags verwendet werden sollen, wann Großbuchstaben und wann optionale Tags verwendet werden sollen. Wenn Seiten importiert oder neue Inhalte erstellt werden, wendet FrontPage diese Einstellungen automatisch auch auf den neuen Code an.
Anzeigen der HTML-Tags einer Seite
Neu! Sie können schnell sehen, mit welchen Tags welche Effekte auf den Seiten erzeugt werden, indem Sie die HTML-Tags auf der Registerkarte Normal in der Seitenansicht anzeigen, für die der WYSIWYG-Modus (WYSIWYG - What You See Is What You Get) gilt.


Kontrolle auf Seitenebene
Sie verfügen nun über mehr Kontrolle bei der Veröffentlichung, da Sie exakt angeben können, welche Seiten veröffentlicht werden sollen und welche nicht. Sie können auch festlegen, dass nur die Seiten veröffentlicht werden, die geändert wurden.
Statusanzeige
Neu! Mithilfe einer Statusanzeige können Sie verfolgen, was während des Veröffentlichungsprozesses passiert.
Veröffentlichen an jedem Ort
Sie können Ihre Website bei einem beliebigen ISP veröffentlichen, und zwar ungeachtet, ob auf dessen Server die FrontPage-Servererweiterungen installiert sind.


Datenbankergebnis-Assistent
Sie können Datenbankabfragen einfach und automatisch direkt in Webseiten einfügen, sogar dann, wenn Sie keine Erfahrung im Umgang mit Datenbanken haben. Die Daten sind dynamisch, und bei jedem Laden der Seite werden die aktuellen Daten aus der Datenbank zurückgegeben.
Datenzugriffsseiten
Neu! Sie können mit Microsoft Access erstellte Datenbanken auf einfache Weise in eine Webseite integrieren. Sitebesucher können der Datenbank dann direkt in ihrem Webbrowser Daten hinzufügen oder diese bearbeiten.
Problemloses Veröffentlichen von Datenbanken
Neu! Das Erstellen und Aktualisieren einer Datenbank ist jetzt so einfach wie das Erstellen eines Formulars, basierend auf den Formulardaten einer Seite können Sie nun eine neue Access-Datenbank erstellen oder eine vorhandene bearbeiten.
Bearbeiten von HTML, DHTML, Skript, ASP und XML
Verwenden Sie die Registerkarte HTML, um Seiten und Skripts anzuzeigen und diese direkt zu bearbeiten. Dies gilt für HTML ebenso wie für DHTML, Skript, ASP und XML.


Microsoft Skript-Editor
Neu! Skripts, einschließlich der mit JavaScript und VBScript erstellten, können nun mit dem integrierten Script Editor schneller bearbeitet und nach Fehlern durchsucht („debuggt“) werden .
Visual Basic für Applikationen
Neu! Mit VBA können Sie leistungsfähige FrontPage-basierte Lösungen entwickeln. Nutzen Sie vorhandene Kenntnisse, um diese Lösungen auch auf andere Office-Anwendungen auszudehnen.
Anwendungs-, Dokument- und Webobjektmodelle
Neu! Entwickler können FrontPage, Seiten und Webs durch Programmierung beeinflussen.
Integration von Entwurfszeit-Steuerelementen und Visual InterDev
Erweitern Sie die Funktionalität von FrontPage, indem Sie mit dem Webentwicklungssystem Microsoft Visual InterDev Entwurfszeit-Steuerelemente erstellen.


Integration von Editor und Explorer
FrontPage-Editor und FrontPage Explorer wurden integriert, wodurch Sie Webs in einer Anwendung erstellen und verwalten können.
Benutzeroberfläche wie Microsoft Office
In Office 2000 und FrontPage 2000 werden Designs, Symbolleisten, Menüs, Verknüpfungen und Tools wie Format übertragen, die HTML-Hilfe und die Rechtschreibprüfung im Hintergrund gemeinsam genutzt.
Seitenansicht
Neu! Der FrontPage-Editor steht mit seiner gesamten Funktionalität in der Seitenansicht zur Verfügung, wodurch Sie im gleichen Fenster Webs erstellen und verwalten können.
Ordneransicht
Ermöglicht das Anzeigen aller in einem Web befindlichen Seiten, Grafiken und Dateien.
Berichtsansicht
Sie können schnell eine Liste der Seiten, Grafiken und Dateien Ihres Webs erstellen und das Web analysieren, indem Sie Berichte generieren, in denen alle langsamen Seiten, unverknüpfte Seiten, kürzlich hinzugefügte oder geänderte Dateien, unterbrochene Hyperlinks und Komponentenfehler, Prüfstatus, zugewiesen an, Kategorien, Veröffentlichungsstatus oder der Checkoutstatus aufgeführt werden.
Navigationsansicht
Sie können die Arbeitsweise der Navigationsleisten Ihres Webs festlegen, indem Sie eine Navigationsstruktur für Ihre Site einrichten. Sie können bestimmte Knoten in der Vergrößerung betrachten, und Sie können Hyperlinks zu externen Sites hinzufügen.
Hyperlinkansicht
Zeigen Sie eine grafische Sicht aller Hyperlinks an, die zu einer und von einer bestimmten Seite oder einem Microsoft Office-Dokument führen, und erkennen Sie bereits an der Grafik, ob bestimmte Hyperlinks unterbrochen sind
Aufgabenansicht
Sie können verfolgen, welche Aufgaben noch erledigt werden müssen und wem diese Aufgaben zugewiesen wurden, und Sie können schnell den Status, die Beschreibung und die Priorität von Aufgaben überblicken.


Gemeinsame Designs
In Office 2000 und FrontPage 2000 werden Designs gemeinsam verwendet, so dass Seiten, die in Word, Access oder FrontPage erstellt wurden, über ein einheitliches Erscheinungsbild verfügen können.
In Office 2000 wird HTML als systemeigenes Dateiformat verwendet.
Neu! HTML wurde zu einem gleichrangigen Dateiformat wie die Office-eigenen Dateiformate (*.doc, *.xls, *.ppt, *.mdb) erhoben, was bedeutet, dass HTML-Dokumente in etwa auf die gleiche Weise wie Office-Dateien verwendet werden können. In Webs befindliche HTML-Dokumente können in FrontPage auf einfache Weise bearbeitet und gespeichert werden.
Öffnen und Speichern von Office 2000-Dokumenten in Webs mit FrontPage
Sie können Office-Dateien und Webseiten mit FrontPage ebenso einfach direkt in einen Web speichern, wie Sie eine Datei auf Ihrer Festplatte speichern.
HTML-Bearbeitung in Office-Anwendungen integriert
Neu! Wenn Sie eine in einem Web befindliche Office 2000-Datei in FrontPage bearbeiten, wird die Office-Anwendung geöffnet, die zum Erstellen der Datei verwendet wurde, so dass Sie die Datei weiterhin in der Ursprungsanwendung bearbeiten können.
Hinzufügen, Bearbeiten und Verwalten der Office 2000-Webkomponenten
Neu! Mit den Microsoft Office-Webkomponenten (wie Spreadsheet, PivotTable und Chart) können Sie die Funktionalität von Microsoft Excel direkt in Webseiten integrieren.
Gemeinsame Servererweiterungen
Neu! Die Office-Servererweiterungen umfassen die Funktionen der FrontPage-Servererweiterungen, wodurch Sie Webs auch auf Servern veröffentlichen können, auf denen die Office-Servererweiterungen ausgeführt werden.


Lieferbar in 15 Sprachen
FrontPage 2000 ist in Englisch, Französisch, Deutsch, Italienisch, Japanisch, Spanisch, Norwegisch, Holländisch, Schwedisch, Brasilianisch, Koreanisch, Chinesisch (Taiwan), Chinesisch (VR China), Dänisch und Finnisch verfügbar. Darüber hinaus können Sie Webs in der Sprache des jeweiligen Windows-Betriebssystems erstellen und verwalten.
Nur eine einzige ausführbare Datei
Dass nur eine einzige ausführbare Datei benötigt wird, hat den Vorteil, dass Unternehmen die grundlegende Office 2000- oder FrontPage 2000-Installation weltweit standardisieren können und dann je nach Bedarf Unterstützung für die entsprechenden Sprachen hinzufügen können.
Globale Benutzeroberfläche und mehrsprachige Bearbeitungsmöglichkeit
Wenn zusätzliche Sprachen erforderlich sind, können Sie diese einfach aus dem entsprechenen Sprachpaket installieren. Sie können für die FrontPage-Benutzeroberfläche auch eine andere Sprache verwenden als die, in der Sie gerade Inhalte erstellen.
Festlegen der Sprache auf Seitenebene
Neu! Sie können die Sprache für jede Seite separat festlegen, wodurch das Erstellen von mehrsprachigen Inhalten vereinfacht wird. Die für die Seite festgelegte Sprache bestimmt, welche Korrekturtools verwendet werden. Darüber hinaus können Suchprogramme wie beispielsweise Microsoft Index Server (Indexing Services) die Sprache als Suchkriterium verwenden.


Windows Installer-Technologie
Neu! Durch Verwenden der Standard Windows Installer-Technologie von Microsoft, können Sie FrontPage 2000 problemlos zusammen mit Office 2000 installieren.
Installation nach Bedarf
Neu! Programme und Komponenten werden erst installiert, wenn sie benötigt werden, wodurch Speicherplatz auf der Festplatte gespart wird, bis die entsprechende Komponente benötigt wird.
Selbsttätige Reparatur
Neu! Beim Start prüft FrontPage 2000, ob wichtige Dateien fehlen und wo sich diese befinden.
Assistent für benutzerdefinierte Installation
Neu! Der Assistent für benutzerdefinierte Installation ermöglicht es Administratoren, Hilfestellung bei der Verteilung von benutzerdefinierten Versionen von Microsoft Office 2000 und FrontPage 2000 zu geben, die auf der jeweiligen Feature-, Menü- oder Symbolleistenebene über vorgewählte Konfigurationsoptionen verfügen.


Glossar

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z
A

Nach oben

abgeschrägter Rand
Ein dreidimensionaler Kanteneffekt, der dem Rand einer Grafik zugewiesen wird. Den Befehl Abgeschrägter Rand finden Sie auf der Symbolleiste Grafik in der Seitenansicht.
Absatzformatvorlage
In der Seitenansicht von FrontPage werden mit der Absatzformatvorlage die Art der zu verwendenden Schrift, die Schriftgröße sowie weitere Attribute angegeben, die sich auf den Text einer Seite beziehen. In der Absatzformatvorlage wird weiterhin angegeben, ob Aufzählungszeichen oder Absatznummerierungen verwendet werden sollen, und es werden Einzug und Zeilenabstand definiert.
absoluter URL
Die vollständige Internetadresse einer Seite oder einer anderen Ressource im World Wide Web. Der absolute URL umfasst ein Protokoll, wie beispielsweise „http“, die Netzwerkadresse, einen optionalen Pfad sowie den Dateinamen. Beispielsweise ist http://beispiel.microsoft.com/ ein absoluter URL. Siehe auch URL.
Active Server Page
(ASP) Ein Dokument, das eingebettete serverbasierte Skriptbefehle enthält. ASP-kompatible Webserver können diese Skriptbefehle ausführen. Auf der Clientseite stellt sich eine ASP als standardmäßiges HTML-Dokument dar.
ActiveX
Eine Sammlung von Techniken, die es Softwarekomponenten ermöglichen, in einer Netzwerkumgebung zusammenzuarbeiten, und zwar ungeachtet der Programmiersprache, in der die Komponenten erstellt wurden. ActiveX wird in erster Linie zum Entwickeln interaktiver Inhalte für das World Wide Web verwendet, kann jedoch auch in Desktopanwendungen und anderen Programmen eingesetzt werden. Siehe auch ActiveX-Steuerelemente.
ActiveX-Steuerelemente
Wiederverwendbare Softwarekomponenten, die auf ActiveX-Technik basieren. ActiveX-Steuerelemente können in Webseiten eingebettet werden, um Animations- und andere Multimediaeffekte, interaktive Objekte und innovative Anwendungen zu produzieren. Sie können in einer Vielzahl von Programmiersprachen wie beispielsweise C, C++ und Visual Basic geschrieben werden.
Aktive Datenobjekte
(ADO) Komponenten, die es Clientanwendungen ermöglichen, über einen Provider auf Daten in einer datei- oder serverbasierten Datenbank zuzugreifen und diese zu ändern.
aktiver Hyperlink
Der Hyperlink, der in einem Webbrowser aktuell ausgewählt wurde. In einigen Webbrowsern wird der aktive Hyperlink durch eine Farbänderung gekennzeichnet.
aktive Seite, aktives Web
Siehe aktuelle Seite, aktuelles Web.
aktuelle Seite
In FrontPage die Seite, die aktuell in der Seitenansicht bearbeitet wird.
aktuelles Web
In FrontPage das Web, das aktuell geöffnet ist.
animierte GIF-Grafik
Eine Datei, die eine Reihe von GIF-Grafiken (Graphics Interchange Format) enthält, die in schneller Abfolge in einem Webbrowser angezeigt werden und auf diese Weise den Eindruck eines sich bewegenden Bildes erzeugen. Siehe auch GIF.
Anker
Siehe Textmarke.
anonymous FTP
Die Möglichkeit, mithilfe von Internet File Transfer Protocol (FTP) auf ein Remotecomputersystem zuzugreifen, in dem der Benutzer kein persönliches Konto besitzt. Mit „anonymous“ FTP verfügt der Benutzer nur über beschränkte Zugriffsrechte und kann normalerweise nur Dateien aus einem öffentlichen Verzeichnis im Remotesystem auflisten, anzeigen und downloaden bzw. in dieses Verzeichnis uploaden. Bei vielen FTP-Sites ist der Zugriff über „anonymous“ FTP allerdings aus Sicherheitsgründen nicht gestattet. Siehe auch FTP.
Anschluss
Einer der Netzwerk-Ein-/Ausgabekanäle eines Computers, auf dem TCP/IP ausgeführt wird. Im World Wide Web bezieht sich der Begriff „Anschluss“ zumeist auf die Anschlussnummer, unter der ein Server ausgeführt wird. Auf einem einzelnen Computer können eine Vielzahl von Webserver ausgeführt werden, jedoch muss jeder Server über einen eigenen Anschluss verfügen. Der Standardanschluss für Webserver ist 80.
Ansichtenleiste
Eine vertikale Leiste auf der linken Seite des FrontPage-Anwendungsfensters. Mit den Schaltflächen auf der Ansichtenleiste können Sie zu den verschiedenen Ansichten des Webs wechseln, wie beispielsweise zur Ordneransicht oder zur Hyperlinkstatusansicht. Ansichten bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Anzeigenwechsler
Eine Komponente in FrontPage, in der eine Reihe einzelner Grafiken jeweils für eine vorher festgelegte Anzahl von Sekunden angezeigt wird. Dann erfolgt ein Übergang auf die nächste Grafik unter Verwendung eines der verschiedenen Übergangseffekte. Anzeigenwechsel beinhalten normalerweise Hyperlinks zur Website des Anzeigenkunden.
Applet
Siehe Java-Applet.
Artikel
Eine Nachricht oder eine Veröffentlichung in einem Diskussionsforum oder einer Internet-Newsgroup. Ein Artikel kann auch eine Antwort auf einen vorangehenden Artikel sein.
ASCII
(American Standard Code for Information Interchange) Ein Codierungsschema basierend auf 7 oder 8 Bit, mit dem bis zu 256 Zeichen einschließlich Buchstaben, Zahlzeichen, Satzzeichen, Steuerzeichen und anderen Sonderzeichen ein nummerischer Wert zugewiesen wird. ASCII wurde im Jahre 1968 entwickelt, um den Datenaustausch zwischen unterschiedlichen Hardware- und Softwaresystemen zu standardisieren und ist integrativer Bestandteil aller Personalcomputer.
ASP
(Active Server Page) Ein Dokument, das eingebettete, serverbasierte Skriptbefehle enthält. ASP-kompatible Webserver können diese Skriptbefehle ausführen. Auf der Clientseite stellt sich eine ASP als standardmäßiges HTML-Dokument dar, das auf jeder Plattform mit jedem beliebigen Webbrowser angezeigt werden kann.
Assistent
Ein Programm in FrontPage, mit dem basierend auf Ihrer Auswahl in den Eingabebereichen des Assistenten Webs oder Webseiten erstellt werden.
Aufgabe
Ein Element, das mit einem Web in FrontPage verbunden ist und das für eine Aktion steht, die Sie noch ausführen müssen, um das Web fertig zu stellen oder zu verwalten. Einige Aufgaben werden in FrontPage automatisch von Assistenten erzeugt. Sie können jedoch auch eigene Aufgaben hinzufügen. Aufgaben werden in der Aufgabenansicht angezeigt.
Aufgabenansicht
Die Ansicht in FrontPage, in der eine Liste der Aufgaben unterhalten wird, die noch erledigt werden müssen, um ein Web fertig zu stellen oder zu verwalten. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Authentifzierung
In einer Mehrbenutzer- oder Netzwerkumgebung der Prozess, mit dem das System die Anmeldeinformationen eines Benutzers prüft. Hierbei werden der Name und das Kennwort des Benutzers mit einer autorisierten Liste verglichen und, sofern das System eine Übereinstimmung findet, wird dem Benutzer der Zugriff auf das System in der Breite gewährt, wie sie in der Liste der Zugriffsberechtigungen für diesen Benutzer angegeben wurde.
Authentifizierungsdatenbank
Eine Datenbank auf einem Server, in der die Benutzernamen und zugehörigen Kennwörter gespeichert sind.
AutoMiniaturansicht
Ein Tool, mit dem die Miniaturansicht eines Bildes oder einer Fotografie sowie ein Hyperlink zum Originalbild erstellt wird. Den Befehl AutoMiniaturansicht finden Sie auf der Symbolleiste Grafik in der Seitenansicht. Siehe auch Miniaturansicht.
B

Nach oben

Banner
Siehe Seitenbanner.
Basisadresse, Basis-URL
Ein URL, den Sie einer Seite zuweisen können, damit alle relativen URLs auf der Seite in absolute URLs umgewandelt werden. Ein Basis-URL sollte mit dem Dokumentnamen, wie beispielsweise in http://beispiel.microsoft.com/beispiel.htm, oder mit einem abschließenden Schrägstrich, wie in http://beispiel.microsoft.com/subdir/, enden. Siehe auch absoluter URL.
Benutzerwörterbuch
Eine Liste mit Wörtern, die sich nicht im Standardwörterbuch befinden, die der Autor jedoch für die Rechtschreibprüfung als korrekt kennzeichnen möchte. FrontPage greift gemeinsam mit den anderen Anwendungen des Microsoft Office-Pakets auf die gleichen Rechtschreibwörterbücher zu.
Bericht Siteübersicht
In FrontPage der standardmäßig in der Berichtsansicht angezeigte Bericht. Eine Siteübersicht ist eine Kombination aus mehreren Berichten, in denen unverknüpfte Dateien, langsame Seiten, unüberprüfte Hyperlinks, unterbrochene Hyperlinks, Fehler im Zusammenhang mit Seitenkomponenten, nicht verwendete Designdateien und unerledigte Aufgaben aufgeführt werden. Die Siteübersicht ist nützlich zum Ermitteln der Gesamtgröße und des Zustand eines Webs. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Berichtsansicht
Die Ansicht in FrontPage, in der Sie den Inhalt eines Webs analysieren können. Sie können die Gesamtgröße der Dateien im Web berechnen, Sie können anzeigen, welche Dateien nicht mit anderen Dateien verknüpft sind, langsame und nicht mehr aktuelle Seiten finden, Dateien nach Aufgaben oder der Person gruppieren, der die Aufgaben übertragen wurden usw. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Bestätigungsfeld-Komponente
Eine Komponente in FrontPage, die durch den Inhalt eines Formularfeldes ersetzt wird. Diese Komponente erweist sich auf einer Formularbestätigungsseite als nützlich, auf der dadurch der Name des Sitebesuchers oder beliebige andere Daten angezeigt werden können, die in ein Feld eingegeben wurden.
Bestätigungsseite
Eine Seite, die in einem Webbrowser angezeigt und mit der bestätigt wird, dass die Daten, die in ein Formular eingegeben wurden, erfolgreich übermittelt wurden. Der Verweis auf die Bestätigungsseite eines Formulars erfolgt im Dialogfeld der Formularbehandlungsroutine.
besuchter Hyperlink
Ein Hyperlink auf einer Seite, der bereits aktiviert wurde. Besuchte Hyperlinks werden im Webbrowser normalerweise in einer hierfür festgelegten Farbe angezeigt.
Bild
Eine Grafikdatei, die auf einer Webseite eingefügt und in einem Webbrowser angezeigt werden kann. In FrontPage können Sie Grafiken der folgenden Formate importieren: GIF, JPEG (Standard und progressiv), BMP (Windows und OS/2), TIFF, TGA, RAS, EPS, PCX, WMF und PNG. Importierte Grafiken werden in das GIF-Format (bei Grafiken mit bis zu 256 Farben) oder in das JPEG-Format (bei Grafiken mit mehr als 256 Farben) konvertiert, wenn die Seite im aktuellen Web gespeichert wird. Wird auch als Abbildung bezeichnet.
Bild nach Zeitplan einschließen, Komponente
Eine Komponente in FrontPage, die auf einer Seite während eines bestimmten Zeitraums durch eine Grafik ersetzt wird. Nach Ablauf des vorgegebenen Zeitraums wird die Grafik nicht mehr angezeigt. Dies ist nützlich, wenn Informationen angezeigt werden sollen, die nur eine begrenzte Aktualität besitzen, wie beispielsweise die Ankündigung eines neuen Produkts oder Dienstes.
BMP
(Bitmap) Das Standardformat für Grafikdateien auf einem Windows-kompatiblen Computer. Bitmapgrafiken unterstützen 24-Bit-Farben und können für Windows- oder OS/2-Systeme gespeichert werden. FrontPage kann BMP-Dateien importieren.
Browser
Siehe Webbrowser.
browsersichere Palette
Eine Farbpalette, die nur 216 von 256 möglichen Farben enthält und die verwendet wird, um die Farben von Grafiken und Bildern in Webbrowsern plattformübergreifend präzise wiederzugeben. Die verbleibenden 40 Farben unterscheiden sich auf IBM- und Macintosh-kompatiblen Computern und werden daher nicht verwendet.
C

Nach oben

Cascading Stylesheet
(CSS) Eine HTML-Spezifikation, die vom World Wide Web Consortium entwickelt wurde und die es den Autoren von Webseiten ermöglicht, HTML-Dokumenten Stylesheets zuzuweisen. Stylesheets können typographische Informationen zum Erscheinungsbild einer Seite enthalten, wie beispielsweise Angaben zur Schriftart des Textes auf der Seite. Mit CCS wird darüber hinaus auch die Art und Weise vorgegeben, wie die Stylesheets des HTML-Dokuments und die benutzerseitig erstellte Formatvorlage verbunden werden.
CGI
(Common Gateway Interface) Eine Standardmethode für das Erweitern der Funktionalität von Webservern, indem auf dem Webserver in Reaktion auf die jeweiligen Anforderungen von Webbrowsern Programme oder Skripts ausgeführt werden. CGI wird häufig bei der Verarbeitung von Formularen verwendet, wobei der Webbrowser Formulardaten an ein CGI-Skript auf dem Server sendet, das Skript die Daten in eine Datenbank einfügt und die Ergebnisse in Form einer Webseite zurücksendet. Unter Verwendung von CGI kann eine Webseite wesentlich dynamischer gestaltet werden und für den Benutzer Möglichkeiten der Interaktion bereitstellen.
Client
In einem LAN (Local Area Network, lokales Netzwerk) oder im Internet ein Computer, der auf freigegebene Netzwerkressourcen zugreift, die von einem anderen Computer bereitgestellt werden. Siehe auch Server.
clientseitige Imagemap
Eine Imagemap, die den Ziel-URL eines jeden Hotspots direkt auf einer Webseite codiert. Bei clientseitigen Imagemaps ist keine Verarbeitung seitens eines Servers erforderlich, damit Sitebesucher den Hyperlinks auf der Imagemap folgen können. Allerdings werden clientseitige Imagemaps nicht von allen Webbrowsern unterstützt. Siehe auch Imagemap.
clientseitiges Programm
Im Internet ein Programm, das auf einem Clientcomputer anstatt auf einem Server ausgeführt wird.
D

Nach oben

Datei
Eine mit einem Namen versehene Sammlung von Informationen, die auf einem Computer gespeichert ist. Der englische Begriff „File“ ist auch die Bezeichnung für ein Internetprotokoll, das sich auf Dateien auf einem Datenträger oder in einem LAN bezieht. In FrontPage können Sie in der Seitenansicht mit file:// Hyperlinks zu Dateien erstellen.
Dateiserver
Ein in ein Netzwerk eingebundener Computer, auf dem Dateien gespeichert sind und der den Zugriff hierauf ermöglicht. Siehe auch Server.
Dateityp
Das Format einer Datei, das im Allgemeinen durch die Dateinamenerweiterung gekennzeichnet wird. Computeranwendungen können normalerweise nur eine begrenzte Anzahl Dateitypen verarbeiten.
Datenbank
Eine Datei, die Datensätze mit Informationen enthält, die so geordnet und präsentiert werden, dass sie einen bestimmten Zweck erfüllen, wie beispielsweise die Vereinfachung des Suchens, Sortierens und Neukombinierens von Daten. Datenbanken können im World Wide Web veröffentlicht werden, damit Sitebesucher in den Datensätzen enthaltene Informationen nachschlagen oder neue Informationen zur Datenbank hinzufügen können.
Datenbankergebnis-Assistent
In FrontPage ein Assistent, der Sie durch die Erstellung eines Bereichs auf einer Seite führt, in dem die Informationen angezeigt werden, die als Ergebnis einer Datenbankabfrage zurückgegeben werden. Hierzu können Sie eine bereits vorhandene Datenbank verwenden oder veranlassen, dass der Assistent eine Datenbank für Sie erstellt.
Datensatz
In einer Datenbank eine Gruppe zusammenhängender Felder mit Daten, die als Einheit betrachtet werden. Datensätze sind die logischen Äquivalente der Zeilen einer Tabelle. In FrontPage wird ein Gruppe von Datensätzen als Recordset bezeichnet.
Datenverbindung
In FrontPage eine Verbindung, bei der der Name, die Adresse sowie optional weitere Informationen zu einer Datenbankdatei angegeben werden.
Design
Mit einem Design werden den Elementen auf den Seiten eines FrontPage-basierten Webs professionell gestaltete Grafiken zugewiesen. Zum Lieferumfang von FrontPage gehört eine Sammlung mit über 50 Designs, die aus jeweils konsistenten Gestaltungselemente und Farbschemas für Aufzählungszeichen, Schriftarten, Grafiken, Navigationsleisten und andere Seitenelemente bestehen. Wird ein solches Design zugewiesen, erhalten Seiten und Navigationsleisten in einem Web ein attraktives und einheitliches Erscheinungsbild.
Diskussionsfaden
In Konversationen per E-Mail und in Internet-Newsgroups eine Reihe von Nachrichten und Antworten, die alle mit einem bestimmten Thema befasst sind.
Diskussionsgruppe
Ein FrontPage-basiertes Web, das interaktive Diskussionen zwischen Sitebesuchern unterstützt. Die Besucher senden Themen oder Antworten auf Themen ein, indem sie Text in ein Formular eingeben, das sie dann absenden. Besucher können die Gruppe auch mithilfe eines Suchformulars durchsuchen oder unter Verwendung eines Inhaltsverzeichnisses auf Beiträge zugreifen.
Dokumentvorlage
Eine Sammlung vordefinierter Formate für Text und Grafiken, auf deren Grundlage neue Seiten und Webs erstellt werden können. Nachdem eine Seite oder ein Web unter Verwendung einer Dokumentvorlage erstellt wurde, können Sie die Seite oder das Web Ihren Vorstellungen entsprechend anpassen.
Domänenname
Die Adresse eines Netzwerkstandorts in einem Format, das den Eigentümer der Adresse identifiziert: server.organisation.typ. Beispielsweise identifiziert der Domänennamen www.whitehouse.gov den Webserver im Weißen Haus in den Vereinigten Staaten. Siehe auch Netzwerkadresse.
Dropdownmenü-Feld
Ein Formularfeldelement, mit dem eine Auswahlliste in Form eines Dropdownmenüs erstellt wird. Ein Fomularfeldelement vom Typ Dropdownmenü kann so konfiguriert werden, dass die Auswahl vieler Felder oder nur eines einzigen Feldes zulässig ist.
Dynamic HTML
(DHTML) Eine Erweiterung der Programmiersprache HTML, mit der die Erstellung von Präsentationseffekten für Text und Objekte ermöglicht wird. In FrontPage können Sie die Symbolleiste DHTML Effekte verwenden, um Seitenelementen Effekte hinzuzufügen, ohne dass Sie hierfür über Programmierkenntnisse verfügen müssen.
E

Back to top

Editor
Ein Programm, mit dem Dateien erstellt oder vorhandene Dateien geändert werden können. In FrontPage ist die Seitenansicht ein Webseiten-Editor und die Registerkarte HTML in der Seitenansicht ein HTML-Editor. Sie können Dateien in FrontPage-basierten Webs mit externen Editoren verknüpfen, so dass diese Dateien beim Doppelklicken auf den Dateinamen in dem jeweils verknüpften Bearbeitungsprogramm geöffnet werden. Beispielsweise können Sie Bilddateien mit Ihrem bevorzugten Bildbearbeitungsprogramm wie z.B. Microsoft Image Composer verknüpfen, damit diese immer in diesem Programm geöffnet werden.
Eigenschaften
In FrontPage die Charakteristiken eines Elements im aktuellen Web, wie beispielsweise Titel und URL eines Webs oder Name und Anfangswert eines Formularfeldes. Sie können auch Eigenschaften für Seitenelemente wie beispielsweise Tabellen, Grafiken und aktive Elemente festlegen.
Eingabehilfen
Hardware- oder Softwarekomponenten eines Systems, durch die es auch für Personen mit Körperbehinderungen, wie beispielsweise Lähmungen, Blindheit oder Gehörlosigkeit, nutzbar wird.
eingebettete Dateien
In FrontPage Grafiken, Bilder, Audiodateien und Videoclips, die aus einem Dateisystem oder aus der Zwischenablage in der Seitenansicht in eine Seite eingefügt wurden. Beim Speichern der aktuellen Seite werden Sie aufgefordert, eingebettete Dateien ebenfalls zu speichern.
eingebettete Formatvorlage
Eine Methode, mit der Eigenschaften und Werte eines Cascading Stylesheets einem Element auf einer Seite, wie beispielsweise einer Tabelle, einer Grafik oder einem ActiveX-Steuerelement, zugewiesen werden. Sie können diese Methode auch dann verwenden, wenn die Seite nicht mit einem externen Stylesheet verknüpft ist oder kein eingebettetes Stylesheet enthält.
eingebettete Framesseite
Eine Framesseite, die in einem ihrer Frames eine weitere Framesseite enthält. Siehe auch Framesseite, Frame.
eingebettetes Stylesheet
Ein Cascading Stylesheet, das in eine Seite eingebettet ist. Die Formatvorlagen in einem eingebetteten Stylesheet können nur der Seite zugewiesen werden, die das Stylesheet enthält, und erweitern entweder die in einem beliebigen mit der Seite verknüpften externen Stylesheet definierten Formatvorlagen oder setzen diese außer Kraft.
einzeiliges Textfeld
Ein beschriftetes, einzeiliges Formularfeld, in das ein Sitebesucher Text eingeben kann.
E-Mail
(elektronische Post) Der Austausch von E-Mail-Nachrichten und Anlagen in Form von Computerdateien über ein Kommunikationsnetz wie beispielsweise ein LAN oder das Internet.
Entwurfszeit-Steuerelement
Ein ActiveX-Steuerelement, das beim Gestalten oder Bearbeiten einer Seite verwendet wird. Entwurfszeit-Steuerelemente, die auf dem Clientcomputer installiert sind, werden in der Seitenansicht von FrontPage aufgeführt. Siehe auch ActiveX.
EPS
(Encapsulated PostScript) Eine Erweiterung des von Adobe Systems entwickelten Grafikdateiformats PostScript. EPS ermöglicht die Integration von Grafikdateien vom Typ PostScript in andere Dokumente. FrontPage kann EPS-Dateien importieren.
erneut Einlesen
Das Ändern der Pixelmenge eines Bildes oder einer Grafik (und damit der physikalischen Größe der Datei). Der Vorgang des erneuten Einlesens kann hierbei nach unten (die Anzahl der Pixel wird verringert) oder nach oben (die Anzahl der Pixel wird erhöht) gerichtet erfolgen. Wird die Anzahl der Pixel verringert, werden Pixelinformationen aus der Grafik gelöscht. Wird die Anzahl der Pixel erhöht, werden basierend auf den entsprechenden Farbwerten der vorhandenen Pixel neue Pixel erstellt. Verringern Sie erst die Pixelanzahl einer Grafik, und erhöhen Sie diese anschließend wieder bis zur ursprünglichen Auflösung, verschlechtert sich die Qualität der Grafik in gravierendem Maße. Den Befehl Erneut einlesen finden Sie auf der Symbolleiste Grafik von FrontPage.
Ersetzen-Komponente
Eine Komponente in FrontPage, die vom Wert einer gewählten Seiten- oder Webvariablen ersetzt wird.
externer Hyperlink
Ein Hyperlink, der auf eine Seite oder eine Datei außerhalb des aktuellen Webs verweist.
externes Stylesheet
Ein Cascading Stylesheet in einer Datei mit der Dateinamenerweiterung *.css. Die CSS-Datei besteht lediglich aus Formatvorlagenregeln in gültiger CSS-Syntax ohne umgebende HTML-Tags. Durch die Definition von Formatvorlagen in einem oder mehreren externen Stylesheets und das Verknüpfen derselben mit Seiten in einem Web stellen Sie ein einheitliches Erscheinungsbild dieser Seiten sicher. Wenn Sie eine Formatvorlage in dem externen Stylesheet ändern, wird diese Änderung für alle Seiten wirksam, die mit dem Stylesheet verknüpft sind.
F

Nach oben

FAQ
(Frequently Asked Questions, häufig gestellte Fragen) Ein Dokument, in dem allgemeine Fragen und Antworten zu einem bestimmten Thema gesammelt werden. FAQs werden häufig in Internetnewsgroups veröffentlicht, in denen neue Teilnehmer immer wieder die gleichen Fragen stellen, die regelmäßige Leser bereits viele Male beantwortet haben.
Firewall
Eine Methode zum Schützen der Dateien und Programme auf einem Netzwerk vor Benutzern in einem anderen Netzwerk. Ein Firewall dient einerseits als Sperre für unerwünschte Zugriffe auf ein geschütztes Netzwerk und ermöglicht andererseits dem geschützten Netzwerk den Zugriff auf Netzwerke außerhalb des Firewalls. Eine Organisation installiert normalerweise einen Firewall, um ihren Benutzern den Zugriff auf das Internet zu ermöglichen und gleichzeitig auch die internen Daten zu schützen. FrontPage ermöglicht Benutzern das Überarbeiten von Webs im Internet auch von einem geschützten Netzwerk aus.
Formatvorlage
Formatvorlagen werden verwendet, um Schriftart, Ausrichtung und Textabstand, das Erscheinungsbild von Hintergrundseiten und andere HTML-Attribute zu steuern. Eine Sammlung von Formatvorlagen wird als Stylesheet bezeichnet. Siehe auch Cascading Stylesheet.
Formular
Eine Sammlung von Dateneingabefeldern auf einer Seite, die auf einem Webserver verarbeitet werden. Die Daten werden an den Server gesendet, wenn der Sitebesucher das Formular durch Klicken auf eine Schaltfläche oder, in einigen Fällen, durch Klicken auf eine Grafik abschickt.
Formularbehandlungsroutine
Ein Programm auf einem Server, das ausgeführt wird, wenn ein Sitebesucher ein Formular abschickt. In FrontPage wird ein Formular im Dialogfeld Formulareigenschaften mit einer Formularbehandlungsroutine verknüpft.
Formularbehandlungsroutine für Diskussion
In FrontPage eine Formularbehandlungsroutine, die es Sitebesuchern ermöglicht, an Onlinediskussionen teilzunehmen. Mit der Formularbehandlungsroutine für Diskussion werden die Daten aus einem Formular gesammelt und als HTML-Seite formatiert, die dann einem Inhaltsverzeichnis und einem Textindex hinzugefügt wird. Darüber hinaus können mit der Formularbehandlungsroutine für Diskussion auch Daten aus dem Formular gesammelt und diese in einem ausgewählten Format gespeichert werden.
Formularbehandlungsroutine für E-Mail
Siehe Formularbehandlungsroutine zum Speichern von Ergebnissen.
Formularbehandlungsroutine für Registrierung
In FrontPage eine Formularbehandlungsroutine, die es Sitebesuchern ermöglicht, sich automatisch für den Zugriff auf einen Dienst, der als Website implementiert ist, zu registrieren. Mit der Formularbehandlungsroutine für Registrierung werden Sitebesucher in eine Authentifizierungsdatenbank aufgenommen, dem Formular anschließend weitere optionale Daten entnommen und in einem von vielen unterstützten Formaten gespeichert.
Formularbehandlungsroutine zum Speichern von Ergebnissen
In FrontPage eine Formularbehandlungsroutine, mit der die Informationen aus einem Formular abgerufen und in einem der vielen Formaten gespeichert oder an eine E-Mail-Adresse gesendet werden können. Wenn ein Sitebesucher ein Formular abschickt, hängt die Formularbehandlungsroutine zum Speichern von Ergebnissen die Formularinformationen in dem von Ihnen angegebenen Format an eine Datei auf dem Server an.
Formularfeld
Ein Dateneingabefeld auf einer Seite. Der Sitebesucher gibt Informationen in ein Feld ein, indem er entweder Text eingibt oder ein Feld auswählt.
Frame
Ein Bereich in einem Webbrowserfenster, der mithilfe einer Framesseite definiert wird. Ein Frame wird in einem Webbrowser als einer von mehreren unterschiedlichen Bereichen dargestellt, in dem Seiten angezeigt werden können. Ein Frame kann über Bildlauffelder verfügen, in der Größe veränderbar sein und einen Rahmen aufweisen. Sie zeigen eine Seite in einem Frame an, indem Sie einen Hyperlink zu der Seite erstellen und den Frame als Teil des Hyperlinks angeben. Siehe auch Framesseite.
Framesseite
Eine Seite, mit der das Fenster eines Webbrowsers in verschiedene Bereiche, so genannte Frames, unterteilt wird, in denen unabhängig voneinander mehrere Webseiten angezeigt werden können. Siehe auch Frame.
Frameset
Siehe Framesseite.
FrontPage Editor
In FrontPage 98 und den Vorläuferversionen die Anwendung zum Erstellung und Bearbeiten von Webseiten. In FrontPage 2000 erstellen und bearbeiten Sie Webseiten in der Seitenansicht.
FrontPage Explorer
In FrontPage 98 und den Vorläuferversionen die Anwendung zum Pflegen, Testen und Veröffentlichen von Webs. In FrontPage 2000 pflegen, testen und veröffentlichen Sie Webs mithilfe einer der fünf Webansichten.
FrontPage-Servererweiterungen
Eine Sammlung mit Programmen und Skripts, die die Dokumenterstellung in FrontPage unterstützen und die Funktionalität eines Webservers erweitern. Die FrontPage-Servererweiterungen stehen für Microsoft Internet Information Services (IIS) und andere populäre Windows- und UNIX-Webserver zur Verfügung. Wenn Sie prüfen möchten, ob Ihr Webserver unterstützt wird, besuchen Sie http://www.microsoft.com/germany/frontpage/
FTP
(File Transfer Protocol) Der Internetdienst, mit dem Dateien über Standardtelefonleitungen von einem Computer auf einen anderen übertragen werden können. FTP-Hyperlinks (ftp://) können Sie in der Seitenansicht von FrontPage erstellen.
G

Nach oben

Gateway Script
Siehe CGI.
Gemeinsame Randbereiche
Bereiche auf Seiten, die für Inhalte vorbehalten sind, die einheitlich auf alle Seiten eines Webs angezeigt werden sollen. Gemeinsame Randbereiche enthalten normalerweise Navigationsleisten, also Hyperlinks zu anderen Seiten im aktuellen Web. Wenn Sie ein Web in der Navigationsansicht von FrontPage erstellen, werden gemeinsame Randbereiche und Navigationsleisten automatisch erstellt und aktiviert, auch wenn Sie in der Webstruktur Seiten hinzufügen, verschieben oder entfernen.
gesichteter Hyperlink
Siehe besuchter Hyperlink.
GIF
(Graphics Interchange Format) Ein Format für Grafikdateien, das häufig verwendet wird, um Grafiken mit indizierten Farben im World Wide Web anzuzeigen. Bei GIF handelt es sich um ein komprimiertes Format, das mit dem Ziel entwickelt wurde, die Dateiübertragungszeiten über Standardtelefonleitungen zu verkürzen. FrontPage kann GIF-Dateien importieren und exportieren. Siehe auch GIF mit Zeilensprung.
GIF mit Zeilensprung
Ein Bild im GIF-Format, das in einem Webbrowser schrittweise aufgebaut wird, wobei immer detailliertere Versionen des Bildes angezeigt werden, bis die gesamte Datei gedownloaded wurde. Siehe auch GIF.
Grafikdateiformate
FrontPage kann die folgenden Grafikdateiformate importieren: BMP, EPS, GIF, JPEG, PCD, PCX, PNG, RAS, TGA, TIFF und WMF. Wenn Sie das Web speichern, wandelt FrontPage diese Grafiken (falls erforderlich) basierend auf der Farbtiefe der Originaldatei in das Dateiformat GIF, JPEG oder PNG um.
Gültigkeitsprüfung für Daten
Eine Sammlung von Regeln, die Sie Formularfeldern zuweisen können, um die Art der Daten einzuschränken, die Sitebesucher in Formulare eingeben können. Beispielsweise können Sie mit diesen Regeln festlegen, dass in ein Feld „Name“ in einem Formular nur Buchstaben und keine Zahlen eingegeben werden können.
H

Nach oben

Hintergrundsound
Eine Audiodatei, die mit einer Webseite verbunden ist. Wenn die Seite in einem Webbrowser angezeigt wird, wird der Sound entweder kontinuierlich oder so oft abgespielt, wie auf der Seite angegeben wurde.
Homepage
Im World Wide Web die Zugangsseite zu einer Reihe von Webseiten und anderer Dateien in einer Website. Die Homepage wird standardmäßig angezeigt, wenn sich ein Besucher mithilfe eines Webbrowsers zu einer Site begibt. Der Name der Homepage ist abhängig vom Typ des Webservers, der als Host für die Website verwendet wird. Bei einigen Webservern wird Index.htm als Name für die Homepage reserviert, andere verwenden Default.htm als Standardname für die Homepage.
Host
Siehe Server.
Hostname
Siehe Netzwerkadresse.
Hotspot
Ein grafisch definierter Bereich in einer Grafik oder einem Bild, der einen Hyperlink enthält. Eine Grafik mit einem Hotspot wird als Imagemap bezeichnet. Hotspots sind in Webbrowsern unsichtbar. Sitebesucher können jedoch feststellen, ob ein Hotspot vorhanden ist, da sich in diesem Fall das Aussehen des Mauszeigers ändert, wenn die Maus über die Grafik bewegt wird. Siehe auch Imagemap.
Hoverschaltfläche, Komponente
Eine animierte Schaltfläche in der Navigationsleiste einer Webseite, die aktiviert wird, wenn der Mauszeiger über die Schaltfläche bewegt wird oder auf die Schaltfläche geklickt wird. Siehe auch Navigationsleiste.
HTML
(HyperText Markup Language) Die standardmäßige „Auszeichnungssprache“ (Markup Language), die für Dokumente im World Wide Web verwendet wird. Die Entwicklung von HTML erfolgt seitens des World Wide Web Consortiums. Bei der Programmiersprache HTML werden Tags verwendet, um anzugeben, wie Seitenelemente, wie beispielsweise Text und Grafiken in einem Webbrowser angezeigt werden sollen und wie ein Webbrowser auf Benutzeraktionen, wie beispielsweise das Aktivieren von Hyperlinks durch Tastendruck oder Mausklick reagieren soll. Die meisten Webbrowser, insbesondere Microsoft Internet Explorer und Netscape Navigator, erkennen auch HTML-Tags, die noch nicht Bestandteil des aktuell gültigen Standards sind. FrontPage liest und schreibt HTML-Dateien, daher ist keine Kenntnis der Programmiersprache HTML erforderlich. Siehe auch World Wide Web Consortium.
HTML-Attribut
Ein Wert, der innerhalb eines HTML-Tags verwendet wird, um dem zu definierenden Objekt zusätzliche Eigenschaften zuzuweisen. FrontPage weist einige Attribute automatisch bei der Erstellung eines Objekts, wie beispielsweise eines Absatzes oder einer Imagemap, zu. Sie können andere Attribute zuweisen, indem Sie die Eigenschaften des Objekts im jeweiligen Eigenschaftendialogfeld bearbeiten.
HTML der Framesseite, Registerkarte
Die Registerkarte in der Seitenansicht, auf der der HTML-Code der aktiven Framesseite angezeigt wird. Siehe auch Framesseite.
HTML, Registerkarte
In FrontPage die Registerkarte in der Seitenansicht, auf die Sie klicken, um den HTML-Code einer Seite anzuzeigen. Auf dieser Registerkarte können Sie den HTML-Code einer Seite auch direkt bearbeiten.
HTML-Tag
Eine Textzeichenfolge, die in HTML verwendet wird, um den Typ, das Format und das Erscheinungsbild eines Seitenelements zu kennzeichnen. FrontPage erstellt für jedes Element auf einer Seite automatisch HTML-Tags.
HTML-Zeichencodierung
Eine Standardtabelle, in der jedes Zeichen in einem Zeichensatz mit einem nummerischer Index verbunden wird. Diese Tabelle wird verwendet, wenn Sie eine Webseite für den Einsatz in einer speziellen Sprache erstellen. Wird auch als Codeseite bezeichnet.
HTTP
(Hypertext Transfer Protocol) Das Internetprotokoll, das es Webbrowsern ermöglicht, Informationen von World Wide Web-Servern abzurufen.
Hyperlink
Ein Hyperlink ist ein Verweis von einem Text, einem Bild oder einer Grafik oder von einer Imagemap zu einer Seite oder Datei im World Wide Web. Im World Wide Web stellen Hyperlinks die wichtigste Methode dar, um zwischen Seiten und verschiedenen Websites zu navigieren. Wird auch als Link bezeichnet.
Hyperlinkansicht
Eine Ansicht in FrontPage, in der der Status der Hyperlinks in einem Web angezeigt wird. Diese Liste enthält sowohl interne als auch externe Hyperlinks, und es erfolgt eine grafische Anzeige, ob Hyperlinks überprüft wurden oder unterbrochen sind. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Hypertext
Ursprünglich alle Informationen in Textform auf einen Computer, die Sprungbefehle zu anderen Informationen enthalten. Diese Hypertextsprungbefehle werden als Hyperlinks bezeichnet. Im World Wide Web stellt Hypertext die wichtigste Methode dar, um zwischen Seiten und verschiedenen Websites zu navigieren. Der Hypertext auf Webseiten wurde erweitert, um neben Hyperlinks an Textpassagen auch solche an einem Bild oder einer Grafik sowie an Imagemaps zu ermöglichen.
I

Nach oben

ID-Selektor
In der Formatvorlagendefinition (oder der Formatvorlagenregel) einer Cascading Stylesheet ein Selektor, der verwendet wird, um eine Formatvorlage für ein einzelnes Seitenelement zu definieren (normalerweise als eingebettete Formatvorlage).
IIS
Siehe Internet Information Services.
Imagemap
Eine Grafik, die einen oder mehrere unsichtbare Bereiche, so genannte Hotspots, umfasst, denen Hyperlinks zugewiesen wurden. Normalerweise enthält eine Imagemap für den Sitebesucher sichtbare Hinweise auf die Informationen, die verfügbar werden, wenn er auf den jeweiligen Teil des Bildes oder der Grafik klickt. Beispielsweise könnte aus einer geographischen Karte eine Imagemap erstellt werden, indem jeder interessanten Region auf der Karte ein Hotspot zugewiesen wird.
Inhaltsverzeichnis-Komponente
Eine Komponente in FrontPage, mit der eine Gliederung des Webs mit Hyperlinks zu jeder Seite erstellt wird. Diese Gliederung wird von der Inhaltsverzeichnis-Komponente jedes Mal aktualisiert, wenn sich der Inhalt eines Webs ändert.
interner Hyperlink
In FrontPage ein Hyperlink, der auf eine beliebige Seite oder Datei innerhalb des aktuellen Webs verweist. Siehe auch Hyperlink.
internes Web
Eine Website, die organisationsintern erstellt wurde und auf die nur Mitglieder dieser Organisation über ein Intranet Zugriff haben. Siehe auch Intranet.
Internet
Der weltweite Verbund aus Computern, Netzwerken und Gateways, die TCP/IP-Protokolle verwenden, um miteinander zu kommunizieren. Im Herzen des Internets befinden sich Hochgeschwindigkeitsleitungen für die Datenkommunikation zwischen den wichtigsten Hostcomputern, und es setzt sich aus tausenden von Computersystemen zusammen, kommerziellen ebenso wie solchen im Regierungs- und Bildungsbereich, die Daten und Nachrichten an ihren Bestimmungsort weiterleiten. Aktuell bietet das Internet den Benutzern eine breite Palette von Diensten, wie beispielsweise E-Mail, das World Wide Web, FTP, Usenet-Newsgroups, Gopher, IRC, Telnet und andere.
Internetadresse
Siehe Netzwerkadresse.
Internetdienstanbieter
Ein Geschäftszweig, der Internetzugriffsdienste für Einzelpersonen, Unternehmen und andere Organisationen anbietet. Bei einigen ISPs (Internet Services Provider) handelt es sich um große nationale und multinationale Unternehmen, die an vielen Standorten Zugriffsmöglichkeiten bieten, wohingegen sich andere auf eine bestimmte Stadt oder Region beschränken.
Internet Information Services
(IIS) Ein Markenname von Microsoft für eine Webserversoftware, bei der das Hypertext Transfer Protocol (HTTP) für die Übermittlung von World Wide Web-Dokumenten eingesetzt wird. IIS umfasst eine Vielzahl von Funktionen für den Bereich Sicherheit, ermöglicht den Einsatz von CGI-Programmen und die Einrichtung von FTP-Servern.
Intranet
Ein Netzwerk, das für die Informationsverarbeitung innerhalb eines Unternehmens oder einer Organisation ausgelegt ist. Die Einsatzbreite umfasst Dienste wie beispielsweise Dokumenten- und Softwareverteilung, Zugriff auf Datenbanken sowie Schulungen. Die Bezeichnung „Intranet“ wird verwendet, weil normalerweise Anwendungen zum Einsatz kommen, die mit dem Internet zusammenhängen, wie beispielsweise Webseiten, Webbrowser, FTP-Sites, E-Mail, Newsgroups und Verteilerlisten, wobei jedoch nur Personen innerhalb des Intranets hierauf Zugriff haben. Siehe auch Firewall.
IP
(Internet Protocol) Eine Internetsoftware, mit der die Daten für die Übertragung über das Internet in Pakete unterteilt werden. Damit Computer über das Internet miteinander kommunizieren können, muss IP ausgeführt werden. Siehe auch TCP.
IP-Adresse
(Internet Protocol-Adresse) Die standardmäßige Methode zur Kennzeichnung eines Computers, der mit dem Internet verbunden ist, vergleichbar mit einer Telefonnummer, mit der ein Anschluss in einem Telefonnetz bezeichnet wird. Eine IP-Adresse besteht aus vier Zahlen, die durch Punkte voneinander getrennt sind, wobei jede Zahl kleiner als 256 ist, beispielsweise 192.200.44.69. Ein Computer erhält seine IP-Adresse vom Webserveradministrator oder vom Internetdienstanbieter.
IP-Adressmaske
(Internet Protocol-Adressmaske) Ein Bereich von IP-Adressen, der so definiert ist, dass nur Computern mit IP-Adressen innerhalb dieses Bereichs der Zugriff auf einen Internetdienst gestattet ist. Um einen Teil einer IP-Adresse zu maskieren, ersetzen Sie diesen durch das Platzhalterzeichen Stern (*). Beispielsweise steht 192.44.*.* für jeden Computer im Internet, dessen IP-Adresse mit 192.44. beginnt.
ISAPI
(Internet Server Application Programming Interface, Programmierschnittstelle für Internetserveranwendungen) Eine Anwendungsentwicklungsschnittstelle für Webserver, die von Microsoft in Zusammenarbeit mit Process Software entwickelt wurde und die anstelle von CGI verwendet werden kann.
ISP
Siehe Internetdienstanbieter.
J K

Nach oben

Java
Eine universell einsetzbare Programmiersprache, die von Sun Microsystems entwickelt wurde. Aktuell wird Java hauptsächlich für das Programmieren kleiner Anwendungen, so genannter Applets, für das World Wide Web verwendet. Siehe auch Java-Applet.
Java-Applet
Eine Java-Klasse, die von jeder bereits ausgeführten Java-Anwendung wie beispielsweise einem Webbrowser geladen und ausgeführt wird. Java-Applets können mit jedem Webbrowser gedownloaded und ausgeführt werden, der in der Lage ist, Java zu interpretieren, wie beispielsweise Microsoft Internet Explorer oder Netscape Navigator. Java-Applets werden häufig verwendet, um Webseiten mit Multimediaeffekten und interaktiven Funktionen auszustatten, d. h. beispielsweise, um Videoclips, Animationen, Taschenrechner, Echtzeituhren und interaktive Spiele hinzuzufügen. Applets können automatisch aktiviert werden, wenn die Seite, die ein Applet enthält, in einem Webbrowser angezeigt wird, es kann jedoch auch eine benutzerseitige Aktion wie beispielsweise das Klicken auf ein Element auf der Seite erforderlich sein.
JavaScript
Eine Skriptsprache, die von Netscape Communications und Sun Microsystems, Inc. entwickelt wurde. Verglichen mit Java weist JavaScript hinsichtlich der Leistungsfähigkeit Einschränkungen auf, da vor der Ausführung keine Kompilierung erfolgt. Mit JavaScript können Webseiten einfache Online-Anwendungen und Funktionen hinzugefügt werden, jedoch ist die Anzahl und Komplexität der mit der Anwendungsprogrammierungsschnittstelle verfügbaren Funktionen geringer als die von Java. Im Allgemeinen wird davon ausgegangen, dass JavaScript-Code, der zusammen mit HTML-Code auf einer Webseite verwendet werden kann, besonders für weniger erfahrene Programmierer einfacher zu schreiben ist als Java-Code. Zum Interpretieren von JavaScript-Code wird ein JavaScript-kompatibler Webbrowser wie beispielsweise Microsoft Internet Explorer oder Netscape Navigator, benötigt.
JPEG
(Joint Photographics Experts Group) Ein Format für Grafikdateien, das verwendet wird, um Grafiken mit hochauflösenden Farben im World Wide Web anzuzeigen. Bei JPEG-Grafiken wird ein benutzerseitig anzugebendes Komprimierungsschema verwendet, mit dem sich die umfangreichen Dateigrößen, die normalerweise mit fotorealistischen Farbgrafiken einhergehen, drastisch reduzieren lassen. Hierbei gilt, je höher der Komprimierungslevel, desto geringer die Qualität und umgekehrt. FrontPage kann JPEG-Dateien importieren und exportieren. Siehe auch progressives JPEG.
Kategorie
In FrontPage eine Klassifizierung für das Beschriften und Gruppieren von Webseiten und Dateien anhand allgemeiner Kriterien wie beispielsweise Seiteninhalt, Dateityp oder ähnlicher Unterscheidungen.
Kennwort
Eine Sicherheitsmaßnahme, die dazu dient, den Zugriff auf Computersysteme und sicherheitsrelevante Dateien zu schützen. Im World Wide Web bestehen Kennwörter aus Zeichenfolgen, die es Sitebesuchern gestatten, auf Internetdienste wie beispielsweise FTP zuzugreifen, sofern der Internetdienst eine Authentifizierung voraussetzt. Siehe auch Authentifizierung.
Klassen-Selektor
In der Formatvorlagendefinition (oder der Formatvorlagenregel) einer Cascading Stylesheet die Untermenge eines Selektors, mit der gesteuert wird, ob der gleiche Selektor in anderen Situationen auch für geringfügig abweichende Formatvorlagen verwendet werden kann.
Kommentar
In FrontPage ein Text, der in der Seitenansicht angezeigt werden kann, jedoch in einem Webbrowser nicht angezeigt wird. Kommentartexte werden in der Seitenansicht violett angezeigt und verwendet, um während der Seitenerstellung Anmerkungen für Autoren und Editoren einzufügen. Sitebesucher können Kommentare ebenfalls einblenden, indem sie den HTML-Quellcode der Seite anzeigen, die die Kommentare enthält.
Komponente
Ein integriertes FrontPage-Objekt, das ausgewertet und ausgeführt wird, wenn ein Autor die Seite speichert oder, in einigen Fällen, ein Sitebesucher die Seite öffnet. Mit den meisten Komponenten wird HTML-Code erzeugt. Zu den Komponenten in FrontPage gehören Suchformulare, mit denen das Web mit einer Möglichkeit zur Volltextsuche ausgestattet wird, und Formularbehandlungsroutinen zum Speichern von Ergebnissen, mit denen die Daten eines Formulars gesammelt und in einer Datei gespeichert oder an eine angegebene E-Mail-Adresse gesendet werden. Anleitungen zum Hinzufügen von benutzerdefinierten Komponenten zu den Menüs der Seitenansicht in FrontPage finden Sie im FrontPage Software Developer’s Kit.
Kontrollkästchen
Ein Formularfeld, das durch Klicken auf ein Feld aktiviert werden kann. Wenn ein Feld aktiviert wurde, wird dies normalerweise durch ein Häkchen oder ein X angezeigt. Kontrollkästchen werden im Normalfall gruppiert, um so eine Sammlung sich gegenseitig nicht ausschließender Auswahlmöglichkeiten zu bilden. Siehe auch Optionsfeld.
L

Nach oben

LAN
(Local Area Network, lokales Netzwerk) Eine Computernetzwerktechnik, mit der Computer verbunden werden, die sich in nur geringer Entfernung voneinander befinden. Ein LAN kann mit dem Internet verbunden werden und ebenso auch als Intranet konfiguriert werden.
langsame Seiten
Seiten, die ungewöhnlich lange (20 Sekunden oder länger) für den Download mit einem Webbrowser benötigen. In FrontPage können Sie langsame Seiten in Ihrem Web mithilfe der Berichtsansicht aufspüren. Die Anzahl der Sekunden und die Geschwindigkeit der Internetverbindung, die FrontPage für die Ermittlung langsamer Seiten voraussetzen soll, kann angegeben werden.
Laufschrift-Komponente
Ein Bereich auf einer Seite, in dem eine horizontal umlaufende Textnachricht angezeigt wird.
lebendiges Web
Ein Web, das auf einem Webserver veröffentlicht wurde und aktuell von Sitebesuchern aufgesucht werden kann. Wird ein lebendiges Web mit FrontPage bearbeitet, können Sitebesucher alle Aktualisierungen und Änderungen an einer Seite sofort sehen, nachdem die Seite gespeichert wurde. Siehe auch vorgeschaltetes Web.
Link
Siehe Hyperlink.
M

Nach oben

mailto
Das Internetprotokoll, das zum Senden von elektronischer Post verwendet wird. In FrontPage können Sie auch E-Mail-Hyperlinks erstellen
META-Tag
Ein HTML-Tag, das im Bereich HEAD der Seite vorhanden sein muss. META-Tags stellen Informationen über eine Seite bereit, beeinflussen jedoch nicht deren Aussehen. Ein standardmäßiges META-Tag, „generator“, wird verwendet, um die Art des Editors anzugeben, mit dem die HTML-Seite erstellt wurde.
Microsoft Image Composer
Eine leistungsfähige Bildbearbeitungsanwendung, die zum Lieferumfang von FrontPage gehört. Hiermit können Sie eigene Grafiken erstellen oder vorhandene Grafiken für die Verwendung in einem Web bearbeiten.
Microsoft Internet Explorer
Der Webbrowser von Microsoft, der für die Plattformen Windows, Macintosh und UNIX zur Verfügung steht. Wenn Internet Explorer in Verbindung mit FrontPage installiert wurde, stehen zusätzliche Funktionen wie beispielsweise dynamische Seiten- und Designvorschau in der Seitenansicht zur Verfügung.
Microsoft Management Console
(MMC) Eine grafische Schnittstelle für Microsoft Internet Information Services (IIS), die Verwaltungstools in Form von „Snap-Ins“ enthält, wie beispielsweise das FrontPage MMC-Snap-In. Siehe auch Internet Information Services.
Microsoft Visual Basic
Eine hoch entwickelte Basic-Version für die visuelle Programmierung. Visual Basic wurde von Microsoft für die Programmierung von Windows-basierten Anwendungen entwickelt.
Microsoft Visual Basic for Applications
(VBA) Eine Makrosprachenversion von Microsoft Visual Basic, die zum Programmieren von Windows-Anwendungen verwendet wird und zum Lieferumgang einiger Microsoft-Anwendungen gehört. Siehe auch Microsoft Visual Basic.
Microsoft Visual Basic Scripting Edition
(VBScript) Eine Teilmenge der Programmiersprache Visual Basic for Applications, die für die webbezogene Programmierung optimiert wurde. Wie bei JavaScript wird der Code für die Visual Basic Scripting Edition in HTML-Dokumente eingebettet. Diese Version ist Bestandteil von Microsoft Internet Explorer. Siehe auch Microsoft Visual Basic.
Microsoft Visual SourceSafe
Ein professionelles Quellcodeverwaltungssystem für Dokumente, das von Microsoft entwickelt wurde. Ist sowohl FrontPage als auch Visual SourceSafe auf dem gleichen Computer installiert, kann FrontPage in Visual SourceSafe integriert werden.
MIME-Typ
(Multipurpose Internet Mail Extensions-Typ) Eine Methode, die von Webbrowsern verwendet wird, um Dateien eines bestimmten Typs mit Anwendungen zu verknüpfen, die Dateien dieses Typs anzeigen können.
Miniaturansicht
Eine verkleinerte Darstellung eines Bildes auf einer Webseite, die normalerweise einen Hyperlink zur Originalversion des Bildes enthält. Miniaturansichten werden verwendet, damit Seiten, auf denen sich viele Grafiken und Bilder befinden, in einem Webbrowser schneller geladen werden können. Siehe auch AutoMiniaturansicht.
Multihosting
Die Fähigkeit eines Webservers zur Unterstützung von mehr als einer Internetadresse und mehr als einer Homepage. Wird auch als Multihoming bezeichnet.
N

Nach oben

Name-Wert-Paar
Der Name eines Formularfeldes und der Wert des Feldes zu dem Zeitpunkt, an dem das Formular abgeschickt wird. Jedes Feld in einem Formular kann über eines oder mehrere Name-Wert-Paare verfügen, und auch das Formular selbst kann ein oder mehrere Name-Wert-Paare aufweisen.
Navigationsansicht
Die Ansicht in FrontPage, die zum Erstellen, Anzeigen, Drucken und Ändern der Navigationsstruktur eines Webs dient. Die Navigationsansicht umfasst eine ordnerartige Ansicht, von der aus Sie mit der Maus Seiten in Ihre Sitestruktur ziehen können. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Navigationsleiste
In FrontPage eine Sammlung von grafisch gestalteten oder mit Text versehenen Schaltflächen, die Hyperlinks zu Seiten enthalten, die Teil der gleichen Webstruktur sind. Siehe auch Webstruktur, Navigationsansicht.
Netzwerkadresse
In einem URL ein eindeutiger Name, der einen Internetserver kennzeichnet. Eine Netzwerkadresse besteht aus zwei oder mehr Teilen, die durch Punkte voneinander getrennt sind, wie in beispiel.microsoft.com. Wird auch als Hostname und als Internetadresse bezeichnet. Siehe auch URL.
news
Das Internetprotokoll zum Abrufen von Dateien aus einer Internetnewsgroup. In FrontPage können Sie auch News-Hyperlinks (news://) erstellen.
Normaler Text
In FrontPage das standardmäßige Absatzformat der Seitenansicht, das für die Verwendung in Textabsätzen vorgesehen ist.
Normal, Registerkarte
In FrontPage die Standardregisterkarte der Seitenansicht, auf der die Seite so angezeigt wird, wie sie in einem Webbrowser erscheint.
NTLM
(NT LanMan) Das Windows NT-Authentifizierungsprotokoll „Herausforderung/Rückmeldung“. Bei diesem Protokoll wird für die sichere Übertragung von Kennwörtern eine Verschlüsselung verwendet.
O

Nach oben

Ohne Frames, Registerkarte
In FrontPage die Registerkarte in der Seitenansicht, auf der der alternative HTML-Code einer Framesseite angezeigt wird. Hierbei handelt es sich um den HTML-Code für Webbrowser, die die Anzeige von Framesseiten nicht unterstützen.
OLE
(Object Linking and Embedding, Objekte verknüpfen und einbetten) Eine Technik für den Transfer und die gemeinsame Nutzung von Informationen in unterschiedlichen Anwendungen. Mit OLE kann ein Autor verschiedene Editor-Komponenten aufrufen, um so ein aus verschiedenen Objekten zusammengesetztes Dokument zu erstellen.
Open Database Connectivity
(ODBC) Eine Anwendungsprogrammierungsschnittstelle (Application Programming Interface, API) für die Erstellung von Anwendungen, die unabhängig von einem spezifischen Datenbankverwaltungssystem sind.
Optionsfeld
Ein Formularfeld, das dem Sitebesucher eine Auswahlmöglichkeit bietet, die er per Klicken auf ein Feld aktivieren kann. Optionsfelder haben oft die Form einer Liste, in der ein Eintrag bereits standardmäßig aktiviert ist. Mit der Auswahl eines anderen Listeneintrags wird die Auswahl des aktuell gewählten Listeneintrags aufgehoben. Siehe auch Kontrollkästchen.
Ordner
Ein mit einem Namen versehener Speicherbereich auf einem Computer, der Dateien und weitere Ordner enthält.
Ordneransicht
In FrontPage die Ansicht eines Webs, in der angezeigt wird, wie der Inhalt des Webs organisiert ist. Ähnlich der Vorgehensweise in Windows Explorer können Sie auch in der Ordneransicht Ordner erstellen, löschen, kopieren und verschieben. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Ordner mit ausführbaren Dateien
Ein Ordner in einem FrontPage-basierten Web, von dem aus Skripts und ausführbare Programme auf einem Webserver ausgeführt werden können. Der Serveradministrator kann den Einsatz von Ordnern mit ausführbaren Dateien unterbinden.
P Q

Nach oben

PCD
(Photo CD) Ein Grafikdateiformat, das von der Eastman Kodak Company entwickelt wurde. FrontPage kann PCD-Dateien importieren.
PCT
(Personal Communications Technology) Eine verbesserte Version von Secure Sockets Layer. Siehe auch Secure Sockets Layer.
PCX
Ein Grafikdateiformat, bei dem die Grafikdaten mit einer RLE-artigen Komprimierung komprimiert werden, wie sie in frühen Versionen von Windows Paintbrush verwendet wurde. FrontPage kann PCX-Dateien importieren.
Pfad
Der Teil eines URLs, mit dem die Ordner angegeben werden, in dem sich die Datei befindet. Im URL http://beispiel.microsoft.com/hello/world/top.htm lautet der Pfad beispielsweise /hello/world/.
Plugin
Eines aus einer Reihe von Softwaremodulen, die in Webbrowser integriert sind, um deren Fähigkeiten zur Anzeige interaktiver und multimedialer Elemente zu erweitern.
PNG
(Portable Network Graphics) Ein Dateiformat für komprimierte Bitmapgrafiken, ähnlich dem GIF-Format. FrontPage kann PNG-Dateien importieren und exportieren.
PPP
(Point-to-Point Protocol) Ein Internetstandard für die Übertragung von Daten über serielle Verbindungen zwischen Computern.
progressives JPEG
Eine Erweiterung des Grafikdateiformats JPEG, mit der ein fotorealistisches Bild in einem Webbrowser schrittweise aufgebaut wird, wobei immer detailliertere Versionen des Bildes angezeigt werden, bis die gesamte Datei gedownloaded wurde. Gegenüber GIF-Dateien mit Zeilensprung kann mit Dateien im Format progressives JPEG die hohe Qualität von 24-Bit-Farben beibehalten werden, wobei die gleiche effiziente Komprimierung wie bei Standard-JPEG geboten wird. Siehe auch JPEG.
Protokoll
Eine Zugriffsmethode auf ein Dokument oder einen Dienst über das Internet, wie beispielsweise FTP (File Transfer Protocol) oder HTTP (Hypertext Transfer Protocol). Wird auch als Typ bezeichnet.
Proxyserver
Ein Internetserver, der als Firewall dient und den Datenverkehr zwischen einem geschützten Netzwerk und dem Internet überwacht. Siehe auch Firewall.
R

Nach oben

RAS
Das von Sun Microsystems entwickelte Rastergrafikdateiformat. FrontPage kann RAS-Dateien importieren.
registrierter Benutzer
Der Besucher einer Website, dessen Name und Kennwort innerhalb der Website gespeichert sind. In FrontPage können sich Sitebesucher mit der FrontPage-Formularbehandlungsroutine für Registrierung in Ihrem Web registrieren.
relationale Datenbank
Bei einem relationalen Datenbankverwaltungssystem (Relational Database Management System, RDBMS) werden Daten in Zeilen und Spalten geordnet, die zueinander in einer Beziehung stehen, wie sie jeweils vom relationalen Modell vorgegeben wird. Beispiele für relationale Datenbankverwaltungssysteme sind Microsoft SQL Server und Oracle. Auch eine Microsoft Access-Datenbank ist ein Beispiel für eine relationale Datenbank.
relativer URL
Die Internetadresse einer Seite oder einer anderen Ressource im World Wide Web, die in Relation zur Internetadresse der aktuellen Seite steht. Mit einem relativen URL wird der Pfad von der aktuellen Seite zu einer Zielseite oder -ressource angegeben. Ein relativer URL kann ein Protokoll umfassen. Beispielsweise bezieht sich der relative URL Doc/Beispiel.htm auf die Seite Beispiel.htm im Ordner Doc unterhalb des aktuellen Ordners. Siehe auch URL.
RTF
(Rich Text Format) Eine Methode des Codierens von Textformaten und der Dokumentstruktur unter Verwendung des ASCII-Zeichensatzes. RTF-Dateien haben in der Regel die Dateinamenerweiterung .rtf. Sie können in FrontPage RTF-Dateien öffnen und nach HTML konvertieren.
S

Nach oben

Schaltfläche
Ein Formularfeld, auf das der Sitebesucher klicken kann, um ein Formular abzuschicken oder ein Formular in seinen ursprünglichen Zustand zurückzuversetzen.
Secure Sockets Layer
(SSL) Ein von Netscape Communications entwickelter offener Standard für die Einrichtung eines sicheren Kommunikationskanals, um das Abfangen von kritischen Informationen, wie beispielsweise Kreditkartennummern, zu verhindern. Mit SSL wird in erster Linie der Zweck verfolgt, sichere elektronische Finanztransaktionen über das World Wide Web zu ermöglichen, das Protokoll kann jedoch auch in Verbindung mit anderen Internetdiensten eingesetzt werden. Diese Technik, bei der die Verschlüsselung mit öffentlichen Schlüsseln zum Einsatz kommt, ist Bestandteil vieler Webbrowser und Webserver.
Seite
Ein einzelnes Dokument in einer Website, das in HTML geschrieben wurde. Sie können FrontPage verwenden, um Seiten zu erstellen oder zu ändern, ohne dass hierfür Kenntnisse in HTML benötigt würden.
Seite einschließen-Komponente
Eine Komponente in FrontPage, die durch den Inhalt einer anderen Seite im Web ersetzt wird. Hiermit können Sie in einem Schritt Bereiche auf einer Vielzahl von Seiten aktualisieren.
Seite nach Zeitplan einschließen-Komponente
Eine Komponente in FrontPage, die während eines bestimmten Zeitraums durch den Inhalt einer Datei im aktuellen Web ersetzt wird. Nach Ablauf des vorgegebenen Zeitraums wird der Inhalt der Datei nicht mehr angezeigt. Dies ist nützlich, wenn Textinformationen angezeigt werden sollen, die nur für eine begrenzte Zeit relevant sind.
Seitenansicht
Die Ansicht in FrontPage, in der Sie Webseiten erstellen, bearbeiten und in der Vorschau betrachten. In der Seitenansicht werden Webseiten so angezeigt, wie sie in einem Webbrowser erscheinen. Die Ansichten in FrontPage bieten verschiedene Möglichkeiten zur Anzeige der Informationen in einem Web, so dass Sie die Site auf effiziente Weise verwalten können.
Seitenbanner
Ein Bereich einer Webseite, der ein grafisches Element sowie Text, wie beispielsweise den Seitentitel, enthält. Seitenbanner werden normalerweise am Kopf einer Webseite angezeigt.
Seitentitel
Eine beschreibende Textzeichenfolge, mit der eine Seite gekennzeichnet wird.
Seitenverhältnis
Bei Computeranzeigen und -grafiken das Verhältnis zwischen der Breite eines Bildes oder eines Bildbereichs und dessen Höhe. Beispielsweise gibt ein Seitenverhältnis von 2:1 an, dass ein Bild zweimal so breit wie hoch ist. Das Seitenverhältnis ist ein wichtiger Faktor bei der Beibehaltung der korrekten Proportionen, wenn ein Bild in ein anderes Dokument, wie beispielsweise eine Webseite, eingefügt wird.
Seitenvorlage
Eine generische Webseite mit vordefinierten Gestaltungselementen, die Sie zum Erstellen neuer, benutzerdefinierter Seiten verwenden können. Einige der Seitenvorlagen in FrontPage enthalten typischen Seiteninhalt, andere bieten allgemein gebräuchliche Seitenlayouts.
Selektor
In der Formatvorlagendefinition (oder Formatvorlagenregel) eines Cascading Stylesheets das HTML-Element, das mit einem bestimmten Satz Formatvorlageneigenschaften und -werten verbunden ist.
Server
Ein Computer, der in einem Netzwerk Dienste zur Verfügung stellt. Im World Wide Web wird der Computer als Server bezeichnet, auf dem Webserversoftware ausgeführt wird, die auf Anforderungen des HTTP-Protokolls antwortet. Wird auch als Host bezeichnet.
serverseitige Imagemap
Eine Imagemap, mit der die Koordinaten des Mauszeigers an eine CGI-Behandlungsroutine auf dem Server übergeben werden. Serverseitige Imagemaps setzen voraus, dass der Webserver den Ziel-URL des Hyperlinks basierend auf den Koordinaten des Mauszeigers berechnen kann. Siehe auch Imagemap.
serverseitiges Einschließen
Ein Feature, das von einigen Webservern angeboten wird und mit der automatisch Text auf Seiten eingefügt werden kann, wenn diese von einem Webbrowser abgerufen werden.
Skript
Eine Art von Computercode, der direkt von jedem Programm, das die Sprache versteht, in der das Skript geschrieben wurde, ausgeführt werden kann. Skripts müssen nicht kompiliert werden, um ausgeführt werden zu können.
SLIP
(Serial Line Internet Protocol) Ein Internetstandard für die Übertragung von Daten über serielle Verbindungen zwischen Computern.
Stammweb
Das standardmäßige Web der obersten Ebene, das vom Webserver bereitgestellt wird. Für den Zugriff auf das Stammweb geben Sie den URL des Servers ohne Zusatz eines Seitennamens oder Unterwebs an. Bei der Installation von FrontPage wird ein Stammweb mit Namen C:\Eigene Dateien\Eigene Webs erstellt. Siehe auch Unterweb.
Standardhyperlink
In einer Imagemap der Hyperlink, dem die Sitebesucher folgen, wenn sie in einen Bereich des Bildes klicken, in dem sich keine Hotspots befinden. Siehe auch Hotspot.
Startseite
Die Seite, die zu Beginn in einem Frame angezeigt wird, wenn der Sitebesucher zu der Framesseite wechselt, die den Frame enthält. In FrontPage können Sie die Startseite eines Frames in der Seitenansicht zuweisen. Siehe auch Framesseite.
Strukturierte Abfragesprache
(Structured Query Language, SQL) Eine Datenbankabfrage- und Programmiersprache, die häufig verwendet wird, um auf Daten in relationalen Datenbanksystemen zuzugreifen, diese abzufragen, zu aktualisieren und zu verwalten. Unter Verwendung von SQL können Sie Daten aus einer Datenbank abrufen, Datenbanken und Datenbankobjekte erstellen, Daten hinzufügen, vorhandene Daten bearbeiten und andere, weit komplexere Funktionen ausführen. Mit SQL können Sie auch die Serverkonfiguration ändern, die Einstellungen für Datenbanken oder Sitzungen ändern und Daten- und Zugriffsanweisungen steuern.
Suchformular-Komponente
Eine Komponente in FrontPage, mit der ein Formular erstellt werden kann, das Ihr FrontPage-basiertes Web mit einer Möglichkeit zur Volltextsuche ausstattet. Nachdem der Sitebesucher das Formular abgeschickt hat, das die zu suchenden Begriffe enthält, gibt das Suchformular eine Liste mit Hyperlinks zu Seiten in Ihrem FrontPage-basierten Web zurück, die Entsprechungen der Begriffe enthalten.
T

Nach oben

Tabelle
Eine oder mehrere Zeilen mit Zellen auf einer Seite, die verwendet werden, um das Layout der Seite zu organisieren oder um Daten systematisch anzuordnen. In FrontPage können Sie jedes beliebige Element in eine Tabelle einfügen, einschließlich Text, Grafiken und Formulare.
Tag
Siehe HTML-Tag.
Textabstand
Der Abstand zwischen dem Inhalt und dem Innenrand einer Tabellenzelle.
Textfeld mit Bildlauf
Ein mit einer Beschriftung versehenes, mehrzeiliges Formularfeld, in das der Sitebesucher eine oder mehrere Zeilen Text eingeben kann.
Textmarke
Eine benannte Position auf einer Webseite, die das Ziel eines Hyperlinks sein kann. Eine Textmarke kann einer Zeichenfolge zugewiesen oder unabhängig von Text auf einer Seite erstellt werden. Textmarken ermöglichen es Autoren, einen Hyperlink zu einem bestimmten Abschnitt auf einer Zielseite zu erstellen. In einem URL wird einer Textmarke ein Doppelkreuz (#) vorangestellt. Wird auch als Anker bezeichnet.
TCP
(Transmission Control Protocol) Internetnetzwerksoftware, mit der die Übertragung von Datenpaketen über das Internet gesteuert wird. Neben anderen Aufgaben prüft TCP auf verlorene Pakete, bringt Daten aus eine Vielzahl Paketen in die richtige Reihenfolge und fordert fehlende oder fehlerhafte Pakete erneut an. Damit Computer mit Webservern kommunizieren können, muss TCP ausgeführt werden.
TGA
(Targa) Ein Grafikdateiformat für fotorealistische Grafiken, das für Systeme mit Truevision-Grafikkarte ausgelegt ist. FrontPage kann TGA-Dateien importieren.
TIFF
(Tagged Image File Format) Ein hochauflösendes, tagbasiertes Grafikformat. TIFF wird für den universellen Austausch von digitalen Grafiken verwendet. FrontPage kann TIFF-Dateien importieren.
Tool für Farbmittelwert
In FrontPage die Aktion, bei dem das Pipettentool über eine Auswahl an Grafiken oder verschiedenen Volltonfarben auf einer Webseite gezogen wird, um auf diese Weise das mittlere Farbspektrum dieser Farben zu ermitteln.
TWAIN
(Technology without an interesting name) Entwickelt von einem Konsortium aus Herstellern von Bildverarbeitungshardware- und -software, ist TWAIN eine plattformübergreifende Schnittstelle für das Einlesen von Bildern, die mit TWAIN-kompatiblen Scannern, digitalen Kameras und standbildfähigen Videograbberkarten digitalisiert wurden. In FrontPage können Sie Bilder direkt von TWAIN-kompatiblen Geräten auf Webseiten transferieren.
U

Nach oben

Übergangseffekt
Einer aus einer Reihe von Effekten für die Anzeige von Seiten, wie beispielsweise „Auflösen“ und „Von innen einblenden“, die in einigen Webbrowsern zur Verfügung stehen. Übergangseffekte können so konfiguriert werden, dass sie aktiviert werden, wenn ein Sitebesucher die Seite öffnet oder verlässt. Mit FrontPage können Sie Seiten Übergangseffekte zuweisen.
übergeordnete Seite
In FrontPage eine Seite in einem Web, die Teil der Navigationsstruktur des Webs ist und mit einer oder mehreren untergeordneten Seiten verknüpft wurde. Von der übergeordneten Seite aus wird über einen Hyperlink in der Navigationsleiste auf die jeweils untergeordnete Seite zugegriffen. Siehe auch Navigationsleiste, Webstruktur.
übergeordnetes Web
In einer hierarchischen Struktur das Web, das sich unmittelbar über dem aktuellen Web befindet.
Überschrift
Ein Absatzformat, das in einer größeren Schriftart angezeigt wird als normaler Text. Die Schriftgröße einer Überschrift ist abhängig von der Überschriftenebene: Überschrift 1 weist die größte Schriftart auf, Überschrift 2 die nächst kleinere usw. Sie verwenden Überschriften, um beschreibende Namen oder Titel für Textabschnitte oder ganze Seiten bereitzustellen.
UNIX
Ein mehrbenutzerfähiges Multitasking-Betriebssystem, das in den unterschiedlichsten Formen und Implementierungen vorliegt und normalerweise auf proprietären Computerarbeitsstationen eingesetzt wird. Viele Webserver werden auf UNIX-Systemen ausgeführt.
unterbrochener Hyperlink
In FrontPage ein Hyperlink, der auf einen falschen URL oder eine fehlende Seite oder Datei verweist.
untergeordnetes Web
Siehe Unterweb.
Unterweb
Ein mit einem Namen versehenes Unterverzeichnis des Stammwebs, bei dem es sich um ein komplettes, FrontPage-basiertes Web handelt. Jedes Unterweb kann über vom Stammweb und von anderen Unterwebs unabhängige Berechtigungen für Verwaltung, Betreuung und Zugriff verfügen. Darüber hinaus sind Suchläufe, die über das FrontPage-basierte Suchformular implementiert wurden, auf das Unterweb beschränkt, und FrontPage zeigt nur die Hyperlinks innerhalb des Unterwebs an. Innerhalb des Stammwebs kann ein beliebige Anzahl Unterwebs erstellt werden, und innerhalb dieser Unterwebs können wiederum Unterwebs erstellt werden. Siehe auch Stammweb, Web.
URL
(Uniform Resource Locator) Eine Zeichenfolge, mit der die Internetadresse einer Website oder einer Ressource im World Wide Web zusammen mit dem Protokoll angegeben wird, mit dem auf die Site oder die Ressource zugegriffen wird. Der am häufigsten verwendete URL-Typ ist http://, womit die Internetadresse einer Webseite angegeben wird. Andere URL-Typen sind gopher://, womit die Internetadresse eines Gopher-Verzeichnisses angegeben wird, und ftp://, womit die Netzwerkadresse einer FTP-Ressource bezeichnet wird.
V

Nach oben

VBA
Siehe Microsoft Visual Basic for Applications.
VBScript
Siehe Microsoft Visual Basic Scripting Edition.
verborgenes Feld
Ein Formularfeld, das für den Sitebesucher unsichtbar ist, jedoch Daten an eine Formularbehandlungsroutine übergibt. Jedes verborgene Feld wird als ein Name-Wert-Paar implementiert. Wenn der Sitebesucher ein Formular abschickt, werden dessen verborgene Felder zusammen mit den Name-Wert-Paaren jedes sichtbaren Formularfelds an die Formularbehandlungsroutine übergeben. Siehe auch Name-Wert-Paar.
verborgener Ordner
Ein Ordner in einem Web in FrontPage, dessen Name mit einem Unterstrich beginnt, wie in _verborgen. Standardmäßig können Seiten und Dateien, die sich in verborgenen Ordnern befinden, nicht in einem Webbrowser angezeigt werden.
veröffentlichen
Das Verfahren, mit dem ein Web im World Wide Web oder in einem Intranet für die Öffentlichkeit bzw. für einen autorisierten Benutzerkreis zugänglich gemacht wird, indem alle zugehörigen Seiten und Dateien auf den Webserver kopiert werden, der mit dem Internet oder dem lokalen Netzwerk verbunden ist.
Verteilte Kennwortauthentifizierung (Distributed Password Authentication, DPA)
Eine fortschrittliche, verteilte Methode der Benutzerauthentifizierung, die von Microsoft entwickelt wurde und die Anmeldung eines einzelnen Benutzers gestattet. Die Unterstützung für DPA wird vom Microsoft Membership System bereitgestellt und wurde für die Anforderungen von Internetdienstanbietern und Onlinediensten optimiert.
verwaschen
Ein Grafikbearbeitungseffekt, der in der Seitenansicht von FrontPage zur Verfügung steht. Wird eine Grafik mit dem Tool Verwaschen aus der Symbolleiste Grafik bearbeitet, wird eine Version der Grafik mit niedrigerer Auflösung und höheren Kontrasten erstellt. Eine Grafik, auf die der Effekt „Verwaschen“ angewendet wurde, kann für Ihre Seiten als mit Wasserzeichen versehener Hintergrund verwendet werden, ohne dass Sie manuell in einem Bildbearbeitungsprogramm Änderungen an den Einstellungen für Auflösung, Farbe und Kontrast vornehmen müssen.
virtueller Server
Eine von vielen Websites, die auf dem gleichen Server ausgeführt werden, von denen jede über einen eindeutigen Domänennamen und eine eindeutige IP-Adresse verfügt. Ein Webserver, der virtuelle Server unterstützt, wird auch als Multihosting-Webserver bezeichnet.
Visual Basic
Siehe Microsoft Visual Basic.
vorgeschaltetes Web
Ein lokales Web, das sich in einem Dateisystem oder auf einem lokalen Webserver befindet und auf das Sitebesucher aktuell nicht zugreifen können. Vorgeschaltete Webs ermöglichen es Autoren und Arbeitsgruppen, umfassende Änderungen und Aktualisierungen an Websites vorzunehmen, bevor sie im World Wide Web oder dem Unternehmensintranet veröffentlicht werden. Siehe auch lebendiges Web.
W X Y Z

Nach oben

WAIS
(Wide Area Information Service) Unterstützt Suchläufe über das Internet.
WAN
(Wide Area Network, Weitverkehrsnetz) Ein Computernetzwerk, bei dem große Entfernungen überwunden werden und in dem spezielle Computer zur Einbindung kleinerer Netzwerke verwendet werden.
Wasserzeichen
Eine Grafik, die auf dem Hintergrund der Seiten eines Webs angezeigt wird, um als Dekoration und Kennzeichnung der Seiten zu dienen, die bei einem Bildlauf der Seite jedoch statisch bleibt. Wasserzeichen werden nicht in allen Webbrowsern unterstützt.
Web
Eine Homepage und die hiermit verbundenen Seiten, Grafiken, Dokumente, Multimedia- und andere Dateien, die in FrontPage erstellt und auf einem Webserver oder auf der Festplatte eines Computers gespeichert sind. Ein Web enthält darüber hinaus auch Dateien, mit denen die für FrontPage spezifischen Funktionen unterstützt werden, die es ermöglichen, Webs mit FrontPage zu öffnen, zu kopieren, zu bearbeiten und zu verwalten.
Webbrowser
Software, die die Textauszeichnungen von HTML-Dateien interpretiert, sie in Webseiten umwandelt und dem Benutzer anzeigt. Einige Browser ermöglichen es den Benutzern, E-Mails zu senden bzw. zu empfangen, Newsgroups zu lesen und Sound- oder Videodateien abzuspielen, die in den Webdokumenten eingebettet sind.
Webname
Der Webname in FrontPage entspricht dem Namen des Ordners auf einem Webserver und unterliegt daher im Hinblick auf Konventionen wie Länge, verwendbare Zeichen und Groß-/Kleinschreibungen den für diesen Server gültigen Einschränkungen.
Webstruktur
Die Gesamtheit der Beziehungen zwischen den Seiten in einem FrontPage-basierten Web wie in der Navigationsansicht definiert. Mit einer gut definierten Struktur erhält ein Sitebesucher eine Vorstellung von seiner Position in einem Web. Wenn auf einer Seite eine Navigationsleiste einfügt wird, die Teil einer Webstruktur ist, erstellt FrontPage automatisch Hyperlinks zu den Seiten, die sich in der Struktur unterhalb der Seite befinden (untergeordnete Ebene), die sich in der Struktur oberhalb der Seite befinden (übergeordnete Ebene) und die sich in der Struktur gleichauf mit der Seite befinden (gleiche Ebene). Siehe auch Navigationsleiste, Navigationsansicht.
WMF
(Windows Metafile Format) Ein Vektorgrafikformat für Windows-kompatible Computer, das in der Hauptsache für ClipArt-Objekte in der Textverarbeitung verwendet wird. FrontPage kann WMF-Dateien importieren.
World Wide Web
Die Gesamtmenge aller miteinander verbundenen Hypertextdokumente, die auf HTTP-Servern überall auf der Welt gespeichert sind. Dokumente im World Wide Web werden als Seiten oder Webseiten bezeichnet, die in HTML (Hypertext Markup Language) geschrieben wurden. Webseiten werden von URLs (Uniform Resource Locators) gekennzeichnet, mit denen ein bestimmter Computer- und Pfadname angegeben wird, anhand dessen auf eine Datei zugegriffen werden kann, und sie werden von Knoten zu Knoten unter Verwendung von HTTP (Hypertext Transfer Protocol) zum Endbenutzer übermittelt. Webseiten können Text in einer Vielzahl von Schriftarten und -stilen, Bildern, Grafiken, Videoclips, Audiodateien sowie kleinen, eingebetteten Softwareprogrammen enthalten, die ausgeführt werden, wenn der Sitebesucher sie aktiviert, indem er auf einen Hyperlink klickt. Sitebesucher können möglicherweise auch Dateien downloaden und via E-Mail Nachrichten an andere Benutzer senden, indem sie die Links auf einer Webseite nutzen. Das World Wide Web wurde im Jahre 1990 von Tim Berners-Lee für die Europäische Organisation für Kernforschung (CERN) entwickelt.
World Wide Web Consortium
(W3C) Ein Konsortium bestehend aus kommerziellen und im Bildungsbereich tätigen Institutionen, das die Forschung und Entwicklung überwacht und sich in allen mit dem World Wide Web zusammenhängenden Bereichen für die Schaffung von Standards einsetzt.
Zellenabstand
Der Abstand zwischen den einzelnen Zellen einer Tabelle. Der Zellenabstand ist die Dicke der Ränder jeder Zelle in Pixel.
Zielframe
Der Name des Frames, in dem die Zielseite eines Hyperlinks angezeigt wird. Normalerweise verweist ein Hyperlink in einem Frame einer Framesseite als Zielframe auf einen anderen Frame innerhalb der Framesseite. Siehe auch Frame, Framesseite.
Zugriffszähler-Komponente
Eine Komponente in FrontPage, mit der die Anzahl der Sitebesucher im World Wide Web gezählt wird.


Aktualisieren auf FrontPage 2000

Microsoft FrontPage 2000 ist kompatibel mit früheren Versionen von FrontPage, d. h. Webs, die in der einen Version erstellt wurden, können in einer anderen angezeigt und bearbeitet werden. Die unterschiedlichen Versionen der FrontPage-Clientanwendung können auch mit den unterschiedlichen Versionen der FrontPage-Servererweiterungen verwendet werden.

Lesen Sie hierzu die folgenden Hilfethemen:

  • Aktualisieren der Clientanwendung
  • Aktualisieren der FrontPage-Servererweiterungen
  • Aktualisieren von lokalisierten Versionen von FrontPage

Detailliertere Informationen hierzu finden Sie im Resource-Kit für Microsoft FrontPage 2000-Servererweiterungen.

Aktualisieren der Clientanwendung

Mit FrontPage 2000 können Sie:

  • Seiten öffnen und beabeiten, die in früheren Versionen von FrontPage erstellt wurden.
  • ein Web aktualisieren, das in einer früheren Version erstellt wurde, indem Sie es in FrontPage 2000 öffnen, bearbeiten und dann speichern.
  • Webs bearbeiten und veröffentlichen sowie Seiten bearbeiten und in Webs veröffentlichen, die mit FrontPage 97 oder FrontPage 98 erstellt wurden. Wenn Sie in FrontPage 2000 beispielsweise eine Seite erstellt haben, können Sie diese in einem FrontPage 98-basierten Web veröffentlichen. Allerdings können einige der neuen Funktionen von FrontPage 2000 in FrontPage 98- oder FrontPage 97-basierten Webs nicht verwendet werden.

FrontPage 2000 bietet keine Unterstützung für Kanaldefinitionsdateien oder Internet Datenbankeinbindung. Dieses Feature wurde in FrontPage 2000 jedoch durch eine neue Datenbankfunktionalität ersetzt.

FrontPage 2000-basierte Webs können auch in früheren Version von FrontPage geöffnet und bearbeitet werden. Die neuen Funktionen von FrontPage 2000, wie beispielsweise Designs, bei denen Cascading Stylesheets, Datenbankverbindungen und verschachtelte Unterwebs verwendet werden, können in diesem Fall jedoch nicht eingesetzt werden.

Die früheren Versionen von FrontPage umfassten einen Personal Web Server, mit dessen Hilfe Sie Ihre Webs in der Vorschau betrachten konnten. In FrontPage 2000 hingegen wird Personal Web Server für festplattenbasierte Webs nicht mehr benötigt und daher auch nicht mehr automatisch installiert. Wenn Sie Laufzeitfunktionen in der Vorschau betrachen möchten, für die die Servererweiterungen benötigt werden (wie beispielsweise Formulare und Zugriffszähler), haben Sie die Möglichkeit, Personal Web Server und die Servererweiterungen zu installieren. Wenn Sie mit einer früheren Version von Personal Web Server arbeiten, aktualisiert FrontPage automatisch Personal Web Server und die Servererweiterungen auf die neueste Version.

FrontPage 2000 behält die Einstellungen und benutzerdefinierten Komponenten bei, die in einer Datei aus einer früheren Version von FrontPage gespeichert wurden. Diese Einstellungen und Komponenten umfassen benutzerdefinierte Designs, Dokumentvorlagen, Menüs und die zuletzt geöffneten Webs. Darüber hinaus kann jedes Programm, das auf die Automationsschnittstelle von FrontPage 97 oder FrontPage 98 zugreift, mit FrontPage 2000 zusammenarbeiten.

Aktualisieren der FrontPage-Servererweiterungen

Die FrontPage 2000-Servererweiterungen unterstützen die gesamte Funktionalität von FrontPage 2000, FrontPage 98 und FrontPage 97. Wenn Sie FrontPage 2000 oder Office 2000 installieren, werden die FrontPage 2000-Servererweiterungen automatisch installiert, und frühere Versionen der Servererweiterungen werden aktualisiert. Sie können Webs, die mit einer höheren Verison von FrontPage erstellt wurden, auch in Verbindung mit früheren Versionen der Servererweiterungen verwenden, wenn Sie jedoch Unterstützung für die neuesten Funktionen benötigen, müssen Sie die FrontPage 2000-Servererweiterungen verwenden.

Aktualisieren von lokalisierten Versionen von FrontPage

FrontPage 2000 ermöglicht Ihnen, mit mehr Sprachen und Zeichen zu arbeiten, als in früheren Versionen. Sie können verschiedene neue Sprachen ebenso wie alle Unicode 2.0-Zeichen anzeigen und speichern. Darüber hinaus erkennt FrontPage 2000 auch mehr Verweise auf HTML 4.0-Zeichenentitäten als frühere Versionen.

Die erweiterten Sprachfeatures in FrontPage 2000 beeinflussen den Dateiaustausch zwischen FrontPage 2000 und früheren Programmversionen in folgender Weise:

  • Wenn Sie eine Seite in einer der Sprachen erstellen, deren Unterstützung mit FrontPage 2000 neu eingeführt wurde, wird, wenn Sie die Seite in FrontPage 98 oder FrontPage 97 öffnen, eine Fehlermeldung angezeigt.
  • Wenn Sie eine Seite erstellen, die ein Unicodezeichen (wie beispielsweise &#914; für den griechischen Großbuchstaben Beta) enthält, wird das Zeichen gelöscht, wenn Sie die Seite in FrontPage 98 oder FrontPage 97 öffnen oder speichern.
  • Wenn Sie eine Seite erstellen, die einen Verweis auf eine HTML 4.0-Zeichenentität enthält, können Sie dieses Zeichen in FrontPage 98 oder FrontPage 97 nicht bearbeiten (der Verweis auf die Zeichenentität erscheint als &delta;).


Wenn Sie zu einer Seite eine Navigationsleiste hinzufügen, wählen Sie aus, welche Hyperlinks angezeigt werden sollen. Diese Hyperlinks sind relativ zur Position der Seite in der Navigationsstruktur.

Nachstehend sehen Sie die verschiedenen Arten von Navigationsleisten, die Sie verwenden können. Wenn die Navigationsleiste auf dieser Seite Seite mit Navigationsleiste platziert wird, umfasst sie Hyperlinks zu den Seiten Navigationsleistenhyperlink. Die Homepage erkennen Sie an Homepage.

Navigationsleiste der gleichen Ebene Navigationsleiste der gleichen Ebene | Navigationsleiste der obersten Ebene Navigationsleiste der obersten Ebene
Navigationsleiste der übergeordneten Ebene Navigationsleiste der übergeordneten Ebene | Navigationsleiste der untergeordneten Ebene Navigationsleiste der untergeordneten Ebene
Untergeordnete Seiten der Homepage Untergeordnete Seiten der Homepage | Navigationsleiste "Zurück" und "Weiter" Navigationsleiste „Zurück“ und „Weiter“ (zum Blättern in Seiten der gleichen Ebene)

Zusätzlich zu diesen die Navigationsleiste betreffenden Auswahlmöglichkeiten können Sie auch Hyperlinks zur Homepage des Webs und/oder zur übergeordneten Seite der aktuellen Seite einfügen.

Wenn Sie Navigationshyperlinks wählen, die für die aktuelle Seite nicht relevant sind (wenn Sie beispielsweise eine Navigationsleiste der obersten Ebene hinzufügen, sich aber auf der obersten Ebene des Webs außer der Homepage keine Seiten befinden), wird die Navigationsleiste in einem Webbrowser nicht angezeigt. Beim Bearbeiten der Seite sehen Sie jedoch einen Platzhalter für die Navigationsleiste.


Eine Navigationsleiste ist eine Zusammenstellung von Hyperlinks, die dazu dient, den Besucher beim Bewegen in einer Website zu unterstützen. Eine typische Navigationsleiste enthält beispielsweise Hyperlinks zu der Homepage und den Hauptseiten eines Webs:

Sie können auf jeder Seite Ihres Webs eine Navigationsleiste anzeigen, so dass Ihre Sitebesucher jederzeit schnell und einfach zu den Hauptseiten des Webs gelangen können.

In einer Navigationsleiste können Schaltflächen ebenso wie Texthyperlinks verwendet werden. Die oben dargestellte Navigationsleiste könnte auch als Text angezeigt werden:

Home Neuigkeiten Inhalt Suche

Sie können selbst eine Zusammenstellung von Hyperlinks als Navigationsleiste erstellen, d. h. Sie können eine eigene Zusammenstellung von Schaltflächen erstellen, diese mit den in Frage kommenden Seiten in Ihrem Web verknüpfen und auf jeder Seite duplizieren, auf der sich eine Navigationsleiste befinden soll. Oder Sie können eine Navigationsstruktur für Ihr Web einrichten und es FrontPage überlassen, die Navigationsleisten zu erstellen. FrontPage verwaltet die vom Programm selbst erstellten Navigationsleisten; wenn Sie eine Seite verschieben oder hinzufügen, aktualisiert FrontPage die Navigationsleiste entsprechend, indem alle Hyperlinks erneut berechnet werden.

Anmerkung FrontPage kann Navigationsleisten nur erstellen, wenn Sie mit einem Web arbeiten, nicht bei der Erstellung einzelner Seiten.

Weitere Informationen

Festlegen einer Navigationsstruktur für ein Web

Hinzufügen einer Navigationsleiste zu einer Seite


Sie können Navigationsleisten horizontal oder vertikal auf einer Seite anordnen. Sie können jeder Seite auch mehr als eine Navigationsleiste hinzufügen, beispielsweise, um die Navigation auf verschiedenen Seitenebenen zu ermöglichen.

Beachten Sie im nachfolgenden Beispiel für eine Navigationsansicht, dass sich die Seiten „Dienstleistungen“ und „Neuigkeiten“ auf der gleichen Seitenebene befinden und dass „Dienstleistungen“ über vier untergeordnete Seiten verfügt:

Darüber hinaus zeigt die nachstehende Beispielseite eine horizontale Navigationsleiste für die Navigation auf der gleichen Seitenebene sowie einen Hyperlink zur Homepage, die es dem Sitebesucher ermöglicht, zu den Hauptseiten des Webs zu wechseln. Am linken Rand der Seite ermöglicht eine vertikale Navigationsleiste für die Navigation zu untergeordneten Seiten dem Sitebesucher den Zugriff auf die untergeordneten Seiten der Seite „Dienstleistungen“.

Eine Seite mit zwei Navigationsleisten


Ein gemeinsamer Randbereich ist ein Bereich, der von einer oder mehreren Seiten in einem Web gemeinsam genutzt wird. Verwenden Sie gemeinsame Randbereiche, wenn Sie gleiche Inhalte in einem Schritt auf mehreren Seiten platzieren möchten, anstatt jede Seite einzeln zu bearbeiten. Wenn Sie beispielsweise im Kopf jeder Seite ein Logo anzeigen möchten, fügen Sie eine Grafik in den gemeinsamen oberen Randbereich ein.

In gemeinsamen Randbereichen können Sie auch Navigationsleisten verwenden. Allerdings ist eine Navigationsleiste immer relativ zur jeweiligen Seite, sie mag Ihnen also auf der einen Seite als nützlich erscheinen, wenn Sie die Navigationsleiste jedoch von einer anderen Seite aus betrachten, erscheint Ihnen die Auswahl der Hyperlinks möglicherweise nicht mehr sinnvoll. Da eine Navigationsleiste in einem gemeinsamen Randbereich über die gleichen Einstellungen für alle Seiten verfügt, die den gemeinsamen Randbereich nutzen, müssen Sie dies gegebenenfalls bereits beim Einrichten der Navigationsstruktur berücksichtigen.

Betrachten wir beispielsweise die nachstehend dargestellte Webstruktur. Damit die Sitebesucher auf den Hauptseiten navigieren können, fügen Sie eine Navigationsleiste der gleichen Ebene in einen gemeinsamen Randbereich ein. Auf der Seite „Produkte“ erscheint die Navigationsleiste sinnvoll, da sie Hyperlinks zu den Hauptseiten enthält. Wenn Sie jedoch die Navigationsleiste auf der Seite „Download“ betrachten, enthält diese Links zu den Seiten „Download“ und „Bestellung“ und nicht zu den Hauptseiten.

Beispiel für eine Navigationsstruktur

Eine Möglichkeit zur Lösung dieses Problems besteht darin, die Navigationsleiste zu verwenden, in der sich Hyperlinks zu den untergeordneten Seiten der Homepage befinden. Ungeachtet der Seite, die Sie anzeigen, enthält die Navigationsleiste immer Hyperlinks zu den Seiten „Aktuell“, „Produkte“ und „Dienste“. Diese Navigationsleiste könnten Sie noch verbessern, indem Sie einen Hyperlink zur Homepage hinzufügen.

Verwenden einer Navigationsleiste für untergeordnete Seiten der Homepage

Sie können einer Seite mehr als eine Navigationsleiste hinzufügen. Im obigen Beispiel können Sie nicht zu den Seiten „Download“ und „Bestellung“ navigieren. Zur Lösung dieses Problems fügen Sie der Seite „Produkte“ eine Navigationsleiste der untergeordneten Ebene hinzu.

Verwenden einer Navigationsleiste der untergeordneten Ebene

Sie können diese Navigationsleiste der untergeordneten Ebene lediglich der Seite „Produkte“ hinzufügen, oder Sie können sie in einen gemeinsamen linken Randbereich setzen. Auch wenn andere Seiten ebenfalls den gemeinsamen linken Randbereich nutzen, wird diese Navigationsleiste nur auf der Seite „Produkte“ angezeigt, da die anderen Seiten nicht über untergeordnete Seiten verfügen und da eine Navigationsleiste nicht angezeigt wird, wenn sie für eine Seite nicht anwendbar ist.

Weitere Informationen

Info über gemeinsame Randbereiche


Sie können eine Navigationsstruktur für das aktuelle Web erstellen, indem Sie die Seiten in der Navigationsansicht anordnen. Eine solche Navigationsstruktur zeigt, wie die Seiten in Ihrem Web miteinander verbunden sind und gibt FrontPage die Möglichkeit, Navigationsleisten einzurichten. Beispielsweise wird FrontPage mithilfe der Navigationsstruktur mitgeteilt, welche Seiten zur obersten Ebene des Webs gehören; FrontPage verwendet diese Informationen, um zu ermitteln, welche Hyperlinks in die Navigationsleiste gesetzt werden sollen, und mit den Seitentiteln werden die Beschriftungen der Hyperlinks festgelegt.

Das folgende Beispiel zeigt die Struktur eines Webs:

Im Folgenden finden Sie eine Erläuterung der Beziehungen zwischen diesen Seiten:

Die Homepage ist die erste Seite, die der Navigationsstruktur hinzugefügt wird; sie trägt normalerweise den Namen Default.htm oder Index.htm und wird durch Homepagesymbol repräsentiert. Im vorliegenden Beispiel ist „Willkommen“ die Homepage.

Die Seiten der obersten Ebene befinden sich zwar auf der gleichen Ebene wie die Homepage, jedoch wird diese als Sonderfall betrachtet. Im vorliegenden Beispiel sind „Beschreibung“ und „Kontakt“ die Seiten der obersten Ebene.

Zu den Seiten der übergeordneten Ebene gehören die übergeordnete Seite einer anderen Seite sowie alle Seiten, die auf der gleichen Ebene direkt mit der übergeordneten Seite verbunden sind. Im vorliegenden Beispiel sind „Willkommen“ (die übergeordnete Seite), „Beschreibung“ und „Kontakt“ Seiten der übergeordneten Ebene für „Aktuell“. Ebenso sind „Produkte“; (die übergeordnete Seite), „Aktuell“ und „Dienste“ Seiten der übergeordneten Ebene für „Download“. „Stellen“ zählt nicht hierzu, weil diese Seite nicht mit „Produkte“ verbunden ist.

Bei den Seiten der untergeordneten Ebene handelt es sich um die Seiten, die sich direkt unterhalb einer anderen Seite befinden. Im vorliegenden Beispiel verfügt „Willommen“ über drei untergeordnete Seiten („Aktuell“, „Produkte“ und „Dienste“), „Kontakt“ verfügt über eine untergeordnete Seite, („Stellen“), und „Produkte“ weist zwei untergeordnete Seiten auf („Download“ und „Bestellung“).

Die Seiten der gleichen Ebene schließlich sind die Seiten, die sich in der Struktur auf der gleichen Ebene befinden und über die gleiche übergeordnete Seite verfügen. In diesem Beispiel sind „Aktuell“, „Produkte“, und „Dienste“ Seiten der gleichen Ebene, „Stellen“; jedoch nicht, da für diese Seite eine andere übergeordnete Seite gilt. „Download“ und „Bestellung“ sind ebenfalls Seiten der gleichen Ebene.

Weitere Informationen

Festlegen einer Navigationsstruktur für ein Web


Info über Navigationsleisten


Was ist eine Navigationsleiste?
Eine Navigationsstruktur
Navigationshyperlinks
Anordnen von Navigationsleisten auf einer Seite
Navigationsleisten in einem gemeinsamen Randbereich


Info über Seiten

Seiten sind Basisdokumente des World Wide Web und in HTML (HyperText Markup Language) geschrieben. Seiten können entweder Teil eines Webs oder eigenständige Seiten sein. Viele Funktionsmerkmale in Microsoft FrontPage sind jedoch nur sinnvoll, wenn Sie sie in einem Web einsetzen. Eine Navigationsleiste, die einem Sitebesucher erlaubt, in einem Web zu einer anderen Seite zu wechseln, ist z. B. auf einer einzelnen Seite sinnlos.

HTML

Eine HTML-Seite enthält HTML-Tags. Dies sind eingebettete Befehle, die Informationen zur Struktur, zum Erscheinungsbild und zu den Inhalten der Seite enthalten. Webbrowser bestimmen anhand dieser Informationen, wie die Seite angezeigt werden soll.

Um Microsoft FrontPage einsetzen zu können, müssen Sie nicht mit HTML vertraut sein. Während Sie Seiten genau wie in einer Textverarbeitung bearbeiten (Eingeben und Formatieren von Text, Hinzufügen von Grafiken, Tabellen und anderen Seitenelementen), fügt FrontPage im Hintergrund die erforderlichen HTML-Tags hinzu. Ihre Seite wird so angezeigt wie sie in einem Webbrowser angezeigt würde. Sie können jedoch die HTML-Tags auf der Seite auch anzeigen, und wenn Sie mit HTML vertraut sind, die Tags direkt selber schreiben oder sie bearbeiten.

Erstellen und Entwerfen von Seiten

FrontPage bietet eine Reihe von Vorlagen, die Ihnen helfen, professionelle Webseiten zu erstellen und zu entwerfen. Mit diesen Vorlagen können Sie schnell Seiten mit einer Vielzahl unterschiedlicher Layouts und Funktionen erstellen. Sie können z. B. eine FrontPage-Vorlage zum Erstellen einer zweispaltigen Seite oder einer Seite mit einem Suchformular verwenden. Sie können darüber hinaus eines der verschiedenen Designs verwenden, um Seiten mit einem einheitlichen Erscheinungsbild zu erstellen. Ein Design enthält Designelemente und ein Farbschema, einschließlich Schriften, Grafiken, Navigationsleisten, horizontaler Linien und anderer Seitenelemente.

Wenn Sie das Design und Layout für Ihre Seite selbst festlegen möchten, können Sie mit einer leeren Seite beginnen:

  • Verwenden Sie Frames, Tabellen oder absolutes Positionieren, um Text und Grafiken auf einer Seite genau zu positionieren.
  • Fügen Sie Seitenelemente wie Text, Grafiken, Seitenbanner, Tabellen, Formulare, Hyperlinks, Anzeigenwechsler, Laufschriften, Hoverschaltflächen, Zeitmarkierungen, Zugriffszähler usw. hinzu.
  • Formatieren Sie Text durch Zuweisen von Formatvorlagen oder Verwenden von Stylesheets.
  • Animieren Sie Seitenelemente, und legen Sie Seitenübergänge fest, um Seiten lebendig zu machen.
  • Legen Sie Hintergrundfarbe-, -bild oder -sound fest.
  • Erstellen Sie eigene Seitenvorlagen.

Weitere Informationen

Organisieren eines Intranets durch Unterwebs

Arbeiten mit HTML


Absolutes Positionieren erlaubt das Ablegen eines Elements an einer genauen Position auf einer Seite. Sie können das Element durch Ziehen an die gewünschte Position oder durch Angeben von Koordinaten relativ zur linken oberen Ecke des Containers (z. B. eine Seite, wie im nachstehenden Beispiel) des Elements positionieren.

Angeben von Koordinaten zum Positionieren eines Bildes

Wenn ein absolut positioniertes Element in einem Positionierungssfeld abgelegt wird, sind die Koordinaten relativ zur oberen linken Ecke des Positionierungsfeldes anstatt zur oberen linken Ecke der Seite.

Ein absolut positioniertes Seitenelement ist nicht Teil des Textflusses. Das Element wird vor oder hinter dem Textfluss angezeigt, der Text umfließt das Element nicht.

Beim Anzeigen mit unterschiedlichen Bildschirmauflösungen wird das Element u. U. nicht immer wie erwartet angezeigt, obwohl es jedesmal an den von Ihnen festgelegten Koordinaten erscheint. Wenn sich die Bildschirmauflösung ändert, ändert sich auch das Layout, da verschiedene Seitenelemente, wie z. B. Text, anders angezeigt werden. Um sicherzustellen, dass Ihre Seiten bei allen Sitebesuchern wie gewünscht angezeigt werden, testen Sie Ihre Seiten mit einer Vielzahl von Browsern und unterschiedlichen Bildschirmauflösungen.

Anmerkung Absolutes Positionieren sollte nicht zusammen mit DHTML eingesetzt werden, da die Ergebnisse nicht vorhersehbar sind.


Sie können Positionierungsfeatures kombinieren und so eine Vielzahl unterschiedlicher Ergebnisse zu erzielen, wie z. B. das Zusammenhalten einer Gruppe von Seitenelementen in einer Einheit. Sie können auch ein Positionierungsfeld zu einer Seite hinzufügen und innerhalb dieses Feldes mehrere Seitenelemente absolut positionieren. Das Ergebnis ist ein Positionierungsfeld, das relativ zum Textfluss auf der Seite positioniert ist, die Anordnung der Elemente innerhalb des Feldes wird jedoch, unabhängig von den Änderungen, die sonst auf der Seite vorgenommen werden, immer beibehalten. Die Anordnung der Elemente im Positionierungsfeld bleibt auch dann gleich, wenn die Fenstergröße verändert wird.

Absolut positionierte Elemente als Gruppe in einem Positionierungsfeld Absolut positionierte Elemente als Gruppe in einem Positionierungsfeld


Info über Positionieren

Positionieren ist eine weitere Methode zum Ablegen von Elementen (Text oder Grafiken) auf einer Seite. Es erlaubt das genaue Positionieren und das Festlegen der Ebenenordnung eines Seitenelements. Während Seitenelemente in der Regel sequentiell in einem Textfluss (vergleichbar mit den Zeilen in Textzeilen auf einer Seite) positioniert werden, entfernt das Positionieren ein Seitenelement aus dieser sequentiellen Reihenfolge und erlaubt, das Element beliebig auf der Seite vor oder hinter anderen Elementen abzulegen. Außerdem können Sie Positionierungsfunktionen kombinieren, um z. B. Elemente zu gruppieren, die als Einheit interpretiert werden sollen.

Da das Positionieren ein erweitertes Funktionsmerkmal ist und die Ergebnisse des Positionierens je nach Webbrowser und Bildschirmauflösung des Sitebesuchers sehr unterschiedlich sein können, müssen Sie ggf. mit den Positionierungsfunktionen experimentieren, bis Sie die gewünschten Ergebnisse erhalten.

Anmerkungen

  • Positionieren wird nur von Webbrowsern unterstützt, die CSS 2.0 unterstützen, wie z. B. Microsoft Internet Explorer 4.0 und höher und Netscape Navigator 4.0 und höher. Beim Anzeigen in früheren Browsern wird positionierter Text linksbündig ausgerichtet und befindet sich im Textfluss an der der Stelle, an der die Elemente verankert sind. Wenn Ihre Seiten von einer größeren Gruppe unterschiedlicher Browser angezeigt werden sollen, sollten Sie ggf. zum Positionieren von Seitenelementen Tabellen verwenden.
  • Positionierte Elemente werden standardmäßig in DIV-Tags abgelegt. Wenn Sie Seitenelementen Positionierungsattribute direkt (ohne DIV-Tags) zuweisen möchten, klicken Sie im Menü Extras auf Seitenoptionen und deaktivieren Sie dann auf der Registerkarte Allgemein das Kontrollkästchen Zum Positionieren DIV- und SPAN-Tags verwenden.

Weitere Informationen

Möglichkeiten zur Verwendung von Tabellen

Arbeiten mit Cascading Stylesheets


Verwenden Sie relatives Positionieren, um Elemente an einer festen Position innerhalb des Textflusses abzulgen. Die Anordnung der positionierten Elemente bleibt, unabhängig von den Änderungen, die Sie an der Seite oberhalb oder unterhalb dieser Stelle vornehmen, erhalten. Verwenden Sie relatives Positionieren z. B. für Animationen und DHTML-Effekte.

Weitere Informationen

Animieren Ihres Webs


Info über Positionieren


Überblick
Absolutes Positionieren
Textfluss
Z-Ordnung
Relatives Positionieren
Gruppieren von Seitenelementen


Sie können ein unverankertes Seitenelement erstellen, das von anderen Elementen, wie Text, umflossen werden kann. Ein unverankertes Element wird aus dem Textfluss entfernt und links- oder rechtsbündig ausgerichtet. Sie können außerdem die Höhe und Breite des unverankerten Bereichs des Elements festlegen. Das nachstehende Bild zeigt z. B. Text, der einen Absatz umfließt, der rechts unverankert ist. So wird eine Seitenleiste erzeugt, die unabhängig von der Anordnung des Texts um sie herum am rechten Rand ausgerichtet ist:

Textfluss um einen unverankerten Absatz


Durch Positionieren können Sie Elemente auch überlappend anordnen. Die Z-Ordnung kennzeichnet die Position eines Elements in einem Stapel von Elementen. Dazu gehört die Hauptseitenebene, die den Textfluss enthält. Sie können Elemente aber auch unterhalb der Hauptseitenebene positionieren.

Überlappen von Seitenelementen

Die Hauptseitenebene lautet 0; eine positive Z-Ordnung gibt an, dass das Element vor der Hauptebene liegt; eine negative Zahl gibt an, dass es dahinter liegt.


Info über Sicherheit

FrontPage bietet Verwaltungsprogramme, mit denen Sie Berechtigungen festlegen und den Zugriff auf Webs, die Sie auf einem Webserver erstellen und bearbeiten, einschränken können. Die Sicherheit von FrontPage basiert auf dem vom Webserver und seinem Betriebssystem verwendeten Sicherheitsmechanismus.

Festlegen von Berechtigungen für ein Web

Sie können festlegen, wer in FrontPage auf ein Web zugreifen kann, indem Sie Benutzer (und Benutzergruppen) zur Benutzerliste des Webs hinzufügen und die Zugriffsart festlegen, die ein Benutzer erhält. Die Benutzer können eine der folgenden Berechtigungsarten erhalten:

  • Lesen - Der Benutzer kann die Dateien im Web lesen.
  • Verfassen - Der Benutzer kann die Dateien im Web lesen und ändern.
  • Verwalten - Der Benutzer kann die Dateien im Web lesen, ändern und das Web durch Hinzufügen oder Entfernen von Benutzern verwalten. Auf Systemen, die Internet Information Server (IIS) ausführen, gewährt FrontPage standardmäßig allen Mitgliedern der Administratorengruppe und dem SYSTEM-Konto von Windows NT Verwaltungszugriff.

Diese Berechtigungen werden für das Stammweb (d. h. das Web auf oberster Ebene auf Ihrem Webserver) vergeben, und alle Unterwebs erben automatisch diese Berechtigungen. Das bedeutet, dass ein Benutzer mit der Berechtigung als Autor alle Webs ändern kann und dass Site-Besucher alle Webs lesen können. Wenn Sie den Zugriff auf ein Unterweb gesondert kontrollieren möchten, können Sie für das Unterweb spezielle Berechtigungen vergeben. Durch dieses Funktionsmerkmal können Sie den Webinhalt kontrollieren und auf unterschiedlich zusammengesetzte Gruppen von Verwaltern, Autoren und Site-Besuchern aufteilen.

Sicherheit für Microsoft-Server in Windows

Wenn der Webserver aus einem Windows NT Server mit IIS (Internet Information Server) besteht, werden Benutzer und Gruppen in Windows NT eingerichtet und verwaltet und können nicht in FrontPage erstellt werden. Sie wählen Benutzer und Gruppen für Ihre Webs aus diesen Windows NT-Konten aus. Der Zugriff auf Webs wird dann über das Anmeldekonto des Benutzers (Benutzername und Kennwort) geregelt. Wenn der Benutzer eine Aktion durchführt, die eine Berechtigung erfordert, verlangt der Webserver die Übergabe von Benutzernamen und Kennwort. FrontPage sendet dann den Benutzernamen und das Kennwort, mit dem der Benutzer derzeit angemeldet ist.

Anmerkung Da die Sicherheit in FrontPage auf ACLs (Access Control Lists, Zugriffskontrolllisten) basiert, müssen die Webs in einer NTFS-Partition und nicht in einer FAT-Partition gespeichert sein, damit die Sicherheit gewährleistet werden kann.

Wenn Sie Microsoft Internet Information Server oder Microsoft Personal Web Server 1.0 verwenden (in Konfigurationen, welche die Sicherheit unterstützen), können Sie Berechtigungen ausschließlich für Benutzer oder Gruppen einrichten, die dem Webserver bekannt sind. Mit Microsoft Personal Web Server 4.0 können Sie keine Berechtigungen für Ihre Webs vergeben: alle Benutzer im Netzwerk können Ihre Webs lesen, während das Verfassen/Ändern und das Verwalten von Webs nur auf dem Computer erlaubt ist, auf dem der Webserver selbst installiert ist.

Sicherheit für Server unter UNIX und Windows ohne IIS

Die meisten UNIX-Webserver führen eine Zugriffsliste mit Benutzern, die Berechtigungen zur Verwendung des Webservers haben; diese Liste unterscheidet sich von der Liste mit Benutzern und Gruppen, die sich beim Computer anmelden können. Um anzugeben, wer auf ein Web in FrontPage zugreifen kann, fügen Sie Benutzer hinzu und geben deren Kennwörter und Berechtigungsstufen an.

Weitere Informationen

Festlegen von Berechtigungen für ein Web

"Sicherheit" im Resource Kit für Microsoft FrontPage-Servererweiterungen


Info über das Veröffentlichen

Wenn Sie bereit sind, Ihr Web im World Wide Web oder im Intranet Ihrer Firma anzuzeigen, dann müssen Sie Ihr Web veröffentlichen. Das Veröffentlichen besteht im Wesentlichen aus dem Kopieren der Webdateien an eine Zielposition, wie einem Webserver, auf dem andere das Web durchsuchen können.

Vor dem Veröffentlichen eines Webs

Bevor ein Web veröffentlicht wird, sollten Sie sich vergewissern, dass es entsprechend vorbereitet ist, indem Sie auf unterbrochene Hyperlinks überprüfen, ob die Seiten so aussehen, wie Sie es möchten, und indem Sie das Web testen um sicherzustellen, dass alles funktioniert. Eine gute Möglichkeit sich zu vergewissern, dass ein Web fertig ist, liegt in der Vorschau in einen Webbrowser und im Navigieren durch die Site, und indem Sie den Status von Dateien in der Berichtsansicht überprüfen.

Wenn Sie ein Web im World Wide Web veröffentlichen möchten, benötigen Sie einen Internetdienstanbieter (ISP), vorzugsweise einen, der einen Webserver hat, auf dem die FrontPage Server-Erweiterungen installiert sind. Außerdem müssen Sie zur Veröffentlichung Ihres Webs die ISP-Webserveradresse kennen, sowie Ihren Benutzernamen und Ihr Kennwort, falls erforderlich. Weitere Informationen über ISPs, welche die FrontPage-Servererweiterungen verwenden (auch Webpräsenzprovider, WPP, genannt) erhalten Sie auf der Microsoft FrontPage Homepage, oder klicken Sie im Menü Datei auf Web veröffentlichen, und klicken Sie dann auf die Schaltfläche WPP.

Wie die Servererweiterungen sich auf das Veröffentlichen auswirken

Es gibt verschiedene Vorteile beim Veröffentlichen auf einem Webserver, auf dem die FrontPage-Servererweiterungen installiert sind:

  • Ihr Web wird die volle FrontPage-Funktionalität besitzen, wenn es veröffentlicht ist. Ohne die Servererweiterungen funktionieren manche Features nicht, wie z. B. die meisten Formularbehandlungsroutinen, Suchformulare, Trefferzähler und Komponentenfeatures.
  • FrontPage pflegt Dateien und Hyperlinks jedesmal wenn das Web veröffentlicht wird. FrontPage vergleicht die Dateien auf Ihrem lokalen Computer mit den Dateien auf dem Webserver. Wenn Sie zum Beispiel eine Datei in Ihrem lokalen Web verschieben, aktualisiert und korrigiert FrontPage alle Hyperlinks auf sie, und führt dieselben Korrekturen auch auf dem Webserver durch, sobald Sie das Web neu veröffentlichen.
  • Nachdem Sie das Web veröffentlicht haben, können Sie an ihm direkt auf dem Webserver des ISPs Bearbeitungen vornehmen (wodurch allerdings Ihre lokale Webversion nicht mehr auf dem neuesten Stand ist).

Wenn der Webserver die Servererweiterungen hat, kann FrontPage das Web über HTTP (HyperText Transfer Protocol) veröffentlichen. Andernfalls wird das Web über FTP (File Transfer Protocol) veröffentlicht.

Auswahl der zu veröffentlichenden Dateien

Sie können wählen, welche Dateien Sie veröffentlichen möchten, und welche nicht. Wenn zum Beispiel eine Datei unvollständig oder kein direkter Bestandteil Ihres Webs ist, können Sie die Datei als Nicht veröffentlichen kennzeichnen. Später, wenn Sie sich entschließen, die Datei zu veröffentlichen, nachdem Sie zum Beispiel die Seite vervollständigt haben, können Sie den Status in Veröffentlichen ändern.

Bestimmte Dateien sollten nicht noch einmal veröffentlicht werden, nachdem Sie Ihr Web zum ersten Mal veröffentlicht haben. Sie erstellen beispielsweise ein Web mit einem Gästebuch und veröffentlichen es. Wenn Sie Ihre Webseiten dann später aktualisieren und Sie veröffentlichen alle Dateien, einschließlich der Datei die die Informationen des Gästebuchs speichert, dann speichern Sie ein leeres Gästebuch über das bereits Vorhandene und verlieren alle Informationen. Weitere Beispiele sind Seiten mit Zugriffszähler, Diskussionswebs und Kataloge (wenn Sie Index Server ausführen).

Sie können auch entscheiden, nur diejenigen Dateien zu veröffentlichen, die sich geändert haben. FrontPage vergleicht dann die Dateien im Arbeitsweb auf Ihrem lokalen Computer mit den veröffentlichten Dateien auf dem Webserver. Wenn FrontPage eine neuere Dateiversion auf Ihrem lokalen Computer entdeckt, wird die Datei auf dem Webserver neu veröffentlicht.

Verwalten der Dateien auf dem Webserver

Wenn der ISP Ihnen eine Größenbegrenzung auf dem Webserver auferlegt hat, ist die Dateiverwaltung eine Notwendigkeit. Durch periodisches Löschen von unbenutzten oder alten Dateien (insbesondere Grafiken) kann der Umfang eines Webs klein gehalten werden. Wenn Sie einmal ein Web veröffentlicht haben, kann FrontPage jedesmal, wenn Sie erneut veröffentlichen, die Dateien in Ihrem lokalen Web mit den veröffentlichten Dateien auf dem Webserver synchronisieren.

Nachdem Sie Dateien auf dem lokalen Computer gelöscht haben, wird FrontPage Sie auffordern, dieselben Dateien auf dem Webserver zu löschen, wenn Sie das Web erneut veröffentlichen und sich dabei entscheiden, nur geänderte Seiten zu veröffentlichen.

Wenn Ihr Webserver die FrontPage-Servererweiterungen verwendet, kann FrontPage beim nächsten Mal, wenn Sie das Web veröffentlichen, auch andere Aktionen auf dem Webserver nachvollziehen, wie das Verschieben oder Umbenennen von Dateien. FrontPage aktualisiert dann die Navigationsleisten, die gemeinsamen Randbereiche und die Hyperlinks auf dem Webserver, um die Aktionen, die Sie am Web auf Ihrem lokalen Computer durchgeführt haben, nachzuvollziehen.

Weitere Informationen

Kennzeichnen von Seiten für das Veröffentlichen

Veröffentlichen eines Webs

Prüfen des Veröffentlichungsstatus eines Webs


Info über Quellcodeverwaltung

Mit der Quellcodeverwaltung bietet sich Ihnen die Möglichkeit sicherzustellen, dass nur jeweils eine Person gleichzeitig eine Datei bearbeiten kann, was in einer Umgebung mit mehreren Autoren unabdingbar ist. Microsoft FrontPage bietet integrierte Quellcodeverwaltungsfeatures, mit denen Webautoren grundlegende Aufgaben zur Quellcodeverwaltung durchführen können:

  • Ein Webautor kann eine Datei auschecken. Wenn eine Datei ausgecheckt wurde, kann sie von anderen Autoren zwar geöffnet, jedoch nicht geändert werden. Eine Datei, die ausgecheckt wurde, wird mit Für Sie ausgecheckt (die Datei wurde für Sie ausgecheckt) oder Für einen anderen Autor ausgecheckt (die Datei wurde für einen anderen Autor ausgecheckt) gekennzeichnet.
  • Nach dem Bearbeiten und Speichern kann ein Webautor eine Datei wieder einchecken. Die Datei steht dann wieder zur Verfügung und kann für andere Autoren ausgecheckt werden. Eine Datei, die eingecheckt und verfügbar ist, wird mit Eingecheckt und für Auschecken verfügbar gekennzeichnet.
  • Ein Webautor kann das Auschecken einer Datei rückgängig machen. Die Datei wird dann wieder eingecheckt, ohne dass irgendwelche Änderungen, die seit dem Auschecken der Datei vorgenommen wurden, übernommen werden.

FrontPage veröffentlicht die zuletzt gespeicherte Version einer Datei und nicht die Datei, die zuletzt eingecheckt wurde. Wenn eine Datei beispielsweise ausgecheckt, geändert und dann gespeichert wurde, wird diese Version der Datei veröffentlicht und nicht diejenige, die zuletzt eingecheckt wurde.

Anmerkung Wenn Sie mit der integrierten Quellcodeverwaltung arbeiten möchten, müssen die FrontPage-Servererweiterungen auf Ihrem Webserver installiert sein.

Integrieren von Microsoft Visual SourceSafe in FrontPage

Wenn Sie Microsoft Visual SourceSafe als Methode für die Quellcodeverwaltung verwenden möchten, können Sie ein neues oder bereits vorhandenes Visual SourceSafe-Projekt in FrontPage integrieren. In diesem Fall werden alle den Quellcode betreffenden Aktionen, die in FrontPage vorgenommen werden, auch ebenso in Visual SourceSafe durchgeführt, als hätte der Webautor direkt in Visual SourceSafe gearbeitet. Wenn ein Webautor beispielsweise in FrontPage eine Datei auscheckt, wird diese Datei auch in dem Visual SourceSafe-Projekt ausgecheckt.

Alle Dateien im Web werden im Visual SourceSafe-Projekt registriert. Andere Visual SourceSafe-Funktionen (wie beispielsweise Anzeigen einer Dateihistorie oder Wiederherstellen einer vorherigen Dateiversion) müssen jedoch in Visual SourceSafe durchgeführt werden.

Da das Visual SourceSafe-Projekt mit FrontPage synchronisiert ist, werden Dateiverwaltungsfunktionen, die Sie in FrontPage durchführen, im Visual SourceSafe-Projekt widergespiegelt:

  • Hinzufügen oder Erstellen einer Datei. FrontPage fügt die Datei dem Visual SourceSafe-Projekt hinzu.
  • Verschieben oder Umbenennen einer Datei. Die Datei wird auch im Visual SourceSafe-Projekt verschoben oder umbenannt. Anschließend checkt FrontPage alle Seiten aus, auf denen sich Hyperlinks zu der verschobenen oder umbenannten Seite befinden, aktualisiert die Hyperlinks, speichert die Seiten und checkt diese wieder ein.
  • Durchführen einer Aktion, die Auswirkungen auf andere Seiten hat. Zu den Aktionen, die Auswirkungen auf andere Seiten haben, gehört das Zuweisen eines Designs, das Ändern eines gemeinsamen Randbereichs oder das Ändern einer Datei, die Bestandteil anderer Seiten ist. FrontPage checkt alle Seiten aus, die von der Änderung betroffen sind, aktualisiert die Seiten, speichert sie und checkt sie dann wieder ein.
  • Löschen einer Datei. FrontPage löscht die Seite aus dem Visual SourceSafe-Projekt.

Anmerkung Diese Aktionen sollten vorzugsweise durchgeführt werden, wenn alle Dateien im Web eingecheckt sind. Wenn nämlich eine aktuell ausgecheckte Datei von einer dieser Aktionen betroffen ist, gestattet FrontPage entweder die Durchführung der Aktion nicht, oder Sie müssen die Datei selbst aktualisieren, nachdem sie wieder eingecheckt wurde.

Informationen über das Integrieren von Visual SourceSafe in FrontPage finden Sie unter „Übersicht über die Quellcodeverwaltung der Servererweiterungen“ im Microsoft FrontPage Server Extensions Resource Kit.

Weitere Informationen

Aktivieren der integrierten Quellcodeverwaltung


Info über gemeinsame Randbereiche

Ein gemeinsamer Randbereich ist ein Seitenbereich, den eine oder mehrere Seiten gemeinsam haben. Hierbei kann sich der gemeinsame Randbereich am Kopf der Seite (ähnlich der Kopfzeile), am Fuß der Seite (ähnlich der Fußzeile) oder am linken oder rechten Rand der Seite befinden. Sie verwenden gemeinsame Randbereiche, um die gleichen Inhalte in einem Schritt auf mehreren Seiten zu platzieren, anstatt jede Seite einzeln zu bearbeiten. Um beispielsweise oben auf jeder Ihrer Webseiten ein Logo einzufügen, legen Sie den oberen Rand als gemeinsamen Randbereich fest und fügen dann die Grafik in den oberen Rand ein.

Gemeinsame linke und rechte Randbereiche

Ein Vorteil gemeinsamer Randbereiche besteht darin, dass Sie den Inhalt nur an einer Stelle ändern müssen, um alle Seiten zu aktualisieren. Wenn Sie beispielsweise den Copyright-Hinweis in einer Website mit 30 Seiten ändern möchten, müssen Sie diesen nur auf einer Seite ändern, wenn er sich in einem gemeinsamen Randbereich befindet.

Verwendungsmöglichkeiten für gemeinsame Randbereiche

Gemeinsame Randbereiche bieten eine schnelle und einfache Methode, um Ihren Seiten ein einheitliches Aussehen zu verleihen. Im Folgenden finden Sie Beispiele für die vielfältigen Verwendungsmöglichkeiten von gemeinsamen Randbereichen:

  • Fügen Sie einem gemeinsamen oberen Randbereich ein Seitenbanner hinzu, um sicherzustellen, dass jede Seite über einen Titel verfügt.
  • Setzen Sie das Logo Ihrer Organisation in den gemeinsamen oberen Randbereich.
  • Stellen Sie eine Navigationsleiste bereit, mit der Sitebesucher zu den Hauptseiten Ihres Webs gelangen können. Weitere Informationen hierzu finden Sie unter Info über Navigationsleisten.
  • Setzen Sie einen Copyright-Hinweis in den gemeinsamen unteren Randbereich.
  • Fügen Sie Datum und Uhrzeit der letzten Änderung des Webs hinzu.
  • Fügen Sie eine E-Mail-Adresse für Feedback hinzu, also beispielsweise die Adresse des Webmasters.

Festlegen von gemeinsamen Randbereichen für Seiten und Webs

Sie können gemeinsame Randbereiche festlegen, die standardmäßig im gesamten Web verwendet werden, oder Sie können einzelne Seiten mit gemeinsamen Randbereichen versehen. Beispielsweise könnte ein gemeinsamer oberer und linker Randbereich als Standardeinstellung für ein Web vorgegeben werden; jede neue Seite würde dann über diese gemeinsamen Randbereiche verfügen. Für bestimmte Seiten könnten Sie den gemeinsamen Randbereich jedoch deaktivieren, falls auf diesen ein solcher nicht gewünscht wird.

Festlegen unterschiedlicher gemeinsamer Randbereiche für einzelne Seiten

Ein weiteres Beispiel ist ein Web, das standardmäßig nicht über gemeinsame Randbereiche verfügt; hier können Sie Ihren Anforderungen entsprechend gemeinsame Randbereiche für bestimmte Seiten festlegen.

Weitere Informationen

Festlegen von gemeinsamen Randbereichen für alle Seiten in einem Web

Festlegen von gemeinsamen Randbereichen für eine Seite

Hinzufügen, Ändern oder Entfernen von Elementen in einem gemeinsamen Randbereich


Ein Anzeigenwechsel ist wie eine sich drehende Reklametafel auf einer Webseite. Hierin werden in einer zeitlich festgelegten Reihenfolge Bilder angezeigt, wobei zwischen den Bildern ein Übergangseffekt zum Einsatz kommt.

Im Normalfall verwenden Autoren Anzeigenwechsel, um kommerzielle Werbung auf Seiten zu platzieren. Sie können für den Anzeigenwechsel einen Hyperlink zu der Website oder der Webseite des Unternehmens, des Produkts oder des Dienstes erstellen, für das bzw. den mit der Anzeige geworben wird.


Sie können beinahe jedem Element auf einer Seite, d. h. Text, Absätzen, Bildern, Schaltflächen, Laufschrift usw. DHTML-Animationseffekte (Dynamic HTML) zuweisen und diesen Effekt mit einem auslösenden Ereignis verbinden, wie beispielsweise dem Klicken oder Zeigen mit der Maus, dem Laden einer Seite usw. Bei den nachstehenden Beispielen kommen unterschiedliche Animationseffekte zum Einsatz:

Wenn Sie auf diesen Absatz zeigen, ändert sich die Schrift und erhält das Format „Fett“.

Wenn Sie auf diesen Absatz klicken, wird er mit einem Rahmen und einer Schattierung versehen.

Wenn Sie auf diese Bild doppelklicken, „fliegt“ es von der Seite.

Wenn Sie auf dieses Bild klicken, wird stattdessen ein anderes Bild angezeigt.


Eine Hoverschaltfläche ist eine einfache Möglichkeit, um Ihrem Web ohne jegliche Skripterstellung eine Animation hinzuzufügen. Wie jede andere Schaltfläche verfügt auch eine Hoverschaltfläche über einen Hyperlink zu einer anderen Seite oder einer anderen Datei. Wenn ein Sitebesucher jedoch auf eine Hoverschaltfläche klickt oder zeigt, kann eine solche Schaltfläche auch zu leuchten beginnen, es kann ein benutzerdefiniertes Bild angezeigt oder ein Soundeffekt abgespielt werden. Sie können auch ein Bild für eine Hoverschaltfläche oder für den Hovereffekt einer Hoverschaltfläche verwenden.


Mit einer Laufschrift wird eine durchlaufende Textmitteilung angezeigt. Sie können eine Laufschrift Ihren Anforderungen entsprechend anpassen, um exakt die gewünschten Effekte zu erzielen, wie im nachfolgenden Beispiel gezeigt:

Diese Laufschrift wird kontinuierlich wiederholt, und es wird Gelb als Hintergrundfarbe verwendet.


Sie können Spezialeffekte erstellen, die angezeigt werden, wenn ein Besucher Ihre Site öffnet oder verlässt oder eine bestimmte Seite lädt oder schließt. Mit einheitlich und umsichtig im gesamten Web eingesetzten Übergangseffekten können Sie wirkungsvolle Präsentationen nach Art einer Slide-Show mit professionellen Übergängen zwischen Seiten erstellen.


Mit Sounds und Soundeffekten können Sie Ihrem Web eine weitere Dimension hinzufügen. Wenn Ihre Organisation über eine spezielle Musik oder einen Sound als „Logo“, über ein Jingle oder eine Erkennungsmelodie verfügt, können Sie diese/s abspielen, wenn ein Sitebesucher von einer anderen Site im World Wide Web zu Ihrer Homepage wechselt.

Sie können auch einer Hoverschaltfläche Soundeffekte hinzufügen. Wenn der Sitebesucher dann auf die Hoverschaltfläche zeigt oder klickt, wird der Soundeffekt abgespielt.


Animieren eines Webs


Dynamische HTML-Effekte
Seitenübergänge
Anzeigenwechsel
Hoverschaltflächen
Laufschrift
Soundeffekte


Arbeiten mit Cascading Stylesheets

Mit Cascading Stylesheets können Sie das Erscheinungsbild und die Darstellung Ihrer Seiten besser steuern. Sie können die Position und das Erscheinungsbild von Elementen auf einer Seite exakt festlegen und Spezialeffekte erzeugen. Darüber hinaus können Sie Besuchern mit speziellen Browsern oder Ausgabegeräten den Zugang zu Ihrer Site erleichtern.

Der Inhalt eines Stylesheets

Ein Cascading Stylesheet (CSS) definiert die Formatvorlagen, die Sie Seiten oder Seitenelementen zuweisen können. Jede Formatvorlagendefinition oder Formatvorlagenregel besteht aus einem Selektor gefolgt von den Eigenschaften und Regeln für diesen Selektor. Es folgen einige einfache Beispiele für in einem Stylesheet definierte Formatvorlagenregeln:

H1 { font-size: x-large; color: green }
H2 { font-size: large; color: blue }
.Anmerkung { font-size: small }
#Fußzeile { font-family: serif }

In diesem Beispiel sind H1 und H2 Selektoren, die die Formateigenschaften von Standard-HTML-Tags ändern. Die Eigenschaften und Werte der Selektoren sind in geschweiften Klammern { } angegeben. font-size ist eine Eigenschaft und x-large ist der Wert der Eigenschaft font-size. Sie können für einen Selektor mehrere Eigenschaften, durch ein Semikolon (;) voneinander getrennt, angeben. In diesem Beispiel ist .Anmerkung ein Klassenselektor und #Fußzeile ein ID-Selektor.

Mit Cascading Stylesheets können Sie mehr Eigenschaften festlegen, als wenn Sie nur Standard-HTML verwenden, z. B.:

  • Schrifteffekte, wie Kapitälchen und erweiterter Zeichenabstand.
  • Absatzeigenschaften, wie Einzug, Zeilenabstand und Abstand vor und nach Absätzen.
  • Rahmen- und Schattierungseigenschaften, wie Kästen und Hintergrundfarben.
  • Positionierungseigenschaften, wie Textumbruch um Seitenelemente, absolute oder negative Positionierung und Z-Ordnung (Anordnung in Ebenen) von Seitenelementen.

Weitere Informationen zur Struktur und zu den Regeln zum Definieren eines Cascading Stylesheets sowie zu gültigen Eigenschaften und Werten finden Sie in den Spezifikationen des World Wide Web Consortium (W3C) zu Cascading Stylesheets.

Verwenden eines Stylesheets für eine Seite

Sie haben drei Möglichkeiten, Stylesheets für Seiten in Ihrem Web zu verwenden:

  • Verknüpfen einer Seite mit einem externen Stylesheet.
  • Erstellen eines integrierten Stylesheets auf einer Seite.
  • Zuweisen von eingebetteten Formatvorlagen zu einzelnen Seitenelementen.

Jede Methode hat Vor- und Nachteile:

  • Verwenden Sie ein externes Stylesheet, wenn Sie allen Seiten in Ihrem Web konsistent die gleichen Formatvorlagen zuweisen möchten. Wenn Sie Formatvorlagen in einem oder mehreren externen Stylesheets definieren und diese mit Seiten verknüpfen, stellen Sie die Konsistenz des Erscheinungsbilds in allen diesen Seiten sicher. Wenn Sie eine Formatvorlage ändern, müssen Sie nur eine Änderung vornehmen: im externen Stylesheet. Die Änderung wird dann automatisch in allen Seiten implementiert, die mit diesem Stylesheet verknüpft sind. In der Regel verwendet das externe Stylesheet die Dateierweiterung .CSS, z. B. NEUE_FORMATE.CSS.
  • Verwenden Sie ein eingebettetes Stylesheet, wenn Sie Formatvorlagen nur für die aktuelle Seite definieren möchten. Ein eingebettetes Stylesheet ist in die <HEAD>-Tags einer Seite „integriert“. Formatvorlagen in einem eingebetteten Stylesheet können nur auf derselben Seite verwendet werden.
  • Verwenden Sie eingebettete Formatvorlagen zum Zuweisen von Cascading Stylesheet-Eigenschaften zu einzelnen Elementen auf einer Seite.

Wenn eine Seite mit einem externen Stylesheet verknüpft ist, erweitern oder überschreiben die integrierten oder eingebetteten Formatvorlagen für diese Seite die Eigenschaften, die im externen Stylesheet definiert sind.

Erstellen oder Bearbeiten eines Stylesheets

FrontPage 2000 beinhaltet jetzt Vorlagen zum Erstellen externer Stylesheets. Sie können mit einer leeren Vorlage oder einer Vorlage, die bereits einige Formatvorlagen enthält (z. B. die Vorlage „Bögen“) beginnen. Wenn Sie das Stylesheet speichern, verwendet FrontPage die Dateierweiterung .CSS. Zum Bearbeiten des Stylesheets doppelklicken Sie in der Ordnerliste auf die Datei.

Wenn Sie eine Formatvorlage für eine Datei unter Verwendung des Befehls Formatvorlage aus dem Menü Format erstellen oder ändern, erstellt FrontPage automatisch ein integriertes Stylesheet (sofern dieses nicht bereits existiert) und speichert die Formatvorlage als Klassenselektor im integrierten Stylesheet.

Sie können zum Erstellen neuer, zum Ändern oder Löschen vorhandener oder zum Zuweisen von CSS-Formateigenschaften in Standard-HTML-Tags (z. B. <H1>) das Dialogfeld Formatvorlage verwenden. Wenn Sie auf OK klicken, um das Dialogfeld zu schließen, schreibt FrontPage die Formateigenschaften unter Verwendung der korrekten Syntax zurück in das externe oder eingebettete Stylesheet. Sie können jedoch die Formatvorlageninformationen auch einfach direkt in der korrekten CSS-Syntax eingeben. Zum Eingeben von Formatvorlageninformationen für ein integriertes Stylesheet klicken Sie in der Seitenansicht auf die Registerkarte HTML.

Wenn Sie das Kontrollkästchen CSS verwenden für ein Design aktivieren, das einem Web zugewiesen ist, erstellt FrontPage im Stammverzeichnis Ihres Webs ein externes Stylesheet namens Design1.CSS, wobei Design der Name des Designs ist. Wenn Sie das Design ändern, schreibt FrontPage die Änderungen automatisch auch zurück in das CSS des Designs. Sie können das Design auch direkt im CSS des Designs ändern.

Verwenden eines Stylesheets

Um Formatvorlagen in einem externen Stylesheet auf einer Seite zu verwenden, verknüpfen Sie die Seite mit dem Stylesheet. Dazu verwenden Sie den Befehl Links zu Stylesheet aus dem Menü Format. Sie können die aktuelle Seite, die in der Ordnerliste markierten Seiten oder alle Seiten in Ihrem Web in der Seitenansicht mit einem oder mehreren Stylesheets verknüpfen.

Das Feld Formatvorlage zeigt Standard-HTML-Tags, wie z. B. Überschrift 1, sowie alle in einem integrierten Stylesheet oder externen Stylesheet, das mit der Seite verknüpft ist, enthaltenen Klassen- oder ID-Selektoren an. Zum Zuweisen einer Formatvorlage zu einem Seitenelement, wählen Sie das Element aus und klicken im Feld Formatvorlage auf die Vorlage oder den Selektor.

In Microsoft FrontPage 2000 werden bestimmte Formatierungsfunktionen jetzt automatisch als eingebettete Formatvorlagen zugewiesen. Wenn Sie z. B. einem normalen Absatz mithilfe des Befehls Rahmen und Schattierung aus dem Menü Format einen Rahmen zuweisen, schreibt FrontPage die Formatinformationen als eingebettete Formatvorlagenattribut für den Absatztag (z. B. <p style="border-style: solid">). Einige Attribute werden jedoch unter Verwendung von Cascading Stylesheets zugewiesen, andere unter Verwendung von HTML. Wenn Sie eingebettete Formatvorlagen nur unter Verwendung von CSS zuweisen möchten, weisen Sie einen Klassen- oder ID-Selektor oder eine eingebettete Formatvorlage unter Verwendung der Schaltfläche Formatvorlage im Dialogfeld Eigenschaften des Seitenelements zu.

Aktivieren oder Deaktivieren von Cascading Stylesheets

Wenn eine Formatvorlageneigenschaft nicht verfügbar ist (d. h. wenn sie abgeblendet ist), oder wenn Sie keine Cascading Stylesheets verwenden möchten, um Kompatibilität mit älteren Browsern zu gewährleisten, müssen Sie bestimmte Versionen von CSS aktivieren oder deaktivieren. FrontPage verwendet CSS, um die folgenden Formatvorlageneigenschaften zu implementieren:

  • Befehl Zeichen (Menü Format): Einige Schrifteffekte auf der Registerkarte Zeichen und erweiterter und reduzierter Zeichenabstand auf der Registerkarte Zeichenabstand.
  • Befehl Absatz (Menü Format): Optionen Einzug und Abstand.
  • Befehl Rahmen und Schattierung (Menü Format): Alle Rahmen- und Schattierungsoptionen.
  • Befehl Position (Menü Format): Alle Positionierungsoptionen.


Verwenden von Tabellen

Eine Tabelle besteht aus Zeilen und Spalten von Zellen, in denen Sie Text und Grafiken einfügen können. Tabellen können in Microsoft FrontPage auf verschiedene Art und Weise verwendet werden.

Darstellung von Informationen in tabellarischem Format

Stellen Sie Informationen mithilfe einer Tabelle im Rasterformat dar, wie z. B. Zeitpläne, Produktinformationen, Tarife usw.

Hoteltarife pro Übernachtung
Zimmer | Nebensaison (Jan - Apr) | Hauptsaison (Mai - Dez)
Einzelzimmer | 100 | 110
Ez. + Bad | 120 | 130
Doppelzimmer | 160 | 175
Dz. + Bad | 180 | 195

Sie können Ihre Tabellen so gestalten, dass sie attraktiver und leichter zu lesen sind. Durch Festlegen von Ausrichtung und Schriftart können Sie steuern, wie der Text jeder Zelle angezeigt wird, die Abstände zwischen Spalten und Zeilen steuern sowie für Rahmen und Hintergrund Farben festlegen. Weitere Informationen finden Sie unter Anpassen von Tabellen.

Gestaltung von Text und Grafiken auf einer Seite

Sie können für das Seitenlayout von Text und Grafiken Tabellen verwenden, um die einzelnen Elemente anzuordnen. Tabellen werden von praktisch allen Webbrowsern unterstützt und stellen einen einfachen Weg dar, das Seitenlayout festzulegen.

Grafik | Dies ist ein Beispiel für die Verwendung einer Tabelle, um das Layout einer Seite festzulegen. Diese Tabelle enthält zwei Zeilen und zwei Spalten, die unterschiedliche Hintergrundfarben haben, damit Sie die Grenzen sehen können. Wenn Sie auf diese Weise Tabellen verwenden, können Sie Text und Grafiken leicht in Spalten einteilen.
Grafik | Indem Sie mehrere Zeilen verwenden, können Sie sicherstellen, dass jede Grafik an einem Begleittext ausgerichtet ist. Wenn Sie Tabellen für das Seitenlayout verwenden, können Sie diese für Besucher unsichtbar machen, indem Sie die Rahmen verbergen.

Sie können auch gemeinsame Randbereiche, Frames und die zweidimensionale Positionierung für das Layout Ihrer Seiten verwenden, jedoch haben diese Funktionsmerkmale andere Vorteile:

  • Gemeinsame Randbereiche sind von Nutzen, wenn Sie auf jeder Seite dieselben Elemente anzeigen möchten.

    • Wenn Sie z. B. Ihr Firmenlogo am oberen Rand jeder Seite Ihres gesamten Webs anzeigen möchten, können Sie einen gemeinsamen Randbereich verwenden, der das Logo enthält. Wenn Sie jedoch das Logo nur auf einer Seite anzeigen möchten, können Sie stattdessen eine Tabelle verwenden. Weitere Informationen erhalten Sie unter Info über Gemeinsame Randbereiche.

  • Frames sind von Nutzen, wenn Sie mehrere Seiten dynamisch auf einer Seite anzeigen möchten oder gewisse Inhalte immer sichtbar sein sollen, wie z. B. eine Liste von Hyperlinks. Sie können in Frames auch große Informationsmengen mit Bildlauf anzeigen.

    • Sie zeigen z. B. in einem Frame eine Liste von Elementen an. Je nachdem, auf welches Element der Sitebesucher klickt, wird in einem anderen Frame auf derselben Seite eine weitere, dazugehörige Seite angezeigt. Handelt es sich jedoch um statische Informationen, ist die Tabelle die einfachste Möglichkeit, Text und Grafiken anzuzeigen. Weitere Informationen finden Sie unter So verstehen Sie Frames und Framesseiten.

  • Durch zweidimensionales Positionieren können Sie Text und Grafiken an beliebiger Stelle auf der Seite anordnen, unabhängig von den Textzeilen (Absatzmarken) einer Seite. Sie können auch Text und Grafiken einander überlappen lassen. Allerdings unterstützen die meisten älteren Webbrowser dieses Funktionsmerkmal nicht und stellen eine derartige Seite nicht korrekt dar. Weitere Informationen erhalten Sie unter Info über Positionierung.

Weitere Informationen

Erstellen von Tabellen

Anpassen von Tabellen


Erstellen von Tabellen

Microsoft FrontPage erlaubt die Erstellung einer Tabelle auf verschiedene Arten:

Erstellen einer einfachen Tabelle Einfache Tabelle
Sie können schnell eine einfache Tabelle erstellen, indem Sie lediglich die Anzahl der Spalten und Zeilen angeben. Später können Sie die Eigenschaften der Tabelle je nach Erfordernis ändern.
Zeichnen einer Tabelle Zeichnen einer Tabelle
Sie können eine Tabelle durch Ziehen mit der Maus erstellen. Sie zeichnen mit dem Hilfsprogramm Tabelle zeichnen den Rahmen und dann die Zellen der Tabelle. Sie können eine komplexe Tabelle mit Zellen unterschiedlicher Größe und unterschiedlicher Anzahl von Spalten und Zeilen erstellen.
Erstellen einer Tabelle und Festlegen ihrer Eigenschaften Erstellen einer Tabelle und Festlegen ihrer Eigenschaften
Sie können eine Tabelle sofort erstellen, indem Sie verschiedene Tabelleneigenschaften wie die Anzahl von Zeilen und Spalten, die Breite, Ausrichtung, Rahmenstärke, den Textabstand innerhalb und den Abstand zwischen Zellen festlegen.
Name, Stadt
Jeff Smith, Los Angeles

Name | Stadt
Jeff Smith | Los Angeles
 Umwandeln von Text in eine Tabelle
Wenn der Text, den Sie in eine Tabelle bringen möchten, bereits vorliegt, können Sie ihn in eine Tabelle umwandeln, solange der Text Trennzeichen enthält, die eindeutig angeben, wie er in Spalten und Zeilen aufzuteilen ist.

Weitere Informationen

Erstellen einer einfachen Tabelle

Erstellen einer Tabelle durch Zeichnen

Erstellen einer Tabelle und Festlegen ihrer Eigenschaften

Umwandeln von Text in einer Tabelle

Anpassen von Tabellen


Sie können Hintergrundfarben und -bilder für Ihre Tabellen auswählen. Hintergrundfarben können dazu benutzt werden, um bestimmte Spalten oder Zeilen hervorzuheben. Mit Hintergrundbildern können Sie Ihre Tabellen visuell ansprechender gestalten.

Sie können Hintergrundfarben und -bilder für bestimmte Zellen oder für die gesamte Tabelle festlegen. Die Zelleneinstellungen haben jedoch immer Vorrang. Wenn Sie z. B. die Hintergrundfarbe einer Tabelle auf Grün einstellen und eine Zellenfarbe auf Blau, dann erhält die Tabelle einen grünen Hintergrund, die eine Zelle ist aber blau.

 | Montag | Dienstag | Mittwoch | Donnerstag | Freitag
8:00 |  |  |  |  |
8:30 |  |  |  |  |
9:00 |  |  |  |  |
9:30 |  |  |  |  |
10:00 |  |  |  |  |

Weitere Informationen

Festlegen der Hintergrundfarbe einer Tabelle

Anzeigen eines Hintergrundbildes in einer Tabelle


Sie können das Aussehen eines Tabellenrahmens individuell anpassen. Legen Sie die Rahmenfarbe entweder für die ganze Tabelle fest, oder bestimmen Sie für einzelne Zellen unterschiedliche Rahmenfarben. Sie können eine Farbe für den Rahmen oder, falls Sie ein dreidimensionales Aussehen bevorzugen, zwei Farben wählen: eine helle und eine dunkle Farbe. Sie können auch die Stärke des äußeren Rahmens ändern.

Produkt | Preis | Stck | Gesamt
Schreibtisch | 600 | 1 | 600
Stuhl | 250 | 2 | 500
Lampe | 50 | 3 | 150
Summe |  |  | 1250

Weitere Informationen

Festlegen der Farbe eines Tabellenrahmens

Verbergen eines Tabellenrahmens

Ändern eines Tabellenrahmens


Sie können Tabellen mit einer Beschriftung oder einem Titel versehen, indem Sie eine Tabellenbeschriftung hinzufügen. Diese wird oberhalb oder unterhalb der Tabelle angebracht. Der Beschriftungstext kann auch formatiert werden.

Um bestimmte Zellen in einer Tabelle hervorzuheben, können Sie diese als Kopfzeilen der Tabelle definieren. In der Tabelle weiter unten enthalten die erste Zeile und die erste Spalte Beschriftungen. Diese werden als Tabellenkopfzeilen formatiert, damit sie sich vom Rest der Tabelle abheben. Standardmäßig wird eine Tabellenkopfzeile in Fettschrift formatiert. Sie können jedoch die Formatvorlage für Kopfzeilen der Tabelle (th) auch ändern und weitere Eigenschaften, wie z. B. Schattierung definieren.

Tabellenbeschriftung
 | Jan | Feb | Mrz | Gesamt
Osten |  |  |  |
Westen |  |  |  |
Süden |  |  |  |
Gesamt |  |  |  |

Weitere Informationen

Einfügen einer Tabellenbeschriftung

Formatieren von Kopfzeilen einer Tabelle


Sie können steuern, wie eine Tabelle auf der Seite angezeigt wird, indem Sie die Tabellenausrichtung festlegen. Tabellen können linksbündig, rechtsbündig oder zentriert auf der Seite ausgerichtet werden. Die Tabelle weiter unten ist zentriert.

Sie können auch die Länge und Breite einer Tabelle steuern. So können Sie z. B. die Tabellenbreite auf 80% der gesamten Breite der Seite (oder des Frames, wenn die Tabelle in einem Frame angezeigt wird) festlegen. Wenn ein Sitebesucher die Fenstergröße seines Browsers verändert, ändern sich Seite und Tabelle in ihrer Größe entsprechend. Auf Seiten, die eine Tabelle und Text enthalten, können Sie auch festlegen, ob der Text um die Tabelle herumfließen soll.

Sie können auch steuern, wie der Text innerhalb einer Zelle angezeigt wird. So können Sie z. B. festlegen, wie viel Platz zwischen dem Rahmen und dem Text einer Zelle gelassen wird, und die horizontale und vertikale Ausrichtung von Text bestimmen. Außerdem kann Tabellentext wie jeder andere Text formatiert werden. Sie können Art, Größe, Farbe der Schrift und andere Attribute ändern.

Produkt | Preis
Schreibtisch | DM 500,00
Stuhl | DM 100,00
Lampe | DM 50,00

Weitere Informationen

Festlegen des Tabellenlayouts

Arbeiten mit Zeilen, Spalten und Zellen

Festlegen des Zellenlayouts


Nachdem Sie eine Tabelle erstellt haben, passen Sie diese je nach Bedarf durch Einfügen von Zeilen und Spalten an. Sie können weitere Zellen in der Tabelle erstellen, indem Sie eine Zelle in zwei oder mehr Zellen aufteilen. Weiterhin können Sie zusammenliegende Zellen zu einer zusammenfassen.

Eine Zelle
Aufgeteilt Aufgeteilt Aufgeteilt

Wenn Sie alle benötigten Zeilen und Spalten in der Tabelle angeordnet haben, können Sie die Zeilenhöhe und Spaltenbreite nach Wunsch festlegen.

  • Ändern Sie die Größe von Zeilen und Spalten individuell, indem Sie deren Ränder mit der Maus ziehen.
    Größenveränderung einer Spalte
  • Definieren Sie die Zeilenhöhe und Spaltenbreite als Prozentsatz der gesamten Tabellengröße. So können Sie z. B. festlegen, dass die Breite einer Spalte 10% der Gesamtbreite der Tabelle beträgt.
  • Definieren Sie die Zeilenhöhe und Spaltenbreite durch ein diskretes Pixelmaß.
  • Legen Sie fest, dass alle Zeilen und alle Spalten einheitliche Abstände haben.

Weitere Informationen

Hinzufügen einer Zelle, Zeile oder Spalte

Zellen teilen

Zellen verbinden

Verändern der Größe einer Zelle, Zeile oder Spalte

Verändern der Größe einer Tabelle

Gleichmäßiges Verteilen von Zeilen und Spalten


Anpassen von Tabellen


Layout von Text und Tabelle
Zeilen und Spalten
Beschriftungen und Kopfzeilen
Ränder
Hintergrund


Info über Designs

Ein Design ist eine einheitliche Sammlung von Designelementen und Farbschemata, die auf Seiten angewendet werden, um ihnen ein konsistentes und attraktives Erscheinungsbild zu geben. Die Verwendung eines Designs ist ein schneller und einfacher Weg, Seiten interessanter zu machen und ihnen ein professionelles Aussehen zu verleihen. FrontPage enthält viele vordefinierte Designs, die Sie sofort benutzen können. Sie können sie so benutzen, wie sie sind, oder Sie können sie ändern.

Das folgende Beispiel zeigt Ihnen, wie eine einfache Seite aussieht, und wie sie aussieht, wenn man unterschiedliche Designs auf sie anwendet:

Beispiel von Designs, die auf eine einfache Seite angewendet werden

Ein Design wirkt sich auf alle Aspekte des Erscheinungsbildes einer Seite aus:

  • Farben. Ein Design verwendet ein Farbschema, um die Farbe von Haupttext, Überschriften, Hyperlinks, Seitenbannertext, Beschriftung der Navigationsleiste, Tabellenrahmen und Seitenhintergrund festzulegen. Sie können die normalen oder die lebendigen Farbeinstellungen verwenden.
  • Grafiken. Ein Design verwendet Grafiken für verschiedene Seitenelemente wie Hintergrundbild, Seitenbanner, Aufzählungszeichen, Navigationsschaltflächen und horizontale Linien. Sie können die normalen oder die aktiven Grafikeinstellungen verwenden. Letztere enthalten animierte Seitenelemente wie Hoverschaltflächen anstelle von einfachen Schaltflächen auf Navigationsleisten.
  • Formatvorlagen. Ein Design verwendet eigene Formatvorlagen (Schriftarten) für Haupttext und Überschriften.

Gewisse Funktionsmerkmale von FrontPage stehen nur bei Verwendung eines Designs zur Verfügung. So werden zum Beispiel Seitenbanner und Schaltflächen der Navigationsleiste als Grafiken angezeigt, wenn ein Design verwendet wird, sie werden jedoch als Text angezeigt, wenn kein Design verwendet wird.

Sie können durch ein Design das Erscheinungsbild Ihrer Seiten an einer zentralen Stelle verwalten. Wenn Sie ein Design als Standard für Ihr Web auswählen, dann wird dieses Design auf alle bestehenden Seiten und auf alle später hinzugefügten Seiten angewendet. Sie können das Standarddesign ändern oder entfernen, womit die Änderung sich automatisch auf das gesamte Web auswirkt. Es gibt auch die Option, Designs nur auf einzelne Seiten anzuwenden.

Designs können geändert und angepasst werden. So können Sie zum Beispiel das Hintergrundbild oder die Schriftart für Überschriften eines Designs ändern. Wenn Sie ein vorgefertigtes Design anpassen, erstellen Sie eigentlich ein neues Design. Sie können Ihre eigenen Grafiken, Farbsätze und Formatvorlagen verwenden.

Weitere Informationen

Anwenden eines Designs

Anpassen eines Designs

Info über Grafiken

Info über Farben


Sie können eine Datei einer Person oder Arbeitsgruppe zuweisen, ohne eine bestimmte Aufgabe für diese Datei zu erstellen. In einer Arbeitsgruppenumgebung weist z. B. ein Produktmanager verschiedenen Arbeitsgruppen Dateien zu. Einzelne Arbeitsgruppen-Manager weisen dann den einzelnen Mitgliedern einer Arbeitsgruppe bestimmte Aufgaben für diese Dateien zu. Der Produktmanager kann den Fortschritt pro Arbeitsgruppe überwachen, während die einzelnen Arbeitsgruppen-Manager den Fortschritt jedes einzelnen Gruppenmitglieds verfolgen können.

Sie können Kommentare zu Dateien hinzufügen, den Arbeitsgruppen Dateien zuweisen sowie Aufgaben erstellen und zuweisen.


Ein Prüfstatus hilft Ihnen dabei, den Status von Seiten, Bildern und anderen Dateien während deren Vorbereitung zur Veröffentlichung anzugeben. Sie können z. B. eine Seite, die eine Syntaxprüfung benötigt, der Codeprüfung übergeben, eine Seite, die eine Copyright-Prüfung benötigt, der Rechtlichen Prüfung übergeben usw. Sie können benutzerdefinierte Prüfstatuskategorien erstellen und können von Datei zu Datei festlegen, welche Seiten oder andere Dateien freigegeben und in Ihrem bereits in Betrieb befindlichen Web veröffentlicht werden sollten.

Sie können den Prüfstatus verwenden, um Dateien für die Publikation zu überwachen und anzugeben, welche Dateien veröffentlicht werden können.


Sie können Berichte erstellen, die folgende Aufgaben erfüllen:

  • Anzeigen, welche Seiten langsam im Download sind. Microsoft FrontPage berechnet die Größe aller Bilder, von Text, Steuerelementen und anderen Elementen, die mit einer Seite in Ihrem Web verknüpft sind, um darzustellen, wie lange es für Sitebesucher dauert, bis sie eine Seite bei unterschiedlichen Modemgeschwindigkeiten übertragen haben.
  • Anzeigen, welche Dateien in Ihrem Web mit keinen anderen Dateien verknüpft sind. Sie können diese Informationen während der regelmäßigen Webverwaltung verwenden, um veraltete oder doppelte Dateien zu löschen.
  • Anzeigen und Drucken von Siteübersichten. FrontPage berechnet die Anzahl und Größe von Seiten, Bildern, nicht erledigten Aufgaben und anderen Elementen in Ihrem Web. Sie können sehen, welche Dateien am ältesten oder am neuesten sind, sie nach Person oder Arbeitsgruppe, der sie zugeordnet sind, nach Größe usw. sortieren.

Der Bericht "Siteübersicht" stellt eine "Inventarliste" Ihres Webs dar.


Verwalten eines Webs


Verwalten von Arbeitsabläufen mithilfe von Aufgaben
Zuweisen von Dateien an Personen oder Arbeitsgruppen
Organisieren von Seiten mithilfe von Kategorien
Verwalten des Veröffentlichungsprozesses
Erstellen von Webberichten
Anzeigen und Prüfen von Hyperlinks


Sie können Dateien, die in unterschiedlichen Ordnern gespeichert sind (oder auch verschiedene Dateien im selben Ordner) mithilfe von Kategorien in logische Gruppen einteilen. Dateien können in einer oder mehreren Kategorien klassifiziert werden und erlauben somit die Anzeige eines Webs nach Kategorien.

Sie könnten z. B. Dateien, die noch die Genehmigung des Herausgebers benötigen, in der Kategorie „Herausgeber“ klassifizieren. Alle Dateien, die mit dem Verkauf zu tun haben (z. B. Katalog- und Produktseiten im Stammweb, Bilder im Ordner images und eine Preisdatenbank in einem anderen Ordner) könnten in den Kategorien „Katalog“ und „Produkte“ zusammengefasst werden.

Sie können auch die Komponente Microsoft FrontPage Category verwenden, um zu Ihren Seiten dynamische Kategorielisten hinzuzufügen. Auf einer Seite für den Einkauf könnten Sie z. B. drei Produktlisten in den Kategorien „Kleine Anlagen“, „Große Anlagen“ und „Freiluftanlagen“ einfügen: die Sitebesucher können in jeder Liste auf ein Produkt klicken, um dessen Seite aus dem Onlinekatalog anzuzeigen. Wenn Sie Produkte zu einer Produktgruppe hinzufügen oder aus ihr entfernen und damit auch die Produktseiten aus dem Web entfernen, werden die Kategorielisten automatisch aktualisiert.

Sie können Dateien kategorisieren und dann die Dateien nach Kategorie auflisten oder dynamische Kategorielisten auf Ihren Seiten hinzufügen


Erstellen Sie Aufgaben, um die in Ihrem Web zu erledigenden Arbeiten zu verfolgen. Sie können einer Person oder einer Arbeitsgruppe eine Aufgabe zuweisen, ihre Priorität nach Wichtigkeit festlegen und die Aufgabe mit einer bestimmten Datei oder dem gesamten Web verknüpfen.

Wenn Sie eine Aufgabe mit einer Datei verknüpfen, können Sie auf Aufgabe ausführen klicken, um die Datei in dem Programm zu öffnen, das Sie für die Bearbeitung verwenden, und augenblicklich mit der Arbeit beginnen. Wenn Sie z. B. eine Aufgabe mit der Bezeichnung „Hintergrundbild ändern“ einer Bilddatei zuordnen, wird bei Ausführung der Aufgabe das Bild in Microsoft Image Composer, Adobe Photoshop oder in einem anderen Bildbearbeitungseditor, den Sie mit dem Bilddateityp verknüpft haben, geöffnet.

Microsoft FrontPage überwacht den Aufgabenstatus für Sie. Wenn Sie eine Seite, die mit einer Aufgabe verknüpft ist, in der Seitenansicht speichern, fragt FrontPage Sie, ob Sie den Aufgabenstatus in „Erledigt“ ändern möchten. Wenn Sie als Antwort Nein eingeben, ändert FrontPage den Aufgabenstatus in „In Bearbeitung“.

Sie können Aufgaben auch in der Aufgabenansicht als „Erledigt“ markieren.

Verwenden Sie die Aufgabenansicht, um Aufgaben zuzuweisen, mit Prioritäten zu versehen und zu verwalten.


In der Berichtsansicht listet der Bericht Siteübersicht die Gesamtzahl der Hyperlinks in Ihrem Web sowie die Anzahl der noch nicht geprüften Hyperlinks, der unterbrochenen Hyperlinks, der externen und der internen Hyperlinks auf.

Die Hyperlinkansicht zeigt Ihnen eine grafische Darstellung der Hyperlinks von und zu jeder Datei in Ihrem Web an. FrontPage verfolgt und repariert automatisch alle internen Hyperlinks in Ihrem Web, wenn Sie eine Datei verschieben, umbenennen oder löschen. Sie können den Status aller externen Hyperlinks mithilfe des Befehls Hyperlinks neu berechnen im Menü Extras augenblicklich prüfen.

Die Hyperlinkansicht stellt eine visuelle Landkarte der Hyperlinks in Ihrem Web dar: verwenden Sie den Bericht <strong>Siteübersicht</strong>, um eine Statistik über die Hyperlinks zu erhalten.


Formatieren von Text

Sie können Text in Microsoft FrontPage genauso formatieren wie in einem Textverarbeitungssystem, um visuelle Organisation, Hervorhebung und Struktur hinzuzufügen. Es können die Schriftart, Schriftgröße, Format, Farbe, Zeilenabstände, die vertikale Textposition geändert und Effekte wie Unterstreichung hinzugefügt werden. Sie können ebenfalls horizontale Abstände und die Einrückung steuern, Aufzählungszeichen und -nummern hinzufügen sowie die Ausrichtung festlegen. So formatieren Sie z. B. einen Haupttext mit der Schriftart Times New Roman in der Größe von 10 Punkt und die Überschriften mit Arial 16 Punkt, auf der Seite zentriert.

Text und Absätze

Die angewandte Formatierung kann sich entweder auf markierte Wörter oder auf einen gesamten Absatz beziehen. Als allgemeine Richtlinie gilt, dass Eigenschaften der Schrift auf markierten Text, und Absatzeigenschaften (wie Aufzählungszeichen und -nummern, Ränder und Schattierungen) sich auf den gesamten Absatz beziehen. So können Sie z. B. ein einzelnes Wort in einem Absatz kursiv formatieren, wenn Sie jedoch versuchen, ein Wort rechtsbündig auszurichten, wird der ganze Absatz ausgerichtet.

Ein Absatz ist ein Textblock, der von einem anderen durch eine Absatzmarke ( Absatzmarke) getrennt ist. Wenn Textzeilen durch einen Zeilenumbruch ( Zeilenumbruch) voneinander getrennt sind, wird der Text dennoch als ein Absatz betrachtet. Sie können Absatzmarken und Zeilenumbruch sichtbar machen, indem Sie auf Einblenden/Ausblenden Schaltfläche "Einblenden/Ausblenden" klicken.

Formatvorlagen

Eine Formatvorlage ist eine Sammlung von Zeichen- und Absatzformatierungen. Das Anwenden einer Formatvorlage auf einen Text ist ein Verfahren, das aus einem Schritt besteht und viel schneller durchgeführt werden kann, als jeden Absatz eines Textes individuell zu formatieren. Zudem ist ein Text bei Verwendung von Formatvorlagen einheitlicher formatiert. Um z. B. die Hauptüberschriften vom übrigen Text abzuheben, wenden Sie die Formatvorlage Überschrift 1 an und lassen den Haupttext in der Formatierung von Normal (dem Standard), in der eine kleinere Schrift verwendet wird. Sie können immer noch zusätzliche Formatierungen an Text anbringen, der über eine Formatvorlage formatiert ist, um z. B. ein Wort zu unterstreichen. Sie können Formatvorlagen erstellen, ändern und eigene, externe Dokumentvorlagen erstellen.

Sie können auch Motive verwenden, um einen Text automatisch zu formatieren, da jedes Motiv vordefinierte Formatvorlagen enthält. Wenn Sie das Erscheinungsbild eines Textes ändern möchten, auf den ein Motiv angewandt wurde, können sie entweder die vom Motiv verwendeten Formatvorlagen ändern oder markierten Text besonders formatieren.

Weitere Informationen

Formatieren von Text

Arbeiten mit Cascading Stylesheets

Info über Designs

Info über Listen


Organisieren eines Intranets durch Unterwebs

Ein Unterweb ist ein Web, das in einem anderen Web verschachtelt ist. Das Web, das ein Unterweb enthält, wird übergeordnetes Web genannt, weil es in der hierarchischen Struktur oberhalb des Unterwebs liegt, ähnlich wie in einem Stammbaum:

Organisieren von Ordnern und Unterwebs nach Arbeitsgruppe oder Berechtigungen

Im obigen Diagramm ist Nordwind das Stammweb; Marketing und Personalwesen sind Unterwebs im Stammweb Nordwind; Stellenausschreibungen und Mitarbeiterprämien sind Unterwebs von Personalwesen.

Sie können ein Unterweb erstellen, indem Sie einen Ordner in ein Web umwandeln, indem Sie ein Web in einen Ordner importieren und dann den Ordner in ein Web umwandeln, und indem Sie ein Web in einem anderen Web als Unterweb veröffentlichen. Ein Unterweb erbt anfänglich gewisse Webeinstellungen (wie Informationen über Designs und Berechtigungen) vom übergeordneten Web. Organisieren Sie Ihr Intranet mithilfe von Unterwebs auf eine logische Weise, die dem Organisationsmodell Ihrer Firma entspricht.

Sie können mithilfe von Unterwebs auch den Zugriff aus Sicherheitsgründen einschränken. Da jedes Unterweb seine eigene Zusammenstellung von Berechtigungen dafür hat, wer es bearbeiten, wer es nur durchsuchen und wer es verwalten darf, können Sie individuelle Unterwebs einrichten, die unterschiedliche Berechtigungsstufen und unterschiedliche Benutzergruppen haben.

Sie könnten z. B. verschiedene Unterwebs für Marketing und Personalwesen einrichten; innerhalb des Unterwebs Personalwesen könnten Sie verschiedene Unterwebs mit unterschiedlichen Berechtigungen für Stellenausschreibungen, Mitarbeiterdaten und Mitarbeiterprämien haben. So könnte nur das Personalbüro das Unterweb mit den Stellenausschreibungen bearbeiten, aber jedermann in der Firma dürfte das Unterweb durchsuchen. Nur Führungskräfte im Personalwesen dürften das Unterweb mit Mitarbeiterdaten durchsuchen und bearbeiten, während jeder in der Firma das Unterweb für Mitarbeiterprämien durchsuchen (aber nicht bearbeiten) könnte.


Verwenden einer Beispiel-Datenbankverbindung

FrontPage enthält eine Beispieldatenbank mit dem Namen Nordwind, die Sie zusammen mit dem Datenbankergebnis-Assistenten verwenden können, um Seiten zu erstellen, die Informationen aus Datenbanken anzeigen. Wenn Sie nie eine Datenbank verwendet haben oder wenn Sie mit dem Erstellen von Seiten experimentieren möchten, die Daten in eine Datenbank eingeben, ohne dass Sie Ihre eigene „Live“-Datenbank ändern müssen, dann führen Sie den Datenbankergebnis-Assistenten aus und verwenden die Nordwind-Datenbank.

  1. Öffnen Sie in der Seitenansicht eine Seite, die einen bestehenden Datenbankergebnisbereich enthält, oder erstellen Sie eine neue Seite, die einen solchen Bereich aufnehmen soll, und starten Sie dann den Datenbankergebnis-Assistenten:
    • Wenn Sie den Assistenten noch nicht aufgerufen haben, um einen Datenbankergebnisbereich auf der Seite zu erstellen, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
    • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, und Sie die betreffenden Daten durch die Daten aus der Nordwind-Datenbank ersetzen möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle innerhalb des Datenbankergebnisbereichs, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
  2. Klicken Sie in Schritt 1 des Assistenten auf Beispieldatenbankverbindung verwenden (Nordwind).

Hinzufügen von Informationen aus einer Datenbank mithilfe des Datenbankergebnis-Assistenten


Verwenden einer bestehenden Datenbankverbindung

Um Informationen aus einer Datenbank anzuzeigen oder in eine Datenbank einzugeben, verwendet FrontPage eine Datenbankverbindung. Diese gibt den Namen, Speicherort und den Typ der Datenbank an, auf die Sie zugreifen möchten, zusammen mit gegebenenfalls erforderlichen Parametern.

Wenn Sie den Datenbankergebnis-Assistenten starten, geben Sie die Datenbankverbindung an, die Sie verwenden möchten. Um unter den bestehenden Datenbankverbindungen für Ihr Web eine Verbindung auszuwählen, führen Sie folgende Schritte aus:

  1. Öffnen Sie in der Seitenansicht eine Seite, die einen bestehenden Datenbankergebnisbereich enthält, oder erstellen Sie eine neue Seite, die einen solchen Bereich aufnehmen soll, und rufen Sie dann den Datenbankergebnis-Assistenten auf:
    • Wenn Sie den Assistenten noch nicht aufgerufen haben, um einen Datenbankergebnisbereich auf der Seite zu erstellen, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
    • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, und Sie die betreffenden Daten durch die Daten aus der Nordwind-Datenbank ersetzen möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle innerhalb des Datenbankergebnisbereichs, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
  2. Klicken Sie in Schritt 1 des Assistenten auf Bestehende Datenbankverbindung verwenden, und wählen Sie dann eine andere Datenbankverbindung aus.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer neuen Datenbankverbindung zu einer Datei oder einem Ordner im aktuellen Web

Um Informationen aus einer Datenbank oder Eingabeinformationen für eine Datenbank anzeigen zu können, verwendet FrontPage eine Datenbankverbindung. Diese gibt den Namen, Speicherort und den Typ der Datenbank an, auf die Sie zugreifen möchten, zusammen mit weiteren, ggf. erforderlichen Parametern.

Wenn Sie den Datenbankergebnis-Assistenten starten, geben Sie die Datenbankverbindung an, die Sie verwenden möchten. Um eine neue Verbindung zu einer Datenbankdatei oder -ordner im aktuellen Web zu erstellen (zum Beispiel zu einer Microsoft Access- oder Microsoft Excel-Datenbank), führen Sie folgende Schritte aus:

  1. Öffnen Sie in der Seitenansicht eine Seite, die einen bestehenden Datenbankergebnisbereich enthält, oder erstellen Sie eine neue Seite, welche die Datenbankergebnisse aufnehmen soll, und starten Sie dann den Datenbankergebnis-Assistenten:
    • Wenn Sie den Assistenten zur Erstellung eines Datenbankergebnisbereichs auf der Seite noch nicht aufgerufen haben, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
    • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, und Sie die betreffenden Daten durch die Daten aus einer anderen Datenbankverbindung ersetzen möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle innerhalb des Datenbankergebnisbereichs, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
  2. Klicken Sie in Schritt 1 des Assistenten auf Neue Datenbankverbindung verwenden, und klicken Sie dann auf Erstellen.
  3. Klicken Sie auf Hinzufügen, und geben Sie dann im Feld Name einen Namen für die neue Datenbankverbindung ein.
  4. Klicken Sie auf Datei oder Ordner im aktuellen Web, und klicken Sie dann auf Durchsuchen.
  5. Wählen Sie im Feld Dateityp den Treiber für den Typ der Datenbank aus, mit dem Sie einen Verbindung herstellen möchten.
  6. Geben Sie im Feld URL den Pfad zur Datei oder zum Ordner ein, der die Datenbank enthält, und klicken Sie dann auf OK. Oder navigieren Sie mithilfe der Dateiliste im Feld Suchen in zur gewünschten Datei oder zum gewünschten Ordner, und doppelklicken Sie dann auf die Datei oder den Ordner in der Liste.
  7. Klicken Sie auf OK, um das Dialogfeld Eigenschaften der Datenbankverbindung zu schließen, und klicken Sie dann auf OK, um das Dialogfeld Webeinstellungen zu schließen.

Tipps

  • Um eine neue Datenbankverbindung für ein Web zu erstellen, ohne den Datenbankergebnis-Assistenten auszuführen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Datenbank, und befolgen Sie dann dieses Verfahren ab Schritt 3.
  • Wenn die Datenbank kennwortgeschützt ist, klicken Sie auf Erweitert, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in den jeweiligen Feldern ein.
  • Um Timeouts und andere Name/Wert-Parameter für die Datenbank einzurichten, klicken Sie auf Erweitert.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer neuen Datenbankverbindung mit einem System-DSN auf einem Webserver

Um Informationen aus einer Datenbank oder Eingabeinformationen für eine Datenbank anzeigen zu können, verwendet FrontPage eine Datenbankverbindung. Diese gibt den Namen, Speicherort und den Typ der Datenbank an, auf die Sie zugreifen möchten, zusammen mit weiteren, ggf. erforderlichen Parametern.

Wenn Sie den Datenbankergebnis-Assistenten starten, geben Sie die Datenbankverbindung an, die Sie verwenden möchten. Sie können sich mit jedem auf dem Webserver definierten Systemdatenquellennamen (System-DSN) verbinden. Ein System-DSN kann mit einer ODBC-konformen Datenbank (wie Microsoft Access oder Microsoft Excel) oder einem Datenbank-Verwaltungssystem (wie Microsoft SQL Server) eine Verbindung aufnehmen.

Anmerkung Nur ein Webserver-Administrator kann eine System-DSN auf einem Webserver erstellen. Wenn der Webserver keinen System-DSN für die Datenbank hat, auf die Sie zugreifen möchten, bitten Sie den Webserver-Administrator, eine solche mithilfe der Option ODBC-Datenquellen in der Systemsteuerung zu definieren.

Um eine neue Verbindung mit einer Systemdatenquelle auf einem Webserver zu erstellen, führen Sie folgende Schritte aus:

  1. Öffnen Sie in der Seitenansicht eine Seite mit einem bestehenden Datenbankergebnisbereich, oder erstellen Sie eine neue Seite, welche die Datenbankergebnisse aufnehmen soll, und starten Sie dann den Datenbankergebnis-Assistenten:
    • Wenn Sie den Assistenten zur Erstellung eines Datenbankergebnisbereichs auf der Seite noch nicht aufgerufen haben, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
    • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, und Sie die betreffenden Daten durch die Daten aus einer anderen Datenbankverbindung ersetzen möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle innerhalb des Datenbankergebnisbereichs, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
  2. Klicken Sie in Schritt 1 des Assistenten auf Neue Datenbankverbindung verwenden, und klicken Sie dann auf Erstellen.
  3. Klicken Sie auf Hinzufügen, und geben Sie dann im Feld Name einen Namen für die neue Datenbankverbindung ein.
  4. Klicken Sie auf Datenquelle auf dem Webserver, und klicken Sie dann auf Durchsuchen.

    5. Das Dialogfeld Datenquellen auf dem Webserver wird angezeigt. Die Liste zeigt die auf dem Webserver definierten System-DSNs an.

  5. Markieren Sie den System-DSN für die Datenbank, auf die Sie zugreifen möchten, und klicken Sie dann auf OK.
  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften der Datenbankverbindung zu schließen, und klicken Sie dann auf OK, um das Dialogfeld Webeinstellungen zu schließen.

Tipps

  • Um eine neue Datenbankverbindung für ein Web zu erstellen, ohne den Datenbankergebnis-Assistenten auszuführen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Datenbank, und befolgen Sie dann dieses Verfahren ab Schritt 3.
  • Wenn die Datenbank kennwortgeschützt ist, klicken Sie auf Erweitert, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in den jeweiligen Feldern ein.
  • Um Timeouts und andere Name/Wert-Parameter für die Datenbank einzurichten, klicken Sie auf Erweitert.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer neuen Datenbankverbindung zu einem Datenbankserver in einem Netzwerk

Um Informationen aus einer Datenbank oder Eingabeinformationen für eine Datenbank anzeigen zu können, verwendet FrontPage eine Datenbankverbindung. Diese gibt den Namen, Speicherort und den Typ der Datenbank an, auf die Sie zugreifen möchten, zusammen mit weiteren, ggf. erforderlichen Parametern.

Wenn Sie den Datenbankergebnis-Assistenten starten, geben Sie die Datenbankverbindung an, die Sie verwenden möchten. Um eine Verbindung zu einem Datenbank-Verwaltungssystem (wie Microsoft SQL Server) auf einem Netzwerkserver herzustellen, führen Sie folgende Schritte aus:

  1. Öffnen Sie in der Seitenansicht eine Seite, die einen bestehenden Datenbankergebnisbereich enthält, oder erstellen Sie eine neue Seite, welche die Datenbankergebnisse aufnehmen soll, und starten Sie dann den Datenbankergebnis-Assistenten:
    • Wenn Sie den Assistenten zur Erstellung eines Datenbankergebnisbereichs auf der Seite noch nicht aufgerufen haben, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
    • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, und Sie die betreffenden Daten durch die Daten aus einer anderen Datenbankverbindung ersetzen möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle innerhalb des Datenbankergebnisbereichs, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
  2. Klicken Sie in Schritt 1 des Assistenten auf Neue Datenbankverbindung verwenden, und klicken Sie dann auf Erstellen.
  3. Klicken Sie auf Hinzufügen, und geben Sie dann im Feld Name einen Namen für die neue Datenbankverbindung ein.
  4. Klicken Sie auf Anderer Datenbankserver im Netzwerk, und klicken Sie dann auf Durchsuchen.
  5. Markieren Sie im Feld Typ der Datenbank den Typ des Datenbanktreibers, den Sie für die Verbindung mit dem Datenbankserver verwenden möchten.
  6. Geben Sie im Feld Servername den URL des Netzwerkservers ein, der die Datenbank enthält, auf die Sie zugreifen möchten.
  7. Geben Sie im Feld Datenbankname den Namen der Datenbank ein, und klicken Sie dann auf OK, um das Dialogfeld Datenbankverbindung über Netzwerk zu schließen.

    8. Anmerkung Sie brauchen keinen Datenbanknamen einzugeben, um sich mit einem Oracle-Datenbankserver zu verbinden.

  8. Klicken Sie auf OK, um das Dialogfeld Neue Datenbankverbindung zu schließen, und klicken Sie dann auf OK, um das Dialogfeld Webeinstellungen zu schließen.

Tipps

  • Um eine neue Datenbankverbindung für ein Web zu erstellen, ohne den Datenbankergebnis-Assistenten auszuführen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Datenbank, und befolgen Sie dann dieses Verfahren ab Schritt 3.
  • Wenn die Datenbank kennwortgeschützt ist, klicken Sie auf Erweitert, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in den jeweiligen Feldern ein.
  • Um Timeouts und andere Name/Wert-Parameter für die Datenbank einzurichten, klicken Sie auf Erweitert.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Einrichten oder Ändern von erweiterten Eigenschaften einer Datenbankverbindung

Wenn eine Datenbank kennwortgeschützt ist, müssen Sie Ihren Benutzernamen und Ihr Kennwort in den erweiterten Eigenschaften der Datenbankverbindung speichern, damit FrontPage auf die Datenbank zugreifen kann. Sie können auch Timeouts oder andere Parameter einer Datenbankverbindung festlegen.

Tipp Um die erweiterten Eigenschaften einer Datenbankverbindung einzurichten, während Sie eine neue Datenbankverbindung mithilfe des Datenbankergebnis-Assistenten erstellen, befolgen Sie dieses Verfahren ab Stufe 3, wenn das Dialogfeld Neue Datenbankverbindung angezeigt wird.

  1. Klicken Sie im Menü Extras auf Webeinstellungen, und klicken Sie dann auf die Registerkarte Datenbank.
  2. Klicken Sie auf die Datenbankverbindung, die Sie ändern möchten, und klicken Sie dann auf Ändern.
  3. Klicken Sie auf Erweitert, um die Eigenschaften von Autorisierung und Timeouts einzustellen bzw. zu bearbeiten :
    • Um einen Benutzernamen und ein Kennwort für FrontPage anzugeben, das zum Verbinden mit der Datenbank zu verwenden ist, geben Sie im Feld Benutzername einen Benutzernamen und ein Kennwort im Feld Kennwort ein.

      • Anmerkung Wenn die Verbindung für einen Datenbankserver in einem Netzwerk gedacht ist, wird die Kombination von Benutzername und Kennwort häufig Konto genannt. Fragen Sie Ihren Datenbank-Administrator nach einem Konto mit den passenden Berechtigungen zur Verwendung bei einem Webserver. Um die Privatsphäre Ihrer Datenbank zu schützen, verwenden Sie nicht das Konto „Administrator“.

    • Um Timeouts für die Datenbankverbindung einzurichten, geben Sie im Feld Verbindung die Anzahl der Sekunden ein, die verstreichen müssen, bevor der Server das Zeitlimit erreicht, während FrontPage versucht, die Verbindung herzustellen, und geben Sie dann im Feld Befehl die Anzahl der Sekunden ein, die verstreichen müssen, bevor die an die Verbindung gesandten Befehle ihr Zeitlimit erreichen.
  4. Stellen Sie Andere Parameter ein. Die verfügbaren Optionen und Entscheidungen, die Sie treffen können, sind spezifisch für den Typ der jeweiligen Datenbankverbindung:
    • Wenn die Datenbankverbindung keine benutzereigene Definition verwendet, können Sie zusätzliche Parameter, die spezifisch für den verwendeten ODBC-Treiber sind, hinzufügen, ändern und entfernen.
    • Wenn die Datenbankverbindung eine benutzereigene Definition verwendet, können Sie die Verbindungszeichenfolge bearbeiten oder die Position des Datenbankcursors verändern.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Auswählen einer Datensatzquelle aus einer Datenbank

Nachdem Sie eine Datenbankverbindung in Schritt 1 des Datenbankergebnis-Assistenten ausgewählt oder erstellt haben, verbindet FrontPage sich mit der Datenbank und liest deren Datensatzquellen, d. h. deren Tabellen oder Ansichten. (In einer Microsoft Access-Datenbank wird eine Ansicht Abfrage genannt.) Sie können die Datensatzquelle auswählen, in der die Datensätze enthalten sind, die Sie in dem Datenbankergebnisbereich auf der Seite anzeigen möchten.

Wenn Sie zum Beispiel die Beispieldatenbank Nordwind verwenden, können Sie die Tabelle Personal als Datensatzquelle auswählen, um die Mitarbeiterdatensätze aus dieser Tabelle in dem Datenbankergebnisbereich anzuzeigen.

  1. Klicken Sie in Schritt 2 des Datenbankergebnis-Assistenten auf Datensatzquelle, und klicken Sie dann auf das Feld, um eine Liste der Tabellen und Ansichten in der Datenbank anzuzeigen.
  2. Klicken Sie auf die Tabelle oder Ansicht, welche die Informationen enthalten, die Sie in dem Datenbankergebnisbereich anzeigen möchten.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer benutzerdefinierten Abfrage

Nachdem Sie in Schritt 1 des Datenbankergebnis-Assistenten eine Datenbankverbindung ausgewählt oder erstellt haben, verbindet FrontPage sich mit der Datenbank und liest deren Datensatzquellen. Sie können dann mithilfe von Structured Query Language (SQL) eine benutzerdefinierte Abfrage erstellen, um die Informationen anzugeben, die in dem Datenbankergebnisbereich auf der Seite angezeigt werden sollen. Sie können Parameter in die Abfrage einfügen, eine Abfrage aus der Zwischenablage einfügen oder die Abfrage anhand der Datenbank überprüfen, um sicherzugehen, ob Syntax und Parameter korrekt sind.

Wenn Sie ein Formular erstellt haben, über das ein Sitebesucher Text eingeben oder eine Auswahl vornehmen kann, damit nur ausgewählte Datensätze aus der Datenbank zurückgegeben werden, können Sie den Namen eines Formularfeldes in der Abfrage als Parameter angeben. Wenn der Sitebesucher das Formular übermittelt, wird der Formularfeldname durch den Wert des Formularfeldes in der Abfragezeichenfolge ersetzt.

Sie können zum Beispiel ein Formular erstellen, über das ein Sitebesucher die Telefonnummer einer bestimmten Person in der Adressbuchdatenbank für Mitarbeiter nachschlagen kann. Wenn der Sitebesucher den Nachnamen eines Mitarbeiters im Formular eingibt und das Formular an den Server übermittelt, wird dieser Nachname in einer benutzerdefinierten Abfrage eingesetzt, die einen Parameter in der WHERE-Klausel enthält, der dem genannten Formularfeld entspricht. Der Datenbankergebnisbereich zeigt dann eine Liste von Mitarbeitern an, deren Nachnamen mit dem vom Sitebesucher angegebenen Namen übereinstimmen.

Anmerkung Wenn Sie nicht wissen, wie eine benutzerdefinierte Abfrage mithilfe einer SQL-Anweisung geschrieben wird, wenden Sie dieses Verfahren nicht an.

  1. Klicken Sie in Schritt 2 des Datenbankergebnis-Assistenten auf Benutzerdefinierte Abfrage, und klicken Sie dann auf Bearbeiten.
  2. Geben Sie im Feld SQL-Anweisung die Abfrage unter Verwendung gültiger SQL-Anweisungen ein.
  3. Um den Namen eines Formularfeld-Parameters in die Abfrage einzufügen, klicken Sie auf Parameter einfügen, und geben Sie dann den Namen des Formularfeldes ein, der bei Ausführung der Abfrage durch seinen Wert ersetzt werden soll.
  4. Um eine SQL-Anweisung aus der Zwischenablage einzufügen, klicken Sie auf Aus Zwischenablage.
  5. Um die Abfrage anhand der Datenbank zu überprüfen, klicken Sie auf Abfrage prüfen.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Bearbeiten der Liste von Feldern, die in Datenbankergebnissen eingeschlossen werden sollen

Nachdem Sie eine Datensatzquelle in Schritt 2 des Datenbankergebnis-Assistenten ausgewählt oder erstellt haben, liest FrontPage die Datensatzquelle (oder verarbeitet die benutzerdefinierte Abfrage) und zeigt dann in Schritt 3 des Assistenten eine Liste der Felder der Datensatzquelle (oder der durch die benutzerdefinierte Abfrage zurückgegebenen Felder). Wenn Sie Felder, die in dem Datenbankergebnisbereich enthalten sein sollen, hinzufügen, entfernen oder umsortieren möchten, führen Sie folgende Schritte aus:

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Liste bearbeiten.

    2. Es wird das Dialogfeld Angezeigte Felder angezeigt. Dies ist eine Liste mit allen Feldern, die in dem Datenbankergebnisbereich angezeigt werden. Standardmäßig enthält die Liste zunächst alle Felder der Datensatzquelle (bzw. alle durch die benutzerdefinierte Abfrage zurückgegebenen Felder). Die Felder werden in dem Datenbankergebnisbereich in der Reihenfolge angezeigt, in der sie in der Liste Angezeigte Felder erscheinen.

  2. Ändern Sie die Liste Angezeigte Felder wie folgt:
    • Um ein Feld aus dem Datenbankergebnisbereich zu entfernen, markieren Sie das Feld, das Sie entfernen möchten, und klicken Sie dann auf Entfernen.
    • Um die Reihenfolge, in der die Felder in dem Datenbankergebnisbereich angezeigt werden, zu ändern, markieren Sie das Feld, das Sie verschieben möchten, und klicken Sie dann auf Nach oben oder Nach unten.
    • Um ein Feld zum Datenbankergebnisbereich hinzuzufügen, markieren Sie das betreffende Feld in der Liste Verfügbare Felder, und klicken Sie dann auf Hinzufügen, um das Feld zur Liste Angezeigte Felder hinzuzufügen.
  3. Wenn die Liste Angezeigte Felder die Felder, die Sie mit einschließen möchten, in der richtigen Reihenfolge enthält, klicken Sie auf OK.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Festlegen von Kriterien, die für das Filtern von Datenbankergebnissen verwendet werden sollen

Nachdem Sie in Schritt 2 des Datenbankergebnis-Assistenten eine Datensatzquelle ausgewählt oder eine benutzerdefinierte Abfrage erstellt haben, liest FrontPage die Datensatzquelle (oder verarbeitet die benutzerdefinierte Abfrage) und zeigt dann in Schritt 3 des Assistenten eine Liste der Felder der Datensatzquelle (oder der durch die Abfrage zurückgegebenen Felder) an. Sie können bestimmte Kriterien auf folgende Weise verwenden:

  • Sitebesucher dürfen die Datenbank nach Informationen durchsuchen. Der Assistent kann ein Suchformular erstellen, mit dem Datensätze gefunden werden können, die gewissen Kriterien entsprechen, sowie einen Datenbankergebnisbereich darunter, in dem die Ergebnisse der Suche angezeigt werden.

    • Wenn zum Beispiel ein Sitebesucher, der zu der Seite gelangt ist, die Durchwahl eines Mitarbeiters in der Nordwind-Datenbank nachschauen möchte, kann er den Nachnamen des Mitarbeiters (zum Beispiel „Smith“) im Feld Suchen nach eingeben. Wenn er auf Suche beginnen klickt, sucht die Datenbank nach Mitarbeiterdatensätzen, deren Nachname gleich „Smith“ ist, und zeigt die gefundenen Datensätze im Datenbankergebnisbereich unterhalb des Suchformulars auf derselben Seite an.

  • Filtern der Datensätze, die im Datenbankergebnisbereich einer Seite angezeigt werden.

    • Wenn Sie zum Beispiel eine Liste von Mitarbeitern anzeigen möchten, die in Seattle oder in der nordwestlichen Vertriebsregion leben, können Sie Kriterien angeben, dass nur Datensätze aus der Personaltabelle angezeigt werden, bei denen der Wert des Feldes Ort gleich „Seattle“ oder der Wert des Feldes Region gleich „Nordwest“ ist.

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Erweiterte Optionen, klicken Sie auf Kriterien, und klicken Sie dann auf Hinzufügen.
  2. Wählen Sie im Feld Feldname das Feld aus, das den Wert enthält, nach dem Sie suchen möchten. Im obigen Beispiel würden Sie die Felder mit den Bezeichnungen Nachname oder Ort markieren.
  3. Wählen Sie im Feld Vergleich die Art des durchzuführenden Vergleichs aus. Im obigen Beispiel würden Sie Ist gleich markieren.
  4. Legen Sie im Bereich Wert die Optionen fest, je nachdem, was Sie tun möchten:
    • Um ein Suchformular zu erstellen, mit dem Sitebesucher bestimmte Datensätze nachschauen können, prüfen Sie, ob das Kontrollkästchen Wert von diesem Abfrageparameter übernehmen aktiviert ist und ob der im Feld Wert angezeigte Feldname mit dem im Feld Feldname angezeigten Namen identisch ist. Im obigen Beispiel würden Sie Nachname für Wert und Feldname wählen.

      • Anmerkung Um das Erstellen des Suchformulars abzuschließen, müssen Sie das Kontrollkästchen Formular zum Abfragen der Eingabeparameter erstellen in Schritt 5 des Assistenten aktivieren.

    • Um die Datenbankergebnisse zu filtern, damit nur Datensätze angezeigt werden, die mit einem bestimmten Wert übereinstimmen, deaktivieren Sie das Kontrollkästchen Wert von diesem Abfrageparameter übernehmen, und geben Sie dann den Wert im Feld darunter ein. Im zweiten, weiter oben genannten Beispiel würden Sie „Seattle“ eingeben.
    • Um einen Parameterwert in einer benutzerdefinierten Abfrage, die Sie in Schritt 2 des Assistenten erstellt haben, zu ersetzen, aktivieren Sie das Kontrollkästchen Wert von diesem Abfrageparameter übernehmen, und geben Sie dann im Feld Wert den Namen des in der benutzerdefinierten Abfrage angegebenen Parameters an.
  5. Wenn Sie weitere Kriterien angeben oder ein anderes Feld zum Suchformular hinzufügen möchten, markieren Sie im Feld Und/Oder den Operator, der in Kombination mit weiteren Kriterien zu verwenden ist. Im zweiten, oben genannten Beispiel würden Sie Oder markieren.
  6. Wenn Sie auf OK klicken, wird die neue Bedingung im Dialogfeld Kriterien angezeigt. Um weitere Kriterien anzugeben oder eine anderes Feld hinzuzufügen, klicken Sie auf Hinzufügen, und wiederholen Sie das Verfahren ab Schritt 2.

    7. Im ersten, oben angeführten Beispiel könnten Sie das Feld Vorname zum Suchformular hinzufügen, damit der Sitebesucher seine Suche weiter verfeinern kann. Im zweiten Beispiel würden Sie in Schritt 2 das Feld mit der Bezeichnung Region markieren, in Schritt 3 den Vergleich Ist gleich markieren und in Schritt 4 den Wert „Nordwest“ eingeben.

  7. Wenn Sie mit den im Dialogfeld Kriterien aufgeführten Kriterien zufrieden sind, klicken Sie auf OK, um das Dialogfeld zu schließen.

Tipps

  • Um eine Klausel in bestehenden Kriterien zu ändern, markieren Sie im Dialogfeld Kriterien die Bedingung, die Sie ändern möchten, und klicken Sie dann auf Ändern.
  • Um eine Klausel aus den bestehenden Kriterien zu entfernen, markieren Sie im Dialogfeld Kriterien die Bedingung, die Sie entfernen möchten, und klicken Sie dann auf Löschen.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Festlegen der Sortierreihenfolge von Datenbankergebnissen

Nachdem Sie in Schritt 2 des Datenbankergebnis-Assistenten eine Datensatzquelle ausgewählt oder eine benutzerdefinierte Abfrage erstellt haben, liest FrontPage die Datensatzquelle (oder verarbeitet die benutzerdefinierte Abfrage) und zeigt dann in Schritt 3 des Assistenten eine Liste der Felder der Datensatzquelle (oder der durch die Abfrage zurückgegebenen Felder) an.

Wenn eine Seite mit einem Datenbankergebnisbereich von einem Sitebesucher durch einen Browser angezeigt wird, dann ist die Liste der Datenbankergebnisse standardmäßig nicht sortiert. Sie können für die Liste eine Sortierreihenfolge angeben, indem Sie bestimmte Felder aus der Datensatzmenge auswählen, nach denen das Ergebnis sortiert werden soll.

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Erweiterte Optionen, und klicken Sie dann auf Sortierung.

    2. Die Liste Verfügbare Felder zeigt alle Felder der markierten Datensatzquelle an. Die Liste Sortierreihenfolge zeigt die Felder an, die zum Sortieren der Datenbankergebnisse verwendet werden. Ein Pfeil nach oben neben einem Feldnamen zeigt an, dass das Feld in aufsteigender Reihenfolge sortiert wird (zum Beispiel von A bis Z). Ein Pfeil nach unten zeigt eine absteigende Sortierung an (zum Beispiel von Z to A).

  2. Markieren Sie in der Liste Verfügbare Felder das primäre Feld, nach dem die Datenbankergebnisse sortiert werden sollen, und klicken Sie dann auf Hinzufügen, um das Feld zur Liste Sortierreihenfolge hinzuzufügen.

    3. Tipp Sie können mehrere Felder zur Liste Sortierreihenfolge hinzufügen. Die Datenbankergebnisse werden zunächst nach dem ersten Feld in der Liste und dann nach dem zweiten Feld in der Liste sortiert. Wenn Sie zum Beispiel eine Liste der Mitarbeiter anzeigen möchten, die nach dem Nachnamen und dann nach dem Vornamen sortiert ist, würden Sie die Felder Nachname und dann Vorname zur Liste Sortierreihenfolge hinzufügen.

  3. Um ein Feld aus der Liste Sortierreihenfolge zu entfernen, markieren Sie es, und klicken Sie dann auf Entfernen.
  4. Um die Reihenfolge der Felder in der Liste Sortierreihenfolge zu ändern, markieren Sie das Feld, welches Sie verschieben möchten, und klicken Sie dann auf Nach oben oder Nach unten.
  5. Um die Sortierreihenfolge eines Feldes von aufsteigend in absteigend zu ändern, markieren Sie das Feld in der Liste Sortierreihenfolge, und klicken Sie dann auf Vertauschen. Der Pfeil neben dem Feldnamen ändert sich, um die Sortierrichtung anzuzeigen.
  6. Wenn Sie mit der Reihenfolge in der Liste Sortierreihenfolge zufrieden sind, klicken Sie auf OK.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Bereitstellen von Standardwerten für Eingabeparameter

Wenn Sie Formulare erstellen, mit denen Sitebesucher nach Informationen in einer Datenbank suchen können, dann können Sie Standardwerte oder Eingabeparameter für jedes Feld bereitstellen. Wenn zum Beispiel die meisten Ihrer Mitarbeiter in Seattle wohnen, können Sie Seattle als Standardwert für das Feld Ort festlegen.

Eingabeparameter können mithilfe einer benutzerdefinierten Abfrage in Schritt 2 des Assistenten definiert werden, oder indem Sie in Schritt 3 Filterkriterien für bestimmte Felder hinzufügen.

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Weitere Optionen, und klicken Sie dann auf Standardwerte.

    2. Das Dialogfeld Standardwerte wird angezeigt. Die Liste Eingabeparameter zeigt die Eingabeparameter an, die Sie festgelegt haben, als Sie die benutzerdefinierte Abfrage erstellt oder die Filterkriterien definiert haben, zusammen mit den zugeordneten Standardwerten (falls zutreffend).

  2. Markieren Sie in der Liste Eingabeparameter den Parameter, für den Sie einen Standardwert angeben oder ändern möchten, und klicken Sie dann auf Bearbeiten.
  3. Geben Sie den Standardwert für diesen Parameter im Feld Wert ein, und klicken Sie dann auf OK.
  4. Wenn Sie mit den Standardwerten in der Liste Eingabeparameter zufrieden sind, klicken Sie auf OK.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Einschränken der Anzahl zurückgegebener Datensätze

Nachdem Sie in Schritt 2 des Datenbankergebnis-Assistenten eine Datensatzquelle ausgewählt oder eine benutzerdefinierte Abfrage erstellt haben, liest FrontPage die Datensatzquelle (oder verarbeitet die benutzerdefinierte Abfrage) und zeigt dann in Schritt 3 des Assistenten eine Liste der Felder der Datensatzquelle (oder der durch die Abfrage zurückgegebenen Felder) an.

Um die Anzahl der zurückgegebenen und im Datenbankergebnisbereich angezeigten Datensätze auf einer Seite einzuschränken, führen Sie folgende Schritte aus:

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Erweiterte Optionen.
  2. Aktivieren Sie das Kontrollkästchen Anzahl der zurückgelieferten Datensätze beschränken auf, und geben Sie dann im Feld rechts daneben die Höchstzahl der Datensätze, die zurückgegeben und im Datenbankergebnisbereich angezeigt werden sollen, ein.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer Meldung, die anzuzeigen ist, wenn keine Datensätze zurückgegeben werden

Nachdem Sie in Schritt 2 des Datenbankergebnis-Assistenten eine Datensatzquelle ausgewählt oder eine benutzerdefinierte Abfrage erstellt haben, liest FrontPage die Datensatzquelle (oder verarbeitet die benutzerdefinierte Abfrage) und zeigt dann in Schritt 3 des Assistenten eine Liste der Felder der Datensatzquelle (oder der durch die Abfrage zurückgegebenen Felder) an.

Um eine Meldung zu erstellen, die im Datenbankergebnisbereich auf einer Seite anzuzeigen ist, wenn keine Datensätze zurückgegeben wurden, führen Sie folgende Schritte aus:

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Erweiterte Optionen.
  2. Geben Sie im Feld Meldung, die angezeigt werden soll, wenn keine Datensätze zurückgeliefert wurden, den Text der Meldung ein, die angezeigt werden soll.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Formatieren von Datenbankergebnissen als Tabelle

Nachdem Sie in Schritt 3 des Datenbankergebnis-Assistenten die Liste der Felder bearbeitet oder Optionen festgelegt haben, können Sie in Schritt 4 des Assistenten wählen, wie die Datenbankergebnisse auf der Seite angezeigt werden sollen. Formatieren Sie die Ergebnisse mithilfe dieses Verfahrens in einer Tabelle. Jede Spalte einer Datenbankergebnistabelle entspricht einem Feld aus der Datensatzquelle; jede Zeile entspricht einem zurückgegebenen Datensatz.

Wenn Sie zum Beispiel sich dafür entscheiden, eine Mitarbeitertelefonliste als Tabelle zu formatieren, dann könnte die erste Spalte die Vornamen der Mitarbeiter, die zweite die Nachnamen und die dritte Spalte die Nummern der Nebenstellen enthalten. Jede Zeile würde den Vornamen, Nachnamen und die Nebenstelle eines anderen Mitarbeiters auflisten.

  1. Klicken Sie in Schritt 4 des Datenbankergebnis-Assistenten in der Liste Wählen Sie Formatierungsoptionen für die von der Abfrage zurückgelieferten Datensätze aus auf Tabelle - ein Datensatz pro Zeile.
  2. Geben Sie weitere Tabellenformatierungsoptionen wie folgt ein:
    • Um die inneren und äußeren Tabellenrahmen im Datenbankergebnisbereich zu verbergen, deaktivieren Sie das Kontrollkästchen Tabelle mit Rahmen verwenden.
    • Um eine Tabelle nur so breit wie für ihren Inhalt nötig zu erstellen, deaktivieren Sie das Kontrollkästchen Tabelle auf Seitenbreite ausdehnen. Wenn das Kontrollkästchen aktiviert ist (die Standardeinstellung), hat die Tabelle dieselbe Breite wie die Seite.
    • Um eine Tabelle ohne Kopfzeile zu erstellen, in der der jeweilige Spalteninhalt bezeichnet wird, deaktivieren Sie das Kontrollkästchen Kopfzeile mit Spaltenüberschriften hinzufügen.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Formatieren von Datenbankergebnissen als Liste

Nachdem Sie in Schritt 3 des Datenbankergebnis-Assistenten die Liste der Felder bearbeitet oder Optionen festgelegt haben, können Sie in Schritt 4 des Assistenten wählen, wie die Datenbankergebnisse auf der Seite angezeigt werden sollen. Formatieren Sie die Ergebnisse mithilfe dieses Verfahrens in einer Liste, in der jede Zeile die Bezeichnung und die Daten eines Feldes anzeigt.

  1. Klicken Sie in Schritt 4 des Datenbankergebnis-Assistenten in der Liste Wählen Sie Formatierungsoptionen für die von der Abfrage zurückgelieferten Datensätze aus auf Liste - ein Datensatz pro Listenelement.
  2. Geben Sie weitere Formatierungsoptionen für die Liste folgendermaßen an:
    • Um Feldbezeichnungen zu verbergen und nur Daten anzuzeigen, deaktivieren Sie das Kontrollkästchen Beschriftungen für alle Felder hinzufügen.
    • Um das Ergebnis in einer kontinuierlichen Liste ohne Trennzeichen zwischen den Datensätzen anzuzeigen, deaktivieren Sie das Kontrollkästchen Horizontale Trennlinie zwischen Datensätzen.
  3. Wählen Sie aus dem Feld Listenoptionen einen Formatierungsstil für die Liste aus, wie zum Beispiel Aufzählung oder Nummerierung.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Anzeigen aller Datensätze zusammen oder Aufteilen der Datensätze in kleinere Gruppen

Nachdem Sie in Schritt 4 des Datenbankergebnis-Assistenten entschieden haben, wie die Datenbankergebnisse zu formatieren sind, können Sie nun in Schritt 5 entscheiden, wie die an den Datenbankergebnisbereich zurückgelieferten Datensätze anzuzeigen sind. Wenn Sie ein Tabellen- oder Listenformat auswählen, können Sie alle Datensätze zusammen anzeigen, oder Sie können diese in kleineren Gruppen mit Steuerelementen zur Navigation anzeigen. Wenn Sie eine große Datenbank haben oder eine lange Ergebnisliste erwarten, die an den Datenbankergebnisbereich zurückgegeben wird, sollten Sie in Erwägung ziehen, die Datensätze in kleineren Gruppen anzuzeigen, damit Sitebesucher leichter in den Informationen blättern können, ohne einen Bildlauf ausführen zu müssen.

  • Um Datensätze in einer Liste oder einer Tabelle auf einer Seite anzuzeigen, klicken Sie auf Alle Datensätze zusammen anzeigen.
  • Um Datensätze in kleinere Gruppen aufzuteilen, klicken Sie auf Datensätze in Gruppen unterteilen, und geben Sie dann im Feld die Anzahl der Datensätze ein, die in jeder Gruppen enthalten sein sollen. FrontPage fügt automatisch Navigationssteuerelemente hinzu, wenn die Seite angezeigt wird, damit die Sitebesucher die Möglichkeit haben, durch die Datensatzgruppen zu navigieren.

    • Anmerkung Diese Option steht nicht zur Verfügung, d. h. sie ist deaktiviert, wenn Sie in Schritt 4 des Assistenten die Option Liste- ein Datensatz pro Listenelement aktiviert haben.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Erstellen einer neuen Datenbankverbindung mithilfe einer benutzereigenen Definition

Um Informationen aus einer Datenbank oder die Eingabe für eine Datenbank anzuzeigen, verwendet FrontPage eine Datenbankverbindung. Die Datenbankverbindung nennt den Namen, Speicherort und den Typ der Datenbank, auf die Sie zugreifen möchten, zusammen mit anderen, ggf. erforderlichen Parametern.

Manche Datenbanktreiber für Datenbanksysteme im Netzwerk erfordern eine grosse Anzahl von Konfigurationsparametern. Ein Datenbank-Administrator kann in der ODBC-Systemsteuerung einen Datei-Datenquellennamen (Datei-DSN) erstellen, der alle diese Parameter auf dem Webserver enthält. Sie können dann den Datei-DSN in Ihr Web importieren und sich mit ihm verbinden, um eine neue Datenbankverbindung zu erstellen. Sie können sich auch mit einer UDL-Datei (Universal Data Link-Datei) verbinden.

Wenn ein gegebener Datenbanktreiber Parameter verlangt, die Sie mit FrontPage nicht einsetzen können, dann können Sie eine benutzerdefinierte Datenbankverbindung erstellen, um die Verbindungszeichenfolge zu ändern, die an den Datenbanktreiber übergeben wird. Wenn Sie eine benutzerdefinierte Datenbankverbindung verwenden, dann müssen Sie zwischen Lesezugriff und Schreibzugriff Authentifizierung unterscheiden (bei allen anderen Datenbankverbindungen ist die Lesezugriff und Schreibzugriff Authentifizierung gleich). Der Benutzername für den Schreibzugriff und das Kennwort werden von FrontPage im Dialogfeld Webeinstellungen auf der Registerkarte Datenbank, vom Datenbankergebnis-Assistent und der Formularbehandlungsroutine zum Spiechern in einer Datenbank abgefragt. Der Benutzername für den Lesezugriff und das Kennwort werden benötigt um eine Verbindung herzustellen, wenn eine Seite in einem Webbrowser angezeigt wird.

Wenn Sie eine benutzerdefinierte Datenbankverbindung verwenden, dann müssen der Benutzername für den Schreibzugriff und das Kennwort in der DSN oder UDL-Datei enthalten sein. Wenn Sie eine benutzerdefinierte Verbindungszeichenfolge verwenden, dann müssen der Benutzername für den Schreibzugriff und das Kennwort in der Verbindungszeichenfolge enthalten sein. Die Syntax der Verbindungszeichenfolge ist providerspezifisch; grundsätzlich gilt für die meisten ODBC-Verbindungen, dass Sie UID- und PWD-Attribute hinzufügen (z. B. UID=Benutzername; PWD=Kennwort).

    Wenn Sie den Datenbankergebnis-Assistenten starten, geben Sie die Datenbankverbindung an, die Sie verwenden möchten. Um mithilfe einer benutzereigenen Definition eine neue Verbindung zu erstellen, führen Sie folgende Schritte aus:

    1. Öffnen Sie in der Seitenansicht eine Seite, die einen bestehenden Datenbankergebnisbereich enthält oder erstellen Sie eine neue Seite, welche die Datenbankergebnisse aufnehmen soll, und rufen Sie dann den Datenbankergebnis-Assistenten auf:
      • Wenn Sie den Assistenten noch nicht ausgeführt haben, um einen Datenbankergebnisbereich auf der Seite zu erstellen, zeigen Sie im Menü Einfügen auf Datenbank, und klicken Sie dann auf Ergebnisse.
      • Wenn die Seite bereits einen Datenbankergebnisbereich enthält, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Datenbankergebnisbereich, und klicken Sie dann im Kontextmenü auf Eigenschaften: Datenbankergebnisse.
    2. Klicken Sie in Schritt 1 des Assistenten auf Neue Datenbankverbindung verwenden, und klicken Sie dann auf Erstellen.
    3. Klicken Sie auf Hinzufügen, und geben Sie dann im Feld Name einen Namen für die neue Datenbankverbindung ein.
    4. Klicken Sie auf Benutzereigene Definition, und wählen Sie dann einen Datei-DSN oder eine UDL-Datei aus, bzw. bearbeiten Sie eine Verbindungszeichenfolge:
      • Um einen Datei-DSN oder eine UDL-Datei im aktuellen Web auszuwählen, klicken Sie auf Durchsuchen. Geben Sie im Feld URL den Pfad zum Datei-DSN oder zur UDL-Datei ein, mit dem oder der Sie sich verbinden möchten, und klicken Sie dann auf OK. Oder navigieren Sie mithilfe des Feldes Suchen in und seiner Dateiliste zum gewünschten Datei-DSN oder zur gewünschten UDL-Datei, und doppelklicken Sie dann auf die Datei in der Liste.
      • Um eine Verbindungszeichenfolge zu bearbeiten, klicken Sie auf Erweitert. Geben Sie im Feld Verbindungszeichenfolge die entsprechende Zeichenfolge ein, die an den Datenbanktreiber, mit dem Sie sich verbinden möchten, zu übergeben ist. Klicken Sie auf OK.
    5. Klicken Sie auf OK, um das Dialogfeld Neue Datenbankverbindung zu schließen, und klicken Sie dann auf OK, um das Dialogfeld Webeinstellungen zu schließen.

    Tipps

    • Um für ein Web eine neue Datenbankverbindung zu erstellen, ohne den Datenbankergebnis-Assistenten aufzurufen, klicken Sie im Menü Extras auf Webeinstellungen, klicken Sie auf die Registerkarte Datenbank, und befolgen Sie dann dieses Verfahren ab Schritt 3.
    • Verwenden Sie keinen Datei-DSN, um sich mit einer Datenbankdatei im aktuellen Web zu verbinden; der Datei-DSN enthält Pfade, die für den Webserver nicht korrekt sind. Klicken Sie stattdessen unter Lage der Datenbank auf Datei oder Ordner im aktuellen Web.
    • Alle Timeouts oder Name/Wert-Parameter für die Datenbank müssen im Datei-DSN enthalten sein. Ist dies nicht der Fall, klicken Sie auf Erweitert, und geben Sie dann die entsprechende Information ein.
    • Der Datenbanktreiber, auf den durch den Datei-DSN oder die Verbindungszeichenfolge verwiesen wird, muss auf dem Webserver vorhanden sein, damit die Verbindung korrekt funktioniert.

    Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Formatieren der Datenbankergebnisse als Dropdownliste

Nachdem Sie in Schritt 3 des Datenbankergebnis-Assistenten die Feldliste bearbeitet oder Optionen festgelegt haben, können Sie in Schritt 4 des Assistenten auswählen, wie die Datenbankergebnisse auf der Seite angezeigt werden sollen. Formatieren Sie mithilfe dieses Verfahrens die Ergebnisse in einer Dropdownliste, in der jedes Element die Daten eines Feldes anzeigt, und der dazugehörende Wert aus einem anderen (oder demselben) Feld kommt.

  1. Klicken Sie in Schritt 4 des Datenbankergebnis-Assistenten im Feld Wählen Sie Formatierungsoptionen für die von der Abfrage zurückgelieferten Datensätze aus auf Liste - ein Datensatz pro Listenelement.
  2. Markieren Sie im Feld Werte aus diesem Feld anzeigen das Feld, das Sie zur Anzeige der Auswahlmöglichkeiten für den Sitebesucher verwenden möchten.

    3. Um zum Beispiel eine Liste der Nachnamen von Mitarbeitern anzuzeigen, würden Sie das Feld Nachname markieren.

  3. Markieren Sie im Feld Werte aus diesem Feld übermitteln das Feld, das Sie für die Werte verwenden möchten, die an den Webserver übermittelt werden sollen, wenn die Dropdownliste mit den Datenbankergebnissen innerhalb eines Formulars liegt. Sie können dasselbe Feld, das Sie bereits in Schritt 2 gewählt haben, oder ein anderes auswählen.

    4. Um zum Beispiel eine andere Seite anzuzeigen, die den gesamten Datensatz eines Mitarbeiters darstellt, können Sie, anstatt den Wert des Feldes Nachname zu senden (da mehr als ein Mitarbeiter mit demselben Nachnamen existieren könnte), den Wert des Feldes Personal-Nr aus dem entsprechenden Mitarbeiterdatensatz senden (da jeder Mitarbeiter eine eindeutige Personalnummer hat).

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Hinzufügen eines Suchformulars zu der Seite mit den Datenbankergebnissen

Wenn Sie Sitebesucher bestimmte Informationen in einem Datenbankergebnisbereich suchen und anzeigen lassen wollen, dann können Sie ein Suchformular zu der gleichen Seite hinzufügen, die auch den Datenbankergebnisbereich enthält. Wenn ein Sitebesucher die Felder das Suchformulars ausfüllt und auf Abschicken klickt, dann zeigt der Datenbankergebnisbereich nur die Datensätze an, die auf die Suchbegriffe zu treffent.

Ein Sitebesucher, der z. B. die Seite anzeigt, um die Durchwahl eines Angestellten in der Nordwinddatenbank nachzuschlagen, kann den Nachnamen des Angestellten (z. B Smith) im Feld Suchen nach eingeben. Wenn er auf Abschicken klickt, dann weist FrontPage die Datenbank an die Datensätze der Angestellten nach dem Wert für Nachname zu durchsuchen, der „Smith“ entspricht und zeigt nur die entsprechenden Datensätze im Datenbankergebnisbereich an.

  1. Klicken Sie in Schritt 3 des Datenbankergebnis-Assistenten auf Weitere Optionen, klicken Sie auf Kriterien und klicken Sie dann auf Hinzufügen.
  2. Wählen Sie im Feld Feldname aus, wonach Sie die Sitebesucher suchen lassen wollen und klicken Sie dann auf OK.

    3. Um z. B. die Sitebesucher die Datensätze nach allen Angestellten mit dem Nachnamen „Smith“ durchsuchen und anzeigen zu lassen, klicken Sie auf Nachname und klicken Sie dann auf OK.

  3. Um ein weiteres Feld zum verfeinern der Suche zu dem Suchformular hinzuzufügen (z. B. um zunächst nach dem Feld Nachnameund dann nach dem Feld Vornamezu suchen), klicken Sie auf Hinzufügen und wiederholen Sie dann Schritt 2 dieser Anweisung. Wenn alle Felder, die Sie zu dem Suchformular hinzufügen wollen, in der Liste Kriterien angezeigt werden, klicken Sie zweimal auf OK und kehren Sie zu Schritt 3 des Assistenten zurück.
  4. Klicken Sie zweimal auf Weiter und markieren Sie dann in Schritt 5 des Assistenten des Kontrolkästchen Suchformular hinzufügen.

Hinzufügen von Informationen aus einer Datenbank zu einer Seite unter Verwendung des Datenbankergebnis-Assistenten


Festlegen einer benutzerdefinierten Farbe

Eine benutzerdefinierte Farbe ist eine Farbe, die Sie auf eine der folgenden Arten festlegen:

  • Auswählen einer Farbe aus einer browsersicheren Palette.
  • Festlegen einer Farbe durch Eingeben eines Hexadezimalwertes.
  • Auswählen einer Farbe auf dem Bildschirm, wie z. B. einer Farbe aus einem Bild auf einer geöffneten Seite.
  • Auswählen eines Bildschirmbereichs und Erstellen eines Farbmittelwerts aus diesem Bereich.
  • Eingeben einer Wertekombination für Farbe-Sättigung-Helligkeit oder Rot-Grün-Blau.
  • Auswählen einer Farbe aus einer Farbmatrix.

Die benutzerdefinierten Farben, die Sie in der aktuellen Sitzung von Microsoft FrontPage festlegen, stehen auch in zukünftigen Sitzungen zur Verfügung.

Was möchten Sie tun?

Weitere Informationen zu Farben erhalten

Eine benutzerdefinierte Farbe für ein Seitenelement festlegen

Eine benutzerdefinierte Farbe für ein Designelement festlegen

Eine benutzerdefinierte Farbe für eine Formatvorlage festlegen


Erstellen eines Formulars

Erstellen Sie ein Formular zum Sammeln von Informationen von Sitebesuchern, fordern Sie diese auf, sich an einer geschützten Website anzumelden oder lassen Sie sie Ihre Website durchsuchen.

Was möchten Sie tun?

Weitere Informationen zu Formularen erhalten

Ein Formular erstellen

Ein Formular unter Verwendung eines Assistenten erstellen

Ein Suchformular erstellen

Ein Formular für die Benutzerregistrierung erstellen


Hinzufügen von Feldern zu einem Formular

Es gibt unterschiedliche Möglichkeiten, Felder zu einem Formular zum Sammeln von Informationen hinzuzufügen.

Was möchten Sie tun?

Weitere Informationen zu Formularen erhalten

Ein einzeiliges Textfeld zu einem Formular hinzufügen

Ein Textfeld mit Bildlauf zu einem Formular hinzufügen

Ein Kontrollkästchen zu einem Formular hinzufügen

Ein Optionsfeld zu einem Formular hinzufügen

Ein Dropdownmenü zu einem Formular hinzufügen

Eine Schaltfläche Zurücksetzen zu einem Formular hinzufügen

Eine Schaltfläche Abschicken zu einem Formular hinzufügen

Ein Bild als Schaltfläche Abschicken zu einem Formular hinzufügen

Eine benutzerdefinierte Schaltfläche zu einem Formular hinzufügen

Ein verborgenes Feld zu einem Formular hinzufügen

Ein Kennwortfeld zu einem Formular hinzufügen


Festlegen von Regeln für Daten in Feldern

Für bestimmte Formularfelder können Sie Dateneingaberegeln (Gültigkeitsprüfung) festlegen. Verwenden Sie diese Regeln, wenn Sie festlegen möchten, dass der Besucher ein bestimmtes Feld ausfüllen muss, oder wenn in ein Feld Daten eines bestimmten Typs eingegeben werden sollen (z. B. Zahlen und Bindestriche für Kreditkartennummern).

Was möchten Sie tun?

Weitere Informationen zu Formularen erhalten

Dateneingaberegeln für ein Textfeld festlegen

Dateneingaberegeln für ein Optionsfeld festlegen

Dateneingaberegeln für ein Dropdownmenü festlegen


Sammeln der Ergebnisse aus einem Formular

Sie können zum Verarbeiten der Ergebnisse aus Ihren Formularen eine Formularbehandlungsroutine oder ein benutzerdefiniertes Skript verwenden.

Anmerkung Wenn Sie anstatt eines benutzerdefinierten Skripts eine der Formularbehandlungsroutinen verwenden, müssen die Microsoft FrontPage-Servererweiterungen auf dem Server installiert sein, auf dem sich Ihre Website befindet.

Was möchten Sie tun?

Weitere Informationen zu Formularen erhalten

Die Informationen festlegen, die aus einem Formular gesammelt werden sollen

Die Ergebnisse in einer Datei speichern

Formularergebnisse in einer E-Mail-Nachricht senden

Formularergebnisse in einer vorhandenen Datenbank speichern

Formularergebnisse in einer neuen Microsoft Access-Datenbank speichern

Formularergebnisse unter Verwendung einer benutzerdefinierten Formularbehandlungsroutine speichern

Formularergebnisse anzeigen


Arbeiten mit Frames und Framesseiten

Eine Framesseite ist eine spezielle Art von HTML-Seite, mit der das Browserfenster in unterschiedliche Bereiche, so genannte Frames, aufgeteilt wird, von denen jeder eine andere Seite anzeigen kann. Beim Klicken auf einen Hyperlink auf einer Seite, die in einem Frame angezeigt wird, wird im Normalfall die Seite, auf die dieser Hyperlink verweist, in einem anderen Frame angezeigt.

Was möchten Sie tun?

Mehr über Frames und Framesseiten erfahren

Eine Framesseite erstellen

Eine Framesseite öffnen

Eine Framesseite speichern

Die Startseite für eine Framesseite festlegen

Einen Hyperlink zu einer Seite erstellen, die dann in einem anderen Frame angezeigt wird

Die Seite bearbeiten, die in einem Frame in einem anderen Fenster angezeigt wird

Zwischen den Frames in einer Framesseite wechseln

Steuern, wie Frames in einem Browser angezeigt werden

Die Größe eines Frames ändern

Die Frameränder festlegen

Den Abstand zwischen Frames festlegen

Die Framerahmen anzeigen oder ausblenden

Einen Frame teilen


Anzeigen einer Seite in einem Frame

Wenn eine Framesseite in einem frameskompatiblen Browser gedownloaded wird, liest der Browser die Frame-Informationen und zeigt in jedem Frame eine Startseite an. Wenn der Sitebesucher auf einer Seite in einem Frame auf einen Hyperlink klickt, wird die Seite, auf die dieser Hyperlink verweist, im Normalfall in einem anderen Frame auf der gleichen Framesseite angezeigt.

Was möchten Sie tun?

Die Startseite festlegen, die in einem Frame angezeigt wird

Einen Hyperlink zu einer Seite erstellen, die dann in einem anderen Frame angezeigt wird


Ändern der HTML-Formatierung

Sie können ändern, wie Microsoft FrontPage den HTML-Code einer Seite formatiert und diesen HTML-Code auf der Registerkarte HTML in der Seitenansicht anzeigt. Beispielsweise können Sie die Namen von HTML-Tags in Großbuchstaben und die HTML-Attribute in Kleinbuchstaben anzeigen, um diese besser voneinander unterscheiden zu können.

Sie können darüber hinaus auch ändern, wie FrontPage bestimmte HTML-Tags einer Seite formatiert und diese Tags auf der Registerkarte HTML in der Seitenansicht anzeigt. Beispielsweise können Sie FrontPage anweisen, keine Endtags (</p>) einzufügen oder den Inhalt einzurücken und einen Zeilenumbruch vor <h1>-Tags einzufügen.

Was möchten Sie tun?

Die HTML-Formatierung ändern

Die HTML-Formatierung bestimmter Tags ändern


Bearbeiten von HTML

Wenn Sie Webseiten nicht im WYSIWYG-Modus (WYSIWYG = What You See Is What You Get = Was Sie sehen, wird angezeigt) auf der Registerkarte Normal in der Seitenansicht erstellen möchten, können Sie den HTML-Code auch direkt auf der Registerkarte HTML bearbeiten.

Was möchten Sie tun?

Den HTML-Code einer Seite bearbeiten

Den HTML-Code einer Framesseite bearbeiten

Den HTML-Code einer Seite bearbeiten, die in einem Frame angezeigt wird


Hinzufügen einer Grafik zu einer Seite

Was möchten Sie tun?

Mehr über Grafiken erfahren

Ein Bild aus einer Datei hinzufügen

Ein Bild aus einem Web hinzufügen

Ein Bild von einer Site im World Wide Web hinzufügen

Einen Videoclip hinzufügen

Ein ClipArt-Objekt hinzufügen

Grafiken in ein Web importieren


Erstellen einer Imagemap

Sie können auf einer Seite eine Imagemap, also eine Grafik erstellen, auf der sich ein oder mehrere Hotspots (Hyperlinkbereiche) befinden. Wenn Sie die gesamte Grafik als Hotspot definieren möchten, legen Sie einen Standardhyperlink für die Grafik fest.

Was möchten Sie tun?

Einen Standardhyperlink für eine Grafik festlegen

Einer Grafik einen Hotspot hinzufügen

Einer Grafik einen Texthotspot hinzufügen

Einen Hotspot auf einer Grafik bearbeiten, verschieben, löschen oder dessen Größe ändern

Die Hotspots auf einer Grafik markieren


Erstellen eines Hyperlinks

Was möchten Sie tun?

Mehr über Hyperlinks erfahren

Einen Hyperlink zu einer Seite oder einer Datei in einem Web erstellen

Einen Hyperlink zu einer neuen Seite erstellen

Einen Hyperlink zu einer Seite oder einer Datei im World Wide Web erstellen

Einen Hyperlink zu einer Seite oder einer Datei in einem Dateisystem erstellen

Einen Hyperlink erstellen, mit dem eine E-Mail gesendet werden kann

Einen Hyperlink zu einem Office-Dokument erstellen

Einen Hyperlink zu einer Textmarke erstellen

Einen Standardhyperlink für eine Grafik festlegen

Einer Grafik einen Hotspot hinzufügen

Einer Grafik einen Texthotspot hinzufügen


Erstellen einer Liste

Was möchten Sie tun?

Mehr über Listen erfahren

Erstellen einer Aufzählungsliste

Erstellen einer nummerierten Liste

Erstellen einer Definitionsliste

Erstellen einer Gliederung

Erstellen einer ausblendbaren Liste

Erstellen einer mehrstufigen Liste

Erstellen benutzerdefinierter Aufzählungszeichen


Ändern einer Navigationsleiste

Was möchten Sie tun?

Herausnehmen einer Seite aus den Navigationsleisten

Ändern der Seitenbeschriftungen in einer Navigationsleiste

Ändern der Ausrichtung einer Navigationsleiste

Anzeigen von Texthyperlinks oder Schaltflächen in einer Navigationsleiste

Ändern, welche Seiten in einer Navigationsleiste angezeigt werden

Hinzufügen eines externen Hyperlinks zu einer Navigationsleiste

Ändern des Textformats einer Navigationsleiste

Festlegen der Farben für Hyperlinks

Löschen einer Navigationsleiste von einer Seite


Festlegen von Berechtigungen für ein Web

Was möchten Sie tun?

Mehr über Sicherheit erfahren

Hinzufügen eines Benutzers zu einem Web und Festlegen von Berechtigungen

Hinzufügen eine Benutzergruppe zu einem Web und Festlegen von Berechtigungen

Ändern von Berechtigungen für einen Benutzer

Ändern von Berechtigungen für eine Benutzergruppe

Entfernen eines Benutzers oder einer Benutzergruppe aus einem Web


Veröffentlichen eines Webs

Wenn Sie ein Web auf einem Webserver, auf dem die Microsoft FrontPage Servererweiterungen installiert sind, veröffentlichen, können Sie dies über HTTP (HyperText Transfer Protocol) tun. Anderfalls müssen Sie Ihr Web über FTP (File Transfer Protocol) veröffentlichen. Wenn Sie beispielsweise beim Versuch, über HTTP zu veröffentlichen, eine Meldung erhalten, die besagt, dass Ihr Webserver nicht für FrontPage eingerichtet ist, müssen Sie die Veröffentlichung über FTP vornehmen.

Sie können ein Web auch an einer Stelle in Ihrem lokalen Dateisystem veröffentlichen.

Was möchten Sie tun?

Mehr über das Veröffentlichen erfahren

Veröffentlichen eines Webs mittels HTTP

Veröffentlichen eines Webs mittels FTP

Veröffentlichen eines Webs an einem Ort des lokalen Dateisystems

Hinzufügen oder Ändern eines FTP-Speicherorts


Erstellen einer Tabelle

Sie können eine Tabelle erstellen, um entweder Informationen anzuzeigen oder Text und Grafiken auf einer Seite anzuordnen.

Was möchten Sie tun?

Mehr über das Erstellen von Tabellen erfahren

Erstellen einer Tabelle und Festlegen ihrer Eigenschaften

Erstellen einer einfachen Tabelle

Erstellen einer Tabelle durch Zeichnen

Umwandeln von Text in eine Tabelle


Anpassen einer Tabelle

Was möchten Sie tun?

Mehr über das Anpassen von Tabellen erfahren

Festlegen des Tabellenlayouts

Festlegen des Zellenlayouts

Arbeiten mit Zeilen, Spalten und Zellen

Einfügen einer Tabellenbeschriftung

Formatieren von Kopfzeilen einer Tabelle

Festlegen der Farbe eines Tabellenrahmens

Festlegen der Hintergrundfarbe einer Tabelle

Anzeigen eines Hintergrundbildes in einer Tabelle


Arbeiten mit Zeilen, Spalten und Zellen

Tabellen können durch Einfügen und Löschen von Zellen, Zeilen und Spalten geändert werden. Sie können auch die Größe von Zellen, Zeilen und Spalten ändern. Sie können einfach mit der Maus eine ihrer Rahmenlinien ziehen, die Abstände gleichmäßig verteilen und die Zellengröße entweder in Pixel oder als Prozentsatz der Tabellengröße definieren. Sie können eine Zelle auch in mehrere Zellen aufteilen und zusammenliegende Zellen verbinden, um die Gesamtgröße einer Tabelle zu kontrollieren.

Was möchten Sie tun?

Mehr über das Arbeiten mit Zeilen und Spalten erfahren

Hinzufügen einer Zelle, Zeile oder Spalte

Verändern der Größe einer Zelle, Zeile oder Spalte

Verändern der Größe einer Tabelle

Gleichmäßiges Verteilen von Zeilen und Spalten

Zellen teilen

Zellen verbinden

Festlegen der Spannweite von Zellen


Anwenden eines Designs

Ein Design kann auf ausgewählte Webseiten, auf die aktuelle Seite der Seitenansicht oder, um das Standarddesign für ein Web festzulegen, auf ein ganzes Web angewendet werden.

Was möchten Sie tun?

Mehr über Designs erfahren

Anwenden eines Designs auf die aktuelle Seite

Anwenden eines Designs auf ausgewählte Seiten

Anwenden eines Designs auf ein Web


Anpassen eines Designs

Was möchten Sie tun?

Mehr über Designs erfahren

Ändern der in einem Design verwendeten Farben

Ändern der in einem Design verwendeten Grafiken

Ändern der in einem Design verwendeten Schriftarten

Erstellen eines neuen Designs


Erstellen einer Sitemap

Viele Websites verwenden Sitemaps, um es den Sitebesuchern leichter zu machen, eine gewünschte Seite zu finden. Für ein persönliches Web oder ein anderes, kleines Web kann eine Sitemap einfach aus einer Liste von Hyperlinks zu allen Seiten des Webs bestehen. Sie können diese Art von Sitemap mithilfe der Inhaltsverzeichnis-Komponente erstellen.

Beim Präsenzweb einer Firma oder einem anderen großen Web enthält eine Sitemap in der Regel eine Liste von Hyperlinks auf Seiten in verschiedenen Teilwebs, Kategorien oder anderen logischen Gruppen, die unter logischen Stichworten angeordnet sind. Wenn Sie z. B. Anlagen verkaufen, dann könnte Ihre Sitemap Spalten mit Hyperlinks auf kleine Anlagen, große Anlagen und den Kundendienst enthalten. Sie können diese Art von Sitemap mithilfe von Kategorien erstellen.

Was möchten Sie tun?

Erstellen eines Inhaltsverzeichnisses für ein Web

Erstellen einer Sitemap mithilfe von Kategorien


Zuweisen von Arbeiten

Sie können Ihre Arbeitsabläufe effektiver verwalten, indem Sie Dateien und Aufgaben einzelnen Personen oder Arbeitsgruppen zuweisen, Seiten kategorisieren, den Aufgabenstatus überwachen und aktualisieren sowie den Prüfstatus von Dateien angeben, die zur Veröffentlichung in Ihrem in Betrieb befindlichen Web freizugeben sind.

Was möchten Sie tun?

Mehr über die Verwaltung eines Webs erfahren

Zuweisen einer Aufgabe

Zuweisen einer Datei

Hinzufügen eines Kommentars zur Datei-Info

Kategorisieren einer Datei

Prioritätsvergabe an Aufgaben

Ausführen einer Aufgabe

Markieren einer Aufgabe als erledigt

Festlegen des Prüfstatus einer Datei

Sortieren der Aufgabenliste


Erstellen von Berichten über ein Web

Die Berichte von Microsoft FrontPage erlauben die Analyse und Übersicht über ein Web auf vielfältige Weise, damit Sie Informationen erhalten, die Sie benötigen.

Was möchten Sie tun?

Anzeigen einer Siteübersicht

Sortieren von Dateien nach Datum

Berechnen der Größe eines Webs

Zählen von Bildern

Berechnen der Größe aller Bilder

Auflisten von langsamen Downloadseiten

Auflisten unterbrochener Hyperlinks

Auflisten unverknüpfter Dateien

Auflisten von Fehlern in Komponenten

Auflisten von Dateien nach Zuweisung

Auflisten von Dateien nach Kategorie

Auflisten von Dateien nach Checkoutstatus

Auflisten von Dateien nach Veröffentlichungsstatus

Auflisten von Dateien nach Prüfstatus


Formatieren von Text

Was möchten Sie tun?

Mehr über das Formatieren von Text erfahren

Festlegen der Schriftart für einen Text

Formatieren von Text in Fettschrift

Unterstreichen von Text

Höher- oder Tieferstellen von Text

Vergrößern oder Verkleinern des Abstands zwischen Zeichen

Hinzufügen von Rahmen um einen Text

Hinzufügen von Schattierung zu einem Text

Entfernen einer Textformatierung


Hinzufügen einer Seite zu einem Web

Sie können Seiten zu einem Web auf vielfältige Weise hinzufügen. Sie können neue Seiten in mehreren Ansichten in Microsoft FrontPage erstellen. Sie können auch Dateien und Ordner in ein Web importieren oder kopieren.

Was möchten Sie tun?

Erstellen einer neuen Seite

Erstellen eines Hyperlinks auf eine neue Seite

Festlegen der Anfangsseite, die in einem Frame angezeigt wird

Erstellen einer neuen Seite in der Ordnerliste

Festlegen einer Navigationsstruktur für ein Web

Importieren einer Datei oder eines Ordners