OLAP-Cube-Assistent: Übersicht

Mit Hilfe des Assistenten werden Sie durch den Prozess der Organisation der in einer Abfrage ausgewählten externen Daten in einem OLAP-Cube geführt, d. h. eine Methode der Organisation zusammengefasster Daten für eine Analyse. Der Assistent leistet Ihnen Hilfe bei der Vorbereitung der Daten für ihre Verwendung in einem Datenbankbericht, beispielsweise einem PivotTable- oder PivotChart-Bericht oder einer PivotTable-Liste in einer Webseite.

Der Assistent wurde für Benutzer konzipiert, die sich mit Datenbankverwaltung und Erstellung von Datenbankberichten befassen. Wenn Sie mit der Datenbankverwaltung nicht vertraut sind, bzw. wenn Datenbankberichte für Sie etwas Neues darstellen und Sie dabei Hilfe benötigen, wenden Sie sich an die Person, die mit der Verwaltung der Netzwerkdatenbank betraut ist, mit der Sie zusammenarbeiten möchten.

Wie werden Daten vom Assistenten organisiert?

Zusammenfassung der einzelnen Assistenten-Schritte

Bevor Sie den Assistenten starten

Weitere Informationen

Wie werden Daten vom Assistenten organisiert?

Am Ende Ihrer Assistenten-Sitzung erhalten Sie einen Cube, anhand dessen Sie Ihre Berichte verfassen können. Falls Sie nach dem Erstellen und Anzeigen der Berichte den Cube anders organisieren oder darin andere Daten zusammenfassen möchten, können Sie zurück zum Assistenten wechseln, um die Änderungen vorzunehmen..

Was ist OLAP? On-Line Analytical Processing (OLAP) stellt eine Methode der Datenorganisation dar, die an die Art der Benutzeranalyse - in hierarchischen Kategorien und mit Hilfe vorberechneter Zusammenfassungswerte - angepasst ist. Mit dem OLAP-Cube werden für Ihren Bericht anstatt einer umfangreichen Anzahl individueller Daten lediglich die zusammengefassten Ergebnisse zur Verfügung gestellt, so dass Sie größere Datenmengen analysieren können, als es von Ihren Systemressourcen eigentlich möglich wäre. Beim Erstellen eines OLAP-Cubes in einer relationalen Datenbank führen Sie die ersten Schritte aus, die im Erstellen eines Berichtes bestehen, den Sie oder andere Benutzer verwenden können.

Daten- und Dimensionsfelder Mit Hilfe des Assistenten können Sie den Feldern einer Datensatzreihe eine hierarchische Struktur zuordnen und die zu berechnenden Zusammenfassungswerte definieren.

Der auf diese Weise erstellte Cube enthält zwei Arten von Daten: zusammengefasste Werte und entsprechend zugeordnete beschreibende Angaben. Die zusammenzufassenden Werte, wie beispielsweise die Anzahl verkaufter Artikel, werden Datenfelder genannt. Die beschreibenden Angaben, wie beispielsweise Datum und Ort des Verkaufsvorgangs, sind in Detailebenen mit der Bezeichnung Dimensionen organisiert.

Beim Organisieren der Felder können Sie dieselben Kategorien verwenden, die Sie oder Ihre Benutzer bei der Datenanalyse in Berichten verwenden. Die Verwendung der Daten- und der Dimensionen ermöglicht eine einfache Darstellung sowohl der zusammenfassenden Ebene, wie beispielsweise der Gesamtverkaufszahlen in einem Land oder einem Bezirk als auch der Detailebene, wie Angaben zu Filialen mit besonders hohen oder niedrigen Verkaufszahlen.

Zurück zum Anfang

Zusammenfassung der einzelnen Assistenten-Schritte

Nachfolgend finden Sie eine kurze Erklärung zur Verwendung des Assistenten. Detailliertere Anweisungen finden Sie im Abschnitt Weitere Informationen weiter unten.

Schritt 1: Definieren der Datenfelder Im ersten Schritt legen Sie die als Datenfelder zu verwendenden Felder fest, wählen eine Zusammenfassungsfunktion zur Berechnung der einzelnen Feldwerte und eine Bezeichnung der Felder aus.

Schritt 2: Definieren der Dimension und der einzelnen Ebenen Im zweiten Schritt organisieren Sie die verbleibenden Felder nach Daten- und Dimensionen und ordnen beiden Elementen Bezeichnungen zu.

Schritt 3: Wahl des Cube-Typs Die Verfügbarkeit des dritten Schrittes ist davon abhängig, welches Programm Sie für den Datenzugriff und die Ausführung des Assistenten verwenden. In diesem dritten Schritt entscheiden Sie, ob Sie den Cube im Arbeitsspeicher erstellen oder als Cube-Datei speichern möchten. Ist dieser Schritt nicht verfügbar, wenden Sie sich an die Hilfe des für die Ausführung des Assistenten verwendeten Programms, um festzustellen, welcher Cube-Typ erstellt wird.

Ändern eines vorhandenen Cubes Nach dem Beenden der Assistentenfunktion können Sie alle gewählten Optionen ändern. Sie können Felder hinzufügen oder entfernen, die Art der Datenfeldzusammenfassung und die Organisation der Dimension ändern. Weitere Informationen über das Ändern eines vorhandenen Cubes finden Sie in der Hilfe des für den Datenzugriff verwendeten Programms, das Sie mit dem Assistenten verwenden.

Zurück zum Anfang

Bevor Sie den Assistenten starten

Bevor Sie den Cube erstellen, sollten Sie zuerst überlegen, in welchen Feldern der gegebenen Daten die zusammenzufassenden Werte enthalten sind (diese Felder werden als Datenfelder verwendet) und in welchen Feldern die beschreibenden Daten enthalten sind (diese Felder werden als Dimension verwendet).

Welche Felder sollten als Datenfelder verwendet werden? Die Datenfelder, in denen die zu berechnenden oder zu addierenden Werte enthalten sind, bilden den Hauptbestandteil der anhand des Cubes erstellten Berichte. Sind beispielsweise in einer Vertriebsdatenbank Felder enthalten, in denen die dem jeweiligen Verkaufsvorgang zugeordneten Umsatzzahlen und Lagerbestände aufgeführt sind, können Sie für jedes Produkt Berichte erstellen, in denen Gesamtverkaufszahlen und Inventarebenen (Datenfelder) sowie die Verkaufsgebiete (Dimension) dargestellt werden.

Der Cube kann die Daten nach vier Methoden unter Verwendung der folgenden Zusammenfassungsfunktionen zusammenfassen: Summe, Anzahl, Minimum und Maximum.

Wenn Sie ein Feld nach mehreren Methoden zusammenfassen möchten, müssen Sie das Feld für jede gewünschte Zusammenfassungsmethode Ihrer Abfrage oder der Quelldatenauswahl hinzufügen. Wenn Sie beispielsweise für das Feld Vertrieb die Verkaufsumsatzzahlen addieren (Summe) und die Anzahl der Verkaufsvorgänge zusammenrechnen (Anzahl) möchten, müssen Sie das Vertriebsfeld zweimal hinzufügen. Möglicherweise müssen Sie den Assistenten beenden und weitere Datenfelder hinzufügen, bevor Sie fortfahren können.

Welche Felder sollten als Dimensionsfelder verwendet werden? Überlegen Sie im Voraus, anhand welcher Detailebenen Ihre Informationen im Bericht angeordnet werden können. Beschreibende Felder, die hierarchisch nach Kategorien gegliedert werden können, bilden zusammen eine Dimension. Beispielsweise kann eine Datenbank separate Felder aufweisen, in denen die Länder, Gebiete und Städte aufgeführt werden, in denen die Verkaufsvorgänge getätigt wurden. Mit Hilfe einer Dimension können diese geographischen Angaben wie folgt in aufsteigender Detailreihenfolge angeordnet werden:

Ebenen eines geographischen Dimensionsfeldes

Ebenen eines geographischen Dimensionsfeldes

Enthalten Ihre Daten Datums- oder Zeitfelder, erstellt der Assistent für diese Felder automatisch ein Dimensionsfeld, wobei die Daten nach den Kategorien Jahr, Halbjahr, Quartal, Monat, Woche und Tag oder Stunde, Minute und Sekunde angeordnet werden.

Felder, die einzelne oder vertrauliche Angaben enthalten und keiner hierarchischen Gliederung unterliegen - wie beispielsweise ein Feld mit Angaben zum Steuerstatus eines Produktes - können als Dimension mit einer einzigen Ebene definiert werden.

Effizientes Festlegen der Quelldaten Alle Felder in einem Cube müssen entweder als Quellenfelder oder als Dimension definiert sein und alle Felder Ihrer Daten müssen einem der beiden Feldtypen zugeordnet sein. Um die Abfrage bzw. Quelldatenauswahl effizienter zu gestalten und die Aktualisierung der auf ihrer Grundlage erstellten Berichte zu beschleunigen, sollten Sie nur diejenigen Felder aufnehmen, die Sie in dem Cube verwenden möchten. Bevor Sie mit dem Assistenten fortfahren, sollten Sie sich vergewissern, dass Ihre Abfrage bzw. Quelldatenauswahl alle gewünschten Daten und nur diese enthält.

Bestimmen des benötigten Cube-Typs Ob Sie mit Hilfe des Assistenten den zu erstellenden Cube-Typ festlegen können, hängt davon ab, welches Programm Sie beim Erstellen Ihrer Abfrage bzw. Auswahl der Quelldaten verwendet haben. Angaben darüber, ob Ihr Assistent diesen Schritt enthält oder ob die Auswahl automatisch erfolgt, finden Sie in der Hilfe des Programms, in dem Sie den Assistenten ausführen.

Ist diese Funktion verfügbar, können Sie zwischen drei Optionen wählen, die in unterschiedlicher Weise die Ausführungsgeschwindigkeit mit Arbeits- und Plattenspeicherplatz kombinieren.

  • Sie können einen temporären, dem aktuell verwendeten Bericht zugeordneten Cube im Arbeitsspeicher erstellen und aus der ursprünglichen Datenbank alle Daten gleichzeitig abrufen.

  • Sie können denselben Typ eines temporären Cubes wie in der ersten Option erstellen, die Daten aber erst bei Anforderung im Bericht abrufen.

  • Sie können eine Cube-Datei erstellen, die für andere Berichte wiederverwendet werden kann.

Möglicherweise müssen Sie erst mit den verschiedenen Optionen experimentieren, um die optimale Kombination zwischen Geschwindigkeit und Arbeits- bzw. Festplattenspeicherplatz für Ihren Bericht herauszufinden. Die optimale Kombination ist vom Umfang der im Cube aufzunehmenden Daten und dem Komplexitätsgrad des zu erstellenden Berichts abhängig.

Weitere Informationen zu diesen Optionen und ihren jeweiligen Vor- und Nachteilen finden Sie in der Hilfe für Assistenten-Schritt 3.

Zurück zum Anfang

Weitere Informationen

Die folgenden Hilfethemen enthalten detaillierte Informationen zur Verwendung der jeweiligen Assistenten-Schritte.

Schritt 1: Definieren der Datenfelder.

Schritt 2: Definieren der Dimension und der einzelnen Ebenen.

Schritt 3: Auswählen des Cube-Typs. (Die Verfügbarkeit dieses Schrittes steht in Abhängigkeit von dem zur Ausführung des Assistenten verwendeten Programm.)

Zurück zum Anfang


OLAP-Cube-Assistent: Schritt 1

In diesem Schritt bestimmen Sie die Felder Ihrer Quelldaten, die Sie als Datenfelder verwenden möchten. Datenfelder enthalten Werte, die zusammengefasst werden sollen, wie beispielsweise Verkaufszahlen, die addiert werden sollen. Bestimmen Sie mindestens ein Feld als Datenfeld.

Der Assistent bestimmt, in welchen Feldern gesuchte Daten enthalten sein können und schlägt sie als Datenfelder vor. Die vorgeschlagenen Felder werden markiert im oberen Bereich der Liste angezeigt. Sie können überprüfen, ob die Vorschläge des Assistenten richtig sind und eventuelle Änderungen vornehmen.

Bei diesem Schritt müssen Sie mindestens ein Feld unmarkiert lassen. Die Felder ohne Markierung stehen Ihnen als Dimension zur Verfügung, d. h. Felder, die beschreibende Daten und Angaben enthalten, die als Kategorien und Aufzählungen in Ihrem Bericht fungieren. Die Auswahl und Organisation der Dimensionsfelder bestimmen Sie im nächsten Schritt.

So führen Sie diesen Schritt durch:

  1. Aktivieren Sie die Kontrollkästchen für eventuelle zusätzliche Felder, die Sie als Datenfelder verwenden möchten, und deaktivieren Sie die Kontrollkästchen für die Felder, die Sie nicht verwenden möchten. Sie müssen mindestens ein Feld auswählen.

  2. Wenn Sie eine andere als die vom Assistenten vorgeschlagene Zusammenfassungsfunktion wählen möchten, klicken Sie zuerst in der Spalte Zusammenfassen mit auf die vorgeschlagene und anschließend auf die gewünschte Funktion. Die verfügbaren Zusammenfassungsfunktionen heißen Summe, Anzahl, Minimum (gibt den kleinsten Wert aus den zusammengefassten Daten zurück) und Maximum (gibt den größten Wert aus den zusammengefassten Daten zurück).

    Um ein Feld mit Hilfe von mehreren Zusammenfassungsfunktionen zusammenzufassen, muss Ihre Abfrage oder Quelldatenauswahl für jede gewünschte Zusammenfassungsfunktion eine Feldinstanz enthalten. Wenn Sie weitere Feldinstanzen hinzufügen möchten, klicken Sie zunächst auf Abbrechen, um den Assistenten zu beenden, fügen Sie die Felder anschließend Ihrer Abfrage bzw. Auswahl hinzu, und starten Sie den Assistenten erneut.

  3. Um einen vom Assistenten vorgeschlagenen Feldnamen zu ändern, klicken Sie auf den Namen in der Spalte Datenfeldname, und geben Sie den neuen Namen ein.

    Die von Ihnen im Assistenten zugewiesenen Feldnamen werden in den mit Hilfe des Cubes erstellten Berichten eingeblendet. Die Verfügbarkeit der Namensänderungsoption in den Berichten ist vom zu erstellenden Berichttyp abhängig.

Weitere Informationen

Übersicht zum OLAP-Cube-Assistenten


OLAP-Cube-Assistent: Schritt 2

In diesem Schritt gruppieren Sie die beschreibenden Daten in Dimensionen. Jede Dimension wird als ein Feld in den anhand des Cubes erstellten Berichten dargestellt. Durch die Anordnung der Felder nach Detailebenen ermöglichen Sie dem Benutzer, eine bestimmte Detailansicht auszuwählen, beginnend mit der groben Zusammenfassung und fortschreitend zu mehr Details oder umgekehrt.

Sie müssen für den Cube mindestens ein Dimensionsfeld definieren. Felder, die einzelne Angaben enthalten und keiner hierarchischen Gliederung unterliegen - wie beispielsweise ein Feld mit Angaben zum Steuerstatus eines Produkts - können Sie als Dimensionsfeld mit einer Ebene definieren. Der Cube wird Ihnen jedoch nützlicher bei Erstellung von Berichten sein, wenn Sie einige Felder in mehreren Ebenen anordnen. Beispielsweise können Sie drei Felder in einem Dimensionsfeld "Produktion" mit drei Ebenen anordnen: Produktabteilung, Produktgruppe innerhalb der Abteilung und das individuelle Produkt.

Wenn Sie Datums- oder Zeitfelder als Dimensionsfelder verwenden, erstellt der Assistent automatisch die Ebenen für dieses Dimensionsfeld. Anschließend können Sie die in den Berichten verfügbaren Ebenen auswählen. Beispielsweise können Sie Wochen, Quartale und Jahre oder Wochen, Monate und Jahre auswählen.

Um diesen Schritt durchzuführen, gehen Sie folgendermaßen vor:

  1. Ziehen Sie alle Felder, die zu Dimensionsfelder werden sollen aus der Liste Quellenfelder in den Bereich mit der Überschrift Felder hier ablegen, um eine Dimension zu erstellen in die Liste Dimensionen. Sie müssen mindestens eine Dimension erstellen.

    Sie können ein Feld nur einmal aufnehmen. Um dasselbe Feld in mehrere Dimensionen zu verwenden, muss Ihre Abfrage oder Quelldatenauswahl für jede Dimension, in dem sie verwendet werden soll, eine Feldinstanz enthalten. Wenn Sie weitere Feldinstanzen hinzufügen möchten, klicken Sie zunächst auf Abbrechen, um den Assistenten zu beenden, fügen Sie die Felder anschließend Ihrer Abfrage bzw. Auswahl hinzu, und starten Sie den Assistenten erneut.

  2. Um eine Ebene innerhalb einer Dimension zu erstellen, ziehen Sie ein Feld aus der Liste Quellenfelder auf eine vorhandene Dimension oder in eine Unterebene in der Liste Dimensionen, wie im folgenden Beispiel.

    Beispiel für Ziehen eines Feldes in eine Ebene

    Um eine Ebene "Stadt" unter der Ebene "Gebiet" zu erstellen, ziehen Sie das Feld "Stadt" auf das Feld "Gebiet".

    Klicken Sie auf die Schaltfläche Plus oder Minus , um die Ebenen ein- und auszublenden.

    Felder, die detailierter sind, sollten auf unteren Ebenen angeordnet sein. Um ein Feld von einer niedrigeren auf eine höhere Ebene zu verschieben, klicken Sie auf das Dimensionfeld, und ziehen Sie es auf ein niedrigeres oder höheres Feld innerhalb der Dimension.

    Bei Datums- und Zeitfeldern werden die Ebenen nur dann vom Assistenten automatisch erstellt, wenn Sie ein neues oberes Dimensionsfeld erstellen. Werden diese Felder als Ebenen in einer vorhanden Dimension hinzugefügt, erstellt der Assistent keine Datums- und Zeitfelder.

  3. Aktivieren Sie bei Datums- und Zeitdimensionen die Kontrollkästchen für die Felder, die aufgenommen werden sollen, und deaktivieren Sie die Kontrollkästchen für die Felder, die nicht aufgenommen werden sollen. Sie können entweder eine Wochenebene oder eine Monatsebene aufnehmen, jedoch nicht beide, da Monate eine ungerade Anzahl von Wochen enthalten.

  4. Um den Namen eines Dimensionsfeldes oder einer Ebene zu ändern, klicken Sie einmal auf den Namen, um ihn auszuwählen, dann ein zweites Mal, um ihn zu ändern, und geben Sie anschließend den neuen Namen ein. Bei Datums- und Zeitdimensionen können die Namen der Ebenen nicht geändert werden.

    Die von Ihnen im Assistenten zugewiesenen Feldnamen werden in den aus dem Cube erstellten Berichten eingeblendet. Die Verfügbarkeit der Namensänderungsoption in den Berichten ist vom zu erstellenden Berichttyp abhängig.

Weitere Informationen

Tastenkombinationen für diesen Schritt des OLAP-Cube-Assistenten

Übersicht zum OLAP-Cube-Assistenten


OLAP-Cube-Assistent: Schritt 3

In diesem Schritt bestimmen Sie den Cube-Typ, der vom Assistenten erstellt werden soll. Die optimale Wahl hängt von mehreren Faktoren ab, einschließlich des Datenumfangs der im Cube enthaltenen Daten, des Typs und des Komplexitätsgrades der aus dem Cube zu erstellenden Berichte und der dem Benutzer zur Erstellung und Ansicht der Berichte zur Verfügung stehenden Ressourcen (Arbeits- und Festplattenspeicher). Möglicherweise müssen Sie die Optionen zuerst ausprobieren, um die für Ihre Berichte am besten geeignete Kombination herauszufinden.

Option 1: Bedarfsgesteuerter Datenabruf

Was diese Option beinhaltet Diese Option beinhaltet Anweisungen zur Erstellung eines Cubes neben Ihrer Abfrage bzw. Ihrem Bericht und erstellt den Cube nur beim Öffnen eines Berichts. Der Cube ruft nur Daten ab, die zur Darstellung des Berichts benötigt werden. Weitere Daten werden nach Bedarf bei Änderungen in der Berichtdarstellung abgerufen.

Wann soll diese Option verwendet werden Verwenden Sie diese Option bei Berichten, die von Ihnen oder dem Berichtverfasser geöffnet und angezeigt, jedoch selten geändert werden, sowie bei Arbeits- oder Festplattenspeicherproblemen bei der Verwendung der anderen Optionen.

Geschwindigkeits- und Ressourcenkombinationen Da lediglich die zunächst im Bericht angezeigten Daten abgerufen werden, wird die zum Öffnen eines Berichts benötigte Zeit minimiert. Wenn beispielsweise in dem Cube Vertriebsdaten aus vier Gebieten angeordnet sind, in Ihrem Bericht jedoch zunächst nur die Daten für das Gebiet "Westen" angezeigt werden, ruft der Cube nur die Daten für das Gebiet "Westen" ab. Sie müssen allerdings bei jeder vorgenommenen Änderung der im Bericht angezeigten Daten abwarten, bis neue Daten vom Cube abgerufen werden, so dass die Änderungen längere Zeit in Anspruch nehmen können.

Option 2: Gleichzeitiges Abrufen aller Daten

Was diese Option beinhaltet Wie bei der ersten Option sind hier Anweisungen zur Erstellung eines Cubes neben Ihrer Abfrage bzw. Ihrem Bericht enthalten, und der Cube wird erst beim Öffnen des Berichts erstellt. Diesmal ruft der Cube beim ersten Öffnen des Berichts jedoch alle benötigten Daten auf einmal ab, so dass Sie Änderungen an der Darstellung des Berichts vornehmen können, ohne den Abruf neuer Daten abwarten zu müssen.

Wann soll diese Option verwendet werden Verwenden Sie diese Option bei Berichten, die in hohem Maße interaktiv genutzt werden, bzw. die von Ihnen oder Ihren Benutzern wiederholt geändert werden, oder wenn Sie keinen umfangreichen Speicherplatz für die Berichte aufwenden möchten.

Geschwindigkeits- und Ressourcenkombinationen Da bei dieser Option alle Daten gleichzeitig zur Verfügung gestellt werden, können Sie schnell die Ansicht wechseln und verschiedene Daten anzeigen. Dieser Cube-Typ benötigt jedoch mehr Speicherplatz als der Cube, der nur bei Bedarf Daten abruft, so dass Ihnen möglicherweise bei großen Datenmengen, die im Cube enthalten sind, nicht genügend Ressourcen zur Verfügung stehen werden.

Option 3: Speichern einer Cube-Datei

Was diese Option beinhaltet Diese Option erstellt eine separate Cube-Datei auf der Festplatte, in der alle für den Cube benötigten Daten abgerufen und in der Datei gespeichert werden.

Wann soll diese Option verwendet werden Verwenden Sie diese Option bei interaktiven Berichten, die Sie häufig ändern möchten, wenn Sie den verfügbaren Speicherplatz vernachlässigen können, oder wenn Sie den Cube im Netzwerk speichern möchten, so dass andere Benutzer auf ihn zugreifen können, um eigene Berichte zu erstellen. Eine Cube-Datei kann bestimmte Daten aus der ursprünglichen Datenbank bereitstellen und andere vertrauliche oder vor einem Zugriff unbefugter Personen zu schützende Daten herausfiltern. Mit Hilfe einer Cube-Datei können Sie auch offline mit den Berichten arbeiten, indem Sie einen Snapshot der ursprünglichen Quellendatenbank verwenden.

Geschwindigkeits- und Ressourcenkombinationen Das erstmalige Erstellen einer Cube-Datei nimmt zwar längere Zeit in Anspruch als die anderen Optionen, dafür kann das Öffnen und Ändern der Berichte schneller ausgeführt werden. Die Größe des Cubes wirkt sich auf die Geschwindigkeit aus, mit der Sie Berichte öffnen und ändern können. Der Umfang der aufgenommenen Daten und die Anordnung der Daten- und Dimension im Cube bestimmen die Dateigröße. Wenn Ihnen nur beschränkter Festplattenspeicherplatz zur Verügung steht, müssen Sie möglicherweise mit verschiedenen Anordnungen und Auswahlmöglichkeiten der Daten experimentieren, um die Größe der Cube-Datei zu verringern oder vielleicht die anderen Optionen verwenden, anstatt eine Cube-Datei zu erstellen.

Cube-Dateien und Cube-Definitionsdateien

Speichern einer Cube-Datei Wenn Sie sich für die dritte Option entscheiden, wird am angegebenen Ort eine Cube-Datei mit der Erweiterung .cub erstellt. In der Datei sind alle für den Cube benötigten Daten enthalten. Die Datei wird nicht sofort nach dem Klicken auf die Option Fertig stellen erstellt, sondern entweder, nachdem Sie die Cube-Definition in einer Datei speichern, oder wenn Sie auf der Grundlage des Cubes einen Bericht erstellen.

Speichern der Cube-Definition in einer Datei Dieser Abschnitt findet nur dann Anwendung, wenn Sie den OLAP-Cube-Assistenten von Microsoft Query aus ausführen. Bei allen drei Optionen werden Sie von Query aufgefordert, eine Cube-Definitionsdatei (.oqy) zu speichern, die Sie in Excel öffnen können, um auf der Grundlage Ihres Cubes Berichte zu erstellen. Diese Datei ist unabhängig von allen .cub-Dateien, in denen die eigentlichen Cube-Daten gespeichert werden. Wenn Sie an dem Cube Änderungen vornehmen möchten, können Sie die .oqy-Datei in Query öffnen, um erneut den OLAP-Cube-Assistenten zu öffnen. Weitere Informationen über Arbeiten mit .oqy-Dateien finden Sie in der Microsoft Query-Hilfe.

Weitere Informationen

Übersicht zum OLAP-Cube-Assistenten


Tasten zur Verwendung mit dem OLAP-Cube-Assistenten

Verwenden Sie diese Tasten, um Schritt 2 des OLAP-Cube-Assistenten durchzuführen.

So ziehen Sie ein Feld aus der Liste "Quellenfelder" in die Liste "Dimensionen"

  1. Drücken Sie TAB, um die Liste Quellenfelder auszuwählen.

  2. Drücken Sie die NACH-OBEN- oder NACH-UNTEN-TASTE, um das Feld auszuwählen, das verschoben werden soll.

  3. Drücken Sie zuerst TAB, um die Schaltfläche > auszuwählen und anschließend die EINGABETASTE.

  4. Um andere Felder zu verschieben, wiederholen Sie die Schritte 1 bis 3.

So verschieben Sie ein Feld auf eine höhere oder niedrigere Ebene innerhalb des Dimensionsfelds

  1. Drücken Sie TAB, um das Feld Dimensionen auszuwählen.

  2. Drücken Sie die NACH-OBEN- oder NACH-UNTEN-TASTE, um das zu verschiebende Feld auszuwählen.

  3. Drücken Sie CTRL+X.

  4. Drücken Sie die NACH-OBEN- oder NACH-UNTEN-TASTE, um auszuwählen, wohin das Feld verschoben werden soll.

  5. Drücken Sie CTRL+V.