Informationen zum Entwerfen und Veröffentlichen von PivotTable-Listen für das Web

Dieses Thema bietet einen Fahrplan für den Entwurf einer PivotTable-Liste und ihrer Veröffentlichung im Web.

Überblick

Bevor Sie beginnen

Schritt 1: Vorbereiten der Datenquelle

Schritt 2: Erstellen oder Öffnen einer PivotTable-Liste

Schritt 3: Anbinden der Quelldaten an die PivotTable-Liste

Schritt 4: Zuweisen von Raum für die PivotTable-Liste

Schritt 5: Entwerfen des Datenlayouts

Schritt 6: Einschränken des Zugriffs im Browser

Schritt 7: Hinzufügen weiterer Steuerelemente, Automatisierung oder einer Hilfe

Schritt 8: Testen und Veröffentlichen

Terminologie in PivotTable-Listen

Überblick

Wenn Sie noch nicht mit PivotTable-Listen gearbeitet haben Bei einer PivotTable-Liste handelt es sich um ein Steuerelement der Microsoft Office Web Components, das Sie auf einer Webseite verwenden können, um zusammengefasste Daten aus einer Datenbank oder einer anderen Datenquelle darzustellen. Benutzer, die die Seite anzeigen, können vom Webbrowser aus mit dem Steuerelement arbeiten. Wenn Sie jetzt zum ersten Mal etwas über dieses Steuerelement lesen oder begonnen haben, eines zu entwerfen oder zu ändern, möchten Sie eventuell mehr über die Funktionsweise einer PivotTable-Liste und über die Möglichkeiten einer PivotTable-Liste im Browser erfahren.

Wenn Sie allgemeine Informationen über den Entwurf von Webseiten brauchen, finden Sie weitere Informationen in dem Programm, das Sie zum Erstellen Ihrer Webseiten oder Website verwenden. Sie können die beiden folgenden Programme zum Erstellen von Webseiten mit PivotTable-Listen verwenden: die Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 (verfügbar in Microsoft Office 2000 Professional und Office 2000 Premium) sowie Microsoft FrontPage (verfügbar in Office 2000 Premium).

Entwurfsvorgang Der Vorgang, eine PivotTable-Liste zu entwerfen, umfasst mehrere Schritte, die in diesem Thema ausführlicher behandelt werden. Nachstehend finden Sie einen Überblick über diesen Vorgang:

  • Vorbereitungen vor dem Beginn: Vergewissern Sie sich, dass eine PivotTable-Liste das richtige Steuerelement für die Aufgabe und die erwartete Arbeitsweise der Benutzer im Browser darstellt. Stellen Sie fest, ob sich das verwendete Entwurfsprogramm für Ihren geplanten Entwurf eignet.

  • Vorbereiten der Datenquelle (Bestandteil von Schritt 1 dieses Vorgangs): Identifizieren Sie eine Verbindung zur Datenquelle und bereiten Sie sie vor. Bei der Datenquelle handelt es sich um die Daten, die in der PivotTable-Liste zur Verfügung gestellt werden.

  • Einrichten des PivotTable-Listensteuerelements (Schritte 2, 3 und 4): Zum Entwerfen des eigentlichen Steuerelements erstellen Sie die PivotTable-Liste in der Webseite oder einem anderen Dokument, fügen Sie die Datenquelle an und weisen Sie den Platz zu, der verwendet werden soll.

  • Entwerfen des Datenlayouts (Schritt 5): Entwerfen Sie die Anfangsdarstellung, organisieren Sie die Daten, und formatieren Sie sie.

  • Anpassen Ihrer PivotTable-Liste (Schritte 6 und 7, optional): Beschränken Sie den Zugriff auf Detaildaten oder Features, erstellen Sie ein dazugehöriges Diagramm, schreiben Sie Skripts, um die Aufgaben der Benutzer zu automatisieren, oder stellen Sie eine eigene Hilfe zur Verfügung.

  • Testen und Veröffentlichen (Schritt 8): Überprüfen Sie, ob die PivotTable-Liste im Browser genauso aussieht und funktioniert wie gewünscht, nehmen Sie alle Änderungen und Korrekturen vor, und stellen Sie dann die Webseite den Benutzern Ihrer Website zur Verfügung.

Zurück zum Anfang

Bevor Sie beginnen

Wie arbeiten die Benutzer mit den Daten? Bevor Sie mit dem Entwurf einer PivotTable-Liste beginnen, sollten Sie überlegen, ob die Benutzer die Daten bearbeiten oder lediglich anzeigen.

  • Auf einer Webseite Wenn Sie beabsichtigen, eine PivotTable-Liste auf einer Webseite zu veröffentlichen, bedenken Sie, dass die Interaktivität vom Browser des Benutzers bestimmt wird. Wenn Sie glauben, dass die Benutzer die PivotTable-Liste bearbeiten möchten, stellen Sie sicher, dass sie Browser, die PivotTable-Listen vollständig unterstützen, besitzen.

  • In einem anderen Programm Wenn Sie die PivotTable-Liste für die Verwendung in einem anderen Programm als einem Webbrowser entwerfen, stellen Sie sicher, dass Sie die Leistungsmerkmale für PivotTable-Listen kennen, die in dem betreffenden Programm zur Verfügung stehen. Weitere Informationen finden Sie unter Informationen zur Auswahl eines Entwurfsprogramms für eine PivotTable-Liste.

Benutzen Sie das richtige Steuerelement für Ihre Aufgabe? PivotTable-Listen sind in der Lage, Listen und Informationen aus Datenbanken für eine interaktive Verwendung darzustellen. Abhängig von den beabsichtigten Ergebnissen können Sie unter Umständen ein anderes Steuerelement der Microsoft Office-Webkomponente oder weitere Steuerelemente zusammen mit der PivotTable-Liste verwenden. Weitere Informationen finden Sie unter Wann sollte eine PivotTable-Liste verwendet werden?.

Verwenden Sie das richtige Entwurfsprogramm? Das Entwurfsprogramm ist das Programm, das Sie zum Erstellen der PivotTable-Liste verwenden. Unterschiedliche Entwurfsprogramme verfügen über unterschiedliche Leistungsmerkmale. Um beispielsweise ein Diagramm, einzuschließen, das die Daten in der PivotTable-Liste darstellt, müssen Sie die Entwurfsansicht der Microsoft Access-Datenzugriffsseite verwenden. Weitere Informationen finden Sie unter Informationen zur Auswahl eines Entwurfsprogramms für eine PivotTable-Liste.

Zurück zum Anfang

Schritt 1: Vorbereiten der Datenquelle

Bei der Datenquelle handelt es sich um die Informationen, die in der PivotTable-Liste angezeigt und analysiert werden sollen. Abhängig von dem verwendeten Entwurfsprogramm und dem Typ der Datenquelle, die angezeigt werden soll, müssen Sie möglicherweise eine Datenquelle einrichten oder eine Abfrage erstellen, bevor Sie die Daten in die PivotTable-Liste einschließen können. Bei einer Datenquelle handelt es sich um ein Mittel zur Aufzeichnung der erforderlichen Informationen, um die PivotTable-Liste mit den Daten in einer Datenbank zu verbinden; eine Abfrage stellt ein Mittel dar, um die aus der Datenbank zu ladenden Informationen anzugeben. Weitere Informationen finden Sie unter Informationen zu den Quelldaten für PivotTable-Listen. Informationen und Anleitungen zum Zugriff auf Datenquellen aus Ihrem Entwurfsprogramm zur Verwendung in einer PivotTable-Liste finden Sie in der Hilfe des betreffenden Entwurfsprogramms.

Wenn Sie mit einem Excel PivotTable-Bericht beginnen Wenn Sie einen PivotTable-Bericht aus Microsoft Excel auf einer Webseite veröffentlichen, erledigt Excel einen Teil der Entwurfsarbeit für Sie. Einige Elemente von PivotTable-Berichten werden jedoch geändert, wenn Sie einen Bericht als PivotTable-Liste für das Web speichern. Es gibt einige Elemente, wie z. B. benutzerdefinierte Berechnungen, die möglicherweise geändert werden müssen, um die gewünschten Ergebnisse anzuzeigen. Weitere Informationen finden Sie unter Informationen zum Arbeiten mit PivotTable-Listen, die von Microsoft Excel aus veröffentlicht wurden.

Zurück zum Anfang

Schritt 2: Erstellen oder Öffnen einer PivotTable-Liste

Die jeweiligen Schritte zum Erstellen des Steuerelements hängen von den verschiedenen Entwurfsprogrammen ab. Spezielle Informationen finden Sie in der Hilfe Ihres Entwurfsprogramms. Wenn die Hilfe Ihres Entwurfsprogramms jedoch keine Verfahren bereitstellt, finden Sie weitere Informationen unter Erstellen einer neuen PivotTable-Liste.

Wenn Sie eine vorhandene PivotTable-Liste ändern möchten, die beispielsweise aus einem PivotTable-Bericht von Microsoft Excel gespeichert oder aus einer anderen Webseite kopiert wurde, können Sie die Datei mit der PivotTable-Liste in einem Entwurfsprogramm öffnen und anschließend das Steuerelement aktivieren, indem Sie den Anleitungen des Programms folgen (normalerweise, indem Sie auf die PivotTable-Liste klicken oder doppelklicken). Details finden Sie in der Hilfe Ihres Entwurfsprogramms.

Festlegen der Position und Größe der PivotTable-Liste Wenn Sie eine neue PivotTable-Liste erstellen, weisen Sie normalerweise auf der Webseite einen Anfangsbereich für die Liste relativ zu anderen Elementen auf der Seite zu. Nach dem Verbinden der Datenquellen (in Schritt 3 dieses Verfahrens) können Sie den Platzumfang für die Liste zuweisen und die PivotTable-Liste dann an die optimale Position verschieben (siehe Schritt 4 dieses Verfahrens).

Arbeiten mit der PivotTable-Liste Nachdem Sie eine PivotTable-Liste in einem Entwurfsprogramm erstellt oder ausgewählt haben, arbeiten Sie in der PivotTable-Liste und setzen den Entwurf in der PivotTable-Liste mit Hilfe der Symbolleiste und der PivotTable-Eigenschaftentoolbox fort.

Zurück zum Anfang

Schritt 3: Anbinden der Datenquellen an die PivotTable-Liste

Wenn Sie mit einer vorhandenen PivotTable-Liste arbeiten, wurden die Datenquellen möglicherweise bereits dem Steuerelement zugeordnet und unter Umständen auch mit dem Steuerelement gespeichert. Bei einer neuen PivotTable-Liste müssen Sie eine Verbindung zu den Datenquellen einrichten, die im Entwurfsprogramm vorbereitet wurde. Weitere Informationen finden Sie unter Hinzufügen von Daten zu einer PivotTable-Liste.

Zurück zum Anfang

Schritt 4: Zuweisen von Raum für die PivotTable-Liste

Zuweisen der Anfangsgröße Im PivotTable-Listensteuerelement können Sie die Gesamtgröße festlegen, wie z. B. eine feste Höhe und Breite, in denen für die Daten ein Bildlauf durchgeführt werden kann. Sie können auch zulassen, dass die PivotTable-Liste mit maximaler Größe angezeigt wird und Bildlaufleisten bei Bedarf angezeigt werden. Die festgelegte Größe überschreibt die Anfangsgröße des gezeichneten Rechtecks oder die beim Erstellen der PivotTable-Liste anderweitig festgelegt wurde. Alternativ können Sie zulassen, dass die PivotTable-Liste soweit wie erforderlich vergrößert oder verkleinert wird, um die Daten anzuzeigen. Darüber hinaus können Sie die Größe und Zeilenhöhe für den Detailbereich in einer PivotTable-Liste festlegen.

Ändern der Größe zu einem späteren Zeitpunkt Diese Einstellungen bestimmen die Größe der PivotTable-Liste im Browser und die Größe des Arbeitsbereichs, wenn Sie die Darstellung der Daten im Entwurfsprogramm entwerfen. Wenn Sie später einen anderen Platzbedarf für die PivotTable-Liste festlegen oder andere Einstellungen für den Browser als beim Entwurf verwenden möchten, können Sie diese Einstellungen ändern.

Zurück zum Anfang

Schritt 5: Entwerfen des Datenlayouts

Nach dem Erstellen einer PivotTable-Liste und dem Hinzufügen von Datenquellen besteht der nächste Schritt darin, festzulegen, wie die Daten dargestellt werden sollen, wenn Benutzer die Webseite zum ersten Mal öffnen.

Anpassen der Darstellung an die Anforderungen der Benutzer Überlegen Sie, wie die Benutzer wahrscheinlich mit den Daten arbeiten. Wenn einerseits alle Benutzer mit PivotTable-Listen vertraut sind und eigene Datenlayouts und Zusammenfassungen erstellen möchten, brauchen Sie unter Umständen lediglich einige der Felder von den Quelldaten anzuzeigen. Wenn Ihre Benutzer andererseits eine bestimmte Art der Zusammenfassung oder Ansicht der Daten benötigen bzw. darauf vertrauen, dass Sie die Layoutarbeit erledigen, oder unterschiedliche Fähigkeiten besitzen, möchten Sie eventuell Layout, Anordnung und Format der Daten selbst festlegen. Weitere Informationen finden Sie unter Informationen zum Arbeiten mit einer PivotTable-Liste im Browser.

Bedenken Sie, dass Benutzer in einigen Browsern, wie z. B. Microsoft Internet Explorer, Version 3.x, die Daten nicht anzeigen oder bearbeiten können. Um die Daten zu bearbeiten, müssen die Benutzer über einen Browser, der PivotTable-Listen unterstützt, verfügen.

Einrichten des Anfangslayouts Zum Anzeigen der Daten in der PivotTable-Liste fügen Sie Felder von den Datenquellen zu den Dropbereichen für die unterschiedlichen Feldtypen hinzu. Überlegen Sie ferner, wie wie Sie die Daten zusammenfassen möchten, indem Sie Gesamtsummen erstellen und anzeigen.

Anordnen der Daten Nach dem Hinzufügen der Felder und Ergebnisse stehen Ihnen mehrere Optionen zur Verfügung, um die angezeigten Ergebnisse anzuordnen. Sie können die Daten sortieren, um die Reihenfolge der Datenelemente in einem Feld zu ändern. Um eine Teilmenge der Daten anzuzeigen, können Sie die Felder filtern, um nur die Datenelemente anzuzeigen, die den Werten entsprechen, die angezeigt werden sollen. Weiterhin können Sie für ein Feld oder Datenelement selektiv Details anzeigen oder ausblenden.

Formatieren der Daten Die Formatierungsoptionen umfassen: Festlegen der Schriftarten und Hintergrundfarben, Ändern der Anzeigeformate für Zahlen, Ausrichten von Text in Zellen, Ändern der Spaltenbreiten, Anzeigen oder Ausblenden der Dropbereiche für Felder, Formatieren der Feldbeschriftungen und Anzeigen oder Ausblenden der Erweiterungssymbole ( Pluskästchen oder Minuskästchen) neben Elementen. Weitere Informationen finden Sie unter Informationen zum Formatieren einer PivotTable-Liste. Darüber hinaus können Sie einen Titel für die PivotTable-Liste hinzufügen und formatieren.

Zurück zum Anfang

Schritt 6: Einschränken des Zugriffs im Browser

Auch in einem Browser, der PivotTable-Listen vollständig unterstützt, wie z. B. Microsoft Internet Explorer 5, können die Benutzer auf einige Befehle und Features nicht zugreifen, die Sie in einem Entwurfsprogramm verwenden können. Um Benutzer daran zu hindern, Teile der Datenquellen zu ändern oder darauf zuzugreifen, die Sie nicht zur Verfügung stellen möchten, können Sie weitere Einschränkungen festlegen. Weitere Informationen finden Sie unter Informationen zum Einschränken des Zugriffs auf eine PivotTable-Liste im Browser.

Zurück zum Anfang

Schritt 7: Hinzufügen weiterer Steuerelemente, Automatisierung oder einer Hilfe

Einschließen eines Diagramms Sie können eine weitere Microsoft Office-Webkomponente, die Diagrammkomponente, verwenden, um ein getrenntes Diagramm der Daten in Ihrer PivotTable-Liste anzuzeigen. Wenn ein Benutzer die in der PivotTable-Liste angezeigten Daten ändert, wird das Diagramm im Browser automatisch aktualisiert. Wenn die PivotTable-Liste beispielsweise zeitabhängige Daten von Aktienkursen liefert, können Sie auf der Webseite ein Diagramm einschließen, um den Preisverlauf grafisch darzustellen. Wenn der Benutzer unterschiedliche Aktien auswählt, die in der PivotTable-Liste angezeigt werden sollen, wird das Diagramm automatisch entsprechend den ausgewählten Aktien aktualisiert. Weitere Informationen finden Sie unter Informationen zum Erstellen und Verwenden eines Diagramms, das auf einer PivotTable-Liste basiert.

Schreiben von Skripts Sie können auf viele der Features und Leistungsmerkmale von PivotTable-Listen mit Hilfe von Webskripts oder anderen Programmen zugreifen und diese steuern. Wenn Sie mit dem Schreiben von Skripts für Webseiten in eine Sprache, wie z. B. Visual Basic Scripting Edition (VBScript) oder JavaScript, vertraut sind, möchten Sie vielleicht Skripts zu der Webseite hinzufügen, um einige Aufgaben im Browser zu automatisieren. Sie können beispielsweise ein Skript zur Verfügung stellen, um die PivotTable-Liste in verschiedene nützliche Layouts zu ändern, und dann Schaltflächen zu der Webseite hinzufügen, mit denen jedes Layout ausgewählt werden kann.

Ihr Entwurfsprogramm stellt möglicherweise Tools zum Schreiben von Skripts zur Verfügung. Die Microsoft Office-Programme enthalten beispielsweise den Microsoft Skript-Editor . Weitere Informationen zum Schreiben von Skripts finden Sie in der Hilfe Ihres Entwurfsprogramms. Weitere Informationen über den Zugriff auf die Features von PivotTable-Listen mit Hilfe von Skripts finden Sie unter Informationen zur Unterstützung beim Schreiben von Programmen und Skripts für PivotTable-Listen.

Bereitstellen einer Hilfe Im Browser können die Benutzer in einer PivotTable-Liste auf eine eigenständige Hilfe zugreifen, die die Verwendung ihrer Features erläutert, solange Sie den Zugriff auf diese Hilfe beschränken. Sie können diese Laufzeithilfe ergänzen, indem Sie bestimmte Anleitungen oder Informationen auf Ihrer Webseite zum Verwenden Ihrer PivotTable-Liste bereitstellen. Sie können den Benutzern beispielsweise mitteilen, welche Datenbank die Datenquellen liefert und an wen sich hinsichtlich des Kennworts zu wenden ist, sofern für den Zugriff eines erforderlich ist. Weitere Informationen finden Sie unter Informationen zum Bereitstellen benutzerdefinierter Anleitungen für eine PivotTable-Liste.

Zurück zum Anfang

Schritt 8: Testen und Veröffentlichen

Überprüfen der PivotTable-Liste in einem Browser Bevor Sie die PivotTable-Liste den Benutzern zur Verfügung stellen, ist zu empfehlen, sie in einem Webbrowser zu testen. Microsoft Internet Explorer 5 oder höher wird für solche Benutzer empfohlen, die mit PivotTable-Listen arbeiten möchten. Wenn Ihre Benutzer über unterschiedliche Browserversionen verfügen, möchten Sie die PivotTable-Liste eventuell in jeder Version testen, um sicherzustellen, dass alle Benutzer die beabsichtigten Aufgaben zur Laufzeit durchführen können. Wenn Sie eine eigene Hilfe für die Webseite bereitstellen, vergewissern Sie sich, dass die Hilfe wie beabsichtigt aussieht und funktioniert. Weitere Informationen finden Sie unter Informationen zur Unterstützung von PivotTable-Listen in verschiedenen Browsern.

Durchführen von Änderungen Sollten Sie mit der PivotTable-Liste und der Webseite nicht zufrieden sein, können Sie zum Entwurfsprogramm zurückkehren und Änderungen vornehmen. Zusätzlich zum Ändern der Einstellungen, die Sie beim Entwurf des Datenlayouts und Anpassen der PivotTable-Liste vorgenommen haben, und die in den vorherigen Abschnitten dieses Themas behandelt wurden, können Sie in der PivotTable-Liste die folgenden Aufgaben durchführen:

  • Ändern des Layouts

  • Entfernen von Feldern

Veröffentlichen der Webseite Wenn Sie mit den Ergebnissen zufrieden sind, stellen Sie die Webseite den Benutzern zur Verfügung. Weitere Informationen zum Veröffentlichen von Webseiten finden Sie in der Hilfe Ihres Entwurfsprogrammes, oder wenden Sie sich an Ihren Webmaster.

Zurück zum Anfang


Was versteht man unter einer PivotTable-Liste?

Bei einer PivotTable-Liste handelt es sich um eine interaktive Tabelle, mit der Sie in Ihrem Webbrowser Daten dynamisch analysieren können. Sie können eine PivotTable-Liste verwenden, um Daten aus Listen oder Datenbanken anzuzeigen und anzuordnen, um nach Informationen oder Details zu suchen, sowie um personalisierte Zusammenfassungen und Berichte zu erstellen. Sie können die Datenwerte, die in einer PivotTable-Liste angezeigt werden, jedoch nicht ändern, bearbeiten oder löschen.

Beispiel für eine PivotTable-Liste

Eine einfache PivotTable-Liste zeigt eine Zusammenfassung der Daten aus einer Datenbank an.

Analysieren von Daten

Erstellen eines Anfangsdesigns Beim Erstellen einer PivotTable-Liste wählen Sie Daten aus einer externen Datenbank oder andern Datenquelle aus, die Sie den Benutzern Ihrer Webseite zur Verfügung stellen möchten. Diese Daten werden zu den Quelldaten der PivotTable-Liste. Sie können anschließend eine Anfangsdarstellung oder -ansicht der Daten einrichten, wie z. B. die im vorhergehenden Beispiel gezeigte Zusammenfassung, in der die Daten in einer von mehreren Möglichkeiten analysiert werden. Sie erledigen diese Aufgabe in einem Entwurfsprogramm, wie z. B. Microsoft Excel 2000, Microsoft FrontPage 2000 oder der Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000.

Weitere Analyse der Daten im Browser Nachdem die PivotTable-Liste auf einer Webseite durch Veröffentlichen zur Verfügung gestellt wurde, können Benutzer, die über einen Browser, der PivotTable-Listen unterstützt, verfügen, die Daten auch analysieren. Im Browser oder in einer anderen Laufzeitumgebung, können die Benutzer unterschiedliche Felder anzeigen und Ihre Anfangsansicht entsprechend ihren Anforderungen ändern. Abhängig von Ihrem Entwurfsprogramm und den Methoden können Sie die PivotTable-Liste in anderen Programmen als einem Browser zur Verfügung stellen.

Erstellen eines Zusammenfassungsberichts

Start mit einer Basisliste Die Beispiele verdeutlichen, wie Sie bei der Arbeit in einem Entwurfsprogramm oder ein Benutzer bei der Arbeit in einem Browser, eine Gruppe von Datensätzen aus einer Datenbank in einen Zusammenfassungsbericht ändern können. In der einfachsten erstellbaren Form zeigt eine PivotTable-Liste die Datensätze aus den Quelldaten in einem Raster, wobei die Feldnamen in der obersten Zeile angezeigt werden. Das folgende Beispiel enthält Felder mit den Namen Sport, Quartal und Absatz.

Beispiel für eine PivotTable-Liste mit allen Detailfeldern

Eine einfache PivotTable-Liste stellt eine Tabelle mit Datensätzen aus einer Datenbank als Gruppe von Detailfeldern dar.

Erstellen eines Zeilenfeldes Sie können eine Zusammenfassung erstellen, indem Sie Felder in andere Bereiche verschieben und Felder sortieren, um eine logische Anordnung zu erreichen. Die folgenden PivotTable-Liste übernimmt beispielsweise das vorhergehende Beispiel und zeigt, wie Sie durch Verschieben des Feldes Sport in den Zeilenbereich eine Zusammenfassung erstellen können, um die Daten anhand der Sportart zu ordnen, und dann das Feld Quartal sortieren können, um die Verkaufszahlen in chronologischer Reihenfolge anzuordnen.

Beispiel für eine PivotTable-Liste mit einem Zeilenfeld

Durch Verschieben des Feldes Sport in den Zeilenbereich werden die Daten so angeordnet, dass die Golf-Datensätze vor den Tennis-Datensätzen stehen.

Erstellen eines Spaltenfeldes Um die Verkaufszahlen für alle Sportarten in jedem Quartal zu vergleichen, können Sie das Feld Quartal in den Spaltenbereich verschieben, wie im folgenden Beispiel gezeigt wird.

Hinzufügen eines neuen Zeilen- oder Spaltenfeldes zu einer PivotTable-Liste

Das Erstellen eines Spaltenfeldes führt zu einer kreuzförmigen Tabellenansicht der Verkaufszahlen nach Sportart und Quartal.

Hinzufügen von Gesamtsummen und Ausblenden von Details Zum Anzeigen und Vergleichen der gesamten Verkaufszahlen an Stelle der detaillierten Verkaufsdaten, können Sie ein Gesamtsummenfeld Summe der Verkäufe hinzufügen und dann für die Felder Sport und Quartal die Detaildaten ausblenden. Ein Gesamtsummenfeld liefert die Werte, die in der PivotTable-Liste zusammengefasst werden. In dem folgenden Beispiel wird in der unteren rechten Zelle die Gesamtsumme der Tennis-Verkaufszahlen im 4. Quartal angezeigt, d. h., die Summe aller Verkaufszahlen aller Zeilen in den Quelldaten, die Tennis als Sportart und Qrtl4 als Quartal enthalten.

Beispiel für eine PivotTable-Liste mit Zusammenfassungsdaten

Das Hinzufügen eines Gesamtsummenfeldes liefert eine Zusammenfassung der Verkaufsdaten.

Weitere Analyseoptionen Um den Zusammenfassungsbericht zu erstellen, der am Anfang dieses Themas gezeigt ist, können Sie für die Felder Sport und Quartal anschließend Gesamtergebnisse anzeigen.

Um die Daten weiter zu analysieren, können Sie die Felder filtern, um bestimmte Daten zu finden. Sie können beispielsweise nur die Daten über Tennisverkäufe im dritten Quartal anzeigen. Darüber hinaus können Sie zu der Liste weitere Berechnungen hinzufügen. Sie können beispielsweise den größten Verkaufsumfang für alle Sportarten anzeigen.

Weitere Informationen

Informationen zum Arbeiten mit einer PivotTable-Liste im Browser

Informationen zum Entwerfen und Veröffentlichen von PivotTable-Listen für das Web


Informationen zum Arbeiten mit einer PivotTable-Liste im Browser

Dieses Thema enthält Informationen darüber, wie Benutzer des Webbrowsers Microsoft Internet Explorer mit einer PivotTable-Liste, die Sie erstellen, arbeiten können. Das Verständnis der Leistungsmerkmale des Browsers in Bezug auf PivotTable-Listen kann Ihnen bei der Verbesserung des Designs helfen, um die Bedürfnisse der Benutzer zu erfüllen. Weitere Informationen finden Sie unter Was versteht man unter einer PivotTable-Liste? sowie unter Informationen zum Entwerfen und Veröffentlichen von PivotTable-Listen für das Web.

Dieses Thema enthält Informationen über:

Arbeiten in einem Browser im Vergleich zum Arbeiten in einem Entwurfsprogramm

Die Browserschnittstelle für PivotTable-Listen

Möglichkeiten der Benutzer im Browser

Einfluss der festgelegten Einstellungen auf das Arbeiten im Browser

Terminologie

Arbeiten in einem Browser im Vergleich zum Arbeiten in einem Entwurfsprogramm

Sie können mit Hilfe der PivotTable-Komponente in einem Entwurfsprogramm eine PivotTable-Liste für den Zugriff in einem Webbrowser oder einer anderen Laufzeitumgebung erstellen. Die Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 ist eines mehrerer Entwurfsprogramme, mit denen Sie PivotTable-Listen erstellen und ändern können. Weitere Informationen finden Sie unter Informationen zur Auswahl eines Entwurfsprogramms für eine PivotTable-Liste.

Die in diesem Thema erläuterten Laufzeitfeatures stehen Benutzern zur Verfügung, die die Microsoft Office Web Components installiert haben. Dies kann durch Installieren von Microsoft Office 2000 oder (sofern ihre Firma über eine Office 2000-Sitelizenz verfügt) durch Downloaden der Office Web Components aus dem Firmenintranet erfolgen. Benutzer benötigen darüber hinaus einen Webbrowser, der PivotTable-Listen vollständig unterstützt. Wenn Sie beabsichtigen, PivotTable-Listen für den Einsatz in einem anderen Programm als einem Webbrowser, wie z. B. einem Microsoft Visual Basic-Formular, das Bestandteil einer benutzerdefinierten Lösung ist, zu erstellen, finden Sie in der Hilfe des Entwurfsprogramms Informationen darüber, wie die Benutzer auf PivotTable-Listen zugreifen und mit ihnen arbeiten können.

Zurück zum Anfang

Die Browserschnittstelle für PivotTable-Listen

Im Browser können die Benutzer eine PivotTable-Liste aktivieren und mit der gleichen Symbolleiste und Eigenschaften-Toolbox bearbeiten, die Sie beim Entwurf des Datenlayouts verwenden. Die Benutzer können jedoch im Browser auf einige Features nicht zugreifen, die Ihnen im Entwurfsprogramm zur Verfügung stehen.

Beispiel einer PivotTable-Liste auf einer Webseite

Im Browser können Benutzer die Symbolleiste und die PivotTable-Eigenschaftentoolbox verwenden, um mit einer PivotTable-Liste zu arbeiten.

Im Browser können Benutzer die gleiche PivotTable-Feldliste anzeigen, die Sie im Entwurfsprogramm verwenden. Die Feldliste steht auf der Symbolleiste in der PivotTable-Liste zur Verfügung und führt alle Felder auf, die aus den Quelldaten zur Verfügung gestellt wurden.

Beispiel einer Feldliste

Im Browser können Benutzer eine Liste aller Felder anzeigen, die aus der Quelldatenbank zur Verfügung gestellt wurden.

Zurück zum Anfang

Möglichkeiten der Benutzer im Browser

Benutzer können Daten anzeigen und analysieren Abhängig von den Einschränkungen, die Sie beim Entwurf der PivotTable-Liste festgelegt haben, kann der Benutzer Felder aus der Feldliste hinzufügen sowie die Anordnung und Anzeige der Daten ändern. Die Benutzer können genauso wie Sie im Entwurfsprogramm die Daten analysieren und Zusammenfassungen erstellen.

Unter Berücksichtigung der Anforderungen und Fähigkeiten der Zielgruppe können Sie die gesamte Analyse im Entwurfsprogramm durchführen und die Ergebnisse entsprechend veröffentlichen. Für normale Benutzer können Sie die fertigen Zusammenfassungen als getrennte PivotTable-Listen auf Ihrer Webseite veröffentlichen. Für erfahrenere Benutzer können Sie die Rohdaten der Datenquelle in einer PivotTable-Liste zur Verfügung stellen und die Analyse den Benutzern überlassen. Weitere Informationen finden Sie unter Erstellen einer Zusammenfassung.

Einfluss der Browserversion auf die Möglichkeiten der Benutzer Um die Vorteile der Leistungsfähigkeit von PivotTable-Listen vollständig zu nutzen, benötigen die Benutzer Microsoft Internet Explorer, Version 4.01 oder höher. In Internet Explorer 4.0 können die Benutzer auf einige der Leistungsmerkmale von PivotTable-Listen zugreifen. In anderen Browsern können die Benutzer keine PivotTable-Listen anzeigen oder bearbeiten. Weitere Informationen finden Sie unter Informationen zur Unterstützung von PivotTable-Listen in verschiedenen Browsern.

Zugriff vom Browser auf die Quelldatenbank Wenn Sie eine PivotTable-Liste entwerfen, geben Sie die zu verwendende Ursprungsdatenbank an und welche Teilmenge der Daten in der PivotTable-Liste als Quelldaten zur Verfügung gestellt werden sollen. Als Designer können Sie darüber hinaus Informationen über die Felder in der Quelldatenbank anzeigen.

Im Browser können die Benutzer lediglich die Daten anzeigen, die Sie ihnen zur Verfügung gestellt haben. Falls für den Zugriff auf die Datenbank ein Kennwort erforderlich ist, müssen die Benutzer zur Anzeige der Daten das Kennwort eingeben. Im Browser wird der Name oder der Typ der Quelldatenbank nicht angezeigt. Ferner lässt der Browser nicht zu, dass die Benutzer Informationen über die Felder in der Datenbank anzeigen. Die Benutzer können die PivotTable-Liste im Browser aktualisieren, damit alle Änderungen in den Quelldaten angezeigt werden. Sie können jedoch keinen umfassenderen Zugriff auf die Quelldatenbank erhalten oder Änderungen der darin gespeicherten Daten vornehmen.

Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

Benutzerhilfe im Browser Im Browser kann der Benutzer auf zwei Arten von Hilfe zugreifen: das Hilfesystem des Browsers selbst sowie der zusätzliche Hilfeinhalt, der automatisch innerhalb einer PivotTable-Liste zur Verfügung gestellt wird. Die letztere Hilfe erklärt die Verwendung der Befehle und Features, die in der PivotTable-Liste im Browser zur Verfügung stehen. Zum Anzeigen diese Hilfe öffnen Sie im Browser eine Webseite, die eine PivotTable-Liste enthält, und klicken auf der Symbolleiste in der PivotTable-Liste auf Hilfe [image]. Weitere Informationen finden Sie unter Informationen zum Bereitstellen benutzerdefinierter Anleitungen für eine PivotTable-Liste.

Zurück zum Anfang

Einfluss der festgelegten Einstellungen auf das Arbeiten im Browser

Wenn Sie die Optionen, die den Benutzern zur Laufzeit zur Verfügung stehen, vereinfachen möchten, können Sie Einschränkungen festlegen, die gelten, wenn die PivotTable-Liste im Browser angezeigt wird. Sie können beispielsweise verhindern, dass Benutzer die Detaildaten anzeigen. Sie können weiterhin Einschränkungen festlegen, wenn Sie die Analyseaufgaben im Entwurfsprogramm selbst durchführen und sicherstellen möchten, dass die Benutzer einige Gesichtspunkte im Hinblick auf die Anordnung der Daten nicht ändern. Sie können beispielsweise verhindern, dass Benutzer die Zeilen- und Spaltenfelder verschieben. Weitere Informationen finden Sie unter Informationen zum Einschränken des Zugriffs auf eine PivotTable-Liste im Browser.

Zurück zum Anfang


Elemente einer PivotTable-Liste

Beispiel für eine PivotTable-Liste, in der ihre Elemente angezeigt werden

Felder Jedes Feld entspricht einer Spalte von Daten und kann mehrere Zeilen mit Informationen zusammenfassen. Die Feldtypen umfassen: Zeilenfelder, Spaltenfelder, Datenfelder und Filterfelder.

Element Ein eindeutiges Datenelement in einem Feld. Datenelemente in Zeilen- und Spaltenfeldern werden in Spalten und Zeilen aufgeführt. Die Zelle, die im Schnittpunkt einer Zeile und einer Spalte liegt, zeigt die zusammengefassten Daten für die Elemente an, die am Anfang der Spalte und auf der linken Seite der Zeile aufgeführt sind.

Sind für ein Element weitere Detaildaten zur Anzeige verfügbar, wird neben dem Element das Erweiterungssymbol Pluskästchen angezeigt.

Zeilenfeld Ein Feld im Zeilenbereich. Im vorherigen Beispiel handelt es sich bei Artikel und Verkauft von um Zeilenfelder. Elemente in Zeilenfeldern werden auf der linken Seite einer PivotTable-Liste von oben nach unten aufgeführt. Innere Zeilenfelder, wie z. B. Verkauft von, befinden sich näher am Datenbereich; äußere Zeilenfelder, wie z. B. Artikel, befinden sich links von inneren Zeilenfeldern.

Spaltenfeld Ein Feld im Spaltenbereich. Elemente in Spaltenfeldern werden am Anfang einer PivotTable-Liste über den Datenfeldern aufgeführt. In dem Beispiel handelt es sich bei Quartal um ein Spaltenfeld mit zwei Elementen, Qrtl2 und Qrtl3. Innere Spaltenfelder liegen dem Datenbereich am nächsten; äußere Spaltenfelder befinden sich über den inneren Spaltenfeldern.

Filterfeld Ein Feld im Filterbereich, mit dem Sie die ganze PivotTable-Liste filtern können, um zusammengefasste Daten für ein bestimmtes Element anzuzeigen. In dem Beispiel handelt es sich bei Region um ein Filterfeld, mit dem Sie Daten für alle Regionen oder nur eine einzelne Region anzeigen können. Filterfelder führen die gleichen Funktionen aus wie Seitenfelder in Microsoft Excel PivotTable-Berichten und Microsoft Access PivotTable-Formularen.

Datenbereich Der Teil einer PivotTable-Liste, der Datenfelder enthält.

Datenfeld Ein Feld, das Zusammenfassungswerte aus den Quelldaten enthält. In dem Beispiel handelt es sich bei Verk. um ein Datenfeld, das zusammengefasste Verkaufszahlen enthält, wobei jeder Wert im Datenfeld die Summe der Einträge in dem Feld bzw. in der Spalte Verk. in den Quelldaten bildet.

Ein Datenfeld fasst normalerweise numerische Daten mit Hilfe der Zusammenfassungsfunktion Summe zusammen, wie z. B. Statistiken oder Verkaufszahlen. In dem Beispiel zeigt die Zelle mit dem Wert 30,984 die Gesamtverkäufe von Milchprodukten für Davolio im zweiten Quartal an. Diese Zelle kombiniert die Verkaufszahlen aller Datensätze in den Quelldaten, in denen Getreide als Produkt, Davolio als Verkaufsberater und Qrtl2 als Quartal enthalten ist.

Bei den zugrunde liegenden Daten kann es sich auch um Text handeln, der standardmäßig mit der Zusammenfassungsfunktion Anzahl zusammengefasst wird, mit der die Anzahl der Elemente berechnet wird. Ein Datenfeld, das den Typ des verkauften Produktes enthält, kann beispielsweise dazu verwendet werden, um die Anzahl der Verkäufe von Molkereiprodukten für Davolio im zweiten Quartal zu berechnen. Eine PivotTable-Liste kann darüber hinaus Daten mit Hilfe der Zusammenfassungsfunktionen Minimum und Maximum zusammenfassen, die den kleinsten bzw. größten Wert liefern.

Detailbereich Der Teil einer PivotTable-Liste (im Beispiel nicht gezeigt), der alle Zeilen oder Datensätze aus den Quelldaten anzeigen kann. Eine PivotTable-Liste kann Detailzeilen und zusammengefasste Daten gleichzeitig anzeigen. Felder im Detailbereich werden Detailfelder genannt.

Dropdownfeldpfeil Der Pfeil Feldpfeil auf der rechten Seite jedes Felds. Klicken Sie auf diesen Pfeil, um eine Dropdownliste anzuzeigen, in der Sie die anzuzeigenden und auszublendenden Elemente auswählen können.

In PivotTable-Listen, die auf OLAP-Quelldaten basieren, können Sie in einem Dimensionsfeld Elemente auf unterschiedlichen Ebenen auswählen. Datums- und Uhrzeitfelder bieten verschiedene Ebenen in allen Arten von Quelldaten. Wenn Sie beispielsweise auf den Dropdownpfeil für das Feld Jahr klicken, könnte die Anzeige wie folgt aussehen:

Dropdownliste für ein OLAP-Dimensionsfeld

Beispiel für eine Dropdownlist eines OLAP-Dimensionsfeldes

In dem Beispiel kennzeichnet das deaktivierte Kontrollkästchen neben 1998, dass das Jahr 1998 ausgeblendet ist. Das schattierte Kontrollkästchen neben 1999 kennzeichnet, dass das Jahr 1999 aktuell zur Anzeige ausgewählt ist, jedoch einige der Elemente unter 1999 nicht zur Anzeige ausgewählt wurden. In 1999 wurde Qrtl1 ausgeblendet. Das aktivierte Kontrollkästchen neben 2000 kennzeichnet, dass das Jahr 2000 zur Anzeige ausgewählt wurde. Wenn Sie auf Alle anzeigen klicken, werden alle Elemente auf allen Ebenen zur Anzeige ausgewählt.


Anzeigen des Inhaltsverzeichnisses für Ihr Entwurfsprogramm

Beim Anzeigen eines Hilfethemas für PivotTable-Listen sind im Hilfefenster in der Registerkarte Inhalt lediglich die Hilfethemen für PivotTable-Listen aufgeführt.

So zeigen Sie die Themen im Hilfesystem Ihres Entwurfsprogramms an:

  1. Klicken Sie im Hilfefenster auf die Registerkarte Antwort-Assistent, geben Sie eine Frage zu einem Thema ein, das sich nicht auf eine PivotTable-Liste bezieht, und klicken Sie dann auf Suchen.

  2. Klicken Sie auf ein Thema im Hilfesystem Ihres Entwurfsprogramms und dann auf Anzeigen.

  3. Klicken Sie auf die Registerkarte Inhalt, um den Inhalt der Hilfe für das Entwurfsprogramm anzuzeigen.


Informationen zur Unterstützung beim Schreiben von Programmen und Skripts für PivotTable-Listen

Sie können mit Hilfe von Skripts und Programmen PivotTable-Listen automatisieren oder PivotTable-Listen in andere Laufzeitprogramme, Programme, die Sie in einer Programmierumgebung, wie z. B. Microsoft Visual Basic, entwickeln, als Webbrowser einschließen.

Schreiben von Skripts Microsoft Office 2000-Programme enthalten den Microsoft Skript-Editor, der Ihnen beim Schreiben von Skripts hilft. Sie können beispielsweise den Skript-Editor in der Entwurfsansicht für Datenzugriffsseiten von Microsoft Access verwenden, um eine PivotTable-Liste anzupassen. Weitere Informationen zum Ausführen des Skript-Editors finden Sie in der Hilfe Ihres Office-Entwurfsprogrammes. Im Skript-Editor können Sie eine zusätzliche Hilfe zur Verwendung seiner Features und zum Schreiben von Skripts anzeigen.

Objektmodell-Hilfe Um Hilfe zum Entwickeln eines Programmes oder Skripts, das mit einer PivotTable-Liste arbeiten soll, zu erhalten, können Sie die Microsoft Office Web Components Visual Basic Reference verwenden. Dort finden Sie Informationen über das Objektmodel sowie über für PivotTable-Listen spezifische Eigenschaften und Methoden. Diese Objektmodell-Hilfe wird immer beim Installieren der Microsoft Office Web Components, die als eine Komponente PivotTable-Listen umfassen, installiert. Abhängig von dem verwendeten Entwurfsprogramm können Sie auf diese Hilfe auf zwei verschiedene Weisen zugreifen:

  • Hilfe in Microsoft Visual Basic In Visual Basic oder Visual Basic für Applikationen können Sie einen Verweis auf die Bibliothek der Microsoft Office Web Components erstellen. Sie können dann eine Hilfe im Objektkatalog anzeigen oder ein Schlüsselwort markieren und F1 drücken. Weitere Informationen zum Erstellen von Verweisen und zum Verwenden der Objektmodell-Hilfe finden Sie in der Hilfe von Visual Basic oder Visual Basic für Applikationen.

  • Hilfe in anderen Umgebungen Wenn Sie eine andere Entwicklungsumgebung verwenden, suchen Sie die Hilfedatei Msowcvba.chm, und doppelklicken Sie darauf.


Tastenkombinationen für PivotTable-Listen

Weitere Informationen zum Aktivieren und Deaktivieren einer PivotTable-Liste mit Hilfe der Tastatur finden Sie in der Hilfe Ihres Entwurfsprogrammes.

Wie möchten Sie mit Hilfe von Tastenkombinationen verfahren?

Markieren von Elementen in einer PivotTable-Liste

Ausführen von Befehlen

Anzeigen, Ausblenden, Filtern und Sortieren von Daten

Hinzufügen von Feldern und Gesamtsummen sowie Ändern des Layouts einer PivotTable-Liste

Formatieren einer PivotTable-Liste


Markieren von Elementen in einer PivotTable-Liste mit Hilfe von Tastenkombinationen

Taste | Zweck
TAB | Markieren jedes Feldes und anschließend der gesamten PivotTable-Liste, wobei diese Markierungen nacheinander erfolgen.
UMSCHALT+TAB | Markieren des vorherigen Feldes oder der gesamten PivotTable-Liste.
Pfeiltasten | Verschieben der Auswahl in Richtung der Pfeiltaste. Ist ein Zeilen- oder Spaltenfeld markiert, drücken Sie die NACH-UNTEN-TASTE, um sich zum ersten Datenelement im Feld zu bewegen, und drücken Sie dann eine Pfeiltaste, um sich zum nächsten oder vorherigen Element oder zurück zum Feld zu bewegen. Ist ein Detailfeld oder ein Datenelement markiert, drücken Sie die NACH-UNTEN-TASTE oder die NACH-RECHTS-TASTE, um sich zur ersten Zelle im Detailbereich oder Datenbereich zu bewegen.
UMSCHALT+Pfeiltaste | Erweitern oder Reduzieren der Auswahl in Richtung der Pfeiltaste. Sie können eine Auswahl nach unten und nach rechts erweitern.
UMSCHALT+BILD-AB | Erweitern einer Auswahl um einen Bildschirm nach unten. Bei einem Bildschirm handelt es sich um die Daten, die aktuell in der PivotTable-Liste angezeigt werden.
UMSCHALT+BILD-AUF | Reduzieren einer Auswahl um einen Bildschirm.
STRG+LEERTASTE | Markieren des Feldes für das aktuell ausgewählte Datenelement, die aktuell ausgewählte Gesamtsumme oder Detailzelle.
UMSCHALT+LEERTASTE | Markieren der gesamten Zeile, die die aktuell ausgewählte Zelle enthält.
STRG+A | Löschen der gesamten PivotTable-Liste.
BILD-AB | Anzeigen des nächsten Bildschirms. Bei einem Bildschirm handelt es sich um die Daten, die aktuell in der PivotTable-Liste angezeigt werden.
BILD-AUF | Anzeigen des vorherigen Bildschirms.
ALT+BILD-AB | Anzeigen des nächsten Bildschirms rechts.
ALT+BILD-AUF | Anzeigen des vorherigen Bildschirms links.


Ausführen von Befehlen in einer PivotTable-Liste mit Hilfe von Tastenkombinationen

Taste | Zweck
F1 | Anzeigen von Hilfethemen. Weitere Informationen zu den im Hilfefenster verwendbaren Tasten finden Sie in der Hilfe Ihres Entwurfsprogramms.
UMSCHALT+F10 | Anzeigen des Kontextmenüs für das markierte Element der PivotTable-Liste. Verwenden Sie Kontextmenüs, um in der PivotTable-Liste Befehle auszuführen.
Unterstrichener Buchstabe | Ausführen eines Befehls im Kontextmenü. Weitere Informationen zur PivotTable-Eigenschaftentoolbox finden Sie unter ALT+EINGABETASTE.
ESC | Schließen des Kontextmenüs ohne Ausführen eines Befehls.
STRG+7 | Anzeigen oder Ausblenden der Symbolleiste.
ALT+EINGABETASTE | Anzeigen der PivotTable-Eigenschaftentoolbox. Zum Ausführen von Befehlen oder Festlegen von Eigenschaften stehen in der Toolbox keine Tastenkombinationen zur Verfügung.
ALT+F4 | Schließen der PivotTable-Eigenschaftentoolbox.
F9 | Aktualisieren der PivotTable-Liste aus den Quelldaten.
ESC | Abbrechen einer laufenden Aktualisierung.
STRG+C | Kopieren der markierten Daten aus der PivotTable-Liste in die Zwischenablage.
STRG+E | Exportieren der PivotTable-Liste nach Microsoft Excel.


Anzeigen, Ausblenden, Filtern und Sortieren von Daten in einer PivotTable-Liste mit Hilfe von Tastenkombinationen

Taste | Zweck
STRG+8 | Anzeigen oder Ausblenden der Erweiterungssymbole Pluskästchen und Minuskästchen neben Elementen.
STRG+Pluszeichen | Anzeigen der Details für das aktuell markierte Element.
STRG+Minuszeichen | Ausblenden der Details für das aktuell markierte Element.
ALT+NACH-UNTEN-TASTE | Öffnen der Dropdownliste für das aktuell markierte Feld.
TAB | Wechseln zu dem zuletzt markierten Element, der Schaltfläche OK und der Schaltfläche Abbrechen in der Dropdownliste für ein Feld.
Pfeiltasten | Bewegen zum nächsten Element in der Dropdownliste für ein Feld.
LEERTASTE | Aktivieren oder Deaktivieren des Kontrollkästchens für das aktuelle Element in der Dropdownliste für ein Feld.
Pluszeichen (numerisches Tastenfeld) | Anzeigen niedrigerer Detailebenen (sofern verfügbar) für das aktuelle Element in der Dropdownliste für ein Feld.
Minuszeichen (numerisches Tastenfeld) | Ausblenden niedrigerer Detailebenen für das aktuelle Element in der Dropdownliste für ein Feld.
EINGABETASTE | Schließen der Dropdownliste für ein Feld und Übernehmen aller vorgenommenen Änderungen.
ESC | Schließen der Dropdownliste für ein Feld, ohne die Änderungen zu übernehmen.
STRG+T | Aktivieren oder Deaktivieren von AutoFilter.
STRG+UMSCHALT+A | Sortieren der Daten in dem markierten Feld oder der markierten Gesamtsumme in aufsteigender Reihenfolge (A – Z 0 – 9).
STRG+UMSCHALT+Z | Sortieren der Daten in dem markierten Feld oder der markierten Gesamtsumme in absteigender Reihenfolge (Z – A 9 – 0).


Formatieren einer PivotTable-Liste mit Hilfe von Tastenkombinationen

Die ersten sieben Tastenkombinationen in der folgenden Tabelle ändern das Zahlenformat des markierten Elements. Weitere Informationen hierzu finden Sie unter Zahlenformate.

Um die folgenden Tastenkombinationen zu verwenden, markieren Sie zunächst ein Detailfeld oder eine Datenzelle eines Gesamtsummenfelds.

Taste | Zweck
STRG+UMSCHALT+Ö | Zuweisen des allgemeinen Zahlenformats für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+$ | Zuweisen des Währungsformats mit zwei Dezimalstellen und negativen Zahlen in Klammern für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+% | Zuweisen des Prozentformats ohne Dezimalstellen für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+& | Zuweisen des exponentiellen Zahlenformats mit zwei Dezimalstellen für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+§ | Zuweisen des Datumsformats mit Tag, Monat und Jahr für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+" (Anführungszeichen) | Zuweisen des Uhrzeitformats mit Stunde, Minute und AM oder PM für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+UMSCHALT+! | Zuweisen des numerischen Formats mit zwei Dezimalstellen, 1.000er-Trennzeichen und einem Minuszeichen für negative Werte für die Werte im markierten Gesamtsummen- oder Detailfeld.
STRG+B | Fett-Formatieren des Textes in dem markierten Element der PivotTable-Liste.
STRG+U | Unterstreichen des Textes in dem markierten Element der PivotTable-Liste.
STRG+I | Kursiv-Formatieren des Textes in dem markierten Element der PivotTable-Liste.


Hinzufügen von Feldern und Gesamtsummen sowie Ändern des Layouts einer PivotTable-Liste mit Hilfe von Tastenkombinationen

Dieses Thema enthält:

Tasten zum Arbeiten mit dem Dialogfeld PivotTable-Feldliste

Tasten zum Hinzufügen von Feldern und Gesamtsummen

Tasten zum Ändern des Layouts

Tasten zum Arbeiten mit dem Dialogfeld "PivotTable-Feldliste"

Taste | Zweck
STRG+L | Anzeigen des Dialogfelds PivotTable-Feldliste oder Aktivieren, sofern das Dialogfeld bereits angezeigt wird.
Pfeiltasten | Bewegen zum nächsten Element in der Feldliste.
Pluszeichen (numerisches Tastenfeld) | Erweitern des aktuellen Elements in der Feldliste, um seinen Inhalt anzuzeigen. Oder Erweitern von Gesamtsummen, um die verfügbaren Gesamtsummenfelder anzuzeigen.
Minuszeichen (numerisches Tastenfeld) | Reduzieren des aktuellen Elements in der Feldliste, um seinen Inhalt auszublenden. Oder Reduzieren von Gesamtsummen, um die verfügbaren Gesamtsummenfelder auszublenden.
TAB | Wechseln zum vorher ausgewählten Element, der Schaltfläche Hinzufügen zu und der Liste neben der Schaltfläche Hinzufügen zu in der Feldliste.
ALT+NACH-UNTEN-TASTE | Öffnen der Dropdownliste neben der Schaltfläche Hinzufügen zu in der Feldliste. Verwenden Sie die Pfeiltasten, um zum nächsten Element in der Liste zu wechseln, und drücken Sie die EINGABETASTE, um ein Element auszuwählen.
EINGABETASTE | Hinzufügen des markierten Feldes in der Feldliste zu dem Bereich in der PivotTable-Liste, der in der Liste Hinzufügen zu angezeigt wird.
ALT+F4 | Schließen der Feldliste.

Zurück zum Anfang

Tasten zum Hinzufügen von Feldern und Gesamtsummen

Taste | Zweck
STRG+UMSCHALT+S | Hinzufügen eines neuen Gesamtsummenfelds für das markierte Feld in der PivotTable-Liste unter Verwendung der Berechnung Summe.
STRG+UMSCHALT+C | Hinzufügen eines neuen Gesamtsummenfelds für das markierte Feld in der PivotTable-Liste unter Verwendung der Berechnung Anzahl.
STRG+UMSCHALT+M | Hinzufügen eines neuen Gesamtsummenfelds für das markierte Feld in der PivotTable-Liste unter Verwendung der Berechnung Minimum.
STRG+UMSCHALT+X | Hinzufügen eines neuen Gesamtsummenfelds für das markierte Feld in der PivotTable-Liste unter Verwendung der Berechnung Maximum.
STRG+UMSCHALT+B | Aktivieren oder Deaktivieren der Teilergebnisse und Gesamtergebnisse für das markierte Feld in der PivotTable-Liste.

Zurück zum Anfang

Tasten zum Ändern des Layouts

Taste | Zweck
STRG+1 | Verschieben des markierten Feldes in der PivotTable-Liste in den Zeilenbereich.
STRG+2 | Verschieben des markierten Feldes in der PivotTable-Liste in den Spaltenbereich.
STRG+3 | Verschieben des markierten Feldes in der PivotTable-Liste in den Filterbereich.
STRG+4 | Verschieben des markierten Feldes in der PivotTable-Liste in den Detailbereich.
STRG+NACH-LINKS-TASTE | Verschieben des markierten Zeilen- oder Spaltenfelds in der PivotTable-Liste auf eine höhere Ebene.
STRG+NACH-RECHTS-TASTE | Verschieben des markierten Zeilen- oder Spaltenfelds in der PivotTable-Liste auf eine niedrigere Ebene.

Zurück zum Anfang


Wann sollte eine PivotTable-Liste verwendet werden?

Die Microsoft Office Web Components bieten eine Reihe von Tools, mit denen Sie interaktive PivotTable-Listen, Tabellen und Diagramme auf Ihren Webseiten einschließen können. Jede Komponente besitzt Features und Leistungsmerkmale, die sich für bestimmte Zwecke eignen. Dieses Thema enthält einige Richtlinien, die Ihnen helfen sollen, zu bestimmen, ob eine PivotTable-Liste, eine Kalkulationstabelle oder ein Diagramm die optimale Lösung für die Aufgaben darstellt, von denen Sie erwarten, dass die Benutzer sie auf der Webseite ausführen.

Wann stellt eine PivotTable-Liste die richtige Auswahl dar?

Anzeigen von Informationen aus einer separaten Datenbank Verwenden Sie eine PivotTable-Liste, wenn Sie Informationen aus einer Datenbank, wie z. B. Microsoft Access- oder SQL Server-Datensätze oder OLAP-Daten aus einer Microsoft SQL Server OLAP-Dienste-Datenbank, in einer Form zur Verfügung stellen möchten, so dass Benutzer die Informationen im Webbrowser oder in einer Laufzeitumgebung bearbeiten und analysieren können.

Anzeigen und Analysieren, jedoch kein Aktualisieren von Daten Die Benutzer einer PivotTable-Liste können die zugrunde liegenden Quelldaten im Browser in keiner Weise aktualisieren oder ändern. Verwenden Sie eine PivotTable-Liste, wenn die Benutzer keine Änderungen der Daten einzugeben brauchen, um eigene Berechnungen durchzuführen, aber vorhandene Daten anzeigen und analysieren müssen. Sie benötigen beispielsweise eine PivotTable-Liste, um aus Microsoft Access kreuztabellenförmige Daten auf einer Webseite zu veröffentlichen.

Beispiele Nachstehend finden Sie einige Beispiele für die Anwendung von PivotTable-Listen:

  • Bereitstellen einer Datenbank mit Verkaufszahlen für Benutzer, die den Umsatz verschiedener Produkte und Regionen vergleichen möchten.

  • Veröffentlichen von Aktienkursen aus einer Datenbank, die häufig aktualisiert wird, so dass Benutzer die Leistungsfähigkeit der interessanten Aktien anzeigen und vergleichen können.

  • Bereitstellen ein Produktkatalogs, den Kunden filtern können, um die gewünschten Produkte zu finden, sowie um Informationen zu Preis, Lieferbarkeit und Versandkosten anzuzeigen.

Wann sollte ein anderes Steuerelement in Betracht gezogen werden?

Wenn Benutzer Daten eingeben und berechnen müssen Wenn Benutzer Änderungen der Daten oder Formeln zum Berechnen von Werten eingeben müssen, können Sie auf der Webseite eine interaktive Tabelle an Stelle einer PivotTable-Liste verwenden. Für die Berechnung von Kreditzahlungen, bei der Benutzer den zu finanzierenden Betrag eingeben und die Zinsenberechnungen ändern können, stellt eine Tabelle eine bessere Lösung dar als eine PivotTable-Liste. Sie können aus einer Tabelle jedoch nicht auf Datenbankdaten zugreifen, wie dies in einer PivotTable-Liste möglich ist.

Wenn Benutzer Datensätze in einer Datenbank aktualisieren müssen Wenn Sie ein Webseitensteuerelement benötigen, das für den Zugriff auf und zum Aktualisieren von Datensätzen in einer Datenbank verwendet werden kann, stellen Sie fest, ob Ihr Entwurfsprogramm ein solches zur Verfügung stellt. Weitere Informationen finden Sie in der Hilfe Ihres Entwurfsprogrammes. Microsoft Access bietet beispielsweise Datenbanksteuerelemente, die in der Entwurfsansicht für Datenzugriffsseiten verfügbar sind, die Sie zur Dateneingabe verwenden können.

Wenn Benutzer keine Interaktion mit den Daten benötigen Wenn Benutzer Daten anzeigen, ohne diese zu bearbeiten, kann eine nichtinteraktive Tabelle eine einfachere Möglichkeit bieten, um statische Daten anzuzeigen. Weitere Informationen zu anderen Möglichkeiten, Daten auf einer Webseite zur Verfügung zu stellen, finden Sie in der Hilfe Ihres Entwurfsprogrammes für Webseiten.

Weitere Informationen

Was versteht man unter einer PivotTable-Liste?

Informationen zum Arbeiten mit einer PivotTable-Liste im Browser

Unterstützung von PivotTable-Listen in verschiedenen Browserversionen


Informationen zur Unterstützung von PivotTable-Listen in verschiedenen Browsern

Um PivotTable-Listen anzuzeigen und zu bearbeiten, müssen die Benutzer die Microsoft Office Web Components installiert haben. Dies kann durch Installieren von Microsoft Office 2000 oder (sofern ihre Firma über eine Office 2000-Sitelizenz verfügt) durch Downloaden der Office Web Components aus dem Firmenintranet erfolgen.

Der vollständige Umfang der Features, die PivotTable-Listen im Web bereit stellen können, wie z. B. Bearbeiten der Daten in einer PivotTable-Liste durch Benutzer von einem Webbrowser aus, steht nicht in allen Browsern zur Verfügung.

Microsoft Internet Explorer 5 und höher In diesem Browser können die Benutzer auf alle Features von PivotTable-Listen zugreifen, auf die von einem Browser aus zugegriffen werden kann. Von den Benutzern vorgenommene Änderungen wie z. B. Formatierungen und Layoutänderungen bleiben erhalten, wenn die Benutzer eine PivotTable-Liste verlassen und sie in derselben Browsersitzung zu einem späteren Zeitpunkt erneut aufrufen.

Microsoft Internet Explorer, Versionen 4.01, 4.1x und 4.2x Die Benutzer können auf alle Features von PivotTable-Listen zugreifen, die in einem Browser verfügbar sind. Die Änderungen bleiben erhalten, wenn die Benutzer eine PivotTable-Liste verlassen und sie in derselben Browsersitzung zu einem späteren Zeitpunkt erneut aufrufen. In einigen Fällen benötigen die Benutzer darüber hinaus einen installierten Internet Explorer 5, um PivotTable-Listen auf Webseiten anzuzeigen, die in Microsoft Access mit Hilfe der Entwurfsansicht für Datenzugriffsseiten erstellt wurden.

Microsoft Internet Explorer 4.0 Benutzer können auf alle Features von PivotTable-Listen zugreifen, die auf der Symbolleiste in der PivotTable-Liste und den Kontextmenüs erreichbar sind, jedoch nicht auf die PivotTable-Eigenschaftentoolbox. Änderungen bleiben nicht erhalten, nachdem ein Benutzer eine PivotTable-Liste verlässt. In einigen Fällen benötigen die Benutzer darüber hinaus einen installierten Internet Explorer 5, um PivotTable-Listen auf Webseiten anzuzeigen, die in Microsoft Access mit Hilfe der Entwurfsansicht für Datenzugriffsseiten erstellt wurden.

Andere Browser In früheren Versionen von Microsoft Internet Explorer und in anderen Browsern können Benutzer keine PivotTable-Listen anzeigen. Eine PivotTable-Liste wird auf der Webseite entweder als umrandetes Feld oder überhaupt nicht angezeigt.


Informationen zur Auswahl eines Entwurfsprogramms für eine PivotTable-Liste

Bei einer PivotTable-Liste handelt es sich um eine Komponente, die in einem Programm, dem Entwurfsprogramm, erstellt und entworfen wird, um in einem anderen Programm, dem Laufzeitprogramm, verwendet zu werden. PivotTable-Listen sind hauptsächlich für den Einsatz im Webbrowser Microsoft Internet Explorer gedacht. Weitere Informationen finden Sie unter Unterstützung unterschiedlicher Browser.

Unterstützte Entwurfsprogramme Zum Erstellen von PivotTable-Listen können Sie die folgenden Entwurfsprogramme verwenden: Microsoft Excel, Microsoft FrontPage 2000, Microsoft Access 2000 und die Programmierumgebung Microsoft Visual Basic. Sie können in allen diesen Entwurfsprogrammen Webskripts erstellen, um PivotTable-Listen zu automatisieren. Microsoft Word bildet kein geeignetes Entwurfsprogramm für PivotTable-Listen.

Arbeiten in mehr als einem Entwurfsprogramm Abhängig vom Inhalt Ihrer Webseite und den Aufgaben, die Benutzer mit der PivotTable-Liste durchführen, sind einige Programme für Ihre Entwurfsaufgaben besser geeignet als andere. Sie können eine Webseite zunächst in einem Entwurfsprogramm erstellen und Komponenten wie z. B. PivotTable-Listen hinzufügen und die Webseite anschließend in einem anderen Programm öffnen, um weitere Aufgaben zu erledigen.

Wenn Sie beispielsweise einen PivotTable-Bericht in Microsoft Excel entworfen haben, können Sie diesen Bericht mit Excel speichern oder in einer PivotTable-Liste auf einer Webseite veröffentlichen. (Bei einem PivotTable-Bericht handelt es sich um die Excel-Version einer PivotTable-Liste.) Wenn Sie die sich ergebende PivotTable-Liste anpassen und die Standardeinstellungen ändern oder weitere Steuerelemente zu der Seite hinzufügen möchten, können Sie die Webseite anschließend in FrontPage 2000 öffnen und ändern.

Microsoft Excel Wenn Sie verschiedene Layouts ausprobieren und die Quelldaten, die in der PivotTable-Liste zur Verfügung gestellt werden sollen, anpassen möchten, bildet Excel eine hervorragende Entwurfsumgebung. Sie können in Excel Tools, wie z. B. Microsoft Query, verwenden, um auf externe Daten zuzugreifen und einen Excel PivotTable-Bericht zu erstellen. Von Excel aus können Sie einen PivotTable-Bericht in einer PivotTable-Liste auf einer Webseite speichern oder veröffentlichen. Die in Excel angegebenen Quelldaten werden automatisch mit der PivotTable-Liste verbunden. Die meisten Features von Excel PivotTable-Berichten sind beim Veröffentlichen enthalten. Weitere Informationen finden Sie unter Excel-Features, die in einer PivotTable-Liste nicht enthalten sind.

Eventuell möchten Sie die PivotTable-Liste in einem anderen Entwurfsprogramm formatieren und deren Größe sowie Erscheinungsbild ändern. Wenn irgendeiner der Benutzer Ihrer Webseite über Internet Explorer, Version 4.x verfügt, müssen Sie FrontPage 2000 verwenden, um von Excel aus veröffentlichte PivotTable-Listen zu ändern. Excel veröffentlicht PivotTable-Listen auf Webseiten mit Unterstützung für Internet Explorer 4.x und höher, und bei FrontPage 2000 bleibt diese Unterstützung erhalten. Wenn Sie eine Webseite, die von Excel aus veröffentlicht wurde, in Microsoft Access mit Hilfe der Entwurfsansicht für Datenzugriffsseiten ändern, müssen die Benutzer unter Umständen Internet Explorer 5 zusätzlich zu Internet Explorer 4.x installieren, bevor sie die Webseite verwenden können.

Microsoft FrontPage 2000 FrontPage stellt das empfohlene Entwurfsprogramm zum Erstellen von PivotTable-Listen für Benutzer dar, die Internet Explorer, Version 4.x besitzen, und zum Ändern von PivotTable-Listen, die von Excel aus gespeichert oder veröffentlicht wurden. In FrontPage können Sie PivotTable-Listen auf Webseiten erstellen (zeigen Sie im Menü Einfügen auf Komponente, und klicken Sie auf Office PivotTable), PivotTable-Listen, die in anderen Programmen erstellt wurden, ändern und anschließend die Features von FrontPage verwenden, um die Website zu erstellen und zu verwalten.

Microsoft FrontPage 2000 ist im Lieferumfang von Microsoft Office 2000 Premium enthalten.

Entwurfsansicht für Datenzugriffsseiten in Microsoft Access Access bietet spezielle Features zum Erstellen von Webseiten, die mit Daten aus Microsoft Access- und Microsoft SQL Server-Datenbanken arbeiten und diese anzeigen. Sie können beispielsweise mit dem Befehl Feldliste (Menü Ansicht) Daten suchen und in eine PivotTable-Liste ziehen. Sie können Verknüpfungen zwischen PivotTable-Listen und anderen Steuerelementen herstellen, die Daten aus Datenbanken auf einer Webseite anzeigen und ändern. Wenn eine Seite andere Daten als diejenigen, die in einer PivotTable-Liste oder einem anderen Steuerelement der Microsoft Office Web Components angezeigt werden, enthält, müssen die Benutzer Ihrer Webseite über Internet Explorer 5 oder höher verfügen, um die Seite anzuzeigen.

Microsoft Access ist im Lieferumfang von Microsoft Office 2000 Professional und Office 2000 Premium enthalten.

Visual Basic Wenn Sie eine umfassendere Programmierumgebung benötigen, als die Skriptmöglichkeiten von Excel, FrontPage und Access bieten, können Sie PivotTable-Listen in dem Entwicklungssystem Microsoft Visual Basic entwerfen. Verwenden Sie Visual Basic, wenn Sie eine PivotTable-Liste in eine benutzerdefinierte Lösung einschließen möchten. Die Benutzer können PivotTable-Listen in den Visual Basic-Formularen Ihrer Programme anzeigen und bearbeiten. An Stelle eines Browsers bildet das Formular die Laufzeitumgebung, und Ihr Programm kann viele Features von PivotTable-Listen automatisieren.

Weitere Entwurfsinformationen In der Hilfe des Entwurfsprogramms, das Sie verwenden möchten, können Sie feststellen, ob das Programm das Entwerfen von PivotTable-Listen unterstützt, und welche Verfahren zum Erstellen und Ändern eingesetzt werden.


Erstellen einer neuen PivotTable-Liste

Die jeweiligen Schritte zum Erstellen einer PivotTable-Liste hängen von dem Programm ab, das Sie zum Entwerfen der Webseite verwenden. In Microsoft Access können Daten beispielsweise automatisch zu einer PivotTable-Liste hinzugefügt werden. Weitere Informationen finden Sie in der Hilfe Ihres Entwurfsprogramms. Wenn die Hilfe Ihres Entwurfsprogramms kein Verfahren zum Erstellen von Steuerelementen, wie z. B. PivotTable-Listen, bietet, führen Sie die folgenden Schritte durch:

  1. Öffnen oder erstellen Sie die Webseite, in der die PivotTable-Liste angezeigt werden soll, in Ihrem Entwurfsprogramm.

  2. Markieren Sie mit Hilfe des Verfahrens des Entwurfsprogramms zum Hinzufügen eines Steuerelements zu einer Webseite das PivotTable-Listensteuerelement, und legen Sie die Position und Anfangsgröße der PivotTable-Liste auf der Webseite fest.

  3. Hinzufügen der Quelldaten zu der PivotTable-Liste.

Anmerkung Nach dem Erstellen einer PivotTable-Liste können Sie die Größe anpassen und weitere Einstellungen vornehmen. Weitere Informationen finden Sie unter Entwerfen einer PivotTable-Liste.


Festlegen der Größe einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste oder (wenn Sie noch keine Daten zu der PivotTable-Liste hinzugefügt haben) auf die PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Führen Sie einen der folgenden Schritte durch:

    Um die Größe des Bereichs auf der Webseite, der von der PivotTable-Liste verwendet wird, automatisch zu vergrößern und zu verkleinern, damit die aktuell angezeigten Daten hinein passen, aktivieren Sie das Kontrollkästchen Automatisch anpassen. Um anschließend zu verhindern, dass die PivotTable-Liste über eine bestimmte Größe hinaus vergrößert wird, geben Sie in dem Feld Maximale Höhe und/oder Maximale Breite einen Wert in Pixel ein.

    Um die PivotTable-Liste in einem Bereich mit fester Größe anzuzeigen, deaktivieren Sie das Kontrollkästchen Automatisch anpassen, und geben Sie dann die Höhe und Breite in den Feldern Höhe und Breite in Pixel ein.

Anmerkungen

  • Diese Einstellungen können im Browser nicht geändert werden.

  • Wenn Sie eine maximale Höhe oder Breite festlegen oder eine feste Größe angeben, werden in der PivotTable-Liste Bildlaufleisten angezeigt, sofern mehr Daten verfügbar sind, als in den Bereich passen.

  • Sie können die Größe für den Detailbereich getrennt festlegen.


Informationen zu den Quelldaten für PivotTable-Listen

Eine PivotTable-Liste bietet die Möglichkeit, Daten von externen Datenquellen zur Anzeige und Analyse auf eine Webseite zu bringen. Beim Entwerfen einer PivotTable-Liste wählen Sie die Quelldaten aus, die das Steuerelement verwendet und im Browser zur Verfügung stellt, und Sie stellen eine Verbindung zu den Quelldaten her. Im Browser können die Benutzer dann die PivotTable-Liste aktualisieren, um die aktualisierten Quelldaten anzuzeigen.

Die Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 bietet eine Reihe von Features und Befehlen, um Daten für die Verwendung in PivotTable-Listen vorzubereiten. Informationen über die Methoden und Verfahren, die Access zum Verwenden von Daten auf Datenzugriffsseiten bietet, finden Sie in der Access-Hilfe. Weitere Informationen finden Sie unter Programme, mit denen Sie PivotTable-Listen entwerfen können.

Dieses Thema betrifft alle Entwurfsprogramme für PivotTable-Listen und bietet Informationen über:

Typen von Quelldaten

Herstellen der Verbindung zu Quelldaten

Aktualisieren bei geänderten Quelldaten

Typen von Quelldaten

PivotTable-Listen können Daten von drei Typen von Datenquellen anzeigen: relationale Datenbanken, Microsoft Excel-Arbeitsmappen und OLAP-Datenbanken (On-Line Analytical Processing).

Relationale Datenbanken Eine PivotTable-Liste kann Daten aus mehreren Datensätzen in einer relationalen Datenbank, wie z. B. Microsoft Access oder Microsoft SQL Server, anzeigen und zusammenfassen. Wenn die Quelldaten aus einer relationalen Datenbank stammen, können Sie in der PivotTable-Liste neue Gesamtsummenfelder erstellen, in Feldern Detaildaten für Elemente anzeigen und Felder in den Detailbereich verschieben.

Daten aus Excel-Arbeitsmappen Wenn Sie einen Microsoft Excel PivotTable-Bericht erstellen, der auf Daten aus einer Excel-Arbeitsmappe basiert, und den Bericht anschließend auf einer Webseite als PivotTable-Liste speichern, werden die Daten aus der Excel-Arbeitsmappe in einer separaten HTML-Datei in einem Unterordner der Webseite gespeichert. Wenn die Quelldaten aus einer Excel-Arbeitsmappe stammen, können Sie in der PivotTable-Liste neue Gesamtsummenfelder erstellen, in Feldern Detaildaten für Elemente anzeigen und Felder in den Detailbereich verschieben.

Weitere Informationen zum Veröffentlichen von Excel PivotTable-Berichten auf Webseiten finden Sie in der Excel-Hilfe. Weitere Informationen finden Sie unter Arbeiten mit PivotTable-Listen, die von Microsoft Excel aus veröffentlicht wurden.

OLAP-Datenbanken Bei OLAP handelt es sich um ein Verfahren der Datenbankserververarbeitung, bei dem große Datenumfänge so organisiert werden, dass sie für Personen, die kommerzielle Trends und Ergebnisse analysieren möchten, erreichbar und verständlich sind. OLAP-Daten werden in Strukturen, die als Cubes bezeichnet werden, gespeichert und innerhalb des Cubes entsprechend der Detailebene angeordnet. Mehrere Ebenen, wie z. B. Informationen über Land, Region, Stadt und Standort, werden als Dimension bezeichnet und können in einer PivotTable-Liste als Feldgruppe verwendet werden. Bei einem OLAP-Cube kann es sich um eine Serverdatenbank, eine Cube-Datei, die aus einer Serverdatenbank extrahiert wurde, oder um einen Cube handeln, der im Speicher aus den Datensätzen in einer relationalen Datenbank erstellt wurde. Dies hängt von dem verwendeten OLAP-Server und der verwendeten Clientsoftware ab.

In PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, können Dimensionsfelder (auch Fieldsets genannt) unterschiedliche Detailebenen anzeigen. Wenn Sie Quelldaten aus OLAP-Datenbanken verwenden, können Sie keine eigenen Gesamtsummenfelder erstellen, keine Felder in den Detailbereich verschieben und keine Detaildaten anzeigen. OLAP-Datenbanken bieten jedoch ihre eigenen Tools, um Zusammenfassungsdaten und Berechnungen zu erstellen. Da Zusammenfassungen vorberechnet werden, anstatt große Umfänge von Detaildaten an die Client-PivotTable-Liste zurückzugeben, die zusammengefasst werden sollen, ermöglichen OLAP-Datenbanken das Analysieren größerer Datenumfänge, als normalerweise in einer PivotTable-Liste möglich wäre.

Weitere Informationen zum Erstellen von Zusammenfassungsfeldern in einem OLAP-Cube oder einer OLAP-Datenbank, die in einer PivotTable-Liste angezeigt werden können, erhalten Sie von Ihrem OLAP-Datenbankadministrator bzw. finden Sie in der Hilfe der OLAP-Tools von Microsoft Office (z. B. der OLAP-Cube-Assistent oder der Offline-Cube-Assistent, die beide zum Lieferumfang von Microsoft Excel gehören).

Zurück zum Anfang

Herstellen der Verbindung zu Quelldaten

Wenn Sie die Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 als Entwurfsprogramm verwenden, können Sie die Methoden und Befehle von Access verwenden, um Daten vorzubereiten und Verbindungen herzustellen. Weitere Informationen und Verfahren finden Sie in der Access-Hilfe.

Einrichten einer Datenquelle Um in Ihrem Entwurfsprogramm externe Quelldaten zu verwenden, richten Sie auf Ihrem System eine Datenquelle ein. Bei einer Datenquelle handelt es sich um eine Reihe benannter, gespeicherter Informationen, die Ihr Entwurfsprogramm mit einer externen Datenbank verbinden und Daten laden. Zum Einrichten einer Datenquelle benötigen Sie ein für den Typ der Quelldaten spezifisches Treiberprogramm. Microsoft Office bietet eine Reihe von Treibern für weit verbreitete Datenbanktypen. Ihr Entwurfsprogramm stellt unter Umständen weitere Treiber zur Verfügung; weitere Office-kompatible Treiber erhalten Sie von vielen Datenbankherstellern.

Wenn Sie in Ihrem Entwurfsprogramm sowohl mit OLAP-Datenbanken als auch mit relationalen Datenbanken arbeiten möchten, müssen Sie Datenquellen für beide Typen einrichten. Ihr Entwurfsprogramm bietet möglicherweise Möglichkeiten zum Einrichten von Datenquellen, oder Sie können für die Einrichtung Microsoft Windows-Tools oder Office-Tools einsetzen.

Sie können in der Windows-Systemsteuerung den Befehl 32-Bit-ODBC verwenden, um eine Vielzahl der mit Microsoft Office gelieferten Treiber einzurichten. Um beispielsweise den Microsoft SQL Server-Treiber einzurichten, klicken Sie auf der Registerkarte Benutzer-DSN (DSN bedeutet Datenquellenname) auf Hinzufügen, doppelklicken auf SQL Server, und folgen dann den Anleitungen, um die Datenquelle zu benennen und die Informationen zum Herstellen der Verbindung zu der Datenbank einzugeben. Sie können auch Datenquellen hinzufügen, wenn Sie Daten zu einer PivotTable-Liste hinzufügen.

Darüber hinaus können Sie Microsoft Query (eine Komponente von Microsoft Office) verwenden, um Datenquellen, einschließlich denen für OLAP-Datenbanken, einzurichten. Weitere Informationen zum Einrichten von Datenquellen finden Sie in Ihrem Entwurfsprogramm und der Hilfe für den Datenquellentreiber.

Erstellen einer Abfrage zum Laden der Daten Bei Quelldaten aus einer relationalen Datenbank müssen Sie nach dem Einrichten einer Datenquelle eine Abfrage erstellen oder eine SQL SELECT-Anweisung oder Prozedur schreiben, um die gewünschten Datensätze zu definieren und zu laden. Weitere Informationen dazu finden Sie in der Hilfe für Ihr Entwurfsprogramm und der Dokumentation für Ihre Datenbank. Microsoft Access verfügt beispielsweise über Tools, um Abfragen zu erstellen und Datensätze in der Access-Feldliste bereitzustellen (verfügbar im Access-Menü Ansicht), ohne eine Abfrage zu erstellen. Sie können dann mit Hilfe der Feldliste Daten für die Verwendung in PivotTable-Listen auswählen. Sie können darüber hinaus Microsoft Query verwenden, um Abfragen von Daten in den verschiedenen unterstützen Datenbanken zu erstellen.

OLAP-Cube-Datenquellen Um OLAP-Daten zu verwenden, benötigen Sie eine OLAP-Serverdatenbank, eine Cube-Datei oder Cubedefinition. Sie brauchen keine Abfrage einzurichten, um auf die Daten im Cube zuzugreifen; Sie brauchen lediglich einen Treiber und eine Datenquelle einzurichten. Weitere Informationen zum Arbeiten mit OLAP-Datenbanken finden Sie in der Dokumentation Ihres OLAP-Anbieters bzw. in der Microsoft Excel-Hilfe, Microsoft Query-Hilfe oder Microsoft Access-Hilfe.

Hinzufügen der Daten zu der PivotTable-Liste Wenn Sie Daten zu einer leeren PivotTable-Liste hinzufügen, richten Sie eine Verbindung zwischen der PivotTable-Liste und der Datenquelle ein. Beim Hinzufügen der Daten zu der PivotTable-Liste werden der PivotTable-Liste alle erforderlichen Informationen zur Verfügung gestellt, um die betreffende Verbindung erneut herzustellen und die Daten zu laden, wenn Benutzer die PivotTable-Liste im Browser öffnen.

Ihr Entwurfsprogramm enthält möglicherweise Tools, die Ihnen beim Einrichten dieser Verbindung helfen. Wenn Sie beispielsweise die Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 verwenden, können Sie die Daten suchen und in die PivotTable-Liste ziehen, wobei die Daten automatisch zu dem Steuerelement hinzugefügt werden. Weitere Informationen zum Einrichten einer Verbindung in Ihrem Entwurfsprogramm finden Sie in der Hilfe des Entwurfsprogrammes.

Falls Ihr Entwurfsprogramm keine Tools oder Hilfe für das Einrichten einer Verbindung enthält, können Sie eine Verbindungszeichenfolge für die Datenquelle mit Hilfe der PivotTable-Eigenschaftentoolbox erstellen. Weitere Informationen zu der Syntax von Verbindungszeichenfolgen finden Sie in der Hilfe des verwendeten Datenquellentreibers und in der Programmierhilfe für PivotTable-Listen.

So verwenden Sie die PivotTable-Eigenschaftentoolbox zum Hinzufügen von Daten zu einer PivotTable-Liste.

Auswirkungen der Treiber und Datenquellen für die Benutzer Ihrer Webseite Benutzer, die die PivotTable-Liste im Browser bearbeiten möchten, müssen einen für die Quelldatenbank spezifischen ODBC-Treiber oder Datenquellentreiber installieren, bevor sie versuchen, die PivotTable-Liste anzuzeigen. Dies betrifft alle Typen von Quelldaten außer den Daten aus Excel-Arbeitsmappen. Wenn Sie eine Quelldatenbank verwenden, für die der Treiber nicht als Bestandteil von Office installiert wird, stellen Sie sicher, dass die Benutzer der PivotTable-Liste auf den Treiber zugreifen können.

Im Browser brauchen die Benutzer jedoch keine Datenquelle für die externe Datenbank einzurichten. Wenn Sie in Ihrem Entwurfsprogramm die Daten zu der PivotTable-Liste hinzufügen, werden die Verbindungsinformationen für die Datenbank, die der Browser benötigt, in die PivotTable-Liste integriert und als Bestandteil der Webseite gespeichert. Ob die Benutzer eine Anmelde-ID und ein Kennwort für die externe Datenbank eingeben müssen, hängt von der Einrichtung der verwendeten Datenquelle beim Entwurf der PivotTable-Liste ab.

Zurück zum Anfang

Aktualisieren bei geänderten Quelldaten

Nachdem Sie eine Verbindung zu einer Datenbank eingerichtet haben, können Sie die PivotTable-Liste aktualisieren, wenn Aktualisierungen und Änderungen der Quelldaten berücksichtigt werden müssen.

Relationale Datenbanken Bei Quelldaten aus relationalen Datenbanken wird die Quelldatenbank bei einer Aktualisierung erneut abgefragt; d. h. beim Aktualisieren werden sowohl Änderungen der Daten und alle neuen Daten, die den eingerichteten Kriterien entsprechen, geladen. Wenn Sie möchten, dass die Abfrage, die SELECT-Anweisung oder die Gespeicherte Prozedur andere Daten oder Felder aus der Datenbank auswählen soll, finden Sie weitere Informationen zum Durchführen von Änderungen in der Dokumentation der Datenbank oder des Programmes, das zum Erstellen der Abfrage verwendet wurde.

OLAP-Datenbanken Bei OLAP-Quelldaten werden Daten von dem Server oder aus der Cube-Datei geladen, sobald in der PivotTable-Liste Änderungen vorgenommen werden, die sich auf die angezeigten Daten auswirken. Wenn Sie beispielsweise ein neues Feld zum Zeilenbereich hinzufügen, werden die Zusammenfassungswerte für die neuen Datenelemente geladen, die jetzt angezeigt werden. Wenn Sie mit einer OLAP-Cube-Datei arbeiten, finden Sie weitere Informationen zum Aktualisieren der Datei, wenn sich die Informationen in der ursprünglichen Serverdatenbank ändern, in der Dokumentation des Programmes, das zum Erstellen der Cube-Datei verwendet wurde.

Daten aus Excel-Arbeitsmappen Wenn Sie beabsichtigen, einen PivotTable-Bericht aus Microsoft Excel zu veröffentlichen, sollten Sie in Excel am Besten zuerst eine Kopie der Arbeitsmappe speichern und dann den PivotTable-Bericht in einer PivotTable-Liste auf einer Webseite veröffentlichen. Wenn Sie eine PivotTable-Liste, die von Excel aus veröffentlicht wurde, mit neuen oder geänderten Daten in der ursprünglichen Excel-Arbeitsmappe aktualisieren möchten, oder wenn Sie andere Excel-Daten für die PivotTable-Liste auswählen möchten, können Sie den ursprünglichen Excel PivotTable-Bericht ändern und den betreffenden Bericht anschließend in der PivotTable-Liste erneut veröffentlichen. Anleitungen dazu finden Sie in der Excel-Hilfe.

Aktualisierung der Daten im Browser Im Browser werden die Daten geladen, wenn der Benutzer die PivotTable-Liste zum ersten Mal anzeigt. Wenn der Benutzer zu einer anderen Webseite wechselt und dann zu der Seite mit der PivotTable-Liste zurückkehrt, bleiben die Änderungen des Benutzers an der PivotTable-Liste erhalten. Die Seite wird jedoch nicht erneut vom Webserver geladen, und die Daten in der PivotTable-Liste werden nicht aktualisiert. Der Benutzer kann die Daten aktualisieren, indem er auf Aktualisieren [image] klickt, und eine laufende Aktualisierung abbrechen, indem er die ESC-Taste drückt.

Zurück zum Anfang


Hinzufügen von Daten zu einer PivotTable-Liste

Ihr Entwurfsprogramm bietet unter Umständen eine einfachere Möglichkeit, Daten zu einer PivotTable-Liste hinzuzufügen. In der Entwurfsansicht für Datenzugriffsseiten von Microsoft Access 2000 können Sie beispielsweise Daten direkt in die PivotTable-Liste ziehen. Wenn Sie die Entwurfsansicht für Datenzugriffsseiten an Stelle des Verfahrens in diesem Thema verwenden, finden Sie weitere Informationen in der Access-Hilfe.

Verwenden Sie das folgende Verfahren, wenn Ihr Entwurfsprogramm kein Verfahren zum Hinzufügen von Daten bietet. Weitere Informationen finden Sie in der Hilfe Ihres Entwurfsprogrammes.

Bevor Sie Daten zu einer PivotTable-Liste hinzufügen können, müssen Sie einen ODBC-Treiber oder Datenquellentreiber (Unterstützungssoftware für OLE-DB oder OLAP) installieren und eine Datenquelle für die Verbindung zur Datenbank einrichten. Weitere Informationen finden Sie unter Datenquellen.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf die PivotTable-Liste bzw. auf die Titelleiste der PivotTable-Liste, sofern bereits Daten zu der PivotTable-Liste hinzugefügt wurden.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Datenquelle nicht eingeblendet ist, klicken Sie auf die Leiste Datenquelle.

  5. Führen Sie unter Daten erreichen mit einen der folgenden Schritte durch:

    Wenn ein Datenquellen-Steuerelement zu der Webseite hinzugefügt wurde, das die Quelldaten liefert, klicken Sie auf Datenquellen-Steuerelement, und klicken Sie dann in der Liste unter der Option auf das zu verwendende Steuerelement. Bei Datenquellen-Steuerelementen handelt es sich um ein Feature von Microsoft Access. Weitere Informationen zum Erstellen und Arbeiten mit Datenquellen-Steuerelementen finden Sie in der Access-Hilfe.

    Wenn die Webseite kein Datenquellen-Steuerelement besitzt oder Sie eine Verbindung zu anderen Quelldaten herstellen möchten, klicken Sie auf Verbindung und dann auf Verbindungseditor. Geben Sie im Dialogfeld Datenlinkeigenschaften die Datenquellen-Informationen für die Datenbank ein. Weitere Informationen zu den vorzunehmenden Einstellungen finden Sie in der Hilfe für den ODBC- oder Datenquellentreiber; weitere Informationen zur Einrichtung der Datenquelle finden Sie ebenfalls in der Hilfe Ihres Entwurfsprogrammes. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

  6. Führen Sie unter Daten verwenden aus: einen der folgenden Schritte durch:

    Um Daten aus einem bestimmten Element in der Datenbank zu verwenden, wie z. B. einer vorhandenen Tabelle oder Abfrage, klicken Sie auf Datenmitglied, und wählen Sie dann das gewünschte Element aus der Liste.

    Um Daten einer Abfrage oder eines Befehls, wie z. B. einer SQL-Anweisung, zum Auswählen der Daten zu verwenden, klicken Sie auf Befehltext, und geben Sie dann die Abfrage oder den Befehl im Feld ein. Weitere Informationen zur Abfrage- oder Befehlssyntax finden Sie in der Dokumentation Ihrer Datenbank.

Anmerkung Diese Einstellungen können im Browser nicht geändert werden.


Informationen zum Einschränken des Zugriffs auf eine PivotTable-Liste im Browser

Einige Features von PivotTable-Listen sind nur während der Arbeit im Entwurfsprogramm verfügbar. Andere Features können vom Benutzer einer PivotTable-Liste im Browser geändert werden. Für einige dieser Laufzeitfeatures können Sie den Zugriff beschränken, wenn Sie nicht möchten, dass Benutzer im Browser Änderungen vornehmen.

Auswirkungen der Browserversion auf den Zugriff Ob die Benutzer an einer PivotTable-Liste zur Laufzeit Änderungen vornehmen können, hängt von dem verwendeten Browser ab.

Leistungsmerkmale, die im Browser niemals verfügbar sind Im Browser können die Benutzer die folgenden Features nicht verwenden, die nur während der Bearbeitung der PivotTable-Liste in einem Entwurfsprogramm zur Verfügung stehen:

  • Ändern der Größe der PivotTable-Liste

  • Ändern der Größe des Detailbereichs

  • Hinzufügen von Quelldaten zu der PivotTable-Liste

  • Automatisches Anzeigen von Detaildaten für alle Elemente

  • Formatieren der Titelleiste

  • Formatieren oder Ändern der Beschriftungen des Dropbereichs

  • Anzeigen der PivotTable-Liste von rechts nach links

  • Anzeigen von Informationen über Felder und Quelldaten

Leistungsmerkmale, die im Browser normalerweise verfügbar sind Wenn der verwendete Browser PivotTable-Listen vollständig unterstützt, können die Benutzer viele derselben Änderungen an PivotTable-Liste im Browser vornehmen, die Sie im Entwurfsprogramm durchführen können. Weitere Informationen finden Sie unter Verwenden von PivotTable-Listen im Browser.

Einschränkungen, die festgelegt werden können Um die Benutzer daran zu hindern, eine PivotTable-Liste zu ändern oder auf Bestandteile der Quelldaten zuzugreifen, die Sie ihnen nicht zur Verfügung stellen möchten, können Sie die folgenden Einschränkungen verwenden:

  • Aufheben der Verfügbarkeit der PivotTable-Eigenschaftentoolbox

  • Verhindern, dass Zeilen- und Spaltenfelder hinzugefügt und verschoben werden

  • Verhindern, dass Detaildaten angezeigt werden

  • Verhindern, dass die Benutzer die Filterung ändern


Informationen zum Bereitstellen benutzerdefinierter Anleitungen für eine PivotTable-Liste

Im Browser steht den Benutzern in einer PivotTable-Liste eine Hilfe zur Verfügung. Diese Laufzeithilfe erklärt die Verwendung der Features und Leistungsmerkmale von PivotTable-Listen. Abhängig von den Fertigkeiten der Benutzer und den Aufgaben, die von ihnen erledigt werden sollen, möchten Sie die Laufzeithilfe unter Umständen ergänzen, indem Sie benutzerdefinierte Anleitungen für Ihre PivotTable-Liste bereitstellen.

Vom Browser zur Verfügung gestellte Hilfe Benutzern, die Microsoft Internet Explorer, Version 4.01 oder höher und die Microsoft Office Web Components besitzen, steht automatisch eine spezielle Hilfe für PivotTable-Listen zur Verfügung. Die Laufzeithilfe ist von der Hilfe getrennt, die im Menü Hilfe des Browsers zur Verfügung steht.

Die Themen der Laufzeithilfe zu PivotTable-Listen bieten allgemeine Informationen über die Verwendung von PivotTable-Listen im Browser für alle Benutzer. Sie sind nicht mit den Themen der Entwurfshilfe für PivotTable-Listen identisch, die Sie derzeit lesen. Weitere Steuerelemente der Microsoft Office Web Components, wie z. B. das Tabellensteuerelement, verfügen ebenfalls über eine eigenständige Hilfe, die im Browser zur Verfügung steht.

Um festzustellen, welche Hilfe im Browser zur Verfügung steht, erstellen Sie eine PivotTable-Liste auf einer Webseite, öffnen Sie die Webseite in Internet Explorer, klicken Sie auf die PivotTable-Liste, und klicken Sie dann auf der Symbolleiste in der PivotTable-Liste auf Hilfe [image]. Im Hilfefenster können Sie ein Inhaltsverzeichnis anzeigen und bestimmte Themen suchen. Der Office-Assistent steht im Browser zum Beantworten von Fragen nicht zur Verfügung.

Benutzer, die nicht über die Office Web Components und Internet Explorer 4.01 oder höher verfügen, können nicht auf die Laufzeithilfe zugreifen. Weitere Informationen finden Sie unter Arbeiten mit PivotTable-Listen in verschiedenen Browsern.

Bereitstellen benutzerdefinierter Anleitungen Wenn Sie spezielle Anleitungen oder Informationen über die Quelldaten zur Verfügung stellen möchten, oder die PivotTable-Liste in Internet Explorer 4.0 verwendet wird, können Sie auf der Webseite eigene Anleitungen bereitstellen. Obwohl Sie Ihre Anleitungen nicht direkt mit der Onlinehilfe verbinden können, die mit der PivotTable-Liste bereitgestellt wird, können Sie direkt auf der Webseite Text einschließen, der die PivotTable-Liste beschreibt, oder einen Hyperlink zu einer separaten Webseite mit Anleitungen zur Verfügung stellen. Weitere Informationen, wie dies auf unterschiedlichen Webseiten realisiert werden kann, finden Sie in Ihrem Entwurfsprogramm für Webseiten.


Informationen zum Arbeiten mit PivotTable-Listen, die von Microsoft Excel aus veröffentlicht wurden

Microsoft Excel PivotTable-Berichte verfügen über einige Leistungsmerkmale, die beim Speichern oder Veröffentlichen eines Berichts als PivotTable-Liste verloren gehen. Aus diesem Grund möchten Sie eventuell ein anderes Entwurfsprogramm verwenden, um nach dem Veröffentlichen weitere Änderungen vorzunehmen. Ein wesentliches Kriterium bei der Auswahl des zu verwendenden Entwurfsprogramms liegt in der Kenntnis des Webbrowsers, den Ihre Benutzer wahrscheinlich installiert haben. Weitere Informationen finden Sie unter Auswählen eines Entwurfsprogramms.

Die folgenden Merkmale von Excel PivotTable-Berichten werden beim Veröffentlichen als PivotTable-Liste beeinflusst:

Berechnungen

Formatierung

Layout

Anzeigeoptionen

Quelldaten und Aktualisierungsoptionen

Berechnungen

Die folgenden Berechnungsmerkmale werden beim Veröffentlichen oder Speichern eines PivotTable-Berichts in Excel als PivotTable-Liste geändert oder gehen verloren:

Berechnete Felder Gehen verloren. PivotTable-Listen unterstützen keine berechneten Excel-Felder. Alle berechneten Felder in Excel werden in der PivotTable-Liste als Gesamtsummenfelder angezeigt, die die Standardzusammenfassungsfunktion verwenden. Berechnete Feldformeln gehen verloren.

Berechnete Elemente Gehen verloren. PivotTable-Listen unterstützen keine berechneten Elemente.

Zusammenfassungsfunktionen Lediglich die Funktionen Summe, Anzahl, Minimum und Maximum bleiben erhalten. Datenfelder in Excel, die unter Verwendung anderer Zusammenfassungsfunktionen zusammengefasst werden, gehen verloren. Die nicht zusammengefassten Felder sind in der Feldliste der PivotTable-Liste verfügbar, und Sie können Sie im Entwurfsprogramm verwenden, um Gesamtsummenfelder hinzuzufügen, die eine der unterstützten Zusammenfassungsfunktionen verwenden.

Benutzerdefinierte Berechnungen Gehen verloren. PivotTable-Listen unterstützen keine benutzerdefinierten Berechnungen. Alle Datenfelder mit benutzerdefinierten Berechnungen in Excel gehen verloren. Das Quellfeld, das für das Datenfeld verwendet wurde, steht in der Feldliste der PivotTable-Liste zur Verfügung, und Sie können es im Entwurfsprogramm verwenden, um Gesamtsummenfelder hinzuzufügen, die eine der unterstützten Zusammenfassungsfunktionen verwenden.

Benutzerdefinierte Teilergebnisse Gehen verloren. In einer PivotTable-Liste verwenden Teilergebnisse und Gesamtergebnisse immer dieselbe Zusammenfassungsfunktion wie das Gesamtsummenfeld. Wenn Sie in Excel die Zusammenfassungsfunktion für Teilergebnisse oder Gesamtergebnisse ändern, stellt das Teilergebnis oder das Gesamtergebnis die Zusammenfassungsfunktion des Gesamtsummenfeldes in einer veröffentlichten PivotTable-Liste wieder her.

Sternchen, die Gesamtsummen markieren Neben Teilergebnissen und Gesamtergebnissen werden in PivotTable-Listen, die auf Quelldaten von OLAP-Datenbanken basieren, Sternchen angezeigt, auch wenn sie im Excel PivotTable-Bericht deaktiviert wurden. Die Berechnungen von Teilergebnissen und Gesamtergebnissen in PivotTable-Listen können alle durch Filterung ausgeblendeten Datenelemente einschließen oder ausschließen.

Zurück zum Anfang

Formatierung

Die folgenden Formatierungsmerkmale werden beim Veröffentlichen oder Speichern einer PivotTable-Liste von Excel geändert oder gehen verloren:

Zeichen- und Zellenformatierung Gehen verloren. Änderungen von Schriftarten, Textgröße, Textfarbe und Zellhintergründen in Excel, einschließlich aller verwendeten AutoFormate, gehen verloren. Weitere Informationen finden Sie unter Formatieren einer PivotTable-Liste im Entwurfsprogramm.

Zahlenformate Gehen teilweise verloren. Zahlenformate, die Sie PivotTable-Feldern in Excel zuweisen, bleiben erhalten, während Zahlenformate, die Sie einzelnen Zellen zuweisen, verloren gehen. Wenn Sie ein Excel PivotTable-Feld mit einem benutzerdefinierten Zahlenformat oder einem anderen Excel-Zahlenformat als den Zahlenformaten, die in PivotTable-Listen unterstützt werden, formatieren, wird das veröffentlichte Ergebnis mit dem gleichen Zahlenformat wie im Excel PivotTable-Bericht angezeigt. Wenn Sie das Zahlenformat für das Feld im Entwurfsprogramm oder Browser nachträglich ändern, können Sie das Feld nicht mehr zurück in das benutzerdefinierte Zahlenformat umwandeln. In einer PivotTable-Liste können Sie Zahlenformate nur mit Hilfe eines Programms oder Skripts im Entwurfsprogramm anpassen. Weitere Informationen finden Sie unter Informationen zur Unterstützung beim Schreiben von Programmen und Skripts.

Druckeinstellungen Gehen verloren. Die Excel-Einstellungen zum Wiederholen der Bezeichnungen von PivotTable-Zeilen und -Spalten auf allen Seiten wiederholen Elementbezeichnungen nach Seitenumbrüchen. Festgelegte Seitenumbrüche zwischen Bereichen haben keine Auswirkung auf den Ausdruck einer PivotTable-Liste aus dem Entwurfsprogramm oder dem Browser. Weitere Informationen finden Sie unter Drucken von PivotTable-Listen.

Zurück zum Anfang

Layout

Die folgenden Layoutmerkmale werden beim Veröffentlichen oder Speichern eines PivotTable-Berichts in Excel als PivotTable-Liste geändert oder gehen verloren:

Gruppierte Elemente in Feldern Gehen teilweise verloren. Alle ausgewählten Elemente und numerischen Elemente, die in Excel gruppiert sind, sind in der PivotTable-Liste nicht mehr gruppiert, und Gruppenfelder von Excel gehen verloren. PivotTable-Listen verfügen über keine Möglichkeit, Elemente in Feldern zu gruppieren.

Gruppierte Elemente in Datumsfeldern bleiben erhalten, und die Elemente in diesen Feldern werden automatisch in Ebenen angeordnet, damit Sie im Entwurfsprogramm oder Browser die gewünschte Ebene auswählen können (Woche, Monat, Quartal usw.).

Benutzerdefinierte Sortierreihenfolgen Gehen verloren. Wenn Sie in einem Excel PivotTable-Feld eine benutzerdefinierte Sortierreihenfolge verwenden, werden die Daten in der PivotTable-Liste stattdessen in der Reihenfolge angezeigt, in der sie aus der Quelldatenbank abgerufen werden. Im Entwurfsprogramm oder Browser können Sie Daten in der PivotTable-Liste sortieren, jedoch weder benutzerdefinierte Sortierreihenfolgen erstellen oder verwenden noch die Datenelemente in einem Feld manuell neu anordnen.

Einzugsformate Gehen verloren. Wenn Sie mit dem Befehl Bericht formatieren in Excel einen PivotTable-Bericht mit Einzugsformat erstellen, verwendet die PivotTable-Liste kein Einzugsformat. Die Felder stehen an denselben Positionen, aber die Zeichen- und Zellenformatierung geht verloren. Wenn Sie zwischen Elementgruppen in Excel Leerzeilen eingefügt haben, sind die Leerzeilen in der veröffentlichten PivotTable-Liste nicht vorhanden.

Teilergebnisse am Anfang von Elementgruppen Gehen verloren. Wenn Sie Teilergebnisse in Excel am Anfang jeder Elementgruppe mit Teilergebnissen anzeigen, werden die Teilergebnisse in der PivotTable-Liste am Ende jeder Gruppe angezeigt. Sie können im Entwurfsprogramm oder Browser die horizontale Ausrichtung von Teilergebniselementen ändern jedoch nicht deren vertikale Position.

Zurück zum Anfang

Anzeigeoptionen

Die folgenden Anzeigeoptionen werden beim Veröffentlichen oder Speichern eines PivotTable-Berichts in Excel als PivotTable-Liste geändert oder gehen verloren:

AutoAnzeigen von obersten/untersten Elementen Geht verloren. Wenn Sie in einem Excel PivotTable-Bericht ein Feld festlegen, in dem eine Teilmenge der Elemente angezeigt werden soll (Excel-Dialogfeld Weitere Optionen für PivotTable-Feld), werden alle Elemente im Feld in der PivotTable-Liste angezeigt. Im Entwurfsprogramm können Sie das Feld sortieren, damit die obersten oder untersten Elemente zuerst angezeigt werden, und dann das Feld filtern, um nur die gewünschten Elemente anzuzeigen. In PivotTable-Listen besteht jedoch keine Möglichkeit, obere oder untere Teilmengen automatisch anzuzeigen.

Fehler und leere Zellen Gehen verloren. Beim Anpassen der Anzeige von Fehlern und leere Zellen in Excel, gehen die Anpassungen in der veröffentlichten PivotTable-Liste verloren. In PivotTable-Listen werden Fehler und leere Zellen, die von Excel aus veröffentlicht wurden, als Zellen ohne Inhalt angezeigt.

Seitenfelder in Zeilen oder Spalten Gehen verloren. Wenn Sie das Seitenlayout und die Einstellungen Felder pro Spalte (Excel-Dialogfeld PivotTable-Optionen) ändern, wirken sich die Änderungen nicht auf die veröffentlichte PivotTable-Liste aus. Filterfelder werden immer am Anfang der PivotTable-Liste angeordnet.

Zurück zum Anfang

Quelldaten und Aktualisierungsoptionen

Die folgenden Quelldaten und Aktualisierungsoptionen werden beim Veröffentlichen oder Speichern eines PivotTable-Berichts in Excel als PivotTable-Liste geändert oder gehen verloren:

Kennworteinstellungen Gehen verloren. Wenn Sie in Excel Ihr Kennwort mit einer Abfrage speichern, die erstellt wurde, um externe Daten für einen PivotTable-Bericht abzufragen, werden die Browserbenutzer beim Öffnen einer Webseite, die die PivotTable-Liste enthält, weiterhin aufgefordert, das Kennwort einzugeben.

Aktualisierungseinstellungen Gehen verloren. Wenn Sie in Excel eine Aktualisierung im Hintergrund oder die Ladeoptionen für Seitenfelder festlegen, wirken sich diese Optionen nicht auf die veröffentlichte PivotTable-Liste aus. PivotTable-Listen unterstützen keine Hintergrundaktualisierung oder das Laden von Daten für jedes einzelne Element in einem Filterfeld. Weitere Informationen finden Sie unter Aktualisieren einer PivotTable-Liste.

Ändern der Quelldaten Nicht verfügbar. Von einer PivotTable-Liste im Browser aus können die Benutzer keinen anderen Bereich der Excel-Quelldaten definieren oder die Abfrage so ändern, dass andere externe Daten ausgewählt werden. Wenn Sie die Quelldaten ändern möchten, können Sie diese Änderung in Excel vornehmen und die PivotTable-Liste anschließend erneut veröffentlichen. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

Client/Server-Einstellungen Nicht verfügbar. Wenn Sie einen Excel PivotTable-Bericht veröffentlichen, der mit einer Offline-Cube-Datei verbunden ist, können Sie von der veröffentlichten PivotTable-Liste keine erneute Verbindung zu der ursprünglichen Serverdatenbank herstellen und im Entwurfsprogramm oder Browser keine Änderungen am Inhalt der Offline-Cube-Datei durchführen. Wenn Sie eine dieser Aktionen durchführen müssen, können Sie dies in Excel erledigen und die PivotTable-Liste dann erneut veröffentlichen.

Zurück zum Anfang


Informationen zum Erstellen und Verwenden eines Diagramms, das auf einer PivotTable-Liste basiert

Beim Erstellen eines Diagramms, das auf einer PivotTable-Liste basiert, werden die in der PivotTable-Liste angezeigten Daten im Diagramm dargestellt. Wenn Sie die Ansicht der Daten in der PivotTable-Liste ändern, wird das Diagramm dynamisch aktualisiert, um die Änderungen zu berücksichtigen. Wenn Sie beispielsweise ein Feld zum Zeilen- oder Spaltenbereich hinzufügen, wird das Diagramm aktualisiert, damit das neue Feld entweder als Rubrik oder als Datenreihe berücksichtigt wird. Wenn Sie Daten filtern, in der PivotTable-Liste Details ausblenden oder ein Feld entfernen, so dass es in der Ansicht nicht mehr enthalten ist, werden die Daten ebenfalls aus dem Diagramm entfernt.

Bevor Sie beginnen Bevor Sie das Diagramm erstellen, müssen Sie in der PivotTable-Liste alle Daten, die im Diagramm angezeigt werden sollen, in die Zeilen- und Spaltenbereiche verschieben. Standardmäßig werden die Daten in Zeilenfeldern im Diagramm als Datenreihen, und die Daten in Spaltenfeldern als Datenrubriken angezeigt. Darüber hinaus müssen Sie zu der PivotTable-Liste mindestens ein Gesamtsummenfeld hinzufügen, damit die Daten im Diagramm angezeigt werden. Wenn Sie mehr als ein Gesamtsummenfeld hinzufügen, verwendet das Diagramm die Daten aus dem Gesamtsummenfeld, das sich am weitesten links befindet.

Erstellen eines Diagramms Zum Erstellen eines Diagramms verwenden Sie das Verfahren Ihres Entwurfsprogrammes zum Hinzufügen eines Steuerelements zu einer Webseite. In Microsoft FrontPage 2000 zeigen Sie beispielsweise im Menü Einfügen auf Komponente und klicken dann auf Office Chart. Nach dem Hinzufügen des Diagrammsteuerelements folgen Sie den Anleitungen im Microsoft Office Diagramm-Assistenten. In dem Assistenten können Sie den gewünschten Diagrammtyp auswählen und die Datenreihen so ändern, dass die Daten in Spaltenfeldern an Stelle der Daten in Zeilenfeldern verwendet werden.

Das folgende Beispiel zeigt ein Diagramm, das auf einer PivotTable-Liste basiert. In dem Gesamtsummenfeld Summe der Verkäufe werden die Gesamtverkäufe für jeden Produkttyp nach Verkaufsberater angezeigt. Der blaue Pfeil in der Bezeichnung des Feldes Verkaufsberater gibt an, dass das Feld gefiltert wurde, so dass lediglich die Daten für vier Verkaufsberater angezeigt werden.

Diagramm, das auf einer PivotTable-Liste basiert

Ein Diagramm, das auf einer PivotTable-Liste basiert. Das Spaltenfeld Typ der PivotTable-Liste wird im Diagramm als Datenrubrik (Getränke, Getreide und so weiter) angezeigt. Das Zeilenfeld Verkaufsberater wird im Diagramm als Datenreihe angezeigt. Die Namen der Datenreihen werden in der Legende angezeigt (Buchanan, Davolio und so weiter).

Verwenden des Diagramms Wenn Sie Felder in der PivotTable-Liste hinzufügen oder verschieben, wird das Diagramm entsprechend den Änderungen aktualisiert:

Diagramm, das entsprechend den Änderungen der PivotTable-Liste aktualisiert wurde

Ein Diagramm, das entsprechend den Änderungen der PivotTable-Liste aktualisiert wurde.

In dem vorhergehenden Beispiel wurde das Feld Verkaufsberater in den Spaltenbereich und das Feld Typ in den Zeilenbereich der PivotTable-Liste verschoben. Das Feld Region wurde zu dem Spaltenbereich hinzugefügt und so gefiltert, dass nur Ost und Nord angezeigt werden. Das Diagramm wird so aktualisiert, dass die Daten aus dem Feld Typ in der Legende als Datenreihen und die Daten aus den Feldern Verkaufsberater und Region die Rubriken bilden.

Weitere Informationen

Erstellen eines Diagramms, das auf einer PivotTable-Liste basiert


Erstellen eines Diagramms für das Web, das auf einer PivotTable-Liste basiert

Die jeweiligen Schritte zum Erstellen eines Diagramms, das auf einer PivotTable-Liste basiert, hängen von dem Entwurfsprogramm ab, das Sie zum Entwerfen der Webseite verwenden. Weitere Informationen finden Sie in der Hilfe des betreffenden Programmes. Wenn die Hilfe Ihres Entwurfsprogrammes kein Verfahren zum Erstellen von Steuerelementen, wie z. B. Diagrammen, bietet, führen Sie die folgenden Schritte durch:

  1. Öffnen oder erstellen Sie in Ihrem Entwurfsprogramm die Webseite, auf der das Diagramm angezeigt werden soll.

  2. Falls sich auf der Webseite noch keine PivotTable-Liste befindet, erstellen Sie die PivotTable-Liste.

    Sie müssen mindestens ein Gesamtsummenfeld hinzufügen und die Daten, die im Diagramm angezeigt werden sollen, in die Zeilen- und Spaltenbereiche verschieben. Die Daten in den Zeilen- und Spaltenfeldern werden in dem Diagramm als Reihen und Rubriken verwendet.

  3. Markieren Sie mit Hilfe des Verfahrens des Entwurfsprogrammes zum Hinzufügen eines Steuerelements zu einer Webseite das Diagrammsteuerelement, und legen Sie die Position und Anfangsgröße des Diagramms auf der Webseite fest.

  4. Folgen Sie den Anleitungen im Microsoft Office Diagramm-Assistenten.

Anmerkung In Schritt 3 des Diagramm-Assistenten können Sie angeben, ob die Daten in den Zeilenfeldern oder die Daten in den Spaltenfeldern der PivotTable-Liste die Reihen des Diagramms bilden sollen.


Speichern der Änderungen in einer PivotTable-Liste

Zum Speichern von Änderungen verwenden Sie den Befehl des Entwurfsprogramms, um die Datei, die die PivotTable-Liste enthält, zu speichern. Weitere Informationen zum Befehl Speichern finden Sie in der Hilfe des Entwurfsprogramms.


Löschen einer PivotTable-Liste

Sie können im Browser eine PivotTable-Liste nicht aus einer Webseite löschen.

  1. Markieren Sie in Ihrem Entwurfsprogramm das PivotTable-Listensteuerelement. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Drücken Sie ENTF.


Anzeigen und Verwenden der PivotTable-Eigenschaftentoolbox und der Symbolleiste

Wie möchten Sie verfahren?

Symbolleiste

Informationen zu Symbolleistenschaltflächen und -befehlen

Ausblenden der Symbolleiste

Anzeigen der Symbolleiste, wenn diese ausgeblendet ist

PivotTable-Eigenschaftentoolbox

Verwenden der Toolbox

Informationen zu den Toolboxbefehlen und -optionen

Aufheben der Verfügbarkeit der Toolbox im Browser

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zur PivotTable-Eigenschaftentoolbox und zur Symbolleiste

Symbolleiste Die Symbolleiste in einer PivotTable-Liste wird am oberen Rand der Liste angezeigt und bietet eine Reihe von Befehlen, mit deren Hilfe Sie die Daten in der PivotTable-Liste bei deren Entwurf bearbeiten können. Im Browser können die Benutzer ebenfalls die Symbolleiste verwenden, um mit der PivotTable-Liste zu arbeiten. Bewegen Sie den Zeiger auf eine einzelne Symbolleistenschaltfläche, um den Namen des dazugehörigen Befehls anzuzeigen.

PivotTable-Eigenschaftentoolbox Die Toolbox enthält Befehle, wie z. B. Symbolleiste einblenden, und Eigenschaften, die Sie einstellen können, wie z. B. die Hintergrundfarbe oder Spaltenbreite. Der Inhalt der Toolbox ändert sich, wenn Sie andere Teile einer PivotTable-Liste markieren. Wenn Sie auf der Webseite ein anderes Steuerelement als die PivotTable-Liste oder ein anderes Steuerelement der Microsoft Office-Webkomponente markieren, wird die Toolbox ausgeblendet, bis Sie wieder ein Steuerelement der Office-Webkomponente markieren. Die Toolbox enthält einige Befehle, die auf der Symbolleiste oder in Kontextmenüs nicht verfügbar sind. Zum Anzeigen der Toolbox klicken Sie auf der Symbolleiste in der PivotTable-Liste auf die Schaltfläche Eigenschaftentoolbox [image].

Die Befehle und Eigenschaften in der Toolbox sind auf verschiedene Abschnitte aufgeteilt, die alle durch eine Leiste gekennzeichnet sind, die den Namen des Abschnitts anzeigt. Die verfügbaren Abschnitte ändern sich in Abhängigkeit von dem aktuell markierten Teil der PivotTable-Liste. Wenn Sie die Toolbox zum ersten Mal anzeigen, werden die Befehle und Eigenschaften des Abschnitts Allgemein angezeigt. Sie können den Inhalt der Abschnitte anzeigen (erweitern) und ausblenden, indem Sie auf die Leisten klicken. So verwenden Sie die PivotTable-Eigenschaftentoolbox.

Einige Eigenschaften und Befehle sind in der Toolbox sowohl beim Entwurf der PivotTable-Liste als auch bei der Anzeige im Browser verfügbar. Andere stehen nur zur Verfügung, wenn Sie in einem Entwurfsprogramm arbeiten. Weitere Informationen finden Sie unter den Befehlen und Eigenschaften in der PivotTable-Eigenschaftentoolbox.

Zugriff auf die Symbolleiste und die PivotTable-Eigenschaftentoolbox im Browser Wenn Sie nicht möchten, dass die Benutzer auf die Befehle und Eigenschafteneinstellungen in der Toolbox zugreifen, können Sie die Verfügbarkeit der Toolbox im Browser aufheben.

Wenn Sie nicht möchten, dass Benutzer auf die Symbolleiste im Browser zugreifen, können Sie die Symbolleiste ausblenden. Um sicherzustellen, dass die Benutzer die Symbolleiste nicht wieder anzeigen können, müssen Sie auch die Verfügbarkeit der Toolbox aufheben, da die Toolbox einen Befehl für die erneute Anzeige der Symbolleiste enthält. Darüber hinaus müssen Sie die Titelleiste ausblenden, um den Zugriff auf den Kontextmenübefehl zum Anzeigen der Symbolleiste zu verhindern. Ist die Titelleiste ausgeblendet, wird der Zugriff auf einige Befehle der Symbolleiste nicht verhindert. Diese Befehle stehen in den Kontextmenüs der Felder, Datenelemente und anderer Markierungen weiterhin zur Verfügung.

Wenn Sie nicht möchten, dass Benutzer im Browser Änderungen an der PivotTable-Liste vornehmen können, überlegen Sie sich, die Daten als nicht interaktive HTML-Tabelle zur Verfügung zu stellen. Weitere Informationen, wie z. B. zur Beschränkung des Benutzerzugriffs und alternativer Möglichkeiten zum Veröffentlichen von Daten auf einer Webseite, finden Sie unter Entwerfen einer PivotTable-Liste.


Anzeigen der Symbolleiste in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie mit der rechten Maustaste auf die Titelleiste der PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Symbolleiste.

Anmerkungen

  • Um die Symbolleiste bei ausgeblendeter Titelleiste anzuzeigen, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden und dann auf Symbolleiste [image].

  • Wenn die Symbolleiste im Entwurfsprogramm angezeigt wird, steht die Symbolleiste auch bei der Anzeige der PivotTable-Liste im Browser zur Verfügung.


Ausblenden der Symbolleiste in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die PivotTable-Liste.

  3. Klicken Sie auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden.

  5. Klicken Sie auf Symbolleiste [image].

Anmerkung Um sicherzustellen, dass die Benutzer die Symbolleiste im Browser nicht erneut anzeigen können, müssen Sie darüber hinaus die Verfügbarkeit der PivotTable-Eigenschaftentoolbox aufheben, da die Toolbox einen Befehl enthält, um die Symbolleiste erneut anzuzeigen. Sie müssen weiterhin die Titelleiste ausblenden, um den Zugriff auf den Kontextmenübefehl zum Anzeigen der Symbolleiste zu verhindern. Durch Ausblenden der Titelleiste wird der Zugriff auf einige der Befehle auf der Symbolleiste nicht verhindert. Diese Befehle stehen in den Kontextmenüs für Felder, Datenelemente und weitere Markierungen weiterhin zur Verfügung.


Symbolleistenschaltflächen und -befehle für PivotTable-Listen

Symbolleistenschaltflächen und -befehle sind beim Entwerfen der PivotTable-Liste und bei der Anzeige im Browser identisch.

Office-Logowürfel Office-Logowürfel Zeigt das Dialogfeld Info an, in dem die installierte Version angezeigt wird. Der Würfel dreht sich, während Daten geladen und berechnet werden.

Kopieren Kopiert die markierten Daten aus einer PivotTable-Liste in die Zwischenablage, so dass Sie die Markierung in andere Programme einfügen können. Wenn Sie in Microsoft Excel ein interaktive Kopie benötigen, verwenden Sie stattdessen Nach Excel exportieren [image].

Aufsteigend sortieren Sortiert die Daten in dem markierten Feld in der Reihenfolge A – Z 0 – 9.

Absteigend sortieren Sortiert die Daten in dem markierten Feld in der Reihenfolge Z – A 9 – 0.

AutoFilter Aktiviert oder deaktiviert die Filterung für alle Felder. Sie können die Filterung verwenden, um lediglich die Zeilen oder Spalten anzuzeigen, die den angegebenen Werten entsprechen.

AutoBerechnung Fügt ein Gesamtsummenfeld zur Feldliste hinzu, das die Daten in dem markierten Feld mit Hilfe der Berechnung Summe, Anzahl, Minimum oder Maximum zusammenfasst. Steht in PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, nicht zur Verfügung.

Teilergebnisse Zeigt Teilergebnisse für das markierte Feld an oder blendet die Teilergebnisse aus.

In Zeilenbereich verschieben Verschiebt das markierte Feld, so dass es als Zeilenfeld angezeigt wird. Zeilenfelder fassen Daten in einem Feld zusammen, indem die Datenelemente entlang den Zeilen einer PivotTable-Liste angezeigt werden.

In Spaltenbereich verschieben Verschiebt das markierte Feld, so dass es als Spaltenfeld angezeigt wird. Spaltenfelder fassen Daten in einem Feld zusammen, indem die Datenelemente entlang den Spalten einer PivotTable-Liste angezeigt werden.

In Filterbereich verschieben Verschiebt das markierte Feld, so dass es als Filterfeld angezeigt wird. Filterfelder filtern die gesamte PivotTable-Liste, so dass lediglich die Daten für das ausgewählte Element angezeigt werden.

In Detailbereich verschieben Verschiebt das markierte Feld in den Detailbereich, so dass alle Daten in dem Feld in nicht zusammengefasster Form angezeigt werden. Steht in PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, nicht zur Verfügung.

Heraufstufen Verschiebt das markierte innere Zeilen- oder Spaltenfeld in die nächste äußere Ebene. Wenn eine PivotTable-Liste über mehr als ein Zeilenfeld oder ein Spaltenfeld verfügt, handelt es sich bei den äußeren Feldern um die Felder, die von den Daten weiter weg stehen und sich links von oder über den Daten befinden.

Tieferstufen Verschiebt das markierte äußere Zeilen- oder Spaltenfeld in die nächste innere Ebene. Wenn eine PivotTable-Liste über mehr als ein Zeilenfeld oder ein Spaltenfeld verfügt, handelt es sich bei den inneren Feldern um die Felder, die näher an den Daten stehen und sich rechts von oder unter den Daten.

Erweitern oder Reduzieren Blendet Details aus oder zeigt alle Details für das markierte Feld, Datenelement oder die markierte Zelle im Datenbereich an.

Aktualisieren Aktualisiert die PivotTable-Liste aus der Quelldatenbank, wobei alle neuen Daten angezeigt und alle neuen Felder zur Feldliste hinzugefügt werden.

Nach Excel exportieren Startet oder wechselt zu Microsoft Excel und kopiert die PivotTable-Liste als Excel PivotTable-Bericht in eine neue Arbeitsmappe, der das interaktive Excel-Äquivalent einer PivotTable-Liste darstellt.

Eigenschaftentoolbox Zeigt die PivotTable-Eigenschaftentoolbox an, so dass Sie Befehle ausführen und Eigenschaften festlegen können.

Feldliste Zeigt die Liste der Felder an, die aus den Quelldaten für die PivotTable-Liste zur Verfügung stehen, so dass Sie weitere Felder zur PivotTable-Liste hinzufügen können.

Hilfe Zeigt in einem Entwurfsprogramm die Hilfethemen zum Entwerfen und Verwenden einer PivotTable-Liste an. Zeigt in einem Browser die Hilfethemen zum Verwenden einer PivotTable-Liste im Browser an.


Verwenden der PivotTable-Eigenschaftentoolbox

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Markieren Sie den Teil der PivotTable-Liste, für den Sie Eigenschaften anzeigen oder festlegen bzw. Befehle ausführen möchten.

    Wie wird's gemacht?

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

    Wenn die Symbolleiste nicht angezeigt wird, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox.

  4. Um den Inhalt eines Abschnitts einzublenden oder auszublenden, klicken Sie auf die Leiste mit dem Namen des betreffenden Abschnitts.

    Weitere Informationen finden Sie in der Zusammenfassung der Befehle und Eigenschaften, die in der PivotTable-Eigenschaftentoolbox verfügbar sind.

Anmerkungen

  • Wenn Sie die PivotTable-Eigenschaftentoolbox beim Markieren unterschiedlicher Teile der PivotTable-Liste oder anderer Steuerelemente von Microsoft Office Web Components angezeigt lassen, ändern sich die verfügbaren Abschnitte und deren Inhalte in Abhängigkeit von der aktuellen Markierung.

  • Eigenschaften, die Sie für Gesamtsummen festlegen, wirken sich auf alle Gesamtergebnisse in der PivotTable-Liste aus.

  • Um den Zugriff auf die PivotTable-Eigenschaftentoolbox im Browser zu verhindern, können Sie die Verfügbarkeit der Toolbox aufheben. Die Toolbox steht im Entwurfsprogramm immer zur Verfügung.

  • Weitere Informationen finden Sie unter PivotTable-Eigenschaftentoolbox.


Befehle und Optionen der PivotTable-Eigenschaftentoolbox

Dieses Thema führt alle Eigenschaften und Befehle auf, die in der PivotTable-Eigenschaftentoolbox zur Verfügung stehen. Welche Befehle zur Verfügung stehen, hängt davon ab, welcher Teil der PivotTable-Liste markiert wurde. Weitere Informationen finden Sie unter Elemente, aus denen eine PivotTable-Liste besteht und So markieren Sie Teile einer PivotTable-Liste.

Wenn Sie ein Programm oder Skript für eine PivotTable-Liste schreiben, können Sie Referenzinformationen zu den Objekten, Methoden und Eigenschaften, die von den Optionen und Befehlen der PivotTable-Eigenschaftentoolbox verwendet werden, in der Microsoft Office Web Components Visual Basic Reference finden.

So finden Sie in diesem Thema schnell Befehle oder Eigenschaften Um Informationen über einen bestimmten Befehl oder eine bestimmte Eigenschaft zu finden, klicken Sie im Hilfenavigationsfenster auf die Registerkarte Suchen, geben den Namen des Befehls oder der Eigenschaft oben auf der Registerkarte im Feld Zu suchendes Schlüsselwort ein, und klicken dann auf Themenliste. Klicken Sie auf den Namen des betreffenden Themas und dann auf Anzeigen. Wenn Sie in dem betreffenden Thema einen Bildlauf durchführen, werden alle Vorkommen des eingegebenen Namen hervorgehoben. Um die Suchbegriffhervorhebung zu aktivieren oder zu deaktivieren, klicken Sie im Hilfefenster in der Symbolleiste auf Optionen [image] und dann auf Suchbegriffhervorhebung aktivieren oder Suchbegriffhervorhebung deaktivieren.

So suchen Sie einen Befehl oder eine Eigenschaft mit Hilfe der folgenden Liste Klicken Sie auf das Element in der Liste, das die aktuelle Auswahl in der PivotTable-Liste beschreibt:

Alle Markierungen

Die gesamte PivotTable-Liste

Ein Detailfeld

Ein Zeilen- oder Spaltenfeld

Ein Filterfeld

Ein Gesamtsummenfeld

Ein Datenelement in einem Feld

Ein Teilergebnis oder ein Gesamtergebnis

Zurück zum Anfang

Alle Markierungen

Die folgenden Optionen stehen immer zur Verfügung, wenn Sie die PivotTable-Eigenschaftentoolbox anzeigen, unabhängig davon, was in der PivotTable-Liste markiert wurde, z. B. beim Markieren einer Zelle oder eines Zellenbereichs. Diese Optionen stehen im Entwurfsprogramm und im Browser zur Verfügung.

Option | Beschreibung
Leiste Allgemein
Feld Markierung | Kennzeichnet den aktuell in der PivotTable-Liste markierten Teil.
Hilfe | Zeigt Hilfethemen an.
Leiste Ein-/Ausblenden
Titelleiste | Zeigt die Titelleiste oben in der PivotTable-Liste an. Dieser Befehl steht zur Verfügung, wenn Sie Daten zu einer neuen PivotTable-Liste hinzufügen.
Symbolleiste | Zeigt die Symbolleiste in der PivotTable-Liste an.
Feldliste | Zeigt die Feldliste für die PivotTable-Liste an.
Erweiterungssymbole | Zeigt neben Datenelementen in Zeilen- und Spaltenfeldern, für die Detaildaten angezeigt oder ausgeblendet werden können, Erweiterungssymbole an.
Dropbereiche | Zeigt die Konturen und Beschriftungen der Dropbereiche an. Dieser Befehl steht zur Verfügung, sobald Sie Daten zu einer neuen PivotTable-Liste hinzufügen.

Zurück zum Anfang

Die gesamte PivotTable-Liste

Die Abschnitte Datenquelle und Erweitert stehen in einer neuen PivotTable-Liste auch vor dem Hinzufügen von Daten zur Verfügung.

Option | Beschreibung
Leiste Format
Feld PivotTable-Titel | Gibt den Text der Titelleiste am Anfang der PivotTable-Liste an.
Hintergrund | Legt die Hintergrundfarbe in einer PivotTable-Liste fest.
Leiste Datenquelle (nicht im Browser verfügbar)
Option und Liste Datenquellen-Steuerelement | Gibt ein Datenquellen-Steuerelement auf der Webseite an, das die Quelldaten bereitstellt.
Option und Feld Verbindung | Stellt eine Verbindungszeichenfolge bereit, um zu der PivotTable-Liste Daten hinzuzufügen.
Schaltfläche Verbindungseditor | Erstellt eine Verbindungszeichenfolge aus Datenquelleninformationen, die im Dialogfeld Datenlinkeigenschaften eingegeben wurden.
Option und Liste Datenmitglied | Gibt die Daten von einem bestimmten Element in der Datenbank als Quelldaten an.
Option und Feld Befehlstext | Stellt eine Abfrage oder einen Befehl, wie z. B. eine SQL-Anweisung, bereit, um Daten aus der Datenbank auszuwählen.
Leiste Gesamtsummen
Kontrollkästchen Zwischensummen für gefilterte Elemente | Beim Berechnen von Teilergebnissen und Gesamtergebnissen werden die Werte von Datenelementen, die durch eine Filterung ausgeblendet sind, eingeschlossen.
Liste Summenorientierung | Zeigt Gesamtsummenfelder in Zeilen- oder Spaltenausrichtung an.
Leiste Leere Elemente anzeigen
Kontrollkästchen Zeile | Zeigt Elemente ohne Daten in Zeilenfeldern an.
Kontrollkästchen Spalte | Zeigt Elemente ohne Daten in Spaltenfeldern an.
Leiste Format - Detaildaten (im Browser nicht verfügbar)
Kontrollkästchen Detaildaten automatisch anpassen | Ermöglicht das Vergrößern oder Verkleinern des Detailbereichs auf die zum Anzeigen der Daten erforderliche Größe.
Feld Maximale Breite | Legt die größte Breite fest, auf die der Detailbereich vergrößert werden kann, wenn AutoAnpassen aktiviert ist.
Feld Maximale Höhe | Legt die größte Höhe fest, auf die der Detailbereich vergrößert werden kann, wenn AutoAnpassen aktiviert ist.
Feld Detailbereichsbreite | Legt eine feste Breite für den Detailbereich fest, wenn AutoAnpassen deaktiviert ist.
Feld Detailbereich-Zeilenhöhe | Legt die Zeilenhöhe für Zeilen im Detailbereich fest.
Format - Titelleiste- Leiste (im Browser nicht verfügbar)
Textformat | Zeigt den Titelleistentext fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart für den Titelleistentext anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe für den Titelleistentext anhand der auf dem System verfügbaren Schriftgrößen fest.
Hintergrund | Legt die Hintergrundfarbe für die Titelleiste fest.
Leiste Dropbereichbeschriftungen (im Browser nicht verfügbar)
Feld Zeilenbereich | Gibt den Text für den Zeilenfeld-Dropbereich an.
Feld Spaltenbereich | Gibt den Text für den Spaltenfeld-Dropbereich an.
Feld Detailbereich | Gibt den Text für den Detailfeld- und Datenfeld-Dropbereich an.
Feld Filterbereich | Gibt den Text für den Filterfeld-Dropbereich an.
Textformat | Zeigt die Dropbereich-Beschriftungen fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart für die Dropbereich-Beschriftungen anhand der Liste der auf dem System verfügbaren Schriftarten an.
Liste Größe | Legt die Größe des Dropbereich-Beschriftungstextes anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe für die Dropbereiche fest.
Leiste Erweitert (im Browser nicht verfügbar)
Liste Elemente standardmäßig erweitern | Zeigt automatisch die Detaildaten für alle Elemente an, wenn die PivotTable-Liste zum ersten Mal angezeigt wird.
Kontrollkästchen Details zulassen | Lässt die Anzeige von Detaildaten im Browser zu.
Kontrollkästchen Eigenschaftentoolbox zulassen | Lässt den Zugriff auf die PivotTable-Eigenschaftentoolbox im Browser zu.
Kontrollkästchen Filter sperren | Verhindert Änderungen der Filterung und der Datenelemente, die im Browser angezeigt werden oder ausgeblendet sind.
Kontrollkästchen Zeilen-/Spaltenfelder sperren | Hindert Benutzer daran, Felder im Browser in die oder aus den Zeilen- und Spaltenbereichen zu verschieben.
Kontrollkästchen Automatisch anpassen | Ermöglicht das Vergrößern oder Verkleinern der gesamten PivotTable-Liste auf die zum Anzeigen der Daten erforderliche Größe.
Feld Maximale Höhe | Legt die größte Höhe fest, auf die die gesamte PivotTable-Liste vergrößert werden kann, wenn AutoAnpassen aktiviert ist.
Feld Maximale Breite | Legt die größte Breite fest, auf die die gesamte PivotTable-Liste vergrößert werden kann, wenn AutoAnpassen aktiviert ist.
Feld Höhe | Legt eine feste Höhe für die gesamte PivotTable-Liste fest, wenn AutoAnpassen deaktiviert ist.
Feld Breite | Legt eine feste Breite für die gesamte PivotTable-Liste fest, wenn AutoAnpassen deaktiviert ist.
Kontrollkästchen Von rechts nach links anzeigen | Zeigt die PivotTable-Liste von rechts nach links zur Anzeige in Sprachen mit Schreibweise von rechts nach links an.
Text Detaildaten verfügbar | Zeigt an, ob die Quelldaten Detaildaten enthalten.

Zurück zum Anfang

Ein Detailfeld

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Datenzellen für das Detailfeld fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart der Datenzellen für das Detailfeld anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen der Datenzellen für das Detailfeld anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe der Datenzellen für das Detailfeld fest.
Liste Horizontale Ausrichtung | Legt die Ausrichtung für den Text in den Datenzellen für das Detailfeld fest.
Liste Zahlenformat | Legt das Anzeigeformat für Zahlen in den Datenzellen für das Detailfeld fest. Weitere Informationen finden Sie in der Liste der verfügbaren Zahlenformate.
Feld Breite | Legt die Breite der Spalten in Pixel fest, die im Detailfeld angezeigt werden.
Kontrollkästchen Optimale Feldbreite | Lässt ein Vergrößern oder Verkleinern der Spaltenbreite für das Detailfeld auf die für die Anzeige der Daten erforderliche Größe zu.
Leiste Beschriftungen
Feld Beschriftung | Gibt die Bezeichnung für das Feld an.
Feld Fieldsetbeschriftung | Gibt für ein Feld, das Bestandteil einer OLAP-Dimension ist, die Bezeichnung der Dimension an.
Leiste Sortieren
Liste Sortierrichtung | Sortiert die Datenelemente im Feld in der Reihenfolge Aufsteigend, Absteigend oder Standard. Die Standardsortierreihenfolge ist die Reihenfolge, in der die Elemente von der Quelldatenbank geladen werden.
Leiste Erweitert (im Browser nicht verfügbar)
Text Basisfeldname | Zeigt den Namen des Feldes in der ursprünglichen Quelldatenbank.
Text Datenfeld | Wenn die Quelldaten für die PivotTable-Liste nicht aus einer OLAP-Cubedatenbank stammen, wird der Name des Feldes in den Quelldaten angezeigt, das die Daten für dieses Feld angibt.
Text Datentyp | Zeigt den Datentyp des Feldes in den Quelldaten an.
Text Feldname | Zeigt den Namen des Feldes in der PivotTable-Liste an.
Text Feldtyp | Zeigt den Feldtyp an: Normal, Zeit, Unbekannt oder Benutzerdefiniert.
Text Fieldsetorientierung | Kennzeichnet, in welchem Bereich das Feld aktuell angezeigt wird.
Text Fieldsettyp | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Typ der Dimension an: Zeit, Sonstige, Unbekannt oder Benutzerdefiniert.
Text Fieldsetname | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Namen der Dimension an.

Zurück zum Anfang

Ein Zeilen- oder Spaltenfeld

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Feldbezeichnung fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart für die Feldbezeichnung anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen für die Feldbezeichnung anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe für die Feldbezeichnung fest.
Feld Breite | Legt die Breite der Spalte in Pixel fest, in der das Feld angezeigt wird.
Kontrollkästchen Optimale Feldbreite | Lässt ein Vergrößern oder Verkleinern der Spaltenbreite für das Feld auf die für die Anzeige der Daten erforderliche Größe zu.
Leiste Beschriftungen
Feld Beschriftung | Gibt den Text für die Feldbezeichnung an.
Feld Fieldsetbeschriftung | Gibt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Text für die Dimensionsbezeichnung an.
Leiste Sortieren
Liste Sortierrichtung | Sortiert die Datenelemente im Feld in der Reihenfolge Aufsteigend, Absteigend oder Standard. Die Standardsortierreihenfolge ist die Reihenfolge, in der die Elemente von der Quelldatenbank geladen werden.
Leiste Erweitert (im Browser nicht verfügbar)
Text Basisfeldname | Zeigt den Namen des Feldes in der ursprünglichen Quelldatenbank.
Text Datenfeld | Wenn die Quelldaten für die PivotTable-Liste nicht aus einer OLAP-Cubedatenbank stammen, wird der Name des Feldes in den Quelldaten angezeigt, das die Daten für dieses Feld zur Verfügung stellt.
Text Datentyp | Zeigt den Datentyp des Feldes in den Quelldaten an.
Text Feldname | Zeigt den Namen des Feldes in der PivotTable-Liste an.
Text Feldtyp | Zeigt den Feldtyp an: Normal, Zeit, Unbekannt oder Benutzerdefiniert.
Text Fieldsetorientierung | Kennzeichnet, in welchem Bereich das Feld aktuell angezeigt wird.
Text Fieldsettyp | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Typ der Dimension an: Zeit, Sonstige, Unbekannt oder Benutzerdefiniert.
Text Fieldsetname | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Namen der Dimension an.

Zurück zum Anfang

Ein Filterfeld

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Feldbezeichnung fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart für die Feldbezeichnung anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen für die Feldbezeichnung anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe für die Feldbezeichnung fest.
Leiste Beschriftungen
Feld Beschriftung | Gibt die Bezeichnung für das Feld an.
Feld Fieldsetbeschriftung | Gibt für ein Feld, das Bestandteil einer OLAP-Dimension ist, die Bezeichnung der Dimension an.
Leiste Erweitert (im Browser nicht verfügbar)
Text Basisfeldname | Zeigt den Namen des Feldes in der ursprünglichen Quelldatenbank.
Text Datenfeld | Wenn die Quelldaten für die PivotTable-Liste nicht aus einer OLAP-Cubedatenbank stammen, wird der Name des Feldes in den Quelldaten angezeigt, das die Daten für dieses Feld zur Verfügung stellt.
Text Datentyp | Zeigt den Datentyp des Feldes in den Quelldaten an.
Text Feldname | Zeigt den Namen des Feldes in der PivotTable-Liste an.
Text Feldtyp | Zeigt den Feldtyp an: Normal, Zeit, Unbekannt oder Benutzerdefiniert.
Text Fieldsetorientierung | Kennzeichnet, in welchem Bereich das Feld aktuell angezeigt wird.
Text Fieldsettyp | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Typ der Dimension an: Zeit, Sonstige, Unbekannt oder Benutzerdefiniert.
Text Fieldsetname | Zeigt für ein Feld, das Bestandteil einer OLAP-Dimension ist, den Namen der Dimension an.

Zurück zum Anfang

Ein Gesamtsummenfeld

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Datenzellen für das Gesamtsummenfeld fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart der Datenzellen für das Gesamtsummenfeld anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen der Datenzellen für das Gesamtsummenfeld anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe der Datenzellen für das Gesamtsummenfeld fest.
Liste Horizontale Ausrichtung | Legt die Ausrichtung des Textes in den Datenzellen für das Gesamtsummenfeld fest.
Liste Zahlenformat | Legt das Anzeigeformat für die Zahlen Datenzellen für das Gesamtsummenfeld fest. Weitere Informationen finden Sie in der Liste der verfügbaren Zahlenformate.
Feld Breite | Legt die Breite der Spalten in Pixel fest, in denen das Gesamtsummenfeld angezeigt wird.
Kontrollkästchen Optimale Feldbreite | Lässt ein Vergrößern oder Verkleinern der Spaltenbreite des Gesamtsummenfeldes auf die zum Anzeigen der Daten erforderliche Größe zu.
Leiste Gesamtsummenbeschriftung
Feld Beschriftung | Gibt die Bezeichnung für das Gesamtsummenfeld an.
Liste Ausrichtung innerhalb von Zeilen | Richtet die Teilergebnis- und Gesamtergebniselemente im Gesamtsummenfeld in Bezug auf den Detailbereich aus, sofern dieser angezeigt wird. Folgende Ausrichtungen sind möglich: Automatisch, Links, Zentriert oder Rechts. Bei Automatisch wird die Standardausrichtung (links) ausgewählt.
Leiste Gesamtsummenfunktion
Liste Funktion | Legt die Zusammenfassungsfunktion für das Gesamtsummenfeld fest.
Leiste Erweitert (im Browser nicht verfügbar)
Text Summenquellfeld | Zeigt den Namen des Feldes in den Quelldaten an, das die zum Berechnen der Gesamtsummen verwendeten Werte zur Verfügung stellt.
Text Summenname | Zeigt den Namen des Gesamtsummenfeldes an.
Text Summentyp | Zeigt den Summentyp an. Berechnet verwendet eine der integrierten Zusammenfassungsfunktionen. Benutzerdefiniert verwendet ein benutzerentwickeltes Programm oder Skript.

Zurück zum Anfang

Ein Datenelement in einem Feld

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Elementbezeichnung fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart der Elementbezeichnung anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen für die Elementbezeichnung anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe für die Elementbezeichnung fest.
Liste Horizontale Ausrichtung | Legt die Textausrichtung in der Zelle für die Elementbezeichnung fest.
Leiste Erweitert (im Browser nicht verfügbar)
Text Elementname | Zeigt den Namen des Elements aus den Quelldaten an.
Text Eindeutiger Elementname | Zeigt den vollständigen Elementnamen einschließlich des Feldnamens und, sofern das Element aus einer OLAP-Datenbank stammt, den Dimensionsnamen an.
Text Elementbeschriftung | Zeigt die Bezeichnung des Elements in der PivotTable-Liste an.

Zurück zum Anfang

Ein Teilergebnis oder ein Gesamtergebnis

Option | Beschreibung
Leiste Format
Textformat | Zeigt die Datenzellen für das Teilergebnis oder Gesamtergebnis fett, kursiv oder unterstrichen an und legt die Zeichenfarbe fest.
Liste Schriftart | Legt die Schriftart der Datenzellen für das Teilergebnis oder Gesamtergebnis anhand der Liste der auf dem System verfügbaren Schriftarten fest.
Liste Größe | Legt die Größe der Zeichen der Datenzellen für das Teilergebnis oder Gesamtergebnis anhand der auf dem System verfügbaren Schriftgrade fest.
Hintergrund | Legt die Hintergrundfarbe der Datenzellen für das Teilergebnis oder Gesamtergebnis fest.

Zurück zum Anfang


Aufheben der Verfügbarkeit der PivotTable-Eigenschaftentoolbox

Dieses Verfahren hebt die Verfügbarkeit der PivotTable-Eigenschaftentoolbox im Browser zur Laufzeit auf. Sie können die PivotTable-Eigenschaftentoolbox im Entwurfsprogramm weiterhin verwenden.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Deaktivieren Sie das Kontrollkästchen Eigenschaftentoolbox zulassen.

Anmerkung Diese Einstellung kann im Browser nicht geändert werden. Im Entwurfsprogramm ist die PivotTable-Eigenschaftentoolbox immer verfügbar, und diese Einstellung hat darauf keine Auswirkung.


Hinzufügen von Feldern zu einer PivotTable-Liste

Wie möchten Sie verfahren?

Hinzufügen von Feldern

Zeilen- oder Spaltenfeld

Datenfeld

Filterfeld

Detailfeld

Gesamtsummenfeld

Angeben der Verwendung von Feldern

Anzeigen von Informationen über ein Feld und seine Quelldaten

Verhindern, dass Zeilen- und Spaltenfelder hinzugefügt und verschoben werden

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Hinzufügen von Feldern zu einer PivotTable-Liste

Wenn Sie die Daten zu einer PivotTable-Liste hinzufügen, geben Sie die Datenbank an, aus der die Daten übernommen werden sollen, sowie die Teilmenge der Daten, die als Quelldaten für die PivotTable-Liste zur Verfügung gestellt werden sollen. Aus diesen Quelldaten können Sie die Felder auswählen, die zu Beginn in der PivotTable-Liste angezeigt werden sollen. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

Anzeigen der verfügbaren Felder Klicken Sie in der PivotTable-Liste auf der Symbolleiste auf Felder anzeigen [image], um die Liste der Felder anzuzeigen, die von den Quelldaten verfügbar sind, und um Felder zu den Zeilen-, Spalten-, Filter-, Daten- und Detailbereichen der PivotTable-Liste hinzuzufügen. Felder, die in der Feldliste nicht fett angezeigt werden, stehen zur Verfügung, werden in der PivotTable-Liste jedoch noch nicht angezeigt. Die fett formatierten Felder werden bereits angezeigt. Sie können einen Bildlauf durchführen und auf das Kästchen Pluskästchen klicken, um weitere Felder anzuzeigen, und auf das Kästchen Minuskästchen klicken, um weniger Felder anzuzeigen.

Einschränkungen bei den Quelldaten Wenn Ihre PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, die beispielsweise mit Hilfe der Microsoft SQL Server OLAP-Dienste erstellt wurde, werden Sie feststellen, dass Sie keine Felder in den Detailbereich verschieben können. Sie werden weiterhin feststellen, dass einige Felder lediglich in die Zeilen-, Spalten- und Filterbereiche verschoben werden können. Weitere Felder, die unter Gesamtsummen aufgeführt sind, können nur als Datenfelder verwendet werden.

Hinzufügen von Feldern

Detailfelder Um alle verfügbaren Detaildaten anzuzeigen und festzustellen, welche Daten für eine Zusammenfassung zur Verfügung stehen, verwenden Sie Detailfelder. Wenn Sie Felder zu dem Detailbereich hinzufügen, können Sie für die Felder alle Detaildatensätze aus den Quelldaten anzeigen. Feldnamen werden zu Spaltenbeschriftungen, und die Detaildatensätze werden in den Zeilen unter den Spaltenbeschriftungen angezeigt.

Beispiel für Detailfelder

Zeilen- und Spaltenfelder Mit Hilfe von Zeilen- und Spaltenfeldern können Sie Daten zusammenfassen und vergleichen. In diesen Feldern werden die eindeutigen Datenelemente in einem Feld spaltenweise oder zeilenweise angezeigt. Die Zelle in jedem Zeilen- und Spaltenschnittpunkt fasst die Daten eines Elements zusammen. Weitere Informationen finden Sie unter Hinzufügen von Zeilen- und Spaltenfeldern.

Beispiel für Zeilen- und Spaltenfelder

Datenfelder Datenfelder liefern die Werte, die in der PivotTable-Liste zusammengefasst werden sollen. Wenn Sie ein Feld zum Datenbereich hinzufügen, werden die Werte des Feldes für die Zeilen- und Spaltenfeldelemente zusammengefasst.

Beispiel für ein Datenfeld

Filterfelder Ein Filterfeld lässt sich mit einem Seitenfeld in einem Microsoft Excel PivotTable-Bericht vergleichen. Mit Hilfe von Filterfeldern können Sie die Ansicht auf einen bestimmten Teil der verfügbaren Daten einschränken. Wenn Sie ein Filterfeld hinzufügen, werden die Daten aller Elemente in diesem Feld anfänglich in der Ansicht zusammengefasst. Wenn Sie ein Element in einem Filterfeld auswählen, werden die Daten lediglich für das betreffende Element angezeigt und berechnet. Wenn Sie beispielsweise ein Bereichsfilterfeld hinzufügen, können Sie in der PivotTable-Liste die Daten für einen einzigen Bereich anzeigen und berechnen lassen. Weitere Informationen finden Sie unter Hinzufügen eines Filterfeldes.

Beispiel für ein Filterfeld

Verschieben von Feldern Nachdem Sie ein Feld zu einer PivotTable-Liste hinzugefügt haben, können Sie es in andere Bereiche verschieben. Beim Verschieben eines Feldes wird das Layout der PivotTable-Liste sowie die angezeigten Daten und die berechneten Zusammenfassungen geändert.

Hinzufügen von Berechnungen für Zusammenfassungen Sie können neue Datenfelder hinzufügen, indem Sie Gesamtsummenfelder zu der PivotTable-Liste hinzufügen. Gesamtsummenfelder liefern zusammengefasste Daten, die als Datenfelder verwendet werden können. Wenn die Quelldaten beispielsweise ein Feld Absatz enthalten, in dem der Umfang aller Verkäufe angezeigt werden, können Sie das Gesamtsummenfeld Summe der Verkäufe hinzufügen, um die Gesamtverkaufszahlen zu berechnen, oder das Gesamtsummenfeld Verkaufszahlen, um die Anzahl der verkauften Einheiten zu berechnen. Weitere Informationen finden Sie unter Gesamtsummen in PivotTable-Listen.

Entfernen von Feldern Zum Löschen von Daten, die nicht angezeigt oder zusammengefasst werden sollen, können Sie aus dem PivotTable-Layout Felder entfernen. Durch das Entfernen eines Feldes wird es nicht aus den verfügbaren Quelldaten entfernt. Ein Feld, das entfernt wird, wird in der PivotTable-Liste nicht mehr angezeigt, steht in der Feldliste aber weiterhin zur Anzeige zur Verfügung.

Angeben der Verwendung der Felder

Die Features zum Hinzufügen von Feldern und zum Erstellen von Zusammenfassungen sind ebenfalls im Browser verfügbar, solange der Zugriff des Benutzers nicht eingeschränkt wurde. Weitere Informationen finden Sie unter Arbeiten mit PivotTable-Listen und Erstellen von Zusammenfassungen im Browser.

Anzeigen von Informationen über Felder Sie können Informationen über die Felder in einer PivotTable-Liste anzeigen, wie z. B. Informationen über das Feld in der Quelldatenbank, aus der die Daten stammen, und den Datentyp, den die Quelldatenbank für das Feld bereitstellt. Diese Informationen stehen den Benutzern im Browser nicht zur Verfügung.

Beschränken von Layoutänderungen im Browser Wenn Sie nicht möchten, dass Benutzer ändern, welche Felder als Zeilen- und Spaltenfelder festgelegt wurden, können Sie verhindern, dass Zeilen- und Spaltenfelder im Browser hinzugefügt und verschoben werden. Darüber hinaus können Sie den Zugriff auf Details einschränken, damit Benutzer keine Felder in den Detailbereich verschieben können, sowie den Zugriff auf die Filterung einschränken, damit Benutzer keine Felder in den Filterbereich verschieben können.


Hinzufügen eines neuen Zeilen- oder Spaltenfeldes zu einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Feldliste [image].

  3. Verwenden Sie die Bildlaufleisten und die Kästchen Pluskästchen und Minuskästchen, um das Feld zu suchen, das zu der PivotTable-Liste hinzugefügt werden soll.

  4. Klicken Sie auf das Feld.

  5. Führen Sie in der Liste in der unteren rechten Ecke der Feldliste einen der folgenden Schritte durch

    Um ein neues Zeilenfeld hinzuzufügen, klicken Sie auf Zeilenbereich.

    Um ein neues Spaltenfeld hinzuzufügen, klicken Sie auf Spaltenbereich.

  6. Klicken Sie auf Hinzufügen zu.

Anmerkungen

  • Wenn Hinzufügen zu bei der Auswahl von Zeilenbereich oder Spaltenbereich nicht mehr verfügbar ist, kann das ausgewählte Feld möglicherweise nicht als Zeilen- oder Spaltenfeld verwendet werden. Wenn die PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste nicht unter Gesamtsummen aufgeführt sind, als Zeilen- und Spaltenfelder verwendet werden.

  • Wenn Sie nicht möchten, dass Benutzer neue Zeilen- und Spaltenfelder hinzufügen, können Sie verhindern, dass Zeilen- und Spaltenfelder im Browser hinzugefügt und verschoben werden.


Hinzufügen eines neuen Datenfeldes zu einer PivotTable-Liste

Datenfelder, die numerische Daten zusammenfassen, verwenden die Zusammenfassungsfunktion Summe. Felder, die andere Datentypen zusammenfassen, verwenden die Zusammenfassungsfunktion Anzahl. Weitere Informationen finden Sie unter Anzeigen des Datentyps eine Feldes.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Feldliste [image].

  3. Verwenden Sie die Bildlaufleisten und die Kästchen Pluskästchen und Minuskästchen, um das Feld zu suchen, das zu der PivotTable-Liste hinzugefügt werden soll.

  4. Klicken Sie auf das Feld und in der Liste in der unteren rechten Ecke der Feldliste auf Datenbereich.

  5. Klicken Sie auf Hinzufügen zu.

Anmerkung Wenn Hinzufügen zu bei der Auswahl von Datenbereich nicht mehr verfügbar ist, kann das ausgewählte Feld möglicherweise nicht als Datenfeld verwendet werden. Wenn die PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste nicht unter Gesamtsummen aufgeführt sind, als Datenfelder verwendet werden.


Hinzufügen eines neuen Filterfeldes zu einer PivotTable-Liste

Wenn Sie ein Filterfeld hinzufügen, können Sie die ganze PivotTable-Liste filtern, damit nur das Element, das in der Dropdownliste des Filterfeldes ausgewählt wurde, angezeigt wird.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Feldliste [image].

  3. Verwenden Sie die Bildlaufleisten und die Kästchen Pluskästchen und Minuskästchen, um das Feld zu suchen, das zu der PivotTable-Liste hinzugefügt werden soll.

  4. Klicken Sie auf das Feld und in der Liste in der unteren rechten Ecke der Feldliste auf Filterbereich.

  5. Klicken Sie auf Hinzufügen zu.

Anmerkungen

  • Wenn Hinzufügen zu bei der Auswahl von Filterbereich nicht mehr verfügbar ist, kann das ausgewählte Feld möglicherweise nicht als Filterfeld verwendet werden. Wenn die PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste nicht unter Gesamtsummen aufgeführt sind, als Filterfelder verwendet werden.

  • Wenn Sie nicht möchten, dass Benutzer neue Filterfelder hinzufügen, können Sie die Verfügbarkeit der Filterbefehle im Browser aufheben.


Hinzufügen eines neuen Detailfeldes zu einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Feldliste [image].

  3. Verwenden Sie die Bildlaufleisten und die Kästchen Pluskästchen und Minuskästchen, um das Feld zu suchen, das zu der PivotTable-Liste hinzugefügt werden soll.

  4. Klicken Sie auf das Feld und in der Liste in der unteren rechten Ecke der Feldliste auf Detaildaten.

  5. Klicken Sie auf Hinzufügen zu.

Anmerkungen

  • Wenn Hinzufügen zu bei der Auswahl von Detaildaten nicht mehr verfügbar ist, stehen möglicherweise keine Detaildaten aus den Quelldaten zur Verfügung. Wenn die PivotTable-Liste beispielsweise auf Quelldaten aus einer OLAP-Datenbank basiert, stehen oftmals nur Zusammenfassungsdaten und keine Detaildaten zur Verfügung.

  • Wenn Sie nicht möchten, dass Benutzer neue Detailfelder hinzufügen, können Sie im Browser den Zugriff auf Details einschränken.


Verhindern, dass Zeilen- und Spaltenfelder in einer PivotTable-Liste hinzugefügt oder verschoben werden

Dieses Verfahren verhindert, dass Benutzer Zeilen- und Spaltenfelder im Browser hinzufügen oder verschieben. Nach Abschluss des Verfahrens können Sie jedoch im Entwurfsprogramm keine weiteren Felder hinzufügen oder verschieben.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Aktivieren Sie das Kontrollkästchen Zeilen-/Spaltenfelder sperren.

Anmerkungen

  • Diese Einstellung kann im Browser nicht geändert werden.

  • Wenn Sie darüber hinaus nicht möchten, dass Benutzer die Felder im Filterbereich hinzufügen oder verschieben können, können Sie die Verfügbarkeit der Filterbefehle im Browser aufheben.

  • Wenn Sie darüber hinaus nicht möchten, dass Benutzer die Felder im Detailbereich hinzufügen oder verschieben können, können Sie den Zugriff auf Details im Browser einschränken.

  • In Microsoft Excel hat diese Einschränkung keine Auswirkung. Benutzer, die eine PivotTable-Liste aus dem Browser nach Excel exportieren, können anschließend die Excel-Features verwenden, um beliebige in den Quelldaten verfügbare Felder hinzuzufügen und zu verschieben. Um Benutzer daran zu hindern, Felder auf diese Weise zu verschieben, können Sie den Zugriff auf den Befehl Nach Excel exportieren im Browser einschränken, indem Sie die Symbolleiste deaktivieren und den Zugriff auf die PivotTable-Eigenschaftentoolbox beschränken. Weitere Informationen finden Sie unter Einschränken des Zugriffs auf Features im Browser.


Anzeigen von Informationen zu einem Feld und seinen Quelldaten in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Feld, für das Sie Informationen anzeigen möchten.

    Weitere Informationen zu einem Datenelement in einem Feld erhalten Sie, wenn Sie auf das Element klicken.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

    Weitere Informationen finden Sie unter Informationen, die über Felder und Elemente angezeigt werden.

Anmerkung Diese Informationen können im Browser nicht angezeigt werden.


Entfernen eines Feldes aus einer PivotTable-Liste

Wenn Sie ein Feld aus dem Layout einer PivotTable-Liste entfernen, werden die Daten des Feldes nicht mehr angezeigt; das Feld steht jedoch in der Feldliste weiterhin zur Anzeige zur Verfügung.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Feldbezeichnung des Feldes, das aus der PivotTable-Liste entfernt werden soll.

  3. Ziehen Sie das Feld aus der PivotTable-Liste heraus, bis sich der Zeiger in Zeiger mit rotem X ändert.

Anmerkung Um ein Gesamtsummenfeld sowohl aus der PivotTable-Liste als auch der Feldliste zu entfernen, klicken Sie mit der rechten Maustaste auf das Gesamtsummenfeld, und klicken Sie dann im Kontextmenü auf Löschen.


Ändern des Layouts einer PivotTable-Liste

Wie möchten Sie verfahren?

Angeben, wie Felder verschoben werden können

Anzeigen der Dropbereiche zum Verschieben und Hinzufügen von Feldern

Verhindern, dass Zeilen- und Spaltenfelder hinzugefügt und verschoben werden

Verschieben von Feldern

Verschieben eines Feldes in den Zeilen- oder Spaltenbereich

Verschieben eines Feldes in den Datenbereich

Verschieben eines Feldes in den Filterbereich

Verschieben eines Zeilen- oder Spaltenfeldes auf eine höhere Ebene

Verschieben eines Zeilen- oder Spaltenfeldes auf eine niedrigere Ebene

Verschieben eines Feldes in den Detailbereich

Hinzufügen oder Löschen von Feldern

Hinzufügen neuer Felder

Entfernen eines Feldes

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Ändern des Layouts einer PivotTable-Liste

Sie können ändern, wie die Daten in einer PivotTable-Liste zusammengefasst werden, indem Sie das Layout ändern. Mit einem anderen Layout können Sie zusammengefasste Werte für unterschiedliche Elementen in Ihren Daten berechnen oder vergleichen bzw. Zusammenfassungen für eine Teilmenge der Daten anzeigen. Wenn Sie die PivotTable-Liste im Browser den Benutzern zur Verfügung stellen, können die Benutzer weitere Änderungen an Ihrem Anfangslayout vornehmen.

Verwenden der Dropbereiche Sie ändern das Layout, indem Sie die Felder in vordefinierte Ablagebereiche im Arbeitsbereich der PivotTable-Liste verschieben. Um die Umrisse dieser Dropbereiche zu sehen, sofern diese ausgeblendet wurden, zeigen Sie die Dropbereiche an.

Beispiel für Dropbereiche

Nachdem die Felder in die Dropbereiche verschoben wurden, so dass die Beschriftungen der Dropbereiche abgedeckt sind, können Sie weiterhin Felder in den Bereichen ablegen oder die Felder mit Hilfe der Befehle auf der Symbolleiste verschieben.

Verschieben von Feldern in die Zeilen- und Spaltenbereiche Wenn Sie ein Feld in den Zeilenbereich verschieben, werden die eindeutigen Datenelemente in dem Feld in der PivotTable-Liste zeilenweise angezeigt. Wenn Sie ein Feld in den Spaltenbereich verschieben, werden die eindeutigen Datenelemente spaltenweise angezeigt.

Ändern der Ebene von Zeilen- oder Spaltenfeldern Verfügt eine PivotTable-Liste über mehrere Zeilen- und Spaltenfelder, werden die Felder, die den zusammengefassten Daten am nächsten liegen, als innere Felder bezeichnet und die anderen Felder als äußere Felder. Für innere Felder können mehr Details angezeigt werden als für äußere Felder.

Beispiel für innere und äußere Zeilenfelder

Sie können die Anordnung dieser Felder ändern, indem Sie Felder auf eine höhere Ebene bewegen, so dass innere Felder zu äußeren Feldern werden, bzw. die Felder in eine niedrigere Ebene verschieben.

Verschieben von Feldern in den Filterbereich Ein Filterfeld lässt sich mit einem Seitenfeld in einem Microsoft Excel PivotTable-Bericht vergleichen. Filterfelder ermöglichen es Ihnen, die Ansicht auf einen bestimmten Teil der verfügbaren Daten zu beschränken. Wenn Sie beispielsweise ein Produktfeld in den Filterbereich verschieben, können Sie erreichen, dass die PivotTable-Liste zu einem bestimmten Zeitpunkt eine Zusammenfassung für ein Produkt anzeigt. Weitere Informationen finden Sie unter Verschieben eines Feldes in den Filterbereich.

Verschieben von Feldern in den Datenbereich Datenfelder stellen die Werte zur Verfügung, die in der PivotTable-Liste zusammengefasst werden sollen. Wenn Sie ein Feld in den Datenbereich verschieben, werden die Werte des Feldes für die Zeilen- und Spaltenfeldelemente zusammengefasst.

Verschieben von Feldern in den Detailbereich Um alle Detaildatensätze aus den Quelldaten für die PivotTable-Liste anzuzeigen, können Sie Felder in den Detailbereich verschieben. Wenn Sie die Anordnung der Felder oder die zusammengefassten Daten nicht ändern möchten, können Sie neben den zusammengefassten Daten Details anzeigen.

Hinzufügen und Entfernen von Daten Das Layout einer PivotTable-Liste braucht nicht alle Felder zu enthalten, die von den Quelldaten verfügbar sind. Stehen mehr Daten zur Verfügung, können Sie Felder zum PivotTable-Layout hinzufügen. Wenn die PivotTable-Liste beispielsweise Verkaufserlöse zusammenfasst und die Quelldaten darüber hinaus die Verkaufsmengen enthalten, können Sie das Mengenfeld als Datenfeld hinzufügen, um sowohl Erlös als auch Menge der verkauften Produkte zusammenzufassen. Darüber hinaus können Sie Felder aus dem PivotTable-Layout entfernen, die nicht mehr angezeigt werden sollen.

Das Verschieben von Feldern hat keinen Einfluss auf die Filterung Wenn Sie ein Feld filtern, bleiben die Filtereinstellungen für das Feld erhalten, wenn es in den Daten- oder Filterbereich verschoben wird, in denen die Elemente nicht ausgeblendet sind. Das bedeutet, dass die zuvor ausgeblendeten Elemente beim Verschieben des Feldes zurück in den Zeilen-, Spalten- oder Detailbereich wiederum ausgeblendet sind. Wenn Sie ein Feld entfernen und später das Feld wieder zum Layout hinzufügen, sind dieselben Elemente ebenfalls wiederum ausgeblendet. Sie können mitteilen, dass die Elemente in einem Feld auf Grund einer Filterung ausgeblendet sind, wenn der Pfeil neben der Feldbezeichnung blau angezeigt wird.

Einschränkungen beim Hinzufügen und Verschieben von Feldern Wenn Sie mit einer PivotTable-Liste arbeiten, die auf Quelldaten aus einer OLAP-Datenbank basiert, die z. B. mit Hilfe der Microsoft SQL Server OLAP-Dienste erstellt wurde, werden Sie feststellen, dass Sie keine Felder in den Detailbereich verschieben können. Sie werden weiterhin feststellen, dass einige Felder lediglich in die Zeilen-, Spalten- und Filterbereiche und Felder im Datenbereich nicht in andere Bereiche verschoben werden können.

Einschränken der Layoutänderungen im Browser Sie können die Möglichkeiten des Benutzers, das Layout der PivotTable-Liste zu ändern, einschränken, indem Sie verhindern, dass Zeilen- und Spaltenfelder im Browser hinzugefügt oder verschoben werden.


Anzeigen der Dropbereiche zum Verschieben und Hinzufügen von Feldern in einer PivotTable-Liste

Zum Anzeigen der Dropbereiche müssen Sie zunächst Daten zu der PivotTable-Liste hinzufügen.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie mit der rechten Maustaste auf die Titelleiste der PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Dropbereiche.

Anmerkungen

  • Wenn die Titelleiste ausgeblendet ist, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden. Klicken Sie auf Dropbereiche [image].

  • Wenn die Felder in alle Bereiche verschoben wurden, werden die Konturen und Beschriftungen des Dropbereichs nicht angezeigt, aber Sie können weiterhin Felder in die Bereiche verschieben.


Verschieben eines Feldes in den Zeilen- oder Spaltenbereich einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Zeigen Sie die Dropbereiche für die PivotTable-Liste an.

  3. Zeigen Sie auf die Feldbezeichnung des Feldes, das verschoben werden soll, bis sich der Zeiger in Zeiger mit Vierfachpfeil ändert.

  4. Führen Sie einen der folgenden Schritte durch:

    Um das Feld in ein Zeilenfeld zu ändern, ziehen Sie die Feldbezeichnung in den Zeilenbereich auf der linken Seite der PivotTable-Liste, bis sich der Zeiger in Zeiger mit hervorgehobenen Zeilenbereich ändert.

    Um das Feld in ein Spaltenfeld zu ändern, ziehen Sie die Feldbezeichnung in den Spaltenbereich in der Nähe des oberen Randes der PivotTable-Liste, bis sich der Zeiger in Zeiger mit hervorgehobenen Spaltenbereich ändert.

Tipp Um lediglich die zusammengefassten Daten für ein neues Zeilen- oder Spaltenfeld anzuzeigen, klicken Sie auf die Kästchen Minuskästchen der Datenelemente in dem Feld.


Ändern der Ebene eines Zeilen- oder Spaltenfeldes in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Feldbezeichnung für das Feld, das auf eine andere Ebene verschoben werden soll.

  3. Führen Sie auf der Symbolleiste in der PivotTable-Liste einen der folgenden Schritte durch:

    Um das Feld auf eine höhere Ebene zu verschieben, klicken Sie auf Heraufstufen [image].

    Um das Feld auf eine niedrigere Ebene zu verschieben, klicken Sie auf Tieferstufen [image].


Verschieben eines Feldes in den Datenbereich einer PivotTable-Liste

Sie können die Felder aus den Zeilen-, Spalten- und Filterbereichen nur dann in den Datenbereich verschieben, wenn die PivotTable-Liste auf Daten einer Datenquelle basiert, bei der es sich nicht um eine OLAP-Datenbank handelt.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Zeigen Sie die Dropbereiche der PivotTable-Liste an.

  3. Zeigen Sie auf die Feldbezeichnung des Feldes, das verschoben werden soll, bis sich der Zeiger in Zeiger mit Vierfachpfeil ändert.

  4. Ziehen Sie das Feld in den Datenbereich in dem unteren rechten Teil der PivotTable-Liste, bis sich der Zeiger in Zeiger mit Sigma ändert.

Anmerkung Wie das in den Datenbereich verschobene Feld zusammengefasst wird, hängt von dem Typ der Daten im Feld ab. Felder mit numerischen Daten werden mit der Berechnung Summe zusammengefasst. Felder mit anderen Datentypen werden mit der Berechnung Anzahl zusammengefasst. Für einige Felder können Sie die Zusammenfassungsfunktion ändern.


Verschieben eines Feldes in den Filterbereich einer PivotTable-Liste

Beim Verschieben eines Feldes in den Filterbereich können Sie die gesamte PivotTable-Liste so filtern, dass Daten nur für das Element, das in der Dropdownliste des Filterfeldes ausgewählt wurde, angezeigt werden.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Zeigen Sie die Dropbereiche der PivotTable-Liste an.

  3. Zeigen Sie auf die Feldbezeichnung des Feldes, das verschoben werden soll, bis sich der Zeiger in Zeiger mit Vierfachpfeil ändert.

  4. Ziehen Sie das Feld in den Filterbereich im oberen Teil der PivotTable-Liste, bis sich der Zeiger in Zeiger mit hervorgehobenen Filterbereich ändert.

Anmerkung Wenn Sie nicht möchten, dass Benutzer Felder in den oder aus dem Filterbereich verschieben können, heben Sie die Verfügbarkeit der Filterbefehle im Browser auf.


Verschieben eines Feldes in den Detailbereich einer PivotTable-Liste

Sie können keine Felder in den Detailbereich verschieben, wenn die PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Feldbezeichnung des Feldes, das Sie in den Detailbereich verschieben möchten.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf In Detailbereich verschieben [image].

Tipp Sie können Benutzer daran hindern, Felder in den Detailbereich zu verschieben, indem Sie den Zugriff im Browser auf Detaildaten einschränken.


Ändern der Spaltenreihenfolge in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Zeigen Sie auf die Feld- oder Elementbezeichnung am Anfang der Spalte, bis sich der Zeiger in Zeiger mit Vierfachpfeil ändert.

  3. Ziehen Sie die Spalte an die neue Position.

Tipp Um die Reihenfolge der Felder schnell zu ändern, sofern mehrere Zeilenfelder oder mehrere Spaltenfelder existieren, klicken Sie auf das Feld, das Sie ändern möchten, und klicken Sie dann auf Heraufstufen [image] oder Tieferstufen [image].


Anzeigen von Gesamtsummen in einer PivotTable-Liste

Wie möchten Sie verfahren?

Hinzufügen und Formatieren von Gesamtsummenfeldern

Hinzufügen eines Gesamtsummenfeldes zu einer PivotTable-Liste

Ändern der Zusammenfassungsfunktion für ein Gesamtsummenfeld

Weitere Informationen über Zusammenfassungsfunktionen

Vertikales oder horizontales Anzeigen von Gesamtsummenfeldern

Anzeigen und Formatieren von Teilergebnissen und Gesamtergebnissen

Anzeigen von Teilergebnissen und Gesamtergebnissen für ein Feld

Ändern der Ausrichtung von Teilergebnis- und Gesamtergebniselementen in einem Feld

Einschließen oder Ausschließen von Daten in Teilergebnissen und Gesamtergebnissen, die durch Filterung ausgeblendet sind

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Anzeigen von Gesamtsummen in einer PivotTable-Liste

PivotTable-Listen verwenden zwei verschiedene Arten von Gesamtsummen, um zusammengefasste Werte anzuzeigen. Der erste Typ, Gesamtsummenfelder, liefert die zusammengefassten Werte für die PivotTable-Liste. Wenn die PivotTable-Liste ein Gesamtsummenfeld enthält, können Sie für die Zeilen- und Spaltenfelder auch den zweiten Typ, Teilergebnisse und Gesamtergebnisse, anzeigen.

Dieses Thema erläutert die Funktionsweise von Gesamtsummenfelder sowie Teilergebnissen und Gesamtergebnissen, und welche Änderungen jeweils an der Anzeige vorgenommen werden können.

Gesamtsummenfelder

Teilergebnisse und Gesamtergebnisse

Gesamtsummenfelder

Funktionsweise von Gesamtsummenfeldern Bei Gesamtsummenfeldern handelt es sich um Datenfelder, die entweder in den Quelldaten zur Verfügung gestellt oder von Ihnen erstellt werden, um die Daten aus anderen Feldern in den Quelldaten zusammenzufassen. Wenn die Quelldaten beispielsweise ein Feld Verk. enthalten, das den Umfang aller einzelnen Verkäufe aufzeichnet, kann ein Gesamtsummenfeld Summe der Verkäufe die Verkaufszahlen für alle Kategorien in der PivotTable-Liste zusammenfassen, oder ein Gesamtsummenfeld Verkaufszahlen die Anzahl der Verkäufe aller Kategorien zusammenfassen. In der Feldliste werden Gesamtsummenfelder am Anfang unter Gesamtsummen angezeigt.

Beispiel für eine Feldliste mit Gesamtsummenfeldern

Die Felder Verk. und Einheiten können in der PivotTable-Liste als Gesamtsummenfelder eingeschlossen werden.

Quelldaten und Gesamtsummenfelder In PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, werden die Werte von Gesamtsummenfeldern auf dem Datenbankserver, der die Quelldaten liefert, vorberechnet. Daher stehen die Befehle zum Hinzufügen neuer Gesamtsummenfelder, zum Verschieben der Gesamtsummenfelder in den Detailbereich und zum Ändern der Zusammenfassungsfunktion, mit der die Werte in einem Gesamtsummenfeld berechnet werden, nicht zur Verfügung. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

Hinzufügen neuer Gesamtsummenfelder Wenn die in der Feldliste verfügbaren Gesamtsummenfelder nicht die gewünschten Zusammenfassungen zur Verfügung stellen, können Sie einer PivotTable-Liste neue Gesamtsummenfelder hinzufügen, sofern die Quelldaten dies zulassen. In der Regel werden Sie Gesamtsummenfelder zum Datenbereich hinzufügen. In der folgenden PivotTable-Liste wurde beispielsweise das Gesamtsummenfeld Summe der Verkäufe zum Datenbereich hinzugefügt, um Zusammenfassungsdaten für jede Sportart und jedes Quartal anzuzeigen.

Beispiel für ein Gesamtsummenfeld in einer PivotTable-Liste

Wenn das Gesamtsummenfeld Gesamtumsatz zum Datenbereich hinzugefügt wird, liefert es zusammengefasste Werte für jede Sportart und jedes Quartal.

Sofern die Quelldaten dies zulassen, können Sie darüber hinaus Gesamtsummenfelder zum Detailbereich hinzufügen. Um beispielsweise in dem vorherigen Beispiel den Umfang jedes einzelnen Verkaufs anzuzeigen, können Sie das Gesamtsummenfeld Summe der Verkäufe zum Detailbereich hinzufügen. Beachten Sie, dass Sie Gesamtsummenfelder nicht zum Zeilen-, Spalten- oder Filterbereich hinzufügen können.

Zusammenfassungsfunktionen für Gesamtsummenfelder Ein Gesamtsummenfeld alle vier Zusammenfassungsfunktionen, Summe, Anzahl, Minimum oder Maximum, verwenden. Sie können die Zusammenfassungsfunktion ändern, um einen anderen Typ von Zusammenfassung anzuzeigen, sofern die Quelldaten und der Feldtyp dies zulassen. Wenn ein Feld beispielsweise Text enthält, steht für dieses Feld lediglich die Zusammenfassungsfunktion Anzahl zur Verfügung. Abhängig von dem Typ der Quelldaten können Sie auch mehr als eine Zusammenfassungsfunktion verwenden, um die Daten in demselben Feld zusammenzufassen, indem Sie weitere Gesamtsummenfelder hinzufügen, wobei jeweils eine andere Zusammenfassungsfunktion verwendet wird.

Ändern der Anzeigeposition von Gesamtsummenfeldern Sie können die Ausrichtung der Gesamtsummenfelder in der PivotTable-Liste ändern. Bei der zeilenweisen Anzeige der Felder werden sie in der ersten Spalte rechts neben den Zeilenfeldern von oben nach unten angezeigt. Bei der spaltenweisen Anzeige der Felder werden sie in der ersten Zeile unter den Spaltenfeldern angezeigt.

Zurück zum Anfang

Teilergebnisse und Gesamtergebnisse

Anzeigen von Teilergebnissen und Gesamtergebnissen Sie können für jedes Zeilen- oder Spaltenfeld in der PivotTable-Liste Teilergebnisse anzeigen, wenn die Liste mindestens ein Gesamtsummenfeld und mehr als ein Zeilen- oder Spaltenfeld enthält. Wenn die Teilergebnisse für ein Feld angezeigt werden sollen, werden ebenfalls die Gesamtergebnisse angezeigt, und die Teilergebnisse sowie die Gesamtergebnisse werden für jedes Gesamtsummenfeld in der PivotTable-Liste am Schnittpunkt des ausgewählten Zeilen- oder Spaltenfeldes angezeigt. So zeigen Sie Teilergebnisse und Gesamtergebnisse an für ein Feld.

In dem folgenden Beispiel werden für beide Zeilenfelder Teilergebnisse und Gesamtergebnisse angezeigt, wobei die Werte im Gesamtsummenfeld Summe der Verkäufe verwendet werden.

Beispiel für Teilergebnis und Gesamtergebnis in einer PivotTable-Liste

Wenn die Teilergebnisse und Gesamtergebnisse für die Felder Sport und Quartal angezeigt werden, enthält die PivotTable-Liste Teilergebnisse für das Feld Quartal und ein Gesamtergebnis für das Feld Sport.

Verschieben oder Ausblenden von Teilergebnissen und Gesamtergebnissen Wenn Sie ein Feld verschieben, für das Teilergebnisse oder Gesamtergebnisse außerhalb des Zeilen- oder Spaltenbereichs angezeigt werden, werden die Teilergebnisse oder Gesamtergebnisse ausgeblendet, wobei diese Einstellung jedoch beibehalten wird. Die Teilergebnisse oder Gesamtergebnisse werden erneut angezeigt, wenn das Feld zurück in den Zeilen- oder Spaltenbereich verschoben wird.

Wenn Sie für ein Feld Teilergebnisse und Gesamtergebnisse ausblenden, bleiben diese unabhängig davon, wohin das Feld verschoben wird, ausgeblendet, auch wenn Sie das Feld aus der PivotTable-Liste entfernen und später wieder hinzufügen.

Ändern der Ausrichtung relativ zu den Detaildaten Sie können in den Teilergebnis- und den Gesamtergebniszeilen die Textausrichtung ändern, so dass der Text links, rechts oder zentriert ausgerichtet wird. Sie können die Änderung der Ausrichtung feststellen, wenn Sie in einem Feld, in dem Teilergebnisse und Gesamtergebnisse angezeigt werden, Details für ein oder mehrere Elemente anzeigen.

Einschließen und Ausschließen ausgeblendeter Daten Abhängig von den Quelldaten und dem in der PivotTable-Liste verwendeten Datentyp möchten Sie eventuell, dass die Teilergebnisse und Gesamtergebnisse die Werte für Datenelemente, die durch Filterung ausgeblendet wurden, einschließen oder nicht. Sie können angeben, dass alle Teilergebnisse und Gesamtergebnisse alle ausgeblendeten Daten einschließen oder ausschließen.

Zurück zum Anfang


Hinzufügen eines Gesamtsummenfeldes zu einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Feld, das die Werte enthält, die Sie zusammenfassen möchten.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf AutoBerechnung [image], und klicken Sie dann auf die gewünschte Zusammenfassungsfunktion.

    Die Schaltfläche AutoBerechnung ist nicht verfügbar, wenn die Quelldaten der PivotTable-Liste ein Hinzufügen von Gesamtsummenfeldern nicht zulassen, wenn z. B. die Quelldaten aus einer OLAP-Datenbank stammen. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

Anmerkungen

  • Wenn Sie aus einer PivotTable-Liste ein Gesamtsummenfeld entfernen, bleibt das Feld weiterhin in der Feldliste verfügbar, und Sie können es wieder in die PivotTable-Liste einfügen. Um ein Gesamtsummenfeld sowohl aus der PivotTable-Liste als auch der Feldliste zu entfernen, klicken Sie mit der rechten Maustaste auf das Gesamtsummenfeld, und klicken Sie dann im Kontextmenü auf Löschen.

  • Sie können Gesamtsummenfelder zum Datenbereich hinzufügen. Sie können jedoch diese Felder nicht zum Zeilen-, Spalten-, Detail- oder Filterbereich hinzufügen.


Ändern der Zusammenfassungsfunktion für ein Gesamtsummenfeld in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Markieren Sie das Gesamtsummenfeld, für das Sie die Zusammenfassungsfunktion ändern möchten.

    Wie wird´s gemacht?

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Gesamtsummenfunktion nicht eingeblendet ist, klicken Sie auf die Gesamtsummenfunktion-Leiste.

    Wenn die Leiste Gesamtsummenfunktion nicht angezeigt wird, erlauben die Quelldaten für die PivotTable-Liste keine Änderung der Zusammenfassungsfunktion, wenn z. B. die Quelldaten aus einer OLAP-Datenbank stammen. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

  5. Klicken Sie in der Liste Funktion auf die Zusammenfassungsfunktion, die Sie für das Gesamtsummenfeld verwenden möchten.


Zusammenfassungsfunktionen für PivotTable-Listen

Der Befehl AutoBerechnung [image] auf der Symbolleiste in der PivotTable-Liste, mit dem Sie Gesamtsummenfelder erstellen, bietet die folgenden Zusammenfassungsfunktionen:

Summe Berechnet die Summe der Werte.

Anzahl Zählt die Anzahl der Werte. Leere Werte, wie z. B. leere Zeichenfolgen (Zeichenfolgen ohne Zeichen), sind in der Anzahl enthalten, während Nullwerte (Werte, die fehlende oder unbekannte Daten kennzeichnen) nicht enthalten sind.

Minimum Gibt den kleinsten Wert in dem zusammengefassten Feld zurück.

Maximum Gibt den größten Wert in dem zusammengefassten Feld zurück.

Anmerkung Die für ein Feld verfügbaren Zusammenfassungsfunktionen hängen von dem Datentyp im Feld ab. Wenn ein Feld beispielsweise Datumsangaben enthält, können Sie die Funktion Summe nicht verwenden, um das betreffende Feld zusammenzufassen. Wenn ein Feld Text enthält, können Sie für das Feld Summe, Minimum oder Maximum nicht verwenden, jedoch Anzahl.


Ändern der Ausrichtung von Gesamtsummenfeldern in einer PivotTable-Liste

Dieses Verfahren betrifft alle Gesamtsummenfelder in der PivotTable-Liste. Es hat keine Auswirkungen auf Teilergebnisse oder Gesamtergebnisse. So ändern Sie die Ausrichtung von Teilergebnissen und Gesamtergebnissen in Bezug auf Detaildaten.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Gesamtsummen nicht eingeblendet ist, klicken Sie auf die Leiste Gesamtsummen.

  5. Führen Sie in der Liste Summenausrichtung einen der folgenden Schritte durch:

    Klicken Sie auf Zeile, um die Gesamtsummenfelder in der ersten Spalte rechts neben den Zeilenfeldern oder in der am weitesten links liegenden Spalte anzuzeigen, wenn keine Zeilenfelder vorhanden sind.

    Klicken Sie auf Spalte, um die Gesamtsummenfelder in der ersten Zeile unter den Spaltenfeldern oder in der obersten Zeile anzuzeigen, wenn keine Spaltenfelder vorhanden sind.


Anzeigen von Teil- und Gesamtergebnissen für ein Feld in einer PivotTable-Liste

  1. Vergewissern Sie sich, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Zeilen- oder Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden sollen.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Teilergebnis [image].

Anmerkungen

  • Weitere Informationen finden Sie unter Funktionsweise von Teilergebnis-, Gesamtergebnis- und Gesamtsummenfeldern in einer PivotTable-Liste.

  • Teilergebnisse und Gesamtergebnisse werden für Felder im Detailbereich (dem Bereich, in dem alle einzelnen Datensätze angezeigt werden können) nicht angezeigt.

  • Wenn sie angezeigt werden sollen, werden Teilergebnis- und Gesamtergebniswerte für jedes Gesamtsummenfeld in der PivotTable-Liste angezeigt. Sie können einzelne Gesamtsummenfelder nicht ausschließen.

  • Teilergebnis- und Gesamtergebnisberechnungen können die durch eine Filterung ausgeblendeten Datenelemente einschließen oder ausschließen.


Ändern der Ausrichtung der Teilergebnis- oder Gesamtergebniselemente in einem Gesamtsummenfeld einer PivotTable-Liste

Teilergebnis- und Gesamtergebniselemente für ein Gesamtsummenfeld stellen die Bezeichnungen in der Teilergebnis- oder Gesamtergebniszeile oder -spalte dar, wie z. B. Summe der Verkäufe oder Anzahl Inventar. Die Ausrichtung der Teilergebnis- und Gesamtergebniselemente erfolgt relativ zu den anderen Zellen im Detailbereich. Um die Auswirkung der Änderung der Ausrichtung festzustellen, zeigen Sie die Details für ein Element oder mehrere Elemente in einem Feld an, in dem Teilergebnisse und Gesamtergebnisse angezeigt werden.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Markieren Sie das Gesamtsummenfeld, für das Sie die Ausrichtung der Teilergebnis- und Gesamtergebniselemente ändern möchten.

    Wie wird´s gemacht?

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Gesamtsummenbeschriftung nicht eingeblendet ist, klicken Sie auf die Leiste Gesamtsummenbeschriftung.

  5. Klicken Sie in der Liste Ausrichtung innerhalb von Zeilen auf die gewünschte horizontale Ausrichtung (Automatisch, Links, Zentriert oder Rechts).


Einschließen oder Ausschließen ausgeblendeter Daten in Teil- oder Gesamtergebnissen in einer PivotTable-Liste

Dieses Verfahren gilt für alle Teilergebnisse und Gesamtergebnisse in der PivotTable-Liste.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf die Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Gesamtsummen nicht eingeblendet ist, klicken Sie auf die Leiste Gesamtsummen.

  5. Führen Sie einen der folgenden Schritte durch:

    Um ausgeblendete Daten einzuschließen, aktivieren Sie das Kontrollkästchen Zwischensummen für gefilterte Elemente.

    Um ausgeblendete Daten auszuschließen, aktivieren Sie das Kontrollkästchen Zwischensummen für gefilterte Elemente.

Anmerkungen

  • Diese Einstellung betrifft Daten, die durch Filtern von Zeilen- und Spaltenfeldern ausgeblendet wurden; Daten, die mit Hilfe von Filterfeldern ausgeblendet wurden, sind aus den Gesamtsummen immer ausgeschlossen.

  • Wenn Sie das Kontrollkästchen Zwischensummen für gefilterte Elemente aktivieren, werden in den Teilergebnissen und Gesamtergebnissen Sternchen angezeigt, um Sie darauf hinzuweisen, dass die Summenwerte sowohl die ausgeblendeten Elemente als auch die angezeigten Elemente enthalten.


Ausblenden der Teil- und Gesamtergebnisse für ein Feld in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Zeilen- oder Spaltenfeld, für das die Teilergebnisse und Gesamtergebnisse ausgeblendet werden sollen.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Teilergebnis [image], so dass die Schaltfläche nicht mehr gedrückt ist.


Anzeigen von Details für zusammengefasste Daten in einer PivotTable-Liste

Wie möchten Sie verfahren?

Auswählen der anzuzeigenden Details

Anzeigen der Erweiterungssymbole neben Elementen

Erweitern von Daten zum Anzeigen von Daten auf niedrigerer Ebene

Anzeigen von Detaildaten für ein Element oder eine Zelle

Automatisches Anzeigen von Detaildaten für alle Elemente

Anzeigen von Elementen ohne Daten

Anzeigemodus von Details angeben

Festlegen der Größe des Detailbereichs

Aufheben der Verfügbarkeit zusätzlicher Details im Browser

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Anzeigen von Details für zusammengefasste Daten in einer PivotTable-Liste

Sie können eine PivotTable-Liste so einrichten, dass beliebig viele der in den Quelldaten verfügbaren Details angezeigt werden. Sie können alle verfügbaren Details, lediglich Zusammenfassungen auf höherer Ebene oder Zusammenfassungen auf einer beliebigen Detailebene dazwischen anzeigen, und Sie können ausgewählte Details für Datenelemente anzeigen, die Sie hervorheben möchten. Solange Sie den Zugriff nicht einschränken, können die Benutzer die PivotTable-Liste im Browser ändern, so dass unterschiedliche Detailebenen und ein unterschiedlicher Umfang von Details angezeigt werden.

Auswählen der Details, die angezeigt werden sollen

Erweiterungssymbole Zum Ändern der Detailebene für jedes Datenelement in einem Feld verwenden Sie die Erweiterungssymbole. Bei den Erweiterungssymbolen handelt es sich um die Kästchen Pluskästchen und Minuskästchen, die neben Elementen angezeigt werden. Wenn Sie beispielsweise über ein Zeilenfeld mit dem Namen Artikel verfügen, das die Elemente Getreide und Fleisch enthält, sehen die Erweiterungssymbole folgendermaßen aus:

Beispiel für Erweiterungssymbole

Wenn die Erweiterungssymbole ausgeblendet sind, können Sie sie anzeigen. Wenn sie für ein Element dennoch nicht angezeigt werden, handelt es sich bei dem betreffenden Element möglicherweise um die unterste Detailebene, die von den Quelldaten zur Verfügung steht.

Anzeigen der Daten auf niedrigerer Ebene Wenn die Erweiterungssymbole aktiviert sind, wird neben Elementen, bei denen Daten auf niedrigerer Ebene zur Anzeige verfügbar sind, das Kästchen Pluskästchen angezeigt. Sie können für ein ganzes Feld die Daten auf niedrigerer Ebene anzeigen oder für jedes Element die Daten einzeln anzeigen, indem Sie nur die Daten einblenden, die angezeigt werden sollen.

Anzeigen von Detaildaten Eine PivotTable-Liste, bei der sich alle Felder im Detailbereich befinden, stellt alle Detailzeilen oder -datensätze der Quelldaten nicht zusammengefasst dar. Die Details können beispielsweise einzelne Rechnungsdatensätze anzeigen. Wenn Sie Felder aus dem Detailbereich in die Zeilen- oder Spaltenbereiche verschieben, können Sie Zusammenfassungen der Daten erstellen oder die jeweiligen Detailzeilen oder -datensätze anzeigen, die den zusammengefassten Wert für ein Element oder eine Zelle bilden. Sie können Detaildaten nur dann anzeigen, wenn in den Quelldaten Details verfügbar sind. OLAP-Datenbanken liefern beispielsweise oftmals nur Zusammenfassungsdaten und keine Detaildaten. Weitere Informationen finden Sie unter Informationen zu den Quelldaten für PivotTable-Listen.

Standardmäßig werden Detaildaten zu Beginn im Browser nicht angezeigt, wenn ein Benutzer Felder zu der PivotTable-Liste hinzufügt. Sie können jedoch automatisch Detaildaten für alle Elemente anzeigen, sofern Sie dies möchten.

Wenn Sie keine Detaildaten anzeigen möchten, können Sie die Details ausblenden.

Anzeigen von Zusammenfassungen auf höherer Ebene Neben Elementen, die aktuell Daten auf unterer Ebene anzeigen, wird das Kästchen Minuskästchen angezeigt. Sie können diese Elemente ausblenden, wenn Sie nur die Daten auf höherer Ebene anzeigen möchten.

Elemente ohne Daten Standardmäßig werden in einer PivotTable-Liste keine Elemente angezeigt, für die die Quelldaten keine Werte liefern. Wenn Sie beispielsweise die Verkaufszahlen für jeden Monat anzeigen und im Monat April keine Verkäufe erfolgt sind, verfügt das Feld Monat über kein Element für April. Wenn Sie die Elemente für alle zwölf Monate einschließen möchten, wobei für Monate ohne Verkäufe leere Zellen angezeigt werden, können Sie Elemente ohne Daten anzeigen.

Angeben, wie die Details angezeigt werden

Festlegen der Größe des Detailbereichs Wenn Sie Detail für ein Element oder eine Zelle anzeigen, wird ein Detailbereich in der PivotTable-Liste eingeblendet, in dem die Detailzeilen angezeigt werden. Standardmäßig wird dieser Bereich innerhalb der Grenzen, die Sie für die Größe der PivotTable-Liste als Ganzes festgelegt haben, auf die notwendige Größe erweitert, damit alle Daten angezeigt werden können. Um anzugeben, wie viel des verfügbaren Platzes der Detailbereich belegen darf, wenn Benutzer die Details im Browser anzeigen, können Sie die maximale Größe des Detailbereichs und die Zeilenhöhe festlegen.

Einschränken des Zugriffs auf Detaildaten im Browser Sie können den Umfang und die Ebene von Details anzeigen, die Sie für geeignet halten, und anschließend verhindern, dass Benutzer im Browser zusätzliche Details anzeigen.

Export nach Microsoft Excel ermöglicht Zugriff auf alle Details In Excel sind alle festgelegten Einschränkungen für die Anzeige von Detaildaten nicht mehr wirksam. Benutzer, die eine PivotTable-Liste aus dem Browser nach Excel exportieren, können mit Hilfe der Excel-Features alle in den Quelldaten verfügbaren Details anzeigen. Um zu verhindern, dass die Benutzer auf diese Weise auf die Detaildaten zugreifen, können Sie den Zugriff auf den Befehl Nach Excel exportieren im Browser einschränken, indem Sie die Symbolleiste deaktivieren und den Zugriff auf die PivotTable-Eigenschaftentoolbox einschränken. Weitere Informationen finden Sie unter Informationen zum Einschränken des Zugriffs auf eine PivotTable-Liste im Browser.


Festlegen der Größe und Zeilenhöhe für den Detailbereich in einer PivotTable-Liste

Der Detailbereich bildet den Teil einer PivotTable-Liste, in dem Detaildaten angezeigt werden. Wenn Detaildaten für mehr als ein Datenelement angezeigt werden, kann die PivotTable-Liste über mehr als einen Detailbereich verfügen. Wenn Sie die Größe des Detailbereichs festlegen, ist diese Größe unabhängig von der für die PivotTable-Liste als Ganzes festgelegte Größe.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Format - Detaildaten nicht eingeblendet ist, klicken Sie auf die Leiste Format - Detaildaten.

  5. Führen Sie einen der folgenden Schritte durch:

    Um die Größe des Detailbereichs zu vergrößern oder zu verkleinern, so dass die aktuell angezeigten Daten hinein passen, aktivieren Sie das Kontrollkästchen Detaildaten automatisch anpassen. Um anschließend zu verhindern, dass der Detailbereich eine bestimmte Größe überschreitet, geben Sie im Feld Maximale Höhe und/oder Maximale Breite einen Wert in Pixel ein.

    Um die Detaildaten in einem Bereich mit fester Breite anzuzeigen, deaktivieren Sie das Kontrollkästchen Detaildaten automatisch anpassen, und geben Sie dann die Breite im Feld Detailbereichsbreite die Breite in Pixel ein.

  6. Um eine feste Höhe für alle Zeilen im Detailbereich festzulegen, geben Sie einen Wert in Pixel im Feld Detailbereich-Zeilenhöhe ein.

Anmerkungen

  • Diese Einstellungen können im Browser nicht geändert werden.

  • Sie können darüber hinaus die Größe für die gesamte PivotTable-Liste festlegen.


Anzeigen der Erweiterungssymbole neben Elementen in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden.

  5. Klicken Sie auf Erweiterungssymbole [image].

Anmerkungen

  • Elemente, für die keine Daten auf niedrigerer Ebene verfügbar sind, besitzen keine Erweiterungssymbole.

  • Wenn Sie nicht möchten, dass Benutzer die Anzeige von Erweiterungssymbolen ändern können, können Sie im Browser den Zugriff auf die PivotTable-Eigenschaftentoolbox einschränken.


Automatisches Anzeigen der Detaildaten aller Elemente in einer PivotTable-Liste

Standardmäßig sind die Detaildaten für Elemente zu Beginn im Browser ausgeblendet, und die Benutzer können die Detaildaten für ein Feld anzeigen, indem sie auf Erweitern [image] klicken.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Klicken Sie in der Liste Elemente standardmäßig erweitern auf Immer.

Anmerkungen

  • Um die Detaildaten für alle Elemente auszublenden, klicken Sie in der Liste Elemente standardmäßig erweitern auf Nie oder Automatisch.

  • Diese Einstellungen können im Browser nicht geändert werden.

  • Detaildaten stehen in PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, normalerweise nicht zur Verfügung. Sind Detaildaten nicht verfügbar, hat die Einstellung Elemente standardmäßig erweitern keine Auswirkung. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.


Einblenden eines Elements in einer PivotTable-Liste, um die Daten auf der darunter liegenden Ebene anzuzeigen

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Stellen Sie sicher, dass die Erweiterungssymbole angezeigt werden.

  3. Klicken Sie auf das Kästchen Pluskästchen neben dem Element, für das die nächste Datenebene angezeigt werden soll.

Anmerkungen

  • Um alle Elemente in einem Feld anzuzeigen, klicken Sie auf die Feldbezeichnung und dann auf der Symbolleiste in der PivotTable-Liste auf Erweitern [image].

  • Wenn ein Element über kein Erweiterungssymbol verfügt, befindet sich das Element möglicherweise auf der untersten für die Quelldaten verfügbaren Ebene. Sofern die Quelldaten dies zulassen, können Sie die Detaildaten der Elemente auf der untersten Ebene anzeigen. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

  • Wenn Sie nicht möchten, dass Benutzer Elemente über die von Ihnen festgelegte Ebene hinaus einblenden, können Sie im Browser den Zugriff auf Details einschränken.


Anzeigen der Detaildaten für ein Element oder eine Zelle in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Element oder die Zelle, für das bzw. die Sie die Detaildaten anzeigen möchten.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Erweitern [image].

Anmerkungen

  • Wenn der Befehl Erweitern [image] nicht verfügbar ist, befindet sich das Element oder die Zelle auf der untersten für die Quelldaten verfügbaren Ebene, oder es stehen aus den Quelldaten keine Detaildaten zur Verfügung. PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, lassen beispielsweise die Anzeige unterschiedlicher Datenebenen zu, stellen jedoch oftmals nur Zusammenfassungsdaten und keine Detaildaten zur Verfügung. Weitere Informationen finden Sie unter Quelldaten für PivotTable-Listen.

  • Wenn Sie nicht möchten, dass Benutzer Detaildaten anzeigen, können Sie im Browser den Zugriff auf Details einschränken.


Anzeigen von Elementen ohne Daten in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Leere Elemente anzeigen nicht eingeblendet ist, klicken Sie auf die Leiste Leere Elemente anzeigen.

  5. Zum Anzeigen von Zeilenfeldelementen ohne Daten, aktivieren Sie das Kontrollkästchen Zeile.

    Zum Anzeigen von Spaltenfeldelementen ohne Daten, aktivieren Sie das Kontrollkästchen Spalte.


Ausblenden eines Elements in einer PivotTable-Liste, um nur die Daten auf höherer Ebene anzuzeigen

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Stellen Sie sicher, dass die Erweiterungssymbole angezeigt werden.

  3. Klicken Sie auf das Kästchen Minuskästchen neben dem Element, für das nur Daten auf höherer Ebene angezeigt werden sollen.


Ausblenden der Detaildaten in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Datenelement, für das Detaildaten angezeigt werden.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Reduzieren [image].

Anmerkung Zum Ausblenden der Details für alle Elemente in einem Feld, klicken Sie auf das Feld, und klicken Sie dann auf Reduzieren [image].


Aufheben der Verfügbarkeit zusätzlicher Details einer PivotTable-Liste

Dieses Verfahren hebt die Verfügbarkeit von Details, die nicht angezeigt werden, im Browser auf. Nach Abschluss dieses Verfahrens können Sie jedoch im Entwurfsprogramm keine weiteren Details anzeigen.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Deaktivieren Sie das Kontrollkästchen Details zulassen.

Anmerkungen

  • Diese Einstellung kann im Browser nicht geändert werden.

  • In Microsoft Excel hat diese Einschränkung keine Auswirkung. Benutzer, die eine PivotTable-Liste aus dem Browser nach Excel exportieren, können anschließend die Excel-Features verwenden, um alle in den Quelldaten verfügbaren Details anzuzeigen. Um Benutzer daran zu hindern, auf diese Weise auf Detaildaten zuzugreifen, können Sie den Zugriff auf den Befehl Nach Excel exportieren im Browser einschränken, indem Sie die Symbolleiste deaktivieren und den Zugriff auf die PivotTable-Eigenschaftentoolbox beschränken. Weitere Informationen finden Sie unter Einschränken des Zugriffs auf Features im Browser.


Sortieren von Daten in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Führen Sie einen der folgenden Schritte durch:

    Um die Daten in einem Feld basierend auf den Elementbezeichnungen zu sortieren, klicken Sie auf die Bezeichnung des Feldes, das die Daten enthält, die sortiert werden sollen.

    Um die Daten in einem Feld basierend auf den Zusammenfassungswerten in einer Spalte zu sortieren, klicken Sie auf die Zelle in der Spalte, die die Werte enthält, die sortiert werden sollen.

    Um die Daten in einem Feld basierend auf den Teilergebnis- oder Gesamtergebniswerten zu sortieren, klicken Sie auf einen Teilergebnis- oder Gesamtergebniswert des Feldes, das die Daten enthält, die sortiert werden sollen. Wenn Sie auf einen Gesamtergebniswert in der untersten Zeile der PivotTable-Liste klicken, werden an Stelle der Zeilen die Spalten sortiert.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf eine der folgenden Schaltflächen:

    Um das Feld in der Reihenfolge A – Z 0 – 9 zu sortieren, klicken Sie auf Aufsteigend sortieren [image].

    Um das Feld in der Reihenfolge Z – A 9 – 0 zu sortieren, klicken Sie auf Absteigend sortieren [image].

Anmerkungen

  • Um die Sortierung rückgängig zu machen und die vorherige Reihenfolge der Datenelemente in dem Feld wiederherzustellen, klicken Sie erneut auf die Schaltfläche Aufsteigend sortieren [image] bzw. die Schaltfläche Absteigend sortieren [image], so dass die Schaltfläche nicht mehr gedrückt ist.

  • Die Reihenfolge, in der Zahlen, Text und Sonderzeichen sortiert werden, hängt von den Quelldaten und den Ländereinstellungen in der Windows-Systemsteuerung ab. Wenn die Benutzer in ihren Browsern über andere Ländereinstellungen verfügen, können sich deren Sortierreihenfolgen von Ihrer unterscheiden.

  • In einer PivotTable-Liste, die auf Quelldaten aus einer OLAP-Datenbank basiert, werden die aktuelle Ebene und die unteren Ebenen, jedoch keine höheren Ebenen sortiert, wenn Sie ein Feld sortieren, für das niedrigere und höhere Detailebenen verfügbar sind. Die höheren Ebenen bestimmen, welche Elemente der unteren Ebenen zusammen sortiert werden. Beheben von Problemen beim Sortieren von Daten aus OLAP-Datenbanken.

  • Sie können nach mehr als einer Spalte sortieren, indem Sie jede Spalte getrennt sortieren.


Informationen zum Sortieren von Daten nach mehr als einer Spalte in einer PivotTable-Liste

Um nach mehr als einer Spalte zu sortieren, können Sie die PivotTable-Liste getrennt nach jeder Spalte sortieren. Die Reihenfolge, in der Sie die Spalten sortieren, bestimmt die Anordnung der Daten.

Beispiel für Daten, die nach zwei Spalten sortiert sind

In diesem Beispiel wird die Liste nach Verkäufer sortiert. Die Spalte Artikel wurde zuerst sortiert, so dass die Produkte in alphabetischer Reihenfolge aufgeführt werden; die Spalte Verkaufsberater wurde danach sortiert.

Bestimmen Sie beim Sortieren mehrerer Spalten zunächst die Reihenfolge, in der die Spalten sortiert werden sollen, und arbeiten Sie dann entgegengesetzt zur Sortierreihenfolge, wobei die äußerste Spalte zuletzt sortiert wird. Wenn Sie beispielsweise zwei Spalten sortieren, legen Sie fest, welche Spalte die äußere Spalte und welche die innere Spalte bildet. Sortieren Sie die innere Spalte zuerst und anschließend die äußere Spalte. Um die Produkte für alle Verkäufer in alphabetischer Reihenfolge aufzuführen, sortieren Sie zunächst die innere Spalte Artikel und dann die äußere Spalte Verkaufsberater.

So sortieren Sie Daten in einer PivotTable-Liste.


Filtern einer PivotTable-Liste zum Anzeigen bestimmter Daten

Wie möchten Sie verfahren?

Filtern eines Feldes, damit nur die gewünschten Daten angezeigt werden

Anzeigen nur der Daten, die einer Zelle entsprechen

Hinzufügen eines neuen Filterfeldes

Verwenden eines vorhandenen Feldes als Filterfeld

Verhindern, dass Benutzer die Filterung für eine PivotTable-Liste im Browser ändern

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Filtern der Daten in einer PivotTable-Liste

PivotTable-Listen verfügen über keinen Suchbefehl. Sie können jedoch die Filter- und Sortierfunktionen verwenden, um bestimmte Datenwerte oder alle Daten, die einem Wert entsprechen, zu suchen. Sortiervorgänge, Filtervorgänge mit Hilfe von Filterfeldern und Filtervorgänge mit Hilfe von Filterbefehlen können sowohl beim Entwerfen der PivotTable-Liste als auch beim Anzeigen im Browser durchgeführt werden. Sie können jedoch den Zugriff auf einige Filterfunktionen im Browser einschränken.

Filterung zum Suchen von Daten Filtern stellt ein schnelles Verfahren dar, um mit einer Teilmenge der Daten in einer PivotTable-Liste zu arbeiten. Sie können die Felder in den Zeilen-, Spalten- und Detailbereichen filtern. Beim Filtern eines Feldes markieren Sie ein oder mehrere Datenelemente in dem Feld, die angezeigt werden sollen, und blenden die anderen Elemente aus.

Beispiele für eine gefilterte PivotTable-Liste

Das Feld Sport wird zunächst so gefiltert, dass lediglich Verkäufe im Produktbereich Golf angezeigt werden. Anschließend wird das Feld Quartal so gefiltert, dass nur Verkäufe von Golfprodukten im dritten Quartal angezeigt werden.

Wenn Sie eine PivotTable-Liste filtern, werden die Dropdownpfeile Feldpfeile der gefilterten Felder blau anstatt schwarz angezeigt, und die Schaltfläche AutoFilter [image] auf der Symbolleiste in der PivotTable-Liste ist gedrückt.

Auswählen mehrerer Elemente in mehreren Feldern Die Filterung ist besonders hilfreich, wenn eine PivotTable-Liste einen großen Umfang an Quelldaten besitzt und Sie sich auf bestimmte Bereiche konzentrieren möchten. Beim Filtern eines Feldes können Sie die Daten für ein einzelnen Element anzeigen oder einige Elemente auswählen, die angezeigt werden sollen, und andere Elemente, die ausgeblendet werden sollen. Sie können gleichzeitig mehr als ein Feld filtern, um den Bereich weiter einzuschränken. Weitere Informationen finden Sie unter Filtern eines Feldes.

Filterung basierend auf den Daten in einer Zelle Sie können ein Feld filtern, damit nur Daten angezeigt werden, die mit dem Wert in einer ausgewählten Zelle übereinstimmen. Die auswahlbasierte Filterung ist besonders nützlich für Felder im Detailbereich, wenn alle Zeilen angezeigt werden sollen, die einen bestimmten Wert enthalten.

Deaktivieren der Filterung Um alle Daten aller Felder in einer PivotTable-Liste anzuzeigen, können Sie die Filterung entfernen. Die Filtereinstellungen bleiben erhalten, so dass beim erneuten Aktivieren der Filterung die gleichen Daten, die zuvor angezeigt und ausgeblendet waren, wieder angezeigt und ausgeblendet werden. Die Filtereinstellungen bleiben auch erhalten, wenn Sie Felder verschieben, um das Layout der PivotTable-Liste zu ändern.

Filterung verhält sich kumulativ Nach dem Aktivieren der Filterung durch Klicken auf die Schaltfläche AutoFilter [image], so dass die Schaltfläche gedrückt ist, wird jeder Filter zu den bereits wirksamen Filtern hinzugefügt. Wenn Sie beispielsweise Filter auf ein Feld anwenden und dann ein anderes Feld auswahlbasiert filtern, gelten beide Filter. Alle Filter bleiben wirksam, bis die Filterung deaktiviert wird. Um die vorhandenen Filter zu löschen, deaktivieren Sie die Filterung, und wählen Sie dann neue Elemente aus, die gefiltert werden sollen.

Verwenden eines Filterfeldes zum Filtern der gesamten PivotTable-Liste Darüber hinaus können Sie Daten mit Hilfe von Filterfeldern filtern. Wenn Sie ein anderes Element für ein Filterfeld auswählen, ändern sich die in der ganzen PivotTable-Liste angezeigten und berechneten Daten in Abhängigkeit von dem betreffenden Element. Sie können zu der PivotTable-Liste neue Filterfelder hinzufügen oder vorhandene Felder in den Filterbereich verschieben.

Auswirkungen der Filterung auf Berechnungen Gesamtsummen können lediglich angezeigte Daten oder alle Daten in einer PivotTable-Liste, einschließlich der angezeigten und ausgeblendeten Daten, umfassen. Standardmäßig sind ausgeblendete Daten aus Gesamtsummen ausgeschlossen, mit der Ausnahme von PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren und die von Microsoft Excel aus veröffentlicht wurden, in denen ausgeblendete Daten in den Gesamtergebnissen enthalten sind. Weitere Informationen finden Sie unter Typen der Quelldaten. Sie können die gültige Einstellung ändern, um ausgeblendete Daten in Gesamtsummen einzuschließen oder auszuschließen. Diese Einstellung betrifft nur Daten, die durch Filterung von Zeilen- und Spaltenfeldern ausgeblendet wurden; Daten, die mit Hilfe von Filterfeldern ausgeblendet wurden, werden immer aus Gesamtsummen ausgeschlossen.

Verhindern, dass Benutzer die Filterung ändern Wenn Sie nicht möchten, dass Benutzer Ihre Filterung der Daten ändern, können Sie die Verfügbarkeit der Filterung im Browser aufheben.


Filtern eines Feldes in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf den Dropdownpfeil Feldpfeil des Feldes mit den Datenelementen, die Sie filtern möchten.

  3. Aktivieren Sie die Kontrollkästchen der Elemente, die angezeigt werden sollen, und deaktivieren Sie die Kontrollkästchen der Datenelemente, die Sie ausblenden möchten.

Anmerkungen

  • Um alle Daten für ein Feld anzuzeigen oder auszublenden, aktivieren bzw. deaktivieren Sie das Kontrollkästchen Alle anzeigen.

  • Ein schattiertes Kontrollkästchen kennzeichnet, dass einige oder alle Elemente auf unterer Ebene ausgeblendet sind. Um festzustellen, welche Elemente der unteren Ebenen ausgeblendet sind, klicken Sie neben dem Element mit dem schattierten Kontrollkästchen auf Pluskästchen.

  • Um alle Daten aller Felder anzuzeigen, klicken Sie auf die Schaltfläche AutoFilter [image], so dass die Schaltfläche nicht gedrückt ist. Die zuvor vorgenommenen Filtereinstellungen bleiben erhalten; wenn Sie daher das nächste Mal auf die Schaltfläche AutoFilter klicken, werden die Felder erneut gefiltert. Wenn Sie die Filtereinstellungen nicht behalten möchten, achten Sie darauf, dass die Schaltfläche AutoFilter nicht gedrückt ist, bevor Sie mit der Auswahl der zu filternden Elemente beginnen. Ist die Schaltfläche nicht gedrückt, wird das Filtern beim Auswählen der neuen zu filternden Elemente automatisch aktiviert und die früheren Filtereinstellungen wiederhergestellt.

  • Wenn Sie ein gefiltertes Feld verschieben, bleiben die Filtereinstellungen für das Feld erhalten, sofern sich das Feld im Daten- oder Filterbereich befindet und die Elemente nicht ausgeblendet sind. Das bedeutet, dass beim Verschieben des Feldes zurück in den Zeilen-, Spalten- oder Detailbereich die zuvor ausgeblendeten Elemente wieder ausgeblendet sind. Wenn Sie ein Feld verschieben und das Feld später wieder zum Layout hinzufügen, sind die gleichen Elemente ebenfalls wieder ausgeblendet. Wenn die Elemente in einem Feld durch das Filtern ausgeblendet sind, wird der Dropdownpfeil Feldpfeil in der Feldbezeichnung blau angezeigt.

  • Wenn Sie nicht möchten, dass Benutzer auf dieses Feature zugreifen, können Sie die Verfügbarkeit des Filterns im Browser aufheben.


Anzeigen nur der Daten, die einer Zelle in einer PivotTable-Liste entsprechen

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie mit der rechten Maustaste auf die Zelle mit dem Wert, der angezeigt werden soll, und klicken Sie dann im Kontextmenü auf Auswahlbasierter Filter.

Anmerkungen

  • Wenn Sie ein gefiltertes Feld verschieben, bleiben die Filtereinstellungen für das Feld erhalten, sofern sich das Feld im Daten- oder Filterbereich befindet und die Elemente nicht ausgeblendet sind. Das bedeutet, dass beim Verschieben des Feldes zurück in den Zeilen-, Spalten- oder Detailbereich die zuvor ausgeblendeten Elemente wieder ausgeblendet sind. Wenn Sie ein Feld verschieben und das Feld später wieder zum Layout hinzufügen, sind die gleichen Elemente ebenfalls wieder ausgeblendet. Wenn die Elemente in einem Feld durch das Filtern ausgeblendet sind, wird der Dropdownpfeil Feldpfeil in der Feldbezeichnung blau angezeigt.

  • Wenn die Schaltfläche AutoFilter [image] auf der Symbolleiste gedrückt ist, verhält sich die auswahlbasierte Filterung kumulativ; das heißt, dass ein weiterer Filter zu den bereits wirksamen hinzugefügt wird. Wenn die Schaltfläche AutoFilter nicht gedrückt ist, wird beim auswahlbasierten Filtern automatisch der kumulative Filter, der vorher eingestellt wurde, entfernt und das Filtern mit einer neuen Akkumulation aktiviert.

  • Um alle Daten aller Felder anzuzeigen, klicken Sie auf die Schaltfläche AutoFilter [image], so dass die Schaltfläche nicht gedrückt ist. Die zuvor vorgenommenen Filtereinstellungen bleiben erhalten; wenn Sie daher das nächste Mal auf die Schaltfläche AutoFilter klicken, werden die Felder erneut gefiltert. Wenn Sie die Filtereinstellungen nicht behalten möchten, achten Sie darauf, dass die Schaltfläche AutoFilter nicht gedrückt ist, bevor Sie mit der Auswahl der zu filternden Elemente beginnen.

  • Wenn Sie nicht möchten, dass Benutzer auf diesen Befehl zugreifen, können Sie die Verfügbarkeit des Filterns im Browser aufheben.


Entfernen der Filter zum Anzeigen aller Daten in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf die Schaltfläche AutoFilter [image], so dass die Schaltfläche nicht gedrückt ist.

Anmerkungen

  • Wenn Sie erneut auf AutoFilter [image] klicken, um die Filterung wieder zu aktivieren, werden die zuvor eingestellten Filter wiederhergestellt.

  • Wenn Sie nicht möchten, dass Benutzer Ihre Filter entfernen, können Sie die Verfügbarkeit der Filterbefehle im Browser aufheben.


Verhindern, dass Benutzer die Filterung einer PivotTable-Liste ändern

Dieses Verfahren verhindert, dass Benutzer die Filterung zur Laufzeit im Browser ändern, und verhindert ebenfalls, dass Sie die Filterung im Entwurfsprogramm weiter ändern.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Aktivieren Sie das Kontrollkästchen Filter sperren.

Anmerkung Diese Einstellung kann im Browser nicht geändert werden.


Formatieren einer PivotTable-Liste

Wie möchten Sie verfahren?

Formatieren von Zellen und Daten

Markieren von Teilen einer PivotTable-Liste, die formatiert werden sollen

Festlegen von Schriftart und Textformat

Festlegen von Hintergrundfarben für Zellen

Ausrichten von Text in einer Zelle

Anzeigen der gesamten PivotTable-Liste, so dass sie von rechts nach links gelesen wird

Ändern von Zahlenformaten

Angeben der Formate für alle Elemente in der PivotTable-Liste

Ändern und Formatieren von Titeln und Bezeichnungen

Anzeigen oder Ausblenden der Titelleiste

Ändern von Bezeichnungen und Namen

Formatieren der Titelleiste

Formatieren von Gesamtsummenfeldern, Teilergebnissen und Gesamtergebnissen

Vertikales oder horizontales Anzeigen von Gesamtsummenfeldern

Ändern der Ausrichtung von Teilergebnis- und Gesamtergebniselementen in einem Feld

Formatieren der Dropbereiche

Ausblenden der Dropbereiche

Formatieren der Dropbereichbeschriftungen

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen über das Formatieren einer PivotTable-Liste

Funktionsweise der Formatierung in PivotTable-Listen

Ausblenden der Dropbereiche Bei den Dropbereichen handelt es sich um die umrissenen Textfelder, wie z. B. "Filterfelder hierher ziehen", mit denen Sie das Layout ändern können. Sie können die Dropbereiche ausblenden, wenn Sie beispielsweise eine PivotTable-Liste drucken möchten, jedoch nicht den Text der Dropbereiche. Wenn Sie die Dropbereiche ausblenden, werden alle Dropbereiche, die keine Felder enthalten, im Entwurfsprogramm und zur Laufzeit im Browser aus der Ansicht entfernt. Wenn die PivotTable-Liste beispielsweise über keine Filterfelder verfügt, wird der Dropbereich für Filterfelder ausgeblendet.

Formatieren ähnlicher Elemente Formate, die Sie einem Element zuweisen, können sich auf ähnliche Elemente auswirken. Wenn Sie beispielsweise die Textfarbe für eine Gesamtsumme ändern, werden alle Gesamtsummen in der PivotTable-Liste mit der neuen Textfarbe formatiert. Wenn Sie ein Element von einem Bereich in einen anderen verschieben, z. B. ein Detailfeld in den Zeilenbereich, verliert das verschobene Element seine vorherige Formatierung und übernimmt die Formatierung, die dem neuen Bereich zugewiesen wurde. Weitere Informationen finden Sie unter Markieren von Elementen einer PivotTable-Liste, die formatiert werden sollen.

Festlegen von Textformaten Sie können die Schriftart, den Schriftgrad und die Textfarbe festlegen und Text fett, unterstrichen oder kursiv formatieren. Änderungen, die Benutzer an den Einstellungen des Browsers für Schriftarten und Farben vornehmen, haben keine Auswirkung auf PivotTable-Listen. Weitere Informationen finden Sie unter Festlegen von Textformaten.

Ausrichten von Text in einer Zelle Sie können Werte in den Zellen horizontal links, rechts oder zentriert ausrichten. Die vertikale Ausrichtung der Zellen kann nicht geändert werden. Weitere Informationen finden Sie unter Ausrichten von Text in einer Zelle. Darüber hinaus können Sie Teil- und Gesamtergebnisse relativ zu den Detaildaten ausrichten.

Festlegen von Hintergrundfarben Sie können die Hintergrundfarbe der Zellen ändern. Änderungen, die Benutzer an den Einstellungen des Browsers für Farben vornehmen, haben keine Auswirkung auf PivotTable-Listen.

Ändern der Zahlenformate Sie können die Formate, in denen Zahlen, Datum und Uhrzeit in einem Feld angezeigt werden, in mehrere vordefinierte Zahlenformate ändern. Sie können eine Zahl beispielsweise als Währung oder Prozentwert anzeigen, und Sie können ein Datum im Langformat, mit ausgeschriebenem Tag und Monat, oder im Kurzformat anzeigen. Änderungen des Zahlenformats ändern nicht die eigentlichen Werte, sondern lediglich die Anzeige der Werte. Die Einstellungen im Dialogfeld Eigenschaften von Ländereinstellungen in der Windows-Systemsteuerung des Benutzers beeinflussen die Anzeige der festgelegten Zahlenformate im Browser. Weitere Informationen finden Sie unter Ändern der Zahlenformate.

Formatieren aller Elemente in einer PivotTable-Liste

Um das Erscheinungsbild aller Elemente in einer PivotTable-Liste anzupassen, müssen Sie unter Umständen zeitweise das Layout ändern, damit Elemente, die in der Anfangsdarstellung der Daten nicht enthalten sein sollen, formatiert werden können. Um beispielsweise Formate für ein Feld im Detailbereich einzurichten, wenn das Anfangslayout das betreffende Detailfeld nicht beinhaltet, müssen Sie ein Feld in den Detailbereich verschieben, formatieren und das Feld dann zurück in den vorherigen Bereich verschieben. Wenn Benutzer im Browser Felder in andere Bereiche der PivotTable-Liste verschieben, übernehmen die Felder und deren Daten die Formatierung, die für Felder und Daten in den jeweiligen Bereichen eingerichtet wurde.

Die Verfahren für Textformatierung und Hintergrundformatierung sind für alle Elemente identisch. Markieren Sie zunächst das Element, und weisen Sie Textformatierung und Hintergrundformatierung mit Hilfe der allgemeinen Verfahren zu.

Markieren von Elementen in einer PivotTable-Liste.

Zuweisen von Textformatierung und Hintergrundformatierung.

So formatieren Sie eine PivotTable-Liste

  1. Markieren Sie ein Feld im Zeilen-, Spalten- oder Filterbereich, und weisen Sie den Feldbezeichnungen die gewünschte Text- und Hintergrundformatierung zu.

  2. Markieren Sie ein Datenelement in einem Zeilen- oder Spaltenfeld, und weisen Sie den Elementbezeichnungen, Detailfeldbezeichnungen, Teilergebnisbezeichnungen , Gesamtergebnisbezeichnungen und Gesamtsummenfeldbezeichnungen die gewünschte Text- und Hintergrundformatierung sowie horizontale Ausrichtung zu.

    Ändern der horizontalen Ausrichtung.

  3. Markieren Sie ein Gesamtsummenfeld, und weisen Sie den Datenzellen in Gesamtsummenfeldern die gewünschte Text- und Hintergrundformatierung, horizontale Ausrichtung und das gewünschte Zahlenformat zu.

    Sind in der PivotTable-Liste keine Gesamtsummenfelder vorhanden, können Sie ein Gesamtsummenfeld erstellen, es formatieren und dann das Feld aus dem Layout entfernen.

    Ändern des Zahlenformats für Daten.

  4. Wählen Sie ein Gesamtergebnis für jedes Feld aus, und weisen Sie den Datenzellen für Teil- und Gesamtergebnisse in diesem Feld die gewünschte Text- und Hintergrundformatierung zu.

    Zum Anzeigen eines Gesamtergebnisses müssen Sie das Feld in den Zeilen- oder Spaltenbereich verschieben und für das Feld die Teil- und Gesamtergebnisse anzeigen.

  5. Wenn die Quelldaten die Anzeige von Detaildaten zulassen, legen Sie die Ausrichtung von Teil- und Gesamtergebniselementen relativ zu den Detaildaten jedes Gesamtsummenfeldes fest.

  6. Wenn die Quelldaten die Anzeige von Detailfeldern zulassen, verschieben Sie alle Felder in den Detailbereich, und weisen Sie jedem Feld die gewünschte Text- und Hintergrundformatierung, horizontale Ausrichtung und das gewünschte Zahlenformat zu.

  7. Markieren Sie die gesamte PivotTable-Liste, und weisen Sie das gewünschte Hintergrundformat für den Bereich über den Zeilenfeldern und links von den Spaltenfeldern zu. Weisen Sie der Titelleiste die gewünschte Text- und Hintergrundformatierung zu.

  8. Zeigen Sie die Dropbereiche an, und weisen Sie die gewünschte Text- und Hintergrundformatierung zu.


Markieren von Elementen einer PivotTable-Liste

Das Feld Auswahl im Abschnitt Allgemein der PivotTable-Eigenschaftentoolbox kennzeichnet, welches Element der PivotTable-Liste aktuell ausgewählt ist. Zum Anzeigen der Toolbox klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image]. So identifizieren Sie Elemente einer PivotTable-Liste.

Mehrfachauswahl Sie können gleichzeitig nicht mehr als ein Exemplar eines Elements markieren. Sie können beispielsweise gleichzeitig nicht mehr als ein Feld markieren. In den meisten Fällen gilt jedoch die Formatierung, die Sie einem Element zuweisen, für alle Elemente desselben Typs in der PivotTable-Liste, wie in der folgenden Tabelle erläutert.

Zum Auswählen | Aktion ausführen
der gesamten PivotTable-Liste | Klicken Sie auf Titelleiste. Wenn die PivotTable-Liste über keine Titelleiste verfügt, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste und klicken im Kontextmenü auf Eigenschaftentoolbox. Klicken Sie auf die Leiste Ein-/Ausblenden, und klicken Sie dann auf Titelleiste [image] . Sie müssen Daten zu einer PivotTable-Liste hinzufügen, bevor Sie ihre Titelleiste anzeigen können.
Datenzellen | Klicken Sie auf eine Zelle, um sie zu markieren. Klicken Sie auf eine Zelle, und ziehen Sie die Maustaste, um eine Gruppe von Zellen zu markieren. Sie können einzelne Datenzellen nicht formatieren.
Zeilen-, Spalten- oder Filterfeld | Klicken Sie auf die Feldbezeichnung. Beim Markieren eines Zeilen- oder Spaltenfeldes werden auch alle Datenelemente in dem Feld markiert. Formate, die Sie einem Feld zuweisen, gelten für alle Zeilen-, Spalten- und Filterfeldbezeichnungen in der PivotTable-Liste.
Detailfeld | Klicken Sie auf die Feldbezeichnung. Wenn Detaildaten für mehrere Elemente angezeigt werden, so dass die Feldbezeichnung mehrmals angezeigt wird, und Sie auf ein Exemplar der Feldbezeichnung klicken, werden alle Exemplare markiert. Formate, die Sie einem Detailfeld zuweisen, gelten nur für die Datenzellen des jeweiligen Feldes.
Gesamtsummenfeld | Klicken Sie auf eine beliebige Feldbezeichnung des Gesamtsummenfeldes. Zum Anzeigen der Bezeichnungen des Gesamtsummenfeldes müssen Sie mindestens ein Feld in den Zeilen- oder Spaltenbereich verschieben und unter Umständen die Details für die betreffenden Felder ausblenden. Formate, die Sie einem Gesamtsummenfeld zuweisen, gelten für alle Gesamtsummenfelder in der PivotTable-Liste und nur für die Datenzellen für das Feld. Zum Formatieren der Bezeichnungen des Gesamtsummenfeldes markieren Sie ein Datenelement in einem Zeilen- oder Spaltenfeld. Hier finden Sie ein Beispiel für ein Gesamtsummenfeld.
Datenelement in einem Feld | Klicken Sie auf die Elementbezeichnung, Achten Sie darauf, dass Sie nicht auf das Erweiterungssymbol Pluskästchen oder Minuskästchen klicken, sofern das Element ein solches besitzt. Beim Markieren eines Elements werden auch alle Daten des betreffenden Elements markiert. Formate, die Sie einem Element zuweisen, gelten für alle Elementbezeichnungen, Detailfeldbezeichnungen, Teilergebnisbezeichnungen, Gesamtergebnisbezeichnungen und Gesamtsummenfeldbezeichnungen in der PivotTable-Liste.
Teilergebnis oder Gesamtergebnis | Klicken Sie auf das Teilergebnis oder Gesamtergebnis. Beim Markieren eines Teilergebnisses oder Gesamtergebnisses werden auch alle Daten für das Teilergebnis oder das Gesamtergebnis markiert. Formate, die Sie einem Teilergebnis oder Gesamtergebnis zuweisen, gelten für alle Datenzellen der Teilergebnisse oder Gesamtergebnisse in dem Zeilen- oder Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden. Zum Formatieren der Teilergebnis- und Gesamtergebnisbezeichnungen markieren Sie ein Datenelement in einem Zeilen- oder Spaltenfeld. Hier finden Sie ein Beispiel für Teilergebnisse und Gesamtergebnisse.


Festlegen von Schriftart und Textformat für Daten in einer PivotTable-Liste

Sie können die Schriftart und das Textformat für eine ganze PivotTable-Liste nicht in einem Schritt durchführen. In den meisten Fällen gelten jedoch Formate, die Sie einem Element zuweisen, für alle Elemente desselben Typs.

Um die Schriftart und das Textformat für die ganze PivotTable-Liste festzulegen, markieren Sie ein Zeilen-, Spalten- oder Filterfeld, ein Datenelement in einem Zeilen- oder Spaltenfeld und ein Gesamtsummenfeld, und formatieren Sie es einzeln. Formatieren Sie für jedes Zeilen- und Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden, das Gesamtergebnis oder Teilergebnis. Wenn in der PivotTable-Liste Detailfelder angezeigt werden können, formatieren Sie jedes Detailfeld einzeln.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Markieren Sie das Element, das formatiert werden soll.

    Wie wird´s gemacht?

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Format nicht eingeblendet ist, klicken Sie auf die Leiste Format.

  5. Klicken Sie auf die gewünschten Formatoptionen.

    Um den Text fett zu formatieren, klicken Sie auf Fett [image].

    Um den Text kursiv zu formatieren, klicken Sie auf Kursiv [image].

    Um den Text zu unterstreichen, klicken Sie auf Unterstrichen [image].

    Um die Textfarbe zu ändern, klicken Sie auf den Pfeil neben Schriftfarbe [image], und klicken Sie dann auf die gewünschte Farbe.

    Um die Schriftart zu ändern, klicken Sie in der Liste Schriftart auf eine andere Schriftart.

    Um den Schriftgrad zu ändern, klicken Sie in der Liste Größe auf eine andere Größe.

Anmerkungen

  • Wenn Sie die Textfarbe auf die gleiche Farbe festlegen wie den Hintergrund, können Sie den Text nicht anzeigen.

  • Die in den Listen verfügbaren Schriftarten und Schriftgrößen hängen von den Schriftarten ab, die auf dem System installiert sind.


Ausrichten von Text in einer Zelle einer PivotTable-Liste

Sie können die Textausrichtung für eine ganze PivotTable-Liste nicht in einem Schritt durchführen. In den meisten Fällen gilt jedoch die Ausrichtung, die Sie einem Element zuweisen, für alle Elemente desselben Typs.

Um die Textausrichtung für alle Elemente, für die die Ausrichtung geändert werden kann, in der gesamten PivotTable-Liste festzulegen, markieren Sie ein Zeilen- oder Spaltenfeld und ein Gesamtsummenfeld. Wenn in der PivotTable-Liste Detailfelder angezeigt werden können, richten Sie den Text in jedem Detailfeld einzeln aus.

Sie können die horizontale Ausrichtung von Zeilen-, Spalten- oder Filterfeldbezeichnungen nicht ändern.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Markieren Sie das Element, das geändert werden soll.

    Vorgehensweise

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Bereich Format nicht eingeblendet ist, klicken Sie auf die Leiste Format.

  5. Klicken Sie im Feld Horizontale Ausrichtung auf die gewünschte Ausrichtung: Links, Zentriert, Rechts oder Automatisch. Bei der automatischen Ausrichtung werden Zahlen und Datumsangaben rechts und Text links ausgerichtet.

Anmerkung Sie können darüber hinaus Teilergebnis- und Gesamtergebniselemente relativ zu den Detaildaten ausrichten.


Festlegen der Hintergrundfarben von Zellen in einer PivotTable-Liste

Sie können die Hintergrundfarbe für alle Elemente einer PivotTable-Liste nicht in einem Schritt festlegen. In den meisten Fällen gelten jedoch die Farben, die Sie einem Element zuweisen, für alle Elemente desselben Typs. Zeilen-, Spalten- und Filterfelder bilden beispielsweise einen Typ, so dass beim Festlegen der Farbe für Filterfeldbezeichnungen Zeilen- und Spaltenfeldbezeichnungen die gleiche Farbe erhalten.

Um die Hintergrundfarben für alle Elemente in der PivotTable-Liste festzulegen, wählen Sie die Hintergrundfarbe einzeln für die gesamte PivotTable-Liste, ein Zeilen-, Spalten- oder Filterfeld, ein Datenelement in einem Zeilen- oder Spaltenfeld und ein Gesamtsummenfeld aus und legen sie fest. Für jedes Zeilen- und Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden, legen Sie die Hintergrundfarbe für das Gesamtergebnis oder Teilergebnis fest. Wenn in der PivotTable-Liste Detailfelder angezeigt werden können, legen Sie die Hintergrundfarbe für jedes Detailfeld einzeln fest.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Markieren Sie das Element, das geändert werden soll.

    Vorgehensweise

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Format nicht eingeblendet ist, klicken Sie auf die Leiste Format.

  5. Klicken Sie auf den Pfeil neben Hintergrund [image], und klicken Sie dann auf die gewünschte Farbe.

Anmerkung Wenn die Hintergrundfarbe auf dieselbe Farbe eingestellt wird wie der Text, können Sie den Text nicht sehen.


Ändern der Bezeichnungen und Namen in einer PivotTable-Liste

Sie können den Titel der PivotTable-Liste, die Feldnamen, die Namen der Elemente in Feldern sowie die Namen von Gesamtsummenfeldern ändern. Die vorgenommenen Änderungen haben keine Auswirkung auf die Quelldaten.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Markieren Sie die Bezeichnung oder den Namen, der geändert werden soll.

    Wie wird´s gemacht?

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Beschriftungen nicht eingeblendet ist, klicken Sie auf die Leiste Beschriftungen.

  5. Geben Sie im Feld Beschriftung den neuen Namen ein.

Anmerkung Zum Ändern des Titelleistentextes klicken Sie auf die Titelleiste und geben dann im Abschnitt Format der Toolbox den neuen Text im Feld PivotTable-Titel ein.


Ändern der Breite einer Spalte in einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Zeigen Sie auf den rechten Rand der Feldbeschriftung, bis sich der Zeiger in Zeiger mit rechtwinklig angeordneten Doppelpfeilen ändert.

  3. Führen Sie einen der folgenden Schritte durch:

    Ziehen Sie den Rand, bis die Spalte die gewünschte Breite besitzt.

    Um die Spaltenbreite an den Inhalt anzupassen, doppelklicken Sie auf den Spaltenrand.

Anmerkung Sie können darüber hinaus die Höhe aller Zeilen im Detailbereich ändern, obwohl Sie nicht die Zeilenhöhe außerhalb des Detailbereichs anpassen können.


Ändern der Zahlenformate in einer PivotTable-Liste

Sie können das Zahlenformat in Detailfeldern und Gesamtsummenfeldern ändern. Wenn das Feld, für das Sie das Zahlenformat ändern möchten sich im Zeilen-, Spalten- oder Filterbereich befindet und für die Quelldaten ein Verschieben der Felder in den Detailbereich zulässig ist, können Sie das Feld zeitweise in den Detailbereich verschieben, das Format ändern und dann das Feld zurück verschieben.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf das Detailfeld oder Gesamtsummenfeld, für das Sie das Zahlenformat ändern möchten.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Format nicht eingeblendet ist, klicken Sie auf die Leiste Format.

  5. Klicken Sie in der Liste Zahlenformat auf das gewünschte Format.

    Weitere Informationen finden Sie unter Verfügbare Zahlenformate.


Zahlenformate für PivotTable-Listen

Die Einstellungen im Dialogfeld Eigenschaften von Ländereinstellungen der Windows-Systemsteuerung bestimmen, wie Zahlen-, Währungs-, Datums- und Uhrzeitformat im Entwurfsprogramm und zur Laufzeit im Browser angezeigt werden. Diese Einstellungen legen beispielsweise fest, ob Jahresangaben zweistellig oder vierstellig angezeigt werden. Weitere Informationen zu diesen Formaten finden Sie in der Windows-Hilfe.

In Microsoft Visual Basic oder in einem Skript können Sie den Daten benutzerdefinierte Zahlenformate zuweisen. Weitere Informationen finden Sie in der Hilfe zum Schreiben von Programmen und Skripts für PivotTable-Listen.

Die folgenden Zahlenformate stehen im Abschnitt Format der PivotTable-Eigenschaftentoolbox in der Liste Zahlenformat zur Verfügung.

Format | Effekte
Allgemeine Zahl | Zeigt eine Zahl rechts ausgerichtet, ohne 1.000er-Trennzeichen und (sofern negativ) einem Minuszeichen davor an. Zeigt bis zu 11 Ziffern oder 10 Ziffern mit einem Dezimaltrennzeichen an, wobei zusätzliche Ziffern rechts vom Dezimaltrennzeichen gerundet werden. Zeigt Zahlen mit mehr als 11 Ziffern links vom Dezimaltrennzeichen in exponentiellem Format an. Zeigt Text links ausgerichtet an.
Standardatum | Zeigt eine Zahl als Datum und optionaler Uhrzeit an. Beispiel: 31.8.99 14:23. Der Nachkommaanteil der Zahl bildet die Uhrzeit. Besitzt eine Zahl keinen Nachkommaanteil, wird nur das Datum angezeigt. Besitzt eine Zahl lediglich einen Nachkommaanteil und keinen ganzzahligen Teil, wird nur die Uhrzeit angezeigt.
Datum, lang | Zeigt ein Datum entsprechend der Windows-Ländereinstellung für das lange Datumsformat an. Beispiel: Dienstag, 25. Januar 2001.
Datum, mittel | Zeigt ein Datum entsprechend den Windows-Ländereinstellungen für das Monats- und Datumstrennzeichen an sowie zwei Ziffern für das Jahr. Beispiel: 25.Jan.01.
Datum, kurz | Zeigt ein Datum entsprechend der Windows-Ländereinstellung für das kurze Datumsformat an. Beispiel: 25.1.01 .
Zeit, lang | Zeigt eine Uhrzeit entsprechend der Windows-Ländereinstellung für das lange Uhrzeitformat an. Beispiel: 20:45:36.
Zeit, 12 Std | Zeigt eine Uhrzeit im 12-Stundenformat mit dem Bezeichner AM oder PM ohne Sekunden an. Beispiel: 8:45 PM.
Zeit, 24 Std | Zeigt eine Uhrzeit im 24-Stundenformat ohne Sekunden an. Beispiel: 20:45.
Währung | Zeigt eine Zahl entsprechend der Windows-Ländereinstellung für die Währung, gegebenenfalls mit 1.000er-Trennzeichen und zwei Dezimalstellen an. Beispiel (Standardländereinstellungen für Englisch (USA)): DM 2.532,75.
Eurowährung | Zeigt eine Zahl in der Währung Euro an, mit 1.000er-Trennzeichen und zwei Dezimalstellen. Das Euro-Symbol wird in Abhängigkeit von den Ländereinstellungen in der Windows-Systemsteuerung vor oder hinter die Zahl gesetzt. Beispiel mit den Standardländereinstellungen für Deutschland: 12,35 [image] .
Festkommazahl | Zeigt eine Zahl mit zwei Dezimalstellen an. Beispiel: 68,30.
Standardzahl | Zeigt eine Zahl mit einem 1.000er-Trennzeichen und zwei Ziffern rechts vom Dezimaltrennzeichen an. Die Windows-Ländereinstellungen für Zahlen legen fest, welches Zeichen als 1.000er-Trennzeichen verwendet wird. Beispiel (Verwendung des Punkts als 1.000er-Trennzeichen): 1.800,00.
Prozentzahl | Zeigt eine Zahl multipliziert mit 100, zwei Dezimalstellen und einem Prozentzeichen an. Der Wert 0.8914 wird beispielsweise als 89.14% angezeigt.
Wissenschaft | Zeigt eine Zahl in wissenschaftlicher Notation an. Beispiel: 1.25E+10.
Ja/Nein | Zeigt Nein an, wenn die Zahl 0 ist; zeigt Ja für jede andere Zahl an.
Wahr/Falsch | Zeigt Falsch an, wenn die Zahl 0 ist; zeigt Wahr für jede andere Zahl an.
Ein/Aus | Zeigt Aus an, wenn die Zahl 0 ist; zeigt Ein für jede andere Zahl an.


Ausblenden der Dropbereiche in einer PivotTable-Liste

Durch Ausblenden werden die Dropbereiche sowohl im Entwurfsprogramm als auch zur Laufzeit im Browser ausgeblendet. Wenn die Dropbereiche ausgeblendet sind und die PivotTable-Liste noch keine Zeilen-, Spalten-, Daten- oder Filterfelder enthält, können Sie keine Felder in diese Bereiche ziehen. Sie können jedoch Felder mit Hilfe der Schaltflächen auf der Symbolleiste in der PivotTable-Liste weiterhin hinzufügen und verschieben.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden.

  4. Klicken Sie auf Dropbereiche [image], so dass die Schaltfläche nicht mehr gedrückt ist.


Formatieren der Dropbereichbeschriftungen für eine PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Dropbereichbeschriftungen nicht eingeblendet ist, klicken Sie auf die Dropbereichbeschriftungen-Leiste.

  5. Nehmen Sie in den Feldern Zeilenbereich, Spaltenbereich, Detailbereich und Filterbereich die gewünschten Änderungen am Beschriftungstext vor.

    Wenn Sie überhaupt keine Dropbereichbeschriftungen anzeigen möchten, können Sie auch zum Löschen des Dropbereichtextes die Dropbereiche ausblenden.

  6. Klicken Sie auf die gewünschten Formatoptionen.

    Um die Beschriftungen fett zu formatieren, klicken Sie auf Fett [image].

    Um die Beschriftungen kursiv zu formatieren, klicken Sie auf Kursiv [image].

    Um den Beschriftungstext zu unterstreichen, klicken Sie auf Unterstrichen [image].

    Um die Farbe der Beschriftung zu ändern, klicken Sie auf den Pfeil neben Schriftfarbe [image], und klicken Sie dann auf die gewünschte Farbe. Wenn Sie auf dieselbe Farbe klicken wie die Hintergrundfarbe, können Sie den Beschriftungstext nicht sehen.

    Um die Schriftart zu ändern, klicken Sie in der Liste Schriftart auf eine andere Schriftart. Die in der Liste verfügbaren Schriftarten hängen von den Schriftarten ab, die auf dem System installiert sind.

    Um den Schriftgrad zu ändern, klicken Sie in der Liste Größe auf einen anderen Schriftgrad. Die verfügbaren Schriftgrade hängen von den Schriftarten ab, die auf dem System installiert sind.

    Um die Hintergrundfarbe zu ändern, klicken Sie auf den Pfeil neben Hintergrund [image], und klicken Sie dann auf die gewünschte Farbe. Wenn Sie die Hintergrundfarbe auf dieselbe Farbe einstellen wie die Textfarbe, können Sie den Text nicht sehen.

Anmerkung Diese Einstellungen können im Browser nicht geändert werden.


Anzeigen oder Ausblenden der Titelleiste in einer PivotTable-Liste

Zum Anzeigen der Titelleiste müssen Sie zunächst Daten zu der PivotTable-Liste hinzufügen.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn der Abschnitt Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Leiste Ein-/Ausblenden.

  4. Führen Sie einen der folgenden Schritte durch:

    Zum Anzeigen der Titelleiste klicken Sie auf Titelleiste [image], so dass die Schaltfläche gedrückt ist.

    Zum Ausblenden der Titelleiste klicken Sie auf Titelleiste [image], so dass die Schaltfläche nicht gedrückt ist.

Anmerkung Im Browser können die Benutzer die Titelleiste anzeigen oder ausblenden und den Titelleistentext ändern, solange Sie nicht deren Zugriff auf die PivotTable-Eigenschaftentoolbox einschränken. Die Optionen im Abschnitt Format - Titelleiste der Eigenschaftentoolbox stehen im Browser nicht zur Verfügung. So formatieren Sie die Titelleiste.


Formatieren der Titelleiste einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Format nicht eingeblendet ist, klicken Sie auf Format-Leiste.

  5. Geben Sie im Feld PivotTable-Titel den Text für den Titel ein oder ändern Sie ihn.

    Der Befehl Hintergrund im Abschnitt Format formatiert den Hintergrundbereich hinter den Daten in der PivotTable-Liste und nicht den Hintergrund der Titelleiste.

  6. Wenn der Abschnitt Format - Titelleiste nicht eingeblendet ist, klicken Sie auf die Format - Titelleiste-Leiste.

  7. Klicken Sie auf die gewünschten Formatoptionen.

    Um den Titeltext fett zu formatieren, klicken Sie auf Fett [image].

    Um den Titeltext kursiv zu formatieren, klicken Sie auf Kursiv [image].

    Um den Titeltext zu unterstreichen, klicken Sie auf Unterstrichen [image].

    Um die Farbe des Titeltextes zu ändern, klicken Sie auf den Pfeil neben Schriftfarbe [image], und klicken Sie dann auf die gewünschte Farbe.

    Um die Schriftart zu ändern, klicken Sie in der Liste Schriftart auf eine andere Schriftart. Die in der Liste verfügbaren Schriftarten hängen von den Schriftarten ab, die auf dem System installiert sind.

    Um den Schriftgrad zu ändern, klicken Sie in der Liste Größe auf einen anderen Schriftgrad. Die verfügbaren Schriftgrade hängen von den Schriftarten ab, die auf dem System installiert sind.

    Zum Ändern der Hintergrundfarbe klicken Sie auf den Pfeil neben Hintergrundfarbe [image], und klicken Sie dann auf die gewünschte Farbe. Wenn Sie für die Hintergrundfarbe dieselbe Farbe verwenden wie für den Text, können Sie den Text nicht sehen. Um die Windows-Systemfarben im Entwurfsprogramm und im Browser zu verwenden, so dass die Titelleiste in der PivotTable-Liste mit den Titelleisten anderer Fenster übereinstimmt, klicken Sie auf Standard.

Anmerkungen

  • Wenn Sie für die PivotTable-Liste keine Titelleiste anzeigen möchten, klicken Sie auf die Ein-/Ausblenden-Leiste und dann auf Titelleiste [image], so dass die Schaltfläche nicht gedrückt ist.

  • Im Browser können Benutzer die Titelleiste anzeigen oder ausblenden und den Titelleistentext ändern, solange Sie nicht deren Zugriff auf die PivotTable-Eigenschaftentoolbox einschränken. Die Optionen im Abschnitt Format - Titelleiste stehen im Browser nicht zur Verfügung.


Anzeigen einer PivotTable-Liste von rechts nach links oder umgekehrt

Verwenden Sie die Anzeige von rechts nach links, wenn Ihre PivotTable-Liste in Sprachen mit Schreibweise von rechts nach links angezeigt wird. Bei Auswahl der Anzeige von rechts nach links, werden die Elemente der PivotTable-Liste zur Standardanzeige von links nach rechts gespiegelt angezeigt: Die Dropbereiche befinden sich auf der oberen rechten Seite der PivotTable-Liste, und die Zeilenfelder in den am weitesten rechts liegenden Spalten, und die Elemente in Spaltenfelder werden von rechts nach links aufgeführt.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Eigenschaftentoolbox [image].

  4. Wenn der Abschnitt Erweitert nicht eingeblendet ist, klicken Sie auf die Leiste Erweitert.

  5. Führen Sie einen der folgenden Schritte durch:

    Zum Anzeigen der PivotTable-Liste von rechts nach links, aktivieren Sie das Kontrollkästchen Von rechts nach links anzeigen.

    Zum Anzeigen der PivotTable-Liste von links nach rechts, deaktivieren Sie das Kontrollkästchen Von rechts nach links anzeigen.

Anmerkung Diese Einstellung kann im Browser nicht geändert werden.


Aktualisieren einer PivotTable-Liste mit aktualisierten Quelldaten

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Klicken Sie auf die PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Aktualisieren [image].

Anmerkungen

  • Der Office-Logowürfel Office-Logowürfel hört auf sich zu drehen, wenn der Aktualisierungsvorgang abgeschlossen ist. Während die PivotTable-Liste aktualisiert wird, können Sie sie nicht bearbeiten oder ändern. Sie können den Aktualisierungsvorgang nicht abbrechen, während die Daten geladen werden. Um einen Aktualisierungsvorgang während der Berechnung der PivotTable-Liste abzubrechen, drücken Sie ESC.

  • So beheben Sie Probleme beim Aktualisieren einer PivotTable-Liste.


Abbrechen der Aktualisierung einer PivotTable-Liste

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen hierzu finden Sie in der Hilfe Ihres Entwurfsprogramms.

  2. Drücken Sie während der Berechnung der PivotTable-Liste ESC.

Anmerkungen

  • Sie können den Aktualisierungsvorgang nur abbrechen, wenn die PivotTable-Liste berechnet wird. Während dem Laden der Quelldaten können Sie den Ladevorgang nicht abbrechen.

  • Nach dem Abbruch zeigt die PivotTable-Liste temporär keine Daten an. Um die Daten erneut anzuzeigen, klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Aktualisieren [image].

  • So beheben Sie Probleme beim Aktualisieren einer PivotTable-Liste.


Verwenden einer PivotTable-Liste in Microsoft Excel oder Microsoft Word

Wie möchten Sie verfahren?

Exportieren einer PivotTable-Liste in einen Excel PivotTable-Bericht

Kopieren einer ganzen PivotTable-Liste nach Excel oder Word

Kopieren eines Teils einer PivotTable-Liste nach Excel oder Word

Sie sind sich über die gewünschte Auswahl nicht sicher?


Informationen zum Verwenden einer PivotTable-Liste in Microsoft Excel oder anderen Programmen

Wenn Sie mit Microsoft Excel PivotTable-Berichten vertraut sind und mit den Daten in Excel arbeiten möchten, können Sie dies auf verschiedene Weise erreichen. Wenn Sie jedoch eine Webseite, die eine PivotTable-Liste enthält, direkt in Microsoft Excel öffnen, können Sie die PivotTable-Liste weder anzeigen noch ändern. Dieses Thema erläutert die Möglichkeiten, die PivotTable-Liste in Excel oder andere Programme zu übernehmen, und enthält Informationen über:

Exportieren in einen interaktiven Excel PivotTable-Bericht

Kopieren von Daten in ein anderes Programm für nichtinteraktive Verwendung

Die Benutzer verfügen über die gleichen Export- und Kopiermöglichkeiten im Browser wie Sie im Entwurfsprogramm.

Exportieren in einen interaktiven Excel PivotTable-Bericht

Um eine PivotTable-Liste auf einer Webseite mit Hilfe von Excel anzuzeigen und zu ändern, können Sie die PivotTable-Liste nach Excel exportieren. Der Excel PivotTable-Bericht wird mit denselben Quelldaten wie die ursprüngliche PivotTable-Liste verbunden, so dass alle Felder und Daten aus der ursprünglichen PivotTable-Liste in Excel verfügbar sind. Sie können den Bericht aktualisieren, wenn sich die Quelldaten ändern.

Vorbereiten des Exports nach Excel Excel PivotTable-Berichte können keine Detailfelder anzeigen. Beim Exportieren nach Excel stehen die Detailfelder in der Excel-Symbolleiste PivotTable zur Verfügung, die Felder werden jedoch nicht im Bericht angezeigt. Wenn der Excel PivotTable-Bericht das Erscheinungsbild der PivotTable-Liste im Web behalten soll, verschieben Sie alle Felder in der PivotTable-Liste vor dem Exportieren in einen Excel PivotTable-Bericht aus dem Detailbereich, und blenden Sie die Details für Elemente und Zellen aus, so dass keine Detailbereiche angezeigt werden.

Features von PivotTable-Listen, die nicht exportiert werden Die folgenden Features von PivotTable-Listen werden in Excel PivotTable-Berichten nicht unterstützt und deshalb nicht exportiert:

  • Detailfelder Excel PivotTable-Berichte können keine Detailfelder anzeigen. Alle Quelldaten sind jedoch weiterhin verfügbar, und Sie können alle in der Excel-Symbolleiste PivotTable aufgeführten Detailfelder anzeigen. Weitere Informationen zum Anzeigen von Details für Zellen in Excel PivotTable-Berichten finden Sie in der Hilfe von Excel.

  • Filtereinstellungen Bei einigen Quelldatentypen werden die Filtereinstellungen bei einem auswahlbasierten Filter nicht exportiert. Ferner werden keine Filtereinstellungen für Felder, die nicht angezeigt werden, exportiert. Sie können diese Felder in Excel jedoch neu filtern.

  • Wochenebene in Datumsfeldern Beim Exportieren einer PivotTable-Liste, in der die Wochenebene angezeigt wird, wird im Excel PivotTable-Bericht stattdessen die Monatsebene angezeigt. Sie können in Excel das Feld so gruppieren, dass die Tage in Gruppen zu sieben Tagen angezeigt werden. Weitere Informationen über das Gruppieren von Feldern in PivotTable-Berichten finden Sie in der Hilfe von Excel.

  • Einschränkungseinstellungen Alle festgelegten Einschränkungen hinsichtlich dem Verschieben von Feldern, Filtern und Anzeigen von Detaildaten in der PivotTable-Liste sind in der exportierten Version nicht mehr wirksam. Da die Benutzer eine PivotTable-Liste auch aus dem Browser nach Excel exportieren können, können Sie anschließend die Excel-Features verwenden, um alle in den Quelldaten verfügbaren Details anzuzeigen. Wenn Sie nicht möchten, dass die Benutzer auf diese Weise Zugriff auf die Detaildaten erhalten, können Sie im Browser den Zugriff auf den Befehl Nach Excel exportieren verhindern, indem Sie die Symbolleiste und die Titelleiste deaktivieren und den Zugriff auf die PivotTable-Eigenschaftentoolbox einschränken. Weitere Informationen finden Sie unter Einschränken des Zugriffs auf Features im Browser.

Zurück zum Anfang

Kopieren von Daten in ein anderes Programm für nichtinteraktive Verwendung

Kopieren nach Microsoft Word oder Excel Wenn Sie mit einer Momentaufnahme der Daten, die aktuell in einer PivotTable-Liste angezeigt werden, arbeiten möchten, können Sie die Daten kopieren und in Excel oder Word einfügen. Wenn Sie die ganze PivotTable-Liste in ein anderes Programm kopieren oder bestimmte Teile der Daten kopieren, werden Text und Werte der PivotTable-Liste Bestandteil des Word-Dokuments oder der Excel-Arbeitsmappe. Zwischen den ursprünglichen Quelldaten der PivotTable-Liste und der Kopie im Dokument oder in der Arbeitsmappe besteht keine Verbindung, so dass die kopierten Daten nicht aktualisiert werden können.

Kopieren in andere Programme Darüber hinaus können Sie die in einer PivotTable-Liste angezeigten Daten in andere Programme, wie z. B. Microsoft FrontPage oder Microsoft Access, kopieren. Wenn Sie die Daten in ein anderes Programm als Excel oder Word kopieren, das das von PivotTable-Listen verwendete HTML-Format nicht unterstützt, werden die Daten als unformatierter Text kopiert.

Zurück zum Anfang


Kopieren einer ganzen PivotTable-Liste nach Microsoft Excel oder Microsoft Word

Verwenden Sie dieses Verfahren, um eine PivotTable-Liste zu kopieren und sie als nicht interaktive, formatierte Tabelle in Excel oder Word einzufügen. Um die Liste als interaktiven Excel PivotTable-Bericht zu kopieren, exportieren Sie die PivotTable-Liste nach Excel.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf die Titelleiste der PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Kopieren [image].

  4. Wechseln Sie zu Excel oder Word, und klicken Sie auf die Stellen, an denen die Daten aus der PivotTable-Liste angezeigt werden sollen.

  5. Klicken Sie auf Einfügen [image].

Anmerkungen

  • Wenn Sie eine PivotTable-Liste kopieren, werden lediglich Formatierung und Datenwerte kopiert. Zwischen der Kopie in Word oder Excel und der ursprünglichen Quelldatenbank besteht keine Verbindung mehr. Die Kopie in Word oder Excel ist nicht interaktiv und kann nicht aktualisiert werden.

  • Sie können auch einen Teil einer PivotTable-Liste nach Word oder Excel kopieren.


Kopieren eines Teils einer PivotTable-Liste nach Microsoft Excel oder Microsoft Word

Verwenden Sie dieses Verfahren, um in einer PivotTable-Liste markierte Werte zu kopieren und sie als nicht interaktive, formatierte Tabelle in Excel oder Word einzufügen. Um die Daten als interaktiven Excel PivotTable-Bericht zu kopieren, exportieren Sie die PivotTable-Liste nach Excel.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Markieren Sie den Teil der PivotTable-Liste, den Sie kopieren möchten.

    Vorgehensweise

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Kopieren [image].

  4. Wechseln Sie zu Excel oder Word, und klicken Sie auf die Stelle, an der die Daten aus der PivotTable-Liste angezeigt werden sollen.

  5. Klicken Sie auf Einfügen [image].

Anmerkungen

  • Wenn Sie einen Teil einer PivotTable-Liste kopieren, werden lediglich Formatierung und Werte kopiert. Zwischen der Kopie in Word oder Excel und der ursprünglichen Quelldatenbank besteht keine Verbindung mehr. Die Kopie in Word oder Excel ist nicht interaktiv und kann nicht aktualisiert werden.

  • Sie können einen Teil einer PivotTable-Liste auch als unformatierten Text in andere Programme, wie z. B. Microsoft Access, kopieren.

  • Darüber hinaus können Sie eine ganze PivotTable-Liste nach Word oder Excel kopieren.


Exportieren einer PivotTable-Liste in einen Microsoft Excel PivotTable-Bericht

Verwenden Sie das folgende Verfahren, um eine PivotTable-Liste aus Ihren Entwurfsprogramm als interaktiven PivotTable-Bericht nach Excel zu exportieren. Die Verbindung zwischen dem Excel PivotTable-Bericht und der ursprünglichen Quelldatenbank bleibt erhalten.

Um optimale Ergebnisse zu erzielen, verschieben Sie alle Felder aus dem Detailbereich und blenden die Details für Elemente und Zellen aus, bevor Sie die Liste nach Excel exportieren.

  1. Stellen Sie sicher, dass die PivotTable-Liste im Entwurfsfenster aktiviert ist. Anleitungen dazu finden Sie in der Hilfe Ihres Entwurfsprogrammes.

  2. Klicken Sie auf die PivotTable-Liste.

  3. Klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Nach Excel exportieren [image], um Excel auszuführen oder zu Excel zu wechseln und die Daten in einem PivotTable-Bericht anzuzeigen.

Anmerkung Da PivotTable-Berichte in Excel einige Layouts und Berechnungen von PivotTable-Listen nicht anzeigen können, wird der PivotTable-Bericht möglicherweise anders angezeigt als die PivotTable-Liste im Entwurfsprogramm. Alle in der Feldliste im Entwurfsprogramm verfügbaren Felder und Daten können in den PivotTable-Bericht eingefügt werden, einschließlich der nicht angezeigten Felder. Detailfelder werden jedoch nicht in dem Bericht angezeigt und in einigen Feldern werden möglicherweise andere Werte berechnet. Weitere Informationen zum Arbeiten mit PivotTable-Berichten und zum Hinzufügen von Felder finden Sie in der Excel-Hilfe.


Problembehandlung bei PivotTable-Listen

Aktualisieren

Die Daten in der PivotTable-Liste können nicht von der Datenquelle aktualisiert werden.

Die Abfrage in einer PivotTable-Liste ist fehlgeschlagen.

Filtern und Sortieren

Die Daten können nicht wie gewünscht gefiltert werden.

Die Daten in einem Feld werden nicht richtig sortiert.

Verschieben von Feldern

Das gewünschte Feld kann nicht hinzugefügt oder verschoben werden.

Beim Ändern des Layouts dauert es sehr lange, bis die Daten angezeigt werden.

Die PivotTable-Eigenschaftentoolbox oder die Feldliste wird nicht mehr angezeigt.

Daten

Zu der in der PivotTable-Liste angegebenen Datenquelle kann keine Verbindung hergestellt werden.

Die Detaildaten werden nicht angezeigt.

Die Felder sind zwar vorhanden, aber die Daten fehlen.

Nach dem Kopieren einer PivotTable-Liste nach Microsoft Excel oder Microsoft Word fehlen Daten.

In einer Zelle wird ##### an Stelle einer Zahl angezeigt.

Ein Diagramm, das auf einer PivotTable-Liste basiert, ist leer oder verfügt über keine Daten.

Warum werden neben den Ergebnisse in der PivotTable-Liste Sternchen angezeigt?


In einer Zelle einer PivotTable-Liste wird ##### an Stelle einer Zahl angezeigt.

Wenn eine Zahl zu breit ist, um in eine Zelle zu passen, werden in der PivotTable-Liste Nummernzeichen an Stelle der Zahl angezeigt. Zum Beheben dieses Problems stehen Ihnen folgende Möglichkeiten zur Verfügung:

  • Verbreitern Sie die Spalte, damit die ganze Zahl hineinpasst.

  • Verkleinern Sie den Schriftgrad, wenn Sie die Spalte nicht verbreitern möchten.

  • Ändern Sie das Zahlenformat in eines, das weniger Platz beansprucht.


Ein Diagramm, das auf einer PivotTable-Liste basiert, ist leer oder verfügt über keine Daten.

Hinzufügen von Gesamtsummenfeldern Damit ein Diagramm Daten aus einer PivotTable-Liste anzeigen kann, müssen Sie zu der PivotTable-Liste mindestens ein Gesamtsummenfeld hinzufügen .

Verschieben von Feldern in die Zeilen- und Spaltenbereiche Die Zeilen- und Spaltenfelder in einer PivotTable-Liste liefern die Rubriken- und Datenreihendaten in dem Diagramm. Wenn sich alle Felder im Detailbereich der PivotTable-Liste befinden, verfügt das Diagramm beispielsweise über keine Rubriken und Datenreihen, die dargestellt werden. Verschieben Sie mindestens ein Feld aus dem Detailbereich oder aus der Feldliste in den Zeilenbereich oder den Spaltenbereich.


Die Daten in einem Feld einer PivotTable-Liste werden nicht richtig sortiert.

In einem Dimensionsfeld wurden eventuell Ebenen ausgeblendet Wenn Sie ein Feld in einer PivotTable-Liste sortieren, die auf einer Datenquelle aus einer OLAP-Datenbank basiert, werden die aktuelle Ebene und die darunter liegenden Ebenen sortiert. Die höheren Ebenen bestimmen, welche Elemente auf den unteren Ebenen zusammen sortiert werden. Sind eine oder mehrere Ebenen in einer Dimension beim Sortieren von Daten in einem Feld auf niedrigerer Ebene ausgeblendet, werden die Daten so sortiert, als ob die ausgeblendeten Ebenen vorhanden wären.

Wenn ein Dimensionsfeld beispielsweise die Ebenen "Land", "Region" und "Stadt" enthält, und die Ebene "Region" in der PivotTable-Liste beim Sortieren der Elemente im Feld "Stadt" nicht angezeigt wird, werden die Elemente "Stadt" für jede Region getrennt sortiert, obwohl die regionalen Informationen nicht angezeigt werden. Wenn daher ein Land die Regionen "Norden" und "Süden" enthält, werden die Elemente "Stadt" für die Region "Nord" und dann die Elemente "Stadt" für die Region "Süd" zusammen sortiert. Bei dem Sortiervorgang werden nicht alle Elemente "Stadt" für das Land kombiniert, obwohl es bei ausgeblendeter Ebene "Region" so scheint, als ob die Elemente "Stadt" kombiniert seien.

Schließen Sie alle Ebenen vor dem Sortieren ein Um zu verstehen, wie die Daten sortiert werden, entfernen Sie alle Ebenen der Dimension, fügen Sie das Dimensionsfeld in der PivotTable-Liste wieder ein und zeigen Sie die Ebenen anschließend erneut an, damit keine Ebene über der Ebene, die sortiert werden soll, fehlt.


Nach dem Kopieren einer PivotTable-Liste nach Microsoft Excel oder Microsoft Word fehlen Daten.

Wenn Sie die Daten in einer PivotTable-Liste in die Zwischenablage kopieren und in Microsoft Excel oder Microsoft Word einfügen, werden nur sichtbare Zeilen und Spalten kopiert. Alle ausgeblendeten oder gefilterten Daten werden nicht kopiert.

Kopieren aller Daten Bevor Sie Daten kopieren, deaktivieren Sie die Filterung, um alle Daten in der PivotTable-Liste anzuzeigen, und zeigen Sie die Detaildaten an, die kopiert werden sollen.

Exportieren nach Microsoft Excel Um zu vermeiden, dass alle Daten zunächst angezeigt werden müssen, können Sie die PivotTable-Liste exportieren anstatt zu kopieren. Beim Exportieren einer Kopie einer PivotTable-Liste nach Excel sind alle Daten automatisch enthalten, wobei dieselbe Filterung aktiv ist. Sie können auf zusätzliche Felder in der Datenquelle gleichermaßen zugreifen wie in einer PivotTable-Liste, und Sie können die Filterung in Excel ändern. Von Excel aus können Sie dann die Daten nach Word oder andere Programme kopieren oder die Daten erneut in einer PivotTable-Liste veröffentlichen. Weitere Informationen zum Arbeiten mit PivotTable-Berichten in Excel und zum Veröffentlichen auf einer Webseite finden Sie in der Excel-Hilfe.


Das gewünschte Feld kann in der PivotTable-Liste nicht hinzugefügt oder verschoben werden.

Das Feld wird möglicherweise bereits angezeigt Sie können ein Feld nicht gleichzeitig in mehr als einem Bereich anzeigen. Weitere Informationen finden Sie unter Ändern des Layouts einer PivotTable-Liste.

Die Datenquelle schränkt möglicherweise die Verwendbarkeit der Felder ein Eine Datenquelle aus OLAP-Datenbanken (On-Line Analytical Processing) liefert Feldgruppen für verschiedene Detailebenen. Innerhalb einer Feldgruppe können Sie Detailebenen ausblenden, jedoch keine Felder in der Gruppe zur Anzeige in anderen Bereichen heraustrennen.


Zu der in der PivotTable-Liste angegebenen Datenquelle kann keine Verbindung hergestellt werden.

Die Quelldatenbank ist möglicherweise nicht verfügbar Sie verfügen beispielsweise über keine Netzwerkverbindung oder benötigen möglicherweise Zugriffsrechte oder ein Kennwort, um eine Verbindung zum Server herzustellen. Im Browser müssen Benutzer, die die PivotTable-Liste anzeigen und bearbeiten möchten, denselben Zugriff und dieselben Berechtigungen für die Quelldatenbank besitzen wie Sie im Entwurfsprogramm. Wenden Sie sich an den Netzwerk- oder Datenbankadministrator, um Hilfe zu erhalten.

Office unterstützt möglicherweise die Quelldatenbank nicht Wenn die Quelldaten aus einer Datenbank stammen, die von Microsoft Office nicht unterstützt wird, müssen Sie eventuell eine Office-kompatible Unterstützungssoftware des Datenbankanbieters installieren. Die Benutzer müssen dieselbe Unterstützungssoftware installieren, um die PivotTable-Liste im Browser zu aktualisieren. Weitere Informationen über die erforderliche Software erhalten Sie vom Datenbankanbieter.

Die Verbindung wurde möglicherweise nicht richtig eingerichtet Um eine Verbindung zu den Quelldaten herzustellen, müssen Sie zunächst eine Verbindung oder Datenquelle zwischen der Quelldatenbank und Ihrem Entwurfsprogramm einrichten. Vergewissern Sie sich, dass die in Ihrem Entwurfsprogramm eingerichtete Datenquelle funktioniert und den Zugriff auf die Datenbank ermöglicht. Informationen zum Setup finden Sie in der Hilfe Ihres Entwurfsprogrammes und des Datenquellentreibers oder ODBC-Treibers. Stellen Sie beim Hinzufügen der Daten zu der PivotTable-Liste sicher, dass alle notwendigen Verbindungsinformationen enthalten sind. Weitere Informationen finden Sie unter Datenquellen für PivotTable-Listen.


Die Detaildaten in der PivotTable-Liste können nicht angezeigt werden.

Die Erweiterungssymbole sind möglicherweise deaktiviert Wenn die Kästchen Pluskästchen neben den Datenelementen in Zeilen- und Spaltenfeldern nicht angezeigt werden, vergewissern Sie sich, dass die Erweiterungssymbole aktiviert sind.

Weitere Details sind möglicherweise nicht verfügbar Wenn sich ein Datenelement auf der untersten Detailebene befindet, die von der Datenquelle verfügbar ist, wird neben dem Element das Kästchen Pluskästchen nicht angezeigt, auch wenn die Erweiterungssymbole aktiviert wurden.

Die Datenquelle enthält möglicherweise keine Detaildaten Einige Arten von Datenquellen, wie z. B. Datenquellen aus OLAP(On-Line Analytical Processing)-Datenbanken, verfügen über keine Detaildatensätze zur Anzeige. Weitere Informationen finden Sie unter Datenquellentypen für PivotTable-Listen.


Die Daten in der PivotTable-Liste können nicht wie gewünscht gefiltert werden.

Filterbeschränkungen Filtermöglichkeiten, die in Microsoft Excel-Arbeitsblättern und Excel PivotTable-Berichten verfügbar sind, wie z. B. benutzerdefinierte AutoFilter und Top-Ten-Filterung, stehen in PivotTable-Listen für das Web nicht zur Verfügung. Weiterhin ist keine Filterung möglich, die auf Teilen der Daten in einer Zelle basiert, ein Feature, das für Formulare und Datenblätter in Microsoft Access verfügbar ist. Weitere Informationen finden Sie unter Filtermöglichkeiten in PivotTable-Listen.

Verwenden von Access zum Anzeigen der Daten Wenn Sie eine Filterung benötigen, die auf Teilen einer Zelle basiert, arbeiten Sie mit der Datenquelle in Microsoft Access anstatt in einer PivotTable-Liste. Sie können die Daten in einem Formular oder einem Datenblatt in Microsoft Access möglicherweise direkt anzeigen, wo die Filterung anhand von Zellbestandteilen unterstützt wird. Nach dem Filtern der Daten in Access auf die gewünschte Weise können Sie mit der Entwurfsansicht für Datenzugriffsseiten eine neue PivotTable-Liste erstellen oder die vorhandene ändern, so dass die gefilterte Datenquelle verwendet wird. Weitere Informationen finden Sie in der Access-Hilfe.


Die Felder sind zwar in einer PivotTable-Liste vorhanden, aber die Daten fehlen.

Sie haben die Berechnung der PivotTable-Liste abgebrochen, oder die Berechnung wurde beendet, bevor sie vollständig durchgeführt wurde. Klicken Sie zum Anzeigen der Daten auf der Symbolleiste in der PivotTable-Liste auf Aktualisieren [image].

Tipp Vor dem Aktualisieren der Daten können Sie das Layout ändern oder in den Feldern die Elemente filtern.


Die PivotTable-Liste kann die Daten von der Datenquelle nicht aktualisieren.

Einige PivotTable-Listen können nicht aktualisiert werden PivotTable-Listen, die anhand von Daten aus Microsoft Excel-Arbeitsblättern gespeichert oder veröffentlicht werden, Excel-Webabfragen und Excel-Textabfragen können in anderen Entwurfsprogrammen oder im Browser aus der ursprünglichen Datenquelle nicht aktualisiert werden. In diesen Fällen müssen Sie die ursprüngliche Excel-Arbeitsmappe aktualisieren und die Veröffentlichung der Daten wiederholen.

Die Quelldatenbank ist möglicherweise nicht verfügbar Sie verfügen beispielsweise über keine Netzwerkverbindung oder benötigen Zugriffsrechte oder ein Kennwort, um eine Verbindung zum Server herzustellen. Im Browser müssen Benutzer, die die PivotTable-Liste anzeigen und bearbeiten möchten, denselben Zugriff und dieselben Berechtigungen für die Quelldatenbank besitzen wie Sie im Entwurfsprogramm. Wenden Sie sich an den Netzwerk- oder Datenbankadministrator, um Hilfe zu erhalten.

Office unterstützt möglicherweise die Quelldatenbank nicht Wenn die Datenquelle aus einer Datenbank stammt, die von Microsoft Office nicht unterstützt wird, müssen Sie eventuell eine Office-kompatible Unterstützungssoftware des Datenbankanbieters installieren. Die Benutzer müssen dieselbe Unterstützungssoftware installieren, um die PivotTable-Liste im Browser zu aktualisieren.

Die Quelldatenbank wurde möglicherweise geändert Manchmal können Änderungen an der Organisation einer Datenbank auf dem Server verhindern, dass Sie eine PivotTable-Liste aktualisieren können. Wenn die Quelldaten beispielsweise aus einer OLAP (On-Line Analytical Processing)-Datenbank stammen, und die verfügbaren Daten beim Neuerstellen der Datenbank geändert wurden, müssen Sie unter Umständen eine neue PivotTable-Liste erstellen. Wenden Sie sich an den Datenbankadministrator, um weitere Informationen zu erhalten.


Die PivotTable-Eigenschaftentoolbox oder die Feldliste wird nicht mehr angezeigt.

Wenn Sie auf der Webseite auf ein Steuerelement klicken, bei dem es sich nicht um ein Steuerelement der Microsoft Office-Webkomponente handelt, oder das Entwurfsfenster minimieren und dann wieder herstellen, werden die Toolbox und die Feldliste eventuell ausgeblendet.

Um die Toolbox oder die Feldliste erneut anzuzeigen, klicken Sie auf die PivotTable-Liste, damit sie erneut aktiviert wird.


Die Abfrage in einer PivotTable-Liste ist fehlgeschlagen.

Die Quelldatenbank ist möglicherweise nicht verfügbar Wenn die PivotTable-Liste auf einer Datenquelle aus einer Datenbank in einem Netzwerk basiert, steht der Datenbankserver oder das Netzwerk möglicherweise nicht zur Verfügung bzw. die Verbindung zum Netzwerk wurde unterbrochen. Wenden Sie sich an den Server- oder Netzwerkadministrator, um festzustellen, ob Server und Netzwerk verfügbar sind.

Sie verfügen möglicherweise nicht über die erforderlichen Berechtigungen Sie können eventuell zwar eine Verbindung zu der Datenbank herstellen, verfügen aber nicht über die erforderlichen Berechtigungen, um die Abfrage für die PivotTable-Liste auszuführen. Wenden Sie sich an den Datenbankadministrator, um mehr über Berechtigungen zu erfahren.

Überprüfen Sie die Filterung in der PivotTable-Liste Manchmal kann eine PivotTable-Liste gefiltert sein, damit bestimmte Elemente angezeigt werden, und auf Grund von Änderungen der Quelldatenbank wurde eines dieser Elemente entfernt, was zu einem Versagen der Abfrage führt. In diesem Fall können Sie die Filterung deaktivieren, um alle Elemente anzuzeigen, und dann auf der Symbolleiste in der PivotTable-Liste auf Aktualisieren [image] klicken, um die Abfrage auszuführen.


Warum werden neben den Ergebnissen in der PivotTable-Liste Sternchen angezeigt?

Neben den Ergebnissen werden in den folgenden Fällen Sternchen angezeigt:

  • Die Ergebnisse enthalten ausgeblendete Elemente Wenn die Option festgelegt wird, dass alle Elemente in Ergebnisse eingeschlossen werden, werden neben den Ergebnissen Sternchen angezeigt, um anzuzeigen, dass die Ergebnisse zusätzlich zu den angezeigten Elementen ausgeblendete Elemente enthalten.

  • Die PivotTable-Liste wurde von Microsoft Excel aus veröffentlicht In Excel PivotTable-Berichten, die auf Datenquellen aus OLAP(On-Line Analytical Processing)-Datenbanken basieren, umfassen die Berechnungen für Teilergebnis- und Gesamtergebniswerte immer die Werte aller Elemente in dem Feld, sowohl angezeigte als auch ausgeblendete. Excel bietet eine Option, um die Anzeige dieser Sternchen zu deaktivieren. Wenn Sie den Excel-Bericht jedoch als PivotTable-Liste für das Web speichern oder veröffentlichen, werden die Sternchen in der PivotTable-Liste angezeigt, auch wenn sie in Excel deaktiviert wurden.

Sie können die Berechnung der Ergebnisse ändern In der PivotTable-Liste können Sie, unabhängig davon, ob sie auf einer Datenquelle aus einer OLAP-Datenbank basiert, eine Option einstellen, um lediglich angezeigte Daten einzuschließen, wenn Sie die durch Filterung ausgeblendeten Daten in Teilergebnissen und Gesamtergebnissen auslassen möchten. Diese Option blendet ebenfalls die Sternchen aus.


Beim Ändern des Layouts einer PivotTable-Liste dauert es sehr lange, bis die Daten angezeigt werden.

Wenn die Berechnung der PivotTable-Liste sehr lange dauert, können Sie gleichzeitig mehrere Änderungen am Layout durchführen und nach Abschluss der Änderungen die Daten laden.

  1. Wird die Meldung "PivotTable berechnen" angezeigt, drücken Sie ESC, um die Berechnung abzubrechen. In der PivotTable-Liste werden dann lediglich die Namen der Felder angezeigt.

  2. Ändern Sie das Layout, wobei Sie so viele Felder wie gewünscht hinzufügen und verschieben.

  3. Um die Daten für das neue Layout zu laden und zu berechnen, klicken Sie auf der Symbolleiste in der PivotTable-Liste auf Aktualisieren [image].


Drucken einer PivotTable-Liste

Zum Drucken einer PivotTable-Liste verwenden Sie den Druckbefehl in Ihrem Entwurfsprogramm. Die erzielten Ergebnisse hängen von den Druckmöglichkeiten des Entwurfsprogramms ab. Weitere Informationen finden Sie in der Hilfe Ihres Entwurfsprogramms.

Anmerkung In Microsoft FrontPage 2000 können Sie möglicherweise eine PivotTable-Liste nicht einwandfrei drucken.