Info über PivotTable-Listen

Dieses Hilfethema beinhaltet Folgendes:

Übersicht

Analysieren der Daten in einer PivotTable-Liste

Datenquellen

Weitere Informationen

Übersicht

Eine PivotTable-Liste ist eine interaktiv nutzbare Tabelle, mit der Sie Daten in Ihrem Webbrowser analysieren können. Sie können die Liste verwenden, um Daten aus großen Datenbanken anzuzeigen und zu organisieren, um nach Informationen oder Details zu suchen und um Zusammenfassungen und Berichte zu erstellen.

Woher stammen die Daten für die PivotTable-Liste? In einer PivotTable-Liste können Daten angezeigt werden, die sich in irgendeiner Quelle an einem anderen Standort in Ihrem Netzwerk befinden. Die Person, die die PivotTable-Liste erstellt, legt fest, welche Datenquellen verwendet werden und welcher Teil der Daten aus der Herkunftsdatenbank zur Verfügung stehen soll. Sie können weder neue Werte in berechnete Zellen der Liste eingeben noch die Datenquellen neu definieren, die in der Liste angezeigt werden, jedoch können Sie die Art und Weise ändern, wie die Daten angezeigt werden und organisiert sind. Darüber hinaus können Sie die PivotTable-Liste aktualisieren, so dass eventuelle Änderungen an den Datenquellen übernommen werden.

PivotTable-Listen und -Diagramme Der Ersteller einer PivotTable-Liste kann ein hiermit verknüpftes Diagramm einfügen, in dem die gleichen Daten grafisch dargestellt werden. Wenn sich auf der Webseite, die Sie anzeigen, ein solches Diagramm befindet, werden alle Änderungen und Aktualisierungen, die Sie an der PivotTable-Liste vornehmen, auch in dem Diagramm wiedergegeben. So arbeiten Sie mit einem Diagramm, das mit einer PivotTable-Liste verknüpft ist.

Terminologie In Verbindung mit PivotTable-Listen werden Begriffe wie beispielsweise "Feld" und "Detailbereich" verwendet, um Daten zu beschreiben. Wenn Sie auch mit Microsoft Excel-PivotTable-Berichten oder Microsoft Access-PivotTable-Formularen arbeiten, sind Sie mit der Terminologie der PivotTable-Listen bereits vertraut.

Zurück zum Anfang

Analysieren der Daten in einer PivotTable-Liste

Der Ersteller der PivotTable-Liste richtet diese so ein, dass eine von vielen möglichen Ansichten der Daten angezeigt wird. Sie können die Symbolleiste und die PivotTable-Eigenschaftentoolbox verwenden, um die Art und Weise zu ändern, wie die Daten angezeigt werden. Sie können nach bestimmten Daten suchen, umfassende oder weniger umfassende Details anzeigen oder die Zeilen und Spalten in andere Bereiche verschieben, um unterschiedliche Zusammenfassungen der Daten zu berechnen.

Wie Daten in einer PivotTable-Liste angezeigt werden In ihrer einfachsten Form zeigt eine PivotTable-Liste Daten in Zeilen und Spalten an, wobei sich ähnliche Fakten in der jeweils gleiche Spalte befinden. Jede dieser Spalten wird als Feld bezeichnet. Das folgende Beispiel enthält Felder mit Namen "Sport", "Vierteljahr" und "Verkäufe".

Beispiel für eine PivotTable-Liste mit allen Detailfeldern

Eine einfache PivotTable-Liste gleicht einer Tabelle mit Datensätzen aus einer Datenbank oder einer Sammlung von Zeilen in einer Liste, die mit einer Tabellenkalkulation erstellt wurde.

Um die Daten weiter zu analysieren, können Sie:

  • Felder filtern, um Daten zu suchen. Beispielsweise können Sie nur die Umsatzdaten im Bereich "Tennis" für das dritte Quartal anzeigen.

  • Sortieren, um die Zeilen neu zu ordnen. So können Sie beispielsweise nach dem Feld "Verkäufe" sortieren, um herauszufinden, bei welchen Sportarten und in welchem Quartal die höchsten Bruttoeinnahmen erzielt wurden.

  • Der Liste Teilergebnisse hinzufügen oder andere Berechnungen hinzufügen. Beispielsweise können Sie die höchsten Umsatzzahlen für jede Sportart anzeigen.

Eine PivotTable-Liste verfügt über verschiedene Bereiche, in die Sie Felder verschieben können, um diese zusammenzufassen oder um alle Details von deren Inhalt anzuzeigen. Sie können Ihre PivotTable-Liste wie im vorstehenden Beispiel dargestellt anzeigen, indem Sie alle Felder in den Detailbereich verschieben, sofern die Datenquellen so eingerichtet wurden, dass dies zulässig ist.

Zusammenfassen der Daten Indem Sie ein Summenfeld erstellen und Felder in andere Bereiche verschieben, können Sie die Daten schnell zusammenfassen. Beginnen Sie beispielsweise mit der PivotTable-Liste im vorstehenden Beispiel. Indem Sie wie im folgenden Beispiel ein Summenfeld "Summe der Verkäufe" erstellen, das Feld "Sport" in den Zeilenbereich und das Feld "Vierteljahr" in den Spaltenbereich verschieben, können Sie auf einfache Weise ermitteln, wie sich die Umsätze im Bereich "Golf" im dritten Quartal gegenüber den Umsätzen in den anderen Sportarten oder Quartalen entwickelt haben, und Sie können das Gesamtergebnis der Umsätze anzeigen.

Beispiel für eine PivotTable-Liste mit zusammenfassten Daten

In der Zelle, in der die Umsätze im Bereich "Golf" für das dritte Quartal angezeigt werden, werden die Umsatzzahlen aus jedem Datensatz summiert, bei dem "Golf" im Feld "Sport" und "3. Qtr" im Feld "Vierteljahr" angegeben wurde.

Speichern Ihrer Änderungen Wenn Sie mit Microsoft Internet Explorer 4.01 oder höher arbeiten, sind Änderungen, die Sie im Verlauf einer Browsersitzung an der PivotTable-Liste vorgenommen haben, auch dann noch vorhanden, wenn Sie nach der Anzeige anderer Webseiten zu der PivotTable-Liste zurückkehren. Wenn Sie die Webseite jedoch erneut öffnen - beispielsweise, indem Sie in die Adressleiste von Internet Explorer klicken und dann die EINGABETASTE drücken - sind Ihre Änderungen verschwunden.

Von Ihnen vorgenommene Änderungen haben keine Auswirkungen auf die ursprüngliche PivotTable-Liste, ungeachet des verwendeten Webbrowsers. Daher können andere Benutzer, die die gleiche PivotTable-Liste zur gleichen Zeit anzeigen, Ihre Änderungen nicht sehen.

Arbeiten mit anderen Programmen Sie können Daten aus der PivotTable-Liste in andere Programme kopieren, also beispielsweise nach Microsoft Word. Wenn Sie die Daten weiterführend analysieren möchten oder eine benutzerdefiniert angepasste Version der Daten drucken möchten, können Sie die Liste in einen Microsoft Excel-PivotTable-Bericht exportieren. Wenn Sie eine eigene PivotTable-Liste erstellen oder designbezogene Änderungen an einer vorhandenen PivotTable-Liste vornehmen möchten, können Sie sowohl den Datendesigner für Datenzugriffsseiten von Microsoft Access 2000 als auch FrontPage 2000 verwenden, um die Webseite zu öffnen und die erweiterten Funktionen von PivotTable-Listen zu nutzen. Informationen dazu finden Sie in der Hilfe zu Access oder FrontPage.

Zurück zum Anfang

Datenquellen

Datenbanken In PivotTable-Listen können Daten aus im Netzwerk befindlichen Datenbanken angezeigt werden. Hierzu gehören OLAP-Datenbanken ebenso wie relationale Datenbanken wie beispielsweise Microsoft Access oder Microsoft SQL Server. Weitere Informationen über OLAP-Datenbanken finden Sie unter OLAP-Datenquellen. In PivotTable-Listen können jedoch auch Daten aus anderen Arten von Datenbanken in Ihrem Netzwerk sowie Daten aus tabellarischen Datenbanken wie beispielsweise Excel-Listen angezeigt werden. Mit der Art der Herkunftsdatenbank und mit der Art der Daten, die die von Ihnen angezeigte PivotTable-Liste umfasst, wird festgelegt, welche Arten von Ansichten und Zusammenfassungen Sie in einem Webbrowser erstellen können.

Wenn die Herkunftsdatenbank selbst geändert oder mit neuen Daten aktualisiert wird, können Sie die PivotTable-Liste aktualisieren, um die neuesten Daten abzurufen.

Der Ersteller der PivotTable-Liste legt die Datenquellen fest, d. h., der Ersteller entscheidet, welche Herkunftsdatenbank verwendet wird und welcher Teil dieser Daten zur Verfügung stehen soll. Dieser Teil bestimmt, welche Daten Sie als Betrachter zusammenfassen können. Wenn Sie beispielsweise die Ebenen "Produktumsatz" und "Lagerbestand" zusammenfassen möchten, müssen mit den Datenquellen die Verkaufszahlen und die Lagerbestandsdaten für Ihre Produkte bereitstehen.

Anzeigen der Felder, die seitens der Datenquellen verfügbar sind Eine von Ihnen angezeigte PivotTable-Liste umfasst möglicherweise nicht alle Felder, die anhand der Datenquellen verfügbar sind. Wenn weitere Daten verfügbar sind, können Sie der PivotTable-Liste Felder hinzufügen. Beim Hinzufügen von Feldern verwenden Sie die Liste im Dialogfeld Feldliste, auf das Sie mit der Schaltfläche Feldliste [image] in der Symbolleiste der PivotTable-Liste zugreifen.

Beispiel für eine Feldliste

Beispiel für eine Feldliste

In dieser Liste können Sie blättern, und Sie können auf die Felder Plusfeld und Minusfeld klicken, um Felder anzuzeigen oder auszublenden. Felder, die bereits in der PivotTable-Liste angezeigt werden, werden fett formatiert dargestellt.

OLAP-Datenquellen On-Line Analytical Processing (Analytische Onlineverarbeitung, OLAP) ist eine Verarbeitungsmethode auf dem Datenbankserver, mit der große Datenmengen auf eine Weise organisiert werden, die sie für Personen zugänglich und übersichtlich macht, die Geschäftstrends und -ergebnisse analysieren möchten. In diesen Datenbanken werden Daten nach Kategorien in Dimensionen und Detailebenen angeordnet.

Beispielsweise könnte eine geographische Dimension über die Ebenen "Land", "Region" und "Stadt" verfügen, und eine zeitliche Dimension könnte die Ebenen "Jahr", "Quartal", "Monat" und "Tag" aufweisen. Diese Dimensionen werden in einer PivotTable-Liste in Zeilen-, Spalten- und Filterfeldern umgesetzt. Mit jedem Dimensionsfeld in einer PivotTable-Liste können Daten von niedrigeren und höheren Detailebenen angezeigt werden.

Wenn Sie mit PivotTable-Listen arbeiten, die auf OLAP-Datenbanken basieren, also beispielsweise auf einer Datenbank, die mit Microsoft SQL Server OLAP Services erstellt wurde, werden Sie feststellen, dass Sie keine Felder in den Detailbereich verschieben können und dass bestimmte Felder nur im Datenbereich verwendet werden können. Sie werden darüber hinaus feststellen, dass Felder für Dimensionen in Gruppen angezeigt werden, d. h. wenn Sie ein Feld in einer Gruppe verschieben, werden die anderen Felder ebenfalls verschoben. In der Feldliste erkennen Sie Dimensionsfelder an den daneben befindlichen Symbolen Dimensionsfeld , und Datenfelder sind mit den Symbolen Datenfeld gekennzeichnet.

Zurück zum Anfang

Weitere Informationen

Anzeigen von Details für zusammengefasste Daten

Formatieren einer PivotTable-Liste

Drucken einer PivotTable-Liste

Zurück zum Anfang


Elemente einer PivotTable-Liste

Beispiel für eine PivotTable-Liste, in der Elementnamen angezeigt werden

Felder Felder entsprechen einer Spalte mit Daten; hiermit können mehrere Zeilen mit Informationen zusammengefasst werden. Zu den Feldtypen gehören Zeilenfelder, Spaltenfelder, Datenfelder und Filterfelder.

Element Ein eindeutiges Datenelement in einem Feld. Elemente in Zeilen- und Spaltenfeldern werden spalten- und zeilenweise angezeigt. In der Zelle, in der sich eine Zeile und eine Spalte überschneiden, werden die zusammengefassten Daten für die Elemente angezeigt, die oben im Spaltenkopf und links im Zeilentitel angegeben werden.

Wenn für ein Element zusätzliche Detaildaten angezeigt werden können, erscheint das Eweiterungssymbol Plusfeld neben dem Element.

Zeilenfeld Ein Feld im Zeilenbereich. Im vorstehenden Beispiel sind die Felder "Produkt" und "Verkauft von" Zeilenfelder. Elemente in Zeilenfeldern werden spaltenweise auf der linken Seite einer PivotTable-Liste angezeigt. Innere Zeilenfelder wie beispielsweise "Verkauft von" befinden sich am nähesten am Datenbereich; äußere Zeilenfelder wie beispielsweise "Produkt" befinden sich links der inneren Zeilenfelder.

Spaltenfeld Ein Feld im Spaltenbereich. Elemente in Spaltenfeldern werden oben in einer PivotTable-Liste zeilenweise überhalb der Datenfelder angezeigt. Im vorstehenden Beispiel ist "Quartale" ein Spaltenfeld mit zwei Elementen, "2. Qtrl" und "3. Qtrl". Innere Spaltenfelder befinden sich am nähesten am Datenbereich; äußere Spaltenfelder befinden sich überhalb der inneren Spaltenfelder.

Filterfeld Ein Feld im Filterbereich, das Sie zum Filtern der gesamten PivotTable-Liste verwenden können, um zusammengefasste Daten anzuzeigen. Im vorstehenden Beispiel ist "Region" ein Filterfeld, das Sie verwenden können, um jeweils Daten für alle Regionen oder nur für eine Region anzuzeigen. Filterfelder haben die gleichen Funktionen wie Seitenfelder in Microsoft Excel PivotTable-Berichten und Microsoft Access PivotTable-Formularen.

Datenbereich Der Teil einer PivotTable-Liste, der die Datenfelder enthält.

Datenfeld Ein Feld, das die zusammengefassten Werte aus den Quelldaten enthält. Im vorstehenden Beispiel ist "Verkäufe" ein Datenfeld, das zusammengefasste Verkaufsmengen enthält - jeder Wert im Datenfeld ist die Summe der Einträge aus dem Feld oder der Spalte "Verkäufe" in den Quelldaten.

In einem Datenfeld werden normalerweise numerische Daten mit Hilfe der Zusammenfassungsfunktion "Summe" zusammengefasst, wie beispielsweise statistische Werte oder Verkaufsmengen. Im vorliegenden Beispiel zeigt die Zelle mit dem Wert 30.984 den Gesamtumsatz von Davolio für Milchprodukte im zweiten Quartal. In dieser Zelle werden die Verkaufsmengen aus allen Datensätzen in den Quelldaten zusammengefasst, in denen "Molkereiprodukte" als Produkt, "Davolio" als Verkäufer und "Qtr2" als Quartal angegeben wurde.

Bei den zugrunde liegenden Daten kann es sich auch um Text handeln, welcher standardmäßig mit der Zusammenfassungsfunktion "Anzahl" zusammengefasst wird, womit die Anzahl der Einträge zurückgegeben wird. Beispielsweise kann ein Datenfeld, das den Typ des verkauften Produkts enthält, verwendet werden, um die Anzahl der Verkäufe im Bereich Milchprodukte wiederzugeben, die Davolio im zweiten Quartal getätigt hat. In einer PivotTable-Liste können Daten auch mit Hilfe der Zusammenfassungsfunktionen "Min" und "Max" zusammengefasst werden, womit die jeweils höchsten und niedrigsten Werte zurückgegeben werden.

Detailbereich Der Teil einer PivotTable-Liste (im Beispiel nicht dargestellt), in dem alle Zeilen, oder Datensätze, der Quelldaten angezeigt werden können. In einer PivotTable-Liste können Detailzeilen und zusammengefasste Daten gleichzeitig angezeigt werden. Felder im Detailbereich werden als Detailfelder bezeichnet.

Dropdownpfeil eines Feldes Der Pfeil Feldpfeil auf der rechten Seite jedes Feldes. Klicken Sie auf diesen Pfeil, um eine Dropdownliste zu öffnen, aus der Sie die Elemente auswählen können, die angezeigt oder ausgeblendet werden sollen.

In PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, können Sie Elemente auf verschiedenen Ebenen in einem Dimensionsfeld auswählen. Mit Datums- und Zeitfeldern stehen bei allen Arten von Quelldaten unterschiedliche Ebenen bereit. Wenn Sie beispielsweise auf den Dropdownpfeil eines Feldes "Jahr" klicken, könnte Folgendes angezeigt werden:

Dropdownliste eines OLAP-Dimensionsfeldes

Beispiel für die Dropdownliste eines OLAP-Dimensionsfeldes

Das graue Häkchen für das Jahr 1999 zeigt an, dass dieses Jahr aktuell zur Anzeige gewählt wurde, jedoch sind einige der unterhalb befindlichen Elemente nicht zur Anzeige gewählt. Das Jahr 1998 ist ausgeblendet. Innerhalb des Jahres 1999 ist "2. Qtr" ausgeblendet. Wenn Sie nun auf Alle anzeigen klicken, werden alle Elemente im Feld auf allen Ebenen zur Anzeige gewählt.


Drucken einer PivotTable-Liste

  • Klicken Sie im Menü Datei von Internet Explorer auf Drucken.

Anmerkungen

  • Wenn die PivotTable-Liste breiter als die gedruckte Seite ist, wird der Teil auf der rechten Seite, der nicht auf die Druckseite passt, nicht gedruckt.

  • Der Webbrowser druckt nur die Teile der PivotTable-Liste, die nicht verborgen sind und in denen Sie während der Browsersitzung einen Bildlauf durchgeführt haben. Wenn Sie beispielsweise nur Daten der höheren Ebene anzeigen oder die Detailanzeige ausblenden, werden die ausgeblendeten Details nicht gedruckt. Wenn Sie jedoch in den Daten der PivotTable-Liste einen Bildlauf von Anfang bis Ende durchgeführt haben, wird die gesamte Liste gedruckt.

  • Wenn Sie weitere Steuerungsmöglichkeit über die Art und Weise benötigen, wie die Daten gedruckt werden, einschließlich der Möglichkeit zum Drucken des gesamten Inhalts einer langen Liste und zum Festlegen von Seitenumbrüchen, können Sie die PivotTable-Liste nach Microsoft Excel exportieren. Informationen über das Drucken von Excel aus finden Sie in der Excel-Hilfe.


Speichern von Änderungen an einer PivotTable-Liste

Wenn Sie mit Microsoft Internet Explorer, Version 4.01 oder höher, arbeiten, werden Änderungen, die Sie an der PivotTable-Liste vorgenommen haben, während der gesamten Browsersitzung beibehalten, auch wenn Sie zwischenzeitlich andere Webseiten anzeigen und dann wieder zu der PivotTable-Liste zurückkehren. Wenn Sie allerdings die Webseite erneut öffnen - beispielsweise, indem Sie auf die Adressleiste von Internet Explorer klicken und dann die EINGABETASTE drücken - sind Ihre Änderungen verschwunden. Sie können die Änderungen nicht in einer Datei speichern.

Wenn Sie Änderungen an einer PivotTable-Liste in einer Datei speichern möchten, müssen Sie die PivotTable-Liste in einem Gestaltungsprogramm wie beispielsweise Microsoft FrontPage 2000 oder dem Datenseitendesigner für Datenzugriffseiten von Microsoft Access öffnen. Weitere Informationen über Gestaltungsprogramme für PivotTable-Listen. Sie können die PivotTable-Liste auch in einen Excel-PivotTable-Bericht exportieren und den Excel-Bericht dann speichern. Weitere Informationen hierzu finden Sie in der Excel-Hilfe.


Rückgängigmachen aller Änderungen

  • Wenn Sie eine PivotTable-Liste wieder in den Zustand zurückversetzen möchten, in dem sie sich befunden hat, als Sie sie zu Beginn in Microsoft Internet Explorer anzeigten, schließen Sie Internet Explorer, und starten Sie die Anwendung dann erneut.

Anmerkung Einzelne Änderungen an einer PivotTable-Liste können Sie nicht rückgängig machen. Weitere Informationen über das Arbeiten mit PivotTable-Listen in unterschiedlichen Browsern anzeigen.


Info über das Arbeiten mit PivotTable-Listen in unterschiedlichen Browsern

Wenn Sie PivotTable-Listen anzeigen und hiermit arbeiten möchten, müssen die Microsoft Office Web Components auf Ihrem Computer installiert sein. Hierfür müssen Sie entweder Microsoft Office 2000 installieren oder, falls Ihr Unternehmen über eine Sitelizenz für Office 2000 verfügt, die Office Web Components aus dem Unternehmensintranet downloaden. Allerdings wird die vollständige Funktionspalette für PivotTable-Listen im Web, wie beispielsweise Funktionen, die den interaktiven Umgang mit Daten in einer PivotTable-Liste im Webbrowser ermöglichen, nicht von allen Webbrowsern unterstützt.

Microsoft Internet Explorer, Version 5 und höher Mit diesem Browser haben Sie Zugriff auf alle Funktionen einer PivotTable-Liste, die in einem Browser verwendet werden können. Vorgenommene Änderungen, wie beispielsweise Format- und Layoutänderungen, werden beibehalten, wenn Sie eine PivotTable-Liste verlassen und während der gleichen Browsersitzung zu einem späteren Zeitpunkt erneut hierauf zugreifen.

Microsoft Internet Explorer, Version 4.01, 4.1x und 4.2x Sie haben Zugriff auf alle in einem Browser verfügbaren Funktionen einer PivotTable-Liste, und Ihre Änderungen werden beibehalten, wenn Sie die PivotTable-Liste verlassen. Wenn Sie jedoch auf Webseiten befindliche PivotTable-Listen anzeigen möchten, die mit dem Datenseitendesigner für Datenzugriffsseiten von Microsoft Access erstellt oder geändert wurden, muss Internet Explorer 5 installiert sein.

Microsoft Internet Explorer 4.0 Sie haben Zugriff auf alle Funktionen, die über die Symbolleiste oder die Kontextmenüs für die PivotTable-Liste zur Verfügung stehen, können jedoch nicht auf die PivotTable-Eigenschaftentoolbox zugreifen. Ihre Änderungen werden nicht beibehalten, wenn Sie eine PivotTable-Liste verlassen. Wenn Sie allerdings auf Webseiten befindliche PivotTable-Listen anzeigen möchten, die mit dem Datenseitendesigner für Datenzugriffsseiten von Microsoft Access erstellt oder geändert wurden, muss Internet Explorer 5 installiert sein.

Andere Browser In früheren Versionen von Microsoft Internet Explorer und in anderen Browsern können Sie PivotTable-Listen nicht anzeigen. Eine PivotTable-Liste erscheint hierin entweder als umrahmtes Feld auf der Webseite, oder sie wird gar nicht angezeigt.


Info über das Anzeigen eines Diagramms, dem eine PivotTable-Liste zugrunde liegt

Bei der Entwicklung der von Ihnen geöffneten Webseite wurde möglicherweise ein Diagramm zur graphischen Darstellung der Daten aus einer PivotTable-Liste erstellt. Dieser Abschnitt enthält Informationen über die Funktionsweise eines solchen Diagramms. Außerdem wird erläutert, was geschieht, wenn Änderungen an der PivotTable-Liste vorgenommen werden.

Automatische Aktualisierung Wenn Sie eine PivotTable-Liste ändern, die einem Diagramm zugrunde liegt, wird das Diagramm automatisch aktualisiert und spiegelt so die Änderungen an der PivotTable-Liste wieder. Wenn Sie z. B. ein Feld in den Zeilen- oder Spaltenbereich verschieben wird das Diagramm automatisch dahingehend aktualisiert, dass der Inhalt des Feldes entweder als Kategoriedaten oder als Datenreihen dargestellt wird. Werden Daten ausgeblendet (z. B. beim Filtern der Daten oder Entfernen eines Feldes aus der PivotTable-Liste) und dadurch nicht mehr in der Listenansicht angezeigt, werden sie auch aus dem Diagramm entfernt.

Erforderliche Felder Damit die Daten in dem Diagramm dargestellt werden, muss einer PivotTable-Liste mindestens ein Gesamtsummenfeld hinzugefügt werden. Wenn in der PivotTable-Liste mehrere Gesamtsummenfelder enthalten sind, wird in dem Diagramm bei dem am weitesten links angeordneten Feld mit der Anzeige der Daten begonnen. Die Zeilen- und Spaltenfelder einer PivotTable-Liste werden in dem Diagramm als Kategoriedaten und Datenreihen dargestellt. Befinden sich beispielsweise alle angezeigten Felder im Detailbereich der PivotTable-Liste, können in dem Diagramm weder Kategoriedaten noch Datenreihen gezeichnet werden. Verschieben Sie mindestens ein Feld aus dem Detailbereich oder der Feldliste in den Zeilen- oder Spaltenbereich.

Beispiel Nachfolgend ist ein Diagramm dargestellt, dem eine PivotTable-Liste zugrunde liegt. Das Feld Summe der Verkäufe enthält Gesamtsummen für jeden Produkttyp und jeden Verkäufer. Der blaue Pfeil in der Beschriftung des Feldes Verkäufer gibt an, dass für das Feld ein Filter gesetzt wurde, damit nur die Gesamtsummen für vier Verkäufer angezeigt werden.

Auf einer PivotTable-Liste basierendes Diagramm

Ein auf einer PivotTable-Liste basierendes Diagramm. Der Inhalt des Spaltenfeldes Typ der PivotTable-Liste wird in den Diagramm als Kategoriedaten (Getränke, Fleisch usw.) dargestellt. Der Inhalt des Zeilenfeldes Verkäufer wird in dem Diagramm in Form von Datenreihen wiedergegeben. Die Namen der Reihen sind in der Legende aufgeführt (Buchanan, Davolio usw.).

Wenn Sie der PivotTable-Liste Felder hinzufügen oder Felder in der Liste verschieben, wird das Diagramm automatisch aktualisiert, so dass die Änderungen wiedergegeben werden:

Aktualisiertes Diagramm auf der Grundlage der Änderungen in der PivotTable-Liste

In einem aktualisierten Diagramm werden die Änderungen in der PivotTable-Liste angezeigt.

Im vorigen Beispiel wurde das Feld Verkäufer in den Spaltenbereich und das Feld Typ in den Zeilenbereich der PivotTable-Liste verschoben. Das Feld Region wurde dem Spaltenbereich hinzugefügt. Anschließend wurde ein Filter gesetzt, so dass nur noch Ost und Nord angezeigt werden. Das Diagramm wurde automatisch aktualisiert. Daher werden nun das Feld Typ in der Legende als Reihe und die Felder Verkäufer und Region als Kategorien angezeigt.


So erhalten Sie Hilfe bei der Gestaltung Ihrer eigenen PivotTable-Liste

Wenn Sie eine PivotTable-Liste in Ihrem Webbrowser anzeigen und damit arbeiten, arbeiten Sie mit einem Steuerelement, das in einem anderen Programm, einem so genannten Designprogramm, erstellt wurde. In einem Designprogramm können Sie die Quelldaten auswählen, die in einer PivotTable-Liste angezeigt werden sollen, Sie können die PivotTable-Liste einer Webseite hinzufügen, die Sie gerade gestalten, und Sie können die Webseite auf einem Webserver veröffentlichen. Hilfe beim Gestalten einer PivotTable-Liste wird seitens des jeweiligen Designprogramms zur Verfügung gestellt.

In diesem Hilfethema erhalten Sie Informationen darüber, wie Sie mit dem Design einer PivotTable-Liste beginnen und dann weitere Unterstützung erhalten können:

Gestalten einer eigenen PivotTable-Liste

Erhalten von Hilfe beim Gestalten von PivotTable-Listen

Erhalten von Hilfe beim Schreiben von Skripts und Programmen für PivotTable-Listen

Gestalten einer eigenen PivotTable-Liste

Wenn Sie mehr über das Gestalten einer PivotTable-Liste erfahren möchten, wählen Sie zunächst das Designprogramm aus, in dem Sie arbeiten möchten. Sie können in jedem beliebigen der unterstützten Designprogramme beginnen und die gleiche PivotTable-Liste später in einem anderen Designprogramm weiter bearbeiten, wenn Sie andere Designfunktionen benötigen.

Verwenden von Microsoft FrontPage 2000 als Designprogramm Zum Erstellen einer neuen PivotTable-Liste für Benutzer, die mit Microsoft Internet Explorer, Version 4 oder höher, arbeiten, oder zum Ändern des Designs einer PivotTable-Liste, die mit Microsoft Excel veröffentlicht wurde, empfiehlt sich Microsoft FrontPage 2000. Damit Benutzer interaktiv mit PivotTable-Listen arbeiten können, die Sie in FrontPage erstellt haben, müssen sie über Internet Explorer 4 oder höher und die Microsoft Office Web Components verfügen. FrontPage 2000 gehört zum Lieferumfang von Microsoft Office 2000 Premium. Die Office Web Components sind Bestandteil von Office 2000 Standard, Professional und Premium.

Verwenden von Microsoft Access als Designprogramm Verwenden Sie den Datenseitendesigner für Datenzugriffsseiten von Microsoft Access 2000 zum Erstellen einer neuen PivotTable-Liste für Benutzer, die mit Microsoft Internet Explorer, Version 5 oder höher, arbeiten, oder die Internet Explorer 4 oder höher verwenden, jedoch auch Internet Explorer 5 installieren können. Microsoft Access stellt spezielle Funktionen für das Erstellen von Webseiten für den Zugriff auf und die Arbeit mit Daten aus Datenbanken bereit. Um interaktiv mit PivotTable-Listen arbeiten zu können, die Sie in Access erstellen, müssen Benutzer Internet Explorer 5 oder höher sowie die Microsoft Office Web Components installieren. Microsoft Access 2000 gehört zum Lieferumfang von Microsoft Office 2000 Professional und Premium . Die Office Web Components sind Bestandteil von Office 2000 Standard, Professional und Premium.

Verwenden von Microsoft Excel als Designprogramm Sie verwenden Microsoft Excel 2000, wenn Sie bereits mit Excel PivotTable-Berichten vertraut sind oder einen PivotTable-Bericht vorliegen haben, den Sie auf einer Webseite veröffentlichen möchten. Um interaktiv mit PivotTable-Listen arbeiten zu können, die Sie von Excel aus veröffentlichen, müssen die Benutzer über Internet Explorer 4 oder höher und die Microsoft Office Web Components verfügen.

Verwenden von Microsoft Visual Basic oder einer Skriptsprache Wenn Sie Programmierer sind, können Sie Programme oder Skripts schreiben, mit denen eine PivotTable-Liste erstellt wird. Sowohl FrontPage 2000 als auch der Datendesigner für Datenzugriffsseiten in Access ermöglichen Ihnen, Skripts zu schreiben. Wenn Sie eine PivotTable-Liste für die Verwendung in einer benutzerdefinierten Lösung an Stelle eines Webbrowsers gestalten möchten, können Sie eine Programmierumgebung wie beispielsweise Microsoft Visual Basic verwenden.

Zurück zum Anfang

Erhalten von Hilfe beim Gestalten von PivotTable-Listen

Arbeiten mit einer PivotTable-Liste in einem Designprogramm Wenn Sie eine PivotTable-Liste in einem Designprogramm wie beispielsweise FrontPage 2000 oder dem Datenseitendesigner für Datenzugriffsseiten von Access 2000 erstellen oder aktivieren, liefert die PivotTable-Eigenschaftentoolbox zusätzliche Eigenschaften und Befehle, die Sie verwenden können, um festzulegen, wie die PivotTable-Liste in einem Webbrowser verwendet werden kann. Das Designprogramm stellt möglicherweise auch eigene Befehle und Funktionen für das Vorbereiten von Quelldaten und das Verbinden derselben mit einer PivotTable-Liste bereit.

Erhalten von Hilfe im Designprogramm Während Sie in einem Designprogramm arbeiten, stehen Ihnen zwei verschiedene Möglichkeiten zur Verfügung, um Hilfe beim Gestalten einer PivotTable-Liste erhalten:

  • Hilfe des Designprogramms Informationen über die Befehle und Funktionen, die im Designprogramm für die Arbeit mit PivotTable-Listen zur Verfügung stehen, finden Sie in der Hilfe des jeweiligen Designprogramms. Klicken Sie in Microsoft Access beispielsweise auf den Office-Assistenten, oder klicken Sie auf Microsoft Access Hilfe [image].

    Microsoft Excel bietet sowohl allgemeine Hilfe über das Speichern und Veröffentlichen von Excel-Daten für die Verwendung auf Webseiten als auch spezielle Informationen über das Vorbereiten von Daten für die Verwendung in einem PivotTable-Bericht und das anschließende Veröffentlichen eines PivotTable-Berichts als PivotTable-Liste auf einer Webseite. Für den Zugriff auf diese Hilfethemen in Excel klicken Sie auf den Office-Assistenten, oder Sie klicken auf Microsoft Excel Hilfe [image].

  • Design-Hilfe der PivotTable-Liste Bei einer PivotTable-Liste, die Sie in einem Designprogramm erstellt oder aktiviert haben, klicken Sie in der Symbolleiste der Liste auf Hilfe [image] . Mit dieser Methode werden die die Gestaltung betreffenden Hilfethemen über die Eigenschaften und Befehle angezeigt, die Sie im Zusammenhang mit der PivotTable-Liste im Designprogramm verwenden können. Diese Design-Hilfe ist nicht die gleiche wie die Hilfe im Browser (d. h. die Hilfethemen, die Sie aktuell anzeigen).

Zurück zum Anfang

Schreiben von Skripts und Programmen für PivotTable-Listen

Sie können mit Hilfe von Skripts und Programmen PivotTable-Listen automatisieren, oder Sie können PivotTable-Listen in Laufzeitprogrammen verwenden, die keine Webbrowser sind, also in Programmen, die Sie in einer Programmierumgebung wie beispielsweise Microsoft Visual Basic entwickelt haben.

Schreiben von Skripts Zu den Programmen des Microsoft Office 2000-Pakets gehört der Microsoft Skript-Editor, der Ihnen beim Schreiben von Skripts hilfreich zur Seite steht. Beispielsweise können Sie den Skript-Editor des Datenseitendesigners für Datenzugriffsseiten von Microsoft Access verwenden, um eine PivotTable-Liste Ihren Anforderungen entsprechend anzupassen. Informationen über das Ausführen des Skript-Editors finden Sie in der Hilfe des entsprechenden Office-Designprogramms. Im Skript-Editor können Sie weitere Hilfethemen über die Verwendung von dessen Funktionen und das Schreiben von Skripts anzeigen.

Objektmodellhilfe Wenn Sie beim Entwicklen eines Programms oder eines Skripts Hilfe benötigen, das in Verbindung mit einer PivotTable-Liste zur Anwendung kommen soll, können Sie auf die Visual Basic Referenz in den Microsoft Office Web Components zurückgreifen, um Informationen über das Objektmodell und über die Eigenschaften und Methoden anzuzeigen, die speziell für PivotTable-Listen gelten. Diese Objektmodellhilfe wird immer dann installiert, wenn Sie Office Web Components installieren, zu denen PivotTable-Listen als Komponente gehören. Abhängig vom verwendeten Gestaltungsprogramm können Sie mit einer von zwei Methoden auf diese Hilfe zugreifen:

  • Hilfe in Visual Basic In Visual Basic oder in Visual Basic für Anwendungen können Sie einen Verweis auf die Microsoft Office Web Componentsbibliothek erstellen. In diesem Fall haben Sie über den Objektbrowser Zugriff auf die Hilfe, oder indem Sie ein Schlüsselwort wählen und F1 drücken. Informationen über das Erstellen von Verweisen und das Verwenden der Objektmodellhilfe finden Sie in der Hilfe von Visual Basic oder Visual Basic für Anwendungen.

  • Hilfe in anderen Umgebungen Wenn Sie eine andere Entwicklungsumgebung verwenden, suchen Sie die Hilfedatei Msowcvba.chm, und doppelklicken Sie darauf.

Zurück zum Anfang


Tastenkombinationen in PivotTable-Listen

Welche Aufgaben möchten Sie mit Hilfe von Tastenkombinationen erledigen?

Aktivieren, Bewegen in und Deaktivieren einer PivotTable-Liste

Markieren von Elementen in einer PivotTable-Liste

Ausführen von Befehlen

Anzeigen, Ausblenden, Filtern und Sortieren von Daten

Hinzufügen von Feldern und Gesamtsummen sowie Ändern des Layouts einer PivotTable-Liste

Formatieren einer PivotTable-Liste


Aktivieren, Bewegen in und Deaktivieren einer PivotTable-Liste unter Verwendung von Tastenkombinationen

Tastenkombination | Aktion
TAB | Auswählen oder Aktivieren jedes Steuerelements auf einer Webseite in Folge. Nachdem Sie die PivotTable-Liste aktiviert haben, werden durch Drücken von TAB Elemente innerhalb der PivotTable-Liste markiert.
STRG+TAB | Deaktivieren (oder Verlassen) einer PivotTable-Liste und Markieren oder Aktivieren des nächsten Steuerelements auf der Webseite.


Auswählen von Elementen innerhalb einer PivotTable-Liste unter Verwendung von Tastenkombinationen

Tastenkombination | Aktion
TAB | Nachdem Sie eine PivotTable-Liste aktiviert haben, drücken Sie die TAB, um jedes einzelne Feld und dann die gesamte PivotTable-Liste zu markieren. Die einzelnen Markierungsmöglichkeiten werden jeweils nacheinander geboten.
UMSCHALT+TAB | Markieren des vorherigen Feldes oder der gesamten PivotTable-Liste.
Pfeiltasten Verschieben der Markierung in der von der Pfeiltaste vorgegebenen Richtung.

Wenn ein Zeilen- oder Spaltenfeld markiert ist, drücken Sie die NACH-UNTEN-TASTE, um zum ersten Datenelement im Feld zu wechseln und drücken dann eine Pfeiltaste, um zum nächsten oder vorherigen Element oder zurück zum Feld zu wechseln.

Wenn eine Detailfeld oder ein Datenelement markiert ist, drücken Sie die NACH-UNTEN-TASTE oder die NACH-RECHTS-TASTE, um zur ersten Zelle im Detailbereich oder Datenbereich zu wechseln.
UMSCHALT+Pfeiltaste | Erweitern oder Reduzieren der Markierung in der von der Pfeiltaste vorgegebenen Richtung. Sie können eine Markierung nach unten und nach rechts erweitern.
UMSCHALT+BILD-AB | Erweitern einer Markierung um eine Bildschirmseite nach unten. Eine Bildschirmseite ist gleichbedeutend mit allen Daten, die aktuell in der PivotTable-Liste angezeigt werden.
UMSCHALT+BILD-AUF | Reduzieren einer Markierung um eine Bildschirmseite.
STRG+LEERTASTE | Markieren des Feldes des aktuell markierten Datenelements, der Gesamtsumme oder der Detailzelle.
UMSCHALT+LEERTASTE | Markieren der gesamten Zeile, in der sich die aktuell markierte Zelle befindet.
STRG+A | Markieren der gesamten PivotTable-Liste.
BILD-AB | Anzeigen der nächsten Bildschirmseite. Eine Bildschirmseite ist gleichbedeutend mit allen Daten, die aktuell in der PivotTable-Liste angezeigt werden.
BILD-AUF | Anzeigen der vorherigen Bildseite.
ALT+BILD-AB | Anzeigen der nächsten Bildschirmseite rechts.
ALT+BILD-AUF | Anzeigen der vorherigen Bildschirmseite links.


Ausführen von Befehlen unter Verwendung von Tastenkombinationen

Tastenkombination | Aktion
F1 | Anzeigen von Hilfethemen. Informationen über die Tasten, die im Hilfefenster verwendet werden können, finden Sie in der Hilfe Ihres Webbrowsers.
UMSCHALT+F10 | Anzeigen des Kontextmenüs für das markierte Element der PivotTable-Liste. Verwenden Sie die Kontextmenüs, um in der PivotTable-Liste Befehle auszuführen.
Unterstrichener Buchstabe | Ausführen eines Befehls aus dem Kontextmenü. Siehe ALT+EINGABETASTE für Informationen über die PivotTable-Eigenschaftentoolbox.
ESC | Schließen des Kontextmenüs, ohne einen Befehl auszuführen.
STRG+7 | Anzeigen oder Ausblenden der Symbolleiste.
ALT+EINGABETASTE | Anzeigen der PivotTable-Eigenschaftentoolbox. Für das Ausführen von Befehlen oder das Festlegen von Eigenschaften in der Toolbox stehen keine Tastenkombinationen zur Verfügung.
ALT+F4 | Schließen der PivotTable-Eigenschaftentoolbox.
F9 | Aktualisieren der PivotTable-Liste anhand der Quelldaten.
ESC | Abbrechen der aktuell laufenden Aktualisierungsoperation.
STRG+C | Kopieren der markierten Daten aus der PivotTable-Liste in die Zwischenablage.
STRG+E | Exportieren der PivotTable-Liste nach Microsoft Excel.


Anzeigen, Ausblenden, Filtern und Sortieren von Daten unter Verwendung von Tastenkombinationen

Tastenkombination | Aktion
STRG+8 | Anzeigen oder Ausblenden der Erweiterungssymbole Plusfeld und Minusfeld neben Elementen.
STRG+PLUSZEICHEN | Anzeigen der Details für das aktuell markierte Element.
STRG+MINUSZEICHEN | Ausblenden der Details für das aktuell markierte Element.
ALT+NACH-UNTEN-TASTE | Öffnen der Dropdownliste für das aktuell markierte Feld.
TAB | Wechseln zum zuletzt markierten Element, zur Schaltfläche OK und zur Schaltfläche Abbrechen in der Dropdownliste eines Feldes (jeweils abwechselnd).
Pfeiltasten | Wechseln zum nächsten Element in der Dropdownliste eines Feldes.
LEERTASTE | Aktivieren oder Deaktivieren des Kontrollkästchens für das aktuelle Element in der Dropdownliste eines Feldes.
PLUSZEICHEN auf der Zehnertastatur | Anzeigen der niedrigeren Detailebenen, sofern verfügbar, für das aktuelle Element in der Dropdownliste eines Feldes.
MINUSZEICHEN auf der Zehnertastatur | Ausblenden der niedrigeren Detailebenen für das aktuelle Element in der Dropdownliste eines Feldes.
EINGABETASTE | Schließen der Dropdownliste eines Feldes und Zuweisen aller von Ihnen vorgenommenen Änderungen.
ESC | Schließen der Dropdownliste eines Feldes ohne Zuweisen von Änderungen.
STRG+T | Aktivieren oder Deaktivieren des AutoFilters.
STRG+UMSCHALT+A | Sortieren der Daten im markierten Feld oder Summenfeld in aufsteigender Reihenfolge (A - Z, 0 - 9).
STRG+UMSCHALT+Z | Sortieren der Daten im markierten Feld oder Summenfeld in absteigender Reihenfolge (Z - A, 9 - 0).


Formatieren einer PivotTable-Liste unter Verwendung von Tastenkombinationen

Mit den ersten sieben Tastenkombinationen in der folgenden Tabelle wird das Zahlenformat des markierten Elements geändert. Mehr über Zahlenformate erfahren.

Wenn Sie folgenden Tastenkombinationen verwenden möchten, müssen Sie zuerst ein Detailfeld oder eine Datenzelle eines Summenfeldes markieren.

Tastenkombination | Aktion
STRG+UMSCHALT+Ö | Zuweisen des Zahlenformats "Allgemeine Zahl" zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+$ | Zuweisen des Zahlenformats "Währung" mit zwei Dezimalstellen und negativen Zahlen in Klammern zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+% | Zuweisen des Zahlenformats "Prozent" ohne Dezimalstellen zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+& | Zuweisen des Zahlenformats "Exponentiell" mit zwei Dezimalstellen zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+§ | Zuweisen des Zahlenformats "Datum" im Format Tag/Monat/Jahr zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+" (Anführungszeichen) | Zuweisen des Zahlenformats "Zeit" im Format Stunde/Minute (mit dem Zusatz AM oder PM) zu Werten im markierten Summen- oder Detailfeld.
STRG+UMSCHALT+! | Zuweisen des Zahlenformats "Numerisch" mit zwei Dezimalstellen, 1.000er-Trennzeichen und einem Minuszeichen für negative Werte zu Werten im markierten Summen- oder Detailfeld.
STRG+2 | Fett formatieren des Textes im markierten Element der PivotTable-Liste.
STRG+4 | Unterstreichen des Textes im markierten Element der PivotTable-Liste.
STRG+3 | Kursiv formatieren des Textes im markierten Element der PivotTable-Liste.


Hinzufügen von Feldern und Gesamtsummen und Ändern des Layouts einer PivotTable-Liste unter Verwendung von Tastenkombinationen

Dieses Hilfethema beinhaltet Folgendes:

Tastenkombinationen für das Arbeiten mit der Feldliste

Tastenkombinationen für das Hinzufügen von Feldern und Gesamtsummen

Tastenkombinationen für das Ändern des Layouts

Tastenkombinationen für das Arbeiten mit der Feldliste

Tastenkombination | Aktion
STRG+L | Anzeigen der Feldliste oder Aktivieren derselben, sofern sie bereits angezeigt wird.
Pfeiltasten | Wechseln zum nächsten Element in der Feldliste.
PLUSZEICHEN auf der Zehnertastatur | Erweitern des aktuellen Elements in der Feldliste zum Anzeigen des Inhalts, oder Erweitern von Gesamtsummen zum Anzeigen der verfügbaren Summenfelder.
MINUSZEICHEN auf der Zehnertastatur | Reduzieren des aktuellen Elements in der Feldliste zum Ausblenden des Inhalts, oder Reduzieren von Gesamtsummen zum Ausblenden der verfügbaren Summenfelder.
TAB | Wechseln zum zuletzt markierten Element, zur Schaltfläche Hinzufügen zu und zur Liste neben der Schaltfläche Hinzufügen zu in der Feldliste (jeweils abwechselnd).
ALT+NACH-UNTEN-TASTE | Öffnen der Dropdownliste neben der Schaltfläche Hinzufügen zu in der Feldliste. Verwenden Sie die Pfeiltasten, um zum nächsten Element in der Liste zu wechseln, und drücken Sie dann die EINGABETASTE, um das Element zu markieren.
EINGABETASTE | Hinzufügen des in der Feldliste hervorgehobenen Feldes zu dem Bereich der PivotTable-Liste, der in der Liste Hinzufügen zu angezeigt wird.
ALT+F4 | Schließen der Feldliste.

Zurück zum Anfang

Tastenkombinationen für das Hinzufügen von Feldern und Gesamtsummen

Tastenkombination | Aktion
STRG+UMSCHALT+S | Hinzufügen eines neuen Summenfeldes für das in der PivotTable-Liste markierte Feld unter Verwendung der Zusammenfassungsfunktion "Summe".
STRG+UMSCHALT+C | Hinzufügen eines neuen Summenfeldes für das in der PivotTable-Liste markierte Feld unter Verwendung der Zusammenfassungsfunktion "Anzahl".
STRG+UMSCHALT+M | Hinzufügen eines neuen Summenfeldes für das in der PivotTable-Liste markierte Feld unter Verwendung der Zusammenfassungsfunktion "Minimum".
STRG+UMSCHALT+X | Hinzufügen eines neuen Summenfeldes für das in der PivotTable-Liste markierte Feld unter Verwendung der Zusammenfassungsfunktion "Maximum".
STRG+UMSCHALT+B | Aktivieren oder Deaktivieren von Teilergebnissen und Gesamtergebnissen für das in der PivotTable-Liste markierte Feld.

Zurück zum Anfang

Tastenkombinationen für das Ändern des Layouts

Tastenkombination | Aktion
STRG+1 | Verschieben des in der PivotTable-Liste markierten Feldes in den Zeilenbereich.
STRG+2 | Verschieben des in der PivotTable-Liste markierten Feldes in den Spaltenbereich.
STRG+3 | Verschieben des in der PivotTable-Liste markierten Feldes in den Filterbereich.
STRG+4 | Verschieben des in der PivotTable-Liste markierten Feldes in den Detailbereich.
STRG+NACH-LINKS-TASTE | Verschieben des in der PivotTable-Liste markierten Zeilen- oder Spaltenfeldes auf eine höhere Ebene.
STRG+NACH-RECHTS-TASTE | Verschieben des in der PivotTable-Liste markierten Zeilen- oder Spaltenfeldes auf eine niedrigere Ebene.

Zurück zum Anfang


Info über die Symbolleiste und die PivotTable-Eigenschaftentoolbox

Symbolleiste In einer PivotTable-Liste wird die Symbolleiste am Kopf der Liste angezeigt; sie stellt eine Reihe von Befehlen bereit, die Sie verwenden können, um mit den Daten in der PivotTable-Liste zu arbeiten. Zeigen Sie mit dem Mauszeiger auf eine Schaltfläche, um den Namen der Schaltfläche anzuzeigen.

Wenn keine Symbolleiste angezeigt wird, hat der Ersteller der PivotTable-Liste diese möglicherweise ausgeblendet. So zeigen Sie die Symbolleiste an, wenn diese ausgeblendet ist.

PivotTable-Eigenschaftentoolbox Die Toolbox umfasst Befehle wie beispielsweise Symbolleiste einblenden sowie Eigenschaften, die Sie festlegen können, wie beispielsweise die Hintergrundfarbe oder die Spaltenbreite. Der Inhalt der Toolbox ändert sich jeweils, wenn Sie unterschiedliche Bereiche einer PivotTable-Liste markieren. Die Toolbox enthält einige Befehle, die nicht in der Symbolleiste oder in den Kontextmenüs vorhanden sind.

Die Befehle und Eigenschaften in der Toolbox sind in mehrere Kategorien unterteilt, von denen jede mit einer Leiste gekennzeichnet ist, in der der Name der Kategorie angegeben wird. Die verfügbaren Kategorien ändern sich abhängig vom aktuell gewählten Bereich der PivotTable-Liste. Wenn Sie die Toolbox zum ersten Mal anzeigen, werden die Befehle und Eigenschaften der Kategorie Standard angezeigt. Sie können den Inhalt der Kategorien anzeigen, erweitern oder ausblenden, indem Sie auf die Leisten klicken. So verwenden Sie die PivotTable-Eigenschaftentoolbox.

Wenn die Toolbox nicht angezeigt wird, klicken Sie in der Symbolleiste auf die Schaltfläche Eigenschaftentoolbox [image] . Wenn diese Schaltfläche nicht verfügbar ist, hat der Ersteller der PivotTable-Liste den Zugriff auf die Toolbox möglicherweise ausgeschaltet. Für Hilfestellung wenden Sie sich in diesem Fall an die Person, die die PivotTable-Liste erstellt hat.


Anzeigen der Symbolleiste einer PivotTable-Liste

  • Klicken Sie mit der rechten Maustaste auf die Titelleiste der PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Symbolleiste.

Anmerkungen

  • Wenn die PivotTable-Liste nicht über eine Symbolleiste verfügt, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Wenn die Kategorie Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Ein-/Ausblenden-Leiste, und klicken Sie dann auf Symbolleiste [image].

  • Wenn der Befehl Eigenschaftentoolbox nicht im Kontextmenü verfügbar ist, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff auf die Toolbox möglicherweise ausgeschaltet. Wenden Sie sich in diesem Fall zwecks Hilfestellung an den Ersteller der PivotTable-Liste.


Schaltflächen und Befehle der Symbolleiste

Würfel mit Office-Logo Office-Logowürfel Zeigt das Dialogfeld About Microsoft Office Web Components an, dem Sie entnehmen können, welche Version auf Ihrem System installiert ist. Der Würfel dreht sich, während Daten abgerufen werden.

Kopieren Kopiert markierte Daten von einer PivotTable-Liste in die Zwischenablage, so dass Sie die Markierung in andere Anwendungen einfügen können. Wenn Sie eine interaktiv nutzbare Kopie in Microsoft Excel benötigen, verwenden Sie stattdessen Nach Excel exportieren [image] .

Aufsteigend sortieren Sortiert die Daten im markierten Feld in der Reihenfolge A - Z, 0 - 9.

Absteigend sortieren Sortiert die Daten im markierten Feld in der Reihenfolge Z - A, 9 - 0.

AutoFilter Aktiviert oder deaktiviert die Filterung für alle Felder. Mit Hilfe von Filtern können Sie nur die Zeilen oder Spalten anzeigen, die den von Ihnen angegebenen Werten entsprechen.

AutoBerechnung Fügt der Feldliste ein Summenfeld hinzu, wobei die Daten unter Verwendung der Zusammenfassungsfunktionen "Summe", "Anzahl", "Min" oder "Max" zusammengefasst werden.

Teilergebnis Zeigt für das markierte Feld Teilergebnisse an oder blendet Teilergebnisse aus.

In Zeilenbereich verschieben Verschiebt das markierte Feld, so dass dieses zu einem Zeilenfeld wird. Mit Zeilenfeldern werden Daten zusammengefasst, indem die Datenelemente in einem Feld zeilenweise in einer Spalte der PivotTable-Liste angezeigt werden.

In Spaltenbereich verschieben Verschiebt das markierte Feld, so dass es zu einem Spaltenfeld wird. Mit Spaltenfeldern werden Daten zusammengefasst, indem die Datenelemente in einem Feld spaltenweise in einer Zeile der PivotTable-Liste angezeigt werden.

In Filterbereich verschieben Verschiebt das markierte Feld, so dass es zu einem Filterfeld wird. Mit Filterfeldern wird die gesamte PivotTable-Liste so gefiltert, dass nur die Daten für das markierte Element im Feld angezeigt werden.

In Detailbereich verschieben Verschiebt das markierte Feld in den Detailbereich, so dass alle Daten im Feld in nicht zusammengefasster Form angezeigt werden.

Heraufstufen Verschiebt das markierte innere Zeilen- oder Spaltenfeld auf die nächst äußere Ebene. Wenn eine PivotTable-Liste über mehr als ein Zeilen- oder Spaltenfeld verfügt, sind die äußeren Felder diejenigen, die sich, nach links oder oben gesehen, weiter von den Daten entfernt befinden.

Tieferstufen Verschiebt das markierte äußere Zeilen- oder Spaltenfeld auf die nächst innere Ebene. Wenn eine PivotTable-Liste über mehr als ein Zeilen- oder Spaltenfeld verfügt, sind die inneren Felder diejenigen, die sich, nach rechts oder unten gesehen, näher an den Daten befinden.

Erweitern oder Reduzieren Blendet für das markierte Feld, das Datenelement oder die Zelle im Datenbereich alle Details aus oder zeigt alle Details an.

Aktualisieren Aktualisiert die PivotTable-Liste anhand der Quelldatei oder -datenbank, wobei alle neuen Daten angezeigt und alle neuen Felder der Feldliste hinzugefügt werden.

Nach Exel exportieren Startet oder wechselt zu Excel und kopiert die PivotTable-Liste als Excel-PivotTable-Bericht in eine neue Arbeitsmappe. Ein Excel-PivotTable-Bericht ist das interaktive Excel-Äquivalent zu einer PivotTable-Liste.

Eigenschaftentoolbox Zeigt die the Eigenschaftentoolbox der PivotTable-Liste an, in der Sie Befehle ausführen und Eigenschaften festlegen können.

Feldliste Zeigt die Liste der seitens der Quelldaten für die PivotTable-Liste verfügbaren Felder an, so dass Sie der PivotTable-Liste weitere Daten hinzufügen können.

Hilfe Zeigt die Hilfethemen an, die bezüglich der Verwendung einer PivotTable-Liste verfügbar sind.


Ausblenden der Symbolleiste in einer PivotTable-Liste

  1. Klicken Sie auf die PivotTable-Liste.

  2. Klicken Sie auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Ein-/Ausblenden-Leiste.

  4. Klicken Sie auf Symbolleiste [image].

Anmerkung Wenn die Schaltfläche Eigenschaftentoolbox [image] nicht in der Symbolleiste verfügbar ist, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff auf die Toolbox möglicherweise abgeschaltet. Wenden Sie sich in diesem Fall zwecks Hilfestellung an den Ersteller der PivotTable-Liste.


Verwenden der PivotTable-Eigenschaftentoolbox

  1. Markieren Sie den Teil der PivotTable-Liste, für den Sie die Eigenschaften anzeigen oder festlegen oder für den Sie Befehle ausführen möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

    Wenn die Symbolleiste nicht angezeigt wird, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox.

  3. Wenn Sie den Inhalt einer Kategorie erweitern oder ausblenden möchten, klicken Sie auf die Leiste mit dem Namen der Kategorie.

Anmerkungen

  • Die Toolbox enthält Befehle wie beispielsweise Symbolleiste, sowie Eigenschaften, die Sie festlegen können, wie beispielsweise Hintergrundfarbe oder Spaltenbreite.

  • Wenn Sie Einträge in die Toolbox eingeben oder hierin bearbeiten, müssen Sie auf einen anderen Teil der Toolbox klicken oder die EINGABETASTE drücken, damit die Änderungen wirksam werden.

  • Wenn sowohl die Schaltfläche Eigenschaftentoolbox [image] als auch der Menübefehl im Kontextmenü nicht verfügbar sind, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff hierauf möglicherweise deaktiviert.

  • Eigenschaften, die Sie für Gesamtsummen festlegen, gelten für alle Gesamtsummen in der PivotTable-Liste.

  • Wenn Sie die Toolbox geöffnet lassen, während Sie andere Teile der PivotTable-Liste oder andere Microsoft Office Web Components markieren, ändern sich die verfügbaren Kategorien und deren Inhalt, um die aktuelle Auswahl widerzuspiegeln. Wenn Sie einen Teil der Webseite markieren, der nicht zu den Steuerelementen der Office Web Components gehört, wird die Toolbox ausgeblendet.


Info über das Suchen von Daten

Für PivotTable-Listen gibt es keinen Suchbefehl. Sie können jedoch die Funktionen Filtern und Sortieren verwenden, um bestimmte Datenwerte oder alle Daten zu finden, die einem Wert entsprechen.

Filtern zum Suchen von Daten Das Filtern stellt eine schnelle Möglichkeit dar, um mit einer Teilmenge der Daten in einer PivotTable-Liste zu arbeiten. Sie können Felder im Zeilen-, Spalten- und Detailbereich filtern. Wenn Sie ein Feld filtern, wählen Sie ein oder mehrere Datenelemente im Feld zur Anzeige aus, während alle anderen ausgeblendet werden.

Beispiele für eine gefilterte PivotTable-Liste

Zuerst wird das Feld "Sport" gefiltert, um nur die Verkäufe im Teilbereich "Golf" anzuzeigen, anschließend wird das Feld "Vierteljahr" gefiltert, so dass nur die Verkäufe im Teilbereich "Golf" im dritten Quartal angezeigt werden.

Wenn die PivotTable-Liste, die Sie aktuell betrachten, gefiltert worden ist, sind die Dropdownpfeile Feldpfeil der gefilterten Felder blau anstatt schwarz.

Auswählen von mehreren Elementen in mehreren Feldern Das Filtern erweist sich besonders dann als nützlich, wenn eine PivotTable-Liste ein große Menge Quelldaten aufweist und Sie sich nur auf die Bereiche konzentrieren möchten, die für Sie von besonderem Interesse sind. Wenn Sie ein Feld filtern, können Sie die Daten für ein einzelnes Element anzeigen, oder Sie können einige Elemente zur Anzeige auswählen und andere Elemente ausblenden. Sie können mehr als ein Feld gleichzeitig filtern, um den Schwerpunkt der in der Liste angezeigten Daten weiter einzugrenzen. So filtern Sie ein Feld.

Filtern basierend auf den Daten in einer Zelle Sie können ein Feld filtern, um nur Daten anzuzeigen, die dem Wert in einer ausgewählten Zelle entsprechen. Filtern durch Auswahl ist besonders für Felder im Detailbereich von Nutzen, wenn Sie alle Zeilen anzeigen möchten, die einen bestimmten Wert enthalten.

Deaktivieren des Filters Um wieder alle Daten für alle Felder in einer PivotTable-Liste anzuzeigen, können Sie alle Filter entfernen. Die Filtereinstellungen werden jedoch beibehalten, so dass die gleichen Daten, die im Vorfeld angezeigt wurden bzw. ausgeblendet waren, erneut angezeigt bzw. ausgeblendet werden, wenn Sie die Filterung wieder aktivieren. Die Filtereinstellungen werden auch beibehalten, wenn Sie in der PivotTable-Liste Felder verschieben, um das Layout zu ändern. Wenn Sie jedoch neue Filtereinstellungen definieren, während die Filterung deaktiviert ist, werden die vorherigen Filtereinstellungen gelöscht.

Verwenden eines Filterfeldes zum Filtern einer gesamten PivotTable-Liste Sie können Daten auch mit Hilfe von Filterfeldern filtern. Wenn Sie ein anderes Element für ein Filterfeld auswählen, ändern sich die Daten, die angezeigt und berechnet werden, für die gesamte PivotTable-Liste. Sie können einer PivotTable-Liste neue Filterfelder hinzufügen oder vorhandene Felder in den Filterbereich verschieben.

Auswirkungen beim Filtern von Berechnungen Standardmäßig umfassen Teilergebnisse und Gesamtergebnisse alle Daten in einem Feld, einschließlich der angezeigten und ausgeblendeten Daten. Wenn Sie mit Hilfe von Filtern ausgeblendete Daten aus Teilergebnissen und Gesamtergebnissen ausnehmen möchten, können Sie eine Option aktivieren, mit der nur angezeigte Daten eingeschlossen werden.

Wenn Sie einen Suchbefehl benötigen Wenn Sie die Daten durchsuchen möchten anstatt sie zu filtern oder wenn Sie Daten finden möchten, die einem bestimmten Muster entsprechen, können Sie die PivotTable-Liste nach Microsoft Excel exportieren. Informationen über die Verwendung des Excel-Befehls Suchen finden Sie in der Excel-Hilfe.


Filtern eines Feldes, um nur die gewünschten Daten anzuzeigen

  1. Klicken Sie auf den Dropdownpfeil Feldpfeil des Feldes, das die Datenelemente enthält, die Sie filtern möchten.

  2. Markieren Sie die Kontrollkästchen für die Elemente, die Sie anzeigen möchten, und löschen Sie die Kontrollkästchen für die Datenelemente, die Sie ausblenden möchten.

Anmerkungen

  • Um alle Daten für ein Feld anzuzeigen oder auszublenden, markieren oder löschen Sie das Kontrollkästchen Alle anzeigen.

  • Ein schattiertes Kontrollkästchen zeigt an, dass einige oder alle der Elemente auf der niedrigeren Ebene ausgeblendet wurden. Wenn Sie sehen möchten, welche Elemente der niedrigeren Ebene ausgeblendet wurden, klicken Sie auf Plusfeld neben dem Element mit dem schattierten Kontrollkästchen.

  • Wenn Sie alle Daten für alle Felder anzeigen möchten, klicken Sie auf AutoFilter [image] , so dass die Schaltfläche nicht länger gedrückt ist. Die Filterauswahl, die Sie im Vorfeld getroffen haben, wird beibehalten, und wenn Sie das nächste Mal auf die Schaltfläche AutoFilter klicken, werden die Felder erneut gefiltert. Wenn die Filterauswahl nicht beibehalten werden soll, vergewissern Sie sich, dass die Schaltfläche AutoFilter nicht gedrückt ist, wenn Sie mit der Auswahl der zu filternden Elemente beginnen. Wenn die Schaltfläche nicht gedrückt ist, wird mit der Auswahl neuer zu filternder Elemente die Filterung automatisch aktiviert, und frühere Filtereinstellungen werden entfernt.

  • Wenn Sie ein Feld verschieben, für das ein Filter gesetzt wurde, werden Ihre Filtereinstellungen für dieses Feld beibehalten, wenn sich das Feld im Daten- oder Filterbereich befindet, in dem die Elemente nicht ausgeblendet sind. Dies bedeutet, dass die vorher ausgeblendeten Elemente wiederum ausgeblendet werden, wenn Sie das Feld zurück in den Zeilen-, Spalten- oder Detailbereich verschieben. Auch wenn Sie ein solches Feld entfernen und es zu einem späteren Zeitpunkt dem Layout wieder hinzufügen, werden die gleichen Elemente wieder ausgeblendet. Dass Elemente in einem Feld ausgeblendet wurden, erkennen Sie daran, dass der Pfeil neben der Feldbeschriftung in diesem Fall blau statt schwarz ist.


Nur Anzeigen von Daten, die einer Zelle entsprechen

  • Klicken Sie mit der rechten Maustaste auf die Zelle, die den Wert enthält, den Sie anzeigen möchten, und klicken Sie dann im Kontextmenü auf Auswahlbasierter Filter.

Anmerkungen

  • Wenn die Schaltfläche AutoFilter [image] in der Symbolleiste gedrückt wurde, erfolgt das Filtern durch Auswahl kumulativ, d. h., es wird den bereits aktiven Filtern ein weiterer Filter hinzugefügt. Wenn AutoFilter nicht gedrückt wurde, werden mit dem Filtern durch Auswahl automatisch alle Filter entfernt, die Sie im Vorfeld gesetzt hatten, und die Filterung wird eingeschaltet, wodurch eine neue Akkumulation begonnen wird.

  • Wenn Sie alle Daten für alle Felder anzeigen möchten, klicken Sie auf AutoFilter [image] , so dass die Schaltfläche nicht mehr gedrückt ist. Die Filterauswahl, die Sie im Vorfeld getroffen haben, wird beibehalten, und wenn Sie das nächste Mal auf die Schaltfläche AutoFilter klicken, werden die gleichen Felder erneut gefiltert. Wenn die Filterauswahlen nicht beibehalten werden sollen, vergewissern Sie sich, dass die Schaltfläche AutoFilter nicht gedrückt ist, bevor Sie mit der Auswahl der zu filternden Elemente beginnen.

  • Wenn Sie ein Feld verschieben, für das ein Filter gesetzt wurde, werden Ihre Filtereinstellungen für dieses Feld beibehalten, wenn sich das Feld im Daten- oder Filterbereich befindet, in dem die Elemente nicht ausgeblendet sind. Dies bedeutet, dass die vorher ausgeblendeten Elemente wiederum ausgeblendet werden, wenn Sie das Feld zurück in den Zeilen-, Spalten- oder Detailbereich verschieben. Auch wenn Sie ein solches Feld entfernen und es zu einem späteren Zeitpunkt dem Layout wieder hinzufügen, werden die gleichen Elemente wieder ausgeblendet. Dass Elemente in einem Feld mit Hilfe eines Filters ausgeblendet wurden, erkennen Sie daran, dass der Dropdownpfeil Feldpfeil neben der Feldbeschriftung in diesem Fall blau statt schwarz ist.


Entfernen von Filtern zum Anzeigen aller Daten

  • Klicken Sie in der Symbolleiste der PivotTable-Liste auf AutoFilter [image] , so dass die Schaltfläche nicht gedrückt ist.

Tipp Wenn Sie erneut auf AutoFilter [image] klicken, um die Filterung wieder zu aktivieren, werden die vorher festgelegten Filtereinstellungen wiederhergestellt.


Sortieren von Daten in einem Feld

  1. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie die Daten in einem Feld basierend auf den Elementbeschriftungen sortieren möchten, klicken Sie auf die Beschriftung des Feldes, das Sie sortieren möchten.

    Wenn Sie die Daten in einem Feld basierend auf den zusammengefassten Werten in einer Spalte sortieren möchten, klicken Sie auf eine Zelle in der Spalte, die die Werte enthält, nach denen Sie sortieren möchten.

    Wenn Sie die Daten in einem Feld basierend auf Teilergebnis- oder Gesamtergebniswerten sortieren möchten, klicken Sie auf den Teilergebnis- oder Gesamtergebniswert des Feldes, das Sie sortieren möchten. Wenn Sie auf einen Gesamtergebniswert in der untersten Zeile einer PivotTable-Liste klicken, werden an Stelle der Zeilen die Spalten sortiert.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf eine der folgenden Schaltflächen:

    Wenn Sie ein Feld in der Reihenfolge A - Z, 0 - 9 sortieren möchten, klicken Sie auf Aufsteigend sortieren [image].

    Wenn Sie ein Feld in der Reihenfolge Z - A, 9 - 0 sortieren möchten, klicken Sie auf Absteigend sortieren [image].

Anmerkungen

  • Um einen Sortiervorgang rückgängig zu machen und die Datenelemente im Feld in die ursprüngliche Reihenfolge zurückzuversetzen, klicken Sie erneut auf Aufsteigend sortieren [image] oder Absteigend sortieren [image] , so dass die Schaltfläche nicht mehr gedrückt ist.

  • Wenn Sie ein Feld sortieren, für das höhere und niedrigere Detailebenen verfügbar sind, werden die aktuelle Ebene und alle niedrigeren Ebenen sortiert, höhere Ebenen werden jedoch nicht sortiert.

  • Die Reihenfolge, in der Zahlen, Text und Sonderzeichen sortiert werden, ist abhängig von den Quelldaten und Ihren Ländereinstellungen in der Windows-Systemsteuerung.

  • Wenn Sie ein Feld in einer PivotTable-Liste sortieren, die auf Quelldaten aus einer OLAP-Datenbank basiert, werden die aktuelle und alle niedrigeren Ebenen sortiert. Die höheren Ebenen legen fest, welche Elemente der niedrigeren Ebene zusammen sortiert werden. Problembehandlung beim Sortieren von Daten aus OLAP-Datenbanken.

  • Sie können nach mehr als einer Spalte sortieren, indem Sie jede Spalte einzeln sortieren.


Info über das Sortieren von Daten nach mehr als einer Spalte

Wenn Sie nach mehr als einer Spalte sortieren möchten, können Sie jede Spalte der PivotTable-Liste separat sortieren. Hierbei legen Sie anhand der Reihenfolge, in der Sie die Spalten sortieren, fest, wie die Daten geordnet werden.

Beispiel für Daten, die nach zwei Spalten sortiert wurden

In diesem Beispiel ist die Liste nach Verkäufer geordnet. Die Spalte "Produkt" wurde zuerst sortiert, so dass die Produkte in alphabetischer Reihenfolge stehen; die Spalte "Verkäufer" wurde als zweite sortiert.

Wenn Sie nach mehreren Spalten sortieren, legen Sie zuerst die Reihenfolge fest, in der Sie die Spalten sortieren möchten, und arbeiten dann in umgekehrter Reihenfolge, wobei Sie die am weitesten außen befindliche Spalte zuletzt sortieren. Wenn Sie beispielsweise nach zwei Spalten sortieren, legen Sie zunächst fest, welches die äußere und welches die innere Spalte ist. Sortieren Sie nun zuerst die innere und dann die äußere Spalte. Um die Produkte für jeden Verkäufer in alphabetischer Reihenfolge aufzulisten, sortieren Sie zuerst die innen befindliche Spalte "Produkt" und dann die äußere Spalte "Verkäufer".

So sortieren Sie Daten in einer PivotTable-Liste.


Info über das Ändern des Layouts einer PivotTable-Liste

Sie können ändern, wie die Daten in einer PivotTable-Liste zusammengefasst werden, indem Sie deren Layout ändern. Unter Verwendung eines anderen Layouts können Sie zusammengefasste Werte für unterschiedliche Elemente in Ihren Daten berechnen und vergleichen, oder Sie können Zusammenfassungen für eine Teilmenge der Daten anzeigen.

Verwenden der Dropbereiche Sie können das Layout ändern, indem Sie die Felder in vordefinierte Dropbereiche innerhalb der PivotTable-Liste verschieben. Um die Gliederungen der Dropbereiche wieder sichtbar zu machen, wenn diese ausgeblendet wurden, zeigen Sie die Dropbereiche an.

Beispiel für Dropbereiche

Auch wenn Sie Felder so in den Dropbereichen abgelegt haben, dass deren Beschriftungen verdeckt werden, können Sie weiterhin Felder in die Dropbereiche ziehen, oder Sie können die Befehle in der Symbolleiste verwenden, um Felder zu verschieben.

Verschieben von Feldern in die Zeilen- und Spaltenbereiche Wenn Sie ein Feld in einen Zeilenbereich verschieben, werden die eindeutigen Elemente mit Daten in diesem Feld vertikal in den Zeilen der PivotTable-Liste (also als Spalte) angezeigt. Wenn Sie ein Feld in einen Spaltenbereich verschieben, werden die eindeutigen Elemente mit Daten horizontal über die Spalten (also als Zeile) dargestellt.

Ändern der Ebene von Zeilen- und Spaltenfelder Wenn eine PivotTable-Liste über mehrere Zeilen- und Spaltenfelder verfügt, werden die Felder, die sich direkt neben den zusammengefassten Daten befinden, als "innere Felder" bezeichnet. Die anderen Felder sind äußere Felder. Für innere Felder können mehr Details angezeigt werden als für äußere Felder.

Beispiel für innere und äußere Zeilenfelder

Sie können die Anordnung dieser Felder ändern, indem Sie Felder auf eine höhere Ebene verschieben, so dass aus inneren Feldern äußere Felder werden, oder Sie können Felder auf eine niedrigere Ebene verschieben.

Verschieben von Feldern in den Filterbereich Ein Filterfeld ist mit einem Seitenfeld in einem Microsoft Excel PivotTable-Bericht vergleichbar. Filterfelder ermöglichen Ihnen, die Ansicht auf einen bestimmten Teil der verfügbaren Daten zu beschränken. Wenn Sie beispielsweise ein Feld "Produkt" in den Filterbereich verschieben, können Sie veranlassen, dass in der PivotTable-Liste eine Zusammenfassung für jeweils ein Produkt angezeigt wird. So verschieben Sie ein Feld in den Filterbereich.

Verschieben von Feldern in den Datenbereich Mit Datenfeldern werden die Werte bereitgestellt, die in der PivotTable-Liste zusammengefasst werden sollen. Wenn Sie ein Feld in den Datenbereich verschieben, werden die Werte in diesem Feld entsprechend der Zeilen- und Spaltenfeldelemente zusammengefasst.

Verschieben von Feldern in den Detailbereich Wenn Sie alle Detaildatensätze der Quelldaten der PivotTable-Liste anzeigen möchten, können Sie Felder in den Detailbereich verschieben. Wenn Sie die Felder nicht neu anordnen oder die zusammengefassten Daten nicht ändern möchten, können Sie neben den zusammengefassten Daten Details anzeigen.

Hinzufügen und Entfernen von Daten Das Layout einer PivotTable-Liste umfasst möglicherweise nicht alle Felder, die anhand der Quelldaten verfügbar sind. Wenn weitere Daten verfügbar sind, können Sie dem Layout der Pivot-Tabellen Felder hinzufügen. Wenn in der PivotTable-Liste beispielsweise eine Zusammenfassung der Verkaufserlöse aufgeführt wird, die Quelldaten jedoch auch die Verkaufsmengen beinhalten, könnten Sie das Feld "Menge" als Datenfeld hinzufügen, um sowohl die Einnahmen aus dem Verkauf als auch die verkauften Mengen einzelner Produkte zusammenzufassen. Sie können aus dem PivotTable-Layout auch Felder entfernen, die Sie nicht länger benötigen.

Das Verschieben von Feldern hat keinen Auswirkungen auf die Filterung Wenn Sie ein Feld filtern, werden die Filtereinstellungen für dieses Feld beibehalten, wenn Sie das Feld in den Daten- oder Filterbereich verschieben. Dies bedeutet, dass die vormals ausgeblendeten Elemente wiederum ausgeblendet werden, wenn Sie das Feld zurück in den Zeilen-, Spalten- oder Detailbereich verschieben. Ebenso gilt, wenn Sie ein Feld entfernen und dem Layout zu einem späteren Zeitpunkt das Feld wieder hinzufügen, werden die gleichen Elemente wieder ausgeblendet. Ob die Elemente in einem Feld per Filterung ausgeblendet wurden, erkennen Sie daran, dass der Pfeil in der Feldbeschriftung in diesem Fall blau ist.

Einschränkungen beim Hinzufügen und Verschieben von Feldern Wenn Sie mit einer PivotTable-Liste arbeiten, die auf Quelldaten aus eine OLAP-Datenbank basiert, wie beispielsweise einer Datenbank, die unter Verwendung der Microsoft SQL Server OLAP Services erstellt wurde, werden Sie feststellen, dass Sie Felder nicht in den Detailbereich verschieben können. Sie werden darüber hinaus feststellen, dass einige Felder nur in die Zeilen-, Spalten- und Filterbereiche verschoben werden können und dass die Felder im Datenbereich nicht in andere Bereiche verschoben werden können.


Anzeigen der Dropbereiche für das Verschieben und Hinzufügen von Feldern

  • Klicken Sie mit der rechten Maustaste auf die Titelleiste der PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Dropbereiche.

Anmerkungen

  • Wenn die PivotTable-Liste nicht über eine Titelleiste verfügt, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Wenn die Kategorie Ein-/Ausblenden nicht erweitert ist, klicken Sie auf die Ein-/Ausblenden-Leiste. Klicken Sie auf Dropbereiche [image].

  • Wenn Felder in alle Bereiche verschoben worden sind, sind die Konturen und Titel der Dropbereiche zwar nicht mehr sichtbar, Sie können jedoch weiterhin Felder in die Bereiche verschieben.


Verschieben eines Feldes in den Zeilen- oder Spaltenbereich

  1. Zeigen Sie auf die Feldbeschriftung des Feldes, das Sie verschieben möchten, bis sich der Mauszeiger in Zeiger mit Vierfachpfeil ändert.

  2. Führen Sie eine der folgenden Aktionen aus:

    Um aus dem Feld ein Zeilenfeld zu machen, ziehen Sie die Feldbeschriftung in den Zeilenbereich auf der linken Seite der PivotTable-Liste, bis sich der Mauszeiger in Zeiger mit hervorgehobenem Zeilenbereich ändert.

    Um aus dem Feld ein Spaltenfeld zu machen, ziehen Sie die Feldbeschriftung in den Spaltenbereich nahe dem Kopf der PivotTable-Liste, bis sich der Mauszeiger in Zeiger mit hervorgehobenem Spaltenbereich ändert.

Tipp Wenn Sie für das neue Zeilen- oder Spaltenfeld nur zusammengefasste Daten anzeigen möchten, klicken Sie für die Datenelemente im Feld auf die Felder Minusfeld .


Ändern der Ebene eines Zeilen- oder Spaltenfeldes

  1. Klicken Sie auf die Feldbeschriftung des Feldes, das Sie zu einer anderen Ebene verschieben möchten.

  2. Führen Sie in der Symbolleiste der PivotTable-Liste eine der folgenden Aktionen aus:

    Wenn Sie das Feld auf eine höhere Ebene verschieben möchten, klicken Sie auf Heraufstufen [image].

    Um das Feld auf eine tiefere Ebene zu verschieben, klicken Sie auf Tieferstufen [image].


Verschieben eines Feldes in den Datenbereich

Sie können Felder aus dem Zeilen-, Spalten und Filterbereich nur dann in den Datenbereich verschieben, wenn die PivotTable-Liste auf Daten aus einer anderen Datenquelle als einer OLAP-Datenbank basiert.

  1. Zeigen Sie die Dropbereiche für die PivotTable-Liste an.

  2. Zeigen Sie auf die Feldbeschriftung des Feldes, das Sie verschieben möchten, und warten Sie, bis sich der Mauszeiger in Zeiger mit Vierfachpfeil ändert.

  3. Ziehen Sie das Feld in den Datenbereich auf der unteren rechten Seite der PivotTable-Liste, bis sich der Mauszeiger in Zeiger mit Sigma ändert.

Anmerkung Wie das Feld, das Sie in den Datenbereich ziehen, zusammengefasst wird, ist abhängig von dem im Feld befindlichen Datentyp. Felder, die numerische Daten enthalten, werden mit der Zusammenfassungsfunktion "Summe" zusammengefasst. Felder, die andere Datentypen enthalten, werden mit der Zusammenfassungsfunktion "Anzahl" zusammengefasst. Sie können die Zusammenfassungsfunktion für einige Felder ändern.


Verschieben eines Feldes in den Filterbereich

Wenn Sie ein Feld in den Filterbereich verschieben, können Sie die gesamte PivotTable-Liste filtern, um Daten nur für das Element anzuzeigen, das Sie in der Dropdownliste des Filterfeldes auswählen.

  1. Zeigen Sie die Dropbereiche der PivotTable-Liste an.

  2. Zeigen Sie auf die Feldbeschriftung des Feldes, das Sie verschieben möchten, und warten Sie, bis sich der Mauszeiger in Zeiger mit Vierfachpfeil ändert.

  3. Ziehen Sie das Feld in den Filterbereich am Kopf der PivotTable-Liste, bis sich der Mauszeiger in Zeiger mit hervorgehobenem Filterbereich ändert.

Anmerkung Wenn Sie keine Felder in den oder aus dem Filterbereich ziehen können, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff auf die Filterfunktion möglicherweise beschränkt.


Verschieben eines Feldes in den Detailbereich

Sie können Felder nicht in den Detailbereich verschieben, wenn die Person, die die PivotTable-Liste erstellt hat, den Zugriff auf den Detailbereich beschränkt hat, oder wenn die PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert.

  1. Klicken Sie auf die Feldbeschriftung des Feldes, das Sie in den Detailbereich verschieben möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf In Detailbereich verschieben [image].


Ändern der Spaltenreihenfolge

  1. Zeigen Sie auf die Feld- oder Elementbeschriftung im Spaltenkopf, bis sich der Mauszeiger in Zeiger mit Vierfachpfeil ändert.

  2. Ziehen Sie die Spalte an die neue Position.

Tipp Um die Reihenfolge von Feldern schnell zu ändern, wenn Sie über mehrere Zeilen- oder Spaltenfelder verfügen, klicken Sie auf das Feld, das Sie ändern möchten, und klicken Sie dann in der Symbolleiste der PivotTable-Liste auf Heraufstufen [image] oder Tieferstufen [image].


Info über das Anzeigen von Gesamtsummen in einer PivotTable-Liste

In PivotTable-Listen werden zwei unterschiedliche Arten von Gesamtsummen zum Anzeigen zusammengefasster Werte verwendet. Mit dem ersten Typ, dem Summenfeld, werden die zusammengefassten Werte für die PivotTable-Liste bereitgestellt. Befindet sich in Ihrer PivotTable-Liste ein Summenfeld, können Sie auch den zweiten Typ, Teilergebnisse und Gesamtergebnisse, für die Zeilen- und Spaltenfelder anzeigen.

In diesem Hilfethema wird erläutert, wie Summenfelder, Teilergebnisfelder und Gesamtergebnisfelder funktionieren, und welche Änderungen Sie an der Art der Anzeige jedes Feldes vornehmen können.

Summenfelder

Teilergebnisse und Gesamtergebnisse

Summenfelder

Wie Summenfelder funktionieren Summenfelder sind Datenfelder, die entweder in den Quelldaten zur Verfügung stehen oder von Ihnen erstellt werden, um Daten aus anderen Feldern der Quelldaten zusammenzufassen. Wenn sich in den Quelldaten beispielsweise ein Feld "Sales" befindet, mit dem die Mengen jedes einzelnen Verkaufs aufgezeichnet wird, können Sie mit einem Summenfeld "Sum of Sales" die Verkaufszahlen für jede einzelne Kategorie in der PivotTable-Liste addieren, oder Sie können mit einem Summenfeld "Count for Sales" die Anzahl der verkauften Einheiten pro Produkt berechnen. In der Feldliste werden die Summenfelder im oberen Bereich unter Summe aufgeführt.

Beispiel für eine Feldliste mit Summenfeldern

Die Felder "Sales" und "Units" stehen als Summenfelder für die Aufnahme in die PivotTable-Liste zur Verfügung.

In einigen PivotTable-Listen werden die Werte der Summenfelder möglicherweise bereits auf dem Datenbankserver berechnet, der die Quelldaten liefert. In diesem Fall stehen die Befehle zum Hinzufügen von neuen Summenfeldern, zum Verschieben von Summenfeldern in den Detailbereich und zum Ändern der Zusammenfassungsfunktion, die zum Berechnen der Werte in einem Summenfeld verwendet wurde, nicht zur Verfügung. Wenn Sie herauszufinden möchten, welche Art Quelldaten in der von Ihnen angezeigten PivotTable-Liste verwendet wird, wenden Sie sich an den Ersteller der PivotTable-Liste.

Hinzufügen neuer Summenfelder Wenn mit den in der Feldliste befindlichen Summenfeldern die gewünschte Art der Zusammenfassung nicht geboten wird und die Quelldaten dies zulassen, können Sie der PivotTable-Liste neue Summenfelder hinzufügen. In den meisten Fällen fügen Sie Summenfelder zum Datenbereich hinzu. In der folgenden PivotTable-Liste wurde das Summenfeld "Sum of Sales" beispielsweise dem Datenbereich hinzugefügt, um die zusammengefassten Daten nach Sportart und Quartal anzuzeigen.

Beispiel für ein Summenfeld in einerPivotTable-Liste

Im Summenfeld "Sum of Sales" werden, wenn dieses dem Datenbereich hinzugefügt wird, die zusammengefassten Werte je Sportart und Quartal angezeigt.

Wenn die Quelldaten dies zulassen, können Sie auch Summenfelder zum Detailbereich hinzufügen. Wenn Sie beispielsweise im vorstehenden Beispiel den Umfang jedes einzelnen Verkaufs anzeigen möchten, können Sie das Feld "Sum of Sales" dem Detailbereich hinzufügen. Beachten Sie jedoch, dass Sie dem Zeilen-, Spalten- oder Filterbereich keine Summenfelder hinzufügen können.

Zusammenfassungsfunktionen für Summenfelder Für ein Summenfeld kann eine beliebige der vier Zusammenfassungsfunktionen verwendet werden, also "Summe", "Anzahl", "Minimum" oder "Maximum". Sie können die Zusammenfassungsfunktion ändern, wenn Sie eine andere Art der Zusammenfassung anzeigen möchten, sofern die Quelldaten und die Art des Feldes dies zulassen. Wenn ein Feld beispielsweise Text enthält, steht für dieses Feld nur die Zusammenfassungsfunktion "Anzahl" zur Verfügung. Wenn die Art der Quelldaten dies gestattet, können Sie auch mehr als eine Zusammenfassungsfunktion verwenden, um die Daten im gleichen Feld zusammenzufassen, und zwar, indem Sie weitere Summenfelder hinzufügen, von denen jedes eine andere Zusammenfassungsfunktion verwendet.

Ändern der Position, an der die Feldbeschriftungen von Summenfeldern angezeigt werden Sie können in einer PivotTable-Liste die Ausrichtung von Summenfeldern ändern. Werden die Felder in Zeilenausrichtung angezeigt, werden sie in der ersten Spalte rechts der Zeilenfelder aufgelistet. Werden die Felder in Spaltenausrichtung angezeigt, werden sie in der ersten Zeile unterhalb der Spaltenfelder aufgeführt.

Zurück zum Anfang

Teilergebnisse und Gesamtergebnisse

Anzeigen von Teilergebnissen und Gesamtergebnissen Sie können für jedes beliebige Zeilen- oder Spaltenfeld in der PivotTable-Liste Teilergebnisse anzeigen, wenn die Liste zumindest ein Summenfeld und mehr als ein Zeilenfeld oder mehr als ein Spaltenfeld enthält. Wenn Sie sich für die Anzeige von Teilergebnissen für ein Feld entscheiden, wird hiermit auch die Anzeige von Gesamtergebnissen aktiviert, und für jedes Summenfeld in der PivotTable-Liste werden am Schnittpunkt mit dem jeweils gewählten Zeilen- oder Spaltenfeld Teilergebnisse und Gesamtergebnisse angezeigt. So zeigen Sie Teilergebnisse und Gesamtergebnisse für ein Feld an.

Im folgenden Beispiel werden unter Verwendung der Werte im Summenfeld "Sum of Sales" Teilergebnisse und Gesamtergebnisse für beide Zeilenfelder angezeigt.

Beispiel für Teilergebnisse und Gesamtergebnisse in einer PivotTable-Liste

Wenn für die Felder "Sport" und "Quarter" Teilergebnisse und Gesamtergebnisse angezeigt werden, weist die PivotTable-Liste Teilergebnisse für das Feld "Quarter" und ein Gesamtergebnis für das Feld "Sport" auf.

Verschieben oder Ausblenden von Teilergebnissen und Gesamtergebnissen Wenn Sie ein Feld, für das Teilergebnisse oder Gesamtergebnisse angezeigt werden, aus dem Zeilen- oder Spaltenbereich verschieben, werden die Teilergebnisse oder Gesamtergebnisse ausgeblendet, jedoch wird die Einstellung des Feldes beibehalten. Die Teilergebnisse oder Gesamtergebnisse werden also erneut angezeigt, wenn Sie das Feld wieder in den Zeilen- oder Spaltenbereich zurück verschieben.

Wenn Sie für ein Feld Teilergebnisse und Gesamtergebnisse ausblenden, bleiben diese ungeachtet der Position, an die Sie das Feld verschieben, ausgeblendet; dies gilt auch dann, wenn Sie das Feld aus der PivotTable-Liste entfernen und später wieder hinzufügen.

Ändern der Ausrichtung in Relation zu Detaildaten Sie können die Ausrichtung des Textes in den Teilergebnis- und Gesamtergebniszeilen ändern, so dass der Text links- oder rechtsbündig ausgerichtet oder zentriert wird. Die Unterschiede in der Ausrichtung sehen Sie, wenn Sie in einem Feld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden, die Details für eines oder mehrere Elemente anzeigen.

Einschließen und Ausschließen ausgeblendeter Daten Abhängig von den Quelldaten und dem Datentyp, den Sie in der PivotTable-Liste anzeigen, möchten Sie möglicherweise, dass die Werte von Datenelementen, die Sie mit Hilfe eines Filters ausgeblendet haben, in Teilergebnisse und Gesamtergebnisse eingeschlossen oder ausgeschlossen werden. Sie können daher für alle Teilergebnisse und Gesamtergebnisse angeben, ob ausgeblendete Daten eingeschlossen oder ausgeschlossen werden sollen.

Zurück zum Anfang


Hinzufügen eines Summenfeldes zu einer PivotTable-Liste

  1. Klicken Sie auf das Feld, das die Werte enthält, die Sie zusammenfassen möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf AutoBerechnung [image], und klicken Sie dann auf die gewünschte Zusammenfassungsfunktion.

    Wenn die Schaltfläche AutoBerechnung nicht zur Verfügung steht, gestatten die Quelldaten der PivotTable-Liste möglicherweise das Hinzufügen von Summenfeldern nicht. Wenden Sie sich in diesem Fall für weitere Informationen an den Ersteller der PivotTable-Liste.

Anmerkungen

  • Wenn Sie ein Summenfeld entfernen, steht das Feld weiterhin über die Feldliste zur Verfügung, und Sie können es jederzeit der PivotTable-Liste wieder hinzufügen. Wenn Sie ein Summenfeld sowohl aus der PivotTable-Liste als auch aus der Feldliste löschen möchten, klicken Sie mit der rechten Maustaste auf das Summenfeld und klicken anschließend im Kontextmenü auf Löschen.

  • Sie können dem Datenbereich Summenfelder hinzufügen und, sofern die Quelldaten dies zulassen, auch dem Detailbereich Summenfelder hinzufügen. Allerdings können Sie diese Felder nicht dem Zeilen-, Spalten- oder Filterbereich hinzufügen.


Ändern der Zusammenfassungsfunktion für ein Summenfeld

  1. Markieren Sie das Summenfeld, für das Sie die Zusammenfassungsfunktion ändern möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Gesamtsummenfunktion nicht erweitert ist, klicken Sie auf die Gesamtsummenfunktion-Leiste.

    Wenn die Total Function-Leiste nicht angezeigt wird, gestatten die Quelldaten der PivotTable-Liste ein Ändern der Zusammenfassungsfunktion möglicherweise nicht. Wenden Sie sich für weitere Informationen hierzu an den Ersteller der PivotTable-Liste.

  4. Klicken Sie in der Liste Funktion auf die Zusammenfassungsfunktion, die Sie für das gesamte Feld einsetzen möchten.


Zusammenfassungsfunktionen

Der Befehl AutoBerechnung [image] in der Symbolleiste einer PivotTable-Liste stellt die folgenden Zusammenfassungsfunktionen für die Verwendung in Summenfeldern bereit:

Summe Berechnet die Summe der Werte.

Anzahl Ermittelt die Anzahl der Werte. Leere Werte wie beispielsweise Zeichenfolgen der Länge Null werden, im Gegensatz zu Nullwerten, bei der Zählung mit einbezogen.

Min Gibt den niedrigsten Wert in dem Feld zurück, das zusammenfasst wird.

Max Gibt den höchsten Wert in dem Feld zurück, das zusammengefasst wird.

Anmerkung Die für ein Feld verfügbaren Zusammenfassungsfunktionen sind abhängig vom Datentyp im Feld. Enthält ein Feld beispielsweise Datumsangaben, können Sie für dieses Feld nicht "Summe" als Zusammenfassungsfunktion verwenden. Wenn eine Feld Text enthält, können Sie weder "Summe" noch "Min" oder "Max", sondern nur "Anzahl" verwenden.


Ändern der Ausrichtung von Summenfeldern

Dieses Verfahren wirkt sich auf alle Summenfelder in der PivotTable-Liste aus. Teilergebnisse oder Gesamtergebnisse sind nicht einbezogen. So ändern Sie die Ausrichtung von Teilergebnissen und Gesamtergebnissen unter Berücksichtigung der Detaildaten.

  1. Markieren Sie die gesamte PivotTable-Liste, indem Sie auf die Titelleiste klicken.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Gesamtsummen nicht erweitert ist, klicken Sie auf die Totals-Leiste.

  4. Wählen Sie in der Liste Summenorientierung einen der folgenden Einträge:

    Klicken Sie auf Zeile, um Summenfelder in der ersten Spalte rechts der Zeilenfelder, oder, wenn keine Zeilenfelder vorhanden sind, in der am weitesten links befindlichen Spalte anzuzeigen.

    Klicken Sie auf Spalte, wenn Sie Summenfelder in der ersten Zeile unterhalb der Spaltenfelder, oder, falls keine Spaltenfelder vorhanden sind, in der obersten Zeile anzeigen möchten.


Anzeigen von Teilergebnissen und Gesamtergebnissen für ein Feld

  1. Klicken Sie auf das Zeilen- oder Spaltenfeld, für das Sie Teilergebnisse oder Gesamtergebnisse anzeigen möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Teilergebnis [image].

Anmerkungen

  • Klicken Sie auf diesen Hyperlink, wenn Sie mehr über das Arbeiten mit Teilergebnissen, Gesamtergebnissen und Summenfeldern in einer PivotTable-Liste erfahren möchten.

  • Teilergebnisse und Gesamtergebnisse werden für Felder im Detailbereich (dem Bereich, in dem alle individuellen Datensätze angezeigt werden können) nicht angezeigt.

  • Wenn Sie sich für deren Anzeige entscheiden, werden Teilergebnis- und Gesamtergebniswerte für jedes Summenfeld in der PivotTable-Liste angezeigt. Sie können einzelne Summenfelder nicht ausschließen.

  • Datenelemente, die mit Hilfe eines Filters ausgeblendet wurden, können in Teilergebnis- und Gesamtergebnisberechnungen eingeschlossen oder ausgeschlossen werden.


Ändern der Ausrichtung der Teilergebnis- und Gesamtergebniselemente in einem Summenfeld

Teilergebnis- und Gesamtergebniselemente für ein Summenfeld sind Beschriftungen wie beispielsweise "Summe der Verkäufe" oder "Lagerbestand" in der Teilergebnis- oder Gesamtergebniszeile oder -spalte. Die Ausrichtung der Teilergebnis- und Gesamtergebniselemente ist relativ zu anderen Zellen im Detailbereich. Wenn Sie sehen möchten, welche Effekte sich mit einer Ausrichtungsänderung ergeben, zeigen Sie die Details für ein oder mehrere Elemente in einem Feld an, für das Teilergebnisse und Gesamtergebnisse angezeigt werden.

  1. Markieren Sie das Summenfeld, für das Sie die Ausrichtung der Teilergebnis- und Gesamtergebniselemente ändern möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Gesamtsummenbeschriftung nicht erweitert ist, klicken Sie auf die Gesamtsummenbeschriftung-Leiste.

  4. Klicken Sie in der Liste Ausrichtung innerhalb von Zeilen auf die gewünschte horizontale Ausrichtung (Automatisch, Links, Zentriert oder Rechts).


Ein- oder Ausschließen verborgener Daten in Teil- und Gesamtergebnissen

Dieses Verfahren wirkt sich auf alle Teil- und Gesamtergebnisse in der PivotTable-Liste aus.

  1. Markieren Sie die gesamte PivotTable-Liste durch Klicken auf die Titelleiste.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn der Abschnitt Gesamtsummen nicht eingeblendet ist, klicken Sie auf die Leiste Gesamtsummen.

  4. Führen Sie einen der folgenden Schritte durch:

    Wenn verborgene Daten eingeschlossen werden sollen, aktivieren Sie das Kontrollkästchen Alle Elemente.

    Wenn verborgene Daten ausgeschlossen werden sollen, deaktivieren Sie das Kontrollkästchen Alle Elemente.

Anmerkungen

  • Diese Einstellung wirkt sich auf Daten aus, die durch das Filtern von Zeilen- und Spaltenfeldern ausgeblendet wurden. Anhand von Filterfeldern ausgeblendete Daten bleiben in Gesamtsummen stets ausgeschlossen.

  • Wenn Sie das Kontrollkästchen Alle Elemente aktivieren, werden neben den Teil- und Gesamtergebnissen Sternchen angezeigt. Hierdurch wird angegeben, dass in den Gesamtwerten sowohl die verborgenen als auch die angezeigten Elemente eingeschlossen sind.


Ausblenden von Teilergebnissen und Gesamtergebnissen für ein Feld

  1. Klicken Sie auf das Zeilen- oder Spaltenfeld, für das Sie Teilergebnisse und Gesamtergebnisse ausblenden möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Teilergebnis [image] , so dass die Schaltfläche nicht mehr gedrückt ist.


Info über das Anzeigen von Details zu zusammengefassten Daten

Die Menge der Details, die zu Beginn angezeigt werden, wird vom Ersteller der PivotTable-Liste bestimmt. Sie können die PivotTable-Liste jedoch so ändern, dass eine beliebige Menge der Details angezeigt wird, die in den Quelldaten zur Verfügung stehen. Sie können alle verfügbaren Details anzeigen, nur Zusammenfassungen der oberen Ebene oder eine beliebige Detailebene dazwischen, und Sie können ausgewählte Details zu Datenelementen anzeigen, die Sie besonders interessieren.

Erweiterungssymbol Verwenden Sie zum Ändern der Detailebene, die für jedes Datenelement in einem Feld angezeigt wird, die Erweiterungssymbole. Erweiterungssymbole sind die Felder Plusfeld und Minusfeld , die neben den Elementen angezeigt werden. Wenn Sie beispielsweise über ein Zeilenfeld mit Namen "Product" verfügen, das die Elemente "Dairy" und "Meat" enthält, sehen die Erweiterungssymbole möglicherweise wie folgt aus:

Beispiel für Erweiterungssymbole

Wenn keine Erweiterungssymbole angezeigt werden, können Sie deren Anzeige aktivieren. Wenn danach für ein Element noch immer keine Erweiterungssymbole angezeigt werden, befindet sich dieses Element möglicherweise auf der niedrigsten verfügbaren Detailebene der Quelldaten.

Anzeigen von Daten auf niedrigeren Ebenen Wenn die Erweiterungssymbole aktiviert sind, befindet sich neben Elementen, für die noch Daten auf niedrigeren Ebenen verfügbar sind, das Feld Plusfeld. Sie können Daten auf niedrigeren Ebenen anzeigen, und zwar für ein gesamtes Feld oder auf Elementbasis, wobei nur die Elemente erweitert werden, die Sie sehen möchten.

Anzeigen von Detaildaten In einer PivotTable-Liste, in der sich alle Felder im Detailbereich befinden, werden alle Detailzeilen oder Datensätze der Quelldaten in nicht zusammengefasster Form angezeigt. Verfügt eine PivotTable-Liste über Zeilen- und Spaltenfelder, können Sie Zusammenfassungen der Daten anzeigen, oder Sie können die spezifischen Detailzeilen oder Datensätze anzeigen, aus denen sich der zusammengefasste Wert eines Elements oder einer Zelle zusammensetzt. Sie können Detaildaten jedoch nur dann anzeigen, wenn die Person, die die PivotTable-Liste erstellt hat, den Zugriff auf die Detailebene nicht beschränkt hat und wenn Detaildaten in den Quelldaten verfügbar sind. Beispielsweise stellen OLAP-Datenbanken oftmals nur zusammengefasste Daten an Stelle von Detaildaten bereit.

Wenn Sie keine Detaildaten anzeigen möchten, können Sie die Details ausblenden.

Anzeigen von Zusammenfassungen höherer Ebenen Neben Elementen, für die aktuell Daten niedrigerer Ebenen angezeigt werden, wird das Feld Minusfeld angezeigt. Sie können die Detailanzeige für diese Elemente ausblenden, wenn Sie nur die Daten der höheren Ebene anzeigen möchten.

Elemente ohne Daten Standardmäßig werden in einer PivotTable-Liste keine Elemente angezeigt, für die sich in den Quelldaten keine Werte befinden. Wenn Sie beispielsweise die Verkaufszahlen für jeden Monat anzeigen und für April keine Verkäufe zu verzeichnen waren, würde im Feld Month" kein Element "April" angezeigt. Wenn Sie allerdings Elemente für alle zwölf Monate mit leeren Zellen für die Monate ohne Umsätze anzeigen möchten, können Sie auch Elemente ohne Daten anzeigen.


Anzeigen der Erweiterungssymbole neben Elementen

  1. Klicken Sie auf die PivotTable-Liste.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Ein-/Ausblenden nicht erweitert ist, klicken Sie auf die Ein-/Ausblenden-Leiste.

  4. Klicken Sie auf Erweiterungssymbole [image].

Anmerkung Bei Elementen, für die keine Daten auf niedrigeren Ebenen verfügbar sind, werden keine Erweiterungssymbole angezeigt.


Erweitern eines Elements zum Anzeigen der Daten auf einer niedrigeren Ebene

  1. Vergewissern Sie sich, dass die Erweiterungssymbole angezeigt werden.

  2. Klicken Sie auf das Feld Plusfeld neben dem Element, für das Sie die nächstuntere Datenebene anzeigen möchten.

Anmerkungen

  • Wenn Sie alle Elemente in einem Feld erweitern möchten, klicken Sie auf die Feldbeschriftung, und klicken Sie dann in der Symbolleiste der PivotTable-Liste auf Erweitern [image] .

  • Wenn ein Element nicht über ein Erweiterungssymbol verfügt, befindet sich das Element möglicherweise auf der untersten verfügbaren Ebene der Quelldaten. Wenn die Quelldaten dies gestatten, können Sie Detaildaten für Elemente auf der niedrigsten Ebene anzeigen.


Anzeigen von Detaildaten für ein Element oder eine Zelle

  1. Klicken Sie auf das Element oder die Zelle, für die Sie die Detaildaten anzeigen möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Erweitern [image].

Anmerkung Wenn Erweitern [image] nicht verfügbar ist, hat der Ersteller der PivotTable-Liste den Zugriff auf Detaildaten möglicherweise beschränkt. Eventuell befindet sich das Element oder die Zelle schon auf der niedrigsten Ebene, die für Quelldaten zur Verfügung steht, oder seitens der Quelldaten stehen keine Detaildaten zur Verfügung. Beispielsweise können Sie in PivotTable-Listen, die auf Quelldaten aus OLAP-Datenbanken basieren, unterschiedliche Datenebenen anzeigen, jedoch stellen diese Listen oftmals nur zusammengefasste Daten an Stelle von Detaildaten bereit.


Anzeigen von Elementen ohne Daten

  1. Markieren Sie die gesamte PivotTable-Liste, indem Sie auf die Titelleiste klicken.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Leere Elemente anzeigen nicht erweitert ist, klicken Sie auf die Leere Elemente anzeigen-Leiste.

  4. Wenn Sie Zeilenfeldelemente ohne Daten anzeigen möchten, aktivieren Sie das Kontrollkästchen Zeile.

    Zum Anzeigen von Spaltenfeldelementen ohne Daten aktivieren Sie das Kontrollkästchen Spalte.


Ausblenden eines Elements, um nur Daten der höheren Ebene anzuzeigen

  1. Vergewissern Sie sich, dass die Erweiterungssymbole angezeigt werden.

  2. Klicken Sie bei dem Element, für das Sie nur die Daten der höheren Ebene anzeigen möchten, auf das Feld Minusfeld.


Ausblenden von Detaildaten

  1. Klicken Sie auf das Datenelement, für das die Detaildaten angezeigt werden.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Reduzieren [image].

Anmerkung Um die Details für alle Elemente in einem Feld auszublenden, klicken Sie auf das Feld, und klicken Sie dann auf Reduzieren [image].


Info über das Hinzufügen oder Entfernen von Daten

Abhängig von der Art und Weise, wie die Person, die eine PivotTable-Liste erstellt hat, die Daten vorbereitet hat, können Sie weitere Daten anzeigen oder Daten entfernen, die Sie nicht anzeigen oder zusammenfassen möchten.

Wie die anfänglichen Daten ausgewählt werden Der Ersteller einer PivotTable legt die Datenbank fest, aus der Daten abgerufen werden, sowie die Untermenge der Daten, die als Quelldaten für die PivotTable-Liste zur Verfügung stehen sollen. Aus diesen Quelldaten wählt der Ersteller die Felder aus, die anfänglich in der PivotTable-Liste angezeigt werden und legt fest, wie die Daten zusammengefasst werden sollen.

Wie Sie weitere Daten anzeigen können Sie können zwar nicht ändern, welche Quelldaten zur Verfügung stehen, wenn sich in den Quelldaten jedoch Felder befinden, die aktuell in der PivotTable-Liste nicht angezeigt werden, können Sie diese Felder hinzufügen, um weitere Daten anzuzeigen.

Wenn in einer PivotTable-Liste beispielsweise die Verkaufserlöse zusammengefasst werden, sich in den Quelldaten jedoch auch die von jedem Produkt verkauften Mengen befinden, könnten Sie das Feld "Anzahl" als Datenfeld hinzufügen, um sowohl Umsatz als auch Menge jedes verkauften Produkts zusammenzufassen. Wenn in der PivotTable-Liste Produkte nach Typ und Verkäufer zusammengefasst werden und das Feld "Region" zur Verfügung steht, könnten Sie auch dieses Feld hinzufügen, um die Verkäufe nach Region anzuzeigen. Wenn Sie das Feld "Region" als Filterfeld hinzufügen, können Sie die gesamte PivotTable-Liste filtern, um nur die Daten anzuzeigen, die sich auf die gewählte Region beziehen.

Anzeigen und Hinzufügen von verfügbaren Feldern Klicken Sie auf Feldliste [image] , um die Liste der in den Quelldaten verfügbaren Felder anzuzeigen und um den Zeilen-, Spalten-, Filter-, Daten- und Detailbereichen der PivotTable-Liste Felder hinzuzufügen. Die Felder in der Feldliste, die nicht fett formatiert sind, sind verfügbar, werden in der PivotTable-Liste jedoch noch nicht angezeigt. Die fett formatierten Felder werden bereits angezeigt. Sie können einen Bildlauf durchführen und auf das Feld Plusfeld klicken, um weitere Felder anzuzeigen, bzw. auf das Feld Minusfeld , um weniger Felder anzuzeigen.

Wenn die Feldliste kein Feld für bestimmte Daten enthält, von denen Sie wissen, dass sie in der Quelldatenbank vorhanden sind, hat der Ersteller der PivotTable-Liste beschlossen, diese Daten nicht in die Liste aufzunehmen.

Hinzufügen von Detailfeldern Wenn Sie anzeigen möchten, welche Daten zwecks Zusammenfassung verfügbar sind, verwenden Sie die Detailfelder. Wenn Sie dem Detailbereich ein Feld hinzufügen, können Sie alle Detaildatensätze der Quelldaten für dieses Feld anzeigen. Feldnamen werden zu Spaltenbeschriftungen, und die Detaildatensätze werden in Zeilen unterhalb der Spaltenbeschriftungen angezeigt.

Beispiel für Detailfelder

Hinzufügen von Zeilen- und Spaltenfeldern Sie verwenden Zeilen- und Spaltenfelder, um Daten zusammenzufassen und zu vergleichen. In diesen Feldern werden die eindeutigen Datenelemente in einem Feld vertikal in Spalten oder horizontal in Zeilen angezeigt. In der Zelle am jeweiligen Schnittpunkt einer Zeile und einer Spalte werden die Daten für ein Element zusammengefasst. So fügen Sie Zeilen- und Spaltenfelder hinzu.

Beispiel für Zeilen- und Spaltenfelder

Hinzufügen von Datenfeldern Datenfelder stellen die zusammengefassten Werte in der PivotTable-Liste bereit. Wenn Sie dem Datenbereich ein Feld hinzufügen, werden die Werte in diesem Feld für die Elemente im Zeilen- und Spaltenfeld zusammengefasst. Sie können auch neue Datenfelder erstellen, indem Sie einer PivotTable-Liste Summenfelder hinzufügen. Summenfelder enthalten zusammengefasste Daten, die als Datenfelder verwendet werden können. Befindet sich in den Quelldaten beispielsweise ein Feld "Absatz", in dem der Umfang jedes Verkaufs angezeigt wird, könnten Sie ein Summenfeld "Gesamtsumme" hinzufügen, um die Gesamtverkäufe zu berechnen, oder Sie könnten ein Summenfeld "Gesamtsumme" hinzufügen, wenn Sie berechnen möchten, wie viele Einheiten verkauft wurden. Mehr über Gesamtsummen in PivotTable-Listen erfahren.

Beispiel für ein Datenfeld

Hinzufügen von Filterfeldern Ein Filterfeld ist mit einem Seitenfeld in einem Microsoft Excel PivotTable-Bericht vergleichbar. Sie verwenden Filterfelder, um die Anzeige eines bestimmten Datenelements in einem Feld einzuschränken. Wenn Sie ein Filterfeld hinzufügen, werden in der Anzeige anfänglich die Daten für alle Elemente in diesem Feld zusammengefasst. Wenn Sie im Filterfeld nun ein Element auswählen, werden die Daten nur für dieses Element angezeigt und berechnet. Wenn Sie beispielsweise als Filterfeld "Region" hinzufügen, können Sie in der PivotTable-Liste die Daten für nur jeweils eine Region anzeigen und berechnen. So fügen Sie ein Filterfeld hinzu.

Beispiel für ein Filterfeld

Verschieben von Feldern Nachdem Sie einer PivotTable-Liste ein Feld hinzugefügt haben, können Sie dieses Feld auch in andere Bereiche verschieben. Wenn Sie ein Feld verschieben, ändern Sie das Layout der PivotTable-Liste, und Sie ändern die Daten, die angezeigt und die Zusammenfassungen, die berechnet werden.

Einschränkungen beim Hinzufügen und Verschieben von Feldern Wenn Sie mit einer PivotTable-Liste arbeiten, die auf Quelldaten aus eine OLAP-Datenbank basiert, wie beispielsweise eine Datenbank, die unter Verwendung der Microsoft SQL Server OLAP Services erstellt wurde, werden Sie feststellen, dass Sie Felder nicht in den Detailbereich verschieben können. Sie werden darüber hinaus feststellen, dass einige Felder nur in die Zeilen-, Spalten- und Filterbereiche verschoben werden können. Andere Felder, die unter Gesamtsummen aufgeführt werden, können nur als Datenfelder verwendet werden.

Entfernen von Feldern Um Daten zu entfernen, die Sie nicht anzeigen oder zusammenfassen möchten, können Sie aus dem Layout der PivotTable-Liste Felder entfernen. Mit dem Entfernen eines Feldes aus der PivotTable-Liste wird dieses nicht aus den verfügbaren Quelldaten gelöscht. Ein Feld, das Sie entfernen, wird zwar in der PivotTable-Liste nicht länger angezeigt, verbleibt jedoch in der Feldliste, so dass Sie es jederzeit wieder in die PivotTable-Liste aufnehmen können.


Hinzufügen eines neuen Zeilen- oder Spaltenfeldes

  1. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Feldliste [image].

  2. Verwenden Sie die Bildlaufleisten und die Felder Plusfeld und Minusfeld , um das Feld zu suchen, das Sie der PivotTable-Liste hinzufügen möchten.

  3. Klicken Sie auf das Feld.

  4. Führen Sie in der Liste in der unteren rechten Ecke der Feldliste eine der folgenden Aktionen aus:

    Wenn Sie ein neues Zeilenfeld hinzufügen möchten, klicken Sie auf Zeilenbereich.

    Wenn Sie ein neues Spaltenfeld hinzufügen möchten, klicken Sie auf Spaltenbereich.

  5. Klicken Sie auf Hinzufügen zu.

Anmerkung Falls Hinzufügen zu nicht verfügbar ist, wenn Sie Zeilenbereich oder Spaltenbereich wählen, steht das Feld, das Sie gewählt haben, möglicherweise nicht für die Verwendung als Zeilen- oder Spaltenfeld zur Verfügung, oder der Ersteller der PivotTable-Liste hat die Möglichkeit zum Verschieben von Felder in diese Bereiche beschränkt. Wenn Ihre PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste nicht unter Gesamtsummen aufgeführt werden, als Zeilen- und Spaltenfelder verwendet werden.


Hinzufügen eines neuen Datenfeldes

Standardmäßig wird für Datenfelder, mit denen numerische Daten zusammengefasst werden, die Zusammenfassungsfunktion "Summe" verwendet. Bei Datenfeldern, mit denen andere Datentypen zusammengefasst werden, wird die Zusammenfassungsfunktion "Anzahl" verwendet.

  1. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Feldliste [image].

  2. Verwenden Sie die Bildlaufleisten und die Felder Plusfeld und Minusfeld , um das Feld zu suchen, das Sie der PivotTable-Liste hinzufügen möchten.

  3. Klicken Sie auf das Feld, und klicken Sie dann in der Liste in der unteren rechten Ecke der Feldliste auf Datenbereich.

  4. Klicken Sie auf Hinzufügen zu.

Anmerkung Falls Hinzufügen zu nicht verfügbar ist, wenn Sie Datenbereich wählen, steht das Feld, das Sie gewählt haben, möglicherweise nicht für die Verwendung als Datenfeld zur Verfügung. Wenn Ihre PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste unter Gesamtsummen aufgeführt werden, als Datenfelder verwendet werden.


Hinzufügen eines neuen Filterfeldes

Wenn Sie ein Filterfeld hinzufügen, können Sie die gesamte PivotTable-Liste filtern, um Daten nur für das Element anzuzeigen, das Sie in der Dropdownliste Filterfeld ausgewählt haben.

  1. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Feldliste [image].

  2. Verwenden Sie die Bildlaufleisten und die Felder Plusfeld und Minusfeld , um das Feld zu suchen, das Sie der PivotTable-Liste hinzufügen möchten.

  3. Klicken Sie auf das Feld, und klicken Sie in der Liste in der unteren rechten Ecke der Feldliste auf Filterbereich.

  4. Klicken Sie auf Hinzufügen zu.

Anmerkung Falls Hinzufügen zu nicht verfügbar ist, wenn Sie Filterbereich wählen, steht das Feld, das Sie gewählt haben, möglicherweise nicht für die Verwendung als Filterfeld zur Verfügung, oder der Ersteller der PivotTable-Liste hat den Zugriff auf die Filterfunktionen beschränkt. Wenn Ihre PivotTable-Liste auf Quelldaten aus einer OLAP-Datenbank basiert, können nur die Felder, die in der Feldliste nicht unter Gesamtsummen aufgeführt werden, als Filterfelder verwendet werden.


Hinzufügen eines neuen Detailfeldes

  1. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Feldliste [image].

  2. Verwenden Sie die Bildlaufleisten und die Felder Plusfeld und Minusfeld , um das Feld zu suchen, das Sie der PivotTable-Liste hinzufügen möchten.

  3. Klicken Sie auf das Feld, und klicken Sie dann in der Liste in der unteren rechten Ecke der Feldliste auf Detaildaten.

  4. Klicken Sie auf Hinzufügen zu.

Anmerkung Falls Hinzufügen zu nicht verfügbar ist, wenn Sie Detaildaten wählen, hat der Ersteller der PivotTable-Liste den Zugriff auf die Detaildaten möglicherweise beschränkt, oder anhand der Quelldaten stehen keine Detaildaten zur Verfügung. Wenn Ihre PivotTable-Liste beispielsweise auf Quelldaten aus einer OLAP-Datenbank basiert, stehen oftmals nur zusammengefasste Daten an Stelle von Detaildaten zur Verfügung.


Entfernen eines Feldes

Wenn Sie ein Feld aus dem Layout einer PivotTable-Liste entfernen, werden die Daten dieses Feldes nicht mehr angezeigt, jedoch steht das Feld weiterhin in der Feldliste zur Verfügung, so dass Sie es der PivotTable-Liste wieder hinzufügen können.

  1. Klicken Sie auf die Feldbeschriftung des Feldes, das Sie aus der PivotTable-Liste entfernen möchten.

  2. Ziehen Sie das Feld aus der PivotTable-Liste heraus, bis sich der Mauszeiger in Zeiger mit rotem X ändert.

Anmerkung Wenn Sie ein Summenfeld sowohl aus der PivotTable-Liste als auch aus der Feldliste löschen möchten, klicken Sie mit der rechten Maustaste auf das Summenfeld und klicken dann im Kontextmenü auf Löschen.


Aktualisieren einer PivotTable-Liste mit aktualisierten Quelldaten

  1. Klicken Sie auf die PivotTable-Liste.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Aktualisieren [image].

Anmerkungen

  • Der Würfel mit dem Office-Logo Würfel mit Office-Logo hört auf, sich zu drehen, wenn die Aktualisierungsaktion abgeschlossen ist. Während die PivotTable-Liste aktualisiert wird, ist keine interaktive Nutzung möglich und es können keine Änderungen hieran vorgenommen werden. Sie können die Aktualisierungsaktion auch nicht abbrechen, während Daten abgerufen werden. Wenn Sie eine Aktualisierungsaktion abbrechen möchten, während die PivotTable-Liste berechnet wird, drücken Sie ESC.

  • So beheben Sie Probleme beim Aktualisieren einer PivotTable-Liste.


Abbrechen der Aktualisierung einer PivotTable-Liste

  • Drücken Sie ESC.

Anmerkungen

  • Sie können eine Aktualisierungsoperation nur dann abbrechen, wenn die PivotTable-Liste gerade berechnet wird. Werden Quelldaten abgerufen, können Sie den Vorgang nicht abbrechen.

  • Nachdem Sie das Aktualisieren einer PivotTable-Liste abgebrochen haben, werden vorübergehend keine Daten angezeigt. Um die Daten erneut anzuzeigen, klicken Sie in der Symbolleiste der PivotTable-Liste auf Aktualisieren [image] , oder führen Sie eine beliebige Aktion durch, mit der sich das Layout der PivotTable-Liste ändern lässt.

  • So beheben Sie Probleme beim Aktualisieren einer PivotTable-Liste.


Infos über das Verwenden einer PivotTable-Liste in Microsoft Excel oder Microsoft Word

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Exportieren in einen interaktiven Excel PivotTable-Bericht

Kopieren von Daten in ein anderes Programm zur nichtinteraktiven Verwendung

Exportieren in einen interaktiven Excel PivotTable-Bericht

Wenn Sie mit Excel PivotTable-Berichten vertraut sind und in dieser Form mit den Daten arbeiten möchten, können Sie die PivotTable-Liste nach Excel exportieren. (Bei einem PivotTable-Bericht handelt es sich um die Excel-Version einer PivotTable-Liste.) Der Excel PivotTable-Bericht wird mit denselben Quelldaten verbunden wie die ursprüngliche PivotTable-Liste. Daher stehen alle Felder und Daten der ursprünglichen PivotTable-Liste auch in Excel zur Verfügung, und der Bericht kann bei einer Änderung der Quelldaten aktualisiert werden.

Vorbereiten des Exports nach Excel Wenn der Excel PivotTable-Bericht der Darstellung der PivotTable-Liste im Web entsprechen soll, gehen Sie vor dem Exportieren in einen Excel PivotTable-Bericht folgendermaßen vor: Verschieben Sie alle Felder der PivotTable-Liste aus dem Detailbereich; für Elemente und Zellen blenden Sie die Details aus, so dass keine Detailbereiche angezeigt werden.

Nichtexportierte Merkmale von PivotTable-Listen In Excel PivotTable-Berichten ist die Anzeige von Detailfeldern nicht möglich. Alle Quelldaten sind jedoch weiterhin verfügbar, und sämtliche Detailfelder sind auf der Excel-Symbolleiste PivotTable aufgeführt. Informationen über das Anzeigen von Details für Zellen in Excel PivotTable-Berichten erhalten Sie in der Hilfe zu Excel.

Wenn Sie einen auswahlbasierten Filter verwenden, werden die Filtereinstellungen für einige Quelldatentypen nicht exportiert. Weiterhin werden Filtereinstellungen für nicht angezeigte Felder nicht exportiert. Sie können jedoch in Excel erneut Filter für diese Felder setzen.

Zurück zum Anfang

Kopieren von Daten in ein anderes Programm zur nichtinteraktiven Verwendung

Kopieren nach Microsoft Word oder Excel Wenn Sie einen Snapshot der aktuell in einer PivotTable-Liste angezeigten Daten bearbeiten möchten, können Sie die Daten kopieren und anschließend in Word oder Excel einfügen. Wenn Sie die gesamte PivotTable-Liste in ein anderes Programm kopieren oder ausgewählte Datenbereiche kopieren werden der Text und die Werte der PivotTable-Liste zum Bestandteil des Word-Dokuments oder der Excel-Arbeitsmappe. Zwischen den ursprünglichen Quelldaten der PivotTable-Liste und der Kopie in dem Dokument oder der Arbeitsmappe wird keine Verbindung erstellt. Daher ist eine Aktualisierung der nach Word oder Excel kopierten Daten nicht möglich.

In andere Programme kopieren In einer PivotTable-Liste angezeigte Daten können auch in ein anderes Programm kopiert werden, das das durch PivotTable-Listen verwendete HTML-Format unterstützt: z. B. Microsoft FrontPage und Microsoft Access. Wenn Sie Daten in ein Programm kopieren, das dieses Format nicht unterstützt, werden die Daten als unformatierter Text kopiert.

Zurück zum Anfang


Kopieren einer gesamten PivotTable-Liste nach Microsoft Excel oder Microsoft Word

Verwenden Sie dieses Verfahren, wenn Sie eine PivotTable-Liste kopieren und in eine nicht interaktiv nutzbare, formatierte Tabelle in Excel oder Word einfügen möchten. Zum Kopieren einer Liste als interaktiv nutzbarem Excel-PivotTable-Bericht exportieren Sie die PivotTable-Liste nach Excel.

  1. Markieren Sie die gesamte PivotTable-Liste, indem Sie auf die Titelleiste klicken.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Kopieren [image].

  3. Wechseln Sie zu Excel oder Word, und klicken Sie an die Position, an der die Daten aus der PivotTable-Liste angezeigt werden sollen.

  4. Klicken Sie auf Einfügen [image].

Anmerkungen

  • Wenn Sie eine PivotTable-Liste kopieren, kopieren Sie lediglich die Formatanweisungen und die Datenwerte. Zwischen der Kopie in Word oder Excel und der originalen Quelldatenbank wird keine Verknüpfung aufrechterhalten. Die Kopie in Word oder Excel ist nicht interaktiv nutzbar und kann nicht aktualisiert werden.

  • Sie können auch einen Teil einer PivotTable-Liste nach Word oder Excel kopieren.


Kopieren eines Teils einer PivotTable-Liste nach Microsoft Excel oder Microsoft Word

Verwenden Sie dieses Verfahren, wenn Sie ausgewählte Werte in einer PivotTable-Liste kopieren und als nicht interaktiv nutzbare, formatierte Tabelle in Excel oder Word einfügen möchten. Zum Kopieren der Daten als interaktiv nutzbaren Excel-PivotTable-Bericht exportieren Sie die PivotTable-Liste nach Excel.

  1. Markieren Sie den Teil der PivotTable-Liste, den Sie kopieren möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Kopieren [image].

  3. Wechseln Sie zu Excel oder Word, und klicken Sie an die Position, an der die Daten aus der PivotTable-Liste angezeigt werden sollen.

  4. Klicken Sie auf Einfügen [image].

Anmerkungen

  • Wenn Sie einen Teil einer PivotTable-Liste kopieren, kopieren Sie lediglich die Formatanweisungen und die Werte. Zwischen der Kopie in Word oder Excel und der originalen Quelldatenbank wird keine Verknüpfung aufrechterhalten. Die Kopie in Word oder Excel ist nicht interaktiv nutzbar und kann nicht aktualisiert werden.

  • Sie können auch Teile einer PivotTable-Liste als unformatierten Text in andere Programme wie beispielsweise Microsoft Access kopieren.

  • Sie können auch eine gesamte PivotTable-Liste nach Word oder Excel kopieren.


Exportieren einer PivotTable-Liste im Web nach Microsoft Excel

Verwenden Sie dieses Verfahren, um eine im Web befindliche PivotTable-Liste als interaktiv nutzbaren PivotTable-Bericht nach Excel zu exportieren. Die Verknüpfung zwischen dem Excel-PivotTable-Bericht und der ursprünglichen Herkunftsdatenbank wird beibehalten.

Um ein optimales Ergebnis zu erzielen, verschieben Sie alle Felder aus dem Detailbereich, und blenden Sie Details für Elemente und Zellen aus, bevor Sie die Liste nach Excel exportieren.

  1. Klicken Sie auf die PivotTable-Liste.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Nach Excel exportieren [image], um dies durchzuführen oder wechseln Sie zu Excel, um die Daten in einem PivotTable-Bericht anzuzeigen.

Anmerkung Da in PivotTable-Berichten in Excel einige Layouts und Berechnungen von PivotTable-Listen nicht angezeigt werden können, unterscheidet sich das Aussehen des PivotTable-Berichts möglicherweise von dem der PivotTable-Liste im Web. Alle in der Feldliste im Web verfügbaren Felder und Daten, also auch die Felder, die sich nicht im Layout der PivotTable-Liste befinden, stehen für die Aufnahme im Excel-PivotTable-Bericht zur Verfügung. Allerdings werden im Bericht keine Detailfelder angezeigt, und in einigen Feldern werden möglicherweise nicht die gleichen Werte berechnet. Informationen über das Arbeiten mit Excel-PivotTable-Berichten und das Hinzufügen von Feldern finden Sie in der Excel-Hilfe.


Info über das Formatieren einer PivotTable-Liste zum Verbessern des Erscheinungsbildes oder der Lesbarkeit

Wenn Microsoft Internet Explorer, Version 4.01 oder höher, auf Ihrem Computer installiert ist, werden Formatänderungen beibehalten, wenn Sie im Verlauf der Browsersitzung die PivotTable-Liste verlassen und hierher zurückkehren. Wenn Sie Internet Explorer jedoch beenden, dann erneut öffnen und zur PivotTable-Liste zurückkehren, sind Ihre Änderungen verschwunden.

Ausblenden von Dropbereichen Dropbereiche sind die umrahmten Textfelder wie beispielsweise "Filterfelder hierher ziehen", die Sie verwenden, um Änderungen am Layout vorzunehmen. Wenn Sie z. B. eine PivotTable-Liste drucken möchten, ohne den Text im Dropbereich ebenfalls auszugeben, können Sie Dropbereiche ausblenden. Wenn Sie die Dropbereiche ausblenden, werden alle Dropbereiche, die keine Felder enthalten, aus der Ansicht entfernt. Wenn eine PivotTable-Liste beispielsweise nicht über Filterfelder verfügt, wird der Dropbereich für Filterfelder ausgeblendet.

Formatieren ähnlicher Elemente Formate, die Sie einem Element zuweisen, können Auswirkungen auf ähnliche Elemente haben. Wenn Sie beispielsweise die Textfarbe für eine Gesamtsumme ändern, werden alle Gesamtsummen in der PivotTable-Liste mit der neuen Textfarbe formatiert. Wenn Sie ein Element von einem Bereich in einen anderen verschieben, wenn Sie also beispielsweise ein Detailfeld in den Zeilenbereich verschieben, übernimmt das verschobene Element jegliche Formatierung, die dem neuen Bereich im Vorfeld zugewiesen wurde. So markieren Sie Elemente einer PivotTable-Liste zwecks Formatierung.

Festlegen von Textformaten Sie können die Schriftart, den Schriftgrad sowie die Farbe für Text festlegen, und Sie können Text fett, unterstrichen oder kursiv formatieren. Diese Einstellungen sind getrennt von den Einstellungen Ihres Browsers für Schriftarten und Farben zu sehen, da diese auf PivotTable-Listen keinen Einfluss haben. So legen Sie Textformate fest.

Ausrichten von Text in einer Zelle Sie können Werte in Zellen linksbündig, rechtsbündig oder horizontal zentriert ausgerichtet anzeigen. Die vertikale Ausrichtung eines Wertes können Sie jedoch nicht ändern. So richten Sie Text in einer Zelle aus. Sie können auch Teilergebnisse und Gesamtergebnisse relativ zu Detaildaten ausrichten.

Festlegen von Hintergrundfarben Sie können die Hintergrundfarbe von Zellen ändern. Diese Einstellungen sind separat von den Einstellungen Ihres Browsers für Farben zu sehen, da diese keinen Einfluss auf PivotTable-Listen haben.

Ändern von Zahlenformaten Sie können die Formate, in denen Zahlen, Datums- und Zeitangaben in einem Feld angezeigt werden, in eines der verschiedenen vordefinierten Zahlenformate ändern. Beispielsweise können Sie eine Zahl als Währung oder als Prozentwert anzeigen, und Sie können ein Datum im langen Format anzeigen, wobei Tag und Monat ausgeschrieben werden, oder Sie können das abgekürzte Format wählen. Mit Änderungen am Zahlenformat werden die eigentlichen Werte jedoch nicht geändert, sondern nur die Art und Weise, wie die Werte angezeigt werden. So ändern Sie Zahlenformate.

Wenn Sie weitere Formatierungsoptionen wünschen Für mehr Steuerungsmöglichkeiten über die Art der Formatierung, wie beispielsweise weitere Optionen zur Textausrichtung, benutzerdefinierte Zahlenformate und Druckformatoptionen exportieren Sie die PivotTable-Liste nach Microsoft Excel. In Excel wird die PivotTable-Liste zu einem PivotTable-Bericht, den Sie formatieren, für den Druck einrichten und in einer Arbeitsmappendatei speichern können. Weitere Informationen über das Arbeiten mit PivotTable-Berichten finden Sie in der Excel-Hilfe.


Markieren der Elemente einer PivotTable-Liste

Im Feld Auswahl in der Kategorie Standard der PivotTable-Eigenschaftentoolbox wird angegeben, welches Element der PivotTable-Liste aktuell markiert ist. Zum Anzeigen der Toolbox klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image] . So identifizieren Sie die Elemente einer PivotTable-Liste.

Mehrfachmarkierung Sie können nicht mehr als eine Instanz eines Elements gleichzeitig markieren. Beispielsweise können Sie nicht mehr als ein Feld gleichzeitig markieren. In den meisten Fällen jedoch gilt das Format, das Sie einem Element zuweisen, für alle Elemente des gleichen Typs in der PivotTable-Liste, wie in der folgenden Tabelle beschrieben.

Zu markierendes Element Verfahren
Die gesamte PivotTable-Liste Klicken Sie auf die Titelleiste.

Wenn die PivotTable-Liste nicht über eine Titelleiste verfügt, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Klicken Sie auf die Ein-/Ausblenden-Leiste, und klicken Sie anschließend auf Titelleiste [image].

Wenn der Befehl Eigenschaftentoolbox im Kontextmenü nicht verfügbar ist, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff hierauf möglicherweise beschränkt.
Datenzellen Klicken Sie auf die gewünschte Zelle, um sie zu markieren. Ziehen Sie den Mauszeiger über eine Gruppe von Zellen, um sie zu markieren.

Einzelne Datenzellen können Sie nicht formatieren.
Zeilen-, Spalten- oder Filterfeld Klicken Sie auf die Feldbeschriftung.

Mit dem Markieren eines Zeilen- oder Spaltenfeldes werden auch alle Datenelemente in diesem Feld markiert.

Formate, die Sie einen Feld zuweisen, gelten auch für alle Zeilen-, Spalten- und Filterfeldbeschriftungen in der PivotTable-Liste.
Detailfeld Klicken Sie auf die Feldbeschriftung.

Wenn für verschiedene Elemente Detaildaten angezeigt werden, so dass die Feldbeschriftung mehr als einmal angezeigt wird, werden mit dem Klicken auf eine Instanz der Feldbeschriftung alle Instanzen markiert.

Formate, die Sie einem Detailfeld zuweisen, gelten nur für die Datenzellen dieses individuellen Feldes.
Summenfeld Klicken Sie auf eine beliebige Feldbeschriftung des Summenfeldes.

Zum Anzeigen der Feldbeschriftungen von Summenfeldern müssen Sie wenigstens ein Feld in den Zeilen- oder Spaltenbereich verschieben, und Sie müssen möglicherweise die Details für diese Felder ausblenden.

Formate, die Sie einem Summenfeld zuweisen, gelten für alle Summenfelder in der PivotTable-Liste und gelten darüber hinaus nur für die Datenzellen des Feldes. Zum Formatieren der Feldbeschriftungen von Summenfeldern markieren Sie ein Datenelement in einem Zeilen- oder Spaltenfeld.

Ein Beispiel für ein Summenfeld anzeigen.
Datenelement in einem Feld Klicken Sie auf die Elementbeschriftung, und achten Sie hierbei darauf, nicht auf die Anzeige Plusfeld oder Minusfeld zu klicken, sofern das Element solche aufweist.

Mit dem Markieren eines Elements werden auch alle Daten für dieses Element markiert.

Formate, die Sie einem Element zuweisen, gelten für alle Elementbeschriftungen, Detailfeldbeschriftungen, Teilergebnisbeschriftungen, Gesamtergebnisbeschriftungen und Summenfeldbeschriftungen in der PivotTable-Liste.
Teilergebnis oder Gesamtergebnis Klicken Sie auf das Teilergebnis oder das Gesamtergebnis.

Mit dem Markieren eines Teilergebnisses oder eines Gesamtergebnisses werden auch alle Daten markiert, auf denen das Teilergebnis oder das Gesamtergebnis basiert.

Formate, die Sie einem Teilergebnis oder einem Gesamtergebnis zuweisen, gelten für alle Datenzellen der Teilergebnisse oder Gesamtergebnisse in dem Zeilen- oder Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden. Wenn Sie die Teilergebnis- oder Gesamtergebnisbeschriftung formatieren möchten, markieren Sie ein Datenelement in einem Zeilen- oder Spaltenfeld.

Ein Beispiel für Teilergebnisse und Gesamtergebnisse anzeigen.


Festlegen der Schriftart und des Schriftstils für Daten

Sie können die Schriftart und den Schriftstil nicht mit einer einzigen Operation für die gesamte PivotTable-Liste festlegen. In den meisten Fällen jedoch gelten Formate, die Sie einem Element zuweisen, für alle Elemente des gleichen Typs.

Zum Festlegen der Schriftart und des Schriftstils für die gesamte PivotTable-Liste markieren und formatieren Sie das Zeilen-, Spalten- oder Filterfeld, das Datenelement in einem Zeilen- oder Spaltenfeld und das Summenfeld jeweils einzeln. Für jedes Zeilen- oder Spaltenfeld, für das Teilergebnisse oder Gesamtergebnisse anzeigt werden, formatieren Sie das Gesamtergebnis oder das Teilergebnis. Wenn in Ihrer PivotTable-Liste Detailfelder angezeigt werden können, formatieren Sie auch jedes Detailfeld einzeln.

  1. Markieren Sie das Element, das Sie formatieren möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image] .

  3. Wenn die Kategorie Format nicht erweitert ist, klicken Sie auf die Format-Leiste.

  4. Klicken Sie auf die gewünschten Formatoptionen.

    Wenn Sie Text fett formatieren möchten, klicken Sie auf Fett [image].

    Wenn Sie Text kursiv formatieren möchten, klicken Sie auf Kursiv [image].

    Wenn Sie Text unterstreichen möchten, klicken Sie auf Unterstreichen [image].

    Wenn Sie die Textfarbe ändern möchten, klicken Sie auf den Pfeil neben Schriftfarbe [image], und klicken Sie dann auf die gewünschte Farbe.

    Wenn die Schriftart ändern möchten, klicken Sie in der Liste Schriftart auf die gewünschte Schriftart.

    Wenn Sie den Schriftgrad ändern möchten, klicken Sie in der Liste Schriftgrad auf die gewünschte Größe.

Anmerkungen

  • Wenn Sie als Hintergrundfarbe die gleiche wie die für den Text wählen, ist dieser nicht mehr sichtbar.

  • Die in den Listen verfügbaren Schriftarten und Schriftgrade sind abhängig von den Schriften, die auf Ihrem System installiert sind.


Ausrichten von Text innerhalb einer Zelle

Sie können die Textausrichtung für eine gesamte PivotTable-Liste nicht mit einer einzigen Operation festlegen. In den meisten Fällen jedoch gilt die Ausrichtung, die Sie für ein Element festlegen, für alle Elemente des gleichen Typs.

Zum Festlegen der Textausrichtung für alle Elemente in der gesamten PivotTable-Liste, für die die Ausrichtung geändert werden kann, markieren Sie das jeweilige Element in einem Zeilen- oder Spaltenfeld oder in einem Summenfeld und ändern jeweils die Ausrichtung des einzelnen Elements. Wenn in Ihrer PivotTable-Liste Detailfelder angezeigt werden können, richten Sie den Text für jedes Detailfeld individuell aus. Die horizontale Ausrichtung von Zeilen-, Spalten- oder Filterfeldbeschriftungen können Sie nicht ändern.

  1. Wählen Sie das Element aus, das Sie ändern möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Format nicht angezeigt wird, klicken Sie auf die Format-Leiste.

  4. Klicken Sie im Feld Horizontale Ausrichtung auf die gewünschte Ausrichtung: Links, Zentriert, Rechts oder Automatisch. Mit dem Format Automatisch werden Zahlen und Datumsangaben rechts- und Text linksbündig ausgerichtet angezeigt.

Anmerkung Sie können Teilergebnisse und Gesamtergebnisse auch relativ zu Detaildaten ausrichten.


Festlegen von Hintergrundfarben für Zellen

Sie können die Hintergrundfarben nicht für alle Elemente einer PivotTable-Liste in einer Operation festlegen. In den meisten Fällen jedoch gelten Farben, die Sie für ein Element festgelegt haben, für alle Elemente des gleichen Typs. Beispielsweise sind Zeilen-, Spalten- und Filterfelder vom gleichen Typ. Wenn Sie also die Farbe für die Filterfeldbeschriftung festlegen, wird Zeilen- und Spaltenfeldern die gleiche Farbe zugewiesen.

Um die Hintergrundfarben für alle Elemente in der PivotTable-Liste festzulegen, wählen Sie einzeln die Hintergrundfarben für die gesamte PivotTable-Liste aus, also für ein Zeilen-, Spalten- und Filterfeld, für ein Datenelement in einem Zeilen- oder Spaltenfeld und für ein Summenfeld. Für jedes Zeilen- oder Spaltenfeld, für das Teilergebnisse und Gesamtergebnisse angezeigt werden, legen Sie die Hintergrundfarbe für das Gesamtergebniss oder das Teilergebnis fest. Wenn in Ihrer PivotTable-Liste Detailfelder angezeigt werden können, legen Sie die Hintergrundfarbe für jedes Detailfeld einzeln fest. Die Hintergrundfarbe der Dropbereiche können Sie jedoch nicht ändern.

  1. Markieren Sie das Element, das Sie ändern möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Format nicht angezeigt wird, klicken Sie auf die Format-Leiste.

  4. Klicken Sie auf den Pfeil neben Hintergrundfarbe [image], und klicken Sie dann auf die gewünschte Farbe.

Anmerkung Wenn Sie als Hintergrundfarbe die gleiche wie die für Text wählen, ist dieser nicht mehr sichtbar.


Ändern von Beschriftungen und Namen

Sie können den Titel der PivotTable-Liste, die Feldnamen, die Namen von Elementen in Feldern und die Namen von Summenfeldern ändern. Diese Änderungen haben keine Auswirkungen auf die Quelldaten.

  1. Markieren Sie die Beschriftung oder den Namen, die bzw. den Sie ändern möchten.

    Wie wird's gemacht?

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  3. Wenn die Kategorie Beschriftungen nicht erweitert ist, klicken Sie auf die Beschriftungen-Leiste.

  4. Geben Sie im Feld Beschriftungen den neuen Namen ein.

Anmerkung Wenn Sie den Text der Titelleiste ändern möchten, klicken Sie auf die Titelleiste, und geben Sie dann den neuen Titel in das Feld PivotTable-Titel in der Kategorie Format der Toolbox ein.


Ändern der Spaltenbreite

  1. Zeigen Sie auf die rechte Begrenzung der Feldbeschriftung, bis sich der Mauszeiger in Zeiger mit vertikalem Doppelpfeil ändert.

  2. Sie haben nun folgende Möglichkeiten:

    Ziehen Sie die Spaltenbegrenzung, bis die Spalte die gewünschte Breite hat.

    Wenn Sie die Spaltenbreite an die Länge der Einträge anpassen möchten, doppelklicken Sie auf die Spaltenbegrenzung.


Ändern der Zahlenformate

Sie können die Zahlenformate in Detail- und Summenfeldern ändern. Wenn sich das Feld, für das Sie das Zahlenformat ändern möchten, im Zeilen-, Spalten- oder Filterbereich befindet und wenn das Verschieben von Feldern in den Detailbereich in Ihrer PivotTable-Liste zulässig ist, können Sie das Feld vorübergehend in den Detailbereich verschieben, das Format ändern und das Feld anschließend wieder zurücksetzen.

  1. Klicken Sie auf das Detailfeld oder das Summenfeld, für das Sie das Zahlenformat ändern möchten.

  2. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image] .

  3. Wenn die Kategorie Format nicht erweitert ist, klicken Sie auf die Format-Leiste.

  4. Wählen Sie das gewünschte Zahlenformat in der Liste Zahlenformat aus.

    Weitere Informationen über die verfügbaren Zahlenformate .


Zahlenformate

Wie Zahlen-, Währungs-, Datums- und Zeitformate angezeigt werden, wird von den Einstellungen im Dialogfeld Eigenschaften von Ländereinstellungen in der Windows Systemsteuerung festgelegt. Beispielsweise legen Sie mit diesen Einstellungen fest, ob Jahreszahlen zwei- oder vierstellig angezeigt werden. Informationen über diese Formate finden Sie in der Windows-Hilfe.

Die Person, die die PivotTable-Liste erstellt hat, hat den Daten möglicherweise benutzerdefinierte Zahlenformate zugewiesen. Im Browser können Sie keine benutzerdefinierten Zahlenformate erstellen. Die folgenden Zahlenformate stehen über die Liste Zahlenformat in der Kategorie Format der PivotTable-Eigenschaftentoolbox zur Verfügung.

Format | Darstellungsweise
Allgemeine Zahl | Zeigt eine Zahl rechtsbündig ausgerichtet und ohne 1.000er-Trennzeichen an; negativen Zahlen wird ein Minuszeichen vorangestellt. Zeigt bis zu 11 Stellen bzw. 10 Stellen mit Dezimaltrennzeichen an, wobei weitere Stellen rechts des Dezimaltrennzeichens gerundet werden. Zeigt Zahlen mit mehr als 11 Stellen links des Dezimaltrennzeichens im Format "Wissenschaft" an. Text wird linksbündig ausgerichtet angezeigt.
Standarddatum | Zeigt eine Zahl als Datum mit optionaler Uhrzeit an. Beispiel: 31.8.99 05:54. Die Nachkommastellen der Zahl sind die Uhrzeit. Wenn die Zahl keine Nachkommastellen besitzt, erscheint nur das Datum. Wenn die Zahl nur Nachkommastellen aufweist, wird lediglich die Zeit angezeigt.
Datum, lang | Zeigt ein Datum entsprechend den Vorgaben unter Langes Datumsformat in den Windows-Ländereinstellungen an. Beispiel: Donnerstag, 25. Januar, 2001.
Datum, mittel | Zeigt ein Datum entsprechend den Vorgaben unter Datumstrennzeichen in den Windows-Ländereinstellungen sowie eine zweistellige Jahreszahl an. Beispiel: 25. Jan. 01.
Datum, kurz | Zeigt ein Datum entsprechend den Vorgaben unter Kurzes Datumsformat in den Windows-Ländereinstellungen an. Beispiel: 25.1.01.
Zeit, lang | Zeigt die Uhrzeit entsprechend den Vorgaben unter Zeitformat der Windows-Ländereinstellungen an. Beispiel: 20:45:36.
Zeit, mittel | Zeigt die Uhrzeit im 12-Stunden-Format mit dem Zusatz AM oder PM an, wobei die Sekunden weggelassen werden. Beispiel: 8:45 PM.
Zeit, kurz | Zeigt die Uhrzeit im 24-Stunden-Format an, wobei die Sekunden weggelassen werden. Beispiel: 20:45.
Währung | Zeigt eine Zahl entsprechend den Vorgaben auf der Registerkarte Währung der Windows-Ländereinstellungen an, ggf. mit 1.000er-Trennzeichen und zwei Dezimalstellen. Beispiel mit den Standardeinstellungen Englisch (USA): $2,532.75.
Eurowährung | Zeigt eine Zahl in der Währung Euro an, mit 1.000er-Trennzeichen und zwei Dezimalstellen. Das Euro-Symbol wird in Abhängigkeit von den Ländereinstellungen in der Windows-Systemsteuerung vor oder hinter die Zahl gesetzt. Beispiel mit den Standardländereinstellungen für Deutschland: 12,35 [image] .
Festkommazahl | Zeigt eine Zahl mit zwei Dezimalstellen an. Beispiel: 68,30.
Standardzahl | Zeigt eine Zahl mit 1.000er-Trennzeichen und zwei Stellen rechts des Dezimaltrennzeichens an. Welches Zeichen als 1.000er-Trennzeichen verwendet wird, ist in den Windows-Ländereinstellungen festgelegt. Beispiel mit einem Punkt als 1.000er-Trennzeichen: 1.800,00.
Prozent | Zeigt eine Zahl multipliziert mit 100, mit zwei Dezimalstellen und einem Prozentzeichen an. Beispielsweise wird der Wert 0,8914 als 89,14% angezeigt.
Wissenschaft | Zeigt eine Zahl in Exponentialschreibweise an. Beispiel: 1,25E+10.
Ja/Nein | Zeigt "Nein" an, wenn eine Zahl gleich 0 ist; für jede andere Zahl wird "Ja" angezeigt.
Wahr/Falsch | Zeigt "Falsch" an, wenn eine Zahl gleich 0 ist; für jede andere Zahl wird "Wahr" angezeigt.
Ein/Aus | Zeigt "Aus" an, wenn eine Zahl gleich 0 ist; für jede andere Zahl wird "Ein" angezeigt .


Ausblenden der Dropbereiche

Wenn die Dropbereiche ausgeblendet sind und die PivotTable-Liste nicht bereits über Zeilen-, Spalten-, Daten- oder Filterfelder verfügt, können Sie keine Felder in diese Bereiche ziehen. Allerdings können Sie noch immer Felder hinzufügen oder verschieben, indem Sie die Schaltflächen in der Symbolleiste der PivotTable-Liste verwenden.

  1. Klicken Sie in der Symbolleiste der PivotTable-Liste auf Eigenschaftentoolbox [image].

  2. Wenn die Kategorie Ein-/Ausblenden nicht eingeblendet ist, klicken Sie auf die Ein-/Ausblenden-Leiste.

  3. Klicken Sie auf Dropbereiche [image] , so dass die Schaltfläche nicht gedrückt ist.


Problembehandlung bei PivotTable-Listen

Wobei benötigen Sie Hilfe?

Aktualisieren

Die Daten in der PivotTable-Liste können nicht anhand der Quelle aktualisiert werden.

Wenn eine PivotTable-Liste aktualisiert wird, werden andere PivotTable-Listen auf der Webseite ebenfalls geändert.

Die Abfrage in einer PivotTable-Liste ist fehlgeschlagen.

Filtern und Sortieren

Die Filterbefehle können nicht ausgeführt werden.

Die Daten können nicht auf die gewünschte Weise gefiltert werden.

Die in einem Feld enthaltenen Daten werden nicht korrekt sortiert.

Verschieben von Feldern

Die Befehle zum Verschieben von Feldern können nicht ausgeführt werden.

Das gewünschte Feld kann nicht hinzugefügt oder verschoben werden.

Wenn das Layout geändert wird, benötigt die Anzeige der Daten viel Zeit.

Die PivotTable-Eigenschaftentoolbox oder die Feldliste werden nicht mehr angezeigt.

Daten

Die gewünschten Daten können nicht ausgewählt werden.

Die Detaildaten können nicht angezeigt werden.

Die Daten sind schlecht lesbar.

Wenn auf der Seite ein Bildlauf nach unten durchgeführt wird, wird die getroffene Auswahl nicht angezeigt.

Die Felder werden angezeigt, die Daten jedoch nicht.

Beim Drucken einer PivotTable-Liste werden die Daten nicht gedruckt.

Nach dem Kopieren einer PivotTable-Liste in Microsoft Excel oder Word werden keine Daten mehr angezeigt.

Anstelle einer Zahl wird in einer Zelle ##### angezeigt.

Ein auf einer PivotTable-Liste basierendes Diagramm ist leer oder enthält keine Daten.

Wenn Sie in Ihrem Webbrowser auf die Schaltfläche Bearbeiten klicken, wird Ihre Webseite im falschen Programm geöffnet.

Warum werden neben den Gesamtsummen in der PivotTable-Liste Sternchen angezeigt?


In einer Zelle wird ##### an Stelle einer Zahl angezeigt.

Wenn eine Zahl zu groß ist, um in eine Zelle zu passen, werden in der PivotTable-Liste Rauten (#) an Stelle der Zahl angezeigt. Sie können dies mit einer der folgenden Methoden beheben:

  • Sie können die Spalte verbreitern, so dass die gesamte Zahl angezeigt werden kann.

  • Sie können eine kleinere Schriftart wählen, wenn Sie die Spaltenbreite nicht ändern möchten.

  • Sie können das Zahlenformat ändern und eines auswählen, das weniger Platz beansprucht.


Ein auf einer PivotTable-Liste basierendes Diagramm ist leer oder enthält keine Daten

Hinzufügen von Gesamtsummenfeldern Damit die Daten einer PivotTable-Liste in einem Diagramm angezeigt werden können, müssen Sie der PivotTable-Liste mindestens ein Gesamtsummenfeld hinzufügen.

Verschieben von Feldern in die Zeilen- und Spaltenbereiche Die Kategoriedaten und die Datenreihen des Diagramms werden anhand der Zeilen- und Spaltenfelder einer PivotTable-Liste erstellt. Wenn sich z. B. alle angezeigten Felder im Detailbereich befinden, können in dem Diagramm keine Kategorien und Reihen gezeichnet werden. Verschieben Sie mindestens ein Feld aus dem Detailbereich oder der Feldliste in den Zeilen- oder Spaltenbereich.


Beim Klicken auf die Schaltfläche "Bearbeiten" im Webbrowser wird die Webseite im falschen Programm geöffnet

Welche Programme im Webbrowser über die Schaltfläche Bearbeiten verfügbar sind, ist abhängig davon, wie die Seite veröffentlicht wurde.

Wird im Webbrowser beim Klicken auf die Schaltfläche Bearbeiten ein Programm geöffnet, das Sie nicht verwenden möchten, beenden Sie das Programm. Starten Sie dann das gewünschte Programm, und öffnen Sie die Webseite in diesem Programm.


Die Daten in einem Feld wurden nicht korrekt sortiert.

Möglicherweise fehlen bei einem Dimensionsfeld Ebenen Wenn Sie ein Feld in einer PivotTable-Liste sortieren, das auf Datenquellen aus einer OLAP-Datenbank basiert, werden die aktuelle und alle niedrigeren Ebenen sortiert. Mit den höheren Ebenen wird festgelegt, welche auf niedrigeren Ebenen befindliche Elemente zusammen sortiert werden. Wenn in einer Dimension eine oder mehrere Ebenen beim Sortieren von Daten in einem Feld auf der niedrigeren Ebene ausgeblendet wurden, werden die Daten so sortiert, als wären die fehlenden Ebenen vorhanden.

Wenn ein Dimensionsfeld beispielsweise die Ebenen "Land", "Region" und "Stadt" umfasst, die Ebene "Region" in der PivotTable-Liste jedoch nicht angezeigt wird, wenn Sie Elemente im Feld "Stadt" sortieren, werden die Elemente im Feld "Stadt" für jede Region separat sortiert, auch wenn die Daten für "Region" nicht angezeigt werden. Dementsprechend werden, wenn "Land" über die Regionen "Nord" und "Süd" verfügt, die Elemente für "Stadt" für die nördliche Region und die Elemente für "Stadt" für die südliche Region jeweils gemeinsam sortiert. Bei der Sortierung werden nicht alle Elemente für "Stadt" des Landes zusammengeführt, auch wenn es bei ausgeblendeter Ebene "Region" den Anschein hat, dass die Elemente für "Stadt" hätten zusammengeführt werden müssen.

Schließen Sie vor dem Sortieren alle Ebenen ein Wenn Sie verstehen möchten, wie die Daten sortiert werden, entfernen Sie alle Ebenen für die Dimension, fügen Sie das Dimensionsfeld wieder in die PivotTable-Liste ein, und zeigen Sie dann die Ebenen erneut an, so dass überhalb der Ebene, die Sie sortieren möchten, keine Ebenen fehlen.


Nach dem Kopieren einer PivotTable-Liste nach Excel oder Word fehlen Daten.

Wenn Sie Daten einer PivotTable-Liste in die Zwischenablage kopieren und dann in Microsoft Excel oder Microsoft Word einfügen, werden nur die sichtbaren Zeilen und Spalten kopiert. Alle Daten, die Sie ausgeblendet oder herausgefiltert haben, werden nicht kopiert.

Kopieren aller Daten Vor dem Kopieren sollten Sie die Filterung deaktivieren, um alle Daten in der PivotTable-Liste anzuzeigen, und Sie sollten den Detailbereich anzeigen, den Sie kopieren möchten.

Exportieren nach Microsoft Excel Um ein vorheriges Anzeigen aller Daten zu umgehen, können Sie die PivotTable-Liste nach Excel exportieren, anstatt sie zu kopieren. Wenn Sie eine Kopie der PivotTable-Liste nach Excel exportieren, werden automatisch alle Daten miteinbezogen, wobei die gleichen Filtereinstellungen wirksam bleiben. Sie haben den gleichen Zugriff auf zusätzliche Felder in den Quelldaten wie bei einer PivotTable-Liste, und Sie können die Filtereinstellungen in Excel ändern. Von Excel aus können Sie dann die Daten nach Word oder in eine andere Anwendung kopieren. Informationen hierzu finden Sie in der Excel-Hilfe.


Beim Drucken einer PivotTable-Liste fehlen Daten.

Vergewissern Sie sich, dass keine Daten ausgeblendet wurden Wenn Sie Daten drucken möchten, die mit Hilfe eines Filters ausgeblendet wurden, zeigen Sie die Daten an, bevor Sie drucken. Zum Drucken von Detaildaten zeigen Sie Details an, bevor Sie drucken.

Prüfen Sie, ob die PivotTable-Liste in einem festgelegten Bereich angezeigt wird PivotTable-Listen können, abhängig von der Art und Weise, wie der Ersteller die Liste gestaltet hat, auf der Webseite vergrößert oder verkleinert werden, um nur so viel Platz in Anspruch zu nehmen, wie für die Anzeige der Daten benötigt wird, oder sie können in einem Bereich mit einer festgelegten Größe angezeigt werden. Wenn die PivotTable-Liste in einem festgelegten Bereich angezeigt wird, werden nur die aktuell angezeigten Daten gedruckt.

Führen Sie einen Bildlauf durch die gesamte PivotTable-Liste durch Wenn Sie eine PivotTable-Liste drucken, die der Menge der anzuzeigenden Daten entsprechend vergrößert und verkleinert wird, werden nur die Daten gedruckt, zu denen Sie im Verlauf der aktuellen Browsersitzung einen Bildlauf durchgeführt haben. Verwenden Sie also die Bildlaufleisten, um zum Anfang und zum Ende der PivotTable-Liste zu wechseln, bevor Sie die Webseite drucken.

Drucken Sie die PivotTable-Liste aus Microsoft Excel Wenn Sie mehr Steuerungsmöglichkeiten über die Druckausgabe der Daten benötigen, wie beispielsweise die Fähigkeit zum Drucken aller Daten in einer langen Liste und zum Festlegen von Seitenumbrüchen, können Sie eine Kopie der PivotTable-Liste nach Excel exportieren. Informationen über das Drucken von Excel aus finden Sie in der Excel-Hilfe.


Sie können das gewünschte Feld nicht hinzufügen oder verschieben.

Das Feld wird möglicherweise bereits angezeigt Sie können das gleiche Feld nicht in mehr als einem Bereich anzeigen. Näheres zum Ändern des Layouts einer PivotTable-Liste erfahren.

Die Einsatzbreite von Feldern wird möglicherweise durch die Datenquellen begrenzt Datenquellen aus OLAP (On-Line Analytical Processing)-Datenbanken stellen für verschiedene Detailebenen Feldgruppen bereit. Innerhalb einer Feldgruppe können Sie Detailebenen ausblenden, jedoch können Sie aus diesen Feldgruppen keine Felder herausnehmen, um diese in anderen Bereichen anzuzeigen. Wenn Sie herausfinden möchten, ob die Datenquellen einer PivotTable-Liste auf einer OLAP-Datenbank basieren, wenden Sie sich an den Ersteller der PivotTable-Liste.

Die Möglichkeit zum Verschieben von Feldern wurde möglicherweise beschränkt Die Person, die die PivotTable-Liste erstellt hat, hat die Möglichkeit zum Verschieben von Feldern möglicherweise deaktiviert. Wenden Sie sich für weitere Informationen an den Ersteller der PivotTable-Liste.

Nach Microsoft Excel exportieren Wenn Sie Felder verschieben müssen, können Sie eine Kopie der PivotTable-Liste nach Excel exportieren. In dem Excel-PivotTable-Bericht ist das Verschieben von Feldern ohne Einschränkungen möglich, und Sie können ein Feld gleichzeitig im Filter- (Seiten-)bereich und im Datenbereich anzeigen. Wenn OLAP-Datenquellen zum Einsatz kommen, unterliegen Excel-PivotTable-Berichte allerdings den gleichen Beschränkungen. Informationen über das Verschieben von Feldern in einem PivotTable-Bericht und Informationen über OLAP-Quelldaten finden Sie in der Excel-Hilfe.


Sie können keine Detaildaten anzeigen.

Die Erweiterungssymbole könnten deaktiviert worden sein Wenn neben Datenelementen in Zeilen- und Spaltenfeldern die Felder Plusfeld nicht angezeigt werden, prüfen Sie, ob die Erweiterungssymbole aktiviert sind.

Möglicherweise sind keine weiteren Details verfügbar Wenn sich ein Datenelement auf der niedrigsten Detailebene befindet, die seitens der Quelldaten verfügbar ist, wird neben dem Element das Feld Plusfeld auch dann nicht angezeigt, wenn die Erweiterungssymbole aktiviert sind.

Möglicherweise umfassen die Datenquellen keine Detaildaten Bei einigen Arten von Datenquellen, wie beispielsweise bei Datenquellen aus OLAP (On-Line Analytical Processing)-Datenbanken, stehen keine Detaildatensätze zur Anzeige zur Verfügung. Um herauszufinden, ob die Datenquellen Ihrer PivotTable-Liste auf einer OLAP-Datenbank basieren und in welchem Umfang Detaildaten zur Verfügung stehen, wenden Sie sich an den Ersteller der PivotTable-Liste.

Die Möglichkeit zur Anzeige von Details könnte beschränkt worden sein Wenn die Befehle zum Aktivieren der Erweiterungssymbole und zum Anzeigen von Details nicht verfügbar sind, hat die Person, die die PivotTable-Liste erstellt hat, die Möglichkeit zum Anzeigen von Details unter Umständen deaktiviert. Weitere Informationen dazu erhalten Sie vom Ersteller der PivotTable-Liste. Wenn Sie die Detaildaten anzeigen müssen, können Sie eine Kopie der PivotTable-Liste nach Microsoft Excel exportieren. In dem daraus resultierenden Excel-PivotTable-Bericht gibt es keinerlei Beschränkungen im Hinblick auf die Anzeige von Details. Informationen über das Anzeigen von Details in einem PivotTable-Bericht finden Sie in der Excel-Hilfe.


Sie können Daten nicht auf die gewünschte Weise filtern.

Filterbeschränkungen Die Filtermöglichkeiten, wie sie in Microsoft Excel-Tabellen und Excel-PivotTable-Berichten zur Verfügung stehen, einschließlich benutzerdefinierter AutoFilter und Top-Ten-Filterung, sind für PivotTable-Listen nicht verfügbar. Ebenfalls nicht verfügbar ist die Filterung, die auf Teildaten in einer Zelle basiert, eine Funktion, die für Formulare und Tabellen in Microsoft Access zur Verfügung steht. Mehr über die Filtermöglichkeiten für PivotTable-Listen erfahren.

Nach Excel exportieren Wenn Sie die Excel-Filterfunktionen verwenden möchten, exportieren Sie eine Kopie der PivotTable-Liste nach Excel.

Verwenden Sie Access zum Anzeigen der Daten Wenn Sie die Filterung basierend auf Teildaten in einer Zelle einsetzen möchten, wenden Sie sich an die Person, die die PivotTable-Liste erstellt hat, um zu erfahren, woher die Datenquellen stammen. Möglicherweise können Sie diese Daten direkt in einem Formular oder einer Tabelle in Access anzeigen, wo diese Form der Filterung unterstützt wird.


Die Befehle zum Verschieben von Feldern funktionieren nicht.

Die Möglichkeit zum Verschieben von Feldern könnte beschränkt worden sein Die Person, die die PivotTable-Liste erstellt hat, hat die Möglichkeit zum Verschieben von Feldern unter Umständen deaktiviert. Weitere Informationen darüber erhalten Sie vom Ersteller der PivotTable-Liste.

Export nach Microsoft Excel Wenn Sie Felder verschieben müssen, können Sie eine Kopie der PivotTable-Liste nach Excel exportieren. In dem daraus resultierenden Excel-PivotTable-Bericht gibt es keinerlei Beschränkungen im Hinblick auf das Verschieben von Feldern. Informationen über das Verschieben von Feldern in einem PivotTable-Bericht finden Sie in der Excel-Hilfe.


Die Daten sind schwer lesbar.

Verwenden Sie eine größere Schriftart Die Einstellungen Ihres Browsers für die Schriftgröße haben keinen Einfluss auf die Größe des Textes in einer PivotTable-Liste. Wenn Sie kleinen, nur schwer lesbaren Text vergrößern möchten, können Sie für Elemente in einer PivotTable-Liste die Schriftgrößen ändern.

Verwenden Sie kontrastierende Farben Die Farbeinstellungen Ihres Browsers haben keinen Einfluss auf die Farben einer PivotTable-Liste. Wenn Sie den Kontrast zwischen Text und Hintergrund verstärken möchten, können Sie für jedes Element in der PivotTable-Liste erst die Schriftfarbe festlegen und dann eine kontrastierende Hintergrundfarbe angeben.

Exportieren Sie nach Microsoft Excel Wenn Sie eine Kopie einer PivotTable-Liste nach Excel kopieren, können Sie die Zoomfunktion verwenden, um die Datenanzeige zu vergrößern. Informationen über das Arbeiten mit Excel-PivotTable-Berichten finden Sie in der Excel-Hilfe.


Die Felder sind vorhanden, jedoch fehlen alle Daten.

Sie haben die Berechnung der PivotTable-Liste abgebrochen, oder die Berechnung wurde gestoppt, bevor sie vollständig durchgeführt werden konnte. Klicken Sie zum Anzeigen der Daten in der Symbolleiste der PivotTable-Liste auf Aktualisieren [image] .

Tipp Bevor Sie die Daten aktualisieren, können Sie das Layout ändern oder die Elemente in den Feldern filtern.


Die Filterbefehle funktionieren nicht.

Der Zugriff auf die Filterfunktionen könnte beschränkt worden sein Die Person, die die PivotTable-Liste erstellt hat, hat die Fähigkeit zu ändern, wie Felder gefiltert werden, möglicherweise deaktiviert. Informationen darüber erhalten Sie vom Ersteller der PivotTable-Liste.

Export nach Microsoft Excel Wenn Sie die Daten filtern müssen, können Sie eine Kopie der PivotTable-Liste nach Excel exportieren. In dem daraus resultierenden Excel-PivotTable-Bericht gibt es keine Beschränkungen im Hinblick auf das Filtern von Feldern. Informationen über das Filtern von Daten in einem PivotTable-Bericht finden Sie in der Excel-Hilfe.


Die PivotTable-Liste kann anhand der Quelldaten nicht aktualisiert werden.

Einige PivotTable-Listen können nicht aktualisiert werden PivotTable-Listen, die basierend auf den Daten in einer Microsoft Excel-Tabelle, auf Excel-Webabfragen und Excel-Textabfragen veröffentlicht wurden, können nicht aktualisiert werden. In diesen Fällen muss die ursprüngliche Excel-Arbeitsmappe aktualisiert und die Veröffentlichung der PivotTable-Liste wiederholt werden. Wenden Sie sich an den Ersteller der PivotTable-Liste, um herauszufinden, auf welchen Datenquellen die Liste basiert und, sofern es sich um eine der oben genannten Arten handelt, ob die Veröffentlichung der PivotTable-Liste wiederholt werden kann, um eine aktualisierte Version bereitzustellen.

Die Herkunftsdatenbank ist möglicherweise nicht verfügbar Wenn die PivotTable-Liste auf Datenquellen aus einer in einem Netzwerk befindlichen Datenbank basiert, ist der Datenbankserver möglicherweise nicht verfügbar, oder Sie haben keinen Zugriff auf den Server. Eventuell besteht aktuell keine Verbindung zum Netzwerk, oder Sie benötigen unter Umständen Zugriffsrechte oder ein Kennwort, um die Verbindung zum Server herzustellen. Wenden Sie sich an den Ersteller der PivotTable-Liste, um herauszufinden, auf welcher Art von Datenquellen die Liste basiert und welche Datenbank verwendet wird. Wenn Probleme beim Zugriff auf den Server auftreten, wenden Sie sich an den Datenbankadministrator.

Microsoft Office unterstützt möglicherweise die Herkunftsdatenbank nicht Wenn die Datenquellen aus einer Datenbank stammen, die von Microsoft Office nicht unterstützt wird, müssen Sie möglicherweise Office-kompatible Supportsoftware des Datenbankherstellers installieren. Wenden Sie sich an den Ersteller der PivotTable-Liste, um herauszufinden, ob die Herkunftsdatenbank von Office unterstützt wird und, falls nicht, welche Software zum Erstellen der Datenbank verwendet wurde.

Die Herkunftsdatenbank wurde möglicherweise geändert Gelegentlich verhindern Änderungen am Aufbau der Datenbank auf dem Server eine mögliche Aktualisierung der PivotTable-Liste. Wenn die Quelldaten beispielsweise aus einer OLAP(On-Line Analytical Processing)-Datenbank stammen, die mit Änderungen an den verfügbaren Daten neu erstellt wurde, muss möglicherweise auch eine neue PivotTable-Liste erstellt werden. Wenden Sie sich in diesem Fall für weitere Informationen an den Ersteller der PivotTable-Liste.


Die Eigenschaftentoolbox oder die Feldliste der PivotTable-Liste werden nicht mehr angezeigt.

Wenn Sie auf der Webseite auf ein Steuerelement klicken, das kein Steuerelement der Microsoft Office Web Components ist, oder wenn Sie das Browserfenster minimieren und anschließend wiederherstellen, werden die Toolbox und die Feldliste ausgeblendet.

Um die Toolbox oder die Feldliste erneut anzuzeigen, klicken Sie auf die PivotTable-Liste, um sie zu erneut zu aktivieren.


Die Abfrage in einer PivotTable-Liste ist fehlgeschlagen.

Möglicherweise ist die Herkunftsdatenbank nicht verfügbar Wenn die PivotTable-Liste auf Datenquellen aus einer Datenbank in einem Netzwerk basiert, wurde der Datenbankserver möglicherweise heruntergefahren, oder das Netzwerk ist zwischenzeitlich nicht mehr verfügbar bzw. Ihre Verbindung zum Netzwerk wurde unterbrochen. Wenden Sie sich an den Administrator des Servers oder des Netzwerks, um zu prüfen, ob Server und Netzwerk verfügbar sind.

Möglicherweise verfügen Sie nicht über die notwendigen Zugriffsrechte Unter Umständen sind Sie zwar in der Lage, die Verbindung zur Datenbank herzustellen, jedoch verfügen Sie nicht über die notwendigen Zugriffsrechte zum Ausführen der Abfrage für die PivotTable-Liste. Erkundigen Sie sich beim Datenbankverwalter nach den notwendigen Zugriffsrechten.

Prüfen Sie die Filterung in der PivotTable-Liste Gelegentlich ist eine PivotTable-Liste so gefiltert, dass nur bestimmte Elemente angezeigt werden, und durch Änderungen an der Herkunftsdatenbank wird eines dieser Elemente möglicherweise entfernt, was dazu führt, dass die Abfrage fehlschlägt. In diesem Fall können Sie die Filterung deaktivieren, um alle Elemente anzuzeigen, und dann in der Symbolleiste der PivotTable-Liste auf Aktualisieren [image] klicken, um die Abfrage auszuführen.


Wenn Sie das Layout ändern, dauert es sehr lange, bis die Daten angezeigt werden.

Wenn das Berechnen der PivotTable-Liste lange Zeit in Anspruch nimmt, können Sie in einem Durchgang mehrere Layoutänderungen durchführen und die Daten erst dann abrufen, wenn Sie alle gewünschten Änderungen vorgenommen haben.

  1. Wenn die Meldung "PivotTable berechnen" angezeigt wird, drücken Sie ESC, um die Berechnung abzubrechen. In der PivotTable-Liste werden dann nur die Namen der Felder angezeigt.

  2. Ändern Sie das Layout, und fügen Sie so viele Felder hinzu bzw. verschieben Sie so viele Felder, wie es Ihren Anforderungen entspricht.

  3. Um nun die Daten für das neue Layout zu laden und zu berechnen, klicken Sie in der Symbolleiste der PivotTable-Liste auf Aktualisieren [image] .


Wenn Sie die BILD-AB-TASTE drücken, können Sie Ihre Auswahl nicht sehen.

Verwenden Sie die Bildlaufleisten des Browsers Der Ersteller der PivotTable-Liste hat die Liste so gestaltet, dass sie vergrößert oder verkleinert wird, wenn Sie ihr Layout ändern, so dass sie auf der Webseite nur so viel Platz in Anspruch nimmt, wie für die Anzeige der Daten benötigt wird. Wenn Sie weiteren Webseiteninhalt anzeigen möchten, verwenden Sie die Bildlaufleisten des Browsers, um einen Bildlauf durch die gesamte Webseite durchzuführen.


Beim Aktualisieren einer PivotTable-Liste ändern sich andere PivotTable-Listen auf der Webseite ebenfalls

Die Webseite, die Sie anzeigen, wurde so gestaltet, dass die anderen PivotTable-Listen ebenfalls aktualisiert werden, wenn Sie eine PivotTable-Liste aktualisieren.

Für Informationen darüber, wie die PivotTable-Listen verknüpft sind, wenden Sie sich an den Ersteller der Webseite.


Warum werden neben den Gesamtsummen in der PivotTable-Liste Sternchen angezeigt?

In folgenden Fällen werden Sternchen neben den Gesamtsummen angezeigt:

  • Gesamtsummen enthalten verborgene Elemente Wenn Sie festlegen, dass alle Elemente in Gesamtsummen berücksichtigt werden sollen, wird durch die neben den Gesamtsummen angezeigten Sternchen angegeben, dass neben den angezeigten Elementen auch verborgene Elemente in den Gesamtsummen berücksichtigt sind.

  • Die PivotTable-Liste wurde in Microsoft Excel veröffentlicht In Excel PivotTable-Berichten, denen Quelldaten aus OLAP-Datenbanken (On-Line Analytical Processing) zugrunde liegen, werden bei der Berechnung der Werte für Teil- und Gesamtergebnisse stets die Werte für alle Elemente des Feldes (d. h. angezeigte und verborgene Werte) berücksichtigt. In Excel steht eine Option zur Verfügung, mit der die Anzeige der Sternchen ein- und ausgeschaltet werden kann. Wenn jedoch ein Excel-Bericht als PivotTable-Bericht für das Web gespeichert oder veröffentlicht wird, werden die Sternchen auch dann in der PivotTable-Liste angezeigt, wenn ihre Anzeige in Excel deaktiviert wurde.

Sie können die Art der Berechnung von Gesamtsummen ändern Wenn Sie durch Filtern der Gesamt- und Teilergebnisse verhindern möchten, dass in der PivotTable-Liste (unabhängig davon, ob dieser Quelldaten aus einer OLAP-Datenbank zugrunde liegen) verborgene Daten berücksichtigt werden, können Sie über eine Option festlegen, dass nur angezeigte Daten berücksichtigt werden. Durch diese Option wird auch die Anzeige der Sternchen ausgeblendet.


Markieren einer gesamten PivotTable-Liste

  • Klicken Sie auf die Titelleiste.

    Wenn die PivotTable-Liste nicht über eine Titelleiste verfügt, klicken Sie mit der rechten Maustaste auf die PivotTable-Liste, und klicken Sie dann im Kontextmenü auf Eigenschaftentoolbox. Wenn die Kategorie Ein-/Ausblenden nicht erweitert ist, klicken Sie auf die Ein-/Ausblenden-Leiste, und klicken Sie dann auf Titelleiste [image].

Anmerkung Wenn der Befehl Eigenschaftentoolbox im Kontextmenü nicht verfügbar ist, hat die Person, die die PivotTable-Liste erstellt hat, den Zugriff hierauf möglicherweise beschränkt.