Abrufen von externen Daten mit Microsoft Query

Zum Anzeigen dieses Themas klicken Sie auf die Grafik.

Zum Anzeigen dieses Themas klicken Sie auf die Grafik


Aufrufen der Programminformationen zu Microsoft Query

  • Klicken Sie in Microsoft Query im Menü ? auf Info.

    Die Programminformationen, wie z. B. die Versionsnummer, werden im Dialogfeld Info angezeigt.


Einblenden, Ausblenden und Deaktivieren des Office-Assistenten

  • Klicken Sie im Menü ? auf Microsoft Query Hilfe.

Anmerkung Wenn Sie den Assistenten deaktivieren möchten, klicken Sie auf Optionen und deaktivieren Sie dann das Kontrollkästchen Den Office-Assistenten verwenden. Sie können auch Hilfe ohne den Office-Assistenten aufrufen.


Verschieben des Office-Assistenten und der Sprechblase

  • Ziehen Sie den Office-Assistenten an eine beliebige Stelle auf dem Bildschirm.


Auswählen eines anderen Office-Assistenten

  1. Klicken Sie auf den Office-Assistenten.

  2. Klicken Sie auf Optionen.
  3. Klicken Sie auf der Registerkarte Katalog auf Zurück oder Weiter, bis der gewünschte Assistent angezeigt wird.


Ein- und Ausschalten der Geräusche des Office-Assistenten

Wenn Sie beim Verwenden des Assistenten die Geräusche hören möchten, muss auf dem Computer eine Audiokarte installiert sein. Außerdem muss der Assistent aktiviert sein.

  1. Klicken Sie auf den Office-Assistenten.
  2. Klicken Sie auf Optionen.

  3. Aktivieren oder deaktivieren Sie auf der Registerkarte Optionen das Kontrollkästchen Sounds aktivieren.


Problembehandlung beim Office-Assistenten

Wobei benötigen Sie Hilfe?

Der Office-Assistent lenkt bei der Arbeit ab.

Der Office-Assistent zeigt das gewünschte Hilfethema nicht an.

Die Funktionen der Sprechblase des Office-Assistenten werden nicht ordnungsgemäß ausgeführt.


Anzeigen von Meldungen ohne den Office-Assistenten

Wenn der Assistent deaktiviert ist, werden Meldungen automatisch ohne den Assistenten angezeigt. Zum Ausführen dieses Verfahrens muss der Assistent aktiviert sein.

  1. Klicken Sie auf den Office-Assistenten.

  2. Klicken Sie auf Optionen.

  3. Deaktivieren Sie in der Registerkarte Optionen das Kontrollkästchen Warnmeldungen anzeigen.


Aufrufen der Hilfe ohne den Office-Assistenten

Wenn Sie Hilfe ohne den Office-Assistenten aufrufen möchten, muss der Assistent deaktiviert sein. So deaktivieren Sie den Office-Assistenten.

  1. Klicken Sie im Menü ? auf Microsoft Query Hilfe.

    Wenn die Registerkarten Inhalt, Antwort-Assistent und Index nicht angezeigt werden, klicken Sie auf Anzeigen [image].

  2. Im Hilfefenster können Sie nach einer der folgenden Methoden vorgehen:

    Wenn Sie das Inhaltsverzeichnis der Hilfe anzeigen möchten, klicken Sie auf die Registerkarte Inhalt.

    Wenn Sie eine Frage zu einem Programm von Microsoft Office eingeben möchten, klicken Sie auf die Registerkarte Antwort-Assistent.

    Wenn Sie nach spezifischen Wörtern oder Ausdrücken suchen oder diese aus einer Liste auswählen möchten, klicken Sie auf die Registerkarte Index. Sie können die Suche eingrenzen und steuern, wie lang die Liste der gefundenen Themen sein soll. Dazu fügen Sie Suchbegriffe hinzu oder entfernen Sie diese, bis nur die gewünschten Themen und Suchbegriffe in der Liste stehen.


Verwenden von Tastenkombinationen in Microsoft Query

Was möchten Sie tun?

Mit Tastenkombinationen in Microsoft Query-Ausschnitten bewegen

Daten und Kriterien mit Tastenkombinationen markieren

Daten und Kriterien mit Tastenkombinationen bearbeiten

Funktionstasten in Microsoft Query verwenden

Den Office-Assistenten verwenden

Tastenkombinationen im OLAP-Cube-Assistenten verwenden


Bewegen in den Microsoft Query-Ausschnitten mit Tastenkombinationen

Bewegen im Tabellenfenster

Taste(nkombination) | Zweck
TAB | Wechseln zwischen Tabellen
PFEIL-NACH-OBEN-TASTE oder PFEIL-NACH-UNTEN-TASTE | Wechseln zu und Markieren von Feldnamen in einer Tabelle
UMSCHALT+PFEIL-NACH-OBEN- oder UMSCHALT+PFEIL-NACH-UNTEN-TASTE | Auswählen angrenzender Felder in einer Tabelle oder Aufheben der Markierung

Bewegen zwischen Spalten und Zeilen im Daten- oder Kriterienfenster

Taste(nkombination) | Zweck
F5, Eingabe der Nummer des Datensatzes im Feld Datensatz und anschließendes Drücken der EINGABETASTE. | Wechseln zu einem bestimmten Datensatz (einer Zeile) im Datenfenster
TAB, EINGABETASTE oder PFEIL-NACH-RECHTS-TASTE (von einer markierten Zelle aus). | Wechseln zur nächsten Spalte im Datenfenster
UMSCHALT+TAB, UMSCHALT+EINGABE oder PFEIL-NACH-LINKS-TASTE (von einer markierten Zelle aus) | Wechseln zur vorherigen Spalte in der aktuellen Zeile oder zum letzten Feld im vorherigen Datensatz
ENDE | Wechseln zur letzten Spalte in der aktuellen Zeile.
STRG+ENDE | Wechseln zur letzten Spalte in der letzten Zeile
POS1 | Wechseln zur ersten Spalte in der aktuellen Zeile
STRG+POS1 | Wechseln zur ersten Spalte in der ersten Zeile
NACH-UNTEN-TASTE | Wechseln zur nächsten Zeile in der aktuellen Spalte
STRG+NACH-UNTEN | Wechseln zur letzten Zeile in der aktuellen Spalte
NACH-OBEN-TASTE | Wechseln zur vorherigen Zeile in der aktuellen Spalte
STRG+NACH-OBEN | Wechseln zur ersten Zeile in der aktuellen Spalte

Verschieben der Einfügemarke innerhalb eines Wertes in einer Zelle im Daten- oder Kriterienfenster

Taste(nkombination) | Zweck
F2 | Markierung aufheben und die Einfügemarke in einer markierten Zelle anzeigen
NACH-RECHTS-TASTE | Einfügemarke ein Zeichen nach rechts verschieben
STRG+NACH-RECHTS | Einfügemarke ein Wort nach rechts verschieben
NACH-LINKS-TASTE | Einfügemarke ein Zeichen nach links verschieben
STRG+NACH-LINKS | Einfügemarke ein Wort nach links verschieben
ENDE | Einfügemarke bei ein- oder mehrzeiligen Werten an das Ende der aktuellen Zeile verschieben
STRG+ENDE | Einfügemarke bei mehrzeiligen Werten an das Ende des Wertes verschieben
POS1 | Einfügemarke bei ein- oder mehrzeiligen Werten an den Anfang der aktuellen Zeile verschieben
STRG+POS1 | Einfügemarke bei mehrzeiligen Werten an den Anfang des Wertes verschieben

Seitenweises Bewegen im Daten- oder Kriterienfenster

Taste(nkombination) | Zweck
BILD-AB | Einfügemarke in einem Ausschnitt eine Bildschirmseite nach unten verschieben
BILD-AUF | Einfügemarke in einem Ausschnitt eine Bildschirmseite nach oben verschieben
STRG+BILD-AB | Einfügemarke in einem Ausschnitt eine Bildschirmseite nach rechts verschieben
STRG+BILD-AUF | Einfügemarke in einem Ausschnitt eine Bildschirmseite nach links verschieben


Auswählen von Daten und Kriterien mit Hilfe von Tastenkombinationen

Markieren von Werten innerhalb einer Spalte

Taste(nkombination) | Zweck
F2 | Aktuellen Wert markieren bzw. die Markierung aufheben und die Einfügemarke anzeigen
TAB, EINGABETASTE oder PFEIL-NACH-RECHTS-TASTE (von einer markierten Zelle aus) | Wert in der nächsten Spalte markieren
UMSCHALT+POS1 | Innerhalb eines Wertes den Teil zwischen der Einfügemarke und dem Anfang der Zeile markieren
UMSCHALT+ENDE | Innerhalb eines Wertes den Teil zwischen der Einfügemarke und dem Ende der Zeile markieren
UMSCHALT+NACH-RECHTS | Markierung um ein Zeichen nach rechts erweitern oder aufheben
STRG+Umschalt+NACH-RECHTS | Markierung um ein Wort nach rechts erweitern oder aufheben
UMSCHALT+NACH-LINKS | Markierung um ein Zeichen nach links erweitern oder aufheben
STRG+Umschalt+NACH-LINKS | Markierung um ein Wort nach links erweitern oder aufheben

Markieren einer Zeile

Taste(nkombination) | Zweck
UMSCHALT+LEERTASTE | Aktuelle Zeile markieren
NACH-UNTEN-TASTE | Wenn aktuelle Zeile markiert ist: nächste Zeile markieren
NACH-OBEN-TASTE | Wenn aktuelle Zeile markiert ist: vorherige Zeile markieren
UMSCHALT+ NACH-UNTEN | Markierung um eine Zeile nach unten erweitern oder aufheben
UMSCHALT+ NACH-OBEN | Markierung um eine Zeile nach oben erweitern oder aufheben
UMSCHALT+BILD-AB | Markierung um eine Bildschirmseite nach unten erweitern
UMSCHALT+BILD-AUF | Markierung um eine Bildschirmseite nach oben erweitern
STRG+Umschalt+leertaste | Alle zurückgegebenen Datensätze markieren

Markieren einer Spalte

Taste(nkombination) | Zweck
STRG+leeRtaste | Aktuelle Spalte markieren
NACH-RECHTS-TASTE | Wenn aktuelle Spalte markiert ist: nächste Spalte markieren
NACH-LINKS-TASTE | Wenn aktuelle Spalte markiert ist: vorherige Spalte markieren
UMSCHALT+NACH-LINKS | Markierung um eine Spalte nach links erweitern oder aufheben
UMSCHALT+NACH-RECHTS | Markierung um eine Spalte nach rechts erweitern oder aufheben
STRG+Umschalt+BILD-AB | Markierung um eine Bildschirmseite nach rechts erweitern
STRG+Umschalt+BILD-AUF | Markierung um eine Bildschirmseite nach links erweitern


Bearbeiten von Daten und Kriterien mit Hilfe von Tastenkombinationen

Kopieren, Ausschneiden, Einfügen oder Löschen

Taste(nkombination) | Zweck
STRG+C | Aktuelle Markierung in die Zwischenablage kopieren
STRG+V | Inhalt der Zwischenablage an der Einfügemarke einfügen
STRG+X | Aktuelle Markierung ausschneiden und in die Zwischenablage kopieren
RÜCKTASTE | Aktuelle Markierung oder Zeichen links der Einfügemarke löschen
ENTF | Aktuelle Markierung oder Zeichen rechts der Einfügemarke löschen

Vergrößern des Datenfensters zwecks Bearbeitung

Taste(nkombination) | Zweck
UMSCHALT+F2 | Dialogfeld Zoom öffnen, um Werte in kleinen Eingabebereichen im Datenfenster leichter eingeben zu können


Funktionstasten in Microsoft Query

Taste(nkombination) | Zweck
F1 | Zur Hilfe wechseln
UMSCHALT+F1 und dann EINGABETASTE | Kontextbezogene Hilfe für das markierte Element aufrufen
F2 | Aktuellen Wert markieren oder Markierung aufheben
ALT+UMSCHALT+F2 oder UMSCHALT+F12 | Speichern einer Abfrage mit dem Befehl Speichern
ALT+F2 oder F12 | Speichern einer Abfrage mit dem Befehl Speichern unter
UMSCHALT+F2 | Dialogfeld Zoom öffnen, um Werte in kleinen Eingabebereichen im Datenfenster leichter eingeben zu können
STRG+F4 | Aktive Abfrage schließen
ALT+F4 | Microsoft Query beenden
F5, Nummer des Datensatzes im Feld Datensatz eingeben, dann die EINGABETASTE drücken | Zu einem bestimmten Datensatz (einer Zeile) im Datenfenster wechseln
F6 | Zum nächsten Ausschnitt im Abfragefenster wechseln
UMSCHALT+F6 | Zum vorherigen Ausschnitt im Abfragefenster wechseln
STRG+F6 | Zum nächsten offenen Abfragefenster wechseln
STRG+UMSCHALT+F6 | Zum vorherigen offenen Abfragefenster wechseln
F9 | Offene Abfrage ausführen


Verwenden von Tastenkombinationen im OLAP-Cube-Assistenten

Verwenden Sie diese Tasten, um Schritt 2 im OLAP-Cube-Assistenten zu Ende zu führen.

So verschieben Sie ein Feld aus der Liste "Quellfelder" in das Feld "Dimensionen"

  1. Drücken Sie TAB, um die Liste Quellfelder auszuwählen.

  2. Drücken Sie die PFEIL-NACH-OBEN-TASTE oder PFEIL-NACH-UNTEN-TASTE, um das Feld auszuwählen, das Sie verschieben möchten.

  3. Drücken Sie TAB, um die Schaltfläche > auszuwählen, und drücken Sie dann die EINGABETASTE.

  4. Wiederholen Sie die Schritte 1 bis 3 für jedes weitere Feld, das Sie verschieben möchten.

So verschieben Sie ein Feld im Feld "Dimensionen" innerhalb einer Dimension auf eine niedrigere oder höhere Ebene

  1. Drücken Sie TAB, um das Feld Dimensionen auszuwählen.

  2. Drücken Sie die PFEIL-NACH-OBEN-TASTE oder PFEIL-NACH-UNTEN-TASTE, um das Feld auszuwählen, das Sie verschieben möchten.

  3. Drücken Sie STRG+X.

  4. Drücken Sie die PFEIL-NACH-OBEN-TASTE oder die PFEIL-NACH-UNTEN-TASTE, um auszuwählen, wohin das Feld verschoben werden soll.

  5. Drücken Sie STRG+V.


Tastenkombinationen zur Verwendung des Office-Assistenten

Tastenkombination | Zweck
F1 | Anfordern von Hilfe über den Office-Assistenten
ALT+Themennummer (wobei 1 das erste Thema darstellt, 2 das zweite usw.) | Auswählen eines der im Office-Assistenten angezeigten Hilfethemen
ALT+NACH-UNTEN | Anzeigen weiterer Hilfethemen
ALT+NACH-OBEN | Anzeigen der vorigen Hilfethemen
ESC | Schließen einer Meldung des Office-Assistenten oder einer Sprechblase des Assistenten


 Installieren eines ODBC-Treibers für den Zugriff auf eine externe Datenquelle

Installieren eines ODBC-Treibers für den Zugriff auf eine externe Datenquelle

Die von Microsoft in Query zur Verfügung gestellten ODBC-Treiber werden bei der Installation von Query mitinstalliert. Zeigen Sie die Liste der ODBC-Treiber an, die mit Microsoft Query installiert werden.

Wenn die externe Datenbank, auf die Sie zugreifen möchten, nicht von diesen ODBC-Treibern unterstützt wird, müssen Sie einen mit Microsoft Office kompatiblen ODBC-Treiber von einem Fremdanbieter, wie beispielsweise dem Hersteller der Datenbank, erwerben. Wenn Sie Anweisungen zur Installation benötigen, wenden Sie sich an den Händler, von dem Sie die Datenbank erworben haben.

Anmerkung Für OLAP-Datenbanken sind ODBC-Treiber nicht erforderlich. Bei der Installation von Microsoft Query werden Treiber und Support mitinstalliert, die den Zugriff auf Datenbanken ermöglichen, die mit Microsoft SQL Server OLAP-Services erstellt wurden. Wenn Sie eine Verbindung zu anderen OLAP-Datenbanken herstellen möchten, müssen Sie einen Datenquellentreiber und Clientsoftware installieren. Rufen Sie weitere Informationen zu OLAP-Fremdanbietern auf.


 Installieren von OLAP-Anbietern

Installieren von OLAP-Anbietern

Wenn Sie eine Verbindung zu Produkten von Drittanbietern herstellen möchten, die OLAP-Daten und -Dienste zur Verfügung stellen, müssen Sie die OLAP-Anbietersoftware installieren. Diese Software besteht aus zusätzlichen Datenquellentreibern und Clientsoftware, über die Sie eine Verbindung zu einer OLAP-Datenbank eines Drittanbieters auf einem Server herstellen können.

Um die Leistungsmerkmale von Microsoft Office für die Bearbeitung von OLAP-Daten nutzen zu können, muss der fremde OLAP-Anbieter mit Office kompatibel sein. Nicht alle Anbieter unterstützen das Erstellen und Bearbeiten von Offline-Cube-Dateien. Um festzustellen, ob der ausgewählte Anbieter dieses Leistungsmerkmal unterstützt, erstellen Sie einen Microsoft Excel PivotTable-Bericht anhand der durch die OLAP-Datenbank zur Verfügung gestellten Quelldaten. In dem PivotTable-Bericht steht im Menü PivotTable (Symbolleiste PivotTable) der Befehl Client-Server-Einstellungen nicht zur Verfügung, wenn der Anbieter keine Offline-Cube-Dateien unterstützt.

Informationen über das Installieren und Verwenden eines fremden OLAP-Anbieters erhalten Sie bei Ihrem Systemadministrator oder bei dem Lieferanten des OLAP-Produkts. Nach dem Installieren des Anbieters können Sie in Microsoft Query Datenquellen einrichten, um auf die Datenbanken des Anbieters zuzugreifen.


 Datenbanken, auf die Sie zugreifen können

Datenbanken, auf die Sie zugreifen können

Microsoft Office umfasst Treiber, mit denen Sie Daten aus den folgenden Datenquellen abrufen können:

  • Microsoft SQL Server OLAP Services (OLAP-Dienstanbieter)

  • Microsoft Access 2000

  • dBASE

  • Microsoft FoxPro

  • Microsoft Excel

  • Oracle

  • Paradox

  • SQL Server

  • Textdateidatenbanken

Anmerkung Sie können ODBC-Treiber oder Datenquellentreiber von anderen Herstellern verwenden, um Informationen aus anderen Datenbanktypen abzurufen, die hier nicht aufgelistet sind. Dazu gehören auch andere Typen von OLAP-Datenbanken. Informationen zu anderen Treibern, die unter Umständen von Microsoft erhältlich sind, finden Sie in der Datei xlreadme.txt. Weitere Informationen zum Installieren eines ODBC-Treibers oder eines Datenquellentreibers, die nicht hier oder in der Datei xlreadme.txt aufgelistet sind, finden Sie in der Dokumentation zur Datenbank, oder wenden Sie sich an den Händler, von dem Sie die Datenbank erworben haben.


 Angeben einer Quelle, aus der Daten abgerufen werden sollen

Angeben einer Quelle, aus der Daten abgerufen werden sollen

  1. Wenn das Dialogfeld Datenquelle auswählen nicht angezeigt wird, klicken Sie auf Neue Abfrage [image] .

  2. Gehen Sie nach einer der folgenden Methoden vor:

    Zum Angeben einer Datenquelle für eine relationale Datenbank, eine Textdateidatenbank oder eine Microsoft Excel Liste klicken Sie auf die Registerkarte Datenbanken.

    Zum Angeben einer OLAP-Cube-Datenquelle klicken Sie auf die Registerkarte OLAP-Cubes. Diese Registerkarte ist nur dann verfügbar, wenn Sie Microsoft Query von Microsoft Excel aus ausgeführt haben.

  3. Doppelklicken Sie auf Neue Datenquelle.

  4. Geben Sie in Schritt 1 einen Namen ein, um die Datenquelle zu identifizieren.

  5. Klicken Sie in Schritt 2 auf einen Treiber für den Datenbanktyp, den Sie als Datenquelle verwenden.

    Wenn die gewünschte Datenbank nicht angezeigt wird, müssen Sie möglicherweise den ODBC-Treiber oder den Datenquellentreiber für die Datenquelle installieren.

    Wie wird's gemacht?

  6. Klicken Sie auf Verbinden, und geben Sie dann die Informationen an, die erforderlich sind, um eine Verbindung zur Datenbank herzustellen.

    Bei relationalen Datenbanken, Textdateidatenbanken und Excel-Listen müssen Sie je nach dem Typ der ausgewählten Datenbank unterschiedliche Informationen angeben. Sie werden unter Umständen zur Eingabe eines Anmeldenamens, eines Kennwortes, der Version der verwendeten Datenbank, des Speicherortes der Datenbank oder anderer Informationen aufgefordert, die für den ausgewählten Datenbanktyp spezifisch sind. .

    Bei Microsoft SQL Server OLAP Services-Datenquellen folgen Sie den im Verbindungs-Assistenten für Multi-Dimensionale Verbindungen angegebenen Schritten.

  7. Wenn Sie die erforderlichen Informationen eingegeben haben, klicken Sie auf OK oder Fertig stellen, um zum Dialogfeld Neue Datenquelle erstellen zurückzukehen.

  8. Wenn Ihre Datenbank über Tabellen verfügt, und wenn eine bestimmte Tabelle automatisch im Query-Assistenten angezeigt werden soll, klicken Sie auf das Feld für Schritt 4, und klicken Sie dann auf die gewünschte Tabelle.
  9. Wenn Sie den Anmeldenamen und das Kennwort beim Verwenden der Datenquelle nicht eingeben möchten, aktivieren Sie das Kontrollkästchen User-ID und Kennwort in der Datenquellendefinition speichern. Ist das Kontrollkästchen nicht verfügbar, erkundigen Sie sich beim Datenbankadministrator, ob diese Option möglicherweise deaktiviert wurde.

    Nachdem Sie diese Schritte ausgeführt haben, wird der Name Ihrer Datenquelle im Dialogfeld Datenquelle auswählen angezeigt.


 Einrichten einer Datenquelle, die den Microsoft Access-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft Access-Treiber verwendet

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle an, und wählen Sie in Schritt 2 Microsoft Access-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Klicken Sie unter Datenbank auf Auswählen, und verwenden Sie das Dialogfeld Datenbank auswählen, um nach der gewünschten Datenbankdatei zu suchen.

    Wenn Microsoft Query die Datenbank schreibgeschützt öffnen soll, aktivieren Sie das Kontrollkästchen Schreibgeschützt.

    Soll auf diese Datenbank lediglich mit Microsoft Query zugegriffen werden, wenn Sie diese Datenquelle verwenden, aktivieren Sie das Kontrollkästchen Exklusiv.

  4. Klicken Sie auf OK.

    Müssen für die Datenbank weitere Verbindungsparameter eingestellt werden, klicken Sie auf Erweitert. Wenden Sie sich gegebenenfalls an den Datenbankadministrator. Informationen zu den erweiterten Einstellungen erhalten Sie, indem Sie auf Abbrechen und dann im Dialogfeld ODBC Microsoft Access Setup auf Hilfe klicken.

  5. Wenn Microsoft Query auf die Systemdatenbank zugreifen soll, klicken Sie unter Systemdatenbank auf Datenbank und dann auf Systemdatenbank. Suchen Sie im Dialogfeld Systemdatenbank auswählen nach der gewünschten Systemdatenbankdatei, und klicken Sie dann auf OK.

  6. Klicken Sie auf OK, und geben Sie unter Information zur Anmeldung Ihren Anmeldenamen und das Kennwort ein. Wenn Sie für den Zugriff auf die Datenbank keinen Anmeldenamen bzw. kein Kennwort benötigen, lassen Sie dieses Feld leer.

Anmerkung Sie können das Dialogfeld ODBC Microsoft Access Setup verwenden, um Microsoft Access-Datenbanken zu erstellen, zu reparieren und zu komprimieren. Wenn Sie mit diesen Verfahren nicht vertraut sind, sollten Sie es nur in Microsoft Access durchführen. Weitere Informationen finden Sie in der Microsoft Access-Hilfe.


 Einrichten einer Datenquelle, die den Microsoft dBASE- oder FoxPro-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft dBASE- oder FoxPro-Treiber verwendet

Bevor Sie das folgende Verfahren durchführen, empfiehlt es sich, alle zu verwendenden Datenbankdateien im selben Ordner abzulegen, so dass Query alle Dateien finden kann und Sie nicht jedesmal den gesamten Pfad eingeben müssen, wenn Sie einer Abfrage eine Tabelle hinzufügen möchten. Es ist jedoch möglich, die Datenbank- und Index-Dateien in unterschiedlichen Ordnern zu speichern.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle an, und wählen Sie in Schritt 2 Microsoft dBASE-Treiber oder Microsoft Visual FoxPro-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Führen Sie einen der folgenden Schritte durch:

    Klicken Sie beim Microsoft dBase-Treiber in der Liste Version auf die Version von dBASE oder FoxPro, die zum Erstellen Ihrer Datenbankdateien verwendet wurde. Sind die Datenbankdateien nicht im aktuellen Verzeichnis gespeichert, deaktivieren Sie das Kontrollkästchen Aktuelles Verzeichnis verwenden und klicken dann auf Verzeichnis auswählen, um den Ordner zu lokalisieren. Wenn sich die Indexdateien für die Datenbank ebenfalls in einem anderen Ordner befinden, klicken Sie auf Indizes auswählen, um den Ordner zu suchen.

    Klicken Sie beim Microsoft Visual FoxPro-Treiber unter Datenbanktyp auf die Option für Ihre FoxPro-Datenbank, und geben Sie dann im Feld Pfad den Pfad zu der Datenbank ein.


 Einrichten einer Datenquelle, die den Microsoft Excel-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft Excel-Treiber verwendet

Wenn Sie den ODBC-Treiber für Microsoft Excel verwenden, können Sie nur auf Daten aus Arbeitsmappen im selben Ordner zugreifen. Bevor Sie das folgende Verfahren durchführen, kopieren Sie alle Arbeitsmappen, auf deren Daten Sie gleichzeitig zugreifen möchten, in einen Ordner und benennen Sie alle Bereiche des Tabellenblattes, die Microsoft Query als Tabellen erkennen soll.

Sie müssen für jeden Ordner, aus dem Sie Daten abrufen möchten, eine eigene Datenquelle einrichten.

Schließen Sie die Arbeitsmappe in Excel, bevor Sie eine Datenquelle einrichten oder eine Abfrage ausführen, bei der auf Daten in einer Excel-Arbeitsmappe zugegriffen wird.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle an, und wählen Sie in Schritt 2 Microsoft Excel-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Klicken Sie im Feld Version auf die Excel-Version, in der die Arbeitsmappe erstellt wurde. Wurde die Arbeitsmappe in Excel 97 erstellt, klicken Sie auf Excel 97-2000. Wurde die Arbeitsmappe in Excel 95 (Excel, Version 7.0) erstellt, klicken Sie auf Excel 5.0/7.0.

  4. Klicken Sie auf Arbeitsmappe auswählen, und suchen Sie dann nach der Arbeitsmappendatei.


 Einrichten einer Datenquelle, die den Microsoft ODBC für Oracle-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft ODBC für Oracle-Treiber verwendet

Wenn Sie den Microsoft ODBC für Oracle-Treiber verwenden, können Sie eine Verbindung zu Oracle-Datenbanken herstellen, die SQL*Net, Version 2.3 oder höher, unterstützen. Weitere Informationen zu dieser Unterstützung finden Sie in der Dokumentation zu Oracle.

Vor dem Einrichten von Datenquellen, die diesen Treiber verwenden, müssen Sie Oracle Client- und Netzwerkkomponenten, Version 7.3 oder höher, installieren. Sie erhalten diese Komponenten direkt bei Oracle oder bei Ihrem Oracle-Händler.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle ein, und wählen Sie in Schritt 2 Microsoft ODBC für Oracle-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Klicken Sie unter Datenbank auf Auswählen.

  4. Geben Sie im Feld Benutzername Ihren Anmeldenamen für die Datenbank ein.

  5. Geben Sie den Namen des Oracle-Servers und alle zusätzlichen Informationen ein, die erforderlich sind, um eine Verbindung zum Server herzustellen. Sie erhalten diese Informationen vom Administrator der Oracle-Datenbank. Um weitere Informationen zu Optionen beim Setup zu erhalten, klicken Sie im Setup-Dialogfeld auf ? (Hilfe).

  6. Geben Sie Ihre Anmelde-ID und das Kennwort ein, und klicken Sie dann zweimal auf OK.


 Einrichten einer Datenquelle, die den Microsoft Paradox-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft Paradox-Treiber verwendet

Bevor Sie das folgende Verfahren durchführen, empfiehlt es sich, alle zu verwendenden Datenbankdateien im selben Ordner abzulegen, so dass Query alle Dateien finden kann und Sie nicht jedesmal den gesamten Pfad eingeben müssen, wenn Sie einer Abfrage eine Tabelle hinzufügen möchten.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle ein, und wählen Sie in Schritt 2 Microsoft Paradox-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Wählen Sie im Feld Version die Paradox-Version aus, in der die Datenbankdateien erstellt wurden.

  4. Wenn sich die Datenbankdateien nicht im aktuellen Ordner befinden, deaktivieren Sie das Kontrollkästchen Aktuelles Verzeichnis verwenden, und klicken Sie auf Verzeichnis auswählen, um nach dem Ordner zu suchen.

  5. Wenn für die Datenbank weiterer Optionen eingestellt werden müssen, klicken Sie auf Optionen. Wenden Sie sich gegebenenfalls an den Datenbankadministrator. Informationen zu den erweiterten Einstellungen erhalten Sie, indem Sie im Dialogfeld ODBC Paradox-Setup auf Hilfe klicken.


 Einrichten einer Datenquelle, die den Microsoft SQL Server OLAP Services-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft SQL Server OLAP Services-Treiber verwendet

Mit diesem Treiber können Sie Datenquellen sowohl für Serverdatenbanken als auch für Offline-Cube-Dateien (*.cub) einrichten, die entweder in Excel aus Microsoft SQL Server OLAP Services-Datenbanken mit dem Offline-Cube-Assistenten erstellt wurden oder die in Microsoft Query aus Datensätzen einer relationalen Datenbank mit dem OLAP-Cube-Assistenten erstellt wurden. Zeigen Sie weitere Informationen zu OLAP-Datenquellen an.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte OLAP-Cubes, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle ein, und wählen Sie in Schritt 2 Microsoft OLE DB Provider for OLAP Services.

    Die Registerkarte OLAP-Cubes ist nur dann verfügbar, wenn Sie Query in Excel ausführen.

  2. Klicken Sie in Schritt 3 des Dialogfeldes Neue Datenquelle erstellen auf Verbinden.

  3. Gehen Sie in Schritt 1 des Dialogfeldes Multidimensionale Verbindung nach einer der folgenden Methoden vor:

    Wenn Sie eine Verbindung zu einer Serverdatenbank herstellen möchten, klicken Sie auf OLAP-Server, und geben Sie dann den Servernamen, die Anmelde-ID und das Kennwort für den Server an. Informationen zu diesen und anderen Einstellungen Ihrer Datenbank erhalten Sie beim Serveradministrator.

    Zum Herstellen einer Verbindung zu einer Offline-Cube-Datei klicken Sie auf DCube-Datei und geben in das Feld Datei den Pfad der .cub-Datei ein.

  4. Führen Sie einen der folgenden Schritte durch:

    Wenn Sie eine Verbindung zu einer Offline-Cube-Datei herstellen möchten, klicken Sie auf Fertig stellen.

    Wenn Sie eine Verbindung zu einer Serverdatenbank herstellen möchten, klicken Sie auf Weiter, wählen Sie die Serverdatenbank, und klicken Sie dann auf Fertig stellen. In Schritt 4 des Dialogfeldes Neue Datenquelle erstellen wählen Sie den Namen des Datenbank-Cubes, aus dem Sie Daten abrufen möchten.


 Einrichten einer Datenquelle, die den Microsoft Text-Treiber verwendet

Einrichten einer Datenquelle, die den Microsoft Text-Treiber verwendet

Sie müssen für jeden Ordner mit Textdateien, aus denen Sie Informationen abfragen möchten, eine eigene Datenquelle einrichten. Wenn Sie eine Datenquelle zum gleichzeitigen Zugriff auf mehr als eine Textdatei verwenden möchten, kopieren Sie alle Textdateien in denselben Ordner, bevor Sie das folgende Verfahren durchführen.

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle ein, und wählen Sie in Schritt 2 Microsoft Text-Treiber.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Wenn sich die Textdateien nicht im aktuellen Ordner befinden, deaktivieren Sie das Kontrollkästchen Aktuelles Verzeichnis verwenden, und klicken Sie dann auf Verzeichnis auswählen, um nach dem Ordner zu suchen.

Anmerkung Es ist möglich, auf Daten in Textdateien verschiedener Formate zuzugreifen, z. B. auf durch Leerzeichen, Kommata oder Tabstopps getrennte Spalten. Weitere Informationen zu einsetzbaren Textdatei-Formaten erhalten Sie, indem Sie im Dialogfeld ODBC Text-Setup auf Hilfe klicken.


 Einrichten einer Datenquelle, die den SQL Server-Treiber verwendet

Einrichten einer Datenquelle, die den SQL Server-Treiber verwendet

  1. Wenn das Dialogfeld Neue Datenquelle erstellen nicht angezeigt wird, klicken Sie im Menü Datei auf Neu, klicken Sie auf die Registerkarte Datenbanken, und doppelklicken Sie dann auf Neue Datenquelle. Geben Sie in Schritt 1 einen Namen für die Datenquelle ein, und wählen Sie in Schritt 2 SQL Server.

  2. Klicken Sie in Schritt 3 auf Verbinden.

  3. Geben Sie im Feld Server den Namen des SQL-Servers im Netzwerk ein. Informationen zu den für das Feld Server verfügbaren Auswahlmöglichkeiten erhalten Sie, indem Sie auf Hilfe klicken.

  4. Klicken Sie auf Optionen, und wählen Sie weitere, für die Datenbank erforderliche Optionen aus. Wenden Sie sich gegebenenfalls an den Datenbankadministrator. Weitere Informationen zu den Einstellungen der Optionen erhalten Sie, indem Sie auf Hilfe klicken.

  5. Geben Sie Ihre Anmelde-ID und Ihr Kennwort ein, und klicken Sie dann zweimal auf OK.


 Erstellen einer neuen Abfrage

Erstellen einer neuen Abfrage

Eine Abfrage ist eine Methode, die Datensätze abzurufen, die eine bestimmte Frage beantworten. Diese Frage haben Sie zu den in der Datenbank gespeicherten Daten gestellt. Zum Erstellen einer Abfrage können Sie entweder den Query-Assistenten verwenden oder direkt in Microsoft Query arbeiten. Wie Sie die Abfrage erstellen, ist abhängig von den Features, die Sie benötigen, um die gewünschten Daten abzurufen.

Verwenden des Query-Assistenten Verwenden Sie den Query-Assistenten, wenn Sie eine einfache Abfrage erstellen möchten. Mit dem Query-Assistenten können Sie die Tabellen und Felder auswählen, die Sie in die Abfrage einschließen möchten. Es wird automatisch eine Exklusionsverknüpfung erstellt, wenn der Query-Assistent in einer Tabelle ein Primärschlüssel-Feld und ein Feld mit demselben Namen in der anderen Tabelle findet.

Sie haben im Query-Assistenten weiterhin die Möglichkeit, die Ergebnismenge zu sortieren und einfache Filtervorgänge durchzuführen. Im letzten Schritt des Query-Assistenten können Sie festlegen, ob Sie die Daten an Microsoft Excel zurückgeben, die Abfrage in Microsoft Query optimieren oder aus den Daten einen OLAP-Cube erstellen möchten. Nach dem Erstellen der Abfrage können Sie diese in Microsoft Excel oder in Microsoft Query ausführen. So verwenden Sie den Query-Assistenten.

Verwenden von Microsoft Query Setzen Sie Microsoft Query ein, wenn Sie eine komplexe Abfrage erstellen möchten. Bei dieser Vorgehensweise haben Sie die größten Eingriffsmöglichkeiten, da Sie die Ergebnismenge einschränken können, indem Sie entweder eine Exklusionsverknüpfung oder eine Inklusionsverknüpfung erstellen, oder indem Sie Ausdrücke und komplexe Kriterien verwenden. Unter einem Ausdruck versteht man eine Berechnung, die Sie mit Hilfe von Operatoren, Funktionen, Feldnamen und Konstanten durchführen können. Komplexere Filtervorgänge können Sie durch Verwenden von Kriterien ausführen.

Sie können die Ergebnismenge in Microsoft Query anzeigen. Wenn Sie sicher sind, dass die Ergebnismenge die gewünschten Daten enthält, können Sie diese an Microsoft Excel zurückgeben. Sie können in Microsoft Query auch OLAP-Cubes erstellen. Nach dem Erstellen der Abfrage können Sie diese in Microsoft Excel oder in Microsoft Query ausführen. So erstellen Sie eine Abfrage in Microsoft Query.

Verwenden einer Paramter-Abfrage Eine Parameterabfrage ist dann sinnvoll, wenn Sie mit einer Abfrage Daten abrufen möchten, die unterschiedliche Kriterien aufweisen. Wenn Sie zum Beispiel die Verkaufsdaten für jeweils ein Produkt abrufen möchten, können Sie den Produktnamen als Kriterium verwenden. Parameterabfragen können auch eingesetzt werden, um einen Teil der Daten aus einer Datenbank abzurufen, die so groß ist, dass die Systemressourcen nicht alle Daten gleichzeichtig abrufen können.

Bei der Ausführung einer Parameterabfrage werden Sie aufgefordert, Kriterien anzugeben. Eine Parameterabfrage kann nur in Microsoft Query erstellt werden, nicht im Query-Assistenten. Die Kriterien, die Sie eingeben, werden zum Abrufen von Daten aus den Tabellen in der Abfrage verwendet. Nach dem Erstellen der Abfrage können Sie diese in Microsoft Excel oder in Microsoft Query ausführen. So erstellen Sie eine Parameterabfrage.


Erstellen einer neuen Abfrage

Was möchten Sie tun?

Eine Abfrage mit Hilfe des Query-Assistenten erstellen

Ein komplexe Abfrage in Microsoft Query erstellen

Eine Parameterabfrage erstellen

Sie sind nicht sicher, welche Auswahl Sie treffen sollen?


 Erstellen einer Parameterabfrage

Erstellen einer Parameterabfrage

  1. Erstellen Sie eine Abfrage, die die gewünschten Tabellen und Felder für die Datensätze enthält.

    Wie wird's gemacht?

  2. Stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht niedergedrückt ist.

  3. Stellen Sie sicher, dass die Schaltfläche Kriterien ein-/ausblenden [image] niedergedrückt ist, um das Kriterienfenster anzuzeigen.

  4. Klicken Sie auf die erste Zelle in der Zeile Kriterienfeld, und klicken Sie dann auf den Pfeil in der Zelle, um aus der Liste ein Feld auszuwählen, das als Parameter für die Abfrage verwendet werden soll.

  5. Klicken Sie auf die erste Zelle in der Zeile Wert. Geben Sie [ (eine linke eckige Klammer) ein, gefolgt von dem Text für die Eingabeaufforderung, die Microsoft Query beim Ausführen der Abfrage anzeigen soll, und geben Sie dann ] (eine rechte eckige Klammer) ein. Die folgende Abbildung zeigt ein Beispiel.

    Der Text der Eingabeaufforderung darf nicht mit dem Feldnamen identisch sein, er kann den Feldnamen jedoch enthalten.

    Um mehr als einen Parameter für die Abfrage zu erstellen, wiederholen Sie die Schritte 4 und 5 für jeden Parameter, den Sie in der nächsten verfügbaren Spalte im Kriterienfenster hinzufügen möchten.

    Weitere Informationen zu den Kriterien, die Sie zum Verfeinern einer Abfrage verwenden können, erhalten Sie, wenn Sie auf [image] klicken.

  6. Drücken Sie die EINGABETASTE.

  7. Um die Abfrage auszuführen, klicken Sie auf Jetzt abfragen [image] .

Anmerkung Wenn Sie die gewünschten Daten abgerufen haben, können Sie die Ergebnismenge an Microsoft Excel zurückgeben. Weitere Informationen erhalten Sie, indem Sie auf [image] klicken.


 Öffnen einer Abfrage

Öffnen einer Abfrage

  1. Klicken Sie auf Abfrage öffnen [image] , klicken Sie auf die zu öffnende Abfragedatei, und klicken Sie dann auf Öffnen.

    Eine Query-Datei besitzt die Dateinamenerweiterung .dqy oder .qry.

  2. Geben Sie, wenn Sie dazu aufgefordert werden, den Anmeldenamen, das Kennwort und andere Informationen ein, die für die Datenquelle erforderlich sind.

  3. Geben Sie, wenn Sie dazu aufgefordert werden, Parameterwerte für die Abfrage ein, und klicken Sie dann auf OK. Wenn Sie die zulässigen Parameter nicht kennen, erkundigen Sie sich bei der Person, die die Abfrage erstellt hat.

Anmerkung Sie können auch eine Cube-Definitionsdatei mit der Erweiterung .oqy öffnen, die mit Hilfe des OLAP-Cube-Assistenten erstellt wurde. Wenn dieser Dateityp geöffnet wird, startet der Assistent, und Sie können die Cube-Definition ändern. Weitere Informationen zum Erstellen von Cubes erhalten Sie, wenn Sie den OLAP-Cube-Assistenten verwenden.


 Speichern einer Abfrage

Speichern einer Abfrage

Speichern Sie eine Abfrage, wenn Sie Formatierungen erhalten möchten oder wenn Sie dieselbe Abfrage zu einem späteren Zeitpunkt oder in einer anderen Arbeitsmappe verwenden möchten. Informationen zum Öffnen von Abfragedateien in Microsoft Excel finden Sie in Excel in der Hilfe. Sie brauchen eine Abfrage nicht zu speichern, um Daten an Excel zurückzugeben.

  1. Klicken Sie auf Speichern [image] .

  2. Geben Sie im Feld Dateiname den gewünschten Namen ein.

  3. In der Liste Dateityp wählt Microsoft Query automatisch Query-Dateien (*.dqy) aus. Wenn Sie die Abfrage in einer Version von Query vor Microsoft Query 97 einsetzen möchten, klicken Sie auf Query-Dateien (*.qry).

    Eine Parameterabfrage kann nur im Dateiformat *.dqy gespeichert werden und kann erst ab Microsoft Query, Version 97, verwendet werden.

  4. Klicken Sie in der Liste Speichern in auf den Ordner, in dem die Abfrage gespeichert werden soll.

  5. Klicken Sie auf Speichern.

Anmerkungen

  • Wenn Sie eine Abfragedatei speichern, speichert Query nicht die aktuelle Ergebnismenge, das im Datenfenster angezeigt wird. Die Ergebnismenge wird automatisch aktualisiert, bevor das Dialogfeld Speichern unter angezeigt wird; dies ist selbst dann der Fall, wenn die Schaltfläche AutoAbfrage [image] nicht gedrückt ist.

  • Wenn Sie verhindern möchten, dass Query die Abfrage ausführt, bevor diese gespeichert wird oder bevor die Daten an Excel zurückgegeben werden, klicken Sie im Menü Bearbeiten auf Optionen, und deaktivieren Sie dann das Kontrollkästchen Gültigkeit von Abfragen vor dem Speichern oder Zurückgeben von Daten überprüfen.

  • Der Standardspeicherort für Abfragedateien ist der Benutzerprofil-Ordner im Verzeichnis Anwendungsdaten\Microsoft\Abfragen. Wurde eine Abfrage an diesem Ort gespeichert, wird der Dateiname auf der Registerkarte Abfragen angezeigt, wenn Sie eine neue Abfrage in Microsoft Query öffnen oder wenn Sie in Excel den Befehl Gespeicherte Abfrage ausführen (Menü Daten, Option Externe Daten) ausführen.


 Ausführen, Anzeigen oder Bearbeiten eines SQL-Befehls, einer SQL-Prozedur oder einer SQL-Anweisung

Ausführen, Anzeigen oder Bearbeiten eines SQL-Befehls, einer SQL-Prozedur oder einer SQL-Anweisung

Wenn Sie mit SQL (Structured Query Language) vertraut sind, können Sie SQL verwenden, um bei einer Abfrage die SQL-Anweisung SELECT zu bearbeiten. Weitere Informationen zu SQL finden Sie in der Dokumentation der Datenbank.

  1. Erstellen Sie eine neue Abfrage. Geben Sie die Ergebnisse nicht an Microsoft Excel zurück.

    Wie wird's gemacht?

  2. Klicken Sie auf SQL-Ansicht einblenden [image] .

    Microsoft Query zeigt das Dialogfeld SQL mit der SQL-Anweisung SELECT an, die der Abfrage entspricht.

  3. Geben Sie die gewünschten Änderungen in die SQL-Anweisung ein, und klicken Sie dann auf OK.

    Um in dem Feld SQL-Anweisung eine neue Zeile hinzuzufügen, drücken Sie EINGABE.

Anmerkungen

  • Wenn Sie die SQL-Anweisung ändern oder ersetzen möchten, verwenden Sie die SQL-Syntax, die von Microsoft Query verwendet wird, oder die Syntax, die von der Datenquelle unterstützt wird. Microsoft Query versucht, die verwendete Syntax zu interpretieren, und zeigt sowohl den Abfageentwurf als auch die Ergebnismenge der Abfrage an.

  • Wenn Microsoft Query den Abfrageentwurf nicht anzeigen kann, weil ein Teil der verwendeten Syntax nicht interpretiert werden konnte, wird die Ergebnismenge trotzdem angezeigt. Sie können jedoch lediglich die Formatierung der Ergebnismenge ändern, beispielsweise die angezeigte Schriftart oder die Spaltenbreite. Sie können keine Daten bearbeiten und müssen alle Änderungen, die Sie an der Abfragedefinition vornehmen möchten, beispielsweise das Hinzufügen oder Entfernen von Feldern, im Dialogfeld SQL vornehmen.


 Automatisches Ausführen einer Abfrage oder Ausführen der Abfrage zu einem späteren Zeitpunkt

Automatisches Ausführen einer Abfrage oder Ausführen der Abfrage zu einem späteren Zeitpunkt

Microsoft Query führt eine Abfrage automatisch durch und aktualisiert die Daten in der Ergebnismenge, sobald Sie dem Datenfenster ein Feld hinzufügen oder Kriterien im Kriterienfenster hinzufügen oder ändern. Wenn die Abfrage eine große Anzahl von Datensätzen umfasst, empfiehlt es sich, die Abfrage erst dann auszuführen, wenn Sie keine Änderungen mehr an der Abfrage vornehmen möchten.

  • Wenn eine Abfrage automatisch ausgeführt werden soll, sobald Sie neue Kriterien oder ein Feld hinzufügen, stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] niedergedrückt ist.

  • Wenn Sie eine Abfrage erst dann ausführen möchten, wenn Sie alle neuen Kriterien oder Felder hinzugefügt haben, stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht niedergedrückt ist. Um die Abfrage schließlich auszuführen, klicken Sie auf Jetzt abfragen [image] .


 Liefern einer Ergebnismenge an Microsoft Excel

Liefern einer Ergebnismenge an Microsoft Excel

  1. Wenn das Dialogfeld Externe Daten an Microsoft Excel zurückgeben nicht angezeigt wird, klicken Sie auf Daten zurückgeben [image] , und geben Sie beliebige von der Abfrage benötigte Parameterwerte ein, wenn Sie dazu aufgefordert werden.

  2. Klicken Sie auf Eigenschaften, um Optionen für die Formatierung und das Layout des externen Datenbereichs festzulegen, der an Microsoft Excel zurückgegeben wird. Weitere Informationen finden Sie in der Microsoft Excel-Hilfe.

  3. Um die Ergebnismenge in dem ausgewählten Tabellenblatt einzufügen, klicken Sie auf Bestehendes Arbeitsblatt. Klicken Sie in dem Tabellenblatt auf die Zelle, in die Sie die obere linke Ecke der Ergebnismenge einfügen möchten, und klicken Sie dann auf OK.

    Um die Ergebnismenge in einem neuen Tabellenblatt einzufügen, klicken Sie auf Als neues Blatt, und klicken Sie dann auf OK. Microsoft Excel fügt der Arbeitsmappe ein neues Tabellenblatt hinzu und fügt die Ergebnismenge automatisch in der oberen linken Ecke des neuen Tabellenblatts ein.

    Um die externen Daten in einem PivotTable-Bericht zu verwenden, klicken Sie auf PivotTable-Bericht, und klicken Sie dann auf OK.

Anmerkungen

  • Die Ergebnismenge wird automatisch in Microsoft Query aktualisiert, bevor das Dialogfeld Externe Daten an Excel zurückgeben angezeigt wird. Dies ist auch dann der Fall, wenn die Schaltfläche Auto Query [image] nicht gedrückt ist. Wenn Sie verhindern möchten, dass Query die Abfrage ausführt, bevor die Daten an Excel zurückgegeben werden, klicken Sie in Query im Menü Bearbeiten auf Optionen und deaktivieren Sie das Kontrollkästchen Gültigkeit von Abfragen vor dem Speichern oder Zurückgeben von Daten überprüfen.

  • Sie können den Status einer Abfrage überprüfen, die sehr viel Zeit für die Rückgabe von Daten in Anspruch nimmt. Klicken Sie in Excel auf der Symbolleiste Externe Daten auf Daten aktualisieren [image] . Um die Rückgabe von Daten abzubrechen, klicken Sie auf Aktualisierung abbrechen.


 Ausführen einer SQL-Anweisung oder -Prozedur

Ausführen einer SQL-Anweisung oder -Prozedur

Wenn Sie mit SQL (Structured Query Language) vertraut sind, können Sie SQL verwenden, um eine SELECT SQL-Anweisung auszuführen. Weitere Informationen zu SQL finden Sie in der Dokumentation der Datenbank.

  1. Klicken Sie im Menü Datei auf SQL ausführen.

    Um eine SQL-Anweisung für eine Tabelle in einer anderen Datenquelle auszuführen, klicken Sie auf Datenquellen, klicken Sie auf die gewünschte Datenquelle, und klicken Sie dann auf OK. Sie können auch eine neue Datenquelle angeben.

    Wie wird's gemacht?

  2. Geben Sie im Feld SQL-Anweisung die auszuführende SQL-Anweisung ein.

    Wenn Sie eine vorhandene SQL-Anweisung ausführen möchten, klicken Sie auf Öffnen, klicken Sie auf die SQL-Datei, und klicken Sie dann auf Öffnen.

    Um eine SQL-Prozedur auszuführen, die in der externen Datenbank gespeichert ist, klicken Sie auf Prozeduren, auf die gewünschte Prozedur im Feld Query und dann auf Einfügen, um die Prozedur in das Feld SQL-Anweisung zu kopieren.

  3. Klicken Sie auf Jetzt abfragen.

    Microsoft Query führt die SQL-Anweisung aus. Wenn die Rückgabe von Daten sehr lange dauert, können Sie die Abfrage abbrechen, indem Sie ESC drücken.

    Um die SQL-Anweisung zu speichern, klicken Sie auf Speichern.

Anmerkungen

  • Wenn Sie die SQL-Anweisung ändern oder ersetzen möchten, verwenden Sie die SQL-Syntax, die von Microsoft Query verwendet wird, oder die Syntax, die von der Datenquelle unterstützt wird. Microsoft Query versucht, die verwendete Syntax zu interpretieren, und zeigt sowohl den Abfrageentwurf als auch die Ergebnismenge der Abfrage an.

  • Wenn Microsoft Query den Abfrageentwurf nicht anzeigen kann, weil ein Teil der verwendeten Syntax nicht interpretiert werden konnte, wird die Ergebnismenge trotzdem angezeigt. Sie können jedoch lediglich die Formatierung der Ergebnismenge ändern, beispielsweise die angezeigte Schriftart oder die Spaltenbreite. Sie können keine Daten bearbeiten und müssen alle Änderungen, die Sie an der Abfragedefinition vornehmen möchten, beispielsweise das Hinzufügen oder Entfernen von Feldern, im Dialogfeld SQL vornehmen.

  • Wenn die Abfrage mehr als eine Ergebnismenge liefert, zeigt Microsoft Query die erste im Datenfenster an. Weitere Ergebnismengen werden nicht angezeigt.

  • Wenn die Abfrage erfolgreich durchgeführt wurde, jedoch keine Ergebnismenge zurückgibt, zeigt Microsoft Query eine Meldung an, dass die Anweisung erfolgreich ausgeführt wurde. Wenn Zeilen in den zugrunde liegenden Tabellen von der Abfrage betroffen sind, gibt die Meldung auch die Anzahl der betroffenen Zeilen an.

  • Wenn die Abfrage nicht erfolgreich durchgeführt wurde, zeigt Microsoft Query eine SQL-Fehlermeldung an, die auf das Problem hinweist. Um das Dialogfeld SQL ausführen anzuzeigen und die Anweisung zu korrigieren, klicken Sie auf OK.


 Info über OLAP-Abfragen

Info über OLAP-Abfragen

Microsoft Query bietet Ihnen die Möglichkeit, Daten aus OLAP-Datenbanken (On-Line Analytical Processing) zu erstellen und zu bearbeiten, indem Sie Datenquellen einrichten, OLAP-Cubes anhand relationaler Daten erstellen und Dateien für die OLAP-Cube-Definition speichern. In diesem Abschnitt wird erläutert, wie OLAP-Daten mit Hilfe von Microsoft Query für die Verwendung in Microsoft Excel PivotTable-Berichten und PivotChart-Berichten vorbereitet werden.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Was ist OLAP?

Verbinden mit OLAP-Datenbanken

Erstellen eines OLAP-Cubes aus den Datensätzen einer Abfrage

Speichern von OLAP-Abfragedateien

Was ist OLAP?

OLAP ermöglicht die Organisation umfangreicher Geschäftsdatenbanken. Bei der Organisation der OLAP-Daten berücksichtigt der Datenbankadministrator die Art und Weise, wie diese Daten von den Benutzern analysiert und verwaltet werden, so dass Zeit und Aufwand für das Erstellen der Berichte reduziert werden können.

Detailebenen In OLAP-Datenbanken werden Daten anhand von Detailebenen organisiert. Dabei werden dieselben Kategorien zugrunde gelegt, die auch beim Analysieren der Daten verwendet werden. Beispielsweise kann eine Datenbank mit weltweiten Handelsdaten für die Produkte eines Unternehmens verschiedene Felder für das Land, die Region, die Stadt und den Standort der einzelnen Vertriebsbüros enthalten. In einer OLAP-Datenbank können diese geographischen Daten folgendermaßen von der niedrigsten bis zur höchsten Detailebene angeordnet werden:

Ebenen einer geographischen Dimension

Ebenen einer geographischen Dimension

Durch diese Organisation ist es problemlos möglich, sowohl Absatzergebnisse auf höherer Ebene, wie z. B. den gesamten Absatz für ein Land oder eine Region, als auch Details für Standorte mit besonders hohem oder niedrigem Absatz anzuzeigen. In einem Microsoft Excel PivotTable-Bericht oder PivotChart-Bericht können zusammengefasste Daten auf verschiedenen Ebenen angezeigt werden. Wenn es sich um Ebenen mit einer größeren Anzahl von Details handelt, können Sie auch lediglich die Elemente anzeigen lassen, die für Sie von Interesse sind.

Dimensionen und Cubes Eine Gruppe von Ebenen, die einen bestimmten Datenaspekt umfasst (z. B. geographische Bereiche), wird als Dimension bezeichnet. Daten über den Zeitpunkt des Absatzes können beispielsweise in einer Zeitdimension angeordnet werden, die Ebenen für das Jahr, das Quartal, den Monat und den Tag enthält. OLAP-Datenbanken werden als Cubes bezeichnet, da in ihnen verschiedenen Dimensionen, wie z. B. Zeit, Geographie und Produkte mit zusammengefassten Daten wie Verkaufs- und Bestandszahlen kombiniert werden. In einer OLAP-Datenbank wird ein zusammengefasster Wert für jede Kombination aus einer beliebigen Ebene und Dimension berechnet. Dies kann z. B der gesamte Absatz für jeden Tag und Monat und jedes Jahr für jeden Standort, jede Region und jedes Land für sämtliche Produkte und Produktlinien sein.

Zurück zum Anfang

Verbinden mit OLAP-Datenbanken

OLAP-Anbieter Wenn Sie eine Verbindung zu einer OLAP-Datenbank herstellen möchten, benötigen Sie einen OLAP-Anbieter, der diesen bestimmten Typ der OLAP-Datenbank unterstützt. Microsoft Office enthält OLAP-Anbietersoftware für das Microsoft OLAP-Serverprodukt, Microsoft SQL Server OLAP Services. Für andere Produkte, die OLAP-Daten und -Dienste zur Verfügung stellen, müssen Sie zusätzliche Treiber und Clientsoftware installieren. Informationen über den Einsatz eines fremden OLAP-Anbieters erhalten Sie bei Ihrem Systemadministrator oder dem Lieferanten des OLAP-Produkts. Info über das Installieren von OLAP-Anbietern.

Datenquellen Die OLAP-Clientsoftware enthält einen Datenquellentreiber für die OLAP-Datenbank. Office enthält einen Treiber mit der Bezeichnung Microsoft OLE DB Provider for OLAP Services, mit dem auf Datenbanken zugegriffen werden kann, die unter Verwendung von Microsoft SQL Server OLAP Services erstellt wurden. Wenn Sie Cubes oder Offline-Cube-Dateien in Microsoft Query erstellen, werden ebenfalls Datenquellen für den Zugriff auf die Cubes erstellt.

Wenn Sie Microsoft Query ausführen, um eine Verbindung zu einer OLAP-Datenbank oder einer Offline-Cube-Datei herzustellen, richten Sie eine neue Datenquelle auf dieselbe Weise ein, wie für jede andere Art von Daten. Legen Sie jedoch außerdem auf der Registerkarte OLAP-Cubes im Dialogfeld Datenquelle auswählen einen Namen für die Datenquelle fest, geben Sie den Datenquellentreiber für den verwendeten OLAP-Anbieter an, und stellen Sie die Verbindung zu der Datenbank her. Einrichten einer Datenquelle.

Zurückgeben von Daten an Excel Nachdem eine OLAP-Datenquelle eingerichtet und zur Verwendung ausgewählt wurde, erstellen Sie jedoch keine Abfrage zum Auswählen von Tabellen und Feldern, wie für andere Datenarten. Die Datenquelle ermöglicht Ihnen den Zugriff auf alle Daten in dem OLAP-Cube. Die Datenfelder werden umgehend als PivotTable-Bericht an Excel übermittelt.

Zurück zum Anfang

Erstellen eines OLAP-Cubes aus den Datensätzen einer Abfrage

Mit Hilfe von Microsoft Query und der mit Microsoft Office zur Verfügung gestellten OLAP-Clientsoftware können Sie einen eigenen OLAP-Cube oder eine Offline-Cube-Datei aus den Daten erstellen, die von einer relationalen Datenbank, wie z. B. Microsoft SQL Server abgerufen werden. Durch das Erstellen eines OLAP-Cubes kann der Zugriff auf große Mengen relationaler Daten effizienter gestaltet werden. Außerdem bietet ein OLAP-Cube Unterstützung bei der Organisation der Daten, die in Berichten verwendet werden sollen. Um diesen Typ von OLAP-Cube zu erstellen und zu verwenden, wird kein OLAP-Serverprodukt benötigt.

Abrufen der Daten für den Cube Um einen Cube zu erstellen, müssen Sie zuerst für die relationale Datenbank eine Datenquelle einrichten, dann eine Abfrage erstellen, um die Daten abzurufen und anschließend den OLAP-Cube-Assistenten ausführen, um eine Cubestruktur für die abgefragten Daten zu definieren. Optional können Sie dann noch eine Offline-Cube-Datei speichern.

Erstellen eines im Speicher integrierten Cubes Der OLAP-Cube-Assistent bietet Ihnen die Möglichkeit, einen temporären Cube zu erstellen, der beim Öffnen eines auf dem Cube basierenden Berichts im Speicher wiederhergestellt wird. Informationen darüber, wann dieser Cubetyp erstellt wird, erhalten Sie in der Hilfe des OLAP-Cube-Assistenten. Info über das Ausführen des Assistenten zum Erstellen eines OLAP-Cubes.

Erstellen einer Offline-Cube-Datei Der OLAP-Cube-Assistent ermöglicht Ihnen auch die Erstellung einer Offline-Cube-Datei (.cub), die auf der lokalen Festplatte oder einer Netzfreigabe gespeichert werden kann. Wenn Sie die .cub-Datei auf der lokalen Festplatte speichern, können Sie mit der Bearbeitung der Daten fortfahren, auch wenn keine Verbindung zum Netzwerk besteht oder der Server nicht verfügbar ist. Wird die Datei auf einer Netzfreigabe gespeichert, können Sie gemeinsam mit anderen Benutzern Datenquellen einrichten, um auf die Offline-Cube-Datei zuzugreifen und Berichte auf der Basis dieser Datei zu erstellen. Info über das Ausführen des Assistenten zum Erstellen einer Offline-Cube-Datei.

Zurück zum Anfang

Speichern von OLAP-Abfragedateien

OLAP-Datenquellen Wenn Sie auf der Registerkarte OLAP-Cubes des Dialogfeldes Datenquelle auswählen eine Datenquelle einrichten, speichert Microsoft Query eine .oqy-Datei in Ihrem Benutzerprofil-Ordner im Verzeichnis Anwendungsdaten\Microsoft\Abfragen. Neben dem Festlegen der Datenquelle beim Erstellen eines PivotTable- oder PivotChart-Berichts in Excel können Sie zum Erstellen eines PivotTable-Reports die .oqy-Datei direkt in Excel öffnen. Wenn die .oqy-Datei mit einer OLAP-Serverdatenbank oder einer Offline-Cube-Datei auf einer Netzfreigabe verbunden ist, haben Sie die Möglichkeit, die .oqy-Datei für die Verwendung durch andere Benutzer freizugeben. Diese können die Datei dann zur Erstellung von Berichten öffnen, ohne dass sie eigene Datenquellen einrichten müssen.

Cubes des OLAP-Cube-Assistenten Nachdem Sie den letzten Schritt im OLAP-Cube-Assistenten durchgeführt haben, werden Sie zum Speichern einer Datei (.oqy) mit der Cube-Definition aufgefordert. Diese Datei enthält die Informationen, die Excel zum Aufbau des Cubes im Speicher oder zur Herstellung einer Verbindung mit einer Offline-Cube-Datei benötigt, sofern eine solche Datei erstellt wurde. Anstelle der Rückgabe der abgefragten Datensätze an Microsoft Excel können Sie diese Datei in Excel öffnen, um einen PivotTable-Bericht zu erstellen. Die Einrichtung einer separaten Datenquelle für den OLAP-Cube ist nicht erforderlich. Sie haben jedoch die Möglichkeit, für eine Offline-Cube-Datei eine separate Datenquelle einzurichten, wenn Sie zum Zweck der Berichterstellung eine direkte Verbindung mit der Cube-Datei herstellen möchten.

Das Speichern der .oqy-Datei ist nicht identisch mit dem Speichern einer Kopie der Abfrage der relationalen Datenbanksätze, anhand derer der OLAP-Cube erstellt wurde. Wenn Sie eine Kopie dieser Abfrage aufbewahren möchten, um dem Cube später Daten hinzuzufügen, müssen Sie die Abfrage in einer Datenbankdatei (.dqy) speichern.

Zurück zum Anfang


 Info über das Erstellen eines OLAP-Cubes aus relationalen Daten

Info über das Erstellen eines OLAP-Cubes aus relationalen Daten

In diesem Abschnitt wird erläutert, wie ein OLAP-Cube anhand einer Abfrage erstellt werden kann, die Daten aus einer relationalen Datenbank, wie z. B. Microsoft Access oder Microsoft SQL Server abruft. Für die Erstellung und Verwendung dieses Typs von OLAP-Cube ist kein OLAP-Serverprodukt erforderlich. Um dieses Leistungsmerkmal von Microsoft Query zu verstehen und sinnvoll einsetzen zu können, müssen Sie mit der Verwaltung von Datenbanken und der Verwendung von Microsoft Query zum Abrufen von Daten für Microsoft Excel PivotTable-Berichte oder PivotChart-Berichte vertraut sein.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Was ist ein OLAP-Cube?

Erstellen einer Datenabfrage

Erstellen eines Cubes

Aktualisieren und Ändern eines Cubes

Was ist ein OLAP-Cube?

Bei OLAP (On-Line Analytical Processing) handelt es sich um ein Verfahren zur Datenorganisation, in dem berücksichtigt wird, wie die Daten von Ihnen analysiert und verwaltet werden. Auf diese Weise wird die für die Berichterstellung benötigte Zeit und der Aufwand verringert. Beim Erstellen eines OLAP-Cubes anhand einer Abfrage werden die ungeordneten Datensätze in eine strukturierte Hierarchie, den Cube, übernommen. Dies ermöglicht in Berichten die Konzentration auf die gewünschte Detailebene. Außerdem legen Sie Voreinstellungen für die berechneten Werte der Berichte fest, was zu einer schnelleren Berichtsberechnung führt.

Erstellen Sie einen OLAP-Cube, wenn umfangreiche Mengen externer Daten für die Verwendung in Microsoft Excel-Berichten vorgesehen sind, insbesondere dann, wenn mehr Datensätze zu analysieren sind, als an Excel zurückgegeben werden können, ohne dass die Systemressourcen erschöpft sind. Da ein Cube Excel die Möglichkeit bietet, nur die Daten abzurufen, die für die aktuelle Ansicht erforderlich sind, kann ein Bericht bei großen Datenmengen normalerweise schneller erstellt und aktualisiert werden, als dies der Fall ist, wenn die vollständige Gruppe von Datensätzen aus der Datenbank abgerufen wird.

Die Daten aus dem OLAP-Cube können an Excel nur als PivotTable- oder PivotChart-Bericht zurückgegeben werden, im Gegensatz zu relationalen Datenbanksätzen in der Abfrage, die an Excel auch als externe Datenbereiche auf einem Arbeitsblatt zurückgegeben werden können.

Info über OLAP-Datenquellen und Abfragen.

Zurück zum Anfang

Erstellen einer Datenabfrage

Wenn Sie einen OLAP-Cube aus relationalen Datenbanksätzen erstellen möchten, müssen Sie für die relationale Datenbank eine Datenquelle einrichten und dann eine Abfrage erstellen, um die Felder und Datensätze abzurufen, die die Daten für den Cube enthalten.

Auswählen von Feldern für die Abfrage Um sicherzustellen, dass die Abfrage so effektiv wie möglich ausgeführt wird, übernehmen Sie nur die Tabellen und Felder in die Abfrage, die für den Cube benötigt werden. Stellen Sie jedoch sicher, dass alle gewünschten Felder hinzugefügt werden. Nach dem Erstellen eines Cubes können Sie in der Abfrage keine weiteren Felder mehr aufnehmen, die dann in den Cube übernommen werden. Wenn Sie einem Cube weitere Felder hinzufügen möchten, müssen Sie den Cube völlig neu erstellen.

Mehrfaches Hinzufügen von Feldern Manchmal muss ein Feld in einem Cube mehrmals verwendet werden. Dies kann z. B. der Fall sein, wenn die Inhalte eines Absatzfeldes auf zwei verschiedene Arten zusammengefasst werden sollen: Addieren der Verkaufsbeträge und Zählen der Verkäufe. Möglicherweise werden auch zwei Versionen eines Datumsfeldes benötigt: eines, in dem die Daten nach Quartal und Monat und ein weiteres, in dem sie nach Quartal und Woche sortiert sind. Wenn Sie ein Feld mehrmals in einem Cube verwenden möchten, müssen Sie der Abfrage das Feld einmal pro Einsatz hinzufügen. Fügen Sie das Absatzfeld der Abfrage beispielsweise zweimal hinzu, wenn die Werte in dem Feld sowohl addiert als auch gezählt werden sollen.

Genaue Angaben zum mehrfachen Hinzufügen eines Feldes in der Abfrage erhalten Sie in der Hilfe des OLAP-Cube-Assistenten. Wenn Sie der Abfrage Felder hinzufügen möchten, während der Assistent ausgeführt wird, können Sie den Assistenten beenden, die Felder hinzufügen und den Assistenten anschließend erneut starten.

Speichern der Abfrage Wenn Sie den Cube zu einem späteren Zeitpunkt möglicherweise mit anderen Feldern neu erstellen möchten, sollten Sie unbedingt die Abfrage in einer Datenbankabfragedatei (.dqy) speichern. Diese Datei können Sie dann öffnen, die Abfrage ändern und neue Cubes aus der geänderten Abfrage erstellen.

Zurück zum Anfang

Erstellen eines Cubes

Um einen Cube zu erstellen, öffnen Sie den OLAP-Cube-Assistenten. Anleitungen zu den einzelnen Schritten finden Sie in der Hilfe des Assistenten.

Temporäre Cubes und Offline-Cube-Dateien Der Assistent bietet Ihnen die Möglichkeit, zwei Cubetypen zu erstellen. Bei dem ersten Typ handelt es sich um eine Cube-Definition, die der Assistent in einer .oqy-Datei speichert. Wenn Sie einen Bericht öffnen, der auf dem .oqy-Dateityp basiert, wird der Cube temporär im Speicher erstellt. Der zweite Typ ist eine separate Offline-Cube-Datei, die auf der lokalen Festplatte oder einer Netzfreigabe gespeichert wird. Wird der Cube auf der lokalen Festplatte gespeichert, können Sie mit der Datenbearbeitung fortfahren, auch wenn keine Netzwerkverbindung besteht. Eine Offline-Cube-Datei kann als Datenquelle für Berichte eingerichtet werden.

Speichern einer Cubedefinitionsdatei Unabhängig davon, ob Sie eine separate Offline-Cube-Datei speichern, speichert der Assistent eine Cubedefinitionsdatei (.oqy). Diese Datei enthält die Informationen, die Microsoft Query benötigt, um den Cube zu laden, damit Sie Änderungen daran vornehmen können. Außerdem sind in dieser Datei die Informationen gespeichert, die in Excel benötigt werden, um den Cube entweder im Speicher aufzubauen oder eine Verbindung zu einer Offline-Cube-Datei herzustellen, sofern eine solche Datei erstellt wurde.

Verwenden der Cubedefinitionsdatei zum Erstellen von Berichten Anstatt die Datensätze aus der relationalen Datenbankabfrage an Microsoft Excel zurückzugeben, können Sie zum Erstellen eines PivotTable-Berichts, der auf den OLAP-Cube basiert, auch die .oqy-Datei in Excel öffnen. Anschließend haben Sie die Möglichkeit, den PivotTable-Bericht in einer Arbeitsmappe zu speichern oder PivotChart-Berichte auf der Grundlage des PivotTable-Berichts zu erstellen. Anleitungen zum Öffnen von .oqy-Dateien und Erstellen von Berichten erhalten Sie in der Hilfe zu Excel.

Zurück zum Anfang

Aktualisieren und Ändern eines Cubes

Aktualisieren eines OLAP-Cubes Um einen Cube zu aktualisieren, öffnen Sie in Microsoft Excel einen auf dem Cube basierenden Bericht und aktualisieren den Bericht. Dabei werden neue und geänderte Daten aus der ursprünglichen Datenbank in den Cube übernommen, wenn der Cube temporär im Speicher erstellt wurde. Handelt es sich bei dem Cube um eine Offline-Cube-Datei, wird die Datei mit den neuen Daten neu erstellt, und die vorhandene Datei wird ersetzt. Wenn Sie eigene Cubes erstellen und aktualisieren möchten, benötigen Sie einen OLAP-Anbieter, wie z. B. Microsoft SQL Server OLAP Services, der diese Funktionen unterstützt. Informationen zum Aktualisieren eines PivotTable- oder PivotChart-Berichts, der auf einem OLAP-Cube basiert, erhalten Sie in der Hilfe zu Excel.

Ändern eines OLAP-Cubes Sie können einen OLAP-Cube ändern, der im OLAP-Cube-Assistenten erstellt wurde, wenn Sie die Daten anders sortieren oder Felder entfernen möchten, die nicht in Berichten verwendet werden sollen. Falls Sie eine Offline-Cube-Datei erstellt haben, kann die geänderte Datei gespeichert werden.

Nachdem ein OLAP-Cube erstellt wurde, können diesem keine weiteren Felder mehr aus der ursprünglichen relationalen Datenbank hinzugefügt werden. Sie haben jedoch die Möglichkeit, aus derselben Datenbankabfragedatei (.dqy) einen neuen OLAP-Cube zu erstellen. Auf diese Weise können andere Felder aus der Originaldatenbank verwendet werden.

Zurück zum Anfang


 Erstellen eines OLAP-Cubes aus relationalen Daten

Erstellen eines OLAP-Cubes aus relationalen Daten

Die Daten aus dem OLAP-Cube können nur in Form eines PivotTable-Berichts und nicht als externer Datenbereich auf einem Tabellenblatt an Microsoft Excel zurückgegeben werden.

  1. Erstellen Sie eine Abfrage, mit der die Felder abgerufen werden, die in dem Cube verwendet werden sollen.

    Vorgehensweise

  2. Zum Öffnen des OLAP-Cube-Assistenten stehen Ihnen zwei Möglichkeiten zur Verfügung:

    Wenn die Abfrage im Query-Assistenten erstellt wurde, klicken Sie im letzten Schritt des Assistenten auf Einen OLAP-Cube aus dieser Abfrage erstellen, und klicken Sie dann auf Fertig stellen.

    Wenn die Abfrage in Microsoft Query erstellt wurde, klicken Sie im Menü Datei auf OLAP-Cube erstellen.

  3. Führen Sie die Schritte im OLAP-Cube-Assistenten aus. Weitere Anweisungen erhalten Sie in der Hilfe des OLAP-Cube-Assistenten.

  4. Wenn Sie alle erforderlichen Einstellungen in dem Assistenten vorgenommen haben, fordert Query Sie zum Speichern einer Datei mit der Cube-Definition (.oqy-Datei) auf. Geben Sie einen Namen für die Datei ein, und klicken Sie dann auf Speichern.

Anmerkungen

  • Wenn Sie im OLAP-Cube-Assistenten eine Offline-Cube-Datei (.cub) angegeben haben, wird die .cub-Datei erstellt, nachdem Sie auf Speichern geklickt haben. Je nachdem, wie umfangreich die Datenmenge für den Cube ist, kann das Speichern dieser Datei sehr zeitaufwendig sein. In Microsoft Query können erst wieder weitere Aktionen durchgeführt werden, nachdem die Erstellung der Offline-Cube-Datei abgeschlossen ist.

  • Wenn weitere Microsoft Excel-Berichte auf dem Cube basieren sollen, geben Sie die abgefragten Daten nicht an Excel zurück. Öffnen Sie stattdessen die .oqy-Datei unter Verwendung des Befehls Öffnen im Excel-Menü Datei.

  • Sie können Excel-Berichte auch auf der Basis einer Offline-Cube-Datei erstellen, indem Sie für die Datei eine Datenquelle einrichten und dann diese Datenquelle beim Ausführen des Excel PivotTable- und PivotChart-Assistenten angeben.

  • Wenn Sie dem Cube möglicherweise zu einem späteren Zeitpunkt Felder aus der Quelldatenbank hinzufügen möchten, sollten Sie unbedingt eine Datenbankabfragedatei (.dqy) speichern. Diese Abfragedatei kann dann zum Ändern des Cubes verwendet werden.


 Ändern des Inhalts und der Einstellungen eines OLAP-Cubes

Ändern des Inhalts und der Einstellungen eines OLAP-Cubes

Sie können die Organisation der Felder in einem Cube ändern und nicht mehr benötigte Felder entfernen. Es ist jedoch nicht möglich, einem bestehenden OLAP-Cube weitere Felder hinzuzufügen. Wenn Sie einem OLAP-Cube weitere Felder hinzufügen möchten, müssen Sie einen neuen Cube erstellen.

  1. Klicken Sie in Microsoft Query im Menü Datei auf Öffnen.

  2. Klicken Sie in der Liste Dateityp auf OLAP-Cubes.

  3. Doppelklicken Sie auf die Datei mit der Cube-Definition (.oqy-Datei) für den zu ändernden Cube.

  4. Führen Sie die Schritte im OLAP-Cube-Assistenten aus, um den Inhalt und die Einstellungen zu ändern. Weitere Anweisungen erhalten Sie in der Hilfe im OLAP-Cube-Assistenten.

  5. Nachdem Sie den Assistenten beendet haben, fordert Query Sie zum Speichern der .oqy-Datei auf. Um die vorhandene .oqy-Datei zu ersetzen, klicken Sie auf Speichern. Wenn Sie eine neue .oqy-Datei speichern möchten, geben Sie einen neuen Namen für die Datei ein und klicken dann auf Speichern.

Anmerkungen

  • Wurde von Ihnen eine Offline-Cube-Datei (.cub) in dem OLAP-Cube-Assistenten angegeben, wird die Datei erstellt, nachdem Sie auf Speichern geklickt haben. Wenn Sie eine vorhandene .cub-Datei ändern, muss diese vollständig neu erstellt werden. Die bestehende Datei wird dann durch die neue Datei ersetzt. Je nachdem, wie umfangreich die Datenmenge für den Cube ist, kann das Speichern dieser Datei sehr zeitaufwendig sein. In Microsoft Query können erst wieder Aktionen durchgeführt werden, nachdem die Erstellung der .cub-Datei abgeschlossen ist.

  • Zum Erstellen von Microsoft Excel-Berichten auf der Basis einer .cub-Datei können Sie die .oqy-Datei unter Verwendung des Befehls Öffnen im Excel-Menü Datei öffnen. Sie haben jedoch auch die Möglichkeit, für die .cub-Datei eine Datenquelle einzurichten, die Sie dann bei der Ausführung des Excel PivotTable- und PivotChart-Assistenten angeben.


 Löschen einer Offline-Cube-Datei

Löschen einer Offline-Cube-Datei

Beim Löschen einer Offline-Cube-Datei (.cub) wird diese endgültig von der Festplatte entfernt, auf der sie gespeichert war. Hierdurch wird der häufig sehr umfangreiche durch diese Dateien belegte Festplattenspeicher wieder freigegeben. Sie können nun jedoch keine Berichte mehr ändern, denen die Datei zugrunde lag. Wenn Datenquellen erstellt wurden, für die die Datei verwendet wurde, können diese nun auch nicht mehr genutzt werden.

  • Löschen Sie in Microsoft Windows die .cub-Datei.


 Hinzufügen einer Tabelle zu einer Abfrage

Hinzufügen einer Tabelle zu einer Abfrage

  1. Klicken Sie auf Tabellen hinzufügen [image] .

  2. Wählen Sie die hinzuzufügende Tabelle aus.

  3. Klicken Sie auf Hinzufügen.

Anmerkung Sie können der Abfrage beliebig viele Abfragen hinzufügen. Klicken Sie nach Abschluss des Verfahrens auf Schließen.


Entfernen einer Tabelle aus einer Abfrage

  1. Klicken Sie auf die zu löschende Tabelle.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.


 Hinzufügen oder Entfernen eines Feldes

Hinzufügen oder Entfernen eines Feldes

Ein Feld ist eine Informationskategorie, wie z. B. ein Produktname oder eine Bestellsumme, die in einer Tabelle einer Datenbank gespeichert ist. Wird ein Feld hinzugefügt oder entfernt, werden die Informationen dieses Feldes bei der Abfrage berücksichtigt bzw. ausgeschlossen. Die zugrunde liegende Datenbank, die diese Informationen enthält, wird nicht geändert.

Hinzufügen eines Feldes Um die Ergebnismenge eines einzelnen Feldes hinzuzufügen, doppelklicken Sie im Tabellenfenster auf das Feld, das Sie hinzufügen möchten.

Beispiel eines in der Tabelle markierten Feldes

Entfernen eines Feldes Um ein Feld aus der Ergebnismenge zu entfernen, klicken Sie auf die Spaltenüberschrift des Feldes, das Sie im Datenauschnitt löschen möchten, und klicken Sie dann im Menü Datensätze auf Spalte entfernen.

Tipps

  • Wenn Sie gleichzeitig mehrere Felder derselben Tabelle hinzufügen möchten, halten Sie die STRG-TASTE gedrückt und klicken Sie auf die gewünschten Felder. Ziehen Sie dann die markierten Felder in das Datenfenster.

  • Um alle Felder einer Tabelle zur Ergebnismenge hinzuzufügen, doppelklicken Sie oben im Tabellenfenster auf * (Sternchen).

    Beispiel eines im Tabellenfenster markierten Sternchens (*)


Abrufen verwandter Datensätze aus mehreren Tabellen mit Verknüpfungen

Klicken Sie auf die Grafik, um das Thema anzuzeigen.

Klicken Sie auf die Grafik, um das Thema anzuzeigen


Verknüpfen von Tabellen in einer Abfrage

Wenn Ihre Abfrage mehr als eine Tabelle umfasst, können Sie zusammenhängende Datensätze aus mehreren Tabellen abrufen, indem Sie mit Verknüpfungen arbeiten. Eine Verknüpfung ist eine Verbindung zwischen zwei Tabellen, bei denen ein Feld in der einen Tabelle die gleichen Daten wie ein Feld in der anderen Tabelle enthält.

Was möchten Sie tun?

Mehr über das Abrufen von Datensätzen mit Exklusions- und Inklusionsverknüpfungen erfahren

Eine Exklusionsverknüpfung erstellen

Eine Inklusionsverknüpfung erstellen

Eine Reflexivverknüpfung erstellen

Alle Datensätze zweier Tabellen abrufen

Nur die Datensätze abrufen, durch die sich zwei Tabellen unterscheiden


 Kombinieren aller Daten aus zwei Tabellen

Kombinieren aller Daten aus zwei Tabellen

Wenn Sie sämtliche Daten aus zwei Tabellen mit ähnlichen, jedoch nicht identischen Daten zusammenführen möchten, z. B. zwei Listen (Tabellen) mit Kunden, die unterschiedliche Kundeninformationen (Feldern) enthalten, und jede Liste enthält Kunden, die in der anderen Liste nicht aufgeführt werden, können Sie eine Abfrage erstellen, die alle Kunden umfasst. Dieser Abfragetyp wird vollständige Inklusionsverknüpfung genannt. Zeigen Sie weitere Informationen zu vollständigen Inklusionsverknüpfungen an.

  1. Erstellen Sie in Microsoft Query eine Abfrage, und fügen Sie beide Tabellen hinzu.

  2. Verknüpfen Sie ein in beiden Tabellen enthaltenes Feld (z. B. das Feld Kundennummer in zwei Kundenlisten), indem Sie das Feld von der ersten Tabelle in die zweite Tabelle ziehen.

    Wählen Sie ein Feld, das in beiden Tabellen in jedem Datensatz Daten enthält. Wenn beispielsweise zwei Kundenlisten übereinstimmende Felder für die Kundennummer haben, verknüpfen Sie diese.

  3. Doppelklicken Sie auf die Verknüpfungslinie zwischen den beiden Tabellen.

  4. Klicken Sie im Dialogfeld Verknüpfungen auf die Option 2, klicken Sie auf Hinzufügen, und klicken Sie dann auf Schließen.

  5. Fügen Sie der Abfrage die gewünschten Felder hinzu.

  6. Klicken Sie im Menü Ansicht auf SQL.

  7. Wählen Sie im Feld SQL-Anweisung die Daten aus, drücken Sie zum Kopieren STRG+C, und klicken Sie dann auf OK.

  8. Doppelklicken Sie erneut auf die Verknüpfungslinie.

  9. Klicken Sie im Dialogfeld Verknüpfungen auf Option 3, klicken Sie auf Hinzufügen, und klicken Sie dann auf Schließen.

  10. Klicken Sie im Menü Ansicht auf SQL.

  11. Setzen Sie die Einfügemarke an das Ende des Feldes SQL-Anweisung, drücken Sie die EINGABETASTE, geben Sie das Wort UNION in Großbuchstaben ein, und drücken Sie dann erneut die EINGABETASTE:
  12. Drücken Sie STRG+V, um die kopierten Informationen nach dem Wort UNION einzufügen.

  13. Klicken Sie auf OK, und bestätigen Sie die Meldung, dass die Abfrage nicht grafisch angezeigt werden kann, indem Sie erneut auf OK klicken.


 Abrufen der Datensätze aus zwei Tabellen, die jeweils unterschiedlich sind

Abrufen der Datensätze aus zwei Tabellen, die jeweils unterschiedlich sind

Wenn Sie über zwei Tabellen mit ähnlichen Daten verfügen, z. B. zwei Listen (Tabellen) mit Kunden, und jede Liste enthält Kunden, die in der anderen Liste nicht enthalten sind, können Sie eine Abfrage erstellen, die nur die Datensätze der ersten Tabelle zurückgibt, die in der zweiten Tabelle keine Entsprechung haben. Dieser Abfragetyp wird als exklusive Abfrage oder exklusive Verknüpfung bezeichnet.

  1. Erstellen Sie in Microsoft Query eine Abfrage, und fügen Sie ihr beide Tabellen hinzu.

  2. Verknüpfen Sie ein in beiden Tabellen enthaltenes Feld (z. B. das Feld Kundennummer in den beiden Kundenlisten), indem Sie das Feld der ersten Tabelle in die zweite Tabelle ziehen.

  3. Doppelklicken Sie auf die Verknüpfungslinie zwischen den beiden Tabellen.

  4. Klicken Sie im Dialogfeld Verknüpfungen auf Option 2, klicken Sie auf Hinzufügen, und klicken Sie dann auf Schließen.

  5. Fügen Sie der Abfrage das verknüpfte Feld hinzu.

  6. Fügen Sie ein anderes als das verknüpfte Feld aus der zweiten Tabelle hinzu. Wählen Sie ein Feld, das in der zweiten Tabelle in jedem Datensatz Daten enthält. Wenn Sie beispielsweise die Felder mit den Kundennummern aus den beiden Tabellen verknüpft haben, können Sie das Feld mit den Kundennamen aus der zweiten Tabelle hinzufügen.

  7. Klicken Sie im Menü Ansicht auf Kriterien.

  8. Klicken Sie im ersten Kriterienfeld auf das in Schritt 6 hinzugefügte Feld.

  9. Geben Sie Ist Null im ersten Feld Wert ein.

  10. Zum Anzeigen der Datensätze der ersten Tabelle, die nicht in der zweiten Tabelle enthalten sind, klicken Sie auf Jetzt abfragen [image] .

  11. Fügen Sie der Abfrage beliebige weitere Felder hinzu, und geben Sie die Daten dann an Microsoft Excel zurück.

Anmerkung Um auch die Datensätze aus der zweiten Tabelle abzufragen, denen keine Datensätze aus der ersten Tabelle entsprechen, erstellen Sie nach dem oben beschriebenen Verfahren eine zweite Abfrage, kehren Sie dabei jedoch die Reihenfolge der Tabellen um (die erste Tabelle wird die zweite und umgekehrt).


 Erstellen einer Exklusionsverknüpfung

Erstellen einer Exklusionsverknüpfung

Mit einer Exklusionsverknüpfung werden alle Datensätze der einen Tabelle und die jeweiligen Datensätze aus verknüpften Datensätzen einer anderen Tabelle angezeigt.

  1. Erstellen Sie eine Exklusionsverknüpfung zwischen den Tabellen. So erstellen Sie eine Exklusionsverknüpfung.

  2. Doppelklicken Sie auf die Verknüpfungslinie zwischen den Tabellen.

  3. Klicken Sie in der Liste Operator auf das Gleichheitszeichen (=).

  4. Gehen Sie nach einer der folgenden Methoden vor:

    Klicken Sie zum Erstellen einer Inklusionsverknüpfung, bei der alle Datensätze der linken Tabelle verwendet werden, unter Verknüpfung enthält auf Option 2.

    Klicken Sie zum Erstellen einer Exklusionsverknüpfung, bei der alle Datensätze aus der rechten Tabelle verwendet werden, unter Verknüpfung enthält auf Option 3.

Anmerkungen

  • Alle Datensätze zweier Tabellen abrufen Wenn Sie alle Datensätze aus zwei Tabellen kombinieren möchten, können Sie, ungeachtet, ob die Datensätze verknüpft sind oder nicht, eine vollständige Exklusionsverknüpfung erstellen.

  • Nur die Datensätze abrufen, durch die sich zwei Tabellen unterscheiden Anstatt verknüpfte Datensätze abzurufen, können Sie auch alle Datensätze abrufen, durch die sich zwei Tabellen unterscheiden.


Erstellen einer Reflexivverknüpfung

Gehen Sie nach der hier beschriebenen Methode vor, wenn Sie Informationen aus zwei Ausgaben einer Tabelle kombinieren möchten. Beispiel: Eine Tabelle mit Mitarbeiterinformationen enthält die Personal-Nr des Managers für jeden Mitarbeiter. Sie möchten nun die ID mit dem Namen des Managers verknüpfen. Mit dieser Methode wird ein Abfragetyp erstellt, der als Reflexivverknüpfung bezeichnet wird. Weitere Informationen zu Reflexivverknüpfungen.

  1. Erstellen Sie in Microsoft Query eine Abfrage, und fügen Sie die Tabelle hinzu, für die eine Reflexivverknüpfung in der Abfrage erstellt werden soll.

  2. Fügen Sie dieselbe Tabelle ein zweites Mal zur Abfrage hinzu.

  3. Wenn in einer Meldung darauf hingewiesen wird, dass die Tabelle bereits Teil der Abfrage ist, klicken Sie auf OK.

  4. Wenn Query automatisch die Tabellen verknüpft, doppelklicken Sie auf die Verknüpfungslinie, klicken Sie auf Entfernen, und klicken Sie dann auf Schließen.

  5. Erstellen Sie eine Exklusionsverknüpfung zwischen den beiden Tabellen. Wenn zum Beispiel im Managerfeld die Manager über die Personal-Nr angegeben werden, können Sie das Managerfeld in der ersten Tabelle mit dem Feld mit der Personal-Nr in der zweiten Tabelle verknüpfen.

  6. Fügen Sie die gewünschten Felder zur Abfrage hinzu. Sie können zum Beispiel die Felder mit dem Mitarbeiternamen und dem Manger aus der ersten Tabelle hinzufügen und dann das Feld mit dem Mitarbeiternamen aus der zweiten Tabelle hinzufügen, damit die Namen der Manager für jeden Mitarbeiter angezeigt werden.


Operatoren in Verknüpfungen

In Verknüpfungen können Sie die folgenden Operatoren verwenden:

Operator | Beschreibung
= (Gleich) | Wählt Datensätze mit identischen Werten in den verknüpften Feldern aus.
<> (Nicht gleich) | Wählt Datensätze mit nicht identischen Werten in den verknüpften Feldern aus.
> (Größer als) | Wählt die Datensätze der linken Tabelle aus, deren Werte in den verknüpften Feldern größer sind als die Werte in den Datensätzen der rechten Tabelle.
>= (Größer oder gleich) | Wählt die Datensätze der linken Tabelle aus, deren Werte in den verknüpften Feldern größer oder gleich den Werten in den Datensätzen der rechten Tabelle sind.
< (Kleiner als) | Wählt die Datensätze der linken Tabelle aus, deren Werte in den verknüpften Feldern kleiner als die Werte in den Datensätzen der rechten Tabelle sind.
<= (Kleiner oder gleich) | Wählt die Datensätze der linken Tabelle aus, deren Werte in den verknüpften Feldern kleiner oder gleich den Werten in den Datensätzen der rechten Tabelle sind.


 Entfernen einer Verknüpfung

Entfernen einer Verknüpfung

Wenn die Abfrage eine Exklusionsverknüpfung oder eine Inklusionsverknüpfung enthält, jedoch nicht die gewünschten Datensätze abgerufen werden, sollten Sie die Verknüpfung entfernen.

  1. Klicken Sie im Tabellenfenster auf die zu entfernende Verknüpfungslinie.

  2. Drücken Sie ENTF.

Anmerkungen

  • Beim Entfernen einer Verknüpfung ändern sich die in der Ergebnismenge enthaltenen Datensätze. Je nach Art der entfernten Verknüpfung werden Datensätze hinzugefügt bzw. entfernt.

  • Das Löschen einer Verknüpfung aus einer Abfrage wirkt sich nur auf die Abfrage aus. Wenn Microsoft Query z. B. automatisch eine Exklusionsverknüpfung zwischen zwei Tabellen in der Abfrage erstellt und Sie diese entfernen, erstellt Microsoft Query automatisch eine neue Exklusionsverknüpfung zwischen den Tabellen, wenn Sie diese in einer anderen Abfrage verwenden.


Info über die Verwendung von Kriterien

Klicken Sie auf die Grafik, um das Thema anzuzeigen.

Klicken Sie auf die Grafik, um das Thema anzuzeigen


 Gezieltes Abrufen von Datensätzen mit Hilfe von Kriterien

Gezieltes Abrufen von Datensätzen mit Hilfe von Kriterien

Sie können bestimmte Datensätze abrufen, indem Sie mit Kriterien arbeiten. Microsoft Query verwendet die von Ihnen angegebenen Kriterien zum Aufrufen der gewünschten Datensätze und zeigt diese in der Ergebnismenge an. Um die Anzahl der abgerufenen Datensätze zu beschränken, können Sie einen Wert in der Ergebnismenge auswählen und dann weitere Datensätze suchen, die diesem Wert entsprechen. Oder Sie können im Kriterienfenster ein spezifisches Kriterium erstellen und dann die Datensätze abrufen, die nur diesem Kriterium entsprechen.

Was möchten Sie tun?

Mehr zur Verwendung von Kriterien erfahren

Datensätze abrufen, die mit einem bestimmten Wert übereinstimmen

Mit Hilfe von Kriterien festlegen, welche Datensätze abgerufen werden sollen

Beispiele für Ausdrücke anzeigen, die als Kriterien verwendet werden können


 Verwenden von Kriterien zur Festlegung der abzurufenden Datensätze

Verwenden von Kriterien zur Festlegung der abzurufenden Datensätze

  1. Klicken Sie auf Kriterien ein-/ausblenden [image] .

    Microsoft Query zeigt das Kriterienfenster an.

  2. Klicken Sie im Kriterienfenster auf die erste Zelle in der Zeile Kriterienfeld, und klicken Sie dann auf das Feld, auf das Kriterien angewendet werden sollen.

    Wenn die Abfrage mehrere Tabellen mit ähnlichen Feldnamen verwendet, stellen Sie sicher, dass Sie in der richtigen Tabelle auf das gewünschte Feld klicken.

  3. Klicken Sie in der Zeile Wert auf die Zelle direkt unter dem Feld, das Sie in der Zeile Kriterienfeld ausgewählt haben.

  4. Geben Sie die Kriterien ein, die Microsoft Query bei der Auswahl der Datensätze verwenden soll, und drücken Sie dann die EINGABETASTE.

    Wie wird's gemacht?

  5. Sie müssen gegebenenfalls die Felder hinzufügen, die in der Ergebnismenge angezeigt werden sollen.

    Wie wird's gemacht?

    Wenn Sie Datensätze aus verschiedenen Tabellen anzeigen möchten, stellen Sie sicher, dass Sie diese Tabellen dem Datenfenster in der Abfrage hinzugefügt haben. Weitere Informationen zum Hinzufügen von Tabellen erhalten Sie, indem Sie auf [image] klicken.

Anmerkungen

  • Sie können die Ergebnismenge weiter einschränken, indem Sie dem Kriterienfenster zusätzliche Kriterien hinzufügen. Beispielsweise können Sie alle Datensätze mit Lieferanten suchen, die Milchprodukte liefern und außerdem aus Norwegen oder Italien stammen. Um diese Datensätze auszuwählen, würden Sie im Kriterienfenster zwei Kriteriensätze eingeben. Zuerst klicken Sie im Feld Kriterienfeld auf Land, und geben Sie dann Norwegen Oder Italien im Feld Wert ein. Anschließend klicken Sie im nächsten Feld Kriterienfeld auf Kategorie, und geben Sie =Milchprodukte in dem zugehörigen Feld Wert ein.

  • Wenn der Wert, den Sie als Kriterium verwenden möchten, bereits in der Ergebnismenge angezeigt wird, können Sie diesen in das Kriterienfenster kopieren. Klicken Sie in der Ergebnismenge auf den zu kopierenden Wert, klicken Sie im Menü Bearbeiten auf Kopie erstellen, klicken Sie in der Zeile Wert auf die Zelle, in die Sie den Wert einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

  • Um lange Wartezeiten bei der Rückgabe von Daten für jedes Feld zu vermeiden, können Sie mit dem Ausführen der Abfrage warten, bis Sie der Ergebnismenge alle Felder hinzugefügt haben. Wenn Sie die Daten zu einem späteren Zeitpunkt abrufen möchten, stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht niedergedrückt ist. Wenn die Abfrage schließlich ausgeführt werden soll, klicken Sie auf Jetzt abfragen [image] .

  • Sie können eine Abfrage abbrechen, deren Ausführung sehr lange dauert, indem Sie ESC drücken.


 Abrufen von Datensätzen, die mit einem bestimmten Wert übereinstimmen

Abrufen von Datensätzen, die mit einem bestimmten Wert übereinstimmen

  1. Stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] niedergedrückt ist.

  2. Fügen Sie das Feld, für das Sie Kriterien festlegen möchten, dem Datenfenster hinzu.

    Wie wird's gemacht?

    Wenn Sie beispielsweise Datensätze abrufen möchten, die im Feld Land den Wert Frankreich enthalten, fügen Sie das Feld Land dem Datenfenster hinzu.

  3. Klicken Sie in der Ergebnismenge auf eine Zelle, deren Wert mit dem der Datensätze verglichen werden soll.

  4. Klicken Sie auf Kriterium wie Auswahl [image] .


 Beispiele für Ausdrücke

Beispiele für Ausdrücke

Unter einem Ausdruck versteht man eine Berechnung, in der eine Kombination aus Operatoren, Funktionen, Feldnamen und Konstanten verwendet wird. Sie können einen Ausdruck als Kriterium zur Auswahl von Datensätzen verwenden. Wenn Sie im Kriterienfenster einen Ausdruck verwenden möchten, wählen Sie zunächst im Kriterienfeld das Feld aus, das den zu berechnenden Wert enthält, und geben dann im Feld Wert den gewünschten Operator und den Wert ein.

Welches Beispiel möchten Sie anzeigen?

Ausdrücke anzeigen, in denen arithmetische Operatoren verwendet werden

Ausdrücke anzeigen, in denen Vergleichsoperatoren verwendet werden

Ausdrücke anzeigen, in denen logische Operatoren verwendet werden

Ausdrücke anzeigen, in denen andere Arten von Operatoren verwendet werden

Sie wissen nicht, welche Auswahl Sie treffen sollen?


 Wiederherstellen der vollständigen Ergebnismenge durch Entfernen von Kriterien

Wiederherstellen der vollständigen Ergebnismenge durch Entfernen von Kriterien

Wenn die Abfrage eine Vielzahl von Datensätzen enthält, können Sie Zeit sparen, indem Sie die Aktualisierung der Ergebnismenge erst dann durchführen, wenn Sie alle Kriterien entfernt haben. Wenn Sie die Ergebnismenge zu einem späteren Zeitpunkt aktualisieren möchten, stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht niedergedrückt ist.

  1. Klicken Sie im Kriterienfenster auf die Spaltenüberschrift der Spalte, die die zu löschenden Kriterien enthält.

  2. Drücken Sie ENTF.

    Wiederholen Sie die Schritte 1 und 2 für alle zu entfernenden Kriteriensätze.

    Um alle Kriterien in einem Schritt zu entfernen, klicken Sie im Menü Kriterien auf Alle Kriterien entfernen.

Anmerkung Wenn die Schaltfläche AutoAbfrage nicht gedrückt ist, müssen Sie auf Jetzt abfragen [image] klicken, um die vollständige Ergebnismenge wiederherzustellen.


 Erstellen eines berechneten Feldes

Erstellen eines berechneten Feldes

Sie können die Ergebnisse einer angegebenen Berechnung anzeigen, indem Sie ein neues Feld erstellen, ein sogenanntes berechnetes Feld. Sie können ein berechnetes Feld erstellen, indem Sie einen Ausdruck eingeben; hierbei handelt es sich um eine Berechnung, in der eine Kombination von Operatoren, Funktionen, Feldnamen und Konstanten verwendet wird. Sie können auch eine integrierte Funktion verwenden, um Ergebnisse in einem Feld zu berechnen.

Was möchten Sie tun?

Ein berechnetes Feld unter Verwendung eines Ausdrucks erstellen

Ein berechnetes Feld unter Verwendung einer integrierten Funktion erstellen


 Erstellen eines berechneten Feldes unter Verwendung eines Ausdrucks

Erstellen eines berechneten Feldes unter Verwendung eines Ausdrucks

  1. Klicken Sie im Datenfenster auf eine leere Spaltenüberschrift.

  2. Geben Sie den Ausdruck für die Berechnung ein, und drücken Sie dann die EINGABETASTE. Geben Sie am Anfang des Ausdrucks kein Gleichheitszeichen (=) ein.

    Wenn beispielsweise Mitarbeiter eine Provision erhalten, die 15 Prozent ihres Gesamtumsatzes entspricht, können Sie die Provision für die einzelnen Mitarbeiter berechnen, indem Sie die Verkäufe der jeweiligen Mitarbeiter addieren und dann die Summe mit 0,15 multiplizieren.

    Beispiele für Ausdrücke, in denen arithmetische Operatoren verwendet werden, erhalten Sie, indem Sie auf [image] klicken.


 Beispiele für Ausdrücke mit arithmetischen Operatoren

Beispiele für Ausdrücke mit arithmetischen Operatoren

Arithmetische Operatoren führen grundlegende mathematische Operationen durch, z. B. Additionen, Subtraktionen, Multiplikationen und Divisionen, und erzeugen numerische Ergebnisse. Sie können arithmetische Operatoren in einem Ausdruck im Kriterienfenster oder in einem berechneten Feld verwenden.

Arithmetischer Operator | Bedeutung | Beispiel | Syntax
+ (Pluszeichen) | Addition | Vom Kunden zu zahlender Gesamtpreis | Bestellwert+Versandkosten
– (Minuszeichen) | Subtraktion | Gesamtwert einer Bestellung, abzüglich etwaiger Rabatte | Bestellwert-Rabatt
* (Sternchen) | Multiplikation | Gesamtwert einer Bestellung für ein bestimmtes Produkt | Stückpreis*Anzahl
/ (Schrägstrich) | Division | Stückpreis | Bestellwert/Anzahl


 Erstellen eines berechneten Feldes unter Verwendung einer Funktion

Erstellen eines berechneten Feldes unter Verwendung einer Funktion

  1. Fügen Sie ein Feld hinzu, das die zu berechnenden Werte enthält.

    Wie wird's gemacht?

  2. Klicken Sie auf eine beliebige Stelle in dem zu berechnenden Feld, und klicken Sie dann auf Gruppierungsfunktion anwenden [image] .

  3. Klicken Sie so oft auf Gruppierungsfunktion anwenden, bis Microsoft Query den gewünschten Ergebnistyp anzeigt.

    Bei jedem Klicken auf Gruppierungsfunktion anwenden berechnet Microsoft Query das Feld und zeigt einen anderen Ergebnistyp an (die verwendete Funktion wird in der Spaltenüberschrift angegeben). Eine Beschreibung der Funktionen, die für die Berechnung von Ergebnissen in einem berechneten Feld verwendet werden können, erhalten Sie, indem Sie auf [image] klicken.

  4. Wenn Sie die Funktion ausgewählt haben, die den gewünschten Ergebnistyp liefert, klicken Sie auf Jetzt abfragen [image] , um das Ergebnis des berechneten Feldes anzuzeigen.

Anmerkungen

  • Wenn Sie eine Berechnung aus einem Feld entfernen möchten, klicken Sie so oft auf Gruppierungsfunktion anwenden, bis die Spaltenüberschrift wieder den Feldnamen enthält.

  • Wenn eine Abfrage eine Vielzahl von Datensätzen enthält, können Sie Zeit sparen, indem Sie die Ergebnisse des berechneten Feldes erst dann anzeigen, wenn Sie die gewünschte Funktion ausgewählt haben. Stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht niedergedrückt ist.


 Funktionen zur Verwendung in einem berechneten Feld

Funktionen zur Verwendung in einem berechneten Feld

Eine Funktion gibt einen Wert zurück, der auf den Ergebnissen einer Berechnung oder einer anderen Operation basiert. Beispielsweise gibt die Funktion SUMME als Ergebnis die Summe zweier oder mehrerer Werte zurück. Microsoft Query unterstützt die unten aufgeführten Funktionen. Welche Funktionen tatsächlich für eine Datenquelle verfügbar sind, hängt von dem ODBC-Treiber für die Datenquelle ab. Um die Funktionen anzuzeigen, die für die aktive Datenquelle verfügbar sind, klicken Sie auf ein numerisches Feld und dann auf Gruppierungsfunktion anwenden [image] .

Gewünschter Wert | Funktion
Der Mittelwert einer Reihe von Werten in einem Feld | MITTELWERT
Die Gesamtzahl der Datensätze | ANZAHL
Der höchste Wert einer Reihe von Werten in einem Feld | MAX
Der niedrigste Wert in einer Reihe von Werten in einem Feld | MIN
Die Summe einer Reihe von Werten in einem Feld | SUMME


 Ändern des Layouts einer Ergebnismenge

Ändern des Layouts einer Ergebnismenge

Wenn Sie Felder einfügen oder die Anordnung von Feldern ändern, bleiben die Layoutänderungen erhalten, solange Sie in Microsoft Query arbeiten und wenn Sie die Ergebnismenge an Microsoft Excel zurückgeben.

Was möchten Sie tun?

Die Reihenfolge von Feldern in einer Ergebnismenge ändern

Ein Feld in eine Ergebnismenge einfügen


 Formatieren von Daten in Microsoft Query

Formatieren von Daten in Microsoft Query

Microsoft Query speichert die Änderungen, sobald Sie die Abfrage speichern. Wenn Sie in Query Daten formatieren, wird die Formatierung nach der Rückgabe der Ergebnismenge an Microsoft Excel nicht angezeigt. Wenn Sie die Reihenfolge der Felder oder die Felder ändern, die Teil der Ergebnismenge sind, werden diese Änderungen beibehalten, wenn Sie Daten an Excel zurückgeben.

Was möchten Sie tun?

Die Spaltenüberschrift eines Feldes bearbeiten, so dass der Feldinhalt treffender beschrieben wird

Die Spaltenbreite bzw. Zeilenhöhe ändern

Die Schriftart, den Schriftstil oder den Schriftgrad von Text in einer Ergebnismenge ändern

Ein Feld in einer Ergebnismenge ein- oder ausblenden

Das Layout einer Ergebnismenge ändern


 Wechseln zu einem bestimmten Datensatz in der Ergebnismenge

Wechseln zu einem bestimmten Datensatz in der Ergebnismenge

  1. Klicken Sie im Menü Datensätze auf Gehe zu.

  2. Geben Sie die Nummer des Datensatzes ein, zu dem Sie wechseln möchten.


 Sortieren von Datensätzen in einer Abfrage

Sortieren von Datensätzen in einer Abfrage

  1. Stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] gedrückt ist.

  2. Klicken Sie in der Ergebnismenge auf das zu sortierende Feld.

  3. Um Datensätze in aufsteigender Sortierreihenfolge, zu sortieren, klicken Sie auf Aufsteigend sortieren [image] .

    Um Datensätze in absteigender Sortierreihenfolge zu sortieren, klicken Sie auf Absteigend sortieren [image] .

Anmerkungen

  • Wenn Sie mehrere Spalten in einem Schritt sortieren möchten, ordnen Sie die Spalten im Datenfenster von links nach rechts in der Reihenfolge an, in der diese sortiert werden sollen. Drücken Sie die UMSCHALTTASTE, und klicken Sie auf die Spaltenköpfe, um die zu sortierenden Spalten zu markieren, und klicken Sie dann auf Aufsteigend sortieren oder auf Absteigend sortieren.

  • Um die ursprüngliche Reihenfolge der Datensätze wiederherzustellen, klicken Sie im Menü Datensätze auf Sortieren. Klicken Sie im Feld Sortierungen in Abfrage auf das Feld, für das Sie die Sortierreihenfolge entfernen möchten, und klicken Sie dann auf Entfernen.

  • Wenn Sie die Reihenfolge von Spalten in der Ergebnismenge nach dem Sortieren der Datensätze ändern, hat dies keine Auswirkungen auf die Sortierreihenfolge.


 Anzeigen von unterschiedlichen Feldern in einer Abfrage

Anzeigen von unterschiedlichen Feldern in einer Abfrage

  1. Klicken Sie im Menü Format auf Spalten einblenden.

  2. Um eine Spalte vorübergehend aus dem Datenfenster auszublenden, klicken Sie auf die Spalte und dann auf Ausblenden.

    Um eine Spalte wieder einzublenden, klicken Sie auf den Spaltennamen und dann auf Arbeitsmappe einblenden.

Anmerkung Bei der Rückgabe der Ergebnismengen an Microsoft Excel werden auch die ausgeblendeten Felder zurückgeben. Wenn ausgeblendete Felder nicht an Microsoft Excel zurückgegeben werden sollen, löschen Sie diese Felder aus dem Datenfenster, bevor Sie die Ergebnismenge an Microsoft Excel zurückgeben.


 Ändern von Daten in einer Datenbank, für die eine Abfrage durchgeführt wurde

Ändern von Daten in einer Datenbank, für die eine Abfrage durchgeführt wurde

Ändern einer Datenbank, von der Sie Daten abgerufen haben In einigen Fällen können Sie mit Microsoft Query Daten einer externen Datenbank ändern oder Daten einer externen Datenbank löschen. Wenn Sie Änderungen an den Ergebnismengen vornehmen, ändert Microsoft Query die Daten auch in der zugrunde liegenden Tabelle, die für die Abfrage verwendet wurde.

Fälle, in denen das Ändern einer Datenbank nicht möglich ist Sie können Daten einer abgefragten Datenbank in folgenden Fällen nicht ändern:

  • Die Datenquelle ist geschützt bzw. lässt keine Änderungen zu.

  • Die Abfrage enthält mehrere Tabellen.

  • Die Abfrage enthält Summen oder angepasste Ausdrücke.

  • Das Feld, das Sie ändern möchten, ist gesperrt oder deaktiviert, oder das Feld befindet sich in einem gesperrten Datensatz.

  • Sie versuchen Daten eines Datentyps einzugeben, der für die Datenbank nicht zulässig ist. Abhängig von der Datenbank, die Sie ändern möchten, müssen Sie möglicherweise einen spezifischen Wert in das Feld eingeben.

  • Der Administrator hat das System so eingestellt, dass die Features zum Ändern von Datenbanken nicht verfügbar sind.


Bearbeiten von Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde

Was möchten Sie tun?

Mehr über das Ändern einer abgefragten Datenbank erfahren

Die Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde, ändern

Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde, entfernen

Die Änderungen an den Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde, rückgängig machen


Verwenden von DDE (Dynamic Data Exchange) mit Microsoft Query

Microsoft Query unterstützt dynamischen Datenaustausch (DDE), eine Kommunikationsform, die es zwei Programmen ermöglicht, untereinander Daten auszutauschen. In VBA-Anwendungen können DDE-Methoden verwendet werden, mit denen Microsoft Query und andere Programme (beispielsweise Microsoft Excel) kommunizieren und Daten austauschen können.

Was möchten Sie tun?

Mehr über die Verwendung von DDE erfahren

Einen DDE-Kanal öffnen

DDE-Befehle ausführen

Mehr über die verfügbaren DDE-Befehle erfahren

Den Status und andere Informationen anfordern

Daten auffinden

Microsoft Query mit DDE beenden

Einen DDE-Kanal schließen

Microsoft Query mit anderen Programmen verwenden


DDE-Befehle

Klicken Sie auf den Befehl oder die Anforderung, zu der Sie Informationen wünschen.

Activate

AddParameters

AllowEdit

BuildODBC

BuildSQL

Close

Command

EnableParameters

EnableTensor

Exit

Fetch und Fetch.Advise

Fetch.Unadvise

Logoff

Logon

LogonNow

ODBCLogon

Open

ParameterNames2

QueryNow

QueryType

SaveAs

SetParameterName

SetQueryName

SetQueryType

SetWindowState

UserControl

UserControl2

ViewPane


Datumsangaben für das Jahr 2000 in Microsoft Query

Vierstellige Jahreszahlen werden empfohlen Um sicherzustellen, dass Jahreszahlen richtig abgerufen und interpretiert werden, sollten Sie prüfen, ob in der externen Datenbank Jahreszahlen, wenn möglich, vierstellig gespeichert werden (2001 an Stelle von 01).

MicrosoftQuery und Microsoft Excel interpretieren zweistellige Jahresangaben einheitlich Microsoft Query und Excel interpretieren zweistellige Jahresangaben auf dieselbe Weise. Wenn Sie in Microsoft Query Daten anzeigen, die zweistellige Jahresangaben enthalten, und wenn Sie dann die Daten an Excel zurückgeben, werden in beiden Programmen gleiche Werte angezeigt.

So interpretiert Microsoft Query zweistellige Jahresangaben Wenn Microsoft Query eine zweistellige Jahresangabe aus einer externen Datenbank abruft, wird diese folgendermaßen interpretiert:

  • Jahresangaben von 00 bis 29 Zweistellige Jahresangaben von 00 bis 29 werden als die Jahre 2000 bis 2029 interpretiert. Wenn Microsoft Query zum Beispiel das Datum 28/5/19 aus einer externen Datenbank abruft, wird dieses Datum als 28. Mai 2019 interpretiert.

  • Jahresangaben von 30 bis 99 Zweistellige Jahresangaben von 30 bis 99 werden als die Jahre 1930 bis 1999 interpretiert. Wenn Microsoft Query zum Beispiel das Datum 28/5/98 aus einer externen Datenbank abruft, wird dieses Datum als 28. Mai 1998 interpretiert.

Administratoren können die Interpretation von Jahren ändern Der Systemadministrator kann Microsoft Office anpassen, so dass über verschiedene Regeln festgelegt wird, wie Datumsangaben interpretiert werden. So kann der Administrator zum Beispiel den ersten zweistelligen Wert 29, der als zukünftiges Datum interpretiert wird, in einen anderen Wert ändern. Wenn Sie herausfinden möchten, ob in Ihrem System die Datumsinterpretation angepasst wurde, wenden Sie sich an den Systemadministrator. Informationen zum Anpassen der Datumsinterpretation finden Sie im Microsoft Office 2000 Resource Kit.


Problembehandlung bei Microsoft Query

Wobei benötigen Sie Hilfe?

Erstellen und Verwenden von Datenquellen

Es kann keine neue Datenquelle erstellt werden.

Eine Datenquelle wird nicht gefunden oder kann nicht gelöscht werden.

Warum wird neben der Datenquelle ein Sternchen angezeigt?

Ein bereits verwendeter ODBC-Treiber wird nicht ordnungsgemäß ausgeführt.

Erstellen von Abfragen

Die gewünschte Tabelle wird nicht angezeigt.

Die gewünschten Verknüpfungen können nicht erstellt werden.

Die Verknüpfungen liefern nicht die erwarteten Datensätze.

Die Bearbeitung von Parametertypen für die SQL-Prozedur ist in Microsoft Query nicht möglich.

Eine Abfrage kann nicht bearbeitet werden.

Abrufen von Daten

In einer Meldung wird darauf hingewiesen, dass der Pfad zur Datenbank ungültig ist.

Microsoft Query kann wiederholt in der vorgegebenen Zeit keine Verbindung zur Datenbank herstellen.

Von Microsoft Query aus kann nicht auf Daten in einer Microsoft Excel-Liste zugegriffen werden.

Microsoft Query verwendet weiterhin Verbindungsressourcen, ohne dass mit einer Datenbank gearbeitet wird.

Microsoft Query gibt nicht alle verfügbaren Datensätze zurück.

Arbeiten in Microsoft Query

Warum kann die Arbeit in Microsoft Query nicht fortgesetzt werden?

Änderungen und Formatierung in der Abfrage werden bei der nächsten Ausführung nicht angezeigt.

Die Ergebnismenge kann in Microsoft Query nicht gedruckt werden.

Adressetiketten können in Microsoft Query nicht erstellt werden.

Die Ergebnismenge kann nicht als Tabelle in der Datenbank gespeichert werden.

Ein Datensatz in der Datenbank kann nicht hinzugefügt, kopiert oder verschoben werden.


Problembehandlung bei OLAP-Abfragen und Cubes

Wobei benötigen Sie Hilfe?

Die gewünschte Berechnungsfunktion für die Daten des Cubes ist nicht verfügbar.

Felder mit Datums- oder Zeitangaben werden nicht korrekt dargestellt.

Zum Speichern einer Offline-Cube-Datei steht nicht ausreichend Festplattenspeicher zur Verfügung.

Dem OLAP-Cube können keine Felder hinzugefügt werden.

Der OLAP-Cube kann nicht geändert werden.

Beim Ändern eines OLAP-Cubes gibt eine Meldung an, dass ein Datenverlust aufgetreten ist.

Eine Meldung informiert darüber, dass der OLAP-Cube-Assistent die .oqy-Datei nicht öffnen kann.


Die Abfrage kann nicht ausgeführt werden. Möchten Sie den SQL-Text ansehen?

Microsoft Query kann die SQL-Anweisung nicht ausführen, weil sich die SQL-Anweisung auf ein aktuell ungültiges Element bezieht, z. B. auf eine nicht mehr vorhandene Tabelle. Um die SQL-Anweisung anzeigen zu lassen und die nötigen Änderungen vorzunehmen, klicken Sie auf OK.


Info über die Verwendung von Kriterien

Was sind Kriterien?
Kriterien, die einer einzelnen Bedingung entsprechen
Kriterien, die mehreren Bedingungen entsprechen
Ähnliche Datensätze suchen
Einen Wertebereich angeben
Eine Berechnung verwenden
Bestimmte Datensätze ausschließen
Unvollständige Datensätze suchen


Info über die Verwendung von Kriterien


Abrufen von externen Daten mit Microsoft Query

Was ist Microsoft Query?
Einrichten von Datenquellen
Definieren einer Abfrage
Arbeiten mit den Daten in Microsoft Excel


Abrufen von externen Daten mit Microsoft Query


Die Tabelle <Name> ist bereits in der Abfrage; nochmal hinzufügen?

Sie haben versucht, eine Tabelle hinzuzufügen, die bereits im Tabellenfenster vorhanden ist.

  • Wenn Sie eine Reflexivverknüpfung erstellen möchten, klicken Sie auf OK, um die Tabelle hinzuzufügen.

  • Wenn Sie die Tabelle nicht hinzufügen möchten, klicken Sie auf Abbrechen.


Datenformatfehler; es kann nicht eingefügt werden

Microsoft Query kann die Daten aus der Zwischenablage nicht einfügen. Möglicherweise steht nicht genug freier Speicher zur Verfügung.

Schließen Sie andere Microsoft Query-Fenster bzw. andere Programme. Wenn der Fehler wiederholt auftritt, starten Sie Microsoft Windows neu, und versuchen Sie dann erneut, die Daten zu kopieren und einzufügen.


In eine offene Datei kann nicht gespeichert werden

Die zu speichernde Datei ist geöffnet. Schließen Sie die Datei vor dem Speichern.


Die andere Anwendung ist beschäftigt

Das andere Programm im DDE-Datenaustausch (Dynamic Data Exchange) ist beschäftigt und kann keinen DDE-Vorgang ausführen. Warten Sie, bis das andere Programm wieder zur Verfügung steht.


'BY' nach 'GROUP' erwartet

Die SQL-Anweisung enthält die GROUP- an Stelle der GROUP BY-Klausel. Der Bestandteil BY wurde möglicherweise falsch eingegeben oder fehlt.


'BY' nach 'ORDER' erwartet

Die SQL-Anweisung enthält die ORDER- an Stelle einer ORDER BY-Klausel. Der Bestandteil BY wurde möglicherweise falsch eingegeben oder fehlt.


Die Zwischenablage konnte nicht geöffnet werden

Die Zwischenablage reagiert nicht. Möglicherweise wird sie gerade von einem anderen Programm verwendet. Schließen Sie das Programm, und versuchen Sie es noch einmal.


Die Datei <Name> konnte nicht geöffnet werden

Microsoft Query konnte die angegebene Datei nicht öffnen oder lesen bzw. speichern. Möglicherweise ist der Datenträger fehlerhaft oder die Datei beschädigt.


Microsoft Query kann nicht gestartet werden. Versuchen Sie es erneut

Entweder ist ein Systemfehler aufgetreten, oder es ist nicht genug freier Speicher zum Starten von Microsoft Query verfügbar.

Starten Sie Microsoft Query neu, oder schließen Sie andere Programme. Wenn der Fehler erneut auftritt, starten Sie Microsoft Windows neu, und wiederholen Sie dann den Vorgang.


Die Spalte <Name> kann nicht mit dem Operator <Operator> verwendet werden

Die Datenquelle unterstützt nicht den Einsatz dieses Feldes mit dem angegebenen Operator, weil der Datentyp in diesem Feld nicht mit diesem Operator verwendet werden kann. Schlagen Sie in der Dokumentation für die Datenquelle nach, welche Operatoren Sie mit Feldern dieses Datentyps verwenden können.


Die Spalte <Name> kann mit diesem Kriterium nicht verwendet werden

In einer Spalte (einem Feld) mit diesem Datentyp können Sie keine Kriterien eingeben.


Hilfe ist nicht verfügbar aufgrund zu geringer verfügbarer Speicherkapazität oder fehlerhafter Installation von Windows oder Microsoft Query

Um Arbeitsspeicher freizugeben, schließen Sie einige Fenster oder andere Programme. Installieren Sie gegebenenfalls Microsoft Windows oder Microsoft Query neu.


Es kann nicht eingefügt werden

Die Zwischenablage reagiert nicht. Möglicherweise wird sie gerade von einem anderen Programm verwendet, die Daten in der Zwischenablage sind in einem Format, das von Microsoft Query nicht erkannt wird, oder es steht nicht genug freier Speicher zum Einfügen der Daten zur Verfügung.

Schließen Sie andere Microsoft Query-Fenster bzw. andere Programme. Tritt der Fehler wiederholt auf, starten Sie Microsoft Windows neu, und versuchen Sie erneut, die Daten zu kopieren und einzufügen.


Microsoft Query kann nicht beendet werden

Microsoft Query steht gerade über DDE (Dynamic Data Exchange) mit einem anderen Programm in Verbindung. Warten Sie, bis der DDE-Vorgang beendet ist, und schließen Sie dann Microsoft Query.


Das Kriterium kann nicht angezeigt werden

Das angegebene Kriterium ist ungültig.


Der Ausdruck <Name> kann der Sortierliste nicht hinzugefügt werden

Die verwendete Datenquelle unterstützt nicht das Sortieren nach Feldern, in denen die Ergebnisse eines Ausdrucks angezeigt werden.


Aggregate können auf Tabellen nicht angewandt werden

Sie haben für die Option Feld an Stelle eines Feldes, für das eine Summe berechnet werden soll, einen Stern (*) eingegeben. Entfernen Sie den Stern (*), und geben Sie den Namen eines Feldes ein.


Festlegen von * als Feld nicht möglich. Um alle Felder hinzuzufügen, können Sie * mit der Maus auf das Raster ziehen und ablegen.

Sie haben in der Zelle Kriterienfeld im Kriterienfenster einen Stern (*) eingegeben. Wenn Sie Kriterien für alle Felder in der Abfrage festlegen möchten, verwenden Sie statt des Sterns eine der folgenden Methoden:

  • Ziehen Sie den Stern (*) aus der Tabelle in das Kriterienfenster.

  • Doppelklicken Sie in der Tabelle auf den Stern.

  • Fügen Sie jedes Feld einzeln hinzu.


Die Funktion <Name> kann nicht mit <Spaltenname> verwandt werden

Die ausgewählte Funktion kann nicht auf den Datentyp in diesem Feld angewandt werden. Sie können beispielsweise nicht den Durchschnitt des Feldes Bestimmungsland berechnen, wenn das Feld Text enthält.


Das Zwischenablageformat wird nicht unterstützt

Die Daten in der Zwischenablage sind in einem Format, das von Microsoft Query nicht erkannt wird.


Einige Abfragen verwenden <Verbindungsname>; möchten Sie trotzdem schließen?

Die zu entfernende Datenquelle wird von einer oder mehreren Abfragen verwendet.

  • Um die Datenquelle zu entfernen und die Abfragen zu schließen, klicken Sie auf OK.

  • Um die Datenquelle weiterhin in der Liste aufzuführen und die Abfrage geöffnet zu lassen, klicken Sie auf Abbrechen.


<Anzahl> Datensätze löschen?

Sie haben eine Aktion ausgeführt, die darauf schließen lässt, dass Sie die angegebene Anzahl von Datensätzen löschen möchten.

Anmerkung Wenn die angezeigte Anzahl von Datensätzen größer als die von Ihnen angegebene ist, hat Microsoft Query auf der Grundlage der Felder im Datenfenster Duplikate von Datensätzen gefunden. Um Duplikate von Datensätzen zu vermeiden, fügen Sie dem Datenfenster vor dem Löschen von Datensätzen alle Felder hinzu.

  • Wenn Sie die Datensätze löschen möchten, klicken Sie auf OK.

  • Wenn Sie die Datensätze nicht löschen möchten, klicken Sie auf Abbrechen.


<Anzahl> Datensätze stimmen mit der Auswahl überein. Möchten Sie alle löschen?

Da das Datenfenster kein Feld enthält, mit dessen Werten die einzelnen Datensätze eindeutig identifiziert werden können (z. B. eine Kunden- oder Bestellnummer), enthält die Ergebnismenge Duplikate der zu löschenden Datensätze. Wenn Sie den ausgewählten Datensatz löschen, löscht Microsoft Query ebenfalls die identischen Datensätze.

Um die Datensätze vor dem Bearbeiten der Daten eindeutig unterscheiden zu können, stellen Sie sicher, dass Sie alle Felder aus der zugrunde liegenden Tabelle hinzufügen, oder erstellen Sie einen eindeutigen Index für die Tabelle.


<Anzahl> Datensätze werden aktualisiert

Das Datenfenster enthält weitere Datensätze, die dem bearbeiteten Datensatz entsprechen. Microsoft Query überträgt die Änderungen automatisch auf die entsprechenden Datensätze.

  • Um doppelte Datensätzen im Datenfenster zu vermeiden, fügen Sie dem Datenfenster vor dem Ändern von Datensätzen alle Felder hinzu.

  • Um die Datensätze zu aktualisieren, klicken Sie auf OK.

  • Um die Datensätze nicht zu aktualisieren, klicken Sie auf Abbrechen.


Datei konnte nicht erstellt werden

Microsoft Query kann die angegebene Abfragedatei nicht erstellen. Möglicherweise ist der Datenträger fehlerhaft oder die Datei beschädigt.


Die Tabelle <Name> wurde erfolgreich erstellt

Microsoft Query hat die definierte Tabelle mit der ausgewählten Datenquelle erstellt.


Die Erstellung eines eindeutigen Indexes ist fehlgeschlagen. Möchten Sie selber einen erstellen?

Microsoft Query kann keinen eindeutigen Index für diese Tabelle erstellen, obwohl die zurückgegebenen Datensätze, die Sie als neue Tabelle speichern möchten, aus einer Tabelle mit einem eindeutigen Index stammen.

  • Um das Dialogfeld Index erstellen einzublenden, so dass Sie einen eindeutigen Index für die Tabelle erstellen können, klicken Sie auf Ja.

  • Wenn Sie keinen eindeutigen Index erstellen möchten, klicken Sie auf Nein.


Die angegebene Länge muss größer als 0 sein

Die im Dialogfeld Tabellendefinition im Feld Länge eingegebene Zahl muss größer als 0 (Null) sein.


 Befehl Activate (DDE)

Befehl Activate (DDE)

Aktiviert das angegebene Abfragefenster. Mit diesem Befehl wird das aktive Fenster geändert, wenn mehr als ein Fenster geöffnet ist. Der Befehl steht nur auf dem Systemkanal zur Verfügung.

Syntax

Activate(Abfragename)

Abfragename Der Name des zu aktivierenden Abfragefensters.

Beispiel

In diesem Beispiel werden zwei Abfragen ausgeführt und zwei Abfragefenster geöffnet. Nach dem Ausführen der zweiten Abfrage wird das von der ersten Abfrage geöffnete Fenster zum aktiven Fenster.

DDEExecute chan, "[BuildSQL('Select * From Customers')]"
DDEExecute chan, "[QueryNow()]"
stQueryname1 = DDERequest(chan, "Query")
DDEExecute chan, "[BuildSQL('Select * From ORDERS')]"
DDEExecute chan, "[QueryNow()]"
stQueryName2 = DDERequest(chan, "Query")
DDEExecute chan, "[Activate('" & stQueryname1(1) & "')]"


Befehl AddParameters (DDE)

Fügt der aktiven Abfrage Parameter zur Verwendung mit Pivot-Tabellen hinzu.

Syntax

AddParameters(Feld1, Feld2, …)

Feld1, Feld2, … Die Namen von Tabellenspalten, die den Kriterien als Parameter hinzugefügt werden sollen. Die Namen der neuen Parameter entsprechen den Namen der Felder. Wenn Sie einen in der aktiven Abfrage nicht verfügbaren Feldnamen angeben, tritt ein Fehler auf.

Anmerkungen

AddParameters kann auch verwendet werden, wenn die Parametereingabe in Microsoft Query gesperrt wurde.

Die geänderte SQL-Zeichenfolge kann durch Abfrage des Elementes ODBCSQLStatement zurückgegeben werden.

Um die Parameter zurückzusetzen, muss die gesamten SQL-Zeichenfolge zurückgesetzt werden.


 Befehl AllowEdit (DDE)

Befehl AllowEdit (DDE)

Bestimmt, ob das Bearbeiten in einem Abfragefenster möglich ist. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar. Er entspricht dem Befehl Bearbeiten ermöglichen im Menü Datensätze.

Syntax 1

AllowEdit(BearbeitungMöglich, Gesperrt)

Syntax 2

Allow.Edit(BearbeitungMöglich, Gesperrt)

Die beiden Formen der Syntax sind gleichbedeutend.

BearbeitungMöglich Legt fest, ob das Bearbeiten im Abfragefenster zulässig ist. Gültige Werte sind "True" (Wahr) und "False" (Falsch).

Gesperrt Legt fest, ob der Befehl Bearbeiten ermöglichen im Menü Datensätze gesperrt ist, wenn der Befehl UserControl ausgeführt wurde. Gültige Werte sind "True" (Wahr) und "False" (Falsch).

Beispiel

In diesem Beispiel wird eine zuvor erstellte SQL-Anweisung ausgeführt. Dann werden die Befehle AllowEdit und UserControl an Microsoft Query gesendet. Damit wird dem Benutzer die Anzeige, jedoch nicht die Bearbeitung der Daten in der Datenquelle ermöglicht. (Der Menübefehl Bearbeiten ermöglichen ist nicht verfügbar, nachdem UserControl gesendet wurde.)

DDEExecute chan,"[BuildSQL(""" & sql & """)]")
DDEExecute chan,"[QueryNow()]")
DDEExecute chan,"[AllowEdit(False, True)]")
DDEExecute chan,"[UserControl(""&Return Data"", 3, False)]")


Befehl BuildODBC (DDE)

Baut segmentweise eine Verbindungszeichenfolge von beliebiger Länge auf.

Syntax

BuildODBC([Zeichenfolge])

Zeichenfolge Segmente einer gültigen Verbindungszeichenfolge. Wenn Zeichenfolge gleich 0 (Null) oder nicht angegeben ist, wird die Verbindungszeichenfolge gelöscht.


 Befehl BuildSQL (DDE)

Befehl BuildSQL (DDE)

Baut segmentweise eine SQL-Anweisung zum Erstellen einer neuen Abfrage auf dem DDE-Kanal auf. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

BuildSQL[(SQLText)]

SQLText Eine gültige SQL-Anweisung. Wenn sqltext nicht angegeben wird oder den Wert 0 (Null) hat, wird die SQL-Anweisung gelöscht.

Anmerkungen

Der Befehl BuildSQL eignet sich zum Aufbau langer SQL-Anweisungen. Wenn eine SQL-Anweisung beispielsweise zu lang ist, um in einer einzigen Anweisung gesendet zu werden, können Sie sie in mehreren kleinen Segmenten senden.

Nach dem Aufbauen einer SQL-Anweisung können Sie sie mit dem Befehl QueryNow ausführen.

Beispiel

In diesem Beispiel wird die Anforderung QueryDefinition verwendet, um die SQL-Anweisung für eine Abfrage zurückzugeben.

sql = DDERequest(chan,"QueryDefinition")

In diesem Beispiel wird der Befehl BuildSQL verwendet, um die zurückgegebene SQL-Zeichenfolge mit einer zusätzlichen WHERE-Klausel zurückzusenden.

DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[BuildSQL("WHERE Freight > 10")]"
DDEExecute chan, "[QueryNow()]


 Befehl Close (DDE)

Befehl Close (DDE)

Schließt die aktuelle Abfrage. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Syntax

Close( )


 Schließen eines DDE-Kanals

Schließen eines DDE-Kanals

Mit DDETerminate wird ein DDE-Kanal geschlossen. Diese Methode hat als einziges Argument die Kanalnummer des zu schließenden DDE-Kanals. Alle auf diesem Kanal geöffneten Abfragen werden bei Verwendung von DDETerminate automatisch geschlossen, und die Verbindungen zu allen Datenquellen werden getrennt.

Wenn die Kanalnummer ungültig ist, wird eine Fehlermeldung zurückgegeben.


 Befehl Command (DDE)

Befehl Command (DDE)

Sendet den Befehl Open an Microsoft Query. Dieser Befehl ist für Programme bestimmt, in denen die Länge von Zeichenfolgen, die mit DDEExecute verwendet werden können, eingeschränkt wird.

Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

Command(Nummer, Befehlszeichenfolge)

Nummer Legt fest, wie Microsoft Query die Befehle empfängt. Die folgenden Werte sind gültig:

Wert | Beschreibung
1 | Initialisiert den Puffer in Microsoft Query mit Befehlszeichenfolge (wobei der Puffer gegebenenfalls gelöscht wird), führt die Abfrage jedoch nicht aus.
2 | Verkettet Befehlszeichenfolge mit dem Ende des Puffers.
3 | Verkettet Befehlszeichenfolge mit dem Ende des Puffers und führt den gesamten Befehlspuffer aus. Da der Befehlspuffer nach der Ausführung gelöscht wird, kann Befehlszeichenfolge nicht erneut ausgeführt werden.

Befehlszeichenfolge Segmente für den Befehl Open. Die gesamte Zeichenfolge muss in einfache oder doppelte Anführungszeichen eingeschlossen werden.

Der Befehl Command in Microsoft Query unterstützt nur das Senden des Befehls Open.

Anmerkung

Dieser Befehl wird nur für die Kompatibilität mit Q+E zur Verfügung gestellt. Es wird empfohlen, zum Senden von langen SQL-Anweisungen den Befehl BuildSQL zu verwenden.


Befehl EnableParameters (DDE)

Steuert, ob Benutzer im Kriterienfenster und SQL-Fenster Parameter eingeben können. Standardmäßig können Benutzer keine Parameter eingeben. Das Eingeben von Parametern kann nicht gesperrt werden, wenn vom Benutzer bereits Parameter eingegeben wurden.

Syntax

EnableParameters(Ermöglichen)

Ermöglichen Legt fest, ob Benutzer Parameter eingeben können. Gültige Werte sind 0 (Null), um die Parametereingabe zu sperren, oder 1, um sie zu ermöglichen.


 Befehl EnableTensor (DDE)

Befehl EnableTensor (DDE)

Gibt an, ob das Zielprogramm OLAP-Datenquellen unterstützt. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

EnableTensor(Kennzeichnung)

Kennzeichnung Verwenden Sie "True" (Wahr), wenn OLAP-Datenquellen an das Zielprogramm zurückgegeben werden sollen. Verwenden Sie "False" (Falsch) oder "Omit" (Auslassen), wenn nur andere Datenquellen als OLAP an das Zielprogramm zurückgegeben werden sollen.


Ausführen von DDE-Befehlen

Mit DDEExecute können Sie Befehle an Microsoft Query senden. Diese Befehle gelten nur für Microsoft Query. Sie entsprechen nicht unbedingt den Menübefehlen. Die Befehle Open (Öffnen) und SaveAs (Speichern unter) haben beispielsweise dieselben Funktionen wie die entsprechenden Menübefehle in Microsoft Query, nicht aber die Befehle ODBCLogon und UserControl. Eine Liste der verfügbaren Befehle erhalten Sie, wenn Sie auf [image] klicken.

Die Anweisung DDEExecute hat zwei Argumente.

Argument | Beschreibung
Kanal | Die von DDEInitiate zurückgegebene DDE-Kanalnummer.
Befehl | Der an Microsoft Query gesendete Befehl.

Der Befehl UserControl kann verwendet werden, um einen Benutzer Abfragen in Microsoft Query erstellen zu lassen. Im folgenden Beispiel wird der Befehl Beenden im Menü Datei in Windows bzw. der Befehl Beenden im Menü Ablage auf dem Macintosh durch den Befehl Mein Befehl zum Beenden ersetzt.

DDEExecute Chan,"[UserControl('&My Exit Command',3,True)]"

Die DDE-Kanalnummer wurde Chan bereits zugeordnet, und der an Microsoft Query gesendete Befehl ist UserControl. Beachten Sie, dass der Befehl UserControl und die zugehörigen Parameter in Anführungszeichen ( " " ) und eckige Klammern ( [ ] ) gesetzt werden.


 Befehl Exit (DDE)

Befehl Exit (DDE)

Beendet Microsoft Query. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

Exit(AllesBeenden)

AllesBeenden Bestimmt, ob Microsoft Query beendet wird, wenn Abfragen auf anderen Kanälen als auf dem geöffnet sind, auf dem der Befehl Exit ausgeführt wurde. Gültige Werte sind "True" (Wahr) und "False" (Falsch).

Der Wert "True" bedeutet, dass Microsoft Query, unabhängig von eventuell geöffneten Abfragen, beendet wird. Wenn auf einem anderen Kanal der Befehl UserControl ausgeführt wurde, wird dieser Kanal geschlossen und die Kontrolle an das Programm zurückgegeben, welches den Befehl UserControl an Microsoft Query gesendet hat.

"False" bedeutet, dass Microsoft Query nur beendet wird, wenn eventuell vorhandene geöffnete Abfragen auf dem Kanal geöffnet wurden, auf dem der Befehl Exit gesendet wurde.

Anmerkung

Dieser DDE-Befehl wird auch verwendet, um Microsoft Query für den Macintosh zu beenden.


Beenden von Microsoft Query über DDE

Um Microsoft Query zu beenden, kann ein Programm den Befehl Exit verwenden. So ist es für den Benutzer nicht erforderlich, im Menü Datei auf Beenden zu klicken.

Befehl | Beschreibung
Exit (False) | Beendet Microsoft Query nur wenn keine Abfragen auf anderen Kanälen offen sind.
Exit (True) | Beendet Microsoft Query unabhängig davon, ob weitere Abfragen geöffnet sind..


 Befehle Fetch und Fetch.Advise (DDE)

Befehle Fetch und Fetch.Advise (DDE)

Mit Hilfe des Befehls Fetch werden Daten von Microsoft Query abgefragt und direkt an das Zielprogramm zurückgegeben.

Fetch.Advise aktualisiert das Zielprogramm nicht nur, wenn der Befehl gesendet wird, sondern automatisch jedesmal, wenn sich Werte in Microsoft Query ändern.

Diese Befehle sind sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Syntax 1

Fetch.Advise(Anwendungsname, Thema, Bereich, Werte)

Syntax 2

Fetch(Anwendungsname, Thema, Bereich, Werte)

Anwendungsname Der Name der Zielanwendung, an welche die Daten gesendet werden sollen. Die folgenden Werte sind als Argument Anwendungsname für Office-Programme gültig:

Programm | Wert für Anwendungsname
Microsoft Access | MSAccess
Microsoft Excel | Excel
Microsoft Word | WinWord

Thema Der Name der Tabelle, des Dokumentes oder des Steuerelementes, an das die Daten gesendet werden sollen.

Bereich Der Bereich in der Tabelle, dem Dokument oder dem Steuerelement, an das die Daten gesendet werden sollen.

Werte Die von Microsoft Query abgefragten Werte. (Die gültigen Werte können Sie der folgenden Tabelle entnehmen.)

Anmerkung Mit Hilfe des Befehls Fetch.Advise werden nur Abfragedaten, jedoch keine Abfrageelemente oder ZeilenNrSpaltenNr-Verweise automatisch aktualisiert.

Die folgenden Werte sind gültig:

Wert | Beschreibung
Request_item | Die zurückzugebenden Informationen; z. B. QueryDefinition.
ZeilenNrSpalteNr | Ein Verweis auf bestimmte abzufragende Zeilen und Spalten, wie z. B. Z3S5 für Microsoft Excel.
/Headers | Fragt Spaltennamen ab.
/Rownum | Fragt Zeilennummern ab.
All | Fragt alle Datensätze ab.

Anmerkung

Der Kanal, den Fetch.Advise zum Zurückgeben von Daten an das Zielprogramm öffnet, wird erst geschlossen, wenn der Befehl Fetch.Unadvise oder Close gesendet wird.

Beispiel

In diesem Beispiel werden die Abfrageelemente NumRows und NumCols verwendet, um die Anzahl von Zeilen und Spalten in der Abfrage abzufragen und dann die Werte mit Spaltenüberschriften an ein Microsoft Excel-Tabellenblatt mit Namen "Tabelle1" zurückzugeben.

rows=REQUEST(Chan,"NumRows")
cols=REQUEST(Chan,"NumCols")
DDEExecute chan, "[Fetch(""Excel"", ""Data.xls!Sheet1"", _
    ""R1C1:R"&rows&"C"&cols&""", ""All/Headers"")]"


Abrufen von Daten

Mit DDERequest können Daten an ein Programm zurückgegeben werden. Mit den Befehlen Fetch und Fetch.Advise können Daten aus Microsoft Query abgefragt und direkt in eine Tabelle oder ein Dokument gesendet werden. Fetch und Fetch.Advise werden als Befehlsargument für DDEExecute verwendet.

Fetch.Advise ähnelt Fetch, nur wird der durch die erste Übertragung erstellte Kanal nicht sofort geschlossen. Microsoft Query sendet weiterhin evtl. vorhandene Änderungen an den Daten, bis der ursprüngliche DDE-Kanal geschlossen wird oder Microsoft Query den Befehl Fetch.Unadvise erhält.


 Befehl Fetch.Unadvise (DDE)

Befehl Fetch.Unadvise (DDE)

Beendet die von Fetch.Advise eingerichtete automatische Aktualisierung und schließt den von Microsoft Query zur Übertragung von Daten an das Zielprogramm geöffneten Kanal. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Anmerkung Die mit Fetch.Unadvise verwendeten Argumente müssen den mit Fetch.Advise verwendeten Argumenten entsprechen.

Syntax

Fetch.Unadvise(Anwendungsname, Thema, Bereich, Werte)

Anwendungsname Der Name der Zielanwendung, an die die Daten gesendet werden sollen. (Beispiele finden Sie unter dem Befehl Fetch.Advise.)

Thema Der Name des Tabellenblatts, des Dokumentes oder des Steuerelementes, an das die Daten gesendet werden sollen.

Bereich Der Bereich des Tabellenblatts, des Dokumentes oder des Steuerelementes, an das die Daten gesendet werden sollen.

Werte Die von Microsoft Query abgefragten Werte. (Gültige Werte finden Sie unter dem Befehl Fetch.Advise.)


Microsoft Query kann nicht ausgeführt werden. Inkompatible Version von <Dateiname>

Die Datei Ddeml.dll ist veraltet oder fehlt. Installieren Sie Microsoft Query oder Microsoft Windows erneut.


 Befehl Logoff (DDE)

Befehl Logoff (DDE)

Meldet Sie von der angegebenen Datenquelle ab. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

Logoff(Quelle)

Quelle Der Name der Datenquelle, zu der Sie die Verbindung aufheben möchten.


 Befehl Logon (DDE)

Befehl Logon (DDE)

Zeigt ein Dialogfeld an, in dem Sie sich an einer Datenquelle anmelden können. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

Logon(Quelle)

Quelle Der Name der Datenquelle, zu der Sie eine Verbindung herstellen möchten.


 Befehl LogonNow (DDE)

Befehl LogonNow (DDE)

Nach dem Aufbau der Verbindungszeichenfolge mit dem Befehl BuildODBC meldet Sie dieser Befehl mit der im Puffer befindlichen Verbindungszeichenfolge an. Wenn sich keine Verbindungszeichenfolge im Puffer befindet, tritt ein Fehler auf.

Syntax

LogonNow([Dialogfelder])

Dialogfelder Bestimmt, ob beim Anmelden Dialogfelder angezeigt werden. Die folgenden Werte sind gültig:

Wert | Beschreibung
0 (Null) | Es werden keine Dialogfelder angezeigt. Wenn dieses Argument nicht angegeben wird, ist der Standardwert 0 (Null).
1 | Es werden Dialogfelder angezeigt, um die nicht in der Verbindungszeichenfolge angegebenen Informationen vom Benutzer anzufordern.
2 | Es werden Dialogfelder angezeigt, wobei die Werte aus der Verbindungszeichenfolge vorgegeben werden.
3 | Wie 1, jedoch werden die nicht zum Verbinden mit der Datenquelle erforderlichen Informationen abgeblendet.


 Befehl ODBCLogon (DDE)

Befehl ODBCLogon (DDE)

Ermöglicht einem Programm, eine Verbindung zu einer Datenquelle herzustellen. Sie können angeben, ob dem Benutzer beim Anmelden Dialogfelder angezeigt werden sollen. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

ODBCLogon(Zeichenfolge, Dialogfelder)

Zeichenfolge Eine Zeichenfolge mit Informationen, die der Treiber zum Aufbau einer Verbindung zu einer Datenquelle benötigt (z. B. Name der Datenquelle, Benutzerkennung und Kennwort). Dieses Argument muss über das für den verwendeten Treiber erforderliche Format verfügen. (Weitere Informationen zu Verbindungszeichenfolgen finden Sie in der Dokumentation der Datenquelle.)

Anmerkung Microsoft Query unterstützt Datei-DSN. Mit Hilfe des Anfrageelements ConnectionString kann die Verbindungszeichenfolge einer mit Datei-DSN erstellten Abfrage ohne DSN abgefragt werden. Sie können diese Verbindungszeichenfolge dann verwenden, um von jedem beliebigen Computer aus erneut Verbindungen zur Datenquelle herzustellen.

Dialogfelder Bestimmt, ob beim Anmelden Dialogfelder angezeigt werden. Die folgenden Werte sind gültig:

Wert | Beschreibung
0 (Null) | Es werden keine Dialogfelder angezeigt.
1 | Es werden Dialogfelder angezeigt, um die nicht in der Verbindungszeichenfolge angegebenen Informationen vom Benutzer anzufordern.
2 | Es werden Dialogfelder angezeigt, wobei die Werte aus der Verbindungszeichenfolge vorgegeben werden.
3 | Wie 1, jedoch werden die nicht zum Verbinden mit der Datenquelle erforderlichen Informationen abgeblendet.

Beispiel

In diesem Beispiel wird das Abfrageelement ConnectionString verwendet, um die zum Verbinden mit der Datenquelle erforderliche Zeichenfolge abzufragen. Diese Zeichenfolge wird gespeichert, nachdem sich der Benutzer bei der Datenquelle angemeldet hat. Später wird der Befehl ODBCLogon verwendet, um ohne eine Eingabe durch einen Benutzer eine Verbindung zu derselben Datenquelle herzustellen.

connstr = DDERequest(chan, "ConnectionString")
' intervening code
DDEExecute chan, "[ODBCLogon (connstr(1), 0)]"


 Öffnen eines DDE-Kanals

Öffnen eines DDE-Kanals

Eine Prozedur verwendet die Methode DDEInitiate, um einen DDE-Kanal zu öffnen. Die Methode DDEInitiate besitzt zwei Argumente: Den Namen des Quellprogramms und das sogenannte Thema des DDE-Datenaustauschs. Der Programmname für Microsoft Query lautet "MSQuery".

Microsoft Query erkennt folgende Themen:

Thema | Beschreibung
Abfragefenstername | Der Name eines offenen Abfragefensters. Der Name des Fensters kann nur angegeben werden, wenn Microsoft Query läuft und ein Fenster offen ist.
System | Ein allgemeines Thema, welches dem Zielprogramm ermöglicht, eine Verbindung mit Microsoft Query selbst statt mit einem Abfragefenster, einer Datei oder einer SQL-Anweisung SELECT aufzunehmen.

Bei Eingang einer Anforderung zum DDE-Datenaustausch über ein Thema, das Microsoft Query erkennt, antwortet Microsoft Query und öffnet einen Kanal. Die Methode DDEInitiate gibt eine Kanalnummer zurück, die einer Variablen zugewiesen und für nachfolgende Operationen auf diesem Kanal verwendet werden kann.

Um mehrere Fenster auf einem Kanal zu öffnen, verwenden Sie das Thema "System". Wenn Sie das Thema "System" verwenden, um einen DDE-Kanal zu öffnen, können Sie nur Fenster aktivieren, die auf diesem DDE-Kanal geöffnet wurden.


 Befehl Open (DDE)

Befehl Open (DDE)

Öffnet eine Abfrage, führt sie aus und zeigt die Daten danach im Datenfenster an. Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

Open(Abfrage)

Abfrage Der Name der Microsoft Query-Datei (unter Windows lautet die Dateinamenerweiterung .dqy) bzw. der Q+E-Datei (nur unter Windows, Dateinamenerweiterung .qef), die die Abfrage enthält; oder die auszuführende SQL-Anweisung SELECT.

Beispiel

In diesem Beispiel wird die Abfrage Verkäufe geöffnet.

DDEExecute chan, "[Open(""c:\msquery\sales.dqy"")]")

Dieses Beispiel führt die gleiche Aktion auf dem Macintosh aus.

DDEExecute chan, "[Open(""drivename:msquery:sales"")]")

Diese Anweisung verwendet die SQL-Anweisung SELECT, um eine neue Abfrage auszuführen.

DDEExecute chan, "[Open(""SELECT * FROM pubs.dbo.titles"")]")


 ParameterNames2-Anforderung (DDE)

ParameterNames2-Anforderung (DDE)

Gibt Informationen über die Parameter einer Parameterabfrage zurück. Diese Anforderung steht nur auf dem Systemkanal zur Verfügung.

Syntax

ParameterNames2( )

ParameterNames2 gibt für jeden Parameter den Namen, den Datentyp und den zuletzt verwendeten Wert zurück. ParameterNames2 gibt eine Matrix mit 3 Spalten und N Zeilen im xlTable-Format zurück, wie im Folgenden dargestellt:

Spalte 1 | Spalte 2 | Spalte 3
Parametername | Datentyp der Spalte | Zuletzt verwendeter Parameterwert, sofern vorhanden; andernfalls Null

Informationen über das xlTable-Format finden Sie in der Hilfe zu Visual Basic für Microsoft Excel.

Die ParameterNames2-Anforderung kann jederzeit verwendet werden, auch dann, wenn Parameter für eine Abfrage mit Hilfe des Befehls EnableParameters deaktiviert wurden. Wenn bei der Abfrage keine Parameter verwendet wurden, gibt ParameterNames2 eine leere Matrix zurück.


 Befehl QueryNow (DDE)

Befehl QueryNow (DDE)

Führt die aktive Abfrage für den geöffneten DDE-Kanal aus. Wenn Sie zum Aufbau dieser Abfrage den Befehl BuildSQL verwendet haben, führt dieser Befehl die SQL-Anweisung im Puffer aus und öffnet ein Abfragefenster. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Syntax

QueryNow( )

Beispiel

In diesem Beispiel wird die SQL-Anweisung einer Abfrage gespeichert und später wieder gesendet, um die Abfrage erneut auszuführen.

sql = DDERequest(Chan, "QueryDefinition")
DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[QueryNow()]"


 QueryType-Anforderung (DDE)

QueryType-Anforderung (DDE)

Gibt Informationen über die Datenquelle einer Abfrage zurück. Diese Anforderung steht nur auf dem Systemkanal zur Verfügung.

Syntax

QueryType( )

Die QueryType-Anforderung gibt eine Matrix mit zwei Elementen im xlTable-Format zurück. Das erste Element enthält den Typ der Abfragedatenquelle, entweder ODBC oder OLE/DB, das zweite Element enthält den Befehlstyp, der von der Datenquelle akzeptiert wird: SQL, Cube oder Cancel, wie nachstehend dargestellt:

QueryType | CommandType | Beschreibung
ODBC | SQL | Die Datenquelle ist eine SQL-entsprechende ODBC-Datenquelle.
OLEDB | Cube | Die Datenquelle ist ein OLAP-Cube. Die SQL-Anweisung enthält den Cube-Namen.
ODBC | Cancel | Der Benutzer hat die Abfrage abgebrochen und ist zum Zielprogramm zurückgekehrt.

Informationen über das xlTable-Format finden Sie in der Hilfe zu Visual Basic für Microsoft Excel.

Verwenden Sie die QueryType-Anforderung nur als die erste Anforderung, nachdem die Ausführung eines UserControl2-Befehls vollständig abgeschlossen ist.

Wenn QueryType zurückgibt, dass es sich bei der Datenquelle um einen OLAP-Cube handelt, können Sie die ODBCSQLStatement- und ConnectionString-Anforderungen zum Abrufen von Informationen zur Datenquelle verwenden. Mehr über die Verwendung von DDE-Anforderungen erfahren.


 Den Status und andere Informationen anfordern

Den Status und andere Informationen anfordern

Nachdem Sie einen DDE-Kanal zu Microsoft Query geöffnet haben, können Sie unter Verwendung von DDERequest eine Ergebnismenge oder andere Informationen abrufen.

Die Methode DDERequest verfügt über zwei Argumente.

Argument | Beschreibung
channel | Der von DDEInitiate zurückgegebene Wert für den DDE-Kanal.
request_item | Die Daten, die zurückgegeben werden sollen. Bei diesen Daten kann es sich um den Inhalt eines Feldes oder eines Felderbereichs in einem Abfragefenster oder um andere Informationsarten, wie beispielsweise die Anzahl der Datensätze in einem Abfragefenster handeln.

Abfrageelemente können sowohl auf dem Abfragekanal als auch auf dem Systemkanal angefordert werden. Auf dem Abfragekanal können jedoch nur Informationen über die Abfrage, wie beispielsweise Anzahl der Zeilen oder Spalten, oder die Abfragedefinition zurückgegeben werden. Auf dem Systemkanal können hingegen allgemeine Informationen über Microsoft Query, wie z. B. die aktuellen Verbindungen, Themennamen und der Programmstatus sowie für die aktive Abfrage spezifische Informationen zurückgegeben werden.

Als Abfrageelement für einen Abfragekanal oder für die aktive Abfrage auf einem Systemkanal kann eines der folgenden verwendet werden.

Abfrageelement | Zurückgegebene Informationen
ColumnTitles | Eine Matrix bestehend aus Spaltenüberschriften. Die Spaltenüberschrift ist gleich dem Feldnamen, sofern der Benutzer die Spaltenüberschrift nicht in Microsoft Query geändert hat.
ConnectionString | Eine Matrix bestehend aus den Segmenten einer Verbindungszeichenfolge (von denen jedes bis zu 255 Zeichen umfassen kann), aus denen sich die Verbindungszeichenfolge zusammensetzt, die zum Herstellen der Verbindung zum aktiven Abfragefenster verwendet wird. Wenn die Abfrage aus einem Datei-DSN erstellt wurde, gibt dieses Abfrageelement eine Verbindungszeichenfolge ohne DSN zurück.
ConnectionString/n | Eine Matrix bestehend aus den Segmenten einer Verbindungszeichenfolge (von denen jedes bis zu n Zeichen lang sein kann), aus denen sich die Verbindungszeichenfolge zusammensetzt, die zum Herstellen der Verbindung zum aktiven Abfragefenster verwendet wird. Wenn die Abfrage aus einem Datei-DSN erstellt wurde, gibt dieses Abfrageelement eine Verbindungszeichenfolge ohne DSN zurück.
DataSourceName | Der von der aktiven Abfrage verwendete Name der Datenquelle (DSN).
ErrorText | Der Fehlertext, sofern vorhanden, der zuletzt ausgeführten SQL-Anweisung. Dieses Element kann mehrfach angefordert werden, um alle Fehler abzurufen, die aufgetreten sind. Nachdem alle Fehler abgerufen wurden, gibt das Element eine leere Zeichenfolge zurück. Das Element gibt ebenfalls eine leere Zeichenfolge zurück, wenn die zuletzt ausgeführte SQL-Anweisung erfolgreich war, und zwar auch dann, wenn vorher ausgeführte SQL-Anweisungen nicht erfolgreich waren.
FieldDef | Eine Matrix mit Werten, die die Ausdrücke und Datentypen der Spalten (Felder) im Abfragefenster beschreibt. Mit jeder Zeile der Matrix wird ein Feld in der Abfrage beschrieben. Die Matrix gibt die folgenden Daten im Spaltenformat zurück: den Feldnamen, den Q+E-Datentyp des Feldes, die Feldbreite, die Feldgenauigkeit und den SQL-Datentyp des Feldes.
GetUniqueItems | Eine Matrix mit den eindeutigen Elementen in einer gegebenen Spalte der Ergebnismengen. Das eigentliche Abfrageelement muss der nullbasierte Spaltenindex der Spalte sein, der an "GetUniqueItems" angefügt wird (beispielsweise werden die eindeutigen Elemente in der zweiten Spalte mit "GetUniqueItems1" zurückgegeben). Sie können jedoch nicht die eindeutigen Elemente einer Spalte anfordern, die nicht Bestandteil der Abfrage ist. Dieses Element gibt die gleichen Werte wie eine SELECT DISTINCT-Anweisung für die angeforderte Spalte mit allen gültigen Verknüpfungen und Kriterienklauseln zurück. Kriterienklauseln, bei denen Parameter angegeben wurden, werden nicht eingeschlossen.
NameSeparator | Das einzelne Zeichen, das als Trennzeichen für den ODBC Qualifizierungsnamen verwendet wird.
NumCols | Die Anzahl der Spalten (Felder) in der Abfrage.
NumRows | Die Anzahl der Zeilen (Datensätze) in der Abfrage.
ODBCSQLStatement | Eine Matrix mit den SQL-Segmenten (von denen jedes aus bis zu 255 Zeichen bestehen kann), aus denen sich die ODBC SQL-Anweisung der Abfrage zusammensetzt. Mit dieser Zeichenfolge können Sie Microsoft Query umgehen und eine ODBC SQL-Anweisung zur Verarbeitung direkt an ODBC übergeben.
ODBCSQLStatement/n | Eine Matrix aus den SQL-Segmenten (von denen jedes bis zu n Zeichen lang sein kann), aus denen sich die ODBC SQL-Anweisung für die Abfrage zusammensetzt. Sie können dieses Abfrageelement zum Speichern einer ODBC SQL-Anweisung in mehreren kürzeren Segmenten verwenden.
ParameterNames | Eine Matrix mit den in der Abfrage verwendeten Parametern. Wenn keine Parameter vorhanden sind, wird eine leere Matrix zurückgegeben. Dieses Element kann jederzeit angefordert werden, auch wenn Parameter für die Abfrage deaktiviert wurden.
Query | Der Name der Abfrage.
QueryDefinition | Eine Matrix bestehend aus den Segmenten der Abfragedefinition (von denen jedes bis zu 255 Zeichen lang sein kann), aus denen sich die Abfragedefinition (eine SQL -Anweisung) so zusammensetzt, wie in Microsoft Query definiert. Dieses Element kann für zukünftige Abfragen abgerufen und gespeichert werden.
QueryDefinition/n | Eine Matrix bestehend aus den Segmenten der Abfragedefinition (von denen jedes bis zu n Zeichen lang sein kann), aus denen sich die Abfragedefinition (eine SQL-Anweisung) der Abfrage zusammensetzt.
Recest | Eine grobe Schätzung der Anzahl der Zeilen, die gleichzeitig abgerufen werden können.
TierType | Eine einzelne Ziffer, die den Typ der Datenquelle angibt: 1 steht für eine Datei, die nur eine einzelne Tabelle beinhalten kann; 2 bezeichnet eine Datei für eine Datenbank, die eine oder mehrere Tabellen enthält; 3 zeigt an, dass die Daten nicht durchsucht werden können. Dieses Abfrageelement wird verwendet, wenn das Programm ein Dialogfeld Öffnen zum Durchsuchen der Daten auf einem Datenträger bereitstellen muss.

Wenn Sie die oben aufgeführten Abfrageelemente auf dem Systemkanal verwenden, werden Daten für das Abfragefenster zurückgegeben, das zuletzt in einer DDE-Operation verwendet wurde.

Auf dem Systemkanal können Sie zusätzlich zu den oben genannten Abfrageelementen auch die folgenden Elemente anfordern.

Abfrageelement | Zurückgegebene Informationen
Sources | Alle aktuellen Datenquellenverbindungen (nur DSN).
Logon | Alle Remote-Datenbanken, zu denen Sie die Verbindung herstellen können (DSN-Einträge aus der Registrierung).
Logoff | Alle Remote-Datenbanken, zu denen aktuell eine Verbindung besteht (nur DSN).
Tables/source/user/database | Alle Tabellen für die angegebene DSN-Verbindung, den -Benutzer und die -Datenbank. Beachten Sie, dass die Quelle ein gültiger DSN sein muss.
Users/source/database | Alle Benutzer für die angegebene DSN-Verbindung und -Datenbank. Beachten Sie, dass die Quelle ein gültiger DSN sein muss.
Database/source | Alle Datenbanken für die angegebene DSN-Verbindung. Beachten Sie, dass die Quelle ein gültiger DSN sein muss.
Username/source/database | Der Benutzername für die angegebene DSN-Verbindung und -Datenbank. Beachten Sie, dass die Quelle ein gültiger DSN sein muss.
Topics | Die Namen der auf dem Systemkanal offenen Themen, zusammen mit System.
Status | Der Status des Programms, der entweder "Ready" oder "Busy" sein kann. Hierbei bedeutet "Ready", dass das Programm einen DDE-Datenaustausch mit Microsoft Query aufbauen kann. "Busy" bedeutet, dass Microsoft Query nicht für den DDE-Datenaustausch bereit ist.

In diesem Beispiel wird der von dem Abfrageelement NumRows zurückgegebene Wert in die Zelle A10 eines Microsoft Excel-Arbeitsblattes eingefügt.

ActiveWorksheet.Range("A10").Value = DDERequest(chan, "NumRows")


 Befehl SaveAs (DDE)

Befehl SaveAs (DDE)

Speichert den Entwurf einer neuen oder einer bereits vorhandenen Abfrage unter einem anderen Namen. Führt dieselbe Funktion aus wie der Befehl Speichern unter im Menü Datei. Der Befehl steht sowohl auf dem Systemkanal als auch auf dem Abfragekanal zur Verfügung.

Syntax 1

SaveAs(Abfragename)

Syntax 2

Save.As(Abfragename)

Die beiden Formen der Syntax sind gleichbedeutend.

Abfragename Der neue Name für die Abfrage.


Befehl SetParameterName (DDE)

Bestimmt den Namen eines Parameters, der in einer Abfragezeichenfolge an Microsoft Query gesendet wurde. SetParameterName sollte nach dem Befehl BuildSQL gesendet werden.

Syntax

SetParameterName(Index, Name)

Index Die Indexnummer des Parameters.

Name Der Name des Parameters.

Anmerkung

Wenn die von BuildSQL gesendete SQL-Anweisung Parameter enthält, jedoch kein Befehl SetParameterName gesendet wird, vergibt Microsoft Query Standardnamen für Parameter in der Form "Parameter n", wobei n eine fortlaufende Zahl ist. Wenn die Anzahl der mit SetParameterName gesendeten Namen für die Parameter nicht ausreicht, werden die übrigen Parameter mit "Parameter n" benannt. Werden zu viele Namen für Parameter gesendet, werden die überschüssigen Namen ignoriert.


Befehl SetQueryName (DDE)

Verwendet den Namen der aktiven Abfrage oder erstellt eine Abfrage mit dem angegebenen Namen, wenn keine Abfrage aktiv ist. Der Name wird in der Titelleiste des Abfragefensters angezeigt.

Syntax

SetQueryName(Name)

Name Der Name der Abfrage.


 Befehl SetQueryType (DDE)

Befehl SetQueryType (DDE)

Bestimmt die Aktionen, die Microsoft Query bei Abfragen basierend auf unterschiedlichen Arten von Datenquellen unternimmt. Dieser Befehl steht nur auf dem Systemkanal zur Verfügung.

Syntax

SetQueryType(QueryType, CommandType)

Gültige Kombinationen der Parameter QueryType und CommandType sind:

QueryType | CommandType | Beschreibung
ODBC | SQL | Zum Bearbeiten der Abfrage in Microsoft Query. Diese Werte werden zugrunde gelegt, wenn keine Parameter verwendet werden.
OLEDB | Cube | Zum Ausführen des OLAP-Cube-Assistenten, um die Cube-Definition zu ändern.

Wenn Sie SetQueryType(OLEDB, Cube) verwenden, ignoriert Microsoft Query jeden LogonNow-, EnableParameters- und SetQueryName-Befehl sowie UserControl2-Argumente, die innerhalb des Bearbeitungskontextes einer Cube-Definition im OLAP-Cube-Assistenten nicht gültig sind.


 Befehl SetWindowState (DDE)

Befehl SetWindowState (DDE)

Gibt an, ob das aktive Fenster beim Öffnen in Normalgröße minimiert oder maximiert angezeigt werden soll. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Syntax

SetWindowState(Zustand)

Zustand Der Zustand des aktiven Fensters. Die folgenden Werte sind gültig:

Wert | Beschreibung
1 | Normal
2 | Minimiert (nur unter Windows)
3 | Maximiert


 Befehl UserControl2 (DDE)

Befehl UserControl2 (DDE)

Aktiviert Microsoft Query und ermöglicht dem Benutzer das Erstellen, Öffnen oder Bearbeiten einer Abfrage, als ob Microsoft Query als Einzelprogramm ausgeführt würde.

Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Anmerkung Im Gegensatz zum Befehl UserControl kann bei UserControl2 ein Befehl angegeben werden, der in das Menü Datei eingefügt wird. Mit diesem Befehl werden alle in Microsoft Query erstellten Abfragen geschlossen, und die Kontrolle wird wieder an das Zielprogramm übertragen. Es werden jedoch keine Daten zurückgegeben.

Syntax

UserControl2(BeendenBefehl, AbbrechenBefehl, Zustand, NeueAbfrage)

BeendenBefehl Der Name des zum Beenden von Microsoft Query nach einem DDE-Datenaustausch verwendeten Befehls. Wird dieses Argument ausgelassen, wird die EINGABETASTE verwendet.

AbbrechenBefehl Der Name des zum Abbrechen der aktuellen Sitzung verwendeten Menübefehls. Der Befehl wird am Ende des Menüs Datei in Microsoft Query hinzugefügt. Wenn dieses Argument ausgelassen wird, wird kein neuer Menübefehl erstellt.

Zustand Der Zustand des Programms. Die folgenden Werte sind gültig:

Wert | Beschreibung
1 | Normal
2 | Minimiert (nur unter Windows)
3 | Maximiert

Wird dieses Argument ausgelassen, wird der aktuelle Zustand von Microsoft Query verwendet.

NeueAbfrage Gibt an, ob das Dialogfeld Datenquelle auswählen angezeigt wird, wenn Microsoft Query während eines DDE-Datenaustausches gestartet wird. Gültige Werte sind "True" (Wahr) und "False" (Falsch).

Wenn NeueAbfrage gleich "True" ist, wird das Dialogfeld Datenquelle auswählen angezeigt und der Benutzer zum Auswählen einer Datenquelle aufgefordert. Wenn NeueAbfrage gleich "False" (Standardwert) ist, wird kein Dialogfeld angezeigt, und alle offenen Abfragen für den Kanal sind verfügbar.


 Befehl UserControl (DDE)

Befehl UserControl (DDE)

Aktiviert Microsoft Query und ermöglicht dem Benutzer das Erstellen, Öffnen oder Bearbeiten einer Abfrage, als ob Microsoft Query als Einzelprogramm ausgeführt würde.

Dieser Befehl ist nur auf dem Systemkanal verfügbar.

Syntax

UserControl(BeendenBefehl, Zustand, NeueAbfrage)

BeendenBefehl Der Name des zum Beenden von Microsoft Query nach einem DDE-Datenaustausch verwendeten Befehls. Wird dieses Argument ausgelassen, wird "Return" verwendet.

Zustand Der Zustand des Programms. Die folgenden Werte sind gültig:

Wert | Beschreibung
1 | Normal
2 | Minimiert (nur unter Windows)
3 | Maximiert

Wird dieses Argument nicht angegeben, wird der aktuelle Zustand von Microsoft Query verwendet.

NeueAbfrage Gibt an, ob das Dialogfeld Datenquelle auswählen angezeigt wird, wenn Microsoft Query während eines DDE-Datenaustausches gestartet wird. Gültige Werte sind "True" (Wahr) und "False" (Falsch).

Wenn NeueAbfrage gleich "True" ist, wird das Dialogfeld Datenquelle auswählen angezeigt und der Benutzer zum Auswählen einer Datenquelle aufgefordert. Wenn NeueAbfrage gleich "False" ist (Standardwert), wird kein Dialogfeld angezeigt, und alle offenen Abfragen für den Kanal sind verfügbar.

Anmerkungen

Die Kontrolle durch den Benutzer endet, wenn der Benutzer im Menü Datei auf Beenden (unter Windows) oder im Menü Ablage auf Beenden (auf dem Macintosh) klickt. Microsoft Query kehrt dann zum vorigen Programmzustand zurück und gibt die Kontrolle wieder an das Zielprogramm ab.

Wichtig Bei manchen Programmen wird ein Zeitlimit gesetzt. Stellen Sie sicher, dass dieses Zeitlimit nicht überschritten wird, bevor die Kontrolle durch den Benutzer beendet wird.

Wenn Microsoft Query unter Kontrolle des Benutzers läuft, werden alle neuen oder bereits vorhandenen Abfragen auf demselben DDE-Kanal geöffnet.

Beispiel

In diesem Beispiel wird Microsoft Query mit maximiertem Fenster gestartet. Dabei wird der Befehl Beenden im Menü Datei (bzw. der Befehl Beenden im Menü Ablage auf dem Macintosh) durch den Befehl Daten an Microsoft Excel zurückgeben ersetzt. Anschließend wird das Dialogfeld Datenquelle auswählen angezeigt.

DDEExecute chan, "[UserControl(""&Return To Excel"",3,True)]")


 Verwenden von DDE

Verwenden von DDE

Zwei Programmme tauschen Daten aus, indem Sie auf einem DDE-Kanal einen DDE-Datenaustausch aufbauen. Ein Programm kann mehr als einen Datenaustausch mit Microsoft Query aufbauen, aber jeder Datenaustausch erfolgt auf einem eigenen Kanal.

Das Programm, welches den Datenaustausch veranlasst, wird Zielprogramm genannt; das Programm, welches dem Zielprogramm antwortet, ist das Quellprogramm. Bei einem DDE-Datenaustausch ist Microsoft Query immer das Quellprogramm. Dies bedeutet, dass der DDE-Datenaustausch mit Microsoft Query immer von einem anderen Programm veranlasst wird.

Anmerkung DDE wird nicht von allen Programmen unterstützt. Informationen darüber, ob Ihr Programm DDE unterstützt, finden Sie in der Dokumentation des Programms.

DDE-Kanäle

DDE-Kanäle fallen in zwei Gruppen: Systemkanäle und Abfragekanäle.

Ein Systemkanal wird in einem DDE-Datenaustausch zwischen einem Zielprogramm und Microsoft Query verwendet, um allgemeine und abfragebezogene Informationen auszutauschen. Dieser Kanal ermöglicht es, zusätzlich zu den Informationen zu Abfragen auch Informationen zu dem System abzurufen, beispielsweise zu der aktuellen Verbindung, offenen Abfragen und dem Status des Zielprogramms.

Ein Abfragekanal wird in einem DDE-Datenaustausch zwischen dem Zielprogramm und einer speziellen Abfrage (zum Beispiel Abfrage1) in Microsoft Query verwendet. Bevor ein Abfragekanal verwendet werden kann, muss das Abfragefenster bereits mit einem Systemkanal geöffnet worden sein.

Wie funktioniert DDE?

Sie können einen DDE-Datenaustausch mit einem normalen Gespräch zwischen zwei Personen vergleichen. In einem Bewerbungsgespräch beispielsweise stellt der Personalchef dem Bewerber eine Reihe von Fragen. Der Personalchef (das Ziel) ruft Informationen vom Bewerber (der Quelle) ab und zeichnet diese auf einem Blatt Papier (der Tabelle oder dem Dokument) auf. Natürlich kann auch der Bewerber dem Personalchef Fragen stellen und so einen gegenseitigen Datenaustausch beginnen.

Die an einem DDE-Datenaustausch beteiligten Programme übertragen Informationen auf ähnliche Art. Eine Prozedur in VBA könnte beispielsweise folgende Schritte ausführen, um DDE zum Kommunizieren mit Microsoft Query zu verwenden:

  1. Die Prozedur öffnet einen Kanal mit der Methode DDEInitiate.

  2. Optional kann die Prozedur weitere Informationen an Microsoft Query senden, beispielsweise über vorhandene Datenquellen oder die aktuelle Verbindung.

  3. Die Prozedur aktiviert Microsoft Query. Dieser Schritt ist die Voraussetzung dafür, dass Microsoft Query Befehle annehmen kann. Jetzt kann der Benutzer oder die Prozedur eine Abfrage aufbauen oder bearbeiten. Die Prozedur kann Befehle mit der Methode DDEExecute direkt an Microsoft Query senden.

  4. Nachdem der Benutzer oder die Prozedur Microsoft Query beendet hat, übernimmt das Zielprogramm wieder die Kontrolle. Die Prozedur kann die Ergebnismengen mit der Methode DDERequest zurück zum Zielprogramm oder wiederum Daten an Microsoft Query senden.

  5. Die Prozedur schließt den Kanal mit DDETerminate.

Einzelheiten über die DDE-Methoden in VBA finden Sie in der Hilfe zu Visual Basic.


 Verwenden von Microsoft Query mit anderen Programmen

Verwenden von Microsoft Query mit anderen Programmen

Andere Programme verwenden Microsoft Query üblicherweise zur Erledigung von drei Aufgaben:

  • Erstellen von neuen Abfragen

  • Aktualisieren von vorhandenen Daten

  • Bearbeiten von Abfragedefinitionen oder Daten

Microsoft Query als Hilfsmittel zum Abfragen von Daten für Benutzer

Mit DDE können Sie Microsoft Query als Hilfsmittel zum Abfragen von Daten verwenden. Nachdem ein Makro oder Programm einen DDE-Kanal geöffnet hat, kann es Microsoft Query aktivieren und angeben, welcher Befehl den Befehl Beenden im Menü Datei (unter Windows) oder Beenden im Menü Ablage (auf dem Macintosh) ersetzen soll, wie Microsoft Query angezeigt werden soll (minimiert [nur Windows], maximiert oder wiederhergestellt), und ob Dialogfelder angezeigt werden sollen.

Es ist dann möglich, Abfragen zu erstellen, zu öffnen und zu bearbeiten, als ob Microsoft Query als selbständiges Programm laufen würde. Nach dem Erstellen der Abfrage kann Microsoft Query durch Klicken auf den als Ersatz für den Befehl Beenden angegebenen benutzerdefinierten Befehl oder auf die Schaltfläche Beenden auf der Symbolleiste beendet werden.

Nachdem das Zielprogramm (das Dokument, die Tabelle oder ein anderes Objekt) wieder die Kontrolle übernommen hat, können Daten von Microsoft Query angefordert werden. So kann beispielswiese die Anzahl von Zeilen oder Spalten in der Abfrage, die die Abfrage definierende SQL-Zeichenfolge, die Verbindungs-Zeichenfolge für die Datenquelle oder der Name der Datenquelle abgefragt werden. Die Daten können an das Zielprogramm zurückgegeben werden, bevor der DDE-Kanal geschlossen und das Makro oder Programm beendet wird.

Aktualisieren von abgefragten Daten

Nachdem eine Abfrage ausgeführt worden ist, können die zurückgegebenen Datensätze später mit den aktuellen Daten aus der Datenquelle aktualisiert werden. Mit DDE ist es möglich, die Daten ohne Eingabe durch den Benutzer zu aktualisieren. Ein Programm kann eine SQL-Anweisung an Microsoft Query senden, das dann die Abfrage ausführt und die zurückgegebenen Datensätze im Zielprogramm aktualisiert.

Bearbeiten von Abfragedefinitionen oder Daten

Ein Programm kann Microsoft Query auch verwenden, um einen Benutzer eine bereits bestehende Abfragedefinition in Microsoft Query oder Daten in einer Datenquelle bearbeiten zu lassen.

Bei diesem Vorgang öffnet das Programm einen DDE-Kanal, baut eine Verbindung zu einer Datenquelle auf und sendet eine (von der vorherigen Abfrage gespeicherte) SQL-Zeichenfolge zum Erstellen einer neuen Abfrage an Microsoft Query. Nachdem das Programm die neue Abfrage geöffnet hat, übergibt es die Kontrolle an den Benutzer, der die Abfrage oder die Daten dann bearbeiten kann. Wenn der Benutzer Microsoft Query beendet, werden die Daten an das Programm zurückgegeben, die neue Abfragedefinition gespeichert und die Abfrage geschlossen.

So könnte ein Benutzer beispielsweise in Word einen benutzerdefinierten Befehl namens "Verkaufszahlen abrufen" auswählen, um ein entsprechendes Makro zu starten. Ohne dass der Benutzer es bemerken würde, könnte dieses Makro dann Microsoft Query starten, eine Abfrage erstellen und die Verkaufsdaten an das Word-Dokument zurückgeben.


 Befehl ViewPane (DDE)

Befehl ViewPane (DDE)

Gibt an, welche Ausschnitte im Abfragefenster angezeigt werden. Dieser Befehl ist sowohl auf dem Systemkanal als auch auf dem Abfragekanal verfügbar.

Syntax

ViewPane(Ausschnitte)

Ausschnitte Gibt an, welche Ausschnitte angezeigt werden. Die folgenden Werte sind gültig:

Wert | Beschreibung
0 (Null) | Nur Datenfenster
1 | Daten- und Tabellenfenster
2 | Daten- und Kriterienfenster
3 | Daten-, Tabellen- und Kriterienfenster


Die Tabelle <Name> wurde erfolgreich gelöscht

Microsoft Query hat die Tabelle und alle darin gespeicherten Daten gelöscht. Sie können das Löschen nicht rückgängig machen.


Tabelle <Name> löschen?

Sie haben eine Aktion ausgeführt, die darauf schließen lässt, dass Sie die Tabelle löschen möchten. Wenn Sie die Tabelle löschen, werden ebenfalls alle Daten in der Tabelle gelöscht.

Vorsicht Das Löschen kann nicht rückgängig gemacht werden.

  • Wenn Sie die Tabelle und alle darin gespeicherten Daten löschen möchten, klicken Sie auf Ja.

  • Wenn Sie die Tabelle nicht löschen möchten, klicken Sie auf Nein.


Der Speichervorgang wurde wegen ungültigem Abfragestatus gestoppt

Der Entwurf der Abfrage ist ungültig. Möglicherweise haben Sie die Kriterien nicht korrekt angegeben. Wenn der Befehl AutoAbfrage deaktiviert ist, klicken Sie im Menü Datensätze auf Jetzt abfragen, um die Abfrage zu starten.


Eine Bildschirmauflösung von mindestens 400 x 350 Pixel ist zur Ausführung von Microsoft Query erforderlich

Die Auflösung des Treibers für die Anzeige reicht zur Ausführung von Microsoft Query nicht aus. Führen Sie das Microsoft Windows-Setup aus, um den Treiber für die Anzeige zu ersetzen. Möglicherweise müssen Sie vorher den Computer mit einer Grafikkarte für eine höhere Auflösung aufrüsten.


Treiberfehler

Dieser Fehler wurde vom Treiber zurückgegeben. Weitere Informationen finden Sie in der Dokumentation des verwendeten Treibers.


Es wurde ein Datensatz mit Duplikat gefunden

In den zurückgegebenen Datensätzen befinden sich Duplikate, da das Datenfenster kein Feld enthält, mit dessen Werten die einzelnen Datensätze eindeutig identifiziert werden können, z. B. eine Kunden- oder Bestellnummer. Änderungen an einem der identischen Datensätze wirken sich auf alle Duplikate aus.

Damit die Datensätze eindeutig identifiziert werden können, stellen Sie sicher, dass Sie dem Datenfenster alle Felder der zugrunde liegenden Tabelle hinzufügen, bevor Sie die Daten bearbeiten.


Die berechnete Spalte kann nicht bearbeitet werden

Daten in einer Spalte, in der Summen berechnet oder die Ergebnisse eines benutzerdefinierten Ausdrucks angezeigt werden, können nicht bearbeitet werden.


Die Gruppenabfrage kann nicht bearbeitet werden

Sie können keine Abfrage bearbeiten, die Funktionen enthält oder bei der im Dialogfeld Abfrageeigenschaften das Kontrollkästchen Datensätze gruppieren aktiviert ist. Wenn Sie die Daten bearbeiten möchten, entfernen Sie die Funktionen, oder deaktivieren Sie das Kontrollkästchen Datensätze gruppieren.


Mehrtabellenabfrage kann nicht bearbeitet werden

Daten in einer Abfrage mit mehr als einer Tabelle können nicht bearbeitet werden.

  • Um Daten in einer Tabelle zu bearbeiten, nehmen Sie nur diese Tabelle in die Abfrage auf, und klicken Sie im Menü Datensätze auf Bearbeiten ermöglichen.

  • Um Daten in der aktuellen Abfrage zu bearbeiten, löschen Sie alle Tabellen, bis auf die Tabelle mit den zu bearbeitenden Daten, aus der Abfrage. Klicken Sie dann im Menü Datensätze auf Bearbeiten ermöglichen.

Anmerkung Wenn Sie eine Tabelle in einer Abfrage löschen, werden die Daten in der zugrunde liegenden Tabelle nicht gelöscht. Das Löschen entfernt die Tabelle und deren Daten nur aus der aktuellen Abfrage.


Datenquelle konnte nicht hinzugefügt werden

Microsoft Query kann die ausgewählte Datenquelle wegen eines Verbindungsproblems nicht hinzufügen.


Inkorrekter Spaltenausdruck: <Ausdruck>

Der in der SELECT-Liste angegebene Ausdruck ist nicht korrekt. Der Ausdruck sollte folgendes Format haben:

SELECT employee.EMPLOY_ID, employee.HIRE_DATE
FROM C:\QT\employee employee


Nach 'GROUP BY' Gruppierausdruck erwartet

Die SQL-Anweisung enthält GROUP BY, ohne dass ein Ausdruck folgt.


Nach 'ORDER BY' Sortierausdruck erwartet

Die SQL-Anweisung enthält ORDER BY, ohne dass ein Ausdruck folgt.


Mehrere Kopien einer Datei können nicht geöffnet werden

Sie können dieselbe Abfragedatei nicht zweimal gleichzeitig öffnen.


Tabelle <Name> konnte nicht hinzugefügt werden

Die angegebene Tabelle konnte nicht hinzugefügt werden. Stellen Sie Folgendes sicher:

  • Die angegebene Tabelle ist in der Datenbank vorhanden.

  • Der Name der Tabelle ist richtig angegeben. Achten Sie auf die Interpunktion, wie z. B. fehlende Unterstriche ( _ ).

  • Die angegebene Tabelle enthält gültige Felder (Spalten).


Um eine Reflexivverknüpfung herzustellen, müssen zwei Instanzen der Tabelle vorhanden sein

Im Tabellenfenster befinden sich zwei unterschiedliche Tabellen. Die von Ihnen definierte Reflexivverknüpfung verwendet im Dialogfeld Verknüpfungen in den Feldern Links und Rechts denselben Tabellennamen.

  • Zum Erstellen einer Reflexivverknüpfung müssen sich im Tabellenfenster zwei Vorkommen derselben Tabelle befinden.

  • Um zwei verschiedene Tabellen zu verknüpfen, müssen Sie eine der Tabellen für die linke und eine für die rechte Seite der Verknüpfung verwenden.


Die Länge <Zahl> muss numerisch sein

Sie haben im Feld Länge einen nichtnumerischen Wert verwendet. Geben Sie einen numerischen Wert ein.


Ein Fehler im Namen <Name> ist entdeckt worden

Der Tabellenname und die Feldnamen müssen den Konventionen für die Namensgebung der Datenquelle entsprechen. Schlagen Sie in der Dokumentation für die Datenquelle nach.


Die Anzahl der Nachkommastellen muss kleiner oder gleich der Gesamtlänge sein

Sie haben im Feld Dezimal einen Wert eingegeben, der den Wert im Feld Länge überschreitet. Ändern Sie den Wert im Feld Dezimal in eine Zahl kleiner oder gleich der Zahl im Feld Länge.


Maximale Länge für Typ <Datentypname> ist <Zahl>

Sie haben im Feld Länge einen Wert eingegeben, der die maximale Länge für ein Feld mit diesem Datentyp überschreitet.


Die Aktualisierung ist fehlgeschlagen

Microsoft Query kann die Tabellenliste im Dialogfeld Tabellen hinzufügen nicht aktualisieren, weil die Datenquelle nicht reagiert. Stellen Sie sicher, dass die Verbindung mit der Datenquelle noch vorhanden ist.


Datenquelle konnte nicht entfernt werden

Microsoft Query kann die ausgewählte Datenquelle nicht entfernen. Sie müssen die Verbindung zur Datenquelle trennen, um sie entfernen zu können.


Es ist ein allgemeiner ODBC-Fehler aufgetreten

Microsoft ODBC oder die Datenquelle hat einen Fehler ohne ausführlichere Informationen zurückgegeben. Stellen Sie sicher, dass Ihre Datenbank ausgeführt wird und verfügbar ist, und wiederholen Sie den Vorgang.


Syntaxfehler in GROUP BY-Klausel

Die SQL-Anweisung enthält eine ungültige GROUP BY-Klausel. Möglicherweise wurde ein reserviertes Wort falsch bzw. gar nicht eingegeben, oder die Interpunktion ist fehlerhaft.


Syntaxfehler in HAVING-Klausel

Die SQL-Anweisung enthält eine ungültige HAVING-Klausel. Möglicherweise wurde ein reserviertes Wort falsch bzw. gar nicht eingegeben, oder die Interpunktion ist fehlerhaft.


Syntaxfehler in JOIN-Ausdruck

Auf die ON-Klausel in der SQL-Anweisung folgt kein gültiger Ausdruck. Der Ausdruck sollte folgendes Format besitzen:

{oj C:\QT\orders orders LEFT OUTER JOIN C:\QT\orddtail orddtail ON orders.ORDER_ID = orddtail.ORDER_ID}


Syntaxfehler in ORDER BY-Klausel

Die SQL-Anweisung enthält eine ungültige ORDER BY-Klausel. Möglicherweise wurde ein reserviertes Wort falsch bzw. gar nicht eingegeben, oder die Interpunktion ist fehlerhaft.


Wählen Sie zuerst eine Datenquelle

Sie haben versucht, eine SQL-Anweisung auszuführen, ohne dass eine Datenquelle ausgewählt war. Klicken Sie im Dialogfeld SQL ausführen auf Datenquellen, und wählen Sie dann eine Datenquelle aus.


Nach Tabelle <Name> wurde Verknüpfungsoperator erwartet

In der LEFT OUTER JOIN- oder RIGHT OUTER JOIN-Klausel fehlt der Operator = zwischen den beiden Tabellennamen im Ausdruck. Äußere Verknüpfungen müssen Gleichheitsverknüpfungen sein (den Operator = verwenden).


Nach Tabelle <Name> LEFT oder RIGHT erwartet

Die SQL-Anweisung enthält die OUTER JOIN-Klausel, der das Schlüsselwort LEFT oder RIGHT nicht vorausgeht. Die OUTER JOIN-Klausel in einer SQL-Anweisung muss entweder LEFT OUTER JOIN oder RIGHT OUTER JOIN lauten.


Ausdruck nach 'HAVING' erwartet

Auf die HAVING-Klausel in der SQL-Anweisung folgt keine Suchbedingung.


Ausdruck nach 'WHERE' erwartet

Auf die WHERE-Klausel in der SQL-Anweisung folgt keine Suchbedingung.


Tabellenname nach FROM erwartet

Die SQL-Anweisung enthält die FROM-Klausel, ohne dass ein Tabellenname folgt.


Der Text war zu lang; die Einfügung konnte nicht vorgenommen werden

Der Text in der Zwischenablage ist zu umfangreich für das ausgewählte Feld im Daten- oder Kriterienfenster. Die Höchstzahl von Zeichen, die Sie im Feld einfügen können, hängt von der beim Erstellen der Tabelle festgelegten Feldlänge ab.


Es ist ein Ein-/Ausgabefehler während des Ladens aufgetreten

Microsoft Query kann die ausgewählte Datei nicht öffnen oder lesen. Möglicherweise ist der Datenträger fehlerhaft oder die Datei beschädigt.


Diese Datei konnte nicht gelesen werden

Microsoft Query kann die Datei nicht lesen. Möglicherweise ist die Datei nicht im Microsoft Query- oder Q+E-Format, der Datenträger ist fehlerhaft, oder die Datei ist beschädigt.


Es ist ein Ein-/Ausgabefehler während des Speicherns aufgetreten

Microsoft Query kann die Abfrage nicht auf dem Datenträger speichern. Möglicherweise ist der Datenträger fehlerhaft.


Die Kriterien können nicht bestimmt werden, solange Sie nicht ein Feld angegeben haben

Bevor Sie Kriterien für ein Feld angeben können, müssen Sie das Feld dem Kriterienfenster hinzufügen.


Der Treiber unterstützt nicht alle Funktionen

Der eingegebene Ausdruck enthält mindestens eine Funktion, die von der Datenquelle nicht unterstützt wird. Informationen darüber, welche Funktionen von der Datenquelle unterstützt werden, finden Sie in der Dokumentation zum Treiber Ihrer Datenquelle, oder wenden Sie sich an den Treiberhändler.


Der Index konnte nicht erstellt werden

Die Datenquelle für diese Tabelle unterstützt keine Indices.


Der Index wurde erfolgreich erstellt

Microsoft Query hat den Index im angegebenen Feld bzw. in den angegebenen Feldern der Tabelle erstellt.


Der DDE-Datenaustausch wurde geschlossen oder geändert

Das andere Programm hat den DDE-Datenaustausch (Dynamic Data Exchange) unerwartet beendet oder geändert; wahrscheinlich durch Ausgabe der Anweisung DDETerminate oder DDETerminateAll.

Brechen Sie den aktuellen Datenaustausch ab, und stellen Sie einen erneuten Datenaustausch mit dem anderen Programm her.


Breite muss zwischen 0 und <Zahl> liegen

Geben Sie eine zwischen diesen Werten liegende Spaltenbreite ein, oder aktivieren Sie im Dialogfeld Spaltenbreite das Kontrollkästchen Standardbreite.


Ungültiger Dateiname

Dateinamen müssen den Konventionen für die Namensgebung der verwendeten Datenquelle entsprechen. Schlagen Sie in der Dokumentation der Datenquelle nach.


Höhe muss zwischen 1 und <Zahl> liegen

Geben Sie eine zwischen diesen beiden Werten liegende Zeilenhöhe ein, oder aktivieren Sie im Dialogfeld Zeilenhöhe das Kontrollkästchen Standardhöhe.


Rechte und linke äußere Verknüpfungen müssen Gleichheitsverknüpfungen sein

In der LEFT OUTER JOIN- oder RIGHT OUTER JOIN-Klausel fehlt der Operator = zwischen den beiden Tabellennamen im Ausdruck, oder die Klausel verwendet einen anderen Operator. Äußere Verknüpfungen müssen Gleichheitsverknüpfungen sein (den Operator = verwenden).


Die zu verknüpfenden Spalten <Name> und <Name> entsprechen nicht dem gleichen Typ. Möchten Sie die Verknüpfung trotzdem erstellen?

Sie versuchen, Felder (Spalten) zu verknüpfen, die Daten verschiedenen Typs enthalten, z. B. ein Datumsfeld mit einem Textfeld.

  • Wenn Sie die Verknüpfung verhindern möchten, klicken Sie auf Abbrechen.

  • Wenn Sie die Verknüpfung erstellen möchten, klicken Sie auf OK.

Anmerkung Diese Art von Verknüpfung führt möglicherweise nicht zu den gewünschten Ergebnissen. Stellen Sie sicher, dass Microsoft Query die korrekten Daten für die Ergebnismenge anzeigt.


'JOIN' nach OUTER erwartet

Die SQL-Anweisung enthält die LEFT OUTER- oder RIGHT OUTER-Klausel an Stelle der LEFT OUTER JOIN- bzw. RIGHT OUTER JOIN-Klausel. Der Bestandteil JOIN wurde möglicherweise falsch eingegeben oder fehlt.


Der DDE-Befehl konnte nicht ausgeführt werden. Überprüfen Sie, ob Sie über die richtige Version der Datei DDEML.DLL verfügen

Die Installation von Microsoft Query ist unvollständig oder beschädigt. Um das Problem zu beheben, installieren Sie Microsoft Query neu, und wählen Sie die Option Reparieren.


Sind in der Abfrage mehr als zwei Tabellen enthalten, kann keine Inklusionsverknüpfung erstellt werden

Wenn Sie eine Inklusionsverknüpfung verwenden, dürfen sich nur zwei Tabellen im Tabellenfenster befinden. Entfernen Sie die übrigen Tabellen aus dem Tabellenfenster, und erstellen Sie die Inklusionsverknüpfung.


Die Meldungswarteschleife ist voll; die DDE-Meldung ist verloren

Microsoft Query kann die anstehende Anzahl von DDE-Vorgängen nicht ausführen.

Versuchen Sie, einige DDE-Datenaustauschvorgänge zu schließen und den Vorgang erneut zu starten.


Der Wert muss eine Zahl sein

Sie haben für eine Option, für die ein numerischer Wert erforderlich ist, einen nichtnumerischen Wert eingegeben. Geben Sie eine Zahl ein.


Die andere Anwendung führt den beabsichtigten DDE-Vorgang nicht aus

Das andere Programm kann den anstehenden DDE-Vorgang nicht ausführen.

  • Möglicherweise haben Sie Daten oder Befehle eingegeben, die das andere Programm nicht erkennt. Informationen zu den vom Programm erkannten Daten bzw. Befehlen finden Sie in der Dokumentation des Programms.

  • Möglicherweise erkennt das andere Programm auf der Grundlage des definierten Themas im Datenaustausch das Argument Item nicht. Informationen zu den vom Programm erkannten Elementen finden Sie in der Dokumentation des Programms.


DDE-Kanal kann nicht geöffnet werden; Microsoft Query konnte das angegebene Programm oder Thema nicht finden

Microsoft Query kann das angegebene Programm und Thema (den Gegenstand des DDE-Datenaustausches [Dynamic Data Exchange]) nicht finden. Stellen Sie sicher, dass das andere Programm (Zielprogramm) ausgeführt wird sowie das Thema geöffnet ist, und dass die Namen des Programms und des Themas bei der Definition des DDE-Datenaustausches richtig angegeben wurden.


Die Spalte <Name> dieser Datenquelle konnte nicht gespeichert werden

Sie haben versucht, die zurückgegebenen Datensätze als Tabelle zu speichern. Der Datentyp wird jedoch nicht von der Datenquelle unterstützt oder kann von dieser nicht in einen vergleichbaren Datentyp konvertiert werden. Versuchen Sie, die Datei in einer Datenquelle zu speichern, die den Datentyp unterstützt.


Nicht genug Systemressourcen für eine vollständige Anzeige

Microsoft Query hat nicht genug freien Speicher, um den Vorgang abzuschließen.

Schließen Sie andere Microsoft Query-Fenster bzw. andere Programme. Wenn der Fehler erneut auftritt, starten Sie Microsoft Windows neu, und wiederholen Sie dann den Vorgang.


Auf die Tabelle <Name> kann nicht zugegriffen werden

Die angegebene Tabelle wurde nicht gefunden, ist von einem anderen Benutzer bzw. einer anderen laufenden Abfrage gesperrt worden oder enthält keine gültigen Felder.


Anzeige der Hilfe ist nicht möglich

Die Hilfedatei für Microsoft Query befindet sich nicht im aktuellen Ordner. Verschieben oder kopieren Sie die Datei in den aktuellen Ordner.


Prozeduren konnten nicht gefunden werden

Microsoft Query kann die Liste mit den Prozeduren der Datenquelle nicht anzeigen, weil die Datenquelle nicht reagiert. Möglicherweise ist die Verbindung zur Datenquelle unterbrochen.


Es wurden keine Prozeduren gefunden

Diese Datenquelle enthält keine Prozeduren. Informationen zum Erstellen von Prozeduren finden Sie in der Dokumentation für die Datenquelle.


Kann nicht entfernt werden; einige Abfragen verwenden diese Quelle

Die zu entfernende Datenquelle wird von einer oder mehreren Abfragen verwendet. Schließen Sie erst die Abfragen, die auf die Datenquelle zugreifen.


Datensatz existiert nicht

Die angegebene Datensatznummer ist nicht vorhanden. Möglicherweise ist sie zu groß oder zu klein. Stellen Sie sicher, dass sich im Datenfenster Datensätze befinden und Sie die Datensatznummer richtig eingegeben haben.


In dieser Tabelle existieren keine eindeutigen Indizes. Möchten Sie selbst einen erstellen?

Die zurückgegebenen Datensätze, die Sie als neue Tabelle speichern möchten, stammen aus einer Tabelle, die keinen eindeutigen Index enthält.

  • Um das Dialogfeld Index erstellen einzublenden, so dass Sie einen eindeutigen Index für die Tabelle erstellen können, klicken Sie auf Ja.

  • Wenn Sie keinen Index erstellen möchten, klicken Sie auf Nein.


Die Werte können nicht wiederhergestellt werden

Microsoft Query kann die für die Kriterien ausgewählten Werte nicht anzeigen. Möglicherweise steht nicht genug Speicher zur Verfügung, oder die Verbindung zur Datenquelle wurde getrennt.

Wenn die Verbindung mit der Datenquelle noch vorhanden ist, schließen Sie nicht benötigte Microsoft Query-Fenster oder andere Programme. Wenn der Fehler wiederholt auftritt, starten Sie Microsoft Windows neu.


Ein neues Fenster konnte nicht erstellt werden

Microsoft Query kann die ausgewählte Datei nicht anzeigen. Möglicherweise steht nicht genug freier Speicher zur Verfügung.

Schließen Sie andere Fenster in Microsoft Query oder andere Programme. Wenn der Fehler wiederholt auftritt, starten Sie Microsoft Windows neu.


 Der Office-Assistent zeigt das gewünschte Hilfethema nicht an

Der Office-Assistent zeigt das gewünschte Hilfethema nicht an

Suchen Sie im Web nach Hilfe Wenn Sie das gewünschte Thema immer noch nicht finden, klicken Sie auf Senden und aufs Web gehen. Damit wird der Webbrowser gestartet und eine Verbindung zu einer Website hergestellt, in der Sie nach weiterer Hilfe suchen können. Sie können auch beschreiben, wie Sie vorgegangen sind, um Hilfe zu erhalten. Ihre Fragen und Anmerkungen tragen dazu bei, zukünftige Versionen des Hilfesystems zu verbessern.


Der Office-Assistent lenkt ab

Wählen Sie einen Office-Assistent, der weniger aktiv ist Einige Assistenten sind aktiver als andere. Wenn Sie einen anderen Assistent auswählen möchten, klicken Sie mit der rechten Maustaste auf den Assistenten. Klicken Sie dann im Kontextmenü auf Assistent auswählen. Klicken Sie auf der Registerkarte Katalog auf Zurück oder Weiter, um die verfügbaren Assistenten anzuzeigen. Der Office Logo-Assistent ist am wenigsten aktiv.

Deaktivieren Sie die Soundeffekte des Assistenten Wenn Sie den Sound deaktivieren möchten, klicken Sie auf den Assistenten, klicken Sie auf Optionen und deaktivieren Sie dann das Kontrollkästchen Sounds aktivieren.

Schränken Sie die Bewegungen des Assistenten ein Wenn Sie verhindern möchten, dass sich der Assistent automatisch auf dem Bildschirm verschiebt, klicken Sie auf den Assistenten, klicken Sie dann auf Optionen und deaktivieren Sie das Kontrollkästchen Verschieben, wenn im Weg.


Die Operation kann nicht rückgängig gemacht werden. Möchten Sie trotzdem fortfahren?

Der Befehl Rückgängig ist auf diesen Vorgang nicht anwendbar, weil der Vorgang zu umfangreich ist oder nicht genügend Speicher zur Verfügung steht.

  • Wenn Sie den Vorgang fortsetzen möchten, ohne ihn rückgängig machen zu können, klicken Sie auf OK.

  • Wenn Sie den Vorgang abbrechen möchten, klicken Sie auf Abbrechen.


'ON' nach Verknüpfungstabelle erwartet

Die SQL-Anweisung enthält die LEFT OUTER JOIN- oder RIGHT OUTER JOIN-Klausel und einen entsprechenden Ausdruck. Auf den Ausdruck folgt jedoch keine ON-Klausel mit entsprechendem Ausdruck. Der Bestandteil ON wurde möglicherweise falsch eingegeben oder fehlt.


Eine Abfrage kann nur eine Inklusionsverknüpfung haben

In einer Abfrage kann sich nur eine Inklusionsverknüpfung befinden.


Für den Operator <Operator> muss ein Wert ausgewählt werden

Wenn Sie mit diesem Operator Kriterien definieren, dürfen Sie nur einen Wert verwenden. Microsoft Query wählt dann lediglich die Datensätze aus, die im Feld, für das Sie die Kriterien festgelegt haben, diesen Wert aufweisen. Wenn Sie z. B. Beginnt mit im Feld Operator auswählen, sucht Microsoft Query in dem Feld, für das Sie die Kriterien gesetzt haben, nach Werten, die mit dem von Ihnen angegebenen Wert beginnen. Nur diese Datensätze werden in die Ergebnismenge aufgenommen.


Für den Operator <Operator> müssen zwei Werte ausgewählt werden

Wenn Sie mit diesem Operator Kriterien definieren, müssen Sie zwei Werte verwenden. Wenn Sie z. B. Liegt zwischen im Feld Operator auswählen, sucht Microsoft Query in dem Feld, für das Sie die Kriterien gesetzt haben, nach Werten, die zwischen den zwei angegebenen Werten liegen. Nur diese Datensätze werden in die Ergebnismenge aufgenommen.


Datei kann nicht geöffnet werden

Microsoft Query kann die ausgewählte Abfragedatei nicht öffnen. Möglicherweise ist der Datenträger fehlerhaft oder die Datei beschädigt.


Die Datei konnte nicht geöffnet werden

Microsoft Query kann die im Dialogfeld SQL ausführen angegebene Microsoft Query-Datei nicht öffnen oder lesen. Möglicherweise ist der Datenträger fehlerhaft, oder die Datei ist beschädigt bzw. verfügt nicht über das Textformat.


'OUTER' nach LEFT/RIGHT erwartet

Die SQL-Anweisung enthält die LEFT- oder RIGHT OUTER JOIN-Klausel, in der das Schlüsselwort OUTER fehlt. Die OUTER JOIN-Klausel in der SQL-Anweisung muss entweder LEFT OUTER JOIN oder RIGHT OUTER JOIN lauten.


Es sind nur zwei Tabellen mit einer Inklusionsverknüpfung zulässig. Möchten Sie die Inklusionsverknüpfung löschen, um eine Tabelle hinzuzufügen?

Im Tabellenfenster befinden sich bereits zwei mit einer Inklusionsverknüpfung verbundene Tabellen. Wenn Sie drei oder mehr Tabellen im Tabellenfenster verwenden möchten, müssen Sie die Inklusionsverknüpfung löschen oder in eine Exklusionsverknüpfung umwandeln.


Die Zahl ist zu groß

Geben Sie einen kleineren Wert ein.


Der Ausdruck ist zu lang

Der Ausdruck ist für die Auswertung durch Microsoft Query zu lang. Kürzen Sie den Ausdruck, oder teilen Sie ihn in zwei Ausdrücke.


Auf <Datenbank> konnte nicht zugegriffen werden

Die verwendete Datenquelle unterstützt lediglich das Hinzufügen von Tabellen aus der aktuellen Datenbank (oder Datenbank-Entsprechung).


 Info über Ausdrücke

Info über Ausdrücke

Ein Ausdruck ist eine Berechnung, bei der eine Kombination aus Operatoren, Funktionen, Feldnamen und Konstanten verwendet wird.

Sie können einen Ausdruck als Kriterium zur Auswahl von Datensätzen verwenden. Wenn Sie im Kriterienfenster einen Ausdruck verwenden möchten, wählen Sie zunächst im Kriterienfeld das Feld aus, das die zu berechnenden Werte enthält, und geben dann im Feld Wert den gewünschten Operator und Wert ein. Stellen Sie bei der Auswahl des Kriterienfeldes sicher, dass sie dieses aus der richtigen Tabelle wählen.

Ausdrücke, in denen arithmetische Operatoren verwendet werden Zum Abrufen von Datensätzen, die auf dem Ergebnis einer Berechnung basieren, erstellen Sie einen Ausdruck, in dem arithmetische Operatoren für die Addition, Subtraktion, Multiplikation oder Division verwendet werden. Beispiele für Ausdrücke mit arithmetischen Operatoren anzeigen.

Ausdrücke, in denen Vergleichsoperatoren verwendet werden Mit Vergleichsoperatoren wird ein Wert mit einem anderen verglichen. Um beispielsweise alle Bestellungen zu finden, bei denen die Anzahl der verkauften Einheiten größer als 1.000 ist, geben Sie >1000 als Kriterium für das Feld "Menge" ein. Beispiele für Ausdrücke mit Vergleichsoperatoren anzeigen.

Ausdrücke, in denen logische Operatoren verwendet werden Mit logischen Operatoren werden, ähnlich wie mit Vergleichsoperatoren, Werte verglichen. Um beispielsweise alle Datensätze für Verkäufe außerhalb Frankreichs abzurufen, verwenden Sie die Phrase Nicht Frankreich als Kriterium im Feld "Land". Beispiele für Ausdrücke mit logischen Operatoren anzeigen.

Ausdrücke, in denen andere Arten von Operatoren verwendet werden Sie können weitere Operatoren zum Suchen von Werten verwenden, die gleich einem beliebigen von verschiedenen Werten sind, um zu ermitteln, ob ein Datensatz einen Wert in einem angegebenen Feld enthält oder um Datensätze unter Verwendung eines Platzhalterzeichens zu suchen. Beispiele für Ausdrücke, in denen andere Arten von Operatoren verwendet werden, anzeigen.


 Bearbeiten der Spaltenüberschrift eines Feldes, so dass der Feldinhalt treffender beschrieben wird

Bearbeiten der Spaltenüberschrift eines Feldes, so dass der Feldinhalt treffender beschrieben wird

  1. Doppelklicken Sie auf die Spaltenüberschrift des zu ändernden Feldes.

  2. Geben Sie im Feld Spaltenüberschrift den gewünschten Text ein.


 Ändern der Spaltenbreite bzw. der Höhe aller Zeilen

Ändern der Spaltenbreite bzw. der Höhe aller Zeilen

Ändern der Spaltenbreite Zeigen Sie zum Ändern der Spaltenbreite auf den rechten Rand der Spaltenüberschrift, und ziehen Sie dann den Rand, bis die Spalte die gewünschte Breite aufweist.

Tipp Um die Spaltenbreite schnell an die Breite des größten Wertes in der Spalte anzupassen, doppelklicken Sie auf den rechten Rand der Spaltenüberschrift.

Ändern der Zeilenhöhe Zeigen Sie zum Ändern der Höhe aller Zeilen auf den unteren Rand einer beliebigen Zeilenüberschrift, und ziehen Sie dann den Rand, bis die Zeilen die gewünschte Höhe aufweisen.

Anmerkung Das Ändern der Zeilenhöhe wirkt sich auf alle Zeilen in der Ergebnismenge aus.


Ändern der Schriftart, des Schriftstils oder des Schriftgrads von Text in einer Ergebnismenge

  1. Klicken Sie im Menü Format auf Schriftart.

  2. Nehmen Sie die gewünschten Änderungen vor.


 Ändern der Art der Verknüpfung zwischen Tabellen in einer Abfrage

Ändern der Art der Verknüpfung zwischen Tabellen in einer Abfrage

  1. Doppelklicken Sie auf die Verknüpfungslinie zwischen den Tabellen.

  2. Zur Auswahl eines Operators, den Microsoft Query zum Vergleichen der Daten in den verknüpften Feldern verwenden soll, klicken Sie im Feld Operator auf den gewünschten Operator. Weitere Informationen erhalten Sie, wenn Sie auf [image] klicken.

  3. Zum Erstellen einer Inklusionsverknüpfung, bei der alle Datensätze aus der linken Tabelle verwendet werden, klicken Sie unter Verknüpfung enthält auf Option 2. Wenn Sie Inklusionsverknüpfungen erstellen möchten, müssen Sie den Operator = wählen.

    Zum Erstellen einer Inklusionsverknüpfung, bei der alle Datensätze aus der rechten Tabelle verwendet werden, klicken Sie unter Verknüpfung enthält auf Option 3.

    Zum Erstellen einer Exklusionsverknüpfung, bei der nur Datensätze verwendet werden, die sich in beiden Tabellen befinden, klicken Sie unter Verknüpfung enthält auf Option 1.

  4. Klicken Sie auf Hinzufügen.

  5. Klicken Sie auf Schließen.

    Weitere Informationen zu Verknüpfungtypen und deren Auswirkungen auf die Ergebnisse einer Abfrage erhalten Sie, indem Sie auf [image] klicken.


 Erstellen einer umfangreichen Abfrage in Microsoft Query

Erstellen einer umfangreichen Abfrage in Microsoft Query

  1. Klicken Sie auf Neue Abfrage [image] .

  2. Klicken Sie in der Registerkarte Datenbanken auf die Datenbank, aus der Sie die Daten abrufen möchten, oder erstellen Sie eine neue Datenquelle.

    Wie wird's gemacht?

  3. Deaktivieren Sie das Kontrollkästchen Query-Assistenten für Erstellung/Bearbeitung von Abfragen verwenden, und klicken Sie dann auf OK.

  4. Fügen Sie der Abfrage die gewünschten Tabellen hinzu.

    Wie wird's gemacht?

  5. Fügen Sie die Felder hinzu, die Ergebnismenge angezeigt werden sollen.

    Wie wird's gemacht?

    Wenn Sie die Ergebnismenge einschränken möchten, so dass diese nur bestimmte Datensätze enthält, geben Sie die Kriterien zum Filtern der Datensätze ein.

    Wie wird's gemacht?

    Wenn Sie eine Parameterabfrage erstellen möchten, bei deren Ausführung Sie zur Eingabe von Kriterien aufgefordert werden, geben Sie die Parameter an.

    Wie wird's gemacht?

    Sie können eine Exklusionsverknüpfung oder eine Inklusionsverknüpfung zwischen den Tabellen erstellen, um die Ergebnismenge zu ändern.

    Wie wird's gemacht?

Anmerkungen

  • Wenn Sie die gewünschten Daten abgerufen haben, können Sie die Ergebnismenge an Microsoft Excel zurückgeben. Weitere Informationen erhalten Sie, indem Sie auf [image] klicken.

  • Sie können eine Abfrage anhalten, deren Ausführung sehr lange dauert, indem Sie ESC drücken.

  • Wenn Sie die Daten erst abrufen möchten, nachdem Sie die Ergebnismenge alle Felder hinzugefügt haben, stellen Sie sicher, dass die Schaltfläche AutoAbfrage [image] nicht gedrückt ist. Um die Abfrage schließlich auszuführen, klicken Sie auf Jetzt abfragen [image] .
  • Wenn Sie verhindern möchten, dass Microsoft Query die Abfrage ausführt, bevor sie gespeichert wurde oder bevor die Daten an Excel zurückgegeben wurden, klicken Sie im Menü Bearbeiten auf Optionen. Deaktivieren Sie dann das Kontrollkästchen Gültigkeit von Abfragen vor dem Speichern oder Zurückgeben von Daten überprüfen.


 Erstellen einer Abfrage mit Hilfe des Query-Assistenten

Erstellen einer Abfrage mit Hilfe des Query-Assistenten

  1. Klicken Sie auf Neue Abfrage [image] .

  2. Aktivieren Sie das Kontrollkästchen Query-Assistenten für Erstellung/Bearbeitung von Abfragen verwenden.

  3. Doppelklicken Sie auf der Registerkarte Datenbanken auf die Datenbank, aus der Sie die Daten abrufen möchten.

    Wenn Sie eine neue Datenquelle erstellen müssen, doppelklicken Sie auf Neue Datenquelle und geben Sie die Datenquelle an.

  4. Folgen Sie den Anweisungen im Query-Assistenten.

  5. Gehen Sie im Dialogfeld Query-Assistent - Fertig stellen nach einer der folgenden Methoden vor:

    Um die Daten direkt an Microsoft Excel zurückzugeben, klicken Sie auf Daten an Microsoft Excel zurückgeben, klicken Sie auf Weiter und markieren Sie dann die Stelle, an der die externen Daten eingefügt werden sollen.

    Wenn die Abfrage in einer .dqy-Querydatei gespeichert werden soll, die Sie in Microsoft Query öffnen und bearbeiten oder in Excel öffnen und ausführen können, klicken Sie auf Abfrage speichern. Dieser optionale Schritt wird empfohlen, wenn Sie planen, einen OLAP-Cube aus der Abfrage zu erstellen.

    Wenn Sie den OLAP-Cube-Assistenten ausführen möchten, mit dem Sie aus den Abfragedaten einen Cube erstellen können, klicken Sie auf Einen OLAP-Cube aus der aktuellen Abfrage erstellen, klicken Sie auf Fertig stellen und folgen Sie dann den Anweisungen des Assistenten. Diese Option wird nur für erfahrene Benutzer empfohlen. Rufen Sie weitere Informationen zum Erstellen von OLAP-Cubes auf.

    Wenn Sie die Abfrage weiter spezifizieren möchten, klicken Sie auf Daten in Microsoft Query bearbeiten oder ansehen und klicken Sie dann auf Fertig stellen. Die Ergebnismenge wird im Datenfenster angezeigt. Sie können nun weitere Änderungen vornehmen und dann zu einem späteren Zeitpunkt das Abfrageergbnis an Microsoft Excel zurückgeben.

Tipp Zum Anhalten einer Abfrage, deren Ausführung sehr lange dauert, drücken Sie ESC.


 Entfernen von Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde

Entfernen von Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde

Vorsicht Durch das Löschen eines Datensatzes in einer Datenbank wird dieser endgültig sowohl aus der Ergebnismenge als auch aus der Datenbank entfernt.

  1. Stellen Sie sicher, dass der Befehl Bearbeitung zulassen im Menü Datensätze aktiviert ist.

    Unter Umständen lässt Microsoft Query Änderungen an den Daten nicht zu. Ist der Befehl Bearbeitung zulassen abgeblendet oder wird eine Meldung eingeblendet, wenn Sie auf den Befehl Bearbeitung zulassen klicken, ist eine Änderung der Daten nicht möglich. Weitere Informationen erhalten Sie, indem Sie auf [image] klicken.

  2. Klicken Sie auf den zu löschenden Datensatz.

  3. Klicken Sie im Menü Bearbeiten auf Löschen.


 Ändern von Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde

Ändern von Daten aus einer Datenbank, in der eine Abfrage ausgeführt wurde

  1. Stellen Sie in Microsoft Query sicher, dass der Befehl Bearbeitung zulassen im Menü Datensätze aktiviert ist.

    Unter Umständen lässt Microsoft Query Änderungen an den Daten nicht zu. Ist der Befehl Bearbeitung zulassen abgeblendet oder wird eine Meldung angezeigt, wenn Sie auf den Befehl Bearbeitung zulassen klicken, ist eine Änderung der Daten nicht möglich. Weitere Informationen erhalten Sie, indem Sie auf [image] klicken.

  2. Klicken Sie in der Ergebnismenge auf das zu ändernde Feld.

  3. Nehmen Sie an den Daten die gewünschten Änderungen vor, und drücken Sie dann die EINGABETASTE.

Anmerkung Unterläuft Ihnen beim Bearbeiten der Daten ein Fehler, können Sie die letzte Änderung umkehren, indem Sie im Menü Bearbeiten auf Rückgängig klicken. Das Rückgängigmachen einer Änderung muss vor dem Bearbeiten des nächsten Datensatzes oder dem Wechseln zu einem anderen Fenster erfolgen.


 Einfügen eines Feldes in eine Ergebnismenge

Einfügen eines Feldes in eine Ergebnismenge

  1. Klicken Sie auf die Spaltenüberschrift des Feldes, das sich rechts neben dem neu einzufügenden Feld befindet.

  2. Klicken Sie im Menü Datensätze auf Spalte einfügen.

  3. Wählen Sie im Feld Feld die einzufügende Spalte aus.

    Möchten Sie über der Spalte eine Spaltenüberschrift einfügen, die den Inhalt der Spalte treffender beschreibt, geben Sie im Feld Spaltenüberschrift den gewünschten Text ein.

  4. Klicken Sie auf Einfügen.

Anmerkung Zum schnellen Einfügen eines Feldes in eine Ergebnismenge können Sie ein Feld aus dem Tabellenfenster in die Ergebnismenge ziehen.


 Erstellen einer Exklusionsverknüpfung

Erstellen einer Exklusionsverknüpfung

  • Ziehen Sie ein Feld aus einer Tabelle zu dem entsprechenden Feld (ein Feld des gleichen Datentyps mit ähnlichen Daten) in der Feldliste für die andere Tabelle.

Anmerkung Bei einer Exklusionsverknüpfung wählt Microsoft Query Datensätze aus beiden Tabellen oder Abfragen nur dann aus, wenn die Werte in den verknüpften Feldern gleich sind. Sie können auch eine Inklusionsverknüpfung erstellen, mit der alle Datensätze aus der einen Tabelle und beliebige Datensätze aus verknüpften Datensätzen einer anderen Tabelle abgerufen werden.


 Ändern der Reihenfolge von Feldern in einer Ergebnismenge

Ändern der Reihenfolge von Feldern in einer Ergebnismenge

  1. Klicken Sie auf die Spaltenüberschrift des zu verschiebenden Feldes.

  2. Verschieben Sie den Mauszeiger über die Spaltenüberschrift, und ziehen Sie dann die Spalte an die gewünschte Stelle.


 Ein- oder Ausblenden eines Feldes in einer Ergebnismenge

Ein- oder Ausblenden eines Feldes in einer Ergebnismenge

  1. Klicken Sie auf die Spaltenüberschrift des auszublendenden Feldes.

  2. Klicken Sie im Menü Format auf Spalten ausblenden.

Um eine verborgene Spalte einzublenden, klicken Sie im Menü Format auf Spalten einblenden, wählen Sie die gewünschte Spalte aus, und klicken Sie dann auf Arbeitsmappe einblenden.


 Rückgängigmachen von Änderungen an Daten in einer Datenbank, in der eine Abfrage ausgeführt wurde

Rückgängigmachen von Änderungen an Daten in einer Datenbank, in der eine Abfrage ausgeführt wurde

  • Klicken Sie im Menü Bearbeiten auf Rückgängig.

Anmerkung Sie können die letzte Änderung der Daten umkehren. Das Rückgängigmachen einer Änderung muss vor dem Bearbeiten des nächsten Datensatzes oder dem Wechseln zu einem anderen Fenster erfolgen.


(Ohne Titel)

Anstatt Datensätze zu suchen, die einem bestimmten Wert entsprechen, können Sie auch Datensätze abrufen, die einem Wert nicht entsprechen. Beispielsweise können Sie den Operator Nicht zum Auffinden aller Datensätze von Lieferanten verwenden, die außerhalb der Vereinigten Staaten ansässig sind.

Kriterium, das mit dem Nicht-Operator zusammenarbeitet

Verwenden Sie den Nicht-Operator zum Ausschließen von Datensätzen.

Weitere Informationen

Beispiele für Ausdrücke, in denen logische Operatoren verwendet werden


(Ohne Titel)

Sie können Datensätze finden, die fehlende oder unvollständige Werte enthalten. Beispielsweise können Sie den Operator Ist Null zum Auffinden aller Datensätze von Belegschaftsmitgliedern verwenden, in denen ein Wert für den Namen des Vorgesetzten fehlt.

Kriterium, das mit dem Ist Null-Operator zusammenarbeitet

Verwenden Sie den Ist Null-Operator zum Auffinden von Datensätzen mit leeren Feldern.

Weitere Informationen

Beispiele für Ausdrücke, in denen andere Arten von Operatoren verwendet werden


(Ohne Titel)

Sie können Datensätze suchen, in denen die Werte in einem Feld ähnlich sind, wie beispielsweise Telefonnummern mit der gleichen Landes- oder Ortskennzahl. Beispielsweise können Sie alle Kunden auflisten, deren Telefonnummern mit der Ortskennzahl (171) oder der Landeskennzahl (1) und (11) beginnen.

Kriterium, das mit dem Wie-Operator zusammenarbeitet

Sie verwenden den Wie-Operator, indem Sie das Wort Wie und dann den Wert, den Sie finden möchten, in einfachen Anführungszeichen eingeben.

Anmerkung Das Prozentzeichen (%) im obigen Beispiel ist ein Platzhalterzeichen, das für eine beliebige Anzahl Zeichen steht. Sie können einen Unterstrich (_) verwenden, wenn Sie nur ein variables Zeichen angeben möchten. Die Platzhalterzeichen, die Sie verwenden können, variieren jeweils abhängig von der verwendeten Datenquelle. Weitere Informationen zu den unterstützten Platzhalterzeichen finden Sie in der Dokumentation zum Treiber Ihrer Datenquelle.

Weitere Informationen

Beispiele für Ausdrücke, in denen andere Arten von Operatoren verwendet werden


(Ohne Titel)

Sie können alle Datensätze mit Werten suchen, die einer einzelnen Bedingung entsprechen - beispielsweise einem bestimmten Land oder Produkt. Im folgenden Beispiel wird ein Kriterium gezeigt, mit dem alle Datensätze abgerufen werden, bei denen sich im Feld "Land" der Eintrag "Schweden" befindet.

Beispiel für einzelne Kriterien

Zur Angabe einzelner Kriterien wählen Sie den Namen des Feldes im Kriterienfeld aus, und geben Sie dann den zu suchenden Wert in das Feld Wert ein.

Weitere Informationen

Beispiele für Ausdrücke, in denen logische Operatoren verwendet werden


(Ohne Titel)

Den Bedingungen in zwei oder mehr Feldern entsprechen Sie können alle Datensätze mit Werten suchen, die der Bedingung in dem einen Feld und der Bedingung in einem anderen Feld entsprechen. Beispielsweise können Sie alle Datensätze für Bestellungen abrufen, die in den USA aus dem Raum Washington (WA) eingegangen sind. Zur Auswahl dieser Datensätze geben Sie zwei Kriteriensätze in das Kriterienfenster ein. Um mehrere Bedingungen anzugeben, von denen alle als "True" (Wahr) ausgewertet werden, erstellen Sie eine UND-Bedingung.

Kriterium, das einer UND-Bedingung entspricht

Zum Suchen von Datensätzen, die zwei oder mehreren Bedingungen entsprechen, geben Sie ein Kriterienfeld für jede Bedingung an.

Mehreren Bedingungen im gleichen Feld entsprechen Sie können alle Datensätze mit Werten finden, die mehreren Bedingungen im gleichen Feld entsprechen. Beispielsweise können Sie alle Datensätze für Kunden abrufen, die sowohl in den USA als auch in Mexiko ansässig sind. Zur Auswahl dieser Datensätze geben Sie zwei Kriteriensätze in das Kriterienfenster ein. Wenn Sie mehrere Bedingungen angeben möchten, von denen eine als "True" (Wahr) ausgewertet wird, erstellen Sie eine ODER-Bedingung. In einer ODER-Bedingung muss nur jeweils eine von zwei (oder mehreren) Bedingungen als "True" ausgewertet werden.

Kriterien, die einer ODER-Bedingung entsprechen

Mit den obigen Kriterien werden alle Kunden aus Mexiko oder den USA abgerufen.

Anmerkung Sie können den Oder-Operator auch innerhalb eines Kriterienwertes verwenden. Beispielsweise können Sie an Stelle von Mexiko im Feld Oder auch USA Oder Mexiko im Feld Wert eingeben.

Weitere Informationen

Beispiele für Ausdrücke, in denen logische Operatoren verwendet werden


(Ohne Titel)

Sie können alle Datensätze suchen, die einen Wert aufweisen, der innerhalb eines bestimmten Werte- oder Datumsbereichs liegt. Beispielsweise können Sie alle Datensätze für Bestellungen abrufen, die zwischen dem 1. November 1998 und dem 31. Dezember 1998 eingegangen sind. Zur Angabe von zwei oder mehr Bedingungen, denen entsprochen werden muss, erstellen Sie eine UND-Bedingung. Mit einer UND-Bedingung definieren Sie einen Wertebereich.

Beispiel für einen Bereich mit zwei Kriterien

Eine UND-Bedingung, die mit zwei Instanzen des gleichen Feldes im Kriterienfenster arbeitet.

Ein Bereich, der mit der UND-Verknüpfung festgelegt wird

Eine UND-Bedingung, in der die oberen und unteren Grenzwerte durch die Und-Verknüpfung getrennt werden.

Anmerkung Wenn Sie ein Datum in das Kriterienfenster eingeben, konvertiert Query das Datum in ein vom Programm verarbeitbares Format. Geben Sie beispielsweise das Kriterium >31.10.1998 ein, wandelt Query dieses in >#31.10.98# um.

Weitere Informationen

Beispiele für Ausdrücke, in denen Vergleichsoperatoren verwendet werden


(Ohne Titel)

Möglicherweise müssen Sie Datensätze suchen, in denen Werte dem Ergebnis einer Berechnung entsprechen, wie beispielsweise alle Datensätze, in denen das gesamte Auftragsvolumen größer als der Wert ist, der sich aus dem Feld "Einzelpreis" multipliziert mit dem Feld "Menge" ergibt.

Beispiel für berechnete Kriterien

Zum Suchen aller Datensätze, in denen das Auftragsvolumen größer als 500 DM ist, erstellen Sie eine Formel, mit der die jeweilige Gesamtsumme des Auftrags berechnet wird, und geben dann die Kriterien an.

Weitere Informationen

Beispiele für Ausdrücke, in denen arithmetische Operatoren verwendet werden


 (Ohne Titel)

Kriterien sind Bedingungen, die Sie angeben, um bestimmte Datensätze in einer Datenbank oder einer Liste zu suchen. Mit der Verwendung von Kriterien beschränken Sie die Datensätze (oder Zeilen), die in die Ergebnismenge einer Abfrage aufgenommen werden. Beispielsweise können Sie mit dem Kriterium EinheitPreis > 30 Datensätze auswählen, in denen der Wert im Feld "EinheitPreis" größer als 30 ist. Sie können im Kriterienfenster in Microsoft Query ein Kriterium entweder hinzufügen, indem Sie das Kriterium direkt in den Ausschnitt eingeben, oder indem Sie den Befehl Kriterien hinzufügen aus dem Menü Kriterien wählen. Die Felder, die Sie zur Angabe von Kriterien verwenden, müssen nicht Bestandteil der Ergebnismenge sein.

Da Ihre Abfrage möglicherweise mehrere Tabellen mit ähnlichen Feldnamen umfasst, vergewissern Sie sich, dass Sie das Feld aus der richtigen Tabelle verwenden. Wenn Sie beispielsweise alle Lieferanten für ein bestimmtes Land suchen möchten, wählen Sie das Feld "Land" aus der Tabelle "Lieferanten" anstatt aus der Tabelle "Kunden".

Weitere Informationen

Mit Hilfe von Kriterien angeben, welche Datensätze abgerufen werden sollen


 (Ohne Titel)

Mit Microsoft Query können Sie Daten aus externen Quellen in andere Programme von Microsoft Office importieren - dazu gehört insbesondere Microsoft Excel. Wenn Sie mit Hilfe von Query Daten aus Datenbanken und Dateien des Unternehmens abrufen, brauchen die Daten nicht neu erfasst zu werden, die Sie in Excel analysieren möchten. Sie können auch dafür sorgen, dass Ihre Excel-Berichte und Zusammenfassungen automatisch bei jeder Aktualisierung der Quelldatenbanken mitaktualisiert werden.

Datenbanktypen, auf die Sie zugreifen können Sie können Daten aus einer Reihe von Datenbanktypen abrufen, dazu gehören Microsoft Access, Microsoft SQL Server und Microsoft SQL Server OLAP Services. Sie können auch Daten aus Excel-Listen und aus Textdateien abrufen. Zeigen Sie eine Liste der Datenbanktypen an, auf die Sie zugreifen können.

In Excel können Sie Daten aus Webseiten abrufen, dafür wird Query nicht benötigt. Informationen zum Abrufen von Daten aus Webseiten finden Sie in der Excel-Hilfe.

Auswählen von Daten aus einer Datenbank Zum Abrufen von Daten aus einer Datenbank erstellen Sie eine Abfrage. Eine Abfrage ist vergleichbar mit einer Frage, die Sie über Daten stellen, die in einer externen Datenbank gespeichert sind. Beispiel: Ihre Daten sind in einer Access-Datenbank gespeichert und Sie möchten die Verkaufszahlen für ein bestimmtes Produkt in einzelnen Regionen erfahren. Sie können die benötigten Daten abrufen, indem Sie nur die Daten für das Produkt und die Regionen auswählen, die Sie analysieren möchten. Nicht benötigte Daten werden in diesem Fall nicht berücksichtigt.

Beispiel für das Auswählen von Daten in Query

In Query können Sie die gewünschten Datenspalten auswählen und nur diese Daten nach Excel übernehmen.

Aktualisieren des Arbeitsblattes in einem Vorgang Wenn die externen Daten in ein Excel-Arbeitsblatt übernommen wurden, können Sie die Daten bei jeder Änderung der Datenbank aktualisieren. Damit wird auch Ihre Analyse aktualisiert. Sie brauchen also nicht Ihre Berichte und Diagramme jedes Mal neu zu erstellen. Sie können beispielsweise eine Übersicht über die monatlichen Verkaufszahlen erstellen und diese jeden Monat dann aktualisieren, wenn die neuen Verkaufszahlen vorliegen.

Abrufen von Daten mit Query Für das Übernehmen externer Daten nach Excel mit Hilfe von Query sind drei Schritte erforderlich: Zuerst richten Sie eine Datenquelle ein, um eine Verbindung zur Datenbank herzustellen, dann wählen Sie mit dem Query-Assistenten die gewünschten Daten aus und schließlich geben Sie die Daten an Excel weiter. Dort können Sie die Daten formatieren, zusammenfassen und Berichte erstellen.


 (Ohne Titel)

Was ist eine Datenquelle? Eine Datenquelle enthält die Daten, die es Microsoft Excel und Microsoft Query ermöglichen, eine Verbindung zu einer externen Datenbank herzustellen. Zum Einrichten einer Datenquelle mit Hilfe von Query benennen Sie die Datenquelle und geben dann den Namen und Speicherort der Datenbank oder des Servers, den Datenbanktyp und Ihre Anmelde- und Kennwortdaten an. Zu diesen Informationen gehört auch der Name eines ODBC-Treibers oder eines Datenquellentreibers. Dieser Treiber ist ein Programm, das eine Verbindung zu einem bestimmten Datenbanktyp herstellt. Bei einigen Typen von externen Datenbanken (OLAP-Cubes) ist es für das Abrufen von Daten nur erforderlich, eine Datenquelle einzurichten.

So verwendet Query Datenquellen Wenn Sie eine Datenquelle für eine bestimmte Datenbank eingerichtet haben, können Sie diese so oft verwenden, wie Sie möchten, um eine Abfrage zu erstellen, über die Sie Daten aus der betreffenden Datenbank auswählen und abrufen - Sie brauchen also nicht die ganzen Verbindungsdaten erneut einzugeben. Query stellt über die Datenquelle eine Verbindung zur externen Datenbank her und zeigt Ihnen die verfügbaren Daten an. Wenn Sie die Abfrage erstellt und die Daten an Excel zurückgegeben haben, werden die Daten von Query abgerufen. Die Excel-Arbeitsmappe verfügt dann über die Abfragedaten und über die Datenquellenangaben, so dass Sie erneut eine Verbindung zur Datenbank herstellen können, wenn Sie die Daten aktualisieren möchten.

Diagramm zur Verwendung von Datenquellen in Query

Mit Hilfe einer Datenquelle wird in Query und Excel eine Verbindung zu einer spezifischen Datenbank hergestellt, so dass Daten abgerufen werden können.


 (Ohne Titel)

Wenn Sie über zwei Tabellen mit ähnlichen Daten verfügen, wie beispielsweise zwei Tabellen mit Kundendaten, und jede Tabelle enthält Informationen, die nicht Bestandteil der jeweils anderen Tabelle sind, können Sie eine Subtraktionsverknüpfung erstellen. Mit einer Subtraktionsverknüpfung werden nur die Datensätze aus der ersten Tabelle zurückgegeben, die nicht den Datensätzen der zweiten Tabelle entsprechen.

Tabellen mit ähnlichen Daten vor einer Subtraktionsverknüpfung

Zwei Tabellen mit ähnlichen Kundendaten

Beispiel für eine Subtraktionsverknüpfung

Weitere Informationen

Abrufen der Datensätze, die nicht von zwei Tabellen gemeinsam verwendet werden


 (Ohne Titel)

Wenn Sie alle Daten aus zwei Tabellen verbinden möchten, können Sie eine Abfrage mit vollständiger Inklusionsverknüpfung erstellen. Mit diesem Abfragetyp werden alle Daten aus beiden Tabellen zurückgegeben, auch wenn die Daten nicht verwandt sind.

Tabellen mit ähnlichen Daten vor einer vollständigen Inklusionsverknüpfung

Wenn Sie beispielsweise über eine Tabelle "Kunden" und eine Tabelle "Bestellungen" verfügen, können Sie mit einer vollständigen Inklusionsverknüpfung alle zurzeit anstehenden Bestellungen (aus der Tabelle "Bestellungen") sowie alle Kunden abrufen, die keine Bestellung aufgegeben haben (aus der Tabelle "Kunden").

Ergebnismenge von Kunden, die keinen Auftrag erteilt haben

Die beiden ersten Kunden in dieser Liste haben keinen Auftrag erteilt.

Anmerkung Wenn Sie eine vollständige Inklusionsverknüpfung erstellen, zeigt Query nur die Ergebnismenge der Abfrage an und nicht die Tabellen, die in der Abfrage verwendet wurden.

Weitere Informationen

Kombinieren aller Daten aus zwei Tabellen


(Ohne Titel)

Mit einer Exklusionsverknüpfung - dem standardmäßigen Verknüpfungstyp - werden nur Datensätze abgerufen, die in den verknüpften Feldern in beiden Tabellen den gleichen Wert aufweisen. Microsoft Query kombiniert die übereinstimmenden Datensätze beider Tabellen und zeigt diese als Ergebnismenge an.

Beispiel für eine Exklusionsverknüpfung

Weitere Informationen

Verknüpfen von Tabellen in einer Abfrage

Ändern des Verknüpfungstyps zwischen Tabellen in einer Abfrage


(Ohne Titel)

Mit einer Inklusionsverknüpfung werden alle Datensätze aus der einen Tabelle und alle übereinstimmenden Datensätze aus einer anderen Tabelle abgerufen. Wenn in beiden Tabellen gleiche Werte vorhanden sind, kombiniert Microsoft Query die übereinstimmenden Datensätze und zeigt diese als einen Datensatz in der Ergebnismenge an. Wenn ein Datensatz aus der Tabelle, deren gesamte Datensätze verwendet werden, keine Entsprechung in einem Datensatz der anderen Tabelle findet, wird dieser Datensatz dennoch in der Ergebnismenge angezeigt. Allerdings zeigt Query leere Zellen für die Einträge an, für die in der anderen Tabelle kein übereinstimmender Datensatz gefunden werden konnte.

Beispiel für eine Inklusionsverknüpfung

Weitere Informationen

Verknüpfen von Tabellen in einer Abfrage

Ändern des Verknüpfungstyps zwischen Tabellen in einer Abfrage


 (Ohne Titel)

Datenbanken bestehen aus mehreren Tabellen mit zusammenhängenden Informationen. Wenn Sie einer Abfrage zwei (oder mehr) Tabellen hinzufügen, erstellt Microsoft Query automatisch eine "Verknüpfung" zwischen den Tabellen, wenn es ein Primärschlüssel-Feld in einer Tabelle und ein Feld mit gleichlautendem Namen in der anderen Tabelle erkennt. Mit Hilfe von Verknüpfungslinien wird die Beziehung zwischen den Daten in den Tabellen angezeigt.

Verknüpfungslinien zwischen Tabellen

Verknüpfungslinien verbinden die Tabelle "Produkte" mit der Tabelle "Auftragsdetails", indem das Feld "ProduktID" in jeder Tabelle verknüpft wird. Die Tabellen "Auftragsdetails" und "Aufträge" sind über die Felder "AuftragsID" verknüpft.

Es gibt zwei grundlegende Arten von Verknüpfungen, die zum Abrufen von Datensätzen aus mehreren Tabellen verwendet werden können. Mit einer Exklusionsverknüpfung werden nur verwandte Datensätze aus den Tabellen abgerufen. Mit einer Inklusionsverknüpfung werden alle Datensätze aus der einen Tabelle und die jeweils verwandten Datensätze aus der anderen Tabelle abgerufen.

Zusätzlich zur Exklusions- und Inklusionsverknüpfung können Sie drei weitere Verknüpfungstypen erstellen - Reflexivverknüpfung, vollständige Inklusionsverknüpfung und Subtraktionsverknüpfung. Mit Hilfe einer Reflexivverknüpfung werden in der Ergebnismenge die in einer Tabelle enthaltenen Informationen kombiniert. Mit Hilfe einer vollständigen Inklusionsverknüpfung werden alle Datensätze aus beiden Tabellen zurückgegeben, auch wenn die Datensätze nicht verwandt sind. Bei einer Subtraktionsverknüpfung werden nur die Datensätze aus der ersten Tabelle zurückgegeben, die nicht den Datensätzen in einer zweiten Tabelle entsprechen.


 (Ohne Titel)

Nach dem Erstellen einer Abfrage im Query-Assistenten oder in Microsoft Query können Sie die Daten an ein Microsoft Excel-Arbeitsblatt zurückgeben. Die Daten werden dann entweder ein externer Datenbereich oder ein PivotTable-Bericht, den Sie formatieren, analysieren und aktualisieren können.

Formatieren und Analysieren von Daten In Excel können Sie zum Aufbereiten und Zusammenfassen von Daten die gewohnten Tools, wie den Diagramm-Assistenten oder die automatischen Teilergebnisse, verwenden. Sie können Daten formatieren, wobei die Formatierung auch dann beibehalten wird, wenn die Daten über die Quelldatenbank aktualisiert werden. Wenn Sie zum externen Datenbereich Spalten mit Formeln hinzufügen, können diese Formeln automatisch in neue Zeilen übernommen werden, die beim Aktualisieren der Daten zum Datenbereich hinzugefügt werden. Sie können an Stelle der Feldnamen eigene Spaltenbezeichnungen verwenden und automatisch Zeilennummern einfügen. Weitere Informationen zur Formatierung und zum Layout eines externen Datenbereichs finden Sie in der Excel-Hilfe.

Erneutes Verwenden und Freigeben von Abfragen Im Query-Assistenten und in Query können Sie eine .dqy-Abfragedatei speichern, die bearbeitet, wieder verwendet und freigegeben werden kann. Excel kann .dqy-Dateien direkt öffnen, so dass Sie oder andere Benutzer über die gleiche Abfrage zusätzliche externe Datenbereiche erstellen können.

Wenn Sie in Excel eine Zusammenfassung oder einen Bericht freigeben möchten, die bzw. der auf externen Daten beruht, können Sie anderen Benutzern eine Arbeitsmappe zur Verfügung stellen, die einen externen Datenbereich enthält, oder Sie können eine Berichtsvorlage erstellen. Über eine Berichtsvorlage können Sie die Zusammenfassung oder den Bericht speichern, ohne dass Sie die externen Daten zu speichern brauchen. Damit bleibt die Datei kleiner. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet. Weitere Informationen zum Erstellen einer Berichtsvorlage finden Sie in der Excel-Hilfe.

Aktualisieren von externen Daten Wenn Sie externe Daten aktualisieren, führen Sie die Abfrage aus, um neue oder geänderte Daten abzurufen, die Ihren Angaben entsprechen. Sie können eine Abfrage sowohl in Query als auch in Excel aktualisieren. Excel bietet mehrere Optionen zum Aktualisieren von Abfragen, wie das Aktualisieren von Daten bei jedem Öffnen der Arbeitsmappe oder das automatische Aktualisieren in bestimmten Zeitabständen. Sie können beim Aktualisierungsvorgang weiter in Excel arbeiten und dabei den Status überprüfen. Weitere Informationen zum Aktualisieren externer Daten in Excel finden Sie in der Excel-Hilfe.


 (Ohne Titel)

Verwenden Sie den Query-Assistenten für die meisten Abfragen Der Query-Assistent, der Teil von Microsoft Query ist, wurde für Anwender entwickelt, die noch keine Abfragen erstellt haben. Mit Hilfe des Assistenten können ganz einfach Daten aus unterschiedlichen Tabellen und Feldern für Ihre Datenbank ausgewählt und verknüpft werden. Nach der Auswahl der Daten können Sie den Assistenten verwenden, um die Ergebnismengen zu filtern und zu sortieren. Sie können den Query-Assistenten einsetzen, um eine vollständige Abfrage zu erstellen oder um eine Abfrage anzulegen, die Sie dann direkt in Query weiter bearbeiten.

Arbeiten Sie direkt in Query, wenn Sie andere Abfragetypen erstellen möchten Wenn Sie bereits Erfahrung im Erstellen von Abfragen haben oder wenn Sie eine komplexe Abfrage erstellen möchten, können Sie direkt in Query arbeiten. Sie können mit Hilfe von Query Abfragen anzeigen und ändern, die Sie im Query-Assistenten angelegt haben, oder Sie können ohne den Assistenten neue Abfragen erstellen.

Arbeiten Sie direkt in Query, wenn Sie Abfragen erstellen möchten, die folgende Funktionen ausführen:

  • Auswählen spezifischer Daten aus einem Feld In einer großen Datenbank möchten Sie möglicherweise einige der Daten eines Feldes auswählen und nicht benötigte Daten unberücksichtigt lassen. Wenn Sie zum Beispiel Daten zu zwei Produkten eines Feldes benötigen, das Informationen zu vielen Produkten enthält, wählen Sie mit Hilfe von Kriterien die Daten nur für die beiden gewünschten Produkte aus. Rufen Sie weitere Informationen zum Verwenden von Kriterien auf.

  • Beim Ausführen der Abfrage Daten nach unterschiedlichen Kriterien abrufen Wenn Sie in Excel einen Bericht oder eine Zusammenfassung für mehrere Bereiche und für die gleichen externen Daten erstellen müssen - wenn Sie zum Beispiel einen eigenen Verkaufsbericht für jede Region erstellen müssen - dann können Sie eine Parameterabfrage erstellen. Wenn Sie eine Parameterabfrage ausführen, werden Sie aufgefordert, die Daten anzugeben, die Sie als Kriterien für die Auswahl der Datensätze bei der Abfrage verwenden möchten. So können Sie zum Beispiel in einer Parameterabfrage aufgefordert werden, eine spezifische Region anzugeben. Dann können Sie die Abfrage zum Erstellen der regionalen Verkaufsberichte einsetzen. Rufen Sie weitere Informationen zu Parameterabfragen auf.

  • Verwenden verschiedener Möglichkeiten zum Kombinieren von Daten Sie können mit Hilfe von Query Daten aus verschiedenen Tabellen in Ihrer Datenbank kombinieren oder verknüpfen. Beispiel: Sie verfügen über eine Tabelle mit Verkaufsinformationen und eine Tabelle mit Kundeninformationen. Jetzt möchten Sie diese Tabellen so verknüpfen, dass Sie herausfinden können, welche Kunden in jüngster Zeit nichts mehr gekauft haben. Rufen Sie weitere Informationen zum Verknüpfen von Tabellen auf.

Erstellen Sie aus den Daten einer Abfrage einen OLAP-Cube On-Line Analytical Processing (OLAP) stellt eine Möglichkeit dar, Daten für Abfragen und Berichte anzuordnen, statt Transaktionen zu verarbeiten. In einer OLAP-Datenbank werden Daten hierarchisch angeordnet und an Stelle von Tabellen in Cubes gespeichert.

Sie können in Query einen OLAP-Cube aus den Daten der Abfrage erstellen, so dass in Microsoft Excel Berichte, die auf diesen Daten basieren, schneller und leichter erstellt werden können. Zum Erstellen eines OLAP-Cubes führen Sie den OLAP-Cube-Assistenten im Query-Assistenten oder direkt in Query aus. Sie können die Daten an Excel als PivotTable-Bericht zurückgeben. Rufen Sie weitere Informationen zum Erstellen eines OLAP-Cubes aus abgefragten Daten auf.

Weitere Informationen

Wann empfiehlt sich die Verwendung des Query-Assistenten und wann die Verwendung von Microsoft Query


(Ohne Titel)

Wenn Sie Informationen in einer Tabelle kombinieren möchten, erstellen Sie eine Reflexivverknüpfung. Beispielsweise enthält jeder Datensatz in einer Personaltabelle auch die Personal-Nr des jeweils vorgesetzten Abteilungsleiters. Da sich der Datensatz des Abteilungsleiters ebenfalls in der gleiche Tabelle wie der des Mitarbeiters befindet, können Sie die Tabelle mit sich selbst verknüpfen, um sowohl den Namen als auch die Personal-Nr des Abteilungsleiters abzurufen.

Beispiel für eine Reflexivverknüpfung

Indem Sie die Tabelle mit sich selbst verknüpfen, können Sie sowohl die ID als auch den Namen des Abteilungsleiters abrufen.

Weitere Informationen

Abrufen mehrerer Felder mit einer Reflexivverknüpfung


 Beispiele für Ausdrücke mit Vergleichsoperatoren

Beispiele für Ausdrücke mit Vergleichsoperatoren

Vergleichsoperatoren werden in Ausdrücken verwendet, die als Kriterien für die Auswahl von Datensätzen und für die Einschränkung einer Ergebnismenge eingesetzt werden.

Vergleichsoperator | Bedeutung | Beispiel | Auswahl im Kriterienfeld | Eingabe im Feld Wert
= (Gleichheitszeichen) | Gleich | Sucht Datensätze mit Kunden aus Deutschland | Land | =Deutschland
<> (Ungleich-Zeichen) | Ungleich | Sucht Datensätze mit Lieferanten, die nicht aus den Vereinigten Staaten stammen | Land | <>USA
> (Größer-als-Zeichen) | Größer als | Sucht Datensätze mit Bestellungen, die nach einem bestimmten Datum in Auftrag gegeben wurden | Bestelldatum | >30.6.2000
< (Kleiner-als-Zeichen) | Kleiner als | Sucht Datensätze mit Bestellungen, die vor einem bestimmten Datum in Auftrag gegeben wurden | Bestelldatum | <30.6.2000
>= (Größer- gleich- Zeichen) | Größer oder gleich | Sucht Datensätze mit Bestellungen, die an einem bestimmten Datum oder danach in Auftrag gegeben wurden | Bestelldatum | >=30.6.2000
<= (Kleiner- gleich- Zeichen) | Kleiner oder gleich | Sucht Datensätze, die an einem bestimmten Datum oder davor in Auftrag gegeben wurden | Bestelldatum | <=30.6.2000


Beispiele für Ausdrücke, in denen logische Operatoren verwendet werden

Mit logischen Operatoren werden zwei Werte verglichen.

Logischer Operator | Bedeutung | Beispiel | Klicken Sie im Kriterienfeld auf | Eingabe im Feld "Wert"
Und | Für die Datensätze in der Ergebnismenge muss dieser Wert und ein anderer Wert im gleichen Feld als "True" (Wahr) bewertet werden. | Zum Abrufen von Datensätzen zu Bestellungen, die innerhalb eines bestimmten Datumsbereichs eingegangen sind | Bestelldatum | >5/6/2000 Und <23/6/2000
Oder | Für die Datensätze in der Ergebnismenge muss dieses Kriterium und ein weiteres Kriterium als "True" (Wahr) bewertet werden. | Zum Abrufen von Datensätzen zu Lieferanten an einem von zwei Standorten | Land | USA Oder Brasilien
Nicht | Für die Datensätze in der Ergebnismenge darf dieses Kriterium nicht als "True" (Wahr) bewertet werden. | Zum Abrufen von Datensätzen zu Lieferanten, die nicht in einem bestimmten Land ansässig sind | Land | Nicht Kanada


Beispiele für Ausdrücke mit anderen Arten von Operatoren

In der folgenden Tabelle sind Operatoren aufgeführt, die Sie verwenden können, um einen Bereich von Werten auszuwählen, um Werte zu suchen, die mit einem beliebigen von mehreren Werten übereinstimmen, um festzustellen, ob ein Datensatz einen Wert in einem angegebenen Feld enthält, oder um Datensätze mit Hilfe eines Stellvertreterzeichens zu suchen.

Operator | Bedeutung | Beispiel | Auswahl im Kriterienfeld | Eingabe im Feld Wert
Liegt zwischen | Zeigt einen Bereich von Werten an, die zwischen zwei Endwerten liegen (einschließlich der Endwerte) | Sucht Datensätze mit Bestellwerten zwischen 1.000 DM und 3.000 DM | Bestellwert | Zwischen 1000 Und 3000
Ist eine von | Ermittelt, ob ein Wert mit einem beliebigen Wert in einer Liste von Werten übereinstimmt | Sucht Datensätze mit Kunden in Hamburg, Bremen und Köln | Stadt | In ('Hamburg', 'Bremen', 'Köln')
Ist Null | Ermittelt, ob ein Datensatz in dem angegebenen Feld keinen Wert enthält | Sucht Datensätze von Mitarbeitern, bei denen im Feld Vorgesetzter kein Eintrag vorhanden ist | Vorgesetzter | Ist Null
Ist Nicht Null | Ermittelt, ob ein Datensatz einen Wert in dem angegebenen Feld enthält | Sucht Datensätze von Mitarbeitern, bei denen im Feld Vorgesetzter ein Eintrag vorhanden ist | Vorgesetzter | Ist Nicht Null
Wie | Verwendet Wie und das Stellvertreter- zeichen %, um Werte zu vergleichen | Sucht Datensätze mit Mitarbeitern, deren Nachname mit den Buchstaben "Schmi" beginnt, z. B. Schmidt und Schmitt | Nachname | Wie 'Schm%'


 Eine Meldung weist darauf hin, dass der Pfad zur Datenbank ungültig ist

Eine Meldung weist darauf hin, dass der Pfad zur Datenbank ungültig ist

Prüfen Sie die Zuordnung des Netzwerklaufwerks Wenn sich die Datenbank auf einer Netzwerkfreigabe befindet, wurde der Pfad zur Datenbank beim Einrichten der Datenquelle und Auswählen der Datenbankdatei möglicherweise mit dem zu diesem Zeitpunkt gültigen Laufwerkbuchstaben in der Datenquelle registriert. Verfügen Sie z. B. über eine Datenbank mit dem Namen Lagerbestand.mdb und haben der Netzwerkfreigabe, auf dem sich die Datenbank befindet, den Laufwerkbuchstaben G zugewiesen, wird dieser Speicherort möglicherweise als G:\Öffentlich\Lagerbestand.mdb in der Datenquelle registriert. Wenn Sie oder andere Benutzer versuchen, auf die Datenquelle zuzugreifen oder mit dieser Datenquelle erstellte Abfragen auszuführen, wird vom ODBC Treiber eine Meldung ausgeben, dass der Pfad ungültig ist, wenn der Laufwerkbuchstabe G nicht derselben Netzwerkfreigabe zugewiesen wurde.

Verwenden Sie an Stelle der Laufwerkszuordnung eine andere Lösung Wenn Sie den Microsoft Access- oder Microsoft Excel-Treiber verwenden, können Sie das Problem beheben, indem Sie eine neue Datenquelle erstellen. Wählen Sie bei der Angabe des Speicherortes der Datenbankdatei nicht den Laufwerkbuchstaben aus, der der Netzwerkfreigabe zugewiesen wurde, sondern geben Sie die UNC-Adresse ein, und wählen Sie dann die Datenbank aus. Befindet sich die Datenbankdatei beispielsweise auf einem Server mit dem Namen Freigabe, können Sie \\Gemeinsam\Öffentlich eingeben, und dann die Datei Lagerbestand.mdb auswählen.

Ordnen Sie den gleichen Buchstaben für das Netzlaufwerk zu, bevor Sie die Datenquelle verwenden Bei anderen ODBC-Treibern müssen Sie vor dem Zugriff auf die Datenquelle oder dem Ausführen einer mit dieser Datenquelle erstellten Abfrage sicherstellen, dass der Netzwerkfreigabe mit der Datenbank derselbe Laufwerkbuchstabe zugewiesen wird, der auch beim Erstellen der Datenquelle verwendet wurde.


 Ein bereits verwendeter ODBC-Treiber wird nicht ordnungsgemäß ausgeführt

Ein bereits verwendeter ODBC-Treiber wird nicht ordnungsgemäß ausgeführt

Unter folgenden Umständen müssen Sie gegebenenfalls einen anderen Treiber mit Microsoft Query 2000 verwenden:

Stellen Sie sicher, dass Sie einen 32-Bit-ODBC-Treiber verwenden Zur Ausführung von Microsoft Query 2000 sind 32-Bit-ODBC-Treiber erforderlich, wie z. B. die im Lieferumfang von Microsoft Query 2000 und Microsoft Query 97 enthaltenen Treiber. Wenn Sie beispielsweise ein Programm zum Abfragen von externen Daten für Microsoft Excel 2000 in Visual Basic entwickeln und dieses dann an Benutzer von Microsoft Excel 5.x verteilen, kann das Programm unter Umständen nicht mit den 16-Bit-ODBC-Treibern von Microsoft Excel 5.x ausgeführt werden.

Stellen Sie sicher, dass Sie Microsoft Treiber, Versionen 3.0 oder höher, verwenden Wenn Sie andere als die mit Microsoft Excel 2000 oder Microsoft Office 2000 gelieferten Microsoft ODBC-Treiber installieren, stellen Sie sicher, dass Sie Version 3.0 oder eine höhere Version dieser Treiber verwenden. Mit früheren Versionen der Microsoft ODBC-Treiber kann Microsoft Query 2000 möglicherweise nicht ausgeführt werden. Mit Microsoft Excel 97 und Microsoft Office 97 werden Treiber der Version 3.0 oder höher mitgeliefert. Beim Installieren dieser Treiber werden die früheren Versionen in der Regel automatisch ersetzt.

Stellen Sie sicher, dass Sie die richtige Version eines Treibers von einem Drittanbieter verwenden Wenn Sie mit einem ODBC-Treiber von einem Drittanbieter arbeiten, müssen Sie beim Aufrüsten der Datenbank oder Installieren einer neuen Datenbankversion unter Umständen ebenfalls einen neuen ODBC-Treiber für Microsoft Query installieren. Weitere Informationen hierzu finden Sie in der Datenbank-Dokumentation.


 Felder mit Datums- oder Zeitangaben werden nicht korrekt dargestellt

Felder mit Datums- oder Zeitangaben werden nicht korrekt dargestellt

Überprüfen des Datums- oder Zeitfeldes in der Quelldatenbank Wenn die gewünschten Ebenen in den Datums- oder Zeitdimensionen des OLAP-Cubes nicht angezeigt werden, überprüfen Sie das Datums- oder Zeitfeld der zugrunde liegenden relationalen Datenbank, aus der die Datensätze für die Abfrage übernommen wurden. Möglicherweise sind Datumsangaben und Uhrzeit als Text und nicht in dem Datums- oder Zeitformat gespeichert, das der OLAP-Cube-Assistent erkennt. Wenn Sie dies vermuten, wenden Sie sich an den Administrator der relationalen Datenbank und bitten ihn, dies zu überprüfen und gegebenenfalls das Datums- oder Zeitformat für das Feld zu korrigieren.

Überprüfen der obersten Dimensionsebene Wenn der OLAP-Cube-Assistent Felder mit Datums- und Zeitangaben als niedrigere Ebenen einer bestehenden Dimension hinzufügt, werden die Daten nicht automatisch in die Ebenen Jahr/Quartal/Monat/Woche und Stunde/Minute/Sekunde aufgelöst. Der Assistent führt diese Aktion nur dann durch, wenn Sie das Datums- oder Zeitfeld als oberste Ebene einer neuen Dimension hinzufügen. Handelt es sich bei dem Datums- oder Zeitfeld nicht um die oberste Ebene, bearbeiten Sie den Cube.


 Änderungen und Formatierungen in der Abfrage werden bei der nächsten Ausführung nicht angezeigt

Änderungen und Formatierungen in der Abfrage werden bei der nächsten Ausführung nicht angezeigt

Excel speichert Formatierungsänderungen nicht in Abfragen Beim Zurückgeben von Daten an Microsoft Excel wird die Definition der Abfrage als Teil des Tabellenblattes gespeichert. Es wird jedoch nicht automatisch eine separate Abfragedatei gespeichert. Bei der Bearbeitung der Abfrage des externen Datenbereichs bleiben die in Microsoft Query vorgenommenen Änderungen an der Formatierung und den Spaltenüberschriften nicht erhalten.

Formatierungsänderungen werden nicht in den .dqy-Abfragedateien gespeichert Wenn Sie eine Datei im .dqy-Format speichern, bleiben Änderungen an der Formatierung und Spaltenüberschriften nicht erhalten.

Formatierungsänderungen werden in .qry-Dateien erhalten Um die Formatierung in Microsoft Query beizubehalten, nehmen Sie die gewünschten Formatierungsänderungen vor, klicken Sie in Microsoft Query im Menü Datei auf Speichern unter, und klicken Sie in der Liste Dateityp auf Query-Dateien (*.qry). Wenn Sie die Abfragedatei erneut öffnen, wird die Microsoft Query-Formatierung angezeigt.


 Beim Ändern eines OLAP-Cubes gibt eine Meldung an, dass ein Datenverlust aufgetreten ist

Beim Ändern eines OLAP-Cubes gibt eine Meldung an, dass ein Datenverlust aufgetreten ist

Ein in den Cube eingefügtes Feld steht in der Quelldatenbank nicht mehr zur Verfügung.

Prüfen, ob an der Originaldatenbank Änderungen vorgenommen wurden Wenn die beim erstmaligen Erstellen des Cubes eingerichtete Abfrage gespeichert wurde, können Sie die Datenbankabfrage öffnen. Sie können jedoch auch eine neue Abfrage erstellen. Überprüfen Sie den Datenbereich der Abfrage, und vergewissern Sie sich, dass alle ursprünglich hinzugefügten Felder noch in der Abfrage enthalten sind. Im Tabellenbereich können Sie einen Bildlauf durchführen und so feststellen, welche Felder verfügbar sind.

Wenn eine bestehende Abfrage nicht geöffnet oder keine neue Abfrage erstellt werden kann, wenden Sie sich an den Datenbankadministrator, um zu erfahren, welche Änderungen an der Datenbank vorgenommen wurden.

Erstellen eines neuen Cubes Wenn Felder aus der Datenbank entfernt wurden, können Sie einen neuen Cube erstellen.


Dem OLAP-Cube können keine Felder hinzugefügt werden

Nachdem Sie einen OLAP-Cube im OLAP-Cube-Assistenten definiert haben, können Sie diesem keine weiteren Felder aus der ursprünglichen relationalen Datenbank hinzufügen. Wenn Sie weitere Felder einfügen möchten, müssen Sie die Datenbankabfragedatei (.dqy) ändern und anschließend den Cube neu erstellen.

Öffnen oder Erstellen der Abfrage Wenn die beim Erstellen des Cubes eingerichtete Datenbankabfrage gespeichert wurde, können Sie die .dqy-Datei öffnen. Wurde die Abfrage nicht gespeichert, können Sie eine neue Abfrage erstellen.

Hinzufügen von Feldern zu der Abfrage Fügen Sie die Felder hinzu, die für die Abfrage erforderlich sind. Wenn Sie möglicherweise zu einem späteren Zeitpunkt einen Cube mit anderen Feldern benötigen, speichern Sie eine Kopie der Abfrage, damit Sie diese nicht jedes Mal neu erstellen müssen.

Erstellen eines neuen Cubes Wenn Sie über eine Abfrage verfügen, die alle für den Cube benötigten Felder enthält, können Sie einen neuen Cube erstellen.


 Die gewünschte Berechnungsfunktion für die Daten des Cubes ist nicht verfügbar

Die gewünschte Berechnungsfunktion für die Daten des Cubes ist nicht verfügbar

Wenn ein Cube mit Hilfe des OLAP-Cube-Assistenten aus Datensätzen einer relationalen Datenbank erstellt wird, stehen zur Berechnung der Werte in den Datenfeldern nur die Berechnungsfunktionen Summe, Anzahl, Min und Max zur Verfügung.

Direktes Erstellen des Berichts aus den Datenbanksätzen Wenn Sie die Abfrage so einrichten, dass die zurückgegebene Datenmenge problemlos durch das System verarbeitet werden kann und kein OLAP-Cube für die Daten erstellt werden muss, geben Sie die abgefragten Datensätze an Microsoft Excel zurück, anstatt einen Cube zu erstellen.

Wenn Sie in Excel einen PivotTable- oder PivotChart-Bericht erstellen, der direkt auf der relationalen Datenbankabfrage und nicht auf einem Cube basiert, erhalten Sie Zugriff auf eine größere Anzahl von Berechnungsfunktionen: Summe, Anzahl, Mittelwert, Max, Min, Produkt, Anzahl Zahlen, Standardabweichung (Stichprobe), Standardabweichung (Grundgesamtheit), Varianz (Stichprobe) und Varianz (Grundgesamtheit). Weitere Informationen über die Funktionsweise und Verwendung dieser Berechnungsverfahren erhalten Sie in der Hilfe zu Excel.

Einrichten eines OLAP-Servers für die Datenbank Das Microsoft OLAP-Serverprodukt, Microsoft SQL Server OLAP Services, ermöglicht Ihnen die Festlegung einer größeren Anzahl von Berechnungsfeldern als die in Microsoft Office enthaltene OLAP-Clientsoftware.


Zum Speichern einer Offline-Cube-Datei steht nicht ausreichend Festplattenspeicher zur Verfügung

Die relationale Datenbank, für die Sie einen Cube erstellen, ist möglicherweise sehr groß. Wenn Sie eine umfangreiche Teilmenge dieser Daten für die Offline-Cube-Datei vorsehen, steht unter Umständen nicht genug lokaler Festplattenspeicher zur Verfügung.

Freigeben von Festplattenspeicher oder Verwenden eines anderen Datenträgers Löschen Sie vor dem Speichern der Datei alle nicht benötigten Dateien von der Festplatte. Sie können die Datei jedoch auch auf einem Netzlaufwerk speichern.

Übernehmen einer geringeren Datenmenge in die Offline-Cube-Datei Stellen Sie Überlegungen an, wie Sie einerseits die Datenmenge in der Datei möglichst gering halten können, während andererseits alle für die Microsoft Excel PivotTable- und PivotChart-Berichte benötigten Daten berücksichtigt werden. Wählen Sie unter folgenden Möglichkeiten:

  • Nur unbedingt erforderliche Felder einfügen Wählen Sie in Schritt 1 des OLAP-Cube-Assistenten nur die Datenfelder aus, die auf den Berichten angezeigt werden müssen.

  • Nur die benötigten Dimensionen einfügen Fügen Sie in Schritt 2 des OLAP-Cube-Assistenten nur die Felder hinzu, die auf den Berichten als Ebenen und Dimensionen angezeigt werden. Anweisungen zum Erstellen von Dimensionen erhalten Sie in der Hilfe des OLAP-Cube-Assistenten.

Verwenden eines temporären Cubes an Stelle einer Offline-Cube-Datei Wenn Sie alle Daten entfernt haben, bei denen dies möglich war, jedoch weiterhin keine Offline-Cube-Datei speichern können, wählen Sie die erste Option in Schritt 3 des OLAP-Assistenten aus. Bei Wahl dieser Option wird der geringste Festplattenspeicher verwendet und der Cube im Speicher neu aufgebaut, wenn Sie einen Bericht öffnen, der auf dem Cube basiert. Nur die zum Anzeigen dieses Berichts benötigten Daten werden abgerufen.


 Ein Datensatz in der Datenbank kann nicht hinzugefügt, kopiert oder verschoben werden

Ein Datensatz in der Datenbank kann nicht hinzugefügt, kopiert oder verschoben werden

In Microsoft Query 2000 können Sie bereits in der Datenbank vorhandene Datensätze bearbeiten und löschen, Sie können jedoch nicht die Reihenfolge der Datensätze ändern. Sie können mit Query auch nicht Datensätze zu Datenbanken hinzufügen, auf die Sie mit dem Microsoft Excel-Treiber oder dem Microsoft Text-Treiber zugreifen.

Arbeiten Sie direkt in der Datenbank Wenn Sie einen Datensatz kopieren möchten, öffnen Sie die Datenbank direkt, und verwenden Sie die entsprechenden Datenbankbefehle. Um Informationen oder Anleitungen zu erhalten, wenden Sie sich an den Datenbankadministrator.

Sortieren Sie die Datensätze in Query Sie können die Reihenfolge der Datensätze in der Ergebnismenge ändern, indem Sie im Menü Datensätze den Befehl Sortieren verwenden. Das Sortieren in Microsoft Query wirkt sich nicht auf die zugrunde liegende Datenbank aus, sondern lediglich auf die Ergebnismenge. Weitere Informationen erhalten Sie, indem Sie auf [image] klicken.


 Die gewünschten Verknüpfungen können nicht erstellt werden

Die gewünschten Verknüpfungen können nicht erstellt werden

Stellen Sie bei einer Inklusionsverknüpfung sicher, dass die Abfrage nicht mehr als zwei Tabellen umfasst Umfasst die Abfrage mehr als zwei Tabellen, kann keine Inklusionsverknüpfung erstellt werden. Bei den Optionen 2 und 3 im Dialogfeld Verknüpfungen handelt es sich um Inklusionsverknüpfungen.

Eine Abfrage kann nur eine Inklusionsverknüpfung umfassen In einer Abfrage können beliebig viele Exklusionsverknüpfungen (Option 1 im Dialogfeld Verknüpfungen), jedoch nur eine Inklusionsverknüpfung erstellt werden. Wenn Sie Programmiererfahrung in SQL haben, können Sie versuchen, die SQL-Anweisung im Dialogfeld SQL (Menü Ansicht, Befehl SQL) zu ändern, um mehr als eine Inklusionsverknüpfung erstellen zu können.

Informationen zu Verknüpfungen Um Informationen zum Verwenden von Inklusionsverknüpfungen für das Verbinden von Datensätzen zu erhalten, klicken Sie auf [image] .


 Die Ergebnismenge kann nicht als Tabelle in der Datenbank gespeichert werden

Die Ergebnismenge kann nicht als Tabelle in der Datenbank gespeichert werden

Microsoft Query 2000 lässt nicht zu, dass Sie die Ergebnismenge als Tabelle in der Datenbank speichern.

Importieren Sie die Daten aus Excel in die Datenbank Wenn die Datenbank den Import von Daten aus Microsoft Excel unterstützt, können Sie die Ergebnismenge an Microsoft Excel zurückgeben und dann die entsprechenden Datenbankbefehle verwenden, um die Microsoft Excel-Daten als Tabelle zu importieren. In Microsoft Access z. B. steht ein Importassistent für Tabellenblätter zur Verfügung, mit dem Sie eine Tabelle aus Microsoft Excel-Daten erstellen können. Weitere Informationen finden Sie in der Dokumentation oder der Hilfe zur Datenbank.

Importieren Sie eine Textdatei in die Datenbank Wenn die Datenbank den Import von Textdateien unterstützt, können Sie die Ergebnismenge an Microsoft Excel zurückgeben, als Textdatei speichern und dann mit den entsprechenden Datenbankbefehlen als Tabelle importieren. Informationen zum Konvertieren von Text finden Sie in der Microsoft Excel-Hilfe.


 Eine Datenquelle kann nicht gefunden oder gelöscht werden

Eine Datenquelle kann nicht gefunden oder gelöscht werden

Mit früheren Versionen von Microsoft Query erstellte Datenquellen Datenquellen, die mit Versionen von Microsoft Query vor Query 97 erstellt wurden, werden mit einem Sternchen neben dem Namen angezeigt. Alle Datenquellen, einschließlich der neu mit Query 2000 erstellten, werden als Dateien mit der Dateinamenerweiterung .dsn gespeichert. Wenn Sie Datenquellen auflisten möchten, die mit früheren Versionen von Query erstellt wurden, klicken Sie im Dialolgfeld Datenquelle auswählen auf Optionen (Menü Datei, Befehl Neu). Aktivieren Sie dann das Kontrollkästchen Registrierungs-DSNs in Liste verfügbarer Datenbanken einschließen. Wenn sich die Datenquellen an den Standardspeicherorten befinden, können Sie diese im Dialogfeld Datenquelle auswählen markieren und dann löschen, indem Sie auf Löschen klicken.

Speicherorte von Datenquellendateien Datenquellendateien aus früheren Versionen von Microsoft Query werden in der Regel im Unterordner ODBC Datenquellen des Ordners Gemeinsame Dateien gespeichert. Datenquellendateien für Query 2000 werden im Benutzerprofil-Ordner im Verzeichnis \\\Anwendungsdaten\Microsoft\Abfragen gespeichert. Um herauszufinden, welche Ordner zum Speichern von Datenquellendateien verwendet werden, klicken Sie auf Neue Abfrage [image] , klicken Sie auf die Registerkarte Datenbanken und dann auf Optionen.

Suchen und Löschen von Datenquellendateien Gehen Sie nach der folgenden Methode vor, um Datenquellendateien zu suchen und zu löschen:

  • Verwenden der Systemsteuerung von Windows Wenn sich alle Datenquellendateien im Ordner Gemeinsame Dateien\ODBC Datenquellen oder in Ihrem Benutzerprofil-Ordner befinden, doppelklicken Sie in der Systemsteuerung auf das Symbol ODBC-Datenquellen (32-Bit). Klicken Sie dann auf die Registerkarte File DSN, und löschen Sie mit der Schaltfläche Entfernen alle nicht benötigten Dateien mit der Erweiterung .dsn.

  • Suchen nach .dsn-Dateien Wenn sich die Datenquellendateien in verschiedenen Ordnern befinden, verwenden Sie in Microsoft Windows den Befehl Suchen, um alle Dateien mit der Dateinamenerweiterung .dsn zu suchen, und löschen Sie dann alle nicht benötigten Dateien.


Die Abfrage kann nicht bearbeitet werden.

Prüfen Sie, ob das Bearbeiten aktiviert ist Klicken Sie im Menü Bearbeiten auf Optionen. Deaktivieren Sie dann das Kontrollkästchen Bearbeitung von Ergebnismengen nicht zulassen.


 Die gewünschte Tabelle wird nicht angezeigt

Die gewünschte Tabelle wird nicht angezeigt

Wenn die Liste mit Tabellen nicht die erwarteten Tabellen enthält, überprüfen Sie, je nach den für die verwendete Datenquelle verfügbaren Optionen, die folgenden Punkte:

  • Prüfen Sie den Eigentümer Möglicherweise gehören die gewünschten Tabellen einem anderen Eigentümer. Klicken Sie im Dialogfeld Tabellen hinzufügen im Feld Eigentümer auf einen anderen Eigentümer. Der Eigentümer der Tabellen muss Ihnen gegebenenfalls die entsprechenden Berechtigungen einräumen, damit Sie auf die Tabellen zugreifen können.

  • Prüfen Sie die angezeigten Tabellentypen Die gewünschten Tabellen gehören unter Umständen zu einem nicht zur Anzeige ausgewählten Typ. Klicken Sie im Dialogfeld Tabellen hinzufügen auf Optionen. Stellen Sie sicher, dass unter Anzeigen alle Tabellentypen aktiviert sind.

  • Aktualisieren Sie die Liste der Tabellen Möglicherweise wurden die entsprechenden Tabellen der Datenbank erst nach der letzten Verbindung zur Datenbank durch Microsoft Query hinzugefügt. Um neu hinzugefügte Tabellen anzuzeigen, klicken Sie im Dialogfeld Tabellen hinzufügen auf Optionen und dann auf Aktualisieren.


 Es kann keine neue Datenquelle erstellt werden

Es kann keine neue Datenquelle erstellt werden

Prüfen Sie den Treiber Stellen Sie zuerst sicher, dass Sie den entsprechenden ODBC-Treiber oder Datenquellentreiber für Ihre Datenquelle installiert haben. Durch die Verwendung von ODBC- und Datenquellentreibern ist Microsoft Query vielseitig verwendbar. Sie können Verbindungen zu neuen Datenbanken herstellen, sobald diese erhältlich sind, indem Sie einfach neue Treiber installieren. Sie müssen jedoch den angemessenen Treiber für den verwendeten Datenbanktyp installieren und einrichten.

Stellen Sie sicher, dass die Treiber mit Microsoft Query funktionieren Neben den im Lieferumfang von Microsoft Query enthaltenen Treibern können ODBC- und Datenquellentreiber von Drittanbietern verwendet werden. Sie sollten jedoch nur Treiber anderer Hersteller verwenden, die bereits für Microsoft Query 2000 getestet wurden. Bei einigen Datenbanken empfiehlt sich der Einsatz des mit der Datenbank-Software gelieferten Treibers. Wenden Sie sich an den Datenbankadministrator, um herauszufinden, welche Treiber verfügbar sind und Ihren Anforderungen optimal entsprechen. Zeigen Sie eine Liste der mit Query mitgelieferten Treiber an.

Prüfen Sie die Serveradresse und die Anmeldedaten Bevor Sie eine Datenquelle einrichten, müssen Sie sicherstellen, dass Sie die Speicheradresse der Datenbank im Netzwerk kennen und über die entsprechenden Berechtigungen zum Herstellen einer Verbindung zur Datenbank und zum Anmelden verfügen. Wenden Sie sich an den Datenbankadministator, um einen Anmeldenamen, ein Kennwort oder weitere erforderliche Berechtigungen zu erhalten, damit Sie problemlos auf die Datenbank zugreifen können.

Prüfen Sie, ob der Treiber richtig installiert ist Zum Anzeigen einer Liste der verfügbaren ODBC-Treiber klicken Sie auf Neue Abfrage [image] , doppelklicken Sie auf der Registerkarte Datenbanken bzw. auf der Registerkarte OLAP-Cubes auf Neue Datenquelle, geben Sie in Schritt 1 des Dialogfeldes Neue Datenquelle erstellen einen Namen ein, und klicken Sie dann in Schritt 2 auf die Liste. Wenn die Registerkarte OLAP-Cubes nicht verfügbar ist, führen Sie Query über Microsoft Excel aus. Zeigen Sie dazu in Excel im Menü Daten auf Externe Daten, und klicken Sie dann auf Neue Abfrage erstellen. Doppelklicken Sie auf der Registerkarte OLAP-Cubes auf Neue Datenquelle, geben Sie in Schritt 1 des Dialogfeldes Neue Datenquelle erstellen einen Namen ein, und klicken Sie dann in Schritt 2 auf die Liste. Wenn der erforderliche Treiber nicht angezeigt wird, prüfen Sie, ob der Treiber richtig installiert ist. So installieren Sie Treiber.

Prüfen Sie, ob Sie alle Konfigurationsdaten angegeben haben Nachdem der Treiber installiert und im Dialogfeld Neue Datenquelle erstellen in Schritt 2 ausgewählt wurde, müssen Sie in Schritt 3 des Dialogfeldes alle notwendigen Angaben machen. Informationen zu einem Treiber von Microsoft erhalten Sie, indem Sie zuerst auf Verbinden und dann im angezeigten Dialogfeld auf Hilfe klicken. Informationen zu Treibern von Drittanbietern finden Sie in der Hilfe oder der Dokumentation des entsprechenden Treibers.

Wenn Sie eine Datenquelle mit einem ODBC- oder einem Datenquellentreiber von Microsoft einrichten, klicken Sie auf den Namen des Treibers, um Informationen zu den Einstellungen zu erhalten, die Sie im Dialogfeld Neue Datenquelle erstellen in Schritt 3 vornehmen müssen.

ODBC-Treiber

Microsoft Access-Treiber

Microsoft dBASE-Treiber

Microsoft FoxPro-Treiber

Microsoft Excel-Treiber

Microsoft ODBC für Oracle-Treiber

Microsoft Paradox-Treiber

Microsoft Text-Treiber

SQL Server-Treiber

Datenquellentreiber

Microsoft SQL Server OLAP Services-Treiber


 Die Verknüpfungen liefern nicht die erwarteten Datensätze

Die Verknüpfungen liefern nicht die erwarteten Datensätze

Die Abfrage verwendet standardmäßig Exklusionsverknüpfungen Die beim Verknüpfen von Tabellen in Microsoft Query standardmäßig verwendete Verknüpfung ist eine Exklusionsverknüpfung (Option 1 im Dialogfeld Verknüpfungen). Wenn zwei Tabellen mit einer Exklusionsverknüpfung verbunden werden, sind die Datensätze aus der zweiten Tabelle, denen keine Datensätze aus der ersten Tabelle entsprechen, nicht in der Ergebnismenge enthalten.

Erstellen Sie eine Inklusionsverknüpfung Um alle Datensätze aus beiden Tabellen abzufragen, wenn eine Tabelle Datensätze enthält, die in der anderen nicht enthalten sind, verwenden Sie eine Inklusionsverknüpfung (Optionen 2 und 3 im Dialogfeld Verknüpfungen). Informationen zum Einsatz von Inklusionsverknüpfungen zum Kombinieren von Datensätzen erhalten Sie, indem Sie auf [image] klicken.

Prüfen Sie, ob mehrere Verknüpfungen zwischen denselben Tabellen vorhanden sind Es kann vorkommen, dass eine Inklusionsverknüpfung zwischen zwei Tabellen keine Datensätze aus der zweiten Tabelle liefert. Wenn Sie in einem solchen Fall eine Exklusionsverknüpfung zwischen den Tabellen einfügen, kann Microsoft Query von keiner der beiden Tabellen Datensätze abfragen. Um die Datensätze anzuzeigen, müssen Sie eine der Verknüpfungen löschen.

Informationen zu Verknüpfungen Weitere Informationen zu Verknüpfungen erhalten Sie, indem Sie auf [image] klicken.


 Microsoft Query gibt nicht alle verfügbaren Datensätze zurück

Microsoft Query gibt nicht alle verfügbaren Datensätze zurück

Prüfen Sie, ob die Anzahl der zurückzugebenden Datensätze eingeschränkt wurde Stellen Sie sicher, dass die Anzahl der zurückzugebenden Datensätze nicht eingeschränkt wurde. Klicken Sie im Menü Bearbeiten auf Optionen, und vergewissern Sie sich, dass unter Benutzereinstellungen das Kontrollkästchen Anzahl der zurückgegebenen Datensätze auf ... begrenzen deaktiviert ist.

Prüfen Sie die Kriterien Stellen Sie sicher, dass alle angegebenen Kriterien korrekt eingegeben wurden, so dass die gewünschten Datensätze abgefragt werden. Weitere Informationen zum Eingeben von Kriterien erhalten Sie, indem Sie auf [image] klicken.

Prüfen Sie die Verknüpfungen Stellen Sie sicher, dass alle erstellten Verknüpfungen die gewünschten Auswirkungen haben. Um Sie weitere Informationen zu Verknüpfungen zu erhalten, klicken Sie auf [image] .


 Microsoft Query kann wiederholt in der vorgegebenen Zeit keine Verbindung zur Datenbank herstellen

Microsoft Query kann wiederholt in der vorgegebenen Zeit keine Verbindung zur Datenbank herstellen

Legen Sie eine längere Verbindungszeit fest Standardmäßig versucht Microsoft Query für eine vom ODBC-Treiber der Datenquelle vorgegebene Zeitdauer, die Verbindung zur Datenbank herzustellen. Wenn der Aufbau von Verbindungen zur Datenbank in der Regel mehr Zeit in Anspruch nimmt, können Sie eine längere Zeitdauer einstellen. Klicken Sie in Microsoft Query im Menü Bearbeiten auf Optionen, stellen Sie sicher, dass das Kontrollkästchen Abbrechen, wenn die Verbindung nicht innerhalb von ... zustandekommt aktiviert ist, und geben Sie dann die für den Aufbau der Verbindung zulässige Zeitdauer in Sekunden ein.

Geben Sie an, dass Query ohne Zeitbeschränkung versuchen soll, eine Verbindung herzustellen Wenn Microsoft Query Verbindungen ohne Zeitbeschränkung aufbauen soll, deaktivieren Sie das Kontrollkästchen Abbrechen, wenn die Verbindung nicht innerhalb von ... zustande kommt. Wenn Microsoft Query keine Verbindung zur Datenbank herstellen kann, können Sie den Versuch abbrechen, indem Sie auf ESC drücken.


 Von Microsoft Query aus kann nicht auf Daten in einer Microsoft Excel-Liste zugegriffen werden

Von Microsoft Query aus kann nicht auf Daten in einer Microsoft Excel-Liste zugegriffen werden

Schließen Sie die Arbeitsmappe Bevor Sie versuchen, auf Daten zuzugreifen, stellen Sie sicher, dass die Arbeitsmappe nicht in Microsoft Excel geöffnet ist.

Prüfen Sie das Tabellenblatt Überprüfen Sie im Microsoft Excel-Tabellenblatt die folgenden Punkte:

  • Prüfen Sie das Listenformat Stellen Sie sicher, dass die Liste im Microsoft Excel-Listenformat vorliegt. (Informationen und Anleitungen zum Erstellen von Listen in Tabellenblättern finden Sie in der Microsoft Excel-Hilfe.) Benennen Sie die Bereiche, bei denen es sich um Tabellen handelt. Jeder Bereich muss einen anderen Namen erhalten.

  • Benennen Sie die Liste Microsoft Query erkennt nur benannte Bereiche als Tabellen. Um eine Liste zu benennen, markieren Sie die gesamte Liste in Microsoft Excel, und geben Sie dann im Namenfeld auf der Bearbeitungsleiste den Namen ein.

  • Greifen Sie auf die Liste nicht als Systemtabelle zu Greifen Sie nicht auf Microsoft Excel-Tabellen zu, indem Sie im Dialogfeld Tabellenblattoptionen unter Anzeigen auf die Option Systemtabellen klicken. Dies kann dazu führen, dass Microsoft Query leere Zellen in der Tabelle mit Daten verwechselt, die tatsächlichen Daten nicht erkennt und die Daten eventuell nicht ordnungsgemäß abruft.

  • Formatieren Sie Listen so, dass Daten nach derselben Methode kombiniert werden Verwenden Sie für alle Spalten in den zu kombinierenden Listen dasselbe Format. Wenn sich beispielsweise in jeder Liste eine Datumsspalte befindet, verwenden Sie für alle Spalten dasselbe Datumsformat. Wenn Sie innerhalb einer Spalte Text- und Zahlenformate verwenden, kann der Microsoft Excel-Treiber möglicherweise nicht alle Daten finden und zusammenführen.

  • Verwenden Sie keine Spaltenbeschriftungen wie "Tabelle" oder "Datenbank" Microsoft Query verwendet bestimmte Spaltenbeschriftungen intern und erkennt diese nicht in den Daten.

  • Verschieben Sie alle Arbeitsmappen in denselben Ordner Mit einer für den Microsoft Excel-Treiber eingerichteten Datenquelle kann immer nur gleichzeitig auf die Arbeitsmappen eines Ordners zugegriffen werden. Befinden sich die Listen in unterschiedlichen Arbeitsmappen, stellen Sie sicher, dass sich beide Arbeitsmappen in demselben Ordner wie die Arbeitsmappe befinden, die Sie beim Einrichten der Datenquelle angegeben haben.

  • Verschieben Sie Arbeitsmappen in den Ordner, der für die Datenquelle angegeben ist Bevor Sie Microsoft Query starten, stellen Sie sicher, dass Sie alle zu verwendenden Arbeitsmappen in den in der Datenquelle angegebenen Ordner kopiert haben. Microsoft Query kann neue Arbeitsmappen, die beim Erstellen einer Abfrage in den Ordner kopiert werden, nicht automatisch erkennen. Sie können auf neue Arbeitsmappen zugreifen, indem Sie im Dialogfeld Tabellen hinzufügen auf Optionen und dann auf Aktualisieren klicken.

Verwenden Sie Excel zum Kombinieren von Daten Der Einsatz von Microsoft Query empfiehlt sich, wenn Sie Daten aus mindestens zwei Microsoft Excel-Listen kombinieren möchten. Wenn Sie mit Daten in einem einzelnen Tabellenblatt arbeiten oder Zeilen mit Hilfe einfacher Kriterien in einem Tabellenblatt auswählen möchten, bieten sich die Microsoft Excel-Befehle AutoFilter und Spezialfilter (Menü Daten, Untermenü Filter) an. Weitere Informationen zu Auto- und Spezialfiltern finden Sie in der Microsoft Excel-Hilfe.


Die Bearbeitung von Parametertypen für die SQL-Prozedur ist in Microsoft Query nicht möglich

So erstellen Sie Parameter in einer SQL-gespeicherten Prozedur und geben die Datentypen an:

  1. Klicken Sie im Menü Datei auf SQL ausführen.

  2. Erstellen Sie die Abfrage im Feld SQL ausführen. Verwenden Sie feststehende Argumente für die Prozedur, und klicken Sie dann auf Speichern.

  3. Klicken Sie im Menü Ansicht auf SQL.

  4. Ersetzen Sie im Feld SQL-Anweisung jedes feststehende Argument durch ?

  5. Klicken Sie auf OK und dann im Menü Ansicht auf Parameter.

  6. Um den Datentyp eines Parameter zu ändern, klicken Sie auf den Parameter und dann auf Bearbeiten.


 Adressetiketten können in Microsoft Query nicht erstellt werden

Adressetiketten können in Microsoft Query nicht erstellt werden

Query ruft Daten für Etiketten ab Microsoft Query ist ein Tool zum Abfragen von Daten aus einer Datenbank und dient nicht zum Erstellen von Adressetiketten. Sie können jedoch die mit Query abgerufenen Daten in Microsoft Excel und Microsoft Word zum Erstellen von Adressetiketten verwenden.

Erstellen Sie die Etiketten in Word Geben Sie zuerst die Daten an Excel zurück, indem Sie im Menü Datei auf Daten an Microsoft Excel zurückgeben klicken. Sobald sich die Ergebnismenge in Excel befindet, können Sie die Daten in Word als Adressliste verwenden. Sie können auch zuerst die Etiketten in Word erstellen und dann die Daten direkt aus Query an Word zurückgeben. Weitere Informationen zu Adressetiketten finden Sie in der Hilfe von Excel bzw. Word.


 Die Ergebnismenge kann in Microsoft Query nicht gedruckt werden

Die Ergebnismenge kann in Microsoft Query nicht gedruckt werden

Query hat keine Druckfunktionen Microsoft Query ist ein Tool zum Abfragen von Daten aus einer Datenbank. Berichte können nicht direkt von Query aus gedruckt werden.

Drucken Sie die Datensätze in Excel Um die Ergebnismenge zu drucken, geben Sie dieses an Microsoft Excel zurück, indem Sie im Menü Datei auf Daten an Microsoft Excel zurückgeben klicken. Sobald sich die Ergebnismenge in Microsoft Excel befindet, können Sie die Daten mit allen verfügbaren Druck- und Formatierungsbefehlen bearbeiten und drucken. Weitere Informationen zum Drucken in Microsoft Excel finden Sie in der Microsoft Excel-Hilfe.


 Microsoft Query verwendet weiterhin Verbindungsressourcen, ohne dass mit einer Datenbank gearbeitet wird

Microsoft Query verwendet weiterhin Verbindungsressourcen, ohne dass mit einer Datenbank gearbeitet wird

Verbindungen bleiben während einer Query-Sitzung offen Standardmäßig stellt Microsoft Query eine einzige Verbindung zur Datenbank her und hält diese bis zum Beenden von Microsoft Query aufrecht, unabhängig davon, wie viele Fenster Sie zu dieser Zeit für Abfragen der Datenbank öffnen. Wenn Sie während einer Microsoft Query-Sitzung Abfragen von mehr als einer Datenbank erstellen, werden durch die offenen Verbindungen unter Umständen die Ressourcen übermäßig in Anspruch genommen und die Verbindungszeit erhöht.

Schließen Sie die Verbindungen, wenn Sie die Abfragefenster schließen Um die Verbindungszeit zu reduzieren, kann Microsoft Query die Verbindung beenden, wenn kein Abfragefenster für eine Datenbank geöffnet ist. Um die Verbindung nur so lange aufrecht zu erhalten wie ein Abfragefenster geöffnet ist, klicken Sie im Menü Bearbeiten auf Optionen, und deaktivieren Sie das Kontrollkästchen Verbindungen aufrechterhalten, bis Microsoft Query beendet wird.


 Warum wird neben der Datenquelle ein Sternchen angezeigt?

Warum wird neben der Datenquelle ein Sternchen angezeigt?

Die Datenquelle stammt aus einer früheren Version von Microsoft Query Query 2000- und Query 97-Datenquellen verfügen über ein anderes Format als Datenquellen, die mit Versionen vor Microsoft Query 97 erstellt wurden. Die mit früheren Microsoft Query-Versionen erstellten Datenquellen und Abfragen können zwar in Microsoft Query 2000 verwendet werden, sie können jedoch nicht für andere Benutzer freigegeben werden. In Versionen vor Query 97 werden Informationen zur Datenquelle als Teil des Betriebssystems Microsoft Windows gespeichert, und diese Informationen sind dann nur auf Ihrem System verfügbar.

Datenquellen, die nicht gemeinsam genutzt werden können Wenn Sie Datenquellen verwenden möchten, die mit früheren Versionen von Microsoft Query erstellt wurden, klicken Sie im Dialogfeld Datenquelle auswählen auf Optionen (Menü Datei, Befehl Neu), und aktivieren Sie dann das Kontrollkästchen Registrierungs-DSNs in Liste verfügbarer Datenbanken einschließen. Bei allen Datenquellen, die mit früheren Versionen als Microsoft Query 97 erstellt wurden, wird im Dialogfeld Datenquelle auswählen ein Sternchen neben dem Namen angezeigt.

Erstellen von Datenquellen, die gemeinsam genutzt werden können Wenn Sie Abfragen oder Berichtsvorlagen freigeben möchten, die Daten aus externen Datenbanken verwenden, die in nicht gemeinsam nutzbaren Datenquellen angegebenen sind, erstellen Sie neue Microsoft Query 2000-Datenquellen für diese Datenbanken, und verwenden Sie dann die neuen Datenquellen zum Erstellen der Abfragen, Abfragedateien und Berichtsvorlagen.

Löschen von nicht mehr benötigten Datenquellen So löschen Sie Datenquellen, die nicht gemeinsam genutzt werden können.


Der OLAP-Cube kann nicht geändert werden

Sicherstellen, dass die Originaldatenbank verfügbar ist Wenn Sie Änderungen an einem OLAP-Cube vornehmen möchten, müssen Sie Zugriff auf die ursprüngliche Serverdatenbank besitzen, aus der die Daten für den Cube übernommen wurden. Überprüfen Sie den Speicherort dieser Datenbank, und vergewissern Sie sich, dass die Datenbank nicht umbenannt oder verschoben wurde. Stellen Sie sicher, dass der Server verfügbar ist und dass eine Verbindung zu dem Server hergestellt werden kann.

Prüfen, ob Änderungen an der Originaldatenbank vorgenommen wurden Möglicherweise wurden Tabellen in der Datenbank umbenannt oder gelöscht, so dass die Originaldaten für den Cube nicht mehr gefunden werden können. Prüfen Sie, ob Änderungen an der Organisation oder dem Schema der Datenbank durchgeführt wurden. Zu diesem Zweck können Sie die Datenbankabfrage öffnen, sofern die Abfrage beim erstmaligen Erstellen des Cubes gespeichert wurde. Sie können jedoch auch eine neue Abfrage erstellen. Klicken Sie im Menü Tabelle auf Tabellen hinzufügen, um die verfügbaren Tabellen anzuzeigen. Wenn Sie keine bestehende Abfrage öffnen und keine neue Abfrage erstellen können, wenden Sie sich an den Datenbankadministrator, um zu erfahren, inwieweit Änderungen an der Datenbank durchgeführt wurden.


 Eine Meldung gibt an, dass der OLAP-Cube-Assistent die .oqy-Datei nicht öffnen kann

Eine Meldung gibt an, dass der OLAP-Cube-Assistent die .oqy-Datei nicht öffnen kann

Sicherstellen, dass die Datei ursprünglich durch den Assistenten erstellt wurde Sie können .oqy-Dateien nur öffnen und ändern, wenn sie im OLAP-Cube-Assistenten erstellt und gespeichert wurden. Sonstige .oqy-Dateien, die keine Cubedefinition enthalten, wie z. B. die Dateien, mit denen eine Verbindung zu einer OLAP-Serverdatenbank oder einer Offline-Cube-Datei hergestellt wird, können nicht in dem Assistenten geöffnet und bearbeitet werden.

Neuerstellen der .oqy-Datei Wenn Sie eine durch den OLAP-Cube-Assistenten erstellte .oqy-Datei nicht öffnen können, ist die Datei möglicherweise beschädigt. Versuchen Sie, eine Sicherungskopie der Datei zu öffnen. Wenn keine Sicherungskopie vorhanden ist, erstellen Sie den Cube erneut.


Da die Datenbank schreibgeschützt ist, können Sie keine Tabellen erstellen. Möchten Sie fortfahren?

Sie können in einer schreibgeschützten Datenbank Tabellendefinitionen anzeigen, jedoch keine neuen Tabellen erstellen oder bereits bestehende Tabellen löschen.


Datensatz konnte nicht gefunden werden. Zur Identifikation sind weitere Spalten erforderlich. Möglicherweise ist der Datensatz von einem anderen Benutzer geändert worden

Microsoft Query kann einen in der Abfrage aktualisierten oder gelöschten Datensatz in der zugrunde liegenden Tabelle nicht finden. Möglicherweise befinden sich zur Identifizierung des zu aktualisierenden Datensatzes nicht genügend Spalten in der Abfrage, oder ein anderer Benutzer hat den Datensatz seit der letzten Abfrage geändert. Bevor Sie den Datensatz aktualisieren, gehen Sie nach einem der folgenden Verfahren vor:

  • Fügen Sie der Abfrage mehr Spalten bzw. die Spalte hinzu, mit der der Datensatz eindeutig identifiziert werden kann.

  • Führen Sie die Abfrage nochmals aus, um die aktuellsten Daten der zugrunde liegenden Tabelle zu erhalten. Klicken Sie dazu im Menü Datensätze auf Jetzt abfragen.


Es sind Fernverknüpfungen vorhanden; möchten Sie trotzdem schließen?

Die Daten in der Abfrage sind mit einem anderen Programm verknüpft, z. B. mit Microsoft Excel oder Microsoft Word.

  • Um die Abfrage und die Verknüpfung zu schließen, klicken Sie auf OK. Wenn Sie die Abfrage schließen, können Sie die Verknüpfung nicht wiederherstellen.

  • Um die Abfrage und die Verknüpfung geöffnet zu lassen, klicken Sie auf Abbrechen.


Möchten Sie den großen Zwischenablageinhalt von <Name> speichern?

Sie haben eine große Datenmenge in der Zwischenablage gespeichert.

  • Um die Daten in der Zwischenablage zu speichern und die Abfrage zu schließen oder Microsoft Query zu beenden, klicken Sie auf Ja.

  • Um die Daten in der Zwischenablage zu löschen und die Abfrage zu schließen oder Microsoft Query zu beenden, klicken Sie auf Nein.

  • Um weiterhin in Microsoft Query zu arbeiten und die Daten nicht aus der Zwischenablage zu entfernen, klicken Sie auf Abbrechen.


Die Funktionen der Sprechblase des Office-Assistenten werden nicht ordnungsgemäß ausgeführt

  • Es kann vorkommen, dass sich die Sprechblasen überlagern. Schließen Sie die Sprechblase im Vordergrund, um die dahinterliegende Sprechblase anzuzeigen.

  • Meldungen und Erinnerungen werden beim Aufrufen der Hilfe ausgeblendet, werden jedoch automatisch wieder eingeblendet, sobald Sie das Hilfefenster schließen oder auf eine beliebige Stelle im Microsoft Query-Fenster klicken.

  • Wenn Sie zu einem anderen Office-Programm wechseln, wird die Sprechblase des ersten Programms ausgeblendet. Meldungen sind programmspezifisch und gelten nur für das aktive Programm.

  • Einige Sprechblasen des Office-Assistenten werden beim Klicken auf das Microsoft Query-Fenster automatisch geschlossen. Diese Meldungen sind rein informativ und erfordern keine Reaktion von Ihnen.


Die Arbeit in Microsoft Query kann nicht fortgesetzt werden

Manche Meldungen, unabhängig davon, ob sie vom Office-Assistenten angezeigt werden, müssen erst geschlossen werden, bevor Sie in Microsoft Query weiterarbeiten können. Es handelt sich hierbei um wichtige Meldungen, die eine Reaktion von Ihnen erfordern.

Um mit der Arbeit in Microsoft Query fortzufahren, klicken Sie auf eine der Optionsschaltflächen in der Meldung. Wenn Microsoft Query an Stelle der Meldung ein Hilfethema anzeigt, klicken Sie auf eine beliebige Stelle im Microsoft Query-Fenster, um die Meldung erneut anzuzeigen.


Abrufen verwandter Datensätze aus mehreren Tabellen mit Verknüpfungen

Verknüpfen von Tabellen
Exklusionsverknüpfungen
Inklusionsverknüpfungen
Reflexivverknüpfungen
Vollständige Inklusionsverknüpfungen
Subtraktionsverknüpfungen


Abrufen verwandter Datensätze aus mehreren Tabellen mit Verknüpfungen


Änderungen in <Name> speichern?

Sie haben seit dem letzten Speichern Änderungen am Entwurf oder Format der aktuellen Abfrage vorgenommen.

  • Klicken Sie auf Ja, wenn Sie die Änderungen an der Abfrage vor dem Schließen speichern möchten.

  • Klicken Sie auf Nein, wenn Sie die Änderungen verwerfen und die Abfrage schließen möchten.

  • Klicken Sie auf Abbrechen, wenn Sie die Abfrage nicht schließen und die Änderungen nicht speichern möchten.


Die SQL-Anweisung wurde erfolgreich ausgeführt: <Anzahl> Zeilen betroffen

Microsoft Query hat die angegebene SQL-Anweisung ausgeführt. Dies hat Auswirkung auf die angezeigte Anzahl von Zeilen (Datensätzen).


SQL-Ausführung fehlgeschlagen

Microsoft Query kann die SQL-Anweisung nicht ausführen. Stellen Sie sicher, dass Sie die Anweisung richtig eingegeben haben.


Die Tabelle <Name> existiert bereits; wollen Sie sie ersetzen?

Eine Tabelle dieses Namens besteht bereits.

  • Wenn Sie die bisherige Tabelle durch eine neue ersetzen möchten, klicken Sie auf Ja.

  • Wenn Sie die bisherige Tabelle nicht ersetzen möchten, klicken Sie auf Nein, und geben Sie einen anderen Namen für die neue Tabelle ein.


Möchten Sie die Datei unter <Name> speichern?

Sie haben versucht, die zurückgegebenen Datensätze als Tabelle ohne oder mit falscher Dateinamenserweiterung zu speichern.

  • Um die zurückgegebenen Datensätze in einer Datei zu speichern, die über eine für die Datenquelle gültige Dateinamenserweiterung verfügt, klicken Sie auf OK.

  • Um zu Microsoft Query zurückkehren, ohne die zurückgegebenen Datensätze zu speichern, klicken Sie auf Abbrechen.


Die andere Anwendung wurde beendet

Das andere Programm im DDE-Datenaustausch (Dynamic Data Exchange) ist unerwartet beendet worden. Starten Sie dieses Programm neu, bevor sie den DDE-Datenaustausch erneut beginnen.


Eine SQL-Abfrage kann nicht grafisch dargestellt werden. Möchten Sie trotzdem fortfahren?

Microsoft Query kann das Tabellenfenster für diese Abfrage nicht anzeigen. Wenn die Abfrage Datensätze zurückgibt, können Sie im Query-Fenster weder diese noch den Abfrageentwurf bearbeiten. Sie können den Abfrageentwurf jedoch bearbeiten, indem sie im Menü Ansicht auf SQL klicken und die SQL-Anweisung direkt bearbeiten.


Timeout während des Wartens auf eine DDE-Antwort

Das andere Programm im DDE-Datenaustausch (Dynamic Data Exchange) hat nicht innerhalb der mit der Option DDE-Timeout festgelegten Zeitspanne reagiert.

  • Das andere Programm wartet möglicherweise auf eine Benutzereingabe. Wechseln Sie zu dem Programm, und schließen Sie das Dialogfeld, oder reagieren Sie auf die vom anderen Programm angezeigte Nachricht.

  • Das andere Programm ist möglicherweise zu beschäftigt, um auf DDE-Meldungen zu reagieren.

Anmerkung Sie können die in der Option DDE-Timeout festgelegte Zeit nicht ändern.


<Text> wurde nach der Spaltenliste in der GROUP BY-Klausel nicht erwartet

Der Ausdruck oder die Klausel nach der Spaltenliste in der GROUP BY-Klausel ist ungültig.


<Text> wurde nach der HAVING-Klausel nicht erwartet

Der Ausdruck oder die Klausel nach der HAVING-Klausel in der SQL-Anweisung ist ungültig.


<Text> wurde nach der Spaltenliste in der ORDER BY-Klausel nicht erwartet

Der Ausdruck oder die Klausel nach der Spaltenliste in der ORDER BY-Klausel ist ungültig.


<Text> wurde nach der SELECT-Spaltenliste nicht erwartet

Der Ausdruck oder die Klausel nach der Auswahlliste in der SELECT-Anweisung ist ungültig.


<Text> wurde nach WHERE-Klausel nicht erwartet

Der Ausdruck oder die Klausel nach der WHERE-Klausel in der SQL-Anweisung ist ungültig.


Es sind zu viele Werte ausgewählt

Es ist nicht genügend Speicher vorhanden, um alle angegebenen Werte als Kriterien für dieses Feld zu speichern. Geben Sie weniger Werte an.


Keine bekannte Maßeinheit

Microsoft Query kann die für diese Option eingegebenen Zeichen nicht erkennen. Geben Sie eine Zahl für das Maß ein, jedoch keine Zeichen für die Maßeinheit, wie z. B. " (für Zoll) oder "cm" (für Zentimeter).


Die Aktualisierung ist fehlgeschlagen. Datensatz weiter bearbeiten?

Microsoft Query kann die bearbeiteten Daten nicht aktualisieren, da die zugrunde liegende Tabelle oder Datenquelle schreibgeschützt bzw. beschädigt ist oder nicht genug Speicherplatz auf dem Datenträger zur Verfügung steht, um die Änderungen zu speichern.


<Wert> hat zu viele Dezimalstellen

Der Wert übersteigt die Anzahl der für Werte in diesem Feld zulässigen Dezimalstellen. Verwenden Sie weniger Stellen.


<Wert> ist kein logischer Wert

Sie haben einen nichtlogischen Wert in ein Feld für logische Werte eingegeben, z. B. ein Datum in ein Feld, in dem nur die Werte "0" und "1" zulässig sind.


<Wert> ist kein gültiges Datum

Sie haben einen falschen Wert eingegeben, z. B. Text in ein Datumsfeld.


<Wert> ist keine gültige Zahl

Sie haben einen falschen Wert eingegeben, z. B. Text in ein Feld für numerische Werte.


<Wert> ist größer als der numerische Bereich dieser Spalte

Der Wert überschreitet den für diese Spalte (dieses Feld) zulässigen Maximum. Geben Sie einen kleineren Wert ein.


Bestehende Tabellen können nicht geändert werden. Änderungen können zum Erstellen einer neuen leeren Tabelle verwendet werden

Um aus einer bereits bestehenden Tabelle eine neue Tabelle zu erstellen, müssen Sie den Tabellennamen im Dialogfeld Tabellendefinition ändern. Die neue Tabelle enthält nicht die in der bereits bestehenden Tabelle gespeicherten Daten. Bereits bestehende Tabellendefinitionen können in Microsoft Query nicht bearbeitet werden.


Ungültige Erweiterung <Erweiterung>

Der angegebene Tabellenname enthält keine gültige Dateinamenserweiterung. Schlagen Sie die gültige Dateinamenserweiterung in der Dokumentation für die Datenquelle nach.


Ausdruck zu komplex

Dem Ausdruck kann kein Wert zugewiesen werden, weil er zu umfangreich ist. Versuchen Sie, den Ausdruck zu vereinfachen.


Syntaxfehler

Der Ausdruck enthält einen Syntaxfehler. Möglicherweise fehlt der Operand oder der Operator, oder Sie haben ein ungültiges Zeichen oder Komma bzw. Text ohne Anführungszeichen ( " oder ' ) verwendet. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.


Syntaxfehler in Datum

Der Ausdruck enthält einen ungültigen Datumswert. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.


Unzulässige Verwendung von '.', '!', oder '()'

Der Ausdruck enthält einen ungültigen Operator . (Punkt) oder ! bzw. eine ungültige runde Klammer. Möglicherweise haben Sie einen ungültigen Bezeichner oder eine runde Klammer nach der Null-Konstante eingegeben. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.


Syntaxfehler in Zahl

Der Ausdruck enthält eine ungültige Zahl. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.


Syntaxfehler in Zeichenfolge

Der Ausdruck enthält eine ungültige Zeichenfolge. Möglicherweise haben Sie die maximale Zeichenlänge überschritten. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.


Zwischen Operator ohne 'Und'

Wenn Sie den Operator Zwischen...Und verwenden, müssen Sie das reservierte Wort Und eingeben. Verwenden Sie folgende Syntax:

Ausdruck Zwischen Wert1 Und Wert2


Extra ')'

Der Ausdruck enthält zu viele schließende runde Klammern. Löschen Sie die Klammern, für die keine öffnenden runden Klammern vorhanden sind.


Speichermangel während der Berechnung

Es steht nicht genügend Speicher zur Verfügung, um Berechnungen durchzuführen.

Schließen Sie Fenster in Microsoft Query, oder schließen Sie andere Programme. Wenn der Fehler erneut auftritt, starten Sie Microsoft Windows neu, und wiederholen Sie die Berechnung.


Fehlende ')', ']', oder '|'

Es fehlt eine runde schließende Klammer, eine eckige schließende Klammer oder eine vertikale Linie im Ausdruck. Stellen Sie sicher, dass Sie den Ausdruck richtig eingegeben haben.