 Auswählen eines Tools für die Replikation

Auswählen eines Tools für die Replikation

Sie können sieben unterschiedliche Tools für die Replikation und Synchronisierung von Datenbanken einsetzen:

  • Die Aktenkoffer-Replikation ist ein geeignetes Tool, um eine Datenbankdatei aktuell zu halten. Sie können zum Beispiel eine Datenbankdatei, die sich auf Ihrem Computer im Büro befindet, auf das Symbol Aktenkoffer auf Ihrem Laptop ziehen. Damit wird ein Replikat erstellt. Wenn Sie weitere Informationen dazu aufrufen möchten, klicken Sie auf [image] .

  • Mit den Replikationsbefehlen im Microsoft Access-Menü Extras einer Datenbank und in einem Projekt können Sie Replikate erstellen und diese bei Bedarf beim Arbeiten in Microsoft Access synchronisieren. Wenn Sie weitere Informationen zur Replikation in einer Datenbank benötigen, klicken Sie auf [image] . Wenn Sie weitere Informationen zur Replikation in einem Projekt benötigen, klicken Sie auf [image] .

  • Datenzugriffsobjekte (DAO) und Jet and Replication-Objekte (JRO) umfassen Methoden und Eigenschaften, die Entwickler nutzen können, um per Softwaresteuerung Datenbanken und Projekte zu replizieren und zu synchronisieren. Wenn Sie weitere Informationen zu DAO benötigen, klicken Sie auf [image] . Wenn Sie weitere Informationen zu JRO benötigen, klicken Sie auf [image] .

  • Der Microsoft Replikations-Manager ist ein vollwertiges Tool zum Verwalten von Replikaten, Festlegen von Zeitplänen für die Synchronisierung und für das Anzeigen von Mitgliedern der Replikatgruppe. Er ist für Besitzer von Microsoft Office 2000 Developer verfügbar. Wenn Sie weitere Informationen dazu benötigen, klicken Sie auf [image] .


 Microsoft Replikations-Manager

Microsoft Replikations-Manager

Sie können den Microsoft Replikations-Manager für folgende Zwecke verwenden:

  • Verwalten einer großen Anzahl an Replikaten.

  • Unterstützen von Laptop-Benutzern, die nicht immer über eine Verbindung zu einem Netzwerk verfügen.

  • Einfaches Erstellen von Replikaten für mehrere Datenbanken.

  • Festlegen von Zeitplänen für das Synchronisieren der Mitglieder der Replikatgruppe.

  • Ergreifen von Maßnahmen zur Fehlerbehebung.

Der Replikations-Manager bietet eine visuelle Schnittstelle für das Festlegen von Designmastern, für das Erstellen von Replikaten, das Anzeigen der Verbindungen zwischen Mitgliedern einer Replikatgruppe sowie für das Einstellen von Eigenschaften für Replikate.

Anmerkung Wenn Sie ein globales Replikat verschieben oder kopieren, bei dem es sich um ein Hub-Replikat für lokale oder anonyme Replikate handelt, und wenn Sie dabei nicht im Replikat-Manager den Befehl Replikat verschieben verwenden, ist es nicht mehr möglich, das globale Replikat mit den lokalen oder anonymen Replikaten in der Replikatgruppe zu synchronisieren. Ebensowenig können die lokalen oder anonymen Replikate dann noch mit dem globalen Replikat synchronisiert werden, über das sie erstellt wurden.


 Neues bei der Replikation

Neues bei der Replikation

Die Replikationsbefehle im Menü Extras einer Microsoft Access-Datenbank (.mdb) und eines Microsoft Access-Projekts (.adp) ermöglichen es Ihnen, Replikate zu erstellen und diese bei Bedarf beim Arbeiten in Microsoft Access zu synchronisieren.

  • Replikation in einem Access-Projekt Replizieren Sie Daten in einem Access-Projekt, indem Sie Publikationen und Abonnements erstellen.

  • Jet and Replication-Objekte (JRO) JRO umfasst Methoden und Eigenschaften, mit deren Hilfe Entwickler Datenbanken und Access-Projekte per Programmsteuerung replizieren und synchronisieren können.

  • Webserverreplikation Arbeiten Sie an Dateien, auch wenn Sie nicht mehr mit einem Webserver verbunden sind.

  • Replikatspriorität Einem Replikat wird bei seiner Erstellung in der Replikatgruppe eine Priorität zugewiesen. Bei einem Konflikt während der Synchronisierung gewinnt das Replikat mit der höchsten Priorität.

  • Option "Löschen blockieren" Diese Option verhindert, dass Benutzer Datensätze in einem Replikat löschen.

  • Lokale und anonyme Replikate Erstellen Sie lokale und anonyme Replikate. Lokale und anonyme Replikate werden nur mit ihrem übergeordneten, globalen Replikat synchronisiert. Anonyme Replikate werden für Internet-Anwendungen empfohlen, wenn eine große Anzahl von Replikaten benötigt wird.

  • Microsoft-Replikationskonflikt-Viewer Der Microsoft-Replikationskonflikt-Viewer ist in Access das Standardtool zum Abstimmen und Beheben von Synchronisierungskonflikten.

  • Row Level Tracking-Eigenschaft (Konfliktlösung auf Datensatzebene) Wenn für diese Tabelleneigenschaft True eingestellt ist, wird damit angegeben, dass Konflikte auf der Datensatzebene einer Tabelle verwaltet werden. Standardmäßig werden Konflikte auf Spaltenebene verwaltet.

  • ConflictFunction-Eigenschaft Diese Eigenschaft wird verwendet, um den Microsoft-Replikationskonflikt-Viewer von Microsoft Access durch ein angepasstes Verfahren zu ersetzen, das Benutzer beim Lösen von Synchronisierungskonflikten unterstützt.

  • Aufbewahrungsdauer Steuert, wie viele Tage nicht synchronisierte Datensätze in den Systemtabellen aufbewahrt werden.

  • Synchronisierungskonflikte Es wird ein einfacher Mechanismus zum Erfassen und Beheben von Konflikten und Fehlern eingesetzt. Dies erleichtert die Konfliktlösung. Wenn ein Konflikt auftritt, wird die Änderung ausgewählt, die den Konflikt gewinnt, und dann in allen Replikaten übernommen. Die Änderung, die verliert, wird als Konflikt in allen Replikaten erfasst.

  • Konfliktlösung auf Spaltenebene Konflikte werden auf Spaltenebene festgestellt. Bei Änderungen an dem gleichen Datensatz in zwei unterschiedlichen Replikaten entsteht nur dann ein Synchronisierungskonflikt, wenn die Änderung in der gleichen Spalte oder im gleichen Feld erfolgt ist.


Problembehandlung bei Replikationsproblemen in einer Datenbank

Warum wurde meine Tabelle oder meine Abfrage umbenannt?

Wenn ich Daten in einem Mitglied der Replikatgruppe ändere, werden diese Änderungen in einem anderen Mitglied nicht übernommen.

Wenn ich das Design eines Objekts im Designmaster ändere, ändert sich keines der Replikate.

Ich kann den Designmaster nicht finden.

Ich kann den Designmaster nicht öffnen.

Ich kann ein Replikat nicht als Designmaster definieren.

In der Replikatgruppe gibt es zwei Designmaster.

Ich möchte zum Beheben von Synchronisierungskonflikten ein anderes Programm verwenden.

Ich möchte die Replikation nicht verwenden, wenn ich eine Datenbankdatei in den Aktenkoffer ziehe. Wie umgehe ich die Aktenkoffer-Replikation?


 Bestimmen eines Replikats zum neuen Designmaster

Bestimmen eines Replikats zum neuen Designmaster

  1. Stellen Sie sicher, dass weder das Replikat noch der aktuelle Designmaster momentan anderweitig verwendet werden.

  2. Öffnen Sie das Replikat, das Sie als neuen Designmaster verwenden möchten.

  3. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Jetzt synchronisieren.

  4. Wählen Sie den aktuellen Designmaster als dasjenige Mitglied aus, mit dem synchronisiert werden soll.

  5. Aktivieren Sie das Kontrollkästchen Legt Dateiname als Designmaster fest.

  6. Klicken Sie auf OK.


 Wiederherstellen des Designmasters

Wiederherstellen des Designmasters

Sie können einen Designmaster wiederherstellen, wenn die Datei verlorenging oder beschädigt bzw. verschoben wurde. Diese Option ist jedoch nicht verfügbar, wenn das momentan geöffnete Replikat ein Teilreplikat ist, oder wenn der Designmaster mit einem anderen Tool als dem Replikations-Manager verschoben wurde. Um Informationen zum Verschieben eines Designmasters anzuzeigen, klicken Sie auf [image] .

  1. Stellen Sie sicher, dass sich in der Replikatgruppe kein Designmaster befindet.

  2. Öffnen Sie das Replikat, das Sie als neues Designmaster-Replikat festlegen möchten.

  3. Klicken Sie im Menü Extras auf Replikation, und klicken Sie dann auf Jetzt synchronisieren.

  4. Klicken Sie in der Liste auf ein Replikat und dann auf OK.

  5. Wiederholen Sie die Schritte 2 bis 4 so oft, bis das Replikat mit allen übrigen Replikaten der Replikatgruppe synchronisiert ist.

    Wichtig Stellen Sie sicher, dass Sie mit allen Replikaten der Replikatgruppe synchronisiert haben.

  6. Klicken Sie im Menü Extras auf Replikation, und klicken Sie dann auf Designmaster wiederherstellen.

  7. Klicken Sie auf Ja.


 Erstellen eines Replikats Ihrer Datenbank

Erstellen eines Replikats Ihrer Datenbank

  1. Öffnen Sie die Datenbank, die Sie replizieren möchten. Wenn Sie in einer Mehrbenutzerumgebung arbeiten, müssen Sie sicherstellen, dass alle anderen Benutzer die Datenbank geschlossen haben.

    Wichtig Es wird empfohlen, dass Sie vor dem Replizieren der Datenbank alle Themen zu Änderungen lesen, die beim Replizieren an einer Datenbank vorgenommen werden. Klicken Sie hierzu auf [image] .

  2. Entfernen Sie das Kennwort, falls Ihre Datenbank kennwortgeschützt ist.

    Wie wird's gemacht?

  3. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Datenbank in Replikat konvertieren.

  4. Klicken Sie auf Ja, wenn Sie aufgefordert werden, die Datenbank zu schließen.

  5. Klicken Sie auf Ja oder Nein (Ja wird empfohlen), wenn Sie zum Erstellen einer Sicherungskopie der Datenbank aufgefordert werden (diese Aufforderung erscheint nur, wenn die Datenbank zuerst in einen Designmaster konvertiert werden muss, bevor das erste Replikat erstellt werden kann).

  6. Wählen Sie im Dialogfeld Speicherort des neuen Replikats den Ort, an dem Sie das neue Replikat ablegen möchten.

  7. Klicken Sie im Dialogfeld Speicherort des neuen Replikats auf die Schaltfläche Priorität, geben Sie die Priorität für das Replikat ein, und klicken Sie dann auf OK. Wenn Sie weitere Informationen zum Festlegen der Replikatpriorität benötigen, klicken Sie auf [image] .

  8. Aktivieren Sie im Dialogfeld Speicherort des neuen Replikats das Kontrollkästchen Löschen sperren, wenn Sie verhindern möchten, dass Benutzer Datensätze im Replikat löschen können.

  9. Wählen Sie im Dialogfeld Speicherort des neuen Replikats im Dropdownlistenfeld Dateityp die Sichtbarkeit des Replikats. Wenn Sie weitere Informationen zur Sichtbarkeit des Replikats benötigen, klicken Sie auf [image] .

  10. Klicken Sie auf OK.

Anmerkungen

  • Beim Replizieren einer Datenbank werden standardmäßig alle Tabellen, Abfragen, Formulare, Berichte, Makros und Module sowie alle Daten repliziert. Wenn Sie weitere Informationen dazu benötigen, wie Sie Formulare, Berichte, Makros und Module lokal verwenden können, klicken Sie auf [image] .

  • Wenn Sie weitere Hinweise zum Replizieren eines Microsoft Access-Projekts benötigen, klicken Sie auf [image] .


Erstellen eines Replikats mit dem Aktenkoffer

  1. Stellen Sie sicher, dass der Aktenkoffer auf Ihrem Computer installiert ist. Wenn dies der Fall ist, sehen Sie auf dem Windows-Desktop das Symbol Aktenkoffer.

    Wenn der Aktenkoffer nicht installiert ist, müssen Sie die beiden folgenden Schritte ausführen:

    • Zeigen Sie im Windows Startmenü auf Einstellungen, klicken Sie zuerst auf Systemsteuerung, dann auf Software und anschließend auf Windows Setup. Doppelklicken Sie zum Schluss auf Zubehör, und folgen Sie den Anweisungen auf dem Bildschirm.

    • Zum Installieren der Aktenkoffer-Replikation führen Sie das Microsoft Access Setup-Programm aus. Zum Anzeigen weiterer Informationen klicken Sie auf [image] .

  2. Entfernen Sie das Kennwort, falls Ihre Datenbank kennwortgeschützt ist.

    Wie wird's gemacht?

  3. Wählen Sie in Windows Explorer den Ordner, in dem sich Ihre Microsoft Access-Datenbank befindet.

  4. Ziehen Sie die Datenbankdatei auf das Symbol Aktenkoffer auf dem Windows-Desktop.

    Wichtig Lesen Sie vor dem Replizieren der Datenbank alle Themen zu Änderungen, die beim Replizieren an einer Datenbank vorgenommen werden. Klicken Sie hierzu auf [image] .


 Entfernen eines Replikats aus der Replikatgruppe

Entfernen eines Replikats aus der Replikatgruppe

  1. Suchen Sie mit Hilfe von Windows Explorer das Replikat, das Sie löschen möchten.

  2. Klicken Sie auf das zu löschende Replikat, und drücken Sie dann ENTF.

  3. Versuchen Sie, ein anderes Mitglied der Replikatgruppe mit dem gelöschten Mitglied zu synchronisieren. (Dadurch wird der Löschvorgang den anderen Mitgliedern mitgeteilt.)

Vorsicht Löschen Sie den Designmaster für die Replikatgruppe nur dann, wenn er nicht mehr funktioniert. Wenn Sie den Designmaster löschen, können Sie den Datenbankentwurf nicht mehr ändern. Außerdem empfiehlt es sich, ein Replikat auf Konflikte zu überprüfen. Andernfalls geht das Protokoll der vorhandenen Konflikte verloren, wenn Sie das Replikat löschen (oder verschieben).


 Vergleich der Sichtbarkeit von globalen, lokalen und anonymen Replikaten

Vergleich der Sichtbarkeit von globalen, lokalen und anonymen Replikaten

Es gibt drei Typen der Sichtbarkeit bei Replikaten, die in Microsoft Access verfügbar sind: global, lokal und anonym.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Verwendung von Replikaten

Umgebung im Internet ohne Verbindung

Angepasste Anwendungen im Internet

Replikaterstellung

Verwendung als Designmaster

Sichtbarkeit von Datenbankreplikaten in Access 95 und 97

Konfliktbehebung

Synchronisierung

Zeitplanung

Unterstützung des Aktenkoffers

Verwendung von Replikaten

  • Globales Replikat
 Dient als Hub in einer Replikatgruppe
  • Lokales Replikat
Steuerung der Topologie
  • Anonymes Replikat
 Steuerung der Topologie/Internet

Zurück zum Anfang

Umgebung im Internet ohne Verbindung

  • Globales Replikat
 Ja
  • Lokales Replikat
 Ja
  • Anonymes Replikat
 Ja. Anonyme Replikate werden empfohlen für Internetanwendungen, wenn Sie eine große Anzahl von Replikaten benötigen.

Zurück zum Anfang

Angepasste Anwendungen im Internet

  • Globales Replikat
 Ja
  • Lokales Replikat
 Ja
  • Anonymes Replikat
 Ja. Verwenden Sie das Internet als Verteilermechanismus für eine große Anzahl an Replikaten.

Zurück zum Anfang

Replikaterstellung

  • Globales Replikat
 Ja. Erstellen Sie ein globales, lokales oder anonymes Replikat.
  • Lokales Replikat
 Ja. Erstellen Sie neue, lokale Replikate.
  • Anonymes Replikat
 Ja. Erstellen Sie neue, anonyme Replikate.

Zurück zum Anfang

Verwendung als Designmaster

  • Globales Replikat
 Wird unterstützt. Wenn eine Datenbank repliziert wird, ist das erste Replikat, das erstellt wird (als Designmaster), ein globales Replikat.
  • Lokales Replikat
 Nicht unterstützt
  • Anonymes Replikat
 Nicht unterstützt

Zurück zum Anfang

Sichtbarkeit von Datenbankreplikaten in Access 95 und 97

  • Globales Replikat
 Standard
  • Lokales Replikat
 Nicht zutreffend
  • Anonymes Replikat
 Nicht zutreffend

Zurück zum Anfang

Konfliktbehebung

  • Globales Replikat
 Die Konfliktbehebung kann über jedes globale Replikat verwaltet werden.
  • Lokales Replikat
 Alle Konflikte werden am Hub-Replikat (dem globalen Replikat) aufgezeichnet und gelöst.
  • Anonymes Replikat
 Alle Konflikte werden am Hub-Replikat (dem globalen Replikat) aufgezeichnet und gelöst.

Zurück zum Anfang

Synchronisierung

  • Globales Replikat
 Synchronisierung mit einem beliebigen globalen Replikat in der Replikatgruppe oder einem beliebigen lokalen oder anonymen Replikat, das in der Gruppe erstellt wurde.
  • Locales Replikat
 Synchronisierung erfolgt nur mit dem Hub-Replikat (dem globalen Replikat).
  • Anonymes Replikat
 Synchronisierung erfolgt nur mit dem Hub-Replikat (dem globalen Replikat).

Zurück zum Anfang

Zeitplanung

  • Globales Replikat
 Der Replikations-Manager kann die Synchronisierung mit einem globalen oder lokalen (untergeordneten) Replikat planen. Die Synchronisierung kann nicht für anonyme Replikate geplant werden.
  • Lokales Replikat
 Hub-Replikate können einen Austausch mit einem lokalen Replikat planen. Und lokale Replikate können die Synchronisierung mit dem Hub-Replikat (dem globalen Replikat) planen.
  • Anonyme Replikate
 Anonyme Replikate können die Synchronisierung mit dem Hub-Replikat (dem globalen Replikat) planen.

Zurück zum Anfang

Unterstützung des Aktenkoffers

  • Globales Replikat
 Ja
  • Lokales Replikat
 Nein
  • Anonymes Replikat
 Nein

Zurück zum Anfang


 Einstellen der Replikatpriorität

Einstellen der Replikatpriorität

Die Replikatpriorität bestimmt, wie bei einem Synchronisierungskonflikt Änderungen an Datensätzen behandelt werden.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Prioriätsunterschiede in Access

Festlegen der Replikatpriorität

Einfacher Fall

Komplexer Fall

Weitere Informationen

Prioriätsunterschiede in Access

In Microsoft Access 95 und 97 wurden Konflikte bei der Synchronisierung gelöst, indem als Regel der Datensatz mit den häufigsten Änderungen bevorzugt wurde. In Access 2000 wird einem Replikat in einer Replikatguppe bei der Erstellung eine Priorität zugewiesen. Bei einem Synchronisierungskonflikt wird das Replikat mit der höchsten Priorität bevorzugt. Bei gleicher Priorität wird das Replikat mit der niedrigsten Replikat-ID bevorzugt. Rufen Sie weitere Informationen auf zu Eigenschaften, die bei der Replikation zur Datenbank hinzugefügt werden.

Zurück zum Anfang

Festlegen der Replikatpriorität

Jedem Replikat wird eine Priorität zwischen 0 und 100 zugewiesen, wobei 100 der höchsten Priorität entspricht. Wenn eine Datenbank replizierbar gemacht wird, wird die Standardpriorität des Replikats auf 90 festgelegt. Darauf folgende Replikate haben eine Standardpriorität, die 90 Prozent der Priorität des Hubs entspricht. Die Priorität für lokale und anonyme Replikate ist immer 0. Bei einem Konflikt mit dem globalen Hub-Replikat werden lokale und anonyme Replikate automatisch benachteiligt. Wenn ein lokales oder anonymes Replikat eine Änderung, die keinen Konflikt verursacht, an den Hub sendet, übernimmt der Hub den Besitz der Änderung.

Access zeichnet die historische Priorität für jeden Datensatz in einer Replikatgruppe auf. Bei der Synchronisierung wird die Einstellung für die historische Prioriät beurteilt und bei Konflikten gewinnt der Datensatz mit der höchsten Priorität. Zum besseren Verständnis des Prioritätenkonzepts betrachten Sie das Beispiel des Designmasters Replikat A, mit einer Prioriät von 100. Replikat A repliziert zwei Replikate, und zwar Replikat B mit einer Priorität von 90 und Replikat C mit einer Priorität von 95.

Prioritäten in einer Replikatgruppe.

Zurück zum Anfang

Einfacher Fall

Die höchste Prioritätsänderung gewinnt. Gehen wir davon aus, dass alle drei Standorte darin übereinstimmen, dass Replikat A die erste Version des Datensatzes erstellt und dass keine weiteren Änderungen vorgenommen wurden. Wenn die Replikate A und B den Datensatz gleichzeitig aktualisieren, dann gewinnt in diesem Konflikt die Aktualisierung von Replikat A, da es die höchste Priorität hat.

Zurück zum Anfang

Komplexer Fall

Wenn nach der letzten Synchronisierung mehrere Änderungen an demselben Datensatz vorgenommen wurden, dann wird das Replikat, das Änderungen mit der höchsten historischen Priorität aufweist, verwendet, um den Gewinner des Konflikts zu ermitteln. Nehmen wir einmal an, dass Replikat A die zweite Version erstellt und dann diese an Replikat B sendet. Replikat B erstellt die dritte Version und sendet diese zurück an Replikat A. Dort werden die Versionen zusammengeführt. Nehmen wir weiter an, dass Replikat C auch eine zweite Version erstellt hat und diese mit Replikat A abstimmt. Wenn die höchste historische Priorität für Änderungen ausgewählt wird, die nach den Änderungen am ursprünglichen Datensatz ausgewählt wird (Replikat A mit einer Replikatpriorität 100 und 95 für die Version der Reihe von Replikat C), dann sind die gemeinsamen Änderungen von Replikat A und B die Gewinner der Priorität, wenn diese mit den Änderungen verglichen werden, die durch Replikat C vorgenommen wurden. Jedoch wurde Replikat A vor Replikat B erstellt, deshalb gewinnt Replikat A diesen Konflikt. Ein Vorteil dieser Regel ist, dass Änderungen die an dem Replikat mit der höchsten Priorität vorgenommen wurden, niemals durch den Mechanismus zur Konfliktlösung aufgehoben werden.

Zurück zum Anfang

Weitere Informationen

Synchronisieren von Daten in der Replikatgruppe

Erstellen eines Replikats der Datenbank

Zurück zum Anfang


 Festlegen der Aufbewahrungsdauer für eine Replikatgruppe

Festlegen der Aufbewahrungsdauer für eine Replikatgruppe

Durch das Festlegen der Aufbewahrungsdauer für eine Replikatgruppe wird eingestellt, wie viele Tage nicht synchronisierte Datensätze in Systemtabellen aufbewahrt werden. Die Aufbewahrungsdauer wird festgelegt, wenn die Datenbank zum ersten Mal replizierbar gemacht wird. Wenn Sie die Datenbank mit Hilfe des Replikations-Managers, mit Datenzugriffsobjekten (Data Access Objects, DAO) oder mit Jet and Replication-Objekten (JRO) replizieren, dann werden als Standardaufbewahrungsdauer 60 Tage festgelegt. Wenn Sie die Datenbank mit Microsoft Access oder mit dem Aktenkoffer replizieren, dann werden als Standardaufbewahrungsdauer 1000 Tage festgelegt.

Die Aufbewahrungsdauer kann in einem Designmaster mit Hilfe des Replikations-Managers oder in JRO über die RetentionPeriod-Eigenschaft geändert werden. Die Aufbewahrungsdauer muss zwischen 5 und 32.000 Tage betragen. Für die Replikatgruppe sollte eine lange Aufbewahrungsdauer eingestellt werden, wenn die Replikate nicht häufig synchronisiert werden. Wenn die Replikate jedoch häufig synchronisiert werden und Sie das Replikat möglichst klein halten möchten, geben Sie eine kürzere Aufbewahrungsdauer an.

Ein Replikat oder ein Designmaster muss Daten und Schemas innerhalb der Aufbewahrungsdauer empfangen und senden. Wenn Sie in Microsoft Access oder im Replikations-Manager ein Replikat öffnen, das innerhalb von fünf Tagen abläuft, werden Sie in einer Meldung darüber informiert. Wenn für ein Replikat die Aufbewahrungsdauer abläuft, dann synchronisieren der Replikations-Manager und Access nicht mehr die Änderungen zwischen dem abgelaufenen Replikat und anderen Replikaten in der Replikatgruppe. Wenn ein Replikat innerhalb der Aufbewahrungsdauer nicht mit einem anderen Replikat in der Replikatgruppe synchronisiert wird, dann wird das Replikat beim nächsten Synchronisierungsversuch aus der Replikatgruppe entfernt. Wenn der Designmaster abläuft, müssen Sie den Designmaster wiederherstellen, um ein vorhandenes oder neues Replikat im Designmaster zu ändern.

Weitere Informationen

Erstellen eines Replikats Ihrer Datenbank mit Access

Erstellen eines Replikats mit dem Aktenkoffer

Microsoft Replikations-Manager

Replikation mit Datenzugriffsobjekten (Data Access Objects, DAO)

Replikation mit Jet and Replication-Objekte (JRO)

Synchronisieren von Daten in der Replikatgruppe


 Ein Vergleich der Konfliktlösung auf Zeilen- und Spaltenebene

Ein Vergleich der Konfliktlösung auf Zeilen- und Spaltenebene

In Microsoft Access 95 und 97 werden Konflikte auf der Zeilenebene gelöst. Konflikte treten immer dann auf, wenn derselbe Datensatz in zwei unterschiedlichen Replikaten geändert wird, und zwar auch dann, wenn unterschiedliche Felder des Datensatzes geändert werden. Wenn zum Beispiel die Telefonnummer eines Kunden in einem Replikat geändert wird und die Postleitzahl desselben Kunden in einem anderen Replikat, dann wird ein Konflikt verursacht.

In Access 2000 werden Konflikte auf Spaltenebene festgestellt. Änderungen an demselben Datensatz in zwei unterschiedlichen Replikaten verursachen nur dann einen Synchronisierungskonflikt, wenn die gleiche Spalte oder das gleiche Feld geändert wird. Damit entsteht für das obige Beispiel kein Synchronisierungskonflikt mehr, da die beiden Benutzer unterschiedliche Felder geändert haben.

Die Konfliktlösung auf Spaltenebene ist der Standard, wenn eine Datenbank replizierbar gemacht wird. Zum Angeben einer Konfliktlösung auf Zeilenebene für eine Tabelle müssen Sie dies angeben, bevor Sie die Tabelle replizierbar machen.

Sie können die Konfliktverwaltung einer Datenbank oder einer einzelnen Tabelle festlegen, bevor Sie diese replizierbar machen. Wenn Sie ein Replikat erstellt haben, können Sie die Einstellung nicht mehr ändern. Sie können jedoch den Wert für einzelne Tabellen der Verwaltung auf Zeilenebene festlegen. Dazu verwenden Sie die RowLevelTracking-Eigenschaft der Tabelle.

Anmerkung Durch das Verwenden von Jet and Replication-Objekten (JRO) können Sie nur die Standardverwaltung für die Datenbank angeben, nicht aber für einzelne Tabellen. Wenn Sie eine Datenbank replizierbar machen, können sie ColumnLevelTracking entweder auf True oder False festlegen. Verwenden Sie dazu die MakeReplicable-Methode in JRO.

Weitere Informationen

Erstellen eines Replikats der Datenbank

Replikation mit Jet and Replication-Objekten (JRO)

Replikation in einem Microsoft Access-Projekt


 Synchronisierungskonflikte

Synchronisierungskonflikte

Konflikte können dann auftreten, wenn an einem oder mehreren Replikaten Datenänderungen vorgenommen wurden.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Unterschiede beim Konfliktverhalten in Access

Konflikt bei gleichzeitiger Aktualisierung

Konflikt mit eindeutigem Schlüssel

Gültigkeitskonflikt auf Tabellenebene

Konflikt in der referenziellen Integrität durch Aktualisieren

Konflikt in der referenziellen Integrität durch Löschen

Sperrkonflikt

Konflikt durch Fremdschlüsselverletzung

Beachtung der Groß-/Kleinschreibung in Replikatgruppen

Konflikte bei Teilreplikaten

Konfliktbehebung

Unterschiede beim Konfliktverhalten in Access

In Microsoft Access 95 und 97 sind bei der Synchronisierung Konflikte und Fehler aufgetreten. Synchronisierungskonflikte traten immer dann auf, wenn zwei Benutzer denselben Datensatz in einer Replikatgruppe aktualisiert haben. Die beiden Datenbanken werden dann zwar synchronisiert, aber nur eine der beiden Änderungen wird von beiden Datenbanken übernommen. Synchronisierungsfehler traten auf, wenn Änderungen an Daten in einer Datenbank in einer Replikatgruppe nicht in eine andere Datenbank der Replikatgruppe übernommen werden konnten, weil dies die Verletzung der referenziellen Integrität oder einer anderen Einschränkung zur Folge hatte.

In Access 2000 werden Ereignisse, die Konflikte und Fehler bei der Synchronisierung verursachen, einfach als Synchronisierungskonflikte betrachtet. Ein einfacher Mechanismus wird verwendet, um diese Konflikte zu erfassen und zu beheben, was den Vorgang erheblich vereinfacht. Wenn ein Konflikt auftritt, wird die Änderung ausgewählt, die den Konflikt gewinnt. Diese wird in allen Replikaten übernommen. Die Änderung, die den Konflikt verliert, wird als Konflikt in allen Replikaten erfasst. Der Microsoft-Replikationskonflikt-Viewer, das Standardtool in Access, wird verwendet, um Synchronisierungskonflikte abzustimmen und zu beheben.

Zurück zum Anfang

Konflikt bei gleichzeitiger Aktualisierung

Ein Konflikt bei einer gleichzeitigen Aktualisierung tritt dann auf, wenn zwei Replikate denselben Datensatz aktualisieren. Der Datensatz, der den Konflikt verliert, wird in der Konflikttabelle erfasst. Rufen Sie weitere Informationen zum Verwalten von Datenänderungen auf.

Zurück zum Anfang

Konflikt mit eindeutigem Schlüssel

Ein Konflikt mit einem eindeutigen Schlüssel kann folgendermaßen auftreten:

  • Zwei Replikate geben einen neuen Datensatz mit demselben Wert in ein Feld ein, das ein Primärschlüssel ist oder einen eindeutigen Index hat.

  • Der Designmaster erstellt einen eindeutigen Index, und ein Replikat fügt gleichzeitig zwei oder mehrere Datensätze mit demselben Schlüsselwert hinzu. Wenn die Schemaänderung das erste Replikat mit doppelten Schlüsseldatensätzen erreicht, dann bleibt der erste Datensatz mit doppeltem Schlüssel in der Basistabelle. Darauf folgende Datensätze werden zum Löschen markiert und in die Konflikttabelle geschrieben.

Zurück zum Anfang

Gültigkeitskonflikt auf Tabellenebene

Ein Gültigkeitskonflikt auf Tabellenebene tritt dann auf, wenn Daten eingegeben werden, die auf Tabellenebene eine Gültigkeitsregel verletzen, mit der die möglichen, in einer Tabelle einzugebenen Werte oder Datentypen eingeschränkt werden. Wenn Sie auf Tabellenebene eine Gültigkeitregel zum Designmaster hinzufügen, ohne zu prüfen, ob alle vorhandenen Daten dieser Regel entsprechen, kann möglicherweise ein Konflikt auftreten, wenn die Designänderungen mit der Replikatgruppe synchronisiert werden. In diesem Fall werden die Datensätze gelöscht und in der Konflikttabelle protokolliert.

Zurück zum Anfang

Konflikt in der referenziellen Integrität durch Aktualisieren

Ein Konflikt in der referenziellen Integrität durch Aktualisieren tritt dann auf, wenn für ein Replikat der Primärschlüssel geändert wird und wenn bei einem anderen Replikat neue untergeordnete Datensätze hinzugefügt werden, die einen Verweis zum ursprünglichen Primärschlüsselwert enthalten.

Zurück zum Anfang

Konflikt in der referenziellen Integrität durch Löschen

Ein Konflikt in der referenziellen Integrität durch Löschen tritt dann auf, wenn ein Primärschlüsseldatensatz in einem Replikat gelöscht wird, und wenn bei einem anderen Replikat neue untergeordnete Datensätze hinzugefügt werden, die einen Verweis zum ursprünglichen Primärschlüssel enthalten. Beim Synchronisieren der beiden Replikate werden die neuen untergeordneten Datensätze zum Löschen gekennzeichnet und zur Konflikttabelle hinzugefügt.

Zurück zum Anfang

Sperrkonflikt

Ein Sperrkonflikt tritt dann auf, wenn der Datensatz bei der Synchronisierung nicht abgestimmt werden kann, weil ein anderer Benutzer die Tabelle gesperrt hat. Microsoft Access versucht in diesem Fall mehrmals den Datensatz zu aktualisieren. Da dies ohne Erfolg bleibt, wird die Synchronisierung angehalten und die ganze Transaktion nimmt wieder den ursprünglichen Status an. Eine Fehlermeldung wird ausgegeben, es wird jedoch kein Konflikt protokolliert.

Zurück zum Anfang

Konflikt durch Fremdschlüsselverletzung

Ein Konflikt durch eine Fremdschlüsselverletzung tritt dann auf, wenn ein ungültiger Primärschlüsseldatensatz vorhanden ist. Dies kann durch einen der anderen Konflikttypen verursacht werden.

Zurück zum Anfang

Beachtung der Groß-/Kleinschreibung in Replikatgruppen

Die Anzahl der Konflikte kann sich in Replikatgruppen erhöhen, die mehrere Datenbanktypen umfassen, wie z. B. Access und Microsoft SQL Server, bei denen sich die Sprachsortierreihenfolge oder die Beachtung der Groß-/Kleinschreibung beim Sortieren unterscheidet. Das kann daran liegen, dass eindeutige Schlüsselwerte in einer Datenbank möglicherweise in einer anderen Datenbank mit einer anderen Sortierreihenfolge nicht eindeutig sind. Das Problem kann sowohl indizierte Textdaten als auch Metadaten betreffen, es betrifft jedoch keine nichtindizierten Textdaten. Beim Erstellen von Replikaten mit unterschiedlicher Sortierreihenfolge muss deshalb sehr sorgfältig vorgegangen werden, um sicherzustellen, dass Metadaten und indizierter Text immer für beide Sortiermethoden eindeutig sind.

Zurück zum Anfang

Konflikte bei Teilreplikaten

Ein Teilreplikat empfängt Konflikte, die mit allen Reihen des Teilreplikats in Zusammenhang stehen, dazu gehören auch die Reihen, die bei der Synchronisierung zum Teilreplikat hinzugefügt werden.

Zurück zum Anfang

Konfliktbehebung

Wenn derselbe Datensatz in einer replizierten Datenbank in einem oder mehreren Replikaten geändert wird, entstehen beim Synchronisieren eines Replikats mit der Replikatgruppe Konflikte. Wenn Sie diese Konflikte beheben möchten, ruft Access den Microsoft-Replikationskonflikt-Viewer auf. Dieser Assistent zeigt jeden Konflikt an, und Sie können dann manuell bestimmen, welcher geänderte Datensatz die richtigen Informationen enthält. So beheben Sie Synchronisierungskonflikte zwischen Mitgliedern der Replikatgruppe.

Zurück zum Anfang


 Synchronisieren von Daten in einer Replikatgruppe

Synchronisieren von Daten in einer Replikatgruppe

In Microsoft Access, im Replikations-Manager und in Jet and Replication-Objekten (JRO) können Sie zwischen drei unterschiedlichen Methoden zum Synchronisieren von Daten wählen: direkt, indirekt und Internet.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Direkte Synchronisierung

Indirekte Synchronisierung

Internetsynchronisierung

Verschieben und Kopieren von globalen Replikaten

Weitere Informationen

Direkte Synchronisierung

Die direkte Synchronisierung ist eine ausgezeichnete Lösung, wenn Replikate direkt mit dem lokalen Netzwerk verbunden sind und über freigegebene Netzwerkordner verfügbar gemacht werden. Die direkte Synchronisierung ist keine optimale Lösung, wenn eine Remote-Synchronisierung über eine RAS (Remote Access Service)- oder eine Wählverbindung erforderlich ist. In diesem Fall sollten Sie die indirekte oder die Internetsynchronisierung verwenden.

Wenn Sie versuchen, eine direkte Synchronisierung für ein Replikat auszuführen, das sich in der Liste der bekannten Replikate befindet, und wenn dieses Replikat nicht gefunden wird, dann wird es aus der Replikatgruppe entfernt.

Zurück zum Anfang

Indirekte Synchronisierung

Die indirekte Synchronisierung ist dann sinnvoll, wenn Sie in einer unabhängigen Umgebung arbeiten, also wenn Sie beispielsweise mit einem Laptop reisen.

Die indirekte Synchronisierung kann nur mit Hilfe des Replikations-Managers konfiguriert werden, der über den Microsoft Office 2000 Developer (MOD) verfügbar ist. Wenn die indirekte Synchronisierung mit dem Replikations-Manager konfiguriert ist, können Sie eine indirekte Synchronisierung mit Hilfe von Microsoft Access, dem Replikations-Manager oder mit JRO ausführen.

Zurück zum Anfang

Internetsynchronisierung

Die Internetsynchronisierung ist eine geeignete Methode, Replikate in einer eigenständigen Umgebung zu synchronisieren, in der ein Internet Server konfiguriert ist.

Für das Konfigurieren der Internetsynchronisierung verwenden Sie den Replikations-Manager, der über den Microsoft Office 2000 Developer (MOD) verfügbar ist.

Zurück zum Anfang

Verschieben und Kopieren von globalen Replikaten

Wenn Sie ein globales Replikat verschieben oder kopieren, das ein Hub-Replikat für lokale oder anonyme Replikate darstellt, dürfen Sie nur den Befehl Replikat verschieben im Replikations-Manager verwenden. Andernfalls können Sie nicht mehr das globale Replikat mit den lokalen oder anonymen Replikaten in der Replikatgruppe synchronisieren. Und die lokalen oder anonymen Replikate können nicht mehr mit dem übergeordneten globalen Replikat synchronisiert werden.

Zurück zum Anfang

Weitere Informationen

Microsoft Replikations-Manager

Vergleich der Sichtbarkeit von Replikaten

Synchronisierungskonflikte

Synchronisierung mit einem anderen Mitglied der Replikatgruppe

Replikation in einem Microsoft Access-Projekt

Zurück zum Anfang


 Lösen von Synchronisierungskonflikten zwischen den Replikaten einer Replikatgruppe

Lösen von Synchronisierungskonflikten zwischen den Replikaten einer Replikatgruppe

Konflikte können auftreten, wenn sich Daten im selben Satz zweier Mitglieder einer Replikatgruppe geändert haben, die synchronisiert wurden.

  1. Starten Sie den Microsoft-Replikationskonflikt-Viewer für die Replikation. Gehen Sie dazu nach einer der folgenden Methoden vor:
    • Öffnen Sie die Datenbank, die Sie nach Konflikten untersuchen möchten. Wenn Konflikte bestehen, werden Sie gefragt, ob diese gelöst werden sollen. Klicken Sie auf Ja, um fortzufahren.

    • Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Konflikte beheben.

  2. Markieren im Microsoft-Replikationskonflikt-Viewer in der Liste eine Tabelle, in der Konflikte vorhanden sind, und klicken Sie dann auf Anzeigen.

  3. Wählen Sie für jeden im Microsoft-Replikationskonflikt-Viewer angezeigten Konflikt eine der folgenden Optionen.
    • Wenn Sie die Daten in Replikat 1 behalten möchten, klicken Sie auf Vorhandene Daten beibehalten.

    • Wenn Sie die Daten in Replikat 1 ändern möchten und dann bei der nächsten Synchronisierung nach Replikat 2 kopieren möchten, klicken Sie auf Überarbeitete Daten beibehalten.

    • Wenn Sie die Daten in Replikat 2 behalten möchten und die Daten in Replikat 1 bei der nächsten Synchronisierung überschrieben werden sollen, klicken Sie auf Mit Konfliktdaten überschreiben.

    • Wenn Sie die Daten in Replikat 2 ändern möchten und die Daten in Replikat 1 bei der nächsten Synchronisierung überschrieben werden sollen, klicken Sie auf Mit überarbeiteten Daten überschreiben.

  4. Klicken Sie auf Lösen.

  5. Wiederholen Sie die Schritte 3 und 4 so oft, bis alle Konflikte in der Tabelle gelöst sind.

Anmerkungen

  • Die in Konflikt stehenden Datensätze können verloren gehen, wenn Sie ein Replikat löschen oder verschieben. Überprüfen Sie daher jedes Replikat auf Konflikte, bevor Sie es löschen oder verschieben.

  • Um weitere Informationen zu Synchronisierungskonflikten aufzurufen, klicken Sie auf [image] .


 Synchronisieren eines Replikats mit dem Aktenkoffer

Synchronisieren eines Replikats mit dem Aktenkoffer

Beim Synchronisieren werden zwei Mitglieder einer Replikatgruppe aktualisiert, indem alle geänderten Datensätze und Objekte in beiden Mitgliedern ausgetauscht werden. Zwei Mitglieder sind dann synchron, wenn die Änderungen aus einem Mitglied auch beim jeweils anderen Mitglied durchgeführt wurden.

  1. Klicken Sie auf das Symbol Aktenkoffer, und klicken Sie dann auf die Datenbankdatei.

  2. Klicken Sie im Menü Aktenkoffer auf Auswahl aktualisieren.

  3. Klicken Sie auf Aktualisieren, um die Änderungen durch den Aktenkoffer abzugleichen.

Anmerkung Der Aktenkoffer unterstützt lokale oder anonyme Replikate nicht.


 Synchronisieren mit einem anderen Mitglied der Replikatgruppe in einer Datenbank

Synchronisieren mit einem anderen Mitglied der Replikatgruppe in einer Datenbank

Beim Synchronisieren werden zwei Mitglieder einer Replikatgruppe aktualisiert, indem alle geänderten Datensätze und Objekte in beiden Mitgliedern ausgetauscht werden. Zwei Mitglieder sind dann synchron, wenn die Änderungen aus einem Mitglied auch beim jeweils anderen Mitglied durchgeführt wurden.

  1. Öffnen Sie das Replikatgruppenmitglied, das Sie synchronisieren möchten.

  2. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Jetzt synchronisieren. (Wenn ein Synchronizer auf dem Internet ein Mitglied einer Replikatgruppe verwaltet, wird dieses Replikat im Dropdownlistenfeld Direkt mit Replikat als http://ServerName angezeigt, wobei ServerName für den Namen des Internetservers steht.)

  3. Geben Sie den Pfad und den Dateinamen des Replikatgruppenmitglieds an, das Sie mit der aktuellen Datenbank synchronisieren möchten.

  4. Wenn Ihre Datenbank der Designmaster ist und Sie das andere Replikat als Designmaster festlegen möchten, aktivieren Sie das Kontrollkästchen Legt Dateiname als Designmaster fest. (Diese Option ist nicht verfügbar, wenn eines der zu synchronisierenden Replikate ein Teilreplikat ist.)

  5. Klicken Sie auf OK.

  6. Klicken Sie auf Ja, wenn Sie zum Schließen und erneuten Öffnen der Datenbank aufgefordert werden. (Wenn Sie auf Nein klicken, sehen Sie unter Umständen nicht alle vorgenommenen Änderungen.)

Anmerkungen

  • Wenn Sie weitere Informationen zum Replizieren eines Microsoft Access-Projekts benötigen, klicken Sie auf [image] .

  • Wenn Sie weitere Informationen zum Synchronisieren von Daten in Ihrer Replikatgruppe benötigen, klicken Sie auf [image] .


 Konvertieren einer Replikatgruppe in Microsoft Access 2000

Konvertieren einer Replikatgruppe in Microsoft Access 2000

Vorsicht Synchronisieren Sie den Test-Designmaster und die Test-Replikate in keinem Fall mit Mitgliedern der ursprünglichen Replikatgruppe. Andernfalls könnten sich Daten und Struktur der ursprünglichen Replikatgruppe unbeabsichtigt ändern.

  1. Erstellen Sie eine Sicherungskopie des aktuellen, in Microsoft Access 97 erstellten Designmasters. Speichern Sie die Kopie auf einem anderen Computer, oder isolieren Sie sie vollständig von allen anderen Replikatgruppenmitgliedern.

  2. Legen Sie die isolierte Kopie in Microsoft Access 97 als neuen Designmaster fest, indem Sie im Menü Extras auf Replikation zeigen und dann auf Designmaster-Replikat wiederherstellen klicken.

  3. Erstellen Sie einige Replikate auf der Basis des neuen Designmasters.

  4. Zeigen Sie im Menü Extras auf Datenbank-Dienstprogramme, und klicken Sie dann auf Datenbank konvertieren, um den neuen Designmaster in eine Microsoft Access 2000-Datenbank zu konvertieren.

  5. Wiederholen Sie Schritt 4 für alle Replikate in der Replikatgruppe.

  6. Synchronisieren Sie den neuen, konvertierten Designmaster mit den soeben konvertierten Replikaten.

  7. Führen Sie alle gewünschten Tests durch.

    Wenn Sie einige Objekte ändern möchten, können Sie die Änderungen ebenfalls im ursprünglichen Designmaster nach seiner Konvertierung vornehmen. Sie können aber auch die Kopie so lange aufbewahren, bis Sie alle geänderten Objekte aus ihr importiert haben.

  8. Sobald die Kopie zufriedenstellend arbeitet, löschen Sie den neuen Designmaster und alle zugehörigen Replikate. Stellen Sie sicher, dass alle Benutzer, die auf die Datenbanken des Designmasters und der Replikate zugreifen, Microsoft Access 2000 installiert haben.

  9. Konvertieren Sie den ursprünglichen Designmaster nach Microsoft Access 2000, und konvertieren Sie dann alle ursprünglichen Replikate.

    Sie können die konvertierten Replikate nicht mehr in Microsoft Access 97 öffnen.

Anmerkung Wenn Sie weitere Hinweise zum Replizieren eines Microsoft Access-Projekts benötigen, klicken Sie auf [image] .


 Umwandeln einer replizierten Datenbank in eine reguläre Datenbank

Umwandeln einer replizierten Datenbank in eine reguläre Datenbank

Eine Datenbank, die in einen Designmaster konvertiert wurde, kann nicht mehr in den vorherigen Zustand einer regulären Datenbank rekonvertiert werden. Wenn Sie jedoch die Replikation nicht mehr verwenden und die replizierte Datenbank verkleinern möchten, können Sie eine neue, reguläre Datenbank erstellen, die alle Objekte und Daten aus der replizierten Datenbank enthält, jedoch ohne die zusätzlichen replikationsbezogenen Systemfelder, Tabellen und Eigenschaften auskommt.

Anmerkung Erstellen Sie für jede Tabelle in der Datenbank den Index, der auch in der Replikationstabelle verwendet wird. Wenn das Feld s_GUID ein Primärschlüssel ist (und Fremdschlüssel in anderen Tabellen darauf verweisen), benötigen Sie dieses Feld in der Regel in der neuen Tabelle. Wird s_GUID dagegen nicht als Primärschlüssel verwendet, gibt es keinen Grund, das Feld in die neue Tabelle zu übernehmen. Die Felder s_Lineage und s_Generation dürfen nicht in die neue Tabelle kopiert werden.

  1. Erstellen Sie eine neue Datenbank, und öffnen Sie diese.

  2. Zeigen Sie im Menü Datei auf Externe Daten, und klicken Sie dann auf Importieren.

  3. Klicken Sie auf das Replikat mit den Datenbankobjekten, die in die reguläre Datenbank übernommen werden sollen, und klicken Sie dann auf Importieren.

  4. Klicken Sie auf die Datenbankobjekte - ausgenommen Tabellen -, die in die neue Datenbank importiert werden sollen.

  5. Klicken Sie auf OK, um diese Objekte zu importieren.

  6. Erstellen Sie in der neuen Datenbank für jede Tabelle im Replikat eine Abfrage, die alle Daten aus der alten Tabelle liest und sie in eine neue Tabelle übernimmt.

    Wie wird's gemacht?

  7. Erstellen Sie für jede Tabelle in der neuen Datenbank den Index, der auch in der Tabelle des Replikats verwendet wird.

    Wie wird's gemacht?

  8. Erstellen Sie für jede Tabelle in der neuen Datenbank die Beziehungen, die für die Replikattabelle bestanden haben.

    Wie wird's gemacht?

  9. Speichern Sie die neue Datenbank.


 Replikation mit früheren Versionen von Microsoft Access

Replikation mit früheren Versionen von Microsoft Access

In Versionen von Microsoft Access vor Microsoft Access 7.0 ist die Replikation von Datenbanken nicht möglich. Deshalb können auch keine replizierten Datenbanken verwendet werden.

Sie können eine Replikatgruppe umwandeln, die Sie in Microsoft Access 97 erstellt haben, indem Sie die Replikatgruppe synchronisieren und dann jedes Replikat einzeln in Access 2000 umwandeln. Wenn Sie weitere Informationen zum Konvertieren einer Replikatgruppe benötigen, so dass diese in Microsoft Access 2000 verwendet werden kann, klicken Sie auf [image] .


 AutoWert-Felder und Replikation in einer Datenbank

AutoWert-Felder und Replikation in einer Datenbank

Wenn Sie beabsichtigen, Ihre Datenbank zu replizieren, müssen Sie überlegen, welche Feldgrößen für die Felder vom Typ AutoWert geeignet sind, die als Primärschlüssel einer Tabelle verwendet werden. Wenn Sie ein Feld vom Typ AutoWert als Primärschlüssel für eine Tabelle in der replizierten Datenbank verwenden, stellen Sie dessen Eigenschaft Feldgröße entweder auf Long Integer oder Replikations-ID ein.

  • Wenn zwischen den Synchronisierungen der Replikate normalerweise weniger als 100 Datensätze hinzugefügt werden, verwenden Sie die Einstellung Long Integer für die Eigenschaft Feldgröße, um Speicherplatz zu sparen.

  • Wenn zwischen den Synchronisierungen der Replikate normalerweise mehr als 100 Datensätze hinzugefügt werden, verwenden Sie die Einstellung Replikations-ID für die Eigenschaft Feldgröße, um zu verhindern, dass den Datensätzen in verschiedenen Replikaten derselbe Primärschlüsselwert zugewiesen wird. Beachten Sie jedoch, dass ein Feld vom Typ AutoWert mit der Feldgröße Replikations-ID einen 128-Bit-Wert erzeugt und dadurch mehr Speicherplatz benötigt.


Datenbankänderungen beim Verwenden der Replikation

Beim Replizieren einer Microsoft Access-Datenbank wird automatisch eine Reihe von Änderungen an Ihrer Datenbank vorgenommen.

Über welche Änderungen möchten Sie mehr erfahren?

Felder, die zu jeder vorhandenen Tabelle der Datenbank hinzugefügt werden

Tabellen, die zur Datenbank hinzugefügt werden

Eigenschaften, die zur Datenbank hinzugefügt werden

Änderungen am Verhalten der AutoWert-Felder

Änderungen der Größe der Datenbankdatei


 Hinweise zum Ändern des Designs einer replizierten Datenbank

Hinweise zum Ändern des Designs einer replizierten Datenbank

  • Synchronisieren Sie alle Replikate in der Replikatgruppe, bevor Sie Änderungen am Design vornehmen.

  • Prüfen Sie alle Replikate, um sicherzustellen, dass der für ein neues Feld oder Objekt ausgewählte Name nicht bereits als Name eines lokalen Objekts verwendet wird. (Wenn Sie denselben Namen wählen, wird das lokale Objekt umbenannt.)

  • Erstellen Sie keine Beziehungen zwischen Tabellen, wenn Sie einige Tabellen replizieren möchten und andere nur lokal verwalten möchten.

  • Stellen Sie sicher, dass die Anzahl Byte, die Sie zu einem Feld hinzufügen, oder dass die Anzahl Felder, die Sie zu einem Datensatz hinzufügen, nicht den maximal zulässigen Wert für eine replizierte Datenbank überschreitet. Wenn Sie weitere Informationen zu den Größeneinschränkungen bei einer replizierten Datenbank benötigen, klicken Sie auf [image] .

  • Wenn Sie verknüpfte Tabellen verwenden, sollten Sie beachten, dass verknüpfte Tabellen nicht automatisch repliziert werden. Wenn Sie im Designmaster eine replizierte Tabelle erstellen, wird diese als lokales Objekt erstellt und bleibt so lange lokal, bis sie replizierbar gemacht wird. Wenn Sie die Tabelle replizierbar machen, werden die Verknüpfung und die Tabelle an alle Replikate der Gruppe weitergeleitet. Wenn die Tabelle in jedem Replikat erscheint, können Sie die Verknüpfung in einem einzelnen Replikat oder im Designmaster ändern, ohne dass dadurch die anderen Mitglieder der Replikatgruppe beeinträchtigt werden. Wenn Sie die Verknüpfung in allen Mitgliedern der Replikatgruppe aktualisieren möchten, ändern Sie (im Designmaster) die replizierbare verknüpfte Tabelle in eine lokale Tabelle um, aktualisieren Sie die Verknüpfung, und ändern Sie dann die Tabelle wieder in eine replizierbare Tabelle zurück.


 Schützen einer replizierten Datenbank

Schützen einer replizierten Datenbank

Zum Schützen einer replizierten Datenbank können Sie Berechtigungen für Benutzer für replizierte Datenbankobjekte festlegen. Diese Berechtigungen haben keine Auswirkungen auf die Synchronisierung der Datenbank. Sie können die replizierte Datenbank jedoch nicht mit einem Kennwort schützen. Eine kennwortgeschützte Datenbank kann nicht replizierbar gemacht werden. Ebensowenig kann einer replizierten Datenbank ein Kennwort zugewiesen werden.

Sie können auch ein Replikat in einem nicht freigegebenen Verzeichnis speichern und die indirekte Synchronisierung (über den Microsoft Replikations-Manager) verwenden. Wenn die direkte Synchronisierung erforderlich ist, stellen Sie die Berechtigungen für den Bereich ein, auf dem sich die Replikate befinden, so dass nur bestimmte Benutzer darauf zugreifen können. Stellen Sie Replikate nicht in schreibgeschützte Bereiche, da dann die Synchronisierung mit anderen Replikatgruppen nicht erfolgen kann.

Wenn Sie andere Themen zum Replizieren eines Microsoft Access-Projekts aufrufen möchten, klicken Sie auf [image] .


 Replikation mit Jet and Replication-Objekten (JRO)

Replikation mit Jet and Replication-Objekten (JRO)

Sie können eine replizierte Datenbank mit Hilfe von Methoden und Eigenschaften von Jet and Replication-Objekten (JRO) erstellen und verwalten.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

Programmierung von replizierten Datenbanken

Methoden

Eigenschaften

Methoden und Eigenschaften, die in einem Teilreplikat verfügbar sind

Weitere Informationen

Programmierung von replizierten Datenbanken

Verwenden Sie JRO, wenn Sie eine Softwaresteuerung für den Austausch von Daten und Designinformationen unter den Mitgliedern der Replikatgruppe benötigen. Sie können beispielsweise JRO verwenden, um eine Prozedur zu schreiben, die automatisch ein Replikat eines Benutzers mit der übrigen Gruppe synchronisiert, wenn der Benutzer die Datenbank öffnet. Die Datenbank muss geschlossen werden, wenn die Datenbank per Softwaresteuerung replizierbar gemacht werden soll.

Zurück zum Anfang

Methoden

CreateReplica-Methode

GetObjectReplicability-Methode

MakeReplicable-Methode

SetObjectReplicability-Methode

Synchronize-Methode

Zurück zum Anfang

Eigenschaften

ActiveConnection-Eigenschaft

ConflictFunction-Eigenschaft

ConflictTables-Eigenschaft

DesignMasterId-Eigenschaft

ReplicaId-Eigenschaft

ReplicaType-Eigenschaft

RetentionPeriod-Eigenschaft

TableName-Eigenschaft

Visibility-Eigenschaft

Zurück zum Anfang

Methoden und Eigenschaften, die in einem Teilreplikat verfügbar sind

Append-Methode

Delete-Methode

PopulatePartial-Methode

FilterCriteria-Eigenschaft

FilterType-Eigenschaft

Priority-Eigenschaft

Zurück zum Anfang

Weitere Informationen

Erstellen von Teilreplikaten

Zurück zum Anfang


 Konvertieren einer Replikatgruppe in Microsoft Access 2000

Konvertieren einer Replikatgruppe in Microsoft Access 2000

Wenn Sie ein Replikat, das Sie in Microsoft Access 97 erstellt haben, so konvertieren, dass es in Microsoft Access 2000 verwendet werden kann, müssen Sie die Konvertierung für jedes Replikat einzeln durchführen. Es wird empfohlen, dass Sie vor der Konvertierung zuerst die Replikatgruppe synchronisieren. Wenn ihre Replikatgruppe gespeichert wurde, empfiehlt es sich, auch die Datei system.mdw zu konvertieren, die Datenbankberechtigungen enthält. Dies ist jedoch nicht unbedingt erforderlich. Die Umwandlung funktioniert nur dann, wenn sich alle Mitglieder der Replikatgruppe auf Computern befinden, auf denen Microsoft Access 2000 installiert ist.

Gehen Sie beim Konvertieren einer Replikatgruppe umsichtig vor. In dem Verfahren ist es möglich, zuerst einmal eine temporäre, sekundäre Replikatgruppe zu testen, bevor Sie die Original-Replikatgruppe umwandeln.

Weitere Informationen

Konvertieren einer Replikatgruppe in Microsoft Access 2000


 Festlegen des Designmasters beim Arbeiten im Aktenkoffer

Festlegen des Designmasters beim Arbeiten im Aktenkoffer

Wenn Sie beim Arbeiten in der Aktenkofferausgabe der .mdb-Datei das Design Ihrer Datenbank ändern möchten, definieren Sie die Aktenkofferausgabe als Designmaster. Dabei müssen Sie jedoch beachten, dass in diesem Fall niemand in der Lage ist, das Design des Replikats zu ändern, das sich auf dem Desktop befindet.


 Änderungen am Verhalten von AutoWert-Feldern beim Replizieren einer Datenbank

Änderungen am Verhalten von AutoWert-Feldern beim Replizieren einer Datenbank

Beim Replizieren einer Datenbank werden alle inkrementellen AutoWert-Felder in Ihrer Datenbank in Felder mit Zufallszahlen geändert. Dabei behalten alle AutoWert-Felder in vorhandenen Datensätzen ihre Werte, bei eingefügten Datensätze werden jedoch Zufallszahlen für AutoWert-Felder verwendet. Das heißt, dass die Datensatznummern nicht die Reihenfolge wiedergeben, in der Datensätze eingefügt wurden. Der zuletzt eingefügte Datensatz hat dadurch auch nicht unbedingt den höchsten Wert.

Stellen Sie vor dem Replizieren einer Datenbank fest, ob für eine der Anwendungen oder Benutzer die inkrementelle Nummerierung der AutoWert-Felder von Bedeutung ist. Wenn das der Fall ist, können Sie Informationen zur sequentiellen Reihenfolge über ein zusätzliches Feld für Datum/Zeit einfügen.

Anmerkung Replikate in einer Access-Datenbank, die über eine Microsoft SQL Server-Publikation erstellt wurden, behalten die AutoWert-Funktion bei, um die Funktion für benannte Bereiche von SQL Server zu unterstützen. Sie müssen diese Bereiche in jedem Replikat verwalten. Wenn Sie weitere Informationen zur Replikation in einem Microsoft Access-Projekt aufrufen möchten, klicken Sie auf [image] .


 Felder, die beim Replizieren einer Datenbank zur Tabelle hinzugefügt werden

Felder, die beim Replizieren einer Datenbank zur Tabelle hinzugefügt werden

Wenn Sie eine Datenbank replizieren, fügt Microsoft Access in der replizierten Datenbank die folgenden Systemfelder zu jeder replizierten Tabelle hinzu:

Feld | Beschreibung
s_GUID | Ein global eindeutiger Bezeichner für jeden Datensatz.
s_Lineage | Ein binäres Feld, das für jeden Datensatz Informationen zur Änderungshistorie enthält.
s_Generation | Ein Feld, das Informationen zu Änderungsgruppen speichert.

Anmerkungen

  • Zusätzliche Felder (mit der Bezeichnung Gen_Fieldname) werden für jedes Feld einer Tabelle mit dem Datentyp Memo oder OLE-Objekt hinzugefügt.

  • Die Systemfelder s_GUID, s_Lineage und s_Generation sind Systemobjekte, die in den Tabellen ein- oder ausgeblendet sein können. Wenn Sie diese Felder in replizierten Tabellen einblenden möchten, klicken Sie im Menü Extras auf Optionen, klicken Sie dann auf die Registerkarte Ansicht, und aktivieren Sie das Kontrollkästchen Systemobjekte. Zum Anzeigen der Felder öffnen Sie eine replizierte Tabelle.

  • Sie können die Informationen nicht ändern, die in den Systemfeldern einer replizierten Tabelle gespeichert sind.

  • Wenn Sie weitere Anmerkungen zum Replizieren eines Microsoft Access-Projekts aufrufen möchten, klicken Sie auf [image] .


 Eigenschaften, die bei der Replikation zur Datenbank hinzugefügt werden

Eigenschaften, die bei der Replikation zur Datenbank hinzugefügt werden

Wenn Sie eine Datenbank replizieren oder ein Datenbankobjekt als lokal definieren, werden möglicherweise die folgenden neuen Eigenschaften zur Eigenschaften-Auflistung von Objekten hinzugefügt:

Eigenschaft | Beschreibung
Replicable oder ReplicableBool | Eine Eigenschaft einer Datenbank oder eines Objekts. Wenn für die Eigenschaft T (oder True für ReplicableBool) festgelegt wird, wird damit angegeben, dass die Datenbank oder die Tabelle jetzt replizierbar ist. Die Eigenschaften Replicable und ReplicableBool können untereinander ausgetauscht werden.
KeepLocal | Eine Eigenschaft, die an eine Tabelle oder an eine Abfrage angehängt wird. Wenn für die Eigenschaft T festgelegt wird, wird damit angegeben, dass das Objekt nicht repliziert werden soll, wenn die Datenbank repliziert wird. Für ein Objekt, das bereits repliziert ist, kann die KeepLocal-Eigenschaft nicht eingestellt werden.
ReplicaID | Eine Eigenschaft, die für die eindeutige Identifikation jedes Mitglieds der Replikatgruppe sorgt. Diese Eigenschaft ist schreibgeschützt und wird in der Systemtabelle MSysReplicas gespeichert.
DesignMasterID | Die Replikat-ID des Designmasters. Wird in der Systemtabelle MSysRepInfo als Schemamaster gespeichert.
ColumnLevelTracking | Eine Eigenschaft einer Datenbank oder Tabelle. Wenn die Eigenschaft auf True (Standard) gesetzt wird, wird damit angegeben, dass Konflikte auf der Spaltenebene der Tabelle verwaltet werden. Wenn Sie weitere Informationen zum Verwalten von Datenänderungen benötigen, klicken Sie auf [image] .
Replication ConflictFunction | Diese Eigenschaft wird verwendet, um den Microsoft-Replikationskonflikt-Viewer durch ein angepasstes Verfahren zu ersetzen, das Benutzer beim Beheben von Synchronisierungskonflikten unterstützt.

Anmerkungen

  • Microsoft Access-Objekte (Formulare, Berichte, Makros und Module) sind in Access 2000 entweder alle repliziert oder alle lokal. Deshalb gelten die Eigenschaften Replicable und KeepLocal nur für Tabellen und Abfragen. Wenn Sie weitere Informationen dazu benötigen, wie Sie das Replizieren von Formularen, Berichten, Makros und Modulen verhindern können, klicken Sie auf [image] .

  • Wenn Sie weitere Informationen zu den Eigenschaften Replicable, KeepLocal, ReplicaId und DesignMasterID benötigen, öffnen Sie den Visual Basic-Editor, und rufen Sie die Hilfe des Visual Basic-Editors auf.


 Tabellen, die beim Replizieren zur Datenbank hinzugefügt werden

Tabellen, die beim Replizieren zur Datenbank hinzugefügt werden

Wenn eine Microsoft Access-Datenbank repliziert wird, dann werden unter bestimmten Bedingungen neue Systemtabellen zur Datenbank hinzugefügt. Unter diesen sind die folgenden neuen Systemtabellen von Interesse:

Tabelle | Beschreibung
MSysSidetables | Diese Tabelle ist nur dann vorhanden, wenn ein Konflikt zwischen dem Replikat des Benutzers und einem anderen Replikat in der Replikatgruppe aufgetreten ist. Diese Tabelle wird nicht repliziert. Sie wird nur zu Informationszwecken bereitgestellt; ihr Inhalt kann durch angepasste Routinen zur Konfliktbehebung oder vom Benutzer geändert oder gelöscht werden. Alle Nebentabellen haben die Bezeichnung table_conflict, wobei table der ursprüngliche Name der Tabelle ist.
MSysSchemaProb | Diese Tabelle ist nur dann vorhanden, wenn beim Aktualisieren des Designs eines Replikats ein Fehler aufgetreten ist. Sie stellt zusätzliche Details zur Fehlerursache zur Verfügung. Hier handelt es sich um eine lokale Tabelle, die nicht repliziert wird.
MSysReplicas | In dieser Tabelle werden Details, wie z. B. die Replikat-ID und der Pfad, für alle bekannten Replikate in der Replikatgruppe gespeichert. Diese Tabelle wird für alle Mitglieder der Replikatgruppe angezeigt, sie wird jedoch nicht repliziert.
MSysTransAddress | In dieser Tabelle werden Adressinformationen für den Synchronizer gespeichert, und es wird die Gruppe der Synchronizer definiert, die für die Replikatgruppe bekannt sind. Diese replizierte Tabelle wird für alle Mitglieder der Replikatgruppe angezeigt.
MSysTombstone | In dieser Tabelle sind Informationen zu gelöschten Datensätzen gespeichert. Sie ermöglicht, dass Löschungen beim Synchronisieren an andere Replikate weitergegeben werden. Diese Tabelle wird für alle Mitglieder der Replikatgruppe angezeigt, sie ist jedoch keine replizierte Tabelle.
MSysRepInfo | In dieser Tabelle sind Informationen zur gesamten Replikatgruppe gespeichert, wozu auch die ID (GUID) des Designmasters gehört. Diese Tabelle enthält einen einzigen Datensatz. Diese replizierte Tabelle wird für alle Mitglieder der Replikatgruppe angezeigt.
MSysExchangeLog | In dieser Tabelle werden Informationen zu Synchronisierungen von Replikaten gespeichert, die stattgefunden haben. Es handelt sich hierbei um eine lokale Tabelle, die nicht repliziert wird.

Anmerkungen

  • Diese Tabellen werden angezeigt, wenn Systemobjekte eingeblendet sind. Zum Einblenden von Systemobjekten klicken Sie im Menü Extras auf Optionen, klicken auf die Registerkarte Ansicht und aktivieren dann das Kontrollkästchen Systemobjekte.

  • Sie können in einer replizierten Datenbank die Daten nicht ändern, die in den folgenden Systemtabellen gespeichert sind: MSysSchemaProb, MSysExchangeLog, MSysReplicas, MSysTransAddress, MSysTombstone und MSysRepInfo.


 Replikation mit Datenzugriffsobjekten (DAO)

Replikation mit Datenzugriffsobjekten (DAO)

Sie können eine replizierte Datenbank mit Hilfe von DAO-Methoden und Eigenschaften erstellen und verwalten. Verwenden Sie DAO, wenn der Austausch von Daten und Entwurfsinformationen zwischen Mitgliedern einer Replikatgruppe programmgesteuert erfolgen muss. Beispielsweise können Sie unter Verwendung der DAO eine Prozedur schreiben, die ein Replikat des Benutzers automatisch mit dem Rest der Replikatgruppe synchronisiert, wenn der Benutzer die Datenbank öffnet.

Zum Erstellen und Verwalten einer replizierten Datenbank können Sie die folgenden Methoden und Eigenschaften verwenden:

MakeReplica-Methode

Synchronize-Methode

ConflictTable-Eigenschaft

DesignMasterID-Eigenschaft

KeepLocal-Eigenschaft

Replicable-Eigenschaft

ReplicaID-Eigenschaft

ReplicationConflictFunction-Eigenschaft

Zum Erstellen und Verwalten von Teilreplikaten (Replikate, die eine Teilmenge der Datensätze eines vollständigen Replikats enthalten) bietet Microsoft Jet zusätzlich die folgenden Methoden und Eigenschaften:

ReplicaFilter-Eigenschaft

PartialReplica-Eigenschaft

PopulatePartial-Methode

Rufen Sie Informationen zum Erstellen von Teilreplikaten auf.

Anmerkung Wenn Sie weitere Informationen zu diesen Eigenschaften und Methoden benötigen, öffnen Sie den Visual Basic-Editor, und greifen Sie auf die Visual Basic Editor-Hilfe zu.


 Zusätzliche Größeneinschränkungen bei einer replizierten Datenbank

Zusätzliche Größeneinschränkungen bei einer replizierten Datenbank

Die Addition von drei Feldern (s_GUID, s_Lineage und s_Generation) verursacht zwei Einschränkungen für die replizierten Tabellen:

  • Die Microsoft Jet Datenbank-Engine lässt maximal 2.048 Byte (ohne die Felder Memo oder OLE-Objekt) in einem Datensatz zu. Die Replikation benötigt mindestens 54 Byte zum Speichern von eindeutigen Bezeichnern, Indexen und Informationen zu Änderungen des Datensatzes. Wenn der Datensatz entweder Memo- oder OLE-Objekt-Felder enthält, benötigt die Replikation zusätzliche 4 Byte für jedes dieser Felder. Die Gesamtzahl der Byte, die in einem Datensatz einer replizierten Tabelle verfügbar ist, kann folgendermaßen errechnet werden:

    2.048 Byte
    - 54 Byte für Replikationsoverhead
    - (4 Byte * Anzahl der Memo-Felder)
    - (4 Byte * Anzahl der OLE-Objekt-Felder)
    = maximale Anzahl verfügbarer Byte

  • Die Microsoft Jet Datenbank-Engine lässt maximal 255 Felder in einer Tabelle zu, wobei mindestens drei Felder für die Replikation verwendet werden. Die Gesamtzahl der Felder, die in einer replizierten Tabelle verfügbar sind, kann folgendermaßen errechnet werden:

    255 Felder
    - 3 Systemfelder
    - Anzahl der Memo- und OLE-Objekt-Felder
    = Anzahl der verfügbaren Felder

In nur wenigen, ausgefeilten Anwendungen werden alle verfügbaren Felder einer Tabelle oder alle Byte in einem Datensatz verwendet. Wenn Ihre Tabelle über eine große Anzahl von Memo- oder OLE-Objekt-Feldern verfügt, entstehen möglicherweise Einschränkungen.

Anmerkung Zusätzlich zum Setzen von Einschränkungen für die verfügbare Anzahl Zeichen und Felder schränkt die Microsoft Jet Datenbank-Engine auch die Anzahl der zulässigen, verschachtelten Transaktionen ein. In einer nichtreplizierten Datenbank sind maximal sieben verschachtelte Transaktionen zulässig, in einer replizierten Datenbank aber maximal sechs.

Durch das Hinzufügen mehrerer neuer Tabellen wird auch die Datenbank größer. Die meisten dieser neuen Tabellen enthalten zwar nur wenige Datensätze, einige der neuen Tabellen können jedoch, abhängig von der Häufigkeit der Synchronisierungen zwischen Replikaten, erheblich anwachsen.

Die Größe Ihrer Datenbank ist aus zwei Gründen von Bedeutung:

  • Die Microsoft Jet Datenbank-Engine unterstützt Dateien mit einer Größe von maximal 1 GB, bei vielen Benutzer ist jedoch der Platz auf der Festplatte beschränkt. Eine replizierte Datenbank, die größer ist als die ursprüngliche Datenbankdatei, verbraucht möglicherweise einen großen Prozentsatz der verfügbaren Festplattenkapazität.

  • Wenn Sie eine Sicherungskopie des nichtreplizierbaren Formats Ihrer Datenbank erstellen, müssen Sie auf Ihrer Festplatte ausreichend Platz für die replizierte Datenbank und die Sicherungskopie haben.

  • Anmerkung Wenn Sie weitere Informationen zu einem Microsoft Access-Projekt benötigen, klicken Sie auf [image] .


Hintergründe der Datenbankreplikation

1 Vor dem Replizieren einer Datenbank

Auswählen eines Tools für die Replikation

2 Erstellung einer replizierten Datenbank

Erstellen eines Replikats Ihrer Datenbank

Erstellen eines Replikats mit dem Aktenkoffer

3 Synchronisierung einer Replikatgruppe

Synchronisieren einer Kopie mit einem anderen Replikat der Replikatgruppe

Synchronisieren eines Replikats mit dem Aktenkoffer

Lösen von Synchronisierungskonflikten zwischen den Replikaten einer Replikatgruppe

4 Verwaltung von replizierten Datenbanken

Wiederherstellen des Designmasters

Bestimmen eines Replikats zum neuen Designmaster

Umwandeln einer replizierten Datenbank in eine reguläre Datenbank

Schützen einer replizierten Datenbank

Entfernen eines Replikats aus der Replikatgruppe

Erstellen einer Sicherungskopie einer replizierten Microsoft Access-Datenbank

5 Umwandlung einer replizierten Datenbank

Konvertieren einer Replikatgruppe in Microsoft Access 97

6 Programmgesteuertes Replizieren einer Datenbank

Replikation mit Datenzugriffsobjekten (Data Access Objects = DAO)

Replikation mit Jet and Replication-Objekten (JRO)


 Konvertieren einer Datenbank im Aktenkoffer

Konvertieren einer Datenbank im Aktenkoffer

Die ausgewählte Datenbankdatei ist kein Replikat mit der Erweiterung .MDB. Um die Datenbank zu einem Replikat zu machen, muss sie zuerst in einen Designmaster konvertiert werden. Das Konvertieren der Datenbank vergrößert die Datei, da neue, ausgeblendete Systemfelder und Tabellen zur Datenbank hinzugefügt werden.

Entfernen Sie das Datenbank-Kennwort, bevor Sie die Datenbank konvertieren. Wenn Sie für den Zugriff auf die Datenbank Benutzerberechtigungen einstellen, behindern diese die Synchronisierung nicht.


 Erstellen einer Sicherungskopie einer replizierten Microsoft Access-Datenbank

Erstellen einer Sicherungskopie einer replizierten Microsoft Access-Datenbank

Wenn Sie eine Microsoft Access-Datenbank auf das Symbol Aktenkoffer ziehen oder im Microsoft Access-Menü Extras auf Replikation zeigen und dann auf Datenbank in Replikat konvertieren klicken, können Sie eine Sicherungskopie der Originaldatei erstellen. Das Erstellen einer Sicherungskopie ist sehr empfehlenswert; verwenden Sie die Sicherungskopien jedoch nur im Notfall. Kopien der Sicherungskopie der Datenbank sowie Replikate, die aus einer konvertierten Sicherungskopie erstellt werden, können nicht mit den vorhandenen Mitgliedern der Replikatgruppe synchronisiert werden.


Verhindern der Replikation von Formularen, Berichten, Makros und Modulen

Anmerkung Dieser Vorgang muss vor dem Replizieren einer Datenbank ausgeführt werden.

  1. Klicken Sie im Menü Datei auf Datenbankeigenschaften.

  2. Klicken Sie auf die Registerkarte Anpassen.

  3. Markieren Sie im Feld Eigenschaften die Option ReplicateProject.

  4. Klicken Sie neben Wert auf Nein.

  5. Klicken Sie auf Ändern.


 Ich kann den Designmaster nicht finden.

Ich kann den Designmaster nicht finden.

Möglicherweise wurde der Designmaster verschoben, oder er ist beschädigt. So finden Sie den neuen Speicherort:

  1. Öffnen Sie ein Replikat in der Replikatgruppe.

  2. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Jetzt Synchronisieren.

  3. Klicken Sie auf Durchsuchen, um andere Mitglieder der Replikatgruppe auf Ihrem Computer oder im Netzwerk zu suchen.

  4. Wählen Sie ein Mitglied der Replikatgruppe aus. Wenn das Kontrollkästchen Legt 'Dateiname' als Designmaster fest angezeigt wird, dann ist das Mitglied, mit dem Sie die Synchronisierung ausführen, der Designmaster.


 Ich kann das Replikat nicht als Designmaster definieren.

Ich kann das Replikat nicht als Designmaster definieren.

Möglicherweise wird das Replikat gerade von einem anderen Vorgang oder einer anderen Anwendung verwendet, und es kann nicht exklusiv geöffnet werden. Warten Sie einige Minuten, und versuchen Sie es dann erneut.

Wenn Sie dann das Replikat immer noch nicht zum Designmaster machen können, und wenn Sie keine Fehlermeldung erhalten haben, dann ist das Replikat möglicherweise beschädigt. Löschen Sie das Replikat, und erstellen Sie ein neues. Wenn Sie Informationen zum Löschen eines Replikats benötigen, klicken Sie auf [image] .


 Ich kann den Designmaster nicht öffnen.

Ich kann den Designmaster nicht öffnen.

Der Designmaster ist möglicherweise beschädigt. Definieren Sie ein Replikat als den neuen Designmaster. Wenn Sie weitere Informationen dazu benötigen, klicken Sie auf [image] .


 Ich möchte zum Beheben von Synchronisierungskonflikten ein anderes Programm verwenden.

Ich möchte zum Beheben von Synchronisierungskonflikten ein anderes Programm verwenden.

  1. Öffnen Sie den Designmaster für die Replikatgruppe.

  2. Klicken Sie im Menü Datei auf Datenbankeigenschaften.

  3. Klicken Sie auf die Registerkarte Anpassen.

  4. Geben Sie in das Feld Name Folgendes ein: ReplicationConflictFunction.

  5. Klicken Sie im Feld Typ auf Text.

  6. Geben Sie im Feld Wert den Namen der angepassten Funktion ein, und danach ( ). Wenn beispielsweise der Name der angepassten Funktion MyResolver lautet, geben Sie MyResolver( ) ein.

Um weitere Informationen zu der ReplicationConflictFunction-Eigenschaft aufzurufen, klicken Sie auf [image] .


 Wenn ich Daten in einem Mitglied der Replikatgruppe ändere, werden diese Änderungen in einem anderen Mitglied nicht übernommen.

Wenn ich Daten in einem Mitglied der Replikatgruppe ändere, werden diese Änderungen in einem anderen Mitglied nicht übernommen.

  1. Öffnen Sie das Mitglied der Replikatgruppe, das Sie synchronisieren möchten.

  2. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie auf Jetzt synchronisieren.

  3. Geben Sie den Pfad und den Dateinamen der anderen replizierten Datenbank ein, mit der Sie die Datenbank öffnen möchten, die Sie synchronisieren möchten.

  4. Klicken Sie auf OK.

  5. Schließen Sie die Datenbank, und öffnen Sie sie erneut, um die aktualisierten Datensätze anzuzeigen.

  6. Wenn die Änderungen immer noch nicht angezeigt werden, haben Sie möglicherweise die Änderungen in lokalen Objekten vorgenommen, die nicht mit den Mitgliedern der Replikatgruppe synchronisiert werden, oder es besteht ein Konflikt mit einem anderen Mitglied. Wenn Sie Informationen zum Beheben von Konflikten aufrufen möchten, klicken Sie auf [image] .


 Wenn ich das Design eines Objekts im Designmaster ändere, ändert sich keines der Replikate.

Wenn ich das Design eines Objekts im Designmaster ändere, ändert sich keines der Replikate.

  1. Öffnen Sie den Designmaster.

  2. Zeigen Sie im Menü Extras auf Replikation, und klicken Sie dann auf Jetzt synchronisieren.


Ich möchte die Replikation nicht verwenden, wenn ich eine Datenbankdatei in den Aktenkoffer ziehe. Wie umgehe ich die Aktenkoffer-Replikation?

Der Aktenkoffer repliziert Microsoft Access-Datenbankdateien, wenn Sie diese in den Aktenkoffer ziehen. Wenn Sie die Datenbankdatei nicht replizieren möchten, ändern Sie die Dateinamenerweiterung .mdb (oder .mde) in eine andere Erweiterung.


 In der Replikatgruppe gibt es zwei Designmaster.

In der Replikatgruppe gibt es zwei Designmaster.

Wenn mehr als ein Designmaster in einer Replikatgruppe vorhanden ist, wird damit verindert, dass die Mitglieder der Gruppe richtig synchronisiert werden. Gehen Sie in diesem Fall folgendermaßen vor:

  1. Stellen Sie fest, welcher Designmaster der ursprüngliche Designmaster ist und ob dieser es auch weiterhin bleiben soll.

  2. Löschen Sie den anderen Designmaster.

  3. Löschen Sie alle Replikate, die zuletzt mit dem gelöschten Designmaster oder mit Replikaten synchronisiert wurden, die mit dem gelöschten Designmaster synchronisiert wurden.

    Wie wird's gemacht?

  4. Erstellen Sie aus dem verbleibenden Designmaster neue Replikate, um das oder die gelöschten Replikate zu ersetzen.