Neue FrontPage-Leistungsmerkmale für Entwickler

Microsoft FrontPage 2000 umfasst nun ein Microsoft Visual Basic für Applikationen entsprechendes Objektmodell, das die neuen und verbesserten Funktionen in der Anwendung unterstützt. Viele der Methoden, die Sie aus FrontPage 98 kennen, sind zwar weiterhin verfügbar, wurden jedoch durch Sprachelemente ersetzt, die das neue Objektmodell nutzen können. Weitere Informationen zu den Funktionsbereichen in FrontPage finden Sie im Abschnitt Neue Funktionsbereiche; Einzelheiten zu Sprachelementen finden Sie im Abschnitt Neue Sprachelemente, und wenn Sie Näheres zu den verborgenen Sprachelementen erfahren möchten, lesen Sie den Abschnitt Verborgene Sprachelemente.

Neue Funktionsbereiche

In den folgenden Hilfethemen finden Sie grundlegende Informationen über die neuen Funktionen in FrontPage 2000.

Zugreifen auf das Objektmodell in FrontPage über Entwurfszeit-Steuerelemente

Zugreifen auf Framesets mit Microsoft Visual Basic

Erstellen von Code in einer Umgebung ohne Fenster

Erstellen von Websites

Erforschen von Prozeduren

Erforschen des Objektmodells in FrontPage

Verwalten des Veröffentlichungsprozesses mit MetaTags

Verwalten von Quellcodeverwaltungsprojekten

Programmgesteuertes Ändern von Seiten

Programmieren von dynamischen Elementen

Freigeben von Programmierprojekten

Grundlegendes zur absoluten und relativen Adressierung

Verwenden von Ereignissen zum Steuern von Aktionen

Neue Sprachelemente

Die Integration von Microsoft Visual Basic für Applikationen ist neu in FrontPage. Sie können FrontPage jetzt mithilfe Ihrer Microsoft Word- oder Microsoft Excel-Makros automatisieren, alle Befehle verwenden, mit denen Sie bereits vertraut sind, und vieles mehr. Sie verfügen nun über Befehle, die Sie bei der Verwaltung von Websites ebenso unterstützen wie beim Erstellen von FrontPage-basierten Webseiten und die mit Microsoft Office-Makros und -Anwendungen ebenso kommunizieren wie mit den vertrauten Makrotools von Visual Basic.

Die neuen Sprachelemente in Visual Basic ersetzen die Sprachelemente von FrontPage 98. Aus Gründen der Abwärtskompatibilität sind die FrontPage 98-Elemente allerdings nach wie vor als verborgene Elemente in FrontPage 2000 integriert; deren Einsatz in Verbindung mit Visual Basic in FrontPage 2000 wird jedoch nicht empfohlen.

Verborgene Sprachelemente

Die OLE-Automatisierungsschnittstellen von Microsoft FrontPage 98 wurden nun zu Gunsten des neuen, umfangreicheren Objektmodells reduziert, wobei die alten Automatisierungsschnittstellen jedoch weiterhin funktionstüchtig sind. Zu berücksichtigen ist lediglich, dass bei jedem Aufruf, der für ein Web erfolgt, das Web verwendet wird, das sich im aktuell oben liegenden FrontPage-Fenster befindet, sofern ein Benutzer mehrere Fenster geöffnet hat.

Die Art und Weise der Menüanpassung der Vorgängerversion wurde durch die Befehlsleistenanpassung von Microsoft Office ersetzt.

Designer HTML wurde durch eine Kombination aus Office-Add-Ins und dem umfangreicheren Objektmodell ersetzt.


Erstellen von Websites mit Microsoft FrontPage 2000

In Microsoft FrontPage 2000 ist das Erstellen eines FrontPage-basierten Webs so einfach wie das Erstellen eines neuen Ordners auf der Festplatte. Der Schlüssel zu einer erfolgreichen Webverwaltung in FrontPage liegt in der Planung der Struktur und des Designs Ihrer Webs. Wie viele Benutzer von FrontPage 98 bereits wissen, erstellt FrontPage eine einzigartige Umgebung für Websites, mit der dem Webmaster eine weit höhere Flexibilität geboten wird. Bei den meisten Webservern arbeiten Sie mit einer Website, mit FrontPage hingegen können Sie so viele Webs erstellen, wie gewünscht werden, wozu auch verschachtelte Webs gehören. Ein FrontPage-basiertes Web besteht aus drei Ebenen, der Webstruktur, der Ordnerstruktur und der Navigationsstruktur. Klicken Sie auf einen der nachstehenden Links, um ein bestimmtes Thema auszuwählen.

Grundlegendes zur Webstruktur in FrontPage

Grundlegendes zur Ordnerstruktur in FrontPage

Grundlegendes zur Navigationsstruktur

Programmgesteuertes Erstellen von Websites

Erstellen einer Website mit der Add-Methode

Erstellen einer Website mit der MakeWeb-Methode

Grundlegendes zur Webstruktur in FrontPage

Bei jedem beliebigen Ordner auf Ihrem Webserver kann es sich um ein Web mit einer eigenen Ordnerhierarchie handeln, die dem Originalweb untergeordnete Unterwebs enthält. Bei der Installation von FrontPage schlägt das Programm automatisch einen Standardnamen für das Hauptweb vor. Auf einem festplattenbasierten System lautet dieser Standardname C:\Eigene Dateien\Eigene Webs bei Systemen, auf denen Microsoft Windows als Betriebssystem ausgeführt wird, oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs bei Systemen, die auf Microsoft Windows NT als Betriebssystem basieren. Möglicherweise möchten Sie die einzelnen Unterwebs nach den verschiedenen Unternehmensnamen selbst benennen, wie beispielsweise Adventure Works, American Society of Science, Encore Musical Instruments, Mightyflight Toys oder Rogue Cellars.

FrontPage umfasst weiterhin eine Vielzahl der unterschiedlichsten Webvorlagen, wie z. B. Firmenpräsenz, Diskussion, Kundenunterstützung usw. Diese Vorlagen stellen die Grundlagen für die Struktur des jeweiligen Webs bereit. Beispielsweise könnte Adventure Works bei Ihnen die Einrichtung eines umfassenden Firmenpräsenzwebs in Auftrag geben, wohingegen Encore Musical Instruments bereits über ein Web verfügt, das Sie importieren und darüber hinaus um ein Kundenunterstützungsweb erweitern sollen. Die Webhierarchie eines festplattenbasierten Webs wird im nachstehenden Diagramm dargestellt.

Abbildung 0.1 Konzeptionelle Ansicht einer Webstruktur.

Die folgende Abbildung zeigt die Webstruktur in der Ordneransicht. Die Unterwebs erkennen Sie an dem kleinen Globus im Ordnersymbol.

Abbildung 0.2 Anzeige der Unterwebs innerhalb der Struktur des Hauptwebs.

Grundlegendes zur Ordnerstruktur in FrontPage

Die Ordnerstruktur in FrontPage gleicht der Ordnerstruktur in Windows Explorer. Um jedoch über den Explorer auf die Dateien zugreifen zu können, müssen Sie diese an eine andere Speicheradresse exportieren, die sich entweder auf Ihrer Festplatte oder auf einem Server befinden kann. Während des Exportverfahrens werden die Dateien in HTML-Seiten umgewandelt. In diesem Sinne ist das Öffnen von FrontPage mit dem Öffnen eines Fensters in Ihrem Web vergleichbar. Die Ordnerhierarchie eines festplattenbasierten Webs wird im nachstehenden Diagramm dargestellt.

Abbildung 0.3 Konzeptionelle Ansicht einer Ordnerstruktur.

In der nachstehenden Abbildung wird gezeigt, wie sich die Ordnerstruktur in der Ordneransicht darstellt.

Abbildung 0.4 Ordner in einer kombinierten Ordner-/Webstruktur.

Anmerkung Diese Abbildung zeigt das gleiche Bild wie die vorherige, da sowohl Ordner als auch Webs in der gleichen Ansicht dargestellt werden, jedoch können Sie anhand der Web- und Ordnerdiagramme ersehen, dass sowohl Webs als auch Ordner über eine jeweils eigene Struktur verfügen. Ein Web oder ein Unterweb ist ein Ordner. Allerdings enthält ein Ordner, der gleichzeitig auch ein Web ist, Metadaten zu diesem Web. Wenn Sie beispielsweise einem Ihrer Webs ein Design zuweisen, wird dieses spezielle Design für alle Ordner innerhalb dieses Webs übernommen. Allerdings können Sie den verschiedenen Webs auf Ihrem Webserver unterschiedliche Designs zuweisen. Wenn Sie ein Web in einen Ordner umwandeln, entfernen Sie die speziellen Einstellungen, mit denen aus einem Ordner ein Web gemacht wird, und Einstellungen wie beispielsweise das Design betreffende ändern sich, so dass sie dem „globalen“ Design für das festplatten- oder serverbasierte Web entsprechen, das als Container für Ihre FrontPage-basierten Unterwebs dient.

Grundlegendes zur Navigationsstruktur

Sie können innerhalb Ihres Webs Dateien erstellen, jedoch wird die Navigationsstruktur, mit der diese Dateien in Ihr Web eingebunden werden, nicht automatisch mit dem Erstellen der Dateien erstellt. Allerdings kann jedes Unterweb über eine eigene Homepage verfügen. Die Homepage ist normalerweise die Startseite jedes Webs in der Navigationsstruktur. In FrontPage können Sie jedoch alternative Seiten erstellen, die sich auf der gleichen Navigationsebene befinden wie die Homepage. Möglicherweise möchten Sie Links zu einer Homepage hinzufügen, mit denen eine Navigation zu den Homepages anderer Unterwebs ermöglicht wird, die Sie betreuen.

Die Navigationsstruktur enthält Knoten, mit denen alle Seiten in Ihren Unterwebs verknüpft werden und stellt Verweise auf die Adresse jeder Seite in der Navigationsstruktur bereit. Die Navigationsstruktur eines festplattenbasierten Webs wird im nachstehenden Diagramm dargestellt.

Abbildung 0.5 Konzeptionelle Ansicht einer Navigationsstruktur.

Die folgende Abbildung zeigt die Navigationsstruktur in der Navigationsansicht.

Abbildung 0.6 Navigationknoten innerhalb der Navigationsstruktur.

Programmgesteuertes Erstellen von Websites

Hier nun ein äußerst einfaches Design für ein Web. Die Firma Rogue Cellars möchte ihrem Web ein Unterweb mit Namen „Wines Around the World“ hinzufügen, das mit Seiten für zwei Länder, Spanien und Frankreich, beginnt. Die Ordnerstruktur enthält das Web „Rogue Cellars“ sowie den Ordner Wines Around the World für das Unterweb, den verborgenen Ordner _private sowie einen Ordner Images. Die Navigationsstruktur enthält die Homepage von Wines Around the World (index.htm) und die beiden untergeordneten Seiten (Spain.htm und France.htm, d. h. den linken bzw. rechten Knoten in der Navigationsstruktur).

In Microsoft Visual Basic für Applikationen stehen zwei Methoden zum Erstellen von FrontPage-basierten Webs zur Verfügung. Einerseits können Sie die Add-Methode in Verbindung mit der Webs-Auflistung verwenden, andererseits können Sie sich für die MakeWeb-Methode in Verbindung mit einem WebFolder-Objekt entscheiden, um einen vorhandenen Ordner in ein Web umzuwandeln.

Erstellen einer Website mit der Add-Methode

Nachdem Sie das gewünschte Aussehen und die Funktionsweise Ihres Webs gestaltet haben, können Sie die Set-Anweisung, wie in der nachstehenden Prozedur gezeigt, verwenden, um ein neues Web zu erstellen.

Anmerkung Um die Beispiele in diesem Hilfethema nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles \Logon-Alias\Personal\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Alternativ können Sie auch ein Web sowie Dateien Ihrer Wahl einsetzen.

Private Sub Add()
Dim myNewWeb As Web

Set myNewWeb = _
    Webs.Add("C:\My Webs\Rogue Cellars\Wines Around the World")
End Sub

Wenn Sie diese Methode zum Erstellen eines Webs verwenden, erstellen Sie lediglich das Web und die dazugehörigen Ordner und keine vollständige Website mit allen Ordnern, Seiten und den entsprechenden Navigationsmöglichkeiten. Der nächste Schritt besteht im Hinzufügen der Homepage. Mit der folgenden, an die vorstehende Prozedur angefügte und im Fettdruck dargestellten Anweisung wird eine Homepage hinzugefügt.

Private Sub Add()
Dim myNewWeb As Web
Dim myFiles As WebFiles
Dim myUrl As String

Set myNewWeb = _
    Webs.Add("C:\My Webs\Rogue Cellars\Wines Around the World")
Set myFiles = myNewWeb.RootFolder.Files
myFileUrl = _
    "C:\My Webs\Rogue Cellars\Wines Around the World\index.htm"

myFiles.Add(myFileUrl)
End Sub

Da es sich bei index.htm oder default.htm um Dateinamen handelt, die generell für Homepages verwendet werden, erstellt FrontPage die entsprechende Navigationsstruktur für eine Homepage immer dann, wenn Sie einen dieser Namen verwenden. Wenn Sie jedoch mit Hilfe der Add-Methode in Verbindung mit dem WebFile-Objekt weitere Seiten hinzufügen, fügen Sie diese Seiten zwar hinzu, jedoch erstellt FrontPage nicht automatisch die Navigationsstruktur für Sie, sondern Sie müssen die Navigationsstruktur manuell hinzufügen, wie in den folgenden, ebenfalls im Fettdruck dargestellten Anweisungen gezeigt.

Anmerkung Im folgenden Beispiel wird innerhalb des Webs „Rogue Cellars“ ein neues Web erstellt, und in diesem neuen Web werden zwei Seiten, index.htm und Spain.htm, erstellt.

Private Sub AddCompleteWeb()
Dim myNewWeb As Web
Dim myFiles As WebFiles
Dim myUrl As String
Dim myFileOne As String

Set myNewWeb = _
    Webs.Add("C:\My Webs\Rogue Cellars\Wines Around the World")
Set myFiles = myNewWeb.RootFolder.Files
myFileUrl = _
    "C:\My Webs\Rogue Cellars\Wines Around the World\index.htm"

myFiles.Add(myFileUrl)
myFileOne = "C:\My Webs\Rogue Cellars\Wines Around the World\"
myFileOne = myFileOne & "Spain.htm"
myFiles.Add myFileOne
Call myNewWeb.HomeNavigationNode.Children.Add(myFileOne, "Spain", _
    fpStructLeftmostChild)
myNewWeb.ApplyNavigationStructure

End Sub

Beachten Sie besonders die letzte fettgedruckte Anweisung; mit dieser Methode werden die Änderungen zugewiesen, die Sie an der Navigationsstruktur vorgenommen haben.

In Verbindung mit der Add-Methode für die Children-Eigenschaft können Sie verschiedene Konstanten verwenden, und zwar fpStructBaseOnSibling, fpStructLeftmostChild sowie fpStructRightmostChild. Diese Konstanten informieren FrontPage ganz einfach, welche Position die Datei in der Navigationsstruktur einnehmen soll, und zwar links, rechts oder eine Position basierend auf einer der gleichgeordneten Dateien. In diesem Beispiel wird myFileOne zur äußersten links positionierten, untergeordneten Seite der Homepage. Der nächste Schritt besteht im Hinzufügen der nächsten Seite, daher können Sie die Navigationsstruktur in der Navigationsansicht anzeigen. Mit der folgenden, fettgedruckten Anweisung wird dem Web aus dem vorherigen Beispiel eine weitere Seite sowie ein Navigationsknoten hinzugefügt.

Private Sub Add()
Dim myNewWeb As Web
Dim myFiles As WebFiles
Dim myFileUrl As String
Dim myFileOne As String
Dim myFileTwo As String

Set myNewWeb = _
    Webs.Add("C:\My Webs\Rogue Cellars\Wines Around the World")
Set myFiles = myNewWeb.RootFolder.Files
myFileUrl = _
    "C:\My Webs\Rogue Cellars\Wines Around the World\index.htm"

myFiles.Add(myFileUrl)
myFileOne = "C:\My Webs\Rogue Cellars\Wines Around the World\"
myFileOne = myFileOne & "Spain.htm"
myFileTwo = "C:\My Webs\Rogue Cellars\Wines Around the World\"
myFileTwo = myFileTwo & "France.htm"

myFiles.Add myFileOne
myFiles.Add myFileTwo
Call myNewWeb.HomeNavigationNode.Children.Add(myFileOne, "Spain", _
    fpStructLeftmostChild)
Call myNewWeb.HomeNavigationNode.Children.Add(myFileOne, "Spain", _
    fpStructRightmostChild)

myNewWeb.ApplyNavigationStructure

End Sub

Auf diese Weise können Sie fortfahren, Ihrem Web Seiten und Navigationsknoten hinzuzufügen, bis das Web vollständig ist. Alternativ können Sie auch eine For-Schleife erstellen, mit der Sie das Web durchlaufen und die Anzahl der Seiten und Navigationsknoten hinzufügen, die Sie benötigen, um das Web zu vervollständigen. Im folgenden Beispiel werden einem neuen Web im Web „Rogue Cellars“ fünf Seiten und Navigationsknoten hinzufgefügt.

Anmerkung Das Erstellen, Verschieben oder Löschen von Dateien und Ordnern beim Versuch, die Navigationsstruktur zu ändern, kann dazu führen, dass einige Änderungen verloren gehen. Nehmen Sie daher zuerst die Änderungen an der Ordnerstruktur des Webs vor, ändern Sie dann die Navigationsstruktur, und weisen Sie dem Web abschließend die Navigationsstruktur zu.

Private Sub AddDesignerCrystalWeb()
Dim myWeb As Web
Dim myParentWeb As Web
Dim myFolders As WebFolders
Dim myFolder As WebFolder
Dim myFiles As WebFiles
Dim myNewFiles(4) As WebFiles
Dim myChildNode As NavigationNode
Dim myNewFilename As String
Dim myFileURL As String
Dim myCount As Integer
Dim myBaseURL As String
Dim myWebURL As String
Dim myInputMsg As String
Dim myExist As Boolean

Set myParentWeb = _
    Webs.Open ("C:/My Documents/My Webs/Rogue Cellars/")
myParentWeb.Activate

myBaseURL = "C:/My Documents/My Webs/Rogue Cellars/"
myWebURL = myBaseURL & "Rogue Cellars Designer Crystal"
myExist = False
myInputMsg = _
    "All files will have "".htm"" appended. Type a file name: "
Set myFolders = Webs(0).RootFolder.Folders

For Each myFolder In myFolders
    'Check to see if myWebURL already exists.
    If myFolder.IsWeb And myFolder.Url = myWebURL Then
        myExist = True
    End If
Next

'Create myWebURL if it doesn't exist.
If myExist = False Then Webs.Add(myWebURL).Activate
Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

'Create files.
For myCount = 0 To UBound(myNewFiles)
    myNewFilename = InputBox(myInputMsg)
    myFileURL = myWeb.Url & "/" & myNewFilename & ".htm"
    myFiles.Add myFileURL
    myFiles(myFileURL).Edit
Next

'Add to navigation structure.
For myCount = 0 To UBound(myNewFiles)
    'Check if the current page is index.htm, if so, skip it.
    If myFiles(myCount).Title = "index.htm" Then
        myCount = myCount + 1
    End If
    Set myChildNode = _
      myWeb.RootNavigationNode.Children(0)
    'Add navigation node to the current page.
    myChildNode.Children.Add myFiles(myCount).Url, _
        myFiles(myCount).Title, fpStructLeftmostChild
Next
myWeb.ApplyNavigationStructure
End Sub

Erstellen einer Website mit der MakeWeb-Methode

Wenn Sie bereits über einen Ordner verfügen, den Sie in ein Web umwandeln möchten, können Sie die MakeWeb-Methode mit einem WebFolder-Objekt verwenden, wie in nachstehender Prozedur gezeigt.

Anmerkung Bei dieser Prozedur wird davon ausgegangen, dass es sich bei Webs(0) um das Web „Rogue Cellars“ handelt und dass dieses einen Ordner mit Namen FolderOne enthält.

Private Sub MakeAWeb()
Dim myWeb As Web
Dim myFolder As WebFolder

Set myWeb = Webs(0)
myWeb.Activate
Set myFolder = ActiveWeb.RootFolder.Folders("FolderOne")
myFolder.MakeWeb
End Sub

Da FolderOne ein Unterweb von „Rogue Cellars“ ist, müssen Sie eine Navigationsstruktur erstellen.


Erforschen der Prozeduren in Microsoft FrontPage 2000

Dieses Hilfethema ist darauf ausgelegt, Benutzern, die zwar mit Microsoft FrontPage vertraut sind, jedoch noch keine Erfahrungen mit Microsoft Visual Basic für Applikationen gesammelt haben, die Hintergründe zu einigen der grundlegenden Konzepte zu vermitteln, die einer FrontPage-basierten Programmierumgebung zugrunde liegen. Beim Programmieren in FrontPage Visual Basic für Applikationen verfügen Sie über HTML-Tools in einer Microsoft Office-Programmierumgebung, in der Sie Prozeduren erstellen können, mit denen eine Aufgabe oder auch eine Abfolge von Aufgaben ausgeführt wird. So können Sie beispielsweise:

  • eine Prozedur erstellen, mit der Daten aus einer Microsoft Access-Datenbank abgerufen und diese Daten auf Ihrer Webseite angezeigt werden,

  • eine Microsoft PowerPoint-Präsentation für automatische Aktualisierungen über das Internet veröffentlichen,

  • eine Microsoft Excel-Tabelle automatisch anhand der Eingaben von Benutzern aktualisieren, die Ihre Website besuchen.

Klicken Sie auf einen Hyperlink in der nachstehenden Liste, um direkt zu dem entsprechenden Hilfethema zu gelangen.

Organisieren von Code für den modularen Einsatz

Arten von Prozeduren

Öffentliche und private Prozeduren

Arten von Prozeduraufrufen

Ereignisprozeduren und Argumente

Erstellen einer Tabelle in FrontPage basierend auf einer Access-Datenbank

Mehrere Projekte

Organisieren von Code für den modularen Einsatz

Visual Basic-Prozeduren bieten Entwicklern die Möglichkeit, Code für den modularen Einsatz zu organisieren. Anstatt die gleiche Taschenrechnerfunktion für jedes Programm immer wieder neu zu schreiben, können Sie dieses Codesegment (die Taschenrechnerfunktion) heranziehen und in ein allgemeines Programm kompilieren, auf das dann von vielen anderen Anwendungen aus zugegriffen werden kann. In Visual Basic wird ein Block mit Code von einer Prozedurüberschrift eingeleitet und mit einer Abschlussanweisung abgeschlossen, und zwar den Anweisungen Sub und End Sub.

Die grundlegende Syntax einer Prozedur in Visual Basic wird im nachstehenden Codebeispiel dargestellt.

[Private|Public|Static] Sub Prozedurname(Argumente)

Anweisungen

End Sub

Wenn Sie eines der vorliegenden Beispiele für einen kompletten Code (einen Codeblock) ausführen möchten, gehen Sie wie in den folgenden Schritten beschrieben vor:

  1. Öffnen Sie FrontPage, wählen Sie Makro aus dem Menü Extras, und klicken Sie dann auf Visual Basic Editor.

  2. Doppelklicken Sie im Fenster Projekt auf Microsoft_FrontPage (oder das aktuelle Projekt), und erweitern Sie den Ordner Module.

  3. Doppelklicken Sie auf Modul 1, um das Codefenster zu öffnen.

  4. Markieren Sie in der Dokumentation den Codeblock, den Sie ausführen möchten, und drücken Sie STRG+C, um den markierten Bereich zu kopieren. Klicken Sie auf der Windows-Taskleiste auf die Schaltfläche Microsoft Visual Basic – Microsoft FrontPage.

  5. Klicken Sie im Codefenster an eine beliebige Position, und drücken Sie STRG+V, um den Beispielcode einzufügen.

  6. Klicken Sie auf der Symbolleiste auf die Schaltfläche Sub/User Form ausführen.

Der Code wird automatisch gespeichert, wenn Sie den Visual Basic-Editor schließen. Weitere Informationen über Visual Basic finden Sie unter Understanding Objects, Properties, Methods, and Events in der Onlinedokumentation Visual Basic Conceptual Topics.

Arten von Prozeduren

FrontPage Visual Basic stellt zwei Arten von Prozeduren bereit, Sub-Prozeduren und Function-Prozeduren. Worin besteht nun der Unterschied? Mit Sub-Prozeduren wird ein Codeblock in Reaktion auf eine Ereignisprozedur, wie beispielsweise ein Mausklick oder ein Tastendruck, ausgeführt. Ihr Rückgabetyp lautet auf „Void“, d. h. Sie führen Aufgaben aus, mit denen keine Werte zurückgegeben werden. Aus diesem Grund können Sie aus einer Ereignisprozedur heraus keinen Wert zurückgeben.

Anmerkung Bei einer Sub-Prozedur kann es sich um eine Ereignisprozedur handeln, hiermit kann jedoch auch eine Aufgabe ausgeführt werden, ohne dass ein Wert zurückgegeben und auf ein Ereignis reagiert wird.

Mit der folgenden Prozedur wird die Versionsnummer von FrontPage aus dem aktiven Web abgerufen, jedoch wird die Versionsnummer nicht an irgendeine andere Prozedur zurückgegeben.

Sub DisplayVersion()
Dim myWeb As Web
Dim myVersion As String

myWeb = "FrontPage version number: " & ActiveWeb.Application.Version
End Sub

Mit einer Function-Prozedur werden ebenfalls Aufgaben durchgeführt, jedoch werden hiermit ein oder mehrere Werte als Argumente zurückgegeben. Im nachstehenden Codebeispiel wird die Versionsnummer von FrontPage an die Aufrufprozedur GetAppVersion zurückgegeben.

Function ReturnVersion(currAppVersion As Variant)
Dim varAppVersion As Variant
    varAppVersion = Application.Version
    ReturnVersion = varAppVersion
End Function

Die Variable ReturnVersion enthält nun die Versionsnummer von FrontPage. Um nun in der Aufrufprozedur auf diesen Wert zuzugreifen, können Sie Code ähnlich dem im nachstehenden Codebeispiel aufgeführten schreiben.

Sub GetAppVersion()
Dim myAppVersion As Variant

MsgBox "This version of FrontPage is version " _
    & ReturnVersion(myAppVersion)
End Sub

Alternativ können Sie den Ausdruck ReturnVersion(varDisplayAppVersion) einer Variablen zuweisen und die Variable anstelle des Funktionsaufrufs an die MessageBox-Anweisung (MsgBox) anhängen.

Sowohl Sub- als auch Function-Prozeduren können so aufgerufen werden, dass sie die entsprechenden Aufgaben aus anderen Modulen oder Prozeduren heraus ausführen, und zwar abhängig davon, ob die Prozeduren als Public- oder Private-Prozeduren deklariert sind.

Anmerkung Wenn Sie die vorherige Funktion in mehr als einem Modul verwenden möchten, setzen Sie den Code in den Deklarationsabschnitt der Prozedur Allgemein.

Als dritte Bezeichnung für Code in Visual Basic für Applikationen wird der Begriff Makro verwendet. Wie eine öffentliche („public“) Sub-Prozedur, die keine Argumente aufweist, kann ein Makro ggf. andere Sub- oder Function-Prozeduren aufrufen, es kann in Befehlsleisten übernommen und es können ihm Tastenkombinationen zugewiesen werden, oder es kann über das Dialogfeld Makro ausgeführt werden.

Öffentliche und private Prozeduren

In Visual Basic gibt es zwei Möglichkeiten, um auf eine Prozedur zuzugreifen. Standardmäßig sind Prozeduren öffentlich, d. h. sie können von jeder anderen Prozedur in jedem anderen Modul in Ihrer Anwendung aufgerufen werden. Wenn Sie beispielsweise bereits eine Prozedur geschrieben haben, mit der die Bilder auf einer Webseite anhand der Dateinamen aufgelistet werden, möchten Sie diese Prozedur möglicherweise als öffentlich („public“) deklarieren, damit Sie sie übergreifend für alle Ihre Websites verwenden können. Wenn Sie allerdings eine Prozedur geschrieben haben, mit der eine bestimmte Datenbank bearbeitet wird, möchten Sie vermutlich, dass diese Prozedur nur in dem Modul verfügbar ist, mit dem das Bearbeiten der Datenbank gesteuert wird; in diesem Fall können Sie die Prozedur als privat („private“) deklarieren. Auf Prozeduren, die als privat deklariert wurden, kann nur von anderen Prozeduren innerhalb des gleichen Moduls verwiesen werden. Die vorstehend aufgeführte Funktion wurde im folgenden Codebeispiel als öffentliche Funktion deklariert und kann daher modul- und projektübergreifend aufgerufen werden.

Public Function ReturnVersion(varCurrentAppVersion As Variant)
    statements
End Function

Demgegenüber sollte eine Prozedur, die zum Bearbeiten einer Datenbank verwendet wird, als privat deklariert werden.

Private Function EditCustomerName(strFirstName As String)
    statements
End Function

Arten von Prozeduraufrufen

Wie wird eine Prozedur programmgesteuert ausgeführt? Sie deklarieren sie auf die gleiche Weise, wie Sie auch ein Schlüsselwort wie beispielsweise Open verwenden. Mit der folgenden Prozedur wird die Funktion ReturnVersion aufgerufen. Sie enthält eine lokale Variable, MyVersion, für den Wert, der an die Prozedur übergeben wird.

Function TestCall(AppVersion As Variant)
Dim MyVersion As Variant
    ReturnVersion(MyVersion)
End Sub

Wenn keinerlei Informationen vorhanden sind, die von einer Prozedur an eine andere übergeben werden können, deklarieren Sie einfach den Namen der Prozedur, wie im nachstehenden Codebeispiel gezeigt.

Sub TestCall2()
    DisplayCompanySplashScreen
End Sub

Die Prozedur TestCall2 ruft eine andere Prozedur, DisplayCompanySplashScreen, auf, die weder Argumente aufweist noch irgendwelche Werte zurückgibt.

Ereignisprozeduren und Argumente

Wenn Sie möchten, dass in Fällen, in denen Sie normalerweise einen Wert an die Aufrufprozedur übergeben würden, das Ausführen von Code mithilfe eines Ereignisses, wie beispielsweise das Klicken auf eine Befehlsschaltfläche, ausgelöst wird, können Sie auch die Ergebnisse der Funktion ausführen, anstatt eine Variable zu übergeben. Wenn Sie den folgenden, fettgedruckten Code der Funktion ReturnVersion hinzufügen, wird die Anzeige der Versionsnummer der aktive Anwendung veranlasst.

Function ReturnVersion(varCurrentAppVersion As Variant)
Dim varAppVersion As Variant
    varAppVersion = Application.System.Version
    varCurrentAppVersion = varAppVersion
    DisplayMsgBox (varCurrentAppVersion)
End Function

Mit der im folgenden Codebeispiel verwendeten Funktion DisplayMsgBox wird der Inhalt der Variablen varCurrentAppVersion angezeigt, die von der Funktion ReturnVersion übergeben wurde.

Function DisplayMsgBox(varGotAppVersion As Variant)
Dim varDisplayAppVersion As Variant
    VarDisplayAppVersion = varGotAppVersion
    MsgBox "This application is version " _
        & varDisplayAppVersion

Nun kann mit einer Ereignisprozedur die Anzeige des Wertes veranlasst werden, der von der Funktion ReturnVersion übergeben wird.

Private Sub CommandButton1_Click()
Dim varThisAppVersion As Variant
    ReturnVersion (varThisAppVersion)
End Sub

Erstellen einer Tabelle in FrontPage basierend auf einer Access-Datenbank

In der folgenden Prozedur werden Objekte aus dem Page-Objektmodell und dem Web-Objektmodell kombiniert, um Daten aus einer geöffneten Microsoft Access-Datenbank abzurufen und diese in eine Tabelle auf einer FrontPage-basierten Webseite einzufügen. Die Prozedur ParseDBTable stellt die Parameter für die Funktion ParseAccessTable bereit, mit der die folgenden Funktionen zum Erstellen und Auffüllen der Tabelle aufgerufen werden:

  • AddDBTableToPage - erstellt eine neue Tabelle,

  • AddDBRow - fügt auf der Webseite eine Zeile ein,

  • AddMemo - ruft die Memos aus der Access-Datenbank ab, gibt diese als Textmarken am Fuß der Seite unterhalb der neuen Tabelle zurück und gibt den URL zur jeweilen Textmarke zurück.

Anmerkung Für dieses Beispiel wurde die Access-Datenbank Nordwind.mdb verwendet. Um dieses Beispiel ausführen zu können, müssen Sie im Visual Basic-Editor über Verweise auf die Microsoft DAO 3.6-Objektbibliothek und die Microsoft Access 9.0-Objektbibliothek verfügen. Darüber hinaus müssen Sie eine Access-Datenbank öffnen, bevor Sie das Beispiel ausführen, und Sie müssen dem aktiven Web eine leere temporäre Datei mit Namen tmp.htm hinzufügen. Wenn Sie eine andere Datenbank als Nordwind.mdb verwenden, müssen Sie den Datenbanknamen und die Tabelle in der Prozedur ParseDBTable angeben.

Function AddDBTableToPage(myPage As PageWindow, _
    myTableName As String, myFields As Integer)
Dim myTable As FPHTMLTable
Dim myHTMLString As String
Dim myCount As Integer

myHTMLString = "<table border=""2"" id=""myRecordSet_" & _
    myTableName & """>" & vbCrLf
myHTMLString = myHTMLString & "<tr>" & vbCrLf

For myCount = 1 To myFields
    myHTMLString = myHTMLString & "<td id=""myDBField_" & _
        myCount & """> </td>" & vbCrLf
Next myCount

myHTMLString = myHTMLString & "</tr>" & vbCrLf
myHTMLString = myHTMLString & "</table>" & vbCrLf

Call myPage.Document.body.insertAdjacentHTML("BeforeEnd", _
    myHTMLString)

End Function

Function AddDBRow(myDBTable As FPHTMLTable)
Dim myHTMLString As String
Dim myTableRow As FPHTMLTableRow

Set myTableRow = myDBTable.rows(0)

myHTMLString = myTableRow.outerHTML
Call myDBTable.insertAdjacentHTML("BeforeEnd", myHTMLString)

End Function

Function AddMemo(myCurrentPage As PageWindow, myDBMemo As String, _
    myBkMarkField As String, myIndex) As String
Dim myHTMLString As String
Dim myMemoBkMark As String
Dim myBookMark As FPHTMLAnchorElement

myMemoBkMark = myBkMarkField & "_" & myIndex
myHTMLString = "<a name=""" & myMemoBkMark & """> Memo #" & _
    myIndex & "</a>" & vbCrLf

'Add the bookmark to the page.
Call myCurrentPage.Document.body.insertAdjacentHTML("BeforeEnd", _
    myHTMLString)

Set myBookMark = myCurrentPage.Document.all(myMemoBkMark)

'Add the memo text to the page.
Call myCurrentPage.Document.body.insertAdjacentHTML("BeforeEnd", _
    myDBMemo)
AddMemo = "<a href=""#" & myBookMark.Name & """>"

End Function

Function ParseAccessTable(myDBName As String, myTableName As String)
'Access/DAO Declarations.
Dim myDBApp As Access.Application
Dim myRecordSet As DAO.recordset
Dim myDBField As DAO.Field

'FrontPage Page object model declarations.
Dim myPage As PageWindow
Dim myTable As FPHTMLTable
Dim myTableRow As FPHTMLTableRow
Dim myTableCell As FPHTMLTableCell

'Function declarations.
Dim myCount As Integer
Dim myFieldValue As String
Dim myRecordCount As Integer
myRecordCount = 0

'Function constants.
Const myTempPage = "tmp.htm"

'Get the current Access database.
On Error GoTo AccessNotThereYet
    Set myDBApp = GetObject(, "Access.Application")

'Get the database table.
On Error Resume Next
Set myRecordSet = myDBApp.CurrentDb.OpenRecordset(myTableName)

'Add a new page to the current web.
Set myPage = ActiveWeb.LocatePage(myTempPage)
myPage.SaveAs myTableName & ".htm"

'Delete the temporary file from web.
ActiveWeb.LocatePage(myTempPage).File.Delete

'Add a database-ready table to the page with the proper number of fields.
AddDBTableToPage myPage, myTableName, myRecordSet.Fields.Count

'Get a reference to the table.
Set myTable = myPage.Document.all.tags("table").Item(0)

'Populate the first row.
For myCount = 0 To myRecordSet.Fields.Count - 1
    myTable.rows(0).cells(myCount).innerHTML = "<b>" & _
        Trim(myRecordSet.Fields(myCount).Name) & "</b>"
Next

'Populate the rest of the table.
While Not (myRecordSet.EOF)

    AddDBRow myTable
    Set myTableRow = myTable.rows(myTable.rows.Length - 1)

    For myCount = 0 To myRecordSet.Fields.Count - 1
        Set myTableCell = myTableRow.cells(myCount)

        If IsNull(myRecordSet.Fields(myCount)) Then
            myFieldValue = "None"
        Else
            myFieldValue = Trim(myRecordSet.Fields(myCount).Value)
        End If

        If myRecordSet.Fields(myCount).Type = DAO.dbMemo Then
            myFieldValue = AddMemo(myPage, _
                myRecordSet.Fields(myCount).Value, _
                myRecordSet.Fields(myCount).Name, myRecordCount)
        End If

        myTableCell.innerHTML = myFieldValue

    Next myCount
    myRecordSet.MoveNext
    myRecordCount = myRecordCount + 1
Wend

myPage.Save
myDBApp.Quit
Exit Function

AccessNotThereYet:
    Debug.Print Err.Number & ":" & Err.Description
    Resume

End Function

Private Sub ParseDBTable()
Call ParseAccessTable("Northwind.mdb", "Products")
End Sub

Mehrere Projekte

Mehrere Projekte werden in FrontPage nicht unterstützt. Sie können Microsoft Office Developer (ODE) installieren, um die Flexibilität des Visual Basic-Editors zu erhöhen. ODE bietet Möglichkeiten zum Erstellen mehrerer Projekte, zum Kompilieren von DLLs und zum effektiveren Verwalten von Visual Basic-Projekten.


Freigeben von Microsoft FrontPage-Programmierprojekten

Microsoft FrontPage bietet nicht die Möglichkeit zum Erstellen mehrerer Projekte, daher mag das Freigeben eines Projekts auf den ersten Blick etwas verwirrend erscheinen. Sie können Microsoft FrontPage-Projekte freigeben, indem Sie eine der folgenden drei Methoden verwenden:

  • Als ein COMAddIn.

  • Indem Sie die Module mit den Erweiterungen .bas, .cls und .frm in ein Verzeichnis auf Ihrer Festplatte (oder an einer Speicheradresse auf einem Server) exportieren. Die Benutzer können dann die Module in ihre Projekte in FrontPage importieren.

  • Indem Sie Microsoft Office Developer Edition zum Öffnen des Projekts verwenden.

Freigeben als ein COMAddIn

Eine detaillierte Beschreibung der Vorgehensweise zum Entwickeln eines COMAddIns finden Sie im Kapitel „Add-Ins, Vorlagen, Assistenten, und Bibliotheken“ im Microsoft Office 2000 Visual Basic Programmer's Guide.

Freigeben durch Exportieren des Projekts

Sie können die Module aus dem Visual Basic Editor exportieren, indem Sie die Module im Fenster Projekt markieren und dann im Menü Datei auf Datei exportieren zeigen. Geben Sie im Dialogfeld Datei exportieren das Verzeichnis an, in das die Dateien exportiert werden sollen, und FrontPage erledigt alles Weitere.

Anmerkung Beim Exportieren von UserForm-Dateien müssen Sie auch Dateien mit der Erweiterung .frx einschließen. Diese Datei wird während des Importvorgangs benötigt und muss nicht importiert werden, sie muss sich jedoch im gleichen Verzeichnis befinden wie die anderen Module.

Freigeben unter Verwendung von Office Developer Edition

Mit Office Developer Edition werden dem Menü Datei von Visual Basic Editor die Befehle Neues Projekt und Erstellen hinzugefügt. Hiermit wird Ihnen ermöglicht, in Visual Basic Editor mehrere Projekte zu erstellen. Mithilfe des Befehls Erstellen können Sie ein Projekt kompilieren und so eine Datei vom Typ .dll erstellen, die gemeinsam mit anderen Personen genutzt werden kann.


Grundlegendes zu absoluten und relativen URLs in FrontPage 2000

Microsoft FrontPage verwendet die Adressierung mit absoluten URLs. Allerdings bietet FrontPage auch eine Möglichkeit zum Ändern der Adressierung von URLs von relativ auf absolut und umgekehrt über die Methoden MakeRel und MakeAbs.

Was ist ein absoluter URL?

Mit einem URL wird die Speicheradresse eines Objekts definiert. Wenn ein URL absolut ist, definiert er ganz eindeutig, wo sich das Objekt befindet. Beispielsweise ist http://www.microsoft.com/FrontPage/default.htm die exakte Adresse der Begrüßungsseite des Microsoft FrontPage-Webs. Das Objekt, default.htm, ist im Ordner oder Unterweb FrontPage auf dem Webserver www.microsoft.com gespeichert.

Ein festplattenbasiertes Web, d. h. ein Web, bei dem sich die zugehörigen Komponenten auf der Festplatte befinden, kann über einen absoluten Basis-URL wie beispielsweise file:C:/Eigene Dateien/Eigene Webs oder C:/WINNT/Profiles/Ihr Logon-Alias/Personal/Eigene Webs/index.htm verfügen.

Wenn Websites aktualisiert werden und die Struktur eines Webs weiterentwickelt wird, kommt es häufig vor, dass Dokumente von einer Speicherposition im Web an eine andere verschoben werden. Wenn Sie eine relative Adresse verwenden, können hierbei Hyperlinks unterbrochen werden. Wenn Sie beispielsweise über ein Dokument verfügen, das einen Hyperlink zu einem Objekt enthält, können Sie einen absoluten URL verwenden, um sicherzustellen, dass der Hyperlink immer auf dieses Objekt verweist. So kann ein Dokument wie file:C:/Eigene Dateien/Eigene Webs/MeinDokument.htm beispielsweise einen absoluten URL enthalten, der auf die Begrüßungsseite http://www.microsoft.com/FrontPage/default.htm verweist. Wenn nun das Dokument default.htm an einen anderen Speicherort verschoben wird, verweist der absolute URL des Dokuments immer noch auf das Objekt auf dem Webserver an www.microsoft.com im Unterweb FrontPage. Wenn es sich bei dem URL für den Hyperlink zu default.htm um eine relative Adresse handelt, könnte der Hyperlink unterbrochen werden, wenn MeinDokument.htm in ein anderes Unterweb oder Hauptweb verschoben wird.

Was ist ein relativer URL?

Anstatt jeden Teil eines URLs anzugeben, mit dem vollständig definiert wird, wie ein Objekt zu finden ist, können Sie einen URL auch abkürzen, um ihn als „relativ“ zur aktuellen Speicheradresse festzulegen. Relative URLs werden normalerweise bei der Erstellung einer Website verwendet, bei der sich die hierin befindlichen Seiten auf andere Seiten in der Site beziehen. Eine Seite wie beispielsweise file:C:/Eigene Dateien/Eigene Webs/MeinDokument.htm kann über einen relativen URL zu NeuesDokument.htm oder zu ../Eigene Webs2/default.htm verfügen. In diesen beiden Fällen lauten die Adressen der Dateien, auf die verwiesen wird, file:C:/Eigene Dateien/Eigene Webs/NeuesDokument.htm und file:C:/Eigene Dateien/Eigene Webs2/default.htm. Beachten Sie, dass in der relativen Adresse weder der vollständige Pfad zum Webserver noch explizit ein Verzeichnis angegeben wird, die Adresse basiert auf der Speicherposition, an der sich das Dokument befindet.

Relative URLs sind äußerst nützlich, insbesondere, wenn eine Site an einem Ort erstellt und anschließend an einem anderen Ort veröffentlicht wird. So geben Sie beispielsweise während des Bearbeitens einer Webseite keinen Servernamen an, da sich der Servername ändert, wenn das Web veröffentlicht wird.

Wie kann aus einem absoluten URL ein relativer URL gemacht werden?

URLs können entweder relativ zu einem Server oder zu einer Seite angegeben werden. Wenn Sie einen URL relativ zu einem Ordner oder einem Web festlegen möchten, müssen Sie den URL entweder relativ zu einem Server oder relativ zu einer Seite angeben, da FrontPage den URL so behandelt, als wäre er relativ zu einer Seite in diesem Ordner oder Web festgelegt worden. Jeder relative URL ergibt in Kombination mit seinem Basis-URL die vollständige Speicheradresse des Objekts.

Wenn Sie über eine absolute Adresse wie beispielsweise http://www.microsoft.com/MeinWeb mit einer Bilddatei namens MeinBild.gif verfügen, die sich im Ordner Images des Webs befindet, können Sie einen relativen URL für diese Adresse erstellen, indem Sie entscheiden, ob sich die relative Adresse auf den Server oder eine Seite beziehen soll. Bei einem URL, der relativ zu einem Server ist, verwenden Sie also MeinWeb/Images/MeinBild.gif; mit dem Servernamen als Basis des relativen URLs definiert diese relative Adresse vollständig die Speicherposition des Objekts. Bei einem URL, der relativ zu einer Seite ist, verwenden Sie Images/MeinBild.gif; mit dem Servernamen und dem Webnamen als Basis des relativen URLs definiert diese relative Adresse vollständig die Speicherposition des Objekts. Bei einem URL, der relativ zu einem Ordner ist, verwenden Sie MeinBild.gif; mit dem Servernamen, dem Webnamen und dem Ordnernamen als Basis des relativen URLs definiert diese relative Adresse vollständig die Speicherposition des Objekts.

Ein URL, der relativ zu einem Ordner ist, kann auch von einem anderen Ordner aus angegeben werden; beispielsweise können Sie ../Images/MeinBild.gif verwenden, wenn sich das Dokument, das den Verweis aufweist, in einem anderen Ordner der obersten Ebene im gleichen Web und auf dem gleichen Server befindet. Die Schreibweise „..“ wird verwendet, um anzugeben, dass als Basis-URL die nächsthöhere Ordnerebene von der aktuellen URL-Adresse aus gesehen gilt.

Programmgesteuerter Zugriff auf relative URLs

Nachdem Sie sich entschieden haben, ob URLs relativ zum Server, zum Web oder zum Ordner angegeben werden sollen, können Sie bestimmen, welche Objekte zu verwenden sind. Bei URLs, die relativ zum Server oder zum Web sind, arbeiten Sie mit Methoden, die sich auf das Web-Objekt beziehen. Bei URLs, die relativ zum Ordner sind, arbeiten Sie mit Methoden, die sich auf das WebFolder-Objekt beziehen.

Umwandeln von relativen und absoluten URLs

In FrontPage empfiehlt sich die absolute Adressierung. Wenn Sie jedoch in FrontPage bereits einen relativen URL angegeben haben, können Sie die MakeAbs-Methode verwenden, um diesen in einen absoluten URL umzuwandeln. Ebenso können Sie, wenn Sie über einen absoluten URL verfügen und in ein Dokument einen Verweis als relativen URL einfügen möchten, diese Adresse mithilfe der MakeRel-Methode in eine relative Adresse umwandeln. Sie können die Methoden MakeAbs und MakeRel auch verwenden, um einen Hyperlink für ein Web-, WebFolder-, WebFile-, NavigationNode- oder IHTMLDocument2-Objekt umzuwandeln.


Erforschen des FrontPage-Objektmodells

Das Objektmodell in Microsoft FrontPage setzt sich aus drei separaten Objektmodellen zusammen, und zwar dem Application-Objektmodell, dem Web-Objektmodell und dem Page-Objektmodell, das auf dem Document-Objektmodell von Microsoft Internet Explorer 4.0 basiert.

Diese Objektmodelle sind darauf ausgelegt, Webdesigner mit einer umfassenden Sammlung von Programmierschnittstellen für das Verwalten einzelner HTML-Dokumente und FrontPage-basierter Webs auszustatten. Die Objektmodelle entsprechen den Objektmodellen anderer Microsoft Office-Anwendungen so genau wie möglich, damit die Benutzer die Erfahrungen und Kenntnisse nutzen können, die sie aktuell bereits mit anderen programmierbaren Office-Anwendungen gewonnen haben. Darüber hinaus ist das Page-Objektmodell mit dem Document-Objektmodell von Microsoft Internet Explorer, Version 4.0 und höher, kompatibel. Das Page-Objektmodell ist so gestaltet, dass auch Webentwickler, die Dynamic HTML mithilfe von Skripts programmieren, ihre bis dato gewonnenen Erfahrungen und Kenntnisse nutzen können.

Unterschiede in den programmierbaren Schnittstellen

FrontPage 2000 ermöglicht dem Benutzer den Vergleich zwischen Entwurfszeitansicht und Laufzeitansicht, da HTML-Seiten normalerweise in einem Browser und nicht in FrontPage betrachtet werden. Andere Office-Anwendungen bieten dem Benutzer lediglich eine Laufzeitansicht, die eine Umgebung umfasst, in der ein Entwickler benutzerspezifische Lösungen erstellen kann, die innerhalb der Anwendung ausgeführt werden. Mit FrontPage 2000 können Sie Dienstprogramme für den Einsatz in der Entwurfsphase des HTML-Dokuments oder der Website erstellen. Nachdem Sie Ihre Webseite entworfen und aufgebaut haben, können Sie mit VBScript, JScript und DHTML interaktive Effekte für den Einsatz während der Laufzeit erstellen, wenn die Seite in einem Browser angezeigt wird.

Funktionalität des Application-Objektmodells

Das Application-Objekt ist das Objekt der obersten Ebene in der Web-Objektmodellhierarchie und ermöglicht den Zugriff auf alle Objekte in FrontPage, wie beispielsweise auf ein aktives Web und eine aktive Seite sowie auf Add-Ins, Befehlsleisten, System, Webs und Web.

Funktionalität und Beschränkungen des Page-Objektmodells in FrontPage

Das Page-Objektmodell verfügt über die gesamte Funktionalität des Document-Objektmodells von Internet Explorer mit Ausnahme der im Vorfeld sowie in den folgenden Hilfethemen beschriebenen Beschränkungen.

HTML-Ereignisse, die von FrontPage 2000 nicht unterstützt werden

HTML-Methoden, die von FrontPage 2000 nicht unterstützt werden

HTML-Eigenschaften, die von FrontPage 2000 nicht unterstützt werden

Funktionalität des Web-Objektmodells

Das Web-Objektmodell ermöglicht die programmgesteuerte Verwaltung einer Vielzahl von FrontPage-basierten Websites und deren Inhalten. Dieses Objektmodell basiert auf Konventionen, die von der Microsoft Office-Anwendungssuite und Microsoft Visual Basic für Applikationen verwendet werden. Das Web-Objektmodell bietet darüber hinaus auch Unterstützung für Microsoft Visual SourceSafe, wenn über FrontPage hierauf zugegriffen wird.

Interaktion zwischen den Objektmodellen

Bei einem Großteil der Programmierung für FrontPage-basierte Webs wird mit einer Kombination aus Programmierelementen des Web- und des Page-Objektmodells gearbeitet. Weitere Informationen sowie Beispiele hierzu erhalten Sie, wenn Sie auf ein Hilfethema in der nachstehenden Liste klicken.

Zugreifen auf Framesets mit Microsoft Visual Basic

Programmgesteuertes Ändern von Seiten

Programmieren von dynamischen Elementen in FrontPage 2000


Zugreifen auf FrontPage-Framesets mit Microsoft Visual Basic

Frames stellen bei der Gestaltung eines Webs ein wichtiges Element dar. FrontPage 2000 bietet Unterstützung beim Programmieren des Inhalts von Frames. Klicken Sie auf einen der folgenden Hyperlinks, wenn Sie weitere Informationen über ein bestimmtes Thema erhalten möchten.

Grundlegendes zu Frames

Die Funktion eines Framesets

Zugreifen auf HTML-Tags

Dynamische Framequellen

Durchlaufen aller Frames in einem PageWindow

Ändern von Inhaltstyp-Metatags in einen anderen Zeichensatz

Grundlegendes zu Frames

Der Zugriff auf Frames innerhalb eines Framesets in FrontPage ist relativ einfach, solange Sie sich vor Augen halten, dass jeder Frame auf seine eigene Seite zugreift und dass Sie auf den Inhalt jeder Seite über ein Page-Objektmodell-Objekt zugreifen. Die beiden Fenster, die beim Anzeigen von Frames zum Einsatz kommen, sind ein PageWindow-Objekt und ein FPHTMLWindow2-Objekt. Der entsprechende Ausdruck für den Zugriff auf den Inhalt des mit dem aktiven Frame verbundenen Fensters ist Set myActiveFrameInFrameset = ActivePageWindow.Document. Mit dem ActivePageWindow-Objekt wird auf das Seitenfenster des Frames zugegriffen, und mit dem Document-Objekt wird auf das FPHTMLWindow2-Objekt zugegriffen.

Anmerkung Möglicherweise erhalten Sie Fehlermeldungen wie „Zugriff verweigert“, wenn Sie versuchen, auf Objekte zuzugreifen, während Sie sich in der HTML-Ansicht befinden. Wenn Sie einem Document-Objekt Code oder Text hinzufügen möchten, müssen Sie die FpPageViewMode-Konstante für die ViewMode-Eigenschaft auf fpPageViewNormal festgelegt haben. Der Wert für Ansichtsmodus darf nicht auf fpPageViewHtml oder fpPageViewPreview festgelegt werden. Ebenso darf auf der Benutzeroberfläche (User Interface - UI) nicht die Registerkarte HTML oder die Registerkarte Vorschau in der Seitenansicht von FrontPage geöffnet sein.

Funktion eines Framesets

Ein Frameset ist der Container für alle Frames in einem Webfenster. Jeder Frame befindet sich in einem eigenen Seitenfenster und hat eine eigene, ihm zugewiesene Seite. Durch den Zugriff auf das FrameWindow-Objekt über das Web-Objektmodell, können Sie auf ein FPHTMLWindow2-Objekt zugreifen, das das Framesseitendokument enthält. Mit diesen Objekten können Sie auf die Fenster, Dokumente und Frames des Framesets zugreifen. In der folgenden Aussage ist myFrameset ein FPHTMLWindow2-Objekt, das die Framesseite zurückgibt. Mit diesem Objekt können Sie auf die <frame>- und <frameset>-Tags oder die Window- oder Document-Objekte zugreifen.

Set myFrameset = ActivePageWindow.FrameWindow

Mit dieser Anweisung wird ein FPHTMLWindow2-Objekt über das Page-Objektmodell zurückgegeben. Mit der Document-Eigenschaft von myFrameset wird auf das Page-Objektmodell der Seite zugegriffen, was gleichbedeutend mit einem Zugriff auf die Registerkarte HTML der Framesseite in der Seitenansicht von FrontPage ist.

Anmerkung Die Registerkarten HTML der Framesseite und Ohne Frames sind nur verfügbar, wenn sich Frames auf der aktuellen Seite befinden.

Zugreifen auf HTML-Tags

Sie können auf die gleichen Informationen zugreifen, auf die auch ein Frames-Tag zugreift, indem Sie ein Objekt als FPHTMLFrameElement deklarieren. Nachstehend einige der Eigenschaften und Methoden, die für dieses Objekt zur Verfügung stehen: border, borderColor, click, frameBorder, frameSpacing, innerHTML, innerText, insertAdjecentHTML und insertAdjacentText.

Dim myFramesElements() As FPHTMLFrameElement

Sie können auf die Informationen eines Frameset-Tags zugreifen, indem Sie ein Objekt als FPHTMLFramesetSite-Objekt deklarieren.

Dim myFramesetSite As FPHTMLFramesetSite

Dynamische Framequellen

Sie können die Framequelle im HTML-Code dynamisch ändern, indem Sie die folgenden Anweisungen verwenden. Mit diesem Code wird als Framequelle ein neuer URL, Inventory_1stQuarter.htm, festgelegt.

Dim myDoc As Object

Set myDoc = ActivePageWindow.FrameWindow.Document

myDoc.all.tags("frame").Item(0).src = _
    "Inventory_1stQuarter.htm"

Durchlaufen aller Frames in einem PageWindow

Wenn Sie auf die Eigenschaften der Frameset-Elemente zugreifen möchten, die sich auf einer speziellen Framesseite befinden, müssen Sie über die Document-Eigenschaft auf das FPHTMLDocument-Objekt zugreifen. Im folgenden Beispiel werden das Frameset und die Frame-Elemente des aktiven Framesets in FrontPage durchlaufen. Das Frameset-Array (myFSElements) enthält jedes <FRAMESET>-Tag auf der Framesseite. Das Frames-Array (myFramesElements) beinhaltet jedes <FRAME>-Tag auf der Framesseite. Das Framefenster-Array (myFramesWindows) enthält jedes FPHTMLWindow2-Objekt, das auf jeden Frame verweist. Sie füllen jedes der Arrays auf, indem Sie die dazugehörigen Tags oder Objekte durchlaufen. Nachdem die Arrays aufgefüllt wurden, ändern Sie die frameSpacing-Eigenschaft im Frameset-Element auf „10“, die borderColor-Eigenschaft auf „rot“, und ändern Sie verschiedene andere Eigenschaften im Dokument.

Private Sub AccessFramesPage()
Dim myFPWindow As FPHTMLWindow2
Dim myFSElements() As IHTMLFrameSetElement
Dim myFramesWindows() As FPHTMLWindow2
Dim myFramesElements() As FPHTMLFrameElement
Dim myStyle As FPHTMLStyle
Dim i As Integer

Set myFPWindow = ActivePageWindow.FrameWindow
ReDim myFSElements(myFPWindow.Document.all.tags("FRAMESET").length)
ReDim myFramesElements(myFPWindow.Document.all.tags("FRAME").length)
ReDim myFramesWindows(myFPWindow.frames.length)

For i = 0 To UBound(myFSElements)
    Set myFSElements(i) = _
        myFPWindow.Document.all.tags("FRAMESET").Item(i)
Next i

i = 0
For i = 0 To UBound(myFramesWindows)
    Set myFramesWindows(i) = myFPWindow.frames(i)
Next i

i = 0
For i = 0 To UBound(myFramesElements)
    Set myFramesElements(i) = _
        myFPWindow.Document.all.tags("FRAME").Item(i)
Next i

myFSElements(0).frameSpacing = "10"
myFramesElements(0).borderColor = "red"

With myFramesWindows(2).Document
    .bgColor = "green"
    .body.innerHTML = "<p id=""cool""> Added by FP Programmability"
    Set myStyle = .all.cool.style
        myStyle.backgroundColor = "white"
        myStyle.display = False
        myStyle.textDecorationUnderline = True
        myStyle.Font = "Tahoma, 24"
        myStyle.fontStyle = "italic"
End With
End Sub

Ändern von Inhaltstyp-Metatags in einen anderen Zeichensatz

Sie können die gesamten Inhaltstyp-Metatags in einen anderen Zeichensatz (Zentraleuropäisch) ändern, wie im folgenden Codebeispiel gezeigt. Der aktuelle Zeichensatz wird im Dialogfeld Sprache (verfügbar für Seiteneigenschaften) angezeigt.

Anmerkung Das gesamte Inhaltstyp-Metatag enthält eine Zeichenfolge ähnlich der folgenden:

content = "text/html; charset = windows-1252

Als Zeichensatz wird „windows-1252“, also der Standardzeichensatz für Englisch (USA) verwendet.

Jedes Mal, wenn das Programm die Schleife durchläuft, greifen Sie auf den nächsten Frame im frameWindow-Objekt zu, was mit dem Zugriff auf jedes Frames-Tag in HTML in Folge vergleichbar ist. Die Frames-Auflistung unterstützt jedoch keine For..each-Konstruktion. Sie können auf die META-Tags vom Typ HTTP-EQUIV nicht über ihren Namen zugreifen, sondern Sie müssen einen Index verwenden, wie im folgenden Beispiel. Mit dem mit myContentType.Content beginnenden Ausdruck wird der Zeichensatz auf „Zentraleuropäisch“ gesetzt.

Anmerkung FrontPage setzt den Inhaltstyp im META-Tag auf Null.

Private Sub ChangeCharSet()
Dim myFrames As IHTMLFramesCollection2
Dim myFrame As FPHTMLWindow2
Dim myHTTPEquiv As String
Dim myContentType As Object
Dim myCount As Integer

Set myFrames = ActivePageWindow.FrameWindow.frames
Set myFrame = ActivePageWindow.FrameWindow.frames(0)
myHTTPEquiv = 0

For myCount = 0 To myFrames.Length - 1
    Set myFrame = myFrames(myCount)
    Set myContentType = _
        myFrame.Document.all.tags("meta").Item(myHTTPEquiv)
    myContentType.content = _
        "text/html; charset=iso-8859-2"
Next myCount
End Sub


Zugreifen auf das FrontPage-Objektmodell über Entwurfszeit-Steuerelemente

Ein Entwurfszeit-Steuerelement (Design-time Control - DTC) gehört zu einer Klasse von ActiveX-Steuerelementen, die ausschließlich zur Entwurfszeit als Hilfe beim Erstellen von Webinhalten zum Einsatz kommen. DTCs funktionieren genau wie eingebundene Assistenten, können also bearbeitet werden, um die Ausgabe zu ändern, die seitens eines DTCs auf der Webseite erzeugt wird. Beim Schließen der Datei wird das DTC deaktiviert und der Text, den das DTC erzeugt hat, in die Datei eingebettet.

Inwiefern unterscheiden sich Entwurfszeit-Steuerelemente von ActiveX-Steuerelementen?

Entwurfszeit-Steuerelemente enthalten keine binäre Laufzeitkomponente, verfügen jedoch über eine spezielle Schnittstelle, die die Möglichkeit bietet, das Entwurfszeit-Steuerelement beizubehalten und Text zu erzeugen. Entwurfszeit-Steuerelemente und ActiveX-Steuerelemente können nebeneinander auf der gleichen Webseite existieren. Weitere Informationen zu DTCs finden Sie auf der Microsoft Workshop-Website in der Dokumentation zu Entwurfszeit-Steuerelementen.

Inwiefern unterscheiden sich Entwurfszeit-Steuerelemente von Visual InterDev?

FrontPage und Microsoft Visual InterDev sind in den meisten Bereichen kompatibel. Im Hinblick auf Entwurfszeitsteuerelemente bietet FrontPage umfassenden Zugriff auf das Document-Objektmodell, das in Microsoft Internet Explorer zur Verfügung steht. Das Web-Objektmodell steht für die Entwurfszeit-Steuerelemente ebenfalls zur Verfügung und stellt eine breite Palette an Objekten, Ereignissen, Methoden und Eigenschaften bereit. FrontPage bietet darüber hinaus auch Unterstützung beim Entfernen von Tags (oder Texten), die mithilfe eines Entwurfszeit-Steuerelements in ein Dokument eingefügt wurden.

Von FrontPage unterstützte Eigenschaften, die von Microsoft Visual InterDev nicht unterstützt werden:

  • Preview - gibt eine Zeichenfolge zurück, die den Vorschautext des Steuerelements enthält.

  • Tag - gibt den Tag-Kontext für die Vorschauzeichenfolge zurück.

In Visual InterDev integrierte Optionen, die von FrontPage nicht unterstützt werden:

  • Abfrage-Generator,

  • Datenverbindungen,

  • Visual InterDev-Objektmodell für ASP-Seiten.

So greifen Sie über ein Entwurfszeitsteuerelement auf das FrontPage-Objektmodell zu

Das Entwurfszeit-Steuerelement gehört zu den ActiveX-Steuerelementen und greift daher ähnlich wie andere Steuerelemente auf das Objektmodell seines Hosts zu (siehe FPHTMLObjectElement-Objekt). Das Entwurfszeit-Steuerelement verfügt über eine UserControl-Eigenschaft, die das UserControl-Objekt zurückgibt. Dieses Objekt wiederum verfügt über eine Extender-Eigenschaft, die die Umgebung zurückgibt, in der sich das ActiveX-Steuerelement befindet. Der Ausdruck UserControl.extender gibt die Umgebung des angegebenen DTCs zurück.

Die Extender-Eigenschaft gibt das FPHTMLObjectElement-Objekt zurück und bietet Zugriff auf alle Eigenschaften und Methoden im FPHTMLObjectElement-Objekt. Eine dieser Eigenschaften ist die Document-Eigenschaft, die auf das Page-Objektmodell des Dokuments zugreift, in dem sich das Entwurfszeit-Steuerelement befindet. In den folgenden Anweisungen wird dargestellt, wie über ein DTC auf die Document-Eigenschaft zugegriffen wird.

Dim myDTC As FPHTMLObjectElement
Dim myDoc As FPHTMLDocument
Dim myPageWindow As PageWindow

Set myDTC = UserControl.Extender
Set myDocument = myDTC.document
Set myPageWindow = myDoc.parentWindow.external

Die letzte Set-Anweisung zeigt, wie über das Page-Objektmodell auf das Web-Objektmodell zugegriffen wird.


Erstellen von Code in einer Umgebung ohne Fenster

In Microsoft FrontPage ist es möglich, eine Umgebung ohne Fenster zu erstellen, um den aus der Benutzeroberfläche (User Interface - UI) resultierenden Overhead zu minimieren, jedoch bringt die Arbeit in einer solchen Umgebung auch einige Nachteile mit sich. Beispielsweise wird beim Öffnen einer Seite nach fpPageViewNoWindow mit der ViewMode-Eigenschaft eine Umgebung ohne Fenster erzeugt, in der Fensterelemente, für die die UI benötigt wird, nicht korrekt funktionieren. Wenn Sie eine Seite ohne ein Fenster öffnen und versuchen, hierauf mit Code wie beispielsweise PageWindow.Document.ParentWindow zuzugreifen, gibt der hieraus resultierende Code nichts anstelle eines FPHTMLWindow2-Objekts zurück. Mit den folgenden Anweisungen erhalten Sie Zugriff auf Seiten ohne Fenster.

Application.LocatePage(DocumentUrl As String, _
    ViewMode As FpPageViewMode) As PageWindow
Web.LocatePage(DocumentUrl As String, ViewMode As FPPageViewMode) _
    As PageWindow
File.Edit(ViewMode As FpPageViewMode) As PageWindow

In der nachstehenden Tabelle werden die PageWindow-Methoden und -Eigenschaften sowie die Objekte oder Fehlermeldungen erläutert, die hiermit zurückgegeben werden. Einige der Methoden und Eigenschaften des PageWindow-Objekts sind in einer Umgebung ohne Fenster deaktiviert und geben die in der folgenden Tabelle dargestellten Ergebnisse zurück.

Deaktivierte Methode oder Eigenschaft des PageWindow-Objekts | Zurückgegebenes Objekt bzw. Fehlermeldung
ActiveDocument | Gibt die Fehlermeldung „object or with variable not set“ zurück.
ActiveFrameWindow | Gibt die Fehlermeldung „object or with variable not set“ zurück.
Caption | Gibt den URL des PageWindow-Objekts zurück.
Document | Gibt ein Document-Objekt zurück.
File
  • Gibt ein File-Objekt zurück.
ReadyState | Gibt den Bereitschafts-Status des Dokuments zurück.
ViewMode | Diese Eigenschaft kann nicht festgelegt werden. Sie gibt die Konstante fpViewModeNoWindow zurück.
Visible | Gibt False zurück.
Web Gibt das Web-Objekt zurück, wenn das Objekt mit einer der folgenden Anweisungen gefunden wurde.

Web.LocatePage

File.Edit
ApplyTheme | Gibt einen Laufzeitfehler zurück.
Close(ForceSave) | Schließt das Seitenfenster.
Refresh(ForceSave) | Aktualisiert das Seitenfenster.
Save(ForceOverwrite) | Speichert das Seitenfenster.
SaveAs(ForceOverwrite) | Speichert das Seitenfenster an einem neuen URL.


Programmgesteuertes Ändern von Seiten

In diesem Hilfethema wird dargestellt, wie mit den Document-Objektelementen innerhalb der Web-Objektmodellumgebung gearbeitet wird, und zwar entweder, um den Inhalt einer Seite zu ändern, oder um einfach zwecks Überprüfung auf den Inhalt einer Seite zuzugreifen.

Microsoft Visual Basic ist ein leistungsfähiges Werkzeug, das Sie zum Ändern von Inhalten in Webseiten verwenden können. Wenn Sie sich einmal näher mit dem Objektkatalog befassen, werden Sie viele gleichartige Komponenten entdecken, die Ihnen bereits aus Microsoft Internet Explorer bekannt sind.

Tipp Wenn Sie nur die Programmierelemente anzeigen möchten, die mit dem Page-Objektmodell von FrontPage kompatibel sind, wählen Sie im Objektkatalog FrontPageEditor als Objektbibliothek.

Sie können auf die HTML-Elemente einer Seite zugreifen, indem Sie die Eigenschaften ActiveDocument oder Document verwenden, die über das PageWindow-Objekt das Document-Objekt zurückgeben. Beispielsweise können Sie mit der folgenden Anweisung die Hintergrundfarbe der Seite im aktiven Seitenfenster ändern.

ActivePageWindow.Document.bgColor = "DarkBlue"

Im folgenden Beispiel wird das aktive Dokument auf das Vorhandensein eines bestimmten Hyperlinks (index.htm) hin geprüft. Wird der Hyperlink gefunden, endet die Prozedur, wird der Hyperlink nicht gefunden, prüft die Prozedur zuerst, ob das aktive Dokument den Namen index.htm trägt; falls nicht, wird der Hyperlink am Ende des Dokuments hinzugefügt.

Private Sub VerifyIndexLink()
Dim myDoc As FPHTMLDocument
Dim myLinks As Variant
Dim myLink As Variant
Dim myNumberOfLinks As Integer
Dim myAddLink As Boolean
Dim myLinkName As String
Dim myLinkName2 As String

Set myDoc = ActivePageWindow.Document
Set myLinks = myDoc.Links
myNumberOfLinks = myLinks.length
myLinkName = "index.htm"
myLinkName2 = """" & myLinkName & """"

For Each myLink In myLinks
    If myLink = myLinkName Then
        myAddLink = True
        Exit For
    End If
Next

If myAddLink = False And myDoc.nameProp <> "index" Then
    Call myDoc.body.insertAdjacentHTML("BeforeEnd", "<a href=" _
        & myLinkName2 & ">" & myLinkName & "</a>")
    ActivePageWindow.Save
End If
End Sub

Tipp Beachten Sie, dass das aktive Seitenfenster in der letzten If-Anweisung gespeichert wird, bevor die Prozedur endet. Diese Anweisung eignet sich gut für den Einsatz in Verbindung mit dem OnPageClose-Ereignis.


Verwenden von Aufzählungstypen in FrontPage

Verglichen mit anderen Microsoft Office-Anwendungen kommen in Microsoft FrontPage nur sehr wenige Konstanten zum Einsatz. Wenn Sie mehr über eine Konstante erfahren möchten, klicken Sie in der nachstehenden Tabelle darauf.

Konstante | Aufzählungskonstante
FpPageViewMode | fpPageViewDefault fpPageViewHtml fpPageViewNoFrames fpPageViewNormal fpPageViewNoWindow fpPageViewPreview
FpSharedBorders | fpBorderAll fpBorderBottom fpBorderLeft fpBorderRight fpBorderTop
FpStructModType | fpStructBaseOnSibling fpStructLeftmostChild fpStructRightmostChild
FpThemeProperties | fpThemeActiveGraphics fpThemeBackgroundImage fpThemeCSS fpThemeDefaultSettings fpThemeName fpThemeNoBackgroundImage fpThemeNoCSS fpThemeNormalColors fpThemeNormalGraphics fpThemePropertiesAll fpThemePropertiesNone fpThemeVividColors
FpWebDeleteFlags | fpDeleteEntireWeb fpDeleteFrontPageInfoFromWeb
FpWebPublishFlags | fpPublishAddToExistingWeb fpPublishCopySubwebs fpPublishIncremental fpPublishNone
FpWebViewMode | fpWebViewAllFiles fpWebViewBrokenLinks fpWebViewFolders fpWebViewLinks fpWebViewPage fpWebViewSiteSummary fpWebViewStructure fpWebViewTodo


Grundlegendes zu WebWindows und PageWindows

In Microsoft Internet Explorer stellt das Window-Objekt die oberste Ebene der Objekthierarchie dar. In Microsoft FrontPage hingegen ist das Application-Objekt die oberste Ebene der Objekthierarchie und das WebWindow-Objekt ein Objekt auf der dritten Stufe der Objekthierarchie, das zur WebWindows-Auflistung (zweite Stufe) gehört. Auf die Document-Eigenschaft wird über das PageWindow-Objekt zugegriffen (das zur PageWindows-Auflistung gehört), dessen übergeordnetes Objekt das WebWindow-Objekt ist. Die Objekthierarchie für die WebWindows-Auflistung wird im nachstehenden Diagramm gezeigt.

Was ist ein WebWindow-Objekt?

Das WebWindow-Objekt ist der Fenstercontainer des Webs. Wenn Sie ein Web in FrontPage öffnen, sehen Sie das Web in seinem „Web“-Fenster. FrontPage öffnet ein neues Fenster für jedes Web, das Sie öffnen.

Was ist ein PageWindow-Objekt?

Das PageWindow-Objekt ist der Container für die Webseite. Wenn Sie eine Seite in einem Webfenster öffnen, befindet sich diese Seite in einem Seitenfenster (ist im rechten Ausschnitt sichtbar). FrontPage öffnet ein neues Seitenfenster für jede Seite, die Sie öffnen; allerdings ist jedes PageWindow-Objekt im WebWindow-Objekt des individuellen Webs enthalten. Jede Seite, die Sie geöffnet haben, wird im Menü Fenster von FrontPage aufgeführt.

Wo passt das Document-Objekt hinein?

Das Document-Objekt enthält die HTML-Elemente einer Seite. Auf die Elemente des Dokuments kann mithilfe eines Ausdrucks wie ActivePageWindow.Document.Element zugegriffen werden, wobei Element für eines der in FrontPage verfügbaren HTML-Elemente steht.


Verwalten des Veröffentlichungsprozesses mit MetaTags

Automatisieren Sie das Veröffentlichen Ihres Webs mit einer Kombination aus Ereignissen wie beispielsweise OnBeforeWebPublishing und Metadaten, die Sie erhalten, indem Sie auf die Daten in der Properties-Auflistung zugreifen. Beispielsweise möchten Sie vor dem Veröffentlichen eines Webs möglicherweise die Metadaten für alle Seiten im Web prüfen. Um zu prüfen, ob Microsoft FrontPage alle Seiten Ihres Webs erzeugt hat, verwenden Sie den folgenden Code zusammen mit einer Ereignisbehandlungsroutine im Ereignis OnBeforeWebPublishing.

Private Sub CheckIfFP()
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myMetaTags As MetaTags
Dim myMetaTag As Variant

Set myFiles = ActiveWeb.RootFolder.Files

For Each myFile In myFiles
    Set myMetaTags = myFile.MetaTags
    'Check for any text files.
    If myMetaTags.Count = 0 And _
        myFile.Extension <> ".asa" Then
        MsgBox myFile.Name & " was not generated by FrontPage."
    End If
    'Check all web pages.
    For Each myMetaTag In myMetaTags
        If myMetaTag = "generator" Then
          If myFile.Properties("vti_generator") = _
            "Microsoft FrontPage 4.0" Then
            Exit For
          Else
            MsgBox myFile.Name & " was not generated by FrontPage."
          End If
        End If
    Next
Next
End Sub

Sie können vor dem Veröffentlichen auch den Wert des Eigenschaftsschlüssels vti_donotpublish prüfen. Wenn es sich bei dem Dokument um einen Entwurf oder um ein Dokument handelt, das nicht veröffentlicht werden soll, ist der Eigenschaftsschlüssel vti_donotpublish auf True festgelegt. Im folgenden Beispiel wird der Wert des Eigenschaftsschlüssels vti_donotpublish geprüft.

Dim myFiles As WebFiles
Dim myFile As WebFile

For Each myFile In myFiles
    If myFile.Properties("vti_donotpublish") = True Then
        MsgBox "Do not publish " & myFile.Name
    End If
Next

Der Eigenschaftsschlüssel vti_donotpublish kann verwendet werden, um die Veröffentlichung einer Datei zu verhindern. Nach Beendigung des Veröffentlichungsvorgangs wurde die entsprechende Datei nicht auf dem Server veröffentlicht. Im folgenden Beispiel wird die ersten Datei in der Files-Auflistung für die Veröffentlichung deaktiviert.

Sub PublishThisFile(myFileName As String, myStatus As Boolean)
Dim myFile As WebFile

Set myFile = ActiveWeb.LocateFile(myFileName)

Call myFile.Properties.Add("vti_donotpublish", Not (myStatus))
myFile.Properties.ApplyChanges
End Sub

Private Sub PublishFile()
PublishThisFile Activeweb.RootFolder.Files(0), False
End Sub


Programmieren von dynamischen Elementen in FrontPage 2000

Die Objekte, Methoden und Eigenschaften in Microsoft Internet Explorer sind normalerweise für den Laufzeiteinsatz vorgesehen. In Microsoft FrontPage sind die meisten dieser Elemente ausschließlich für die Entwurfszeit ausgelegt. Sie können einem vorhandenen Dokument programmgesteuert Inhalte hinzufügen, auf Markierungen auf einer Seite zugreifen, ein Skriptelement erstellen oder eine vorhandene Tabelle ändern. Klicken Sie auf einen der folgenden Hyperlinks, um direkt zu dem entsprechenden Thema zu gelangen.

Hinzufügen von Inhalten zu einem Dokument mithilfe von TextRange

Zugreifen auf eine Benutzerauswahl mithilfe von TextRange

Erstellen von Skriptelementen

Zugreifen auf Tabellen

Hinzufügen von Inhalten zu einem Dokument mithilfe von TextRange

Sie können einer Webseite programmgesteuert HTML-Inhalte hinzufügen, indem Sie ein Textbereichsobjekt (TextRange) erstellen und der Seite den neuen Inhalt wie im nachstehenden Beispiel gezeigt hinzufügen. Das Textbereichsobjekt wird aus dem Body-Objekt von myDocument erstellt. Wenn der Wert für myClearPage auf True festgelegt wird, wird der gesamte Inhalt zwischen den Tags <Body></Body> durch den neuen HTML-Inhalt ersetzt, andernfalls wird der neue Inhalt an den ursprünglichen Inhalt angehängt.

Public Function AddHTMLToPage(myDocument As Object, _
    myHTMLText As String, myClearPage As Boolean) As Boolean
Dim myRange As Object
Dim myBodyText As Object

On Error GoTo CannotAddHTML

'Create a TextRange object
If myClearPage Then
    Set myRange = _
        myDocument.all.tags("BODY").Item(0).createTextRange
    'Clear the current document
        Call myRange.pasteHTML("")
    myRange.collapse False
    Set myRange = Nothing
End If

Set myBodyText = myDocument.all.tags("BODY").Item(0)
myBodyText.innerHTML = myBodyText.innerHTML & myHTMLText & vbCrLf

AddHTMLToPage = True
Exit Function

CannotAddHTML:
AddHTMLToPage = False
End Function

Sub AddNewHTML()
Dim myHTMLString as String
Dim myBodyElement As Object

myHTMLString = "<B> <I> New Sale on Vintage Wines! </I> </B>" & vbCr

If AddHTMLToPage(ActivePageWindow.Document, myHTMLString, True) Then
    Set myBodyElement = _
      ActivePageWindow.Document.all.tags("BODY").Item(0)
End If
End Sub

Zugreifen auf eine Benutzerauswahl mithilfe von TextRange

Sie können das IHTMLTxtRange-Objekt verwenden, um HTML-Objekte zu markieren oder um eine Benutzerauswahl in einem angegebenen Dokument zu manipulieren. Im folgenden Beispiel wird der aktuellen Markierung eine Hintergrundfarbe zugewiesen.

Private Sub ApplyStyleToSelection()
Dim myRange As IHTMLTxtRange

Set myRange = ActiveDocument.selection.createRange

myRange.parentElement.style.backgroundColor = "SkyBlue"
End Sub

Hinzufügen von Skripts zu einer Seite

Die Skripterstellung in Visual Basic für FrontPage 2000 ist unproblematisch. Sie laden einfach das Skript in eine Zeichenfolgenvariable und hängen die Zeichenfolge an das <Head>-Tag der Seite an. (Auf das <Head>-Tag wird mithilfe eines IHTMLElement-Objekts zugegriffen.) Nachdem die Zeichenfolge der Seite hinzugefügt wurde, stellt diese ein gültiges Skriptelement dar, auf das über das FPHTMLScriptElement-Objekt zugegriffen und das hierüber geändert werden kann. Mit dem folgenden Code wird der aktuellen Seite ein Skriptelement hinzugefügt, es wird geprüft, dass das Skript hinzugefügt wurde, es wird eine Benutzerabfrage mit den Schaltflächen OK und Cancel hinzugefügt, und einige der Skriptelementeigenschaften werden anschließend im Fenster Direktbereich des Visual Basic Editors ausgegeben.

Private Sub CreateAScript()
Dim myScriptElement As FPHTMLScriptElement
Dim myHTag As IHTMLElement
Dim myBodyTag As IHTMLElement
Dim myBodyString As String
Dim myHTMLString As String
Dim myText As String

'Build a script tag construct.
myHTMLString = myHTMLString & "<script language=""VBScript"">" _
  & vbCrLf
myHTMLString = myHTMLString & "Function doOK" & vbCrLf
myHTMLString = myHTMLString & _
  "msgbox ""Please wait, an order form is being generated...""" & _
  vbCrLf
myHTMLString = myHTMLString & "End Function" & vbCrLf & vbCrLf
myHTMLString = myHTMLString & "Function doCancel" & vbCrLf
myHTMLString = myHTMLString & _
  "msgbox ""Exiting ordering process.""" & vbCrLf
myHTMLString = myHTMLString & "End Function" & vbCrLf
myHTMLString = myHTMLString & "</script>" & vbCrLf

'Build a call tag construct.
myBodyString = "<CENTER>" & vbCrLf
myBodyString = myBodyString & _
  "<BUTTON onclick=""doOK()"">OK</BUTTON>" & vbTab
myBodyString = myBodyString & _
  "<BUTTON onclick=""doCancel()"">Cancel</BUTTON>" & vbCrLf
myBodyString = myBodyString & "</CENTER>"

'Add text to the document
myText = "I'd like to order some vintage wines."

'Access the <HEAD> tag.
Set myHTag = ActivePageWindow.Document.all.tags("HEAD").Item(0)

'Append the script element to the <Head> tag(myHTag).
myHTag.innerHTML = myHTag.innerHTML & myHTMLString

'Verify that the script element was added.
If ActivePageWindow.Document.scripts.length = 1 Then
    'Access the script element just added.
    Set myScriptElement = ActivePageWindow.Document.scripts(0)

    'Print script element properties to the Immediate window.
    'JScript only: the next statement gets the FOR= attribute from
    'the JScript, otherwise an empty string prints in the Immediate
    'window.
    Debug.Print myScriptElement.htmlFor

    'Retrieve the content of the script.
    Debug.Print myScriptElement.outerHTML

    'Check scripting language.
    Debug.Print myScriptElement.language
End If

'Add a query to the user and call the script element.
ActiveDocument.body.insertAdjacentHTML "BeforeEnd", _
  "<B><I>" & myText & "</B></I><P>" & myBodyString
End Sub

Zugreifen auf Tabellen

Jeder, der in HTML bereits Tabellen erstellt und mit deren Inhalt gearbeitet hat, wird es einfach finden, mit Visual Basic auf Tabellen zuzugreifen. Mit dem folgenden Programm wird auf eine Tabelle auf der aktuellen Seite zugegriffen und eine Zelle in die Tabelle eingefügt.

Sub AccessTables()
Dim myTable As FPHTMLTable
Dim myRow As FPHTMLTableRow
Dim myCell As FPHTMLTableCell

'Get the table.
Set myTable = ActiveDocument.all.tags("TABLE").Item(0)

'Get the first row.
Set myRow = myTable.rows(0)
MsgBox myRow.cells.Length

'Get the first cell.
Set myCell = myRow.cells(0)
MsgBox myCell.Width

'Add a new cell to the first row.
Set myCell = myTable.rows(0).insertCell(myRow.cells.Length)
End Sub


Verwenden von Ereignissen zum Steuern von Aktionen in FrontPage 2000

In Microsoft FrontPage gibt es zwei Arten von Ereignissen, nämlich Ereignisse, die vom Application-Objektmodell aus gesteuert werden, und Ereignisse, die vom Page-Objektmodell aus gesteuert werden. Die Ereignisse für das Application-Objektmodell können verwendet werden, um zu steuern, unter welchen Bedingungen ein Web veröffentlicht wird, ob Sie eine Seite immer dann speichern möchten, wenn das OnPageClose-Ereignis ausgelöst wird oder ob Sie Formatvorlagen, Schriftarten oder Hintergründe immer dann festlegen möchten, wenn eine neue Seite erstellt wird. Um weitere Informationen zu den Ereignissen des Application-Objektmodells zu erhalten, klicken Sie auf eines der Ereignisse in der nachstehenden Liste.

OnAfterPageSave | OnPageNew
OnBeforePageSave | OnPageOpen
OnAfterWebPublish | OnWebClose
OnBeforeWebPublish | OnWebNew
OnPageClose | OnWebOpen

Im DHTML-Objektmodell von Microsoft Internet Explorer werden Ereignisbehandlungsroutinen mithilfe einer der folgenden Methoden erstellt:

  • Erstellen einer Prozedur oder einer Funktion in einem Skript-Tag,

  • Verwenden des Attributs FOR= in einem Skript-Tag,

  • Verwenden von FrontPage-Ereignisse und -Klassenmodulen.

Sie können eine Ereignisbehandlungsroutinen-Funktion deklarieren, indem Sie in einem Skript-Tag eine Prozedur oder eine Funktion erstellen und dann ein On*-Attribut definieren, mit dem diese Prozedur für das Element aufgerufen wird, das die Ereignisse generieren soll. Um beispielsweise einen Mausklick auf einem Anker „einzufangen“, könnten Sie den HTML-Code im folgenden Beispiel verwenden.

<html>
<head>
<script language="VBScript">
sub test
msgbox "You clicked"
End Sub
</script>
</head>
<body>
<a href="CatchMouse.htm" onclick="CatchMe"> This is an anchor, click here</a>
</body>
</html>

Eine weitere Möglichkeit zum Deklarieren von Ereignisbehandlungscode besteht darin, ein Skript-Tag mit einem FOR=-Attribut zu erstellen, wie im folgenden Beispiel gezeigt.

<SCRIPT FOR=myanchor EVENT=onclick LANGUAGE="VBScript">
msgbox "You Clicked"
</SCRIPT>
<a id="myanchor" href="CatchMouse.htm" onclick="CatchMe"> this is an anchor, click on it </a>

Allerdings erfolgt die Programmierung im FrontPage Page-Objektmodell mit Ereignissen und Objekten, die zwar mit Internet Explorer kompatibel, jedoch für den Einsatz zur Entwurfszeit vorgesehen sind. Um Ereignisse für die Laufzeit zu programmieren, können Sie die standardmäßigen Schlüsselwörter von Microsoft Visual Basic 5.0 ebenso verwenden, um auf die Ereignisse des Page-Objektmodells zuzugreifen, wie Sie hiermit auf die Ereignisse des Web-Objektmodells zugreifen. Diese Methode ist eine Kombination der beiden vorstehend beschriebenen Techniken. Im folgenden Beispiel wird das OnClick-Ereignis für einen Hyperlink in FrontPage „eingefangen“.

Fügen Sie in Visual Basic Editor ein Klassenmodul ein, und nennen Sie dieses CatchOnClick. Fügen Sie dem Klassenmodul folgenden Code hinzu.

Dim WithEvents eAnchor As FPHTMLAnchorElement
Dim WithEvents eDoc As FPHTMLDocument
Dim e As IHTMLEventObj

Private Sub Class_Initialize()
Set eDoc = ActiveDocument
Set eAnchor = eDoc.links(0)
End Sub

Private Function eAnchor_onclick() As Boolean
Set e = eAnchor.Document.parentWindow.event
If (MsgBox("OnClick Event for " & e.srcElement.tagName & _
    " would you like to cancel the event bubbling?", _
    vbYesNo) = vbYes) Then
    e.cancelBubble = True
    e.returnValue = False
Else
    e.cancelBubble = False
    e.returnValue = True
End If
End Function

Private Function eDoc_onclick() As Boolean
MsgBox "OnClick event for the Document object"
End Function

Fügen Sie als nächstes ein Standardmodul hinzu, und geben Sie den folgenden Code ein.

Public e As CatchOnClick
Sub GetClick()
Set e = New CatchOnClick
End Sub

Anmerkung Zum Ausführen des Beispiels gehen Sie folgendermaßen vor:

  • Fügen Sie einer Seite in FrontPage einen Hyperlink hinzu,

  • führen Sie die GetClick-Prozedur aus, um eine globale Instanz der CatchOnClick-Ereignisbehandlungsroutinenklasse zu erstellen,

  • klicken Sie auf den Hyperlink.

Es wird nun ein Aufforderungstext angezeigt, der angibt, dass das OnClick-Ereignis ausgelöst wurde. Mit diesem Aufforderungstext wird der Benutzer auch gefragt, ob das Programm das Ereignis die Ereigniskette hinauf weitergeben soll. Wird „Yes“ gewählt, wird das OnClick-Ereignis zwecks Verarbeitung an das Document-Objekt weitergegeben.

Um zu steuern, an welches Document-Objekt das Ereignis weitergegeben wird, müssen Sie sowohl das cancelBubble- als auch das returnValue-Ereignis festlegen. Das cancleBubble-Ereignis soll verhindern, dass das Ereignis in der Ereigniskette weiter nach oben wandert. Legen Sie die cancelBubble-Eigenschaft des IHTMLEventObj auf True fest, wenn Sie verhindern möchten, dass das OnClick-Ereignis auf die nächste Ebene der OnClick-Ereignisse weitergegeben wird, andernfalls legen Sie die cancelBubble-Eigenschaft auf False fest. Wenn Sie beispielsweise über eine Abbildung verfügen, mit der ein OnClick-Ereignis in einem Dokument platziert wird, das ebenfalls über ein OnClick-Ereignis verfügt, würden Sie die cancelBubble-Eigenschaft des IHTMLEventObj-Objekts für die Abbildung auf True festlegen, wenn Sie verhindern möchten, dass das OnClick-Ereignis auf die nächste Ebene an das OnClick-Ereignis des Dokuments weitergegeben wird.

Die returnValue-Eigenschaft wird verwendet, um die Standardaktion zu steuern, die von FrontPage in die Wege geleitet wird, wenn ein Ereignis ausgelöst wird. Bezogen auf das vorstehende Beispiel einer Abbildung, die sich in einem Dokument befindet, bedeutet dies, dass das Kontextmenü der rechten Maustaste deaktiviert wird (da dies die Standardaktion für das OnClick-Ereignis ist), wenn die returnValue-Eigenschaft für das IHTMLEventObject der Abbildung im OnClick-Ereignis auf False festgelegt wird.


Verwalten von Quellcodeverwaltungsprojekten in FrontPage 2000

Microsoft FrontPage stellt zwei Methoden zur Versionskontrolle bereit, und zwar die Quellcodeverwaltung FrontPage Light Weight (auch als Microsoft Office-artige Sperrung oder FrontPage-basierte Sperrung bezeichnet) und Microsoft Visual SourceSafe. Bei der Quellcodeverwaltung FrontPage Light Weight handelt es sich um die standardmäßige Versionskontrollmethode für Quellcodeverwaltungsprojekte in FrontPage.

Mit der Versionskontrolle wird Ihnen eine Kontrollmöglichkeit für Benutzer geboten, deren Aufgabe es ist, bestimmte Seiten in Ihren Websites zu pflegen. Beide Quellcodeverwaltungsmethoden umfassen Verfahren zum Einchecken und Auschecken sowie zum Rückgängigmachen des Auscheckens. Visual SourceSafe bietet weitere Versionskontrollmöglichkeiten wie beispielsweise Funktionen zur Versionsverfolgung und zur Wiederherstellung früherer Versionen.

Erstellen eines Quellcodeverwaltungsprojekts

Zum Erstellen eines neuen Quellcodeverwaltungsprojekts legen Sie die RevisionControlProject-Eigenschaft auf den Pfad des Projekts (für Visual SourceSafe) oder auf <FrontPage-based Locking> fest, wie in der folgenden Anweisung gezeigt.

ActiveWeb.RevisionControlProject = "<FrontPage-based Locking>"

Unter der Voraussetzung, dass es sich bei der Zeichenfolge „$/Rogue Cellars“ um ein gültiges Visual SourceSafe-Projekt handelt, wird mit der nachstehenden Anweisung das aktive Web einem Visual SourceSafe-Projekt zugewiesen.

ActiveWeb.RevisionControlProject = "$/Rogue Cellars/Inventory"

Im folgenden Beispiel wird ein Quellcodeverwaltungsprojekt erstellt, und es werden zwei Dateien ausgecheckt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Sie können auch zwei Dateien mit Namen index.htm und footnote.htm erstellen oder diese Namen durch Dateinamen Ihrer Wahl ersetzen.

Private Sub CreateSourceControl()
Dim myWeb As Web
Dim myProject As String
Dim myFile1 As WebFile
Dim myFile2 As WebFile

Set myWeb = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
Set myFile1 = myWeb.RootFolder.Files("index.htm")
Set myFile2 = myWeb.RootFolder.Files("footnote.htm")

myProject = "<FrontPage-based Locking>"

myWeb.RevisionControlProject = myProject
myFile1.Checkout
myFile2.Checkout
End Sub

Die Checkout-Methode umfasst zum Erzwingen des Auscheckens ein Argument für Administratoren vom Typ Boolean.

Entfernen eines Quellcodeverwaltungsprojekts

Nachdem ein Projekt abgeschlossen wurde, können Sie sich dazu entschließen, die Versionskontrolle zu entfernen. Hierzu legen Sie für die RevisionControlProject-Eigenschaft eine leere Zeichenfolge("") fest, wie in der folgenden Anweisung gezeigt.

myWeb.RevisionControlProject = ""

Wechseln zwischen FrontPage Light Weight- und Visual SourceSafe-Projekten

Um zwischen diesen beiden Arten der Versionskontrolle zu wechseln, müssen Sie zunächst die RevisionControlProject-Eigenschaft auf eine leere Zeichenfolge ("") festlegen, wie in der folgenden Anweisung dargestellt.

myWeb.RevisionControlProject = ""


Microsoft FrontPage 2000-Objekte

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt


OnAfterPageSave-Ereignis

Tritt ein, nachdem eine Seite gespeichert wurde.

Syntax

Private Sub Application_OnAfterPageSave(pPage As PageWindow, _

Success As Boolean)

pPage Erforderliches PageWindow. Ein PageWindow-Objekt.

Success Erforderliches Argument vom Typ Boolean. Gibt True zurück, wenn das PageWindow-Objekt erfolgreich gespeichert wurde.

Hinweise

Das OnAfterPageSave-Ereignis ist mit dem Application-Objekt verbunden. Nachdem der Benutzer eine Seite gespeichert oder Microsoft FrontPage geschlossen hat, wird das OnAfterPageSave-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnAfterPageSave-Ereignis

In diesem Beispiel wird nach dem Speichern der Seite ein Meldungsfenster angezeigt, in dem auch der Dateiname der Seite angegeben wird.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web und innerhalb dieses Webs mindestens eine Seite geöffnet sein.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdSave und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdSave_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdSave_Click()
Dim myPageWindow As PageWindow

Set myPageWindow = ActiveWeb.ActiveWebWindow.ActivePageWindow
myPageWindow.Save
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnAfterPageSave-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnAfterPageSave(ByVal pPage As _
    PageWindow, Success As Boolean)
If Success = True Then
    MsgBox "The following page was saved: " & pPage.File.Name
Else: MsgBox "There was a problem with saving your page: " & _
    pPage.File.Name
End If
End Sub


OnAfterWebPublish-Ereignis

Tritt ein, nachdem ein Web veröffentlicht wurde.

Syntax

Private Sub Application_OnAfterWebPublish(pWeb As Web, Success As Boolean)

pWeb Erforderliches Web. Das angegebene Web-Objekt.

Success Erforderliches Argument vom Typ Boolean. Gibt True zurück, wenn das angegebene Web erfolgreich veröffentlicht wurde.

Hinweise

Das OnAfterWebPublish-Ereignis ist mit dem Application-Objekt verbunden. Nachdem der Benutzer in Microsoft FrontPage ein Web veröffentlicht hat, wird das OnAfterWebPublish-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnAfterWebPublish-Ereignis

In diesem Beispiel wird eine Eigenschaft erstellt, die den Wert True annimmt, nachdem ein Web veröffentlicht wurde.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web geöffnet sein. Im vorliegenden Beispiel wird mit einem Web namens „Rogue Cellars“ gearbeitet. Sie können nun ein Web mit Namen „Rogue Cellars“ erstellen, oder Sie können dieses Web im folgenden Codebeispiel durch ein Web Ihrer Wahl ersetzen.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdPublishWeb und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdPublishWeb_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdPublishWeb_Click()
ActiveWeb.Publish "C:\My Documents\My Webs\Rogue Cellars"
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnAfterWebPublish-Abschnitt des Codefensters hinzu. Mit diesem Code wird dem Web eine Eigenschaft mit Namen Published hinzugefügt, die den Wert True enthält.

Private Sub eFPApplication_OnAfterWebPublish(ByVal pWeb As Web, Success As Boolean)
If Success = True Then
    pWeb.Properties.Add "Published", True
    pWeb.Properties.ApplyChanges
Else: MsgBox "There was a problem publishing your " & pWeb & " web."
End If
End Sub


OnBeforePageSave-Ereignis

Tritt ein, bevor eine Seite gespeichert wird.

Syntax

Private Sub Application_OnBeforePageSave(pPage As PageWindow, _

SaveAsUI As Boolean, Cancel As Boolean)

pPage Erforderliches PageWindow. Das angegebene PageWindow-Objekt.

SaveAsUI Erforderliches Argument vom Typ Boolean. Gibt True zurück, wenn die Seite zum ersten Mal gespeichert wurde. Wenn SaveAsUI auf True festgelegt wurde, dann hat der Benutzer das Dialogfeld Speichern unter verwendet, um die Seite zu speichern; wenn SaveAsUI auf False festgelegt wurde, dann hat der Benutzer das Dialogfeld Speichern verwendet, um eine vorhandene Datei zu speichern.

Cancel Erforderliches Argument vom Typ Boolean. Wird dieses Argument auf True festgelegt, wird Microsoft FrontPage veranlasst, den Speichervorgang abzubrechen. Wird Cancel programmgesteuert auf True festgelegt, kann der Benutzer den Speichervorgang abbrechen, indem er im Formular auf die Schaltfläche Abbrechen klickt. Als Standardwert gilt False.

Hinweise

Das OnBeforePageSave-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer eine Seite speichert oder FrontPage schließt, wird das OnBeforePageSave-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.

Anmerkung Wenn Sie Cancel auf True festlegen, wird die Seite nicht gespeichert.


Beispiel für das OnBeforePageSave-Ereignis

In diesem Beispiel wird vor dem Speichern der Seite ein Meldungsfenster angezeigt, in dem auch der Dokumenttitel der Datei dieser Seite angegeben wird.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web und innerhalb dieses Webs mindestens eine Seite geöffnet sein.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdSave und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdSave_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdSave_Click()
Dim myPageWindow As PageWindow

Set myPageWindow = ActiveWeb.ActiveWebWindow.ActivePageWindow
myPageWindow.Save
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnBeforePageSave-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnBeforePageSave(ByVal pPage As _
    PageWindow, SaveAsUI As Boolean, Cancel As Boolean)
MsgBox "The following page will be saved: " & pPage.File.Name _
    & "will be saved with the title: " & pPage.Document.Title
End Sub


OnBeforeWebPublish-Ereignis

Tritt ein, bevor ein Web veröffentlicht wird.

Syntax

Private Sub Application_OnBeforeWebPublish(pWeb As Web, Destination As String, Cancel As Boolean)

pWeb Erforderliches Web. Das angegebene Web-Objekt.

Destination Erforderliches Argument vom Typ String. Der URL der Zieladresse.

Cancel Erforderliches Argument vom Typ Boolean. Wurde dieses Argument auf True festgelegt, wird Microsoft FrontPage veranlasst, den Veröffentlichungsvorgang abzubrechen. Wenn Cancel programmgesteuert auf True festgelegt wird, kann der Benutzer den Speichervorgang abbrechen, indem er im Formular auf die Schaltfläche Abbrechen klickt. Als Standardwert gilt False.

Hinweise

Das OnBeforeWebPublish-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer in Microsoft FrontPage ein Web veröffentlicht, wird das OnBeforeWebPublish-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnBeforeWebPublish-Ereignis

In diesem Beispiel wird der Indexseite des zu veröffentlichenden Webs eine Copyright-Zeichenfolge hinzugefügt.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web geöffnet sein. Im vorliegenden Beispiel wird mit einem Web namens „Rogue Cellars“ gearbeitet. Sie können nun ein Web mit Namen „Rogue Cellars“ erstellen, oder Sie können dieses Web im folgenden Codebeispiel durch ein Web Ihrer Wahl ersetzen.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdPublishWeb und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdPublishWeb_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdPublishWeb_Click()
ActiveWeb.Publish "C:\My Documents\My Webs\Rogue Cellars"
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnBeforeWebPublish-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnBeforeWebPublish(ByVal pWeb As Web)
Dim myCopyright As String
Dim myIndexFile As WebFile

myCopyright = "Copyright 1999 by Rogue Cellars"
Set myIndexFile = pWeb.RootFolder.Files("index.htm")
myIndexFile.Open
If myIndexFile.Application.ActiveDocument.body.outerText <> _
    myCopyright Then
    myIndexFile.Application.ActiveDocument.body.insertAdjacentText _
        "BeforeEnd", myCopyright
End If
ActivePageWindow.Close
End Sub


OnPageClose-Ereignis

Tritt ein, wenn eine Seite geschlossen wird.

Syntax

Private Sub Application_OnPageClose(pPage As PageWindow, Cancel As Boolean)

pPage Erforderliches PageWindow. Das angegebene PageWindow-Objekt.

Cancel Erforderliches Argument vom Typ Boolean. Wurde dieses Argument auf True festgelegt, wird Microsoft FrontPage veranlasst, den Schließvorgang abzubrechen. Wenn Cancel programmgesteuert auf True festgelegt wird, kann der Benutzer den Speichervorgang abbrechen, indem er im Formular auf die Schaltfläche Abbrechen klickt. Als Standardwert gilt False.

Hinweise

Das OnPageClose-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer ein PageWindow-Objekt schließt, wird das OnPageClose-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnPageClose-Ereignis

In diesem Beispiel wird geprüft, ob eine Seite geändert wurde, und die Seite wird gespeichert, wenn die IsDirty-Eigenschaft vor dem Schließen der Seite den Wert True aufweist.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web und innerhalb dieses Webs mindestens eine Seite geöffnet sein.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdClosePage und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdClosePage_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdClosePage_Click()
ActivePageWindow.Close
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnPageClose-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnPageClose(ByVal pPage As _
    PageWindow, Cancel As Boolean)
If pPage.IsDirty = True Then pPage.Save
End Sub


OnPageNew-Ereignis

Tritt ein, wenn eine neue Seite erstellt wird.

Syntax

Private Sub Application_OnPageNew(pPage As PageWindow)

pPage Erforderliches PageWindow. Ein PageWindow-Objekt.

Hinweise

Wenn der Benutzer in einem Frameset eine neue Seite erstellt, wird das OnPageNew-Ereignis nur einmal für Framesseiten ausgelöst, und zwar, wenn die Seite geöffnet wird, die die Frameset-Tags enthält. Dann führt FrontPage den Code aus, den Sie in der Ereignisprozedur angegeben haben.

Anmerkung Das OnPageNew-Ereignis wird nur für das Standardframeset ausgelöst, auch wenn sich auf der Seite weitere Frames befinden. Dieses Ereignis wird nur ausgelöst, wenn sich FrontPage in der Seitenansicht befindet. Befindet sich FrontPage in einer der anderen Ansichten, wird das OnPageNew-Ereignis nicht ausgelöst.


Beispiel für das OnPageNew-Ereignis

In diesem Beispiel wird einer neuen Seite ein Design zugewiesen.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web geöffnet sein. In diesem Beispiel wird „Rogue Cellars“ als das anzugebende Web und Zinfandel.htm als die anzugebende Seite verwendet. Sie können nun ein Web und eine Seite mit diesen Namen erstellen, oder Sie können stattdessen die Namen eines Webs und einer Seite Ihrer Wahl verwenden.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdAddPage und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdAddPage_Click-Abschnitt des Codefensters hinzu. Mit diesem Code wird der PageWindows-Auflistung eine Seite hinzugefügt und diese anschließend geöffnet.

Private Sub cmdAddPage_Click()
Dim myPageWindows As PageWindows
Dim myFile As String

Set myPageWindows = ActiveWeb.ActiveWebWindow.PageWindows
myFile = _
    "file:///C:/My Documents/My Webs/Rogue Cellars/Zinfandel.htm"
myPageWindows.Add (myFile)
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnPageNew-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnPageNew(ByVal pPage As _
    PageWindow)
pPage.ApplyTheme ("artsy")
End Sub


OnPageOpen-Ereignis

Tritt ein, wenn eine Seite geöffnet wird.

Syntax

Private Sub Application_OnPageOpen(pPage As PageWindow)

pPage Erforderliches PageWindow. Ein PageWindow-Objekt.

Hinweise

Das OnPageOpen-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer eine Seite öffnet, öffnet Microsoft FrontPage das Frameset der Seite und löst das OnPageOpen-Ereignis für das Standardframeset aus. Anschließend führt FrontPage den Code aus, den Sie in der Ereignisprozedur angegeben haben.

Anmerkung Das OnPageOpen-Ereignis wird nur für das Standardframeset ausgelöst, auch wenn sich weitere Frames auf der Seite befinden. Das OnPageOpen-Ereignis wird nur ausgelöst, wenn die Seite nicht geöffnet ist.


Beispiel für das OnPageOpen-Ereignis

In diesem Beispiel wird der Titel des FPHTMLDocument-Objekts geändert, wenn das Dokument in einem PageWindow-Objekt geöffnet wird.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web geöffnet sein. In diesem Beispiel wird „Rogue Cellars“ als das anzugebende Web und Zinfandel.htm als die anzugebende Seite verwendet. Sie können nun ein Web und eine Seite mit diesen Namen erstellen, oder Sie können stattdessen die Namen eines Webs und einer Seite Ihrer Wahl verwenden.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdOpenPage und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdAddPage_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdAddPage_Click()
Dim myPageWindows As PageWindows
Dim myFile As String

Set myPageWindows = ActiveWeb.ActiveWebWindow.PageWindows
myFile = _
    "file:///C:/My Documents/My Webs/Rogue Cellars/Zinfandel.htm"
myPageWindows.Add (myFile)
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnPageOpen-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnPageOpen(ByVal pPage As _
    PageWindow)
Dim myDoc As FPHTMLDocument

Set myDoc = pPage.ActiveDocument

myDoc.Title = "Rogue Cellars Home Page"
End Sub


OnWebClose-Ereignis

Tritt ein, wenn ein Web geschlossen wird.

Syntax

Private Sub Application_OnWebClose(pWeb As Web, Cancel As Boolean)

pWeb Erforderliches Web. Ein Web-Objekt.

Cancel Erforderliches Argument vom Typ Boolean. Ist True, wenn der Schließvorgang über die Benutzeroberfläche abgebrochen wurde oder wenn Cancel explizit auf True festgelegt wurde. Als Standardwert gilt False.

Hinweise

Das OnWebClose-Ereignis ist mit dem Application-Objekt verbunden. Wenn Sie ein Web schließen, wird das OnWebClose-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnWebClose-Ereignis

In diesem Beispiel werden die geöffneten Seiten durchlaufen und diese, falls erforderlich, gespeichert, bevor das Web geschlossen wird.

Anmerkung Zum Ausführen dieses Beispiels muss mindestens ein Web und innerhalb dieses Webs mindestens eine Seite geöffnet sein. In diesem Beispiel wird mit „Rogue Cellars“ als dem anzugebenden Web gearbeitet. Sie können nun ein Web mit Namen „Rogue Cellars“ erstellen oder dieses durch ein Web Ihrer Wahl ersetzen.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdCloseWeb und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdCloseWeb_Click-Abschnitt des Codefensters hinzu. Mit diesem Codebeispiel wird das angegebene Web geschlossen.

Private Sub cmdCloseWeb_Click()
Webs("file:///C:/My Documents/My Webs/Rogue Cellars").Close
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnWebClose-Abschnitt des Codefensters hinzu. Mit diesem Codebeispiel werden die geöffneten Seiten durchlaufen und gespeichert, sofern sie geändert wurden.

Private Sub eFPApplication_OnWebClose(ByVal pWeb As Web, _
    Cancel As Boolean)
Dim myPageWindows As PageWindows
Dim myPageWindow As PageWindow

Set myPageWindows = pWeb.ActiveWebWindow.PageWindows

For Each myPageWindow In myPageWindows
    If myPageWindow.IsDirty = True Then myPageWindow.Save
Next
End Sub


OnWebNew-Ereignis

Tritt ein, wenn ein neues Web erstellt wird.

Syntax

Private Sub Application_OnWebNew(pWeb As Web)

pWeb Erforderliches Web. Ein Web-Objekt.

Hinweise

Das OnWebNew-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer in Microsoft FrontPage ein neues Web erstellt, wird das OnWebNew-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnWebNew-Ereignis

In diesem Beispiel wird ein temporäres Web erstellt und diesem eine neue Datei hinzugefügt, die dann geöffnet wird.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdCreateWeb und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdCreateWeb_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCreateWeb_Click()
Webs.Add ("file:///C:/My Documents/My Webs/TempWeb")
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnWebNew-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnWebNew(ByVal pWeb As Web)
Dim myFile As WebFile

Set myFile = pWeb.RootFolder.Files.Add("index.htm")
myFile.Open
End Sub


OnWebOpen-Ereignis

Tritt ein, wenn ein Web geöffnet wird.

Syntax

Private Sub Application_OnWebOpen(pWeb As Web)

pWeb Erforderliches Web. Ein Web-Objekt.

Hinweise

Das OnWebOpen-Ereignis ist mit dem Application-Objekt verbunden. Wenn der Benutzer in Microsoft FrontPage ein Web öffnet, wird das OnWebOpen-Ereignis ausgelöst und damit der Code ausgeführt, den Sie in der Ereignisprozedur angegeben haben.


Beispiel für das OnWebOpen-Ereignis

In diesem Beispiel wird die Datei index.htm geöffnet, wenn ein Web geöffnet wird.

Anmerkung In diesem Beispiel wird „Rogue Cellars“ als das zu öffnende Web angegeben. Sie können nun ein Web mit Namen „Rogue Cellars“ erstellen, oder Sie können dieses Web durch ein Web Ihrer Wahl ersetzen.

Erstellen Sie ein Formular mit Namen frmLaunchEvents.frm, und fügen Sie diesem zwei Schaltflächen hinzu, eine Schaltfläche mit Namen cmdOpenWeb und eine weitere mit Namen cmdCancel. Fügen Sie den folgenden Code im Deklarationsabschnitt des Formularcodefensters hinzu.

Option Explicit
Private WithEvents eFPApplication As Application
Private pPage As PageWindow

Fügen Sie den folgenden Code im UserForm_Initialize-Abschnitt des Codefensters hinzu.

Private Sub UserForm_Initialize()
Set eFPApplication = New Application
End Sub

Fügen Sie den folgenden Code im cmdOpenWeb_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdOpenWeb_Click()
webs.Open ("file:///C:/My Documents/My Webs/Rogue Cellars")
End Sub

Fügen Sie den folgenden Code im cmdCancel_Click-Abschnitt des Codefensters hinzu.

Private Sub cmdCancel_Click()
'Hide the form.
frmLaunchEvents.Hide
Exit Sub
End Sub

Fügen Sie den folgenden Code im eFPApplication_OnWebOpen-Abschnitt des Codefensters hinzu.

Private Sub eFPApplication_OnWebOpen(ByVal pWeb As Web)
Dim myFile As WebFile

Set myFile = pWeb.RootFolder.Files.Add("index.htm")
myFile.Open
End Sub


Activate-Methode

Aktiviert das angegebene PageWindow-, Web- oder WebWindow-Objekt. Sind mehrere Objekte geöffnet, können Sie die Activate-Methode verwenden, um mit einem bestimmten PageWindow-, Web- oder WebWindow-Objekt zu arbeiten.

Syntax

Ausdruck.Activate

Ausdruck Ein Ausdruck, der ein PageWindow-, Web-, oder WebWindow-Objekt zurückgibt.

Rückgabetyp

Void

Hinweise

Die Activate-Methode hat keinen Einfluss auf ein PageWindow ohne Fenster.


Beispiel für die Activate-Methode

Mit dieser Anweisung wird die Homepage der Website „Adventure Works“ aktiviert.

If myWeb.Url = "C:\My Webs\Adventure Works" Then myWeb.Activate


Add-Methode

Fügt der angegebenen Auflistung ein neues Element hinzu. Elemente in einer Auflistung werden automatisch beginnend mit Null indiziert.

Anmerkung Microsoft Office indiziert Auflistungselemente beginnend mit Eins. Beispielsweise stellt FrontPage einen Indexzusatz für die CommandBars-Auflistung bereit, die für alle Office-Produkte zur Verfügung steht. Wenn die CommandBars-Eigenschaft verwendet wird, um das CommandBars-Objekt zurückzugeben, beginnt die Indizierung mit Eins, da diese Eigenschaft auf ein Office-Objekt zugreift.

FrontPage stellt die in der nachstehenden Tabelle aufgeführten Objekte zum Hinzufügen mit der Add-Methode bereit. Um weitere Informationen zu den Objekten der Add-Methode zu erhalten, klicken Sie in der Tabelle auf den Namen des in Frage kommenden Objekts.

Auflistung der Objekte der Add-Methode | Beschreibung
NavigationNodes | Fügt der Liste der in der NavigationNodes-Auflistung verfügbaren Elemente ein neues NavigationNode-Objekt hinzu.
PageWindows | Fügt der Liste der in der PageWindows-Auflistung verfügbaren Elemente ein neues PageWindow-Objekt hinzu.
Properties | Fügt der Liste der in der Properties-Auflistung verfügbaren Elemente ein neues Property-Objekt hinzu.
WebFiles | Fügt der Liste der in der WebFiles-Auflistung verfügbaren Elemente ein neues WebFile-Objekt hinzu.
WebFolders | Fügt der Liste der in der WebFolders-Auflistung verfügbaren Elemente ein neues WebFolder-Objekt hinzu.
Webs | Fügt der Liste der in der Webs-Auflistung verfügbaren Elemente ein neues Web-Objekt hinzu.

Hinweise

Webverwalter können Zugriffsrechte festlegen und auf diese Weise die Verwendung der Add-Methode einschränken. Es gibt drei Kategorien von Zugriffsrechten: Leser, Autoren und Verwalter. Personen, die das Web lediglich im Browser anzeigen, verfügen grundsätzlich nicht über die Rechte zum Hinzufügen von Dateien zu den WebFiles- und PageWindows-Auflistungen.


Add-Methode (NavigationNodes-Auflistung)

Fügt der Liste der verfügbaren Elemente in der NavigationNodes-Auflistung eine neue Datei hinzu. Verwenden Sie diese Methode, um der Navigationsstruktur eine neue Datei hinzuzufügen. Weitere Informationen über die Verwendung von Navigationsknoten finden Sie in den Erläuterungen zur RootNavigationNode-Eigenschaft für das Web-Objekt oder der Children-Eigenschaft für das NavigationNode-Objekt.

Syntax

Ausdruck.Add(Url As String, NodeLabel As String, uModType As FpStructModType, [LeftSibling])

Ausdruck Ein Ausdruck, der ein NavigationNodes-Auflistungsobjekt zurückgibt.

Url Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den Pfad zu dem Webserver enthält, auf dem die Datei gespeichert werden soll. Hierbei kann es sich um einen absoluten URL wie beispielsweise http://Webserver oder file://Dateisystem bei festplattenbasierten Webs handeln.

NodeLabel Erforderliches Argument vom Typ String. Eine Textzeichenfolge, die zur Kennzeichnung des NavigationNode-Objekts beim Anzeigen der Navigationsstruktur in der Navigationsansicht verwendet wird. Das Argument NodeLabel wird nur als Identifikationshilfe verwendet.

uModType Erforderliches Argument vom Typ FpStructModType. Die möglichen Einstellungen für den Knoten finden Sie in der nachstehenden Tabelle.

Argument | Wert | Beschreibung
FpStructBaseOnSibling | 0 | Verwenden Sie diese Einstellung, wenn Sie rechts des im Argument LeftSibling (linker gleichgeordneter Knoten) angegebenen Knotens einen neuen Knoten hinzufügen möchten.
FpStructLeftMostChild | 1 | Der äußerst links befindliche Knoten in der aktuellen Navigationsstruktur.
FpStructRightMostChild | 2 | Der äußerst rechts befindliche Knoten in der aktuellen Navigationsstruktur.

LeftSibling Optionales Argument vom Typ Variant. Ein Indexwert aus der NavigationNodes-Auflistung. Hierbei kann es sich entweder um eine Zeichenfolge handeln, die einen URL darstellt, oder um eine Zahl, die für einen Knoten in der Auflistung steht.

Hinweise

Das Hinzufügen einer neuen Datei auf dem Webserver (unter Verwendung der WebFiles.Add-Methode) bedeutet nicht zwangsläufig, dass Sie die Datei auch automatisch in die Navigationsstruktur aufnehmen. Für die Datei muss separat ein NavigationNode-Objekt erstellt werden. Zum Erstellen eines neuen NavigationNode-Objekts verwenden Sie die Add-Methode für die NavigationNodes-Auflistung.

Anmerkung Wenn zum Erstellen eines neuen Webs eine Vorlage verwendet wird, werden für Dateien, die dem /Web basierend auf der Vorlage hinzugefügt wurden, automatisch Navigationsknoten erstellt.


Beispiel für die Add-Methode (NavigationNodes-Auflistung)

In diesem Beispiel wird der Liste der Elemente in der NavigationNodes-Auflistung ein neuer Knoten mit Namen footnote.htm hinzugefügt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen „C:\Eigene Dateien\Eigene Webs\Rogue Cellars“ (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder „C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars“ (bei einem Server, auf dem Windows NT ausgeführt wird) sowie über eine FrontPage-basierte Datei namens „footnote.htm“ verfügen. Alternativ können Sie einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub AddNewNavNode()
Dim myHome As NavigationNode
Dim myNewNode As NavigationNode
Dim myFileUrl As String

myFileUrl = "C:\My Documents\My Webs\Rogue Cellars\footnote.htm"
Set myHome = ActiveWeb.HomeNavigationNode
Set myNewNode = _
    myHome.Children.Add (myFileUrl, _
    "Footnote", fpStructLeftmostChild)
ActiveWeb.ApplyNavigationStructure
End Sub


Add-Methode (PageWindows-Auflistung)

Fügt der Liste der in der PageWindows-Auflistung verfügbaren geöffneten Elemente ein neues PageWindow-Objekt hinzu.

Anmerkung Mit dem Öffnen einer neuen oder einer bereits vorhandenen Datei mithilfe der Add-Methode für das PageWindow-Objekt wird auch das PageWindow-Objekt, das mit der geöffneten Datei verbunden ist, der PageWindows-Auflistung hinzugefügt.

Syntax

Ausdruck.Add(FileUrl As String)

Ausdruck Ein Ausdruck, der ein PageWindows-Auflistungsobjekt zurückgibt.

FileUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den Pfad zu dem Webserver enthält, auf dem die Seite gespeichert werden soll. Hierbei kann es sich um den absoluten URL einer Datei wie beispielsweise http://Webserver/Datei oder file://Dateisystem/Datei bei festplattenbasierten Webs handeln.

Hinweise

Wenn Sie HTML-Seiten in der Seitenansicht von Microsoft FrontPage anzeigen möchten, können Sie eine von drei Methoden einsetzen, und zwar die Add-Methode, die Edit-Methode oder die Open-Methode. Wenn Sie eine Datei in der Seitenansicht öffnen möchten, die sich entweder auf einem Dateiserver oder in einem Dateisystem auf der Festplatte befindet, bearbeiten Sie sie, und speichern Sie sie anschließend unter Verwendung der Add-Methode für das PageWindows-Objekt, wie in den folgenden Anweisungen gezeigt.

Anmerkung Hierbei ist es unerheblich, wo sich die Datei befindet; sie kann sich auf einer Festplatte ebenso wie auf einem Server oder in einem FrontPage-basierten Web befinden.

Dim myFile As String

myFile = "C:\Adventure Works HTML Files\Hiking.htm"
ActiveWeb.ActiveWebWindow.PageWindows.Add (myFile)

Mit dieser Methode haben Sie die Datei jedoch nicht einem FrontPage-basierten Web hinzugefügt, sondern Sie haben sie lediglich geöffnet. Wenn myFile Teil eines Webs ist und das Web gerade nicht geöffnet ist, dann öffnet FrontPage zusätzlich das Web.

Wenn Sie eine HTML-Datei öffnen und bearbeiten möchten, die sich in einem Web befindet, verwenden Sie die Edit-Methode für die Files-Auflistung im Stammordner, wie in der folgenden Anweisung dargestellt.

ActiveWeb.RootFolder.Files("Hiking.htm").Edit

Sie können auch die Open-Methode wie in der vorhergehenden Anweisung verwenden, Sie sollten aber die Open-Methode allen nicht-HTML-Dateien vorbehalten, wie Microsoft Word Dokumente, Grafiken, usw.

Sie können die Add-Methode auch verwenden, um ein neues, bisher nicht gespeichertes PageWindow-Objekt zu öffnen. Zum Öffnen eines nicht gespeicherten Seitenfensters können Sie eine der folgenden Anweisungen verwenden.

Set myUnsavedPageWindow = ActiveWebWindow.PageWindows.Add()
Set myUnsavedPageWindow = ActiveWebWindow.PageWindows.Add("")

Anmerkung Sie können den Ausdruck ActiveWebWindow.PageWindows.Add("C:\Eigene Dateien\Eigene Webs\index.htm") als gültigen Ausdruck verwenden, solange „index.htm“ eine gültige FrontPage-basierte Datei ist, die sich im Verzeichnis „Eigene Webs“ befindet. Befindet sich „index.htm“ jedoch nicht im Verzeichnis „Eigene Webs“, führt der Code nicht zum erwarteten Ergebnis. Zum Hinzufügen einer neuen Seite gehen Sie gemäß dem Verfahren vor, das an früherer Stelle in diesem Abschnitt erläutert wurde.


Beispiel für die Add-Methode (PageWindows-Auflistung)

In diesem Beispiel wird der Liste der Elemente in der PageWindows-Auflistung des Webs der Weinkellerei „Rogue Cellars“ die Seite „Inventory“ hinzugefügt. Wenn Sie eine Seite mit dem Argument FileUrl hinzufügen, muss die Seite, die Sie hinzufügen möchten, bereits als Datei vorliegen, d. h., Sie können mit diesem Argument keine neue Seite erstellen. Wenn Sie eine nicht gespeicherte neue Seite erstellen möchten, lesen Sie die Erläuterungen im Hilfethema zur Add-Methode.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen „C:\Eigene Dateien\Eigene Webs\Rogue Cellars“ (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder „C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars“ (bei einem Server, auf dem Windows NT ausgeführt wird) sowie über eine Datei namens „Inventory.htm“ verfügen. Alternativ können Sie einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub AddPage()
Dim myPageWindows As PageWindows
Dim myPage As String

Set myPageWindows = ActiveWeb.ActiveWebWindow.PageWindows
myPage = "C:\My Documents\My Webs\Rogue Cellars\Inventory.htm"

myPageWindows.Add (myPage)
End Sub


Add-Methode (Properties-Auflistung)

Fügt der Liste der verfügbaren Elemente in der Properties-Auflistung eine neue Eigenschaft hinzu.

Syntax

Ausdruck.Add(PropertyKey As String, PropertyValue)

Ausdruck Ein Ausdruck, der die Properties-Auflistung zurückgibt.

PropertyKey Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den Namen der Eigenschaft enthält, die Sie hinzufügen möchten. Weitere Informationen hierüber finden Sie in der Tabelle der Eigenschaften im Hilfethema zur Properties-Auflistung.

PropertyValue Erforderliches Argument vom Typ Variant. Der Wert der Eigenschaft.

Hinweise

Sie können Kategorien und Genehmigungsstufen für die Properties-Auflistung programmgesteuert hinzufügen oder entfernen.


Beispiel für die Add-Methode (Properties-Auflistung)

In diesem Beispiel wird der Liste der Elemente in der Properties-Auflistung eine neue Datei hinzugefügt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen „C:\Eigene Dateien\Eigene Webs\Rogue Cellars\Zinfandel.htm“ (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder „C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars\Zinfandel.htm“ (bei einem Server, auf dem Windows NT ausgeführt wird) sowie über eine FrontPage-basierte Datei namens „footnote.htm“ verfügen. Alternativ können Sie einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub CopyrightAdd()
Dim myWeb As Web
Dim myCopyright As String
Dim myCopyrightProperty As Variant

myCopyright = "Copyright 1999 by Rogue Cellars"
Set myWeb = Webs.Open("C:\My Webs\Rogue Cellers")
myWeb.Activate

ActiveWeb.Properties.Add "Copyright", myCopyright
ActiveWeb.RootFolder.Files("Zinfandel.htm").Open
ActiveDocument.body.insertAdjacentText "BeforeEnd", _
    ActiveWeb.Properties("Copyright")
ActivePageWindow.Save
ActiveWeb.Close
End Sub


Add-Methode (WebFiles-Auflistung)

Fügt der Liste der verfügbaren Elemente in der WebFiles-Auflistung ein neues WebFile-Objekt hinzu. Bei einem WebFile-Objekt kann es sich um einen beliebigen Dateityp handeln; diese Objektart ist nicht auf den Dateityp HTML beschränkt, sondern es kann sich auch um eine Bilddatei, einen Videoclip oder eine ausführbare Datei handeln.

Anmerkung Verwenden Sie diese Methode, wenn Sie einem FrontPage-basierten Web eine neue Datei hinzufügen möchten.

Syntax

Ausdruck.Add(FileUrl As String)

Ausdruck Erforderlich. Ein Ausdruck, der ein Files-Auflistungsobjekt zurückgibt.

FileUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den URL der Datei wie beispielsweise „Inventory.htm“ enthält. Hierbei kann es sich um einen beliebigen absoluten URL einer Datei wie beispielsweise http://Webserver/Datei oder file://Dateisystem/Datei bei festplattenbasierten Webs handeln.

Hinweise

Beim Zugreifen auf ein einzelnes WebFile-Objekt über die WebFiles-Auflistung wird ein Verweis auf ein WebFile-Objekt bereitgestellt, das erst dann Zugriff auf das Page-Objektmodell erhält, wenn die Webdatei geöffnet wird. Nachdem die Datei geöffnet wurde, ermöglicht das mit der Datei verbundene PageWindow-Objekt Zugriff auf das Page-Objektmodell, das mit Microsoft Internet Explorer, Version 4.0 und höher, kompatibel ist. Weitere Informationen über die Verwendung des Page-Objektmodells in Verbindung mit Ihren Webseiten finden Sie unter Erforschen des Objektmodells in FrontPage.


Beispiel für die Add-Methode (WebFiles-Auflistung)

In diesem Beispiel wird der Liste der Elemente in der Files-Auflistung ein neues WebFile-Objekt hinzugefügt.

ActiveWeb.RootFolder.Files.Add ("C:\New Web Files\Sales Statistics.htm")


Add-Methode (WebFolders-Auflistung)

Fügt der Liste der verfügbaren Elemente in der WebFolders-Auflistung ein neues WebFolder-Objekt hinzu.

Syntax

Ausdruck.Add(FolderUrl As String)

Ausdruck Ein Ausdruck, der ein WebFolders-Auflistungsobjekt zurückgibt.

FolderUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den URL des Ordners enthält, wie beispielsweise des Ordners „Images“ in „C:\Eigene Webs“. Hierbei kann es sich um einen beliebigen absoluten URL für einen Ordner wie beispielsweise http://Webserver/Ordner oder file://Dateisystem/Ordner bei festplattenbasierten Webs handeln.


Beispiel für die Add-Methode (WebFolders-Auflistung)

In diesem Beispiel wird der Liste der Elemente in der WebFolders-Auflistung ein Ordner hinzugefügt.

ActiveWeb.RootFolder.Folders.Add ("Distribution Centers")


Add-Methode (Webs-Auflistung)

Fügt der Liste der verfügbaren Elemente in der Webs-Auflistung ein neues Web hinzu.

Syntax

Ausdruck.Add(WebUrl As String, [UserName], [Password])

Ausdruck Ein Ausdruck, der ein Webs-Auflistungsobjekt zurückgibt.

WebUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den Pfad des Webservers enthält, auf dem das Web gespeichert werden soll. Hierbei kann es sich um einen beliebigen absoluten URL für ein Web wie beispielsweise http://Webserver oder file://Dateisystem bei festplattenbasierten Webs handeln.

UserName Optionales Argument vom Typ String. Der Logon-Name des Benutzers für den Webserver.

Password Optionales Argument vom Typ String. Das Kennwort des Benutzers für den Webserver.


Beispiel für die Add-Methode (Webs-Auflistung)

In diesem Beispiel wird der Liste der Dateien in der Webs-Auflistung ein neues Element hinzugefügt.

Webs.Add ("C:\My Documents\My Webs\Rogue Cellars")


ApplyChanges-Methode

Weist dem angegebenen Objekt Änderungen zu. Änderungen an einer Eigenschaft eines Web-, WebFile- oder WebFolder-Objekts werden erst übernommen, wenn Sie die ApplyChanges-Methode für das angegebene Objekt verwenden.

Syntax

Ausdruck.ApplyChanges

Ausdruck Ein Ausdruck, der ein Properties-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die ApplyChanges-Methode

In diesem Beispiel wird der Wert der Eigenschaft vti_title für eine Datei mit Namen Zinfandel.htm geändert, und die Änderung wird zugewiesen.

Private Sub ChangeProperties()
Dim myProperties As Properties

Set myProperties = _
    ActiveWeb.RootFolder.Files("Zinfandel.htm").Properties
myProperties("vti_title") = "Rogue Cellars Wine List"
myProperties.ApplyChanges
End Sub


ApplyNavigationStructure-Methode

Weist dem angegebenen Objekt die Navigationsstruktur zu.

Syntax

Ausdruck.ApplyNavigationStructure

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

Rückgabetyp

Void

Hinweise

Beim programmgesteuerten Erstellen von Dateien und Navigationsknoten müssen die zwei folgenden Voraussetzungen beachtet werden:

  • Navigationsbeschriftungen dürfen nicht leer sein.

  • Änderungen an der Navigationsstruktur können verloren gehen, wenn Sie die Navigationsstruktur nicht zuweisen, bevor Sie Operationen starten, die Auswirkungen auf den Inhalt des Webs haben, wie beispielsweise das Verschieben und das Hinzufügen von Dateien oder Ordnern.


Beispiel für die ApplyNavigationStructure-Methode

In diesem Beispiel wird ein Navigationsknoten als der äußerst rechte untergeordnete Knoten hinzugefügt, und anschließend werden die Änderungen der Navigationsstruktur zugewiesen.

Private Sub AddNewNavNode()
Dim myWeb As Web
Dim myChildNodes As NavigationNodes
Dim myNewNavNode As NavigationNode

Set myWeb = ActiveWeb
Set myChildNodes = _
 myWeb.RootFolder.Files(1).NavigationNode.Children

myNewNavNode = _
 myChildNodes.Add(myWeb.Url & "Sale.htm", "Sale", _
    fpStructRightmostChild)
myWeb.ApplyNavigationStructure
End Sub


ApplyTheme-Methode

Mit dieser Methode wird der im Argument ThemeName enthaltene Wert der im Argument ThemeProperties bezeichneten Eigenschaft zugewiesen. Designs („Themes“) können beispielsweise WebFile-, PageWindow- oder Web-Objekten in einem Microsoft FrontPage-basierten Web zugewiesen werden.

Syntax

Ausdruck.ApplyTheme(ThemeName als String, ThemeProperties als FpThemeProperties)

Ausdruck Ein Ausdruck, der ein FrontPage-Objekt zurückgibt.

ThemeName Erforderlicher Wert vom Typ String (Zeichenfolge). Eine Zeichenfolge, die den Namen des Designs enthält, das Sie einer Datei zuweisen möchten. Hierbei kann es sich um eine der folgenden Konstanten für ThemeName handeln:

artsy | boldstri | indust | sumipntg
blank | capsules | ricepapr |
blends | citrus | rmnsque |
blueprnt | expeditn | strtedge |

ThemeProperties Erforderliches Argument vom Typ Long. Das Argument ThemeProperties akzeptiert die in der folgenden Tabelle aufgeführten Aufzählungstypen.

Aufzählungstyp | Standardwert
FpThemeActiveGraphics | &H10 oder 16
FpThemeBackgroundImage | 1
FpThemeCSS | &H1000 oder 4096
FpThemeDefaultSettings | &H1000000 oder 16777216
FpThemeName | &H2000000 oder 33554432
FpThemeNoBackgroundImage | 0
FpThemeNoCSS | 0
FpThemeNormalColors | 0
FpThemeNormalGraphics | 0
FpThemePropertiesAll | &H1111 oder 4369
FpThemePropertiesNone | 0
FpThemeVividColors | &H100 oder 256

Hinweise

Mit dem folgenden Code wird einer Datei das Design „Sumi Painting“ mit aktiven Grafiken zugewiesen.

Dim strTheme As String

strTheme = "sumipntg"
Call WebFile.ApplyTheme(strTheme, fpThemeUseActiveGraphics)

Wenn Sie beim Zuweisen des Designs mehr als eine Theme-Eigenschaft ändern möchten, verwenden Sie das Pluszeichen (+), wie im folgenden Beispiel gezeigt.

strTheme = "sumipntg"
WebFile.ApplyTheme(strTheme, _
fpThemeVividColors + fpThemeActiveGrphics)

Diese Methode ist im Wesentlichen die gleiche wie die, die Sie zum Zuweisen eines Designs zu einem PageWindow- oder Web-Objekt verwenden.


Beispiel für die ApplyTheme-Methode

Dieses Beispiel enthält eine Funktion, ApplyThemeToFilesInFolder, und eine Prozedur, die Sie anpassen können, um eins der verfügbaren Designs zuzuweisen. In diesem Beispiel wird das Design „Impressionen“ allen Dateien in einem bestimmten Ordner zugewiesen.

Anmerkung Um dieses Beispiel auszuführen, kopieren Sie den folgenden Code in ein Modul im Visual Basic Editor, und führen Sie die Prozedur ChangeToArtsy aus.

Function ApplyThemeToFilesInFolder(myThemeName As String, _
    myFolderObject As WebFolder) As Boolean
Dim myFile As WebFile
Dim myTheme As Theme

On Error GoTo ERR

For Each myFile In myFolderObject.Files
Call myFile.ApplyTheme(myThemeName, fpThemePropertiesAll)
Next myFile

ApplyThemeToFilesInFolder = True
Exit Function

ERR:
MsgBox "An error occured: " & ERR.Description, vbCritical, "Error!"
ApplyThemeToFilesInFolder = False
Exit Function

End Function

Private Sub ChangeToArtsy()
ApplyThemeToFilesInFolder "artsy", ActiveWeb.RootFolder
End Sub


CancelRequests-Methode

Bricht alle Anforderungen an das Web-Objekt unverzüglich und ohne Speichern ab.

Syntax

Ausdruck.CancelRequests

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die CancelRequests-Methode

Die CancelRequests-Methode kann verwendet werden, um einen Prozess zu beenden, der eventuell zu lange dauert, sich in einer Endlosschleife befindet oder der möglicherweise von einer zweifelhaften Quelle kommt.

Private Sub CancelRequestsToWeb_Click()
Dim myWeb As Web

Set myWeb = ActiveWeb
myWeb.CancelRequests
End Sub


Checkin-Methode

Checkt das angegebene WebFile-Objekt in das Quellcodeverwaltungsprojekt ein.

Anmerkung Bevor Sie diese Methode verwenden können, müssen Sie über ein Quellcodeverwaltungsprojekt verfügen. Informationen über Quellcodeverwaltungsprojekte finden Sie unter Verwalten von Quellcodeverwaltungsprojekten.

Syntax

Ausdruck.Checkin(Comment, KeepCheckedout)

Ausdruck Ein Ausdruck, der ein WebFile-Objekt zurückgibt.

Comment Erforderliches Argument vom Typ String. Eine beschreibende Zeichenfolge.

KeepCheckedout Optionales Argument vom Typ Boolean. Sorgt dafür, dass die Datei ausgecheckt bleibt. Als Standardwert gilt False.

Rückgabetyp

Void

Hinweise

Das Argument KeepCheckedout bietet die Möglichkeit, den Status „Ausgecheckt“ für die Datei beizubehalten, während der Benutzer die Datei in Microsoft Visual SourceSafe eincheckt, um die Änderungen aufzuzeichnen. In Verbindung mit der FrontPage Light Weight-Quellcodeverwaltung kann das Argument nicht verwendet werden.


Beispiel für die Checkin-Methode

Mit dem Programm in diesem Beispiel werden die folgenden Schritte ausgeführt:

  • Eine Datei wird ausgecheckt und in den Bearbeitungsmodus versetzt.

  • Dem Dokument wird eine Begrüßungsmeldung hinzugefügt.

  • Es wird geprüft, ob die geöffnete Seite geändert wurde.

  • Wenn die Seite geändert wurde, wird sie gespeichert.

  • Anschließend wird die Datei geschlossen und in das vorhandene Quellcodeverwaltungsprojekt eingecheckt.

Anmerkung Zum Ausführen dieses Beispiels müssen Sie über ein Quellcodeverwaltungsprojekt für ein Web mit einer Datei mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Alternativ können Sie auch ein Web und eine Datei Ihrer Wahl einsetzen.

Private Sub CheckinFile()
Dim myWeb As Web
Dim myFile As WebFile
Dim myPageWindow As PageWindow
Dim myWelcome As String

Set myWeb = Webs("C:/My Webs/Rogue Cellars")
myWelcome = "Welcome to my Web Site!"
Set myFile = myWeb.RootFolder.Files("Zinfandel.htm")
myFile.Checkout
Set myPageWindow = myFile.Edit(fpPageViewNormal)
With myPageWindow
    myPageWindow.Document.body.insertAdjacentText "BeforeEnd", _
        myWelcome
    If myPageWindow.IsDirty = True Then myPageWindow.Save
    .Close
End With
myFile.Checkin
End Sub


Checkout-Methode

Checkt das angegebene WebFile-Objekt in das Quellcodeverwaltungsprojekt aus.

Anmerkung Bevor Sie diese Methode verwenden können, müssen Sie über ein Quellcodeverwaltungsprojekt verfügen. Informationen über Quellcodeverwaltungsprojekte finden Sie unter Verwalten von Quellcodeverwaltungsprojekten.

Syntax

Ausdruck.Checkout(ForceCheckout)

Ausdruck Ein Ausdruck, der ein WebFile-Objekt zurückgibt.

ForceCheckout Optionales Argument vom Typ Boolean. Erzwingt ein Auschecken, auch wenn die Datei bereits ausgecheckt wurde. Als Standardwert gilt False.

Rückgabetyp

Void

Hinweise

Das Argument ForceCheckout ermöglicht es dem Systemadministrator, ein Auschecken in Fällen zu erzwingen, in denen eine Datei von einem Benutzer bereits ausgecheckt wurde, der gegenwärtig nicht verfügbar ist, um die Datei wieder einzuchecken.


Beispiel für die Checkout-Methode

Mit dem Programm in diesem Beispiel werden die folgenden Schritte ausgeführt:

  • Eine Datei wird aus einem vorhandenen Quellcodeverwaltungsprojekt ausgecheckt und in den Bearbeitungsmodus versetzt.

  • Dem Dokument wird eine Begrüßungsmeldung hinzugefügt.

  • Es wird geprüft, ob die geöffnete Seite geändert wurde.

  • Wenn die Seite geändert wurde, wird sie gespeichert.

  • Anschließend wird die Datei geschlossen und in das vorhandene Quellcodeverwaltungsprojekt eingecheckt.

Anmerkung Zum Ausführen dieses Beispiels müssen Sie über ein Quellcodeverwaltungsprojekt für ein Web mit einer Datei mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Alternativ können Sie auch ein Web und eine Datei Ihrer Wahl einsetzen.

Private Sub CheckoutFile()
Dim myWeb As Web
Dim myFile As WebFile
Dim myPageWindow As PageWindow
Dim myWelcome As String

Set myWeb = Webs("C:/My Webs/Rogue Cellars")
myWelcome = "Welcome to my Web Site!"
Set myFile = myWeb.RootFolder.Files("Zinfandel.htm")
myFile.Checkout
Set myPageWindow = myFile.Edit(fpPageViewNormal)
With myPageWindow
    myPageWindow.Document.body.insertAdjacentText "BeforeEnd", _
        myWelcome
    If myPageWindow.IsDirty = True Then myPageWindow.Save
    .Close
End With
myFile.Checkin
End Sub


Close-Methode

Schließt das angegebene Objekt.

Syntax 1: Schließt das angegebene PageWindow-Objekt.

Syntax 2: Schließt die angegebenen Seiten in der PageWindows-Auflistung oder, falls Null, schließt alle geöffneten Seiten der PageWindows-Auflistung.

Syntax 3: Schließt das angegebene WebWindow-Objekt.

Syntax 4: Schließt die angegebenen Webs in der WebWindows-Auflistung.

Syntax 1

Ausdruck.Close([ForceSave als Boolean])

Ausdruck Ein Ausdruck, der ein PageWindow-Objekt zurückgibt.

ForceSave Optionales Argument vom Typ Boolean. Bei Angabe von True wird eine Speicherung der angegebenen Datei erzwungen, bevor die Close-Methode zu Ende geführt wird. Als Standardwert gilt False.

Rückgabetyp

Void

Syntax 2

Ausdruck.Close([Index],[ForceSave als Boolean])

Ausdruck Ein Ausdruck, der ein Objekt aus der PageWindows-Auflistung zurückgibt.

Index Optionales Argument vom Typ Variant. Bezieht sich auf ein einzelnes Element in der PageWindows-Auflistung. Kann eine beliebige Zahl entsprechend einem Element in der Auflistung sein, wobei der Index mit Null beginnt.

ForceSave Optionales Argument vom Typ Boolean. Bei Angabe von True wird eine Speicherung der angegebenen Datei erzwungen, bevor die Close-Methode zu Ende geführt wird. Als Standardwert gilt False.

Rückgabetyp

Void

Syntax 3

Ausdruck.Close()

Ausdruck Ein Ausdruck, der ein WebWindow-Objekt zurückgibt.

Rückgabetyp

Void

Syntax 4

Ausdruck.Close(Index)

Ausdruck Ein Ausdruck, der ein in der WebWindows-Auflistung befindliches Objekt zurückgibt.

Index Optionales Argument vom Typ Variant. Bezieht sich auf ein Element in der WebWindows-Auflistung. Kann eine beliebige Zahl entsprechend einem Element in der Auflistung sein, wobei der Index mit Null beginnt.

Rückgabetyp

Void

Hinweise

Das folgende Beispiel veranschaulicht die Verwendung der jeweiligen Syntaxtypen in Verbindung mit der Close-Methode.

Syntax 1: Das PageWindow-Objekt übergibt ein optionales ForcedSave-Argument, das in der folgenden Anweisung auf True gesetzt wurde, so dass myPageWindow vor dem Schließen gespeichert wird.

myPageWindow.Close(True)

Wenn myPageWindow jedoch ohne erzwungene Speicherung geschlossen werden soll, entfernen Sie das ForcedSave-Argument aus den Klammern, wie in nachfolgender Anweisung gezeigt, oder legen Sie das Argument auf False fest.

myPageWindow.Close()
myPageWindow.Close(False)

Syntax 2: Die PageWindows-Auflistung übergibt das optionale ForcedSave-Argument zusammen mit einem Indexwert, um auf einzelne PageWindow-Objekte zu verweisen. Mit der folgenden Anweisung wird eine einzelne Seite in der Auflistung mit dem ForcedSave-Argument geschlossen.

myPageWindows.Close(2,True)

Anmerkung Wenn das Argument wie in der folgenden Anweisung den Wert Null besitzt, schließt Microsoft FrontPage alle geöffneten Seiten.

myPageWindows.Close()

Syntax 3: Für das WebWindow-Objekt wird die einfache Close-Methode verwendet. Diese Methode ist nützlich, wenn Sie Webs analysieren möchten und nicht mit einzelnen Seiten im Web arbeiten müssen.

myWebWindow.Close

Syntax 4: Die WebWindows-Auflistung übergibt einen Null-basierten Indexwert, um auf einzelne WebWindow-Objekte zu verweisen. Mit der folgenden Anweisung wird das zweite offene WebWindow-Objekt geschlossen.

myWebWindow.Close(1)

Anmerkung Wenn das Argument wie in der folgenden Anweisung den Wert Null besitzt, schließt Microsoft FrontPage alle offenen Webfenster.

myPageWindows.Close()


Beispiel für die Close-Methode

In diesem Beispiel wird die vierte der geöffneten Seiten geschlossen, und es wird eine Fehlerbehandlungsroutine aufgerufen, mit der eine Meldung angezeigt wird, wenn Fehler 4198 auftritt, was bedeutet, dass der Benutzer auf die Schaltfläche Abbrechen geklickt hat.

On Error GoTo errorHandler
PageWindows.Close(3,True)

errorHandler:
If Err=4198 Then MsgBox "PageWindow was not closed."


Copy-Methode

Kopiert das angegebene Objekt an einen bestimmten URL. Während des Kopiervorgangs können Sie wählen, ob Hyperlinks aktualisiert werden sollen, oder Sie können das Überschreiben einer Datei erzwingen, wenn das angegebene Objekt den gleichen Namen wie das Zielobjekt trägt.

Syntax

Ausdruck.Copy(DestinationUrl als String, UpdateLinks als Boolean, ForceOverwrite als Boolean)

Ausdruck Ein Ausdruck, der ein WebFile- oder WebFolder-Objekt zurückgibt.

DestinationUrl Erforderlich. Ein Wert vom Typ String. Der Ziel-URL.

UpdateLinks Erforderlich. Ein Wert vom Typ Boolean. Gibt an, dass Hyperlinks während des Kopiervorgangs aktualisiert werden sollen. Wird auf True festgelegt, um Hyperlinks zu aktualisieren.

ForceOverwrite Erforderlich. Ein Wert vom Typ Boolean. Gibt an, dass das Überschreiben einer Datei erzwungen werden soll, wenn eine Datei oder ein Ordner gleichen Namens gefunden wird. Legen Sie für dieses Argument True fest, um das Überschreiben einer Datei zu erzwingen.

Rückgabetyp

Void

Hinweise

Mit der Copy-Methode können nur Dateien und Ordner im gleichen Web kopiert werden. Sie können hiermit keine webübergreifenden Kopieraktionen vornehmen. Sie können jedoch die SaveAs-Methode für das PageWindow-Objekt verwenden, um eine Seite, deren Datei sich aktuell in dem einen Web befindet, in einer Datei in einem anderen Web zu speichern. Oder Sie können die Add-Methode für das WebFile-Objekt verwenden, um eine Datei, die sich aktuell in einem bestimmten Web befindet, einem anderen Web hinzuzufügen.


Beispiel für die Copy-Methode

In diesem Beispiel wird eine Datei aus dem Webordner Rogue Cellars in den Ordner Inventory im gleichen Web kopiert.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profile\Logon-Alias\Eigenes\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen.

Private Sub FileCopy()
Dim myFile As WebFile

Set myFile = ActiveWeb.RootFolder.Files("Zinfandel.htm")
myFile.Copy "C:\My Webs\Rogue Cellars\Inventory\Zinfandel.htm"
End Sub


Delete-Methode

Löscht das angegebene Objekt, ist aber nicht gleichbedeutend mit dem Entfernen eines Objekts (unter Verwendung der RemoveWeb-Methode) aus einem auf Microsoft FrontPage basierenden Web. So können Sie beispielsweise in der Navigationsansicht von FrontPage eine Seite aus einer FrontPage-basierten Website entfernen, wobei die hiermit verbundene Datei dann noch immer auf dem Server oder auf der Festplatte vorhanden ist. Wenn Sie ein Objekt jedoch mit der Delete-Methode löschen, ist das Objekt danach nicht mehr existent. Für weitere Informationen über die Verwendung der Delete-Methode in Verbindung mit anderen Objekten klicken Sie auf ein Element in der nachstehenden Tabelle.

Objekt | Beschreibung
NavigationNodes | Löscht den angegebenen Navigationsknoten aus der Liste der verfügbaren Knoten in der NavigationNodes-Auflistung.
Properties | Löscht die angegebene Eigenschaft auf der Liste der verfügbaren Eigenschaften in der Properties-Auflistung des Web-, WebFile- oder WebFolder-Objekts.
Web | Löscht das angegebene Web.
WebFile | Löscht die angegebene Datei aus dem Web.
WebFiles | Löscht die angegebene Datei aus der Liste der verfügbaren Dateien in der Files-Auflistung.
WebFolder | Löscht den angegebenen Ordner aus dem Web.
WebFolders | Löscht den angegebenen Ordner aus der Liste der verfügbaren Ordner in der Folders-Auflistung.
Webs | Löscht das angegebene Web aus der Liste der verfügbaren Webs in der Webs-Auflistung.


Delete-Methode (NavigationNodes)

Löscht einen einzelnen Navigationsknoten aus der Liste der verfügbaren Knoten in der NavigationNodes-Auflistung.

Syntax

Ausdruck.Delete(Index)

Ausdruck Ein Ausdruck, der ein NavigationNodes-Objekt zurückgibt.

Index Erforderlicher Wert vom Typ Variant. Bezieht sich auf ein Element in der Navigationsstruktur. Hierbei kann es sich um eine beliebige Zahl handeln, die einem Element in der Navigationsstruktur entspricht, wobei der Index mit Null beginnt.


Beispiel für die Delete-Methode (NavigationNodes)

In diesem Beispiel wird der vierte Navigationsknoten der zweiten Datei im aktiven Web gelöscht.

Anmerkung Sie müssen dem Web die Navigationsstruktur zuweisen, damit die Änderungen für das Web wirksam werden können.

Private Sub DeleteNavNode()
Dim myWeb As Web
Dim myChildNodes As NavigationNodes

Set myWeb = ActiveWeb
Set myChildNodes = _
    myWeb.RootFolder.WebFiles(1).NavigationNode.Children

Call myChildNodes.Delete(3)
myWeb.ApplyNavigationStructure
End Sub


Delete-Methode (Properties)

Löscht eine Eigenschaft aus der Liste der verfügbaren Eigenschaften in der Properties-Auflistung.

Syntax

Ausdruck.Delete(PropertyKey als String)

Ausdruck Ein Ausdruck, der ein Properties-Objekt zurückgibt.

PropertyKey Erforderlich. Ein Wert vom Typ String, der für den Namen einer Eigenschaft steht.


Beispiel für die Delete-Methode (Properties)

In diesem Beispiel wird die Eigenschaft SaleText aus der Datei Sales.htm gelöscht.

Private Sub DeleteProperty()
Dim myFile As WebFile
Dim myProp As String

Set myFile = ActiveWeb.RootFolder.Files("Sales.htm")
myFile.Properties.Delete ("SaleText")
End Sub


Delete-Methode (Web)

Löscht ein Web aus der Liste der verfügbaren Webs in der Webs-Auflistung.

Syntax

Ausdruck.Delete()

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.


Delete-Methode (WebFile)

Löscht die angegebene Datei aus einem Web.

Syntax

Ausdruck.Delete()

Ausdruck Ein Ausdruck, der ein WebFile-Objekt zurückgibt.


Delete-Methode (WebFiles)

Löscht einen Task aus der Liste der verfügbaren Tasks in der WebFiles-Auflistung.

Syntax

Ausdruck.Delete(Index)

Ausdruck Ein Ausdruck, der ein WebFiles-Auflistungsobjekt zurückgibt.

Index Erforderlich. Bezieht sich auf ein Element in der WebFiles-Auflistung. Hierbei kann es sich um eine beliebige Zahl handeln, die einem Element in der Auflistung entspricht, wobei der Index mit Null beginnt.


Beispiel für die Delete-Methode (WebFiles)

Mit dieser Anweisung wird eine Datei aus dem aktiven Web gelöscht.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über eine Datei mit Namen C:\Eigene Webs\TempFile.htm (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profile\Logon-Alias\Eigene Dateien\Eigene Webs\TempFile.htm (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle der angegebenen Datei (TempFile.htm) auch eine andere Datei verwenden.

ActiveWeb.RootFolder.Files.Delete "TempFile"


Beispiel für die Delete-Methode (WebFile)

In diesem Beispiel wird eine Datei aus dem aktiven Web gelöscht.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über eine Datei mit Namen C:\Eigene Webs\TempFile.htm (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profile\Logon-Alias\Eigene Dateien\Eigene Webs\TempFile.htm (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle der angegebenen Datei (TempFile.htm) auch eine andere Datei verwenden.

Private Sub DeleteFile()
Dim myFile As WebFile

Set myFile = ActiveWeb.RootFolder.Files("TempFile")
myFile.Delete

End Sub


Delete-Methode (WebFolder)

Löscht den angegebenen Ordner aus einem Web.

Syntax

Ausdruck.Delete()

Ausdruck Ein Ausdruck, der ein WebFolder-Objekt zurückgibt.


Delete-Methode (WebFolders)

Löscht einen oder mehrere Ordner aus der Liste der verfügbaren Ordner in der WebFolders-Auflistung.

Syntax

Ausdruck.Delete(Index)

Ausdruck Ein Ausdruck, der ein WebFolders-Auflistungsobjekt zurückgibt.

Index Erforderlich. Bezieht sich auf ein Element in der WebFolders-Auflistung. Hierbei kann es sich um eine beliebige Zahl handeln, die einem Element in der Auflistung entspricht, wobei der Index mit Null beginnt.


Beispiel für die Delete-Methode (WebFolders)

Mit dieser Anweisung wird der zweite Ordner aus dem aktiven Web gelöscht.

ActiveWeb.RootFolder.Folders.Delete(1)


Beispiel für die Delete-Methode (WebFolder)

In diesem Beispiel wird ein Ordner aus dem aktiven Web gelöscht.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über eine Datei mit Namen C:\Eigene Webs\TempFolder (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profile\Logon-Alias\Eigene Dateien\Eigene Webs\TempFolder (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle des angegebenen Webordners (TempFolder) auch einen anderen Ordner verwenden.

Private Sub DeleteFolder()
Dim myFolder As WebFolder

Set myFolder = ActiveWeb.RootFolder.Folders("TempFolder")
myFolder.Delete

End Sub


Delete-Methode (Webs)

Löscht ein Web aus der Liste der verfügbaren Webs in der Webs-Auflistung.

Syntax

Ausdruck.Delete(Index)

Ausdruck Ein Ausdruck, der ein Webs-Auflistungsobjekt zurückgibt.

Index Erforderlich. Bezieht sich auf ein Element in der Webs-Auflistung. Hierbei kann es sich um eine beliebige Zahl handeln, die einem Element in der Auflistung entspricht, wobei der Index mit Null beginnt.


Beispiel für die Delete-Methode (Webs)

Mit dieser Anweisung wird das vierte Web gelöscht.

Webs.Delete(3)


Beispiel für die Delete-Methode (Web)

In diesem Beispiel wird ein temporäres Web mit Namen TempWeb gelöscht.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Webs\TempWeb (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profile\Logon-Alias\Eigene Dateien\Eigene Webs\TempWeb (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle des angegebenen Web-URLs auch einen anderen URL verwenden.

Private Sub DeleteWeb()
Dim myWeb As Web
Dim myTempWeb As Web
Dim myFolders As WebFolders
Dim myFolder As WebFolder
Dim myWebToDelete As String

Set myWeb = Webs.Open("C:\My Documents\My Webs")
Set myFolders = myWeb.RootFolder.Folders
myWebToDelete = "TempWeb"

For Each myFolder In myFolders
    If myFolder.IsWeb = True Then
        If myFolder.Name = myWebToDelete Then
            Set myTempWeb = Webs.Open(myFolder.Name)
            myTempWeb.Delete
        End If
    End If
Next
ActiveWebWindow.Close
End Sub


Edit-Methode

Öffnet FrontPage-kompatible Dateien in einem PageWindow-Objekt. Diese Dateien umfassen Dateiformate wie HTML, .css oder .asp. Um externe Dateien mit Formaten wie beispielsweise .gif, .txt oder Dateien ohne Dateinamenerweiterungen zur Vornahme von Änderungen zu öffnen, verwenden Sie die Open-Methode.

Anmerkung HTML-Dateien ohne Dateinamenerweiterung können mit der Edit-Methode nicht geöffnet werden.

Syntax

Ausdruck.Edit([ViewMode As FpPageViewMode = fpPageViewDefault]) As PageWindow

Ausdruck Ein Ausdruck, der ein File-Objekt zurückgibt.

ViewMode Optionaler Wert vom Typ FpPageViewMode. Verwenden Sie ihn, um eine Datei zum Bearbeiten in einer bestimmten Ansicht zu öffnen. Der Standard ist fpPageViewDefault. Der Standard bei HTML-Seiten ist fpPageViewNormal. Für Stylesheetseiten ist der Standard fpPageViewHTML.

Rückgabetyp

PageWindow

Hinweise

FrontPage-basierte externe Dateien können nur in einem PageWindow-Objekt bearbeitet werden.


Beispiel für die Edit-Methode

In diesem Beispiel wird gezeigt, wie die Edit-Methode zum Öffnen einer Datei zwecks Bearbeitung verwendet wird.

Anmerkung Zum Ausführen dieses Programms müssen Sie über ein geöffnetes Web verfügen, in dem sich eine Datei namens RedWines.htm befindet; alternativ können Sie diese Datei durch eine Datei Ihrer Wahl ersetzen.

Private Sub ModifyFile()
Dim myFile As WebFile

Set myFile = ActiveWeb.RootFolder.Files("RedWines.htm")

myFile.Edit
End Sub


LocateFile-Methode

Gibt das angegebene WebFile-Objekt zurück.

Syntax

Ausdruck.LocateFile(String)

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

String Erforderliches Argument vom Typ WebFile. Als Standardwert gilt der Dateianteil des URLs.

Rückgabetyp

String


Beispiel für die LocateFile-Methode

In diesem Beispiel wird eine Datei im Stammverzeichnis des Webs gesucht, und diese Datei wird in den Bearbeitungsmodus versetzt.

Anmerkung Sie müssen über ein geöffnetes Web verfügen, in dem sich eine Datei mit Namen Zinfandel.htm befindet, oder Sie können alternativ eine Datei Ihrer Wahl verwenden.

Private Sub LocateAFile()
Dim myFile As WebFile

Set myFile = Webs(0).LocateFile("Zinfandel.htm")
myFile.Edit
End Sub

In den meisten Fällen verwenden Sie wahrscheinlich den gesamten URL für das Argument String der LocateFile-Methode. Beispielsweise kann sich eine Datei auf einer bestimmten Verzeichnisebene in der Ordnerhierarchie befinden, wie beispielsweise C:/Eigene Dateien/Eigene Webs/Rogue Cellars/Inventur/First_Qtr.htm, und Sie möchten die Datei First_Qtr.htm suchen. Immer wenn sich ein Ordner auf einer Verzeichnisebene unterhalb des Stammverzeichnisses des Webs befindet, verwenden Sie den gesamten URL, wie im nachstehenden Beispiel gezeigt.

Private Sub GetFile()
Dim myFile As String
Dim myFileFound As WebFile

myFile = _
    "C:/My Documents/My Webs/Rogue Cellars/Inventory/First_Qtr.htm"

Set myFileFound = _
    Webs(0).LocateFile(myFile)
End Sub

Es gibt allerdings auch einen schnelleren Weg. Wenn Sie beispielsweise eine Datei suchen möchten, die sich im Ordner Images im Stammverzeichnis des Webs befindet, können Sie eine relative Webadresse verwenden, indem Sie einen Schrägstrich gefolgt vom Unterordner und dem Dateinamen eingeben, wie in der nachstehenden Anweisung gezeigt.

Set myFileFound = _
    Webs(0).LocateFile("images/JPG/myJPGFileList.htm")

Anmerkung In einer relativen Webadresse können Sie keinen umgekehrten Schrägstrich (\) verwenden.


LocateFolder-Methode

Gibt das angegebene WebFolder-Objekt zurück.

Syntax

Ausdruck.LocateFolder(String)

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

String Erforderliches Argument vom Typ WebFolder. Als Standardwert gilt der Ordneranteil des URLs.

Rückgabetyp

String


Beispiel für die LocateFolder-Methode

In diesem Beispiel wird ein Ordner im Stammverzeichnis eines Webs gesucht.

Anmerkung Um diese Beispiele nachvollziehen zu können, müssen Sie über ein geöffnetes Web verfügen.

Private Sub LocateAFolder()
Dim myFolderFound As WebFolder

Set myFolderFound = Webs(0).LocateFolder("images")
End Sub

In den meisten Fällen verwenden Sie wahrscheinlich den gesamten URL für das Argument String der LocateFolder-Methode. Beispielsweise kann sich ein Ordner auf einer bestimmten Verzeichnisebene in der Ordnerhierarchie befinden, wie beispielsweise C:/Eigene Dateien/Eigene Webs/Rogue Cellars/Inventur/First_Quarter, und Sie möchten den Ordner First_Quarter suchen. Immer wenn sich ein Ordner auf einer Verzeichnisebene unterhalb des Stammverzeichnisses des Webs befindet, verwenden Sie den gesamten URL, wie im nachstehenden Beispiel gezeigt.

Private Sub GetFolder()
Dim myFolder As String
Dim myFolderFound As WebFolder

myFolder = _
    "C:/My Documents/My Webs/Rogue Cellars/Inventory/First_Quarter"

Set myFolderFound = _
    Webs(0).LocateFolder(myFolder)
End Sub

Es gibt allerdings auch einen schnelleren Weg. Wenn Sie beispielsweise einen Ordner Images suchen möchten, der sich im Stammverzeichnis des Webs befindet, können Sie eine relative Webadresse verwenden, indem Sie einen Schrägstrich gefolgt vom Namen des Unterordners eingeben, wie in der nachstehenden Anweisung gezeigt.

Set myFolderFound = Webs(0).LocateFolder("images/JPG")

Anmerkung In einer relativen Webadresse können Sie keinen umgekehrten Schrägstrich (\) verwenden.


LocatePage-Methode

Gibt ein PageWindow-Objekt für das angegebene Objekt zurück.

Syntax

Ausdruck.PageWindow(String, ViewMode)

Ausdruck Ein Ausdruck, der ein Application- oder Web-Objekt zurückgibt.

String Erforderliche Zeichenfolge vom Typ LocatePage. Eine Zeichenfolge, die den Dokument- oder Dateianteil des gesamten URLs repräsentiert. Hierbei kann es sich um einen absoluten URL handeln, wie in http://Webserver/Dokument und http://Webserver/Datei oder in file://Dateisystem/Dokument oder file://Dateisystem/Datei bei festplattenbasierten Webs. Standardwert ist der Dateianteil des URLs.

Anmerkung Die Begriffe „Dokument“ und „Datei“ beziehen sich auf zwei unterschiedliche Komponenten. Ein Dokument ist eine HTML-Datei, die von FrontPage gelesen werden kann, während es sich bei einer Datei um einen beliebigen Dateityp (lokal oder extern) handeln kann, der nicht unbedingt auf FrontPage basiert.

ViewMode Optionale Konstante vom Typ FpPageViewMode. Der Standardwert ist fpPageViewDefault. Weitere Informationen hierzu sowie eine Tabelle mit den FpPageViewMode-Konstanten finden Sie im Hilfethema zur ViewMode-Eigenschaft.

Rückgabetyp

PageWindow


Beispiel für die LocatePage-Methode

In diesem Beispiel wird eine Seite im Stammweb und in einem Unterweb aufgefunden.

Anmerkung Damit Sie diese Methode verwenden können, muss die Seite, die Sie in der Prozedur angeben, geöffnet sein. Zum Ausführen dieses Programms können Sie eine Seite mit Namen Zinfandel.htm erstellen oder diesen Namen durch den einer Seite Ihrer Wahl ersetzen. Es muss sich eine Kopie der Datei im Stammweb und eine Kopie hiervon in einem Unterweb befinden.

Private Sub LocatePages()
Dim myRootPage As PageWindow
Dim myWebPage As PageWindow

Set myRootPage = _
    Application.LocatePage("Zinfandel.htm", fpPageViewNormal)
Set myWebPage = _
    Webs(1).LocatePage("Zinfandel.htm", fpPageViewNormal)
End Sub


MakeAbs-Methode

Ändert das Application-Objekt in ein absolutes Objekt anstelle eines relativen Objekts. Weitere Informationen über absolute und relative URLs finden Sie unter Grundlegendes zur absoluten und relativen Adressierung.

Syntax

Ausdruck.MakeAbs(UrlBase, Url)

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

UrlBase Erforderliches Argument vom Typ Variant. Ein Basis-URL. Hierbei kann es sich um eines der folgenden Elemente handeln: eine Zeichenfolge oder ein Objekt vom Typ Web, WebFolder, WebFile, NavigationNode oder IHTMLDocument2.

Url Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den gesamten URL des Webs enthält. Hierbei kann es sich um einen beliebigen URL für ein Web handeln, wie beispielsweise http://Webserver/Ordner oder file://Dateisystem/Ordner bei festplattenbasierten Webs.

Rückgabetyp

String


Beispiel für die MakeAbs-Methode

In diesem Beispiel wird ein relativer URL in einen absoluten URL geändert.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web und eine Datei mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Rogue Cellars\Zinfandel.htm (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ einen anderen Web-URL oder eine andere Datei verwenden.

Private Sub MakeURLAbsolute()
Dim myBaseURL As Web
Dim myAbsAddress As String
Dim myLocalUrl As String

myBaseURL = Webs.Open("C:\My Webs")
myLocalUrl = "Zinfandel.htm"

myAbsAddress = MakeAbs(myBaseURL, myLocalUrl)
End Sub


MakeRel-Methode

Ändert das Application-Objekt in ein relatives Objekt anstelle eines absoluten Objekts. Weitere Informationen über absolute und relative URLs finden Sie unter Grundlegendes zur absoluten und relativen Adressierung.

Syntax

Ausdruck.MakeRel(UrlBase, Url)

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

UrlBase Erforderliches Argument vom Typ Variant. Ein Basis-URL. Hierbei kann es sich um eines der folgenden Elemente handeln: eine Zeichenfolge oder ein Objekt vom Typ Web, WebFolder, WebFile, NavigationNode oder IHTMLDocument2.

Url Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den gesamten URL enthält. Hierbei kann es sich um einen beliebigen URL für ein Web handeln, wie beispielsweise http://Webserver/Ordner oder file://Dateisystem/Ordner bei festplattenbasierten Webs.

Rückgabetyp

String


Beispiel für die MakeRel-Methode

In diesem Beispiel wird ein absoluter URL in einen relativen URL umgewandelt, dem aktiven Dokument wird unter Verwendung des relativen URLs ein Hyperlink hinzugefügt, und anschließend werden die Änderungen im aktiven Seitenfenster gespeichert.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Darüber hinaus müssen Sie über zwei Dateien verfügen, eine namens Zinfandel.htm und eine weitere namens Index.htm, die einen absoluten URL (der Standardstatus) aufweist. Alternativ können Sie auch mit einem anderen Web-URL und anderen Dateinamen arbeiten.

Private Sub MakeURLRelative()
Dim myFile As WebFile
Dim myFile2 As WebFile
Dim myBaseURL As Web
Dim myDoc As FPHTMLDocument
Dim myRelAddress As String
Dim myRelAddress2 As String

Set myBaseURL = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
Set myFile = myBaseURL.RootFolder.Files("Zinfandel.htm")
Set myFile2 = myBaseURL.RootFolder.Files("index.htm")
Set myDoc = myFile.Edit (fpPageViewNormal).Document

myRelAddress = MakeRel(myBaseURL, myFile2.Url)
myRelAddress2 = """" & myRelAddress & """"
Call myDoc.body.insertAdjacentHTML("BeforeEnd", "<a href=" _
    & myRelAddress2 & ">" & myRelAddress & "</a>")
ActivePageWindow.Save
End Sub


MakeWeb-Methode

Erstellt ein neues Web aus einem bereits vorhandenen Ordner. Informationen zum Erstellen eines neuen Webs ohne vorherige Erstellung eines Ordners finden Sie in den Erläuterungen zur Add-Methode.

Syntax

Ausdruck.MakeWeb(UserName, Password)

Ausdruck Ein Ausdruck, der ein WebFolder-Objekt zurückgibt.

UserName Optionales Argument vom Typ String. Der Logon-Name des Benutzers. Sie können mit dieser Option einen Standardbenutzernamen für das Web erstellen.

Password Optionales Argument vom Typ String. Das Kennwort des Benutzers. Sie können mit dieser Option ein Standardkennwort für das Web erstellen.

Rückgabetyp

Void


Beispiel für die MakeWeb-Methode

In diesem Beispiel wird aus dem vorhandenen Ordner Distributors ein neues Web erstellt. (Der Ordner Distributors ist ein Ordner im Web „Rogue Cellars“.)

Private Sub MakeWeb()
Dim myWeb As Web
Dim myFolder As WebFolder

Set myWeb = Webs("C:\My Webs\Rogue Cellars")
myWeb.Activate
Set myFolder = Active.RootFolder.Folders("Distributors")
myFolder.MakeWeb
End Sub


Move-Methode

Verschiebt das angegebene Objekt an eine bestimmte Speicheradresse, wobei es sich entweder um einen URL oder einen Navigationsknoten handeln kann. Während des Verschiebens an eine URL-Adresse können Sie wählen, ob Hyperlinks aktualisiert werden sollen, oder Sie können das Überschreiben einer Datei erzwingen, sofern das angegebene Objekt den gleichen Namen wie ein an der Zieladresse befindliches Objekt trägt.

Syntax 1: Verschiebt das angegebene Objekt von seinem aktuellen Speicherort an einen bestimmten URL.

Syntax 2: Verschiebt einen Navigationsknoten in der Navigationsstruktur von einer Adresse an eine andere.

Syntax 1

Ausdruck.Move(DestinationUrl als String, UpdateLinks als Boolean, ForceOverwrite als Boolean)

Ausdruck Ein Ausdruck, der ein File- oder Folder-Objekt zurückgibt.

DestinationUrl Erforderlich. Ein Wert vom Typ String. Der Ziel-URL, wie beispielsweise C:\Eigene Dateien\Eigene Webs\Adventure Works.

UpdateLinks Erforderlich. Ein Wert vom Typ Long. Legen Sie für dieses Argument True fest, wenn Hyperlinks während des Verschiebens aktualisiert werden sollen. Als Standardwert gilt False.

ForceOverwrite Erforderlich. Ein Wert vom Typ Long. Legen Sie für dieses Argument True fest, wenn das am Ziel-URL befindliche Objekt beim Verschieben mit einem Objekt gleichen Namens überschrieben werden soll. Als Standardwert gilt False.

Rückgabetyp

Void

Syntax 2

Ausdruck.Move(NodeCollection als NavigationNodes, [NewLeftSibling] als Object)

Ausdruck Ein Ausdruck, der ein NavigationNode-Objekt zurückgibt.

NodeCollection Erforderlich. Ein Wert vom Typ NavigationNodes. Die als Ziel anzugebende NavigationNodes-Auflistung.

NewLeftSibling Optionaler Wert vom Typ Objekt. Der Navigationsknoten, der der gleichgeordnete Knoten links des neuen Knotens in der Navigationsstruktur sein soll. Ohne Angabe dieses Objekts wird der Knoten auf die äußerst rechte Seite von NodeCollection verschoben.

Rückgabetyp

NavigationNode (der Knoten, nachdem er verschoben wurde)


Beispiel für die Move-Methode

Dieses Beispiel umfasst Code für beide Syntaxarten.

Syntax 1: Mit der folgenden Anweisung wird eine Datei von der einen Position in der Dateistruktur an eine andere verschoben.

myFile.Move("C:\My Documents\My Webs\Adventure Works\Images", _
    True, False)

Syntax 2: Im folgenden Beispiel wird ein Knoten von der fünften Position in der Navigationsstruktur an die vierte Position verschoben, indem der dritte Knoten als neuer gleichgeordneter Knoten links festgelegt wird.

Private Sub MoveNavNode()
Dim myNodes As NavigationNodes
Dim myNode As NavigationNode

Set myNodes = ActiveWeb.RootNavigationNode.Children
Set myNode = myNodes(4)

myNode.Move(myNodes, myNodes(2))
ActiveWeb.ApplyNavigationStructure
End Sub


Open-Methode

Öffnet das angegebene Objekt.

Syntax 1: Öffnet das angegebene WebFile-Objekt.

Syntax 2: Öffnet das angegebene Web-Objekt.

Syntax 1

Ausdruck.Open

Ausdruck Ein Ausdruck, der ein WebFile-Objekt zurückgibt.

Rückgabetyp

Void

Syntax 2

Ausdruck.Open(szWebUrl als String, [UserName als String], [Password als String])

Ausdruck Ein Ausdruck, der die Webs-Auflistung zurückgibt.

szWebUrl Erforderlicher Wert von Typ String. Der Basis-URL des Webs, wie beispielsweise C:\Eigene Webs. Hierbei kann es sich um jeden beliebigen absoluten URL handeln, wie z. B. http://Webserver oder file://Dateisystem bei festplattenbasierten Webs.

UserName Optionaler Wert vom Typ String. Der Anmeldename des Benutzers.

Password Optionaler Wert vom Typ String. Eine aus bestimmten Zeichen bestehende Zeichenfolge, deren Eingabe für den Zugriff auf das angegebene Web vorausgesetzt wird.

Rückgabetyp

Web


Beispiel für die Open-Methode

In diesem Beispiel wird das Web „Rogue Cellars“ sowie die Datei Sale geöffnet, und es werden folgende Aufgaben durchgeführt:

  • Der Datei wird Text hinzugefügt, indem eine Eigenschaft erstellt wird, die den Text aufnimmt.

  • Es erfolgt ein Zugriff auf das Page-Objektmodell mithilfe der ActiveDocument-Eigenschaft und der insertAdjacentText-Methode.

  • Der Seite wird Text hinzugefügt, indem die Eigenschaft mySaleProp durch den Textparameter in der insertAdjacentText-Methode ersetzt wird.

  • Microsoft FrontPage wird geschlossen.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen, oder Sie können alternativ einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub AddSaleText()
Dim myWeb As Web
Dim myFile As WebFile
Dim mySaleProp As String
Dim mySaleText As String

mySaleText = "Vintage Wines for Oktoberfest Sale!!!"
Set myWeb = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
Set myFile = ActiveWeb.RootFolder.Files("Sale.htm")

myFile.Properties.Add "SaleText", mySaleText
mySaleProp = myFile.Properties("SaleText")
myFile.Open
ActiveDocument.body.insertAdjacentText "BeforeEnd", mySaleProp
WebWindows.Close
End Sub


Publish-Methode

Veröffentlicht ein Web auf einem Webserver, also entweder auf einem Server, auf dem Microsoft Internet Information Services (IIS) ausgeführt wird, oder auf einem Personal Web Server.

Syntax

Ausdruck.Publish(DestinationUrl As String, [PublishFlags As FpWebPublishFlags], [UserName As String],[Password As String])

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

DestinationUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den gesamten Ziel-URL eines Webs enthält, wie beispielsweise http://wwwroot/Adventure Works. Hierbei kann es sich um einen beliebigen URL für ein Web handeln, also beispielsweise http://Webserver/Ordner oder file://Dateisystem/Ordner bei festplattenbasierten Webs.

PublishFlags Erforderliches Argument vom Typ Long. Die Aufzählung der Konstanten für Veröffentlichungs-Flags finden Sie in der folgenden Tabelle.

Konstante | Wert
FpPublishNone | 0
FpPublishIncremental | 1
FpPublishAddToExistingWeb | 2
FpPublishCopySubwebs | 4

UserName Optionales Argument vom Typ Variant. Der Name des Benutzers, der das Web veröffentlicht.

Password Optionales Argument vom Typ Variant. Das Kennwort des Benutzers.

Rückgabetyp

Void


Beispiel für die Publish-Methode

In diesem Beispiel wird das aktive Web veröffentlicht.

Anmerkung Wenn Sie Ihr Web in einem bereits vorhandenen Web veröffentlichen möchten, müssen Sie das Argument fpPublishAddToExistingWeb verwenden, andernfalls wird das Web nicht veröffentlicht. Wenn das Web, in dem Sie veröffentlichen möchten, jedoch noch nicht vorhanden ist, verwenden Sie nicht das Argument fpPublishAddToExistingWeb, weil das Web ansonsten ebenfalls nicht veröffentlicht wird.

Private Sub PublishMyWeb()
Dim myWeb As Web
Dim myBaseURL As String
Dim myPublishParam As FpWebPublishFlags

Set myWeb = Application.ActiveWeb
myBaseURL = "http://www.Adventure-Works.com"
myPublishParam = fpPublishAddToExistingWeb

myWeb.Publish(myBaseURL, myPublishParam)
End Sub


Quit-Methode

Beendet die Anwendung. Mit dieser Methode werden Änderungen, die Sie nicht zuvor mit den Befehlen Save (Speichern) oder SaveAs (Speichern unter) gespeichert haben, nicht gespeichert, sondern die aktive Anwendung wird unverzüglich beendet.

Syntax

Ausdruck.Quit

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die Quit-Methode

In diesem Beispiel wird die Anwendung beendet, ohne die Änderungen zu speichern, die vorgenommen wurden, nachdem die Befehle Save (Speichern) oder SaveAs (Speichern unter) zuletzt ausgeführt wurden.

Private Sub QuitApp()
    Application.Quit
End Sub


RecalcHyperlinks-Methode

Berechnet alle Metadaten auf dem Server für dieses Web neu. Mit dieser Operation werden die von FrontPage verwendeten Informationen im Hinblick auf alle Hyperlinks, Titel für Webseiten, Designs für Seiten usw. neu abgerufen.

Anmerkung Abhängig von der Menge der Metadaten auf dem Server kann diese Operation möglicherweise eine längere Zeit in Anspruch nehmen.

Syntax

Ausdruck.RecalcHyperlinks

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die RecalcHyperlinks-Methode

In diesem Beispiel werden die Hyperlinks für das aktive Web neu berechnet.

Private Sub RecalcLinks()
Dim myWeb As Web

Set myWeb = Application.ActiveWeb

myWeb.RecalcHyperlinks
End Sub


Refresh-Methode

Aktualisiert das angegebene Objekt.

Syntax 1: Aktualisiert das angegebene PageWindow-Objekt mit der Option zum Speichern von Änderungen.

Syntax 2: Aktualisiert das angegebene Web-Objekt.

Syntax 1

Ausdruck.Refresh([SaveChanges As Boolean][FetchAll])

Ausdruck Ein Ausdruck, der ein PageWindow-Objekt zurückgibt.

SaveChanges Ein optionales Argument vom Typ Boolean. Wird auf True gesetzt, um Änderungen zu speichern.

FetchAll Ein optionales Argument vom Typ Boolean. Wird auf True gesetzt, um alle Informationen zu allen Dokumenten zu erhalten, unabhängig von der Ansicht. Wenn diese Argument auf False gesetzt wird, findet es nur die Informationen die zur Unterstützung der aktuellen Ansicht notwendig sind. Wenn jedoch die Berichts- oder Hyperlinkansicht geöffnet sind, aktualisiert False alle Dokumente. Der Standardwert ist False.

Rückgabetyp

Void

Syntax 2

Ausdruck.Refresh

Ausdruck Ein Ausdruck, der ein Web-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die Refresh-Methode

Mit den folgenden Anweisungen werden das aktuelle Seitenfenster und das erste Seitenfenster des ersten Webs aktualisiert.

ActivePageWindow.Refresh
WebWindows(0).PageWindows(0).Refresh

Sie können die folgende Anweisung verwenden, um Änderungen zu speichern, die Sie möglicherweise an der Seite vorgenommen haben.

ActivePageWindow.Refresh(True)

Mit der folgenden Anweisung aktualisieren Sie das aktive Web und das erste Web.

ActiveWeb.Refresh
Webs(0).Refresh


RemoveWeb-Methode

Entfernt das Web-Objekt aus dem angegebenen WebFolder-Objekt.

Syntax

Ausdruck.RemoveWeb([UserName As String], [Password As String])

Ausdruck Ein Ausdruck, der ein WebFolder-Objekt zurückgibt.

UserName Optionales Argument vom Typ String. Der Anmeldename des Benutzers.

Password Optionales Argument vom Typ String. Das Kennwort des Benutzers.

Rückgabetyp

Void

Hinweise

Die RemoveWeb-Methode ist die Ergänzung der MakeWeb-Methode. Ebenso wie die MakeWeb-Methode, die Metadaten für das Web aus einem Ordner erstellt, entfernt die RemoveWeb-Methode die Metadaten für das Web aus einem Ordner, wobei jedoch der Ordner intakt bleibt. Hierin unterscheidet sich diese von der Delete-Methode für das Web-Objekt, mit der der gesamte Inhalt des angegebenen Webs entfernt wird.


Beispiel für die RemoveWeb-Methode

In diesem Beispiel wird ein Web aus einem Ordner entfernt. Der Ordner und dessen Inhalt bleiben intakt, jedoch handelt es sich bei dem Ordner nicht länger um ein Web.

Anmerkung Sie müssen Zugriff auf das Web haben, das den geöffneten Ordner enthält.

Private Sub WebRemove()
Dim myFolders As WebFolders
Dim myFolder As WebFolder

Set myWebFolders = Webs(0).RootFolder.Folders

For Each myFolder In myFolders
 If myFolder.Name = "TempWeb" Then
  myFolder.RemoveWeb
  Exit For
 End If
Next
End Sub


Run-Methode

Führt das bezeichnete Microsoft Visual Basic-Makro aus. Sie können die Run-Methode verwenden, um in Microsoft FrontPage eine angegebene Prozedur auszuführen. Sie können die Run-Methode auch aus der Prozedur eines ActiveX-Steuerelements heraus verwenden, das Anweisungen ausführt, mit denen ein FrontPage-basiertes Web abgefragt oder geändert wird.

Anmerkung: Sie können mit der Run-Methode keine Parameter an eine Prozedur übergeben. Verwenden Sie die Call-Anweisung, um Parameter an eine Prozedur zu übergeben.

Syntax

Ausdruck.Run(MacroName As String)

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

MacroName Erforderliches Argument vom Typ String. Der Name des Makros, des Add-Ins oder des Skripts.

Rückgabetyp

Void


Beispiel für die Run-Methode

In diesem Beispiel wird ein Makro aus einer anderen Prozedur ausgeführt.

Anmerkung Zum Ausführen dieses Beispiels müssen Sie über ein Web mit Namen „Rogue Cellars“ verfügen, oder Sie können alternativ anstelle des Webs „Rogue Cellars“ ein anderes Web verwenden. Kopieren Sie die folgenden Prozeduren in ein Codemodul, und führen Sie StartMacro aus.

Private Sub StartMacro()
Dim myMacro As String

myMacro = "OpenRogueCellars"
Run (myMacro)
End Sub

Sub OpenRogueCellars()
Dim myWeb As Web

Set myWeb = Webs.Open("C:\My Webs\Rogue Cellars")
End Sub


Save-Methode

Speichert ein PageWindow-Objekt.

Syntax

Ausdruck.Save(ForceOverwrite)

Ausdruck Ein Ausdruck, der ein PageWindow-Objekt zurückgibt.

ForceOverwrite Optionaler Wert vom Typ Boolean. Das Argument ForceOverwrite kann verwendet werden, um eine vorhandene Datei zu überschreiben. Als Standardwert gilt True.

Rückgabetyp

Void


SaveAs-Methode

Speichert das angegebene PageWindow-Objekt am Ziel-URL.

Syntax

Ausdruck.SaveAs(DestinationUrl, ForceOverwrite)

Ausdruck Ein Ausdruck, der ein PageWindow-Objekt zurückgibt.

DestinationUrl Erforderliches Argument vom Typ String. Eine Zeichenfolge, die den gesamten URL des Webs enthält, wie beispielsweise C:\Eigene Dateien\Eigene Webs\Adventure Works\index.htm. Hierbei kann es sich um einen beliebigen URL für ein Web handeln, also beispielsweise http://Webserver/Ordner/Datei oder file://Dateisystem/Ordner/Datei bei festplattenbasierten Webs.

ForceOverwrite Optionales Argument vom Typ Boolean. Als Standardwert gilt False.

Rückgabetyp

Void


Beispiel für die SaveAs-Methode

In diesem Beispiel wird eine vorhandene Datei unter einem neuen Namen in einem anderen Web gespeichert. (Hierbei ist es nicht notwendig, den Namen der Datei zu ändern.) Das Programm aktiviert zunächst das Containerweb und öffnet dann die Datei, sodass für die Datei ein Seitenfenster eingerichtet wird. Das Seitenfenster wird einer Variablen zugewiesen, und es wird unter einem neuen Namen in einem anderen Web gespeichert.

Anmerkung Im Ordner C:\Eigene Webs muss sich eine Datei mit Namen Zinfandel.htm befinden. Sie können jedoch auch den Namen der Datei im Programm ändern, damit dieser dem einer in Ihrem Web vorhandenen Datei entspricht.

Private Sub SaveAsNewFile()
Dim myFile As WebFile
Dim myPageWindow As PageWindow

Webs.("C:\My Webs").Activate
Set myFile = ActiveWeb.RootFolder.Files("Zinfandel.htm")
myFile.Open
Set myPageWindow = ActivePageWindow
myPageWindow.SaveAs ("C:\My Webs\Rogue Cellars\Zinfandel Sale.htm")
myPageWindow.Close
End Sub


UndoCheckout-Methode

Setzt das angegebene WebFile-Objekt im Quellcodeverwaltungsprojekt in den vorherigen Zustand zurück.

Anmerkung Bevor Sie diese Methode verwenden können, müssen Sie über ein Quellcodeverwaltungsprojekt verfügen. Informationen über Quellcodeverwaltungsprojekte finden Sie unter Verwalten von Quellcodeverwaltungsprojekten.

Syntax

Ausdruck.UndoCheckout()

Ausdruck Ein Ausdruck, der ein WebFile-Objekt zurückgibt.

Rückgabetyp

Void


Beispiel für die UndoCheckout-Methode

In diesem Beispiel wird eine Datei wieder eingecheckt und so in ihren vorherigen Zustand zurückversetzt (den Zustand vor dem Auschecken). Die Datei muss Teil eines Quellcodeverwaltungsprojekts sein.

Anmerkung Zum Ausführen dieser Prozedur müssen Sie über ein Quellcodeverwaltungsprojekt mit einem Web verfügen, in dem ein Webfenster geöffnet ist und das eine Datei mit Namen Zinfandel.htm enthält. Alternativ können Sie auch ein Web und eine Datei Ihrer Wahl verwenden.

Private Sub UndoCheckout()
Dim myWeb As Web

Set myWeb = ("C:/My Webs/Rogue Cellars")
myWeb.RootFolder.Files("Zinfandel.htm").UndoCheckout
End Sub


Application-Objekt

Application-Objekt

Repräsentiert die Microsoft FrontPage-Anwendung. Das Application-Objekt umfasst Eigenschaften und Methoden, mit denen Objekte der obersten Ebene zurückgegeben werden. Beispielsweise gibt die ActiveDocument-Eigenschaft ein Dokumentobjekt zurück, das auf das FrontPage-Objektmodell verweist, das mit Microsoft Internet Explorer, Version 4.0 und höher, kompatibel ist.

Verwenden des Application-Objekts

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Sie können die Application-Eigenschaft eines beliebigen Objekts in FrontPage verwenden. Im folgenden Beispiel werden die Anmeldedaten des aktuellen Benutzers geprüft und die entsprechenden Sicherheitseinstellungen für das aktive Web-Objekt vorgenommen.

Private Sub GetLogonName()
Dim myWeb As Web
Dim currLogonName As String
Dim userSecurityLevel As Integer

Set myWeb = ActiveWeb
CurrentLogonName = myWeb.Application.UserName

If CurrentLogonName = “Guest”
    userSecurityLevel = 10
Else
    Call CheckUserName(currLogonName)
End If
End Sub

Viele der Eigenschaften und Methoden, die die am häufigsten verwendeten Benutzerschnittstellenobjekte zurückgeben, wie beispielsweise die ActiveDocument-Eigenschaft, können ohne den Objektbezeichner Application verwendet werden. Anstatt also beispielsweise Application.ActiveDocument.Title zu schreiben, können Sie ActiveDocument.Title schreiben. Eigenschaften und Methoden, die ohne den Objektbezeichner Application verwendet werden können, werden als „global“ betrachtet. Zum Anzeigen der globalen Eigenschaften und Methoden im Objektkatalog klicken Sie oben in der Liste im Feld Klassen des Objektkatalogs auf <Global>.

Hinweise

Wenn Sie für die Steuerung von FrontPage von einer anderen Anwendung aus auf Automatisierung zurückgreifen möchten, verwenden Sie die CreateObject- oder die GetObject-Funktion, um ein FrontPage-Application-Objekt zurückzugeben. Mit dem folgenden Beispiel aus Microsoft Word Visual Basic für Applikationen wird FrontPage gestartet, ein vorhandenes Web geöffnet und das Web dann geschlossen.

Private Sub StartFrontPage()
Dim myNewFP As Variant

Set myNewFP = CreateObject("FrontPage.Application")
myNewFP.Webs.Open ("C:\MyWebs\Adventure Works")
myNewFP.Webs.Close "(C:\MyWebs\Adventure Works")
Set myNewFP = Nothing
End Sub


MetaTags-Auflistungsobjekt

Ein Datenfeld mit PropertyKey/Value-Paaren. Jedes MetaTag-Objekt steht für ein Metatag, das sich auf einer HTML-Seite in Microsoft FrontPage befindet. Die MetaTags-Auflistung ist ein Mitglied des WebFile-Objekts.

Anmerkung Metatags, die von FrontPage erzeugt werden, wie beispielsweise Metatags für ein Design oder einen Zierrahmen, werden in der MetaTags-Auflistung nicht angezeigt. Die MetaTags-Auflistung wird erst vererbt, nachdem die Datei gespeichert wurde. Wenn Sie einer Seite beispielsweise mithilfe der HTML-Ansicht oder programmgesteuert durch Nutzung des Page-Objektmodells in Microsoft Visual Basic für Applikationen ein neues Metatag hinzufügen, können Sie die PropertyKey/Value-Paare erst anzeigen, nachdem Sie die Seite gespeichert haben. Um im META-Verzeichnis Platz zu sparen, können Sie die Speicherung von Metatags mit folgenden Methoden deaktivieren:

  • Legen Sie den Schlüssel DisableMetaTagStore auf einer „pro Dienst“-Basis fest.

  • Legen Sie den Schlüssel DisableMetaTagStore als globale Einstellung unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\All Ports fest.

  • Legen Sie die Eigenschaft vti_disablemetatagstore fest.

Der Schlüssel DisableMetaTagStore funktioniert auf die gleiche Weise wie andere Servereinstellungen. Weitere Informationen über Servereinstellungen finden Sie im Resource-Kit für Servererweiterungen.

Verwenden der MetaTags-Auflistung

Verwenden Sie die MetaTags-Eigenschaft, um die MetaTags-Auflistung zurückzugeben.

Anmerkung zu HTML In den Metadaten für FrontPage kann das Attribut „HTTP-EQUIV“ anstelle des Attributs „NAME“ verwendet werden. FrontPage verwendet den Wert des Attributs „HTTP-EQUIV“ nicht im Vorspann von Antwortnachrichten. Die Syntax für Metadaten ist die Folgende:

<META
CONTENT=description
HTTP-EQUIV=text
NAME=text
TITLE=text
URL=url
>

Sie können auch eine Liste der im aktiven Web vorhandenen Metatags zurückgeben, indem Sie über den Stammordner des ActiveWeb-Objekts auf die Dateistruktur zugreifen, wie im folgenden Beispiel gezeigt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie ein Formular mit einem Textfeld namens txtMetaTags (als mehrzeiliges Textfeld festlegen) sowie einer Befehlsschaltfläche namens cmdGetMetaTagInfo erstellen und das Beispiel in das Codefenster kopieren.

Private Sub cmdGetMetaTagInfo_Click()
Dim myWeb As Web
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myMetaTags As MetaTags
Dim myMetaTag As Variant
Dim myFileName As String
Dim myMetaTagName As String
Dim myReturnInfo As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myWeb
    For Each myFile In myFiles
        Set myMetaTags = myFile.MetaTags
        For Each myMetaTag In myMetaTags
            myFileName = myFile.Name
            myMetaTagName = myMetaTag
            myReturnInfo = myFileName & ": " & myMetaTagName
            txtMetaTags.Text = txtMetaTags.Text & myReturnInfo
        Next
    Next
    txtMetaTags.SetFocus
    txtMetaTags.CurLine = 0
End With
End Sub

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Mit der folgenden Anweisung wird das Application-Objekt zurückgegeben.

myAddInsCount = ActiveWeb.RootFolder.Files(0).MetaTags.Application

Verwenden Sie die Count-Eigenschaft, um die Anzahl der MetaTag-Objekte in der Auflistung zurückzugeben. Mit der folgenden Anweisung wird die Anzahl der MetaTag-Objekte in der zehnten Datei des ActiveWeb-Objekts zurückgegeben.

myMetaTagCount = ActiveWeb.RootFolder.Files(9).MetaTags.Count

Verwenden Sie Items(index), wobei index der PropertyKey-Wert (als String) eines Elements in der MetaTags-Auflistung ist, um das PropertyKey/Value-Paar zurückzugeben. Im folgenden Beispiel wird das Programmkennungs-Tag aus den Metatags in der ersten Datei des ActiveWeb-Objekts zurückgegeben.

myMetaTagOne = ActiveWeb.RootFolder.Files(0).MetaTags("ProgId")

Häufig verwendete PropertyKey-Werte sind „generator“ und „progid“. Weitere Informationen über PropertyKey-Werte finden Sie in der Tabelle im Hilfethema zum Properties-Objekt.

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Dateicontainer der MetaTags-Auflistung zurückgeben möchten. Im folgenden Beispiel wird die Url-Eigenschaft des WebFile-Containerobjekts zurückgegeben, das mit den Metatags der ersten Datei im ActiveWeb-Objekt verbunden ist.

myMetaTagParent = _
    ActiveWeb.RootFolder.Files(0).MetaTags.Parent.Url


NavigationNode-Objekt

Repräsentiert einen Knoten in der Navigationsstruktur eines Webs. Das NavigationNode-Objekt ist ein Mitglied der NavigationNodes-Auflistung. Innerhalb der NavigationNodes-Auflistung werden einzelne NavigationNode-Objekte indiziert, wobei der Index mit Null beginnt.

Wichtig Über das NavigationNode-Objekt können Sie auf alle anderen Navigationsknoten in einem Web zugreifen. Das RootNavigationNode-Objekt, das standardmäßig jedes Mal erstellt wird, wenn Sie ein neues Web erstellen, liefert die Basis für die Navigationsstruktur, auf die über die Children-Eigenschaft zugegriffen wird. Der erste untergeordnete Knoten der Navigationsstruktur ist normalerweise die Homepage des Webs, auf die über die HomeNavigationNode-Eigenschaft zugegriffen werden kann. Der erste untergeordnete Knoten des Stammnavigationsknotens kann jedoch jede beliebige Seite sein, und dieser muss nicht unbedingt ein HomeNavigationNode-Objekt enthalten.

Verwenden des NavigationNode-Objekts

Sie können die NavigationNode-Eigenschaft verwenden, um das NavigationNode-Objekt zurückzugeben. Im folgenden Beispiel wird eine Liste der Navigationsknotenbeschriftungen für das WebFile-Objekt der WebFiles-Auflistung zusammengestellt.

Private Sub GetNavigationNode()
Dim myWeb As Web
Dim myWebFiles As WebFiles
Dim myWebFile As WebFile
Dim myNavNodeLabel As String
Dim myLabel As String

On Error Resume Next

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myFiles
    For Each myFile In myFiles
        myLabel = myFile.NavigationNode.Label
        If Err <> 0 Then Exit Sub
        myNavNodeLabel = myNavNodeLabel & myLabel & vbCRLF
    Next
End With
End Sub

Mit der Children-Eigenschaft wird die Auflistung der untergeordneten Knoten innerhalb der Navigationsstruktur eines Webs zurückgegeben. Mit der folgenden Anweisung wird die Anzahl der untergeordneten Knoten innerhalb der Navigationsstruktur des aktiven Webs zurückgegeben.

myNavChildrenCount _
    = ActiveWeb.RootFolder.Files(0).NavigationNode.Children.Count

Verwenden Sie Children(Index), wobei Index die Indexnummer des Navigationsknotenelements ist, um ein einzelnes NavigationNode-Objekt zurückzugeben. Mit der folgenden Anweisung wird der Dateiname des ersten Navigationsknotens in der NavigationNodes-Auflistung zurückgegeben.

myNavNodeName _
    = ActiveWeb.RootFolder.Files(0).NavigationNode.Children(0).File.Name

Mit der File-Eigenschaft wird das File-Objekt zurückgegeben, das mit dem NavigationNode-Objekt in Verbindung steht. Mit der folgenden Anweisung wird True zurückgegeben, wenn die Datei geöffnet ist.

myNavFile = ActiveWeb.RootFolder.Files(3).NavigationNode.File.IsOpen

Mit der Home-Eigenschaft wird das Home-Objekt zurückgegeben, das mit dem aktuellen Navigationsknoten verbunden ist, und es werden Verweise auf Informationen wie die Eigenschaften Children, File, Label, Next, Prev sowie andere Eigenschaften der Homepage erstellt. Mit der folgenden Anweisung wird der URL der Home-Eigenschaft des NavigationNode-Objekts zurückgegeben.

myHomePageUrl _
    = ActiveWeb.RootFolder.Files(5).NavigationNode.Home.Url

Sie können die Label-Eigenschaft zurückgeben, um den Text festzulegen oder zurückzugeben, der für Schaltflächen in der Navigationsstruktur oder als Text in einer Navigationsleiste verwendet werden kann. Im folgenden Beispiel wird die Beschriftung für die Homepage zurückgegeben.

myLabel = ActiveWeb.RootFolder.Files(0).NavigationNode.Label

Verwenden Sie die Eigenschaften Next, Parent, Prev oder Url, um Navigationsknoten zurückzugeben, die mit der angegebenen Eigenschaft verbunden sind. Im folgenden Beispiel wird der URL zurückgegeben, der mit dem vorherigen NavigationNode-Objekt verbunden ist.

myPrevNode = ActiveWeb.RootFolder.Files(1).NavigationNode.Prev.Url

Verwenden Sie die Web-Eigenschaft, um das Web-Objekt zurückzugeben, das mit dem aktuellen Navigationsknoten verbunden ist. Im folgenden Beispiel wir das Web-Objekt des aktuellen Navigationsknotens zurückgegeben.

myNavNodeWeb = _
    ActiveWeb.RootFolder.Files(2).NavigationNode.Web.Url

Verwenden Sie die Move-Methode, um einen Navigationsknoten von einem untergeordneten Knoten an einen anderen zu verschieben. Im folgenden Beispiel wird ein Navigationsknoten an eine untergeordnete Position auf einem gleichgeordneten Knoten im gleichen Web verschoben.

Private Sub MoveNavNode()
Dim myNodes As NavigationNodes
Dim myNode As NavigationNode

Set myNodes = ActiveWeb.RootNavigationNode.Children
Set myNode = myNodes(4)

myNode.Move myNodes, myNodes(2)
ActiveWeb.ApplyNavigationStructure
End Sub


NavigationNodes-Auflistungsobjekt

Eine Auflistung der NavigationNode-Objekte innerhalb der Navigationsstruktur eines Microsoft FrontPage-basierten Webs. Jedes NavigationNode-Objekt steht für einen Verweis auf eine Seite in einem Web. Das NavigationNode-Objekt ist ein Mitglied der NavigationNodes-Auflistung.

Verwenden des NavigationNodes-Objekts

Verwenden Sie die NavigationNode-Eigenschaft, um das NavigationNode-Objekt für ein WebFile-Objekt zurückzugeben. Weitere Informationen über das Zurückgeben einer Auflistung untergeordneter Knoten innerhalb der Navigationsstruktur eines Webs finden Sie im Hilfethema zur Children-Eigenschaft. Im folgenden Beispiel wird eine Liste der Navigationsbeschriftungen erstellt, die mit dem jeweilgen NavigationNode-Objekt in der NavigationNodes-Auflistung verbunden sind. Die Prozedur wird beendet, wenn das Ende der Navigationsstruktur erreicht wird.

Private Sub GetNavigationNode()
Dim myWeb As Web
Dim myWebFiles As WebFiles
Dim myWebFile As WebFile
Dim myNavNodeLabel As String
Dim myLabel As String

On Error Resume Next

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myFiles
    For Each myFile In myFiles
        myLabel = myFile.NavigationNode.Label
        If Err <> 0 Then Exit Sub
        myNavNodeLbl = myNavNodeLabel & myLabel & vbCRLF
    Next
End With
End Sub

Verwenden Sie Children(Index), wobei Index die Indexnummer eines Elements in der Auflistung der untergeordneten Knoten ist, um ein einzelnes NavigationNode-Objekt zurückzugeben. In diesem Beispiel wird das erste NavigationNode-Objekt in der Auflistung, die Homepage, zurückgegeben.

Set myNavNodeOne = ActiveWeb.RootNavigationNode.Children(0)

Verwenden Sie die Add-Methode, um der NavigationNodes-Auflistung ein NavigationNode-Objekt hinzuzufügen. Im folgenden Beispiel wird der äußerst rechten Position in der aktuellen Navigationsstruktur ein Navigationsknoten hinzugefügt.

Private Sub AddNewNavNode()
Dim myWeb As Web
Dim myNewNavNode As NavigationNode
Dim myNavChildren As NavigationNode

Set myWeb = ActiveWeb
Set myNavChildren = _
    myweb.rootfolder.Files(1).NavigationNode.Children
myNewNavNode = _
    myNavChildren.Add("C:\My Webs\Sale.htm", "Sale", fpStructRightmostChild)
myWeb.ApplyNavigationStructure
End Sub

Anmerkung Nachdem Sie alle gewünschten Änderungen an Ihrer Navigationsstruktur vorgenommen haben, müssen Sie die Änderungen mithilfe der ApplyNavigationStructure-Methode zuweisen, damit die Navigationsstruktur in FrontPage aktualisiert wird.


PageWindow-Objekt

Repräsentiert eine offene Editor-Sitzung und kapselt das Page-Objektmodell von Microsoft FrontPage ein, das mit dem Dokumentobjektmodell für Microsoft Internet Explorer, Version 4.0 und höher, kompatibel ist. Das PageWindow-Objekt ist ein Mitglied der PageWindows-Auflistung und repräsentiert alle offenen Seitenfenster im angegebenen Web. Innerhalb der PageWindows-Auflistung sind einzelne PageWindow-Objekte beginnend mit Null indiziert.

Anmerkung Sie können beim Zugriff auf ein PageWindow-Objekt die Indexnummer auch durch die Caption-Eigenschaft des PageWindow-Objekts ersetzen. Die folgenden Anweisungen geben das PageWindow-Objekt für ein offenes Seitenfenster zurück, das über die Titelzeile C:\Eigene Webs\Rogue Cellars\Zinfandel .htm) verfügt.

Set myPageWindow = ActiveWebWindow.PageWindow("Zinfandel.htm")
Set myPageWindow = WebWindows(0).PageWindow("Zinfandel.htm")

Verwenden des PageWindow-Objekts

Verwenden Sie PageWindows(Index), wobei Index die Indexnummer des Seitenfensterelements ist, um ein einzelnes PageWindow-Objekt zurückzugeben. Mit der folgenden Anweisung wird der Datei-URL des ersten Seitenfensters in der PageWindows-Auflistung zurückgegeben.

myPageOne = WebWindows(0).PageWindows(0).Document.Url

Verwenden Sie die ActiveFrameWindow-Eigenschaft, um den aktiven Frame eines PageWindow-Objekts zurückzugeben. Mit der folgenden Anweisung wird das ActiveFrameWindow-Objekt zurückgegeben.

Anmerkung Der aktive Frame ist der Frame, der aktuell den Fokus besitzt; in FrontPage wird der aktive Frame durch einen blauen Rahmen gekennzeichnet.

Set myActiveFrame _
    = WebWindows(1).ActivePageWindow.ActiveFrameWindow

Verwenden Sie die FrameWindow-Eigenschaft, um ein IHTMLWindow2-Objekt zurückzugeben, das dann verwendet werden kann, um die Frames-Auflistung und den Inhalt jeder Seite in der Frames-Auflistung zurückzugeben.

myFrameWindow = WebWindows(0).ActivePageWindow.FrameWindow

Verwenden Sie die Document-Eigenschaft, um das Dokument zurückzugeben, das mit dem PageWindow-Objekt verbunden ist. Mit der folgenden Anweisung wird das Dokument zurückgegeben, das mit dem ersten PageWindow-Objekt des ersten WebWindow-Objekts verbunden ist.

Set myDoc = WebWindows(0).PageWindows(0).Document

Sie können die IsDirty-Eigenschaft verwenden, um festzustellen, ob das PageWindow-Objekt „dirty“ ist, d. h. ob es seit dem letzten Aktualisieren oder Speichern geändert wurde. Gibt True zurück, wenn das PageWindow geändert wurde. Im folgenden Beispiel wird das PageWindow-Objekt gespeichert, wenn das erste Element in der PageWindows-Auflistung geändert wurde.

Private Sub CheckPageWindowIsDirty()
Dim myPageWin As PageWindow

Set myPageWin = WebWindows(0).PageWindows(0)

If myPageWin.IsDirty = True Then
    myPageWin.Save
End If
End Sub

Sie können die ViewMode-Eigenschaft verwenden, um die Ansicht für die Seite festzulegen, wie in folgender Anweisung gezeigt. Weitere Informationen zu den Aufzählungskonstanten, die für diese Eigenschaft verfügbar sind, finden Sie in der Tabelle unter der Beschreibung der ViewMode-Eigenschaft.

WebWindows(1).PageWindows(1).ViewMode = fpPageViewHtml


PageWindows-Auflistungsobjekt

Eine Auflistung von PageWindow-Objekten. Jedes PageWindow-Objekt repräsentiert eine offene Webseite in einem Microsoft FrontPage-Anwendungsfenster. Das PageWindow-Objekt ist ein Mitglied der PageWindows-Auflistung.

Verwenden des PageWindows-Objekts

Verwenden Sie die PageWindows-Eigenschaft, um die PageWindows-Auflistung zurückzugeben. Mit der folgenden Anweisung wird das PageWindows-Objekt an die Variable myPages zurückgegeben.

myPages = WebWindows(0).PageWindows

Verwenden Sie PageWindows(Index), wobei Index die Indexnummer eines Elements in der PageWindows-Auflistung ist, um ein einzelnes PageWindow-Objekt zurückzugeben. Mit der folgenden Anweisung wird das erste PageWindow-Objekt in der Auslistung zurückgegeben.

Set myPageWindow = WebWindows(0).PageWindows(0)

Verwenden Sie die Add-Methode, um der PageWindows-Auflistung ein Seitenfenster hinzuzufügen. Im folgenden Beispiel wird die angegebene Seite in myWebOne geöffnet und zur PageWindows-Auflistung hinzugefügt.

Dim myPageWindows As PageWindows
Set myPageWindows = ActiveWeb.WebWindows(0).PageWindows
myPageWindows.Add("C:\My Webs\myWebOne\bugrep.htm")

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt aus der PageWindows-Auflistung zurückzugeben. Im folgenden Beispiel wird das Application-Objekt aus der PageWindows-Auflistung zurückgegeben.

myAppName = WebWindows.PageWindows.Application.Name

Verwenden Sie die Close-Methode, um ein PageWindow-Objekt oder die Auflistung geöffneter PageWindow-Objekte zu schließen. Mit der folgenden Anweisung wird das vierte PageWindow-Objekt des ersten WebWindow-Objekts geschlossen.

WebWindows(0).PageWindows(3).Close

Verwenden Sie Close(Index), wobei Index die Indexnummer eines Elements in der PageWindows-Auflistung ist, um ein einzelnes PageWindow-Objekt zu schließen, wie in den folgenden Anweisungen gezeigt. Mit beiden Anweisungen wird das gleiche Seitenfenster geschlossen. In der ersten Anweisung wird das Seitenfenster unter Verwendung der Indexnummer in Verbindung mit der Close-Methode geschlossen, während in der zweiten Anweisung das Seitenfenster geschlossen wird, indem Sie die Indexnummer der Seite angeben, die Sie schließen möchten.

WebWindows(0).PageWindows.Close (2)
WebWindows(0).PageWindows(2).Close

Verwenden Sie Close(), um alle offenen PageWindow-Objekte in der PageWindows-Auflistung zu schließen. Mit der folgenden Anweisung werden alle geöffneten Seiten in der PageWindows-Auflistung geschlossen.

WebWindows(0).PageWindows.Close()

Verwenden Sie die Count-Eigenschaft, um die Gesamtanzahl aller Seitenfenster in der PageWindows-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Seitenfenster in der PageWindows-Auflistung zurückgegeben.

myPageCount = WebWindows(0).PageWindows.Count

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der PageWindows-Auflistung zurückgeben möchten. Mit der folgenden Anweisung wird unter Verwendung der Parent-Eigenschaft das WebWindow-Containerobjekt des ersten PageWindow-Objekts zurückgegeben.

Set myParent = ActiveWeb.WebWindows(0).PageWindows.Parent


Properties-Auflistungsobjekt

Eine Auflistung von Metadaten als Property-Objekte. Jedes Element in der Properties-Auflistung repräsentiert ein mit einem einzelnen Web-, WebFile- oder WebFolder-Objekt verbundenes Element. Weitere Informationen dazu finden Sie in der Tabelle der PropertyKeys im Hilfethema Verwenden der PropertyKeys. Wählen Sie ein Hilfethema aus der nachstehenden Liste, um direkt zu dem jeweiligen Hilfethema zu gelangen.

Verwenden des Properties-Objekts

Verwenden der Properties-Auflistung in einem Web

Verwenden von PropertyKeys

Verwenden des Properties-Objekts

Verwenden Sie die Add-Methode, um der Properties-Auflistung eine Eigenschaft hinzuzufügen. Mit der folgenden Anweisung wird der Properties-Auflistung ein Copyrighthinweis hinzugefügt.

ActiveWeb.Properties.Add "Copyright", _
    “Copyright 1999 by Rogue Cellars”)

Sie können auch Kategorien und Genehmigungsstufen hinzufügen oder entfernen.

Verwenden Sie die ApplyChanges-Methode, um ein Property-Objekt zuzuweisen, das der Properties-Auflistung hinzugefügt wurde. Mit den folgenden Anweisungen wird der Properties-Auflistung eine Copyright-Eigenschaft hinzufügt, und diese Eigenschaft wird zugewiesen.

ActiveWeb.Properties.Add "Copyright", _
    “Copyright 1999 by Rogue Cellars”)
ActiveWeb.Properties.ApplyChanges

Verwenden Sie die Count-Eigenschaft, um die Anzahl der Eigenschaften in der Properties-Auflistung zurückzugeben. Im folgenden Beispiel wird geprüft, ob sich die Anzahl der Eigenschaften in der Properties-Auflistung seit dem Hinzufügen und Zuweisen der Copyright-Eigenschaft zur Auflistung erhöht hat, und anschließend wird der Copyrighthinweis einer Webseite hinzugefügt.

Anmerkung   Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene  Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle des angegebenen Web-URLs auch einen anderen URL oder eine andere Datei verwenden.

Private Sub copyrightAdd()
Dim myWeb As Web
Dim myCopyright As String
Dim myCount As Integer
Dim myMessage As String

myCopyright = "Copyright 1999 by Rogue Cellars"
myCount = ActiveWeb.Properties.Count
myMessage = "No new properties have been added."

Set myWeb = Webs.Open("C:\My Webs\Rogue Cellars")
myWeb.Activate
ActiveWeb.Properties.Add "Copyright", myCopyright

If myCount <> ActiveWeb.Properties.Count – 1 Then
    MsgBox myMessage
    Exit Sub
End If

ActiveWeb.RootFolder.Files("Zinfandel.htm").Open
ActiveDocument.body.insertAdjacentText "BeforeEnd", _
    ActiveWeb.Properties("Copyright")
ActivePageWindow.Save
ActiveWeb.Close
End Sub

Verwenden Sie die Delete-Methode, um eine einzelne Eigenschaft zu löschen. Mit der folgenden Anweisung wird die Copyright-Eigenschaft aus der Properties-Auflistung gelöscht.

ActiveWeb.Properties.Delete("Copyright")

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der Properties-Auflistung zurückgeben möchten. Mit der folgenden Anweisung wird beispielsweise der URL des übergeordneten Webs zurückgegeben.

myParentURL  = ActiveWeb.Properties.Parent.Url

Verwenden der Properties-Auflistung in einem Web

Verwenden Sie Properties(index), wobei index der PropertyKey des Elements in der Properties-Auflistung ist, um eine einzelne Eigenschaft zurückzugeben. Im folgenden Beispiel wird der Wert von PropertyKey vti_hassearchbot zurückgegeben.

Private Sub CheckForSearchBot()
Dim myProperties As Properties
Dim myFoundSearchBot As Boolean

Set myProperties = ActiveWeb.Properties

With myProperties
    myFoundSearchBot = .Item("vti_hassearchbot")
End With
End Sub

Wichtig   Bei den Werten für Eigenschaften handelt es sich um Varianten, d. h. ein Wert kann vom Typ String oder vom Typ Boolean sein, oder es kann sich um eine Matrix handeln. Sie können die Funktion Typename() verwenden, um die Art des Eigenschaftswerts zu ermitteln.

Anmerkung   Wenn Sie das folgende Beispiel nachvollziehen möchten, müssen Sie ein Formular mit einem Textfeld mit Namen txtCategories erstellen. Beachten Sie darüber hinaus, dass myCategories in diesem Beispiel als Typ Variant deklariert ist. In einem der vorherigen Beispiele war myFoundSearchBot als vom Typ Boolean deklariert, wobei es jedoch auch als Typ String hätte deklariert werden können.

Private Sub GetWebPropertyCategories()
Dim myProperties As Properties
Dim myCategories As Variant
Dim myCategory As Variant
Dim txtCategories As String

Set myProperties = ActiveWeb.Properties

With myProperties
    myCategories = .Item("vti_categories")
    For Each myCategory In myCategories
        txtCategories = txtCategories & "|" & myCategory
    Next
End With
End Sub

Verwenden von PropertyKeys

Die Eigenschaftsschlüssel können ein wertvolles Tool für die Organisation von Informationen über Ihre Webs darstellen. Beispielsweise können Sie der Hauptliste der Kategorien Ihres Webs Kategorien hinzufügen.

Wichtig   Die Kategorienamen können der Kategorienliste zwar unter Verwendung von Groß- und Kleinschreibung hinzugefügt werden, sie werden auf der Benutzeroberfläche (User Interface - UI) jedoch nicht mit Groß- und Kleinschreibung angezeigt. Aus diesem Grund kann es vorkommen, dass ein Benutzer auf dem Client eine Kategorie wie beispielsweise „Web Administrators“ erstellt und auf dem Server bereits ein Duplikat dieser Kategorie mit der Schreibweise „web administrators“ existiert. In diesem Fall weist FrontPage beide Kategorien der Kategorie „web administrators“ zu und keine davon kann (auf der Benutzeroberfläche) aus dem Web gelöscht werden. Auf Programmierebene wird die Groß- und Kleinschreibung in den Fenstern Direktbereich und Lokal des Visual Basic-Editors korrekt dargestellt.

Im folgenden Beispiel wird zunächst den Eigenschaften des aktiven Webs eine Kategorie hinzugefügt, anschließend wird die Kategorie „Waiting“ aus der gleichen Liste (vti_categories) gelöscht und schließlich die neue Kategorie jeder Datei im aktiven Web hinzugefügt.

Anmerkung   Beim Erstellen einer neuen Kategorie müssen Sie die neue Kategorie erst dem Web hinzufügen, bevor Sie sie irgendeiner der Dateien hinzufügen können. Mit der Prozedur AddCategories wird dem Web eine neue Kategorie und mit der nächsten Prozedur, AddCategoryToFiles, die gleiche Kategorie allen Dateien im Web hinzugefügt.

Private Sub AddCategories()
Dim myWeb As Web
Dim myCategory(2) As String
Dim myItem As Variant

Set myWeb = ActiveWeb
myCategory(0) = "+web administrators"
myCategory(1) = "-waiting"
ActiveWeb.Properties("vti_categories") = myCategory
ActiveWeb.Properties.ApplyChanges

'List all of the items in vti_categories in the Immediate window
For Each myItem In myWeb.Properties("vti_categories")
    Debug.Print myItem
Next
End Sub

Private Sub AddCategoryToFiles()
Dim myWeb As Web
Dim myCategories(1) As String
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myItem As Variant

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files
myCategories(0) = "+web administrators"

For Each myFile In myFiles
    myFile.Properties("vti_categories") = myCategories
    myFile.Properties.ApplyChanges
    'List all the items in vti_categories in the Immediate window
    For Each myItem In myFile.Properties("vti_categories")
        Debug.Print myItem
    Next
Next
End Sub

Anmerkung   Sie können zwar neue Kategorien wie beispielsweise „web administrators“ erstellen, die nicht Bestandteil der Kategorien sind, die automatisch zusammen mit FrontPage installiert werden, diese Kategorien werden jedoch erst dann auf der Benutzeroberfläche (UI) angezeigt, wenn sie dem Web hinzugefügt wurden. Beachten Sie im vorstehenden Beispiel, dass die neue Kategorie erst dem Web hinzugefügt wurde und dadurch auf der UI angezeigt wird.

Die nachstehende Tabelle enthält ausführliche Informationen über die Eigenschaftsschlüssel, die in FrontPage 2000 zur Verfügung stehen. Beachten Sie, dass alle Eigenschaftsschlüssel in FrontPage mit „vti_“ beginnen. Es empfiehlt sich, den Eigenschaftsschlüsseln, die Sie hinzufügen möchten, einen Kurznamen wie beispielsweise eine Abkürzung des Namens Ihrer Organisation voranzustellen, um auf diese Weise zu verhindern, dass sich Benennungskonflikte mit anderen Eigenschaften ergeben.

Eigenschaftsschlüssel | Beschreibung | Berechtigung
vti_approvallevel | Die für die Seite festgelegte Genehmigungsstufe. Die verfügbaren Stufen sind „AssignedTo“, „ReviewStatus“ und „Categories“. | Lesen/Schreiben
vti_approvallevels | Liste der verfügbaren Genehmigungsstufen, die Dokumenten in einem Web zugewiesen werden können. Bei diesem Eigenschaftsschlüssel handelt es sich um eine Vektorzeichenfolge (oder eine aus Zeichenfolgen bestehende Matrix). Wird verwendet, um die webübergreifende Liste der bekannten „Prüfstati“ (auch als Genehmigungsstufen bezeichnet) aufzufüllen, die für ein Dokument festgelegt wurden. Die möglichen Genehmigungsstufen sind „AssignedTo“, „ReviewStatus“ und „Categories“. | Schreibgeschützt
vti_approvedby | Der authentifizierte Name der Person, die die Seite genehmigt hat. | Schreibgeschützt
vti_assignedby | Der authentifizierte Name der Person, die die Seite einem Benutzer zugewiesen hat. | Schreibgeschützt
vti_assigneddate | Das Datum, an dem die Seite zuletzt einem Benutzer zugewiesen wurde. | Schreibgeschützt
vti_assignedto | Der authentifizierte Name der Person, der die Seite zugewiesen wurde. | Schreibgeschützt
vti_author | Gibt den Namen des Autors im Format „String“ zurück. Die Bezeichnung des authentifizierten Autors, der Änderungen am Dokument vorgenommen hat oder gerade vornimmt. Anmerkung Diese Eigenschaft unterscheidet sich von der Author-Eigenschaft, die als Teil der Microsoft Office-Dokumenteneigenschaften gespeichert wird und vom Benutzer auf einen beliebigen Wert festgelegt werden kann. | Schreibgeschützt
vti_casesensitiveurls | Wird auf True festgelegt, wenn das Web auf einem Server veröffentlicht wird, der bei den URLs Groß- und Kleinschreibung unterscheidet, wie beispielsweise Server, auf denen UNIX ausgeführt wird. Wurde diese Eigenschaft auf True festgelegt, werden beispielsweise die Dateien meineDatei.htm und meineDatei.htm als zwei unterschiedliche Dateien betrachtet. | Schreibgeschützt
vti_categories | Die Hauptliste der Kategorien. Dieser Eigenschaftsschlüssel ist eine Vektorzeichenfolge (oder eine aus Zeichenfolgen bestehende Matrix), die für Metadaten sowohl auf Web- als auch auf Dokumentebene verwendet wird. Auf der Webebene enthält der Eigenschaftsschlüssel eine Liste aller bekannten Kategorien, die für das Web existieren. Auf der Dokumentebene enthält er eine Liste aller Kategorien, zu denen das angegebene Dokument gehört. Anmerkung Diese Kategorien werden automatisch immer dann aktualisiert, wenn eine Kategorie hinzugefügt oder auf irgendeine Weise geändert wird. | Lesen/Schreiben
vti_clientvercutoff | Diesen Eigenschaftsschlüssel können Sie verwenden, um eine Zeichenfolge für die Versionsgrenze festzulegen. Auf diese Weise wird vornehmlich in Mehrversionenumgebungen vorgegangen, um zu verhindern, dass ältere Versionen der Anwendung auf einem bestimmten Server ausgeführt werden. Weitere Informationen hierüber finden Sie im Resource-Kit für FrontPage-Servererweiterungen. | Lesen/Schreiben
vti_dataconns | Liste der Datenverbindungen, die von den Datenbankfunktionen in FrontPage verwendet werden. | Schreibgeschützt
vti_defaultcharset | Der standardmäßige Zeichensatz für das Web oder die Seite. | Schreibgeschützt
vti_defaultlanguage | Die Standardsprache für das Web oder die Seite. | Schreibgeschützt
vti_description | Stellt für den Benutzer ein mehrzeiliges Textfeld bereit, in das Kommentare eingegeben werden können. | Lesen/Schreiben
vti_donotpublish | Legen Sie diese Eigenschaft auf True fest, wenn die Seite als „Entwurf“ oder „Nicht zur Veröffentlichung“ gekennzeichnet ist. | Lesen/Schreiben
vti_filesize | Die Größe der Datei in Byte. | Schreibgeschützt
vti_generator | Dieser Eigenschaftsschlüssel entspricht dem „Generator“-Tag in einem HTML-Dokument. Der Wert des Eigenschaftsschlüssels vti_generator enthält den Namen der Anwendung, mit der das Dokument „generiert“ wurde und die sich möglicherweise von der Anwendung unterscheidet, die zum Bearbeiten der Seite aufgerufen wurde. Wenn Sie eine Seite beispielsweise in Microsoft Word erstellt oder bearbeitet haben und dann in Microsoft Visual Basic für FrontPage den Wert des Eigenschaftsschlüssels vti_generator für dieses Dokument abrufen, wird als Wert des Eigenschaftsschlüssels vti_generator „Microsoft Word“ zurückgegeben, und zwar auch dann, wenn der Prozeduraufruf von FrontPage erzeugt wurde. Gültige Werte sind „Microsoft Word“, „Microsoft Access“, „Microsoft FrontPage“ usw. Anmerkung Wenn der Eigenschaftsschlüssel vti_generator den Wert „Microsoft Word“ aufweist, setzen bei einem Designkonflikt die Word-Einstellungen die FrontPage-Einstellungen außer Kraft. | Schreibgeschützt
vti_globalpage | Markiert eine Seite als „global“, d. h. als Seite der obersten Ebene in der Navigationsstruktur, also auf der gleichen Ebene wie, jedoch nicht gleich der Homepage. | Lesen/Schreiben
vti_hasframeset | Dieser Eigenschaftsschlüssel wird auf True festgelegt, wenn die Seite Framesets enthält. Er wird beim Aufbau von Links für die Navigationsleiste verwendet. Wenn es sich bei der zu verknüpfenden Seite um ein Frameset handelt, wird für das Attribut „target“ des Links der Wert „_top“ erzwungen. Dies bewirkt, dass die neue Seite das aktuelle Frameset ersetzt, um zur Laufzeit rekursive Framesets zu verhindern. | Schreibgeschützt
vti_hasruntimebots | Wird auf True festgelegt, wenn sich auf der Seite Laufzeit-Bots befinden. | Schreibgeschützt
vti_htmlextensions | Eine verkettete Zeichenfolge mit den Erweiterungen, die zur Angabe einer Webdatei verwendet werden, wie beispielsweise htm.html.asp. | Schreibgeschützt
vti_httpdversion | Die FrontPage-Version, die auf dem httdp-Server ausgeführt wird. | Schreibgeschützt
vti_imagemapformat | Mit diesem Eigenschaftsschlüssel wird das vom serverseitigen Imagemap-Prozessor verwendete URL-Format festgelegt. Gültige Werte sind NCSA und CERN. Dieser Eigenschaftsschlüssel wird nur bei den Vorgängerversionen von FrontPage benötigt. In FrontPage 2000 werden clientseitige Imagemaps verwendet. | Lesen/Schreiben
vti_imagemapurlprefix | Legt den serverrelativen URL des serverseitigen Imagemap-Prozessors für das gewählte Imagemap-Format fest. Wenn der Wert des Eigenschaftsschlüssels vti_imagemapurlprefix auf eine leere Zeichenfolge ("") festgelegt wird, werden serverseitige Imagemaps automatisch von den FrontPage-Servererweiterungen verarbeitet. Bei anderen Formaten müssen Sie den Namen und die Speicheradresse des Imagemap-Prozessors angeben. Zum Angeben von clientseitigen Imagemaps legen Sie diese Variable auf eine leere Zeichenfolge fest. Weitere Informationen hierzu finden Sie im Resource-Kit für FrontPage-Servererweiterungen. | Lesen/Schreiben
vti_insecureserverurl | Ruft den http://-URL (ungesicherter URL) einer Website ab. Ermöglicht die Kompatibilität mit älteren Browsern, die möglicherweise nicht über sichere Browserfähigkeiten verfügen. Weitere Informationen hierzu finden Sie im Resource-Kit für FrontPage-Servererweiterungen. | Schreibgeschützt
vti_isbrowsable | Wird auf True festgelegt, wenn der Seitenordner durchsucht werden kann. Verwenden Sie Folder.IsBrowsable, um diesen Wert festzulegen. | Schreibgeschützt
vti_ischildweb | Wird auf True festgelegt, wenn der angegebene Ordner der Stammordner eines Unterwebs ist. Verwenden Sie Folder.MakeWeb und Folder.RemoveWeb, um diesen Eigenschaftsschlüssel zu ändern. | Schreibgeschützt
vti_isexecutable | Legen Sie diese Eigenschaft auf True fest, um sie zu aktivieren, wenn dieser Ordner auf dem Server mit der Kennzeichnung für ausführbaren Inhalt versehen wird. Verwenden Sie Folder.IsExecutable, um diesen Wert festzulegen. | Lesen/Schreiben
vti_isscriptable | Legen Sie diese Eigenschaft auf True fest, um Scripting für diesen Ordner zu ermöglichen. Verwenden Sie Folder.IsScriptable, um diesen Wert festzulegen. | Lesen/Schreiben
vti_longfilenames | Wird auf True festgelegt, wenn der Server Dateinamen unterstützt, die länger als das standardmäßige Dateiformat 8.3 sind. (Das Dateiformat 8.3 unterstützt nur 8 Zeichen umfassende Dateienamen mit einer drei Zeichen langen Erweiterung, wie beispielsweise Dat_name.txt.) | Schreibgeschützt
vti_metatags | Dieser Eigenschschaftenschlüssel entspricht dem Inhalt innerhalb der Metatags in einem HTML-Dokument. Die gesamten in diesem Eigenschaftsschlüssel enthaltenen Informationen werden der METAtags-Auflistung hinzugefügt. | Schreibgeschützt
vti_modifiedby | Der authentifizierte Name des Autors, der die Seite zuletzt geändert hat. | Schreibgeschützt
vti_navbuttonhomelabel | Die Grafikdatei, die mit der Schaltfläche für den Link zur Homepage verbunden ist. Anmerkung Diese Grafik wird dem Design entnommen, das mit der Datei verbunden ist, und kann nicht angepasst werden. | Lesen/Schreiben
vti_navbuttonhomelabeltext | Der Text, der vti_navbuttonhomelabel überlagert. Anmerkung Dieser Text kann vom Benutzer angepasst werden. | Lesen/Schreiben
vti_navbuttonlabeltext | Der Text, der vti_nvabuttonuplabel überlagert. Anmerkung Dieser Text kann vom Benutzer angepasst werden. | Lesen/Schreiben
vti_navbuttonnextlabel | Die Grafikdatei, die mit der Schaltfläche für den Link zur nächsten Seite in der Navigationsstruktur verbunden ist. Anmerkung Diese Grafik wird dem Design entnommen, das mit der Datei verbunden ist, und kann nicht angepasst werden. | Lesen/Schreiben
vti_navbuttonnextlabeltext | Der Text, der vti_navbuttonnextlabel überlagert. Anmerkung Dieser Text kann vom Benutzer angepasst werden. | Lesen/Schreiben
vti_navbuttonprevlabel | Die Grafikdatei, die mit der Schaltfläche für den Link zur vorherigen Seite in der Navigationsstruktur verbunden ist. Anmerkung Diese Grafik wird dem Design entnommen, das mit der Datei verbunden ist, und kann nicht angepasst werden. | Lesen/Schreiben
vti_navbuttonprevlabeltext | Der Text, der vti_navbuttonprevlabel überlagert. Anmerkung Dieser Text kann vom Benutzer angepasst werden. | Lesen/Schreiben
vti_navbuttonuplabel | Die Grafikdatei, die mit der Schaltfläche für den Link zu der Seite auf der nächstübergeordneten Ebene in der Navigationsstruktur verbunden ist. Anmerkung Diese Grafik wird dem Design entnommen, das mit der Datei verbunden ist, und kann nicht angepasst werden. | Lesen/Schreiben
vti_noclientimagemaps | Wird auf True gesetzt, wenn clientseitige Imagemaps nicht zulässig sind. | Schreibgeschützt
vti_nonnavpage | Wird auf True gesetzt, wenn die Seite nicht mit einem Navigationsknoten in der Navigationsstruktur verbunden ist. | Lesen/Schreiben
vti_nosourcecontrol | Wird auf True gesetzt, wenn das Web nicht als Quellcodeverwaltungsprojekt gespeichert wird. Wenn diese Eigenschaft auf True festgelegt ist, wird verhindert, dass die Datei der Quellcodeverwaltung hinzugefügt wird. Anmerkung Wenn bei einer Datei die vti_nosourcecontrol-Eigenschaft vorher auf False festgelegt und die Datei Bestandteil eines Quellcodeverwaltungsprojekts war, wird die Datei nicht aus dem Quellcodeverwaltungsprojekt entfernt, wenn die Eigenschaft später auf True festgelegt wird. | Lesen/Schreiben
vti_originator | Dieser Eigenschaftsschlüssel entspricht dem Metatag „originator“ in einem HTML-Dokument. Der Wert dieser Eigenschaft enthält den Namen der Anwendung, mit der das Dokument erstellt wurde. Sie sollten diesen Eigenschaftsschlüssel niemals mit dem Namen einer anderen Anwendung überschreiben. Der Eigenschaftsschlüssel vti_generator sollte verwendet werden, um nachzuverfolgen, mit welcher Anwendung die HTML-Seite zuletzt „generiert“ wurde. Durch einfaches Bearbeiten eines Dokuments in FrontPage wird der Wert des Eigenschaftsschlüssels vti_generator auf „Microsoft FrontPage“ geändert. Gültige Werte sind „Microsoft Word“, „Microsoft Access“, „Microsoft FrontPage“ usw. Anmerkung Wenn der Eigenschaftsschlüssel vti_generator den Wert „Microsoft Word“ aufweist, setzen bei einem Designkonflikt die Word-Einstellungen die FrontPage-Einstellungen außer Kraft. | Schreibgeschützt
vti_privatetext | Der Wert dieses Eigenschaftsschlüssels muss eine Ganzzahl sein. Als Standardwerte gelten „Null“ oder „nicht vorhanden“. Ein Wert, der nicht Null ist, bedeutet, dass die Seite keinem der Textindizes hinzugefügt wird. Dieser Eigenschaftsschlüssel funktioniert nur mit den in FrontPage integrierten Textindizes und wird von Microsoft Internet Information Services (IIS) nicht erkannt. | Lesen/Schreiben
vti_progid | Dieser Eigenschaftsschlüssel entspricht dem Metatag „progid“ in einem HTML-Dokument. Der Wert dieses Eigenschaftsschlüssels legt fest, mit welcher Anwendung das Dokument geöffnet wird, wenn ein Benutzer in Windows Explorer auf den Dateinamen des Dokuments klickt (oder doppelklickt). Gültige Werte sind „FrontPage.Editor.Document“, „Word.Document“, „Excel.Sheet“, „PowerPoint.Slide“, „Access.Application“. Anmerkung Wenn der Eigenschaftsschlüssel vti_generator den Wert „Microsoft Word“ aufweist, setzen bei einem Designkonflikt die Word-Einstellungen die FrontPage-Einstellungen außer Kraft. | Schreibgeschützt
vti_scriptlanguage | Gibt an, welche Skriptsprache auf dem Server aktiviert ist. | Schreibgeschützt
vti_secureserverurl | Ruft den https://-URL (gesicherten URL) einer Website ab. Liefert eine sichere Umgebung für vertrauliche Transaktionen über das Internet. Weitere Informationen hierzu finden Sie im Resource-Kit für FrontPage-Servererweiterungen. | Schreibgeschützt
vti_serveripaddress | Die IP-Adresse des Servers. Anmerkung Eine mit 127 beginnende IP-Adresse steht für einen lokalen Server. | Schreibgeschützt
vti_serverlanguage | Die Sprache des Betriebssystems. Wird für Lokalisierungszwecke verwendet. | Schreibgeschützt
vti_showhiddenpages | Wird auf True festgelegt, wenn verborgene Seiten angezeigt werden. | Schreibgeschützt
vti_sourcecontrolcheckedoutby | Der authentifizierte Name des Autors, der die Seite zuletzt ausgecheckt hat. | Schreibgeschützt
vti_sourcecontrolerror | Der zuletzt vom Quellcodeverwaltungssystem ausgegebene Fehler. Dieser Fehler wird den Metataginformationen hinzugefügt, wenn ein Fehler auftritt, während die Datei einem Quellcodeverwaltungsprojekt hinzugefügt wird. | Schreibgeschützt
vti_sourcecontrolproject | Der Name des Quellcodeverwaltungsprojekts. Bei einem Microsoft Visual SourceSafe-Projekt würde die Zeichenfolge das „$“- Symbol umfassen, wie in „$/meinProjekt“. | Schreibgeschützt
vti_sourcecontrolsystem | Der Wert dieses Eigenschaftsschlüssels bezeichnet die Art der Quellcodeverwaltung, die für dieses Web verwendet wird. Hierbei kann es sich um Microsoft Visual SourceSafe oder die Microsoft Frontpage Light Weight-Quellcodeverwaltung handeln. Gültige Werte für diese beiden Arten der Quellcodeverwaltung sind „VSS“ bzw. „LW“. Dieser Eigenschaftsschlüssel wird zu Beginn eines Quellcodeverwaltungsprojekts festgelegt. Weitere Informationen über Quellcodeverwaltungsprojekte finden Sie unter Verwalten von Quellcodeverwaltungsprojekten. | Schreibgeschützt
vti_sourcecontrolversion | Eine nummerierte Zeichenfolge, die die Version des verwendeten Quellcodeverwaltungssystems enthält. | Schreibgeschützt
vti_textextensions | Eine verkettete Zeichenfolge mit Erweiterungen, die allgemein verwendet werden, um Textdateien zu bezeichnen. Die verkettete Zeichenfolge könnte beispielsweise „.txt.rpt...“ enthalten. | Schreibgeschützt
vti_themedefault | Das standardmäßige Design des Webs. | Schreibgeschützt
vti_themesusecss | Wird auf True festgelegt, wenn für die Präsentation des Designs CSS verwendet wird. | Lesen/Schreiben
vti_timecreated | Der Zeitpunkt (Zeitstempel), zu dem die Seite erstellt wurde. Der Zeitstempel wird in UTC (Universal Time Coordinate)- oder Greenwich-Zeit angezeigt. | Schreibgeschützt
vti_timelastmodified | Der Zeitpunkt, zu dem die Seite zuletzt geändert wurde. Der Zeitstempel wird in UTC-Zeit angezeigt. Dieser Wert wird nur festgelegt, wenn der Autor die Seite direkt bearbeitet. | Schreibgeschützt
vti_timelastwritten | Der Zeitpunkt, zu dem die Seite zuletzt umgeschrieben wurde. Der Zeitstempel wird in UTC-Zeit angezeigt. | Schreibgeschützt
vti_-title | Der Wert des Textes zwischen den <TITLE>-Tags auf der Seite. | Schreibgeschützt
vti_usernames | Die Liste der bekannte Benutzernamen eines angegebenen Webs. | Schreibgeschützt
vti_webservertype | Der Typ des Webservers. Gültige Werte sind u. a. „MSIIS“ für Microsoft Internet Information Services und „PWS“ für Personal Web Server. | Schreibgeschützt
vti_welcomenames | Eine verkettete Liste mit Dateinamen, die als Dateinamen für die Homepage verwendet werden können, wie beispielsweise index.htm index.html default.htm. | Schreibgeschützt


System-Objekt

Repräsentiert die Microsoft FrontPage-Zugriffsfunktion für das System-Objekt und ermöglicht den Zugriff auf Informationen wie beispielsweise Betriebssystem, Bildschirmauflösung und Registrierungseinträge.

Verwenden des System-Objekts

Verwenden Sie die System-Eigenschaft, um das System-Objekt zurückzugeben. Mit der folgenden Anweisung wird der Name der aufrufenden Anwendung zurückgegeben.

mySysApp = System.Application.Name

Verwenden Sie die Eigenschaften Build und Version, um Angaben zum Aufbau und zur Version des Betriebssystems zurückzugeben.

myVer = System.Version
myBld = System.Build

Sie können die horizontale und vertikale Auflösung verwenden, um zu ermitteln, ob auf dem Clientcomputer eine Grafik angezeigt werden kann. Mit den folgenden Anweisungen werden die Einstellungen für die Auflösung zurückgegeben.

currHorizRes = System.HorizontalResolution
currVertRes = System.Vertical.Resolution

Verwenden Sie die OperatingSystem-Eigenschaft, um den Namen des aktuellen Betriebssystems zurückzugeben, wie in folgender Anweisung gezeigt.

thisOps = System.OperatingSystem

Verwenden Sie die Parent-Eigenschaft, um das übergeordnete Objekt des angegebenen Objekts zurückzugeben. Mit der folgenden Anweisung werden Informationen zum übergeordneten Objekt des System-Objekts zurückgegeben.

Private Sub GetSystemParentInfo()
Dim mySys As System
Dim mySysUserName As String

Set mySys = System

With mySys
    mySysUserName = .Parent.UserName
End With
End Sub

Verwenden Sie die LanguageDesignation-Eigenschaft, um eine aus drei Buchstaben bestehende Abkürzung für die vom Betriebssystem verwendete Sprache zurückzugeben. Mit der folgenden Anweisung wird „enu“ als Abkürzung für die Sprachbezeichnung der Sprache Englisch (US) zurückgegeben.

currSystemLanguage = System.LanguageDesignation

Verwenden Sie die Eigenschaft ProfileString(RegistrySection als String, RegistryKey als String[, Value als String]), um einen Eintrag in der Windows-Registrierung zurückzugeben oder festzulegen. Bei Verwendung ohne Parameter gibt die ProfileString-Eigenschaft standardmäßig folgenden Schlüssel zurück:

HKEY_CURRENT_USERS\Software\Microsoft\FrontPage

Die Parameter für die ProfileString-Eigenschaft sind:

  • RegistrySection, wobei RegistrySection eine Unterstruktur der Registrierung, wie beispielsweise HKEY_CURRENT_USER oder HKEY_LOCAL_MACHINE, ist.

  • RegistryKey, wobei RegistryKey die nächste Ebene unterhalb des Abschnitts oder der Unterstruktur mit Schlüsselnamen wie „Software“ oder „Network“ bezeichnet.

Im folgenden Beispiel wird der Bezeichner für den Unterschlüssel „CentralProcessor“ zurückgegeben.

Private Sub GetProfileString()
Dim mySys As System
Dim myRegSec As String
Dim myRegKeyInfo As String

Set mySys = System

myRegSec = _
 "HKEY_LOCAL_MACHINE\Hardware\Description\System\CentralProcessor\0"

myRegKeyInfo
    = mySys.ProfileString(myRegSec, "Identifier")
End Sub


Theme-Objekt

Repräsentiert ein Design in Microsoft FrontPage. Das Theme-Objekt ist ein Bestandteil der Themes-Auflistung. Die Themes-Auflistung repräsentiert alle Designs, die sich auf dem lokalen Computer befinden oder die einem bestimmten Web zugewiesen wurden. Innerhalb der Themes-Auflistung werden die einzelnen Theme-Objekte beginnend mit Null indiziert.

Verwenden des Theme-Objekts

Verwenden Sie die Format-Eigenschaft, um die Formatinformationen eines Designs zurückzugeben. Mit der folgenden Anweisung wird das Format des Designs zurückgegeben, das der aktiven FrontPage-basierten Webseite zugewiesen wurde.

myThemeFormat = Theme.Format

Verwenden Sie die Label-Eigenschaft, um den Namen zurückzugeben, der im Design-Listenfeld angezeigt wird, d. h. den vollständigen Namen des Designs. Mit der folgenden Anweisung wird die Bezeichnung des Designs zurückgegeben.

myThemeLbl = Theme.Label

Verwenden Sie die Name-Eigenschaft, um ein Design zurückzugeben oder um einer Webseite ein Design zuzuweisen. Die Name-Eigenschaft enthält den Verzeichnisnamen des Designs, d. h. eine abgekürzte Version des Namens, der für das Design im Design-Listenfeld angezeigt wird. Im folgenden Beispiel wird der Name des Designs zurückgegeben, der mit dem ActivePageWindow-Objekt verbunden ist.

Anmerkung Um dieses Beispiel nachvollziehen zu können, muss ein Web geöffnet sein, bei dem der aktiven Seite, dem gesamten Web oder einer Datei im Web ein Design zugewiesen wurde.

Private Sub GetThemeName()
Dim myPageWindow As PageWindow
Dim myThemeName As String

Set myPageWindow = ActivePageWindow
myThemeName = myPageWindow.Theme.Name
End Sub

Verwenden Sie die Version-Eigenschaft, um die Versionsnummer des Designs zurückzugeben. Im folgenden Beispiel wird die Version eines Designs zurückgegeben.

myThemeVersion = Theme.Version


Themes-Auflistungsobjekt

Eine Auflistung von Theme-Objekten. Jedes Theme-Objekt repräsentiert ein Design, das mit einer HTML-Seite oder einem Web in Microsoft FrontPage verbunden ist. Das Theme-Objekt ist ein Mitglied der Themes-Auflistung.

Verwenden der Themes-Auflistung

Verwenden Sie die Themes-Eigenschaft, um die Themes-Auflistung zurückzugeben. Die Themes-Eigenschaft kann sowohl mit Application- als auch mit Web-Objekten verwendet werden. Die Themes-Eigenschaft für das Application-Objekt ist die Auflistung der in FrontPage verfügbaren Designs. Die Themes-Eigenschaft für das Web-Objekt ist die Auflistung der Designs, die den Dateien in einem Web zugewiesen wurden, oder die Auflistung der Designs, die einem Web zugewiesen wurden. Die folgende Anweisung illustriert sowohl die Themes- als auch die Count-Eigenschaft und gibt die Anzahl der Elemente in der Themes-Auflistung zurück, die in FrontPage zur Verfügung stehen.

myTotalThemeCount = Application.Themes.Count

Die folgende Anweisung gibt die Anzahl der Designs in einem Web zurück.

myWebThemeCount = Application.Webs(0).Themes.Count

Verwenden Sie Themes(Index), wobei Index die Indexnummer des Designelements ist, um ein einzelnes Theme-Objekt zurückzugeben. Die folgende Anweisung gibt das erste Design in der Themes-Auflistung zurück.

myThemeOne = Web.Themes(0)

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Im folgenden Beispiel wird die Versions- und Buildnummer von FrontPage aus der Themes-Auflistung zurückgegeben.

Anmerkung Zum Ausführen dieses Verfahrens müssen Sie über wenigstens ein geöffnetes Web verfügen.

Private Sub GetBuildNumber()
Dim myThemes As Themes
Dim myBuild As String

Set myThemes = ActiveWeb.Themes

myBuild = myThemes.Application.Build
End Sub

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der Themes-Auflistung zurückgeben möchten. Beispielsweise gibt die folgende Anweisung den URL zurück, der mit dem übergeordneten Container der Themes-Auflistung verbunden ist.

myParentUrl = Web.Themes.Parent.Url


Web-Objekt

Repräsentiert ein Microsoft FrontPage Web-Objekt. Das Web-Objekt ist ein Mitglied der Webs-Auflistung, welche alle geöffneten Webs in einer Website repräsentiert. FrontPage bietet die Fähigkeit zum Erstellen mehrerer Web-Objekte auf einem Webserver. Innerhalb der Webs-Auflistung werden die einzelnen Web-Objekte indiziert, wobei der Index mit Null beginnt. Die Verzeichnishierarchie einer Website in FrontPage gleicht einer Ordnerhierarchie. Jeder WebFolder kann hierbei eine Website repräsentieren, jedoch muss nicht jeder WebFolder notwendigerweise für eine Website stehen. Die Webordnerhierarchie liefert die Verknüpfung zu Ordnern und Dateien in einem Webserververzeichnis.

Verwenden der Eigenschaften des Web-Objekts

Verwenden Sie die Web-Eigenschaft, um das Web-Objekt zurückzugeben. Im folgenden Beispiel wird das Betriebssystem des Webs auf die Fähigkeit zum Verarbeiten langer Dateinamen geprüft.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einer Befehlsschaltfläche mit Namen cmdCheckLongFilenames und einem Textfeld mit Namen txtLongFilenames und kopieren das Beispiel in das Codefenster.

Private Sub cmdCheckLongFilenames()
Dim myPageWin As PageWindow

Set myPageWin = ActivePageWindow

With myPageWin
    If .Web.AllowsLongFilenames = True Then
        txtLongFilenames = _
            “This operating system uses long file names.”
        Exit Sub
    Else
        txtLongFilenames = _
            “This operating system only uses short file names.”
    End If
End With
End Sub

Verwenden Sie Webs(Index), wobei Index für die Indexnummer eines Webelements steht, um ein einzelnes Web-Objekt zurückzugeben. Im folgenden Beispiel wird der URL des ersten Webelements in der Webs-Auflistung zurückgegeben.

Application.Webs(0).Url

Verwenden Sie die ActiveWebWindow-Eigenschaft, um das ausgewählte ActiveWebWindow-Objekt zurückzugeben. Über das ActiveWebWindow-Objekt können Sie auf die Objekte ActiveDocument, ActivePageWindow oder Application und damit auf Eigenschaften wie beispielsweise Caption, PageWindows, Parent, ViewMode, Visible und Web zugreifen. Mit dem folgenden Beispiel wird das Erstellungsdatum und die Dateigröße des aktiven Dokuments zurückgegeben.

Anmerkung Obwohl Date in Visual Basic für Applikationen ein verfügbarer Wertetyp ist, gibt das ActiveDocument-Objekt das Datum im Format String zurück und wandelt diese Zeichenfolge nicht automatisch in ein Datumsformat um.

Private Sub ActiveDocDateSize()
Dim myWebWindow As WebWindow
Dim myFileSize As String
Dim myCreateDate As String

Set myWebWindow = ActiveWebWindow

With myWebWindow
    myFileSize = .ActiveDocument.fileSize
    myCreateDate = .ActiveDocument.fileCreatedDate
End With
End Sub

Mit den Eigenschaften RevisionControlProject und IsUnderRevisionControl wird der Status des Überarbeitungsstadiums des Web-Objekts zurückgegeben. Sie haben in Microsoft FrontPage die Möglichkeit der Versionskontrolle über Microsoft Visual SourceSafe oder über Microsoft Office-"Style locking". Weitere Informationen über Quellcodeverwaltungsprojekte und Office-"Style locking" finden Sie unter Quellcodeverwaltung.

Wenn ein Quellcodeverwaltungsprojekt nicht einem gültigen Visual SourceSafe-Projekt entspricht, verwendet FrontPage standardmäßig Office-"Style locking". Im folgenden Beispiel werden die Eigenschaften RevisionControlProject und IsUnderRevisionControl zurückgegeben, und es beinhaltet ein Beispiel für ein Quellcodeverwaltungsprojekt.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Modul, und kopieren Sie das Beispiel in das Codefenster. Darüber hinaus muss ein Web geöffnet sein.

Private Sub SourceControl()

Dim myWeb As Web

Set myWeb = ActiveWeb
If Not(myWeb.IsUnderRevisionControl) Then
    MyWeb.RevisionControlProject = "<FrontPage-based Locking>"
End If
End Sub

Private Sub ReturnRevisionState()
Dim myWeb As Web
Dim myRevCtrlProj As String
Dim myIsUnderRevCtrl As Boolean

Set myWeb = ActiveWeb

With myWeb
    myRevCtrlProj = .RevisionControlProject
    myIsUnderRevCtrl = .IsUnderRevisionControl
End With
End Sub

Verwenden Sie die Eigenschaften RootFolder und RootNavigationNode, um den Stammordner oder den Stammnavigationsknoten zu ermitteln. Die RootFolder-Eigenschaft gibt einen Zeiger auf den Stammordner einer Website zurück. Die RootNavigationNode-Eigenschaft gibt das NavigationNode-Objekt zurück, über das Sie auf alle anderen Navigationsknoten in einem Web zugreifen können. Das RootNavigationNode-Objekt wird standardmäßig erstellt, wenn Sie ein Web erstellen, und liefert die grundlegende Navigationsstruktur, auf die über die Children-Eigenschaft zugegriffen wird. Der erste untergeordnete Knoten der Navigationsstruktur ist die Homepage des Webs. Im folgenden Beispiel wird der Name des Stammordners und der URL des RootNavigationNode-Objekts zurückgegeben.

Private Sub GetRootInfo()
Dim myWeb As Web
Dim myRootFolder As String
Dim myHomeNavNode As String

Set myWeb = ActiveWeb

With myWeb
    myRootFolder = .RootFolder.Name
    myHomeNavNode = .RootNavigationNode.Children(0).Url
End With
End Sub

Verwenden Sie die SharedBorders-Eigenschaft, um die gemeinsamen Randbereiche eines Webs entweder zu aktivieren oder zu deaktivieren. Mit der folgenden Anweisung wird die SharedBorders-Eigenschaft auf True festgelegt, und die gemeinsamen Randbereiche des angegebenen Webs werden aktiviert.

ActiveWeb.SharedBorders(fpBorderTop) = True

Verwenden Sie die WebWindows-Eigenschaft, um die Auflistung der WebWindow-Objekte zurückzugeben, die im aktuellen Web-Objekt enthalten sind. Mit der folgenden Anweisung wird eine Zählung der WebWindows-Auflistung zurückgegeben.

Application.WebWindows.Count

Verwenden der Web Object-Methoden

Verwenden Sie die Activate-Methode, um den Fokus auf das aktuelle Objekt zu setzen. Mit den folgenden Anweisungen wird geprüft, ob myAdventureWorksWeb das aktive Web ist; falls nicht, wird myAdventureWorksWeb aktiviert.

If ActiveWeb <> myAdventureWorksWeb Then
    myAdventureWorksWeb.Activate
End If

Verwenden Sie die ApplyNavigationStructure-Methode, um einer Website eine neu erstellte oder geänderte Navigationsstruktur zuzuweisen. Mit der folgenden Anweisung wird einem Web eine Navigationsstruktur zugewiesen, wobei die Variable für das Web „Adventure Works“ myAdventureWorksWeb ist.

myAdventureWorksWeb.ApplyNavigationStructure

Verwenden Sie die CancelRequests-Methode, um alle Serveranforderungen abzubrechen. Mit der folgenden Anweisung werden alle Serveranforderungen für das Web „Adventure Works“ abgebrochen, wobei myAdventureWorksWeb die Webvariable darstellt.

Anmerkung Der Client stoppt alle Anforderungen an den Server. Es ist allerdings möglich, dass der Server bereits mit einer Transaktion begonnen hat; in diesem Fall führt er die Transaktion zu Ende, und alle noch verbleibenden Anforderungen (sofern vorhanden) werden abgebrochen.

myAdventureWorksWeb.CancelRequests

Verwenden Sie die Methoden LocateFile oder LocateFolder, um ein WebFile- oder ein WebFolder-Objekt in einem Web zurückzugeben. Im folgenden Beispiel wird der Ordner eines festplattenbasierten Webs gesucht.

Application.Web.LocateFolder("C:\My Webs\Adventure Works\images")

Verwenden Sie die Publish-Methode, um ein Web auf einem Webserver zu veröffentlichen. Mit der folgenden Anweisung wird das Web „Adventure Works“ in einer Personal Web Server-Site veröffentlicht.

Dim myWeb As Web

Set myWeb = Application.Web

With myWeb
    .Publish _
    "http://myServer/wwwroot", fpPublishAddToExistingWeb

Die FpWebPublishFlags-Aufzählungstypen können, wie in der folgenden Anweisung gezeigt, verkettet werden.

myWeb.Publish _
    "http://myServer/wwwroot", fpPublishAddToExistingWeb + _
    fpPublishCopySubwebs

Verwenden Sie die RecalcHyperlinks-Methode, um die Anzeige aller Hyperlinks in einem Web zu aktualisieren. Wenn Sie in einer Mehrbenutzerumgebung arbeiten, in der viele Personen Änderungen am Web vornehmen, möchten Sie Hyperlinks möglicherweise häufig neu berechnen. Wenn Sie Hyperlinks neu berechnen, führt FrontPage auch andere Verfahren, wie beispielsweise Löschen nicht verwendeter Designs und Aktualisieren der Komponenteninformationen, auf dem Server durch. Mit der folgenden Anweisung werden die Hyperlinks im Web „Adventure Works“ neu berechnet.

webAdventureWorks.RecalcHyperlinks

Verwenden Sie die Refresh-Methode, um eine Seite zu aktualisieren. Mit den folgenden Anweisungen werden eine Seite und das aktive Web aktualisiert.

myPage.Refresh
myWeb.Refresh


Webs-Auflistungsobjekt

Eine Auflistung von Web-Objekten. Hierbei repräsentiert jedes Web-Objekt ein Web auf einem Webserver, wobei es sich entweder um ein festplattenbasiertes (auf einer lokalen Festplatte befindliches) oder um ein serverbasiertes Web handeln kann. Weitere Informationen über FrontPage-basierte Webs finden Sie unter Erstellen von Websites. Ein Web-Objekt ist ein Bestandteil der Webs-Auflistung.

Verwenden der Webs-Auflistung

Verwenden Sie die Webs-Eigenschaft, um die Webs-Auflistung zurückzugeben. Sie können auch die Application-Eigenschaft verwenden, um das Application-Objekt zurückzugeben. In der folgenden Anweisung wird das Application-Objekt verwendet, um das erste Element in der Webs-Auflistung zurückzugeben; Sie können auch die zweite Anweisung verwenden, um die gesamte Auflistung der Webs zurückzugeben.

Set myWebOne = Application.Webs(0)
Set myWebs = Application.Webs

Verwenden Sie Webs(Index), wobei Index die Indexnummer eines Elements in der Webs-Auflistung ist, um ein einzelnes Web-Objekt zurückzugeben. Mit der folgenden Anweisung wird das dritte Web in der Auflistung der geöffneten Web-Objekte zurückgegeben.

Set myGetWebThree = Webs(2)

Verwenden Sie die Add-Methode, um der Liste der in der Webs-Auflistung verfügbaren Elemente ein Element hinzuzufügen. Mit der folgenden Anweisung wird das Web „Rogue Cellars“ der Webs-Auflistung hinzugefügt.

Webs.Add("C:\My Documents\My Webs\Rogue Cellars")

Verwenden Sie die Application-Eigenschaft, um Informationen über die Anwendung aus der Webs-Auflistung zurückzugeben. Mit der folgenden Anweisung wird die Versionsnummer des Application-Objekts zurückgegeben.

ActiveWeb.Webs.Application.Version

Verwenden Sie die Count-Eigenschaft, um die Anzahl der geöffneten Webs in der Webs-Auflistung zurückzugeben. Mit der folgenden Anweisung wird die Anzahl der geöffneten Webs zurückgegeben.

Webs.Count

Verwenden Sie die Delete-Methode, um ein Web dauerhaft aus der Webs-Auflistung zu löschen. Mit der folgenden Anweisung wird das Web „Rogue Cellars“ gelöscht.

Webs.Delete("C:\My Documents\My Webs\Rogue Cellars")

Verwenden Sie die Open-Methode, um ein Web zu öffnen. Mit der folgenden Anweisung wird ein Web geöffnet und der Auflistung der Elemente in der Webs-Auflistung hinzugefügt.

Webs.Open("C:\My Documents\My Webs\Rogue Cellars")

Verwenden Sie die Parent-Methode, wenn Sie den Container der Webs-Auflistung, d. h. die Anwendung, zurückgeben möchten. Mit der folgenden Anweisung wird das Application-Objekt zuückgegeben.

Set myParent = Webs.Parent


WebFile-Objekt

Repräsentiert eine Datei in einem auf Microsoft FrontPage basierenden Web. Das WebFile-Objekt ist ein Mitglied der WebFiles-Auflistung. Die WebFiles-Auflistung repräsentiert alle Dateien in dem angegebenen WebFolder-Objekt. Innerhalb der WebFiles-Auflistung werden die einzelnen WebFile-Objekte indiziert, wobei der Index mit Null beginnt. Das WebFile-Objekt ist mit einer Datei in einer verzeichnisbasierten Hierarchie vergleichbar. FrontPage bietet die Möglichkeit zum Erstellen von mehreren Web-Objekten auf einem Webserver. Jeder WebFolder kann hierbei eine Website repräsentieren, jedoch muss nicht jeder WebFolder notwendigerweise für eine Website stehen.

Verwenden des File-Objekts

Verwenden Sie WebFiles(Index), wobei Index die Indexnummer eines Webdateielements ist, um ein einzelnes WebFile-Objekt zurückzugeben. Im folgenden Beispiel wird der Dateiname der ersten Webdatei in der WebFiles-Auflistung zurückgegeben.

ActiveWeb.RootFolder.Files(0).Name

Verwenden Sie das File-Objekt, um Informationen über eine Datei in einem Web zurückzugeben. Im folgenden Beispiel werden die Eigenschaften Name, Title und Url für jedes File-Objekt im aktiven Web zurückgegeben.

Anmerkung Zum Ausführen dieses Programms muss mindestens ein Web geöffnet sein.

Private Sub GetWebFileInfo()
Dim myWeb As Web
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myFileName As String
Dim myTitle As String
Dim myUrl As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myWeb
    For Each myFile In myFiles
            myFileName = myFile.Name
            myTitle = myFile.Title
            myUrl = myFile.Url
    Next
End With
End Sub

Verwenden Sie die IsOpen-Eigenschaft, um zu prüfen, ob eine Datei aktuell in der Seitenansicht geöffnet ist. Im folgenden Beispiel wird die IsOpen-Eigenschaft für das angegebene File-Objekt zurückgegeben. Beachten Sie, dass die Edit-Methode in diesem Beispiel benutzt wurde, um die Datei zu öffnen. Mehr Informationen zur Verwendung dieser Methode finden Sie unter Edit-Methode.

Anmerkung Um dieses Programm ausführen zu können, muss mindestens ein Web geöffnet sein.

Private Sub CheckForOpenFile()
Dim myWeb As Web
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myFileToOpen As String
Dim myMessage As String
Dim myFileName As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

myFileToOpen = "index.htm"
myMessage = "This file is currently open."

With myWeb
    For Each myFile In myFiles
        myFileName = myFile.Name
        If myFileName = myFileToOpen Then
            If myFile.IsOpen = True Then
                MsgBox (myMessage)
                Exit Sub
            Else
                myFile.Edit fpPageViewNormal
                Exit Sub
            End If
        End If
    Next
End With
End Sub

Verwenden Sie die Methoden Checkin, Checkout und UndoCheckout, um über die Quellcodeverwaltung die Dateiressourcen eines Webs zu verwalten. Mit der folgenden Anweisung wird die erste Datei im aktiven Web ausgecheckt.

Anmerkung Damit diese Anweisung ordnungsgemäß funktionieren kann, muss ein Quellcodeverwaltungsprojekt eingerichtet worden sein.

myFileCheckedOut = ActiveWeb.RootFolder.Files(1).Checkout

Ähnlich den Dateiverwaltungsfunktionen in Microsoft Visual SourceSafe bietet auch FrontPage eine UndoCheckout-Methode, die Sie verwenden können, um eine Datei in den ursprünglichen Zustand zurückzuversetzen. Mit der folgenden Anweisung wird die Datei in den Urzustand zurückversetzt.

myFileCheckedOut = ActiveWeb.RootFolder.Files(1).UndoCheckout

Bevor Sie versuchen, eine Datei auszuchecken, können Sie die CheckedoutBy-Eigenschaft verwenden, um zu sehen, ob und von wem die Datei aktuell ausgecheckt wurde. Mit der folgenden Anweisung wird der Logon-Alias der Person zurückgegeben, die die Datei ausgecheckt hat, oder Null, wenn die Datei aktuell nicht ausgecheckt ist.

myWhoCheckedOutFile = ActiveWeb.RootFolder.Files(0).CheckedoutBy

Verwenden Sie die Properties-Eigenschaft, um Informationen über ein Web, wie beispielsweise Typ des Webservers (vti_webservertype), zurückzugeben oder um zu ermitteln, ob das Web über einen Such-BOT (vti_hassearchbot) verfügt. Die Properties-Eigenschaft gibt eine Auflistung der Schlüssel/Wert-Paare zurück, die zum Verwalten der Metainformationen verwendet werden. Mit der folgenden Anweisung wird für die Variable mySearchBot True zurückgegeben, sofern das Web über einen Such-BOT verfügt.

mySearchBot = ActiveWeb.Properties.Item("vti_hassearchbot")

Verwenden Sie die MetaTags-Eigenschaften, um Informationen über die Metatags zurückzugeben, die im HTML-Code einer Datei enthalten sind. Die MetaTags-Eigenschaft gibt eine Auflistung der Metatags für ein File-Objekt zurück, wie beispielsweise den Generator der Datei. Im folgenden Beispiel wird der Dateiname und werden Metatags für jede Datei in einem Web zurückgegeben.

Anmerkung Zum Ausführen dieses Programms muss mindestens ein Web geöffnet sein.

Private Sub GetMetaTags()
Dim myWeb As Web
Dim myMetaTag As Variant
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myMetaTags As MetaTags
Dim myFileName As String
Dim myMetaTagName As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myWeb
    For Each myFile In myFiles
        Set myMetaTags = myFile.MetaTags
        For Each myMetaTag In myMetaTags
            myFileName = myFile.Name
            myMetaTagName = myMetaTag
        Next
    Next
End With
End Sub

Verwenden Sie die SharedBorders-Eigenschaft, um die gemeinsamen Randbereiche auf der aktuellen Webseite zurückzugeben oder um neue gemeinsame Randbereiche festzulegen. Mit der folgenden Anweisung wird der am oberen Seitenrand befindliche gemeinsame Randbereich der ersten Datei in der Files-Auflistung des aktiven Webs zurückgegeben.

myTopBorder _
    = ActiveWeb.RootFolder.Files(0).SharedBorders(fpBorderTop)

Sie können auch gemeinsame Randbereiche für eine Webdatei festlegen, wie mit der folgenden Anweisung gezeigt.

ActiveWeb.RootFolder.Files(0).SharedBorders(fpBorderTop) = True

Verwenden Sie die ThemeProperties-Eigenschaft, um die folgenden Informationen über das zugewiesene Design zurückzugeben: Verwendet das Design lebendige Farben oder aktive Grafiken? Im folgenden Beispiel werden die Eigenschaften eines zugewiesenen Designs zurückgegeben, und den aktuellen Designeigenschaften werden lebendige Farben hinzugefügt, wenn für das angegebene Objekt keine lebendigen Farben festgelegt waren.

Private Sub CheckThemeProperties()
Dim myFile As WebFile

Set myFile = ActiveWeb.RootFolder.Files(0)

If myFile.ThemeProperties(fpThemeActiveGraphics) Then
    myFile.ApplyTheme myFile.ThemeProperties(fpThemeName), myFile.ThemeProperties(fpThemePropertiesAll) + fpThemeVividColors
Else
    myFile.ApplyTheme myFile.ThemeProperties(fpThemeName), myFile.ThemeProperties(fpThemePropertiesAll) + fpThemeActiveGraphics + fpThemeVividColors
End If
End Sub

Verwenden der File-Methoden

Verwenden Sie die Methoden Copy, Delete, Edit, Move oder Open, um Webdateien zu verwalten. Zwischen den Methoden Edit und Open gibt es einen feinen Unterschied. Mit der Edit-Methode können Sie eine Datei öffnen und ändern, die in FrontPage geöffnet werden kann, während Sie mit der Open-Methode jede beliebige Datei in dem mit der Datei verbundenen Editor öffnen können und keine Datei zurückgegeben wird. Im folgenden Beispiel wird eine Datei geöffnet, eine Datei gelöscht und eine Datei verschoben.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen.

Private Sub OpenFile()
Dim myWeb As Web
Dim myFile As WebFile

Set myWeb = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
myWeb.Activate
Set myFile = myWeb.RootFolder.Files("index.htm")
myFile.Open
End Sub

Private Sub DeleteFile()
Dim myWeb As Web
Dim myFile As WebFile

Set myWeb = ActiveWeb
Set myFile = myWeb.RootFolder.Files(0)

myFile.Delete
End Sub

Sub MoveFile()
Dim myWeb As Web
Dim myFile As WebFile

Set myWeb = ActiveWeb
Set myFile = myWeb.RootFolder.Files(0)

myFile.Move “New Filename”, True, True
End Sub


WebFiles-Auflistungsobjekt

Eine Auflistung von WebFile-Objekten. Jedes WebFile-Objekt repräsentiert hierbei alle geöffneten Dateien in einem Web. Das WebFile-Objekt ist ein Bestandteil der WebFiles-Auflistung.

Verwenden des WebFiles-Objekts

Verwenden Sie die WebFiles-Eigenschaft, um die WebFiles-Auflistung zurückzugeben. Mit der folgenden Anweisung werden die WebFile-Objekte in der WebFiles-Auflistung zurückgegeben.

Set myWebFiles = Application.Webs(0).RootFolder.WebFiles

Verwenden Sie WebFiles(Index), wobei Index die Indexnummer eines Elements in der WebFiles-Auflistung ist, um ein einzelnes WebFile-Objekt zurückzugeben. Mit der folgenden Anweisung wird das erste WebFile-Objekt in der Auflistung zurückgegeben.

Set myWebFile = ActiveWeb.RootFolder.WebFiles(0)

Verwenden Sie die Add-Methode, um der WebFiles-Auflistung ein WebFile-Objekt hinzuzufügen. Mit der folgenden Anweisung wird der Auflistung der WebFiles ein neues WebFile-Objekt hinzugefügt.

myWebFiles.Add ("C:\New Web WebFiles\Sales Statistics.htm")

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt aus der WebFiles-Auflistung zurückzugeben. Mit der folgenden Anweisung wird das Application-Objekt aus der WebFiles-Auflistung zurückgegeben.

myApp = ActiveWeb.RootFolder.WebFiles.Application

Verwenden Sie die Count-Eigenschaft, um die Anzahl der geöffneten Dateien in der WebFiles-Auflistung zurückzugeben. Mit der folgenden Anweisung wird die Anzahl der Dateien in der WebFiles-Auflistung zurückgegeben.

myCount = Webs(0).RootFolder.WebFiles.Count

Verwenden Sie die Delete-Methode, um ein WebFile-Objekt zu löschen. Mit der folgenden Anweisung wird die dritte Datei in der WebFiles-Auflistung gelöscht.

Webs(0).RootFolder.WebFiles(2).Delete

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der WebFiles-Auflistung zurückgeben möchten. Mit der folgenden Anweisung wird der URL des Ordners zurückgeben, in dem sich die zweite Datei des aktiven Webs befindet.

myWebFileParent = ActiveWeb.RootFolder.WebFiles(1).Parent.Url


WebFolder-Objekt

Repräsentiert einen Ordner in einem auf Microsoft FrontPage basierenden Web. Das WebFolder-Objekt ist ein Mitglied der WebFolders-Auflistung.

Anmerkung Das Folder-Objekt ist ein Verweis auf das WebFolder-Objekt.

Die WebFolders-Auflistung repräsentiert alle Ordner im angegebenen Web. Innerhalb der WebFolders-Auflistung werden einzelne WebFolder-Objekte indiziert, wobei der Index mit Null beginnt. Das WebFolder-Objekt ist mit einem Ordner in einer verzeichnisbasierten Hierarchie vergleichbar, jedoch ist die Beziehung zwischen WebFolder-Objekten und Web-Objekten eindeutig. FrontPage bietet die Möglichkeit zum Erstellen mehrerer Web-Objekte auf einem Webserver. Jeder WebFolder kann hierbei eine Website repräsentieren, jedoch muss nicht jeder WebFolder notwendigerweise für eine Website stehen. Die Webordnerhierarchie liefert die Verknüpfung zu Ordnern und Dateien in einem Webserververzeichnis. Die Navigationsstruktur liefert die den Web-Objekten zugrunde liegende Struktur innerhalb der einzelnen FrontPage-basierten Webs.

Verwenden des WebFolder-Objekts

Verwenden Sie WebFolders(Index), wobei Index für den PropertyKey eines Webordnerelements steht, um ein einzelnes WebFolder-Objekt zurückzugeben. Im folgenden Beispiel wird der Dateiname des ersten Webordnerelements in der WebFolders-Auflistung zurückgegeben.

ActiveDocument.WebFolders(0).Name

Verwenden Sie die Auflistungseigenschaften, wie beispielsweise Files, Folders oder Properties, um das Auflistungsobjekt für das angegebene Element zurückzugeben. Mit den folgenden Anweisungen wird das erste angegebene Element in der Auflistung für das aktive Web zurückgegeben.

myFileOne = ActiveWeb.RootFolder.Files(0)
myFolderOne = ActiveWeb.RootFolder.Folders(0)
myPropertyOne = ActiveWeb.Properties("vti_author")

Verwenden Sie Eigenschaften wie beispielsweise IsExecutable, IsReadable, IsRoot usw., um den angegebenen Status eines Ordners zu prüfen. Wenn Sie mit CGI-Skripts arbeiten, die Sie ausführen möchten, können Sie die Skripts einem Ordner hinzufügen und die IsExecutable-Eigenschaft dieses Ordners auf True festlegen. Befinden sich in diesem Ordner Inhalte, die anderen Personen zugänglich sein sollen, können Sie die IsReadable-Eigenschaft auf True festlegen. Wenn Sie prüfen möchten, ob es sich beim aktuellen Ordner um den Stammordner handelt, können Sie die IsRoot-Eigenschaft verwenden. Im folgenden Beispiel wird geprüft, ob Dateien im aktuellen WebFolder-Objekt ausführbar oder schreibgeschützt sind oder ob sie sich in einem Stammordner befinden.

Private Sub GetFolderInfo()
Dim myWeb As Web
Dim myFolder As WebFolder
Dim myIsExe As Boolean
Dim myIsReadable As Boolean
Dim myIsRoot As Boolean

Set myWeb = ActiveWeb
Set myFolder = myWeb.RootFolder.Folders(1)

With myFolder
    myIsExe = .IsExecutable
    myIsReadable = .IsReadable
    myIsRoot = .IsRoot
End With
End Sub

Die Eigenschaften IsExecutable, IsReadable und IsWriteable geben Informationen über den Status des Ordners zurück. Im folgenden Beispiel wird gezeigt, wie die Eigenschaften IsExecutable und IsReadable festgelegt werden und wie die IsWriteable-Eigenschaft gelesen wird.

Anmerkung Die IsWriteable-Eigenschaft können Sie zwar nicht festlegen, doch können Sie die Eigenschaften IsExecutable und IsReadable für ein WebFolder-Objekt festlegen.

Sub FolderProperties ()
Dim myFolder As WebFolder

Set myFolder = ActiveWeb.RootFolder.Folders(0)

If myFolder.IsWritable Then
    MsgBox "Folder, " & myFolder.Url & " is writable"
End If

If Not(myFolder.IsReadable) Then
    MyFolder.IsReadable = True
End If

If myFolder.IsExecutable Then
    MyFolder.IsExecutable = False
End If
End Sub

Ordner (oder WebFolders) in FrontPage dienen einem zweifachen Zweck. Zum einen können es Ordner sein, die Ihnen helfen, die Inhalte des Webs zu verwalten, zum anderen kann es sich um Webs handeln. Ein Web kann über mehrere untergeordnete Webs verfügen. Die IsWeb-Eigenschaft gibt True zurück, wenn es sich bei dem fraglichen Ordner um ein Web handelt. Im folgenden Beispiel wird die IsWeb-Eigenschaft verwendet, um zu ermitteln, ob der Ordner ein Web ist. Ist dies der Fall, wird das Web geöffnet.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles \Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle des angegebenen Web-URLs auch einen anderen URL verwenden.

Private Sub CheckFolder()
Dim myFolder As WebFolder

Set myFolder = ActiveWeb.RootFolder.Folders("Rogue Cellars")
If myFolder.IsWeb = True Then
    Webs.Open myFolder.Url
End If
End Sub

Verwenden Sie die Url-Eigenschaft, um den URL des aktuellen WebFolder-Objekts zurückzugeben. Mit der folgenden Anweisung wird der absolute URL für den achten Ordner im aktiven Web zurückgegeben.

myUrl = ActiveWeb.RootFolder.Folders(7).Url

Verwenden Sie die Methoden Copy, Delete und Move, um die Webstruktur zu verwalten. Mit der folgenden Anweisung wird ein WebFolder-Objekt von einem Ordner in einen anderen kopiert, während des Kopiervorgangs werden die Links aktualisiert, und sofern die Datei bereits vorhanden ist, wird ein Überschreiben erzwungen.

myFolder.Copy("C:\My Webs\New Adventure Products", True, True)


WebFolders-Auflistungsobjekt

Eine Auflistung von WebFolder-Objekten. Jedes WebFolder-Objekt innerhalb der WebFolders-Auflistung repräsentiert einen geöffneten Ordner in einem Web. Das WebFolder-Objekt ist ein Bestandteil der WebFolders-Auflistung.

Anmerkung Mit allen Methoden, die sich auf das Ändern der Speicherposition eines Ordners beziehen, wie beispielsweise Kopieren oder Verschieben, kann nur die Speicherposition innerhalb des aktuellen Webs geändert werden, d. h. Sie können einen Ordner nicht aus dem aktuellen Web in ein anderes Web kopieren oder verschieben.

Verwenden des WebFolders-Objekts

Verwenden Sie WebFolders(Index), wobei Index die Indexnummer eines Elements in der WebFolders-Auflistung ist, um ein einzelnes WebFolder-Objekt zurückzugeben. Im folgenden Beispiel wird das erste WebFolder-Objekt in der Auflistung zurückgegeben.

Set myFolder = ActiveWeb.RootFolder.Folders(0)

Verwenden Sie die Add-Methode, um der WebFolders-Auflistung in einem Web ein neues WebFolder-Objekt hinzuzufügen. Mit beiden nachstehenden Anweisungen wird der WebFolders-Auflistung im aktiven Web ein WebFolder hinzugefügt, wobei für den Ordnernamen keine Klammern erforderlich sind, wie in der zweiten Anweisung gezeigt.

Anmerkung Der Platzhalter FolderUrl innerhalb der Anführungszeichen („Rogue Cellars“) sollte nur den Namen des neuen Ordners und nicht den gesamten URL beinhalten. Das Programm gibt einen Fehler aus, wenn der gesamte URL verwendet wird.

ActiveWeb.RootFolder.Folders.Add ("Rogue Cellars")
ActiveWeb.RootFolder.Folders.Add "Rogue Cellars"

Verwenden Sie die Count-Eigenschaft, um die Anzahl aller Navigationsknoten in der WebFolders-Auflistung zurückzugeben. Mit der folgenden Anweisung wird die Anzahl der Webs im Web „Rogue Cellars“ zurückgegeben.

Webs("C:\Web Server One\Rogue Cellars").Folders.Count

Verwenden Sie die Delete-Methode, um ein WebFolder-Objekt aus der WebFolders-Auflistung zu löschen. Mit der folgenden Anweisung wird das zehnte WebFolder-Objekt gelöscht. In der zweiten Anweisung wird der Name des Ordners anstelle der Indexnummer verwendet, um den zu löschenden Ordner zu bezeichnen.

ActiveWeb.RootFolder.Folders(9).Delete
ActiveWeb.RootFolder.Folders("TempFolder").Delete

Verwenden Sie die Copy-Methode, um ein WebFolder-Objekt zu kopieren. Im folgenden Beispiel wird ein Ordner (WebFolders(4)) in einen anderen Ordner im aktiven Web („Chardonnay Inventory“) kopiert. Zum Zwecke dieses Beispiels ist WebFolders(4) ein Ordner mit Namen Inventory im Web „Rogue Cellars“. Dieser Ordner enthält den gesamten Weinbestand. Der Webdesigner wollte jedoch den Verkauf von Chardonnay-Weinen hervorheben und hat daher einen temporären Ordner erstellt, der so bearbeitet wird, dass er nur Chardonnay-Weine enthält.

Private Sub CopyInventory()
Dim myFolder As WebFolder

Set myFolder = ActiveWeb.RootFolder.Folders(4)

myFolder.Copy ("C:\Rogue Cellars\Chardonnay Inventory, False, True)
End Sub

Verwenden Sie die Move-Methode, um einen Ordner von einer Speicherposition in einem Web an eine andere zu verschieben. Wenn Sie beispielsweise über alte Angebotsseiten verfügen, die Sie für den Verkauf im nächsten Quartal behalten möchten, können Sie diese in einen anderen Ordner verschieben, wie im nachstehenden Beispiel gezeigt.

Private Sub MoveOldAds()
Dim myOldAds As WebFolder

Set myOldAds = Webs(0).RootFolder.Folders(1)

myOldAds.Move("C:\Rogue Cellars\FirstQtr Advertising", True, True)
End Sub

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der WebFolders-Auflistung zurückgeben möchten. Mit der folgenden Anweisung wird der Container des vierten Ordners zurückgegeben.

myParent = Webs.RootFolder.Folders(3).Parent


WebWindow-Objekt

Repräsentiert ein Fenster, das in einem Microsoft FrontPage-basierten Web geöffnet ist. Das WebWindow-Objekt ist ein Mitglied der WebWindows-Auflistung. Die WebWindows-Auflistung repräsentiert alle geöffneten Fenster in einem bestimmten Web oder in FrontPage. In der WebWindows-Auflistung werden die einzelnen WebWindow-Objekte beginnend mit Null indiziert. Jedes Web, das in FrontPage geöffnet wird, ist in einem neuen WebWindow-Objekt enthalten, es sein denn, es wird in einer Umgebung ohne Fenster geöffnet, indem die Visible-Eigenschaft des WebWindow-Objekts auf False gesetzt wird. Weitere Informationen über Umgebungen ohne Fenster finden Sie unter Erstellen von Code in einer Umgebung ohne Fenster.

Verwenden des WebWindow-Objekts

Verwenden Sie die WebWindow-Eigenschaft, um Informationen über ein geöffnetes WebWindow-Objekt zurückzugeben. Sie können auch die PageWindows-Eigenschaft verwenden, um Informationen über die Auflistung der geöffneten Seiten in einem WebWindow-Objekt zurückzugeben. Im folgenden Beispiel wird das aktive Webfenster als WebWindow-Objekt festgelegt, und es werden für die Auflistung der geöffneten PageWindows-Objekte im WebWindow-Objekt die Dateinamen der zuletzt geänderten Dateien und die Änderungsdaten zurückgegeben.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einer Befehlsschaltfläche mit Namen cmdWebWindowDisplay sowie einem Textfeld mit Namen txtWebWindowDisplay. Damit die Wiederholung angezeigt wird, muss mehr als ein Seitenfenster geöffnet sein.

Private sub cmdWebWindowDisplay_Click()
On Error Resume Next
Dim openWebWindow As WebWindow
Dim openPageWindows As PageWindows
Dim thisPage As PageWindow
Dim CRLF As String
Dim myText As String

Set openWebWindow = Application.ActiveWebWindow
Set openPageWindows = openWebWindow.PageWindows
txtWebWindowDisplay.MaxLength = 1000
txtWebWindowDisplay.MultiLine = True
txtWebWindowDisplay.WordWrap = True
CRLF = Chr(13) & Chr(10)

With openWebWindow
    For Each thisPage in openPageWindows
        With thisPage
            myText = myText & "Open Page: " & .Caption _
            & CRLF & "Page Last Modified: " _
            & thisPage.Document.fileModifiedDate & CRLF & CRLF
        End With
    Next
txtWebWindowDisplay.Text = myText
End With
End Sub

Verwenden Sie WebWindows(Index), wobei Index die Indexnummer eines Webfensterelements ist, um ein einzelnes WebWindow-Objekt zurückzugeben. Mit der folgenden Anweisung wird die ViewMode-Eigenschaft des ersten Webfensterelements in der WebWindows-Auflistung zurückgegeben.

myViewMode = WebWindows(0).ViewMode

Sie können die ViewMode-Eigenschaft auch verwenden, um zwischen unterschiedlichen Ansichtsmodi zu wechseln, und zwar, indem Sie den Ansichtsmodus wie in der folgenden Anweisung gezeigt festlegen, womit von der aktuellen Ansicht in die Navigationsansicht gewechselt wird.

ActiveWebWindow.ViewMode = fpWebViewStructure

Mit der Activate-Methode wird der Fokus auf das angegebene WebWindow-Objekt gesetzt. Mit den folgenden Anweisungen wird das zweite Web in der Auflistung der geöffneten Webfenster aktiviert.

myWebWindow = WebWindows(0)
myWebWindow.Activate

Mit der ActivePageWindow-Eigenschaft wird das ActivePageWindow-Objekt zurückgegeben. Die folgende Anweisung gibt den URL und die Titelzeile des ActivePageWindow-Objekts zurück. Der Wert, der in diesem Fall als Titelzeile zurückgegeben wird, ist der Dateiname, wie beispielsweise Index.htm.

urlThisDoc = WebWindow.ActivePageWindow.Document.Url
fileName = WebWindow.ActivePageWindow.Caption

Sie können auch die Caption-Eigenschaft des WebWindow-Objekts zurückgeben. In diesem Fall wird als Text die Titelzeile des FrontPage-Anwendungsfensters zurückgegeben, die sich aus dem Namen der Anwendung und dem URL des angegebenen WebWindowObjekts zusammensetzt, wie beispielsweise Microsoft FrontPage – C:\Eigene Webs\Adventure Works. Mit der folgenden Anweisung wird der Wert der Caption-Eigenschaft des WebWindow-Objekts zurückgegeben.

thisCaption = WebWindow.Caption

Verwenden Sie die Close-Methode, um ein WebWindow-Objekt zu schließen. Mit der folgenden Anweisung wird das angegebene WebWindow geschlossen.

Set myWebWindowOne = WebWindows(0)
myWebWindowOne.Close

Sie können die Eigenschaften SelectedFiles und SelectedFolders verwenden, um auf ausgewählte Objekte in einem WebWindow-Objekt zuzugreifen. Im folgenden Beispiel werden die Dateinamen der gewählten Dateien in jedem geöffneten Webfenster zurückgegeben.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einer Befehlsschaltfläche mit Namen cmdSelectedFiles und einem Textfeld mit Namen txtSelFileDisplay. Darüber hinaus muss mehr als ein Webfenster mit jeweils mindestens einer ausgewählten Datei geöffnet sein.

Private Sub cmdSelectedFiles_Click()
Dim myWebWindows As WebWindows
Dim myWebWindow As WebWindow
Dim mySelFiles As Variant
Dim mySelFile As WebFile
Dim mySelName As String
Dim myCount As Integer

Set myWebWindows = WebWindows

txtSelFileDisplay.maxLength = 1000
txtSelFileDisplay.MultiLine = True
txtSelFileDisplay.WordWrap = True
mySelName = "Selected Files: "

For Each myWebWindow In myWebWindows
    mySelFiles = myWebWindow.SelectedFiles
    For myCount = 0 To UBound(mySelFiles)
        Set mySelFile = mySelFiles(myCount)
        mySelName = mySelName & " " & mySelFile.Name
        txtSelFileDisplay.Text = mySelName & vbCrLf
    Next
Next
End Sub

Verwenden Sie die ViewMode-Eigenschaft, um einen der in der nachstehenden Tabelle aufgeführten Werte zurückzugeben oder festzulegen. Sie können diese Aufzählungswerte auch verwenden, um zwischen den Ansichten in FrontPage zu wechseln.

Aufzählungskonstante | Wert | Entsprechende Ansicht in FrontPage
FpWebViewLinks | 0 | Hyperlinkansicht
FpWebViewFolders | 1 | Ordneransicht
FpWebViewStructure | 2 | Navigationsansicht
FpWebViewPage | 3 | Seitenansicht
fpWebViewAllFiles | 4 | Anzeigen einer Liste aller Dateien in der Berichtsansicht
FpWebViewTodo | 5 | Anzeigen einer Aufgabenliste in der Aufgabenansicht
FpWebViewBrokenLinks | 6 | Anzeigen einer Liste der unterbrochenen Hyperlinks in der Berichtsansicht
FpWebFiewSiteSummary | 7 | Siteübersicht in der Berichtsansicht

Mit der folgenden Anweisung wird die ViewMode-Eigenschaft auf fpWebViewPage gesetzt.

WebWindows(0).ViewMode = fpWebViewPage

Verwenden Sie die Visible-Eigenschaft, um einen booleschen Wert für den Status eines WebWindow-Objekts festzulegen. Die Visible-Eigenschaft gibt True zurück, wenn ein WebWindow-Objekt sichtbar ist. Mit der folgenden Anweisung wird für ein WebWindow-Objekt der Status „Nicht sichtbar“ gesetzt.

WebWindow.Visible = False

Verwenden Sie die Web-Eigenschaft, um Informationen über das Web-Objekt zurückzugeben. Mit der folgenden Anweisung wir die Anzahl der Eigenschaften des angegebenen Webs zurückgegeben.

myProperties = ActiveWeb.WebWindows(0).Web.Properties.Count


WebWindows-Auflistungsobjekt

Eine Auflistung von WebWindow-Objekten. Jedes WebWindow-Objekt repräsentiert hierbei ein geöffnetes Fenster in Microsoft FrontPage. Das WebWindow-Objekt ist ein Element der WebWindows-Auflistung.

Verwenden der WebWindows-Auflistung

Verwenden Sie WebWindows(Index), wobei Index die Indexnummer eines Elements in der WebWindows-Auflistung ist, um ein einzelnes WebWindow-Objekt zurückzugeben. Mit der folgenden Anweisung wird die Caption-Eigenschaft des vierten Elements in der WebWindows-Auflistung zurückgegeben.

Function ReturnWebWindowCaption() As String
Dim myCaption As String
Dim myWebWindow As WebWindow

Set myWebWindow = Application.WebWindows(3)
myCaption = myWebWindow.Caption
ReturnWebWindowCaption = myCaption
End Sub

Verwenden Sie die WebWindows-Eigenschaft, um die WebWindows-Auflistung zurückzugeben. Im folgenden Beispiel werden alle geöffneten WebWindow-Objekte in der WebWindows-Auflistung mit Ausnahme des ActiveWebWindow-Objekts geschlossen.

Private Sub CloseWebWindows
Dim myWebWindows As WebWindows
Dim myWebWindow As WebWindow
Dim myActiveWebWindow As WebWindow

Set myWebWindows = Application.WebWindows
Set myActiveWebWindow = ActiveWebWindow

For Each myWebWindow In myWebWindows
    If myWebWindow.Caption <> myActiveWebWindow.Caption Then _
        myWebWindow.Close
Next
End Sub

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Wenn Sie bereits mit der WebWindows-Auflistung arbeiten und die Versionsnummer der Anwendung prüfen möchten, können Sie hierauf einfach von der Anweisung With myWebWindows aus zugreifen, wie im nachfolgenden Beispiel gezeigt.

With myWebWindows
    myWebWindowCount = myWebWindows.Count
    myAppVersion = .Application.Version
    If myAppVersion < "4.0" Then
        MsgBox "Please upgrade your FrontPage software."
    Else
        For Each myWebWindow In myWebWindows
            myCaption = myWebWindow.Caption
            With myPageWindows
                myPageCount = PageWindows.Count
            End With
        Next
    End If
End With

Sie können die Close-Methode verwenden, um ein einzelnes WebWindow-Objekt, mehrere WebWindow-Objekte oder alle WebWindow-Objekte in einem Web zu schließen. Weitere Einzelheiten zur Close-Methode entnehmen Sie den in der nachfolgenden Tabelle beschriebenen Anwendungsbereichen.

Wichtig FrontPage beendet die Anwendung, wenn Sie mit der Close-Methode alle WebWindow-Objekte in FrontPage schließen.

Verwendung der Close-Methode | Code
Schließen eines einzelnen WebWindow-Objekts in der Anwendung
Application.WebWindows(index).Close

or
Application.WebWindows.Close(index)
Schließen mehrerer WebWindow-Objekte in der Anwendung (wie im vorstehenden Beispiel gezeigt)
For Each myWebWindow In myWebWindows

    If myWebWindow.Caption <> _
        myActiveWebWindow.Caption Then _
        myWebWindow.Close
Next
Schließen aller WebWindow-Objekte in der Anwendung
Application.WebWindows.Close
Schließen eines einzelnen WebWindow-Objekts in einem Web
Webs(index).WebWindows(index).Close
Schließen mehrerer WebWindow-Objekte in einem Web
Set myWeb = Web(index).WebWindows

For Each myWebWindow In myWebWindows
    If myWebWindow.Caption _
      <> myActiveWebWindow.Caption Then _
        myWebWindow.Close
Next
Schließen einer Auflistung in einem Web
Webs(index).WebWindows.Close
Das Schließen aller WebWindow-Objekte in FrontPage entspricht der Quit-Methode. | Der Ausdruck Application.WebWindows.Close ist der gleiche wie Application.Quit.

Verwenden Sie die Count-Eigenschaft, um die Anzahl der WebWindow-Objekte in der Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der WebWindow-Objekte zurückgegeben.

Web.WebWindows.Count

Verwenden Sie die Parent-Eigenschaft, wenn Sie den Container der WebWindows-Auflistung zurückgeben möchten. Mit der folgenden Anweisung wird das Application-Objekt zurückgegeben.

Application.WebWindows.Parent.Name


ActiveDocument-Eigenschaft

Gibt das aktive Dokument als IHTML Document2-Objekt zurück. Schreibgeschütztes Application- oder PageWindow-Objekt.

Hinweise

Dieses Objekt ermöglicht den Zugriff auf Elemente des Microsoft FrontPage-Seitenobjektmodells, die mit Microsoft Internet Explorer, Version 4.0 und höher, kompatibel sind. Dieses Objektmodell stellt eine Programmiermöglichkeit für die HTML- und DHTML-Programmierelemente von Internet Explorer bereit.


Beispiel für die ActiveDocument-Eigenschaft

Mit der folgenden Anweisung wird das ActiveDocument-Objekt für das Application-Objekt zurückgegeben.

myDoc = Application.ActiveDocument

Mit der folgenden Anweisung wird das ActiveDocument-Objekt für das PageWindow-Objekt zurückgegeben.

myDoc = Application.WebWindows(0).PageWindows(0).ActiveDocument


ActiveFrameWindow-Eigenschaft

Gibt das IHTMLWindow2 PageWindow-Objekt des ausgewählten Frames im Seitenfenster zurück. Schreibgeschütztes Objekt.

Anmerkung Der Zugriff auf die ActiveFrameWindow-Eigenschaft ist gleichbedeutend mit dem Zugriff auf das übergeordnete Fenster über das aktive Seitenfenster, wobei Sie wie folgt vorgehen:

ActivePageWindow.Document.parentWindow


Beispiel für die ActiveFrameWindow-Eigenschaft

In diesem Beispiel wird das ActiveFrameWindow-Objekt abgerufen.

Private Sub GetActiveFrame()
Dim myPageWindow As PageWindow
Dim myFrame As FPHTMLWindow2

Set myPageWindow = _
    ActiveWeb.ActiveWebWindow.ActivePageWindow
Set myFrame = myPageWindow.ActiveFrameWindow
End Sub


ActivePageWindow-Eigenschaft

Gibt das ActivePageWindow-Objekt zurück. Schreibgeschützes Application- oder WebWindow-Objekt.


Beispiel für die ActivePageWindow-Eigenschaft

Im folgenden Beispiel wird das ActivePageWindow-Objekt für das Application-Objekt zurückgegeben.

Private Sub GetActivePageWindow()
Dim myPageWindow As PageWindow

Set myPageWindow = ActivePageWindow
End Sub

Im folgenden Beispiel wird das ActivePageWindow-Objekt aus dem WebWindow-Objekt zurückgegeben.

Private Sub GetActivePageWindow()
Dim myPage As PageWindow

Set myPage = ActiveWebWindow.ActivePageWindow
End Sub


ActiveWeb-Eigenschaft

Gibt das aktuelle ActiveWeb-Objekt zurück. Schreibgeschütztes Object-Objekt.

Hinweis

Das Microsoft FrontPage Application-Objektmodell ermöglicht den Zugriff auf das Web-Objektmodell über das ActiveWeb-Objekt. Weitere Informationen über die FrontPage-Objektmodelle finden Sie unter Erforschen des Objektmodells in FrontPage.


ActiveWebWindow-Eigenschaft

Gibt das aktuelle ActiveWebWindow für das angegebene Objekt zurück. Schreibgeschütztes Objekt.


Beispiel für die ActiveWebWindow-Eigenschaft

In diesem Beispiel wird der Wert der ActiveDocument.nameProp-Eigenschaft für das ActiveWebWindow-Objekt gedruckt.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einer Befehlsschaltfläche mit Namen cmdActiveWebWindowDisplay und einem Bezeichnungsfeld mit Namen lblWebWindowDisplay. Fügen Sie folgenden Code in das Codefenster ein. Damit mit diesem Verfahren ein Dokumentname zurückgegeben werden kann, muss eine Seite eines FrontPage-basierten Webs geöffnet sein.

Private Sub cmdActiveWebWindowDisplay_Click()
On Error Resume Next
Dim myCurrentWebWindow As WebWindow

Set myCurrentWebWindow = Application.ActiveWebWindow

With myCurrentWebWindow
    lblWebWindowDisplay.Caption = .ActiveDocument.nameProp
End With
End Sub


AllowsLongFilenames-Eigenschaft

Gibt True zurück, wenn das Betriebssystem des Computers, auf dem sich das Web befindet, lange Dateinamen akzeptiert. Schreibgeschützter Wert vom Typ Boolean.


Beispiel für die AllowsLongFilenames-Eigenschaft

In diesem Beispiel wird der Wert der AllowsLongFilenames-Eigenschaft des ActiveWeb-Objekts geprüft. Im Beispiel wird davon ausgegangen, dass ConvertLongFilenames eine Prozedur ist, die für dieses Codebeispiel zur Verfügung steht.

If ActiveWeb.AllowsLongFilenames = True Then
    Exit Sub
Else
    Call ConvertLongFilenames()
End If


AnswerWizard-Eigenschaft

Gibt das AnswerWizard-Objekt zurück. Schreibgeschütztes AnswerWizard-Objekt.


Beispiel für die AnswerWizard-Eigenschaft

In diesem Beispiel wird eine Answer Wizard-Datei hinzugefügt, und die Creator- und Count-Eigenschaften werden abgerufen.

Anmerkung Die in FrontPage verwendete Creator-Eigenschaft unterscheidet sich von der Creator-Eigenschaft, die von anderen Microsoft Office-Objekten wie beispielsweise dem AnswerWizard-Objekt verwendet wird. Bei der Creator-Eigenschaft für FrontPage wird ein Zeichenfolgenformat verwendet, wohingegen bei Office-Objekten eine 32-Bit-Ganzzahl zum Bezeichnen der Anwendung verwendet wird, in der die Datei erstellt wurde. In diesem Beispiel werden Sie feststellen, dass die Creator-Eigenschaft eine 32-Bit-Ganzzahl anstelle des FrontPage-gemäßen Zeichenfolgenformats zurückgibt, da es sich bei dem AnswerWizard-Objekt um ein ImsoDispObj-Objekt aus Office handelt. Wenn Sie weitere Informationen benötigen, verwenden Sie den Objektkatalog für alle Bibliotheken oder die Microsoft Visual Basic-Hilfe, um weitere Einzelheiten über die Creator-Eigenschaft für Microsoft Office-Objekte anzuzeigen.

Private Sub GetAnswerWizardInfo()
Dim myAW As AnswerWizard
Dim myAWFiles As AnswerWizardFiles
Dim myAWCount As Integer
Dim myAWCreator As String

Set myAW = activeWeb.Application.AnwerWizard
Set myAW = myAW.Files

With myAWFiles
    myAWCreator = .Creator
    .Add ("myAWFile")
    myAWCount = .Count
End With
End Sub


Application-Eigenschaft

Gibt das Application-Objekt zurück. Schreibgeschütztes Objekt.

Hinweise

Wird diese Eigenschaft ohne Bezeichner verwendet, ermöglicht sie den direkten Zugriff auf das Microsoft FrontPage Application-Objekt. In Verbindung mit einem Objektbezeichner gibt diese Eigenschaft ein Application-Objekt zurück, das den Ersteller des angegebenen Objekts repräsentiert; Sie können diese Eigenschaft mit einem Automatisierungsobjekt verwenden, um die Anwendung dieses Objekts zurückzugeben.


Beispiel für die Application-Eigenschaft

Von den Objekten und Auflistungen im FrontPage-Objektmodell kann direkt auf den Anwendungsnamen zugegriffen werden. Mit dieser Anweisung wird die Anwendung zurückgegeben, auf die von der Files-Auflistung aus zugegriffen wird.

Set currApp = ActiveWeb.RootFolder.Files.Application


Build-Eigenschaft

Gibt die Buildnummer des angegebenen Objekts zurück. Schreibgeschützter Wert vom Typ String.

Hinweise

Wenn das Application-Objekt angegeben wird, gibt die Build-Eigenschaft die Buildnummer der Anwendung zurück. Wenn das System-Objekt angegeben wird, gibt diese Eigenschaft die Buildnummer des Betriebssystems zurück. Beispielsweise könnte das Format, das für das Dialogfeld Info einer Anwendung verwendet wird, folgendermaßen aussehen: „Version: 4.0.0.xxxx“, wobei xxxx für die Buildnummer der Anwendung steht. Wird auf die Build-Eigenschaft des System-Objekts zugegriffen, wird der aktuelle Build des Betriebssystems zurückgegeben, ein Verwendungszweck, den Sie auf der Registerkarte Allgemein des Dialogfeldes Eigenschaften für System vorfinden.


Beispiel für die Build-Eigenschaft

Mit der folgenden Anweisung wird die Buildnummer der Anwendung zurückgegeben.

myAppBuild = Application.Build

Auf den Systembuild können Sie wie in nachstehender Anweisung gezeigt zugreifen.

mySysbuild = System.Build


Caption-Eigenschaft

Gibt den Text der Titelleiste des angegebenen Objekts zurück. Schreibgeschütztes Objekt.

Hinweise

Die Caption-Eigenschaft gibt abhängig vom angegebenen Objekt unterschiedliche Werte zurück. Beispielsweise gibt die Caption-Eigenschaft des PageWindow-Objekts den URL der geöffneten Seite zurück, während die Caption-Eigenschaft des WebWindow-Objekts den Text der Titelleiste des Microsoft FrontPage-Anwendungsfensters zurückgibt.


Beispiel für die Caption-Eigenschaft

Mit dieser Anweisung wird die Titelzeile der aktiven Seite zurückgegeben.

myCaption = ActivePageWindow.Caption

In diesem Beispiel wird gezeigt, wie mithilfe der With- und For-Anweisungen sowohl auf das aktive WebWindow- als auch auf das PageWindow-Objekt zugegriffen werden kann.

Private Sub GetPageWindowCaption()
Dim myWebWindow As WebWindow
Dim myPageWindows As PageWindows
Dim myPageWindowCaptions As String
Dim myWebWindowCaption As String

Set myWebWindow = Application.ActiveWebWindow
Set myPageWindows = myWebWindow.PageWindows

With myWebWindow
    myWebWindowCaption = .Caption
End With

For Each myPageWindow in myPageWindows
    myPageWindowCaptions = myPageWindowCaption & myPageWindow.Caption
Next
End Sub


CheckedoutBy-Eigenschaft

Gibt den Anmeldenamen der Person zurück, für die das angegebene WebFile-Objekt ausgecheckt wurde. Schreibgeschütztes WebFile-Objekt.

Anmerkung Bevor Sie diese Methode verwenden können, muss ein Quellcodeverwaltungsprojekt eingerichtet worden sein.


Beispiel für die CheckedoutBy-Eigenschaft

In diesem Beispiel wird der Anmeldealiasname der Person abgerufen, die die Datei ausgecheckt hat.

Anmerkung Um dieses Beispiel nachvollziehen zu können, muss zuvor ein Quellcodeverwaltungsprojekt eingerichtet worden sein.

Private Sub GetCheckedOutBy()
Dim myCheckedOutAlias As String

myCheckedOutAlias = _
    ActiveWeb.RootFolder.Files(0).CheckedOutBy
End Sub


Children-Eigenschaft

Gibt die Auflistung der untergeordneten Navigationsknoten für einen Navigationsknoten zurück. Schreibgeschütztes Objekt.


Beispiel für die Children-Eigenschaft

In diesem Beispiel wird die Anzahl der untergeordneten Knoten zurückgegeben, die sich direkt unterhalb des Homepage-Navigationsknotens befinden.

Private Sub GetChildrenCount()
Dim myCount As Integer

myCount = ActiveWeb.HomeNavigationNode.Children.Count
End Sub


COMAddIns-Eigenschaft

Gibt das COMAddIns-Objekt zurück. Schreibgeschütztes Object-Objekt.

Hinweise

Alle registrierten FrontPage-Add-Ins finden sich in der Windows-Registrierung unter den folgenden Schlüsseln:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\FrontPage\AddIns

Add-Ins für Administratoren sind registriert unter:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\FrontPage\Addins


Beispiel für die COMAddIns-Eigenschaft

In diesem Beispiel wird die Anzahl der Add-Ins zurückgegeben, die für Microsoft FrontPage zur Verfügung stehen.

Private Sub GetCOMAddIns()
Dim myWeb As Web
Dim myAddinCount As Integer

Set myWeb = ActiveWeb
myAddinCount = Application.COMAddIns.Count

End Sub


CommandBars-Eigenschaft

Gibt ein CommandBars-Objekt zurück, das das Menü und die Symbolleisten repräsentiert, die in FrontPage angezeigt werden. Schreibgeschütztes Object-Objekt.

Hinweise

Mithilfe der CommandBars-Eigenschaft können Sie nicht auf die FrontPage-spezifischen Popup-Kontextmenüs zugreifen. Beispielsweise können Sie nicht auf das Kontextmenü zugreifen, das angezeigt wird, wenn Sie in der Seitenansicht mit der rechten Maustaste auf eine Seite klicken. Allerdings können Sie mithilfe der ShowPopup-Methode für das CommandBar-Objekt eigene Popup-Kontextmenüs erstellen.


Beispiel für die CommandBars-Eigenschaft

Mit den folgenden drei Prozeduren wird auf einer Symbolleiste ein neues Menüelement eingerichtet.

Prozedur 1:

Sub AddMenuItem()
Dim newMenu As CommandBarControl
Dim toolsMenu As CommandBar
Set toolsMenu = Application.CommandBars("Tools")

Set newMenu = _
  toolsMenu.Controls.Add(msoControlButton, , , , True)

newMenu.Caption = "New &Menu Item"
End Sub

Mit dieser nächsten Prozedur, die einem Klassen- oder Formularmodul hinzugefügt werden muss, wird das Click-Ereignis mit der benutzerdefinierten Schaltfläche verbunden. Beim gezeigten Modul handelt es sich um ein Formularmodul. Mit der Prozedur wird dem Menü Tools ein neues Element hinzugefügt, und die Ereignisse der benutzerdefinierten Schaltfläche werden verbunden, indem die Variable e_NewMenu (die in der WithEvents-Anweisung verwendet wird) der Variablen newMenu der benutzerdefinierten Schaltfläche zugewiesen wird.

Prozedur 2:

Private Sub AddButton_Click()
Dim newMenu As CommandBarControl
Dim WithEvents e_NewMenu As CommandBarButton

Sub AddMenuItemWithEventHook()
Dim toolsMenu As CommandBar
Set toolsMenu = Application.CommandBars("Tools")

Set newMenu = _
  toolsMenu.Controls.Add(msoControlButton, , , , True)

Set e_NewMenu = newMenu
newMenu.Caption = "New &Menu Item"
End Sub

Private Sub e_NewMenu_Click(ByVal Ctrl As _
  Office.CommandBarButton, CancelDefault As Boolean)
MsgBox "Menu Item Clicked"
ctrl.caption = "Clicked"
End Sub

Zum Ausführen der benutzerdefinierten Menüelemente von FrontPage unter Verwendung der CommandBars-Auflistung indizieren Sie das Menüelement und rufen die Ausführungsmethode (Execute) für dieses Element auf. Im folgenden Beispiel wird ein Microsoft Office Spreadsheet-Steuerelement an der Einfügemarke eingefügt.

Prozedur 3:

Sub ExecuteMenu()
Dim I As String
Dim C As String
Dim O As String

I = "Insert"
C = "C&omponent"
O = "Office Sp&readsheet"

CommandBars(I).Controls(C).Controls(O).Execute
End Sub

Im folgenden Beispiel wird der Status verschiedener Eigenschaften der Befehlsleisten im aktiven Web zurückgegeben.

Private Sub GetCommandBars()
Dim myWeb As Web
Dim myCB As Object
Dim myCBCount As Integer
Dim myDisplayFonts As Boolean
Dim myDisplayKeysInToolTips As Boolean
Dim myLargeButtons As Boolean
Dim myMenuAnimationStyle As String

Set myWeb = ActiveWeb
Set myCB = Application.CommandBars

With myCB
    myCBCount = .Count
    myDisplayFonts = .DisplayFonts
    myDisplayKeysInToolTips = .DisplayKeysInToolTips
    myLargeButtons = .LargeButtons
    myMenuAnimationStyle = .MenuAnimationStyle
End With
End Sub

Das folgende Beispiel ist ein Tool, das die Befehlsleisten durchläuft und verschiedene Eigenschaften aus jedem Menü zurückgibt.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einem Textfeld namens txtComBar und einer Befehlsschaltfläche namens cmdComBar, und kopieren Sie den folgenden Code in das Codefenster.

Private Sub cmdComBar_Click()
Dim myWeb As Web
Dim myComBars As Object
Dim myComBar As Object
Dim myText As String
Dim myName As String
Dim myAdaptMenu As String
Dim myEnabledMenu As String
Dim myMenuHeight As String
Dim myMenuWidth As String

Set myWeb = ActiveWeb
Set myComBars = Application.CommandBars
myName = "Name: "
myAdaptMenu = "Menu Adaptive? "
myEnabledMenu = "Menu Enabled? "
myMenuHeight = "Menu Height: "
myMenuWidth = "Menu Width: "
txtComBar.Locked = True
txtComBar.MaxLength = 10000
txtComBar.MultiLine = True
txtComBar.ScrollBars = fmScrollBarsVertical

With myComBars
    For Each myComBar In myComBars
        With myComBar
            myText = myText & myName & .Name & vbCrLf
             myText = myText & myAdaptMenu _
                 & .adaptivemenu & vbCrLf
            myText = _
                myText & myEnabledMenu & .Enabled _
                & vbCrLf
            myText = myText & myMenuHeight & .Height _
                & vbCrLf
            myText = myText & myMenuWidth & .Width _
                & vbCrLf
            txtComBar.Text = myText
        End With
    Next
txtComBar.SetFocus
txtComBar.CurLine = 0
End With
End Sub


Count-Eigenschaft

Gibt die Anzahl der Elemente in der angegebenen Auflistung zurück. Schreibgeschützter Wert vom Typ Variant.

Hinweise

Einige Auflistungen basieren auf dem Wert 0 und einige auf dem Wert 1. Die Count-Eigenschaft für Auflistungen beginnt mit 1, obwohl Sie auf das erste Element einer Auflistung mit einer 0 zugreifen.


Beispiel für die Count-Eigenschaft

Im folgenden Beispiel wird die Anzahl der Designs und Ordner im aktiven Web zurückgegeben.

Private Sub GetWebCount()
Dim myWeb As Web
Dim myCount As Integer

Set myWeb = ActiveWeb

With myWeb
    myThemeCount = .Themes.Count
    myFolderCount = .RootFolder.Folders.Count
End With
End Sub


Creator-Eigenschaft

Gibt eine Zeichenfolge zurück, mit der die Anwendung angegeben wird, in der das Objekt erstellt wurde. Wenn das Objekt in Microsoft FrontPage erstellt wurde, gibt diese Eigenschaft die Zeichenfolge „FrontPage.Editor.Document“ zurück. Schreibgeschützter Wert vom Typ String.

Anmerkung Die Creator-Eigenschaft für FrontPage unterscheidet sich von der Creator-Eigenschaft, die in anderen Microsoft Office-Objekten verwendet wird. Die Creator-Eigenschaft für FrontPage verwendet ein Zeichenfolgenformat, während bei Office-Objekten eine 32-Bit-Ganzzahl verwendet wird, um die Anwendung zu kennzeichnen, in der die Datei erstellt wurde.


Beispiel für die Creator-Eigenschaft

In diesem Beispiel wird geprüft, ob FrontPage der Ersteller einer Datei ist.

Private Sub GetCreator()
Dim myCreator As String

myCreator = ActiveWeb.RootFolder.Files(0).Creator

If myCreator <> "FrontPage.Editor.Document" Then
    MsgBox "This file was not created by FrontPage."
End If
End Sub


Document-Eigenschaft

Gibt das IHTMLDocument2-Objekt zurück. Schreibgeschütztes Object-Objekt.

Hinweise

Die Document-Eigenschaft ermöglicht den Zugriff auf das Page-Objektmodell in Microsoft FrontPage, das mit Internet Explorer, Version 4.0 und höher, kompatibel ist. Weitere Informationen über das Page-Objektmodell finden Sie unter Erforschen des Objektmodells in FrontPage.


Beispiel für die Document-Eigenschaft

In diesem Beispiel wird eine Seite geöffnet und dem Dokument mithilfe der insertAdjacentText-Methode Text hinzugefügt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. In beiden Fällen können Sie alternativ anstelle des angegebenen Web-URLs auch einen anderen URL oder eine andere Datei verwenden. Darüber hinaus müssen Sie auch über eine Datei mit Namen Sales.htm verfügen oder diese durch eine andere Datei ersetzen.

Private Sub AddTextToDoc()
Dim myWeb As Web
Dim myPageWindow As PageWindow
Dim myText As String

Set myWeb = _
    Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
myWeb.Activate
myText = "Winter Sale Begins November 1st!"
Set myPageWindow = _
    ActiveWeb.RootFolder.Files("Sales.htm").Edit

myPageWindow.Document.body.insertAdjacentText _
    "BeforeEnd", myText

ActivePageWindow.Save
ActiveWeb.Close
End Sub


Extension-Eigenschaft

Gibt die Dateinamenerweiterung der angegebenen Datei zurück. Schreibgeschützter Wert vom Typ String.


Beispiel für die Extension-Eigenschaft

Mit dieser Anweisung wird die Dateinamenerweiterung der Homepage zurückgegeben.

myHomePageExt = ActiveWeb.RootFolder.File(0).Extension


File-Eigenschaft

Gibt das WebFile-Objekt zurück, das mit dem angegebenen Objekt verbunden ist. Schreibgeschütztes Objekt.


Files-Eigenschaft

Gibt die Elemente in der WebFiles-Auflistung zurück. Schreibgeschütztes Objekt.

Hinweise

Die Files-Eigenschaft verweist auf die WebFiles-Auflistung. Für den Zugriff auf die Auflistung deklarieren Sie eine Variable vom Typ WebFiles, wie in der Anweisung Dim myFiles As WebFiles gezeigt, und legen dann die Variable myFiles auf Web.RootFolder.Files fest.


FileSearch-Eigenschaft

Gibt das msoFileSearch-Objekt zurück. Schreibgeschütztes FileSearch-Objekt.

Hinweise

Das FileSearch-Objekt akzeptiert keinen URL (Uniform Resource Locator) als Wert für einen Dateinamen oder Ordner.


Beispiel für die FileSearch-Eigenschaft

In diesem Beispiel werden das Web „Adventure Works“ und dessen Unterverzeichnisse gesucht, und es wird die Anzahl der Index.htm-Dateien zurückgegeben, die im Web vorhanden sind.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Adventure Works (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Personal\Eigene Webs\Adventure Works (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen. Alternativ können Sie den Wert für LookIn auf ein Web ändern, das Ihnen aktuell zur Verfügung steht. Darüber hinaus müssen Sie einen Verweis auf die Microsoft Office 9.0-Objektbibilothek festlegen.

Private Sub WebFileSearch()
Dim myFileSearch As FileSearch
Dim myFileCount As Integer

Set myFileSearch = Application.FileSearch

With myFileSearch
    .FileName = "index.htm"
    .LookIn = "C:\My Webs\Adventure Works"
    .SearchSubFolders = True
    .Execute
    myFileCount = .FoundFiles.Count
End With
End Sub


Folders-Eigenschaft

Gibt die Elemente in der WebFolders-Auflistung zurück. Schreibgeschütztes Objekt.

Hinweise

Die Folders-Eigenschaft gibt die WebFolders-Auflistung des angegebenen Webs zurück. Für den Zugriff auf die Auflistung deklarieren Sie eine Variable vom Typ WebFolders, wie in der Anweisung Dim myFolders As WebFolders gezeigt, und legen dann die Variable auf Web.RootFolder.Folders fest.


Beispiel für die Folders-Eigenschaft

In diesem Beispiel werden zwei der Eigenschaften eines Ordners abgerufen, und die Daten werden zu einer Zeichenfolge verkettet, wobei die Daten mit einem senkrechten Balken (Pipe, „|“) als Trennzeichen separiert werden.

Anmerkung Die in diesem Beispiel verwendeten PropertyKeys beziehen sich auf ein Web, das mit dem Assistenten zur Erstellung eines Webs mit einer Seite erstellt wurde. Bei anderen Vorlagen werden möglicherweise andere PropertyKeys verwendet.

Private Sub GetFolderProperties()
Dim myFolders As WebFolders
Dim myFolder As WebFolder
Dim myHasSubDirs As String
Dim myIsScriptable As String
Dim myProperties As Properties

Set myFolders = ActiveWeb.Rootfolder.Folders

For Each myFolder In myFolders
    Set myProperties = myFolder.Properties

    myHasSubDirs = myHasSubDirs & _
        myProperties("vti_ hassubdirs") & "|"
    myIsScriptable = myIsScriptable & _
        myProperties("vti_ isscriptable") & "|"
Next
End Sub


Format-Eigenschaft

Gibt das Format des angegebenen Theme-Objekts zurück. Schreibgeschützer Wert vom Typ String.

Hinweise

Im Designformat zeigt sich der Unterschied zwischen den Formaten für Microsoft FrontPage 98 und Microsoft FrontPage 2000. Die Formatversion für FrontPage 98 kann entweder 0.0 oder 1.0 lauten, während die Formatversion für FrontPage 2000 2.0 lautet.


Beispiel für die Format-Eigenschaft

In diesem Beispiel wird das Format des dem aktiven Web zugewiesenen Designs abgerufen.

Private Sub GetThemeFormat()
Dim myFormat As String

myFormat = ActiveWeb.Themes(0).Format
End Sub


FrameWindow-Eigenschaft

Gibt das FPHTMLWindow2-Objekt zurück. Die Document-Eigenschaft des FPHTMLWindow2-Objekts verweist auf das FPHTMLDocument-Objekt der Framesseite. Schreibgeschütztes Object-Objekt.


Beispiel für die FrameWindow-Eigenschaft

In diesem Beispiel wird die IHTMLLocation-Eigenschaft des FrameWindow-Objekts abgerufen.

Private Sub GetFrameWindowLocation()
Dim myWeb As Web
Dim myPage As PageWindow
Dim myFrameWindowLocation As String

Set myWeb = Webs("C:\My Webs\Rogue Cellars")
Set myPage = _
    myWeb.ActiveWebWindow.ActivePageWindow
myFrameWindowLocation = myPage.FrameWindow.Location.href
End Sub


Home-Eigenschaft

Gibt ein HomeNavigationNode-Objekt für das Navigation-Objekt zurück. Schreibgeschütztes Objekt.


HomeNavigationNode-Eigenschaft

Gibt den Navigationsknoten für die Homepage zurück. Schreibgeschütztes Objekt.

Hinweise

Der Home-Navigationsknoten ist der Ausgangspunkt für die gesamte Navigationsadressierung innerhalb der Navigationsstruktur. Immer wenn Sie einen Knoten hinzufügen, verschieben oder löschen, eines der Attribute eines Knotens ändern oder einfach nur auf die aktuelle Navigationsstruktur zugreifen möchten, verwenden Sie als Ausgangspunkt das HomeNavigationNode-Objekt. Nur wenn Sie einen Navigationsknoten, der sich auf der gleichen Ebene wie das HomeNavigationNode-Objekt befindet, hinzufügen oder auf einen solchen zugreifen möchten, verwenden Sie das RootNavigationNode-Objekt für den Zugriff auf die Navigationsstruktur.


Beispiel für die HomeNavigationNode-Eigenschaft

In diesem Beispiel wird auf das HomeNavigationNode-Objekt zugegriffen, und der URL der Homepage wird abgerufen.

Private Sub GetHomeNavigationNode()
Dim myWeb As Web
Dim myHomeNode As NavigationNode
Dim myHomeUrl As String

Set myWeb = ActiveWeb

myHomeNode = myWeb.HomeNavigationNode
myHomeURL = myHomeNode.Url
End Sub


HorizontalResolution-Eigenschaft

Gibt die horizontale Auflösung des Bildschirms in Pixel zurück. Schreibgeschützter Wert vom Typ Long.


Beispiel für die HorizontalResolution-Eigenschaft

In diesem Beispiel wird die horizontale Auflösung des Bildschirms zurückgegeben.

myHoriz = System.HorizontalResolution


IsDirty-Eigenschaft

Gibt True zurück, wenn das PageWindow-Objekt seit dem letzten Speichern des Objekts geändert wurde. Schreibgeschützter Wert vom Typ Long.


Beispiel für die IsDirty-Eigenschaft

In diesem Beispiel wird geprüft, ob die aktive Seite geändert wurde; falls zutreffend führt das Programm die Save-Methode für die aktive Seite durch.

Private Sub DirtyDocument()
Dim myPage As PageWindow
Dim myDoc As FPHTMLDocument
Dim mySaveCheck As Boolean

Set myDoc = WebWindows(0).PageWindows(0).Document

Call myDoc.body.insertAdjacentHTML("BeforeEnd", _
    "<b> modified </b>")
If ActivePageWindow.IsDirty = True Then
    ActivePageWindow.Save
End If
End Sub


IsExecutable-Eigenschaft

Gibt die Einstellung für die Ausführungsberechtigung eines WebFolder-Objekts zurück. Wert vom Typ Boolean, der gelesen und geschrieben werden kann.


Beispiel für die IsExecutable-Eigenschaft

In diesem Beispiel wird die Einstellung der IsExecutable-Eigenschaft eines WebFolder-Objekts abgerufen.

Private Sub CheckExecutable()
Dim myFolder As WebFolder
Dim myExeStatus As Boolean

Set myFolder = ActiveWeb.RootFolder.Folders("images")
myExeStatus = myFolder.IsExecutable

End Sub


IsOpen-Eigenschaft

Diese Eigenschaft gibt True zurück, wenn das aktive WebFile-Objekt geöffnet ist. Schreibgeschützter Wert vom Typ Boolean.


Beispiel für die IsOpen-Eigenschaft

In diesem Beispiel wird die IsOpen-Eigenschaft verwendet, um zu prüfen, ob eine Datei geöffnet ist.

Private Sub CheckForOpenFile()
Dim myWeb As Web
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myFileToOpen As String
Dim myMessage As String
Dim myFileName As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

myFileToOpen = "index.htm"
myMessage = "This file is open, try again later."

With myWeb
    For Each myFile In myFiles
        If myFileName = myFileToOpen Then
                If myFile.IsOpen = True Then
                MsgBox (myMessage)
                Exit Sub
            Else
                myFile.Open (fpPageViewNormal)
                Exit Sub
            End If
        End If
    Next
End With
End Sub


IsReadable-Eigenschaft

Gibt die Einstellung für die Leseberechtigung eines WebFolder-Objekts zurück. Wert vom Typ Boolean, der gelesen und geschrieben werden kann.


Beispiel für die IsReadable-Eigenschaft

In diesem Beispiel wird die Einstellung der IsReadable-Eigenschaft eines WebFolder-Objekts abgerufen.

Private Sub CheckReadable()
Dim myFolder As WebFolder
Dim myReadStatus As Boolean

Set myFolder = ActiveWeb.RootFolder.Folders("images")
myReadStatus = myFolder.IsReadable

End Sub


IsRoot-Eigenschaft

Gibt zurück, ob ein WebFolder-Objekt als Stammweb definiert wurde. Schreibgeschützter Wert vom Typ Boolean.


Beispiel für die IsRoot-Eigenschaft

In diesem Beispiel wird die Einstellung der IsRoot-Eigenschaft eines WebFolder-Objekts abgerufen.

Private Sub CheckExecutable()
Dim myFolder As WebFolder
Dim myIsRoot As Boolean

Set myFolder = ActiveWeb.RootFolder.Folders("images")
myIsRoot = myFolder.IsRoot

End Sub


IsUnderRevisionControl-Eigenschaft

Gibt True zurück, wenn für das aktive Web-Objekt die Quellcodeverwaltung verwendet wird. Schreibgeschützter Wert vom Typ Boolean.

Hinweise

Um die Versionskontrolle verwenden zu können, müssen Sie über ein Quellcodeverwaltungsprojekt verfügen, das mit Microsoft Visual SourceSafe oder Microsoft Office erstellt wurde.


Beispiel für die IsUnderRevisionControl-Eigenschaft

In diesem Beispiel wird ein Quellcodeverwaltungsprojekt erstellt, und anschließend wird in der zweiten Prozedur der Status der IsUnderRevisionControl-Eigenschaft geprüft.

Private Sub SourceControlProject()
Dim myWeb As Web

Set myWeb = ActiveWeb

If Not (myWeb.IsUnderRevisionControl) Then
    myWeb.RevisionControlProject = _
        "<FrontPage-based Locking>"
End If
End Sub

Private Sub GetRevisionState()
Dim myWeb As Web
Dim myRevCtrlProj As String
Dim myIsRevCtrl As Boolean

Set myWeb = ActiveWeb

With myWeb
    myRevCtrlProj = .RevisionControlProject
    myIsUnderRevCtrl = .IsUnderRevisionControl
End With
End Sub


IsWeb-Eigenschaft

Gibt zurück, ob ein WebFolder-Objekt als Web definiert wurde. Schreibgeschützter Wert vom Typ Boolean.


Beispiel für die IsWeb-Eigenschaft

In diesem Beispiel wird die Einstellung der IsWeb-Eigenschaft eines WebFolder-Objekts abgerufen.

Private Sub CheckExecutable()
Dim myFolder As WebFolder
Dim myWebStatus As Boolean

Set myFolder = ActiveWeb.RootFolder.Folders("images")
myWebStatus = myFolder.IsWeb

End Sub


IsWritable-Eigenschaft

Gibt die Einstellung für die Schreibberechtigung eines WebFolder-Objekts zurück. Schreibgeschützter Wert vom Typ Boolean.


Beispiel für die IsWritable-Eigenschaft

In diesem Beispiel wird die Einstellung der IsWritable-Eigenschaft eines WebFolder-Objekts abgerufen.

Private Sub CheckExecutable()
Dim myFolder As WebFolder
Dim myWritableStatus As Boolean

Set myFolder = ActiveWeb.RootFolder.Folders("images")
myWritableStatus = myFolder.IsWritable

End Sub


Item-Eigenschaft

Gibt ein einzelnes Objekt aus einer Auflistung basierend auf dem Wert des Arguments Index zurück. Schreibgeschützter Wert vom Typ String.

Syntax 1: Gibt den PropertyKey für die angegebenen MetaTags- oder Properties-Auflistungen zurück.

Syntax 2: Gibt die Indexnummer des angegebenen Objekts zurück. Hierbei kann es sich um eine der folgenden Auflistungen handeln: NavigationNodes, PageWindows, Themes, WebFiles, WebFolders, Webs oder WebWindows.

Syntax 1

Ausdruck.Item(PropertyKey as String)

Ausdruck Ein Ausdruck, der ein Auflistungsobjekt zurückgibt.

PropertyKey Erforderlicher Wert vom Typ String. Eine Zeichenfolge, die eine Indexnummer aus der Auflistung umfasst. Der Index beginnt mit Null.

Syntax 2

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein Auflistungsobjekt zurückgibt.

Index Erforderlicher Wert vom Typ Variant. Bezieht sich auf ein Element in der Auflistung. Kann eine beliebige Zahl sein, die der Indexnummer eines Elements in der Auflistung entspricht, wobei der Index mit Null beginnt.


Beispiel für die Item-Eigenschaft

Im folgenden Beispiel wird gezeigt, wie ein Wert zurückgegeben wird, indem ein Element in der Auflistung indiziert wird. In diesem Beispiel wird die Beschriftung des ersten Navigationsknotens in der Navigationsstruktur des aktiven Webs zurückgegeben.

Anmerkung Auf die NavigationNodes-Auflistung greifen Sie über die Children-Eigenschaft der RootNavigationNode-Eigenschaft des aktiven Webs zu.

Private Sub GetNavigationNode()
Dim myWeb As Web
Dim myNavNodes As NavigationNodes
Dim myNavNodeLabel As String

Set myWeb = ActiveWeb

myNavNodeLabel _
    = myWeb.RootNavigationNode.Children.Item(0).Label
End Sub

Anmerkung Sie können die Item-Eigenschaft auch auslassen und auf das angegebene Element zugreifen, indem Sie die nachstehende Codierungsmethode verwenden. Mit der folgenden Anweisung wird der gleiche Wert wie mit der vorstehenden Anweisung zurückgegeben. Weitere Informationen und ein zusätzliches Beispiel zum Auslassen der Item-Eigenschaft finden Sie im letzten Absatz dieses Abschnitts.

myNavNodeLabel _
    = myWeb.RootNavigationNode.Children(0).Label

Mit der folgenden Anweisung wird der Inhalt eines Metatags zurückgegeben, das sich auf einer Webseite im aktiven Web befindet, und die Funktion des Arguments PropertyKey wird demonstriert.

myMetaTagContents _
    = ActiveWeb.RootFolder.Files.Item(0).MetaTags.Item("generator")

Anmerkung Auf der Registerkarte HTML in der Seitenansicht zeigt FrontPage dieses Metatag mit einem Großbuchstaben am Anfang an (Generator). Als Wert wird dieses Metatag-Element jedoch komplett kleingeschrieben (generator). Wenn Sie den Anfangsbuchstaben eines META-Tagnamens großschreiben und diesen Namen als Suchkriterium in einem Visual Basic-Programm verwenden, schlägt die Suche fehl.

Es ist nicht immer notwendig, den Index oder den Eigenschaftsnamen der Item-Eigenschaft anzugeben, wenn Werte aus einer Auflistung zurückgegeben werden sollen. Im folgenden Beispiel wird eine Liste mit den Dateinamen jeder Webseite im aktiven Web zurückgegeben, die einen „generator“ entsprechenden Metatagnamen enthält, ohne dass die Item-Eigenschaft angegeben wird. FindGeneratorTags ruft eine Liste der Dateien ab, die das Metatag „generator“ enthalten und fügt der Variablen myMetaTag den Wert der Item-Eigenschaft hinzu, da in diesem Fall der Wert der Item-Eigenchaft gleich dem Dateinamen ist. Hierin unterscheidet sich dieses vom vorherigen Beispiel, in dem der Inhalt des Metatags „generator“ zurückgegeben wurde.

Private Function FindGeneratorTags() As String
Dim myWeb As Web
Dim myMetaTags As MetaTags
Dim myMetaTag As Variant
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myMetaTagName As String
Dim myReturnFileName As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myWeb
    For Each myFile In myFiles
        Set myMetaTags = myFile.MetaTags
        For Each myMetaTag In myMetaTags
            myMetaTagName = myMetaTag
            If myMetaTagName = "generator" Then
                myReturnFileName = myReturnFileName & myFile.Name
            End If
        Next
    Next
End With
FindGeneratorTags = myReturnFileName
End Function


Label-Eigenschaft

Gibt die Bezeichnung zurück, die mit dem aktiven Navigationsknoten verbunden ist. Diese Bezeichnung wird als Verweis für einzelne Navigationsknoten in der Navigationsansicht oder als Name eines Designs verwendet. Wert vom Typ String, der gelesen und geschrieben werden kann.

Hinweise

Verwenden Sie den Text in einem Label-Objekt als Text für ein Banner oder für eine Schaltfläche, die einen Link zu einem anderen Navigationsknoten in der Navigationsstruktur bereitstellt.


Beispiel für die Label-Eigenschaft

In diesem Beispiel wird der Text für die Bezeichnung des ersten untergeordneten Knotens festgelegt. Die Bezeichnung zeigt die Platzierung des Knotens in der Navigationsansicht.

Private Sub AddLabelToNavigationNode()
Dim myNode As NavigationNode

Set myNode = ActiveWeb.HomeNavigationNode.Children(0)

myNewNode.Label = “Finance Page”
End Sub

Im folgenden Beispiel wird der Name eines Designs abgerufen.

Anmerkung Wenn Sie dieses Verfahren ausführen möchten, müssen Sie über ein geöffnetes Web mit einer Seite verfügen, der zuvor ein Design zugewiesen war.

Private Sub GetThemeName()
Dim myTheme As String

myTheme = ActiveWeb.Themes(0).Label
End Sub


LanguageDesignation-Eigenschaft

Gibt den abgekürzten Namen der in der Systemsoftware festgelegten Sprache zurück. Schreibgeschützter Wert vom Typ String.

Hinweise

Wenn Sie die zwei Buchstaben umfassende Sprachabkürzung des ISO-Standards 639 zugrunde legen und einen dritten Buchstaben hinzufügen, wie beispielsweise „u“ für die Vereinigten Staaten, wird eine drei Buchstaben umfassende Sprachabkürzung erstellt.

Sie können eine aus zwei Buchstaben bestehende Sprachabkürzung auch mit GetLocaleInfo() auslesen, indem Sie LOCALE_SABBREVLANGNAME als den LCType angeben. Der abgekürzte Name „enu“ wird für die Sprache Englisch (US) zurückgegeben, und es handelt sich hierbei um die gleiche Abkürzung, die auch mit der LanguageDesignation-Eigenschaft zurückgegeben wird.


Beispiel für die LanguageDesignation-Eigenschaft

In diesem Beispiel wird der abgekürzte Name der in der Systemsoftware festgelegten Sprache zurückgegeben.

myLang = System.LanguageDesignation


LanguageSettings-Eigenschaft

Gibt das LanguageSettings-Objekt für die Microsoft FrontPage-Anwendung zurück. Schreibgeschütztes LanguageSettings-Objekt.


Beispiel für die LanguageSettings-Eigenschaft

In diesem Beispiel wird die LanguageID-Eigenschaft für die Benutzeroberfläche zurückgegeben, und die LanguagePreferredForEditing-Eigenschaften werden festgelegt.

Anmerkung Die LanguageSettings-Eigenschaft verfügt über eine erforderliche Konstante namens MsoAppLanguageID. Die Aufzählungswerte für diese Konstante sind msoLanguageIDHelp, msoLanguageIDInstall, msoLanguageIDUI und msoLanguageIDUIPrevious. Die LanguagePreferredForEditing-Eigenschaft verfügt ebenfalls über Aufzählungskonstanten für die verfügbaren Sprachen. Weitere Informationen hierzu finden Sie im Hilfethema zum LanguageSettings-Objekt.

Private Sub GetLanguageInfo()
Dim myLSet As LanguageSettings
Dim myLangID As String
Dim prfLang As String

Set myLSet = Application.LanguageSettings

With myLSet
myLangID = .LanguageID(msoLanguageIDUI)
prfLang = _
.LanguagePreferredForEditing(msoLanguageIDEnglishUS) _
  = True
End With
End Sub


MetaTags-Eigenschaft

Gibt die MetaTags-Auflistung des angegebenen WebFile-Objekts zurück. Schreibgeschützte MetaTags.


Beispiel für die MetaTags-Eigenschaft

In diesem Beispiel wird die MetaTags-Auflistung durchlaufen, und die Datei- und MetaTag-Namen werden zu einer Zeichenfolge mit Namen myReturnInfo verkettet.

Private Sub GetMetaTagInfo_Click()
Dim myWeb As Web
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myMetaTags As MetaTags
Dim myMetaTag As Variant
Dim myFileName As String
Dim myMetaTagName As String
Dim myReturnInfo As String

Set myWeb = ActiveWeb
Set myFiles = myWeb.RootFolder.Files

With myWeb
    For Each myFile In myFiles
        Set myMetaTags = myFile.MetaTags
        For Each myMetaTag In myMetaTags
            myFileName = myFile.Name
            myMetaTagName = myMetaTag
            myReturnInfo = myFileName & ": " _
                & myMetaTagName
        Next
    Next
End With
End Sub


Name-Eigenschaft

Gibt den Wert des Namens als Zeichenfolge zurück, der dem angegebenen Objekt zugewiesen wurde. Schreibgeschützter Wert vom Typ String.

Hinweise

Der Name einer Datei oder eines Ordners ist normalerweise der letzte Teil eines URLs. Beispielsweise stellt im URL C:\Eigene Webs\Adventure Works\index.htm der Teil index.htm das Name-Objekt der Datei dar. Ebenso steht im URL C:\Eigene Webs\Adventure Works\Images Images für das Name-Objekt des Ordners.


Beispiel für die Name-Eigenschaft

Mit der folgenden Anweisung wird mit AppName als Variable vom Typ String der Name der Anwendung zurückgegeben.

AppName = Application.Name


NavigationNode-Eigenschaft

Gibt für das WebFile-Objekt das aktuelle NavigationNode-Objekt in der Navigationsstruktur zurück. Schreibgeschütztes Objekt.

Hinweise

Wenn innerhalb der Navigationsstruktur des aktuellen FrontPage-basierten Webs kein NavigationNode-Objekt gefunden werden kann, gibt die NavigationNode-Eigenschaft Null zurück.


Beispiel für die NavigationNode-Eigenschaft

In diesem Beispiel wird die NavigationNode-Eigenschaft verwendet, um den Dateinamen zurückzugeben, der mit dem Navigationsknoten verbunden ist.

Private Sub GetNavNode()
Dim myWeb As Web
Dim myNavNode As NavigationNode
Dim myNavNodeLabel As String

Set myWeb = ActiveWeb
Set myNavNode = _
    myWeb.RootNavigationNode.Files(0).NavigationNode

With myNavNode
    myNavNodeLabel = .Label
End With
End Sub


Next-Eigenschaft

Gibt den nächsten Navigationsknoten in der Navigationsabfolge zurück. Schreibgeschütztes Objekt.

Hinweise

Obwohl die Next-Eigenschaft ein Mitglied der NavigationNode-Klasse ist, dient diese Eigenschaft zur Navigation innerhalb der Children-Auflistung des angegebenen NavigationNode-Objekts.

Anmerkung Die Children-Auflistung verfügt nicht über eine Mantelfunktion, so dass bei Code wie Children(Children.Count – 1).Next die Fehlermeldung „Object or With variable not set“ zurückgegeben wird.


Beispiel für die Next-Eigenschaft

In diesem Beispiel wird der Navigationszeiger auf den nächsten Knoten verschoben, es sei denn, der aktuelle Knoten ist der letzte Knoten auf dieser Ebene der Navigationsstruktur.

Private Sub MoveNext()
Dim theNode As NavigationNode
Dim theNextNode As NavigationNode
On Error Resume Next

Set theNode = ActiveWeb.HomeNavigationNode.Children(1)
Set theNextNode = theNode.Next

If Err <> 0 then
    MsgBox “End of the current navigation row”
End If
End Sub


OperatingSystem-Eigenschaft

Gibt den Namen des aktuellen Betriebssystems, beispielsweise „Windows“ oder „Windows NT“, zurück. Schreibgeschützter Wert vom Typ String.


Beispiel für die OperatingSystem-Eigenschaft

Im folgenden Beispiel werden in einem Beschriftungsfeld auf einem Formular Systeminformationen angezeigt.

lblSystemInfo.Caption=System.OperatingSystem

In diesem Beispiel wird der Name des aktuellen Betriebssystems im Direkt-Fenster gedruckt.

myOpSys = System.OperatingSystem


OrganizationName-Eigenschaft

Gibt den Namen der Organisation für die Anwendung zurück. Schreibgeschütztes Object-Objekt.

Anmerkung Der Name der Organisation wird normalerweise während der Installation einer Anwendung oder eines Betriebssystems festgelegt.


Beispiel für die OrganizationName-Eigenschaft

Anstatt für Ihre Webseite eine Variable „Name der Organisation“ zu erstellen, können Sie den Organisationsnamen wie in der folgenden Anweisung gezeigt verwenden.

myCompanyName = Application.OrganizationName


PageWindows-Eigenschaft

Gibt das angegebene PageWindow-Objekt zurück. Schreibgeschütztes PageWindows-Objekt.


Beispiel für die PageWindows-Eigenschaft

In diesem Beispiel wird ein Seitenfenster abgerufen, das die Seite Spain.htm enthält, und der Ansichtsmodus wird auf „Vorschau“ festgelegt.

Anmerkung Zum Ausführen dieser Prozedur müssen Sie über ein geöffnetes Web mit einer offenen Seite namens Spain.htm verfügen; alternativ können Sie auch mit einer Datei Ihrer Wahl arbeiten.

Private Sub SetPagePreview()
Dim myPage As PageWindow

Set myPage = ActiveWebWindow.PageWindows("Spain.htm")
myPage.ViewMode = fpPageViewPreview
End Sub


Parent-Eigenschaft

Gibt den Namen des Parent-Objekts des angegebenen Objekts zurück. Schreibgeschütztes Objekt.

Hinweise

Bei Angabe der Parent-Eigenschaft eines WebFile-Objekts wird das WebFolder-Objekt zurückgegeben. Wenn ein Objekt in einem Web enthalten ist, gibt die Parent-Eigenschaft das Web-Objekt zurück. Befindet sich beispielsweise das Theme-Objekt in einem Web-Objekt mit Namen „Adventure Works Web“, gibt die Parent-Eigenschaft „Adventure Works Web“ zurück; andernfalls gibt die Parent-Eigenschaft beim Verweis auf ein Design, das sich außerhalb eines Web-Objekts befindet, den Namen des Application-Objekts zurück, d. h. in diesem Beispiel würde „Microsoft FrontPage“ zurückgegeben. Wird seitens eines Clientcomputers jedoch das System-Objekt angegeben, gibt die Parent-Eigenschaft das Application-Objekt des Hosts und nicht des Clients zurück.

In der folgenden Tabelle werden die Werte erläutert, die für die unterschiedlichen Objekttypen zurückgegeben werden.

Objekt | Beschreibung
MetaTags | Gibt das WebFile-Objekt für die MetaTags zurück.
NavigationNode | Gibt das übergeordnete NavigationNode-Objekt zurück; dies gilt jedoch nicht für das RootNavigationNode-Objekt. Dessen übergeordnetes Objekt ist das Web.
NavigationNodes | Gibt das übergeordnete NavigationNode-Objekt der Auflistung der Navigationsknoten basierend auf der Navigationsstruktur zurück.
PageWindow | Gibt das WebWindow- oder Application-Objekt zurück, in dem sich die Seite befindet.
PageWindows | Gibt das Application-Objekt zurück, das die Auflistung enthält.
Properties | Gibt das Web-, das WebFile- oder das WebFolder-Objekt aus der MetaTag-Information zurück.
System | Gibt das Application-Objekt zurück.
Theme | Gibt das übergeordnete (Web- oder WebFile-) Objekt des Designs zurück.
Themes | Gibt das Web-Objekt zurück, das die Auflistung enthält.
Web | Gibt das Application-Objekt zurück.
WebFile | Gibt das WebFolder-Objekt zurück.
WebFiles | Gibt das übergeordnete WebFolder-Objekt zurück.
WebFolder | Gibt entweder das übergeordnete WebFolder-Objekt zurück (sofern es sich um einen Unterordner handelt) oder gibt das Web-Objekt des Stammordners zurück.
WebFolders | Gibt das WebFolder-Objekt zurück, das die Auflistung enthält.
Webs | Gibt das Application-Objekt zurück.
WebWindow | Gibt das Application-Objekt zurück, das das angegebene Objekt enthält.
WebWindows | Gibt das Application-Objekt zurück, das die Auflistung enthält.


Beispiel für die Parent-Eigenschaft

In diesem Beispiel gibt myParent den Dateityp und den Build der übergeordneten Anwendung des aktiven FrontPage-basierten Webs zurück.

Private Sub GetParentInfo()
Dim myWeb As Web
Dim myParent As String
Dim myParentBuild As String

Set myWeb = Application.ActiveWeb

With myWeb
    myParent = .Parent.FileSearch.FileType
    ParentBuild = .Parent.Build
End With
End Sub


Prev-Eigenschaft

Gibt den vorherigen Navigationsknoten in der Navigationsabfolge zurück. Schreibgeschütztes Objekt.


Beispiel für die Prev-Eigenschaft

In diesem Beispiel wird der Navigationszeiger auf den vorherigen Knoten verschoben, es sei denn, der aktuelle Knoten ist der erste Knoten auf dieser Ebene der Navigationsstruktur.

Private Sub MovePrev()
Dim theNode as NavigationNode
Dim thePrevNode as NavigationNode
On Error Resume Next

Set theNode = ActiveWeb.HomeNavigationNode.Children(1)
Set thePrevNode = theNode.Prev

If Err <> 0 Then
    MsgBox “The current navigation level starts here.”
End If
End Sub


ProductCode-Eigenschaft

Gibt den GUID (Globally Unique Identifier) für Microsoft FrontPage zurück. Schreibgeschützter Wert vom Typ String.


Beispiel für die ProductCode-Eigenschaft

Mit dieser Anweisung wird die Produktkennung für FrontPage zurückgegeben.

mySystem = Application.ProductCode


ProfileString-Eigenschaft

Gibt einen Wert für einen Eintrag in der Registrierung von Microsoft Windows unter folgendem Unterschlüssel zurück bzw. legt einen solchen Wert fest:

HKEY_CURRENT_USERS\Software\Microsoft\FrontPage\

Wert vom Typ String, der gelesen und geschrieben werden kann.

Syntax

Ausdruck.ProfileString(RegistrySection as String, RegistryKey as String)

Ausdruck Erforderlich. Ein Ausdruck, der ein System-Objekt zurückgibt.

RegistrySection Erforderlicher Wert vom Typ String. Ein Unterschlüssel unterhalb des Unterschlüssels „HKEY_CURRENT_USERS\Software\MicrosoftFrontPage\“ in der Windows Registrierung.

RegistryKey Erforderlicher Wert vom Typ String. Der Name des Eintrags im Unterschlüssel, der von szSection angegeben wird. Beispielsweise sind „Software“ oder „Network“ im Registrierungs-Editor Unterschlüssel.


Beispiel für die ProfileString-Eigenschaft

In diesem Beispiel wird der Wert des Unterschlüssels, 0 (Null), im Eintrag „Recently Used URLs“ zurückgegeben.

Anmerkung Um dieses Beispiel auszuführen muss sich in einem Ihrer Webs eine Seite befinden, die Sie vor kurzem geöffnet haben.

Private Sub GetRegRecentlyUsedInfo()
Dim mySecKey As String
Dim myRegKey As String
Dim myProfile As String

mySecKey = "HKEY_CURRENT_USER\Software"
mySecKey = mySecKey & _
    "\Microsoft\FrontPage\Editor\Recently Used URLs"
myRegKey = "0"

myProfile = System.ProfileString(mySecKey, myRegKey)
End Sub


Properties-Eigenschaft

Gibt die Properties-Auflistung für das angegebene Objekt zurück. Schreibgeschütztes Properties-Objekt.


Beispiel für die Properties-Eigenschaft

In diesem Beispiel wird eine neue Eigenschaft hinzugefügt und auf der aktiven Webseite angezeigt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) sowie über eine Datei namens Zinfandel.htm verfügen. Alternativ können Sie einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub CopyrightAdd()
Dim myWeb As Web
Dim myCopyright As String

myCopyright = "Copyright 1999 by Rogue Cellars"
Set myWeb = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
myWeb.Activate
ActiveWeb.Properties.Add "Copyright", myCopyright
ActiveWeb.RootFolder.Files("Zinfandel.htm").Open
ActiveDocument.body.insertAdjacentText "BeforeEnd", _
    ActiveWeb.Properties("Copyright")
ActivePageWindow.Save
ActiveWeb.Close
End Sub


RevisionControlProject-Eigenschaft

Gibt die RevisionControlProject-Eigenschaft zurück oder legt diese fest. Wert vom Typ String, der gelesen und geschrieben werden kann.

Hinweise

Bei einem Versionskontrollprojekt kann es sich entweder um ein Visual SourceSafe-Projekt oder um ein FrontPage-basiertes Locking-Projekt handeln. Bei einem Versionskontrollprojekt in Visual SourceSafe müssen Sie das Projekt mit der Zeichenfolge „$/“ beginnen. Für ein FrontPage-basiertes Quellcodeverwaltungsprojekt müssen Sie die RevisionControlProject-Eigenschaft auf "<FrontPage-based Locking>" festlegen.

Zum Entfernen eines Quellcodeverwaltungsprojekts verwenden Sie die folgende Anweisung, mit der das Versionskontrollprojekt auf eine leere Zeichenfolge gesetzt wird.

Set RevisionControlProject = ""


Beispiel für die RevisionControlProject-Eigenschaft

In diesem Beispiel wird die RevisionControlProject-Eigenschaft in einem Microsoft Visual SourceSafe-Projekt festgelegt.

Private Sub SetRevisionControlProjectName()
Dim myWeb As Web
Dim myRevisionControlProject As String

Set myWeb = ActiveWeb
myRevisionControlProject = _
    "$/Rogue Cellars/Rogue Cellars Update"

myWeb.RevisionControlProject = _
    myRevisionControlProject
End Sub


RootFolder-Eigenschaft

Gibt ein Folder-Objekt zurück, das den Stammordner des aktiven Web-Objekts repräsentiert. Schreibgeschütztes Objekt.


Beispiel für die RootFolder-Eigenschaft

In der folgenden Anweisung wird der Name des Stammordners zurückgegeben.

ActiveWeb.RootFolder.Name


RootNavigationNode-Eigenschaft

Gibt ein NavigationNode-Objekt zurück, das den abstrakten Navigationsstamm repräsentiert. Schreibgeschützes Objekt.

Hinweise

Sie können die RootNavigationNode-Eigenschaft verwenden, um den Stammnavigationsknoten zu ermitteln. Die RootNavigationNode-Eigenschaft gibt das NavigationNode-Objekt zurück, von dem aus Sie auf alle anderen Navigationsknoten in einem Web zugreifen können. Das RootNavigationNode-Objekt wird standardmäßig erstellt, wenn Sie ein Web erstellen, und liefert die Basis für die Navigationsstruktur, auf die über die Children-Auflistung zugegriffen werden kann. Der erste untergeordnete Knoten in der Navigationsstruktur ist die Homepage der Website.


Beispiel für die RootNavigationNode-Eigenschaft

Im folgenden Beispiel wird rechts neben dem Home-Navigationsknoten ein globaler Navigationsknoten erstellt.

Private Sub AddNode()
Dim myRNode As NavigationNode
Dim myPage As String

Set myRNode = ActiveWeb.RootNavigationNode
myPage = "http://myServer/myWeb/search.htm"

Call myRNode.Children.Add(myPage, "Search", _
    fpStructRightmostChild)
ActiveWeb.ApplyNavigationStructure
End Sub


SelectedFiles-Eigenschaft

Gibt die ausgewählten Dateien zurück. Schreibgeschütztes WebFile-Objekt.

Hinweise

Damit Sie mehrere Dateien auswählen können, muss auf der Benutzeroberfläche (User Interface - UI) die Ordneransicht geöffnet sein und zum Auswählen der Dateien der rechte Fensterausschnitt verwendet werden. Sie können in der Ordneransicht mehrere Dateien in einem einzigen Web oder in unterschiedlichen Webs auswählen. Wenn Sie die Seitenansicht verwenden müssen, können Sie nur eine Datei pro Web im linken Fensterausschnitt auswählen.

Tipp Sie können die Konstante fpWebViewFolders der ViewMode-Eigenschaft verwenden, um als Ansicht die Ordneransicht festzulegen.


Beispiel für die SelectedFiles-Eigenschaft

In diesem Beispiel werden die Namen der ausgewählten Dateien in einer Variablen mit Namen mySelName verkettet.

Anmerkung Als Trennzeichen zum Trennen der Dateinamen in der Variablen mySelName wird das Leerzeichen verwendet.

Private Sub GetSelectedFileNames()
Dim myWebWindows As WebWindows
Dim myWebWindow As WebWindow
Dim mySelFiles As Variant
Dim mySelFile As WebFile
Dim mySelName As String
Dim myCount As Integer

Set myWebWindows = WebWindows

mySelFiles = ActiveWebwindow.SelectedFiles

For myCount = 0 To UBound(mySelFiles)
    Set mySelFile = mySelFiles(myCount)
    mySelName = mySelName & " " & mySelFile.Name
Next
End Sub


SelectedFolders-Eigenschaft

Gibt die ausgewählten Ordner zurück. Schreibgeschütztes WebFolder-Objekt.

Hinweise

Damit Sie mehrere Ordner auswählen können, muss auf der Benutzeroberfläche (User Interface - UI) die Ordneransicht geöffnet sein und zum Auswählen der Ordner der rechte Fensterausschnitt verwendet werden. Sie können in der Ordneransicht mehrere Ordner in einem einzigen Web oder in unterschiedlichen Webs auswählen. Wenn Sie die Seitenansicht verwenden müssen, können Sie nur einen Ordner pro Web aus den Ordnern im linken Fensterausschnitt auswählen.

Anmerkung Wenn Sie Ordner programmgesteuert auswählen, können Sie die Konstante fpWebViewFolders der ViewMode-Eigenschaft verwenden, um als Ansicht die Ordneransicht festzulegen.


Beispiel für die SelectedFolders-Eigenschaft

In diesem Beispiel werden die Namen der ausgewählten Ordner in einer Variablen mit Namen mySelName verkettet.

Anmerkung Als Trennzeichen zum Trennen der Ordnernamen in der Variablen mySelName wird das Leerzeichen verwendet.

Private Sub GetSelectedFolderNames()
Dim myWebWindows As WebWindows
Dim myWebWindow As WebWindow
Dim mySelFolders As Variant
Dim mySelFolder As WebFolder
Dim mySelName As String
Dim myCount As Integer

Set myWebWindows = WebWindows

mySelFolders = ActiveWebwindow.SelectedFolders

For myCount = 0 To UBound(mySelFolders)
    Set mySelFolder = mySelFolders(myCount)
    mySelName = mySelName & " " & mySelFolder.Name
Next
End Sub


SharedBorders-Eigenschaft

Gibt True zurück, wenn für das Web- oder das WebFile-Objekt irgendwelche gemeinsamen Randbereiche verwendet werden. Wert vom Typ Variant, der gelesen und geschrieben werden kann.

Syntax

Ausdruck.SharedBorders([BorderIndex as FpSharedBorders])

Ausdruck Erforderlich. Ein Ausdruck, der für ein Web- oder WebFile-Objekt einen gemeinsamen Randbereich zurückgibt oder diesen festlegt.

BorderIndex Optionale Konstante vom Typ FpSharedBorders. Der Randbereichsindex ist vom Typ Aufzählung und kann einer der Konstanten in der folgenden Tabelle entsprechen. Als Standardkonstante gilt fpBorderTop.

FpSharedBorders | Wert | Beschreibung
FpBorderTop | 1 | Legt einen Randbereich im Kopf einer Seite fest oder gibt diesen zurück.
FpBorderLeft | 2 | Legt einen Randbereich am linken Rand einer Seite fest oder gibt diesen zurück.
FpBorderRight | 4 | Legt einen Randbereich am rechten Rand einer Seite fest oder gibt diesen zurück.
FpBorderBottom | 8 | Legt einen Randbereich am Fuß einer Seite fest oder gibt diesen zurück.
FpBorderAll | 255 oder &HFF | Legt Randbereiche an allen Seitenrändern einer Seite fest oder gibt diese zurück.

Hinweise

Gemeinsame Randbereiche wie beispielsweise die Konstante fpLeftBorder können verwendet werden, um individuelle Randbereichswerte festzulegen.

Anmerkung Wenn kein gemeinsamer Randbereich angegeben wurde, wird der standardmäßige gemeinsame Randbereich verwendet.


Beispiel für die SharedBorders-Eigenschaft

In diesem Beispiel wird der gemeinsame Randbereich für das aktive Web festgelegt.

Private Sub SetSharedBorders()
Dim myPage As PageWindow

ActiveWeb.SharedBorders(fpBorderLeft) = True

End Sub


System-Eigenschaft

Gibt das System-Objekt zurück. Schreibgeschütztes Object-Objekt.


Beispiel für die System-Eigenschaft

Mit dieser Anweisung wird das aktuelle Betriebssystem zurückgegeben.

mySystem = Application.System.OperatingSystem


ThemeProperties-Eigenschaft

Gibt das Theme-Objekt für das angegebene Objekt zurück oder legt dieses fest. Schreibgeschütztes Objekt.

Syntax

Ausdruck.ThemeProperties(PropertyIndex)

Ausdruck Ein Ausdruck, der ein PageWindow-, Web- oder WebFile-Objekt zurückgibt.

PropertyIndex Optionale Konstante vom Typ FpThemeProperties. Gibt die Designeigenschaften zurück oder legt diese fest. Es kann sich um eine der folgenden FpThemeProperties Type-Konstanten handeln, die in der Tabelle dargestellt werden. Detaillierte Informationen zu den einzelnen in der Tabelle aufgeführten Type-Konstanten finden Sie in den Tabellen und Listen im Hilfethema zur ApplyTheme-Methode.

FpThemeProperties Type | Wert | Beschreibung
fpThemeActiveGraphics | 16 oder &H10 | Legt die Konstante für aktive Grafiken fest oder gibt diese zurück.
fpThemeBackgroundImage | 1 | Legt ein Hintergrundbild fest oder gibt dieses zurück.
fpThemeCSS | 4096 oder &H1000 | Legt das Cascading Stylesheet fest oder gibt dieses zurück.
fpThemeDefaultSettings | 16777216 oder &H1000000 | Gibt das dem Web zugewiesene Design zurück.
fpThemeName | 33554432 oder &H2000000 | Legt die ThemeName-Konstante fest oder gibt diese zurück.
fpThemeNoBackgroundImage | 0 | Legt einen Hintergrund ohne Bild fest oder gibt diesen zurück.
fpThemeNoCSS | 0 | Legt diese Eigenschaft fest oder gibt sie zurück, wenn kein Cascading Stylesheet festgelegt wurde oder keines gewünscht wird.
fpThemeNormalColors | 0 | Legt den Farbmodus für normale Farben fest oder gibt diesen zurück.
fpThemeNormalGraphics | 0 | Legt den Grafikmodus für normale Grafiken fest oder gibt diesen zurück.
fpThemePropertiesAll | 4369 oder &H1111 | Legt die gesamten Designeigenschaften fest oder gibt diese zurück. Nachdem einem Objekt ein Design zugewiesen wurde, kombiniert die fpThemePropertiesAll-Eigenschaft alle Eigenschaften, die dem Objekt zugewiesen wurden.
fpThemePropertiesNone | 0 | Legt für die Designeigenschaften „Keine“ fest oder gibt diesen Hinweis zurück.
fpThemeVivdColors | 256 | Legt die VividColors-Eigenschaft fest oder gibt diese zurück.


Beispiel für die ThemeProperties-Eigenschaft

Im folgenden Beispiel werden die Designeigenschaften auf aktive Grafiken geprüft. Wurden bereits aktive Grafiken zugewiesen, werden dem aktiven Seitenfenster zusätzlich zu den Designeigenschaften, die hierfür bereits festgelegt wurden, noch lebendige Farben zugewiesen. Wurden bis dato keine aktiven Grafiken zugewiesen, werden dem aktiven Seitenfenster sowohl aktive Grafiken als auch lebendige Farben zugewiesen.

Private Sub GetThemeProperties()
Dim myPageWindow As PageWindow

Set myPageWindow = ActiveWeb.ActiveWebWindow.ActivePageWindow

If myPageWindow.ThemeProperties(fpThemeActiveGraphics) Then
    myPageWindow.AppyTheme (fpThemePropertiesAll + _
        fpThemeVividColors)
    Exit Sub
Else
    myPageWindow.ApplyTheme (fpThemePropertiesAll + _
        fpThemeActiveGraphics + fpThemeVividColors)
End If
End Sub

Im folgenden Beispiel wird der angegebenen Datei ein Hintergrundbild hinzugefügt.

Private Sub AddBackgroundImage()
Dim myFile As WebFile

Set myFile = Webs(0).Rootfolder.Files("index.htm")
If myFile.ThemeProperties(fpThemeBackgroundImage) = 0 Then
    myFile.ApplyTheme myFile.ThemeProperties(fpThemeName), _
        myfile.ThemeProperties(fpThemePropertiesAll) + _
        fpThemeBackgroundImage
End If
End Sub


Themes-Eigenschaft

Gibt die Auflistung der Designs (Themes) zurück, die für das angegebene Objekt zur Verfügung stehen. Schreibgeschütztes Objekt.

Hinweise

Die Themes-Eigenschaft gibt, wenn sie dem Application-Objekt zugewiesen wird, die Auflistung der Designs zurück, die zwecks Zuweisung zur Verfügung stehen. Wenn die Themes-Eigenschaft dem Web-Objekt zugewiesen wird, gibt sie die Auflistung der Designs zurück, die dem Web zugewiesen wurden. Diese entspricht der Liste, die im Verzeichnis _theme des Webs angezeigt wird. Wenn einem Web-Objekt ein Design zugewiesen wird, befindet sich ein einziges Design in der Auflistung. Wenn jedoch eine Seite in einem Web separat von dem für das Web festgelegten Design über ein eigenes Design verfügt, dann beinhaltet die Themes-Auflistung für das Web-Objekt zwei Designs, nämlich das Design, das ursprünglich dem Web zugewiesen wurde, und das Design, das speziell der Seite zugewiesen wurde.


Beispiel für die Themes-Eigenschaft

In diesem Beispiel wird sowohl in den Designs, die lokal auf dem Client zur Verfügung stehen, als auch in den Designs, die dem ActiveWeb-Objekt zugewiesen wurden, nach einem bestimmten Design gesucht.

Private Sub SearchAllThemes()
Dim myTheme As Theme
Dim myThemeToFind As String
Dim myIsFound As Boolean

myThemeToFind = “blends”
myIsFound = False

For Each myTheme In Application.Themes
    If myTheme.Label = myThemeToFind Then
        myIsFound = True
        Exit For
    End If
Next

For Each myTheme In ActiveWeb.Themes
    If myTheme.Label = myThemeToFind Then
        myIsFound = True
        Exit For
    End If
Next

End Sub


Title-Eigenschaft

Gibt den Titel des angegebenen Objekts zurück. Schreibgeschützter Wert vom Typ String oder ein Wert vom Typ String, der gelesen und geschrieben werden kann, abhängig vom angegebenen Objekt.

Hinweise

Bei den Web- und WebFile-Objekten gibt die Title-Eigenschaft den Titel des aktiven Web-Objekts als Wert vom Typ String zurück, der gelesen und geschrieben werden kann.


Beispiel für die Title-Eigenschaft

Während Sie die Navigationsknoten durchlaufen, können Sie gleichzeitig auch den Titel (Dateinamen) der Datei zurückgeben, die mit einem bestimmten Knoten verbunden ist. Im folgenden Beispiel wird der Titel der Datei zurückgegeben, die mit einem Navigationsknoten im aktiven FrontPage-basierten Web verbunden ist.

Private Sub GetFileFromNavNode()
Dim myWeb As Web
Dim myNavNode As NavigationNode
Dim myFileFromNavNode As String

Set myWeb = ActiveWeb
Set myNavNode = _
    myWeb.RootNavigationNode.File.NavigationNode

With myNavNode
    myFileFromNavNode = .File.Title
End With
End Sub

Im folgenden Beispiel wird gezeigt, wie Sie den Titel für die erste Datei im Web festlegen können.

Private Sub SetTitle()
Dim myWeb As Web
Dim myNewTitle As String
Dim myFile As WebFile

MyNewTitle = "Inventory.htm"
Set myWeb = ActiveWeb
Set myFile = myWeb.RootFolder.Files(0)

MyFile.Title = myNewTitle
End Sub


Url-Eigenschaft

Gibt den URL des angegebenen Objekts zurück. Schreibgeschützter Wert vom Typ String.

Hinweise

URLs können absolut oder relativ sein. Ein absoluter URL enthält den exakten Pfad zum angegebenen Objekt, wohingegen ein relativer URL abhängig von dem URL-Zugriffschema, das zum Analysieren des relativen URLs verwendet wird, möglicherweise Zeichen wie beispielsweise „../..“, „?“ oder „ ; “ enthält. Das Microsoft FrontPage-Objektmodell verwendet grundsätzlich absolute URLs. Weitere Informationen zu URLs finden Sie unter So funktionieren absolute und relative Pfade in FrontPage 2000.


Beispiel für die Url-Eigenschaft

In diesem Beispiel wird der URL der ersten Datei im Stammordner des aktiven Webs zurückgegeben.

Private Sub GetFileUrl()
Dim myFile As WebFile
Dim myURL As String

Set myFile = ActiveWeb.RootFolder.Files(0)
myURL = myFile.Url

End Sub


UserName-Eigenschaft

Gibt den Logon-Namen des Benutzers zurück, der aktuell am Netzwerk oder Betriebssystem angemeldet ist. Schreibgeschützter Wert vom Typ String.

Hinweise

Die UserName-Eigenschaft ist immer dann der Standardparameter, wenn für einen Parameter im Web-Objektmodell ein Benutzername gefordert wird. Beispielsweise wird bei den Methoden Webs.Open und Webs.Publish jeweils ein UserName-Parameter gefordert. Wenn dieser Parameter nicht angegeben wird, gilt der Benutzername des aktuell angemeldeten Benutzers als Standardparameter.


Beispiel für die UserName-Eigenschaft

In diesem Beispiel wird der Logon-Name des aktuellen Benutzers zurückgegeben.

myLogonName = Application.UserName


Version-Eigenschaft

Gibt die Versionsnummer des angegebenen Objekts im Format „x.x.x“ zurück, wobei x für eine Zahl in der Versionsnummer steht. Schreibgeschützter Wert vom Typ String.

Hinweise

Wenn das Application-Objekt angegeben wird, gibt die Version-Eigenschaft die Versionsnummer der Anwendung zurück. Greifen Sie auf die Version-Eigenschaft des System-Objekts zu, wird die aktuelle Version des Betriebssystems zurückgegeben, ein Verwendungszweck, wie Sie ihn auf der Registerkarte Allgemein im Dialogfeld Eigenschaften von System vorfinden.


Beispiel für die Version-Eigenschaft

Im folgenden Beispiel wird die Version der Anwendung zurückgegeben.

Public Sub GetAppVersion()
Dim myAppVersion As String

myAppVersion = Application.Version
End Sub


VerticalResolution-Eigenschaft

Gibt die vertikale Auflösung des Bildschirms in Pixel zurück. Schreibgeschützter Wert vom Typ Long.


Beispiel für die VerticalResolution-Eigenschaft

In diesem Beispiel wird die vertikale Auflösung des Bildschirms zurückgegeben.

myVerticalRes = System.VerticalResolution


ViewMode-Eigenschaft

Gibt das ViewMode-Objekt in Microsoft FrontPage zurück oder legt dieses fest. Wert vom Typ Long, der sowohl gelesen als auch geschrieben werden kann.

Anmerkung Der Ansichtsmodus unterliegt im Hinblick auf die Schreibfähigkeit einigen Beschränkungen. Beispielsweise können Sie als Ansichtsmodus für ein vorhandenes Seitenfenster nicht fpPageViewNoWindow festlegen. Sie können jedoch ein Seitenfenster öffnen, bei dem das Argument FpPageViewMode auf fpPageViewNoWindow festgelegt wurde. Nachdem Sie eine Seite in einer Umgebung ohne Fenster geöffnet haben, können Sie für das Argument FpPageViewMode keine andere Konstante festlegen.

Syntax 1: Gibt ein PageWindow-Objekt zurück oder legt dieses fest.

Syntax 2: Gibt ein WebWindow-Objekt zurück oder legt dieses fest.

Syntax 1

Ausdruck.ViewMode As FpPageViewMode

Ausdruck Erforderlich. Ein Ausdruck, der ein ViewMode-Objekt für ein PageWindow-Objekt zurückgibt oder dieses festlegt.

FpPageViewMode Eine Zeichenfolge, die den Ansichtsmodus enthält. Diese Argument kann auf Ansichtsmodi wie beispielsweise Normal, HTML oder Vorschau festgelegt werden, die den Namen der Registerkarten in der Seitenansicht entsprechen.

In der folgenden Tabelle werden die Aufzählungskonstanten für die ViewMode-Eigenschaft erläutert.

Aufzählungskonstante | Wert | Beschreibung
FpPageViewDefault | 0 | Die Registerkarte Normal in der Seitenansicht für HTML-Seiten und die Registerkarte HTML in der Seitenansicht für Stylesheets oder ASP-Seiten, sofern diese HTML-Code enthalten, den FrontPage nicht auf sichere Weise analysieren kann.
fpPageViewNormal | 1 | Die Registerkarte Normal in der Seitenansicht.
fpPageViewHtml | 2 | Die Registerkarte HTML in der Seitenansicht.
fpPageViewNoFrames | 4 | Die Registerkarte Ohne Frames in der Seitenansicht (diese Registerkarte ist nur verfügbar, wenn mit Frames gearbeitet wird).
fpPageViewPreview | 8 | Die Registerkarte Vorschau in der Seitenansicht.
fpPageViewNoWindow | 128 oder &H80 | Diese Einstellung verhindert, dass für eine Seite ein Fenster geöffnet wird.

Anmerkung Das Öffnen einer Seite mit fpPageViewNoWindow führt zu einem Zustand, in dem Sie auf Fensterelemente nicht zugreifen können. Wenn Sie beispielsweise eine Seite ohne Fenster öffnen und versuchen, hierauf mit Code wie beispielsweise PageWindow.Document.ParentWindow zuzugreifen, gibt der hieraus resultierende Code nichts anstelle eines FPHTMLWindow2-Objekts zurück. Weitere Informationen über das Öffnen von Seiten ohne Fenster finden Sie unter Erstellen von Code in einer Umgebung ohne Fenster.

Syntax 2

Ausdruck.ViewMode As FpWebViewMode

Ausdruck Erforderlich. Ein Ausdruck, der ein ViewMode-Objekt für ein WebWindow-Objekt zurückgibt oder dieses festlegt.

FpWebViewMode Eine Zeichenfolge, die den Ansichtsmodus enthält. Dieser kann auf Normal, HTML oder Vorschau festgelegt werden, was den Namen der entsprechenden Registerkarten in der Seitenansicht entspricht.

In der folgenden Tabelle werden die Aufzählungskonstanten für die ViewMode-Eigenschaft erläutert.

Aufzählungskonstante | Wert | Beschreibung
fpWebViewLinks | 0 | Hyperlinkansicht
fpWebViewFolders | 1 | Ordneransicht
fpWebViewStructure | 2 | Navigationsansicht
fpWebViewPage | 3 | Seitenansicht
fpWebViewAllFiles | 4 | Alle Dateien wie in der Berichtsansicht angezeigt
fpWebViewTodo | 5 | Aufgabenliste in der Aufgabenansicht
fpWebViewBrokenLinks | 6 | Liste der unterbrochenen Hyperlinks in der Berichtsansicht
fpWebViewSiteSummary | 7 | Siteübersichtsliste in der Berichtsansicht


Beispiel für die ViewMode-Eigenschaft

In diesem Beispiel wird die Ansicht eines offenen Seitenfensters in die HTML-Ansicht geändert.

Private Sub Get PageWindow()
Dim myPageWindow As PageWindow

Set myPageWindow = ActiveWebWindow.Pagewindows(0)
myPageWindow.ViewMode = fpPageViewHtml

End Sub


Visible-Eigenschaft

Gibt abhängig vom Objekt den Sichtbarkeitsstatus des PageWindow- oder des WebWindow-Objekts zurück oder legt diesen fest. Der Sichtbarkeitsstatus für das PageWindow-Objekt ist ein schreibgeschützter Wert vom Typ Boolean. Der Sichtbarkeitsstatus für das WebWindow-Objekt ist ein Wert vom Typ Boolean, der gelesen und geschrieben werden kann.


Beispiel für die Visible-Eigenschaft

Die Prozedur GetVisibleState gibt den Sichtbarkeitsstatus des ersten PageWindow-Objekts aus der CheckIfVisible-Funktion zurück.

Private Sub GetVisibleState()
Dim myIsVisible As Boolean

myIsVisible = CheckIfVisible
End Sub

Function CheckIfVisible() As Boolean
Dim myPage As PageWindow
Dim myVisibleState As Boolean

Set myPage = Application.Webs(0).WebWindows(0).PageWindows(0)

myVisibleState = myPage.Visible
CheckIfVisible = myVisibleState
End Function

In diesem Beispiel wird der Sichtbarkeitsstatus eines WebWindow-Objekts auf ohne Fenster festgelegt.

Private Sub OpenInNoWindow()
Dim myWebWindow As WebWindow

Set myWebWindow = Webs(0).WebWindows(0)

myWebWindow.Visible = False
End Sub


Web-Eigenschaft

Gibt den Container des Microsoft FrontPage-basierten Webs für das angegebene Objekt zurück. Schreibgeschütztes Objekt.


Webs-Eigenschaft

Gibt die Auflistung der geöffneten Webs für das angegebene Objekt zurück. Schreibgeschütztes Objekt.


Beispiel für die Webs-Eigenschaft

In diesem Beispiel wird ein Array erstellt, das alle URLs für alle geöffneten Webs in Ihrer Website enthält.

Anmerkung Sie müssen alle Webs öffnen, für die Sie die URLs auslesen möchten.

Private Sub GetWebs()
Dim myWebs As Webs
Dim myWeb As Web
Dim myOpenWebs() As Variant
Dim i As Integer
Dim myWebCount As Integer

Set myWebs = Application.Webs
myWebCount = myWebs.Count

ReDim myOpenWebs(myWebCount)

Do
For Each myWeb In myWebs
    myOpenWebs(i) = myWeb.Url
    i = i + 1
Next
Loop Until i > myWebCount

End Sub


WebWindows-Eigenschaft

Gibt die Auflistung geöffneter WebWindow-Objekte im angegebenen Objekt zurück. Schreibgeschütztes Objekt.


Beispiel für die WebWindows-Eigenschaft

In diesem Beispiel wird geprüft, ob für beliebige Webfenster die Seitenansicht festgelegt wurde, und für diejenigen, für die die Seitenansicht festgelegt wurde, wird die Ordneransicht ausgewählt.

Private Sub GetViewModes()
Dim myWebWindows As WebWindows
Dim myWebWindow As WebWindow
Dim myView As FpWebViewMode

Set myWebs = Webs
Set myWebWindows = myWebs.WebWindows

For Each myWebWindow In myWebWindows
    myView = myWebWindow.ViewMode
    If myView = fpWebViewPage Then
        myWebWindow.ViewMode = fpWebViewFolders
    End If
Next
End Sub


Zurückgeben eines Objekts aus einer Auflistung

Die Item-Eigenschaft gibt ein einzelnes Objekt aus einer Auflistung zurück. Mit den folgenden Anweisungen wird die Variable fileOne auf ein WebFile-Objekt festgelegt, das die erste Datei in der Files-Auflistung repräsentiert.

Dim fileOne As WebFile

Set fileOne = ActiveWeb.RootFolder.Files.Item(0)

Die Item-Eigenschaft ist die Standardeigenschaft für die meisten Auflistungen, daher können Sie das Schlüsselwort Item wie in der folgenden Anweisung gezeigt auslassen.

Set fileOne = ActiveWeb.RootFolder.Files(0)

Benannte Objekte

Obwohl Sie normalerweise in Verbindung mit der Item-Eigenschaft einen ganzzahligen Wert angeben können, ist es möglicherweise praktischer, ein Objekt anhand seines Namens zurückzugeben. Im folgenden Beispiel wird eine Datei mit Namen „Web Sales.htm“ aus dem aktiven Web zur Bearbeitung abgerufen.

ActiveWeb.RootFolder.Files("Web Sales.htm").Edit


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, da die Microsoft Office Visual Basic Hilfe nicht gefunden werden konnte, nicht installiert oder entfernt wurde.

So installieren Sie die Microsoft Office Visual Basic Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf Microsoft Office 2000, und klicken Sie dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic Hilfe, um die die Installation betreffenden Auswahlmöglichkeiten anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder auf Von CD/Vom Netzwerk starten, und klicken Sie dann auf Jetzt aktualisieren.


Hilfethema nicht verfügbar

Dieses Hilfethema kann nicht angezeigt werden, da die Hilfe von Visual Basic für Applikationen nicht gefunden werden konnte, nicht installiert oder entfernt wurde.

So installieren Sie die Hilfe zu Visual Basic für Applikationen

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die aktuell installierte Version von Microsoft Office 2000, und klicken Sie dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic Hilfe, um die die Installation betreffenden Auswahlmöglichkeiten anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder auf Von CD/Vom Netzwerk starten, und klicken Sie dann auf Jetzt aktualisieren.


Beispiel für die Save-Methode

In diesem Beispiele wird eine Eigenschaft erstellt, die einer Datei hinzugefügt wird, und anschließend das aktive PageWindow-Objekt gespeichert. Das Argument ForceOverwrite ist standardmäßig auf True festgelegt.

Anmerkung Um dieses Beispiel nachvollziehen zu können, müssen Sie über ein Web mit Namen C:\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Microsoft Windows ausgeführt wird) oder C:\WINNT\Profiles\Logon-Alias\Eigene Dateien\Eigene Webs\Rogue Cellars (bei einem Server, auf dem Windows NT ausgeführt wird) verfügen, oder Sie können alternativ einen anderen Web-URL und einen anderen Dateinamen einsetzen.

Private Sub AddSaleText()
Dim myWeb As Web
Dim myFile As WebFile
Dim mySaleProp As String
Dim mySaleText As String

mySaleText = "Vintage Wines for Oktoberfest Sale!!!"
Set myWeb = Webs.Open("C:\My Documents\My Webs\Rogue Cellars")
Set myFile = ActiveWeb.RootFolder.Files("Sale.htm")

myFile.Properties.Add "SaleText", mySaleText
mySaleProp = myFile.Properties("SaleText")
myFile.Open
ActiveDocument.body.insertAdjacentText "BeforeEnd", mySaleProp
ActivePageWindow.Save
WebWindows.Close
End Sub


Beispiel für die ActiveWeb-Eigenschaft

In diesem Beispiel wird die ActiveWeb-Eigenschaft eingesetzt, um die Webseite index.htm zu finden und die Hintergrundfarbe der Webseite zu ändern.

Anmerkung Wenn Sie dieses Beispiel nachvollziehen möchten, erstellen Sie ein Formular mit einer Befehlsschaltfläche mit Namen cmdActiveWebColorChange und fügen den folgenden Code in das Codefenster ein. Damit die Hintergrundfarbe mit dieser Prozedur geändert werden kann, müssen Sie über eine Webseite index.htm verfügen.

Private Sub cmdActiveWebBKGRDColorChange_Click()
Dim myPageWin As PageWindow

Set myPageWin = Application.ActiveWeb.LocatePage("index.htm")

myPageWin.Document.bgColor = "PapayaWhip"

End Sub

Anmerkung Microsoft Visual Basic für Applikationen stellt Farbkonstanten mit dem Präfix „vb“, wie beispielsweise vbCyan, bereit. FrontPage erstellt Webseiten in HTML, wobei andere Farbkonstanten wie in Visual Basic verwendet werden. Wenn Sie in Ihren bereits vorhandenen Programmen die von Visual Basic bereitgestellten Farbkonstanten verwenden, müssen Sie diese in die entsprechenden hexadezimalen Farbwerte ändern, wenn Sie Ihre Programme auf ein FrontPage-basiertes Web portieren oder Farben übergreifend über Office-Anwendungen einsetzen möchten, die ein FrontPage-basiertes Web umfassen.


Beispiel für die Files-Eigenschaft

In diesem Beispiel werden alle Eigenschaften einer Datei abgerufen, und die META-Tags werden zu einer Zeichenfolge verkettet, wobei die Daten mit einem senkrechten Balken (Pipe, „|“) als Trennzeichen separiert werden.

Anmerkung Die in diesem Beispiel verwendeten PropertyKeys beziehen sich auf ein Web, das mit dem Assistenten zur Erstellung eines Webs mit einer Seite erstellt wurde. Bei anderen Vorlagen werden möglicherweise andere PropertyKeys verwendet.

Private Sub GetFileProperties()
Dim myFiles As WebFiles
Dim myFile As WebFile
Dim myAuthor As String
Dim myModifiedBy As String
Dim myTimeCreated As String
Dim myTimeLastModified As String
Dim myFileSize As String
Dim myTitle As String
Dim myMetaTags As Variant
Dim myMetaTag As Variant
Dim myProgID As Variant
Dim myGenerator As String
Dim myTimeLastWritten As String
Dim myProperties As Properties
Dim myMetaTagList As String

Set myFiles = ActiveWeb.Rootfolder.Files

For Each myFile In myFiles
    Set myProperties = myFile.Properties

    myAuthor = myAthor & myProperties("vti_author") _
        & "|"
    myModifiedBy = myModifiedBy & _
        myProperties("vti_modifiedby) & "|"
    myTimeCreated = myTimeCreated & _
        myProperties("vti_timecreated") & "|"
    myTimeLastModified = myTimeLastModified & _
        myProperties("vti_timelastmodified") & "|"
    myFileSize = myFileSize & _
        myProperties("vti_FileSize) & "|"
    myTitle = myTitle & myProperties("vti_title") _
        & "|"
    myProgID = myProgID & myProperties("vti_title") _
        & "|"
    myGenerator = myGenerator & _
        myProperties("vti_generator") & "|"
    myTimeLastWritten = myTimeLastWritten & _
        myProperties("vti_timelastwritten") & "|"
    myMetaTags = myProperties("vti_metatags")
    For Each myMetaTag In myMetaTags
        myMetaTagList = myMetaTagList & myMetaTag & "|"
    Next
Next
End Sub


Beispiel für die File-Eigenschaft

In diesem Beispiel wird der Name des File-Objekts zurückgegeben, das mit einem Navigationsknoten im aktiven FrontPage-basierten Web verbunden ist.

Private Sub GetFileFromNavNode()
Dim myNavNode As NavigationNode
Dim myNavNodes As NavigationNodes
Dim myNavFiles As String
Dim myNavFile As String
On Error Resume Next
Set myNavNodes = ActiveWeb.HomeNavigationNode.Children
For Each myNavNode In myNavNodes
    myNavFile = myNavNode.File.Name
    If Err <> 0 Then Exit Sub
    myNavFiles = myNavFiles & myNavFile & vbCrLf
Next

End Sub


Beispiel für die Home-Eigenschaft

In diesem Beispiel wird nach einem Navigationsknoten mit dem Namen „Sale“ gesucht, der anschließend aktualisiert wird.

Private Sub ChangeNavLabel()
Dim myFiles As WebFiles
Dim myFile As WebFile

Set myFiles = ActiveWeb.RootFolder.Files

For Each myFile in myFiles
    If myFile.NavigationNode.Home.Label = "Sale" Then
        myFile.NavigationNode.Home.Label = "Sales Items"
    End If
Next
End Sub


Beispiel für die Web-Eigenschaft

In diesem Beispiel wird der Titel eines FrontPage-basierten Webs zurückgegeben.

Private Sub GetWebTitle()
Dim myWeb As Web
Dim myWebName As String

Set myWeb = ActiveWeb

myWebName = myWeb.RootFolder.Web.Title

End Sub