Microsoft Graph-Objekte

Application-Objekt

Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Pfeil nach rechts Klicken Sie auf den Pfeil, um das Diagramm zu erweitern.


Programmtechnische OLE-Bezeichner

Ein programmtechnischer OLE-Bezeichner (manchmal auch ProgID genannt) kann zur Erstellung eines Automation-Objekts verwendet werden. Die folgende Tabelle enthält programmtechnische OLE-Bezeichner für ActiveX-Steuerelemente, Microsoft Office-Anwendungen und Microsoft Office Web Components.

ActiveX-Steuerelemente

Microsoft Access

Microsoft Excel

Microsoft Graph

Microsoft Office Web Components

Microsoft Outlook

Microsoft PowerPoint

Microsoft Word

ActiveX-Steuerelemente

Um die in der folgenden Tabelle aufgeführten ActiveX-Steuerelemente zu erstellen, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner.

Steuerelement | Bezeichner
CheckBox | Forms.CheckBox.1
ComboBox | Forms.ComboBox.1
CommandButton | Forms.CommandButton.1
Frame | Forms.Frame.1
Image | Forms.Image.1
Label | Forms.Label.1
ListBox | Forms.ListBox.1
MultiPage | Forms.MultiPage.1
OptionButton | Forms.OptionButton.1
ScrollBar | Forms.ScrollBar.1
SpinButton | Forms.SpinButton.1
TabStrip | Forms.TabStrip.1
TextBox | Forms.TextBox.1
ToggleButton | Forms.ToggleButton.1

Microsoft Access

Um die in der folgenden Tabelle aufgeführten Microsoft Access-Objekte zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Access erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Access.Application, Access.Application.9
CurrentData | Access.CodeData, Access.CurrentData
CurrentProject | Access.CodeProject, Access.CurrentProject
DefaultWebOptions | Access.DefaultWebOptions

Microsoft Excel

Um die in der folgenden Tabelle aufgeführten Microsoft Excel-Objekte zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Excel erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner | Kommentare
Application | Excel.Application, Excel.Application.9 |
Workbook | Excel.AddIn |
Workbook | Excel.Chart, Excel.Chart.8 | Gibt eine Arbeitsmappe mit zwei Tabellenblättern zurück: ein Blatt für das Diagramm und ein weiteres für die zugehörigen Daten. Bei dem Tabellenblatt mit dem Diagramm handelt es sich um das aktive Arbeitsblatt.
Workbook | Excel.Sheet, Excel.Sheet.8 | Gibt eine Arbeitsmappe mit einem Tabellenblatt zurück.

Microsoft Graph

Um die in der folgenden Tabelle aufgeführten Microsoft Graph-Objekte zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Graph erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | MSGraph.Application, MSGraph.Application.8
Chart | MSGraph.Chart, MSGraph.Chart.8

Microsoft Office Web Components

Um die in der folgenden Tabelle aufgeführten Microsoft Office Web Components-Objekte zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Microsoft Office Web Components erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
ChartSpace | OWC.Chart, OWC.Chart.9
DataSourceControl | OWC.DataSourceControl, OWC.DataSourceControl.9
ExpandControl | OWC.ExpandControl, OWC.ExpandControl.9
PivotTable | OWC.PivotTable, OWC.PivotTable.9
RecordNavigationControl | OWC.RecordNavigationControl, OWC.RecordNavigationControl.9
Spreadsheet | OWC.Spreadsheet, OWC.Spreadsheet.9

Microsoft Outlook

Um das in der folgenden Tabelle aufgeführte Microsoft Outlook-Objekt zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Outlook erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Outlook.Application, Outlook.Application.9

Microsoft PowerPoint

Um das in der folgenden Tabelle aufgeführte Microsoft PowerPoint-Objekt zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von PowerPoint erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | PowerPoint.Application, PowerPoint.Application.9

Microsoft Word

Um die in der folgenden Tabelle aufgeführten Microsoft Word-Objekte zu erstellen, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, wird das Objekt in der neuesten Version von Word erstellt, die auf dem Computer verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Word.Application, Word.Application.9
Document | Word.Document, Word.Document.9, Word.Template.8
Global | Word.Global


Activate-Methode

Aktiviert das Objekt.

Syntax

Ausdruck.Activate

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf "Betrifft".


Beispiel zur Activate-Methode

In diesem Beispiel wird die Tabelle aktiviert.

myChart.Application.DataSheet.Activate


Add-Methode

Erstellt eine neue Trendlinie. Gibt ein Trendline-Objekt zurück.

Syntax

Ausdruck.Add(Type, Order, Period, Forward, Backward, Intercept, DisplayEquation, DisplayRSquared, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Trendline-Objekt zurückgibt.

Type Variant optional. Die Art der Trendlinie. Kann eine der folgenden XlTrendlineType-Konstanten sein: xlLinear, xlLogarithmic, xlExponential, xlPolynomial, xlMovingAvg oder xlPower. Der Standardwert ist xlLinear.

Order Variant optional. Erforderlich, falls Type den Wert xlPolynomial besitzt. Die Reihenfolge der Trendlinie. Muss eine Ganzzahl zwischen 2 und 6 sein.

Period Variant optional. Erforderlich, falls Type den Wert xlMovingAvg besitzt. Die Periode der Trendlinie. Muss eine Ganzzahl sein, die größer ist als 1 und kleiner als die Anzahl der Datenpunkte in der Datenreihe, der Sie eine Trendlinie hinzufügen.

Forward Variant optional. Die Anzahl der Perioden (oder Einheiten eines Punkt(XY)-Diagramms), um die sich die Trendlinie nach vorne erstreckt.

Backward Variant optional. Die Anzahl der Perioden (oder Einheiten eines Punkt(XY)-Diagramms), um die sich die Trendlinie nach hinten erstreckt.

Intercept Variant optional. Der Schnittpunkt der Trendlinie. Wird dieses Argument weggelassen, wird der Schnittpunkt automatisch durch die Regression festgelegt.

DisplayEquation Variant optional. True, um die Gleichung der Trendlinie im Diagramm anzuzeigen (in derselben Datenbeschriftung wie der R-Quadratwert). Der Standardwert ist False.

DisplayRSquared Variant optional. True, um den R-Quadratwert der Trendlinie im Diagramm anzuzeigen (in derselben Datenbeschriftung wie die Gleichung). Der Standardwert ist False.

Name Variant optional. Der Name der Trendlinie als Text. Wird dieses Argument weggelassen, erstellt Microsoft Graph einen Namen.


AddChartAutoFormat-Methode

Fügt der Liste verfügbarer Diagramm-AutoFormate ein benutzerdefiniertes Diagramm-AutoFormat hinzu.

Syntax

Ausdruck.AddChartAutoFormat(Name, Description)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Name String erforderlich. Der Name des AutoFormats.

Description String optional. Eine Beschreibung des benutzerdefinierten AutoFormats.


Beispiel zur AddChartAutoFormat-Methode

In diesem Beispiel wird ein neues AutoFormat hinzugefügt.

myChart.Application.AddChartAutoFormat _
    Name:="Presentation Chart"


AddReplacement-Methode

Fügt einen Eintrag in die Matrix der AutoKorrektur-Ersetzungen ein.

Syntax

Ausdruck.AddReplacement(What, Replacement)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrect-Objekt zurückgibt.

What String erforderlich. Der zu ersetzende Text. Ist diese Zeichenfolge bereits in der Matrix der AutoKorrektur-Ersetzungen vorhanden, wird der bestehende Ersatztext mit dem neuen Text überschrieben.

Replacement String erforderlich. Der Ersatztext.


Beispiel zur AddReplacement-Methode

In diesem Beispiel wird in der Matrix der AutoKorrektur-Ersetzungen das Wort "Temperature" durch das Wort "Temp." ersetzt.

With myChart.Application.AutoCorrect
    .AddReplacement "Temperature", "Temp."
End With


ApplyCustomType-Methode

Weist einem Diagramm oder einer Datenreihe einen benutzerdefinierten- oder Standarddiagrammtyp zu.

Syntax

Ausdruck.ApplyCustomType(ChartType, TypeName)

Ausdruck Ein Ausdruck, der ein Chart- oder Series-Objekt zurückgibt.

ChartType Long erforderlich. Einen Standarddiagrammtyp (eine Liste der verfügbaren Konstanten) finden Sie unter der ChartType-Eigenschaft. Bei Chart-Objekten kann dies auch eine der folgenden XlChartGallery-Konstanten sein: xlBuiltIn, xlUserDefined oder xlAnyGallery.

TypeName Variant optional (nur bei Chart-Objekten). Ein String, der den benutzerdefinierten Diagrammtyp bezeichnet, wenn mit ChartType ein Katalog benutzerdefinierter Diagrammformate angegeben wird.


Beispiel zur ApplyCustomType-Methode

In diesem Beispiel wird der Diagrammtyp Linien mit Datenpunkten angewendet.

myChart.ApplyCustomType xlLineMarkers


ApplyDataLabels-Methode

Ordnet einem Datenpunkt, einer Datenreihe oder allen Datenreihen im Diagramm Datenbeschriftungen zu.

Syntax

Ausdruck.ApplyDataLabels(Type, LegendKey, AutoText, HasLeaderLines)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-, Point- oder Series-Objekt zurückgibt.

Type Variant optional. Der Typ der Datenbeschriftung. Dies kann eine der folgenden XlDataLabelsType-Konstanten sein:

Konstante | Beschreibung
xlDataLabelsShowNone | Keine Datenbeschriftungen.
xlDataLabelsShowValue | Wert für den Datenpunkt (wenn dieses Argument nicht angegeben wird, wird ein Wert berechnet).
xlDataLabelsShowPercent | Prozentsatz der Summe. Nur für Kreis- und Ringdiagramme verfügbar.
xlDataLabelsShowLabel | Rubrikbezeichnung für den Datenpunkt. Dies ist der Standardwert.
xlDataLabelsShowLabelAndPercent | Prozentsatz der Summe und Rubrikbezeichnung für den Datenpunkt. Nur für Kreis- und Ringdiagramme verfügbar.

LegendKey Variant optional. Wenn True, wird das Legendensymbol neben dem Datenpunkt angezeigt. Der Standardwert ist False.

AutoText Optional Variant. Wahr, wenn das Objekt basierend auf dem Inhalt automatisch angemessenen Text erzeugt.

LegendKey Optional Variant. Für die Chart- und Series-Objekte, Wahr, wenn die Reihe Führungslinien besitzt.


Beispiel zur ApplyDataLabels-Methode

In diesem Beispiel werden der ersten Datenreihe Rubrikenbeschriftungen zugewiesen.

myChart.SeriesCollection(1). _
    ApplyDataLabels Type:=xlDataLabelsShowLabel


AreaGroups-Methode

Bei einem 2D-Diagramm gibt diese Methode ein Objekt zurück, das entweder eine einzelne Flächendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung aller Flächendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.AreaGroups(Index)

Syntax 2

Ausdruck.AreaGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Die Indexnummer der angegebenen Diagrammgruppe.


Beispiel zur AreaGroups-Methode

In diesem Beispiel werden die Bezugslinien einer 2D-Flächendiagrammgruppe eingeschaltet.

myChart.AreaGroups(1).HasDropLines = True


AutoFit-Methode

Stellt die Spalten des angegebenen Bereichs auf die optimale Breite ein.

Syntax

Ausdruck.AutoFit

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Muss eine Zeile oder ein Zeilenbereich bzw. eine Spalte oder ein Spaltenbereich sein. Andernfalls führt diese Methode zu einem Fehler.

Anmerkungen

Eine Einheit der Spaltenbreite entspricht der Breite eines Zeichens in der Formatvorlage Standard.


Beispiel zur AutoFit-Methode

In diesem Beispiel werden die Spalten A bis I im Datenblatt auf ihre optimale Breite eingestellt.

myChart.Application.DataSheet.Columns("A:I").AutoFit

In diesem Beispiel werden im Datenblatt die Spalten A bis E auf ihre optimale Breite eingestellt. Als Grundlage dienen ausschließlich die Inhalte der Zellen A1:E1.

myChart.Application.DataSheet.Range("A1:E1").Columns.AutoFit


Axes-Methode

Gibt ein Objekt zurück, das eine einzelne Achse (ein Axis-Objekt, Syntax 1) oder eine Auflistung der Achsen des Diagramms (eine Axes-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.Axes(Type, AxisGroup)

Syntax 2

Ausdruck.Axes

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Type Variant optional. Gibt die zurückzugebende Achse an. Dies kann eine der folgenden XlAxisType-Konstanten sein: xlValue, xlCategory oder xlSeriesAxis (xlSeriesAxis ist nur für 3D-Diagramme gültig).

AxisGroup Variant optional. Gibt die Achsengruppe an. Dies kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Wird dieses Argument nicht angegeben, wird die primäre Gruppe verwendet. 3D-Diagramme haben nur eine Achsengruppe.


Beispiel zur Axes-Methode

In diesem Beispiel wird zur Rubrikenachse eine Achsenbeschriftung hinzugefügt.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With

In diesem Beispiel werden die Hauptgitternetzlinien der Rubrikenachse deaktiviert.

myChart.Axes(xlCategory).HasMajorGridlines = False

In diesem Beispiel werden die Gitternetzlinien aller Achsen deaktiviert.

For Each a In myChart.Axes
    a.HasMajorGridlines = False
    a.HasMinorGridlines = False
Next a


BarGroups-Methode

Bei einem 2D-Diagramm gibt diese Methode ein Objekt zurück, das entweder eine einzelne Balkendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung aller Balkendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.BarGroups(Index)

Syntax 2

Ausdruck.BarGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Die Indexnummer der angegebenen Balkendiagrammgruppe.


Beispiel zur BarGroups-Methode

In diesem Beispiel wird festgelegt, dass in der 2D-Balkendiagrammgruppe der Leerraum zwischen Säulengruppen 50 Prozent der Balkenbreite beträgt.

myChart.BarGroups(1).GapWidth = 50


Chart-Methode

Gibt ein Chart-Objekt zurück, das das Microsoft Graph-Diagramm darstellt.


ChartGroups-Methode

Gibt ein Objekt zurück, das eine einzelne Diagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung aller Diagrammgruppen im Diagramm (ein ChartGroups-Objekt, Syntax 2) darstellt. Die zurückgegebene Auflistung enthält alle Gruppentypen.

Syntax 1

Ausdruck.ChartGroups(Index)

Syntax 2

Ausdruck.ChartGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Die Nummer der Diagrammgruppe.


Beispiel zur ChartGroups-Methode

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe aktiviert und anschließend deren Farben festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit zwei Datenreihen an, die sich in mindestens einem Datenpunkt schneiden.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


Clear-Methode

Löscht den gesamten Bereich oder die Diagrammfläche.

Syntax

Ausdruck.Clear

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartArea- oder Range-Objekt zurückgibt.


ClearContents-Methode

Löscht die Formeln aus dem Bereich. Löscht die Daten aus einem Diagramm, jedoch nicht die Formatierung.

Syntax

Ausdruck.ClearContents

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart- oder Range-Objekt zurückgibt.


Beispiel zur ClearContents-Methode

In diesem Beispiel werden die Formeln aus dem Bereich A1:G37 in der Tabelle gelöscht, die Formatierung bleibt jedoch erhalten.

myChart.Application.DataSheet.Range("A1:G37").ClearContents

In diesem Beispiel werden die Daten aus einem Diagramm gelöscht, während die Formatierung erhalten bleibt.

myChart.ChartArea.ClearContents


ClearFormats-Methode

Löscht die Formatierung des Objekts.

Syntax

Ausdruck.ClearFormats

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


Beispiel zur ClearFormats-Methode

In diesem Beispiel werden alle Formatierungen im Bereich A1:G37 der Tabelle gelöscht.

myChart.Application.DataSheet.Range("A1:G37").ClearFormats

In diesem Beispiel wird die Formatierung des Diagramms gelöscht.

myChart.ChartArea.ClearFormats


ColumnGroups-Methode

Bei einem 2D-Diagramm gibt diese Methode ein Objekt zurück, das entweder eine einzelne Säulendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Balkendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.ColumnGroups(Index)

Syntax 2

Ausdruck.ColumnGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Die Indexnummer der angegebenen Säulendiagrammgruppe.


Beispiel zur ColumnGroups-Methode

In diesem Beispiel wird festgelegt, dass in der 2D-Säulendiagrammgruppe der Leerraum zwischen Säulengruppen 50 Prozent der Säulenbreite beträgt.

myChart.ColumnGroups(1).GapWidth = 50


Copy-Methode

Syntax 1: Kopiert das Objekt in die Zwischenablage. Kopiert ein Bild des Datenpunkts oder der Datenreihe in die Zwischenablage.

Syntax 2: Kopiert das Range-Objekt in den angegebenen Bereich oder in die Zwischenablage.

Syntax 1

Ausdruck.Copy

Syntax 2

Ausdruck.Copy(Destination)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Destination Variant optional. Gibt den neuen Bereich an, in den der angegebene Bereich kopiert wird. Wenn dieses Argument ausgelassen wird, kopiert Microsoft Graph den Bereich in die Zwischenablage.


Beispiel zur Copy-Methode

In diesem Beispiel werden die Formeln im Zellbereich A1:D4 in der Tabelle in den Zellbereich E5:H8 kopiert.

Set mySheet = myChart.Application.DataSheet
mySheet.Range("A1:D4").Copy _
    Destination:= mySheet.Range("E5")


Cut-Methode

Schneidet den angegebenen Bereich aus und legt ihn in der Zwischenablage oder an einer angegebenen Stelle ab.

Syntax

Ausdruck.Cut(Destination)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Destination Variant optional. Der Bereich, in den das Objekt eingefügt werden soll. Wird dieses Argument nicht angegeben, wird das ausgeschnittene Objekt in der Zwischenablage abgelegt.


Beispiel zur Cut-Methode

In diesem Beispiel wird der Bereich A1:G37 aus der Tabelle ausgeschnitten und in der Zwischenablage abgelegt.

Set mySheet = myChart.Application.DataSheet
mySheet.Range("A1:G37").Cut


DataLabels-Methode

Gibt ein Objekt zurück, das eine einzelne Datenbeschriftung (ein DataLabel-Objekt, Syntax 1) oder eine Auflistung aller Datenbeschriftungen der Datenreihe (eine DataLabels-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.DataLabels(Index)

Syntax 2

Ausdruck.DataLabels

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Index Variant optional. Die Nummer der Datenbeschriftung.


Beispiel zur DataLabels-Methode

In diesem Beispiel werden die Datenbeschriftungen für die erste Datenreihe so festgelegt, dass das Legendensymbol angezeigt wird. Es wird vorausgesetzt, dass die Werte bei der Ausführung des Makros eingeblendet sind.

With myChart.SeriesCollection(1)
    .HasDataLabels = True
    With .DataLabels
        .ShowLegendKey = True
        .Type = xlValue
    End With
End With


Delete-Methode

Löscht das angegebene Objekt. Syntax 2 gilt nur für Range-Objekte.

Syntax 1

Ausdruck.Delete

Syntax 2

Ausdruck.Delete(Shift)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf "Betrifft".

Shift Variant optional. Wird nur bei Range-Objekten verwendet. Gibt an, wie die Zellen verschoben werden, um die gelöschten Zellen zu ersetzen. Dies kann eine der folgenden XlDeleteShiftDirection-Konstanten sein: xlShiftToLeft oder xlShiftUp. Wenn dieses Argument weggelassen wird, verschiebt Microsoft Graph die Zellen entsprechend der Form des angegebenen Bereichs.

Anmerkungen

Durch Löschen eines Point- oder LegendKey-Objekts wird die gesamte Datenreihe gelöscht.


DeleteChartAutoFormat-Methode

Entfernt ein benutzerdefiniertes AutoFormat für Diagramme aus der Liste verfügbarer AutoFormate für Diagramme.

Syntax

Ausdruck.DeleteChartAutoFormat(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Name String erforderlich. Der Name des zu entfernenden benutzerdefinierten AutoFormats.


Beispiel zur DeleteChartAutoFormat-Methode

In diesem Beispiel wird das benutzerdefinierte AutoFormat "Presentation Chart" gelöscht.

myChart.Application.DeleteChartAutoFormat _
    name:="Presentation Chart"


DeleteReplacement-Methode

Löscht einen Eintrag aus der Matrix der AutoKorrektur-Ersetzungen.

Syntax

Ausdruck.DeleteReplacement(What)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrect-Objekt zurückgibt.

What String erforderlich. Der zu ersetzende Text, so wie er in der Zeile erscheint, die aus der Matrix der AutoKorrektur-Ersetzungen gelöscht werden soll. Existiert diese Zeichenfolge in der Matrix der AutoKorrektur-Ersetzungen nicht, schlägt diese Methode fehl.


Beispiel zur DeleteReplacement-Methode

In diesem Beispiel wird das Wort "Temperature" aus der Matrix der AutoKorrektur-Ersetzungen entfernt.

With myChart.Application.AutoCorrect
    .DeleteReplacement "Temperature"
End With


Deselect-Methode

Hebt die Markierung im Diagramm auf.

Syntax

Ausdruck.Deselect

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.


Beispiel zur Deselect-Methode

Dieses Beispiel hat die gleiche Wirkung wie das Drücken von ESC während der Bearbeitung des Diagramms. Wenden Sie das Makro auf ein Diagramm an, in dem eine Komponente (z. B. eine Achse) markiert ist.

myChart.Deselect


DoughnutGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Ringdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Ringdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.DoughnutGroups(Index)

Syntax 2

Ausdruck.DoughnutGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur DoughnutGroups-Methode

In diesem Beispiel wird der Anfangswinkel für die erste Ringdiagrammgruppe festgelegt.

myChart.DoughnutGroups(1).FirstSliceAngle = 45


ErrorBar-Methode

Wendet Fehlerindikatoren auf die angegebene Datenreihe an.

Syntax

Ausdruck.ErrorBar(Direction, Include, Type, Amount, MinusValues)

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Direction Variant optional. Die Richtung des Fehlerindikators. Dies kann eine der folgenden XlErrorBarDirection-Konstanten sein: xlX oder xlY. xlX kann nur bei Punktdiagrammen verwendet werden. Der Standardwert ist xlY.

Include Variant optional. Gibt an, welche Teile des Fehlerindikators enthalten sein sollen. Dies kann eine der folgenden XlErrorBarInclude-Konstanten sein: xlErrorBarIncludePlusValues, xlErrorBarIncludeMinusValues, xlErrorBarIncludeNone oder xlErrorBarIncludeBoth. Der Standardwert ist xlErrorBarIncludeBoth.

Type Variant optional. Der Typ des Fehlerindikators. Dies kann eine der folgenden XlErrorBarType-Konstanten sein: xlErrorBarTypeFixedValue, xlErrorBarTypePercent, xlErrorBarTypeStDev, xlErrorBarTypeStError oder xlErrorBarTypeCustom.

Amount Variant optional. Der Fehlerbetrag. Wird nur für einen positiven Fehlerbetrag verwendet, wenn Type den Wert xlErrorBarTypeCustom hat.

MinusValues Variant optional. Der negative Fehlerbetrag, wenn Type den Wert xlErrorBarTypeCustom hat.


Beispiel zur ErrorBar-Methode

In diesem Beispiel werden der ersten Datenreihe positive und negative Standardfehlerindikatoren in Y-Richtung zugewiesen. Wenden Sie das Makro auf ein 2D-Liniendiagramm an.

myChart.SeriesCollection(1).ErrorBar _
    Direction:=xlY, Include:=xlErrorBarIncludeBoth, _
    Type:=xlErrorBarTypeStError


Evaluate-Methode

Wandelt einen Microsoft Graph-Namen in ein Objekt oder einen Wert um.

Syntax

Ausdruck.Evaluate(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Microsoft Graph Application-Objekt zurückgibt.

Name String erforderlich. Der Name des angegebenen Objekts nach den Benennungskonventionen von Microsoft Graph.

Anmerkungen

Bei dieser Methode können Sie die folgenden Benennungsarten in Microsoft Graph verwenden:

  • A1-Bezugssystem. Sie können jeden Bezug auf eine Zelle in A1-Schreibweise verwenden. Alle Bezüge gelten als absolut.

  • Bereiche. Sie können die Operatoren Bereich, Schnittmenge und Vereinigung (oder entsprechend Doppelpunkt, Leerzeichen bzw. Komma) bei Bezügen verwenden.

  • Definierte Namen. Sie können jeden Namen in der Sprache des Makros angeben.

Anmerkung Eckige Klammern (z. B. "[A1:C5]") besitzen die gleiche Bedeutung wie das Aufrufen der Evaluate-Methode mit einem Zeichenfolgenargument, wie in folgendem Beispiel verdeutlicht wird:

myChart.Application.[a1].Value = 25
myChart.Application.Evaluate("A1").Value = 25

Der Vorteil von eckigen Klammern liegt in einem kürzeren Code. Evaluate besitzt den Vorteil, dass es eine Zeichenfolge als Argument besitzt und Sie diese somit in Ihrem Code erzeugen oder eine Visual Basic-Variable verwenden können.


Beispiel zur Evaluate-Methode

In diesem Beispiel werden die Inhalte der Zelle A1 des Datenblattes gelöscht.

clearCell = "A1"
myChart.Application.Evaluate(clearCell).Clear


Export-Methode

Exportiert das Diagramm in ein bestimmtes Grafikformat.

Syntax

Ausdruck.Export(FileName, FilterName, Interactive)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

FileName String erforderlich. Der Name der exportierten Datei.

FilterName Variant optional. Der sprachunabhängige Name des Grafikfilters in der Form, in der er in der Registrierung erscheint.

Interactive Variant optional. Ist das Argument True, wird ein Dialogfeld mit filterspezifischen Optionen angezeigt. Ist es False, verwendet Microsoft Graph die Vorgabewerte für den Filter. Der Standardwert ist False.


Beispiel zur Export-Methode

In diesem Beispiel wird das Diagramm als GIF-Datei exportiert.

myChart.Export _
    FileName:="current_sales.gif", FilterName:="GIF"


FileImport-Methode

Importiert eine angegebene Zeile bzw. einen angegebenen Bereich oder ein gesamtes Blatt mit Daten.

Syntax

Ausdruck.FileImport(FileName, Password, ImportRange, WorksheetName, OverwriteCells)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

FileName String erforderlich. Die Datei, die die zu importierenden Daten enthält.

Password Variant optional. Das Kennwort der zu importierenden Datei, falls die Datei kennwortgeschützt ist.

ImportRange Variant optional. Der zu importierende Zellbereich, falls die zu importierende Datei ein Microsoft Excel-Tabellenblatt oder eine Arbeitsmappe ist. Wird dieses Argument weggelassen, werden die gesamten Inhalte des Tabellenblattes importiert.

WorksheetName Variant optional. Der Name des zu importierenden Tabellenblattes, falls die zu importierende Datei eine Microsoft Excel-Arbeitsmappe ist.

OverwriteCells Variant optional. True, um festzulegen, dass der Benutzer unterrichtet wird, bevor importierte Daten bestehende Daten im Tabellenblatt überschreiben. Der Standardwert ist True.


Beispiel zur FileImport-Methode

In diesem Beispiel werden Daten aus dem Bereich A2:D5 des Tabellenblattes "My Sheet" in die Microsoft Excel-Arbeitsmappe "mynums.xls" importiert.

With myChart.Application
    .FileImport FileName:="C:\mynums.xls" _
        ImportRange:="A2:D5" WorksheetName:="MySheet" _
        OverwriteCells:=False
End With


Insert-Methode

Fügt eine Zelle oder einen Zellbereich in das Tabellenblatt ein und verschiebt die anderen Zellen entsprechend.

Ausdruck.Insert(Shift)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Shift Variant optional. Gibt an, in welche Richtung die Zellen verschoben werden. Dies kann eine der folgenden XlInsertShiftDirection-Konstanten sein: xlShiftToRight oder xlShiftDown. Wird das Argument weggelassen, legt Microsoft Graph die Richtung anhand der Form des Bereichs fest.


Beispiel zur Insert-Methode

In diesem Beispiel wird eine neue Zelle vor Zeile 4 im Tabellenblatt eingefügt.

myChart.Application.DataSheet.Rows(4).Insert

In diesem Beispiel werden neue Zellen im Bereich A1:C5 im Tabellenblatt eingefügt und die Zellen nach unten verschoben.

Set mySheet = myChart.Application.DataSheet
mySheet.Range("A1:C5").Insert Shift:=xlShiftDown


Item-Methode

Gibt einen Teil der angegebenen Auflistung zurück. Die Item-Methode ist die Standardmethode für Auflistungen. Beispielsweise besitzen die folgenden beiden Code-Zeilen die gleiche Bedeutung:

myChart.SeriesCollection.Item(1)
myChart.SeriesCollection(1)


LegendEntries-Methode

Gibt ein Objekt zurück, das einen einzelnen Legendeneintrag (ein LegendEntry-Objekt, Syntax 1) oder eine Auflistung von Legendeneinträgen (ein LegendEntries-Objekt, Syntax 2) der Legende darstellt.

Syntax 1

Ausdruck.LegendEntries(Index)

Syntax 2

Ausdruck.LegendEntries

Ausdruck Erforderlich. Ein Ausdruck, der ein Legend-Objekt zurückgibt.

Index Variant optional. Die Nummer des Legendeneintrags.


Beispiel zur LegendEntries-Methode

In diesem Beispiel wird die Schrift für den ersten Legendeneintrag festgelegt.

myChart.Legend.LegendEntries(1).Font.Name = "Arial"


LineGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Liniendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Liniendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.LineGroups(Index)

Syntax 2

Ausdruck.LineGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur LineGroups-Methode

In diesem Beispiel wird für alle Datenpunktmarkierungen der ersten Liniendiagrammgruppe eine andere Farbe verwendet. Wenden Sie das Makro auf ein 2D-Diagramm an.

myChart.LineGroups(1).VaryByCategories = True


OneColorGradient-Methode

Legt für die angegebene Füllung einen einfarbigen, fließenden Farbverlauf fest.

Syntax

Ausdruck.OneColorGradient(Style, Variant, Degree)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

Style Long erforderlich. Die Richtung des Farbverlaufs der angegebenen Füllung. Kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Farbverlaufsvariante der angegebenen Füllung. Kann ein Wert von 1 bis 4 sein, entsprechend den vier Varianten, die in der Registerkarte Gradient im Dialogfeld Fülleffekte aufgeführt sind. Besitzt Style den Wert msoGradientFromCenter, kann das Argument Variant nur 1 oder 2 sein.

Degree Single erforderlich. Der Grad des Farbverlaufs der angegebenen Füllung. Kann ein Wert von 0,0 (dunkel) bis 1,0 (hell) sein.


Beispiel zur OneColorGradient-Methode

In diesem Beispiel wird das Füllungsformat des Diagramms festgelegt.

With myChart.ChartArea.Fill
    If .Type = msoFillGradient Then
        If .GradientColorType = msoGradientOneColor Then
            .OneColorGradient Style:=msoGradientFromCorner, _
                 Variant:=1, Degree:=0.3
        End If
    End If
End With


Paste-Methode

Fügt den Inhalt der Zwischenablage in den angegebenen Bereich des Datenblattes ein.

Syntax

Ausdruck.Paste(Link)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Link Variant optional. True, um eine Verknüpfung zu der Quelle der eingefügten Daten herzustellen. Der Standardwert ist False.


Beispiel zur Paste-Methode

In diesem Beispiel wird der Inhalt der Zwischenablage in die Zelle A1 des Datenblattes eingefügt.

myChart.Application.DataSheet.Range("A1").Paste


Patterned-Methode

Legt für die angegebene Füllung eine Struktur fest.

Syntax

Ausdruck.Patterned(Pattern)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

Pattern Long erforderlich. Die Strukturart. Kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBricks

msoPatternDivits

msoPatternDottedGrid

msoPatternHorizontalBrick

msoPatternLargeCheckerBoard

 msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDiamonds

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamonds

msoPatternPlaid

msoPatternShingles

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamonds

msoPatternSpheres

msoPatternTrellis

msoPatternWaves

msoPatternWavyLines

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal


Beispiel zur Patterned-Methode

In diesem Beispiel wird die Struktur der Füllung festgelegt.

With myChart.ChartArea.Fill
    .Patterned msoPatternDiagonalBrick
    .Visible = True
End With


PieGroups-Methode

Gibt bei einem 2D-Diagramm ein Objekt zurück, das eine einzelne Kreisdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Kreisdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.PieGroups(Index)

Syntax 2

Ausdruck.PieGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur PieGroups-Methode

In diesem Beispiel wird für die erste Kreisdiagrammgruppe festgelegt, dass jede Datenpunktmarkierung eine andere Farbe erhält. Es ist sinnvoll, das Makro auf ein 2D-Diagramm anzuwenden.

myChart.PieGroups(1).VaryByCategories = True


Points-Methode

Gibt ein Objekt zurück, das einen einzelnen Datenpunkt (ein Point-Objekt, Syntax 1) oder eine Auflistung aller Datenpunkte (eine Points-Auflistung, Syntax 2) der Datenreihe darstellt. Schreibgeschützt.

Syntax 1

Ausdruck.Points(Index)

Syntax 2

Ausdruck.Points

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des Datenpunkts.


Beispiel zur Points-Methode

In diesem Beispiel erhält der erste Datenpunkt der ersten Datenreihe eine Beschriftung.

myChart.SeriesCollection(1).Points(1).ApplyDataLabels


PresetGradient-Methode

Legt für die angegebene Füllung einen vordefinierten Farbverlauf fest.

Syntax

Ausdruck.PresetGradient(Style, Variant, PresetGradientType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

Style Erforderlich Long. Legt den Farbverlaufsstil für die angegebene Füllung fest. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Erforderlich Long. Die Farbverlaufsvariante für die angegebene Füllung. Kann ein Wert zwischen 1 und 4 sein, entsprechend den vier Varianten, die auf der Registerkarte Graduelle Füllung im Dialogfeld Fülleffekte aufgeführt werden. Besitzt Style den Wert msoGradientFromCenter, kann das Argument Variant nur den Wert 1 oder 2 haben.

PresetGradientType Erforderlich Long. Der Farbverlaufstyp für die angegebene Füllung. Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed


Beispiel zur PresetGradient-Methode

In diesem Beispiel wird als Füllungsformat des Diagramms die vordefinierte Messingfarbe festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .PresetGradient msoGradientDiagonalDown, 3, msoGradientBrass
End With


PresetTextured-Methode

Legt das Format der angegebenen Füllung für eine vordefinierte Strukturart fest.

Syntax

Ausdruck.PresetTextured(PresetTexture)

Ausdruck Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

PresetTexture Erforderlich Long. Die vordefinierte Strukturart für die angegebene Füllung. Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

Kann einer der folgenden MsoPresetTexture-Werte sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat


Beispiel zur PresetTextured-Methode

In diesem Beispiel wird im Füllungsformat des Diagramms die vordefinierte Struktur von Oak (Eiche) in Walnut (Walnuss) geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillTextured Then
        If .TextureType = msoTexturePreset Then
            If .PresetTexture = msoTextureOak Then
                .PresetTextured msoTextureWalnut
            End If
        End If
    End If
End With


Quit-Methode

Beendet Microsoft Graph.

Syntax

Ausdruck.Quit

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur Quit-Methode

Mit diesem Beispiel wird Microsoft Graph beendet.

myChart.Application.Quit


RadarGroups-Methode

Gibt für ein 2D-Diagramm ein Objekt zurück, das eine einzelne Netzdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Netzdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.RadarGroups(Index)

Syntax 2

Ausdruck.RadarGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur RadarGroups-Methode

In diesem Beispiel wird für jeden Datenpunkt in der ersten Netzgruppe eine andere Farbe verwendet. Es ist sinnvoll, das Makro auf ein 2D-Diagramm anzuwenden.

myChart.RadarGroups(1).VaryByCategories = True


Refresh-Methode

Löst aus, dass das angegebene Diagramm sofort neu gezeichnet wird.

Syntax

Ausdruck.Refresh

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.


ReplacementList-Methode

Gibt die Matrix der AutoKorrektur-Ersetzungen zurück.

Syntax

Ausdruck.ReplacementList(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrect-Objekt zurückgibt.

Index Variant optional. Die Zeile der Matrix der AutoKorrektur-Ersetzungen, die zurückgegeben werden soll. Die Zeile wird als eindimensionale Matrix mit zwei Elementen zurückgegeben: Das erste Element ist der Text in Spalte 1, das zweite Element ist der Text in Spalte 2. Befindet sich Index außerhalb des Bereichs, schlägt die Methode fehl.

Wird Index ausgelassen, gibt diese Methode eine zweidimensionale Matrix zurück. Jede Zeile in der Matrix enthält eine Ersetzung, wie in der folgenden Tabelle angezeigt.

Spalte | Inhalt
1 | Der zu ersetzende Text
2 | Der Ersatztext

Anmerkungen

Verwenden Sie die AddReplacement-Methode, wenn Sie zur Liste der Ersetzungen einen Eintrag hinzufügen möchten.


Beispiel zur ReplacementList-Methode

In diesem Beispiel wird die Liste der Ersetzungen nach "Temperature" durchsucht und der Ersetzungseintrag angezeigt, falls er existiert.

repl = myChart.Application.AutoCorrect.ReplacementList
For x = 1 To UBound(repl)
        If repl(x, 1) = "Temperature" Then MsgBox repl(x, 2)
Next


SaveAsOldFileFormat-Methode

Speichert ein Diagramm in einer Host-Anwendung wie Microsoft PowerPoint in dem angegebenen älteren Dateiformat.

Syntax

Ausdruck.SaveAsOldFileFormat(MajorVersion, MinorVersion)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

MajorVersion Variant optional. Gibt die Hauptversionsnummer des Dateiformats an, das Sie verwenden möchten.

MinorVersion Variant optional. Gibt die Unterversionsnummer des Dateiformats an, das Sie verwenden möchten.


Beispiel zur SaveAsOldFileFormat-Methode

In diesem Beispiel wird das Diagramm im Dateiformat von Microsoft Graph 5 gespeichert.

myChart.Application.SaveAsOldFileFormat MajorVersion:=5


SeriesCollection-Methode

Gibt ein Objekt zurück, das eine einzelne Datenreihe (ein Series-Objekt, Syntax 1) oder eine Auflistung aller Datenreihen (ein SeriesCollection-Objekt, Syntax 2) des Diagramms oder der Diagrammgruppe darstellt.

Syntax 1

Ausdruck.SeriesCollection(Index)

Syntax 2

Ausdruck.SeriesCollection

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart- oder ChartGroup-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer der Datenreihe.


Beispiel zur SeriesCollection-Methode

In diesem Beispiel werden die Datenbeschriftungen für die erste Datenreihe aktiviert.

myChart.SeriesCollection(1).HasDataLabels = True


SetDefaultChart-Methode

Legt den Namen der Diagrammvorlage fest, die Microsoft Graph bei der Erstellung neuer Diagramme verwendet.

Syntax

Ausdruck.SetDefaultChart(FormatName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

FormatName Variant optional. Der Name des angegebenen benutzerdefinierten AutoFormats. Dieser Name kann eine Zeichenfolge sein, die das benutzerdefinierte AutoFormat angibt, oder die Sonderkonstante xlBuiltIn, mit der die integrierte Diagrammvorlage angegeben wird.


Beispiel zur SetDefaultChart-Methode

In diesem Beispiel wird als Standarddiagrammvorlage das benutzerdefinierte AutoFormat "Monthly Sales" festgelegt.

myChart.Application.SetDefaultChart FormatName:="Monthly Sales"


Solid-Methode

Legt für die Füllung eine einfarbige Farbe fest. Verwenden Sie diese Methode, wenn Sie eine fließende, strukturierte bzw. gemusterte Füllung oder eine Hintergrundfüllung in eine Farbflächenfüllung umwandeln möchten.


Beispiel zur Solid-Methode

In diesem Beispiel wird die Füllung der Diagrammfläche in eine Farbflächenfüllung umgewandelt.

myChart.ChartArea.Fill.Solid


Trendlines-Methode

Gibt ein Objekt zurück, das eine einzelne Trendlinie (ein Trendline-Objekt, Syntax 1) oder eine Auflistung aller Trendlinien (ein Trendlines-Objekt, Syntax 2) der Datenreihe darstellt.

Syntax 1

Objekt.Trendlines(Index)

Syntax 2

Objekt.Trendlines

Objekt Erforderlich. Das Objekt Series.

Index Variant optional. Der Name oder die Nummer der Trendlinie.


Beispiel zur Trendlines-Methode

In diesem Beispiel wird zur ersten Datenreihe eine lineare Trendlinie hinzugefügt.

myChart.SeriesCollection(1).Trendlines.Add Type:=xlLinear


TwoColorGradient-Methode

Bestimmt eine zweifarbige fließende Füllung.

Syntax

Ausdruck.TwoColorGradient(Style, Variant)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

Style Long erforderlich. Legt den Farbverlaufstil fest. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Legt die Variante des Farbverlaufs fest. Dies kann ein Wert von 1 bis 4 sein, entsprechend den vier Varianten der Registerkarte Graduell im Dialogfeld Fülleffekte. Wenn Style den Wert msoGradientFromCenter hat, kann das Argument Variant nur den Wert 1 oder 2 haben.


Beispiel zur TwoColorGradient-Methode

In diesem Beispiel werden der Farbverlauf und die Hintergrund- sowie Vordergrundfarbe für die Füllung des Diagrammbereichs festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


Update-Methode

Aktualisiert das angegebene eingebettete Objekt in der Host-Datei.

Syntax

Ausdruck.Update

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


UserPicture-Methode

Füllt die angegebene Form mit einem Bild.

Syntax

Ausdruck.UserPicture(PictureFile, PictureFormat, PictureStackUnit, PicturePlacement)

Ausdruck Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

PictureFile String erforderlich. Der Name der angegebenen Bilddatei.

PictureFormat Long optional. Das Format des angegebenen Bildes. Kann eine der folgenden XlChartPictureType-Konstanten sein: xlScale, xlStackScale, xlStack oder xlStretch.

PictureStackUnit Long optional. Die Stapel- oder Skalierungseinheit des angegebenen Bildes (hängt von dem PictureFormat-Argument ab).

PicturePlacement Long optional. Die Positionierung des angegebenen Bildes. Kann eine der folgenden XlChartPicturePlacement-Konstanten sein: xlSides, xlEnd, xlEndSides, xlFront, xlFrontSides, xlFrontEnd oder xlAllFaces.


Beispiel zur UserPicture-Methode

In diesem Beispiel wird festgelegt, dass die Füllung des Diagramms auf der Grundlage eines vom Benutzer gelieferten Bildes formatiert wird.

With myChart.ChartArea.Fill
    .UserPicture PictureFile:="C:\My Documents\brick.bmp"
    .Visible = True
End With


UserTextured-Methode

Füllt die angegebene Form mit kleinen Kacheln des Bildes. Soll sie mit einem großen Bild gefüllt werden, verwenden Sie die UserPicture-Methode.

Syntax

Ausdruck.UserTextured(TextureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartFillFormat-Objekt zurückgibt.

TextureFile String erforderlich. Der Name der angegebenen Bilddatei.


Beispiel zur UserTextured-Methode

In diesem Beispiel wird die benutzerdefinierte Strukturart für das Füllungsformat des Diagramms geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillTextured Then
        If .TextureType = msoTextureUserDefined Then
            If .TextureName = "C:\brick.bmp" Then
               .UserTextured "C:\stone.bmp"
            End If
        End If
    End If
End With


XYGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Punkt (xy)-Diagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Punkt (xy)-Diagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.XYGroups(Index)

Syntax 2

Ausdruck.XYGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur XYGroups-Methode

In diesem Beispiel wird festgelegt, dass in der ersten XY-Gruppe (Punktdiagrammgruppe) für jeden Datenpunkt eine andere Farbe verwendet wird. Es ist sinnvoll, das Makro auf ein 2D-Diagramm anzuwenden.

myChart.XYGroups(1).VaryByCategories = True


Application-Objekt

Stellt das gesamte Microsoft Graph-Programm dar. Das Application-Objekt stellt die höchste Ebene der Objekthierarchie dar und enthält alle Objekte, Eigenschaften und Methoden des Programms.

Verwenden des Application-Objekts

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Im folgenden Beispiel wird die DataSheet-Eigenschaft für das Application-Objekt festgelegt.

myChart.Application.DataSheet.Range("A1").Value = 32


AutoCorrect-Objekt

Enthält Microsoft Graph-AutoKorrektur-Eigenschaften (Großschreibung von Tagen, Korrektur zweier großgeschriebener Anfangsbuchstaben, automatische Korrekturliste usw.).

Verwenden des AutoCorrect-Objekts

Verwenden Sie die AutoCorrect-Eigenschaft, um das AutoCorrect-Objekt zurückzugeben. Im folgenden Beispiel wird festgelegt, dass Microsoft Graph Wörter, die zwei großgeschriebene Anfangsbuchstaben besitzen, automatisch korrigiert.

With myChart.Application.AutoCorrect
    .TwoInitialCapitals = True
    .ReplaceText = True
End With


Axis-Objekt

Stellt eine einzelne Achse eines Diagramms dar. Das Axis-Objekt ist ein Element der Axes-Auflistung.

Verwenden des Axis-Objekts

Verwenden Sie Axes(Typ, Gruppe), wobei Typ der Achsentyp und Gruppe die Achsengruppe ist, um ein einzelnes Axis-Objekt zurückzugeben. Typ kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeries oder xlValue. Gruppe kann eine der beiden folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Weitere Informationen finden Sie unter der Axes-Methode.

Im folgenden Beispiel wird der Text im Titel der Rubrikenachse des ersten Diagramms festgelegt.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Caption = "1994"
End With


Axes-Auflistungsobjekt

Eine Auflistung aller Axis-Objekte des angegebenen Diagramms.

Verwenden der Axes-Auflistung

Verwenden Sie die Axes-Methode, um die Axes-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Achsen im Diagramm angezeigt.

With myChart
    MsgBox .Axes.Count
End With

Verwenden Sie Axes(Typ, Gruppe), wobei Typ der Achsentyp und Gruppe die Achsengruppe ist, um ein einzelnes Axis-Objekt zurückzugeben. Typ kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeries oder xlValue. Gruppe kann eine der beiden folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Weitere Informationen finden Sie unter der Axes-Methode.

Im folgenden Beispiel wird der Text im Titel der Rubrikenachse festgelegt.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Caption = "1994"
End With


AxisTitle-Objekt

Stellt den Titel einer Achse in einem Diagramm dar.

Verwenden des AxisTitle-Objekts

Verwenden Sie die AxisTitle-Eigenschaft, um ein AxisTitle-Objekt zurückzugeben. Im folgenden Beispiel wird der Text im Titel der Größenachse festgelegt und die Schriftart "Bookman" in 10 Punkt zugewiesen.

With myChart.Axes(xlValue)
    .HasTitle = True
    With .AxisTitle
        .Caption = "Revenue (millions)"
        .Font.Name = "bookman"
        .Font.Size = 10
    End With
End With

Anmerkungen

Das AxisTitle-Objekt existiert nicht und kann nicht verwendet werden, solange die HasTitle-Eigenschaft der angegebenen Achse den Wert True besitzt.


Border-Objekt

Stellt den Rahmen des angegebenen Objekts dar.

Verwenden des Border-Objekts

Der Rahmen eines Objekts wird immer als einzelne Einheit behandelt und in seiner Gesamtheit zurückgegeben, unabhängig von der Anzahl seiner Seiten. Verwenden Sie die Border-Eigenschaft, um das Border-Objekt zurückzugeben. Im folgenden Beispiel wird um die Diagrammfläche ein gestrichelter und um die Zeichnungsfläche ein gepunkteter Rahmen gelegt.

With myChart
    .ChartArea.Border.LineStyle = xlDash
    .PlotArea.Border.LineStyle = xlDot
End With


Chart-Objekt

Stellt das angegebene Microsoft Graph-Diagramm dar.

Verwenden des Chart-Objekts

Verwenden Sie die Chart-Eigenschaft um ein Chart-Objekt zurückzugeben. Meistens werden Sie einen Bezug zu einem Microsoft Graph-Diagramm herstellen und ihn anschließend in Ihrem Code verwenden.


ChartArea-Objekt

Stellt die Diagrammfläche des angegebenen Diagramms dar. In einem 2D-Diagramm enthält die Diagrammfläche die Achsen, den Diagrammtitel, die Achsentitel und die Legende. In einem 3D-Diagramm enthält sie den Diagrammtitel und die Legende; die Zeichnungsfläche (die Fläche innerhalb der Diagrammfläche, in der die Daten aufgezeichnet werden) ist nicht eingeschlossen. Weitere Informationen über die Formatierung der Zeichnungsfläche finden Sie unter dem PlotArea-Objekt.

Verwenden des ChartArea-Objekts

Verwenden Sie die ChartArea-Eigenschaft, um das ChartArea-Objekt zurückzugeben. Im folgenden Beispiel wird das Muster der Diagrammfläche festgelegt.

myChart.ChartArea.Interior.Pattern = xlLightDown


ChartColorFormat-Objekt

Stellt eine Vordergrund- oder Hintergrundfarbe dar.

Verwenden des ChartColorFormat-Objekts

Verwenden Sie die ForeColor-Eigenschaft, um ein ChartColorFormat-Objekt zurückzugeben, das die Füllfarbe des Vordergrunds darstellt. Mit Hilfe der BackColor-Eigenschaft geben Sie die Füllfarbe des Hintergrunds zurück. Die RGB-Eigenschaft gibt die Farbe als expliziten Rot-Grün-Blauwert zurück. Die SchemeColor-Eigenschaft verwenden Sie, um die Farbe als ein Element der Farbskala zurückzugeben oder festzulegen. Im folgenden Beispiel werden für die Füllung der Diagrammfläche im ersten Diagramm Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


ChartFillFormat-Objekt

Stellt die Formatierung der Füllung dar.

Verwenden des ChartFillFormat-Objekts

Verwenden Sie die Fill-Eigenschaft, um das ChartFillFormat-Objekt zurückzugeben. Im folgenden Beispiel werden für die Füllung der Diagrammfläche im ersten Diagramm Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


ChartGroup-Objekt

Stellt eine oder mehrere Datenreihen von Punkten dar, die in einem Diagramm mit demselben Format gezeichnet sind. Ein Diagramm enthält eine oder mehrere Diagrammgruppen, jede Diagrammgruppe enthält eine oder mehrere Datenreihen, und jede Datenreihe enthält einen oder mehrere Punkte. Beispielsweise kann ein einzelnes Diagramm sowohl eine Liniendiagrammgruppe, in der sich alle mit dem Format des Liniendiagramms gezeichneten Datenreihen befinden, enthalten als auch eine Balkendiagrammgruppe, in der sich alle mit dem Format des Balkendiagramms gezeichneten Datenreihen befinden. Das ChartGroup-Objekt ist ein Element der ChartGroups-Auflistung.

Verwenden des ChartGroup-Objekts

Verwenden Sie ChartGroups(Index), wobei Index die Indexnummer der Diagrammgruppe ist, um ein einzelnes ChartGroup-Objekt zurückzugeben. Im folgenden Beispiel werden der ersten Diagrammgruppe im Diagramm Bezugslinien hinzugefügt.

myChart.ChartGroups(1).HasDropLines = True

Da sich die Indexnummer einer bestimmten Diagrammgruppe ändern kann, wenn das für die Gruppe verwendete Diagrammformat geändert wird, kann es einfacher sein, eine der genannten Schnellzugriffsmethoden für Diagrammgruppen zu verwenden, um eine bestimmte Diagrammgruppe zurückzugeben. Die PieGroups-Methode gibt die Auflistung von Kreisdiagrammgruppen in einem Diagramm zurück, die LineGroups-Methode gibt die Auflistung aller Liniendiagrammgruppen zurück usw. Sie können jede dieser Methoden mit einer Indexnummer verwenden, um ein einzelnes ChartGroup-Objekt zurückzugeben. Ohne Angabe einer Indexnummer wird eine ChartGroups-Auflistung zurückgegeben. Folgende Methoden sind für Diagrammgruppen verfügbar:

  • AreaGroups-Methode

  • BarGroups-Methode

  • ColumnGroups-Methode

  • DoughnutGroups-Methode

  • LineGroups-Methode

  • PieGroups-Methode


ChartGroups-Auflistungsobjekt

Eine Auflistung aller ChartGroup-Objekte des angegebenen Diagramms. Das ChartGroup-Objekt stellt eine oder mehrere Datenreihen dar, die im Diagramm in demselben Format aufgezeichnet sind. Ein Diagramm enthält eine oder mehrere Diagrammgruppen, jede Diagrammgruppe enthält eine oder mehrere Datenreihen und jede Datenreihe enthält einen oder mehrere Punkte. Beispielsweise kann ein einzelnes Diagramm sowohl eine Liniendiagrammgruppe enthalten, in der sich alle mit dem Format des Liniendiagramms gezeichneten Datenreihen befinden, als auch eine Balkendiagrammgruppe, in der sich alle mit dem Format des Balkendiagramms gezeichneten Datenreihen befinden.

Verwenden der ChartGroups-Auflistung

Verwenden Sie die ChartGroups-Methode, um die ChartGroups-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Diagrammgruppen im Diagramm angezeigt.

MsgBox myChart.ChartGroups.Count

Verwenden Sie ChartGroups(Index), wobei Index die Indexnummer der Diagrammgruppe ist, um ein einzelnes ChartGroup-Objekt zurückzugeben. Im folgenden Beispiel werden der ersten Diagrammgruppe im Diagramm Bezugslinien hinzugefügt.

myChart.ChartGroups(1).HasDropLines = True

Da sich die Indexnummer einer bestimmten Diagrammgruppe ändern kann, wenn das für die Gruppe verwendete Diagrammformat geändert wird, kann es einfacher sein, eine der genannten Schnellzugriffsmethoden für Diagrammgruppen zu verwenden, um eine bestimmte Diagrammgruppe zurückzugeben. Die PieGroups-Methode gibt die Auflistung von Kreisdiagrammgruppen in einem Diagramm zurück, die LineGroups-Methode gibt die Auflistung aller Liniendiagrammgruppen zurück usw. Sie können jede dieser Methoden mit einer Indexnummer verwenden, um ein einzelnes ChartGroup-Objekt zurückzugeben. Ohne Angabe einer Indexnummer wird eine ChartGroups-Auflistung zurückgegeben. Folgende Methoden sind für Diagrammgruppen verfügbar:

  • AreaGroups-Methode

  • BarGroups-Methode

  • ColumnGroups-Methode

  • DoughnutGroups-Methode

  • LineGroups-Methode

  • PieGroups-Methode


ChartTitle-Objekt

Stellt den Titel des angegebenen Diagramms dar.

Verwenden des ChartTitle-Objekts

Verwenden Sie die ChartTitle-Eigenschaft, um das ChartTitle-Objekt zurückzugeben. Im folgenden Beispiel wird dem Diagramm ein Titel hinzugefügt.

With myChart
    .HasTitle = True
    .ChartTitle.Text = "February Sales"
End With

Anmerkungen

Das ChartTitle-Objekt existiert nicht und kann nicht zurückgegeben werden, solange die HasTitle-Eigenschaft des Diagramms den Wert True besitzt.


Corners-Objekt

Stellt die Ecken des angegebenen 3D-Diagramms dar. Dieses Objekt ist keine Auflistung.

Verwenden des Corners-Objekts

Verwenden Sie die Corners-Eigenschaft, um das Corners-Objekt zurückzugeben. Im folgenden Beispiel werden die Ecken des Diagramms markiert.

myChart.Corners.Select

Handelt es sich bei dem Diagramm nicht um ein 3D-Diagramm, schlägt die Corners-Eigenschaft fehl.


DataLabel-Objekt

Stellt die Datenbeschriftung des angegebenen Punktes oder der angegebenen Trendlinie in einem Diagramm dar. Bei einer Datenreihe ist das DataLabel-Objekt ein Element der DataLabels-Auflistung, die für jeden Punkt ein DataLabel-Objekt enthält. Bei einer Datenreihe ohne definierbare Punkte (z. B. einer Bereichsdatenreihe), enthält die DataLabels-Auflistung ein einziges DataLabel-Objekt.

Verwenden des DataLabel-Objekts

Verwenden Sie DataLabels(Index), wobei Index die Indexnummer der Datenbeschriftung ist, um ein einzelnes DataLabel-Objekt zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die fünfte Datenbeschriftung der ersten Datenreihe im Diagramm festgelegt.

myChart.SeriesCollection(1).DataLabels(5).NumberFormat = "0.000"

Verwenden Sie die DataLabel-Eigenschaft, um das DataLabel-Objekt für einen einzelnen Punkt zurückzugeben. Im folgenden Beispiel wird für den zweiten Punkt der ersten Datenreihe im Diagramm die Datenbeschriftung eingeschaltet und ihr der Text "Samstag" zugewiesen.

With myChart
    With .SeriesCollection(1).Points(2)
        .HasDataLabel = True
        .DataLabel.Text = "Saturday"
    End With
End With

Bei einer Trendlinie gibt die DataLabel-Eigenschaft den mit der Trendlinie angezeigten Text zurück. Dabei kann es sich um die Gleichung, den R-Quadratwert oder um beide handeln (wenn beide angezeigt werden). Im folgenden Beispiel wird festgelegt, dass der Text der Trendlinie nur die Gleichung anzeigt. Danach wird der Text der Datenbeschriftung in die Zelle A1 auf dem Datenblatt positioniert.

With myChart.SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = False
    .DisplayEquation = True
    x = .DataLabel.Text
End With
With myChart.Application.DataSheet
    .Range("A1").Value = x
End With


DataLabels-Auflistungsobjekt

Eine Auflistung aller DataLabel-Objekte der angegebenen Datenreihe. Das DataLabel-Objekt stellt eine Datenbeschriftung eines Punktes oder einer Trendlinie dar. Bei Datenreihen ohne definierbare Punkte (z. B. einer Bereichsdatenreihe), enthält die DataLabels-Auflistung eine einzelne Datenbeschriftung.

Verwenden der DataLabels-Auflistung

Verwenden Sie die DataLabels-Methode, um die DataLabels-Auflistung zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die Datenbeschriftung der ersten Datenreihe im Diagramm festgelegt.

With myChart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.NumberFormat = "##.##"
End With

Verwenden Sie DataLabels(Index), wobei Index die Indexnummer der Datenbeschriftung ist, um ein einzelnes DataLabel-Objekt zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die fünfte Datenbeschriftung der ersten Datenreihe im Diagramm festgelegt.

myChart.SeriesCollection(1).DataLabels(5).NumberFormat = "0.000"


DataSheet-Objekt

Stellt das Microsoft Graph-Datenblatt dar.

Verwendung des DataSheet-Objekts

Nachdem Sie einen Bezug zu einem Diagramm hergestellt haben, können Sie die Application-Eigenschaft des Diagramms verwenden, um das Datenblatt abzurufen. Im folgenden Beispiel wird die DataSheet-Eigenschaft des Application-Objekts und anschließend die Range-Eigenschaft des Datenblattes festgelegt, um der Zelle A1 den Wert 32 zuzuweisen.

myChart.Application.DataSheet.Range("A1").Value = 32

Anmerkungen

Die erste Spaltenüberschrift (links beginnend) lautet A, die nächsten B, C, D usw. Die erste Zeilenüberschrift (oben beginnend) lautet 1, die nächsten 2, 3, 4 usw. Weder die am weitesten links gelegene Spalte noch die oberste Zeile sind mit einer Überschrift versehen. Mit anderen Worten ist die Spalte A eigentlich die zweite Spalte von links; entsprechend ist die Zeile 1 die zweite Zeile von oben. Die am weitesten links gelegene Spalte und die oberste Zeile werden gewöhnlich für Legendentext oder Achsenbeschriftungen verwendet und als Spalte 0 (Null) bzw. Zeile 0 (Null) bezeichnet. So wird im folgenden Beispiel der Text "Jahresumsatz" in die oberste Zelle der Spalte A (die zweite Spalte) eingefügt.

myChart.Application.DataSheet.Range("A0").Value = "Annual Sales"

Im folgenden Beispiel wird der Text "Bezirk 1" in die am weitesten links gelegene Zelle der Zeile 2 (die dritte Zeile) eingefügt.

myChart.Application.DataSheet.Range("02").Value = "District 1"


DataTable-Objekt

Stellt eine Datentabelle des angegebenen Diagramms dar.

Verwenden des DataTable-Objekts

Verwenden Sie die DataTable-Eigenschaft um ein DataTable-Objekt zurückzugeben. Im folgenden Beispiel wird eine Datentabelle mit Konturrahmen in das eingebettete Diagramm eingefügt.

With myChart
    .HasDataTable = True
    .DataTable.HasBorderOutline = True
End With


DisplayUnitLabel-Objekt

Zusammenstellung von Achsen (Axis-Objekt)

Steht für die Beschriftung von Einheiten auf der Größenachse im angegebenen Diagramm. Beschriftungen für Einheiten sind in den Diagrammen nützlich, in denen große Werte dargestellt werden, wie zum Beispiel Zahlen im Millionen- oder Milliardenbereich. Wenn Sie an den Teilstrichen der Achse eine einzige Einheitenbeschriftung an Stelle von großen Zahlen mit vielen Nullen verwenden, wird das Diagramm leichter lesbar. Sie brauchen in diesem Fall an den Teilstrichen nur noch zweistellige Zahlen.

Verwenden des DisplayUnitLabel-Objekts

Verwenden Sie die DisplayUnitLabel-Eigenschaft, wenn das DisplayUnitLabel-Objekt zurückgegeben werden soll. Im folgenden Beispiel wird für die Größenachse in myChart als Beschriftung "Million" festgelegt und die automatische Schriftskalierung wird deaktiviert.

With myChart.Axes(xlValue).DisplayUnitLabel
    .Caption = "Millions"
    .AutoScaleFont = False
End With


DownBars-Objekt

Stellt die negativen Abweichungsbalken der angegebenen Diagrammgruppe dar. Negative Abweichungsbalken verbinden Punkte in der ersten Datenreihe mit niedrigeren Werten in der letzten Datenreihe der Diagrammgruppe (die Linien führen von der ersten Datenreihe nach unten). Nur 2D-Liniengruppen mit mindestens zwei Datenreihen können negative Abweichungsbalken enthalten. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das einen einzelnen negativen Abweichungsbalken darstellt; positive und negative Abweichungsbalken sind für alle Punkte einer Diagrammgruppe entweder aus- oder eingeschaltet.

Verwenden des DownBars-Objekts

Verwenden Sie die DownBars-Eigenschaft, um das DownBars-Objekt zurückzugeben. Im folgenden Beispiel werden die positiven und die negativen Abweichungsbalken der ersten Diagrammgruppe im Diagramm eingeschaltet. Anschließend wird den positiven Abweichungsbalken die Farbe Blau und den negativen die Farbe Rot zugewiesen.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .UpBars.Interior.Color = RGB(0, 0, 255)
    .DownBars.Interior.Color = RGB(255, 0, 0)
End With

Anmerkungen

Besitzt die HasUpDownBars-Eigenschaft den Wert False, sind die meisten Eigenschaften des DownBars-Objekts deaktiviert.


DropLines-Objekt

Stellt die Bezugslinien der angegebenen Diagrammgruppe dar. Bezugslinien verbinden die Punkte im Diagramm mit der X-Achse. Nur Linien- und Flächendiagrammgruppen können Bezugslinien besitzen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Bezugslinie darstellt, Bezugslinien sind für alle Punkte einer Diagrammgruppe entweder ein- oder ausgeschaltet.

Verwenden des DropLines-Objekts

Verwenden Sie die DropLines-Eigenschaft, um das DropLines-Objekt zurückzugeben. Im folgenden Beispiel werden die Bezugslinien der ersten Diagrammgruppe im Diagramm eingeschaltet. Anschließend wird ihnen die Farbe Rot zugewiesen.

myChart.ChartGroups(1).HasDropLines = True
myChart.ChartGroups(1).DropLines.Border.ColorIndex = 3

Anmerkungen

Falls die HasDropLines-Eigenschaft den Wert False besitzt, sind die meisten Eigenschaften des DropLines-Objekts deaktiviert.


ErrorBars-Objekt

Stellt die Fehlerindikatoren der angegebenen Diagrammdatenreihen dar. Fehlerindikatoren zeigen den Unsicherheitsgrad von Diagrammdaten an. Nur Datenreihen von Flächen-, Balken-, Linien- und Punktgruppen in einem 2D-Diagramm können Fehlerindikatoren besitzen.

Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das einen einzelnen Fehlerindikator darstellt. X-Fehlerindikatoren oder Y-Fehlerindikatoren sind für alle Punkte einer Datenreihe entweder ein- oder ausgeschaltet.

Verwenden des ErrorBars-Objekts

Verwenden Sie die ErrorBars-Eigenschaft, um das ErrorBars-Objekt zurückzugeben. Im folgenden Beispiel werden für die erste Datenreihe des ersten eingebetteten Diagramms die Fehlerindikatoren eingeschaltet, und danach wird die Art ihrer Enden festgelegt.

myChart.SeriesCollection(1).HasErrorBars = True
myChart.SeriesCollection(1).ErrorBars.EndStyle = xlNoCap

Anmerkungen

Die ErrorBar-Methode ändert Format und Typ von Fehlerindikatoren.


Floor-Objekt

Stellt die Bodenfläche des angegebenen 3D-Diagramms dar.

Verwenden des Floor-Objekts

Verwenden Sie die Floor-Eigenschaft, um das Floor-Objekt zurückzugeben. Im folgenden Beispiel wird als Farbe der Bodenfläche des Diagramms Zyan festgelegt. Handelt es sich bei dem Diagramm nicht um ein 3D-Diagramm, schlägt dieses Beispiel fehl.

myChart.Floor.Interior.Color = RGB(0, 255, 255)


Font-Objekt

Enthält die Zeichenformatierung (Schriftartname, Schriftgrad, -farbe usw.) des angegebenen Objekts.

Verwenden des Font-Objekts

Verwenden Sie die Font-Eigenschaft, um das Font-Objekt zurückzugeben. Im folgenden Beispiel wird der Text im Titel der Größenachse festgelegt, die Schriftart "Bookman" in 10 Punkt zugewiesen und das Wort "Millionen" kursiv formatiert.

With myChart.Axes(xlValue)
    .HasTitle = True
    With .AxisTitle
        .Caption = "Revenue (millions)"
        .Font.Name = "bookman"
        .Font.Size = 10
        .Characters(10, 8).Font.Italic = True
    End With
End With


Gridlines-Objekt

Stellt Haupt- und Hilfsgitternetzlinien der angegebenen Achse dar. Gitternetzlinien verlängern die Teilstrichbeschriftungen einer Diagrammachse und machen so den mit den Datenpunktmarkierungen verbundenen Wert leichter erkennbar. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Gitternetzlinie darstellt. Gitternetzlinien einer Achse sind in ihrer Gesamtheit entweder ein- oder ausgeschaltet.

Verwenden des Gridlines-Objekts

Verwenden Sie die MajorGridlines-Eigenschaft, um das Gridlines-Objekt, das die Hauptgitternetzlinien der Achse darstellt, zurückzugeben. Verwenden Sie die MinorGridlines-Eigenschaft, um das Gridlines-Objekt, das die Hilfsgitternetzlinien der Achse darstellt, zurückzugeben. Haupt- und Hilfsgitternetzlinien können gemeinsam zurückgegeben werden.

Im folgenden Beispiel werden die Hauptgitternetzlinien der Rubrikenachse des Diagramms eingeschaltet und ihre Linien blau gestrichelt formatiert.

With myChart.Axes(xlCategory)
    .HasMajorGridlines = True
    .MajorGridlines.Border.Color = RGB(0, 0, 255)
    .MajorGridlines.Border.LineStyle = xlDash
End With


HiLoLines-Objekt

Stellt die Spannweitenlinien der angegebenen Diagrammgruppe dar. Spannweitenlinien verbinden in jeder Rubrik der Diagrammgruppe die höchsten Punkte mit den niedrigsten. Nur 2D-Liniengruppen können Spannweitenlinien besitzen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Spannweitenlinie darstellt; Spannweitenlinien sind für alle Punkte einer Diagrammgruppe entweder ein- oder ausgeschaltet.

Verwenden des HiLoLines-Objekts

Verwenden Sie die HiLoLines-Eigenschaft, um das HiLoLines-Objekt zurückzugeben. Im folgenden Beispiel wird den Spannweitenlinien der ersten Diagrammgruppe im Diagramm die Farbe Blau zugewiesen.

myChart.ChartGroups(1).HiLoLines.Border.Color = RGB(0, 0, 255)

Anmerkungen

Wenn die HasHiLoLines-Eigenschaft den Wert False besitzt, sind die meisten Eigenschaften des HiLoLines-Objekts deaktiviert.


Interior-Objekt

Stellt die Innenfläche des angegebenen Objekts dar.

Verwenden des Interior-Objekts

Verwenden Sie die Interior-Eigenschaft, um das Interior-Objekt zurückzugeben. Im folgenden Beispiel wird der Diagrammfläche die Farbe Grau und der Zeichnungsfläche die Farbe Grün zugewiesen.

With myChart
    .PlotArea.Interior.Color = RGB(0, 100, 150)
    .ChartArea.Interior.Color = RGB(50, 10, 50)
End With


LeaderLines-Objekt

Stellt Führungslinien im angegebenen Diagramm dar. Führungslinien verbinden Datenbeschriftungen mit Datenpunkten. Bei diesem Objekt handelt es sich nicht um eine Auflistung. Es ist kein Objekt vorhanden, das eine einzelne Führungslinie darstellt.

Verwenden des LeaderLines-Objekts

Verwenden Sie die LeaderLines-Eigenschaft, um das LeaderLines-Objekt zurückzugeben. Im folgenden Beispiel werden der ersten Datenreihe des Diagramms Datenbeschriftungen und blaue Führungslinien hinzugefügt.

With myChart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


Legend-Objekt

Gibt die Legende des angegebenen Diagramms zurück. Jedes Diagramm kann nur eine Legende besitzen. Das Legend-Objekt enthält ein oder mehrere LegendEntry-Objekte; jedes LegendEntry-Objekt enthält ein LegendKey-Objekt.

Verwenden des Legend-Objekts

Verwenden Sie die Legend-Eigenschaft, um das Legend-Objekt zurückzugeben. Im folgenden Beispiel wird die Schrift der Legende fett formatiert.

myChart.Legend.Font.Bold = True

Anmerkungen

Die Diagrammlegende ist nur sichtbar, wenn die HasLegend-Eigenschaft den Wert True besitzt. Besitzt sie den Wert False, schlagen Eigenschaften und Methoden des Legend-Objekts fehl.


LegendEntry-Objekt

Stellt einen Legendeneintrag in der angegebenen Diagrammlegende dar. Das LegendEntry-Objekt ist ein Element der LegendEntries-Auflistung, die alle LegendEntry-Objekte der Legende enthält.

Jede Legende besteht aus zwei Teilen: dem Eintragstext, der den Namen der dem Eintrag zugeordneten Datenreihe darstellt, und der Datenpunktmarkierung, die den Legendeneintrag sichtbar mit der zugeordneten Datenreihe oder Trendlinie im Diagramm verknüpft. Formateigenschaften der Eingangsmarkierung und der zugeordneten Datenreihe oder Trendlinie sind im LegendKey-Objekt enthalten.

Der Text eines Legendeneintrags kann nicht geändert werden. LegendEntry-Objekte unterstützen Zeichenformatierung und können nicht gelöscht werden. Bei Legendeneinträgen wird Musterformatierung nicht unterstützt. Position und Größe von Einträgen sind feste Werte.

Verwenden des LegendEntry-Objekts

Verwenden Sie LegendEntries(Index), wobei Index die Indexnummer des Legendeneintrags ist, um ein einzelnes LegendEntry-Objekt zurückzugeben. Sie können Legendeneinträge nicht durch Angabe von Namen zurückgeben.

Die Indexnummer stellt die Position des Eintrags innerhalb der Legende dar. LegendEntries(1) steht oben in der Legende, LegendEntries(LegendEntries.Count)unten. Im folgenden Beispiel wird die Schriftart für den Text des Legendeneintrags am Anfang der Legende (gewöhnlich die Legende der ersten Datenreihe) geändert.

myChart.Legend.LegendEntries(1).Font.Italic = True

Anmerkungen

Die Datenreihe und die Trendlinie, die zu einem bestimmten Legendeneintrag gehören, können auf direktem Weg nicht zurückgegeben werden.

Gelöschte Legendeneinträge lassen sich nur wiederherstellen, indem man die Legende, in der sie enthalten waren, entfernt und neu erstellt. Dazu muss für die HasLegend-Eigenschaft des Diagramms der Wert False festlegt und anschließend wieder in True ändert werden.


LegendEntries-Auflistungsobjekt

Eine Auflistung aller LegendEntry-Objekte der angegebenen Diagrammlegende. Jede Legende besteht aus zwei Teilen: dem Eintragstext, der den Namen der Datenreihe darstellt, die dem Eintrag zugeordnet ist, und der Datenpunktmarkierung, die den Legendeneintrag sichtbar mit der zugeordneten Datenreihe oder Trendlinie im Diagramm verknüpft. Formateigenschaften der Eingangsmarkierung und der zugeordneten Datenreihe oder Trendlinie sind im LegendKey-Objekt enthalten.

Verwenden der LegendEntries-Auflistung

Verwenden Sie die LegendEntries-Methode, um die LegendEntries-Auflistung zurückzugeben. Im folgenden Beispiel wird in einem Schleifendurchlauf durch die Auflistung die Schrift der Legendeneinträge im Diagramm blau formatiert.

With myChart.Legend
    For i = 1 To .LegendEntries.Count
        .LegendEntries(i).Font.ColorIndex = 5
    Next
End With

Verwenden Sie LegendEntries(Index), wobei Index die Indexnummer des Legendeneintrags ist, um ein einzelnes LegendEntry-Objekt zurückzugeben. Legendeneinträge können nicht durch Angabe eines Namens zurückgegeben werden.

Die Indexnummer stellt die Position des Eintrags innerhalb der Legende dar. LegendEntries(1) steht oben in der Legende, LegendEntries(LegendEntries.Count)unten. Im folgenden Beispiel wird der Schriftschnitt für den Text des Legendeneintrags am Anfang der Legende in myChart (gewöhnlich die Legende der ersten Datenreihe) in kursiv geändert.

myChart.Legend.LegendEntries(1).Font.Italic = True


LegendKey-Objekt

Stellt ein Legendensymbol in der angegebenen Diagrammlegende dar. Jedes Legendensymbol ist eine Grafik, die eine sichtbare Verknüpfung zwischen einem Legendeneintrag und der ihm zugeordneten Datenreihe oder Trendlinie im Diagramm herstellt. Die Verknüpfung hat zur Folge, dass beim Formatieren eines Elements gleichzeitig das andere formatiert wird.

Verwenden des LegendKey-Objekts

Verwenden Sie die LegendKey-Eigenschaft, um das LegendKey-Objekt zurückzugeben. Im folgenden Beispiel wird die Hintergrundfarbe für die Markierung des oben in der Legende stehenden Eintrags in Blau geändert. Dadurch ändert sich gleichzeitig die Formatierung jedes Punktes der Datenreihe, die mit diesem Legendeneintrag verbunden ist (allerdings nur, wenn diese Datenreihe Datenpunktmarkierungen unterstützt).

myChart.Legend.LegendEntries(1) _
    .LegendKey.MarkerBackgroundColorIndex = 5


PlotArea-Objekt

Stellt die Zeichnungsfläche des angegebenen Diagramms dar. Dies ist die Fläche, auf der die Diagrammdaten gezeichnet werden. In einem 2D-Diagramm enthält die Zeichnungsfläche Datenpunktmarkierungen, Gitternetzlinien, Datenbeschriftungen, Trendlinien und optionale Diagrammelemente, die sich in der Diagrammfläche befinden. In einem 3D-Diagramm enthält die Zeichnungsebene alle oben aufgeführten Elemente und zusätzlich Wände, Bodenfläche, Achsen, Achsentitel und Teilstrichbeschriftungen des Diagramms.

Die Diagrammfläche umgibt die Zeichnungsfläche. In einem 2D-Diagramm enthält sie die Achsen, den Diagrammtitel, die Achsentitel und die Legende. In einem 3D-Diagramm enthält die Diagrammfläche den Diagrammtitel und die Legende. Informationen über die Formatierung der Diagrammfläche finden Sie unter dem ChartArea-Objekt.

Verwenden des PlotArea-Objekts

Verwenden Sie die PlotArea-Eigenschaft, um das PlotArea-Objekt zurückzugeben. Im folgenden Beispiel wird um die Diagrammfläche ein gestrichelter Rahmen und um die Zeichnungsfläche ein gepunkteter Rahmen gelegt.

With myChart
    .ChartArea.Border.LineStyle = xlDash
    .PlotArea.Border.LineStyle = xlDot
End With


Point-Objekt

Stellt einen einzelnen Punkt in einer Datenreihe des angegebenen Diagramms dar. Das Point-Objekt ist ein Element der Points-Auflistung, die alle Punkte der angegebenen Datenreihe enthält.

Verwenden des Point-Objekts

Verwenden Sie Points(Index), wobei Index die Indexnummer des Punktes ist, um ein einzelnes Point-Objekt zurückzugeben. Punkte werden in der Datenreihe von links nach rechts nummeriert. Points(1) ist der am weitesten links und Points(Points.Count) der am weitesten rechts gelegene Punkt. Im folgenden Beispiel wird die Markierungsart für den dritten Punkt der ersten Datenreihe festgelegt. Dieses Beispiel funktioniert nur, wenn es sich bei der ersten Datenreihe um eine 2D-Linien-, -Punkt- oder -Netzdatenreihe handelt.

myChart.SeriesCollection(1).Points(3).MarkerStyle = xlDiamond


Points-Auflistungsobjekt

Eine Auflistung aller Point-Objekte der angegebenen Datenreihe in einem Diagramm.

Verwenden der Points-Auflistung

Verwenden Sie die Points-Methode, um die Points-Auflistung zurückzugeben. Im folgenden Beispiel wird dem letzten Punkt der ersten Datenreihe im Diagramm eine Datenbeschriftung hinzugefügt.

Dim pts As Points
Set pts = myChart.SeriesCollection(1).Points
pts(pts.Count).ApplyDataLabels Type:=xlShowValue

Verwenden Sie Points(Index), wobei Index die Indexnummer des Punktes ist, um ein einzelnes Point-Objekt zurückzugeben. Punkte werden innerhalb der Datenreihe von links nach rechts nummeriert. Points(1) ist der am weitesten links und Points(Points.Count) der am weitesten rechts liegende Punkt. Im folgenden Beispiel wird die Markierungsart für den dritten Punkt der ersten Datenreihe im Diagramm festgelegt. Bei der angegebenen Datenreihe muss es sich um eine 2D-Linien-, -Punkt- oder -Netzdatenreihe handeln.

myChart.SeriesCollection(1).Points(3).MarkerStyle = xlDiamond


Range-Objekt

Stellt eine Zelle, eine Zeile, eine Spalte oder eine Markierung von Zellen, die einen oder mehrere zusammenhängende Zellblöcke enthält, dar.

Verwenden des Range-Objekts

In diesem Abschnitt werden die folgenden Eigenschaften zur Rückgabe eines Range-Objekts beschrieben:

  • Range-Eigenschaft

  • Cells-Eigenschaft

Range-Eigenschaft

Verwenden Sie Range(Arg), wobei Arg der Name des Bereichs ist, um ein Range-Objekt zurückzugeben, das eine Zelle oder einen Zellbereich darstellt. Im folgenden Beispiel wird der Wert der Zelle A1 in die Zelle A5 gelegt.

myChart.Application.DataSheet.Range("A5").Value = _
    myChart.Application.DataSheet.Range("A1").Value

Im folgenden Beispiel erhält der Bereich A1:H8 den Wert 20.

myChart.Application.DataSheet.Range("A1:H8").Value = 20

Cells-Eigenschaft

Verwenden Sie Cells(Zeile, Spalte), wobei Zeile die Indexnummer der Zeile und Spalte die Indexnummer der Spalte ist, um eine einzelne Zelle zurückzugeben. Im folgenden Beispiel wird der Zelle A1 der Wert 24 zugewiesen (Spalte A ist die zweite Spalte und Zeile 1 die zweite Zeile auf dem Datenblatt.

myChart.Application.DataSheet.Cells(2, 2).Value = 24

Obwohl Sie auch mit Hilfe von Range("A1") die Zelle A1 zurückgeben können, kann es manchmal vorteilhafter sein, mit der Cells-Eigenschaft zu arbeiten, weil Sie dort eine Variable für Zeile oder Spalte angeben können. Im folgenden Beispiel werden im Datenblatt Zeilen- und Spaltenüberschriften erstellt.

Sub SetUpTable()
With myChart.Application.DataSheet
    For theYear = 1 To 5
        .Cells(1, theYear + 1).Value = 1990 + theYear
    Next theYear
    For theQuarter = 1 To 4
        .Cells(theQuarter + 1, 1).Value = "Q" & theQuarter
    Next theQuarter
End With
End Sub

Zwar können Sie Visual Basic-Zeichenfolgenfunktionen verwenden, um Bezüge in A1-Schreibweise zu ändern, doch ist es viel leichter (und eine elegantere Programmierungsweise), mit der Schreibweise Cells(1, 1) zu arbeiten.

Verwenden Sie Ausdruck.Cells(Zeile, Spalte), wobei Ausdruck ein Ausdruck ist, der ein Range-Objekt zurückgibt, und Zeile sowie Spalte relativ zur oberen linken Ecke des Bereichs angegeben werden, um einen Teil des Bereichs zurückzugeben. Im folgenden Beispiel wird der Wert der Zelle C5 festgelegt.

myChart.Application.Range("C5:C10").Cells(1, 1).Value = 35


Series-Objekt

Stellt eine Datenreihe des angegebenen Diagramms dar. Das Series-Objekt ist ein Element der SeriesCollection-Auflistung.

Verwenden des Series-Objekts

Verwenden Sie SeriesCollection(Index), wobei Index die Indexnummer oder der Name der Datenreihe ist, um ein einzelnes Series-Objekt zurückzugeben. Im folgenden Beispiel wird für die erste Datenreihe im Diagramm die Farbe der Innenfläche festgelegt.

myChart.SeriesCollection(1).Interior.Color = RGB(255, 0, 0)

Die Indexnummer der Datenreihe gibt an, in welcher Reihenfolge die Datenreihe dem Diagramm hinzugefügt wird. SeriesCollection(1) wird als erste und SeriesCollection(SeriesCollection.Count) als letzte Datenreihe eingefügt.


SeriesCollection-Auflistungsobjekt

Eine Auflistung aller Series-Objekte des angegebenen Diagramms oder der angegebenen Diagrammgruppe.

Verwenden der SeriesCollection-Auflistung

Verwenden Sie die SeriesCollection-Methode, um die SeriesCollection-Auflistung zurückzugeben. Im folgenden Beispiel wird die Innenbereichsfarbe jeder Datenreihe der Auflistung angepasst:

For X = 1 To myChart.SeriesCollection.Count
    With myChart.SeriesCollection(X)
        .Interior.Color = RGB(X * 75, 50, X * 50)
    End With
Next X

Verwenden Sie SeriesCollection(Index), wobei Index die Indexnummer oder der Name der Datenreihe ist, um ein einzelnes Series-Objekt zurückzugeben. Im folgenden Beispiel wird für die erste Datenreihe im Diagramm die Innenbereichsfarbe Rot festgelegt.

myChart.SeriesCollection(1).Interior.Color = RGB(255, 0, 0)


SeriesLines-Objekt

Stellt die Verbindungslinien der angegebenen Diagrammgruppe dar. Verbindungslinien verbinden die Datenwerte jeder Datenreihe. Nur 2D-Diagramme mit gestaffelten Balken oder 2D-Säulendiagrammgruppen können Verbindungslinien besitzen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Verbindungslinie darstellt; Verbindungslinien sind für alle Punkte einer Diagrammgruppe entweder ein- oder ausgeschaltet.

Verwenden des SeriesLines-Objekts

Verwenden Sie die SeriesLines-Eigenschaft, um das SeriesLines-Objekt zurückzugeben. Im folgenden Beispiel werden der ersten Diagrammgruppe des Diagramms Verbindungslinien hinzugefügt. Bei dem Diagramm muss es sich um ein 2D-Diagramm mit gestaffelten Balken oder um ein 2D-Säulendiagramm handeln.

With myChart.ChartGroups(1)
    .HasSeriesLines = True
    .SeriesLines.Border.Color = RGB(0, 0, 255)
End With

Anmerkungen

Besitzt die HasSeriesLines-Eigenschaft den Wert False, sind die meisten Eigenschaften des SeriesLines-Objekts deaktiviert.


TickLabels-Objekt

Stellt die Teilstrichbeschriftungen dar, die den Teilstrichen der angegebenen Diagrammachsen zugeordnet sind.

Der Text für die Teilstrichbeschriftung der Rubrikenachse stammt von dem Namen der dazugehörigen Rubrik im Diagramm. Der Standardtext für die Teilstrichbeschriftung der Rubrikenachse ist die Zahl, die die Position der Rubrik relativ zum linken Ende der Achse angibt. Um die Anzahl der unbeschrifteten Teilstriche zwischen Teilstrichbeschriftungen zu ändern, müssen Sie die TickLabelSpacing-Eigenschaft der Rubrikenachse ändern.

Der Text für die Teilstrichbeschriftung der Größenachse wird auf Grundlage der MajorUnit-, MinimumScale- und MaximumScale-Eigenschaften der Größenachse berechnet. Um den Text für die Teilstrichbeschriftung der Größenachse zu ändern, müssen Sie die Werte dieser Eigenschaften ändern.

Verwenden des TickLabels-Objekts

Verwenden Sie die TickLabels-Eigenschaft, um das TickLabels-Objekt zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die Teilstrichbeschriftungen der Größenachse im Diagramm geändert.

myChart.Axes(xlValue).TickLabels.NumberFormat = "0.00"


Trendline-Objekt

Stellt eine Trendlinie des angegebenen Diagramms dar. Eine Trendlinie zeigt den Trend oder die Richtung von Daten in einer Datenreihe an. Das Trendline-Objekt ist ein Element der Trendlines-Auflistung, die alle Trendline-Objekte einer einzelnen Datenreihe enthält.

Verwenden des Trendline-Objekts

Verwenden Sie Trendlines(Index), wobei Index die Indexnummer der Trendlinie ist, um ein einzelnes Trendline-Objekt zurückzugeben. Im folgenden Beispiel wird die Art der Trendlinie der ersten Datenreihe im Diagramm geändert. Besitzt die Datenreihe keine Trendlinie, schlägt dieses Beispiel fehl.

myChart.SeriesCollection(1).Trendlines(1).Type = xlMovingAvg

Die Indexnummer legt die Reihenfolge fest, in der Trendlinien der Datenreihe hinzugefügt werden. Trendlines(1) wird als erste und Trendlines(Trendlines.Count) als letzte Trendlinie eingefügt.


Trendlines-Auflistungsobjekt

Eine Auflistung aller Trendline-Objekte der angegebenen Datenreihe. Jedes Trendline-Objekt stellt eine Trendlinie eines Diagramms dar. Eine Trendlinie gibt den Trend oder die Richtung von Daten einer Datenreihe an.

Verwenden der Trendlines-Auflistung

Verwenden Sie die Trendlines-Methode, um die Trendlines-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Trendlinien der ersten Datenreihe im Diagramm angezeigt.

MsgBox myChart.SeriesCollection(1).Trendlines.Count

Verwenden Sie die Add-Methode, um eine neue Trendlinie zu erstellen und sie einem Diagramm hinzuzufügen. Im folgenden Beispiel wird der ersten Datenreihe im Diagramm eine lineare Trendlinie hinzugefügt.

With myChart.SeriesCollection(1).Trendlines
    .Add Type:=xlLinear, Name:="Linear Trend"
End With

Verwenden Sie Trendlines(Index), wobei Index die Indexnummer der Trendlinie ist, um ein einzelnes TrendLine-Objekt zurückzugeben. Im folgenden Beispiel wird die Art der Trendlinie der ersten Datenreihe im Diagramm geändert. Besitzt die Datenreihe keine Trendlinie, schlägt dieses Beispiel fehl.

myChart.SeriesCollection(1).Trendlines(1).Type = xlMovingAvg

Die Indexnummer gibt die Reihenfolge an, in der die Trendlinien den Datenreihen hinzugefügt werden. Trendlines(1) ist die erste und Trendlines(Trendlines.Count)die letzte Trendlinie, die hinzugefügt wird.


UpBars-Objekt

Stellt die positiven Abweichungsbalken einer Diagrammgruppe dar. Positive Abweichungsbalken verbinden Punkte in der ersten Datenreihe mit höheren Werten in der letzten Datenreihe der Diagrammgruppe (die Linien führen von der ersten Datenreihe nach oben). Nur 2D-Liniengruppen mit mindestens zwei Datenreihen können positive Abweichungsbalken enthalten. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das einen einzelnen positiven Abweichungsbalken darstellt; positive Abweichungsbalken sind für alle Punkte einer Diagrammgruppe entweder aus- oder eingeschaltet.

Verwenden des UpBars-Objekts

Verwenden Sie die UpBars-Eigenschaft, um das UpBars-Objekt zurückzugeben. Im folgenden Beispiel werden die positiven und die negativen Abweichungsbalken der ersten Diagrammgruppe im Diagramm eingeschaltet. Anschließend wird den positiven Abweichungsbalken die Farbe Blau und den negativen die Farbe Rot zugewiesen.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .UpBars.Interior.Color = RGB(0, 0, 255)
    .DownBars.Interior.Color = RGB(255, 0, 0)
End With

Anmerkungen

Besitzt die HasUpDownBars-Eigenschaft den Wert False, sind die meisten Eigenschaften des UpBars-Objekt deaktiviert.


Walls-Objekt

Stellt die Wände des angegebenen 3D-Diagramms dar. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Wand darstellt; alle Wände müssen als eine Einheit zurückgegeben werden.

Verwenden des Walls-Objekts

Verwenden Sie die Walls-Eigenschaft, um das Walls-Objekt zurückzugeben. Im folgenden Beispiel wird das Muster für die Diagrammwände festgelegt. Handelt es sich bei dem Diagramm nicht um ein 3D-Diagramm, schlägt dieses Beispiel fehl.

myChart.Walls.Interior.Pattern = xlGray75


Application-Eigenschaft

Gibt ein Application-Objekt zurück, das die Microsoft Graph-Anwendung darstellt.


Beispiel zur Application-Eigenschaft

In diesem Beispiel wird in der Matrix der AutoKorrektur-Ersetzungen das Wort "Temperature" durch das Wort "Temp." ersetzt.

With myChart.Application.AutoCorrect
    .AddReplacement "Temperature", "Temp."
End With


ApplyPictToEnd-Eigenschaft

True, wenn dem Ende des Datenpunkts oder aller Datenpunkte der Datenreihe ein Bild zugewiesen wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToEnd-Eigenschaft

In diesem Beispiel werden den Enden aller Datenpunkte in der ersten Datenreihe Bilder zugewiesen. Der Datenreihe müssen bereits Bilder zugewiesen sein (durch das Festlegen dieser Eigenschaft ändert sich die Ausrichtung des Bildes).

myChart.SeriesCollection(1).ApplyPictToEnd = True


ApplyPictToFront-Eigenschaft

True, wenn dem Anfang des Datenpunkts oder aller Datenpunkte der Datenreihe ein Bild zugewiesen wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToFront-Eigenschaft

In diesem Beispiel werden dem Anfang aller Datenpunkte in der ersten Datenreihe Bilder zugewiesen. Der Datenreihe müssen bereits Bilder zugewiesen sein (durch das Festlegen dieser Eigenschaft ändert sich die Ausrichtung des Bildes).

myChart.SeriesCollection(1).ApplyPictToFront = True


ApplyPictToSides-Eigenschaft

True, wenn den Seiten des Datenpunkts oder aller Datenpunkte in der Datenreihe ein Bild zugewiesen wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToSides-Eigenschaft

In diesem Beispiel werden den Seiten aller Datenpunkte in der ersten Datenreihe Bilder zugewiesen. Der Datenreihe müssen bereits Bilder zugewiesen sein (durch das Festlegen dieser Eigenschaft ändert sich die Ausrichtung des Bildes).

myChart.SeriesCollection(1).ApplyPictToSides = True


Area3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die angegebene Flächendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Area3DGroup-Eigenschaft

In diesem Beispiel werden die Bezugslinien des 3D-Flächendiagramms eingeschaltet.

myChart.Area3DGroup.HasDropLines = True


AutoCorrect-Eigenschaft

Gibt ein AutoCorrect-Objekt zurück, das die Microsoft Graph-AutoKorrektur-Attribute darstellt. Schreibgeschützt.


Beispiel zur AutoCorrect-Eigenschaft

In diesem Beispiel wird in der Matrix der AutoKorrektur-Ersetzungen das Wort "Temperature" durch das Wort "Temp." ersetzt.

With myChart.Application.AutoCorrect
    .AddReplacement "Temperature", "Temp."
End With


AutoScaleFont-Eigenschaft

True, wenn sich die Schriftgröße des Texts im Objekt bei der Änderung der Objektgröße ändert. Der Standardwert ist True. Variant Schreib-Lesezugriff.


Beispiel zur AutoScaleFont-Eigenschaft

In diesem Beispiel wird ein Titel zum Diagramm hinzugefügt, und es wird festgelegt, dass sich die Schriftgröße des Titels bei Änderung der Diagrammgröße nicht verändert.

With myChart
    .HasTitle = True
    .ChartTitle.Text = "1996 sales"
    .ChartTitle.AutoScaleFont = False
End With


AutoScaling-Eigenschaft

True, wenn Microsoft Graph ein 3D-Diagramm so skaliert, dass seine Größe der des entsprechenden 2D-Diagramms nahekommt. Die RightAngleAxes-Eigenschaft muss True sein. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoScaling-Eigenschaft

In diesem Beispiel wird das Diagramm automatisch skaliert. Wenden Sie das Makro auf ein 3D-Diagramm an.

With myChart
    .RightAngleAxes = True
    .AutoScaling = True
End With


AutoText-Eigenschaft

True, wenn das Objekt automatisch geeigneten Text aufgrund des Kontextes erstellt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoText-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Datenbeschriftungen der ersten Datenreihe automatisch einen passenden Text erzeugen.

myChart.SeriesCollection(1).DataLabels.AutoText = True


AxisBetweenCategories-Eigenschaft

True, wenn die Größenachse die Rubrikenachse zwischen den Rubriken schneidet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur gültig für Rubrikenachsen. Sie gilt nicht für 3D-Diagramme.


Beispiel zur AxisBetweenCategories-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Größenachse die Rubrikenachse zwischen den Rubriken schneidet.

myChart.Axes(xlCategory).AxisBetweenCategories = True


AxisGroup-Eigenschaft

Gibt die Gruppe für die angegebene Achse, Diagrammgruppe oder Datenreihe zurück. Dies kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Long Schreib-Lese-Zugriff für Series; Long Schreibgeschützt für Axis und ChartGroup.

Anmerkungen

Für 3D-Diagramme ist nur die Gruppe xlPrimary gültig.


Beispiel zur AxisGroup-Eigenschaft

In diesem Beispiel wird die Größenachse gelöscht, falls sie sich in der sekundären Gruppe befindet.

With myChart.Axes(xlValue)
    If .AxisGroup = xlSecondary Then .Delete
End With


AxisTitle-Eigenschaft

Gibt ein AxisTitle-Objekt zurück, das die Beschriftung der angegebenen Achse darstellt. Schreibgeschützt.


Beispiel zur AxisTitle-Eigenschaft

In diesem Beispiel wird zur Rubrikenachse in myChart eine Achsenbeschriftung hinzugefügt.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With


BackColor-Eigenschaft

Gibt ein ChartColorFormat-Objekt zurück, das die Füllfarbe des Hintergrunds darstellt.


Beispiel zur BackColor-Eigenschaft

In diesem Beispiel werden Farbverlauf sowie Hinter- und Vordergrundfarbe für die Füllung der Diagrammfläche festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


Background-Eigenschaft

Gibt die Art des Texthintergrunds zurück oder legt sie fest. Dies kann eine der folgenden XlBackground-Konstanten sein: xlBackgroundAutomatic, xlBackgroundOpaque oder xlBackgroundTransparent. Diese Eigenschaft wird nur für Text in Diagrammen verwendet. Long Schreib-Lese-Zugriff.


Beispiel zur Background-Eigenschaft

In diesem Beispiel wird ein Diagrammtitel hinzugefügt. Danach werden die Schriftgröße und die Art des Hintergrunds für den Titel festgelegt.

With myChart
    .HasTitle = True
    .ChartTitle.Text = "1995 Rainfall Totals by Month"
    With .ChartTitle.Font
        .Size = 10
        .Background = xlBackgroundTransparent
    End With
End With


Backward-Eigenschaft

Gibt die Anzahl der Perioden (bzw. Einheiten in einem Punkt (XY)-Diagramm) zurück, um die sich eine Trendlinie rückwärts erstreckt, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Backward-Eigenschaft

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, um die sich die Trendlinie vorwärts und rückwärts erstreckt. Wenden Sie das Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

With myChart.SeriesCollection(1).Trendlines(1)
    .Forward = 5
    .Backward = .5
End With


Bar3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die angegebene Balkendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Bar3DGroup-Eigenschaft

In diesem Beispiel wird festgelegt, dass in der 3D-Balkendiagrammgruppe der Leerraum zwischen Balkengruppen 50 Prozent der Balkenbreite beträgt.

myChart.BarGroup3DGroup.GapWidth = 50


BarShape-Eigenschaft

Gibt die Form zurück, die mit dem angegebenen 3D-Balken- oder Säulendiagramm verwendet wird, oder legt sie fest. Kann eine der folgenden XlBarShape-Konstanten sein: xlBox, xlConeToMax, xlConeToPoint, xlCylinder, xlPyramidToMax oder xlPyramidToPoint. Long Schreib-Lese-Zugriff.


Beispiel zur BarShape-Eigenschaft

In diesem Beispiel wird die Form festgelegt, die mit der ersten Datenreihe im Diagramm verwendet wird.

myChart.SeriesCollection(1).BarShape = xlConeToPoint


BaseUnit-Eigenschaft

Gibt die Basiseinheit für die angegebene Rubrikenachse zurück oder legt sie fest. Es kann sich um eine der folgenden XlTimeUnit-Konstanten handeln: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.

Anmerkungen

Das Festlegen dieser Eigenschaft hat keine sichtbare Wirkung, wenn die Eigenschaft CategoryType für die angegebene Achse auf xlCategoryScale gesetzt wurde. Der festgelegte Wert wird jedoch beibehalten und tritt in Kraft, wenn die Eigenschaft CategoryType auf xlTimeScale gesetzt wird.

Sie können diese Eigenschaft nicht für eine Größenachse festlegen.


BaseUnitIsAuto-Eigenschaft

True, wenn Microsoft Graph die entsprechenden Basiseinheiten für die Rubrikenachse automatisch wählt. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für Größenachsen nicht verfügbar.


Beispiel zur BaseUnitIsAuto-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse des Diagramms eine Zeitskala mit automatischen Basiseinheiten festgelegt.

With myChart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnitIsAuto = True
    End With
End With


Bold-Eigenschaft

True, wenn die Schriftart Fett ist. Variant Schreib-Lese-Zugriff.


Beispiel zur Bold-Eigenschaft

In diesem Beispiel wird der Diagrammtitel mit dem Schriftstil "Bold" (Fett) formatiert.

myChart.ChartTitle.Font.Bold = True


Border-Eigenschaft

Gibt ein Border-Objekt zurück, das den Rahmen des angegebenen Objekts darstellt. Schreibgeschützt.


Beispiel zur Border-Eigenschaft

In diesem Beispiel wird dem Rahmen der Diagrammfläche die Farbe Rot zugewiesen.

myChart.ChartArea.Border.ColorIndex = 3


BubbleScale-Eigenschaft

Gibt den Skalierfaktor für Blasen in der angegebenen Diagrammgruppe zurück oder legt ihn fest. Dies kann eine Ganzzahl zwischen 0 (Null) und 300 sein, die dem Prozentsatz der Standardgröße entspricht. Nur gültig für Blasendiagramme. Long Schreib-Lese-Zugriff.


Beispiel zur BubbleScale-Eigenschaft

In diesem Beispiel wird die Blasengröße der ersten Diagrammgruppe auf 200 Prozent der Standardgröße festgelegt.

With myChart
    .ChartGroups(1).BubbleScale = 200
End With


CapitalizeNamesOfDays-Eigenschaft

True, wenn der Anfangsbuchstabe der Wochentagsnamen automatisch großgeschrieben wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur CapitalizeNamesOfDays-Eigenschaft

In diesem Beispiel wird Microsoft Graph so eingestellt, dass der Anfangsbuchstabe der Wochentagsnamen großgeschrieben wird.

With myChart.Application.AutoCorrect
    .CapitalizeNamesOfDays = True
    .ReplaceText = True
End With


Caption-Eigenschaft

Gibt Text mit einer von mehreren verschiedenen Bedeutungen zurück, die von dem Objekttyp abhängen, auf den die Caption-Eigenschaft angewendet wird. String Schreib-Lesezugriff.

Objekttyp | Bedeutung
AxisTitle | Die Achsenbeschriftung
ChartTitle | Der Diagrammtitel
DataLabel | Die Datenbeschriftung


Beispiel zur Caption-Eigenschaft

In diesem Beispiel wird der Titel "Jahresumsätze" zum Diagramm hinzugefügt.

myChart.HasTitle = True
myChart.ChartTitle.Caption = "Annual Salary Figures"


CategoryType-Eigenschaft

Gibt den Typ der Rubrikenachse zurück oder legt ihn fest. Dies kann eine der folgenden XlCategoryType-Konstanten sein: xlCategoryScale, xlTimeScale oder xlAutomaticScale. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für Größenachsen nicht verfügbar.


Beispiel zur CategoryType-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse des Diagramms eine Zeitskala mit Monaten als Basiseinheit festgelegt.

With myChart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnit = xlMonths
    End With
End With


CellDragAndDrop-Eigenschaft

True, wenn die Drag & Drop-Bearbeitung von Zellen aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur CellDragAndDrop-Eigenschaft

In diesem Beispiel wird die Drag & Drop-Bearbeitung von Zellen aktiviert.

myChart.Application.CellDragAndDrop = True


Cells-Eigenschaft

Range-Objekt: Gibt ein Range-Objekt zurück, das die Zellen des angegebenen Bereichs darstellt. Schreibgeschützt.

DataSheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zellen des Datenblattes (nicht nur die aktuell verwendeten) darstellt. Schreibgeschützt.


Beispiel zur Cells-Eigenschaft

In diesem Beispiel wird im Datenblatt die Formel in der Zelle A1 gelöscht. Beachten Sie, dass es sich im Datenblatt bei der Spalte A um die zweite Spalte und bei der Zeile 1 um die zweite Zeile handelt.

myChart.Application.DataSheet.Cells(2,2).ClearContents

In diesem Beispiel werden im Datenblatt die Zellen A1:A13 in einer Schleife bearbeitet. Besitzen dabei Zellen einen Wert, der kleiner ist als 0,001, wird er durch 0 (Null) ersetzt.

Set mySheet = myChart.Application.DataSheet
For rwIndex = 2 to 4
    For colIndex = 2 to 10
        If mySheet.Cells(rwIndex, colIndex) < .001 Then
            mySheet.Cells(rwIndex, colIndex).Value = 0
        End If
    Next colIndex
Next rwIndex


ChartArea-Eigenschaft

Gibt ein ChartArea-Objekt zurück, das die komplette Diagrammfläche des Diagramms darstellt. Schreibgeschützt.


Beispiel zur ChartArea-Eigenschaft

In diesem Beispiel wird dem Innenraum von myChart die Farbe Rot und dem Rahmen die Farbe Blau zugewiesen.

With myChart.ChartArea
    .Interior.ColorIndex = 3
    .Border.ColorIndex = 5
End With


ChartTitle-Eigenschaft

Gibt ein ChartTitle-Objekt zurück, das den Titel des angegebenen Diagramms darstellt. Schreibgeschützt.


Beispiel zur ChartTitle-Eigenschaft

In diesem Beispiel wird der Text für den Diagrammtitel festgelegt.

With myChart
    .HasTitle = True
    .ChartTitle.Text = "First Quarter Sales"
End With


ChartType-Eigenschaft

Gibt den Diagrammtyp zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlChartType-Konstanten sein:

Diagrammtyp | Beschreibung | Konstante
Säulen | Säulen (gruppiert) | xlColumnClustered
 | Säulen (3D, gruppiert) | xl3DColumnClustered
 | Gestapelte Säulen. Vergleicht die Beiträge einzelner Werte mit dem Gesamtwert aller Kategorien. | xlColumnStacked
 | Gestapelte 3D-Säulen | xl3DColumnStacked
 | Säulen (100%, gestapelt) | xlColumnStacked100
 | Säulen (3D, 100%, gestapelt) | xl3DColumnStacked100
 | 3D-Säulen | xl3DColumn
Balken | Balken (gruppiert) | xlBarClustered
 | Balken (3D, gruppiert) | xl3DBarClustered
 | Balken (gestapelt) | xlBarStacked
 | Balken (3D, gestapelt) | xl3DBarStacked
 | Balken (100%, gestapelt) | xlBarStacked100
 | Balken (3D, 100%, gestapelt) | xl3DBarStacked100
Linien | Linien | xlLine
 | Linien mit Markierungen | xlLineMarkers
 | Linien (gestapelt) | xlLineStacked
 | Linien (gestapelt, mit Datenpunkten) | xlLineMarkersStacked
 | Linien (100%, gestapelt) | xlLineStacked100
 | Linien (100%, gestapelt, mit Datenpunkten) | xlLineMarkersStacked100
 | 3D-Linien | xl3DLine
Kreise | Kreis | xlPie
 | Kreis (explodiert) | xlPieExploded
 | 3D-Kreis | xl3DPie
 | Kreis (3D, explodiert) | xl3DPieExploded
 | Kreis-aus-Kreis | xlPieOfPie
 | Balken-aus-Kreis | xlBarOfPie
XY (Punkt) | Punkte | xlXYScatter
 | Punkte mit interpolierten Linien | xlXYScatterSmooth
 | Punkte mit interpolierten Linien ohne Datenpunkte | xlXYScatterSmoothNoMarkers
 | Punkte mit Linien | xlXYScatterLines
 | Punkte mit Linien ohne Datenpunkte | xlXYScatterLinesNoMarkers
Blasen | Blasen | xlBubble
 | Blasen mit 3D-Effekt | xlBubble3DEffect
Fläche | Flächen | xlArea
 | 3D-Fläche | xl3DArea
 | Flächen (gestapelt) | xlAreaStacked
 | Gestapelte 3D-Fläche | xl3DAreaStacked
 | Flächen (100%, gestapelt) | xlAreaStacked100
 | Gestapelte 3D-Fläche (100%) | xl3DAreaStacked100
Ring | Ring | xlDoughnut
 | Ring (explodiert) | xlDoughnutExploded
Netz | Netz | xlRadar
 | Netz mit Datenpunkten | xlRadarMarkers
 | Netz (gefüllt) | xlRadarFilled
Oberfläche | 3D-Oberfläche | xlSurface
 | Oberfläche (Draufsicht) | xlSurfaceTopView
 | Oberfläche (3D, Drahtmodell) | xlSurfaceWireframe
 | Oberfläche (Draufsicht, Drahtmodell) | xlSurfaceTopViewWireframe
Börsenkurse | Hoch-Tief-Schluss | xlStockHLC
 | Menge-Hoch-Tief-Schluss | xlStockVHLC
 | Öffnungs-Hoch-Tief-Schluss | xlStockOHLC
 | Menge-Öffnungs-Hoch-Tief-Schluss | xlStockVOHLC
Zylinder | Zylindersäulen (gruppiert) | xlCylinderColClustered
 | Zylinderbalken (gruppiert) | xlCylinderBarClustered
 | Zylindersäulen (gestapelt) | xlCylinderColStacked
 | Zylinderbalken (gestapelt) | xlCylinderBarStacked
 | Zylindersäulen (100%, gestapelt) | xlCylinderColStacked100
 | Zylinderbalken (100%, gestapelt) | xlCylinderBarStacked100
 | Zylindersäulen (3D) | xlCylinderCol
Kegel | Kegelsäulen (gruppiert) | xlConeColClustered
 | Kegelbalken (gruppiert) | xlConeBarClustered
 | Kegelsäulen (gestapelt) | xlConeColStacked
 | Kegelbalken (gestapelt) | xlConeBarStacked
 | Kegelsäulen (100%, gestapelt) | xlConeColStacked100
 | Kegelbalken (100%, gestapelt) | xlConeBarStacked100
 | Kegelsäulen (3D) | xlConeCol
Pyramide | Pyramidensäulen (gruppiert) | xlPyramidColClustered
 | Pyramidenbalken (gruppiert) | xlPyramidBarClustered
 | Pyramidensäulen (gestapelt) | xlPyramidColStacked
 | Pyramidenbalken (gestapelt) | xlPyramidBarStacked
 | Pyramidensäulen (100%, gestapelt) | xlPyramidColStacked100
 | Pyramidenbalken (100%, gestapelt) | xlPyramidBarStacked100
 | Pyramidensäulen (3D) | xlPyramidCol


Beispiel zur ChartType-Eigenschaft

In diesem Beispiel wird die Blasengröße in der ersten Diagrammgruppe auf 200 Prozent der Standardgröße festgelegt, wenn es sich hierbei um ein 2D-Blasendiagramm handelt.

With myChart
    If .ChartType = xlBubble Then
        .ChartGroups(1).BubbleScale = 200
    End If
End With


Color-Eigenschaft

Gibt die Primärfarbe des Objekts zurück oder legt sie fest, wie in der folgenden Tabelle aufgeführt. Erstellen Sie Farbwerte mit der RGB-Funktion. Long Schreib-Lese-Zugriff.

Objekt | Farbe
Border | Die Farbe des Rahmens
Font | Die Schriftfarbe
Interior | Die Farbe der Zellschattierung oder Füllfarbe des Zeichnungsobjekts


ColorIndex-Eigenschaft

Gibt die Farbe des Rahmens oder des Innenbereichs zurück oder legt diese fest, wie in der folgenden Tabelle gezeigt. Die Farbe wird als Index in der aktuellen Farbpalette oder als eine der folgenden XlColorIndex-Konstanten angegeben: xlColorIndexAutomatic oder xlColorIndexNone. Variant Lese-Schreib-Zugriff.

Objekt | Beschreibung
Rahmen | Farbe des Rahmens.
Innenbereich | Die Farbe der Füllung des Innenbereichs. Setzen Sie ColorIndex auf xlColorIndexNone, wenn Sie angeben möchten, dass keine Füllung des Innenbereichs erfolgen soll. Setzen Sie ColorIndex auf xlColorIndexAutomatic, um anzugeben, dass das Ausfüllen (von Zeichnungsobjekten) automatisch vorgenommen werden soll.

Anmerkungen

Mit dieser Eigenschaft wird eine Farbe als Index in der Farbpalette angegeben. Die folgende Abbildung zeigt die ColorIndexwerte der Standard-Farbpalette.

ColorIndexwerte in der Standard-Farbpalette


Beispiel zur ColorIndex-Eigenschaft

Im folgenden Beispiel wird vorausgesetzt, dass Sie die Standard-Farbpalette verwenden.

In diesem Beispiel wird die Farbe der Hauptgitternetzlinien der Größenachse festgelegt.

With myChart.Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 5    'set color to blue
    End If
End With

In diesem Beispiel wird dem Innenraum der Diagrammfläche die Farbe Rot und dem Rahmen die Farbe Blau zugewiesen.

With myChart.ChartArea
    .Interior.ColorIndex = 3
    .Border.ColorIndex = 5
End With


Column3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die angegebene Säulendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Column3DGroup-Eigenschaft

In diesem Beispiel wird festgelegt, dass in der 3D-Säulendiagrammgruppe der Leerraum zwischen Säulengruppen 50 Prozent der Säulenbreite beträgt.

myChart.Column3DGroup.GapWidth = 50


Columns-Eigenschaft

Range-Objekt: Gibt ein Range-Objekt zurück, das die Spalten im angegebenen Bereich darstellt. Schreibgeschützt.

DataSheet-Objekt: Gibt ein Range-Objekt zurück, das alle Spalten in der Tabelle darstellt. Schreibgeschützt.

Weitere Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Columns-Eigenschaft

In diesem Beispiel wird Spalte A der Tabelle gelöscht.

myChart.Application.DataSheet.Columns(2).ClearContents


ColumnWidth-Eigenschaft

Gibt die Breite aller Spalten im angegebenen Bereich zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.

Anmerkungen

Eine Einheit der Spaltenbreite entspricht der Breite eines Zeichens in der Formatvorlage Standard. Bei Proportionalschriften wird die Breite des Zeichens 0 (Null) verwendet.

Wenn alle Spalten in dem Bereich dieselbe Breite haben, gibt die ColumnWidth-Eigenschaft diese Breite zurück. Sind die Spalten unterschiedlich breit, gibt diese Eigenschaft Null zurück.


Beispiel zur ColumnWidth-Eigenschaft

In diesem Beispiel wird die Breite der Spalte A in der Tabelle verdoppelt.

With myChart.Application.DataSheet.Columns("A")
    .ColumnWidth = .ColumnWidth * 2
End With


CommandBars-Eigenschaft

Gibt ein CommandBars-Objekt zurück, das die Befehlsleiste von Microsoft Graph darstellt. Schreibgeschützt.


Beispiel zur CommandBars-Eigenschaft

In diesem Beispiel werden alle benutzerdefinierten Befehlsleisten gelöscht, die nicht sichtbar sind.

For Each bar In myChart.Application.CommandBars
    If Not bar.BuiltIn And Not bar.Visible Then bar.Delete
Next


Corners-Eigenschaft

Gibt ein Corners-Objekt zurück, das die Ecken des angegebenen 3D-Diagramms darstellt. Schreibgeschützt.


CorrectCapsLock-Eigenschaft

True, wenn Microsoft Graph den versehentlichen Gebrauch der FESTSTELLTASTE automatisch korrigiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectCapsLock-Eigenschaft

In diesem Beispiel wird die unbeabsichtigte Verwendung der FESTSTELLTASTE von Microsoft Graph automatisch korrigiert.

myChart.Application.AutoCorrect.CorrectCapsLock = True


CorrectSentenceCap-Eigenschaft

True, wenn Microsoft Graph das erste Wort eines Satzes automatisch mit einem Großbuchstaben schreibt. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectSentenceCap-Eigenschaft

In diesem Beispiel wird die automatische Großschreibung des Satzanfangs durch Microsoft Graph aktiviert.

myChart.Application.AutoCorrect.CorrectSentenceCap = True


Count-Eigenschaft

Gibt die Anzahl der Objekte in der angegebenen Auflistung zurück. Long Schreibgeschützt.


Beispiel zur Count-Eigenschaft

In diesem Beispiel wird die Anzahl der Diagrammgruppen im Diagramm angezeigt.

MsgBox "The chart contains " & _
    myChart.ChartGroups.Count & _
    " chart groups."


Creator-Eigenschaft

Gibt die Anwendung, in der das angegebene Objekt erstellt wurde, als 32-Bit-Ganzzahl zurück. Wenn das Objekt in Microsoft Graph erstellt wurde, gibt diese Eigenschaft die Zeichenfolge MSGR zurück, die der hexadezimalen Zahl 4D534752 entspricht. Long Schreibgeschützt.


Beispiel zur Creator-Eigenschaft

In diesem Beispiel wird eine Meldung über den Urheber von myChart angezeigt.

If myChart.Creator = &h4D534752 Then
    MsgBox "This is a Microsoft Graph object"
Else
    MsgBox "This is not a Microsoft Graph object"
End If


Crosses-Eigenschaft

Gibt auf der angegebenen Achse den Schnittpunkt mit der anderen Achse zurück oder legt ihn fest. Long Schreib-Lesezugriff.

Dies kann eine der XlAxisCrosses-Konstanten sein, die in der folgenden Tabelle aufgelistet sind:

Konstante | Bedeutung
xlAxisCrossesAutomatic | Microsoft Graph legt den Achsenschnittpunkt fest.
xlMinimum | Die Achse schneidet die angegebene Achse im Minimalwert.
xlMaximum | Die Achse schneidet die angegebene Achse im Maximalwert.
xlAxisCrossesCustom | Die CrossesAt-Eigenschaft gibt den Schnittpunkt an.

Anmerkungen

Diese Eigenschaft ist für Netzdiagramme nicht verfügbar. Für 3D-Diagramme gibt die Eigenschaft an, wo die von der Rubrikenachse definierte Ebene die Größenachse kreuzt.

Diese Eigenschaft kann sowohl für Rubriken- als auch für Größenachsen verwendet werden. Bei der Rubrikenachse legt xlMinimum den Schnittpunkt mit der Größenachse in der ersten Rubrik fest, und xlMaximum legt den Schnittpunkt mit der Größenachse in der letzten Rubrik fest.

Die Werte xlMinimum und xlMaximum können je nach Achse verschiedene Bedeutungen haben.


CrossesAt-Eigenschaft

Gibt auf der Größenachse den Schnittpunkt mit der Rubrikenachse zurück oder legt ihn fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird der Wert der Crosses-Eigenschaft in xlAxisCrossesCustom geändert.

Diese Eigenschaft ist für 3D- oder Netzdiagramme nicht verfügbar.


Beispiel zur CrossesAt-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Rubrikenachse die Größenachse im Wert 3 schneidet.

With myChart.Axes(xlValue)
    .Crosses = xlAxisCrossesCustom
    .CrossesAt = 3
End With


DataLabel-Eigenschaft

Gibt ein DataLabel-Objekt zurück, das die mit dem angegebenen Datenpunkt oder der Trendlinie verbundene Datenbeschriftung darstellt. Schreibgeschützt.


Beispiel zur DataLabel-Eigenschaft

In diesem Beispiel wird die Datenbeschriftung für Datenpunkt 7 der dritten Datenreihe aktiviert. Danach wird der Datenbeschriftung die Farbe Blau zugewiesen.

With myChart.SeriesCollection(3).Points(7)
    .HasDataLabel = True
    .ApplyDataLabels type:=xlValue
    .DataLabel.Font.ColorIndex = 5
End With


DataSheet-Eigenschaft

Gibt das DataSheet-Objekt zurück. Schreibgeschützt.


Beispiel zur DataSheet-Eigenschaft

In diesem Beispiel wird der Zelle A1 des Datenblattes der Wert 3,14159 zugewiesen.

With myChart.Application
    .DataSheet.Range("A1").Value = 3.14159
End With


DataTable-Eigenschaft

Gibt ein DataTable-Objekt zurück, das die Diagrammdatentabelle darstellt. Schreibgeschützt.


Beispiel zur DataTable-Eigenschaft

In diesem Beispiel wird eine Datentabelle mit einem äußeren Rahmen zum Diagramm hinzugefügt.

With myChart
    .HasDataTable = True
    .DataTable.HasBorderOutline = True
End With


DepthPercent-Eigenschaft

Gibt die Tiefe eines 3D-Diagramms als Prozentsatz der Diagrammbreite (zwischen 20 und 2000 Prozent) zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur DepthPercent-Eigenschaft

In diesem Beispiel wird die Tiefe des Diagramms auf 50 Prozent seiner Breite festgelegt. Wenden Sie das Makro auf ein 3D-Diagramm an (die DepthPercent-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird).

myChart.DepthPercent = 50


DisplayAlerts-Eigenschaft

True, falls Microsoft Graph bestimmte Warnungen und Meldungen anzeigt, während ein Makro ausgeführt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Der Standardwert ist True. Legen Sie für diese Eigenschaft den Wert False fest, wenn Sie während der Ausführung eines Makros nicht durch Eingabeaufforderungen und Meldungen gestört werden möchten; erfordert eine Meldung eine Antwort, verwendet Microsoft Graph die Standardantwort.

Wenn Sie für diese Eigenschaft den Wert False festlegen, wird er von Microsoft Graph nicht automatisch auf den Wert True zurückgesetzt, wenn das Makro beendet ist. Schreiben Sie Ihr Makro so, dass es diese Eigenschaft immer auf den Wert True zurücksetzt, wenn es beendet ist.


DisplayBlanksAs-Eigenschaft

Gibt zurück oder legt fest, wie leere Zellen in einem Diagramm dargestellt werden. Dies kann eine der folgenden XlDisplayBlanksAs-Konstanten sein: xlNotPlotted, xlInterpolated oder xlZero. Long Schreib-Lese-Zugriff.


Beispiel zur DisplayBlanksAs-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Graph leere Zellen nicht darstellt.

myChart.DisplayBlanksAs = xlNotPlotted


DisplayEquation-Eigenschaft

True, wenn die Gleichung der Trendlinie im Diagramm angezeigt wird (in derselben Datenbeschriftung wie das Bestimmtheitsmaß). Wird diese Eigenschaft auf True gesetzt, werden die Datenbeschriftungen automatisch angezeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayEquation-Eigenschaft

In diesem Beispiel werden das Bestimmtheitsmaß und die Gleichung der ersten Trendlinie angezeigt. Wenden Sie das Makro auf ein 2D-Säulendiagramm mit einer Trendlinie für die erste Datenreihe an.

With myChart.SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = True
    .DisplayEquation = True
End With


DisplayRSquared-Eigenschaft

True, wenn das Bestimmtheitsmaß der Trendlinie im Diagramm angezeigt wird (in derselben Datenbeschriftung wie die Gleichung). Wird diese Eigenschaft auf True gesetzt, werden Datenbeschriftungen automatisch angezeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayRSquared-Eigenschaft

In diesem Beispiel werden das Bestimmtheitsmaß und die Gleichung der ersten Trendlinie angezeigt. Wenden Sie das Makro auf ein 2D-Säulendiagramm mit einer Trendlinie für die erste Datenreihe an.

With myChart.SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = True
    .DisplayEquation = True
End With


DisplayUnit-Eigenschaft

Gibt die Einheiten zurück oder legt die Einheiten fest, die für die Größenachse in dem angegebenen Diagramm angezeigt werden. Als Werte sind folgende XlDisplayUnit- oder Constants-Konstanten möglich: xlNone, xlHundreds, xlThousands, xlTenThousands, xlHundredThousands, xlMillions, xlTenMillions, xlHundredMillions, xlThousandMillions, xlMillionMillions oder xlCustom. Wenn der Wert xlCustom lautet, dann gibt die DisplayUnitCustom-Eigenschaft den Wert der für die Größenachse angezeigten Einheiten zurück oder legt ihn fest. XlDisplayUnit Lese-/Schreibzugriff.

Anmerkungen

Das Verwenden von Beschriftungen für Einheiten auf der Größenachse beim Darstellen großer Werte erleichtert das Lesen der inkrementellen Beschriftungen. Daten können so leichter verfolgt werden. Wenn Sie also die Größenachse zum Beispiel in Tausernder-Schritten beschriften, können Sie an den Teilstrichen auf der Achse kleinere numerische Werte verwenden.


DisplayUnitCustom-Eigenschaft

Wenn der Wert, der von der DisplayUnit-Eigenschaft zurückgegeben wird, xlCustom lautet, dann wird von der DisplayUnitCustom-Eigenschaft der Wert für die Einheiten festgelegt oder zurückgegeben, die auf der Größenachse des angegebenen Diagramms angezeigt werden. Der Wert muss eine Zahl von 0 bis 10E307 sein. Double Lese-/Schreibzugriff.

Anmerkungen

Das Verwenden von Beschriftungen für Einheiten auf der Größenachse beim Darstellen großer Werte erleichtert das Lesen der inkrementellen Beschriftungen. Daten können so leichter verfolgt werden. Wenn Sie also die Größenachse zum Beispiel in Tausender-Schritten beschriften, können Sie an den Teilstrichen der Achse kleinere numerische Werte verwenden.


Beispiel zur DisplayUnitCustom-Eigenschaft

Im folgenden Beispiel wird für die auf der Größenachse des Diagramms myChart angezeigten Einheiten eine Schrittweite von 500 festgelegt.

With myChart.Axes(xlValue)
    .DisplayUnit = xlCustom
    .DisplayUnitCustom = 500
    .HasTitle = True
    .AxisTitle.Caption = "Rebate Amounts"
End With


DisplayUnitLabel-Eigenschaft

Gibt das DisplayUnitLabel-Objekt für die Größenachse des angegebenen Diagramms zurück. Gibt Null zurück, wenn für die HasDisplayUnitLabel-Eigenschaft False festgelegt ist. Schreibgeschützt.


Beispiel zur DisplayUnitLabel-Eigenschaft

Im folgenden Beispiel wird für die Größenachse in myChart als Beschriftung "Million" festgelegt, und die automatische Skalierung der Schrift wird deaktiviert.

With myChart.Axes(xlValue).DisplayUnitLabel
    .Caption = "Millions"
    .AutoScaleFont = False
End With


DoughnutHoleSize-Eigenschaft

Gibt die Innenringgröße einer Ringdiagrammgruppe zurück oder legt sie fest. Die Innenringgröße wird als Prozentsatz der Diagrammgröße angegeben und kann im Bereich von 10 bis 90 Prozent liegen. Long Schreib-Lese-Zugriff.


Beispiel zur DoughnutHoleSize-Eigenschaft

In diesem Beispiel wird die Innenringgröße für die erste Ringdiagrammgruppe festgelegt. Wenden Sie das Makro auf ein 2D-Ringdiagramm an.

myChart.DoughnutGroups(1).DoughnutHoleSize = 10


DownBars-Eigenschaft

Gibt ein DownBars-Objekt zurück, das die negativen Abweichungsbalken eines Liniendiagramms darstellt. Schreibgeschützt.


Beispiel zur DownBars-Eigenschaft

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe eingeblendet. Danach werden den Balken Farben zugewiesen. Es ist sinnvoll, dieses Makro auf ein 2D-Liniendiagramm mit zwei Datenreihen anzuwenden, die sich in wenigstens einem Datenpunkt schneiden.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


DropLines-Eigenschaft

Gibt ein DropLines-Objekt zurück, das die Bezugslinien für eine Datenreihe eines Linien- oder Flächendiagramms darstellt. Nur gültig für Linien- oder Flächendiagramme. Schreibgeschützt.


Beispiel zur DropLines-Eigenschaft

In diesem Beispiel werden die Bezugslinien der ersten Diagrammgruppe angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit einer Datenreihe an.

With myChart.ChartGroups(1)
    .HasDropLines = True
    With .DropLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


Elevation-Eigenschaft

Gibt die Betrachtungshöhe für 3D-Diagramme in Grad zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Betrachtungshöhe eines Diagramms ist die Perspektive oder der Winkel in Grad, aus dem Sie das Diagramm sehen. Der Standardwert für die meisten Diagrammtypen beträgt 15 Grad. Der Wert dieser Eigenschaft muss zwischen -90 und 90 liegen. Für 3D-Balkendiagramme muss der Wert zwischen 0 und 44 liegen.


Beispiel zur Elevation-Eigenschaft

In diesem Beispiel wird die Betrachtungshöhe des Diagramms auf 34 Grad festgelegt. Wenden Sie das Makro auf ein 3D-Diagramm an (die Elevation-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird.)

myChart.Elevation = 34


EndStyle-Eigenschaft

Gibt zurück, oder legt fest, wie die Enden der Fehlerindikatoren dargestellt werden. Dies kann eine der folgenden XlEndStyleCap-Konstanten sein: xlCap oder xlNoCap. Long Schreib-Lese-Zugriff.


Beispiel zur EndStyle-Eigenschaft

In diesem Beispiel wird der Typ der Enden der Fehlerindikatoren für die erste Datenreihe festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm an, das Fehlerindikatoren für die Y-Achse der ersten Datenreihe enthält.

myChart.SeriesCollection(1).ErrorBars.EndStyle = xlCap


ErrorBars-Eigenschaft

Gibt ein ErrorBars-Objekt zurück, das die Fehlerindikatoren der Datenreihe darstellt. Schreibgeschützt.


Beispiel zur ErrorBars-Eigenschaft

In diesem Beispiel wird die Farbe des Fehlerindikators für die erste Datenreihe festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit Fehlerindikatoren für die erste Datenreihe an.

With myChart.SeriesCollection(1)
    .ErrorBars.Border.ColorIndex = 8
End With


Explosion-Eigenschaft

Gibt den Explosionswert für Kreisdiagramm- oder Ringdiagramm-Segmente zurück oder legt ihn fest. Gibt 0 (Null) zurück, wenn keine Explosion vorhanden ist (die Spitze des Segments befindet sich in der Mitte des Kreises). Long Schreib-Lese-Zugriff.


Beispiel zur Explosion-Eigenschaft

In diesem Beispiel wird der Explosionswert für den zweiten Datenpunkt festgelegt. Wenden Sie das Makro auf ein Kreisdiagramm an.

myChart.SeriesCollection(1).Points(2).Explosion = 20


Fill-Eigenschaft

Gibt ein ChartFillFormat-Objekt zurück, das Füllungsformateigenschaften des angegebenen Diagramms enthält. Schreibgeschützt.


Beispiel zur Fill-Eigenschaft

In diesem Beispiel wird dem Füllungsformat des Diagramms die vordefinierte Messingfarbe zugewiesen.

With myChart.ChartArea.Fill
    .Visible = True
    .PresetGradient msoGradientDiagonalDown, 3, msoGradientBrass
End With


FirstSliceAngle-Eigenschaft

Gibt den Winkel des ersten Kreisdiagramm- oder Ringdiagramm-Segments in Grad zurück oder legt ihn fest. Der Gradwert wird im Uhrzeigersinn von der Senkrechten aus angegeben. Nur gültig für Kreis-, 3D-Kreis- und Ringdiagramme. Long Schreib-Lese-Zugriff.


Beispiel zur FirstSliceAngle-Eigenschaft

In diesem Beispiel wird der Winkel für das erste Segment der ersten Diagrammgruppe angegeben. Wenden Sie das Makro auf ein 2D-Kreisdiagramm an.

myChart.ChartGroups(1).FirstSliceAngle = 15


Floor-Eigenschaft

Gibt ein Floor-Objekt zurück, das die Bodenfläche eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Floor-Eigenschaft

In diesem Beispiel wird der Bodenfläche die Farbe Blau zugewiesen. Wenden Sie das Makro auf ein 3D-Diagramm an (die Floor-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird).

myChart.Floor.Interior.ColorIndex = 5


Font-Eigenschaft

Gibt ein Font-Objekt zurück, das die Schriftart des angegebenen Objekts darstellt. Schreibgeschützt.


FontStyle-Eigenschaft

Gibt den Schriftstil zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie diese Eigenschaft ändern, können auch andere Font-Eigenschaften (wie Bold und Italic) betroffen sein.


Beispiel zur FontStyle-Eigenschaft

In diesem Beispiel wird der Diagrammtitel mit dem Schriftstil "Bold Italic" (Fett und Kursiv) formatiert.

myChart.ChartTitle.Font.FontStyle = "Bold Italic"


ForeColor-Eigenschaft

Gibt ein ChartColorFormat-Objekt zurück, das die Vordergrundfarbe der Ausfüllung darstellt.


Beispiel zur ForeColor-Eigenschaft

In diesem Beispiel werden Farbverlauf sowie Hinter- und Vordergrundfarbe für die Ausfüllung der Diagrammfläche festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


Forward-Eigenschaft

Gibt die Anzahl der Perioden (oder Einheiten in einem Punktdiagramm) zurück, um die sich die Trendlinie vorwärts erstreckt, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Forward-Eigenschaft

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, um die sich die Trendlinie vorwärts und rückwärts erstreckt. Wenden Sie dieses Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

With myChart.SeriesCollection(1).Trendlines(1)
    .Forward = 5
    .Backward = .5
End With


GapDepth-Eigenschaft

Gibt den Abstand zwischen den Datenreihen in einem 3D-Diagramm als Prozentwert der Markierungsbreite zurück oder legt ihn fest. Der Wert dieser Eigenschaft muss zwischen 0 und 500 liegen. Long Schreib-Lese-Zugriff.


Beispiel zur GapDepth-Eigenschaft

In diesem Beispiel wird der Abstand zwischen der Datenreihe auf 200 Prozent der Markierungsbreite festgelegt. Wenden Sie das Makro auf ein 3D-Diagramm an (die GapDepth-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird).

myChart.GapDepth = 200


GapWidth-Eigenschaft

Balken- und Säulendiagramme: Gibt den Abstand zwischen Balken- oder Säulengruppen als Prozentwert der Balken- oder Säulenbreite zurück oder legt ihn fest. Der Wert dieser Eigenschaft muss zwischen 0 und 500 liegen. Long Schreib-Lese-Zugriff.

Kreis-aus-Kreis- und Balken-aus-Kreis-Diagramme: Gibt den Abstand zwischen dem primären und sekundären Abschnitt des angegebenen Diagramms zurück oder legt ihn fest. Der Wert dieser Eigenschaft muss zwischen 0 und 200 liegen. Long Schreib-Lese-Zugriff.


Beispiel zur GapWidth-Eigenschaft

In diesem Beispiel wird der Abstand zwischen den Säulengruppen auf 50 Prozent der Säulenbreite festgelegt.

myChart.ChartGroups(1).GapWidth = 50


GradientColorType-Eigenschaft

Gibt den Farbtyp des Farbverlaufs in der angegebenen Füllung zurück. Kann eine der folgenden MsoGradientColorType-Konstanten sein: msoGradientColorMixed, msoGradientOneColor, msoGradientPresetColors oder msoGradientTwoColors. Long Schreibgeschützt.


Beispiel zur GradientColorType-Eigenschaft

In diesem Beispiel wird das Füllungsformat des Diagramms festgelegt, wenn die Diagrammfläche eine einfarbige, fließende Füllung besitzt.

With myChart.ChartArea.Fill
    If .Type = msoFillGradient Then
        If .GradientColorType = msoGradientOneColor Then
            .OneColorGradient Style:= msoGradientFromCorner, _
                 Variant:= 1, Degree:= 0.3
        End If
    End If
End With


GradientDegree-Eigenschaft

Gibt den Grad des Farbverlaufs der angegebenen einfarbigen, schattierten Füllung als Gleitkommawert von 0,0 (dunkel) bis 1,0 (hell) zurück. Single Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient-Methode, um den Grad des Farbverlaufs für die Füllung festzulegen.


Beispiel zur GradientDegree-Eigenschaft

In diesem Beispiel wird das Füllungsformat des Diagramms so festgelegt, dass der Grad des Farbverlaufs mindestens 0,3 beträgt.

With myChart.ChartArea.Fill
    If .Type = msoFillGradient Then
       If .GradientColorType = msoGradientOneColor Then
           If .GradientDegree < 0.3 Then
              .OneColorGradient .GradientStyle, _
                  .GradientVariant, 0.3
           End If
        End If
    End If
End With


GradientStyle-Eigenschaft

Gibt die Richtung des Farbverlaufs in der angegebenen Füllung zurück. Kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal, msoGradientMixed oder msoGradientVertical. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient- oder die TwoColorGradient-Methode, um die Richtung des Farbverlaufs in der Füllung festzulegen.


Beispiel zur GradientStyle-Eigenschaft

In diesem Beispiel wird für das Füllungsformat des Diagramms festgelegt, dass die Richtung des Farbverlaufs in msoGradientDiagonalUp geändert wird, falls sie zuvor den Wert msoGradientDiagonalDown besaß.

With myChart.ChartArea.Fill
   If .Type = msoFillGradient Then
      If .GradientColorType = msoGradientOneColor Then
         If .GradientStyle = msoGradientDiagonalDown Then
            .OneColorGradient msoGradientDiagonalUp, _
                .GradientVariant, .GradientDegree
         End If
      End If
   End If
End With


GradientVariant-Eigenschaft

Gibt die Schattierungsvariante der angegebenen Füllung als Ganzzahl von 1 bis 4 zurück. Die Werte dieser Eigenschaft entsprechen den Farbverlaufsvarianten (nummeriert von links oben nach rechts unten), die in der Registerkarte Gradient im Dialogfeld Fülleffekte aufgeführt sind. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient- oder die TwoColorGradient-Methode, um die Farbverlaufsvariante der Füllung festzulegen.


Beispiel zur GradientVariant-Eigenschaft

In diesem Beispiel wird für das Füllungsformat des Diagramms festgelegt, dass es mit der zweiten Schattierungsvariante angezeigt wird, falls es aktuell die erste Schattierungsvariante verwendet.

With myChart.ChartArea.Fill
    If .Type = msoFillGradient Then
        If .GradientColorType = msoGradientOneColor Then
            If .GradientVariant = 1 Then
                .OneColorGradient .GradientStyle, 2, _
                    .GradientDegree
            End If
        End If
    End If
End With


Has3DEffect-Eigenschaft

True, wenn die Datenreihe dreidimensional dargestellt wird. Gilt nur für Blasendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur Has3DEffect-Eigenschaft

In diesem Beispiel wird die erste Datenreihe im Blasendiagramm dreidimensional dargestellt.

With myChart
    .SeriesCollection(1).Has3DEffect = True
End With


Has3DShading-Eigenschaft

True, wenn die Diagrammgruppe eine dreidimensionale Schattierung aufweist. Boolean Schreib-Lese-Zugriff.


Beispiel zur Has3DShading-Eigenschaft

In diesem Beispiel erhält die erste Diagrammgruppe im Diagramm eine dreidimensionale Schattierung.

Charts(1).ChartGroups(1).Has3DShading = True


HasAxis-Eigenschaft

Gibt zurück oder legt fest, welche Achsen sich im Diagramm befinden. Variant Schreib-Lese-Zugriff.

Syntax

Ausdruck.HasAxis(Index1, Index2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index1 Variant optional. Der Achsentyp. Dies kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlValue oder xlSeriesAxis. Datenreihenachsen sind nur für 3D-Diagramme gültig.

Index2 Variant optional. Die Achsengruppe. Dies kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. 3D-Diagramme verfügen nur über eine Achsengruppe.

Anmerkung

Microsoft Graph kann Achsen erstellen oder löschen, wenn Sie den Diagrammtyp oder die AxisGroup-Eigenschaft ändern.


Beispiel zur HasAxis-Eigenschaft

In diesem Beispiel wird die primäre Größenachse aktiviert.

myChart.HasAxis(xlValue, xlPrimary) = True


HasBorderHorizontal-Eigenschaft

True, wenn die Diagrammdatentabelle horizontale Zellrahmen aufweist. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderHorizontal-Eigenschaft

In diesem Beispiel wird die Diagrammdatentabelle mit einem Außenrahmen und ohne Zellrahmen dargestellt.

With myChart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasBorderOutline-Eigenschaft

True, wenn die Diagrammdatentabelle einen Außenrahmen hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderOutline-Eigenschaft

In diesem Beispiel wird die Diagrammdatentabelle mit einem Außenrahmen und ohne Zellrahmen dargestellt.

With myChart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasBorderVertical-Eigenschaft

True, wenn die Diagrammdatentabelle vertikale Zellrahmen aufweist. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderVertical-Eigenschaft

In diesem Beispiel wird die Diagrammdatentabelle mit einem Außenrahmen und ohne Zellrahmen dargestellt.

With myChart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasDataLabel-Eigenschaft

True, wenn der Datenpunkt eine Beschriftung erhält. Boolean Schreib-Lese-Zugriff.


HasDataLabels-Eigenschaft

True, wenn die Datenreihe Datenbeschriftungen hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDataLabels-Eigenschaft

In diesem Beispiel werden die Datenbeschriftungen der dritten Datenreihe aktiviert.

With myChart.SeriesCollection(3)
    .HasDataLabels = True
    .ApplyDataLabels Type:=xlValue
End With


HasDataTable-Eigenschaft

True, wenn das Diagramm eine Datentabelle hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDataTable-Eigenschaft

In diesem Beispiel wird die Diagrammdatentabelle mit einem Außenrahmen und ohne Zellrahmen dargestellt.

With myChart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasDisplayUnitLabel-Eigenschaft

True wenn die von der DisplayUnit- oder DisplayUnitCustom-Eigenschaft angegebene Beschriftung auf der Größenachse angezeigt wird. False wenn keine Einheiten angezeigt werden. Der Standardwert ist True. Boolean Lese-/Schreibzugriff.


Beispiel zur HasDisplayUnitLabel-Eigenschaft

Im folgenden Beispiel wird für die Einheiten auf der Größenachse in myChart eine Schrittgröße von 500 festgelegt, die Einheitenbeschriftung selbst wird jedoch ausgeblendet.

With myChart.Axes(xlValue)
    .DisplayUnit = xlCustom
    .DisplayUnitCustom = 500
    .AxisTitle.Caption = "Rebate Amounts"
    .HasDisplayUnitLabel = False
End With


HasDropLines-Eigenschaft

True, wenn im Linien- oder Flächendiagramm Bezugslinien angezeigt werden. Nur gültig für Linien- und Flächendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDropLines-Eigenschaft

In diesem Beispiel werden die Bezugslinien der ersten Diagrammgruppe angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit einer Datenreihe an.

With myChart.ChartGroups(1)
    .HasDropLines = True
    With .DropLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasErrorBars-Eigenschaft

True, wenn die Datenreihe Fehlerindikatoren enthält. Diese Eigenschaft ist für 3D-Diagramme nicht verfügbar. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasErrorBars-Eigenschaft

In diesem Beispiel werden die Fehlerindikatoren der ersten Datenreihe entfernt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit Fehlerindikatoren für die erste Datenreihe an.

myChart.SeriesCollection(1).HasErrorBars = False


HasHiLoLines-Eigenschaft

True, wenn das Liniendiagramm Spannweitenlinien enthält. Nur gültig für Liniendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasHiLoLines-Eigenschaft

In diesem Beispiel werden Spannweitenlinien für die erste Diagrammgruppe angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, das Makro auf ein 2D-Liniendiagramm anzuwenden, das drei Datenreihen mit Börsennotizen (Höchstkurs, Tiefstkurs, Schlusskurs) oder Ähnlichem enthält.

With myChart.ChartGroups(1)
    .HasHiLoLines = True
    With .HiLoLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasLeaderLines-Eigenschaft

True, wenn die Datenreihe Führungslinien hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasLeaderLines-Eigenschaft

In diesem Beispiel erhält die erste Datenreihe im Kreisdiagramm Datenbeschriftungen und blaue Führungslinien.

With myChart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


HasLegend-Eigenschaft

True, wenn das Diagramm eine Legende hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasLegend-Eigenschaft

In diesem Beispiel wird die Legende des Diagramms aktiviert. Anschließend wird der Legende die Farbe Blau zugewiesen.

With myChart
    .HasLegend = True
    .Legend.Font.ColorIndex = 5
End With


HasLinks-Eigenschaft

True, falls das angegebene Diagramm Verknüpfungen zu einer externen Datenquelle besitzt. Boolean Schreibgeschützt.


Beispiel zur HasLinks-Eigenschaft

In diesem Beispiel werden die Inhalte der Zellen A1:D4 im Datenblatt gelöscht, falls das Diagramm keine Verknüpfungen besitzt.

With myChart.Application
    If .HasLinks = False Then
        .DataSheet.Range("A1:D4").Clear
    End If
End With


HasMajorGridlines-Eigenschaft

True, wenn die Achse Hauptgitternetzlinien hat. Nur Achsen in der primären Achsengruppe können Gitternetzlinien haben. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasMajorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hauptgitternetzlinien der Größenachse festgelegt.

With myChart.Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 3    'set color to red
    End If
End With


HasMinorGridlines-Eigenschaft

True, wenn die Achse Hilfsgitternetzlinien hat. Nur Achsen in der primären Achsengruppe können Gitternetzlinien haben. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasMinorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hilfsgitternetzlinien der Größenachse festgelegt.

With myChart.Axes(xlValue)
    If .HasMinorGridlines Then
        .MinorGridlines.Border.ColorIndex = 4
        ' Set color to green.
    End If
End With


HasRadarAxisLabels-Eigenschaft

True, wenn ein Netzdiagramm Achsenbeschriftungen hat. Nur gültig für Netzdiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasRadarAxisLabels-Eigenschaft

In diesem Beispiel werden die Netzachsenbeschriftungen für die erste Diagrammgruppe aktiviert und ihre Farbe festgelegt. Wenden Sie das Makro auf ein Netzdiagramm an.

With myChart.ChartGroups(1)
    .HasRadarAxisLabels = True
    .RadarAxisLabels.Font.ColorIndex = 3
End With


HasSeriesLines-Eigenschaft

True, wenn ein gestapeltes Säulen- oder Balkendiagramm Verbindungslinien hat oder wenn ein Kreis-aus-Kreis- bzw. Balken-aus-Kreis-Diagramm zwischen den beiden Abschnitten Verbindungslinien ausweist. Nur gültig für gestapelte Säulen-, Balken-, Kreis-aus-Kreis- oder Balken-aus-Kreis-Diagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasSeriesLines-Eigenschaft

In diesem Beispiel werden die Verbindungslinien für die erste Diagrammgruppe aktiviert. Anschließend werden die Linienart, die Stärke und die Farbe festgelegt. Wenden Sie das Makro auf ein gestapeltes 2D-Säulendiagramm mit mindestens zwei Datenreihen an.

With myChart.ChartGroups(1)
    .HasSeriesLines = True
    With .SeriesLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasTitle-Eigenschaft

True, wenn die Achse eine sichtbare Beschriftung oder das Diagramm einen sichtbaren Titel aufweist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Eine Achsenbeschriftung wird durch ein AxisTitle-Objekt dargestellt.

Ein Diagrammtitel wird durch ein ChartTitle-Objekt dargestellt.


Beispiel zur HasTitle-Eigenschaft

In diesem Beispiel erhält die Rubrikenachse eine Achsenbeschriftung.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With


HasUpDownBars-Eigenschaft

True, wenn das angegebene Liniendiagramm positive und negative Abweichungsbalken aufweist. Nur gültig für Liniendiagramme. Boolean Schreib-Lese-Zugriff


Beispiel zur HasUpDownBars-Eigenschaft

In diesem Beispiel werden die positiven und negativen Abweichungsbalken für die erste Diagrammgruppe aktiviert. Anschließend wird ihre Farbe festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm mit zwei Datenreihen an, die sich in mindestens einem Datenpunkt schneiden.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


 Height-Eigenschaft

Height-Eigenschaft

Gibt die Höhe eines Objekts in Punkten zurück oder legt sie fest. Long Schreib-Lesezugriff (Ausnahmen siehe folgende Tabelle).

Anmerkungen

Die Bedeutung der Height-Eigenschaft richtet sich nach dem Typ des angegebenen Objekts.

Objekttyp | Höhe
Application | Die Höhe des Haupt-Anwendungsfensters. Wenn das Fenster minimiert wurde, ist diese Eigenschaft schreibgeschützt und gibt die Symbolhöhe an. Ist das Fenster maximiert, kann diese Eigenschaft nicht festgelegt werden. Bestimmen Sie den Zustand des Fensters mit der WindowState-Eigenschaft.
Axis,ChartArea, LegendEntry, LegendKey | Die Höhe des Objekts. Schreibgeschützt.
Chart,DataSheet,Legend,,PlotArea | Die Höhe des Objekts.


HeightPercent-Eigenschaft

Gibt die Höhe eines 3D-Diagramms als Prozentsatz der Breite des Diagramms (zwischen 5 und 500 Prozent) zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur HeightPercent-Eigenschaft

In diesem Beispiel wird die Höhe des Diagramms auf 80 Prozent der Breite festgelegt. Wenden Sie das Makro auf ein 3D-Diagramm an.

myChart.HeightPercent = 80


HiLoLines-Eigenschaft

Gibt ein HiLoLines-Objekt zurück, das die Spannweitenlinien der angegebenen Datenreihen in einem Liniendiagramm darstellt. Gilt nur für Liniendiagramme. Schreibgeschützt.


Beispiel zur HiLoLines-Eigenschaft

In diesem Beispiel werden die Spannweitenlinien der ersten Diagrammgruppe im Diagramm eingeschaltet und anschließend ihre Linienart, -stärke und -farbe festgelegt. Das Beispiel sollte bei einem 2D-Liniendiagramm ausgeführt werden, das drei Datenreihen und aktienkursähnliche Daten enthält (Maximum-Tiefstwert-Schlusswert)

With myChart.ChartGroups(1)
    .HasHiLoLines = True
    With .HiLoLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HorizontalAlignment-Eigenschaft

Gibt die horizontale Ausrichtung des angegebenen Objekts zurück oder legt sie fest. Für alle Objekte kann diese Eigenschaft eine der folgenden XlHAlign-Konstanten sein: xlHAlignCenter, xlHAlignCenterAcrossSelection, xlHAlignDistributed, xlHAlignFill, xlHAlignGeneral, xlHAlignJustify, xlHAlignLeft oder xlHAlignRight. Variant Schreib-Lesezugriff.

Anmerkungen

Je nachdem, welche Sprachunterstützung (z. B. U.S. Englisch) ausgewählt oder installiert wurde, stehen Ihnen einiger dieser Konstanten möglicherweise nicht zur Verfügung.


Beispiel zur HorizontalAlignment-Eigenschaft

In diesem Beispiel wird der Diagrammtitel zentriert.

myChart.ChartTitle.HorizontalAlignment = xlCenter


Include-Eigenschaft

True, falls die Daten der angegebenen Zeile oder Spalte im Diagramm enthalten sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur Include-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Daten in der zweiten Zeile des Datenblatts nicht ins Diagramm aufgenommen werden.

With myChart.Application.DataSheet
    .Rows(2).Include = False
End With


Index-Eigenschaft

Gibt die Indexnummer des Objekts in einer Auflistung ähnlicher Objekte zurück. Long Schreibgeschützt.


Beispiel zur Index-Eigenschaft

In diesem Beispiel wird die Indexnummer eines Objekts angezeigt, das dieser Prozedur übergeben wird.

MsgBox "The index number of this object is " & obj.Index


InsideHeight-Eigenschaft

Gibt die Innenhöhe der Zeichnungsfläche in Punkt zurück. Double Schreibgeschützt.

Anmerkungen

Die für diese Messung verwendete Zeichnungsfläche beinhaltet nicht die Achsenbeschriftungen. Die Height-Eigenschaft der Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftungen beinhaltet.


InsideLeft-Eigenschaft

Gibt den Abstand zwischen dem Rand des Diagramms und dem linken Innenrand der Zeichnungsfläche in Punkt zurück. Double Schreibgeschützt.

Anmerkungen

Die für diese Messung verwendete Zeichnungsfläche beinhaltet nicht die Achsenbeschriftungen. Die Left-Eigenschaft der Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftungen beinhaltet.


InsideTop-Eigenschaft

Gibt den Abstand zwischen dem Rand des Diagramms und dem oberen Innenrand der Zeichnungsfläche in Punkt zurück. Double Schreibgeschützt.

Anmerkungen

Die für diese Messung verwendete Zeichnungsfläche beinhaltet nicht die Achsenbeschriftungen. Die Top-Eigenschaft der Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftungen beinhaltet.


InsideWidth-Eigenschaft

Gibt die Innenbreite der Zeichnungsfläche in Punkt zurück. Double Schreibgeschützt.

Anmerkungen

Die für diese Messung verwendete Zeichnungsfläche beinhaltet nicht die Achsenbeschriftungen. Die Width-Eigenschaft der Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftungen beinhaltet.


Intercept-Eigenschaft

Gibt den Punkt zurück, in dem die Trendlinie die Größenachse schneidet, oder legt ihn fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch das Festlegen dieser Eigenschaft wird die InterceptIsAuto-Eigenschaft auf False gesetzt.


InterceptIsAuto-Eigenschaft

True, wenn der Schnittpunkt der Trendlinie mit der Größenachse automatisch von der Regression bestimmt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch das Festlegen der Intercept-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur InterceptIsAuto-Eigenschaft

In diesem Beispiel bestimmt Microsoft Graph den Trendlinienschnittpunkt automatisch. Wenden Sie dieses Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

myChart.SeriesCollection(1).Trendlines(1) _
    .InterceptIsAuto = True


Interior-Eigenschaft

Gibt ein Interior-Objekt zurück, das den Innenbereich des angegebenen Objekts darstellt. Schreibgeschützt.


Beispiel zur Interior-Eigenschaft

In diesem Beispiel wird die Farbe des Innenbereichs des Diagrammtitels zugewiesen.

myChart.ChartTitle.Interior.ColorIndex = 8


InvertIfNegative-Eigenschaft

True, wenn Microsoft Graph das Muster im Element invertiert, falls sein Wert negativ ist. Variant Schreib-Lese-Zugriff für das Interior-Objekt; Boolean Schreib-Lese-Zugriff für alle anderen Objekte.


Beispiel zur InvertIfNegative-Eigenschaft

In diesem Beispiel wird das Muster für negative Werte der ersten Datenreihe invertiert. Wenden Sie das Makro auf ein 2D-Säulendiagramm an.

myChart.SeriesCollection(1).InvertIfNegative = True


Italic-Eigenschaft

True, wenn die Schriftart Kursiv ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur Italic-Eigenschaft

In diesem Beispiel wird der Diagrammtitel "Italic" (Kursiv) formatiert.

myChart.ChartTitle.Font.Italic = True


Item-Eigenschaft

Gibt ein Range-Objekt zurück, das einen Bereich darstellt, der von dem angegebenen Bereich versetzt ist. Schreibgeschützt.

Syntax 1

Ausdruck.Item(RowIndex, ColumnIndex)

Syntax 2

Ausdruck.Item(RowIndex)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

RowIndex Syntax 1: Variant erforderlich. Die Zeilennummer der Zelle, mit der Sie arbeiten möchten (die erste Zeile des Bereichs ist 1).

Syntax 2: Variant erforderlich. Die Indexnummer der Zelle, mit der Sie arbeiten möchten, von links oben nach rechts unten gezählt. Range.Item(1) gibt die Zelle in der oberen linken Ecke des Bereichs und Range.Item(2)die Zelle unmittelbar rechts daneben zurück.

ColumnIndex Variant optional. Eine Zahl oder eine Zeichenfolge, die die Spaltennummer der Zelle angibt, mit der Sie arbeiten möchten (die erste Spalte des Bereichs ist entweder 1 oder A).

Anmerkungen

Syntax 1 verwendet als Indexargumente eine Zeilennummer oder entweder eine Spaltennummer oder einen Buchstaben. Weitere Informationen über diese Syntax finden Sie unter dem Range-Objekt. Die Argumente RowIndex und ColumnIndex stellen relative Versetzungen dar, d. h., wenn Sie für RowIndex 1 angeben, werden Zellen in der ersten Zeile des Bereichs und nicht die erste Zeile des Datenblattes zurückgegeben.


Beispiel zur Item-Eigenschaft

In diesem Beispiel werden die Inhalte der Zelle B2 im Datenblatt gelöscht.

myChart.Application.DataSheet.Range("A1").Item(2, 2).Clear


LeaderLines-Eigenschaft

Gibt ein LeaderLines-Objekt zurück, das die Führungslinien der angegebenen Datenreihe darstellt. Schreibgeschützt.


Beispiel zur LeaderLines-Eigenschaft

In diesem Beispiel werden der ersten Datenreihe des Kreisdiagramms Datenbeschriftungen und blaue Führungslinien hinzugefügt

With myChart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


 Left-Eigenschaft

Left-Eigenschaft

Gibt die Position des angegebenen Objekts in Punkten zurück oder legt sie fest. Long Schreib-Lesezugriff (Ausnahmen siehe folgende Tabelle).

Anmerkungen

Die Bedeutung der Left-Eigenschaft richtet sich nach dem angegebenen Objekt.

Objekt | Bedeutung
Application | Der Abstand vom linken Rand des Bildschirms zum linken Rand des Microsoft Graph-Hauptfensters.
Chart, DataSheet | Der Abstand vom linken Rand des Objekts zum linken Rand des Microsoft Graph-Fensters.
Axis, ChartArea, LegendEntry, LegendKey | Der Abstand vom linken Rand des Objekts zum linken Rand des Diagrammbereichs. Schreibgeschützt.
AxisTitle, ChartTitle, DataLabel, Legend, PlotArea | Der Abstand vom linken Rand des Objekts zum linken Rand des Diagrammbereichs.

Ist das Fenster maximiert, gibt Application.Left einen negativen Wert zurück, der von der Breite des Fensterrands abhängt. Wenn Sie Application.Left auf 0 (Null) setzen, wird das Fenster etwas kleiner als beim Maximieren des Anwendungsfensters. Wenn Application.Left also den Wert 0 hat, ist der linke Rand des Microsoft Graph-Hauptfensters gerade noch auf dem Bildschirm sichtbar.

Application.Left steuert die Position des Fenstersymbols, wenn das Microsoft Graph-Fenster minimiert ist.


Beispiel zur Left-Eigenschaft

In diesem Beispiel wird der linke Rand des Diagrammtitels am linken Rand des Diagrammbereichs ausgerichtet.

myChart.ChartTitle.Left = 0


Legend-Eigenschaft

Gibt ein Legend-Objekt zurück, das die Legende des angegebenen Diagramms darstellt. Schreibgeschützt.


LegendKey-Eigenschaft

Gibt ein LegendKey-Objekt zurück, das das mit dem Eintrag verknüpfte Legendensymbol darstellt.


Beispiel zur LegendKey-Eigenschaft

In diesem Beispiel wird ein Dreieck als Legendensymbol für den ersten Legendeneintrag festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm an.

myChart.Legend.LegendEntries(1).LegendKey _
    .MarkerStyle = xlMarkerStyleTriangle


Line3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Liniendiagrammgruppe in einem 3D-Diagramm darstellt. Schreibgeschützt.


Beispiel zur Line3DGroup-Eigenschaft

In diesem Beispiel wird für alle Datenpunktmarkierungen der 3D-Liniendiagrammgruppe eine andere Farbe verwendet.

myChart.Line3DGroup.VaryByCategories = True


LineStyle-Eigenschaft

Gibt die Linienart des Rahmens zurück oder legt sie fest. Dies kann eine der folgenden XlLineStyle-Konstanten sein: xlContinuous, xlDash, xlDashDot, xlDashDotDot, xlDot, xlDouble, xlSlantDashDot oder xlLineStyleNone. Long Schreib-Lese-Zugriff.


Beispiel zur LineStyle-Eigenschaft

In diesem Beispiel wird ein Rahmen um den Diagrammbereich und die Zeichnungsfläche gelegt.

With myChart
    .ChartArea.Border.LineStyle = xlDashDot
    With .PlotArea.Border
        .LineStyle = xlDashDotDot
        .Weight = xlThick
    End With
End With


MajorGridlines-Eigenschaft

Gibt ein Gridlines-Objekt zurück, das die Hauptgitternetzlinien der angegebenen Achsengruppe darstellt. Nur Achsen der primären Achsengruppe können Gitternetzlinien besitzen. Schreibgeschützt.


Beispiel zur MajorGridlines-Eigenschaft

In diesem Beispiel wird für die Größenachse im Diagramm die Farbe der Gitternetzlinien festgelegt.

With myChart.Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 5
    End If
End With


MajorTickMark-Eigenschaft

Gibt die Art der Hauptteilstriche für die angegebene Achse zurück oder legt sie fest. Dies kann eine der folgenden XlTickMark-Konstanten sein: xlTickMarkNone, xlTickMarkInside, xlTickMarkOutside oder xlTickMarkCross. Long Schreib-Lese-Zugriff.


Beispiel zur MajorTickMark-Eigenschaft

In diesem Beispiel werden der Größenachse außen liegende Hauptteilstriche zugewiesen.

myChart.Axes(xlValue).MajorTickMark = xlTickMarkOutside


MajorUnit-Eigenschaft

Gibt die Hauptintervalle der Achse zurück oder legt sie fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MajorUnitIsAuto-Eigenschaft auf False gesetzt.

Mit der TickMarkSpacing-Eigenschaft können Sie den Abstand zwischen den Teilstrichen auf der Rubrikenachse festlegen.


MajorUnitIsAuto-Eigenschaft

True, wenn Microsoft Graph die Hauptintervalle der Achse automatisch berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MajorUnit-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MajorUnitIsAuto-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse automatisch berechnet.

With myChart.Axes(xlValue)
    .MajorUnitIsAuto = True
    .MinorUnitIsAuto = True
End With


MajorUnitScale-Eigenschaft

Gibt den Skalierungswert des Hauptintervalls für die Rubrikenachse zurück, wenn die CategoryType-Eigenschaft auf xlTimeScale gesetzt ist. Dies kann eine der folgenden XlTimeUnit-Konstanten sein: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.


Beispiel zur MajorUnitScale-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse eine Zeitskala gewählt, und die Haupt- sowie Hilfsintervalle werden festgelegt.

With myChart.Axes(xlCategory)
    .CategoryType = xlTimeScale
    .MajorUnit = 5
    .MajorUnitScale = xlDays
    .MinorUnit = 1
    .MinorUnitScale = xlDays
End With


MarkerBackgroundColor-Eigenschaft

Gibt die Hintergrundfarbe für Punktmarkierungen als RGB-Wert zurück oder legt sie fest. Dies gilt nur für Linien-, Punkt- und Netzdiagramme. Long Schreib-Lese-Zugriff


MarkerBackgroundColorIndex-Eigenschaft

Gibt die Hintergrundfarbe für Punktmarkierungen als Index in der aktuellen Farbpalette zurück oder legt sie fest bzw. weist ihr eine der folgenden XlColorIndex-Konstanten zu: xlColorIndexAutomatic oder xlColorIndexNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Die folgende Abbildung zeigt die ColorIndexwerte der Standard-Farbpalette.

ColorIndexwerte in der Standard-Farbpalette


Beispiel zur MarkerBackgroundColorIndex-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunkts der ersten Datenreihe festgelegt.

With myChart.SeriesCollection(1).Points(2)
    .MarkerBackgroundColorIndex = 4    ' green
    .MarkerForegroundColorIndex = 3    ' red
End With


MarkerForegroundColor-Eigenschaft

Gibt die Vordergrundfarbe für Punktmarkierungen als RGB-Wert zurück oder legt sie fest. Dies gilt nur für Linien-, Punkt- und Netzdiagramme. Long Schreib-Lese-Zugriff


MarkerForegroundColorIndex-Eigenschaft

Gibt die Vordergrundfarbe für Punktmarkierungen als Index in der aktuellen Farbpalette zurück oder legt sie fest bzw. weist ihr eine der folgenden XlColorIndex-Konstanten zu: xlColorIndexAutomatic oder xlColorIndexNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Die folgende Abbildung zeigt die ColorIndexwerte der Standard-Farbpalette.

ColorIndexwerte in der Standard-Farbpalette


Beispiel zur MarkerForegroundColorIndex-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunkts der ersten Datenreihe festgelegt.

With myChart.SeriesCollection(1).Points(2)
    .MarkerBackgroundColorIndex = 4    ' green
    .MarkerForegroundColorIndex = 3    ' red
End With


 MarkerSize-Eigenschaft

MarkerSize-Eigenschaft

Gibt die Größe der Datenpunktmarkierungen in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur MarkerSize-Eigenschaft

In diesem Beispiel wird die Größe der Datenpunktmarkierung für alle Datenpunktmarkierungen der ersten Datenreihe festgelegt.

MyChart.SeriesCollection(1).MarkerSize = 10


MarkerStyle-Eigenschaft

Gibt die Art der Markierung für einen Datenpunkt oder eine Datenreihe in einem Linien-, Punkt- oder Netzdiagramm zurück bzw. legt sie fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlMarkerStyle-Konstanten sein:

Konstante | Beschreibung
xlMarkerStyleNone | Keine Markierung
xlMarkerStyleAutomatic | Automatische Markierungen
xlMarkerStyleSquare | Quadratische Markierungen
xlMarkerStyleDiamond | Rautenförmige Markierungen
xlMarkerStyleTriangle | Dreieckige Markierungen
xlMarkerStyleX | Quadratische Markierungen mit einem X
xlMarkerStyleStar | Quadratische Markierungen mit einem Sternchen
xlMarkerStyleDot | Kurze Balken als Markierungen
xlMarkerStyleDash | Lange Balken als Markierungen
xlMarkerStyleCircle | Runde Markierungen
xlMarkerStylePlus | Quadratische Markierungen mit einem Pluszeichen
xlMarkerStylePicture | Bildmarkierungen


Beispiel zur MarkerStyle-Eigenschaft

In diesem Beispiel wird die Markierungsart für die erste Datenreihe festgelegt. Es ist sinnvoll, das Makro auf ein 2D-Liniendiagramm anzuwenden.

myChart.SeriesCollection(1).MarkerStyle = xlMarkerStyleCircle


MaximumScale-Eigenschaft

Gibt das Maximum auf der Größenachse zurück oder legt ihn fest. Double Schreib-Lese-Zugriff.

Anmerkung

Durch Festlegen dieser Eigenschaft wird die MaximumScaleIsAuto-Eigenschaft auf False gesetzt.


MaximumScaleIsAuto-Eigenschaft

True, wenn Microsoft Graph das Maximum für die Achse berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MaximumScale-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MaximumScaleIsAuto-Eigenschaft

In diesem Beispiel werden der niedrigste und der höchste Wert für die Größenachse automatisch berechnet.

With myChart.Axes(xlValue)
    .MinimumScaleIsAuto = True
    .MaximumScaleIsAuto = True
End With


MinimumScale-Eigenschaft

Gibt das Minimum auf der Achse zurück oder legt ihn fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MinimumScaleIsAuto-Eigenschaft auf False gesetzt.


MinimumScaleIsAuto-Eigenschaft

True, wenn Microsoft Graph das Minimum für die Achse berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MinimumScale-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MinimumScaleIsAuto-Eigenschaft

In diesem Beispiel werden der niedrigste und der höchste Wert für die Größenachse automatisch berechnet.

With myChart.Axes(xlValue)
    .MinimumScaleIsAuto = True
    .MaximumScaleIsAuto = True
End With


MinorGridlines-Eigenschaft

Gibt ein Gridlines-Objekt zurück, das die Hilfsgitternetzlinien der angegebenen Achsengruppe darstellt. Nur Achsen der primären Achsengruppe können Gitternetzlinien besitzen. Schreibgeschützt.


Beispiel zur MinorGridlines-Eigenschaft

In diesem Beispiel wird für die Hilfsgitternetzlinien der Größenachse die Farbe Blau festgelegt.

With myChart.Axes(xlValue)
    If .HasMinorGridlines Then
        .MinorGridlines.Border.ColorIndex = 5
    End If
End With


MinorTickMark-Eigenschaft

Gibt die Art der Hilfsteilstriche für die angegebene Achse zurück oder legt sie fest. Dies kann eine der folgenden XlTickMark-Konstanten sein: xlTickMarkNone, xlTickMarkInside, xlTickMarkOutside oder xlTickMarkCross. Long Schreib-Lese-Zugriff.


Beispiel zur MinorTickMark-Eigenschaft

In diesem Beispiel werden der Größenachse innen liegende Hilfsteilstriche zugewiesen.

myChart.Axes(xlValue).MinorTickMark = xlTickMarkInside


MinorUnit-Eigenschaft

Gibt die Hilfsintervalle der Achse zurück oder legt sie fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MinorUnitIsAuto-Eigenschaft auf False gesetzt.

Mit der TickMarkSpacing-Eigenschaft können Sie den Abstand zwischen den Teilstrichen auf der Rubrikenachse festlegen.


MinorUnitIsAuto-Eigenschaft

True, wenn Microsoft Graph die Hilfsintervalle der Achse automatisch berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MinorUnit-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MinorUnitIsAuto-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse automatisch berechnet.

With myChart.Axes(xlValue)
    .MajorUnitIsAuto = True
    .MinorUnitIsAuto = True
End With


MinorUnitScale-Eigenschaft

Gibt den Skalierungswert des Hilfsintervalls für die Rubrikenachse zurück, wenn die CategoryType-Eigenschaft auf xlTimeScale gesetzt ist. Dies kann eine der folgenden XlTimeUnit-Konstanten sein: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.


Beispiel zur MinorUnitScale-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse eine Zeitskala gewählt, und die Haupt- sowie Hilfsintervalle werden festgelegt.

With myChart.Axes(xlCategory)
    .CategoryType = xlTimeScale
    .MajorUnit = 5
    .MajorUnitScale = xlDays
    .MinorUnit = 1
    .MinorUnitScale = xlDays
End With


MoveAfterReturn-Eigenschaft

True, wenn die aktive Zelle nach dem Drücken der EINGABETASTE verschoben wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur MoveAfterReturn-Eigenschaft

In diesem Beispiel wird der MoveAfterReturn-Eigenschaft der Wert True zugewiesen.

myChart.Application.MoveAfterReturn = True


Name-Eigenschaft

Gibt den Namen des angegebenen Objekts zurück oder legt ihn fest. String Schreib-Lesezugriff.


NameIsAuto-Eigenschaft

True, wenn Microsoft Graph den Namen der Trendlinie automatisch bestimmt. Boolean Schreib-Lese-Zugriff.


Beispiel zur NameIsAuto-Eigenschaft

Mit diesem Beispiel wird Microsoft Graph so eingestellt, dass der Name der ersten Trendlinie automatisch festgelegt wird. Es ist sinnvoll, das Makro auf ein 2D-Säulendiagramm anzuwenden, das eine einzelne Datenreihe mit einer Trendlinie enthält.

myChart.SeriesCollection(1).Trendlines(1).NameIsAuto = True


NumberFormat-Eigenschaft

Gibt den Formatierungscode für das Objekt zurück oder legt ihn fest. Die Eigenschaft gibt Null zurück, wenn die Zellen im angegebenen Bereich nicht dasselbe Zahlenformat haben. Variant Schreib-Lese-Zugriff für das Range-Objekt, String Schreib-Lese-Zugriff für alle anderen Objekte.


NumberFormatLocal-Eigenschaft

Gibt das Format für das angegebene Objekt als Zeichenkette in der Sprache des Benutzers zurück oder legt es fest. Variant Schreib-Lesezugriff.

Anmerkungen

Die Format-Funktion verwendet andere Formatzeichenketten als die NumberFormat- und die NumberFormatLocal-Eigenschaften.


Beispiel zur NumberFormatLocal-Eigenschaft

In diesem Beispiel wird das Zahlenformat für die Datenbeschriftungen der ersten Datenreihe des Diagramms in der Sprache des Benutzers angezeigt.

MsgBox "The number format for the first series is " & _
    myChart.SeriesCollection(1).DataLabels.NumberFormatLocal


Offset-Eigenschaft

Gibt den Abstand zwischen den einzelnen Beschriftungsebenen sowie den Abstand zwischen der ersten Ebene und der Achsenlinie zurück oder legt ihn fest. Der Standardwert ist 100 und gibt den Abstand zwischen den Achsenbeschriftungen und der Achsenlinie an. Dieser Wert kann eine Ganzzahl von 0 bis 1000 sein und bezieht sich auf die Schriftgröße der Achsenbeschriftung. Long Lese-/Schreibzugriff.


Beispiel zur Offset-Eigenschaft

Im folgenden Beispiel wird der Abstand zwischen den vorhandenen Teilstrichen auf der Größenachse in myChart verdoppelt, wenn der Offset-Wert kleiner als 500 ist.

With myChart.Axes(xlCategory).TickLabels
    If .Offset < 500 then
        .Offset = .Offset * 2
    End If
End With


Order-Eigenschaft

Gibt die Ordnung der Trendlinien (eine Ganzzahl größer als 1) zurück oder legt sie fest, wenn als Trendlinientyp xlPolynomial festgelegt ist. Long Schreib-Lese-Zugriff.


Beispiel zur Order-Eigenschaft

In diesem Beispiel wird die Ordnung der ersten Trendlinie der ersten Datenreihe festgelegt, wenn diese polynomial ist.

With myChart.SeriesCollection(1).Trendlines(1)
    If .Type = xlPolynomial Then .Order = 3
End With


Orientation-Eigenschaft

Gibt die Ausrichtung des angegebenen Objekts zurück oder legt sie fest, entsprechend der folgenden Tabelle. Long Lese-/Schreibzugriff.

Objekt | Ausrichtung
AxisTitle, ChartTitle, DataLabel, DisplayUnitLabel, Range, Style, TextFrame | Die Textausrichtung. Dies kann eine Ganzzahl zwischen -90 Grad und 90 Grad oder eine der folgenden XlOrientation-Konstanten sein: xlDownward, xlHorizontal, xlUpward oder xlVertical.
TickLabels | Die Textausrichtung. Dies kann eine Ganzzahl zwischen -90 Grad und 90 Grad oder eine der folgenden XlTickLabelOrientation-Konstanten sein: xlTickLabelOrientationAutomatic, xlTickLabelOrientationDownward, xlTickLabelOrientationHorizontal, xlTickLabelOrientationUpward oder xlTickLabelOrientationVertical.


Beispiel zur Orientation-Eigenschaft

In diesem Beispiel wird die Ausrichtung des Diagrammtitels festgelegt.

myChart.ChartTitle.Orientation = xlHorizontal


OutlineFont-Eigenschaft

True, wenn die Schriftart eine Konturenschriftart ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat in Microsoft Windows keine Wirkung, jedoch bleibt ihr Wert erhalten (er kann festgelegt und zurückgegeben werden).


Beispiel zur OutlineFont-Eigenschaft

In diesem Beispiel wird für den Diagrammtitel eine Konturenschriftart festgelegt.

myChart.ChartTitle.Font.OutlineFont = True


Overlap-Eigenschaft

Bestimmt die Positionierung von Balken und Säulen. Zulässige Werte liegen zwischen -100 und 100. Nur gültig für 2D-Balken- und 2D-Säulendiagramme. Long Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft auf -100 festgelegt, werden die Balken mit dem Abstand einer Balkenbreite positioniert. Beträgt der Überlappungswert 0 (Null), so besteht kein Abstand zwischen den Balken. Beträgt der Wert 100, so werden die Balken genau übereinander positioniert.


Beispiel zur Overlap-Eigenschaft

In diesem Beispiel wird die Überlappung für die erste Diagrammgruppe auf -50 festgelegt. Es ist sinnvoll, das Makro auf ein 2D-Säulendiagramm mit mindestens zwei Datenreihen anzuwenden.

myChart.ChartGroups(1).Overlap = -50


Parent-Eigenschaft

Gibt das übergeordnete Objekt für das angegebene Objekt zurück. Schreibgeschützt.


Pattern-Eigenschaft

Interior-Objekt: Gibt das Muster des Innenbereichs zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlPattern-Konstanten sein:

xlPatternAutomatic

xlPatternChecker

xlPatternCrissCross

xlPatternDown

xlPatternGray16

xlPatternGray25

xlPatternGray50

xlPatternGray75

xlPatternGray8

xlPatternGrid

 xlPatternHorizontal

xlPatternLightDown

xlPatternLightHorizontal

xlPatternLightUp

xlPatternLightVertical

xlPatternNone

xlPatternSemiGray75

xlPatternSolid

xlPatternUp

xlPatternVertical

ChartFillFormat-Objekt: Gibt das Füllmuster zurück oder legt es fest. Long Schreibgeschützt.

Dies kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBrick

msoPatternDivits

msoPatternDottedGrid

msoPatternHorizontalBrick

msoPatternLargeCheckerBoard

 msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDiamonds

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamonds

msoPatternPlaid

msoPatternShingles

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamonds

msoPatternSpheres

msoPatternTrellis

msoPatternWaves

msoPatternWavyLines

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal


PatternColor-Eigenschaft

Gibt die Musterfarbe für den Innenbereich als RGB-Wert zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.


PatternColorIndex-Eigenschaft

Gibt die Musterfarbe des Innenbereichs als Index in der aktuellen Farbpalette zurück oder legt sie fest bzw. weist ihr eine der folgenden XlColorIndex-Konstanten zu: xlColorIndexAutomatic oder xlColorIndexNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie dieser Eigenschaft xlColorIndexAutomatic zuordnen, wird die Musterfarbe der Zellen bzw. die Ausfüllart von Zeichnungsobjekten automatisch festgelegt. Ordnen Sie dieser Eigenschaft xlColorIndexNone zu, wenn Sie kein Muster wünschen. Die gleiche Wirkung erzielen Sie, wenn Sie der Pattern-Eigenschaft des Interior-Objekts xlPatternNone zuordnen.

Die folgende Abbildung zeigt die ColorIndexwerte der Standard-Farbpalette.

ColorIndexwerte in der Standard-Farbpalette


Beispiel zur PatternColorIndex-Eigenschaft

In diesem Beispiel wird die Musterfarbe des Innenbereichs für den Diagrammbereich festgelegt.

myChart.ChartArea.Interior.PatternColorIndex = 5


Period-Eigenschaft

Gibt bei Trendlinien für gleitenden Durchschnitt die Perioden zurück bzw. legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Period-Eigenschaft

In diesem Beispiel wird die Periode für die Trendlinie mit gleitendem Durchschnitt festgelegt. Das Beispiel muss auf ein 2D-Säulendiagramm angewendet werden, das eine einzelne Datenreihe mit 10 Datenpunkten und eine Trendlinie mit gleitendem Durchschnitt enthält.

With myChart.SeriesCollection(1).Trendlines(1)
    If .Type = xlMovingAvg Then .Period = 5
End With


Perspective-Eigenschaft

Gibt die Perspektive für die Ansicht eines 3D-Diagramms zurück oder legt sie fest. Der Wert muss zwischen 0 und 100 liegen. Diese Eigenschaft wird nicht beachtet, wenn die RightAngleAxes-Eigenschaft den Wert True hat. Long Schreib-Lese-Zugriff.


Beispiel zur Perspective-Eigenschaft

In diesem Beispiel wird der Perspektive von myChart der Wert 70 zugewiesen. Es ist sinnvoll, das Makro auf ein 3D-Diagramm anzuwenden.

myChart.RightAngleAxes = False
myChart.Perspective = 70


PictureType-Eigenschaft

Gibt zurück oder legt fest, wie Bilder in Säulen- oder Balkengrafikdiagrammen bzw. auf den Wänden und Flächen eines 3D-Diagramms dargestellt werden. Variant Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlPictureType-Konstanten sein:

Wert | Beschreibung
xlStretch | Streckt das Bild, um den erforderlichen Wert zu erreichen.
xlStack | Stapelt die Bilder, um den erforderlichen Wert zu erreichen.
xlScale | Stapelt die Bilder. Legen Sie mit der PictureUnit-Eigenschaft fest, welche Einheit die einzelnen Bilder darstellen.
xlTile | Ordnet die Bilder nebeneinander an.


Beispiel zur PictureType-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Bilder der ersten Datenreihe gestreckt werden. Wenden Sie das Makro auf ein 2D-Säulendiagramm mit Bildern als Datenpunktmarkierungen an.

myChart.SeriesCollection(1).PictureType = xlStretch


PictureUnit-Eigenschaft

Gibt zurück oder legt fest, wie viele Einheiten einem Bild in einem Diagramm entsprechen, wenn die PictureType-Eigenschaft auf xlScale gesetzt ist (anderenfalls wird diese Eigenschaft ignoriert). Long Schreib-Lese-Zugriff.


Beispiel zur PictureUnit-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Bilder der ersten Datenreihe gestapelt werden und dass jedes Bild fünf Einheiten darstellt. Wenden Sie das Makro auf ein 2D-Säulendiagramm mit Bildern als Datenpunktmarkierungen an.

With myChart.SeriesCollection(1)
    .PictureType = xlScale
    .PictureUnit = 5
End With


Pie3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Kreisdiagrammgruppe in einem 3D-Diagramm darstellt. Schreibgeschützt.


Beispiel zur Pie3DGroup-Eigenschaft

In diesem Beispiel wird für jede Datenpunktmarkierung in der 3D-Kreisdiagrammgruppe eine andere Farbe verwendet.

myChart.Pie3DGroup.VaryByCategories = True


PlotArea-Eigenschaft

Gibt ein PlotArea-Objekt zurück, das die Zeichnungsfläche eines Diagramms darstellt. Schreibgeschützt.


Beispiel zur PlotArea-Eigenschaft

In diesem Beispiel wird der inneren Zeichnungsfläche in myChart die Farbe Zyan zugewiesen.

myChart.PlotArea.Interior.ColorIndex = 8


PlotBy-Eigenschaft

Gibt zurück oder legt fest, wie Spalten oder Zellen im Diagramm als Datenreihen verwendet werden. Dies kann eine der folgenden XlRowCol-Konstanten sein: xlColumns oder xlRows. Long Schreib-Lese-Zugriff.


Beispiel zur PlotBy-Eigenschaft

In diesem Beispiel werden die Daten des eingebetteten Diagramms spaltenweise dargestellt.

myChart.PlotBy = xlColumns


PlotOnX-Eigenschaft

Gibt den Index der Datenblattreihe zurück, deren Inhalte als Werte für die Rubrikenachse im angegebenen XY-Punktdiagramm verwendet werden sollen oder legt diesen fest. Long Schreib-Lesezugriff.


Beispiel zur PlotOnX-Eigenschaft

In diesem Beispiel wird die Reihe 0 als die Reihe festgelegt, deren Inhalt der Rubrikenachse in myChart in Form von Werten zugewiesen wird.

myChart.PlotOnX = 0


Position-Eigenschaft

Gibt entsprechend der folgenden Tabelle die Position des angegebenen Objekts zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Objekt | Position
DataLabel, DataLabels | Die Position der Datenbeschriftung. Dies kann eine der folgenden XlDataLabelPosition-Konstanten sein: xlLabelPositionAbove, xlLabelPositionBelow, xlLabelPositionBestFit, xlLabelPositionCenter, xlLabelPositionCustom, xlLabelPositionInsideBase, xlLabelPositionInsideEnd, xlLabelPositionLeft, xlLabelPositionMixed, xlLabelPositionOutsideEnd oder xlLabelPositionRight.
Legend | Die Position der Legende im Diagramm. Dies kann eine der folgenden XlLegendPosition-Konstanten sein: xlLegendPositionBottom, xlLegendPositionCorner, xlLegendPositionLeft, xlLegendPositionRight oder xlLegendPositionTop.


Beispiel zur Position-Eigenschaft

In diesem Beispiel wird die Legende oben im Diagramm positioniert.

myChart.Legend.Position = xlLegendPositionTop


PresetGradientType-Eigenschaft

Gibt die vordefinierte Art des Farbverlaufs für die angegebene Füllung zurück. Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetGradient-Methode, um die vordefinierte Art des Farbverlaufs für die Füllung festzulegen.


Beispiel zur PresetGradientType-Eigenschaft

In diesem Beispiel wird im Füllungsformat des Diagramms die vordefinierte Art des Farbverlaufs von Silber in Gold geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillGradient Then
        If .GradientColorType = msoGradientPresetColors Then
            If .PresetGradientType = msoGradientSilver Then
                .PresetGradient .GradientStyle, _
                .GradientVariant, msoGradientGold
            End If
        End If
    End If
End With


PresetTexture-Eigenschaft

Gibt die vordefinierte Struktur der angegebenen Füllung zurück. Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

Kann einer der folgenden MsoPresetTexture-Werte sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetTextured-Methode, um die vordefinierte Struktur für die Füllung festzulegen.


Beispiel zur PresetTexture-Eigenschaft

In diesem Beispiel wird im Füllungsformat des Diagramms die vordefinierte Struktur von Oak (Eiche) in Walnut (Walnuss) geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillTextured Then
        If .TextureType = msoTexturePreset Then
            If .PresetTexture = msoTextureOak Then
                .PresetTextured msoTextureWalnut
            End If
        End If
    End If
End With


RadarAxisLabels-Eigenschaft

Gibt ein TickLabels-Objekt zurück, das die Netzachsenbeschriftungen der angegebenen Diagrammgruppe darstellt. Schreibgeschützt.


Beispiel zur RadarAxisLabels-Eigenschaft

In diesem Beispiel werden die Netzachsenbeschriftungen der ersten Diagrammgruppe im Diagramm eingeschaltet und ihre Farbe festgelegt. Das Beispiel sollte bei einem Netzdiagramm ausgeführt werden.

With myChart.ChartGroups(1)
    .HasRadarAxisLabels = True
    .RadarAxisLabels.Font.ColorIndex = 3
End With


Range-Eigenschaft

Gibt ein Range-Objekt zurück, das die angegebene Zelle oder den angegebenen Zellbereich darstellt.

Syntax 1

Ausdruck.Range(Cell1)

Syntax 2

Ausdruck.Range(Cell1, Cell2)

Ausdruck Erforderlich. Ein Ausdruck, der ein DataSheet-Objekt zurückgibt.

Cell1 Erforderlich für Syntax 1. Der Name des angegebenen Bereichs. Er muss in der Schreibweise des A1-Bezugssystems in der Sprache des Makros angegeben werden und kann den Bereichsoperator (einen Doppelpunkt), den Schnittmengenoperator (ein Leerzeichen) oder den Vereinigungsoperator (ein Komma) enthalten. Es dürfen auch Dollarzeichen vorkommen, sie werden jedoch ignoriert.

Cell1, Cell2 Erforderlich für Syntax 2. Die Zellen der oberen linken und der unteren rechten Ecke des angegebenen Bereichs. Jedes Argument kann ein Range-Objekt sein, das eine einzelne Zelle (oder eine gesamte Spalte bzw. Zeile) enthält, oder es kann eine Zeichenfolge sein, die den Namen einer einzelnen Zelle in der Sprache des Makros enthält.

Anmerkungen

Die erste Spaltenüberschrift (links beginnend) lautet A, die nächsten lauten B, C, D usw. Die erste Zeilenüberschrift (oben beginnend) lautet 1, die nächsten lauten 2, 3, 4 usw. Weder die am weitesten links gelegene Spalte noch die oberste Zeile sind mit einer Überschrift versehen. Mit anderen Worten ist die Spalte A eigentlich die zweite Spalte von links; entsprechend ist die Zeile 1 die zweite Zeile von oben. Die am weitesten links gelegene Spalte und die oberste Zeile werden gewöhnlich für Legendentext oder Achsenbeschriftungen verwendet und als Spalte 0 (Null) bzw. Zeile 0 (Null) bezeichnet. So wird im folgenden Beispiel der Text "Jahresumsatz" in die oberste Zelle der Spalte A (der zweiten Spalte) eingefügt.

myChart.Application.DataSheet.Range("A0").Value = "Annual Sales"

Im folgenden Beispiel wird der Text "Bezirk 1" in die am weitesten links gelegene Zelle der Zeile 2 (der dritten Zeile) eingefügt.

myChart.Application.DataSheet.Range("02").Value = "District 1"


Beispiel zur Range-Eigenschaft

In diesem Beispiel wird der Zelle A1 des Datenblattes der Wert 3,14159 zugewiesen.

myChart.DataSheet.Range("A1").Value = 3.14159

In diesem Beispiel werden die Zellen A1:C3 des Datenblattes in einer Schleife bearbeitet. Besitzt eine der Zellen einen Wert, der kleiner ist als 0,001, wird er durch 0 (Null) ersetzt.

With myChart.Application.DataSheet
    For Each c in .Range("A1:C3")
        If c.Value < .001 Then
            c.Value = 0
        End If
    Next c
End With


ReadingOrder-Eigenschaft

Gibt die Lesereihenfolge des angegebenen Objekts zurück oder legt sie fest. Dies kann eine der folgenden Konstanten sein: xlContext, xlLTR (von links nach rechts) oder xlRTL (von rechts nach links). Long Schreib-Lesezugriff.

Anmerkungen

Je nachdem, welche Sprachunterstützung (z. B. U.S. Englisch) ausgewählt wurde, stehen Ihnen einige dieser Konstanten möglicherweise nicht zur Verfügung.


Beispiel zur ReadingOrder-Eigenschaft

In diesem Beispiel wird die Lesereihenfolge von rechts nach links für den Diagrammtitel festgelegt.

myChart.ChartTitle.ReadingOrder = xlRTL


ReplaceText-Eigenschaft

True, wenn Text, der einem Eintrag in der Liste der AutoKorrektur-Ersetzungen entspricht, automatisch ersetzt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ReplaceText-Eigenschaft

In diesem Beispiel wird das automatische Ersetzen von Text für das Diagramm deaktiviert.

With myChart.Application.AutoCorrect
    .CapitalizeNamesOfDays = True
    .ReplaceText = False
End With


ReversePlotOrder-Eigenschaft

True, wenn Microsoft Graph Datenpunkte in umgekehrter Reihenfolge, also beginnend mit dem letzten Datenpunkt, darstellt. Boolean Schreib-Lese-Zugriff.

Anmerkung

Diese Eigenschaft ist für Netzdiagramme nicht verfügbar.


Beispiel zur ReversePlotOrder-Eigenschaft

In diesem Beispiel werden Datenpunkte auf der Größenachse in umgekehrter Reihenfolge dargestellt.

myChart.Axes(xlValue).ReversePlotOrder = True


RGB-Eigenschaft

Gibt den Rot-Grün-Blauwert der angegebenen Farbe zurück. Long Schreibgeschützt.


Beispiel zur RGB-Eigenschaft

In diesem Beispiel wird für die Farbe der Legendenschriftart die Vordergrundfüllfarbe der Zeichnungsfläche festgelegt.

myChart.Legend.Font.Color = _
    myChart.PlotArea.Fill.ForeColor.RGB


RightAngleAxes-Eigenschaft

True, wenn die Diagrammachsen in rechtem Winkel zueinander stehen, unabhängig von der Drehung oder der Betrachtungshöhe des Diagramms. Gilt nur für 3D-Linien-, Säulen- und Balkendiagramme. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft den Wert True hat, wird die Perspective-Eigenschaft ignoriert.


Beispiel zur RightAngleAxes-Eigenschaft

In diesem Beispiel werden die Achsen so eingestellt, dass sie sich im rechten Winkel schneiden. Es ist sinnvoll, das Makro auf ein 3D-Diagramm anzuwenden.

myChart.RightAngleAxes = True


Rotation-Eigenschaft

Chart-Objekt: Gibt die Drehung für die Ansicht des 3D-Diagramms (die Drehung der Diagrammfläche um die z-Achse in Grad) zurück oder legt sie fest. Dieser Wert muss zwischen 0 und 360 liegen. Bei 3D-Balkendiagrammen muss der Wert zwischen 0 und 44 liegen. Der Standardwert ist 20. Nur gültig für 3D-Diagramme. Variant Schreib-Lese-Zugriff.


Beispiel zur Rotation-Eigenschaft

In diesem Beispiel wird die Drehung von myChart auf 30 Grad festgelegt. Es ist sinnvoll, das Makro auf ein 3D-Diagramm anzuwenden.

myChart.Rotation = 30


Rows-Eigenschaft

Range-Objekt: Gibt ein Range-Objekt zurück, das die Zeilen im angegebenen Bereich darstellt. Schreibgeschützt.

Datasheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen des Tabellenblatts darstellt. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Rows-Eigenschaft

In diesem Beispiel wird die dritte Zeile des Tabellenblatts gelöscht.

myChart.Application.DataSheet.Rows(3).Delete


ScaleType-Eigenschaft

Gibt die Art der Skalierung der Größenachse zurück oder legt sie fest. Dies kann eine der folgenden XlScaleType-Konstanten sein: xlScaleLinear oder xlScaleLogarithmic. Gilt nur für die Größenachse. Long Schreib-Lese-Zugriff.

Anmerkung

Bei einer logarithmischen Skalierung werden Logarithmen zur Basis 10 verwendet.


Beispiel zur ScaleType-Eigenschaft

In diesem Beispiel wird für die Größenachse eine logarithmische Skalierung eingestellt.

myChart.Axes(xlValue).ScaleType = xlScaleLogarithmic


SchemeColor-Eigenschaft

Gibt die Farbe des angegebenen ChartColorFormat-Objekts als Index der aktuellen Farbskala zurück oder legt die Farbe fest. Long Schreib-Lese-Zugriff.


Beispiel zur SchemeColor-Eigenschaft

In diesem Beispiel werden für die Diagrammfläche des Diagramms Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With myChart.ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


SecondaryPlot-Eigenschaft

True, wenn der Punkt sich im sekundären Abschnitt eines Kreis-aus-Kreis- oder eines Balken-aus-Kreis-Diagramms befindet. Gilt nur für Punkte von Kreis-aus-Kreis- bzw. Balken-aus-Kreis-Diagrammen. Boolean Schreib-Lese-Zugriff.


Beispiel zur Secondary Plot-Eigenschaft

Dieses Beispiel muss auf ein Kreis-aus-Kreis- oder auf ein Balken-aus-Kreis-Diagramm angewendet werden. Mit dem Beispiel wird der vierte Punkt in den sekundären Abschnitt des Diagramms verschoben.

With myChart.SeriesCollection(1)
    .Points(4).SecondaryPlot = True
End With


SecondPlotSize-Eigenschaft

Gibt die Größe des sekundären Abschnitts eines Kreis-aus-Kreis- oder eines Balken-aus-Kreis-Diagramms als Prozentsatz der Größe des primären Kreises zurück bzw. legt die Größe fest. Dies kann ein Wert von 5 bis 200 sein. Long Schreib-Lese-Zugriff.


Beispiel zur SecondPlotSize-Eigenschaft

Dieses Beispiel muss an einem Kreis-aus-Kreis- oder einem Balken-aus-Kreis-Diagramm ausgeführt werden. In diesem Beispiel werden die beiden Abschnitte des Diagramms nach Werten geteilt; dabei werden alle Werte unter 10 im primären Kreis zusammengefasst und im sekundären Abschnitt angezeigt. Die Größe des sekundären Abschnitts beträgt 50 Prozent der Größe des primären Kreises.

With myChart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
    .SecondPlotSize = 50
End With


SeriesLines-Eigenschaft

Gibt ein SeriesLines-Objekt zurück, das die Verbindungslinien des angegebenen gestapelten Balkendiagramms oder gestapelten Säulendiagramms darstellt. Gilt nur für gestapelte Balken- und Säulendiagramme. Schreibgeschützt.


Beispiel zur SeriesLines-Eigenschaft

In diesem Beispiel werden die Verbindungslinien der ersten Diagrammgruppe im Diagramm eingeschaltet und ihre Linienart, -stärke und -farbe festgelegt. Das Beispiel sollte bei einem gestapelten 2D-Säulendiagramm ausgeführt werden, das zwei oder mehr Datenreihen besitzt.

With myChart.ChartGroups(1)
    .HasSeriesLines = True
    With .SeriesLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


Shadow-Eigenschaft

True, wenn die Schriftart eine schattierte Schriftart ist oder wenn das angegebene Objekt einen Schatten hat. Boolean Schreib-Lese-Zugriff.

Anmerkung

Unter Microsoft Windows hat diese Eigenschaft beim Font-Objekt keine Wirkung. Ihr Wert wird jedoch gespeichert und kann festgelegt sowie gelesen werden.


Beispiel zur Shadow-Eigenschaft

In diesem Beispiel wird dem Titel von myChart ein Schatten hinzugefügt.

myChart.ChartTitle.Shadow = True


ShowChartTipNames-Eigenschaft

True, wenn in Diagrammen Namen von Diagrammtipps angezeigt werden. Die Standardeinstellung ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowChartTipNames-Eigenschaft

In diesem Beispiel werden die Namen und Werte von Diagrammtipps deaktiviert.

With myChart.Application
    .ShowChartTipNames = False
    .ShowChartTipValues = False
End With


ShowChartTipValues-Eigenschaft

True, wenn Diagrammtippwerte auf Diagrammen angezeigt werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowChartTipValues-Eigenschaft

In diesem Beispiel werden die Namen und Werte von Diagrammtipps deaktiviert.

With myChart.Application
    .ShowChartTipNames = False
    .ShowChartTipValues = False
End With


ShowLegendKey-Eigenschaft

True, wenn das Legendensymbol der Datenbeschriftung sichtbar ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowLegendKey-Eigenschaft

In diesem Beispiel werden die Datenbeschriftungen der ersten Datenreihe so eingestellt, dass die Werte und das Legendensymbol angezeigt werden.

With myChart.SeriesCollection(1).DataLabels
    .ShowLegendKey = True
    .Type = xlShowValue
End With


ShowNegativeBubbles-Eigenschaft

True, wenn für die Diagrammgruppe negative Blasen angezeigt werden. Dies gilt nur für Blasendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowNegativeBubbles-Eigenschaft

In diesem Beispiel werden für die erste Diagrammgruppe negative Blasen angezeigt.

myChart.ChartGroups(1).ShowNegativeBubbles = True


Size-Eigenschaft

Gibt den Schriftgrad zurück oder legt ihn fest. Variant Schreib-Lese-Zugriff.


SizeRepresents-Eigenschaft

Gibt zurück oder legt fest, was die Blasengröße in einem Blasendiagramm darstellen soll. Kann eine der beiden folgenden XlSizeRepresents-Konstanten sein: xlSizeIsArea oder xlSizeIsWidth. Long Schreib-Lese-Zugriff.


Beispiel zur SizeRepresents-Eigenschaft

In diesem Beispiel wird festgelegt, was die Blasengröße im Diagramm darstellen soll. (Es wird davon ausgegangen, dass es sich bei dem Diagramm um ein Blasendiagramm handelt.)

myChart.ChartGroups(1).SizeRepresents = xlSizeIsWidth


Smooth-Eigenschaft

True, wenn die Kurvenglättung für Linien- oder Punktdiagramme aktiviert ist. Dies gilt nur für Linien- und Punktdiagramme. Schreib-Lese-Zugriff.


Beispiel zur Smooth-Eigenschaft

In diesem Beispiel wird die Kurvenglättung für die erste Datenreihe aktiviert. Das Beispiel muss an einem 2D-Liniendiagramm ausgeführt werden.

myChart.SeriesCollection(1).Smooth = True


SplitType-Eigenschaft

Gibt die Art der Trennung der beiden Abschnitte eines Kreis-aus-Kreis- oder eines Balken-aus-Kreis-Diagramms zurück oder legt sie fest. Dies kann eine der folgenden XlChartSplitType-Konstanten sein: xlSplitByPosition, xlSplitByPercentValue, xlSplitByCustomSplit oder xlSplitByValue. Long Schreib-Lese-Zugriff.


Beispiel zur SplitType-Eigenschaft

Dieses Beispiel muss an einem Kreis-aus-Kreis- oder einem Balken-aus-Kreis-Diagramm ausgeführt werden. In diesem Beispiel werden die beiden Abschnitte des Diagramms nach Werten geteilt; dabei werden alle Werte unter 10 im primären Kreis zusammengefasst und im sekundären Abschnitt angezeigt.

With myChart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
End With


SplitValue-Eigenschaft

Gibt den Schwellenwert zurück, der die beiden Abschnitte eines Kreis-aus-Kreis- oder Balken-aus-Kreis-Diagramms trennt, oder legt den Schwellenwert fest. Variant Schreib-Lese-Zugriff.


Beispiel zur SplitValue-Eigenschaft

Dieses Beispiel muss an einem Kreis-aus-Kreis- oder einem Balken-aus-Kreis-Diagramm ausgeführt werden. In diesem Beispiel werden die beiden Abschnitte des Diagramms nach Werten geteilt; dabei werden alle Werte unter 10 im primären Kreis zusammengefasst und im sekundären Abschnitt angezeigt.

With myChart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
End With


Strikethrough-Eigenschaft

True, wenn die Schrift horizontal durchgestrichen ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur Strikethrough-Eigenschaft

In diesem Beispiel wird die Schrift des Diagrammtitels durchgestrichen formatiert.

myChart.ChartTitle.Font.Strikethrough = True


Subscript-Eigenschaft

True, falls die angegebene Schriftart tief gestellt formatiert werden soll. Der Standardwert ist False. Variant Schreib-Lese-Zugriff.


Superscript-Eigenschaft

True, falls die angegebene Schriftart hoch gestellt formatiert werden soll. Der Standardwert ist False. Variant Schreib-Lese-Zugriff.


SurfaceGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Oberflächendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur SurfaceGroup-Eigenschaft

In diesem Beispiel wird für alle Datenpunkte der Diagramme einer 3D-Oberflächendiagrammgruppe eine andere Farbe verwendet. Das Beispiel muss an einem 3D-Diagramm ausgeführt werden.

myChart.SurfaceGroup.VaryByCategories = True


Text-Eigenschaft

Gibt den Text des angegebenen Objekts zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


TextureName-Eigenschaft

Gibt den Namen der benutzerdefinierten Strukturdatei der angegebenen Füllung zurück. String Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die UserPicture- oder die UserTextured-Methode, um die Strukturdatei der Füllung festzulegen.


Beispiel zur TextureName-Eigenschaft

In diesem Beispiel wird im Füllungsformat des Diagramms die benutzerdefinierte Strukturart geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillTextured Then
        If .TextureType = msoTextureUserDefined Then
            If .TextureName = "brick.bmp" Then
               .UserTextured "stone.bmp"
            End If
        End If
    End If
End With


TextureType-Eigenschaft

Gibt die Strukturart der angegebenen Füllung zurück. Kann eine der folgenden MsoTextureType-Konstanten sein: msoTexturePreset, msoTextureTypeMixed oder msoTextureUserDefined. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die UserTextured-Methode, um die Strukturart der Füllung festzulegen.


Beispiel zur TextureType-Eigenschaft

In diesem Beispiel wird im Füllungsformat des Diagramms die benutzerdefinierte Strukturart geändert.

With myChart.ChartArea.Fill
    If .Type = msoFillTextured Then
        If .TextureType = msoTextureUserDefined Then
            If .TextureName = "C:\brick.bmp" Then
               .UserTextured "C:\stone.bmp"
            End If
        End If
    End If
End With


TickLabelPosition-Eigenschaft

Beschreibt die Position der Teilstrichbeschriftungen auf der angegebenen Achse. Dies kann eine der folgenden XlTickLabelPosition-Konstanten sein: xlTickLabelPositionNone, xlTickLabelPositionLow, xlTickLabelPositionHigh oder xlTickLabelPositionNextToAxis. Long Schreib-Lese-Zugriff.


Beispiel zur TickLabelPosition-Eigenschaft

In diesem Beispiel werden die Teilstrichbeschriftungen der Rubrikenachse nach oben gesetzt (über das Diagramm).

myChart.Axes(xlCategory) _
    .TickLabelPosition = xlTickLabelPositionHigh


TickLabels-Eigenschaft

Gibt eine TickLabels-Auflistung zurück, die die Teilstrichbeschriftungen der angegebenen Achse darstellt. Schreibgeschützt.


TickLabelSpacing-Eigenschaft

Gibt die Anzahl der Rubriken oder Datenreihen zwischen den Teilstrichbeschriftungen zurück oder legt sie fest. Gilt nur für Rubriken- und Datenreihenachsen. Long Schreib-Lese-Zugriff.

Anmerkung

Der Abstand der Teilstrichbeschriftungen auf der Größenachse wird stets von Microsoft Graph berechnet.


Beispiel zur TickLabelSpacing-Eigenschaft

In diesem Beispiel wird die Anzahl der Rubriken zwischen den Teilstrichbeschriftungen der Rubrikenachse berechnet.

myChart.Axes(xlCategory).TickLabelSpacing = 10


TickMarkSpacing-Eigenschaft

Gibt die Anzahl der Rubriken oder Datenreihen zwischen den Teilstrichen zurück oder legt sie fest. Gilt nur für Rubriken- und Datenreihenachsen. Long Schreib-Lese-Zugriff.

Anmerkung

Verwenden Sie die Eigenschaften MajorUnit und MinorUnit, um den Abstand der Teilstriche auf der Größenachse festzulegen.


Beispiel zur TickMarkSpacing-Eigenschaft

In diesem Beispiel wird die Anzahl der Rubriken zwischen den Teilstrichen der Rubrikenachse berechnet.

myChart.Axes(xlCategory).TickMarkSpacing = 10


 Top-Eigenschaft

Top-Eigenschaft

Gibt die Position des angegebenen Objekts in Punkten zurück oder legt sie fest. Long Lese-/Schreibzugriff (Ausnahmen siehe folgende Tabelle).

Anmerkungen

Die Bedeutung der Top-Eigenschaft hängt vom angegebenen Objekt ab.

Objekt | Bedeutung
Application | Der Abstand des oberen Bildschirmrands zum oberen Rand des Microsoft Graph-Hauptfensters. In Microsoft Windows legt diese Eigenschaft die Position des Symbols überall auf dem Bildschirm fest, wenn das Anwendungsfenster minimiert ist.
Axis, AxisTitle, ChartArea, Chart, ChartTitle, DataLabel, DataSheet, Legend, LegendEntry, LegendKey, PlotArea | Der Abstand vom oberen Rand des Objekts zum oberen Rand von Zeile 1 (in einem Tabellenblatt) oder zum oberen Rand des Diagrammbereichs (in einem Diagramm). Die Objekte Axis, ChartArea, LegendEntry und LegendKey sind schreibgeschützt.


Beispiel zur Top-Eigenschaft

In diesem Beispiel wird die Position des oberen Randes des Diagrammtitels festgelegt.

myChart.ChartTitle.Top = 10


TwoInitialCapitals-Eigenschaft

True, wenn Wörter, die mit zwei großgeschriebenen Buchstaben beginnen, automatisch korrigiert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur TwoInitialCapitals-Eigenschaft

In diesem Beispiel wird Microsoft Graph so eingestellt, dass Wörter mit zwei großgeschriebenen Anfangsbuchstaben automatisch korrigiert werden.

With myChart.Application.AutoCorrect
    .TwoInitialCapitals = True
    .ReplaceText = True
End With


Type-Eigenschaft

Gibt den Typ des angegebenen Objekts zurück oder legt ihn fest, wie in der folgenden Tabelle aufgezeigt wird.

Objekt | Typ
Axis | Achsentyp. Kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeriesAxis oder xlValue. Long Schreib-Lese-Zugriff.
ChartColoFormat | Farbtyp. Kann eine der folgenden MsoColorType-Konstanten sein: msoColorTypeMixed, msoColorTypeRGB oder msoColorTypeScheme. Long Schreibgeschützt.
DataLabel, DataLabels | Datenbeschriftungstyp. Kann eine der folgenden XlDataLabelsType-Konstanten sein: xlDataLabelsShowBubbleSizes, xlDataLabelsShowLabel, xlDataLabelsShowLabelAndPercent, xlDataLabelsShowNone, xlDataLabelsShowPercent oder xlDataLabelsShowValue. Long Schreib-Lese-Zugriff.
ChartFillFormat | Füllungstyp. Kann eine der folgenden MsoFillType-Konstanten sein: msoFillBackground, msoFillGradient, msoFillMixed, msoFillPatterned, msoFillPicture, msoFillSolid oder msoFillTextured. Long Schreibgeschützt.
Trendline | Trendlinientyp. Kann eine der folgenden XlTrendlineType-Konstanten sein: xlExponential, xlLinear, xlLogarithmic, xlMovingAvg, xlPolynomial oder xlPower. Long Schreib-Lese-Zugriff.


Beispiel zur Type-Eigenschaft

In diesem Beispiel wird der Trendlinientyp der ersten Datenreihe im Diagramm geändert. Besitzt die Datenreihe keine Trendlinie, schlägt dieses Beispiel fehl.

myChart.SeriesCollection(1).Trendlines(1).Type = xlMovingAvg


Underline-Eigenschaft

Gibt die Art der auf die Schrift angewendeten Unterstreichung zurück oder legt sie fest. Dies kann eine der folgenden XlUnderlineStyle-Konstanten sein: xlUnderlineStyleNone, xlUnderlineStyleSingle, xlUnderlineStyleDouble, xlUnderlineStyleSingleAccounting oder xlUnderlineStyleDoubleAccounting. Long Schreib-Lese-Zugriff.


Beispiel zur Underline-Eigenschaft

In diesem Beispiel wird der Diagrammtitel einfach unterstrichen formatiert.

myChart.ChartTitle.Font.Underline = xlUnderlineStyleSingle


UpBars-Eigenschaft

Gibt eine UpBars-Auflistung zurück, die die positiven Abweichungen in einem Liniendiagramm darstellt. Gilt nur für Liniendiagramme. Schreibgeschützt.


Beispiel zur UpBars-Eigenschaft

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe aktiviert und die zugehörigen Farben festgelegt. Es ist sinnvoll, dieses Makro auf ein 2D-Liniendiagramm mit zwei Datenreihen anzuwenden, die sich in wenigstens einem Datenpunkt schneiden.

With myChart.ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


Value-Eigenschaft

Gibt den Wert der angegebenen Zelle zurück. Wenn die Zelle leer ist, gibt Value den Wert Empty zurück (überprüfen Sie die Zelle dazu mit der Funktion IsEmpty). Wenn das Range-Objekt mehrere Zellen enthält, gibt diese Eigenschaft eine Wertematrix zurück (überprüfen Sie die Zelle dazu mit der Funktion IsArray). Schreib-Lese-Zugriff.


Beispiel zur Value-Eigenschaft

In diesem Beispiel wird der Wert der Zelle A1 im Tabellenblatt auf 3,14159 festgelegt.

myChart.Application.DataSheet.Range("A1").Value = 3.14159


VaryByCategories-Eigenschaft

True, wenn Microsoft Graph jedem Datenpunkt eine andere Farbe oder ein anderes Muster zuweist. Das Diagramm darf nur eine Datenreihe enthalten. Boolean Schreib-Lese-Zugriff.


Beispiel zur VaryByCategories-Eigenschaft

In diesem Beispiel wird jedem Datenpunkt in der ersten Diagrammgruppe eine andere Farbe oder ein anderes Muster zugewiesen. Es ist sinnvoll, das Makro auf ein 2D-Liniendiagramm anzuwenden, bei dem Datenpunkte für eine Datenreihe vorhanden sind.

myChart.ChartGroups(1).VaryByCategories = True


Version-Eigenschaft

Gibt die Versionsnummer von Microsoft Graph zurück. String Schreibgeschützt.


Beispiel zur Version-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Versionsnummer von Microsoft Graph und dem Namen des Betriebssystems angezeigt.

MsgBox "Welcome to Microsoft Graph version " & _
    myChart.Application.Version


VerticalAlignment-Eigenschaft

Gibt die vertikale Ausrichtung des angegebenen Objekts zurück oder legt sie fest. Dies kann eine der folgenden XlVAlign-Konstanten sein: xlVAlignBottom, xlVAlignCenter, xlVAlignDistributed, xlVAlignJustify oder xlVAlignTop. Variant Schreib-Lese-Zugriff.

Anmerkungen

Je nachdem, welche Sprachunterstützung (z. B. U.S. Englisch) ausgewählt oder installiert wurde, stehen Ihnen einige dieser Konstanten möglicherweise nicht zur Verfügung.


Beispiel zur VerticalAlignment-Eigenschaft

In diesem Beispiel wird der Diagrammtitel vertikal und zentriert ausgerichtet.

myChart.ChartTitle.VerticalAlignment = xlCenter


Visible-Eigenschaft

True, falls das angegebene Objekt sichtbar ist. Boolean oder Long Schreib-Lese-Zugriff.


Beispiel zur Visible-Eigenschaft

In diesem Beispiel wird die Füllung des Diagramms mit einem vordefinierten Farbverlauf formatiert und anschließend sichtbar gemacht.

With myChart.ChartArea.Fill
    .Visible = True
    .PresetGradient msoGradientDiagonalDown, _
         3, msoGradientBrass
End With


Walls-Eigenschaft

Gibt eine Walls-Auflistung zurück, die die Wände eines 3D-Diagramms darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft trifft nicht auf 3D-Kreisdiagramme zu.


WallsAndGridlines2D-Eigenschaft

True, wenn die Gitternetzlinien in einem 3D-Diagramm zweidimensional gezeichnet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur WallsAndGridlines2D-Eigenschaft

In diesem Beispiel zeichnet Microsoft Graph 2D-Gitternetzlinien im Diagramm.

myChart.WallsAndGridlines2D = True


Weight-Eigenschaft

Gibt die Stärke des Rahmens zurück oder legt sie fest. Dies kann eine der folgenden XlBorderWeight-Konstanten sein: xlHairline, xlThin, xlMedium oder xlThick. Long Schreib-Lese-Zugriff.


Beispiel zur Weight-Eigenschaft

In diesem Beispiel wird die Stärke des Rahmens für den Diagrammbereich festgelegt.

myChart.ChartArea.Border.Weight = xlMedium


 Width-Eigenschaft

Width-Eigenschaft

Gibt die Breite eines Objekts in Punkten zurück oder legt sie fest. Long Lese-/Schreibzugriff (Ausnahmen siehe folgende Tabelle).

Anmerkungen

Die Bedeutung der Width-Eigenschaft richtet sich nach dem angegebenen Objekt.

Objekt | Beschreibung
Application | Der Abstand zwischen linkem und rechtem Rand des Anwendungsfensters.
Axis, ChartArea, LegendEntry, LegendKey | Die Breite des Objekts. Schreibgeschützt.
Chart, DataSheet, Legend, PlotArea | Die Breite des Objekts.

Wenn Sie das Fenster minimieren, ist Application.Width schreibgeschützt und gibt die Breite des Fenstersymbols zurück.


Beispiel zur Width-Eigenschaft

In diesem Beispiel wird die Breite des Diagramms festgelegt.

myChart.Width = 360


WindowState-Eigenschaft

Gibt den Zustand des Fensters zurück oder legt ihn fest. Dies kann eine der folgenden XlWindowState-Konstanten sein: xlMaximized, xlMinimized oder xlNormal. Long Schreib-Lese-Zugriff.


Beispiel zur WindowState-Eigenschaft

In diesem Beispiel wird in Microsoft Graph das Anwendungsfenster maximiert.

myChart.Application.WindowState = xlMaximized


Aufrufen von Hilfe zu Macintosh-Schlüsselwörtern

Sie haben Hilfe für ein Visual Basic-Schlüsselwort angefordert, das nur auf dem Macintosh verwendet wird. Informationen zu diesem Schlüsselwort finden Sie in der Hilfe zur Sprachreferenz der Microsoft Office 98 Macintosh Edition.


Zurückgeben eines Objekts aus einer Auflistung

Die Item-Methode gibt ein einzelnes Objekt einer Auflistung zurück. Im folgenden Beispiel wird für die Variable ersterEintrag ein LegendEntry-Objekt festgelegt, das den ersten Legendeneintrag darstellt.

Set firstEntry = myChart.Legend.LegendEntries.Item(1)

Die Item-Methode ist für die meisten Auflistungen die Standardmethode. Sie können also die gleiche Anweisung durch Weglassen des Schlüsselwortes Item kürzer schreiben.

Set firstEntry = myChart.Legend.LegendEntries(1)

Weitere Informationen über eine bestimmte Auflistung finden Sie unter dem Hilfethema der Auflistung.


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Microsoft Office Visual Basic-Hilfe nicht gefunden werden kann, nicht installiert ist oder entfernt wurde.

So installieren Sie die Microsoft Office Visual Basic-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie in der Registerkarte Installieren/Deinstallieren auf die installierte Edition von Microsoft Office 2000, und klicken Sie dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Installationsoptionen anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Visual Basic für Applikationen-Hilfe nicht gefunden werden kann, nicht installiert ist oder entfernt wurde.

So installieren Sie die Visual Basic für Applikationen-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie in der Registerkarte Installieren/Deinstallieren auf die installierte Edition von Microsoft Office 2000, und klicken Sie dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann Office Tools in der Liste der Leistungsmerkmale.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Installationsoptionen anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Beispiel zur Add-Methode

In diesem Beispiel wird im Diagramm eine neue lineare Trendlinie erstellt.

myChart.SeriesCollection(1).Trendlines.Add


Beispiel zur Clear-Methode

In diesem Beispiel werden Formeln und Formatierungen im Zellbereich A1:G37 in der Tabelle gelöscht.

myChart.Application.DataSheet.Range("A1:G37").Clear

In diesem Beispiel wird die Diagrammfläche (die Diagrammdaten und die Formatierung) in Chart1 gelöscht.

myChart.ChartArea.Clear


Beispiel zur Delete-Methode

In diesem Beispiel wird der Zellbereich A1:D10 in der Tabelle gelöscht, und die verbleibenden Zellen werden nach links verschoben.

Set mySheet = myChart.Application.DataSheet
mySheet.Range("A1:D10").Delete Shift:=xlShiftToLeft

In diesem Beispiel wird der Diagrammtitel gelöscht.

myChart.ChartTitle.Delete


Beispiel zur BaseUnit-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse des Diagramms eine Zeitskala festgelegt, wobei Monate als Basiseinheiten verwendet werden.

With myChart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnit = xlMonths
    End With
End With


Beispiel zur Color-Eigenschaft

In diesem Beispiel wird die Farbe der Teilstrichbeschriftungen der Größenachse festgelegt.

myChart.Axes(xlValue).TickLabels.Font.Color = RGB(0, 255, 0)


Beispiel zur Crosses-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Größenachse die Rubrikenachse (x-Achse) in deren Maximum schneidet.

myChart.Axes(xlCategory).Crosses = xlMaximum


Beispiel zur DisplayUnit-Eigenschaft

Im folgenden Beispiel werden als Einheiten für die Größenachse in myChart Hunderter-Schritte festgelegt.

With myChart.Axes(xlValue)
    .DisplayUnit = xlHundreds
    .HasTitle = True
    .AxisTitle.Caption = "Rebate Amounts"
End With


Beispiel zur Font-Eigenschaft

In diesem Beispiel wird der Diagrammtitel mit einer Schrift von 14 Punkt fett und kursiv formatiert.

With myChart.ChartTitle.Font
    .Size = 14
    .Bold = True
    .Italic = True
End With


Beispiel zur HasDataLabel-Eigenschaft

In diesem Beispiel wird die Beschriftung für den siebten Datenpunkt der dritten Datenreihe aktiviert. Anschließend wird der Datenbeschriftung die Farbe Blau zugewiesen.

With myChart.SeriesCollection(3).Points(7)
    .HasDataLabel = True
    .ApplyDataLabels Type:=xlValue
    .DataLabel.Font.ColorIndex = 5
End With


Beispiel zur Height-Eigenschaft

In diesem Beispiel wird die Höhe der Diagrammlegende auf 1 Zoll (72 Punkt) festgelegt.

myChart.Legend.Height = 72


Beispiel zur Intercept-Eigenschaft

In diesem Beispiel wird festgelegt, dass die erste Trendlinie die Größenachse in Punkt 5 schneidet. Wenden Sie dieses Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

myChart.SeriesCollection(1).Trendlines(1).Intercept = 5


Beispiel zur Legend-Eigenschaft

In diesem Beispiel wird die Legende des Diagramms eingeschaltet und für ihre Schriftart die Farbe Blau festgelegt.

myChart.HasLegend = True
myChart.Legend.Font.ColorIndex = 5


Beispiel zur MajorUnit-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse festgelegt.

With myChart.Axes(xlValue)
    .MajorUnit = 100
    .MinorUnit = 20
End With


Beispiel zur MarkerBackgroundColor-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe festgelegt.

With myChart.SeriesCollection(1).Points(2)
    .MarkerBackgroundColor = RGB(0,255,0)    ' green
    .MarkerForegroundColor = RGB(255,0,0)    ' red
End With


Beispiel zur MarkerForegroundColor-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe festgelegt.

With myChart.SeriesCollection(1).Points(2)
    .MarkerBackgroundColor = RGB(0,255,0)    ' green
    .MarkerForegroundColor = RGB(255,0,0)    ' red
End With


Beispiel zur MaximumScale-Eigenschaft

In diesem Beispiel werden der niedrigste und der höchste Wert für die Größenachse festgelegt.

With myChart.Axes(xlValue)
    .MinimumScale = 10
    .MaximumScale = 120
End With


Beispiel zur MinimumScale-Eigenschaft

In diesem Beispiel werden der niedrigste und der höchste Wert für die Größenachse festgelegt.

With myChart.Axes(xlValue)
    .MinimumScale = 10
    .MaximumScale = 120
End With


Beispiel zur MinorUnit-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse festgelegt.

With myChart.Axes(xlValue)
    .MajorUnit = 100
    .MinorUnit = 20
End With


Beispiel zur Name-Eigenschaft

In diesem Beispiel wird der Variablen meinTrendname der Name der ersten Trendlinie zugewiesen.

myTrendname = myChart.SeriesCollection(1).Trendlines(1).Name


Beispiel zur NumberFormat-Eigenschaft

In diesem Beispiel wird das Zahlenformat für die Datenbeschriftungen der ersten Datenreihe festgelegt.

myChart.SeriesCollection(1).DataLabels.NumberFormat = "General"


Beispiel zur PatternColor-Eigenschaft

In diesem Beispiel wird die Musterfarbe für den Innenbereich des Diagrammbereichs festgelegt.

myChart.ChartArea.Interior.PatternColor = RGB(255,0,0)


Beispiel zur Pattern-Eigenschaft

In diesem Beispiel erhält der Innenbereich der Zeichnungsfläche eine Kreuzschraffur.

myChart.PlotArea.Interior.Pattern = xlPatternCrissCross


Beispiel zur Size-Eigenschaft

In diesem Beispiel wird der Schriftgrad des Diagrammtitels festgelegt.

myChart.ChartTitle.Font.Size = 12


Beispiel zur Text-Eigenschaft

In diesem Beispiel wird der Text für den Titel des Diagramms festgelegt.

With myChart
    .HasTitle = True
    .ChartTitle.Text = "First Quarter Sales"
End With

In diesem Beispiel wird der Text des Titels der Rubrikenachse festgelegt.

With myChart.Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "Month"
End With


Beispiel zur TickLabels-Eigenschaft

In diesem Beispiel wird die Farbe der Teilstrichbeschriftung für die Größenachse festgelegt.

myChart.Axes(xlValue).TickLabels.Font.ColorIndex = 3


Beispiel zur Walls-Eigenschaft

In diesem Beispiel wird den Kanten der Wände die Farbe Rot zugewiesen. Es ist sinnvoll, das Makro auf ein 3D-Diagramm anzuwenden.

myChart.Walls.Border.ColorIndex = 3


Microsoft Graph-Objekte (ChartGroup)

Pfeil nach oben

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Pfeil nach oben Klicken Sie auf den Pfeil, um zum vorhergehenden Diagramm zurückzukehren.


Sprachspezifische Informationen

Sprachspezifische Hilfethemen gelten nur, wenn das sprachspezifische Feature zur Verfügung steht. Informieren Sie sich, wie Sie in einer anderen Sprache arbeiten oder die Korrekturhilfen für eine andere Sprache installieren, oder fragen Sie Ihre Systemadministration nach weiteren Einzelheiten.