Neuigkeiten für Microsoft PowerPoint 2000-Entwickler

Um die neuen und verbesserten Funktionen der Anwendung zu unterstützen, wurden zahlreiche Veränderungen am Objektmodell von Visual Basic für Microsoft PowerPoint 2000 vorgenommen.

Bereiche der neuen Merkmale

Unter den folgenden Themen finden Sie Informationen zur Konzeption der wesentlichen neuen Funktionen im Objektmodell von PowerPoint 2000:

Add-Ins für das Component Object Model (COM)

Verwenden von Ereignissen mit dem Application-Objekt

Arbeiten mit Tabellen

Arbeiten mit Ausschnitten und Ansichten

Veröffentlichen von Webpräsentationen

Neue Sprachelemente

Unter den folgenden Themen finden Sie Listen der neuen Sprachelemente in PowerPoint 2000:

Neue Objekte

Neue Eigenschaften (nach Objekten)

Neue Eigenschaften (alphabetisch)

Neue Methoden (nach Objekten)

Neue Methoden (alphabetisch)

Neue Ereignisse

Sprachspezifische Eigenschaften und Methoden

Verborgene Sprachelemente

Unter dem folgenden Thema finden Sie eine Liste der verborgenen Eigenschaften in PowerPoint 2000.

Verborgene Eigenschaften


Verwenden von Ereignissen mit dem Application-Objekt

Um eine Ereignis-Behandlungsroutine für ein Application-Objekt zu erstellen, müssen Sie die drei folgenden Schritte ausführen:

  1. Deklarieren Sie eine Objektvariable in einem Klassenmodul für die Behandlung der Ereignisse.

  2. Verfassen Sie die spezifischen Ereignisprozeduren.

  3. Initialisieren Sie das deklarierte Objekt aus einem anderen Modul.

Deklarieren der Objektvariablen

Bevor Sie Prozeduren für die Ereignisse des Application-Objekts verfassen können, müssen Sie ein neues Klassenmodul erstellen und ein Objekt des Typs Application mit Ereignissen deklarieren. Angenommen, Sie erstellen ein neues Klassenmodul und nennen es EventClassModule. Das neue Klassenmodul enthält den folgenden Code:

Public WithEvents App As Application

Schreiben der Ereignisprozeduren

Nach dem Deklarieren des neuen Objekts mit Ereignissen wird es in der Object-Liste im Klassenmodul aufgeführt, und Sie können Ereignisprozeduren für das neue Objekt schreiben. (Wenn Sie das neue Objekt in der Object-Liste auswählen, werden die gültigen Ereignisse für dieses Objekt in der Procedure-Liste aufgeführt.) Wählen Sie ein Ereignis aus der Procedure-Liste aus. Dem Klassenmodul wird eine leere Prozedur hinzugefügt:

Private Sub App_NewPresentation()

End Sub

Initialisieren des deklarierten Objekts

Um die Prozedur zu initialisieren, müssen Sie das deklarierte Objekt im Klassenmodul mit dem Application-Objekt verknüpfen. Dies ist mit dem folgenden Code aus einem beliebigen Modul möglich:

Dim X As New EventClassModule
Sub InitializeApp()
    Set X.App = Application
End Sub

Führen Sie die Prozedur InitializeApp aus. Nach dem Ausführen der Prozedur zeigt das App-Objekt im Klassenmodul auf das Microsoft PowerPoint Application-Objekt. Fortan werden die Ereignisprozeduren im Klassenmodul bei Eintreten der Ereignisse ausgeführt.


Arbeiten mit Formen (Zeichnungsobjekte)

Formen oder Zeichnungsobjekte werden durch drei verschiedene Objekte dargestellt: die Shapes-Auflistung, die ShapeRange-Auflistung und das Shape-Objekt. In der Regel wird die Shapes-Auflistung verwendet, um Formen zu erstellen und alle Formen einer Folie zu durchlaufen. Mit dem Shape-Objekt können Sie eine einzelne Form bearbeiten. Mit der ShapeRange-Auflistung können Sie mehrere Formen auf die gleiche Weise bearbeiten wie mehrere markierte Formen in der Benutzeroberfläche.

Festlegen der Eigenschaften für eine Form

Viele Formateigenschaften von Formen werden nicht durch Eigenschaften festgelegt, die direkt für das Shape- oder ShapeRange-Objekt gelten. Stattdessen werden verwandte Formattribute unter sekundären Objekten gruppiert. Dies gilt z. B. für das FillFormat-Objekt, das alle Eigenschaften enthält, die sich auf die Füllung der Form oder des LinkFormat-Objekts beziehen, das wiederum alle Eigenschaften enthält, die sich eindeutig auf verknüpfte OLE-Objekte beziehen. Um Eigenschaften für eine Form festzulegen, müssen Sie zuerst das Objekt zurückgeben, das den Satz mit verwandten Formattributen darstellt, und anschließend die Eigenschaften des zurückgegebenen Objekts festlegen. So können Sie z. B. die Fill-Eigenschaft verwenden, um das FillFormat-Objekt zurückzugeben. Anschließend können Sie die ForeColor-Eigenschaft des FillFormat-Objekts festlegen, um die Vordergrundfarbe der Füllung für die angegebene Form festzulegen. Dies wird im folgenden Beispiel gezeigt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).Fill.ForeColor.RGB = RGB(255, 0, 0)

Gleichzeitiges Anwenden einer Eigenschaft oder Methode auf verschiedene Formen

In der Benutzeroberfläche gibt es einige Operationen, die Sie mit mehreren gleichzeitig markierten Formen ausführen können. So können Sie z. B. verschiedene Formen markieren und deren individuelle Füllungen gleichzeitig festlegen. Es gibt andere Operationen, die Sie nur mit einer einzelnen markierten Form ausführen können. So können Sie z. B. nur dann den Text in einer Form bearbeiten, wenn eine einzelne Form markiert ist.

In Visual Basic haben Sie zwei Möglichkeiten, Eigenschaften und Methoden auf einen Satz von Formen anzuwenden. Dadurch können Sie jede Operation, die Sie bei einer einzelnen Form ausführen können, auch bei einem Formbereich ausführen. Es ist dabei nicht von Bedeutung, ob Sie die gleiche Operation auch in der Benutzeroberfläche ausführen können.

  • Wenn sich die Operation bei mehreren markierten Formen in der Benutzeroberfläche ausführen lässt, können Sie die gleiche Operation auch in Visual Basic ausführen, indem Sie eine ShapeRange-Auflistung erstellen, die die gewünschten Formen enthält. Anschließend können Sie die geeigneten Eigenschaften und Methoden direkt auf die ShapeRange-Auflistung anwenden.

  • Wenn sich die Operation nicht bei mehreren markierten Formen in der Benutzeroberfläche ausführen lässt, können Sie die Operation trotzdem in Visual Basic ausführen, indem Sie die Shapes-Auflistung oder eine ShapeRange-Auflistung durchlaufen, die die gewünschten Formen enthält. Anschließend können Sie die geeigneten Eigenschaften und Methoden auf die einzelnen Shape-Objekte in der Auflistung anwenden.

Es schlagen viele Eigenschaften und Methoden fehl, die für das Shape-Objekt und die ShapeRange-Auflistung gelten, wenn diese auf bestimmte Formenarten angewendet werden. So schlägt z. B. die TextFrame-Eigenschaft fehl, wenn sie auf eine Form angewendet wird, die keinen Text enthalten kann. Wenn nicht sicher ist, dass eine bestimmte Eigenschaft oder Methode auf alle Formen einer ShapeRange-Auflistung angewendet werden kann, dann wenden Sie die Eigenschaft oder Methode nicht auf die ShapeRange-Auflistung an. Wenn Sie eine dieser Eigenschaften oder Methoden auf eine Auflistung mit Formen anwenden möchten, müssen Sie zuvor die Auflistung durchlaufen und jede einzelne Form prüfen. Dadurch können Sie sich vergewissern, dass es sich um einen geeigneten Formentyp handelt, bevor Sie die Eigenschaft oder die Methode auf diesen Typ anwenden.

Anwenden einer Eigenschaft oder Methode auf eine ShapeRange-Auflistung

Können Sie eine Operation bei mehreren markierten Formen in der Benutzeroberfläche gleichzeitig ausführen, so können Sie auch die programmtechnische Entsprechung ausführen, indem Sie eine ShapeRange-Auflistung erstellen und anschließend die geeigneten Eigenschaften oder Methoden auf diese Auflistung anwenden. Im folgenden Beispiel wird ein Formbereich erstellt, der die AutoFormen "Big Star" und "Little Star" von myDocument enthält, und diesem eine Verlaufsfüllung zugewiesen.

Set myDocument = ActivePresentation.Slides(1)
Set myRange = myDocument.Shapes _
    .Range(Array("Big Star", "Little Star"))
myRange.Fill.PresetGradient msoGradientHorizontal, _
    1, msoGradientBrass

Die folgenden allgemeinen Richtlinien erläutern das Verhalten von Eigenschaften und Methoden, wenn diese auf eine ShapeRange-Auflistung angewendet werden.

  • Das Anwenden einer Methode auf eine Auflistung entspricht dem Anwenden der Methode auf jedes einzelne Shape-Objekt in dieser Auflistung.

  • Das Festlegen des Wertes einer Eigenschaft der Auflistung entspricht dem Festlegen des Wertes der Eigenschaft für jede einzelne Form in diesem Bereich.

  • Eine Eigenschaft der Auflistung, die eine Konstante zurückgibt, gibt den Wert der Eigenschaft für eine individuelle Form in der Auflistung zurück, wenn alle Formen der Auflistung den gleichen Wert für diese Eigenschaft besitzen. Ist Letzteres nicht der Fall, wird die "gemischte" Konstante zurückgegeben.

  • Eine Eigenschaft der Auflistung, die einen einfachen Datentyp (z. B. Long, Single oder String) zurückgibt, gibt den Wert der Eigenschaft für eine einzelne Form zurück, wenn alle Formen der Auflistung den gleichen Wert für diese Eigenschaft besitzen.

  • Der Wert einiger Eigenschaften kann nur dann zurückgegeben oder festgelegt werden, wenn die Auflistung genau eine Form besitzt. Befinden sich mehrere Formen in der Auflistung, wird ein Laufzeitfehler generiert. Dies ist in der Regel der Fall, wenn Eigenschaften zurückgegeben oder festgelegt werden, bei denen die Entsprechung in der Benutzeroberfläche nur bei einer einzelnen Form ausgeführt werden kann (z. B. beim Bearbeiten von Text in einer Form oder beim Bearbeiten der Punkte einer Freihandform).

Die obigen Richtlinien gelten auch dann, wenn Sie Eigenschaften von Formen festlegen, die Untergruppierungen von sekundären Objekten der ShapeRange-Auflistung darstellen, z. B. das FillFormat-Objekt. Stellt das sekundäre Objekt Operationen dar, die bei mehreren markierten Objekten in der Benutzeroberfläche ausgeführt werden können, können Sie das Objekt aus einer ShapeRange-Auflistung zurückgeben und dessen Eigenschaften festlegen. So können Sie z. B. mit der Fill-Eigenschaft das FillFormat-Objekt zurückgeben, das die Füllungen aller Formen in der ShapeRange-Auflistung darstellt. Wenn Sie die Eigenschaften von diesem FillFormat-Objekt festlegen, werden auch die gleichen Eigenschaften aller individuellen Formen in der ShapeRange-Auflistung festgelegt.

Durchlaufen einer Shapes- oder ShapeRange-Auflistung

Auch wenn Sie eine Operation bei verschiedenen Formen in der Benutzeroberfläche nicht gleichzeitig ausführen können, indem Sie die Formen markieren und anschließend einen Befehl verwenden, so haben Sie doch die Möglichkeit, die Entsprechung programmtechnisch auszuführen, indem Sie zuerst die Shapes-Auflistung oder eine ShapeRange-Auflistung durchlaufen, die die gewünschten Formen enthält, und anschließend die geeigneten Eigenschaften und Methoden auf die einzelnen Shape-Objekte in der Auflistung anwenden. Im folgenden Beispiel werden alle Formen von myDocument durchlaufen und jeder Form, bei der es sich um eine AutoForm handelt, Text hinzugefügt.

Set myDocument = ActivePresentation.Slides(1)
For Each sh In myDocument.Shapes
    If sh.Type = msoAutoShape Then
            sh.TextFrame.TextRange.InsertAfter " (version 1)"
    End If
Next

Im folgenden Beispiel wird eine ShapeRange-Auflistung erstellt, die alle aktuell markierten Formen im aktiven Fenster enthält, und der Text in jeder Form der Auflistung festgelegt, die Text enthalten kann.

For Each sh in ActiveWindow.Selection.ShapeRange
    If sh.HasTextFrame Then
        sh.TextFrame.TextRange = "Initially selected"
    End If
Next

Ausrichten, Verteilen und Gruppieren von Formen in einem Formbereich

Mit den Align- und Distribute-Methoden können Sie einen Satz Formen relativ zueinander oder zum Dokument positionieren. Mit der Group-Methode oder der Regroup-Methode können Sie aus einem Satz Formen eine einzelne gruppierte Form bilden.


Arbeiten mit Tabellen

In Microsoft PowerPoint 2000 können Sie Tabellen erstellen, ohne dass sie aus Microsoft Word importiert werden müssen. Tabellen sind Elemente der Shapes-Auflistung. Jede Zelle, Spalte und Zeile in einer Tabelle stellt ein separates, über das Makro ansprechbares Objekt dar.

Erstellen einer Tabelle

Wenn Sie eine Tabelle auf einer Folie erstellen möchten, verwenden Sie die AddTable-Methode. Mit dieser Methode wird der Shapes-Auflistung eine Tabelle mit der durch das NumRows-Argument und das NumColumns-Argument festgelegten Anzahl von Zeilen und Spalten hinzugefügt. In diesem Beispiel wird Folie 2 eine Tabelle mit drei Zeilen und vier Spalten hinzugefügt.

ActivePresentation.Slides(2).Shapes _
    .AddTable NumRows:=3, NumColumns:=4, Left:=10, _
    Top:=10, Width:=288, Height:=288

Überprüfen, ob eine Form eine Tabelle ist

Ehe Sie mit dem Inhalt und den Objekten in einer Tabelle arbeiten können, müssen Sie zunächst feststellen, ob die betreffende Form eine Tabelle ist. Um festzustellen, ob eine Form eine Tabelle ist, verwenden Sie die HasTable-Eigenschaft. Angenommen, Folie 1 verfügt über viele Formen, und Sie wissen, dass eine von ihnen eine Tabelle ist. Sie möchten die Größe dieser Tabelle anpassen, so dass die Daten, die aus einer anderen Quelle importiert werden sollen, vollständig aufgenommen werden können. Mit diesem Code wird die Shapes-Auflistung auf Folie 2 durchlaufen, um die Tabelle zu finden. Danach wird die Breite der Spalten angepasst.

With ActivePresentation.Slides(2)
    For sh = 1 To .Shapes.Count
        If .Shapes(sh).HasTable Then
            For Each col In .Shapes(sh).Table.Columns
                col.Width = 110
            Next col
        End If
    Next
End With

Arbeiten mit Zellen, Spalten und Zeilen

Um den Inhalt und die Eigenschaften einer einzelnen Spalte oder Zeile zurückzugeben, verwenden Sie ein bestimmtes Element der Columns-Auflistung oder der Rows-Auflistung. Die Cell-Methode gibt ein einzelnes Cell-Objekt innerhalb eines Table-Objekts zurück. In diesem Beispiel werden verschiedene Attribute der Tabelle (dargestellt durch Form 5 auf Folie 2) geändert. Die Farbe von Zeile 2, die Breite von Spalte 1 sowie der Text der Zelle in Zeile 2 / Spalte 1 werden geändert.

With ActivePresentation.Slides(2).Shapes(4).Table
    For Each cl In .Rows(2).Cells
        cl.Shape.Fill.ForeColor.RGB = RGB(50, 125, 0)
    Next cl
    .Columns(1).Width = 110
    .Cell(2, 1).Shape.TextFrame.TextRange.Text = "Mallard"
End With


 Arbeiten mit Fensterausschnitten und Ansichten

Arbeiten mit Fensterausschnitten und Ansichten

Alle in Microsoft PowerPoint 97 verfügbaren Ansichten sind auch in PowerPoint 2000 verfügbar. Die Normalansicht (die Standardansicht des Dokumentfensters) enthält jetzt aber drei Fensterausschnitte, deren Größe angepasst werden kann (siehe folgende Tabelle).

Fensterausschnitt | Indexnummer
Gliederung | 1
Folie | 2
Notizen | 3

Die Normalansicht ist die einzige Ansicht, die über mehrere Fensterausschnitte verfügt. Alle anderen Ansichten verfügen lediglich über einen Fensterausschnitt. Alle Fensterausschnitte sind Elemente der Panes-Auflistung.

Ändern der aktiven Ansicht

Sie können die aktuelle Ansicht im aktiven Dokumentfenster mit der ViewType-Eigenschaft zurückgeben oder festlegen. In diesem Beispiel wird als aktuelle Ansicht im aktiven Dokumentfenster die Folienansicht festgelegt.

ActiveWindow.ViewType = ppViewSlide

Wechseln zwischen Fensterausschnitten in der Normalansicht

In der Normalansicht können Sie die ViewType-Eigenschaft mit dem aktiven Pane-Objekt verwenden, um den aktiven Fensterausschnitt zurückzugeben. Die ViewType-Eigenschaft gibt eine der folgenden PpViewType-Konstanten zurück, die den aktiven Fensterausschnitt angeben: ppViewNotesPage, ppViewOutline oder ppViewSlide. Alle anderen Ansichten verfügen nur über einen Fensterausschnitt, und die ViewType-Eigenschaft gibt für die PpViewType-Konstante denselben Wert wie das aktive Dokumentfenster zurück.

Sie können einen Fensterausschnitt aktivieren, indem Sie die ViewType-Eigenschaft festlegen oder die Activate-Methode verwenden. In diesem Beispiel wird der Wert der ViewType-Eigenschaft zurückgegeben, um die aktive Ansicht und den aktiven Fensterausschnitt festzustellen. Wenn die aktive Ansicht die Normalansicht und der aktive Fensterausschnitt das Notizenfeld ist, wird mit der Activate-Methode das Folienfeld aktiviert.

With ActiveWindow
    If .ViewType = ppViewNormal and _
            .ActivePane.ViewType = ppViewNotesPage Then
        .Panes(2).Activate
    End If
End With

Anpassen der Größe von Fensterausschnitten

Sie können die SplitHorizontal-Eigenschaft und die SplitVertical-Eigenschaft verwenden, um die Fensterteiler in der Normalansicht auf den angegebenen Prozentsatz des verfügbaren Dokumentfensters zu setzen. Damit wird die Größe der Fensterausschnitte zu beiden Seiten des entsprechenden Fensterteilers geändert. Der Höchstwert für diese Eigenschaften liegt stets unter 100 Prozent, da für das Folienfeld eine Mindestgröße festgelegt ist, die auf einer Zoomstufe von 10 Prozent beruht. In diesem Beispiel wird der Prozentsatz der verfügbaren Höhe des Dokumentfensters so eingestellt, dass das Folienfeld auf 65 Prozent erweitert wird. Für das Notizenfeld verbleiben also 35 Prozent der verfügbaren Höhe.

ActiveWindow.SplitVertical = 65


Veröffentlichen einer Webpräsentation

Mit Microsoft PowerPoint 2000 können Sie eine Präsentation direkt auf einem Webserver veröffentlichen und HTML-Dokumente direkt in PowerPoint bearbeiten.

Speichern einer Präsentation als Webseite

Wenn Sie eine Präsentation als Webseite speichern, erstellen und speichern Sie eine HTML-Version dieser Präsentation. Verwenden Sie dazu die SaveAs-Methode, wie im folgenden Beispiel dargestellt, in dem die aktuelle Präsentation als C:\Myfile.htm gespeichert wird.

ActivePresentation.SaveAs "c:\myfile.htm", ppSaveAsHTMLv3, msoTrue

Veröffentlichen einer Webpräsentation

Wenn Sie eine Webpräsentation veröffentlichen, erstellen Sie eine HTML-Version einer Präsentation und speichern diese Version anschließend unter Verwendung der Publish-Methode auf einem Webserver oder Dateiserver. Der Unterschied zum Speichern einer Präsentation als Webseite mit der SaveAs-Methode liegt darin, dass die Präsentation beim Veröffentlichen als Webpräsentation durch Festlegen von verschiedenen Attributen angepasst werden kann. Außerdem kann die Präsentation direkt auf einem Webserver veröffentlicht werden. Im folgenden Beispiel werden zunächst verschiedene Eigenschaften des WebOptions-Objekts festgelegt. Anschließend wird die aktive Präsentation auf einem Webserver mit der URL-Adresse http://www.someones.homepage/mallard.htm veröffentlicht.

With ActivePresentation
    With .WebOptions
        .FrameColors = ppFrameColorsWhiteTextOnBlack
        .RelyonVML = True
        .OrganizeInFolder = True
    End With
    With .PublishObjects(1)
        .FileName = "http://www.someones.homepage/mallard.htm"
        .SourceType = ppPublishAll
        .SpeakerNotes = True
        .Publish
    End With
End With

Weboptionen und Standardweboptionen

Wenn Sie die Publish-Methode verwenden, können Sie durch Einstellen der Eigenschaften des DefaultWebOptions-Objekts und des WebOptions-Objekts das Erscheinungsbild, den Inhalt, die unterstützten Browser, die Unterstützung von Bearbeitungsfunktionen, das Grafikformat, die Bildschirmauflösung, die Dateiorganisation sowie die Codierung des HTML-Dokuments anpassen. Das DefaultWebOptions-Objekt enthält Eigenschaften auf Anwendungsebene. Diese werden durch alle Einstellungen für die Eigenschaften auf Präsentationsebene im WebOptions-Objekt überschrieben, wenn diese denselben Namen aufweisen.

In diesem Beispiel werden verschiedene Eigenschaften auf Anwendungsebene für das Veröffentlichen im Web festgelegt. Diese stellen dann die Standardeinstellungen für alle aktuell oder zukünftig geladenen Präsentationen dar, bis die Einstellungen erneut geändert werden. Der Code stellt dann die ResizeGraphics-Eigenschaft für die aktive Präsentation ein, wodurch die Standardeinstellung auf Anwendungsebene überschrieben wird. Die aktive Präsentation wird als C:\Mallard.htm veröffentlicht.

With Application.DefaultWebOptions
    .FrameColors = ppFrameColorsWhiteTextOnBlack
    .IncludeNavigation = False
    .ResizeGraphics = True
End With
With ActivePresentation
    .WebOptions.ResizeGraphics = False
    With .PublishObjects(1)
        .FileName = "c:\mallard.htm"
        .SourceType = ppPublishAll
        .SpeakerNotes = True
        .Publish
    End With
End With

Öffnen eines HTML-Dokuments in PowerPoint

Wenn Sie ein HTML-Dokument in PowerPoint bearbeiten möchten, öffnen Sie das HTML-Dokument mit der Open-Methode. In diesem Beispiel wird die Datei Myfile.htm zum Bearbeiten geöffnet.

Presentations.Open Filename:="c:\Windows\myfile.htm"


 Verwenden von ActiveX-Steuerelementen bei Folien

Verwenden von ActiveX-Steuerelementen bei Folien

Sie können ihren Folien Steuerelemente hinzufügen, womit Sie während einer Bildschirmpräsentation Informationen mit dem Benutzer auf professionelle Art und Weise austauschen können. So können Sie z. B. Steuerelemente bei Folien verwenden, damit die Betrachter einer Bildschirmpräsentation für einen Kiosk Optionen auswählen und anschließend eine benutzerdefinierte Präsentation starten können, die auf der jeweiligen Auswahl des Betrachters basiert.

Informationen über das Hinzufügen und Bearbeiten von Steuerelementen finden Sie unter Verwenden von ActiveX-Steuerelementen bei Dokumenten und Erstellen eines benutzerdefinierten Dialogfelds.

Beachten Sie bei Arbeiten mit Steuerelementen auf Folien folgendes.

  • Ein Steuerelement ist auf einer Folie immer dann im Design-Modus, wenn die Bildschirmpräsentation nicht abläuft.

  • Soll ein Steuerelement auf allen Folien einer Präsentation erscheinen, fügen Sie es dem Folienmaster hinzu.

  • In einer Ereignisprozedur für ein Steuerelement auf einer Folie bezieht sich das Schlüsselwort Me nicht auf das Steuerelement, sondern auf die Folie.

Das Schreiben von Ereigniscodes für Steuerelemente auf Folien ist nahezu gleichbedeutend mit dem Schreiben von Ereigniscodes für Steuerelemente auf Formularen. Die folgende Prozedur legt den Hintergrund für die Folie fest, dessen Schaltfläche "cmdChangeColor" aktiv ist, sobald auf die Schaltfläche geklickt wird.

Private Sub cmdChangeColor_Click()
    With Me
        .FollowMasterBackground = Not .FollowMasterBackground
        .Background.Fill.PresetGradient _
            msoGradientHorizontal, 1, msoGradientBrass
    End With
End Sub

Sie können Steuerelemente verwenden, damit Ihre Bildschirmpräsentation über Navigationswerkzeuge verfügt, die komlexer als die integrierten Werkzeuge von PowerPoint sind. So können Sie z. B. die beiden Schaltflächen "cmdBack" und "cmdForward" dem Folienmaster hinzufügen und den nachfolgenden Code anhängen. Alle Folien, die auf diesem Master basieren (und für die festgelegt wird, dass Hintergrundgrafiken des Masters angezeigt werden) werden über diese professionellen Navigationsschaltflächen verfügen, die während einer Bildschirmpräsentation aktiv sind.

Private Sub cmdBack_Click()
    Me.Parent.SlideShowWindow.View.Previous
End Sub

Private Sub cmdForward_Click()
    Me.Parent.SlideShowWindow.View.Next
End Sub

Um mit allen ActiveX-Steuerelementen einer Folie arbeiten zu können, ohne dass die anderen Formen der Folie davon betroffen sind, können Sie eine ShapeRange-Auflistung erstellen, die ausschließlich Steuerelemente enthält. Sie können anschließend Eigenschaften und Methoden der gesamten Auflistung zuweisen oder die Auflistung durchlaufen, um mit jedem Steuerelement individuell arbeiten zu können. Das folgende Beispiel richtet alle Steuerelemente von Folie 1 in der aktiven Präsentation aus und verteilt sie vertikal.

With ActivePresentation.Slides(1).Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numControls = 0
        ReDim ctrlArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoOLEControlObject Then
                numControls = numControls + 1
                ctrlArray(numControls) = .Item(i).Name
            End If
        Next
        If numControls > 1 Then
            ReDim Preserve ctrlArray(1 To numControls)
            Set ctrlRange = .Range(ctrlArray)
            ctrlRange.Distribute msoDistributeVertically, True
            ctrlRange.Align msoAlignLefts, True
        End If
    End If
End With


Verwenden von ActiveX-Steuerelementen in einem Dokument

Genauso wie Sie benutzerdefinierten Dialogfeldern ActiveX-Steuerelemente hinzufügen können, können Sie zu Dokumenten direkt Steuerelemente hinzufügen. So können Benutzer direkt auf Makros zugreifen, ohne dazu Dialogfelder aufrufen zu müssen. Verwenden Sie das folgende Verfahren, um Ihrem Dokument ActiveX-Steuerelemente hinzuzufügen. Weitere Informationen über die Verwendung von ActiveX-Steuerelementen in PowerPoint finden Sie unter Verwenden von ActiveX-Steuerelementen bei Folien.

  1. Hinzufügen von Steuerelementen zu einem Dokument

    Blenden Sie die Steuerelement-Toolbox ein, und klicken Sie erst auf das hinzuzufügende Steuerelement und dann auf das Dokument.

  2. Setzen der Eigenschaften von Steuerelementen

    Klicken Sie im Entwurfsmodus mit der rechten Maustaste auf ein Steuerelement, und klicken Sie dann auf Eigenschaften, um das Eigenschaftenfenster einzublenden.

  3. Initialisieren der Eigenschaften von Steuerelementen

    Sie können Steuerelemente in einer Prozedur initialisieren.

  4. Ereignisse von Steuerelementen und Dialogfeldern

    Alle Steuerelemente verfügen über einen vordefinierten Satz von Ereignissen. So verfügt beispielsweise eine Befehlsschaltfläche über ein Click-Ereignis, das eintritt, wenn der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren verfassen, die ausgeführt werden, wenn das betreffende Ereignis eintritt.

  5. Verwenden der Werte von Steuerelementen, während der Code läuft

    Einige Eigenschaften können während der Laufzeit festgelegt werden.


Erstellen eines benutzerdefinierten Dialogfelds

Mit der folgenden Prozedur können Sie ein benutzerdefiniertes Dialogfeld erstellen:

  1. Erstellen eines UserForm

    Klicken Sie im Menü Einfügen im Visual Basic Editor auf UserForm.

  2. Hinzufügen von Steuerelementen zum UserForm

    Suchen Sie das Steuerelement, das der Toolbox hinzugefügt werden soll, und ziehen Sie das Steuerelement auf das Formular.

  3. Festlegen von Eigenschaften von Steuerelementen

    Klicken Sie mit der rechten Maustaste auf ein Steuerelement im Design-Modus, und klicken Sie auf Eigenschaften, um das Fenster Eigenschaften zu öffnen.

  4. Initialisieren der Steuerelemente

    Sie können die Steuerelemente in einer Prozedur initialisieren, bevor Sie ein Formular anzeigen. Sie können aber auch dem Initialize-Ereignis des Formulars einen Code hinzufügen.

  5. Schreiben von Ereignisprozeduren

    Alle Steuerelemente haben einen vordefinierten Ereignissatz. So hat z. B. eine Befehlsschaltfläche ein Klick-Ereignis, das auftritt, wenn der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren schreiben, die dann ablaufen, wenn die Ereignisse auftreten.

  6. Anzeigen des Dialogfelds

    Mit der Show-Methode können Sie ein UserForm anzeigen.

  7. Verwenden von Steuerelementwerten während des Ablaufs des Code

    Einige Eigenschaften können Sie zum Zeitpunkt der Laufzeit festlegen. Änderungen, die vom Benutzer am Dialogfeld vorgenommen werden, gehen verloren, wenn das Dialogfeld geschlossen wird.


 Steuern einer Microsoft Office-Anwendung aus einer anderen heraus

Steuern einer Microsoft Office-Anwendung aus einer anderen heraus

Soll Ihr Code in einer Microsoft Office-Anwendung ablaufen, die mit Objekten in einer anderen Anwendung arbeitet, befolgen Sie folgende Schritte:

  1. Legen Sie einen Bezug zur Typenbibliothek der Anwendung im Dialogfeld Verweise (Menü Extras) fest. Anschließend werden die Objekte, Eigenschaften und Methoden im Objektkatalog angezeigt und die Syntax beim Kompilieren überprüft. Hierzu ist kontextbezogene Hilfe verfügbar.

  2. Deklarieren Sie Objektvariablen, die einen Bezug zu den Objekten in der anderen Anwendung als bestimmte Typen herstellen. Vergewissern Sie sich, dass Sie jeden Typ durch den Namen der Anwendung qualifizieren, die das Objekt bereitstellt. So deklariert z. B. die folgende Anweisung eine Variable, die auf ein Word-Dokument verweist, sowie eine andere Variable, die auf eine Microsoft Excel-Anwendung verweist.
    Dim appWD As Word.Application, wbXL As Excel.Application

    Anmerkung Befolgen Sie die obigen Schritte, damit Ihr Code früh gebunden werden kann.

  3. Verwenden Sie das Schlüsselwort New mit dem programmtechnischen OLE-Bezeichner des Objekts, mit dem Sie in der anderen Anwendung arbeiten möchten. Dies wird im folgenden Beispiel gezeigt. Wenn Sie die Sitzung der anderen Anwendung sehen möchten, legen Sie für die Visible-Eigenschaft den Wert True fest.
    Dim appWD As Word.Application

Set appWD = New Word.Application
appWd.Visible = True

  4. Verwenden Sie die Eigenschaften und Methoden des Objekts, das in der Variablen enthalten ist. Die folgende Anweisung erstellt z. B. ein Word-Dokument.
    Dim appWD As Word.Application

Set appWD = New Word.Application
appWD.Documents.Add

  5. Wenn Sie mit der Arbeit in der anderen Anwendung fertig sind, können Sie diese mit der Quit-Methode schließen. Dies wird im folgenden Beispiel gezeigt.
    appWd.Quit


Programmtechnische OLE-Bezeichner

Sie können einen programmtechnischen OLE-Bezeichner (manchmal auch als ProgID bezeichnet) verwenden, um ein Automatisierungsobjekt zu erstellen. In den folgenden Tabellen sind die programmtechnischen OLE-Bezeichner für die ActiveX-Steuerelemente, Microsoft Office-Anwendungen und Microsoft Office-Webkomponenten aufgeführt.

ActiveX-Steuerelemente

Microsoft Access

Microsoft Excel

Microsoft Graph

Microsoft Office-Webkomponenten

Microsoft Outlook

Microsoft PowerPoint

Microsoft Word

ActiveX-Steuerelemente

Wenn Sie die in der folgenden Tabelle aufgeführten ActiveX-Steuerelemente erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner.

Steuerelement | Bezeichner
CheckBox | Forms.CheckBox.1
ComboBox | Forms.ComboBox.1
CommandButton | Forms.CommandButton.1
Frame | Forms.Frame.1
Image | Forms.Image.1
Label | Forms.Label.1
ListBox | Forms.ListBox.1
MultiPage | Forms.MultiPage.1
OptionButton | Forms.OptionButton.1
ScrollBar | Forms.ScrollBar.1
SpinButton | Forms.SpinButton.1
TabStrip | Forms.TabStrip.1
TextBox | Forms.TextBox.1
ToggleButton | Forms.ToggleButton.1

Microsoft Access

Um die in der folgenden Tabelle aufgeführten Objekte von Microsoft Access zu erstellen, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Access-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Access.Application, Access.Application.9
CurrentData | Access.CodeData, Access.CurrentData
CurrentProject | Access.CodeProject, Access.CurrentProject
DefaultWebOptions | Access.DefaultWebOptions

Microsoft Excel

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Excel erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Excel-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner | Anmerkungen
Application | Excel.Application, Excel.Application.9 |
Workbook | Excel.AddIn |
Workbook | Excel.Chart, Excel.Chart.8 | Gibt eine Arbeitsmappe mit zwei Tabellenblättern zurück; eines für das Diagramm und eines für die enthaltenen Daten. Das Tabellenblatt mit dem Diagramm ist das aktive Tabellenblatt.
Workbook | Excel.Sheet, Excel.Sheet.8 | Gibt eine Arbeitsmappe mit einem Tabellenblatt zurück.

Microsoft Graph

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Graph erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt in der neuesten Graph-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | MSGraph.Application, MSGraph.Application.8
Chart | MSGraph.Chart, MSGraph.Chart.8

Microsoft Office-Webkomponenten

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Office-Webkomponenten erstellen möchten, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version der Microsoft Office-Webkomponenten, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
ChartSpace | OWC.Chart, OWC.Chart.9
DataSourceControl | OWC.DataSourceControl, OWC.DataSourceControl.9
ExpandControl | OWC.ExpandControl, OWC.ExpandControl.9
PivotTable | OWC.PivotTable, OWC.PivotTable.9
RecordNavigationControl | OWC.RecordNavigationControl, OWC.RecordNavigationControl.9
Spreadsheet | OWC.Spreadsheet, OWC.Spreadsheet.9

Microsoft Outlook

Wenn Sie das in der folgenden Tabelle aufgeführte Objekt von Microsoft Outlook erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version von Microsoft Outlook, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Outlook.Application, Outlook.Application.9

Microsoft PowerPoint

Wenn Sie das in der folgenden Tabelle aufgeführte Objekt von Microsoft PowerPoint erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version von Microsoft PowerPoint, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | PowerPoint.Application, PowerPoint.Application.9

Microsoft Word

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Word erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt in der neuesten Version von Microsoft Word, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Word.Application, Word.Application.9
Document | Word.Document, Word.Document.9, Word.Template.8
Global | Word.Global


Microsoft PowerPoint-Objekte

Application-Objekt

Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern


 NewPresentation-Ereignis

NewPresentation-Ereignis

Tritt nach dem Erstellen einer Präsentation ein, sobald diese zur Presentations-Auflistung hinzugefügt wird.

Syntax

Private Sub Anwendung_NewPresentation(ByVal Pres As Presentation)

Anwendung Ein Objekt des Typs Application, das in einem Klassenmodul mit Ereignissen deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt siehe Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die neue Präsentation.


Beispiel zum NewPresentation-Ereignis

In diesem Beispiel wird mit der RGB-Funktion die Hintergrundfarbe des Folienmasters auf Rosa festgelegt und dann das dritte Farbschema für die neue Präsentation übernommen.

Private Sub App_NewPresentation(ByVal Pres As Presentation)
    With Pres
        Set CS3 = .ColorSchemes(3)
        CS3.Colors(ppBackground).RGB = RGB(240, 115, 100)
        .SlideMaster.ColorScheme = CS3
    End With
End Sub


 PresentationClose-Ereignis

PresentationClose-Ereignis

Tritt unmittelbar vor dem Schließen einer geöffneten Präsentation ein, während diese aus der Presentations-Auflistung entfernt wird.

Syntax

Private Sub Anwendung_PresentationClose(ByVal Pres As Presentation)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wurde. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die Präsentation, die gerade geschlossen wird.


Beispiel zum PresentationClose-Ereignis

In diesem Beispiel wird eine Kopie der aktiven Präsentation unter demselben Namen und in demselben Ordner wie das Original als HTML-Datei gespeichert.

Private Sub App_PresentationClose(ByVal Pres As Presentation)
    FindNum = InStr(1, Pres.FullName, ".")
    HTMLName = Mid(Pres.FullName, 1, FindNum - 1) _
        & ".htm"
    Pres.SaveCopyAs HTMLName, ppSaveAsHTML
End Sub


 PresentationNewSlide-Ereignis

PresentationNewSlide-Ereignis

Tritt beim Erstellen einer neuen Folie in einer geöffneten Präsentation ein, sobald die Folie der Folien-Auflistung hinzugefügt wird.

Syntax

Private Sub Anwendung_PresentationNewSlide(ByVal Sld As Slide)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sld Die neue Folie.


Beispiel zum PresentationNewSlide-Ereignis

In diesem Beispiel wird die Hintergrundfarbe für das Farbschema 3 geändert und das geänderte Farbschema für die neue Folie übernommen. Danach wird Standardtext in Form 1 eingefügt, wenn diese über einen Textrahmen verfügt.

Private Sub App_PresentationNewSlide(ByVal Sld As Slide)
    With ActivePresentation
        Set CS3 = .ColorSchemes(3)
        CS3.Colors(ppBackground).RGB = RGB(240, 115, 100)
        Windows(1).Selection.SlideRange.ColorScheme = CS3
    End With

    If Sld.Layout <> ppLayoutBlank Then
        With Sld.Shapes(1)
            If .HasTextFrame = msoTrue Then
                .TextFrame.TextRange.Text = "King Salmon"
            End If
        End With
    End If
End Sub


 PresentationOpen-Ereignis

PresentationOpen-Ereignis

Tritt nach dem Öffnen einer vorhandenen Präsentation ein, sobald diese der Presentations-Auflistung hinzugefügt wird.

Syntax

Private Sub Anwendung_PresentationOpen(ByVal Pres As Presentation)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die geöffnete Präsentation.


Beispiel zum PresentationOpen-Ereignis

In diesem Beispiel wird die Hintergrundfarbe für Farbschema 3 geändert, das geänderte Farbschema für die soeben geöffnete Präsentation wird übernommen und die Präsentation in der Folienansicht angezeigt.

Private Sub App_PresentationOpen(ByVal Pres As Presentation)
    With Pres
        Set CS3 = .ColorSchemes(3)
        CS3.Colors(ppBackground).RGB = RGB(240, 115, 100)
        With Windows(1)
            .Selection.SlideRange.ColorScheme = CS3
            .ViewType = ppViewSlide
        End With
    End With
End Sub


 PresentationPrint-Ereignis

PresentationPrint-Ereignis

Tritt vor dem Drucken einer Präsentation ein.

Syntax

Private Sub Anwendung_PresentationPrint(ByVal Pres As Presentation)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die zu druckende Präsentation.


Beispiel zum PresentationPrint-Ereignis

In diesem Beispiel wird die PrintHiddenSlides-Eigenschaft auf True gesetzt, so dass bei jedem Ausdruck der aktiven Präsentation auch die ausgeblendeten Folien gedruckt werden.

Private Sub App_PresentationPrint(ByVal Pres As Presentation)
    Pres.PrintOptions.PrintHiddenSlides = True
End Sub


 PresentationSave-Ereignis

PresentationSave-Ereignis

Tritt ein, bevor eine geöffnete Präsentation gespeichert wird.

Syntax

Private Sub Anwendung_PresentationSave(ByVal Pres As Presentation)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die zu speichernde Präsentation.


Beispiel zum PresentationSave-Ereignis

In diesem Beispiel wird die aktuelle Präsentation unter dem Namen mallard.htm als HTML-Datei der Version 4.0 gespeichert. Dann wird eine Meldung mit dem Hinweis angezeigt, dass die Datei unter dem aktuellen Namen sowohl im PowerPoint- als auch im HTML-Format gespeichert wird.

Private Sub App_PresentationSave(ByVal Pres As Presentation)
    With Pres.PublishObjects(1)
        PresName = .SlideShowName
        .SourceType = ppPublishAll
        .FileName = "C:\HTMLPres\mallard.htm"
        .HTMLVersion = ppHTMLVersion4
        MsgBox ("Saving presentation " & "'" _
            & PresName & "'" & " in PowerPoint" _
            & Chr(10) & Chr(13) _
            & " format and HTML version 4.0 format")
        .Publish
    End With
End Sub


 SlideShowBegin-Ereignis

SlideShowBegin-Ereignis

Tritt beim Beginn einer Bildschirmpräsentation ein. Microsoft PowerPoint erstellt das Fenster für die Bildschirmpräsentation und übergibt es diesem Ereignis. Wenn eine Bildschirmpräsentation in eine zweite verzweigt, tritt das SlideShowBegin-Ereignis bei Beginn der zweiten Bildschirmpräsentation kein weiteres Mal ein.

Syntax

Private Sub Anwendung_SlideShowBegin(ByVal Wn As SlideShowWindow)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Wn Das Fenster für die Bildschirmpräsentation, das vor Eintreten dieses Ereignisses geöffnet wurde.


Beispiel zum SlideShowBegin-Ereignis

In diesem Beispiel werden Größe und Position des Bildschirmpräsentationsfensters angepasst und dann erneut aktiviert.

Private Sub App_SlideShowBegin(ByVal Wn As SlideShowWindow)
    With Wn
        .Height = 325
        .Width = 400
        .Left = 100
        .Activate
    End With
End Sub


 SlideShowEnd-Ereignis

SlideShowEnd-Ereignis

Tritt nach dem Ende einer Bildschirmpräsentation ein – unmittelbar nach dem letzten SlideShowNextSlide-Ereignis.

Syntax

Private Sub Anwendung_SlideShowEnd(ByVal Pres As Presentation)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über die Verwendung von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die Präsentation, die bei Eintreten dieses Ereignisses geschlossen wird.

Hinweise

Das SlideShowEnd-Ereignis tritt immer dann vor dem Ende einer Bildschirmpräsentation ein, wenn das SlideShowBegin-Ereignis aufgetreten ist. Mit dem SlideShowEnd-Ereignis können Sie alle Eigenschaftseinstellungen und Variableninitialisierungen des SlideShowBegin-Ereignisses auf die ursprünglichen Einstellungen zurücksetzen.


Beispiel zum SlideShowEnd-Ereignis

In diesem Beispiel werden der Eingangseffekt und die Übergangseffekte der automatischen Abfolge für die Bildschirmpräsentation der Folien 1 bis 4 am Ende der Bildschirmpräsentation deaktiviert. Außerdem werden die Einstellungen für die Folienabfolge auf manuell gesetzt.

Private Sub App_SlideShowEnd(ByVal Pres As Presentation)
    With Pres.Slides.Range(Array(1, 4)) _
            .SlideShowTransition
        .EntryEffect = ppEffectNone
        .AdvanceOnTime = msoFalse
    End With

    With Pres.SlideShowSettings
        .AdvanceMode = ppSlideShowManualAdvance
    End With
End Sub


 SlideShowNextBuild-Ereignis

SlideShowNextBuild-Ereignis

Tritt nach einem Mausklick oder der Anzeigedauer einer Animation ein, jedoch bevor das animierte Objekt sichtbar wird.

Syntax

Private Sub Anwendung_SlideShowNextBuild(ByVal Wn As SlideShowWindow)

Anwendung Objekt des Typs Application, das in einem Klassenmodul mit Ereignissen deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Wn Das aktive Fenster der Bildschirmpräsentation.


Beispiel zum SlideShowNextBuild-Ereignis

In diesem Beispiel wird, wenn die aktuelle Form auf der Folie ein Film ist, der Film fortlaufend abgespielt, bis er vom Vortragenden manuell angehalten wird. Dieser Code ist für die synchrone Verwendung mit dem zweiten Beispiel zum SlideShowNextSlide-Ereignis gedacht.

Private Sub App_SlideShowNextBuild(ByVal Wn As SlideShowWindow)
    If EvtCounter <> 0 Then
        With ActivePresentation.Slides(1) _
                .Shapes(shpAnimArray(2, EvtCounter))
            If .Type =msoMedia Then
                If .MediaType = ppMediaTypeMovie
                    .AnimationSettings.PlaySettings _
                        .LoopUntilStopped
                End If
            End If
        End With
    End If
        EvtCounter = EvtCounter + 1
End Sub


 SlideShowNextSlide-Ereignis

SlideShowNextSlide-Ereignis

Tritt unmittelbar vor dem Übergang zur nächsten Folie ein. Bei der ersten Folie tritt es unmittelbar nach dem SlideShowBegin-Ereignis ein.

Syntax

Private Sub Anwendung_SlideShowNextSlide(ByVal Wn As SlideShowWindow)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Wn Das aktive Fenster für die Bildschirmpräsentation.


Beispiel zum SlideShowNextSlide-Ereignis

In diesem Beispiel wird die Position für die Folie festgelegt, die nach dem SlideShowNextSlide-Ereignis gezeigt wird. Wenn die folgende Folie Folie drei ist, nimmt der Mauszeiger im Beispiel die Form eines Stifts an, und die Stiftfarbe wird in Rot geändert.

Private Sub App_SlideShowNextSlide(ByVal Wn As SlideShowWindow)

Dim Showpos As Integer

Showpos = Wn.View.CurrentShowPosition + 1
    If Showpos = 3 Then
        With ActivePresentation.SlideShowSettings.Run.View
            .PointerColor.RGB = RGB(255, 0, 0)
            .PointerType = ppSlideShowPointerPen
        End With
    Else
        With ActivePresentation.SlideShowSettings.Run.View
            .PointerColor.RGB = RGB(0, 0, 0)
            .PointerType = ppSlideShowPointerArrow
        End With
    End If
End Sub

In diesem Beispiel wird eine globale Zählervariable auf Null gesetzt. Dann wird berechnet, wie viele Formen die nach diesem Ereignis gezeigte Folie enthält, festgelegt, welche Formen Animationen enthalten, und die Reihenfolge sowie Nummer einer jeden Animation in ein Array eingetragen.

Anmerkung Das in diesem Beispiel angelegte Array wird auch im SlideShowNextBuild-Ereignis verwendet.

Private Sub App_SlideShowNextSlide(ByVal Wn As SlideShowWindow)

Dim i, j, numShapes As Integer
Dim objSld As Slide

EvtCounter = 0

Set objSld = ActivePresentation.Slides _
        (ActivePresentation.SlideShowWindow.View _
        .CurrentShowPosition + 1)
    With objSld.Shapes
        numShapes = .Count
        If numShapes > 0 Then
            j = 1
            ReDim shpAnimArray(1 To 2, 1 To numShapes)
            For i = 1 To numShapes
                If .Item(i).AnimationSettings.Animate Then
                    shpAnimArray(1, j) = _
                        .Item(i).AnimationSettings.AnimationOrder
                    shpAnimArray(2, j) = i
                    j = j + 1
                End If
            Next
        End If
    End With
End Sub


 WindowActivate-Ereignis

WindowActivate-Ereignis

Tritt beim Aktivieren des Anwendungsfensters oder eines beliebigen Dokumentfensters ein.

Syntax

Private Sub Anwendung_WindowActivate(ByVal Pres As Presentation, ByVal Wn As DocumentWindow)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die im aktiven Fenster angezeigte Präsentation.

Wn Das Fenster des aktivierten Dokuments.


Beispiel zum WindowActivate-Ereignis

In diesem Beispiel werden alle aktivierten Präsentationen in der Foliensortieransicht geöffnet.

Private Sub App_WindowActivate _
        (ByVal Pres As Presentation, ByVal Wn As DocumentWindow)
    Wn.ViewType = ppViewSlideSorter
End Sub


 WindowBeforeDoubleClick-Ereignis

WindowBeforeDoubleClick-Ereignis

Tritt ein, wenn Sie auf die Elemente in den Ansichten doppelklicken, die in der folgenden Tabelle aufgeführt werden.

Ansicht | Element
Normal- oder Folienansicht | Form
Foliensortieransicht | Folie
Notizenseitenansicht | Folienbild

Wenn das Argument Abbrechen nicht auf True gesetzt ist, tritt die Standarddoppelklickaktion ein.

Syntax

Private Sub Anwendung_WindowBeforeDoubleClick(ByVal Sel As Selection, ByVal Cancel As Boolean)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Die bei Eintreten des Doppelklick-Ereignisses unter dem Mauszeiger befindliche Auswahl.

Cancel False bei Eintreten des Ereignisses. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird die voreingestellte Aktion bei Doppelklick nach Beendigung der Prozedur nicht ausgeführt.


Beispiel zum WindowBeforeDoubleClick-Ereignis

In der Foliensortieransicht ist das Standardereignis bei Doppelklick für alle Folien, dass diese in die Folienansicht wechseln. In diesem Beispiel wird die Standardaktion mit dem WindowBeforeDoubleClick-Ereignis belegt, wenn die aktive Präsentation in der Foliensortieransicht angezeigt wird. Die Ereignisprozedur wechselt zur Normalansicht und verhindert dann den Wechsel zur Folienansicht, indem sie das Cancel-Argument auf True setzt.

Private Sub App_WindowBeforeDoubleClick _
        (ByVal Sel As Selection, ByVal Cancel As Boolean)
    With Application.ActiveWindow
        If .ViewType = ppViewSlideSorter Then
           .ViewType = ppViewNormal
            Cancel = True
        End If
    End With
End Sub


 WindowBeforeRightClick-Ereignis

WindowBeforeRightClick-Ereignis

Tritt ein, wenn mit der rechten Maustaste auf eine Form, eine Folie, eine Notizenseite oder auf Text geklickt wird. Dieses Ereignis wird vom MouseUp-Ereignis ausgelöst.

Syntax

Private Sub Anwendung_WindowBeforeRightClick(ByVal Sel As Selection, ByVal Cancel As Boolean)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Die bei Eintreten des Klicks mit der rechten Maustaste unter dem Mauszeiger befindliche Auswahl.

Cancel False, wenn das Ereignis auftritt. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird das Standardkontextmenü nach Beendigung der Prozedur nicht angezeigt.


Beispiel zum WindowBeforeRightClick-Ereignis

In diesem Beispiel wird ein Duplikat der ausgewählten Form erstellt. Wenn die Form über einen Textrahmen verfügt, wird der neuen Form der Text "Duplicate Shape" hinzugefügt. Wenn das Cancel-Argument auf True gesetzt wird, wird das Standardkontextmenü nicht mehr angezeigt.

Private Sub App_WindowBeforeRightClick _
        (ByVal Sel As Selection, ByVal Cancel As Boolean)
    With ActivePresentation.Selection.ShapeRange
        If .HasTextFrame Then
            .Duplicate.TextFrame.TextRange.Text = "Duplicate Shape"
        Else
            .Duplicate
        End If
        Cancel = True
    End With
End Sub


 WindowDeactivate-Ereignis

WindowDeactivate-Ereignis

Tritt beim Deaktivieren des Anwendungsfensters oder eines beliebigen Dokumentfensters ein.

Syntax

Private Sub Anwendung_WindowDeactivate(ByVal Pres As Presentation, ByVal Wn As DocumentWindow)

Anwendung Objekt des Typs Anwendung, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Pres Die im deaktivierten Fenster angezeigte Präsentation.

Wn Das Fenster für die deaktivierte Präsentation.


Beispiel zum WindowDeactivate-Ereignis

In diesem Beispiel wird der Dateiname der Präsentation (ohne Erweiterung) im deaktivierten Fenster ermittelt. Dann wird die Erweiterung .htm an den Dateinamen angehängt und die Datei als Webseite im gleichen Ordner wie die Präsentation gespeichert.

Private Sub App_WindowDeactivate _
        (ByVal Pres As Presentation, ByVal Wn As DocumentWindow)
    FindNum = InStr(1, Wn.Presentation.FullName, ".")
    If FindNum = 0 Then
        HTMLName = Wn.Presentation.FullName & ".htm"
    Else
        HTMLName = Mid(Wn.Presentation.FullName, 1, FindNum - 1) _
            & ".htm"
    End If
    Wn.Presentation.SaveCopyAs HTMLName, ppSaveAsHTML
    MsgBox "Presentation being saved in HTML format as " _
        & HTMLName & " ."
End Sub


 WindowSelectionChange-Ereignis

WindowSelectionChange-Ereignis

Tritt ein, wenn im aktiven Dokument die Auswahl eines Textes, einer Form oder einer Folie mit Hilfe der Benutzeroberfläche oder mittels Code verändert wird.

Syntax

Private Sub Anwendung_WindowSelectionChange(ByVal Sel As Selection)

Anwendung Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert wird. Informationen über das Verwenden von Ereignissen mit dem Application-Objekt erhalten Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Stellt das ausgewählte Objekt dar.


Beispiel zum WindowSelectionChange-Ereignis

In diesem Beispiel wird der Zeitpunkt für die Auswahl einer neuen Folie festgelegt und die Hintergrundfarbe der neu auszuwählenden Folie verändert.

Private Sub App_WindowSelectionChange(ByVal Sel As Selection)
    With Sel
        If .Type = ppSelectionNone Then
            With .SlideRange(1)
                .ColorScheme.Colors(ppBackground).RGB = _
                    RGB(240, 115, 100)
            End With
        End If
    End With
End Sub


Neue Methoden (nach Objekten)

In der folgenden, nach Objektnamen sortierten Tabelle finden Sie eine Aufstellung der Methoden, die in Microsoft PowerPoint 2000 vorhandenen Objekten hinzugefügt wurden:

Objekt | Neue Methoden
Borders | Item
BulletFormat | Picture
DocumentWindow | PointsToScreenPixelsX, PointsToScreenPixelsY, RangeFromPoint, ScrollIntoView
Hyperlink | CreateNewDocument, Delete, Follow
Presentation | ReloadAs, WebPagePreview
Shapes | AddTable
TextRange | LtrRun, RtlRun


Activate-Methode

Aktiviert das angegebene Objekt.

Syntax

Ausdruck.Activate

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-, Pane-, OLEFormat-, Application- oder SlideShowWindow-Objekt zurückgibt.


Beispiel zur Activate-Methode

In diesem Beispiel wird das Dokumentfenster aktiviert, das in der Anordnung der Dokumentfenster direkt auf das aktive Fenster folgt.

Windows(2).Activate


Add-Methode

Fügt ein Objekt zu einer Auflistung hinzu. Wählen Sie eines der folgenden Objekte aus, um eine ausführliche Beschreibung der Add-Methode für dieses Objekt anzuzeigen.

AddIns

ColorSchemes

Columns

ExtraColors

NamedSlideShows

Presentations

PrintRanges

Rows

Slides

TabStops

Tags


Add-Methode (AddIns-Objekt (Auflistung))

Fügt der Liste mit Add-Ins im Dialogfeld Add-Ins (Menü Extras) eine neue Add-In-Datei hinzu. Gibt ein AddIn-Objekt zurück, das das neu hinzugefügte Add-In darstellt.

Syntax

Ausdruck.Add(Filename)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

Filename String erforderlich. Der vollständige Name der Datei (mit Pfad und Dateinamenserweiterung), der das gewünschte Add-In enthält.

Anmerkungen

Diese Methode lädt das neue Add-In nicht. Um das Add-In zu laden, müssen Sie die Loaded-Eigenschaft festlegen.


Beispiel zur Add-Methode (AddIns-Objekt (Auflistung))

Dieses Beispiel fügt der Liste im Dialogfeld Add-Ins (Menü Extras) die Datei MyTools.ppa hinzu.

Set myAddIn = Application.AddIns.Add("c:\my documents\mytools.ppa")
MsgBox myAddIn.Name & " has been added to the list"


AddCallout-Methode

Erstellt eine rahmenlose Legende mit Linien. Gibt ein Shape-Objekt zurück, das die neue Legende darstellt.

Syntax

Ausdruck.AddCallout(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Der Typ der Legendenlinie. Dies kann eine der folgenden MsoCalloutType-Konstanten sein: msoCalloutOne (eine Legendenlinie mit einem horizontalen oder vertikalen Abschnitt), msoCalloutTwo (eine Legendenlinie mit einem Abschnitt, der sich frei dreht), msoCalloutThree (eine Legendenlinie mit zwei Abschnitten) oder msoCalloutFour (eine Legendenlinie mit drei Abschnitten).

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der Legende gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Die Breite und Höhe des Begrenzungsrechtecks der Legende in Punkt.

Anmerkungen

Sie können mit der AddShape-Methode eine größere Auswahl an Legenden einfügen.


Beispiel zur AddCallout-Methode

Dieses Beispiel fügt zu myDocument eine rahmenlose Legende mit einer frei drehbaren Legendenlinie mit einem Abschnitt hinzu und legt anschließend für die Legende einen Winkel von 30° fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddCallout(msoCalloutTwo, 50, 50, 200, 100) _
    .Callout.Angle = msoCalloutAngle30


AddComment-Methode

Fügt einen Kommentar hinzu. Gibt ein Shape-Objekt zurück, das einen neuen Kommentar darstellt.

Syntax

Ausdruck.AddComment(Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Left, Top Single optional. Die Position (in Punkt) der oberen linken Ecke des Kommentar-Begrenzungsrechtecks gemessen von der oberen linken Ecke des Dokuments. Standardmäßig wird der Kommentar in der oberen linken Ecke des Dokuments platziert.

Width, Height Single optional. Die Breite und Höhe des Kommentars in Punkt. Standardmäßig hat der Kommentar eine Höhe und Breite von jeweils 100 Punkt.


Beispiel zur AddComment-Methode

Dieses Beispiel fügt zu myDocument einen Kommentar mit dem Text "Test Comment" hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddComment(100, 100, 150, 150)
    .TextFrame.TextRange.Text = .TextFrame _
        .TextRange.Text + "Test Comment"
End With


AddConnector-Methode

Erstellt eine Verbindung. Gibt ein Shape-Objekt zurück, das die neue Verbindung darstellt. Wenn eine Verbindung hinzugefügt wird, ist diese noch nicht verbunden. Mit der BeginConnect- und EndConnect-Methode können Sie den Anfang und das Ende einer Verbindung mit anderen Formen im Dokument zusammenfügen.

Syntax

Ausdruck.AddConnector(Type, BeginX, BeginY, EndX, EndY)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Der Typ der Verbindung. Dies kann eine der folgenden MsoConnectorType-Konstanten sein: msoConnectorCurve, msoConnectorElbow oder msoConnectorStraight.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Anfangspunkts der Verbindung gemessen von der oberen linken Ecke des Dokuments.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunkts der Verbindung gemessen von der oberen linken Ecke des Dokuments.

Anmerkungen

Wenn Sie eine Verbindung mit einer Form zusammenfügen, wird die Größe und Position der Verbindung gegebenenfalls automatisch angepasst. Deshalb sind die Werte für die Position und die Maße für die Verbindung irrelevant, die Sie beim Hinzufügen der Verbindung angeben.


Beispiel zur AddConnector-Methode

Dieses Beispiel fügt zu myDocument zwei Rechtecke hinzu und verbindet diese mit einer gekrümmten Verbindung. Beachten Sie, dass beim Zusammenfügen der Verbindung mit den Rechtecken die Größe und Position der Verbindung automatisch angepasst wird. Deshalb sind die Werte für die Position und die Maße für die Legende irrelevant, die Sie beim Hinzufügen angeben (die Maße dürfen nicht den Wert 0 haben).

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 100, 100) _
        .ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    .Parent.RerouteConnections
End With


 AddCurve-Methode

AddCurve-Methode

Erstellt eine Bézierkurve. Gibt ein Shape-Objekt zurück, das die neue Kurve darstellt.

Syntax

Ausdruck.AddCurve(SafeArrayOfPoints)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

SafeArrayOfPoints Variant erforderlich. Eine Matrix mit Koordinatenpaaren, die die Scheitelpunkte und Kontrollpunkte der Kurve angibt. Der erste angegebene Punkt ist der Anfangsscheitelpunkt, bei den nächsten beiden Punkten handelt es sich um die Kontrollpunkte des ersten Bézier-Abschnitts. Anschließend geben Sie für jeden weiteren Abschnitt der Kurve jeweils einen Scheitelpunkt und zwei Kontrollpunkte an. Der letzte Punkt, den Sie angeben, ist der abschließende Scheitelpunkt der Kurve. Beachten Sie, dass immer 3n + 1 Punkte angeben werden müssen (n entspricht der Anzahl der Abschnitte einer Kurve).


Beispiel zur AddCurve-Methode

Dieses Beispiel fügt zu myDocument eine Bézierkurve mit zwei Abschnitten hinzu.

Dim pts(1 To 7, 1 To 2) As Single
pts(1, 1) = 0
pts(1, 2) = 0
pts(2, 1) = 72
pts(2, 2) = 72
pts(3, 1) = 100
pts(3, 2) = 40
pts(4, 1) = 20
pts(4, 2) = 50
pts(5, 1) = 90
pts(5, 2) = 120
pts(6, 1) = 60
pts(6, 2) = 30
pts(7, 1) = 150
pts(7, 2) = 90
Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddCurve pts


AddLabel-Methode

Erstellt eine Beschriftung. Gibt ein Shape-Objekt zurück, das eine neue Beschriftung darstellt.

Syntax

Ausdruck.AddLabel(Orientation, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Orientation Long erforderlich. Die Textausrichtung innerhalb der Beschriftung. Dies kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (beispielsweise Deutsch) ab.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke der Beschriftung gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Die Breite und Höhe der Beschriftung in Punkt.


Beispiel zur AddLabel-Methode

Dieses Beispiel fügt zu myDocument eine vertikale Beschriftung hinzu, die den Text "Test Label" enthält.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes _
    .AddLabel(msoTextOrientationVerticalFarEast, 100, _
    100, 60, 150).TextFrame.TextRange.Text = "Test Label"


AddLine-Methode

Erstellt eine Linie. Gibt ein Shape-Objekt zurück, das die neue Linie darstellt.

Syntax

Ausdruck.AddLine(BeginX, BeginY, EndX, EndY)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Anfangspunkts der Linie gemessen von der oberen linken Ecke des Dokuments.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunkts der Linie gemessen von der oberen linken Ecke des Dokuments.


Beispiel zur AddLine-Methode

Dieses Beispiel fügt zu myDocument eine blaue gestrichelte Linie hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


AddMediaObject-Methode

Erstellt ein Mediaobjekt. Gibt ein Shape-Objekt zurück, das das neue Mediaobjekt darstellt.

Syntax

Ausdruck.AddMediaObject(FileName, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

FileName String erforderlich. Die Datei, in der das Mediaobjekt erstellt werden soll. Ist der Pfad nicht angegeben, wird der aktuelle Ordner verwendet.

Left, Top Single optional. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks des Mediaobjekts gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single optional. Die Breite und Höhe des Begrenzungsrechtecks des Mediaobjekts in Punkt.


Beispiel zur AddMediaObject-Methode

Dieses Beispiel fügt den Film "Clock.avi" zu myDocument hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddMediaObject FileName:="C:\WINNT\clock.avi", _
    Left:=5, Top:=5, Width:=100, Height:=100


AddNodes-Methode

Fügt einen neuen Abschnitt am Ende der Freihandfigur ein, die erstellt wird. Außerdem wird der Knoten hinzugefügt, der den Abschnitt definiert. Sie können diese Methode beliebig oft verwenden, um derjenigen Freihandfigur Knoten hinzuzufügen, die Sie erstellen. Anschließend können Sie mit der ConvertToShape-Methode die Freihandfigur erstellen, die Sie gerade definiert haben. Mit der Insert-Methode der ShapeNodes-Auflistung können Sie Knoten zu einer Freihandfigur hinzufügen, nachdem diese erstellt wurde.

Syntax

Ausdruck.AddNodes(SegmentType, EditingType, X1, Y1, X2, Y2, X3, Y3)

Ausdruck Erforderlich. Ein Ausdruck, der ein FreeformBuilder-Objekt zurückgibt.

SegmentType Long erforderlich. Der Typ des Abschnitts, der hinzugefügt werden soll. Dies kann eine der folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des Scheitelpunkts. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (jedoch nicht msoEditingSmooth oder msoEditingSymmetric). Wird für SegmentType die Konstante msoSegmentLine festgelegt, muss für EditingType die Konstante msoEditingAuto festgelegt sein.

X1 Single erforderlich. Lautet der EditingType des neuen Abschnitts msoEditingAuto, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Knotens msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Kontrollpunkt für den neuen Abschnitt an.

Y1 Single erforderlich. Lautet der EditingType des neuen Abschnitts msoEditingAuto, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Knotens msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Kontrollpunkt für den neuen Abschnitt an.

X2 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Kontrollpunkt für den neuen Abschnitt an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

Y2 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Kontrollpunkt für den neuen Abschnitt an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

X3 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

Y3 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.


Beispiel zur AddNodes-Methode

Dieses Beispiel fügt zur ersten Folie der aktiven Präsentation eine Freihandfigur mit fünf Scheitelpunkten hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, _
        msoEditingCorner, 380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


AddOLEObject-Methode

Erstellt ein OLE-Objekt. Gibt ein Shape-Objekt zurück, das das neue OLE-Objekt darstellt.

Syntax

Ausdruck.AddOLEObject(Left, Top, Width, Height, ClassName, FileName, DisplayAsIcon, IconFileName, IconIndex, IconLabel, Link)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Left, Top Single optional. Die Position (in Punkt) der oberen linken Ecke des neuen Objekts gemessen von der oberen linken Ecke der Folie. Der Standardwert ist 0.

Width, Height Single optional. Die Initialmaße des OLE-Objekts in Punkt.

ClassName String optional. Der Klassenname für OLE-Long (lange OLE-Klassennamen) oder die ProgID des Objekts, das erstellt werden soll. Es muss entweder das ClassName- oder das FileName-Argument für das Objekt angegeben werden, jedoch nicht beide. Weitere Informationen über Erkennungszeichen von Programmen (programmtechnische Bezeichner) finden Sie unter Programmtechnische OLE-Bezeichner.

FileName String optional. Die Datei, aus der das Objekt erstellt werden soll. Ist der Pfad nicht angegeben, wird der aktuelle Arbeitsordner verwendet. Es muss entweder das ClassName- oder das FileName-Argument für das Objekt angegeben werden, jedoch nicht beide.

DisplayAsIcon Long optional. True, damit das OLE-Objekt als Symbol angezeigt wird. Der Standardwert ist False.

IconFileName String optional. Die Datei, die das Symbol enthält, das angezeigt werden soll.

IconIndex Long optional. Der Index des Symbols innerhalb von IconFileName. Die Reihenfolge der Symbole in der angegebenen Datei entspricht der Reihenfolge, in der die Symbole im Dialogfeld Symbol ändern angezeigt werden (das Sie über das Dialogfeld Objekt einfügen aufrufen können, wenn das Kontrollkästchen Als Symbol anzeigen aktiviert ist). Das erste Symbol der Datei hat die Indexnummer 0. Wenn ein Symbol mit einer bestimmten Indexnummer in IconFileName nicht existiert, wird das Symbol mit der Indexnummer 1 (dem zweiten Symbol der Datei) verwendet. Der Standardwert ist 0.

IconLabel String optional. Eine Beschriftung, die unter dem Symbol angezeigt wird.

Link Long optional. True, um das OLE-Objekt mit der Datei zu verknüpfen, aus der das Objekt erstellt wurde. False, wenn das OLE-Objekt eine unabhängige Kopie der Datei werden soll. Geben Sie einen Wert für ClassName an, so muss für dieses Argument False gelten. Der Standardwert ist False.


Beispiel zur AddOLEObject-Methode

Dieses Beispiel fügt zu myDocument ein verknüpftes Word-Dokument hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddOLEObject Left:=100, Top:=100, _
    Width:=200, Height:=300, _
    FileName:="c:\my documents\testing.doc", link:=True

Dieses Beispiel fügt zu myDocument ein neues Arbeitsblatt von Microsoft Excel hinzu. Das Arbeitsblatt wird als Symbol angezeigt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddOLEObject Left:=100, Top:=100, _
    Width:=200, Height:=300, _
    ClassName:="Excel.Sheet", DisplayAsIcon:=True

In diesem Beispiel wird zu myDocument eine Befehlsschaltfläche hinzugefügt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddOLEObject Left:=100, Top:=100, _
    Width:=150, Height:=50, ClassName:="Forms.CommandButton.1"


AddPeriods-Methode

Fügt im angegebenen Text am Ende jedes Absatzes einen Punkt ein.

Syntax

Ausdruck.AddPeriods

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Anmerkungen

Diese Methode fügt einem Absatz, der bereits mit einem Punkt endet, keinen weiteren Punkt hinzu.


Beispiel zur AddPeriods-Methode

In diesem Beispiel wird am Ende jedes Absatzes in der zweiten Form der ersten Folie in der aktiven Präsentation ein Punkt hinzugefügt.

Application.ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .TextRange.AddPeriods


AddPicture-Methode

Erstellt eine Grafik aus der vorhandenen Datei. Gibt ein Shape-Objekt zurück, das die neue Grafik darstellt.

Syntax

Ausdruck.AddPicture(FileName, LinkToFile, SaveWithDocument, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

FileName String erforderlich. Die Datei, aus der das OLE-Objekt erstellt werden soll.

LinkToFile Long erforderlich. True, wenn die Grafik mit der Urheberdatei verknüpft werden soll. False, wenn die Grafik eine unabhängige Kopie der Datei sein soll.

SaveWithDocument Long erforderlich. True, wenn die verknüpfte Grafik mit dem Dokument gespeichert werden soll, in das die Grafik eingefügt wurde. False, wenn nur die Verknüpfungsinformationen im Dokument gespeichert werden sollen. Für dieses Argument muss True gelten, wenn für LinkToFile False gilt.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke der Grafik gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single optional. Die Breite und Höhe der Grafik (in Punkt).


Beispiel zur AddPicture-Methode

Dieses Beispiel fügt zu myDocument eine Grafik hinzu, die aus der Datei Music.bmp erstellt wurde. Die eingefügte Grafik ist mit der Urheberdatei verknüpft und wird mit myDocument gespeichert.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddPicture "c:\microsoft office\" & _
    "clipart\music.bmp", True, True, 100, 100, 70, 70


AddPlaceholder-Methode

Stellt einen zuvor gelöschten Platzhalter auf einer Folie wieder her. Gibt ein Shape-Objekt zurück, das den wiederhergestellten Platzhalter darstellt.

Hinweis Wenn Sie den angegebenen Platzhalter zuvor noch nicht gelöscht haben, erzeugt diese Methode einen Fehler.

Syntax

Ausdruck.AddPlaceholder(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Der Typ des Platzhalters, der wiederhergestellt werden soll. Dies kann eine der folgenden PpPlaceholderType-Konstanten sein:

ppPlaceholderBitmap

ppPlaceholderBody

ppPlaceholderCenterTitle

ppPlaceholderChart

ppPlaceholderDate

ppPlaceholderFooter

ppPlaceholderHeader

ppPlaceholderMediaClip

ppPlaceholderMixed

 ppPlaceholderObject

ppPlaceholderOrgChart

ppPlaceholderSlideNumber

ppPlaceholderSubtitle

ppPlaceholderTable

ppPlaceholderTitle

ppPlaceholderVerticalBody

ppPlaceholderVerticalTitle

Platzhalter vom Typ ppPlaceholderVerticalBody oder ppPlaceholderVerticalTitle befinden sich nur auf Folien des Layouttyps ppLayoutVerticalText, ppLayoutClipArtAndVerticalText, ppLayoutVerticalTitleAndText oder ppLayoutVerticalTitleAndTextOverChart. Sie können mit diesen Layouts keine Folien von der Benutzeroberfläche erstellen. Sie müssen diese programmatisch mit der Add-Methode oder durch Festlegen der Layout-Eigenschaft einer vorhandenen Folie erstellen.

Left, Top Single optional. Die Position (in Punkt) der oberen linken Ecke des Platzhalters gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single optional. Die Breite und Höhe des Platzhalters in Punkt.

Anmerkungen

Wurden mehrere Platzhalter des angegebenen Typs aus der Folie gelöscht, fügt die AddPlaceholder-Methode diese wieder nacheinander in die Folie ein. Es wird dann mit dem Platzhalter begonnen, dessen ursprüngliche Indexnummer am niedrigsten ist.


Beispiel zur AddPlaceholder-Methode

Wenn der Titel von Folie 2 in der aktiven Präsentation ursprünglich oben in der Folie war und entweder manuell oder mit dem folgenden Code gelöscht wurde:

ActivePresentation.Slides(2).Shapes.Placeholders(1).Delete

Dieses Beispiel stellt den gelöschten Platzhalter auf Folie 2 wieder her.

Application.ActivePresentation.Slides(2) _
    .Shapes.AddPlaceholder ppPlaceholderTitle


 AddPolyline-Methode

AddPolyline-Methode

Erstellt eine offene Polylinie oder ein geschlossenes Vieleck. Gibt ein Shape-Objekt zurück, das die neue Polylinie bzw. das neue Vieleck darstellt.

Syntax

Ausdruck.AddPolyline(SafeArrayOfPoints)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

SafeArrayOfPoints Single erforderlich. Eine Matrix mit Koordinatenpaaren, die Scheitelpunkte der Polylinie angeben.

Anmerkungen

Um ein geschlossenes Vieleck zu bilden, weisen Sie dem ersten und letzten Scheitelpunkt der Polylinie die gleichen Koordinaten zu.


Beispiel zur AddPolyline-Methode

Dieses Beispiel fügt zu myDocument ein Dreieck hinzu. Da die ersten und letzten Punkte identische Koordinaten haben, wird das Vieleck geschlossen und gefüllt. Die Farbe der Objektfüllung entspricht der Füllfarbe der Standardform.

Dim triArray(1 To 4, 1 To 2) As Single
triArray(1, 1) = 25
triArray(1, 2) = 100
triArray(2, 1) = 100
triArray(2, 2) = 150
triArray(3, 1) = 150
triArray(3, 2) = 50
triArray(4, 1) = 25     ' Last point has same coordinates as first
triArray(4, 2) = 100
Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddPolyline triArray


AddShape-Methode

Erstellt eine AutoForm. Gibt ein Shape-Objekt zurück, das die neue AutoForm darstellt.

Syntax

Ausdruck.AddShape(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Gibt den Typ der zu erstellenden AutoForm an. Dies kann eine der folgenden MsoAutoShapeType-Konstanten sein.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der AutoForm gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Die Breite und Höhe des Begrenzungsrechtecks der AutoForm in Punkt.

Anmerkungen

Um den Typ der AutoForm zu ändern, die Sie hinzugefügt haben, legen Sie die AutoShapeType-Eigenschaft fest.


Beispiel zur AddShape-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200


AddTable-Methode

Fügt eine Tabellenform in eine Folie ein.

Syntax

Ausdruck.AddTable(NumRows, NumColumns, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

NumRows Erforderlich Long. Die Anzahl der Zeilen in der Tabelle.

NumColumns Erforderlich Long. Die Anzahl der Spalten in der Tabelle.

Left Optional Single. Der Abstand zwischen dem linken Rand der Folie und dem linken Rand der Tabelle (in Punkt).

Top Optional Single. Der Abstand zwischen dem oberen Rand der Folie und dem oberen Rand der Tabelle (in Punkt).

Width Optional Single. Die Breite der neuen Tabelle (in Punkt).

Height Optional Single. Die Höhe der neuen Tabelle (in Punkt).


Beispiel zur AddTable-Methode

In diesem Beispiel wird eine neue Tabelle auf Folie 2 der aktiven Präsentation erstellt. Die Tabelle besteht aus drei Zeilen und vier Spalten. Sie ist 10 Punkt vom linken Rand der Folie und 10 Punkt vom oberen Rand der Folie entfernt. Die Breite der neuen Tabelle beträgt 288 Punkt, wodurch die vier Spalten ein Zoll breit werden (bei 72 Punkt pro Zoll). Die Höhe wird auf 216 Punkt gesetzt, wodurch jede der drei Zeilen ein Zoll hoch ist.

ActivePresentation.Slides(2).Shapes _
    .AddTable(3, 4, 10, 10, 288, 216)


AddTextbox-Methode

Erstellt ein Textfeld. Gibt ein Shape-Objekt zurück, das das neue Textfeld darstellt.

Syntax

Ausdruck.AddTextbox(Orientation, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Orientation Long erforderlich. Die Textausrichtung innerhalb der Beschriftung. Dies kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationMixed, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (beispielsweise Deutsch) ab.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Textfeldes gemessen von der oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Die Breite und Höhe des Textfeldes in Punkt.


Beispiel zur AddTextbox-Methode

Dieses Beispiel fügt zu myDocument ein Textfeld hinzu, das den Text "Test Box" enthält.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddTextbox(msoTextOrientationHorizontal, _
    100, 100, 200, 50).TextFrame.TextRange.Text = "Test Box"


AddTextEffect-Methode

Erstellt ein WordArt-Objekt. Gibt ein Shape-Objekt zurück, das das neue WordArt-Objekt darstellt.

Syntax

Ausdruck.AddTextEffect(PresetTextEffect, Text, FontName, FontSize, FontBold, FontItalic, Left, Top)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

PresetTextEffect Long erforderlich. Der vordefinierte Texteffekt. Dies kann eine der folgenden MsoPresetTextEffect-Konstanten sein:

msoTextEffect1

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

msoTextEffect16

msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect2

msoTextEffect20

msoTextEffect21

msoTextEffect22

 msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect3

msoTextEffect30

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

Text String erforderlich. Der Text in der WordArt.

FontName String erforderlich. Die Schriftart, die in der WordArt verwendet wird.

FontSize Single erforderlich. Der Schriftgrad (in Punkt), der in der WordArt verwendet wird.

FontBold Long erforderlich. True, um die Schriftart in der WordArt fett zu formatieren.

FontItalic Long erforderlich. True, um die Schriftart in der WordArt kursiv zu formatieren.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der WordArt gemessen von der oberen linken Ecke des Dokuments.

Anmerkungen

Wenn Sie WordArt zu einem Dokument hinzufügen, wird automatisch festgelegt, dass die Höhe und die Breite des WordArt auf die Größe und das Volumen des angegebenen Texts basiert.


Beispiel zur AddTextEffect-Methode

Dieses Beispiel fügt zu myDocument WordArt hinzu, das den Text "Test" enthält.

Set myDocument = ActivePresentation.Slides(1)
Set newWordArt = myDocument.Shapes _
    .AddTextEffect(PresetTextEffect:=msoTextEffect1, _
    Text:="Test", FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=10, Top:=10)


AddTitle-Methode

Stellt einen zuvor gelöschten Platzhalter für den Titel einer Folie wieder her. Gibt ein Shape-Objekt zurück, das den wiederhergestellten Titel darstellt.

Hinweis Diese Methode erzeugt einen Fehler, wenn Sie den Platzhalter für den Titel der angegebenen Folie nicht zuvor gelöscht haben. Mit der HasTitle-Eigenschaft können Sie bestimmen, ob der Platzhalter für den Titel gelöscht wurde.

Syntax

Ausdruck.AddTitle

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.


AddTitleMaster-Methode

Fügt der angegebenen Präsentation einen Titelmaster hinzu. Gibt ein Master-Objekt zurück, das den Titelmaster darstellt. Hat die Präsentation bereits einen Titelmaster, tritt ein Fehler auf.

Syntax

Ausdruck.AddTitleMaster

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.


Beispiel zur AddTitleMaster-Methode

In diesem Beispiel wird der aktiven Präsentation ein Titelmaster hinzugefügt, wenn diese noch keinen hat.

With Application.ActivePresentation
    If Not .HasTitleMaster Then .AddTitleMaster
End With


AddToFavorites-Methode

Presentation-Objekt: Erstellt eine Verknüpfung mit der aktuellen Auflistung in der angegebenen Präsentation und dem Ordner Favoriten im Programmordner Windows.

Hyperlink-Objekt: Erstellt eine Verknüpfung mit dem angegebenen Zieldokument des Hyperlinks und dem Ordner Favoriten im Programmordner Windows.

Syntax

Ausdruck.AddToFavorites

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation- oder Hyperlink-Objekt zurückgibt.

Anmerkungen

Als Verknüpfungsname wird nach Möglichkeit der reguläre Name des Dokuments angegeben. Ist dieser nicht verfügbar, wird der Verknüpfungsname verwendet, der in der Datei HLINK.DLL ermittelt wurde.


Beispiel zur AddToFavorites-Methode

In diesem Beispiel wird der aktiven Präsentation ein Hyperlink mit dem Ordner Favoriten im Programmordner Windows hinzugefügt.

Application.ActivePresentation.AddToFavorites


Align-Methode

Richtet die Formen im angegebenen Formbereich aus.

Syntax

Ausdruck.Align(AlignCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

AlignCmd Long erforderlich. Gibt an, wie die Formen im angegebenen Formbereich ausgerichtet werden sollen. Dies kann eine der folgenden MsoAlignCmd-Konstanten sein: msoAlignBottoms, msoAlignCenters, msoAlignLefts, msoAlignMiddles, msoAlignRights oder msoAlignTops.

RelativeTo Long erforderlich. True, um Formen relativ zur Seite der Folie auszurichten. False, um Formen relativ zueinander auszurichten.


Beispiel zur Align-Methode

Dieses Beispiel richtet die linken Seiten aller Formen im angegebenen Bereich in myDocument mit der linken Seite der äußersten linken Form im Bereich aus.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Range.Align msoAlignLefts, False


Apply-Methode

Betrifft die angegebene Formformatierung, die mit der PickUp-Methode kopiert wurde.

Syntax

Ausdruck.Apply

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.


ApplyTemplate-Methode

Weist der angegebenen Präsentation eine Entwurfsvorlage zu.

Syntax

Ausdruck.ApplyTemplate(FileName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

FileName String erforderlich. Gibt den Namen der Entwurfsvorlage an.

Anmerkung Wenn Sie auf eine nicht installierte Entwurfsvorlage verweisen, wird ein Laufzeitfehler generiert. Unhabhängig von der Einstellung der FeatureInstall-Eigenschaft wird die Vorlage nicht automatisch installiert. Wenn Sie die ApplyTemplate-Methode für eine Vorlage verwenden möchten, die noch nicht installiert ist, müssen Sie zunächst die weiteren Entwurfsvorlagen installieren. Wählen Sie dazu im Dialogfeld Neu (Menü Datei) die gewünschte Vorlage aus, oder installieren Sie die weiteren Entwurfsvorlagen für PowerPoint, indem Sie das Installationsprogramm von Microsoft Office 2000 erneut ausführen. (Sie können das Installationsprogramm mit Hilfe des Symbols Software in der Windows-Systemsteuerung aufrufen.)


Beispiel zur ApplyTemplate-Methode

In diesem Beispiel wird der aktiven Präsentation die Entwurfsvorlage Professional zugewiesen.

Application.ActivePresentation.ApplyTemplate _
    "c:\program files\microsoft office\templates" & _
    "\presentation designs\professional.pot"


Arrange-Methode

Ordnet alle offenen Dokumentfenster im Arbeitsbereich an.

Syntax

Ausdruck.Arrange(ArrangeStyle)

Ausdruck Ein Ausdruck, der eine DocumentWindows-Auflistung zurückgibt.

ArrangeStyle Long optional. Gibt an, ob die Fenster überlappend oder nebeneinander angezeigt werden. Dies kann eine der folgenden PpArrangeStyle-Konstanten sein: ppArrangeCascade oder ppArrangeTiled. Der Standard ist ppArrangeTiled.


Beispiel zur Arrange-Methode

In diesem Beispiel wird ein neues Fenster erstellt, und anschließend werden alle offenen Dokumentfenster angeordnet.

Application.ActiveWindow.NewWindow
Windows.Arrange ppArrangeCascade


AutomaticLength-Methode

Gibt an, dass der erste Abschnitt der Legendenlinie (der Abschnitt, der mit dem Legenden-Textfeld verbunden ist) automatisch skaliert wird, wenn Sie die Legende verschieben. Mit der CustomLength-Methode können Sie angeben, dass der erste Abschnitt der Legendenlinie beim Verschieben die feste Länge beibehält, die von der Length-Eigenschaft zurückgegeben wird. Dies betrifft nur Legenden, deren Linien aus mehreren Abschnitten bestehen (die Typen msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.AutomaticLength

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Anmerkungen

Wenn Sie diese Methode zuweisen, wird für die AutoLength-Eigenschaft True festgelegt.


Beispiel zur AutomaticLength-Methode

Dieses Beispiel wechselt zwischen einem automatisch skalierenden ersten Abschnitt und einem Abschnitt mit einer festen Länge für die Legendenlinie für Form 1 in myDocument. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


Background-Methode

Gibt an, dass die Füllung der Form dem Folienhintergrund angepasst wird. Ändern Sie den Folienhintergrund, nachdem Sie dieser Methode eine Füllung zugewiesen haben, dann ändert sich auch die Füllung.

Anmerkungen

Wenn Sie der Background-Methode eine Formfüllung zuweisen, ist dies nicht mit dem Festlegen einer transparenten Formfüllung identisch. Außerdem entspricht dies nicht immer dem Zuweisen gleicher Füllungen für Form und Hintergrund. Dies wird im zweiten Beispiel demonstriert.


Beispiel zur Background-Methode

Dieses Beispiel legt fest, dass die Füllung von Form 1 in Folie 1 der aktiven Präsentation dem Folienhintergrund angepasst wird.

ActivePresentation.Slides(1).Shapes(1).Fill.Background

Dieses Beispiel legt als Hintergrund für Folie 1 der aktiven Präsentation einen vordefinierten Verlauf fest, fügt der Folie ein Rechteck hinzu und positioniert anschließend drei Ovale vor das Rechteck. Das erste Oval besitzt eine Füllung, die dem Folienhintergrund angepasst ist, das zweite hat eine transparente Füllung, und das dritte Oval hat die gleiche Füllung, die auch dem Hintergrund zugewiesen wurde. Beachten Sie das jeweils unterschiedliche Erscheinungsbild der drei Ovale.

With ActivePresentation.Slides(1)
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient _
        msoGradientHorizontal, 1, msoGradientDaybreak
    With .Shapes
        .AddShape msoShapeRectangle, 50, 200, 600, 100
        .AddShape(msoShapeOval, 75, 150, 150, 100) _
            .Fill.Background
        .AddShape(msoShapeOval, 275, 150, 150, 100).Fill _
            .Transparency = 1
        .AddShape(msoShapeOval, 475, 150, 150, 100) _
            .Fill.PresetGradient _
            msoGradientHorizontal, 1, msoGradientDaybreak
    End With
End With


BeginConnect-Methode

Fügt den Anfang einer angegebenen Verbindung mit einer angegebenen Form zusammen. Existiert bereits ein Verbund zwischen dem Anfang der Verbindung und einer anderen Form, wird dieser aufgehoben. Ist der Anfang der Verbindung noch nicht am angegebenen Verbindungspunkt positioniert, dann verschiebt diese Methode den Anfang der Verbindung zum Verbindungspunkt und passt die Größe und Position der Verbindung an. Mit der EndConnect-Methode können Sie das Ende der Verbindung mit einer Form zusammenfügen.

Syntax

Ausdruck.BeginConnect(ConnectedShape, ConnectionSite)

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.

ConnectedShape Shape-Objekt erforderlich. Die Form, mit der der Anfang einer Verbindung zusammengefügt werden soll. Das angegebene Shape-Objekt muss in der gleichen Shapes-Auflistung wie die Verbindung vorhanden sein.

ConnectionSite Long erforderlich. Ein Verbindungspunkt in der Form, die von ConnectedShape angegeben ist. Es muss sich um eine ganze Zahl handeln, die im Bereich zwischen 1 und der Zahl liegt, die von der ConnectionSiteCount-Eigenschaft der angegebenen Form zurückgegeben wird. Soll die Verbindung automatisch den kürzesten Pfad zwischen den beiden verbundenen Formen suchen, geben Sie eine gültige ganze Zahl für dieses Argument an, und verwenden Sie die RerouteConnections-Methode, nachdem die Verbindung mit beiden Formen an beiden Enden zusammengefügt worden ist.

Anmerkungen

Wenn Sie eine Verbindung mit einem Objekt zusammenfügen, wird die Größe und Position der Verbindung gegebenenfalls automatisch angepasst.


Beispiel zur BeginConnect-Methode

Dieses Beispiel fügt der ersten Folie der aktiven Präsentation zwei Rechtecke hinzu und verbindet diese mit einer gekrümmten Verbindung. Beachten Sie, dass es durch die RerouteConnections-Methode keine Rolle spielt, welche Werte Sie für die ConnectionSite-Argumente festlegen, die mit der BeginConnect- und EndConnect-Methode verwendet werden.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 100, 100) _
        .ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    .Parent.RerouteConnections
End With


BeginDisconnect-Methode

Löst den Anfang der angegebenen Verbindung von der Form, mit der diese zusammengefügt ist. Diese Methode ändert nicht die Größe oder Position der Verbindung: Der Anfang der Verbindung verbleibt an der Position eines Verbindungspunkts, ist jedoch nicht mehr damit verbunden. Mit der EndDisconnect-Methode können Sie das Ende der Verbindung von einer Form lösen.

Syntax

Ausdruck.BeginDisconnect

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.


Beispiel zur BeginDisconnect-Methode

Dieses Beispiel fügt der ersten Folie der aktiven Präsentation zwei Rechtecke hinzu, fügt diese mit einer Verbindung zusammen, erstellt die Verbindung entlang des kürzesten Pfades neu und löst anschließend die Verbindung mit den Rechtecken.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 0, 0).ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    .Parent.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


BuildFreeform-Methode

Baut ein Freihandobjekt auf. Gibt ein FreeformBuilder-Objekt zurück, das die Freihandfigur während des Aufbaus darstellt. Mit der AddNodes-Methode können Sie Abschnitte zu der Freihandfigur hinzufügen. Nachdem Sie mindestens einen Abschnitt hinzugefügt haben, können Sie mit der ConvertToShape-Methode das FreeformBuilder-Objekt in ein Shape-Objekt umwandeln, das die geometrische Beschreibung enthält, die Sie im FreeformBuilder-Objekt definiert haben.

Syntax

Ausdruck.BuildFreeform(EditingType, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des ersten Knotens. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (jedoch nicht msoEditingSmooth oder msoEditingSymmetric).

X1, Y1 Single erforderlich. Die Position (in Punkt) des ersten Knotens in der Freihandfigur gemessen von der oberen linken Ecke des Dokuments.


Beispiel zur BuildFreeform-Methode

Dieses Beispiel fügt zu myDocument eine Freihandfigur mit vier Segmenten hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, 380, _
        230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Cell-Methode

Gibt ein Cell-Objekt zurück, das eine Zelle in einer Tabelle darstellt.

Syntax

Ausdruck.Cell(Row, Column)

Ausdruck Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt.

Row Long erforderlich. Die Zahl der Zeile in der Tabelle, die zurückgegeben werden soll. Dies kann eine ganze Zahl zwischen 1 und der Anzahl der Zeilen in der Tabelle sein.

Column Long erforderlich. Die Zahl der Spalte in der Tabelle, die zurückgegeben werden soll. Dies kann eine ganze Zahl zwischen 1 und der Anzahl der Spalten in der Tabelle sein.


Beispiel zur Cell-Methode

In diesem Beispiel wird auf einer neuen Folie eine Tabelle mit drei Zeilen und drei Spalten erstellt und in die erste Zelle der Tabelle Text eingegeben.

With Presentations.Add
    With .Slides.Add(1, ppLayoutBlank)
        .Shapes.AddTable(3, 3).Select
        .Shapes(1).Table.Cell(1, 1).Shape.TextFrame _
            .TextRange.Text = "Cell 1"
    End With
End With

In diesem Beispiel wird die Stärke des Rahmens der Zelle in Zeile 2, Spalte 1 auf zwei Punkt gesetzt.

ActivePresentation.Slides(2).Shapes(5).Table _
    .Cell(2, 1).Borders(ppBorderBottom).Weight = 2


ChangeCase-Methode

Ändert die Groß-/Kleinschreibung im angegebenen Text.

Syntax

Ausdruck.ChangeCase(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Type Long erforderlich. Legt die Art fest, wie die Groß-/Kleinschreibung geändert wird. Dies kann eine der folgenden PpChangeCase-Konstanten sein: ppCaseLower, ppCaseSentence, ppCaseTitle, ppCaseToggle.


Beispiel zur ChangeCase-Methode

In diesem Beispiel wird die Groß-/Kleinschreibung für den Titel der ersten Folie auf Großschreibung gesetzt.

Application.ActivePresentation.Slides(1).Shapes.Title.TextFrame _
    .TextRange.ChangeCase ppCaseTitle


Characters-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textzeichen darstellt. Informationen über Zählvorgänge und Schleifenläufe durch die Zeichen eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Characters(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Das erste Zeichen im zurückgegebenen Bereich.

Length Long optional. Die Anzahl der zurückzugebenden Zeichen.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit dem ersten Zeichen und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau ein Zeichen.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit dem ersten Zeichen des festgelegten Bereichs.

Ist Start größer als die Anzahl der Zeichen des festgelegten Textes, beginnt der zurückgegebene Bereich mit dem letzten Zeichen des festgelegten Bereichs.

Ist Length größer als die Anzahl der Zeichen von dem festgelegten Anfangszeichen bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Zeichen.


Beispiel zur Characters-Methode

In diesem Beispiel wird der Text für die zweite Form der ersten Folie in der aktiven Präsentation festgelegt und anschließend dem zweiten Zeichen eine Tieferstellung um 20 Prozent zugewiesen.

Dim charRange As TextRange
With Application.ActivePresentation.Slides(1).Shapes(2)
    Set charRange = .TextFrame.TextRange.InsertBefore("H2O")
    charRange.Characters(2).Font.BaselineOffset = -0.2
End With

In diesem Beispiel wird jedes tiefer gestellte Zeichen in der zweiten Form der ersten Folie fett formatiert.

With Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange
    For i = 1 To .Characters.Count
        With .Characters(i).Font
            If .Subscript Then .Bold = True
        End With
    Next
End With


Clear-Methode

Entfernt den angegebenen Tabstop aus dem Lineal und löscht diesen in der TabStops-Auflistung.


ClearAll-Methode

Löscht alle Druckbereiche der PrintRanges-Auflistung. Mit der Add-Methode der PrintRanges-Auflistung können Sie der Auflistung neue Druckbereiche hinzufügen.

Syntax

Ausdruck.ClearAll

Ausdruck Erforderlich. Ein Ausdruck, der ein PrintRange-Objekt zurückgibt.


Beispiel zur ClearAll-Methode

Dieses Beispiel löscht alle zuvor definierten Druckbereiche der aktiven Präsentation. Anschließend werden neue Druckbereiche für Folie 1, Folie 3 bis 5 sowie Folie 8 und 9 erstellt, die neu definierten Folienbereiche gedruckt und die neuen Druckbereiche gelöscht.

With ActivePresentation.PrintOptions
    .RangeType = ppPrintSlideRange
    With .Ranges
        .ClearAll
        .Add 1, 1
        .Add 3, 5
        .Add 8, 9
        .Parent.Parent.PrintOut
        .ClearAll
    End With
End With


Close-Methode

Schließt das angegebene Dokumentfenster, die angegebene Präsentation oder die offene Freihandzeichnung.

Vorsicht Bei der Verwendung dieser Methode schließt PowerPoint eine geöffnete Präsentation, ohne den Benutzer zum Speichern seiner Arbeit aufzufordern. Um einen Datenverlust zu verhindern, verwenden Sie vor dem Einsatz der Close-Methode die SaveAs- oder die Save-Methode.

Syntax

Ausdruck.Close

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow- oder Presentation-Objekt zurückgibt.


Beispiel zur Close-Methode

In diesem Beispiel werden alle Fenster mit Ausnahme des aktiven Fensters geschlossen.

With Application.Windows
    For i = 2 To .Count
        .Item(i).Close
    Next
End With

In diesem Beispiel wird pres1.ppt geschlossen, ohne Änderungen zu speichern.

With Application.Presentations("pres1.ppt")
    .Saved = True
    .Close
End With

In diesem Beispiel werden alle offenen Präsentationen geschlossen.

With Application.Presentations
    For i = .Count To 1 Step -1
        .Item(i).Close
    Next
End With


Colors-Methode

Gibt ein RGBColor-Objekt zurück, das eine einzelne Farbe in einer Farbskala darstellt.

Syntax

Ausdruck.Colors(SchemeColor)

Ausdruck Erforderlich. Ein Ausdruck, der ein ColorScheme-Objekt zurückgibt.

SchemeColor Long erforderlich. Die individuelle Farbe in der angegebenen Farbskala. Dies kann eine der folgenden PpColorSchemeIndex-Konstanten sein: ppAccent1, ppAccent2, ppAccent3, ppBackground, ppFill, ppForeground, ppNotSchemeColor, ppSchemeColorMixed, ppShadow oder ppTitle.


Beispiel zur Colors-Methode

Dieses Beispiel legt die Titelfarbe für die Folien 1 und 3 der aktiven Präsentation fest.

Set mySlides = ActivePresentation.Slides.Range(Array(1, 3))
mySlides.ColorScheme.Colors(ppTitle).RGB = RGB(0, 255, 0)


ConvertToShape-Methode

Erstellt eine Form mit den geometrischen Charakteristika des angegebenen FreeformBuilder-Objekts. Gibt ein Shape-Objekt zurück, das die neue Form darstellt.

Hinweis Die AddNodes-Methode muss für ein FreeformBuilder-Objekt mindestens einmal zugewiesen werden, bevor Sie die ConvertToShape-Methode verwenden können.

Syntax

Ausdruck.ConvertToShape

Ausdruck Erforderlich. Ein Ausdruck, der ein FreeformBuilder-Objekt zurückgibt.


Beispiel zur ConvertToShape-Methode

Dieses Beispiel fügt der ersten Folie der aktiven Präsentation eine Freihandfigur mit fünf Scheitelpunkten hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, _
        msoEditingCorner, 380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Copy-Methode

Kopiert das angegebene Objekt in die Zwischenablage.

Syntax

Ausdruck.Copy

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-, Shape-, ShapeRange-, Slide-, SlideRange- oder TextRange-Objekt zurückgibt.

Anmerkungen

Mit der Paste-Methode können Sie den Inhalt in die Zwischenablage einfügen.


Beispiel zur Copy-Methode

Dieses Beispiel kopiert die Markierung in Fenster 1 in die Zwischenablage und fügt diese anschließend in die Ansicht in Fenster 2 ein. Wenn die Inhalte der Zwischenablage nicht in die Ansicht in Fenster 2 eingefügt werden können (wenn z. B. eine Form in die Foliensortieransicht eingefügt werden soll), schlägt dieses Beispiel fehl.

Windows(1).Selection.Copy
Windows(2).View.Paste

Dieses Beispiel kopiert Form 1 und 2 in Folie 1 in der aktiven Präsentation in die Zwischenablage und fügt anschließend die Kopien in Folie 2 ein.

With ActivePresentation
    .Slides(1).Shapes.Range(Array(1, 2)).Copy
    .Slides(2).Shapes.Paste
End With

Dieses Beispiel kopiert Folie 1 in der aktiven Präsentation in die Zwischenablage.

ActivePresentation.Slides(1).Copy

Dieses Beispiel kopiert den Text in Form 1 in Folie 1 in der aktiven Präsentation in die Zwischenablage.

ActivePresentation.Slides(1).Shapes(1).TextFrame.TextRange.Copy


CreateNewDocument-Methode

Erstellt eine mit dem angegebenen Hyperlink verbundene neue Webpräsentation.

Syntax

Ausdruck.CreateNewDocument(FileName, EditNow, Overwrite)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

FileName String erforderlich. Der Pfad und Dateiname des Dokuments.

EditNow Boolean erforderlich. True, wenn Sie das Dokument sofort zum Bearbeiten in dem ihm zugeordneten Editor öffnen möchten. False, wenn Sie das Dokument nicht sofort öffnen möchten. Der Standardwert ist True.

Overwrite Erforderlich Boolean. True, wenn Sie gegebenenfalls eine vorhandene Datei mit demselben Namen unter demselben Pfad überschreiben möchten. False, wenn Sie gegebenenfalls eine vorhandene Datei mit demselben Namen in demselben Ordner behalten möchten. In diesem Fall müssen Sie mit dem Argument FileName einen neuen Dateinamen angeben. Der Standardwert ist False.


Beispiel zur CreateNewDocument-Methode

In diesem Beispiel wird eine neue Webpräsentation erstellt, die mit dem Hyperlink 1 auf Folie 1 verbunden ist. Die neue Präsentation wird im Ordner HTMLPres unter dem Namen Brittany.ppt gespeichert, wobei gegebenenfalls eine gleichnamige Datei überschrieben wird. Das neue Präsentationsdokument wird sofort zum Bearbeiten in Microsoft PowerPoint geladen.

ActivePresentation.Slides(1).Hyperlinks(1).CreateNewDocument _
    FileName:="C:\HTMLPres\Brittany.ppt", _
    EditNow:=True, _
    Overwrite:=True


CustomDrop-Methode

Legt den vertikalen Abstand (in Punkt) von der Seite des Text-Begrenzungsrechtecks bis zu der Stelle fest, an der die Legendenlinie mit dem Textfeld verbunden ist. Dieser Abstand wird von der Oberseite des Textfeldes gemessen, es sei denn, für die AutoAttach-Eigenschaft gilt True und das Textfeld befindet sich links vom Ursprung der Legendenlinie (die Stelle, auf die die Legende deutet). In diesem Fall wird der Bezugsabstand von der Unterseite des Textfeldes gemessen.

Syntax

Ausdruck.CustomDrop(Drop)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Drop Single erforderlich. Der Bezugsabstand in Punkt.


Beispiel zur CustomDrop-Methode

Dieses Beispiel legt den benutzerdefinierten Bezugsabstand auf 14 Punkt fest. Außerdem wird angegeben, dass der Bezugsabstand immer von der Oberseite gemessen wird. Damit dieses Beispiel funktioniert, muss Form 3 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Callout
    .CustomDrop 14
    .AutoAttach = False
End With


CustomLength-Methode

Gibt an, dass der erste Abschnitt der Legendenlinie (der Abschnitt, der mit dem Legenden-Textfeld verbunden ist) eine feste Länge beibehält, wenn die Legende verschoben wird. Mit der AutomaticLength-Methode können Sie angeben, dass der erste Abschnitt der Legendenlinie automatisch skaliert wird, wenn Sie die Legende verschieben. Dies betrifft nur Legenden, deren Linien aus mehreren Abschnitten bestehen (die Typen msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.CustomLength(Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Length Single erforderlich. Die Länge des ersten Abschnitts der Legende in Punkt.

Anmerkungen

Wenn Sie diese Methode zuweisen, wird für die AutoLength-Eigenschaft False und für die Length-Eigenschaft der Wert festgelegt, der für das Length-Argument angegeben wurde.


Beispiel zur CustomLength-Methode

Dieses Beispiel wechselt zwischen einem automatisch skalierenden ersten Abschnitt und einem Abschnitt mit einer festen Länge für die Legendenlinie für Form 1 in myDocument. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


Cut-Methode

Löscht das angegebene Objekt und kopiert es in die Zwischenablage.

Syntax

Ausdruck.Cut

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection, Shape, ShapeRange, Slide, SlideRange- oder TextRange-Objekt zurückgibt.


Beispiel zur Cut-Methode

Dieses Beispiel löscht die Markierung in Fenster 1 und kopiert es in die Zwischenablage.

Windows(1).Selection.Cut

Dieses Beispiel löscht Form 1 und 2 von Folie 1 in der aktiven Präsentation, kopiert sie in die Zwischenablage, und fügt anschließend die Kopien in Folie 2 ein.

With ActivePresentation
    .Slides(1).Shapes.Range(Array(1, 2)).Cut
    .Slides(2).Shapes.Paste
End With

Dieses Beispiel löscht Folie 1 der aktiven Präsentation und kopiert sie in die Zwischenablage.

ActivePresentation.Slides(1).Cut

Dieses Beispiel löscht den Text von Form 1 in Folie 1 der aktiven Präsentation und kopiert diesen in die Zwischenablage.

ActivePresentation.Slides(1).Shapes(1).TextFrame.TextRange.Cut


Delete-Methode

Syntax 1: Löscht das angegebene Objekt.

Syntax 2: Löscht den angegebenen Knoten.

Syntax 3: Löscht die angegebene Marke.

Syntax 1

Ausdruck.Delete

Syntax 2

Ausdruck.Delete(Index)

Syntax 3

Ausdruck.Delete(Name)

Ausdruck Syntax 1: Ein Ausdruck, der das Objekt zurückgibt, das gelöscht werden soll.

Syntax 2: Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Syntax 3: Ein Ausdruck, der ein Tags-Objekt zurückgibt.

Index Integer erforderlich. Gibt den Knoten an, der gelöscht werden soll. Das Segment, das auf den Knoten folgt, wird ebenfalls gelöscht. Handelt es sich bei dem Knoten um einen Kontrollpunkt einer Kurve, wird die Kurve mit allen dazugehörigen Knoten gelöscht.

Name String erforderlich. Gibt den Namen der Marke an, die gelöscht werden soll.

Hinweise

Ein Laufzeitfehler tritt auf, wenn Sie die einzige vorhandene Zeile oder Spalte einer Tabelle löschen möchten.


DeleteText-Methode

Löscht den der angegebenen Form zugeordneten Text.

Syntax

Ausdruck.DeleteText

Ausdruck Erforderlich. Ein Ausdruck, der ein TextFrame-Objekt zurückgibt.


Beispiel zur DeleteText-Methode

Wenn Form 2 in myDocument Text enthält, wird durch dieses Beispiel der Text gelöscht.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(2).TextFrame.DeleteText


Distribute-Methode

Verteilt die Formen im angegebenen Formenbereich gleichmäßig. Sie können angeben, ob die Formen horizontal oder vertikal verteilt werden sollen. Sie können auch angeben, ob sie über die gesamte Folie oder lediglich über den ursprünglich belegten Raum verteilt werden sollen.

Syntax

Ausdruck.Distribute(DistributeCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

DistributeCmd Long erforderlich. Gibt an, ob die Formen im Bereich horizontal oder vertikal verteilt werden. Dies kann eine der folgenden MsoDistributeCmd-Konstanten sein: msoDistributeHorizontally oder msoDistributeVertically.

RelativeTo Long erforderlich. True, um die Formen gleichmäßig über den gesamten horizontalen oder vertikalen Raum auf der Folie zu verteilen. False, um die Formen innerhalb des horizontalen oder vertikalen Raums zu verteilen, den der Bereich der Formen ursprünglich belegt.


Beispiel zur Distribute-Methode

Dieses Beispiel definiert einen Formbereich, der alle AutoFormen von myDocument enthält. Anschließend werden die Formen horizontal in diesem Bereich verteilt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numAutoShapes = 0
        ReDim autoShpArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoAutoShape Then
                numAutoShapes = numAutoShapes + 1
                autoShpArray(numAutoShapes) = .Item(i).Name
            End If
        Next
        If numAutoShapes > 1 Then
            ReDim Preserve autoShpArray(1 To numAutoShapes)
            Set asRange = .Range(autoShpArray)
            asRange.Distribute msoDistributeHorizontally, False
        End If
    End If
End With


 DoVerb-Methode

DoVerb-Methode

Fordert an, dass ein OLE-Objekt ein Verb ausführt. Mit der ObjectVerbs-Eigenschaft können Sie die verfügbaren Verben für ein OLE-Objekt bestimmen.

Syntax

Ausdruck.DoVerb(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEFormat-Objekt zurückgibt.

Index optional Integer. Das Verb, das ausgeführt werden soll. Wird dieses Argument nicht angegeben, wird das Standardverb ausgeführt.


Beispiel zur DoVerb-Methode

In diesem Beispiel wird das Standardverb für Form 3 von Folie 1 in der aktiven Präsentation ausgeführt, wenn Form 3 ein verknüpftes oder eingebettetes OLE-Objekt ist.

With ActivePresentation.Slides(1).Shapes(3)
    If .Type = msoEmbeddedOLEObject Or _
            .Type = msoLinkedOLEObject Then
        .OLEFormat.DoVerb
    End If
End With

Dieses Beispiel führt das Verb "Open" für Form 3 von Folie 1 in der aktiven Präsentation aus, wenn Form 3 ein OLE-Objekt ist, das das Verb "Open" unterstützt.

With ActivePresentation.Slides(1).Shapes(3)
    If .Type = msoEmbeddedOLEObject Or _
            .Type = msoLinkedOLEObject Then
        For Each sVerb In .OLEFormat.ObjectVerbs
            nCount = nCount + 1
            If sVerb = "Open" Then
                .OLEFormat.DoVerb nCount
                Exit For
            End If
        Next
    End If
End With


DrawLine-Methode

Zeichnet eine Linie in der angegebenen Bildschirmpräsentationsansicht.

Syntax

Ausdruck.DrawLine(BeginX, BeginY, EndX, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Anfangspunkts der Linie relativ zur oberen linken Ecke der Folie.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunkts der Linie relativ zur oberen linken Ecke der Folie.


Beispiel zur DrawLine-Methode

In diesem Beispiel wird in Bildschirmpräsentationsfenster 1 eine Linie gezeichnet.

SlideShowWindows(1).View.DrawLine 5, 5, 250, 250


Duplicate-Methode

Shape-Objekt: Erstellt ein Duplikat des angegebenen Shape-Objekts, fügt die neue Form zur Shapes-Auflistung direkt nach der ursprünglich angegebenen Form hinzu und gibt anschließend das neue Shape-Objekt zurück.

ShapeRange-Objekt: Erstellt ein Duplikat des angegebenen ShapeRange-Objekts, fügt den neuen Bereich der Formen zur Shapes-Auflistung direkt nach dem ursprünglich angegebenen Bereich der Formen hinzu und gibt anschließend das neue ShapeRange-Objekt zurück.

Slide-Objekt: Erstellt ein Duplikat des angegebenen Slide-Objekts, fügt die neue Folie zur Slides-Auflistung direkt nach der ursprünglich angegebenen Folie hinzu und gibt anschließend ein Slide-Objekt zurück, das das Duplikat der Folie darstellt.

SlideRange-Objekt: Erstellt ein Duplikat des angegebenen SlideRange-Objekts, fügt den neuen Bereich der Folien zur Slides-Auflistung direkt nach dem ursprünglich angegebenen Folienbereich hinzu und gibt anschließend ein SlideRange-Objekt zurück, das das Duplikat der Folien darstellt.

Syntax

Ausdruck.Duplicate

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-, ShapeRange-, Slide- oder SlideRange-Objekt zurückgibt.


Beispiel zur Duplicate-Methode

Dieses Beispiel erstellt ein Duplikat von Folie 1 in der aktiven Präsentation und legt anschließend die Hintergrundschattierung und den Titeltext der neuen Folie fest. Die neue Folie wird Folie 2 der Präsentation.

Set newSlide = ActivePresentation.Slides(1).Duplicate
With newSlide
    .Background.Fill.PresetGradient msoGradientVertical, _
        1, msoGradientGold
    .Shapes.Title.TextFrame.TextRange _
        .Text = "Second Quarter Earnings"
End With

Dieses Beispiel fügt eine neue, leere Folie an das Ende der aktiven Präsentation hinzu, fügt eine Diamantform zur neuen Folie hinzu, dupliziert die Diamantform und legt anschließend die Eigenschaften für das Duplikat fest. Der erste Diamant erhält die Standard-Füllfarbe für die aktive Farbskala. Der zweite Diamant wird vom ersten Diamanten versetzt positioniert und erhält die Standard-Schattenfarbe.

Set mySlides = ActivePresentation.Slides
Set newSlide = mySlides.Add(mySlides.Count + 1, ppLayoutBlank)
Set firstObj = newSlide.Shapes _
    .AddShape(msoShapeDiamond, 10, 10, 250, 350)
With firstObj.Duplicate
    .Left = 150
    .Fill.ForeColor.SchemeColor = ppShadow
End With


EndConnect-Methode

Fügt das Ende einer angegebenen Verbindung mit einer angegebenen Form zusammen. Existiert bereits ein Verbund zwischen dem Ende der Verbindung und einer anderen Form, wird dieser aufgehoben. Ist das Ende der Verbindung noch nicht am angegebenen Verbindungspunkt positioniert, dann verschiebt diese Methode das Ende der Verbindung zum Verbindungspunkt und passt die Größe und Position der Verbindung an. Mit der BeginConnect-Methode können Sie den Anfang der Verbindung mit einer Form zusammenfügen.

Syntax

Ausdruck.EndConnect(ConnectedShape, ConnectionSite)

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.

ConnectedShape Shape-Objekt erforderlich. Die Form, mit der das Ende einer Verbindung zusammengefügt werden soll. Das angegebene Shape-Objekt muss in der gleichen Shapes-Auflistung wie die Verbindung vorhanden sein.

ConnectionSite Long erforderlich. Ein Verbindungspunkt in der Form, die von ConnectedShape angegeben ist. Es muss sich um eine ganze Zahl handeln, die im Bereich zwischen 1 und der Zahl liegt, die von der ConnectionSiteCount-Eigenschaft der angegebenen Form zurückgegeben wird. Soll die Verbindung automatisch den kürzesten Pfad zwischen den beiden verbundenen Formen suchen, geben Sie eine gültige ganze Zahl für dieses Argument an, und verwenden Sie die RerouteConnections-Methode, nachdem die Verbindung mit beiden Formen an beiden Enden zusammengefügt worden ist.

Anmerkungen

Wenn Sie eine Verbindung mit einem Objekt zusammenfügen, wird die Größe und Position der Verbindung gegebenenfalls automatisch angepasst.


Beispiel zur EndConnect-Methode

Dieses Beispiel fügt der ersten Folie der aktiven Präsentation zwei Rechtecke hinzu und verbindet diese mit einer gekrümmten Verbindung. Beachten Sie, dass es durch die RerouteConnections-Methode keine Rolle spielt, welche Werte Sie für die ConnectionSite-Argumente festlegen, die mit der BeginConnect- und EndConnect-Methode verwendet werden.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 100, 100) _
        .ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    .Parent.RerouteConnections
End With


EndDisconnect-Methode

Löst das Ende der angegebenen Verbindung von der Form, mit der diese zusammengefügt ist. Diese Methode ändert nicht die Größe oder Position der Verbindung: Das Ende der Verbindung verbleibt an der Position eines Verbindungspunkts, ist jedoch nicht mehr damit verbunden. Mit der BeginDisconnect-Methode können Sie den Anfang der Verbindung von einer Form lösen.

Syntax

Ausdruck.EndDisconnect

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.


Beispiel zur EndDisconnect-Methode

Dieses Beispiel fügt der ersten Folie der aktiven Präsentation zwei Rechtecke hinzu, fügt diese mit einer Verbindung zusammen, erstellt die Verbindung entlang des kürzesten Pfades neu und löst anschließend die Verbindung mit den Rechtecken.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 0, 0).ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    .Parent.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


EndNamedShow-Methode

Wechselt beim Ablauf von einer benutzerdefinierten oder benannten Bildschirmpräsentation zum Ablauf der gesamten Präsentation, wobei die benutzerdefinierte Bildschirmpräsentation eine Untermenge davon ist. Wenn die Bildschirmpräsentation von der aktuellen Folie zur nächsten Folie übergeht, handelt es sich bei der nächsten angezeigten Folie nicht um die nächste Folie der benutzerdefinierten Bildschirmpräsentation, sondern um die nächste Folie der gesamten Präsentation.

Syntax

Ausdruck.EndNamedShow

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.


Beispiel zur EndNamedShow-Methode

Läuft eine benutzerdefinierte Bildschirmpräsentation aktuell im Bildschirmpräsentationsfenster 1 ab, definiert dieses Beispiel die Bildschirmpräsentation neu, damit alle Folien der Präsentation eingeschlossen sind, aus der die Folien in der benutzerdefinierten Bildschirmpräsentation ausgewählt wurden.

SlideShowWindows(1).View.EndNamedShow


EraseDrawing-Methode

Entfernt eine Linie, die während einer Bildschirmpräsentation mit der DrawLine-Methode oder dem Stift-Hilfsmittel gezeichnet wurde.

Syntax

Ausdruck.EraseDrawing

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.


Beispiel zur EraseDrawing-Methode

In diesem Beispiel werden alle Linien gelöscht, die in Bildschirmpräsentationsfenster 1 mit der DrawLine-Methode oder dem Stift-Hilfsmittel gezeichnet wurden.

SlideShowWindows(1).View.EraseDrawing


Exit-Methode

Beendet die angegebene Bildschirmpräsentation.

Syntax

Ausdruck.Exit

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.


Beispiel zur Exit-Methode

In diesem Beispiel wird die Bildschirmpräsentation beendet, die in Bildschirmpräsentationsfenster 1 läuft.

SlideShowWindows(1).View.Exit


Export-Methode

Presentation-Objekt: Exportiert jede Folie in der Präsentation mit dem angegebenen Grafikfilter und speichert die exportierten Dateien im angegebenen Ordner.

Slide- oder SlideRange-Objekt: Exportiert eine Folie oder einen Folienbereich mit dem angegebenen Grafikfilter und speichert die exportierte Datei unter dem angegebenen Dateinamen.

Syntax 1

Ausdruck.Export(Path, FilterName, ScaleWidth, ScaleHeight)

Syntax 2

Ausdruck.Export(FileName, FilterName, ScaleWidth, ScaleHeight)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt (Syntax 1) bzw. ein Slide- oder SlideRange-Objekt (Syntax 2) zurückgibt.

Path String erforderlich. Der Pfad für den Ordner, in dem die exportierten Folien gespeichert werden sollen. Sie können einen vollständigen Pfad angeben. Wenn Sie keinen vollständigen Pfad angeben, erstellt PowerPoint für die exportierten Folien einen Unterordner im aktuellen Ordner.

FileName String erforderlich. Der Name der Datei, die exportiert und auf einem Datenträger gespeichert werden soll. Sie können einen vollständigen Pfad angeben. Wenn Sie keinen vollständigen Pfad angeben, erstellt PowerPoint eine Datei im aktuellen Ordner.

FilterName String erforderlich. Das Grafikformat, in das die Folien exportiert werden sollen. Der Exportfilter des angegebenen Grafikformats muss in der Windows-Registrierung registriert sein. Sie können entweder die registrierte Erweiterung oder den registrierten Namen des Filters angeben. PowerPoint durchsucht die Systemregistrierung zuerst nach einer übereinstimmenden Erweiterung. Wenn keine Erweiterung mit der angegebenen Zeichenfolge übereinstimmt, wird nach einem übereinstimmenden Filternamen gesucht.

ScaleWidth Long optional. Die Breite einer exportierten Folie in Pixel.

ScaleHeight Long optional. Die Höhe einer exportierten Folie in Pixel.

Hinweise

Wenn Sie eine Präsentation exportieren, wird die Saved-Eigenschaft einer Präsentation nicht auf True gesetzt.

PowerPoint verwendet den angegebenen Grafikfilter, um jede einzelne Folie der Präsentation zu speichern. Die Namen für die exportierten und auf dem Datenträger gespeicherten Folien werden von PowerPoint bestimmt. In der Regel werden die Folien unter den Namen Folie1.WMF, Folie2.WMF usw. gespeichert. Der Pfad für die gespeicherten Dateien wird im Path-Argument angegeben.


Beispiel zur Export-Methode

Dieses Beispiel speichert die aktive Präsentation als PowerPoint-Präsentation und exportiert anschließend jede Folie der Präsentation im Format "Portable Network Graphics (PNG)" im Ordner "Current work". In diesem Beipiel wird außerdem jede exportierte Folie auf die Hälfte der Höhe und Breite des Originals skaliert.

With ActivePresentation
    .SaveAs "c:\current work\Annual Sales", ppSaveAsPresentation
    .Export "c:\current work", "png", 0.5, 0.5
End With

Dieses Beispiel exportiert Folie 3 in der aktiven Präsentation auf den Datenträger im Format JPEG. Die Folie wird unter dem Namen "Slide 3 of Annual Sales.jpg" gespeichert.

With Application.ActivePresentation.Slides(3)
    .Export "c:\my documents\Graphic Format\" & _
        "Slide 3 of Annual Sales", "JPG"
End With


Find-Methode

Sucht den angegebenen Text in einem Textbereich und gibt ein TextRange-Objekt zurück, das den ersten Textbereich darstellt, in dem der Text gefunden wird. Gibt Nothing zurück, falls keine Übereinstimmung gefunden wird.

Syntax

Ausdruck.Find(FindWhat, After, MatchCase, WholeWords)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

FindWhat String erforderlich. Der zu suchende Text.

After Long optional. Die Position des Zeichens (in dem angegebenen Textbereich), nach dem Sie die Suche nach dem nächsten Auftreten von FindWhat beginnen wollen. Wenn Sie z. B. ab dem fünften Zeichen des Textbereichs suchen wollen, geben Sie 4 für After an. Wird dieses Argument nicht angewendet, wird die Suche bei dem ersten Zeichen des Textbereichs begonnen.

MatchCase Long optional. Wenn der Wert True ist, wird bei der Suche zwischen groß- und kleingeschriebenen Zeichen unterschieden. Der Standardwert ist False.

WholeWords Long optional. Wenn der Wert True ist, wird nur nach ganzen Wörtern und nicht nach Wortteilen gesucht. Der Standardwert ist False.


FindBySlideID-Methode

Gibt ein Slide-Objekt zurück, das die Folie mit der angegebenen Folien-ID darstellt. Jeder Folie wird automatisch eine eindeutige Folien-ID zugewiesen, wenn sie erstellt wird. Mit der SlideID-Eigenschaft können Sie die Folien-ID zurückgeben.

Syntax

Ausdruck.FindBySlideID(SlideID)

Ausdruck Erforderlich. Ein Ausdruck, der eine Slides-Auflistung zurückgibt.

SlideID Long erforderlich. Gibt die ID der Folie an, die zurückgegeben werden soll. PowerPoint weist diese Nummer zu, wenn die Folie erstellt wird.

Anmerkungen

Im Gegensatz zur SlideIndex-Eigenschaft ändert sich die SlideID-Eigenschaft eines Slide-Objekts nicht, wenn Sie der Präsentation Folien hinzufügen oder die Folien in der Präsentation neu anordnen. Deshalb ist die FindBySlideID-Methode mit der ID-Nummer besser geeignet, um ein bestimmtes Slide-Objekt von einer Slides-Auflistung zurückzugeben, als die Item-Methode mit der Indexnummer der Folie.


Beispiel zur FindBySlideID-Methode

Dieses Beispiel zeigt, wie die eindeutige ID-Nummer für ein Slide-Objekt abgerufen und anschließend verwendet werden muss, um das Slide-Objekt von der Slides-Auflistung zurückzugeben.

Set gslides = ActivePresentation.Slides

'Get slide ID
graphSlideID = gslides.Add(2, ppLayoutChart).SlideID
gslides.FindBySlideID(graphSlideID) _
    .SlideShowTransition.EntryEffect = _
    ppEffectCoverLeft      'Use ID to return specific slide


First-Methode

Legt für die angegebene Bildschirmpräsentationsansicht fest, dass die erste Folie der Präsentation angezeigt wird.

Syntax

Ausdruck.First

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.

Anmerkungen

Wenn Sie die First-Methode verwenden, um während einer Bildschirmpräsentation von einer Folie zu einer anderen zu wechseln, wird die Animation der ursprünglichen Folie, wenn Sie zu dieser zurückkehren, an der Stelle wieder aufgenommen, an der sie beim Wechsel zur anderen Folie unterbrochen wurde.


Beispiel zur First-Methode

In diesem Beispiel wird für das Bildschirmpräsentationsfenster 1 festgelegt, dass die erste Folie der Präsentation angezeigt wird.

SlideShowWindows(1).View.First


FitToPage-Methode

Passt die Größe des angegebenen Dokumentfensters so an, dass alle Daten angezeigt werden.

Syntax

Ausdruck.FitToPage

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.


Beispiel zur FitToPage-Methode

In diesem Beispiel wird die aktuelle Bildschirmpräsentation geschlossen und für das aktive Fenster die Folienansicht und ein Zoom von 25% festgelegt. Außerdem wird die Größe des Fensters so angepasst, dass die Folie darin angezeigt werden kann.

Application.SlideShowWindows(1).View.Exit
With Application.ActiveWindow
    .ViewType = ppViewSlide
    .View.Zoom = 25
    .FitToPage
End With


Flip-Methode

Kippt die angegebene Form um dessen horizontale oder vertikale Achse.

Syntax

Ausdruck.Flip(FlipCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

FlipCmd Long erforderlich. Gibt an, ob die Form horizontal oder vertikal gekippt wird. Dies kann eine der folgenden MsoFlipCmd-Konstanten sein: msoFlipHorizontal oder msoFlipVertical.


Beispiel zur Flip-Methode

Dieses Beispiel fügt ein Dreieck zu myDocument hinzu, dupliziert dieses Dreieck, und kippt anschließend das Duplikat vertikal und weist diesem die Farbe Rot zu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRightTriangle, 10, 10, 50, 50).Duplicate
    .Fill.ForeColor.RGB = RGB(255, 0, 0)
    .Flip msoFlipVertical
End With


Follow-Methode

Zeigt das mit dem angegebenen Hyperlink verbundene HTML-Dokument in einem neuen Webbrowserfenster an.

Syntax

Ausdruck.Follow

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.


FollowHyperlink-Methode

Zeigt ein Dokument aus dem Cache an, wenn es bereits heruntergeladen ist. Andernfalls löst diese Methode den Hyperlink auf, lädt das Zieldokument herunter und zeigt dieses in der entsprechenden Anwendung an.

Syntax

Ausdruck.FollowHyperlink(Address, SubAddress, NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

Address String erforderlich. Die Adresse des Zieldokuments.

SubAddress String optional. Die Position im Zieldokument. Der Standard ist eine leere Zeichenfolge.

NewWindow Long optional. True, um die Zielanwendung in einem neuen Fenster zu öffnen. Der Standardwert ist False.

AddHistory Long optional. True, wenn der Link zum Verlaufsordner des aktuellen Tages hinzugefügt werden soll.

ExtraInfo String optional. Zeichenfolgen- oder Bytematrix, die Informationen für HTTP angibt. Dieses Argument kann z. B. verwendet werden, um die Koordinaten einer Imagemap oder den Inhalt eines Formulars anzugeben. Außerdem kann der Name einer FAT-Datei angezeigt werden. Das Method-Argument bestimmt, wie diese zusätzlichen Informationen gesteuert werden.

Method Long optional. Gibt an, wie zusätzliche Informationen für HTTP gesteuert werden, die vom ExtraInfo-Argument angegeben werden. Dies kann eine der folgenden MsoExtraInfoMethod-Konstanten sein:

Konstante | Beschreibung
msoMethodGet | ExtraInfo ist ein String, der der Adresse angehängt ist. Dies ist der Standard.
msoMethodPost | ExtraInfo wird als String oder als Bytematrix abgelegt.

HeaderInfo Optional Variant. Eine Zeichenfolge, die Headerinformationen für die HTTP-Anforderung angibt. Der Standardwert ist eine leere Zeichenfolge. Mit der folgenden Syntax können Sie verschiedene Headerzeilen zu einer einzigen Zeichenfolge zusammenfassen: "Zeichenfolge1" & vbCr & "Zeichenfolge2". Die angegebene Zeichenfolge wird automatisch in ANSI-Zeichen konvertiert. Beachten Sie, dass das HeaderInfo-Argument Standard-HTTP-Headerfelder überschreiben kann.


Beispiel zur FollowHyperlink-Methode

In diesem Beispiel wird das Dokument bei www.gohere.com in einem neuen Fenster geladen und dem Verlaufordner hinzugefügt.

ActivePresentation.FollowHyperlink _
    Address:="http://www.gohere.com", _
    NewWindow:=True, AddHistory:=True


GotoNamedShow-Methode

Wechselt zur angegebenen benutzerdefinierten oder benannten Bildschirmpräsentation während einer anderen Bildschirmpräsentation. Wenn die Bildschirmpräsentation von der aktuellen Folie zur nächsten Folie übergeht, handelt es sich bei der nächsten angezeigten Folie nicht um die nächste Folie der aktuellen Bildschirmpräsentation, sondern um die nächste Folie der angegebenen Präsentation.

Syntax

Ausdruck.GotoNamedShow(SlideShowName)

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.

SlideShowName String erforderlich. Der Name der benutzerdefinierten Bildschirmpräsentation, zu der gewechselt werden soll.


Beispiel zur GotoNamedShow-Methode

Läuft eine Bildschirmpräsentation aktuell im Bildschirmpräsentationsfenster 1 ab, definiert dieses Beispiel die Bildschirmpräsentation neu, damit nur die Folien der benutzerdefinierten Bildschirmpräsentation "Quick Show" eingeschlossen werden.

SlideShowWindows(1).View.GotoNamedShow "Quick Show"


GotoSlide-Methode

View-Objekt: Wechselt zur angegebenen Folie.

SlideShowView-Objekt: Wechselt während einer Bildschirmpräsentation zur angegebenen Folie. Sie können angeben, ob die Animationseffekte erneut gestartet werden sollen.

Syntax 1

Ausdruck.GotoSlide(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.

Index Long erforderlich. Die Nummer der Folie, zu der gewechselt werden soll.

Syntax 1

Ausdruck.GotoSlide(Index, ResetSlide)

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.

Index Long erforderlich. Die Nummer der Folie, zu der gewechselt werden soll.

ResetSlide Long optional. Wenn Sie während einer Bildschirmpräsentation von einer Folie zu einer anderen wechseln, während ResetSlide auf False eingestellt ist, wird die Animation bei der Rückkehr zur ersten Folie an der Stelle weitergeführt, an der sie beim Wechsel unterbrochen wurde. Wenn Sie von einer Folie zu einer anderen wechseln, während ResetSlide auf True eingestellt ist, wird die gesamte Animation der ersten Folie erneut abgespielt, wenn Sie zu dieser zurückkehren. Der Standardwert ist True.


Beispiel zur GotoSlide-Methode

In diesem Beispiel wird von der aktuellen Folie zur Folie 3 in Bildschirmpräsentationsfenster 1 gewechselt. Wenn Sie während der Bildschirmpräsentation zur aktuellen Folie zurückkehren, wird deren gesamte Animation von vorn abgespielt.

With SlideShowWindows(1).View
    .GotoSlide 3
End With

In diesem Beispiel wird von der aktuellen Folie zur Folie 3 in Bildschirmpräsentationsfenster 1 gewechselt. Wenn Sie während der Bildschirmpräsentation zur aktuellen Folie zurückkehren, wird deren Animation an der Stelle wieder aufgenommen, an der sie beim Wechsel unterbrochen wurde.

With SlideShowWindows(1).View
    .GotoSlide 3, False
End With


Group-Methode

Gruppiert die Formen im angegebenen Bereich. Gibt die gruppierten Formen als einzelnes Shape-Objekt zurück.

Syntax

Ausdruck.Group

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Eine Gruppe mit Formen wird als einzelne Form behandelt. Deshalb ändert sich durch Gruppieren bzw. Aufheben von Gruppierungen die Anzahl der Elemente der Shapes-Auflistung sowie die Indexnummern derjenigen Elemente, die nach den betroffenen Elementen in der Auflistung aufgeführt sind.


Beispiel zur Group-Methode

Dieses Beispiel fügt zu myDocument zwei Formen hinzu, gruppiert die beiden neuen Formen, legt die Füllung für die Gruppe fest, dreht die Gruppe, und sendet die Gruppe in den Hintergrund der Zeichnungsebene.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeCan, 50, 10, 100, 200).Name = "shpOne"
    .AddShape(msoShapeCube, 150, 250, 100, 200).Name = "shpTwo"
    With .Range(Array("shpOne", "shpTwo")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .Rotation = 45
        .ZOrder msoSendToBack
    End With
End With


Help-Methode

Zeigt ein Hilfethema an.

Syntax

Ausdruck.Help(HelpFile, ContextID)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

HelpFile String optional. Der Name der Hilfedatei, die angezeigt werden soll. Dies kann eine Datei mit der Endung .chm oder .hlp sein. Wenn dieses Argument nicht angegeben ist, wird die PowerPoint-Hilfe verwendet.

ContextID Long optional. Die Kontext-ID-Nummer für das Hilfethema. Wenn dieses Argument fehlt oder eine Kontext-ID-Nummer angegeben wird, der kein Hilfethema zugeordnet ist, wird das Dialogfeld Hilfethemen angezeigt.


Beispiel zur Help-Methode

In diesem Beispiel wird das Thema Nummer 65527 in der Hilfedatei MyHelpFile.chm angezeigt.

Application.Help "MyHelpFile.chm", 65527


ImportFromFile-Methode

Gibt den Klang an, der dann wiedergegeben wird, wenn Sie auf die angegebene Form klicken oder diese animieren bzw., wenn der angegebene Folienübergang eintritt.

Syntax

Ausdruck.ImportFromFile(FullName)

Ausdruck Erforderlich. Ein Ausdruck, der ein SoundEffect-Objekt zurückgibt.

FullName String erforderlich. Der Name der angegebenen Klangdatei.


Beispiel zur ImportFromFile-Methode

Dieses Beispiel gibt an, dass die Datei Dudududu.wav beim Übergang zu Folie 2 der aktiven Präsentation wiedergegeben wird, und zwar so lange, bis der nächste Klang beginnt.

With ActivePresentation.Slides(2).SlideShowTransition
    .SoundEffect.ImportFromFile "c:\sndsys\dudududu.wav"
    .LoopSoundUntilNext = True
End With


IncrementBrightness-Methode

Ändert die Helligkeit der Grafik um den angegebenen Wert. Mit der Brightness-Eigenschaft können Sie die absolute Helligkeit der Grafik festlegen.

Syntax

Ausdruck.IncrementBrightness(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel sich der Wert für die Brightness-Eigenschaft der Grafik ändert. Ein positiver Wert erhöht die Helligkeit; ein negativer Wert verringert die Helligkeit.

Anmerkungen

Der Grad der Helligkeit einer Grafik kann die Ober- und Untergrenze für die Brightness-Eigenschaft nicht überschreiten. Beträgt z. B. der Wert für die Initialeinstellung der Brightness-Eigenschaft 0,9, und Sie geben den Wert 0,3 für das Increment-Argument an, beträgt die Helligkeitsstufe nicht 1,2, sondern 1,0, weil dieser Wert die Obergrenze für die Brightness-Eigenschaft ist.


Beispiel zur IncrementBrightness-Methode

Dieses Beispiel erstellt ein Duplikat von Form 1 in myDocument. Anschließend wird das Duplikat verschoben und dunkler gemacht. Damit dieses Beispiel funktioniert, muss es sich bei Form 1 um eine Grafik oder ein OLE-Objekt handeln.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Duplicate
    .PictureFormat.IncrementBrightness -0.2
    .IncrementLeft 50
    .IncrementTop 50
End With


IncrementContrast-Methode

Ändert den Kontrast der Grafik um den angegebenen Wert. Mit der Contrast-Eigenschaft können Sie den absoluten Kontrast für die Grafik festlegen.

Syntax

Ausdruck.IncrementContrast(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel sich der Wert für die Contrast-Eigenschaft der Grafik ändert. Ein positiver Wert erhöht den Kontrast; ein negativer Wert verringert den Kontrast.

Anmerkungen

Der Kontrast einer Grafik kann die Ober- und Untergrenze für die Contrast-Eigenschaft nicht überschreiten. Beträgt z. B. der Wert für die Initialeinstellung der Contrast-Eigenschaft 0,9, und Sie geben den Wert 0,3 für das Increment-Argument an, beträgt die Kontraststufe nicht 1,2, sondern 1,0, weil dieser Wert die Obergrenze für die Contrast-Eigenschaft ist.


Beispiel zur IncrementContrast-Methode

Dieses Beispiel erhöht den Kontrast für alle Grafiken von myDocument, für die der maximale Kontrast noch nicht festgelegt wurde.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.Type = msoPicture Then
        s.PictureFormat.IncrementContrast 0.1
    End If
Next


IncrementLeft-Methode

Verschiebt die angegebene Form horizontal um den angegebenen Wert in Punkt.

Syntax

Ausdruck.IncrementLeft(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel Punkt die Form horizontal verschoben wird. Ein positiver Wert verschiebt die Form nach rechts, ein negativer Wert verschiebt die Form nach links.


Beispiel zur IncrementLeft-Methode

Dieses Beispiel dupliziert Form 1 von myDocument, legt die Füllung für das Duplikat fest, verschiebt es um 70 Punkt nach rechts und 50 Punkt nach oben und dreht es im Uhrzeigersinn um 30 Grad.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


IncrementOffsetX-Methode

Ändert die horizontale Schattenposition um den angegebenen Punktwert. Mit der OffsetX-Eigenschaft können Sie die absolute horizontale Schattenposition festlegen.

Syntax

Ausdruck.IncrementOffsetX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit die Schattenposition horizontal in Punkt versetzt wird. Ein positiver Wert verschiebt den Schatten nach rechts, ein negativer Wert verschiebt ihn nach links.


Beispiel zur IncrementOffsetX-Methode

Dieses Beispiel verschiebt den Schatten von Form 3 in myDocument um 3 Punkt nach links.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).Shadow.IncrementOffsetX -3


IncrementOffsetY-Methode

Ändert die vertikale Schattenposition um den angegebenen Punktwert. Mit der OffsetY-Eigenschaft können Sie die absolute vertikale Schattenposition festlegen.

Syntax

Ausdruck.IncrementOffsetY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit die Schattenposition vertikal in Punkt versetzt wird. Ein positiver Wert verschiebt den Schatten nach unten, ein negativer Wert verschiebt ihn nach oben.


Beispiel zur IncrementOffsetY-Methode

Dieses Beispiel verschiebt den Schatten von Form 3 in myDocument um 3 Punkt nach oben.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).Shadow.IncrementOffsetY -3


 IncrementRotation-Methode

IncrementRotation-Methode

Ändert die Drehung der angegebenen Form um die Z-Achse um den angegebenen Wert in Grad. Mit der Rotation-Eigenschaft legen Sie die absolute Drehung der Form fest.

Syntax

Ausdruck.IncrementRotation(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt den Wert in Grad an, um den die Form horizontal gedreht wird. Ein positiver Wert dreht die Form im Uhrzeigersinn; ein negativer Wert dreht die Form gegen den Uhrzeigersinn.

Anmerkungen

Um eine dreidimensionale Form um die X-Achse oder die Y-Achse drehen zu lassen, verwenden Sie die IncrementRotationX-Methode oder die IncrementRotationY-Methode.


Beispiel zur IncrementRotation-Methode

Dieses Beispiel dupliziert Form 1 von myDocument, legt die Füllung für das Duplikat fest, verschiebt es um 70 Punkt nach rechts und 50 Punkt nach oben und dreht es im Uhrzeigersinn um 30 Grad.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


 IncrementRotationX-Methode

IncrementRotationX-Methode

Ändert die Drehung der angegebenen Form um die X-Achse um die angegebene Gradzahl. Verwenden Sie die RotationX-Eigenschaft, um die absolute Drehung der Form um die X-Achse festzulegen.

Syntax

Ausdruck.IncrementRotationX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um welches Ausmaß (in Grad) die Drehung der Form um die X-Achse geändert werden soll. Es kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert kippt die Form nach oben, ein negativer Wert kippt sie nach unten.

Anmerkungen

Eine Änderung der Drehung um die X-Achse der angegebenen Form ist nur innerhalb der oberen und unteren Grenze für die RotationX-Eigenschaft möglich (90 Grad bis -90 Grad. Wenn z. B. die Ausgangsstellung 80 ist und Sie 40 für das Increment-Argument angeben, wird die Drehung 90 (obere Grenze der RotationX-Eigenschaft) statt 120 betragen.

Um die Drehung einer Form um die Y-Achse zu ändern, verwenden Sie die IncrementRotationY-Methode. Um die Drehung um die Z-Achse zu ändern, verwenden Sie die IncrementRotation-Methode.


Beispiel zur IncrementRotationX-Methode

In diesem Beispiel wird die Form 1 in myDocument um 10 Grad nach oben gekippt. Form 1 muss eine projizierte Form sein, damit Sie den Effekt dieses Codes sehen können.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).ThreeD.IncrementRotationX 10


 IncrementRotationY-Methode

IncrementRotationY-Methode

Ändert die Drehung der angegebenen Form um die Y-Achse um die angegebene Gradzahl. Verwenden Sie die RotationY-Eigenschaft, um die absolute Drehung der Form um die Y-Achse festzulegen.

Syntax

Ausdruck.IncrementRotationY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um welches Ausmaß (in Grad) die Drehung der Form um die Y-Achse geändert werden soll. Es kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert kippt die Form nach links, ein negativer Wert kippt sie nach rechts.

Anmerkungen

Um die Drehung einer Form um die X-Achse zu ändern, verwenden Sie die IncrementRotationX-Methode. Um die Drehung um die Z-Achse zu ändern, verwenden Sie die IncrementRotation-Methode.

Eine Änderung der Drehung um die Y-Achse der angegebenen Form ist nur innerhalb der oberen und unteren Grenze für die RotationY-Eigenschaft möglich (90 Grad bis -90 Grad. Wenn z. B. die Ausgangsstellung 80 ist und Sie 40 für das Increment-Argument angeben, wird die Drehung 90 (obere Grenze der RotationY-Eigenschaft) statt 120 betragen.


Beispiel zur IncrementRotationY-Methode

In diesem Beispiel wird Form 1 in myDocument um 10 Grad nach rechts gekippt. Form 1 muss eine projizierte Form sein, damit Sie den Effekt dieses Codes sehen können.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).ThreeD.IncrementRotationY -10


IncrementTop-Methode

Verschiebt die angegebene Form vertikal um den angegebenen Wert in Punkt.

Syntax

Ausdruck.IncrementTop(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit die Form vertikal in Punkt verschoben wird. Ein positiver Wert verschiebt die Form nach unten; ein negativer Wert verschiebt die Form nach oben.


Beispiel zur IncrementTop-Methode

Dieses Beispiel dupliziert Form 1 von myDocument, legt die Füllung für das Duplikat fest, verschiebt es um 70 Punkt nach rechts und 50 Punkt nach oben und dreht es im Uhrzeigersinn um 30 Grad.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


Insert-Methode

Fügt einen neuen Abschnitt nach dem angegebenen Knoten der Freihandfigur ein.

Syntax

Ausdruck.Insert(Index, SegmentType, EditingType, X1, Y1, X2, Y2, X3, Y3)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, nach dem der neue Knoten eingefügt werden soll.

SegmentType Long erforderlich. Der Typ des Abschnitts, der hinzugefügt werden soll. Dies kann eine der folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des Scheitelpunkts. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (jedoch nicht msoEditingSmooth oder msoEditingSymmetric).

X1 Single erforderlich. Lautet der EditingType des neuen Abschnitts msoEditingAuto, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Knotens msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Kontrollpunkt für den neuen Abschnitt an.

Y1 Single erforderlich. Lautet der EditingType des neuen Abschnitts msoEditingAuto, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Knotens msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Kontrollpunkt für den neuen Abschnitt an.

X2 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Kontrollpunkt für den neuen Abschnitt an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

Y2 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Kontrollpunkt für den neuen Abschnitt an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

X3 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den horizontalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.

Y3 Single optional. Lautet der EditingType des neuen Abschnitts msoEditingCorner, gibt dieses Argument den vertikalen Abstand (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Lautet der EditingType des neuen Abschnitts msoEditingAuto, geben Sie für dieses Argument keinen Wert an.


InsertAfter-Methode

Hängt an das Ende des angegebenen Textbereichs eine Zeichenfolge an. Gibt ein TextRange-Objekt zurück, das die angehängte Zeichenfolge darstellt. Wird diese Methode ohne Argument verwendet, gibt sie eine Zeichenfolge der Länge Null am Ende des angegebenen Bereichs zurück.

Syntax

Ausdruck.InsertAfter(NewText)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

NewText String optional. Der einzufügende Text. Der Standardwert ist eine leere Zeichenfolge.


Beispiel zur InsertAfter-Methode

In diesem Beispiel wird am Titelende der ersten Folie in der aktiven Präsentation die Zeichenfolge ": Test version" angehängt.

With Application.ActivePresentation.Slides(1).Shapes(1)
    .TextFrame.TextRange.InsertAfter ": Test version"
End With

In diesem Beispiel wird am Titelende der ersten Folie der Inhalt der Zwischenablage angehängt.

Application.ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange.InsertAfter.Paste


InsertBefore-Methode

Fügt am Anfang des angegebenen Textbereichs eine Zeichenfolge ein. Gibt ein TextRange-Objekt zurück, das die eingefügte Zeichenfolge darstellt. Wird diese Methode ohne Argument verwendet, gibt sie eine Zeichenfolge der Länge Null am Ende des angegebenen Bereichs zurück.

Syntax

Ausdruck.InsertBefore(NewText)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

NewText String optional. Der einzufügende Text. Der Standardwert ist eine leere Zeichenfolge.


Beispiel zur InsertBefore-Methode

In diesem Beispiel wird am Titelanfang der ersten Folie in der aktiven Präsentation die Zeichenfolge "Test version: " eingefügt.

With Application.ActivePresentation.Slides(1).Shapes(1)
    .TextFrame.TextRange.InsertBefore "Test version: "
End With

In diesem Beispiel wird am Titelanfang der ersten Folie der Inhalt der Zwischenablage eingefügt.

Application.ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange.InsertBefore.Paste


InsertDateTime-Methode

Fügt im angegebenen Textbereich Datum und Uhrzeit ein. Gibt ein TextRange-Objekt zurück, welches den eingefügten Text darstellt.

Syntax

Ausdruck.InsertDateTime(DateTimeFormat, InsertAsField)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

DateTimeFormat Erforderlich Long. Ein Format für Datum und Uhrzeit. Dabei kann es sich um eine der folgenden PpDateTimeFormat-Konstanten handeln:

ppDateTimeddddMMMMddyyyy

ppDateTimedMMMMyyyy

ppDateTimedMMMyy

ppDateTimeHmm

ppDateTimehmmAMPM

ppDateTimeHmmss

ppDateTimehmmssAMPM

 ppDateTimeMdyy

ppDateTimeMMddyyHmm

ppDateTimeMMddyyhmmAMPM

ppDateTimeMMMMdyyyy

ppDateTimeMMMMyy

ppDateTimeMMyy

InsertAsField Long optional. True, wenn das eingefügte Datum und die Uhrzeit bei jedem Öffnen der Präsentation aktualisiert werden soll. Der Standardwert ist False.


Beispiel zur InsertDateTime-Methode

In diesem Beispiel werden nach dem ersten Satz des ersten Absatzes in der zweiten Form der ersten Folie in der aktiven Präsentation Datum und Uhrzeit eingefügt.

Set sh = Application.ActivePresentation.Slides(1).Shapes(2)
Set sentOne = sh.TextFrame.TextRange.Paragraphs(1).Sentences(1)
sentOne.InsertAfter.InsertDateTime ppDateTimeMdyy


InsertFromFile-Methode

Fügt Folien aus einer Datei in eine Präsentation an der angegebenen Stelle ein. Gibt eine Ganzzahl zurück, die die Anzahl der eingefügten Folien darstellt.

Syntax

Ausdruck.InsertFromFile(FileName, Index, SlideStart, SlideEnd)

Ausdruck Erforderlich. Ein Ausdruck, der eine Slides-Auflistung zurückgibt.

FileName String erforderlich. Der Name der Datei, die die gewünschten Folien enthält.

Index Long erforderlich. Die Indexnummer des Slide-Objekts in der angegebenen Slides-Auflistung, in die die neuen Folien danach eingefügt werden sollen.

SlideStart Long optional. Die Indexnummer des ersten Slide-Objekts in der Slides-Auflistung in der Datei, die durch FileName dargestellt wird.

SlideEnd Long optional. Die Indexnummer des letzten Slide-Objekts in der Slides-Auflistung in der Datei, die durch FileName dargestellt wird.


Beispiel zur InsertFromFile-Methode

Dieses Beispiel fügt die Folien 3 bis 6 aus C:\Ppt\sales.ppt nach Folie 2 der aktiven Präsentation ein.

ActivePresentation.Slides.InsertFromFile _
    "c:\ppt\sales.ppt", 2, 3, 6


InsertSlideNumber-Methode

Fügt die Foliennummer der aktuellen Folie in den angegebenen Textbereich ein. Gibt ein TextRange-Objekt zurück, das die Foliennummer darstellt.

Syntax

Ausdruck.InsertSlideNumber

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Anmerkungen

Die eingefügte Foliennummer wird automatisch aktualisiert, wenn sich die Foliennummer der aktuellen Folie ändert.


Beispiel zur InsertSlideNumber-Methode

In diesem Beispiel wird nach dem ersten Satz des ersten Absatzes in der zweiten Form der ersten Folie in der aktiven Präsentation die Foliennummer der aktuellen Folie eingefügt.

Set sh = Application.ActivePresentation.Slides(1).Shapes(2)
Set sentOne = sh.TextFrame.TextRange.Paragraphs(1).Sentences(1)
sentOne.InsertAfter.InsertSlideNumber


InsertSymbol-Methode

Fügt das Symbol in den angegebenen Textbereich ein. Gibt ein TextRange-Objekt zurück, das das Symbol darstellt.

Syntax

Ausdruck.InsertSymbol(FontName, CharNumber, UniCode)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

FontName String erforderlich. Der Name der Schriftart.

CharNumber Long erforderlich. Die Unicode- oder ASCII-Zeichennummer.

UniCode Long optional. Wenn der Wert True ist, stellt das CharNumber-Argument ein Unicode-Zeichen dar. Wenn der Wert False ist, stellt das CharNumber-Argument ein ASCII-Zeichen dar. Der Standardwert ist False.


Beispiel zur InsertSymbol-Methode

In diesem Beispiel wird nach dem ersten Satz des ersten Absatzes in der zweiten Form der ersten Folie in der aktiven Präsentation das Symbol für "Symbol" eingefügt.

Set sh = Application.ActivePresentation.Slides(1).Shapes(2)
Set sentOne = sh.TextFrame.TextRange.Paragraphs(1).Sentences(1)
sentOne.InsertAfter.InsertSymbol "Symbol", 226


 Item-Methode

Item-Methode

Gibt ein einzelnes Element einer Auflistung zurück. Je nach Auflistung können Sie eine Indexnummer, einen Namen oder eine integrierte Konstante verwenden, um die Rückgabe eines bestimmten Elements anzugeben.

Item ist das Standardelement für eine Auflistung. So sind z. B. die nächsten beiden Codezeilen identisch:

ActivePresentation.Slides.Item(1)
ActivePresentation.Slides(1)

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Um Informationen über die Item-Methode einer gegebenen Auflistung zu erhalten, wählen Sie den Namen der Auflistung in der folgenden Liste aus.

ActionSettings

AddIns

Borders

CellRange

ColorSchemes

Columns

DocumentWindows

ExtraColors

Fonts

GroupShapes

Hyperlinks

NamedSlideShows

ObjectVerbs

Panes

 Presentations

PrintRanges

PublishObjects

Rows

RulerLevels

ShapeNodes

ShapeRange

Shapes

SlideRange

Slides

SlideShowWindows

TabStops

Tags

TextStyleLevels

Hinweise

Die Item-Methode gibt in der Regel das Objekt zurück, dessen Name im Singular derjenigen Auflistung steht, der die Methode zugewiesen wird. So gibt z. B. die Item-Methode der Shapes-Auflistung ein Shape-Objekt zurück. Die Ausnahmen zu dieser Regel werden in der folgenden Tabelle aufgelistet:

Objekt | Rückgabetyp der Item-Methode
Borders | BorderType
CellRange | Cell
ExtraColors | Long
GroupShapes | Shape
ObjectVerbs | String
Placeholders | Shape
ShapeRange | Shape
SlideRange | Slide
Tags | String


Item-Methode (ActionSettings-Auflistung)

Gibt ein einzelnes Element einer Auflistung mit Aktionseinstellungen zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine ActionSettings-Auflistung zurückgibt.

Index Long erforderlich. Gibt an, welche der beiden folgenden Einstellungen zurückgegeben werden soll: wenn der Mauszeiger über der angegebenen Form positioniert wird oder wenn der Benutzer auf die Form klickt. Dies kann eine der folgenden PpMouseActivation-Konstanten sein: ppMouseClick oder ppMouseOver.


Item-Methode (Borders (Auflistung))

Gibt ein LineFormat-Objekt für den angegebenen Rahmen zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine Borders-Auflistung zurückgibt.

Index Long erforderlich. Gibt an, welcher Rahmen einer Zelle oder eines Zellbereichs zurückgegeben werden soll. Dies kann eine der folgenden PpBorderType-Konstanten sein: ppBorderBottom, ppBorderLeft, ppBorderRight oder ppBorderTop.


Item-Methode (ExtraColors-Auflistung)

Gibt einen Long-Wert zurück, der eine der Extrafarben in der Präsentation darstellt.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine ExtraColors-Auflistung zurückgibt.

Index Long erforderlich. Die Indexnummer der Extrafarbe, die zurückgegeben werden soll.


Item-Methode (Mehrere Auflistungen)

Gibt ein einzelnes Element einer Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine AddIns-, Fonts-, GroupShapes-, Hyperlinks-, NamedSlideShows-, Presentations-, ShapeNodes-, ShapeRange-, Shapes-, SlideRange- oder Slides-Auflistung zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Elements in der Auflistung, das zurückgegeben werden soll.


Item-Methode (Mehrere Auflistungen)

Gibt ein einzelnes Element einer Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine CellRange-, ColorSchemes-, Columns-, DocumentWindows-, Panes-, Placeholders-, PrintRanges-, PublishObjects-, Rows-, RulerLevels-, SlideShowWindows- oder TabStops-Auflistung zurückgibt.

Index Long erforderlich. Die Indexnummer des Elements in derjenigen Auflistung, die zurückgegeben werden soll.


Item-Methode (ObjectVerbs-Auflistung)

Gibt einen String-Wert zurück, der eines der OLE-Verben für das angegebene OLE-Objekt darstellt.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine ObjectVerbs-Auflistung zurückgibt.

Index Long erforderlich. Die Indexnummer des Verbs, das zurückgegeben werden soll.


Item-Methode (Tags-Objekt)

Gibt eine einzelne Marke vom Tags-Objekt zurück.

Syntax

Ausdruck.Item(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Tags-Objekt zurückgibt.

Name String erforderlich. Der Name des Elements in der Auflistung, die zurückgegeben werden soll.


Item-Methode (TextStyleLevels-Auflistung)

Gibt ein einzelnes Element einer Auflistung mit Ebenen für Formatvorlagen zurück.

Syntax

Ausdruck.Item(Level)

Ausdruck Erforderlich. Ein Ausdruck, der eine TextStyleLevels-Auflistung zurückgibt.

Level Long erforderlich. Die Ebene, die von der Auflistung zurückgegeben werden soll. Dies kann eine ganze Zahl im Bereich von 1 bis 5 sein.


Item-Methode (TextStyles Collection)

Gibt ein einzelnes Element einer Auflistung mit Textformaten zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine TextStyles-Auflistung zurückgibt.

Index Long erforderlich. Das Textformat, das aus der Auflistung zurückgegeben werden soll. Dies kann eine der folgenden PpTextStyleType-Konstanten sein: ppBodyStyle, ppDefaultStyle oder ppTitleStyle.


Beispiel zur Item-Methode

Dieses Beispiel legt für den Vordergrund der Form "Rectangle 1" von Folie 1 in der aktiven Präsentation die Farbe Rot fest.

ActivePresentation.Slides.Item(1).Shapes.Item("rectangle 1").Fill _
    .ForeColor.RGB = RGB(128, 0, 0)

Dieses Beispiel legt für Form 3 in Folie 1 fest, dass ein Applaus wiedergegeben wird. Außerdem wird mit der AnimateAction-Eigenschaft angegeben, dass die Farbe der Form immer dann invertiert werden soll, wenn während einer Bildschirmpräsentation auf die Form geklickt wird.

With ActivePresentation.Slides.Item(1).Shapes _
        .Item(3).ActionSettings.Item(ppMouseClick)
    .SoundEffect.Name = "applause"
    .AnimateAction = True
End With

Dieses Beispiel legt den Erstzeileneinzug und den hängenden Einzug für Gliederungsebene 1 im Textkörper beim Folienmaster der aktiven Präsentation fest.

With ActivePresentation.SlideMaster.TextStyles.Item(ppBodyStyle)
    With .Ruler.Levels.Item(1) ' sets indents for level 1
        .FirstMargin = 9
        .LeftMargin = 54
    End With
End With

Dieses Beispiel verbirgt alle Folien in der aktiven Präsentation, die nicht den Wert "east" für die Marke "region" haben.

For Each s In ActivePresentation.Slides
    If s.Tags.Item("region") <> "east" Then
        s.SlideShowTransition.Hidden = True
    End If
Next


LargeScroll-Methode

Führt durch das angegebene Dokumentfenster einen seitenweisen Bildlauf durch.

Syntax

Ausdruck.LargeScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

Down Long optional. Gibt die Anzahl der Seiten an, die nach unten gerollt werden sollen.

Up Long optional. Gibt die Anzahl der Seiten an, die nach oben gerollt werden sollen.

ToRight Long optional. Gibt die Anzahl der Seiten an, die nach rechts gerollt werden sollen.

ToLeft Long optional. Gibt die Anzahl der Seiten an, die nach links gerollt werden sollen.

Anmerkungen

Wird kein Argument angegeben, führt diese Methode einen Bildlauf um eine Seite nach unten durch. Ist sowohl Down als auch Up angegeben, wird der Bildlauf berechnet. Hat z. B. Down den Wert 2 und Up den Wert 4, wird ein Bildlauf um 2 Seiten nach oben durchgeführt. Entsprechendes gilt, wenn sowohl Right als auch Left angegeben wird.

Jedes Argument kann eine negative Zahl enthalten.


Beispiel zur LargeScroll-Methode

In diesem Beispiel wird das aktive Fenster um drei Seiten nach unten gerollt.

Application.ActiveWindow.LargeScroll Down:=3


Last-Methode

Legt für die angegebene Bildschirmpräsentationsansicht fest, dass die letzte Folie der Präsentation angezeigt wird.

Syntax

Ausdruck.Last

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.

Anmerkungen

Wenn Sie die Last-Methode verwenden, um während einer Bildschirmpräsentation von einer Folie zu einer anderen zu wechseln, wird die Animation der ursprünglichen Folie, wenn Sie zu dieser zurückkehren, an der Stelle wieder aufgenommen, an der sie beim Wechsel zur anderen Folie unterbrochen wurde.


Beispiel zur Last-Methode

In diesem Beispiel wird für Bildschirmpräsentationsfenster 1 festgelegt, dass die letzte Folie der Präsentation angezeigt wird.

SlideShowWindows(1).View.Last


Lines-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textzeilen darstellt. Informationen über Zählvorgänge und Schleifenläufe durch die Zeilen eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Lines(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Die erste Zeile des zurückgegebenen Bereichs.

Length Long optional. Die Anzahl der zurückzugebenden Zeilen.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit der ersten Zeile und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau eine Zeile.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit der ersten Zeile des festgelegten Bereichs.

Ist Start größer als die Anzahl der Zeilen des festgelegten Textes, beginnt der zurückgegebene Bereich mit der letzten Zeile des festgelegten Bereichs.

Ist Length größer als die Anzahl der Zeilen von der festgelegten Anfangszeile bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Zeilen.


Beispiel zur Lines-Methode

In diesem Beispiel werden in der zweiten Form der ersten Folie in der aktiven Präsentation die ersten beiden Zeilen des zweiten Absatzes kursiv formatiert.

Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange.Paragraphs(2) _
    .Lines(1, 2).Font.Italic = True


LtrRun-Methode

Sprachspezifische Informationen.

Sets the direction of text in a text range to read from left to right.

Syntax

expression.LtrRun

expression Required. An expression that returns a TextRange object.

Remarks

This method makes it possible to use text from both left-to-right and right-to-left languages in the same presentation.


Beispiel zur LtrRun-Methode

The following example finds all of the shapes on slide one that contain text and changes the text to read from left to right.

ActiveWindow.ViewType = ppViewSlide
For Each sh In ActivePresentation.Slides(1).Shapes
    If sh.HasTextFrame Then
         sh.TextFrame.TextRange.LtrRun
    End If
Next


Merge-Methode

Führt eine Tabellenzelle mit einer anderen Zelle zusammen. Das Ergebnis ist eine einzelne Tabellenzelle.

Syntax

Ausdruck.Merge(MergeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-Objekt zurückgibt.

MergeTo Erforderlich. Das Cell-Objekt, mit dem die Zelle verbunden werden soll. Verwenden Sie die Syntax .Cell(row, column).


Beispiel zur Merge-Methode

In diesem Beispiel werden die ersten zwei Zellen der Zeile 1 in der angegebenen Tabelle zusammengeführt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Cell(1, 1).Merge MergeTo:=.Cell(1, 2)
End With


Name-Methode

Gibt den Namen der angegebenen Marke als String zurück.

Syntax

Ausdruck.Name(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine Tags-Auflistung zurückgibt.

Index Long erforderlich. Die Nummer der Marke.


Beispiel zur Name-Methode

In diesem Beispiel wird der Name und der Wert für jede Marke angezeigt, die zu Folie 1 der aktiven Präsentation gehört.

With Application.ActivePresentation.Slides(1).Tags
    For i = 1 To .Count
        MsgBox "Tag #" & i & ": Name = " & .Name(i)
        MsgBox "Tag #" & i & ": Value = " & .Value(i)
    Next
End With

In diesem Beispiel werden die Marken für jede Folie der aktiven Präsentation durchsucht. Wenn eine Marke mit dem Namen "PRIORITY" existiert, wird der Wert der Marke in einem Meldungsfeld angezeigt. Wenn keine Marke mit dem Namen "PRIORITY" existiert, wird die Marke mit dem Wert "Unknown" hinzugefügt.

For Each s In Application.ActivePresentation.Slides
    With s.Tags
        found = False
        For i = 1 To .Count
            If .Name(i) = "PRIORITY" Then
                found = True
                slNum = .Parent.SlideIndex
                MsgBox "Slide " & slNum & _
                    " priority: " & .Value(i)
            End If
        Next
        If Not found Then
            slNum = .Parent.SlideIndex
            .Add "Name", "New Figures"
            .Add "Priority", "Unknown"
            MsgBox "Slide " & slNum & _
                " priority tag added: Unknown"
        End If
    End With
Next


NewWindow-Methode

Presentation-Objekt: Öffnet ein neues Fenster, das die angegebene Präsentation enthält. Gibt ein DocumentWindow-Objekt zurück, das das neue Fenster darstellt.

DocumentWindow-Objekt: Öffnet ein neues Fenster, das das Dokument enthält, welches im angegebenen Fenster angezeigt wird. Gibt ein DocumentWindow-Objekt zurück, das das neue Fenster darstellt.

Syntax

Ausdruck.NewWindow

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow- oder Presentation-Objekt zurückgibt.


Beispiel zur NewWindow-Methode

In diesem Beispiel wird ein neues Fenster mit dem Inhalt des aktiven Fensters erstellt (dadurch wird das neue Fenster aktiviert) und anschließend wieder zum ersten Fenster gewechselt.

Set oldW = Application.ActiveWindow
Set newW = oldW.NewWindow
oldW.Activate


Next-Methode

SlideShowView-Objekt: Zeigt die Folie an, die unmittelbar auf die aktuell angezeigte Folie folgt. Wenn die letzte Folie angezeigt wird, schließt die Next-Methode die Bildschirmpräsentation im Rednermodus und kehrt zu der ersten Folie im Kioskmodus zurück. Wenn Sie im Menü Extras den Eintrag Optionen gewählt und dann auf der Registerkarte Ansicht die Option Mit schwarzer Folie beenden aktiviert haben, wird die schwarze Folie als letzte Folie behandelt. Die View-Eigenschaft des SlideShowWindow-Objekts gibt das SlideShowView-Objekt zurück.

Syntax

Ausdruck.Next

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.


Beispiel zur Next-Methode

In diesem Beispiel wird die Folie angezeigt, die direkt auf die aktuell angezeigte Folie im Fenster 1 der Bildschirmpräsentation folgt.

SlideShowWindows(1).View.Next


OneColorGradient-Methode

Legt einen einfarbigen Verlauf für die angegebene Füllung fest.

Syntax

Ausdruck.OneColorGradient(Style, Variant, Degree)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der den vier Varianten der Registerkarte Graduell im Dialogfeld Fülleffekte entspricht. Gilt für Style entweder msoGradientFromTitle oder msoGradientFromCenter, kann dieses Argument 1 oder 2 sein.

Degree Single erforderlich. Der Verlaufsgrad. Der Wert liegt im Bereich von 0.0 (dunkel) bis 1.0 (hell).


Beispiel zur OneColorGradient-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck mit einer einfarbigen Verlaufsfüllung hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 80).Fill
    .ForeColor.RGB = RGB(0, 128, 128)
    .OneColorGradient msoGradientHorizontal, 1, 1
End With


Open-Methode

Presentations -Auflistung: Öffnet die angegebene Präsentation. Gibt ein Presentation-Objekt zurück, das die geöffnete Präsentation darstellt. Wenn die entsprechenden Importfilter installiert sind, kann Microsoft PowerPoint-Dateien mit den folgenden MS-DOS-Dateinamenerweiterungen öffnen: .ch3, .cht, .doc, .htm, .html, .mcw, .pot, .ppa, .pps, .ppt, .pre, .rtf, .sh3, .shw, .txt, .wk1, .wk3, .wk4, .wpd, .wpf, .wps und .xls.

Syntax

Ausdruck.Open(FileName, ReadOnly, Untitled, WithWindow)

Ausdruck Erforderlich. Ein Ausdruck, der eine Presentations-Auflistung zurückgibt.

FileName String erforderlich. Der Name der Datei, die geöffnet werden soll.

ReadOnly Long optional. True, wenn die Datei im Schreibgeschützt-Modus geöffnet werden soll. Wird dieses Argument nicht angegeben, wird die Datei im Schreib-Lese-Modus geöffnet.

Untitled Long optional. True, wenn die Datei ohne einen Titel geöffnet werden soll. Dies entspricht dem Erstellen einer Kopie der Datei. Wird dieses Argument nicht angegeben, erhält der Titel der geöffneten Präsentation automatisch den Namen der Datei.

WithWindow Long optional. True, wenn die Datei in einem sichtbaren Fenster geöffnet werden soll. False, wenn die geöffnete Präsentation ausgeblendet werden soll. Der Standardwert ist True.


Beispiel zur Open-Methode

In diesem Beispiel wird eine Präsentation im Schreibgeschützt-Modus geöffnet.

Presentations.Open FileName:="c:\My documents\pres1.ppt", _
    ReadOnly:=True


Paragraphs-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textabsätzen darstellt. Informationen über Zählvorgänge und Schleifenläufe durch die Absätze eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Paragraphs(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Der erste Absatz des zurückgegebenen Bereichs.

Length Long optional. Die Anzahl der zurückzugebenden Absätze.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit dem ersten Absatz und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau einen Absatz.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit dem ersten Absatz des festgelegten Bereichs.

Ist Start größer als die Anzahl der Absätze des festgelegten Textes, beginnt der zurückgegebene Bereich mit dem letzten Absatz des festgelegten Bereichs.

Ist Length größer als die Anzahl der Absätze von dem festgelegten Anfangsabsatz bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Absätze.


Beispiel zur Paragraphs-Methode

In diesem Beispiel werden in der zweiten Form der ersten Folie in der aktiven Präsentation die ersten beiden Zeilen des zweiten Absatzes kursiv formatiert.

Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange.Paragraphs(2) _
    .Lines(1, 2).Font.Italic = True


Paste-Methode

Shapes-Objekt: Fügt die Formen, Folien oder Text aus der Zwischenablage in die angegebene Shapes-Auflistung an die oberste Position der Z-Reihenfolge ein. Jedes eingefügte Objekt wird ein Element der angegebenen Shapes-Auflistung. Wenn die Zwischenablage ganze Folien enthält, werden die Folien als Formen eingefügt, die die Bilder der Folien enthalten. Enthält die Zwischenablage einen Textbereich, wird der Text in die neu erstellte TextFrame-Form eingefügt. Gibt ein ShapeRange-Objekt zurück, das die eingefügten Objekte darstellt.

Slides-Objekt: Fügt die Folien aus der Zwischenablage in die Slides-Auflistung für die Präsentation ein. Geben Sie mit dem Index-Argument an, wo die Folien eingefügt werden sollen. Gibt ein SlideRange-Objekt zurück, das die eingefügten Objekte darstellt. Jede eingefügte Folie wird ein Element der angegebenen Slides-Auflistung.

TextRange-Objekt: Fügt den Text aus der Zwischenablage in den angegebenen Textbereich ein und gibt ein TextRange-Objekt zurück, das den eingefügten Text darstellt.

View-Objekt: Fügt den Inhalt der Zwischenablage in die aktive Ansicht ein. Wenn der Versuch unternommen wird, ein Objekt in eine Ansicht einzufügen, die das Objekt nicht akzeptiert, entsteht ein Fehler. Informationen zu Ansichten und die Objekte, die Sie darin einfügen können, finden Sie im Abschnitt "Anmerkungen".

Syntax 1

Ausdruck.Paste

Syntax 2

Ausdruck.Paste(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes, TextRange oder View-Objekt (Syntax 1) bzw. ein Slides-Objekt (Syntax 2) zurückgibt.

Index Long optional. Die Indexnummer der Folie, in die die Folien aus der Zwischenablage zuvor eingefügt werden sollen. Wird dieses Argument nicht angegeben, werden die Folien aus der Zwischenablage nach der letzten Folie der Präsentation eingefügt.

Anmerkungen

Mit der ViewType-Eigenschaft können Sie die Ansicht für ein Fenster festlegen, bevor der Inhalt der Zwischenablage darin eingefügt wird. Die folgende Tabelle zeigt, welche Objekte in die verschiedenen Ansichten eingefügt werden können.

Diese Ansicht | akzeptiert folgende Objekte aus der Zwischenablage
Folienansicht oder Notizblattansicht | Formen, Text oder gesamte Folien. Wenn Sie eine Folie aus der Zwischenablage einfügen, wird ein Bild der Folie in die Folie eingefügt. Ein Master oder Notizblatt wird als eingebettetes Objekt eingefügt. Ist eine Form markiert, wird der eingefügte Text dem Text der Form beigefügt. Wurde Text markiert, ersetzt der eingefügte Text die Markierung. Wurde etwas anderes markiert, wird der Text in den jeweiligen Textrahmen eingefügt. Eingefügte Formen werden der obersten Position der Z-Reihenfolge hinzugefügt. Diese Formen ersetzen markierte Formen nicht.
Gliederungsansicht | Text oder gesamte Folien. In die Gliederungsansicht können Sie keine Formen einfügen. Eine eingefügte Folie wird vor die Folie eingefügt, die die Einfügemarke enthält.
Foliensortieransicht | Gesamte Folien. In die Foliensortieransicht können Sie keine Formen einfügen. Eine eingefügte Folie wird entweder an die Einfügemarke oder nach der letzten Folie eingefügt, die in der Präsentation markiert ist.


Beispiel zur Paste-Methode

Dieses Beispiel kopiert die Markierung in Fenster 1 in die Zwischenablage und fügt diese anschließend in die Ansicht in Fenster 2 ein. Wenn die Inhalte der Zwischenablage nicht in die Ansicht in Fenster 2 eingefügt werden können (wenn z. B. eine Form in die Foliensortieransicht eingefügt werden soll), schlägt dieses Beispiel fehl.

Windows(1).Selection.Copy
Windows(2).View.Paste

Dieses Beispiel kopiert die Markierung in Fenster 1 in die Zwischenablage, prüft, ob Fenster 1 in Folienansicht ist und kopiert anschließend den Inhalt der Zwischenablage in die Ansicht in Fenster 2.

Windows(1).Selection.Copy
With Windows(2)
    .ViewType = ppViewSlide
    .View.Paste
End With

Dieses Beispiel kopiert Form 1 in Folie 1 in der aktiven Präsentation in die Zwischenablage und fügt sie anschließend in Folie 2 ein.

With ActivePresentation
    .Slides(1).Shapes(1).Copy
    .Slides(2).Shapes.Paste
End With

Dieses Beispiel schneidet den Text von Form 1 in Folie 1 der aktiven Präsentation aus, kopiert ihn in die Zwischenablage, und fügt anschließend den Text nach dem ersten Wort in Form 2 der gleichen Folie ein.

With ActivePresentation.Slides(1)
    .Shapes(1).TextFrame.TextRange.Cut
    .Shapes(2).TextFrame.TextRange.Words(1).InsertAfter.Paste
End With

Dieses Beispiel schneidet die Folien 3 und 5 der Präsentation "Old Sales" aus und fügt diese anschließend vor Folie 4 der aktiven Präsentation ein.

Presentations("Old Sales").Slides.Range(Array(3, 5)).Cut
ActivePresentation.Slides.Paste 4


Patterned-Methode

Legt fest, dass die angegebene Füllung ein Muster ist.

Syntax

Ausdruck.Patterned(Pattern)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Pattern Long erforderlich. Das Muster, das für die angegebene Füllung verwendet wird. Dies kann eine beliebige MsoPatternType-Konstante sein.

Anmerkungen

Mit der BackColor- und ForeColor-Eigenschaft können Sie die Farben festlegen, die im Muster verwendet werden.


Beispiel zur Patterned-Methode

Dieses Beispiel fügt zu myDocument ein Oval mit einer gemusterten Füllung hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeOval, 60, 60, 80, 40).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(0, 0, 255)
    .Patterned msoPatternDarkVertical
End With


PickUp-Methode

Kopiert das Format der angegebenen Form. Mit der Apply-Methode können Sie das kopierte Format auf eine andere Form übertragen.

Syntax

Ausdruck.PickUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.


Beispiel zur PickUp-Methode

Dieses Beispiel kopiert das Format von Form 1 in myDocument und überträgt anschließend das kopierte Format auf Form 2.

Set myDocument = ActivePresentation.Slides(1)
With myDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


Picture-Methode

Legt die für Aufzählungszeichen in einer Aufzählung zu verwendende Grafikdatei fest, wenn die Type-Eigenschaft des BulletFormat-Objekts auf ppBulletPicture gesetzt ist.

Syntax

Ausdruck.Picture (Picture)

Ausdruck Erforderlich. Ein Ausdruck, der ein BulletFormat-Objekt vom Typ ppBulletPicture zurückgibt.

Picture String erforderlich. Pfad und Dateiname einer gültigen Grafikdatei.

Hinweise

Gültig sind Grafikdateien mit den folgenden Dateinamenerweiterungen: .bmp, .cdr, .cgm, .drw, .dxf, .emf, .eps, .gif, .jpg, .jpeg, .pcd, .pct, .pcx, .pict, .png, .tga, .tiff, .wmf und .wpg.


Beispiel zur Picture-Methode

In diesem Beispiel werden die Aufzählungszeichen in dem Textfeld, das der Form 2 auf Folie 1 entspricht, durch eine Bitmapgrafik einer blauen Noppe ersetzt.

With ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat.Bullet
        .Type = ppBulletPicture
        .Picture ("C:\Windows\Blue Rivets.bmp")
    End With
End With


Play-Methode

Gibt den angegebenen Klangeffekt wieder.

Syntax

Ausdruck.Play

Ausdruck Erforderlich. Ein Ausdruck, der ein SoundEffect-Objekt zurückgibt.


Beispiel zur Play-Methode

Dieses Beispiel gibt den Klangeffekt wieder, der für den Übergang zu Folie 2 der aktiven Präsentation festgelegt wurde.

ActivePresentation.Slides(2).SlideShowTransition.SoundEffect.Play


PointsToScreenPixelsX-Methode

Wandelt ein horizontales Maß in Punkt nach Pixel um. Diese Methode wird verwendet, um eine horizontale Bildschirmposition für einen Textrahmen oder eine Form zurückzugeben. Das konvertierte Maß wird als Single zurückgegeben.

Syntax

Ausdruck.PointsToScreenPixelsX(Points)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

Points Single erforderlich. Das horizontale Maß (in Punkt), das in Pixel konvertiert werden soll.


Beispiel zur PointsToScreenPixelsX-Methode

In diesem Beispiel werden Breite und Höhe des ausgewählten Textrahmens von Punkt nach Pixel konvertiert und die Werte als myXparm und myYparm zurückgegeben.

With ActiveWindow
    myXparm = .PointsToScreenPixelsX _
        (.Selection.TextRange.BoundWidth)
    myYparm = .PointsToScreenPixelsY _
        (.Selection.TextRange.BoundHeight)
End With


PointsToScreenPixelsY-Methode

Wandelt eine vertikale Größe von Punkt in Pixel um. Diese Methode wird verwendet, um eine vertikale Bildschirmposition für einen Textrahmen oder eine Form zurückzugeben. Gibt die konvertierte Größe als Single zurück.

Syntax

Ausdruck.PointsToScreenPixelsY(Points)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

Points Single erforderlich. Die vertikale Größe (in Punkt), die in Pixel umgewandelt wird.


Beispiel zur PointsToScreenPixelsY-Methode

In diesem Beispiel werden die Breite und die Höhe der Begrenzungslinien des ausgewählten Textrahmens von Punkt nach Pixel umgewandelt und die Werte als myXparm und myYparm zurückgegeben.

With ActiveWindow
    myXparm = .PointsToScreenPixelsX _
        (.Selection.TextRange.BoundWidth)
    myYparm = .PointsToScreenPixelsY _
        (.Selection.TextRange.BoundHeight)
End With


PresetDrop-Methode

Gibt an, ob die Legendenlinie mit der oberen oder unteren Seite oder mit der Mitte des Legenden-Textfelds bzw. mit einem Punkt verbunden wird, bei dem es sich um einen angegebenen Abstand von der oberen oder unteren Seite des Textfelds handelt.

Syntax

Ausdruck.PresetDrop(DropType)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

DropType Long erforderlich. Die Anfangsposition der Legendenlinie relativ zum Text-Begrenzungsrechteck. Dies kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter oder msoCalloutDropTop. Wenn Sie msoCalloutDropCustom für dieses Argument angeben, schlägt der Code fehl.


Beispiel zur PresetDrop-Methode

Dieses Beispiel gibt an, dass die Legendenlinie mit der oberen Seite des Text-Begrenzungsrechtecks für Form 1 in myDocument verbunden wird. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).Callout.PresetDrop msoCalloutDropTop

Dieses Beispiel wechselt zwischen zwei vordefinierten Bezügen für Form 1 in myDocument. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropTop Then
        .PresetDrop msoCalloutDropBottom
    ElseIf .DropType = msoCalloutDropBottom Then
        .PresetDrop msoCalloutDropTop
    End If
End With


PresetGradient-Methode

Legt für die angegebene Füllung einen vordefinierten Farbverlauf fest.

Syntax

Ausdruck.PresetGradient(Style, Variant, PresetGradientType)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der den vier Varianten der Registerkarte Graduell im Dialogfeld Fülleffekte entspricht. Gilt für Style entweder msoGradientFromTitle oder msoGradientFromCenter, kann dieses Argument 1 oder 2 sein.

PresetGradientType Long erforderlich. Der Verlaufstyp. Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

 msoGradientLateSunset

msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat


Beispiel zur PresetGradient-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck mit einer vordefinierten Verlaufsfüllung hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape(msoShapeRectangle, 90, 90, 140, 80) _
    .Fill.PresetGradient msoGradientHorizontal, 1, msoGradientBrass


PresetTextured-Methode

Legt für die angegebene Füllung eine vordefinierte Struktur fest.

Syntax

Ausdruck.PresetTextured(PresetTexture)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PresetTexture Long erforderlich. Die vordefinierte Struktur. Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat


Beispiel zur PresetTextured-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck mit der strukturierten Füllung Grüner Marmor hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape(msoShapeCan, 90, 90, 40, 80) _
    .Fill.PresetTextured msoTextureGreenMarble


Previous-Methode

SlideShowView-Objekt: Zeigt die Folie an, die unmittelbar der aktuell angezeigten Folie vorausgeht. Wenn Sie sich auf der ersten Folie einer Bildschirmpräsentation im Kioskmodus befinden, wechseln Sie mit der Previous-Methode zur letzten Folie der Bildschirmpräsentation. Anderenfalls hat sie keine Auswirkungen, wenn die erste Folie einer Bildschirmpräsentation momentan angezeigt wird. Die View-Eigenschaft des SlideShowWindow-Objekts gibt das SlideShowView-Objekt wieder.

Syntax

Ausdruck.Previous

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt wiedergibt.


Beispiel zur Previous-Methode

In diesem Beispiel wird die Folie angezeigt, die direkt vor der aktuell angezeigten Folie im Fenster 1 der Bildschirmpräsentation liegt.

SlideShowWindows(1).View.Previous


PrintOut-Methode

Druckt die angegebene Präsentation.

Syntax

Ausdruck.PrintOut(From, To, PrintToFile, Copies, Collate)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

From Long optional. Die Seitenzahl der ersten Seite, die gedruckt werden soll. Wird dieses Argument nicht angegeben, beginnt der Druck am Anfang der Präsentation. Mit der Angabe der To- und From-Argumente werden die Inhalte des PrintRanges-Objekts und der Wert der RangeType-Eigenschaft für die Präsentation festgelegt.

To Long optional. Die Seitenzahl der letzten Seite, die gedruckt werden soll. Wird dieses Argument nicht angegeben, wird die Präsentation bis zum Ende gedruckt. Mit der Angabe der To- und From-Argumente werden die Inhalte des PrintRanges-Objekts und der Wert der RangeType-Eigenschaft für die Präsentation festgelegt.

PrintToFile String optional. Der Name der Datei, an die die Druckausgabe weitergeleitet werden soll. Wenn Sie dieses Argument angeben, wird die Datei nicht an den Drucker weitergeleitet, sondern in eine Datei umgeleitet. Wird dieses Argument nicht angegeben, wird die Datei an einen Drucker weitergeleitet.

Copies Long optional. Die Anzahl der zu druckenden Kopien. Wird dieses Argument nicht angegeben, wird nur eine Kopie gedruckt. Mit der Angabe dieses Arguments wird der Wert der NumberOfCopies-Eigenschaft festgelegt.

Collate Long optional. True, wenn eine vollständige Kopie der Präsentation gedruckt werden soll, bevor die erste Seite der nächsten Kopie gedruckt wird. Wird dieses Argument nicht angegeben, werden mehrere Kopien sortiert. Mit der Angabe dieses Arguments wird der Wert der Collate-Eigenschaft festgelegt.


Beispiel zur PrintOut-Methode

In diesem Beispiel werden zwei nicht sortierte Kopien von Folie 2 bis Folie 5 der aktiven Präsentation gedruckt. Es ist dabei nicht relevant, ob die Folien ein- oder ausgeblendet sind.

With Application.ActivePresentation
    .PrintOptions.PrintHiddenSlides = True
    .PrintOut From:=2, To:=5, Copies:=2, Collate:=False
End With

In diesem Beispiel wird eine Kopie aller Folien der aktiven Präsentation in die Datei Testprnt.prn umgeleitet.

Application.ActivePresentation.PrintOut _
    PrintToFile:="TestPrnt"


Publish-Methode

Erstellt eine Webpräsentation (HTML-Format) aus einer beliebigen geladenen Präsentation. Sie können die veröffentlichte Präsentation in einem Webbrowser öffnen.

Ausdruck.Publish

Ausdruck Erforderlich. Ein Ausdruck, der ein PublishObject-Objekt zurückgibt.

Hinweise

Sie können Inhalt und Attribute der veröffentlichten Präsentation festlegen, indem Sie verschiedene Eigenschaften des PublishObject-Objekts einstellen. Beispielsweise wird mit der SourceType-Eigenschaft der Anteil einer geladenen Präsentation definiert, der veröffentlicht werden soll. Die RangeStart-Eigenschaft und die RangeEnd-Eigenschaft legen den Folienbereich fest, der veröffentlicht werden soll, und die SpeakerNotes-Eigenschaft bestimmt, ob die Sprechernotizen veröffentlicht werden sollen oder nicht.


Beispiel zur Publish-Methode

In diesem Beispiel werden die Folien drei bis fünf der aktiven Präsentation im HTML-Format veröffentlicht. Die veröffentlichte Präsentation wird mit Mallard.htm benannt.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


Quit-Methode

Verlässt PowerPoint. Entspricht dem Befehl Beenden im Menü Datei.

Syntax

Ausdruck.Quit

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Verwenden Sie vorher die Save- oder SaveAs-Methode zum Speichern aller offenen Präsentationen, damit Sie nicht zum Speichern aufgefordert werden, nachdem Sie die Quit-Methode verwendet haben.


Beispiel zur Quit-Methode

In diesem Beispiel werden alle offenen Präsentationen gespeichert und PowerPoint verlassen.

With Application
    For Each w In .Presentations
        w.Save
    Next w
    .Quit
End With


Range-Methode

Shapes-Objekt: Gibt ein ShapeRange-Objekt zurück, das eine Untermenge der Formen in einer Shapes-Auflistung darstellt.

Slides-Objekt: Gibt ein SlideRange-Objekt zurück, das eine Untermenge der Formen in einer Slides-Auflistung darstellt.

Syntax

Ausdruck.Range(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes- oder ein Slides-Objekt zurückgibt.

Index Variant optional. Die einzelnen Formen oder Folien, die im Bereich enthalten sein sollen. Dies kann eine ganze Zahl sein, die die Indexnummer der Form oder der Folie angibt. Außerdem kann es sich um eine Zeichenfolge, die den Namen der Form oder Folie angibt bzw. um eine Matrix handeln, die entweder ganze Zahlen oder Zeichenfolgen enthält. Wird dieses Argument nicht angegeben, gibt die Range-Methode alle Objekte der angegebenen Auflistung zurück.

Anmerkungen

Sie können zwar mit der Range-Methode eine beliebige Anzahl von Formen oder Folien zurückgeben, es ist jedoch einfacher, wenn Sie die Item-Methode verwenden, wenn nur ein einzelnes Element der Auflistung zurückgegeben werden soll. So ist z. B. Shapes(1) einfacher als Shapes.Range(1), und Slides(2) einfacher als Slides.Range(2).

Um eine Matrix mit ganzen Zahlen oder Zeichenfolgen für Index anzugeben, können Sie die Array-Funktion verwenden. So gibt z. B. die folgende Anweisung zwei Formen zurück, die durch Namen angegeben sind:

Dim x() As Variant, myRange As Object
x = Array("Oval 4", "Rectangle 5")
Set myRange = ActivePresentation.Slides(1).Shapes.Range(x)


RangeFromPoint-Methode

Gibt das Shape-Objekt zurück, das sich an der Stelle befindet, die durch das Koordinatenpaar der Bildschirmposition bestimmt wird. Wenn sich an der durch das Koordinatenpaar bestimmten Stelle keine Form befindet, gibt diese Methode Nothing zurück.

Syntax

Ausdruck.RangeFromPoint(x, y)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

x Long erforderlich. Der horizontale Abstand (in Pixel) vom linken Rand des Bildschirms bis zum Punkt.

y Long erforderlich. Der vertikale Abstand (in Pixel) vom oberen Rand des Bildschirms bis zum Punkt.


Beispiel zur RangeFromPoint-Methode

In diesem Beispiel wird Folie 1 unter Verwendung der Koordinaten (288, 100) ein neuer fünfzackiger Stern hinzugefügt. Danach werden diese Koordinaten von Punkt in Pixel umgewandelt. Mit der RangeFromPoint-Methode wird ein Bezug zum neuen Objekt zurückgegeben und die Füllfarbe des Sterns geändert.

Dim myPointX As Integer, myPointY As Integer
Dim myShape As Object

ActivePresentation.Slides(1).Shapes _
    .AddShape(msoShape5pointStar, 288, 100, 100, 72).Select
myPointX = ActiveWindow.PointsToScreenPixelsX(288)
myPointY = ActiveWindow.PointsToScreenPixelsY(100)
Set myShape = ActiveWindow.RangeFromPoint(myPointX, myPointY)
myShape.Fill.ForeColor.RGB = RGB(80, 160, 130)


Regroup-Methode

Stellt die Gruppe wieder her, zu der der angegebene Formbereich vorher gehörte. Gibt die wiederhergestellte Gruppierung der Formen als einzelnes Shape-Objekt zurück.

Syntax

Ausdruck.Regroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Die Regroup-Methode stellt nur die Gruppe für die erste zuvor gruppierte Form wieder her, die in der angegebenen ShapeRange-Auflistung gefunden wurde. Enthält deshalb der angegebene Formbereich Formen, die vorher zu verschiedenen Gruppen gehört haben, wird nur eine der Gruppen wiederhergestellt.

Beachten Sie, dass eine Gruppe mit Formen wie eine einzelne Form behandelt wird. Deshalb ändert sich bei Gruppierungsaktionen an Formen die Anzahl der Elemente in der Shapes-Auflistung. Außerdem werden die Indexnummern der Elemente geändert, die nach den betroffenen Elementen in der Auflistung stehen.


Beispiel zur Regroup-Methode

Dieses Beispiel stellt die Gruppierung der Formen in der Markierung im aktiven Fenster wieder her. Wurde an den Formen zuvor keine Gruppierungsaktion vorgenommen, schlägt dieses Beispiel fehl.

ActiveWindow.Selection.ShapeRange.Regroup


 ReloadAs-Methode

ReloadAs-Methode

Lädt eine Präsentation erneut auf Grundlage einer festgelegten HTML-Dokumentcodierung.

Syntax

Ausdruck.ReloadAs (Encoding)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

Encoding Long erforderlich. Die Dokumentcodierung, die beim erneuten Laden der Webseite verwendet wird. Kann eine beliebige MsoEncoding-Konstante sein. Eine Liste gültiger MsoEncoding-Konstanten finden Sie im Objektbrowser des Visual Basic-Editors.


Beispiel zur ReloadAs-Methode

In diesem Beispiel wird die aktive Präsentation unter Verwendung der Codierung Westlich erneut geladen.

ActivePresentation.ReloadAs (msoEncodingWestern)


Remove-Methode

Entfernt ein Add-In aus der Auflistung mit Add-Ins.

Syntax

Ausdruck.Remove(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

Index Variant erforderlich. Der Name des Add-Ins, das aus der Auflistung entfernt werden soll.


RemovePeriods-Methode

Entfernt im angegebenen Textbereich am Ende jedes Absatzes den Punkt.

Syntax

Ausdruck.RemovePeriods

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.


Beispiel zur RemovePeriods-Methode

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation am Ende jedes Absatzes der Punkt entfernt.

Application.ActivePresentation.Slides(1) _
    .Shapes(2).TextFrame.TextRange _
    .RemovePeriods


Replace-Methode

TextRange-Objekt: Sucht in einem Textbereich nach angegebenem Text, ersetzt den gefundenen Text durch eine angegebene Zeichenfolge und gibt ein TextRange-Objekt zurück, das das erste Vorkommen des gesuchten Textes darstellt. Gibt Nothing zurück, wenn keine Übereinstimmung gefunden wird.

Fonts-Auflistung: Ersetzt eine Schriftart in der Fonts-Auflistung.

Syntax 1

Ausdruck.Replace(FindWhat, ReplaceWhat, After, MatchCase, WholeWords)

Syntax 2

Ausdruck.Replace(Original, Replacement)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt (Syntax 1) oder eine Fonts-Auflistung (Syntax 2) zurückgibt.

FindWhat String erforderlich. Der zu suchende Text.

ReplaceWhat String erforderlich. Der Text, durch den der gefundene Text ersetzt werden soll.

After Long optional. Die Position des Zeichens (in dem angegebenen Textbereich), nach dem Sie die Suche nach dem nächsten Auftreten von FindWhat beginnen wollen. Wenn Sie z. B. ab dem fünften Zeichen des Textbereichs suchen wollen, geben Sie 4 für After an. Wird dieses Argument nicht angewendet, wird die Suche bei dem ersten Zeichen des Textbereichs begonnen.

MatchCase Long optional. Falls der Wert True ist, wird bei der Suche zwischen groß- und kleingeschriebenen Zeichen unterschieden. Der Standardwert ist False.

WholeWords Long optional. Wenn der Wert True ist, wird nur nach ganzen Wörtern und nicht nach Wortteilen gesucht. Der Standardwert ist False.

Original String erforderlich. Der Name der zu ersetzenden Schriftart.

Replacement String erforderlich. Der Name der Schriftart, durch die ersetzt wird.


Beispiel zur Replace-Methode

In diesem Beispiel wird in der aktiven Präsentation jedes Vorkommen von "CompanyX" als ganzes Wort durch "CompanyY" ersetzt.

For Each sld In Application.ActivePresentation.Slides
    For Each shp In sld.Shapes
        shp.TextFrame.TextRange.Replace FindWhat:="CompanyX", _
            Replacewhat:="CompanyY", WholeWords:=True
    Next shp
Next sld

In diesem Beispiel wird in der aktiven Präsentation die Schriftart Times New Roman durch die Schriftart Courier ersetzt.

Application.ActivePresentation.Fonts _
    .Replace "Times New Roman", "Courier"


RerouteConnections-Methode

Erstellt Verbindungen neu, so dass diese den kürzesten Pfad zu den Formen nehmen, mit denen sie verbunden werden. Um dieses Ziel zu erreichen, kann die RerouteConnections-Methode die Enden einer Verbindung lösen und mit anderen Verbindungspunkten der verbundenen Formen zusammenfügen.

Diese Methode erstellt alle Verbindungen neu, die mit der angegebenen Form zusammengefügt sind. Handelt es sich bei der angegebenen Form um eine Verbindung, wird diese neu erstellt.

Syntax

Ausdruck.RerouteConnections

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Anmerkungen

Wird diese Methode einer Verbindung zugewiesen, wird nur diese Verbindung neu erstellt. Wird diese Methode einer verbundenen Form zugewiesen, werden alle Verbindungen mit dieser Form neu erstellt.


Beispiel zur RerouteConnections-Methode

Dieses Beispiel fügt zwei Rechtecke zu myDocument hinzu, fügt diese mit einer Verbindung zusammen, erstellt die Verbindung neu, so dass die Verbindung den kürzesten Pfad zwischen den beiden Rechtecken nimmt. Beachten Sie, dass die RerouteConnections-Methode die Größe und Position der Verbindung anpasst und bestimmt, welche Verbindungspunkte zusammengefügt werden. Dadurch werden die Werte irrelevant, die Sie zu Anfang für die ConnectionSite-Argumente festgelegt haben, die mit den BeginConnect- und EndConnect-Methoden verwendet werden.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set newConnector = s _
    .AddConnector(msoConnectorCurve, 0, 0, 100, 100)
With newConnector.ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
End With
newConnector.RerouteConnections


ResetRotation-Methode

Setzt die Drehung der Projektion um die X-Achse und die Y-Achse auf 0 (Null) zurück, so dass die Vorderseite der Projektion nach vorne zeigt. Diese Methode setzt die Drehung um die Z-Achse nicht zurück.

Syntax

Ausdruck.ResetRotation

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Anmerkungen

Um die Drehung der Projektion um die X-Achse und die Y-Achse auf einen anderen Wert als 0 (Null) einzustellen, verwenden Sie die RotationX- und die RotationY-Eigenschaft des ThreeDFormat-Objekts. Um die Drehung der Projektion um die Z-Achse einzustellen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts, das die projizierte Form darstellt.


Beispiel zur ResetRotation-Methode

In diesem Beispiel wird die Drehung um die X-Achse und die Y-Achse für die Projektion von Form 1 in myDocument auf 0 (Null) zurückgesetzt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).ThreeD.ResetRotation


ResetSlideTime-Methode

Setzt die verstrichene Zeit (dargestellt durch die SlideElapsedTime-Eigenschaft) für die derzeit angezeigte Folie auf 0 (Null) zurück.

Syntax

Ausdruck.ResetSlideTime

Ausdruck Erforderlich. Ein Ausdruck, der ein SlideShowView-Objekt zurückgibt.


Beispiel zur ResetSlideTime-Methode

In diesem Beispiel wird die verstrichene Zeit für die derzeit in Bildschirmpräsentationsfenster eins angezeigte Folie auf 0 (Null) zurückgesetzt.

SlideShowWindows(1).View.ResetSlideTime


RotatedBounds-Methode

Gibt die Koordinaten der Eckpunkte des Textbegrenzungsrechtecks für den angegebenen Textbereich zurück.

Syntax

Ausdruck.RotatedBounds(X1, Y1, X2, Y2, X3, Y3, X4, Y4)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

X1, Y1 Single erforderlich. Gibt die Position (in Punkt) des ersten Eckpunkts des Begrenzungsrechtecks für den Text innerhalb des angegebenen Textbereichs zurück.

X2, Y2 Single erforderlich. Gibt die Position (in Punkt) des zweiten Eckpunkts des Begrenzungsrechtecks für den Text innerhalb des angegebenen Textbereichs zurück.

X3, Y3 Single Erforderlich. Gibt die Position (in Punkt) des dritten Eckpunkts des Begrenzungsrechtecks für den Text innerhalb des angegebenen Textbereichs zurück.

X4, Y4 Single Erforderlich. Gibt die Position (in Punkt) des vierten Eckpunkts des Begrenzungsrechtecks für den Text innerhalb des angegebenen Textbereichs zurück.


Beispiel zur RotatedBounds-Methode

In diesem Beispiel werden die durch die Argumente der RotatedBounds-Methode zurückgegebenen Werte zum Zeichnen einer Freihandfigur verwendet. Diese hat die Abmessungen des Textbegrenzungsrechtecks für das dritte Wort im Textbereich der Form 1 auf Folie 1 der aktiven Präsentation.

Dim x1 As Single, y1 As Single
Dim x2 As Single, y2 As Single
Dim x3 As Single, y3 As Single
Dim x4 As Single, y4 As Single
Dim myDocument As Slide

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).TextFrame.TextRange.Words(3).RotatedBounds _
    x1, y1, x2, y2, x3, y3, x4, y4
With myDocument.Shapes.BuildFreeform(msoEditingCorner, x1, y1)
    .AddNodes msoSegmentLine, msoEditingAuto, x2, y2
    .AddNodes msoSegmentLine, msoEditingAuto, x3, y3
    .AddNodes msoSegmentLine, msoEditingAuto, x4, y4
    .AddNodes msoSegmentLine, msoEditingAuto, x1, y1
    .ConvertToShape.ZOrder msoSendToBack
End With


RtlRun-Methode

Sprachspezifische Informationen.

Sets the direction of text in a text range to read from right to left.

Syntax

expression.RtlRun

expression Required. An expression that returns a TextRange object.

Remarks

This method makes it possible to use text from both left-to-right and right-to-left languages in the same presentation.


Beispiel zur RtlRun-Methode

The following example finds all of the shapes on slide one that contain text and changes the text to read from right to left.

ActiveWindow.ViewType = ppViewSlide
For Each sh In ActivePresentation.Slides(1).Shapes
    If sh.HasTextFrame Then
         sh.TextFrame.TextRange.RtlRun
    End If
Next


Run-Methode

Application-Objekt: Startet eine Visual Basic-Prozedur.

SlideShowSettings-Objekt: Startet eine Bildschirmpräsentation der angegebenen Präsentation. Gibt ein SlideShowWindow-Objekt zurück.

Syntax 1

Ausdruck.Run(MacroName, safeArrayOfParams)

Syntax 2

Ausdruck.Run

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt (Syntax 1) oder ein SlideShowSettings-Objekt (Syntax 2) zurückgibt.

MacroName String erforderlich. Der Name der auszuführenden Prozedur. Die Zeichenfolge kann folgendes enthalten: eine geladene Präsentation oder den Namen einer Add-In-Datei vor einem Ausrufezeichen (!), einen gültigen Modulnamen vor einem Punkt (.) sowie den Namen einer Prozedur. Diese Zeichenfolge "MeinePräs.ppt!Modul1.Test" ist beispielsweise ein gültiger Wert für MacroName.

safeArrayOfParams Variant erforderlich. Das Argument, das an die Prozedur übergeben wird. Sie können für dieses Argument kein Objekt angeben. Außerdem können keine benannten Argumente mit dieser Methode verwendet werden. Argumente müssen nach Position übergeben werden.

Anmerkungen

Wenn Sie eine benutzerdefinierte Bildschirmpräsentation benutzen möchten, stellen Sie die RangeType-Eigenschaft auf ppShowNamedSlideShow und die SlideShowName-Eigenschaft auf den Namen der benutzerdefinierten Bildschirmpräsentation, die Sie benutzen möchten.


Runs-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textläufen darstellt. Ein Textlauf besteht aus einem Bereich von Zeichen mit derselben Zeichenformatierung. Informationen über Zählvorgänge und Schleifenläufe durch die Textläufe eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Runs(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Der erste Textlauf des angegebenen Bereichs.

Length Long optional. Die Anzahl der zurückzugebenden Textläufe.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit dem ersten Textlauf und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau einen Textlauf.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit dem ersten Textlauf des festgelegten Bereichs.

Ist Start größer als die Anzahl der Textläufe des festgelegten Textes, beginnt der zurückgegebene Bereich mit dem letzten Textlauf des festgelegten Bereichs.

Ist Length größer als die Anzahl der Textläufe von dem festgelegten Anfangstextlauf bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Textläufe.

Ein Textlauf besteht aus allen Zeichen von dem ersten Zeichen nach einem Zeichenformatwechsel bis zu dem vorletzten Zeichen mit derselben Zeichenformatierung. Sehen Sie sich beispielsweise folgenden Satz an:

Das kursive Wort ist nicht fett.

Darin besteht der erste Textlauf nur dann aus dem Wort "Das", wenn das Leerzeichen nach "Das" nicht kursiv formatiert ist (ist das Leerzeichen kursiv, besteht der erste Textlauf lediglich aus den beiden ersten Zeichen "Da". Entsprechend enthält der zweite Textlauf nur dann das Wort "kursiv", wenn das nachfolgende Leerzeichen kursiv formatiert ist.


Beispiel zur Runs-Methode

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation der zweite Textlauf fett kursiv formatiert, wenn er bereits kursiv ist.

With Application.ActivePresentation.Slides(1).Shapes(2) _
        .TextFrame.TextRange
    With .Runs(2).Font
        If .Italic Then
            .Bold = True
        End If
    End With
End With


Save-Methode

Speichert die angegebene Präsentation.

Syntax

Ausdruck.Save

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

Hinweise

Verwenden Sie die SaveAs-Methode, um eine Präsentation zum ersten Mal zu speichern. Um festzustellen, ob eine Präsentation bereits gespeichert wurde, prüfen Sie die FullName- oder Path-Eigenschaft auf einem nicht leeren Wert. Wenn ein Dokument mit dem gleichen Namen wie die angegebene Präsentation bereits auf dem Datenträger existiert, wird dieses Dokument überschrieben. In diesem Fall wird keine Warnmeldung ausgegeben.

Um eine Präsentation als gespeichert zu markieren, ohne diese auf dem Datenträger zu speichern, legen Sie für die Saved-Eigenschaft den Wert True fest.


SaveAs-Methode

Speichert eine Präsentation zum ersten Mal oder speichert eine bereits gespeicherte Präsentation unter einem anderen Namen.

Syntax

Ausdruck.SaveAs(Filename, FileFormat, EmbedFonts)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

Filename String erforderlich. Gibt den Namen an, unter dem die Datei gespeichert werden soll. Wenn Sie keinen vollständigen Pfad eingeben, wird die Datei im aktuellen Ordner gespeichert.

FileFormat Long optional. Gibt das gespeicherte Dateiformat an. Wird dieses Argument nicht angegeben, wird die Präsentation in dem Dateiformat der aktuellen Version von PowerPoint gespeichert (ppSaveAsPresentation). Dabei kann es sich um eine der folgenden PpSaveAsFileType-Konstanten handeln:

ppSaveAsAddIn

ppSaveAsBMP

ppSaveAsDefault

ppSaveAsGIF

ppSaveAsHTML

ppSaveAsHTMLDual

ppSaveAsHTMLv3

ppSaveAsJPG

ppSaveAsMetaFile

ppSaveAsPNG

 ppSaveAsPowerPoint3

ppSaveAsPowerPoint4

ppSaveAsPowerPoint4FarEast

ppSaveAsPowerPoint7

ppSaveAsPresentation

ppSaveAsRTF

ppSaveAsShow

ppSaveAsTemplate

EmbedFonts Long optional. True, damit TrueType-Schriftarten in die gespeicherte Präsentation eingebettet werden. Der Standardwert ist False.


Beispiel zur SaveAs-Methode

In diesem Beispiel wird eine Kopie der aktiven Präsentation unter dem Namen "New Format Copy.ppt" gespeichert. Standardmäßig wird diese Kopie in das Dateiformat der aktuellen Version von PowerPoint gespeichert. Die Präsentation wird anschließend im Dateiformat von PowerPoint 4.0 unter dem Namen "Old Format Copy" gespeichert.

With Application.ActivePresentation
    .SaveCopyAs "New Format Copy"
    .SaveAs "Old Format Copy", ppSaveAsPowerPoint4
End With


SaveCopyAs-Methode

Speichert eine Kopie der angegebenen Präsentation, ohne die Originaldatei zu ändern.

Syntax

Ausdruck.SaveCopyAs(FileName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.

Filename String erforderlich. Gibt den Namen an, unter dem die Datei gespeichert wird. Wenn Sie keinen vollständigen Pfad eingeben, wird die Datei im aktuellen Ordner gespeichert.


Beispiel zur SaveCopyAs-Methode

In diesem Beispiel wird eine Kopie der aktiven Präsentation unter dem Namen "New Format Copy.ppt" gespeichert. Standardmäßig wird diese Kopie in das Dateiformat der aktuellen Version von PowerPoint gespeichert. Die Präsentation wird anschließend im Dateiformat von PowerPoint 4.0 unter dem Namen "Old Format Copy" gespeichert.

With Application.ActivePresentation
    .SaveCopyAs "New Format Copy"
    .SaveAs "Old Format Copy", ppSaveAsPowerPoint4
End With


ScaleHeight-Methode

Skaliert die Höhe der Form um den angegebenen Faktor. Sie können nur bei Bildern und OLE-Objekten angeben, ob die Form relativ zur Originalgröße oder relativ zur aktuellen Größe skaliert werden soll. Andere Formen werden immer relativ zur aktuellen Höhe skaliert.

Syntax

Ausdruck.ScaleHeight(Factor, RelativeToOriginalSize, fScale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Gibt das Verhältnis der Höhe der Form nach dem Ändern der Größe zur aktuellen oder ursprünglichen Höhe an. Möchten Sie z. B. ein Rechteck um 50 Prozent vergrößern, geben Sie für dieses Argument den Wert 1.5 an.

RelativeToOriginalSize Long erforderlich. True, wenn die Form relativ zur Originalgröße skaliert wird. False, wenn die Form relativ zur aktuellen Größe skaliert wird. Sie können für dieses Argument nur dann True festlegen, wenn es sich bei der angegebenen Form um eine Grafik oder ein OLE-Objekt handelt.

fScale Long optional. Der Teil der Form, der bei der Skalierung der Form seine Position beibehält. Kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight, msoScaleFromMiddle oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleHeight-Methode

Dieses Beispiel legt für alle Grafiken und OLE-Objekte von myDocument einen Maßstab von 175 Prozent ihrer Originalhöhe und -breite fest. Für alle anderen Formen wird ein Maßstab von 175 Prozent der aktuellen Höhe und Breite festgelegt.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    Select Case s.Type
    Case msoEmbeddedOLEObject, msoLinkedOLEObject, _
            msoOLEControlObject, msoLinkedPicture, msoPicture
        s.ScaleHeight 1.75, True
        s.ScaleWidth 1.75, True
    Case Else
        s.ScaleHeight 1.75, False
        s.ScaleWidth 1.75, False
    End Select
Next


ScaleWidth-Methode

Skaliert die Breite der Form um den angegebenen Faktor. Sie können nur bei Bildern und OLE-Objekten angeben, ob die Form relativ zur Originalgröße oder relativ zur aktuellen Größe skaliert werden soll. Andere Formen werden immer relativ zur aktuellen Höhe skaliert.

Syntax

Ausdruck.ScaleWidth(Factor, RelativeToOriginalSize, fScale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Gibt das Verhältnis der Breite der Form nach dem Ändern der Größe zur aktuellen oder ursprünglichen Breite an. Möchten Sie z. B. ein Rechteck um 50 Prozent vergrößern, geben Sie für dieses Argument den Wert 1.5 an.

RelativeToOriginalSize Long erforderlich. True, wenn die Form relativ zur Originalgröße skaliert wird. False, wenn die Form relativ zur aktuellen Größe skaliert wird. Sie können für dieses Argument nur dann True festlegen, wenn es sich bei der angegebenen Form um eine Grafik oder ein OLE-Objekt handelt.

fScale Long optional. Der Teil der Form, der bei der Skalierung der Form seine Position beibehält. Kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight, msoScaleFromMiddle oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleWidth-Methode

Dieses Beispiel legt für alle Grafiken und OLE-Objekte von myDocument einen Maßstab von 175 Prozent ihrer Originalhöhe und -breite fest. Für alle anderen Formen wird ein Maßstab von 175 Prozent der aktuellen Höhe und Breite festgelegt.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    Select Case s.Type
    Case msoEmbeddedOLEObject, msoLinkedOLEObject, _
            msoOLEControlObject, msoLinkedPicture, msoPicture
        s.ScaleHeight 1.75, True
        s.ScaleWidth 1.75, True
    Case Else
        s.ScaleHeight 1.75, False
        s.ScaleWidth 1.75, False
    End Select
Next


ScrollIntoView-Methode

Führt einen Bildlauf durch das Dokumentfenster aus, so dass Elemente innerhalb eines rechteckigen Bereichs im Dokumentfenster oder im Fensterausschnitt angezeigt werden.

Syntax

Ausdruck.ScrollIntoView(Left, Top, Width, Height, Start)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

Left Long erforderlich. Der horizontale Abstand (in Punkt) vom linken Rand des Dokumentfensters bis zum Rechteck.

Top Long erforderlich. Der vertikale Abstand (in Punkt) vom oberen Rand des Dokumentfensters bis zum Rechteck.

Width Long erforderlich. Die Breite des Rechtecks (in Punkt).

Height Long erforderlich. Die Höhe des Rechtecks (in Punkt).

Start Boolean optional. True, wenn die linke obere Ecke des Rechtecks an der linken oberen Ecke des Dokumentfensters angezeigt werden soll. False, wenn die rechte untere Ecke des Rechtecks an der rechten unteren Ecke des Dokumentfensters angezeigt werden soll. Der Standardwert ist True.

Hinweise

Wenn die Maße des Rechtecks die Maße des Dokumentfensters übersteigen, wird mit dem Start-Argument eingestellt, welcher Teil des Rechtecks angezeigt wird oder zuerst den Fokus erhält. Diese Methode steht für die Gliederungsansicht und die Foliensortieransicht nicht zur Verfügung.


Beispiel zur ScrollIntoView-Methode

In diesem Beispiel wird ein Bereich von 100 x 200 Punkt dargestellt, ausgehend von 50 Punkt vom linken Rand der Folie und 20 Punkt vom oberen Rand der Folie. Die linke obere Ecke des Rechtecks wird an der linken oberen Ecke des aktiven Dokumentfensters positioniert.

ActiveWindow.ScrollIntoView Left:=50, Top:=20, _
    Width:=100, Height:=200


Select-Methode

Markiert das angegebene Objekt.

Syntax 1

Ausdruck.Select

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-, Column-, Row-, Slide-, SlideRange- oder TextRange-Objekt zurückgibt.

Syntax 2

Ausdruck.Select(Replace)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Replace Long optional. True, wenn die Markierung die vorherige Markierung ersetzt. False, wenn die Markierung der vorherigen Markierung hinzugefügt wird. Der Standardwert ist True.

Anmerkungen

Wenn Sie etwas markieren möchten, das in der jeweiligen Ansicht nicht zulässig ist, schlägt Ihr Code fehl. Sie können z. B. eine Folie in der Foliensortieransicht, jedoch nicht in der Folienansicht markieren.


SelectAll-Methode

Markiert alle Formen in der angegebenen Shapes-Auflistung.

Syntax

Ausdruck.SelectAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.


Beispiel zur SelectAll-Methode

Dieses Beispiel markiert alle Formen von myDocument.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.SelectAll


Sentences-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textsätzen darstellt. Informationen über Zählvorgänge und Schleifenläufe durch die Sätze eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Sentences(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Der erste Satz des angegebenen Bereichs.

Length Long optional. Die Anzahl der zurückzugebenden Sätze.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit dem ersten Satz und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau einen Satz.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit dem ersten Satz des festgelegten Bereichs.

Ist Start größer als die Anzahl der Sätze des festgelegten Textes, beginnt der zurückgegebene Bereich mit dem letzten Satz des festgelegten Bereichs.

Ist Length größer als die Anzahl der Sätze von dem festgelegten Anfangssatz bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Sätze.


Beispiel zur Sentences-Methode

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation der zweite Satz des zweiten Absatzes fett formatiert.

Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange.Paragraphs(2).Sentences(2).Font _
    .Bold = True


SetEditingType-Methode

Legt den Bearbeitungstyp des Knoten fest, der vom Index angegeben ist. Handelt es sich bei dem Knoten um einen Kontrollpunkt für einen gekrümmten Abschnitt, legt diese Methode den Bearbeitungstyp des benachbarten Knoten fest, der die beiden Abschnitte verbindet. Beachten Sie, dass diese Methode bei bestimmten Bearbeitungstypen die Position der benachbarten Knoten beeinflussen kann.

Syntax

Ausdruck.SetEditingType(Index, EditingType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Bearbeitungstyp festgelegt werden soll.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des Scheitelpunkts. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric.


Beispiel zur SetEditingType-Methode

Dieses Beispiel ändert alle Eckknoten in Form 3 von myDocument zu glatten Knoten. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


SetExtrusionDirection-Methode

Legt die Richtung fest, in die der Bewegungsweg der Projektion von der projizierten Form abgelenkt wird.

Syntax

Ausdruck.SetExtrusionDirection(PresetExtrusionDirection)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetExtrusionDirection Long erforderlich. Gibt die Projektions-Richtung an. Dies kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft oder msoExtrusionTopRight.

Anmerkungen

Diese Methode stellt die PresetExtrusionDirection-Eigenschaft auf die durch das PresetExtrusionDirection-Argument angegebene Richtung ein.


Beispiel zur SetExtrusionDirection-Methode

In diesem Beispiel wird angegeben, dass sich die Projektion für Form eins in myDocument zum oberen Rand der Form hin ausdehnt und die Beleuchtung für die Projektion von links kommt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


SetPosition-Methode

Legt die Position des Knotens fest, der vom Index angegeben ist. Beachten Sie, dass diese Methode bei bestimmten Bearbeitungstypen die Position der benachbarten Knoten beeinflussen kann.

Syntax

Ausdruck.SetPosition(Index, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Position festgelegt werden soll.

X1, Y1 Single erforderlich. Die Position (in Punkt) des neuen Knotens gemessen von der oberen linken Ecke des Dokuments.


Beispiel zur SetPosition-Methode

Dieses Beispiel verschiebt Knoten 2 in Form 3 von myDocument um 200 Punkt nach rechts und 300 Punkt nach unten. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(1, 1)
    currYvalue = pointsArray(1, 2)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


SetSegmentType-Methode

Legt den Abschnittstyp des Abschnitts fest, der auf den Knoten folgt, der vom Index angegeben ist. Handelt es sich bei dem Knoten um einen Kontrollpunkt für einen gekrümmten Abschnitt, legt diese Methode den Abschnittstyp für die Kurve fest. Beachten Sie, dass die Gesamtzahl der Knoten durch Einfügen oder Löschen benachbarter Knoten beeinflusst werden kann.

Syntax

Ausdruck.SetSegmentType(Index, SegmentType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Abschnittstyp festgelegt werden soll.

SegmentType Long erforderlich. Gibt an, ob der Abschnitt gerade oder gekrümmt ist. Dies kann eine der folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.


Beispiel zur SetSegmentType-Methode

Dieses Beispiel ändert alle geraden Abschnitte in Form 3 von myDocument zu gekrümmten Abschnitten. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


 SetShapesDefaultProperties-Methode

SetShapesDefaultProperties-Methode

Weist die Formatierung für die angegebene Form der Standardform zu. Formen, die erstellt werden, nachdem diese Methode verwendet wurde, wird diese Formatierung standardmäßig zugewiesen.

Syntax

Ausdruck.SetShapesDefaultProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.


Beispiel zur SetShapesDefaultProperties-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck hinzu, formatiert die Füllung des Rechtecks, weist die Formatierung des Rechtecks der Standardform zu und fügt dem Dokument anschließend ein weiteres kleineres Rechteck zu. Das zweite Rechteck hat die gleiche Füllung wie das erste Rechteck.

Set mydocument = ActivePresentation.Slides(1)
With mydocument.Shapes
    With .AddShape(msoShapeRectangle, 5, 5, 80, 60)
        With .Fill
            .ForeColor.RGB = RGB(0, 0, 255)
            .BackColor.RGB = RGB(0, 204, 255)
            .Patterned msoPatternHorizontalBrick
        End With
    ' Sets formatting for default shapes
        .SetShapesDefaultProperties
    End With
' New shape has default formatting
    .AddShape msoShapeRectangle, 90, 90, 40, 30
End With


SetThreeDFormat-Methode

Stellt das voreingestellte Projektionsformat ein. Jedes voreingestellte Projektionsformat enthält einen Satz von voreingestellten Werten für die verschiedenen Eigenschaften der Projektion.

Syntax

Ausdruck.SetThreeDFormat(PresetThreeDFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetThreeDFormat Long erforderlich. Gibt ein voreingestelltes Projektionsformat an, das einer der Optionen entspricht (nummeriert von links nach rechts und von oben nach unten), die angezeigt werden, wenn Sie in der Zeichnen-Symbolleiste auf die Schaltfläche 3D klicken. Dies kann eine der folgenden MsoPresetThreeDFormat-Konstanten sein: msoThreeD1, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19, msoThreeD2, msoThreeD20, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8 oder msoThreeD9. Beachten Sie, dass die Spezifizierung von msoPresetThreeDFormatMixed für dieses Argument einen Fehler verursacht.

Anmerkungen

Diese Methode stellt die PresetThreeDFormat-Eigenschaft auf das durch das PresetThreeDFormat-Argument angegebene Format ein.


Beispiel zur SetThreeDFormat-Methode

In diesem Beispiel wird dem Element myDocument ein Oval hinzugefügt und dessen Projektionsformat auf den 3D-Stil "12" eingestellt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeOval, 30, 30, 50, 25).ThreeD
    .Visible = True
    .SetThreeDFormat msoThreeD12
End With


SmallScroll-Methode

Führt durch das angegebene Dokumentfenster einen zeilen- und spaltenweisen Bildlauf durch.

Syntax

Ausdruck.SmallScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein DocumentWindow-Objekt zurückgibt.

Down Long optional. Gibt die Anzahl der Zeilen an, die nach unten gerollt werden sollen.

Up Long optional. Gibt die Anzahl der Zeilen an, die nach oben gerollt werden sollen.

ToRight Long optional. Gibt die Anzahl der Spalten an, die nach rechts gerollt werden sollen.

ToLeft Long optional. Gibt die Anzahl der Spalten an, die nach links gerollt werden sollen.

Anmerkungen

Wird kein Argument angegeben, führt diese Methode einen Bildlauf um eine Zeile nach unten durch. Ist sowohl Down als auch Up angegeben, wird der Bildlauf berechnet. Hat z. B. Down den Wert 2 und Up den Wert 4, wird ein Bildlauf um 2 Zeilen nach oben durchgeführt. Entsprechendes gilt, wenn sowohl Right als auch Left angegeben wird.

Jedes Argument kann eine negative Zahl enthalten.


Beispiel zur SmallScroll-Methode

In diesem Beispiel wird im aktiven Fenster ein Bildlauf um drei Zeilen nach unten durchgeführt.

Application.ActiveWindow.SmallScroll Down:=3


Solid-Methode

Legt für die angegebene Füllung eine einfarbige Füllung fest. Mit dieser Methode können Sie Verlaufsfüllungen, strukturierte, gemusterte oder Hintergrundfüllungen in einfarbige Füllungen umwandeln.

Syntax

Ausdruck.Solid

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.


Beispiel zur Solid-Methode

Dieses Beispiel wandelt alle Füllungen von myDocument in einfarbige rote Füllungen um.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    With s.Fill
        .Solid
        .ForeColor.RGB = RGB(255, 0, 0)
    End With
Next


Split-Methode

Teilt eine einzelne Tabellenzelle in mehrere Zellen auf.

Syntax

Ausdruck.Split NumRows, NumColumns

Ausdruck Erforderlich. Ein Ausdruck der ein Cell-Objekt zurückgibt.

NumRows Long erforderlich. Anzahl der Zeilen, in die die Zelle aufgeteilt werden soll.

NumColumns Long erforderlich. Anzahl der Spalten, in die die Zelle aufgeteilt werden soll.


Beispiel zur Split-Methode

In diesem Beispiel wird die erste Zelle in der Bezugstabelle in zwei Zellen aufgeteilt, von denen eine direkt über der anderen liegt.

ActivePresentation.Slides(2).Shapes(5).Table.Cell(1, 1).Split 2, 1


ToggleVerticalText-Methode

Wechselt den Textfluss in der angegebenen WordArt von horizontal zu vertikal oder umgekehrt.

Syntax

Ausdruck.ToggleVerticalText

Ausdruck Erforderlich. Ein Ausdruck, der ein TextEffectFormat-Objekt zurückgibt.

Anmerkungen

Mit der ToggleVerticalText-Methode tauschen Sie die Werte der Width-und Height-Eigenschaft des Shape-Objekts aus, das die WordArt darstellt. Die Werte der Left- und Top-Eigenschaften bleiben unverändert.

Die Flip-Methode und Rotation-Eigenschaft des Shape-Objekts sowie die RotatedChars-Eigenschaft und ToggleVerticalText-Methode des TextEffectFormat-Objekts wirken sich auf die Textflussrichtung und Zeichenausrichtung in einem Shape-Objekt aus, das WordArt darstellt. Um bestimmte Ergebnisse zu erzielen, können Sie die Effekte dieser Eigenschaften und Methoden kombinieren.


Beispiel zur ToggleVerticalText-Methode

Dieses Beispiel fügt WordArt zu myDocument hinzu, das den Text "Test" enthält. Der horizontale Textfluss (der Standard msoTextEffect1 in der Formatvorlage der angegebenen WordArt) wird in vertikalen Textfluss umgewandelt.

Set myDocument = ActivePresentation.Slides(1)
Set newWordArt = myDocument.Shapes.AddTextEffect _
    (PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=100, Top:=100)
newWordArt.TextEffect.ToggleVerticalText


TrimText-Methode

Gibt ein TextRange-Objekt zurück, das den angegebenen Text abzüglich aller vorhandenen anschließenden Leerzeichen darstellt.

Syntax

Ausdruck.TrimText

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.


Beispiel zur TrimText-Methode

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation die Zeichenfolge " Text to trim " am Anfang des Textes eingefügt und anschließend werden Meldungsfelder angezeigt, in denen die Zeichenfolge vor und nach der Kürzung angegeben wird.

With Application.ActivePresentation.Slides(1).Shapes(2) _
        .TextFrame.TextRange
    With .InsertBefore("   Text to trim   ")
        MsgBox "Untrimmed: " & """" & .Text & """"
        MsgBox "Trimmed: " & """" & .TrimText.Text & """"
    End With
End With


TwoColorGradient-Methode

Legt die angegebene Füllung auf eine zweifarbige Verlaufsfüllung fest.

Syntax

Ausdruck.TwoColorGradient(Style, Variant)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der den vier Varianten der Registerkarte Graduell im Dialogfeld Fülleffekte entspricht. Gilt für Style entweder msoGradientFromTitle oder msoGradientFromCenter, kann dieses Argument 1 oder 2 sein.


Beispiel zur TwoColorGradient-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck mit einer zweifarbigen Verlaufsfüllung hinzu und legt die Hintergrund- und Vordergrundfarben für die Füllung fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(0, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


Ungroup-Methode

Hebt die Gruppierung von gruppierten Formen in der angegebenen Form oder dem angegebenen Formbereich auf. Löst Grafiken und OLE-Objekte innerhalb der angegebenen oder dem angegebenen Formbereich auf. Formen, deren Gruppierung aufgehoben wurde, werden als einzelne ShapeRange-Objekte zurückgegeben.

Syntax

Ausdruck.Ungroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Eine Gruppe mit Formen wird als einzelne Form behandelt. Deshalb ändert sich durch Gruppieren bzw. Aufheben von Gruppierungen die Anzahl der Elemente der Shapes-Auflistung sowie die Indexnummern von Elementen, die nach den betroffenen Elementen in der Auflistung aufgeführt sind.


Beispiel zur Ungroup-Methode

Dieses Beispiel hebt die Gruppierung von gruppierten Formen auf und löst die Grafiken oder OLE-Objekte von myDocument auf.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    s.Ungroup
Next

Dieses Beispiel hebt die Gruppierung von gruppierten Formen von myDocument auf, ohne die Grafiken oder OLE-Objekte der Folie aufzulösen.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.Type = msoGroup Then s.Ungroup
Next


Unselect-Methode

Bricht die aktuelle Markierung ab.

Syntax

Ausdruck.Unselect

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur Unselect-Methode

Dieses Beispiel bricht die aktuelle Markierung in Fenster 1 ab.

Windows(1).Selection.Unselect


Update-Methode

Aktualisiert das angegebene verknüpfte OLE-Objekt. Mit der UpdateLinks-Methode können Sie alle Verknüpfungen in einer Präsentation gleichzeitig aktualisieren.

Syntax

Ausdruck.Update

Ausdruck Erforderlich. Ein Ausdruck, der ein LinkFormat-Objekt zurückgibt.


UpdateLinks-Methode

Aktualisiert verknüpfte OLE-Objekte in der angegebenen Präsentation.

Syntax

Ausdruck.UpdateLinks

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.


Beispiel zur UpdateLinks-Methode

Dieses Beispiel aktualisiert alle OLE-Verknüpfungen in der aktiven Präsentation.

ActivePresentation.UpdateLinks


UseDefaultFolderSuffix-Methode

Legt das Ordnersuffix für die angegebene Präsentation als Standardsuffix für die ausgewählte oder installierte Sprachunterstützung fest.

Syntax

Ausdruck.UseDefaultFolderSuffix

Ausdruck Ein Ausdruck, der ein WebOptions-Objekt zurückgibt.

Hinweise

Microsoft PowerPoint verwendet das Ordnersuffix, wenn Sie eine vollständige Präsentation oder Teile einer Präsentation als Webseite speichern oder veröffentlichen, wenn Sie lange Dateinamen verwenden und wenn Sie die Hilfsdateien in einem separaten Ordner speichern (das heißt, wenn die UseLongFileNames-Eigenschaft und die OrganizeInFolder-Eigenschaft auf True eingestellt sind).

Das Suffix folgt im Namen des Ordners nach dem Namen der Präsentation. Wenn die Präsentation beispielsweise "Pres1" heißt und die unterstützte Sprache Englisch ist, lautet der Ordnername Pres1_files. Die Ordnersuffixe für die einzelnen Sprachen sind im Thema FolderSuffix-Eigenschaft aufgeführt.


Beispiel zur UseDefaultFolderSuffix-Methode

In diesem Beispiel wird das Ordnersuffix für die aktive Präsentation auf das Standardsuffix eingestellt.

ActivePresentation.WebOptions.UseDefaultFolderSuffix


UserPicture-Methode

Füllt die angegebene Form mit einem einzigen Bild. Möchten Sie die Form mit kleinen, aneinander gereihten Ausgaben des Bilds füllen, verwenden Sie die UserTextured-Methode.

Syntax

Ausdruck.UserPicture(PictureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PictureFile String erforderlich. Der Name der Grafikdatei.


Beispiel zur UserPicture-Methode

Dieses Beispiel fügt zu myDocument zwei Rechtecke hinzu. Die Fläche des linken Rechtecks wird durch ein Bild der Grafik Tiles.bmp gefüllt. Die Fläche des rechten Rechtecks wird mit kleinen, aneinander gereihten Bildern der Grafik Tiles.bmp gefüllt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeRectangle, 0, 0, 200, 100).Fill _
        .UserPicture "c:\windows\tiles.bmp"
    .AddShape(msoShapeRectangle, 300, 0, 200, 100).Fill _
        .UserTextured "c:\windows\tiles.bmp"
End With


UserTextured-Methode

Füllt die angegebene Form mit kleinen, aneinander gereihten Ausgaben eines Bilds. Wenn Sie die Form mit einem einzigen Bild füllen möchten, verwenden Sie die UserPicture-Methode.

Syntax

Ausdruck.UserTextured(TextureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

TextureFile String erforderlich. Der Name der Grafikdatei.


Beispiel zur UserTextured-Methode

Dieses Beispiel fügt zu myDocument zwei Rechtecke hinzu. Die Fläche des linken Rechtecks wird durch ein Bild der Grafik Tiles.bmp gefüllt. Die Fläche des rechten Rechtecks wird durch viele kleine aneinander gereihte Bilder der Grafik Tiles.bmp gefüllt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeRectangle, 0, 0, 200, 100).Fill _
        .UserPicture "c:\windows\tiles.bmp"
    .AddShape(msoShapeRectangle, 300, 0, 200, 100).Fill _
        .UserTextured "c:\windows\tiles.bmp"
End With


Value-Methode

Gibt den Wert der angegebenen Marke als String zurück.

Syntax

Ausdruck.Value(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine Tags-Auflistung zurückgibt.

Index Long erforderlich. Die Nummer der Marke.


Beispiel zur Value-Methode

In diesem Beispiel wird der Name und der Wert für jede Marke angezeigt, das zu Folie 1 der aktiven Präsentation gehört.

With Application.ActivePresentation.Slides(1).Tags
    For i = 1 To .Count
        MsgBox "Tag #" & i & ": Name = " & .Name(i)
        MsgBox "Tag #" & i & ": Value = " & .Value(i)
    Next
End With

In diesem Beispiel werden die Marken für jede Folie der aktiven Präsentation durchsucht. Wenn eine Marke mit dem Namen "PRIORITY" existiert, wird der Wert der Marke in einem Meldungsfeld angezeigt. Wenn keine Marke mit dem Namen "PRIORITY" existiert, wird die Marke mit dem Wert "Unknown" hinzugefügt.

For Each s In Application.ActivePresentation.Slides
    With s.Tags
        found = False
        For i = 1 To .Count
            If .Name(i) = "PRIORITY" Then
                found = True
                slNum = .Parent.SlideIndex
                MsgBox "Slide " & slNum & " priority: " & .Value(i)
            End If
        Next
        If Not found Then
            slNum = .Parent.SlideIndex
            .Add "Name", "New Figures"
            .Add "Priority", "Unknown"
            MsgBox "Slide " & slNum & _
               " priority tag added: Unknown"
        End If
    End With
Next


WebPagePreview-Methode

Zeigt eine Vorschau der Präsentation im aktiven Webbrowser an.

Syntax

Ausdruck.WebPagePreview

Ausdruck Erforderlich. Ein Ausdruck, der ein Presentation-Objekt zurückgibt.


Beispiel zur WebPagePreview-Methode

In diesem Beispiel wird eine Vorschau von Präsentation 2 als Webseite ausgegeben.

Presentations(2).WebPagePreview


Words-Methode

Gibt ein TextRange-Objekt zurück, das die angegebene Untermenge von Textwörtern darstellt. Informationen über Zählvorgänge und Schleifenläufe durch die Wörter eines Textbereichs finden Sie unter TextRange-Objekt.

Syntax

Ausdruck.Words(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextRange-Objekt zurückgibt.

Start Long optional. Das erste Wort des zurückgegebenen Bereichs.

Length Long optional. Die Anzahl der zurückzugebenden Wörter.

Anmerkungen

Wenn sowohl Start als auch Length nicht angegeben werden, beginnt der zurückgegebene Bereich mit dem ersten Wort und endet mit dem letzten Absatz des festgelegten Bereichs.

Wird Start angegeben, Length jedoch nicht, enthält der zurückgegebene Bereich genau ein Wort.

Wird Length angegeben, Start jedoch nicht, beginnt der zurückgegebene Bereich mit dem ersten Wort des festgelegten Bereichs.

Ist Start größer als die Anzahl der Wörter des festgelegten Textes, beginnt der zurückgegebene Bereich mit dem letzten Wort des festgelegten Bereichs.

Ist Length größer als die Anzahl der Wörter von dem festgelegten Anfangswort bis zum Ende des Textes, enthält der zurückgegebene Bereich alle diese Wörter.


Beispiel zur Words-Methode

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation das zweite, dritte und vierte Wort im ersten Absatz fett formatiert.

Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange.Paragraphs(1).Words(2, 3).Font _
    .Bold = True


ZOrder-Methode

Verschiebt die angegebene Form vor oder hinter andere Formen in der Auflistung (d. h., es wird die Z-Reihenfolge der Form geändert).

Syntax

Ausdruck.ZOrder(ZOrderCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

ZOrderCmd Long erforderlich. Gibt an, wohin die angegebene Form relativ zu anderen Formen verschoben wird. Dies kann eine der folgenden MsoZOrderCmd-Konstanten sein: msoBringForward, msoBringToFront, msoSendBackward oder msoSendToBack. Die Konstanten msoBringInFrontOfText und msoSendBehindText werden nur in Microsoft Word verwendet.

Anmerkungen

Mit der ZOrderPosition-Eigenschaft können Sie die Position der Z-Reihenfolge der Form bestimmen.


Beispiel zur ZOrder-Methode

Wenn es mindestens eine andere Form auf der Folie gibt, fügt dieses Beispiel myDocument ein Oval hinzu, das an zweiter Stelle der hinteren Z-Reihenfolge platziert wird.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


Neue Objekte

In der folgenden Tabelle finden Sie eine Aufstellung der in Microsoft PowerPoint 2000 zu Visual Basic hinzugefügten Objekte:

Objekt | Beschreibung
Cell | Eine einzelne Zelle in einem Table-Objekt.
CellRange | Eine Auflistung von Cell-Objekten innerhalb einer Tabelle, die im Programm als .Cells bezeichnet werden.
Column | Eine vertikale Gruppierung von Zellen in einem Table-Objekt.
Columns | Eine Auflistung von Column-Objekten in einer Tabelle.
DefaultWebOptions | Eine Gruppe von Attributen auf Anwendungsebene, die als Standardeinstellungen für das Veröffentlichen oder Speichern einer Präsentation als Webseite verwendet werden.
Pane | Ein durch Teilen des Dokumentfensters entstandener Bereich. Die Normalansicht verfügt über drei Ausschnitte (Gliederung, Folie und Notizen). Alle anderen Ansichten des Dokumentfensters verfügen über nur einen Ausschnitt.
Panes | Die Auflistung der Pane-Objekte im Dokumentfenster.
PublishObject | Eine Gruppe von Attributen, die die Präsentation vollständig oder teilweise für die Veröffentlichung als Webseite definieren.
PublishObjects | Eine Auflistung eines PublishObject-Objekts.
Row | Eine horizontale Gruppierung von Zellen innerhalb eines Table-Objekts.
Rows | Eine Auflistung von Row-Objekten innerhalb einer Tabelle.
Table | Eine durch ein Netz aus Zeilen und Spalten gekennzeichnete Form.
WebOptions | Eine Gruppe von Attributen auf Präsentationsebene zum Veröffentlichen oder Speichern einer Präsentation als Webseite, die Vorrang vor den DefaultWebOptions-Attributen auf Anwendungsebene haben.


ActionSetting-Objekt

Enthält Informationen über die Reaktionen der angegebenen Form oder des Textbereichs auf Mausaktionen während einer Bildschirmpräsentation. Das ActionSetting-Objekt ist ein Element der ActionSettings-Auflistung. Die ActionSettings-Auflistung enthält ein ActionSetting-Objekt, das die Reaktion des angegebenen Objekts darstellt, wenn ein Benutzer während einer Bildschirmpräsentation darauf klickt. Außerdem enthält die Auflistung ein ActionSetting-Objekt, das die Reaktion des angegebenen Objekts darstellt, wenn der Benutzer den Mauszeiger während einer Bildschirmpräsentation darüber bewegt.

Verwendung des ActionSetting-Objekts

Mit ActionSettings(Index) können Sie ein einzelnes ActionSetting-Objekt zurückgeben. (Index ist entweder ppMouseClick oder ppMouseOver.) Das folgende Beispiel legt die Mausklickaktion für den Text in der dritten Form von Folie 1 in der aktiven Präsentation als Internetverknüpfung fest.

With ActivePresentation.Slides(1).Shapes(3) _
        .TextFrame.TextRange.ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    .Hyperlink.Address = "http://www.microsoft.com"
End With

Hinweise

Wenn die festgelegten Eigenschaften für das ActionSetting-Objekt nicht den gewünschten Effekt erzielen sollten, vergewissern Sie sich, dass für die Action-Eigenschaft der richtige Wert festgelegt wurde.


ActionSettings-Objekt (Auflistung)

Eine Auflistung, die die beiden ActionSetting-Objekte für einen Form- oder Textbereich enthält. Das eine ActionSetting-Objekt stellt dar, wie das angegebene Objekt auf einen Mausklick während einer Bildschirmpräsentation reagiert. Das andere ActionSetting-Objekt stellt dar, wie das angegebene Objekt reagiert, wenn der Benutzer während einer Bildschirmpräsentation den Mauszeiger darauf richtet.

Verwendung der ActionSettings-Auflistung

Mit der ActionSettings-Eigenschaft können Sie die ActionSettings-Auflistung zurückgeben. Mit ActionSettings(Index) können Sie ein einzelnes ActionSetting-Objekt zurückgeben. (Index ist entweder ppMouseClick oder ppMouseOver.) Dieses Beispiel gibt an, dass das Makro CalculateTotal immer dann ausgeführt wird, wenn der Mauszeiger während einer Bildschirmpräsentation auf die Form gerichtet wird.

With ActivePresentation.Slides(1).Shapes(3) _
        .ActionSettings(ppMouseOver)
    .Action = ppActionRunMacro
    .Run = "CalculateTotal"
    .AnimateAction = True
End With


 AddIn-Objekt

AddIn-Objekt

Stellt ein einzelnes Add-In dar, das entweder geladen oder nicht geladen ist. Das AddIn-Objekt ist ein Element der AddIns-Auflistung. Die AddIns-Auflistung enthält alle verfügbaren PowerPoint-spezifischen Add-Ins, wobei nicht von Bedeutung ist, ob sie geladen sind. Die Auflistung entspricht der Liste mit Add-Ins, die im Dialogfeld Add-Ins (Menü Extras) angezeigt werden. Sie enthält jedoch keine Component Object Model (COM)-Add-Ins.

Verwendung des AddIn-Objekts

Mit AddIns(Index) können Sie ein einzelnes AddIn-Objekt zurückgeben. (Index ist der Titel des Add-Ins oder die Indexnummer.) Das folgende Beispiel lädt das Add-In "my ppt tools".

AddIns("my ppt tools").Loaded = True

Verwechseln Sie den Add-In-Titel nicht mit dem Add-In-Namen. Der Titel erscheint im Dialogfeld Add-Ins, beim Add-In-Namen handelt es sich um den Dateinamen des Add-Ins. Die Buchstabenreihenfolge des Add-In-Titels muss der Schreibweise im Dialogfeld Add-Ins entsprechen, die Beachtung der Groß-/Kleinschreibung ist jedoch nicht erforderlich.

Die Indexnummer stellt die Position des Add-Ins im Feld Verfügbare Add-Ins im Dialogfeld Add-Ins dar. Das folgende Beispiel zeigt die Namen aller Add-Ins an, die aktuell in PowerPoint geladen sind.

For i = 1 To AddIns.Count
    If AddIns(i).Loaded Then MsgBox AddIns(i).Name
Next

Hinweise

Mit der Add-Methode können Sie der Liste mit verfügbaren Add-Ins ein PowerPoint-spezifisches Add-In hinzufügen. Beachten Sie jedoch, dass mit dieser Methode das Add-In nicht geladen wird. Um das Add-In zu laden, legen Sie für die Loaded-Eigenschaft des Add-Ins True fest, nachdem Sie die Add-Methode verwenden. Das folgende Beispiel zeigt, wie Sie beide Aktionen in einem Schritt ausführen können. (Beachten Sie, dass bei der Add-Methode nicht der Titel, sondern der Name des Add-Ins verwendet wird.)

AddIns.Add("generic.ppa").Loaded = True

Mit AddIns(Index) können Sie einen Bezug zum geladenen Add-In zurückgeben. (Index ist der Titel des Add-Ins.) Das folgende Beispiel legt die Variable presAddin für das Add-In mit dem Titel "my ppt tools" und die Variable myName für den Namen des Add-Ins fest.

Set presAddin = AddIns("my ppt tools")
With presAddin
    myName = .Name
End With


 AddIns-Objekt (Auflistung)

AddIns-Objekt (Auflistung)

Eine Auflistung mit AddIn-Objekten, die alle Microsoft PowerPoint-spezifischen Add-Ins darstellen, die in PowerPoint verfügbar sind. Es ist nicht von Bedeutung, ob sie geladen sind. Diese Liste entspricht der Liste mit Add-Ins, die im Dialogfeld Add-Ins (Menü Extras) angezeigt werden. Sie enthält jedoch keine Component Object Model (COM)-Add-Ins.

Verwendung der AddIns-Auflistung

Mit der AddIns-Methode können Sie die AddIns-Auflistung zurückgeben. Das folgende Beispiel zeigt die Namen aller Add-Ins an, die aktuell in PowerPoint geladen sind.

For Each ad In AddIns
    If ad.Loaded Then MsgBox ad.Name
Next

Mit der Add-Methode können Sie der Liste mit den verfügbaren Add-Ins ein PowerPoint-spezifisches Add-In hinzufügen. Die Add-Methode fügt zwar der Liste ein Add-In hinzu, lädt dies jedoch nicht. Um das Add-In zu laden, legen Sie für die Loaded-Eigenschaft des Add-Ins True fest, nachdem Sie die Add-Methode verwendet haben. Das folgende Beispiel zeigt, wie Sie beide Aktionen in einem Schritt ausführen können. (Beachten Sie, dass bei der Add-Methode nicht der Titel, sondern der Name des Add-Ins verwendet wird.)

AddIns.Add("graphdrs.ppa").Loaded = True

Mit AddIns(Index) können Sie ein einzelnes AddIn-Objekt zurückgeben. (Index ist der Titel oder die Indexnummer des Add-Ins.) Das folgende Beispiel lädt das hypothetische Add-In "my ppt tools".

AddIns("my ppt tools").Loaded = True

Verwechseln Sie den Add-In-Titel nicht mit dem Add-In-Namen. Der Titel erscheint im Dialogfeld Add-Ins, beim Add-In-Namen handelt es sich um den Dateinamen des Add-Ins. Die Buchstabenreihenfolge des Add-In-Titels muss der Schreibweise im Dialogfeld Add-Ins entsprechen, die Beachtung der Groß-/Kleinschreibung ist jedoch nicht erforderlich.


Adjustments-Objekt

Enthält eine Auflistung mit Korrekturwerten für die angegebene AutoForm, das WordArt-Objekt oder die Verbindung. Jeder Korrekturwert stellt eine Möglichkeit dar, wie ein Korrekturziehpunkt angepasst werden kann. Da es zwei Möglichkeiten gibt, Korrekturziehpunkte anzupassen (einige Ziehpunkte können horizontal und vertikal angepasst werden), kann eine Form mehr Korrekturwerte als Korrekturziehpunkte haben. Eine Form kann bis zu acht Korrekturen haben.

Verwendung des Adjustments-Objekts

Mit der Adjustments-Eigenschaft können Sie ein Adjustments-Objekt zurückgeben. Mit Adjustments(Index) können Sie einen einzelnen Korrekturwert zurückgeben. (Index ist die Indexnummer des Korrekturwerts).

Verschiedene Formen können eine unterschiedliche Anzahl von Korrekturwerten haben, verschiedene Arten der Korrekturen ändern die Geometrie einer Form auf unterschiedliche Art und Weise, und verschiedene Arten der Korrekturen können unterschiedliche Bereiche mit gültigen Werten besitzen. Die folgende Illustration zeigt, was jeder einzelne der vier Korrekturwerte für eine Legende mit einem rechten Pfeil zur Definition der Geometrie der Legende beiträgt.

Legende mit rechtem Pfeil und unterschiedlichen Korrekturziehpunkten

Anmerkung Da jede korrigierbare Form über unterschiedliche Sätze mit Korrekturen verfügt, können Sie das Korrekturverhalten für eine bestimmte Form am besten dadurch prüfen, dass Sie eine Instanz der Form manuell erstellen, Korrekturen über die aktivierte Makroaufzeichnung vornehmen und anschließend den aufgezeichneten Code überprüfen.

Die folgende Tabelle fasst die Bereiche der gültigen Korrekturwerte für verschiedene Korrekturtypen zusammen. In den meisten Fällen wird der Korrektur der nächste gültige Wert zugewiesen, wenn Sie einen Wert angeben, der den Bereich der gültigen Werte überschreitet.

Korrekturtyp | Gültige Werte
Linear (horizontal oder vertikal) | In der Regel stellt der Wert 0,0 die linke Seite oder die Oberseite der Form und 1,0 die rechte Seite oder die Unterseite der Form dar. Gültige Werte entsprechen gültigen Korrekturen, die Sie bei der Form manuell vornehmen können. Wenn Sie z. B. einen Korrekturziehpunkt nur zur Hälfte manuell über die Form ziehen können, beträgt der maximale Wert für die entsprechende Korrektur 0,5. Formen wie Verbindungen und Legenden, bei denen die Werte 0,0 und 1,0 die Grenzen des Rechtecks darstellen, das durch die Anfangs- und Endpunkte der Verbindung oder Legendenlinie definiert wird, stellen negative Werte und Werte größer als 1,0 gültige Werte dar.
Radial | Ein Korrekturwert von 1,0 entspricht der Breite der Form. Der maximale Wert beträgt 0,5 bzw. die Hälfte der Form.
Winkel | Werte werden in Grad ausgedrückt. Wenn Sie einen Wert außerhalb des Bereichs zwischen -180 und 180 angeben, wird dieser für den Bereich angepasst.

Das folgende Beispiel fügt zu myDocument eine Legende mit einem rechten Pfeil hinzu und legt die Korrekturwerte für die Legende fest. Beachten Sie, dass die Form zwar nur drei Korrekturziehpunkte besitzt, jedoch vier Korrekturen hat. Die Korrekturen drei und vier entsprechen dem Ziehpunkt zwischen der Pfeilspitze und der Halsspitze des Pfeils.

Set myDocument = ActivePresentation.Slides(1)
Set rac = myDocument.Shapes _
    .AddShape(msoShapeRightArrowCallout, 10, 10, 250, 190)
With rac.Adjustments
    .Item(1) = 0.5    'adjusts width of text box
    .Item(2) = 0.15   'adjusts width of arrow head
    .Item(3) = 0.8    'adjusts length of arrow head
    .Item(4) = 0.4    'adjusts width of arrow neck
End With


AnimationSettings-Objekt

Stellt die Spezialeffekte dar, die der Animation für die angegebene Form während einer Bildschirmpräsentation zugewiesen wurden.

Verwendung des AnimationSettings-Objekts

Mit der AnimationSettings-Eigenschaft des Shape-Objekts können Sie das AnimationSettings-Objekt zurückgeben. Das folgende Beispiel fügt der aktiven Präsentation eine Folie hinzu, die einen Titel und eine Liste mit drei Elementen enthält. Anschließend wird für die Liste festgelegt, dass sie von Absätzen der ersten Ebene animiert wird, die Form mit dem Flugeffekt von links kommt, wenn sie animiert wird, die angegebene Farbe nach dem Animieren abgeblendet wird und die Elemente der Liste in umgekehrter Reihenfolge animiert werden.

Set sObjs = ActivePresentation.Slides.Add(2, ppLayoutText).Shapes
sObjs.Title.TextFrame.TextRange.Text = "Top Three Reasons"
With sObjs.Placeholders(2)
    .TextFrame.TextRange.Text = _
        "Reason 1" & VBNewLine & "Reason 2" & VBNewLine & "Reason 3"
    With .AnimationSettings
        .TextLevelEffect = ppAnimateByFirstLevel
        .EntryEffect = ppEffectFlyFromLeft
        .AfterEffect = ppAfterEffectDim
        .DimColor.RGB = RGB(100, 120, 100)
        .AnimateTextInReverse = True
    End With
End With


Application-Objekt

Stellt die gesamte Anwendung Microsoft PowerPoint dar. Das Application-Objekt enthält:

  • Einstellungen und Optionen für die gesamte Anwendung (z. B. den Namen des aktiven Druckers).

  • Eigenschaften, die Objekte der obersten Ebene zurückgeben, z. B. ActivePresentation, Windows usw.

Verwendung des Application-Objekts

Mit der Application-Eigenschaft können Sie das Application-Objekt zurückgeben. Das folgende Beispiel gibt den Pfad zur Anwendungsdatei zurück.

Dim MyPath As String
MyPath = Application.Path

Das folgende Beispiel erstellt ein Application-Objekt von PowerPoint in einer anderen Anwendung, startet PowerPoint (wenn die Anwendung nicht bereits läuft) und öffnet eine vorhandene Präsentation mit der Bezeichnung ex_a2a.ppt.

Set ppt = New Powerpoint.Application
ppt.Visible = True
ppt.Presentations.Open "c:\My Documents\ex_a2a.ppt"

Hinweise

Wenn Sie einen Code schreiben, der von PowerPoint abläuft, können die folgenden Eigenschaften des Application-Objekts ohne Objektkennzeichner verwendet werden: ActivePresentation, ActiveWindow, AddIns, Assistant, CommandBars, Presentations, SlideShowWindows und Windows. So können Sie z. B. ActiveWindow.Height = 200 anstelle von Application.ActiveWindow.Height = 200 schreiben.


Borders-Objekt (Auflistung)

Eine Auflistung von LineFormat-Objekten, die die Rahmen und diagonalen Linien einer Zelle oder eines Zellbereichs in einer Tabelle darstellen.

Verwendung der Borders-Auflistung

Jedes Cell-Objekt oder jede CellRange-Auflistung verfügt über sechs Elemente in der Borders-Auflistung. Zur Borders-Auflistung können keine Objekte hinzugefügt werden.

Verwenden Sie Borders(Index), wobei Index den Zellrahmen oder die diagonale Zeile identifiziert, um ein einzelnes Border-Objekt zurückzugeben. Index kann eine der folgenden PPBorderType-Konstanten sein: ppBorderBottom, ppBorderLeft, ppBorderRight, ppBorderTop, ppBorderDiagonalDown oder ppBorderDiagonalUp.

Mit der DashStyle-Eigenschaft können Sie einem Border-Objekt das Format einer gestrichelten Linie zuweisen. In diesem Beispiel wird die zweite Zeile der Tabelle ausgewählt, und der unteren Rahmenlinie wird das Format einer gestrichelten Linie zugewiesen.

ActiveWindow.Selection.ShapeRange.Table.Rows(2) _
    .Cells.Borders(ppBorderBottom).DashStyle = msoLineDash


BulletFormat-Objekt

Stellt die Formatierung von Aufzählungszeichen dar.

Verwendung des BulletFormat-Objekts

Mit der Bullet-Eigenschaft können Sie das BulletFormat-Objekt zurückgeben. Das folgende Beispiel legt die Größe und Farbe für die Aufzählungszeichen der Absätze in Form 2 von Folie 1 in der aktiven Präsentation fest.

With ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat.Bullet
        .Visible = True
        .RelativeSize = 1.25
        .Character = 169
        With .Font
            .Color.RGB = RGB(255, 255, 0)
            .Name = "Symbol"
        End With
    End With
End With


CalloutFormat-Objekt

Enthält Eigenschaften und Methoden, die Legenden mit Linien zugewiesen werden.

Verwendung des CalloutFormat-Objekts

Mit der Callout-Eigenschaft können Sie ein CalloutFormat-Objekt zurückgeben. Das folgende Beispiel gibt die folgenden Attribute von Form 3 (eine Legende mit Linie) von myDocument an:

  • Die Legende verfügt über eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

  • Der Winkel zwischen der Legendenlinie und der Seite des Legendentextfeldes beträgt 30 Grad.

  • Der Legendentext ist nicht von einem Rahmen umgeben.

  • Die Legendenlinie wird oben am Legendentextfeld angefügt.

  • Die Legendenlinie besteht aus zwei Abschnitten.

Damit dieses Beispiel funktioniert, muss Form 3 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Callout
    .Accent = True
    .Angle = msoCalloutAngle30
    .Border = False
    .PresetDrop msoCalloutDropTop
    .Type = msoCalloutThree
End With


Cell-Objekt

Stellt eine Tabellenzelle dar. Das Cell-Objekt gehört zur CellRange-Auflistung. Die CellRange-Auflistung stellt alle Zellen in der angegebenen Spalte oder Zeile dar. Wenn Sie mit der CellRange-Auflistung arbeiten möchten, verwenden Sie das Cells-Schlüsselwort.

Arbeiten mit dem Cell-Objekt

Verwenden Sie Cell(row, column), wobei row die Zeilennummer und column die Spaltennummer darstellt, oder Cells(index), wobei index die Nummer der Zelle in der angegebenen Zeile oder Spalte ist, um ein einzelnes Cell-Objekt zurückzugeben. Zellen werden von links nach rechts in den Zeilen und von oben nach unten in den Spalten nummeriert. Bei Einstellungen für Sprachen mit der Schreibrichtung von rechts nach links verhält sich dieses Schema umgekehrt. Im folgenden Beispiel werden die ersten zwei Zellen in Zeile 1 der Tabelle in Form 5 auf Folie 2 zusammengeführt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Cell(1, 1).Merge MergeTo:=.Cell(1, 2)
End With

In diesem Beispiel wird die untere Rahmenlinie für Zelle 1 in der ersten Spalte der Tabelle als gestrichelte Linie formatiert.

With ActivePresentation.Slides(2).Shapes(5).Table.Columns(1) _
        .Cells(1)
    .Borders(ppBorderBottom).DashStyle = msoLineDash
End With

Verwenden Sie die Shape-Eigenschaft, um auf das Shape-Objekt zuzugreifen und den Inhalt der einzelnen Zellen zu bearbeiten. In diesem Beispiel wird der Text in der ersten Zelle (Zeile 1, Spalte 1) gelöscht, neuer Text eingefügt und danach die Breite der gesamten Spalte auf 110 Punkt eingestellt.

With ActivePresentation.Slides(2).Shapes(5).Table.Cell(1, 1)
    .Shape.TextFrame.TextRange.Delete
    .Shape.TextFrame.TextRange.Text = "Rooster"
    .Parent.Columns(1).Width = 110
End With

Hinweise

Sie können durch ein Programm einer PowerPoint-Tabelle keine Zellen hinzufügen oder Zellen aus der Tabelle löschen. Verwenden Sie die Add-Methode der Columns-Auflistung oder Rows-Auflistung, um einer Tabelle eine Zeile oder Spalte hinzuzufügen. Verwenden Sie die Delete-Methode der Columns-Auflistung oder Rows-Auflistung, um eine Spalte oder Zeile aus einer Tabelle zu löschen.


CellRange-Objekt (Auflistung)

Eine Auflistung von Cell-Objekten in einer Tabellenspalte oder -zeile. Die CellRange-Auflistung stellt alle Zellen in der angegebenen Spalte oder Zeile dar. Wenn Sie mit der CellRange-Auflistung arbeiten möchten, verwenden Sie das Cells-Schlüsselwort.

Verwendung der CellRange-Auflistung

Verwenden Sie die Cells-Eigenschaft, um die CellRange-Auflistung zurückzugeben. In diesem Beispiel wird die rechte Rahmenlinie für die Zellen der ersten Spalte der Tabelle als gestrichelte Linie formatiert.

With ActivePresentation.Slides(2).Shapes(5).Table.Columns(1).Cells
    .Borders(ppBorderRight).DashStyle = msoLineDash
End With

In diesem Beispiel wird die Anzahl der Zellen in Zeile 1 der ausgewählten Tabelle zurückgegeben.

num = ActiveWindow.Selection.ShapeRange.Table.Rows(1).Cells.Count

Verwenden Sie Cell(row, column), wobei row die Zeilennummer und column die Spaltennummer darstellt, oder Cells(index), wobei index die Nummer der Zelle in der angegebenen Zeile oder Spalte ist, um ein einzelnes Cell-Objekt zurückzugeben. Zellen werden in Zeilen von links nach rechts und in Spalten von oben nach unten nummeriert. Bei Sprachen mit der Schreibrichtung von rechts nach links ist dieses Schema umgekehrt. Im folgenden Beispiel werden die ersten zwei Zellen in Zeile 1 der Tabelle in Form 5 auf Folie 2 zusammengeführt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Cell(1, 1).Merge MergeTo:=.Cell(1, 2)
End With

Hinweise

Obwohl das Auflistungsobjekt den Namen CellRange trägt und im Objektkatalog angezeigt wird, wird dieses Schlüsselwort nicht bei der Programmierung des PowerPoint-Objektmodells verwendet. Stattdessen wird das Schlüsselwort Cells verwendet.

Sie können durch ein Programm einer PowerPoint-Tabelle keine Zellen hinzufügen oder Zellen aus der Tabelle löschen. Verwenden Sie die AddTable-Methode mit dem Table-Objekt, um eine neue Tabelle hinzuzufügen. Verwenden Sie die Add-Methode der Columns-Auflistung oder Rows-Auflistung, um einer Tabelle eine Spalte oder Zeile hinzuzufügen. Verwenden Sie die Delete-Methode der Columns-Auflistung oder Rows-Auflistung, um eine Spalte oder Zeile aus einer Tabelle zu löschen.


ColorFormat-Objekt

Stellt die Farbe eines einfarbigen Objekts, die Vordergrundfarbe oder Hintergrundfarbe eines Objekts mit einem Verlauf oder einer gemusterten Füllung oder die Farbe des Mauszeigers fest. Sie können Farben als expliziten Rot-Grün-Blau-Wert (mit der RGB-Eigenschaft) oder als Farbe in der Farbskala (mit der SchemeColor-Eigenschaft) festlegen.

Verwendung des ColorFormat-Objekts

Mit den Eigenschaften, die in der folgenden Tabelle aufgelistet sind, können Sie ein ColorFormat-Objekt zurückgeben.

Verwenden Sie diese Eigenschaft | Mit diesem Objekt | Um das folgende ColorFormat-Objekt zurückzugeben
DimColor | AnimationSettings | Farbe für abgeblendete Objekte
BackColor | FillFormat | Füllfarbe für den Hintergrund (bei einer schattierten oder gemusterten Füllung)
ForeColor | FillFormat | Füllfarbe für den Vordergrund (bzw. einfach die Füllfarbe für eine einfarbige Füllung)
Color | Font | Farbe für Aufzählungszeichen oder Schriften
BackColor | LineFormat | Linienfarbe für den Hintergrund (bei einer gemusterten Linie)
ForeColor | LineFormat | Linienfarbe für den Vordergrund (oder nur die Linienfarbe für eine einfarbige Linie)
ForeColor | ShadowFormat | Schattenfarbe
PointerColor | SlideShowSettings | Standardfarbe des Mauszeigers für eine Präsentation
PointerColor | SlideShowView | Temporäre Farbe des Mauszeigers für eine Ansicht einer Bildschirmpräsentation
ExtrusionColor | ThreeDFormat | Farbe der Seiten eines projizierten Objekts

Mit der SchemeColor-Eigenschaft können Sie die Farbe eines Folienelements als eine der Farben in der Standardfarbskala festlegen. Das folgende Beispiel legt die Textfarbe für Form 1 in Folie 2 der aktiven Präsentation als Standardtitelfarbe der Farbskala fest.

ActivePresentation.Slides(2).Shapes(1).TextFrame _
    .TextRange.Font.Color.SchemeColor = ppTitle

Mit der RGB-Eigenschaft können Sie für eine Farbe einen expliziten Rot-Grün-Blau-Wert festlegen. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu und legt anschließend die Vordergrundfarbe, Hintergrundfarbe und den Verlauf für die Füllung des Rechtecks fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, 90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


ColorScheme-Objekt

Stellt eine Farbskala dar, die einen Satz mit acht Farben für die verschiedenen Elemente einer Folie, Notizenseite oder Handzettel, z. B. den Titel oder Hintergrund, besitzt. (Beachten Sie, dass die Farbskalen für Folien, Notizenseiten und Handzettel in einer Präsentation unabhängig festgelegt werden können.) Jede Farbe wird durch ein RGBColor-Objekt dargestellt. Das ColorScheme-Objekt ist ein Element der ColorSchemes-Auflistung. Die ColorSchemes-Auflistung enthält alle Farbskalen in einer Präsentation.

Verwendung des ColorScheme-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben eines ColorScheme-Objekts aus der Auflistung mit allen Farbskalen der Präsentation

  • Zurückgeben des ColorScheme-Objekts, das einer bestimmten Folie oder einem Master beigefügt ist

  • Zurückgeben der Farbe eines einzelnen Folienelements von einem ColorScheme-Objekt

Zurückgeben eines ColorScheme-Objekts aus der Auflistung mit allen Farbskalen der Präsentation

Mit ColorSchemes(Index) können Sie ein einzelnes ColorScheme-Objekt zurückgeben. (Index ist die Indexnummer der Farbskala.) Das folgende Beispiel löscht Farbskala 2 aus der aktiven Präsentation.

ActivePresentation.ColorSchemes(2).Delete

Zurückgeben des ColorScheme-Objekts, das einer bestimmten Folie oder einem Master beigefügt ist

Legen Sie die ColorScheme-Eigenschaft für ein Slide-, SlideRange- oder Master-Objekt fest, um die Farbskala für eine Folie, einen Satz mit Folien bzw. einen Master zurückzugeben. Das folgende Beispiel erstellt eine Farbskala, die auf der aktuellen Folie basiert, fügt die neue Farbskala der Auflistung mit Standardfarbskalen der Präsentation hinzu und legt die neue Farbskala als Farbskala für den Folienmaster fest. Alle neuen Folien, die auf dem Master basieren, werden diese Farbskala haben.

Set newScheme = ActiveWindow.View.Slide.ColorScheme
newScheme.Colors(ppTitle).RGB = RGB(0, 150, 250)
Set newStandardScheme = _
    ActivePresentation.ColorSchemes.Add(newScheme)
ActivePresentation.SlideMaster.ColorScheme = newStandardScheme

Zurückgeben der Farbe eines einzelnen Folienelements von einem ColorScheme-Objekt

Mit der Colors-Methode können Sie ein RGBColor-Objekt zurückgeben, das die Farbe eines einzelnen Typs für ein Folienelement darstellt. Sie können ein RGBColor-Objekt als anderes RGBColor-Objekt festlegen. Sie können auch mit der RGB-Eigenschaft den ausdrücklichen Rot-Grün-Blau-Wert (RGB) für ein RGBColor-Objekt festlegen oder zurückgeben. Das folgende Beispiel legt als Hintergrundfarbe in Farbskala 1 die Farbe Rot und die Titelfarbe fest, die für Farbskala 2 definiert wurde.

With ActivePresentation.ColorSchemes
    .Item(1).Colors(ppBackground).RGB = RGB(255, 0, 0)
    .Item(1).Colors(ppTitle) = .Item(2).Colors(ppTitle)
End With


ColorSchemes-Objekt (Auflistung)

Eine Auflistung aller ColorScheme-Objekte in der angegebenen Präsentation. Jedes ColorScheme-Objekt stellt eine Farbskala dar, die einen Satz mit Farben enthält, die in einer Folie verwendet werden.

Verwendung der ColorSchemes-Auflistung

Mit der ColorSchemes-Eigenschaft können Sie die ColorSchemes-Auflistung zurückgeben. Mit ColorSchemes(Index), können Sie ein einzelnes ColorScheme-Objekt zurückgeben. (Index ist die Indexnummer der Farbskala.) Das folgende Beispiel löscht Farbskala 2 aus der aktiven Präsentation.

ActivePresentation.ColorSchemes(2).Delete

Mit der Add-Methode können Sie eine neue Farbskala erstellen und zur ColorSchemes-Auflistung hinzufügen. Das folgende Beispiel fügt der aktiven Präsentation eine Farbskala hinzu und legt die Titelfarbe und Hintergrundfarbe für die Farbskala fest. (Da bei der Add-Methode kein Argument angegeben wurde, ist die hinzugefügte Farbskala zunächst mit der ersten Standardfarbskala in der Präsentation identisch.)

With ActivePresentation.ColorSchemes.Add
    .Colors(ppTitle).RGB = RGB(255, 0, 0)
    .Colors(ppBackground).RGB = RGB(128, 128, 0)
End With

Legen Sie die ColorScheme-Eigenschaft eines Slide-, SlideRange- oder Master-Objekts fest, um die Farbskala für eine Folie, einen Satz mit Folien bzw. einen Master zurückzugeben. Das folgende Beispiel legt als Farbskala für alle Folien in der aktiven Präsentation die dritte Farbskala in der Präsentation fest.

With ActivePresentation
    .Slides.Range.ColorScheme = .ColorSchemes(3)
End With


Column-Objekt

Stellt eine Tabellenspalte dar. Das Column-Objekt ist ein Element der Columns-Auflistung. Die Columns-Auflistung umfasst alle Spalten in einer Tabelle.

Verwendung des Column-Objekts

Verwenden Sie Columns(Index), um ein einzelnes Column-Objekt zurückzugeben. Index stellt die Position der Spalte in der Columns-Auflistung dar (dabei wird normalerweise von links nach rechts gezählt. Dies kann jedoch durch die TableDirection-Eigenschaft umgekehrt werden). In diesem Beispiel wird die erste Spalte der Tabelle in Form 5 auf der zweiten Folie ausgewählt.

ActivePresentation.Slides(2).Shapes(5).Table.Columns(1).Select

Mit dem Cell-Objekt können Sie indirekt auf das Column-Objekt verweisen. In diesem Beispiel wird der Text in der ersten Zelle (Reihe 1, Spalte 1) gelöscht, neuer Text eingefügt und dann die Breite der gesamten Spalte auf 110 Punkt gesetzt.

With ActivePresentation.Slides(2).Shapes(5).Table.Cell(1, 1)
    .Shape.TextFrame.TextRange.Delete
    .Shape.TextFrame.TextRange.Text = "Rooster"
    .Parent.Columns(1).Width = 110
End With

Mit der Add-Methode können Sie eine Spalte zu einer Tabelle hinzufügen. In diesem Beispiel wird eine Spalte in einer bestehenden Tabelle erstellt und die Spaltenbreite auf 72 Punkt (ein Zoll, ca. 2,54 cm) gesetzt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Columns.Add.Width = 72
End With

Hinweise

Mit der Cells-Eigenschaft können Sie die einzelnen Zellen in einem Column-Objekt verändern. In diesem Beispiel wird die erste Spalte der Tabelle ausgewählt und am unteren Rand eine gestrichelte Rahmenlinie hinzugefügt.

ActiveWindow.Selection.ShapeRange.Table.Columns(1) _
    .Cells.Borders(ppBorderBottom).DashStyle = msoLineDash


Columns-Objekt (Auflistung)

Eine Auflistung von Column-Objekten, die die Spalten in einer Tabelle darstellen.

Verwendung der Columns-Auflistung

Mit der Columns-Eigenschaft können Sie die Columns-Auflistung zurückgeben. In diesem Beispiel wird die erste Tabelle in der aktiven Präsentation gesucht, die Anzahl der Column-Objekte in der Columns-Auflistung gezählt, und die Information dem Benutzer angezeigt.

Dim ColCount, sl, sh As Integer

With ActivePresentation
    For sl = 1 To .Slides.Count
        For sh = 1 To .Slides(sl).Shapes.Count
            If .Slides(sl).Shapes(sh).HasTable Then
                ColCount = .Slides(sl).Shapes(sh) _
                    .Table.Columns.Count
                MsgBox "Shape " & sh & " on slide " & sl & _
                    " contains the first table and has " & _
                    ColCount & " columns."
                Exit Sub
            End If
        Next
    Next
End With

Mit der Add-Methode können Sie einer Tabelle eine Spalte hinzufügen. In diesem Beispiel wird eine Spalte in einer bestehenden Tabelle erstellt, und die Breite der neuen Spalte auf 72 Punkt (ein Zoll, ca. 2,54 cm) gesetzt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Columns.Add.Width = 72
End With

Verwenden Sie Columns(Index), um ein einzelnes Column-Objekt zurückzugeben. Index stellt die Position der Spalte in der Columns-Auflistung dar. (Dabei wird normalerweise von links nach rechts gezählt; durch die TableDirection-Eigenschaft kann dies jedoch umgekehrt werden.) In diesem Beispiel wird die erste Spalte der Tabelle in Form 5 auf der zweiten Folie gewählt.

ActivePresentation.Slides(2).Shapes(5).Table.Columns(1).Select


ConnectorFormat-Objekt

Enthält Eigenschaften und Methoden, die Verbindungen zugewiesen werden. Eine Verbindung ist eine Linie, die zwei andere Formen mit als Verbindungspunkte bezeichneten Punkten zusammenfügt. Wenn Sie die verbundenen Formen neu anordnen, wird die Geometrie der Verbindung automatisch angepasst, so dass die Formen verbunden bleiben.

Verwendung des ConnectorFormat-Objekts

Mit der ConnectorFormat-Eigenschaft können Sie ein ConnectorFormat-Objekt zurückgeben. Mit der BeginConnect- und EndConnect-Methode können Sie die Enden einer Verbindung mit anderen Formen im Dokument zusammenfügen. Mit der RerouteConnections-Methode können Sie automatisch den kürzesten Pfad zwischen den beiden Formen suchen, die mit der Verbindung verbunden sind. Mit der Connector-Eigenschaft können Sie feststellen, ob es sich bei einer Form um eine Verbindung handelt.

Beachten Sie, dass Sie eine Größe und Position zuweisen, wenn Sie der Shapes-Auflistung eine Verbindung hinzufügen. Die Größe und Position werden jedoch automatisch angepasst, wenn Sie den Anfang und das Ende der Verbindung mit anderen Formen der Auflistung zusammenfügen. Wenn Sie beabsichtigen, eine Verbindung mit anderen Formen zusammenzufügen, sind die ursprüngliche Größe und Position nicht relevant, die Sie angeben. Dies gilt auch, wenn Sie angeben, welche Verbindungspunkte einer Form mit der Verbindung zusammengefügt werden sollen, wenn Sie die Verbindung zusammenfügen. Wenn Sie jedoch die RerouteConnections-Methode verwenden, nachdem die Verbindung zusammengefügt wurde, können sich die Verbindungspunkte ändern, mit denen die Verbindung zusammengefügt wurde. Dadurch wird Ihre ursprüngliche Wahl der Verbindungspunkte irrelevant.

Das folgende Beispiel fügt zu myDocument zwei Rechtecke hinzu und verbindet diese mit einer gekrümmten Verbindung.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 0, 0).ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    .Parent.RerouteConnections
End With

Hinweise

Verbindungspunkte werden nach den Regeln nummeriert, die in der folgenden Tabelle verzeichnet sind.

Formart | Schema für die Nummerierung des Verbindungspunkts
AutoFormen, WordArt, Grafiken und OLE-Objekte | Die Verbindungspunkte werden von oben fortlaufend entgegen dem Uhrzeigersinn nummeriert.
Freihandformen | Die Verbindungspunkte sind die Scheitelpunkte, die den Nummern der Scheitelpunkte entsprechen.

Um herauszufinden, welche Nummer dem Verbindungspunkt auf einer komplexen Form entspricht, können Sie mit der Form experimentieren, während die Makroaufzeichnung aktiv ist, und anschließend den aufgezeichneten Code überprüfen. Sie können auch eine Form erstellen, diese markieren und anschließend das folgende Beispiel ablaufen lassen. Dieser Code nummeriert jeden Verbindungspunkt und fügt diesen mit einer Verbindung zusammen.

Set mainshape = ActiveWindow.Selection.ShapeRange(1)
With mainshape
    bx = .Left + .Width + 50
    by = .Top + .Height + 50
End With
With ActiveWindow.View.Slide
    For j = 1 To mainshape.ConnectionSiteCount
        With .Shapes.AddConnector(msoConnectorStraight, _
                bx, by, bx + 50, by + 50)
            .ConnectorFormat.EndConnect mainshape, j
            .ConnectorFormat.Type = msoConnectorElbow
            .Line.ForeColor.RGB = RGB(255, 0, 0)
            l = .Left
            t = .Top
        End With
        With .Shapes.AddTextbox(msoTextOrientationHorizontal, _
                l, t, 36, 14)
            .Fill.Visible = False
            .Line.Visible = False
            .TextFrame.TextRange.Text = j
        End With
    Next j
End With


DefaultWebOptions-Objekt

Enthält Attribute auf der globalen Anwendungsebene, die von Microsoft PowerPoint verwendet werden, wenn Sie eine Präsentation vollständig oder teilweise als Webseite veröffentlichen bzw. speichern oder eine Webseite öffnen. Sie können Attribute zurückgeben oder festlegen, entweder auf Anwendungsebene (global) oder auf Präsentationsebene. (Beachten Sie, dass die Attributwerte von einer Präsentation zur anderen unterschiedlich sein können, je nach Attributwert zu dem Zeitpunkt, an dem die Präsentation gespeichert wurde.) Attribute auf Präsentationsebene überschreiben Attributeinstellungen auf Anwendungsebene. Attribute auf Präsentationsebene sind im WebOptions-Objekt enthalten.

Verwendung des DefaultWebOptions-Objekts

Mit der DefaultWebOptions-Eigenschaft können Sie das DefaultWebOptions-Objekt zurückgeben. Im anschließenden Beispiel wird geprüft, ob PNG (Portable Network Graphics) als Grafikformat zugelassen ist, und dann die Variable strImageFileType entsprechend eingestellt.

Set objAppWebOptions = Application.DefaultWebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        strImageFileType = "PNG"
    Else
        strImageFileType = "JPG"
    End If
End With


DocumentWindow-Objekt

Stellt ein Dokumentfenster dar. Das DocumentWindow-Objekt ist ein Element der DocumentWindows-Auflistung. Die DocumentWindows-Auflistung enthält alle geöffneten Dokumentfenster.

Verwendung des DocumentWindow-Objekts

Mit Windows(Index) können Sie ein einzelnes DocumentWindow-Objekt zurückgeben. (Index ist die Indexnummer des Dokumentfensters.) Das folgende Beispiel aktiviert Dokumentfenster 2.

Windows(2).Activate

Das erste Element der DocumentWindows-Auflistung (Windows(1)) gibt immer das aktive Dokumentfenster zurück. Sie können aber auch mit der ActiveWindow-Eigenschaft das aktive Dokumentfenster zurückgeben. Das folgende Beispiel maximiert das aktive Fenster.

ActiveWindow.WindowState = ppWindowMaximized

Verwenden Sie Panes(Index), wobei Index die Indexnummer des Fensterausschnitts ist, um die Fensterausschnitte innerhalb der Normal-, Folien-, Gliederungs- und Notizenseitenansicht des Dokumentfensters zu verändern. Im folgenden Beispiel wird Fensterausschnitt 3, die Notizenansicht, aktiviert.

ActiveWindow.Panes(3).Activate

Mit der ActivePane-Eigenschaft können Sie den aktiven Fensterausschnitt innerhalb des Dokumentfensters zurückgeben. Das folgende Beispiel prüft, ob der aktive Fensterausschnitt der Gliederungsausschnitt ist. Wenn nicht, wird der Gliederungsausschnitt aktiviert.

mypane = ActiveWindow.ActivePane.ViewType
    If mypane <> 1 Then
        ActiveWindow.Panes(1).Activate
    End If

Mit der Presentation-Eigenschaft können Sie die Präsentation zurückgeben, die im angegebenen Dokumentfenster aktuell abläuft.

Mit der Selection-Eigenschaft können Sie die Markierung zurückgeben.

Mit der SplitHorizontal-Eigenschaft können Sie den Prozentsatz der Bildschirmbreite zurückgeben, den der Gliederungsausschnitt in der Normalansicht einnimmt.

Mit der SplitVertical-Eigenschaft können Sie den Prozentsatz der Bildschirmhöhe zurückgeben, den der Folienausschnitt in der Normalansicht einnimmt.

Mit der View-Eigenschaft können Sie die Ansicht im angegebenen Dokumentfenster zurückgeben.


DocumentWindows-Objekt (Auflistung)

Eine Auflistung aller DocumentWindow-Objekte, die in PowerPoint aktuell geöffnet sind. Diese Auflistung enthält keine geöffneten Bildschirmpräsentationsfenster. Diese befinden sich in der SlideShowWindows-Auflistung.

Verwendung der DocumentWindows-Auflistung

Mit der Windows-Eigenschaft können Sie die DocumentWindows-Auflistung zurückgeben. Das folgende Beispiel teilt die geöffneten Dokumentfenster.

Windows.Arrange ppArrangeTiled

Mit der NewWindow-Methode können Sie ein Dokumentfenster erstellen und der DocumentWindows-Auflistung hinzufügen. Das folgende Beispiel erstellt ein neues Fenster für die aktive Präsentation.

ActivePresentation.NewWindow

Mit Windows(Index) können Sie ein einzelnes DocumentWindow-Objekt zurückgeben. (Index ist die Indexnummer des Fensters.) Das folgende Beispiel schließt Dokumentfenster 2.

Windows(2).Close


 ExtraColors-Objekt

ExtraColors-Objekt

Stellt die zusätzlichen Farben in einer Präsentation dar. Das Objekt kann bis zu acht Farben enthalten, jede davon wird durch einen Rot-Grün-Blau-Wert (RGB) dargestellt.

Verwendung des ExtraColors-Objekts

Mit der ExtraColors-Eigenschaft können Sie das ExtraColors-Objekt zurückgeben. ExtraColors(Index) gibt den Rot-Grün-Blau-Wert (RGB) für eine einzelne zusätzliche Farbe an. Hierbei ist Index die Indexnummer der zusätzlichen Farbe. Im folgenden Beispiel wird der Folie 1 in der aktiven Präsentation ein Rechteck hinzugefügt und als Füllfarbe des Vordergrundes die erste zusätzliche Farbe bestimmt. Wenn nicht mindestens eine zusätzliche Farbe für die Präsentation definiert wurde, kann das Beispiel nicht durchgeführt werden.

With ActivePresentation
    Set rect = .Slides(1).Shapes _
        .AddShape(msoShapeRectangle, 50, 50, 100, 200)
    rect.Fill.ForeColor.RGB = .ExtraColors(1)
End With

Mit der Add-Methode können Sie eine zusätzliche Farbe hinzufügen. Das folgende Beispiel fügt der aktiven Präsentation eine zusätzliche Farbe hinzu (falls diese nicht bereits hinzugefügt wurde).

ActivePresentation.ExtraColors.Add RGB(69, 32, 155)


FillFormat-Objekt

Stellt die Formatierung der Füllung für eine Form dar. Eine Form kann folgende Füllungen haben: einfarbig, Verlauf, Struktur, Muster, Grafik oder semi-transparent.

Verwendung des FillFormat-Objekts

Mit der Fill-Eigenschaft können Sie ein FillFormat-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu und legt anschließend den Verlauf und die Farbe für die Füllung des Rechtecks fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 80).Fill
    .ForeColor.RGB = RGB(0, 128, 128)
    .OneColorGradient msoGradientHorizontal, 1, 1
End With

Hinweise

Viele der Eigenschaften des FillFormat-Objekts sind schreibgeschützt. Um eine dieser Eigenschaften festzulegen, müssen Sie die entsprechende Methode zuweisen.


Font-Objekt

Stellt die Zeichenformatierung für Text oder ein Aufzählungszeichen dar. Das Font-Objekt ist ein Element der Fonts-Auflistung. Die Fonts-Auflistung enthält alle Schriftarten, die in einer Präsentation verwendet werden.

Verwendung des Font-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben des Font-Objekts, das die Zeichenformatierung für ein angegebenes Aufzählungszeichen, einen angegebenen Textbereich oder den gesamten Text bei einer angegebenen Gliederungsebene enthält

  • Zurückgeben eines Font-Objekts aus der Auflistung mit allen Schriftarten einer Präsentation

Zurückgeben des Font-Objekts, das die Zeichenformatierung für ein angegebenes Aufzählungszeichen, einen angegebenen Textbereich oder den gesamten Text bei einer angegebenen Gliederungsebene enthält

Mit der Font-Eigenschaft können Sie das Font-Objekt zurückgeben, das die Zeichenformatierungen für ein bestimmtes Aufzählungszeichen, einen Textbereich oder eine Gliederungsebene darstellt. Das folgende Beispiel legt den Titeltext von Folie 1 und die Eigenschaften für die Schriftart fest.

With ActivePresentation.Slides(1).Shapes.Title _
        .TextFrame.TextRange
    .Text = "Volcano Coffee"
    With .Font
        .Italic = True
        .Name = "Palatino"
        .Color.RGB = RGB(0, 0, 255)
    End With
End With

Zurückgeben eines Font-Objekts aus der Auflistung mit allen Schriftarten einer Präsentation

Mit Fonts(Index) können Sie ein einzelnes Font-Objekt zurückgeben. (Index ist die Indexnummer der Schriftart.) Das folgende Beispiel prüft, ob Schriftart 1 der aktiven Präsentation in die Präsentation eingebettet ist.

If ActivePresentation.Fonts(1).Embedded = _
    True Then MsgBox "Font 1 is embedded"


Fonts-Objekt (Auflistung)

Eine Auflistung aller Font-Objekte in der angegebenen Präsentation. Jedes Font-Objekt stellt eine Schriftart dar, die in der Präsentation verwendet wird.

Anmerkung Mit der Font-Eigenschaft können Sie das Font-Objekt für das Aufzählungszeichen oder den Textbereich zurückgeben, wenn lediglich die Zeichenformatierung für ein bestimmtes Aufzählungszeichen oder einen Textbereich festgelegt werden soll.

Verwendung des Fonts-Objekts

Mit der Fonts-Eigenschaft können Sie die Fonts-Auflistung zurückgeben. Das folgende Beispiel zeigt die Anzahl der Schriftarten an, die in der aktiven Präsentation verwendet werden.

MsgBox ActivePresentation.Fonts.Count

Mit Fonts(Index) können Sie ein einzelnes Font-Objekt zurückgeben. Das folgende Beispiel prüft, ob Schriftart 1 der aktiven Präsentation in die Präsentation eingebettet ist. (Index ist der Name oder die Indexnummer für die Schriftart.)

If ActivePresentation.Fonts(1).Embedded = True Then
    MsgBox "Font 1 is embedded"


FreeformBuilder-Objekt

Stellt die Geometrie einer Freihandform während des Aufbaus dar.

Verwendung des FreeformBuilder-Objekts

Mit der BuildFreeform-Methode können Sie ein FreeformBuilder-Objekt zurückgeben. Mit der AddNodes-Methode können Sie der Freihandform Knoten hinzufügen. Mit der ConvertToShape-Methode können Sie die Form erstellen, die im FreeformBuilder-Objekt definiert ist, und der Shapes-Auflistung hinzufügen. Das folgende Beispiel fügt zu myDocument eine Freihandform mit vier Abschnitten hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


GroupShapes-Objekt (Auflistung)

Stellt die individuellen Formen innerhalb einer gruppierten Form dar. Jede Form wird durch ein Shape-Objekt dargestellt. Mit der Item-Methode können Sie bei diesem Objekt mit einzelnen Formen innerhalb einer Gruppe arbeiten, ohne die Gruppierung aufheben zu müssen.

Verwendung der Groupshapes-Auflistung

Mit der GroupItems-Eigenschaft können Sie die GroupShapes-Auflistung zurückgeben. Mit GroupItems(Index) können Sie eine einzelne Form aus der GroupShapes-Auflistung zurückgeben. (Index ist die individuelle Form innerhalb der gruppierten Form.) Das folgende Beispiel fügt zu myDocument drei Dreiecke hinzu, gruppiert diese, legt eine Farbe für die gesamte Gruppe fest und ändert anschließend die Farbe für das zweite Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, 10, _
        10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, 150, _
        10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, 300, _
        10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


HeaderFooter-Objekt

Stellt eine Kopfzeile, Fußzeile, Datum und Uhrzeit, Foliennummer oder Seitenzahl von einer Folie oder einem Master dar. Alle HeaderFooter-Objekte sind für eine Folie oder einen Master in einem HeadersFooters-Objekt enthalten.

Verwendung des HeaderFooter-Objekts

Mit den Eigenschaften, die in der folgenden Tabelle aufgelistet sind, können Sie das HeaderFooter-Objekt zurückgeben.

Mit dieser Eigenschaft | Geben Sie dieses Objekt zurück
DateAndTime | Ein HeaderFooter-Objekt, das das Datum und die Uhrzeit von der Folie darstellt.
Footer | Ein HeaderFooter-Objekt, das die Fußzeile für die Folie darstellt.
Header | Ein HeaderFooter-Objekt, das die Kopfzeile für die Folie darstellt. Dies funktioniert nur bei Notizenseiten und Handzetteln, jedoch nicht bei Folien.
SlideNumber | Ein HeaderFooter-Objekt, das die Foliennummer (von einer Folie) oder die Seitenzahl (von einer Notizenseite oder einem Handzettel) darstellt.

Anmerkung HeaderFooter-Objekte sind nicht für Slide-Objekte verfügbar, die Notizenseiten darstellen. Das HeaderFooter-Objekt, das eine Kopfzeile darstellt, ist nur für einen Notizenmaster oder Handzettelmaster verfügbar.

Sie können die Eigenschaften von HeaderFooter-Objekten für einzelne Folien festlegen. Das folgende Beispiel legt den Text der Fußzeile für Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1).HeadersFooters.Footer _
    .Text = "Volcano Coffee"

Sie können auch die Eigenschaften von HeaderFooter-Objekten für den Folienmaster, Titelmaster, Notizenmaster oder Handzettelmaster festlegen, damit sich diese gleichzeitig auf alle Folien, Titelfolien, Notizenseiten oder Handzettel und Gliederungen auswirken. Das folgende Beispiel legt den Text für die Fußzeile im Folienmaster der aktiven Präsentation und das Format für Datum und Uhrzeit fest und aktiviert die Anzeige der Foliennummern. Diese Einstellungen werden allen Folien zugewiesen, die auf diesem Master basieren sowie Mastergrafiken anzeigen und denen außerdem noch keine individuellen Einstellungen für die Fußzeile sowie das Datum und die Uhrzeit zugewiesen wurden.

Set mySlidesHF = ActivePresentation.SlideMaster.HeadersFooters
With mySlidesHF
    .Footer.Visible = True
    .Footer.Text = "Regional Sales"
    .SlideNumber.Visible = True
    .DateAndTime.Visible = True
    .DateAndTime.UseFormat = True
    .DateAndTime.Format = ppDateTimeMdyy
End With

Lassen Sie den folgenden Code ablaufen, bevor Sie das vorherige Beispiel starten, um die Informationen für die Kopfzeile und Fußzeile zu löschen, die für individuelle Folien festgelegt wurden. Außerdem können Sie sich dadurch vergewissern, dass alle Folien die Informationen für die Kopfzeile und Fußzeile anzeigen, die Sie für den Folienmaster definiert haben.

For Each s In ActivePresentation.Slides
    s.DisplayMasterShapes = True
    s.HeadersFooters.Clear
Next


HeadersFooters-Objekt

Enthält alle HeaderFooter-Objekte in der angegebenen Folie, der Notizenseite, dem Handzettel oder dem Master. Jedes HeaderFooter-Objekt stellt eine Kopfzeile, Fußzeile, Datum und Uhrzeit oder eine Foliennummer dar.

Anmerkung HeaderFooter-Objekte sind nicht für Slide-Objekte verfügbar, die Notizenseiten darstellen. Das HeaderFooter-Objekt, das eine Kopfzeile darstellt, ist nur für einen Notizenmaster oder Handzettelmaster verfügbar.

Verwendung des HeaderFooters-Objekts

Mit der HeadersFooters-Eigenschaft können Sie das HeadersFooters-Objekt zurückgeben. Mit der DateAndTime-, Footer-, Header- oder SlideNumber-Eigenschaft können Sie ein individuelles HeaderFooter-Objekt zurückgeben. Das folgende Beispiel legt den Text der Fußzeile für Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1).HeadersFooters.Footer _
    .Text = "Volcano Coffee"


Hyperlink-Objekt

Stellt einen Hyperlink dar, der einer Form, die kein Platzhalter ist, oder Text zugewiesen wurde. Sie können einen Hyperlink verwenden, der innerhalb der aktiven Präsentation zu einer Internet- oder Intranetsite bzw. zu einer anderen Datei oder zu einer Folie springt. Das Hyperlink-Objekt ist ein Element der Hyperlinks-Auflistung. Die Hyperlinks-Auflistung enthält alle Hyperlinks einer Folie oder eines Masters.

Verwendung des Hyperlink-Objekts

Mit der Hyperlink-Eigenschaft können Sie einen Hyperlink für eine Form zurückgeben. Einer Form können zwei verschiedene Hyperlinks zugewiesen werden: Ein Hyperlink, wenn der Benutzer auf die Form während einer Bildschirmpräsentation klickt, und ein weiterer, wenn der Benutzer den Mauszeiger auf die Form während einer Bildschirmpräsentation richtet. Damit der Hyperlink während einer Bildschirmpräsentation aktiv ist, muss für die Action-Eigenschaft ppActionHyperlink festgelegt sein. Das folgende Beispiel legt als Mausklickaktion für Form 3 von Folie 1 in der aktiven Präsentation eine Internetverknüpfung fest.

With ActivePresentation.Slides(1).Shapes(3) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    .Hyperlink.Address = "http://www.microsoft.com"
End With

Eine Folie kann mehrere Hyperlinks enthalten. Jede Form ohne Platzhalterfunktion kann einen Hyperlink haben, der Text innerhalb einer Form kann seinen eigenen Hyperlink haben, und auch jedes einzelne Zeichen kann seinen eigenen Hyperlink haben. Mit Hyperlinks(Index) können Sie ein einzelnes Hyperlink-Objekt zurückgeben. (Index ist die Hyperlink-Nummer.) Das folgende Beispiel fügt dem Favoritenordner den Mausklickhyperlink für Form 3 hinzu.

ActivePresentation.Slides(1).Shapes(3) _
    .ActionSettings(ppMouseClick).Hyperlink.AddToFavorites

Anmerkung Wenn Sie diese Methode verwenden, um dem Favoritenordner von Microsoft Internet Explorer einen Hyperlink hinzuzufügen, wird im Menü Favoriten ein Symbol ohne einen entsprechenden Namen angezeigt. Fügen Sie den Namen aus Internet Explorer heraus hinzu.


Hyperlinks-Objekt (Auflistung)

Eine Auflistung aller Hyperlink-Objekte in einer Folie oder einem Master.

Verwendung der Hyperlinks-Auflistung

Mit der Hyperlinks-Eigenschaft können Sie die Hyperlinks-Auflistung zurückgeben. Das folgende Beispiel aktualisiert alle Hyperlinks von Folie 1 in der aktiven Präsentation, die die angegebene Adresse enthalten.

For Each hl In ActivePresentation.Slides(1).Hyperlinks
    If hl.Address = "c:\current work\sales.ppt" Then
        hl.Address = "c:\new\newsales.ppt"
    End If
Next

Mit der Hyperlink-Eigenschaft können Sie einen Hyperlink erstellen und der Hyperlinks-Auflistung hinzufügen. Das folgende Beispiel legt einen Hyperlink fest, zu dem gesprungen wird, wenn der Benutzer auf Form 3 von Folie 1 in der aktiven Präsentation während einer Bildschirmpräsentation klickt, und fügt den neuen Hyperlink der Auflistung hinzu. Wenn für Form 3 bereits ein Mausklickhyperlink definiert ist, löscht das folgende Beispiel diesen Hyperlink aus der Auflistung, wenn ein neuer Hyperlink hinzugefügt wird, so dass sich die Anzahl der Elemente in der Hyperlinks-Auflistung nicht ändert.

With ActivePresentation.Slides(1).Shapes(3) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    .Hyperlink.Address = "http://www.microsoft.com"
End With


LineFormat-Objekt

Stellt die Formatierung für Linien und Pfeilspitzen dar. Bei Linien enthält das LineFormat-Objekt Formatierungsinformationen für die Linie. Bei Formen mit einem Rahmen enthält dieses Objekt Formatierungsinformationen für den Rahmen der Form.

Verwendung des LineFormat-Objekts

Mit der Line-Eigenschaft können Sie ein LineFormat-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument eine blaue, gestrichelte Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


LinkFormat-Objekt

Enthält Eigenschaften und Methoden, die verknüpften OLE-Objekten zugewiesen werden. Das OLEFormat-Objekt enthält Eigenschaften und Methoden, die verknüpften und nicht verknüpften OLE-Objekten zugewiesen werden. Das PictureFormat-Objekt enthält Eigenschaften und Methoden, die Grafiken und OLE-Objekten zugewiesen werden.

Verwendung des LinkFormat-Objekts

Mit der LinkFormat-Eigenschaft können Sie ein LinkFormat-Objekt zurückgeben. Das folgende Beispiel durchläuft alle Formen von allen Folien der aktiven Präsentation und legt für alle verknüpften Microsoft Excel-Tabellenblätter fest, dass sie manuell aktualisiert werden.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Excel.Sheet" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


Master-Objekt

Stellt einen Folienmaster, Titelmaster, Handzettelmaster oder Notizenmaster dar.

Verwendung des Master-Objekts

Mit der Master-Eigenschaft des Slide-Objekts oder der SlideRange-Auflistung bzw. der HandoutMaster-, NotesMaster-, SlideMaster- oder TitleMaster-Eigenschaft des Presentation-Objekts können Sie ein Master-Objekt zurückgeben. Das folgende Beispiel legt die Hintergrundfüllung für den Folienmaster der aktiven Präsentation fest.

ActivePresentation.SlideMaster.Background.Fill _
    .PresetGradient msoGradientHorizontal, 1, msoGradientBrass

Mit der AddTitleMaster-Methode können Sie einer Präsentation einen Titelmaster hinzufügen und ein Master-Objekt zurückgeben, das den neuen Titelmaster darstellt. Das folgende Beispiel fügt der aktiven Präsentation einen Titelmaster hinzu und positioniert den Platzhalter für den Titel 10 Punkt von der Oberseite des Masters.

ActivePresentation.AddTitleMaster.Shapes.Title.Top = 10


NamedSlideShow-Objekt

Stellt eine benutzerdefinierte Bildschirmpräsentation dar, bei der es sich um eine benannte Untermenge der Folien in einer Präsentation handelt. Das NamedSlideShow-Objekt ist ein Element der NamedSlideShows-Auflistung. Die NamedSlideShows-Auflistung enthält alle benannten Bildschirmpräsentationen der Präsentation.

Verwendung des NamedSlideShow-Objekts

Mit NamedSlideShows(Index) können Sie ein einzelnes NamedSlideShow-Objekt zurückgeben. (Index ist entweder der Name der benutzerdefinierten Bildschirmpräsentation oder die Indexnummer.) Das folgende Beispiel löscht die benutzerdefinierte Bildschirmpräsentation "Quick Show".

ActivePresentation.SlideShowSettings _
    .NamedSlideShows("Quick Show").Delete

Mit der SlideIDs-Eigenschaft können Sie eine Matrix zurückgeben, die die eindeutigen Folien-IDs für alle Folien der angegebenen benutzerdefinierten Bildschirmpräsentation enthält. Das folgende Beispiel zeigt die Folien-IDs für die Folien der benutzerdefinierten Bildschirmpräsentation "Quick Show" an.

idArray = ActivePresentation.SlideShowSettings _
    .NamedSlideShows("Quick Show").SlideIDs
For i = 1 To UBound(idArray)
    MsgBox idArray(i)
Next


NamedSlideShows-Objekt (Auflistung)

Eine Auflistung aller NamedSlideShow-Objekte der Präsentation. Jedes NamedSlideShow-Objekt stellt eine benutzerdefinierte Bildschirmpräsentation dar.

Verwendung der NamedSlideShows-Auflistung

Mit der NamedSlideShows-Eigenschaft können Sie die NamedSlideShows-Auflistung zurückgeben. Mit NamedSlideShows(Index) können Sie ein einzelnes NamedSlideShow-Objekt zurückgeben. (Index ist entweder der Name der benutzerdefinierten Bildschirmpräsentation oder die Indexnummer.) Das folgende Beispiel löscht die benutzerdefinierte Bildschirmpräsentation "Quick Show".

ActivePresentation.SlideShowSettings _
    .NamedSlideShows("Quick Show").Delete

Mit der Add-Methode können Sie eine neue Bildschirmpräsentation erstellen und der NamedSlideShows-Auflistung hinzufügen. Das folgende Beispiel fügt der aktiven Präsentation die Bildschirmpräsentation "Quick Show" hinzu, die die Folien 2, 7 und 9 enthält. Anschließend wird diese benutzerdefinierte Bildschirmpräsentation gestartet.

Dim qSlides(1 To 3) As Long
With ActivePresentation
    With .Slides
        qSlides(1) = .Item(2).SlideID
        qSlides(2) = .Item(7).SlideID
        qSlides(3) = .Item(9).SlideID
    End With
    With .SlideShowSettings
        .NamedSlideShows.Add "Quick Show", qSlides
        .RangeType = ppShowNamedSlideShow
        .SlideShowName = "Quick Show"
        .Run
    End With
End With


ObjectVerbs-Objekt

Stellt die Auflistung mit OLE-Verben für das angegebene OLE-Objekt dar. Bei OLE-Verben handelt es sich um Operationen, die von einem OLE-Objekt unterstützt werden. Häufig verwendete OLE-Verben sind z. B. "Wiedergeben" und "Bearbeiten".

Verwendung des ObjectVerbs-Objekts

Mit der ObjectVerbs-Eigenschaft können Sie ein ObjectVerbs-Objekt zurückgeben. Das folgende Beispiel zeigt alle verfügbaren Verben für das OLE-Objekt an, das in Form 1 in Folie 2 der aktiven Präsentation enthalten ist. Damit dieses Beispiel funktioniert, muss Form 1 ein OLE-Objekt enthalten.

With ActivePresentation.Slides(2).Shapes(1).OLEFormat
    For Each v In .ObjectVerbs
        MsgBox v
    Next
End With


OLEFormat-Objekt

Enthält Eigenschaften und Methoden, die OLE-Objekten zugewiesen werden. Das LinkFormat-Objekt enthält Eigenschaften und Methoden, die nur verknüpften OLE-Objekten zugewiesen werden. Das PictureFormat-Objekt enthält Eigenschaften und Methoden, die Grafiken und OLE-Objekten zugewiesen werden.

Verwendung des OLEFormat-Objekts

Mit der OLEFormat-Eigenschaft können Sie ein OLEFormat-Objekt zurückgeben. Das folgende Beispiel durchläuft alle Formen auf allen Folien der aktiven Präsentation und legt für alle verknüpften Microsoft Excel-Tabellenblätter fest, dass sie manuell aktualisiert werden.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Excel.Sheet" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


PageSetup-Objekt

Enthält Informationen über die Seiteneinrichtung bei Folien, Notizenseiten, Handzetteln und Gliederungen in einer Präsentation.

Verwendung des PageSetup-Objekts

Mit der PageSetup-Eigenschaft können Sie das PageSetup-Objekt zurückgeben. Das folgende Beispiel legt fest, dass alle Folien in der aktiven Präsentation 11 Zoll breit und 8,5 Zoll hoch sind. Außerdem wird festgelegt, dass die Foliennummerierung für die Präsentation bei Nummer 17 beginnt.

With ActivePresentation.PageSetup
    .SlideWidth = 11 * 72
    .SlideHeight = 8.5 * 72
    .FirstSlideNumber = 17
End With


 Pane-Objekt

Pane-Objekt

Ein Objekt, das einen der drei Fensterausschnitte in der Normalansicht darstellt oder den einzelnen Fensterausschnitt einer der anderen Ansichten im Dokumentfenster.

Verwendung des Pane-Objekts

Mit Panes(Index) können Sie ein einzelnes Pane-Objekt zurückgeben, wobei Index die Indexnummer für einen Fensterausschnitt ist. In der folgenden Tabelle sind die Namen der Fensterausschnitte in der Normalansicht mit ihren entsprechenden Indexnummern aufgelistet.

Fensterausschnitt | Indexnummer
Gliederung | 1
Folie | 2
Notizen | 3

Wenn Sie nicht in der Normalansicht, sondern in einer anderen Dokumentfensteransicht arbeiten, können Sie mit Pane(1) auf das einzelne Pane-Objekt verweisen.

Mit der Activate-Methode können Sie den angegebenen Fensterausschnitt aktivieren.

Mit der ViewType-Eigenschaft können Sie bestimmen, welcher Fensterausschnitt aktiv ist. Im folgenden Beispiel wird mit der ViewType-Eigenschaft festgelegt, ob der Folienausschnitt der aktive Fensterausschnitt ist. In diesem Fall legt die Activate-Methode den Notizenausschnitt als aktiven Fensterausschnitt fest.

With ActiveWindow
    If .ActivePane.ViewType = ppViewSlide Then
        .Panes(3).Activate
    End If
End With

Hinweise

Die Normalansicht ist die einzige Ansicht, die mehrere Fensterausschnitte besitzt. Alle anderen Dokumentfensteransichten haben als einzigen Fensterausschnitt das Dokumentfenster.


Panes-Objekt (Auflistung)

Eine Auflistung von Pane-Objekten, die die Folien-, Gliederungs- und Notizausschnitte im Dokumentfenster der Normalansicht oder den einzelnen Fensterausschnitt in jeder anderen Ansicht des Dokumentfensters darstellt.

Verwendung der Panes-Auflistung

Mit der Panes-Eigenschaft geben Sie die Panes-Auflistung zurück. Im folgenden Beispiel wird die Anzahl der Ausschnitte im aktiven Fenster überprüft. Wenn der Wert eins beträgt, wodurch eine andere Ansicht als die Normalansicht bezeichnet wird, wird die Normalansicht aktiviert, und der vertikale Trennbalken wird so eingestellt, dass das Dokumentfenster zu 15% für den Gliederungsausschnitt und zu 85% für den Folienausschnitt aufgeteilt wird.

With ActiveWindow
    If .Panes.Count = 1 Then
        .ViewType = ppViewNormal
        .SplitHorizontal = 15
    End If
End With

Hinweise

In der Normalansicht enthält die Panes-Auflistung drei Elemente. Alle anderen Dokumentfenster haben lediglich einen Fensterausschnitt, so dass die Panes-Auflistung aus einem Element besteht.


ParagraphFormat-Objekt

Stellt die Absatzformatierung für einen Textbereich dar.

Verwendung des ParagraphFormat-Objekts

Mit der ParagraphFormat-Eigenschaft können Sie das ParagraphFormat-Objekt zurückgeben. Das folgende Beispiel richtet die Absätze in Form 2 von Folie 1 der aktiven Präsentation links aus.

ActivePresentation.Slides(1).Shapes(2).TextFrame.TextRange _
    .ParagraphFormat.Alignment = ppAlignLeft


PictureFormat-Objekt

Enthält Eigenschaften und Methoden, die Grafiken und OLE-Objekten zugewiesen werden. Das LinkFormat-Objekt enthält Eigenschaften und Methoden, die nur verknüpften OLE-Objekten zugewiesen werden. Das OLEFormat-Objekt enthält Eigenschaften und Methoden, die verknüpften oder nicht verknüpften OLE-Objekten zugewiesen werden.

Verwendung des PictureFormat-Objekts

Mit der PictureFormat-Eigenschaft können Sie ein PictureFormat-Objekt zurückgeben. Das folgende Beispiel legt die Helligkeit, den Kontrast und die Farbtransformation für Form 1 in myDocument fest und schneidet 18 Punkt von der Unterseite der Form zu. Damit dieses Beispiel funktioniert, muss Form 1 entweder eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = 0.7
    .ColorType = msoPictureGrayScale
    .CropBottom = 18
End With


PlaceholderFormat-Objekt

Enthält Eigenschaften, die nur Platzhaltern zugewiesen werden, z. B. einen Platzhaltertyp.

Verwendung des PlaceholderFormat-Objekts

Mit der PlaceholderFormat-Eigenschaft können Sie ein PlaceholderFormat-Objekt zurückgeben. Das folgende Beispiel fügt Text zu Platzhalter 1 von Folie 1 in der aktiven Präsentation hinzu, vorausgesetzt der Platzhalter ist vorhanden und ein horizontaler Titelplatzhalter.

With ActivePresentation.Slides(1).Shapes.Placeholders
    If .Count > 0 Then
        With .Item(1)
            Select Case .PlaceholderFormat.Type
                Case ppPlaceholderTitle
                    .TextFrame.TextRange = "Title Text"
                Case ppPlaceholderCenterTitle
                    .TextFrame.TextRange = "Centered Title Text"
                Case Else
                    MsgBox "There's no horizontal " _
                        "title on this slide"
            End Select
        End With
    End If
End With


 Placeholders-Objekt (Auflistung)

Placeholders-Objekt (Auflistung)

Eine Auflistung aller Shape-Objekte, die auf der angegebenen Folie Platzhalter darstellen. Jedes Shape-Objekt in der Placeholders-Auflistung stellt einen Platzhalter für Text, ein Diagramm, eine Tabelle, ein Organisationsdiagramm oder eine andere Art von Objekt dar. Wenn die Folie einen Titel hat, ist der Titel der erste Platzhalter in der Auflistung.

Verwendung der Placeholders-Auflistung

Mit der Placeholders-Eigenschaft können Sie die Placeholders-Auflistung zurückgeben. Sie können mit Placeholders(Index) ein Shape-Objekt zurückgeben, das einen einzelnen Platzhalter darstellt. Dabei ist Index die Indexnummer des Platzhalters. Beachten Sie, dass für jede Folie mit einem Titel Shapes.Title gleichbedeutend ist mit Shapes.Placeholders(1). Im folgenden Beispiel werden dem Anfang einer Präsentation eine neue Folie mit einem Aufzählungslayout hinzugefügt, der Text für den Titel festgelegt und dann dem Textplatzhalter zwei Absätze hinzugefügt.

Set sObj = ActivePresentation.Slides.Add(1, ppLayoutText).Shapes
sObj.Title.TextFrame.TextRange.Text = "This is the title text"
sObj.Placeholders(2).TextFrame.TextRange.Text = _
    "Item 1" & Chr(13) & "Item 2"

Sie können die einzelnen Platzhalter mit der Delete-Methode löschen, und Sie können gelöschte Platzhalter mit der AddPlaceholder-Methode wiederherstellen, Sie können einer Folie jedoch nicht mehr Platzhalter hinzufügen, als bei ihrer Erstellung ursprünglich vorhanden waren. Um die Anzahl der Platzhalter auf einer bestimmten Folie zu ändern, setzen Sie die Layout-Eigenschaft.


PlaySettings-Objekt

Enthält Informationen über die Wiedergabe des angegebenen Medienclips während einer Bildschirmpräsentation.

Verwendung des PlaySettings-Objekts

Mit der PlaySettings-Eigenschaft können Sie das PlaySettings-Objekt zurückgeben. Das folgende Beispiel fügt den Film "Clock.avi" in Folie 1 in der aktiven Präsentation hinzu. Danach wird festgelegt, dass der Film nach der vorherigen Animation oder einem Folienübergang automatisch wiedergegeben wird, und es wird angegeben, dass die Bildschirmpräsentation während der Wiedergabe des Films fortfährt. Außerdem wird angegeben, dass das Filmobjekt während einer Bildschirmpräsentation ausgeblendet ist, wenn es nicht wiedergegeben wird.

Set clockMovie = ActivePresentation.Slides(1).Shapes _
    .AddMediaObject(FileName:="C:\WINNT\clock.avi", _
    Left:=20, Top:=20)
With clockMovie.AnimationSettings.PlaySettings
    .PlayOnEntry = True
    .PauseAnimation = False
    .HideWhileNotPlaying = True
End With


Presentation-Objekt

Stellt eine PowerPoint-Präsentation dar. Das Presentation-Objekt ist ein Element der Presentations-Auflistung. Die Presentations-Auflistung enthält alle Presentation-Objekte, die in PowerPoint geöffnete Präsentationen darstellen.

Verwendung des Presentation-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben einer Präsentation, die Sie durch den Namen oder die Indexnummer angeben

  • Zurückgeben der Präsentation im aktiven Fenster

  • Zurückgeben der Präsentation in einem beliebigen Dokumentfenster oder in einem angegebenen Bildschirmpräsentationsfenster

Zurückgeben einer Präsentation, die Sie durch den Namen oder die Indexnummer angeben

Mit Presentations(Index) können Sie ein einzelnes Presentation-Objekt zurückgeben. (Index ist der Name oder die Indexnummer der Präsentation.) Der Name der Präsentation ist der Dateiname mit oder ohne Dateinamenerweiterung und ohne Pfadangabe. Das folgende Beispiel fügt dem Anfang von "Sample Presentation" eine Folie hinzu.

Presentations("Sample Presentation").Slides.Add 1, 1

Wenn mehrere Präsentationen mit dem gleichen Namen geöffnet sind, wird die erste Präsentation der Auflistung zurückgegeben, die den angegebenen Namen hat.

Zurückgeben der Präsentation im aktiven Fenster

Mit der ActivePresentation-Eigenschaft können Sie die Präsentation im aktiven Fenster zurückgeben. Das folgende Beispiel speichert die aktive Präsentation.

ActivePresentation.Save

Wenn eine eingebettete Präsentation vor Ort aktiviert ist, gibt die ActivePresentation-Eigenschaft die eingebettete Präsentation zurück.

Zurückgeben der Präsentation in einem beliebigen Dokumentfenster oder in einem angegebenen Bildschirmpräsentationsfenster

Mit der Presentation-Eigenschaft können Sie die Präsentation zurückgeben, die sich im angegebenen Dokumentfenster oder im Bildschirmpräsentationsfenster befindet. Das folgende Beispiel zeigt den Namen der Bildschirmpräsentation an, die im Bildschirmpräsentationsfenster 1 abläuft.

MsgBox SlideShowWindows(1).Presentation.Name


Presentations-Objekt (Auflistung)

Eine Auflistung mit allen Presentation-Objekten in PowerPoint. Jedes Presentation-Objekt stellt eine Präsentation dar, die in PowerPoint aktuell geöffnet ist.

Verwendung der Presentations-Auflistung

Mit der Presentations-Eigenschaft können Sie die Presentations-Auflistung zurückgeben. Mit der Add-Methode können Sie eine neue Präsentation erstellen und sie der Auflistung hinzufügen. Das folgende Beispiel erstellt eine neue Präsentation, fügt der Präsentation eine Folie hinzu und speichert anschließend die Präsentation.

Set newPres = Presentations.Add(True)
newPres.Slides.Add 1, 1
newPres.SaveAs "Sample"

Mit Presentations(Index) können Sie ein einzelnes Presentation-Objekt zurückgeben. (Index ist der Name oder die Indexnummer der Präsentation.) Das folgende Beispiel druckt Präsentation 1.

Presentations(1).PrintOut

Mit der Open-Methode können Sie eine Präsentation öffnen und der Presentations-Auflistung hinzufügen. Das folgende Beispiel öffnet die Datei sales.ppt als schreibgeschützte Präsentation.

Presentations.Open FileName:="sales.ppt", ReadOnly:=True

Hinweise

Die Presentations-Auflistung enthält keine geöffneten Add-Ins, bei denen es sich um einen besonderen Typ einer ausgeblendeten Präsentation handelt. Sie können jedoch ein einzelnes geöffnetes Add-In zurückgeben, wenn Sie den Dateinamen kennen. So gibt z. B. Presentations("oscar.ppa") das geöffnete Add-In Oscar.ppa als ein Presentation-Objekt zurück. Es ist jedoch besser, die AddIns-Auflistung für die Rückgabe geöffneter Add-Ins zu verwenden.


PrintOptions-Objekt

Enthält Druckoptionen für eine Präsentation.

Anmerkung Wenn Sie für die PrintOut-Methode die optionalen Argumente From, To, Copies und Collate angeben, werden die entsprechenden Eigenschaften des PrintOptions-Objekts festgelegt.

Verwendung des PrintOptions-Objekts

Mit der PrintOptions-Eigenschaft können Sie das PrintOptions-Objekt zurückgeben. Das folgende Beispiel druckt zwei unsortierte Farbkopien aller Folien (sichtbar und ausgeblendet) in der aktiven Präsentation. Das Beispiel skaliert außerdem jede Folie so, dass sie der Druckseite angepasst ist, und umrahmt jede Folie mit einem dünnen Rahmen.

With ActivePresentation
    With .PrintOptions
        .NumberOfCopies = 2
        .Collate = False
        .PrintColorType = ppPrintColor
        .PrintHiddenSlides = True
        .FitToPage = True
        .FrameSlides = True
        .OutputType = ppPrintOutputSlides
    End With
    .PrintOut
End With

Mit der RangeType-Eigenschaft können Sie angeben, ob die gesamte Präsentation oder lediglich ein angegebener Teil gedruckt werden soll. Wenn Sie lediglich bestimmte Folien drucken möchten, legen Sie für die RangeType-Eigenschaft ppPrintSlideRange fest und verwenden die Ranges-Eigenschaft, um anzugeben, welche Seiten gedruckt werden sollen. Das folgende Beispiel druckt die Folien 1, 4, 5 und 6 in der aktiven Präsentation

With ActivePresentation
    With .PrintOptions
        .RangeType = ppPrintSlideRange
        With .Ranges
            .Add 1, 1
            .Add 4, 6
        End With
    End With
    .PrintOut
End With


PrintRange-Objekt

Stellt einen einzelnen Bereich mit aufeinander folgenden Folien oder Seiten dar, die gedruckt werden sollen. Das PrintRange-Objekt ist ein Element der PrintRanges-Auflistung. Die PrintRanges-Auflistung enthält alle Druckbereiche, die für die angegebene Präsentation definiert wurden.

Verwendung des PrintRange-Objekts

Mit Ranges(Index) können Sie ein einzelnes PrintRange-Objekt zurückgeben. (Index ist die Indexnummer des Druckbereichs.) Das folgende Beispiel zeigt eine Meldung an, die die Anfangs- und Endnummern der Folien für Druckbereich 1 in der aktiven Präsentation angibt.

With ActivePresentation.PrintOptions.Ranges
    If .Count > 0 Then
        With .Item(1)
            MsgBox "Print range 1 starts on slide " & .Start & _
                " and ends on slide " & .End
        End With
    End If
End With

Mit der Add-Methode können Sie ein PrintRange-Objekt erstellen und der PrintRanges-Auflistung hinzufügen. Das folgende Beispiel definiert drei Druckbereiche, die die Folie 1, die Folien 3 bis 5 und die Folien 8 und 9 in der aktiven Präsentation darstellen. Anschließend werden die Folien in diesen Bereichen gedruckt.

With ActivePresentation.PrintOptions
    .RangeType = ppPrintSlideRange
    With .Ranges
        .ClearAll
        .Add 1, 1
        .Add 3, 5
        .Add 8, 9
    End With
End With
ActivePresentation.PrintOut

Hinweise

Sie können Druckbereiche in der PrintRanges-Auflistung unabhängig von der Einstellung des RangeType festlegen. Diese Bereiche werden so lange beibehalten, bis die Präsentation nicht mehr geladen ist. Die Bereiche in der PrintRanges-Auflistung werden zugewiesen, wenn für die RangeType-Eigenschaft ppPrintSlideRange festgelegt ist.


PrintRanges-Objekt (Auflistung)

Eine Auflistung aller PrintRange-Objekte in der angegebenen Präsentation. Jedes PrintRange-Objekt stellt einen Bereich mit aufeinander folgenden Folien oder Seiten dar, die gedruckt werden sollen.

Verwendung der PrintRanges-Auflistung

Mit der Ranges-Eigenschaft können Sie die PrintRanges-Auflistung zurückgeben. Das folgende Beispiel löscht alle zuvor definierten Druckbereiche aus der Auflistung der aktiven Präsentation.

ActivePresentation.PrintOptions.Ranges.ClearAll

Mit der Add-Methode können Sie ein PrintRange-Objekt erstellen und der PrintRanges-Auflistung hinzufügen. Das folgende Beispiel definiert drei Druckbereiche, die die Folie 1, die Folien 3 bis 5 und die Folien 8 und 9 der aktiven Präsentation darstellen. Anschließend werden die Folien in diesen Bereichen gedruckt.

With ActivePresentation.PrintOptions
    .RangeType = ppPrintSlideRange
    With .Ranges
        .ClearAll
        .Add 1, 1
        .Add 3, 5
        .Add 8, 9
    End With
End With
ActivePresentation.PrintOut

Mit Ranges(Index) können Sie ein einzelnes PrintRange-Objekt zurückgeben. (Index ist die Indexnummer des Platzhalters.) Das folgende Beispiel zeigt eine Meldung an, die die Anfangs- und Endnummern der Folien für Druckbereich 1 in der aktiven Präsentation angibt.

With ActivePresentation.PrintOptions.Ranges
    If .Count > 0 Then
        With .Item(1)
            MsgBox "Print range 1 starts on slide " & .Start & _
                " and ends on slide " & .End
        End With
    End If
End With


PublishObject-Objekt

Stellt eine vollständig oder teilweise geladene Präsentation dar, die im HTML-Format veröffentlicht werden kann. Das PublishObject-Objekt ist ein Element der PublishObjects-Auflistung.

Verwendung des PublishObject-Objekts

Mit PublishObjects(Index) können Sie ein einzelnes Objekt für eine geladene Präsentation zurückgeben, wobei Index immer "1" ist. Für jede geladene Präsentation kann es nur ein PublishObject-Objekt geben. In diesem Beispiel werden die Folien 3-5 der Präsentation 2 im HTML-Format veröffentlicht. Die veröffentlichte Präsentation wird Mallard.htm genannt.

With Presentations(2).PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With

Hinweise

Sie können den Inhalt und die Attribute der veröffentlichten Präsentation festlegen, indem Sie die verschiedenen Eigenschaften des PublishObject-Objekts festsetzen. Zum Beispiel definiert die SourceType-Eigenschaft den Teil der geladenen Präsentation, der veröffentlicht werden soll. Die RangeStart-Eigenschaft und die RangeEnd-Eigenschaft legen den zu veröffentlichenden Folienbereich fest, und die SpeakerNotes-Eigenschaft bestimmt, ob die Sprechernotizen veröffentlicht werden.


PublishObjects-Objekt (Auflistung)

Eine Auflistung von PublishObject-Objekten, die eine Menge vollständig oder teilweise geladener Präsentationen darstellen, die im HTML-Format veröffentlicht werden können.

Verwendung der PublishObjects-Auflistung

Mit der PublishObjects-Eigenschaft können Sie die PublishObjects-Auflistung zurückgeben. In diesem Beispiel werden die Folien 3-5 der aktiven Präsentation im HTML-Format veröffentlicht. Die veröffentlichte Präsentation wird Mallard.htm genannt.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With

Mit Item(Index) können Sie ein einzelnes PublishObject-Objekt für eine geladene Präsentation zurückgeben, wobei Index immer "1" ist. Für jede geladene Präsentation kann es nur ein PublishObject-Objekt geben.

In diesem Beispiel wird als PublishObject-Objekt die gesamte aktive Präsentation definiert, indem die SourceType-Eigenschaft auf ppPublishAll gesetzt wird.

ActivePresentation.PublishObjects.Item(1).SourceType = ppPublishAll

Hinweise

Sie können den Inhalt und die Attribute der veröffentlichten Präsentation festlegen, indem Sie die verschiedenen Eigenschaften des PublishObject-Objekts einstellen. Zum Beispiel definiert die SourceType-Eigenschaft den Teil der geladenen Präsentation, der veröffentlicht werden soll. Die RangeStart-Eigenschaft und die RangeEnd-Eigenschaft legen den zu veröffentlichenden Folienbereich fest, und die SpeakerNotes-Eigenschaft bestimmt, ob die Sprechernotizen veröffentlicht werden.

Sie können der PublishObjects-Auflistung nichts hinzufügen.


RGBColor-Objekt

Stellt eine einzelne Farbe in einer Farbskala dar.

Verwendung des RGBColor-Objekts

Mit der Colors-Methode können Sie ein RGBColor-Objekt zurückgeben. Sie können ein RGBColor-Objekt als anderes RGBColor-Objekt festlegen. Sie können auch mit der RGB-Eigenschaft den ausdrücklichen Rot-Grün-Blau-Wert (RGB) für ein RGBColor-Objekt festlegen oder zurückgeben. Ausgenommen davon sind die RGBColor-Objekte, die durch die ppNotSchemeColor-Konstante und die ppSchemeColorMixed-Konstante definiert sind. Für diese beiden Objekte kann die RGB-Eigenschaft zurückgegeben, aber nicht eingestellt werden. Das folgende Beispiel legt als Hintergrundfarbe in Farbskala 1 die Farbe Rot und die Titelfarbe fest, die für Farbskala 2 definiert wurde.

With ActivePresentation.ColorSchemes
    .Item(1).Colors(ppBackground).RGB = RGB(255, 0, 0)
    .Item(1).Colors(ppTitle) = .Item(2).Colors(ppTitle)
End With


Row-Objekt

Stellt eine Zeile in einer Tabelle dar. Das Row-Objekt ist ein Element der Rows-Auflistung. Die Rows-Auflistung enthält alle Zeilen in der angegebenen Tabelle.

Verwendung des Row-Objekts

Mit Rows(Index) können Sie ein einzelnes Row-Objekt zurückgeben, wobei Index eine Nummer ist, welche die Position der Zeile in der Tabelle repräsentiert. In diesem Beispiel wird die erste Zeile aus der Tabelle in Form 5 auf Folie 2 der aktiven Präsentation gelöscht.

ActivePresentation.Slides(2).Shapes(5).Table.Rows(1).Delete

Mit der Select-Methode können Sie eine Zeile in einer Tabelle markieren. In diesem Beispiel wird Zeile 1 der angegebenen Tabelle markiert.

ActivePresentation.Slides(2).Shapes(5).Table.Rows(1).Select

Hinweise

Mit der Cells-Eigenschaft können Sie einzelne Zellen in einem Row-Objekt ändern. In diesem Beispiel wird die zweite Zeile der Tabelle markiert und ihrem unteren Rahmen das Format einer gestrichelten Linie zugewiesen.

ActiveWindow.Selection.ShapeRange.Table.Rows(2) _
    .Cells.Borders(ppBorderBottom).DashStyle = msoLineDash


Rows-Objekt (Auflistung)

Eine Auflistung von Row-Objekten, die die Zeilen einer Tabelle darstellen.

Verwendung der Rows-Auflistung

Mit der Rows-Eigenschaft können Sie die Rows-Auflistung zurückgeben. In diesem Beispiel wird die Höhe aller Zeilen in der angegebenen Tabelle auf 160 Punkt geändert.

Dim i As Integer
With ActivePresentation.Slides(2).Shapes(4).Table
    For i = 1 To .Rows.Count
        .Rows.Height = 160
    Next i
End With

Mit der Add-Methode können Sie einer Tabelle eine Zeile hinzufügen. In diesem Beispiel wird in die Bezugstabelle vor der zweiten Zeile eine Zeile eingefügt.

ActivePresentation.Slides(2).Shapes(5).Table.Rows.Add (2)

Mit Rows(Index) können Sie ein einzelnes Row-Objekt zurückgeben, wobei Index eine Nummer ist, die die Position der Zeile in der Tabelle darstellt. In diesem Beispiel wird die erste Zeile der Tabelle in Form 5 auf Folie 2 gelöscht.

ActivePresentation.Slides(2).Shapes(5).Table.Rows(1).Delete


Ruler-Objekt

Stellt das Lineal für den Text in der angegebenen Form oder für den gesamten Text im angegebenen Textformat dar. Enthält Tabstopps und die Einstellungen für die Einzüge der Gliederungsebenen für Text.

Verwendung des Ruler-Objekts

Mit der Ruler-Eigenschaft des TextFrame-Objekts können Sie das Ruler-Objekt zurückgeben, das das Lineal für den Text in der angegebenen Form darstellt. Mit der TabStops-Eigenschaft können Sie das TabStops-Objekt zurückgeben, das die Tabstopps des Lineals darstellt. Mit der Levels-Eigenschaft können Sie das RulerLevels-Objekt zurückgeben, das die Einstellungen für die Einzüge der Gliederungsebenen für Text enthält. Das folgende Beispiel legt einen links ausgerichteten Tabstopp bei 144 Punkt und einen hängenden Einzug für den Text in Objekt 2 von Folie 1 in der aktiven Präsentation fest.

With ActivePresentation.Slides(1).Shapes(2).TextFrame.Ruler
    .TabStops.Add ppTabStopLeft, 144
    .Levels(1).FirstMargin = 0
    .Levels(1).LeftMargin = 36
End With

Mit der Ruler-Eigenschaft des TextStyle-Objekts können Sie das Ruler-Objekt zurückgeben, das das Lineal für eine der vier definierten Textformate darstellt (Titeltext, Textkörper, Notizentext oder Standardtext). Das folgende Beispiel legt den Erstzeileneinzug und hängenden Einzug für Gliederungsebene 1 des Textkörpers beim Folienmaster der aktiven Präsentation fest.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).Ruler.Levels(1)
    .FirstMargin = 9
    .LeftMargin = 54
End With


RulerLevel-Objekt

Enthält Informationen über Erstzeileneinzug und hängenden Einzug bei einer Gliederungsebene. Das RulerLevel-Objekt ist ein Element der RulerLevels-Auflistung. Die RulerLevels-Auflistung enthält ein RulerLevel-Objekt für jede der fünf verfügbaren Gliederungsebenen.

Verwendung des RulerLevel-Objekts

Mit RulerLevels(Index) können Sie ein einzelnes RulerLevel-Objekt zurückgeben. (Index ist die Gliederungsebene.) Das folgende Beispiel legt den Erstzeileneinzug und hängenden Einzug für Gliederungsebene 1 beim Textkörper des Folienmasters der aktiven Präsentation fest.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).Ruler.Levels(1)
    .FirstMargin = 9
    .LeftMargin = 54
End With

Das folgende Beispiel legt den Erstzeileneinzug und hängenden Einzug für Gliederungsebene 1 in Form 2 von Folie 1 der aktiven Präsentation fest.

With ActivePresentation.SlideMaster.Shapes(2) _
        .TextFrame.Ruler.Levels(1)
    .FirstMargin = 9
    .LeftMargin = 54
End With


RulerLevels-Objekt (Auflistung)

Eine Auflistung aller RulerLevel-Objekte im angegebenen Lineal. Jedes RulerLevel-Objekt stellt den Erstzeileneinzug und den linken Einzug für Text bei einer bestimmten Gliederungsebene dar. Diese Auflistung enthält immer fünf Elemente (jeweils eines für die verfügbaren Gliederungsebenen).

Verwendung der RulerLevels-Auflistung

Mit der Levels-Eigenschaft können Sie die RulerLevels-Auflistung zurückgeben. Das folgende Beispiel legt die Ränder für die fünf Gliederungsebenen beim Textkörper in der aktiven Präsentation fest.

With ActivePresentation.SlideMaster.TextStyles(ppBodyStyle).Ruler
    .Levels(1).FirstMargin = 0
    .Levels(1).LeftMargin = 40
    .Levels(2).FirstMargin = 60
    .Levels(2).LeftMargin = 100
    .Levels(3).FirstMargin = 120
    .Levels(3).LeftMargin = 160
    .Levels(4).FirstMargin = 180
    .Levels(4).LeftMargin = 220
    .Levels(5).FirstMargin = 240
    .Levels(5).LeftMargin = 280
End With


Selection-Objekt

Stellt die Markierung im angegebenen Dokumentfenster dar.

Verwendung des Selection-Objekts

Mit der Selection-Eigenschaft können Sie das Selection-Objekt zurückgeben. Das folgende Beispiel setzt eine Kopie der Markierung im aktiven Fenster in die Zwischenablage.

ActiveWindow.Selection.Copy

Mit der ShapeRange-, SlideRange- oder TextRange-Eigenschaft können Sie einen Bereich von Formen, Folien oder Text aus der Markierung zurückgeben.

Das folgende Beispiel legt die Vordergrundfarbe der Füllung für die markierten Formen in Fenster 2 fest. Es wird davon ausgegangen, dass mindestens eine Form markiert ist. Außerdem wird davon ausgegangen, dass alle markierten Formen die gleiche Füllung haben, deren Vordergrundfarbe festgelegt werden kann.

With Windows(2).Selection.ShapeRange.Fill
    .Visible = True
    .ForeColor.RGB = RGB(255, 0, 255)
End With

Das folgende Beispiel legt den Text in der ersten markierten Form in Fenster 2 fest, wenn die Form einen Textrahmen enthält.

With Windows(2).Selection.ShapeRange(1)
    If .HasTextFrame Then
        .TextFrame.TextRange = "Current Choice"
    End If
End With

Das folgende Beispiel schneidet den markierten Text im aktiven Fenster aus und kopiert ihn in die Zwischenablage.

ActiveWindow.Selection.TextRange.Cut

Das folgende Beispiel dupliziert alle Folien in der Markierung. Wenn Sie sich in der Folienansicht befinden, wird die aktuelle Folie dupliziert.

ActiveWindow.Selection.SlideRange.Duplicate

Haben Sie kein Objekt des entsprechenden Typs markiert, wenn Sie eine dieser Eigenschaften verwenden, wird ein Fehler erzeugt. Dies ist z. B. der Fall, wenn Sie die ShapeRange-Eigenschaft verwenden, ohne dass Formen markiert sind. Mit der Type-Eigenschaft können Sie bestimmen, welche Objektarten markiert sind. Das folgende Beispiel prüft, ob die Markierung Folien enthält. Ist dies der Fall, wird der Hintergrund für die erste Folie in der Markierung festgelegt.

With Windows(2).Selection
    If .Type = ppSelectionSlides Then
        With .SlideRange(1)
            .FollowMasterBackground = False
            .Background.Fill.PresetGradient _
                msoGradientHorizontal, 1, msoGradientLateSunset
        End With
    End If
End With

Hinweise

Das Selection-Objekt wird gelöscht, wenn Sie die Folien in einer aktiven Folienansicht ändern. (Die Type-Eigenschaft gibt dann ppSelectionNone zurück.)


ShadowFormat-Objekt

Stellt die Schattenformate für eine Form dar.

Verwendung des ShadowFormat-Objekts

Mit der Shadow-Eigenschaft können Sie ein ShadowFormat-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument ein schattiertes Rechteck hinzu. Der semitransparente, blaue Schatten wird um 5 Punkt nach rechts und um 3 Punkt darüber positioniert.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        50, 50, 100, 200).Shadow
    .ForeColor.RGB = RGB(0, 0, 128)
    .OffsetX = 5
    .OffsetY = -3
    .Transparency = 0.5
    .Visible = True
End With


 Shape-Objekt

Shape-Objekt

Stellt ein Objekt in der Zeichnungsebene, z. B. eine AutoForm, Freihandform, ein OLE-Objekt oder eine Grafik dar. Das Shape-Objekt ist ein Element der Shapes-Auflistung. Die Shapes-Auflistung enthält alle Formen einer Folie.

Anmerkung Es gibt drei Objekte, die Formen darstellen: Die Shapes-Auflistung, die alle Formen eines Dokuments darstellt. Die ShapeRange-Auflistung, die eine angegebene Untermenge der Formen eines Dokuments darstellt (so kann z. B. ein ShapeRange-Objekt Form 1 und 4 oder auch alle markierten Formen in einem Dokument darstellen). Das Shape-Objekt, das eine einzelne Form in einem Dokument darstellt. Wenn Sie mit mehreren Formen gleichzeitig oder mit Formen innerhalb der Markierung arbeiten möchten, verwenden Sie eine ShapeRange-Auflistung. Weitere Informationen darüber, wie Sie mit einer einzelnen Form oder mit jeweils mehreren Formen arbeiten können, finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwendung des Shape-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben einer vorhandenen Form auf einer Folie, die durch den Namen oder eine Nummer indiziert ist.

  • Zurückgeben einer neu erstellten Form auf einer Folie.

  • Zurückgeben einer Form innerhalb der Markierung.

  • Zurückgeben des Folientitels und anderer Platzhalter auf einer Folie.

  • Zurückgeben der Formen, die mit den Enden einer Verbindung zusammengefügt sind.

  • Zurückgeben der Standardform für eine Präsentation.

  • Zurückgeben einer neu erstellten Freihandform.

  • Zurückgeben einer einzelnen Form innerhalb einer Gruppe.

  • Zurückgeben einer neu gebildeten Gruppe mit Formen.

Zurückgeben einer vorhandenen Form auf einer Folie

Mit Shapes(Index) können Sie ein einzelnes Shape-Objekt zurückgeben, das eine Form einer Folie darstellt. (Index ist der Name einer Folie.) Das folgende Beispiel kippt Form 1 und die Form "Rectangle 1" von myDocument horizontal.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).Flip msoFlipHorizontal
myDocument.Shapes("Rectangle 1").Flip msoFlipHorizontal

Jeder Form wird ein Standardname zugewiesen, wenn Sie die Form der Shapes-Auflistung hinzufügen. Mit der Name-Eigenschaft können Sie die Form umbenennen. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu, benennt es "Red Square" und legt anschließend die Vordergrundfarbe und die Linienart fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 144, 144, 72, 72)
    .Name = "Red Square"
    .Fill.ForeColor.RGB = RGB(255, 0, 0)
    .Line.DashStyle = msoLineDashDot
End With

Zurückgeben einer neu erstellten Form auf einer Folie

Um einer Folie eine Form hinzuzufügen und ein Shape-Objekt zurückzugeben, das die neu erstellte Form darstellt, verwenden Sie eine der folgenden Methoden der Shapes-Auflistung: AddCallout, AddComment, AddConnector, AddCurve, AddLabel, AddLine, AddMediaObject, AddOLEObject, AddPicture, AddPlaceholder, AddPolyline, AddShape, AddTable, AddTextbox, AddTextEffect, AddTitle.

Zurückgeben einer Form innerhalb der Markierung

Mit Selection.ShapeRange(Index) können Sie ein Shape-Objekt zurückgeben, das eine Form innerhalb einer Markierung darstellt. (Index ist der Name der Form oder die Indexnummer.) Das folgende Beispiel legt die Füllung für die erste Form der Markierung im aktiven Fenster fest. Es wird davon ausgegangen, dass die Markierung mindestens eine Form enthält.

ActiveWindow.Selection.ShapeRange(1).Fill _
    .ForeColor.RGB = RGB(255, 0, 0)

Zurückgeben des Folientitels und anderer Platzhalter auf einer Folie

Mit Shapes.Title können Sie ein Shape-Objekt zurückgeben, das einen vorhandenen Folientitel darstellt. Mit Shapes.AddTitle können Sie einer Folie, die noch keinen Titel hat, einen Titel hinzufügen und ein Shape-Objekt zurückgeben, das den neu erstellten Titel darstellt. Mit Shapes.Placeholders(Index) können Sie ein Shape-Objekt zurückgeben, das einen Platzhalter darstellt. (Index ist die Indexnummer des Platzhalters.) Wenn Sie die Anordnung der Ebenen der Formen einer Folie noch nicht geändert haben, haben die folgenden drei Anweisungen die gleiche Bedeutung. Es wird davon ausgegangen, dass Folie 1 einen Titel hat.

ActivePresentation.Slides(1).Shapes.Title _
    .TextFrame.TextRange.Font.Italic = True
ActivePresentation.Slides(1).Shapes.Placeholders(1) _
    .TextFrame.TextRange.Font.Italic = True
ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange.Font.Italic = True

Zurückgeben der Formen, die mit den Enden einer Verbindung zusammengefügt sind

Mit der BeginConnectedShape oder EndConnectedShape-Eigenschaft können Sie ein Shape-Objekt zurückgeben, das eine der Formen darstellt, die von einer Verbindung zusammengefügt sind.

Zurückgeben der Standardform für eine Präsentation

Mit der DefaultShape-Eigenschaft können Sie ein Shape-Objekt zurückgeben, das die Standardform für eine Präsentation darstellt.

Zurückgeben einer neu erstellten Freihandform

Mit den Methoden BuildFreeform und AddNodes können Sie die Geometrie einer neuen Freihandform definieren. Mit der ConvertToShape-Methode können Sie die Freihandform erstellen und das Shape-Objekt zurückgeben, das diese darstellt.

Zurückgeben einer einzelnen Form innerhalb der Gruppe

Mit GroupItems(Index) können Sie ein Shape-Objekt zurückgeben, das eine einzelne Form in einer gruppierten Form darstellt. (Index ist der Name der Form oder die Indexnummer innerhalb der Gruppe.)

Zurückgeben einer neu gebildeten Gruppe mit Formen

Mit der Group- oder Regroup-Methode können Sie einen Formbereich gruppieren und ein einzelnes Shape-Objekt zurückgeben, das die neu gebildete Gruppe darstellt. Nachdem eine Gruppe gebildet wurde, können Sie diese wie eine beliebige Form bearbeiten.


Shapes-Objekt (Auflistung)

Eine Auflistung aller Shape-Objekte der angegebenen Folie. Jedes Shape-Objekt stellt ein Objekt in der Zeichnungsebene dar, z. B. eine AutoForm, Freihandform, ein OLE-Objekt oder eine Grafik.

Anmerkung Möchten Sie mit einer Untermenge der Formen eines Dokuments arbeiten (z. B. Aktionen ausschließlich bei den AutoFormen oder markierten Formen des Dokuments vornehmen), müssen Sie eine ShapeRange-Auflistung erstellen, die die gewünschten Formen enthält. Weitere Informationen darüber, wie Sie mit einer einzelnen Form oder mit jeweils mehreren Formen arbeiten können, finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwendung der Shapes-Auflistung

Mit der Shapes-Eigenschaft können Sie die Shapes-Auflistung zurückgeben. Das folgende Beispiel markiert alle Formen von myDocument.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.SelectAll

Anmerkung Möchten Sie eine Aktion bei allen Formen eines Dokuments gleichzeitig vornehmen (z. B. eine Eigenschaft löschen oder festlegen), verwenden Sie die Range-Methode ohne Argument, um ein ShapeRange-Objekt zu erstellen, das alle Formen der Shapes-Auflistung enthält. Weisen Sie anschließend dem ShapeRange-Objekt die geeignete Eigenschaft oder Methode zu.

Mit der AddCallout-, AddComment-, AddConnector-, AddCurve-, AddLabel-, AddLine-, AddMediaObject-, AddOLEObject-, AddPicture-, AddPlaceholder-, AddPolyline-, AddShape-, AddTable-, AddTextbox-, AddTextEffect-oder AddTitle-Methode können Sie eine neue Form erstellen und der Shapes-Auflistung hinzufügen. Mit der BuildFreeform-Methode können Sie in Verbindung mit der ConvertToShape-Methode eine neue Freihandform erstellen und der Auflistung hinzufügen. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200

Mit Shapes(Index) können Sie ein einzelnes Shape-Objekt zurückgeben. (Index ist der Name oder die Indexnummer der Form.) Das folgende Beispiel legt für Form 1 in myDocument als Füllung eine vordefinierte Schattierung fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).Fill _
    .PresetGradient msoGradientHorizontal, 1, msoGradientBrass

Mit Shapes.Range(Index) können Sie eine ShapeRange-Auflistung zurückgeben, die eine Untermenge der Shapes-Auflistung darstellt. (Index ist der Name oder die Indexnummer der Form oder eine Matrix mit Namen der Formen oder Indexnummern.) Das folgende Beispiel legt das Füllmuster für Form 1 und 3 von myDocument fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Range(Array(1, 3)).Fill _
    .Patterned msoPatternHorizontalBrick

Mit Shapes.Placeholders(Index) können Sie ein Shape-Objekt zurückgeben, das einen Platzhalter darstellt. (Index ist die Nummer des Platzhalters.) Wenn die angegebene Folie einen Titel hat, können Sie mit Shapes.Placeholders(1) oder Shapes.Title den Platzhalter des Titels zurückgeben. Das folgende Beispiel fügt der aktiven Präsentation eine Folie hinzu und fügt anschließend Text zum Titel und Untertitel hinzu (der Untertitel ist der zweite Platzhalter einer Folie mit diesem Layout).

Set myDocument = ActivePresentation.Slides(1)
With ActivePresentation.Slides.Add(1, ppLayoutTitle).Shapes
    .Title.TextFrame.TextRange = "This is the title text"
    .Placeholders(2).TextFrame.TextRange = "This is subtitle text"
End With


ShapeNode-Objekt

Stellt die Geometrie und die Eigenschaften für die Bearbeitung der Geometrie der Knoten in einer benutzerdefinierten Freihandform dar. Knoten beziehen die Scheitelpunkte zwischen den Abschnitten der Freihandform und den Kontrollpunkten für gekrümmte Abschnitte mit ein. Das ShapeNode-Objekt ist ein Element der ShapeNodes-Auflistung. Die ShapeNodes-Auflistung enthält alle Knoten in einer Freihandform.

Verwendung des ShapeNode-Objekts

Mit Nodes(Index) können Sie ein einzelnes ShapeNode-Objekt zurückgeben, wobei Index die Indexnummer des Knotens ist. Wenn es sich bei Knoten 1 in Form 3 von myDocument um eine Ecke handelt, wandelt das folgende Beispiel den Knoten in einen glatten Punkt um. Damit dieses Beispiel funktioniert, muss Form 3 eine Freihandform sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeNodes-Objekt (Auflistung)

Eine Auflistung aller ShapeNode-Objekte in der angegebenen Freihandform. Jedes ShapeNode-Objekt stellt entweder einen Knoten zwischen Abschnitten in einer Freihandform oder einen Kontrollpunkt für einen gekrümmten Abschnitt einer Freihandform dar. Sie können eine Freihandform manuell oder mit der BuildFreeform- und der ConvertToShape-Methode erstellen.

Verwendung der ShapeNodes-Auflistung

Mit der Nodes-Eigenschaft können Sie die ShapeNodes-Auflistung zurückgeben. Das folgende Beispiel löscht Knoten 4 in Form 3 von myDocument. Damit dieses Beispiel funktioniert, muss Form 3 eine Freihandform mit mindestens vier Knoten sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).Nodes.Delete 4

Mit der Insert-Methode können Sie einen neuen Knoten erstellen und der ShapeNodes-Auflistung hinzufügen. Das folgende Beispiel fügt nach Knoten 4 in Form 3 von myDocument einen glatten Knoten mit einem gekrümmten Abschnitt hinzu. Damit dieses Beispiel funktioniert, muss Form 3 eine Freihandform mit mindestens vier Knoten sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With

Mit Nodes(Index) können Sie ein einzelnes ShapeNode-Objekt zurückgeben. (Index ist die Indexnummer des Knotens.) Wenn es sich bei Knoten 1 in Form 3 von myDocument um eine Ecke handelt, wandelt das folgende Beispiel die Ecke in einen glatten Punkt um. Damit dieses Beispiel funktioniert, muss Form 3 eine Freihandform sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeRange-Objekt (Auflistung)

Stellt einen Formbereich dar, der ein Formensatz eines Dokuments ist. Der Formbereich kann zwischen einer einzelnen Form und sämtlichen Formen des Dokuments liegen. Sie können beliebige Formen einbeziehen (Sie haben die Auswahl zwischen allen Formen des Dokuments oder allen Formen der Markierung), um einen Formbereich zu erstellen. So können Sie z. B. eine ShapeRange-Auflistung erstellen, die die ersten drei Formen, alle markierten Formen oder alle Freihandformen in einem Dokument enthält.

Weitere Informationen darüber, wie Sie mit einer einzelnen Form oder mit jeweils mehreren Formen arbeiten können, finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwendung der ShapeRange-Auflistung

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben eines Formensatzes, den Sie mit dem Namen oder der Indexnummer angeben.

  • Zurückgeben von allen oder von bestimmten markierten Formen in einem Dokument.

Zurückgeben eines Formensatzes, den Sie mit dem Namen oder der Indexnummer angeben

Mit Shapes.Range(Index) können Sie eine ShapeRange-Auflistung zurückgeben, die einen Satz mit Formen in einem Dokument darstellt. (Index ist der Name oder die Indexnummer der Form oder der Matrix, die entweder Namen oder Indexnummern von Formen enthält.) Mit der Array-Funktion können Sie eine Matrix mit Namen oder Indexnummern erstellen. Das folgende Beispiel legt das Füllmuster für Form 1 und 3 von myDocument fest

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Range(Array(1, 3)).Fill _
    .Patterned msoPatternHorizontalBrick

Das folgende Beispiel legt das Füllmuster für die Formen "Oval 4" und "Rechteck 5" von myDocument fest.

Set myDocument = ActivePresentation.Slides(1)
Set myRange = myDocument.Shapes _
    .Range(Array("Oval 4", "Rectangle 5"))
myRange.Fill.Patterned msoPatternHorizontalBrick

Sie können zwar mit der Range-Methode eine beliebige Anzahl von Formen oder Folien zurückgeben, es ist jedoch einfacher, wenn Sie die Item-Methode verwenden, wenn nur ein einzelnes Element der Auflistung zurückgegeben werden soll. So ist z. B. Shapes(1) einfacher als Shapes.Range(1).

Zurückgeben von allen oder von bestimmten markierten Formen in einem Dokument

Mit der ShapeRange-Eigenschaft des Selection-Objekts können Sie alle Formen in der Markierung zurückgeben. Das folgende Beispiel legt die Vordergrundfarbe der Füllung für alle Formen der Markierung in Fenster 1 fest. Es wird davon ausgegangen, dass mindestens eine Form markiert ist.

Windows(1).Selection.ShapeRange.Fill.ForeColor _
    .RGB = RGB(255, 0, 255)

Mit Selection.ShapeRange(Index) können Sie eine einzelne Form innerhalb der Markierung zurückgeben. (Index ist der Name der Form oder die Indexnummer.) Das folgende Beispiel legt den Vordergrund der Füllung für Form 2 in der Auflistung markierter Formen in Fenster 1 fest. Es wird davon ausgegangen, dass die Markierung mindestens zwei Formen enthält.

Windows(1).Selection.ShapeRange(2).Fill.ForeColor _
    .RGB = RGB(255, 0, 255)


Slide-Objekt

Stellt eine Folie dar. Das Slide-Objekt ist ein Element der Slides-Auflistung. Die Slides-Auflistung enthält alle Slide-Objekte in einer Präsentation.

Anmerkung Beachten Sie, dass bei einem Bezug auf eine einzelne Folie ein SlideRange-Objekt zurückgegeben werden kann. Eine einzelne Folie kann nämlich entweder von einem Slide-Objekt oder einer SlideRange-Auflistung dargestellt werden, die nur eine Folie enthält. Dies hängt davon ab, wie Sie einen Bezug auf die Folie zurückgeben. Wenn Sie z. B. einen Bezug auf eine Folie mit der Add-Methode erstellen und zurückgeben, wird die Folie von einem Slide-Objekt dargestellt. Wenn Sie jedoch einen Bezug auf eine Folie mit der Duplicate-Methode erstellen und zurückgeben, wird die Folie durch eine SlideRange-Auflistung dargestellt, die eine einzelne Folie enthält. Alle Eigenschaften und Methoden, die einem Slide-Objekt zugewiesen wurden, gelten auch für eine SlideRange-Auflistung, die eine einzelne Folie enthält. Deshalb können Sie mit einer zurückgegebenen Folie auf die gleiche Weise arbeiten. Es ist dabei nicht relevant, ob die Folie durch ein Slide-Objekt oder eine SlideRange-Auflistung dargestellt wird.

Verwendung des Slide-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben einer Folie, die durch den Namen, die Indexnummer oder ID-Nummer der Folie angegeben wird

  • Zurückgeben einer Folie in der Markierung

  • Zurückgeben der Folie, die in einem beliebigen Dokumentfenster oder Bildschirmpräsentationsfenster aktuell angezeigt wird

  • Erstellen einer neuen Folie.

Zurückgeben einer Folie, die durch den Namen, die Indexnummer oder ID-Nummer der Folie angegeben wird

Um ein einzelnes Slide-Objekt zurückzugeben, verwenden Sie Slides(Index) (Index ist der Folienname oder die Indexnummer) oder Slides.FindBySlideID(Index) (Index ist die ID-Nummer der Folie). Das folgende Beispiel legt das Layout für Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1).Layout = ppLayoutTitle

Das folgende Beispiel legt das Layout für die Folie mit der ID-Nummer 265 fest.

ActivePresentation.Slides.FindBySlideID(265).Layout = ppLayoutTitle

Zurückgeben einer Folie in der Markierung

Mit Selection.SlideRange(Index) können Sie ein einzelnes Slide-Objekt zurückgeben. (Index ist der Folienname oder die Indexnummer innerhalb der Markierung.) Das folgende Beispiel legt das Layout für Folie 1 in der Markierung im aktiven Fenster fest. Es wird davon ausgegangen, dass mindestens eine Folie markiert ist.

ActiveWindow.Selection.SlideRange(1).Layout = ppLayoutTitle

Wenn nur eine Folie markiert ist, können Sie mit Selection.SlideRange eine SlideRange-Auflistung zurückgeben, die die markierte Folie enthält. Das folgende Beispiel legt das Layout für Folie 1 in der aktuellen Markierung im aktiven Fenster fest. Es wird davon ausgegangen, dass genau eine Folie markiert ist.

ActiveWindow.Selection.SlideRange.Layout = ppLayoutTitle

Zurückgeben der Folie, die in einem beliebigen Dokumentfenster oder Bildschirmpräsentationsfenster aktuell angezeigt wird

Mit der Slide-Eigenschaft können Sie die Folie zurückgeben, die in der angegebenen Ansicht des Dokumentfensters oder des Bildschirmpräsentationsfensters aktuell angezeigt wird. Das folgende Beispiel kopiert die Folie, die im Dokumentfenster 2 aktuell angezeigt wird, in die Zwischenablage.

Windows(2).View.Slide.Copy

Erstellen einer neuen Folie

Mit der Add-Methode können Sie eine neue Folie erstellen und der Präsentation hinzufügen. Das folgende Beispiel fügt dem Anfang der aktiven Präsentation eine Titelfolie hinzu.

ActivePresentation.Slides.Add 1, ppLayoutTitleOnly


Slides-Objekt (Auflistung)

Eine Auflistung aller Slide-Objekte in der angegebenen Präsentation.

Verwendung der Slides-Auflistung

Dieser Abschnitt beschreibt folgende Aktionen:

  • Eine Folie erstellen und der Auflistung hinzufügen

  • Zurückgeben einer einzelnen Folie, die Sie durch den Namen, die Indexnummer oder die ID-Nummer der Folie angeben

  • Zurückgeben einer Untermenge der Folien in der Präsentation

  • Gleichzeitiges Zuweisen einer Eigenschaft oder Methode zu allen Folien in der Präsentation

Eine Folie erstellen und der Auflistung hinzufügen

Mit der Slides-Eigenschaft können Sie eine Slides-Auflistung zurückgeben. Mit der Add-Methode können Sie eine neue Folie erstellen und der Auflistung hinzufügen. Das folgende Beispiel fügt der aktiven Präsentation eine neue Folie hinzu.

ActivePresentation.Slides.Add 2, ppLayoutBlank

Zurückgeben einer einzelnen Folie, die Sie durch den Namen, die Indexnummer oder die ID-Nummer der Folie angeben

Um ein einzelnes Slide-Objekt zurückzugeben, verwenden Sie Slides(Index) (Index ist der Folienname oder die Indexnummer) oder Slides.FindBySlideID(Index) (Index ist die ID-Nummer der Folie.). Das folgende Beispiel legt das Layout für Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1).Layout = ppLayoutTitle

Das folgende Beispiel legt das Layout für die Folie "Big Chart" in der aktiven Präsentation fest. Beachten Sie, dass Folien automatisch generierte Namen des Formulars Folien (n ist eine ganze Zahl) zugewiesen werden, wenn diese erstellt werden. Mit der Name-Eigenschaft können Sie Folien andere Namen zuweisen.

ActivePresentation.Slides("Big Chart").Layout = ppLayoutTitle

Zurückgeben einer Untermenge der Folien in der Präsentation

Mit Slides.Range(Index) können Sie ein SlideRange-Objekt zurückgeben, das eine Untermenge der Slides-Auflistung darstellt. (Index ist die Indexnummer der Folie oder der Name bzw. eine Matrix der Indexnummern der Folie oder eine Matrix der Foliennamen.) Das folgende Beispiel legt die Hintergrundfüllung für die Folien 1 und 3 in der aktiven Präsentation fest.

With ActivePresentation.Slides.Range(Array(1, 3))
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
        1, msoGradientLateSunset
End With

Gleichzeitiges Zuweisen einer Eigenschaft oder Methode zu allen Folien in der Präsentation

Wenn Sie Aktionen an allen Folien Ihrer Präsentation gleichzeitig vornehmen möchten (z. B. das Löschen aller Folien oder das Festlegen einer Eigenschaft für alle Folien), verwenden Sie Slides.Range ohne Argument, um eine SlideRange-Auflistung zu erstellen, die alle Folien in der Slides-Auflistung enthält, und anschließend die geeignete Eigenschaft oder Methode der SlideRange-Auflistung zuzuweisen. Das folgende Beispiel legt die Hintergrundfüllung für alle Folien in der aktiven Präsentation fest.

With ActivePresentation.Slides.Range
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
        1, msoGradientLateSunset
End With


SlideRange-Objekt (Auflistung)

Eine Auflistung, die eine Notizenseite oder einen Folienbereich darstellt, der ein Satz mit Folien ist, der eine einzelne Folie bis zu sämtlichen Folien einer Präsentation enthalten kann. Sie können alle gewünschten Folien einbeziehen (die Sie aus den Folien der Präsentation oder aus den Folien der Markierung auswählen können), um einen Folienbereich zu erstellen. So können Sie z. B. eine SlideRange-Auflistung erstellen, die die ersten drei Folien in einer Präsentation, alle markierten Folien der Präsentation oder alle Titelfolien in der Präsentation enthält.

Verwendung der SlideRange-Auflistung

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben eines Foliensatzes, den Sie durch den Namen oder die Indexnummer angeben

  • Zurückgeben aller oder bestimmter markierter Folien einer Präsentation

  • Zurückgeben einer Notizenseite

  • Zuweisen von Eigenschaften und Methoden zu einem Folienbereich

Zurückgeben eines Foliensatzes, den Sie durch den Namen oder die Indexnummer angeben

Mit Slides.Range(Index) können Sie eine SlideRange-Auflistung zurückgeben, die einen Satz mit Folien in einer Präsentation darstellt. (Index ist der Name oder die Indexnummer der Folie oder der Matrix, die entweder Namen oder Indexnummern von Folien enthält.) Mit der Array-Funktion können Sie eine Matrix mit Namen oder Indexnummern erstellen. Das folgende Beispiel legt die Hintergrundfüllung für die Folien 1 und 3 der aktiven Präsentation fest.

With ActivePresentation.Slides.Range(Array(1, 3))
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
         1, msoGradientLateSunset
End With

Das folgende Beispiel legt die Hintergrundfüllung für die Folien "Intro" und "Big Chart" in der aktiven Präsentation fest. Beachten Sie, dass Folien automatisch generierte Namen des Formulars Folien (n ist eine ganze Zahl) zugewiesen werden, wenn diese erstellt werden. Mit der Name-Eigenschaft können Sie Folien andere Namen zuweisen.

With ActivePresentation.Slides.Range(Array("Intro", "Big Chart"))
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
        1, msoGradientLateSunset
End With

Sie können zwar mit der Range-Methode eine beliebige Anzahl von Formen oder Folien zurückgeben, es ist jedoch einfacher, die Item-Methode zu verwenden, wenn nur ein einzelnes Element der Auflistung zurückgegeben werden soll. So ist z. B. Shapes(1) einfacher als Shapes.Range(1)

Zurückgeben aller oder bestimmter markierter Folien einer Präsentation

Mit der SlideRange-Eigenschaft des Selection-Objekts können Sie alle Folien in der Markierung zurückgeben. Das folgende Beispiel legt die Hintergrundfüllung für alle markierten Folien in Fenster 1 fest. Es wird davon ausgegangen, dass mindestens eine Folie markiert ist.

With Windows(1).Selection.SlideRange
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
        1, msoGradientLateSunset
End With

Mit Selection.SlideRange(Index) können Sie eine einzelne Folie aus der Markierung zurückgeben. (Index ist der Folienname oder die Indexnummer.) Das folgende Beispiel legt die Hintergrundfüllung für Folie 2 in der Auflistung mit markierten Folien in Fenster 1 fest. Es wird davon ausgegangen, dass mindestens zwei Folien markiert sind.

With Windows(1).Selection.SlideRange(2)
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient msoGradientHorizontal, _
        1, msoGradientLateSunset
End With

Zurückgeben einer Notizenseite

Mit der NotesPage-Eigenschaft können Sie eine SlideRange-Auflistung zurückgeben, die die angegebene Notizenseite darstellt. Das folgende Beispiel fügt Text in Platzhalter 2 (dem Notizenbereich) der Notizenseite für Folie 1 in der aktiven Präsentation ein.

ActivePresentation.Slides(1).NotesPage.Shapes _
    .Placeholders(2).TextFrame.TextRange.InsertAfter "Added Text"

Zuweisen einer Eigenschaft oder Methode zu einem Folienbereich

Sie können mit verschiedenen Folien gleichzeitig programmtechnisch arbeiten, indem Sie eine SlideRange-Auflistung erstellen und dieser Eigenschaften oder Methoden zuweisen. Sie können entsprechend mit verschiedenen Folien gleichzeitig in der Benutzeroberfläche arbeiten, indem Sie die Folien markieren und diesen einen Befehl zuweisen. Genau wie bei einigen Befehlen, die in der Benutzeroberfläche zwar bei einzelnen Folien, jedoch nicht bei mehreren markierten Folien gültig sind, erzeugen einige Eigenschaften und Methoden, die bei einem Slide-Objekt oder einer SlideRange-Auflistung arbeiten, die nur eine Folie enthält, einen Fehler, wenn sie einer SlideRange-Auflistung zugewiesen werden, die mehrere Folien enthält. Allgemein gilt, dass Sie nicht manuell vorgehen können, wenn mehrere Folien markiert sind (z. B. das Zurückgeben individueller Formen bei einer der Folien). Sie können auch nicht programmtechnisch vorgehen, indem Sie eine SlideRange-Auflistung verwenden, die mehrere Folien enthält.

Bei Operationen, die in der Benutzeroberfläche ausgeführt werden können, wenn sowohl eine einzelne als auch mehrere Folien markiert sind (z. B. beim Kopieren der Markierung in die Zwischenablage oder beim Festlegen der Hintergrundfüllung der Folie), können die zugewiesenen Eigenschaften und Methoden bei einer SlideRange-Auflistung ausgeführt werden, die mehrere Folien enthält. Es folgen allgemeine Richtlinien für das Verhalten dieser Eigenschaften und Methoden beim Zuweisen zu mehreren Folien.

  • Das Zuweisen einer Methode zu einer SlideRange-Auflistung entspricht dem Zuweisen der Methode zu allen Slide-Objekten des Bereichs als Gruppe.

  • Das Festlegen des Werts einer Eigenschaft der SlideRange-Auflistung entspricht dem individuellen Festlegen des Werts der Eigenschaft in jeder Folie des Bereichs (bei einer Eigenschaft, die einen Aufzählungstyp benötigt, ist dieser "Mischwert" nicht anwendbar).

  • Eine Eigenschaft der SlideRange-Auflistung, die einen Aufzählungstyp zurückgibt, gibt den Wert der Eigenschaft für eine individuelle Folie in der Auflistung zurück, wenn alle Folien der Auflistung den gleichen Wert für diese Eigenschaft besitzen. Haben die Folien in der Auflistung nicht alle den gleichen Wert für die Eigenschaft, gibt diese Eigenschaft den "Mischwert" zurück.

  • Eine Eigenschaft der SlideRange-Auflistung, die einen einfachen Datentyp (z. B. Long, Single oder String) zurückgibt, gibt den Wert der Eigenschaft für eine individuelle Folie in der Auflistung zurück, wenn alle Folien der Auflistung den gleichen Wert für diese Eigenschaft besitzen. Haben die Folien der Auflistung nicht alle den gleichen Wert für diese Eigenschaft, gibt diese Eigenschaft entweder –2 zurück oder generiert einen Fehler. Wenn Sie z. B. die Name-Eigenschaft mit einem SlideRange-Objekt verwenden, das mehrere Folien enthält, wird ein Fehler generiert, weil jede Folie einen anderen Wert für ihre Name-Eigenschaft besitzt.

  • Einige Formateigenschaften von Folien werden nicht von Eigenschaften und Methoden festgelegt, die der SlideRange-Auflistung direkt zugewiesen werden, sondern von Eigenschaften und Methoden, die einem Objekt zugewiesen werden, das in der SlideRange-Auflistung enthalten ist (z. B. das ColorScheme-Objekt). Stellt das enthaltene Objekt Operationen dar, die von mehreren Objekten in der Benutzeroberfläche ausgeführt werden können, dann können Sie das Objekt von einer SlideRange-Auflistung zurückgeben, das mehrere Folien enthält, und deren Eigenschaften und Methoden werden die vorhergehenden Regeln befolgen. So können Sie z. B. die ColorScheme-Eigenschaft verwenden, um das ColorScheme-Objekt zurückzugeben, das die Farbskalen darstellt, die von allen Folien der angegebenen SlideRange-Auflistung verwendet werden. Wenn Sie diese Eigenschaften für dieses ColorScheme-Objekt festlegen, werden auch die Eigenschaften für die ColorScheme-Objekte auf allen individuellen Folien der SlideRange-Auflistung festgelegt.


SlideShowSettings-Objekt

Stellt die Einrichtung der Bildschirmpräsentation für eine Präsentation dar.

Verwendung des SlideShowSettings-Objekts

Mit der SlideShowSettings-Eigenschaft können Sie das SlideShowSettings-Objekt zurückgeben. Der erste Abschnitt im folgenden Beispiel legt für alle Folien in der aktiven Präsentation fest, dass diese automatisch nach fünf Sekunden zur nächsten Folie übergehen. Der zweite Abschnitt legt fest, dass die Bildschirmpräsentation mit Folie 2 beginnt und mit Folie 4 endet und die Folienübergänge entsprechend der Zeiteinstellungen des ersten Abschnitts ausgeführt und so lange fortlaufend durchgeführt werden, bis der Benutzer ESC drückt. Anschließend wird die Bildschirmpräsentation gestartet.

For Each s In ActivePresentation.Slides
    With s.SlideShowTransition
        .AdvanceOnTime = True
        .AdvanceTime = 5
    End With
Next

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowSlideRange
    .StartingSlide = 2
    .EndingSlide = 4
    .AdvanceMode = ppSlideShowUseSlideTimings
    .LoopUntilStopped = True
    .Run
End With


SlideShowTransition-Objekt

Enthält Informationen darüber, wie die angegebene Folie während einer Bildschirmpräsentation zur nächsten Folie übergeht.

Verwendung des SlideShowTransition-Objekts

Mit der SlideShowTransition-Eigenschaft können Sie das SlideShowTransition-Objekt zurückgeben. Das folgende Beispiel gibt für Folie 1 in der aktiven Präsentation den Folienübergangseffekt "von links unten überdecken" an, der vom Klang Bass.wav begleitet wird. Es wird angegeben, dass die Folie automatisch fünf Sekunden nach der vorherigen Animation oder des Folienübergangs zur nächsten Folie übergeht.

With ActivePresentation.Slides(1).SlideShowTransition
    .Speed = ppTransitionSpeedFast
    .EntryEffect = ppEffectStripsDownLeft
    .SoundEffect.ImportFromFile "c:\sndsys\bass.wav"
    .AdvanceOnTime = True
    .AdvanceTime = 5
End With
ActivePresentation.SlideShowSettings.AdvanceMode = _
    ppSlideShowUseSlideTimings


 SlideShowView-Objekt

SlideShowView-Objekt

Stellt die Ansicht in einem Bildschirmpräsentationsfenster dar.

Verwendung des SlideShowView-Objekts

Mit der View-Eigenschaft des SlideShowWindow-Objekts können Sie das SlideShowView-Objekt zurückgeben. Das folgende Beispiel legt fest, dass Bildschirmpräsentationsfenster 1 die erste Folie in der Präsentation anzeigt.

SlideShowWindows(1).View.First

Mit der Run-Methode des SlideShowSettings-Objekts können Sie ein SlideShowWindow-Objekt erstellen. Mit der View-Eigenschaft können Sie anschließend das SlideShowView-Objekt zurückgeben, das in dem Fenster enthalten ist. Das folgende Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, wandelt den Zeiger in einen Stift um und legt als Stiftfarbe für die Bildschirmpräsentation die Farbe Rot fest.

With ActivePresentation.SlideShowSettings.Run.View
    .PointerColor.RGB = RGB(255, 0, 0)
    .PointerType = ppSlideShowPointerPen
End With


SlideShowWindow-Objekt

Stellt ein Fenster dar, in dem eine Bildschirmpräsentation abläuft. Das SlideShowWindow-Objekt ist ein Element der SlideShowWindows-Auflistung. Die SlideShowWindows-Auflistung enthält alle geöffneten Bildschirmpräsentationsfenster.

Verwendung des SlideShowWindow-Objekts

Mit SlideShowWindows(Index) können Sie ein einzelnes SlideShowWindow-Objekt zurückgeben. (Index ist die Indexnummer des Bildschirmpräsentationsfensters.) Das folgende Beispiel aktiviert Bildschirmpräsentationsfenster 2.

SlideShowWindows(2).Activate

Mit der Run-Methode können Sie ein neues Bildschirmpräsentationsfenster erzeugen und einen Bezug zu diesem Bildschirmpräsentationsfenster zurückgeben. Das folgende Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation und reduziert die Höhe des Bildschirmpräsentationsfensters so, dass die Taskleiste (für Bildschirme mit der Auflösung 800 x 600) noch sichtbar ist.

With ActivePresentation.SlideShowSettings
    .ShowType = ppShowTypeSpeaker
    With .Run
        .Height = 300
        .Width = 400
    End With
End With

Mit der View-Eigenschaft können Sie die Ansicht im angegebenen Bildschirmpräsentationsfenster zurückgeben. Das folgende Beispiel legt für die Ansicht im Bildschirmpräsentationsfenster 1 fest, dass Folie 3 in der Präsentation angezeigt wird.

SlideShowWindows(1).View.GotoSlide 3

Mit der Presentation-Eigenschaft können Sie die Präsentation zurückgeben, die im angegebenen Bildschirmpräsentationsfenster aktuell abläuft. Das folgende Beispiel zeigt den Namen der Präsentation an, die im Bildschirmpräsentationsfenster 1 aktuell abläuft.

MsgBox SlideShowWindows(1).Presentation.Name


SlideShowWindows-Objekt (Auflistung)

Eine Auflistung aller SlideShowWindow-Objekte, die die geöffneten Bildschirmpräsentationen in PowerPoint darstellen.

Verwendung der SlideShowWindows-Auflistung

Mit der SlideShowWindows-Eigenschaft können Sie die SlideShowWindows-Auflistung zurückgeben. Mit SlideShowWindows(Index) können Sie ein einzelnes SlideShowWindow-Objekt zurückgeben. (Index ist die Indexnummer des Fensters.) Das folgende Beispiel reduziert die Höhe von Bildschirmpräsentationsfenster 1, wenn sich dieses im Modus Ganzer Bildschirm befindet.

With SlideShowWindows(1)
    If .IsFullScreen Then
        .Height = .Height - 20
    End If
End With

Mit der Run-Methode können Sie ein neues Bildschirmpräsentationsfenster erstellen und zur SlideShowWindows-Auflistung hinzufügen. Das folgende Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation.

ActivePresentation.SlideShowSettings.Run


SoundEffect-Objekt

Stellt den Klangeffekt dar, der eine Animation oder einen Folienübergang in einer Bildschirmpräsentation begleitet.

Verwendung des SoundEffect-Objekts

Mit der SoundEffect-Eigenschaft des AnimationSettings-Objekts können Sie das SoundEffect-Objekt zurückgeben, das den eine Animation begleitenden Klangeffekt darstellt. Das folgende Beispiel gibt an, dass die Animation des Titels von Folie 1 in der aktiven Präsentation vom Klang der Datei Bass.wav begleitet wird.

With ActivePresentation.Slides(1).Shapes(1).AnimationSettings
    .TextLevelEffect = ppAnimateByAllLevels
    .SoundEffect.ImportFromFile "c:\sndsys\bass.wav"
End With

Mit der SoundEffect-Eigenschaft des SlideShowTransition-Objekts können Sie das SoundEffect-Objekt zurückgeben, das den einen Folienübergang begleitenden Klangeffekt darstellt.

Das folgende Beispiel gibt an, dass der Übergang zu Folie 1 in der aktiven Präsentation vom Klang der Datei Bass.wav begleitet wird.

ActivePresentation.Slides(1).SlideShowTransition.SoundEffect _
    .ImportFromFile "c:\sndsys\bass.wav"


Table-Objekt

Stellt eine Tabellenform auf einer Folie dar. Das Table-Objekt ist ein Element der Shapes-Auflistung. Das Table-Objekt enthält die Columns-Auflistung und die Rows-Auflistung.

Verwendung des Table-Objekts

Mit Shapes(Index) können Sie eine Form zurückgeben, die eine Tabelle enthält, wobei Index eine Nummer ist. Verwenden Sie die HasTable-Eigenschaft, um festzustellen, ob eine Form eine Tabelle enthält. In diesem Beispiel werden die Formen auf Folie 1 durchlaufen, und es wird geprüft, ob jede einzelne Form über eine Tabelle verfügt. Dann wird für jede Tabellenform die Mausklickaktion festgelegt, um zur folgenden Folie zu gehen.

With ActivePresentation.Slides(2).Shapes
    For i = 1 To .Count
        If .Item(i).HasTable Then
            .Item(i).ActionSettings(ppMouseClick) _
                .Action = ppActionNextSlide
        End If
    Next
End With

Mit der Cell-Methode des Table-Objekts greifen Sie auf den Inhalt jeder einzelnen Zelle zu. In diesem Beispiel wird der Text "Cell 1" in die erste Zelle der Tabelle in Form 5 auf Folie 3 eingefügt.

ActivePresentation.Slides(3).Shapes(5).Table _
    .Cell(1, 1).Shape.TextFrame.TextRange _
    .Text = "Cell 1"

Verwenden Sie die AddTable-Methode, um einer Folie eine Tabelle hinzuzufügen. In diesem Beispiel wird eine 3 x 3-Tabelle auf Folie 2 in der aktiven Präsentation hinzugefügt.

ActivePresentation.Slides(2).Shapes.AddTable(3, 3)


TabStop-Objekt

Stellt einen einzelnen Tabstopp dar. Das TabStop-Objekt ist ein Element der TabStops-Auflistung. Die TabStops-Auflistung stellt alle Tabstopps in einem Lineal dar.

Verwendung des Tabstop-Objekts

Mit TabStops(Index) können Sie ein einzelnes TabStop-Objekt zurückgeben. (Index ist die Indexnummer des Tabstopps.) Das folgende Beispiel löscht Tabstopp 1 für den Text in Form 2 von Folie 1 der aktiven Präsentation.

ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .Ruler.TabStops(1).Clear


TabStops-Objekt (Auflistung)

Eine Auflistung aller TabStop-Objekte bei einem Lineal.

Verwendung der TabStops-Auflistung

Mit der TabStops-Eigenschaft können Sie die TabStops-Auflistung zurückgeben. Das folgende Beispiel löscht alle Tabstopps für den Text in Form 2 von Folie 1 der aktiven Präsentation.

With ActivePresentation.Slides(1).Shapes(2) _
        .TextFrame.Ruler.TabStops
    For t = .Count To 1 Step -1
        .Item(t).Clear
    Next
End With

Mit der Add-Methode können Sie einen Tabstopp erstellen und der TabStops-Auflistung hinzufügen. Das folgende Beispiel fügt dem Textkörper im Folienmaster der aktiven Präsentation einen Tabstopp hinzu. Der neue Tabstopp wird 144 Punkt von der linken Seite des Lineals positioniert und links ausgerichtet.

ActivePresentation.SlideMaster _
    .TextStyles(ppBodyStyle).Ruler.TabStops.Add ppTabStopLeft, 144


Tags-Objekt

Stellt eine Marke oder eine benutzerdefinierte Eigenschaft dar, die Sie für eine Form, Folie oder Präsentation erstellen können. Jedes Tags-Objekt enthält den Namen einer benutzerdefinierten Eigenschaft sowie einen Wert für diese Eigenschaft.

Erstellen Sie Marken, wenn Sie mit bestimmten Elementen einer Auflistung selektiv arbeiten möchten, die auf einem Attribut basieren, das noch nicht von einer integrierten Eigenschaft dargestellt wird. Wenn Sie z. B. Folien in einer Präsentation kategorisieren möchten, die auf einer Region eines Landes basieren, dem sie zugewiesen sind, können Sie eine Regionsmarke erstellen und jeder Folie in der Präsentation einen Regionswert zuweisen. Sie können dann eine Operation bei einigen dieser Folien selektiv ausführen, die auf den Werten ihrer Regionsmarken basiert (z. B. alle Folien mit dem Regionswert "East" ausblenden).

Verwendung des Tags-Objekts

Mit der Add-Methode können Sie einem Objekt eine Marke hinzufügen. Das folgende Beispiel fügt Folie 1 in der aktiven Präsentation eine Marke mit dem Namen "Region" und dem Wert "East" hinzu.

ActivePresentation.Slides(1).Tags.Add "Region", "East"

Mit Tags(Index) können Sie den Wert der Marke zurückgeben. (Index ist der Name einer Marke.) Das folgende Beispiel prüft den Wert der Marke "Region" bei allen Folien in der aktiven Präsentation und blendet die Folien aus, die sich nicht auf Ostdeutschland beziehen (die durch den Wert "East" gekennzeichnet sind).

For Each s In ActivePresentation.Slides
    If s.Tags("region") <> "east" Then
        s.SlideShowTransition.Hidden = True
    End If
Next


TextEffectFormat-Objekt

Enthält Eigenschaften und Methoden, die WordArt-Objekten zugewiesen sind.

Verwendung des TextEffectFormat-Objekts

Mit der TextEffect-Eigenschaft können Sie ein TextEffectFormat-Objekt zurückgeben. Das folgende Beispiel legt die Schriftart und Formatierung für Form 1 in myDocument fest. Damit dieses Beispiel funktioniert, muss Form 1 ein WordArt-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).TextEffect
    .FontName = "Courier New"
    .FontBold = True
    .FontItalic = True
End With


 TextFrame-Objekt

TextFrame-Objekt

Stellt den Textrahmen in einem Shape-Objekt dar. Enthält den Text im Textrahmen sowie die Eigenschaften und Methoden, die die Ausrichtung und Verankerung des Textrahmens steuern.

Verwendung des TextFrame-Objekts

Mit der TextFrame-Eigenschaft können Sie ein TextFrame-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu, fügt dem Rechteck Text hinzu und legt anschließend die Ränder für den Textrahmen fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 10
    .MarginLeft = 10
    .MarginRight = 10
    .MarginTop = 10
End With

Mit der HasTextFrame-Eigenschaft können Sie bestimmen, ob eine Form einen Textrahmen hat. Mit der HasText-Eigenschaft können Sie bestimmen, ob der Textrahmen Text enthält. Dies wird am folgenden Beispiel erläutert.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.HasTextFrame Then
        With s.TextFrame
            If .HasText Then MsgBox .TextRange.Text
        End With
    End If
Next


TextRange-Objekt

Enthält den Text, der mit einer Form zusammengefügt ist, sowie Eigenschaften und Methoden für die Textmanipulation.

Verwendung des TextRange-Objekts

Dieser Abschnitt beschreibt folgende Aktionen:

  • Zurückgeben eines Textbereichs bei Formen, die Sie angeben.

  • Zurückgeben eines Textbereichs aus der Markierung.

  • Zurückgeben von bestimmten Zeichen, Wörtern, Linien, Sätzen oder Absätzen aus einem Textbereich.

  • Suchen und Ersetzen von Text in einem Textbereich.

  • Einfügen von Text, Datum und Uhrzeit oder der Foliennummer in einen Textbereich.

  • Positionieren der Einfügemarke in einem Textbereich.

Zurückgeben eines Textbereichs bei Formen, die Sie angeben

Mit der TextRange-Eigenschaft des TextFrame-Objekts können Sie ein TextRange-Objekt für eine beliebige angegebene Form zurückgeben. Mit der Text-Eigenschaft können Sie die Zeichenfolge mit Text im TextRange-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument ein Rechteck hinzu und legt den Text fest, der darin enthalten ist.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape(msoShapeRectangle, 0, 0, 250, 140) _
    .TextFrame.TextRange.Text = "Here is some test text"

Da es sich bei der Text-Eigenschaft um die Standardeigenschaft des TextRange-Objekts handelt, sind die folgenden beiden Anweisungen gleichbedeutend.

ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange.Text = "Here is some test text"
ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange = "Here is some test text"

Mit der HasTextFrame-Eigenschaft können Sie bestimmen, ob eine Form einen Textrahmen hat. Mit der HasText-Eigenschaft können Sie bestimmen, ob der Textrahmen Text enthält.

Zurückgeben eines Textbereichs aus der Markierung

Mit der TextRange-Eigenschaft des Selection-Objekts können Sie den aktuell markierten Text zurückgeben. Das folgende Beispiel kopiert die Markierung in die Zwischenablage.

ActiveWindow.Selection.TextRange.Copy

Zurückgeben von bestimmten Zeichen, Wörtern, Linien, Sätzen oder Absätzen aus einem Textbereich

Mit einer der folgenden Methoden können Sie einen Teil des Textes eines TextRange-Objekts zurückgeben: Characters, Lines, Paragraphs, Runs, Sentences oder Words.

Suchen und Ersetzen von Text in einem Textbereich

Mit der Find- und der Replace-Methode können Sie Text in einem Textbereich suchen und ersetzen.

Einfügen von Text, Datum und Uhrzeit oder der Foliennummer in einen Textbereich

Mit einer der folgenden Methoden können Sie Zeichen in ein TextRange-Objekt einfügen: InsertAfter, InsertBefore, InsertDateTime, InsertSlideNumber oder InsertSymbol.


TextStyle-Objekt

Stellt eines von drei Textformaten dar: Titeltext, Textkörper oder Standardtext. Jedes Textformat enthält ein TextFrame-Objekt, das beschreibt, wie Text innerhalb des Textbegrenzungsrechtecks positioniert wird, ein Ruler-Objekt, das Tabstopps und Formatierungsinformationen über die Gliederungseinzüge enthält, sowie eine TextStyleLevels-Auflistung, die Formatierungsinformationen über den Gliederungstext enthält. Das TextStyle-Objekt ist ein Element der TextStyles-Auflistung.

Verwendung des TextStyle-Objekts

Mit TextStyles(Index) können Sie ein einzelnes TextStyle-Objekt zurückgeben. (Index ist entweder ppBodyStyle, ppDefaultStyle oder ppTitleStyle.) Das folgende Beispiel legt die Schriftart und den Schriftgrad für Textkörper der ersten Ebene auf allen Folien in der aktiven Präsentation fest.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).Levels(1)
    With .Font
        .Name = "Arial"
        .Size = 36
    End With
End With


TextStyles-Objekt (Auflistung)

Eine Auflistung der drei Textformate [image] Titeltext, Textkörper und Standardtext [image]. Jedes Format wird durch ein TextStyle-Objekt dargestellt. Jedes Textformat enthält ein TextFrame-Objekt, das beschreibt, wie der Text innerhalb des Text-Begrenzungsrechtecks positioniert wird, ein Ruler-Objekt, das Tabstopps und Formatierungsinformationen über die Gliederungseinzüge enthält, sowie eine TextStyleLevels-Auflistung, die Formatierungsinformationen über den Gliederungstext enthält.

Verwendung der TextStyles-Auflistung

Mit TextStyles(Index) können Sie ein einzelnes TextStyle-Objekt zurückgeben (Index ist entweder ppBodyStyle, ppDefaultStyle oder ppTitleStyle). Dieses Beispiel legt die Ränder für den Notizenbereich von allen Notizenseiten der aktiven Präsentation fest.

With ActivePresentation.NotesMaster _
        .TextStyles(ppBodyStyle).TextFrame
    .MarginBottom = 50
    .MarginLeft = 50
    .MarginRight = 50
    .MarginTop = 50
End With


TextStyleLevel-Objekt

Enthält Informationen über die Zeichen- und Absatzformatierung einer Gliederungsebene. Das TextStyleLevel-Objekt ist ein Element der TextStyleLevels-Auflistung. Die TextStyleLevels-Auflistung enthält ein TextStyleLevel-Objekt für jede der fünf Gliederungsebenen.

Verwendung des TextStyleLevel-Objekts

Mit Levels(Index) können Sie ein einzelnes TextStyleLevel-Objekt zurückgeben. (Index ist eine Nummer von 1 bis 5, die der Gliederungsebene entspricht.) Das folgende Beispiel legt die Schriftart und den Schriftgrad, den Abstand vor Absätzen und die Absatzausrichtung für Textkörper der ersten Ebene in allen Folien der aktiven Präsentation fest.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).Levels(1)
    With .Font
        .Name = "Arial"
        .Size = 36
    End With
    With .ParagraphFormat
        .LineRuleBefore = False
        .SpaceBefore = 14
        .Alignment = ppAlignJustify
    End With
End With


TextStyleLevels-Objekt (Auflistung)

Eine Auflistung aller Textebenen einer Gliederung. Diese Auflistung enthält immer fünf Elemente. Jedes Element wird durch ein TextStyleLevel-Objekt dargestellt.

Verwendung der TextStyleLevels-Auflistung

Mit Levels(Index) können Sie ein einzelnes TextStyleLevel-Objekt zurückgeben. (Index ist eine Nummer von 1 bis 5, die der Gliederungsebene entspricht.) Das folgende Beispiel legt die Schriftart und den Schriftgrad für Textkörper der ersten Ebene von allen Folien der aktiven Präsentation fest.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).Levels(1)
    With .Font
        .Name = "Arial"
        .Size = 36
    End With
End With

Das folgende Beispiel legt den Schriftgrad für den Text bei jeder Gliederungsebene für den Notizenbereich von allen Notizenseiten in der aktiven Präsentation fest.

With ActivePresentation.NotesMaster.TextStyles(ppBodyStyle).Levels
    .Item(1).Font.Size = 34
    .Item(2).Font.Size = 30
    .Item(3).Font.Size = 25
    .Item(4).Font.Size = 20
    .Item(5).Font.Size = 15
End With


ThreeDFormat-Objekt

Stellt die dreidimensionale Formatierung einer Form dar.

Verwendung des ThreeDFormat-Objekts

Mit der ThreeD-Eigenschaft können Sie ein ThreeDFormat-Objekt zurückgeben. Das folgende Beispiel fügt zu myDocument ein Oval hinzu und gibt anschließend an, dass das Oval mit einer Tiefe von 50 Punkt projiziert ist und dass die Projektion die Farbe Purpur hat.

Set myDocument = ActivePresentation.Slides(1)
Set myShape = myDocument.Shapes _
    .AddShape(msoShapeOval, 90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    'RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With

Hinweise

Sie können für bestimmte Formen keine dreidimensionale Formatierung anwenden, z. B. für Facetten oder mehrfach unterbrochene Strecken. Bei diesen Formen schlagen die meisten Eigenschaften und Methoden des ThreeDFormat-Objekts fehl.


 View-Objekt

View-Objekt

Stellt die aktuelle Ansicht für die Bearbeitung im angegebenen Dokumentfenster dar.

Verwendung des View-Objekts

Mit der View-Eigenschaft des DocumentWindow-Objekts können Sie das View-Objekt zurückgeben. Das folgende Beispiel legt die Größe von Fenster 1 fest und legt anschließend den Zoom so fest, dass dieser an die neue Fenstergröße angepasst ist.

With Windows(1)
    .Height = 200
    .Width = 250
    .View.ZoomToFit = True
End With

Anmerkung Das View-Objekt kann eine beliebige Ansicht für das Dokumentfenster darstellen: Normalansicht, Folienansicht, Gliederungsansicht, Foliensortieransicht, Notizblattansicht, Folienmasteransicht, Handzettelmasteransicht oder Notizenmasteransicht. Bestimmte Eigenschaften und Methoden des View-Objekts funktionieren nur in bestimmten Ansichten. Wenn Sie eine Eigenschaft oder Methode verwenden, die für das View-Objekt nicht geeignet ist, wird ein Fehler erzeugt.


WebOptions-Objekt

Enthält Attribute auf Präsentationsebene, die von Microsoft PowerPoint verwendet werden, wenn Sie eine vollständige Präsentation oder Teile einer Präsentation als Webseite speichern oder veröffentlichen oder wenn Sie eine Webseite öffnen. Sie können Attribute entweder auf der Anwendungsebene (der globalen Ebene) oder auf der Präsentationsebene zurückgeben oder einstellen. (Beachten Sie, dass sich Attributwerte von Präsentation zu Präsentation voneinander unterscheiden können, in Abhängigkeit vom Attributwert zum Zeitpunkt, zu dem die Präsentation gespeichert wurde.) Attributeinstellungen auf Präsentationsebene überschreiben Attributeinstellungen auf Anwendungsebene. Attribute auf Anwendungsebene sind im DefaultWebOptions-Objekt enthalten.

Verwendung des WebOptions-Objekts

Verwenden Sie die WebOptions-Eigenschaft, um das WebOptions-Objekt zurückzugeben. Im folgenden Beispiel wird überprüft, ob Portable Network Graphics (PNG) als Grafikformat für Präsentation 1 zulässig ist. Wenn PNG zulässig ist, wird die Textfarbe für den Gliederungsausschnitt auf Weiß und die Hintergrundfarbe für den Gliederungs- und Folienausschnitt auf Schwarz gesetzt.

Set objAppWebOptions = Presentations(1).WebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        .FrameColors = ppFrameColorsWhiteTextOnBlack
    End If
End With


Neue Eigenschaften (nach Objekt)

In der folgenden, nach Objekten sortierten Tabelle finden Sie eine Aufstellung der in Microsoft PowerPoint 2000 zu vorhandenen Objekten hinzugefügten Eigenschaften:

Objekt | Neue Eigenschaften
ActionSettings | ShowandReturn
Application | AnswerWizard, COMAddIns, DefaultWebOptions, FeatureInstall, LanguageSettings, ProductCode
Borders | Application, Parent
BulletFormat | Number, StartValue, Style, Type
DocumentWindow | ActivePane, Panes, ShowWindowsInTaskbar, SplitHorizontal, SplitVertical
Font | NameComplexScript
Hyperlink | EmailSubject, ScreenTip, ShowandReturn, TextToDisplay
Master | Scripts
Presentation | CommandBars, DefaultLanguageID, EnvelopeVisible, FarEastLineBreakLanguage, HTMLProject, PublishObjects, VBASigned, WebOptions
Shape | AlternativeText, HasTable, Script, Table
ShapeRange | AlternativeText, HasTable, Script, Table
Slide | Scripts
SlideRange | Scripts
TextRange | LanguageID


AcceleratorsEnabled-Eigenschaft

True, wenn Tastenkombinationen während einer Bildschirmpräsentation aktiviert sind. Der Standardwert ist True. Wenn Tastenkombinationen während einer Bildschirmpräsentation deaktiviert sind, können Sie weder über Tasten in die Bildschirmpräsentation eingreifen, noch die F1-Taste drücken, um eine Liste der Tastenkombinationen zu erhalten. Sie können jedoch die ESC-TASTE drücken, um die Bildschirmpräsentation zu beenden. Long Schreib-Lese-Zugriff.


Beispiel zur AcceleratorsEnabled-Eigenschaft

In diesem Beispiel wird eine Bildschirmpräsentation der aktiven Präsentation gestartet, wobei die Shortcuts deaktiviert sind.

ActivePresentation.SlideShowSettings.Run _
    .View.AcceleratorsEnabled = False


Accent-Eigenschaft

True, wenn eine vertikale Markierungsleiste den Legendentext von der Legendenlinie trennt. Long Schreib-Lese-Zugriff.


Beispiel zur Accent-Eigenschaft

Dieses Beispiel fügt zu myDocument ein Oval und eine Legende hinzu, die auf das Oval deutet. Der Legendentext hat keinen Rahmen, sondern eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


Action-Eigenschaft

Gibt den Typ der Aktion zurück, der ausgeführt wird, wenn Sie auf die angegebene Form klicken bzw. den Mauszeiger während einer Bildschirmpräsentation darauf richten, oder legt diesen Typ fest. Dies kann eine der folgenden PpActionType-Konstanten sein: ppActionEndShow, ppActionFirstSlide, ppActionHyperlink, ppActionLastSlide, ppActionLastSlideViewed, ppActionMixed, ppActionNamedSlideShow, ppActionNextSlide, ppActionNone, ppActionOLEVerb, ppActionPreviousSlide, ppActionRunMacro oder ppActionRunProgram. Long Schreib-Lese-Zugriff.

Sie können die Action-Eigenschaft in Verbindung mit anderen Eigenschaften des ActionSetting-Objekts verwenden. Dies wird in der folgenden Tabelle erläutert.

Wenn Sie für die Action-Eigenschaft diesen Wert festlegen | Verwenden Sie diese Eigenschaft | Für folgende Aktion
ppActionHyperlink | Hyperlink | Festlegen der Eigenschaften für die Hyperlink, die auf eine Mausaktion bei der Form während einer Bildschirmpräsentation folgt.
ppActionRunProgram | Run | Zurückgeben oder Festlegen des Namens des Programms, das aufgrund einer Mausaktion bei der Form während einer Bildschirmpräsentation gestartet wird.
ppActionRunMacro | Run | Zurückgeben oder Festlegen des Namens des Makros, das aufgrund einer Mausaktion bei der Form während einer Bildschirmpräsentation ausgeführt wird.
ppActionOLEVerb | ActionVerb | Festlegen des OLE-Verbs, das aufgrund einer Mausaktion bei der Form während einer Bildschirmpräsentation aufgerufen wird.
ppActionNamedSlideShow | SlideShowName | Festlegen des Namens der benutzerdefinierten Bildschirmpräsentation, die aufgrund einer Mausaktion bei der Form während einer Bildschirmpräsentation ausgeführt wird.


ActionSettings-Eigenschaft

Gibt ein ActionSettings-Objekt zurück, das Informationen über die Aktion enthält, die ausgeführt wird, wenn der Anwender während einer Bildschirmpräsentation auf die angegebene Form oder den angegebenen Textbereich klickt bzw. den Mauszeiger darauf richtet. Nur-Lese-Zugriff.


Beispiel zur ActionSettings-Eigenschaft

Dieses Beispiel legt die Aktionen für Form 1 in Folie 2 der aktiven Präsentation fest, die ausgeführt werden, wenn Sie darauf klicken bzw. den Mauszeiger darauf richten.

Set myShape = ActivePresentation.Slides(2).Shapes(1)
myShape.ActionSettings(ppMouseClick).Action = ppActionLastSlide
myShape.ActionSettings(ppMouseOver).SoundEffect.Name = "applause"


ActionVerb-Eigenschaft

PlaySettings-Objekt: Gibt eine Zeichenfolge zurück, die das OLE-Verb enthält, das ausgeführt wird, wenn das angegebene OLE-Objekt während einer Bildschirmpräsentation animiert wird, oder legt diese Zeichenfolge fest. Das Standardverb gibt die Aktion an, die vom OLE-Objekt nach der vorherigen Animation oder dem Folienübergang ausgeführt wird (z. B. Wiedergabe einer Wave-Datei oder die Anzeige von Daten, die geändert werden sollen). String Schreib-Lese-Zugriff.

ActionSetting-Objekt: Gibt eine Zeichenfolge zurück, die das OLE-Verb enthält, das ausgeführt wird, wenn der Benutzer während einer Bildschirmpräsentation auf die angegebene Form klickt oder den Mauszeiger darauf richtet, oder legt diese Zeichenfolge fest. Zuerst muss für die Action-Eigenschaft ppActionOLEVerb festgelegt werden, damit die Aktion während der Bildschirmpräsentation ausgeführt werden kann. String Schreib-Lese-Zugriff.

Die möglichen Werte für diese Eigenschaft entsprechen den Elementen, die im Feld Objektaktion in der Registerkarte Wiedergabeeinstellungen im Dialogfeld Benutzerdefinierte Animation aufgeführt sind (Menü Bildschirmpräsentation), wenn das angegebene Objekt markiert ist.


Beispiel zur ActionVerb-Eigenschaft

Dieses Beispiel gibt an, dass Form 3 in Folie 1 der aktiven Präsentation sich automatisch für das Bearbeiten öffnet, wenn sie animiert wird. Form 3 muss ein OLE-Objekt sein, das ein Sound- oder Filmobjekt enthält und das Verb "Edit" unterstützt.

Set OLEobj = ActivePresentation.Slides(1).Shapes(3)
With OLEobj.AnimationSettings.PlaySettings
    .PlayOnEntry = True
    .ActionVerb = "Edit"
End With

Dieses Beispiel legt fest, dass Form 3 in Folie 1 wiedergegeben wird, wenn der Mauszeiger während einer Bildschirmpräsentation darauf gerichtet wird. Form 3 muss ein OLE-Objekt darstellen, welches das Verb "Play" unterstützt.

With ActivePresentation.Slides(1).Shapes(3) _
        .ActionSettings(ppMouseOver)
    .ActionVerb = "Play"
    .Action = ppActionOLEVerb
End With


Active-Eigenschaft

True, wenn es sich bei dem angegebenen Bereich oder Fenster um das aktive Element handelt. Long Nur-Lese-Zugriff.


ActivePane-Eigenschaft

Gibt ein Pane-Objekt zurück, das den aktiven Ausschnitt im Dokumentfenster darstellt. Nur-Lese-Zugriff.


Beispiel zur ActivePane-Eigenschaft

Wenn der aktive Ausschnitt der Folienausschnitt ist, wird in diesem Beispiel der Notizenausschnitt zum aktiven Ausschnitt. Dieser Ausschnitt ist das dritte Element der Panes-Auflistung.

With ActiveWindow
    If .ActivePane.ViewType = ppViewSlide Then
        .Panes(3).Activate
    End If
End With


ActivePresentation-Eigenschaft

Gibt ein Presentation-Objekt zurück, das die im aktiven Fenster geöffnete Präsentation darstellt. Nur-Lese-Zugriff.

Beachten Sie, dass die ActivePresentation-Eigenschaft die eingebettete Präsentation zurückgibt, wenn eine eingebettete Präsentation direkt aktiviert wurde.


Beispiel zur ActivePresentation-Eigenschaft

In diesem Beispiel wird die geladene Präsentation im Anwendungsordner in der Datei TestFile gespeichert.

MyPath = Application.Path & "\TestFile" _
    Application.ActivePresentation.SaveAs MyPath


ActivePrinter-Eigenschaft

Gibt den Namen des aktiven Druckers zurück. String Nur-Lese-Zugriff.


Beispiel zur ActivePrinter-Eigenschaft

In diesem Beispiel wird der Name des aktiven Druckers angezeigt.

MsgBox "The name of the active printer is " _
    & Application.ActivePrinter


ActiveWindow-Eigenschaft

Gibt ein DocumentWindow-Objekt zurück, das das aktive Fenster darstellt. Nur-Lese-Zugriff.


Beispiel zur ActiveWindow-Eigenschaft

In diesem Beispiel wird das aktive Fenster minimiert.

Application.ActiveWindow.WindowState = ppWindowMinimized


 AddIns-Eigenschaft

AddIns-Eigenschaft

Gibt die programmspezifische AddIns-Auflistung zurück, die alle Add-Ins aus dem Dialogfeld Add-In-Manager (Menü Extras) enthält. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Hinweise

Add-Ins, die für Microsoft PowerPoint spezifisch sind, werden durch die Dateinamenerweiterung .ppa identifiziert. Component Object Model (COM)-Add-Ins können universell für Programmierprodukte von Microsoft verwendet werden und weisen die Dateinamenerweiterung .dll oder .exe auf.


Beispiel zur AddIns-Eigenschaft

In diesem Beispiel wird das Add-In Myaddin.ppa der Liste im Dialogfeld Add-In-Manager hinzugefügt und automatisch geladen.

Set myAddIn = Application.AddIns.Add(FileName:="c:\myaddin.ppa")
myAddIn.Loaded = True
MsgBox myAddIn.Name & " has been added to the list"


Address-Eigenschaft

Gibt die Internet-Adresse (URL) des Zieldokuments zurück oder legt diese fest. String Schreib-Lese-Zugriff.


Beispiel zur Address-Eigenschaft

Dieses Beispiel durchsucht alle Formen auf der ersten Folie nach dem URL der Microsoft Website.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Hyperlinks
    If s.Address = "http://www.microsoft.com/" Then
        MsgBox "You have a link to the Microsoft Homepage"
    End If
Next


Adjustments-Eigenschaft

Gibt ein Adjustments-Objekt zurück, das Anpassungswerte für alle Anpassungen in der angegebenen Form enthält. Betrifft beliebige Shape- oder ShapeRange-Objekte, die eine AutoForm, WordArt oder eine Verbindung darstellen. Nur-Lese-Zugriff.


Beispiel zur Adjustments-Eigenschaft

Dieses Beispiel legt für den Anpassungswert 1 für Form 3 in myDocument den Wert 0,25 fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).Adjustments(1) = 0.25


AdvanceMode-Eigenschaft

AnimationSettings-Objekt: Gibt einen Wert zurück, der anzeigt, ob die angegebene Animation einer Form nur bei einem Mausklick bzw. automatisch nach einem angegebenen Zeitraum ausgeführt wird, oder legt diesen fest. Dies kann eine der folgenden PpAdvanceMode-Konstanten sein: ppAdvanceModeMixed, ppAdvanceOnClick oder ppAdvanceOnTime. Wird Ihre Form nicht animiert, vergewissern Sie sich, dass für die TextLevelEffect-Eigenschaft nicht ppAnimateLevelNone festgelegt wurde und dass für die Animate-Eigenschaft True festgelegt wurde. Long Schreib-Lese-Zugriff.

SlideShowSettings-Objekt: Gibt einen Wert zurück, der angibt, wie die Bildschirmpräsentation ausgeführt wird, oder legt diesen fest. Dies kann eine der folgenden PpSlideShowAdvanceMode-Konstanten sein: ppSlideShowManualAdvance, ppSlideShowRehearseNewTimings oder ppSlideShowUseSlideTimings. Long Schreib-Lese-Zugriff.

SlideShowView-Objekt: Gibt einen Wert zurück, der angibt, wie die Bildschirmpräsentation in der angegebenen Ansicht ausgeführt wird. Dies kann eine der folgenden PpSlideShowAdvanceMode-Konstanten sein: ppSlideShowManualAdvance, ppSlideShowRehearseNewTimings oder ppSlideShowUseSlideTimings. Long Nur-Lese-Zugriff.


Beispiel zur AdvanceMode-Eigenschaft

Dieses Beispiel legt für Form 2 in Folie 1 der aktiven Präsentation fest, dass diese nach fünf Sekunden animiert wird.

With ActivePresentation.Slides(1).Shapes(2).AnimationSettings
    .AdvanceMode = ppAdvanceOnTime
    .AdvanceTime = 5
    .TextLevelEffect = ppAnimateByAllLevels
    .Animate = True
End With


AdvanceOnClick-Eigenschaft

True, wenn zur nächsten Folie übergegangen wird, wenn Sie während einer Bildschirmpräsentation auf die angegebene Folie klicken. Long Nur-Lese-Zugriff.

Anmerkungen

Wenn automatisch nach einem bestimmten Zeitraum zur nächsten Folie übergegangen werden soll, muss für die AdvanceOnTime-Eigenschaft True und für die AdvanceTime-Eigenschaft der Zeitwert festgelegt werden, nachdem die Folie angezeigt werden soll. Wenn Sie sowohl für die AdvanceOnClick- als auch für die AdvanceOnTime-Eigenschaft True festlegen, findet der Folienübergang statt, wenn Sie auf die angegebene Folie klicken bzw. wenn der angegebene Zeitraum verstrichen ist (je nachdem, was zuerst eintritt).


Beispiel zur AdvanceOnClick-Eigenschaft

Dieses Beispiel legt für Folie 1 der aktiven Präsentation fest, dass der Übergang zur nächsten Folie nach Ablauf von 5 Sekunden bzw. durch Mausklick erfolgt (je nachdem, was zuerst eintritt).

With ActivePresentation.Slides(1).SlideShowTransition
    .AdvanceOnClick = True
    .AdvanceOnTime = True
    .AdvanceTime = 5
End With


AdvanceOnTime-Eigenschaft

True, wenn bei der angegebenen Folie automatisch nach einem bestimmten Zeitraum der Übergang zur nächsten Folie stattfindet. Mit der AdvanceTime-Eigenschaft können Sie die Anzahl der Sekunden festlegen, nach denen automatisch zur nächsten Folie übergegangen wird. Long Nur-Lese-Zugriff.

Anmerkungen

Wenn Sie für die AdvanceMode-Eigenschaft des SlideShowSettings-Objekts ppSlideShowUseSlideTimings festlegen, gelten Ihre Einstellungen für die Folienintervalle für die gesamte Bildschirmpräsentation.


Beispiel zur AdvanceOnTime-Eigenschaft

Dieses Beispiel legt für Folie 1 der aktiven Präsentation fest, dass der Übergang zur nächsten Folie nach Ablauf von 5 Sekunden bzw. durch Mausklick erfolgt (je nachdem, was zuerst eintritt).

With ActivePresentation.Slides(1).SlideShowTransition
    .AdvanceOnClick = True
    .AdvanceOnTime = True
    .AdvanceTime = 5
End With


AdvanceTime-Eigenschaft

AnimationSettings-Objekt: Gibt den Zeitraum (in Sekunden) zurück, nach dem die angegebene Form animiert wird, oder legt diesen fest. Single Schreib-Lese-Zugriff.

SlideShowTransition-Objekt: Gibt den Zeitraum (in Sekunden) zurück, nach dem der angegebene Folienübergang ausgeführt wird, oder legt diesen fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Die angegebene Folienanimation wird nur dann automatisch nach dem angegebenen Zeitraum ausgeführt, wenn für die AdvanceMode-Eigenschaft der Animation ppAdvanceOnTime festgelegt wurde. Der angegebene Folienübergang wird nur dann automatisch ausgeführt, wenn für die AdvanceMode-Eigenschaft der Einstellungen der Bildschirmpräsentation ppSlideShowUseSlideTimings festgelegt wurde.


Beispiel zur AdvanceTime-Eigenschaft

Dieses Beispiel legt fest, dass Form 2 in Folie 1 der aktiven Präsentation automatisch nach 5 Sekunden aktiviert wird.

With ActivePresentation.Slides(1).Shapes(2).AnimationSettings
    .AdvanceMode = ppAdvanceOnTime
    .AdvanceTime = 5
    .TextLevelEffect = ppAnimateByAllLevels
    .Animate = True
End With


AfterEffect-Eigenschaft

Gibt einen Wert zurück, der anzeigt, ob die angegebene Form nach dem Aufbau abgeblendet, ausgeblendet bzw. unverändert erscheint, oder legt diesen Wert fest. Dies kann eine der folgenden PpAfterEffect-Konstanten sein: ppAfterEffectDim, ppAfterEffectHide, ppAfterEffectHideOnClick, ppAfterEffectMixed oder ppAfterEffectNothing (der Standardwert). Long Schreib-Lese-Zugriff.

Anmerkungen

Sie können den Effekt, den Sie für eine Form festgelegt haben, erst dann sehen, wenn die Form animiert wird und anschließend mindestens eine weitere Form der Folie animiert wird. Um eine Form zu animieren, muss für die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts der Form ein anderer Wert als ppAnimateLevelNone festgelegt werden oder die EntryEffect-Eigenschaft muss auf eine andere Konstante als ppEffectNone gesetzt werden. Außerdem muss für die Animate-Eigenschaft True festgelegt sein. Mit der AnimationOrder-Eigenschaft können Sie die Anordnung für den Aufbau der Formen ändern.


Beispiel zur AfterEffect-Eigenschaft

Dieses Beispiel gibt an, dass der Titel auf Folie 1 der aktiven Präsentation nach dem Aufbau des Titels abgeblendet erscheinen soll. Handelt es sich bei dem Titel um die letzte oder einzige Form, die auf Folie 1 aufgebaut werden soll, wird der Text nicht abgeblendet.

With ActivePresentation.Slides(1).Shapes.Title.AnimationSettings
    .Animate = True
    .TextLevelEffect = ppAnimateByAllLevels
    .AfterEffect = ppAfterEffectDim
End With


Alignment-Eigenschaft

ParagraphFormat-Objekt: Gibt die Ausrichtung für jeden Absatz im angegebenen Absatzformat zurück oder legt diese fest. Dies kann eine der folgenden PpParagraphAlignment-Konstanten sein: ppAlignCenter, ppAlignDistribute, ppAlignJustify, ppAlignLeft, ppAlignmentMixed oder ppAlignRight. Long Schreib-Lese-Zugriff.

TextEffectFormat-Objekt: Gibt die Ausrichtung für die angegebene WordArt zurück oder legt diese fest. Dies kann eine der folgenden MsoTextEffectAlignment-Konstanten sein: msoTextEffectAlignmentCentered, msoTextEffectAlignmentLeft, msoTextEffectAlignmentLetterJustify, msoTextEffectAlignmentMixed, msoTextEffectAlignmentRight, msoTextEffectAlignmentStretchJustify oder msoTextEffectAlignmentWordJustify. Long Schreib-Lese-Zugriff.


Beispiel zur Alignment-Eigenschaft

In diesem Beispiel werden die Absätze von Form 2 in Folie 1 der aktiven Präsentation linksbündig ausgerichtet.

Application.ActivePresentation.Slides(1).Shapes(2) _
    .TextFrame.TextRange.ParagraphFormat.Alignment = ppAlignLeft

In diesem Beispiel wird Folie 1 der aktiven Präsentation ein WordArt-Objekt hinzugefügt, das anschließend rechtsbündig ausgerichtet wird.

Set mySh = Application.ActivePresentation.Slides(1).Shapes
Set myTE = mySh.AddTextEffect(PresetTextEffect:=msoTextEffect1, _
    Text:="Test Text", FontName:="Palatino", FontSize:=54, _
    FontBold:=True, FontItalic:=False, Left:=100, Top:=50)
myTE.TextEffect.Alignment = msoTextEffectAlignmentRight


AllowPNG-Eigenschaft

True, wenn PNG (Portable Network Graphics) als Grafikformat beim Speichern oder Veröffentlichen einer vollständigen Präsentation oder von Teilen einer Präsentation als Webseite zulässig ist. False, wenn PNG als Ausgabeformat nicht zulässig ist. Der Standardwert ist False. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie Grafiken anstatt in einem anderen Dateiformat im Format PNG speichern, können Sie die Grafikqualität verbessern oder die Größe der betreffenden Grafikdatei reduzieren. Damit wird die Downloaddauer reduziert, vorausgesetzt, dass die angewählten Webbrowser das PNG-Format unterstützen.


Beispiel zur AllowPNG-Eigenschaft

In diesem Beispiel wird PNG als Ausgabeformat für die aktive Präsentation aktiviert.

ActivePresentation.WebOptions.AllowPNG = True

Alternativ dazu kann PNG als globaler Standard der Anwendung für neu erstellte Präsentationen definiert werden.

Application.DefaultWebOptions.AllowPNG = True


 AlternativeText-Eigenschaft

AlternativeText-Eigenschaft

Definiert alternativen Text oder gibt diesen zurück, der zu einer Form in einer Webpräsentation gehört. String Schreib-Lese-Zugriff.


Beispiel zur AlternativeText-Eigenschaft

Im folgenden Beispiel wird der alternative Text für die ausgewählte Form im aktiven Fenster eingestellt. Die ausgewählte Form ist eine Grafik einer Stockente.

ActiveWindow.Selection.ShapeRange _
    .AlternativeText = "This is a mallard duck."


 AlwaysSaveInDefaultEncoding-Eigenschaft

AlwaysSaveInDefaultEncoding-Eigenschaft

True, wenn die Standardcodierung beim Speichern einer Webseite oder eines Nur-Text-Dokuments verwendet wird, unabhängig von der ursprünglichen Codierung der Datei, die beim Öffnen vorlag. False, wenn die ursprüngliche Codierung der Datei verwendet wird. Der Standardwert ist False. Long Schreib-Lese-Zugriff.

Hinweise

Die Encoding-Eigenschaft kann zum Setzen der Standardcodierung verwendet werden.


Beispiel zur AlwaysSaveInDefaultEncoding-Eigenschaft

In diesem Beispiel wird die Codierung auf die Standardcodierung eingestellt. Die Codierung wird verwendet, wenn Sie das Dokument als Webseite speichern.

Application.DefaultWebOptions.AlwaysSaveInDefaultEncoding = True


Angle-Eigenschaft

Gibt den Winkel der Legendenlinie zurück oder legt diesen fest. Enthält die Legendenlinie mehrere Linienabschnitte, gibt diese Eigenschaft den Winkel des Abschnitts zurück, der am weitesten vom Legenden-Textfeld entfernt ist, oder legt diesen Winkel fest. Dies kann eine der folgenden MsoCalloutAngleType-Konstanten sein: msoCalloutAngle30, msoCalloutAngle45, msoCalloutAngle60, msoCalloutAngle90, msoCalloutAngleAutomatic oder msoCalloutAngleMixed. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie für diese Eigenschaft einen anderen Wert als msoCalloutAngleAutomatic festlegen, behält die Legendenlinie einen festen Winkel bei, während Sie die Legende ziehen.


Beispiel zur Angle-Eigenschaft

Dieses Beispiel legt in myDocument für eine Legende mit der Bezeichnung "co1" einen Winkel von 90° fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes("co1").Callout.Angle = msoCalloutAngle90


Animate-Eigenschaft

True, wenn die angegebene Form während einer Bildschirmpräsentation animiert wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Damit die Animation einer Form ausgeführt werden kann, muss die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts für die Form auf einen anderen Wert als ppAnimateLevelNone gesetzt werden. Außerdem muss entweder die Animate-Eigenschaft auf True gesetzt werden, oder die EntryEffect-Eigenschaft muss auf eine andere Konstante als ppEffectNone gesetzt werden.


AnimateAction-Eigenschaft

True, wenn die Farbe der angegebenen Form momentan invertiert ist, wenn die angegebene Mausaktion vollzogen wird. Long Schreib-Lese-Zugriff.


Beispiel zur AnimateAction-Eigenschaft

Dieses Beispiel legt fest, dass bei Form 3 in Folie 1 der aktiven Präsentation ein Applaus wiedergegeben wird und für den Moment die Farbe invertiert wird, wenn Sie während einer Bildschirmpräsentation darauf klicken.

With ActivePresentation.Slides(1) _
    .Shapes(3).ActionSettings(ppMouseClick)
        .SoundEffect.Name = "applause"
        .AnimateAction = True
End With


AnimateBackground-Eigenschaft

Das angegebene Objekt ist eine AutoForm: True, wenn die Form getrennt vom Text animiert wird, der in dieser Form enthalten ist. Die angegebene Form ist ein graphisches Objekt: True, wenn der Hintergrund (die Achsen und Gitternetzlinien) des angegebenen graphischenObjekts animiert wird. Dies betrifft nur AutoFormen, die Text enthalten, der in mehreren Schritten aufgebaut werden kann, oder graphische Objekte. Long Schreib-Lese-Zugriff.

Anmerkungen

Mit den TextLevelEffect- und TextUnitEffect-Eigenschaften können Sie die Animation von Text steuern, der der angegebenen Form beigefügt ist.

Wird für diese Eigenschaft True und für die TextLevelEffect-Eigenschaft ppAnimateByAllLevels festgelegt, werden die Form und der zugehörige Text gleichzeitig animiert. Wird für diese Eigenschaft True und für die TextLevelEffect-Eigenschaft etwas anderes als ppAnimateByAllLevels festgelegt, wird die Form unmittelbar vor dem Text animiert.

Sie können die Effekte der Einstellung für diese Eigenschaft erst dann sehen, wenn die angegebene Form animiert wird. Um eine Form animieren zu können, muss für die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts etwas anderes als ppAnimateLevelNone festgelegt und entweder die Animate-Eigenschaft auf True oder die EntryEffect-Eigenschaft auf eine andere Konstante als ppEffectNone gesetzt werden.


Beispiel zur AnimateBackground-Eigenschaft

Dieses Beispiel erstellt ein Rechteck, das Text enthält. Anschließend gibt dieses Beispiel an, dass die Form mit dem Flugeffekt von unten rechts kommt, dass der Text aus Absätzen der ersten Ebene aufgebaut wird und dass die Form getrennt vom Text animiert wird, der in der Form enthalten ist. In diesem Beispiel startet die EntryEffect-Eigenschaft die Animation.

With ActivePresentation.Slides(1).Shapes.AddShape _
    (msoShapeRectangle, 50, 200, 200, 200)
         .TextFrame.TextRange = "Reason 1" _
         & Chr(13) & "Reason 2" & Chr(13) _
         & "Reason 3"
    With .AnimationSettings
        .EntryEffect = ppEffectFlyFromBottomRight
        .TextLevelEffect = ppAnimateByFirstLevel
        .TextUnitEffect = ppAnimateByParagraph
        .AnimateBackground = True
    End With
End With


AnimateTextInReverse-Eigenschaft

True, wenn die angegebene Form in umgekehrter Reihenfolge aufgebaut wird. Betrifft nur Formen, die in mehreren Schritten aufgebaut werden können (z. B. Formen, die Listen enthalten). Long Schreib-Lese-Zugriff.

Anmerkungen

Sie können die Effekte der Einstellung für diese Eigenschaft erst dann sehen, wenn die angegebene Form animiert wird. Um eine Form animieren zu können, muss für die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts etwas anderes als ppAnimateLevelNone festgelegt werden. Außerdem muss für die Animate-Eigenschaft True gelten.


Beispiel zur AnimateTextInReverse-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation eine Folie nach Folie 1 hinzu, legt den Titeltext fest und fügt dem Platzhalter für den Text eine Liste mit drei Elementen hinzu. Außerdem legt dieses Beispiel fest, dass die Liste in umgekehrter Reihenfolge aufgebaut wird.

With ActivePresentation.Slides.Add(2, ppLayoutText).Shapes
    .Item(1).TextFrame.TextRange.Text = "Top Three Reasons"
    With .Item(2)
        .TextFrame.TextRange = "Reason 1" & Chr(13) _
            & "Reason 2" & Chr(13) & "Reason 3"
        With .AnimationSettings
            .Animate = True
            .TextLevelEffect = ppAnimateByFirstLevel
            .AnimateTextInReverse = True
        End With
    End With
End With


AnimationOrder-Eigenschaft

Gibt eine ganze Zahl zurück, die die Position der angegebenen Form innerhalb der Auflistung der zu animierenden Formen darstellt, oder legt diese Zahl fest. Long Schreib-Lese-Zugriff.

Hinweise

Sie können die Effekte der Einstellung für diese Eigenschaft erst dann sehen, wenn die angegebene Form animiert wird. Um eine Form animieren zu können, muss für die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts etwas anderes als ppAnimateLevelNone festgelegt werden. Außerdem muss für die Animate-Eigenschaft True gelten.

Anmerkung Wenn Sie den Wert der AnimationOrder-Eigenschaft auf einen Wert festlegen, der geringer ist als der größte vorhandene Wert der AnimationOrder-Eigenschaft, kann dies zu einer Verschiebung der Animationsreihenfolge führen.


Beispiel zur AnimationOrder-Eigenschaft

Dieses Beispiel gibt an, dass Form 2 in Folie 2 der aktiven Präsentation an zweiter Stelle animiert wird.

ActivePresentation.Slides(2).Shapes(2) _
    .AnimationSettings.AnimationOrder = 2


AnimationSettings-Eigenschaft

Gibt ein AnimationSettings-Objekt zurück, das alle Spezialeffekte darstellt, die Sie der Animation der angegebenen Form zuweisen können. Nur-Lese-Zugriff.


Beispiel zur AnimationSettings-Eigenschaft

Dieses Beispiel legt für Form 1 in Folie 2 der aktiven Präsentation fest, dass diese mit dem Flugeffekt von links kommt, wenn die Folie aufgebaut wird.

With ActivePresentation.Slides(2).Shapes(1).AnimationSettings
    .EntryEffect = ppEffectFlyFromLeft
    .TextLevelEffect = ppAnimateByAllLevels
End With


AnswerWizard-Eigenschaft

Gibt das AnswerWizard-Objekt zurück, das die Dateien enthält, die vom Suchmodul der Onlinehilfe verwendet werden. Nur-Lese-Zugriff.


Application-Eigenschaft

Gibt ein Application-Objekt zurück, das den Ersteller des angegebenen Objekts darstellt. Nur-Lese-Zugriff.


Beispiel zur Application-Eigenschaft

In diesem Beispiel wird ein Presentation-Objekt an die Prozedur weitergegeben. Die Prozedur fügt der Präsentation eine Folie hinzu und speichert die Präsentation anschließend in dem Ordner, in dem PowerPoint ausgeführt wird.

Sub AddAndSave(pptPres As Presentation)
    pptPres.Slides.Add 1, 1
    pptPres.SaveAs pptPres.Application.Path & "\Added Slide"
End Sub

In diesem Beispiel wird der Name der Anwendung angezeigt, die jedes verknüpfte OLE-Objekt in Folie 1 der aktiven Präsentation erstellt hat.

For Each s In ActivePresentation.Slides(1).Shapes
    If s.Type = msoLinkedOLEObject Then
        MsgBox s.OLEFormat.Object.Application.Name
    End If
Next


Assistant-Eigenschaft

Gibt ein Assistant-Objekt zurück, das den Office-Assistenten darstellt. Nur-Lese-Zugriff.


Beispiel zur Assistant-Eigenschaft

In diesem Beispiel wird der Office-Assistent aufgerufen.

Application.Assistant.Visible = True

In diesem Beispiel wird der Office-Assistent zum oberen linken Bereich des Bildschirms verschoben.

Application.Assistant.Move xLeft:=100, yTop:=100


AutoAttach-Eigenschaft

True, wenn die Stelle, an der die Legendenlinie mit dem Legenden-Textfeld verbunden ist, davon abhängig ist, ob sich der Ursprung der Legendenlinie (wohin die Legende deutet) links oder rechts vom Legenden-Textfeld befindet. Long Schreib-Lese-Zugriff.

Anmerkungen

Gilt für den Wert dieser Eigenschaft True, wird der Bezugswert (der vertikale Abstand von der Seite des Legenden-Textfelds bis zu der Stelle, mit der die Legendenlinie verbunden ist) von der oberen Seite des Textfelds gemessen, wenn sich das Textfeld rechts vom Ursprung befindet, bzw. von der unteren Seite des Textfelds gemessen, wenn es sich links vom Ursprung befindet. Gilt für den Wert dieser Eigenschaft False, so wird der Bezugswert immer von der oberen Seite des Textfelds gemessen. In diesem Fall sind die relativen Positionen von Textfeld und dem Ursprung nicht relevant. Mit der CustomDrop-Methode wird der Bezugswert festgelegt und mit der Drop-Eigenschaft zurückgegeben.

Wenn Sie diese Eigenschaft festlegen, ist eine Legende nur dann davon betroffen, wenn diese einen explizit festgelegten Bezugswert hat (d. h., wenn als Wert für die DropType-Eigenschaft msoCalloutDropCustom gilt). Wenn Legenden erstellt werden, haben sie standardmäßig explizit festgelegte Bezugswerte.


Beispiel zur AutoAttach-Eigenschaft

Dieses Beispiel fügt der ersten Folie zwei Legenden hinzu. Eine der beiden Legenden wird automatisch angefügt, die andere nicht. Wenn Sie den Linienursprung der automatisch angefügten Legende auf die rechte Seite des eingefügten Textfeldes ziehen, ändert sich die Position des Textfeldes. Die Legende, die nicht automatisch eingefügt wird, weist dieses Verhalten nicht auf.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    With .AddCallout(msoCalloutTwo, 420, 170, 200, 50)
        .TextFrame.TextRange.Text = "auto-attached"
        .Callout.AutoAttach = True
    End With
    With .AddCallout(msoCalloutTwo, 420, 350, 200, 50)
        .TextFrame.TextRange.Text = "not auto-attached"
        .Callout.AutoAttach = False
    End With
End With


AutoLength-Eigenschaft

True, wenn der erste Abschnitt der Legendenlinie (der Abschnitt, der mit dem Legenden-Textfeld verbunden ist) beim Verschieben der Legende automatisch skaliert wird. False, wenn der erste Abschnitt der Legende beim Verschieben der Legende die feste Länge beibehält, die von der Length-Eigenschaft angegeben wurde. Dies betrifft nur Legenden, deren Linien aus mehreren Abschnitten bestehen (die Typen msoCalloutThree und msoCalloutFour). Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der AutomaticLength-Methode können Sie für diese Eigenschaft True, mit der CustomLength-Methode False festlegen.


Beispiel zur AutoLength-Eigenschaft

Dieses Beispiel wechselt zwischen einem automatisch skalierenden ersten Abschnitt und einem Abschnitt mit einer festen Länge für die Legendenlinie für Form 1 in myDocument. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


AutoLoad-Eigenschaft

True, wenn das angegebene Add-In bei jedem Start von PowerPoint automatisch geladen wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie für diese Eigenschaft True festlegen, gilt für die Registered-Eigenschaft automatisch True.


Beispiel zur AutoLoad-Eigenschaft

Dieses Beispiel zeigt den Namen von jedem Add-In an, das automatisch beim Start von PowerPoint geladen wird.

For Each myAddIn In AddIns
    If myAddIn.AutoLoad Then
        MsgBox myAddIn.Name
        afound = True
    End If
Next myAddIn
If afound <> True Then
    MsgBox "No add-ins were loaded automatically."

Dieses Beispiel gibt an, dass das Add-In "MyTools" beim Start von PowerPoint automatisch geladen wird.

Application.AddIns("mytools").AutoLoad = True


AutoRotateNumbers-Eigenschaft

Sprachspezifische Informationen.

Returns or sets lateral compression. If set to True, displays half-width numbers within vertical text in two-character lateral columns. If set to False, half-width numbers will not be compressed in lateral columns. Read/write Long.


Beispiel zur AutoRotateNumbers-Eigenschaft

This example sets the text direction of shape three on the first slide to vertical text, and sets lateral column compression.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).TextFrame
    .Orientation = msoTextOrientationVerticalFarEast
    .TextRange.Font.AutoRotateNumbers = True
End With


AutoShapeType-Eigenschaft

Gibt den Typ der Form für das angegebene Shape- oder ShapeRange-Objekt zurück, das eine AutoForm darstellen muss, das keine Linie, Freihandfigur oder Verbindung ist, oder legt diesen Typ fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie den Typ einer Form ändern, behält die Form ihre Größe, Farbe und andere Attribute bei.

Dies kann eine der folgenden MsoAutoShapeType-Konstanten sein:

msoShape16pointStar

msoShape24pointStar

msoShape32pointStar

msoShape4pointStar

msoShape5pointStar

msoShape8pointStar

msoShapeActionButtonBackorPrevious

msoShapeActionButtonBeginning

msoShapeActionButtonCustom

msoShapeActionButtonDocument

msoShapeActionButtonEnd

msoShapeActionButtonForwardorNext

msoShapeActionButtonHelp

msoShapeActionButtonHome

msoShapeActionButtonInformation

msoShapeActionButtonMovie

msoShapeActionButtonReturn

msoShapeActionButtonSound

msoShapeArc

msoShapeBalloon

msoShapeBentArrow

msoShapeBentUpArrow

msoShapeBevel

msoShapeBlockArc

msoShapeCan

msoShapeChevron

msoShapeCircularArrow

msoShapeCloudCallout

msoShapeCross

msoShapeCube

msoShapeCurvedDownArrow

msoShapeCurvedDownRibbon

msoShapeCurvedLeftArrow

msoShapeCurvedRightArrow

msoShapeCurvedUpArrow

msoShapeCurvedUpRibbon

msoShapeDiamond

msoShapeDonut

msoShapeDoubleBrace

msoShapeDoubleBracket

msoShapeDoubleWave

msoShapeDownArrow

msoShapeDownArrowCallout

msoShapeDownRibbon

msoShapeExplosion1

msoShapeExplosion2

msoShapeFlowchartAlternateProcess

msoShapeFlowchartCard

msoShapeFlowchartCollate

msoShapeFlowchartConnector

msoShapeFlowchartData

msoShapeFlowchartDecision

msoShapeFlowchartDelay

msoShapeFlowchartDirectAccessStorage

msoShapeFlowchartDisplay

msoShapeFlowchartDocument

msoShapeFlowchartExtract

msoShapeFlowchartInternalStorage

msoShapeFlowchartMagneticDisk

msoShapeFlowchartManualInput

msoShapeFlowchartManualOperation

msoShapeFlowchartMerge

msoShapeFlowchartMultidocument

msoShapeFlowchartOffpageConnector

msoShapeFlowchartOr

msoShapeFlowchartPredefinedProcess

msoShapeFlowchartPreparation

msoShapeFlowchartProcess

msoShapeFlowchartPunchedTape

msoShapeFlowchartSequentialAccessStorage

 msoShapeFlowchartSort

msoShapeFlowchartStoredData

msoShapeFlowchartSummingJunction

msoShapeFlowchartTerminator

msoShapeFoldedCorner

msoShapeHeart

msoShapeHexagon

msoShapeHorizontalScroll

msoShapeIsoscelesTriangle

msoShapeLeftArrow

msoShapeLeftArrowCallout

msoShapeLeftBrace

msoShapeLeftBracket

msoShapeLeftRightArrow

msoShapeLeftRightArrowCallout

msoShapeLeftRightUpArrow

msoShapeLeftUpArrow

msoShapeLightningBolt

msoShapeLineCallout1

msoShapeLineCallout1AccentBar

msoShapeLineCallout1BorderandAccentBar

msoShapeLineCallout1NoBorder

msoShapeLineCallout2

msoShapeLineCallout2AccentBar

msoShapeLineCallout2BorderandAccentBar

msoShapeLineCallout2NoBorder

msoShapeLineCallout3

msoShapeLineCallout3AccentBar

msoShapeLineCallout3BorderandAccentBar

msoShapeLineCallout3NoBorder

msoShapeLineCallout4

msoShapeLineCallout4AccentBar

msoShapeLineCallout4BorderandAccentBar

msoShapeLineCallout4NoBorder

msoShapeMixed

msoShapeMoon

msoShapeNoSymbol

msoShapeNotchedRightArrow

msoShapeNotPrimitive

msoShapeOctagon

msoShapeOval

msoShapeOvalCallout

msoShapeParallelogram

msoShapePentagon

msoShapePlaque

msoShapeQuadArrow

msoShapeQuadArrowCallout

msoShapeRectangle

msoShapeRectangularCallout

msoShapeRegularPentagon

msoShapeRightArrow

msoShapeRightArrowCallout

msoShapeRightBrace

msoShapeRightBracket

msoShapeRightTriangle

msoShapeRoundedRectangle

msoShapeRoundedRectangularCallout

msoShapeSmileyFace

msoShapeStripedRightArrow

msoShapeSun

msoShapeTrapezoid

msoShapeUpArrow

msoShapeUpArrowCallout

msoShapeUpDownArrow

msoShapeUpDownArrowCallout

msoShapeUpRibbon

msoShapeUTurnArrow

msoShapeVerticalScroll

msoShapeWave

Anmerkungen

Mit der Type-Eigenschaft des ConnectorFormat-Objekts können Sie den Verbindungstyp festlegen oder zurückgeben.


Beispiel zur AutoShapeType-Eigenschaft

Dieses Beispiel ersetzt alle Sterne mit 16 Ecken durch Sterne mit 32 Ecken in myDocument.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.AutoShapeType = msoShape16pointStar Then
        s.AutoShapeType = msoShape32pointStar
    End If
Next


AutoSize-Eigenschaft

Gibt einen Wert zurück oder legt einen Wert fest, der angibt, ob die Größe der angegebenen Form automatisch geändert und an den Text innerhalb ihrer Begrenzung angepasst wird. Dies kann eine der folgenden PpAutoSize-Konstanten sein: ppAutoSizeMixed, ppAutoSizeNone oder ppAutoSizeShapeToFitText. Long Schreib-Lese-Zugriff.


Beispiel zur AutoSize-Eigenschaft

In diesem Beispiel wird die Größe des Begrenzungsfelds für den Titel auf Folie eins dem Titeltext angepasst.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1)
    If .TextFrame.TextRange.Characters.Count < 50 Then
        .TextFrame.AutoSize = ppAutoSizeShapeToFitText
    End If
End With


AutoUpdate-Eigenschaft

Gibt die Art der Aktualisierung der Verknüpfung zurück oder legt diese fest (entweder beim Öffnen der Präsentation bzw. beim Ändern der Quelldatei oder manuell, wenn der Anwender dies ausdrücklich anfordert). Dies kann eine der folgenden PpUpdateOption-Konstanten sein: ppUpdateOptionAutomatic, ppUpdateOptionManual oder ppUpdateOptionMixed. Long Schreib-Lese-Zugriff.


Beispiel zur AutoUpdate-Eigenschaft

Dieses Beispiel durchläuft alle Formen auf allen Folien in der aktiven Präsentation und legt für alle verknüpften Microsoft Excel-Tabellenblätter fest, dass diese manuell aktualisert werden.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Excel.Sheet" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


BackColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Hintergrundfarbe für die angegebene Füllung oder gemusterte Linie darstellt, oder legt dieses Objekt fest. Schreib-Lese-Zugriff.


Beispiel zur BackColor-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt anschließend die Vordergrundfarbe, Hintergrundfarbe und den Farbverlauf für die Füllung des Rechtecks fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With

Dieses Beispiel fügt zu myDocument eine gemusterte Linie hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


Background-Eigenschaft

Master-, Slide- und SlideRange-Objekte: Gibt ein ShapeRange-Objekt zurück, das den Folienhintergrund darstellt. Nur-Lese-Zugriff.

Anmerkungen

Möchten Sie die Background-Eigenschaft verwenden, um den Hintergrund für eine individuelle Folie festzulegen, ohne den Folienmaster zu ändern, dann muss für die FollowMasterBackground-Eigenschaft der Folie False gelten.


Beispiel zur Background-Eigenschaft

Dieses Beispiel legt für den Hintergrund des Folienmaster der aktiven Präsentation einen vordefinierten Schatten fest.

ActivePresentation.SlideMaster.Background.Fill.PresetGradient _
    msoGradientHorizontal, 1, msoGradientLateSunset

Dieses Beispiel legt für den Hintergrund von Folie 1 der aktiven Präsentation einen vordefinierten Schatten fest.

With ActivePresentation.Slides(1)
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient _
        msoGradientHorizontal, 1, msoGradientLateSunset
End With


BaseLineAlignment-Eigenschaft

Gibt die Ausrichtung der Grundlinie für den angegebenen Absatz zurück oder legt sie fest. Dies kann eine der folgenden PpBaselineAlignment-Konstanten sein: ppBaselineAlignBaseline, ppBaselineAlignCenter, ppBaselineAlignFarEast50, ppBaselineAlignMixed oder ppBaselineAlignTop. Long Schreib-Lese-Zugriff.


Beispiel zur BaseLineAlignment-Eigenschaft

In diesem Beispiel wird die Ausrichtung der Grundlinie der Absätze bei Form 2 in Folie 1 der aktiven Präsentation angezeigt.

MsgBox ActivePresentation.Slides(1).Shapes(2).TextFrame.TextRange _
    .ParagraphFormat.BaseLineAlignment


BaselineOffset-Eigenschaft

Gibt den Abstand von der Grundlinie bei hoch gestellten oder tief gestellten Zeichen zurück oder legt diesen fest. Es kann sich dabei um einen Gleitkommawert im Bereich von – 1 bis 1 handeln. Der Wert – 1 stellt einen Abstand von – 100 % und der Wert 1 einen Abstand von 100 % dar. Single Schreib-Lese-Zugriff.

Anmerkungen

Wird für die BaselineOffset-Eigenschaft ein negativer Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch True und für die Superscript-Eigenschaft automatisch False.

Wird für die BaselineOffset-Eigenschaft ein positiver Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch False und für die Superscript-Eigenschaft automatisch True.

Wird für die Subscript-Eigenschaft True festgelegt, gilt für die BaselineOffset-Eigenschaft automatisch der Wert 0,3 (30 %).

Wird für die Superscript-Eigenschaft True festgelegt, gilt für die BaselineOffset-Eigenschaft automatisch der Wert – 0,25 ( – 25 %).


Beispiel zur BaselineOffset-Eigenschaft

In diesem Beispiel wird der Text für Form 2 auf Folie 1 festgelegt, wobei das zweite Zeichen um 20 % tief gestellt wird.

With Application.ActivePresentation.Slides(1) _
        .Shapes(2).TextFrame.TextRange
    .Text = "H2O"
    .Characters(2, 1).Font.BaselineOffset = -0.2
End With


BeginArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadLength-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadStyle-Konstanten sein: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadStyle-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadWidth-Eigenschaft

Gibt die Stärke der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadWidth-Konstanten sein: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadWidth-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginConnected-Eigenschaft

True, wenn der Anfang der angegebenen Verbindung mit einer Form verbunden wird. Long Nur-Lese-Zugriff.


BeginConnectedShape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Form darstellt, mit der der Anfang der angegebenen Verbindung zusammengefügt ist. Nur-Lese-Zugriff.

Hinweis Wenn der Anfang der angegebenen Verbindung nicht mit einer Form zusammengefügt ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur BeginConnectedShape-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass die erste Folie der aktiven Präsentation zwei Formen enthält, die mit der Verbindung "Conn1To2." zusammengefügt sind. Der Code fügt zu der ersten Folie ein Rechteck und eine Verbindung hinzu. Der Anfang der Verbindung wird mit dem gleichen Verbindungspunkt zusammengefügt wie der Anfang der Verbindung "Conn1To2". Außerdem wird das Ende der neuen Verbindung mit Verbindungspunkt 1 im neuen Rechteck zusammengefügt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 450, 190, 200, 100)
    .AddConnector(msoConnectorCurve, 0, 0, 10, 10) _
        .Name = "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        beginConnSite1 = .BeginConnectionSite
        Set beginConnShape1 = .BeginConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect beginConnShape1, beginConnSite1
        .EndConnect r3, 1
    End With
End With


BeginConnectionSite-Eigenschaft

Gibt eine ganze Zahl zurück, die den Verbindungspunkt angibt, mit der der Anfang einer Verbindung verbunden ist. Long Nur-Lese-Zugriff.

Hinweis Wenn der Anfang der angegebenen Verbindung nicht mit einer Form zusammengefügt ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur BeginConnectionSite-Eigenschaft

In diesem Beispiel ist die erste Folie der aktiven Präsentation mit zwei Formen gegeben, die mit der Verbindung "Conn1To2." zusammengefügt sind. Der Code fügt zur ersten Folie ein Rechteck und eine Verbindung hinzu. Der Anfang der Verbindung wird mit dem gleichen Verbindungspunkt zusammengefügt wie der Anfang der Verbindung "Conn1To2". Außerdem wird das Ende der neuen Verbindung mit Verbindungspunkt 1 im neuen Rechteck zusammengefügt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 450, 190, 200, 100)
    .AddConnector(msoConnectorCurve, _
        0, 0, 10, 10).Name = "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        beginConnSite1 = .BeginConnectionSite
        Set beginConnShape1 = .BeginConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect beginConnShape1, beginConnSite1
        .EndConnect r3, 1
    End With
End With


BlackAndWhite-Eigenschaft

True, wenn die Anzeige im Dokumentfenster Schwarzweiß ist. Der Standard ist False. Long Schreib-Lese-Zugriff.


Beispiel zur BlackAndWhite-Eigenschaft

In diesem Beispiel wird die Anzeige von Fenster 1 auf Schwarzweiß umgestellt.

Application.Windows(1).BlackAndWhite = True


BlackWhiteMode-Eigenschaft

Gibt einen Wert zurück, der anzeigt, wie die angegebene Form erscheint, wenn die Präsentation im Schwarzweißmodus angezeigt wird, oder legt diesen Wert fest. Dies kann eine der folgenden MsoBlackWhiteMode-Konstanten sein: msoBlackWhiteAutomatic, msoBlackWhiteBlack, msoBlackWhiteBlackTextAndLine, msoBlackWhiteDontShow, msoBlackWhiteGrayOutline, msoBlackWhiteGrayScale, msoBlackWhiteHighContrast, msoBlackWhiteInverseGrayScale, msoBlackWhiteLightGrayScale, msoBlackWhiteMixed oder msoBlackWhiteWhite. Long Schreib-Lese-Zugriff.


Beispiel zur BlackWhiteMode-Eigenschaft

Dieses Beispiel legt fest, dass Form 1 in myDocument im Schwarzweißmodus erscheint. Wenn Sie die Präsentation im Schwarzweißmodus aufrufen, wird Form 1 auch dann schwarz angezeigt, wenn im Farbmodus eine andere Farbe festgelegt wurde.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).BlackWhiteMode = msoBlackWhiteBlack


Bold-Eigenschaft

True, wenn die Zeichen fett formatiert sind, False, wenn die Zeichen nicht fett formatiert sind, msoTriStateMixed, wenn der angegebene Textbereich sowohl fett als auch nicht fett formatierte Zeichen enthält. Long Schreib-Lese-Zugriff.


Beispiel zur Bold-Eigenschaft

In diesem Beispiel werden die Zeichen 1 bis 5 im Titel von Folie 1 fett formatiert.

Set myT = Application.ActivePresentation.Slides(1).Shapes.Title
myT.TextFrame.TextRange.Characters(1, 5).Font.Bold = True


Border-Eigenschaft

True, wenn der Text in der angegebenen Legende von einem Rahmen umgeben ist. Long Schreib-Lese-Zugriff.


Borders-Eigenschaft

Gibt eine Borders-Auflistung zurück, die die Rahmen und diagonalen Linien für das angegebene Cell-Objekt oder die CellRange-Auflistung darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Borders-Eigenschaft

In diesem Beispiel wird die Stärke der linken Rahmenlinie für die erste Zelle in der zweiten Zeile der ausgewählten Tabelle auf drei Punkt eingestellt.

ActiveWindow.Selection.ShapeRange.Table.Rows(2) _
    .Cells(1).Borders.Item(ppBorderLeft).Weight = 3


 BoundHeight-Eigenschaft

BoundHeight-Eigenschaft

Gibt die Höhe (in Punkt) des Text-Begrenzungsrechtecks im angegebenen Textrahmen zurück. Single Nur-Lese-Zugriff.


Beispiel zur BoundHeight-Eigenschaft

In diesem Beispiel wird der ersten Folie in der aktiven Präsentation ein abgerundetes Rechteck hinzugefügt. Es besitzt die gleichen Abmessungen wie das Textbegrenzungs-Rechteck der ersten Form.

With Application.ActivePresentation.Slides(1).Shapes
    Set tr = .Item(1).TextFrame.TextRange
    Set roundRect = .AddShape(msoShapeRoundedRectangle, _
        tr.BoundLeft, tr.BoundTop, tr.BoundWidth, tr.BoundHeight)
End With
With roundRect.Fill
    .ForeColor.RGB = RGB(255, 0, 128)
    .Transparency = 0.75
End With


 BoundLeft-Eigenschaft

BoundLeft-Eigenschaft

Gibt den Abstand (in Punkt) vom linken Rand des Text-Begrenzungsrechtecks im angegebenen Textrahmen zum linken Rand der Folie zurück. Single Nur-Lese-Zugriff.


Beispiel zur BoundLeft-Eigenschaft

In diesem Beispiel wird der ersten Folie in der aktiven Präsentation ein abgerundetes Rechteck hinzugefügt. Es besitzt die gleichen Abmessungen wie das Textbegrenzungsrechteck der ersten Form.

With Application.ActivePresentation.Slides(1).Shapes
    Set tr = .Item(1).TextFrame.TextRange
    Set roundRect = .AddShape(msoShapeRoundedRectangle, _
        tr.BoundLeft, tr.BoundTop, tr.BoundWidth, tr.BoundHeight)
End With
With roundRect.Fill
    .ForeColor.RGB = RGB(255, 0, 128)
    .Transparency = 0.75
End With


 BoundTop-Eigenschaft

BoundTop-Eigenschaft

Gibt den Abstand (in Punkt) vom oberen Rand des Text-Begrenzungsrechtecks im angegebenen Textrahmen zum oberen Rand der Folie zurück. Single Nur-Lese-Zugriff.


Beispiel zur BoundTop-Eigenschaft

In diesem Beispiel wird der ersten Folie in der aktiven Präsentation ein abgerundetes Rechteck hinzugefügt. Es besitzt die gleichen Abmessungen wie das Textbegrenzungs-Rechteck der ersten Form.

With Application.ActivePresentation.Slides(1).Shapes
    Set tr = .Item(1).TextFrame.TextRange
    Set roundRect = .AddShape(msoShapeRoundedRectangle, _
        tr.BoundLeft, tr.BoundTop, tr.BoundWidth, tr.BoundHeight)
End With
With roundRect.Fill
    .ForeColor.RGB = RGB(255, 0, 128)
    .Transparency = 0.75
End With


 BoundWidth-Eigenschaft

BoundWidth-Eigenschaft

Gibt die Breite (in Punkt) des Text-Begrenzungsrechtecks im angegebenen Textrahmen zurück. Single Nur-Lese-Zugriff.


Beispiel zur BoundWidth-Eigenschaft

In diesem Beispiel wird der ersten Folie in der aktiven Präsentation ein abgerundetes Rechteck hinzugefügt. Es besitzt die gleichen Abmessungen wie das Textbegrenzungs-Rechteck der ersten Form.

With Application.ActivePresentation.Slides(1).Shapes
    Set tr = .Item(1).TextFrame.TextRange
    Set roundRect = .AddShape(msoShapeRoundedRectangle, _
        tr.BoundLeft, tr.BoundTop, tr.BoundWidth, tr.BoundHeight)
End With
With roundRect.Fill
    .ForeColor.RGB = RGB(255, 0, 128)
    .Transparency = 0.75
End With


Brightness-Eigenschaft

Gibt die Helligkeit für die angegebene Grafik oder das OLE-Objekt zurück oder legt diese fest. Der Wert für diese Eigenschaft muss im Bereich von 0,0 (am stärksten abgeblendet) bis 1,0 (am hellsten) liegen. Single Schreib-Lese-Zugriff.


Beispiel zur Brightness-Eigenschaft

Dieses Beispiel legt die Helligkeit für Form 1 in myDocument fest. Bei Form 1 muss es sich um eine Grafik oder ein OLE-Objekt handeln.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).PictureFormat.Brightness = 0.3


Build-Eigenschaft

Gibt die Build-Nummer von PowerPoint zurück. String Nur-Lese-Zugriff.


Beispiel zur Build-Eigenschaft

Dieses Beispiel zeigt die Buildnummer von PowerPoint an.

MsgBox Prompt:=Application.Build, Title:="PowerPoint Build"


BuiltInDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle integrierten Dokumenteigenschaften für die angegebene Präsentation darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Verwenden Sie die CustomDocumentProperties-Eigenschaft, um die Auflistung benutzerdefinierter Dokumenteigenschaften zurückzugeben.


Beispiel zur BuiltInDocumentProperties-Eigenschaft

In diesem Beispiel werden die Namen aller integrierten Dokumenteigenschaften für die aktive Präsentation angezeigt.

For Each p In Application.ActivePresentation _
        .BuiltInDocumentProperties
    bidpList = bidpList & p.Name & Chr$(13)
Next
MsgBox bidpList

In diesem Beispiel wird die integrierte Eigenschaft "Kategorie" für die aktive Präsentation festgelegt, wenn der Name des Autors der Präsentation Jake Jarmel lautet.

With Application.ActivePresentation.BuiltInDocumentProperties
    If .Item("author").Value = "Jake Jarmel" Then
        .Item("category").Value = "Creative Writing"
    End If
End With


Bullet-Eigenschaft

Gibt ein BulletFormat-Objekt zurück, das die Formatierung der Aufzählungszeichen für das angegebene Absatzformat darstellt. Nur-Lese-Zugriff.


Beispiel zur Bullet-Eigenschaft

In diesem Beispiel werden Größe und Farbe der Aufzählungszeichen der Absätze von Form 2 in Folie 1 der aktiven Präsentation festgelegt.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat.Bullet
        .Visible = True
        .RelativeSize = 1.25
        .Font.Color = RGB(255, 0, 255)
    End With
End With


Callout-Eigenschaft

Gibt ein CalloutFormat-Objekt zurück, das Formateigenschaften für Legenden für die angegebene Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die Legendenlinien darstellen. Nur-Lese-Zugriff.


Beispiel zur Callout-Eigenschaft

Dieses Beispiel fügt zu myDocument ein Oval und eine Legende hinzu, die auf das Oval deutet. Der Legendentext hat keinen Rahmen, sondern eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


Caption-Eigenschaft

Application-Objekt: Gibt den Text zurück, der in der Titelleiste des Anwendungsfensters angezeigt wird. String Schreib-Lese-Zugriff.

DocumentWindow-Objekt: Gibt den Text zurück, der in der Titelleiste des Dokumentfensters angezeigt wird. String Nur-Lese-Zugriff.


Beispiel zur Caption-Eigenschaft

In diesem Beispiel wird die Unter- bzw. Überschrift für jedes offene Dokumentfenster angezeigt.

With Application.Windows
    For w = 1 To .Count
        MsgBox "Window " & w & " contains " & .Item(1).Caption
    Next
End With


Cells-Eigenschaft

Gibt eine CellRange-Auflistung zurück, die die Zellen in einer Tabellenspalte oder -zeile darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Cells-Eigenschaft

In diesem Beispiel wird eine neue Präsentation erstellt, eine Folie hinzugefügt, eine Tabelle mit drei Spalten und drei Zeilen auf der Folie eingefügt und jeder Zelle in der Tabelle die Spalten- und Zeilennummer zugewiesen.

Dim i As Integer
Dim j As Integer
With Presentations.Add
    .Slides.Add(1, ppLayoutBlank).Shapes.AddTable(3, 3).Select
    Set myTable = .Slides(1).Shapes(1).Table
    For i = 1 To myTable.Columns.Count
        For j = 1 To myTable.Columns(i).Cells.Count
            myTable.Columns(i).Cells(j).Shape.TextFrame _
                .TextRange.Text = "col. " & i & "row " & j
        Next j
    Next i
End With


Character-Eigenschaft

Gibt das Unicode-Zeichen zurück, das für Aufzählungszeichen im angegebenen Text verwendet wird, oder legt das Zeichen fest. Long Schreib-Lese-Zugriff.


Beispiel zur Character-Eigenschaft

Dieses Beispiel legt das Aufzählungszeichen für Form 2 in Folie 1 der aktiven Präsentation fest.

Set frame2 = ActivePresentation.Slides(1).Shapes(2).TextFrame
With frame2.TextRange.ParagraphFormat.Bullet
    .Character = 8226
    .Visible = True
End With


ChartUnitEffect-Eigenschaft

Gibt einen Wert zurück, der anzeigt, ob der Diagrammbereich nach Datenreihen, Kategorie oder Element animiert wird, oder legt diesen Wert fest. Dies kann einer der folgenden ChartUnitEffect-Werte sein: ppAnimateByCategory, ppAnimateByCategoryElements, ppAnimateBySeries, ppAnimateBySeriesElements oder ppAnimateChartMixed. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Ihr Graph nicht animiert wird, vergewissern Sie sich, dass für die Animate-Eigenschaft True festgelegt ist.


Beispiel zur ChartUnitEffect-Eigenschaft

Dieses Beispiel legt fest, dass Form 2 in Folie 3 der aktiven Präsentation nach Datenreihen animiert wird. Form 2 muss ein Graph sein.

With ActivePresentation.Slides(3).Shapes(2)
    With .AnimationSettings
        .ChartUnitEffect = ppAnimateBySeries
        .EntryEffect = ppEffectFlyFromLeft
        .Animate = True
    End With
End With


CheckIfOfficeIsHTMLEditor-Eigenschaft

True, wenn Microsoft PowerPoint überprüft, ob eine Office-Anwendung beim Starten von PowerPoint der Standard-HTML-Editor ist. False, wenn PowerPoint diese Prüfung nicht ausführt. Der Standardwert ist True. Long Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft wird nur verwendet, wenn der verwendete Webbrowser die Bearbeitung in HTML und HTML-Editoren unterstützt.

Wenn Sie einen anderen HTML-Editor verwenden möchten, müssen Sie diese Eigenschaft auf False setzen und dann den Editor als Standard-HTML-Editor des Systems registrieren.


Beispiel zur CheckIfOfficeIsHTMLEditor-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft PowerPoint nicht überprüft, ob eine Office-Anwendung der Standard-HTML-Editor ist.

Application.DefaultWebOptions.CheckIfOfficeIsHTMLEditor = False


Collate-Eigenschaft

True, wenn eine vollständige Kopie der angegebenen Präsentation gedruckt wird, bevor die erste Seite der nächsten Kopie gedruckt wird. Der Standardwert ist True. Long Schreib-Lese-Zugriff.

Anmerkungen

Mit der Angabe des Werts für das Collate-Argument der PrintOut-Methode wird der Wert dieser Eigenschaft festgelegt.


Beispiel zur Collate-Eigenschaft

Dieses Beispiel druckt drei sortierte Kopien der aktiven Präsentation.

With ActivePresentation.PrintOptions
    .NumberOfCopies = 3
    .Collate = True
    .Parent.PrintOut
End With


Color-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Farbe für die angegebenen Zeichen darstellt. Nur-Lese-Zugriff.


ColorScheme-Eigenschaft

Gibt das ColorScheme-Objekt zurück, das die Farben der Skala für die angegebenen Folien, den Folienbereich oder den Folienmaster darstellt, oder legt dieses fest. Schreib-Lese-Zugriff.


ColorSchemes-Eigenschaft

Gibt eine ColorSchemes-Auflistung zurück, die alle Farbskalen in der angegebenen Präsentation darstellt. Nur-Lese-Zugriff.


Beispiel zur ColorSchemes-Eigenschaft

In diesem Beispiel wird die Hintergrundfarbe für Farbskala drei in der aktiven Präsentation festgelegt und dann allen Folien der Präsentation, die auf der Master-Folie basieren, die Farbskala zugewiesen.

With ActivePresentation
    Set cs1 = .ColorSchemes(3)
    cs1.Colors(ppBackground).RGB = RGB(128, 128, 0)
    .SlideMaster.ColorScheme = cs1
End With


ColorType-Eigenschaft

Gibt den Typ der Farbtransformation zurück, der der angegebenen Grafik oder dem OLE-Objekt zugewiesen wird, oder legt diesen Typ fest. Dies kann eine der folgenden MsoPictureColorType-Konstanten sein: msoPictureAutomatic, msoPictureBlackAndWhite, msoPictureGrayscale, msoPictureMixed oder msoPictureWatermark. Long Schreib-Lese-Zugriff.


Beispiel zur ColorType-Eigenschaft

Dieses Beispiel legt als Farbtransformation eine Graustufe für Form 1 in myDocument fest. Bei Form 1 muss es sich um eine Grafik oder ein OLE-Objekt handeln.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).PictureFormat.ColorType = msoPictureGrayScale


Columns-Eigenschaft

Gibt eine Columns-Auflistung zurück, die alle Spalten in einer Tabelle darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Columns-Eigenschaft

In diesem Beispiel wird die Nummer der Form, die Foliennummer und die Anzahl der Spalten in der ersten Tabelle der aktiven Präsentation angezeigt.

Dim ColCount As Integer
Dim sl As Integer
Dim sh As Integer

With ActivePresentation
    For sl = 1 To .Slides.Count
        For sh = 1 To .Slides(sl).Shapes.Count
            If .Slides(sl).Shapes(sh).HasTable Then
                ColCount = .Slides(sl).Shapes(sh) _
                    .Table.Columns.Count
                MsgBox "Shape " & sh & " on slide " & sl & _
                    " contains the first table and has " & _
                    ColCount & " columns."
                Exit Sub
            End If
        Next
    Next
End With

In diesem Beispiel wird die ausgewählte Form überprüft, ob diese eine Tabelle enthält. Wenn dies der Fall ist, stellt der Code die Breite der Spalte 1 auf 72 Punkt (1 Zoll, ca. 2,54 cm) ein.

With ActiveWindow.Selection.ShapeRange
    If .HasTable = True Then
       .Table.Columns(1).Width = 72
    End If
End With


 COMAddIns-Eigenschaft

COMAddIns-Eigenschaft

Gibt einen Bezug zur COMAddIns-Auflistung zurück, die alle Component Object Model (COM)-Add-Ins darstellt, die aktuell in Microsoft PowerPoint geladen sind. Diese sind im Dialogfeld COM-Add-Ins aufgeführt. Sie können dem Menü Extras den Befehl COM-Add-Ins hinzufügen, indem Sie das Dialogfeld Anpassen verwenden (Menü Extras). Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


CommandBars-Eigenschaft

Application-Objekt: Gibt eine CommandBars-Auflistung zurück, die alle Befehlsleisten von PowerPoint darstellt. Nur-Lese-Zugriff.

Presentation-Objekt: Gibt eine CommandBars-Auflistung zurück, die die vereinigte Menge der Befehlsleisten der Hostcontaineranwendung und PowerPoint darstellt. Diese Eigenschaft gibt nur ein gültiges Objekt zurück, wenn der Container ein DocObject-Server ist, wie beispielsweise Microsoft Sammelmappe, und PowerPoint als OLE-Server fungiert. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur CommandBars-Eigenschaft

In diesem Beispiel werden alle Schaltflächen der Befehlsleiste vergrößert und die QuickInfo aktiviert.

With Application.CommandBars
    .LargeButtons = True
    .DisplayTooltips = True
End With

In diesem Beispiel wird die Befehlsleiste Format mit der vereinigten Menge der Befehlsleisten oben im Anwendungsfenster angezeigt.

With ActivePresentation.CommandBars("Formatting")
    .Visible = True
    .Position = msoBarTop
End With


ConnectionSiteCount-Eigenschaft

Gibt die Anzahl der Verbindungspunkte in der angegebenen Form zurück. Long Nur-Lese-Zugriff.


Beispiel zur ConnectionSiteCount-Eigenschaft

Dieses Beispiel fügt in myDocument zwei Rechtecke hinzu und verbindet diese mit zwei Verbindungen. Der Anfang von beiden Verbindungen wird mit dem Verbindungspunkt 1 im ersten Rechteck zusammengefügt. Die Enden der Verbindungen werden mit dem ersten und dem letzten Verbindungspunkt des zweiten Rechtecks zusammengefügt.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
lastsite = secondRect.ConnectionSiteCount
With s.AddConnector(msoConnectorCurve, 0, 0, 100, 100) _
        .ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
End With
With s.AddConnector(msoConnectorCurve, 0, 0, 100, 100) _
        .ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, _
        ConnectionSite:=lastsite
End With


Connector-Eigenschaft

True, wenn die angegebene Form eine Verbindung ist. Long Nur-Lese-Zugriff.


ConnectorFormat-Eigenschaft

Gibt ein ConnectorFormat-Objekt zurück, das die Formateigenschaften für Verbindungen enthält. Betrifft Shape- oder ShapeRange-Objekte, die Verbindungen darstellen. Nur-Lese-Zugriff.


Beispiel zur ConnectorFormat-Eigenschaft

Dieses Beispiel fügt zwei Rechtecke zu myDocument hinzu, fügt diese mit einer Verbindung zusammen, erstellt die Verbindung entlang des kürzesten Pfads neu und löst anschließend die Verbindung mit den Rechtecken.

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(msoConnectorCurve, 0, 0, 0, 0).ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    .Parent.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


Container-Eigenschaft

Gibt das Objekt zurück, das die angegebene, eingebettete Präsentation enthält. Object Nur-Lese-Zugriff.

Hinweis Wenn die Containeranwendung keine OLE-Automatisierung unterstützt oder die angegebene Präsentation nicht in eine Microsoft Sammelmappe-Datei eingebettet ist, schlägt diese Eigenschaft fehl.


Beispiel zur Container-Eigenschaft

In diesem Beispiel wird der zweite Abschnitt der Microsoft Sammelmappe-Datei ausgeblendet, die die eingebettete aktive Präsentation enthält. Die Container-Eigenschaft der Präsentation gibt ein Section-Objekt zurück, und die Parent-Eigenschaft des Section-Objekts gibt ein Binder-Objekt zurück.

Application.ActivePresentation.Container.Parent.Sections(2) _
    .Visible = False


Contrast-Eigenschaft

Gibt den Kontrast für die angegebene Grafik oder das OLE-Objekt zurück oder legt diesen fest. Der Wert für diese Eigenschaft muss im Bereich von 0,0 (geringster Kontrast) bis 1,0 (höchster Kontrast) liegen. Single Schreib-Lese-Zugriff.


Beispiel zur Contrast-Eigenschaft

Dieses Beispiel legt den Kontrast für Form 1 in myDocument fest. Bei Form 1 muss es sich um eine Grafik oder ein OLE-Objekt handeln.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).PictureFormat.Contrast = 0.8


Count-Eigenschaft

Gibt die Anzahl der Objekte in der angegebenen Auflistung zurück. Long Nur-Lese-Zugriff.


Beispiel zur Count-Eigenschaft

In diesem Beispiel werden alle Fenster mit Ausnahme des aktiven Fensters geschlossen.

With Application.Windows
    For i = 2 To .Count
        .Item(2).Close
    Next
End With


Creator-Eigenschaft

Gibt eine 32-Bit-Ganzzahl zurück, die den aus vier Zeichen bestehenden Ersteller-Code für die Anwendung darstellt, in der das angegebene Objekt erstellt wurde. Wurde das Objekt z. B. in PowerPoint erstellt, gibt diese Eigenschaft die Hexadezimalzahl 50505433 zurück, die die Zeichenfolge "PPT3" darstellt. Long Nur-Lese-Zugriff.

Anmerkungen

Die Creator-Eigenschaft wurde für Microsoft Office-Anwendungen bei Macintosh entwickelt.


Beispiel zur Creator-Eigenschaft

Dieses Beispiel zeigt eine Meldung über den Ersteller von myObject an.

Set myObject = Application.ActivePresentation.Slides(1).Shapes(1)
If myObject.Creator = &h50505433 Then
    MsgBox "This is a PowerPoint object"
Else
    MsgBox "This is not a PowerPoint object"
End If


CropBottom-Eigenschaft

Gibt die Anzahl der Punkte zurück, die von der Unterseite der angegebenen Grafik oder dem OLE-Objekt zugeschnitten sind, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Das Zuschneiden wird relativ zur ursprünglichen Größe der Grafik berechnet. Wenn Sie z. B. eine Grafik mit der ursprünglichen Höhe von 100 Punkt einfügen, diese auf 200 Punkt Höhe neu skalieren und anschließend für die CropBottom-Eigenschaft 50 festlegen, werden 100 Punkt (nicht 50) von der Unterseite Ihrer Grafik zugeschnitten.


Beispiel zur CropBottom-Eigenschaft

Dieses Beispiel schneidet 20 Punkt von der Unterseite von Form 3 von myDocument zu. Damit dieses Beispiel funktioniert, muss Form 3 entweder eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).PictureFormat.CropBottom = 20

Dieses Beispiel schneidet den vom Benutzer angegebenen Prozentsatz von der Unterseite der markierten Form zu. Es ist nicht von Bedeutung, ob die Form skaliert wurde. Damit dieses Beispiel funktioniert, muss die markierte Form entweder eine Grafik oder ein OLE-Objekt sein.

percentToCrop = InputBox("What percentage do you " & _
    "want to crop off the bottom of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropBottom = cropPoints


CropLeft-Eigenschaft

Gibt die Anzahl der Punkte zurück, die von der linken Seite der angegebenen Grafik oder dem OLE-Objekt zugeschnitten sind, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Das Zuschneiden wird relativ zur ursprünglichen Größe der Grafik berechnet. Wenn Sie z. B. eine Grafik mit der ursprünglichen Breite von 100 Punkt einfügen, diese auf 200 Punkt Breite neu skalieren und anschließend für die CropLeft-Eigenschaft 50 festlegen, werden 100 Punkt (nicht 50) von der linken Seite Ihrer Grafik zugeschnitten.


Beispiel zur CropLeft-Eigenschaft

Dieses Beispiel schneidet 20 Punkt von der linken Seite von Form 3 von myDocument zu. Damit dieses Beispiel funktioniert, muss Form 3 entweder eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).PictureFormat.CropLeft = 20

Dieses Beispiel schneidet den vom Benutzer angegebenen Prozentsatz von der linken Seite der markierten Form zu. Es ist nicht von Bedeutung, ob die Form skaliert wurde. Damit dieses Beispiel funktioniert, muss die markierte Form entweder eine Grafik oder ein OLE-Objekt sein.

percentToCrop = InputBox("What percentage do you " & _
    "want to crop off the left of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropLeft = cropPoints


CropRight-Eigenschaft

Gibt die Anzahl der Punkte zurück, die von der rechten Seite der angegebenen Grafik oder dem OLE-Objekt zugeschnitten sind, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Das Zuschneiden wird relativ zur ursprünglichen Größe der Grafik berechnet. Wenn Sie z. B. eine Grafik mit der ursprünglichen Breite von 100 Punkt einfügen, diese auf 200 Punkt Breite neu skalieren und anschließend für die CropRight-Eigenschaft 50 festlegen, werden 100 Punkt (nicht 50) von der rechten Seite Ihrer Grafik zugeschnitten.


Beispiel zur CropRight-Eigenschaft

Dieses Beispiel schneidet 20 Punkt von der rechten Seite von Form 3 von myDocument zu. Damit dieses Beispiel funktioniert, muss Form 3 entweder eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).PictureFormat.CropRight = 20

Dieses Beispiel schneidet den vom Benutzer angegebenen Prozentsatz von der rechten Seite der markierten Form zu. Es ist nicht von Bedeutung, ob die Form skaliert wurde. Damit dieses Beispiel funktioniert, muss die markierte Form entweder eine Grafik oder ein OLE-Objekt sein.

percentToCrop = InputBox("What percentage do you " & _
    "want to crop off the right of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropRight = cropPoints


CropTop-Eigenschaft

Gibt die Anzahl der Punkte zurück, die von der Oberseite der angegebenen Grafik oder dem OLE-Objekt zugeschnitten sind, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Das Zuschneiden wird relativ zur ursprünglichen Größe der Grafik berechnet. Wenn Sie z. B. eine Grafik mit der ursprünglichen Höhe von 100 Punkt einfügen, diese auf 200 Punkt Höhe neu skalieren und anschließend für die CropTop-Eigenschaft 50 festlegen, werden 100 Punkt (nicht 50) von der Oberseite Ihrer Grafik zugeschnitten.


Beispiel zur CropTop-Eigenschaft

Dieses Beispiel schneidet 20 Punkt von der Oberseite von Form 3 von myDocument zu. Damit dieses Beispiel funktioniert, muss Form 3 entweder eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).PictureFormat.CropTop = 20

Dieses Beispiel schneidet den vom Benutzer angegebenen Prozentsatz von der Oberseite der markierten Form zu. Es ist nicht von Bedeutung, ob die Form skaliert wurde. Damit dieses Beispiel funktioniert, muss die markierte Form entweder eine Grafik oder ein OLE-Objekt sein.

percentToCrop = InputBox("What percentage do you " & _
    "want to crop off the top of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropTop = cropPoints


CurrentShowPosition-Eigenschaft

Gibt die Position der aktuellen Folie innerhalb der Bildschirmpräsentation in der angegebenen Ansicht zurück. Long Nur-Lese-Zugriff.

Hinweise

Wenn die angegebene Ansicht eine benutzerdefinierte Bildschirmpräsentation enthält, gibt die CurrentShowPosition-Eigenschaft die Position der aktuellen Folie innerhalb der benutzerdefinierten Präsentation zurück und nicht die Position der aktuellen Folie innerhalb der gesamten Präsentation.


Beispiel zur CurrentShowPosition-Eigenschaft

In diesem Beispiel wird eine Variable auf die Position der aktuellen Folie in der Bildschirmpräsentation gesetzt, die im Fenster 1 der Bildschirmpräsentation ausgeführt wird.

lastSlideSeen = SlideShowWindows(1).View.CurrentShowPosition


CustomDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle benutzerdefinierten Dokumenteigenschaften für die angegebene Präsentation darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Verwenden Sie die BuiltInDocumentProperties-Eigenschaft, um die Auflistung der integrierten Dokumenteigenschaften zurückzugeben.


Beispiel zur CustomDocumentProperties-Eigenschaft

In diesem Beispiel wird der aktiven Präsentation eine statische benutzerdefinierte Eigenschaft mit dem Namen "Complete" hinzugefügt.

Application.ActivePresentation.CustomDocumentProperties _
    .Add Name:="Complete", LinkToContent:=False, _
    Type:=msoPropertyTypeBoolean, Value:=False

In diesem Beispiel wird die aktive Präsentation gedruckt, wenn die benutzerdefinierte Eigenschaft "Complete" True ist.

With Application.ActivePresentation
    If .CustomDocumentProperties("complete") Then .PrintOut
End With


DashStyle-Eigenschaft

Gibt die Strichart der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoLineDashStyle-Konstanten sein: msoLineDash, msoLineDashDot, msoLineDashDotDot, msoLineDashStyleMixed, msoLineLongDash, msoLineLongDashDot, msoLineRoundDot, msoLineSolid oder msoLineSquareDot. Long Schreib-Lese-Zugriff.


Beispiel zur DashStyle-Eigenschaft

Dieses Beispiel fügt zu myDocument eine blaue, gestrichelte Linie hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


DateAndTime-Eigenschaft

Gibt ein HeaderFooter-Objekt zurück, das das Element für Datum und Uhrzeit darstellt, das unten links in einer Folie oder oben rechts in einer Notizzettelseite, einem Handzettel oder einer Gliederung angezeigt wird. Nur-Lese-Zugriff.


Beispiel zur DateAndTime-Eigenschaft

In diesem Beispiel wird das Format für Datum und Uhrzeit für den Folienmaster der aktiven Präsentation festgelegt. Diese Einstellung wird allen Folien zugewiesen, die auf diesem Master basieren.

Set myPres = Application.ActivePresentation
With myPres.SlideMaster.HeadersFooters.DateAndTime
    .Format = ppDateTimeMdyy
    .UseFormat = True
End With


DefaultLanguageID-Eigenschaft

Gibt die Standardsprache einer Präsentation zurück oder legt diese fest. Wenn Sie die DefaultLanguageID-Eigenschaft festlegen, gilt diese Einstellung auch für alle folgenden Präsentationen. Long Schreib-Lese-Zugriff. Es kann sich um eine der folgenden MsoLanguageID-Konstanten handeln:

msoLanguageIDAfrikaans

msoLanguageIDArabic

msoLanguageIDBasque

msoLanguageIDBelgianDutch

msoLanguageIDBelgianFrench

msoLanguageIDBrazilianPortuguese

msoLanguageIDBulgarian

msoLanguageIDByelorussian

msoLanguageIDCatalan

msoLanguageIDCroatian

msoLanguageIDCzech

msoLanguageIDDanish

msoLanguageIDDutch

msoLanguageIDEnglishAUS

msoLanguageIDEnglishCanadian

msoLanguageIDEnglishNewZealand

msoLanguageIDEnglishSouthAfrica

msoLanguageIDEnglishUK

msoLanguageIDEnglishUS

msoLanguageIDEstonian

msoLanguageIDFarsi

msoLanguageIDFinnish

msoLanguageIDFrench

msoLanguageIDFrenchCanadian

msoLanguageIDGerman

msoLanguageIDGreek

msoLanguageIDHebrew

msoLanguageIDHungarian

msoLanguageIDIcelandic

msoLanguageIDItalian

msoLanguageIDJapanese

msoLanguageIDKorean

 msoLanguageIDLatvian

msoLanguageIDMacedonian

msoLanguageIDMalaysian

msoLanguageIDMexicanSpanish

msoLanguageIDMixed

msoLanguageIDNone

msoLanguageIDNoProofing

msoLanguageIDNorwegianBokmol

msoLanguageIDNorwegianNynorsk

msoLanguageIDPolish

msoLanguageIDPortuguese

msoLanguageIDRomanian

msoLanguageIDRussian

msoLanguageIDSerbianCyrillic

msoLanguageIDSerbianLatin

msoLanguageIDSesotho

msoLanguageIDSimplifiedChinese

msoLanguageIDSlovak

msoLanguageIDSlovenian

msoLanguageIDSpanish

msoLanguageIDSpanishModernSort

msoLanguageIDSwedish

msoLanguageIDSwissFrench

msoLanguageIDSwissGerman

msoLanguageIDSwissItalian

msoLanguageIDTraditionalChinese

msoLanguageIDTsonga

msoLanguageIDTswana

msoLanguageIDTurkish

msoLanguageIDUkrainian

msoLanguageIDVenda

msoLanguageIDXhosa

msoLanguageIDZulu

Hinweise

Mit der Eigenschaft LanguageID können Sie für einzelne Textabschnitte andere Sprachen setzen. Allen Abschnitten, für die nicht ausdrücklich eine andere Sprache gesetzt wurde, wird diese Standardsprache zugewiesen.


Beispiel zur DefaultLanguageID-Eigenschaft

In diesem Beispiel wird Deutsch als Standardsprache für die aktive Präsentation sowie für alle folgenden neuen Präsentationen festgelegt.

ActivePresentation.DefaultLanguageID = msoLanguageIDGerman


 DefaultShape-Eigenschaft

DefaultShape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Standardform für die Präsentation darstellt. Nur-Lese-Zugriff.


Beispiel zur DefaultShape-Eigenschaft

In diesem Beispiel wird Folie 1 in der aktiven Präsentation eine Form hinzugefügt und die Füllfarbe Rot als Standard für die Formen der Präsentation festgelegt. Anschließend wird eine neue Form hinzugefügt, der die Standardfüllfarbe automatisch zugewiesen wird.

With Application.ActivePresentation
    Set sld1Shapes = .Slides(1).Shapes
    sld1Shapes.AddShape msoShape16pointStar, 20, 20, 100, 100
    .DefaultShape.Fill.ForeColor.RGB = RGB(255, 0, 0)
    sld1Shapes.AddShape msoShape16pointStar, 150, 20, 100, 100
End With


DefaultSpacing-Eigenschaft

Gibt den Abstand für den Standard-Tabstop für den angegebenen Text in Punkt zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.


Beispiel zur DefaultSpacing-Eigenschaft

In diesem Beispiel wird der Abstand für den Standard-Tabstop auf 0,5 Zoll (36 Punkt) für den Text von Form 2 in Folie 1 der aktiven Präsentation festgelegt.

Application.ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .Ruler.TabStops.DefaultSpacing = 36


DefaultWebOptions-Eigenschaft

Gibt das DefaultWebOptions-Objekt zurück, in dem sich Attribute für die gesamte Anwendungsebene befinden, die von Microsoft PowerPoint verwendet werden, wenn Sie eine Präsentation ganz oder teilweise als Webseite veröffentlichen oder speichern bzw. wenn Sie eine Webseite öffnen. Nur-Lese-Zugriff.


Beispiel zur DefaultWebOptions-Eigenschaft

In diesem Beispiel wird überprüft, ob die Standarddokumentcodierung auf Westlich eingestellt ist. Ist dies der Fall, wird die Zeichenfolge strDocEncoding entsprechend eingestellt.

Set objAppWebOptions = Application.DefaultWebOptions
With objAppWebOptions
    If .Encoding = msoEncodingWestern Then
        strDocEncoding = "Western"
    End If
End With


Depth-Eigenschaft

Gibt die Tiefe der Projektion der Form zurück oder legt sie fest. Es kann ein Wert zwischen -600 und 9600 sein (positive Werte erzeugen eine Projektion, deren Vorderseite die Originalform ist; negative Werte erzeugen eine Projektion, deren Rückseite die Originalform ist). Single Schreib-Lese-Zugriff.


Beispiel zur Depth-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Oval hinzugefügt und anschließend festgelegt, dass das Oval auf eine Tiefe von 50 Punkt projiziert wird und die Projektion die Farbe Purpurrot erhält.

Set myDocument = ActivePresentation.Slides(1)
Set myShape = myDocument.Shapes _
    .AddShape(msoShapeOval, 90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    'RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With


DimColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Farbe der angegebenen Form nach dessen Aufbau darstellt, oder legt dieses Objekt fest. Nur-Lese-Zugriff.

Anmerkungen

Wenn Sie nicht den erwarteten Effekt erzielen, prüfen Sie die anderen Einstellungen für den Aufbau. Sie können den Effekt der DimColor-Eigenschaft erst dann sehen, wenn Sie für die TextLevelEffect-Eigenschaft des AnimationSettings-Objekts etwas anderes als ppAnimateLevelNone, für die AfterEffect-Eigenschaft ppAfterEffectDim und für die Animate-Eigenschaft True festgelegt haben. Handelt es sich bei der angegebenen Form außerdem um das einzige Element bzw. um das zuletzt aufgebaute Element der Folie, wird die Form nicht abgeblendet. Um die Anordnung des Aufbaus der Formen in einer Folie ändern zu können, verwenden Sie die AnimationOrder-Eigenschaft.


Beispiel zur DimColor-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation eine Folie hinzu, die sowohl einen Titel als auch eine Liste mit drei Elementen enthält, und legt fest, dass der Titel und die Liste nach dem Aufbau abgeblendet werden. Außerdem legt dieses Beispiel die jeweilige Farbe für das Abblenden fest.

With ActivePresentation.Slides.Add(2, ppLayoutText).Shapes
    With .Item(1)
        .TextFrame.TextRange.Text = "Sample title"
        With .AnimationSettings
            .TextLevelEffect = ppAnimateByAllLevels
            .AfterEffect = ppAfterEffectDim
            .DimColor.SchemeColor = ppShadow
            .Animate = True
        End With
    End With
    With .Item(2)
        .TextFrame.TextRange.Text = "Item one" _
            & Chr(13) & "Item two"
        With .AnimationSettings
            .TextLevelEffect = ppAnimateByFirstLevel
            .AfterEffect = ppAfterEffectDim
            .DimColor.RGB = RGB(100, 150, 130)
            .Animate = True
        End With
    End With
End With


DisplayComments-Eigenschaft

True, wenn in der angegebenen Präsentation Kommentare angezeigt werden. Long Schreib-Lese-Zugriff.


Beispiel zur DisplayComments-Eigenschaft

Dieses Beispiel blendet Kommentare in der aktiven Präsentation aus.

ActivePresentation.DisplayComments = False


DisplayMasterShapes-Eigenschaft

True, wenn die angegebene Folie oder der angegebene Folienbereich die Hintergrundobjekte im Folienmaster anzeigt. Diese Hintergrundobjekte können Text, Zeichnungen, OLE-Objekte, und ClipArt enthalten, die Sie dem Folienmaster hinzufügen. Kopf- und Fußzeilen werden nicht berücksichtigt. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie eine neue Folie erstellen, gilt als Standardwert für diese Eigenschaft True. Kopieren Sie eine Folie von einer anderen Präsentation, behält sie die Einstellungen aus der Originalpräsentation bei. Das heißt, wenn die Folie die Hintergrundobjekte des Folienmasters in der Originalpräsentation weggelassen hat, werden diese auch in der neuen Präsentation weggelassen.

Beachten Sie, dass das Erscheinungsbild des Hintergrunds der Folie von der Farbskala und den Hintergrundobjekten sowie vom Hintergrund selbst bestimmt wird. Erzielen Sie mit der DisplayMasterShapes-Eigenschaft nicht die gewünschten Ergebnisse, verwenden Sie auch die FollowMasterBackground- und ColorScheme-Eigenschaft.


Beispiel zur DisplayMasterShapes-Eigenschaft

Dieses Beispiel kopiert Folie 1 von Präsentation 2, fügt die Folie an das Ende von Präsentation 1 ein, und passt den Hintergrund, die Farbskala und die Hintergrundobjekte der Folie dem Rest von Präsentation 1 an.

Presentations(2).Slides(1).Copy
With Presentations(1).Slides.Paste
    .FollowMasterBackground = True
    .ColorScheme = Presentations(1).SlideMaster.ColorScheme
    .DisplayMasterShapes = True
End With


DisplayOnTitleSlide-Eigenschaft

True, wenn die Fußzeile, das Datum und die Uhrzeit sowie die Foliennummer in der Titelfolie erscheinen. False, wenn diese Informationen in allen Folien außer der Titelfolie erscheinen. Gilt für Folienmaster. Long Schreib-Lese-Zugriff.


Beispiel zur DisplayOnTitleSlide-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Fußzeile, das Datum und die Uhrzeit sowie die Foliennummer nicht in der Titelfolie erscheinen.

Application.ActivePresentation.SlideMaster.HeadersFooters _
    .DisplayOnTitleSlide = False


DisplaySlideMiniature-Eigenschaft

True, wenn das Miniaturbildfenster automatisch angezeigt wird und das Dokumentfenster im Schwarzweißmodus angezeigt wird, das Fenster der Folie auf mehr als 150% der prozentualen Vergrößerung der Ansicht bei optimaler Anpassung an das Dokumentfenster vergrößert ist oder die Masteransicht angezeigt wird. False, wenn das Miniaturbildfenster nicht automatisch angezeigt wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist in der Bildschirmpräsentationsansicht und der Foliensortierungsansicht nicht verfügbar. Das Miniaturbildfenster ist weder ein Element der Windows-Auflistung noch der SlideShowWindows-Auflistung.

Die prozentuale Vergrößerung bei optimaler Anpassung bestimmt sich aus der Foliengröße und der Größe des Präsentationsfensters. Um den Wert der prozentualen Vergrößerung zu ermitteln, setzen Sie die ZoomToFit-Eigenschaft auf True und fragen dann den Wert der Zoom-Eigenschaft ab.


Beispiel zur DisplaySlideMiniature-Eigenschaft

Wenn sich Dokumentfenster eins in der Folienansicht befindet, wird mit dem folgenden Beispiel das Miniaturbild-Fenster angezeigt.

With Windows(1).View
    If .Type = ppViewSlide Then .DisplaySlideMiniature = True
End With


Drop-Eigenschaft

Diese Eigenschaft gibt bei Legenden mit einem explizit festgelegten Bezugswert den vertikalen Abstand von der Seite des Textbegrenzungsrechtecks zu der Stelle in Punkt zurück, wo sich die Legendenlinie mit dem Textfeld verbindet. Dieser Abstand wird von der oberen Seite des Textfeldes gemessen, es sei denn, für die AutoAttach-Eigenschaft gilt True, und das Textfeld befindet sich links vom Ursprung der Legendenlinie (die Stelle, auf die die Legende deutet). In diesem Fall wird der Bezugsabstand von der unteren Seite des Textfeldes gemessen. Single Nur-Lese-Zugriff.

Anmerkungen

Mit der CustomDrop-Methode können Sie den Wert für diese Eigenschaft festlegen.

Der Wert für diese Eigenschaft zeigt nur dann die exakte Position der Verbindung der Legendenlinie mit dem Textfeld, wenn die Legende einen explizit festgelegten Bezugswert hat (d. h., wenn als Wert für die DropType-Eigenschaft msoCalloutDropCustom gilt).


DropType-Eigenschaft

Gibt einen Wert zurück, der angibt, wo sich die Legendenlinie mit dem Legendentextfeld verbindet. Dies kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter, msoCalloutDropCustom, msoCalloutDropMixed oder msoCalloutDropTop. Long Nur-Lese-Zugriff.

Anmerkungen

Gilt msoCalloutDropCustom als Bezugstyp der Legende, werden die Werte der Eigenschaften Drop und AutoAttach sowie die relativen Positionen des Legendentextfelds und des Ursprungs der Legendenlinie (die Stelle, auf die die Legende deutet) verwendet, um die Verbindung der Legendenlinie mit dem Textfeld zu bestimmen.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der PresetDrop-Methode können Sie den Wert für diese Eigenschaft festlegen.


Beispiel zur DropType-Eigenschaft

Dieses Beispiel prüft, ob es sich bei Form 3 in myDocument um eine Legende mit einem benutzerdefinierten Bezug handelt. Ist dies der Fall, ersetzt der Code den benutzerdefinierten Bezug durch einen von zwei vordefinierten Bezügen. Welcher Bezug verwendet wird, hängt davon ab, ob der Wert für den benutzerdefinierten Bezug größer oder kleiner als die Hälfte der Höhe des Legenden-Textfelds ist.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Type = msoCallout Then
        With .Callout
            If .DropType = msoCalloutDropCustom Then
                If .Drop < .Parent.Height / 2 Then
                    .PresetDrop msoCalloutDropTop
                Else
                    .PresetDrop msoCalloutDropBottom
                End If
            End If
        End With
    End If
End With


EditingType-Eigenschaft

Ist der angegebene Knoten ein Scheitelpunkt, gibt diese Eigenschaft einen Wert zurück, der anzeigt, wie sich die an dem Knoten vorgenommenen Änderungen auf die beiden Abschnitte auswirken, die mit dem Knoten verbunden sind. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric. Handelt es sich bei dem Knoten um einen Kontrollpunkt für einen gekrümmten Abschnitt, gibt diese Eigenschaft den Bearbeitungstyp des benachbarten Scheitelpunkts zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der SetEditingType-Methode können Sie den Wert für diese Eigenschaft festlegen.


Beispiel zur EditingType-Eigenschaft

Dieses Beispiel ändert alle Eckknoten zu glatten Knoten in Form 3 von myDocument. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


EmailSubject-Eigenschaft

Gibt den Text der Betreffzeile des Hyperlinks zurück oder legt diesen fest. Die Betreffzeile wird an die Internetadresse (URL) des Hyperlinks angehängt. String Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft findet für gewöhnlich bei E-Mail-Hyperlinks Verwendung. Der Wert dieser Eigenschaft hat einen höheren Rang als ein möglicherweise vorhandener E-Mail-Betreff der Address-Eigenschaft des gleichen Hyperlink-Objekts.


Beispiel zur EmailSubject-Eigenschaft

In diesem Beispiel wird die Betreffzeile der E-Mail-Nachricht des ersten Hyperlinks auf der ersten Folie in der aktiven Präsentation festgesetzt.

ActivePresentation.Slides(1).Hyperlinks(1) _
    .EmailSubject = "Quote Request"


Embeddable-Eigenschaft

True, wenn die angegebene Schriftart in die Präsentation eingebettet werden kann. Long Nur-Lese-Zugriff.


Beispiel zur Embeddable-Eigenschaft

Dieses Beispiel überprüft bei jeder Schriftart, die in der aktiven Präsentation verwendet wird, ob diese in die Präsentation eingebettet werden kann.

For Each usedFont In Presentations(1).Fonts
    If usedFont.Embeddable Then
        MsgBox usedFont.Name & ": Embeddable"
    Else
        MsgBox usedFont.Name & ": Not embeddable"
    End If
Next usedFont


Embedded-Eigenschaft

True, wenn die angegebene Schriftart in die Präsentation eingebettet ist. Long Nur-Lese-Zugriff.


Beispiel zur Embedded-Eigenschaft

Dieses Beispiel überprüft bei jeder Schriftart, die in der aktiven Präsentation verwendet wird, ob diese in die Präsentation eingebettet ist.

For Each usedFont In Presentations(1).Fonts
    If usedFont.Embedded Then
        MsgBox usedFont.Name & ": Embedded"
    Else
        MsgBox usedFont.Name & ": Not embedded"
    End If
Next usedFont


Emboss-Eigenschaft

True, wenn die Zeichen hervorgehoben sind, False, wenn die Zeichen nicht hervorgehoben sind, msoTriStateMixed, wenn der angegebene Textbereich sowohl hervorgehobene als auch nicht hervorgehobene Zeichen enthält. Long Schreib-Lese-Zugriff.


Beispiel zur Emboss-Eigenschaft

In diesem Beispiel wird der Titeltext von Folie 1 hervorgehoben formatiert.

Application.ActivePresentation.Slides(1).Shapes.Title _
    .TextFrame.TextRange.Font.Emboss = True


 Encoding-Eigenschaft

Encoding-Eigenschaft

Gibt die Dokumentcodierung (Codepage oder Zeichensatz) zurück oder legt diese fest, mit der der Webbrowser das gespeicherte Dokument darstellen soll. Dabei kann es sich um eine der MsoEncoding-Konstanten handeln, die im Visual Basic-Objektkatalog aufgeführt sind. In der Standardeinstellung ist der Systemzeichensatz festgelegt. Long Schreib-Lese-Zugriff.

Hinweise

Sie können keine der Konstanten mit dem Suffix AutoDetect verwenden. Diese Konstanten werden für die ReloadAs-Methode verwendet.


Beispiel zur Encoding-Eigenschaft

In diesem Beispiel wird überprüft, ob als Standardeinstellung die Dokumentcodierung Westlich festgelegt ist. Anschließend wird die Zeichenfolge strDocEncoding entsprechend festgesetzt.

If Application.DefaultWebOptions.Encoding = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Other"
End If


End-Eigenschaft

Gibt die Nummer der letzten Folie im angegebenen Druckbereich zurück. Long Nur-Lese-Zugriff.


EndArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Ende der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadLength-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Ende der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadStyle-Konstanten sein: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadStyle-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadWidth-Eigenschaft

Gibt die Stärke der Pfeilspitze am Ende der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadWidth-Konstanten sein: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadWidth-Eigenschaft

Dieses Beispiel fügt zu myDocument eine Linie hinzu. Der Anfangspunkt hat ein kurzes, schmales Oval, der Endpunkt hat ein breites Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndConnected-Eigenschaft

True, wenn das Ende der angegebenen Verbindung mit einer Form verbunden ist. Long Nur-Lese-Zugriff.


EndConnectedShape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Form darstellt, mit der das Ende der angegebenen Verbindung zusammengefügt ist. Nur-Lese-Zugriff.

Hinweis Wenn das Ende der angegebenen Verbindung nicht mit einer Form zusammengefügt ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur EndConnectedShape-Eigenschaft

In diesem Beispiel ist die erste Folie der aktiven Präsentation mit zwei Formen gegeben, die mit der Verbindung "Conn1To2." zusammengefügt sind. Der Code fügt der ersten Folie ein Rechteck und eine Verbindung hinzu. Das Ende der Verbindung wird mit dem gleichen Verbindungspunkt zusammengefügt wie das Ende der Verbindung "Conn1To2". Außerdem wird der Anfang der neuen Verbindung mit Verbindungspunkt 1 im neuen Rechteck zusammengefügt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 100, 420, 200, 100)
    .AddConnector(msoConnectorCurve, 0, 0, 10, 10) _
        .Name = "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        endConnSite1 = .EndConnectionSite
        Set endConnShape1 = .EndConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect r3, 1
        .EndConnect endConnShape1, endConnSite1
    End With
End With


EndConnectionSite-Eigenschaft

Gibt eine ganze Zahl zurück, die den Verbindungspunkt angibt, mit dem das Ende einer Verbindung verbunden ist. Long Nur-Lese-Zugriff.

Hinweis Wenn das Ende der angegebenen Verbindung nicht mit einer Form zusammengefügt ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur EndConnectionSite-Eigenschaft

In diesem Beispiel ist die erste Folie der aktiven Präsentation mit zwei Formen gegeben, die mit der Verbindung "Conn1To2." zusammengefügt sind. Der Code fügt der ersten Folie ein Rechteck und eine Verbindung hinzu. Das Ende der Verbindung wird mit dem gleichen Verbindungspunkt zusammengefügt, wie das Ende der Verbindung "Conn1To2". Außerdem wird der Anfang der neuen Verbindung mit Verbindungspunkt 1 im neuen Rechteck zusammengefügt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 100, 420, 200, 100)
    .AddConnector(msoConnectorCurve, 0, 0, 10, 10) _
        .Name = "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        endConnSite1 = .EndConnectionSite
        Set endConnShape1 = .EndConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect r3, 1
        .EndConnect endConnShape1, endConnSite1
    End With
End With


EndingSlide-Eigenschaft

Gibt die letzte Folie zurück, die in der angegebenen Bildschirmpräsentation angezeigt werden soll, oder legt diese fest. Long Schreib-Lese-Zugriff.


Beispiel zur EndingSlide-Eigenschaft

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, die mit Folie 2 beginnt und mit Folie 4 endet.

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowSlideRange
    .StartingSlide = 2
    .EndingSlide = 4
    .Run
End With


EntryEffect-Eigenschaft

Diese Eigenschaft gibt für das AnimationSettings-Objekt den Spezialeffekt zurück, der der Animation für die angegebene Form zugewiesen wurde, oder legt diesen Effekt fest. Diese Eigenschaft gibt für das SlideShowTransition-Objekt den Spezialeffekt zurück, der dem angegebenen Folienübergang zugewiesen wurde, oder legt diesen Effekt fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden PpEntryEffect-Konstanten sein:

ppEffectAppear

ppEffectBlindsHorizontal

ppEffectBlindsVertical

ppEffectBoxIn

ppEffectBoxOut

ppEffectCheckerboardAcross

ppEffectCheckerboardDown

ppEffectCoverDown

ppEffectCoverLeft

ppEffectCoverLeftDown

ppEffectCoverLeftUp

ppEffectCoverRight

ppEffectCoverRightDown

ppEffectCoverRightUp

ppEffectCoverUp

ppEffectCrawlFromDown

ppEffectCrawlFromLeft

ppEffectCrawlFromRight

ppEffectCrawlFromUp

ppEffectCut

ppEffectCutThroughBlack

ppEffectDissolve

ppEffectFade

ppEffectFlashOnceFast

ppEffectFlashOnceMedium

ppEffectFlashOnceSlow

ppEffectFlyFromBottom

ppEffectFlyFromBottomLeft

ppEffectFlyFromBottomRight

ppEffectFlyFromLeft

ppEffectFlyFromRight

ppEffectFlyFromTop

ppEffectFlyFromTopLeft

ppEffectFlyFromTopRight

 ppEffectMixed

ppEffectNone

ppEffectPeekFromDown

ppEffectPeekFromLeft

ppEffectPeekFromRight

ppEffectPeekFromUp

ppEffectRandom

ppEffectRandomBarsHorizontal

ppEffectRandomBarsVertical

ppEffectSplitHorizontalIn

ppEffectSplitHorizontalOut

ppEffectSplitVerticalIn

ppEffectSplitVerticalOut

ppEffectStripsDownLeft

ppEffectStripsDownRight

ppEffectStripsLeftDown

ppEffectStripsLeftUp

ppEffectStripsRightDown

ppEffectStripsRightUp

ppEffectStripsUpLeft

ppEffectStripsUpRight

ppEffectUncoverDown

ppEffectUncoverLeft

ppEffectUncoverLeftDown

ppEffectUncoverLeftUp

ppEffectUncoverRight

ppEffectUncoverRightDown

ppEffectUncoverRightUp

ppEffectUncoverUp

ppEffectWipeDown

ppEffectWipeLeft

ppEffectWipeRight

ppEffectWipeUp

Anmerkungen

Wird für die TextLevelEffect-Eigenschaft der angegebenen Form ppAnimateLevelNone (der Standardwert) festgelegt bzw. gilt für die Animate-Eigenschaft False, dann können Sie den Spezialeffekt nicht sehen, den Sie mit der EntryEffect-Eigenschaft zugewiesen haben.


Beispiel zur EntryEffect-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation eine Titelfolie hinzu und legt fest, dass der Titel mit dem Flugeffekt von rechts kommt, wenn dieser während einer Bildschirmpräsentation animiert wird.

With ActivePresentation.Slides.Add(1, ppLayoutTitleOnly).Shapes(1)
        .TextFrame.TextRange.Text = "Sample title"
    With .AnimationSettings
        .TextLevelEffect = ppAnimateByAllLevels
        .EntryEffect = ppEffectFlyFromRight
        .Animate = True
    End With
End With


EnvelopeVisible-Eigenschaft

True, wenn der E-Mail-Nachrichtenkopf im Dokumentfenster sichtbar ist. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnvelopeVisible-Eigenschaft

In diesem Beispiel wird der E-Mail-Nachrichtenkopf angezeigt.

ActivePresentation.EnvelopeVisible = True


 ExtraColors-Eigenschaft

ExtraColors-Eigenschaft

Gibt ein ExtraColors-Objekt zurück, das die Extra-Farben darstellt, die in der angegebenen Präsentation verfügbar sind. Nur-Lese-Zugriff.


Beispiel zur ExtraColors-Eigenschaft

In diesem Beispiel wird der aktiven Präsentation eine Extrafarbe hinzugefügt (vorausgesetzt, diese Farbe wurde nicht zuvor bereits hinzugefügt). Außerdem wird die Hintergrundfarbe für die Standard-Farbskala festgelegt.

With ActivePresentation
    Set rect = .Slides(1).Shapes _
        .AddShape(msoShapeRectangle, 50, 50, 100, 200)
    rect.Fill.ForeColor.RGB = .ExtraColors(1)
End With


ExtrusionColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Farbe der Projektion der Form darstellt. Nur-Lese-Zugriff.


ExtrusionColorType-Eigenschaft

Gibt einen Wert zurück oder legt einen Wert fest, der angibt, ob die Projektionsfarbe auf dem Füllbereich der projizierten Form basiert (der vorderen Fläche der Projektion) und sich automatisch ändert, wenn sich der Füllbereich ändert, oder ob die Projektionsfarbe unabhängig vom Füllbereich der Form ist. Dies kann eine der folgenden MsoExtrusionColorType-Konstanten sein: msoExtrusionColorAutomatic (Projektionsfarbe auf Füllbereich der Form basierend), msoExtrusionColorCustom (Projektionsfarbe unabhängig vom Füllbereich der Form) oder msoExtrusionColorTypeMixed. Long Schreib-Lese-Zugriff.


Beispiel zur ExtrusionColorType-Eigenschaft

Wenn Form eins in myDocument eine automatische Projektionsfarbe hat, wird mit diesem Beispiel der Projektion ein benutzerdefiniertes Gelb zugewiesen.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    If .ExtrusionColorType = msoExtrusionColorAutomatic Then
        .ExtrusionColor.RGB = RGB(240, 235, 16)
    End If
End With


FarEastLineBreakControl-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the line break control option if you have an Asian language setting specified True if the line break control option is selected. Read/write Long.


Beispiel zur FarEastLineBreakControl-Eigenschaft

This example selects the line break option for the text in shape one on the first slide of the active presentation.

ActivePresentation.Slides(1).Shapes(1).TextFrame _.
    TextRange.ParagraphFormat.FarEastLineBreakControl = True


FarEastLineBreakLanguage-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the language used to determine which line break level is used when the line break control option is turned on. Can be one of the following MsoFarEastLineBreakLanguageID constants: MsoFarEastLineBreakLanguageJapanese, MsoFarEastLineBreakLanguageKorean, MsoFarEastLineBreakLanguageSimplifiedChinese, or MsoFarEastLineBreakLanguageTraditionalChinese. Read/write Long.


Beispiel zur FarEastLineBreakLanguage-Eigenschaft

The following example sets the line break language to Japanese.

ActivePresentation.FarEastLineBreakLanguage = _
    MsoFarEastLineBreakLanguageJapanese


FarEastLineBreakLevel-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the line break based upon Asian character level. Read/write Long. Can be one of the following PpFarEastLineBreakLevel constants: ppFarEastLineBreakLevelCustom, ppFarEastLineBreakLevelNormal, or ppFarEastLineBreakLevelStrict.


Beispiel zur FarEastLineBreakLevel-Eigenschaft

This example sets line break control to use level one kinsoku characters.

ActivePresentation.FarEastLineBreakLevel = _
    ppFarEastLineBreakLevelNormal


FeatureInstall-Eigenschaft

Gibt zurück oder stellt ein, wie Microsoft PowerPoint reagiert, wenn Methoden oder Eigenschaften aufgerufen werden, die nicht installierte Features benötigen. Long Schreib-Lese-Zugriff.

Die folgenden MsoFeatureInstall-Konstanten sind möglich.

Konstante | Wert | Beschreibung
msoFeatureInstallNone | 0 | Standardwert. Ein auffangbarer Laufzeit-Automatisierungsfehler wird beim Aufrufen von nicht installierten Features erzeugt.
msoFeatureInstallOnDemand | 1 | Ein Dialogfeld wird angezeigt, in dem der Benutzer aufgefordert wird, die benötigten Features zu installieren.
msoFeatureInstallOnDemandWithUI | 2 | Während der Installation wird eine Statusanzeige angezeigt. Der Benutzer wird nicht aufgefordert, neue Features zu installieren.

Hinweise

Mit der msoFeatureInstallOnDemandWithUI-Konstante können Sie verhindern, dass Benutzer annehmen, die Anwendung reagiere nicht mehr, während ein Feature installiert wird. Verwenden Sie die msoFeatureInstallNone-Konstante mit Fehlerbehebungsroutinen, um die Installation von Features durch Endbenutzer auszuschließen.

Anmerkung Wenn Sie sich in einer Zeichenfolge auf eine nicht installierte Entwurfsvorlage beziehen, wird ein Laufzeitfehler erzeugt. Ungeachtet Ihrer Einstellungen für die FeatureInstall-Eigenschaft wird die Entwurfsvorlage nicht automatisch installiert. Wenn Sie die ApplyTemplate-Methode für eine gegenwärtig nicht installierte Vorlage verwenden möchten, müssen Sie zunächst die zusätzlichen Entwurfsvorlagen installieren. Wählen Sie hierzu im Dialogfeld Neu (Menü Datei) eine entsprechende Vorlage aus, oder installieren Sie weitere Entwurfsvorlagen für PowerPoint, indem Sie das Installationsprogramm für Microsoft Office 2000 ausführen (verfügbar über das Symbol Software in der Systemsteuerung von Windows).


Beispiel zur FeatureInstall-Eigenschaft

In diesem Beispiel wird der Wert der FeatureInstall-Eigenschaft geprüft. Wenn die Eigenschaft auf msoFeatureInstallNone eingestellt wurde, wird ein Meldungsfeld angezeigt, in dem der Benutzer gefragt wird, ob die Einstellung für die Eigenschaft geändert werden soll. Wenn der Benutzer mit Ja antwortet, wird die Eigenschaft auf msoFeatureInstallOnDemand eingestellt.

With Application
    If .FeatureInstall = msoFeatureInstallNone Then
        Reply = MsgBox("Uninstalled features for this " _
                & "application " & vbCrLf _
                & "may cause a run-time error when called." & vbCrLf _
                & vbCrLf _
                & "Would you like to change this setting" & vbCrLf _
                & "to automatically install missing features when called?" _
                , 52, "Feature Install Setting")
            If Reply = 6 Then
                .FeatureInstall = msoFeatureInstallOnDemand
            End If
    End If
End With


FileName-Eigenschaft

Gibt den Pfad- und Dateinamen der erstellten Webpräsentation zurück und legt diesen fest, wenn die aktive Präsentation ganz oder teilweise veröffentlicht wird. String Schreib-Lese-Zugriff.

Hinweise

Wenn ein Ordner im angegebenen Pfad nicht vorhanden ist, gibt die FileName-Eigenschaft eine Fehlermeldung aus.


Beispiel zur FileName-Eigenschaft

In diesem Beispiel werden die Folien 1 bis 5 aus der aktiven Präsentation im HTML-Format veröffentlicht. Die veröffentlichte Präsentation erhält den Namen Mallard.htm und wird im Ordner Test gespeichert.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


FileSearch-Eigenschaft

Gibt ein FileSearch-Objekt zurück, bei dem für die Dateisuche entweder ein absoluter oder ein relativer Pfad verwendet werden kann. Nur-Lese-Zugriff.


Beispiel zur FileSearch-Eigenschaft

In diesem Beispiel werden alle Dateinamen im Ordner MyDocuments angezeigt, die mit "New" beginnen.

With Application.FileSearch
    .FileName = "New*.*"
    .LookIn = "C:\My Documents"
    .Execute
    For I = 1 To .FoundFiles.Count
        MsgBox .FoundFiles(I)
    Next
End With


Fill-Eigenschaft

Gibt ein FillFormat-Objekt zurück, das Formateigenschaften der Füllung für die angegebene Form enthält. Nur-Lese-Zugriff.


Beispiel zur Fill-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt anschließend die Vordergrundfarbe, Hintergrundfarbe und den Farbverlauf für die Füllung des Rechtecks fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


FirstMargin-Eigenschaft

Gibt den Erstzeileneinzug für die angegebene Gliederungsebene in Punkt zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Beginnt ein Absatz mit einem Aufzählungszeichen, werden die Position des Aufzählungszeichens von der FirstMargin-Eigenschaft und die Position des ersten Textzeichens im Absatz von der LeftMargin-Eigenschaft bestimmt.

Anmerkung Die RulerLevels-Auflistung enthält fünf RulerLevel-Objekte, von denen jedes einer der möglichen Gliederungsebenen entspricht. Der Wert der FirstMargin-Eigenschaft für das RulerLevel-Objekt, welches der ersten Gliederungsebene entspricht, hat einen Gültigkeitsbereich von (-9,0 bis 4095,875). Der Gültigkeitsbereich für die Werte der FirstMargin-Eigenschaft für die RulerLevel-Objekte, welche der zweiten bis fünften Gliederungsebene entsprechen, wird folgendermaßen bestimmt:

  • Der Höchstwert beträgt stets 4095,875.

  • Der Minimalwert entspricht dem Wert der FirstMargin-Eigenschaft (oder, falls größer, dem Wert der LeftMargin-Eigenschaft) der vorhergehenden Ebene plus 9.

    Zum Bestimmen des Minimalwertes für die FirstMargin-Eigenschaft können die folgenden Gleichungen verwendet werden. Index, die Indexnummer des RulerLevel-Objekts, zeigt die dem Objekt entsprechende Gliederungsebene an. Zum Bestimmen der Minimalwerte der FirstMargin-Eigenschaft für die RulerLevel-Objekte, welche der zweiten bis fünften Gliederungsebene entsprechen, setzen Sie für Index 2, 3, 4 oder 5 ein.

    Minimum(RulerLevel(Index).FirstMargin) = Maximum(RulerLevel(Index -1).FirstMargin, RulerLevel(Index -1).LeftMargin) + 9

    Minimum(RulerLevel(Index).LeftMargin) = Maximum(RulerLevel(Index -1).FirstMargin, RulerLevel(Index -1).LeftMargin) + 9


Beispiel zur FirstMargin-Eigenschaft

In diesem Beispiel werden der Erstzeileneinzug und hängende Einzug für Gliederungsebene 1 beim Textkörper im Folienmaster für die aktive Präsentation festgelegt.

With Application.ActivePresentation _
        .SlideMaster.TextStyles(ppBodyStyle)
    With .Ruler.Levels(1)
        .FirstMargin = 9
        .LeftMargin = 54
    End With
End With


FirstSlideNumber-Eigenschaft

Gibt die Foliennummer für die erste Folie der Präsentation zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Foliennummer ist die tatsächliche Nummer, die unten rechts in der Folie erscheint, wenn Sie Foliennummern anzeigen. Diese Nummer wird durch die Nummer (Anordnung) der Folie innerhalb der Präsentation (der Wert für die SlideIndex-Eigenschaft) und durch die Anfangsfoliennummer für die Präsentation (der Wert für die FirstSlideNumber-Eigenschaft) bestimmt. Die Foliennummer ist immer gleich der Anfangsfoliennummer + der Folienindexnummer -1. Die SlideNumber-Eigenschaft gibt die Foliennummer zurück.


Beispiel zur FirstSlideNumber-Eigenschaft

Dieses Beispiel zeigt, wie sich die Änderung der ersten Foliennummer der aktiven Präsentation auf die Foliennummer einer bestimmten Folie auswirkt.

With Application.ActivePresentation
    .PageSetup.FirstSlideNumber = 1  'starts slide numbering at 1
    MsgBox .Slides(2).SlideNumber    'returns 2

    .PageSetup.FirstSlideNumber = 10  'starts slide numbering at 10
    MsgBox .Slides(2).SlideNumber     'returns 11
End With


FitToPage-Eigenschaft

True, wenn die angegebenen Folien so skaliert werden, dass sie die Druckseite ausfüllen, wobei die Werte in den Feldern Höhe und Breite im Dialogfeld Seite einrichten (Menü Datei) nicht berücksichtigt werden. False, wenn die Folien die Maße haben, die im Dialogfeld Seite einrichten angegeben sind, wobei nicht berücksichtigt wird, ob diese Maße mit dem Papierformat der Druckseite in Konflikt geraten. Der Standardwert ist False. Long Schreib-Lese-Zugriff.


Beispiel zur FitToPage-Eigenschaft

Dieses Beispiel druckt die aktive Präsentation und passt jede Folie der Druckseite an.

With ActivePresentation
    .PrintOptions.FitToPage = True
    .PrintOut
End With


FolderSuffix-Eigenschaft

Gibt das Ordnersuffix zurück, das von Microsoft PowerPoint verwendet wird, wenn Sie eine Präsentation ganz oder teilweise als Webseite speichern oder veröffentlichen, lange Dateinamen verwenden und die unterstützenden Dateien in einem separaten Ordner speichern möchten (d. h., wenn die UseLongFileNames- und OrganizeInFolder-Eigenschaften auf True gesetzt sind). String Schreib-Lese-Zugriff.

Hinweise

Von neu erstellten Präsentationen wird das Suffix verwendet, das von der FolderSuffix-Eigenschaft des DefaultWebOptions-Objekts zurückgegeben wird. Falls die Präsentation zuvor in einer anderen Sprachversion von Microsoft PowerPoint bearbeitet wurde, kann der Wert der FolderSuffix-Eigenschaft des WebOptions-Objekts vom Wert des DefaultWebOptions-Objekts abweichen. Mit der UseDefaultFolderSuffix-Methode können Sie das Suffix in das Suffix der Sprache ändern, die Sie gerade in Microsoft Office 2000 verwenden.

In der Standardeinstellung ergibt sich der Name des Hilfsordners aus dem Namen der Webseite in Verbindung mit einem Unterstrich (_), einem Punkt (.) oder einem Bindestrich (-) und dem Wort "Dateien" (dieses erscheint in der Sprache der PowerPoint-Version, in der die Datei als Webseite gespeichert wurde). Angenommen, Sie speichern eine Datei mit dem Namen Page1 in der holländischen Sprachversion von PowerPoint. Gemäß der Standardeinstellung würde der Name des Hilfsordners in diesem Fall Page1_bestanden lauten.

In der folgenden Tabelle sind alle Sprachversionen von PowerPoint zusammen mit dem jeweiligen Wert ihrer LanguageID-Eigenschaft und dem Ordnersuffix aufgeführt. Für die nicht in der Tabelle aufgeführten Sprachen wird das Suffix .files verwendet.

Sprache

Sprache | LanguageID | Ordnersuffix
Arabisch | 1025 | .files
Baskisch | 1069 | _fitxategiak
Brasilianisch | 1046 | _arquivos
Bulgarisch | 1026 | .files
Katalanisch | 1027 | _fitxers
Chinesisch (Simplifiziert) | 2052 | .files
Chinesisch (Traditional) | 1028 | .files
Kroatisch | 1050 | _datoteke
Tschechisch | 1029 | _soubory
Dänisch | 1030 | -filer
Niederländisch | 1043 | _bestanden
Englisch | 1033 | _files
Estnisch | 1061 | _failid
Finnisch | 1035 | _tiedostot
Französisch | 1036 | _fichiers
Deutsch | 1031 | -Dateien
Griechisch | 1032 | .files
Hebräisch | 1037 | .files
Ungarisch | 1038 | _elemei
Italienisch | 1040 | -file
Japanisch | 1041 | .files
Koreanisch | 1042 | .files
Lettisch | 1062 | _fails
Litauisch | 1063 | _bylos
Norwegisch | 1044 | -filer
Polnisch | 1045 | _pliki
Portugiesisch | 2070 | _ficheiros
Rumänisch | 1048 | .files
Russisch | 1049 | .files
Serbisch (Kyrillisch) | 3098 | .files
Serbisch (Lateinisch) | 2074 | _fajlovi
Slowakisch | 1051 | .files
Slowenisch | 1060 | _datoteke
Spanisch | 3082 | _archivos
Schwedisch | 1053 | -filer
Thai | 1054 | .files
Türkisch | 1055 | _dosyalar
Ukrainisch | 1058 | .files
Vietnamesisch | 1066 | .files


Beispiel zur FolderSuffix-Eigenschaft

In diesem Beispiel wird das in Präsentation 1 verwendete Ordnersuffix zurückgegeben. Das Suffix wird in der Variablen strFolderSuffix vom Typ String zurückgegeben.

strFolderSuffix = Presentations(1).WebOptions.FolderSuffix


FollowColors-Eigenschaft

Gibt das Ausmaß zurück, dem die Farben im angegebenen Objekt der Farbskala der Folie folgen, oder legt dieses fest. Bei dem angegebenen Objekt muss es sich um ein Diagramm handeln, das entweder in Microsoft Graph oder in Microsoft Organisationsdiagramm erstellt wurde. Die Eigenschaft kann eine der folgenden PpFollowColors-Konstanten haben: ppFollowColorsScheme, wenn alle Farben im Diagramm der Farbskala der Folie folgen. ppFollowColorsTextAndBackground, wenn nur der Text und der Hintergrund der Farbskala der Folie folgen. ppFollowColorsNone, wenn die Diagrammfarben der Farbskala der Folie nicht folgen. Long Schreib-Lese-Zugriff.


Beispiel zur FollowColors-Eigenschaft

Dieses Beispiel gibt an, dass der Text und der Hintergrund bei Form 2 von Folie 1 in der aktiven Präsentation der Farbskala der Folie folgt. Bei Form 2 muss es sich um ein Diagramm handeln, das entweder in Microsoft Graph oder Microsoft Organisationsdiagramm erstellt wurde.

ActivePresentation.Slides(1).Shapes(2).OLEFormat.FollowColors = _
    ppFollowColorsTextAndBackground


FollowMasterBackground-Eigenschaft

True, wenn die angegebene Folie oder der angegebene Folienbereich dem Hintergrund des Folienmasters folgt. False, wenn die angegebene Folie oder der angegebene Folienbereich einen benutzerdefinierten Hintergrund hat. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie eine neue Folie erstellen, gilt als Standardwert für diese Eigenschaft True. Kopieren Sie eine Folie von einer anderen Präsentation, werden die Einstellungen aus der Originalpräsentation beibehalten. Das heißt, wenn die Folie dem Hintergrund des Folienmasters in der Originalpräsentation folgt, wird diese automatisch dem Hintergrund des Folienmasters in der neuen Präsentation folgen. Oder, wenn die Folie einen benutzerdefinierten Hintergrund hatte, wird sie den benutzerdefinierten Hintergrund beibehalten.

Beachten Sie, dass das Erscheinungsbild des Hintergrunds der Folie von der Farbskala und den Hintergrundobjekten sowie vom Hintergrund selbst bestimmt wird. Erzielen Sie mit der FollowMasterBackground-Eigenschaft nicht die gewünschten Ergebnisse, verwenden Sie auch die ColorScheme- und DisplayMasterShapes-Eigenschaft.


Beispiel zur FollowMasterBackground-Eigenschaft

Dieses Beispiel kopiert Folie 1 von Präsentation 2, fügt die Folie an das Ende von Präsentation 1 ein und passt den Hintergrund, die Farbskala, und die Hintergrundobjekte der Folie dem Rest von Präsentation 1 an.

Presentations(2).Slides(1).Copy
With Presentations(1).Slides.Paste
    .FollowMasterBackground = True
    .ColorScheme = Presentations(1).SlideMaster.ColorScheme
    .DisplayMasterShapes = True
End With


Font-Eigenschaft

Gibt ein Font-Objekt zurück, das Zeichenformatierung darstellt. Nur-Lese-Zugriff.


FontBold-Eigenschaft

True, wenn der Schriftschnitt von WordArt fett formatiert ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontBold-Eigenschaft

Dieses Beispiel legt für die Schriftart für Form 3 in myDocument den Schriftschnitt Fett fest, wenn es sich bei der Form um WordArt handelt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


FontItalic-Eigenschaft

True, wenn der Schriftschnitt von WordArt kursiv formatiert ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontItalic-Eigenschaft

Dieses Beispiel legt für die Schriftart der Form "WordArt 4" in myDocument den Schriftschnitt Kursiv fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes("WordArt 4").TextEffect.FontItalic = True


FontName-Eigenschaft

Gibt die Schriftart in der angegebenen WordArt zurück oder legt diese fest. String Schreib-Lese-Zugriff.


Beispiel zur FontName-Eigenschaft

Dieses Beispiel legt die Schriftart "Courier New" für Form 3 in myDocument fest, wenn es sich bei der Form um WordArt handelt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontName = "Courier New"
    End If
End With


Fonts-Eigenschaft

Presentation-Objekt: Gibt eine Fonts-Auflistung zurück, die alle Schriftarten darstellt, die in der angegebenen Präsentation verwendet werden. Nur-Lese-Zugriff.

DefaultWebOptions-Objekt: Gibt eine WebPageFonts-Auflistung zurück, die alle Schriftarten darstellt, in denen eine Präsentation als Webseite gespeichert werden kann. Nur-Lese-Zugriff.


FontSize-Eigenschaft

Gibt den Schriftgrad für die angegebene WordArt in Punkt zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.


Beispiel zur FontSize-Eigenschaft

Dieses Beispiel legt für Form "WordArt 4" in myDocument den Schriftgrad 16 Punkt fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes("WordArt 4").TextEffect.FontSize = 16


Footer-Eigenschaft

Gibt ein HeaderFooter-Objekt zurück, das die Fußzeile darstellt, die unten in einer Folie oder unten links in einer Notizzettelseite, einem Handzettel oder einer Gliederung angezeigt wird. Nur-Lese-Zugriff.


Beispiel zur Footer-Eigenschaft

Dieses Beispiel legt den Text für die Fußzeile in Folie 1 der aktiven Präsentation fest. Außerdem wird festgelegt, dass die Fußzeile, das Datum und die Uhrzeit sowie die Foliennummer in der Titelfolie erscheinen.

With Application.ActivePresentation.SlideMaster.HeadersFooters
    .Footer.Text = "Introduction"
    .DisplayOnTitleSlide = True
End With


ForeColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Vordergrundfarbe für die Füllung, die Linie oder den Schatten darstellt, oder legt dieses Objekt fest. Schreib-Lese-Zugriff.


Beispiel zur ForeColor-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt anschließend die Vordergrundfarbe, Hintergrundfarbe und den Farbverlauf für die Füllung des Rechtecks fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With

Dieses Beispiel fügt eine gemusterte Linie zu myDocument hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


Format-Eigenschaft

Gibt das Format für die automatisch aktualisierten Werte für Datum und Uhrzeit zurück oder legt es fest. Wird nur HeaderFooter-Objekten zugewiesen, die Datum und Uhrzeit darstellen (die von der HeadersFooters-Auflistung der DateAndTime-Eigenschaft zurückgegeben werden). Long Schreib-Lese-Zugriff.

Mögliche PpDateTimeFormat-Konstanten:

ppDateTimeddddMMMMddyyyy

ppDateTimedMMMMyyyy

ppDateTimedMMMyy

ppDateTimeFormatMixed

ppDateTimeHmm

ppDateTimehmmAMPM

ppDateTimeHmmss

 ppDateTimehmmssAMPM

ppDateTimeMdyy

ppDateTimeMMddyyHmm

ppDateTimeMMddyyhmmAMPM

ppDateTimeMMMMdyyyy

ppDateTimeMMMMyy

ppDateTimeMMyy

Anmerkungen

Vergewissern Sie sich, dass Datum und Uhrzeit kein feststehender Text sind, sondern automatisch aktualisiert werden, indem Sie für die UseFormat-Eigenschaft True festlegen.


Beispiel zur Format-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Datum und die Uhrzeit für den Folienmaster der aktiven Präsentation automatisch aktualisiert werden. Anschließend wird das Format für das Datum und die Uhrzeit so festgelegt, dass Stunden, Minuten und Sekunden angezeigt werden.

Set myPres = Application.ActivePresentation
With myPres.SlideMaster.HeadersFooters.DateAndTime
    .UseFormat = True
    .Format = ppDateTimeHmmss
End With


FrameColors-Eigenschaft

Gibt die Textfarbe für den Gliederungsausschnitt und die Hintergrundfarbe für den Gliederungs- und Folienausschnitt für Webpräsentationen zurück oder legt diese fest. Es kann sich um eine der folgenden PpFrameColors-Konstanten handeln: ppFrameColorsBlackTextOnWhite, ppFrameColorsBrowserColors, ppFrameColorsPresentationSchemeAccentColor, ppFrameColorsPresentationSchemeTextColor oder ppFrameColorsWhiteTextOnBlack. Long Schreib-Lese-Zugriff.


Beispiel zur FrameColors-Eigenschaft

In diesem Beispiel werden für das Speichern oder Veröffentlichen der aktiven Präsentation als Webseite folgende Festlegungen getroffen: die Textfarbe des Gliederungsausschnitts soll weiß sein, die Hintergrundfarbe für den Gliederungs- und Folienausschnitt schwarz, PNG (Portable Network Graphics) wird als Bildformat zugelassen.

With ActivePresentation.WebOptions
    .FrameColors = ppFrameColorsWhiteTextOnBlack
    .AllowPNG = True
End With


FrameSlides-Eigenschaft

True, wenn ein dünner Rahmen um die Umrandung der gedruckten Folien gesetzt wird. Betrifft gedruckte Folien, Handzettel und Notizenseiten. Der Standardwert ist False. Long Schreib-Lese-Zugriff.


Beispiel zur FrameSlides-Eigenschaft

Dieses Beispiel druckt die aktive Präsentation mit einem Rahmen um jede Folie.

With ActivePresentation
    .PrintOptions.FrameSlides = True
    .PrintOut
End With


FullName-Eigenschaft

Gibt den Namen des angegebenen Add-Ins oder der gespeicherten Präsentation zusammen mit dem Pfad, dem aktuellen Dateisystem-Trennzeichen und der Dateinamenerweiterung zurück. String Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft entspricht der Path-Eigenschaft, gefolgt vom aktuellen Dateisystem-Trennzeichen, gefolgt von der Name-Eigenschaft.


Beispiel zur FullName-Eigenschaft

In diesem Beispiel werden der Pfad und der Dateiname von jedem verfügbaren Add-In angezeigt.

For Each a In Application.AddIns
    MsgBox a.FullName
Next a

In diesem Beispiel werden der Pfad und der Dateiname der aktiven Präsentation angezeigt (vorausgesetzt, dass die Präsentation gespeichert wurde).

MsgBox Application.ActivePresentation.FullName


Gap-Eigenschaft

Gibt den horizontalen Abstand zwischen dem Ende der Legendenlinie und dem Text-Begrenzungsrechteck in Punkt zurück, oder legt diesen Abstand fest. Single Schreib-Lese-Zugriff.


Beispiel zur Gap-Eigenschaft

Dieses Beispiel legt für den Abstand zwischen der Legendenlinie und dem Text-Begrenzungsrechteck für Form 1 in myDocument 3 Punkt fest. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(1).Callout.Gap = 3


GradientColorType-Eigenschaft

Gibt den Farbtyp des Verlaufs für die angegebene Füllung zurück. Dies kann eine der folgenden MsoGradientColorType-Konstanten sein: msoGradientColorMixed, msoGradientOneColor, msoGradientPresetColors oder msoGradientTwoColors. Long Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der OneColorGradient-, PresetGradient- oder TwoColorGradient-Methode können Sie den Verlaufstyp für die Füllung festlegen.


Beispiel zur GradientColorType-Eigenschaft

Dieses Beispiel legt bei allen Formen in myDocument, die eine zweifarbige Verlaufsfüllung haben, eine vordefinierte Verlaufsfüllung fest.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    With s.Fill
        If .GradientColorType = msoGradientTwoColors Then
            .PresetGradient msoGradientHorizontal, _
                1, msoGradientBrass
        End If
    End With
Next


GradientDegree-Eigenschaft

Gibt einen Wert zurück, der anzeigt, wie dunkel oder hell eine einfarbige Verlaufsfüllung ist. Der Wert 0 bedeutet, dass die Farbe Schwarz mit der Vordergrundfarbe der Form vermischt wird, um den Verlauf zu bilden. Der Wert 1 bedeutet, dass die Farbe Weiß vermischt wird. Werte zwischen 0 und 1 zeigen die dunklen bzw. hellen Schattierungen an, die mit der Vordergrundfarbe vermischt werden. Single Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der OneColorGradient-Methode können Sie den Verlaufsgrad für die Füllung festlegen.


Beispiel zur GradientDegree-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt den Grad des Füllverlaufs fest, der dem Verlauf der Form "Rechteck 2" angepasst wird. Hat Rechteck 2 keine einfarbige Verlaufsfüllung, schlägt dieses Beispiel fehl.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    gradDegree1 = .Item("Rectangle 2").Fill.GradientDegree
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .OneColorGradient msoGradientHorizontal, 1, gradDegree1
    End With
End With


GradientStyle-Eigenschaft

Gibt die Verlaufsart für die angegebene Füllung zurück. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal, msoGradientMixed oder msoGradientVertical. Long Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der OneColorGradient-, PresetGradient- oder TwoColorGradient-Methode können Sie die Verlaufsart für die Füllung festlegen.

Hinweis Wenn Sie versuchen, diese Eigenschaft für eine Füllung ohne Farbverlauf zurückzugeben, wird ein Fehler generiert. Mit der Type-Eigenschaft können Sie bestimmen, ob die Füllung einen Farbverlauf hat.


Beispiel zur GradientStyle-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt für die Art des Füllverlaufs fest, dass sie der Füllung der Form "Rechteck1" angepasst wird. Damit dieses Beispiel funktioniert, muss Rechteck1 eine Verlaufsfüllung haben.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    gradStyle1 = .Item("rect1").Fill.GradientStyle
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .OneColorGradient gradStyle1, 1, 1
    End With
End With


GradientVariant-Eigenschaft

Gibt die Verlaufsvariante für die angegebene Füllung als ganzzahligen Wert von 1 bis 4 für die meisten Verlaufsfüllungen zurück. Wird als Verlaufsart msoGradientFromTitle oder msoGradientFromCenter festgelegt, gibt diese Eigenschaft entweder 1 oder 2 zurück. Die Werte für diese Eigenschaft entsprechen den vier Verlaufsvarianten (die von links nach rechts und von oben nach unten nummeriert werden) der Registerkarte Graduell im Dialogfeld Fülleffekte. Long Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der OneColorGradient-, PresetGradient- oder TwoColorGradient-Methode können Sie die Verlaufsvariante für die Füllung festlegen.


Beispiel zur GradientVariant-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt für die Variante des Füllverlaufs fest, dass sie der Füllung der Form "Rechteck1" angepasst wird. Damit dieses Beispiel funktioniert, muss Rechteck1 eine Verlaufsfüllung haben.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    gradVar1 = .Item("rect1").Fill.GradientVariant
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .OneColorGradient msoGradientHorizontal, gradVar1, 1
    End With
End With


GroupItems-Eigenschaft

Gibt ein GroupShapes-Objekt zurück, das die einzelnen Formen in der angegebenen Gruppe darstellt. Mit der Item-Methode des GroupShapes-Objekts können Sie eine einzelne Form aus der Gruppe zurückgeben. Betrifft Shape- oder ShapeRange-Objekte, die gruppierte Formen darstellen. Nur-Lese-Zugriff.


Beispiel zur GroupItems-Eigenschaft

Dieses Beispiel fügt drei Dreiecke zu myDocument hinzu, gruppiert diese, legt eine Farbe für die gesamte Gruppe fest und ändert anschließend nur die Farbe für das zweite Dreieck.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, 10, _
        10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, 150, _
        10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, 300, _
        10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


HandoutMaster-Eigenschaft

Gibt ein Master-Objekt zurück, das den Handzettelmaster darstellt. Nur-Lese-Zugriff.


Beispiel zur HandoutMaster-Eigenschaft

In diesem Beispiel wird das Hintergrundmuster beim HandoutMaster der aktiven Präsentation festgelegt.

Application.ActivePresentation.HandoutMaster.Background.Fill _
    .Patterned msoPatternDarkHorizontal


HandoutOrder-Eigenschaft

Gibt die Seitenlayoutreihenfolge zurück oder legt diese fest, in der Folien auf gedruckten Handzetteln erscheinen, bei denen sich mehrere Folien auf einer Seite befinden. Long Schreib-Lese-Zugriff. Es kann sich um eine der folgenden PpPrintHandoutOrder-Konstanten handeln:

Konstante | Beschreibung
ppPrintHandoutHorizontalFirst | Folien werden horizontal angeordnet, wobei sich die erste Folie in der linken oberen Ecke, die zweite Folie rechts neben dieser befindet. Wenn in Ihrer Spracheinstellung eine Sprache mit Schreibweise von rechts nach links festgelegt ist, wird die erste Folie in der rechten oberen Ecke und die zweite Folie links daneben dargestellt.
ppPrintHandoutVerticalFirst | Folien werden vertikal angeordnet, wobei sich die erste Folie in der linken oberen Ecke, die zweite Folie unter ihr befindet. Wenn in Ihrer Spracheinstellung eine Sprache mit Schreibweise von rechts nach links festgelegt ist, wird die erste Folie in der rechten oberen Ecke und die zweite Folie unter dieser dargestellt.


Beispiel zur HandoutOrder-Eigenschaft

In diesem Beispiel werden Handzettel so festgelegt, dass sie sechs Folien pro Seite enthalten. Die Folien werden dann horizontal auf den Handzetteln angeordnet und die Handzettel werden ausgedruckt.

With ActivePresentation
    .PrintOptions.OutputType = ppPrintOutputSixSlideHandouts
    .PrintOptions.HandoutOrder = ppPrintHandoutHorizontalFirst
    .PrintOut
End With


HangingPunctuation-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the hanging punctuation option if you have an Asian language setting specified. True if the hanging punctuation option is selected. Read/write Long.


Beispiel zur HangingPunctuation-Eigenschaft

This example selects hanging punctuation for the first paragraph of the active presentation.

ActivePresentation.Paragraphs(1).HangingPunctuation = True


HasTable-Eigenschaft

True, wenn es sich bei der angegebenen Form um eine Tabelle handelt. Long Nur-Lese-Zugriff.


Beispiel zur HasTable-Eigenschaft

In diesem Beispiel wird überprüft, ob es sich bei der aktuell ausgewählten Form um eine Tabelle handelt. Ist dies der Fall, legt der Code die Breite der ersten Spalte auf ein Zoll (72 Punkt, ca. 2,54 cm) fest.

With ActiveWindow.Selection.ShapeRange
    If .HasTable = True Then
       .Table.Columns(1).Width = 72
    End If
End With


HasText-Eigenschaft

True, wenn der angegebenen Form Text zugeordnet ist. Long Nur-Lese-Zugriff.


HasTextFrame-Eigenschaft

True, wenn die angegebene Form einen Textrahmen hat und somit Text enthalten kann. Long Nur-Lese-Zugriff.


Beispiel zur HasTextFrame-Eigenschaft

Dieses Beispiel extrahiert Text aus allen Formen der ersten Folie, die Textrahmen enthalten. Anschließend werden die Namen dieser Formen mit dem enthaltenen Text in einer Matrix gespeichert.

Dim shpTextArray() As Variant
Dim numShapes, numAutoShapes, i As Long

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
    numTextShapes = 0
        ReDim shpTextArray(1 To 2, 1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).HasTextFrame Then
                numTextShapes = numTextShapes + 1
                shpTextArray(numTextShapes, 1) = .Item(i).Name
                shpTextArray(numTextShapes, 2) = .Item(i) _
                    .TextFrame.TextRange.Text
            End If
        Next
        ReDim Preserve shpTextArray(1 To 2, 1 To numTextShapes)
    End If
End With


HasTitle-Eigenschaft

True, wenn die Auflistung der Objekte in der angegebenen Folie einen Platzhalter für den Titel enthält. Long Nur-Lese-Zugriff.


HasTitleMaster-Eigenschaft

True, wenn die angegebene Präsentation einen TitleMaster hat. Long Nur-Lese-Zugriff.


Beispiel zur HasTitleMaster-Eigenschaft

In diesem Beispiel wird der aktiven Präsentation ein TitleMaster hinzugefügt, wenn diese noch keinen hat.

With Application.ActivePresentation
    If Not .HasTitleMaster Then .AddTitleMaster
End With


Header-Eigenschaft

Gibt ein HeaderFooter-Objekt zurück, das eine Kopfzeile darstellt, die oben in einer Folie oder oben links in einer Notizzettelseite, einem Handzettel oder einer Gliederung angezeigt wird. Nur-Lese-Zugriff.


HeadersFooters-Eigenschaft

Gibt eine HeadersFooters-Auflistung zurück, die die Kopfzeile, Fußzeile, Datum und Uhrzeit und Foliennummer zu einer Folie, einem Folienmaster oder Folienbereich darstellt. Nur-Lese-Zugriff.

Informationen über die Rückgabe einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur HeadersFooters-Eigenschaft

Dieses Beispiel legt den Fußzeilentext und das Format für Datum und Uhrzeit für den Notizenmaster der aktiven Präsentation fest. Außerdem wird festgelegt, dass Datum und Uhrzeit automatisch aktualisiert werden.

With ActivePresentation.NotesMaster.HeadersFooters
    .Footer.Text = "Regional Sales"
    With .DateAndTime
        .UseFormat = True
        .Format = ppDateTimeHmmss
    End With
End With


Height-Eigenschaft

Gibt die Höhe des angegebenen Objekts in Punkt zurück oder legt diese fest. Single Nur-Lese-Zugriff für das Master-Objekt, Single Schreib-Lese-Zugriff für alle anderen Objekte.

Anmerkungen

Die Height-Eigenschaft eines Shape-Objekts gibt die Höhe der nach vorne zeigenden Oberfläche der angegebenen Form zurück oder legt diese fest. Schatten oder 3D-Effekte werden nicht einbezogen.


Beispiel zur Height-Eigenschaft

Dieses Beispiel legt als Höhe für das Dokumentfenster 2 die halbe Höhe des Anwendungsfensters fest.

Windows(2).Height = Application.Height / 2

Dieses Beispiel legt als Höhe für Zeile 2 der angegebenen Tabelle 100 Punkt fest (72 Punkt pro Zoll).

ActivePresentation.Slides(2).Shapes(5).Table.Rows(2).Width = 100


Hidden-Eigenschaft

True, wenn die angegebene Folie während einer Bildschirmpräsentation ausgeblendet ist. Long Nur-Lese-Zugriff.


Beispiel zur Hidden-Eigenschaft

Dieses Beispiel blendet Folie 2 der aktiven Präsentation aus.

ActivePresentation.Slides(2).SlideShowTransition.Hidden = True


HideWhileNotPlaying-Eigenschaft

True, wenn der angegebene Medienclip während einer Bildschirmpräsentation ausgeblendet ist, es sei denn dieser wird nicht wiedergegeben. Long Schreib-Lese-Zugriff.


Beispiel zur HideWhileNotPlaying-Eigenschaft

Dieses Beispiel fügt den Film "globe.avi" auf Folie 1 der aktiven Präsentation ein. Anschließend wird festgelegt, dass der Film automatisch nach dem Folienübergang wiedergegeben wird. Das Filmobjekt ist während einer Bildschirmpräsentation ausgeblendet, wenn es nicht wiedergegeben wird.

With ActivePresentation.Slides(1).Shapes _
        .AddOLEObject(Left:=10, Top:=10, _
        Width:=250, Height:=250, _
        FileName:="c:\winnt\clock.avi")
    With .AnimationSettings.PlaySettings
        .PlayOnEntry = True
        .HideWhileNotPlaying = True
    End With
End With


HorizontalAnchor-Eigenschaft

Gibt die horizontale Ausrichtung für Text in einem Textrahmen zurück oder legt diese fest. Dies kann eine der folgenden MsoHorizontalAnchor-Konstanten sein: msoAnchorCenter, msoAnchorNone oder msoHorizontalAnchorMixed. Long Schreib-Lese-Zugriff.


Beispiel zur HorizontalAnchor-Eigenschaft

In diesem Beispiel wird die Ausrichtung des Textes in Form 1 in myDocument auf oben zentriert festgelegt.

Set myDocument = ActivePresentation.SlideMaster
With myDocument.Shapes(1)
    .TextFrame.HorizontalAnchor = msoAnchorCenter
    .TextFrame.VerticalAnchor = msoAnchorTop
End With


HorizontalFlip-Eigenschaft

True, wenn die angegebene Form um die horizontale Achse gedreht wird. Long Nur-Lese-Zugriff.


Beispiel zur HorizontalFlip-Eigenschaft

Dieses Beispiel stellt bei allen horizontal oder vertikal gekippten Formen von myDocument den ursprünglichen Zustand wieder her.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


HTMLProject-Eigenschaft

Gibt das HTMLProject-Objekt zurück, bei dem es sich um eine Webpräsentation (im HTML-Format) handelt, auf die über den Microsoft Script Editor zugegriffen wird. Nur-Lese-Zugriff.

Hinweise

Das HTMLProject-Objekt kann für eine geladene Präsentation als Projektzweig der höchsten Stufe im Fenster des Projektexplorers von Script Editor verstanden werden. Es enthält die HTMLProjectItems-Auflistung. Elemente der HTMLProjectItems-Auflistung bilden Folien, Master oder Handzettel für die Webpräsentation.


Beispiel zur HTMLProject-Eigenschaft

In diesem Beispiel werden die Namen aller Elemente der HTMLProjectItems-Auflistung für das geladene HTMLProject überprüft. Lautet der Name Slide2, so wird der für diese Folie erstellte HTML-Code im Microsoft Script Editor geöffnet.

Dim i As Integer
With ActivePresentation.HTMLProject
    For i = 1 To .HTMLProjectItems.Count
        If .HTMLProjectItems(i).Name = "Slide2" Then
            .HTMLProjectItems(i).Open
        End If
    Next
End With


HTMLVersion-Eigenschaft

Gibt die HTML-Version für eine veröffentlichte Präsentation zurück oder legt sie fest. Der Wert kann eine der folgenden PpHTMLVersion-Konstanten sein: ppHTMLv3, ppHTMLDual oder ppHTMLv4. Der Standardwert ist ppHTMLv4. Long Schreib-Lese-Zugriff.


Beispiel zur HTMLVersion-Eigenschaft

In diesem Beispiel werden die Folien 3 bis 5 der aktiven Präsentation in HTML Version 3.0 veröffentlicht. Die veröffentlichte Präsentation erhält den Namen Mallard.htm

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .HTMLVersion = ppHTMLv3
    .Publish
End With


Hyperlink-Eigenschaft

Gibt ein Hyperlink-Objekt zurück, das den Hyperlink für die angegebene Form darstellt. Damit der Hyperlink während einer Bildschirmpräsentation aktiv werden kann, muss für die Action-Eigenschaft ppActionHyperlink festgelegt werden. Nur-Lese-Zugriff.


Hyperlinks-Eigenschaft

Gibt eine Hyperlinks-Auflistung zurück, die alle Hyperlinks in der angegebenen Folie darstellt. Nur-Lese-Zugriff.

Informationen über die Rückgabe einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Hyperlinks-Eigenschaft

Dieses Beispiel ermöglicht es dem Benutzer, eine veraltete Internetadresse für alle Hyperlinks der aktiven Präsentation zu aktualisieren.

oldAddr = InputBox("Old internet address")
newAddr = InputBox("New internet address")
For Each s In ActivePresentation.Slides
    For Each h In s.Hyperlinks
        If LCase(h.Address) = oldAddr Then h.Address = newAddr
    Next
Next


IncludeNavigation-Eigenschaft

True, wenn die Navigationsleiste für Webpräsentationen am unteren Rand der Seite eingeblendet ist. False, wenn die Navigationsleiste nicht eingeblendet ist, wodurch die Folie größer wird. Der Standardwert lautet True. Long Schreib-Lese-Zugriff.


Beispiel zur IncludeNavigation-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Navigationsleiste in der angegebenen Webpräsentation ausgeblendet ist. Anschließend wird eine Vorschau der Präsentation im aktiven Webbrowser ausgegeben.

With Presentations(2)
    .WebOptions.IncludeNavigation = False
    .WebPagePreview
End With


IndentLevel-Eigenschaft

Gibt die Einzugsebene des angegebenen Textes als ganze Zahl zwischen 1 und 5 zurück oder legt sie fest. Dabei steht 1 für einen Absatz erster Ebene ohne Einzug. Long Schreib-Lese-Zugriff.


Beispiel zur IndentLevel-Eigenschaft

In diesem Beispiel wird dem zweiten Absatz in der zweiten Form der ersten Folie in der aktiven Präsentation ein Einzug zugewiesen.

Application.ActivePresentation.Slides(2).Shapes(2).TextFrame _
    .TextRange.Paragraphs(2).IndentLevel = 2


IsFullScreen-Eigenschaft

True, wenn das angegebene Fenster der Bildschirmpräsentation den ganzen Bildschirm beansprucht. Long Nur-Lese-Zugriff.


Beispiel zur IsFullScreen-Eigenschaft

In diesem Beispiel wird die Höhe eines Fensters einer Bildschirmpräsentation, die am ganzen Bildschirm angezeigt wird, so reduziert, dass nur noch die Taskleiste sichtbar ist.

With Application.SlideShowWindows(1)
    If .IsFullScreen Then
        .Height = .Height - 20
    End If
End With


IsNamedShow-Eigenschaft

True, wenn in der angegebenen Bildschirmpräsentationsansicht eine zielgruppenorientierte (benannte) Bildschirmpräsentation angezeigt wird. Long Nur-Lese-Zugriff.


Beispiel zur IsNamedShow-Eigenschaft

Wenn die im Bildschirmpräsentationsfenster 1 laufende Bildschirmpräsentation eine zielgruppenorientierte Bildschirmpräsentation ist, wird mit diesem Beispiel deren Namen angezeigt.

With SlideShowWindows(1).View
    If .IsNamedShow Then
        MsgBox "Now showing in slide show window 1: " _
           & .SlideShowName
    End If
End With


Italic-Eigenschaft

Font-Objekt: True, wenn die Zeichen kursiv formatiert sind, False, wenn die Zeichen nicht kursiv formatiert sind, msoTriStateMixed, wenn der angegebene Textbereich sowohl kursiv formatierte als auch nicht kursiv formatierte Zeichen enthält. Long Schreib-Lese-Zugriff.


Beispiel zur Italic-Eigenschaft

In diesem Beispiel erhält der Titeltext von Folie 1 die Farbe Blau und wird kursiv formatiert.

With Application.ActivePresentation.Slides(1) _
        .Shapes.Title.TextFrame.TextRange
    .Text = "Volcano Coffee"
    With .Font
        .Italic = True
        .Name = "palatino"
        .Color.RGB = RGB(0, 0, 255)
    End With
End With


Item-Eigenschaft

Gibt den Anpassungswert zurück, der vom Index-Argument angegeben wird, oder legt diesen fest. Bei linearen Anpassungen entspricht der Anpassungswert 0,0 allgemein der linken oder oberen Seite und der Wert 1,0 der rechten oder unteren Seite der Form. Anpassungen können bei einigen Formen jedoch die Begrenzungen überschreiten. Bei radialen Anpassungen entspricht der Wert 1,0 der Breite der Form. Bei eckigen Anpassungen wird der Wert in Grad angegeben. Die Item-Eigenschaft betrifft nur Formen mit Anpassungen. Single Schreib-Lese-Zugriff.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Adjustments-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer der Anpassung.

Anmerkungen

AutoFormen, Verbindungen und WordArt-Objekte können bis zu acht Anpassungen haben.


Beispiel zur Item-Eigenschaft

Dieses Beispiel fügt zu myDocument zwei Kreuze hinzu und legt anschließend für jedes Kreuz den Wert für Anpassung 1 (der einzige für diesen AutoForm-Typ) fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeCross, 10, 10, 100, 100) _
        .Adjustments.Item(1) = 0.4
    .AddShape(msoShapeCross, 150, 10, 100, 100) _
        .Adjustments.Item(1) = 0.2
End With

Dieses Beispiel hat das gleiche Ergebnis wie das vorherige Beispiel, obwohl die Item-Eigenschaft nicht explizit verwendet wird.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape(msoShapeCross, 10, 10, 100, 100) _
        .Adjustments(1) = 0.4
    .AddShape(msoShapeCross, 150, 10, 100, 100) _
        .Adjustments(1) = 0.2
End With


KernedPairs-Eigenschaft

True, wenn Zeichenpaare in der angegebenen WordArt unterschnitten werden. Long Schreib-Lese-Zugriff.


Beispiel zur KernedPairs-Eigenschaft

Dieses Beispiel aktiviert für Form 3 in myDocument, dass Zeichenpaare unterschnitten werden, wenn es sich bei der Form um WordArt handelt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.KernedPairs = True
    End If
End With


LanguageID-Eigenschaft

Gibt die Sprache für den angegebenen Textbereich zurück oder legt diese fest. Diese Eigenschaft wird für Text verwendet, der in einer anderen Sprache geschrieben wurde, als der in der DefaultLanguageID-Eigenschaft festgesetzten. Hierdurch kann die Rechtschreib- und Grammatikprüfung in PowerPoint in der Sprache des jeweiligen Textbereichs durchgeführt werden. Diese Eigenschaft hängt nicht mit der Sprache der Anwendungsoberfläche zusammen. Schreib-Lese-Zugriff. Es kann sich um eine der folgenden MsoLanguageID-Konstanten handeln:

msoLanguageIDAfrikaans

msoLanguageIDArabic

msoLanguageIDBasque

msoLanguageIDBelgianDutch

msoLanguageIDBelgianFrench

msoLanguageIDBrazilianPortuguese

msoLanguageIDBulgarian

msoLanguageIDByelorussian

msoLanguageIDCatalan

msoLanguageIDCroatian

msoLanguageIDCzech

msoLanguageIDDanish

msoLanguageIDDutch

msoLanguageIDEnglishAUS

msoLanguageIDEnglishCanadian

msoLanguageIDEnglishNewZealand

msoLanguageIDEnglishSouthAfrica

msoLanguageIDEnglishUK

msoLanguageIDEnglishUS

msoLanguageIDEstonian

msoLanguageIDFarsi

msoLanguageIDFinnish

msoLanguageIDFrench

msoLanguageIDFrenchCanadian

msoLanguageIDGerman

msoLanguageIDGreek

msoLanguageIDHebrew

msoLanguageIDHungarian

msoLanguageIDIcelandic

msoLanguageIDItalian

msoLanguageIDJapanese

msoLanguageIDKorean

 msoLanguageIDLatvian

msoLanguageIDMacedonian

msoLanguageIDMalaysian

msoLanguageIDMexicanSpanish

msoLanguageIDMixed

msoLanguageIDNone

msoLanguageIDNoProofing

msoLanguageIDNorwegianBokmol

msoLanguageIDNorwegianNynorsk

msoLanguageIDPolish

msoLanguageIDPortuguese

msoLanguageIDRomanian

msoLanguageIDRussian

msoLanguageIDSerbianCyrillic

msoLanguageIDSerbianLatin

msoLanguageIDSesotho

msoLanguageIDSimplifiedChinese

msoLanguageIDSlovak

msoLanguageIDSlovenian

msoLanguageIDSpanish

msoLanguageIDSpanishModernSort

msoLanguageIDSwedish

msoLanguageIDSwissFrench

msoLanguageIDSwissGerman

msoLanguageIDSwissItalian

msoLanguageIDTraditionalChinese

msoLanguageIDTsonga

msoLanguageIDTswana

msoLanguageIDTurkish

msoLanguageIDUkrainian

msoLanguageIDVenda

msoLanguageIDXhosa

msoLanguageIDZulu


Beispiel zur LanguageID-Eigenschaft

In diesem Beispiel wird die Sprache für den in Form 1 angegebenen Text als amerikanisches Englisch festgelegt.

ActivePresentation.Slides(1).Shapes(1).TextFrame.TextRange _
    .LanguageID = msoLanguageIDEnglishUS


LanguageSettings-Eigenschaft

Gibt ein LanguageSettings-Objekt zurück, das Informationen über die Spracheinstellungen in Microsoft PowerPoint enthält. Nur-Lese-Zugriff.


LastSlideViewed-Eigenschaft

Gibt ein Slide-Objekt zurück, das die Ansicht der Folie direkt vor der aktuellen Folie in der angegebenen Bildschirmpräsentationsansicht darstellt.


Beispiel zur LastSlideViewed-Eigenschaft

Dieses Beispiel ruft die Folie auf, die direkt vor der aktuellen Folie in Fenster 1 der Bildschirmpräsentation angezeigt wurde.

With SlideShowWindows(1).View
    .GotoSlide (.LastSlideViewed.SlideIndex)
End With


Layout-Eigenschaft

Gibt das Folienlayout zurück oder legt dieses fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden PpSlideLayout-Konstanten sein:

ppLayoutBlank

ppLayoutChart

ppLayoutChartAndText

ppLayoutClipartAndText

ppLayoutClipArtAndVerticalText

ppLayoutFourObjects

ppLayoutLargeObject

ppLayoutMediaClipAndText

ppLayoutMixed

ppLayoutObject

ppLayoutObjectAndText

ppLayoutObjectOverText

ppLayoutOrgchart

ppLayoutTable

ppLayoutText

 ppLayoutTextAndChart

ppLayoutTextAndClipart

ppLayoutTextAndMediaClip

ppLayoutTextAndObject

ppLayoutTextAndTwoObjects

ppLayoutTextOverObject

ppLayoutTitle

ppLayoutTitleOnly

ppLayoutTwoColumnText

ppLayoutTwoObjectsAndText

ppLayoutTwoObjectsOverText

ppLayoutVerticalText

ppLayoutVerticalTitleAndText

ppLayoutVerticalTitleAndTextOverChart


LayoutDirection-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the layout direction for the user interface. Can be one of the following PpDirection constants: ppDirectionLeftToRight, ppDirectionMixed, or ppDirectionRightToLeft. The default value depends on the language support you have selected or installed. Read/write Long.


Beispiel zur LayoutDirection-Eigenschaft

This example sets the layout direction to right-to-left.

Application.ActivePresentation.LayoutDirection = _
    ppDirectionRightToLeft


Left-Eigenschaft

Gibt die linke Position des Objekts in Punkt zurück oder legt diese fest. (Siehe nachfolgende Tabelle.) Single Schreib-Lese-Zugriff.

Objekt | Bedeutung
Application, SlideShowWindow | Der Abstand von der linken Seite des Fensters der Anwendung oder Bildschirmpräsentation zur linken Seite des Desktops. Wenn Sie für diese Eigenschaft einen hohen positiven oder negativen Wert festlegen, kann das Fenster vollständig außerhalb des Desktops liegen.
DocumentWindow | Der Abstand von der linken Seite des Dokumentfensters zur linken Seite des Clientbereichs des Anwendungsfensters.
Shape | Der Abstand von der linken Seite des Begrenzungsrechtecks der Form zur linken Seite des Dokuments.
ShapeRange | Der Abstand von der linken Seite der äußersten linken Form im Formbereich zur linken Seite des Dokuments.


LeftMargin-Eigenschaft

Gibt den linken Einzug für die angegebene Gliederungsebene in Punkt zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Beginnt ein Absatz mit einem Aufzählungszeichen, werden die Position des Aufzählungszeichens von der FirstMargin-Eigenschaft und die Position des ersten Textzeichens im Absatz von der LeftMargin-Eigenschaft bestimmt.

Anmerkung Die RulerLevels-Auflistung enthält fünf RulerLevel-Objekte. Jedes dieser Objekte entspricht einer der möglichen Gliederungsebenen. Der Wert der LeftMargin-Eigenschaft des RulerLevel-Objekts, welches der ersten Gliederungsebene entspricht, hat einen Gültigkeitsbereich von (-9,0 bis 4095,875). Der Gültigkeitsbereich für die Werte der LeftMargin-Eigenschaft der RulerLevel-Objekte, welche der zweiten bis fünften Gliederungsebene entsprechen, wird folgendermaßen bestimmt:

  • Der Höchstwert ist stets 4095,875.

  • Der Minimalwert entspricht dem Wert der FirstMargin-Eigenschaft (oder, falls größer, dem Wert der LeftMargin-Eigenschaft) der vorhergehenden Ebene plus 9.

    Zum Bestimmen der Minimalwerte für die LeftMargin-Eigenschaft können die folgenden Gleichungen verwendet werden. Index, die Indexnummer des RulerLevel-Objekts, zeigt die dem Objekt entsprechende Gliederungsebene an. Zum Bestimmen der Minimalwerte für die LeftMargin-Eigenschaft der RulerLevel-Objekte, welche der zweiten bis fünften Gliederungsebene entsprechen, setzen Sie für Index 2, 3, 4 oder 5 ein.

    Minimum(RulerLevel(Index).FirstMargin) = Maximum(RulerLevel(Index -1).FirstMargin, RulerLevel(Index -1).LeftMargin) + 9

    Minimum(RulerLevel(Index).LeftMargin) = Maximum(RulerLevel(Index -1).FirstMargin, RulerLevel(Index -1).LeftMargin) + 9


Beispiel zur LeftMargin-Eigenschaft

In diesem Beispiel werden der Erstzeileneinzug und der hängende Einzug für Gliederungsebene 1 beim Textkörper im Folienmaster für die aktive Präsentation festgelegt.

With Application.ActivePresentation _
        .SlideMaster.TextStyles(ppBodyStyle)
    With .Ruler.Levels(1)
        .FirstMargin = 9
        .LeftMargin = 54
    End With
End With


Length-Eigenschaft

CalloutFormat-Objekt: Wenn für die AutoLength-Eigenschaft der angegebenen Legende False festgelegt wird, gibt die Length-Eigenschaft die Länge des ersten Abschnitts der Legendenlinie (der Abschnitt, der mit dem Legendentextfeld verbunden ist) in Punkt zurück. Dies betrifft nur Legenden, deren Linien aus mehreren Abschnitten bestehen (die Typen msoCalloutThree und msoCalloutFour). Single Nur-Lese-Zugriff.

TextRange-Objekt: Gibt die Länge des angegebenen Textbereichs in Zeichen zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der CustomLength-Methode können Sie den Wert dieser Eigenschaft für das CalloutFormat-Objekt festlegen.


Beispiel zur Length-Eigenschaft

Hat der erste Linienabschnitt in der Legende "lg1" eine feste Länge, gibt dieses Beispiel an, dass die Länge des ersten Linienabschnitts in der Legende "lg2" die gleiche feste Länge hat. Damit dieses Beispiel funktioniert, müssen beide Legenden Linien mit mehreren Abschnitten haben.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    With .Item("co1").Callout
        If Not .AutoLength Then len1 = .Length
    End With
    If len1 Then .Item("co2").Callout.CustomLength len1
End With

Dieses Beispiel legt für den Schriftgrad des Titels 48 Punkt fest, wenn der Titel von Folie 2 mehr als 5 Zeichen hat. Enthält der Titel genau 5 Zeichen oder weniger, wird ein Schriftgrad von 72 Punkt festgelegt.

Set myDocument = ActivePresentation.Slides(2)
With myDocument.Shapes(1).TextFrame.TextRange
    If .Length > 5 Then
        .Font.Size = 48
    Else
        .Font.Size = 72
    End If
End With


Levels-Eigenschaft

Ruler-Objekt: Gibt ein RulerLevels-Objekt zurück, das die Einzugsformatierung einer Gliederung darstellt. Nur-Lese-Zugriff.

TextStyle-Objekt: Gibt ein TextStyleLevels-Objekt zurück, das die Textformatierung einer Gliederung darstellt. Nur-Lese-Zugriff.


Beispiel zur Levels-Eigenschaft

In diesem Beispiel werden der Erstzeileneinzug und hängende Einzug für Gliederungsebene 1 beim Textkörper im Folienmaster für die aktive Präsentation festgelegt. Anschließend werden der Name und die Größe der Schrift für den Text dieser Ebene festgelegt.

With Application.ActivePresentation _
        .SlideMaster.TextStyles(ppBodyStyle)
    With .Ruler.Levels(1) ' sets indents for level 1
        .FirstMargin = 9
        .LeftMargin = 54
    End With
    With .Levels(1).Font  ' sets text formatting for level 1
        .Name = "arial"
        .Size = 36
    End With
End With


Line-Eigenschaft

Gibt ein LineFormat-Objekt zurück, das die Formateigenschaften der Linien für die angegebene Form enthält. (Bei einer Linie stellt das LineFormat-Objekt die Linie selbst dar. Bei einer Form mit einem Rahmen stellt das LineFormat-Objekt den Rahmen dar.) Nur-Lese-Zugriff.


LineRuleAfter-Eigenschaft

True, wenn für den Zeilenabstand nach der letzten Zeile bei jedem Absatz eine bestimmte Zeilenzahl festgelegt wird. False, wenn für den Zeilenabstand eine bestimmte Punktzahl festgelegt wird. Long Schreib-Lese-Zugriff.


Beispiel zur LineRuleAfter-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld eingeblendet, das die Festlegung des Abstands nach Absätzen für den Text von Form 2 in Folie 1 der aktiven Präsentation anzeigt.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat
        sa = .SpaceAfter
        If .LineRuleAfter Then
            saUnits = " lines"
        Else
            saUnits = " points"
        End If
    End With
End With
MsgBox "Current spacing after paragraphs: " & sa & saUnits


LineRuleBefore-Eigenschaft

True, wenn für den Zeilenabstand vor der ersten Zeile bei jedem Absatz eine bestimmte Zeilenzahl festgelegt wird. False, wenn für den Zeilenabstand eine bestimmte Punktzahl festgelegt wird. Long Schreib-Lese-Zugriff.


Beispiel zur LineRuleBefore-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld eingeblendet, das die Festlegung des Abstands vor Absätzen für den Text von Form 2 in Folie 1 der aktiven Präsentation anzeigt.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat
        sb = .SpaceBefore
        If .LineRuleBefore Then
            sbUnits = " lines"
        Else
            sbUnits = " points"
        End If
    End With
End With
MsgBox "Current spacing before paragraphs: " & sb & sbUnits


LineRuleWithin-Eigenschaft

True, wenn für den Zeilenabstand zwischen Grundlinien eine bestimmte Zeilenzahl festgelegt wird. False, wenn für den Zeilenabstand eine bestimmte Punktzahl festgelegt wird. Long Schreib-Lese-Zugriff.


Beispiel zur LineRuleWithin-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld eingeblendet, das die Festlegung des Zeilenabstands für den Text von Form 2 in Folie 1 der aktiven Präsentation anzeigt.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat
        ls = .SpaceWithin
        If .LineRuleWithin Then
            lsUnits = " lines"
        Else
            lsUnits = " points"
        End If
    End With
End With
MsgBox "Current line spacing: " & ls & lsUnits


LinkFormat-Eigenschaft

Gibt ein LinkFormat-Objekt zurück, das die feststehenden besonderen Eigenschaften für verknüpfte OLE-Objekte enthält. Nur-Lese-Zugriff.


Beispiel zur LinkFormat-Eigenschaft

Dieses Beispiel aktualisiert die Verknüpfungen zwischen sämtlichen OLE-Objekten in Folie 1 der aktiven Präsentation und deren Quelldateien.

For Each sh In ActivePresentation.Slides(1).Shapes
    If sh.Type = msoLinkedOLEObject Then
        With sh.LinkFormat
            .Update
        End With
    End If
Next


Loaded-Eigenschaft

True, wenn das angegebene Add-In geladen wird. Es sind im Dialogfeld Add-Ins (Menü Extras) die Kontrollkästchen neben den geladenen Add-Ins aktiviert. Long Schreib-Lese-Zugriff.


Beispiel zur Loaded-Eigenschaft

Dieses Beispiel fügt der Liste im Dialogfeld Add-Ins (Menü Extras) die Datei mytools.ppa hinzu, die anschließend geladen wird.

Addins.Add("c:\my documents\mytools.ppa").Loaded = True

Dieses Beispiel entlädt das Add-In "mytools."

Application.Addins("mytools").Loaded = False


LockAspectRatio-Eigenschaft

True, wenn die angegebene Form ihre ursprünglichen Proportionen beibehält, wenn Sie deren Größe ändern. False, wenn Sie beim Ändern der Größe einer Form dessen Höhe und Breite unabhängig voneinander verändern können. Long Schreib-Lese-Zugriff.


Beispiel zur LockAspectRatio-Eigenschaft

Dieses Beispiel fügt zu myDocument einen Würfel hinzu. Sie können zwar die Größe des Würfels ändern und diesen verschieben, das Seitenverhältnis bleibt jedoch unberührt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddShape(msoShapeCube, 50, 50, 100, 200) _
    .LockAspectRatio = True


LoopSoundUntilNext-Eigenschaft

True, wenn der für den angegebenen Folienübergang festgelegte Klang so lange wiederholt wird, bis der nächste Klang beginnt. Long Nur-Lese-Zugriff.


Beispiel zur LoopSoundUntilNext-Eigenschaft

Dieses Beispiel legt fest, dass die Datei Dudududu.wav beim Übergang zu Folie 2 der aktiven Präsentation kontinuierlich bis zum Beginn des nächsten Klangs wiedergegeben wird.

With ActivePresentation.Slides(2).SlideShowTransition
    .SoundEffect.ImportFromFile "c:\sndsys\dudududu.wav"
    .LoopSoundUntilNext = True
End With


LoopUntilStopped-Eigenschaft

PlaySettings-Objekt: True, wenn der angegebene Film oder Klang sich so lange fortlaufend wiederholt, bis entweder der nächste Film bzw. Klang beginnt, oder der Benutzer auf die Folie klickt, oder ein Folienübergang stattfindet. Long Schreib-Lese-Zugriff.

SlideShowSettings-Objekt: True, wenn die angegebene Bildschirmpräsentation so lange fortlaufend wiedergegeben wird, bis der Benutzer Esc drückt. Long Schreib-Lese-Zugriff.


Beispiel zur LoopUntilStopped-Eigenschaft

Dieses Beispiel gibt an, dass Form 3 in Folie 1 der aktiven Präsentation in der Animationsreihenfolge so lange fortlaufend wiedergegeben wird, bis der nächste Medienclip beginnt. Form 3 muss ein Sound- oder Filmobjekt sein.

ActivePresentation.Slides(1).Shapes(3) _
    .AnimationSettings.PlaySettings.LoopUntilStopped = True

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, die die Folien automatisch (mit den gespeicherten Zeiteinstellungen) wechselt. Diese Bildschirmpräsentation wird so lange fortlaufend in der Präsentation wiedergegeben, bis der Benutzer ESC drückt.

With ActivePresentation.SlideShowSettings
    .AdvanceMode = ppSlideShowUseSlideTimings
    .LoopUntilStopped = True
    .Run
End With


MarginBottom-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem unteren Rand des Textrahmens und dem unteren Rand des beschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginBottom-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Rechteck und dem Rechteck Text hinzugefügt. Anschließend werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 10
    .MarginRight = 0
    .MarginTop = 20
End With


MarginLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem linken Rand des Textrahmens und dem linken Rand des beschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginLeft-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Rechteck und dem Rechteck Text hinzugefügt. Anschließend werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 10
    .MarginRight = 0
    .MarginTop = 20
End With


MarginRight-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem rechten Rand des Textrahmens und dem rechten Rand des beschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginRight-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Rechteck und dem Rechteck Text hinzugefügt. Anschließend werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 10
    .MarginRight = 5
    .MarginTop = 20
End With


MarginTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem oberen Rand des Textrahmens und dem oberen Rand des beschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginTop-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Rechteck und dem Rechteck Text hinzugefügt. Anschließend werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 10
    .MarginRight = 0
    .MarginTop = 20
End With


Master-Eigenschaft

Gibt ein Master-Objekt zurück, das den Folienmaster darstellt. Nur-Lese-Zugriff.


Beispiel zur Master-Eigenschaft

Dieses Beispiel legt die Hintergrundfüllung für den Folienmaster für Folie 1 der aktiven Präsentation fest.

ActivePresentation.Slides(1).Master.Background.Fill _
    .PresetGradient msoGradientDiagonalUp, 1, msoGradientDaybreak


MediaType-Eigenschaft

Gibt den OLE-Medientyp zurück. Dies kann eine der folgenden PpMediaType-Konstanten sein: ppMediaTypeMixed, ppMediaTypeMovie, ppMediaTypeOther oder ppMediaTypeSound. Long Nur-Lese-Zugriff.


Beispiel zur MediaType-Eigenschaft

Dieses Beispiel legt für alle plattformspezifischen Klangobjekte in Folie 1 der aktiven Präsentation fest, dass diese so lange während einer Bildschirmpräsentation fortlaufend wiederholt werden, bis sie manuell angehalten werden.

For Each so In ActivePresentation.Slides(1).Shapes
    If so.Type = msoMedia Then
        If so.MediaType = ppMediaTypeSound Then
            so.AnimationSettings.PlaySettings _
                .LoopUntilStopped = True
        End If
    End If
Next


Name-Eigenschaft

Gibt den Namen des angegebenen Objekts zurück oder legt diesen fest. Sie können den Namen des Objekts in Verbindung mit der Item-Methode verwenden, um einen Bezug zum Objekt herzustellen, wenn für die Item-Methode für die Auflistung, die das Objekt enthält, ein Variant-Argument gilt. Lautet z. B. der Wert der Name-Eigenschaft für eine Form "Rectangle 2", so gibt .Shapes("Rectangle 2") einen Bezug zu dieser Form zurück. Die folgende Tabelle enthält Informationen über die Name-Eigenschaft für jedes Objekt, das ihr zugewiesen wird.

Objekt | Details zur Name-Eigenschaft
AddIn | Der Name (Titel) des Add-Ins für registrierte Dateitypen. String Nur-Lese-Zugriff.
Application | Gibt die Zeichenfolge "Microsoft PowerPoint" zurück. String Nur-Lese-Zugriff.
Font | String Schreib-Lese-Zugriff.
Master | String Schreib-Lese-Zugriff.
NamedSlideShow | Sie können diese Eigenschaft nicht verwenden, um den Namen für eine benutzerdefinierte Bildschirmpräsentation festzulegen. Mit der Add-Methode können Sie eine benutzerdefinierte Bildschirmpräsentation unter einem neuen Namen neu definieren. String Nur-Lese-Zugriff.
Presentation | Der Name der Präsentation enthält die Dateinamenerweiterung (für registrierte Dateitypen), jedoch nicht den Pfad. Sie können diese Eigenschaft nicht verwenden, um den Namen festzulegen. Mit der SaveAs-Methode können Sie die Präsentation unter einem anderen Namen speichern, wenn Sie den Namen ändern müssen. String Nur-Lese-Zugriff.
Shape oder ShapeRange (der Formbereich muss genau eine Form enthalten) | Wenn Sie eine Form erstellen, weist Powerpoint im Formular FormTyp Zahl automatisch einen Namen zu. FormTyp bezeichnet den Typ der Form oder der AutoForm und Zahl ist eine ganze Zahl, die innerhalb der Auflistung der Formen auf der Folie eindeutig ist. Die automatisch generierten Namen der Formen einer Folie können z. B. "Platzhalter 1", "Oval 2" und "Rechteck 3" lauten. Um nicht mit automatisch zugewiesenen Namen in Konflikt zu geraten, verwenden Sie das Formular ShapeType Number nicht für benutzerdefinierte Namen, wenn es sich bei FormTyp um einen Wert handelt, der für automatisch generierte Namen verwendet wird, und Zahl eine positive ganze Zahl ist. String Schreib-Lese-Zugriff.
Slide oder SlideRange (der Folienbereich muss genau eine Folie enthalten) | Wenn eine Folie in eine Präsentation eingefügt wird, weist PowerPoint automatisch einen Namen im Formular Sliden zu. Hierbei handelt es sich bei n um eine ganze Zahl, die die Reihenfolge darstellt, in der die Folie in der Präsentation erstellt wurde. So wird z. B. die erste Folie, die in eine Präsentation eingefügt wird, automatisch mit "Folie1" bezeichnet. Wenn Sie eine Folie von einer Präsentation in eine andere kopieren, hat die Folie nicht mehr den gleichen Namen wie in der ersten Präsentation, und es wird ihr in der zweiten Präsentation automatisch ein neuer Name zugewiesen. String Schreib-Lese-Zugriff.
SoundEffect | Gültige Namen für eine Präsentation finden Sie im Feld Klang im Dialogfeld Folienübergang (Menü Bildschirmpräsentation). String Schreib-Lese-Zugriff.


NameAscii-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the font used for ASCII characters (characters with character set numbers within the range of 0 to 127). Read/write String.

Remarks

The default value of this property is Times New Roman. Use the Replace method to change the font that’s applied to all text and that appears in the Font box on the Formatting toolbar.


Beispiel zur NameAscii-Eigenschaft

This example sets the font used for ASCII characters in the title of the first slide to Century.

Application.ActivePresentation.Slides(1).Shapes.Title _
    .TextFrame.TextRange.Font.NameAscii = "Century"


NameComplexScript-Eigenschaft

Gibt den Namen der Schriftart für komplexe Schriftzeichen zurück oder legt diesen fest. Diese Eigenschaft wird für Text verwendet, der mehrere Sprachen enthält. String Schreib-Lese-Zugriff.

Hinweise

Wenn Sie eine Schrift mit Schreibweise von rechts nach links eingestellt haben, entspricht diese Eigenschaft der Liste Schriftarten für asiatische und komplexe Schriftzeichen im Dialogfeld Zeichen (Menü Format). Wenn Sie eine asiatische Schrift eingestellt haben, entspricht diese Eigenschaft der Liste Asiatische Schriftarten im Dialogfeld Zeichen (Menü Format).


Beispiel zur NameComplexScript-Eigenschaft

In diesem Beispiel wird die Schriftart für komplexe Schriftzeichen auf Times New Roman gesetzt.

ActivePresentation.Slides(1).Shapes.Title.TextFrame _
    .TextRange.Font.NameComplexScript = "Times New Roman"


NamedSlideShows-Eigenschaft

Gibt eine NamedSlideShows-Auflistung zurück, die alle benannten Bildschirmpräsentationen (benutzerdefinierten Bildschirmpräsentationen) in der angegebenen Präsentation darstellt. Jede benannte Bildschirmpräsentation oder benutzerdefinierte Bildschirmpräsentation ist eine vom Anwender markierte Untermenge der angegebenen Präsentation. Nur-Lese-Zugriff.

Anmerkungen

Mit der Add-Methode des NamedSlideShows-Objekts können Sie eine benannte Bildschirmpräsentation erstellen.


Beispiel zur NamedSlideShows-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation die benannte Bildschirmpräsentation "Quick Show" hinzu, die die Folien 2, 7 und 9 enthält. Anschließend startet dieses Beispiel die Bildschirmpräsentation.

Dim qSlides(1 To 3) As Long
With ActivePresentation
    With .Slides
        qSlides(1) = .Item(2).SlideID
        qSlides(2) = .Item(7).SlideID
        qSlides(3) = .Item(9).SlideID
    End With
    With .SlideShowSettings
        .RangeType = ppShowNamedSlideShow
        .NamedSlideShows.Add "Quick Show", qSlides
        .SlideShowName = "Quick Show"
        .Run
    End With
End With


NameFarEast-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the Asian font name. Read/write String.

Remarks

Use the Replace method to change the font that’s applied to all text and that appears in the Font box on the Formatting toolbar.


Beispiel zur NameFarEast-Eigenschaft

This example displays the name of the Asian font applied to the selection.

MsgBox ActiveWindow.Selection.ShapeRange _
    .TextFrame.TextRange.Font.NameFarEast


NameOther-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the font used for characters whose character set numbers are greater than 127. Read/write String.

Remarks

In the U.S. English version of Microsoft PowerPoint, this property is read-only and the default value is Times New Roman. Use the Replace method to change a font in a presentation. The NameOther property setting is the same as the NameASCII property setting except when the NameASCII property is set to "Use FE Font."


Beispiel zur NameOther-Eigenschaft

This example sets the font used for characters whose character set numbers are greater than 127, for the first member of the Fonts collection.

ActivePresentation.Fonts(1).NameOther = "Tahoma"


Nodes-Eigenschaft

Gibt eine ShapeNodes-Auflistung zurück, die die geometrische Beschreibung der angegebenen Form darstellt. Betrifft Shape- oder ShapeRange-Objekte, die Freihandfiguren darstellen.


Beispiel zur Nodes-Eigenschaft

Dieses Beispiel fügt einen glatten Knoten mit einem gekrümmten Abschnitt nach Knoten 4 in Form 3 bei myDocument hinzu. Form 3 muss eine Freihandfigur mit mindestens vier Knoten sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With


NoLineBreakAfter-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the characters that cannot end a line. Read/write String.


Beispiel zur NoLineBreakAfter-Eigenschaft

This example sets "$", "(", "[", "\", and "{" as characters that cannot end a line.

With ActivePresentation
    .FarEastLineBreakLevel = ppFarEastLineBreakLevelCustom
    .NoLineBreakAfter =  "$([\{"
End With


NoLineBreakBefore-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the characters that cannot begin a line. Read/write String.


Beispiel zur NoLineBreakBefore-Eigenschaft

This example sets "!", ")", and "]" as characters that cannot begin a line.

With ActivePresentation
    .FarEastLineBreakLevel = ppFarEastLineBreakLevelCustom
    .NoLineBreakBefore =  "!)]"
End With


NormalizedHeight-Eigenschaft

True, wenn alle Zeichen (Groß- und Kleinbuchstaben) in der angegebenen WordArt die gleiche Höhe haben. Long Schreib-Lese-Zugriff.


Beispiel zur NormalizedHeight-Eigenschaft

Dieses Beispiel fügt zu myDocument WordArt mit dem Text "Test Effect" zurück und gibt der neuen WordArt den Namen "texteff1". Anschließend wird allen Zeichen der Form "texteff1" die gleiche Höhe zugewiesen.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddTextEffect(PresetTextEffect:=msoTextEffect1, _
    Text:="Test Effect", FontName:="Courier New", _
    FontSize:=44, FontBold:=True, _
    FontItalic:=False, Left:=10, Top:=10)_
    .Name = "texteff1"
myDocument.Shapes("texteff1").TextEffect.NormalizedHeight = True


NotesMaster-Eigenschaft

Gibt ein Master-Objekt zurück, das den Notizenmaster darstellt. Nur-Lese-Zugriff.


Beispiel zur NotesMaster-Eigenschaft

In diesem Beispiel wird der Text der Kopf- und Fußzeile beim Notizenmaster für die aktive Präsentation festgelegt.

With Application.ActivePresentation.NotesMaster.HeadersFooters
    .Header.Text = "Employee Guidelines"
    .Footer.Text = "Volcano Coffee"
End With


NotesOrientation-Eigenschaft

Gibt das Format für den Druck und das Format am Bildschirm für Notizzettelseiten, Handzettel und Gliederungen für die angegebene Präsentation zurück oder legt dieses fest. Dies kann eine der folgenden MsoOrientation-Konstanten sein: msoOrientationHorizontal, msoOrientationMixed oder msoOrientationVertical. Long Schreib-Lese-Zugriff.


Beispiel zur NotesOrientation-Eigenschaft

In diesem Beispiel wird für alle Notizzettelseiten, Handzettel und Gliederungen in der aktiven Präsentation das Querformat festgelegt.

Application.ActivePresentation.PageSetup.NotesOrientation = _
    msoOrientationHorizontal


NotesPage-Eigenschaft

Gibt ein SlideRange-Objekt zurück, das die Notizenseiten für die angegebene Folie oder den angegebenen Folienbereich darstellt. Nur-Lese-Zugriff.

Hinweis Folgende Eigenschaften und Methoden schlagen fehl, wenn sie einem SlideRange-Objekt zugewiesen werden, das eine Notizenseite darstellt: Copy-Methode, Cut-Methode, Delete-Methode, Duplicate-Methode, HeadersFooters-Eigenschaft, Hyperlinks-Eigenschaft, Layout-Eigenschaft, PrintSteps-Eigenschaft, SlideShowTransition-Eigenschaft.

Anmerkungen

Die NotesPage-Eigenschaft gibt die Notizenseite entweder für eine einzelne Folie oder einen Folienbereich zurück. Sie können nur Änderungen an diesen Notizenseiten vornehmen. Möchten Sie Änderungen vornehmen, die sich auf alle Notizenseiten auswirken, können Sie mit der NotesMaster-Eigenschaft das Slide-Objekt zurückgeben, das den Notizenmaster darstellt.


Beispiel zur NotesPage-Eigenschaft

Dieses Beispiel legt die Hintergrundfüllung für die Notizenseite für Folie 1 der aktiven Präsentation fest.

With ActivePresentation.Slides(1).NotesPage
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient _
        msoGradientHorizontal, 1, msoGradientLateSunset
End With


Number-Eigenschaft

Gibt die Nummer des Aufzählungszeichens in einem Absatz zurück, wenn die Type-Eigenschaft des BulletFormat-Objekts auf ppBulletNumbered gesetzt ist. Long Nur-Lese-Zugriff.

Hinweis

Wenn diese Eigenschaft für mehrere Absätze mit verschiedenen Nummern abgefragt wird, wird der Wert ppBulletMixed zurückgegeben. Wenn diese Eigenschaft für einen Absatz eines anderen Typs als ppBulletNumbered abgefragt wird, tritt ein Laufzeitfehler auf.


NumberOfCopies-Eigenschaft

Gibt die Anzahl der zu druckenden Kopien der Präsentation zurück oder legt diese fest. Der Standardwert ist 1. Long Schreib-Lese-Zugriff.

Anmerkungen

Mit Angabe eines Wertes für das Copies-Argument der PrintOut-Methode wird der Wert dieser Eigenschaft festgelegt.


Beispiel zur NumberOfCopies-Eigenschaft

Dieses Beispiel druckt drei sortierte Kopien der aktiven Präsentation.

With ActivePresentation.PrintOptions
    .NumberOfCopies = 3
    .Collate = True
    .Parent.PrintOut
End With


Object-Eigenschaft

Gibt das Objekt zurück, das die höchste Schnittstelle des angegebenen OLE-Objekts darstellt. Mit dieser Eigenschaft können Sie auf die Eigenschaften und Methoden der Anwendung zugreifen, in der ein OLE-Objekt erstellt wurde. Nur-Lese-Zugriff.

Anmerkungen

Mit der TypeName-Funktion können Sie den Typ des Objekts bestimmen, den diese Eigenschaft für ein bestimmtes OLE-Objekt zurückgibt.


 ObjectVerbs-Eigenschaft

ObjectVerbs-Eigenschaft

Gibt eine ObjectVerbs-Auflistung zurück, die alle OLE-Verben für das angegebene OLE-Objekt enthält. Nur-Lese-Zugriff.


Beispiel zur ObjectVerbs-Eigenschaft

Dieses Beispiel zeigt alle verfügbaren Verben für das OLE-Objekt in Form 1 von Folie 2 in der aktiven Präsentation an. Damit dieses Beispiel funktioniert, muss Form 1 eine Form sein, die ein OLE-Objekt darstellt.

With ActivePresentation.Slides(2).Shapes(1).OLEFormat
    For Each v In .ObjectVerbs
        MsgBox v
    Next
End With

Dieses Beispiel gibt an, dass sich das durch Form 1 dargestellte OLE-Objekt in Folie 2 in der aktiven Präsentation öffnet, wenn während einer Bildschirmpräsentation darauf geklickt wird, falls es sich bei "Open" um eines der OLE-Verben für das Objekt handelt. Damit dieses Beispiel funktioniert, muss Form 1 eine Form sein, die ein OLE-Objekt darstellt.

With ActivePresentation.Slides(2).Shapes(1)
    For Each sVerb In .OLEFormat.ObjectVerbs
        If sVerb = "Open" Then
            With .ActionSettings(ppMouseClick)
                .Action = ppActionOLEVerb
                .ActionVerb = sVerb
            End With
            Exit For
        End If
    Next
End With


Obscured-Eigenschaft

True, wenn der Schatten der angegebenen Form auch dann ausgefüllt erscheint und von der Form verdeckt wird, wenn die Form keine Füllung hat. False, wenn der Schatten keine Füllung hat und die Umrisse des Schattens durch die Form so sichtbar sind, als hätte die Form keine Füllung. Long Schreib-Lese-Zugriff.


Beispiel zur Obscured-Eigenschaft

Dieses Beispiel legt die horizontalen und vertikalen Schattenpositionen für Form 3 in myDocument fest. Der Schatten wird um 5 Punkt nach rechts und 3 Punkt nach oben von der Form versetzt. Wenn dieser Form noch kein Schatten zugewiesen wurde, fügt dieses Beispiel einen hinzu. Der Schatten wird ausgefüllt und von der Form selbst dann verdeckt, wenn die Form keine Füllung hat.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
    .Obscured = True
End With


OffsetX-Eigenschaft

Gibt die horizontale Schattenposition von der angegebenen Form in Punkt zurück oder legt diese fest. Ein positiver Wert versetzt den Schatten nach rechts, ein negativer Wert versetzt den Schatten nach links von der Form. Single Schreib-Lese-Zugriff.

Anmerkungen

Mit der IncrementOffsetX- oder IncrementOffsetY-Methode können Sie einen Schatten horizontal oder vertikal von der aktuellen Position am Raster ausrichten, ohne eine absolute Position angeben zu müssen.


Beispiel zur OffsetX-Eigenschaft

Dieses Beispiel legt die horizontalen und vertikalen Schattenpositionen für Form 3 in myDocument fest. Der Schatten wird um 5 Punkt nach rechts und 3 Punkt nach oben von der Form versetzt. Wenn dieser Form noch kein Schatten zugewiesen wurde, fügt dieses Beispiel einen hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OffsetY-Eigenschaft

Gibt die vertikale Schattenposition von der angegebenen Form in Punkt zurück, oder legt diese fest. Ein positiver Wert versetzt den Schatten nach unten, ein negativer Wert versetzt den Schatten nach oben von der Form. Single Schreib-Lese-Zugriff.

Anmerkungen

Mit der IncrementOffsetX- oder IncrementOffsetY-Methode können Sie einen Schatten horizontal oder vertikal von der aktuellen Position am Raster ausrichten, ohne eine absolute Position angeben zu müssen.


Beispiel zur OffsetY-Eigenschaft

Dieses Beispiel legt die horizontalen und vertikalen Schattenpositionen für Form 3 in myDocument fest. Der Schatten wird um 5 Punkt nach rechts und 3 Punkt nach oben von der Form versetzt. Wenn dieser Form noch kein Schatten zugewiesen wurde, fügt dieses Beispiel einen hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OLEFormat-Eigenschaft

Gibt ein OLEFormat-Objekt zurück, das OLE-Formateigenschaften für die angegebene Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die OLE-Objekte darstellen. Nur-Lese-Zugriff.


Beispiel zur OLEFormat-Eigenschaft

Dieses Beispiel durchläuft alle Objekte auf allen Folien der aktiven Präsentation und legt fest, dass alle verknüpften Dokumente von Microsoft Word manuell aktualisiert werden müssen.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Word.Document" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


OperatingSystem-Eigenschaft

Gibt den Namen des Betriebssystems zurück. String Nur-Lese-Zugriff.


Beispiel zur OperatingSystem-Eigenschaft

In diesem Beispiel prüft die OperatingSystem-Eigenschaft, ob PowerPoint unter einer 32-Bit-Version von Microsoft Windows läuft.

os = Application.OperatingSystem
If InStr(os, "Windows (32-bit)") <> 0 Then
    MsgBox "Running a 32-bit version of Microsoft Windows"
End If


OrganizeInFolder-Eigenschaft

True, wenn alle Hilfsdateien, wie Hintergrundbilder und Grafiken, beim Speichern der Präsentation als Webseite in einem separaten Ordner organisiert werden. False, wenn die Hilfsdateien im selben Ordner wie die Webseite gespeichert werden. Der Standardwert ist True. Long Schreib-Lese-Zugriff.

Hinweis

Der neue Ordner wird in dem Ordner erstellt, in dem Sie die Webseite gespeichert haben, und nach der Präsentation benannt. Wenn die UseLongFileNames-Eigenschaft auf True gesetzt ist, wird eine Endung an den Ordnernamen angehängt.

Wenn sie eine Präsentation speichern, deren OrganizeInFolder-Eigenschaft auf einen anderen Wert eingestellt war, verschiebt Microsoft PowerPoint automatisch die Hilfsdateien in die oder aus den entsprechenden Ordnern.

Wenn Sie keine langen Dateinamen verwenden, (d. h., wenn die UseLongFileNames-Eigenschaft auf False gesetzt ist), speichert PowerPoint die Hilfsdateien automatisch in einem separaten Ordner. Die Dateien können nicht in demselben Ordner wie die Webseite gespeichert werden.


Beispiel zur OrganizeInFolder-Eigenschaft

In diesem Beispiel wird festgelegt, dass beim Speichern bzw. Veröffentlichen von Präsentation 2 als Webseite alle Hilfsdateien im selben Ordner wie die Präsentation gespeichert werden.

Presentations(2).WebOptions.OrganizeInFolder = False


Orientation-Eigenschaft

Sprachspezifische Informationen

Returns or sets text orientation. Can be one of the following MsoTextOrientation constants: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical, or msoTextOrientationVerticalFarEast. Some of these constants may not be available to you, depending on the language support (U.S. English, for example) that you’ve selected or installed. Read/write Long.


Beispiel zur Orientation-Eigenschaft

In diesem Beispiel wird der Text innerhalb der Form drei in myDocument horizontal ausgerichtet.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(3).TextFrame _
    .Orientation = msoTextOrientationHorizontal


OutputType-Eigenschaft

Gibt einen Wert zurück, der die Komponente (Folien, Handzettel, Notizenseiten oder eine Gliederung) der zu druckenden Präsentation anzeigt, oder legt diesen fest. Dies kann eine der folgenden PpPrintOutputType-Konstanten sein: ppPrintOutputBuildSlides, ppPrintOutputNotesPages, ppPrintOutputOutline, ppPrintOutputSixSlideHandouts, ppPrintOutputSlides, ppPrintOutputTwoSlideHandouts, ppPrintOutputThreeSlideHandouts, ppPrintOutputFourSlideHandouts oder ppPrintOutputNineSlideHandouts. Der Standardwert ist ppPrintOutputSlides. Long Schreib-Lese-Zugriff.


Beispiel zur OutputType-Eigenschaft

Dieses Beispiel druckt Handzettel der aktiven Präsentation mit sechs Folien pro Seite.

With ActivePresentation
    .PrintOptions.OutputType = ppPrintOutputSixSlideHandouts
    .PrintOut
End With


PageSetup-Eigenschaft

Gibt ein PageSetup-Objekt zurück, dessen Eigenschaften die Attribute für die Einrichtung der Folien der aktuellen Präsentation steuern. Nur-Lese-Zugriff.


Beispiel zur PageSetup-Eigenschaft

Im folgenden Beispiel werden die Größe und das Format der Folien der Präsentation "Präs1" festgelegt.

With Presentations("pres1").PageSetup
    .SlideSize = ppSlideSize35MM
    .SlideOrientation = msoOrientationHorizontal
End With


 Panes-Eigenschaft

Panes-Eigenschaft

Gibt eine Panes-Auflistung zurückt, die die Fensterausschnitte im Dokumentfenster darstellt. Nur-Lese-Zugriff.


Beispiel zur Panes-Eigenschaft

In diesem Beispiel wird festgestellt, wie viele Fensterausschnitte im aktiven Fenster vorhanden sind. Wenn der Wert eins ist und dementsprechend nicht die Normalansicht, sondern eine andere Ansicht aktiv ist, wird die Normalansicht aktiviert.

If ActiveWindow.Panes.Count = 1 Then
    ActiveWindow.ViewType = ppViewNormal
End If


ParagraphFormat-Eigenschaft

Gibt ein ParagraphFormat-Objekt zurück, das die Absatzformatierung des angegebenen Textes darstellt. Nur-Lese-Zugriff.


Beispiel zur ParagraphFormat-Eigenschaft

In diesem Beispiel wird in der zweiten Form der ersten Folie in der aktiven Präsentation der Zeilenabstand vor, innerhalb und nach jedem Absatz festgelegt.

With Application.ActivePresentation.Slides(2).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat
        .LineRuleWithin = msoTrue
        .SpaceWithin = 1.4
        .LineRuleBefore = msoTrue
        .SpaceBefore = 0.25
        .LineRuleAfter = msoTrue
        .SpaceAfter = 0.75
    End With
End With


Parent-Eigenschaft

Gibt das übergeordnete Objekt für das angegebene Objekt zurück. Nur-Lese-Zugriff.


Beispiel zur Parent-Eigenschaft

In diesem Beispiel wird zu Folie 1 der aktiven Präsentation ein Oval mit Textinhalt hinzugefügt und das Oval sowie der Text um 45 Grad gedreht. Das übergeordnete Objekt (Parent) für den Textrahmen ist das Shape-Objekt, das den Text enthält.

Set myShapes = ActivePresentation.Slides(1).Shapes
With myShapes.AddShape(msoShapeOval, 50, 50, 300, 150).TextFrame
    .TextRange.Text = "Test text"
    .Parent.Rotation = 45
End With


Path-Eigenschaft

Gibt den Pfad für das angegebene AddIn-, Application- oder Presentation-Objekt zurück. String Nur-Lese-Zugriff.

Anmerkung Der Pfad enthält nicht den letzten Schrägstrich (\) und den Namen des angegebenen Objekts. Verwenden Sie die Name-Eigenschaft des Presentation-Objekts, um den Dateinamen ohne Pfadangabe zurückzugeben. Verwenden Sie die FullName-Eigenschaft, um den Dateinamen und die Pfadangabe zurückzugeben.

Hinweise

Wenn Sie diese Eigenschaft verwenden, um einen Pfad für eine Präsentation auszulesen, die noch nicht gespeichert wurde, wird eine leere Zeichenfolge zurückgegeben. Wenn Sie diese Eigenschaft verwenden, um einen Pfad für ein Add-In auszulesen, das nicht geladen ist, wird ein Fehler zurückgegeben.


Beispiel zur Path-Eigenschaft

In diesem Beispiel wird die aktive Präsentation im gleichen Ordner gespeichert, in dem auch PowerPoint gespeichert ist.

With Application
    fName = .Path & "\test presentation"
    ActivePresentation.SaveAs fName
End With


Pattern-Eigenschaft

Gibt einen Wert zurück, der das Muster darstellt, das der angegebenen Füllung oder Linie zugewiesen wurde oder legt diesen fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBrick

msoPatternDivot

msoPatternDottedDiamond

msoPatternDottedGrid

msoPatternHorizontalBrick

 msoPatternLargeCheckerBoard

msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamond

msoPatternPlaid

msoPatternShingle

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamond

msoPatternSphere

msoPatternTrellis

msoPatternWave

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal

msoPatternZigZag

Mit der BackColor- und der ForeColor-Eigenschaft können Sie die Farben festlegen, die im Muster verwendet werden.


Beispiel zur Pattern-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt für das Füllmuster fest, dass es der Füllung der Form "Rechteck1" angepasst wird. Das neue Rechteck hat zwar das gleiche Muster wie Rechteck1, muss jedoch nicht die gleichen Farben haben. Die Farben für das Muster werden mit der BackColor- und ForeColor-Eigenschaft festgelegt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    pattern1 = .Item("rect1").Fill.Pattern
    With .AddShape(msoShapeRectangle, 100, 100, 120, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .BackColor.RGB = RGB(0, 0, 255)
        .Patterned pattern1
    End With
End With

Dieses Beispiel fügt eine gemusterte Linie zu myDocument hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


PauseAnimation-Eigenschaft

True, wenn die Bildschirmpräsentation angehalten wird, bis der angegebene Medienclip die Wiedergabe beendet hat. False, wenn die Bildschirmpräsentation ausgeführt wird, während der Medienclip im Hintergrund wiedergegeben wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Damit die PauseAnimation-Eigenschaft funktioniert, muss für die PlayOnEntry-Eigenschaft der angegebenen Form True gelten.


Beispiel zur PauseAnimation-Eigenschaft

Dieses Beispiel gibt an, dass Form 3 in Folie 1 der aktiven Präsentation automatisch wiedergegeben wird, wenn sie animiert wird. Außerdem fährt die Bildschirmpräsentation nicht fort, während der Film im Hintergrund wiedergegeben wird. Form 3 muss ein Klang- oder Filmobjekt sein.

Set OLEobj = ActivePresentation.Slides(1).Shapes(3)
With OLEobj.AnimationSettings.PlaySettings
    .PlayOnEntry = True
    .PauseAnimation = True
End With


Perspective-Eigenschaft

True, wenn die Projektion perspektivisch erscheint, d. h. wenn sich die Wände der Projektion zu einem Fluchtpunkt hin verengen. False, wenn es sich bei der Projektion um eine parallele bzw. orthogonale Projektion handelt, d. h. wenn sich die Wände nicht zu einem Fluchtpunkt hin verengen. Long Schreib-Lese-Zugriff.


Beispiel zur Perspective-Eigenschaft

In diesem Beispiel wird die Projektionstiefe für Form 1 in myDocument auf 100 Punkt festgelegt und die Projektion als parallel bzw. orthogonal angegeben.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .Depth = 100
    .Perspective = False
End With


PictureFormat-Eigenschaft

Gibt ein PictureFormat-Objekt zurück, das Formateigenschaften für Grafiken für die angegebene Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die Grafiken oder OLE-Objekte darstellen. Nur-Lese-Zugriff.


Beispiel zur PictureFormat-Eigenschaft

Dieses Beispiel legt die Helligkeit und den Kontrast für Form 1 in myDocument fest. Form 1 muss eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = .75
End With


PlaceholderFormat-Eigenschaft

Gibt ein PlaceholderFormat-Objekt zurück, das die Eigenschaften enthält, die nur für Platzhalter gelten. Nur-Lese-Zugriff.


Beispiel zur PlaceholderFormat-Eigenschaft

Dieses Beispiel fügt zu Platzhalter 1 von Folie 1 in der aktiven Präsentation Text hinzu, wenn der Platzhalter ein horizontaler Platzhalter für einen Titel ist.

With ActivePresentation.Slides(1).Shapes.Placeholders
    If .Count > 0 Then
        With .Item(1)
            Select Case .PlaceholderFormat.Type
                Case ppPlaceholderTitle
                    .TextFrame.TextRange = "Title Text"
                Case ppPlaceholderCenterTitle
                    .TextFrame.TextRange = "Centered Title Text"
                Case Else
                    MsgBox "There's no horizontal" & _
                        "title on this slide"
            End Select
        End With
    End If
End With


Placeholders-Eigenschaft

Gibt eine Placeholders-Auflistung zurück, die die Auflistung aller Platzhalter einer Folie darstellt. Es kann jeder Platzhalter der Auflistung Text, ein Diagramm, eine Tabelle, ein Organigramm oder ein anderes Objekt enthalten. Nur-Lese-Zugriff.


Beispiel zur Placeholders-Eigenschaft

Dieses Beispiel fügt zu myDocument der aktiven Präsentation eine Folie hinzu. Anschließend wird dem Titel (dem ersten Platzhalter in der Folie) und dem Untertitel Text hinzugefügt.

Set myDocument = ActivePresentation.Slides(1)
With ActivePresentation.Slides _
        .Add(1, ppLayoutTitle).Shapes.Placeholders
    .Item(1).TextFrame.TextRange.Text = "This is the title text"
    .Item(2).TextFrame.TextRange.Text = "This is subtitle text"
End With


PlayOnEntry-Eigenschaft

True, wenn der angegebene Film oder Klang automatisch wiedergegeben wird, wenn dieser animiert wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Durch Setzen dieser Eigenschaft auf True wird die Animate-Eigenschaft des AnimationSettings-Objekts auf True gesetzt. Durch Setzen der Animate-Eigenschaft auf False wird die PlayOnEntry-Eigenschaft automatisch auf False gesetzt.

Mit der ActionVerb-Eigenschaft können Sie das Verb festlegen, das zum Zeitpunkt der Animation des Medienclip aktiviert wird.


Beispiel zur PlayOnEntry-Eigenschaft

Dieses Beispiel gibt an, dass Form 3 in Folie 1 der aktiven Präsentation automatisch wiedergegeben wird, wenn sie animiert wird. Form 3 muss ein Klang- oder Filmobjekt sein.

Set OLEobj = ActivePresentation.Slides(1).Shapes(3)
OLEobj.AnimationSettings.PlaySettings.PlayOnEntry = True


PlaySettings-Eigenschaft

Gibt ein PlaySettings-Objekt zurück, das Informationen über die Wiedergabe des angegebenen Medienclips während einer Bildschirmpräsentation enthält. Nur-Lese-Zugriff.


Beispiel zur PlaySettings-Eigenschaft

Dieses Beispiel fügt einen Film mit der Bezeichnung "globe.avi" in Folie 1 der aktiven Präsentation ein, der automatisch nach dem Folienübergang wiedergegeben wird. Außerdem wird festgelegt, dass das Filmobjekt während der Bildschirmpräsentation ausgeblendet wird, wenn keine Wiedergabe erfolgt.

With ActivePresentation.Slides(1).Shapes.AddOLEObject(Left:=10, _
        Top:=10, Width:=250, Height:=250, _
        FileName:="c:\winnt\clock.avi")
    With .AnimationSettings.PlaySettings
        .PlayOnEntry = True
        .HideWhileNotPlaying = True
    End With
End With


PointerColor-Eigenschaft

SlideShowSettings-Objekt: Gibt die Farbe des Zeigers für die angegebene Präsentation als ColorFormat-Objekt zurück. Diese Farbe wird mit der Präsentation gespeichert und ist immer dann die Standard-Stiftfarbe, wenn Sie die Präsentation anzeigen. Nur-Lese-Zugriff.

SlideShowView-Objekt: Gibt ein ColorFormat-Objekt zurück, das die Farbe des Zeigers für die angegebene Präsentation während einer Bildschirmpräsentation darstellt. Sobald die Bildschirmpräsentation beendet ist, gilt wieder die Standardfarbe für die Präsentation. Nur-Lese-Zugriff.

Anmerkungen

Um den Zeiger in einen Stift umzuwandeln, legen Sie für die PointerType-Eigenschaft den Wert ppSlideShowPointerPen fest.


Beispiel zur PointerColor-Eigenschaft

Dieses Beispiel legt als Standard-Stiftfarbe für die aktive Präsentation die Farbe Blau fest, startet eine Bildschirmpräsentation, wandelt den Zeiger in einen Stift um. Anschließend wird die Farbe Rot als Stiftfarbe für diese Bildschirmpräsentation festgelegt.

With ActivePresentation.SlideShowSettings
    .PointerColor.RGB = RGB(0, 0, 255)          'blue
    With .Run.View
        .PointerColor.RGB = RGB(255, 0, 0)      'red
        .PointerType = ppSlideShowPointerPen
    End With
End With


PointerType-Eigenschaft

Gibt den in der Bildschirmpräsentation verwendeten Zeigertyp zurück oder legt ihn fest. Dies kann eine der folgenden PpSlideShowPointerType-Konstanten sein: ppSlideShowPointerAlwaysHidden, ppSlideShowPointerArrow, ppSlideShowPointerAutoArrow, ppSlideShowPointerNone oder ppSlideShowPointerPen. Long Schreib-Lese-Zugriff.


Beispiel zur PointerType-Eigenschaft

In diesem Beispiel wird eine Bildschirmpräsentation der aktiven Präsentation gestartet, der Zeiger in einen Stift geändert und die Stiftfarbe für diese Bildschirmpräsentation auf Rot eingestellt.

Set currView = ActivePresentation.SlideShowSettings.Run.View
With currView
    .PointerColor.RGB = RGB(255, 0, 0)
    .PointerType = ppSlideShowPointerPen
End With


 Points-Eigenschaft

Points-Eigenschaft

Gibt die Position des angegebenen Knotens als Koordinatenpaar zurück. Die Koordinaten werden in Punkt ausgedrückt. Variant Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der SetPosition-Methode können Sie den Wert für diese Eigenschaft festlegen.


Beispiel zur Points-Eigenschaft

Dieses Beispiel verschiebt Knoten 2 in Form 3 von myDocument um 200 Punkt nach rechts und um 300 Punkt nach unten. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(1, 1)
    currYvalue = pointsArray(1, 2)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


Position-Eigenschaft

Gibt die Position des angegebenen Tabstops in Punkt zurück oder legt diese fest. Single Schreib-Lese-Zugriff.


Beispiel zur Position-Eigenschaft

In diesem Beispiel werden alle Tabstopps für den Text von Form 2 in Folie 1 der aktiven Präsentation gelöscht, die größer als 1 Zoll (72 Punkt) sind.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .Ruler.TabStops
    For i = .Count To 1 Step -1
        With .Item(i)
            If .Position > 72 Then .Clear
        End With
    Next
End With


Presentation-Eigenschaft

Gibt ein Presentation-Objekt zurück, das die Präsentation darstellt, in der das angegebene Dokumentfenster oder Bildschirmpräsentationsfenster erstellt wurde. Nur-Lese-Zugriff.

Anmerkungen

Wenn die aktuell angezeigte Folie im Dokumentfenster 1 aus einer eingebetteten Präsentation stammt, gibt Windows(1).View.Slide.Parent die eingebettete Präsentation und Windows(1).Presentation die Präsentation zurück, in der Dokumentfenster 1 erstellt wurde.

Wenn die aktuell angezeigte Folie im Bildschirmpräsentationsfenster 1 aus einer eingebetteten Präsentation stammt, gibt SlideShowWindows(1).View.Slide.Parent die eingebettete Präsentation und SlideShowWindows(1).Presentation die Präsentation zurück, in der die Bildschirmpräsentation ausgeführt wurde.


PresentationElapsedTime-Eigenschaft

Gibt die Anzahl der Sekunden zurück, die seit dem Beginn der angegebenen Bildschirmpräsentation verstrichen sind. Long Nur-Lese-Zugriff.


Beispiel zur PresentationElapsedTime-Eigenschaft

In diesem Beispiel wird in Bildschirmpräsentationsfenster 1 zu Folie 7 gewechselt, wenn seit Beginn der Bildschirmpräsentation mehr als fünf Minuten verstrichen sind.

With SlideShowWindows(1).View
    If .PresentationElapsedTime > 300 Then
        .GotoSlide 7
    End If
End With


Presentations-Eigenschaft

Gibt eine Presentations-Auflistung zurück, die alle offenen Präsentationen darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Presentations-Eigenschaft

In diesem Beispiel wird die Präsentation "Long Version.ppt" geöffnet.

Application.Presentations.Open _
    FileName:="c:\My Documents\Long version.ppt"

In diesem Beispiel wird Präsentation1 unter dem Namen "Year-End Report.ppt" gespeichert.

Application.Presentations(1).SaveAs "Year-End Report"

In diesem Beispiel wird die Präsentation "Year-End Report" geschlossen.

Application.Presentations("Year-End Report.ppt").Close


PresetExtrusionDirection-Eigenschaft

Gibt die Richtung zurück, in die der Ausdehnungsweg der Projektion von der projizierten Form (der vorderen Fläche der Projektion) abgelenkt wird. Dies kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft, msoExtrusionTopRight oder msoPresetExtrusionDirectionMixed. Long Nur-Lese-Zugriff.

Anmerkungen

Für diese Eigenschaft gilt Nur-Lese-Zugriff. Um den Wert dieser Eigenschaft einzustellen, verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur PresetExtrusionDirection-Eigenschaft

In diesem Beispiel wird jede Projektion in myDocument, die sich zur oberen linken Ecke der vorderen Fläche der Projektion hin ausdehnt, in eine Projektion geändert, die sich zur unteren rechten Ecke der vorderen Fläche ausdehnt.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    With s.ThreeD
        If .PresetExtrusionDirection = msoExtrusionTopLeft Then
            .SetExtrusionDirection msoExtrusionBottomRight
        End If
    End With
Next


PresetGradientType-Eigenschaft

Gibt den vordefinierten Verlaufstyp für die angegebene Füllung zurück. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der PresetGradient-Methode können Sie den vordefinierten Verlaufstyp für die Füllung festlegen.


Beispiel zur PresetGradientType-Eigenschaft

Dieses Beispiel legt in myDocument für alle Formen, die die vordefinierte Füllung Moos haben, die vordefinierte Verlaufsfüllung Nebel fest.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    With s.Fill
        If .PresetGradientType = msoGradientMoss Then
            .PresetGradient msoGradientHorizontal,_
                1, msoGradientFog
        End If
    End With
Next


PresetLightingDirection-Eigenschaft

Gibt die Position der Lichtquelle relativ zur Projektion zurück oder legt sie fest. Dies kann eine der folgenden MsoPresetLightingDirection-Konstanten sein: msoLightingBottom, msoLightingBottomLeft, msoLightingBottomRight, msoLightingLeft, msoLightingNone, msoLightingRight, msoLightingTop, msoLightingTopLeft, msoLightingTopRight oder msoPresetLightingDirectionMixed. Long Schreib-Lese-Zugriff.

Hinweis Die festgelegten Beleuchtungseffekte sind nicht zu sehen, wenn die Projektion eine Drahtmodelloberfläche besitzt.


Beispiel zur PresetLightingDirection-Eigenschaft

In diesem Beispiel wird angegeben, dass die Projektion für Form 1 in myDocument sich zum oberen Rand der Form ausdehnt und die Beleuchtung für die Projektion von links kommt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


PresetLightingSoftness-Eigenschaft

Gibt die Intensität der Beleuchtung der Projektion zurück oder legt sie fest. Dies kann eine der folgenden MsoPresetLightingSoftness-Konstanten sein: msoLightingBright, msoLightingDim, msoLightingNormal oder msoPresetLightingSoftnessMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetLightingSoftness-Eigenschaft

In diesem Beispiel wird angegeben, dass die Projektion für Form 1 in myDocument von links hell beleuchtet wird.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetLightingSoftness = msoLightingBright
    .PresetLightingDirection = msoLightingLeft
End With


PresetMaterial-Eigenschaft

Gibt das Oberflächenmaterial der Projektion zurück oder legt es fest. Dies kann eine der folgenden MsoPresetMaterial-Konstanten sein: msoMaterialMatte, msoMaterialMetal, msoMaterialPlastic, msoMaterialWireFrame oder msoPresetMaterialMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetMaterial-Eigenschaft

Dieses Beispiel gibt für das Oberflächenmaterial für Form 1 in myDocument "wire frame" an.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetMaterial = msoMaterialWireFrame
End With


PresetShape-Eigenschaft

Gibt die Form der angegebenen WordArt zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTextEffectShape-Konstanten sein:

msoTextEffectShapeArchDownCurve

msoTextEffectShapeArchDownPour

msoTextEffectShapeArchUpCurve

msoTextEffectShapeArchUpPour

msoTextEffectShapeButtonCurve

msoTextEffectShapeButtonPour

msoTextEffectShapeCanDown

msoTextEffectShapeCanUp

msoTextEffectShapeCascadeDown

msoTextEffectShapeCascadeUp

msoTextEffectShapeChevronDown

msoTextEffectShapeChevronUp

msoTextEffectShapeCircleCurve

msoTextEffectShapeCirclePour

msoTextEffectShapeCurveDown

msoTextEffectShapeCurveUp

msoTextEffectShapeDeflate

msoTextEffectShapeDeflateBottom

msoTextEffectShapeDeflateInflate

msoTextEffectShapeDeflateInflateDeflate

msoTextEffectShapeDeflateTop

 msoTextEffectShapeDoubleWave1

msoTextEffectShapeDoubleWave2

msoTextEffectShapeFadeDown

msoTextEffectShapeFadeLeft

msoTextEffectShapeFadeRight

msoTextEffectShapeFadeUp

msoTextEffectShapeInflate

msoTextEffectShapeInflateBottom

msoTextEffectShapeInflateTop

msoTextEffectShapeMixed

msoTextEffectShapePlainText

msoTextEffectShapeRingInside

msoTextEffectShapeRingOutside

msoTextEffectShapeSlantDown

msoTextEffectShapeSlantUp

msoTextEffectShapeStop

msoTextEffectShapeTriangleDown

msoTextEffectShapeTriangleUp

msoTextEffectShapeWave1

msoTextEffectShapeWave2

Anmerkungen

Wenn Sie die PresetTextEffect-Eigenschaft festlegen, wird automatisch die PresetShape-Eigenschaft festgelegt.


Beispiel zur PresetShape-Eigenschaft

Dieses Beispiel legt für die Formen der WordArt in myDocument einen eingekerbten Richtungspfeil nach unten fest.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetShape = msoTextEffectShapeChevronDown
    End If
Next


PresetTextEffect-Eigenschaft

Gibt die Formatvorlage der angegebenen WordArt zurück oder legt diese fest. Die Werte für diese Eigenschaft entsprechen den Formaten im Dialogfeld WordArt-Katalog (die von links nach rechts oben nach unten nummeriert sind). Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTextEffect-Konstanten sein:

msoTextEffect1

msoTextEffect2

msoTextEffect3

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

msoTextEffect16

 msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect20

msoTextEffect21

msoTextEffect22

msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect30

msoTextEffectMixed

Anmerkungen

Wenn Sie die PresetTextEffect-Eigenschaft festlegen, werden automatisch mehrere andere Formateigenschaften für die angegebene Form festgelegt.


Beispiel zur PresetTextEffect-Eigenschaft

Dieses Beispiel legt als Formatvorlage für die WordArt in myDocument die erste Vorlage fest, die im Dialogfeld WordArt-Katalog aufgeführt ist.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetTextEffect = msoTextEffect1
    End If
Next


PresetTexture-Eigenschaft

Gibt die vordefinierte Struktur für die angegebene Füllung zurück. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der PresetTextured-Methode können Sie die vordefinierte Struktur für die Füllung festlegen.


Beispiel zur PresetTexture-Eigenschaft

Dieses Beispiel fügt ein Rechteck zu myDocument hinzu und legt für die vordefinierte Struktur fest, dass diese mit der Struktur von Form 2 angepasst wird. Damit dieses Beispiel funktioniert, muss Form 2 eine vordefinierte strukturierte Füllung haben.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    presetTexture2 = .Item(2).Fill.PresetTexture
    .AddShape(msoShapeRectangle, 100, 0, 40, 80).Fill _
        .PresetTextured presetTexture2
End With


PresetThreeDFormat-Eigenschaft

Gibt das voreingestellte Projektionsformat zurück. Jedes voreingestellte Projektionsformat enthält einen Satz von voreingestellten Werten für die verschiedenen Eigenschaften der Projektion. Wenn die Projektion kein voreingestelltes, sondern ein benutzerdefiniertes Format hat, gibt diese Eigenschaft msoPresetThreeDFormatMixed zurück. Dies kann eine der folgenden MsoPresetThreeDFormat-Konstanten sein: msoPresetThreeDFormatMixed, msoThreeD1, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19, msoThreeD2, msoThreeD20, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8 oder msoThreeD9. Die Werte für diese Eigenschaft entsprechen den Optionen (nummeriert von links nach rechts und von oben nach unten), die angezeigt werden, wenn Sie in der Zeichnen-Symbolleiste auf die Schaltfläche 3D klicken. Long Nur-Lese-Zugriff.

Anmerkungen

Für diese Eigenschaft gilt Nur-Lese-Zugriff. Um das voreingestellte Projektionsformat festzulegen, verwenden Sie die SetThreeDFormat-Methode.


Beispiel zur PresetThreeDFormat-Eigenschaft

In diesem Beispiel wird das Projektionsformat für Form 1 in myDocument auf 3D-Stil "12" eingestellt, wenn die Form ursprünglich ein benutzerdefiniertes Projektionsformat hat.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    If .PresetThreeDFormat = msoPresetThreeDFormatMixed Then
        .SetThreeDFormat msoThreeD12
    End If
End With


PrintColorType-Eigenschaft

Gibt zurück, wie das angegebene Dokument gedruckt wird, oder legt dieses fest: Schwarzweiß, reines Schwarzweiß (das auch als Hochkontrast bezeichnet wird) oder in Farbe. Dies kann eine der folgenden PpPrintColorType-Konstanten sein: ppPrintBlackAndWhite, ppPrintColor oder ppPrintPureBlackAndWhite. Der Standardwert wird vom Drucker festgelegt. Long Schreib-Lese-Zugriff.


Beispiel zur PrintColorType-Eigenschaft

Dieses Beispiel druckt die Folien der aktiven Präsentation in Farbe.

With Application.ActivePresentation
    .PrintOptions.PrintColorType = ppPrintColor
    .PrintOut
End With


PrintFontsAsGraphics-Eigenschaft

True, wenn TrueType-Schriftarten als Grafiken gedruckt werden. Long Schreib-Lese-Zugriff.


Beispiel zur PrintFontsAsGraphics-Eigenschaft

Dieses Beispiel gibt an, dass TrueType-Schriftarten in der aktiven Präsentation als Grafiken gedruckt werden.

ActivePresentation.PrintOptions.PrintFontsAsGraphics = True


PrintHiddenSlides-Eigenschaft

True, wenn die ausgeblendeten Folien in der angegebenen Präsentation gedruckt werden. Der Standardwert ist False. Long Schreib-Lese-Zugriff.


Beispiel zur PrintHiddenSlides-Eigenschaft

Dieses Beispiel druckt alle ausgeblendeten oder eingeblendeten Folien der aktiven Präsentation.

With ActivePresentation
    .PrintOptions.PrintHiddenSlides = True
    .PrintOut
End With


PrintInBackground-Eigenschaft

True, wenn die angegebene Präsentation im Hintergrund gedruckt wird. Dies bedeutet, dass Sie während des Druckvorgangs mit Ihrer Arbeit fortfahren können. Der Standardwert ist True. Long Schreib-Lese-Zugriff.


Beispiel zur PrintInBackground-Eigenschaft

Dieses Beispiel druckt die aktive Präsentation im Hintergrund.

With ActivePresentation
    .PrintOptions.PrintInBackground = True
    .PrintOut
End With


PrintOptions-Eigenschaft

Gibt ein PrintOptions-Objekt zurück, das die Druckoptionen darstellt, die mit der angegebenen Präsentation gespeichert werden. Nur-Lese-Zugriff.


Beispiel zur PrintOptions-Eigenschaft

In diesem Beispiel werden ausgeblendete Folien der aktiven Präsentation gedruckt und die gedruckten Folien an das Papierformat angepasst.

With Application.ActivePresentation
    With .PrintOptions
        .PrintHiddenSlides = True
        .FitToPage = True
    End With
    .PrintOut
End With


PrintSteps-Eigenschaft

Gibt die Anzahl der Folien zurück, die gedruckt werden müssen, um den Aufbau in der angegebenen Folie, dem Folienmaster oder dem angegebenen Folienbereich zu simulieren. Long Nur-Lese-Zugriff.


Beispiel zur PrintSteps-Eigenschaft

Dieses Beispiel legt als Wert für eine Variable die Anzahl der Folien fest, die gedruckt werden müssen, um die Aufbauten in Folie 1 der aktiven Präsentation zu simulieren. Anschließend wird der Wert der Variablen angezeigt.

steps1 = ActivePresentation.Slides(1).PrintSteps
MsgBox steps1


ProductCode-Eigenschaft

Gibt den global eindeutigen Bezeichner (GUID = globally unique identifier) von Microsoft PowerPoint zurück. Der GUID wird beispielsweise bei manchen Aufrufen der Schnittstelle für Anwendungsprogrammierung (API) verwendet. String Nur-Lese-Zugriff.


Beispiel zur ProductCode-Eigenschaft

In diesem Beispiel wird der PowerPoint-GUID in der Variablen pptGUID zurückgegeben.

Dim pptGUID As String
pptGUID = Application.ProductCode


 ProgID-Eigenschaft

ProgID-Eigenschaft

Gibt Programmtechnischer Bezeichner (ProgID) für das angegebene OLE-Objekt zurück. String Nur-Lese-Zugriff.


Beispiel zur ProgID-Eigenschaft

Dieses Beispiel durchläuft alle Objekte von allen Folien in der aktiven Präsentation und legt für alle verknüpften Microsoft Excel-Tabellenblätter fest, dass diese manuell aktualisiert werden.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Excel.Sheet" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


PublishObjects-Eigenschaft

Gibt eine PublishObjects-Auflistung mit allen ganz oder teilweise geladenen Präsentationen zurück, die als HTML-Präsentationen veröffentlicht werden können. Nur-Lese-Zugriff.


Beispiel zur PublishObjects-Eigenschaft

In diesem Beispiel werden die Folien 3 bis 5 der aktiven Präsentation als HTML-Präsentation veröffentlicht. Der veröffentlichten Präsentation wird der Name Mallard.htm zugewiesen.

With ActivePresentation.PublishObjects.Item(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


RangeEnd-Eigenschaft

Gibt die Nummer der letzten Folie in einem Folienbereich zurück, den Sie als Webpräsentation veröffentlichen, oder legt diese fest. Integer Schreib-Lese-Zugriff.


Beispiel zur RangeEnd-Eigenschaft

In diesem Beispiel werden die Folien 3 bis 5 der aktiven Präsentation als HTML-Präsentation veröffentlicht. Der veröffentlichten Präsentation wird der Name Mallard.htm zugewiesen.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


Ranges-Eigenschaft

Gibt das PrintRanges-Objekt zurück, das Folienbereiche in der Präsentation darstellt, die gedruckt werden sollen. Nur-Lese-Zugriff.

Anmerkungen

Wenn Sie keine vollständige Präsentation drucken möchten, können Sie mit der Add-Methode ein PrintRange-Objekt für alle aufeinander folgenden Folien festlegen, die gedruckt werden sollen. Möchten Sie z. B. Folie 1, die Folien 3 bis 5 sowie die Folien 8 und 9 in einer angegebenen Präsentation drucken, müssen drei PrintRange-Objekte für die Darstellung folgender Folien erstellt werden: eines für Folie 1, eines für die Folien 3 bis 5 sowie eines für die Folien 8 und 9. Weitere Informationen finden Sie im Beispiel für diese Eigenschaft.

Für die RangeType-Eigenschaft muss ppPrintSlideRange gelten, um die Bereiche in der PrintRanges-Auflistung zuweisen zu können.

Mit der ClearAll-Methode können Sie alle vorhandenen Druckbereiche der PrintRanges-Auflistung löschen.

Mit der Angabe eines Wertes für die To- und From-Argumente der PrintOut-Methode werden die Inhalte des PrintRanges-Objekts festgelegt.


RangeStart-Eigenschaft

Gibt die Nummer der ersten Folie in einem Folienbereich zurück, den Sie als Webpräsentation veröffentlichen, oder legt diese fest. Integer Schreib-Lese-Zugriff.


Beispiel zur RangeStart-Eigenschaft

In diesem Beispiel werden die Folien 3 bis 5 der aktiven Präsentation als HTML-Präsentation veröffentlicht. Der veröffentlichten Präsentation wird der Name Mallard.htm zugewiesen.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


RangeType-Eigenschaft

PrintOptions-Objekt: Gibt den Druckbereichstyp für die Präsentation zurück oder legt diesen fest. Dies kann eine der folgenden PpPrintRangeType-Konstanten sein: ppPrintAll, ppPrintCurrent, ppPrintNamedSlideShow, ppPrintSelection oder ppPrintSlideRange. Long Schreib-Lese-Zugriff.

SlideShowSettings-Objekt: Gibt die Art der anzuwendenden Bildschirmpräsentation zurück oder legt sie fest. Dies kann eine der folgenden PpSlideShowRangeType-Konstanten sein: ppShowAll, ppShowNamedSlideShow oder ppShowSlideRange. Long Schreib-Lese-Zugriff.

Anmerkungen

Um die Folienbereiche drucken zu können, die Sie in der PrintRanges-Auflistung definiert haben, muss vorher für die RangeType-Eigenschaft ppPrintSlideRange gelten. Wenn für RangeType ein anderer Wert als ppPrintSlideRange festgelegt wurde, werden die Bereiche nicht zugewiesen, die in der PrintRanges-Auflistung definiert wurden. Dies wirkt sich jedoch in keiner Weise auf den Inhalt der PrintRanges-Auflistung aus. Wenn Sie demzufolge Druckbereiche definieren, legen Sie für die RangeType-Eigenschaft einen anderen Wert als ppPrintSlideRange fest, und setzen Sie anschließend RangeType auf ppPrintSlideRange zurück. Dann bleiben zuvor definierte Druckbereiche unverändert.

Mit Angabe eines Wertes für die To- und From-Argumente der PrintOut-Methode wird der Wert dieser Eigenschaft festgelegt.


Beispiel zur RangeType-Eigenschaft

Dieses Beispiel druckt die aktuelle Folie der aktiven Präsentation.

With ActivePresentation
    .PrintOptions.RangeType = ppPrintCurrent
    .PrintOut
End With

In diesem Beispiel wird die Bildschirmpräsentation "Schnelle Show" aufgerufen.

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowNamedSlideShow
    .SlideShowName = "Quick Show"
    .Run
End With


ReadOnly-Eigenschaft

True, wenn die angegebene Präsentation schreibgeschützt ist. Long Nur-Lese-Zugriff.


Beispiel zur ReadOnly-Eigenschaft

In diesem Beispiel wird die aktive Präsentation als Datneu.ppt gespeichert (wenn die Präsentation schreibgeschützt ist).

With Application.ActivePresentation
    If .ReadOnly Then .SaveAs FileName:="newfile"
End With


 Registered-Eigenschaft

Registered-Eigenschaft

True, wenn das angegebene Add-In in der Windows-Registrierung registriert wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Der Unterschlüssel für ein Microsoft PowerPoint-spezifisches Add-In, das von einem Installationsprogramm registriert wurde, wird in der Regel unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\PowerPoint\AddIns\Add-In-Name abgelegt. Der Unterschlüssel für ein PowerPoint-spezifisches Add-In, das Sie über Festlegen der Registered-Eigenschaft auf True registrieren, wird unter HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\PowerPoint\AddIns\Add-In-Name abgelegt.

Der Unterschlüssel für ein Component Object Model-(COM-)Add-In, das von einem Installationsprogramm registriert wurde, wird in der Regel unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\PowerPoint\AddIns\Add-In-Name abgelegt Der Unterschlüssel für ein COM-Add-In, das Sie über Festlegen der Registered-Eigenschaft auf True registrieren, wird unter HKEY_CURRENT_USER\Software\Microsoft\Office\PowerPoint\AddIns\Add-In-Name abgelegt.


Beispiel zur Registered-Eigenschaft

Dieses Beispiel registriert das Add-In "MyTools" unter HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\PowerPoint\AddIns\MyTools.

Application.Addins("MyTools").Registered = True


RelativeSize-Eigenschaft

Gibt die Größe der Aufzählungszeichen relativ zur Größe des ersten Textzeichens im Absatz zurück oder legt diese fest. Hierbei kann es sich um einen Gleitkommawert im Bereich von 0,25 bis 4 handeln, der somit angibt, dass die Größe der Aufzählungszeichen 25 bis 400 Prozent der Größe der Textzeichen sein kann. Single Schreib-Lese-Zugriff.


Beispiel zur RelativeSize-Eigenschaft

Dieses Beispiel legt die Formatierung für die Aufzählungszeichen in Form 2 in Folie 1 der aktiven Präsentation fest. Die Größe der Aufzählungszeichen entspricht 125 Prozent der Größe des ersten Textzeichens vom Absatz.

With ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat.Bullet
        .Visible = True
        .RelativeSize = 1.25
        .Character = 169
        With .Font
            .Name = "Symbol"
            .Color.RGB = RGB(255, 0, 0)
        End With
    End With
End With


RelyOnVML-Eigenschaft

True, wenn beim Speichern oder Veröffentlichen einer vollständigen Präsentation oder eines Teiles davon als Webseite keine Grafikdateien für Zeichnungsobjekte erzeugt werden. False, wenn Grafikdateien erzeugt werden. Der Standardwert ist False. Long Schreib-Lese-Zugriff.

Hinweise

Sofern Ihr Webbrowser Vector Markup Language (VML) unterstützt, können Sie kleinere Dateien erzielen, indem Sie Zeichnungsobjekte nicht mit Grafikdateien erstellen. Microsoft Internet Explorer 5 unterstützt dieses Feature. Wenn Ihre Webseite mit diesem Browser betrachtet werden soll, empfiehlt es sich, dass Sie die RelyOnVML-Eigenschaft auf True setzen. Wenn Sie eine Webseite, bei der diese Eigenschaft beim Speichern auf True gesetzt war, in einem Browser betrachten, der kein VML unterstützt, werden keine Zeichnungsobjekte angezeigt.

Sie sollten beispielsweise keine Grafikdateien erzeugen, wenn Sie auf der Webseite Grafikdateien verwenden, die Sie früher erstellt haben, und sich der Speicherort, an dem Sie die Präsentation speichern, vom endgültigen Speicherort der Seite auf dem Webserver unterscheidet.


Beispiel zur RelyOnVML-Eigenschaft

In diesem Beispiel wird festgelegt, dass beim Speichern bzw. Veröffentlichen der aktiven Präsentation als Webseite Grafikdateien erzeugt werden.

ActivePresentation.WebOptions.RelyOnVML = False


ResizeGraphics-Eigenschaft

True, wenn Folien und auf den Folien enthaltene Grafiken an die Größe des Anzeigebereichs des Zielwebbrowsers angepasst werden. False, wenn die Größe der Folien und Grafiken in der Quellpräsentation unabhängig vom Anzeigebereich des Webbrowsers beibehalten wird. Der Standardwert ist True. Long Schreib-Lese-Zugriff.


Beispiel zur ResizeGraphics-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Größen der Grafiken in der angegebenen Webpräsentation an den Zielwebbrowser angepasst werden. Anschließend wird die gesamte Präsentation mit Sprechernotizen in einer Datei namens Mallard.htm veröffentlicht.

With Presentations(2)
    .WebOptions.ResizeGraphics = True
    With .PublishObjects(1)
        .FileName = "C:\Mallard.htm"
        .SourceType = ppPublishAll
        .SpeakerNotes = True
        .Publish
    End With
End With


RewindMovie-Eigenschaft

True, wenn der erste Rahmen des angegebenen Films automatisch neu angezeigt wird, sobald der Film nicht mehr wiedergegeben wird. Long Schreib-Lese-Zugriff.


Beispiel zur RewindMovie-Eigenschaft

Dieses Beispiel gibt an, dass der erste Rahmen des Films, der von Form 3 in Folie 1 der aktiven Präsentation dargestellt wird, automatisch angezeigt wird, sobald der Film nicht mehr wiedergegeben wird. Form 3 muss ein Filmobjekt sein.

Set OLEobj = ActivePresentation.Slides(1).Shapes(3)
OLEobj.AnimationSettings.PlaySettings.RewindMovie = True


 RGB-Eigenschaft

RGB-Eigenschaft

ColorFormat-Objekt: Gibt den Wert für Rot-Grün-Blau (RGB) der angegebenen Farbe zurück oder legt diesen fest. Long Schreib-Lese-Zugriff.

RGBColor-Objekt: Gibt den Wert für Rot-Grün-Blau (RGB) der Farbe einer angegebenen Farbskala oder einer zusätzlichen Farbe zurück oder legt diesen fest, wenn eine der folgenden Konstanten der Colors-Methode verwendet wird: ppAccent1, ppAccent2, ppAccent3, ppBackground, ppFill, ppForeground, ppShadow oder ppTitle. Die Colors-Methode wird verwendet, um das RGBColor-Objekt zurückzugeben. Long Schreib-Lese-Zugriff.


Beispiel zur RGB-Eigenschaft

In diesem Beispiel wird die Hintergrundfarbe für die Farbskala 3 der aktiven Präsentation festgelegt. Die Farbskala wird anschließend allen Folien der Präsentation zugewiesen, die auf dem Folienmaster basieren.

With ActivePresentation
    Set cs1 = .ColorSchemes(3)
    cs1.Colors(ppBackground).RGB = RGB(128, 128, 0)
    .SlideMaster.ColorScheme = cs1
End With

In diesem Beispiel wird der Wert für die Rot-, Grün- und Blau-Komponenten der Vordergrundfüllfarbe der Form 1 auf der Folie 1 im aktiven Dokument angezeigt.

Set myDocument = ActivePresentation.Slides(1)
c = myDocument.Shapes(1).Fill.ForeColor.RGB
redComponent = c Mod 256
greenComponent = c \ 256 Mod 256
blueComponent = c \ 65536 Mod 256
MsgBox "RGB components: " & redComponent & _
    ", " & greenComponent & ", " & blueComponent


RotatedChars-Eigenschaft

True, wenn die Zeichen in der angegebenen WordArt 90° relativ zur Begrenzungsform der WordArt gedreht werden. False, wenn die Zeichen in der angegebenen WordArt ihre ursprüngliche Ausrichtung relativ zur Begrenzungsform beibehalten. Long Schreib-Lese-Zugriff.

Anmerkungen

Enthält die WordArt horizontalen Text, werden die Zeichen um 90° gegen den Uhrzeigersinn gedreht, wenn für die RotatedChars-Eigenschaft True gilt. Enthält die WordArt vertikalen Text, werden die Zeichen um 90° im Uhrzeigersinn gedreht, wenn für die RotatedChars-Eigenschaft False gilt. Mit der ToggleVerticalText-Methode wechseln Sie zwischen horizontalem und vertikalem Textfluss.

Die Flip-Methode und die Rotation-Eigenschaft des Shape-Objekts sowie die RotatedChars-Eigenschaft und die ToggleVerticalText-Methode des TextEffectFormat-Objekts wirken sich auf die Textflussrichtung und Zeichenausrichtung in einem Shape-Objekt aus, das WordArt darstellt. Um bestimmte Ergebnisse zu erzielen, können Sie die Effekte dieser Eigenschaften und Methoden kombinieren.


Beispiel zur RotatedChars-Eigenschaft

Dieses Beispiel fügt WordArt zu myDocument hinzu, das den Text "Test" enthält, und dreht die Zeichen um 90° gegen den Uhrzeigersinn.

Set myDocument = ActivePresentation.Slides(1)
Set newWordArt = myDocument.Shapes.AddTextEffect _
    (PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=10, Top:=10)
newWordArt.TextEffect.RotatedChars = True


 Rotation-Eigenschaft

Rotation-Eigenschaft

Gibt den Wert in Grad zurück, um den die angegebene Form um die Z-Achse gedreht wird, oder legt diesen Wert fest. Ein positiver Wert gibt eine Drehung im Uhrzeigersinn, ein negativer Wert eine Drehung gegen den Uhrzeigersinn an. Single Schreib-Lese-Zugriff

Anmerkungen

Um eine dreidimensionale Form um die X-Achse oder die Y-Achse drehen zu lassen, verwenden Sie die RotationX-Eigenschaft oder die RotationY-Eigenschaft des ThreeDFormat-Objekts.


Beispiel zur Rotation-Eigenschaft

Dieses Beispiel passt die Drehung aller Formen von myDocument der Drehung von Form 1 an.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    sh1Rotation = .Item(1).Rotation
    For o = 1 To .Count
        .Item(o).Rotation = sh1Rotation
    Next
End With


 RotationX-Eigenschaft

RotationX-Eigenschaft

Gibt die Drehung der projizierten Form um die X-Achse in Grad zurück oder legt sie fest. Dies kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert gibt eine Drehung nach oben, ein negativer Wert eine Drehung nach unten an. Single Schreib-Lese-Zugriff.

Hinweise

Um die Drehung der projizierten Form um die Y-Achse festzulegen, verwenden Sie die RotationY-Eigenschaft des ThreeDFormat-Objekts. Um die Drehung der projizierten Form um die Z-Achse festzulegen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts. Um die Richtung des Bewegungswegs der Projektion zu ändern, ohne dabei die vordere Fläche der Projektion zu drehen, verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur RotationX-Eigenschaft

In diesem Beispiel werden dem Element myDocument drei identische projizierte Ovale hinzugefügt. Dann wird deren Drehung um die X-Achse auf -30, 0 bzw. 30 Grad eingestellt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    With .AddShape(msoShapeOval, 30, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = -30
    End With
    With .AddShape(msoShapeOval, 90, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 0
    End With
    With .AddShape(msoShapeOval, 150, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 30
    End With
End With


 RotationY-Eigenschaft

RotationY-Eigenschaft

Gibt die Drehung der projizierten Form um die Y-Achse in Grad zurück oder legt sie fest. Es kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert gibt eine Drehung nach links, ein negativer Wert eine Drehung nach rechts an. Single Schreib-Lese-Zugriff.

Anmerkungen

Um die Drehung der projizierten Form um die X-Achse festzulegen, verwenden Sie die RotationX-Eigenschaft des ThreeDFormat-Objekts. Um die Drehung der projizierten Form um die Z-Achse festzulegen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts. Um die Richtung des Bewegungswegs der Projektion zu ändern, ohne dabei die vordere Fläche der Projektion zu drehen, verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur RotationY-Eigenschaft

In diesem Beispiel werden dem Element myDocument drei identische projizierte Ovale hinzugefügt. Dann wird deren Drehung um die Y-Achse auf -30, 0 bzw. 30 Grad eingestellt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    With .AddShape(msoShapeOval, 30, 30, 50, 25).ThreeD
        .Visible = True
        .RotationY = -30
    End With
    With .AddShape(msoShapeOval, 30, 70, 50, 25).ThreeD
        .Visible = True
        .RotationY = 0
    End With
    With .AddShape(msoShapeOval, 30, 110, 50, 25).ThreeD
        .Visible = True
        .RotationY = 30
    End With
End With


Rows-Eigenschaft

Gibt eine Rows-Auflistung zurück, die alle Zeilen in einer Tabelle darstellt. Nur-Lese-Zugriff.

Informationen über das Zurückgeben eines Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Rows-Eigenschaft

In diesem Beispiel wird die dritte Zeile der Tabelle in Form 5 auf Folie 2 der aktiven Präsentation gelöscht.

ActivePresentation.Slides(2).Shapes(5).Table.Rows(3).Delete

In diesem Beispiel wird dem unteren Rand der zweiten Zeile in der Tabelle eine gestrichelte Linienart zugewiesen.

ActiveWindow.Selection.ShapeRange.Table.Rows(2) _
    .Cells.Borders(ppBorderBottom).DashStyle = msoLineDash


Ruler-Eigenschaft

Gibt ein Ruler-Objekt zurück, das das Lineal für den angegebenen Text darstellt. Nur-Lese-Zugriff.


Beispiel zur Ruler-Eigenschaft

In diesem Beispiel wird für den Text in Form 2 in myDocument ein linksbündiger Tabstopp bei 5,08 cm (144 Punkt) gesetzt.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes(2).TextFrame.Ruler.TabStops _
    .Add ppTabStopLeft, 144


Run-Eigenschaft

Gibt den Namen von Präsentationen oder Makros zurück, die ausgeführt werden, wenn Sie auf die angegebene Form klicken bzw. wenn der Mauszeiger während einer Bildschirmpräsentation darauf gerichtet wird, oder legt diesen Namen fest. Für die Action-Eigenschaft muss ppActionRunMacro oder ppActionRunProgram festgelegt werden, damit sich diese Eigenschaft auf die Aktion der Bildschirmpräsentation auswirken kann. String Schreib-Lese-Zugriff.

Anmerkungen

Lautet der Wert für die Action-Eigenschaft ppActionRunMacro, muss es sich bei dem angegebenen Wert der Zeichenfolge um den Namen eines aktuell geladenen globalen Makros handeln. Lautet der Wert für die Action-Eigenschaft ppActionRunProgram, muss es sich bei dem angegebenen Wert der Zeichenfolge um den vollständigen Pfad- und Dateinamen eines Programms handeln.

Sie können für die Run-Eigenschaft ein Makro festlegen, das keine Argumente akzeptiert, oder ein Makro festlegen, das ein einziges Shape-oder Object-Argument akzeptiert. Die während der Bildschirmpräsentation angeklickte Form wird als Argument weitergegeben.


Beispiel zur Run-Eigenschaft

Dieses Beispiel gibt an, dass das Makro CalculateTotal immer dann ausgeführt wird, wenn der Mauszeiger während einer Bildschirmpräsentation auf die Form gerichtet wird.

With ActivePresentation.Slides(1) _
    .Shapes(3).ActionSettings(ppMouseOver)
        .Action = ppActionRunMacro
        .Run = "CalculateTotal"
        .AnimateAction = True
End With


Saved-Eigenschaft

True, wenn bei einer Präsentation seit dem letzten Speichern keine Änderungen vorgenommen wurden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wurde für die Saved-Eigenschaft einer geänderten Präsentation True festgelegt, wird der Benutzer beim Schließen der Präsentation nicht aufgefordert, die Änderungen zu speichern. Es gehen dann alle Änderungen verloren, die seit dem letzten Speichern vorgenommen wurden.


Beispiel zur Saved-Eigenschaft

In diesem Beispiel wird die aktive Präsentation gespeichert, wenn seit dem letzten Speichern Änderungen vorgenommen wurden.

With Application.ActivePresentation
    If Not .Saved And .Path <> "" Then .Save
End With


SchemeColor-Eigenschaft

Gibt die Farbe der zugewiesenen Farbskala zurück, die zu dem angegebenen Objekt gehört, oder legt diese Farbe fest. Dies kann eine der folgenden PpColorSchemeIndex Konstanten sein: ppAccent1, ppAccent2, ppAccent3, ppBackground, ppFill, ppForeground, ppNotSchemeColor, ppSchemeColorMixed, ppShadow oder ppTitle. Long Schreib-Lese-Zugriff.


Beispiel zur SchemeColor-Eigenschaft

In diesem Beispiel wird die Hintergrundfarbe von Folie 1 der aktiven Präsentation von einem expliziten Rot-Grün-Blau-Wert zur Hintergrundfarbe der Farbskala gewechselt.

With ActivePresentation.Slides(1)
    .FollowMasterBackground = False
    With .Background.Fill.ForeColor
        If .Type = msoColorTypeScheme Then
            .RGB = RGB(0, 128, 128)
        Else
            .SchemeColor = ppBackground
        End If
    End With
End With


ScreenSize-Eigenschaft

Gibt die ideale Mindestbildschirmgröße (Breite mal Höhe in Pixel) zurück, die Sie beim Betrachten der gespeicherten Präsentation in einem Webbrowser verwenden sollten, oder legt diesen Wert fest. Kann eine der unten aufgeführten MsoScreenSize-Konstanten sein. Der Standardwert ist msoScreenSize800x600. Long Schreib-Lese-Zugriff.

msoScreenSize1024x768

msoScreenSize1152x882

msoScreenSize1152x900

msoScreenSize1280x1024

msoScreenSize1600x1200

msoScreenSize1800x1440

 msoScreenSize1920x1200

msoScreenSize544x376

msoScreenSize640x480

msoScreenSize720x512

msoScreenSize800x600


Beispiel zur ScreenSize-Eigenschaft

In diesem Beispiel wird die Zielbildschirmgröße auf 640x480 Pixel gesetzt.

Presentations(2).WebOptions.ScreenSize = _
    msoScreenSize640x480


ScreenTip-Eigenschaft

Gibt den Bildschirmtipptext eines Hyperlinks zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Hinweise

Der Bildschirmtipptext wird beispielsweise angezeigt, wenn Sie eine Präsentation im HTML-Format speichern, in einem Webbrowser betrachten und mit dem Mauszeiger auf einen Hyperlink zeigen. Nicht alle Browser unterstützen Bildschirmtipptext.


Beispiel zur ScreenTip-Eigenschaft

In diesem Beispiel wird der Bildschirmtipptext für den ersten Hyperlink gesetzt.

ActivePresentation.Slides(1).Hyperlinks(1) _
    .ScreenTip = "Go to the Microsoft home page"


Script-Eigenschaft

Gibt ein Script-Objekt zurück, das einen Skriptblock auf einer Microsoft PowerPoint-Folie darstellt. Skripte sind in PowerPoint mit Anchorformen verbunden. Wenn mit der angegebenen Form kein Skript verbunden ist, wird nichts zurückgegeben. Nur-Lese-Zugriff.

Hinweise

Skripte auf einer Folie können nur in einer Webpräsentation ausgeführt werden.

Standardmäßig sind Anchorformen für Skripte nicht sichtbar. Sie können diese Formen nur über die Benutzeroberfläche von PowerPoint sichtbar machen. Dies ist unter Hinzufügen von Befehlen für Webskripte zum Menü Extras beschrieben. Sie können Anchorformen für Skripte nicht mit Visual Basic sichtbar machen.

Sie können die Script-Eigenschaft sowohl mit einzelnen Anchorformen als auch mit Bereichen von Formen (ShapeRange.Script) verwenden. Wenn der Bereich jedoch mehr als eine Form enthält, ist der Code nicht lauffähig. In diesem Fall informiert Sie eine Meldung darüber, dass Sie nicht auf die Script-Eigenschaft zugreifen können.


Scripts-Eigenschaft

Gibt eine Scripts-Auflistung zurück, die alle Script-Objekte (Blöcke mit Skripten) in einer Präsentation darstellt. Nur-Lese-Zugriff.

Hinweise

Skripte, die durch ein Script-Objekt dargestellt werden, können nur in einer Webpräsentation ausgeführt werden.


SegmentType-Eigenschaft

Gibt einen Wert zurück, der angibt, ob der Abschnitt gerade oder gekrümmt ist, der zu dem angegebenen Knoten gehört. Dies kann eine der folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine. Handelt es sich bei dem angegebenen Knoten um einen Kontrollpunkt für einen gekrümmten Abschnitt, gibt diese Eigenschaft msoSegmentCurve zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der SetSegmentType-Methode können Sie den Wert für diese Eigenschaft festlegen.


Beispiel zur SegmentType-Eigenschaft

Dieses Beispiel ändert alle geraden Abschnitte in Form 3 von myDocument zu gekrümmten Abschnitten. Form 3 muss eine Freihandfigur sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


Selection-Eigenschaft

Gibt ein Selection-Objekt zurück, das die Markierung im angegebenen Dokumentfenster darstellt. Nur-Lese-Zugriff.


Beispiel zur Selection-Eigenschaft

Wenn Text im aktiven Fenster markiert ist, wird dieser im folgenden Beispiel kursiv formatiert.

With Application.ActiveWindow.Selection
    If .Type = ppSelectionText Then
        .TextRange.Font.Italic = True
    End If
End With


Shadow-Eigenschaft

Font-Objekt: True, wenn dem angegebenen Text ein Schatten hinzugefügt wurde False, wenn dem angegebenen Text kein Schatten hinzugefügt wurde msoTriStateMixed, wenn nur bestimmten Textstellen ein Schatten hinzugefügt wurde. Long Schreib-Lese-Zugriff.

Shape- oder ShapeRange-Objekt: Gibt ein ShadowFormat-Objekt zurück, das Formatierungseigenschaften für Schatten für die angegebene Form bzw. die angegebenen Formen enthält. Nur-Lese-Zugriff.


Beispiel zur Shadow-Eigenschaft

In diesem Beispiel wird dem Titeltext von Folie 1 der aktiven Präsentation ein Schatten hinzugefügt.

Application.ActivePresentation.Slides(1).Shapes.Title _
    .TextFrame.TextRange.Font.Shadow = True

In diesem Beispiel wird Folie 1 der aktiven Präsentation ein schattiertes Rechteck hinzugefügt. Der blaue, hervorgehobene Schatten wird 3 Punkt nach rechts und 2 Punkt nach unten vom Rechteck versetzt.

Set myShap = Application.ActivePresentation.Slides(1).Shapes
With myShap.AddShape(msoShapeRectangle, 10, 10, 150, 90).Shadow
    .Type = msoShadow17
    .ForeColor.RGB = RGB(0, 0, 128)
    .OffsetX = 3
    .OffsetY = 2
End With


Shape-Eigenschaft

Gibt ein Shape-Objekt zurück, das eine Form in einer Tabellenzelle darstellt. Nur-Lese-Zugriff.


ShapeRange-Eigenschaft

Gibt ein ShapeRange-Objekt zurück, das alle Folienobjekte darstellt, die in der angegebenen Folie markiert sind. Dieser Bereich kann die Zeichnungen, Formen, OLE-Objekte, Grafiken, Textobjekte, Titel, Kopfzeilen, Fußzeilen, Platzhalter für Foliennummern sowie Objekte für Datum und Uhrzeit in einer Folie enthalten. Nur-Lese-Zugriff.

Hinweise

Sie können einen Formbereich von einer Markierung zurückgeben, wenn sich die Präsentation in der Normalansicht, der Folienansicht oder einer beliebigen Masteransicht befindet.


Beispiel zur ShapeRange-Eigenschaft

Dieses Beispiel legt die Vordergrundfarbe der Füllung für alle markierten Formen in Fenster 1 fest.

Windows(1).Selection.ShapeRange.Fill _
    .ForeColor.RGB = RGB(255, 0, 255)


Shapes-Eigenschaft

Gibt eine Shapes-Auflistung zurück, die alle Elemente darstellt, die in der angegebenen Folie, im Folienmaster oder im angegebenen Folienbereich platziert oder eingefügt wurden. Diese Auflistung kann die Zeichnungen, Formen, OLE-Objekte, Grafiken, Textobjekte, Titel, Kopfzeilen, Fußzeilen, Foliennummern sowie Objekte für Datum und Uhrzeit in einer Folie oder im Folienbild einer Notizenseite enthalten. Nur-Lese-Zugriff.

Informationen über die Rückgabe einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Shapes-Eigenschaft

Dieses Beispiel fügt ein Rechteck mit einer Breite von 100 Punkt und einer Höhe von 50 Punkt hinzu, dessen obere linke Ecke 5 Punkt von der linken Seite von Folie 1 der aktiven Präsentation und 25 Punkt von der Oberseite der Folie entfernt ist.

Set firstSlide = ActivePresentation.Slides(1)
firstSlide.Shapes.AddShape msoShapeRectangle, 5, 25, 100, 50

Dieses Beispiel legt die Füllstruktur für Form 3 in Folie 1 der aktiven Präsentation fest.

Set newRect = ActivePresentation.Slides(1).Shapes(3)
newRect.Fill.PresetTextured msoTextureOak

Wenn Folie 1 der aktiven Präsentation einen Titel enthält, legt die zweite und die dritte Zeile des Codes im folgenden Beispiel den Titeltext von Folie 1 in der Präsentation fest.

Set firstSl = ActivePresentation.Slides(1)
firstSl.Shapes.Title.TextFrame.TextRange.Text = "Some title text"
firstSl.Shapes(1).TextFrame.TextRange.Text = "Other title text"

Wenn Form 2 in Folie 2 der aktiven Präsentation einen Textrahmen enthält, fügt das folgende Beispiel der Folie eine Datenreihe mit Absätzen hinzu. Beachten Sie, dass Chr(13) verwendet wird, um Absatzmarken in den Text einzufügen.

Set tShape = ActivePresentation.Slides(2).Shapes(2)
tShape.TextFrame.TextRange.Text = "First Item" & Chr(13) & _
    "Second Item" & Chr(13) & "Third Item"

Bei den meisten Folienlayouts sind die ersten Formen in der Folie Platzhalter für Text. Im folgenden Beispiel wird das gleiche ausgeführt wie im vorhergehenden Beispiel.

Set testShape = ActivePresentation.Slides(2).Shapes.Placeholders(2)
testShape.TextFrame.TextRange.Text = "First Item" & _
    Chr(13) & "Second Item" & Chr(13) & "Third Item"


ShowandReturn-Eigenschaft

True, wenn Microsoft PowerPoint zur ursprünglichen Bildschirmpräsentation zurückkehrt, die aus einer deaktivierten benutzerdefinierten Bildschirmpräsentation durch das Hyperlink- oder ein ActionSetting-Objekt der ursprünglichen Präsentation aktiviert wurde. False, wenn PowerPoint aus der deaktivierten benutzerdefinierten Bildschirmpräsentation nicht zur ursprünglichen Bildschirmpräsentation zurückkehrt. Der Standardwert ist False. Long Schreib-Lese-Zugriff.


Beispiel zur ShowandReturn-Eigenschaft

In diesem Beispiel wird die Mausklickaktion für Form 5 auf Folie 1 der aktiven Präsentation festgelegt, mit der die benutzerdefinierte Bildschirmpräsentation "Techtalk" angezeigt wird. Wenn die benutzerdefinierte Bildschirmpräsentation durchlaufen ist, wird automatisch zur ursprünglichen Präsentation zurückgekehrt, und zwar in den Zustand vor dem Eintreten des Mausklicks.

With ActivePresentation.Slides(1).Shapes(5) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionNamedSlideShow
    .SlideShowName = "techtalk"
    .ShowandReturn = msoTrue
End With


ShowSlideAnimation-Eigenschaft

True, wenn bei der Vorschau, beim Speichern oder beim Veröffentlichen einer Webpräsentation die Folienanimationen aktiviert sind. Der Standardwert ist False. Long Schreib-Lese-Zugriff.


Beispiel zur ShowSlideAnimation-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Folienanimationen in Präsentation 2 für die Webpräsentation aktiviert sind. Dann wird die Vorschau der Webseite angezeigt.

With Presentations(2)
    .WebOptions.ShowSlideAnimation = True
    .WebPagePreview
End With


ShowType-Eigenschaft

Gibt die Art der Präsentation für die angegebene Bildschirmpräsentation zurück oder legt diese fest. Dies kann eine der folgenden PpSlideShowType-Konstanten sein: ppShowTypeKiosk, ppShowTypeSpeaker oder ppShowTypeWindow. Long Schreib-Lese-Zugriff.


Beispiel zur ShowType-Eigenschaft

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation in einem Fenster, die mit Folie 2 beginnt und mit Folie 4 endet. Das neue Fenster der Bildschirmpräsentation wird in der oberen linken Ecke des Bildschirms platziert. Die Breite und Höhe des Fensters beträgt jeweils 300 Punkt.

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowSlideRange
    .StartingSlide = 2
    .EndingSlide = 4
    .ShowType = ppShowTypeWindow
    With .Run
        .Left = 0
        .Top = 0
        .Width = 300
        .Height = 300
    End With
End With


ShowWindowsInTaskbar-Eigenschaft

True, wenn für jede geöffnete Präsentation eine Schaltfläche auf der Windows-Taskleiste vorhanden ist. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Wenn diese Eigenschaft auf True gesetzt ist, wird das Erscheinungsbild einer SDI (Single-Document Interface, Einzeldokumentoberfläche) simuliert. Dadurch wird das Wechseln zwischen geöffneten Präsentationen erleichtert. Wenn Sie jedoch mit mehreren Präsentationen arbeiten und gleichzeitig andere Anwendungen geöffnet sind, empfiehlt es sich möglicherweise, diese Eigenschaft auf False zu setzen. So vermeiden Sie, dass die Taskleiste durch nicht benötigte Schaltflächen gefüllt wird.

Diese Eigenschaft ist nur verfügbar, wenn Sie Microsoft Office mit der Windows-Desktopaktualisierung, mit Windows 98 oder mit Windows 2000 verwenden.


Beispiel zur ShowWindowsInTaskbar-Eigenschaft

In diesem Beispiel wird festgelegt, dass nicht für jede geöffnete Präsentation eine Schaltfläche auf der Taskleiste von Windows angezeigt wird.

Application.ShowWindowsInTaskbar = False


ShowWithAnimation-Eigenschaft

True, wenn die angegebene Bildschirmpräsentation Formen mit zugewiesenen Animationseinstellungen anzeigt. Long Schreib-Lese-Zugriff.


Beispiel zur ShowWithAnimation-Eigenschaft

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, bei der Animation und Stimme nicht aktiv sind.

With ActivePresentation.SlideShowSettings
    .ShowWithAnimation = False
    .ShowWithNarration = False
    .Run
End With


ShowWithNarration-Eigenschaft

True, wenn die angegebene Bildschirmpräsentation mit Stimme ausgeführt wird. Long Schreib-Lese-Zugriff.


Beispiel zur ShowWithNarration-Eigenschaft

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, bei der Animation und Stimme nicht aktiv sind.

With ActivePresentation.SlideShowSettings
    .ShowWithAnimation = False
    .ShowWithNarration = False
    .Run
End With


Size-Eigenschaft

Gibt die Zeichengröße in Punkt zurück oder legt diese fest. Single Schreib-Lese-Zugriff.


Beispiel zur Size-Eigenschaft

In diesem Beispiel wird die Größe des Textes von Form 1 in Folie 1 auf 24 Punkt festgelegt.

Application.ActivePresentation.Slides(1) _
    .Shapes(1).TextFrame.TextRange.Font _
    .Size = 24


Slide-Eigenschaft

SlideShowView-Objekt: Gibt ein Slide-Objekt zurück, das die Folie darstellt, die derzeit in der Ansicht des angegebenen Bildschirmpräsentationsfensters angezeigt wird. Nur-Lese-Zugriff.

View-Objekt: Gibt ein Slide-Objekt zurück, das die Folie darstellt, die derzeit in der Ansicht des angegebenen Dokumentfensters angezeigt wird, oder legt ein Objekt fest. Schreib-Lese-Zugriff.

Anmerkungen

Wenn die derzeit angezeigte Folie zu einer eingebetteten Präsentation gehört, können Sie die Parent-Eigenschaft des von der Slide-Eigenschaft zurückgegebenen Slide-Objekts verwenden, um die eingebettete Präsentation zurückzugeben, die die Folie enthält. (Die Presentation-Eigenschaft des SlideShowWindow-Objekts oder des DocumentWindow-Objekts gibt nicht die eingebettete Präsentation zurück, sondern die Präsentation, aus der das Fenster erstellt wurde.)


SlideElapsedTime-Eigenschaft

Gibt die Anzahl der Sekunden zurück, die die aktuelle Folie angezeigt wurde. Long Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie die ResetSlideTime-Methode, um die für die derzeit angezeigte Folie verstrichene Zeit zurückzusetzen.


Beispiel zur SlideElapsedTime-Eigenschaft

In diesem Beispiel wird für die Folie, die derzeit in Bildschirmpräsentationsfenster 1 angezeigt wird, eine Variable für die verstrichene Zeit eingesetzt. Anschließend wird der Wert der Variablen angezeigt.

currTime = SlideShowWindows(1).View.SlideElapsedTime
MsgBox currTime


SlideHeight-Eigenschaft

Gibt die Höhe der Folie in Punkt zurück oder legt diese fest. Single Schreib-Lese-Zugriff.


Beispiel zur SlideHeight-Eigenschaft

In diesem Beispiel wird die Höhe der Folie auf 8,5 Zoll und die Breite der Folie auf 11 Zoll für die aktive Präsentation festgelegt.

With Application.ActivePresentation.PageSetup
    .SlideWidth = 11 * 72
    .SlideHeight = 8.5 * 72
End With


SlideID-Eigenschaft

Gibt eine eindeutige ID für die angegebene Folie zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Im Gegensatz zur SlideIndex-Eigenschaft ändert sich die SlideID-Eigenschaft eines Slide-Objekts nicht, wenn Sie der Präsentation Folien hinzufügen oder die Folien in der Präsentation neu anordnen. Deshalb ist die FindBySlideID-Methode mit der ID-Nummer besser geeignet, um ein bestimmtes Slide-Objekt von einer Slides-Auflistung zurückzugeben, als die Item-Methode mit der Indexnummer der Folie.


SlideIDs-Eigenschaft

Gibt eine Matrix mit Folien-IDs für die angegebene benannte Bildschirmpräsentation zurück. Variant Schreib-Lese-Zugriff.


Beispiel zur SlideIDs-Eigenschaft

Dieses Beispiel fügt der benutzerdefinierten Bildschirmpräsentation "Kurzbericht Marketing" die aktuelle Folie im aktiven Fenster hinzu. Beachten Sie, dass Sie die ursprüngliche benutzerdefinierte Bildschirmpräsentation zuerst löschen und anschließend wieder mit dem gleichen Namen hinzufügen müssen, um eine geänderte Version der benutzerdefinierten Bildschirmpräsentation speichern zu können. Beachten Sie außerdem, dass Sie die Variable ausdrücklich deklarieren müssen, bevor Sie versuchen, die Größe ihrer Matrix zu ändern, wenn Sie die Größe einer Matrix ändern möchten, die in einer Variant-Variablen enthalten ist.

'NOTE - The following code line is NOT optional.
'Can't redim array without this
Dim customShowSlideIDs As Variant
Dim customShowToExpand As NamedSlideShow

customShowName = "Marketing Short Version"
Set customShowToExpand = ActivePresentation.SlideShowSettings _
    .NamedSlideShows(customShowName)
slideToAddID = ActiveWindow.View.Slide.SlideID
customShowSlideIDs = customShowToExpand.SlideIDs
numSlides = UBound(customShowSlideIDs)

ReDim Preserve customShowSlideIDs(numSlides + 1)

customShowSlideIDs(numSlides + 1) = slideToAddID
customShowToExpand.Delete
ActivePresentation.SlideShowSettings.NamedSlideShows _
    .Add customShowName, customShowSlideIDs


SlideIndex-Eigenschaft

Gibt die Indexnummer der angegebenen Folie in der Slides-Auflistung zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Im Gegensatz zur SlideID-Eigenschaft kann sich die SlideIndex-Eigenschaft eines Slide-Objekts ändern, wenn Sie der Präsentation Folien hinzufügen oder die Folien in der Präsentation neu anordnen. Deshalb ist die FindBySlideID-Methode mit der ID-Nummer besser geeignet, um ein bestimmtes Slide-Objekt von einer Slides-Auflistung zurückzugeben, als die Item-Methode mit der Indexnummer der Folie.


Beispiel zur SlideIndex-Eigenschaft

Dieses Beispiel zeigt die Indexnummer der aktuell angezeigten Folie im Fenster 1 der Bildschirmpräsentation an.

MsgBox SlideShowWindows(1).View.Slide.SlideIndex


SlideMaster-Eigenschaft

Gibt ein Master-Objekt zurück, das den Folienmaster darstellt. Nur-Lese-Zugriff.


Beispiel zur SlideMaster-Eigenschaft

In diesem Beispiel wird das Hintergrundmuster beim Folienmaster für die aktive Präsentation festgelegt.

Application.ActivePresentation.SlideMaster.Background.Fill _
    .PresetTextured msoTextureGreenMarble


SlideNumber-Eigenschaft

HeadersFooters-Auflistung: Gibt ein HeaderFooter-Objekt zurück, das die Foliennummer unten rechts in einer Folie oder die Seitenzahl unten rechts in einer Notizzettelseite oder einem gedruckten Handzettel oder einer gedruckten Gliederung darstellt. Nur-Lese-Zugriff.

Slide oder SlideRange-Objekt: Gibt die Foliennummer zurück. Integer Nur-Lese-Zugriff.

Hinweise

Die SlideNumber-Eigenschaft bei einem Slide-Objekt ist die tatsächliche Nummer, die unten links in der Folie erscheint, wenn Sie Foliennummern anzeigen. Diese Nummer wird durch die Nummer der Folie innerhalb der Präsentation (der Wert für die SlideIndex-Eigenschaft) und durch die Anfangsfoliennummer für die Präsentation (der Wert für die FirstSlideNumber-Eigenschaft) bestimmt. Die Foliennummer ist immer gleich der Anfangsfoliennummer plus der Folienindexnummer -1.


Beispiel zur SlideNumber-Eigenschaft

Dieses Beispiel zeigt, wie sich die Änderung der ersten Foliennummer auf die Foliennummer einer bestimmten Folie auswirkt.

With Application.ActivePresentation
    .PageSetup.FirstSlideNumber = 1   'starts slide numbering at 1
    MsgBox .Slides(2).SlideNumber     'returns 2

    .PageSetup.FirstSlideNumber = 10  'starts slide numbering at 10
    MsgBox .Slides(2).SlideNumber     'returns 11
End With

In diesem Beispiel wird die Foliennummer in Folie 2 der aktiven Präsentation ausgeblendet bzw. eingeblendet (wenn die Foliennummer bereits ausgeblendet ist).

With Application.ActivePresentation.Slides(2) _
        .HeadersFooters.SlideNumber
    If .Visible Then
        .Visible = False
    Else
        .Visible = True
    End If
End With


SlideOrientation-Eigenschaft

Gibt das Format für den Druck und das Format am Bildschirm für Folien in der angegebenen Präsentation zurück oder legt dieses fest. Dies kann eine der folgenden MsoOrientation-Konstanten sein: msoOrientationHorizontal, msoOrientationMixed oder msoOrientationVertical. Long Schreib-Lese-Zugriff.


Beispiel zur SlideOrientation-Eigenschaft

In diesem Beispiel wird für alle Folien in der aktiven Präsentation das Hochformat festgelegt.

Application.ActivePresentation.PageSetup.SlideOrientation = _
    msoOrientationVertical


SlideRange-Eigenschaft

Gibt ein SlideRange-Objekt zurück, das einen Bereich mit markierten Folien darstellt. Nur-Lese-Zugriff.

Hinweise

Ein Folienbereich kann in der Folienansicht, Foliensortieransicht, der Normalansicht, der Notizseitenansicht oder der Gliederungsansicht erstellt werden. In der Folienansicht gibt SlideRange die aktuell angezeigte Folie zurück.


Beispiel zur SlideRange-Eigenschaft

Dieses Beispiel legt die Hintergrundfarbe aus der Farbskala für alle Folien fest, die in Fenster 1 markiert sind.

Windows(1).Selection.SlideRange.ColorScheme _
    .Colors(ppBackground).RGB = RGB(0, 0, 255)


Slides-Eigenschaft

Gibt eine Slides-Auflistung zurück, die alle Folien in der angegebenen Präsentation darstellt. Nur-Lese-Zugriff.


SlideShowName-Eigenschaft

ActionSetting-Objekt: Gibt den Namen der benutzerdefinierten Bildschirmpräsentation zurück, die aufgrund einer Mausaktion auf der Form während einer Bildschirmpräsentation aktiviert werden soll, und legt den Namen fest. String Schreib-Lese-Zugriff.

PrintOptions-Objekt: Gibt den Namen der zu druckenden, zielgruppenorientierten Bildschirmpräsentation zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

PublishObject-Objekt: Gibt den Namen der zielgruppenorientierten Bildschirmpräsentation zurück, die als Webpräsentation publiziert wurde oder legt ihn fest. String Schreib-Lese-Zugriff.

SlideShowView-Objekt: Gibt den Namen der zielgruppenorientierten Bildschirmpräsentation zurück, die derzeit in der angegebenen Bildschirmpräsentationsansicht läuft. String Nur-Lese-Zugriff.

Hinweise

Die RangeType-Eigenschaft muss auf ppPrintNamedSlideShow eingestellt werden, damit eine zielgruppenorientierte Bildschirmpräsentation gedruckt werden kann.


Beispiel zur SlideShowName-Eigenschaft

Wenn die in Bildschirmpräsentationsfenster eins laufende Bildschirmpräsentation eine zielgruppenorientierte Bildschirmpräsentation ist, wird mit diesem Beispiel deren Namen angezeigt.

With SlideShowWindows(1).View
    If .IsNamedShow Then
        MsgBox "Now showing in slide show window 1: " _
            & .SlideShowName
    End If
End With

In diesem Beispiel wird eine vorhandene zielgruppenorientierte Bildschirmpräsentation "tech talk" gedruckt.

With ActivePresentation.PrintOptions
    .RangeType = ppPrintNamedSlideShow
    .SlideShowName = "tech talk"
End With
ActivePresentation.PrintOut

Das folgende Beispiel speichert die aktuelle Präsentation als Datei mit dem Namen "mallard.htm" im Format HTML Version 4.0. Danach wird eine Meldung angezeigt, dass die aktuelle, benannte Präsentation sowohl im Format von PowerPoint als auch im Format HTML gespeichert wurde.

With Pres.PublishObjects(1)
    PresName = .SlideShowName
    .SourceType = ppPublishAll
    .FileName = "C:\HTMLPres\mallard.htm"
    .HTMLVersion = ppHTMLVersion4
    MsgBox ("Saving presentation " & "'" _
        & PresName & "'" & " in PowerPoint" _
        & Chr(10) & Chr(13) _
        & " format and HTML version 4.0 format")
    .Publish
End With


SlideShowSettings-Eigenschaft

Gibt ein SlideShowSettings-Objekt zurück, das die Einstellungen der Bildschirmpräsentation für die angegebene Präsentation darstellt. Nur-Lese-Zugriff.


Beispiel zur SlideShowSettings-Eigenschaft

In diesem Beispiel wird eine Bildschirmpräsentation gestartet, die von einem Redner präsentiert werden soll. Die Bildschirmpräsentation wird ausgeführt, während Animation und Stimme ausgeschaltet sind.

With Application.ActivePresentation.SlideShowSettings
    .ShowType = ppShowTypeSpeaker
    .ShowWithNarration = False
    .ShowWithAnimation = False
    .Run
End With


SlideShowTransition-Eigenschaft

Gibt ein SlideShowTransition-Objekt zurück, das die Spezialeffekte für den angegebenen Folienübergang darstellt. Nur-Lese-Zugriff.


Beispiel zur SlideShowTransition-Eigenschaft

Dieses Beispiel legt für Folie 2 der aktiven Präsentation fest, dass während einer Bildschirmpräsentation nach 5 Sekunden automatisch die nächste Folie aufgerufen wird, wobei während des Folienübergangs Hundegebell abgespielt wird.

With ActivePresentation.Slides(2).SlideShowTransition
    .AdvanceOnTime = True
    .AdvanceTime = 5
    .SoundEffect.ImportFromFile "c:\windows\media\dogbark.wav"
End With
ActivePresentation.SlideShowSettings.AdvanceMode = _
    ppSlideShowUseSlideTimings


SlideShowWindow-Eigenschaft

Gibt ein SlideShowWindow-Objekt zurück, welches das Bildschirmpräsentationsfenster darstellt, in dem die angegebene Präsentation ausgeführt wird. Nur-Lese-Zugriff.

Hinweise

Diese Eigenschaft kann in Verbindung mit dem Me-Schlüsselwort und der Parent-Eigenschaft verwendet werden, um das Bildschirmpräsentationsfenster zurückzugeben, in welchem ein Ereignis eines ActiveX-Steuerelements ausgelöst wurde, wie im Beispiel gezeigt wird.


SlideShowWindows-Eigenschaft

Gibt eine SlideShowWindows-Auflistung zurück, die alle offenen Fenster von Bildschirmpräsentationen darstellt. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung


Beispiel zur SlideShowWindows-Eigenschaft

In diesem Beispiel wird eine Bildschirmpräsentation in einem Fenster ausgeführt und die Höhe und Breite für das Fenster der Bildschirmpräsentation festgelegt.

With Application
    .Presentations(1).SlideShowSettings.Run
    With .SlideShowWindows(1)
        .Height = 250
        .Width = 250
    End With
End With


SlideSize-Eigenschaft

Gibt die Foliengröße für die angegebene Präsentation zurück oder legt diese fest. Dies kann eine der folgenden PpSlideSizeType-Konstanten sein: ppSlideSize35MM, ppSlideSizeA4Paper, ppSlideSizeCustom, ppSlideSizeLetterPaper, ppSlideSizeOnScreen oder ppSlideSizeOverhead. Long Schreib-Lese-Zugriff.


Beispiel zur SlideSize-Eigenschaft

In diesem Beispiel wird die Foliengröße auf Overheadformat für die aktive Präsentation festgelegt.

Application.ActivePresentation.PageSetup _
    .SlideSize = ppSlideSizeOverhead


SlideWidth-Eigenschaft

Gibt die Folienbreite in Punkt zurück oder legt diese fest. Single Schreib-Lese-Zugriff.


Beispiel zur SlideWidth-Eigenschaft

In diesem Beispiel wird die Folienhöhe auf 8,5 Zoll und die Folienbreite auf 11 Zoll für die aktive Präsentation festgelegt.

With Application.ActivePresentation.PageSetup
    .SlideWidth = 11 * 72
    .SlideHeight = 8.5 * 72
End With


SoundEffect-Eigenschaft

ActionSetting-Objekt: Gibt ein SoundEffect-Objekt zurück, das den Klang darstellt, der wiedergegeben wird, wenn Sie auf die angegebene Form klicken oder den Mauszeiger darauf richten. Wenn Sie den Klang während der Bildschirmpräsentation nicht hören, den Sie der Form zugewiesen haben, vergewissern Sie sich, dass für die TextLevelEffect-Eigenschaft ein anderer Wert als ppAnimateLevelNone festgelegt ist und für die Animate-Eigenschaft True gilt. Nur-Lese-Zugriff.

AnimationSettings-Objekt: Gibt ein SoundEffect-Objekt zurück, das den Klang darstellt, der während der Animation zu der angegebenen Form wiedergegeben wird. Nur-Lese-Zugriff.

SlideShowTransition-Objekt: Gibt ein SoundEffect-Objekt zurück, das den Klang darstellt, der während des Übergangs zur angegebenen Folie wiedergegeben wird. Nur-Lese-Zugriff.


Beispiel zur SoundEffect-Eigenschaft

Dieses Beispiel legt fest, dass die Datei Bass.wav immer dann wiedergegeben wird, wenn Form 1 in Folie 1 der aktiven Präsentation animiert wird.

With ActivePresentation.Slides(1).Shapes(1).AnimationSettings
    .Animate = True
    .TextLevelEffect = ppAnimateByAllLevels
    .SoundEffect.ImportFromFile "c:\sndsys\bass.wav"
End With


SourceFullName-Eigenschaft

Gibt den Namen und den Pfad der Quelldatei für das verknüpfte OLE-Objekt zurück oder legt diesen fest. String Schreib-Lese-Zugriff.


Beispiel zur SourceFullName-Eigenschaft

Dieses Beispiel legt die Quelldatei "Wordtest.doc" für Form 1 in Folie 1 in der aktiven Präsentation fest und gibt an, dass das Bild des Objekts automatisch aktualisiert wird.

With ActivePresentation.Slides(1).Shapes(1)
    If .Type = msoLinkedOLEObject Then
        With .LinkFormat
            .SourceFullName = "c:\my documents\wordtest.doc"
            .AutoUpdate = ppUpdateOptionAutomatic
        End With
    End If
End With


SourceType-Eigenschaft

Gibt den Quellentyp der im HTML-Format zu veröffentlichenden Präsentation an oder legt diesen fest. Kann eine der folgenden PpPublishSourceType-Konstanten sein: ppPublishAll, ppPublishNamedSlideShow oder ppPublishSlideRange. Long Schreib-Lese-Zugriff.

Hinweise

Verwenden Sie zum Veröffentlichen einer benutzerdefinierten Bildschirmpräsentation die ppPublishNamedSlideShow-Konstante, und geben Sie dabei den Namen der benutzerdefinierten Bildschirmpräsentation mit der SlideShowName-Eigenschaft an.


Beispiel zur SourceType-Eigenschaft

In diesem Beispiel wird der angegebene Folienbereich (Folien 3-5) des aktiven Dokuments im HTML-Format veröffentlicht. Die veröffentlichte Präsentation wird Mallard.htm genannt.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .Publish
End With


SpaceAfter-Eigenschaft

Gibt den Abstand nach der ersten Zeile in jedem Absatz des angegebenen Textes in Punkt oder Zeilen zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.


Beispiel zur SpaceAfter-Eigenschaft

In diesem Beispiel wird der Abstand nach Absätzen auf 6 Punkt für den Text von Form 2 in Folie 1 der aktiven Präsentation festgelegt.

With Application.ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat
        .LineRuleAfter = False
        .SpaceAfter = 6
    End With
End With


SpaceBefore-Eigenschaft

Gibt den Abstand vor der ersten Zeile in jedem Absatz des angegebenen Textes in Punkt oder Zeilen zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.


Beispiel zur SpaceBefore-Eigenschaft

In diesem Beispiel wird der Abstand vor Absätzen auf 6 Punkt für den Text von Form 2 in Folie 1 der aktiven Präsentation festgelegt.

With Application.ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat
        .LineRuleBefore = False
        .SpaceBefore = 6
    End With
End With


SpaceWithin-Eigenschaft

Gibt den Abstand zwischen den Grundlinien im angegebenen Text in Punkt oder Zeilen zurück oder legt diesen fest. Single Schreib-Lese-Zugriff.


Beispiel zur SpaceWithin-Eigenschaft

In diesem Beispiel wird ein Zeilenabstand von 21 Punkt für den Text von Form 2 in Folie 2 der aktiven Präsentation festgelegt.

With Application.ActivePresentation.Slides(2).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat
        .LineRuleWithin = False
        .SpaceWithin = 21
    End With
End With


SpeakerNotes-Eigenschaft

True, wenn die Sprechernotizen gemeinsam mit der Präsentation veröffentlicht werden sollen. Long Schreib-Lese-Zugriff.


Beispiel zur SpeakerNotes-Eigenschaft

In diesem Beispiel werden die Folien 3-5 der aktiven Präsentation im HTML-Format veröffentlicht. Die dazugehörigen Sprechernotizen werden als Teil der Präsentation veröffentlicht und die Präsentation als Mallard.htm benannt.

With ActivePresentation.PublishObjects(1)
    .FileName = "C:\Test\Mallard.htm"
    .SourceType = ppPublishSlideRange
    .RangeStart = 3
    .RangeEnd = 5
    .SpeakerNotes = True
    .Publish
End With


Speed-Eigenschaft

Gibt die Geschwindigkeit des Übergangs zur angegebenen Folie zurück oder legt diese fest. Dies kann eine der folgenden PpTransitionSpeed-Konstanten sein: ppTransitionSpeedFast, ppTransitionSpeedMedium, ppTransitionSpeedMixed oder ppTransitionSpeedSlow. Long Nur-Lese-Zugriff.


Beispiel zur Speed-Eigenschaft

Dieses Beispiel legt Diagonal nach unten links als Spezialeffekt für den Übergang zu Folie 1 der aktiven Präsentation sowie eine schnelle Übergangsgeschwindigkeit fest.

With ActivePresentation.Slides(1).SlideShowTransition
    .EntryEffect = ppEffectStripsDownLeft
    .Speed = ppTransitionSpeedFast
End With


SplitHorizontal-Eigenschaft

Gibt die Breite des Dokumentfensters zurück oder legt diese fest, die der Gliederungsausschnitt in der Normalansicht einnimmt. Entspricht der Position der Trennlinie zwischen Folienausschnitt und Gliederungsausschnitt. Long Schreib-Lese-Zugriff.

Hinweise

Der Maximalwert der SplitHorizontal-Eigenschaft beträgt immer weniger als 100%, weil der Folienausschnitt eine minimale Breite auf Grundlage einer 10%-Zoomstufe einnimmt. Der tatsächliche Maximalwert kann je nach Größe des Anwendungsfensters variieren.


Beispiel zur SplitHorizontal-Eigenschaft

Im folgenden Beispiel wird die vertikale Trennlinie für das aktive Dokumentfenster so festgelegt, dass sie zu 15% in Gliederungsfenster und zu 85% in Folienfenster unterteilt.

ActiveWindow.SplitHorizontal = 15


SplitVertical-Eigenschaft

Gibt die Höhe des Dokumentfensters in Prozent zurück oder legt die Höhe fest, die der Folienausschnitt in der Normalansicht einnimmt. Entspricht der Position der Trennlinie zwischen Folienausschnitt und Notizenausschnitt. Long Schreib-Lese-Zugriff.

Hinweise

Der Minimalwert der SplitVertical-Eigenschaft beträgt immer mehr als 0%, weil der Folienausschnitt eine minimale Höhe auf Grundlage einer 10%-Zoomstufe einnimmt. Der tatsächliche Minimalwert kann je nach Größe des Anwendungsfensters variieren.


Beispiel zur SplitVertical-Eigenschaft

Im folgenden Beispiel wird die horizontale Trennlinie für das aktive Dokumentfenster so festgelegt, dass sie zu 60% in Folienausschnitt und zu 40% in Notizenausschnitt unterteilt.

ActiveWindow.SplitVertical = 60


Start-Eigenschaft

PrintRange-Objekt: Gibt die Nummer der ersten Folie im Folienbereich an, der gedruckt werden soll. Long Nur-Lese-Zugriff.

TextRange-Objekt: Gibt die Position des ersten Zeichens im angegebenen Textbereich relativ zum ersten Zeichen in der Form zurück, die den Text enthält. Long Nur-Lese-Zugriff.


StartingSlide-Eigenschaft

Gibt die erste Folie zurück, die in der angegebenen Bildschirmpräsentation angezeigt werden soll, oder legt diese fest. Long Schreib-Lese-Zugriff.


Beispiel zur StartingSlide-Eigenschaft

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation, die mit Folie 2 beginnt und mit Folie 4 endet.

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowSlideRange
    .StartingSlide = 2
    .EndingSlide = 4
    .Run
End With


StartValue-Eigenschaft

Gibt den Anfangswert einer Aufzählung zurück oder legt diesen fest, wenn die Type-Eigenschaft des BulletFormat-Objekts auf ppBulletNumbered gestellt ist. Der Wert muss im Bereich von 1 bis 32767 liegen. Integer Schreib-Lese-Zugriff.


Beispiel zur StartValue-Eigenschaft

In diesem Beispiel werden Aufzählungszeichen für das Textfeld festgelegt, das durch Form 2 auf Folie 1 mit der Zahl fünf beginnend festgelegt ist.

With ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange.ParagraphFormat.Bullet
        .Type = ppBulletNumbered
        .StartValue = 5
    End With
End With


State-Eigenschaft

Gibt den Zustand der Bildschirmpräsentation zurück oder legt ihn fest. Dies kann eine der folgenden PpSlideShowState-Konstanten sein: ppSlideShowBlackScreen, ppSlideShowDone, ppSlideShowPaused, ppSlideShowRunning, ppSlideShowWhiteScreen. Long Schreib-Lese-Zugriff.


Beispiel zur State-Eigenschaft

In diesem Beispiel wird für den Zustand der Ansicht in Bildschirmpräsentationsfenster 1 festgelegt, dass der Bildschirm schwarz ist.

SlideShowWindows(1).View.State = ppSlideShowBlackScreen


StopAfterSlides-Eigenschaft

Gibt die Anzahl der Folien zurück, die angezeigt werden sollen, bevor der Medienclip nicht mehr wiedergegeben wird, oder legt diese Anzahl fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Damit die StopAfterSlides-Eigenschaft funktioniert, muss für die PauseAnimation-Eigenschaft der angegebenen Folie False und die PlayOnEntry-Eigenschaft True gelten.

Der Medienclip wird nicht mehr wiedergegeben, wenn die Anzeige der angegebenen Folien oder der Clip zu Ende ist (je nachdem, was zuerst eintritt). Der Wert 0 gibt an, dass der Clip nach der Anzeige der aktuellen Folie nicht mehr wiedergegeben wird.


Beispiel zur StopAfterSlides-Eigenschaft

Dieses Beispiel gibt an, dass der Medienclip, der von Form 3 in Folie 1 der aktiven Präsentation dargestellt wird, automatisch wiedergegeben wird, wenn sie animiert wird. Außerdem fährt die Bildschirmpräsentation fort, während der Medienclip im Hintergrund wiedergegeben wird. Außerdem wird festgelegt, dass der Clip nach der Anzeige von drei Folien bzw. nach dem Ende des Clips (je nachdem, was zuerst eintritt) nicht mehr wiedergegeben wird. Form 3 muss ein Klang- oder Filmobjekt sein.

Set OLEobj = ActivePresentation.Slides(1).Shapes(3)
With OLEobj.AnimationSettings.PlaySettings
    .PlayOnEntry = True
    .PauseAnimation = False
    .StopAfterSlides = 3
End With


Style-Eigenschaft

LineFormat-Objekt: Gibt die Linienart zurück oder legt sie fest. Dies kann eine der folgenden MsoLineStyle-Konstanten sein: msoLineSingle, msoLineStyleMixed, msoLineThickBetweenThin, msoLineThickThin, msoLineThinThick oder msoLineThinThin. Long Schreib-Lese-Zugriff.

BulletFormat-Objekt: Gibt das Format der Aufzählungszeichen zurück oder legt es fest. Dies kann eine der folgenden PpNumberedBulletStyle-Konstanten sein. Abhängig von der ausgewählten oder installierten Sprachunterstützung (beispielsweise Deutsch) sind einige dieser Konstanten möglicherweise nicht verfügbar. Long Schreib-Lese-Zugriff.

Konstante | Wert | Beschreibung
ppBulletAlphaLCParenBoth | 8 | Kleinbuchstaben in runden Klammern
ppBulletAlphaLCParenRight | 9 | Kleinbuchstaben mit runder Klammer rechts
ppBulletAlphaLCPeriod | 0 | Kleinbuchstaben mit einem Punkt
ppBulletAlphaUCParenBoth | 10 | Großbuchstaben in runden Klammern
ppBulletAlphaUCParenRight | 11 | Großbuchstaben mit runder Klammer rechts
ppBulletAlphaUCPeriod | 1 | Großbuchstaben mit einem Punkt
ppBulletArabicAbjadDash | 24 | Arabisches Abdschad-Alphabet mit einem Gedankenstrich
ppBulletArabicAlphaDash | 23 | Buchstaben des arabischen Alphabets mit einem Gedankenstrich
ppBulletArabicDBPeriod | 29 | Arabische Doppelbyte-Nummerierungszeichen mit Doppelbyte-Punkten
ppBulletArabicDBPlain | 28 | Arabische Doppelbyte-Nummerierungszeichen (ohne Interpunktion)
ppBulletArabicParenBoth | 12 | Arabische Zahlen in runden Klammern
ppBulletArabicParenRight | 2 | Arabische Zahlen mit runder Klammer rechts
ppBulletArabicPeriod | 3 | Arabische Zahlen mit einem Punkt
ppBulletArabicPlain | 13 | Arabische Zahlen
ppBulletCircleNumDBPlain | 18 | Doppelbyteziffer in einem Kreis für Werte bis 10
ppBulletCircleNumWDBlackPlain | 20 | Zahl in Schattenfarbe in einem Kreis in Textfarbe
ppBulletCircleNumWDWhitePlain | 19 | Zahl in Textfarbe in einem Kreis der gleichen Farbe
ppBulletHebrewAlphaDash | 25 | Buchstaben des hebräischen Alphabets mit einem Gedankenstrich
ppBulletKanjiKoreanPeriod | 27 | Japanische/koreanische Zahlen mit einem Punkt
ppBulletKanjiKoreanPlain | 26 | Japanische/koreanische Zahlen ohne Punkt
ppBulletRomanLCParenBoth | 4 | Kleingeschriebene römische Zahlen in runden Klammern
ppBulletRomanLCParenRight | 5 | Kleingeschriebene römische Zahlen mit runder Klammer rechts
ppBulletRomanLCPeriod | 6 | Kleingeschriebene römische Zahlen mit einem Punkt
ppBulletRomanUCParenBoth | 14 | Großgeschriebene römische Zahlen in runden Klammern
ppBulletRomanUCParenRight | 15 | Großgeschriebene römische Zahlen mit runder Klammer rechts
ppBulletRomanUCPeriod | 7 | Großgeschriebene römische Zahlen mit einem Punkt
ppBulletSimpChinPlain | 16 | Chinesisch (simplifiziert) ohne Punkt
ppBulletSimpChinPeriod | 17 | Chinesisch (simplifiziert) mit einem Punkt
ppBulletStyleMixed | -2 | Ein beliebiges undefiniertes Format
ppBulletTradChinPlain | 21 | Chinesisch (traditionell) ohne Punkt
ppBulletTradChinPeriod | 22 | Chinesisch (traditionell) mit einem Punkt


Beispiel zur Style-Eigenschaft

Dieses Beispiel fügt zu myDocument eine dicke, blaue Verbundlinie hinzu. Die Verbundlinie besteht aus einer dicken Linie, die an beiden Enden eine dünne Linie hat.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .Style = msoLineThickBetweenThin
    .Weight = 8
    .ForeColor.RGB = RGB(0, 0, 255)
End With

In diesem Beispiel wird das Format der Aufzählungszeichen der Aufzählung, dargestellt durch Form 1 der ersten Folie, festgelegt als Zahl in Schattenfarbe in einem Kreis in normaler Textfarbe.

ActivePresentation.Slides(1).Shapes(1).TextFrame _
    .TextRange.ParagraphFormat.Bullet _
        .Style = ppBulletCircleNumWDBlackPlain


SubAddress-Eigenschaft

Gibt die Position in einem Dokument (z. B. eine Textmarke in einem Word-Dokument, ein Bereich in einem Microsoft Excel-Tabellenblatt oder eine Folie in einer PowerPoint-Präsentation) zurück, die einem angegebenen Hyperlink zugewiesen ist, oder legt diese fest. String Schreib-Lese-Zugriff.


Beispiel zur SubAddress-Eigenschaft

Dieses Beispiel legt fest, dass Form 1 von Folie 1 der aktiven Präsentation zur Folie "Last Quarter" in "Latest Figures.ppt" springt, sobald Sie auf die Form während einer Bildschirmpräsentation klicken.

With ActivePresentation.Slides(1).Shapes(1) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    With .Hyperlink
        .Address = "c:\sales\latest figures.ppt"
        .SubAddress = "last quarter"
    End With
End With

Dieses Beispiel legt fest, dass Form 1 in Folie 1 in der aktiven Präsentation zum Bereich A1:B10 in "Latest.xls" springt, sobald Sie auf die Form während einer Bildschirmpräsentation klicken.

With ActivePresentation.Slides(1).Shapes(1) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    With .Hyperlink
        .Address = "c:\sales\latest.xls"
        .SubAddress = "A1:B10"
    End With
End With


Subscript-Eigenschaft

True, wenn der angegebene Text tiefgestellt ist, False, wenn der angegebene Text nicht tiefgestellt ist, msoStateMixed, wenn einige Zeichen im Text tiefgestellt sind. Der Standard ist False. Long Schreib-Lese-Zugriff.

Anmerkungen

Wird für die BaselineOffset-Eigenschaft ein negativer Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch True und für die Superscript-Eigenschaft automatisch False.

Wird für die BaselineOffset-Eigenschaft ein positiver Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch False und für die Superscript-Eigenschaft automatisch True.

Wird für die Subscript-Eigenschaft True festgelegt, gilt für die BaselineOffset-Eigenschaft automatisch der Wert – 0,25 ( – 25%).


Beispiel zur Subscript-Eigenschaft

In diesem Beispiel wird das erste Zeichen im Titel von Folie 1 vergrößert, wenn es tiefgestellt ist.

With Application.ActivePresentation.Slides(1) _
        .Shapes.Title.TextFrame.TextRange
    With .Characters(1, 1).Font
        If .Subscript Then
            scaleChar = -20 * .BaselineOffset
            .Size = .Size * scaleChar
        End If
    End With
End With


Superscript-Eigenschaft

True, wenn der angegebene Text hochgestellt ist, False, wenn der Text nicht hochgestellt ist, msoStateMixed, wenn einige Zeichen im Text hochgestellt sind. Der Standard ist False. Long Schreib-Lese-Zugriff.

Anmerkungen

Wird für die BaselineOffset-Eigenschaft ein negativer Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch True und für die Superscript-Eigenschaft automatisch False.

Wird für die BaselineOffset-Eigenschaft ein positiver Wert festgelegt, gilt für die Subscript-Eigenschaft automatisch False und für die Superscript-Eigenschaft automatisch True.

Wird für die Superscript-Eigenschaft True festgelegt, gilt für die BaselineOffset-Eigenschaft automatisch der Wert 0,3 (30%).


Beispiel zur Superscript-Eigenschaft

In diesem Beispiel wird der Text für Form 2 auf Folie 1 festgelegt, wobei das fünfte Zeichen 30 % hochgestellt wird.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame
    With .TextRange
        .Text = "E=mc2"
        .Characters(5, 1).Font.Superscript = True
    End With
End With


Table-Eigenschaft

Gibt ein Table-Objekt zurück, das eine Tabelle in einer Form oder in einem Formenbereich darstellt. Nur-Lese-Zugriff.


TableDirection-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the direction in which the table cells are ordered. Can be one of the following PpDirection constants: ppDirectionLeftToRight, ppDirectionMixed, or ppDirectionRightToLeft. Read/write Long.

Remarks

The default value of the TableDirection property is ppDirectionLefttToRight unless the LanguageSettings property or the DefaultLanguageID property is set to a right-to-left language, in which case the default value is ppDirectionRightToLeft. The ppDirectionMixed constant may be returned when using the TextDirection property.


Beispiel zur TableDirection-Eigenschaft

This example sets the direction in which cells in the selected table are ordered to left to right (first column is the leftmost column).

ActiveWindow.Selection.ShapeRange.Table.TableDirection = _
    ppDirectionLeftToRight


TabStops-Eigenschaft

Gibt eine TabStops-Auflistung zurück, die die Tabstops für den angegebenen Text darstellt. Nur-Lese-Zugriff.


Beispiel zur TabStops-Eigenschaft

In diesem Beispiel wird der aktiven Präsentation eine Folie mit zwei Textspalten hinzugefügt, ein linksbündiger Tabstopp für den Titel der neuen Folie festgelegt und das Titelfeld linksbündig ausgerichtet. Außerdem wird dem Titel unter Verwendung des soeben erstellten Tabstopps Text zugewiesen.

With Application.ActivePresentation.Slides _
        .Add(2, ppLayoutTwoColumnText).Shapes
    With .Title.TextFrame
        With .Ruler
            .Levels(1).FirstMargin = 0
            .TabStops.Add ppTabStopLeft, 310
        End With
        .TextRange.ParagraphFormat.Alignment = ppAlignLeft
        .TextRange = "first column" + Chr(9) + "second column"
    End With
End With


Tags-Eigenschaft

Gibt ein Tags-Objekt zurück, das die Marken für das angegebene Objekt darstellt. Nur-Lese-Zugriff.


Beispiel zur Tags-Eigenschaft

Anmerkung Markenwerte werden als Großbuchstaben hinzugefügt und gespeichert. Es empfiehlt sich, bei der Abfrage der Werte von Marken auf Großbuchstaben hin zu überprüfen, wie im zweiten Beispiel erläutert.

In diesem Beispiel wird eine Marke mit dem Namen "REGION" und eine Marke mit dem Namen "PRIORITY" zur Folie 1 der aktiven Präsentation hinzugefügt.

With Application.ActivePresentation.Slides(1).Tags
    .Add "Region", "East"     'Adds "Region" tag with value "East"
    .Add "Priority", "Low"    'Adds "Priority" tag with value "Low"
End With

In diesem Beispiel werden die Marken jeder Folie der aktiven Präsentation durchsucht. Wird die Marke "PRIORITY" gefunden, wird der Markenwert in einem Meldungsfeld angezeigt. Enthält das Objekt keine Marke "PRIORITY", wird diese Marke mit dem Wert "Unknown" hinzugefügt.

For Each s In Application.ActivePresentation.Slides
    With s.Tags
        found = False
        For i = 1 To .Count
          If .Name(i) = "PRIORITY" Then
              found = True
              slNum = .Parent.SlideIndex
              MsgBox "Slide " & slNum & " Priority: " & .Value(i)
          End If
        Next
        If Not found Then
          slNum = .Parent.SlideIndex
          .Add "Priority", "Unknown"
          MsgBox "Slide " & slNum & " Priority tag added: Unknown"
        End If
    End With
Next


TemplateName-Eigenschaft

Gibt den Namen der Präsentationsvorlage zurück, die zur angegebenen Präsentation gehört. String Nur-Lese-Zugriff.

Anmerkungen

Die zurückgegebene Zeichenfolge enthält die MS-DOS-Dateinamenerweiterung (für registrierte Dateitypen), jedoch nicht den vollständigen Pfad.


Beispiel zur TemplateName-Eigenschaft

Im folgenden Beispiel wird die Präsentationsvorlage Professional.pot der Präsentation Pres1.ppt zugeordnet (sofern dies nicht bereits geschehen ist).

With Presentations("Pres1.ppt")
    If .TemplateName <> "Professional.pot" Then
        .ApplyTemplate "c:\program files\microsoft office" & _
            "\templates\presentation designs\Professional.pot"
    End If
End With


Text-Eigenschaft

HeaderFooter-, TextEffectFormat- oder TextRange-Objekt: Gibt den Text zurück, der im angegebenen Objekt enthalten ist, oder legt diesen fest. String Schreib-Lese-Zugriff.


TextDirection-Eigenschaft

Sprachspezifische Informationen.

Returns or sets the text direction for the specified paragraph. Can be one of the following PpDirection constants: ppDirectionLeftToRight, ppDirectionMixed, or ppDirectionRightToLeft. The default value depends on the language support you have selected or installed. Read/write Long.


Beispiel zur TextDirection-Eigenschaft

In diesem Beispiel wird die Textrichtung der Absätze von Form 2 in Folie 1 der aktiven Präsentation angezeigt.

MsgBox ActivePresentation.Slides(1).Shapes(2).TextFrame.TextRange _
    .ParagraphFormat.TextDirection


TextEffect-Eigenschaft

Gibt ein TextEffectFormat-Objekt zurück, das Formateigenschaften für Texteffekte der angegebenen Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die WordArt darstellen. Nur-Lese-Zugriff.


Beispiel zur TextEffect-Eigenschaft

Dieses Beispiel legt die Stilart Fett für Form 3 in myDocument fest, wenn es sich bei der Form um WordArt handelt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


TextFrame-Eigenschaft

Gibt ein TextFrame-Objekt zurück, das die Ausrichtung und Verankerungseigenschaften für die angegebene Form oder den Master-Textstil enthält.

Anmerkungen

Mit der TextRange-Eigenschaft des TextFrame-Objekts können Sie den Text im Textrahmen zurückgeben.

Verwenden Sie die HasTextFrame-Eigenschaft, um festzulegen, ob die Form einen Textrahmen enthalten soll, bevor Sie die TextFrame-Eigenschaft anwenden


Beispiel zur TextFrame-Eigenschaft

Dieses Beispiel fügt zu myDocument ein Rechteck hinzu, fügt dem Rechteck Text hinzu und legt den oberen Rand für den Textrahmen fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes _
        .AddShape(msoShapeRectangle, 180, 175, 350, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginTop = 10
End With


TextLevelEffect-Eigenschaft

Gibt einen Wert zurück, der anzeigt, ob der Text in der angegebenen Form von Absätzen der ersten bzw. einer anderen Ebene (bis zu Absätzen der fünften Ebene) animiert wird, oder legt diesen Wert fest. Dies kann eine der folgenden PpTextLevelEffect-Konstanten sein: ppAnimateByAllLevels, ppAnimateByFifthLevel, ppAnimateByFirstLevel, ppAnimateByFourthLevel, ppAnimateBySecondLevel, ppAnimateByThirdLevel, ppAnimateLevelMixed oder ppAnimateLevelNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Damit die Einstellung für die TextLevelEffect-Eigenschaft ausgeführt werden kann, muss für die Animate-Eigenschaft True gelten.


Beispiel zur TextLevelEffect-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation eine Titelfolie und Titeltext hinzu und legt fest, dass der Titel Buchstabe für Buchstabe aufgebaut wird.

With ActivePresentation.Slides.Add(1, ppLayoutTitleOnly).Shapes(1)
    .TextFrame.TextRange.Text = "Sample title"
    With .AnimationSettings
        .Animate = True
        .TextLevelEffect = ppAnimateByFirstLevel
        .TextUnitEffect = ppAnimateByCharacter
        .EntryEffect = ppEffectFlyFromLeft
    End With
End With


TextRange-Eigenschaft

Selection-Objekt: Gibt ein TextRange-Objekt zurück, das den markierten Text darstellt. Nur-Lese-Zugriff.

TextFrame-Objekt: Gibt ein TextRange-Objekt zurück, das den Text im angegebenen Textrahmen darstellt. Nur-Lese-Zugriff.

Anmerkungen

Sie können einen Textbereich von einer Markierung erstellen, wenn sich die Präsentation in der Folienansicht, der Normalansicht, der Gliederungsansicht, der Notizseitenansicht oder einer beliebigen Masteransicht befindet.


Beispiel zur TextRange-Eigenschaft

Dieses Beispiel zeichnet den markierten Text in Fenster 1 fett aus.

Windows(1).Selection.TextRange.Font.Bold = True


TextStyles-Eigenschaft

Gibt eine TextStyles-Auflistung zurück, die drei Textformate – Titeltext, Textkörper und Standardtext – für den angegebenen Folienmaster darstellt. Nur-Lese-Zugriff.

Informationen über die Rückgabe einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TextStyles-Eigenschaft

Dieses Beispiel legt die Schriftart und den Schriftgrad für Textkörper der ersten Ebene in den Folien der aktiven Präsentation fest.

With ActivePresentation.SlideMaster_
        .TextStyles(ppBodyStyle).Levels(1)
    With .Font
        .Name = "arial"
        .Size = 36
    End With
End With


TextToDisplay-Eigenschaft

Gibt den Anzeigetext für einen keiner Grafik zugewiesenen Hyperlink zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft verursacht einen Laufzeitfehler, wenn sie mit einem Hyperlink verwendet wird, der keinem Textbereich zugewiesen ist. Sie können Code wie den folgenden verwenden, um zu prüfen, ob ein gegebener Hyperlink, hier durch myHyperlink dargestellt, einem Textbereich zugewiesen ist.

If TypeName(myHyperlink.Parent.Parent) = "TextRange" Then
    strTRtest = "True"
End If


Beispiel zur TextToDisplay-Eigenschaft

In diesem Beispiel wird ein dem Text in Form 2 auf Folie 1 zugewiesener Hyperlink erstellt. Dann wird der Anzeigetext als "Microsoft Homepage" festgelegt und die Hyperlinkadresse auf den richtigen URL eingestellt.

With ActivePresentation.Slides(1).Shapes(2) _
        .TextFrame.TextRange
    With .ActionSettings(ppMouseClick)
        .Action = ppActionHyperlink
        .Hyperlink.TextToDisplay = "Microsoft Homepage"
        .Hyperlink.Address = "http://www.microsoft.com/"
    End With
End With


TextUnitEffect-Eigenschaft

Gibt einen Wert zurück, der anzeigt, ob der Text in der angegebenen Form absatzweise, wortweise oder Buchstabe für Buchstabe animiert wird, oder legt diesen Wert fest. Dies kann einer der folgenden TextUnitEffect-Werte sein: ppAnimateByCharacter, ppAnimateByParagraph, ppAnimateByWord oder ppAnimateUnitMixed. Long Schreib-Lese-Zugriff.

Anmerkungen

Damit die Einstellung der TextUnitEffect-Eigenschaft ausgeführt wird, muss die TextLevelEffect-Eigenschaft für die angegebene Form einen anderen Wert als ppAnimateLevelNone oder ppAnimateByAllLevels haben. Außerdem muss für die Animate-Eigenschaft True festgelegt sein.


Beispiel zur TextUnitEffect-Eigenschaft

Dieses Beispiel fügt der aktiven Präsentation eine Titelfolie und Titeltext hinzu und legt fest, dass der Titel Buchstabe für Buchstabe aufgebaut wird.

With ActivePresentation.Slides.Add(1, ppLayoutTitleOnly).Shapes(1)
    .TextFrame.TextRange.Text = "Sample title"
    With .AnimationSettings
        .Animate = True
        .TextLevelEffect = ppAnimateByFirstLevel
        .TextUnitEffect = ppAnimateByCharacter
        .EntryEffect = ppEffectFlyFromLeft
    End With
End With


TextureName-Eigenschaft

Gibt den Namen der benutzerdefinierten Strukturdatei für die angegebene Füllung zurück. String Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der UserTextured-Methode können Sie die Strukturdatei für die Füllung festlegen.


Beispiel zur TextureName-Eigenschaft

Dieses Beispiel fügt zu myDocument ein Oval hinzu. Hat Form 1 in myDocument eine benutzerdefinierte strukturierte Füllung, wird dem neuen Oval die gleiche Füllung zugewiesen. Hat Form 1 einen anderen Füllungstyp, erhält das Oval die strukturierte Füllung Grüner Marmor.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    Set newFill = .AddShape(msoShapeOval, 0, 0, 200, 90).Fill
    With .Item(1).Fill
        If .Type = msoFillTextured And _
                .TextureType = msoTextureUserDefined Then
            newFill.UserTextured .TextureName
        Else
            newFill.PresetTextured msoTextureGreenMarble
        End If
    End With
End With


TextureType-Eigenschaft

Gibt den Strukturtyp für die angegebene Füllung zurück. Dies kann eine der folgenden MsoTextureType-Konstanten sein: msoTexturePreset, msoTextureTypeMixed oder msoTextureUserDefined. Long Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Mit der PresetTextured- oder der UserTextured-Methode können Sie den Strukturtyp für die Füllung festlegen.


Beispiel zur TextureType-Eigenschaft

Dieses Beispiel weist allen Formen in myDocument, die eine benutzerdefinierte strukturierte Füllung haben, die Füllung Leinen hinzu.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    With s.Fill
        If .TextureType = msoTextureUserDefined Then
            .PresetTextured msoTextureCanvas
        End If
    End With
Next


ThreeD-Eigenschaft

Gibt ein ThreeDFormat-Objekt zurück, das Formateigenschaften von 3D-Effekten für die angegebene Form enthält. Nur-Lese-Zugriff.


Beispiel zur ThreeD-Eigenschaft

Dieses Beispiel legt die Tiefe, Projektionsfarbe, Projektionsrichtung und Beleuchtungsrichtung für die 3D-Effekte fest, die für Form 1 von myDocument zugewiesen wurden.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .Depth = 50
    'RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


Title-Eigenschaft

Gibt ein Shape-Objekt zurück, das den Folientitel darstellt. Nur-Lese-Zugriff.

Anmerkungen

Sie können mit der Item-Methode der Shapes- oder Placeholders-Auflistung den Folientitel auch zurückgeben.


TitleMaster-Eigenschaft

Gibt ein Master-Objekt zurück, das den Titelmaster der angegebenen Präsentation darstellt. Hat die Präsentation keinen Titelmaster, tritt ein Fehler auf. Nur-Lese-Zugriff.

Anmerkungen

Verwenden Sie die AddTitleMaster-Methode, um einer Präsentation einen Titelmaster hinzuzufügen.


Beispiel zur TitleMaster-Eigenschaft

Wenn die aktive Präsentation einen Titelmaster hat, wird in diesem Beispiel der Fußnotentext für den Titelmaster festgelegt.

With Application.ActivePresentation
    If .HasTitleMaster Then
        .TitleMaster.HeadersFooters.Footer.Text = "Introduction"
    End If
End With


Top-Eigenschaft

Gibt die oberste Position des Objekts in Punkt zurück oder legt diese fest. (Siehe nachfolgende Tabelle.) Single Schreib-Lese-Zugriff.

Objekt | Bedeutung
Application, SlideShowWindow | Der Abstand von der Oberseite des Fensters der Anwendung oder Bildschirmpräsentation zur Oberseite des Desktops. Wenn Sie für diese Eigenschaft einen hohen positiven oder negativen Wert festlegen, kann das Fenster vollständig außerhalb des Desktops liegen.
DocumentWindow | Der Abstand von der Oberseite des Dokumentfensters zur Oberseite des Clientbereichs des Anwendungsfensters.
Shape | Der Abstand von der Oberseite des Begrenzungsrechtecks der Form zur Oberseite des Dokuments.
ShapeRange | Der Abstand von der Oberseite der obersten Form im Formbereich zur linken Seite des Dokuments.


Beispiel zur Top-Eigenschaft

Dieses Beispiel ordnet die Fenster 1 und 2 horizontal an. Dies bedeutet, jedes Fenster belegt die Hälfte der verfügbaren vertikalen sowie die gesamte verfügbare horizontale Fläche des Clientbereichs des Anwendungsfensters. Damit dieses Beispiel funktioniert, dürfen nur zwei Dokumentfenster geöffnet sein.

Windows.Arrange ppArrangeTiled
ah = Windows(1).Height                      ' available height
aw = Windows(1).Width + Windows(2).Width    ' available width
With Windows(1)
    .Width = aw
    .Height = ah / 2
    .Left = 0
End With
With Windows(2)
    .Width = aw
    .Height = ah / 2
    .Top = ah / 2
    .Left = 0
End With


Tracking-Eigenschaft

Gibt das Verhältnis des horizontalen Zeichenabstands zurück, das jedem Zeichen in der angegebenen WordArt relativ zur Zeichenbreite zugewiesen wird, oder legt dieses Verhältnis fest. Es kann sich dabei um einen Wert zwischen 0 (null) und 5 handeln. (Hohe Werte geben einen weiten Zeichenabstand an. Werte kleiner 1 können überlappende Zeichen erzeugen.) Single Schreib-Lese-Zugriff.

Die folgende Tabelle gibt die Werte der Tracking-Eigenschaft an, die den Einstellungen entsprechen, die in der Benutzeroberfläche verfügbar sind.

Einstellungen der Benutzeroberfläche | Entsprechender Wert der Tracking-Eigenschaft
Sehr genau | 0.8
Genau | 0.9
Standard | 1.0
Ungenau | 1.2
Sehr ungenau | 1.5


Beispiel zur Tracking-Eigenschaft

Dieses Beispiel fügt WordArt zu myDocument hinzu, das den Text "Test" enthält. Es wird ein sehr genauer Abstand für die Zeichen angegeben.

Set myDocument = ActivePresentation.Slides(1)
Set newWordArt = myDocument.Shapes.AddTextEffect _
    (PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=100, Top:=100)
newWordArt.TextEffect.Tracking =0.8


Transparency-Eigenschaft

Gibt den Grad der Transparenz für die angegebene Füllung, den Schatten oder die Linie als Wert zurück, der im Bereich zwischen 0.0 (undurchsichtig) und 1.0 (durchsichtig) liegen kann, oder legt diesen Wert fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Der Wert dieser Eigenschaft verändert nur einfarbige Füllungen und Linien; er hat keine Auswirkungen auf gestrichelte Linien oder die Fülleffekte "Fließend", "Struktur", "Grafik" und "Muster".


 TransparencyColor-Eigenschaft

TransparencyColor-Eigenschaft

Gibt die transparente Farbe für die angegebene Grafik als Rot-Grün-Blau-Wert zurück oder legt diesen Wert fest. Damit diese Eigenschaft funktioniert, muss für die TransparentBackground-Eigenschaft True gelten. Gilt nur für Bitmaps. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die Objekte hinter der Grafik durch die transparenten Teile der Grafik nicht verdeckt werden sollen, muss für die Visible-Eigenschaft des FillFormat-Objekts der Grafik False festgelegt werden. Enthält Ihre Grafik eine transparente Farbe und gilt für die Visible-Eigenschaft des FillFormat-Objekts der Grafik True, wird zwar die Grafikfüllung durch die transparente Farbe sichtbar, die Objekte hinter der Grafik bleiben jedoch verdeckt.


Beispiel zur TransparencyColor-Eigenschaft

Dieses Beispiel legt die Farbe, die von der Funktion RGB(0, 0, 255) zurückgegeben wird, als die transparente Farbe für Form 1 in myDocument fest. Damit dieses Beispiel funktioniert, muss Form 1 ein Bitmap sein.

blueScreen = RGB(0, 0, 255)
Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


TransparentBackground-Eigenschaft

True, wenn diejenigen Teile der Grafik transparent erscheinen, deren Farbe als transparente Farbe definiert wurde. Mit der TransparencyColor-Eigenschaft können Sie die transparente Farbe festlegen. Dies gilt nur für Bitmaps. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die Objekte hinter der Grafik durch die transparenten Teile der Grafik nicht verdeckt werden sollen, muss für die Visible-Eigenschaft des FillFormat-Objekts der Grafik False festgelegt werden. Enthält Ihre Grafik eine transparente Farbe und gilt für die Visible-Eigenschaft des FillFormat-Objekts der Grafik True, wird zwar die Grafikfüllung durch die transparente Farbe sichtbar, die Objekte hinter der Grafik bleiben jedoch verdeckt.


Beispiel zur TransparentBackground-Eigenschaft

Dieses Beispiel legt die Farbe, die von der Funktion RGB(0, 24, 240) zurückgegeben wird, als die transparente Farbe für Form 1 in myDocument fest. Damit dieses Beispiel funktioniert, muss Form 1 ein Bitmap sein.

blueScreen = RGB(0, 0, 255)
Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


Type-Eigenschaft

Gibt den Objekttyp zurück und legt diesen bei einigen Objekten fest. Die folgende Tabelle listet sowohl alle Objekte auf, denen die Type-Eigenschaft zugewiesen werden kann, als auch alle möglichen Werte für die Type-Eigenschaft von jedem dieser Objekte.

Object | Details der Type-Eigenschaft
BulletFormat | Dies kann eine der folgenden PpBulletType-Konstanten sein: ppBulletMixed, ppBulletNone, ppBulletNumbered, ppBulletPicture oder ppBulletUnnumbered. Long Schreib-Lese-Zugriff.
CalloutFormat | Dies kann eine der folgenden MsoCalloutType-Konstanten sein: msoCalloutFour, msoCalloutMixed, msoCalloutOne, msoCalloutThree oder msoCalloutTwo. Long Schreib-Lese-Zugriff.
ColorFormat | Dies kann eine der folgenden MsoColorType-Konstanten sein: msoColorTypeMixed, msoColorTypeRGB oder msoColorTypeScheme. Long Nur-Lese-Zugriff.
ConnectorFormat | Dies kann eine der folgenden MsoConnectorType-Konstanten sein: msoConnectorCurve, msoConnectorElbow, msoConnectorStraight oder msoConnectorTypeMixed. Long Schreib-Lese-Zugriff.
FillFormat | Dies kann eine der folgenden MsoFillType-Konstanten sein: msoFillBackground, msoFillGradient, msoFillMixed, msoFillPatterned, msoFillPicture, msoFillSolid oder msoFillTextured. Long Nur-Lese-Zugriff.
Hyperlink | Dies kann eine der folgenden MsoHyperlinkType-Konstanten sein: msoHyperlinkInlineShape (wird nur in Microsoft Word verwendet), msoHyperlinkRange oder msoHyperlinkShape. Long Nur-Lese-Zugriff.
PlaceholderFormat | Dies kann eine der folgenden PpPlaceholderType-Konstanten sein: ppPlaceholderBitmap, ppPlaceholderBody, ppPlaceholderCenterTitle, ppPlaceholderChart, ppPlaceholderDate, ppPlaceholderFooter, ppPlaceholderHeader, ppPlaceholderMediaClip, ppPlaceholderMixed, ppPlaceholderObject, ppPlaceholderOrgChart, ppPlaceholderSlideNumber, ppPlaceholderSubtitle, ppPlaceholderTable, ppPlaceholderTitle, ppPlaceholderVerticalBody oder ppPlaceholderVerticalTitle
Selection | Dies kann eine der folgenden PpSelectionType-Konstanten sein: ppSelectionNone, ppSelectionShapes, ppSelectionSlides oder ppSelectionText. Long Nur-Lese-Zugriff.
ShadowFormat | Dies kann eine der folgenden MsoShadowType-Konstanten sein: msoShadow1, msoShadow10, msoShadow11, msoShadow12, msoShadow13, msoShadow14, msoShadow15, msoShadow16, msoShadow17, msoShadow18, msoShadow19, msoShadow2, msoShadow20, msoShadow3, msoShadow4, msoShadow5, msoShadow6, msoShadow7, msoShadow8, msoShadow9 oder msoShadowMixed. Long Schreib-Lese-Zugriff.
Shape oder ShapeRange | Dies kann eine der folgenden MsoShapeType-Konstanten sein: msoAutoShape, msoCallout, msoChart, msoComment, msoEmbeddedOLEObject, msoFormControl, msoFreeform, msoGroup, msoLine, msoLinkedOLEObject, msoLinkedPicture, msoMedia, msoOLEControlObject, msoPicture, msoPlaceholder, msoScriptAnchor, msoShapeTypeMixed, msoTable, msoTextBox oder msoTextEffect. Long Nur-Lese-Zugriff.
SoundEffect | Dies kann eine der folgenden PpSoundEffectType-Konstanten sein: ppSoundEffectsMixed, ppSoundFile, ppSoundNone oder ppSoundStopPrevious. Long Schreib-Lese-Zugriff.
TabStop | Dies kann eine der folgenden PpTabStopType-Konstanten sein: ppTabStopCenter, ppTabStopDecimal, ppTabStopLeft, ppTabStopMixed oder ppTabStopRight. Long Schreib-Lese-Zugriff.
View | Dies kann eine der folgenden PpViewType-Konstanten sein: ppViewHandoutMaster, ppViewNormal, ppViewNotesMaster, ppViewNotesPage, ppViewOutline, ppViewSlide, ppViewSlideMaster, ppViewSlideSorter oder ppViewTitleMaster. Long Nur-Lese-Zugriff.


Beispiel zur Type-Eigenschaft

Dieses Beispiel durchläuft alle Formen von allen Folien in der aktiven Präsentation und legt für alle verknüpften Microsoft Excel-Tabellenblätter fest, dass sie manuell aktualisiert werden.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            If sh.OLEFormat.ProgID = "Excel.Sheet" Then
                sh.LinkFormat.AutoUpdate = ppUpdateOptionManual
            End If
        End If
    Next
Next


Underline-Eigenschaft

Font-Objekt: True, wenn der angegebene Text unterstrichen, False, wenn der Text nicht unterstrichen ist, msoTriStateMixed, wenn einige Zeichen im Text unterstrichen sind. Long Schreib-Lese-Zugriff.

FontInfo-Objekt: True, wenn der Schriftschnitt unterstrichen ist. Long Nur-Lese-Zugriff.


Beispiel zur Underline-Eigenschaft

In diesem Beispiel wird die Formatierung für den Text in Form 2 von Folie 1 der aktiven Präsentation festgelegt.

With Application.ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.Font
        .Size = 32
        .Name = "Palatino"
        .Underline = True
    End With
End With


UpdateLinksOnSave-Eigenschaft

True, wenn Hyperlinks und Pfade zu allen Hilfsdateien automatisch aktualisiert werden, bevor Sie die Präsentation als Webseite speichern oder veröffentlichen. Dadurch wird sichergestellt, dass die Verknüpfungen zum Zeitpunkt des Speicherns der Präsentation aktuell sind. False, wenn die Verknüpfungen nicht aktualisiert werden. Der Standardwert ist True. Long Schreib-Lese-Zugriff.

Hinweise

Setzen Sie diese Eigenschaft auf False, wenn der Speicherort der Präsentation sich vom endgültigen Ort auf dem Webserver unterscheidet und die Hilfsdateien am ursprünglichen Ort nicht verfügbar sind.


Beispiel zur UpdateLinksOnSave-Eigenschaft

In diesem Beispiel wird festgelegt, dass Verknüpfungen vor dem Speichern der Präsentation nicht aktualisiert werden.

Application.DefaultWebOptions.UpdateLinksOnSave = False


UseFormat-Eigenschaft

True, wenn das Objekt für Datum und Uhrzeit automatisch aktualisierte Informationen enthält, False, wenn es sich bei Datum und Uhrzeit um eine feststehende Zeichenfolge handelt. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird nur einem HeaderFooter-Objekt zugewiesen, das Datum und Uhrzeit darstellt (das von der DateAndTime-Eigenschaft zurückgegeben wird). Legen Sie für die UseFormat-Eigenschaft eines HeaderFooter-Objekts für Datum und Uhrzeit True fest, wenn das Format für Datum und Uhrzeit mit der Format-Eigenschaft festgelegt oder zurückgegeben werden soll. Legen Sie für die UseFormat-Eigenschaft False fest, wenn die Text-Zeichenfolge für das feststehende Datum und die Uhrzeit festgelegt oder zurückgegeben werden soll.


Beispiel zur UseFormat-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Datum und die Uhrzeit für den Folienmaster der aktiven Präsentation automatisch aktualisiert werden. Anschließend wird das Format für das Datum und die Uhrzeit so festgelegt, dass Stunden, Minuten und Sekunden angezeigt werden.

Set myPres = Application.ActivePresentation
With myPres.SlideMaster.HeadersFooters.DateAndTime
    .UseFormat = True
    .Format = ppDateTimeHmmss
End With


UseLongFileNames-Eigenschaft

True, wenn Sie eine vollständige Präsentation oder Teile einer Präsentation als Webseite speichern oder veröffentlichen und dabei lange Dateinamen verwendet werden. False, wenn keine langen Dateinamen verwendet werden und das DOS-Format für Dateinamen (8.3) verwendet wird. Der Standardwert ist True. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie keine langen Dateinamen verwenden und Ihre Präsentation über Hilfsdateien verfügt, speichert Microsoft PowerPoint diese Dateien automatisch in einem eigenen Ordner. Andernfalls können Sie mit der OrganizeInFolder-Eigenschaft festlegen, ob Hilfsdateien in einem eigenen Ordner gespeichert werden.


Beispiel zur UseLongFileNames-Eigenschaft

In diesem Beispiel wird die Verwendung langer Dateinamen als globale Standardeinstellung der Anwendung untersagt.

Application.DefaultWebOptions.UseLongFileNames = False


UseTextColor-Eigenschaft

True, wenn für die angegebenen Aufzählungszeichen die Farbe des ersten Textzeichens im Absatz festgelegt wird. False, wenn für die angegebenen Aufzählungszeichen eine andere Farbe festgelegt wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Für diese Eigenschaft kann False nicht explizit festgelegt werden. Wenn Sie die Farbe der Aufzählungszeichen (mit der Color-Eigenschaft des Font-Objekts) festlegen, gilt für diese Eigenschaft False. Wenn False für UseTextColor gilt, können Sie True festlegen, damit für das Format der Aufzählungszeichen die Standardfarbe gilt.


Beispiel zur UseTextColor-Eigenschaft

In diesem Beispiel werden die Aufzählungszeichen von Form 2 in Folie 1 der aktiven Präsentation auf die Standardwerte für die Zeichen, Schriftart und Farbe zurückgesetzt.

With ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat.Bullet
        .RelativeSize = 1
        .UseTextColor = True
        .UseTextFont = True
        .Character = 8226
    End With
End With


UseTextFont-Eigenschaft

True, wenn für die angegebenen Aufzählungszeichen die Schriftart des ersten Textzeichens im Absatz festgelegt wird. False, wenn für die angegebenen Aufzählungszeichen eine benutzerdefinierte Schriftart festgelegt wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Für diese Eigenschaft kann False nicht explizit festgelegt werden. Wenn Sie die Farbe der Aufzählungszeichen (mit der Name-Eigenschaft des Font-Objekts) festlegen, gilt für diese Eigenschaft False. Wenn False für UseTextFont gilt, können Sie True festlegen, damit für das Format der Aufzählungszeichen die Standardschriftart gilt.


Beispiel zur UseTextFont-Eigenschaft

In diesem Beispiel werden die Aufzählungszeichen von Form 2 in Folie 1 der aktiven Präsentation auf die Standardwerte für die Zeichen, Schriftart und Farbe zurückgesetzt.

With ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat.Bullet
        .RelativeSize = 1
        .UseTextColor = True
        .UseTextFont = True
        .Character = 8226
    End With
End With


VBASigned-Eigenschaft

True, wenn das Projekt in Visual Basic für Applikationen für das angegebene Dokument mit einer digitalen Signatur versehen ist. Boolean Nur-Lese-Zugriff.


Beispiel zur VBASigned-Eigenschaft

In diesem Beispiel wird eine Präsentation mit dem Namen MyPres.ppt geladen und geprüft, ob sie eine digitale Signatur enthält. Wenn keine digitale Signatur vorhanden ist, gibt der Code eine Warnmeldung aus.

Presentations.Open FileName:="c:\My Documents\MyPres.ppt", _
    ReadOnly:=False, WithWindow:=msoTrue
With ActivePresentation
    If .VBASigned = False And _
           .VBProject.VBComponents.Count > 0 Then
       MsgBox "Warning! The Visual Basic project for" _
           & vbCrLf & "this presentation has not" _
           & vbCrLf & " been digitally signed." _
           , vbCritical, "Digital Signature Warning"
    End If
End With


VBE-Eigenschaft

Gibt ein VBE-Objekt zurück, das den Visual Basic-Editor darstellt. Nur-Lese-Zugriff.


Beispiel zur VBE-Eigenschaft

In diesem Beispiel wird der Name des aktiven Projekts im Visual Basic-Editor festgelegt.

Application.VBE.ActiveVBProject.Name = "TestProject"


VBProject-Eigenschaft

Gibt ein VBProject-Objekt zurück, das das individuelle Visual Basic-Projekt für die Präsentation darstellt. Nur-Lese-Zugriff.


Beispiel zur VBProject-Eigenschaft

Dieses Beispiel ändert den Namen des Visual Basic-Projekts der aktiven Präsentation.

ActivePresentation.VBProject.Name = "TestProject"


Version-Eigenschaft

Gibt die Versionsnummer von PowerPoint zurück. String Nur-Lese-Zugriff.


Beispiel zur Version-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die Versions- und Build-Nummer von PowerPoint sowie den Namen des Betriebssystems enthält.

With Application
MsgBox "Welcome to PowerPoint version " & .Version & _
    ", build " & .Build & ", running on " & .OperatingSystem & "!"
End With


VerticalAnchor-Eigenschaft

Gibt die vertikale Ausrichtung von Text in einem Textrahmen zurück oder legt diesen fest. Dies kann eine der folgenden MsoVerticalAnchor-Konstanten sein: msoAnchorBottom, msoAnchorBottomBaseLine, msoAnchorMiddle, msoAnchorTop, msoAnchorTopBaseLine oder msoVerticalAnchorMixed. Long Schreib-Lese-Zugriff.

Hinweise

Die Konstanten msoAnchorBottomBaseLine und msoAnchorTopBaseLine werden zum Verankern des unteren Randes der Zeichenfolge an der aktuellen Position verwendet unabhängig von einer Größenänderung des Textes. Wenn Sie die Größe des Textes ohne Verankerung der Grundlinie ändern, wird der Text an seiner vorigen Position zentriert.

Für die msoVerticalAnchorMixed-Konstante gilt der Nur-Lese-Zugriff. Diese Konstante wird zurückgegeben, wenn diese Eigenschaft für mindestens zwei Textfelder innerhalb eines Formbereichs auf unterschiedliche Werte gesetzt wurde.


Beispiel zur VerticalAnchor-Eigenschaft

In diesem Beispiel wird die Ausrichtung des Textes in Form 1 in myDocument auf oben zentriert festgelegt.

Set myDocument = ActivePresentation.SlideMaster
With myDocument.Shapes(1)
    .TextFrame.HorizontalAnchor = msoAnchorCenter
    .TextFrame.VerticalAnchor = msoAnchorTop
End With


VerticalFlip-Eigenschaft

True, wenn die angegebene Form um die vertikale Achse gekippt wird. Long Nur-Lese-Zugriff.


Beispiel zur VerticalFlip-Eigenschaft

Dieses Beispiel stellt bei horizontal oder vertikal gekippten Formen von myDocument den Originalzustand wieder her.

Set myDocument = ActivePresentation.Slides(1)
For Each s In myDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


 Vertices-Eigenschaft

Vertices-Eigenschaft

Gibt die Koordinaten der angegebenen Scheitelpunkte (und Kontrollpunkte bei Bézierkurven) der Freihandfigur als Datenreihe von Koordinatenpaaren zurück. Sie können die von dieser Eigenschaft zurückgegebene Matrix als Argument für die AddCurve-Methode oder die AddPolyline-Methode verwenden. Variant Nur-Lese-Zugriff.

Die folgende Tabelle zeigt, wie die Vertices-Eigenschaft die Werte in der Matrix VertArray() den Koordinaten der Scheitelpunkte eines Dreiecks zuordnet.

VertArray-Element | Enthält
VertArray(1, 1) | Der horizontale Abstand vom ersten Scheitelpunkt zur linken Seite der Folie
VertArray(1, 2) | Der vertikale Abstand vom ersten Scheitelpunkt zur Oberseite der Folie
VertArray(2, 1) | Der horizontale Abstand vom zweiten Scheitelpunkt zur linken Seite der Folie
VertArray(2, 2) | Der vertikale Abstand vom zweiten Scheitelpunkt zur Oberseite der Folie
VertArray(3, 1) | Der horizontale Abstand vom dritten Scheitelpunkt zur linken Seite der Folie
VertArray(3, 2) | Der vertikale Abstand vom dritten Scheitelpunkt zur Oberseite der Folie


Beispiel zur Vertices-Eigenschaft

In diesem Beispiel werden die Koordinaten der Scheitelpunkte für Form 1 in myDocument der Matrixvariablen vertArray() zugewiesen und die Koordinaten für den ersten Scheitelpunkt angezeigt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1)
    vertArray = .Vertices
    x1 = vertArray(1, 1)
    y1 = vertArray(1, 2)
    MsgBox "First vertex coordinates: " & x1 & ", " & y1
End With

Dieses Beispiel erstellt eine Kurve, die dieselbe geometrische Beschreibung wie Form 1 in myDocument aufweist. Damit dieses Beispiel erfolgreich ausgeführt werden kann, muss Form 1 3n+1 Scheitelpunkte aufweisen.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddCurve .Item(1).Vertices
End With


View-Eigenschaft

DocumentWindow-Objekt: Gibt ein View-Objekt zurück, das die Ansicht im angegebenen Dokumentfenster darstellt. Nur-Lese-Zugriff.

SlideShowWindow-Objekt: Gibt ein SlideShowView-Objekt zurück. Nur-Lese-Zugriff.


ViewType-Eigenschaft

DocumentWindow-Objekt: Gibt den Ansichtstyp zurück, der im angegebenen Dokumentfenster enthalten ist, oder legt diesen fest.

Pane-Objekt: In allen Ansichten mit Fensterausschnitten. Gibt den Ansichtstyp des angegebenen Ausschnitts zurück. Wenn auf eine Ansicht ohne Fensterausschnitt verwiesen wird, wird der Ansichtstyp des übergeordneten DocumentWindow-Objekts zurückgegeben.

Dies kann eine der folgenden PpViewType-Konstanten sein: ppViewHandout, ppViewHandoutMaster, ppViewNormal, ppViewNotesMaster, ppViewNotesPage, ppViewOutline, ppViewSlide, ppViewSlideMaster, ppViewSlideSorter oder ppViewTitleMaster. Long Schreib-Lese-Zugriff.


Beispiel zur ViewType-Eigenschaft

In diesem Beispiel wird die Anzeige des aktiven Fensters in den Modus Foliensortieransicht geändert, falls das Fenster im Modus Normalansicht angezeigt wird.

With Application.ActiveWindow
    If .ViewType = ppViewNormal Then
        .ViewType = ppViewSlideSorter
    End If
End With

Wenn sich der aktive Fensterausschnitt in der Folienansicht befindet, wird durch dieses Beispiel das Notizenfeld zum aktiven Ausschnitt. Das Notizenfeld ist das dritte Element der Panes-Auflistung.

With ActiveWindow
    If .ActivePane.ViewType = ppViewSlide Then
        .Panes(3).Activate
    End If
End With


Visible-Eigenschaft

Gibt zurück, ob das angegebene Objekt oder das ihm zugewiesene Format sichtbar ist, oder legt dies fest. True, wenn das angegebene Objekt oder Format des Objekts sichtbar ist. Long Schreib-Lese-Zugriff.


Beispiel zur Visible-Eigenschaft

Dieses Beispiel legt die horizontalen und vertikalen Positionen für den Schatten von Form 3 in der ersten Folie der aktiven Präsentation fest. Der Schatten wird um 5 Punkt nach rechts von der Form und um 3 Punkt darüber versetzt. Wenn für die Form noch kein Schatten festgelegt wurde, fügt dieses Beispiel der Form einen Schatten hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


WebOptions-Eigenschaft

Gibt das WebOptions-Objekt zurück, das Attribute auf Präsentationsebene enthält. Diese werden von Microsoft PowerPoint verwendet, wenn Sie eine vollständige Präsentation oder Teile einer Präsentation als Webseite speichern oder veröffentlichen oder eine Webseite öffnen. Nur-Lese-Zugriff.


Beispiel zur WebOptions-Eigenschaft

In diesem Beispiel wird festgelegt, dass beim Speichern oder Veröffentlichen der aktiven Präsentation als Webseite das PNG-Format (Portable Network Graphics) zulässig ist, die Farbe des Textes im Gliederungsausschnitt weiß ist und die Hintergrundfarbe in den Gliederungs- und Folienausschnitten schwarz ist.

With ActivePresentation.WebOptions
    .FrameColors = ppFrameColorsWhiteTextOnBlack
    .AllowPNG = True
End With


Weight-Eigenschaft

Gibt die Stärke der angegebenen Linie zurück (in Punkt) oder legt diese fest. Single Schreib-Lese-Zugriff.


Beispiel zur Weight-Eigenschaft

Dieses Beispiel fügt zu myDocument eine grüne, gestrichelte Linie mit einer Stärke von 2 Punkt hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(0, 255, 255)
    .Weight = 2
End With


Width-Eigenschaft

Gibt die Breite des angegebenen Objekts in Punkt zurück oder legt diese fest. Single Nur-Lese-Zugriff für das Master-Objekt, Single Schreib-Lese-Zugriff für alle anderen Objekte.


Beispiel zur Width-Eigenschaft

In diesem Beispiel werden die Fenster 1 und 2 horizontal angeordnet. Dies bedeutet, jedes Fenster belegt die Hälfte der verfügbaren vertikalen sowie die gesamte verfügbare horizontale Fläche des Clientbereichs des Anwendungsfensters. Damit dieses Beispiel funktioniert, dürfen nur zwei Dokumentfenster geöffnet sein.

Windows.Arrange ppArrangeTiled
ah = Windows(1).Height                      ' available height
aw = Windows(1).Width + Windows(2).Width    ' available width
With Windows(1)
    .Width = aw
    .Height = ah / 2
    .Left = 0
End With
With Windows(2)
    .Width = aw
    .Height = ah / 2
    .Top = ah / 2
    .Left = 0
End With

In diesem Beispiel wird die Breite für Spalte 1 in der angegebenen Tabelle auf 80 Punkt eingestellt (72 Punkt pro Zoll).

ActivePresentation.Slides(2).Shapes(5).Table.Columns(1).Width = 80


Windows-Eigenschaft

Application-Objekt: Gibt eine DocumentWindows-Auflistung zurück, die alle offenen Dokumentfenster darstellt. Nur-Lese-Zugriff.

Presentation-Objekt: Gibt eine DocumentWindows-Auflistung zurück, die alle zur angegebenen Präsentation gehörigen Dokumentfenster darstellt. Diese Eigenschaft gibt keine Fenster von Bildschirmpräsentationen zurück, die zur Präsentation gehören. Nur-Lese-Zugriff.

Weitere Informationen über das Zurückgeben einzelner Elemente einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


WindowState-Eigenschaft

Gibt den Status des angezeigten Fensters zurück oder legt diesen fest. Dies kann eine der folgenden PpWindowState-Konstanten sein: ppWindowMaximized, ppWindowMinimized, ppWindowMixed oder ppWindowNormal. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn der Status des Fensters ppWindowNormal ist, wird das Fenster weder maximiert noch minimiert.


Beispiel zur WindowState-Eigenschaft

In diesem Beispiel wird das aktive Fenster maximiert.

Application.ActiveWindow.WindowState = ppWindowMaximized


WordWrap-Eigenschaft

TextFrame-Objekt: True, wenn Zeilen durch automatischen Umbruch der Form angepasst werden. Long Schreib-Lese-Zugriff.

ParagraphFormat-Objekt: Wird nur mit Kanji-Zeichen verwendet. Long Schreib-Lese-Zugriff.


Beispiel zur WordWrap-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Rechteck mit Text hinzugefügt und anschließend die Wortumbruchfunktion im neuen Rechteck deaktiviert.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 100, 300).TextFrame
    .TextRange.Text = _
        "Here is some test text that is too long for this box"
    .WordWrap = False
End With


Zoomeigenschaft

SlideShowView-Objekt: Gibt die Zoomeinstellung der Ansicht des angegebenen Bildschirm-Präsentationsfensters als Prozentsatz der Normalgröße zurück. Dies kann ein Wert von 10 bis 400 sein. Long Nur-Lese-Zugriff.

View-Objekt: Gibt die Zoomeinstellung der angegebenen Ansicht als Prozentsatz der Normalgröße zurück oder legt sie fest. Dies kann ein Wert von 10 bis 400 sein. Long Schreib-Lese-Zugriff.


ZoomToFit-Eigenschaft

True, wenn die Zoomeinstellung der Ansicht den Abmessungen des Dokumentfensters angepasst wird, sobald sich die Größe des Dokumentfensters ändert. Diese Eigenschaft gilt nur für die Folienansicht, die Notizenansicht und die Masteransicht. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn der Wert der Zoom-Eigenschaft explizit festgelegt wurde, wird der Wert der ZoomToFit-Eigenschaft automatisch auf False eingestellt.


Beispiel zur ZoomToFit-Eigenschaft

Im folgenden Beispiel wird die Ansicht in Dokumentfenster 1 auf Folienansicht eingestellt, wobei die Zoomeinstellung automatisch an die Abmessungen des Fensters angepasst wird.

With Windows(1)
    .ViewType = ppViewSlide
    .View.ZoomToFit = True
End With


ZOrderPosition-Eigenschaft

Gibt die Position der Z-Reihenfolge der angegebenen Form zurück. Shapes(1) gibt die Position der Form in der hinteren Z-Reihenfolge und Shapes(Shapes.Count) gibt die Position der Form in der vorderen Z-Reihenfolge zurück. Long Nur-Lese-Zugriff.

Diese Eigenschaft hat Nur-Lese-Zugriff. Um die Z-Reihenfolge für die Form festzulegen, verwenden Sie die ZOrder-Methode.

Anmerkungen

Die Z-Reihenfolge einer Form entspricht der Indexnummer in der Shapes-Auflistung. Gibt es auf der Folie z. B. vier Formen, so gibt der Ausdruck myDocument.Shapes(1) die Position der Form in der hinteren Z-Reihenfolge und der Ausdruck myDocument.Shapes(4) die Position der Form in der vorderen Z-Reihenfolge zurück.

Wenn Sie einer Auflistung eine neue Form hinzufügen, wird diese standardmäßig der vorderen Position der Z-Reihenfolge hinzugefügt.


Beispiel zur ZOrderPosition-Eigenschaft

Wenn es mindestens eine andere Form auf der Folie gibt, fügt dieses Beispiel zu myDocument ein Oval hinzu, das an zweiter Stelle der hinteren Position der Z-Reihenfolge platziert wird.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


Context-Eigenschaft

Diese Eigenschaft gibt in Microsoft PowerPoint eine leere Zeichenfolge zurück und wird auf keine andere Weise unterstützt.


Sprachspezifische Informationen

Hilfethemen zu sprachspezifischen Fragen können nur verwendet werden, wenn die sprachspezifische Funktion verfügbar ist. Informieren Sie sich über das Arbeiten in einer anderen Sprache oder die Installation der Korrekturhilfen für eine andere Sprache, oder wenden Sie sich an Ihren Systemadministrator, um weitere Informationen zu erhalten.


Hinzufügen von Steuerelementen zu einem Dokument

Um einem Dokument Steuerelemente hinzuzufügen, rufen Sie die Steuerelement-Toolbox auf und klicken dann erst auf das gewünschte Steuerelement und anschließend auf das Dokument. Ziehen Sie einen Korrekturziehpunkt des Steuerelements, bis die Begrenzungslinien des Steuerelements die gewünschte Größe und Form haben.

Anmerkung Wenn Sie ein Steuerelement (oder eine bestimmte Anzahl "gruppierter" Steuerelemente) aus dem Formular zurück auf die Steuerelement-Toolbox ziehen, wird eine Vorlage des Steuerelements erstellt, die Sie erneut verwenden können. Dadurch haben Sie die Möglichkeit, Ihren Anwendungen ein standardisiertes Erscheinungsbild zu verleihen.


Hinzufügen von Steuerelementen zu einem UserForm

Um einem UserForm Steuerelemente hinzuzufügen, suchen Sie in der Toolbox das Steuerelement, das hinzugefügt werden soll, ziehen Sie das Steuerelement auf das Formular, und ziehen Sie anschließend einen Korrekturziehpunkt des Steuerelements, bis die Begrenzungslinien des Steuerelements die gewünschte Größe und Form haben.

Anmerkung Wenn Sie ein Steuerelement (oder eine bestimmte Anzahl "gruppierter" Steuerelemente) aus dem Formular zurück auf die Toolbox ziehen, wird eine Vorlage des Steuerelements erstellt, die Sie erneut verwenden können. Dadurch haben Sie die Möglichkeit, Ihren Anwendungen ein standardisiertes Erscheinungsbild zu verleihen.

Wenn Sie dem Formular Steuerelemente hinzugefügt haben, können Sie mit den Befehlen im Menü Format im Visual Basic-Editor die Ausrichtung und den Abstand des Steuerelements anpassen.


Ereignisse von Steuerelementen und Dialogfeldern

Nachdem Sie Ihrem Dialogfeld oder Dokument Steuerelemente hinzugefügt haben, können Sie Ereignisprozeduren hinzufügen, um zu bestimmen, wie die Steuerelemente auf Benutzeraktionen reagieren sollen.

UserForms und Steuerelemente haben einen vordefinierten Ereignissatz. So hat z. B. eine Befehlsschaltfläche ein Click-Ereignis, das eintritt, sobald der Benutzer auf die Befehlsschaltfläche klickt. UserForms haben ein Initialize-Ereignis, das eintritt, sobald das Formular geladen wird.

Um Ereignisprozeduren für Steuerelemente oder Formulare zu schreiben, öffnen Sie ein Modul, indem Sie auf das Formular oder das Steuerelement doppelklicken, und markieren Sie das Ereignis im Dropdownlistenfeld Prozedur.

Ereignisprozeduren beinhalten den Namen des Steuerelements. So erhält z. B. die Click-Ereignisprozedur für eine Befehlsschaltfläche mit dem Namen Command1 den Namen Command1_Click.

Wenn Sie Code für eine Ereignisprozedur schreiben und anschließend den Namen des Steuerelements ändern, verbleibt Ihr Code in Prozeduren mit seinem vorherigen Namen.

So können Sie z. B. Code für das Click-Ereignis für Command1 schreiben und anschließend das Steuerelement als Command2 umbenennen. Wenn Sie auf Command2 doppelklicken, wird kein Code in der Click-Ereignisprozedur angezeigt. Sie müssen den Code dann aus Command1_Click nach Command2_Click verschieben.

Um Ihre Arbeit später zu erleichtern, empfiehlt es sich, Ihre Steuerelemente vor dem Verfassen des Codes exakt zu benennen.


Erstellen eines UserForms

Um ein benutzerdefiniertes Dialogfeld zu erstellen, müssen Sie ein UserForm erstellen. Um ein UserForm zu erstellen, klicken Sie im Menü Einfügen im Visual Basic-Editor auf UserForm.

Im Eigenschaftenfenster können Sie den Namen, das Verhalten sowie das Erscheinungsbild des Formulars ändern. Wenn Sie z. B. die Beschriftung auf einem Formular ändern möchten, ändern Sie die Caption-Eigenschaft.


Anzeigen eines benutzerdefinierten Dialogfelds

Um Ihr Dialogfeld im Visual Basic Editor zu testen, klicken Sie im Menü Ausführen des Visual Basic Editor auf Sub/Formular ausführen.

Mit der Show-Methode können Sie ein Dialogfeld von Visual Basic anzeigen. Das folgende Beispiel zeigt das Dialogfeld "UserForm1" an.

Private Sub GetUserName()
    UserForm1.Show
End Sub


Aufrufen von Hilfe zu Macintosh-Stichwörtern

Sie haben die Hilfe zu einem Visual Basic-Stichwort aufgerufen, das nur für den Macintosh Gültigkeit besitzt. Weitere Informationen über dieses Stichwort erhalten Sie in der Sprachverzeichnis-Hilfe, die im Lieferumfang der Microsoft Office 98 Macintosh Edition enthalten ist.


Initialisieren der Eigenschaften von Steuerelementen

Mit Visual Basic-Code in einem Makro können Sie Steuerelemente beim Ausführen des Makros initialisieren. So können Sie z. B. ein Listenfeld mit Werten füllen und Textwerte oder Optionsschaltflächen festlegen.

Im folgenden Beispiel wird die AddItem-Methode verwendet, um Daten in ein Listenfeld einzufügen. Anschließend wird der Wert eines Textfeldes festgelegt und das Formular angezeigt.

Private Sub GetUserName()
    With UserForm1
        .lstRegions.AddItem "North"
        .lstRegions.AddItem "South"
        .lstRegions.AddItem "East"
        .lstRegions.AddItem "West"
        .txtSalesPersonID.Text = "00000"
        .Show
        ' ...
    End With
End Sub

Sie können auch Code im Initialize-Ereignis eines Formulars verwenden, um Startwerte für Steuerelemente des Formulars festzulegen. Der Vorteil dabei liegt darin, dass der Startcode beim Formular verbleibt. So können Sie das Formular in ein anderes Projekt kopieren, und die Steuerelemente werden initialisiert, sobald Sie die Show-Methode aufrufen, um das Dialogfeld anzuzeigen.

Private Sub UserForm_Initialize()
    With UserForm1
        With .lstRegions
           .AddItem "North"
            .AddItem "South"
            .AddItem "East"
            .AddItem "West"
        End With
        .txtSalesPersonID.Text = "00000"
    End With
End Sub


 Zurückgeben eines Objekts aus einer Auflistung

Zurückgeben eines Objekts aus einer Auflistung

Die Item-Methode gibt ein einzelnes Objekt aus einer Auflistung zurück. Im folgenden Beispiel wird die Variable firstPres auf ein Presentation-Objekt gesetzt, das Präsentation 1 darstellt.

Set firstPres = Presentations.Item(1)

Die Item-Methode ist die Standardmethode für die meisten Auflistungen. Sie können also die gleiche Anweisung schreiben, ohne das Schlüsselwort Item angeben zu müssen.

Set firstPres = Presentations(1)

Weitere Informationen über eine bestimmte Auflistung finden Sie im Hilfethema für diese Auflistung oder für die Item-Methode der Auflistung.

Benannte Objekte

Sie können bei der Item-Methode zwar in der Regel eine Ganzzahl angeben, es empfiehlt sich jedoch, ein Objekt über den Namen zurückzugeben. Viele Objekte erhalten automatisch generierte Namen, wenn sie erstellt werden. So wird z. B. die erste Folie, die Sie erstellen, automatisch mit "Slide1" benannt. Wenn es sich bei den ersten beiden erstellten Formen um ein Rechteck und ein Oval handelt, so sind deren Standardnamen "Rectangle 1" und "Oval 2". Sie können ein Objekt umbenennen, um es dadurch besser zu kennzeichnen. Dies geschieht in der Regel, indem die Name-Eigenschaft des Objekts festgelegt wird. Im folgenden Beispiel wird eine Folie beim Hinzufügen umbenannt. Sie können diesen Namen anstelle der Indexnummer verwenden, um sich auf die Folie zu beziehen.

ActivePresentation.Slides.Add(1, 1).Name = "Home Page Slide"
With ActivePresentation.Slides("Home Page Slide")
    .FollowMasterBackground = False
    .Background.Fill.PresetGradient _
        msoGradientDiagonalDown, 1, msoGradientBrass
End With

Vordefinierte Indexwerte

Einige Auflistungen haben vordefinierte Indexwerte, mit denen Sie einzelne Objekte zurückgeben können. Jeder vordefinierte Indexwert wird durch eine Konstante dargestellt. So können Sie z. B. eine PpTextStyleType-Konstante mit der Item-Methode der TextStyles-Auflistung angeben, um ein einzelnes Textformat zurückzugeben.

Im folgenden Beispiel werden die Ränder für die Fläche von Folien in der aktiven Präsentation festgelegt.

With ActivePresentation.SlideMaster _
        .TextStyles(ppBodyStyle).TextFrame
    .MarginBottom = 50
    .MarginLeft = 50
    .MarginRight = 50
    .MarginTop = 50
End With


Verwenden der Werte von Steuerelementen, während der Code läuft

Einige Steuerelement-Eigenschaften können festgelegt und zurückgegeben werden, während der Visual Basic-Code läuft. Im folgenden Beispiel wird die Text-Eigenschaft eines Textfeldes auf "Hello" gesetzt.

TextBox1.Text = "Hello"

Die Daten, die ein Benutzer in einem Formular eingegeben hat, gehen verloren, sobald das Formular geschlossen wird. Wenn Sie die Werte der Steuerelemente auf einem Formular zurückgeben, nachdem das Formular entladen wurde, werden nicht die vom Benutzer eingegebenen Werte, sondern die Startwerte für die Steuerelemente zurückgegeben.

Wenn Sie die Daten speichern möchten, die in ein Formular eingegeben wurden, können Sie die Informationen in Modulvariablen speichern, während das Formular geöffnet ist. Im folgenden Beispiel wird ein Formular geöffnet, und die Formulardaten werden gespeichert.

'Code in module to declare public variables
Public strRegion As String
Public intSalesPersonID As Integer
Public blnCancelled As Boolean

'Code in form
Private Sub cmdCancel_Click()
    Module1.blnCancelled = True
    Unload Me
End Sub

Private Sub cmdOK_Click()
    'Save data
    intSalesPersonID = txtSalesPersonID.Text
    strRegion = lstRegions.List(lstRegions.ListIndex)
    Module1.blnCancelled = False
    Unload Me
End Sub

Private Sub UserForm_Initialize()
    Module1.blnCancelled = True
End Sub

'Code in module to display form
Sub LaunchSalesPersonForm()
    frmSalesPeople.Show
    If blnCancelled = True Then
        MsgBox "Operation Cancelled!", vbExclamation
    Else
        MsgBox "The Salesperson's ID is: " &
            intSalesPersonID & _
            "The Region is: " & strRegion
    End If
End Sub


 Setzen der Eigenschaften von Steuerelementen

Setzen der Eigenschaften von Steuerelementen

Sie können einige Steuerelement-Eigenschaften beim Erstellen eines Makros (bevor ein Makro ausgeführt wird) setzen. Klicken Sie mit der rechten Maustaste im Entwurfsmodus auf ein Steuerelement, und klicken Sie auf Eigenschaften, um das Eigenschaftenfenster zu öffnen. Die Namen der Eigenschaften werden in der linken, die Werte in der rechten Spalte des Fensters angezeigt. Sie können den Wert einer Eigenschaft festlegen, indem Sie den neuen Wert rechts neben dem Namen der Eigenschaft eingeben.


ActiveX-Steuerelemente

Weitere Informationen über ein bestimmtes Steuerelement erhalten Sie, wenn Sie ein Objekt aus der folgenden Liste markieren. Informationen über Ereignisse erhalten Sie, wenn Sie ein Steuerelement auswählen und auf "Ereignisse" oben im Thema klicken.

CheckBox

ComboBox

CommandButton

Frame

Image

Label

ListBox

 MultiPage

OptionButton

ScrollBar

SpinButton

TabStrip

TextBox

ToggleButton


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Hilfe zu Microsoft Office Visual Basic nicht gefunden, nicht installiert oder gelöscht wurde.

So installieren Sie die Hilfe zu Microsoft Office Visual Basic

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Hilfe zu Microsoft PowerPoint nicht gefunden, nicht installiert oder gelöscht wurde.

So installieren Sie die Hilfe zu Microsoft PowerPoint

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Microsoft PowerPoint für Windows in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Hilfe zu Visual Basic für Applikationen nicht gefunden, nicht installiert oder gelöscht wurde.

So installieren Sie die Hilfe zu Visual Basic für Applikationen

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Verborgene Eigenschaften

In Microsoft PowerPoint 2000 ist die Visible-Eigenschaft des BulletFormat-Objekts verborgen. Die Funktion dieser Eigenschaft wurde von der Type-Eigenschaft übernommen. Die verborgene Eigenschaft wird nur noch aus Gründen der Kompatibilität mit älteren Versionen unterstützt. Verwenden Sie für neuen Code die Ersatzfunktion von Microsoft PowerPoint 2000.


 Sprachspezifische Eigenschaften und Methoden

Sprachspezifische Eigenschaften und Methoden

Das Visual Basic-Objektmodell von Microsoft PowerPoint 2000 enthält neue sprachspezifische Schlüsselwörter für die Verwendung mit asiatischen Sprachen und Sprachen mit Schreibrichtung von rechts nach links. Die Verfügbarkeit dieser sprachspezifischen Schlüsselwörter richtet sich nach der ausgewählten oder installierten Sprachunterstützung. Weitere Einzelheiten über sprachspezifische Produkteigenschaften erhalten Sie unter Sprachspezifische Informationen.

Sprachspezifische Eigenschaften und Methoden

Eigenschaften und Methoden, die nur für asiatische Sprachen oder Sprachen mit Schreibrichtung von rechts nach links verfügbar sind, werden in der folgenden Tabelle aufgeführt:

Eigenschaft oder Methode | Objekt
AutoRotateNumbers-Eigenschaft | Font
FarEastLineBreakLanguage-Eigenschaft | Presentation
FarEastLineBreakLevel-Eigenschaft | Presentation
FarEastLineBreakControl-Eigenschaft | ParagraphFormat
HangingPunctuation-Eigenschaft | ParagraphFormat
LayoutDirection-Eigenschaft | Presentation
LtrRun-Methode | TextRange
NameAscii-Eigenschaft | Font
NameFarEast-Eigenschaft | Font
NameOther-Eigenschaft | Font
NoLineBreakAfter-Eigenschaft | Presentation
NoLineBreakBefore-Eigenschaft | Presentation
RtlRun-Methode | TextRange
TableDirection-Eigenschaft | Table
TextDirection-Eigenschaft | ParagraphFormat

Sprachspezifische Argumente

Eigenschaften und Methoden, die für alle Sprachen verfügbar sind, jedoch mindestens ein sprachspezifisches Argument aufweisen, sind in der folgenden Tabelle aufgeführt:

Eigenschaft oder Methode | Objekt
AddLabel-Methode | Shapes
AddTextBox-Methode | Shapes
Orientation-Eigenschaft | TextFrame
SaveAs-Methode | Presentation

Anmerkung Um die sprachspezifischen Funktionen in Microsoft PowerPoint zu aktivieren, müssen Sie mit einer 32-Bit-Version des Microsoft Windows-Betriebssystems arbeiten, die eine bestimmte Sprache unterstützt. Die arabische Version von Windows 95 unterstützt beispielsweise rechts-nach-links-Schreibung. Informieren Sie sich über die Anforderungen für Sprachen mit Schreibrichtung von rechts nach links oder für Sprachen des asiatischen Raumes.


Neue Ereignisse

In der folgenden alphabetischen Liste finden Sie eine Aufstellung der zum Application-Objekt in Microsoft PowerPoint 2000 hinzugefügten Ereignisse.

NewPresentation

PresentationClose

PresentationNewSlide

PresentationOpen

PresentationPrint

PresentationSave

SlideShowBegin

SlideShowEnd

SlideShowNextBuild

SlideShowNextSlide

WindowActivate

WindowBeforeDoubleClick

WindowBeforeRightClick

WindowDeactivate

WindowSelectionChange


Neue Methoden (alphabetisch)

In der folgenden alphabetisch sortierten Tabelle finden Sie eine Aufstellung der in Microsoft PowerPoint 2000 zu vorhandenen Objekten hinzugefügten Methoden:

Neue Methode | Objekt
AddTable | Shapes
CreateNewDocument | Hyperlink
Delete | Hyperlink
Follow | Hyperlink
Item | Borders
LtrRun | TextRange
Picture | BulletFormat
PointsToScreenPixelsX | DocumentWindow
PointsToScreenPixelsY | DocumentWindow
RangeFromPoint | DocumentWindow
ReloadAs | Presentation
RtlRun | TextRange
ScrollIntoView | DocumentWindow
WebPagePreview | Presentation


Neue Eigenschaften (alphabetisch)

In der folgenden, alphabetisch sortierten Tabelle finden Sie eine Aufstellung der in Microsoft PowerPoint 2000 zu vorhandenen Objekten hinzugefügten Eigenschaften:

Neue Eigenschaft | Objekt(e)
ActivePane | DocumentWindow
AlternativeText | Shape, ShapeRange
AnswerWizard | Application
Application | Borders
COMAddIns | Application
CommandBars | Presentation
DefaultLanguageID | Presentation
DefaultWebOptions | Application
EmailSubject | Hyperlink
EnvelopeVisible | Presentation
FarEastLineBreakLanguage | Presentation
FeatureInstall | Application
HasTable | Shape, ShapeRange
HTMLProject | Presentation
LanguageID | TextRange
LanguageSettings | Application
NameComplexScript | Font
Number | BulletFormat
Panes | DocumentWindow
Parent | Borders
ProductCode | Application
PublishObjects | Presentation
Script | Shape, ShapeRange
Scripts | Master, Slide, SlideRange
ScreenTip | Hyperlink
ShowandReturn | ActionSettings, Hyperlink
ShowWindowsInTaskbar | DocumentWindow
SplitHorizontal | DocumentWindow
SplitVertical | DocumentWindow
StartValue | BulletFormat
Style | BulletFormat
Table | Shape
TextToDisplay | Hyperlink
Type | BulletFormat
VBASigned | Presentation
WebOptions | Presentation


Add-Methode (ColorSchemes-Objekt, (Auflistung))

Fügt der Auflistung verfügbarer Skalen eine Farbskala hinzu. Gibt ein ColorScheme-Objekt zurück, das die hinzugefügte Farbskala darstellt.

Syntax

Ausdruck.Add(ColorScheme)

Ausdruck Erforderlich. Ein Ausdruck, der ein ColorSchemes-Objekt zurückgibt.

ColorScheme ColorScheme-Objekt optional. Die Farbskala, die hinzugefügt werden soll. Dies kann ein ColorScheme-Objekt jeder Folie oder jedes Masters sein, oder ein Element der ColorSchemes-Auflistung jeder geöffneten Präsentation. Wird dieses Argument ausgelassen, wird das erste ColorScheme-Objekt (die erste Standard-Farbskala) aus der ColorSchemes-Auflistung der angegebenen Präsentation verwendet.

Anmerkungen

Die neue Farbskala basiert auf den verwendeten Farben der angegebenen Folie oder des Masters, oder auf den Farben der angegebenen Farbskala einer geöffneten Präsentation.

Die ColorSchemes-Auflistung kann bis zu 16 Farbskalen enthalten. Um eine neue Farbskala hinzuzufügen, wenn die ColorSchemes-Auflistung bereits 16 Farbskalen enthält, müssen Sie eine bestehende Farbskala mit der Delete-Methode entfernen.

Zu beachten ist, dass PowerPoint zwar automatisch überprüft, ob es sich bei einer Farbskala um ein Duplikat handelt, bevor es durch die Benutzeroberfläche hinzugefügt wird, es aber nicht überprüft, bevor eine Farbskala durch eine Visual Basic-Prozedur hinzugefügt wird. Ihre Prozedur muss selbst Überprüfungen durchführen, um zu vermeiden, dass redundante Farbskalen hinzugefügt werden.


Beispiel zur Add-Methode (ColorSchemes-Objekt (Auflistung))

In diesem Beispiel wird in der aktiven Präsentation der Auflistung der Standard-Farbskalen eine neue Farbskala hinzugefügt. Die neue Farbskala basiert auf den verwendeten Farben der Folie 2 in der aktiven Präsentation.

With ActivePresentation
    Set newClrScheme = .Slides(2).ColorScheme
    .ColorSchemes.Add newClrScheme
End With


Add-Methode (Columns-Objekt (Auflistung))

Fügt eine neue Spalte in einer vorhandenen Tabelle ein.

Syntax

Ausdruck.Add(BeforeColumn)

Ausdruck Erforderlich. Ein Ausdruck, der ein Column-Objekt zurückgibt.

BeforeColumn Optional Long. Die Indexnummer für die Tabellenspalte, vor der die neue Spalte eingefügt wird. Dieses Argument muss eine Ganzzahl zwischen 1 und der Anzahl der Spalten in der Tabelle sein. Wenn dieser Parameter nicht angegeben wird, wird die neue Spalte am Ende der Tabelle eingefügt.


Beispiel zur Add-Methode (Columns-Objekt (Auflistung))

In diesem Beispiel wird vor die Spalte 1 eine neue Spalte in der Tabelle eingefügt, die der Form 5 auf Folie 2 entspricht. Die Breite der neuen Spalte wird dann auf 72 Punkt (1 Zoll, ungefähr 2,54 cm) gesetzt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Columns.Add(1).Width = 72
End With


 Add-Methode (ExtraColors-Objekt)

Add-Methode (ExtraColors-Objekt)

Fügt den Extra-Farben, die der Präsentation zur Verfügung stehen, eine Farbe hinzu, wenn die Farbe nicht bereits hinzugefügt wurde.

Syntax

Ausdruck.Add(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein ExtraColors-Objekt zurückgibt.

Type Long erforderlich. Der Rot-Grün-Blau-Wert der Farbe, die hinzugefügt werden soll.

Anmerkungen

Die ExtraColors-Objekt kann maximal acht Farben enthalten (einschließlich der Farben, die vom Benutzer hinzugefügt wurden).


Beispiel zur Add-Methode (ExtraColors-Objekt)

In diesem Beispiel wird der aktiven Präsentation eine Extra-Farbe hinzugefügt (vorausgesetzt, diese Farbe wurde nicht zuvor bereits hinzugefügt).

ActivePresentation.ExtraColors.Add RGB(69, 32, 155)


Add-Methode (NamedSlideShows-Objekt (Auflistung))

Erstellt eine benannte Bildschirmpräsentation und fügt diese der Auflistung der benannten Bildschirmpräsentationen in der angegebenen Präsentation hinzu. Gibt ein NamedSlideShow-Objekt zurück, das die neue benannte Bildschirmpräsentation darstellt.

Syntax

Ausdruck.Add(Name, SafeArrayOfSlideIDs)

Ausdruck Erforderlich. Ein Ausdruck, der ein NamedSlideShows-Objekt zurückgibt.

Name String erforderlich. Der Name der Bildschirmpräsentation.

SafeArrayOfSlideIDs Variant erforderlich. Enthält die eindeutigen Folien-IDs der Folien, die in einer Bildschirmpräsentation angezeigt werden.

Anmerkungen

Wenn Sie eine benannte Bildschirmpräsentation hinzufügen, ist der angegebene Name das Argument für die Run-Methode, die die benannte Bildschirmpräsentation ausführt.


Beispiel zur Add-Methode (NamedSlideShows-Objekt (Auflistung))

Dieses Beispiel fügt der aktiven Präsentation die Bildschirmpräsentation "Quick Show" hinzu, die die Folien 2, 7 und 9 enthält. Anschließend wird diese Bildschirmpräsentation ausgeführt.

Dim qSlides(1 To 3) As Long
With ActivePresentation
    With .Slides
        qSlides(1) = .Item(2).SlideID
        qSlides(2) = .Item(7).SlideID
        qSlides(3) = .Item(9).SlideID
    End With
    With .SlideShowSettings
        .NamedSlideShows.Add "Quick Show", qSlides
        .RangeType = ppShowNamedSlideShow
        .SlideShowName = "Quick Show"
        .Run
    End With
End With


Add-Methode (Presentations-Auflistung)

Erstellt eine Präsentation. Gibt ein Presentation-Objekt zurück, das die neue Präsentation darstellt.

Syntax

Ausdruck.Add(WithWindow)

Ausdruck Erforderlich. Ein Ausdruck, der eine Presentations-Auflistung zurückgibt.

WithWindow Long optional. True, wenn die Präsentation in einem sichtbaren Fenster erstellt werden soll. Gilt für dieses Argument der Wert False, ist die neue Präsentation nicht sichtbar. Der Standardwert ist True.


Beispiel zur Add-Methode (Presentations Auflistung)

In diesem Beispiel wird eine Präsentation erstellt und dieser eine Folie hinzugefügt. Anschließend wird die Präsentation gespeichert.

With Presentations.Add
    .Slides.Add 1, ppLayoutTitle
    .SaveAs "Sample"
End With


Add-Methode (PrintRanges-Objekt (Auflistung))

Fügt der PrintRanges-Auflistung einen Druckbereich hinzu. Gibt ein PrintRange-Objekt zurück, das eine aufeinander folgende Serie von Folien darstellt, die gedruckt werden sollen.

Syntax

Ausdruck.Add(Start, End)

Ausdruck Erforderlich. Ein Ausdruck, der ein PrintRange-Objekt zurückgibt.

Start Long erforderlich. Die erste Folie im Folienbereich, der gedruckt werden soll. Muss kleiner oder gleich dem Wert des End-Arguments sein.

End Long erforderlich. Die letzte Folie im Folienbereich, der gedruckt werden soll. Muss kleiner oder gleich dem Wert des Start-Arguments sein.

Anmerkungen

Für die RangeType-Eigenschaft muss ppPrintSlideRange gelten, um die Bereiche in der PrintRanges-Auflistung zuweisen zu können.

Wenn Sie keine vollständige Präsentation drucken möchten, fügen Sie Druckbereiche für alle Folien hinzu, die gedruckt werden sollen. Für jede aufeinander folgende Serie von Folien muss ein eigener Druckbereich angegeben werden. Möchten Sie z. B. Folie 1, die Folien 3 bis 5 sowie die Folien 8 und 9 in einer angegebenen Präsentation drucken, müssen drei PrintRange-Objekte für die Darstellung folgender Folien erstellt werden: eines für Folie 1, eines für die Folien 3 bis 5 sowie eines für die Folien 8 und 9. Weitere Informationen finden Sie im Beispiel für diese Eigenschaft.

Mit der ClearAll-Methode können Sie alle zuvor definierten Druckbereiche löschen.


Beispiel zur Add-Methode (PrintRanges-Objekt (Auflistung))

Dieses Beispiel löscht alle zuvor definierten Druckbereiche. Anschließend wird Folie 1, Folie 3 bis 5 sowie Folie 8 und 9 der aktiven Präsentation gedruckt.

With ActivePresentation.PrintOptions
    .RangeType = ppPrintSlideRange
    With .Ranges
        .ClearAll
        .Add 1, 1
        .Add 3, 5
        .Add 8, 9
    End With
End With
ActivePresentation.PrintOut


Add-Methode (Rows-Objekt (Auflistung))

Fügt eine neue Zeile in eine vorhandene Tabelle ein.

Syntax

Ausdruck.Add

Ausdruck Erforderlich. Ein Ausdruck, der ein Row-Objekt zurückgibt.


Beispiel zur Add-Methode (Rows-Objekt (Auflistung))

In diesem Beispiel wird eine Zeile in einer vorhandenen Tabelle erstellt und deren Höhe auf 54 Punkt (0,75 Zoll, ca. 1,9 cm) gesetzt.

With ActivePresentation.Slides(2).Shapes(5).Table
    .Rows.Add.Height = 54
End With


Add-Methode (Slides-Objekt(Auflistung))

Erstellt eine neue Folie und fügt sie der Auflistung mit den Folien der angegebenen Präsentation hinzu. Gibt ein Slide-Objekt zurück, das die neue Folie darstellt.

Syntax

Ausdruck.Add(Index, Layout)

Ausdruck Erforderlich. Ein Ausdruck, der eine Slides-Auflistung zurückgibt.

Index Long erforderlich. Gibt die Indexnummer für die neue Folie in der Slides-Auflistung an. Es kann dabei der Wert der vorhandenen Folien + 1 nicht überschritten werden.

Layout Long erforderlich. Dies kann eine der folgenden PpSlideLayout-Konstanten sein:

ppLayoutBlank

ppLayoutChart

ppLayoutChartAndText

ppLayoutClipartAndText

ppLayoutClipArtAndVerticalText

ppLayoutFourObjects

ppLayoutLargeObject

ppLayoutMediaClipAndText

ppLayoutObject

ppLayoutObjectAndText

ppLayoutObjectOverText

ppLayoutOrgchart

ppLayoutTable

ppLayoutText

 ppLayoutTextAndChart

ppLayoutTextAndClipart

ppLayoutTextAndMediaClip

ppLayoutTextAndObject

ppLayoutTextAndTwoObjects

ppLayoutTextOverObject

ppLayoutTitle

ppLayoutTitleOnly

ppLayoutTwoColumnText

ppLayoutTwoObjectsAndText

ppLayoutTwoObjectsOverText

ppLayoutVerticalText

ppLayoutVerticalTitleAndText

ppLayoutVerticalTitleAndTextOverChart

Anmerkungen

Mit der Layout-Eigenschaft können Sie das Layout einer vorhandenen Folie ändern.


Beispiel zur Add-Methode (Slides-Objekt (Auflistung))

Dieses Beispiel fügt an den Anfang der aktiven Präsentation eine Folie hinzu, die einen Platzhalter für den Titel enthält.

ActivePresentation.Slides.Add 1, ppLayoutTitleOnly

Dieses Beispiel fügt an das Ende der aktiven Präsentation eine leere Folie hinzu.

With ActivePresentation.Slides
    .Add .Count + 1, ppLayoutBlank
End With


Add-Methode (TabStops-Objekt (Auflistung))

Fügt dem Lineal einen Tabstop für den angegebenen Text hinzu. Gibt ein TabStop-Objekt zurück, das den neuen Tabstop darstellt.

Syntax

Ausdruck.Add(Type, Position)

Ausdruck Erforderlich. Ein Ausdruck, der eine TabStops-Auflistung zurückgibt.

Type Long erforderlich. Gibt an, wie der Text mit dem neuen Tabstop ausgerichtet wird. Mögliche PpTabStopType-Konstanten: ppTabStopCenter, ppTabStopDecimal, ppTabStopLeft oder ppTabStopRight.

Position Single erforderlich. Die Position des neuen Tabstops in Punkt.


Beispiel zur Add-Methode (TabStops-Objekt (Auflistung))

In diesem Beispiel wird ein linksbündiger Tabstop bei 2 Zoll (144 Punkt) für den Text von Form 2 in Folie 1 der aktiven Präsentation gesetzt.

Application.ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .Ruler.TabStops.Add ppTabStopLeft, 144


Add-Methode (Tags-Objekt)

Erstellt eine Marke für das angegebene Objekt. Wenn die Marke bereits existiert, ersetzt diese Methode den vorhandenen Wert der Marke.

Syntax

Ausdruck.Add(Name, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein Tags-Objekt zurückgibt.

Name String erforderlich. Der neue Name der Marke. Verwenden Sie "Name" als Zeichenfolge für dieses Argument, um den Wert des Namens der Marke festzulegen.

Value String erforderlich. Der neue Name der Marke.

Anmerkungen

Das Tags-Objekt enthält ein Zeichenfolgenpaar - den Namen der Marke und den Wert der Marke (für jede Marke). Mit der Add-Methode können Sie eine Marke erstellen, und mit der Name- und Value-Methode können Sie den Namen der Marke und die Wertkomponenten zurückgeben.


Beispiel zur Add-Methode (Tags-Objekt)

Dieses Beispiel fügt die Marke "Priority" ein und legt den Wert für den Namen der Marke für Folie 1 in der aktiven Präsentation fest.

With Application.ActivePresentation.Slides(1).Tags
'Sets value for name tag
    .Add "Name", "New Figures"
'Adds "Priority" tag with value "Low"
    .Add "Priority", "Low"
End With


Beispiel zur AddTitle-Methode

Dieses Beispiel stellt den Platzhalter für den Titel von Folie 1 der aktiven Präsentation wieder her, wenn dieser gelöscht wurde. Der Text des wiederhergestellten Titels lautet "Restored title".

With ActivePresentation.Slides(1)
    If .Layout <> ppLayoutBlank Then
        With .Shapes
            If Not .HasTitle Then
                .AddTitle.TextFrame.TextRange _
                    .Text = "Restored title"
            End If
        End With
    End If
End With


Beispiel zur Apply-Methode

Dieses Beispiel kopiert das Format von Form 1 in myDocument und überträgt anschließend das kopierte Format auf Form 2.

Set myDocument = ActivePresentation.Slides(1)
With myDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


Beispiel zur Clear-Methode

In diesem Beispiel werden alle Tabstops für den Text von Form 2 in Folie 1 der aktiven Präsentation gelöscht.

With Application.ActivePresentation.Slides(1).Shapes(2).TextFrame _
    .Ruler.TabStops
    For i = .Count To 1 Step -1
        .Item(i).Clear
    Next
End With


Beispiel zur Delete-Methode

In diesem Beispiel werden alle Freihand-Formen in Folie 1 der aktiven Präsentation gelöscht.

With Application.ActivePresentation.Slides(1).Shapes
    For s = .Count To 1 Step -1
        With .Item(s)
            If .Type = msoFreeform Then .Delete
        End With
    Next
End With


Beispiel zur Find-Methode

In diesem Beispiel wird in der aktiven Präsentation nach jedem Vorkommen von "CompanyX" gesucht und jede Übereinstimmung fett formatiert.

For Each sld In Application.ActivePresentation.Slides
    For Each shp In sld.Shapes
        If shp.HasTextFrame Then
            Set txtRng = shp.TextFrame.TextRange
            Set foundText = txtRng.Find(FindWhat:="CompanyX")
            Do While Not (foundText Is Nothing)
                With foundText
                    .Font.Bold = True
                    Set foundText = _
                        txtRng.Find(FindWhat:="CompanyX", _
                        After:=.Start + .Length - 1)
                End With
            Loop
        End If
    Next
Next


Beispiel zur Follow-Methode

In diesem Beispiel wird das mit dem ersten Hyperlink auf Folie 1 verbundene Dokument in einer neuen Instanz des Webbrowsers geladen.

ActivePresentation.Slides(1).Hyperlinks(1).Follow


Beispiel zur Insert-Methode

Dieses Beispiel fügt einen glatten Knoten mit einem gekrümmten Abschnitt nach Knoten 4 in Form 3 bei myDocument hinzu. Form 3 muss eine Freihandfigur mit mindestens vier Knoten sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With


Beispiel zur Range-Methode

Dieses Beispiel legt das Füllmuster für die Formen 1 und 3 von myDocument fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Range(Array(1, 3)).Fill _
    .Patterned msoPatternHorizontalBrick

Dieses Beispiel legt das Füllmuster für die Formen "Oval 4" und "Rectangle 5" auf der ersten Folie fest.

Dim x() As Variant, myRange As Object
x = Array("Oval 4", "Rectangle 5")
Set myRange = ActivePresentation.Slides(1).Shapes.Range(x)
myRange.Fill.Patterned msoPatternHorizontalBrick

Dieses Beispiel legt das Füllmuster für alle Formen der ersten Folie fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Range.Fill.Patterned msoPatternHorizontalBrick

Dieses Beispiel legt das Füllmuster für Form 1 auf der ersten Folie fest.

Set myDocument = ActivePresentation.Slides(1)
Set myRange = myDocument.Shapes.Range(1)
myRange.Fill.Patterned msoPatternHorizontalBrick

Dieses Beispiel erstellt eine Matrix mit allen AutoFormen der ersten Folie, die für die Definition des Formbereichs verwendet wird. Anschließend werden alle Formen des Bereichs horizontal verteilt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numAutoShapes = 0
        ReDim autoShpArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoAutoShape Then
                numAutoShapes = numAutoShapes + 1
                autoShpArray(numAutoShapes) = .Item(i).Name
            End If
        Next
        If numAutoShapes > 1 Then
            ReDim Preserve autoShpArray(1 To numAutoShapes)
            Set asRange = .Range(autoShpArray)
            asRange.Distribute msoDistributeHorizontally, False
        End If
    End If
End With

Dieses Beispiel legt die Titelfarbe für die Folien 1 und 3 fest.

Set mySlides = ActivePresentation.Slides.Range(Array(1, 3))
mySlides.ColorScheme.Colors(ppTitle).RGB = RGB(0, 255, 0)

Dieses Beispiel legt die Titelfarbe für die Folien "Slide6" und "Slide8" fest.

Set mySlides = ActivePresentation.Slides _
    .Range(Array("Slide6", "Slide8"))
mySlides.ColorScheme.Colors(ppTitle).RGB = RGB(0, 255, 0)

Dieses Beispiel legt die Titelfarbe für alle Folien der aktiven Präsentation fest.

Set mySlides = ActivePresentation.Slides.Range
mySlides.ColorScheme.Colors(ppTitle).RGB = RGB(255, 0, 0)

Dieses Beispiel erstellt eine Matrix, die alle Titelfolien der aktiven Präsentation enthält. Die Matrix wird für die Definition des Folienbereichs verwendet, und anschließend die Titelfarbe für alle Folien des Bereichs festgelegt.

Dim MyTitleArray() As Long
Set pSlides = ActivePresentation.Slides
ReDim MyTitleArray(1 To pSlides.Count)
For Each pSlide In pSlides
    If pSlide.Layout = ppLayoutTitle Then
        nCounter = nCounter + 1
        MyTitleArray(nCounter) = pSlide.SlideIndex
    End If
Next pSlide
ReDim Preserve MyTitleArray(1 To nCounter)

Set rngTitleSlides = ActivePresentation.Slides.Range(MyTitleArray)
rngTitleSlides.ColorScheme.Colors(ppTitle).RGB = RGB(255, 123, 99)


Beispiel zur Remove-Methode

Dieses Beispiel entfernt das Add-In "mytools" aus der Liste der verfügbaren Add-Ins.

AddIns.Remove "mytools"


Beispiel zur Run-Methode

Dieses Beispiel startet eine Bildschirmpräsentation der aktiven Präsentation in der Ansicht Ganzer Bildschirm, wobei die Tastenkombinationen deaktiviert sind.

With ActivePresentation.SlideShowSettings
    .ShowType = ppShowSpeaker
    .Run.View.AcceleratorsEnabled = False
End With

Dieses Beispiel startet die benannte Bildschirmpräsentation "Quick Show."

With ActivePresentation.SlideShowSettings
    .RangeType = ppShowNamedSlideShow
    .SlideShowName = "Quick Show"
    .Run
End With

In diesem Beispiel definiert die Prozedur Main eine Matrix und startet anschließend das Makro TestDurchlauf. Die Matrix läuft als Argument durch.

Sub Main()
    Dim x(1 To 2)
    x(1) = "hi"
    x(2) = 7
    Application.Run "TestPass", x
End Sub

Sub TestPass(x)
    MsgBox x(1)
    MsgBox x(2)
End Sub


Beispiel zur Save-Methode

In diesem Beispiel wird die aktive Präsentation gespeichert, wenn seit dem letzten Speichern Änderungen vorgenommen wurden.

With Application.ActivePresentation
    If Not .Saved And .Path <> "" Then .Save
End With


Beispiel zur Select-Methode

Dieses Beispiel markiert die Formen 1 und 3 von Folie 1 der aktiven Präsentation.

ActivePresentation.Slides(1).Shapes.Range(Array(1, 3)).Select

Dieses Beispiel fügt der vorherigen Markierung die Formen 2 und 4 von Folie 1 der aktiven Präsentation hinzu.

ActivePresentation.Slides(1).Shapes.Range(Array(2, 4)).Select False

Dieses Beispiel markiert die ersten fünf Zeichen des Titels von Folie 1 der aktiven Präsentation.

ActivePresentation.Slides(1).Shapes.Title.TextFrame _
    .TextRange.Characters(1, 5).Select

Dieses Beispiel markiert Folie 1 der aktiven Präsentation.

ActivePresentation.Slides(1).Select

In diesem Beispiel wird eine Tabelle markiert, die einer neuen Folie in einer neuen Präsentation hinzugefügt wurde. Die Tabelle umfasst drei Zeilen und drei Spalten.

With Presentations.Add.Slides
    .Add(1, ppLayoutBlank).Shapes.AddTable(3, 3).Select
End With


Beispiel zur Update-Methode

Dieses Beispiel aktualisiert alle verknüpften OLE-Objekte in der aktiven Präsentation.

For Each sld In ActivePresentation.Slides
    For Each sh In sld.Shapes
        If sh.Type = msoLinkedOLEObject Then
            sh.LinkFormat.Update
        End If
    Next
Next


Beispiel zur Action-Eigenschaft

Dieses Beispiel legt fest, dass Form 3 (ein OLE-Objekt) in Folie 1 der aktiven Präsentation wiedergegeben wird, wenn der Mauszeiger während einer Bildschirmpräsentation darauf gerichtet wird.

With ActivePresentation.Slides(1) _
    .Shapes(3).ActionSettings(ppMouseOver)
        .ActionVerb = "Play"
        .Action = ppActionOLEVerb
End With


Beispiel zur Active-Eigenschaft

Dieses Beispiel überprüft, ob sich die Präsentationsdatei "test.ppt" im aktiven Fenster befindet. Handelt es sich dabei nicht um das aktive Fenster, wird der Name der gegenwärtig aktiven Präsentation in der Variablen oldWin gespeichert und die Präsentation "test.ppt" aktiviert.

With Application.Presentations("test.ppt").Windows(1)
    If Not .Active Then
        Set oldWin = Application.ActiveWindow
        .Activate
    End If
End With


Beispiel zur Animate-Eigenschaft

Dieses Beispiel gibt an, dass der Titel auf Folie 2 der aktiven Präsentation nach dem Aufbau des Titels ausgeblendet wird. Handelt es sich bei dem Titel um die letzte oder einzige Form, die auf Folie 2 aufgebaut werden soll, wird der Text nicht ausgeblendet.

With ActivePresentation.Slides(2).Shapes.Title.AnimationSettings
    .TextLevelEffect = ppAnimateByAllLevels
    .AfterEffect = ppAfterEffectDim
    .Animate = True
End With


Beispiel zur BeginConnected-Eigenschaft

Wenn es sich bei Form 3 auf der ersten Folie der aktiven Präsentation um eine Verbindung handelt, deren Anfang mit einer Form verbunden ist, speichert dieses Beispiel die Nummer des Verbindungspunkts in der Variablen oldBeginConnSite und die Referenz zur verbundenen Form in die Objektvariable oldBeginConnShape. Anschließend wird der Anfang der Verbindung von der Form gelöst.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Connector Then
        With .ConnectorFormat
            If .BeginConnected Then
                oldBeginConnSite = .BeginConnectionSite
                Set oldBeginConnShape = .BeginConnectedShape
                .BeginDisconnect
            End If
        End With
    End If
End With


Beispiel zur Border-Eigenschaft

Dieses Beispiel fügt zu myDocument ein Oval und eine Legende hinzu, die auf das Oval deutet. Der Legendentext hat keinen Rahmen, sondern eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


Beispiel zur ColorScheme-Eigenschaft

Dieses Beispiel legt für die Folien 1 und 3 der aktiven Präsentation die Titelfarbe Grün fest.

Set mySlides = ActivePresentation.Slides.Range(Array(1, 3))
mySlides.ColorScheme.Colors(ppTitle).RGB = RGB(0, 255, 0)


Beispiel zur Color-Eigenschaft

In diesem Beispiel wird die Farbe für die Zeichen 1 bis 5 im Titel von Folie 1 festgelegt.

myRed = RGB(255, 0, 0)
Set myT = Application.ActivePresentation.Slides(1).Shapes.Title
myT.TextFrame.TextRange.Characters(1, 5).Font.Color.RGB = myRed


Beispiel zur Connector-Eigenschaft

Dieses Beispiel löscht alle Verbindungen von myDocument.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes
    For i = .Count To 1 Step -1
        With .Item(i)
            If .Connector Then .Delete
        End With
    Next
End With


Beispiel zur Drop-Eigenschaft

Dieses Beispiel ersetzt den benutzerdefinierten Bezug für Form 1 in myDocument durch einen von zwei vordefinierten Bezüge. Der vordefinierte Bezug hängt davon ab, ob der benutzerdefinierte Bezugswert größer oder kleiner als die Hälfte der Höhe des Legenden-Textfelds ist. Damit dieses Beispiel funktioniert, muss Form 1 eine Legende sein.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropCustom Then
        If .Drop < .Parent.Height / 2 Then
            .PresetDrop msoCalloutDropTop
        Else
            .PresetDrop msoCalloutDropBottom
        End If
    End If
End With


Beispiel zur EndConnected-Eigenschaft

Wenn es sich bei Form 3 in der ersten Folie der aktiven Präsentation um eine Verbindung handelt, deren Ende mit einer Form verbunden ist, speichert dieses Beispiel die Nummer des Verbindungspunkts in der Variablen oldEndConnSite und die Referenz zur verbundenen Form in die Objektvariable oldEndConnShape. Anschließend wird das Ende der Verbindung von der Form gelöst.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3)
    If .Connector Then
        With .ConnectorFormat
            If .EndConnected Then
                oldEndConnSite = .EndConnectionSite
                Set oldEndConnShape = .EndConnectedShape
                .EndDisconnect
            End If
        End With
    End If
End With


Beispiel zur End-Eigenschaft

Dieses Beispiel zeigt eine Meldung an, die die Nummer der ersten und letzten Folie für Druckbereich 1 der aktiven Präsentation angibt.

With ActivePresentation.PrintOptions.Ranges
    If .Count > 0 Then
        With .Item(1)
            MsgBox "Print range 1 starts on slide " & .Start & _
                " and ends on slide " & .End
        End With
    End If
End With


Beispiel zur ExtrusionColor-Eigenschaft

In diesem Beispiel wird dem Element myDocument ein Oval hinzugefügt und anschließend festgelegt, dass das Oval auf eine Tiefe von 50 Punkt projiziert wird und die Projektion die Farbe Purpurrot erhält.

Set myDocument = ActivePresentation.Slides(1)
Set myShape = myDocument.Shapes _
    .AddShape(msoShapeOval, 90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    'RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With


Beispiel zur Fonts-Eigenschaft

In diesem Beispiel wird die Schriftart Times New Roman durch die Schriftart Courier in der aktiven Präsentation ersetzt.

Application.ActivePresentation.Fonts _
    .Replace "Times New Roman", "Courier"

In diesem Beispiel wird die Weboption für die Standardfestbreitenschrift, die mit der Zeichensatzkonstanten msoCharacterSetEnglishWesternEuropeanOtherLatinScript festgelegt wird, auf Courier New 10 Punkt gesetzt.

With Application.DefaultWebOptions _
    .Fonts(msoCharacterSetEnglishWesternEuropeanOtherLatinScript)
        .FixedWidthFont = "Courier New"
        .FixedWidthFontSize = 10
End With


Beispiel zur Font-Eigenschaft

Dieses Beispiel legt die Formatierung für den Text in Form 1 in Folie 1 der aktiven Präsentation fest.

With ActivePresentation.Slides(1).Shapes(1)
    With .TextFrame.TextRange.Font
        .Size = 48
        .Name = "Palatino"
        .Bold = True
        .Color.RGB = RGB(255, 127, 255)
    End With
End With

Dieses Beispiel legt die Farbe und den Namen der Schriftart für Aufzählungszeichen in Form 2 in Folie 1 fest.

With ActivePresentation.Slides(1).Shapes(2)
    With .TextFrame.TextRange.ParagraphFormat.Bullet
        .Visible = True
        With .Font
            .Name = "Palatino"
            .Color.RGB = RGB(0, 0, 255)
        End With
    End With
End With


Beispiel zur HasText-Eigenschaft

Wenn Form 2 in myDocument Text enthält, wird durch dieses Beispiel die Größe der Form dem Text angepasst.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(2).TextFrame
    If .HasText Then .AutoSize = ppAutoSizeShapeToFitText
End With


Beispiel zur HasTitle-Eigenschaft

Dieses Beispiel stellt den Platzhalter für den Titel von Folie 1 der aktiven Präsentation wieder her, wenn dieser gelöscht wurde. Der Text des wiederhergestellten Titels lautet "Wiederhergestellter Titel".

With ActivePresentation.Slides(1)
    If .Layout <> ppLayoutBlank Then
        With .Shapes
            If Not .HasTitle Then
                .AddTitle.TextFrame.TextRange _
                    .Text = "Restored title"
            End If
        End With
    End If
End With


Beispiel zur Header-Eigenschaft

In diesem Beispiel wird der Kopfzeilentext für den Handzettelmaster der aktiven Präsentation festgelegt. Dieser Text erscheint oben links auf der Seite, wenn Sie Ihre Präsentation als Gliederung oder Handzettel drucken.

Set myHandHF = Application.ActivePresentation.HandoutMaster _
    .HeadersFooters
myHandHF.Header.Text = "Third Quarter Report"


Beispiel zur Hyperlink-Eigenschaft

Dieses Beispiel legt fest, dass Form 1 von Folie 1 der aktiven Präsentation zur Microsoft Website springt, sobald Sie auf die Form während einer Bildschirmpräsentation klicken.

With ActivePresentation.Slides(1).Shapes(1) _
        .ActionSettings(ppMouseClick)
    .Action = ppActionHyperlink
    .Hyperlink.Address = "http://www.microsoft.com/"
End With


Beispiel zur Layout-Eigenschaft

Dieses Beispiel ändert das Layout von Folie 1 der aktiven Präsentation so, dass Titel und Untertitel einbezogen werden, wenn ursprünglich nur der Titel existiert.

With ActivePresentation.Slides(1)
    If .Layout = ppLayoutTitleOnly Then
        .Layout = ppLayoutTitle
    End If
End With


Beispiel zur Left-Eigenschaft

Dieses Beispiel ordnet die Fenster 1 und 2 horizontal an. Dies bedeutet, dass jedes Fenster die Hälfte der verfügbaren vertikalen sowie die gesamte verfügbare horizontale Fläche des Clientbereichs des Anwendungsfensters belegt. Damit dieses Beispiel funktioniert, dürfen nur zwei Dokumentfenster geöffnet sein.

Windows.Arrange ppArrangeTiled
ah = Windows(1).Height                      ' available height
aw = Windows(1).Width + Windows(2).Width    ' available width
With Windows(1)
    .Width = aw
    .Height = ah / 2
    .Left = 0
End With
With Windows(2)
    .Width = aw
    .Height = ah / 2
    .Top = ah / 2
    .Left = 0
End With


Beispiel zur Line-Eigenschaft

Dieses Beispiel fügt zu myDocument eine blau gestrichelte Linie hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With

Dieses Beispiel fügt der ersten Folie ein Kreuz hinzu und legt anschließend für dessen Rahmen eine Stärke von 8 Punkt und die Farbe Rot fest.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes.AddShape(msoShapeCross, 10, 10, 50, 70).Line
    .Weight = 8
    .ForeColor.RGB = RGB(255, 0, 0)
End With


Beispiel zur Name-Eigenschaft

Dieses Beispiel legt den Namen "big triangle" für Objekt 2 von Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1).Shapes(2).Name = "big triangle"

Dieses Beispiel legt die Füllfarbe für die Form "big triangle" von Folie 1 in der aktiven Präsentation fest.

ActivePresentation.Slides(1) _
    .Shapes("big triangle").Fill.ForeColor.RGB = RGB(0, 0, 255)


Beispiel zur Number-Eigenschaft

In diesem Beispiel wird die Nummer des Aufzählungszeichens von Absatz 1 im ausgewählten Textbereich als Variable myParnum zurückgegeben.

With ActiveWindow.Selection
    If .Type = ppSelectionTextRange Then
        With .TextRange.Paragraphs(1).ParagraphFormat.Bullet
            If .Type = ppBulletNumbered Then
                myParnum = .Number
            End If
        End With
    End If
End With


Beispiel zur Object-Eigenschaft

Dieses Beispiel zeigt den Typ des Objekts an, der in Form 1 von Folie 1 in der aktiven Präsentation enthalten ist. Form 1 muss ein OLE-Objekt enthalten.

MsgBox TypeName(ActivePresentation.Slides(1) _
    .Shapes(1).OLEFormat.Object)

Dieses Beispiel zeigt den Namen der Anwendung an, in der jedes eingebettete OLE-Objekt von Folie 1 in der aktiven Präsentation erstellt wurde.

For Each s In ActivePresentation.Slides(1).Shapes
    If s.Type = msoEmbeddedOLEObject Then
        MsgBox s.OLEFormat.Object.Application.Name
    End If
Next

Dieses Beispiel fügt Text zu Zelle A1 von Tabellenblatt 1 im Microsoft Excel Arbeitsmappe hinzu, die in Form 3 von Folie 1 in der aktiven Präsentation enthalten ist.

With ActivePresentation.Slides(1).Shapes(3)
    .OLEFormat.Object.Worksheets(1).Range("A1").Value = "New text"
End With


Beispiel zur Presentation-Eigenschaft

Dieses Beispiel setzt die Foliennummerierung für die Präsentation von Fenster 1 in die Foliennummerierung für die Präsentation von Fenster 2 fort.

firstPresSlides = Windows(1).Presentation.Slides.Count
Windows(2).Presentation.PageSetup _
    .FirstSlideNumber = firstPresSlides + 1


Beispiel zur Ranges-Eigenschaft

Dieses Beispiel druckt Folie 1, Folie 3 bis 5 sowie Folie 8 und 9 der aktiven Präsentation.

With ActivePresentation
    With .PrintOptions
        .RangeType = ppPrintSlideRange
        With .Ranges
            .Add 1, 1
            .Add 3, 5
            .Add 8, 9
        End With
    End With
    .PrintOut
End With


Beispiel zur Script-Eigenschaft

In diesem Beispiel wird die Skriptsprache des Skriptanchors (Form 8 auf Folie 1) auf Microsoft Visual Basic Scripting Edition (VBScript) eingestellt.

With ActivePresentation.Slides(1).Shapes(8)
    .Script.Language = msoScriptLanguageVisualBasic
End With


Beispiel zur Shape-Eigenschaft

In diesem Beispiel wird eine Tabelle mit drei Zeilen und drei Spalten in einer neuen Präsentation erstellt und ein vierzackiger Stern in die erste Zelle der Tabelle eingefügt.

With Presentations.Add
    With .Slides.Add(1, ppLayoutBlank)
        .Shapes.AddTable(3, 3).Select
        .Shapes(1).Table.Cell(1, 1).Shape _
            .AutoShapeType = msoShape4pointStar
    End With
End With


Beispiel zur SlideID-Eigenschaft

Dieses Beispiel zeigt, wie die eindeutige ID-Nummer für ein Slide-Objekt abgerufen und anschließend verwendet werden muss, um das Slide-Objekt von der Slides-Auflistung zurückzugeben.

Set gslides = ActivePresentation.Slides

'Get slide ID
graphSlideID = gslides.Add(2, ppLayoutChart).SlideID
gslides.FindBySlideID(graphSlideID) _
    .SlideShowTransition.EntryEffect = _
    ppEffectCoverLeft      'Use ID to return specific slide


Beispiel zur SlideShowWindow-Eigenschaft

Das folgende Beispiel zeigt die Click-Ereignisprozeduren der Schaltflächen "cmdBack" und "cmdForward". Wenn Sie dem Folienmaster diese Schaltflächen hinzufügen und ihnen diese Ereignisprozeduren zuweisen, verfügen alle auf dem Master basierenden Folien (die so eingestellt sein müssen, dass Hintergrundbilder aus dem Master angezeigt werden) über diese während einer Bildschirmpräsentation aktivierten Navigationsschaltflächen. Das Me-Schlüsselwort gibt das Master-Objekt zurück, das den Folienmaster mit dem Steuerelement darstellt. Wenn sich das Steuerelement auf einer einzelnen Folie befindet, gibt das Me-Schlüsselwort innerhalb einer Ereignisprozedur für dieses Steuerelement ein Slide-Objekt zurück.

Private Sub cmdBack_Click()
    Me.Parent.SlideShowWindow.View.Previous
End Sub

Private Sub cmdForward_Click()
    Me.Parent.SlideShowWindow.View.Next
End Sub


Beispiel zur Slides-Eigenschaft

In diesem Beispiel wird der aktiven Präsentation eine Folie hinzugefügt.

Application.ActivePresentation.Slides.Add 1, ppLayoutTitle


Beispiel zur Slide-Eigenschaft

In diesem Beispiel wird eine Kopie der derzeit in Bildschirmpräsentationsfenster 1 angezeigten Folie in der Zwischenablage abgelegt.

SlideShowWindows(1).View.Slide.Copy

In diesem Beispiel wird der Name der derzeit in Bildschirmpräsentationsfenster 1 laufenden Präsentation angezeigt.

MsgBox SlideShowWindows(1).View.Slide.Parent.Name


Beispiel zur Start-Eigenschaft

Dieses Beispiel zeigt eine Meldung an, die die Nummer der ersten und letzten Folie für Druckbereich 1 der aktiven Präsentation angibt.

With ActivePresentation.PrintOptions.Ranges
    If .Count > 0 Then
        With .Item(1)
            MsgBox "Print range 1 starts on slide " & .Start & _
                " and ends on slide " & .End
        End With
    End If
End With


Beispiel zur Table-Eigenschaft

In diesem Beispiel wird die Breite der ersten Spalte der Tabelle in Form 5 auf der zweiten Folie auf 80 Punkt festgelegt.

ActivePresentation.Slides(2).Shapes(5).Table _
    .Columns(1).Width = 80


Beispiel zur Text-Eigenschaft

In diesem Beispiel werden der Text und der Schriftschnitt für den Titel von Folie 1 in der aktiven Präsentation festgelegt.

Set myPres = Application.ActivePresentation
With myPres.Slides(1).Shapes.Title.TextFrame.TextRange
    .Text = "Welcome!"
    .Font.Italic = True
End With


Beispiel zur Title-Eigenschaft

Dieses Beispiel legt den Titeltext in myDocument fest.

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.Title.TextFrame.TextRange.Text = "Welcome!"


Beispiel zur Transparency-Eigenschaft

Dieses Beispiel legt den Schatten für Form 3 in myDocument als halbtransparent Rot fest. Wenn dieser Form noch kein Schatten zugewiesen wurde, fügt dieses Beispiel einen hinzu.

Set myDocument = ActivePresentation.Slides(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .ForeColor.RGB = RGB(255, 0, 0)
    .Transparency = 0.5
End With


Beispiel zur View-Eigenschaft

In diesem Beispiel wird mit Hilfe der View-Eigenschaft die aktuelle Bildschirmpräsentation beendet, für das aktive Fenster der Modus Folienansicht festgelegt und anschließend Folie 3 angezeigt.

Application.SlideShowWindows(1).View.Exit
With Application.ActiveWindow
    .ViewType = ppViewSlide
    .View.GotoSlide 3
End With


Beispiel zur Windows-Eigenschaft

In diesem Beispiel werden alle Fenster mit Ausnahme des aktiven Fensters geschlossen.

With Application.Windows
    For i = .Count To 2 Step -1
        .Item(i).Close
    Next
End With


Beispiel zur Zoom-Eigenschaft

Im folgenden Beispiel wird die Zoomeinstellung für die Ansicht in Dokumentfenster 1 auf 30 Prozent festgelegt.

Windows(1).View.Zoom = 30


Microsoft PowerPoint-Objekte (Presentation)

Pfeil nach oben

Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern.


Microsoft PowerPoint-Objekte (Shape)

Pfeil nach oben

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt